EPP1xxx - EtherCAT P Box modules with digital inputs
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
1.2
▪
EPP1816-0003 added
▪
Assignment of the Working Counter for EPP1258 added
▪
Structure update
1.1
▪
Modules added: EPP1004, EPP1008-0022, EPP1111, EPP1258, EPP1518, EPP1809, EPP1819
1.0.3
▪
EtherCAT P - Calculating cable length, voltage and current added
▪
Cabling updated
▪
Additional checks added
1.0.2
▪
Signal connection updated
1.0.1
▪
EtherCAT P connection updated
1.0.0
▪
First release
0.5
▪
First preliminary versions
Firmware and hardware versions
This documentation refers to the firmware and hardware version that was applicable at the time the documentation was written.
The module features are continuously improved and developed further. Modules having earlier production statuses cannot have the same properties as modules with the latest status. However, existing properties are retained and are not changed, so that older modules can always be replaced with new ones.
The firmware and hardware version (delivery state) can be found in the batch number (D-number) printed on the side of the EtherCAT Box.
Syntax of the batch number (D-number)
D: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with D no. 29 10 02 01:
29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01
Further information on this topic: Version identification of EtherCAT devices.


Product group: EtherCAT P Box modules

Product group: EtherCAT P Box modules
Product group: EtherCAT P Box modules
EtherCAT P
EtherCAT P supplements the EtherCAT technology with a process in which communication and supply voltages are transmitted on a common line. All EtherCAT properties are retained with this process.
Two supply voltages are transmitted per EtherCAT P line. The supply voltages are electrically isolated from each other and can therefore be switched individually. The nominal supply voltage for both is 24 VDC.
EtherCAT P uses the same cable structure as EtherCAT: a 4-core Ethernet cable with M8 connectors. The connectors are mechanically coded so that EtherCAT connectors and EtherCAT P connectors cannot be interchanged.
EtherCAT P Box modules
EtherCAT P Box modules are EtherCAT P slaves with IP67 protection. They are designed for operation in wet, dirty or dusty industrial environments.
EtherCAT P Einführung
EtherCAT P
EtherCAT basics
A detailed description of the EtherCAT system can be found in the EtherCAT system documentation.


Product overview

Product overview
Product overview
Additional information
•
Module overview
•
EPP1004-0061
•
EPP10x8-0001
•
EPP10x8-0002
•
EPP1008-0022
•
EPP1258-0001
•
EPP1258-0002
•
EPP18x9-0021
•
EPP18x9-0022
•
EPP1816-0003
•
EPP1816-0008
•
EPP1816-3008


Module overview

Product overview [image] Module overview
Module overview
Digital input modules
Module | Signal connection | Number of inputs | Input filter | Special features
EPP1004-0061 | 4 x M8 | 4 | 3.0 ms | -
EPP1008-0001 | 8 x M8 | 8 | 3.0 ms | -
EPP1008-0002 | 4 x M12 | 8 | 3.0 ms | -
EPP1008-0022 | 8 x M12 | 8 | 3.0 ms | -
EPP1018-0001 | 8 x M8 | 8 | 10 µs | -
EPP1018-0002 | 4 x M12 | 8 | 10 µs | -
EPP1258-0001 | 8 x M8 | 8 | 10 µs 1) | Two timestamp inputs
EPP1258-0002 | 4 x M12 | 8 | 10 µs 1) | Two timestamp inputs
EPP1809-0021 | 16 x M8 | 16 | 3.0 ms | -
EPP1809-0022 | 8 x M12 | 16 | 3.0 ms | -
EPP1816-0003 | 2 x ZS2001 | 16 | 10 µs | Female headers with spring connection
EPP1816-0008 | 1 x D-sub 25 | 16 | 10 µs | -
EPP1816-3008 | 1 x D-sub 25 | 16 | 10 µs | Acceleration sensors, undervoltage detection
EPP1819-0021 | 16 x M8 | 16 | 10 µs | -
EPP1819-0022 | 8 x M12 | 16 | 10 µs | -
1) The two timestamp inputs have no input filter.


EPP1004-0061

Product overview [image] EPP1004-0061
EPP1004-0061
Additional information
•
Introduction
•
Technical data
•
Process image
•
Scope of supply


Introduction

Product overview [image] EPP1004-0061 [image] Introduction
Introduction
EPP1004-0061
4-channel digital input 24 V DC, 3.0 ms
The EPP1004-0061 EtherCAT P Box with digital inputs acquires the binary control signals from the process level and transmits them, in an electrically isolated form, to the controller. The state of the signals is indicated by light emitting diodes. The signals are connected via M8 screw type connectors.
The EtherCAT P Box modules are characterised by their small and space-saving form factor.
Quick links


Technical data

Product overview [image] EPP1004-0061 [image] Technical data
Technical data
All values are typical values over the entire temperature range, unless stated otherwise.
Technical data | EPP1004-0061
Fieldbus
Fieldbus | EtherCAT
Connection | EtherCAT P: Combined connection for EtherCAT and supply voltages Input: 1 x M8 socket, 4-pin, P-coded Downstream connection: 1 x M8 socket, 4-pin, P-coded
Distributed Clocks | -
Supply voltages
Connection | See Fieldbus connection
Control voltage US
Nominal voltage | 24 VDC (-15 % / +20 %)
Sum current | max. 3 A 1)
Current consumption from US | 100 mA at 24 VDC
Further consumers | Sensors 2)
Peripheral voltage UP
Nominal voltage | 24 VDC (-15 % / +20 %)
Sum current | max. 3 A 1)
Current consumption from UP | None. UP is only forwarded.
Digital inputs
Number | 4
Connection | 4 x M8 socket
Characteristics | Type 3 according to EN 61131-2, compatible with type 1
Input filter | 3.0 ms
Signal voltage "0" | -3…+5 V
Signal voltage "1" | +11…+30 V
Input current | 6 mA at 24 VDC
Sensor supply US1 3) | Branched off from the control voltage US, max. 0.5 A in total, short-circuit proof
Environmental conditions
Ambient temperature during operation | -25…+60 °C -25…+55 °C according to cULus
Ambient temperature during storage | -40…+85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27 Additional checks
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Mechanics
Dimensions | approx. 86 x 30 x 22 mm (without connectors)
Weight | approx. 90 g
Installation position | variable
Approvals and conformity
Approvals | CE, cULus
1) Sum current of consumers and power transmission.
2) "Sensors": devices connected to the input connections.
3) Supply voltage available at the input connections.
Additional checks
The boxes have been subjected to the following checks:
Verification | Explanation
Vibration | 10 frequency sweeps in 3 axes
 | 5 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 35 g, 11 ms


Process image

Product overview [image] EPP1004-0061 [image] Process image
Process image
Process image in TwinCAT | Connector | Contact | Input variable
EPP1004-0061 | X01 | 4 | TC3 InputPDO Symbol Channel 1 TC3 InputVariable Symbol indent Input
 | X02 | 4 | TC3 InputPDO Symbol Channel 2 TC3 InputVariable Symbol indent Input
 | X03 | 4 | TC3 InputPDO Symbol Channel 3 TC3 InputVariable Symbol indent Input
 | X04 | 4 | TC3 InputPDO Symbol Channel 4 TC3 InputVariable Symbol indent Input


Scope of supply

Product overview [image] EPP1004-0061 [image] Scope of supply
Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EPP1004-0061 EtherCAT P Box
▪
2x protective cap for EtherCAT P socket, M8, red (pre-assembled)
▪
4x protective cap for M8 socket, black (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


EPP10x8-0001

Product overview [image] EPP10x8-0001
EPP10x8-0001
Additional information
•
Introduction
•
Technical data
•
Process image
•
Scope of supply


Introduction

Product overview [image] EPP10x8-0001 [image] Introduction
Introduction
EPP10x8-0001
8-channel digital input 24 V DC
The EPP10x8-0001 EtherCAT P Box with digital inputs acquires the binary control signals from the process level and transmits them, in an electrically isolated form, to the controller.
The state of the signals is indicated by light emitting diodes. The signals are connected via M8 screw type connectors.
These versions have input filters of different speeds.
The sensors are supplied from the control voltage US.
Quick links


Technical data

Product overview [image] EPP10x8-0001 [image] Technical data
Technical data
All values are typical values over the entire temperature range, unless stated otherwise.
Technical data | EPP1008-0001 | EPP1018-0001
Fieldbus
Fieldbus | EtherCAT
Connection | EtherCAT P: Combined connection for EtherCAT and supply voltages Input: 1 x M8 socket, 4-pin, P-coded Downstream connection: 1 x M8 socket, 4-pin, P-coded
Distributed Clocks | -
Supply voltages
Connection | See Fieldbus connection
Control voltage US
Nominal voltage | 24 VDC (-15 % / +20 %)
Sum current | max. 3 A 1)
Current consumption from US | 100 mA at 24 VDC
Further consumers | Sensors 2)
Peripheral voltage UP
Nominal voltage | 24 VDC (-15 % / +20 %)
Sum current | max. 3 A 1)
Current consumption from UP | None. UP is only forwarded.
Digital inputs
Number | 8
Connection | 8 x M8 socket
Characteristics | Type 3 according to EN 61131-2, compatible with type 1
Input filter | 3.0 ms | 10 µs
Signal voltage "0" | -3…+5 V
Signal voltage "1" | +11…+30 V
Input current | 6 mA at 24 VDC
Sensor supply US1 3) | Branched off from the control voltage US, max. 0.5 A in total, short-circuit proof
Environmental conditions
Ambient temperature during operation | -25…+60 °C -25…+55 °C according to cULus
Ambient temperature during storage | -40…+85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27 Additional checks
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Mechanics
Dimensions | approx. 126 x 30 x 26.5 mm (without connectors)
Weight | approx. 165 g
Installation position | variable
Approvals and conformity
Approvals | CE, cULus
1) Sum current of consumers and power transmission.
2) "Sensors": devices connected to the input connections.
3) Supply voltage available at the input connections.
Additional checks
The boxes have been subjected to the following checks:
Verification | Explanation
Vibration | 10 frequency sweeps in 3 axes
 | 5 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 35 g, 11 ms


Process image

Product overview [image] EPP10x8-0001 [image] Process image
Process image
Process image in TwinCAT | Connector | Contact | Input variable
EPP1008-0001 | X01 | 4 | TC3 InputPDO Symbol Channel 1 TC3 InputVariable Symbol indent Input
 | X02 | 4 | TC3 InputPDO Symbol Channel 2 TC3 InputVariable Symbol indent Input
 | X03 | 4 | TC3 InputPDO Symbol Channel 3 TC3 InputVariable Symbol indent Input
 | X04 | 4 | TC3 InputPDO Symbol Channel 4 TC3 InputVariable Symbol indent Input
 | X05 | 4 | TC3 InputPDO Symbol Channel 5 TC3 InputVariable Symbol indent Input
 | X06 | 4 | TC3 InputPDO Symbol Channel 6 TC3 InputVariable Symbol indent Input
 | X07 | 4 | TC3 InputPDO Symbol Channel 7 TC3 InputVariable Symbol indent Input
 | X08 | 4 | TC3 InputPDO Symbol Channel 8 TC3 InputVariable Symbol indent Input


Scope of supply

Product overview [image] EPP10x8-0001 [image] Scope of supply
Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EPP10x8-0001 EtherCAT P Box
▪
2x protective cap for EtherCAT P socket, M8, red (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


EPP10x8-0002

Product overview [image] EPP10x8-0002
EPP10x8-0002
Additional information
•
Introduction
•
Technical data
•
Process image
•
Scope of supply


Introduction

Product overview [image] EPP10x8-0002 [image] Introduction
Introduction
EPP10x8-0002
8-channel digital input 24 V DC
The EPP10x8-0002 EtherCAT P Box with digital inputs acquires the binary control signals from the process level and transmits them, in an electrically isolated form, to the controller.
The state of the signals is indicated by light emitting diodes. The signals are optionally connected via M12 screw type connectors.
These versions have input filters of different speeds.
The sensors are supplied from the control voltage US.
Quick links


Technical data

Product overview [image] EPP10x8-0002 [image] Technical data
Technical data
All values are typical values over the entire temperature range, unless stated otherwise.
Technical data | EPP1008-0002 | EPP1018-0002
Fieldbus
Fieldbus | EtherCAT
Connection | EtherCAT P: Combined connection for EtherCAT and supply voltages Input: 1 x M8 socket, 4-pin, P-coded Downstream connection: 1 x M8 socket, 4-pin, P-coded
Distributed Clocks | -
Supply voltages
Connection | See Fieldbus connection
Control voltage US
Nominal voltage | 24 VDC (-15 % / +20 %)
Sum current | max. 3 A 1)
Current consumption from US | 100 mA at 24 VDC
Further consumers | Sensors 2)
Peripheral voltage UP
Nominal voltage | 24 VDC (-15 % / +20 %)
Sum current | max. 3 A 1)
Current consumption from UP | None. UP is only forwarded.
Digital inputs
Number | 8
Connection | 4 x M12 socket
Characteristics | Type 3 according to EN 61131-2, compatible with type 1
Input filter | 3.0 ms | 10 µs
Signal voltage "0" | -3…+5 V
Signal voltage "1" | +11…+30 V
Input current | 6 mA at 24 VDC
Sensor supply US1 3) | Branched off from the control voltage US, max. 0.5 A in total, short-circuit proof
Environmental conditions
Ambient temperature during operation | -25…+60 °C -25…+55 °C according to cULus
Ambient temperature during storage | -40…+85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27 Additional checks
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Mechanics
Dimensions | approx. 126 x 30 x 26.5 mm (without connectors)
Weight | approx. 165 g
Installation position | variable
Approvals and conformity
Approvals | CE, cULus
1) Sum current of consumers and power transmission.
2) "Sensors": devices connected to the input connections.
3) Supply voltage available at the input connections.
Additional checks
The boxes have been subjected to the following checks:
Verification | Explanation
Vibration | 10 frequency sweeps in 3 axes
 | 5 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 35 g, 11 ms


Process image

Product overview [image] EPP10x8-0002 [image] Process image
Process image
Process image in TwinCAT | Connector | Contact | Input variable
EPP1008-0002 | X01 / X02 | 2 | TC3 InputPDO Symbol Channel 2 TC3 InputVariable Symbol indent Input
 |  | 4 | TC3 InputPDO Symbol Channel 1 TC3 InputVariable Symbol indent Input
 | X03 / X04 | 2 | TC3 InputPDO Symbol Channel 4 TC3 InputVariable Symbol indent Input
 |  | 4 | TC3 InputPDO Symbol Channel 3 TC3 InputVariable Symbol indent Input
 | X05 / X06 | 2 | TC3 InputPDO Symbol Channel 6 TC3 InputVariable Symbol indent Input
 |  | 4 | TC3 InputPDO Symbol Channel 5 TC3 InputVariable Symbol indent Input
 | X07 / X08 | 2 | TC3 InputPDO Symbol Channel 8 TC3 InputVariable Symbol indent Input
 |  | 4 | TC3 InputPDO Symbol Channel 7 TC3 InputVariable Symbol indent Input


Scope of supply

Product overview [image] EPP10x8-0002 [image] Scope of supply
Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EPP10x8-0002 EtherCAT P Box
▪
2x protective cap for EtherCAT P socket, M8, red (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


EPP1008-0022

Product overview [image] EPP1008-0022
EPP1008-0022
Additional information
•
Introduction
•
Technical data
•
Process image
•
Scope of supply


Introduction

Product overview [image] EPP1008-0022 [image] Introduction
Introduction
EPP1008-0022
8-channel digital input 24 V DC, 3.0 ms
The EPP1008-0022 EtherCAT P Box with digital inputs acquires the binary control signals from the process level and transmits them, in an electrically isolated form, to the controller.
The state of the signals is indicated by light emitting diodes. The signals are connected via M12 screw type connectors.
Quick links


Technical data

Product overview [image] EPP1008-0022 [image] Technical data
Technical data
All values are typical values over the entire temperature range, unless stated otherwise.
Technical data | EPP1008-0022
Fieldbus
Fieldbus | EtherCAT
Connection | EtherCAT P: Combined connection for EtherCAT and supply voltages Input: 1 x M8 socket, 4-pin, P-coded Downstream connection: 1 x M8 socket, 4-pin, P-coded
Distributed Clocks | -
Supply voltages
Connection | See Fieldbus connection
Control voltage US
Nominal voltage | 24 VDC (-15 % / +20 %)
Sum current | max. 3 A 1)
Current consumption from US | 100 mA at 24 VDC
Further consumers | Sensors 2)
Peripheral voltage UP
Nominal voltage | 24 VDC (-15 % / +20 %)
Sum current | max. 3 A 1)
Current consumption from UP | None. UP is only forwarded.
Digital inputs
Number | 8
Connection | 8 x M12 socket
Characteristics | Type 3 according to EN 61131-2, compatible with type 1
Input filter | 3.0 ms
Signal voltage "0" | -3…+5 V
Signal voltage "1" | +11…+30 V
Input current | 6 mA at 24 VDC
Sensor supply US1 3) | Branched off from the control voltage US, max. 0.5 A in total, short-circuit proof
Environmental conditions
Ambient temperature during operation | -25…+60 °C -25…+55 °C according to cULus
Ambient temperature during storage | -40…+85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27 Additional checks
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Mechanics
Dimensions | approx. 126 x 30 x 26.5 mm (without connectors)
Weight | approx. 250 g
Installation position | variable
Approvals and conformity
Approvals | CE, cULus
1) Sum current of consumers and power transmission.
2) "Sensors": devices connected to the input connections.
3) Supply voltage available at the input connections.
Additional checks
The boxes have been subjected to the following checks:
Verification | Explanation
Vibration | 10 frequency sweeps in 3 axes
 | 5 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 35 g, 11 ms


Process image

Product overview [image] EPP1008-0022 [image] Process image
Process image
Process image in TwinCAT | Connector | Contact | Input variable
EPP1008-0022 | X01 | 4 | TC3 InputPDO Symbol Channel 1 TC3 InputVariable Symbol indent Input
 | X02 | 4 | TC3 InputPDO Symbol Channel 2 TC3 InputVariable Symbol indent Input
 | X03 | 4 | TC3 InputPDO Symbol Channel 3 TC3 InputVariable Symbol indent Input
 | X04 | 4 | TC3 InputPDO Symbol Channel 4 TC3 InputVariable Symbol indent Input
 | X05 | 4 | TC3 InputPDO Symbol Channel 5 TC3 InputVariable Symbol indent Input
 | X06 | 4 | TC3 InputPDO Symbol Channel 6 TC3 InputVariable Symbol indent Input
 | X07 | 4 | TC3 InputPDO Symbol Channel 7 TC3 InputVariable Symbol indent Input
 | X08 | 4 | TC3 InputPDO Symbol Channel 8 TC3 InputVariable Symbol indent Input


Scope of supply

Product overview [image] EPP1008-0022 [image] Scope of supply
Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EPP1008-0022 EtherCAT P Box
▪
2x protective cap for EtherCAT P socket, M8, red (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


EPP1258-0001

Product overview [image] EPP1258-0001
EPP1258-0001
Additional information
•
Introduction
•
Technical data
•
Process image
•
Scope of supply


Introduction

Product overview [image] EPP1258-0001 [image] Introduction
Introduction
EPP1258-0001
8-channel digital input with 2-channel timestamp
The EPP1258 EtherCAT P Box with digital inputs acquires the fast binary control signals from the process level and transmits them, in an electrically isolated form, to the controller.
The signals are furnished with a timestamp that identifies the time of the last edge change with a resolution of 1 ns. This technology enables signals to be traced exactly over time and synchronised with the distributed clocks across the system. With this technology, machine-wide parallel hardware wiring of digital inputs or encoder signals for synchronisation purposes is often no longer required. In this way, the EPP1258 enables responses with equidistant time intervals, largely independent of the bus cycle time.
Quick links


Technical data

Product overview [image] EPP1258-0001 [image] Technical data
Technical data
All values are typical values over the entire temperature range, unless stated otherwise.
Technical data | EPP1258-0001
Fieldbus
Fieldbus | EtherCAT
Connection | EtherCAT P: Combined connection for EtherCAT and supply voltages Input: 1 x M8 socket, 4-pin, P-coded Downstream connection: 1 x M8 socket, 4-pin, P-coded
Distributed Clocks | yes
Supply voltages
Connection | See Fieldbus connection
Control voltage US
Nominal voltage | 24 VDC (-15 % / +20 %)
Sum current | max. 3 A 1)
Current consumption from US | 100 mA at 24 VDC
Further consumers | Sensors 2)
Peripheral voltage UP
Nominal voltage | 24 VDC (-15 % / +20 %)
Sum current | max. 3 A 1)
Current consumption from UP | None. UP is only forwarded.
Digital inputs
Number | 8, of which 2 are Timestamp inputs
Connection | 8 x M8 socket
Characteristics | Type 3 according to EN 61131-2, compatible with type 1 Timestamp inputs: similar to type 3 according to EN 61131-2, compatible with type 1
Input filter | 10 µs Timestamp inputs: no filter
Signal voltage "0" | -3…+5 V
Signal voltage "1" | +11…+30 V
Input current | 6 mA at 24 VDC Timestamp inputs: 3 mA at 24 VDC
Sensor supply US1 3) | Branched off from the control voltage US, max. 0.5 A in total, short-circuit proof
Time stamp function
Resolution | 1 ns
Accuracy | Timestamp: 10 ns + input delay Distributed Clocks: 100 ns
1) Sum current of consumers and power transmission.
2) "Sensors": devices connected to the input connections.
3) Supply voltage available at the input connections.
Technical data | EPP1258-0001
Environmental conditions
Ambient temperature during operation | -25…+60 °C -25…+55 °C according to cULus
Ambient temperature during storage | -40…+85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27 Additional checks
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Mechanics
Dimensions | approx. 126 x 30 x 26.5 mm (without connectors)
Weight | approx. 165 g
Installation position | variable
Approvals and conformity
Approvals | CE, cULus
Additional checks
The boxes have been subjected to the following checks:
Verification | Explanation
Vibration | 10 frequency sweeps in 3 axes
 | 5 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 35 g, 11 ms


Process image

Product overview [image] EPP1258-0001 [image] Process image
Process image
Process image in TwinCAT | Connector | Contact | Input variable
EPP1258-0001 | X01 | 4 | TC3 InputPDO Symbol Channel 1 TC3 InputVariable Symbol indent Input TC3 InputPDO Symbol Latch TC3 InputVariable Symbol indent Status0 TC3 InputVariable Symbol indent LatchPos0 TC3 InputVariable Symbol indent LatchNeg0
 | X02 | 4 | TC3 InputPDO Symbol Channel 2 TC3 InputVariable Symbol indent Input TC3 InputPDO Symbol Latch TC3 InputVariable Symbol indent Status1 TC3 InputVariable Symbol indent LatchPos1 TC3 InputVariable Symbol indent LatchNeg1
 | X03 | 4 | TC3 InputPDO Symbol Channel 3 TC3 InputVariable Symbol indent Input
 | X04 | 4 | TC3 InputPDO Symbol Channel 4 TC3 InputVariable Symbol indent Input
 | X05 | 4 | TC3 InputPDO Symbol Channel 5 TC3 InputVariable Symbol indent Input
 | X06 | 4 | TC3 InputPDO Symbol Channel 6 TC3 InputVariable Symbol indent Input
 | X07 | 4 | TC3 InputPDO Symbol Channel 7 TC3 InputVariable Symbol indent Input
 | X08 | 4 | TC3 InputPDO Symbol Channel 8 TC3 InputVariable Symbol indent Input
Working Counter
The Working Counter is a diagnostic function for EtherCAT networks. A description of the Working Counter can be found in the EtherCAT system documentation.
▪
TC3 InputVariable Symbol WcState0: Working Counter for the inputs Channel 3 to Channel 8
▪
TC3 InputVariable Symbol WcState1: Working Counter for the Timestamp inputs Channel 1 and Channel 2


Scope of supply

Product overview [image] EPP1258-0001 [image] Scope of supply
Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EPP1258-0001 EtherCAT P Box
▪
2x protective cap for EtherCAT P socket, M8, red (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


EPP1258-0002

Product overview [image] EPP1258-0002
EPP1258-0002
Additional information
•
Introduction
•
Technical data
•
Process image
•
Scope of supply


Introduction

Product overview [image] EPP1258-0002 [image] Introduction
Introduction
EPP1258-0002
8-channel digital input with 2-channel timestamp
The EPP1258 EtherCAT P Box with digital inputs acquires the fast binary control signals from the process level and transmits them, in an electrically isolated form, to the controller.
The signals are furnished with a timestamp that identifies the time of the last edge change with a resolution of 1 ns. This technology enables signals to be traced exactly over time and synchronised with the distributed clocks across the system. With this technology, machine-wide parallel hardware wiring of digital inputs or encoder signals for synchronisation purposes is often no longer required. In this way, the EPP1258 enables responses with equidistant time intervals, largely independent of the bus cycle time.
Quick links


Technical data

Product overview [image] EPP1258-0002 [image] Technical data
Technical data
All values are typical values over the entire temperature range, unless stated otherwise.
Technical data | EPP1258-0002
Fieldbus
Fieldbus | EtherCAT
Connection | EtherCAT P: Combined connection for EtherCAT and supply voltages Input: 1 x M8 socket, 4-pin, P-coded Downstream connection: 1 x M8 socket, 4-pin, P-coded
Distributed Clocks | yes
Supply voltages
Connection | See Fieldbus connection
Control voltage US
Nominal voltage | 24 VDC (-15 % / +20 %)
Sum current | max. 3 A 1)
Current consumption from US | 100 mA at 24 VDC
Further consumers | Sensors 2)
Peripheral voltage UP
Nominal voltage | 24 VDC (-15 % / +20 %)
Sum current | max. 3 A 1)
Current consumption from UP | None. UP is only forwarded.
Digital inputs
Number | 8, of which 2 are Timestamp inputs
Connection | 4 x M12 socket
Characteristics | Type 3 according to EN 61131-2, compatible with type 1 Timestamp inputs: similar to type 3 according to EN 61131-2, compatible with type 1
Input filter | 10 µs Timestamp inputs: no filter
Signal voltage "0" | -3…+5 V
Signal voltage "1" | +11…+30 V
Input current | 6 mA at 24 VDC Timestamp inputs: 3 mA at 24 VDC
Sensor supply US1 3) | Branched off from the control voltage US, max. 0.5 A in total, short-circuit proof
Time stamp function
Resolution | 1 ns
Accuracy | Timestamp: 10 ns + input delay Distributed Clocks: 100 ns
1) Sum current of consumers and power transmission.
2) "Sensors": devices connected to the input connections.
3) Supply voltage available at the input connections.
Technical data | EPP1258-0002
Environmental conditions
Ambient temperature during operation | -25…+60 °C -25…+55 °C according to cULus
Ambient temperature during storage | -40…+85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27 Additional checks
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Mechanics
Dimensions | approx. 126 x 30 x 26.5 mm (without connectors)
Weight | approx. 165 g
Installation position | variable
Approvals and conformity
Approvals | CE, cULus
Additional checks
The boxes have been subjected to the following checks:
Verification | Explanation
Vibration | 10 frequency sweeps in 3 axes
 | 5 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 35 g, 11 ms


Process image

Product overview [image] EPP1258-0002 [image] Process image
Process image
Process image in TwinCAT | Connector | Contact | Input variable
EPP1258-0002 | X01 / X02 | 2 | TC3 InputPDO Symbol Channel 2 TC3 InputVariable Symbol indent Input TC3 InputPDO Symbol Latch TC3 InputVariable Symbol indent Status1 TC3 InputVariable Symbol indent LatchPos1 TC3 InputVariable Symbol indent LatchNeg1
 |  | 4 | TC3 InputPDO Symbol Channel 1 TC3 InputVariable Symbol indent Input TC3 InputPDO Symbol Latch TC3 InputVariable Symbol indent Status0 TC3 InputVariable Symbol indent LatchPos0 TC3 InputVariable Symbol indent LatchNeg0
 | X03 / X04 | 2 | TC3 InputPDO Symbol Channel 4 TC3 InputVariable Symbol indent Input
 |  | 4 | TC3 InputPDO Symbol Channel 3 TC3 InputVariable Symbol indent Input
 | X05 / X06 | 2 | TC3 InputPDO Symbol Channel 6 TC3 InputVariable Symbol indent Input
 |  | 4 | TC3 InputPDO Symbol Channel 5 TC3 InputVariable Symbol indent Input
 | X07 / X08 | 2 | TC3 InputPDO Symbol Channel 8 TC3 InputVariable Symbol indent Input
 |  | 4 | TC3 InputPDO Symbol Channel 7 TC3 InputVariable Symbol indent Input
Working Counter
The Working Counter is a diagnostic function for EtherCAT networks. A description of the Working Counter can be found in the EtherCAT system documentation.
▪
TC3 InputVariable Symbol WcState0: Working Counter for the inputs Channel 3 to Channel 8
▪
TC3 InputVariable Symbol WcState1: Working Counter for the Timestamp inputs Channel 1 and Channel 2


Scope of supply

Product overview [image] EPP1258-0002 [image] Scope of supply
Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EPP1258-0002 EtherCAT P Box
▪
2x protective cap for EtherCAT P socket, M8, red (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


EPP18x9-0021

Product overview [image] EPP18x9-0021
EPP18x9-0021
Additional information
•
Introduction
•
Technical data
•
Process image
•
Scope of supply


Introduction

Product overview [image] EPP18x9-0021 [image] Introduction
Introduction
EP18x9-0021
16-channel digital input 24 V DC
The EPP18x9-0021 EtherCAT P Box with digital inputs acquires the binary control signals from the process level and transmits them, in an electrically isolated form, to the controller.
The state of the signals is indicated by light emitting diodes. The signals are optionally connected via M8 screw type connectors.
Quick links


Technical data

Product overview [image] EPP18x9-0021 [image] Technical data
Technical data
All values are typical values over the entire temperature range, unless stated otherwise.
Technical data | EPP1809-0021 | EPP1819-0021
Fieldbus
Fieldbus | EtherCAT
Connection | EtherCAT P: Combined connection for EtherCAT and supply voltages Input: 1 x M8 socket, 4-pin, P-coded Downstream connection: 1 x M8 socket, 4-pin, P-coded
Distributed Clocks | -
Supply voltages
Connection | See Fieldbus connection
Control voltage US
Nominal voltage | 24 VDC (-15 % / +20 %)
Sum current | max. 3 A 1)
Current consumption from US | 100 mA at 24 VDC
Further consumers | Sensors 2)
Peripheral voltage UP
Nominal voltage | 24 VDC (-15 % / +20 %)
Sum current | max. 3 A 1)
Current consumption from UP | None. UP is only forwarded.
Digital inputs
Number | 16
Connection | 16 x M8 socket
Characteristics | Type 3 according to EN 61131-2, compatible with type 1
Input filter | 3.0 ms | 10 µs
Signal voltage "0" | -3…+5 V
Signal voltage "1" | +11…+30 V
Input current | 6 mA at 24 VDC
Sensor supply US1 3) | Branched off from the control voltage US, max. 0.5 A in total, short-circuit proof
Environmental conditions
Ambient temperature during operation | -25…+60 °C -25…+55 °C according to cULus
Ambient temperature during storage | -40…+85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27 Additional checks
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Mechanics
Dimensions | approx. 126 x 60 x 26.5 mm (without connectors)
Weight | approx. 250 g
Installation position | variable
Approvals and conformity
Approvals | CE, cULus
1) Sum current of consumers and power transmission.
2) "Sensors": devices connected to the input connections.
3) Supply voltage available at the input connections.
Additional checks
The boxes have been subjected to the following checks:
Verification | Explanation
Vibration | 10 frequency sweeps in 3 axes
 | 5 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 35 g, 11 ms


Process image

Product overview [image] EPP18x9-0021 [image] Process image
Process image
Process image in TwinCAT | Connector | Contact | Input variable
EPP1819-0021 | X01 | 4 | TC3 InputPDO Symbol Channel 1 TC3 InputVariable Symbol indent Input
 | X02 | 4 | TC3 InputPDO Symbol Channel 2 TC3 InputVariable Symbol indent Input
 | X03 | 4 | TC3 InputPDO Symbol Channel 3 TC3 InputVariable Symbol indent Input
 | X04 | 4 | TC3 InputPDO Symbol Channel 4 TC3 InputVariable Symbol indent Input
 | X05 | 4 | TC3 InputPDO Symbol Channel 5 TC3 InputVariable Symbol indent Input
 | X06 | 4 | TC3 InputPDO Symbol Channel 6 TC3 InputVariable Symbol indent Input
 | X07 | 4 | TC3 InputPDO Symbol Channel 7 TC3 InputVariable Symbol indent Input
 | X08 | 4 | TC3 InputPDO Symbol Channel 8 TC3 InputVariable Symbol indent Input
 | X09 | 4 | TC3 InputPDO Symbol Channel 9 TC3 InputVariable Symbol indent Input
 | X10 | 4 | TC3 InputPDO Symbol Channel 10 TC3 InputVariable Symbol indent Input
 | X11 | 4 | TC3 InputPDO Symbol Channel 11 TC3 InputVariable Symbol indent Input
 | X12 | 4 | TC3 InputPDO Symbol Channel 12 TC3 InputVariable Symbol indent Input
 | X13 | 4 | TC3 InputPDO Symbol Channel 13 TC3 InputVariable Symbol indent Input
 | X14 | 4 | TC3 InputPDO Symbol Channel 14 TC3 InputVariable Symbol indent Input
 | X15 | 4 | TC3 InputPDO Symbol Channel 15 TC3 InputVariable Symbol indent Input
 | X16 | 4 | TC3 InputPDO Symbol Channel 16 TC3 InputVariable Symbol indent Input


Scope of supply

Product overview [image] EPP18x9-0021 [image] Scope of supply
Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EPP18x9-0021 EtherCAT P Box
▪
2x protective cap for EtherCAT P socket, M8, red (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


EPP18x9-0022

Product overview [image] EPP18x9-0022
EPP18x9-0022
Additional information
•
Introduction
•
Technical data
•
Process image
•
Scope of supply


Introduction

Product overview [image] EPP18x9-0022 [image] Introduction
Introduction
EPP18x9-0022
16-channel digital input 24 V DC
The EPP18x9-0022 EtherCAT P Box with digital inputs acquires the binary control signals from the process level and transmits them, in an electrically isolated form, to the controller.
The state of the signals is indicated by light emitting diodes. The signals are connected via M12 screw type connectors.
Quick links


Technical data

Product overview [image] EPP18x9-0022 [image] Technical data
Technical data
All values are typical values over the entire temperature range, unless stated otherwise.
Technical data | EPP1809-0022 | EPP1819-0022
Fieldbus
Fieldbus | EtherCAT
Connection | EtherCAT P: Combined connection for EtherCAT and supply voltages Input: 1 x M8 socket, 4-pin, P-coded Downstream connection: 1 x M8 socket, 4-pin, P-coded
Distributed Clocks | -
Supply voltages
Connection | See Fieldbus connection
Control voltage US
Nominal voltage | 24 VDC (-15 % / +20 %)
Sum current | max. 3 A 1)
Current consumption from US | 100 mA at 24 VDC
Further consumers | Sensors 2)
Peripheral voltage UP
Nominal voltage | 24 VDC (-15 % / +20 %)
Sum current | max. 3 A 1)
Current consumption from UP | None. UP is only forwarded.
Digital inputs
Number | 16
Connection | 8 x M12 socket
Characteristics | Type 3 according to EN 61131-2, compatible with type 1
Input filter | 3.0 ms | 10 µs
Signal voltage "0" | -3…+5 V
Signal voltage "1" | +11…+30 V
Input current | 6 mA at 24 VDC
Sensor supply US1 3) | Branched off from the control voltage US, max. 0.5 A in total, short-circuit proof
Environmental conditions
Ambient temperature during operation | -25…+60 °C -25…+55 °C according to cULus
Ambient temperature during storage | -40…+85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27 Additional checks
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Mechanics
Dimensions | approx. 126 x 60 x 26.5 mm (without connectors)
Weight | approx. 250 g
Installation position | variable
Approvals and conformity
Approvals | CE, cULus
1) Sum current of consumers and power transmission.
2) "Sensors": devices connected to the input connections.
3) Supply voltage available at the input connections.
Additional checks
The boxes have been subjected to the following checks:
Verification | Explanation
Vibration | 10 frequency sweeps in 3 axes
 | 5 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 35 g, 11 ms


Process image

Product overview [image] EPP18x9-0022 [image] Process image
Process image
Process image in TwinCAT | Connector | Contact | Input variable
EPP1819-0022 | X01 / X02 | 2 | TC3 InputPDO Symbol Channel 2 TC3 InputVariable Symbol indent Input
 |  | 4 | TC3 InputPDO Symbol Channel 1 TC3 InputVariable Symbol indent Input
 | X03 / X04 | 2 | TC3 InputPDO Symbol Channel 4 TC3 InputVariable Symbol indent Input
 |  | 4 | TC3 InputPDO Symbol Channel 3 TC3 InputVariable Symbol indent Input
 | X05 / X06 | 2 | TC3 InputPDO Symbol Channel 6 TC3 InputVariable Symbol indent Input
 |  | 4 | TC3 InputPDO Symbol Channel 5 TC3 InputVariable Symbol indent Input
 | X07 / X08 | 2 | TC3 InputPDO Symbol Channel 8 TC3 InputVariable Symbol indent Input
 |  | 4 | TC3 InputPDO Symbol Channel 7 TC3 InputVariable Symbol indent Input
 | X09 / X10 | 2 | TC3 InputPDO Symbol Channel 10 TC3 InputVariable Symbol indent Input
 |  | 4 | TC3 InputPDO Symbol Channel 9 TC3 InputVariable Symbol indent Input
 | X11 / X12 | 2 | TC3 InputPDO Symbol Channel 12 TC3 InputVariable Symbol indent Input
 |  | 4 | TC3 InputPDO Symbol Channel 11 TC3 InputVariable Symbol indent Input
 | X13 / X14 | 2 | TC3 InputPDO Symbol Channel 14 TC3 InputVariable Symbol indent Input
 |  | 4 | TC3 InputPDO Symbol Channel 13 TC3 InputVariable Symbol indent Input
 | X15 / X16 | 2 | TC3 InputPDO Symbol Channel 16 TC3 InputVariable Symbol indent Input
 |  | 4 | TC3 InputPDO Symbol Channel 15 TC3 InputVariable Symbol indent Input


Scope of supply

Product overview [image] EPP18x9-0022 [image] Scope of supply
Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EPP18x9-0022 EtherCAT P Box
▪
2x protective cap for EtherCAT P socket, M8, red (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


EPP1816-0003

Product overview [image] EPP1816-0003
EPP1816-0003
Additional information
•
Introduction
•
Technical data
•
Process image
•
Scope of supply


Introduction

Product overview [image] EPP1816-0003 [image] Introduction
Introduction
EPP1816-0003
16-channel digital input 24 V DC
The EPP1816-0003 EtherCAT P Box with digital inputs acquires the binary control signals from the process level and transmits them, in an electrically isolated form, to the controller.
The state of the signals is indicated by light emitting diodes. For the signal connection female headers with spring connection are used, optionally available with 1 or 3 pins. The module is supplied without connectors.
The sensors are supplied from the box supply voltage US. The auxiliary voltage UP is not used in the input module, but may be connected in order to be relayed downstream.
Quick links


Technical data

Product overview [image] EPP1816-0003 [image] Technical data
Technical data
All values are typical values over the entire temperature range, unless stated otherwise.
Technical data | EPP1816-0003
Fieldbus
Fieldbus | EtherCAT
Connection | EtherCAT P: Combined connection for EtherCAT and supply voltages Input: 1 x M8 socket, 4-pin, P-coded Downstream connection: 1 x M8 socket, 4-pin, P-coded
Distributed Clocks | yes
Supply voltages
Connection | See Fieldbus connection
Control voltage US
Nominal voltage | 24 VDC (-15 % / +20 %)
Sum current | max. 3 A 1)
Current consumption from US | 100 mA at 24 VDC
Further consumers | Sensors 2)
Peripheral voltage UP
Nominal voltage | 24 VDC (-15 % / +20 %)
Sum current | max. 3 A 1)
Current consumption from UP | None. UP is only forwarded.
Digital inputs
Number | 16
Connection | 2 x female header with spring connection: ZS2001
Characteristics | Type 3 according to EN 61131-2, compatible with type 1
Input filter | 10 µs
Signal voltage "0" | -3…+5 V
Signal voltage "1" | +11…+30 V
Input current | 6 mA at 24 VDC
Sensor supply US1 3) | Branched off from the control voltage US, max. 0.5 A in total, short-circuit proof
Environmental conditions
Ambient temperature during operation | -25…+60 °C -25…+55 °C according to cULus
Ambient temperature during storage | -40…+85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27 Additional checks
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Mechanics
Dimensions | approx. 126 x 30 x 26.5 mm (without connectors)
Weight | approx. 165 g
Installation position | variable
Approvals and conformity
Approvals | CE, cULus
1) Sum current of consumers and power transmission.
2) "Sensors": devices connected to the input connections.
3) Supply voltage available at the input connections.
Additional checks
The boxes have been subjected to the following checks:
Verification | Explanation
Vibration | 10 frequency sweeps in 3 axes
 | 5 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 35 g, 11 ms


Process image

Product overview [image] EPP1816-0003 [image] Process image
Process image
Process image in TwinCAT | Connector | Contact | Input variable
EPP1816-0003 | EPP1816-0003 oberer Steckverbinder | 0 | TC3 InputPDO Symbol DIG Inputs Channel 1 TC3 InputVariable Symbol indent Input 1
 |  | 1 | TC3 InputPDO Symbol DIG Inputs Channel 1 TC3 InputVariable Symbol indent Input 2
 |  | 2 | TC3 InputPDO Symbol DIG Inputs Channel 1 TC3 InputVariable Symbol indent Input 3
 |  | 3 | TC3 InputPDO Symbol DIG Inputs Channel 1 TC3 InputVariable Symbol indent Input 4
 |  | 4 | TC3 InputPDO Symbol DIG Inputs Channel 1 TC3 InputVariable Symbol indent Input 5
 |  | 5 | TC3 InputPDO Symbol DIG Inputs Channel 1 TC3 InputVariable Symbol indent Input 6
 |  | 6 | TC3 InputPDO Symbol DIG Inputs Channel 1 TC3 InputVariable Symbol indent Input 7
 |  | 7 | TC3 InputPDO Symbol DIG Inputs Channel 1 TC3 InputVariable Symbol indent Input 8
 | EPP1816-0003 unterer Steckverbinder | 0 | TC3 InputPDO Symbol DIG Inputs Channel 2 TC3 InputVariable Symbol indent Input 1
 |  | 1 | TC3 InputPDO Symbol DIG Inputs Channel 2 TC3 InputVariable Symbol indent Input 2
 |  | 2 | TC3 InputPDO Symbol DIG Inputs Channel 2 TC3 InputVariable Symbol indent Input 3
 |  | 3 | TC3 InputPDO Symbol DIG Inputs Channel 2 TC3 InputVariable Symbol indent Input 4
 |  | 4 | TC3 InputPDO Symbol DIG Inputs Channel 2 TC3 InputVariable Symbol indent Input 5
 |  | 5 | TC3 InputPDO Symbol DIG Inputs Channel 2 TC3 InputVariable Symbol indent Input 6
 |  | 6 | TC3 InputPDO Symbol DIG Inputs Channel 2 TC3 InputVariable Symbol indent Input 7
 |  | 7 | TC3 InputPDO Symbol DIG Inputs Channel 2 TC3 InputVariable Symbol indent Input 8


Scope of supply

Product overview [image] EPP1816-0003 [image] Scope of supply
Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EPP1816-0003 EtherCAT P Box
▪
2x protective cap for EtherCAT P socket, M8, red (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Female headers with spring connection are not included in the scope of supply
You can find suitable types on the product website under "Accessories".
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


EPP1816-0008

Product overview [image] EPP1816-0008
EPP1816-0008
Additional information
•
Introduction
•
Technical data
•
Status LEDs
•
Process image
•
Scope of supply


Introduction

Product overview [image] EPP1816-0008 [image] Introduction
Introduction
EPP1816-0008
16-channel digital input 24 V DC
The EPP1816 EtherCAT P Box with digital inputs acquires the binary control signals from the process level and transmits them, in an electrically isolated form, to the controller.
The state of the signals is indicated by light emitting diodes. The signals are connected via 25-pin D-sub socket.
Quick links


Technical data

Product overview [image] EPP1816-0008 [image] Technical data
Technical data
All values are typical values over the entire temperature range, unless stated otherwise.
Technical data | EPP1816-0008
Fieldbus
Fieldbus | EtherCAT
Connection | EtherCAT P: Combined connection for EtherCAT and supply voltages Input: 1 x M8 socket, 4-pin, P-coded Downstream connection: 1 x M8 socket, 4-pin, P-coded
Distributed Clocks | yes
Supply voltages
Connection | See Fieldbus connection
Control voltage US
Nominal voltage | 24 VDC (-15 % / +20 %)
Sum current | max. 3 A 1)
Current consumption from US | 100 mA at 24 VDC
Further consumers | Sensors 2)
Peripheral voltage UP
Nominal voltage | 24 VDC (-15 % / +20 %)
Sum current | max. 3 A 1)
Current consumption from UP | None. UP is only forwarded.
Digital inputs
Number | 16
Connection | D-sub socket, 25-pin
Characteristics | Type 3 according to EN 61131-2, compatible with type 1
Input filter | 10 µs
Signal voltage "0" | -3…+5 V
Signal voltage "1" | +11…+30 V
Input current | 6 mA at 24 VDC
Sensor supply US1 3) | Branched off from the control voltage US, max. 0.5 A in total, short-circuit proof
Environmental conditions
Ambient temperature during operation | -25…+60 °C -25…+55 °C according to cULus
Ambient temperature during storage | -40…+85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27 Additional checks
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Mechanics
Dimensions | approx. 126 x 30 x 26.5 mm (without connectors)
Weight | approx. 165 g
Installation position | variable
Approvals and conformity
Approvals | CE, cULus
1) Sum current of consumers and power transmission.
2) "Sensors": devices connected to the input connections.
3) Supply voltage available at the input connections.
Additional checks
The boxes have been subjected to the following checks:
Verification | Explanation
Vibration | 10 frequency sweeps in 3 axes
 | 5 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 35 g, 11 ms


Status LEDs

Product overview [image] EPP1816-0008 [image] Status LEDs
Status LEDs
Status LEDs of EPP1816
LED Displays
LED | Display | Meaning
STATUS 1-8 | green illuminated | a signal (24 V) is present at one or more inputs of channels 1 to 8
STATUS 9-16 | green illuminated | a signal (24 V) is present at one or more inputs of channels 9 to 16
US | off | Supply voltage US is not present
 | green illuminated | Supply voltage US is present
UP | off | Supply voltage UP is not present
 | green illuminated | Supply voltage UP is present


Process image

Product overview [image] EPP1816-0008 [image] Process image
Process image
Process image in TwinCAT | Connector | Contact | Input variable
EPP1816-0008 | X01 | 1 | TC3 InputPDO Symbol DIG Inputs Channel 1 TC3 InputVariable Symbol indent Input 1
 |  | 2 | TC3 InputPDO Symbol DIG Inputs Channel 1 TC3 InputVariable Symbol indent Input 2
 |  | 3 | TC3 InputPDO Symbol DIG Inputs Channel 1 TC3 InputVariable Symbol indent Input 3
 |  | 4 | TC3 InputPDO Symbol DIG Inputs Channel 1 TC3 InputVariable Symbol indent Input 4
 |  | 5 | TC3 InputPDO Symbol DIG Inputs Channel 1 TC3 InputVariable Symbol indent Input 5
 |  | 6 | TC3 InputPDO Symbol DIG Inputs Channel 1 TC3 InputVariable Symbol indent Input 6
 |  | 7 | TC3 InputPDO Symbol DIG Inputs Channel 1 TC3 InputVariable Symbol indent Input 7
 |  | 8 | TC3 InputPDO Symbol DIG Inputs Channel 1 TC3 InputVariable Symbol indent Input 8
 |  | 9 | TC3 InputPDO Symbol DIG Inputs Channel 2 TC3 InputVariable Symbol indent Input 1
 |  | 10 | TC3 InputPDO Symbol DIG Inputs Channel 2 TC3 InputVariable Symbol indent Input 2
 |  | 11 | TC3 InputPDO Symbol DIG Inputs Channel 2 TC3 InputVariable Symbol indent Input 3
 |  | 12 | TC3 InputPDO Symbol DIG Inputs Channel 2 TC3 InputVariable Symbol indent Input 4
 |  | 13 | TC3 InputPDO Symbol DIG Inputs Channel 2 TC3 InputVariable Symbol indent Input 5
 |  | 14 | TC3 InputPDO Symbol DIG Inputs Channel 2 TC3 InputVariable Symbol indent Input 6
 |  | 15 | TC3 InputPDO Symbol DIG Inputs Channel 2 TC3 InputVariable Symbol indent Input 7
 |  | 16 | TC3 InputPDO Symbol DIG Inputs Channel 2 TC3 InputVariable Symbol indent Input 8


Scope of supply

Product overview [image] EPP1816-0008 [image] Scope of supply
Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EPP1816-0008 EtherCAT P Box
▪
2x protective cap for EtherCAT P socket, M8, red (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


EPP1816-3008

Product overview [image] EPP1816-3008
EPP1816-3008
Additional information
•
Introduction
•
Technical data
•
Status LEDs
•
Process image
•
Scope of supply


Introduction

Product overview [image] EPP1816-3008 [image] Introduction
Introduction
EPP1816-3008
16-channel digital input 24 V DC, 2 x 3-axis accelerometers
The EPP1816-3008 EtherCAT P Box with 16 digital inputs acquires the binary control signals from the process level and transmits them, in an electrically isolated form, to the controller.
The state of the signals is indicated by light emitting diodes. The signals are connected via 25-pin D-sub socket.
The EtherCAT P Box has 2 x 3 axes accelerometer with 16 bits and a selectable resolution of ±2 g, ±4 g, ±8 g and ±16 g. The sampling frequency is 1 Hz to 5 KHz. Possible applications include the recording of vibrations and shocks/oscillations, and furthermore inclination measurements in all three axes. Undervoltage detection (US and UP) is integrated and is signaled to the controller.
Quick links


Technical data

Product overview [image] EPP1816-3008 [image] Technical data
Technical data
All values are typical values over the entire temperature range, unless stated otherwise.
Technical data | EPP1816-3008
Fieldbus
Fieldbus | EtherCAT
Connection | EtherCAT P: Combined connection for EtherCAT and supply voltages Input: 1 x M8 socket, 4-pin, P-coded Downstream connection: 1 x M8 socket, 4-pin, P-coded
Distributed Clocks | yes
Supply voltages
Connection | See Fieldbus connection
Control voltage US
Nominal voltage | 24 VDC (-15 % / +20 %)
Sum current | max. 3 A 1)
Current consumption from US | 100 mA at 24 VDC
Further consumers | Sensors 2)
Undervoltage detection | yes
Peripheral voltage UP
Nominal voltage | 24 VDC (-15 % / +20 %)
Sum current | max. 3 A 1)
Current consumption from UP | None. UP is only forwarded.
Undervoltage detection | yes
Digital inputs
Number | 16
Connection | D-sub socket, 25-pin
Characteristics | Type 3 according to EN 61131-2, compatible with type 1
Input filter | 10 µs
Signal voltage "0" | -3…+5 V
Signal voltage "1" | +11…+30 V
Input current | 6 mA at 24 VDC
Sensor supply US1 3) | Branched off from the control voltage US, max. 0.5 A in total, short-circuit proof
Environmental conditions
Ambient temperature during operation | -25…+60 °C -25…+55 °C according to cULus
Ambient temperature during storage | -40…+85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27 Additional checks
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
1) Sum current of consumers and power transmission.
2) "Sensors": devices connected to the input connections.
3) Supply voltage available at the input connections.
Technical data | EPP1816-3008
Mechanics
Dimensions | approx. 126 x 30 x 26.5 mm (without connectors)
Weight | approx. 165 g
Installation position | variable
Approvals and conformity
Approvals | CE, cULus
Additional checks
The boxes have been subjected to the following checks:
Verification | Explanation
Vibration | 10 frequency sweeps in 3 axes
 | 5 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 35 g, 11 ms
Additional information
•
Acceleration measurement (EPP1816-3008)


Acceleration measurement (EPP1816-3008)

Product overview [image] EPP1816-3008 [image] Technical data [image] Acceleration measurement (EPP1816-3008)
Acceleration measurement (EPP1816-3008)
Technical data
Acceleration measurement
Inclination measurement
Raw values
Measured values
Measuring range 1)
Parameterizable:
▪
±2 g
▪
±4 g
▪
±8 g
▪
±16 g
±180°
Resolution 1)
10 Bit
▪
Measuring range ±2 g: 4 mg
▪
Measuring range ±4 g: 8 mg
▪
Measuring range ±8 g: 16 mg
▪
Measuring range ±16 g: 48 mg
1°
Representation 1)
10-bit in 16-bit
(left aligned)
1 mg / LSB
1° / LSB
Sampling rate
1 .. 5000 Hz
1) Unit of measurement: 1 g = 9.81 m/s2 (acceleration of gravity). 1 mg = 1/1000 g


Status LEDs

Product overview [image] EPP1816-3008 [image] Status LEDs
Status LEDs
Status LEDs of EPP1816
LED Displays
LED | Display | Meaning
STATUS 1-8 | green illuminated | a signal (24 V) is present at one or more inputs of channels 1 to 8
STATUS 9-16 | green illuminated | a signal (24 V) is present at one or more inputs of channels 9 to 16
US | off | Supply voltage US is not present
 | green illuminated | Supply voltage US is present
UP | off | Supply voltage UP is not present
 | green illuminated | Supply voltage UP is present


Process image

Product overview [image] EPP1816-3008 [image] Process image
Process image
Process image in TwinCAT | Connector | Contact | Input variable
EPP1816-3008 | X01 | 3 | TC3 InputPDO Symbol DIG Inputs Channel 1 TC3 InputVariable Symbol indent Input 1
 |  | 4 | TC3 InputPDO Symbol DIG Inputs Channel 1 TC3 InputVariable Symbol indent Input 2
 |  | 5 | TC3 InputPDO Symbol DIG Inputs Channel 1 TC3 InputVariable Symbol indent Input 3
 |  | 6 | TC3 InputPDO Symbol DIG Inputs Channel 1 TC3 InputVariable Symbol indent Input 4
 |  | 7 | TC3 InputPDO Symbol DIG Inputs Channel 1 TC3 InputVariable Symbol indent Input 5
 |  | 8 | TC3 InputPDO Symbol DIG Inputs Channel 1 TC3 InputVariable Symbol indent Input 6
 |  | 9 | TC3 InputPDO Symbol DIG Inputs Channel 1 TC3 InputVariable Symbol indent Input 7
 |  | 10 | TC3 InputPDO Symbol DIG Inputs Channel 1 TC3 InputVariable Symbol indent Input 8
 |  | 11 | TC3 InputPDO Symbol DIG Inputs Channel 2 TC3 InputVariable Symbol indent Input 1
 |  | 12 | TC3 InputPDO Symbol DIG Inputs Channel 2 TC3 InputVariable Symbol indent Input 2
 |  | 13 | TC3 InputPDO Symbol DIG Inputs Channel 2 TC3 InputVariable Symbol indent Input 3
 |  | 14 | TC3 InputPDO Symbol DIG Inputs Channel 2 TC3 InputVariable Symbol indent Input 4
 |  | 15 | TC3 InputPDO Symbol DIG Inputs Channel 2 TC3 InputVariable Symbol indent Input 5
 |  | 16 | TC3 InputPDO Symbol DIG Inputs Channel 2 TC3 InputVariable Symbol indent Input 6
 |  | 17 | TC3 InputPDO Symbol DIG Inputs Channel 2 TC3 InputVariable Symbol indent Input 7
 |  | 18 | TC3 InputPDO Symbol DIG Inputs Channel 2 TC3 InputVariable Symbol indent Input 8


Scope of supply

Product overview [image] EPP1816-3008 [image] Scope of supply
Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EPP1816-3008 EtherCAT P Box
▪
2x protective cap for EtherCAT P socket, M8, red (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


Mounting and cabling

Mounting and cabling
Mounting and cabling
Additional information
•
Mounting
•
EtherCAT P
•
Digital inputs
•
UL Requirements


Mounting

Mounting and cabling [image] Mounting
Mounting
Additional information
•
Dimensions
•
Mounting
•
Functional earth (FE)
•
Tightening torques for plug connectors


Dimensions

Mounting and cabling [image] Mounting [image] Dimensions
Dimensions
Housing -000x and -0010
Dimensions
All dimensions are given in millimeters.
Housing features
Housing material | PA6 (polyamide)
Sealing compound | polyurethane
Mounting | two fastening holes Ø 3.5 mm for M3
Metal parts | brass, nickel-plated
Contacts | CuZn, gold-plated
Installation position | variable
Protection class | IP65, IP66, IP67 (conforms to EN 60529) when screwed together
Dimensions (H x W x D) | approx. 126 x 30 x 26.5 mm (without connectors)
Weight | approx. 165 g
Housing -002x
Dimensions
All dimensions are given in millimeters.
Housing features
Housing material | PA6 (polyamide)
Sealing compound | polyurethane
Mounting | two fastening holes Ø 4.5 mm for M4
Metal parts | brass, nickel-plated
Contacts | CuZn, gold-plated
Installation position | variable
Protection class | IP65, IP66, IP67 (conforms to EN 60529) when screwed together
Dimensions (H x W x D) | approx. 126 x 60 x 26.5 mm
Weight | approx. 250 g
Housing -0061
Dimensions
All dimensions are given in millimeters.
Housing features
Housing material | PA6 (polyamide)
Sealing compound | polyurethane
Mounting | two fastening holes Ø 3.5 mm for M3
Metal parts | brass, nickel-plated
Contacts | CuZn, gold-plated
Installation position | variable
Protection class | IP65, IP66, IP67 (conforms to EN 60529) when screwed together
Dimensions (H x W x D) | approx. 86 x 30 x 22 mm
Weight | approx. 90 g


Mounting

Mounting and cabling [image] Mounting [image] Mounting
Mounting
Note
Dirt during assembly
Dirty connectors can lead to malfunctions. Protection class IP67 can only be guaranteed if all cables and connectors are connected.
•
Protect the plug connectors against dirt during the assembly.
Housing -000x, -0010, -0061
Mount the module with two M3 screws on the fastening holes in the corners of the module. The fastening holes have no thread.
Housing -002x
Mount the module with two M4 screws in the centrally located fastening holes.


Functional earth (FE)

Mounting and cabling [image] Mounting [image] Functional earth (FE)
Functional earth (FE)
Housing -000x, -0010, -0061
The upper fastening hole also serves as a connection for functional earth (FE).
Make sure that the box is grounded to low impedance via the functional earth (FE) connection. You can achieve this, for example, by mounting the box on a grounded machine bed.
Connection for functional earth (FE)
Housing -002x
The fastening holes also serve as connections for the functional earth (FE).
Make sure that the box is grounded to low impedance via the functional earth (FE) connections. You can achieve this, for example, by mounting the box on a grounded machine bed.
Connection for functional earth (FE)


Tightening torques for plug connectors

Mounting and cabling [image] Mounting [image] Tightening torques for plug connectors
Tightening torques for plug connectors
Screw connectors tight with a torque wrench. (e.g. ZB8801 from Beckhoff)
Connector diameter | Tightening torque
M8 | 0.4 Nm
M12 | 0.6 Nm


EtherCAT P

Mounting and cabling [image] EtherCAT P
EtherCAT P
Additional information
•
Connectors
•
Status LEDs
•
Conductor losses


Connectors

Mounting and cabling [image] EtherCAT P [image] Connectors
Connectors
Note
Risk of damage to the device!
Bring the EtherCAT/EtherCAT P system into a safe, powered down state before starting installation, disassembly or wiring of the modules!
Note
Pay attention to the maximum permissible current!
Pay attention also for the redirection of EtherCAT P, the maximum permissible current for M8 connectors of 3 A must not be exceeded!
EtherCAT P is supplied and forwarded via two M8 sockets at the upper end of the modules:
▪
IN: left M8 socket for EtherCAT P power supply
▪
OUT: right M8 socket for EtherCAT P forwarding
Connectors for EtherCAT P
M8 socket EPP connection
M8 socket, P-coded
Contact | Signal | Voltage | Core color 1)
1 | Tx + | GNDS | yellow
2 | Rx + | GNDP | white
3 | Rx - | UP: Peripheral voltage, +24 VDC | blue
4 | Tx - | US: Control voltage, +24 VDC | orange
Housing | Shield | Shield | Shield
1) The core colors apply to EtherCAT P cables and ECP cables from Beckhoff.


Status LEDs

Mounting and cabling [image] EtherCAT P [image] Status LEDs
Status LEDs
Additional information
•
Supply voltage
•
EtherCAT


Supply voltage

Mounting and cabling [image] EtherCAT P [image] Status LEDs [image] Supply voltage
Supply voltage
Status LEDs for the power supply
EtherCAT P Box Modules have two LEDs that display the status of the supply voltages. The status LEDs are labelled with the designations of the supply voltages: Us and Up.
A status LED lights up green when the respective supply voltage is present.
A Status LED lights up red if the respective supply voltage is short-circuited.


EtherCAT

Mounting and cabling [image] EtherCAT P [image] Status LEDs [image] EtherCAT
EtherCAT
Status LEDs for EtherCAT
L/A (Link/Act)
A green LED labelled "L/A" or “Link/Act” is located next to each EtherCAT/EtherCAT P socket. The LED indicates the communication state of the respective socket:
LED | Meaning
off | no connection to the connected EtherCAT device
lit | LINK: connection to the connected EtherCAT device
flashes | ACT: communication with the connected EtherCAT device
Run
Each EtherCAT slave has a green LED labelled "Run". The LED signals the status of the slave in the EtherCAT network:
LED | Meaning
off | Slave is in "Init" state
flashes uniformly | Slave is in "Pre-Operational“ state
flashes sporadically | Slave is in "Safe-Operational" state
lit | Slave is in "Operational" state
Description of the EtherCAT slave states


Conductor losses

Mounting and cabling [image] EtherCAT P [image] Conductor losses
Conductor losses
Take into account the voltage drop on the supply line when planning a system. Avoid the voltage drop being so high that the supply voltage at the box lies below the minimum nominal voltage.
Variations in the voltage of the power supply unit must also be taken into account.
Use the planning tool for EtherCAT P in TwinCAT.
Voltage drop on the supply line
Leitungsverluste M8-EPP 3A
Voltage drop on the supply line


Digital inputs

Mounting and cabling [image] Digital inputs
Digital inputs
Note
Supply and connection of sensor/actuator to the EPP boxes
The connected sensors/actuators must be powered by an EPP box! GNDS and GNDP from an M8/M12 signal connection of an EPP box must not be connected to the machine bed!
Supply of remote powered sensors/actuators
If the sensors/actuators cannot be supplied from the EPP box the supply of remote powered sensors/actuators must be galvanically isolated!
Additional information
•
M8 sockets
•
M12 sockets
•
Pluggable spring-loaded terminals
•
D-sub sockets, 25-pin


M8 sockets

Mounting and cabling [image] Digital inputs [image] M8 sockets
M8 sockets
Pin assignment
M8 socket 3-pole, 10mm indented
M8 socket, 3-pin
Pin | Function | Core color 1)
1 | US1 2) | brown
3 | GNDS | blue
4 | Input | black
1) The wire colors apply to 3-wire M8 cables from Beckhoff: ZK2000-2xxx
2) US1 serves as sensor supply voltage. It is branched off from the US supply voltage.
Connection examples
Digital inputs M8, connection examples
Status LEDs
There is a green LED next to each M8 socket. The LED lights up when a high level is detected at the digital input.
Status LED at an M8 socket


M12 sockets

Mounting and cabling [image] Digital inputs [image] M12 sockets
M12 sockets
M12 socket
Contact | EPP1xxx-0001 EPP1819-0022 | EPP1008-0022 | Core color 1)
1 | US1 2) | US1 2) | brown
2 | Input B | - | white
3 | GNDS | GNDS | blue
4 | Input A | Input | black
5 | - | - | grey
1) The core colors apply to M12 cables from Beckhoff:
▪
ZK2000-5xxx
▪
ZK2000-6xxx
▪
ZK2000-7xxx
2) US1 serves as sensor supply voltage. It is branched off from the US supply voltage.
Connection examples
Digital inputs M12, connection examples
Status LEDs
Each M12 socket has two green LEDs. An LED lights up when a high level is detected at the respective input.
Status-LEDs von M12-Buchsen
Status LEDs of M12 sockets


Pluggable spring-loaded terminals

Mounting and cabling [image] Digital inputs [image] Pluggable spring-loaded terminals
Pluggable spring-loaded terminals
Pin assignment
ZS2001
Contact | Function
0 | Input 1
1 | Input 2
2 | Input 3
3 | Input 4
4 | Input 5
5 | Input 6
6 | Input 7
7 | Input 8
"24" | US1
"0V" | GNDS
ZS2001-0004 has three rows with ten terminal contacts each. The first row is occupied as shown in the table. The second and third rows are designed to distribute the supply voltage and ground. See connection examples:
Connection examples
ZS2001 Digitale Eingänge, eingerückt
Digital inputs ZS2001, 8 channels
The diagram shows the connection of 8 sensors in single-wire technology as well as one sensor each in two-wire and three-wire technology.
Please note for ZS2001-0004 connectors: two bridges (24 V and 0 V) are required to supply the terminal points for two- and three-wire connection technology.
Status LEDs
ZS2001-0002 and ZS2001-0004 have a green status LED for each digital input. An LED lights up when a high level is detected at the corresponding input.


D-sub sockets, 25-pin

Mounting and cabling [image] Digital inputs [image] D-sub sockets, 25-pin
D-sub sockets, 25-pin
D-Sub25-Buchse, 10mm eingerückt
D-sub socket, 25-pin
Contact | EPP1816-0008 | EPP1816-3008
1 | Channel 1, Input 1 | US1 1)
2 | Channel 1, Input 2 | GNDS
3 | Channel 1, Input 3 | Channel 1, Input 1
4 | Channel 1, Input 4 | Channel 1, Input 2
5 | Channel 1, Input 5 | Channel 1, Input 3
6 | Channel 1, Input 6 | Channel 1, Input 4
7 | Channel 1, Input 7 | Channel 1, Input 5
8 | Channel 1, Input 8 | Channel 1, Input 6
9 | Channel 2, Input 1 | Channel 1, Input 7
10 | Channel 2, Input 2 | Channel 1, Input 8
11 | Channel 2, Input 3 | Channel 2, Input 1
12 | Channel 2, Input 4 | Channel 2, Input 2
13 | Channel 2, Input 5 | Channel 2, Input 3
14 | Channel 2, Input 6 | Channel 2, Input 4
15 | Channel 2, Input 7 | Channel 2, Input 5
16 | Channel 2, Input 8 | Channel 2, Input 6
17 | US1 1) | Channel 2, Input 7
18 | US1 1) | Channel 2, Input 8
19 | US1 1) | US1 1)
20 | US1 1) | US1 1)
21 | US1 1) | US1 1)
22 | US1 1) | US1 1)
23 | GNDS | GNDS
24 | GNDS | GNDS
25 | GNDS | GNDS
1) US1 serves as sensor supply voltage. It is branched off from the US supply voltage.


UL Requirements

Mounting and cabling [image] UL Requirements
UL Requirements
The installation of the EtherCAT Box Modules certified by UL has to meet the following requirements.
Supply voltage
SmallWarningYellow CAUTION
CAUTION!
This UL requirements are valid for all supply voltages of all marked EtherCAT Box Modules!
For the compliance of the UL requirements the EtherCAT Box Modules should only be supplied
•
by a 24 VDC supply voltage, supplied by an isolating source and protected by means of a fuse (in accordance with UL248), rated maximum 4 Amp, or
•
by a 24 VDC power source, that has to satisfy NEC class 2.
A NEC class 2 power supply shall not be connected in series or parallel with another (class 2) power source!
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, the EtherCAT Box Modules must not be connected to unlimited power sources!
Networks
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, EtherCAT Box Modules must not be connected to telecommunication networks!
Ambient temperature range
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, EtherCAT Box Modules has to be operated only at an ambient temperature range of 0 to 55°C!
Marking for UL
All EtherCAT Box Modules certified by UL (Underwriters Laboratories) are marked with the following label.
UL label


Commissioning/Configuration

Commissioning/Configuration
Commissioning/Configuration
Additional information
•
Integration in TwinCAT
•
Timestamp inputs (EPP1258)
•
Accelerometers (EPP1816-3008)
•
Undervoltage detection (EPP1816-3008)
•
EPP1816-0008 - Object description and parameterization
•
Restoring the delivery state
•
Decommissioning


Integration in TwinCAT

Commissioning/Configuration [image] Integration in TwinCAT
Integration in TwinCAT
The procedure for integration in TwinCAT is described in this Quick start guide.


Timestamp inputs (EPP1258)

Commissioning/Configuration [image] Timestamp inputs (EPP1258)
Timestamp inputs (EPP1258)
Timestamp inputs are digital inputs that log the times of signal edges with high temporal resolution.
A timestamp input provides two timestamps in variables:
▪
Timestamp of the last recorded rising signal edge
▪
Timestamp of the last recorded falling signal edge
At each signal edge the corresponding variable is overwritten with the current timestamp.
Variables are always read in by the PLC at the beginning of a PLC cycle. If several signal edges occur within a PLC cycle, the PLC receives only the timestamps of the last rising and the last falling signal edge at the beginning of the following PLC cycle.
Application Note DK9222-0211-0021 contains further information on timestamp inputs.
Variables in the process image
Variable
Contents
Input X01
Input X02
TC3 InputPDO Symbol Channel 1
TC3 InputVariable Symbol indent Input
TC3 InputPDO Symbol Channel 2
TC3 InputVariable Symbol indent Input
Signal level that is currently present at the digital input
TC3 InputPDO Symbol Latch
TC3 InputVariable Symbol indent Status0
TC3 InputPDO Symbol Latch
TC3 InputVariable Symbol indent Status1
Information as to whether the last recorded signal edge was a rising or a falling signal edge:
Bit 3:
▪
Bit 3 is set on rising signal edge
▪
Bit 3 is cleared on falling signal edge
TC3 InputPDO Symbol Latch
TC3 InputVariable Symbol indent LatchPos0
TC3 InputPDO Symbol Latch
TC3 InputVariable Symbol indent LatchPos1
Timestamp of the last recorded rising signal edge.
Representation: 1 ns / LSB
TC3 InputPDO Symbol Latch
TC3 InputVariable Symbol indent LatchNeg0
TC3 InputPDO Symbol Latch
TC3 InputVariable Symbol indent LatchNeg1
Timestamp of the last recorded falling signal edge.
Representation: 1 ns / LSB


Accelerometers (EPP1816-3008)

Commissioning/Configuration [image] Accelerometers (EPP1816-3008)
Accelerometers (EPP1816-3008)
EPP1816-3008 has two accelerometers. Each accelerometer measures the acceleration in three axes.
The accelerometers are offset by 90°. This enables a plausibility check of the measured values.
EPP1816-3008 can also convert the measured values into inclination angles: Presentation of the measured values.
Assignment of the acceleration axes to variables in the process image
EPP1816-3008 acceleration axes
Acceleration axes of EPP1816-3008
Assignment of the inclination axes to variables in the process image
EPP1816-3008 inclination axes
Inclination axes of EPP1816-3008
Additional information
•
Parameters


Parameters

Commissioning/Configuration [image] Accelerometers (EPP1816-3008) [image] Parameters
Parameters
Measuring range
CoE index 8080:11 „Range“
Value | Measuring range
03dec (default) | +/- 2 g
04dec | +/- 4 g
05dec | +/- 8 g
06dec | +/- 16 g
Sampling rate
CoE index 8080:0D „Mode“
Value | Sampling rate
04dec | 1 Hz
05dec | 10 Hz
06dec | 25 Hz
07dec | 50 Hz
08dec | 100 Hz
09dec | 250 Hz
10dec | 400 Hz
11dec | 1600 Hz
12dec (default) | 5000 Hz
Presentation of the measured values
CoE index 8080:1D „Presentation“
Value | Format designation | Description
03dec (default) | Raw Values | The measured acceleration values are output as raw values.
04dec | Horizontal Off-Axis Angle | The measured acceleration values are converted into inclination angles.
05dec | milli G (mG) | The measured acceleration values are output in mg.


Undervoltage detection (EPP1816-3008)

Commissioning/Configuration [image] Undervoltage detection (EPP1816-3008)
Undervoltage detection (EPP1816-3008)
Variables in the process image
In case of undervoltage of US or UP, the corresponding bit in the process image is set:


EPP1816-0008 - Object description and parameterization

Commissioning/Configuration [image] EPP1816-0008 - Object description and parameterization
EPP1816-0008 - Object description and parameterization
Parameterization
The terminal/box can be parameterized via the "CoE – Online" tab (by double-clicking on the corresponding object) or via the Process Data tab (assignment of PDOs).
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website (http://beckhoff.de/german/download/elconfg.htm?id=1983920606140) and installing it according to the installation instructions.
Introduction
The CoE overview contains objects for different intended applications:
▪
Objects required for parameterization during commissioning
▪
Objects intended for regular operation, e.g. through ADS access
▪
Objects for indicating internal settings (may be fixed)
The following section first describes the objects required for normal operation, followed by a complete overview of missing objects.
Objects to be parameterized during commissioning
Objects to be parameterized during commissioning
Index 1011 Restore default parameters
Index | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default settings | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to 0x64616F6C in the set value dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)
Objects for regular operation
The EPP1816 has no such objects.
Additional objects
Standard objects (0x1000-0x1FFF)
The standard objects have the same meaning for all EtherCAT P slaves.
Index 1000 Device type
Index | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT P slave: The Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x01181389 (18355081dec)
Index 1008 Device name
Index | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT P slave | string | RO | EPP1816-0008
Index 1009 Hardware version
Index | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT P slave | string | RO | 00
Index 100A Software version
Index | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT P slave | string | RO | 01
Index 1018 Identity
Index | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Manufacturer ID of the EtherCAT P slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT P slave | UINT32 | RO | 0x07184052 (119029842dec)
1018:03 | Revision | Revision number of the EtherCAT P slave; the Low Word (bit 0-15) indicates the special terminal number, the High Word (bit 16-31) refers to the device description | UINT32 | RO | 0x00100008 (1048584dec)
1018:04 | Serial number | Serial number of the EtherCAT P slave; the Low Byte (bit 0-7) of the Low Word contains the year of production, the High Byte (bit 8-15) of the Low Word contains the week of production, the High Word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 Backup parameter handling
Index | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | Information for standardized loading and saving of backup entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum across all backup entries of the EtherCAT P slave | UINT32 | RO | 0x00000000 (0dec)
Index 1A00 DO TxPDO-Map Inputs Ch.1
Index | Name | Meaning | Data type | Flags | Default
1A00:0 | DO TxPDO-Map Inputs Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x0B (11dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x01 (Input 1)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x02 (Input 2)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x03 (Input 3)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x04 (Input 4)) | UINT32 | RO | 0x6000:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x05 (Input 5)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x06 (Input 6)) | UINT32 | RO | 0x6000:06, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x07 (Input 7)) | UINT32 | RO | 0x6000:07, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x08 (Input 8)) | UINT32 | RO | 0x6000:08, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x1C32, entry 0x20) | UINT32 | RO | 0x1C32:20, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
Index 1A01 DO TxPDO-Map Inputs Ch.2
Index | Name | Meaning | Data type | Flags | Default
1A01:0 | DO TxPDO-Map Inputs Ch.2 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x0B (11dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DO Inputs Ch.2), entry 0x01 (Input 1)) | UINT32 | RO | 0x6010:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (DO Inputs Ch.2), entry 0x02 (Input 2)) | UINT32 | RO | 0x6010:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (DO Inputs Ch.2), entry 0x03 (Input 3)) | UINT32 | RO | 0x6010:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (DO Inputs Ch.2), entry 0x04 (Input 4)) | UINT32 | RO | 0x6010:04, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (DO Inputs Ch.2), entry 0x05 (Input 5)) | UINT32 | RO | 0x6010:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (DO Inputs Ch.2), entry 0x06 (Input 6)) | UINT32 | RO | 0x6010:06, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (DO Inputs Ch.2), entry 0x07 (Input 7)) | UINT32 | RO | 0x6010:07, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (DO Inputs Ch.2), entry 0x08 (Input 8)) | UINT32 | RO | 0x6010:08, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x1C32, entry 0x20) | UINT32 | RO | 0x1C32:20, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
Index 1C00 Sync manager type
Index | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the Sync Managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign
Index | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RO | 0x00 (0dec)
Index 1C13 TxPDO assign
Index | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RO | 0x02 (2dec)
1C13:01 | Subindex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RO | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RO | 0x1A01 (6657dec)
Index 1C33 SM input parameter
Index
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (no outputs available)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (outputs available)
UINT16
RW
0x0022 (34dec)
1C33:02
Cycle time
Cycle time (in ns):
▪
Synchron with SM 2 Event: Master cycle time
▪
DC mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000186A0 (100000dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: Synchron with SM 2 Event is supported (outputs available)
▪
Bit 1: Synchron with SM 3 Event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: Input Shift through local event (outputs available)
▪
Bit 4-5 = 10: Input Shift with SYNC1 Event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 1C33:08)
UINT16
RO
0xC007 (49159dec)
1C33:05
Minimum cycle time
Minimum cycle time (in ns)
UINT32
RO
0x000124F8 (75000dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:08
Command
▪
0: Measurement of the local cycle time is stopped
▪
1: Measurement of the local cycle time is started
The entries 1C33:03, 1C33:06, 1C33:07, 1C33:09 are updated with the maximum measured values.
For a subsequent measurement the measured values are reset
UINT16
RW
0x0000 (0dec)
1C33:09
Delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:0B
SM event missed counter
Number of missed SM events in OPERATIONAL (DC mode only)
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
Number of occasions the cycle time was exceeded in OPERATIONAL (cycle was not completed in time or the next cycle began too early)
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
Number of occasions that the interval between SYNC0 and SYNC1 event was too short (DC mode only)
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
The synchronization was not correct in the last cycle (outputs were output too late; DC mode only)
boolean
RO
0x00 (0dec)
Profile-specific objects (0x6000-0xFFFF)
The profile-specific objects have the same meaning for all EtherCAT slaves that support the profile 5001.
Index 6000 DO Inputs Ch.1
Index | Name | Meaning | Data type | Flags | Default
6000:0 | DO Inputs Ch.1 |  | UINT8 | RO | 0x0E (14dec)
6000:01 | Input 1 |  | boolean | RO | 0x00 (0dec)
6000:02 | Input 2 |  | boolean | RO | 0x00 (0dec)
6000:03 | Input 3 |  | boolean | RO | 0x00 (0dec)
6000:04 | Input 4 |  | boolean | RO | 0x00 (0dec)
6000:05 | Input 5 |  | boolean | RO | 0x00 (0dec)
6000:06 | Input 6 |  | boolean | RO | 0x00 (0dec)
6000:07 | Input 7 |  | boolean | RO | 0x00 (0dec)
6000:08 | Input 8 |  | boolean | RO | 0x00 (0dec)
6000:0E | Sync Error |  | boolean | RO | 0x00 (0dec)
Index 6010 DO Inputs Ch.2
Index | Name | Meaning | Data type | Flags | Default
6010:0 | DO Inputs Ch.2 |  | UINT8 | RO | 0x0E (14dec)
6010:01 | Input 1 |  | boolean | RO | 0x00 (0dec)
6010:02 | Input 2 |  | boolean | RO | 0x00 (0dec)
6010:03 | Input 3 |  | boolean | RO | 0x00 (0dec)
6010:04 | Input 4 |  | boolean | RO | 0x00 (0dec)
6010:05 | Input 5 |  | boolean | RO | 0x00 (0dec)
6010:06 | Input 6 |  | boolean | RO | 0x00 (0dec)
6010:07 | Input 7 |  | boolean | RO | 0x00 (0dec)
6010:08 | Input 8 |  | boolean | RO | 0x00 (0dec)
6010:0E | Sync Error |  | boolean | RO | 0x00 (0dec)
Index F000 Modular device profile
Index | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0002 (2dec)
Index F008 Code word
Index | Name | Meaning | Data type | Flags | Default
F008:0 | Code word |  | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module list
Index | Name | Meaning | Data type | Flags | Default
F010:0 | Module list |  | UINT8 | RW | 0x02 (2dec)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x00000118 (280dec)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x00000118 (280dec)


Restoring the delivery state

Commissioning/Configuration [image] Restoring the delivery state
Restoring the delivery state
The CoE object Restore default parameters, Subindex 001 can be selected in the TwinCAT System Manager (Config mode) in order to restore the delivery state of the back-up objects for the EPPxxxx Boxes.
Selecting the PDO restore default parameter
Double-click on SubIndex 001 to enter the Set Value dialog. Enter the value 1684107116 in the field Dec or alternatively the value 0x64616F6C in the field Hex and confirm with OK.
All backup objects are reset to the delivery state.
Entering a restore value in the Set Value dialog
Alternative restore value
With some older modules the backup objects can be changed with an alternative restore value:
Decimal value: 1819238756
Hexadecimal value: 0x6C6F6164
An incorrect entry for the restore value has no effect.


Decommissioning

Commissioning/Configuration [image] Decommissioning
Decommissioning
SmallWarningYellow WARNING
Risk of electric shock!
Bring the bus system into a safe, de-energized state before starting disassembly of the devices!
Disposal
In order to dispose of the device, it must be removed.
In accordance with the WEEE Directive 2012/19/EU, Beckhoff takes back old devices and accessories in Germany for proper disposal. Transport costs will be borne by the sender.
Return the old devices with the note "for disposal" to:
Beckhoff Automation GmbH & Co. KG
Service Department
Stahlstraße 31
D-33415 Verl


Appendix

Appendix
Appendix
Additional information
•
General operating conditions
•
Accessories
•
Version identification of EtherCAT devices
•
Support and Service


General operating conditions

Appendix [image] General operating conditions
General operating conditions
Protection degrees (IP-Code)
The standard IEC 60529 (DIN EN 60529) defines the degrees of protection in different classes.
1. Number: dust protection and touch guard | Definition
0 | Non-protected
1 | Protected against access to hazardous parts with the back of a hand. Protected against solid foreign objects of Ø 50 mm
2 | Protected against access to hazardous parts with a finger. Protected against solid foreign objects of Ø 12.5 mm.
3 | Protected against access to hazardous parts with a tool. Protected against solid foreign objects Ø 2.5 mm.
4 | Protected against access to hazardous parts with a wire. Protected against solid foreign objects Ø 1 mm.
5 | Protected against access to hazardous parts with a wire. Dust-protected. Intrusion of dust is not totally prevented, but dust shall not penetrate in a quantity to interfere with satisfactory operation of the device or to impair safety.
6 | Protected against access to hazardous parts with a wire. Dust-tight. No intrusion of dust.
2. Number: water* protection | Definition
0 | Non-protected
1 | Protected against water drops
2 | Protected against water drops when enclosure tilted up to 15°.
3 | Protected against spraying water. Water sprayed at an angle up to 60° on either side of the vertical shall have no harmful effects.
4 | Protected against splashing water. Water splashed against the disclosure from any direction shall have no harmful effects
5 | Protected against water jets
6 | Protected against powerful water jets
7 | Protected against the effects of temporary immersion in water. Intrusion of water in quantities causing harmful effects shall not be possible when the enclosure is temporarily immersed in water for 30 min. in 1 m depth.
*) These protection classes define only protection against water!
Chemical Resistance
The Resistance relates to the Housing of the IP 67 modules and the used metal parts. In the table below you will find some typical resistance.
Character | Resistance
Steam | at temperatures >100°C: not resistant
Sodium base liquor (ph-Value > 12) | at room temperature: resistant > 40°C: not resistant
Acetic acid | not resistant
Argon (technical clean) | resistant
Key
▪
resistant: Lifetime several months
▪
non inherently resistant: Lifetime several weeks
▪
not resistant: Lifetime several hours resp. early decomposition


Accessories

Appendix [image] Accessories
Accessories
Mounting
Ordering information | Description
ZS5300-0001 | Mounting rail (500 mm x 129 mm)
Labeling material, protective caps
Ordering information | Description
ZS5000-0000 | Fieldbus box set M8: Inscription labels, protective caps
ZS5000-0002 | Fieldbus box set M12: Inscription labels, protective caps
ZS5000-0010 | Protective cap M8, IP67 (50 pieces)
ZS5000-0020 | Protective cap M12, IP67 (50 pieces)
ZS5100-0000 | Inscription labels, unprinted, 4 strips of 10
ZS5000-xxxx | Printed inscription labels on enquiry
Tool
Ordering information | Description
ZB8801-0000 | Torque wrench for plugs, 0.4…1.0 Nm
ZB8801-0001 | Torque cable key for M8 / wrench size 9 for ZB8801-0000
ZB8801-0002 | Torque cable key for M12 / wrench size 13 for ZB8801-0000
ZB8801-0003 | Torque cable key for M12 field assembly / wrench size 18 for ZB8801-0000
Further accessories
Further accessories can be found in the price list for fieldbus components from Beckhoff and online at https://www.beckhoff.de.


Version identification of EtherCAT devices

Appendix [image] Version identification of EtherCAT devices
Version identification of EtherCAT devices
Designation
A Beckhoff EtherCAT device has a 14-digit designation, made up of
▪
family key
▪
type
▪
version
▪
revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
Notes
▪
The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
▪
EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
▪
The order identifier is made up of
- family key (EL, EP, CU, ES, KL, CX, etc.)
- type (3314)
- version (-0000)
▪
The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
▪
The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Identification number
Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:
Production lot/batch number/serial number/date code/D number
The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02
Exceptions can occur in the IP67 area, where the following syntax can be used (see respective device documentation):
Syntax: D ww yy x y z u
D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB
Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1
Unique serial number/ID, ID number
In addition, in some series each individual module has its own unique serial number.
See also the further documentation in the area
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Terminals with factory calibration certificate and other measuring terminals
Examples of markings
EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
CU2016 switch with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
EP1258-00001 IP67 EtherCAT Box with batch number/ date code 22090101 and unique serial number 158102
EP1908-0002 IP67 EtherCAT Safety Box with batch number/ date code 071201FF and unique serial number 00346070
EL2904 IP20 safety terminal with batch number/ date code 50110302 and unique serial number 00331701
ELM3604-0002 terminal with unique ID number (QR code) 100001051 and serial/ batch number 44160201
Additional information
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Appendix [image] Version identification of EtherCAT devices [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com