EPP1332, EPP1342 - EtherCAT P junction
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
1.2
▪
Front page updated
▪
Scope of supply added
▪
Structure update
1.1
▪
UL and Atex chapters removed
▪
EPP1322-0001 moved to separate documentation
▪
Chapter "Feed-in" added
1.0.9
▪
Preliminary version
1.0.2
▪
EtherCAT P - Calculating cable length, voltage and current added
▪
Cabling updated
▪
Additional checks added
1.0.1
▪
EtherCAT P connection updated
1.0.0
▪
First release
0.5
▪
First preliminary version
Firmware and hardware versions
This documentation refers to the firmware and hardware version that was applicable at the time the documentation was written.
The module features are continuously improved and developed further. Modules having earlier production statuses cannot have the same properties as modules with the latest status. However, existing properties are retained and are not changed, so that older modules can always be replaced with new ones.
The firmware and hardware version (delivery state) can be found in the batch number (D-number) printed on the side of the EtherCAT Box.
Syntax of the batch number (D-number)
D: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with D no. 29 10 02 01:
29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01
Further information on this topic: Version identification of EtherCAT devices.


Product group: EtherCAT P Box modules

Product group: EtherCAT P Box modules
Product group: EtherCAT P Box modules
EtherCAT P
EtherCAT P supplements the EtherCAT technology with a process in which communication and supply voltages are transmitted on a common line. All EtherCAT properties are retained with this process.
Two supply voltages are transmitted per EtherCAT P line. The supply voltages are electrically isolated from each other and can therefore be switched individually. The nominal supply voltage for both is 24 VDC.
EtherCAT P uses the same cable structure as EtherCAT: a 4-core Ethernet cable with M8 connectors. The connectors are mechanically coded so that EtherCAT connectors and EtherCAT P connectors cannot be interchanged.
EtherCAT P Box modules
EtherCAT P Box modules are EtherCAT P slaves with IP67 protection. They are designed for operation in wet, dirty or dusty industrial environments.
EtherCAT P Einführung
EtherCAT P
EtherCAT basics
A detailed description of the EtherCAT system can be found in the EtherCAT system documentation.


Product overview

Product overview
Product overview
Additional information
•
EPP1332-0001
•
EPP1342-0001
•
Technical data
•
Process image


EPP1332-0001

Product overview [image] EPP1332-0001
EPP1332-0001
EPP1332-0001
EPP1332-0001 | EtherCAT P junction with refresh
The EPP1332-0001 EtherCAT P Box has two functions in an EtherCAT P network:
▪
Junction: EPP1332-0001 distributes the incoming EtherCAT P signal to three output ports.
▪
Feed-in point for refreshing the supply voltages.
A refresh of the supply voltages may be necessary in EtherCAT P networks with long cables and/or high output currents. It prevents:
▪
the supply voltages falling below the permissible minimum due to line losses.
▪
the current carrying capacity of the EtherCAT P cables being exceeded by high output currents.
A planning tool for EtherCAT P networks integrated in TwinCAT provides support for deciding where in the network a refresh of the supply voltages should be applied.
Additional information
•
Scope of supply


Scope of supply

Product overview [image] EPP1332-0001 [image] Scope of supply
Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EtherCAT P Box EPP1332-0001
▪
4x protective cap for EtherCAT P socket, M8, red (pre-assembled)
▪
1x protective cap for supply voltage input, M8, transparent (pre-assembled)
▪
1x protective cap for supply voltage output, M8, black (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


EPP1342-0001

Product overview [image] EPP1342-0001
EPP1342-0001
EPP1342-0001 web + block diagram
EPP1342-0001
EPP1342-0001 | EtherCAT P junction
The EPP1342-0001 EtherCAT P Box distributes the incoming EtherCAT P signal to three output ports.
Additional information
•
Scope of supply


Scope of supply

Product overview [image] EPP1342-0001 [image] Scope of supply
Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EtherCAT P Box EPP1342-0001
▪
4x protective cap for EtherCAT P socket, M8, red (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


Technical data

Product overview [image] Technical data
Technical data
Technical data | EPP1332-0001 | EPP1342-0001
Task in the EtherCAT system | 3-port EtherCAT P junction and refresh for US and UP | 3-port EtherCAT P junction
Fieldbus | EtherCAT
Bus interface | M8 socket, shielded, screw-type, 4-pin, EtherCAT P-coded
Number of channels | IN: 1 x EtherCAT P, OUT: 3 x EtherCAT P | IN: 1 x EtherCAT P, OUT: 3 x EtherCAT P
Nominal input voltage | 24 VDC (-15%/+20%)
Sum current | Max. current 3 A per US and UP | no power supply
Power supply connection | feed: 1 x M8 plug, 4-pin; downstream connection: 1 x M8 socket, 4-pin | not required
Current carrying capacity per EtherCAT P port | max. 3 A per US and UP
Supply of the module electronics | From the control voltage US, via the feed connector X60. | From the control voltage US, via the EtherCAT P port X50.
Current consumption of the module electronics | typically 65 mA + load
Permissible ambient temperature during operation | -25 °C to +60 °C
Permissible ambient temperature during storage | -40 °C to +85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27; see also Additional checks.
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Mounting position | variable
Approvals | CE
Additional checks
The boxes have been subjected to the following checks:
Verification | Explanation
Vibration | 10 frequency sweeps in 3 axes
 | 5 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 35 g, 11 ms


Process image

Product overview [image] Process image
Process image
The process image of the EPP1332-0001 and EPP1342-0001 modules is identical. The process image of EPP1332-0001 is shown here as an example.
Process image of EPP1332-0001


Mounting and cabling

Mounting and cabling
Mounting and cabling
Additional information
•
Mounting
•
EtherCAT P
•
Power supply
•
Cabling


Mounting

Mounting and cabling [image] Mounting
Mounting
Additional information
•
Dimensions
•
Fixing
•
Functional earth (FE)
•
Tightening torques for plug connectors


Dimensions

Mounting and cabling [image] Mounting [image] Dimensions
Dimensions
Dimensions
All dimensions are given in millimeters.
Housing features
Housing material | PA6 (polyamide)
Sealing compound | polyurethane
Mounting | two fastening holes Ø 3.5 mm for M3
Metal parts | brass, nickel-plated
Contacts | CuZn, gold-plated
Installation position | variable
Protection class | IP65, IP66, IP67 (conforms to EN 60529) when screwed together
Dimensions (H x W x D) | approx. 126 x 30 x 26.5 mm (without connectors)
Weight | approx. 165 g


Fixing

Mounting and cabling [image] Mounting [image] Fixing
Fixing
Note
Dirt during assembly
Dirty connectors can lead to malfunctions. Protection class IP67 can only be guaranteed if all cables and connectors are connected.
•
Protect the plug connectors against dirt during the assembly.
Mount the module with two M3 screws on the fastening holes in the corners of the module. The fastening holes have no thread.


Functional earth (FE)

Mounting and cabling [image] Mounting [image] Functional earth (FE)
Functional earth (FE)
The upper fastening hole also serves as a connection for functional earth (FE).
Make sure that the box is grounded to low impedance via the functional earth (FE) connection. You can achieve this, for example, by mounting the box on a grounded machine bed.
Connection for functional earth (FE)


Tightening torques for plug connectors

Mounting and cabling [image] Mounting [image] Tightening torques for plug connectors
Tightening torques for plug connectors
Screw M8 connectors tight with a torque wrench. (e.g. ZB8801 from Beckhoff)
Torque: 0.4 Nm.


EtherCAT P

Mounting and cabling [image] EtherCAT P
EtherCAT P
Additional information
•
Connection
•
EtherCAT P LEDs
•
EtherCAT P cable conductor losses M8


Connection

Mounting and cabling [image] EtherCAT P [image] Connection
Connection
Note
Risk of damage to the device!
Bring the EtherCAT/EtherCAT P system into a safe, powered down state before starting installation, disassembly or wiring of the modules!
EtherCAT P is supplied and forwarded via two EtherCAT P-coded M8 connectors at the upper end of the modules:
▪
IN: left M8 connector in EtherCAT P coding for EtherCAT P power supply
▪
OUT: right M8 connector in EtherCAT P coding for EtherCAT P forwarding
EtherCAT P connector on EtherCAT P Box
EtherCAT P socket front reduced, 10mm indented
Pin assignment M8, EtherCAT P In and EtherCAT P Out
Pin assignment
The contacts of the EtherCAT P-coded M8 connectors have a maximum current capacity of 3 A.
Contact | Signal | Voltage | Core colors1)
1 | Tx + | GNDS | yellow
2 | Rx + | GNDP | white
3 | Rx - | UP: Peripheral voltage, +24 VDC | blue
4 | Tx - | US: control voltage +24 VDC | orange
Housing | Shield | Shield | Shield
1) The core colors apply to EtherCAT P cables and ECP cables from Beckhoff.
Note
Pay attention to the maximum permissible current!
Pay attention also for the redirection of EtherCAT P, the maximum permissible current for M8 connectors of 3 A must not be exceeded!


EtherCAT P LEDs

Mounting and cabling [image] EtherCAT P [image] EtherCAT P LEDs
EtherCAT P LEDs
EtherCAT P LEDs
LED display
LED | Display | Meaning
IN L/A | off | no connection to the preceding EtherCAT P module
 | Lit | LINK: connection to the preceding EtherCAT P module
 | flashing | ACT: Communication with the preceding EtherCAT P module
OUT L/A | off | no connection to the following EtherCAT P module
 | Lit | LINK: connection to the following EtherCAT P module
 | flashing | ACT: Communication with the following EtherCAT P module
Run | off | Status of the EtherCAT P module is Init
 | flashes quickly | Status of the EtherCAT P module is pre-operational
 | flashes slowly | Status of the EtherCAT P module is safe-operational
 | Lit | Status of the EtherCAT P module is operational
EtherCAT statuses
The various statuses in which an EtherCAT P module may be found are described in the Basic System Documentation for EtherCAT, which is available for download from our website (www.beckhoff.com) under Downloads.


EtherCAT P cable conductor losses M8

Mounting and cabling [image] EtherCAT P [image] EtherCAT P cable conductor losses M8
EtherCAT P cable conductor losses M8
When using ZK700x-xxxx-0xxx EtherCAT P cables it must be ensured that the voltage at the last device is not less than the minimum rated voltage of 20.4 V according to the standard. Variations in the output voltage from the power supply unit must also be taken into account. This ensures that the connected consumers, sensors and actuators are operated within the permitted voltage range.
The voltage calculation tool integrated in TwinCAT can be used for the offline calculation of the cable lengths.
The EPP9022-0060 box with diagnostics can be used for checking during operation.
Conductor losses on the EtherCAT P cables
Voltage drop EtherCAT P.png
Conductor losses on the EtherCAT P cables
Example
A 10 meter-long EtherCAT P cable with a cross section of 0.34 mm² has a voltage drop of ∼3.0 V with a load of 3 A.


Power supply

Mounting and cabling [image] Power supply
Power supply
Additional information
•
Feed-in
•
Status LEDs


Feed-in

Mounting and cabling [image] Power supply [image] Feed-in
Feed-in
Two M8 connectors at the bottom of the EtherCAT P Box are used for feeding and routing the supply voltages.
▪
IN (X60): left M8 connector for feeding the supply voltages
▪
OUT (X61): right M8 connector for routing the supply voltages
Connections for the supply voltages
Pin assignment
Contact | Voltage
1 | Control voltage Us, +24 VDC
2 | Peripheral voltage Up, +24 VDC
3 | GNDs
4 | GNDp
The contacts of the M8 connectors can conduct a maximum current of 4 A.
Control voltage US
Power is supplied to the fieldbus, the processor logic, the inputs and the sensors from the control voltage US. The control voltage is electrically isolated from the fieldbus circuitry.
Peripheral voltage UP
The peripheral voltage UP supplies the digital outputs; it can be brought in separately. Hence, if the peripheral voltage is switched off, the fieldbus function as well as the supply and function of the inputs are retained.
Redirection of the supply voltages
The IN and OUT power connections are bridged in the module (not IP204x-Bxxx and IE204x). The supply voltages US and UP can thus easily be transferred from EtherCAT Box to EtherCAT Box.
Note
Pay attention to the maximum permissible current!
Pay attention also for the redirection of the supply voltages US and UP, the maximum permissible current for M8 connectors of 4 A must not be exceeded!


Status LEDs

Mounting and cabling [image] Power supply [image] Status LEDs
Status LEDs
IP 67 modules have two status LEDs, which indicate the state of the supply voltages US and UP.
Status LEDs for US and UP
EPP1332-0001
The status LEDs of the EPP1332-0001 light up green when the supply voltages are applied to the M8 connector for the feed-in.
EPP1342-0001
The status LEDs of the EPP1342-0001 light up green when the supply voltages are applied to the incoming EtherCAT P port.


Cabling

Mounting and cabling [image] Cabling
Cabling
For connecting EtherCAT devices only shielded Ethernet cables that meet the requirements of at least category 5 (CAT5) according to EN 50173 or ISO/IEC 11801 should be used.
EtherCAT uses four wires for signal transmission.
Thanks to automatic line detection ("Auto MDI-X"), both symmetrical (1:1) or cross-over cables can be used between Beckhoff EtherCAT.
Detailed recommendations for the cabling of EtherCAT devices
A list of EtherCAT P cables, EtherCAT cables, power cables, sensor cables, Ethernet/EtherCAT connectors and field-configurable connectors can be found under the following link: https://beckhoff.de/english/ethercat-box/ethercat_box_cables.htm


Commissioning/Configuration

Commissioning/Configuration
Commissioning/Configuration
Additional information
•
Configuration in TwinCAT


Configuration in TwinCAT

Commissioning/Configuration [image] Configuration in TwinCAT
Configuration in TwinCAT
An EtherCAT P Box must be configured in TwinCAT to ensure that its functions can be used in a PLC program.
Under the following link you will find a quick start guide describing the configuration of an EtherCAT P Box in TwinCAT:
https://infosys.beckhoff.com/content/1033/epioconfiguration/index.html?id=6991403443235907429
Additional information
•
Assignment of connectors


Assignment of connectors

Commissioning/Configuration [image] Configuration in TwinCAT [image] Assignment of connectors
Assignment of connectors
This chapter describes the assignment of the connectors of EPP1332-0001 and EPP1342-0001 to their representation in TwinCAT. This assignment is required to correctly map an EtherCAT network in TwinCAT "offline" configuration.
An IO module that represents a Box in TwinCAT has four ports: A, B, C, D. Each port represents one connector. The following diagram shows the assignment of the connectors to the ports of an IO module in TwinCAT:
EPP1332, EPP1342 port designations
Connector designations
Type | Connector | Port in TwinCAT
EtherCAT P input | X50 | A
EtherCAT P output | X51 | C
EtherCAT P output | X52 | D
EtherCAT P output | X53 | B
The following page contains examples of how to use the table.
Example: Attaching an EtherCAT P Box to a junction
➢
Requirement: an EtherCAT P junction is added to the IO tree in TwinCAT.
1.
Decide to which connector the EtherCAT P Box is to be connected.
(e.g. at X52)
2.
Use the table to determine the corresponding port.
(e.g. Port D)
3.
Right-click on the EtherCAT P junction in the IO tree.
4.
Click the menu item Add new Item…
5.
In the window that appears select the EtherCAT P Box to be added and the previously determined port.
(e.g. EPP1008-0001, Port D) EPP1332 Slave anfügen
6.
Click OK
⇨
Result: The Box was added at the correct position in the IO tree.
Example: Moving a previously added EtherCAT P Box to another connector
1.
Double-click the EtherCAT P Box in the IO tree.
(e.g. an EPP1008-0001 that was previously connected to X52)
2.
Click the EtherCAT tab.
3.
Use the table to determine the port of the new connector.
(e.g. X51 → Port C)
4.
In the Previous Port dropdown list box, select the junction IO module and the previously determined port.
(e.g. "Box 1 (EPP1332-0001) - C")
⇨
Result: The EtherCAT P Box is connected to the new connector.
Checking the IO configuration graphically
1.
Double-click the EtherCAT master device in the IO tree.
2.
Click the EtherCAT tab.
3.
Click the Topology button.
⇨
Result: A graphical illustration of the network structure created in TwinCAT appears.
Move the mouse pointer over the icons of the IO modules to display their description.


Appendix

Appendix
Appendix
Additional information
•
General operating conditions
•
Accessories
•
Version identification of EtherCAT devices
•
Support and Service


General operating conditions

Appendix [image] General operating conditions
General operating conditions
Protection degrees (IP-Code)
The standard IEC 60529 (DIN EN 60529) defines the degrees of protection in different classes.
1. Number: dust protection and touch guard | Definition
0 | Non-protected
1 | Protected against access to hazardous parts with the back of a hand. Protected against solid foreign objects of Ø 50 mm
2 | Protected against access to hazardous parts with a finger. Protected against solid foreign objects of Ø 12.5 mm.
3 | Protected against access to hazardous parts with a tool. Protected against solid foreign objects Ø 2.5 mm.
4 | Protected against access to hazardous parts with a wire. Protected against solid foreign objects Ø 1 mm.
5 | Protected against access to hazardous parts with a wire. Dust-protected. Intrusion of dust is not totally prevented, but dust shall not penetrate in a quantity to interfere with satisfactory operation of the device or to impair safety.
6 | Protected against access to hazardous parts with a wire. Dust-tight. No intrusion of dust.
2. Number: water* protection | Definition
0 | Non-protected
1 | Protected against water drops
2 | Protected against water drops when enclosure tilted up to 15°.
3 | Protected against spraying water. Water sprayed at an angle up to 60° on either side of the vertical shall have no harmful effects.
4 | Protected against splashing water. Water splashed against the disclosure from any direction shall have no harmful effects
5 | Protected against water jets
6 | Protected against powerful water jets
7 | Protected against the effects of temporary immersion in water. Intrusion of water in quantities causing harmful effects shall not be possible when the enclosure is temporarily immersed in water for 30 min. in 1 m depth.
*) These protection classes define only protection against water!
Chemical Resistance
The Resistance relates to the Housing of the IP 67 modules and the used metal parts. In the table below you will find some typical resistance.
Character | Resistance
Steam | at temperatures >100°C: not resistant
Sodium base liquor (ph-Value > 12) | at room temperature: resistant > 40°C: not resistant
Acetic acid | not resistant
Argon (technical clean) | resistant
Key
▪
resistant: Lifetime several months
▪
non inherently resistant: Lifetime several weeks
▪
not resistant: Lifetime several hours resp. early decomposition


Accessories

Appendix [image] Accessories
Accessories
Mounting
Ordering information | Description
ZS5300-0001 | Mounting rail (500 mm x 129 mm)
Labeling material, protective caps
Ordering information | Description
ZS5000-0010 | Protective cap for M8 sockets, IP67 (50 pieces)
ZS5100-0000 | Inscription labels, unprinted, 4 strips of 10
ZS5000-xxxx | Printed inscription labels on enquiry
Cables
A complete overview of pre-assembled cables for EtherCAT Box modules can be found here.
Ordering information | Description
ZK2020-3xxx-xxxx | Power cable M8, 4-pin link to the website
ZK700x-xxxx-xxxx | EtherCAT P cable M8 Link to website
Tools
Ordering information | Description
ZB8801-0000 | Torque wrench for plugs, 0.4…1.0 Nm
ZB8801-0001 | Torque cable key for M8 / wrench size 9 for ZB8801-0000
Further accessories
Further accessories can be found in the price list for fieldbus components from Beckhoff and online at https://www.beckhoff.com.


Version identification of EtherCAT devices

Appendix [image] Version identification of EtherCAT devices
Version identification of EtherCAT devices
Designation
A Beckhoff EtherCAT device has a 14-digit designation, made up of
▪
family key
▪
type
▪
version
▪
revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
Notes
▪
The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
▪
EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
▪
The order identifier is made up of
- family key (EL, EP, CU, ES, KL, CX, etc.)
- type (3314)
- version (-0000)
▪
The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
▪
The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Identification number
Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:
Production lot/batch number/serial number/date code/D number
The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02
Exceptions can occur in the IP67 area, where the following syntax can be used (see respective device documentation):
Syntax: D ww yy x y z u
D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB
Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1
Unique serial number/ID, ID number
In addition, in some series each individual module has its own unique serial number.
See also the further documentation in the area
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Terminals with factory calibration certificate and other measuring terminals
Examples of markings
EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
CU2016 switch with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
EP1258-00001 IP67 EtherCAT Box with batch number/ date code 22090101 and unique serial number 158102
EP1908-0002 IP67 EtherCAT Safety Box with batch number/ date code 071201FF and unique serial number 00346070
EL2904 IP20 safety terminal with batch number/ date code 50110302 and unique serial number 00331701
ELM3604-0002 terminal with unique ID number (QR code) 100001051 and serial/ batch number 44160201
Additional information
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Appendix [image] Version identification of EtherCAT devices [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com