EPI2xxx, ERI2xxx - IO-Link-Box-Module mit digitalen Ausgängen
Home
EPI 150dpi (default)


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentlichte Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
1.5
▪
Titelseite aktualisiert
1.4
▪
EPI2338-000x, ERI2338-000x: Aufdruck aktualisiert
1.3
▪
Kapitel "Prozessdaten" hinzugefügt
1.2
▪
ERI2xxx hinzugefügt
▪
Einführung aktualisiert
▪
Technische Daten aktualisiert
▪
Anschluss IO-Link Master aktualisiert
▪
Verkabelung aktualisiert
▪
Update Kapitel "IO-Link Master" und "IO-Link Device"
▪
Struktur-Update
▪
Korrekturen
1.1.2
▪
EPI2008 - Technische Daten aktualisiert
▪
EPI2809 - Technische Daten aktualisiert
▪
EPI2338 - Technische Daten aktualisiert
▪
EPI2339 - Technische Daten aktualisiert
1.1.1
▪
Firmware Update des IO-Link Devices aktualisiert
1.1.0
▪
EPI2008-000x - Objektbeschreibung und Parametrierung aktualisiert
▪
EPI2809-002x - Objektbeschreibung und Parametrierung aktualisiert
▪
EPI2338-000x - Objektbeschreibung und Parametrierung aktualisiert
▪
EPI2339-002x - Objektbeschreibung und Parametrierung aktualisiert
1.0.0
▪
Erste Veröffentlichung
0.6
▪
Korrekturen
0.5
▪
Erste vorläufige Version
Firm- und Hardware-Stände
Diese Dokumentation bezieht sich auf den zum Zeitpunkt ihrer Erstellung gültigen Firm- und Hardware-Stand.
Die Eigenschaften der Module werden stetig weiterentwickelt und verbessert. Module älteren Fertigungsstandes können nicht die gleichen Eigenschaften haben, wie Module neuen Standes. Bestehende Eigenschaften bleiben jedoch erhalten und werden nicht geändert, so das ältere Module immer durch neue ersetzt werden können.
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der IO-Link-Box aufgedruckten Batch-Nummer (D-Nummer) entnehmen.
Syntax der Batch-Nummer (D-Nummer):
D: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit D-Nr. 29 10 02 01:
29 - Produktionswoche 29
10 - Produktionsjahr 2010
02 - Firmware-Stand 02
01 - Hardware-Stand 01


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Modulübersicht EPI2xxx, ERI2xxx
•
EPI2008-000x, ERI2008-000x
•
EPI2809-002x, ERI2809-002x
•
EPI2338-000x, ERI2338-000x
•
EPI2339-002x, ERI2339-002x


Modulübersicht EPI2xxx, ERI2xxx

Produktübersicht [image] Modulübersicht EPI2xxx, ERI2xxx
Modulübersicht EPI2xxx, ERI2xxx
Digitale Ausgangsmodule
Modul | Signalanschluss | Anzahl Ausgänge | Strom | Kommentar | Gehäuse
EPI2008-0001 | 8 x M8 | 8 | 0,5 A (Σ 4 A) | Summe aller Ausgänge maximal 4 A | Industriegehäuse
ERI2008-0001 | 8 x M8 | 8 | 0,5 A (Σ 4 A) | Summe aller Ausgänge maximal 4 A | Zink-Druckguss-Gehäuse
EPI2008-0002 | 4 x M12 | 8 | 0,5 A (Σ 4 A) | Summe aller Ausgänge maximal 4 A | Industriegehäuse
ERI2008-0002 | 4 x M12 | 8 | 0,5 A (Σ 4 A) | Summe aller Ausgänge maximal 4 A | Zink-Druckguss-Gehäuse
EPI2809-0021 | 16 x M8 | 16 | 0,5 A (Σ 4 A) |  | Breites Industriegehäuse
ERI2809-0021 | 16 x M8 | 16 | 0,5 A (Σ 4 A) |  | Breites Zink-Druckguss-Gehäuse
EPI2809-0022 | 8 x M12 | 16 | 0,5 A (Σ 4 A) |  | Breites Industriegehäuse
ERI2809-0022 | 8 x M12 | 16 | 0,5 A (Σ 4 A) |  | Breites Zink-Druckguss-Gehäuse
Digitale Kombimodule
Modul | Signalanschluss | Anzahl Ausgänge | Strom | Anzahl Eingänge | Filter (DefaultEinstellung) | Gehäuse
EPI2338-0001 | 8 x M8 | 0 bis 8 | 0,5 A (Σ 4 A) | 8 bis 0 | 3,0 ms | Industriegehäuse
ERI2338-0001 | 8 x M8 | 0 bis 8 | 0,5 A (Σ 4 A) | 8 bis 0 | 3,0 ms | Zink-Druckguss-Gehäuse
EPI2338-0002 | 4 x M12 | 0 bis 8 | 0,5 A (Σ 4 A) | 8 bis 0 | 3,0 ms | Industriegehäuse
ERI2338-0002 | 4 x M12 | 0 bis 8 | 0,5 A (Σ 4 A) | 8 bis 0 | 3,0 ms | Zink-Druckguss-Gehäuse
EPI2339-0021 | 16 x M8 | 0 bis 16 | 0,5 A (Σ 4 A) | 16 bis 0 | 3,0 ms | Breites Industriegehäuse
ERI2339-0021 | 16 x M8 | 0 bis 16 | 0,5 A (Σ 4 A) | 16 bis 0 | 3,0 ms | Breites Zink-Druckguss-Gehäuse
EPI2339-0022 | 8 x M12 | 0 bis 16 | 0,5 A (Σ 4 A) | 16 bis 0 | 3,0 ms | Breites Industriegehäuse
ERI2339-0022 | 8 x M12 | 0 bis 16 | 0,5 A (Σ 4 A) | 16 bis 0 | 3,0 ms | Breites Zink-Druckguss-Gehäuse


EPI2008-000x, ERI2008-000x

Produktübersicht [image] EPI2008-000x, ERI2008-000x
EPI2008-000x, ERI2008-000x
Weiterführende Informationen
•
Einführung
•
Technische Daten
•
Prozessabbild


Einführung

Produktübersicht [image] EPI2008-000x, ERI2008-000x [image] Einführung
Einführung
EPI2008-0001, ERI2008-0001
EPI2008-0002, ERI2008-0002
8 digitale Ausgänge 24 VDC, Imax 0,5 A
Die IO-Link Boxen EPI2008-000x und ERI2008-000x mit digitalen Ausgängen schalten binäre Steuersignale der Steuerung zur Prozessebene an die Aktoren weiter. Die acht Ausgänge verarbeiten Lastströme bis 0,5 A und zeigen ihren Signalzustand über Leuchtdioden an.
Der Signalanschluss erfolgt wahlweise über M8- (EPI2008-0001, ERI2008-0001) oder M12-Steckverbinder (EPI2008-0002, ERI2008-0002). Die Ausgänge sind kurzschlussfest und verpolungsgeschützt.
Die IO-Link-Box-Module im Zinkdruckguss-Gehäuse (ERIxxxx) können in extrem schwieriger Industrie- und Prozessumgebung eingesetzt werden. Durch den Vollverguss und die Metalloberfläche ist die ERI-Serie ideal bei erhöhten Erfordernissen an Belastbarkeit und Beständigkeit beispielsweise gegen Schweißspritzer.
Quick-Links
Montage und Anschluss


Technische Daten

Produktübersicht [image] EPI2008-000x, ERI2008-000x [image] Technische Daten
Technische Daten
Technische Daten | EPI2008-0001 | ERI2008-0001 | EPI2008-0002 | ERI2008-0002
Kommunikation | IO-Link
Datenübertragungsrate | 230,4 kBaud (COM 3)
IO-Link-Anschluss | 1 x M12 Stecker, a-kodiert
Spezifikationsversion | IO-Link V1.1, Class B
Anforderungen IO-Link Master | V1.1
Anzahl Ausgänge | 8
Anschluss Ausgänge | M8 |  | M12
Lastart | ohmsch, induktiv, Lampenlast
Nennspannung Ausgänge | 24 VDC (-15%/+20%)
Ausgangsstrom | max. 0,5 A je Kanal
Kurzschlussstrom | typisch 1,5 A
Stromaufnahme der Modulelektronik | typisch 100 mA aus L+
Stromaufnahme der Ausgangstreiber | typisch 8 mA je Kanal
Versorgung der Modulelektronik | L+
Versorgung der Ausgangstreiber | 2L+
Prozessabbild | 8 Ausgangsbits
Gehäuse | Industriegehäuse (Kunststoff PA6) | Zink-Druckguss-Gehäuse | Industriegehäuse (Kunststoff PA6) | Zink-Druckguss-Gehäuse
Zulässige Umgebungstemperatur im Betrieb | -25 … +60 °C -25 … +55 °C gemäß cURus
Zulässige Umgebungstemperatur bei Lagerung | -40 … +85 °C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529) Beachten Sie hierzu auch das Kapitel Allgemeine Betriebsbedingungen
Einbaulage | beliebig
Zulassungen | CE, cURus


Prozessabbild

Produktübersicht [image] EPI2008-000x, ERI2008-000x [image] Prozessabbild
Prozessabbild
Output 0 bis Output 7
Das IO-Link Device ist an IO-Link Port1 des IO-Link Masters (EP6224-3022) angeschlossen.
Unter Output 0 bis Output 7 finden Sie die 8 digitalen Ausgänge des Moduls (hier als Beispiel das EPI2008-0001).
EPI2008-000x Prozessabbild


EPI2809-002x, ERI2809-002x

Produktübersicht [image] EPI2809-002x, ERI2809-002x
EPI2809-002x, ERI2809-002x
Weiterführende Informationen
•
Einführung
•
Technische Daten
•
Prozessabbild


Einführung

Produktübersicht [image] EPI2809-002x, ERI2809-002x [image] Einführung
Einführung
EPI2809-0021, ERI2809-0021
EPI2809-0022, ERI2809-0022
16 digitale Ausgänge, 24 VDC, Imax 0,5 A (Σ 4 A)
Die IO-Link Boxen EPI2809-002x und ERI2809-002x mit digitalen Ausgängen schalten binäre Steuersignale der Steuerung zur Prozessebene an die Aktoren weiter.
Die 16 Ausgänge verarbeiten Lastströme bis jeweils 0,5 A, wobei der Gesamtstrom auf 4 A begrenzt ist. Damit eignen sich diese Baugruppen besonders für Anwendungen, bei denen nicht alle Ausgänge gleichzeitig aktiv sind oder bei denen nicht alle Aktoren Signalströme von 0,5 A benötigen.
Der Signalzustand wird über Leuchtdioden angezeigt. Der Signalanschluss erfolgt über M8-Steckverbinder (EPI2809-0021, ERI2809-0021) oder M12-Steckverbinder (EPI2809-0022, ERI2809-0022). Alle Ausgänge sind kurzschlussfest und verpolungsgeschützt.
Die IO-Link-Box-Module im Zinkdruckguss-Gehäuse (ERIxxxx) können in extrem schwieriger Industrie- und Prozessumgebung eingesetzt werden. Durch den Vollverguss und die Metalloberfläche ist die ERI-Serie ideal bei erhöhten Erfordernissen an Belastbarkeit und Beständigkeit beispielsweise gegen Schweißspritzer.
Quick-Links
Montage und Anschluss


Technische Daten

Produktübersicht [image] EPI2809-002x, ERI2809-002x [image] Technische Daten
Technische Daten
Technische Daten | EPI2809-0021 | ERI2809-0021 | EPI2809-0022 | ERI2809-0022
Kommunikation | IO-Link
Datenübertragungsrate | 230,4 kBaud (COM 3)
IO-Link-Anschluss | 1 x M12 Stecker, a-codiert
Spezifikationsversion | IO-Link V1.1, Class B
Anforderungen IO-Link Master | V1.1
Anzahl Ausgänge | 16
Anschluss Ausgänge | M8 |  | M12
Lastart | ohmsch, induktiv, Lampenlast
Nennspannung Ausgänge | 24 VDC (-15%/+20%)
Ausgangsstrom | max. 0,5 A je Kanal, Summenstrom aller Ausgänge max. 4 A
Stromaufnahme der Modulelektronik | typisch 100 mA aus L+
Stromaufnahme der Ausgangstreiber | typisch 20 mA
Versorgung der Modulelektronik | L+
Versorgung der Ausgangstreiber | 2L+
Prozessabbild | 16 Ausgangsbits
Gehäuse | Industriegehäuse (Kunststoff PA6) | Zink-Druckguss-Gehäuse | Industriegehäuse (Kunststoff PA6) | Zink-Druckguss-Gehäuse
Zulässige Umgebungstemperatur im Betrieb | -25 … +60 °C -25 … +55 °C gemäß cURus
Zulässige Umgebungstemperatur bei Lagerung | -40 … +85 °C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529) Beachten Sie hierzu auch das Kapitel Allgemeine Betriebsbedingungen
Einbaulage | beliebig
Zulassungen | CE, cURus


Prozessabbild

Produktübersicht [image] EPI2809-002x, ERI2809-002x [image] Prozessabbild
Prozessabbild
Output 0 bis Output 15
Das IO-Link Device ist an IO-Link Port1 des IO-Link Masters (EP6224-3022) angeschlossen.
Unter Output 0 bis Output 15 finden Sie die 16 digitalen Ausgänge des Moduls (hier als Beispiel das EPI2809-0021).
EPI2809-002x Prozessabbild


EPI2338-000x, ERI2338-000x

Produktübersicht [image] EPI2338-000x, ERI2338-000x
EPI2338-000x, ERI2338-000x
Weiterführende Informationen
•
Einführung
•
Technische Daten
•
Prozessabbild


Einführung

Produktübersicht [image] EPI2338-000x, ERI2338-000x [image] Einführung
Einführung
EPI2338-0001, ERI2338-0001 Inventarbild Website
EPI2338-0001, ERI2338-0001
EPI2338-0002, ERI2338-0002
8 digitale Ein- oder Ausgänge, 24 VDC
Die IO-Link Boxen EPI2338-000x und ERI2338-000x verfügen über acht digitale Kanäle die jeweils wahlweise als Ein- oder Ausgänge betrieben werden können. Eine Konfiguration, ob ein Kanal als Ein- oder Ausgang verwendet werden soll ist nicht erforderlich; die Eingangsschaltung ist intern fest mit dem Ausgangstreiber verbunden, so dass ein gesetzter Ausgang automatisch im Eingangsprozessabbild angezeigt wird.
Die Ausgänge verarbeiten Lastströme bis 0,5 A und sind kurzschlussfest und verpolungsgeschützt.
Die Eingänge haben eine Filterkonstante von 3,0 ms (EPI2338-000x, ERI2338-000x). Der Signalzustand wird jeweils über Leuchtdioden angezeigt. Der Anschluss der Signale erfolgt wahlweise über M8- Steckverbinder (EPI2338-0001, ERI2338-0001) oder M12-Steckverbinder (EPI2338-0002, ERI2338-0002).
Versorgung der angeschlossenen Sensoren aus 2L+, nicht aus L+
Die IO-Link Boxen EPI2338 und ERI2338 versorgen digitale Sensoren im Gegensatz zu vielen anderen Modulen aus der zusätzlichen Versorgungsspannung 2L+ und nicht aus der Spannung L+! Dies erfolgt weil die Anschlüsse wahlweise als Ein- oder Ausgang genutzt werden können. Trotzdem wird eine Überlastung der Sensorversorgung (Strom > 0,5 A) auch hier durch rotes Leuchten der „24 V“ LED angezeigt.
Hinweis
Für Abschaltung im Fehlerfall, Sensoren nicht extern versorgen
Falls Ihr Anlagenkonzept vorsieht, dass die zusätzliche Versorgungsspannung 2L+ im Fehlerfall abgeschaltet wird, dürfen Sie die angeschlossenen Sensoren nicht extern, sondern nur durch das EPI23x8, ERI23x8 versorgen! Andernfalls kann das EPI23x8, ERI23x8 bei ausgeschalteter 2L+ Energie aus der externen Sensorversorgung beziehen und die Ausgänge werden nicht abgeschaltet!
Die IO-Link-Box-Module im Zinkdruckguss-Gehäuse (ERIxxxx) können in extrem schwieriger Industrie- und Prozessumgebung eingesetzt werden. Durch den Vollverguss und die Metalloberfläche ist die ERI-Serie ideal bei erhöhten Erfordernissen an Belastbarkeit und Beständigkeit beispielsweise gegen Schweißspritzer.
Quick-Links
Montage und Anschluss


Technische Daten

Produktübersicht [image] EPI2338-000x, ERI2338-000x [image] Technische Daten
Technische Daten
Technische Daten | EPI2338-0001 | ERI2338-0001 | EPI2338-0002 | ERI2338-0002
Kommunikation | IO-Link
Datenübertragungsrate | 230,4 kBaud (COM 3)
IO-Link-Anschluss | 1 x M12 Stecker a-kodiert
Spezifikationsversion | IO-Link V1.1, Class B
Anforderungen IO-Link Master | V1.1
Anzahl Ausgänge | 8 bis 0
Anschluss Ausgänge | M8 |  | M12
Lastart | ohmsch, induktiv, Lampenlast
Nennspannung Ausgänge | 24 VDC (-15%/+20%)
Ausgangsstrom | max. 0,5 A je Kanal
Kurzschlussstrom | max. 1,5 A
Stromaufnahme der Modulelektronik | typisch 100 mA aus L+
Stromaufnahme der Ausgangstreiber | typisch 20 mA
Versorgung der Modulelektronik | L+
Versorgung der Ausgangstreiber | 2L+
Anzahl Eingänge | 0 bis 8
Anschluss Eingänge | M8 |  | M12
Nennspannung Eingänge | 24 VDC (-15%/+20%)
Eingangsfilter (einstellbar) | 3,0 ms (default), einstellbar zwischen 0 ms und 20 ms
Eingangssignalverlängerungszeit (einstellbar) | 0 ms (default), einstellbar zwischen 0 ms und 100 ms
Signalspannung "0" | -3 V...+5 V (EN 61131-2, Typ 3)
Signalspannung "1" | +11 V...+30 V (EN 61131-2, Typ 3)
Eingangsstrom | typisch 3 mA (EN 61131-2, Typ 3)
Sensorversorgung | US1 (abgeleitet aus L+)
Prozessabbild | 8 Eingangsbits, 8 Ausgangsbits
Gehäuse | Industriegehäuse (Kunststoff PA6) | Zink-Druckguss-Gehäuse | Industriegehäuse (Kunststoff PA6) | Zink-Druckguss-Gehäuse
Zulässige Umgebungstemperatur im Betrieb | -25 … +60 °C -25 … +55 °C gemäß cURus
Zulässige Umgebungstemperatur bei Lagerung | -40 … +85 °C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529) Beachten Sie hierzu auch das Kapitel Allgemeine Betriebsbedingungen
Einbaulage | beliebig
Zulassungen | CE, cURus


Prozessabbild

Produktübersicht [image] EPI2338-000x, ERI2338-000x [image] Prozessabbild
Prozessabbild
Inputs und Outputs
Das IO-Link Device ist an IO-Link Port1 des IO-Link Masters (EP6224-3022) angeschlossen.
Unter Input 0 bis Input 7 finden Sie die 8 digitalen Eingänge und unter Output 0 bis Output 7 die 8 digitalen Ausgänge des Moduls (hier als Beispiel das EPI2338-0001).
EPI2338-000x Prozessabbild


EPI2339-002x, ERI2339-002x

Produktübersicht [image] EPI2339-002x, ERI2339-002x
EPI2339-002x, ERI2339-002x
Weiterführende Informationen
•
Einführung
•
Technische Daten
•
Prozessabbild


Einführung

Produktübersicht [image] EPI2339-002x, ERI2339-002x [image] Einführung
Einführung
EPI2339-0021, ERI2339-0021
EPI2339-0022, ERI2339-0022
16 digitale Ein- oder Ausgänge, 24 VDC
Die IO-Link Boxen EPI2339-002x und ERI2339-002x verfügen über 16 digitale Kanäle die jeweils wahlweise als Ein- oder Ausgänge betrieben werden können. Eine Konfiguration, ob ein Kanal als Ein- oder Ausgang verwendet werden soll ist nicht erforderlich; die Eingangsschaltung ist intern fest mit dem Ausgangstreiber verbunden, so dass ein gesetzter Ausgang automatisch im Eingangsprozessabbild angezeigt wird.
Die Ausgänge verarbeiten Lastströme bis 0,5 A und sind kurzschlussfest und verpolungsgeschützt.
Die Eingänge haben eine Filterkonstante von 3 ms.
Der Signalzustand wird jeweils über Leuchtdioden angezeigt. Der Anschluss der Signale erfolgt über M8-Steckverbinder (EPI2339-0021, ERI2339-0021) oder M12-Steckverbinder (EPI2339-0022, ERI2339-0022).
Versorgung der angeschlossenen Sensoren aus 2L+, nicht aus L+
Die IO-Link Boxen EPI2339-002x und ERI2339-002x versorgen digitale Sensoren im Gegensatz zu vielen anderen Modulen aus der zusätzlichen Versorgungsspannung 2L+ und nicht aus der Spannung L+! Dies erfolgt weil die Anschlüsse wahlweise als Ein- oder Ausgang genutzt werden können. Trotzdem wird eine Überlastung der Sensorversorgung (Strom > 0,5 A) auch hier durch rotes Leuchten der „24 V“LED angezeigt.
Hinweis
Für Abschaltung im Fehlerfall, Sensoren nicht extern versorgen
Falls Ihr Anlagenkonzept vorsieht, dass die zusätzliche Versorgungsspannung 2L+ im Fehlerfall abgeschaltet wird, dürfen Sie die angeschlossenen Sensoren nicht extern, sondern nur durch das EPI23x9, ERI23x9 versorgen! Andernfalls kann das EPI23x9, ERI23x9 bei ausgeschalteter 2L+ Energie aus der externen Sensorversorgung beziehen und die Ausgänge werden nicht abgeschaltet!
Die IO-Link-Box-Module im Zinkdruckguss-Gehäuse (ERIxxxx) können in extrem schwieriger Industrie- und Prozessumgebung eingesetzt werden. Durch den Vollverguss und die Metalloberfläche ist die ERI-Serie ideal bei erhöhten Erfordernissen an Belastbarkeit und Beständigkeit beispielsweise gegen Schweißspritzer.
Quick-Links
Montage und Anschluss


Technische Daten

Produktübersicht [image] EPI2339-002x, ERI2339-002x [image] Technische Daten
Technische Daten
Technische Daten | EPI2339-0021 | ERI2339-0021 | EPI2339-0022 | ERI2339-0022
Kommunikation | IO-Link
Datenübertragungsrate | 230,4 kBaud (COM 3)
IO-Link-Anschluss | 1 x M12 Stecker, a-kodiert
Spezifikationsversion | IO-Link V1.1, Class B
Anforderungen IO-Link Master | V1.1
Anzahl Ausgänge | 16 bis 0
Anschluss Ausgänge | M8 |  | M12
Lastart | ohmsch, induktiv, Lampenlast
Nennspannung Ausgänge | 24 VDC (-15%/+20%)
Ausgangsstrom | max. 0,5 A je Kanal
Kurzschlussstrom | maximal 1,5 A
Stromaufnahme der Ausgangstreiber | typisch 20 mA
Versorgung der Modulelektronik | L+
Versorgung der Ausgangstreiber | 2L+
Anschluss Eingänge | M8 |  | M12
Anzahl Eingänge | 0 bis 16
Nennspannung Eingänge | 24 VDC (-15%/+20%)
Eingangsfilter (einstellbar) | 3 ms (default), einstellbar zwischen 0 ms und 20 ms
Eingangssignalverlängerungszeit (einstellbar) | 0 ms (default), einstellbar zwischen 0 ms und 100 ms
Signalspannung "0" | -3 V...+5 V (EN 61131-2, Typ 3)
Signalspannung "1" | +11 V...+30 V (EN 61131-2, Typ 3)
Eingangsstrom | typisch 3 mA (EN 61131-2, Typ 3)
Stromaufnahme der Modulelektronik | typisch 100 mA aus L+
Sensorversorgung | US1 (abgeleitet aus L+)
Stromaufnahme der Sensoren | max. 0,5 A, gesamt kurzschlussfest
Prozessabbild | 16 Eingangsbits, 16 Ausgangsbits
Gehäuse | Industriegehäuse (Kunststoff PA6) | Zink-Druckguss-Gehäuse | Industriegehäuse (Kunststoff PA6) | Zink-Druckguss-Gehäuse
Zulässige Umgebungstemperatur im Betrieb | -25 … +60 °C -25 … +55 °C gemäß cURus
Zulässige Umgebungstemperatur bei Lagerung | -40 … +85 °C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529) Beachten Sie hierzu auch das Kapitel Allgemeine Betriebsbedingungen
Einbaulage | beliebig
Zulassungen | CE, cURus


Prozessabbild

Produktübersicht [image] EPI2339-002x, ERI2339-002x [image] Prozessabbild
Prozessabbild
Inputs und Outputs
Das IO-Link Device ist an IO-Link Port1 des IO-Link Masters (EP6224-3022) angeschlossen.
Unter Input 0 bis Input 15 finden Sie die 16 digitalen Eingänge des Moduls und unter Output 0 bis Output 15 die 16 digitalen Ausgänge des Moduls (hier als Beispiel das EPI2339-0021).
EPI2339-002x Prozessabbild, digitale Ein- und Ausgänge


Grundlagen IO-Link

Grundlagen IO-Link
Grundlagen IO-Link
IO-Link stellt ein Kommunikationssystem zur Anbindung intelligenter Sensoren und Aktoren an ein Automatisierungssystem in der Norm IEC 61131-9 unter der Bezeichnung "Single-drop digital communication interface for small sensors and actuators" (SDCI) dar.
Sowohl die elektrischen Anschlussdaten als auch das Kommunikationsprotokoll sind standardisiert und in der IO-Link Spezifikation zusammengefasst.
Spezifikation IO-Link
Die Entwicklung der EP6224-xxxx unterlag der IO-Link Spezifikation 1.1. Zum Zeitpunkt der Erstellung dieser Dokumentation geht die IO-Link Spezifikation in die IEC-Normung ein und wird als IEC 61131-9 in erweiterter Form übernommen. Dabei wird auch die neue Bezeichnung SDCI eingeführt. Beckhoff unterstützt als Teilnehmer in den entsprechenden Gremien die Entwicklung von IO-Link und bildet Spezifikationsänderungen in seinen Produkten ab.
Weiterführende Informationen
•
IO Link Systemaufbau
•
Aufbau IO Link Kommunikation
•
Gerätebeschreibung IODD
•
Parameterserver
•
Übertragungsgeschwindigkeit


IO Link Systemaufbau

Grundlagen IO-Link [image] IO Link Systemaufbau
IO Link Systemaufbau
Ein IO-Link System besteht aus einem IO-Link Master, einem oder mehreren IO-Link Devices und Sensoren oder Aktoren. Der IO-Link Master stellt die Schnittstelle zur überlagerten Steuerung zur Verfügung und steuert die Kommunikation mit den angeschlossenen IO-Link Devices. Das Beckhoff IO-Link Mastermodul EP6224-xxxx besitzt vier IO-Link-Ports, an dem je ein IO-Link-Device angeschlossen werden kann. IO-Link stellt daher keinen Feldbus dar, sondern ist eine Peer-to-Peer Verbindung (siehe nachfolgende Abbildung).
IO-Link Übersicht: Peer-to-Peer Kommunikation
Die angeschlossenen IO-Link Devices besitzen individuelle Parameterinformationen, die während des automatischen Scannens mit TwinCAT erkannt und im System Manager übernommen werden (vgl. Kapitel "Grundlagen zur Funktion“, Einbinden der IO-Link Devices). Offline können modulspezifische Informationen in Form einer IO-Link Device Description (IODD) eingelesen und in TwinCAT übernommen werden.
▪
Wie Sie manuell (physisch nicht vorhandene) IO-Link Master und Devices in TwinCAT konfigurieren ist unter den beiden folgenden Links beschrieben: Konfigurationserstellung TwinCAT - Manuell (Master), 1. Importieren der Gerätebeschreibung IODD
▪
Wie Sie physisch vorhandene IO-Link Master und Devices in TwinCAT konfigurieren ist unter den beiden folgenden Links beschrieben: Konfigurationserstellung TwinCAT - Online scan (Master), 2. Automatisches Scannen der IO-Link Ports


Aufbau IO Link Kommunikation

Grundlagen IO-Link [image] Aufbau IO Link Kommunikation
Aufbau IO Link Kommunikation
Aufbau IO-Link Kommunikation
Der Aufbau der IO-Link Kommunikation ist in Abb. Aufbau IO-Link Kommunikation dargestellt. Dieser stellt insbesondere den Ablauf beim automatischen Scannen der IO-Link Ports dar.
Aufbau IO-Link Kommunikation
▪
Ist ein IO-Link Device an einem Masterport angeschlossen, so versucht der Master eine Kommunikation aufzubauen. Durch einen definierten Signalpegel, den WakeUp-Impuls, wird dem Slave signalisiert, dass ab jetzt UART-Bytes gesendet werden.
Alle Daten werden vom IO-Link Slave ab da als UART-Bytes interpretiert.
▪
Der Master geht alle Baudraten durch, angefangen bei der schnellsten Baudrate (COM3 = 230kBaud). Eine erfolgreiche Verbindung wird aufgebaut, wenn sich der Slave auf den WakeUp Impuls meldet.
▪
Zunächst liest der Master die Grundparameter aus (Vendor ID, Device ID, Prozessdatenlänge, Telegrammtyp und Zykluszeit) und vergleicht diese mit der vorliegenden Konfiguration.
▪
Konnte keine Verbindung zum Slave aufgebaut werden oder unterscheiden sich die hinterlegten Parameter von den ausgelesenen, so werden entsprechende Fehler ausgegeben.
▪
Stimmen die hinterlegten mit den ausgelesenen Parametern überein, so wechselt das IO-Link Device in den PREOP Status.
Handelt es sich um ein IO-Link Device der Spezifikation V1.1 wird nun der Parameterserver ausgeführt. Handelt es sich im ein IO-Link Device nach V1.0 wird dieser Schritt ausgelassen und direkt in OP geschaltet.
▪
Zuletzt wird die Zykluszeit geschrieben und das Device in OP geschaltet. Danach ist der Master im Zyklischen Datenaustausch mit dem Slave.


Gerätebeschreibung IODD

Grundlagen IO-Link [image] Gerätebeschreibung IODD
Gerätebeschreibung IODD
IO-Link-Geräte besitzen individuelle Systeminformationen in Form einer IO Device Description (IODD), diese enthält:
▪
Kommunikationseigenschaften
▪
Geräteparameter mit Wertebereich und Defaultwerten
▪
Identifikation-, Prozess- und Diagnosedaten
▪
Gerätedaten
▪
Textbeschreibung
▪
Bild des Gerätes
▪
Logo des Herstellers
Ist die IODD importiert, so werden während des automatischen Scannens mit TwinCAT die Gerätedaten erkannt und im System Manager übernommen (vgl. Einbinden der IO-Link Devices).


Parameterserver

Grundlagen IO-Link [image] Parameterserver
Parameterserver
Um die Funktionalität des Parameterservers nutzen zu können, müssen sowohl der IO-Link Master, als auch das IO-Link Device nach V1.1 spezifiziert sein. Die IO-Link Revision des Devices kann für den einzelnen Port unter Settings ausgelesen werden. Der Beckhoff IO-Link Master unterstützt die Spezifikation V1.1 ab FW 07.
▪
Der Parameterserver im IO-Link-Master enthält Parameterdaten die im IO-Link-Devices gespeichert sind. Die Speicherkapazität beträgt max. 2 kByte (inklusive Header).
Wird das IO-Link-Device getauscht, so werden die Daten aus dem Parameterserver auf das neue Gerät geladen. Voraussetzung ist, dass es sich um den gleichen Gerätetyp handelt (VendorID & DeviceID müssen übereinstimmen).
▪
Wird ein neues IO-Link-Device konfiguriert, so lädt beim ersten Start der IO-Link Master die Parameter aus dem IO-Link-Device in den Parameterserver.
Bereits konfigurierte Daten anderer IO-Link-Devices (VendorID & DeviceID stimmen mit dem konfigurierten Gerät nicht überein) werden überschrieben.
▪
Bei jedem weiteren Start prüft der IO-Link Master mit Hilfe einer Checksumme, ob die Daten im Parameterserver mit denen auf dem IO-Link-Device übereinstimmen und macht ggfs. ein Download auf das Device.
▪
Ändern sich Parameter während der Laufzeit des Gerätes, so kann dies über ein spezielles Event dem Master gemeldet werden. Der Master startet daraufhin den Parameterserver mit einem Upload.
▪
Das Event wird standardmäßig nicht bei jedem Parameterschreiben gesetzt, daher ist das Ende des Parametriervorgangs dem IO-Link Device zu melden.
Daraufhin sendet das IO-Link-Device das entsprechende Event an den Master. Die Daten werden in den Parameterserver geladen.
▪
Beim vorprogrammierten IO-Link-Device findet kein Download aus dem Parameterserver auf das Device statt.


Übertragungsgeschwindigkeit

Grundlagen IO-Link [image] Übertragungsgeschwindigkeit
Übertragungsgeschwindigkeit
Ein IO-Link Master nach Spezifikation V1.1 unterstützt alle drei Übertragungsarten, er passt die Übertragungsrate automatisch an die des IO-Link Devices an.
Ein IO-Link Device unterstützt i.d.R. nur eine Übertragungsrate. Auf den verschiedenen Ports des Masters können IO-Link Devices mit unterschiedlichen Übertragungsraten angeschlossen werden.
▪
COM1 = 4,8 kBaud
▪
COM2 = 38,4 kBaud
▪
COM3 = 230,4 kBaud


Montage und Anschluss

Montage und Anschluss
Montage und Anschluss
Weiterführende Informationen
•
Montage
•
IO-Link Anschluss
•
Status-LEDs für die Spannungsversorgung
•
Signalanschluss
•
UL-Anforderungen
•
Verkabelung


Montage

Montage und Anschluss [image] Montage
Montage
Weiterführende Informationen
•
Abmessungen
•
Befestigung
•
Anzugsdrehmomente für Steckverbinder


Abmessungen

Montage und Anschluss [image] Montage [image] Abmessungen
Abmessungen
Abmessungen
Alle Maße sind in Millimeter angegeben.
Gehäuseeigenschaften
IO-Link-Box-Module | Schmales Gehäuse | Breites Gehäuse
Gehäusematerial | EPIxxxx: PA6 (Polyamid) ERIxxxx: Zink-Druckguss
Vergussmasse | Polyurethan
Montage | zwei Befestigungslöcher Ø 3 mm für M3 | zwei Befestigungslöcher Ø 4,5 mm für M4
Metallteile | Messing, vernickelt
Kontakte | CuZn, vergoldet
Einbaulage | beliebig
Schutzart | im verschraubten Zustand IP65, IP66, IP67 (gemäß EN 60529)
Abmessungen (H x B x T) | ca. 126 x 30 x 26,5 mm | ca. 126 x 60 x 26,5 mm
Gewicht | ca. 125 g, je nach Modultyp | ca. 250 g, je nach Modultyp


Befestigung

Montage und Anschluss [image] Montage [image] Befestigung
Befestigung
Anschlüsse vor Verschmutzung schützen!
Schützen Sie während der Montage der Module alle Anschlüsse vor Verschmutzung! Die Schutzart IP65 ist nur gewährleistet, wenn alle Kabel und Stecker angeschlossen sind! Nicht benutzte Anschlüsse müssen mit den entsprechenden Steckern geschützt werden! Steckersets siehe Katalog.
Module mit schmalem Gehäuse werden mit zwei M3-Schrauben montiert.
Module mit breitem Gehäuse werden mit zwei M3-Schrauben an den in den Ecken angeordneten oder mit zwei M4-Schrauben an den zentriert angeordneten Befestigungslöchern montiert.
Die Schrauben müssen länger als 15 mm sein. Die Befestigungslöcher der Module besitzen kein Gewinde.
Beachten Sie bei der Montage, dass die Feldbusanschlüsse die Gesamthöhe noch vergrößert. Siehe Kapitel Zubehör.
Montageschiene ZS5300-0001
Die Montageschiene ZS5300-0001 (500 mm x 129 mm) ermöglicht einen zeitsparenden Aufbau der Module.
Die Schiene besteht aus rostfreiem Stahl (V2A), ist 1,5 mm stark mit passend vorgefertigten M3-Gewinden. Die Schiene hat 5,3 mm Langlöcher um sie mit M5-Schrauben an der Maschine zu befestigen.
Montageschiene ZS5300-0001
Die Montageschiene ist 500 mm lang und erlaubt bei einem Modulabstand von 2 mm die Montage von 15 schmalen Modulen. Sie kann applikationsspezifisch gekürzt werden.
Montageschiene ZS5300-0011
Die Montageschiene ZS5300-0011 (500 mm x 129 mm) bietet neben den M3- auch vorgefertigte M4-Gewinde zur Befestigung der 60 mm breiten Module über deren mittlere Bohrungen.
Bis zu 14 schmale oder 7 breite Module können gemischt montiert werden.


Anzugsdrehmomente für Steckverbinder

Montage und Anschluss [image] Montage [image] Anzugsdrehmomente für Steckverbinder
Anzugsdrehmomente für Steckverbinder
Schrauben Sie Steckverbinder mit einem Drehmomentschlüssel fest. (z.B. ZB8801 von Beckhoff)
Steckverbinder-Durchmesser | Anzugsdrehmoment
M8 | 0,4 Nm
M12 | 0,6 Nm


IO-Link Anschluss

Montage und Anschluss [image] IO-Link Anschluss
IO-Link Anschluss
Weiterführende Informationen
•
Anschluss IO-Link Master
•
Anschluss IO-Link Device
•
IO-Link Device Status LED


Anschluss IO-Link Master

Montage und Anschluss [image] IO-Link Anschluss [image] Anschluss IO-Link Master
Anschluss IO-Link Master
IO-Link Schnittstelle
In der IO-Link-Spezifikation sind verschiedene IO-Link-Anschlussbelegungen festgelegt, auf die im nachfolgenden Teil eingegangen wird.
Die Schalt- und Kommunikationsleitung ist mit (C/Q) gekennzeichnet.
Port Class A (Typ A): Die Funktion von Pin 2 und Pin 5 ist nicht vorgegeben. Der Hersteller kann Pin 2 mit einem zusätzlichen Digitalkanal belegen. Port Class B (Typ B): Pin 2 und Pin 5 werden für eine zusätzliche Spannungsversorgung genutzt. Die Informationen zu der Anschlussbelegung Ihres Modules finden Sie in dem Kapitel „Einführung“.
Class A Schnittstelle_Pin 2 nicht belegt
Anschlussbelegung Port Class A, Pin 2 nicht belegt
Bei Class A-Modulen kann der Pin 2 mit einem zusätzlichen digitalen Eingang bzw. Ausgang (I/Q) belegt sein.
Anschlussbelegung Port Class A IO-Link
Anschlussbelegung Port Class A, Pin 2 belegt
Port Class B (Typ B): Für Devices mit erhöhtem Strombedarf wird über Pin 2 und Pin 5 eine zusätzliche Spannungsversorgung zur Verfügung gestellt.
Anschlussbelegung Port Class B IO-Link
Anschlussbelegung Port Class B
Für den abgehenden IO-Link-Anschluss verfügt der IO-Link Master (EP622x-xxxx) über eine A-kodierte M12-Buchse.
IO-Link-Anschluss, Master
Aderfarben
Die Aderfarben des IO-Link Kabels mit der dazugehörigen Pin-Belegung des IO-Link Steckverbinders:
Pin | Aderfarbe
1 | braun
2 | weiß
3 | blau
4 | schwarz
5 | grau
IO-Link-Kabel
Beispiel IO-Link Kabel: Stecker auf Buchse
Die von Beckhoff lieferbaren Kabel für das IO-Link-System finden Sie unter dem folgenden Link unter dem Punkt „Zubehör“: https://beckhoff.de/german/fieldbus_components_accessories/m12_sensor_5w.htm?id=51657421126830456
IO-Link Kabel
Für Class A Master/Devices von Beckhoff kann ein 3-adriges IO-Link Kabel ausreichend sein. Ein Class B Master/Device benötigt ein 5-adriges IO-Link Kabel.


Anschluss IO-Link Device

Montage und Anschluss [image] IO-Link Anschluss [image] Anschluss IO-Link Device
Anschluss IO-Link Device
Für den ankommenden IO-Link-Anschluss verfügt die IO-Link Box (EPIxxxx, ERIxxxx) über einen A-kodierten M12-Stecker.
IO-Link-Anschluss, Device (schmales Gehäuse)
IO-Link-Anschluss, Device (breites Gehäuse)


IO-Link Device Status LED

Montage und Anschluss [image] IO-Link Anschluss [image] IO-Link Device Status LED
IO-Link Device Status LED
IO-Link Device Status LED (schmales Gehäuse)
IO-Link Device Status LED (breites Gehäuse)
LED-Anzeige
LED | Anzeige | Bedeutung
IO-Link Status LED (X1) | aus | IO-Link Kommunikation nicht aktiv
 | Blinkt grün (1Hz) | IO-Link Kommunikation aktiv
 | Leuchtet rot | Kurzschluss auf C/Q Leitung oder Überhitzung


Status-LEDs für die Spannungsversorgung

Montage und Anschluss [image] Status-LEDs für die Spannungsversorgung
Status-LEDs für die Spannungsversorgung
Das IO-Link Modul enthält 2 Diagnose LEDs für die Spannungsversorgung sowie ein Diagnose Objekt (0x0A00) zur genaueren Diagnose. Die Beschreibung der Diagnose Parameter (Index 0x0A00) ist im Abschnitt Objektbeschreibung und Parametrierung beschrieben.
(EPI2008-000x, ERI2008-000x / EPI2809-002x, ERI2809-002x / EPI2338-000x, ERI2338-000x / EPI2339-002x, ERI2339-002x)
Status-LEDs für die Spannungsversorgung
LED-Anzeigen
LED | Anzeige | Bedeutung
24 V | aus | Spannung L+ nicht vorhanden
 | grün | Spannung L+ OK
 | rot | Spannung L+ zu gering
rechte LED | grün | Spannung 2L+ OK, digitale Ausgänge OK
 | aus | Spannung 2L+ zu gering, Überspannung an einem der digitalen Ausgänge erkannt, Kurzschluss


Signalanschluss

Montage und Anschluss [image] Signalanschluss
Signalanschluss
Weiterführende Informationen
•
Digitale Ausgänge M8 und M12
•
Digitale Ein-/Ausgänge M8 und M12


Digitale Ausgänge M8 und M12

Montage und Anschluss [image] Signalanschluss [image] Digitale Ausgänge M8 und M12
Digitale Ausgänge M8 und M12
Die digitalen Ausgangsmodule schalten die binären Steuersignale des Automatisierungsgerätes zur Prozessebene an die Aktoren weiter.
Der Signalanschluss erfolgt über M8-Steckverbinder (EPI2xxx-00x1, ERI2xxx-00x1) oder M12-Steckverbinder (EPI2xxx-00x2, ERI2xxx-00x2).
Digitale Ausgänge M8 und M12_EPI1xxx
Digitale Ausgänge M8 und M12
Die Ausgänge sind kurzschlussfest und verpolungsgeschützt.
Leuchtdioden zeigen den Signalzustand der Ausgänge an.


Digitale Ein-/Ausgänge M8 und M12

Montage und Anschluss [image] Signalanschluss [image] Digitale Ein-/Ausgänge M8 und M12
Digitale Ein-/Ausgänge M8 und M12
Die Kanäle der EPI23xx-xxxx, ERI23xx-xxxx können jeweils wahlweise als Ein- oder Ausgänge betrieben werden.
Die digitalen Eingänge erfassen die binären Steuersignale aus der Prozessebene und transportieren sie zum übergeordneten Automatisierungsgerät. Die digitalen Ausgänge schalten die binären Steuersignale des Automatisierungsgerätes zur Prozessebene an die Aktoren weiter.
Der Signalanschluss erfolgt über M8-Steckverbinder (EPIxxxx-00x1, ERIxxxx-00x1) oder M12-Steckverbinder (EPIxxxx-00x2, ERIxxxx-00x2).
Leuchtdioden zeigen den Signalzustand der Eingänge/Ausgänge an.
Digitale Ein_Ausgänge M8 und M12_EPI1xxx
Digitale Ein-/Ausgänge M8 und M12
Die Ausgänge sind kurzschlussfest und verpolungsgeschützt.


UL-Anforderungen

Montage und Anschluss [image] UL-Anforderungen
UL-Anforderungen
Die Installation der nach UL zertifizierten IP67 Box Module muss den folgenden Anforderungen entsprechen.
Versorgungsspannung
SmallWarningYellow VORSICHT
VORSICHT!
•
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
•
von einer Spannungsquelle die NEC class 2 entspricht stammt.
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die IP67 Box Module nicht mit unbegrenzten Spannungsquellen verbunden werden!
Netzwerke
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die IP67 Box Module nicht mit Telekommunikations-Netzen verbunden werden!
Umgebungstemperatur
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die IP67 Box Module nur in einem Umgebungstemperaturbereich von 0 bis 55°C betrieben werden!
Kennzeichnung für UL
Alle nach UL (Underwriters Laboratories) zertifizierten IP67 Box Module sind mit der folgenden Markierung gekennzeichnet.
UL-Markierung


Verkabelung

Montage und Anschluss [image] Verkabelung
Verkabelung
Eine Auflistung der EtherCAT-Kabel, Powerkabel, Sensorkabel, IO-Link-Kabel, Ethernet-/EtherCAT-Steckverbinder sowie feldkonfektionierbare Steckverbinder finden Sie unter dem folgenden Link: https://beckhoff.de/default.asp?ethercat-box/ethercat_box_cables.htm?id=690338951657421
IO-Link-Kabel
Der IO-Link Master wird über ein ungeschirmtes, maximal 20 m langes, 3-, 4- oder 5-adriges (Typ A) oder 5-adriges (Typ B) Kabel mit dem IO-Link Device verbunden. Die IO-Link Kabel sind als gerade und abgewinkelte Variante verfügbar. Weitere Informationen zu dem IO-Link Anschluss finden Sie unter: Anschluss IO-Link Master
Beispiel IO-Link-Kabel: Stecker auf Buchse
Sensorkabel
Sensorkabel - Beckhoff.png
Auswahl der von Beckhoff lieferbaren Sensorkabel


Inbetriebnahme/Konfiguration IO-Link Master/Device

Inbetriebnahme/Konfiguration IO-Link Master/Device
Inbetriebnahme/Konfiguration IO-Link Master/Device
Weiterführende Informationen
•
IO-Link Master
•
Zugriff auf IO-Link Parameter
•
IO-Link Device


IO-Link Master

Inbetriebnahme/Konfiguration IO-Link Master/Device [image] IO-Link Master
IO-Link Master
Weiterführende Informationen
•
Konfigurationserstellung TwinCAT - Manuell (Master)
•
Konfigurationserstellung TwinCAT - Online scan (Master)
•
Konfiguration mit TwinCAT - Erläuterung Karteireiter
•
Wiederherstellen des Auslieferungszustandes von einem EtherCAT-Gerät


Konfigurationserstellung TwinCAT - Manuell (Master)

Inbetriebnahme/Konfiguration IO-Link Master/Device [image] IO-Link Master [image] Konfigurationserstellung TwinCAT - Manuell (Master)
Konfigurationserstellung TwinCAT - Manuell (Master)
In diesem Teil der Dokumentation wird die manuelle Konfiguration des IO-Link Masters in TwinCAT beschrieben.
Unterscheidung Online/Offline
Die Unterscheidung Online/Offline bezieht sich auf das Vorhandensein der tatsächlichen I/O-Umgebung (Antriebe, Klemmen, Box-Module).
▪
Offline
Wenn die Konfiguration im Vorfeld der Anlagenerstellung z. B. auf einem Laptop als Programmiersystem erstellt werden soll, ist nur die "Offline-Konfiguration" möglich. Dann müssen alle Komponenten händisch in der Konfiguration z. B. nach Elektro-Planung eingetragen werden (wie nachfolgend unter 1. Importieren der Gerätebeschreibung IODD beschrieben ist).
▪
Online
Ist die vorgesehene Steuerung bereits an das EtherCAT System angeschlossen, alle Komponenten mit Spannung versorgt und die Infrastruktur betriebsbereit, kann die TwinCAT Konfiguration auch vereinfacht durch das so genannte "Scannen" vom Runtime-System aus erzeugt werden. Dies ist der so genannte Online-Vorgang. In jedem Fall prüft der EtherCAT Master bei jedem realen Hochlauf, ob die vorgefundenen Geräte der Konfiguration entsprechen. Dieser Test kann in den erweiterten Device-Einstellungen parametriert werden.
Damit die aktuellsten Features/Einstellungen des Masters genutzt werden können, sollte immer die aktuellste ESI-Datei heruntergeladen werden. Beachten Sie bitte deshalb den nachfolgenden Hinweis.
Installation der neusten ESI-XML-Device-Description
Der TwinCAT System Manager benötigt zur Konfigurationserstellung im Online- und Offline-Modus die Gerätebeschreibungsdateien der zu verwendeten Geräte. Die Gerätebeschreibungen sind die so genannten ESI (EtherCAT Slave Information) in Form von XML-Dateien. Diese Dateien können vom jeweiligen Hersteller angefordert werden bzw. werden zum Download bereitgestellt. Auf der Beckhoff Website werden die ESI für Beckhoff EtherCAT Geräte bereitgehalten. Die ESI-Dateien sind im Installationsverzeichnis von TwinCAT (Standardeinstellung: C:\TwinCAT\IO\EtherCAT) abzulegen. Beim Öffnen eines neuen System Manager-Fensters werden die Dateien einmalig eingelesen. TwinCAT bringt bei der Installation die Beckhoff-ESI-Dateien mit, die zum Erstellungszeitpunkt des TwinCAT builds aktuell waren. Ab TwinCAT 2.11 und in TwinCAT 3 kann aus dem System Manager heraus das ESI-Verzeichnis aktualisiert werden, wenn der Programmier-PC mit dem Internet verbunden ist (TwinCAT → EtherCAT-Devices → Update Device Description…) s. folgend Abbildung.
Update EtherCAT Device Description 1439726603
Update device description
Manuelles Anfügen eines Moduls
▪
Das EtherCAT-System muss sich in einem sicheren, spannungslosen Zustand befinden bevor Sie die EtherCAT-Module an das EtherCAT-Netzwerk anschließen.
▪
Nach Einschalten der Betriebsspannung öffnen Sie den TwinCAT System Manager (Config-Mode)
▪
Fügen Sie ein neues E/A-Gerät an. Im nachfolgenden Dialog wählen Sie das Gerät EtherCAT (Direct Mode), bestätigen Sie mit OK.
Anfügen eines neuen E_A-Gerätes
Anfügen eines neuen E/A-Gerätes (E/A-Geräte -> Rechte Maustaste -> Gerät anfügen...)
Auswahl des Gerätes (EtherCAT)
Auswahl des Gerätes (EtherCAT)
▪
Fügen Sie eine neue Box an.
Anfügen einer neuen Box
Anfügen einer neuen Box (Gerät -> Rechte Maustaste -> Box anfügen...)
▪
Im angezeigten Dialog wählen Sie die gewünschte Box (z. B.: EP6224-2022), bestätigen Sie mit OK.
Auswahl einer Box
Auswahl einer Box (z.B.: EP6224-2022)
Angefügte Box im TwinCAT-Baum
Angefügte Box im TwinCAT-Baum
Konfiguration des IO-Link Masters
Zur Konfiguration des IO-Link Masters wird ein PlugIn benötigt, das im Regelfall mit der TwinCAT Installation geliefert wird. Beim Anfügen des IO-Link Masters (s. Kapitel Konfigurationserstellung TwinCAT - Manuell / Online Scan (Master)) im TwinCAT System Manager wird ein zusätzlicher Karteireiter namens IO-Link angelegt (s. nachfolgende Abbildung). Sollte der Karteireiter nicht angezeigt werden, fehlt die entsprechende System Manager Extension. Diese kann ggf. nachinstalliert werden. Bitte wenden Sie sich dazu an den Support.
Karteireiter "IO-Link"


Konfigurationserstellung TwinCAT - Online scan (Master)

Inbetriebnahme/Konfiguration IO-Link Master/Device [image] IO-Link Master [image] Konfigurationserstellung TwinCAT - Online scan (Master)
Konfigurationserstellung TwinCAT - Online scan (Master)
In diesem Teil der Dokumentation wird die Konfiguration eines physisch vorhandenen IO-Link Masters in TwinCAT beschrieben.
Online Konfigurationserstellung „Scannen“ (TwinCAT 3.x)
Unterscheidung Online/Offline
Die Unterscheidung Online/Offline bezieht sich auf das Vorhandensein der tatsächlichen I/O-Umgebung (Antriebe, Klemmen, Box-Module).
▪
Offline
Wenn die Konfiguration im Vorfeld der Anlagenerstellung z. B. auf einem Laptop als Programmiersystem erstellt werden soll, ist nur die "Offline-Konfiguration" möglich. Dann müssen alle Komponenten händisch in der Konfiguration z. B. nach Elektro-Planung eingetragen werden (wie nachfolgend unter 1. Importieren der Gerätebeschreibung IODD beschrieben ist).
▪
Online
Ist die vorgesehene Steuerung bereits an das EtherCAT System angeschlossen, alle Komponenten mit Spannung versorgt und die Infrastruktur betriebsbereit, kann die TwinCAT Konfiguration auch vereinfacht durch das so genannte "Scannen" vom Runtime-System aus erzeugt werden. Dies ist der so genannte Online-Vorgang. In jedem Fall prüft der EtherCAT Master bei jedem realen Hochlauf, ob die vorgefundenen Geräte der Konfiguration entsprechen. Dieser Test kann in den erweiterten Device-Einstellungen parametriert werden.
Damit die aktuellsten Features/Einstellungen des Masters genutzt werden können, sollte immer die aktuellste ESI-Datei heruntergeladen werden. Beachten Sie bitte deshalb den nachfolgenden Hinweis.
Installation der neusten ESI-XML-Device-Description
Der TwinCAT System Manager benötigt zur Konfigurationserstellung im Online- und Offline-Modus die Gerätebeschreibungsdateien der zu verwendeten Geräte. Die Gerätebeschreibungen sind die so genannten ESI (EtherCAT Slave Information) in Form von XML-Dateien. Diese Dateien können vom jeweiligen Hersteller angefordert werden bzw. werden zum Download bereitgestellt. Auf der Beckhoff Website werden die ESI für Beckhoff EtherCAT Geräte bereitgehalten. Die ESI-Dateien sind im Installationsverzeichnis von TwinCAT (Standardeinstellung: C:\TwinCAT\IO\EtherCAT) abzulegen. Beim Öffnen eines neuen System Manager-Fensters werden die Dateien einmalig eingelesen. TwinCAT bringt bei der Installation die Beckhoff-ESI-Dateien mit, die zum Erstellungszeitpunkt des TwinCAT builds aktuell waren. Ab TwinCAT 2.11 und in TwinCAT 3 kann aus dem System Manager heraus das ESI-Verzeichnis aktualisiert werden, wenn der Programmier-PC mit dem Internet verbunden ist (TwinCAT → EtherCAT-Devices → Update Device Description…) s. folgend Abbildung.
Update EtherCAT Device Description 1439726603
Update device description
Zur Konfigurationserstellung
▪
muss die reale EtherCAT- und IO-Link-Hardware (Geräte, Koppler, Antriebe) vorliegen und installiert sein.
▪
die Geräte/Module müssen über EtherCAT-Kabel und IO-Link-Kabel so verbunden sein wie sie später eingesetzt werden sollen.
▪
die Geräte/Module müssen mit Energie versorgt werden und kommunikationsbereit sein.
▪
TwinCAT muss auf dem Zielsystem im CONFIG-Modus sein.
Der Online-Scan-Vorgang setzt sich zusammen aus:
▪
Erkennen des EtherCAT-Gerätes (Ethernet-Port am IPC)
▪
Erkennen der angeschlossenen EtherCAT-Teilnehmer- Dieser Schritt kann auch unabhängig vom vorherigen Schritt durchgeführt werden.
▪
Problembehandlung
Auch kann der Scan bei bestehender Konfiguration zum Vergleich durchgeführt werden.
Erkennen/Scan des EtherCAT Geräts
Befindet sich das TwinCAT-System im Config-Modus (TwinCAT Icon blau bzw. blaue Anzeige im System Manager) kann online nach Geräten gesucht werden.
TwinCAT Anzeige Config-Modus
Online Scannen im Config Mode
Die Online-Suche im RUN-Modus (produktiver Betrieb) ist nicht möglich.
Es ist die Unterscheidung zwischen TwinCAT-Programmiersystem und TwinCAT-Zielsystem zu beachten. Das TwinCAT-Icon neben der Windows-Uhr stellt immer den TwinCAT-Modus des lokalen IPC dar. Im System Manager-Fenster wird dagegen der TwinCAT-Zustand des Zielsystems gezeigt.
TwinCAT target und local System
Im Konfigurationsbaum bringt Sie ein Rechtsklick auf den Punkt „I/O Devices“ zum Such-Dialog.
Scan Devices
Dieser Scan-Modus versucht nicht nur EtherCAT-Geräte (bzw. die als solche nutzbaren Ethernet-Ports) zu finden, sondern auch NOVRAM, Feldbuskarten, SMB etc. Nicht alle Geräte können jedoch automatisch gefunden werden.
Hinweis automatischer Gerätescan
Hinweis automatischer Gerätescan
Ethernet Ports mit installierten TwinCAT Realtime-Treiber werden als "RT-Ethernet" Geräte angezeigt. Testweise wird an diesen Ports ein EtherCAT-Frame verschickt. Erkennt der Scan-Agent an der Antwort, dass ein EtherCAT-Gerät angeschlossen ist, wird der Port allerdings gleich als "EtherCAT Device" angezeigt.
erkannte Ethernet-Geräte
Für alle angewählten Geräte wird nach Bestätigung "OK" im nachfolgenden ein Teilnehmer-Scan vorgeschlagen (siehe nachfolgende Abbildung).
Erkennen/Scan der EtherCAT Teilnehmer
Funktionsweise Online Scan
Beim Scan fragt der Master die Identity Information des EtherCAT Devices aus dem Device-EEPROM ab. Es werden Name und Revision zur Typbestimmung herangezogen. Die entsprechenden Geräte werden dann in den hinterlegten ESI-Daten gesucht und in dem dort definierten Default-Zustand in den Konfigurationsbaum eingebaut.
Wurde ein EtherCAT-Device in der Konfiguration angelegt (manuell oder durch Scan), kann das I/O-Feld nach Teilnehmern/Slaves gescannt werden.
Scan for Boxes
Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes
Die Konfiguration wurde aufgebaut und direkt in den Online-Zustand (OPERATIONAL) versetzt. Das EtherCAT System sollte sich in einem funktionsfähigen zyklischen Betrieb, wie in der nachfolgenden Abbildung dargestellt, befinden.
beispielhafte Online-Anzeige
Zu beachten sind:
▪
Alle Boxen sollten im OP-State sein
▪
der EtherCAT Master soll im "Actual State" OP sein
▪
"Frames/sec" soll der Zykluszeit unter Berücksichtigung der versendeten Frameanzahl sein
▪
es sollen weder übermäßig "LostFrames"- noch CRC-Fehler auftreten
Die Konfiguration ist nun fertig gestellt. Sie kann auch wie im manuellen Vorgang beschrieben verändert werden.
Wie in der nachfolgenden Abbildung sichtbar, wird der angeschlossene IO-Link Master (EP6224-2022) im TwinCAT Baum angezeigt.
Master-Anzeige_Nach Scan for Boxes
Master-Anzeige nach „Scan for boxes“
Problembehandlung
Beim Scannen können verschiedene Effekte auftreten.
▪
es wird ein unbekanntes Gerät entdeckt, d. h. ein EtherCAT Device für den keine ESI-XML-Beschreibung vorliegt.
In diesem Fall bietet der System Manager an, die im Gerät eventuell vorliegende ESI auszulesen.
▪
Teilnehmer werden nicht richtig erkannt
Ursachen können sein
–
fehlerhafte Datenverbindungen, es treten Datenverluste während des Scans auf
–
Device hat ungültige Gerätebeschreibung
Es sind die Verbindungen und Teilnehmer gezielt zu überprüfen, z. B. durch den Emergency Scan.
Der Scan ist dann erneut vorzunehmen.
Scan über bestehende Konfiguration
Wird der Scan bei bestehender Konfiguration angestoßen, kann die reale I/O-Umgebung genau der Konfiguration entsprechen oder differieren. So kann die Konfiguration verglichen werden.
Configuration is identical
Identische Konfiguration
Sind Unterschiede feststellbar, werden diese im Korrekturdialog angezeigt, die Konfiguration kann umgehend angepasst werden.
Beispiel-Korrekturdialog
Es wird empfohlen das Häkchen „Extended Information“ zu setzen, weil dadurch Unterschiede in der Revision sichtbar werden.
Farbe | Erläuterung
grün | Dieses EtherCAT Device findet seine Entsprechung auf der Gegenseite. Typ und Revision stimmen überein.
blau | Dieses EtherCAT Device ist auf der Gegenseite vorhanden, aber in einer anderen Revision. Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtigung der Kompatibilität möglich. Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Gerät nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.
hellblau | Dieses EtherCAT Device wird ignoriert (Button "Ignore").
rot | Dieses EtherCAT Device ist auf der Gegenseite nicht vorhanden.
Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung werden auch das Prozessabbild, die Art der Kommunikation zwischen Master und Device/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d. h. neuere Geräte (höhere Revision) sollen es auch unterstützen wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/Boxen ist anzunehmen:
Geräte-Revision in der Anlage >= Geräte Revision in der Konfiguration
Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben sind bei Antrieben möglich).
Beispiel: In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1019 oder höher (-1020, -1021) eingesetzt werden.
Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.
Beispiel-Korrekturdialog mit Änderungen
Sind alle Änderungen übernommen oder akzeptiert, können sie durch „OK“ in die reale *.tsm-Konfiguration übernommen werden.


Konfiguration mit TwinCAT - Erläuterung Karteireiter

Inbetriebnahme/Konfiguration IO-Link Master/Device [image] IO-Link Master [image] Konfiguration mit TwinCAT - Erläuterung Karteireiter
Konfiguration mit TwinCAT - Erläuterung Karteireiter
Klicken Sie im linken Fenster des TwinCAT System Managers auf den Baumzweig der IO-Link Box die Sie konfigurieren möchten.
Baumzweig der zu konfigurierende IO-Link-Box
Im rechten Fenster des TwinCAT System Managers stehen Ihnen nun verschiedene Karteireiter zur Konfiguration der IO-Link Box zur Verfügung.
Karteireiter Allgemein
Karteireiter Allgemein
Name | Name des IO-Link-Masters
Id | Laufende Nr. des IO-Link-Masters
Typ | Typ des IO-Link-Masters
Kommentar | Hier können Sie einen Kommentar (z. B. zum Anlagenteil) hinzufügen.
Disabled | Hier können Sie den IO-Link-Master deaktivieren.
Symbole erzeugen | Nur wenn dieses Kontrollkästchen aktiviert ist, können Sie per ADS auf den IO-Link-Master zugreifen.
Karteireiter EtherCAT
Karteireiter EtherCAT
Typ | Typ des IO-Link Masters
Product/Revision | Produkt- und Revisions-Nummer des IO-Link Masters
Auto Inc Adr. | Auto-Inkrement-Adresse des IO-Link Masters. Die Auto-Inkrement-Adresse kann benutzt werden, um jedes EtherCAT-Gerät oder jeden IO-Link Master anhand seiner physikalischen Position im Kommunikationsring zu adressieren. Die Auto-Inkrement-Adressierung wird während der Start-Up-Phase benutzt, wenn der IO-Link Master die Adressen an die EtherCAT-Geräte oder weitere IO-Link Master vergibt. Bei der Auto-Inkrement-Adressierung hat das erste EtherCAT-Gerät im Ring die Adresse 0000hex und für jedes weitere wird die Adresse um 1 verringert (FFFFhex, FFFEhex usw.).
EtherCAT Adr. | Feste Adresse eines EtherCAT-Gerätes/IO-Link-Masters. Diese Adresse wird vom EtherCAT-Gerät/IO-Link Master während der Start-Up-Phase vergeben. Um den Default-Wert zu ändern, müssen Sie zuvor das Kontrollkästchen links von dem Eingabefeld markieren.
Vorgänger Port | Name und Port des EtherCAT-Geräts/IO-Link-Masters, an den dieses Gerät angeschlossen ist. Falls es möglich ist, dieses Gerät mit einem anderen zu verbinden, ohne die Reihenfolge der EtherCAT-Geräte/IO-Link-Master im Kommunikationsring zu ändern, dann ist dieses Kombinationsfeld aktiviert und Sie können das EtherCAT-Gerät oder den IO-Link Master auswählen, mit dem dieses Gerät verbunden werden soll.
Weitere Einstellungen | Diese Schaltfläche öffnet die Dialoge für die erweiterten Einstellungen.
Der Link am unteren Rand des Karteireiters führt Sie im Internet auf die Produktseite dieses IO-Link Masters.
Karteireiter Prozessdaten
Zeigt die Konfiguration der Prozessdaten an. Die Eingangs- und Ausgangsdaten des IO-Link Masters werden als CANopen Prozess-Daten-Objekte (PDO) dargestellt. Falls der IO-Link Master es unterstützt, ermöglicht dieser Dialog dem Anwender ein PDO über PDO-Zuordnung auszuwählen und den Inhalt des individuellen PDOs zu variieren.
Karteireiter Prozessdaten
Sync-Manager
Listet die Konfiguration der Sync-Manager (SM) auf.
Wenn der IO-Link Master eine Mailbox hat, wird der SM0 für den Mailbox-Output (MbxOut) und der SM1 für den Mailbox-Intput (MbxIn) benutzt.
Der SM2 wird für die Ausgangsprozessdaten (Outputs) und der SM3 (Inputs) für die Eingangsprozessdaten benutzt.
Wenn ein Eintrag ausgewählt ist, wird die korrespondierende PDO-Zuordnung in der darunter stehenden Liste PDO-Zuordnung angezeigt.
PDO-Zuordnung
PDO-Zuordnung des ausgewählten Sync-Managers. Hier werden alle für diesen Sync-Manager-Type definierten PDOs aufgelistet:
▪
Wenn in der Sync-Manager-Liste der Ausgangs-Sync-Manager (Outputs) ausgewählt ist, werden alle RxPDOs angezeigt.
▪
Wenn in der Sync-Manager-Liste der Eingangs-Sync-Manager (Inputs) ausgewählt ist, werden alle TxPDOs angezeigt.
Die markierten Einträge sind die PDOs, die an der Prozessdatenübertragung teilnehmen. Diese PDOs werden in der Baumdarstellung des System-Managers als Variablen des IO-Link-Masters angezeigt. Der Name der Variable ist identisch mit dem Parameter Name des PDO, wie er in der PDO-Liste angezeigt wird. Falls ein Eintrag in der PDO-Zuordnungsliste deaktiviert ist (nicht markiert und ausgegraut), zeigt dies an, dass dieser Eintrag von der PDO-Zuordnung ausgenommen ist. Um ein ausgegrautes PDO auswählen zu können, müssen Sie zuerst das aktuell angewählte PDO abwählen.
Aktivierung der PDO-Zuordnung
•
Den IO-Link Master einmal den Statusübergang PS (von Pre-Operational zu Safe-Operational) durchlaufen lassen (siehe Karteireiter Online)
•
den System-Manager des IO-Link-Masters neu laden (Schaltfläche [image])
PDO-Liste
Liste aller von diesem IO-Link Master unterstützten PDOs. Der Inhalt des ausgewählten PDOs wird der Liste PDO-Content angezeigt. Durch Doppelklick auf einen Eintrag können Sie die Konfiguration des PDO ändern.
Spalte | Beschreibung
Index | Index des PDO.
Size | Größe des PDO in Byte.
Name | Name des PDO. Wenn dieses PDO einem Sync-Manager zugeordnet ist, erscheint es als Variable des Slaves mit diesem Parameter als Namen.
Flags | F | Fester Inhalt: Der Inhalt dieses PDO ist fest und kann nicht vom System-Manager geändert werden.
 | M | Obligatorisches PDO (Mandatory). Dieses PDO ist zwingend Erforderlich und muss deshalb einem Sync-Manager Zugeordnet werden! Als Konsequenz können Sie dieses PDO nicht aus der Liste PDO-Zuordnungen streichen
SM | Sync-Manager, dem dieses PDO zugeordnet ist. Falls dieser Eintrag leer ist, nimmt dieses PDO nicht am Prozessdatenverkehr teil.
SU | Sync-Unit, der dieses PDO zugeordnet ist.
PDO-Inhalt
Zeigt den Inhalt des PDOs an. Falls das Flag F (fester Inhalt) des PDOs nicht gesetzt ist, können Sie den Inhalt ändern.
Download
Falls das Gerät intelligent ist und über eine Mailbox verfügt, können die Konfiguration des PDOs und die PDO-Zuordnungen zum Gerät herunter geladen werden. Dies ist ein optionales Feature, das nicht von allen IO-Link-Mastern unterstützt wird.
PDO-Zuordnung
Falls dieses Kontrollkästchen angewählt ist, wird die PDO-Zuordnung die in der PDO-Zuordnungsliste konfiguriert ist beim Startup zum Gerät herunter geladen. Die notwendigen, zum Gerät zu sendenden Kommandos können in dem Karteireiter Startup betrachtet werden.
PDO-Konfiguration
Falls dieses Kontrollkästchen angewählt ist, wird die Konfiguration des jeweiligen PDOs (wie sie in der PDO-Liste und der Anzeige PDO-Inhalt angezeigt wird) zum IO-Link -Slave herunter geladen.
Karteireiter Startup
Der Karteireiter Startup wird angezeigt, wenn der IO-Link-Master eine Mailbox hat und das Protokoll CANopen over EtherCAT (CoE) oder das Protokoll Servo drive over EtherCAT unterstützt. Mit Hilfe dieses Karteireiters können Sie betrachten, welche Download-Requests während des Startups zur Mailbox gesendet werden. Es ist auch möglich neue Mailbox-Requests zur Listenanzeige hinzuzufügen. Die Download-Requests werden in derselben Reihenfolge zum Master gesendet, wie sie in der Liste angezeigt werden.
Karteireiter Startup
Spalte
Beschreibung
Transition
Übergang, in den der Request gesendet wird. Dies kann entweder
▪
der Übergang von Pre-Operational to Safe-Operational (PS) oder
▪
der Übergang von Safe-Operational to Operational (SO) sein.
Wenn der Übergang in "<>" eingeschlossen ist (z.B. <PS>), dann ist der Mailbox Request fest und kann vom Anwender nicht geändert oder gelöscht werden.
Protokoll
Art des Mailbox-Protokolls
Index
Index des Objekts
Data
Datum, das zu diesem Objekt heruntergeladen werden soll.
Kommentar
Beschreibung des zu der Mailbox zu sendenden Requests
Move Up | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach oben.
Move Down | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach unten.
New | Diese Schaltfläche fügt einen neuen Mailbox-Download-Request, der während des Startups gesendet werden soll hinzu.
Delete | Diese Schaltfläche löscht den markierten Eintrag.
Edit | Diese Schaltfläche editiert einen existierenden Request.
Karteireiter CoE - Online
Wenn der IO-Link-Master das Protokoll CANopen over EtherCAT (CoE) unterstützt, wird der zusätzliche Karteireiter CoE - Online angezeigt. Dieser Dialog listet den Inhalt des Objektverzeichnisses des Masters auf (SDO-Upload) und erlaubt dem Anwender den Inhalt eines Objekts dieses Verzeichnisses zu ändern. Details zu den Objekten der einzelnen IO-Link-Geräte finden Sie in den gerätespezifischen Objektbeschreibungen.
Karteireiter CoE - Online
Darstellung der Objekt-Liste
Spalte | Beschreibung
Index | Index und Subindex des Objekts
Name | Name des Objekts
Flags | RW | Das Objekt kann ausgelesen und Daten können in das Objekt geschrieben werden (Read/Write)
 | RO | Das Objekt kann ausgelesen werden, es ist aber nicht möglich Daten in das Objekt zu schreiben (Read only)
 | P | Ein zusätzliches P kennzeichnet das Objekt als Prozessdatenobjekt.
Wert | Wert des Objekts
Update List | Die Schaltfläche Update List aktualisiert alle Objekte in der Listenanzeige
Auto Update | Wenn dieses Kontrollkästchen angewählt ist, wird der Inhalt der Objekte automatisch aktualisiert.
Advanced | Die Schaltfläche Advanced öffnet den Dialog Advanced Settings. Hier können Sie festlegen, welche Objekte in der Liste angezeigt werden.
Erweiterte Einstellungen
Online - über SDO-Information | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis des Gerätes enthaltenen Objekte über SDO-Information aus dem Master hochgeladen. In der untenstehenden Liste können Sie festlegen welche Objekt-Typen hochgeladen werden sollen.
Offline - über EDS-Datei | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis enthaltenen Objekte aus einer EDS-Datei gelesen, die der Anwender bereitstellt.
Karteireiter Diag History
Über den Karteireiter "Diag History" können geloggte Diagnose-Meldungen vom Controller Protokoll ausgelesen werden. Der Diagnosepuffer arbeitet als Ringpuffer mit einer derzeitigen Größe von max. 1000 Einträgen.
Karteireiter DiagHistory
Die auftretenden Ereignisse werden nach Typ (Information, Warnung, Fehler), Flag (N = unbestätigt, Q = bestätigt), Auftreten des Ereignisses (Zeitstempel) und Nachricht (Port-Nummer & Eventcode) aufgegliedert.
Die Bedeutung der einzelnen Meldungen ist der Herstellerdokumentation zu entnehmen. Anhand der Portnummer kann das IO-Link Device direkt zugeordnet werden. Eine Verwaltung der eintreffenden Ereignisse kann über die verschiedenen Buttons erfolgen.
▪
Update History: ist das Feld "Auto Update" nicht ausgewählt, so können über den Button "Update History" die aktuellen Ereignisse angezeigt werden
▪
Auto Update: ist das Feld ausgewählt, so wird die Liste der auftretenden Ereignisse automatisch aktualisiert
▪
Only new Messages: ist das Feld ausgewählt, so werden nur die Meldungen angezeigt, die noch nicht bestätigt wurden
▪
Ack. Messages: ein auftretendes Ereignis wird über das Bit Device Diag (Index 0xF101:10) gemeldet. Eine Bestätigung der Meldung setzt das Bit wider auf 0.
▪
Export Diag History: die aufgetretenen Ereignisse können als "txt"- Datei exportiert und somit archiviert werden.
▪
Advanced: dieses Feld hat für die IO-Link Master Klemmen/Boxen keine Funktion.
Karteireiter Online
Karteireiter Online
Status Maschine
Init | Diese Schaltfläche versucht den IO-Link-Master auf den Status Init zu setzen.
Pre-Op | Diese Schaltfläche versucht den IO-Link-Master auf den Status Pre-Operational zu setzen.
Op | Diese Schaltfläche versucht den IO-Link-Master auf den Status Operational zu setzen.
Bootstrap | Diese Schaltfläche versucht den IO-Link-Master auf den Status Bootstrap zu setzen.
Safe-Op | Diese Schaltfläche versucht den IO-Link-Master auf den Status Safe-Operational zu setzen.
Fehler löschen | Diese Schaltfläche versucht die Fehleranzeige zu löschen. Wenn ein IO-Link-Master beim Statuswechsel versagt, setzt er eine Fehler-Flag. Beispiel: ein IO-Link-Master ist im Zustand PREOP (Pre-Operational). Nun fordert der Master den Zustand SAFEOP (Safe-Operational) an. Wenn der Master nun beim Zustandswechsel versagt, setzt er das Fehler-Flag. Der aktuelle Zustand wird nun als ERR PREOP angezeigt. Nach Drücken der Schaltfläche Fehler löschen ist das Fehler-Flag gelöscht und der aktuelle Zustand wird wieder als PREOP angezeigt.
Aktueller Status | Zeigt den aktuellen Status des IO-Link-Masters an.
Angeforderter Status | Zeigt den für den IO-Link-Master angeforderten Status an.


Wiederherstellen des Auslieferungszustandes von einem EtherCAT-Gerät

Inbetriebnahme/Konfiguration IO-Link Master/Device [image] IO-Link Master [image] Wiederherstellen des Auslieferungszustandes von einem EtherCAT-Gerät
Wiederherstellen des Auslieferungszustandes von einem EtherCAT-Gerät
Um den Auslieferungszustand der Backup-Objekte von der EP6224-xxxx (IO-Link Master) wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoEObjekt „Restore default parameters“, „Subindex 001“ angewählt werden (siehe nachfolgende Abbildung).
Auswahl des PDO Restore default parameters
Durch Doppelklick auf „SubIndex 001“ gelangen Sie in den „Set Value Dialog“ (siehe nachfolgende Abbildung). Tragen Sie im Feld „Dec“ den Wert 1684107116 oder alternativ im Feld „Hex“ den Wert 0x64616F6C ein und bestätigen Sie mit OK. Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.
Eingabe des Restore-Wertes im Set Value Dialog


Zugriff auf IO-Link Parameter

Inbetriebnahme/Konfiguration IO-Link Master/Device [image] Zugriff auf IO-Link Parameter
Zugriff auf IO-Link Parameter
Der Austausch der azyklischen Daten erfolgt über einen festgelegten Index- und Subindex-Bereich, der gerätespezifisch ist und in der entsprechenden Herstellerdokumentation nachgelesen werden kann.
Parameter Datenaustausch
Ein intelligenter IO-Link Sensor/Aktuator (in der vorherigen Abbildung mit „Sensor (IO-Link Device)“ gekennzeichnet) kann eine Parametrierung durch SPDU (Service Protocol Data Units) unterstützen. Diese azyklischen Servicedaten müssen von der SPS explizit angefragt oder, als solche gekennzeichnet, gesendet werden.
Zugang SPDU
TwinCAT unterstützt den Zugriff über ADS und über das EP6224-xxxx CoE-Verzeichnis.
Über den sogenannten SPDU Index wird der entsprechende Parameter adressiert, verfügbar sind die Bereiche:
Bezeichnung | Bereich Index
System | 0x00..0x0F
Identification | 0x10..0x1F
Diagnostic | 0x20..0x2F
Communication | 0x30..0x3F
Prefered Idnex | 0x40..0xFE
Extended Index | 0x0100..0x3FFF
 | der Bereich 0x4000..0xFFFF ist reserviert
Die Nutzung der Implementierung dieser Bereiche obliegt dem Sensor/Aktor-Hersteller. Zur Verdeutlichung sehen Sie hier nur einige mögliche Indexe mit Bezeichnung aufgeführt, sehen Sie sich dazu das entsprechende Kapitel „Objektbeschreibung und Parametrierung“ an.
Index | Name
0010 | Vendor Name
0011 | Vendor Text
0012 | Product Name
0013 | Product ID
0015 | Serial Number
0016 | Hardware Revision
0017 | Firmware Revision
... | ...
ADS
Die Kommunikation der IO-Link Bedarfsdaten wird über einen ADS Befehl ausgeführt. Eine ADS-Adresse besteht immer aus NetID und PortNr. Ein ADS Befehl wird von TwinCAT über AoE (ADS over EtherCAT) an das Box-Modul EP6224 weitergeleitet. Dort wird der Befehl an den IO-Link Masterteil und damit an den Bedarfsdatenkanal weitergeleitet.
AoE-NetID
Die EP6224 bekommt zur Kommunikation mit dem IO-Link Masterteil eine eigene AoE-NetID. Diese wird vom Konfigurationstool vergeben (siehe nachfolgende Abbildung).
Vergabe AoE-NetID
PortNr
Die Zuordnung der einzelnen IO-Link Ports des Masters erfolgt über die Portnummer. Die Portnummern werden Aufsteigend ab 0x1000 vergeben. D. h. IO-Link Port1 === PortNr 0x1000 und IO-Link Portn === PortNr 0x1000 + n-1.
Für die EP6224 (4-Port IO-Link Master) gilt folgende Festlegung:
IO-Link Port1 === PortNr 0x1000
IO-Link Port2 === PortNr 0x1001
IO-Link Port3 === PortNr 0x1002
IO-Link Port4 === PortNr 0x1003
ADS Indexgroup
Die Indexgroup eines ADS Befehls ist, wie beim CoE, auf 0xF302 für den IO-Link-Bedarfsdatenkanal festgelegt.
ADS Indexoffset
Im Indexoffset ist die IO-Link Adressierung mit Index und Subindex codiert. Der Indexoffset ist 4-Byte groß und wie folgt aufgeteilt: 2-Byte Index, 1-Byte reserved, 1-Byte Subindex.
▪
Bsp.: für Index 0x1234 und Subindex 56 entspricht Indexoffset 0x12340056
Beispiel mit ADS Monitor
Auslesen des „Application Specific Name“, Index 0x0018 Subindex 0x00 (siehe nachfolgende Abbildung).
Auslesen des Application Specific Name
Auslesen des Application Specific Name
Beispiel Prinzip im Code
Auslesen des „Application Specific Name“, Index 0x0018 Subindex 0x00 am IO-Link Port2.
AmsAddr adsAdr;
adsAdr.netId.b[0] = 0x0A; //AoE-NetID der EP6224
adsAdr.netId.b[1] = 0x03; //AoE-NetID der EP6224
adsAdr.netId.b[2] = 0x02; //AoE-NetID der EP6224
adsAdr.netId.b[3] = 0x16; //AoE-NetID der EP6224
adsAdr.netId.b[4] = 0x02; //AoE-NetID der EP6224
adsAdr.netId.b[5] = 0x03; //AoE-NetID der EP6224
adsAdr.port = 0x1001; //IO-Link Port2
errCode = AdsSyncReadReq(&adsAdr, 0xF302, 0x00180000, 100, &pReadBuffer);


IO-Link Device

Inbetriebnahme/Konfiguration IO-Link Master/Device [image] IO-Link Device
IO-Link Device
Weiterführende Informationen
•
Konfiguration der IO-Link Devices
•
EPI2xxx, ERI2xxx - Prozessdaten
•
Einstellungen (Settings) der IO-Link Devices
•
EPIxxxx, ERIxxxx - Einstellen der IO-Link Device Parameter
•
EPI2xxx, ERI2xxx - Einstellen der IO-Link Device Parameter
•
EPI23xx-xxxx, ERI23xx-xxxx - Eingangsentprellung und Eingangssignalverlängerung
•
Objektübersicht - EPI2338-0001
•
EPI2008-000x, ERI2008-000x - Objektbeschreibung und Parametrierung
•
EPI2809-002x, ERI2809-002x - Objektbeschreibung und Parametrierung
•
EPI2338-000x, ERI2338-000x - Objektbeschreibung und Parametrierung
•
EPI2339-002x, ERI2339-002x - Objektbeschreibung und Parametrierung
•
Firmware Update des IO-Link Devices


Konfiguration der IO-Link Devices

Inbetriebnahme/Konfiguration IO-Link Master/Device [image] IO-Link Device [image] Konfiguration der IO-Link Devices
Konfiguration der IO-Link Devices
IO-Link Extension
Die IO-Link Extension für die EP6224-xxxx funktioniert ab der TwinCAT Version 2.10, Build 1325 und wird bis zu der Version 2.10, Build 1330 benötigt. Falls Ihre System Manager-Version bzw. TwinCAT3 noch nicht über diese Unterstützung verfügt, können sie ggf. nachinstalliert werden. Bitte wenden Sie sich dazu an den Support.
Einbinden der IO-Link Devices
Der Katalog unterstützt die IO-Link Gerätebeschreibung (IODD). Unter dem folgenden Link können die IODDs für die Beckhoff- IO-Link-Box-Module EPIxxxx, ERIxxxx heruntergeladen werden: Download IODD. Die heruntergeladene Zip-Datei enthält die IODD Device Description Files für die Beckhoff-IO-Link-Box-Module EPIxxxx, ERIxxxx.
Keine manuelle Kopie der XML-Dateien
Dateien nicht direkt in den Ordner kopieren, sondern über Import Devicedescription einlesen lassen! Wichtige Prüfungen werden sonst umgangen!
Das Einbinden der IODD Datei sollte immer der erste Schritt sein, da dadurch die Aufschlüsselung der einzelnen Prozessdaten des IO-Link Devices sowie die Anzeige der Parameter ermöglicht wird.
Es gibt mehrere Möglichkeiten ein IO-Link Device einzubinden:
1.
Importieren der IODD Datei (offline & online) über
–
Button Import Devicedescription (A) oder
–
Button IODD Finder (B)
2.
Automatisches Scannen der IO-Link Ports (online) über
–
Button Scan devices (C)
3.
Manuelles Einfügen (offline & online) über
–
Menü Create Device (D)
Anlegen von IO-Link Devices_1
Anlegen von IO-Link Devices
Liegt die IODD nicht vor, so sollte das IO-Link Device online über Scannen eingebunden werden. Das manuelle Einbinden der IO-Link Devices über Create Device sollte nur vorgenommen werden, wenn die IODD vom Hersteller und das IO-Link Device zum Zeitpunkt der Projekterstellung nicht vorliegen.
Soll der IO-Link Port als einfacher digitaler Ein- oder Ausgang benutzt werden, so kann in dem IO-Link Device Catalog die Auswahl "Std-I/O" -> "dig in" bzw. "dig out" ausgewählt werden. Nach Neustarten des EtherCAT Systems oder Neuladen der Konfiguration im Config-Modus (F4) werden die entsprechenden Prozessdaten angelegt.
Konfiguration Port 2 als digitaler Eingang
Entfernen der IO-Link Devices
Um ein bereits konfiguriertes IO-Link Device zu entfernen, öffnen Sie mit Rechtsklick das Kontextmenü und wählen Delete. Nach Neustarten des EtherCAT Systems oder Neuladen der Konfiguration im Config-Modus (F4) werden die bereits angelegten Prozessdaten entfernt.
Weiterführende Informationen
•
1. Importieren der Gerätebeschreibung IODD
•
2. Automatisches Scannen der IO-Link Ports
•
3. Manuelles Einfügen über Create Device


1. Importieren der Gerätebeschreibung IODD

Inbetriebnahme/Konfiguration IO-Link Master/Device [image] IO-Link Device [image] Konfiguration der IO-Link Devices [image] 1. Importieren der Gerätebeschreibung IODD
1. Importieren der Gerätebeschreibung IODD
Der Import der Gerätebeschreibung vereinfacht das Einbinden der IO-Link Devices. Die einzelnen Prozessdaten werden aufgeschlüsselt, eine einfache Parametrierung des Sensors wird dadurch ermöglicht. Die IODD muss nur bei der erstmaligen Inbetriebnahme eines neuen IO-Link Devices importiert werden. Der Import ist Port-unabhängig. Beim Import der IODD sollte wie folgt vorgegangen werden:
▪
Button "Import Devicedescription“
–
Button Import Devicedescription im Karteireiter IO-Link drücken
–
Auswählen der .xml-Datei des gewünschten Sensors,
–
nach Betätigen des Öffnen Buttons werden die importierten Dateien im folgenden Ordner abgelegt:
- für TwinCAT 2.x: \TwinCAT\IO\IOLink
- für TwinCAT 3.x: \TwinCAT\3.X\Config\IO\IOLink.
–
Die importierten Gerätebeschreibungen werden im Feld Catalog in einer Baumstruktur, nach Hersteller geordnet, aufgeführt.
Keine manuelle Kopie der XML-Dateien
Dateien nicht direkt in den Ordner kopieren, sondern über Import Devicedescription einlesen lassen! Wichtige Prüfungen werden sonst umgangen!
▪
Button "IODD Finder“
–
Button IODD Finder im Karteireiter IO-Link drücken
–
Suchen des gewünschten IO-Link-Sensors/-Devices durch Eingabe in die Suchmaske s. folgende Abb. (1)
–
Auswählen des gewünschten IO-Link-Sensors/-Devices. Bewegen Sie den Mauszeiger über die Abbildung des gewünschten IO-Link-Sensors/-Devices. Es erscheint ein blaues Downloadsymbol s. folgende Abb. (2).
IODD Finder, Auswahl und Import der .xml-Datei
–
Nach Klick auf das Downloadsymbol wird die .xml-Datei des gewählten IO-Link-Sensors/-Devices importiert und in folgendem Ordner abgelegt:
- für TwinCAT 2.x: \TwinCAT\IO\IOLink
- für TwinCAT 3.x: \TwinCAT\3.X\Config\IO\IOLink
–
Bei Bewegung des Mauszeigers auf den IO-Link-Sensor/-Device zeigt jetzt ein grünes Symbol (s. folgende Abb. (3)), dass die .xml Datei bereits vorliegt.
IODD Finder, Anzeige einer bereits importierten Gerätebeschreibung
–
Die importierten Gerätebeschreibungen werden im Feld Catalog des IO-Link Karteireiters in einer Baumstruktur, nach Hersteller geordnet, aufgeführt.
▪
Online Konfiguration: ist das IO-Link Device angeschlossen, so wird dieses automatisch nach Drücken des Button Scan devices erkannt und mit entsprechenden Parametern angelegt.
Sind in der IODD-Datei mehrere Devices hinterlegt, so wird hier immer der erste Eintrag ausgewählt. Eine Gruppierung in der IODD wird vom Hersteller meist dann durchgeführt, wenn die Prozessdaten gleich sind und lediglich mechanische Unterschiede vorliegen (z. B. anderes Material).
▪
Offline Konfiguration: im Feld Catalog wird der IO-Link Device Catalog angezeigt, hier sind die bereits importierten Gerätebeschreibungen - in einer Baumstruktur nach Hersteller geordnet - aufgeführt. Die Auswahl des IO-Link Devices erfolgt per drag-and-drop oder durch Rechtsklick auf das Produkt mit "Add to Port n".
▪
Neustarten des EtherCAT Systems oder Neuladen der Konfiguration im Config-Modus (F4).
▪
Die IO-Link Geräte werden angezeigt und die Prozessdaten angelegt. Wird ein Fehler beim Einbinden des IO-Link Devices festgestellt, z. B. falsche VendorID oder kein Device angeschlossen, so wird dies über den Status des Ports (Objekt State Ch.n 0xF100:0n) angezeigt.


2. Automatisches Scannen der IO-Link Ports

Inbetriebnahme/Konfiguration IO-Link Master/Device [image] IO-Link Device [image] Konfiguration der IO-Link Devices [image] 2. Automatisches Scannen der IO-Link Ports
2. Automatisches Scannen der IO-Link Ports
In diesem Teil der Dokumentation wird die Konfiguration der physisch vorhandenen IO-Link Devices in TwinCAT beschrieben.
Beim automatischem Scannen der IO-Link Ports werden die Schritte WakeUp Impuls, Einstellung der Baudrate, Auslesen der Kommunikationsparameter sowie ggfs. Parameterserver und Zyklischer Datenaustausch durchgeführt, vgl. Aufbau der IO-Link Kommunikation. Dazu muss das entsprechende IO-Link Device an den IO-Link Port angeschlossen sein.
Die angeschlossenen Geräte werden automatisch erkannt, konfiguriert und die dazugehörige IODD gesucht.
Angeschlossene IO-Link Devices finden
Die angeschlossenen IO-Link Devices werden mit klicken auf den Button Scan devices (s. folgende Abb. (C) gefunden.
Anlegen von IO-Link Devices_1
Scan devices (C)
In dem Informationsfenster wird für jeden der vier Ports das angeschlossene Device aufgelistet. Es ist nur der Port 2 des Masters mit einem IO-Link Device belegt. Bestätigen mit dem Button OK.
Information Scan for Devices
Information Scan devices
Um mit den Devices arbeiten zu können, muss der Button Reload Devices (F4) angeklickt werden.
Button: Reload Devices
Die IO-Link Devices sind jetzt in der General-Anzeige eingetragen. Im Feld Details von Port 2 werden Informationen zu dem angeschlossenen Device angezeigt.
Device an Port2
Device an Port 2
Weitere Details werden durch Rechtsklick auf Port 2 im Dialog Settings angezeigt (s. auch Kapitel Einstellungen (Settings) der IO-Link Devices).
Settings Device Port2
Settings Device Port2
Nach Doppelklick auf Port 2 wird der Karteireiter Parameter angezeigt. Hier werden die Parameter des jeweiligen IO-Link Devices aufgeführt (s. auch Kapitel EPIxxxx, ERIxxxx - Einstellen der IO-Link Device Parameter).
Parameter IO-Link Device
Parameter IO-Link Device


3. Manuelles Einfügen über Create Device

Inbetriebnahme/Konfiguration IO-Link Master/Device [image] IO-Link Device [image] Konfiguration der IO-Link Devices [image] 3. Manuelles Einfügen über Create Device
3. Manuelles Einfügen über Create Device
In diesem Teil der Dokumentation wird die manuelle Konfiguration des IO-Link Devices in TwinCAT beschrieben.
Das manuelle Einfügen des IO-Link Devices sollte nur dann durchgeführt werden, wenn die IODD vom Hersteller und das IO-Link Device nicht vorliegen.
Die Konfiguration kann dann manuell vorgenommen werden. Durch das Abspeichern des Projektes werden die Einstellungen der einzelnen Ports gespeichert. Die angelegten Devices werden nicht im Catalog (s. folgende Abb. (A)) hinterlegt.
▪
Zum manuellen Einfügen der IO-Link Devices über Create Device gehe man wie folgt vor:
▪
Liegt die entsprechende IODD des IO-Link Devices bereits vor, so kann im Katalog (s. folgende Abb. (A) sortiert nach dem Hersteller das entsprechende Device ausgewählt werden
▪
Liegt keine IODD vor, so kann das Device manuell zugefügt werden. Diese Daten werden nicht im Katalog gespeichert und müssen für jeden Port manuell eingegeben werden.
▪
Mit Rechtsklick auf den Port das Kontextmenü (s. folgende Abb. (B)) öffnen und Create Device auswählen.
▪
Im Create Device Dialog kann ein IO-Link Device mit den Basis-Kommunikationsparametern anlegt werden. Pflichtfelder sind hierbei: Vendor ID, Device ID, und Prozessdatenlänge, siehe folgende Abb. (D). Die Werte VendorID und DeviceID können sowohl als hexadezimal (Eingabeformat: 0xnnnn) als auch Dezimalzahl (nnnn) eingegeben werden.
Die einzutragenden Kommunikationsparameter entnehmen Sie den Informationen, die vom Device-Hersteller zur Verfügung gestellt werden.
▪
Handelt es sich um ein IO-Link Device der Version 1.1, so wird durch die Auswahl des Feldes der Parameterserver aktiviert.
▪
Neustarten des EtherCAT Systems oder Neuladen der Konfiguration im Config-Modus (F4)
Manuelles Anlegen eines IO-Link Devices über den "Create Device" Dialog (D)
IODD einlesen
Auch beim manuellen Anlegen und Scannen sollte immer die IODD zusätzlich eingelesen werden, um weitere sensorspezifische Informationen angezeigt zu bekommen.
Wird das IO-Link Device manuell angelegt, können in den Settings der IO-Link Geräte noch einige Einstellungen der Geräte vorgenommen werden (siehe Einstellungen (Settings der IO-Link Devices)


EPI2xxx, ERI2xxx - Prozessdaten

Inbetriebnahme/Konfiguration IO-Link Master/Device [image] IO-Link Device [image] EPI2xxx, ERI2xxx - Prozessdaten
EPI2xxx, ERI2xxx - Prozessdaten
Die Prozessdaten der EPI2xxx, ERI2xxx werden im System Manager in der Baumstruktur unter dem zugehörigen Port (A) angezeigt (im untenstehenden Beispiel Port 1 für EPI2338-0001).
Abhängig von Anzahl der Kanäle bieten die EPI2xxx, ERI2xxx 8 Bit oder 16 Bit Ausgangsdaten zur Übertragung an.
Die EPI23xx/ERI23xx - Boxen bieten je 8 Bit oder je 16 Bit Eingangs- und Ausgangsdaten zur Übertragung an (s. folgende Abbildung A und B).
Die Prozessdaten der der einzelnen Boxen finden Sie im Kapitel Produktübersicht.
Default Prozessdaten am Beispiel der EPI2338-0001
Durch Rechtsklick auf die Statusvariable im Konfigurationsbaum (A, B) kann die Struktur zur Verlinkung geöffnet werden.
Die Offsetposition kann unter Berücksichtigung der Variablengröße (E) der Speicherbelegungsanzeige (F) anhand der Punktnotation entnommen werden.
Control/Status-Wort
Die EPI2xxx und ERI2xxx Boxen haben kein Status- und Control-Wort.


Einstellungen (Settings) der IO-Link Devices

Inbetriebnahme/Konfiguration IO-Link Master/Device [image] IO-Link Device [image] Einstellungen (Settings) der IO-Link Devices
Einstellungen (Settings) der IO-Link Devices
Um die Basiseinstellungen der Devices für jeden Port zu finden, öffnen Sie mit Rechtsklick auf den Port das Kontextmenü und wählen Settings. Es wird ein neuer Karteireiter Portx:: Settings geöffnet.
Kontextmenü - Settings
Einstellungen der IO-Link Devices
1.
Information
Dieses Feld ist rein informativ, unter Device Description wird die Bezeichnung der eingelesenen IODD angezeigt. Weiterhin sind die VendorID, DeviceID und die IO-Link Revision (V 1.0 oder V 1.1) des IO-Link Devices angegeben. Handelt es sich um ein IO-Link Device V 1.1, so wird die Funktionalität des Parameterservers unterstützt.

Bei den Settings der IO-Link Geräte können folgende Einstellungen vorgenommen werden (s. Abb. oben):
2.
Start-up checks
Hier kann ausgewählt werden, ob beim Anlauf des IO-Link Gerätes die Vendor ID und die Device ID geprüft werden sollen. Dadurch werden Fehler beim Austausch von IO-Link Devices vermieden.
3.
CycleTime
Hier wird die Zykluszeit des IO-Link Masters angegeben
4.
Communication mode
Auswahl des Modus, in dem der IO-Link Port betrieben werden soll.
–
Communication: Default Modus für IO-Link Geräte
–
StdDigIn / StdDigOut: Modus für nicht IO-Link Geräte, automatische Auswahl, wenn der Port als digitaler Ein- oder Ausgang konfiguriert wurde
5.
Error Reaction
–
Wird das Feld Set Input Data to 0 aktiviert
-> Eingangsdaten werden im Fehlerfall auf 0 gesetzt
-> Statusanzeige: Fehler
6.
Button "Advanced"
Erweiterte Einstellungen
7.
Data Storage
Man beachte die Version der Sensoren
–
V1.0 -> Data Storage wird nicht unterstützt
–
V1.1 -> Daten werden im Parameterserver gespeichert (Voreinstellung)
8.
Process Data Format
Anpassen des Prozessdatenformats
–
Feld only Octet String ausgewählt
-> komplexe Datentypen (Prozessdaten) werden als Octet String angelegt
-> Vorteil: einfache Weiterverarbeitung in der SPS


EPIxxxx, ERIxxxx - Einstellen der IO-Link Device Parameter

Inbetriebnahme/Konfiguration IO-Link Master/Device [image] IO-Link Device [image] EPIxxxx, ERIxxxx - Einstellen der IO-Link Device Parameter
EPIxxxx, ERIxxxx - Einstellen der IO-Link Device Parameter
In diesem Kapitel wird erläutert wie Sie die IO-Link Device Parameter auslesen und einstellen können.
Die Anzahl und Art der angezeigten Objekte im Reiter Parameter variieren je nach Sensortyp.
Zunächst sind die Default-Einstellungen, wie in der entsprechenden IODD hinterlegt, zu sehen.
Zum Öffnen des Karteireiters Parameter
▪
IO-Link Master (EP6224-xxxx) in der TwinCAT Baumstruktur anklicken,
▪
Karteireiter IO-Link anklicken,
▪
wählen Sie den Port an dem das IO-Link Device angeschlossen ist,
▪
öffnen Sie den Karteireiter Parameter per Doppelklick oder
▪
über Rechtsklick und Auswahl von Parameter.
Öffnen des Karteireiters Parameter
IO-Link Device Parameter
Die Device Parameter werden in dem Karteireiter aufgeführt. Im Karteireiter oben befinden sich die Buttons Compare, Read, Write, Set to Default, Export/Import, und Store.
Über die Buttons Read, Write und Store werden die im IO-Link Device gespeicherten Parameter ausgelesen, geladen und im Parameterserver des Masters gespeichert.
Über das Drop-down-Menü können verschiedene Benutzerrollen gewählt werden. Voreingestellt ist die Benutzerrolle Specialist. Die Parameter werden in unterschiedlichen Darstellungen und Umfängen angezeigt.
Compare-Button
▪
Durch Drücken des Compare Buttons werden die Parameterdaten der Konfiguration verglichen mit den Parametersätzen im Sensor und im Parameterserver.
Read-Button
▪
Voreingestellt sind immer die Default-Werte aus der IODD-Datei
▪
Erst durch Drücken des Read-Buttons werden die aktuellen Parameterwerte ausgelesen
Write-Button
▪
Voreingestellt sind immer die Default-Werte aus der IODD-Datei
▪
Eintragen des gewünschten Wertes unter Value
▪
Durch Drücken der Enter-Taste werden die Werte übernommen
▪
Drücken des Write-Buttons, um Daten in Gerät zu schreiben, (offline Konfiguration möglich)
Set Default-Button
▪
Durch Drücken des Set Default-Buttons werden alle Parameterwerte auf die Voreinstellungen gebracht.
Export / Import-Button
▪
Die eingestellten Parameterwerte können als .vbs - Datei exportiert und später über Import wieder hergestellt werden.
▪
Durch Drücken des Export / Import-Buttons s. folgende Abbildung (1) wird der Import / Export Dialog geöffnet
▪
Geben Sie den Pfad an, unter dem sie die vbs - Datei exportieren bzw. importieren möchten s. folgende Abb. (2) und bestätigen Sie mit dem Öffnen-Button s. folgende Abb. (4),
▪
Zusätzlich können die Exportoptionen Attach Store Command und Enable Block Parametrization s. folgende Abb. (3) gewählt werden
–
Attach Store Command: Die Parameter werden in den Parameterserver geladen, nachem das Script alle Werte geschrieben hat.
–
Enable Block Parametrization: Die Blockparametrierung wird eingeschaltet. Bei einigen Sensoren ist Schreiben nur möglich bei eingeschalteter Blockparametrierung.
▪
Drücken Sie den Export bzw. Import-Button
Parametrierung IO-Link device - Export / Import
Store-Button
▪
Klick auf Store (Data Storage): Der Beckhoff IO-Link Master EP6224-xxxx (ab Firmware 10) speichert die Parameter (0x0018) Application Specific Tag, (0x08n0) Settings und 0x3800 Range Settings. Bei Austausch des IO-Link Devices gegen ein baugleiches Modul, kann das Device wiederhergestellt werden.
Standard Command (Index 0x0002)
Der IO-Link Master schreibt während des Hochlaufs diverse IO-Link spezifische Kommandos in den Standard Command. Einige dieser Kommandos sind in der TwinCAT-Oberfläche verfügbar (siehe nachfolgende Abbildung). In der Parameter-Auflistung der Benutzerrolle All Objects die Standard Command anklicken und anschließend Doppelklick auf Standard Command im rechten Feld. Aus der Liste mit den unterschiedlichen Auswahlmöglichkeiten den gewünschten Wert auswählen und den Button Write nutzen (wie zuvor beschrieben).
Device Reset: Startet das IO-Link Device neu.
Application Reset: Hat keine Funktion.
Restore Factory Settings: Wiederherstellung der Applikationsparameter, also der Parameter (0x0800) Settings.
IO-Link Device Parameter: Standard Command
Application Specific Tag (Index 0x0018)
An dieser Stelle können Applikationsspezifische Informationen eingegeben und gespeichert werden. In der Parameter-Auflistung die Application Specific Tag anklicken und anschließend Doppelklick auf Application Specific Tag im rechten Feld. Applikationsspezifische Informationen eingeben und den Button Write und gegebenenfalls Store nutzen (wie zuvor beschrieben).
IO-Link Device Parameter: Application Specific Tag


EPI2xxx, ERI2xxx - Einstellen der IO-Link Device Parameter

Inbetriebnahme/Konfiguration IO-Link Master/Device [image] IO-Link Device [image] EPI2xxx, ERI2xxx - Einstellen der IO-Link Device Parameter
EPI2xxx, ERI2xxx - Einstellen der IO-Link Device Parameter
Weiterführende Informationen
•
Input Filter (Index 0x0800:01)
•
Signal Extension (Index 0x0800:02)
•
Diagnose (Index 0x0A00)


Input Filter (Index 0x0800:01)

Inbetriebnahme/Konfiguration IO-Link Master/Device [image] IO-Link Device [image] EPI2xxx, ERI2xxx - Einstellen der IO-Link Device Parameter [image] Input Filter (Index 0x0800:01)
Input Filter (Index 0x0800:01)
Die Input Filter Funktion wird unter EPI23xx-xxxx, EPI23xx-xxxx - Eingangsentprellung und Eingangssignalverlängerung erklärt. Zur Einstellung der Input Filter gehen sie wie folgt vor:
1.
Wählen Sie Im Karteireiter Parameter die Ansicht Specialist .
2.
Öffnen Sie die Parameter Liste und führen einen Doppelklick auf Input filter aus.
3.
Wählen sie den gewünschten Wert aus der Liste.
4.
Nutzen Sie den Button Write und gegebenenfalls Store (wie zuvor beschrieben).
Einstellung Input Filter (Index 0x0800:01)


Signal Extension (Index 0x0800:02)

Inbetriebnahme/Konfiguration IO-Link Master/Device [image] IO-Link Device [image] EPI2xxx, ERI2xxx - Einstellen der IO-Link Device Parameter [image] Signal Extension (Index 0x0800:02)
Signal Extension (Index 0x0800:02)
Die Signal Extension Funktion wird unter EPI23xx-xxxx, ERI23xx-xxxx - Eingangsentprellung und Eingangssignalverlängerung erklärt. Zur Einstellung der Signal Extension gehen sie wie folgt vor:
1.
Wählen Sie im Karteireiter Parameter die Ansicht Specialist.
2.
Öffnen Sie die Parameter Liste und führen einen Doppelklick auf Signal Extension aus.
3.
Wählen Sie den gewünschten Wert aus der Liste.
4.
Nutzen Sie den Button Write und gegebenenfalls Store (wie zuvor beschrieben).
Einstellung Signal Extension (Index 0x0800:02)


Diagnose (Index 0x0A00)

Inbetriebnahme/Konfiguration IO-Link Master/Device [image] IO-Link Device [image] EPI2xxx, ERI2xxx - Einstellen der IO-Link Device Parameter [image] Diagnose (Index 0x0A00)
Diagnose (Index 0x0A00)
Die Diagnose Parameter unterscheiden sich zwischen den unterschiedlichen Devices. Die Bedeutung der jeweiligen Diagnose Parameter (Index 0x0A00) kann in dem Kapitel Objektbeschreibung und Parametrierung nachgelesen werden.
(EPI2008-000x, ERI2008-000x / EPI2809-002x, ERI2809-002x / EPI2338-000x, ERI2338-000x / EPI2339-002x, ERI2339-002x)
In der nachfolgenden Abbildung sind als Beispiel die Diagnose Parameter der EPI2339-0021 dargestellt.
IO-Link Device Parameter: Diagnose am Beispiel der EPI2339-0021


EPI23xx-xxxx, ERI23xx-xxxx - Eingangsentprellung und Eingangssignalverlängerung

Inbetriebnahme/Konfiguration IO-Link Master/Device [image] IO-Link Device [image] EPI23xx-xxxx, ERI23xx-xxxx - Eingangsentprellung und Eingangssignalverlängerung
EPI23xx-xxxx, ERI23xx-xxxx - Eingangsentprellung und Eingangssignalverlängerung
Die digitalen IO-Link-Boxen EPI23xx und ERI23xx unterstützten für alle digitalen Eingänge eine konfigurierbare Eingangsentprellung sowie eine variable Eingangssignalverlängerung. Diese lassen sich über Device Parameter Objekt 0x0800 einstellen. Der eingestellte Wert gilt für alle digitalen Eingänge gemeinsam. Wie Sie die Parameter der IO-Link Devices einstellen, ist unter EPI2xxx, ERI2xxx - Einstellen der IO-Link Device Parameter erklärt.
Eingangsfilter: variabel Einstellbar über Device Parameter (Objekt 0x0800 Subindex 1)
Wert | Filterzeit [ms]
0 | 0
1 | 0.5
2 | 3
3 | 10
4 | 20
Der Wert bestimmt mit welcher Verzögerung der Eingangswert an die übergeordnete Steuerung gegeben wird. Impulse die kleiner als die Filterzeit sind werden ignoriert. In der nachfolgenden Abbildung sind Funktionsbeispiele mit einer Filterzeit von 10 ms dargestellt.
Signal Input Filter
Eingangssignalverlängerungszeit: variabel Einstellbar über Device Parameter (Objekt 0x0800 Subindex 2)
Wert | Eingangssignalverlängerungszeit [ms]
0 | 0
1 | 0.5
2 | 3
3 | 10
4 | 20
5 | 50
6 | 100
Der Parameter gibt die Zeit an, wie lange ein Eingangsimpuls bei Impulsänderung zusätzlich verlängert wird. Kurze Wechsel des Eingangsimpulses während der Eingangssignalverlängerung werden ignoriert.
Eingangssignalverlängerung
Sind die Eingangsentprellung und Eingangssignalverlängerung aktiv, dann wird der Eingangsimpuls immer als erstes gefiltert und anschließend das Ergebnis verlängert.


Objektübersicht - EPI2338-0001

Inbetriebnahme/Konfiguration IO-Link Master/Device [image] IO-Link Device [image] Objektübersicht - EPI2338-0001
Objektübersicht - EPI2338-0001
IO-Link IODD Device Description
Die Darstellung entspricht der Anzeige der IO-Link Device Parameter. Es wird empfohlen, die entsprechend aktuellsten IO-Link IODD Device Description Dateien im Download-Bereich der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Im Folgenden wird als Beispiel die Objektübersicht des EPI2338-0001 dargestellt.
Subindex | Name | Flags | Default Wert
0x0000:00 | Direct Parameters 1
0x0000:01 | Reserved | RO | 0
0x0000:02 | Master Cycle Time | RO | 5
0x0000:03 | Min Cycle Time | RO | 5
0x0000:04 | M-Sequence Capability | RO | 1
0x0000:05 | IO-Link Version ID | RO | 17
0x0000:06 | Process Data Input Length | RO | 16
0x0000:07 | Process Data Output Length | RO | 16
0x0000:08 | Vendor ID 1 | RO | 0x0120
0x0000:09 | Vendor ID 2 | RO | 0x0120
0x0000:0A | Device ID 1 | RO | 0x233900
0x0000:0C | Device ID 2 | RO | 0x233900
0x0000:0C | Device ID 3 | RO | 0x233900
0x0000:0D | Reserved | RO | 255
0x0000:0E | Reserved | RO | 255
0x0000:0F | Reserved | RO | 255
0x0000:10 | System Command | RO | 255
Subindex | Name | Flags | Default Wert
0x0001:00 | Direct Parameters 2
0x0001:01 | Device Specific Parameter 1 | RW | 0
0x0001:02 | Device Specific Parameter 2 | RW | 0
0x0001:03 | Device Specific Parameter 3 | RW | 0
0x0001:04 | Device Specific Parameter 4 | RW | 0
0x0001:05 | Device Specific Parameter 5 | RW | 0
0x0001:06 | Device Specific Parameter 6 | RW | 0
0x0001:07 | Device Specific Parameter 7 | RW | 0
0x0001:08 | Device Specific Parameter 8 | RW | 0
0x0001:09 | Device Specific Parameter 9 | RW | 0
0x0001:0A | Device Specific Parameter 10 | RW | 0
0x0001:0B | Device Specific Parameter 11 | RW | 0
0x0001:0C | Device Specific Parameter 12 | RW | 0
0x0001:0D | Device Specific Parameter 13 | RW | 0
0x0001:0E | Device Specific Parameter 14 | RW | 0
0x0001:0F | Device Specific Parameter 15 | RW | 0
0x0001:10 | Device Specific Parameter 16 | RW | 0
Subindex | Name | Flags | Default Wert
0x0002 | Standard Command | RW | 0
Subindex | Name | Flags | Default Wert
0x000C:00 | Device Access Locks
0x000C:01 | Parameter (write) Access Lock | RW | 0
0x000C:02 | Data Storage Lock | RW | 0
0x000C:03 | Local Parameterization Lock | RW | 0
0x000C:04 | Local User Interface Lock | RW | 0
Subindex | Name | Flags | Default Wert
0x0010 | Vendor Name | RO | Beckhoff Automation GmbH & Co. KG
0x0011 | Vendor Text | RO | www.beckhoff.com
0x0012 | Product Name | RO | EPI2338-0001
0x0013 | Product ID | RO | EPI2338-0001
0x0014 | Product Text | RO | 8 DIO Module
0x0015 | Serial Number | RO | 00000000
0x0016 | Hardware Version | RO | 01
0x0017 | Firmware Version | RO | 01
0x0018 | Application Specific Tag | RW | ************************
Subindex | Name | Flags | Default Wert
0x0800:00 | Settings
0x0800:01 | Input Filter | RW | 3 ms
0x0800:02 | Signal Extension | RW | off
Subindex | Name | Flags | Default Wert
0x0A00:00 | Diagnose
0x0A00:01 | Overtemperature | RO | 0
0x0A00:02 | Short detected | RO | 0
0x0A00:03 | US low | RO | 0
0x0A00:04 | UP low | RO | 0
0x0A00:05 | UP stat | RO | 0
0x0A00:06 | Reserved | RO | 0
0x0A00:07 | Reserved | RO | 0
0x0A00:08 | Reserved | RO | 0
0x0A00:09 | Reserved | RO | 0
0x0A00:0A | Reserved | RO | 0
0x0A00:0B | Reserved | RO | 0
0x0A00:0C | Reserved | RO | 0
0x0A00:0D | Reserved | RO | 0
0x0A00:0E | Reserved | RO | 0
0x0A00:0F | Reserved | RO | 0
0x0A00:10 | Reserved | RO | 0
Legende
Flags:
RO (Read Only) dieses Objekt kann nur gelesen werden
RW (READ/Write) dieses Objekt kann gelesen und beschrieben werden


EPI2008-000x, ERI2008-000x - Objektbeschreibung und Parametrierung

Inbetriebnahme/Konfiguration IO-Link Master/Device [image] IO-Link Device [image] EPI2008-000x, ERI2008-000x - Objektbeschreibung und Parametrierung
EPI2008-000x, ERI2008-000x - Objektbeschreibung und Parametrierung
IO-Link IODD Device Description
Die Darstellung entspricht der Anzeige der IO-Link Device Parameter. Es wird empfohlen, die entsprechend aktuellsten IO-Link IODD Device Description Dateien im Download-Bereich der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parameter Server (Data Storage)
Die IO-Link Boxen unterstützen die Data Storage Funktionalität nach Protokollrevision 1.1. Die Parameter 0x0018 (Application Specific Tag) und 0x08n0 (Settings) werden dabei vom IO-Link Master gesichert. Um diese Funktionalität nutzen zu können muss der IO-Link Master diese auch unterstützen. (z. B. mit dem Beckhoff EP6224-xxxx IO-Link Master ab Firmware 10) Änderungen dieser Parameter werden dabei vom IO-Link Master gespeichert und auch bei Austausch gegen eine baugleiche IO-Link Box wiederhergestellt. Wie Sie die Data Storage Funktionalität nutzen können, wird in dem Kapitel EPIxxxx, ERIxxxx - Einstellen der IO-Link Device Parameter erläutert.
Index 0000 Direct Parameter Page 1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0000:01 | Reserved | - | UINT8 | RO | 0
0000:02 | Master Cycle Time | IO-Link spezifisch | UINT8 | RO | 5
0000:03 | Min Cycle Time | IO-Link spezifisch | UINT8 | RO | 5
0000:04 | M-Sequence Capability | IO-Link spezifisch | UINT8 | RO | 1
0000:05 | IO-Link Version ID | IO-Link spezifisch | UINT8 | RO | 17
0000:06 | Process Data Input Length | IO-Link spezifisch | UINT8 | RO | 16
0000:07 | Process Data Output Length | IO-Link spezifisch | UINT8 | RO | 16
0000:08 - 0000:09 | Vendor ID | Hersteller ID | UINT8 | RO | 0x0120
0000:0A - 0000:0C | Device ID | Geräte ID | UINT8 | RO | 0x233900
0000:0D - 0000:0F | Reserved | - | UINT8 | RO | 255
0000:16 | System Command | IO-Link spezifisch |  | RO | 255
Index 0001 Direct Parameter Page 2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0001:01 - 0001:10 | Device Specific Parameter | IO-Link spezifisch | UINT8 | RW | 0
Index 0002 Standard Command
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0002 | Standard Command | IO-Link spezifisch | UINT8 | W | 0
Index 000C Device Access Locks
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
000C:01 | Parameter (write) Access Lock | Nicht untersützt | BOOL | RW | FALSE
000C:02 | Data Storage Lock | Nicht untersützt | BOOL | RW | FALSE
000C:03 | Local Parameterization Lock | Nicht untersützt | BOOL | RW | FALSE
000C:04 | Local User Interface Lock | Nicht untersützt | BOOL | RW | FALSE
Index 0010 Vendor Name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0010 | Vendor Name | Herstellerbezeichnung | String | R | Beckhoff Automation GmbH & Co. KG
Index 0011 Vendor Text
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0011 | Vendor Text | Herstellerspezifischer Text | String | R | www.beckhoff.com
Index 0012 Product Name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0012 | Product Name | Produktbezeichnung | String | R | EPI2008-000x, ERI2008-000x
Index 0013 Product ID
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0013 | Product ID | Produktbezeichnung | String | R | EPI2008-000x, ERI2008-000x
Index 0014 Product Text
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0014 | Product Text | Produktbeschreibung | String | R | 8 DO Module
Index 0015 Serial Number
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0015 | Serial Number | Seriennummer (Individuelle Seriennummer. Unabhängig von der aufgelaserten Seriennummer) | String | R | 00000000
Index 0016 Hardware Version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0016 | Hardware Version | Hardwarerevision | String | R | 01
Index 0017 Firmware Version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0017 | Firmware Version | Firmwareversion | String | R | 01
Index 0018 Application Specific Tag
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0018 | Application Specific Tag | Applikationsspezifische Beschreibung | String | RW | ********************** **********
Index 00A0 Diagnose
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0A00:01 | Overtemperature | Überhitzung des IO-Link Modules | BOOL | RO | FALSE
0A00:02 | Short detected | Kurzschluss auf der IO-Link C/Q Datenleitung | BOOL | RO | FALSE
0A00:03 | US low | Versorgungsspannung zu gering (< 18 V) | BOOL | RO | FALSE
0A00:04 | UP low | Zusätzliche Spannungsversorgung zu gering (<18 V) | BOOL | RO | FALSE
0A00:05 | UP stat | Zusätzliche Spannungsversorgung nicht vorhanden (<8 V) | BOOL | RO | FALSE
0A00:06 - 0A00:10 | Reserved | - | BOOL | RO | FALSE


EPI2809-002x, ERI2809-002x - Objektbeschreibung und Parametrierung

Inbetriebnahme/Konfiguration IO-Link Master/Device [image] IO-Link Device [image] EPI2809-002x, ERI2809-002x - Objektbeschreibung und Parametrierung
EPI2809-002x, ERI2809-002x - Objektbeschreibung und Parametrierung
IO-Link IODD Device Description
Die Darstellung entspricht der Anzeige der IO-Link Device Parameter. Es wird empfohlen, die entsprechend aktuellsten IO-Link IODD Device Description Dateien im Download-Bereich der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parameter Server (Data Storage)
Die IO-Link Boxen unterstützen die Data Storage Funktionalität nach Protokollrevision 1.1. Die Parameter 0x0018 (Application Specific Tag) und 0x08n0 (Settings) werden dabei vom IO-Link Master gesichert. Um diese Funktionalität nutzen zu können muss der IO-Link Master diese auch unterstützen. (z. B. mit dem Beckhoff EP6224-xxxx IO-Link Master ab Firmware 10) Änderungen dieser Parameter werden dabei vom IO-Link Master gespeichert und auch bei Austausch gegen eine baugleiche IO-Link Box wiederhergestellt. Wie Sie die Data Storage Funktionalität nutzen können, wird in dem Kapitel EPIxxxx, ERIxxxx - Einstellen der IO-Link Device Parameter erläutert.
Index 0000 Direct Parameter Page 1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0000:01 | Reserved | - | UINT8 | RO | 0
0000:02 | Master Cycle Time | IO-Link spezifisch | UINT8 | RO | 5
0000:03 | Min Cycle Time | IO-Link spezifisch | UINT8 | RO | 5
0000:04 | M-Sequence Capability | IO-Link spezifisch | UINT8 | RO | 1
0000:05 | IO-Link Version ID | IO-Link spezifisch | UINT8 | RO | 17
0000:06 | Process Data Input Length | IO-Link spezifisch | UINT8 | RO | 16
0000:07 | Process Data Output Length | IO-Link spezifisch | UINT8 | RO | 16
0000:08 - 0000:09 | Vendor ID | Hersteller ID | UINT8 | RO | 0x0120
0000:0A - 0000:0C | Device ID | Geräte ID | UINT8 | RO | 0x233900
0000:0D - 0000:0F | Reserved | - | UINT8 | RO | 255
0000:16 | System Command | IO-Link spezifisch |  | RO | 255
Index 0001 Direct Parameter Page 2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0001:01 - 0001:10 | Device Specific Parameter | IO-Link spezifisch | UINT8 | RW | 0
Index 0002 Standard Command
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0002 | Standard Command | IO-Link spezifisch | UINT8 | W | 0
Index 000C Device Access Locks
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
000C:01 | Parameter (write) Access Lock | Nicht untersützt | BOOL | RW | FALSE
000C:02 | Data Storage Lock | Nicht untersützt | BOOL | RW | FALSE
000C:03 | Local Parameterization Lock | Nicht untersützt | BOOL | RW | FALSE
000C:04 | Local User Interface Lock | Nicht untersützt | BOOL | RW | FALSE
Index 0010 Vendor Name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0010 | Vendor Name | Herstellerbezeichnung | String | R | Beckhoff Automation GmbH & Co. KG
Index 0011 Vendor Text
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0011 | Vendor Text | Herstellerspezifischer Text | String | R | www.beckhoff.com
Index 0012 Product Name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0012 | Product Name | Produktbezeichnung | String | R | EPI2809-000x, ERI2809-000x
Index 0013 Product ID
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0013 | Product ID | Produktbezeichnung | String | R | EPI2809-000x, ERI2809-000x
Index 0014 Product Text
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0014 | Product Text | Produktbeschreibung | String | R | 16 DO Module
Index 0015 Serial Number
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0015 | Serial Number | Seriennummer (Individuelle Seriennummer. Unabhängig von der aufgelaserten Seriennummer) | String | R | 00000000
Index 0016 Hardware Version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0016 | Hardware Version | Hardwarerevision | String | R | 01
Index 0017 Firmware Version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0017 | Firmware Version | Firmwareversion | String | R | 01
Index 0018 Application Specific Tag
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0018 | Application Specific Tag | Applikationsspezifische Beschreibung | String | RW | ********************** **********
Index 0A00 Diagnose
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0A00:01 | Overtemperature | Überhitzung des IO-Link Modules | BOOL | RO | FALSE
0A00:02 | Short detected | Kurzschluss auf der IO-Link C/Q Datenleitung | BOOL | RO | FALSE
0A00:03 | US low | Versorgungsspannung zu gering (< 18V) | BOOL | RO | FALSE
0A00:04 | UP low | Zusätzliche Spannungsversorgung zu gering (<18V) | BOOL | RO | FALSE
0A00:05 | UP stat | Zusätzliche Spannungsversorgung nicht vorhanden (<8V) | BOOL | RO | FALSE
0A00:06 - 0A00:07 | Reserved | - | BOOL | RO | FALSE
0A00:08 | Port 0-7 UP Output overcurrent | Überstrom an einem der digitalen Ausgänge Port 0-7 erkannt | BOOL | RO | FALSE
0A00:09 | Port 8-15 UP Output overcurrent | Überstrom an einem der digitalen Ausgänge Port 8-15 erkannt | BOOL | RO | FALSE
0A00:0A - 0A00:10 | Reserved | - | BOOL | RO | FALSE


EPI2338-000x, ERI2338-000x - Objektbeschreibung und Parametrierung

Inbetriebnahme/Konfiguration IO-Link Master/Device [image] IO-Link Device [image] EPI2338-000x, ERI2338-000x - Objektbeschreibung und Parametrierung
EPI2338-000x, ERI2338-000x - Objektbeschreibung und Parametrierung
IO-Link IODD Device Description
Die Darstellung entspricht der Anzeige der IO-Link Device Parameter. Es wird empfohlen, die entsprechend aktuellsten IO-Link IODD Device Description Dateien im Download-Bereich der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parameter Server (Data Storage)
Die IO-Link Boxen unterstützen die Data Storage Funktionalität nach Protokollrevision 1.1. Die Parameter 0x0018 (Application Specific Tag) und 0x08n0 (Settings) werden dabei vom IO-Link Master gesichert. Um diese Funktionalität nutzen zu können muss der IO-Link Master diese auch unterstützen. (z. B. mit dem Beckhoff EP6224-xxxx IO-Link Master ab Firmware 10) Änderungen dieser Parameter werden dabei vom IO-Link Master gespeichert und auch bei Austausch gegen eine baugleiche IO-Link Box wiederhergestellt. Wie Sie die Data Storage Funktionalität nutzen können, wird in dem Kapitel EPIxxxx, ERIxxxx - Einstellen der IO-Link Device Parameter erläutert.
Index 0000 Direct Parameter Page 1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0000:01 | Reserved | - | UINT8 | RO | 0
0000:02 | Master Cycle Time | IO-Link spezifisch | UINT8 | RO | 5
0000:03 | Min Cycle Time | IO-Link spezifisch | UINT8 | RO | 5
0000:04 | M-Sequence Capability | IO-Link spezifisch | UINT8 | RO | 1
0000:05 | IO-Link Version ID | IO-Link spezifisch | UINT8 | RO | 17
0000:06 | Process Data Input Length | IO-Link spezifisch | UINT8 | RO | 16
0000:07 | Process Data Output Length | IO-Link spezifisch | UINT8 | RO | 16
0000:08 - 0000:09 | Vendor ID | Hersteller ID | UINT8 | RO | 0x0120
0000:0A - 0000:0C | Device ID | Geräte ID | UINT8 | RO | 0x233900
0000:0D - 0000:0F | Reserved | - | UINT8 | RO | 255
0000:16 | System Command | IO-Link spezifisch |  | RO | 255
Index 0001 Direct Parameter Page 2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0001:01 - 0001:10 | Device Specific Parameter | IO-Link spezifisch | UINT8 | RW | 0
Index 0002 Standard Command
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0002 | Standard Command | IO-Link spezifisch | UINT8 | W | 0
Index 000C Device Access Locks
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
000C:01 | Parameter (write) Access Lock | Nicht untersützt | BOOL | RW | FALSE
000C:02 | Data Storage Lock | Nicht untersützt | BOOL | RW | FALSE
000C:03 | Local Parameterization Lock | Nicht untersützt | BOOL | RW | FALSE
000C:04 | Local User Interface Lock | Nicht untersützt | BOOL | RW | FALSE
Index 0010 Vendor Name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0010 | Vendor Name | Herstellerbezeichnung | String | R | Beckhoff Automation GmbH & Co. KG
Index 0011 Vendor Text
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0011 | Vendor Text | Herstellerspezifischer Text | String | R | www.beckhoff.com
Index 0012 Product Name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0012 | Product Name | Produktbezeichnung | String | R | EPI2338-000x, ERI2338-000x
Index 0013 Product ID
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0013 | Product ID | Produktbezeichnung | String | R | EPI2338-000x, ERI2338-000x
Index 0014 Product Text
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0014 | Product Text | Produktbeschreibung | String | R | 8 DIO Module
Index 0015 Serial Number
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0015 | Serial Number | Seriennummer (Individuelle Seriennummer. Unabhängig von der aufgelaserten Seriennummer) | String | R | 00000000
Index 0016 Hardware Version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0016 | Hardware Version | Hardwarerevision | String | R | 01
Index 0017 Firmware Version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0017 | Firmware Version | Firmwareversion | String | R | 01
Index 0018 Application Specific Tag
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0018 | Application Specific Tag | Applikationsspezifische Beschreibung | String | RW | ********************** **********
Index 0800 Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0800:01 | Input Filter | Eingangsentprellung für digitale Eingänge | UINT8 | RW | 3ms
0800:02 | Signal Extension | Signalverlängerung für digitale Eingänge | UINT8 | RW | off
Index 00A0 Diagnose
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0A00:01 | Overtemperature | Überhitzung des IO-Link Modules | BOOL | RO | FALSE
0A00:02 | Short detected | Kurzschluss auf der IO-Link C/Q Datenleitung | BOOL | RO | FALSE
0A00:03 | US low | Versorgungsspannung zu gering (< 18 V) | BOOL | RO | FALSE
0A00:04 | UP low | Zusätzliche Spannungsversorgung zu gering (<18 V) | BOOL | RO | FALSE
0A00:05 | UP stat | Zusätzliche Spannungsversorgung nicht vorhanden (<8 V) | BOOL | RO | FALSE
0A00:06 - 0A00:10 | Reserved | - | BOOL | RO | FALSE


EPI2339-002x, ERI2339-002x - Objektbeschreibung und Parametrierung

Inbetriebnahme/Konfiguration IO-Link Master/Device [image] IO-Link Device [image] EPI2339-002x, ERI2339-002x - Objektbeschreibung und Parametrierung
EPI2339-002x, ERI2339-002x - Objektbeschreibung und Parametrierung
IO-Link IODD Device Description
Die Darstellung entspricht der Anzeige der IO-Link Device Parameter. Es wird empfohlen, die entsprechend aktuellsten IO-Link IODD Device Description Dateien im Download-Bereich der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parameter Server (Data Storage)
Die IO-Link Boxen unterstützen die Data Storage Funktionalität nach Protokollrevision 1.1. Die Parameter 0x0018 (Application Specific Tag) und 0x08n0 (Settings) werden dabei vom IO-Link Master gesichert. Um diese Funktionalität nutzen zu können muss der IO-Link Master diese auch unterstützen. (z. B. mit dem Beckhoff EP6224-xxxx IO-Link Master ab Firmware 10) Änderungen dieser Parameter werden dabei vom IO-Link Master gespeichert und auch bei Austausch gegen eine baugleiche IO-Link Box wiederhergestellt. Wie Sie die Data Storage Funktionalität nutzen können, wird in dem Kapitel EPIxxxx, ERIxxxx - Einstellen der IO-Link Device Parameter erläutert.
Index 0000 Direct Parameter Page 1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0000:01 | Reserved | - | UINT8 | RO | 0
0000:02 | Master Cycle Time | IO-Link spezifisch | UINT8 | RO | 5
0000:03 | Min Cycle Time | IO-Link spezifisch | UINT8 | RO | 5
0000:04 | M-Sequence Capability | IO-Link spezifisch | UINT8 | RO | 1
0000:05 | IO-Link Version ID | IO-Link spezifisch | UINT8 | RO | 17
0000:06 | Process Data Input Length | IO-Link spezifisch | UINT8 | RO | 16
0000:07 | Process Data Output Length | IO-Link spezifisch | UINT8 | RO | 16
0000:08 - 0000:09 | Vendor ID | Hersteller ID | UINT8 | RO | 0x0120
0000:0A - 0000:0C | Device ID | Geräte ID | UINT8 | RO | 0x233900
0000:0D - 0000:0F | Reserved | - | UINT8 | RO | 255
0000:16 | System Command | IO-Link spezifisch |  | RO | 255
Index 0001 Direct Parameter Page 2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0001:01 - 0001:10 | Device Specific Parameter | IO-Link spezifisch | UINT8 | RW | 0
Index 0002 Standard Command
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0002 | Standard Command | IO-Link spezifisch | UINT8 | W | 0
Index 000C Device Access Locks
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
000C:01 | Parameter (write) Access Lock | Nicht untersützt | BOOL | RW | FALSE
000C:02 | Data Storage Lock | Nicht untersützt | BOOL | RW | FALSE
000C:03 | Local Parameterization Lock | Nicht untersützt | BOOL | RW | FALSE
000C:04 | Local User Interface Lock | Nicht untersützt | BOOL | RW | FALSE
Index 0010 Vendor Name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0010 | Vendor Name | Herstellerbezeichnung | String | R | Beckhoff Automation GmbH & Co. KG
Index 0011 Vendor Text
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0011 | Vendor Text | Herstellerspezifischer Text | String | R | www.beckhoff.com
Index 0012 Product Name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0012 | Product Name | Produktbezeichnung | String | R | EPI2339-002x, ERI2339-002x
Index 0013 Product ID
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0013 | Product ID | Produktbezeichnung | String | R | EPI2339-002x, ERI2339-002x
Index 0014 Product Text
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0014 | Product Text | Produktbeschreibung | String | R | 16 DIO Module
Index 0015 Serial Number
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0015 | Serial Number | Seriennummer (Individuelle Seriennummer. Unabhängig von der aufgelaserten Seriennummer) | String | R | 00000000
Index 0016 Hardware Version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0016 | Hardware Version | Hardwarerevision | String | R | 01
Index 0017 Firmware Version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0017 | Firmware Version | Firmwareversion | String | R | 01
Index 0018 Application Specific Tag
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0018 | Application Specific Tag | Applikationsspezifische Beschreibung | String | RW | ********************** **********
Index 0800 Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0800:01 | Input Filter | Eingangsentprellung für digitale Eingänge | UINT8 | RW | 3ms
0800:02 | Signal Extension | Signalverlängerung für digitale Eingänge | UINT8 | RW | off
Index 0A00 Diagnose
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
0A00:01 | Overtemperature | Überhitzung des IO-Link Modules | BOOL | RO | FALSE
0A00:02 | Short detected | Kurzschluss auf der IO-Link C/Q Datenleitung | BOOL | RO | FALSE
0A00:03 | US low | Versorgungsspannung zu gering (< 18V) | BOOL | RO | FALSE
0A00:04 | UP low | Zusätzliche Spannungsversorgung zu gering (<18V) | BOOL | RO | FALSE
0A00:05 | UP stat | Zusätzliche Spannungsversorgung nicht vorhanden (<8V) | BOOL | RO | FALSE
0A00:06 | Port 0-7 UP short | Kurzschluss an einen der digitalen Ports 0-7 erkannt | BOOL | RO | FALSE
0A00:07 | Port 8-15 UP short | Kurzschluss an einen der digitalen Ports 8-15 erkannt | BOOL | RO | FALSE
0A00:08 | Port 0-7 UP Output overcurrent | Überstrom an einem der digitalen Ausgänge Port 0-7 erkannt | BOOL | RW | FALSE
0A00:09 | Port 8-15 UP Output overcurrent | Überstrom an einem der digitalen Ausgänge Port 8-15 erkannt | BOOL | RW | FALSE
0A00:0A - 0A00:10 | Reserved | - | BOOL | RO | FALSE


Firmware Update des IO-Link Devices

Inbetriebnahme/Konfiguration IO-Link Master/Device [image] IO-Link Device [image] Firmware Update des IO-Link Devices
Firmware Update des IO-Link Devices
Firmware Update nur mit EtherCAT IO-Link Master Produkten möglich
Das Firmware Update des IO-Link Devices ist nur mit den Produkten EP6224-xxxx, EP6228-xxxx und der EL6224 möglich. Ein Firmware Update mit der KL6224 ist nicht möglich.
Ein Update der Boxenfirmware wird derzeit über die EP622x-xxxx IO-Link Master Box und den TwinCAT System Manger ab der Version 2.11 R3 Build 2248 oder TwinCAT 3.1 Build 4018 unterstützt.
Das Firmware Update wird direkt über die IO-Link Schnittstelle durchgeführt. Dazu muss die Box an der EP622x-xxxx angeschlossen und in dem Zustand Operational sein. Gestartet wird das Update in dem Advanced Dialog des entsprechenden IO-Link Ports (siehe die beiden nachfolgenden Abbildungen).
1.
EP622x-xxxx Box im System Manager auswählen,
2.
im Karteireiter IO-Link mit Rechtsklick auf den entsprechenden Port
3.
den Reiter Settings öffnen,
4.
Button Advanced auswählen
5.
IO-Link Firmware Dateien (verwenden die Dateiendung *.efw) über den Button Download auswählen.
Der Firmware Update Dialog wird nur für unterstütze Beckhoff IO-Link Devices angezeigt. Nach einem Check der *.efw Datei startet das Firmware Update automatisch. Dieser Vorgang darf nicht unterbrochen werden! Nach einem erfolgreichen Update wird die Box automatisch neu gestartet und muss daher nicht stromlos gemacht werden. Gerätspezifische Einstellungen (Appl. Specific Tag, Settings) gehen nicht verloren.
IO-Link Settings - Download Firmware Update
Die aktuell verwendete Firmware kann folgendermaßen ermittelt werden (siehe nachfolgende Abbildung):
1.
EP622x-xxxx Box im System Manager auswählen,
2.
Im Karteireiter IO-Link mit Rechtsklick oder Doppelklick auf den entsprechenden Port
3.
den Reiter Parameter öffnen,
4.
Index 0x017 (Firmware Version) auswählen,
5.
Button Read anklicken
6.
Die Firmwareversion wird bei bestehender IO-Link Kommunikation zur Box ausgelesen und angezeigt.
IO-Link Parameter - Firmware Version


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Allgemeine Betriebsbedingungen
•
Zubehör
•
Support und Service


Allgemeine Betriebsbedingungen

Anhang [image] Allgemeine Betriebsbedingungen
Allgemeine Betriebsbedingungen
Schutzarten nach IP-Code
In der Norm IEC 60529 (DIN EN 60529) sind die Schutzgrade festgelegt und nach verschiedenen Klassen eingeteilt. Die Bezeichnung erfolgt in nachstehender Weise.
1. Ziffer: Staub- und Berührungsschutz | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen den Zugang zu gefährlichen Teilen mit dem Handrücken. Geschützt gegen feste Fremdkörper Ø 50 mm
2 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Finger. Geschützt gegen feste Fremdkörper Ø 12,5 mm
3 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Werkzeug. Geschützt gegen feste Fremdkörper Ø 2,5 mm
4 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Geschützt gegen feste Fremdkörper Ø 1 mm
5 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubgeschützt. Eindringen von Staub ist nicht vollständig verhindert, aber der Staub darf nicht in einer solchen Menge eindringen, dass das zufriedenstellende Arbeiten des Gerätes oder die Sicherheit beeinträchtigt wird
6 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubdicht. Kein Eindringen von Staub
2. Ziffer: Wasserschutz* | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen Tropfwasser
2 | Geschützt gegen Tropfwasser, wenn das Gehäuse bis zu 15° geneigt ist
3 | Geschützt gegen Sprühwasser. Wasser, das in einem Winkel bis zu 60° beiderseits der Senkrechten gesprüht wird, darf keine schädliche Wirkung haben
4 | Geschützt gegen Spritzwasser. Wasser, das aus jeder Richtung gegen das Gehäuse spritzt, darf keine schädlichen Wirkungen haben
5 | Geschützt gegen Strahlwasser.
6 | Geschützt gegen starkes Strahlwasser.
7 | Geschützt gegen die Wirkungen beim zeitweiligen Untertauchen in Wasser. Wasser darf nicht in einer Menge eintreten, die schädliche Wirkungen verursacht, wenn das Gehäuse für 30 Minuten in 1 m Tiefe in Wasser untergetaucht ist
*) In diesen Schutzklassen wird nur der Schutz gegen Wasser definiert.
Chemische Beständigkeit
Die Beständigkeit bezieht sich auf das Gehäuse der IP-67-Module und die verwendeten Metallteile. In der nachfolgenden Tabelle finden Sie einige typische Beständigkeiten.
Art | Beständigkeit
Wasserdampf | bei Temperaturen >100°C nicht beständig
Natriumlauge (ph-Wert > 12) | bei Raumtemperatur beständig > 40°C unbeständig
Essigsäure | unbeständig
Argon (technisch rein) | beständig
Legende
▪
beständig: Lebensdauer mehrere Monate
▪
bedingt beständig: Lebensdauer mehrere Wochen
▪
unbeständig: Lebensdauer mehrere Stunden bzw. baldige Zersetzung


Zubehör

Anhang [image] Zubehör
Zubehör
Befestigung
Bestellangabe | Beschreibung
ZS5300-0001 | Montageschiene (500 mm x 129 mm)
Leitungen
Eine vollständige Übersicht von vorkonfektionierten Leitungen für EtherCAT-Box-Module finden sie hier.
Bestellangabe | Beschreibung
ZK2000-3xxx-xxxx | Sensorleitung M8, 4-polig Link zur Website
ZK2000-5xxx-xxxx ZK2000-71xx-xxxx | Sensorleitung M12 5-polig Link zur Website
ZK2000-6xxx-xxxx | Sensorleitung M12 4-polig Link zur Website
Beschriftungsmaterial, Schutzkappen
Bestellangabe | Beschreibung
ZS5000-0010 | Schutzkappe für M8-Buchsen, IP67 (50 Stück)
ZS5000-0020 | Schutzkappe M12, IP67 (50 Stück)
ZS5100-0000 | Beschriftungsschilder nicht bedruckt, 4 Streifen à 10 Stück
ZS5000-xxxx | Beschriftungsschilder bedruckt, auf Anfrage
Werkzeug
Bestellangabe | Beschreibung
ZB8801-0000 | Drehmoment-Schraubwerkzeug für Stecker, 0,4…1,0 Nm
ZB8801-0001 | Wechselklinge für M8 / SW9 für ZB8801-0000
ZB8801-0002 | Wechselklinge für M12 / SW13 für ZB8801-0000
ZB8801-0003 | Wechselklinge für M12 feldkonfektionierbar / SW18 für ZB8801-0000
Weiteres Zubehör
Weiteres Zubehör finden Sie in der Preisliste für Feldbuskomponenten von Beckhoff und im Internet auf https://www.beckhoff.de.


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.