EP9300-0022 - Profinet-RT-EtherCAT-Box
Home
Web_Title EP 150dpi (default)


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentlichte Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
2.1
▪
Titelseite aktualisiert
2.0
▪
Dokumentation grundlegend überarbeitet
1.0
▪
Erste Veröffentlichung im CHM-Format, nur auf Englisch
Firm- und Hardware-Stände
Diese Dokumentation bezieht sich auf den zum Zeitpunkt ihrer Erstellung gültigen Firm- und Hardware-Stand.
Die Eigenschaften der Module werden stetig weiterentwickelt und verbessert. Module älteren Fertigungsstandes können nicht die gleichen Eigenschaften haben, wie Module neuen Standes. Bestehende Eigenschaften bleiben jedoch erhalten und werden nicht geändert, so dass ältere Module immer durch neue ersetzt werden können.
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der EtherCAT Box aufgedruckten Batch-Nummer (D-Nummer) entnehmen.
Syntax der Batch-Nummer (D-Nummer)
D: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit D-Nr. 29 10 02 01:
29 - Produktionswoche 29
10 - Produktionsjahr 2010
02 - Firmware-Stand 02
01 - Hardware-Stand 01
Weitere Informationen zu diesem Thema: Versionsidentifikation von EtherCAT-Geräten.


EtherCAT Box - Einführung

EtherCAT Box - Einführung
EtherCAT Box - Einführung
Das EtherCAT-System wird durch die EtherCAT-Box-Module in Schutzart IP67 erweitert. Durch das integrierte EtherCAT-Interface sind die Module ohne eine zusätzliche Kopplerbox direkt an ein EtherCAT-Netzwerk anschließbar. Die hohe EtherCAT-Performance bleibt also bis in jedes Modul erhalten.
Die außerordentlich geringen Abmessungen von nur 126 x 30 x 26,5 mm (H x B x T) sind identisch zu denen der Feldbus Box Erweiterungsmodule. Sie eignen sich somit besonders für Anwendungsfälle mit beengten Platzverhältnissen. Die geringe Masse der EtherCAT-Module begünstigt u. a. auch Applikationen, bei denen die I/O-Schnittstelle bewegt wird (z. B. an einem Roboterarm). Der EtherCAT-Anschluss erfolgt über geschirmte M8-Stecker.
EtherCAT-Box-Module in einem EtherCAT-Netzwerk
Die robuste Bauweise der EtherCAT-Box-Module erlaubt den Einsatz direkt an der Maschine. Schaltschrank und Klemmenkasten werden hier nicht mehr benötigt. Die Module sind voll vergossen und daher ideal vorbereitet für nasse, schmutzige oder staubige Umgebungsbedingungen.
Durch vorkonfektionierte Kabel vereinfacht sich die EtherCAT- und Signalverdrahtung erheblich. Verdrahtungsfehler werden weitestgehend vermieden und somit die Inbetriebnahmezeiten optimiert. Neben den vorkonfektionierten EtherCAT-, Power- und Sensorleitungen stehen auch feldkonfektionierbare Stecker und Kabel für maximale Flexibilität zur Verfügung. Der Anschluss der Sensorik und Aktorik erfolgt je nach Einsatzfall über M8- oder M12-Steckverbinder.
Die EtherCAT-Module decken das typische Anforderungsspektrum der I/O-Signale in Schutzart IP67 ab:
▪
digitale Eingänge mit unterschiedlichen Filtern (3,0 ms oder 10 μs)
▪
digitale Ausgänge mit 0,5 oder 2 A Ausgangsstrom
▪
analoge Ein- und Ausgänge mit 16 Bit Auflösung
▪
Thermoelement- und RTD-Eingänge
▪
Schrittmotormodule
Auch XFC (eXtreme Fast Control Technology)-Module wie z. B. Eingänge mit Time-Stamp sind verfügbar.
EtherCAT Box mit M8-Anschlüssen für Sensor/Aktoren
EtherCAT Box mit M12-Anschlüssen für Sensor/Aktoren
Basis-Dokumentation zu EtherCAT
Eine detaillierte Beschreibung des EtherCAT-Systems finden Sie in der System Basis-Dokumentation zu EtherCAT, die auf unserer Homepage (www.beckhoff.de) unter Downloads zur Verfügung steht.
XML-Dateien
XML -Dateien (XML Device Description Files) zu EtherCAT-Modulen von Beckhoff finden Sie unter auf unserer Homepage (www.beckhoff.de) unter Downloads im Bereich Konfigurations-Dateien.


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Einführung
•
Technische Daten
•
Lieferumfang


Einführung

Produktübersicht [image] Einführung
Einführung
EP9300-0022
EP9300-0022 | PROFINET-RT-EtherCAT-Box
Die EtherCAT Box EP9300-0022 verbindet PROFINET-RT-Netzwerke mit EtherCAT-Box-Modulen (EPxxxx, ERxxxx oder EQxxxx) und setzt die Telegramme von PROFINET RT auf EtherCAT um. Eine Station besteht aus einer EP9300-0022 und einer beliebigen Anzahl von EtherCAT-Box-Modulen. Der Anschluss an PROFINET erfolgt über eine D-kodierte M12-Buchse. Mit EtherCAT verfügt die PROFINET-RT-Box über ein unterlagertes, leistungsfähiges und ultraschnelles I/O-System mit einer großen Modulauswahl. Die EP9300-0022 unterstützt das PROFINET-Profil und fügt sich damit nahtlos in PROFINET-RT-Netzwerke ein.
Quick Links


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Alle Werte sind typische Werte über den gesamten Temperaturbereich, wenn nicht anders angegeben.
Technische Daten | EP9300-0022
Profinet
Protokoll | Profinet RT
Anschluss | 2x M12-Buchse, D-codiert, 4-polig, schwarz (switched)
Auto-negotiation | Ja
Auto-crossover | Ja
Übertragungsmedium | CAT 5 Twisted Pair Kupferkabel
Leitungslänge | max. 100 m
Übertragungsrate | 100 MBit/s
EtherCAT-Ausgang
Anschluss | 1x M8-Buchse, 4-polig, grün
Potentialtrennung | 500 V
Anzahl der EtherCAT-Geräte | abhängig von der Prozessdatengröße
Art und Anzahl von Peripheriesignalen | abhängig von der Prozessdatengröße
Versorgungsspannungen
Anschluss | Eingang: 1 x M8-Stecker, 4-polig, schwarz Weiterleitung: 1 x M8-Buchse, 4-polig, schwarz
Steuerspannung US
Nennspannung | 24 VDC (-15 % / +20 %)
Stromaufnahme aus US | 120 mA
Summenstrom | max. 4 A 1)
Peripheriespannung UP
Nennspannung | 24 VDC (-15 % / +20 %)
Stromaufnahme aus UP | Keine. UP wird nur weitergeleitet.
Summenstrom | max. 4 A 1)
Umgebungsbedingungen
Umgebungstemperatur im Betrieb | -25…+60°C -25…+55°C gemäß cURus
Umgebungstemperatur bei Lagerung | -40…+85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Mechanik
Abmessungen | ca. 126 x 60 x 26,5 mm (ohne Steckverbinder)
Einbaulage | beliebig
Gewicht | ca. 320 g
Zulassungen und Konformität
Zulassungen | CE, cURus
1) Dieser Wert entspricht der Stromtragfähigkeit der Steckverbinder-Pins.
Weiterführende Informationen
•
Profinet


Profinet

Produktübersicht [image] Technische Daten [image] Profinet
Profinet
Technische Daten | EP9300-0022
Protokoll
Profinet IO-Device | Ja
ADS Interface | Ja
Dienste
IRT | Nein
TCP/IP ADS | Ja
Shared Device | Ja
Prioritized start-up | Nein
MRP | Ja
SNMP | Ja
LLDP | Ja
ARP | Ja
LLDP | Ja
DHCP | Ja


Lieferumfang

Produktübersicht [image] Lieferumfang
Lieferumfang
Vergewissern Sie sich, dass folgende Komponenten im Lieferumfang enthalten sind:
▪
1x EP9300-0022
▪
1x Schutzkappe für EtherCAT-Buchse, M8, grün (vormontiert)
▪
2x Schutzkappe für Profinet-Buchse, M12, schwarz (vormontiert)
▪
1x Schutzkappe für Versorgungsspannungs-Eingang, M8, transparent (vormontiert)
▪
1x Schutzkappe für Versorgungsspannungs-Ausgang, M8, schwarz (vormontiert)
▪
10x Beschriftungsschild unbedruckt (1 Streifen à 10 Stück)
Vormontierte Schutzkappen gewährleisten keinen IP67-Schutz
Schutzkappen werden werksseitig vormontiert, um Steckverbinder beim Transport zu schützen. Sie sind u.U. nicht fest genug angezogen, um die Schutzart IP67 zu gewährleisten.
Stellen Sie den korrekten Sitz der Schutzkappen sicher, um die Schutzart IP67 zu gewährleisten.


Montage und Anschluss

Montage und Anschluss
Montage und Anschluss
Weiterführende Informationen
•
Montage
•
Anschlüsse
•
UL-Anforderungen


Montage

Montage und Anschluss [image] Montage
Montage
Weiterführende Informationen
•
Abmessungen
•
Befestigung
•
Funktionserdung (FE)


Abmessungen

Montage und Anschluss [image] Montage [image] Abmessungen
Abmessungen
Abmessungen
Alle Maße sind in Millimeter angegeben.
Gehäuseeigenschaften
Gehäusematerial | PA6 (Polyamid)
Vergussmasse | Polyurethan
Montage | zwei Befestigungslöcher Ø 4,5 mm für M4
Metallteile | Messing, vernickelt
Kontakte | CuZn, vergoldet
Stromweiterleitung | max. 4 A
Einbaulage | beliebig
Schutzart | im verschraubten Zustand IP65, IP66, IP67 (gemäß EN 60529)
Abmessungen (H x B x T) | ca. 126 x 60 x 26,5 mm (ohne Steckverbinder)


Befestigung

Montage und Anschluss [image] Montage [image] Befestigung
Befestigung
Hinweis
Verschmutzung bei der Montage
Verschmutzte Steckverbinder können zu Fehlfunktion führen. Die Schutzart IP67 ist nur gewährleistet, wenn alle Kabel und Stecker angeschlossen sind.
•
Schützen Sie die Steckverbinder bei der Montage vor Verschmutzung.
Montieren Sie das Modul mit zwei M4-Schrauben an den zentriert angeordneten Befestigungslöchern.


Funktionserdung (FE)

Montage und Anschluss [image] Montage [image] Funktionserdung (FE)
Funktionserdung (FE)
Die Befestigungslöcher dienen gleichzeitig als Anschlüsse für die Funktionserdung (FE).
Stellen Sie sicher, dass die Box über beide Befestigungsschrauben niederimpedant geerdet ist. Das erreichen Sie z.B., indem Sie die Box an einem geerdeten Maschinenbett montieren.
FE-Anschluss über Befestigungslöcher
Funktionserdung über die Befestigungslöcher


Anschlüsse

Montage und Anschluss [image] Anschlüsse
Anschlüsse
Weiterführende Informationen
•
Steckverbinder-Übersicht
•
Profinet
•
EtherCAT-Ausgang
•
Versorgungsspannungen
•
Diag-Port


Steckverbinder-Übersicht

Montage und Anschluss [image] Anschlüsse [image] Steckverbinder-Übersicht
Steckverbinder-Übersicht
Steckverbinder-Bezeichnungen
Name | Funktion | Steckverbinder-Typ | Anzugs- Drehmoment
X001 | Profinet-Eingang | M12-Buchse, D-codiert | 0,6 Nm 1)
X002 | Profinet-Weiterleitung | M12-Buchse, D-codiert | 0,6 Nm 1)
X60 | Versorgungsspannungs-Eingang | M8-Stecker | 0,4 Nm 1)
X61 | Versorgungsspannungs-Weiterleitung | M8-Buchse | 0,4 Nm 1)
X101 | EtherCAT-Ausgang | M8 | 0,4 Nm 1)
X201 | Diag-Port | - | -
1) Montieren Sie Stecker an diesen Steckverbindern mit einem Drehmomentschlüssel; z.B. ZB8801 von Beckhoff.
Schutzkappen
▪
Verschließen Sie nicht benutzte Steckverbinder mit Schutzkappen.
▪
Stellen Sie den korrekten Sitz von vormontierten Schutzkappen sicher.
Schutzkappen werden werksseitig vormontiert, um Steckverbinder beim Transport zu schützen. Sie sind u. U. nicht fest genug angezogen, um die Schutzart IP67 zu gewährleisten.


Profinet

Montage und Anschluss [image] Anschlüsse [image] Profinet
Profinet
Weiterführende Informationen
•
Steckverbinder
•
Status-LEDs
•
Topologie-Beispiel


Steckverbinder

Montage und Anschluss [image] Anschlüsse [image] Profinet [image] Steckverbinder
Steckverbinder
M12-Buchse, D-codiert EtherCAT/Ethernet
M12-Buchse, D-codiert
Pin | Aderfarbe 1) | Signal
1 | Gelb | Tx +
2 | Weiß | Rx +
3 | orange | Tx -
4 | blau | Rx -
Gehäuse | - | Schirm
1) Die Aderfarben gelten für EtherNet/EtherCAT-Leitungen mit M12-Anschlüssen von Beckhoff.


Status-LEDs

Montage und Anschluss [image] Anschlüsse [image] Profinet [image] Status-LEDs
Status-LEDs
Siehe Kapitel Diagnose-LEDs.


Topologie-Beispiel

Montage und Anschluss [image] Anschlüsse [image] Profinet [image] Topologie-Beispiel
Topologie-Beispiel
Das Profinet-Netzwerk kann in einer Linienstruktur aufgebaut werden. Dabei sollten die folgenden Grenzen eingehalten werden:
▪
Maximal 20 EP9300-0022 hintereinander.
▪
Es sollten keine Switches in der Linie verwendet werden.
Topologie-Beispiel
Einsatz von Switches ohne LLDP
Profinet verwendet zur Topologie Erkennung das LLDP Protokoll. Sollte der Switch, den Sie einsetzen, dies nicht unterstützen, funktioniert die Topologie-Erkennung und die damit verbundenen Profinet-Dienste nicht ordnungsgemäß. Außerdem kommt es zu einem erhöhten Netzwerkverkehr der sich mit jedem Switchport und angeschlossenem Profinet-Teilnehmer vervielfacht. Daraus können Störungen der Kommunikation bis hin zum Kommunikationsabbruch einzelner Profinet-Teilnehmer resultieren.


EtherCAT-Ausgang

Montage und Anschluss [image] Anschlüsse [image] EtherCAT-Ausgang
EtherCAT-Ausgang
Weiterführende Informationen
•
Steckverbinder
•
Status-LEDs
•
Leitungen


Steckverbinder

Montage und Anschluss [image] Anschlüsse [image] EtherCAT-Ausgang [image] Steckverbinder
Steckverbinder
Hinweis
Verwechselungs-Gefahr: Versorgungsspannungen und EtherCAT
Defekt durch Fehlstecken möglich.
•
Beachten Sie die farbliche Codierung der Steckverbinder:
schwarz: Versorgungsspannungen
grün: EtherCAT
Der EtherCAT-Ausgang ist als grüne M8-Buchse ausgeführt.
EtherCAT Steckverbinder
Kontaktbelegung
M8-Buchse 4polig Kontaktbelegung
M8-Buchse
Belegung
Es gibt verschiedene Standards für die Belegung und Farben bei Steckverbindern und Leitung für EtherCAT.
EtherCAT | Steckverbinder |  |  | Leitung |  | Norm
Signal | M8 | M12 | RJ451 | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 und alte Versionen von ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | Pin 1 | Pin 1 | Pin 1 | gelb2 | orange/weiß3 | weiß/orange
Tx - | Pin 4 | Pin 3 | Pin 2 | orange2 | orange3 | orange
Rx + | Pin 2 | Pin 2 | Pin 3 | weiß2 | blau/weiß3 | weiß/grün
Rx - | Pin 3 | Pin 4 | Pin 6 | blau2 | blau3 | grün
Shield | Gehäuse |  | Schirmblech | Schirm | Schirm | Schirm
1) farbliche Markierungen nach EN 61918 im vierpoligen RJ45-Steckverbinder ZS1090-0003
2) Aderfarben nach EN 61918
3) Aderfarben
Anpassung der Farbkodierung für die Leitungen ZB9030, ZB9032 und ZK1090-3xxxx-xxxx (mit M8-Steckverbindern)
Zur Vereinheitlichung wurden die gängigen Leitungen ZB9030, ZB9032 und ZK1090-3xxx-xxxx, also die mit M8-Steckverbindern vorkonfektionierten Leitungen auf die Farben der EN61918 umgestellt (gelb, orange, weiß, blau). Es sind also verschiedene Farbkodierungen im Umlauf. Die elektrischen Eigenschaften sind aber absolut identisch!


Status-LEDs

Montage und Anschluss [image] Anschlüsse [image] EtherCAT-Ausgang [image] Status-LEDs
Status-LEDs
Siehe Kapitel Diagnose-LEDs.


Leitungen

Montage und Anschluss [image] Anschlüsse [image] EtherCAT-Ausgang [image] Leitungen
Leitungen
Verwenden Sie zur Verbindung von EtherCAT-Geräten geschirmte Ethernet-Kabel, die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen.
EtherCAT nutzt vier Adern für die Signalübertragung.
Aufgrund der automatischen Leitungserkennung „Auto MDI-X“ können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte, als auch gekreuzte Kabel (Cross-Over) verwenden.
Detaillierte Empfehlungen zur Verkabelung von EtherCAT-Geräten


Versorgungsspannungen

Montage und Anschluss [image] Anschlüsse [image] Versorgungsspannungen
Versorgungsspannungen
Die EtherCAT Box wird mit zwei Versorgungsspannungen versorgt. Die Massepotentiale der Versorgungsspannungen sind galvanisch getrennt.
▪
Steuerspannung US
▪
Peripheriespannung UP
Weiterleitung der Versorgungsspannungen
Die Power-Anschlüsse IN und OUT sind im Modul gebrückt. Somit können auf einfache Weise die Versorgungsspannungen US und UP von EtherCAT Box zu EtherCAT Box weitergereicht werden.
Hinweis
Maximalen Strom beachten!
Beachten Sie auch bei der Weiterleitung der Versorgungsspannungen US und UP, dass jeweils der für die M8-Steckverbinder maximal zulässige Strom von 4 A nicht überschritten wird!
Weiterführende Informationen
•
Steckverbinder
•
Status-LEDs
•
Leitungsverluste


Steckverbinder

Montage und Anschluss [image] Anschlüsse [image] Versorgungsspannungen [image] Steckverbinder
Steckverbinder
Hinweis
Verwechselungs-Gefahr: Versorgungsspannungen und EtherCAT
Defekt durch Fehlstecken möglich.
•
Beachten Sie die farbliche Codierung der Steckverbinder:
schwarz: Versorgungsspannungen
grün: EtherCAT
Steckverbinder + LEDs
Steckverbinder für Versorgungsspannungen
M8 4polig In+Out Kontaktbelegung
M8-Steckverbinder
Kontakt | Funktion | Beschreibung | Aderfarbe 1)
1 | US | Steuerspannung | Braun
2 | UP | Peripheriespannung | Weiß
3 | GNDS | GND zu US | Blau
4 | GNDP | GND zu UP | Schwarz
1) Die Aderfarben gelten für Leitungen vom Typ: Beckhoff ZK2020-3xxx-xxxx


Status-LEDs

Montage und Anschluss [image] Anschlüsse [image] Versorgungsspannungen [image] Status-LEDs
Status-LEDs
Siehe Kapitel Diagnose-LEDs.


Leitungsverluste

Montage und Anschluss [image] Anschlüsse [image] Versorgungsspannungen [image] Leitungsverluste
Leitungsverluste
Beachten Sie bei der Planung einer Anlage den Spannungsabfall an der Versorgungs-Zuleitung. Vermeiden Sie, dass der Spannungsabfall so hoch wird, dass die Versorgungsspannungen an der Box die minimale Nennspannung unterschreiten.
Berücksichtigen Sie auch Spannungsschwankungen des Netzteils.
Spannungsabfall an der Versorgungs-Zuleitung
Leitungsverluste M8 2A
Leitungsverluste M8 4A


Diag-Port

Montage und Anschluss [image] Anschlüsse [image] Diag-Port
Diag-Port
Der Diag-Port dient zum Aktualisieren der Firmware von EP9300-0022.
Aktualisieren Sie die Firmware nur in Abstimmung mit dem Beckhoff-Support.


UL-Anforderungen

Montage und Anschluss [image] UL-Anforderungen
UL-Anforderungen
Die Installation der nach UL zertifizierten EtherCAT Box Module muss den folgenden Anforderungen entsprechen.
Versorgungsspannung
SmallWarningYellow VORSICHT
VORSICHT!
Die folgenden genannten Anforderungen gelten für die Versorgung aller so gekennzeichneten EtherCAT Box Module.
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur mit einer Spannung von 24 VDC versorgt werden, die
•
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
•
von einer Spannungsquelle die NEC class 2 entspricht stammt.
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit unbegrenzten Spannungsquellen verbunden werden!
Netzwerke
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit Telekommunikations-Netzen verbunden werden!
Umgebungstemperatur
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur in einem Umgebungstemperaturbereich von 0 bis 55°C betrieben werden!
Kennzeichnung für UL
Alle nach UL (Underwriters Laboratories) zertifizierten EtherCAT Box Module sind mit der folgenden Markierung gekennzeichnet.
UL-Markierung


Inbetriebnahme und Konfiguration

Inbetriebnahme und Konfiguration
Inbetriebnahme und Konfiguration
Weiterführende Informationen
•
IP-Adresse
•
Profinet-Name
•
Profinet Konfiguration
•
EtherCAT Konfiguration
•
Konfigurations-Beispiel
•
CoE-Datenzugriff über Profinet
•
Multikonfigurationsmodus
•
IO-Link
•
EBus Error Behaviour
•
Web-Seite freischalten
•
Außerbetriebnahme


IP-Adresse

Inbetriebnahme und Konfiguration [image] IP-Adresse
IP-Adresse
EP9300-0022 hat keine vordefinierte IP-Adresse. Die IP-Adresse kann von einem der folgenden Netzwerk-Teilnehmer zugewiesen werden:
▪
Profinet-Controller (Normalfall)
▪
DHCP-Server
Stellen Sie am Drehschalter S1 ein, von welchem Netzwerk-Teilnehmer die IP-Adresse zugewiesen werden soll:
Drehschalter S1
S1 | Quelle der IP-Adresse
1 | DHCP-Server
3 | Profinet-Controller


Profinet-Name

Inbetriebnahme und Konfiguration [image] Profinet-Name
Profinet-Name
Der Profinet-Name von EP9300-0022 lautet „EP9300-xxx“. „xxx“ ist eine Dezimalzahl zwischen 1 und 255, die Sie über die Drehschalter S2 und S3 einstellen können. Die Drehschalter sind hexadezimal kodiert:
▪
S2 bestimmt das höherwertige Halbbyte.
▪
S3 bestimmt das niederwertige Halbbyte.
Drehschalter S2 und S3
S2 | S3 | Profinet-Name
0 | 1 | EP9300-001
0 | 2 | EP9300-002
0 | 3 | EP9300-003
… | … | …
1 | 0 | EP9300-016
… | … | …
F | F | EP9300-255


Profinet Konfiguration

Inbetriebnahme und Konfiguration [image] Profinet Konfiguration
Profinet Konfiguration
GSDML-Datei
Nur EtherCAT-Geräte, die in der GSDML-Datei vorhanden sind, werden unterstützt; Erweiterungen sind aber möglich. GSDML unterstützt unterstützt Submodule; informieren Sie sich bei Ihrem Profinet Master/Controller, ob dieser Submodule unterstützt. Sollte dies nicht der Fall sein, sind einige EtherCAT-Geräte nicht verwendbar!
Alternativ kann auch der CX8093 eingesetzt werden, dieser unterstützt im Allgemeinen alle EtherCAT-Geräte.
Allgemein
EP9300-0022 wird immer mit Hilfe einer GSDML-Datei im Profinet-Controller (Master) eingebunden. Die GSDML-Datei enthält alle Parametrierungsdaten, die für den Betrieb von EP9300-0022 am Profinet-Controller notwendig sind. Das Konfigurationswerkzeug liest diese Datei ein und stellt dem Anwender die Daten dann zur Verfügung.
In der GSDML-Datei sind auch die EtherCAT-Geräte, die an EP9300-0022 betrieben werden können, angegeben. Es werden nicht alle EtherCAT-Geräte unterstützt. Informieren sie sich deshalb vorab, ob die EtherCAT-Geräte, die Sie einsetzen möchten, auch von EP9300-0022 unterstützt werden.
Daten im DAP (Device Access Point)
Im DAP der GSDML-Datei befinden sich 2x 2 Byte Daten:
▪
ECCycleCounter (2 Byte). Dieser wird mit jedem EtherCAT-Zyklus (1 ms) inkrementiert, vorausgesetzt der EtherCAT-Master befindet sich im Zustand "OP".
▪
Status (2 Byte). Dieser gibt bitweise einzelne Statusinformation wieder. Diese sind wie folgt belegt:
–
Bit 0 - IsSynchron - Wird gesetzt, wenn EP9300-0022 als PTP-Slave oder IRT-Device betrieben wird und synchron ist.
–
Bit 1 - IsPTPMaster - Wird gesetzt, wenn EP9300-0022 als PTP-Master betrieben wird.
–
Bit 2 - ECFrameError - Wird gesetzt, wenn am EtherCAT-Ausgang ein Problem festgestellt wird. Um weitere Informationen zu erhalten, muss die Profinet-Diagnose bzw. die Alarme ausgelesen werden.
Parameter im DAP
Activate PN Fallback Value
Off -> EtherCAT-Daten werden auf Null geschrieben.
On -> es besteht die Möglichkeit bei Ausgängen einen anderen Default-Wert zu benutzen. Bei digitalen Ausgängen kann zum Beispiel der aktuelle Ausgangsprozesswert bei PROFINET Kommunikationsfehler eingefroren, zu 0 oder zu 1 gesetzt werden.
Data Presentation
Intel Format -> Daten werden im Intel Format dargestellt.
Motorola Format -> Daten werden im Motorola Format dargestellt. Zum Beispiel werden bei Wort Variablen High und Low Byte getauscht.
EBus error behaviour
Set IOs to 0 -> Bei einem EtherCAT-Fehler werden Eingangsdaten und Ausgangsdaten auf Null geschrieben.
Legacy -> Eingangsdaten behalten ihren letzten Zustand bei, werden aber nicht mehr aktualisiert; Ausgangsdaten können noch gesetzt werden (abhängig von der Position des EtherCAT-Geräts).
Mapping
Typischerweise wird EP9300-0022 im Verbund mit EtherCAT-Geräten eingesetzt, die am EtherCAT-Ausgang angeschlossen werden. Die EtherCAT-Geräte sind Bestandteil der GSDML; Die Parametrierung der EtherCAT-Geräte geschieht vom Profinet-Controller aus.
Sie müssen die EtherCAT-Geräte genauso in den Hardware-Konfigurator eintragen, wie sie physikalisch angeschlossen sind. Wenn EtherCAT-Sternverteiler und/oder EtherCAT-Abzweige eingesetzt werden, ist es wichtig zu wissen, in welcher Reihenfolge die weiteren EtherCAT-Geräte in das Prozessabbild eingetragen wurden (siehe EtherCAT Mapping).
Verhalten beim Start von EP9300-0022
Beim Start oder Reset von EP9300-0022 müssen immer alle EtherCAT-Teilnehmer vorhanden sein. D.h. alle angeschlossenen EtherCAT-Geräte müssen vor dem Start bzw. gleichzeitig mit Spannung versorgt werden, damit EP9300-0022 am Profinet auch ordnungsgemäß aufstartet. Flexibler kann man eine Lösung mit dem CX8093 aufbauen.
Konfiguration der EtherCAT-Teilnehmer
Es gibt 4 Arten von EtherCAT-Teilnehmern:
▪
EtherCAT-Teilnehmer ohne Prozessdaten
▪
EtherCAT-Teilnehmer mit "einfachen" Prozessdaten ohne Parametrierung
(in der Regel einfache EtherCAT-Geräte mit digitalen Eingängen oder Ausgängen)
▪
EtherCAT-Teilnehmer mit "einfachen" Prozessdaten mit Parametern
(in der Regel EtherCAT-Geräte mit analogen Eingängen oder Ausgängen)
▪
EtherCAT-Teilnehmer mit unterschiedlichen Prozessdaten und Parametern
(zum Beispiel Inkrementalencoder)
Für alle gilt: sie müssen in der Konfiguration eingetragen werden.
Digitale Eingänge und Ausgänge zusammenfassen (Pack-Klemmen)
Digitale Eingangsklemmen und Ausgangsklemmen können auch von ihren Prozessdaten zusammengefasst werden. Diese Möglichkeit kann bei 2 oder 4 Kanal Klemmen verwendet werden. Dafür muss in der GSDML-Datei eine 2 oder 4 Kanal Pack-Klemme (ohne Stern) angefügt werden. Um das Byte zu füllen, muss als nächstes eine 2 oder 4 Kanal Pack-Klemme (mit Stern) angefügt werden. Die Klemmen müssen physikalisch und systematisch hintereinander gesteckt sein, bzw. logisch. Es darf die Byte-Grenze nicht überschritten werden.
Beispiel:
2 Kanal Pack (ohne Stern), danach dürfen 3 Module aus 2 Kanal Pack-Klemmen (mit Stern) angefügt werden.
Nicht erlaubt ist:
2 Kanal Pack (ohne Stern), danach 2 Module aus 4 Kanal Pack-Klemmen (mit Stern). Die Byte Grenze wird überschritten.
EtherCAT-Geräte mit unterschiedlichen Mapping-Möglichkeiten
Einige EtherCAT-Geräte bieten die Möglichkeit, unterschiedliche Prozessdaten darzustellen. Diese werden anhand der Parameter unterschiedlich dargestellt. Im Profinet-Controller wird so ein EtherCAT-Gerät durch Submodule dargestellt. Es wird immer das Standardmapping eingebunden. Wollen Sie abweichend vom Standard ein anderes Mapping benutzen, so löschen sie das Standard-Submodul und fügen Sie das ein, was sie verwenden wollen. Es kann sein, dass abweichend von der Dokumentation des EtherCAT-Geräts nicht alle Mappings unter EP9300-0022 verwendet werden können.
Beispiel einer EtherCAT-Klemme EL5101
Einfügen eines Submoduls
EtherCAT-Gateways
EtherCAT-Gateways unterstützen mehrere Submodule. Das erste Modul bzw. Grundmodul wird sofort geladen; es müssen die Module für die Prozessdaten angelegt werden. Diese müssen anschließend auch auf der Master-Seite des entsprechenden Gateways parametriert werden. Es sind nicht alle Features eines EtherCAT-Gateways an EP9300-0022 nutzbar.
EL6631-0010
Die Profinet-Device-Klemme ermöglicht es, 2 verschiedene Profinet-Netzwerke zu verbinden. Ein Default-Stationsname sowie IP-Einstellungen können über Parametrierdaten (GSDML) erfolgen. Es ist darauf zu achten, dass nicht die komplette maximale Datenlänge der EL6631-0010 verwendet werden kann. Die Länge ist abhängig von anderen EtherCAT-Teilnehmern, die an EP9300-0022 angeschlossen sind.
EL6731-0010
Die Profibus-Slave-Klemme ermöglicht die Kommunikation mit einem Profibus Master. Die Profibus-Adresse wird über die Parametersettings (in der GSDML) der Klemme festgelegt. Es können nur reine Prozessdaten ausgetauscht werden.
EL6692
Die EtherCAT-Slave-Klemme ermöglicht die Kommunikation mit einem EtherCAT Master. Es können nur reine Prozessdaten ausgetauscht werden.
EL6652-0010
Die EtherNet/IP Slave Klemme ermöglicht die Kommunikation mit einem EtherNet/IP Master. Die IP-Adresse und Subnetmaske wird über die Parametersettings (in der GSDML-Datei) von EL6652-0010 festgelegt. Es können nur reine Prozessdaten ausgetauscht werden.


EtherCAT Konfiguration

Inbetriebnahme und Konfiguration [image] EtherCAT Konfiguration
EtherCAT Konfiguration
EP9300-0022 ist ein EtherCAT-Master mit automatischer Konfiguration. D.h. es müssen beim Einschalten des Systems immer alle EtherCAT-Slave-Geräte vorhanden sein. Da in der Regel das Booten von EP9300-0022 wesentlich länger dauert als das Starten der EtherCAT-Slave-Geräte, können diese an der gleichen Spannungsversorgung betrieben werden. Bei dezentralen EtherCAT-Geräten ist darauf zu achten, dass die Versorgungsspannung dieser EtherCAT-Geräte früher oder gleichzeitig mit der Versorgungsspannung von EP9300-0022 eingeschaltet wird.
EtherCAT-Geräte während der Laufzeit ein- bzw. ausschalten
Sollte während der Betriebsphase ein oder mehrere EtherCAT-Geräte ausfallen, wird ein Plug Alarm gesendet; EP9300-0022 bleibt im Datenaustausch. Die Eingangsdaten aller EtherCAT-Geräte sind ungültig und werden auf FALSE oder Null gesetzt; die Ausgangsdaten werden nicht mehr übernommen. Das gilt auch für die Teilnehmer, die noch an EP9300-0022 im Betrieb sind. Möchte man die Möglichkeit nutzen, während der Laufzeit Teilnehmer anzustecken und abzustecken, muss eine weitere "Sync Unit" konfiguriert werden. Dies ist mit EP9300-0022 nicht möglich. Verwenden Sie in dem Fall einen CX8093.
EtherCAT-Geräte, die nicht in der GSDML vorhanden sind
Einige EtherCAT-Geräte sind nicht in der GSDML enthalten und können somit (noch) nicht verwendet werden. Hier kann der CX8093 eingesetzt werden, der vom Prinzip her alle EtherCAT-Geräte unterstützt.
EtherCAT Topologie
Alle EtherCAT-Teilnehmer müssen in der Reihenfolge eingetragen werden, wie sich diese an EP9300-0022 und damit am EtherCAT-Master mappen. EtherCAT-Geräte werden automatisch adressiert, bis auf wenige Ausnahmen sind alle EtherCAT-Geräte mit einem EtherCAT ASIC ausgestattet, die auch im System, d.h. im Profinet-Controller, eingetragen werden müssen. EtherCAT-Geräte ohne ASIC sind zum Beispiel EL9400, EL9070 und weitere EL9xxx. Sie können diese EtherCAT-Geräte anhand der Technischen Daten "Meldung an E-Bus" erkennen. Steht hier ein "-" muss dieses EtherCAT-Gerät auch nicht im Profinet-Controller eingetragen werden.
EtherCAT-Geräte werden in Richtung des EtherCAT Telegrams eingetragen.
Beispielkonfiguration mit EtherCAT-Koppler EK1100
Beispielkonfiguration mit EtherCAT-Koppler EK1100
Beispielkonfiguration mit EtherCAT-Koppler EK1100
Beispielkonfiguration mit EtherCAT-Box-Modulen EPxxxx
Beispielkonfiguration mit EtherCAT-Box-Modulen
Beispielkonfiguration mit EtherCAT-Box-Modulen EPxxxx
Beispielkonfiguration mit EK1122 2-Port-EtherCAT - Abzweig
Bei dem Einsatz eines EK1122 ist die Zählrichtung zu beachten. Ist am EK1122 der EtherCAT - Abzweig 1 angeschlossen, so wird der EtherCAT Frame als erstes hier weiter geschickt (1), ist der Abzweig 1 nicht angeschlossen wird der Frame auf Abzweig 2 verschickt (2), erst danach wird mit dem E-Bus auf der rechten Seite fortgefahren (3).
Beispielkonfiguration mit EP1122 2-Port-EtherCAT - Abzweig
Werden beide Abzweige nicht genutzt, so werden Abzweig 1 und 2 quasi kurzgeschlossen und der EtherCAT Frame geht direkt aus der Klemme rechts weiter.
Es ist zu beachten, dass im PROFINET Controller die Module in Richtung des EtherCAT Frames eingetragen werden.
Beispielkonfiguration mit EP1122-0001 2-Port-EtherCAT - Abzweig
Bei dem Einsatz von EP1122-0001 ist die Zählrichtung zu beachten, sie ist vergleichbar mit der bei EK1122. Ist an EP1122-0001 der EtherCAT - Abzweig 1 angeschlossen, so wird der EtherCAT-Frame als erstes hier weitergeschickt (1), ist der Abzweig 1 nicht angeschlossen wird der Frame auf Abzweig 2 verschickt (2), erst danach wird mit dem EtherCAT-Bus auf der rechten Seite fortgefahren (3).
Beispielkonfiguration mit EP1122 2-Port-EtherCAT - Abzweig
Werden beide Abzweige nicht genutzt, so werden Abzweig 1 und 2 quasi kurzgeschlossen und der EtherCAT-Frame geht direkt aus der Klemme rechts weiter.
Es ist zu beachten, dass im Profinet Controller die Module in Richtung des EtherCAT-Frames eingetragen werden.
Konnektierung im laufenden Betrieb
Sie können EP1122-0001 und EK1122 nicht für Hot-Swap verwenden und auch nicht für ein "connect" und "disconnect" im laufenden Betrieb. EP1122-0001 und EK1122 eigenen sich im Zusammenspiel mit dem EK Koppler nur als Topologie Erweiterung (Stern).


Konfigurations-Beispiel

Inbetriebnahme und Konfiguration [image] Konfigurations-Beispiel
Konfigurations-Beispiel
PDO Mapping
Die Prozessdaten auf der EtherCAT-Seite werden über das PDO Mapping beschrieben. Die einzelnen EtherCAT-Geräte bringen über die ESI-Datei (EtherCAT-Beschreibungsdatei) ein vordefiniertes PDO Mapping mit, also eine sinnvolle Kombination einzelner PDOs.
Auswahldialog "Predefined PDO"
Diese Kombinationen wiederum werden auf Profinet-Seite anhand unterschiedlicher Submodule, und somit Prozessdaten, beschrieben. D.h. jedes vordefinierte PDO Mapping hat ein zugehöriges Submodul.
Submodule
Solche modulare Klemmen haben an EP9300-0022 immer auf Subslot 1 ein festes Submodul stecken. Dieses ist der Platzhalter für die Klemme selbst, d.h. hierüber wird z. B. für die Klemme die allgemein gültige Diagnose betrieben. Auf Subslot 2 werden die eigentlichen Prozessdaten gesteckt und anhand dieser wird das PDO Mapping am EtherCAT-Master erzeugt.
SDO Mapping
Jeder der gesteckten Subslots kann Parametrierdaten mit sich bringen. Über diese Daten werden die Service-Daten-Objekte (SDOs) übertragen, d.h. die SDOs werden auf Recorddatensätze abgebildet. Es werden immer die Objekte 0x8xxx und 0xF8xx abgebildet. Da die Indizes auf der Profinet-Seite nur von 0 - 0x7FFF herstellerspezifisch sind, entsprechen die EtherCAT-Objekte 0x8xxx den Profinet Record Indizes 0x3xxx, EC-Objekte 0xF8xx dem Profinet Indexbereich 0x48xx. In Profinet werden die Records immer in der Startup-Phase vom Controller geschrieben, diese werden intern dem EtherCAT-Master als Startup SDOs übergeben. D.h. während eines Profinet-Neustarts wird auch der interne EtherCAT-Master neu gestartet.
Profinet Record Indizes 0x3xxx (entspricht EtherCAT-Objekte 0x8xxx)
Diese Datensätze können auch im laufenden Betrieb gelesen und geschrieben werden.
Inbetriebnahme EL7031
Die Defaulteinstellungen sind für eine Erstinbetriebnahme ausreichend, d.h. es muss nur das entsprechende Submodul ausgewählt werden. Anhand dessen werden die PDOs und SDOs der Klemme parametriert. Wird z. B. das "Velocity Control" Submodul gewählt, muss nur das Bit Control_Enable gesetzt werden, anschließend durch Vorgabe einer Sollgeschwindigkeit den Motor drehen.


CoE-Datenzugriff über Profinet

Inbetriebnahme und Konfiguration [image] CoE-Datenzugriff über Profinet
CoE-Datenzugriff über Profinet
Beschreibung
CoE bedeutet Can over EtherCAT. Dieser Zugriff erlaubt auf alle Parameter eines EtherCAT-Teilnehmers zuzugreifen. Das CoE-Datenmodell basiert auf den Grundlagen von CANopen und verwendet Index und Subindex um Parameter zu lesen oder zu beschreiben wenn diese es erlauben.
Weiter Information erhalten Sie über folgende Seite: Systemdokumentation
Aufgabe
Parameter eines EtherCAT-Teilnehmers können in der Regel über die Parameter der GSDML-Datei eingestellt und parametriert werden. In manchen Applikationen ist es aber notwendig bestimmte Parameter zur Laufzeit zu verändern oder im laufenden Betrieb Optimierungen durchzuführen.
Lösung
Die CoE-Daten werden über azyklischen PROFINET-Dienste geschickt (PROFINET-Index 0x200F). Die Position des EtherCAT-Teilnehmers wird über die Slot-Nummer vorgeben. Die CoE-Daten werden dann in die Record-Daten eingetragen und bestehen beim Lesen aus CoE-Index und CoE-Subindex und beim Schreiben aus CoE-Index, CoE-Subindex und den zu sendenden Daten.
Beispiel Lesen/Schreiben
Für das Lesen muss als erstes ein Record WriteReq versendet werden. Dies beinhaltet den CoE-Index und CoE-Subindex. Nach dem WriteRsp muss ein ReadReq gesendet werden um die Daten abzuholen, die dann im ReadRsp enthalten sind.
Für das Schreiben erfolgt dies auf gleicher Art und Weise, nur das beim WriteReq die Daten mitgeschickt werden und mit der ReadRsp eine Quittung erfolgt ob das Schreiben geklappt hat.
CoE-Datenzugriff über PROFINET, Beispiel Lesen/Schreiben
Erste Schritte Lesen
PROFINET Record Daten (Write Request) | Wert | Bedeutung
Slot | Position des EtherCAT-Teilnehmers (1...255) | Slot-Nummer, Position des EtherCAT-Teilnehmers
SubSlot | 1 | Sub-Slot-Nummer, immer "1"
Index | 0x200F | PROFINET-Index-Nummer
Length | 4 | Länge der folgenden Daten
Daten | Byte 1 und 2 SDO Index Byte 3 CoE SubIndex Byte 4 "0" Reserve | CoE-Daten
Wartezeit, wir empfehlen hier 100..250 ms bis der Read Request versendet wird, der eine Bestätigung des Fehlerfreien Schreiben beinhaltet.
PROFINET Record Daten (Read Request) | Wert |  | Bedeutung
Slot | Position des EtherCAT-Teilnehmers (1...255) |  | Slot-Nummer, Position des EtherCAT-Teilnehmers
SubSlot | 1 |  | Sub-Slot-Nummer, immer "1"
Index | 0x200F |  | PROFINET-Index-Nummer
Length | Schreiben 4 | Antwort 4 Byte + x Byte | Länge der folgenden Daten
Daten | Schreiben Byte 1 "1" Byte 2 "0" Byte 3 "0" Byte 4 "0" | Antwort Byte 1..4 ADS-Fehler Byte 4..x COE-Datenwert | CoE-Daten
In der Antwort des Read Request also dem Read Response kommen die Daten. Die ersten 4 Byte beinhalten den Fehler-Code. Bei fehlerfreier Antwort ist dieser "0". Der Fehler Code ist ein ADS-Fehler-Code und kann unter folgenden Link nachgelesen werden.
http://infosys.beckhoff.com/content/1031/tcsample/html/ads_returncodes.htm
Erste Schritte Schreiben
PROFINET Record Daten (Write Request) | Wert | Bedeutung
Slot | Position des EtherCAT-Teilnehmers (1...255) | Slot-Nummer, Position des EtherCAT-Teilnehmers
SubSlot | 1 | Sub-Slot-Nummer, immer "1"
Index | 0x200F | PROFINET-Index-Nummer
Lenght | 4 | Länge der folgenden Daten
Daten | Byte 1..2 SDO Index Byte 3 SDO SubIndex Byte 4 "1" Konstante Byte 5..8 Länge als DWORD Byte 9..x CoE Datenwert | CoE-Daten
Wartezeit, wir empfehlen hier 250..500 ms bis der Read Request versendet wird, der eine Bestätigung des Fehlerfreien Schreiben beinhaltet.
PROFINET Record Daten (Read Request) | Wert |  | Bedeutung
Slot | Position des EtherCAT Teilnehmers (1...255) |  | Slot-Nummer, Position des EtherCAT-Teilnehmers
SubSlot | 1 |  | Sub-Slot-Nummer, immer "1"
Index | 0x200F |  | PROFINET-Index-Nummer
Lenght | Schreiben 0 | Antwort 4 | Länge der folgenden Daten
Daten | Schreiben - | Schreiben ADS-Fehler-Code | CoE-Daten
In der Antwort des Read Request also dem Read Response kommt die Bestätigung ob das Schreiben geklappt hat, die ersten 4 Byte beinhalten den Fehler Code, bei fehlerfreier Antwort ist dieser "0". Der Fehler Code ist ein ADS-Fehler-Code und kann unter folgenden Link nachgelesen werden.
http://infosys.beckhoff.com/content/1031/tcsample/html/ads_returncodes.htm
Datenformat beachten
Achten Sie beim Lesen und Schreiben auf die Datengröße und das Format der entsprechenden SDO-Parameter. Wir empfehlen die SDO-Daten erst zu lesen, sie dann zu interpretieren und entsprechend des gelesenen Datenformats dieses auch beim Schreiben der CoE-Daten zu verwenden (eventuell High/Low BYTE/WORD tauschen).
Start-up Parameter überschreiben COE-Daten
Typischerweise werden CoE-Daten nicht im EtherCAT-Teilnehmer gespeichert. Achten Sie darauf, das CoE-Daten beim Starten von EP9300-0022 wieder durch die Start-up Parameter (GSDML) überschrieben werden.


Multikonfigurationsmodus

Inbetriebnahme und Konfiguration [image] Multikonfigurationsmodus
Multikonfigurationsmodus
Beschreibung
Der Multikonfigurationsmodus erlaubt dem Anwender, unterschiedliche Hardware, z. B. EP9300-0022 mit variierenden EtherCAT-Geräten, mit derselben Projektierung zu betreiben.
Diese Beschreibung verwendet in den Beispielen EtherCAT-Klemmen (ELxxxx). Das Prinzip gilt genauso für EtherCAT-Box-Module (EPxxxx).
Aufgabe
Der Maschinenbauer hat eine Maschine, die mit unterschiedlichen Optionen verkauft werden soll. Die Optionen sind in der Regel zusätzliche Signale die verarbeitet und erfasst werden müssen und dafür zusätzliche Klemmen erfordern.
Für all diese Optionen soll aber die Projektierung beibehalten und nur über die Software variiert werden. Es wird also parametriert, welche Optionen die Maschine tatsächlich beinhaltet.
Lösung
Mit dem Multikonfigurationsmodus wird in der Projektierung die maximale Anzahl der Optionen konfiguriert. Hat die Maschine weniger als die maximale Anzahl an Optionen, können EtherCAT-Geräte entfallen, da diese Signale nicht benötigt werden. Die nicht benötigten EtherCAT-Geräte sind zwar in der maximalen Projektierung enthalten, können aber von der Steuerung deaktiviert werden, so dass Hardware und parametrierte Konfiguration wieder übereinstimmen. Sobald dies erfolgt ist geht EP9300-0022 in den normalen Datenaustausch.
Vorteil
Weniger Aufwand bei der Erstellung und Pflege der Projekte, weil die gleiche Projektierung für unterschiedliche Hardware verwendet werden kann.
Beispiel
Die Grundkonfiguration der Maschine besteht ohne Optionen aus:
▪
1x EP9300-0022
▪
2x EP2008-0001
▪
2x EP1008-0001
▪
1x EP5101-0002
Es können folgende Optionen hinzukommen:
▪
Mit automatischer Verstellachse: zusätzlich eine EP7041-0002
▪
Mit Temperaturerfassung: zusätzlich eine EP3314-0002
Damit sieht der maximale Ausbau (mit kursiv dargestellten optionalen EtherCAT-Geräten) wie folgt aus:
▪
1x EP9300-0022
▪
2x EP2008-0001
▪
2x EP1008-0001
▪
1x EP5101-0002
▪
1 x EP7041-0002
▪
1 x EP3314-0002
Genau dieser maximale Ausbau wird in der Hardware-Konfiguration auch projektiert.
Wird die Maschine ohne Optionen bestellt, müssen die EtherCAT-Geräte EP7041-0002 und EP3314-0002 in der Projektierung deaktiviert werden. Dazu wird EP9300-0022 per Record Daten (azyklische Kommunikation) mitgeteilt, welche EtherCAT-Geräte entfallen. Dabei werden die EtherCAT-Geräte über ihre Position identifiziert.
Ohne Optionen sind zweimal EP2008-0001 (an Position 1 und 2), zweimal EP1008-0001 (an Position 3 und 4) und einmal EP5101-0002 (an Position 5) vorhanden. Die EtherCAT-Geräte an Position 6 und 7 (optionale EtherCAT-Geräte) müssen deaktiviert werden.
Wird die Maschine mit der Option "automatischer Verstellachse" bestellt, muss nur das EtherCAT-Gerät an Position 7 deaktiviert werden.
Position von optionalen EtherCAT-Geräten
Optionale EtherCAT-Geräte können auch an einer belieben Position im EtherCAT-Netzwerk vorhanden sein, um sie eventuell zu deaktivieren. Sie müssen nicht, wie im Beispiel gezeigt, zwingend am Ende eingesetzt werden.
Erste Schritte
Damit EP9300-0022 im Multikonfigurationsmodus arbeiten kann, muss im DAP (Device Access Point) der MultiConfigurationMode auf "TRUE" gestellt werden.
Es gibt zwei Möglichkeiten, die Einstellung vorzunehmen.
Option 1
Dies ist eher die Variante zum Testen, da hier die Hardware-Konfiguration angepasst werden muss, was eigentlich vermieden werden sollte.
Im DAP gibt es die Einstellung MultiConfigurationMode mit den Slots. Hier können Sie EtherCAT-Klemmen die projektiert aber nicht vorhanden sind deaktivieren.
Bei einigen PROFINET-Controllern muss das beim Starten erfolgen, es gibt aber auch PROFINET-Controller, die das zur Laufzeit erlauben, was das Testen wesentlich vereinfacht. Das Deaktivieren/Aktivieren von Klemmen zur Laufzeit ist ein Feature des PROFINET-Controllers und kann je nach Hersteller des PROFINET Controllers möglich bzw. nicht möglich sein.
Option 2
Die Konfiguration wird von der SPS über die Record Daten verschickt. Auch hier bieten die Hersteller verschiedene Wege an. Kontaktieren Sie hierzu den Hersteller Ihres PROFINET-Controllers, falls Sie dazu Fragen haben.
Erforderlich für Option 2 ist, dass Ihr PROFINET-Controller den Zugriff auf die Record Daten erlaubt und unterstützt.
PROFINET Record Daten (Write Request) | Wert | Bedeutung
Slot* | 0 | Slot Nummer, immer "0"
SubSlot* | 1 | Sub Slot Nummer, immer "1"
Index | 0#2010 | PROFINET Index Nummer
Lenght | variable | Länge der Daten die Folgen
Daten | Jede Busklemme benötigt 2 Bit: 00bin Klemme vorhanden 10bin Klemme nicht vorhanden | Aktivieren/Deaktivieren der EtherCAT Teilnehmer
* Bei einigen PROFINET Controllern werden diese Daten automatisch aus der GSDML entnommen und müssen nicht projektiert werden.
Vorgehensweise
Nach dem Sie die Station projektiert haben, sind folgende Schritte notwendig.
Wird die Maschine im maximalen Ausbau (mit allen Optionen) bestellt, muss in der Regel nichts gemacht werden, da die Hardware mit der Projektierung übereinstimmt.
Ist eine der Optionen nicht enthalten, so unterscheiden sich Hardware und Projektierung. Der PROFINET-Koppler zeigt dies über die Meldung "Module Difference".
Deaktivieren Sie nun die Klemmen, die nicht vorhanden sind. Sobald dies erfolgt ist wird die Meldung "Module Difference" vom Koppler entfernt. Bleibt die Meldung "Module Difference" erhalten, so haben Sie eventuell den falschen Slot oder zu wenige Slots deaktiviert.
Keine SubSlots
SubSlots werden nicht mitgezählt und können für den Multikonfigurationsmodus auch nicht verwendet werden.
Es können nur Slots verwendet werden, dabei ist es egal ob ein Modul SubSlots verwendet oder nicht.
Kein Shared Device
Das Feature Shared Device kann bei der Verwendung des Multikonfigurationsmodus nicht verwendet werden.
Keine Pack oder (*)-Klemmen
Pack- oder (*)-Klemmen dürfen im Multikonfigurationsmodus nicht verwendet werden.


IO-Link

Inbetriebnahme und Konfiguration [image] IO-Link
IO-Link
Aufgabe
Anschluss eines IO-Link-Sensors an EP9300-0022.
Konfiguration der Prozessdaten
Jedes IO-Link-Device wird als Submodul eingefügt. Für jeden IO-Link-Device wird ein SubModul verwendet. Die Prozessdatengrößen des SubModuls müssen immer gleich oder größer der des IO-Link-Devices sein und dürfen nicht kleiner sein.
Sollten Sie nicht alle IO-Link-Kanäle verwenden sind Empty Channel einzutragen. Beispiel sie haben am IO-Link-Master nur am Eingang 2 und 4 einen Sensor angeschlossen, die Eingänge 1 und 3 sind unbenutzt, dann fügen Sie als erstes einen Empty Channel als Submodul an, der zweite ist dann der Sensor auf Eingang 2, anschließend einen Empty Channel und als Letztes den Sensor auf Eingang 4. Der IO-Link Master verwendet als erstes SubModul ein Diagnose-Modul. Dieses ist beim Einfügen der EL6224/EP6224 immer vorhanden. Dieses SubModul beinhaltet den Status aller angeschlossenen IO-Link-Devices. Ist der Sensor im IO-Link-Datenaustausch wird das über das entsprechende Byte angezeigt (0x03 bedeutet alles in Ordnung).
Angaben zum Status Byte:
0x_0 = Port disabled
0x_1 = Port in std dig in
0x_2 = Port in std dig out
0x_3 = Port in communication OP
0x_4 = Port in communication COMSTOP / dig in Bit (nur im std. IO Mode)
0x_8 = Process Data Invalid Bit
0x1_ = Watchdog detected
0x2_ = internal Error
0x3_ = invalid Device ID
0x4_ = invalid Vendor ID
0x5_ = invalid IO-Link Version
0x6_ = invalid Frame Capability
0x7_ = invalid Cycle Time
0x8_ = invalid PD in length
0x9_ = invalid PD out length
0xA_ = no Device detected
0xB_ = error PreOP/Data storage
Die Prozessdatengröße eines verwendeten IO-Link-Devices entnehmen Sie bitte seiner Dokumentation oder fragen Sie den Hersteller.
Einfügen eines „Generic Channel“ (bei IO-Link-Devices anderer Hersteller
IO-Link-Devices von Beckhoff werden automatisch mit den notwendigen Parametern eingefügt. Bei anderen Herstellern verwenden Sie ein Generic Channel und wählen Sie die Prozessdatengröße aus.
Konfiguration des IO-Link-Devices
Die notwenigen mindest Einstellungen für das Betreiben eines IO-Link-Devices sind:
IO-Link-Version: In der Regel 1.1; tragen Sie hierfür 11 ein
Frame capability: In der Regel 1
Min Cycle Time: In der Regel 2,3 ms, also 23
Processs data in / Out lengh: Variable (Anzahl in Bit), bei einer Größe von 2 Byte Input tragen bei "Process data in length" 16 ein.
Master Control: auf IO-Link stellen
Alle anderen Einstellungen sind optional.
Konfiguration des IO-Link-Devices
Lesen/Schreiben von Parametern
Jedes IO-Link-Device hat Parameter, die man lesen oder schreiben kann. EP9300-0022 unterstützt diese Funktion nicht. D.h. es können keine Parameter gelesen oder geschrieben werden. Die Kommunikation von EP9300-0022 mit einem IO-Link-Device beschränkt sich auf die Prozessdaten.
Wenn Sie auf Parameter der IO-Link-Devices zugreifen möchten, müssen Sie eine Beckhoff-Steuerung verwenden (z. B. CX8093). Hier können Sie die IODD-Datei (IO-Link Device Description) einlesen und über die SPS die Sensordaten lesen oder schreiben.


EBus Error Behaviour

Inbetriebnahme und Konfiguration [image] EBus Error Behaviour
EBus Error Behaviour
Parameter 'EBus error behaviour'
Der Parameter „EBus error behaviour“
Dieser Parameter wird verwendet um die Reaktion auf einen EtherCAT-Fehler einzustellen. Folgende Möglichkeiten können genutzt werden:
Legacy | Ausgangsdaten werden noch geschrieben, Eingangsdaten werden eingefroren und sind damit nicht mehr aktuell.
Set IOs to 0 | Ausgangsdaten werden zu Null geschrieben, Eingangsdaten werden zu Null geschrieben. Sobald das EtherCAT-Netzwerk fehlerfrei ist, startet automatisch der Datenaustausch.
Set IOs to 0 without EBus restart (Default-Einstellung) | Ausgangsdaten werden zu Null geschrieben, Eingangsdaten werden zu Null geschrieben. Sobald das EtherCAT-Netzwerk fehlerfrei ist, kann der E-Bus über die Record Daten wieder freigegeben werden (sieh unten).
Aktivieren von EtherCAT nach einem EtherCAT-Fehler
Im DAP erhalten Sie über das DWord „Status“ die Informationen über den EtherCAT-Zustand. Sobald im EtherCAT-Netzwerk ein Fehler erkannt wird, wird das Bit EcFrameError gesetzt (im High Word Bitoffset x.2). Ist der Fehler behoben und EP9300-0022 wieder bereit, die EtherCAT-Kommunikation zu starten, wird das Bit EcFrameError zurückgesetzt und im High Word Bitoffset x.4 das Flag NeedEBusReset gesetzt.
EP9300 EtherCAT Statuswort
Flag NeedEBusReset
Der Reset wird über Record Daten Write abgesetzt und ist wie folgt aufgebaut.
Profinet Record Daten (Write Request) | Wert | Bedeutung
Slot | 0 | Slotnummer
SubSlot | 1 | Sub Slot Nummer
Index | 0x2013 | Reset Index
Lenght | 2 | Datenlänge
Daten | 0x1234 | Wert
Nach dem Absetzen des Reset wird das Bit NeedEBusReset zurückgesetzt.


Web-Seite freischalten

Inbetriebnahme und Konfiguration [image] Web-Seite freischalten
Web-Seite freischalten
Die Web-Seite kann über die Parameter-Daten des DAPs freigeschaltet werden. Setzen Sie den Parameter Webserver auf active und verbinden Sie EP9300-0022 mit Ihrem Profinet-Controller. Nach dem Verdingungsaufbau und Erhalt der IP-Adresse kann auf die Web-Seite von EP9300-0022 zugegriffen werden.
Parameter „Webserver“ auf „active“ setzen
Wir empfehlen, diese Web-Seite nur für Diagnosezwecke zu verwenden und dort keine Einstellungen vorzunehmen, da diese in der Regel immer durch den Profinet-Controller erfolgen solten.
Die Web-Seite erreicht man über den Aufruf der IP-Adresse von EP9300-0022 mit dem Parameter Config
Beispiel: 192.168.1.10 /Config
Benutzername: guest
Passwort: 1
Um die Web-Seite zu erreichen zu können müssen folgende Voraussetzungen gegeben sein:
▪
Die Web-Seite muss über die Parameter-Daten von EP9300-0022 freischalten worden sein.
▪
Der PROFINET-Controller muss mindestens einmal mit EP9300-0022 in den Datenaustausch gegangen sein, damit die Parameter und die IP-Adresse auf EP9300-0022 eingestellt wurden. EP9300-0022 darf anschließend nicht spannungslos geschaltet werden, da sonst Einstellungen/Parameter nicht übernommen werden und Events im Logger des WebServers verloren gehen.
▪
Der PC mit dem Internet-Browser muss sich im gleichen IP-Segment befinden wie EP9300-0022. Kontrollieren Sie vom PC aus mit dem PING-Befehl ob der PC EP9300-0022 erreichen kann. Sollte dies der Fall sein, können Sie die Web-Seite von EP9300-0022 aufrufen.
Falls die PING-Befehl fehlschlägt, überprüfen sie folgende Punkte:
- Wurde die Web-Seite freigeschaltet?
- War die Kommunikation vom PROFINET-Controller zu EP9300-0022 erfolgreich?
- Ist die IP-Adresse des PCs korrekt?
Browser-Empfehlung
Für die Anzeige der Web-Seite empfehlen wir als Browser Chrome oder Firefox.


Außerbetriebnahme

Inbetriebnahme und Konfiguration [image] Außerbetriebnahme
Außerbetriebnahme
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag!
Setzen Sie das Bus-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Demontage der Geräte beginnen!
Entsorgung
Zur Entsorgung muss das Gerät ausgebaut werden.
Gemäß der WEEE-Richtlinie 2012/19/EU nimmt Beckhoff Altgeräte und Zubehör in Deutschland zur fachgerechten Entsorgung zurück. Die Transportkosten werden vom Absender übernommen.
Senden Sie die Altgeräte mit dem Vermerk „zur Entsorgung“ an:
Beckhoff Automation GmbH & Co. KG
Abteilung Service
Stahlstraße 31
D-33415 Verl


Grundlagen

Grundlagen
Grundlagen
Weiterführende Informationen
•
Systemvorstellung PROFINET
•
Darstellung eines EtherCAT-Slaves am PROFINET


Systemvorstellung PROFINET

Grundlagen [image] Systemvorstellung PROFINET
Systemvorstellung PROFINET
PROFINET ist der Industrial-Ethernet-Standard der PNO (PROFIBUS Nutzerorganisation). PROFINET IO beschreibt den Datenaustausch zwischen Steuerungen und Feldgeräten in mehreren Echtzeitklassen: RT (Software-basiertes Real-Time) und IRT (hardwaregestütztes Isochronous Real-Time). Zusätzlich kann weiterer Ethernet-Verkehr im NRT (Non Real-Time)-Zeitschlitz des PROFINET-Zyklus übertragen werden. RT kann mit handelsüblichen Switches vernetzt werden, für IRT sind Switche mit entsprechender Hardwareunterstützung erforderlich.
PROFINET Systemübersicht
Komponenten | Kommentar
Embedded-PCs
CX8093 | Embedded-PC mit Feldbusschnittstelle PROFINET-RT-Device
CX50xx-M930 | Embedded-PC mit Optionsschnittstelle PROFINET-RT-Controller
CX50xx-B930 | Embedded-PC mit Optionsschnittstelle PROFINET-RT-Device
EtherCAT-Klemmen
EL6631 | PROFINET-IO-Controller
EL6631-0010 | PROFINET-IO-Device
EL6632 | PROFINET-IRT-Controller
Buskoppler
BK9053 | PROFINET-„Compact“-Buskoppler für Busklemmen
BK9103 | PROFINET-Buskoppler für Busklemmen
EK9300 | PROFINET-Buskoppler für EtherCAT-Klemmen
EtherCAT Box
EP9300 | PROFINET-Koppler-Box für EtherCAT-Box-Module
Feldbus Box
IL230x-B903 | PROFINET-Koppler-Box für IP-Link-Box-Module
PC-Feldbuskarten
FC900x | PCI-Ethernet-Karte für sämtliche Ethernet (IEEE 802.3)-basierten Protokolle
FC9x51 | Mini-PCI-Ethernet-Karte für sämtliche Ethernet (IEEE 802.3)-basierten Protokolle
TwinCAT
TwinCAT PROFINET IO Controller | TwinCAT als PROFINET-Master
TwinCAT PROFINET IO Device | TwinCAT als PROFINET-Slave


Darstellung eines EtherCAT-Slaves am PROFINET

Grundlagen [image] Darstellung eines EtherCAT-Slaves am PROFINET
Darstellung eines EtherCAT-Slaves am PROFINET
Dieser Abschnitt soll helfen, die Beschreibung von EtherCAT-Geräten auf ein anderes Feldbussystem zu erläutern und die entsprechenden Informationen aus den bestehenden EtherCAT-Dokumentationen zu erhalten. Dabei werden im Folgenden Begriffe zum besseren Verständnis erklärt.
• Einleitung
EtherCAT-Geräte wie EL-Klemmen (ES, ELX, ELM), EP Module (ER, EQ, EPP) sind EtherCAT-Slave-Geräte die immer aus Prozessdaten und gegebenenfalls aus Parameter-Daten bestehen. In der Regel besitzen digitale EtherCAT-Geräte keine Konfigurationsdaten. Komplexe EtherCAT-Geräte in der Regel immer.
• Prozessdaten (PDO, Prozessdaten-Objekt)
So gut wie alle EtherCAT-Geräte haben Prozessdaten1), die von 2 Bit und bis zu mehreren 100 Byte groß sein können. Bei komplexen EtherCAT-Geräten kann man auch unterschiedliche Strukturen und Größen der Prozessdaten vorgeben. Diese werden als Predefined-PDOs bezeichnet.
Die Predefined-PDOs müssen vom EtherCAT (EC) Master vorgegeben werden und beim Starten des EC-Masters bekannt sein, bzw. hier eingestellt werden. Es gibt immer ein Default Predefined-PDO. Je nach eingesetzten überlagerten Bussystem kann das PDO-Mapping über den überlagerten Feldbussystem (wie bei PROFINET oder PROFIBUS) oder einer Konfigurationsseite (http-Protokoll, wie beim ModbusTCP oder EtherNet/IP) auf dem EK-Koppler eingestellt werden.
1) Außer z.B. der EK1100 Koppler, dieser besitzt weder Prozessdaten noch Konfigurationsdaten, ist aber mit einem EtherCAT-ASIC ausgestattet und sind somit auch ohne Prozessdaten im EtherCAT-Netzwerk sichtbar.
Parameter-Daten (COE)
Die Parameterdaten eines EC-Slaves werden über COE übertragen (CAN over EtherCAT). Diese sind wie bei CAN in Objekte, Subobjekte und Daten aufgeteilt. Parameter-Daten sind zum Beispiel Daten, die bei einer EL3202 Klemme, also einer Temperaturwiderstandsklemme, den Widerstandwert einstellt, wie zum Beispiel PT100, PT1000, NI100 usw.
Es werden beim EK-Koppler nur die applikationsspezifischen COE-Daten zur Verfügung gestellt. Je nach überlagerten Bussystem kann hier auf alle oder nur einige COE-Objekte zugegriffen werden.
Auch hier kann die Parametrierung über eine Webseite (http-Protokoll) im EK stattfinden.
PROFINET
• Prozessdaten
PROFINET-Device-Geräte (Slaves) müssen eine GSDML Datei mitbringen. In dieser GSDML werden die Geräte beschrieben. EP9300-0022 ist ein Gerät mit modularem Aufbau. Dieser besteht aus der Kopfstation (EP9300-0022) und einer Anzahl von EtherCAT-Teilnehmern, die an EP9300-0022 angeschlossen werden. Im PROFINET-Controller muss diese Datei (GSDML) dann eingebunden werden. Ist dies erfolgt, kann man jetzt EP9300-0022 und die EtherCAT-Teilnehmer einbinden und die entsprechenden Einstellungen vornehmen.
• Wie erhalte ich eine Beschreibung der EtherCAT-Prozessdaten?
Die Predefined-PDOs bestehen in der Regel aus verschiedenen PDOs und sind eine Zusammenstellung unterschiedlicher PDOs des Prozessabbildes.
Im Folgenden ist das mit der Automatisierungssoftware TwinCAT dargestellt:
Typische Konfigurationsseite einer EtherCAT-Klemme
Legende:
1.
Die EtherCAT-Klemme ist im TwinCAT-Baum eingefügt und hat Prozessdaten, die man mit dem SPS- Programm verknüpfen kann.
2.
Ansicht der vorhandenen Prozessdaten in Byte (genau diese Anzahl und Größe sieht man bei PROFINET und der Siemens Steuerung, Siemens stellt die Prozessdaten nicht weiter detaillierter dar obwohl diese in der GSDML beschrieben sind)
3.
Anzeige, welche PDOs in den Prozessdaten aktiv sind
4.
Ansicht aller PDOs
5.
Detaillierter einzelner PDOs die man in „4“ auswählen kann
6.
Predefined-PDOs
In der GSDML sind immer nur die Predefined-PDOs auswählbar (6). Will man eine andere Kombination der PDOs, geht dies nur über eine Beckhoff-Steuerung, wie zum Beispiel den CX8093, der über eine Default PROFINET-Schnittstelle verfügt und mit TwinCAT 2 programmierbar ist (bei TwinCAT 3 ist ein CX9020 mit B930 Interface notwendig, oder eine beliebige Beckhoff-Steuerung mit einer EL6631-0010).
Beispiel Mapping einer EL3162 im Standard-Format ( 8 Byte IN / 0 Byte OUT)
Name | Size (Variable) | Bit offset
AI Standard Channel 1.BitArray
Status_Underrange | BIT (BOOL) | 0.0
Status_Overrande | BIT (BOOL) | 0.1
Status_Limit_1[0] | BIT (BOOL) | 0.2
Status_Limit_1[0] | BIT (BOOL) | 0.3
Status_Limit_1[0] | BIT (BOOL) | 0.4
Status_Limit_1[0] | BIT (BOOL) | 0.5
Status_Error | BIT (BOOL) | 0.6
Status_Sync error | BIT (BOOL) | 1.5
Status_TxPDO State | BIT (BOOL) | 1.6
Status_TxPDO Toggle | BIT (BOOL) | 1.7
AI Standard Channel 1.Value | 16 BIT (INT) | 2.0..3.7
AI Standard Channel 2.BitArray
Status_Underrange | BIT (BOOL) | 4.0
Status_Overrande | BIT (BOOL) | 4.1
Status_Limit_1[0] | BIT (BOOL) | 4.2
Status_Limit_1[0] | BIT (BOOL) | 4.3
Status_Limit_1[0] | BIT (BOOL) | 4.4
Status_Limit_1[0] | BIT (BOOL) | 4.5
Status_Error | BIT (BOOL) | 4.6
Status_Sync error | BIT (BOOL) | 5.5
Status_TxPDO State | BIT (BOOL) | 5.6
Status_TxPDO Toggle | BIT (BOOL) | 5.7
AI Standard Channel 2.Value | 16 BIT (INT) | 6.0..7.7
Parameter-Daten
Im Folgenden soll auf die Parameter- oder auch Konfigurationsdaten eingegangen werden. Die meisten notwendigen Konfigurationsdaten sind in der GSDML enthalten, Beckhoff verwendet hier die gleichen Namen und Bedeutungen wie auf der EtherCAT-Seite, die in der ESI Datei2) in der CoE-Beschreibung enthalten ist.
EtherCAT: Parameter-Daten der EL3162 der ESI unter TwinCAT
PROFINET: Parameterdaten der EL3162 der GSDML unter TwinCAT
2) Die ESI Datei ist die Beschreibungsdatei für EtherCAT-Master (ESI-EtherCAT-Slave-Information).
Parameterdaten der EL3162 der GSDML unter TwinCAT
Diese Parameter zu den einzelnen Klemmen finden Sie auch im Konfigurationstool Ihres PROFINET- Controller wieder, egal welchen Hersteller Sie hier verwenden. Sie können auf einzelne Parameter auch über PROFINET und den Record-Daten azyklisch zugreifen. Dafür muss der PROFIENT-Controller über ein Interface zu den Record-Daten verfügen.


FAQ

FAQ
FAQ
Wie kann ich bei einem Profinet-Fehler die Ausgänge im aktuellen Zustand belassen?
Dafür müssen zwei Einstellungen in der GSDML, also dem Konfigurator vorgenommen werden. Als erstes muss im DAP “Activate PN reset value” auf AN gestellt sein. Bei dem entsprechenden EtherCAT-Gerät mit digitalen Ausgängen muss der Wert “Frozen” angewählt sein.
Die Einstellung “Frozen” gilt für alle Kanäle des EtherCAT-Geräts; eine kanalweise Einstellung ist nicht möglich.
Wie kann ich das Mapping eines EtherCAT-Geräts umstellen?
Per Default wird immer das Standard-Mapping angehängt. Wenn andere Mappings möglich sind, müssen Sie zuerst das Standard-Mapping auf Ihrem Konfigurator löschen und dann das neue Submodul einfügen.
Woher bekomme ich die GSDML-Datei?
Die GSDML Datei finden Sie auf unserer Homepage www.beckhoff.de.
Wo finde ich die MAC-Adresse von EP9300-0022?
Die MAC-Adresse ist auf der Box aufgedruckt.
Wozu dient der Diag-Port?
Über den Diag-Port können Firmware-Updates aufgespielt werden.
Ich habe ein EtherCAT-Gerät von einer Fremdfirma, kann ich das auch anschließen?
Nein, Geräte von anderen Herstellern können nur mit einem CX verwendet werden (siehe CX8093 oder ähnliche Produkte).
Ich möchte Antriebsklemmen/Antriebe an EP9300-0022 betreiben, ist das möglich?
Nein, verwenden Sie dafür einen CX mit entsprechender Performanz; z.B. CX9020 oder größer.
Ich möchte TwinSAFE-Klemmen an EP9300-0022 betreiben, ist das möglich?
Nein, TwinSAFE-Klemmen benötigen zum Konfigurieren ein TwinCAT-System, verwenden Sie hierfür den CX8093.
Wie stelle ich fest, dass EtherCAT einen Fehler hat?
Im DAP von EP9300-0022 gibt es ein Status-Wort. Hier wird ein Bit gesetzt, wenn ein EtherCAT-Fehler auftaucht. Weitere Informationen über den Fehler kann man durch Profinet-Alarme erhalten.


Fehlerbehandlung und Diagose

Fehlerbehandlung und Diagose
Fehlerbehandlung und Diagose
Weiterführende Informationen
•
Diagnose-LEDs


Diagnose-LEDs

Fehlerbehandlung und Diagose [image] Diagnose-LEDs
Diagnose-LEDs
Diagnose-LEDs
EtherCAT Link/Act
LED | Signal | Bedeutung
Link/Act | aus | Keine Verbindung zu den angeschlossenen EtherCAT-Geräten.
 | an | Link: Verbindung zu den angeschlossenen EtherCAT-Geräten.
 | blinkt | Act: Kommunikation mit den angeschlossenen EtherCAT-Geräten.
Profinet-Status
LED | Signal | Bedeutung
RUN | grün leuchtend | EP9300-0022 ist bereit.
 | rot leuchtend | Darf nur in der Hochlauf-Phase leuchten
PN | rot blinkend (200 ms) | Aufstart-Phase
 | grün blinkend (200 ms) | kein Profinet-Name
 | grün blinkend (1 s aus, 200 ms an) | keine IP-Adresse
 | Grün leuchtend | OK
DIAG | rot-grün blinkend (500 ms) | Profinet-Controller Identifikation: Der Profinet-Controller sendet ein Identifizierungssignal
 | rot blinkend (200 ms) | No AR established: Der Verbindungsaufbau mit dem Profinet-Controller ist nicht abgeschlossen
 | grün blinkend (1 s aus, 200 ms an) | Problem bei Verbindungsaufbau oder ist und soll Konfiguration unterschiedlich.
 | grün blinkend (200 ms) | Koppler ist im Datenaustausch, SPS ist aber im Stopp-Zustand
 | grün leuchtend | OK
Profinet Link/Act
LED | Signal | Bedeutung
L/A | Aus | Keine Verbindung zu dem angeschlossenen Profinet-Gerät
 | grün leuchtend | Link: Verbindung zu dem angeschlossenen Profinet-Gerät
 | grün blinkend | Activity: Kommunikation mit dem angeschlossenen Profinet-Gerät
Versorgungsspannungs-Status
LED | Signal | Bedeutung
Us 24 V | aus | Die Versorgungsspannung Us ist nicht vorhanden
 | grün leuchtend | Die Versorgungsspannung Us ist vorhanden
Up 24 V | aus | Die Versorgungsspannung Up ist nicht vorhanden
 | grün leuchtend | Die Versorgungsspannung Up ist vorhanden


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Allgemeine Betriebsbedingungen
•
EtherCAT Box- / EtherCAT-P-Box - Zubehör
•
Versionsidentifikation von EtherCAT-Geräten
•
Support und Service


Allgemeine Betriebsbedingungen

Anhang [image] Allgemeine Betriebsbedingungen
Allgemeine Betriebsbedingungen
Schutzarten nach IP-Code
In der Norm IEC 60529 (DIN EN 60529) sind die Schutzgrade festgelegt und nach verschiedenen Klassen eingeteilt. Die Bezeichnung erfolgt in nachstehender Weise.
1. Ziffer: Staub- und Berührungsschutz | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen den Zugang zu gefährlichen Teilen mit dem Handrücken. Geschützt gegen feste Fremdkörper Ø 50 mm
2 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Finger. Geschützt gegen feste Fremdkörper Ø 12,5 mm
3 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Werkzeug. Geschützt gegen feste Fremdkörper Ø 2,5 mm
4 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Geschützt gegen feste Fremdkörper Ø 1 mm
5 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubgeschützt. Eindringen von Staub ist nicht vollständig verhindert, aber der Staub darf nicht in einer solchen Menge eindringen, dass das zufriedenstellende Arbeiten des Gerätes oder die Sicherheit beeinträchtigt wird
6 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubdicht. Kein Eindringen von Staub
2. Ziffer: Wasserschutz* | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen Tropfwasser
2 | Geschützt gegen Tropfwasser, wenn das Gehäuse bis zu 15° geneigt ist
3 | Geschützt gegen Sprühwasser. Wasser, das in einem Winkel bis zu 60° beiderseits der Senkrechten gesprüht wird, darf keine schädliche Wirkung haben
4 | Geschützt gegen Spritzwasser. Wasser, das aus jeder Richtung gegen das Gehäuse spritzt, darf keine schädlichen Wirkungen haben
5 | Geschützt gegen Strahlwasser.
6 | Geschützt gegen starkes Strahlwasser.
7 | Geschützt gegen die Wirkungen beim zeitweiligen Untertauchen in Wasser. Wasser darf nicht in einer Menge eintreten, die schädliche Wirkungen verursacht, wenn das Gehäuse für 30 Minuten in 1 m Tiefe in Wasser untergetaucht ist
*) In diesen Schutzklassen wird nur der Schutz gegen Wasser definiert.
Chemische Beständigkeit
Die Beständigkeit bezieht sich auf das Gehäuse der IP-67-Module und die verwendeten Metallteile. In der nachfolgenden Tabelle finden Sie einige typische Beständigkeiten.
Art | Beständigkeit
Wasserdampf | bei Temperaturen >100°C nicht beständig
Natriumlauge (ph-Wert > 12) | bei Raumtemperatur beständig > 40°C unbeständig
Essigsäure | unbeständig
Argon (technisch rein) | beständig
Legende
▪
beständig: Lebensdauer mehrere Monate
▪
bedingt beständig: Lebensdauer mehrere Wochen
▪
unbeständig: Lebensdauer mehrere Stunden bzw. baldige Zersetzung


EtherCAT Box- / EtherCAT-P-Box - Zubehör

Anhang [image] EtherCAT Box- / EtherCAT-P-Box - Zubehör
EtherCAT Box- / EtherCAT-P-Box - Zubehör
Befestigung
Bestellangaben | Beschreibung
ZS5300-0001 | Montageschiene (500 mm x 129 mm)
Beschriftungsmaterial, Stopfen
Bestellangaben | Beschreibung
ZS5000-0000 | Feldbus-Box-Set M8 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0002 | Feldbus-Box-Set M12 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0010 | Stopfen M8, IP67 (50 Stück)
ZS5000-0020 | Stopfen M12, IP67 (50 Stück)
ZS5100-0000 | Beschriftungsschilder nicht bedruckt, 4 Streifen à 10 Stück
ZS5100-xxxx | Beschriftungsschilder bedruckt, auf Anfrage
Werkzeug
Bestellangaben | Beschreibung
ZB8800 | Drehmoment-Schraubwerkzeug für M8-Leitungen für Stecker mit Rändel, inklusive Ratsche
ZB8800-0001 | Aufsatz M12 für Drehmoment-Schraubwerkzeug ZB8800
ZB8800-0002 | Aufsatz M8 (feldkonfektionierbar) für Drehmoment-Schraubwerkzeug ZB8800
ZB8801-0000 | Drehmoment-Schraubwerkzeug für Stecker mit Sechskant, einstellbar
ZB8801-0001 | Wechselklinge für M8/SW9 für Drehmoment-Schraubwerkzeug ZB8801-0000
ZB8801-0002 | Wechselklinge für M12/SW13 für Drehmoment-Schraubwerkzeug ZB8801-0000
ZB8801-0003 | Wechselklinge für M12 feldkonfektionierbar/SW18 für Drehmoment-Schraubwerkzeug ZB8801-0000
Weiteres Zubehör
Weiteres Zubehör finden Sie in der Preisliste für Feldbuskomponenten von Beckhoff und im Internet unter https://www.beckhoff.de


Versionsidentifikation von EtherCAT-Geräten

Anhang [image] Versionsidentifikation von EtherCAT-Geräten
Versionsidentifikation von EtherCAT-Geräten
Bezeichnung
Ein Beckhoff EtherCAT-Gerät hat eine 14stellige technische Bezeichnung, die sich zusammensetzt aus
▪
Familienschlüssel
▪
Typ
▪
Version
▪
Revision
Beispiel | Familie | Typ | Version | Revision
EL3314-0000-0016 | EL-Klemme (12 mm, nicht steckbare Anschlussebene) | 3314 (4 kanalige Thermoelementklemme) | 0000 (Grundtyp) | 0016
ES3602-0010-0017 | ES-Klemme (12 mm, steckbare Anschlussebene) | 3602 (2 kanalige Spannungsmessung) | 0010 (Hochpräzise Version) | 0017
CU2008-0000-0000 | CU-Gerät | 2008 (8 Port FastEthernet Switch) | 0000 (Grundtyp) | 0000
Hinweise
▪
die oben genannten Elemente ergeben die technische Bezeichnung, im Folgenden wird das Beispiel EL3314-0000-0016 verwendet.
▪
Davon ist EL3314-0000 die Bestellbezeichnung, umgangssprachlich bei „-0000“ dann oft nur EL3314 genannt. „-0016“ ist die EtherCAT-Revision.
▪
Die Bestellbezeichnung setzt sich zusammen aus
- Familienschlüssel (EL, EP, CU, ES, KL, CX, ...)
- Typ (3314)
- Version (-0000)
▪
Die Revision -0016 gibt den technischen Fortschritt wie z. B. Feature-Erweiterung in Bezug auf die EtherCAT Kommunikation wieder und wird von Beckhoff verwaltet.
Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders z. B. in der Dokumentation angegeben.
Jeder Revision zugehörig und gleichbedeutend ist üblicherweise eine Beschreibung (ESI, EtherCAT Slave Information) in Form einer XML-Datei, die zum Download auf der Beckhoff Webseite bereitsteht.
Die Revision wird seit 2014/01 außen auf den IP20-Klemmen aufgebracht, siehe Abb. „EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)“.
▪
Typ, Version und Revision werden als dezimale Zahlen gelesen, auch wenn sie technisch hexadezimal gespeichert werden.
Identifizierungsnummer
Beckhoff EtherCAT Geräte der verschiedenen Linien verfügen über verschiedene Arten von Identifizierungsnummern:
Produktionslos/Chargennummer/Batch-Nummer/Seriennummer/Date Code/D-Nummer
Als Seriennummer bezeichnet Beckhoff im IO-Bereich im Allgemeinen die 8-stellige Nummer, die auf dem Gerät aufgedruckt oder auf einem Aufkleber angebracht ist. Diese Seriennummer gibt den Bauzustand im Auslieferungszustand an und kennzeichnet somit eine ganze Produktions-Charge, unterscheidet aber nicht die Module einer Charge.
Aufbau der Seriennummer: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit
Ser. Nr.: 12063A02: 12 - Produktionswoche 12 06 - Produktionsjahr 2006 3A - Firmware-Stand 3A 02 - Hardware-Stand 02
Ausnahmen können im IP67-Bereich auftreten, dort kann folgende Syntax verwendet werden (siehe jeweilige Gerätedokumentation):
Syntax: D ww yy x y z u
D - Vorsatzbezeichnung
ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine
Beispiel: D.22081501 Kalenderwoche 22 des Jahres 2008 Firmware-Stand Busplatine: 1 Hardware Stand Busplatine: 5 Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig) Hardware-Stand E/A-Platine: 1
Eindeutige Seriennummer/ID, ID-Nummer
Darüber hinaus verfügt in einigen Serien jedes einzelne Modul über eine eindeutige Seriennummer.
Siehe dazu auch weiterführende Dokumentation im Bereich
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Klemmen mit Werkskalibrierzertifikat und andere Messtechnische Klemmen
Beispiele für Kennzeichnungen
EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer und Revisionskennzeichnung (seit 2014/01)
EK1100 EtherCAT Koppler, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer
CU2016 Switch mit Seriennummer/ Chargennummer
EL3202-0020 mit Seriennummer/ Chargennummer 26131006 und eindeutiger ID-Nummer 204418
EP1258-00001 IP67 EtherCAT Box mit Chargennummer/ DateCode 22090101 und eindeutiger Seriennummer 158102
EP1908-0002 IP67 EtherCAT Safety Box mit Chargennummer/ DateCode 071201FF und eindeutiger Seriennummer 00346070
EL2904 IP20 Safety Klemme mit Chargennummer/ DateCode 50110302 und eindeutiger Seriennummer 00331701
ELM3604-0002 Klemme mit eindeutiger ID-Nummer (QR Code) 100001051 und Seriennummer/ Chargennummer 44160201
Weiterführende Informationen
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Anhang [image] Versionsidentifikation von EtherCAT-Geräten [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
Der Beckhoff Identification Code (BIC) wird vermehrt auf Beckhoff-Produkten zur eindeutigen Identitätsbestimmung des Produkts aufgebracht. Der BIC ist als Data Matrix Code (DMC, Code-Schema ECC200) dargestellt, der Inhalt orientiert sich am ANSI-Standard MH10.8.2-2016.
Beckhoff Identification Code
BIC als Data Matrix Code (DMC, Code-Schema ECC200)
Die Einführung des BIC erfolgt schrittweise über alle Produktgruppen hinweg.
Er ist je nach Produkt an folgenden Stellen zu finden:
▪
auf der Verpackungseinheit
▪
direkt auf dem Produkt (bei ausreichendem Platz)
▪
auf Verpackungseinheit und Produkt
Der BIC ist maschinenlesbar und enthält Informationen, die auch kundenseitig für Handling und Produktverwaltung genutzt werden können.
Jede Information ist anhand des so genannten Datenidentifikators (ANSI MH10.8.2-2016) eindeutig identifizierbar. Dem Datenidentifikator folgt eine Zeichenkette. Beide zusammen haben eine maximale Länge gemäß nachstehender Tabelle. Sind die Informationen kürzer, werden sie um Leerzeichen ergänzt. Die Daten unter den Positionen 1 bis 4 sind immer vorhanden.
Folgende Informationen sind enthalten:
Pos-Nr. | Art der Information | Erklärung | Datenidentifikator | Anzahl Stellen inkl. Datenidentifikator | Beispiel
1 | Beckhoff-Artikelnummer | Beckhoff - Artikelnummer | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Eindeutige Seriennummer, Hinweis s. u. | S | 12 | SBTNk4p562d7
3 | Artikelbezeichnung | Beckhoff Artikelbezeichnung, z. B. EL1008 | 1K | 32 | 1KEL1809
4 | Menge | Menge in Verpackungseinheit, z. B. 1, 10… | Q | 6 | Q1
5 | Chargennummer | Optional: Produktionsjahr und -woche | 2P | 14 | 2P401503180016
6 | ID-/Seriennummer | Optional: vorheriges Seriennummer-System, z. B. bei Safety-Produkten oder kalibrierten Klemmen | 51S | 12 | 51S678294104
7 | Variante | Optional: Produktvarianten-Nummer auf Basis von Standardprodukten | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Weitere Informationsarten und Datenidentifikatoren werden von Beckhoff verwendet und dienen internen Prozessen.
Aufbau des BIC
Beispiel einer zusammengesetzten Information aus den Positionen 1 bis 4 und 6.
Die Datenidentifikatoren sind zur besseren Darstellung jeweils rot markiert:
BTN
Ein wichtiger Bestandteil des BICs ist die Beckhoff Traceability Number (BTN, Pos.-Nr. 2). Die BTN ist eine eindeutige, aus acht Zeichen bestehende Seriennummer, die langfristig alle anderen Seriennummern-Systeme bei Beckhoff ersetzen wird (z. B. Chargenbezeichungen auf IO-Komponenten, bisheriger Seriennummernkreis für Safety-Produkte, etc.). Die BTN wird ebenfalls schrittweise eingeführt, somit kann es vorkommen, dass die BTN noch nicht im BIC codiert ist.
Hinweis
Diese Information wurde sorgfältig erstellt. Das beschriebene Verfahren wird jedoch ständig weiterentwickelt. Wir behalten uns das Recht vor, Verfahren und Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern. Aus den Angaben, Abbildungen und Beschreibungen in dieser Information können keine Ansprüche auf Änderung geltend gemacht werden.


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.