EP92x4-0023 - Power distribution for EtherCAT Box Modules
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
2.5
▪
Front page updated
▪
Scope of supply added
▪
Technical data updated
▪
Structure update
2.4
▪
Safety instructions adapted to IEC 82079-1.
▪
EP9224-0023: Specification of the measured values added.
▪
Structure update
2.3.1
▪
Nut torque for connectors updated
▪
Chapter Switch off behavior updated
2.3.0
▪
Cabling added
2.2.0
▪
Operation with or without EtherCAT master updated
2.1.0
▪
Power Connection updated
2.0.0
▪
Migration
▪
Chapter mounting and cabling aktualisiert
▪
Chapter Nut torque for connectors extended
▪
Chapter Switch off behavior updated
▪
Object descriptions updated
1.1.0
▪
EP9224-0023 added
1.0.0
▪
First release
0.1
▪
Preliminary version (only German available)
Firmware and hardware versions
This documentation refers to the firmware and hardware version that was applicable at the time the documentation was written.
The module features are continuously improved and developed further. Modules having earlier production statuses cannot have the same properties as modules with the latest status. However, existing properties are retained and are not changed, so that older modules can always be replaced with new ones.
Documentation | EP9214-0023 |  | EP9224-0023
 | Firmware | Hardware | Firmware | Hardware
2.5 | 12 | 14 | 05 | 14
2.4 | 12 | 14 | 05 | 14
2.3.1 | 12 | 14 | 05 | 13
2.3.0 | 10 | 11 | 04 | 11
2.2.0 | 10 | 11 | 04 | 11
2.1.0 | 09 | 11 | 04 | 10
2.0.0 | 09 | 10 | 04 | 10
1.1.0 | 09 | 06 | 04 | 06
1.0.0 | 07 | 03 | - | -
0.1 | 07 | 03 | - | -
The firmware and hardware version (delivery state) can be found in the batch number (D-number) printed on the side of the EtherCAT Box.
Syntax of the batch number (D-number)
D: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with D no. 29 10 02 01:
29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01
Further information on this topic: Version identification of EtherCAT devices.


Product overview

Product overview
Product overview
Additional information
•
EtherCAT Box - Introduction
•
EP9214 - Introduction
•
EP9224 - Introduction
•
Technical data
•
Scope of supply


EtherCAT Box - Introduction

Product overview [image] EtherCAT Box - Introduction
EtherCAT Box - Introduction
The EtherCAT system has been extended with EtherCAT Box modules with protection class IP 67. Through the integrated EtherCAT interface the modules can be connected directly to an EtherCAT network without an additional Coupler Box. The high-performance of EtherCAT is thus maintained into each module.
The extremely low dimensions of only 126 x 30 x 26.5 mm (h x w x d) are identical to those of the Fieldbus Box extension modules. They are thus particularly suitable for use where space is at a premium. The small mass of the EtherCAT modules facilitates applications with mobile I/O interface (e.g. on a robot arm). The EtherCAT connection is established via screened M8 connectors.
EtherCAT Box Modules within an EtherCAT network
The robust design of the EtherCAT Box modules enables them to be used directly at the machine. Control cabinets and terminal boxes are now no longer required. The modules are fully sealed and therefore ideally prepared for wet, dirty or dusty conditions.
Pre-assembled cables significantly simplify EtherCAT and signal wiring. Very few wiring errors are made, so that commissioning is optimized. In addition to pre-assembled EtherCAT, power and sensor cables, field-configurable connectors and cables are available for maximum flexibility. Depending on the application, the sensors and actuators are connected through M8 or M12 connectors.
The EtherCAT modules cover the typical range of requirements for I/O signals with protection class IP67:
▪
digital inputs with different filters (3.0 ms or 10 μs)
▪
digital outputs with 0.5 or 2 A output current
▪
analog inputs and outputs with 16 bit resolution
▪
Thermocouple and RTD inputs
▪
Stepper motor modules
XFC (eXtreme Fast Control Technology) modules, including inputs with time stamp, are also available.
EtherCAT Box with M8 connections for sensors/actuators
EtherCAT Box with M12 connections for sensors/actuators
Basic EtherCAT documentation
You will find a detailed description of the EtherCAT system in the Basic System Documentation for EtherCAT, which is available for download from our website (www.beckhoff.com) under Downloads.
EtherCAT XML Device Description
You will find XML files (XML Device Description Files) for Beckhoff EtherCAT modules on our website (www.beckhoff.com) under Downloads, in the Configuration Files area.


EP9214 - Introduction

Product overview [image] EP9214 - Introduction
EP9214 - Introduction
EP9214
Power distribution for EtherCAT Box (24 VDC)
The EP9214-0023 enables connection of four power supply branches. In each branch the current consumption for the control voltage US and the peripheral voltage UP is monitored, limited, and, if necessary, switched off.
The power distribution is supplied via a 7/8" connector with up to 16 A (per voltage supply US/UP). Several modules can be configured in a cascade arrangement. In the event of a short-circuit in one of the four outputs, the affected output is switched off. The supply for the other branches remains active. The switch-off and control is done in such a way that the input voltage does not fall below 21 V or other modules are going down, caused by undervoltage. During startup consumers with large capacities can be added without problem.
The master can read diagnostic messages from the individual channels via the EtherCAT interface. Independent switching of individual consumer branches is also possible via the EtherCAT master.
In delivery state the eight outputs of the box (4 times Us, 4 times Up) are activated to enable operation without EtherCAT.
After an error caused the switch off of a channel, this channel remains switched of when you try to switch it on again and has to be set back actively by the EtherCAT master or a hardware reset at the box (lower M8 socket).
Quick links


EP9224 - Introduction

Product overview [image] EP9224 - Introduction
EP9224 - Introduction
EP9224
Power distribution for EtherCAT Box (24 VDC) with data logging
The EP9224-0023 enables connection of four power supply branches. In each branch the current consumption for the control voltage US and the peripheral voltage UP is monitored, limited, and, if necessary, switched off.
The input voltage and current values of all outputs can be evaluated via the process data. A continuous data log of the relevant data can be retrieved when an error occurs in order to localise the cause of the error.
The power distribution is supplied via a 7/8" connector with up to 16 A (per voltage supply US/UP). Several modules can be configured in a cascade arrangement. In the event of a short-circuit in one of the four outputs, the affected output is switched off. The supply for the other branches remains active. The switch-off and control is done in such a way that the input voltage does not fall below 21 V or other modules are going down, caused by undervoltage. During startup consumers with large capacities can be added without problem.
The master can read diagnostic messages from the individual channels via the EtherCAT interface. Independent switching of individual consumer branches is also possible via the EtherCAT master.
In delivery state the eight outputs of the box (4 times US, 4 times UP) are activated to enable operation without EtherCAT.
Nach einem Fehler und darauffolgendem Abschalten eines Kanals, bleibt der Kanal nach dem Aus- und Wiedereinschalten der EP9224 abgeschaltet und muss aktiv durch den EtherCAT-Master oder einen Hardware-Reset an der Box (unterer M8-Steckverbinder) zurückgesetzt werden.
Die Box verfügt über einen internes Log-File, welches die Systemwerte kontinuierlich in einen Ringpuffer schreibt. Dieses Data Logging muss beim Start aktiviert werden.
Im Fehlerfall wird es gestoppt, sodass eine Historie der Systemparameter vor dem Fehlerfall ausgelesen werden kann. Dies ermöglicht eine viel schnellere Fehlereingrenzung.
Quick links


Technical data

Product overview [image] Technical data
Technical data
All values are typical values over the entire temperature range, unless stated otherwise.
Technical data
EP9214-0023
EP9224-0023
Fieldbus
Fieldbus
EtherCAT
Connection
2 x M8 socket, green
Electrical isolation
500 V (fieldbus / IO)
Supply voltages
Connection
Input: 7/8" plug, 5-pin, max. 16 A per contact
Downstream connection: 7/8" socket, 5-pin, max. 16 A per contact
Control voltage US
Nominal voltage
24 VDC (-15 % / +20 %)
Sum current 1)
max. 16 A at 40 °C
Consumers
▪
Module electronics: 110 mA
▪
Loads on the outputs
Peripheral voltage UP
Nominal voltage
24 VDC (-15 % / +20 %)
Consumers
▪
Module electronics: 40 mA
▪
Loads on the outputs
Outputs
Number
4
Connection
4 x M8 socket, black
Output current per M8 socket
max. 4 A per US and UP
Parallel switching of outputs
not permissible
Voltage drop UON
90 mV per ampere
Switch-on delay 2)
parameterizable: 10 ms, 100 ms, 200 ms
Protective functions and diagnostics
Overcurrent tripping characteristic
Individually adjustable for each output.
Temperature switch-off
85 °C internal temperature
Internal fuse
(fail-safe Element)
7 A (FF)
Data logging
-
40 entries
Sampling time: 1...1000 ms
Reset contact and signaling contact
Connection
M8 plug X3: 3-pin, black
M8 socket X4: 3-pin, black
Reset contact
Digital input, 24 VDC
Signaling contact
Potential-free NO contact
Measured values
Representation
-
Measured current values:
▪
Output currents per channel: 1 mA / LSB
▪
Sum currents: 10 mA / LSB
Measured voltage values: 100 mV / LSB
Resolution
-
Measured current values: 10 mA
Measured voltage values: 100 mV
Accuracy
-
5 % of full scale value
1) Sum current of consumers and power transmission. This value corresponds to the current
carrying capacity of the 7/8" connectors.
2) The output voltages are switched on one after the other at the start so that the starting
currents do not add up.
Technical data | EP9214-0023 | EP9224-0023
Environmental conditions
Ambient temperature during operation | -25 .. +60 °C
Ambient temperature during storage | -40 .. +85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Mechanics
Dimensions | 126 x 60 x 26.5 mm without connector
Weight | approx. 450 g
Installation position | variable
Approvals and conformity
Approvals | CE, cURus in preparation


Scope of supply

Product overview [image] Scope of supply
Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EtherCAT Box EP92x4-0023
▪
2x protective cap for EtherCAT socket, M8, green (pre-assembled)
▪
1x protective cap for supply voltage input, M8, transparent (pre-assembled)
▪
4x protective cap for supply voltage output, M8, black (pre-assembled)
▪
1x Protective cap for supply voltage output, 7/8”, black (pre-fitted)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


Mounting and cabling

Mounting and cabling
Mounting and cabling
Additional information
•
Mounting
•
EtherCAT
•
Power supply
•
Status LEDs and status bits
•
Monitoring and reset contacts


Mounting

Mounting and cabling [image] Mounting
Mounting
Additional information
•
Dimensions
•
Fixing
•
Tightening torques for plug connectors


Dimensions

Mounting and cabling [image] Mounting [image] Dimensions
Dimensions
Dimensions
All dimensions are given in millimeters.
Housing features
Housing material | PA6 (polyamide)
Sealing compound | polyurethane
Mounting | two fastening holes Ø 4.5 mm for M4
Metal parts | brass, nickel-plated
Contacts | CuZn, gold-plated
Power feed through | max. 16 A at 40 °C (7/8” connectors)
Mounting position | variable
Protection class | IP65, IP66, IP67 (conforms to EN 60529) when screwed together
Dimensions (H x W x D) | approx. 126 x 60 x 26.5 mm (without connectors)


Fixing

Mounting and cabling [image] Mounting [image] Fixing
Fixing
Note
Dirt during assembly
Dirty connectors can lead to malfunctions. Protection class IP67 can only be guaranteed if all cables and connectors are connected.
•
Protect the plug connectors against dirt during the assembly.
Mount the module with two M4 screws in the centrally located fastening holes.
Cooling plate
The EP9214 module has a cooling plate on the underside. For the effective dissipation of the resultant power loss, the box must be bolted to a metal base, e.g. the machine bed, if possible making contact over the entire surface. A temperature-related automatic switch-off of the box can occur if care is not taken to ensure that the power loss from the module is dissipated via the cooling plate. A corresponding temperature error bit is then set!


Tightening torques for plug connectors

Mounting and cabling [image] Mounting [image] Tightening torques for plug connectors
Tightening torques for plug connectors
Screw connectors tight with a torque wrench. (e.g. ZB8801 from Beckhoff)
Connector diameter | Tightening torque
M8 | 0.4 Nm
7/8” | 1.5 Nm


EtherCAT

Mounting and cabling [image] EtherCAT
EtherCAT
Additional information
•
Connectors
•
Status LEDs
•
Cables


Connectors

Mounting and cabling [image] EtherCAT [image] Connectors
Connectors
Note
Risk of confusion: supply voltages and EtherCAT
Defect possible through incorrect insertion.
•
Observe the color coding of the connectors:
black: Supply voltages
green: EtherCAT
EtherCAT Box Modules have two green M8 sockets for the incoming and downstream EtherCAT connections.
EtherCAT connectors
Connection
M8 socket, 4-pin – connection
M8 socket
EtherCAT | M8 connector | Core colors
Signal | Contact | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 and old versions of ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | 1 | yellow1) | orange/white | white/orange
Tx - | 4 | orange1) | orange | orange
Rx + | 2 | white1) | blue/white | white/green
Rx - | 3 | blue1) | blue | green
Shield | Housing | Shield | Shield | Shield
1) Core colors according to EN 61918
Adaptation of core colors for cables ZB9030, ZB9032 and ZK1090-3xxxx-xxxx
For standardization, the core colors of the ZB9030, ZB9032 and ZK1090-3xxx-xxxx cables have been changed to the EN61918 core colors: yellow, orange, white, blue. So there are different color codes in circulation. The electrical properties of the cables have been retained when the core colors were changed.


Status LEDs

Mounting and cabling [image] EtherCAT [image] Status LEDs
Status LEDs
EtherCAT Status LEDs
L/A (Link/Act)
A green LED labelled "L/A" is located next to each EtherCAT socket. The LED indicates the communication state of the respective socket:
LED | Meaning
off | no connection to the connected EtherCAT device
lit | LINK: connection to the connected EtherCAT device
flashes | ACT: communication with the connected EtherCAT device
Run
Each EtherCAT slave has a green LED labelled "Run". The LED signals the status of the slave in the EtherCAT network:
LED | Meaning
off | Slave is in "Init" state
flashes uniformly | Slave is in "Pre-Operational“ state
flashes sporadically | Slave is in "Safe-Operational" state
lit | Slave is in "Operational" state
Description of the EtherCAT slave states


Cables

Mounting and cabling [image] EtherCAT [image] Cables
Cables
For connecting EtherCAT devices only shielded Ethernet cables that meet the requirements of at least category 5 (CAT5) according to EN 50173 or ISO/IEC 11801 should be used.
EtherCAT uses four wires for signal transmission.
Thanks to automatic line detection ("Auto MDI-X"), both symmetrical (1:1) or cross-over cables can be used between Beckhoff EtherCAT.
Detailed recommendations for the cabling of EtherCAT devices


Power supply

Mounting and cabling [image] Power supply
Power supply
Additional information
•
EP9214-0023 – Power connection
•
EP9214-0023 – Power LEDs
•
Power cable conductor losses M8
•
Power cable 7/8"
•
Conductor losses 7/8"
•
Power outputs


EP9214-0023 – Power connection

Mounting and cabling [image] Power supply [image] EP9214-0023 – Power connection
EP9214-0023 – Power connection
Note
Use cables with suitable cross-sections!
Ensure that the cross-sections of the cables employed are suitable for the load circuit inputs and outputs and the respective nominal current being used!
The supply voltages are fed and relayed onward via two 7/8" connectors in the center of the modules:
▪
Power In: left-hand 7/8" plug for the feed-in of supply voltages
▪
Power Out: right-hand 7/8" socket for the onward feeding of supply voltages
EP9214-0023 - 7/8" connectors
The contacts of the 7/8" connectors can conduct a maximum current of 16 A (40 °C).
Two LEDs next to the device identifier label indicate the status of the supply voltages.
Connection
Connection of the 7/8" connectors
Contact | Voltage
1 | GND Up
2 | GND Us
3 | FE (functional earth), (including upper and lower wire bracket of the central screw connection)
4 | Control voltage Us, +24 VDC
5 | Peripheral voltage Up, +24 VDC
Note
Do not confuse the power output with the EtherCAT connection!
Never connect the power cables (M8, 24 VDC) to the green-marked EtherCAT sockets of the EtherCAT Box Modules. This can cause the destruction of the modules!
Control voltage Us: 24 VDC
The fieldbus and the processor logic are supplied from the 24 VDC control voltage Us. The control voltage is electrically isolated from the fieldbus circuitry.
Peripheral voltage Up: 24 VDC
The peripheral voltage Up is monitored and fed to the power outputs, but is not used in the EP9214.
Redirection of the supply voltages
The power connections Power In and Power Out are bridged in the module. Hence, the supply voltages Us and Up can be passed from EtherCAT Box to EtherCAT Box in a simple manner.
Note
Observe the maximum current of the 7/8" plug connectors!
Also ensure when relaying the supply voltages Us and Up onward that the maximum permissible current of 16 A / 40 °C for each 7/8" plug connector is not exceeded!


EP9214-0023 – Power LEDs

Mounting and cabling [image] Power supply [image] EP9214-0023 – Power LEDs
EP9214-0023 – Power LEDs
Status LEDs for the power supply
EP9214-0023 – Power LEDs
LED | Display | Meaning
Us (control voltage) | off | The supply voltage, Us, is not present
 | green illuminated | The supply voltage, Us, is present
Up (peripheral voltage) | off | The supply voltage, Up, is not present
 | green illuminated | The supply voltage, Up, is present


Power cable conductor losses M8

Mounting and cabling [image] Power supply [image] Power cable conductor losses M8
Power cable conductor losses M8
The ZK2020-xxxx-yyyy power cables should not exceed the total length of 15 m at 4 A (with continuation). When planning the cabling, note that at 24 V nominal voltage, the functionality of the module can no longer be assured if the voltage drop reaches 6 V. Variations in the output voltage from the power supply unit must also be taken into account.
Power cable conductor losses
Example
8 m power cable with 0.34 mm² cross-section has a voltage drop of 3.2 V at 4 A.
EP92x4 Power Distribution Modules
With EP9214 and EP9224 Power Distribution Modules intelligent concepts for voltage supply are available. Further information may be found under www.beckhoff.com/EP9224.


Power cable 7/8"

Mounting and cabling [image] Power supply [image] Power cable 7/8"
Power cable 7/8"
Power cable 7/8"
Technical data
Technical data
Rated voltage according to IEC 61076 2-101 | 300 V (according to IEC 61076-2-101)
Pollution degree according to IEC 60664-1 | 3/2 (according to IEC 60664-1)
Insulation resistance IEC 60512-2 | >109W
Current carrying capacity according to IEC 60512-3 | 16 A at 40 °C (according to IEC 60512-3)
Volume resistance according to IEC 60512-2 | < 5 mW
Protection class conforms to IEC 60529 | IP65, IP66, IP67 (in screwed state)
Permissible ambient temperature | -30 °C to +80 °C
Material properties | TPE-U (PUR) halogen-free according to DIN VDE 0472 Part 815, flame-retardant according to cULus 20549
Approbations | UL
Cable outside diameter | 7.80 ± 0.20 mm
Bending radius | min. 6 x D (external diameter)
Parameter | Max. speed 5 m/s, max. acceleration 10 m/s²
Number of cycles | At least 10 million cycles with a max. travel path of 20 meters
Ordering data
Order designation | Power cable | Screw connector | Contacts | Cross-section | Length
ZK2030-1200-0010 | Straight socket, open end | 7/8" | 5-pole | 1.50 mm2 | 1.00 m
ZK2030-1200-0030 |  |  |  |  | 3.00 m
ZK2030-1200-0050 |  |  |  |  | 5.00 m
ZK2030-1200-0100 |  |  |  |  | 10.00 m
ZK2030-1400-0010 | Angled socket, open end |  |  |  | 1.00 m
ZK2030-1400-0030 |  |  |  |  | 3.00 m
ZK2030-1400-0050 |  |  |  |  | 5.00 m
ZK2030-1400-0100 |  |  |  |  | 10.00 m
ZK2030-1112-0010 | Straight socket, straight connector |  |  |  | 1.00 m
ZK2030-1112-0030 |  |  |  |  | 3.00 m
ZK2030-1112-0050 |  |  |  |  | 5.00 m
ZK2030-1112-0100 |  |  |  |  | 10.00 m
ZK2030-1314-0010 | Angled socket, angled connector |  |  |  | 1.00 m
ZK2030-1314-0030 |  |  |  |  | 3.00 m
ZK2030-1314-0050 |  |  |  |  | 5.00 m
ZK2030-1314-0100 |  |  |  |  | 10.00 m
Further available power cables and the associated data sheets can be found in the Beckhoff catalogue or on our website (http://www.beckhoff.de).


Conductor losses 7/8"

Mounting and cabling [image] Power supply [image] Conductor losses 7/8"
Conductor losses 7/8"
In the case of the power cables ZK2030-xxxx-yyy, a total length of 15 m should not be exceeded at 16 A. When wiring, note that with a rated voltage of 24 V the function of the modules can no longer be guaranteed from a voltage drop of 6 V. Variations in the output voltage from the power supply unit must also be taken into account.
ZK2030-xxxx-yyy - Conductor losses
Alternatively, larger cable cross-section can be used, e.g. 2.5 mm2.


Power outputs

Mounting and cabling [image] Power supply [image] Power outputs
Power outputs
The supply voltages are output via four 4-pole M8 sockets in the lower third of the modules (1, 2, 3 and 4).
M8 sockets
Connection
Connection of the M8 sockets
Contact | Voltage
1 | Control voltage Us, +24 VDC
2 | Peripheral voltage Up, +24 VDC
3 | GNDs* | *) may be internally connected to one another depending on the connected module: see individual module descriptions
4 | GNDp*
The contacts of the M8 connectors can conduct a maximum current of 4 A.
A LED indicates the status of the power outputs.
Note
Do not confuse the power outputs with the EtherCAT connection
Never connect the power cables (M8, 24 VDC) to the green-marked EtherCAT sockets of the EtherCAT Box Modules. This can cause the destruction of the modules!
Control voltage Us: 24 VDC
Power is supplied to the fieldbus, the processor logic, the inputs and the sensors from the control voltage Us (24 VDC). The control voltage is electrically isolated from the fieldbus circuitry.
Peripheral voltage Up: 24 VDC
The peripheral voltage Up (24 VDC) supplies the digital outputs; it can be supplied separately. Hence, if the load voltage is switched off, the fieldbus function as well as the supply and function of the inputs are retained.
Electrical isolation
The grounds of the control voltage (GNDs) and peripheral voltage (GNDp) are electrically isolated from each other in order to ensure the electrical isolation of the peripheral devices on Up from the control voltage.
Note
The electrical isolation can be nullified
If you connect digital and analog Fieldbus Box modules directly to one another via four-pole power lines, then there may no longer be any electrical isolation due to the connected boxes!


Status LEDs and status bits

Mounting and cabling [image] Status LEDs and status bits
Status LEDs and status bits
Below is a table showing the meaning of the Status LEDs and Status bits for the power outputs (taking the EP9214 as an example):
EP9214 - Status LEDs
EP9214 - Status bits
Initialization
When switching on the voltage supply to the EP9214 / EP9224, all green LEDs and then all red LEDs are switched on briefly to test the LEDs.
The LED applies to both voltages/currents (Us and Up; OR).
LED | Status Us / Up | Warning | Error Us / Up | Description
Off | 0 | 0 | 0 | The output is ready
Green | 1 | 0 | 0 | The output is just switching on
Green | 1 | 0 | 0 | The output is switched on. Normal operating state.
Flashing green | 1 | 1 | 0 | The output is still operating, but will switch off if conditions remain unchanged (Warning Ux).
Flashing red | 0 | 1 | 1 | The output has been switched off (Error Ux). Switching on again is not yet possible (waiting time of 20 seconds)
Red | 0 | 0 | 1 | The output has been disabled and can be returned to a normal state by a reset.


Monitoring and reset contacts

Mounting and cabling [image] Monitoring and reset contacts
Monitoring and reset contacts
The EP9214 has a monitoring contact (signaling contact) and a reset contact. These contacts are fed out via an M8 plug and an M8 socket.
The contacts of this M8 plug and M8 socket are wired together 1:1.
EP9214 - Monitoring and reset connections
Connection
EP9214 - Monitoring and reset contacts
Contact | Meaning
Pins 1 and 3: Monitoring | Potential-free signaling contact (NO contact), closes on application of the supply voltage and if an error occurs in one of the eight load circuits
Pin 4: Reset | all errors are reset by applying 24 VDC to the Reset contact.
The contacts of the M8 connectors can conduct a maximum current of 4 A.


Commissioning and configuration

Commissioning and configuration
Commissioning and configuration
Additional information
•
Integration in TwinCAT
•
Operation with or without EtherCAT master
•
Switch-off behavior
•
EP9214-0023
•
EP9224-0023
•
Restoring the delivery state


Integration in TwinCAT

Commissioning and configuration [image] Integration in TwinCAT
Integration in TwinCAT
The procedure for integration in TwinCAT is described in this Quick start guide.


Operation with or without EtherCAT master

Commissioning and configuration [image] Operation with or without EtherCAT master
Operation with or without EtherCAT master
The EP92x4 is preset in the factory and delivered with a set nominal current of 4.0 A and all eight channels switched on.
Note
The channels switch on automatically during commissioning
In the basic setting the nominal current of the EP92x4 is 4 A per channel. Shortly after the EP92x4 is supplied with voltage, all channels are switched on with a delay of 100 ms each.
This is preset by the CoE object 0xF707:01
EP92x4_CoE-Objekt 0xF707_01_Enable Control Via Fieldbus_1
CoE object 0xF707:01 - Enable Control Via Fieldbus
If the EP92x4 is operated on an EtherCAT master, the basic setting or the bootup can be adapted.
This is done via the variable DPO Outputs Device - > Enable control via Fieldbus in the process data.
At the next power-on of the box the load circuits will then be switched on depending on the settings in the CoE objects.
In the case of EtherCAT use, adjust all parameters first
If the EP92x4 is being operated for the first time with an EtherCAT connection, all parameter must be adjusted.
Note
Outputs switch to the default status without an EtherCAT connection
The EtherCAT connection may be disconnected once the EP92x4 has been parameterized with an EtherCAT Master. However, the voltage and current values of all outputs switch to the default status in this case. If the connection to the EtherCAT Master is restored, the previously set values are available again.
Example of the parameterization of the outputs when using EtherCAT
Different settings of the Box Module can be made on the "CoE – Online" tab. As an example, the "Nominal Current US" (Index: 8000:12) can be set by double-clicking on this parameter to open the "Set Value Dialog" (see illustration below).
EP92x4_DPO Settings Ch1 EtherCAT_Verbunden
Setting the DPO Settings Ch. 1 with EtherCAT connection
If the EtherCAT connection has been disconnected, the option "Show Offline Data" should be enabled. The default values of the respective parameters are thus displayed.


Switch-off behavior

Commissioning and configuration [image] Switch-off behavior
Switch-off behavior
Additional information
•
Switch-off characteristics
•
Current limitation, switching the load circuits off
•
Setting the current limitation
•
Status LEDs and status bits


Switch-off characteristics

Commissioning and configuration [image] Switch-off behavior [image] Switch-off characteristics
Switch-off characteristics
The EP92x4 EtherCAT Box selectively protects all connected 24 VDC load circuits. This is done via various electronic circuits, additionally protected by a 7 A micro-fuse.
Selective switch-off means that the load circuits are individually monitored and if a channel is exceeded, only that channel is switched off.
This ensures the function of the remaining consumers connected to the higher-level power supply unit.
General functional principle
The EP92x4 EtherCAT Box monitors the current for each of the 8 output channels. 4 x Us, 4 x Up. Switching off takes place depending on the selected nominal current and tripping characteristic.
Superordinate to all is the hardware switch-off, which responds if
▪
7 A is reached for 50 ms
▪
there is a short-circuit for 50 ms
▪
the capacitive load and thus the start-up current of the connected devices is too high
Due to the intelligent current limitation an output current exceeding 7 A is not possible under operating conditions. The additionally installed 7 A micro fuse thus blows only if the upstream electronic switch-off is already defective.
The nominal current can be set individually for each output channel Us and Up between 1 A and 4 A (in mA) or 3 A in the case of EtherCAT P devices.
Setting the nominal current
All set characteristics are referenced to the set nominal current. The following table shows the response time of the monitoring in relation to the nominal current and characteristic.
Nominal current | Very fast acting | Fast acting | Slow acting | Time delay
100 % | 1 h | - | - | -
110 % | 1 h | 4 h | - | -
120 % | 7 min | 4 h | - | -
150 % | 30 s | 30 min | 1 h | 4 h
210 % | 500 ms | 20 s | 20 s | 100 s
275 % | 500 ms | 1 s | 20 s | 10 s
300 % | 20 ms | 100 ms | 1 s | 3 s
If overcurrent (≥ nominal current) is detected and it is foreseeable that the current monitoring will trip if conditions remain unchanged, then a warning is given both in the process data and in form of a flashing LED. An output switch-off due to overcurrent is indicated by a red LED.
If one of the outputs was switched off due to a diagnosis, it must be reactivated by an active RESET.
Restart after Power OFF/ON
If an output was switched off due to an error, then an active reset by the RESET contact (if existent) or the fieldbus is necessary. Switching off and on again is not sufficient! To protect the circuitry, a RESET can take place maximally every 20 seconds.
Switch-on can take place either by EtherCAT or by 24 V on the RESET contact (if existent). To protect the circuitry, a RESET can take place maximally every 20 seconds. Faster successive edges are ignored.
Switch-on delay of load circuits 1 to 4
Here is a table of the startup times, adjustable in the CoE object 0xF80E:11
Description | Switch-on delay
Fast | 10 ms
Moderate | 100 ms
Slow | 200 ms


Current limitation, switching the load circuits off

Commissioning and configuration [image] Switch-off behavior [image] Current limitation, switching the load circuits off
Current limitation, switching the load circuits off
The switch-off behavior of the individual load circuits can be adapted to the application.
The following modes can be set individually for each channel:
▪
Very fast acting
▪
Fast acting
▪
Slow acting
▪
Time delay
Release time (switch-off time) of the modes
Nominal current | Very fast acting | Fast acting | Slow acting | Time delay
100 % | 1 h | - | - | -
110 % | 1 h | 4 h | - | -
120 % | 7 min | 4 h | - | -
150 % | 30 s | 30 min | 1 h | 4 h
210 % | 500 ms | 20 s | 20 s | 100 s
275 % | 500 ms | 1 s | 20 s | 10 s
300 % | 20 ms | 100 ms | 1 s | 3 s
The release time depends on the set nominal current.
Following the switch-off of a channel it is necessary to reactivate it after rectification of the cause of the error.
Switch-off of the box due to overtemperature
The EP92x4 is internally protected against overheating. A warning is shown in the process data if a temperature of 75 °C is reached; the warning is reset at a value of <73 °C.
Temperature Warning and Temperature Error Bit
On reaching 85 °C all load circuits are switched off in order to protect the hardware against destruction. In this case the Temperature Error bit is set.
So that the permitted temperature is not exceeded, the Box is to be mounted with its rear panel on the flattest possible thermally conductive surface.
Switching the Box on again following an overtemperature error
The error can only be reset via the Global Error Bit when the temperature has fallen below 73 °C and the warning is thus extinguished. The Error Bit is not saved and is reset by a Power Cycle.
Switch off of the box due to undervoltage
Since undervoltage impairs the function of the safety mechanisms, a warning is given in the process data from an input voltage of 21.5 V. If the voltage Up falls below 18 V, all Up outputs are switched off and the Error bit is set.
Us and Up outputs are switched off in case of undervoltage of Us.
In the factory default setting, this error persists until a PowerCycle OR global reset takes place. An automatic error acknowledgment can be enabled on Up with the entry F80E:05 in the CoE. This is useful if UP is only switched on after successfully starting up the system.
Undervoltage is detected independently for Us and Up.
Undervoltage bits
Switching on again
Switching off due to undervoltage and overtemperature is equivalent to the response of the current monitoring, but applies to the entire box and all outputs. In order to acknowledge the error, it is necessary to set the process data GLOBAL RESET or to switch the module off and on again, in addition to which the temperature must have fallen below 73 °C!
Switching load circuits on again after switch-off
This takes place either via the process data by EtherCAT or via the Reset input (if existent) directly on the Box.


Setting the current limitation

Commissioning and configuration [image] Switch-off behavior [image] Setting the current limitation
Setting the current limitation
The switch-off behavior of the individual load circuits can be adapted to the application.
The following modes can be set individually for each channel:
▪
Very fast acting
▪
Fast acting
▪
Slow acting
▪
Time delay
Release time (switch-off time) of the modes
Nominal current | Very fast acting | Fast acting | Slow acting | Time delay
100 % | 1 h | - | - | -
110 % | 1 h | 4 h | - | -
120 % | 7 min | 4 h | - | -
150 % | 30 s | 30 min | 1 h | 4 h
210 % | 500 ms | 20 s | 20 s | 100 s
275 % | 500 ms | 1 s | 20 s | 10 s
300 % | 20 ms | 100 ms | 1 s | 3 s
The release time depends on the set nominal current.
CoE parameters for setting the current limiting characteristic
CoE parameters for setting the current limiting characteristic
Meaning of the parameters
Index | Name | Meaning
0x80n0:02 | Default State Us | TRUE: in case of operation without fieldbus the load circuit Us of channel n is automatically switched on FALSE: in case of operation without fieldbus the load circuit Us of channel n remains switched off
0x80n0:02 | Default State Up | TRUE: in case of operation without fieldbus the load circuit Up of channel n is automatically switched on FALSE: in case of operation without fieldbus the load circuit Up of channel n remains switched off
0x80n0:11 | Characteristic | Tripping time depending on nominal current
0x80n0:12 | Nominal Current Us | Specification of the nominal current of Us in mA
0x80n0:13 | Nominal Current Up | Specification of the nominal current of Up in mA
Switching load circuits on again after switch-off
This takes place either via the process data by EtherCAT or via the Reset input (if existent) directly on the Box.


Status LEDs and status bits

Commissioning and configuration [image] Switch-off behavior [image] Status LEDs and status bits
Status LEDs and status bits
Below is a table showing the meaning of the Status LEDs and Status bits for the power outputs (taking the EP9214 as an example):
EP9214 - Status LEDs
EP9214 - Status bits
The LED applies to both voltages/currents (Us and Up; OR).
LED | Status Us / Up | Warning | Error Us / Up | Description
Off | 0 | 0 | 0 | The output is ready
Green | 1 | 0 | 0 | The output is just switching on
Green | 1 | 0 | 0 | The output is switched on. Normal operating state.
Flashing green | 1 | 1 | 0 | The output is still operating, but will switch off if conditions remain unchanged (Warning Ux).
Flashing red | 0 | 1 | 1 | The output has been switched off (Error Ux). Switching on again is not yet possible (waiting time of 20 seconds)
Red | 0 | 0 | 1 | The output has been disabled and can be returned to a normal state by a reset.
Red running light all channels | x | 1 | 1 | Undervoltage Us/Up or temperature error
Initialization
When switching on the voltage supply to the EP9214 / EP9224, all green LEDs and then all red LEDs are switched on briefly to test the LEDs.


EP9214-0023

Commissioning and configuration [image] EP9214-0023
EP9214-0023
Additional information
•
EP9214-0023 – Object description
•
EP9214-0023 - Process image


EP9214-0023 – Object description

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description
EP9214-0023 – Object description
Parameterization
The terminal is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (assignment of PDOs).
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. It is strongly recommended to download the latest revision of the corresponding XML file from the Beckhoff website (http://www.beckhoff.com/english/default.htm?download/elconfg.htm) and follow the installation instructions.
The CoE overview contains objects for different intended applications:
▪
Objects required for parameterization during commissioning
▪
Objects intended for regular operation, e.g. through ADS access
▪
Objects for indicating internal settings (may be fixed)
▪
Further profile-specific objects indicating inputs, outputs and status information
The following section first describes the objects required for normal operation, followed by a complete overview of missing objects.
Additional information
•
Objects for parameterization
•
Standard objects
•
Profile-specific objects (0x6000-0xFFFF)


Objects for parameterization

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Objects for parameterization
Objects for parameterization
Additional information
•
Index 1011 Restore default parameters
•
Index 8000 DPO Settings Ch.1
•
Index 8010 DPO Settings Ch.2
•
Index 8020 DPO Settings Ch.3
•
Index 8030 DPO Settings Ch.4
•
Index F707 DPO Outputs Device
•
Index F80E DPO Settings Device


Standard objects

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Standard objects
Standard objects
The standard objects have the same meaning for all EtherCAT slaves.
Additional information
•
Index 1000 Device type
•
Index 1008 Device name
•
Index 1009 Hardware version
•
Index 100A Software Version
•
Index 1018 Identity
•
Index 10F0 Backup parameter handling
•
Index 1600 DPO RxPDO-Map Outputs Ch.1
•
Index 1601 DPO RxPDO-Map Outputs Ch.2
•
Index 1602 DPO RxPDO-Map Outputs Ch.3
•
Index 1603 DPO RxPDO-Map Outputs Ch.4
•
Index 1604 DPO RxPDO-Map Outputs Device
•
Index 1A00 DPO TxPDO-Map Inputs Ch.1
•
Index 1A01 DPO TxPDO-Map Inputs Ch.2
•
Index 1A02 DPO TxPDO-Map Inputs Ch.3
•
Index 1A03 DPO TxPDO-Map Inputs Ch.4
•
Index 1A04 DPO TxPDO-Map Inputs Device
•
Index 1C00 Sync manager type
•
Index 1C12 RxPDO assign
•
Index 1C13 TxPDO assign
•
Index 1C32 SM output parameter
•
Index 1C33 SM input parameter


Profile-specific objects (0x6000-0xFFFF)

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF)
Profile-specific objects (0x6000-0xFFFF)
The profile-specific objects have the same meaning for all EtherCAT slaves that support the profile 5001.
Additional information
•
Index 6000 DPO Inputs Ch.1
•
Index 6010 DPO Inputs Ch.2
•
Index 6020 DPO Inputs Ch.3
•
Index 6030 DPO Inputs Ch.4
•
Index 7000 DPO Outputs Ch.1
•
Index 7010 DPO Outputs Ch.2
•
Index 7020 DPO Outputs Ch.3
•
Index 7030 DPO Outputs Ch.4
•
Index 800F DPO Vendor data Ch.1
•
Index 801F DPO Vendor data Ch.2
•
Index 802F DPO Vendor data Ch.3
•
Index 803F DPO Vendor data Ch.4
•
Index F000 Modular device profile
•
Index F008 Code word
•
Index F010 Module list
•
Index F607 DPO Inputs Device
•
Index F81F DPO Vendor Data Device


EP9214-0023 - Process image

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 - Process image
EP9214-0023 - Process image
The EP9214 has 4 x 16-bit status data of the four output channels DPO Inputs Channel n.
Subsequently, a status word follows for the complete device DPO Inputs Device.
In the output section there are 4 x 16-bit output data of the four output channels DPO Outputs Channel n.
An output word follows for the complete device DPO Outputs Device.
WcState and InfoData are standard EtherCAT system variables.
DPO Inputs Channel 1 to 4
The four channels each have status bits for displaying the current channel state:
see Status LEDs
Channel Error:
Error Us or Error Up is TRUE
DPO Inputs Device
The EP9214 has 4 x 16-bit status data of the four output channels DPO Inputs Channel n.
Subsequently, a status word follows for the complete device DPO Inputs Device.
Channel Error:
Error Us or Error Up
One of the eight channels is TRUE
DPO Outputs Channel 1 to 4
The EP9214 has 4 x 16-bit output data of the four output channels DPO Outputs Channel n.
Output Us:
TRUE - switches on the output
FALSE - switches off the output
Reset Us:
TRUE - reset in the event of an error…
DPO Outputs Device
Subsequently, a status word follows for the complete device DPO outputs Device.
Enable Control Via Fieldbus:
TRUE - control of all outputs via the fieldbus / the PLC
FALSE - automatic switch-on depending on the CoE entries
Global Reset:
Resets all errors in the Box


EP9224-0023

Commissioning and configuration [image] EP9224-0023
EP9224-0023
Additional information
•
EP9224-0023 – Diagnostic functions
•
EP9224-0023 – Object description
•
EP9224-0023 - Process image


EP9224-0023 – Diagnostic functions

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Diagnostic functions
EP9224-0023 – Diagnostic functions
Additional information
•
Special features of the EP9224
•
Additional PDOs of the EP922x
•
Extended channel and device diagnostics of the EP9224-00xx
•
Timestamp / trigger of the EP9224
•
Data Logging


Special features of the EP9224

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Diagnostic functions [image] Special features of the EP9224
Special features of the EP9224
The EP9224 EtherCAT Box offers all the basic properties of the EP9214-0023. Beyond that it permits more detailed settings and a further-reaching diagnosis of the output channels.
The diagnostic information is either directly visible in the process data or can be read out via the logdata.csv log file in the event of an error.
The limitation of the sum current can be implemented as a supplement to the channel current limitation in the EP9214 basic version.
Additional properties
▪
Switch-off due to sum current monitoring
▪
Extended diagnostic data by process data
▪
Data Logging
Additional settings in the CoE
Settings for each output channel
The object 80n0:04 must be enabled in order to activate the sum current limitation.
The sum current can then be defined in the object 80n0:14.
Object 8000:14 Nominal Sum Current
CoE | Title | Description
80n0:04 | Enable Sum Current Limitation | The CoE object 80n0:04 must be set to TRUE in order to activate 80n0:14
80n0:14 | Nominal Sum Current | Apart from the nominal current for each Us and Up (basic function of the EP92x4), the sum current of both outputs can also be limited per channel. This property is recommended if the end device may not exceed a total power. The default setting is 4.0 A (4000) and the maximum sum current 8 A. For the EP9224-0037 the default setting is 3.0 A (3000) and the maximum sum current 6 A. The sum current switch-off corresponds to the behavior of the load circuit concerned (CoE 80n0:11).
80n0:15 / 16 | Timestamp n Trigger | On occurrence of the selected event, the corresponding value (Peak Value n) and the appropriate timestamp are set in the process data.
If overcurrent (≥ nominal current) is detected and it is foreseeable that the current monitoring will trip if conditions remain unchanged, then a warning is given both in the process data and in form of a flashing LED. An output switch-off due to overcurrent is indicated by a red LED.
If one of the outputs was switched off due to a diagnosis, it must be reactivated by an active RESET.
Restart after Power OFF/ON
If an output was switched off due to an error, then an active reset by the RESET contact (if existent) or the fieldbus is necessary. Switching off and on again is not sufficient!
Switch-on can take place either by EtherCAT or by 24 V on the RESET contact (if existent). To protect the circuitry, a RESET can take place maximally every 20 seconds. Faster successive edges are ignored.
Additional diagnosis
Extended diagnosis and data logging


Additional PDOs of the EP922x

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Diagnostic functions [image] Additional PDOs of the EP922x
Additional PDOs of the EP922x
The selection of additional PDOs in the PDO Mapping is required for the use of the diagnostic functions.
This allows the display of further diagnostic data in the process data section.
PDOs, taking the EP9224-0023 as an example.
Additional input PDOs
EP9224 – Additional input PDOs
Additional output PDOs
EP9224 – Additional output PDOs


Extended channel and device diagnostics of the EP9224-00xx

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Diagnostic functions [image] Extended channel and device diagnostics of the EP9224-00xx
Extended channel and device diagnostics of the EP9224-00xx
The selection of additional PDOs in the PDO Mapping is required for the use of the diagnostic functions.
Certain values can be recorded with time stamp (timestamp / trigger) for each channel of DPO Extended Diag Inputs Channel n and for the DPO Extended Diag Inputs Device module.
DPO Extended Diag Output Device resets the recording.
DPO Extended Diag Inputs Channel n
The DPO Extended Diag Inputs Channel n can be enabled with each channel.
It continuously indicates the respective current value Peak Value n and the precise time of the arrival Timestamp n.
The selection of the triggering event takes place in the CoE object 80x0:15 or 16.
EP9224 - DPO Extended Diag Inputs Channel 1
DPO Extended Diag Inputs Device
As for each channel there is also a DPO Extended Diag Inputs Device for the entire EP9224.
It continuously indicates the respective current value Peak Value n and the precise time of the arrival Timestamp n.
The selection of the triggering event takes place in the CoE object F80E:15 or 16.
EP9224 - DPO Extended Diag Inputs Device
DPO Extended Diag Outputs Channel n
The Peak Value and Timestamp data of the respective channel are reset by setting the Reset Extended Diag Data bit.
The bit is state-triggered.
EP9224 - DPO Extended Diag Outputs Channel 1
DPO Extended Diag Outputs Device
The Peak Value and Timestamp data of the module are reset by setting the Reset Extended Diag Data bit.
The bit is state-triggered.
EP9224 - DPO Extended Diag Outputs Device


Timestamp / trigger of the EP9224

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Diagnostic functions [image] Timestamp / trigger of the EP9224
Timestamp / trigger of the EP9224
The last min/max values Peak Value n and the respective timestamp Timestamp n can be displayed or recorded via the Timestamp / Trigger setting, depending on the trigger criterion in the CoE 80n0:15 and 16.
Process data
EP9224 - Process data
Peak value / Timestamp
EP9224 - Peak value / Timestamp
The present value and the associated timestamp are set each time the value momentarily saved in Peak Value n is exceeded or fallen below.
Thus, for example, in the above case with the setting Maximum Current Us, the value pv_3 is displayed in the process data with the timestamp t3.
Selection of the trigger criterion
Settings for each output channel
The object 80n0:15 or 16 must be adapted for the selection.
EP9224 – Selection of the trigger criterion – settings per output channel
Description of the setting
CoE | Title | Description
80n0:15 / 16 | Error Us | Switch-off of Us due to an error (edge triggered 0->1)
 | Error Up | Switch-off of Up due to an error (edge triggered 0->1)
 | Warning Us | imminent switch-off of Us due to a continuous overload > 100% (edge triggered 0->1)
 | Warning Up | imminent switch-off of Up due to a continuous overload > 100% (edge triggered 0->1)
 | Error Sum Current | Switch-off of Us and Up due to a sum current error (edge triggered 0->1)
 | Warning Sum Current | Imminent switch-off of Us and Up due to a sum current error (edge triggered 0->1)
 | Minimum Current Us | minimum current on Us
 | Maximum Current Us | maximum current on Us
 | Minimum Current Up | minimum current on Up
 | Maximum Current Up | maximum current on Up
Reset of the values
Reset of Peak Value n and Timestamp for each channel
EP9224 - Reset Extended Diag Data for the channel
Reset of Peak Value n and Timestamp of the module
EP9224 - Reset Extended Diag Data for the module


Data Logging

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Diagnostic functions [image] Data Logging
Data Logging
Overview
With the data logging the continuous logging of all relevant EP9224 data can be started.
These data are written to a 40-line ring buffer. In the case of the EP9224-0037 the memory is 25 lines..
On the first error the recording is stopped so that the data can be evaluated after an error or during normal operation.
In the event of an error, data are still written for a few cycles. The switching-off of a channel is indicated by OFF.
The writing rate or scanning rate is 10 ms in the factory setting. The value can be adjusted from 1 ms to 1000 ms in the CoE.
Setting the sampling rate via CoE object 8040:11
EP9224 – Setting the sampling rate
Starting the logger
The logger is started/stopped via the process data
▪
Start logger and
▪
Stop logger
These must be enabled via the PDO mapping 0x1610 (see PDO settings).
DPO LOG Control
EP9224 - DPO LOG Control
The log file is written when stopping the logger or in the case of an error.
The state of the logger can be tracked in the PDO input area.
To do this it is necessary to activate the PDO 0x1A10 (see PDO settings).
DPO LOG Status
EP9224 - DPO LOG Status
Upload the file from the EP9224
The EP9224 creates the file, giving it the name logdata.csv. This cannot be changed.
When uploading, for example, it must be specified accordingly in TwinCAT.
EP9224 - Uploading the file
Structure of the logging file: logdata.csv
The data are saved in the CSV format, so that simple viewing with EXCEL or a corresponding interpretation is possible.
EP9224 – Structure of the logdata.csv file
Header
Field | Description
Device Name | Name of the module
File Version | Version number (Note: when importing from EXCEL the version, e.g. 1.5, is interpreted/displayed as a date (1st May))
Reason for which the snapshot was taken | Reason for stopping the data logger
Age of snapshot | time elapsed from stopping the data logger until the upload
System timestamp (0 if DC not supported) | current timestamp when uploading
Columns
Type
Description
Time offset additional to snapshot age
The age of the measured values in the row in relation to the stopping of the data logger (0 = stop, > 0 older values) in ms
I(U...)
present current values of the channels Us / Up 1 - 4 in 100 mA
Internal Temperature
internal module temperature in °C
Us / Up
Input voltage Us and Up at the 7/8" input in V
Sum Current Us / Up
Sum current of Us and Up in A
I²t(U...)
virtual overload, incremented or decremented depending on the nominal current
▪
from 10% warning
▪
at 100% shut-off
Example: slow exceeding of the current (simulation with potentiometer)
logdata.csv (zip)
EP9224 - logdata.csv
Description:
▪
EP9224: Setting the Us channel to a nominal current of 1500 mA
▪
Continuous increase of the current on channel1 Us within the recorded range of 3.0 A to 4.9 A, then switch-off takes place.
▪
Overcurrent begins from 180 ms
▪
100% overload reached (99), channel is switched off
▪
the module now waits for an error correction or an active reset of the error


EP9224-0023 – Object description

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description
EP9224-0023 – Object description
Additional information
•
Objects for parameterization
•
Standard objects
•
Profile-specific objects (0x6000-0xFFFF)


Objects for parameterization

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Objects for parameterization
Objects for parameterization
Additional information
•
Index 1011 Restore default parameters
•
Index 8000 DPO Settings Ch.1
•
Index 8010 DPO Settings Ch.2
•
Index 8020 DPO Settings Ch.3
•
Index 8030 DPO Settings Ch.4
•
Index 8040 LOG Settings
•
Index F607 DPO Inputs Device
•
Index F707 DPO Outputs Device
•
Index F80E DPO Settings Device


Index 1011 Restore default parameters

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Objects for parameterization [image] Index 1011 Restore default parameters
Index 1011 Restore default parameters
Index | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default settings | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to 0x64616F6C in the set value dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)


Index 8000 DPO Settings Ch.1

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Objects for parameterization [image] Index 8000 DPO Settings Ch.1
Index 8000 DPO Settings Ch.1
Index | Name | Meaning | Data type | Flags | Default
8000:0 | DPO Settings Ch.1 |  | UINT8 | RO | 0x16 (22dec)
8000:02 | Default State Us | The output assumes this value if Enable Control VIA Fieldbus (F707:01) is not set or if there is no connection to the fieldbus | boolean | RW | 0x01 (1dec)
8000:03 | Default State Up | The output assumes this value if Enable Control VIA Fieldbus (F707:01) is not set or if there is no connection to the fieldbus | boolean | RW | 0x01 (1dec)
8000:04 | Enable Sum Current Limitation | Sum current limitation for the channel: 0bin: disabled 1bin: enabled | boolean | RW | 0x00 (0dec)
8000:11 | Characteristic | Specifies the characteristic with which the current monitoring reacts: 0dec: very fast acting 1dec: fast acting 2dec: slow acting 3dec: time delay | UINT16 | RW | 0x0001 (1dec)
8000:12 | Nominal Current Us | Nominal current on the output | UINT16 | RW | 0x0FA0 (4000dec)
8000:13 | Nominal Current Up | Nominal current on the output | UINT16 | RW | 0x0FA0 (4000dec)
8000:14 | Nominal Sum Current | Nominal sum current | UINT16 | RW | 0x0FA0 (4000dec)
8000:15 | Timestamp 1 Trigger | Trigger condition for the extended diagnosis | UINT16 | RW | 0x0000 (0dec)
8000:16 | Timestamp 2 Trigger | Trigger condition for the extended diagnosis | UINT16 | RW | 0x0000 (0dec)


Index 8010 DPO Settings Ch.2

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Objects for parameterization [image] Index 8010 DPO Settings Ch.2
Index 8010 DPO Settings Ch.2
Index | Name | Meaning | Data type | Flags | Default
8010:0 | DPO Settings Ch.2 |  | UINT8 | RO | 0x16 (22dec)
8010:02 | Default State Us | The output assumes this value if Enable Control VIA Fieldbus (F707:01) is not set or if there is no connection to the fieldbus | boolean | RW | 0x01 (1dec)
8010:03 | Default State Up | The output assumes this value if Enable Control VIA Fieldbus (F707:01) is not set or if there is no connection to the fieldbus | boolean | RW | 0x01 (1dec)
8010:04 | Enable Sum Current Limitation | Sum current limitation for the channel: 0bin: disabled 1bin: enabled | boolean | RW | 0x00 (0dec)
8010:11 | Characteristic | Specifies the characteristic with which the current monitoring reacts: 0dec: very fast acting 1dec: fast acting 2dec: slow acting 3dec: time delay | UINT16 | RW | 0x0001 (1dec)
8010:12 | Nominal Current Us | Nominal current on the output | UINT16 | RW | 0x0FA0 (4000dec)
8010:13 | Nominal Current Up | Nominal current on the output | UINT16 | RW | 0x0FA0 (4000dec)
8010:14 | Nominal Sum Current | Nominal sum current | UINT16 | RW | 0x0FA0 (4000dec)
8010:15 | Timestamp 1 Trigger | Trigger condition for the extended diagnosis | UINT16 | RW | 0x0000 (0dec)
8010:16 | Timestamp 2 Trigger | Trigger condition for the extended diagnosis | UINT16 | RW | 0x0000 (0dec)


Index 8020 DPO Settings Ch.3

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Objects for parameterization [image] Index 8020 DPO Settings Ch.3
Index 8020 DPO Settings Ch.3
Index | Name | Meaning | Data type | Flags | Default
8020:0 | DPO Settings Ch.3 |  | UINT8 | RO | 0x16 (22dec)
8020:02 | Default State Us | The output assumes this value if Enable Control VIA Fieldbus (F707:01) is not set or if there is no connection to the fieldbus | boolean | RW | 0x01 (1dec)
8020:03 | Default State Up | The output assumes this value if Enable Control VIA Fieldbus (F707:01) is not set or if there is no connection to the fieldbus | boolean | RW | 0x01 (1dec)
8020:04 | Enable Sum Current Limitation | Sum current limitation for the channel: 0bin: disabled 1bin: enabled | boolean | RW | 0x00 (0dec)
8020:11 | Characteristic | Specifies the characteristic with which the current monitoring reacts: 0dec: very fast acting 1dec: fast acting 2dec: slow acting 3dec: time delay | UINT16 | RW | 0x0001 (1dec)
8020:12 | Nominal Current Us | Nominal current on the output | UINT16 | RW | 0x0FA0 (4000dec)
8020:13 | Nominal Current Up | Nominal current on the output | UINT16 | RW | 0x0FA0 (4000dec)
8020:14 | Nominal Sum Current | Nominal sum current | UINT16 | RW | 0x0FA0 (4000dec)
8020:15 | Timestamp 1 Trigger | Trigger condition for the extended diagnosis | UINT16 | RW | 0x0000 (0dec)
8020:16 | Timestamp 2 Trigger | Trigger condition for the extended diagnosis | UINT16 | RW | 0x0000 (0dec)


Index 8030 DPO Settings Ch.4

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Objects for parameterization [image] Index 8030 DPO Settings Ch.4
Index 8030 DPO Settings Ch.4
Index | Name | Meaning | Data type | Flags | Default
8030:0 | DPO Settings Ch.4 |  | UINT8 | RO | 0x16 (22dec)
8030:02 | Default State Us | The output assumes this value if Enable Control VIA Fieldbus (F707:01) is not set or if there is no connection to the fieldbus | boolean | RW | 0x01 (1dec)
8030:03 | Default State Up | The output assumes this value if Enable Control VIA Fieldbus (F707:01) is not set or if there is no connection to the fieldbus | boolean | RW | 0x01 (1dec)
8030:04 | Enable Sum Current Limitation | Sum current limitation for the channel: 0bin: disabled 1bin: enabled | boolean | RW | 0x00 (0dec)
8030:11 | Characteristic | Specifies the characteristic with which the current monitoring reacts: 0dec: very fast acting 1dec: fast acting 2dec: slow acting 3dec: time delay | UINT16 | RW | 0x0001 (1dec)
8030:12 | Nominal Current Us | Nominal current on the output | UINT16 | RW | 0x0FA0 (4000dec)
8030:13 | Nominal Current Up | Nominal current on the output | UINT16 | RW | 0x0FA0 (4000dec)
8030:14 | Nominal Sum Current | Nominal sum current | UINT16 | RW | 0x0FA0 (4000dec)
8030:15 | Timestamp 1 Trigger | Trigger condition for the extended diagnosis | UINT16 | RW | 0x0000 (0dec)
8030:16 | Timestamp 2 Trigger | Trigger condition for the extended diagnosis | UINT16 | RW | 0x0000 (0dec)


Index 8040 LOG Settings

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Objects for parameterization [image] Index 8040 LOG Settings
Index 8040 LOG Settings
Index | Name | Meaning | Data type | Flags | Default
8040:0 | LOG Settings |  | UINT8 | RO | 0x11 (17dec)
8040:11 | Sampling Rate | permitted values: 1: 1 ms 10: 10 ms 25: 25 ms 100: 100 ms | UINT16 | RW | 0x000A (10dec)


Index F607 DPO Inputs Device

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Objects for parameterization [image] Index F607 DPO Inputs Device
Index F607 DPO Inputs Device
Index | Name | Meaning | Data type | Flags | Default
F607:0 | DPO Inputs Device |  | UINT8 | RO | 0x19 (25dec)
F607:01 | Temperature Warning | A temperature of about 80 °C has been reached | boolean | RO | 0x00 (0dec)
F607:02 | Temperature Error | A critical temperature of about 85 °C has been reached, the outputs will be switched off. The bit must be reset by a Global Reset (F707:04) or by a voltage reset. No output can be switched on if the error bit is set. | boolean | RO | 0x00 (0dec)
F607:03 | Us Warning | Us is less than 21.5 V, no further outputs can be switched on. | boolean | RO | 0x00 (0dec)
F607:04 | Us Error | Us is less than 19 V, all Us outputs will be switched off. This bit must be reset by a Global Reset (F707:04) or by a voltage reset. No Us output can be switched on if the error bit is set. | boolean | RO | 0x00 (0dec)
F607:05 | Up Warning | Up is less than 21.5 V, no further outputs can be switched on. | boolean | RO | 0x00 (0dec)
F607:06 | Up Error | Up is less than 19 V, all Up outputs will be switched off. This bit must be reset by a Global Reset (F707:04) or by a voltage reset. No Up output can be switched on if the Error bit is set. | boolean | RO | 0x00 (0dec)
F607:07 | Global Error Bit | One of the error bits of the four channels or F607:02 or F607:04 or F60706 is set | boolean | RO | 0x00 (0dec)
F607:08 | Sum Current Warning | The sum current monitoring has detected a current peak. | boolean | RO | 0x00 (0dec)
F607:09 | Sum Current Error | The sum current monitoring has detected an overcurrent. All outputs will be switched off. | boolean | RO | 0x00 (0dec)
F607:0C | Reset Input | 0: There is no voltage on the external reset input 1: 24 V is present on the external reset input | boolean | RO | 0x00 (0dec)
F607:0F | TxPDO State |  | boolean | RO | 0x00 (0dec)
F607:10 | TxPDO Toggle |  | boolean | RO | 0x00 (0dec)
F607:11 | Current Us | Sum current of the module on Us | INT16 | RO | 0x0000 (0dec)
F607:12 | Current Up | Sum current of the module on Up | INT16 | RO | 0x0000 (0dec)
F607:13 | Voltage Us | Voltage at the Us input | INT16 | RO | 0x0000 (0dec)
F607:14 | Voltage Up | Voltage at the Up input | INT16 | RO | 0x0000 (0dec)
F607:15 | Temperature | Internal temperature of the power output stage | INT16 | RO | 0x0000 (0dec)
F607:16 | Peak Value 1 | Extended diagnosis | INT16 | RO | 0x0000 (0dec)
F607:17 | Peak Value 2 | Extended diagnosis | INT16 | RO | 0x0000 (0dec)
F607:18 | Timestamp 1 |  | UINT64 | RO |
F607:19 | Timestamp 2 |  | UINT64 | RO |


Index F707 DPO Outputs Device

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Objects for parameterization [image] Index F707 DPO Outputs Device
Index F707 DPO Outputs Device
Index | Name | Meaning | Data type | Flags | Default
F707:0 | DPO Outputs Device |  | UINT8 | RO | 0x11 (17dec)
F707:01 | Enable Control Via Fieldbus | 0bin: All outputs are set according to their default values (80X0:02, 80X0:03) 1bin: All outputs are set according to their PDOs (70X0:01, 70X0:02) | boolean | RO | 0x00 (0dec)
F707:04 | Global Reset | All error bits are reset | boolean | RO | 0x00 (0dec)
F707:11 | Reset Extended Diag Data | Reset peak values and timestamps from F607 | boolean | RO | 0x00 (0dec)


Index F80E DPO Settings Device

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Objects for parameterization [image] Index F80E DPO Settings Device
Index F80E DPO Settings Device
Index | Name | Meaning | Data type | Flags | Default
F80E:0 | DPO Settings Device |  | UINT8 | RO | 0x16 (22dec)
F80E:02 | Enable Sum Current Limitation | Sum current monitoring: 0bin: enabled 1bin: disabled | boolean | RW | 0x00 (0dec)
F80E:03 | Automatic Restart After Uncritic Events on Us | Automatic restart after undervoltage and overtemperature: 0bin: enabled 1bin: disabled | boolean | RW | 0x00 (0dec)
F80E:04 | Automatic Restart After Uncritic Events on Up | Automatic restart after undervoltage and overtemperature: 0bin: enabled 1bin: disabled | boolean | RW | 0x00 (0dec)
F80E:11 | Startup Delay | Sets the time that is kept between two switch-on procedures: 1dec: fast (10 ms) 2dec: moderate (100 ms) 3dec: slow (200 ms) | UINT16 | RW | 0x0001 (1dec)
F80E:12 | Nominal Sum Current | Nominal sum current | INT16 | RW | 0x2710 (10000dec)
F80E:13 | Sum Current Characteristic | Characteristic of the sum current monitoring | UINT16 | RW | 0x0001 (1dec)
F80E:15 | Timestamp 1 Trigger | Variable of the extended diagnosis to be monitored: 0: Temperature Warning 1: Temperature Error 2: Us Warning 3: Us Error 4: Up Warning 5: Up Error 6: Global Error Bit 7: Sum Current Warning 8: Sum Current Error 16: Minimum Current Us 17: Maximum Current Us 18: Minimum Current Up 19: Maximum Current Up 20: Minimum Voltage Us 21: Maximum Voltage Us 22: Minimum Voltage Up 23: Maximum Voltage Up 25: Maximum Temperature 24: Minimum Temperature | UINT16 | RW | 0x0000 (0dec)
F80E:16 | Timestamp 2 Trigger | Variable of the extended diagnosis to be monitored: 0: Temperature Warning 1: Temperature Error 2: Us Warning 3: Us Error 4: Up Warning 5: Up Error 6: Global Error Bit 7: Sum Current Warning 8: Sum Current Error 16: Minimum Current Us 17: Maximum Current Us 18: Minimum Current Up 19: Maximum Current Up 20: Minimum Voltage Us 21: Maximum Voltage Us 22: Minimum Voltage Up 23: Maximum Voltage Up 25: Maximum Temperature 24: Minimum Temperature | UINT16 | RW | 0x0000 (0dec)


Standard objects

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Standard objects
Standard objects
The standard objects have the same meaning for all EtherCAT slaves.
Additional information
•
Index 1000 Device type
•
Index 1008 Device name
•
Index 1009 Hardware version
•
Index 100A Software version
•
Index 1018 Identity
•
Index 10F0 Backup parameter handling
•
Index 1600 DPO RxPDO-Map Outputs Ch.1
•
Index 1601 DPO RxPDO-Map Extended Diag Outputs Ch.1
•
Index 1602 DPO RxPDO-Map Outputs Ch.2
•
Index 1603 DPO RxPDO-Map Extended Diag Outputs Ch.2
•
Index 1604 DPO RxPDO-Map Outputs Ch.3
•
Index 1605 DPO RxPDO-Map Extended Diag Outputs Ch.3
•
Index 1606 DPO RxPDO-Map Outputs Ch.4
•
Index 1607 DPO RxPDO-Map Extended Diag Outputs Ch.4
•
Index 1608 DPO RxPDO-Map Outputs Device
•
Index 1609 DPO RxPDO-Map Extended Diag Outputs Device
•
Index 1610 LOG RxPDO-Map Contr
•
Index 1A00 DPO TxPDO-Map Inputs Ch.1
•
Index 1A01 DPO TxPDO-Map Extended Diag Inputs Ch.1
•
Index 1A02 DPO TxPDO-Map Inputs Ch.2
•
Index 1A03 DPO TxPDO-Map Extended Diag Inputs Ch.2
•
Index 1A04 DPO TxPDO-Map Inputs Ch.3
•
Index 1A05 DPO TxPDO-Map Extended Diag Inputs Ch.3
•
Index 1A06 DPO TxPDO-Map Inputs Ch.4
•
Index 1A07 DPO TxPDO-Map Extended Diag Inputs Ch.4
•
Index 1A08 DPO TxPDO-Map Inputs Device
•
Index 1A09 DPO TxPDO-Map Extended Diag Inputs Device
•
Index 1A10 LOG TxPDO-Map Status
•
Index 1C00 Sync manager type
•
Index 1C12 RxPDO assign
•
Index 1C13 TxPDO assign
•
Index 1C32 SM output parameter
•
Index 1C33 SM input parameter


Index 1000 Device type

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Standard objects [image] Index 1000 Device type
Index 1000 Device type
Index | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x00001389 (5001dec)


Index 1008 Device name

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Standard objects [image] Index 1008 Device name
Index 1008 Device name
Index | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EP9224-0023


Index 1009 Hardware version

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Standard objects [image] Index 1009 Hardware version
Index 1009 Hardware version
Index | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO |


Index 100A Software version

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Standard objects [image] Index 100A Software version
Index 100A Software version
Index | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO | 01


Index 1018 Identity

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Standard objects [image] Index 1018 Identity
Index 1018 Identity
Index | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x24084052 (604520530dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the Low Word (bit 0-15) indicates the special terminal number, the High Word (bit 16-31) refers to the device description | UINT32 | RO | 0x00000000 (0dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the Low Byte (bit 0-7) of the Low Word contains the year of production, the High Byte (bit 8-15) of the Low Word contains the week of production, the High Word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)


Index 10F0 Backup parameter handling

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Standard objects [image] Index 10F0 Backup parameter handling
Index 10F0 Backup parameter handling
Index | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | Information for standardized loading and saving of backup entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum across all backup entries of the EtherCAT slave | UINT32 | RO | 0x00000000 (0dec)


Index 1600 DPO RxPDO-Map Outputs Ch.1

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Standard objects [image] Index 1600 DPO RxPDO-Map Outputs Ch.1
Index 1600 DPO RxPDO-Map Outputs Ch.1
Index | Name | Meaning | Data type | Flags | Default
1600:0 | DPO RxPDO-Map Outputs Ch.1 | PDO Mapping RxPDO 1 | UINT8 | RO | 0x06 (6dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (DPO Outputs Ch.1), entry 0x01 (Output Us)) | UINT32 | RO | 0x7000:01, 1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (DPO Outputs Ch.1), entry 0x02 (Output Up)) | UINT32 | RO | 0x7000:02, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (DPO Outputs Ch.1), entry 0x05 (Reset Us)) | UINT32 | RO | 0x7000:05, 1
1600:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7000 (DPO Outputs Ch.1), entry 0x06 (Reset Up)) | UINT32 | RO | 0x7000:06, 1
1600:06 | SubIndex 006 | 6. PDO Mapping entry (10 bits align) | UINT32 | RO | 0x0000:00, 10


Index 1601 DPO RxPDO-Map Extended Diag Outputs Ch.1

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Standard objects [image] Index 1601 DPO RxPDO-Map Extended Diag Outputs Ch.1
Index 1601 DPO RxPDO-Map Extended Diag Outputs Ch.1
Index | Name | Meaning | Data type | Flags | Default
1601:0 | DPO RxPDO-Map Extended Diag Outputs Ch.1 | PDO Mapping RxPDO 2 | UINT8 | RO | 0x02 (2dec)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (DPO Outputs Ch.2), entry 0x01 (Output Us)) | UINT32 | RO | 0x7000:11, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (DPO Outputs Ch.2), entry 0x02 (Output Up)) | UINT32 | RO | 0x0000:00, 15


Index 1602 DPO RxPDO-Map Outputs Ch.2

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Standard objects [image] Index 1602 DPO RxPDO-Map Outputs Ch.2
Index 1602 DPO RxPDO-Map Outputs Ch.2
Index | Name | Meaning | Data type | Flags | Default
1602:0 | DPO RxPDO-Map Outputs Ch.2 | PDO Mapping RxPDO 3 | UINT8 | RO | 0x06 (6dec)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (DPO Outputs Ch.3), entry 0x01 (Output Us)) | UINT32 | RO | 0x7010:01, 1
1602:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7020 (DPO Outputs Ch.3), entry 0x02 (Output Up)) | UINT32 | RO | 0x7010:02, 1
1602:03 | SubIndex 003 | 3. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1602:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7020 (DPO Outputs Ch.3), entry 0x05 (Reset Us)) | UINT32 | RO | 0x7010:05, 1
1602:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7020 (DPO Outputs Ch.3), entry 0x06 (Reset Up)) | UINT32 | RO | 0x7010:06, 1
1602:06 | SubIndex 006 | 6. PDO Mapping entry (10 bits align) | UINT32 | RO | 0x0000:00, 10


Index 1603 DPO RxPDO-Map Extended Diag Outputs Ch.2

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Standard objects [image] Index 1603 DPO RxPDO-Map Extended Diag Outputs Ch.2
Index 1603 DPO RxPDO-Map Extended Diag Outputs Ch.2
Index | Name | Meaning | Data type | Flags | Default
1603:0 | DPO RxPDO-Map Extended Diag Outputs Ch.2 | PDO Mapping RxPDO 4 | UINT8 | RO | 0x02 (2dec)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7030 (DPO Outputs Ch.4), entry 0x01 (Output Us)) | UINT32 | RO | 0x7010:11, 1
1603:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7030 (DPO Outputs Ch.4), entry 0x02 (Output Up)) | UINT32 | RO | 0x0000:00, 15


Index 1604 DPO RxPDO-Map Outputs Ch.3

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Standard objects [image] Index 1604 DPO RxPDO-Map Outputs Ch.3
Index 1604 DPO RxPDO-Map Outputs Ch.3
Index | Name | Meaning | Data type | Flags | Default
1604:0 | DPO RxPDO-Map Outputs Ch.3 | PDO Mapping RxPDO 5 | UINT8 | RO | 0x06 (6dec)
1604:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (DPO Outputs Ch.3), entry 0x01 (Output Us)) | UINT32 | RO | 0x7020:01, 1
1604:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7020 (DPO Outputs Ch.3), entry 0x02 (Output Up)) | UINT32 | RO | 0x7020:02, 1
1604:03 | SubIndex 003 | 3. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1604:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7020 (DPO Outputs Ch.3), entry 0x05 (Reset Us)) | UINT32 | RO | 0x7020:05, 1
1604:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7020 (DPO Outputs Ch.3), entry 0x06 (Reset Up)) | UINT32 | RO | 0x7020:06, 1
1604:06 | SubIndex 006 | 6. PDO Mapping entry (10 bits align) | UINT32 | RO | 0x0000:00, 10


Index 1605 DPO RxPDO-Map Extended Diag Outputs Ch.3

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Standard objects [image] Index 1605 DPO RxPDO-Map Extended Diag Outputs Ch.3
Index 1605 DPO RxPDO-Map Extended Diag Outputs Ch.3
Index | Name | Meaning | Data type | Flags | Default
1605:0 | DPO RxPDO-Map Extended Diag Outputs Ch.3 | PDO Mapping RxPDO 6 | UINT8 | RO | 0x02 (2dec)
1605:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (DPO Outputs Ch.3), entry 0x11 (Reset Extended Diag Data)) | UINT32 | RO | 0x7020:11, 1
1605:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15


Index 1606 DPO RxPDO-Map Outputs Ch.4

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Standard objects [image] Index 1606 DPO RxPDO-Map Outputs Ch.4
Index 1606 DPO RxPDO-Map Outputs Ch.4
Index | Name | Meaning | Data type | Flags | Default
1606:0 | DPO RxPDO-Map Outputs Ch.4 | PDO Mapping RxPDO 7 | UINT8 | RO | 0x06 (6dec)
1606:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7030 (DPO Outputs Ch.4), entry 0x01 (Output Us)) | UINT32 | RO | 0x7030:01, 1
1606:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7030 (DPO Outputs Ch.4), entry 0x02 (Output Up)) | UINT32 | RO | 0x7030:02, 1
1606:03 | SubIndex 003 | 3. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1606:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7030 (DPO Outputs Ch.4), entry 0x05 (Reset Us)) | UINT32 | RO | 0x7030:05, 1
1606:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7030 (DPO Outputs Ch.4), entry 0x06 (Reset Up)) | UINT32 | RO | 0x7030:06, 1
1606:06 | SubIndex 006 | 6. PDO Mapping entry (10 bits align) | UINT32 | RO | 0x0000:00, 10


Index 1607 DPO RxPDO-Map Extended Diag Outputs Ch.4

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Standard objects [image] Index 1607 DPO RxPDO-Map Extended Diag Outputs Ch.4
Index 1607 DPO RxPDO-Map Extended Diag Outputs Ch.4
Index | Name | Meaning | Data type | Flags | Default
1607:0 | DPO RxPDO-Map Extended Diag Outputs Ch.4 | PDO Mapping RxPDO 8 | UINT8 | RO | 0x02 (2dec)
1607:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7030 (DPO Outputs Ch.4), entry 0x11 (Reset Extended Diag Data)) | UINT32 | RO | 0x7030:11, 1
1607:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15


Index 1608 DPO RxPDO-Map Outputs Device

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Standard objects [image] Index 1608 DPO RxPDO-Map Outputs Device
Index 1608 DPO RxPDO-Map Outputs Device
Index | Name | Meaning | Data type | Flags | Default
1608:0 | DPO RxPDO-Map Outputs Device | PDO Mapping RxPDO 9 | UINT8 | RO | 0x04 (4dec)
1608:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF707 (DPO Outputs Device), entry 0x01 (Enable Control Via Fieldbus)) | UINT32 | RO | 0xF707:01, 1
1608:02 | SubIndex 002 | 2. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1608:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF707 (DPO Outputs Device), entry 0x04 (Global Reset)) | UINT32 | RO | 0xF707:04, 1
1608:04 | SubIndex 004 | 4. PDO Mapping entry (12 bits align) | UINT32 | RO | 0x0000:00, 12


Index 1609 DPO RxPDO-Map Extended Diag Outputs Device

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Standard objects [image] Index 1609 DPO RxPDO-Map Extended Diag Outputs Device
Index 1609 DPO RxPDO-Map Extended Diag Outputs Device
Index | Name | Meaning | Data type | Flags | Default
1609:0 | DPO RxPDO-Map Extended Diag Outputs Device | PDO Mapping RxPDO 10 | UINT8 | RO | 0x02 (2dec)
1609:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF707 (DPO Outputs Device), entry 0x11 (Reset Extended Diag Data)) | UINT32 | RO | 0xF707:11, 1
1609:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15


Index 1610 LOG RxPDO-Map Contr

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Standard objects [image] Index 1610 LOG RxPDO-Map Contr
Index 1610 LOG RxPDO-Map Contr
Index | Name | Meaning | Data type | Flags | Default
1610:0 | LOG RxPDO-Map Control | PDO Mapping RxPDO 17 | UINT8 | RO | 0x03 (3dec)
1610:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7040 (LOG Control), entry 0x01 (Start Logger)) | UINT32 | RO | 0x7040:01, 1
1610:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7040 (LOG Control), entry 0x02 (Stop Logger)) | UINT32 | RO | 0x7040:02, 1
1610:03 | SubIndex 003 | 3. PDO Mapping entry (14 bits align) | UINT32 | RO | 0x0000:00, 14


Index 1A00 DPO TxPDO-Map Inputs Ch.1

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Standard objects [image] Index 1A00 DPO TxPDO-Map Inputs Ch.1
Index 1A00 DPO TxPDO-Map Inputs Ch.1
Index | Name | Meaning | Data type | Flags | Default
1A00:0 | DPO TxPDO-Map Inputs Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x0E (14dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (DPO Inputs Ch.1), entry 0x01 (Error Us)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (DPO Inputs Ch.1), entry 0x02 (Error Up)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (DPO Inputs Ch.1), entry 0x03 (Warning Us)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (DPO Inputs Ch.1), entry 0x04 (Warning Up)) | UINT32 | RO | 0x6000:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (DPO Inputs Ch.1), entry 0x05 (Status Us)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (DPO Inputs Ch.1), entry 0x06 (Status Up)) | UINT32 | RO | 0x6000:06, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (DPO Inputs Ch.1), entry 0x07 (Channel Error)) | UINT32 | RO | 0x6000:07, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (DPO Inputs Ch.1), entry 0x08 (Error Sum Current)) | UINT32 | RO | 0x6000:08, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (DPO Inputs Ch.1), entry 0x09 (Warning Sum Current)) | UINT32 | RO | 0x6000:09, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 5
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (DPO Inputs Ch.1), entry 0x0E (Sync error)) | UINT32 | RO | 0x6000:0F, 1
1A00:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (DPO Inputs Ch.1), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6000:10, 1
1A00:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6000 (DPO Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6000:11, 16
1A00:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6000 (DPO Inputs Ch.1), entry 0x11 (Current Us)) | UINT32 | RO | 0x6000:12, 16


Index 1A01 DPO TxPDO-Map Extended Diag Inputs Ch.1

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Standard objects [image] Index 1A01 DPO TxPDO-Map Extended Diag Inputs Ch.1
Index 1A01 DPO TxPDO-Map Extended Diag Inputs Ch.1
Index | Name | Meaning | Data type | Flags | Default
1A01:0 | DPO TxPDO-Map Extended Diag Inputs Ch.1 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x04 (4dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (DPO Inputs Ch.1), entry 0x13 (Maximum Current Us)) | UINT32 | RO | 0x6000:13, 16
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (DPO Inputs Ch.1), entry 0x14 (Maximum Current Up)) | UINT32 | RO | 0x6000:14, 16
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (DPO Inputs Ch.1), entry 0x15 (Minimum Current Us)) | UINT32 | RO | 0x6000:17, 64
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (DPO Inputs Ch.1), entry 0x16 (Minimum Current Up)) | UINT32 | RO | 0x6000:18, 64


Index 1A02 DPO TxPDO-Map Inputs Ch.2

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Standard objects [image] Index 1A02 DPO TxPDO-Map Inputs Ch.2
Index 1A02 DPO TxPDO-Map Inputs Ch.2
Index | Name | Meaning | Data type | Flags | Default
1A02:0 | DPO TxPDO-Map Inputs Ch.2 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x0E (14dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DPO Inputs Ch.2), entry 0x01 (Error Us)) | UINT32 | RO | 0x6010:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (DPO Inputs Ch.2), entry 0x02 (Error Up)) | UINT32 | RO | 0x6010:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (DPO Inputs Ch.2), entry 0x03 (Warning Us)) | UINT32 | RO | 0x6010:03, 1
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (DPO Inputs Ch.2), entry 0x04 (Warning Up)) | UINT32 | RO | 0x6010:04, 1
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (DPO Inputs Ch.2), entry 0x05 (Status Us)) | UINT32 | RO | 0x6010:05, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (DPO Inputs Ch.2), entry 0x06 (Status Up)) | UINT32 | RO | 0x6010:06, 1
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (DPO Inputs Ch.2), entry 0x07 (Channel Error)) | UINT32 | RO | 0x6010:07, 1
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (DPO Inputs Ch.2), entry 0x08 (Error Sum Current)) | UINT32 | RO | 0x6010:08, 1
1A02:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6010 (DPO Inputs Ch.2), entry 0x09 (Warning Sum Current)) | UINT32 | RO | 0x6010:09, 1
1A02:0A | SubIndex 010 | 10. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 5
1A02:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6010 (DPO Inputs Ch.2), entry 0x0E (Sync error)) | UINT32 | RO | 0x6010:0F, 1
1A02:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6010 (DPO Inputs Ch.2), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6010:10, 1
1A02:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6010 (DPO Inputs Ch.2), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6010:11, 16
1A02:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6010 (DPO Inputs Ch.2), entry 0x11 (Current Us)) | UINT32 | RO | 0x6010:12, 16


Index 1A03 DPO TxPDO-Map Extended Diag Inputs Ch.2

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Standard objects [image] Index 1A03 DPO TxPDO-Map Extended Diag Inputs Ch.2
Index 1A03 DPO TxPDO-Map Extended Diag Inputs Ch.2
Index | Name | Meaning | Data type | Flags | Default
1A03:0 | DPO TxPDO-Map Extended Diag Inputs Ch.2 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x04 (4dec)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DPO Inputs Ch.2), entry 0x13 (Maximum Current Us)) | UINT32 | RO | 0x6010:13, 16
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (DPO Inputs Ch.2), entry 0x14 (Maximum Current Up)) | UINT32 | RO | 0x6010:14, 16
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (DPO Inputs Ch.2), entry 0x15 (Minimum Current Us)) | UINT32 | RO | 0x6010:17, 64
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (DPO Inputs Ch.2), entry 0x16 (Minimum Current Up)) | UINT32 | RO | 0x6010:18, 64


Index 1A04 DPO TxPDO-Map Inputs Ch.3

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Standard objects [image] Index 1A04 DPO TxPDO-Map Inputs Ch.3
Index 1A04 DPO TxPDO-Map Inputs Ch.3
Index | Name | Meaning | Data type | Flags | Default
1A04:0 | DPO TxPDO-Map Inputs Ch.3 | PDO Mapping TxPDO 5 | UINT8 | RO | 0x0E (14dec)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (DPO Inputs Ch.3), entry 0x01 (Error Us)) | UINT32 | RO | 0x6020:01, 1
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (DPO Inputs Ch.3), entry 0x02 (Error Up)) | UINT32 | RO | 0x6020:02, 1
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (DPO Inputs Ch.3), entry 0x03 (Warning Us)) | UINT32 | RO | 0x6020:03, 1
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (DPO Inputs Ch.3), entry 0x04 (Warning Up)) | UINT32 | RO | 0x6020:04, 1
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (DPO Inputs Ch.3), entry 0x05 (Status Us)) | UINT32 | RO | 0x6020:05, 1
1A04:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6020 (DPO Inputs Ch.3), entry 0x06 (Status Up)) | UINT32 | RO | 0x6020:06, 1
1A04:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020 (DPO Inputs Ch.3), entry 0x07 (Channel Error)) | UINT32 | RO | 0x6020:07, 1
1A04:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6020 (DPO Inputs Ch.3), entry 0x08 (Error Sum Current)) | UINT32 | RO | 0x6020:08, 1
1A04:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6020 (DPO Inputs Ch.3), entry 0x09 (Warning Sum Current)) | UINT32 | RO | 0x6020:09, 1
1A04:0A | SubIndex 010 | 10. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 5
1A04:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6020 (DPO Inputs Ch.3), entry 0x0E (Sync error)) | UINT32 | RO | 0x6020:0F, 1
1A04:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6020 (DPO Inputs Ch.3), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6020:10, 1
1A04:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6020 (DPO Inputs Ch.3), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6020:11, 16
1A04:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6020 (DPO Inputs Ch.3), entry 0x11 (Current Us)) | UINT32 | RO | 0x6020:12, 16


Index 1A05 DPO TxPDO-Map Extended Diag Inputs Ch.3

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Standard objects [image] Index 1A05 DPO TxPDO-Map Extended Diag Inputs Ch.3
Index 1A05 DPO TxPDO-Map Extended Diag Inputs Ch.3
Index | Name | Meaning | Data type | Flags | Default
1A05:0 | DPO TxPDO-Map Extended Diag Inputs Ch.3 | PDO Mapping TxPDO 6 | UINT8 | RO | 0x04 (4dec)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (DPO Inputs Ch.3), entry 0x13 (Maximum Current Us)) | UINT32 | RO | 0x6020:13, 16
1A05:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (DPO Inputs Ch.3), entry 0x14 (Maximum Current Up)) | UINT32 | RO | 0x6020:14, 16
1A05:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (DPO Inputs Ch.3), entry 0x15 (Minimum Current Us)) | UINT32 | RO | 0x6020:17, 64
1A05:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (DPO Inputs Ch.3), entry 0x16 (Minimum Current Up)) | UINT32 | RO | 0x6020:18, 64


Index 1A06 DPO TxPDO-Map Inputs Ch.4

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Standard objects [image] Index 1A06 DPO TxPDO-Map Inputs Ch.4
Index 1A06 DPO TxPDO-Map Inputs Ch.4
Index | Name | Meaning | Data type | Flags | Default
1A06:0 | DPO TxPDO-Map Inputs Ch.4 | PDO Mapping TxPDO 7 | UINT8 | RO | 0x0E (14dec)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6030 (DPO Inputs Ch.4), entry 0x01 (Error Us)) | UINT32 | RO | 0x6030:01, 1
1A06:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6030 (DPO Inputs Ch.4), entry 0x02 (Error Up)) | UINT32 | RO | 0x6030:02, 1
1A06:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6030 (DPO Inputs Ch.4), entry 0x03 (Warning Us)) | UINT32 | RO | 0x6030:03, 1
1A06:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6030 (DPO Inputs Ch.4), entry 0x04 (Warning Up)) | UINT32 | RO | 0x6030:04, 1
1A06:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6030 (DPO Inputs Ch.4), entry 0x05 (Status Us)) | UINT32 | RO | 0x6030:05, 1
1A06:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6030 (DPO Inputs Ch.4), entry 0x06 (Status Up)) | UINT32 | RO | 0x6030:06, 1
1A06:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6030 (DPO Inputs Ch.4), entry 0x07 (Channel Error)) | UINT32 | RO | 0x6030:07, 1
1A06:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6030 (DPO Inputs Ch.4), entry 0x08 (Error Sum Current)) | UINT32 | RO | 0x6030:08, 1
1A06:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6030 (DPO Inputs Ch.4), entry 0x09 (Warning Sum Current)) | UINT32 | RO | 0x6030:09, 1
1A06:0A | SubIndex 010 | 10. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 5
1A06:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6030 (DPO Inputs Ch.4), entry 0x0E (Sync error)) | UINT32 | RO | 0x6030:0F, 1
1A06:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6030 (DPO Inputs Ch.4), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6030:10, 1
1A06:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6030 (DPO Inputs Ch.4), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6030:11, 16
1A06:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6030 (DPO Inputs Ch.4), entry 0x11 (Current Us)) | UINT32 | RO | 0x6030:12, 16


Index 1A07 DPO TxPDO-Map Extended Diag Inputs Ch.4

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Standard objects [image] Index 1A07 DPO TxPDO-Map Extended Diag Inputs Ch.4
Index 1A07 DPO TxPDO-Map Extended Diag Inputs Ch.4
Index | Name | Meaning | Data type | Flags | Default
1A07:0 | DPO TxPDO-Map Extended Diag Inputs Ch.4 | PDO Mapping TxPDO 8 | UINT8 | RO | 0x04 (4dec)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6030 (DPO Inputs Ch.4), entry 0x13 (Maximum Current Us)) | UINT32 | RO | 0x6030:13, 16
1A07:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6030 (DPO Inputs Ch.4), entry 0x14 (Maximum Current Up)) | UINT32 | RO | 0x6030:14, 16
1A07:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6030 (DPO Inputs Ch.4), entry 0x15 (Minimum Current Us)) | UINT32 | RO | 0x6030:17, 64
1A07:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6030 (DPO Inputs Ch.4), entry 0x16 (Minimum Current Up)) | UINT32 | RO | 0x6030:18, 64


Index 1A08 DPO TxPDO-Map Inputs Device

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Standard objects [image] Index 1A08 DPO TxPDO-Map Inputs Device
Index 1A08 DPO TxPDO-Map Inputs Device
Index | Name | Meaning | Data type | Flags | Default
1A08:0 | DPO TxPDO-Map Inputs Device | PDO Mapping TxPDO 9 | UINT8 | RO | 0x13 (19dec)
1A08:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF607 (DPO Inputs Device), entry 0x01 (Temperature Warning)) | UINT32 | RO | 0xF607:01, 1
1A08:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF607 (DPO Inputs Device), entry 0x02 (Temperature Error)) | UINT32 | RO | 0xF607:02, 1
1A08:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF607 (DPO Inputs Device), entry 0x03 (Us Warning)) | UINT32 | RO | 0xF607:03, 1
1A08:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF607 (DPO Inputs Device), entry 0x04 (Us Error)) | UINT32 | RO | 0xF607:04, 1
1A08:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF607 (DPO Inputs Device), entry 0x05 (Up Warning)) | UINT32 | RO | 0xF607:05, 1
1A08:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF607 (DPO Inputs Device), entry 0x06 (Up Error)) | UINT32 | RO | 0xF607:06, 1
1A08:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF607 (DPO Inputs Device), entry 0x07 (Global Error Bit)) | UINT32 | RO | 0xF607:07, 1
1A08:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF607 (DPO Inputs Device), entry 0x08 (Sum Current Warning)) | UINT32 | RO | 0xF607:08, 1
1A08:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF607 (DPO Inputs Device), entry 0x09 (Sum Current Error)) | UINT32 | RO | 0xF607:09, 1
1A08:0A | SubIndex 010 | 10. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A08:0B | SubIndex 011 | 11. PDO Mapping entry (object 0xF607 (DPO Inputs Device), entry 0x0C (Reset Input)) | UINT32 | RO | 0xF607:0C, 1
1A08:0C | SubIndex 012 | 12. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A08:0D | SubIndex 013 | 13. PDO Mapping entry (object 0xF607 (DPO Inputs Device), entry 0x0F (TxPDO State)) | UINT32 | RO | 0xF607:0F, 1
1A08:0E | SubIndex 014 | 14. PDO Mapping entry (object 0xF607 (DPO Inputs Device), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0xF607:10, 1
1A08:0F | SubIndex 015 | 15. PDO Mapping entry (object 0xF607 (DPO Inputs Device), entry 0x11 (Current Us)) | UINT32 | RO | 0xF607:11, 16
1A08:10 | SubIndex 016 | 16. PDO Mapping entry (object 0xF607 (DPO Inputs Device), entry 0x12 (Current Up)) | UINT32 | RO | 0xF607:12, 16
1A08:11 | SubIndex 017 | 17. PDO Mapping entry (object 0xF607 (DPO Inputs Device), entry 0x13 (Voltage Us)) | UINT32 | RO | 0xF607:13, 16
1A08:12 | SubIndex 018 | 18. PDO Mapping entry (object 0xF607 (DPO Inputs Device), entry 0x14 (Voltage Up)) | UINT32 | RO | 0xF607:14, 16
1A08:13 | SubIndex 019 | 19. PDO Mapping entry (object 0xF607 (DPO Inputs Device), entry 0x15 (Temperature)) | UINT32 | RO | 0xF607:15, 16


Index 1A09 DPO TxPDO-Map Extended Diag Inputs Device

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Standard objects [image] Index 1A09 DPO TxPDO-Map Extended Diag Inputs Device
Index 1A09 DPO TxPDO-Map Extended Diag Inputs Device
Index | Name | Meaning | Data type | Flags | Default
1A09:0 | DPO TxPDO-Map Extended Diag Inputs Device | PDO Mapping TxPDO 10 | UINT8 | RO | 0x04 (4dec)
1A09:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF607 (DPO Inputs Device), entry 0x16 (Peak Value 1)) | UINT32 | RO | 0xF607:16, 16
1A09:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF607 (DPO Inputs Device), entry 0x17 (Peak Value 2)) | UINT32 | RO | 0xF607:17, 16
1A09:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF607 (DPO Inputs Device), entry 0x18 (Timestamp 1)) | UINT32 | RO | 0xF607:18, 64
1A09:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF607 (DPO Inputs Device), entry 0x19 (Timestamp 2)) | UINT32 | RO | 0xF607:19, 64


Index 1A10 LOG TxPDO-Map Status

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Standard objects [image] Index 1A10 LOG TxPDO-Map Status
Index 1A10 LOG TxPDO-Map Status
Index | Name | Meaning | Data type | Flags | Default
1A10:0 | LOG TxPDO-Map Status | PDO Mapping TxPDO 17 | UINT8 | RO | 0x04 (4dec)
1A10:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6040 (LOG Status), entry 0x01 (Logger Running)) | UINT32 | RO | 0x6040:01, 1
1A10:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1A10:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6040 (LOG Status), entry 0x11 (Elapsed Time)) | UINT32 | RO | 0x6040:11, 32
1A10:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6040 (LOG Status), entry 0x12 (Trigger Reason)) | UINT32 | RO | 0x6040:12, 16


Index 1C00 Sync manager type

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Standard objects [image] Index 1C00 Sync manager type
Index 1C00 Sync manager type
Index | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the Sync Managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)


Index 1C12 RxPDO assign

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Standard objects [image] Index 1C12 RxPDO assign
Index 1C12 RxPDO assign
Index | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x05 (5dec)
1C12:01 | Subindex 001 | 1. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1600 (5632dec)
1C12:02 | Subindex 002 | 2. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1602 (5634dec)
1C12:03 | Subindex 003 | 3. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1604 (5636dec)
1C12:04 | Subindex 004 | 4. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1606 (5638dec)
1C12:05 | Subindex 005 | 5. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1608 (5640dec)
1C12:06 | Subindex 006 | 6. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:07 | Subindex 007 | 7. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:08 | Subindex 008 | 8. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:09 | Subindex 009 | 9. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:0A | Subindex 010 | 10. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:0B | Subindex 011 | 11. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)


Index 1C13 TxPDO assign

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Standard objects [image] Index 1C13 TxPDO assign
Index 1C13 TxPDO assign
Index | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x05 (5dec)
1C13:01 | Subindex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A02 (6658dec)
1C13:03 | Subindex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A04 (6660dec)
1C13:04 | Subindex 004 | 4. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A06 (6662dec)
1C13:05 | Subindex 005 | 5. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A08 (6664dec)
1C13:06 | Subindex 006 | 6. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:07 | Subindex 007 | 7. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:08 | Subindex 008 | 8. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:09 | Subindex 009 | 9. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0A | Subindex 010 | 10. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0B | Subindex 011 | 11. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)


Index 1C32 SM output parameter

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Standard objects [image] Index 1C32 SM output parameter
Index 1C32 SM output parameter
Index
Name
Meaning
Data type
Flags
Default
1C32:0
SM output parameter
Synchronization parameters for the outputs
UINT8
RO
0x20 (32dec)
1C32:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0000 (0dec)
1C32:02
Cycle time
Cycle time (in ns):
▪
Free Run: Cycle time of the local timer
▪
Synchron with SM 2 Event: Master cycle time
▪
DC mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dec)
1C32:03
Shift time
Time between SYNC0 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000384 (900dec)
1C32:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0 = 1: free run is supported
▪
Bit 1 = 1: Synchron with SM 2 Event is supported
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 10: Output Shift with SYNC1 event (only DC mode)
▪
Bit 14 = 1: dynamic times (measurement through writing of 1C32:08)
UINT16
RO
0x0001 (1dec)
1C32:05
Minimum cycle time
Minimum cycle time (in ns)
UINT32
RO
0x000F4240 (1000000dec)
1C32:06
Calc and copy time
Minimum time between SYNC0 and SYNC1 event (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:07
Minimum delay time
UINT32
RO
0x00000384 (900dec)
1C32:08
Command
▪
0: Measurement of the local cycle time is stopped
▪
1: Measurement of the local cycle time is started
The entries 1C32:03, 1C32:05, 1C32:06, 1C32:09, 1C33:03, 1C33:06, 1C33:09 are updated with the maximum measured values.
For a subsequent measurement the measured values are reset
UINT16
RW
0x0000 (0dec)
1C32:09
Maximum delay time
Time between SYNC1 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000384 (900dec)
1C32:0B
SM event missed counter
Number of missed SM events in OPERATIONAL (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:0C
Cycle exceeded counter
Number of occasions the cycle time was exceeded in OPERATIONAL (cycle was not completed in time or the next cycle began too early)
UINT16
RO
0x0000 (0dec)
1C32:0D
Shift too short counter
Number of occasions that the interval between SYNC0 and SYNC1 event was too short (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:20
Sync error
The synchronization was not correct in the last cycle (outputs were output too late; DC mode only)
boolean
RO
0x00 (0dec)


Index 1C33 SM input parameter

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Standard objects [image] Index 1C33 SM input parameter
Index 1C33 SM input parameter
Index
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (no outputs available)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (outputs available)
UINT16
RW
0x0000 (0dec)
1C33:02
Cycle time
as 1C32:02
UINT32
RW
0x000F4240 (1000000dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000384 (900dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: Synchron with SM 2 Event is supported (outputs available)
▪
Bit 1: Synchron with SM 3 Event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: Input Shift through local event (outputs available)
▪
Bit 4-5 = 10: Input Shift with SYNC1 Event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 1C32:08 or 1C33:08)
UINT16
RO
0x0001 (1dec)
1C33:05
Minimum cycle time
Minimum cycle time (in ns)
UINT32
RO
0x000F4240 (1000000dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:07
Minimum delay time
UINT32
RO
0x00000384 (900dec)
1C33:08
Command
▪
0: Measurement of the local cycle time is stopped
▪
1: Measurement of the local cycle time is started
The entries 1C32:03, 1C32:05, 1C32:06, 1C32:09, 1C33:03, 1C33:06, 1C33:09 are updated with the maximum measured values.
For a subsequent measurement the measured values are reset
UINT16
RW
0x0000 (0dec)
1C33:09
Maximum delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000384 (900dec)
1C33:0B
SM event missed counter
as 1C32:11
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
as 1C32:12
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
as 1C32:13
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
as 1C32:32
boolean
RO
0x00 (0dec)


Profile-specific objects (0x6000-0xFFFF)

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF)
Profile-specific objects (0x6000-0xFFFF)
The profile-specific objects have the same meaning for all EtherCAT slaves that support the profile 5001.
Additional information
•
Index 6000 DPO Inputs Ch.1
•
Index 6010 DPO Inputs Ch.2
•
Index 6020 DPO Inputs Ch.3
•
Index 6030 DPO Inputs Ch.4
•
Index 6040 LOG Status
•
Index 7000 DPO Outputs Ch.1
•
Index 7010 DPO Outputs Ch.2
•
Index 7020 DPO Outputs Ch.3
•
Index 7030 DPO Outputs Ch.4
•
Index 7040 LOG Control
•
Index 800F DPO Vendor data Ch.1
•
Index 801F DPO Vendor data Ch.2
•
Index 802F DPO Vendor data Ch.3
•
Index 803F DPO Vendor data Ch.4
•
Index F000 Modular device profile
•
Index F008 Code word
•
Index F010 Module list
•
Index F81F DPO Vendor Data Device


Index 6000 DPO Inputs Ch.1

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF) [image] Index 6000 DPO Inputs Ch.1
Index 6000 DPO Inputs Ch.1
Index | Name | Meaning | Data type | Flags | Default
6000:0 | DPO Inputs Ch.1 | Input of the first channel | UINT8 | RO | 0x18 (24dec)
6000:01 | Error Us | The current monitoring of Us has tripped. The bit must be reset by a Global Reset (F707:04) or by the corresponding Reset Us (7000:05). The output cannot be enabled as long as the bit is set. | boolean | RO | 0x00 (0dec)
6000:02 | Error Up | The current monitoring of Up has tripped. The bit must be reset by a Global Reset (F707:04) or by the corresponding Reset Up (7000:06). The output cannot be enabled as long as the bit is set. | boolean | RO | 0x00 (0dec)
6000:03 | Warning Us | The monitoring has detected overcurrent; the switching off of output Us on this channel is imminent if the current consumption of the junction does not decrease. | boolean | RO | 0x00 (0dec)
6000:04 | Warning Up | The monitoring has detected overcurrent; the switching off of output Us on this channel is imminent if the current consumption of the junction does not decrease. | boolean | RO | 0x00 (0dec)
6000:05 | Status Us | 0: The output is switched off 1: The output supplies 24 V | boolean | RO | 0x00 (0dec)
6000:06 | Status Up | 0: The output is switched off 1: The output supplies 24 V | boolean | RO | 0x00 (0dec)
6000:07 | Channel Error | 6000:01 or 6000:02 are set | boolean | RO | 0x00 (0dec)
6000:08 | Error Sum Current | Sum current of the channel was exceeded. Therefore, the output has been switched off. An active reset is required in order to restart. | boolean | RO | 0x00 (0dec)
6000:09 | Warning Sum Current | Overcurrent peak was detected in the sum current. If the load on the output remains unchanged it will switch off. | boolean | RO | 0x00 (0dec)
6000:0F | TxPDO State |  | boolean | RO | 0x00 (0dec)
6000:10 | TxPDO Toggle |  | boolean | RO | 0x00 (0dec)
6000:11 | Current Us | Current off Us | INT16 | RO | 0x0000 (0dec)
6000:12 | Current Up | Current off Up | INT16 | RO | 0x0000 (0dec)
6000:13 | Peak Value 1 | Peak value of the 1st variable measured on the extended diagnosis for channel 1. | INT16 | RO | 0x0000 (0dec)
6000:14 | Peak Value 2 | Peak value of the 2nd variable measured on the extended diagnosis for channel 1. | INT16 | RO | 0x0000 (0dec)
6000:17 | Timestamp 1 | Timestamp at which the peak value 6000:13 was measured | UINT64 | RO |
6000:18 | Timestamp 2 | Timestamp at which the peak value 6000:14 was measured | UINT64 | RO |


Index 6010 DPO Inputs Ch.2

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF) [image] Index 6010 DPO Inputs Ch.2
Index 6010 DPO Inputs Ch.2
Index | Name | Meaning | Data type | Flags | Default
6010:0 | DPO Inputs Ch.2 | Inputs of the second channel | UINT8 | RO | 0x18 (24dec)
6010:01 | Error Us | The current monitoring of Us has tripped. The bit must be reset by a Global Reset (F707:04) or by the corresponding Reset Us (7010:05). The output cannot be enabled as long as the bit is set. | boolean | RO | 0x00 (0dec)
6010:02 | Error Up | The current monitoring of Up has tripped. The bit must be reset by a Global Reset (F707:04) or by the corresponding Reset Up (7010:06). The output cannot be enabled as long as the bit is set. | boolean | RO | 0x00 (0dec)
6010:03 | Warning Us | The monitoring has detected overcurrent; the switching off of output Us on this channel is imminent if the current consumption of the junction does not decrease. | boolean | RO | 0x00 (0dec)
6010:04 | Warning Up | The monitoring has detected overcurrent; the switching off of output Us on this channel is imminent if the current consumption of the junction does not decrease. | boolean | RO | 0x00 (0dec)
6010:05 | Status Us | 0: The output is switched off 1: The output supplies 24 V | boolean | RO | 0x00 (0dec)
6010:06 | Status Up | 0: The output is switched off 1: The output supplies 24 V | boolean | RO | 0x00 (0dec)
6010:07 | Channel Error | 6010:01 or 6010:02 are set | boolean | RO | 0x00 (0dec)
6010:08 | Error Sum Current |  | boolean | RO | 0x00 (0dec)
6010:09 | Warning Sum Current |  | boolean | RO | 0x00 (0dec)
6010:0F | TxPDO State |  | boolean | RO | 0x00 (0dec)
6010:10 | TxPDO Toggle |  | boolean | RO | 0x00 (0dec)
6010:11 | Current Us | Current off Us | INT16 | RO | 0x0000 (0dec)
6010:12 | Current Up | Current off Up | INT16 | RO | 0x0000 (0dec)
6010:13 | Peak Value 1 | Peak value of the 1st variable measured on the extended diagnosis for channel 2. | INT16 | RO | 0x0000 (0dec)
6010:14 | Peak Value 2 | Peak value of the 2nd variable measured on the extended diagnosis for channel 2. | INT16 | RO | 0x0000 (0dec)
6010:17 | Timestamp 1 | Timestamp at which the peak value 6010:13 was measured | UINT64 | RO |
6010:18 | Timestamp 2 | Timestamp at which the peak value 6010:14 was measured | UINT64 | RO |


Index 6020 DPO Inputs Ch.3

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF) [image] Index 6020 DPO Inputs Ch.3
Index 6020 DPO Inputs Ch.3
Index | Name | Meaning | Data type | Flags | Default
6020:0 | DPO Inputs Ch.3 | Inputs of the third channel | UINT8 | RO | 0x18 (24dec)
6020:01 | Error Us | The current monitoring of Us has tripped. The bit must be reset by a Global Reset (F707:04) or by the corresponding Reset Us (7020:05). The output cannot be enabled as long as the bit is set. | boolean | RO | 0x00 (0dec)
6020:02 | Error Up | The current monitoring of Up has tripped. The bit must be reset by a Global Reset (F707:04) or by the corresponding Reset Up (7020:06). The output cannot be enabled as long as the bit is set. | boolean | RO | 0x00 (0dec)
6020:03 | Warning Us | The monitoring has detected overcurrent; the switching off of output Us on this channel is imminent if the current consumption of the junction does not decrease. | boolean | RO | 0x00 (0dec)
6020:04 | Warning Up | The monitoring has detected overcurrent; the switching off of output Us on this channel is imminent if the current consumption of the junction does not decrease. | boolean | RO | 0x00 (0dec)
6020:05 | Status Us | 0: The output is switched off 1: The output supplies 24 V | boolean | RO | 0x00 (0dec)
6020:06 | Status Up | 0: The output is switched off 1: The output supplies 24 V | boolean | RO | 0x00 (0dec)
6020:07 | Channel Error | 6020:01 or 6020:02 are set | boolean | RO | 0x00 (0dec)
6020:08 | Error Sum Current |  | boolean | RO | 0x00 (0dec)
6020:09 | Warning Sum Current |  | boolean | RO | 0x00 (0dec)
6020:0F | TxPDO State |  | boolean | RO | 0x00 (0dec)
6020:10 | TxPDO Toggle |  | boolean | RO | 0x00 (0dec)
6020:11 | Current Us | Current off Us | INT16 | RO | 0x0000 (0dec)
6020:12 | Current Up | Current off Up | INT16 | RO | 0x0000 (0dec)
6020:13 | Peak Value 1 | Peak value of the 1st variable measured on the extended diagnosis for channel 3. | INT16 | RO | 0x0000 (0dec)
6020:14 | Peak Value 2 | Peak value of the 2nd variable measured on the extended diagnosis for channel 3. | INT16 | RO | 0x0000 (0dec)
6020:17 | Timestamp 1 | Timestamp at which the peak value 6020:13 was measured | UINT64 | RO |
6020:18 | Timestamp 2 | Timestamp at which the peak value 6020:14 was measured | UINT64 | RO |


Index 6030 DPO Inputs Ch.4

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF) [image] Index 6030 DPO Inputs Ch.4
Index 6030 DPO Inputs Ch.4
Index | Name | Meaning | Data type | Flags | Default
6030:0 | DPO Inputs Ch.4 | Inputs of the fourth channel | UINT8 | RO | 0x18 (24dec)
6030:01 | Error Us | The current monitoring of Us has tripped. The bit must be reset by a Global Reset (F707:04) or by the corresponding Reset Us (7030:05). The output cannot be enabled as long as the bit is set. | boolean | RO | 0x00 (0dec)
6030:02 | Error Up | The current monitoring of Up has tripped. The bit must be reset by a Global Reset (F707:04) or by the corresponding Reset Up (7030:06). The output cannot be enabled as long as the bit is set. | boolean | RO | 0x00 (0dec)
6030:03 | Warning Us | The monitoring has detected overcurrent; the switching off of output Us on this channel is imminent if the current consumption of the junction does not decrease. | boolean | RO | 0x00 (0dec)
6030:04 | Warning Up | The monitoring has detected overcurrent; the switching off of output Us on this channel is imminent if the current consumption of the junction does not decrease. | boolean | RO | 0x00 (0dec)
6030:05 | Status Us | 0: The output is switched off 1: The output supplies 24 V | boolean | RO | 0x00 (0dec)
6030:06 | Status Up | 0: The output is switched off 1: The output supplies 24 V | boolean | RO | 0x00 (0dec)
6030:07 | Channel Error | 6020:01 or 6020:02 are set | boolean | RO | 0x00 (0dec)
6030:08 | Error Sum Current |  | boolean | RO | 0x00 (0dec)
6030:09 | Warning Sum Current |  | boolean | RO | 0x00 (0dec)
6030:0F | TxPDO State |  | boolean | RO | 0x00 (0dec)
6030:10 | TxPDO Toggle |  | boolean | RO | 0x00 (0dec)
6030:11 | Current Us | Current off Us | INT16 | RO | 0x0000 (0dec)
6030:12 | Current Up | Current off Up | INT16 | RO | 0x0000 (0dec)
6030:13 | Peak Value 1 | Peak value of the 1st variable measured on the extended diagnosis for channel 4. | INT16 | RO | 0x0000 (0dec)
6030:14 | Peak Value 2 | Peak value of the 2nd variable measured on the extended diagnosis for channel 4. | INT16 | RO | 0x0000 (0dec)
6030:17 | Timestamp 1 | Timestamp at which the peak value 6030:13 was measured | UINT64 | RO |
6030:18 | Timestamp 2 | Timestamp at which the peak value 6030:14 was measured | UINT64 | RO |


Index 6040 LOG Status

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF) [image] Index 6040 LOG Status
Index 6040 LOG Status
Index | Name | Meaning | Data type | Flags | Default
6040:0 | LOG Status |  | UINT8 | RO | 0x12 (18dec)
6040:01 | Logger Running | 0: Logger still running | boolean | RO | 0x00 (0dec)
6040:11 | Elapsed Time | Time since the logger was stopped | UINT32 | RO | 0x00000000 (0dec)
6040:12 | Trigger Reason | Reason why the logger was stopped | UINT16 | RO | 0x0000 (0dec)


Index 7000 DPO Outputs Ch.1

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF) [image] Index 7000 DPO Outputs Ch.1
Index 7000 DPO Outputs Ch.1
Index | Name | Meaning | Data type | Flags | Default
7000:0 | DPO Outputs Ch.1 |  | UINT8 | RO | 0x11 (17dec)
7000:01 | Output Us | 0: Us will be switched off 1: Us will be switched on | boolean | RO | 0x00 (0dec)
7000:02 | Output Up | 0: Us will be switched off 1: Us will be switched on | boolean | RO | 0x00 (0dec)
7000:05 | Reset Us | An error on Us will be reset | boolean | RO | 0x00 (0dec)
7000:06 | Reset Up | An error on Up will be reset | boolean | RO | 0x00 (0dec)
7000:11 | Reset Extended Diag Data | The peak value and timestamp of the extended diagnosis for this channel will be deleted. | boolean | RO | 0x00 (0dec)


Index 7010 DPO Outputs Ch.2

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF) [image] Index 7010 DPO Outputs Ch.2
Index 7010 DPO Outputs Ch.2
Index | Name | Meaning | Data type | Flags | Default
7010:0 | DPO Outputs Ch.2 |  | UINT8 | RO | 0x11 (17dec)
7010:01 | Output Us | 0: Us will be switched off 1: Us will be switched on | boolean | RO | 0x00 (0dec)
7010:02 | Output Up | 0: Us will be switched off 1: Us will be switched on | boolean | RO | 0x00 (0dec)
7010:05 | Reset Us | An error on Us will be reset | boolean | RO | 0x00 (0dec)
7010:06 | Reset Up | An error on Up will be reset | boolean | RO | 0x00 (0dec)
7010:11 | Reset Extended Diag Data | The peak value and timestamp of the extended diagnosis for this channel will be deleted. | boolean | RO | 0x00 (0dec)


Index 7020 DPO Outputs Ch.3

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF) [image] Index 7020 DPO Outputs Ch.3
Index 7020 DPO Outputs Ch.3
Index | Name | Meaning | Data type | Flags | Default
7020:0 | DPO Outputs Ch.3 |  | UINT8 | RO | 0x11 (17dec)
7020:01 | Output Us | 0: Us will be switched off 1: Us will be switched on | boolean | RO | 0x00 (0dec)
7020:02 | Output Up | 0: Us will be switched off 1: Us will be switched on | boolean | RO | 0x00 (0dec)
7020:05 | Reset Us | An error on Us will be reset | boolean | RO | 0x00 (0dec)
7020:06 | Reset Up | An error on Up will be reset | boolean | RO | 0x00 (0dec)
7020:11 | Reset Extended Diag Data | The peak value and timestamp of the extended diagnosis for this channel will be deleted. | boolean | RO | 0x00 (0dec)


Index 7030 DPO Outputs Ch.4

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF) [image] Index 7030 DPO Outputs Ch.4
Index 7030 DPO Outputs Ch.4
Index | Name | Meaning | Data type | Flags | Default
7030:0 | DPO Outputs Ch.4 |  | UINT8 | RO | 0x11 (17dec)
7030:01 | Output Us | 0: Us will be switched off 1: Us will be switched on | boolean | RO | 0x00 (0dec)
7030:02 | Output Up | 0: Us will be switched off 1: Us will be switched on | boolean | RO | 0x00 (0dec)
7030:05 | Reset Us | An error on Us will be reset | boolean | RO | 0x00 (0dec)
7030:06 | Reset Up | An error on Up will be reset | boolean | RO | 0x00 (0dec)
7030:11 | Reset Extended Diag Data | The peak value and timestamp of the extended diagnosis for this channel will be deleted. | boolean | RO | 0x00 (0dec)


Index 7040 LOG Control

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF) [image] Index 7040 LOG Control
Index 7040 LOG Control
Index | Name | Meaning | Data type | Flags | Default
7040:0 | LOG Control |  | UINT8 | RO | 0x02 (2dec)
7040:01 | Start Logger |  | boolean | RO | 0x00 (0dec)
7040:02 | Stop logger |  | boolean | RO | 0x00 (0dec)


Index 800F DPO Vendor data Ch.1

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF) [image] Index 800F DPO Vendor data Ch.1
Index 800F DPO Vendor data Ch.1
Index | Name | Meaning | Data type | Flags | Default
800F:0 | DPO Vendor data Ch.1 |  | UINT8 | RO | 0x14 (20dec)
800F:11 | GainS |  | UINT16 | RW | 0x4000 (16384dec)
800F:12 | OffsetS |  | INT16 | RW | 0x0000 (0dec)
800F:13 | GainP |  | UINT16 | RW | 0x4000 (16384dec)
800F:14 | OffsetP |  | INT16 | RW | 0x0000 (0dec)


Index 801F DPO Vendor data Ch.2

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF) [image] Index 801F DPO Vendor data Ch.2
Index 801F DPO Vendor data Ch.2
Index | Name | Meaning | Data type | Flags | Default
801F:0 | DPO Vendor data Ch.2 |  | UINT8 | RO | 0x14 (20dec)
801F:11 | GainS |  | UINT16 | RW | 0x4000 (16384dec)
801F:12 | OffsetS |  | INT16 | RW | 0x0000 (0dec)
801F:13 | GainP |  | UINT16 | RW | 0x4000 (16384dec)
801F:14 | OffsetP |  | INT16 | RW | 0x0000 (0dec)


Index 802F DPO Vendor data Ch.3

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF) [image] Index 802F DPO Vendor data Ch.3
Index 802F DPO Vendor data Ch.3
Index | Name | Meaning | Data type | Flags | Default
802F:0 | DPO Vendor data Ch.3 |  | UINT8 | RO | 0x14 (20dec)
802F:11 | GainS |  | UINT16 | RW | 0x4000 (16384dec)
802F:12 | OffsetS |  | INT16 | RW | 0x0000 (0dec)
802F:13 | GainP |  | UINT16 | RW | 0x4000 (16384dec)
802F:14 | OffsetP |  | INT16 | RW | 0x0000 (0dec)


Index 803F DPO Vendor data Ch.4

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF) [image] Index 803F DPO Vendor data Ch.4
Index 803F DPO Vendor data Ch.4
Index | Name | Meaning | Data type | Flags | Default
803F:0 | DPO Vendor data Ch.4 |  | UINT8 | RO | 0x14 (20dec)
803F:11 | GainS |  | UINT16 | RW | 0x4000 (16384dec)
803F:12 | OffsetS |  | INT16 | RW | 0x0000 (0dec)
803F:13 | GainP |  | UINT16 | RW | 0x4000 (16384dec)
803F:14 | OffsetP |  | INT16 | RW | 0x0000 (0dec)


Index F000 Modular device profile

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF) [image] Index F000 Modular device profile
Index F000 Modular device profile
Index | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0005 (5dec)


Index F008 Code word

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF) [image] Index F008 Code word
Index F008 Code word
Index | Name | Meaning | Data type | Flags | Default
F008:0 | Code word |  | UINT32 | RW | 0x00000000 (0dec)


Index F010 Module list

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF) [image] Index F010 Module list
Index F010 Module list
Index | Name | Meaning | Data type | Flags | Default
F010:0 | Module list |  | UINT8 | RW | 0x05 (5dec)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x0000010E (270dec)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x0000010E (270dec)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x0000010E (270dec)
F010:04 | SubIndex 004 |  | UINT32 | RW | 0x0000010E (270dec)
F010:05 | SubIndex 005 |  | UINT32 | RW | 0x00000384 (900dec)


Index F81F DPO Vendor Data Device

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF) [image] Index F81F DPO Vendor Data Device
Index F81F DPO Vendor Data Device
Index | Name | Meaning | Data type | Flags | Default
F81F:0 | DPO Vendor Data Device |  | UINT8 | RO | 0x1A (26dec)
F81F:01 | Enable Auto Offset Calibration | reserved | boolean | RW | 0x00 (0dec)
F81F:02 | Enable Crosstalk Compensation | reserved | boolean | RW | 0x01 (1dec)
F81F:10 | Enable Calibration Mode | reserved | boolean | RW | 0x00 (0dec)
F81F:11 | GainS | reserved | UINT16 | RW | 0x4000 (16384dec)
F81F:12 | OffsetS | reserved | INT16 | RW | 0x0000 (0dec)
F81F:13 | GainP | reserved | UINT16 | RW | 0x4000 (16384dec)
F81F:14 | OffsetP | reserved | INT16 | RW | 0x0000 (0dec)
F81F:15 | Gain US | reserved | UINT16 | RW | 0x4000 (16384dec)
F81F:16 | Offset US | reserved | INT16 | RW | 0x0000 (0dec)
F81F:17 | Gain UP | reserved | UINT16 | RW | 0x4000 (16384dec)
F81F:18 | Offset UP | reserved | INT16 | RW | 0x0000 (0dec)
F81F:19 | Gain Temperature | reserved | UINT16 | RW | 0x4000 (16384dec)
F81F:1A | Offset Temperature | reserved | INT16 | RW | 0x0000 (0dec)


EP9224-0023 - Process image

Commissioning and configuration [image] EP9224-0023 [image] EP9224-0023 - Process image
EP9224-0023 - Process image
The EP9214 has four output channels, DPO Inputs Channel n.
Subsequently, a status channel follows for the complete device DPO Inputs Device.
In the output section there are four output channels, DPO Outputs Channel n.
An output word follows for the complete device DPO Outputs Device.
WcState and InfoData are standard EtherCAT system variables.
DPO Inputs Channel 1 to 4
The four channels each have status bits and status LEDs for displaying the current channel state:
Error Us: Us was switched off due to an error
Error Up: Up was switched off due to an error
Warning Us: If the current value set in CoE object 80n0:12 persists, the channel will be switched off
Warning Up: If the current value set in CoE object 80n0:13 persists, the channel will be switched off
Status Us: Channel switched on or off
Status Up: Channel switched on or off
Channel Error: Error Us or Error Up is TRUE
Error Sum Current: The sum value for Is and Ip of the channel set in CoE object 8000:14 has been exceeded for too long.
Warning Sum Current: If the sum value for Is and Ip of the channel set in CoE object 8000:14 persists, the channel will be switched off.
Current Us, Current Up: Present output current of US or UP.
Presentation: 1 mA / LSB.
DPO Inputs Device
Subsequently, a status word follows for the complete device DPO Inputs Device.
Temperature Warning: The internal temperature of the EP9224 will soon reach the shut-off point.
Temperature Error: The internal temperature was too high. The output channels were switched off.
Us/Up Warning: The value of the input voltage Us/Up is less than 21.5 V
Us/Up Error: The value of the input voltage Us/Up is less than 19.0 V
Global Error Bit: One of the eight channels is TRUE
Sum Current Warning: The sum value for Is and Ip of the box set in CoE object F80E:12 has been exceeded for too long.
Error Sum Current: If the sum value for Is and Ip of the channel set in CoE object 8000:14 persists, the channel will be switched off.
Reset Input: Reset pin to HIGH (lower M8)
Current Us: Present sum current of the supply input socket US.
Presentation: 10 mA / LSB
Current Up: Present sum current of the supply input socket UP.
Presentation: 10 mA / LSB
Voltage Us: Present input voltage US of the supply input socket.
Presentation: 100 mV / LSB
Voltage Up: Present input voltage UP of the supply input socket.
Presentation: 100 mV / LSB
Temperature: Current internal temperature of the Box.
DPO Outputs Channel 1 to 4
The EP9224 has 4 x 16-bit output data of the four output channels DPO Outputs Channel n.
Output Us/Up: TRUE - switch the output on, FALSE - switch the output off
Reset Us/Up: TRUE - reset in the event of an error…
DPO Outputs Device
Subsequently, a status word follows for the complete device DPO outputs Device.
Enable Control Via Fieldbus: TRUE - control all outputs via the fieldbus / PLC, FALSE - automatic switch-on depending on the CoE entries
Global Reset: Resets all errors in the Box


Restoring the delivery state

Commissioning and configuration [image] Restoring the delivery state
Restoring the delivery state
To restore the delivery state for backup objects in ELxxxx terminals / EPxxxx- and EPPxxxx boxes, the CoE object Restore default parameters, SubIndex 001 can be selected in the TwinCAT System Manager (Config mode).
Selecting the Restore default parameters PDO
Double-click on SubIndex 001 to enter the Set Value dialog. Enter the value 1684107116 in field Dec or the value 0x64616F6C in field Hex and confirm with OK.
All backup objects are reset to the delivery state.
Entering a restore value in the Set Value dialog
Alternative restore value
In some older terminals / boxes the backup objects can be switched with an alternative restore value:
Decimal value: 1819238756
Hexadecimal value: 0x6C6F6164
An incorrect entry for the restore value has no effect.


Appendix

Appendix
Appendix
Additional information
•
General operating conditions
•
EtherCAT Box- / EtherCAT P Box - Accessories
•
Version identification of EtherCAT devices
•
Support and Service


General operating conditions

Appendix [image] General operating conditions
General operating conditions
Protection degrees (IP-Code)
The standard IEC 60529 (DIN EN 60529) defines the degrees of protection in different classes.
1. Number: dust protection and touch guard | Definition
0 | Non-protected
1 | Protected against access to hazardous parts with the back of a hand. Protected against solid foreign objects of Ø 50 mm
2 | Protected against access to hazardous parts with a finger. Protected against solid foreign objects of Ø 12.5 mm.
3 | Protected against access to hazardous parts with a tool. Protected against solid foreign objects Ø 2.5 mm.
4 | Protected against access to hazardous parts with a wire. Protected against solid foreign objects Ø 1 mm.
5 | Protected against access to hazardous parts with a wire. Dust-protected. Intrusion of dust is not totally prevented, but dust shall not penetrate in a quantity to interfere with satisfactory operation of the device or to impair safety.
6 | Protected against access to hazardous parts with a wire. Dust-tight. No intrusion of dust.
2. Number: water* protection | Definition
0 | Non-protected
1 | Protected against water drops
2 | Protected against water drops when enclosure tilted up to 15°.
3 | Protected against spraying water. Water sprayed at an angle up to 60° on either side of the vertical shall have no harmful effects.
4 | Protected against splashing water. Water splashed against the disclosure from any direction shall have no harmful effects
5 | Protected against water jets
6 | Protected against powerful water jets
7 | Protected against the effects of temporary immersion in water. Intrusion of water in quantities causing harmful effects shall not be possible when the enclosure is temporarily immersed in water for 30 min. in 1 m depth.
*) These protection classes define only protection against water!
Chemical Resistance
The Resistance relates to the Housing of the IP 67 modules and the used metal parts. In the table below you will find some typical resistance.
Character | Resistance
Steam | at temperatures >100°C: not resistant
Sodium base liquor (ph-Value > 12) | at room temperature: resistant > 40°C: not resistant
Acetic acid | not resistant
Argon (technical clean) | resistant
Key
▪
resistant: Lifetime several months
▪
non inherently resistant: Lifetime several weeks
▪
not resistant: Lifetime several hours resp. early decomposition


EtherCAT Box- / EtherCAT P Box - Accessories

Appendix [image] EtherCAT Box- / EtherCAT P Box - Accessories
EtherCAT Box- / EtherCAT P Box - Accessories
Fixing
Ordering information | Description
ZS5300-0001 | Mounting rail (500 mm x 129 mm)
Marking material, plugs
Ordering information | Description
ZS5000-0000 | Fieldbus Box set M8 (contact labels, plugs)
ZS5000-0002 | Fieldbus Box set M12 (contact labels, plugs)
ZS5000-0010 | plugs M8, IP67 (50 pieces)
ZS5000-0020 | plugs M12, IP67 (50 pieces)
ZS5100-0000 | marking labels, not printed, 4 stripes at 10 pieces
ZS5100-xxxx | printed marking labels, on request
Tools
Ordering information | Description
ZB8800 | torque wrench for M8 cables with knurl, incl. ratchet
ZB8800-0001 | M12 ratchet for torque wrench ZB8800
ZB8800-0002 | M8 ratchet (field assembly) for torque wrench ZB8800
ZB8801-0000 | torque wrench for hexagonal plugs, adjustable
ZB8801-0001 | torque cable key, M8/wrench size 9, for torque wrench ZB8801-0000
ZB8801-0002 | torque cable key, M12/wrench size 13, for torque wrench ZB8801-0000
ZB8801-0003 | torque cable key, M12 field assembly/wrench size 13, for torque wrench ZB8801-0000
Further accessories
Further accessories may be found at the price list for Beckhoff fieldbus components and at the internet under https://www.beckhoff.com


Version identification of EtherCAT devices

Appendix [image] Version identification of EtherCAT devices
Version identification of EtherCAT devices
Designation
A Beckhoff EtherCAT device has a 14-digit designation, made up of
▪
family key
▪
type
▪
version
▪
revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
Notes
▪
The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
▪
EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
▪
The order identifier is made up of
- family key (EL, EP, CU, ES, KL, CX, etc.)
- type (3314)
- version (-0000)
▪
The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
▪
The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Identification number
Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:
Production lot/batch number/serial number/date code/D number
The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02
Exceptions can occur in the IP67 area, where the following syntax can be used (see respective device documentation):
Syntax: D ww yy x y z u
D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB
Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1
Unique serial number/ID, ID number
In addition, in some series each individual module has its own unique serial number.
See also the further documentation in the area
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Terminals with factory calibration certificate and other measuring terminals
Examples of markings
EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
CU2016 switch with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
EP1258-00001 IP67 EtherCAT Box with batch number/ date code 22090101 and unique serial number 158102
EP1908-0002 IP67 EtherCAT Safety Box with batch number/ date code 071201FF and unique serial number 00346070
EL2904 IP20 safety terminal with batch number/ date code 50110302 and unique serial number 00331701
ELM3604-0002 terminal with unique ID number (QR code) 100001051 and serial/ batch number 44160201
Additional information
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Appendix [image] Version identification of EtherCAT devices [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com


Index 1011 Restore default parameters

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Objects for parameterization [image] Index 1011 Restore default parameters
Index 1011 Restore default parameters
Index | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default parameters | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" in the Set Value Dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)


Index 8000 DPO Settings Ch.1

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Objects for parameterization [image] Index 8000 DPO Settings Ch.1
Index 8000 DPO Settings Ch.1
Index | Name | Meaning | Data type | Flags | Default
8000:0 | DPO Settings Ch.1 |  | UINT8 | RO | 0x13 (19dec)
8000:02 | Default State Us | The output adopts this value if F707:01 is not set | boolean | RW | 0x01 (1dec)
8000:03 | Default State Up | The output adopts this value if F707:01 is not set | boolean | RW | 0x01 (1dec)
8000:11 | Characteristic | Specifies the characteristic with which the current monitoring reacts: 0dec: very fast acting 1dec: fast acting 2dec: slow acting 3dec: time delay | UINT16 | RW | 0x0001 (1dec)
8000:12 | Nominal Current Us | Nominal maximum current at the output | UINT16 | RW | 0x0FA0 (4000dec)
8000:13 | Nominal Current Up | Nominal maximum current at the output | UINT16 | RW | 0x0FA0 (4000dec)


Index 8010 DPO Settings Ch.2

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Objects for parameterization [image] Index 8010 DPO Settings Ch.2
Index 8010 DPO Settings Ch.2
Index | Name | Meaning | Data type | Flags | Default
8010:0 | DPO Settings Ch.2 |  | UINT8 | RO | 0x13 (19dec)
8010:02 | Default State Us | The output adopts this value if F707:01 is not set | boolean | RW | 0x01 (1dec)
8010:03 | Default State Up | The output adopts this value if F707:01 is not set | boolean | RW | 0x01 (1dec)
8010:11 | Characteristic | Specifies the characteristic with which the current monitoring reacts: 0dec: very fast acting 1dec: fast acting 2dec: slow acting 3dec: time delay | UINT16 | RW | 0x0001 (1dec)
8010:12 | Nominal Current Us | Nominal maximum current at the output | UINT16 | RW | 0x0FA0 (4000dec)
8010:13 | Nominal Current Up | Nominal maximum current at the output | UINT16 | RW | 0x0FA0 (4000dec)


Index F80E DPO Settings Device

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Objects for parameterization [image] Index F80E DPO Settings Device
Index F80E DPO Settings Device
Index | Name | Meaning | Data type | Flags | Default
F80E:0 | DPO Settings Device |  | UINT8 | RW | 0x11 (17dec)
F80E:11 | Startup Delay | Sets the time that is kept between two switch-on procedures: 1dec: fast (10 ms) 2dec: moderate (100 ms) 3dec: slow (200 ms) | UINT16 | RW | 0x0001 (1dec)


Index 8030 DPO Settings Ch.4

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Objects for parameterization [image] Index 8030 DPO Settings Ch.4
Index 8030 DPO Settings Ch.4
Index | Name | Meaning | Data type | Flags | Default
8030:0 | DPO Settings Ch.4 |  | UINT8 | RO | 0x13 (19dec)
8030:02 | Default State Us | The output adopts this value if F707:01 is not set | boolean | RW | 0x01 (1dec)
8030:03 | Default State Up | The output adopts this value if F707:01 is not set | boolean | RW | 0x01 (1dec)
8030:11 | Characteristic | Specifies the characteristic with which the current monitoring reacts: 0dec: very fast acting 1dec: fast acting 2dec: slow acting 3dec: time delay | UINT16 | RW | 0x0001 (1dec)
8030:12 | Nominal Current Us | Nominal maximum current at the output | UINT16 | RW | 0x0FA0 (4000dec)
8030:13 | Nominal Current Up | Nominal maximum current at the output | UINT16 | RW | 0x0FA0 (4000dec)


Index 8020 DPO Settings Ch.3

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Objects for parameterization [image] Index 8020 DPO Settings Ch.3
Index 8020 DPO Settings Ch.3
Index | Name | Meaning | Data type | Flags | Default
8020:0 | DPO Settings Ch.3 |  | UINT8 | RO | 0x13 (19dec)
8020:02 | Default State Us | The output adopts this value if F707:01 is not set | boolean | RW | 0x01 (1dec)
8020:03 | Default State Up | The output adopts this value if F707:01 is not set | boolean | RW | 0x01 (1dec)
8020:11 | Characteristic | Specifies the characteristic with which the current monitoring reacts: 0dec: very fast acting 1dec: fast acting 2dec: slow acting 3dec: time delay | UINT16 | RW | 0x0001 (1dec)
8020:12 | Nominal Current Us | Nominal maximum current at the output | UINT16 | RW | 0x0FA0 (4000dec)
8020:13 | Nominal Current Up | Nominal maximum current at the output | UINT16 | RW | 0x0FA0 (4000dec)


Index F707 DPO Outputs Device

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Objects for parameterization [image] Index F707 DPO Outputs Device
Index F707 DPO Outputs Device
Index | Name | Meaning | Data type | Flags | Default
F707:0 | DPO Outputs Device |  | UINT8 | RO | 0x04 (4dec)
F707:01 | Enable Control Via Fieldbus | 0bin: All outputs are set according to their default values (80X0:02, 80X0:03) 1bin: All outputs are set according to their PDOs (70X0:01, 70X0:02) | boolean | RO | 0x00 (0dec)
F707:04 | Global Reset | All error bits are reset | boolean | RO | 0x00 (0dec)


Index 1C00 Sync manager type

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Standard objects [image] Index 1C00 Sync manager type
Index 1C00 Sync manager type
Index | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the Sync Managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)


Index 1A02 DPO TxPDO-Map Inputs Ch.3

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Standard objects [image] Index 1A02 DPO TxPDO-Map Inputs Ch.3
Index 1A02 DPO TxPDO-Map Inputs Ch.3
Index | Name | Meaning | Data type | Flags | Default
1A02:0 | DPO TxPDO-Map Inputs Ch.3 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x0B (11dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (DPO Inputs Ch.3), entry 0x01 (Error Us)) | UINT32 | RO | 0x6020:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (DPO Inputs Ch.3), entry 0x02 (Error Up)) | UINT32 | RO | 0x6020:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (DPO Inputs Ch.3), entry 0x03 (Warning Us)) | UINT32 | RO | 0x6020:03, 1
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (DPO Inputs Ch.3), entry 0x04 (Warning Up)) | UINT32 | RO | 0x6020:04, 1
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (DPO Inputs Ch.3), entry 0x05 (Status Us)) | UINT32 | RO | 0x6020:05, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6020 (DPO Inputs Ch.3), entry 0x06 (Status Up)) | UINT32 | RO | 0x6020:06, 1
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020 (DPO Inputs Ch.3), entry 0x07 (Channel Error)) | UINT32 | RO | 0x6020:07, 1
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
1A02:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6020 (DPO Inputs Ch.3), entry 0x0E (Sync error)) | UINT32 | RO | 0x6020:0E, 1
1A02:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6020 (DPO Inputs Ch.3), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6020:0F, 1
1A02:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6020 (DPO Inputs Ch.3), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6020:10, 1


Index 1A04 DPO TxPDO-Map Inputs Device

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Standard objects [image] Index 1A04 DPO TxPDO-Map Inputs Device
Index 1A04 DPO TxPDO-Map Inputs Device
Index | Name | Meaning | Data type | Flags | Default
1A04:0 | DPO TxPDO-Map Inputs Device | PDO Mapping TxPDO 5 | UINT8 | RW | 0x0C (12dec)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF607 (DPO Inputs Device), entry 0x01 (Temperature Warning)) | UINT32 | RW | 0xF607:01, 1
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF607 (DPO Inputs Device), entry 0x02 (Temperature Error)) | UINT32 | RW | 0xF607:02, 1
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF607 (DPO Inputs Device), entry 0x03 (Us Warning)) | UINT32 | RW | 0xF607:03, 1
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF607 (DPO Inputs Device), entry 0x04 (Us Error)) | UINT32 | RW | 0xF607:04, 1
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF607 (DPO Inputs Device), entry 0x05 (Up Warning)) | UINT32 | RW | 0xF607:05, 1
1A04:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF607 (DPO Inputs Device), entry 0x06 (Up Error)) | UINT32 | RW | 0xF607:06, 1
1A04:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF607 (DPO Inputs Device), entry 0x07 (Global Error Bit)) | UINT32 | RW | 0xF607:07, 1
1A04:08 | SubIndex 008 | 8. PDO Mapping entry (4 bits align) | UINT32 | RW | 0x0000:00, 4
1A04:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF607 (DPO Inputs Device), entry 0x0C (Reset Input)) | UINT32 | RW | 0xF607:0C, 1
1A04:0A | SubIndex 010 | 10. PDO Mapping entry (2 bits align) | UINT32 | RW | 0x0000:00, 2
1A04:0B | SubIndex 011 | 11. PDO Mapping entry (object 0xF607 (DPO Inputs Device), entry 0x0F (TxPDO State)) | UINT32 | RW | 0xF607:0F, 1
1A04:0C | SubIndex 012 | 12. PDO Mapping entry (object 0xF607 (DPO Inputs Device), entry 0x10 (TxPDO Toggle)) | UINT32 | RW | 0xF607:10, 1


Index 1A03 DPO TxPDO-Map Inputs Ch.4

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Standard objects [image] Index 1A03 DPO TxPDO-Map Inputs Ch.4
Index 1A03 DPO TxPDO-Map Inputs Ch.4
Index | Name | Meaning | Data type | Flags | Default
1A03:0 | DPO TxPDO-Map Inputs Ch.4 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x0B (11dec)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6030 (DPO Inputs Ch.4), entry 0x01 (Error Us)) | UINT32 | RO | 0x6030:01, 1
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6030 (DPO Inputs Ch.4), entry 0x02 (Error Up)) | UINT32 | RO | 0x6030:02, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6030 (DPO Inputs Ch.4), entry 0x03 (Warning Us)) | UINT32 | RO | 0x6030:03, 1
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6030 (DPO Inputs Ch.4), entry 0x04 (Warning Up)) | UINT32 | RO | 0x6030:04, 1
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6030 (DPO Inputs Ch.4), entry 0x05 (Status Us)) | UINT32 | RO | 0x6030:05, 1
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6030 (DPO Inputs Ch.4), entry 0x06 (Status Up)) | UINT32 | RO | 0x6030:06, 1
1A03:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6030 (DPO Inputs Ch.4), entry 0x07 (Channel Error)) | UINT32 | RO | 0x6030:07, 1
1A03:08 | SubIndex 008 | 8. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
1A03:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6030 (DPO Inputs Ch.4), entry 0x0E (Sync error)) | UINT32 | RO | 0x6030:0E, 1
1A03:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6030 (DPO Inputs Ch.4), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6030:0F, 1
1A03:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6030 (DPO Inputs Ch.4), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6030:10, 1


Index 1603 DPO RxPDO-Map Outputs Ch.4

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Standard objects [image] Index 1603 DPO RxPDO-Map Outputs Ch.4
Index 1603 DPO RxPDO-Map Outputs Ch.4
Index | Name | Meaning | Data type | Flags | Default
1603:0 | DPO RxPDO-Map Outputs Ch.4 | PDO Mapping RxPDO 4 | UINT8 | RO | 0x06 (6dec)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7030 (DPO Outputs Ch.4), entry 0x01 (Output Us)) | UINT32 | RO | 0x7030:01, 1
1603:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7030 (DPO Outputs Ch.4), entry 0x02 (Output Up)) | UINT32 | RO | 0x7030:02, 1
1603:03 | SubIndex 003 | 3. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1603:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7030 (DPO Outputs Ch.4), entry 0x05 (Reset Us)) | UINT32 | RO | 0x7030:05, 1
1603:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7030 (DPO Outputs Ch.4), entry 0x06 (Reset Up)) | UINT32 | RO | 0x7030:06, 1
1603:06 | SubIndex 006 | 6. PDO Mapping entry (10 bits align) | UINT32 | RO | 0x0000:00, 10


Index 1604 DPO RxPDO-Map Outputs Device

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Standard objects [image] Index 1604 DPO RxPDO-Map Outputs Device
Index 1604 DPO RxPDO-Map Outputs Device
Index | Name | Meaning | Data type | Flags | Default
1604:0 | DPO RxPDO-Map Outputs Device | PDO Mapping RxPDO 5 | UINT8 | RO | 0x04 (4dec)
1604:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF707 (DPO Outputs Device), entry 0x01 (Enable Control Via Fieldbus)) | UINT32 | RO | 0xF707:01, 1
1604:02 | SubIndex 002 | 2. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1604:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF707 (DPO Outputs Device), entry 0x04 (Global Reset)) | UINT32 | RO | 0xF707:04, 1
1604:04 | SubIndex 004 | 4. PDO Mapping entry (12 bits align) | UINT32 | RO | 0x0000:00, 12


Index 1A00 DPO TxPDO-Map Inputs Ch.1

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Standard objects [image] Index 1A00 DPO TxPDO-Map Inputs Ch.1
Index 1A00 DPO TxPDO-Map Inputs Ch.1
Index | Name | Meaning | Data type | Flags | Default
1A00:0 | DPO TxPDO-Map Inputs Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x0B (11dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (DPO Inputs Ch.1), entry 0x01 (Error Us)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (DPO Inputs Ch.1), entry 0x02 (Error Up)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (DPO Inputs Ch.1), entry 0x03 (Warning Us)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (DPO Inputs Ch.1), entry 0x04 (Warning Up)) | UINT32 | RO | 0x6000:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (DPO Inputs Ch.1), entry 0x05 (Status Us)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (DPO Inputs Ch.1), entry 0x06 (Status Up)) | UINT32 | RO | 0x6000:06, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (DPO Inputs Ch.1), entry 0x07 (Channel Error)) | UINT32 | RO | 0x6000:07, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (DPO Inputs Ch.1), entry 0x0E (Sync error)) | UINT32 | RO | 0x6000:0E, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (DPO Inputs Ch.1), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6000:0F, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (DPO Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6000:10, 1


Index 1A01 DPO TxPDO-Map Inputs Ch.2

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Standard objects [image] Index 1A01 DPO TxPDO-Map Inputs Ch.2
Index 1A01 DPO TxPDO-Map Inputs Ch.2
Index | Name | Meaning | Data type | Flags | Default
1A01:0 | DPO TxPDO-Map Inputs Ch.2 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x0B (11dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DPO Inputs Ch.2), entry 0x01 (Error Us)) | UINT32 | RO | 0x6010:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (DPO Inputs Ch.2), entry 0x02 (Error Up)) | UINT32 | RO | 0x6010:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (DPO Inputs Ch.2), entry 0x03 (Warning Us)) | UINT32 | RO | 0x6010:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (DPO Inputs Ch.2), entry 0x04 (Warning Up)) | UINT32 | RO | 0x6010:04, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (DPO Inputs Ch.2), entry 0x05 (Status Us)) | UINT32 | RO | 0x6010:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (DPO Inputs Ch.2), entry 0x06 (Status Up)) | UINT32 | RO | 0x6010:06, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (DPO Inputs Ch.2), entry 0x07 (Channel Error)) | UINT32 | RO | 0x6010:07, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6010 (DPO Inputs Ch.2), entry 0x0E (Sync error)) | UINT32 | RO | 0x6010:0E, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6010 (DPO Inputs Ch.2), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6010:0F, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6010 (DPO Inputs Ch.2), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6010:10, 1


Index 1000 Device type

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Standard objects [image] Index 1000 Device type
Index 1000 Device type
Index | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x010E1389 (17699721dec)


Index 1008 Device name

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Standard objects [image] Index 1008 Device name
Index 1008 Device name
Index | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EP9214-0023


Index 1009 Hardware version

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Standard objects [image] Index 1009 Hardware version
Index 1009 Hardware version
Index | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO |


Index 1018 Identity

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Standard objects [image] Index 1018 Identity
Index 1018 Identity
Index | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x23FE4052 (603865170dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the Low Word (bit 0-15) indicates the special terminal number, the High Word (bit 16-31) refers to the device description | UINT32 | RO | 0x00000000 (0dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the Low Byte (bit 0-7) of the Low Word contains the year of production, the High Byte (bit 8-15) of the Low Word contains the week of production, the High Word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)


Index 10F0 Backup parameter handling

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Standard objects [image] Index 10F0 Backup parameter handling
Index 10F0 Backup parameter handling
Index | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | Information for standardized loading and saving of backup entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum across all backup entries of the EtherCAT slave | UINT32 | RO | 0x00000000 (0dec)


Index 1600 DPO RxPDO-Map Outputs Ch.1

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Standard objects [image] Index 1600 DPO RxPDO-Map Outputs Ch.1
Index 1600 DPO RxPDO-Map Outputs Ch.1
Index | Name | Meaning | Data type | Flags | Default
1600:0 | DPO RxPDO-Map Outputs Ch.1 | PDO Mapping RxPDO 1 | UINT8 | RO | 0x06 (6dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (DPO Outputs Ch.1), entry 0x01 (Output Us)) | UINT32 | RO | 0x7000:01, 1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (DPO Outputs Ch.1), entry 0x02 (Output Up)) | UINT32 | RO | 0x7000:02, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (DPO Outputs Ch.1), entry 0x05 (Reset Us)) | UINT32 | RO | 0x7000:05, 1
1600:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7000 (DPO Outputs Ch.1), entry 0x06 (Reset Up)) | UINT32 | RO | 0x7000:06, 1
1600:06 | SubIndex 006 | 6. PDO Mapping entry (10 bits align) | UINT32 | RO | 0x0000:00, 10


Index 1601 DPO RxPDO-Map Outputs Ch.2

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Standard objects [image] Index 1601 DPO RxPDO-Map Outputs Ch.2
Index 1601 DPO RxPDO-Map Outputs Ch.2
Index | Name | Meaning | Data type | Flags | Default
1601:0 | DPO RxPDO-Map Outputs Ch.2 | PDO Mapping RxPDO 2 | UINT8 | RO | 0x06 (6dec)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (DPO Outputs Ch.2), entry 0x01 (Output Us)) | UINT32 | RO | 0x7010:01, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (DPO Outputs Ch.2), entry 0x02 (Output Up)) | UINT32 | RO | 0x7010:02, 1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7010 (DPO Outputs Ch.2), entry 0x05 (Reset Us)) | UINT32 | RO | 0x7010:05, 1
1601:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7010 (DPO Outputs Ch.2), entry 0x06 (Reset Up)) | UINT32 | RO | 0x7010:06, 1
1601:06 | SubIndex 006 | 6. PDO Mapping entry (10 bits align) | UINT32 | RO | 0x0000:00, 10


Index 1602 DPO RxPDO-Map Outputs Ch.3

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Standard objects [image] Index 1602 DPO RxPDO-Map Outputs Ch.3
Index 1602 DPO RxPDO-Map Outputs Ch.3
Index | Name | Meaning | Data type | Flags | Default
1602:0 | DPO RxPDO-Map Outputs Ch.3 | PDO Mapping RxPDO 3 | UINT8 | RO | 0x06 (6dec)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (DPO Outputs Ch.3), entry 0x01 (Output Us)) | UINT32 | RO | 0x7020:01, 1
1602:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7020 (DPO Outputs Ch.3), entry 0x02 (Output Up)) | UINT32 | RO | 0x7020:02, 1
1602:03 | SubIndex 003 | 3. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1602:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7020 (DPO Outputs Ch.3), entry 0x05 (Reset Us)) | UINT32 | RO | 0x7020:05, 1
1602:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7020 (DPO Outputs Ch.3), entry 0x06 (Reset Up)) | UINT32 | RO | 0x7020:06, 1
1602:06 | SubIndex 006 | 6. PDO Mapping entry (10 bits align) | UINT32 | RO | 0x0000:00, 10


Index 1C12 RxPDO assign

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Standard objects [image] Index 1C12 RxPDO assign
Index 1C12 RxPDO assign
Index | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x05 (5dec)
1C12:01 | Subindex 001 | 1. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1600 (5632dec)
1C12:02 | Subindex 002 | 2. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1601 (5633dec)
1C12:03 | Subindex 003 | 3. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1602 (5634dec)
1C12:04 | Subindex 004 | 4. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1603 (5635dec)
1C12:05 | Subindex 005 | 5. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1604 (5636dec)


Index 1C13 TxPDO assign

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Standard objects [image] Index 1C13 TxPDO assign
Index 1C13 TxPDO assign
Index | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x05 (5dec)
1C13:01 | Subindex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A01 (6657dec)
1C13:03 | Subindex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A02 (6658dec)
1C13:04 | Subindex 004 | 4. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A03 (6659dec)
1C13:05 | Subindex 005 | 5. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A04 (6660dec)


Index 1C32 SM output parameter

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Standard objects [image] Index 1C32 SM output parameter
Index 1C32 SM output parameter
Index
Name
Meaning
Data type
Flags
Default
1C32:0
SM output parameter
Synchronization parameters for the outputs
UINT8
RO
0x20 (32dec)
1C32:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0000 (0dec)
1C32:02
Cycle time
Cycle time (in ns):
▪
Free Run: Cycle time of the local timer
▪
Synchron with SM 2 Event: Master cycle time
▪
DC mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dec)
1C32:03
Shift time
Time between SYNC0 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000384 (900dec)
1C32:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0 = 1: free run is supported
▪
Bit 1 = 1: Synchron with SM 2 Event is supported
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 10: Output Shift with SYNC1 event (only DC mode)
▪
Bit 14 = 1: dynamic times (measurement through writing of 1C32:08)
UINT16
RO
0xC007 (49159dec)
1C32:05
Minimum cycle time
Minimum cycle time (in ns)
UINT32
RO
0x000F4240 (1000000dec)
1C32:06
Calc and copy time
Minimum time between SYNC0 and SYNC1 event (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:07
Minimum delay time
UINT32
RO
0x00000384 (900dec)
1C32:08
Command
▪
0: Measurement of the local cycle time is stopped
▪
1: Measurement of the local cycle time is started
The entries 1C32:03, 1C32:05, 1C32:06, 1C32:09, 1C33:03, 1C33:06, 1C33:09 are updated with the maximum measured values.
For a subsequent measurement the measured values are reset
UINT16
RW
0x0000 (0dec)
1C32:09
Maximum delay time
Time between SYNC1 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000384 (900dec)
1C32:0B
SM event missed counter
Number of missed SM events in OPERATIONAL (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:0C
Cycle exceeded counter
Number of occasions the cycle time was exceeded in OPERATIONAL (cycle was not completed in time or the next cycle began too early)
UINT16
RO
0x0000 (0dec)
1C32:0D
Shift too short counter
Number of occasions that the interval between SYNC0 and SYNC1 event was too short (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:20
Sync error
The synchronization was not correct in the last cycle (outputs were output too late; DC mode only)
boolean
RO
0x00 (0dec)


Index 1C33 SM input parameter

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Standard objects [image] Index 1C33 SM input parameter
Index 1C33 SM input parameter
Index
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (no outputs available)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (outputs available)
UINT16
RW
0x0000 (0dec)
1C33:02
Cycle time
as 1C32:02
UINT32
RW
0x000F4240 (1000000dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000384 (900dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: Synchron with SM 2 Event is supported (outputs available)
▪
Bit 1: Synchron with SM 3 Event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: Input Shift through local event (outputs available)
▪
Bit 4-5 = 10: Input Shift with SYNC1 event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 1C32:08 or 1C33:08)
UINT16
RO
0xC007 (49159dec)
1C33:05
Minimum cycle time
as 1C32:05
UINT32
RO
0x000F4240 (1000000dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:07
Minimum delay time
UINT32
RO
0x00000384 (900dec)
1C33:08
Command
as 1C32:08
UINT16
RW
0x0000 (0dec)
1C33:09
Maximum delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000384 (900dec)
1C33:0B
SM event missed counter
as 1C32:11
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
as 1C32:12
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
as 1C32:13
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
as 1C32:32
boolean
RO
0x00 (0dec)


Index 6000 DPO Inputs Ch.1

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF) [image] Index 6000 DPO Inputs Ch.1
Index 6000 DPO Inputs Ch.1
Index | Name | Meaning | Data type | Flags | Default
6000:0 | DPO Inputs Ch.1 | Input of the first channel | UINT8 | RO | 0x10 (16dec)
6000:01 | Error Us | The current monitoring of Us has tripped. The bit must be reset by a ‘Global Reset’ (F707:04) or by the corresponding Reset Us (7000:05). The output cannot be activated as long as the warning bit is 1. | boolean | RO | 0x00 (0dec)
6000:02 | Error Up | The current monitoring of Up has tripped. | boolean | RO | 0x00 (0dec)
6000:03 | Warning Us | The monitoring has detected overcurrent; the switching off of output Us on this channel is imminent if the current consumption of the branch does not decrease. | boolean | RO | 0x00 (0dec)
6000:04 | Warning Up | The monitoring has detected overcurrent; the switching off of output Us on this channel is imminent if the current consumption of the branch does not decrease. | boolean | RO | 0x00 (0dec)
6000:05 | Status Us | 0: The output is switched off 1: The output supplies 24 V | boolean | RO | 0x00 (0dec)
6000:06 | Status Up | 0: The output is switched off 1: The output supplies 24 V | boolean | RO | 0x00 (0dec)
6000:07 | Channel Error | 6000:01 or 6000:02 are set | boolean | RO | 0x00 (0dec)
6000:0E | Sync error |  | boolean | RO | 0x00 (0dec)
6000:0F | TxPDO State |  | boolean | RO | 0x00 (0dec)
6000:10 | TxPDO Toggle |  | boolean | RO | 0x00 (0dec)


Index 800F DPO Vendor data Ch.1

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF) [image] Index 800F DPO Vendor data Ch.1
Index 800F DPO Vendor data Ch.1
Index | Name | Meaning | Data type | Flags | Default
800F:0 | DPO Vendor data Ch.1 |  | UINT8 | RO | 0x14 (20dec)
800F:11 | GainS |  | UINT16 | RW | 0x4000 (16384dec)
800F:12 | OffsetS |  | INT16 | RW | 0x0000 (0dec)
800F:13 | GainP |  | UINT16 | RW | 0x4000 (16384dec)
800F:14 | OffsetP |  | INT16 | RW | 0x0000 (0dec)


Index 801F DPO Vendor data Ch.2

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF) [image] Index 801F DPO Vendor data Ch.2
Index 801F DPO Vendor data Ch.2
Index | Name | Meaning | Data type | Flags | Default
801F:0 | DPO Vendor data Ch.2 |  | UINT8 | RO | 0x14 (20dec)
801F:11 | GainS |  | UINT16 | RW | 0x4000 (16384dec)
801F:12 | OffsetS |  | INT16 | RW | 0x0000 (0dec)
801F:13 | GainP |  | UINT16 | RW | 0x4000 (16384dec)
801F:14 | OffsetP |  | INT16 | RW | 0x0000 (0dec)


Index 802F DPO Vendor data Ch.3

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF) [image] Index 802F DPO Vendor data Ch.3
Index 802F DPO Vendor data Ch.3
Index | Name | Meaning | Data type | Flags | Default
802F:0 | DPO Vendor data Ch.3 |  | UINT8 | RO | 0x14 (20dec)
802F:11 | GainS |  | UINT16 | RW | 0x4000 (16384dec)
802F:12 | OffsetS |  | INT16 | RW | 0x0000 (0dec)
802F:13 | GainP |  | UINT16 | RW | 0x4000 (16384dec)
802F:14 | OffsetP |  | INT16 | RW | 0x0000 (0dec)


Index 803F DPO Vendor data Ch.4

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF) [image] Index 803F DPO Vendor data Ch.4
Index 803F DPO Vendor data Ch.4
Index | Name | Meaning | Data type | Flags | Default
803F:0 | DPO Vendor data Ch.4 |  | UINT8 | RO | 0x14 (20dec)
803F:11 | GainS |  | UINT16 | RW | 0x4000 (16384dec)
803F:12 | OffsetS |  | INT16 | RW | 0x0000 (0dec)
803F:13 | GainP |  | UINT16 | RW | 0x4000 (16384dec)
803F:14 | OffsetP |  | INT16 | RW | 0x0000 (0dec)


Index F000 Modular device profile

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF) [image] Index F000 Modular device profile
Index F000 Modular device profile
Index | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0004 (4dec)


Index F008 Code word

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF) [image] Index F008 Code word
Index F008 Code word
Index | Name | Meaning | Data type | Flags | Default
F008:0 | Code word |  | UINT32 | RW | 0x00000000 (0dec)


Index F010 Module list

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF) [image] Index F010 Module list
Index F010 Module list
Index | Name | Meaning | Data type | Flags | Default
F010:0 | Module list |  | UINT8 | RW | 0x04 (4dec)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x0000010E (270dec)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x0000010E (270dec)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x0000010E (270dec)
F010:04 | SubIndex 004 |  | UINT32 | RW | 0x0000010E (270dec)


Index F607 DPO Inputs Device

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF) [image] Index F607 DPO Inputs Device
Index F607 DPO Inputs Device
Index | Name | Meaning | Data type | Flags | Default
F607:0 | DPO Inputs Device |  | UINT8 | RO | 0x10 (16dec)
F607:01 | Temperature Warning | A temperature of about 80 °C has been reached | boolean | RO | 0x00 (0dec)
F607:02 | Temperature Error | A critical temperature of about 85 °C has been reached, the outputs will be switched off. The bit must be reset by a Global Reset (F707:04) or by a voltage reset. No output can be switched on if the error bit is set. | boolean | RO | 0x00 (0dec)
F607:03 | Us Warning | Us is less than 21.5 V, no further outputs can be switched on. | boolean | RO | 0x00 (0dec)
F607:04 | Us Error | Us is less than 19 V, all Us outputs will be switched off. This bit must be reset by a Global Reset (F707:04) or by a voltage reset. No Us output can be switched on if the error bit is set. | boolean | RO | 0x00 (0dec)
F607:05 | Up Warning | See F607:03 | boolean | RO | 0x00 (0dec)
F607:06 | Up Error | See F607:04 | boolean | RO | 0x00 (0dec)
F607:07 | Global Error Bit | One of the error bits of the four channels or F607:02 or F607:04 or F60706 is set | boolean | RO | 0x00 (0dec)
F607:0C | Reset Input | 0: There is no voltage on the external reset input 1: 24 V is present on the external reset input (only if there is a reset input) | boolean | RO | 0x00 (0dec)
F607:0F | TxPDO State |  | boolean | RO | 0x00 (0dec)
F607:10 | TxPDO Toggle |  | boolean | RO | 0x00 (0dec)


Index F81F DPO Vendor Data Device

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF) [image] Index F81F DPO Vendor Data Device
Index F81F DPO Vendor Data Device
Index | Name | Meaning | Data type | Flags | Default
F81F:0 | DPO Vendor Data Device |  | UINT8 | RO | 0x1A (26dec)
F81F:01 | Enable Auto Offset Calibration | reserved | boolean | RW | 0x00 (0dec)
F81F:02 | Enable Crosstalk Compensation | reserved | boolean | RW | 0x01 (1dec)
F81F:10 | Enable Calibration Mode | reserved | boolean | RW | 0x00 (0dec)
F81F:11 | GainS | reserved | UINT16 | RW | 0x4000 (16384dec)
F81F:12 | OffsetS | reserved | INT16 | RW | 0x0000 (0dec)
F81F:13 | GainP | reserved | UINT16 | RW | 0x4000 (16384dec)
F81F:14 | OffsetP | reserved | INT16 | RW | 0x0000 (0dec)
F81F:15 | Gain US | reserved | UINT16 | RW | 0x4000 (16384dec)
F81F:16 | Offset US | reserved | INT16 | RW | 0x0000 (0dec)
F81F:17 | Gain UP | reserved | UINT16 | RW | 0x4000 (16384dec)
F81F:18 | Offset UP | reserved | INT16 | RW | 0x0000 (0dec)
F81F:19 | Gain Temperature | reserved | UINT16 | RW | 0x4000 (16384dec)
F81F:1A | Offset Temperature | reserved | INT16 | RW | 0x0000 (0dec)


Index 6010 DPO Inputs Ch.2

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF) [image] Index 6010 DPO Inputs Ch.2
Index 6010 DPO Inputs Ch.2
Index | Name | Meaning | Data type | Flags | Default
6010:0 | DPO Inputs Ch.2 | Inputs of the second channel | UINT8 | RO | 0x10 (16dec)
6010:01 | Error Us | The current monitoring of Us has tripped. The bit must be reset by a ‘Global Reset’ (F707:04) or by the corresponding Reset Us (7000:05). The output cannot be activated as long as the warning bit is 1. | boolean | RO | 0x00 (0dec)
6010:02 | Error Up | The current monitoring of Up has tripped. | boolean | RO | 0x00 (0dec)
6010:03 | Warning Us | The monitoring has detected overcurrent; the switching off of output Us on this channel is imminent if the current consumption of the branch does not decrease. | boolean | RO | 0x00 (0dec)
6010:04 | Warning Up | The monitoring has detected overcurrent; the switching off of output Us on this channel is imminent if the current consumption of the branch does not decrease. | boolean | RO | 0x00 (0dec)
6010:05 | Status Us | 0: The output is switched off 1: The output supplies 24 V | boolean | RO | 0x00 (0dec)
6010:06 | Status Up | 0: The output is switched off 1: The output supplies 24 V | boolean | RO | 0x00 (0dec)
6010:07 | Channel Error | 6010:01 or 6010:02 are set | boolean | RO | 0x00 (0dec)
6010:0E | Sync error |  | boolean | RO | 0x00 (0dec)
6010:0F | TxPDO State |  | boolean | RO | 0x00 (0dec)
6010:10 | TxPDO Toggle |  | boolean | RO | 0x00 (0dec)


Index 6020 DPO Inputs Ch.3

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF) [image] Index 6020 DPO Inputs Ch.3
Index 6020 DPO Inputs Ch.3
Index | Name | Meaning | Data type | Flags | Default
6020:0 | DPO Inputs Ch.3 | Inputs of the third channel | UINT8 | RO | 0x10 (16dec)
6020:01 | Error Us | The current monitoring of Us has tripped. The bit must be reset by a ‘Global Reset’ (F707:04) or by the corresponding Reset Us (7000:05). The output cannot be activated as long as the warning bit is 1. | boolean | RO | 0x00 (0dec)
6020:02 | Error Up | The current monitoring of Up has tripped. | boolean | RO | 0x00 (0dec)
6020:03 | Warning Us | The monitoring has detected overcurrent; the switching off of output Us on this channel is imminent if the current consumption of the branch does not decrease. | boolean | RO | 0x00 (0dec)
6020:04 | Warning Up | The monitoring has detected overcurrent; the switching off of output Us on this channel is imminent if the current consumption of the branch does not decrease. | boolean | RO | 0x00 (0dec)
6020:05 | Status Us | 0: The output is switched off 1: The output supplies 24 V | boolean | RO | 0x00 (0dec)
6020:06 | Status Up | 0: The output is switched off 1: The output supplies 24 V | boolean | RO | 0x00 (0dec)
6020:07 | Channel Error | 6020:01 or 6020:02 are set | boolean | RO | 0x00 (0dec)
6020:0E | Sync error |  | boolean | RO | 0x00 (0dec)
6020:0F | TxPDO State |  | boolean | RO | 0x00 (0dec)
6020:10 | TxPDO Toggle |  | boolean | RO | 0x00 (0dec)


Index 6030 DPO Inputs Ch.4

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF) [image] Index 6030 DPO Inputs Ch.4
Index 6030 DPO Inputs Ch.4
Index | Name | Meaning | Data type | Flags | Default
6030:0 | DPO Inputs Ch.4 | Inputs of the fourth channel | UINT8 | RO | 0x10 (16dec)
6030:01 | Error Us | The current monitoring of Us has tripped. The bit must be reset by a ‘Global Reset’ (F707:04) or by the corresponding Reset Us (7000:05). The output cannot be activated as long as the warning bit is 1. | boolean | RO | 0x00 (0dec)
6030:02 | Error Up | The current monitoring of Up has tripped. | boolean | RO | 0x00 (0dec)
6030:03 | Warning Us | The monitoring has detected overcurrent; the switching off of output Us on this channel is imminent if the current consumption of the branch does not decrease. | boolean | RO | 0x00 (0dec)
6030:04 | Warning Up | The monitoring has detected overcurrent; the switching off of output Us on this channel is imminent if the current consumption of the branch does not decrease. | boolean | RO | 0x00 (0dec)
6030:05 | Status Us | 0: The output is switched off 1: The output supplies 24 V | boolean | RO | 0x00 (0dec)
6030:06 | Status Up | 0: The output is switched off 1: The output supplies 24 V | boolean | RO | 0x00 (0dec)
6030:07 | Channel Error | 6020:01 or 6020:02 are set | boolean | RO | 0x00 (0dec)
6030:0E | Sync error |  | boolean | RO | 0x00 (0dec)
6030:0F | TxPDO State |  | boolean | RO | 0x00 (0dec)
6030:10 | TxPDO Toggle |  | boolean | RO | 0x00 (0dec)


Index 7000 DPO Outputs Ch.1

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF) [image] Index 7000 DPO Outputs Ch.1
Index 7000 DPO Outputs Ch.1
Index | Name | Meaning | Data type | Flags | Default
7000:0 | DPO Outputs Ch.1 |  | UINT8 | RO | 0x06 (6dec)
7000:01 | Output Us | 0: Us will be switched off 1: Us will be switched on | boolean | RO | 0x00 (0dec)
7000:02 | Output Up | 0: Us will be switched off 1: Us will be switched on | boolean | RO | 0x00 (0dec)
7000:05 | Reset Us | An error on Us will be reset | boolean | RO | 0x00 (0dec)
7000:06 | Reset Up | An error on Up will be reset | boolean | RO | 0x00 (0dec)


Index 7010 DPO Outputs Ch.2

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF) [image] Index 7010 DPO Outputs Ch.2
Index 7010 DPO Outputs Ch.2
Index | Name | Meaning | Data type | Flags | Default
7010:0 | DPO Outputs Ch.2 |  | UINT8 | RO | 0x06 (6dec)
7010:01 | Output Us | 0: Us will be switched off 1: Us will be switched on | boolean | RO | 0x00 (0dec)
7010:02 | Output Up | 0: Us will be switched off 1: Us will be switched on | boolean | RO | 0x00 (0dec)
7010:05 | Reset Us | An error on Us will be reset | boolean | RO | 0x00 (0dec)
7010:06 | Reset Up | An error on Up will be reset | boolean | RO | 0x00 (0dec)


Index 7020 DPO Outputs Ch.3

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF) [image] Index 7020 DPO Outputs Ch.3
Index 7020 DPO Outputs Ch.3
Index | Name | Meaning | Data type | Flags | Default
7020:0 | DPO Outputs Ch.3 |  | UINT8 | RO | 0x06 (6dec)
7020:01 | Output Us | 0: Us will be switched off 1: Us will be switched on | boolean | RO | 0x00 (0dec)
7020:02 | Output Up | 0: Us will be switched off 1: Us will be switched on | boolean | RO | 0x00 (0dec)
7020:05 | Reset Us | An error on Us will be reset | boolean | RO | 0x00 (0dec)
7020:06 | Reset Up | An error on Up will be reset | boolean | RO | 0x00 (0dec)


Index 7030 DPO Outputs Ch.4

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Profile-specific objects (0x6000-0xFFFF) [image] Index 7030 DPO Outputs Ch.4
Index 7030 DPO Outputs Ch.4
Index | Name | Meaning | Data type | Flags | Default
7030:0 | DPO Outputs Ch.4 |  | UINT8 | RO | 0x06 (6dec)
7030:01 | Output Us | 0: Us will be switched off 1: Us will be switched on | boolean | RO | 0x00 (0dec)
7030:02 | Output Up | 0: Us will be switched off 1: Us will be switched on | boolean | RO | 0x00 (0dec)
7030:05 | Reset Us | An error on Us will be reset | boolean | RO | 0x00 (0dec)
7030:06 | Reset Up | An error on Up will be reset | boolean | RO | 0x00 (0dec)


Index 100A Software Version

Commissioning and configuration [image] EP9214-0023 [image] EP9214-0023 – Object description [image] Standard objects [image] Index 100A Software Version
Index 100A Software Version
Index | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO | 06