EP9128-0021 - EtherCAT Junction with protection class IP67
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
2.3
▪
Title page updated
▪
Scope of supply added
▪
Structure update
2.2.1
▪
Nut torque for connectors extended
2.2.0
▪
Power Connection updated
2.1.0
▪
Nut torque for connectors extended
2.0.0
▪
Migration
1.1.0
▪
Chapter Basic Function Principles updated
▪
English translation available
1.0.0
▪
First release
0.1.0
▪
preliminary version
Firmware and hardware versions
This documentation refers to the firmware and hardware version that was applicable at the time the documentation was written.
The module features are continuously improved and developed further. Modules having earlier production statuses cannot have the same properties as modules with the latest status. However, existing properties are retained and are not changed, so that older modules can always be replaced with new ones.
The firmware and hardware version (delivery state) can be found in the batch number (D-number) printed on the side of the EtherCAT Box.
Syntax of the batch number (D-number)
D: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with D no. 29 10 02 01:
29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01
Further information on this topic: Version identification of EtherCAT devices.


EtherCAT Box - Introduction

EtherCAT Box - Introduction
EtherCAT Box - Introduction
The EtherCAT system has been extended with EtherCAT Box modules with protection class IP 67. Through the integrated EtherCAT interface the modules can be connected directly to an EtherCAT network without an additional Coupler Box. The high-performance of EtherCAT is thus maintained into each module.
The extremely low dimensions of only 126 x 30 x 26.5 mm (h x w x d) are identical to those of the Fieldbus Box extension modules. They are thus particularly suitable for use where space is at a premium. The small mass of the EtherCAT modules facilitates applications with mobile I/O interface (e.g. on a robot arm). The EtherCAT connection is established via screened M8 connectors.
EtherCAT Box Modules within an EtherCAT network
The robust design of the EtherCAT Box modules enables them to be used directly at the machine. Control cabinets and terminal boxes are now no longer required. The modules are fully sealed and therefore ideally prepared for wet, dirty or dusty conditions.
Pre-assembled cables significantly simplify EtherCAT and signal wiring. Very few wiring errors are made, so that commissioning is optimized. In addition to pre-assembled EtherCAT, power and sensor cables, field-configurable connectors and cables are available for maximum flexibility. Depending on the application, the sensors and actuators are connected through M8 or M12 connectors.
The EtherCAT modules cover the typical range of requirements for I/O signals with protection class IP67:
▪
digital inputs with different filters (3.0 ms or 10 μs)
▪
digital outputs with 0.5 or 2 A output current
▪
analog inputs and outputs with 16 bit resolution
▪
Thermocouple and RTD inputs
▪
Stepper motor modules
XFC (eXtreme Fast Control Technology) modules, including inputs with time stamp, are also available.
EtherCAT Box with M8 connections for sensors/actuators
EtherCAT Box with M12 connections for sensors/actuators
Basic EtherCAT documentation
You will find a detailed description of the EtherCAT system in the Basic System Documentation for EtherCAT, which is available for download from our website (www.beckhoff.com) under Downloads.
EtherCAT XML Device Description
You will find XML files (XML Device Description Files) for Beckhoff EtherCAT modules on our website (www.beckhoff.com) under Downloads, in the Configuration Files area.


Product overview

Product overview
Product overview
Additional information
•
Introduction
•
Technical data
•
Scope of supply


Introduction

Product overview [image] Introduction
Introduction
8 channel EtherCAT junction with protection class IP67
Line, tree or star: EtherCAT supports virtually any topologies, which can also be directly branched in the field using the EtherCAT Box modules
If several junctions are required at one point in the star topology, an EtherCAT junction EP9128 with eight sockets can be used instead of several EP1122.
The EtherCAT network is connected to the input port 1 of the EP9128-0021 and can be extended at ports 2 to 8
EtherCAT topologies can be arranged even more flexibly with the EP9128 EtherCAT junction in IP67, since connection to the IP20 world is also possible via the ports.
The EtherCAT junctions are connected via shielded M8 sockets with direct display of link and activity status.
In conjunction with TwinCAT or other suitable EtherCAT masters the EP9128-0021 also supports coupling and uncoupling of EtherCAT strands during operation (Hot Connect).
The device cannot be used as a standard Ethernet switch.
Quick links


Technical data

Product overview [image] Technical data
Technical data
Technical data | EP9128-0021
Fieldbus | EtherCAT
Functionality EtherCAT | coupling of EtherCAT junctions
Data transfer medium | Ethernet/EtherCAT cable (CAT 5 min.), shielded
Fieldbus connector copper | 8 x M8 socket (green)
Cable length | 100 m, twisted pair or in star quad formation CAT 5 (e)
Protocol | EtherCAT
Configuration | not necessary
Distributed Clocks | yes
Delay | app. 1 μsec / Port
Supply voltage | 24 VDC (18 VDC to 30 VDC)
Supply of module electronic | from control voltage Us
Current consumption of module electronic | typical 150 mA
Permissible ambient temperature at operation | -25...+60°C 0...+55°C (conforms to cULus, see UL requirements)
Permissible ambient temperature at storage | -40...+85°C
Dimensions (B x H x T) | 60 mm x 126 mm x 26.5 mm (without connectors)
Vibration / shock resistance | according to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | according to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (according to EN 60529)
Installation position | any
Weight | app. 300 g
Approvals | CE cULus (in preparation)


Scope of supply

Product overview [image] Scope of supply
Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EtherCAT Box EP9128-0021
▪
8x protective cap for EtherCAT socket, M8, green (pre-assembled)
▪
1x protective cap for supply voltage input, M8, transparent (pre-assembled)
▪
1x protective cap for supply voltage output, M8, black (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


Basic function principles

Basic function principles
Basic function principles
Additional information
•
Basic function principles of EtherCAT junctions
•
Basic function principles
•
LED displays


Basic function principles of EtherCAT junctions

Basic function principles [image] Basic function principles of EtherCAT junctions
Basic function principles of EtherCAT junctions
Some Beckhoff EtherCAT devices can be used for junctions in the EtherCAT segment. These include EK1122, EK1521, EP1122, CU1128 and EP9128. In the following examples only the EK1122 is used. The technical and system characteristics of the other devices are similar.
EtherCAT handling in the slaves
With EtherCAT as fieldbus protocol a wide range of bus topologies can be used: line, star and tree topology, with redundancy support even ring topology. The simplest topology is the line topology, in which each EtherCAT slave passes data only to the next slave.
EtherCAT line topology
When using EtherCAT Couplers, e.g. EK1100, it is possible to create a junction and therefore a kind of tree topology.
Line topology with extensions
The basic principle is that internally the Ethernet frame(s) with the EtherCAT protocol data continue to be transported in a logical ring:
▪
the EtherCAT master sends the frame via the two outgoing lines of the Ethernet cable
▪
this frame passes each slave once,
▪
the last logical slave reverses the frame and
▪
is returned to the master through each EtherCAT slave via two return lines of the Ethernet cable without further processing.
At short cycle times in the order of 50 µs at 20,000 Ethernet frames are in transit in the EtherCAT system every second, plus acyclic organizational frames. The master awaits the return of the sent frames, which return the device input data to the master, for example. Telegram transfer between slaves is link-based: An EtherCAT slave will only forward a frame if a 'link' signal to the next device is present. Normally it can be assumed that the downstream device correctly processes each EtherCAT telegram and returns or process it at the end.
The crucial factor for forwarding EtherCAT telegrams is that a link signal is reported only from one slave to the next if both slaves are actually ready for real-time participation in data processing. Specifically, this means that an EtherCAT slave should not open the respective Ethernet port until it is ready to receive and forward an Ethernet frame immediately.
A switch or router is usually used for standard Ethernet traffic forwarding. Any collisions or frame losses are compensated through frame repetition in the higher-level protocol layers (e.g. TCP). This mode is generally not used for EtherCAT due to the short cycle times and the real-time requirement. Some Ethernet devices such as special switches, for example, report a link to the remote terminal even if they will only be ready for data processing in a few milliseconds. This behavior is particularly noticeable in media converters from 100Base-TX (copper) to 100Base-Fx (optical fiber), which may report a link to the preceding EtherCAT slave even if the optical fiber connection is interrupted, depending on the setting on the copper side.
Fast link detection is therefore a central component of each ESC (EtherCAT Slave Controller, hardware processing unit for the EtherCAT protocol). According to the EtherCAT specification an ESC can have and control 1 to 4 ports. Via an open port it can handle outgoing and incoming Ethernet traffic. Fig. 3 shows the direction of the data flow in a fully configured ESC. In the EtherCAT datagrams the data are only processed between ports 0 (A) and 3 (D) in the EtherCAT processing unit.
Direction of data flow in the ESC
Ideally link detection and therefore port handling in the ESC should be fast enough that lost frame events are avoided even at 100 µs cycle time. Nevertheless, at least one lost frame can never be ruled out if a connection is disconnected while an Ethernet frame is in transit on this line and in the bus segment downstream of the separation point.
Implementation: EL terminal
A standard EtherCAT slave such as a Beckhoff EL terminal has 2 ports:
▪
one for incoming frames (port 0 [A])
▪
one for outgoing frames (e.g. port [D]).
The other two ports are internally closed in the ESC. An EtherCAT telegram enters the processing unit via port 0 (A)/top and is forwarded to the next slave via port 3 (D)/left, if a link to this port exists - see green arrows. This is the case if a further EL terminal is connected to the right.
If no link exists, the frame is forwarded to port 1(B) via the purple route. This and port 2 (C) have no link and therefore return the frame to port 0 (A), where the frame leaves via the same Ethernet port through which it arrived at the slave. This is the case if the terminal acts as end terminal.
An EtherCAT device with a single port is therefore only of limited use, since it can only be used as end device.
Implementation: EK1100 EtherCAT Coupler
Three of the four available ports in the EK1100 EtherCAT Coupler are used, thus enabling a connection to the right to terminals and via an RJ45 socket to further couplers; cf. Fig. Line topology with extensions. In the EK1100 the processing unit is not used for process data exchange.
Implementation: EK1122 EtherCAT junction
In the EK1122 all four ESC ports can be connected. two via the internal E-Bus and two via the RJ45 sockets with Ethernet configuration. In the TwinCAT System Manager the link statuses of ports 0, 1, 2 and 3 are indicated via the online display as port A, B, C and D, see Fig. Topology display for interrupted line.
Implementation: EK1521/EK1521-0010/EK1561 EtherCAT junction
As in the EK1100, three ESC ports can be connected in these junctions. Two via E-bus within the terminal and one via the SC socket/versatile link and optical fiber cable/POF line.
Implementation: CU1128 and EP9128 EtherCAT junctions
The CU1128 integrates three ESCs, which means eight ports in total are available to users. The three ESCs are interconnected via E-bus.
Example configuration with EK1122
The following section describes the link characteristics under TwinCAT and its representation in the System Manager.
Example configuration with EK1122
The wiring diagram is shown in the TwinCAT online topology, see Fig. Online topology. The EK1122 is selected, so that further information is shown. The green bars above the slaves indicate the correct RUN state in all slaves.
Online topology
An error is now generated by disconnecting the link between the upper RJ45 socket (X1) and the EL3102 device. Within a few µs the ESC in the EK1122 detects the lost link and automatically closes the affected port. This has the effect that the next incoming EtherCAT telegram is immediately forwarded to port D (port 3) and the EL4732. The link is missing here; the System Manager indicates this in the online display, see Fig. Example configuration with interrupted cable.
Example configuration with interrupted cable
The System Manager messages can be interpreted as follows:
▪
Address 1002 - EK1122: "OP LNK:MIS D": The slave is in OP state, although a link is missing at port D (3) that should be present according to the configuration
▪
Address 1003 - EK1100: "INIT NO_COMM": since communication with this slave is interrupted its state is shown as INIT
▪
Address 1004 - EL3104: ditto.
Logger output
The logger output can be displayed in the lower part of the System Manager (Display--> Show Logger Output). This may be helpful for diagnostic purposes (for link interruptions and other situations).
In the topology view this interruption is indicated by a red border around the affected slaves, see figure below.
Topology view with interrupted line
Note the display of the acyclic frames in Fig. Example configuration with EK1122 and Fig. Example configuration with interrupted line.
Comparison of the frame displays
The image on the left shows a small number (2) of acyclic frames sent by the master during the respective second - all slaves are operating properly. The image on the right shows a significant increase (currently 77 acyclic frames/sec): The EtherCAT master has quickly detected that not all slaves are properly taking part in the data exchange. Once the master has located the fault, it continuously tries to restore the connection.
Reconnection
Once the connection has been restored, the EK1122 reports to the master that a link is present again at port D (3). The EtherCAT master will then make its process data available again for this section. One the preparations are complete, it will instruct the EK1122 to re-open port D (3) for regular data exchange. Cyclic and acyclic data traffic with the other EtherCAT slaves continues normally.
External access to EtherCAT diagnostics
The system offers a wide range of options for accessing status and diagnostic information and EtherCAT master functions from the PLC. Almost all information displayed by the System Manager online can also be retrieved via ADS (see figures on this page). System Manager functions can also be triggered via PLC or ADS. Please refer to the relevant sections in the Beckhoff Information System and the notes on EtherCAT diagnostics.


Basic function principles

Basic function principles [image] Basic function principles
Basic function principles
The EtherCAT star hub EP9128 is an infrastructure device without controllable input/output data (I/O).
It can be used
▪
as a junction point for conducted Fast Ethernet, in order to connect EtherCAT terminal stations, drives or any other EtherCAT slaves to drop lines
▪
as distributed clocks reference clock (see EtherCAT System Documentation)
It has no I/O and no CoE directory and is not parameterizable. The core functions of the link control and distributed clocks synchronization are mapped by the ESCs.
Structure
In order to provide 8 EtherCAT ports, the EP9128 has three internal communication ICs (ESCs), which are connected in series internally. For this reason the EP9128 appears as three individual slaves in the EtherCAT configurator, although they are located in one housing. The interrelationship between the internal ESC ports (A, B, C, D) and the descriptions of the connection sockets (1 to 8) is as follows:
EP9128 diagram
Physical arrangement of the EP9128's ports
Accordingly, 3 devices are displayed in the TwinCAT System Manager:
Slaves in the TwinCAT System Manager
Please note:
▪
port 1 is always the input for the EtherCAT traffic in the EP9128
▪
the other ports (2 to 7) should be used as outputs
▪
it is not permitted to delete sub devices once the EP9128 has been configured
For differentiation see also EEPROM update.
Topological configuration
With the EP9128, special attention should be paid to the sequence of the EtherCAT slaves. Since the EP9128 has seven junction ports, drop lines connected to ports must and can be clearly identified in practice. If incorrect information is provided in the configuration (TwinCAT System Manager file *.tsm), the system cannot start.
For each EtherCAT device the System Manager indicates at which PreviousPort it is connected, i.e. the name of the connected port (B to D) of the previous slave. This also applies for the internal connections between the ESCs in the EP9128:
Previous port of the second ESC in the EP9128
The Fig. above shows a topology as an example, with
▪
EP1018-0002 at port 2
▪
EP7041-3002 at port 3
▪
EP3314-002 at port 4
▪
EP3744-0041 at port 5
▪
EP2624-0002 at port 6
▪
EP2008-0001 at port 7 und
▪
EP5151-0002 at port 8
Setting the PreviousPort for an EP box
In the Fig. above the box 6 successor is set up at port 5, which means the PreviousPort selection of the EP3744 shows the free port D of ESC2 (B and D, see Fig. EP9128 diagram).
The internal connections in the EP9128 are E-bus connections, the 8 ports on the other hand are Ethernet, see Fig. EP9128 diagram.
See also notes for configuration setup.


LED displays

Basic function principles [image] LED displays
LED displays
EtherCAT
For each channel an LED indicates the current status (example port2).
LED display per channel
LED | Display
Link Act | off | No connection
 | on | Connection available (link)
 | flashing | Data transfer (act)
Power supply
The presence of the supply voltages (24 VDC) is indicated by the two green Power LEDs.
Us is used for the module electronics, Up is passed through.
LED display for the supply voltages


Mounting and cabling

Mounting and cabling
Mounting and cabling
Additional information
•
Mounting
•
EtherCAT
•
Supply voltages
•
UL Requirements


Mounting

Mounting and cabling [image] Mounting
Mounting
Additional information
•
Dimensions
•
Fixing
•
Nut torque for connectors


Dimensions

Mounting and cabling [image] Mounting [image] Dimensions
Dimensions
All dimensions are given in millimeters.
Housing features
Housing material | PA6 (polyamide)
Sealing compound | polyurethane
Mounting | two fastening holes Ø 4.5 mm for M4
Metal parts | brass, nickel-plated
Contacts | CuZn, gold-plated
Power feed through | max. 4 A
Installation position | variable
Protection class | IP65, IP66, IP67 (conforms to EN 60529) when screwed together
Dimensions (H x W x D) | approx. 126 x 60 x 26.5 mm (without connectors)


Fixing

Mounting and cabling [image] Mounting [image] Fixing
Fixing
Note
Dirt during assembly
Dirty connectors can lead to malfunctions. Protection class IP67 can only be guaranteed if all cables and connectors are connected.
•
Protect the plug connectors against dirt during the assembly.
Mount the module with two M4 screws in the centrally located fastening holes.


Nut torque for connectors

Mounting and cabling [image] Mounting [image] Nut torque for connectors
Nut torque for connectors
Screw M8 connectors tight with a torque wrench. (e.g. ZB8801 from Beckhoff)
Torque: 0.4 Nm.


EtherCAT

Mounting and cabling [image] EtherCAT
EtherCAT
Additional information
•
Connectors
•
Status LEDs
•
Cables


Connectors

Mounting and cabling [image] EtherCAT [image] Connectors
Connectors
Note
Risk of confusion: supply voltages and EtherCAT
Defect possible through incorrect insertion.
•
Observe the color coding of the connectors:
black: Supply voltages
green: EtherCAT
The EtherCAT connections are implemented as green M8 sockets.
M8-Buchse 4polig Kontaktbelegung
EtherCAT connector
EtherCAT | M8 connector | Core colors
Signal | Contact | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 and old versions of ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | 1 | yellow1) | orange/white | white/orange
Tx - | 4 | orange1) | orange | orange
Rx + | 2 | white1) | blue/white | white/green
Rx - | 3 | blue1) | blue | green
Shield | Housing | Shield | Shield | Shield
1) Core colors according to EN 61918
Adaptation of core colors for cables ZB9030, ZB9032 and ZK1090-3xxxx-xxxx
For standardization, the core colors of the ZB9030, ZB9032 and ZK1090-3xxx-xxxx cables have been changed to the EN61918 core colors: yellow, orange, white, blue. So there are different color codes in circulation. The electrical properties of the cables have been retained when the core colors were changed.


Status LEDs

Mounting and cabling [image] EtherCAT [image] Status LEDs
Status LEDs
L/A (Link/Act)
A green LED labelled "L/A" is located next to each EtherCAT socket. The LED indicates the communication state of the respective socket:
LED | Meaning
off | no connection to the connected EtherCAT device
lit | LINK: connection to the connected EtherCAT device
flashes | ACT: communication with the connected EtherCAT device
Run
Each EtherCAT slave has a green LED labelled "Run". The LED signals the status of the slave in the EtherCAT network:
LED | Meaning
off | Slave is in "Init" state
flashes uniformly | Slave is in "Pre-Operational“ state
flashes sporadically | Slave is in "Safe-Operational" state
lit | Slave is in "Operational" state
Description of the EtherCAT slave states


Cables

Mounting and cabling [image] EtherCAT [image] Cables
Cables
For connecting EtherCAT devices only shielded Ethernet cables that meet the requirements of at least category 5 (CAT5) according to EN 50173 or ISO/IEC 11801 should be used.
EtherCAT uses four wires for signal transmission.
Thanks to automatic line detection ("Auto MDI-X"), both symmetrical (1:1) or cross-over cables can be used between Beckhoff EtherCAT.
Detailed recommendations for the cabling of EtherCAT devices


Supply voltages

Mounting and cabling [image] Supply voltages
Supply voltages
The EtherCAT Box is supplied with two supply voltages. The supply voltages are electrically isolated in the EtherCAT Box.
▪
Control voltage US
▪
Peripheral voltage UP
Redirection of the supply voltages
The IN and OUT power connections are bridged in the module (not IP204x-Bxxx and IE204x). The supply voltages US and UP can thus easily be transferred from EtherCAT Box to EtherCAT Box.
Note
Pay attention to the maximum permissible current!
Pay attention also for the redirection of the supply voltages US and UP, the maximum permissible current for M8 connectors of 4 A must not be exceeded!
Additional information
•
Connectors
•
Status LEDs
•
Conductor losses


Connectors

Mounting and cabling [image] Supply voltages [image] Connectors
Connectors
Note
Risk of confusion: supply voltages and EtherCAT
Defect possible through incorrect insertion.
•
Observe the color coding of the connectors:
black: Supply voltages
green: EtherCAT
Connectors + LEDs
Connectors for supply voltages
M8 connector
Contact | Function | Description | Core color 1)
1 | US | Control voltage | Brown
2 | UP | Peripheral voltage | White
3 | GNDS | GND to US | Blue
4 | GNDP | GND to UP | Black
1) The core colors apply to cables of the type: Beckhoff ZK2020-3xxx-xxxx


Status LEDs

Mounting and cabling [image] Supply voltages [image] Status LEDs
Status LEDs
Connectors + LEDs
Status LEDs for the supply voltages
LED | Display | Meaning
US (control voltage) | off | Supply voltage US is not present
 | green illuminated | Supply voltage US is present
UP (peripheral voltage) | off | Supply voltage UP is not present
 | green illuminated | Supply voltage UP is present


Conductor losses

Mounting and cabling [image] Supply voltages [image] Conductor losses
Conductor losses
Take into account the voltage drop on the supply line when planning a system. Avoid the voltage drop being so high that the supply voltage at the box lies below the minimum nominal voltage.
Variations in the voltage of the power supply unit must also be taken into account.
Voltage drop on the supply line
Leitungsverluste M8 2A
Leitungsverluste M8 4A


UL Requirements

Mounting and cabling [image] UL Requirements
UL Requirements
The installation of the EtherCAT Box Modules certified by UL has to meet the following requirements.
Supply voltage
SmallWarningYellow CAUTION
CAUTION!
This UL requirements are valid for all supply voltages of all marked EtherCAT Box Modules!
For the compliance of the UL requirements the EtherCAT Box Modules should only be supplied
•
by a 24 VDC supply voltage, supplied by an isolating source and protected by means of a fuse (in accordance with UL248), rated maximum 4 Amp, or
•
by a 24 VDC power source, that has to satisfy NEC class 2.
A NEC class 2 power supply shall not be connected in series or parallel with another (class 2) power source!
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, the EtherCAT Box Modules must not be connected to unlimited power sources!
Networks
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, EtherCAT Box Modules must not be connected to telecommunication networks!
Ambient temperature range
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, EtherCAT Box Modules has to be operated only at an ambient temperature range of 0 to 55°C!
Marking for UL
All EtherCAT Box Modules certified by UL (Underwriters Laboratories) are marked with the following label.
UL label


Appendix

Appendix
Appendix
Additional information
•
General operating conditions
•
EEPROM update
•
Accessories
•
Version identification of EtherCAT devices
•
Support and Service


General operating conditions

Appendix [image] General operating conditions
General operating conditions
Protection degrees (IP-Code)
The standard IEC 60529 (DIN EN 60529) defines the degrees of protection in different classes.
1. Number: dust protection and touch guard | Definition
0 | Non-protected
1 | Protected against access to hazardous parts with the back of a hand. Protected against solid foreign objects of Ø 50 mm
2 | Protected against access to hazardous parts with a finger. Protected against solid foreign objects of Ø 12.5 mm.
3 | Protected against access to hazardous parts with a tool. Protected against solid foreign objects Ø 2.5 mm.
4 | Protected against access to hazardous parts with a wire. Protected against solid foreign objects Ø 1 mm.
5 | Protected against access to hazardous parts with a wire. Dust-protected. Intrusion of dust is not totally prevented, but dust shall not penetrate in a quantity to interfere with satisfactory operation of the device or to impair safety.
6 | Protected against access to hazardous parts with a wire. Dust-tight. No intrusion of dust.
2. Number: water* protection | Definition
0 | Non-protected
1 | Protected against water drops
2 | Protected against water drops when enclosure tilted up to 15°.
3 | Protected against spraying water. Water sprayed at an angle up to 60° on either side of the vertical shall have no harmful effects.
4 | Protected against splashing water. Water splashed against the disclosure from any direction shall have no harmful effects
5 | Protected against water jets
6 | Protected against powerful water jets
7 | Protected against the effects of temporary immersion in water. Intrusion of water in quantities causing harmful effects shall not be possible when the enclosure is temporarily immersed in water for 30 min. in 1 m depth.
*) These protection classes define only protection against water!
Chemical Resistance
The Resistance relates to the Housing of the IP 67 modules and the used metal parts. In the table below you will find some typical resistance.
Character | Resistance
Steam | at temperatures >100°C: not resistant
Sodium base liquor (ph-Value > 12) | at room temperature: resistant > 40°C: not resistant
Acetic acid | not resistant
Argon (technical clean) | resistant
Key
▪
resistant: Lifetime several months
▪
non inherently resistant: Lifetime several weeks
▪
not resistant: Lifetime several hours resp. early decomposition


EEPROM update

Appendix [image] EEPROM update
EEPROM update
The EP9128 features 3 internal EtherCAT slave controllers (ESC). This means that 3 EEPROMs are available for write access. In the EP9128 they are different, since all 3 ESCs have different port technology (Ethernet or E-bus), see Fig. 1.
Fig. 1: The 3 internal ESC names of the EP9128
The main slave is the EP9128-0000, in this case revision -0000. The two following internal slaves are EP9128-0001 and EP9128-0002.
The EEPROM can be updated via the EEPROM Update dialog in the System Manager. This is only necessary in special cases and should only be done if instructed by Beckhoff support/service.
Fig. 2: EEPROM Update TwinCAT
All 3 internal ESCs can be write-accessed sequentially, followed by an off/on restart, in order to load the EEPROM. See Fig. 3 for assignment in the TwinCAT selection dialog.
Fig. 3: Currently available EEPROM descriptions for EP9128 and assignment


Accessories

Appendix [image] Accessories
Accessories
Mounting
Ordering information | Description
ZS5300-0001 | Mounting rail (500 mm x 129 mm)
Labeling material, protective caps
Ordering information | Description
ZS5000-0010 | Protective cap for M8 sockets, IP67 (50 pieces)
ZS5100-0000 | Inscription labels, unprinted, 4 strips of 10
ZS5000-xxxx | Printed inscription labels on enquiry
Cables
Ordering information | Description
ZK1090-3xxx-xxxx | EtherCAT cable M8, green link to the website
ZK1093-3xxx-xxxx | EtherCAT cable M8, yellow link to the website
A complete overview of pre-assembled cables for EtherCAT Box modules can be found here.
Tools
Ordering information | Description
ZB8801-0000 | Torque wrench for plugs, 0.4…1.0 Nm
ZB8801-0001 | Torque cable key for M8 / wrench size 9 for ZB8801-0000
Further accessories
Further accessories can be found in the price list for fieldbus components from Beckhoff and online at https://www.beckhoff.com.


Version identification of EtherCAT devices

Appendix [image] Version identification of EtherCAT devices
Version identification of EtherCAT devices
Designation
A Beckhoff EtherCAT device has a 14-digit designation, made up of
▪
family key
▪
type
▪
version
▪
revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
Notes
▪
The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
▪
EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
▪
The order identifier is made up of
- family key (EL, EP, CU, ES, KL, CX, etc.)
- type (3314)
- version (-0000)
▪
The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
▪
The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Identification number
Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:
Production lot/batch number/serial number/date code/D number
The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02
Exceptions can occur in the IP67 area, where the following syntax can be used (see respective device documentation):
Syntax: D ww yy x y z u
D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB
Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1
Unique serial number/ID, ID number
In addition, in some series each individual module has its own unique serial number.
See also the further documentation in the area
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Terminals with factory calibration certificate and other measuring terminals
Examples of markings
EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
CU2016 switch with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
EP1258-00001 IP67 EtherCAT Box with batch number/ date code 22090101 and unique serial number 158102
EP1908-0002 IP67 EtherCAT Safety Box with batch number/ date code 071201FF and unique serial number 00346070
EL2904 IP20 safety terminal with batch number/ date code 50110302 and unique serial number 00331701
ELM3604-0002 terminal with unique ID number (QR code) 100001051 and serial/ batch number 44160201
Additional information
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Appendix [image] Version identification of EtherCAT devices [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com