EP8309-1022 - Multifunctional EtherCAT Box
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation Issue Status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation Issue Status

Foreword [image] Documentation Issue Status
Documentation Issue Status
Version
Comment
2.1
▪
Front page updated
▪
Scope of supply added
▪
Structure update
2.0.0
▪
Migration
▪
Technical data updated
1.1.0
▪
Power Connection updated
1.0.0
▪
First release
Firmware and hardware versions
This documentation refers to the firmware and hardware version that was applicable at the time the documentation was written.
The module features are continuously improved and developed further. Modules having earlier production statuses cannot have the same properties as modules with the latest status. However, existing properties are retained and are not changed, so that older modules can always be replaced with new ones.
Documentation | Firmware | Hardware
2.1 | 06 | 07
2.0.0 | 06 | 06
1.0.0 | 06 | 03
The firmware and hardware version (delivery state) can be found in the batch number (D-number) printed on the side of the EtherCAT Box.
Syntax of the batch number (D-number)
D: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with D no. 29 10 02 01:
29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01
Further information on this topic: Version identification of EtherCAT devices.


EtherCAT Box - Introduction

EtherCAT Box - Introduction
EtherCAT Box - Introduction
The EtherCAT system has been extended with EtherCAT Box modules with protection class IP 67. Through the integrated EtherCAT interface the modules can be connected directly to an EtherCAT network without an additional Coupler Box. The high-performance of EtherCAT is thus maintained into each module.
The extremely low dimensions of only 126 x 30 x 26.5 mm (h x w x d) are identical to those of the Fieldbus Box extension modules. They are thus particularly suitable for use where space is at a premium. The small mass of the EtherCAT modules facilitates applications with mobile I/O interface (e.g. on a robot arm). The EtherCAT connection is established via screened M8 connectors.
EtherCAT Box Modules within an EtherCAT network
The robust design of the EtherCAT Box modules enables them to be used directly at the machine. Control cabinets and terminal boxes are now no longer required. The modules are fully sealed and therefore ideally prepared for wet, dirty or dusty conditions.
Pre-assembled cables significantly simplify EtherCAT and signal wiring. Very few wiring errors are made, so that commissioning is optimized. In addition to pre-assembled EtherCAT, power and sensor cables, field-configurable connectors and cables are available for maximum flexibility. Depending on the application, the sensors and actuators are connected through M8 or M12 connectors.
The EtherCAT modules cover the typical range of requirements for I/O signals with protection class IP67:
▪
digital inputs with different filters (3.0 ms or 10 μs)
▪
digital outputs with 0.5 or 2 A output current
▪
analog inputs and outputs with 16 bit resolution
▪
Thermocouple and RTD inputs
▪
Stepper motor modules
XFC (eXtreme Fast Control Technology) modules, including inputs with time stamp, are also available.
EtherCAT Box with M8 connections for sensors/actuators
EtherCAT Box with M12 connections for sensors/actuators
Basic EtherCAT documentation
You will find a detailed description of the EtherCAT system in the Basic System Documentation for EtherCAT, which is available for download from our website (www.beckhoff.com) under Downloads.
EtherCAT XML Device Description
You will find XML files (XML Device Description Files) for Beckhoff EtherCAT modules on our website (www.beckhoff.com) under Downloads, in the Configuration Files area.


Product Overview

Product Overview
Product Overview
Additional information
•
Introduction
•
Technical data
•
Scope of supply
•
Process image
•
Pulse width modulation (PWM)
•
Influencing of the PWMi output value by the parameters


Introduction

Product Overview [image] Introduction
Introduction
EP8309
EtherCAT Box with different digital and analog inputs and outputs
The EP8309-x022 EtherCAT Box has various digital and analog inputs and outputs.
The analog signals can be processed and output in the range 0/4…20 mA, the digital signals in the range 24 VDC.
The possible output currents are different and can be found in the technical data.
The resolution for the current signals takes place with 12 bits, signed. This applies to input and output signals.
The signal channels and the 24 VDC supply have a common ground potential.
A PWMi output is integrated for connecting a proportional valve. For valves with integrated electronics, this output can alternatively be operated as an analog current output with continuous 24V supply for the valve.
Quick links
Technical data


Technical data

Product Overview [image] Technical data
Technical data
Fieldbus
Technical Data | EP8309-x022
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Tacho inputs
Technical Data | EP8309-x022
Number of tacho inputs | 1 or 2 (dual-shaft mode or single-shaft mode)
Input type | Single-shaft mode: two digital sensors on a common axis Dual-shaft mode: two digital sensors on two different axes, no direction detection, no error detection)
Tacho inputs connection | M12
Rated input voltage | 24 VDC (-15%/+20%)
Input filter | 2.5 kHz
Signal voltage "0" | -3...+5 V (EN 61131-2, type 3)
Signal voltage "1" | +11...+30 V (EN 61131-2, type 3)
Input current | typically 3 mA (EN 61131-2, type 3)
Sensor supply | from the control voltage Us
Current consumption of the sensors | max. 0.5 A, short-circuit-proof overall
Digital inputs and outputs (DIO)
Technical Data | EP8309-x022
Number of digital inputs and outputs (DIO) | 8
Inputs |
Input connections | M12
Rated input voltage | 24 VDC (-15%/+20%)
Input filter | 3.0 ms
Signal voltage "0" | -3...+5 V (EN 61131-2, type 3)
Signal voltage "1" | +11...+30 V (EN 61131-2, type 3)
Input current | typically 3 mA (EN 61131-2, type 3)
Sensor supply | from the control voltage Us
Current consumption of the sensors | max. 0.5 A, short-circuit-proof overall
Outputs |
Output connections | M12
Load type | ohmic, inductive, lamp load
Rated output voltage | 24 VDC (-15%/+20%)
Output current | max. 0.5 A per channel for sockets 4 and 5 max. 1.0 A per channel for sockets 6 and 7
Short circuit current | typically 1.5 A
Output driver supply | from load voltage Up
Output driver current consumption | typically 8 mA per channel
PWM outputs
Technical Data | EP8309-x022
Number of PWM outputs (alternatively analog output) | 1
Output connections | M12
Load type | ohmic/inductive > 1 mH
Supply for the output stage | 24 VDC via power contacts
Output current per channel | 1.2 A (short-circuit-proof, common thermal overload warning for both output stages)
PWM clock frequency | approx. 30 kHz
Rated load voltage | 24 VDC (-15 %/+20 %)
Resolution | 10 bit
Distributed Clocks | yes
Analog inputs (AI)
Technical Data | EP8309-x022
Number of analog inputs | 2
Input connections | M12 sockets
Signal type | 0…20 mA or 4…20 mA (can be set for each CoE)
Input resistance | 85 Ω typ. + diode voltage
Resolution | 12 bit (including sign)
Input filter limit frequency | 5 kHz
Conversion time | approx. 100 µs
Measuring error | < 0,3 % (relative to full scale value)
Analog outputs (AO)
Technical Data | EP8309-x022
Number of analog outputs (alternatively PWMi output) | 1
Output connections | M12 sockets
Signal type | 0…20 mA or 4…20 mA (can be set for each CoE)
Load | < 500 Ω
Resolution | 12 bit
Conversion time | approx. 40 µs
Measuring error | < 0,3 % (relative to full scale value)
General technical data
Technical Data | EP8309-x022
Special features | Multi-function module
Module electronic supply | from the control voltage Us
Module electronic current consumption | typically 120 mA
Sensor supply | from load voltage Up, DC, any value up to 30 V
Actuator supply | from load voltage Up, DC, any value up to 30 V
Power supply connection | Power supply: 1 x M8 plug, 4-pole Onward connection: 1 x M8 socket, 4-pole
Process image | Inputs: 2 x 16 bit Outputs: 2 x 16 bit
Electrical isolation | Control voltage / fieldbus: 500 V
Weight | approx. 165 g
Permissible ambient temperature during operation | -25°C ... +60°C
Permissible ambient temperature during storage | -40°C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (according to EN 60529)
Installation position | variable
Approvals | CE, cULus


Scope of supply

Product Overview [image] Scope of supply
Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EtherCAT Box EP8309-1022
▪
2x protective cap for EtherCAT socket, M8, green (pre-assembled)
▪
1x protective cap for supply voltage input, M8, transparent (pre-assembled)
▪
1x protective cap for supply voltage output, M8, black (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


Process image

Product Overview [image] Process image
Process image
In the default setting the EP8309 is configured for:
▪
analog input channel 1
▪
analog input channel 2
▪
Tacho signal from two sensors on one axis (single-shaft mode)
▪
6 digital inputs
▪
Status of PWM output
▪
Acknowledge / Reset in the event of a PWM error.
▪
6 digital outputs
▪
General EtherCAT process data
AI Inputs Channel 1 and 2
The data for the first analog channel can be found under AI Inputs Channel 1.
Underrange: Value of the analog input is less than 0/4 mA or -10/0 V
Overrange: Value of the analog input is greater than 20 mA or +10 V
Limit 1: with activated Limit 1 (object 0x8000:07 = 1) means
1: value less than limit 1 (set in object 0x8000:13)
2: value greater than limit 1 (set in object 0x8000:13)
3: value equal to limit 1 (set in object 0x8000:13)
Limit 2: with activated Limit 2 (object 0x8000:08 = 1) means
1: value less than limit 2 (set in object 0x8000:14)
2: value greater than limit 2 (set in object 0x8000:14)
3: value equal to limit 2 (set in object 0x8000:14)
Error: This bit is set if over- or under-range was detected.
Tacho single-shaft mode (depending on the setting in the PDO assignment)
The data for the tacho input can be found under TACHO Single Shaft Mode Input Channel 1.
see data under commissioning
Tacho dual-shaft mode (depending on the setting in the PDO assignment)
The data for the tacho input can be found under TACHO Dual Shaft Mode Input Channel 1 or 2.
see data under commissioning
DIG Inputs
The data for the digital inputs can be found under DIG Inputs.
X4 Pin4 -> socket 4, pin 4
....
PWM Status
The data for the PWM output can be found under PWM Status
DEV Inputs
The diagnostic data for the two voltages Us and Up can be found under DEV Inputs.
TRUE = voltage <= approx. 18 VDC
....
TACHO Output Channel 1
The control data for the tacho input can be found under TACHO Output Channel 1.
Reset Error - error reset
DO Outputs
The data for the digital outputs can be found under DO Outputs.
X5 pin4 -> socket 5, pin 4
....
PWM control (activated through PDO assignment 0x1602, default PWM, alternatively AO)
The control data for the PWM output can be found under PWM Control.
Enable Dithering -> activate dithering
Enable -> activate PWM output
Reset -> reset on error
PWM output -> load-independent current, depending on module rating (e.g. 1.2 A and setting in object 0x8060:10)
AO outputs (activated through PDO assignment 0x1603), not activated by default
The values for the analog output can be found under AO Outputs.
Analog Output - output value


Pulse width modulation (PWM)

Product Overview [image] Pulse width modulation (PWM)
Pulse width modulation (PWM)
The Beckhoff terminals and box modules integrate compact PWM output stages in the smallest of designs.
PWM output stages control the output current through pulse width modulation (PWM) of the supply voltage. This means that the full supply voltage is activated or deactivated at the output. The duty cycle (pulse width) is modified, but not the voltage level. The current is built up based on the load connected to the inductance.
Operation at load with adequate inductance
Operation at load with inadequate inductance (near ohmic)
The figure Operation at load with inadequate inductance (virtually ohmic) illustrates operation with an inadequate inductance. Continuous current flow is not reached. The current has "gaps". This mode of operation is not permitted.
Pulse width current terminals require inductive loads
The load inductance should have a minimum inductance of 1 mH. Operation of the pulse width current terminals at loads with an inductance of less than 1 mH is not recommended, since the intermittent current flow prevents reference between the set value and the arithmetic mean of the current.


Influencing of the PWMi output value by the parameters

Product Overview [image] Influencing of the PWMi output value by the parameters
Influencing of the PWMi output value by the parameters
Influencing of the PWMi output value


Mounting and cabling

Mounting and cabling
Mounting and cabling
Additional information
•
Mounting
•
Cabling


Mounting

Mounting and cabling [image] Mounting
Mounting
Additional information
•
Dimensions
•
Tightening torques for plug connectors


Dimensions

Mounting and cabling [image] Mounting [image] Dimensions
Dimensions
Dimensions
All dimensions are given in millimeters.
Housing features
Housing material | PA6 (polyamide)
Sealing compound | polyurethane
Mounting | two fastening holes Ø 4.5 mm for M4
Metal parts | brass, nickel-plated
Contacts | CuZn, gold-plated
Power feed through | max. 4 A
Installation position | variable
Protection class | IP65, IP66, IP67 (conforms to EN 60529) when screwed together
Dimensions (H x W x D) | approx. 126 x 60 x 26.5 mm (without connectors)


Tightening torques for plug connectors

Mounting and cabling [image] Mounting [image] Tightening torques for plug connectors
Tightening torques for plug connectors
Screw connectors tight with a torque wrench. (e.g. ZB8801 from Beckhoff)
Connector diameter | Tightening torque
M8 | 0.4 Nm
M12 | 0.6 Nm


Cabling

Mounting and cabling [image] Cabling
Cabling
Additional information
•
Connections
•
EtherCAT
•
Power Connection
•
Signal connection
•
UL Requirements


Connections

Mounting and cabling [image] Cabling [image] Connections
Connections
The EP8309 has different signals that can be connected via the eight M12 sockets.
Comment
Connector
Comment
EtherCAT IN
EtherCAT OUT
Socket 1:
▪
analog In
Socket 5:
▪
digital In/Out channel 1
▪
digital In/Out channel 2
Socket 2:
▪
analog In
Socket 6:
▪
digital In/Out channel 1
▪
digital In/Out channel 2
Socket 3:
▪
digital In channel 1 / Tacho input 1
▪
digital In channel 2 / Tacho input 2
Socket 7:
▪
digital In/Out channel 3
▪
digital In/Out channel 4
Socket 4:
▪
digital In/Out channel 3
▪
digital In/Out channel 4
Socket 8:
▪
pulse width current output or
▪
analog output
Power In
Power Out


EtherCAT

Mounting and cabling [image] Cabling [image] EtherCAT
EtherCAT
Additional information
•
Connectors
•
Status LEDs
•
Cables


Connectors

Mounting and cabling [image] Cabling [image] EtherCAT [image] Connectors
Connectors
Note
Risk of confusion: supply voltages and EtherCAT
Defect possible through incorrect insertion.
•
Observe the color coding of the connectors:
black: Supply voltages
green: EtherCAT
EtherCAT Box Modules have two green M8 sockets for the incoming and downstream EtherCAT connections.
EtherCAT connectors
Connection
M8 socket, 4-pin – connection
M8 socket
EtherCAT | M8 connector | Core colors
Signal | Contact | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 and old versions of ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | 1 | yellow1) | orange/white | white/orange
Tx - | 4 | orange1) | orange | orange
Rx + | 2 | white1) | blue/white | white/green
Rx - | 3 | blue1) | blue | green
Shield | Housing | Shield | Shield | Shield
1) Core colors according to EN 61918
Adaptation of core colors for cables ZB9030, ZB9032 and ZK1090-3xxxx-xxxx
For standardization, the core colors of the ZB9030, ZB9032 and ZK1090-3xxx-xxxx cables have been changed to the EN61918 core colors: yellow, orange, white, blue. So there are different color codes in circulation. The electrical properties of the cables have been retained when the core colors were changed.


Status LEDs

Mounting and cabling [image] Cabling [image] EtherCAT [image] Status LEDs
Status LEDs
EtherCAT Status LEDs
L/A (Link/Act)
A green LED labelled "L/A" is located next to each EtherCAT socket. The LED indicates the communication state of the respective socket:
LED | Meaning
off | no connection to the connected EtherCAT device
lit | LINK: connection to the connected EtherCAT device
flashes | ACT: communication with the connected EtherCAT device
Run
Each EtherCAT slave has a green LED labelled "Run". The LED signals the status of the slave in the EtherCAT network:
LED | Meaning
off | Slave is in "Init" state
flashes uniformly | Slave is in "Pre-Operational“ state
flashes sporadically | Slave is in "Safe-Operational" state
lit | Slave is in "Operational" state
Description of the EtherCAT slave states


Cables

Mounting and cabling [image] Cabling [image] EtherCAT [image] Cables
Cables
For connecting EtherCAT devices only shielded Ethernet cables that meet the requirements of at least category 5 (CAT5) according to EN 50173 or ISO/IEC 11801 should be used.
EtherCAT uses four wires for signal transmission.
Thanks to automatic line detection ("Auto MDI-X"), both symmetrical (1:1) or cross-over cables can be used between Beckhoff EtherCAT.
Detailed recommendations for the cabling of EtherCAT devices


Power Connection

Mounting and cabling [image] Cabling [image] Power Connection
Power Connection
Additional information
•
Power Connection
•
Status LEDs for power supply
•
Power cable
•
Power cable conductor losses M8


Power Connection

Mounting and cabling [image] Cabling [image] Power Connection [image] Power Connection
Power Connection
The feeding and forwarding of supply voltages is done via two M8 connectors at the bottom end of the modules:
▪
IN: left M8 connector for feeding the supply voltages
▪
OUT: right M8 connector for forwarding the supply voltages
EtherCAT Box, Connectors for power supply
Pin assignment M8, Power In and Power Out
PIN assignment
Pin | Voltage
1 | Control voltage Us, +24 VDC
2 | Auxiliary voltage Up, +24 VDC
3 | GNDs* | *) may be connected internally to each other depending on the module: see specific module descriptions
4 | GNDp*
The pins M8 connectors carry a maximum current of 4 A.
Two LEDs display the status of the supply voltages.
Note
Don't confuse the power connectors with the EtherCAT connectors!
Never connect the power cables (M8, 24 VDC) with the green marked EtherCAT sockets of the EtherCAT Box Modules! This can damage the modules!
Control voltage US
Power is supplied to the fieldbus, the processor logic, the inputs and the sensors from the control voltage US. The control voltage is electrically isolated from the fieldbus circuitry.
Peripheral voltage UP
The peripheral voltage UP supplies the digital outputs; it can be brought in separately. Hence, if the peripheral voltage is switched off, the fieldbus function as well as the supply and function of the inputs are retained.
Redirection of the supply voltages
The IN and OUT power connections are bridged in the module (not IP204x-Bxxx and IE204x). The supply voltages US and UP can thus easily be transferred from EtherCAT Box to EtherCAT Box.
Note
Pay attention to the maximum permissible current!
Pay attention also for the redirection of the supply voltages US and UP, the maximum permissible current for M8 connectors of 4 A must not be exceeded!
Supply via EP92x4-0023 PowerBox modules
If the machine requires higher current or if the EtherCAT Box Modules are installed far away from the control cabinet with included power supply, the usage of four cannel power distribution modules EP9214 or EP9224 (with integrated data logging, see www.beckhoff.com/EP9224) is recommended.
With these modules intelligent power distribution concepts with up to 2 x 16 A and a maximum of 2.5 mm² cable cross-section can be realized.
EP92x4-0023, Connectors for Power In and Power Out
Pin assignment 7/8”, Power In and Power Out
Electrical isolation
Digital modules
In the digital input/output modules, the grounds of the control voltage (GNDs) and the auxiliary voltage (GNDp) are connected to each other!
Check this at the documentation of each used EtherCAT Box.
Analog modules
In the analog input/output modules the grounds of the control voltage (GNDs) and the auxiliary voltage (GNDp) are separated from each other in order to ensure electrical isolation of the analog signals from the control voltage.
In some of the analog modules the sensors or actuators are supplied by Up - this means, for instance, that in the case of 0...10 V inputs, any reference voltage (0...30 V) may be connected to Up; this is then available to the sensors (e.g. smoothed 10 V for measuring potentiometers).
Details of the power supply may be taken from the specific module descriptions.
Note
Electrical isolation may be cancelled!
If digital and analog fieldbus boxes are connected directly via four-core power leads, the analog signals in the fieldbus boxes may be no longer electrically isolated from the control voltage!


Status LEDs for power supply

Mounting and cabling [image] Cabling [image] Power Connection [image] Status LEDs for power supply
Status LEDs for power supply
Status LEDs for power supply
LED display
LED | Display | Meaning
Us (Control voltage) | off | The power supply voltage Us is not present
 | green illuminated | The power supply voltage Us is present
 | red illuminated | Because of overload (current > 0.5 A) the sensor supply generated from power supply voltage Us was switched off for all sensors fed from this.
Up (Auxiliary voltage) | off | The power supply voltage Up is not present
 | green illuminated | The power supply voltage Up is present


Power cable

Mounting and cabling [image] Cabling [image] Power Connection [image] Power cable
Power cable
Ordering data
Order identifier | Power cable | Screw connector | Contacts | Cross-section | Length
ZK2020-3200-0020 | Straight socket, open end | M8 | 4-pole | 0.34 mm2 | 2.00 m
ZK2020-3200-0050 |  |  |  |  | 5.00 m
ZK2020-3200-0100 |  |  |  |  | 10.00 m
ZK2020-3400-0020 | Angled socket, open end |  |  |  | 2.00 m
ZK2020-3400-0050 |  |  |  |  | 5.00 m
ZK2020-3400-0100 |  |  |  |  | 10.00 m
ZK2020-3132-0001 | Straight socket, straight connector |  |  |  | 0.15 m
ZK2020-3132-0005 |  |  |  |  | 0.50 m
ZK2020-3132-0010 |  |  |  |  | 1.00 m
ZK2020-3132-0020 |  |  |  |  | 2.00 m
ZK2020-3132-0050 |  |  |  |  | 5.00 m
ZK2020-3334-0001 | Angled socket, angled connector |  |  |  | 0.15 m
ZK2020-3334-0005 |  |  |  |  | 0.50 m
ZK2020-3334-0010 |  |  |  |  | 1.00 m
ZK2020-3334-0020 |  |  |  |  | 2.00 m
ZK2020-3334-0050 |  |  |  |  | 5.00 m
Further available power cables and the associated data sheets can be found in the Beckhoff catalogue or on our website (http://www.beckhoff.de).
Technical Data
Data
Rated voltage according to IEC61076-2-101 | 30 VDC
Contamination level according to IEC 60 664-1 | 3/2
Insulation resistance IEC 60 512-2 | >109 Ω
Current carrying capacity according to IEC 60512-3 | 4 A
Volume resistance according to IEC 60512-2 | < 5 mΩ
Protection class conforms to IEC 60529 | IP65/66/67, when screwed together
Ambient temperature | -30 °C to +80 °C


Power cable conductor losses M8

Mounting and cabling [image] Cabling [image] Power Connection [image] Power cable conductor losses M8
Power cable conductor losses M8
The ZK2020-xxxx-yyyy power cables should not exceed the total length of 15 m at 4 A (with continuation). When planning the cabling, note that at 24 V nominal voltage, the functionality of the module can no longer be assured if the voltage drop reaches 6 V. Variations in the output voltage from the power supply unit must also be taken into account.
Power cable conductor losses
Example
8 m power cable with 0.34 mm² cross-section has a voltage drop of 3.2 V at 4 A.
EP92x4 Power Distribution Modules
With EP9214 and EP9224 Power Distribution Modules intelligent concepts for voltage supply are available. Further information may be found under www.beckhoff.com/EP9224.


Signal connection

Mounting and cabling [image] Cabling [image] Signal connection
Signal connection
Additional information
•
Digital inputs M12
•
Digital inputs/outputs M12
•
Analog inputs M12
•
Analog output and PWMi output M12
•
Status LEDs


Digital inputs M12

Mounting and cabling [image] Cabling [image] Signal connection [image] Digital inputs M12
Digital inputs M12
The digital input modules acquire the binary control signals from the process level and transmit them to the higher-level automation device.
The signals are connected via M12 connectors.
Digital inputs M12
The sensors are supplied with a common maximum current of 0.5 A from the control voltage Us.
Light emitting diodes indicate the signal state of the inputs.


Digital inputs/outputs M12

Mounting and cabling [image] Cabling [image] Signal connection [image] Digital inputs/outputs M12
Digital inputs/outputs M12
The digital input/output channels connect the binary control signals from the automation device for the process level with the actuators or read digital input signals.
No configuration is required. For each channel one input or output can be connected.
If an output is used, the change in status can be verified on switch-on via the corresponding signal in the input process image.
The signals are connected via M12 connectors.
Digital inputs/outputs M12
The outputs are short-circuit proof and protected against inverse connection.
LEDs indicate the signal state of the outputs.


Analog inputs M12

Mounting and cabling [image] Cabling [image] Signal connection [image] Analog inputs M12
Analog inputs M12
The analog signal inputs pick up analog control signals from the process level and transmit them to the higher-level automation device.
The signals are connected via M12 connectors.
Analog inputs M12
The sensors are supplied with a common maximum current of 0.5 A from the control voltage Us.
LEDs indicate the status of the inputs.


Analog output and PWMi output M12

Mounting and cabling [image] Cabling [image] Signal connection [image] Analog output and PWMi output M12
Analog output and PWMi output M12
Via the multi-function output either an analog output or a PWMi output can be output to a proportional valve, for example.
The signals are connected via M12 connectors.
Analog output and PWMi output M12
The outputs are short-circuit-proof.
LEDs indicate the signal state of the output.


Status LEDs

Mounting and cabling [image] Cabling [image] Signal connection [image] Status LEDs
Status LEDs
Status LEDs
Status LEDs at the M12 connections
Connection | LED | Display | Meaning
M12 socket analog inputs, PWMi | left | off | No data transfer to the D/A converter
 |  | green | Data transfer to the D/A converter
 | right | off | Function OK
 |  | red | Analog error: broken wire or measured value outside the measuring range PWMi: general error, see status word
Correct function is indicated if the green Run LED is on and the red Error LED is off.
Status LEDs at the M12 connections
Connection | LED | Display | Meaning
M12 socket digital inputs/outputs | left / right | off | Input / output off or Low
 |  | green | Input / output on or High


UL Requirements

Mounting and cabling [image] Cabling [image] UL Requirements
UL Requirements
The installation of the EtherCAT Box Modules certified by UL has to meet the following requirements.
Supply voltage
SmallWarningYellow CAUTION
CAUTION!
This UL requirements are valid for all supply voltages of all marked EtherCAT Box Modules!
For the compliance of the UL requirements the EtherCAT Box Modules should only be supplied
•
by a 24 VDC supply voltage, supplied by an isolating source and protected by means of a fuse (in accordance with UL248), rated maximum 4 Amp, or
•
by a 24 VDC power source, that has to satisfy NEC class 2.
A NEC class 2 power supply shall not be connected in series or parallel with another (class 2) power source!
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, the EtherCAT Box Modules must not be connected to unlimited power sources!
Networks
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, EtherCAT Box Modules must not be connected to telecommunication networks!
Ambient temperature range
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, EtherCAT Box Modules has to be operated only at an ambient temperature range of 0 to 55°C!
Marking for UL
All EtherCAT Box Modules certified by UL (Underwriters Laboratories) are marked with the following label.
UL label


Commissioning and Configuration

Commissioning and Configuration
Commissioning and Configuration
Additional information
•
Integration in TwinCAT
•
Tacho analysis
•
Switching between PWMi and analog output
•
Quick start
•
Range settings for inputs and outputs
•
CoE objects
•
Restoring the delivery state


Integration in TwinCAT

Commissioning and Configuration [image] Integration in TwinCAT
Integration in TwinCAT
The procedure for integration in TwinCAT is described in this Quick start guide.


Tacho analysis

Commissioning and Configuration [image] Tacho analysis
Tacho analysis
Tacho analysis refers to velocity or frequency logging for two digital sensors mounted on one shaft (single-shaft mode) or on two shafts (dual-shaft mode).
In single-shaft mode a plausibility check can be run for the two sensors (e.g. velocity deviation of the two sensors).
The targets (sensor markings) should show a 90° overlapping signal when triggered. The minimum ON of OFF time must not be less than 0.2ms, otherwise detection is not possible due to the sampling frequency.
The number of targets on the axis can be set in CoE object 0x80x0:11. In this way slower velocity/speed detection with many targets or high velocity with few targets can be achieved.
Mode selection via the PDOs
The different modes are activated via the PDO assignment.
Single-shaft mode
The input PDO 0x1A02 activates the corresponding setting. The output data are always set.
Tacho evaluation – single shaft mode
Process data
Value | Description
Error Input A | The measured velocity/frequency is lower than that of track B, or it is 0 (sensor faulty)
Input Status A | Status of input A
Error Input B | The measured velocity/frequency is lower than that of track A, or it is 0 (sensor faulty)
Input Status B | Status of input B
Speed below threshold | The velocity is lower than the limit in CoE 0x8020:12 Rotational Speed Threshold or = 0
Rotational Speed | Rotational speed and frequency, shown as a function of CoE object 0x80x0:15
Rotation Direction | 0: rising edge of input A occurs before rising edge of input B
Display of the rotational speed
Tacho evaluation - display of the rotational speed
Dual Shaft Mode
The input PDOs 0x1A03 and 0x1A04 activate the two dual-shaft process data. The output data are always set.
Tacho evaluation - dual shaft mode
Process data (settings for the second channel equivalent)
Value | Description
Digital input | Status of input
Speed below threshold | The velocity is lower than the limit in CoE 0x8020:12 or = 0
Rotational Speed | Rotational speed and frequency, shown as a function of CoE object 0x80x0:15
Display of the rotational speed
see single-shaft mode
CoE settings
The behavior of the tacho inputs is set via the CoE objects.
Tacho evaluation -
The following settings apply to all channels:
CoE | Value | Description
80xx:12 | Input Signal Timeout | The process record <Speed Below Threshold> is set after x msec without signal change at the input.
The following settings are only available in single-shaft mode
CoE objects for tacho settings (0x8020 and 0x8030)
CoE | Value | Description
80x0:0B | Enable Error Detection | Enable/disable error display
80x0:0C | Reversion of rotation | Reversion of rotation display in Rotation direction
80x0:11 | No. of Targets | Number of "cams" on the shaft/axis
80x0:12 | Rotational Speed Threshold | Limit value below which the corresponding status bit is set
80x0:15 | Presentation | Display of the measured value in RPM, Hz, …


Switching between PWMi and analog output

Commissioning and Configuration [image] Switching between PWMi and analog output
Switching between PWMi and analog output
Mode selection via the PDOs
PWMi mode or analog mode can be selected for operating a proportional valve at socket 7, for example.
▪
In PWMi mode (default) the coil is controlled directly via a PWM signal. The valve requires no control electronics.
▪
In analog mode a current value of 0...20 mA or 4...20 mA is output, via which the control electronics integrated in the valve controls the valve travel.
The 24VDC supply is switched on continuously.
The different modes are activated via the PDO assignment.
PWMi mode
The output PDO 0x1602 activates the PWMi mode.
Switching the PWMi/analog output - PWMi mode
Analog mode
The output PDO 0x1603 activates the analog mode.
Switching the PWMi/analog output - analog mode


Quick start

Commissioning and Configuration [image] Quick start
Quick start
Parameterization of the main settings
The module is factory-set such that in most applications it is operational without further parameterization.
Set the parameter Max Current [%] (0x8pp0:10) such that the maximum inductance current is not exceeded. If an EP8309 with 1.2 A rated current and an inductance with a maximum current of 600 mA is used, this parameter can be set to 50 (50%). This means that, at a maximum process data value of 32767dec a coil current of +600 mA is reached (not +1 A).
Info data objects
Via the info data objects additional information can be transferred synchronously. For each channel two of these objects are available.
The synchronous info data can be activated in the TwinCAT System Manager via the "Process Data" tab (0x1A07).
Info data objects - activation of the synchronous info data
Objects 0x8060:21 and 0x8060:22 can be used to set the value to be transferred synchronously.
Info data objects – selection of the value to be transmitted
The following entries are available:
Value | Text | Description
0 | Actual current | Actual current in mA
1 | Set current | Set current in mA
2 | Duty Cycle | The PWM duty cycle of the output stage. A value of 1000 corresponds to 100% duty cycle.
Watchdog
The analog output value can, e.g. in the case of a failure of communication with the controller, be set to a user-specific value.
Watchdog
Three parameterization options are available for this purpose:
Watchdog object (0x8060:05) | Behavior
0: Default watchdog value | The substitute switching value (0x8060:0D) is output on error.
1: Watchdog ramp active | On error the output value is moved to the default value (0x8060:0D) with the ramp time set under 0x8060:0E The ramp time is specified in digits / ms. If the entry is 100 and the default value 0, for example, it takes 327 ms (32767/100) for the output value to change from the maximum value (32767) to the default value in the event of a fault.
2: Last output value active | In the event of a fault (watchdog drop) the last process data is issued.
Optimization of the current control parameters
In order to be able to support all possible loads ex factory, the terminal was parameterized with moderate controller characteristics. Current regulation can be improved significantly by adapting the controller parameters to the actual load.
To determine the settings a current pulse is applied to the load. This pulse can be picked up with an oscilloscope or with TwinCAT ScopeView.
For evaluation with TwinCAT ScopeView the set and actual current is displayed in the synchronous info data.
Selecting the synchronous info data
EP8309 standard parameters (20 ms/div)
Green: Set current
Red: Actual current
Optimized parameters (20 ms/div)
Green: Set current
Red: Actual current
The required step response can be set using the parameters Kp,Ki, and Kd (0x8060:12 to 0x8060:14).
Dithering
Dithering involves modulating a square wave signal on top of the actual output value. The modulated signal results in continuous movement of a valve piston, for example.
This reduces static friction and prevents sudden "breakaway" of the piston.
The configuration required for this depends a lot on the particular application.
To activate dithering, the object 0x8060:03 ("Enable dithering") and the corresponding control bit must be set.
Enable dithering
The following parameters can be set:
Value | Text | Description
0x8060:1E | Dithering frequency [Hz] | Frequency of the applied dither in Hz
0x8060:1F | Dithering amplitude [%] | Amplitude of the applied dither (in % of the rated terminal current)
The controller parameters themselves (Kp,Ki, and Kd) also play a role.
In the diagrams a dither of 10 % of the rated current is shown as 100 Hz.
The controller has 5 ms for compensating a current pulse of 10 %. The steepness of the current rise is limited by the controller parameters and the inductance.
The actual current should follow the set current. This is enabled through suitable settings of the controller and dither parameters (frequency and amplitude).
EP8309 100 Hz dither with 10 % amplitude,
poor parameterization (5 ms/div)
Green: Set current
Red: Actual current
EP8309 100 Hz dither with 10 % amplitude,
better parameterization (5 ms/div)
Green: Set current
Red: Actual current


Range settings for inputs and outputs

Commissioning and Configuration [image] Range settings for inputs and outputs
Range settings for inputs and outputs
CoE-Online tab
The CoE-Online tab lists the contents of the slave object directory of the slave (SDO upload) and enables the user to modify the content of an object in this list.
Object 0xF800:0 contains the range settings for the inputs and outputs of channels 1 to 4.
CoE-Online tab
Click on objects 0xF800:01 to 0xF800:04 to change the settings.
Changing the settings


CoE objects

Commissioning and Configuration [image] CoE objects
CoE objects
Additional information
•
CoE interface
•
Object overview
•
Object description and parameterization


CoE interface

Commissioning and Configuration [image] CoE objects [image] CoE interface
CoE interface
General description
The CoE interface (CANopen over EtherCAT) is used for parameter management of EtherCAT devices. EtherCAT slaves or the EtherCAT master manage fixed (read only) or variable parameters which they require for operation, diagnostics or commissioning.
CoE parameters are arranged in a table hierarchy. In principle, the user has read access via the fieldbus. The EtherCAT master (TwinCAT System Manager) can access the local CoE lists of the slaves via EtherCAT in read or write mode, depending on the properties.
Different CoE parameter types are possible, including string (text), integer numbers, Boolean values or larger byte fields. They can be used to describe a wide range of features. Examples of such parameters include manufacturer ID, serial number, process data settings, device name, calibration values for analog measurement or passwords.
Organization takes place on 2 levels by means of hexadecimal numbering: the (main) index is named first, then the subindex. The value ranges are:
▪
Index 0 to 65535
▪
Subindex: 0…255
A parameter localized in this way is normally written as x8010:07, with preceding "x" to identify the hexadecimal numerical range and a colon between index and subindex.
The relevant ranges for EtherCAT fieldbus users are:
▪
x1000: This is where fixed identity information for the device is stored, including name, manufacturer, serial number etc., plus information about the current and available process data configurations.
▪
x8000: This is where the operational and functional parameters for all channels are stored, such as filter settings or output frequency.
Other important ranges are:
▪
x4000: In some EtherCAT devices the channel parameters are stored here (as an alternative to the x8000 range).
▪
x6000: Input PDOs ("input" from the perspective of the EtherCAT master)
▪
x7000: Output PDOs ("output" from the perspective of the EtherCAT master)
Availability
Not every EtherCAT device must have a CoE list. Simple I/O modules without dedicated processor usually have no variable parameters and therefore no CoE list.
If a device has a CoE list, it is shown in the TwinCAT System Manager as a separate tab with a listing of the elements:
CoE-Online tab
The CoE objects from x1000 to x1600, which are available in the example device "EL2502", can be seen in the above figure; the subindices from x1018 are expanded.
Data management
Some parameters, particularly the setting parameters of the slave, are configurable and writeable. This can be done in write or read mode
▪
via the System Manager (figure above) by clicking. This is useful for commissioning of the system/slaves. Click on the row of the index to be parameterized and enter a value in the SetValue dialog.
▪
from the control system/PLC via ADS, e.g. through function blocks from the TcEtherCAT.lib library This is recommended for modifications while the system is running or if no System Manager or operating staff are available.
Data management
If CoE parameters on the slave are changed online, this is saved fail-safe in the device (EEPROM) in Beckhoff devices. This means that the changed CoE parameters are still retained after a restart. The situation may be different with other manufacturers.
Startup list
Startup list
Changes in the local CoE list of the terminal are lost if the terminal is replaced. If a terminal is replaced with a new Beckhoff terminal, it will have the factory settings. It is therefore advisable to link all changes in the CoE list of an EtherCAT slave with the Startup list of the slave, which is processed whenever the EtherCAT fieldbus is started. In this way a replacement EtherCAT slave can automatically be parameterized with the specifications of the user.
If EtherCAT slaves are used which are unable to store local CoE values permanently, the Startup list must be used.
Recommended approach for manual modification of CoE parameters
▪
Make the required change in the System Manager. The values are stored locally in the EtherCAT slave
▪
If the value is to be stored permanently, enter it in the Startup list. The order of the Startup entries is usually irrelevant.
StartUp-Liste im TwinCAT System Manager
Startup list in the TwinCAT System Manager
The Startup list may already contain values that were configured by the System Manager based on the ESI specifications. Additional application-specific entries can be created.
Online/offline directory
While working with the TwinCAT System Manager, a distinction has to be made whether the EtherCAT device is "available", i.e. switched on and linked via EtherCAT and therefore online, or whether a configuration is created offline without connected slaves.
In both cases a CoE directory is visible according to the figure "CoE-Online tab", but the connectivity is displayed as offline/online.
If the slave is offline
▪
the offline list from the ESI file is displayed. In this case modifications are not meaningful or possible.
▪
the configured status is shown under Identity
▪
no firmware or hardware version is displayed, since these are features of the physical device.
▪
Offline is shown in red
Offline list
If the slave is online
▪
the actual current slave directory is read. This may take several seconds, depending on the size and cycle time.
▪
the actual identity is displayed
▪
the firmware and hardware version of the equipment according to the electronic information is displayed.
▪
Online is shown in green
Online list
Channel-based order
The CoE directory is located in EtherCAT devices that usually encompass several functionally equivalent channels. e.g. a 4-channel 0 – 10 V analog input terminal also has 4 logical channels and thus 4 identical sets of parameter data for the channels. In order to avoid having to list each channel in the documentation, the placeholder "n" tends to be used for the individual channel numbers.
In the CoE system 16 indices, each with 255 subindices, are generally sufficient for representing all channel parameters. The channel-based order is therefore arranged in 16dec/10hex steps. The parameter range x8000 exemplifies this:
▪
Channel 0: parameter range x8000:00 ... x800F:255
▪
Channel 1: parameter range x8010:00 ... x801F:255
▪
Channel 2: parameter range x8020:00 ... x802F:255
▪
…
This is generally written as x80n0. Detailed information on the CoE interface can be found in the EtherCAT system documentation on the Beckhoff website.


Object overview

Commissioning and Configuration [image] CoE objects [image] Object overview
Object overview
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Index (hex) |  | Name | Flags | Default value
1000 |  | Device type | RO | 0x00001389 (5001dec)
1008 |  | Device name | RO | EP8309-1022
1009 |  | Hardware version | RO | 00
100A |  | Software version | RO | 02
1011:0 | Subindex | Restore default parameters | RO | 0x01 (1dec)
 | 1011:01 | SubIndex 001 | RW | 0x00000000 (0dec)
1018:0 | Subindex | Identity | RO | 0x04 (4dec)
 | 1018:01 | Vendor ID | RO | 0x00000002 (2dec)
 | 1018:02 | Product code | RO | 0x20754052 (544555090dec)
 | 1018:03 | Revision | RO | 0x00110016 (1114134dec)
 | 1018:04 | Serial number | RO | 0x00000000 (0dec)
10F0:0 | Subindex | Backup parameter handling | RO | 0x01 (1dec)
 | 10F0:01 | Checksum | RO | 0x00000000 (0dec)
1402:0 | Subindex | PWM RxPDO-Par Control | RO | 0x06 (6dec)
 | 1402:06 | Exclude RxPDOs | RO | 03 16
1403:0 | Subindex | AO RxPDO-Par Outputs | RO | 0x06 (6dec)
 | 1403:06 | Exclude RxPDOs | RO | 02 16
1600:0 | Subindex | TACHO RxPDO-Map OutputsCh.1 | RO | 0x03 (3dec)
 | 1600:01 | SubIndex 001 | RO | 0x0000:00, 8
 | 1600:02 | SubIndex 002 | RO | 0x7020:09, 1
 | 1600:03 | SubIndex 003 | RO | 0x0000:00, 7
1601:0 | Subindex | DO RxPDO-Map Outputs | RO | 0x07 (7dec)
 | 1601:01 | SubIndex 001 | RO | 0x7050:01, 1
 | 1601:02 | SubIndex 002 | RO | 0x7050:02, 1
 | 1601:03 | SubIndex 003 | RO | 0x7050:03, 1
 | 1601:04 | SubIndex 004 | RO | 0x7050:04, 1
 | 1601:05 | SubIndex 005 | RO | 0x7050:05, 1
 | 1601:06 | SubIndex 006 | RO | 0x7050:06, 1
 | 1601:07 | SubIndex 007 | RO | 0x0000:00, 10
1602:0 | Subindex | PWM RxPDO-Map Control | RO | 0x06 (6dec)
 | 1602:01 | SubIndex 001 | RO | 0x7060:01, 1
 | 1602:02 | SubIndex 002 | RO | 0x0000:00, 4
 | 1602:03 | SubIndex 003 | RO | 0x7060:06, 1
 | 1602:04 | SubIndex 004 | RO | 0x7060:07, 1
 | 1602:05 | SubIndex 005 | RO | 0x0000:00, 9
 | 1602:06 | SubIndex 006 | RO | 0x7060:11, 16
Index (hex) |  | Name | Flags | Default value
1603:0 | Subindex | AO RxPDO-Map Outputs | RO | 0x01 (1dec)
 | 1603:01 | SubIndex 001 | RO | 0x7070:11, 16
1802:0 | Subindex | TACHO TxPDO-Par Single Shaft Mode Input Ch.1 | RO | 0x06 (6dec)
 | 1802:06 | Exclude TxPDOs | RO | 03 1A 04 1A
1803:0 | Subindex | TACHO TxPDO-Par Dual Shaft Mode Input Ch.1 | RO | 0x06 (6dec)
 | 1803:06 | Exclude TxPDOs | RO | 02 1A 00 00
1804:0 | Subindex | TACHO TxPDO-Par Dual Shaft Mode Input Ch.2 | RO | 0x06 (6dec)
 | 1804:06 | Exclude TxPDOs | RO | 02 1A 00 00
1A00:0 | Subindex | AI TxPDO-Map Inputs Ch.1 | RO | 0x0A (10dec)
 | 1A00:01 | SubIndex 001 | RO | 0x6000:01, 1
 | 1A00:02 | SubIndex 002 | RO | 0x6000:02, 1
 | 1A00:03 | SubIndex 003 | RO | 0x6000:03, 2
 | 1A00:04 | SubIndex 004 | RO | 0x6000:05, 2
 | 1A00:05 | SubIndex 005 | RO | 0x6000:07, 1
 | 1A00:06 | SubIndex 006 | RO | 0x0000:00, 6
 | 1A00:07 | SubIndex 007 | RO | 0x6000:0E, 1
 | 1A00:08 | SubIndex 008 | RO | 0x6000:0F, 1
 | 1A00:09 | SubIndex 009 | RO | 0x6000:10, 1
 | 1A00:0A | SubIndex 010 | RO | 0x6000:11, 16
1A01:0 | Subindex | AI TxPDO-Map Inputs Ch.2 | RO | 0x0A (10dec)
 | 1A01:01 | SubIndex 001 | RO | 0x6010:01, 1
 | 1A01:02 | SubIndex 002 | RO | 0x6010:02, 1
 | 1A01:03 | SubIndex 003 | RO | 0x6010:03, 2
 | 1A01:04 | SubIndex 004 | RO | 0x6010:05, 2
 | 1A01:05 | SubIndex 005 | RO | 0x6010:07, 1
 | 1A01:06 | SubIndex 006 | RO | 0x0000:00, 6
 | 1A01:07 | SubIndex 007 | RO | 0x6010:0E, 1
 | 1A01:08 | SubIndex 008 | RO | 0x6010:0F, 1
 | 1A01:09 | SubIndex 009 | RO | 0x6010:10, 1
 | 1A01:0A | SubIndex 010 | RO | 0x6010:11, 16
1A02:0 | Subindex | TACHO TxPDO-Map Single Shaft Mode Input Ch.1 | RO | 0x0C (12dec)
 | 1A02:01 | SubIndex 001 | RO | 0x0000:00, 1
 | 1A02:02 | SubIndex 002 | RO | 0x6037:02, 1
 | 1A02:03 | SubIndex 003 | RO | 0x6037:03, 1
 | 1A02:04 | SubIndex 004 | RO | 0x6037:04, 1
 | 1A02:05 | SubIndex 005 | RO | 0x6037:05, 1
 | 1A02:06 | SubIndex 006 | RO | 0x0000:00, 3
 | 1A02:07 | SubIndex 007 | RO | 0x0000:00, 3
 | 1A02:08 | SubIndex 008 | RO | 0x6037:0C, 1
 | 1A02:09 | SubIndex 009 | RO | 0x0000:00, 3
 | 1A02:0A | SubIndex 010 | RO | 0x6037:10, 1
 | 1A02:0B | SubIndex 011 | RO | 0x6037:11, 16
 | 1A02:0C | SubIndex 012 | RO | 0x6037:12, 16
Index (hex) |  | Name | Flags | Default value
1A03:0 | Subindex | TACHO TxPDO-Map Dual Shaft Mode Input Ch.1 | RO | 0x09 (9dec)
 | 1A03:01 | SubIndex 001 | RO | 0x6020:01, 1
 | 1A03:02 | SubIndex 002 | RO | 0x0000:00, 2
 | 1A03:03 | SubIndex 003 | RO | 0x0000:00, 1
 | 1A03:04 | SubIndex 004 | RO | 0x0000:00, 4
 | 1A03:05 | SubIndex 005 | RO | 0x0000:00, 3
 | 1A03:06 | SubIndex 006 | RO | 0x6020:0C, 1
 | 1A03:07 | SubIndex 007 | RO | 0x0000:00, 3
 | 1A03:08 | SubIndex 008 | RO | 0x6020:10, 1
 | 1A03:09 | SubIndex 009 | RO | 0x6020:11, 16
1A04:0 | Subindex | TACHO TxPDO-Map Dual Shaft Mode Input Ch.2 | RO | 0x09 (9dec)
 | 1A04:01 | SubIndex 001 | RO | 0x6030:01, 1
 | 1A04:02 | SubIndex 002 | RO | 0x0000:00, 2
 | 1A04:03 | SubIndex 003 | RO | 0x0000:00, 1
 | 1A04:04 | SubIndex 004 | RO | 0x0000:00, 4
 | 1A04:05 | SubIndex 005 | RO | 0x0000:00, 3
 | 1A04:06 | SubIndex 006 | RO | 0x6030:0C, 1
 | 1A04:07 | SubIndex 007 | RO | 0x0000:00, 3
 | 1A04:08 | SubIndex 008 | RO | 0x6030:10, 1
 | 1A04:09 | SubIndex 009 | RO | 0x6030:11, 16
1A05:0 | Subindex | DI TxPDO-Map Inputs | RO | 0x07 (7dec)
 | 1A05:01 | SubIndex 001 | RO | 0x6040:01, 1
 | 1A05:02 | SubIndex 002 | RO | 0x6040:02, 1
 | 1A05:03 | SubIndex 003 | RO | 0x6040:03, 1
 | 1A05:04 | SubIndex 004 | RO | 0x6040:04, 1
 | 1A05:05 | SubIndex 005 | RO | 0x6040:05, 1
 | 1A05:06 | SubIndex 006 | RO | 0x6040:06, 1
 | 1A05:07 | SubIndex 007 | RO | 0x0000:00, 10
1A06:0 | Subindex | PWM TxPDO-Map Status | RO | 0x08 (8dec)
 | 1A06:01 | SubIndex 001 | RO | 0x0000:00, 1
 | 1A06:02 | SubIndex 002 | RO | 0x0000:00, 3
 | 1A06:03 | SubIndex 003 | RO | 0x6060:05, 1
 | 1A06:04 | SubIndex 004 | RO | 0x6060:06, 1
 | 1A06:05 | SubIndex 005 | RO | 0x6060:07, 1
 | 1A06:06 | SubIndex 006 | RO | 0x0000:00, 1
 | 1A06:07 | SubIndex 007 | RO | 0x0000:00, 7
 | 1A06:08 | SubIndex 008 | RO | 0x6060:10, 1
1A07:0 | Subindex | PWM TxPDO-Map Synchronous Info Data | RO | 0x02 (2dec)
 | 1A07:01 | SubIndex 001 | RO | 0x6060:11, 16
 | 1A07:02 | SubIndex 002 | RO | 0x6060:12, 16
1C00:0 | Subindex | Sync manager type | RO | 0x04 (4dec)
 | 1C00:01 | SubIndex 001 | RO | 0x01 (1dec)
 | 1C00:02 | SubIndex 002 | RO | 0x02 (2dec)
 | 1C00:03 | SubIndex 003 | RO | 0x03 (3dec)
 | 1C00:04 | SubIndex 004 | RO | 0x04 (4dec)
Index (hex) |  | Name | Flags | Default value
1C12:0 | Subindex | RxPDO assign | RW | 0x03 (3dec)
 | 1C12:01 | SubIndex 001 | RW | 0x1600 (5632dec)
 | 1C12:02 | SubIndex 002 | RW | 0x1601 (5633dec)
 | 1C12:03 | SubIndex 003 | RW | 0x1602 (5634dec)
 | 1C12:04 | SubIndex 004 | RW | 0x0000 (0dec)
1C13:0 | Subindex | TxPDO assign | RW | 0x05 (5dec)
 | 1C13:01 | SubIndex 001 | RW | 0x1A00 (6656dec)
 | 1C13:02 | SubIndex 002 | RW | 0x1A01 (6657dec)
 | 1C13:03 | SubIndex 003 | RW | 0x1A02 (6658dec)
 | 1C13:04 | SubIndex 004 | RW | 0x1A05 (6661dec)
 | 1C13:05 | SubIndex 005 | RW | 0x1A06 (6662dec)
 | 1C13:06 | SubIndex 006 | RW | 0x0000 (0dec)
 | 1C13:07 | SubIndex 007 | RW | 0x0000 (0dec)
1C32:0 | Subindex | SM output parameter | RO | 0x20 (32dec)
 | 1C32:01 | Sync mode | RW | 0x0001 (1dec)
 | 1C32:02 | Cycle time | RW | 0x000F4240 (1000000dec)
 | 1C32:03 | Shift time | RO | 0x00000000 (0dec)
 | 1C32:04 | Sync modes supported | RO | 0xC007 (49159dec)
 | 1C32:05 | Minimum cycle time | RO | 0x0007A120 (500000dec)
 | 1C32:06 | Calc and copy time | RO | 0x00000000 (0dec)
 | 1C32:07 | Minimum delay time | RO | 0x00000000 (0dec)
 | 1C32:08 | Command | RW | 0x0000 (0dec)
 | 1C32:09 | Maximum delay time | RO | 0x00000000 (0dec)
 | 1C32:0B | SM event missed counter | RO | 0x0000 (0dec)
 | 1C32:0C | Cycle exceeded counter | RO | 0x0000 (0dec)
 | 1C32:0D | Shift too short counter | RO | 0x0000 (0dec)
 | 1C32:20 | Sync error | RO | 0x00 (0dec)
1C33:0 | Subindex | SM input parameter | RO | 0x20 (32dec)
 | 1C33:01 | Sync mode | RW | 0x0022 (34dec)
 | 1C33:02 | Cycle time | RW | 0x000F4240 (1000000dec)
 | 1C33:03 | Shift time | RO | 0x00000000 (0dec)
 | 1C33:04 | Sync modes supported | RO | 0xC007 (49159dec)
 | 1C33:05 | Minimum cycle time | RO | 0x0007A120 (500000dec)
 | 1C33:06 | Calc and copy time | RO | 0x00000000 (0dec)
 | 1C33:07 | Minimum delay time | RO | 0x00000000 (0dec)
 | 1C33:08 | Command | RW | 0x0000 (0dec)
 | 1C33:09 | Maximum delay time | RO | 0x00000000 (0dec)
 | 1C33:0B | SM event missed counter | RO | 0x0000 (0dec)
 | 1C33:0C | Cycle exceeded counter | RO | 0x0000 (0dec)
 | 1C33:0D | Shift too short counter | RO | 0x0000 (0dec)
 | 1C33:20 | Sync error | RO | 0x00 (0dec)
Index (hex) |  | Name | Flags | Default value
6000:0 | Subindex | AI Inputs Ch.1 | RO | 0x11 (17dec)
 | 6000:01 | Underrange | RO | 0x00 (0dec)
 | 6000:02 | Overrange | RO | 0x00 (0dec)
 | 6000:03 | Limit 1 | RO | 0x00 (0dec)
 | 6000:05 | Limit 2 | RO | 0x00 (0dec)
 | 6000:07 | Error | RO | 0x00 (0dec)
 | 6000:0E | Sync error | RO | 0x00 (0dec)
 | 6000:0F | TxPDO State | RO | 0x00 (0dec)
 | 6000:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6000:11 | Value | RO | 0x0000 (0dec)
6010:0 | Subindex | AI Inputs Ch.2 | RO | 0x11 (17dec)
 | 6010:01 | Underrange | RO | 0x00 (0dec)
 | 6010:02 | Overrange | RO | 0x00 (0dec)
 | 6010:03 | Limit 1 | RO | 0x00 (0dec)
 | 6010:05 | Limit 2 | RO | 0x00 (0dec)
 | 6010:07 | Error | RO | 0x00 (0dec)
 | 6010:0E | Sync error | RO | 0x00 (0dec)
 | 6010:0F | TxPDO State | RO | 0x00 (0dec)
 | 6010:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6010:11 | Value | RO | 0x0000 (0dec)
6020:0 | Subindex | TACHO Dual Shaft Mode Input Ch.1 | RO | 0x11 (17dec)
 | 6020:01 | Digital input | RO | 0x00 (0dec)
 | 6020:0C | Speed Below Threshold | RO | 0x00 (0dec)
 | 6020:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6020:11 | Rotational Speed | RO | 0x0000 (0dec)
6030:0 | Subindex | TACHO Dual Shaft Mode Input Ch.2 | RO | 0x11 (17dec)
 | 6030:01 | Digital input | RO | 0x00 (0dec)
 | 6030:0C | Speed Below Threshold | RO | 0x00 (0dec)
 | 6030:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6030:11 | Rotational Speed | RO | 0x0000 (0dec)
6037:0 | Subindex | TACHO Single Shaft Mode Input | RO | 0x12 (18dec)
 | 6037:02 | Error Input A | RO | 0x00 (0dec)
 | 6037:03 | Input Status A | RO | 0x00 (0dec)
 | 6037:04 | Error Input B | RO | 0x00 (0dec)
 | 6037:05 | Input Status B | RO | 0x00 (0dec)
 | 6037:0C | Speed Below Threshold | RO | 0x00 (0dec)
 | 6037:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6037:11 | Rotational Speed | RO | 0x0000 (0dec)
 | 6037:12 | Rotation Direction | RO | 0x0000 (0dec)
6040:0 | Subindex | DI Inputs | RO | 0x06 (6dec)
 | 6040:01 | Digital Input X4 Pin4 | RO | 0x00 (0dec)
 | 6040:02 | Digital Input X4 Pin2 | RO | 0x00 (0dec)
 | 6040:03 | Digital Input X6 Pin4 | RO | 0x00 (0dec)
 | 6040:04 | Digital Input X6 Pin2 | RO | 0x00 (0dec)
 | 6040:05 | Digital Input X7 Pin4 | RO | 0x00 (0dec)
 | 6040:06 | Digital Input X7 Pin2 | RO | 0x00 (0dec)
Index (hex) |  | Name | Flags | Default value
6060:0 | Subindex | PWM Inputs | RO | 0x12 (18dec)
 | 6060:05 | Ready to enable | RO | 0x00 (0dec)
 | 6060:06 | Warning | RO | 0x00 (0dec)
 | 6060:07 | Error | RO | 0x00 (0dec)
 | 6060:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6060:11 | Info data 1 | RO | 0x0000 (0dec)
 | 6060:12 | Info data 2 | RO | 0x0000 (0dec)
7020:0 | Subindex | TACHO Outputs | RO | 0x09 (9dec)
 | 7020:09 | Reset Error | RO | 0x00 (0dec)
7030:0 | Subindex | TACHO Outputs | RO | 0x09 (9dec)
 | 7030:09 | Reset Error | RO | 0x00 (0dec)
7050:0 | Subindex | DO Outputs | RO | 0x06 (6dec)
 | 7050:01 | Digital Output X5 Pin4 | RO | 0x00 (0dec)
 | 7050:02 | Digital Output X5 Pin2 | RO | 0x00 (0dec)
 | 7050:03 | Digital Output X6 Pin4 | RO | 0x00 (0dec)
 | 7050:04 | Digital Output X6 Pin2 | RO | 0x00 (0dec)
 | 7050:05 | Digital Output X7 Pin4 | RO | 0x00 (0dec)
 | 7050:06 | Digital Output X7 Pin2 | RO | 0x00 (0dec)
7060:0 | Subindex | PWM Outputs | RO | 0x11 (17dec)
 | 7060:01 | Enable dithering | RO | 0x00 (0dec)
 | 7060:06 | Enable | RO | 0x00 (0dec)
 | 7060:07 | Reset | RO | 0x00 (0dec)
 | 7060:11 | PWM output | RO | 0x0000 (0dec)
7070:0 | Subindex | AO Outputs | RO | 0x11 (17dec)
 | 7070:11 | Analog output | RO | 0x0000 (0dec)
8000:0 | Subindex | AI Settings Ch.1 | RW | 0x18 (24dec)
 | 8000:01 | Enable user scale | RW | 0x00 (0dec)
 | 8000:02 | Presentation | RW | 0x00 (0dec)
 | 8000:05 | Siemens bits | RW | 0x00 (0dec)
 | 8000:06 | Enable filter | RW | 0x00 (0dec)
 | 8000:07 | Enable limit 1 | RW | 0x00 (0dec)
 | 8000:08 | Enable limit 2 | RW | 0x00 (0dec)
 | 8000:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8000:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 8000:0E | Swap limit bits | RW | 0x00 (0dec)
 | 8000:11 | User scale offset | RW | 0x0000 (0dec)
 | 8000:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 8000:13 | Limit 1 | RW | 0x0000 (0dec)
 | 8000:14 | Limit 2 | RW | 0x0000 (0dec)
 | 8000:15 | Filter settings | RW | 0x0000 (0dec)
 | 8000:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8000:18 | User calibration gain | RW | 0x4000 (16384dec)
800E:0 | Subindex | AI Internal data Ch.1 | RO | 0x01 (1dec)
 | 800E:01 | ADC raw value | RO | 0x0000 (0dec)
Index (hex) |  | Name | Flags | Default value
800F:0 | Subindex | AI Vendor data Ch.1 | RW | 0x06 (6dec)
 | 800F:01 | R0 Offset | RW | 0x0000 (0dec)
 | 800F:02 | R0 Gain | RW | 0x4000 (16384dec)
 | 800F:03 | R1 Offset | RW | 0x0000 (0dec)
 | 800F:04 | R1 Gain | RW | 0x4000 (16384dec)
 | 800F:05 | R2 Offset | RW | 0x0000 (0dec)
 | 800F:06 | R2 Gain | RW | 0x4000 (16384dec)
8010:0 | Subindex | AI Settings Ch.2 | RW | 0x18 (24dec)
 | 8010:01 | Enable user scale | RW | 0x00 (0dec)
 | 8010:02 | Presentation | RW | 0x00 (0dec)
 | 8010:05 | Siemens bits | RW | 0x00 (0dec)
 | 8010:06 | Enable filter | RW | 0x00 (0dec)
 | 8010:07 | Enable limit 1 | RW | 0x00 (0dec)
 | 8010:08 | Enable limit 2 | RW | 0x00 (0dec)
 | 8010:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8010:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 8010:0E | Swap limit bits | RW | 0x00 (0dec)
 | 8010:11 | User scale offset | RW | 0x0000 (0dec)
 | 8010:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 8010:13 | Limit 1 | RW | 0x0000 (0dec)
 | 8010:14 | Limit 2 | RW | 0x0000 (0dec)
 | 8010:15 | Filter settings | RW | 0x0000 (0dec)
 | 8010:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8010:18 | User calibration gain | RW | 0x4000 (16384dec)
801E:0 | Subindex | AI Internal Data Ch.2 | RO | 0x01 (1dec)
 | 801E:01 | ADC raw value | RO | 0x0000 (0dec)
801F:0 | Subindex | AI Vendor Data Ch.2 | RW | 0x06 (6dec)
 | 801F:01 | R0 Offset | RW | 0x0000 (0dec)
 | 801F:02 | R0 Gain | RW | 0x4000 (16384dec)
 | 801F:03 | R1 Offset | RW | 0x0000 (0dec)
 | 801F:04 | R1 Gain | RW | 0x4000 (16384dec)
 | 801F:05 | R2 Offset | RW | 0x0000 (0dec)
 | 801F:06 | R2 Gain | RW | 0x4000 (16384dec)
8020:0 | Subindex | TACHO Settings Dual Shaft Mode Ch.1 | RW | 0x15 (21dec)
 | 8020:11 | No. of Targets | RW | 0x0001 (1dec)
 | 8020:12 | Input Signal Timeout | RW | 0x0064 (100dec)
 | 8020:15 | Presentation | RW | 0x0001 (1dec)
8030:0 | Subindex | TACHO Settings Dual Shaft Mode Ch.2 | RW | 0x15 (21dec)
 | 8030:11 | No. of Targets | RW | 0x0001 (1dec)
 | 8030:12 | Input Signal Timeout | RW | 0x0064 (100dec)
 | 8030:15 | Presentation | RW | 0x0001 (1dec)
8031:0 | Subindex | TACHO Settings Single Shaft Mode | RW | 0x15 (21dec)
 | 8031:0B | Enable Error Detection | RW | 0x01 (1dec)
 | 8031:0C | Reversion of Rotation | RW | 0x00 (0dec)
 | 8031:11 | No. of Targets | RW | 0x0001 (1dec)
 | 8031:12 | Input Signal Timeout | RW | 0x0064 (100dec)
 | 8031:15 | Presentation | RW | 0x0000 (0dec)
Index (hex) |  | Name | Flags | Default value
8060:0 | Subindex | PWM settings | RW | 0x22 (34dec)
 | 8060:03 | Enable dithering | RW | 0x00 (0dec)
 | 8060:04 | Invert polarity | RW | 0x00 (0dec)
 | 8060:05 | Watchdog | RW | 0x00 (0dec)
 | 8060:0B | Offset | RW | 0x0000 (0dec)
 | 8060:0C | Gain | RW | 0x00010000 (65536dec)
 | 8060:0D | Default output | RW | 0x0000 (0dec)
 | 8060:0E | Default output ramp | RW | 0xFFFF (65535dec)
 | 8060:10 | Max current [%] | RW | 0x64 (100dec)
 | 8060:12 | Kp factor | RW | 0x00FA (250dec)
 | 8060:13 | Ki factor | RW | 0x0004 (4dec)
 | 8060:14 | Kd factor | RW | 0x0032 (50dec)
 | 8060:1E | Dithering frequency [Hz] | RW | 0x0064 (100dec)
 | 8060:1F | Dithering amplitude [%] | RW | 0x0A (10dec)
 | 8060:21 | Select info data 1 | RW | 0x00 (0dec)
 | 8060:22 | Select info data 2 | RW | 0x00 (0dec)
806F:0 | Subindex | PWM Vendor data | RW | 0x02 (2dec)
 | 806F:01 | Offset | RW | 0x0000 (0dec)
 | 806F:02 | Gain | RW | 0x4000 (16384dec)
8070:0 | Subindex | AO Settings | RW | 0x16 (22dec)
 | 8070:01 | Enable user scale | RW | 0x00 (0dec)
 | 8070:02 | Presentation | RW | 0x00 (0dec)
 | 8070:05 | Watchdog | RW | 0x00 (0dec)
 | 8070:07 | Enable user calibration | RW | 0x00 (0dec)
 | 8070:08 | Enable vendor calibration | RW | 0x01 (1dec)
 | 8070:11 | User scale offset | RW | 0x0000 (0dec)
 | 8070:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 8070:13 | Default output | RW | 0x0000 (0dec)
 | 8070:14 | Default output ramp | RW | 0xFFFF (65535dec)
 | 8070:15 | User calibration offset | RW | 0x0000 (0dec)
 | 8070:16 | User calibration gain | RW | 0x4000 (16384dec)
807E:0 | Subindex | AO Internal Data | RO | 0x01 (1dec)
 | 807E:01 | DAC Raw Value | RO | 0x0000 (0dec)
807F:0 | Subindex | AO Vendor Data | RW | 0x06 (6dec)
 | 807F:01 | R0 Calibration Offset | RW | 0x0000 (0dec)
 | 807F:02 | R0 Calibration Gain | RW | 0x4000 (16384dec)
 | 807F:03 | R1 Calibration Offset | RW | 0x0000 (0dec)
 | 807F:04 | R1 Calibration Gain | RW | 0x4000 (16384dec)
 | 807F:05 | R2 Calibration Offset | RW | 0x0000 (0dec)
 | 807F:06 | R2 Calibration Gain | RW | 0x4000 (16384dec)
A060:0 | Subindex | PWM Diag data | RO | 0x06 (6dec)
 | A060:02 | Overtemperature | RO | 0x00 (0dec)
 | A060:06 | Short circuit | RO | 0x00 (0dec)
F000:0 | Subindex | Modular device profile | RO | 0x02 (2dec)
 | F000:01 | Module index distance | RO | 0x0010 (16dec)
 | F000:02 | Maximum number of modules | RO | 0x0008 (8dec)
Index (hex) |  | Name | Flags | Default value
F008 |  | Code word | RW | 0x00000000 (0dec)
F010:0 | Subindex | Module list | RW | 0x08 (8dec)
 | F010:01 | SubIndex 001 | RW | 0x0000012C (300dec)
 | F010:02 | SubIndex 002 | RW | 0x0000012C (300dec)
 | F010:03 | SubIndex 003 | RW | 0x00000208 (520dec)
 | F010:04 | SubIndex 004 | RW | 0x00000208 (520dec)
 | F010:05 | SubIndex 005 | RW | 0x00000064 (100dec)
 | F010:06 | SubIndex 006 | RW | 0x000000C8 (200dec)
 | F010:07 | SubIndex 007 | RW | 0x000000FA (250dec)
 | F010:08 | SubIndex 008 | RW | 0x00000190 (400dec)
F800:0 | Subindex | AIAO Range settings | RW | 0x08 (8dec)
 | F800:01 | Input type Ch1 | RW | 0x0001 (1dec)
 | F800:02 | Input type Ch2 | RW | 0x0001 (1dec)
 | F800:08 | Output type | RW | 0x0001 (1dec)
F900:0 | Subindex | PWM Info data | RO | 0x02 (2dec)
 | F900:02 | Temperature [°C] | RO | 0x00 (0dec)
FB00:0 | Subindex | PWM Command | RO | 0x03 (3dec)
 | FB00:01 | Request | RW | {0}
 | FB00:02 | Status | RO | 0x00 (0dec)
 | FB00:03 | Response | RO | {0}
Key
Flags:
RO (Read Only): this object can be read only
RW (Read/Write): this object can be read and written to


Object description and parameterization

Commissioning and Configuration [image] CoE objects [image] Object description and parameterization
Object description and parameterization
Parameterization
The terminal is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (assignment of PDOs).
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Introduction
The CoE overview contains objects for different intended applications:
▪
Objects required for parameterization during commissioning
▪
Objects intended for regular operation, e.g. through ADS access.
▪
Objects for indicating internal settings (may be fixed)
▪
Further profile-specific objects indicating inputs, outputs and status information
The following section first describes the objects required for normal operation, followed by a complete overview of missing objects.
Additional information
•
Objects to be parameterized during commissioning
•
Objects for regular operation
•
Standard objects (0x1000-0x1FFF)
•
Profile-specific objects (0x6000-0xFFFF)


Objects to be parameterized during commissioning

Commissioning and Configuration [image] CoE objects [image] Object description and parameterization [image] Objects to be parameterized during commissioning
Objects to be parameterized during commissioning
Index 8000 AI Settings Ch.1
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8000:0 | AI Settings | Maximum subindex |  | UINT8 | RO | 0x18 (24dec)
8000:01 | Enable user scale | 1 | User scale is active. | BOOLEAN | RW | 0x00 (0dec)
8000:02 | Presentation | 0 | Signed presentation | BIT3 | RW | 0x00 (0dec)
 |  | 1 | Unsigned presentation
 |  | 2 | Absolute value with MSB as sign (signed amount representation)
8000:06 | Enable filter | 1 | Enable filter, which makes PLC-cycle-synchronous data exchange unnecessary | BOOLEAN | RW | 0x00 (0dec)
8000:07 | Enable limit 1 | 1 | Limit 1 enabled | BOOLEAN | RW | 0x00 (0dec)
8000:08 | Enable limit 2 | 1 | Limit 2 enabled | BOOLEAN | RW | 0x00 (0dec)
8000:0A | Enable user calibration | 1 | Enabling of the user calibration | BOOLEAN | RW | 0x00 (0dec)
8000:0B | Enable vendor calibration | 1 | Enabling of the vendor calibration | BOOLEAN | RW | 0x01 (1dec)
8000:11 | User scale offset | User scale offset |  | INT16 | RW | 0x0000 (0dec)
8000:12 | User scale gain | User scale gain. The gain is represented in fixed-point format, with the factor 2-16. The value 1 corresponds to 65535dez (0x00010000hex) and is limited to +/- 0x7FFFF |  | INT32 | RW | 0x00010000 (65536dec)
8000:13 | Limit 1 | First limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8000:14 | Limit 2 | Second limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8000:15 | Filter settings | This object determines the digital filter settings for all channels of the module, if it is activated via Enable filter (index 0x80n0:06). The possible settings are sequentially numbered. |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 50 Hz FIR
 |  | 1 | 60 Hz FIR
 |  | 2 | IIR 1
 |  | 3 | IIR 2
 |  | 4 | IIR 3
 |  | 5 | IIR 4
 |  | 6 | IIR 5
 |  | 7 | IIR 6
 |  | 8 | IIR 7
 |  | 9 | IIR 8
8000:17 | User calibration offset | User calibration: Offset |  | INT16 | RW | 0x0000 (0dec)
8000:18 | User calibration gain | User calibration: Gain |  | INT16 | RW | 0x4000 (16384dec)
Index 8000 AI Settings Ch.2
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8010:0 | AI Settings | Maximum subindex |  | UINT8 | RO | 0x18 (24dec)
8010:01 | Enable user scale | 1 | User scale is active. | BOOLEAN | RW | 0x00 (0dec)
8010:02 | Presentation | 0 | Signed presentation | BIT3 | RW | 0x00 (0dec)
 |  | 1 | Unsigned presentation
 |  | 2 | Absolute value with MSB as sign (signed amount representation)
8010:06 | Enable filter | 1 | Enable filter, which makes PLC-cycle-synchronous data exchange unnecessary | BOOLEAN | RW | 0x00 (0dec)
8010:07 | Enable limit 1 | 1 | Limit 1 enabled | BOOLEAN | RW | 0x00 (0dec)
8010:08 | Enable limit 2 | 1 | Limit 2 enabled | BOOLEAN | RW | 0x00 (0dec)
8010:0A | Enable user calibration | 1 | Enabling of the user calibration | BOOLEAN | RW | 0x00 (0dec)
8010:0B | Enable vendor calibration | 1 | Enabling of the vendor calibration | BOOLEAN | RW | 0x01 (1dec)
8010:11 | User scale offset | User scale offset |  | INT16 | RW | 0x0000 (0dec)
8010:12 | User scale gain | User scale gain. The gain is represented in fixed-point format, with the factor 2-16. The value 1 corresponds to 65535dez (0x00010000hex) and is limited to +/- 0x7FFFF |  | INT32 | RW | 0x00010000 (65536dec)
8010:13 | Limit 1 | First limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8010:14 | Limit 2 | Second limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8010:15 | Filter settings | This object determines the digital filter settings for all channels of the module, if it is activated via Enable filter (index 0x80n0:06). The possible settings are sequentially numbered. |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 50 Hz FIR
 |  | 1 | 60 Hz FIR
 |  | 2 | IIR 1
 |  | 3 | IIR 2
 |  | 4 | IIR 3
 |  | 5 | IIR 4
 |  | 6 | IIR 5
 |  | 7 | IIR 6
 |  | 8 | IIR 7
 |  | 9 | IIR 8
8010:17 | User calibration offset | User calibration: Offset |  | INT16 | RW | 0x0000 (0dec)
8010:18 | User calibration gain | User calibration: Gain |  | INT16 | RW | 0x4000 (16384dec)
Index 8020 TACHO Settings Dual Shaft Mode Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
8020:0 | TACHO Settings Dual Shaft Mode Ch.1 |  | UINT8 | RO | 0x15 (21dec)
8020:11 | No. of Targets | Number of "cams" on the shaft/axis | UINT16 | RW | 0x0001 (1dec)
8020:12 | Input Signal Timeout | The process record <Speed Below Threshold> is set after x msec without signal change at the input. | UINT16 | RW | 0x0064 (100dec)
8020:15 | Presentation | Display of the measured value in RPM, Hz, … | UINT16 | RW | 0x0001 (1dec)
Index 8030 TACHO Settings Dual Shaft Mode Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
8030:0 | TACHO Settings Dual Shaft Mode Ch.2 |  | UINT8 | RO | 0x15 (21dec)
8030:11 | No. of Targets | Number of "cams" on the shaft/axis | UINT16 | RW | 0x0001 (1dec)
8030:12 | Input Signal Timeout | The process record <Speed Below Threshold> is set after x msec without signal change at the input. | UINT16 | RW | 0x0064 (100dec)
8030:15 | Presentation | Display of the measured value in RPM, Hz, … | UINT16 | RW | 0x0001 (1dec)
Index 8031 TACHO Settings Single Shaft Mode
Index (hex) | Name | Meaning | Data type | Flags | Default
8031:0 | TACHO Settings Single Shaft Mode |  | UINT8 | RO | 0x15 (21dec)
8031:0B | Enable Error Detection | Enable/disable error display | BOOLEAN | RW | 0x01 (1dec)
8031:0C | Reversion of Rotation | Reversion of rotation display in Rotation direction | BOOLEAN | RW | 0x00 (0dec)
8031:11 | No. of Targets | Number of "cams" on the shaft/axis | UINT16 | RW | 0x0001 (1dec)
8031:12 | Input Signal Timeout | The process record <Speed Below Threshold> is set after x msec without signal change at the input. | UINT16 | RW | 0x0064 (100dec)
8031:15 | Presentation | Display of the measured value in RPM, Hz, … | UINT16 | RW | 0x0000 (0dec)
Index 8040 DIG Safe State Active
Index (hex) | Name | Meaning | Data type | Flags | Default
8040:0 | DIG Safe State Active |  | UINT8 | RO | 0x08 (8dec)
8040:01 | X4 Pin4 | Activation of Safe State Value if communication is canceled | BOOLEAN | RW | TRUE
8040:02 | X4 Pin2 | Activation of Safe State Value if communication is canceled | BOOLEAN | RW | TRUE
8040:03 | X5 Pin4 | Activation of Safe State Value if communication is canceled | BOOLEAN | RW | TRUE
8040:04 | X5 Pin2 | Activation of Safe State Value if communication is canceled | BOOLEAN | RW | TRUE
8040:05 | X6 Pin4 | Activation of Safe State Value if communication is canceled | BOOLEAN | RW | TRUE
8040:05 | X6 Pin2 | Activation of Safe State Value if communication is canceled | BOOLEAN | RW | TRUE
8040:07 | X7 Pin4 | Activation of Safe State Value if communication is canceled | BOOLEAN | RW | TRUE
8040:08 | X7 Pin2 | Activation of Safe State Value if communication is canceled | BOOLEAN | RW | TRUE
Index 8041 DIG Safe State Value
Index (hex) | Name | Meaning | Data type | Flags | Default
8040:0 | DIG Safe State Value |  | UINT8 | RO | 0x00 (0dec)
8040:01 | X4 Pin4 | Output value if communication is canceled | BOOLEAN | RW | False
8040:02 | X4 Pin2 | Output value if communication is canceled | BOOLEAN | RW | False
8040:03 | X5 Pin4 | Output value if communication is canceled | BOOLEAN | RW | False
8040:04 | X5 Pin2 | Output value if communication is canceled | BOOLEAN | RW | False
8040:05 | X6 Pin4 | Output value if communication is canceled | BOOLEAN | RW | False
8040:05 | X6 Pin2 | Output value if communication is canceled | BOOLEAN | RW | False
8040:07 | X7 Pin4 | Output value if communication is canceled | BOOLEAN | RW | False
8040:08 | X7 Pin2 | Output value if communication is canceled | BOOLEAN | RW | False
Index 8043 DIG Safe State Delay
Index (hex) | Name | Meaning | Data type | Flags | Default
8040:0 | DIG Safe State Delay |  | UINT8 | RO | 0x00 (0dec)
8040:01 | X4 Pin4 | Delay in msec after communication is canceled | UINT16 | RW | False
8040:02 | X4 Pin2 | Delay in msec after communication is canceled | UINT16 | RW | False
8040:03 | X5 Pin4 | Delay in msec after communication is canceled | UINT16 | RW | False
8040:04 | X5 Pin2 | Delay in msec after communication is canceled | UINT16 | RW | False
8040:05 | X6 Pin4 | Delay in msec after communication is canceled | UINT16 | RW | False
8040:05 | X6 Pin2 | Delay in msec after communication is canceled | UINT16 | RW | False
8040:07 | X7 Pin4 | Delay in msec after communication is canceled | UINT16 | RW | False
8040:08 | X7 Pin2 | Delay in msec after communication is canceled | UINT16 | RW | False
Index 8060 PWM Settings
Index (hex) | Name | Meaning | Data type | Flags | Default
8060:0 | PWM settings | Maximum subindex | UINT8 | RO | 0x22 (34dec)
8060:03 | Enable dithering | Dithering is "enabled", activation via process data | BOOLEAN | RW | 0x00 (0dec)
8060:04 | Invert polarity | Reverse current direction | BOOLEAN | RW | 0x00 (0dec)
8060:05 | Watchdog | 0: Default watchdog value The default value (0x8pp0:0D) is active. 1: Watchdog ramp active The ramp (0x8pp0:0E) for moving to the default value ((0x8pp0:0D)) is active. 2: Last output value active In the event of a fault (watchdog drop) the last process data is issued. | BIT2 | RW | 0x00 (0dec)
8060:0B | Offset | This is the user scaling offset Scaling: 1 = rated terminal current / 1024 | INT16 | RW | 0x0000 (0dec)
8060:0C | Gain | This is the user scaling gain. The gain is a fixed-point number with the factor 2^-16. The value one corresponds to 65536 (0x00010000). | INT32 | RW | 0x00010000 (65536dec)
8060:0D | Default output | This is the default output value. The value is output if it is activated via 0x8pp0:05. | INT16 | RW | 0x0000 (0dec)
8060:0E | Default output ramp | This value defines the ramps for the ramp-down to the default value. The value is specified in digits / ms. If the entry is 100 and the default value 0, for example, it takes 327 ms (32767/100) for the output value to change from the maximum value (32767) to the default value in the event of a fault. | UINT16 | RW | 0xFFFF (65535dec)
8060:10 | Max current [%] | Maximum output current mA | UINT8 | RW | 0x64 (100dec)
8060:12 | Kp factor | This is the user scaling gain. The gain is a fixed-point number with the factor 2^-16. The value 1 corresponds to 65535 (0x00010000). | UINT16 | RW | 0x00FA (250dec)
8060:13 | Ki factor | This is the default output value | UINT16 | RW | 0x0004 (4dec)
8060:14 | Kd factor | This value defines the ramps for the ramp-down to the default value. The value is specified in digits / ms. If the entry is 100 and the default value 0, for example, it takes 327 ms (32767/100) for the output value to change from the maximum value (32767) to the default value in the event of a fault. | UINT16 | RW | 0x0032 (50dec)
8060:1E | Dithering frequency [Hz] | Dither frequency in Hertz | UINT16 | RW | 0x0064 (100dec)
8060:1F | Dithering amplitude [%] | Dithering amplitude in percent of the maximum permitted current (rated box current * 0x8pp0:10) | UINT8 | RW | 0x0A (10dec)
8060:21 | Select info data 1 | Selection of synchronous info data (s. 0x6pp0:11) | UINT8 | RW | 0x00 (0dec)
8060:22 | Select info data 2 | Selection of synchronous info data (s. 0x6pp0:12) | UINT8 | RW | 0x00 (0dec)
Index 8070 AO Settings
Index (hex) | Name | Meaning | Data type | Flags | Default
8070:0 | AO Settings |  | UINT8 | RO | 0x16 (22dec)
8070:01 | Enable user scale | This entry activates the scaling for 0x8pp0:11 and 0x8pp0:12. | BOOLEAN | RW | 0x00 (0dec)
8070:02 | Presentation | 0: Signed presentation The output value range 0x7pp1:11 is shown as 16 bit signed integer. For unipolar terminals (0-10V or 0-20 mA) the negative range is set to zero. 1: Unsigned presentation The output value range 0x7pp1:11 is shown as 16 bit unsigned integer. Negative values are not possible. 2: Absolute value with MSB as sign, signed amount representation is active. 3: Absolute value, the absolute value of the signed representation is formed. | BIT3 | RW | 0x00 (0dec)
8070:05 | Watchdog | 0: Default watchdog value The default value (0x8pp0:13) is active. 1: Watchdog ramp The ramp (0x8pp0:14) for moving to the default value ((0x8pp0:13)) is active. 2: Last output value In the event of a fault (watchdog drop) the last process data is issued. | BIT2 | RW | 0x00 (0dec)
8070:07 | Enable user calibration | Enabling of the user calibration | BOOLEAN | RW | 0x00 (0dec)
8070:08 | Enable vendor calibration | Enable vendor calibration | BOOLEAN | RW | 0x01 (1dec)
8070:11 | User scale offset | This is the user scaling offset | INT16 | RW | 0x0000 (0dec)
8070:12 | User scale gain | This is the user scaling gain. The gain is a fixed-point number with the factor 2^-16. The value 1 corresponds to 65535 (0x00010000). | INT32 | RW | 0x00010000 (65536dec)
8070:13 | Default output | This is the default output value | INT16 | RW | 0x0000 (0dec)
8070:14 | Default output ramp | This value defines the ramps for the ramp-down to the default value. The value is specified in digits / ms. If the entry is 100 and the default value 0, for example, it takes 327 ms (32767/100) for the output value to change from the maximum value (32767) to the default value in the event of a fault. | UINT16 | RW | 0xFFFF (65535dec)
8070:15 | User calibration offset | User calibration offset | INT16 | RW | 0x0000 (0dec)
8070:16 | User calibration gain | User gain compensation | UINT16 | RW | 0x4000 (16384dec)
Index F800 AIAO Range settings
Index (hex) | Name | Meaning | Data type | Flags | Default
F800:0 | AIAO Range settings |  | UINT8 | RO | 0x08 (8dec)
F800:01 | Input type Ch1 | Select input type for Ch1 | UINT16 | RW | 0x0001 (1dec)
F800:02 | Input type Ch2 | Select input type for Ch2 | UINT16 | RW | 0x0001 (1dec)
F800:08 | Output type | Select input type for Ch1 | UINT16 | RW | 0x0001 (1dec)


Objects for regular operation

Commissioning and Configuration [image] CoE objects [image] Object description and parameterization [image] Objects for regular operation
Objects for regular operation
The EP8309 has no such objects.


Standard objects (0x1000-0x1FFF)

Commissioning and Configuration [image] CoE objects [image] Object description and parameterization [image] Standard objects (0x1000-0x1FFF)
Standard objects (0x1000-0x1FFF)
The standard objects have the same meaning for all EtherCAT slaves.
Index 1000 Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Low-Word contains the CoE profile used (5001). The High-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x00001389 (5001dec)
Index 1008 Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EP8309-1022
Index 1009 Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO | 00
Index 100A Software Version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO | 02
Index 1011 Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default parameters | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" in the set value dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)
Index 1018 Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x20754052 (544555090dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the low word (bit 0-15) indicates the special terminal number, the high word (bit 16-31) refers to the device description | UINT32 | RO | 0x00110016 (1114134dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the low byte (bit 0-7) of the low word contains the year of production, the high byte (bit 8-15) of the low word contains the week of production, the high word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 Backup parameter handling
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | Information for standardized loading and saving of backup entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum across all backup entries of the EtherCAT slave | UINT32 | RO | 0x00000000 (0dec)
Index 1402 PWM RxPDO-Par Control
Index (hex) | Name | Meaning | Data type | Flags | Default
1402:0 | PWM RxPDO-Par Control | PDO Parameter RxPDO 3 | UINT8 | RO | 0x06 (6dec)
1402:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 3 | OCTET-STRING[2] | RO | 03 16
Index 1403 AO RxPDO-Par Outputs
Index (hex) | Name | Meaning | Data type | Flags | Default
1403:0 | AO RxPDO-Par Outputs | PDO Parameter RxPDO 4 | UINT8 | RO | 0x06 (6dec)
1403:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 4 | OCTET-STRING[2] | RO | 02 16
Index 1600 TACHO RxPDO-Map OutputsCh.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1600:0 | TACHO RxPDO-Map OutputsCh.1 | PDO Mapping RxPDO 1 | UINT8 | RO | 0x03 (3dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (PWM Outputs Ch.1), entry 0x01 (Enable dithering)) | UINT32 | RO | 0x0000:00, 8
1600:02 | SubIndex 002 | 2. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x7020:09, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7020 (PWM Outputs Ch.1), entry 0x06 (Enable)) | UINT32 | RO | 0x0000:00, 7
Index 1601 DO RxPDO-Map Outputs
Index (hex) | Name | Meaning | Data type | Flags | Default
1601:0 | DO RxPDO-Map Outputs | PDO Mapping RxPDO 2 | UINT8 | RO | 0x07 (7dec)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7030 (PWM Outputs Ch.2), entry 0x01 (Enable dithering)) | UINT32 | RO | 0x7050:01, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x7050:02, 1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7030 (PWM Outputs Ch.2), entry 0x06 (Enable)) | UINT32 | RO | 0x7050:03, 1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7050 (DO Outputs), entry 0x04 (Digital Output X6 Pin2)) | UINT32 | RO | 0x7050:04, 1
1601:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7050 (DO Outputs), entry 0x05 (Digital Output X7 Pin4)) | UINT32 | RO | 0x7050:05, 1
1601:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7050 (DO Outputs), entry 0x06 (Digital Output X7 Pin2)) | UINT32 | RO | 0x7050:06, 1
1601:07 | SubIndex 007 | 7. PDO Mapping entry (10 bits align) | UINT32 | RO | 0x0000:00, 10
Index 1602 PWM RxPDO-Map Control
Index (hex) | Name | Meaning | Data type | Flags | Default
1602:0 | PWM RxPDO-Map Control | PDO Mapping RxPDO 3 | UINT8 | RO | 0x06 (6dec)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7040 (DO Outputs), entry 0x01 (Output 10)) | UINT32 | RO | 0x7060:01, 1
1602:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7040 (DO Outputs), entry 0x02 (Output 11)) | UINT32 | RO | 0x0000:00, 4
1602:03 | SubIndex 003 | 3. PDO Mapping entry (14 bits align) | UINT32 | RO | 0x7060:06, 1
1602:04 | SubIndex 004 | 4. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x7060:07, 1
1602:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7050 (DO Outputs), entry 0x0E (Output 14)) | UINT32 | RO | 0x0000:00, 9
1602:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7050 (DO Outputs), entry 0x0E (Output 15)) | UINT32 | RO | 0x7060:11, 16
Index 1603 AO RxPDO-Map Outputs
Index (hex) | Name | Meaning | Data type | Flags | Default
1603:0 | AO RxPDO-Map Outputs | PDO Mapping RxPDO 4 | UINT8 | RO | 0x01 (1dec)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7060 (AO Outputs Ch.3), entry 0x11 (Analog output)) | UINT32 | RO | 0x7070:11, 16
Index 1802 TACHO TxPDO-Par Single Shaft Mode Input Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1802:0 | TACHO TxPDO-Par Single Shaft Mode Input Ch.1 | PDO parameter TxPDO 3 | UINT8 | RO | 0x06 (6dec)
1802:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 3 | OCTET STRING[4] | RO | 03 1A 04 1A
Index 1803 TACHO TxPDO-Par Dual Shaft Mode Input Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1803:0 | TACHO TxPDO-Par Dual Shaft Mode Input Ch.1 | PDO parameter TxPDO 4 | UINT8 | RO | 0x06 (6dec)
1803:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 4 | OCTET STRING[4] | RO | 02 1A 00 00
Index 1804 TACHO TxPDO-Par Dual Shaft Mode Input Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1804:0 | TACHO TxPDO-Par Dual Shaft Mode Input Ch.2 | PDO parameter TxPDO 5 | UINT8 | RO | 0x06 (6dec)
1804:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 5 | OCTET STRING[4] | RO | 02 1A 00 00
Index 1A00 AI TxPDO-Map Inputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A00:0 | AI TxPDO-Map Inputs Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x0A (10dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x01 (Underrange)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x02 (Overrange)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6000:03, 2
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6000:05, 2
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x07 (Error)) | UINT32 | RO | 0x6000:07, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x0E (Sync error)) | UINT32 | RO | 0x6000:0E, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6000:0F, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6000:10, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x11 (Value)) | UINT32 | RO | 0x6000:11, 16
Index 1A01 AI TxPDO-Map Inputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A01:0 | AI TxPDO-Map Inputs Ch.2 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x0A (10dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x01 (Underrange)) | UINT32 | RO | 0x6010:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x02 (Overrange)) | UINT32 | RO | 0x6010:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6010:03, 2
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6010:05, 2
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x07 (Error)) | UINT32 | RO | 0x6010:07, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x0E (Sync error)) | UINT32 | RO | 0x6010:0E, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6010:0F, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6010:10, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x11 (Value)) | UINT32 | RO | 0x6010:11, 16
Index 1A02 TACHO TxPDO-Map Single Shaft Mode Input Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A02:0 | TACHO TxPDO-Map Single Shaft Mode Input Ch.1 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x0C (12dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (AI Inputs Ch.2), entry 0x01 (Underrange)) | UINT32 | RO | 0x0000:00, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6027 (TACHO Redundant Tracks Inputs Ch.1), entry 0x02 (Track Error A)) | UINT32 | RO | 0x6037:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6027 (TACHO Redundant Tracks Inputs Ch.1), entry 0x03 (Input Status Track A)) | UINT32 | RO | 0x6037:03, 1
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6027 (TACHO Redundant Tracks Inputs Ch.1), entry 0x04 (Track Error B)) | UINT32 | RO | 0x6037:04, 1
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6027 (TACHO Redundant Tracks Inputs Ch.1), entry 0x05 (Input Status Track B)) | UINT32 | RO | 0x6037:05, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 3
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6027 (TACHO Redundant Tracks Inputs Ch.1), entry 0x0C (Speed Below Threshold)) | UINT32 | RO | 0x0000:00, 3
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x6037:0C, 1
1A02:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6027 (TACHO Redundant Tracks Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x0000:00, 3
1A02:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6027 (TACHO Redundant Tracks Inputs Ch.1), entry 0x11 (Rotational Speed)) | UINT32 | RO | 0x6037:10, 1
1A02:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6027 (TACHO Single Shaft Mode Input), entry 0x11 (Rotational Speed)) | UINT32 | RO | 0x6037:11, 16
1A02:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6027 (TACHO Single Shaft Mode Input), entry 0x12 (Rotation Direction)) | UINT32 | RO | 0x6037:12, 16
Index 1A03 TACHO TxPDO-Map Dual Shaft Mode Input Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A03:0 | TACHO TxPDO-Map Dual Shaft Mode Input Ch.1 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x09 (9dec)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (AI Inputs Ch.2), entry 0x01 (Underrange)) | UINT32 | RO | 0x6020:01, 1
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (AI Inputs Ch.2), entry 0x02 (Overrange)) | UINT32 | RO | 0x0000:00, 2
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (AI Inputs Ch.2), entry 0x03 (Limit 1)) | UINT32 | RO | 0x0000:00, 1
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (AI Inputs Ch.2), entry 0x05 (Limit 2)) | UINT32 | RO | 0x0000:00, 4
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (AI Inputs Ch.2), entry 0x07 (Error)) | UINT32 | RO | 0x0000:00, 3
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x6020:0C, 1
1A03:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020 (TACHO Dual Shaft Mode Input Ch.1), entry 0x11 (Rotational Speed)) | UINT32 | RO | 0x0000:00, 3
1A03:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6020 (TACHO Dual Shaft Mode Input Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6020:10, 1
1A03:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6020 (TACHO Dual Shaft Mode Input Ch.1), entry 0x11 (Rotational Speed)) | UINT32 | RO | 0x6020:11, 16
Index 1A04 TACHO TxPDO-Map Dual Shaft Mode Input Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A04:0 | TACHO TxPDO-Map Dual Shaft Mode Input Ch.2 | PDO Mapping TxPDO 5 | UINT8 | RO | 0x09 (9dec)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (PWM Inputs Ch.1), entry 0x01 (Digital input 1)) | UINT32 | RO | 0x6030:01, 1
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 2
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (PWM Inputs Ch.1), entry 0x05 (Ready to enable)) | UINT32 | RO | 0x0000:00, 1
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (PWM Inputs Ch.1), entry 0x06 (Warning)) | UINT32 | RO | 0x0000:00, 4
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (PWM Inputs Ch.1), entry 0x07 (Error)) | UINT32 | RO | 0x0000:00, 3
1A04:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x6030:0C, 1
1A04:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6030 (TACHO Dual Shaft Mode Input Ch.2), entry 0x11 (Rotational Speed)) | UINT32 | RO | 0x0000:00, 3
1A04:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6030 (TACHO Dual Shaft Mode Input Ch.2), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6030:10, 1
1A04:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6030 (TACHO Dual Shaft Mode Input Ch.2), entry 0x11 (Rotational Speed)) | UINT32 | RO | 0x6030:11, 16
Index 1A05 DI TxPDO-Map Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
1A05:0 | DI TxPDO-Map Inputs | PDO Mapping TxPDO 6 | UINT8 | RO | 0x07 (7dec)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (PWM Inputs Ch.1), entry 0x01 (Digital input 1)) | UINT32 | RO | 0x6040:01, 1
1A05:02 | SubIndex 002 | 2. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x6040:02, 1
1A05:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (PWM Inputs Ch.1), entry 0x05 (Ready to enable)) | UINT32 | RO | 0x6040:03, 1
1A05:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (PWM Inputs Ch.1), entry 0x06 (Warning)) | UINT32 | RO | 0x6040:04, 1
1A05:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (PWM Inputs Ch.1), entry 0x07 (Error)) | UINT32 | RO | 0x6040:05, 1
1A05:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x6040:06, 1
1A05:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020 (PM Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x0000:00, 10
Index 1A06 PWM TxPDO-Map Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1A06:0 | PWM TxPDO-Map Status | PDO Mapping TxPDO 7 | UINT8 | RO | 0x08 (8dec)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6040 (DI Inputs), entry 0x01 (Digital Input X4 Pin4)) | UINT32 | RO | 0x0000:00, 1
1A06:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6040 (DI Inputs), entry 0x02 (Digital Input X4 Pin2)) | UINT32 | RO | 0x0000:00, 3
1A06:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6040 (DI Inputs), entry 0x03 (Digital Input X6 Pin4)) | UINT32 | RO | 0x6060:05, 1
1A06:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6040 (DI Inputs), entry 0x04 (Digital Input X6 Pin2)) | UINT32 | RO | 0x6060:06, 1
1A06:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6040 (DI Inputs), entry 0x05 (Digital Input X7 Pin4)) | UINT32 | RO | 0x6060:07, 1
1A06:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6040 (DI Inputs), entry 0x06 (Digital Input X7 Pin2)) | UINT32 | RO | 0x0000:00, 1
1A06:07 | SubIndex 007 | 7. PDO Mapping entry (10 bits align) | UINT32 | RO | 0x0000:00, 7
1A06:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6060 (PWM Inputs), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6060:10, 1
Index 1A07 PWM TxPDO-Map Synchronous info data
Index (hex) | Name | Meaning | Data type | Flags | Default
1A07:0 | PWM TxPDO-Map Synchronous Info Data | PDO Mapping TxPDO 8 | UINT8 | RO | 0x02 (2dec)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6060 (PWM Inputs), entry 0x01 (Digital input 1)) | UINT32 | RO | 0x6060:11, 16
1A07:02 | SubIndex 002 | 2. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x6060:12, 16
Index 1C00 Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the sync managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO Assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x03 (3dec)
1C12:01 | Subindex 001 | 1st allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1600 (5632dec)
1C12:02 | Subindex 002 | 2nd allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1601 (5633dec)
1C12:03 | Subindex 003 | 3rd allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1602 (5634dec)
1C12:04 | Subindex 004 | 4th allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 1C13 TxPDO Assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x05 (5dec)
1C13:01 | Subindex 001 | 1st allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2nd allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A01 (6657dec)
1C13:03 | Subindex 003 | 3rd allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A02 (6658dec)
1C13:04 | Subindex 004 | 4th allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A05 (6661dec)
1C13:05 | Subindex 005 | 5th allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A06 (6662dec)
1C13:06 | Subindex 006 | 6th allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:07 | Subindex 007 | 7th allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 1C32 SM output parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C32:0
SM output parameter
Synchronization parameters for the outputs
UINT8
RO
0x20 (32dec)
1C32:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchronous with SM 2 event
▪
2: DC-Mode - Synchronous with SYNC0 Event
▪
3: DC-Mode - Synchronous with SYNC1 event
UINT16
RW
0x0001 (1dec)
1C32:02
Cycle time
Cycle time (in ns):
▪
Free Run: Cycle time of the local timer
▪
Synchronous with SM 2 event: Master cycle time
▪
DC mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dec)
1C32:03
Shift time
Time between SYNC0 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0 = 1: free run is supported
▪
Bit 1 = 1: Synchronous with SM 2 event is supported
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 10: Output shift with SYNC1 event (only DC mode)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08)
UINT16
RO
0xC007 (49159dec)
1C32:05
Minimum cycle time
Minimum cycle time (in ns)
UINT32
RO
0x0007A120 (500000dec)
1C32:06
Calc and copy time
Minimum time between SYNC0 and SYNC1 event (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:07
Minimum delay time
UINT32
RO
0x00000000 (0dec)
1C32:08
Command
▪
0: Measurement of the local cycle time is stopped
▪
1: Measurement of the local cycle time is started
The entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 are updated with the maximum measured values.
For a subsequent measurement the measured values are reset
UINT16
RW
0x0000 (0dec)
1C32:09
Maximum delay time
Time between SYNC1 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:0B
SM event missed counter
Number of missed SM events in OPERATIONAL (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:0C
Cycle exceeded counter
Number of occasions the cycle time was exceeded in OPERATIONAL (cycle was not completed in time or the next cycle began too early)
UINT16
RO
0x0000 (0dec)
1C32:0D
Shift too short counter
Number of occasions that the interval between SYNC0 and SYNC1 event was too short (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:20
Sync error
The synchronization was not correct in the last cycle (outputs were output too late; DC mode only)
BOOLEAN
RO
0x00 (0dec)
Index 1C33 SM input parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchronous with SM 3 Event (no outputs available)
▪
2: DC - Synchronous with SYNC0 Event
▪
3: DC - Synchronous with SYNC1 Event
▪
34: Synchronous with SM 2 event (outputs available)
UINT16
RW
0x0022 (34dec)
1C33:02
Cycle time
as 0x1C32:02
UINT32
RW
0x000F4240 (1000000dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: Synchronous with SM 2 Event is supported (outputs available)
▪
Bit 1: Synchronous with SM 3 Event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: Input shift through local event (outputs available)
▪
Bit 4-5 = 10: Input shift with SYNC1 event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08 or 0x1C33:08)
UINT16
RO
0xC007 (49159dec)
1C33:05
Minimum cycle time
as 0x1C32:05
UINT32
RO
0x0007A120 (500000dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:07
Minimum delay time
UINT32
RO
0x00000000 (0dec)
1C33:08
Command
as 0x1C32:08
UINT16
RW
0x0000 (0dec)
1C33:09
Maximum delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:0B
SM event missed counter
as 0x1C32:11
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
as 0x1C32:12
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
as 0x1C32:13
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
as 0x1C32:32
BOOLEAN
RO
0x00 (0dec)


Profile-specific objects (0x6000-0xFFFF)

Commissioning and Configuration [image] CoE objects [image] Object description and parameterization [image] Profile-specific objects (0x6000-0xFFFF)
Profile-specific objects (0x6000-0xFFFF)
The profile-specific objects have the same meaning for all EtherCAT slaves that support the profile 5001.
Index 6000 AI Inputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
6000:0 | AI Inputs Ch.1 |  | UINT8 | RO | 0x11 (17dec)
6000:01 | Underrange | Underrange event active | BOOLEAN | RO | 0x00 (0dec)
6000:02 | Overrange | Overrange event active | BOOLEAN | RO | 0x00 (0dec)
6000:03 | Limit 1 | Bit0: Value greater than Limit1 Bit1: Value smaller than Limit1 | BIT2 | RO | 0x00 (0dec)
6000:05 | Limit 2 | Bit0: Value greater than Limit2 Bit1: Value smaller than Limit2 | BIT2 | RO | 0x00 (0dec)
6000:07 | Error | Bit set when Over- or Underrange | BOOLEAN | RO | 0x00 (0dec)
6000:0E | Sync error |  | BOOLEAN | RO | 0x00 (0dec)
6000:0F | TxPDO State |  | BOOLEAN | RO | 0x00 (0dec)
6000:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)
6000:11 | Value |  | INT16 | RO | 0x0000 (0dec)
Index 6010 AI Inputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
6010:0 | AI Inputs Ch.2 |  | UINT8 | RO | 0x11 (17dec)
6010:01 | Underrange | Underrange event active | BOOLEAN | RO | 0x00 (0dec)
6010:02 | Overrange | Overrange event active | BOOLEAN | RO | 0x00 (0dec)
6010:03 | Limit 1 | Bit0: Value greater than Limit1 Bit1: Value smaller than Limit1 | BIT2 | RO | 0x00 (0dec)
6010:05 | Limit 2 | Bit0: Value greater than Limit2 Bit1: Value smaller than Limit2 | BIT2 | RO | 0x00 (0dec)
6010:07 | Error | Bit set when Over- or Underrange | BOOLEAN | RO | 0x00 (0dec)
6010:0E | Sync error |  | BOOLEAN | RO | 0x00 (0dec)
6010:0F | TxPDO State |  | BOOLEAN | RO | 0x00 (0dec)
6010:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)
6010:11 | Value |  | INT16 | RO | 0x0000 (0dec)
Index 6020 TACHO Dual Shaft Mode Input Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
6020:0 | TACHO Dual Shaft Mode Input Ch.1 |  | UINT8 | RO | 0x11 (17dec)
6020:01 | Digital input |  | BOOLEAN | RO | 0x00 (0dec)
6020:0C | Speed Below Threshold |  | BOOLEAN | RO | 0x00 (0dec)
6020:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)
6020:11 | Rotational Speed |  | INT16 | RO | 0x0000 (0dec)
Index 6030 TACHO Dual Shaft Mode Input Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
6030:0 | TACHO Dual Shaft Mode Input Ch.2 |  | UINT8 | RO | 0x11 (17dec)
6030:01 | Digital input |  | BOOLEAN | RO | 0x00 (0dec)
6030:0C | Speed Below Threshold |  | BOOLEAN | RO | 0x00 (0dec)
6030:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)
6030:11 | Rotational Speed |  | INT16 | RO | 0x0000 (0dec)
Index 6037 TACHO Single Shaft Mode Input
Index (hex) | Name | Meaning | Data type | Flags | Default
6037:0 | TACHO Single Shaft Mode Input |  | UINT8 | RO | 0x12 (18dec)
6037:02 | Error Input A |  | BOOLEAN | RO | 0x00 (0dec)
6037:03 | Input Status A |  | BOOLEAN | RO | 0x00 (0dec)
6037:04 | Error Input B |  | BOOLEAN | RO | 0x00 (0dec)
6037:05 | Input Status B |  | BOOLEAN | RO | 0x00 (0dec)
6037:0C | Speed Below Threshold |  | BOOLEAN | RO | 0x00 (0dec)
6037:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)
6037:11 | Rotational Speed |  | INT16 | RO | 0x0000 (0dec)
6037:12 | Rotation Direction |  | UINT16 | RO | 0x0000 (0dec)
Index 6040 DI Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
6040:0 | DI Inputs |  | UINT8 | RO | 0x06 (6dec)
6040:01 | Digital Input X4 Pin4 |  | BOOLEAN | RO | 0x00 (0dec)
6040:02 | Digital Input X4 Pin2 |  | BOOLEAN | RO | 0x00 (0dec)
6040:03 | Digital Input X6 Pin4 |  | BOOLEAN | RO | 0x00 (0dec)
6040:04 | Digital Input X6 Pin2 |  | BOOLEAN | RO | 0x00 (0dec)
6040:05 | Digital Input X7 Pin4 |  | BOOLEAN | RO | 0x00 (0dec)
6040:06 | Digital Input X7 Pin2 |  | BOOLEAN | RO | 0x00 (0dec)
Index 6060 PWM Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
6060:0 | PWM Inputs |  | UINT8 | RO | 0x12 (18dec)
6060:05 | Ready to enable |  | BOOLEAN | RO | 0x00 (0dec)
6060:06 | Warning |  | BOOLEAN | RO | 0x00 (0dec)
6060:07 | Error |  | BOOLEAN | RO | 0x00 (0dec)
6060:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)
6060:11 | Info data 1 |  | INT16 | RO | 0x0000 (0dec)
6060:12 | Info data 2 |  | INT16 | RO | 0x0000 (0dec)
Index 7020 TACHO Outputs
Index (hex) | Name | Meaning | Data type | Flags | Default
7020:0 | TACHO Outputs |  | UINT8 | RO | 0x09 (9dec)
7020:09 | Reset Error |  | BOOLEAN | RO | 0x00 (0dec)
Index 7030 TACHO Outputs
Index (hex) | Name | Meaning | Data type | Flags | Default
7030:0 | TACHO Outputs |  | UINT8 | RO | 0x09 (9dec)
7030:09 | Reset Error |  | BOOLEAN | RO | 0x00 (0dec)
Index 7040 DIG Output
Index (hex) | Output 11>Name | Meaning | Data type | Flags | Default
7050:0 | DIG Outputs |  | UINT8 | RO | 0x06 (6dec)
7050:01 | Digital Output X4 Pin4 |  | BOOLEAN | RO | 0x00 (0dec)
7050:02 | Digital Output X4 Pin2 |  | BOOLEAN | RO | 0x00 (0dec)
7050:03 | Digital Output X5 Pin4 |  | BOOLEAN | RO | 0x00 (0dec)
7050:04 | Digital Output X5 Pin2 |  | BOOLEAN | RO | 0x00 (0dec)
7050:05 | Digital Output X6 Pin4 |  | BOOLEAN | RO | 0x00 (0dec)
7050:06 | Digital Output X6 Pin2 |  | BOOLEAN | RO | 0x00 (0dec)
7050:07 | Digital Output X7 Pin4 |  | BOOLEAN | RO | 0x00 (0dec)
7050:08 | Digital Output X7 Pin2 |  | BOOLEAN | RO | 0x00 (0dec)
Index 7060 PWM Outputs
Index (hex) | Name | Meaning | Data type | Flags | Default
7060:0 | PWM Outputs |  | UINT8 | RO | 0x11 (17dec)
7060:01 | Enable dithering |  | BOOLEAN | RO | 0x00 (0dec)
7060:06 | Enable |  | BOOLEAN | RO | 0x00 (0dec)
7060:07 | Reset |  | BOOLEAN | RO | 0x00 (0dec)
7060:11 | PWM output | Analog output data | INT16 | RO | 0x0000 (0dec)
Index 7070 AO Outputs
Index (hex) | Name | Meaning | Data type | Flags | Default
7070:0 | AO Outputs |  | UINT8 | RO | 0x11 (17dec)
7070:11 | Analog output | Analog output data | INT16 | RO | 0x0000 (0dec)
Index 800E AI Internal data Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
800E:0 | AI Internal data Ch.1 |  | UINT8 | RO | 0x01 (1dec)
800E:01 | ADC raw value |  | INT16 | RO | 0x0000 (0dec)
Index 800F AI Vendor data Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
800F:0 | AI Vendor data Ch.1 |  | UINT8 | RO | 0x06 (6dec)
800F:01 | R0 Offset |  | INT16 | RW | 0x0000 (0dec)
800F:02 | R0 Gain |  | INT16 | RW | 0x4000 (16384dec)
800F:03 | R1 Offset |  | INT16 | RW | 0x0000 (0dec)
800F:04 | R1 Gain |  | INT16 | RW | 0x4000 (16384dec)
800F:05 | R2 Offset |  | INT16 | RW | 0x0000 (0dec)
800F:06 | R2 Gain |  | INT16 | RW | 0x4000 (16384dec)
Index 801E AI Internal data Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
801E:0 | AI Internal Data Ch.2 |  | UINT8 | RO | 0x01 (1dec)
801E:01 | ADC raw value |  | INT16 | RO | 0x0000 (0dec)
Index 801F AI Vendor data Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
801F:0 | AI Vendor Data Ch.2 |  | UINT8 | RO | 0x06 (6dec)
801F:01 | R0 Offset |  | INT16 | RW | 0x0000 (0dec)
801F:02 | R0 Gain |  | INT16 | RW | 0x4000 (16384dec)
801F:03 | R1 Offset |  | INT16 | RW | 0x0000 (0dec)
801F:04 | R1 Gain |  | INT16 | RW | 0x4000 (16384dec)
801F:05 | R2 Offset |  | INT16 | RW | 0x0000 (0dec)
801F:06 | R2 Gain |  | INT16 | RW | 0x4000 (16384dec)
Index 806F PWM Vendor data
Index (hex) | Name | Meaning | Data type | Flags | Default
806F:0 | PWM Vendor data |  | UINT8 | RO | 0x02 (2dec)
806F:01 | Offset | Vendor calibration for +/-10 V | INT16 | RW | 0x0000 (0dec)
806F:02 | Gain | Vendor calibration for +/-10 V | INT16 | RW | 0x4000 (16384dec)
Index 807E AO Internal data
Index (hex) | Name | Meaning | Data type | Flags | Default
807E:0 | AO Internal Data |  | UINT8 | RO | 0x01 (1dec)
807E:01 | DAC Raw Value | This is the raw DAC value. | UINT16 | RO | 0x0000 (0dec)
Index 807F AO Vendor data
Index (hex) | Name | Meaning | Data type | Flags | Default
807F:0 | AO Vendor Data |  | UINT8 | RO | 0x06 (6dec)
807F:01 | R0 Calibration Offset | Vendor calibration for +/-10 V | INT16 | RW | 0x0000 (0dec)
807F:02 | R0 Calibration Gain | Vendor calibration for +/-10 V | UINT16 | RW | 0x4000 (16384dec)
807F:03 | R1 Calibration Offset | Vendor calibration for 0-20 mA | INT16 | RW | 0x0000 (0dec)
807F:04 | R1 Calibration Gain | Vendor calibration for 0-20 mA | UINT16 | RW | 0x4000 (16384dec)
807F:05 | R2 Calibration Offset | Vendor calibration for 4-20 mA | INT16 | RW | 0x0000 (0dec)
807F:06 | R2 Calibration Gain | Vendor calibration for 4-20 mA | UINT16 | RW | 0x4000 (16384dec)
Index A060 PWM Diag data
Index (hex) | Name | Meaning | Data type | Flags | Default
A060:0 | PWM Diag data |  | UINT8 | RO | 0x06 (6dec)
A060:02 | Overtemperature |  | BOOLEAN | RO | 0x00 (0dec)
A060:06 | Short circuit |  | BOOLEAN | RO | 0x00 (0dec)
Index F000 Modular Device Profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0008 (8dec)
Index F008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word |  | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module List
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list |  | UINT8 | RW | 0x08 (8dec)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x0000012C (300dec)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x0000012C (300dec)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x00000208 (520dec)
F010:04 | SubIndex 004 |  | UINT32 | RW | 0x00000208 (520dec)
F010:05 | SubIndex 005 |  | UINT32 | RW | 0x00000064 (100dec)
F010:06 | SubIndex 006 |  | UINT32 | RW | 0x000000C8 (200dec)
F010:07 | SubIndex 007 |  | UINT32 | RW | 0x000000FA (250dec)
F010:08 | SubIndex 008 |  | UINT32 | RW | 0x00000190 (400dec)
Index F900 PWM Info data
Index (hex) | Name | Meaning | Data type | Flags | Default
F900:0 | PWM Info data |  | UINT8 | RO | 0x02 (2dec)
F900:02 | Temperature [°C] |  | UINT8 | RO | 0x00 (0dec)
Index FB00 PWM Command
Index (hex) | Name | Meaning | Data type | Flags | Default
FB00:0 | PWM Command |  | UINT8 | RO | 0x03 (3dec)
FB00:01 | Request |  | OCTET-STRING[2] | RW | {0}
FB00:02 | Status |  | UINT8 | RO | 0x00 (0dec)
FB00:03 | Response |  | OCTET STRING[4] | RO | {0}


Restoring the delivery state

Commissioning and Configuration [image] Restoring the delivery state
Restoring the delivery state
The CoE object Restore default parameters, Subindex 001 can be selected in the TwinCAT System Manager (Config mode) in order to restore the delivery state of the back-up objects for the EPPxxxx Boxes.
Selecting the PDO restore default parameter
Double-click on SubIndex 001 to enter the Set Value dialog. Enter the value 1684107116 in the field Dec or alternatively the value 0x64616F6C in the field Hex and confirm with OK.
All backup objects are reset to the delivery state.
Entering a restore value in the Set Value dialog
Alternative restore value
With some older modules the backup objects can be changed with an alternative restore value:
Decimal value: 1819238756
Hexadecimal value: 0x6C6F6164
An incorrect entry for the restore value has no effect.


Diagnostics

Diagnostics
Diagnostics
The module offers various diagnostic options for users. These messages are divided into hardware warnings and hardware errors. The respective status words for the channels (except digital inputs and outputs) contain a bit for warnings and errors. The exact cause is analyzed via the diagnostic data (0xA050). Warnings are reset automatically. Errors may result in the output stage being switched off (PWMi) and have to be acknowledged in the control word (0x7050:07 Reset)
Error/warning for the PWM stage
Index (hex) | Warning | Meaning
A050:02 | Overtemperature | from 100 °C
A050:06 | Short circuit | An overcurrent/short circuit of more than 105% of the rated current has occurred for more than 200 ms
Control voltage (Us) and peripheral voltage (Up) of the EP8309
Diagnostic control voltage (Us) and peripheral voltage (Up) of the EP8309
DEV input process data | Meaning
Undervoltage Us | Warning below 18 VDC
Undervoltage Up | Warning below 18 VDC


Appendix

Appendix
Appendix
Additional information
•
General operating conditions
•
Accessories
•
Version identification of EtherCAT devices
•
Support and Service


General operating conditions

Appendix [image] General operating conditions
General operating conditions
Protection degrees (IP-Code)
The standard IEC 60529 (DIN EN 60529) defines the degrees of protection in different classes.
1. Number: dust protection and touch guard | Definition
0 | Non-protected
1 | Protected against access to hazardous parts with the back of a hand. Protected against solid foreign objects of Ø 50 mm
2 | Protected against access to hazardous parts with a finger. Protected against solid foreign objects of Ø 12.5 mm.
3 | Protected against access to hazardous parts with a tool. Protected against solid foreign objects Ø 2.5 mm.
4 | Protected against access to hazardous parts with a wire. Protected against solid foreign objects Ø 1 mm.
5 | Protected against access to hazardous parts with a wire. Dust-protected. Intrusion of dust is not totally prevented, but dust shall not penetrate in a quantity to interfere with satisfactory operation of the device or to impair safety.
6 | Protected against access to hazardous parts with a wire. Dust-tight. No intrusion of dust.
2. Number: water* protection | Definition
0 | Non-protected
1 | Protected against water drops
2 | Protected against water drops when enclosure tilted up to 15°.
3 | Protected against spraying water. Water sprayed at an angle up to 60° on either side of the vertical shall have no harmful effects.
4 | Protected against splashing water. Water splashed against the disclosure from any direction shall have no harmful effects
5 | Protected against water jets
6 | Protected against powerful water jets
7 | Protected against the effects of temporary immersion in water. Intrusion of water in quantities causing harmful effects shall not be possible when the enclosure is temporarily immersed in water for 30 min. in 1 m depth.
*) These protection classes define only protection against water!
Chemical Resistance
The Resistance relates to the Housing of the IP 67 modules and the used metal parts. In the table below you will find some typical resistance.
Character | Resistance
Steam | at temperatures >100°C: not resistant
Sodium base liquor (ph-Value > 12) | at room temperature: resistant > 40°C: not resistant
Acetic acid | not resistant
Argon (technical clean) | resistant
Key
▪
resistant: Lifetime several months
▪
non inherently resistant: Lifetime several weeks
▪
not resistant: Lifetime several hours resp. early decomposition


Accessories

Appendix [image] Accessories
Accessories
Mounting
Ordering information | Description
ZS5300-0001 | Mounting rail (500 mm x 129 mm)
Cables
Ordering information | Description
ZK1090-3xxx-xxxx | EtherCAT cable M8, green link to the website
ZK1093-3xxx-xxxx | EtherCAT cable M8, yellow link to the website
ZK2000-5xxx-xxxx ZK2000-71xx-xxxx | Sensor cable M12 5-wire Link to website
ZK2000-6xxx-xxxx | Sensor cable M12 4-wire Link to website
A complete overview of pre-assembled cables for EtherCAT Box modules can be found here.
Labeling material, protective caps
Ordering information | Description
ZS5000-0010 | Protective cap for M8 sockets, IP67 (50 pieces)
ZS5000-0020 | Protective cap M12, IP67 (50 pieces)
ZS5100-0000 | Inscription labels, unprinted, 4 strips of 10
ZS5000-xxxx | Printed inscription labels on enquiry
Tools
Ordering information | Description
ZB8801-0000 | Torque wrench for plugs, 0.4…1.0 Nm
ZB8801-0001 | Torque cable key for M8 / wrench size 9 for ZB8801-0000
ZB8801-0002 | Torque cable key for M12 / wrench size 13 for ZB8801-0000
ZB8801-0003 | Torque cable key for M12 field assembly / wrench size 18 for ZB8801-0000
Further accessories
Further accessories can be found in the price list for fieldbus components from Beckhoff and online at https://www.beckhoff.com.


Version identification of EtherCAT devices

Appendix [image] Version identification of EtherCAT devices
Version identification of EtherCAT devices
Designation
A Beckhoff EtherCAT device has a 14-digit designation, made up of
▪
family key
▪
type
▪
version
▪
revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
Notes
▪
The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
▪
EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
▪
The order identifier is made up of
- family key (EL, EP, CU, ES, KL, CX, etc.)
- type (3314)
- version (-0000)
▪
The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
▪
The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Identification number
Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:
Production lot/batch number/serial number/date code/D number
The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02
Exceptions can occur in the IP67 area, where the following syntax can be used (see respective device documentation):
Syntax: D ww yy x y z u
D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB
Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1
Unique serial number/ID, ID number
In addition, in some series each individual module has its own unique serial number.
See also the further documentation in the area
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Terminals with factory calibration certificate and other measuring terminals
Examples of markings
EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
CU2016 switch with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
EP1258-00001 IP67 EtherCAT Box with batch number/ date code 22090101 and unique serial number 158102
EP1908-0002 IP67 EtherCAT Safety Box with batch number/ date code 071201FF and unique serial number 00346070
EL2904 IP20 safety terminal with batch number/ date code 50110302 and unique serial number 00331701
ELM3604-0002 terminal with unique ID number (QR code) 100001051 and serial/ batch number 44160201
Additional information
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Appendix [image] Version identification of EtherCAT devices [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com