EP7342-0002 - DC motor output stage, two-channel, 48 V, 3.5 A
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
1.0
▪
First release
Firmware and hardware versions
This documentation refers to the firmware and hardware version that was applicable at the time the documentation was written.
The module features are continuously improved and developed further. Modules having earlier production statuses cannot have the same properties as modules with the latest status. However, existing properties are retained and are not changed, so that older modules can always be replaced with new ones.
The firmware and hardware version (delivery state) can be found in the batch number (D-number) printed on the side of the EtherCAT Box.
Syntax of the batch number (D-number)
D: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with D no. 29 10 02 01:
29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01
Further information on this topic: Version identification of EtherCAT devices.


EtherCAT Box - Introduction

EtherCAT Box - Introduction
EtherCAT Box - Introduction
The EtherCAT system has been extended with EtherCAT Box modules with protection class IP 67. Through the integrated EtherCAT interface the modules can be connected directly to an EtherCAT network without an additional Coupler Box. The high-performance of EtherCAT is thus maintained into each module.
The extremely low dimensions of only 126 x 30 x 26.5 mm (h x w x d) are identical to those of the Fieldbus Box extension modules. They are thus particularly suitable for use where space is at a premium. The small mass of the EtherCAT modules facilitates applications with mobile I/O interface (e.g. on a robot arm). The EtherCAT connection is established via screened M8 connectors.
EtherCAT Box Modules within an EtherCAT network
The robust design of the EtherCAT Box modules enables them to be used directly at the machine. Control cabinets and terminal boxes are now no longer required. The modules are fully sealed and therefore ideally prepared for wet, dirty or dusty conditions.
Pre-assembled cables significantly simplify EtherCAT and signal wiring. Very few wiring errors are made, so that commissioning is optimized. In addition to pre-assembled EtherCAT, power and sensor cables, field-configurable connectors and cables are available for maximum flexibility. Depending on the application, the sensors and actuators are connected through M8 or M12 connectors.
The EtherCAT modules cover the typical range of requirements for I/O signals with protection class IP67:
▪
digital inputs with different filters (3.0 ms or 10 μs)
▪
digital outputs with 0.5 or 2 A output current
▪
analog inputs and outputs with 16 bit resolution
▪
Thermocouple and RTD inputs
▪
Stepper motor modules
XFC (eXtreme Fast Control Technology) modules, including inputs with time stamp, are also available.
EtherCAT Box with M8 connections for sensors/actuators
EtherCAT Box with M12 connections for sensors/actuators
Basic EtherCAT documentation
You will find a detailed description of the EtherCAT system in the Basic System Documentation for EtherCAT, which is available for download from our website (www.beckhoff.com) under Downloads.
EtherCAT XML Device Description
You will find XML files (XML Device Description Files) for Beckhoff EtherCAT modules on our website (www.beckhoff.com) under Downloads, in the Configuration Files area.


Product overview

Product overview
Product overview
Additional information
•
Introduction
•
Technical data
•
Scope of supply
•
Technology


Introduction

Product overview [image] Introduction
Introduction
EP7342-0002
2-channel DC motor output stage 48 VDC, 3.5 A
The EP7342 EtherCAT Box enables direct operation of two DC motors.
The speed and position are preset by a 16-bit value from the automation device. By connecting an incremental encoder (24 V DC, single-ended), it is possible to implement a simple servo axis. The output stage is protected against overload and short-circuit.
The EtherCAT Box has two channels, whose signal states are indicated by LEDs. The LEDs enable quick local diagnosis.
Quick links


Technical data

Product overview [image] Technical data
Technical data
All values are typical values over the entire temperature range, unless stated otherwise.
Technical data | EP7342-0002
Fieldbus
Fieldbus | EtherCAT
Connection | 2x M8 socket, 4-pin, green
Distributed Clocks | yes
Electrical isolation | 500 V (fieldbus / IO)
Supply voltages
Connection | Input: 1 x M8 plug, 4-pin Downstream connection: 1 x M8 socket, 4-pin Motor supply: 1x M12 socket, 4-pin
Control voltage US
Nominal voltage | 24 VDC (-15 % / +20 %)
Sum current | max. 4 A 1)
Current consumption from US | 120 mA
Peripheral voltage UP
Nominal voltage | 24 VDC (-15 % / +20 %)
Sum current | max. 4 A 1)
UP consumer | Encoder
Motor supply
Nominal voltage | 8…48 VDC
Motor outputs
Number | 2
Motor type | DC brush motor, inductive
Connection | 1x M12 common socket for both motors
Motor supply | see above under "Supply voltages“
Nominal current per output | 3.5 A, short-circuit proof
Overload protection | Thermal overload warning
Resolution | Current: max. 10 bits Speed: max. 16 bits
PWM clock frequency | 30 kHz with 180° phase shift each
PWM duty cycle | 0…100 % (voltage-controlled)
Current controller frequency | approx. 25 kHz
Encoder inputs
Number | 2
Encoder type | Incremental encoders
Connection | 1x M12 socket per encoder
Encoder supply | 24 VDC taken from the peripheral voltage UP, not short-circuit proof
signals | Single-ended
Signal voltage "0" | -3…1.5 V
Signal voltage "1" | 2.5…24 V
Pulse frequency | max. 400,000 increments per second with 4-fold evaluation
1) This value corresponds to the current carrying capacity of the connections for the supply voltages.
Technical data | EP7342-0002
Environmental conditions
Ambient temperature during operation | -25…+60 °C 0...+55 °C according to ATEX
Ambient temperature during storage | -40…+85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27; see also Additional checks.
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 conforms to EN 60529
Mechanics
Weight | approx. 165 g
Dimensions | approx. 126 x 30 x 26.5 mm (without connectors)
Installation position | variable
Approvals and conformity
Approvals | CE, ATEX
Additional checks
The boxes have been subjected to the following checks:
Verification | Explanation
Vibration | 10 frequency sweeps in 3 axes
 | 5 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 35 g, 11 ms


Scope of supply

Product overview [image] Scope of supply
Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EP7342-0002 EtherCAT Box
▪
2x protective cap for EtherCAT socket, M8, green (pre-assembled)
▪
1x protective cap for supply voltage input, M8, transparent (pre-assembled)
▪
1x protective cap for supply voltage output, M8, black (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


Technology

Product overview [image] Technology
Technology
EP7342-0002 integrates a compact Motion Control solution up to 200 W with minimum space requirement.
DC motor
DC motors can replace the considerably more expensive servo motors in many applications if they are operated with an intelligent controller. Since its speed is proportional to the voltage, the DC motor is easy to control in comparison with other motors.
Two output stages for optimum performance
With the EP7342 EtherCAT Box a DC motor can easily be integrated into the control system. All parameters are adjustable via the fieldbus. The DC motor output stages for EtherCAT unite a small, compact design with an extensive area of application. Two DC motors can be operated directly with each of the output stages. The EP7342 also has an integrated feedback system for incremental encoders.
The speed can be easily adjusted via the process data. The integrated compensation of the internal resistance keeps the motor at the desired speed for load changes. The speed is preset by a 16-bit value from the automation device. Thus a simple drive task can be solved using a simple controller.
The EtherCAT Box has two channels, whose signal states are indicated by LEDs. This enables fast local diagnosis.
Areas of application
Two areas of application are particularly well supported by the output stages:
1.
A simple controller with inexpensive processor power and low demands on the cycle time.
By using the integrated path control, the box can carry out independent positioning movements without the use of NC. Only a DC motor and the EtherCAT Box are required.
2.
High-end positioning with integration in TwinCAT NC.
In conjunction with EP7342, a DC motor is controlled under TwinCAT like a servo terminal. No further changes are necessary.
For demanding positioning tasks a closed speed control loop with a feedback system is needed. The EtherCAT Box enables connection of an incremental encoder.
The control loop can be closed either by the EtherCAT Box itself or by the higher-level control system.
Areas of application
Implementation options for control loops with EP7342-0002
The peak current may briefly significantly exceed the nominal current and in this way makes the whole drive system very dynamic. In such dynamic applications, negative acceleration causes energy recovery, which lead to voltage peaks at the power supply unit.
The EP9576-1032 brake chopper box protects against the consequences of overvoltage by absorbing part of the energy: It has an integrated brake resistor that converts surplus energy into heat.


Mounting and connection

Mounting and connection
Mounting and connection
Additional information
•
Mounting
•
Connection
•
ATEX notes


Mounting

Mounting and connection [image] Mounting
Mounting
Additional information
•
Dimensions
•
Fixing
•
Tightening torques for plug connectors


Dimensions

Mounting and connection [image] Mounting [image] Dimensions
Dimensions
Dimensions
All dimensions are given in millimeters.
Housing features
Housing material | PA6 (polyamide)
Sealing compound | polyurethane
Mounting | two fastening holes Ø 3.5 mm for M3
Metal parts | brass, nickel-plated
Contacts | CuZn, gold-plated
Power feed through | max. 4 A
Installation position | variable
Protection class | IP65, IP66, IP67 (conforms to EN 60529) when screwed together
Dimensions (H x W x D) | approx. 126 x 30 x 26.5 mm (without connectors)


Fixing

Mounting and connection [image] Mounting [image] Fixing
Fixing
Note
Dirt during assembly
Dirty connectors can lead to malfunctions. Protection class IP67 can only be guaranteed if all cables and connectors are connected.
•
Protect the plug connectors against dirt during the assembly.
Mount the module with two M3 screws on the fastening holes in the corners of the module. The fastening holes have no thread.


Tightening torques for plug connectors

Mounting and connection [image] Mounting [image] Tightening torques for plug connectors
Tightening torques for plug connectors
Screw connectors tight with a torque wrench. (e.g. ZB8801 from Beckhoff)
Connector diameter | Tightening torque
M8 | 0.4 Nm
M12 | 0.6 Nm


Connection

Mounting and connection [image] Connection
Connection
Additional information
•
EtherCAT
•
Supply voltages
•
Signal connection


EtherCAT

Mounting and connection [image] Connection [image] EtherCAT
EtherCAT
Additional information
•
Connectors
•
Status LEDs
•
Cables


Connectors

Mounting and connection [image] Connection [image] EtherCAT [image] Connectors
Connectors
Note
Risk of confusion: supply voltages and EtherCAT
Defect possible through incorrect insertion.
•
Observe the color coding of the connectors:
black: Supply voltages
green: EtherCAT
EtherCAT Box Modules have two green M8 sockets for the incoming and downstream EtherCAT connections.
EtherCAT connectors
Connection
M8 socket, 4-pin – connection
M8 socket
EtherCAT | M8 connector | Core colors
Signal | Contact | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 and old versions of ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | 1 | yellow1) | orange/white | white/orange
Tx - | 4 | orange1) | orange | orange
Rx + | 2 | white1) | blue/white | white/green
Rx - | 3 | blue1) | blue | green
Shield | Housing | Shield | Shield | Shield
1) Core colors according to EN 61918
Adaptation of core colors for cables ZB9030, ZB9032 and ZK1090-3xxxx-xxxx
For standardization, the core colors of the ZB9030, ZB9032 and ZK1090-3xxx-xxxx cables have been changed to the EN61918 core colors: yellow, orange, white, blue. So there are different color codes in circulation. The electrical properties of the cables have been retained when the core colors were changed.


Status LEDs

Mounting and connection [image] Connection [image] EtherCAT [image] Status LEDs
Status LEDs
EtherCAT status LEDs
L/A (Link/Act)
A green LED labelled "L/A" is located next to each EtherCAT socket. The LED indicates the communication state of the respective socket:
LED | Meaning
off | no connection to the connected EtherCAT device
lit | LINK: connection to the connected EtherCAT device
flashes | ACT: communication with the connected EtherCAT device
Run
Each EtherCAT slave has a green LED labelled "Run". The LED signals the status of the slave in the EtherCAT network:
LED | Meaning
off | Slave is in "Init" state
flashes uniformly | Slave is in "Pre-Operational“ state
flashes sporadically | Slave is in "Safe-Operational" state
lit | Slave is in "Operational" state
Description of the EtherCAT slave states


Cables

Mounting and connection [image] Connection [image] EtherCAT [image] Cables
Cables
For connecting EtherCAT devices only shielded Ethernet cables that meet the requirements of at least category 5 (CAT5) according to EN 50173 or ISO/IEC 11801 should be used.
EtherCAT uses four wires for signal transmission.
Thanks to automatic line detection ("Auto MDI-X"), both symmetrical (1:1) or cross-over cables can be used between Beckhoff EtherCAT.
Detailed recommendations for the cabling of EtherCAT devices


Supply voltages

Mounting and connection [image] Connection [image] Supply voltages
Supply voltages
The EtherCAT Box is supplied with two supply voltages. The ground potentials of the supply voltages are galvanically connected together.
▪
Control voltage US
▪
Peripheral voltage UP
The motor supply must be provided separately.
See chapter Signal connection.
Redirection of the supply voltages
The IN and OUT power connections are bridged in the module (not IP204x-Bxxx and IE204x). The supply voltages US and UP can thus easily be transferred from EtherCAT Box to EtherCAT Box.
Note
Pay attention to the maximum permissible current!
Pay attention also for the redirection of the supply voltages US and UP, the maximum permissible current for M8 connectors of 4 A must not be exceeded!
Additional information
•
Connectors
•
Status LEDs
•
Conductor losses


Connectors

Mounting and connection [image] Connection [image] Supply voltages [image] Connectors
Connectors
Note
Risk of confusion: supply voltages and EtherCAT
Defect possible through incorrect insertion.
•
Observe the color coding of the connectors:
black: Supply voltages
green: EtherCAT
Connectors for supply voltages
M8 connector
Contact | Function | Description | Core color 1)
1 | US | Control voltage | Brown
2 | UP | Peripheral voltage | White
3 | GNDS | GND to US | Blue
4 | GNDP | GND to UP | Black
1) The core colors apply to cables of the type: Beckhoff ZK2020-3xxx-xxxx


Status LEDs

Mounting and connection [image] Connection [image] Supply voltages [image] Status LEDs
Status LEDs
Connectors + LEDs
Status LEDs for the supply voltages
LED | Display | Meaning
US (control voltage) | off | Supply voltage US is not present
 | green illuminated | Supply voltage US is present
UP (peripheral voltage) | off | Supply voltage UP is not present
 | green illuminated | Supply voltage UP is present


Conductor losses

Mounting and connection [image] Connection [image] Supply voltages [image] Conductor losses
Conductor losses
Take into account the voltage drop on the supply line when planning a system. Avoid the voltage drop being so high that the supply voltage at the box lies below the minimum nominal voltage.
Variations in the voltage of the power supply unit must also be taken into account.
Voltage drop on the supply line
Leitungsverluste M8 2A
Leitungsverluste M8 4A


Signal connection

Mounting and connection [image] Connection [image] Signal connection
Signal connection
Signal connection EP7342-0002
Note
Note the numbering of the M12 sockets
Mixing up the M12 connectors can damage the module.
M12 socket no. 1: DC motor connection
Motor-Anschluss, zugeschnitten
Pin 1: Motor channel 1, connection 1
Pin 2: Motor channel 1, connection 2
Pin 3: Motor channel 2, connection 1
Pin 4: Motor channel 2, connection 2
Pin 5: not connected
M12 socket no. 2: Connection for motor supply
Zwischenkreis-Anschluss, zugeschnitten
Pin 1: Motor supply 8...48 VDC
Pin 2: Motor supply 8...48 VDC
Pin 3: GND
Pin 4: GND
Pin 5: not connected
M12 sockets no. 3 and no. 4: Encoder connection
Note
The encoder supply is not short-circuit proof
Risk of defect.
•
Avoid short-circuiting the encoder supply.
Encoder-Anschluss, zugeschnitten
Pin 1: GND
Pin 2: Encoder supply 24 VDC
Pin 3: Track A
Pin 4: Track B
Pin 5: Track C (Gate/Latch)


ATEX notes

Mounting and connection [image] ATEX notes
ATEX notes
Additional information
•
ATEX - Special conditions
•
BG2000 - EtherCAT Box protection enclosures
•
ATEX Documentation


ATEX - Special conditions

Mounting and connection [image] ATEX notes [image] ATEX - Special conditions
ATEX - Special conditions
SmallWarningYellow WARNING
Observe the special conditions for the intended use of EtherCAT Box modules in potentially explosive areas – directive 94/9/EU.
•
The certified components are to be installed with a BG2000-0000 or BG2000-0010 protection enclosure that guarantees a protection against mechanical hazards!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of 0 to 55°C for the use of EtherCAT Box modules in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0: 2006
▪
EN 60079-15: 2005
Marking
The EtherCAT Box modules certified for potentially explosive areas bear the following marking:
II 3 G Ex nA II T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
or
II 3 G Ex nA nC IIC T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
Batch number (D number)
The EtherCAT Box modules bear a batch number (D number) that is structured as follows:
D: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with batch number 29 10 02 01:
29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01


BG2000 - EtherCAT Box protection enclosures

Mounting and connection [image] ATEX notes [image] BG2000 - EtherCAT Box protection enclosures
BG2000 - EtherCAT Box protection enclosures
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the EtherCAT system into a safe, powered down state before starting installation, disassembly or wiring of the modules!
ATEX
SmallWarningYellow WARNING
Mount a protection enclosure!
To fulfill the special conditions according to ATEX, a BG2000-0000 or BG2000-0010 protection enclosure has to be mounted over the EtherCAT Box.
Installation
Put the cables for EtherCAT, power supply and sensors/actuators through the hole of the protection enclosure.
BG2000 - putting the cables
Fix the wires for EtherCAT, power supply and sensors/actuators to the EtherCAT Box.
BG2000 - fixing the cables
Mount the protection enclosure over the EtherCAT Box.
BG2000 - mounting the protection enclosure


ATEX Documentation

Mounting and connection [image] ATEX notes [image] ATEX Documentation
ATEX Documentation
Notes about operation of EtherCAT Box Modules (EPxxxx-xxxx) in potentially explosive areas (ATEX)
Pay also attention to the continuative documentationNotes about operation of EtherCAT Box Modules (EPxxxx-xxxx) in potentially explosive areas (ATEX) that is available in the download area of the Beckhoff homepage http:\\www.beckhoff.com!


Commissioning/Configuration

Commissioning/Configuration
Commissioning/Configuration
Additional information
•
Integration in TwinCAT
•
Integration into the NC configuration (manually)
•
Settings in the CoE register
•
NC settings
•
Commissioning the motor with the NC
•
Operating modes
•
Restoring the delivery state
•
Decommissioning


Integration in TwinCAT

Commissioning/Configuration [image] Integration in TwinCAT
Integration in TwinCAT
The procedure for integration in TwinCAT is described in this Quick start guide.


Integration into the NC configuration (manually)

Commissioning/Configuration [image] Integration into the NC configuration (manually)
Integration into the NC configuration (manually)
(TwinCAT 3.1)
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
➢
Requirement: EP7342 is integrated in a TwinCAT project.
1.
Add a new NC task: Right-click on "MOTION" and select "Add New Item..."
Add new Item
2.
Right click on "Axes" and click on "Add New Item…“
Axes - Add new Item
⇨
A dialog box appears:
Axes - Add new Item -- Dialogfenster
3.
In the "Type" field select "Continuous axis" and confirm with OK.
4.
Double-click the new axis.
5.
Click on the "Settings" tab
6.
Click on "Link To I/O..."
Axes - Axes 1 -- Link to IO
⇨
A dialog box appears:
Motion - Axes - Axes 1 -- Link to IO -- Dialogfenster
7.
Select the appropriate entry and click "OK".
Note: EP7342 has two motor channels. The assignment of the connector pins to the motor channels can be found in chapter Signal connection.
⇨
The process data are linked to the NC task.
You need to set some parameters before you can start the motor. You will find these parameters in the following chapters:
▪
Settings in the CoE register
▪
NC settings


Settings in the CoE register

Commissioning/Configuration [image] Settings in the CoE register
Settings in the CoE register
The data given here exemplary for a DC motor type GR42X25 from the company Dunkermotoren. For other motors the values may vary, depending on the application.
Additional information
•
Adaptation of current and voltage
•
Adaptation of the encoder data
•
Adaptation of the maximal velocity
•
Selection of the operating mode
•
Select info data
•
KA factor


Adaptation of current and voltage

Commissioning/Configuration [image] Settings in the CoE register [image] Adaptation of current and voltage
Adaptation of current and voltage
Note
The motor may overheat!
In order to prevent overheating of the connected motor it is important to adapt the current and voltage output from the stepper interface to the motor.
Index 0x8020:02 "Nominal current" and index 0x8020:03 "Nominal voltage" have be set appropriately in the CoE register. In addition, you should also adapt the "Maximal current" in the index 0x8020:01 and the coil resistance of the motor in the index 0x8020:04 "Motor coil resistance" to the connected motor.
Reducedcurrent can be set in index 0x8020:05 and 0x8020:06. This reduces the coil current when at a standstill (and therefore the power dissipation). Please note that this reduces the torque.
8020:02 Nominal current, 8020:03 Nominal voltage
Adaptation of current and voltage


Adaptation of the encoder data

Commissioning/Configuration [image] Settings in the CoE register [image] Adaptation of the encoder data
Adaptation of the encoder data
Different encoders are available with a different number of increments. You must specify the number of increments of your encoder in the index 0x8020:07 "Encoder increments" (see fig. Adaptation of the encoder data). In our example an encoder with 1024 increments is used, corresponding to 4096 increments in the case of quadruple evaluation. The number of increments of your encoder can be found in the data sheet for the encoder.
8020:07 Encoder increments
Adaptation of the encoder data


Adaptation of the maximal velocity

Commissioning/Configuration [image] Settings in the CoE register [image] Adaptation of the maximal velocity
Adaptation of the maximal velocity
The maximum velocity with which your DC motor can move must be entered in index 0x8020:08 "Maximum motor velocity". You can take this parameter from the name plate on the motor and write it 1:1 into the index. In the example the motor has a maximum velocity of 3600 revolutions per minute.
8020:08 Maximal motor velocity
Adaptation of the maximal velocity


Selection of the operating mode

Commissioning/Configuration [image] Settings in the CoE register [image] Selection of the operating mode
Selection of the operating mode
You can select the operating mode in the index 0x8022:01 "Operation mode". It is recommended that you select the operation mode "Automatic" (Fig. Setting the operation mode) and then set the suitable operation mode for your application on the Process Data tab. Further information on this can be found in the chapter "Process Data".
8022:01 Operation mode
Setting the operation mode
8022-01 Operation mode - Dialogfenster
Dialog box


Select info data

Commissioning/Configuration [image] Settings in the CoE register [image] Select info data
Select info data
There is a possibility in the index 0x8022:11 "Select info data 1" and 0x8022:19 "Select info data 2", to select two parameters that can be displayed in the process data (see fig. Selection of additional information data).
These two parameters must be activated in the process data afterwards.
8022:11 Select info data 1, 8022:19 Select info data 2
Selection of additional information data
8022-11 Select info data 1 - Dialogfenster
Dialog box


KA factor

Commissioning/Configuration [image] Settings in the CoE register [image] KA factor
KA factor
The KA factor can be used to adapt the current during the acceleration phases. The current increase is calculated as follows.
Current increase in mA = velocity difference x KA / 1000
The steeper the velocity ramp, the higher the current increase.
Velocity ramps
This value can be set in index 0x8023:07 "Ka factor (velo./pos.)" (see Fig. Setting the KA factor).
8023:07 Ka factor (velo./pos.)
Setting the KA factor


NC settings

Commissioning/Configuration [image] NC settings
NC settings
The specified data apply to a DC Motor GR42X25 of the Company "Dunker Motoren" and are intended as an example. For other motors the values may vary, depending on the application.
Additional information
•
Reference velocity selection
•
Dead time compensation
•
Scaling factor
•
Position lag monitoring
•
KV factors


Reference velocity selection

Commissioning/Configuration [image] NC settings [image] Reference velocity selection
Reference velocity selection
The maximum velocity is calculated based on the maximum motor speed (see name plate) and the distance to be covered. In this case the basis is one revolution per second.
vmax = (maximum motor velocity x 360°) / 60s
= ((3600 rpm) x 360°) / 60s
= 21600 revolutions / s
This is a theoretical value that is quite close to the practical value, although the value may vary, depending on the load. To determine the actual value set the Kv factor to 0 and determine the final reference velocity empirically. To this end move the motor using the keys F1 - F4 and compare the actual velocity and the setpoint velocity. These values should be almost identical. If the actual velocity is greater, increase the reference velocity slightly. If the Actual velocity is smaller than the Setpoint velocity, reduce the reference velocity slightly. This empirical exercise should only be carried out once the other parameters have been set.
In our case the reference velocity is 25570 revolutions / s. Finally, adjust the maximum allowed velocity.
Axis 1 - Parameter - Reference Velocity
Reference velocity selection


Dead time compensation

Commissioning/Configuration [image] NC settings [image] Dead time compensation
Dead time compensation
Dead time compensation
The dead time compensation of the axis can be set in the Time Compensation tab of the Axis1_ENC encoder settings. It should, in theory, be 3 cycles of the NC cycle time, although in practice 4 cycles were found to be preferable. The parameter Time Compensation Mode Encoder should be set to 'ON (with velocity)', the parameter Encoder Delay in Cycles to 4.
Axis 1 - Enc - Time Compensation
Dead time compensation parameter


Scaling factor

Commissioning/Configuration [image] NC settings [image] Scaling factor
Scaling factor
The scaling factor can be changed by selecting "Axis 1_Enc" and tab "Parameter" in the NC (see fig. Setting the Scaling Factor). The value can be calculated with the formulas specified below.
Axis 1 - Enc - Parameter - Encoder Evaluation
Setting the Scaling Factor
Calculation of the scaling factor
SF = distance per revolution / (increments x 4) = 360° / (1024 x 4) = 0.087890625 ° / INC


Position lag monitoring

Commissioning/Configuration [image] NC settings [image] Position lag monitoring
Position lag monitoring
The position lag monitoring function checks whether the current position lag of an axis has exceeded the limit value. The position lag is the difference between the setpoint (control value) and the actual value reported back. Suboptimal parameter settings can lead to an error in position lag monitoring during the axis movement. During commissioning it may therefore be advisable to increase the "Maximum Position Lag Value" slightly.
Note
CAUTION: Damage to equipment, machines and peripheral components possible!
Setting the position lag monitoring parameters too high may result in damage to equipment, machines and peripheral components.
Axis 1 - Ctrl - Parameter - Monitoring
Position lag monitoring


KV factors

Commissioning/Configuration [image] NC settings [image] KV factors
KV factors
In the NC two proportional factors Kv can be set under "Axis 1_Ctrl " in tab "Parameter". First select the position controller Type with two P constants (with KA) under the "NC Controller" tab. The two P constants are for the Standstill range and for the Moving range (see Fig. Setting the proportional factor KV). The factors can be used to set the start-up torque and the braking torque to a different value than the drive torque. The threshold value can be set directly below (Position control: Velocity threshold V dyn) between 0.0 (0%) and 1.0 (100%). Fig. Velocity ramp with KV factor limit values shows a speed ramp with thresholds of 50%. The Kv factor for Standstill (t1 and t3) can be different than the Kv factor for Moving (t2). The factor at standstill should always be greater than the factor during motion.
Velocity ramp with KV factor limit values
Axis 1 - Ctrl - Parameter - Position Control Loop
Setting the proportional factor Kv


Commissioning the motor with the NC

Commissioning/Configuration [image] Commissioning the motor with the NC
Commissioning the motor with the NC
Enabling an axis
▪
Once the parameters are set, the motor is basically ready for operation. Individual further parameters have to be adapted to the respective application.
▪
To commission the axis, activate the configuration (Ctrl+Shift+F4), select the axis, select tab Online and enable the axis under Set.
▪
Set all tick marks and set Override to 100% (see Fig. Enabling an axis). The axis can then be moved.
Axis 1 - Online: Achse freigeben
Enabling an axis
Move axis manually
You can now move the axis with the function keys F1, F2 (Backward) or F3, F4 (Forward).
You can adjust the Kv factor in order to approach a suitable factor. Set the value to 0 initially in order to set the correct reference velocity. For calculating the reference velocity please refer to section "Selecting the reference velocity". The calculation provides a relatively precise value, although the value may have to be corrected slightly. To this end move the motor with a Kv factor of 0 until the actual velocity matches the setpoint velocity.
Move axis automatically
Alternatively you can control the axis via the "Functions" tab. An example is provided below.
▪
Select as Reversing Sequence as the start type.
▪
Enter the required Target Position1, e.g. 5000°.
▪
Enter the required Target Velocity, e.g. 2000°/s.
▪
Enter the required Target Position2, e.g. 0°.
▪
Enter the required Idle Time, e.g. 1 s.
▪
Select Start.
Axis 1 - Functions
The motor now turns to position 1, remains there for 1 s and returns to position 2. This is repeated until Stop is pressed.


Operating modes

Commissioning/Configuration [image] Operating modes
Operating modes
Additional information
•
Overview
•
Chopper operation
•
Positioning Interface


Overview

Commissioning/Configuration [image] Operating modes [image] Overview
Overview
The operating modes Automatic, Velocity direct, Position controller, Path control and Brake resistor are supported.
Automatic
In preparation!
Velocity, direct
This mode is intended for the cyclic velocity interface of a numeric controller (NC). In this mode, the NC specifies a set velocity. Ramps for start-up and deceleration of the motor are also controlled by the NC.
Position controller
Refer to the Positioning Interface section for information about this operation mode!
Travel distance control
In preparation!
Brake resistor
Refer to the Chopper operation section for information about this operation mode


Chopper operation

Commissioning/Configuration [image] Operating modes [image] Chopper operation
Chopper operation
You can connect a brake resistor (chopper) to one of the two motor channels instead of a DC motor and enable "Chopper resistor" mode for this channel.
The motor must actively brake for positioning tasks. The mechanical energy is thereby converted back into electrical energy. Small amounts of energy are absorbed by a capacitor in EP7342. Further storage capacities, for example in the power supply unit, can also take up energy. The feedback leads in each case to a voltage increase.
In order to avoid overvoltage, a brake resistor can be connected to the EP7342 in order to dissipate the surplus energy in the form of heat. When the voltage reaches 110% of the nominal voltage, e.g. 55 V, the correctly set output stage sends a fast-pulsed current through the brake resistor (see diagram).
ICH/IN. - UCH/UN characteristic curve
Note
Dimensioning of the brake resistor
The brake resistor should be dimensioned such that it can withstand the expected heat development without damage.
A brake resistor of 10 Ω is recommended, which results in a pulse current of approx. 5.5 A to 6.5 A. The maximum expected continuous power is 125 W. However, the value typically lies significantly below that.
Power estimation
PN = IN² x R
PN = (5A)² x 10 Ω
PN = 250 W
A maximum duty cycle of 50 % is possible. This results in a maximum continuous power of 125 W.
A motor efficiency of 80 % is usual in practice.
The motor thus converts 80 % of the rated electrical power into kinetic energy when accelerating.
Conversely, when braking, the motor (as a generator) converts 80 % of the kinetic energy into electrical power.
This results in a practical braking power of:
PCH = PN/2 x 80/100 x 80/100
PCH = 125W x 80/100 x 80/100
PCH = 80 W


Positioning Interface

Commissioning/Configuration [image] Operating modes [image] Positioning Interface
Positioning Interface
The "Positioning Interface" offers the option to execute motion commands directly on the box.
Note
Commissioning
Commissioning of the EL7342 "Positioning Interface" can be transferred to EP7342-0002.
The commissioning procedure is described in the chapter on "Basic principles for the Positioning Interface" of the EL7342 documentation.


Restoring the delivery state

Commissioning/Configuration [image] Restoring the delivery state
Restoring the delivery state
To restore the delivery state for backup objects in ELxxxx terminals / EPxxxx- and EPPxxxx boxes, the CoE object Restore default parameters, SubIndex 001 can be selected in the TwinCAT System Manager (Config mode).
Selecting the Restore default parameters PDO
Double-click on SubIndex 001 to enter the Set Value dialog. Enter the value 1684107116 in field Dec or the value 0x64616F6C in field Hex and confirm with OK.
All backup objects are reset to the delivery state.
Entering a restore value in the Set Value dialog
Alternative restore value
In some older terminals / boxes the backup objects can be switched with an alternative restore value:
Decimal value: 1819238756
Hexadecimal value: 0x6C6F6164
An incorrect entry for the restore value has no effect.


Decommissioning

Commissioning/Configuration [image] Decommissioning
Decommissioning
SmallWarningYellow WARNING
Risk of electric shock!
Bring the bus system into a safe, de-energized state before starting disassembly of the devices!
Disposal
In order to dispose of the device, it must be removed.
In accordance with the WEEE Directive 2012/19/EU, Beckhoff takes back old devices and accessories in Germany for proper disposal. Transport costs will be borne by the sender.
Return the old devices with the note "for disposal" to:
Beckhoff Automation GmbH & Co. KG
Service Department
Stahlstraße 31
D-33415 Verl


CoE parameters

CoE parameters
CoE parameters
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Parameterization via the CoE list (CAN over EtherCAT)
The EtherCAT device is parameterized via the CoE-Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs). Please note the following general CoE notes when using/manipulating the CoE parameters:
•
Keep a startup list if components have to be replaced
•
Differentiation between online/offline dictionary, existence of current XML description
•
use “CoE reload” for resetting changes
Introduction
The CoE overview contains objects for different intended applications:
▪
Objects required for parameterization during commissioning:
–
Restore object
–
Configuration data
–
Command object
▪
Profile-specific objects:
–
Input data
–
Output data
–
Information and diagnosis data (channel specific)
–
Configuration data (vendor-specific)
–
Information and diagnosis data (device-specific)
▪
Standard objects
The following section first describes the objects required for normal operation, followed by a complete overview of missing objects.
Additional information
•
Restore object
•
Configuration data
•
Command object
•
Input data
•
Output data
•
Information and diagnosis data (channel specific)
•
Configuration data (vendor-specific)
•
Information and diagnosis data (device-specific)
•
Standard objects


Restore object

CoE parameters [image] Restore object
Restore object
Index 1011 Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default parameters | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to “0x64616F6C” in the set value dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)


Configuration data

CoE parameters [image] Configuration data
Configuration data
Index 8000 ENC Settings Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
8000:0 | ENC Settings Ch.1 | Max. Subindex | UINT8 | RO | 0x0E (14dec)
8000:08 | Disable filter | 0: Activates the input filter (inputs A, /A, B, /B, C, /C only) 1: Deactivates the input filter If a filter is activated a signal edge must be present for at least 2.4 µs in order to be counted as an increment. | BOOLEAN | RW | 0x00 (0dec)
8000:0A | Enable micro increments | If activated, the terminal interpolates micro-increments between the integral encoder increments in DC mode. The lower 8 bits of the counter value are used in each case for the display. A 32-bit counter thus becomes a 24+8-bit counter, a 16-bit counter becomes a 8+8-bit counter. | BOOLEAN | RW | 0x00 (0dec)
8000:0E | Reversion of rotation | Activates reversion of rotation | BOOLEAN | RW | 0x00 (0dec)
Index 8010 ENC Settings Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
8010:0 | ENC Settings Ch.2 | Max. Subindex | UINT8 | RO | 0x0E (14dec)
8010:08 | Disable filter | 0: Activates the input filter (inputs A, /A, B, /B, C, /C only) 1: Deactivates the input filter If a filter is activated a signal edge must be present for at least 2.4 µs in order to be counted as an increment. | BOOLEAN | RW | 0x00 (0dec)
8010:0A | Enable micro increments | If activated, the terminal interpolates micro-increments between the integral encoder increments in DC mode. The lower 8 bits of the counter value are used in each case for the display. A 32-bit counter thus becomes a 24+8-bit counter, a 16-bit counter becomes a 8+8-bit counter. | BOOLEAN | RW | 0x00 (0dec)
8010:0E | Reversion of rotation | Activates reversion of rotation | BOOLEAN | RW | 0x00 (0dec)
Index 8020 DCM Motor Settings Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
8020:0 | DCM Motor Settings Ch.1 | Max. Subindex | UINT8 | RO | 0x0F (15dec)
8020:01 | Maximal current | Maximum permanent motor coil current (unit: 1 mA) | UINT16 | RW | 0x1388 (5000dec)
8020:02 | Nominal current | Motor nominal current (unit: 1 mA) | UINT16 | RW | 0x0DAC (3500dec)
8020:03 | Nominal voltage | Nominal voltage (supply voltage) of the motor (unit: 1 mV) | UINT16 | RW | 0xC350 (50000dec)
8020:04 | Motor coil resistance | Internal resistance of the motor (unit: 0.01 ohm) | UINT16 | RW | 0x0064 (100dec)
8020:05 | Reduced current (positive) | Reduced torque in positive direction of rotation (unit: 1 mA) | UINT16 | RW | 0x07D0 (2000dec)
8020:06 | Reduced current (negative) | Reduced torque in negative direction of rotation (unit: 1 mA) | UINT16 | RW | 0x07D0 (2000dec)
8020:07 | Encoder increments (4-fold) | Number of encoder increments per revolution with quadruple evaluation | UINT16 | RW | 0x0000 (0dec)
8020:08 | Maximal motor velocity | Nominal speed of the motor at the nominal voltage (unit: 1 rpm) | UINT16 | RW | 0x0000 (0dec)
8020:0C | Time for switch-off at overload | Time for switch-off at overload (unit: 1 ms) | UINT16 | RW | 0x00C8 (200dec)
8020:0D | Time for current lowering at overload | Time for current lowering at overload (from max. current to nominal current, unit: 1 ms) | UINT16 | RW | 0x07D0 (2000dec)
8020:0E | Torque auto-reduction threshold (positive) | Process data threshold for automatic torque reduction in the positive direction of rotation (unit: 1 %) | UINT8 | RW | 0x00 (0dec)
8020:0F | Torque auto-reduction threshold (negative) | Process data threshold for automatic torque reduction in the negative direction of rotation (unit: 1 %) | UINT8 | RW | 0x00 (0dec)
Index 8021 DCM Controller Settings Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
8021:0 | DCM Controller Settings Ch.1 | Max. Subindex | UINT8 | RO | 0x12 (18dec)
8021:01 | Kp factor (curr.) | Kp control factor of the current controller | UINT16 | RW | 0x00C8 (200dec)
8021:02 | Ki factor (curr.) | Ki control factor of the current controller | UINT16 | RW | 0x0002 (2dec)
8021:03 | Inner window (curr.) | Inner window for the I component (unit: 1%) | UINT8 | RW | 0x00 (0dec)
8021:05 | Outer window (curr.) | Outer window for the I component (unit: 1%) | UINT8 | RW | 0x00 (0dec)
8021:06 | Filter cut off frequency (curr.) | Limit frequency of the current controller (unit: 1 Hz) | UINT16 | RW | 0x0000 (0dec)
8021:11 | Voltage adjustment enable | Activates the compensation of voltage fluctuations (only in the operating mode "Direct velocity") | BOOLEAN | RW | 0x00 (0dec)
8021:12 | Current adjustment enable | Activates the R x I compensation | BOOLEAN | RW | 0x00 (0dec)
Index 8022 DCM Features Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
8022:0 | DCM Features Ch.1 | Max. Subindex | UINT8 | RO | 0x36 (54dec)
8022:01 | Operation mode | Operation mode 0: Automatic 1: Velocity direct 2: Velocity controller 3: Position controller ...: reserved 15: Chopper resistor Existing overvoltage (10% > nominal voltage 0x8020:03) is reduced via connected chopper resistor. | BIT4 | RW | 0x00 (0dec)
8022:09 | Invert motor polarity | Inverts the direction of rotation of the motor | BOOLEAN | RW | 0x00 (0dec)
8022:0A | Torque error enable | Activates the automatic overload cut-off (see also subindex 0x8020:0C) | BOOLEAN | RW | 0x00 (0dec)
8022:0B | Torque auto reduce | Activates the automatic torque reduction (see also subindex 0x8020:0D – 0x8020:0F) | BOOLEAN | RW | 0x00 (0dec)
8022:11 | Select info data 1 | Selection "Info data 1" 0: Status word 1: Motor coil voltage 2: Motor coil current 3: Current limit 4: Control error 5: Duty cycle ....: reserved 7: Motor velocity 8: Overload time ...: reserved 101: Internal temperature ...: reserved 103: Control voltage 104: Motor supply voltage ...: reserved 150: Status word (drive controller) 151: State (drive controller) ...: reserved | UINT8 | RW | 0x01 (1dec)
8022:19 | Select info data 2 | Selection "Info data 2" see subindex 0x8022:11 | UINT8 | RW | 0x02 (2dec)
8022:30 | Invert digital input 1 | Inversion of digital input 1 | BOOLEAN | RW | 0x00 (0dec)
8022:31 | Invert digital input 2 | Inversion of digital input 2 | BOOLEAN | RW | 0x00 (0dec)
8022:32 | Function for input 1 | Function of digital input 1 0: Normal input 1: Hardware enable …: reserved | BIT4 | RW | 0x00 (0dec)
8022:36 | Function for input 2 | Function of digital input 2 see subindex 0x8022:32 | BIT4 | RW | 0x00 (0dec)
Index 8023 DCM Controller Settings 2 Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
8023:0 | DCM Controller Settings 2 Ch.1 | Max. Subindex | UINT8 | RO | 0x08 (8dec)
8023:01 | Kp factor (velo./pos.) | Kp control factor of the velocity/position controller | UINT16 | RW | 0x00C8 (200dec)
8023:02 | Ki factor (velo./pos.) | Ki control factor of the velocity/position controller | UINT16 | RW | 0x0002 (2dec)
8023:03 | Inner window (velo./pos.) | Inner window for the I component (unit: 1%) | UINT8 | RW | 0x00 (0dec)
8023:05 | Outer window (velo./pos.) | Outer window for the I component (unit: 1%) | UINT8 | RW | 0x00 (0dec)
8023:06 | Filter cut off frequency (velo./pos.) | Limit frequency of the velocity/position controller (unit: 1 Hz) | UINT16 | RW | 0x0000 (0dec)
8023:07 | Ka factor (velo./pos.) | Ka control factor of the velocity/position controller | UINT16 | RW | 0x0000 (0dec)
8023:08 | Kd factor (velo./pos.) | Kd control factor of the velocity/position controller | UINT16 | RW | 0x0014 (20dec)
Index 8030 DCM Motor Settings Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
8030:0 | DCM Motor Settings Ch.2 | Max. Subindex | UINT8 | RO | 0x0F (15dec)
8030:01 | Maximal current | Maximum permanent motor coil current (unit: 1 mA) | UINT16 | RW | 0x1388 (5000dec)
8030:02 | Nominal current | Motor nominal current (unit: 1 mA) | UINT16 | RW | 0x0DAC (3500dec)
8030:03 | Nominal voltage | Nominal voltage (supply voltage) of the motor (unit: 1 mV) | UINT16 | RW | 0xC350 (50000dec)
8030:04 | Motor coil resistance | Internal resistance of the motor (unit: 0.01 ohm) | UINT16 | RW | 0x0064 (100dec)
8030:05 | Reduced current (positive) | Reduced torque in positive direction of rotation (unit: 1 mA) | UINT16 | RW | 0x07D0 (2000dec)
8030:06 | Reduced current (negative) | Reduced torque in negative direction of rotation (unit: 1 mA) | UINT16 | RW | 0x07D0 (2000dec)
8030:07 | Encoder increments (4-fold) | Number of encoder increments per revolution with quadruple evaluation | UINT16 | RW | 0x0000 (0dec)
8030:08 | Maximal motor velocity | Rated motor velocity at nominal voltage (unit: 1 rpm) | UINT16 | RW | 0x0000 (0dec)
8030:0C | Time for switch-off at overload | Time for switch-off at overload (unit: 1 ms) | UINT16 | RW | 0x00C8 (200dec)
8030:0D | Time for current lowering at overload | Time for current lowering at overload (from max. current to nominal current, unit: 1 ms) | UINT16 | RW | 0x07D0 (2000dec)
8030:0E | Torque auto-reduction threshold (positive) | Process data threshold for automatic torque reduction in the positive direction of rotation (unit: 1 %) | UINT8 | RW | 0x00 (0dec)
8030:0F | Torque auto-reduction threshold (negative) | Process data threshold for automatic torque reduction in the negative direction of rotation (unit: 1 %) | UINT8 | RW | 0x00 (0dec)
Index 8031 DCM Controller Settings Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
8031:0 | DCM Controller Settings Ch.2 | Max. Subindex | UINT8 | RO | 0x12 (18dec)
8031:01 | Kp factor (curr.) | Kp control factor of the current controller | UINT16 | RW | 0x00C8 (200dec)
8031:02 | Ki factor (curr.) | Ki control factor of the current controller | UINT16 | RW | 0x0002 (2dec)
8031:03 | Inner window (curr.) | Inner window for the I component (unit: 1%) | UINT8 | RW | 0x00 (0dec)
8031:05 | Outer window (curr.) | Outer window for the I component (unit: 1%) | UINT8 | RW | 0x00 (0dec)
8031:06 | Filter cut off frequency (curr.) | Limit frequency of the current controller (unit: 1 Hz) | UINT16 | RW | 0x0000 (0dec)
8031:11 | Voltage adjustment enable | Activates the compensation of voltage fluctuations (only in the operating mode "Direct velocity") | BOOLEAN | RW | 0x00 (0dec)
8031:12 | Current adjustment enable | Activates the R x I compensation | BOOLEAN | RW | 0x00 (0dec)
Index 8032 DCM Features Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
8032:0 | DCM Features Ch.2 | Max. Subindex | UINT8 | RO | 0x36 (54dec)
8032:01 | Operation mode | Operation mode 0: Automatic 1: Velocity direct 2: Velocity controller 3: Position controller ...: reserved 15: Chopper resistor Existing overvoltage (10% > nominal voltage 0x8030:03) is reduced via connected chopper resistor. | BIT4 | RW | 0x00 (0dec)
8032:09 | Invert motor polarity | Inverts the direction of rotation of the motor | BOOLEAN | RW | 0x00 (0dec)
8032:0A | Torque error enable | Activates the automatic overload cut-off (see also subindex 0x8030:0C) | BOOLEAN | RW | 0x00 (0dec)
8032:0B | Torque auto reduce | Activates the automatic torque reduction (see also subindex 0x8030:0D – 0x8030:0F) | BOOLEAN | RW | 0x00 (0dec)
8032:11 | Select info data 1 | Selection "Info data 1" 0: Status word 1: Motor coil voltage 2: Motor coil current 3: Current limit 4: Control error 5: Duty cycle ....: reserved 7: Motor velocity 8: Overload time ...: reserved 101: Internal temperature ...: reserved 103: Control voltage 104: Motor supply voltage ...: reserved 150: Status word (drive controller) 151: State (drive controller) ...: reserved | UINT8 | RW | 0x01 (1dec)
8032:19 | Select info data 2 | Selection "Info data 2" see subindex 0x8032:11 | UINT8 | RW | 0x02 (2dec)
8032:30 | Invert digital input 1 | Inversion of digital input 1 | BOOLEAN | RW | 0x00 (0dec)
8032:31 | Invert digital input 2 | Inversion of digital input 2 | BOOLEAN | RW | 0x00 (0dec)
8032:32 | Function for input 1 | Function of digital input 1 0: Normal input 1: Hardware enable ...: reserved | BIT4 | RW | 0x00 (0dec)
8032:36 | Function for input 2 | Function of digital input 2 see subindex 0x8032:32 | BIT4 | RW | 0x00 (0dec)
Index 8033 DCM Controller Settings 2 Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
8033:0 | DCM Controller Settings 2 Ch.2 | Max. Subindex | UINT8 | RO | 0x08 (8dec)
8033:01 | Kp factor (velo./pos.) | Kp control factor of the velocity/position controller | UINT16 | RW | 0x00C8 (200dec)
8033:02 | Ki factor (velo./pos.) | Ki control factor of the velocity/position controller | UINT16 | RW | 0x0002 (2dec)
8033:03 | Inner window (velo./pos.) | Inner window for the I component (unit: 1%) | UINT8 | RW | 0x00 (0dec)
8033:05 | Outer window (velo./pos.) | Outer window for the I component (unit: 1%) | UINT8 | RW | 0x00 (0dec)
8033:06 | Filter cut off frequency (velo./pos.) | Limit frequency of the velocity/position controller (unit: 1 Hz) | UINT16 | RW | 0x0000 (0dec)
8033:07 | Ka factor (velo./pos.) | Ka control factor of the velocity/position controller | UINT16 | RW | 0x0000 (0dec)
8033:08 | Kd factor (velo./pos.) | Kd control factor of the velocity/position controller | UINT16 | RW | 0x0014(20dec)
Index 8040 POS Settings Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
8040:0 | POS Settings Ch.1 | Max. Subindex | UINT8 | RO | 0x10 (16dec)
8040:01 | Velocity min. | Minimum set velocity (range: 0-10000) | INT16 | RW | 0x0064 (100dec)
8040:02 | Velocity max. | Maximum set velocity (range: 0-10000) | INT16 | RW | 0x2710 (10000dec)
8040:03 | Acceleration pos. | Acceleration in positive direction of rotation (unit: 1 ms) | UINT16 | RW | 0x03E8 (1000dec)
8040:04 | Acceleration neg. | Acceleration in negative direction of rotation (unit: 1 ms) | UINT16 | RW | 0x03E8 (1000dec)
8040:05 | Deceleration pos. | Deceleration in positive direction of rotation (unit: 1 ms) | UINT16 | RW | 0x03E8 (1000dec)
8040:06 | Deceleration neg. | Deceleration in negative direction of rotation (unit: 1 ms) | UINT16 | RW | 0x03E8 (1000dec)
8040:07 | Emergency deceleration | Emergency deceleration (both directions of rotation, unit: 1 ms) | UINT16 | RW | 0x0064 (100dec)
8040:08 | Calibration position | Calibration position | UINT32 | RW | 0x00000000 (0dec)
8040:09 | Calibration velocity (towards plc cam) | Calibration velocity towards the cam (range: 0-10000) | INT16 | RW | 0x03E8 (1000dec)
8040:0A | Calibration Velocity (off plc cam) | Calibration velocity away from the cam (range: 0-10000) | INT16 | RW | 0x0064 (100dec)
8040:0B | Target window | Target window | UINT16 | RW | 0x000A (10dec)
8040:0C | In-Target timeout | Timeout at target position (unit: 1 ms) | UINT16 | RW | 0x03E8 (1000dec)
8040:0D | Dead time compensation | Dead time compensation (unit: 1 µs) | INT16 | RW | 0x0064 (100dec)
8040:0E | Modulo factor | Modulo factor/position | UINT32 | RW | 0x00000000 (0dec)
8040:0F | Modulo tolerance window | Tolerance window for modulo positioning | UINT32 | RW | 0x00000000 (0dec)
8040:10 | Position lag max. | Max. permitted position lag | UINT16 | RW | 0x0000 (0dec)
Index 8041 POS Features Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
8041:0 | POS Features Ch.1 |  | UINT8 | RO | 0x16 (22dec)
8041:01 | Start type | Standard start type | UINT16 | RW | 0x0001 (1dec)
8041:11 | Time information | Time information in subindex 6pp0: 22 (“Actual drive time”) 0: Elapsed time current drive time since start of the travel command ...: reserved | BIT2 | RW | 0x00 (0dec)
8041:13 | Invert calibration cam search direction | Inversion of the direction of rotation towards the cam | BOOLEAN | RW | 0x01 (1dec)
8041:14 | Invert sync impulse search direction | Inversion of the direction of rotation away from the cam | BOOLEAN | RW | 0x00 (0dec)
8041:15 | Emergency stop on position lag error | - Lag error monitoring has triggered - an emergency stop is triggered as soon as "Position lag" = 1. The "Misc Error" is set to 1 and a PDO error is generated. | BOOLEAN | RW | 0x00 (0dec)
8041:16 | Enhanced diag history | TRUE: Additional messages are output during the travel command (each change of the state machine (index 0x9040:03)) | BOOLEAN | RW | 0x00 (0dec)
Index 8050 POS Settings Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
8050:0 | POS Settings Ch.2 | Max. Subindex | UINT8 | RO | 0x10 (16dec)
8050:01 | Velocity min. | Minimum set velocity (range: 0-10000) | INT16 | RW | 0x0064 (100dec)
8050:02 | Velocity max. | Maximum set velocity (range: 0-10000) | INT16 | RW | 0x2710 (10000dec)
8050:03 | Acceleration pos. | Acceleration in positive direction of rotation (unit: 1 ms) | UINT16 | RW | 0x03E8 (1000dec)
8050:04 | Acceleration neg. | Acceleration in negative direction of rotation (unit: 1 ms) | UINT16 | RW | 0x03E8 (1000dec)
8050:05 | Deceleration pos. | Deceleration in positive direction of rotation (unit: 1 ms) | UINT16 | RW | 0x03E8 (1000dec)
8050:06 | Deceleration neg. | Deceleration in negative direction of rotation (unit: 1 ms) | UINT16 | RW | 0x03E8 (1000dec)
8050:07 | Emergency Deceleration | Emergency deceleration (both directions of rotation, unit: 1 ms) | UINT16 | RW | 0x0064 (100dec)
8050:08 | Calibration position | Calibration position | UINT32 | RW | 0x00000000 (0dec)
8050:09 | Calibration velocity (towards plc cam) | Calibration velocity towards the cam (range: 0-10000) | INT16 | RW | 0x03E8 (1000dec)
8050:0A | Calibration Velocity (off plc cam) | Calibration velocity away from the cam (range: 0-10000) | INT16 | RW | 0x0064 (100dec)
8050:0B | Target window | Target window | UINT16 | RW | 0x000A (10dec)
8050:0C | In-Target timeout | Timeout at target position (unit: 1 ms) | UINT16 | RW | 0x03E8 (1000dec)
8050:0D | Dead time compensation | Dead time compensation (unit: 1 µs) | INT16 | RW | 0x0064 (100dec)
8050:0E | Modulo factor | Modulo factor/position | UINT32 | RW | 0x00000000 (0dec)
8050:0F | Modulo tolerance window | Tolerance window for modulo positioning | UINT32 | RW | 0x00000000 (0dec)
8050:10 | Position lag max. | Max. permitted position lag | UINT16 | RW | 0x0000 (0dec)
Index 8051 POS Features Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
8051:0 | POS Features Ch.2 | Max. Subindex | UINT8 | RO | 0x16 (22dec)
8051:01 | Start type | Standard start type | UINT16 | RW | 0x0001 (1dec)
8051:11 | Time information | Time information in subindex 6pp0: 22 (“Actual drive time”) 0: Elapsed time current drive time since start of the travel command ...: reserved | BIT2 | RW | 0x00 (0dec)
8051:13 | Invert calibration cam search direction | Inversion of the direction of rotation towards the cam | BOOLEAN | RW | 0x01 (1dec)
8051:14 | Invert sync impulse search direction | Inversion of the direction of rotation away from the cam | BOOLEAN | RW | 0x00 (0dec)
8051:15 | Emergency stop on position lag error | - Lag error monitoring has triggered - an emergency stop is triggered as soon as "Position lag" = 1. The "Misc Error" is set to 1 and a PDO error is generated. | BOOLEAN | RW | 0x00 (0dec)
8051:16 | Enhanced diag history | TRUE: Additional messages are output during the travel command (each change of the state machine (index 0x9050:03)) | BOOLEAN | RW | 0x00 (0dec)


Command object

CoE parameters [image] Command object
Command object
Index FB00 DCM Command
Index (hex) | Name | Meaning | Data type | Flags | Default
FB00:0 | DCM Command | Max. Subindex | UINT8 | RO | 0x03 (3dec)
FB00:01 | Request | 0x1000 Clear diag history Clear the Diag History 0x1100 Get build number: Read out the build number 0x1101 Get build date Read out the build date 0x1102 Get build time Read out the build time 0x8000 Software reset Perform a software reset (hardware is re-initialized with the current CoE configuration; this otherwise happens only during the transition to INIT) | OCTET-STRING[2] | RW | {0}
FB00:02 | Status | 0: Finished, no error, no response Command terminated without error and without response | UINT8 | RO | 0x00 (0dec)
 |  | 1: Finished, no error, response Command terminated without error and with response
 |  | 2: Finished, error, no response Command terminated with error and without response
 |  | 3: Finished, error, response Command terminated with error and with response
 |  | 255: Executing Command is being executed
FB00:03 | Response | dependent on the request | OCTET-STRING[4] | RO | {0}


Input data

CoE parameters [image] Input data
Input data
Index 6000 ENC Inputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
6000:0 | ENC Inputs Ch.1 | Max. Subindex | UINT8 | RO | 0x16 (22dec)
6000:02 | Latch extern valid | The counter value was locked via the external latch. The data with the index 0x6000:12 correspond to the latched value with the bit set. In order to re-activate the latch input, index 0x7000:02 or object index 0x7000:04 must first be cancelled and then set again. | BOOLEAN | RO | 0x00 (0dec)
6000:03 | Set counter done | The counter was set. | BOOLEAN | RO | 0x00 (0dec)
6000:04 | Counter underflow | Counter underflow. Overflow/underflow control is inactive in combination with a reset function (C/external). | BOOLEAN | RO | 0x00 (0dec)
6000:05 | Counter overflow | Counter overflow. Overflow/underflow control is inactive in combination with a reset function (C/external). | BOOLEAN | RO | 0x00 (0dec)
6000:08 | Extrapolation stall | The extrapolated part of the counter is invalid. | BOOLEAN | RO | 0x00 (0dec)
6000:09 | Status of input A | Status of input A | BOOLEAN | RO | 0x00 (0dec)
6000:0A | Status of input B | Status of input B | BOOLEAN | RO | 0x00 (0dec)
6000:0D | Status of extern latch | Status of the extern latch input | BOOLEAN | RO | 0x00 (0dec)
6000:0E | Sync error | The Sync error bit is only required for DC mode. It indicates whether a synchronization error has occurred during the previous cycle. This means a SYNC signal was triggered in the terminal, although no new process data were available (0=OK, 1=NOK). | BOOLEAN | RO | 0x00 (0dec)
6000:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
6000:11 | Counter value | Counter value | UINT32 | RO | 0x00000000 (0dec)
6000:12 | Latch value | Latch value | UINT32 | RO | 0x00000000 (0dec)
6000:16 | Timestamp | Timestamp of the last counter change | UINT32 | RO | 0x00000000 (0dec)
Index 6010 ENC Inputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
6010:0 | ENC Inputs Ch.2 | Max. Subindex | UINT8 | RO | 0x16 (22dec)
6010:02 | Latch extern valid | The counter value was locked via the external latch. The data with the index 0x6010:12 correspond to the latched value with the bit set. In order to re-activate the latch input, index 0x7010:02 or object index 0x7010:04 must first be cancelled and then set again. | BOOLEAN | RO | 0x00 (0dec)
6010:03 | Set counter done | The counter was set. | BOOLEAN | RO | 0x00 (0dec)
6010:04 | Counter underflow | Counter underflow. Overflow/underflow control is inactive in combination with a reset function (C/external). | BOOLEAN | RO | 0x00 (0dec)
6010:05 | Counter overflow | Counter overflow. Overflow/underflow control is inactive in combination with a reset function (C/external). | BOOLEAN | RO | 0x00 (0dec)
6010:08 | Extrapolation stall | The extrapolated part of the counter is invalid | BOOLEAN | RO | 0x00 (0dec)
6010:09 | Status of input A | Status of input A | BOOLEAN | RO | 0x00 (0dec)
6010:0A | Status of input B | Status of input B | BOOLEAN | RO | 0x00 (0dec)
6010:0D | Status of extern latch | Status of the extern latch input | BOOLEAN | RO | 0x00 (0dec)
6010:0E | Sync error | The Sync error bit is only required for DC mode. It indicates whether a synchronization error has occurred during the previous cycle. This means a SYNC signal was triggered in the terminal, although no new process data were available (0=OK, 1=NOK). | BOOLEAN | RO | 0x00 (0dec)
6010:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
6010:11 | Counter value | Counter value | UINT32 | RO | 0x00000000 (0dec)
6010:12 | Latch value | Latch value | UINT32 | RO | 0x00000000 (0dec)
6010:16 | Timestamp | Timestamp of the last counter change | UINT32 | RO | 0x00000000 (0dec)
Index 6020 DCM Inputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
6020:0 | DCM Inputs Ch.1 | Max. Subindex | UINT8 | RO | 0x12 (18dec)
6020:01 | Ready to enable | Driver stage is ready for enabling | BOOLEAN | RO | 0x00 (0dec)
6020:02 | Ready | Driver stage is ready for operation | BOOLEAN | RO | 0x00 (0dec)
6020:03 | Warning | A warning has occurred (see index 0xA020) | BOOLEAN | RO | 0x00 (0dec)
6020:04 | Error | An error has occurred (see index 0xA020) | BOOLEAN | RO | 0x00 (0dec)
6020:05 | Moving positive | Driver stage is activated in positive direction | BOOLEAN | RO | 0x00 (0dec)
6020:06 | Moving negative | Driver stage is activated in negative direction | BOOLEAN | RO | 0x00 (0dec)
6020:07 | Torque reduced | Reduced torque is active | BOOLEAN | RO | 0x00 (0dec)
6020:0C | Digital input 1 | Digital input 1 | BOOLEAN | RO | 0x00 (0dec)
6020:0D | Digital input 2 | Digital input 2 | BOOLEAN | RO | 0x00 (0dec)
6020:0E | Sync error | The Sync error bit is only required for DC mode. It indicates whether a synchronization error has occurred during the previous cycle. | BOOLEAN | RO | 0x00 (0dec)
6020:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
6020:11 | Info data 1 | Synchronous information (selection via subindex 0x8022:11) | UINT16 | RO | 0x0000 (0dec)
6020:12 | Info data 2 | Synchronous information (selection via subindex 0x8022:19) | UINT16 | RO | 0x0000 (0dec)
Index 6030 DCM Inputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
6030:0 | DCM Inputs Ch.2 | Max. Subindex | UINT8 | RO | 0x12 (18dec)
6030:01 | Ready to enable | Driver stage is ready for enabling | BOOLEAN | RO | 0x00 (0dec)
6030:02 | Ready | Driver stage is ready for operation | BOOLEAN | RO | 0x00 (0dec)
6030:03 | Warning | A warning has occurred (see index 0xA030) | BOOLEAN | RO | 0x00 (0dec)
6030:04 | Error | An error has occurred (see index 0xA030) | BOOLEAN | RO | 0x00 (0dec)
6030:05 | Moving positive | Driver stage is activated in positive direction | BOOLEAN | RO | 0x00 (0dec)
6030:06 | Moving negative | Driver stage is activated in negative direction | BOOLEAN | RO | 0x00 (0dec)
6030:07 | Torque reduced | Reduced torque is active | BOOLEAN | RO | 0x00 (0dec)
6030:0C | Digital input 1 | Digital input 1 | BOOLEAN | RO | 0x00 (0dec)
6030:0D | Digital input 2 | Digital input 2 | BOOLEAN | RO | 0x00 (0dec)
6030:0E | Sync error | The Sync error bit is only required for DC mode. It indicates whether a synchronization error has occurred during the previous cycle. | BOOLEAN | RO | 0x00 (0dec)
6030:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
6030:11 | Info data 1 | Synchronous information (selection via subindex 0x8032:11) | UINT16 | RO | 0x0000 (0dec)
6030:12 | Info data 2 | Synchronous information (selection via subindex 0x8032:19) | UINT16 | RO | 0x0000 (0dec)
Index 6040 POS Inputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
6040:0 | POS Inputs Ch.1 | Max. Subindex | UINT8 | RO | 0x22 (34dec)
6040:01 | Busy | A current travel command is active | BOOLEAN | RO | 0x00 (0dec)
6040:02 | In-Target | Motor has arrived at target | BOOLEAN | RO | 0x00 (0dec)
6040:03 | Warning | A warning has occurred | BOOLEAN | RO | 0x00 (0dec)
6040:04 | Error | an error has occurred | BOOLEAN | RO | 0x00 (0dec)
6040:05 | Calibrated | Motor is calibrated | BOOLEAN | RO | 0x00 (0dec)
6040:06 | Accelerate | Motor is in the acceleration phase | BOOLEAN | RO | 0x00 (0dec)
6040:07 | Decelerate | Motor is in the deceleration phase | BOOLEAN | RO | 0x00 (0dec)
6040:11 | Actual position | Current target position of the travel command generator | UINT32 | RO | 0x00007FFF (32767dec)
6040:21 | Actual velocity | Current set velocity of the travel command generator | INT16 | RO | 0x0000 (0dec)
6040:22 | Actual drive time | Travel command time information (see subindex 8pp1:11) | UINT32 | RO | 0x00000000 (0dec)
Index 6050 POS Inputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
6050:0 | POS Inputs Ch.2 | Max. Subindex | UINT8 | RO | 0x22 (34dec)
6050:01 | Busy | A current travel command is active | BOOLEAN | RO | 0x00 (0dec)
6050:02 | In-Target | Motor has arrived at target | BOOLEAN | RO | 0x00 (0dec)
6050:03 | Warning | A warning has occurred | BOOLEAN | RO | 0x00 (0dec)
6050:04 | Error | an error has occurred | BOOLEAN | RO | 0x00 (0dec)
6050:05 | Calibrated | Motor is calibrated | BOOLEAN | RO | 0x00 (0dec)
6050:06 | Accelerate | Motor is in the acceleration phase | BOOLEAN | RO | 0x00 (0dec)
6050:07 | Decelerate | Motor is in the deceleration phase | BOOLEAN | RO | 0x00 (0dec)
6050:11 | Actual position | Current target position of the travel command generator | UINT32 | RO | 0x00007FFF (32767dec)
6050:21 | Actual velocity | Current set velocity of the travel command generator | INT16 | RO | 0x0000 (0dec)
6050:22 | Actual drive time | Travel command time information (see subindex 8pp1:11) | UINT32 | RO | 0x00000000 (0dec)


Output data

CoE parameters [image] Output data
Output data
Index 7000 ENC Outputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
7000:0 | ENC Outputs Ch.1 | Max. Subindex | UINT8 | RO | 0x11 (17dec)
7000:02 | Enable latch extern on positive edge | Activate external latch with positive edge. | BOOLEAN | RO | 0x00 (0dec)
7000:03 | Set counter | Set counter | BOOLEAN | RO | 0x00 (0dec)
7000:04 | Enable latch extern on negative edge | Activate external latch with negative edge. | BOOLEAN | RO | 0x00 (0dec)
7000:11 | Set counter value | The counter value to be set via "Set counter" (index 0x7000:03). | UINT32 | RO | 0x00000000 (0dec)
Index 7010 ENC Outputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
7010:0 | ENC Outputs Ch.2 | Max. Subindex | UINT8 | RO | 0x11 (17dec)
7010:02 | Enable latch extern on positive edge | Activate external latch with positive edge. | BOOLEAN | RO | 0x00 (0dec)
7010:03 | Set counter | Set counter | BOOLEAN | RO | 0x00 (0dec)
7010:04 | Enable latch extern on negative edge | Activate external latch with negative edge. | BOOLEAN | RO | 0x00 (0dec)
7010:11 | Set counter value | The counter value to be set via "Set counter" (index 0x7010:03). | UINT32 | RO | 0x00000000 (0dec)
Index 7020 DCM Outputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
7020:0 | DCM Outputs Ch.1 | Max. Subindex | UINT8 | RO | 0x21 (33dec)
7020:01 | Enable | Activates the output stage | BOOLEAN | RO | 0x00 (0dec)
7020:02 | Reset | All errors that may have occurred are reset by setting this bit (rising edge) | BOOLEAN | RO | 0x00 (0dec)
7020:03 | Reduce torque | Reduced torque (coil current) is active (see subindex 0x8020:05 / 0x8020:06) | BOOLEAN | RO | 0x00 (0dec)
7020:11 | Position | Set position specification | UINT32 | RO | 0x00000000 (0dec)
7020:21 | Velocity | Set velocity specification | INT16 | RO | 0x0000 (0dec)
Index 7030 DCM Outputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
7030:0 | DCM Outputs Ch.2 | Max. Subindex | UINT8 | RO | 0x21 (33dec)
7030:01 | Enable | Activates the output stage | BOOLEAN | RO | 0x00 (0dec)
7030:02 | Reset | All errors that may have occurred are reset by setting this bit (rising edge) | BOOLEAN | RO | 0x00 (0dec)
7030:03 | Reduce torque | Reduced torque (coil current) is active (see subindex 0x8030:05 / 0x8030:06) | BOOLEAN | RO | 0x00 (0dec)
7030:11 | Position | Set position specification | UINT32 | RO | 0x00000000 (0dec)
7030:21 | Velocity | Set velocity specification | INT16 | RO | 0x0000 (0dec)
Index 7040 POS Outputs Ch.1
Index (hex)
Name
Meaning
Data type
Flags
Default
7040:0
POS Outputs Ch.1
Max. Subindex
UINT8
RO
0x24 (36dec)
7040:01
Execute
Start travel command (rising edge), or prematurely abort travel command (falling edge)
BOOLEAN
RO
0x00 (0dec)
7040:02
Emergency stop
Prematurely abort travel command with an emergency ramp (rising edge)
BOOLEAN
RO
0x00 (0dec)
7040:11
Target position
Specification of the target position
UINT32
RO
0x00007FFF (32767dec)
7040:21
Velocity
Specification of the maximum set velocity
INT16
RO
0x0000 (0dec)
7040:22
Start type
Specification of the start types
0x0000 Idle
No travel command is being executed
0x0001 Absolute
Absolute target position
0x0002 Relative
Target position relative to the start position
0x0003 Endless plus
Endless driving in positive direction of rotation
0x0004 Endless minus
Endless driving in negative direction of rotation
0x0105 Modulo short
Shortest distance to the next modulo position
0x0115 Modulo short extended
Shortest distance to the next modulo position (without modulo window)
0x0205 Modulo plus
Drive in positive direction of rotation to the next modulo position
0x0215 Modulo plus extended
Drive in positive direction of rotation to the next modulo position (without modulo window)
0x0305 Modulo minus
Drive in negative direction of rotation to the next modulo position
0x0315 Modulo minus extended
Drive in negative direction of rotation to the next modulo position (without modulo window)
0x0405 Modulo current
Drive in the last implemented direction of rotation to the next modulo position
0x0415 Modulo current extended
Drive in the last implemented direction of rotation to the next modulo position (without modulo window)
0x0006 Additive
New target position relative/additive to the last target position
0x6000 Calibration, Plc cam
Calibration with cam
0x6100 Calibration, Hw sync
Calibration with cam and C-track
0x6E00 Calibration, set manual
Set calibration manually
0x6E01 Calibration, set manual auto
Set calibration automatically
0x6F00 Calibration, clear manual
Clear calibration manually
UINT16
RO
0x0000 (0dec)
7040:23
Acceleration
Acceleration specification
UINT16
RO
0x0000 (0dec)
7040:24
Deceleration
Deceleration specification
UINT16
RO
0x0000 (0dec)
Index 7050 POS Outputs Ch.2
Index (hex)
Name
Meaning
Data type
Flags
Default
7050:0
POS Outputs Ch.2
Max. Subindex
UINT8
RO
0x24 (36dec)
7050:01
Execute
Start travel command (rising edge), or prematurely abort travel command (falling edge)
BOOLEAN
RO
0x00 (0dec)
7050:02
Emergency Stop
Prematurely abort travel command with an emergency ramp (rising edge)
BOOLEAN
RO
0x00 (0dec)
7050:11
Target position
Specification of the target position
UINT32
RO
0x00007FFF (32767dec)
7050:21
Velocity
Specification of the maximum set velocity
INT16
RO
0x0000 (0dec)
7050:22
Start type
Specification of the start types 0x0000 Idle
No travel command is being executed
0x0001 Absolute
Absolute target position
0x0002 Relative
Target position relative to the start position
0x0003 Endless plus
Endless driving in positive direction of rotation
0x0004 Endless minus
Endless driving in negative direction of rotation
0x0105 Modulo short
Shortest distance to the next modulo position
0x0115 Modulo short extended
Shortest distance to the next modulo position (without modulo window)
0x0205 Modulo plus
Drive in positive direction of rotation to the next modulo position
0x0215 Modulo plus extended
Drive in positive direction of rotation to the next modulo position (without modulo window)
0x0305 Modulo minus
Drive in negative direction of rotation to the next modulo position
0x0315 Modulo minus extended
Drive in negative direction of rotation to the next modulo position (without modulo window)
0x0405 Modulo current
Drive in the last implemented direction of rotation to the next modulo position
0x0415 Modulo current extended
Drive in the last implemented direction of rotation to the next modulo position (without modulo window)
0x0006 Additive
New target position relative/additive to the last target position
0x6000 Calibration, Plc cam
Calibration with cam
0x6100 Calibration, Hw sync
Calibration with cam and C-track
0x6E00 Calibration, set manual
Set calibration manually
0x6E01 Calibration, set manual auto
Set calibration automatically
0x6F00 Calibration, clear manual
Clear calibration manually
UINT16
RO
0x0000 (0dec)
7050:23
Acceleration
Acceleration specification
UINT16
RO
0x0000 (0dec)
7050:24
Deceleration
Deceleration specification
UINT16
RO
0x0000 (0dec)


Information and diagnosis data (channel specific)

CoE parameters [image] Information and diagnosis data (channel specific)
Information and diagnosis data (channel specific)
Index 9020 DCM Info data Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
9020:0 | DCM Info data Ch.1 | Max. Subindex | UINT8 | RO | 0x09 (9dec)
9020:01 | Status word | Status word (see Index App0) | UINT16 | RO | 0x0000 (0dec)
9020:02 | Motor coil voltage | Present coil voltage | UINT16 | RO | 0x0000 (0dec)
9020:03 | Motor coil current | Present coil current | INT16 | RO | 0x0000 (0dec)
9020:04 | Current limit | Present current limit | UINT16 | RO | 0x0000 (0dec)
9020:05 | Control error | Present control error | INT16 | RO | 0x0000 (0dec)
9020:06 | Duty cycle | Present Duty-Cycle | INT8 | RO | 0x00 (0dec)
9020:08 | Motor velocity | Present motor velocity | INT16 | RO | 0x0000 (0dec)
9020:09 | Overload time | Time since overload | UINT16 | RO | 0x0000 (0dec)
Index 9030 DCM Info data Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
9030:0 | DCM Info data Ch.2 | Max. Subindex | UINT8 | RO | 0x09 (9dec)
9030:01 | Status word | Status word (see Index App0) | UINT16 | RO | 0x0000 (0dec)
9030:02 | Motor coil voltage | Present coil voltage | UINT16 | RO | 0x0000 (0dec)
9030:03 | Motor coil current | Present coil current | INT16 | RO | 0x0000 (0dec)
9030:04 | Current limit | Present current limit | UINT16 | RO | 0x0000 (0dec)
9030:05 | Control error | Present control error | INT16 | RO | 0x0000 (0dec)
9030:06 | Duty cycle | Present Duty-Cycle | INT8 | RO | 0x00 (0dec)
9030:08 | Motor velocity | Present motor velocity | INT16 | RO | 0x0000 (0dec)
9030:09 | Overload time | Time since overload | UINT16 | RO | 0x0000 (0dec)
Index 9040 POS Info data Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
9040:0 | POS Info data Ch.1 | Max. Subindex | UINT8 | RO | 0x04 (4dec)
9040:01 | Status word | Status word | UINT16 |  | 0x0000 (0dec)
9040:03 | State (drive controller) | Current step of the internal state machine | UINT16 | RO | 0xFFFF (65535dec)
9040:04 | Actual position lag | Current position lag | UINT16 |  | 0x0000 (0dec)
Index 9050 POS Info data Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
9050:0 | POS Info data Ch.2 | Max. Subindex | UINT8 | RO | 0x04 (4dec)
9050:01 | Status word | Status word | UINT16 | RO | 0x0000 (0dec)
9050:03 | State (drive controller) | Current step of the internal state machine | UINT16 | RO | 0xFFFF (65535dec)
9050:04 | Actual position lag | Current position lag | UINT16 | RO | 0x0000 (0dec)
Index A020 DCM Diag data Ch.1
Index (hex) | Name | Meaning |  | Data type | Flags | Default
A020:0 | DCM Diag data Ch.1 | Max. Subindex |  | UINT8 | RO | 0x11 (17dec)
A020:01 | Saturated | Driver stage operates with maximum duty cycle | Warning | BOOLEAN | RO | 0x00 (0dec)
A020:02 | Over temperature | Internal terminal temperature is greater than 80 °C | Warning | BOOLEAN | RO | 0x00 (0dec)
A020:03 | Torque overload | Present motor current exceeds the nominal current (see 0x8020:02) | Warning (8022:0A = 0) / Error (8022:0A = 1) | BOOLEAN | RO | 0x00 (0dec)
A020:04 | Under voltage | Supply voltage less than 7 V | Error | BOOLEAN | RO | 0x00 (0dec)
A020:05 | Over voltage | Supply voltage 10 % higher than the nominal voltage (see 0x8020:03) | Error | BOOLEAN | RO | 0x00 (0dec)
A020:06 | Short circuit | Short circuit in the driver stage | Error | BOOLEAN | RO | 0x00 (0dec)
A020:08 | No control power | No power supply to driver stage | Error | BOOLEAN | RO | 0x00 (0dec)
A020:09 | Misc error | - initialization failed or - internal temperature of the terminal exceeds 100 °C (see 0xF80F:05) or - motor current exceeds the nominal current (see 0x8022:0A) | Error | BOOLEAN | RO | 0x00 (0dec)
A020:0A | Configuration | CoE change has not yet been adopted into the current configuration | Warning | BOOLEAN | RO | 0x00 (0dec)
A020:11 | Actual operation mode | Present operating mode (in the case of automatic detection of operating mode, see 0x8022:01) |  | BIT4 | RO | 0x00 (0dec)
Index A030 DCM Diag data Ch.2
Index (hex) | Name | Meaning |  | Data type | Flags | Default
A030:0 | DCM Diag data Ch.1 | Max. Subindex |  | UINT8 | RO | 0x11 (17dec)
A030:01 | Saturated | Driver stage operates with maximum duty cycle | Warning | BOOLEAN | RO | 0x00 (0dec)
A030:02 | Over temperature | Internal terminal temperature is greater than 80 °C | Warning | BOOLEAN | RO | 0x00 (0dec)
A030:03 | Torque overload | Present motor current exceeds the nominal current (see 0x8030:02) | Warning (0x8032:0A = 0) / Error (0x8032:0A = 1) | BOOLEAN | RO | 0x00 (0dec)
A030:04 | Under voltage | Supply voltage less than 7 V | Error | BOOLEAN | RO | 0x00 (0dec)
A030:05 | Over voltage | Supply voltage 10 % higher than the nominal voltage (see 0x8030:03) | Error | BOOLEAN | RO | 0x00 (0dec)
A030:06 | Short circuit | Short circuit in the driver stage | Error | BOOLEAN | RO | 0x00 (0dec)
A030:08 | No control power | No power supply to driver stage | Error | BOOLEAN | RO | 0x00 (0dec)
A030:09 | Misc error | - initialization failed or - internal temperature of the terminal exceeds 100 °C (see 0xF80F:05) or - motor current exceeds the nominal current (see 0x8032:0A) | Error | BOOLEAN | RO | 0x00 (0dec)
A030:0A | Configuration | CoE change has not yet been adopted into the current configuration | Warning | BOOLEAN | RO | 0x00 (0dec)
A030:11 | Actual operation mode | Present operating mode (in the case of automatic detection of operating mode, see 0x8032:01) |  | BIT4 | RO | 0x00 (0dec)
Index A040 POS Diag data Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
A040:0 | POS Diag data Ch.1 | Max. Subindex | UINT8 | RO | 0x6 (6dec)
A040:01 | Command rejected | Travel command was rejected | BOOLEAN | RO | 0x00 (0dec)
A040:02 | Command aborted | Travel command was aborted | BOOLEAN | RO | 0x00 (0dec)
A040:03 | Target overrun | Target position was overrun in the opposite direction | BOOLEAN | RO | 0x00 (0dec)
A040:04 | Target timeout | The motor did not reach the target window (0x8040:0B) within the configured time (0x8040:0C) after the end of the travel command. | BOOLEAN | RO | 0x00 (0dec)
A040:05 | Position lag | Position lag exceeded - The position lag monitoring is deactivated if "Position lag max." = 0. If a value is entered in "Position lag max.", then this value is compared with "Actual position lag". As soon as "Actual position lag" exceeds "Position lag max.", "Position lag" = 1 is set and a PDO warning is output. | BOOLEAN | RO | 0x00 (0dec)
A040:06 | Emergency stop | An emergency stop was triggered (automatic or manual). | BOOLEAN | RO | 0x00 (0dec)
Index A050 POS Diag data Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
A050:0 | POS Diag data Ch.2 | Max. Subindex | UINT8 | RO | 0x6 (6dec)
A050:01 | Command rejected | Travel command was rejected | BOOLEAN | RO | 0x00 (0dec)
A050:02 | Command aborted | Travel command was aborted | BOOLEAN | RO | 0x00 (0dec)
A050:03 | Target overrun | Target position was overrun in the opposite direction | BOOLEAN | RO | 0x00 (0dec)
A050:04 | Target timeout | The motor did not reach the target window (0x8050:0B) within the configured time (0x8050:0C) after the end of the travel command. | BOOLEAN | RO | 0x00 (0dec)
A050:05 | Position lag | Position lag exceeded - The position lag monitoring is deactivated if "Position lag max." = 0. If a value is entered in "Position lag max.", then this value is compared with "Actual position lag". As soon as "Actual position lag" exceeds "Position lag max.", "Position lag" = 1 is set and a PDO warning is output. | BOOLEAN | RO | 0x00 (0dec)
A050:06 | Emergency stop | An emergency stop was triggered (automatic or manual) | BOOLEAN | RO | 0x00 (0dec)


Configuration data (vendor-specific)

CoE parameters [image] Configuration data (vendor-specific)
Configuration data (vendor-specific)
Index F80F DCM Vendor data
Index (hex) | Name | Meaning | Data type | Flags | Default
F80F:0 | DCM Vendor data | Max. Subindex | UINT8 | RO | 0x06 (6dec)
F80F:01 | PWM Frequency | DC link frequency (unit: 1 Hz) | UINT16 | RW | 0x7530 (30000dec)
F80F:02 | Deadtime | Dead time for pulse width modulation | UINT16 | RW | 0x0102 (258dec)
F80F:03 | Deadtime space | Duty cycle limitation | UINT16 | RW | 0x0009 (9dec)
F80F:04 | Warning temperature | Threshold of the temperature warning (unit: 1 °C) | INT8 | RW | 0x50 (80dec)
F80F:05 | Switch off temperature | Switch-off temperature (unit: 1 °C) | INT8 | RW | 0x64 (100dec)
F80F:06 | Analog trigger point | Trigger point for AD conversion | UINT16 | RW | 0x000A (10dec)


Information and diagnosis data (device-specific)

CoE parameters [image] Information and diagnosis data (device-specific)
Information and diagnosis data (device-specific)
Index F900 DCM Info data
Index (hex) | Name | Meaning | Data type | Flags | Default
F900:0 | DCM Info data | Max. Subindex | UINT8 | RO | 0x06 (6dec)
F900:01 | Software version (driver) | Software version of the driver card | STRING | RO |
F900:02 | Internal temperature | Internal terminal temperature (unit: 1 °C) | INT8 | RO | 0x00 (0dec)
F900:04 | Control voltage | Control voltage (unit: 1 mV) | UINT16 | RO | 0x0000 (0dec)
F900:05 | Motor supply voltage | Load voltage (unit: 1 mV) | UINT16 | RO | 0x0000 (0dec)
F900:06 | Cycle time | Measured cycle time (unit: 1 µs) | UINT16 | RO | 0x0000 (0dec)


Standard objects

CoE parameters [image] Standard objects
Standard objects
The standard objects have the same meaning for all EtherCAT slaves.
Index 1000 Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: the Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x00001389 (5001dec)
Index 1008 Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EP7342-0002
Index 1009 Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO | 1)
1) Refer to Firmware and hardware versions.
Index 100A Software version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO | 1)
1) Refer to Firmware and hardware versions.
Index 1018 Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x1CAE4052 (481181778dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the Low Word (bit 0-15) indicates the special terminal number, the High Word (bit 16-31) refers to the device description | UINT32 | RO | -
1018:04 | Serial number | Serial number of the EtherCAT slave; the Low Byte (bit 0-7) of the Low Word contains the year of production, the High Byte (bit 8-15) of the Low Word contains the week of production, the High Word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 Backup parameter handling
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | Information for standardized loading and saving of backup entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum across all backup entries of the EtherCAT slave | UINT32 | RO | 0x00000000 (0dec)
Index 1400 ENC RxPDO-Par Control compact Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1400:0 | ENC RxPDO-Par Control compact Ch.1 | PDO Parameter RxPDO 1 | UINT8 | RO | 0x06 (6dec)
1400:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 1 | OCTET-STRING[6] | RO | 01 16 00 00 00 00
Index 1401 ENC RxPDO-Par Control Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1401:0 | ENC RxPDO-Par Control Ch.1 | PDO Parameter RxPDO 2 | UINT8 | RO | 0x06 (6dec)
1401:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 2 | OCTET-STRING[6] | RO | 00 16 00 00 00 00
Index 1402 ENC RxPDO-Par Control compact Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1402:0 | ENC RxPDO-Par Control compact Ch.2 | PDO Parameter RxPDO 3 | UINT8 | RO | 0x06 (6dec)
1402:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 3 | OCTET-STRING[6] | RO | 03 16 00 00 00 00
Index 1403 ENC RxPDO-Par Control Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1403:0 | ENC RxPDO-Par Control Ch.2 | PDO Parameter RxPDO 4 | UINT8 | RO | 0x06 (6dec)
1403:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 4 | OCTET-STRING[6] | RO | 02 16 00 00 00 00
Index 1405 DCM RxPDO-Par Position Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1405:0 | DCM RxPDO-Par Position Ch.1 | PDO Parameter RxPDO 6 | UINT8 | RO | 0x06 (6dec)
1405:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 6 | OCTET-STRING[6] | RO | 06 16 0A 16 0B 16
Index 1406 DCM RxPDO-Par Velocity Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1406:0 | DCM RxPDO-Par Velocity Ch.1 | PDO Parameter RxPDO 7 | UINT8 | RO | 0x06 (6dec)
1406:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 7 | OCTET-STRING[6] | RO | 05 16 0A 16 0B 16
Index 1408 DCM RxPDO-Par Position Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1408:0 | DCM RxPDO-Par Position Ch.2 | PDO Parameter RxPDO 9 | UINT8 | RO | 0x06 (6dec)
1408:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 9 | OCTET-STRING[6] | RO | 09 16 0C 16 0D 16
Index 1409 DCM RxPDO-Par Velocity Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1409:0 | DCM RxPDO-Par Velocity Ch.2 | PDO Parameter RxPDO 10 | UINT8 | RO | 0x06 (6dec)
1409:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 10 | OCTET-STRING[6] | RO | 08 16 0C 16 0D 16
Index 140A POS RxPDO-Par Control compact Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
140A:0 | POS RxPDO-Par Control compact Ch.1 | PDO Parameter RxPDO 11 | UINT8 | RO | 0x06 (6dec)
140A:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 11 | OCTET-STRING[6] | RO | 05 16 06 16 0B 16
Index 140B POS RxPDO-Par Control Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
140B:0 | POS RxPDO-Par Control Ch.1 | PDO Parameter RxPDO 12 | UINT8 | RO | 0x06 (6dec)
140B:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 12 | OCTET-STRING[6] | RO | 05 16 06 16 0A 16
Index 140C POS RxPDO-Par Control compact Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
140C:0 | POS RxPDO-Par Control compact Ch.2 | PDO Parameter RxPDO 13 | UINT8 | RO | 0x06 (6dec)
140C:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 13 | OCTET-STRING[6] | RO | 08 16 09 16 0D 16
Index 140D POS RxPDO-Par Control Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
140D:0 | POS RxPDO-Par Control Ch.2 | PDO Parameter RxPDO 14 | UINT8 | RO | 0x06 (6dec)
140D:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 14 | OCTET-STRING[6] | RO | 08 16 09 16 0C 16
Index 1600 ENC RxPDO-Map Control compact Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1600:0 | ENC RxPDO-Map Control compact Ch.1 | PDO Mapping RxPDO 1 | UINT8 | RO | 0x07 (7dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:02, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7000:04, 1
1600:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1600:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1600:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 16
Index 1601 ENC RxPDO-Map Control Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1601:0 | ENC RxPDO-Map Control Ch.1 | PDO Mapping RxPDO 2 | UINT8 | RO | 0x07 (7dec)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:02, 1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03, 1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7000:04, 1
1601:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1601:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1601:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 32
Index 1602 ENC RxPDO-Map Control compact Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1602:0 | ENC RxPDO-Map Control compact Ch.2 | PDO Mapping RxPDO 3 | UINT8 | RO | 0x07 (7dec)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1602:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7010:02, 1
1602:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x03 (Set counter)) | UINT32 | RO | 0x7010:03, 1
1602:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7010:04, 1
1602:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1602:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1602:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7010:11, 16
Index 1603 ENC RxPDO-Map Control Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1603:0 | ENC RxPDO-Map Control Ch.2 | PDO Mapping RxPDO 4 | UINT8 | RO | 0x07 (7dec)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1603:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7010:02, 1
1603:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x03 (Set counter)) | UINT32 | RO | 0x7010:03, 1
1603:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7010:04, 1
1603:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1603:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1603:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7010:11, 32
Index 1604 DCM RxPDO-Map Control Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1604:0 | DCM RxPDO-Map Control Ch.1 | PDO Mapping RxPDO 5 | UINT8 | RO | 0x05 (5dec)
1604:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (DCM Outputs Ch.1), entry 0x01 (Enable)) | UINT32 | RO | 0x7020:01, 1
1604:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7020 (DCM Outputs Ch.1), entry 0x02 (Reset)) | UINT32 | RO | 0x7020:02, 1
1604:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7020 (DCM Outputs Ch.1), entry 0x03 (Reduce torque)) | UINT32 | RO | 0x7020:03, 1
1604:04 | SubIndex 004 | 4. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1604:05 | SubIndex 005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1605 DCM RxPDO-Map Position Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1605:0 | DCM RxPDO-Map Position Ch.1 | PDO Mapping RxPDO 6 | UINT8 | RO | 0x01 (1dec)
1605:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (DCM Outputs Ch.1), entry 0x11 (Position)) | UINT32 | RO | 0x7020:11, 32
Index 1606 DCM RxPDO-Map Velocity Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1606:0 | DCM RxPDO-Map Velocity Ch.1 | PDO Mapping RxPDO 7 | UINT8 | RO | 0x01 (1dec)
1606:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (DCM Outputs Ch.1), entry 0x21 (Velocity)) | UINT32 | RO | 0x7020:21, 16
Index 1607 DCM RxPDO-Map Control Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1607:0 | DCM RxPDO-Map Control Ch.2 | PDO Mapping RxPDO 8 | UINT8 | RO | 0x05 (5dec)
1607:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7030 (DCM Outputs Ch.2), entry 0x01 (Enable)) | UINT32 | RO | 0x7030:01, 1
1607:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7030 (DCM Outputs Ch.2), entry 0x02 (Reset)) | UINT32 | RO | 0x7030:02, 1
1607:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7030 (DCM Outputs Ch.2), entry 0x03 (Reduce torque)) | UINT32 | RO | 0x7030:03, 1
1607:04 | SubIndex 004 | 4. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1607:05 | SubIndex 005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1608 DCM RxPDO-Map Position Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1608:0 | DCM RxPDO-Map Position Ch.2 | PDO Mapping RxPDO 9 | UINT8 | RO | 0x01 (1dec)
1608:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7030 (DCM Outputs Ch.2), entry 0x11 (Position)) | UINT32 | RO | 0x7030:11, 32
Index 1609 DCM RxPDO-Map Velocity Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1609:0 | DCM RxPDO-Map Velocity Ch.2 | PDO Mapping RxPDO 10 | UINT8 | RO | 0x01 (1dec)
1609:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7030 (DCM Outputs Ch.2), entry 0x21 (Velocity)) | UINT32 | RO | 0x7030:21, 16
Index 160A POS RxPDO-Map Control compact Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
160A:0 | POS RxPDO-Map Control compact Ch.1 | PDO Mapping RxPDO 11 | UINT8 | RO | 0x05 (5dec)
160A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7040 (POS Outputs Ch.1), entry 0x01 (Execute)) | UINT32 | RO | 0x7040:01, 1
160A:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7040 (POS Outputs Ch.1), entry 0x02 (Emergency stop)) | UINT32 | RO | 0x7040:02, 1
160A:03 | SubIndex 003 | 3. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
160A:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
160A:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7040 (POS Outputs Ch.1), entry 0x11 (Target position)) | UINT32 | RO | 0x7040:11, 32
Index 160B POS RxPDO-Map Control Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
160B:0 | POS RxPDO-Map Control Ch.1 | PDO Mapping RxPDO 12 | UINT8 | RO | 0x09 (9dec)
160B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7040 (POS Outputs Ch.1), entry 0x01 (Execute)) | UINT32 | RO | 0x7040:01, 1
160B:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7040 (POS Outputs Ch.1), entry 0x02 (Emergency stop)) | UINT32 | RO | 0x7040:02, 1
160B:03 | SubIndex 003 | 3. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
160B:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
160B:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7040 (POS Outputs Ch.1), entry 0x11 (Target position)) | UINT32 | RO | 0x7040:11, 32
160B:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7040 (POS Outputs Ch.1), entry 0x21 (Velocity)) | UINT32 | RO | 0x7040:21, 16
160B:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7040 (POS Outputs Ch.1), entry 0x22 (Start type)) | UINT32 | RO | 0x7040:22, 16
160B:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7040 (POS Outputs Ch.1), entry 0x23 (Acceleration)) | UINT32 | RO | 0x7040:23, 16
160B:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7040 (POS Outputs Ch.1), entry 0x24 (Deceleration)) | UINT32 | RO | 0x7040:24, 16
Index 160C POS RxPDO-Map Control compact Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
160C:0 | POS RxPDO-Map Control compact Ch.2 | PDO Mapping RxPDO 13 | UINT8 | RO | 0x05 (5dec)
160C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7050 (POS Outputs Ch.2), entry 0x01 (Execute)) | UINT32 | RO | 0x7050:01, 1
160C:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7050 (POS Outputs Ch.2), entry 0x02 (Emergency stop)) | UINT32 | RO | 0x7050:02, 1
160C:03 | SubIndex 003 | 3. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
160C:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
160C:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7050 (POS Outputs Ch.2), entry 0x11 (Target position)) | UINT32 | RO | 0x7050:11, 32
Index 160D POS RxPDO-Map Control Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
160D:0 | POS RxPDO-Map Control Ch.2 | PDO Mapping RxPDO 14 | UINT8 | RO | 0x09 (9dec)
160D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7050 (POS Outputs Ch.2), entry 0x01 (Execute)) | UINT32 | RO | 0x7050:01, 1
160D:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7050 (POS Outputs Ch.2), entry 0x02 (Emergency stop)) | UINT32 | RO | 0x7050:02, 1
160D:03 | SubIndex 003 | 3. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
160D:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
160D:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7050 (POS Outputs Ch.2), entry 0x11 (Target position)) | UINT32 | RO | 0x7050:11, 32
160D:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7050 (POS Outputs Ch.2), entry 0x21 (Velocity)) | UINT32 | RO | 0x7050:21, 16
160D:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7050 (POS Outputs Ch.2), entry 0x22 (Start type)) | UINT32 | RO | 0x7050:22, 16
160D:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7050 (POS Outputs Ch.2), entry 0x23 (Acceleration)) | UINT32 | RO | 0x7050:23, 16
160D:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7050 (POS Outputs Ch.2), entry 0x24 (Deceleration)) | UINT32 | RO | 0x7050:24, 16
Index 1800 ENC TxPDO-Par Status compact Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1800:0 | ENC TxPDO-Par Status compact Ch.1 | PDO Parameter TxPDO 1 | UINT8 | RO | 0x09 (9dec)
1800:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 1 | OCTET-STRING[2] | RO | 01 1A
1800:09 | TxPDO Toggle | The TxPDO toggle is toggled with each update the corresponding input data | BOOLEAN | RO | 0x00 (0dec)
Index 1801 ENC TxPDO-Par Status Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1801:0 | ENC TxPDO-Par Status Ch.1 | PDO Parameter TxPDO 2 | UINT8 | RO | 0x09 (9dec)
1801:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 2 | OCTET-STRING[2] | RO | 00 1A
1801:09 | TxPDO Toggle | The TxPDO toggle is toggled with each update the corresponding input data | BOOLEAN | RO | 0x00 (0dec)
Index 1803 ENC TxPDO-Par Status compact Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1803:0 | ENC TxPDO-Par Status compact Ch.2 | PDO Parameter TxPDO 4 | UINT8 | RO | 0x09 (9dec)
1803:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 4 | OCTET-STRING[2] | RO | 04 1A
1803:09 | TxPDO Toggle | The TxPDO toggle is toggled with each update the corresponding input data | BOOLEAN | RO | 0x00 (0dec)
Index 1804 ENC TxPDO-Par Status Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1804:0 | ENC TxPDO-Par Status Ch.2 | PDO Parameter TxPDO 5 | UINT8 | RO | 0x09 (9dec)
1804:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 5 | OCTET-STRING[2] | RO | 03 1A
1804:09 | TxPDO Toggle | The TxPDO toggle is toggled with each update the corresponding input data | BOOLEAN | RO | 0x00 (0dec)
Index 180A POS TxPDO-Par Status compact Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
180A:0 | POS TxPDO-Par Status compact Ch.1 | PDO Parameter TxPDO 11 | UINT8 | RO | 0x06 (6dec)
180A:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 11 | OCTET-STRING[2] | RO | 0B 1A
Index 180B POS TxPDO-Par Status Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
180B:0 | POS TxPDO-Par Status Ch.1 | PDO Parameter TxPDO 12 | UINT8 | RO | 0x06 (6dec)
180B:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 12 | OCTET-STRING[2] | RO | 0A 1A
Index 180C POS TxPDO-Par Status compact Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
180C:0 | POS TxPDO-Par Status compact Ch.2 | PDO Parameter TxPDO 13 | UINT8 | RO | 0x06 (6dec)
180C:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 13 | OCTET-STRING[2] | RO | 0D 1A
Index 180D POS TxPDO-Par Status Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
180D:0 | POS TxPDO-Par Status Ch.2 | PDO Parameter TxPDO 14 | UINT8 | RO | 0x06 (6dec)
180D:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 14 | OCTET-STRING[2] | RO | 0C 1A
Index 1A00 ENC TxPDO-Map Status compact Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A00:0 | ENC TxPDO-Map Status compact Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x11 (17dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A00:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6000:0D, 1
1A00:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A00:0E | SubIndex 014 | 14. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A00:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1800 (ENC TxPDO-Par Status compact Ch.1), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1800:09, 1
1A00:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 16
1A00:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 16
Index 1A01 ENC TxPDO-Map Status Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A01:0 | ENC TxPDO-Map Status Ch.1 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x11 (17dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A01:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6000:0D, 1
1A01:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A01:0E | SubIndex 014 | 14. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A01:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1801 (ENC TxPDO-Par Status Ch.1), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1801:09, 1
1A01:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
1A01:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 32
Index 1A02 ENC TxPDO-Map Timest. compact Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A02:0 | ENC TxPDO-Map Timest. compact Ch.1 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x01 (1dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x16 (Timestamp)) | UINT32 | RO | 0x6000:16, 32
Index 1A03 ENC TxPDO-Map Status compact Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A03:0 | ENC TxPDO-Map Status compact Ch.2 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x11 (17dec)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6010:02, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6010:03, 1
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6010:04, 1
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6010:05, 1
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A03:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6010:08, 1
1A03:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6010:09, 1
1A03:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6010:0A, 1
1A03:0A | SubIndex 010 | 10. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A03:0B | SubIndex 011 | 11. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A03:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6010:0D, 1
1A03:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A03:0E | SubIndex 014 | 14. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A03:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1803 (ENC TxPDO-Par Status compact Ch.2), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1803:09, 1
1A03:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x11 (Counter value)) | UINT32 | RO | 0x6010:11, 16
1A03:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x12 (Latch value)) | UINT32 | RO | 0x6010:12, 16
Index 1A04 ENC TxPDO-Map Status Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A04:0 | ENC TxPDO-Map Status Ch.2 | PDO Mapping TxPDO 5 | UINT8 | RO | 0x11 (17dec)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6010:02, 1
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6010:03, 1
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6010:04, 1
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6010:05, 1
1A04:06 | SubIndex 006 | 6. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A04:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6010:08, 1
1A04:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6010:09, 1
1A04:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6010:0A, 1
1A04:0A | SubIndex 010 | 10. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A04:0B | SubIndex 011 | 11. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A04:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6010:0D, 1
1A04:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A04:0E | SubIndex 014 | 14. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A04:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1804 (ENC TxPDO-Par Status Ch.2), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1804:09, 1
1A04:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x11 (Counter value)) | UINT32 | RO | 0x6010:11, 32
1A04:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x12 (Latch value)) | UINT32 | RO | 0x6010:12, 32
Index 1A05 ENC TxPDO-Map Timest. compact Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A05:0 | ENC TxPDO-Map Timest. compact Ch.2 | PDO Mapping TxPDO 6 | UINT8 | RO | 0x01 (1dec)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x16 (Timestamp)) | UINT32 | RO | 0x6010:16, 32
Index 1A06 DCM TxPDO-Map Status Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A06:0 | DCM TxPDO-Map Status Ch.1 | PDO Mapping TxPDO 7 | UINT8 | RO | 0x0E (14dec)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x01 (Ready to enable)) | UINT32 | RO | 0x6020:01, 1
1A06:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x02 (Ready)) | UINT32 | RO | 0x6020:02, 1
1A06:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x03 (Warning)) | UINT32 | RO | 0x6020:03, 1
1A06:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x04 (Error)) | UINT32 | RO | 0x6020:04, 1
1A06:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x05 (Moving positive)) | UINT32 | RO | 0x6020:05, 1
1A06:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x06 (Moving negative)) | UINT32 | RO | 0x6020:06, 1
1A06:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x07 (Torque reduced)) | UINT32 | RO | 0x6020:07, 1
1A06:08 | SubIndex 008 | 8. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A06:09 | SubIndex 009 | 9. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1A06:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x0C (Digital input 1)) | UINT32 | RO | 0x6020:0C, 1
1A06:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x0D (Digital input 2)) | UINT32 | RO | 0x6020:0D, 1
1A06:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A06:0D | SubIndex 013 | 13. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A06:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1806, entry 0x09) | UINT32 | RO | 0x1806:09, 1
Index 1A07 DCM TxPDO-Map Synchron info data Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A07:0 | DCM TxPDO-Map Synchron info data Ch.1 | PDO Mapping TxPDO 8 | UINT8 | RO | 0x02 (2dec)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x11 (Info data 1)) | UINT32 | RO | 0x6020:11, 16
1A07:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x12 (Info data 2)) | UINT32 | RO | 0x6020:12, 16
Index 1A08 DCM TxPDO-Map Status Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A08:0 | DCM TxPDO-Map Status Ch.2 | PDO Mapping TxPDO 9 | UINT8 | RO | 0x0E (14dec)
1A08:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x01 (Ready to enable)) | UINT32 | RO | 0x6030:01, 1
1A08:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x02 (Ready)) | UINT32 | RO | 0x6030:02, 1
1A08:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x03 (Warning)) | UINT32 | RO | 0x6030:03, 1
1A08:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x04 (Error)) | UINT32 | RO | 0x6030:04, 1
1A08:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x05 (Moving positive)) | UINT32 | RO | 0x6030:05, 1
1A08:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x06 (Moving negative)) | UINT32 | RO | 0x6030:06, 1
1A08:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x07 (Torque reduced)) | UINT32 | RO | 0x6030:07, 1
1A08:08 | SubIndex 008 | 8. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A08:09 | SubIndex 009 | 9. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1A08:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x0C (Digital input 1)) | UINT32 | RO | 0x6030:0C, 1
1A08:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x0D (Digital input 2)) | UINT32 | RO | 0x6030:0D, 1
1A08:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A08:0D | SubIndex 013 | 13. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A08:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1808, entry 0x09) | UINT32 | RO | 0x1808:09, 1
Index 1A09 DCM TxPDO-Map Synchron info data Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A09:0 | DCM TxPDO-Map Synchron info data Ch.2 | PDO Mapping TxPDO 10 | UINT8 | RO | 0x02 (2dec)
1A09:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x11 (Info data 1)) | UINT32 | RO | 0x6030:11, 16
1A09:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x12 (Info data 2)) | UINT32 | RO | 0x6030:12, 16
Index 1A0A POS TxPDO-Map Status compact Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A0A:0 | POS TxPDO-Map Status compact Ch.1 | PDO Mapping TxPDO 11 | UINT8 | RO | 0x09 (9dec)
1A0A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6040 (POS Inputs Ch.1), entry 0x01 (Busy)) | UINT32 | RO | 0x6040:01, 1
1A0A:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6040 (POS Inputs Ch.1), entry 0x02 (In-Target)) | UINT32 | RO | 0x6040:02, 1
1A0A:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6040 (POS Inputs Ch.1), entry 0x03 (Warning)) | UINT32 | RO | 0x6040:03, 1
1A0A:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6040 (POS Inputs Ch.1), entry 0x04 (Error)) | UINT32 | RO | 0x6040:04, 1
1A0A:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6040 (POS Inputs Ch.1), entry 0x05 (Calibrated)) | UINT32 | RO | 0x6040:05, 1
1A0A:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6040 (POS Inputs Ch.1), entry 0x06 (Accelerate)) | UINT32 | RO | 0x6040:06, 1
1A0A:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6040 (POS Inputs Ch.1), entry 0x07 (Decelerate)) | UINT32 | RO | 0x6040:07, 1
1A0A:08 | SubIndex 008 | 8. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A0A:09 | SubIndex 009 | 9. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1A0B POS TxPDO-Map Status Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A0B:0 | POS TxPDO-Map Status Ch.1 | PDO Mapping TxPDO 12 | UINT8 | RO | 0x0C (12dec)
1A0B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6040 (POS Inputs Ch.1), entry 0x01 (Busy)) | UINT32 | RO | 0x6040:01, 1
1A0B:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6040 (POS Inputs Ch.1), entry 0x02 (In-Target)) | UINT32 | RO | 0x6040:02, 1
1A0B:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6040 (POS Inputs Ch.1), entry 0x03 (Warning)) | UINT32 | RO | 0x6040:03, 1
1A0B:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6040 (POS Inputs Ch.1), entry 0x04 (Error)) | UINT32 | RO | 0x6040:04, 1
1A0B:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6040 (POS Inputs Ch.1), entry 0x05 (Calibrated)) | UINT32 | RO | 0x6040:05, 1
1A0B:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6040 (POS Inputs Ch.1), entry 0x06 (Accelerate)) | UINT32 | RO | 0x6040:06, 1
1A0B:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6040 (POS Inputs Ch.1), entry 0x07 (Decelerate)) | UINT32 | RO | 0x6040:07, 1
1A0B:08 | SubIndex 008 | 8. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A0B:09 | SubIndex 009 | 9. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1A0B:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6040 (POS Inputs Ch.1), entry 0x11 (Actual position)) | UINT32 | RO | 0x6040:11, 32
1A0B:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6040 (POS Inputs Ch.1), entry 0x21 (Actual velocity)) | UINT32 | RO | 0x6040:21, 16
1A0B:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6040 (POS Inputs Ch.1), entry 0x22 (Actual drive time)) | UINT32 | RO | 0x6040:22, 32
Index 1A0C POS TxPDO-Map Status compact Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A0C:0 | POS TxPDO-Map Status compact Ch.2 | PDO Mapping TxPDO 13 | UINT8 | RO | 0x09 (9dec)
1A0C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6050 (POS Inputs Ch.2), entry 0x01 (Busy)) | UINT32 | RO | 0x6050:01, 1
1A0C:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6050 (POS Inputs Ch.2), entry 0x02 (In-Target)) | UINT32 | RO | 0x6050:02, 1
1A0C:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6050 (POS Inputs Ch.2), entry 0x03 (Warning)) | UINT32 | RO | 0x6050:03, 1
1A0C:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6050 (POS Inputs Ch.2), entry 0x04 (Error)) | UINT32 | RO | 0x6050:04, 1
1A0C:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6050 (POS Inputs Ch.2), entry 0x05 (Calibrated)) | UINT32 | RO | 0x6050:05, 1
1A0C:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6050 (POS Inputs Ch.2), entry 0x06 (Accelerate)) | UINT32 | RO | 0x6050:06, 1
1A0C:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6050 (POS Inputs Ch.2), entry 0x07 (Decelerate)) | UINT32 | RO | 0x6050:07, 1
1A0C:08 | SubIndex 008 | 8. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A0C:09 | SubIndex 009 | 9. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1A0D POS TxPDO-Map Status Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A0D:0 | POS TxPDO-Map Status Ch.2 | PDO Mapping TxPDO 14 | UINT8 | RO | 0x0C (12dec)
1A0D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6050 (POS Inputs Ch.2), entry 0x01 (Busy)) | UINT32 | RO | 0x6050:01, 1
1A0D:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6050 (POS Inputs Ch.2), entry 0x02 (In-Target)) | UINT32 | RO | 0x6050:02, 1
1A0D:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6050 (POS Inputs Ch.2), entry 0x03 (Warning)) | UINT32 | RO | 0x6050:03, 1
1A0D:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6050 (POS Inputs Ch.2), entry 0x04 (Error)) | UINT32 | RO | 0x6050:04, 1
1A0D:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6050 (POS Inputs Ch.2), entry 0x05 (Calibrated)) | UINT32 | RO | 0x6050:05, 1
1A0D:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6050 (POS Inputs Ch.2), entry 0x06 (Accelerate)) | UINT32 | RO | 0x6050:06, 1
1A0D:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6050 (POS Inputs Ch.2), entry 0x07 (Decelerate)) | UINT32 | RO | 0x6050:07, 1
1A0D:08 | SubIndex 008 | 8. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A0D:09 | SubIndex 009 | 9. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1A0D:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6050 (POS Inputs Ch.2), entry 0x11 (Actual position)) | UINT32 | RO | 0x6050:11, 32
1A0D:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6050 (POS Inputs Ch.2), entry 0x21 (Actual velocity)) | UINT32 | RO | 0x6050:21, 16
1A0D:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6050 (POS Inputs Ch.2), entry 0x22 (Actual drive time)) | UINT32 | RO | 0x6050:22, 32
Index 1C00 Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the sync managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x06 (6dec)
1C12:01 | SubIndex 001 | 1. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1600 (5632dec)
1C12:02 | SubIndex 002 | 2. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1602 (5634dec)
1C12:03 | SubIndex 003 | 3. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1604 (5636dec)
1C12:04 | SubIndex 004 | 4. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1606 (5638dec)
1C12:05 | SubIndex 005 | 5. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1607 (5639dec)
1C12:06 | SubIndex 006 | 6. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1609 (5641dec)
Index 1C13 TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x04 (4dec)
1C13:01 | SubIndex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | SubIndex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A03 (6659dec)
1C13:03 | SubIndex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A06 (6662dec)
1C13:04 | SubIndex 004 | 4. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A08 (6664dec)
1C13:05 | SubIndex 005 | 5. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C32:06 | SubIndex 006 | 6. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:07 | SubIndex 007 | 7. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:08 | SubIndex 008 | 8. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:09 | SubIndex 009 | 9. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0A | SubIndex 010 | 10. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 1C32 SM output parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C32:0
SM output parameter
Synchronization parameters for the outputs
UINT8
RO
0x20 (32dec)
1C32:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchronous with SM 2 event
▪
2: DC-Mode - Synchronous with SYNC0 Event
▪
3: DC-Mode - Synchronous with SYNC1 event
UINT16
RW
0x0001 (1dec)
1C32:02
Cycle time
Cycle time (in ns):
▪
Free Run: Cycle time of the local timer
▪
Synchron with SM 2 Event: Master cycle time
▪
DC mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dec)
1C32:03
Shift time
Time between SYNC0 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0 = 1: free run is supported
▪
Bit 1 = 1: Synchron with SM 2 event is supported
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 10: Output shift with SYNC1 event (only DC mode)
▪
Bit 14 = 1: dynamic times (measurement through writing of 1C32:08)
UINT16
RO
0xC007 (49159dec)
1C32:05
Minimum cycle time
Minimum cycle time (in ns)
UINT32
RO
0x0003D090 (250000dec)
1C32:06
Calc and copy time
Minimum time between SYNC0 and SYNC1 event (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:07
Minimum delay time
UINT32
RO
0x00000000 (0dec)
1C32:08
Command
▪
0: Measurement of the local cycle time is stopped
▪
1: Measurement of the local cycle time is started
The entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 are updated with the maximum measured values.
For a subsequent measurement the measured values are reset
UINT16
RW
0x0000 (0dec)
1C32:09
Maximum delay time
Time between SYNC1 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:0B
SM event missed counter
Number of missed SM events in OPERATIONAL (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:0C
Cycle exceeded counter
Number of occasions the cycle time was exceeded in OPERATIONAL (cycle was not completed in time or the next cycle began too early)
UINT16
RO
0x0000 (0dec)
1C32:0D
Shift too short counter
Number of occasions that the interval between SYNC0 and SYNC1 event was too short (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:20
Sync error
The synchronization was not correct in the last cycle (outputs were output too late; DC mode only)
BOOLEAN
RO
0x00 (0dec)
Index 1C33 SM input parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (no outputs available)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (outputs available)
UINT16
RW
0x0022 (34dec)
1C33:02
Cycle time
as 0x1C32:02
UINT32
RW
0x000F4240 (1000000dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: Synchronous with SM 2 Event is supported (outputs available)
▪
Bit 1: Synchronous with SM 3 Event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: input shift through local event (outputs available)
▪
Bit 4-5 = 10: input shift with SYNC1 event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08 or 0x1C33:08)
UINT16
RO
0xC007 (49159dec)
1C33:05
Minimum cycle time
as 0x1C32:05
UINT32
RO
0x0003D090 (250000dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:07
Minimum delay time
UINT32
RO
0x00000000 (0dec)
1C33:08
Command
as 1C32:08
UINT16
RW
0x0000 (0dec)
1C33:09
Maximum delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:0B
SM event missed counter
as 0x1C32:11
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
as 0x1C32:12
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
as 0x1C32:13
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
as 0x1C32:32
BOOLEAN
RO
0x00 (0dec)
Index F000 Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0006 (6dec)
Index F008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module list
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list | Max. Subindex | UINT8 | RW | 0x06 (6dec)
F010:01 | SubIndex 001 | Profile number of the encoder interface | UINT32 | RW | 0x000001FF (511dec)
F010:02 | SubIndex 002 | Profile number of the encoder interface | UINT32 | RW | 0x000001FF (511dec)
F010:03 | SubIndex 003 | Profile number of the DC motor interface | UINT32 | RW | 0x000002DD (733dec)
F010:04 | SubIndex 004 | Profile number of the DC motor interface | UINT32 | RW | 0x000002DD (733dec)
F010:05 | SubIndex 005 | Profile number of the positioning interface | UINT32 | RW | 0x000002C0 (704dec)
F010:06 | SubIndex 006 | Profile number of the positioning interface | UINT32 | RW | 0x000002C0 (704dec)


Appendix

Appendix
Appendix
Additional information
•
General operating conditions
•
Accessories
•
Version identification of EtherCAT devices
•
Support and Service


General operating conditions

Appendix [image] General operating conditions
General operating conditions
Protection degrees (IP-Code)
The standard IEC 60529 (DIN EN 60529) defines the degrees of protection in different classes.
1. Number: dust protection and touch guard | Definition
0 | Non-protected
1 | Protected against access to hazardous parts with the back of a hand. Protected against solid foreign objects of Ø 50 mm
2 | Protected against access to hazardous parts with a finger. Protected against solid foreign objects of Ø 12.5 mm.
3 | Protected against access to hazardous parts with a tool. Protected against solid foreign objects Ø 2.5 mm.
4 | Protected against access to hazardous parts with a wire. Protected against solid foreign objects Ø 1 mm.
5 | Protected against access to hazardous parts with a wire. Dust-protected. Intrusion of dust is not totally prevented, but dust shall not penetrate in a quantity to interfere with satisfactory operation of the device or to impair safety.
6 | Protected against access to hazardous parts with a wire. Dust-tight. No intrusion of dust.
2. Number: water* protection | Definition
0 | Non-protected
1 | Protected against water drops
2 | Protected against water drops when enclosure tilted up to 15°.
3 | Protected against spraying water. Water sprayed at an angle up to 60° on either side of the vertical shall have no harmful effects.
4 | Protected against splashing water. Water splashed against the disclosure from any direction shall have no harmful effects
5 | Protected against water jets
6 | Protected against powerful water jets
7 | Protected against the effects of temporary immersion in water. Intrusion of water in quantities causing harmful effects shall not be possible when the enclosure is temporarily immersed in water for 30 min. in 1 m depth.
*) These protection classes define only protection against water!
Chemical Resistance
The Resistance relates to the Housing of the IP 67 modules and the used metal parts. In the table below you will find some typical resistance.
Character | Resistance
Steam | at temperatures >100°C: not resistant
Sodium base liquor (ph-Value > 12) | at room temperature: resistant > 40°C: not resistant
Acetic acid | not resistant
Argon (technical clean) | resistant
Key
▪
resistant: Lifetime several months
▪
non inherently resistant: Lifetime several weeks
▪
not resistant: Lifetime several hours resp. early decomposition


Accessories

Appendix [image] Accessories
Accessories
Additional information
•
Motor cables
•
Encoder cables


Motor cables

Appendix [image] Accessories [image] Motor cables
Motor cables
ZK4000-6100-0xxx
4 x 0.5 mm², M12 plug – open end
Use:
▪
Motor cable
▪
Motor supply cable
ZK4000-6100- | 2005 | 2010 | 2020 | 2050 | 2100
Length | 0.5 m | 1.0 m | 2.0 m | 5.0 m | 10.0 m
ZK4000-6200-0xxx
4 x 0.5 mm², M12 socket – open end
Use:
▪
Cable for feeding in the motor supply in EP7041-2002 and EP7041-3002
▪
Motor cable for stepper motor AS1010, AS1020, AS1030, AS1050 or AS1060
on stepper motor terminals from the series ELxxxx (E-bus) or KLxxxx (K-bus)
ZK4000-6200- | 2005 | 2010 | 2020 | 2050 | 2100
Length | 0.5 m | 1.0 m | 2.0 m | 5.0 m | 10.0 m


Encoder cables

Appendix [image] Accessories [image] Encoder cables
Encoder cables
ZK4000-5151-0xxx
4 x 0.35 mm², shielded, preassembled at both ends
Use:
▪
Encoder cable for stepper motor AS1020, AS1050 or AS1060
ZK4000-5151- | 2005 | 2010 | 2020
Length | 0.5 m | 1.0 m | 2.0 m
ZK4000-5100-2xxx
4 x 0.35 mm², shielded, M12 socket – open end
Use:
▪
Encoder cable for other encoders
ZK4000-5100- | 2005 | 2010 | 2020 | 2050 | 2100
Length | 0.5 m | 1.0 m | 2.0 m | 5.0 m | 10.0 m


Version identification of EtherCAT devices

Appendix [image] Version identification of EtherCAT devices
Version identification of EtherCAT devices
Designation
A Beckhoff EtherCAT device has a 14-digit designation, made up of
▪
family key
▪
type
▪
version
▪
revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
Notes
▪
The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
▪
EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
▪
The order identifier is made up of
- family key (EL, EP, CU, ES, KL, CX, etc.)
- type (3314)
- version (-0000)
▪
The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
▪
The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Identification number
Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:
Production lot/batch number/serial number/date code/D number
The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02
Exceptions can occur in the IP67 area, where the following syntax can be used (see respective device documentation):
Syntax: D ww yy x y z u
D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB
Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1
Unique serial number/ID, ID number
In addition, in some series each individual module has its own unique serial number.
See also the further documentation in the area
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Terminals with factory calibration certificate and other measuring terminals
Examples of markings
EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
CU2016 switch with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
EP1258-00001 IP67 EtherCAT Box with batch number/ date code 22090101 and unique serial number 158102
EP1908-0002 IP67 EtherCAT Safety Box with batch number/ date code 071201FF and unique serial number 00346070
EL2904 IP20 safety terminal with batch number/ date code 50110302 and unique serial number 00331701
ELM3604-0002 terminal with unique ID number (QR code) 100001051 and serial/ batch number 44160201
Additional information
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Appendix [image] Version identification of EtherCAT devices [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com