EP7211-0034 - Servomotormodul mit OCT
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
1.4
▪
Front page updated
1.3
▪
Ordering information for motor connecting cables added
▪
Pin assignment of the connectors for touch probes updated
▪
CoE object 6010 updated
1.2
▪
Link to STO application example added
▪
Corrections
1.1
▪
Removed variant -9034
1.0
▪
Erste Veröffentlichung
0.4
▪
First release
0.3
▪
Updates
0.2
▪
Technical data updated
0.1
▪
First draft
Firmware and hardware versions
This documentation refers to the firmware and hardware version that was applicable at the time the documentation was written.
The module features are continuously improved and developed further. Modules having earlier production statuses cannot have the same properties as modules with the latest status. However, existing properties are retained and are not changed, so that older modules can always be replaced with new ones.
The firmware and hardware version (delivery state) can be found in the batch number (D-number) printed on the side of the EtherCAT Box.
Syntax of the batch number (D-number)
D: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with D no. 29 10 02 01:
29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01
Further information on this topic: Version identification of EtherCAT devices.


Product overview

Product overview
Product overview
Additional information
•
EtherCAT Box - Introduction
•
EP7211-0034 - Introduction
•
Technical data
•
Scope of supply
•
Technology


EtherCAT Box - Introduction

Product overview [image] EtherCAT Box - Introduction
EtherCAT Box - Introduction
The EtherCAT system has been extended with EtherCAT Box modules with protection class IP 67. Through the integrated EtherCAT interface the modules can be connected directly to an EtherCAT network without an additional Coupler Box. The high-performance of EtherCAT is thus maintained into each module.
The extremely low dimensions of only 126 x 30 x 26.5 mm (h x w x d) are identical to those of the Fieldbus Box extension modules. They are thus particularly suitable for use where space is at a premium. The small mass of the EtherCAT modules facilitates applications with mobile I/O interface (e.g. on a robot arm). The EtherCAT connection is established via screened M8 connectors.
EtherCAT Box Modules within an EtherCAT network
The robust design of the EtherCAT Box modules enables them to be used directly at the machine. Control cabinets and terminal boxes are now no longer required. The modules are fully sealed and therefore ideally prepared for wet, dirty or dusty conditions.
Pre-assembled cables significantly simplify EtherCAT and signal wiring. Very few wiring errors are made, so that commissioning is optimized. In addition to pre-assembled EtherCAT, power and sensor cables, field-configurable connectors and cables are available for maximum flexibility. Depending on the application, the sensors and actuators are connected through M8 or M12 connectors.
The EtherCAT modules cover the typical range of requirements for I/O signals with protection class IP67:
▪
digital inputs with different filters (3.0 ms or 10 μs)
▪
digital outputs with 0.5 or 2 A output current
▪
analog inputs and outputs with 16 bit resolution
▪
Thermocouple and RTD inputs
▪
Stepper motor modules
XFC (eXtreme Fast Control Technology) modules, including inputs with time stamp, are also available.
EtherCAT Box with M8 connections for sensors/actuators
EtherCAT Box with M12 connections for sensors/actuators
Basic EtherCAT documentation
You will find a detailed description of the EtherCAT system in the Basic System Documentation for EtherCAT, which is available for download from our website (www.beckhoff.com) under Downloads.
EtherCAT XML Device Description
You will find XML files (XML Device Description Files) for Beckhoff EtherCAT modules on our website (www.beckhoff.com) under Downloads, in the Configuration Files area.


EP7211-0034 - Introduction

Product overview [image] EP7211-0034 - Introduction
EP7211-0034 - Introduction
EP7211-0034 Website Inventarbild
EP7211-0034
The EP7211-0034 EtherCAT Box is a single-channel servo drive for synchronous servomotors with OCT feedback system.
It is intended for operation with motors from the AM81xx series. These motors have an electronic identification plate. EP7211-0034 can read the electronic identification plate in order to set the motor parameters in TwinCAT automatically.
Process-side interfaces of EP7211-0034:
▪
Motor
▪
Motor brake
▪
OCT communication:
–
Feedback
–
Electronic identification plate readout
▪
2 x touch probe
▪
Hardware Enable: digital input for activating the output stage
The motor is connected via a hybrid cable. The hybrid cable contains the wires for the motor phases, the brake and the OCT communication.
Using the EP7211-0034 together with an EL2904, an STO function complying with EN 61800-5-2 can be implemented in accordance with the application example.
The user bears the responsibility for the safety evaluation in case of deviation from the application example.


Technical data

Product overview [image] Technical data
Technical data
Technical data
EP7211-0034
Fieldbus
Fieldbus
EtherCAT
Connection
2 x M8 socket (green)
Electrical isolation
500 V (fieldbus / IO)
Distributed clocks
yes
Process image
Dependent on the operation mode
Supply voltages
Connection
Feed:
1 x 7/8" plug, 5-pin, max. 16 A for each US/UP
Downstream connection:
1 x 7/8" socket, 5-pin, max. 16 A for each US/UP
Control voltage US
24 VDC (-15 % / +20 %)
DC link supply voltage UP
48 VDC (8…50 VDC), not protected against polarity reversal
Supply of the module electronics
from the control voltage US
Current consumption of the module
electronics
typ. 120 mA
Current consumption from the
DC link supply voltage
typ. 50 mA
Motor
Motor type
Synchronous servomotor
Connection
1 x iTec socket, 9-pin, M23
Hybrid connector for:
▪
1 x motor
▪
1 x feedback (OCT encoder)
▪
1 x brake
Power rating Pn
max. 276 W
Nominal output current In
4.5 Aeff
Peak output current Ipeak
9.0 Aeff for 1 s
Output frequency range
0…599 Hz
PWM clock frequency
16 kHz
Current controller frequency
32 kHz
Speed controller frequency
16 kHz
Drive profile
Alternatively:
▪
MDP 742 (default)
▪
CiA DS402
Motor brake
Output voltage
24 VDC from the control voltage US
Output current
max. 0.5 A, short-circuit protected
Digital input “Hardware enable”
Signal voltage „1“
10…30 VDC
Digital inputs “Touch probe”
Number
2
Technical data | EP7211-0034
Environmental conditions
Permissible ambient temperature during operation | -25°C ... +60°C
Permissible ambient temperature during storage | -40°C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
EMC category | Category C3 (auxiliary filter required) Category C2, C1 in preparation (auxiliary filter required)
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Mechanics
Dimensions | 150 mm x 60 mm x 26.5 mm (without plug connectors)
Weight | approx. 500 g
Installation position | variable
Approvals and conformity
Approvals | CE, UL in preparation
Also see about this
•
Drive profiles
•
Operation modes
•
Connectors
•
Connector


Scope of supply

Product overview [image] Scope of supply
Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EtherCAT Box EP7211-0034
▪
2x protective caps for EtherCAT socket (mounted)
▪
1x protective cap for 7/8" socket (mounted)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


Technology

Product overview [image] Technology
Technology
Servomotor
The servomotor is an electrical motor. Together with a servo drive the servomotor forms a drive. The servomotor is operated in a closed control loop with position, torque or speed control.
EP7211-0034 supports control of permanent magnet synchronous motors. These consist of 3 coils which are offset by 120° and a permanent magnet rotor.
Three synchronous motor coils, each offset by 120°
One Cable Technology (OCT)
In the servomotors from the AM8100-xF2 x series the feedback signals are transmitted directly via the power supply cable, so that power and feedback system are combined in a single motor connection cable. With the use of the One Cable technology, the information is sent reliably and without interference through a digital interface. Since a cable and plug are omitted at both the motor and controller end, the component and commissioning costs are reduced.
Thermal I²T motor model
The thermal I²T motor model represents the thermal behavior of the motor winding taking into account the absolute thermal resistance Rth and the thermal capacity Cth of motor and the stator winding.
The model assumes that the motor reaches its maximum continuous operating temperature Tnom during continuous operation with rated current Inom. This temperature corresponds to 100% motor load. During operation at rated current the motor model reaches a load of 63% after a time of τth=Rth∙Cth and slowly reaches its continuous operating temperature.
If the motor is operated with a current that is greater than the rated current, the model reaches 100% load more quickly.
If the load of the I²T model exceeds 100%, the requested set current is limited to the rated current, in order to protect the motor winding thermally. The load reduces to a maximum of 100%. If the current falls below the rated current, the load falls below 100% and the set current limitation is cancelled.
For a motor that has been cooled to ambient temperature, the time for reaching 100% load with a set current that exceeds the rated current can be estimated with τth∙Inom²/Iactual².
The actual load must be known for exact calculation of the time when the 100% load threshold is exceeded.
Limitation to the rated motor current


Mounting and cabling

Mounting and cabling
Mounting and cabling
Additional information
•
Mounting
•
Cabling


Mounting

Mounting and cabling [image] Mounting
Mounting
Additional information
•
Dimensions
•
Fixing
•
Functional earth (FE)


Dimensions

Mounting and cabling [image] Mounting [image] Dimensions
Dimensions
Dimensions
All dimensions are given in millimeters.
Housing features
Housing material | PA6 (polyamide)
Sealing compound | polyurethane
Mounting | two fastening holes Ø 4.5 mm for M4
Metal parts | brass, nickel-plated
Contacts | CuZn, gold-plated
Power feed through | max. 16 A at 40°C (according to IEC 60512-3)
Installation position | variable
Protection class | IP65, IP66, IP67 (conforms to EN 60529) when screwed together
Dimensions (H x W x D) | approx. 150 x 60 x 26.5 mm (without connectors)


Fixing

Mounting and cabling [image] Mounting [image] Fixing
Fixing
Note
Dirt during assembly
Dirty connectors can lead to malfunctions. Protection class IP67 can only be guaranteed if all cables and connectors are connected.
•
Protect the plug connectors against dirt during the assembly.
Mount the module with two M4 screws in the centrally located fastening holes.


Functional earth (FE)

Mounting and cabling [image] Mounting [image] Functional earth (FE)
Functional earth (FE)
All existing connections for the functional earth must be connected to earth:
▪
Fastening holes
▪
"FE" cores in the supply cables
Functional earth via the fastening holes
The fastening holes also serve as connections for the functional earth (FE).
Make sure that the box is earthed with low impedance via both fastening screws.
FE connection via fastening holes
Functional earth via the fastening holes
Functional earth via the supply lines
The pins of the supply connectors marked with "FE" are directly connected to the functional earth potential of the fastening holes.
Connect the functional earth of the "FE" cores in accordance with the following instructions:
▪
If the remote station is a device with a 7/8" connector: connect the devices with a pre-configured cable. Possible types of preconfigured cables:
–
Beckhoff ZK2030-1112-0xxx
–
Beckhoff ZK2030-1114-0xxx
–
Beckhoff ZK2030-1314-0xxx
▪
Otherwise: Earth the "FE" core with low impedance as near as possible to the remote station.


Cabling

Mounting and cabling [image] Cabling
Cabling
EP7211 connector designations
Connector overview
Name | Connector type | Tightening torque | Function
X01 | M12 | 0.6 Nm 1) | Hardware Enable HWE
X02
X03 | M12 | 0.6 Nm 1) | Touch Probe
X04
X20 | iTec M23 | - | Motor, brake and feedback system
X40 | M8 | 0.4 Nm 1) | EtherCAT
X41
X60 | 7/8" | 1.5 Nm | Power supply
X61
1) Mount connectors on these plug connectors using a torque wrench, e.g. ZB8801 from Beckhoff.
Protective caps
▪
Seal unused connectors with protective caps.
▪
Ensure the correct seating of pre-assembled protective caps.
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Additional information
•
Power supply
•
EtherCAT
•
Motor, brake and feedback system
•
Hardware Enable HWE
•
Touch Probe


Power supply

Mounting and cabling [image] Cabling [image] Power supply
Power supply
Additional information
•
Connectors
•
Status LEDs
•
Conductor losses


Connectors

Mounting and cabling [image] Cabling [image] Power supply [image] Connectors
Connectors
Two 7/8" connectors at the low-end of the modules are used for feeding and routing the supply voltages:
▪
"IN" (male): left connector for feeding the supply voltages
▪
"OUT" (female): right connector for downstream connection
7/8 Zoll In+Out Kontaktbelegung
7/8" connector pin assignment
Note Defect possible through polarity reversal. The input for the DC link voltage Up is not protected against polarity reversal. Ensure that the polarity is correct.
Pin | Name | Comment | Core colors 1)
1 | GNDP | GND to UP | Black
2 | GNDS | GND to US | Blue
3 | FE | Functional earth | Grey
4 | +24 VDC US | Control voltage US | Brown
5 | +48 VDC UP | DC link voltage UP | White
1) The core colors apply to cables of the type: Beckhoff ZK203x-xxxx.


Status LEDs

Mounting and cabling [image] Cabling [image] Power supply [image] Status LEDs
Status LEDs
The status of the supply voltages is signaled by two LEDs. A Status LED lights up green when the respective supply voltage is present on the connector for the supply.
Power supply Status LEDs


Conductor losses

Mounting and cabling [image] Cabling [image] Power supply [image] Conductor losses
Conductor losses
Take into account the voltage drop on the supply line when planning a system. Avoid the voltage drop being so high that the supply voltage at the box lies below the minimum nominal voltage.
Variations in the voltage of the power supply unit must also be taken into account.
Voltage drop on the supply line
Leitungsverluste 7/8" 2A
Leitungsverluste 7/8" 4A


EtherCAT

Mounting and cabling [image] Cabling [image] EtherCAT
EtherCAT
Additional information
•
Connectors
•
Status LEDs


Connectors

Mounting and cabling [image] Cabling [image] EtherCAT [image] Connectors
Connectors
Note
Risk of confusion: supply voltages and EtherCAT
Defect possible through incorrect insertion.
•
Observe the color coding of the connectors:
black: Supply voltages
green: EtherCAT
EtherCAT Box Modules have two green M8 sockets for the incoming and downstream EtherCAT connections.
EtherCAT connectors
Connection
M8 socket, 4-pin – connection
M8 socket
EtherCAT | M8 connector | Core colors
Signal | Contact | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 and old versions of ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | 1 | yellow1) | orange/white | white/orange
Tx - | 4 | orange1) | orange | orange
Rx + | 2 | white1) | blue/white | white/green
Rx - | 3 | blue1) | blue | green
Shield | Housing | Shield | Shield | Shield
1) Core colors according to EN 61918
Adaptation of core colors for cables ZB9030, ZB9032 and ZK1090-3xxxx-xxxx
For standardization, the core colors of the ZB9030, ZB9032 and ZK1090-3xxx-xxxx cables have been changed to the EN61918 core colors: yellow, orange, white, blue. So there are different color codes in circulation. The electrical properties of the cables have been retained when the core colors were changed.


Status LEDs

Mounting and cabling [image] Cabling [image] EtherCAT [image] Status LEDs
Status LEDs
EtherCAT Status LEDs
L/A (Link/Act)
A green LED labelled "L/A" is located next to each EtherCAT socket. The LED indicates the communication state of the respective socket:
LED | Meaning
off | no connection to the connected EtherCAT device
lit | LINK: connection to the connected EtherCAT device
flashes | ACT: communication with the connected EtherCAT device
Run
Each EtherCAT slave has a green LED labelled "Run". The LED signals the status of the slave in the EtherCAT network:
LED | Meaning
off | Slave is in "Init" state
flashes uniformly | Slave is in "Pre-Operational“ state
flashes sporadically | Slave is in "Safe-Operational" state
lit | Slave is in "Operational" state
Description of the EtherCAT slave states


Motor, brake and feedback system

Mounting and cabling [image] Cabling [image] Motor, brake and feedback system
Motor, brake and feedback system
Additional information
•
Connector
•
Connecting cables
•
Status LEDs


Connector

Mounting and cabling [image] Cabling [image] Motor, brake and feedback system [image] Connector
Connector
iTec socked 9-pin M23 pin pattern 150%
iTec socket pin assignment
Pin | Name | Comment | Core colors1)
1 | Brake + | Motor brake + | Red
2 | Brake - | Motor brake - | Black
3 | OCT + | Data and supply for the OCT feedback system | White
4 | OCT - | Data and supply for the OCT feedback system | Blue
5 | - | - |
A | U | Motor phase U | Black
B | W | Motor phase W | Grey
C | V | Motor phase V | Brown
 | FE, shield | Functional earth, cable shield | green-yellow
1) The core colors apply to the ZK470x-xxxx motor cables from Beckhoff.


Connecting cables

Mounting and cabling [image] Cabling [image] Motor, brake and feedback system [image] Connecting cables
Connecting cables
Beckhoff Automation offers suitable connecting cables with iTec connectors. The following table shows some examples:
Ordering information | Material | Wire gauge | Properties
ZK4701-0401-2xxx | PVC | 0.75 mm2 | For fixed installation
ZK4701-0421-2xxx | PUR | 0.75 mm2 | Highly flexible, drag-chain suitable
ZK4701-0461-2xxx | PUR | 0.75 mm2 | Torsion-resistant for robot applications
The complete product range can be found on our homepage www.beckhoff.com.


Status LEDs

Mounting and cabling [image] Cabling [image] Motor, brake and feedback system [image] Status LEDs
Status LEDs
Status-LEDs der EP7211-9034 (EP7211-9034_LED.PNG)
Status LEDs of the motor connection
LED Displays
LED
Display
Meaning
Drv OK
green illuminated
The driver stage is ready for operation.
Rd OCT
flashing green
The electronic identification plate is being read.
Enable
green
The driver stage is enabled.
The LED is linked with bits 1 and 2 of the Status word1).
Limit
orange
Limit reached (e.g. torque or speed limit).
The LED is linked with bit 11 of the Status word1).
Warning
flashes
Error while reading the electronic identification plate.
orange
Warning. The "Warning" threshold value is exceeded.
Possible reasons:
▪
Motor load (I²T) is higher than 100%
▪
The motor output stage is not activated
▪
Maximum operating temperature exceeded
The LED is linked with bit 7 of the Status word1).
Error
red
Error. The “Error” threshold value is exceeded.
Possible reasons:
▪
Overcurrent
▪
Voltage not available
▪
Feedback not connected
▪
Max. temperature (100 °C) exceeded
The LED is linked with bit 3 of the Status word1).
1) Status word in the CoE directory:
▪
Device profile MDP742 (default)
▪
Device profile DS402


Hardware Enable HWE

Mounting and cabling [image] Cabling [image] Hardware Enable HWE
Hardware Enable HWE
Additional information
•
Connectors
•
Cabling
•
Status LED


Connectors

Mounting and cabling [image] Cabling [image] Hardware Enable HWE [image] Connectors
Connectors
Connect the "Hardware Enable" signal to the X01 or alternatively the X02 socket. The X01 and X02 sockets have the same configuration and are bridged 1:1 inside the box.
M12 socket pin assignment
Pin | Signal | Core colors1)
1 | n.c. | Brown
2 | n.c. | White
3 | n.c. | Blue
4 | Hardware Enable HWE | Black
5 | FE (Functional earth) | Grey
1) The core colors apply to cables of the types ZK2000-5xxx, ZK2000-6xxx and ZK2000-7xxx from Beckhoff.


Cabling

Mounting and cabling [image] Cabling [image] Hardware Enable HWE [image] Cabling
Cabling
The X01 and X02 sockets have the same configuration and are bridged 1:1 inside the box. This makes it possible to forward the signal for "Hardware Enable" from one box to the next.
Sample:
Sample: forwarded HWE signal


Status LED

Mounting and cabling [image] Cabling [image] Hardware Enable HWE [image] Status LED
Status LED
Status LED for HWE
The green LED with the name "HWE" (Hardware Enable) lights when a high level is present on the corresponding pin of X01 or X02.
→ The motor output stage is activated.


Touch Probe

Mounting and cabling [image] Cabling [image] Touch Probe
Touch Probe
Additional information
•
Connector
•
Cabling
•
Status LEDs


Connector

Mounting and cabling [image] Cabling [image] Touch Probe [image] Connector
Connector
Connect touch probes to the sockets X03 and X04. The X03 and X04 sockets have the same configuration and are bridged 1:1 inside the box.
M12 socket pin assignment
Pin | Signal | Core colors1)
1 | US: +24 VDC | Brown
2 | IN B = TP2 | White
3 | GNDS | Blue
4 | IN A = TP1 | Black
5 | FE (Functional earth) | Grey
1) The core colors apply to cables of the types ZK2000-5xxx, ZK2000-6xxx and ZK2000-7xxx from Beckhoff.


Cabling

Mounting and cabling [image] Cabling [image] Touch Probe [image] Cabling
Cabling
The X03 and X04 sockets have the same configuration and are bridged 1:1 inside the box. This enables the touch probes to be wired in two ways:
▪
One common cable (connection to X03 or X04)
Endlagenschalter Verkabelung V1
▪
One cable per touch probe (connection to X03 and X04)
Endlagenschalter Verkabelung V2


Status LEDs

Mounting and cabling [image] Cabling [image] Touch Probe [image] Status LEDs
Status LEDs
LEDs: limit switch
Touch probe Status LEDs
The green LEDs with the names "IN A" and "IN B" light when a high level is present on the corresponding pins of X03 or X04:
▪
IN A = TP1
▪
IN B = TP2


Commissioning

Commissioning
Commissioning
Additional information
•
Activate motor output stage
•
Integration in TwinCAT
•
Start-up and parameter configuration
•
Drive profiles
•
Operation modes
•
Process data MDP 742
•
DS402 process data
•
Object description (MDP 742)
•
Object description (DS402)


Activate motor output stage

Commissioning [image] Activate motor output stage
Activate motor output stage
Activate the motor output stage by applying a high level to the digital input Hardware Enable HWE.


Integration in TwinCAT

Commissioning [image] Integration in TwinCAT
Integration in TwinCAT
The procedure for integration in TwinCAT is described in this Quick start guide.


Start-up and parameter configuration

Commissioning [image] Start-up and parameter configuration
Start-up and parameter configuration
Additional information
•
Integration into the NC configuration
•
Settings with the Drive Manager
•
Settings in the CoE register
•
NC settings
•
Commissioning without NC, status word/control word
•
Settings for the automatic configuration
•
Configure end position monitoring
•
Homing
•
Touch Probe


Integration into the NC configuration

Commissioning [image] Start-up and parameter configuration [image] Integration into the NC configuration
Integration into the NC configuration
(Master: TwinCAT 2.11 R3)
Installation of the latest XML device description
Please ensure that you have installed the corresponding latest XML device description in TwinCAT. This can be downloaded from the Beckhoff Website and installed according to the installation instructions.
Integration into the NC can be accomplished as follows:
▪
The box must already have been added manually under I/O devices or have been scanned in by the system (see section Configuration in TwinCAT).
Adding an axis automatically
▪
TwinCAT detects the new axes automatically once the IO modules have been successfully scanned. The user is asked whether the detected axes should be added
automatically (see Fig. Axis detected). If this is confirmed, all axes are automatically liked to the NC.
Axis detected
▪
Several parameters have to be set before the motor can be started up. The values can be found in the chapter Settings in the CoE register.
Set these parameters before continuing with the motor commissioning.
Adding an axis manually
▪
First add a new task. Right-click on NC configuration and select "Append Task..." (see Fig. Adding a new task).
▪
Rename the task if required and confirm with OK.
Adding a new task
▪
Right-click on Axes, then add a new axis (see Fig. Adding a new axis).
Adding a new axis
▪
Select Continuous Axis type and confirm with OK (see Fig. Selecting and confirming the axis type).
Selecting and confirming the axis type
▪
Left-click your axis to select it. On the Settings tab, select "Link To..." (see Fig. Linking the axis with the box).
Linking the axis with the box
▪
Select the appropriate box (CANopen DS402, EtherCAT CoE) and confirm with "OK".
Selection of the correct box
▪
All main links between the NC configuration and the box are set automatically (see Fig. Automatic linking of all main variables)
Automatic linking of all main variables
▪
Several parameters have to be set before the motor can be started up. The values can be found in the chapters Settings in the CoE register and NC settings.
Set these parameters before continuing with the motor commissioning.


Settings with the Drive Manager

Commissioning [image] Start-up and parameter configuration [image] Settings with the Drive Manager
Settings with the Drive Manager
(Master TwinCAT 2.11 R3)
The data given here serve as an example for a servomotor type AM8131-0F20-0000 from Beckhoff Automation. For other motors the values may vary, depending on the application.
Table of contents
Start-up with the Drive Manager
Setting further parameters with the Drive Manager
Integral velocity controller component Tn
Proportional velocity controller component Kp
The TwinCAT Drive Manager is available for download in the AX5000 download package.
The TwinCAT Drive Manager for parameterizing an EL7211 is integrated in the System Manager, so that no separate configuration tool is required. Once an EP7211 has been detected or entered, the TwinCAT Drive Manager is available on the "Configuration" tab.
The following points are intended to enable you to start up the EP7211 quickly. More detailed information on the Drive Manager can be found in the corresponding documentation "AX5000 Introduction in the TCDrivemanager"
Start-up with the Drive Manager
▪
The box must already have been added manually under I/O devices or have been scanned in by the system (see chapter Configuration in TwinCAT)
▪
The box must already have been integrated in the NC (see chapter Integration into the NC configuration)
▪
Select the Drive Manager tab of the EP7211.
▪
Select the connected voltage under Power Management.
Selecting the connected voltage
▪
You can subsequently scan or select the connected motor under Channel A > Configuration > Motor and Feedback. If you decide to use automatic scanning, click on Scan motor and feedback. The electronic identification plate of the AM81xx-x2xx motor will then be read automatically. To do this it is necessary for automatic scanning of the motor to be activated in the box (Index 0x8008, MDP or Index 0x2018, DS402)
Automatic scanning of the connected motor
▪
If you decide to manually input the connected motor, please click on Select Motor.
Selecting the connected motor
▪
Select the suitable motor in the selection window and confirm with Ok.
List of available motors
▪
Confirm the next dialog box with OK. All required parameters are automatically entered in the NC, and the scaling factor is calculated. If this is not confirmed, these settings have to be entered manually. See section NC settings.
Confirmation of the automatic NC settings parameters
▪
The scaling can be determined under Scalings and NC Parameters. A motor revolution is defined as 360° as an example. All required parameters are adjusted automatically. The setting only becomes active once the configuration is activated.
Adapting the scaling
All main parameters for the commissioning the motor are now set. The motor can now be commissioned with the NC, for example. A brief description can be found in section "Commissioning the motor with the NC". Or the NC can be addressed from the PLC. A sample program has been added in the documentation for this also.
Some parameters can be adjusted manually for your particular application.
Setting further parameters with the Drive Manager
The values specified here are exemplary, although in most cases they have led to excellent results. Depending on the application, other values may yield better results.
These values can be changed during operation. Click on Download to apply the values.
Integral velocity controller component Tn
▪
Reduce the value, until the motor starts to oscillate slightly. Then increase the value by 10%.
Adapting Tn
Proportional velocity controller component Kp
▪
Increase the value, until the motor starts to oscillate slightly. Then reduce the value to 80%.
Adapting Kp


Settings in the CoE register

Commissioning [image] Start-up and parameter configuration [image] Settings in the CoE register
Settings in the CoE register
(Master TwinCAT 2.11 R3)
The data given here serve as an example for a servomotor type AM8131-0F20-0001 from Beckhoff Automation. For other motors the values may vary, depending on the application.
Table of contents
Settings in the CoE register
Settings in the CoE register
Setting further parameters
Settings in the CoE register
Torque limitation
Settings in the CoE register
Settings in the CoE register
Inserting the motor XML file
Downloading the motor XML files
The motor XML files are available for download from the Beckhoff website.
To facilitate commissioning of the EP7211, motor XML files have been created for the servomotors that are supported by the EP7211. The XML files can be read in the System Manager.
All CoE parameters and DS402 parameters are then set as required.
▪
To read the motor XML file, select the EP7211 and open the Startup tab. Right-click in the empty field and select Import from XML...(see Fig. Importing the motor XML file).
Importing the motor XML file
▪
Select the motor XML file that matches the connected motor (see Fig. Selecting the correct motor XML file)
Selecting the correct motor XML file
▪
All required parameters are then set, and the motor can be put into operation (see Fig. CoE parameters of the motor XML file).
CoE parameters of the motor XML file
Startup list
Any further application-specific settings should also be implemented in the Startup list. Otherwise the modified settings will be overwritten next time the box starts up.
Adaptation of current and voltage
Note
The motor may overheat!
In order to prevent overheating of the connected motor, it is important to adjust the output voltage of the box to the actually connected voltage.
This requires the index 0x8010:19 (0x2002:19, DS402 profile) "Nominal DC Link Voltage" of the connected voltage to be set accordingly
Setting further parameters
Single-turn bits (MDP742: Index 0x8000:12 / DS402: Index 0x2010:12) /
Multi-turn bits (MDP742: Index 0x8000:13 / DS402: Index 0x2010:13)
Here the user can specify how many single-turn and multi-turn bits the box should display. A total of 32 bits are available. These 32 bits can be subdivided as required.
The standard setting is 20 single-turn bits and 12 multi-turn bits.
Single-turn bits: number of bits relating to the resolution of one rotor rotation.
Multiturn bits: after a rotor rotation the multi-turn bits are incremented by one.
The motor may overheat!
If the number of single-turn bits is changed, the scaling factor in the NC has to be adjusted.
Multi-turn / single-turn bits
Torque limitation (MDP742: Index 0x7010:0B / DS402: Index 0x6072:0)
Limits the current / torque to this value. The value is specified in 1000th of the rated current.
Integral velocity controller component Tn (MDP742: Index 0x8010:14 / DS402: Index 0x2002:14)
The values specified here are exemplary, although in most cases they have led to excellent results. Depending on the application, other values may yield better results.
▪
Reduce the value, until the motor starts to oscillate slightly. Then increase the value by 10%.
Proportional velocity controller component Kp (MDP742: Index 0x8010:15 / DS402: Index 0x2002:15)
The values specified here are exemplary, although in most cases they have led to excellent results. Depending on the application, other values may yield better results.
▪
Increase the value, until the motor starts to oscillate slightly. Then reduce the value to 80%.


NC settings

Commissioning [image] Start-up and parameter configuration [image] NC settings
NC settings
(Master TwinCAT 2.11 R3)
The data given here serve as an example for a servomotor type AM8122-0F20-0000 from Beckhoff Automation. For other motors the values may vary, depending on the application.
Table of contents
Definition of the unit
Selecting the maximum velocity
Dead time compensation
NC settings
NC settings
Calculation of the scaling factor
Scaling output
NC settings
Commissioning the motor with the NC
Several important parameters are required for the commissioning with the NC. These should be set as follows before commissioning. A fundamental factor for setting the following parameters is the unit in which the NC is set to operate. For the following parameters it was assumed that one revolution corresponds to 360°.
Definition of the unit
The unit can be defined in the Settings tab for the axis.
Definition of the unit
Selecting the maximum velocity
The maximum permitted velocity is calculated based on the maximum motor speed (name plate) and the distance, in this case in relation to 360° per second.
Adjusting the reference velocity
The reference velocity matches the maximum permitted velocity.
Below that separate values for the maximum and minimum velocity for manual NC mode can be set.
Dead time compensation
The dead time compensation can be adjusted on the Time Compensation tab of Axis1_ENC.
It should theoretically be 3 cycles of the NC cycle time, although in practice 4 cycles are preferable.
Therefore, the settings of the parameters Time Compensation Mode Encoder should be ‚ON (with velocity) )‘ and Encoder Delay in Cycles ‘4’.
Dead time compensation parameter
Setting the encoder mask
The maximum values for the encoder mask can be set in the Parameter tab for the Axis1_ENC encoder settings. EP7211 provides a maximum of 32 bits for the encoder.
The parameter Encoder Mask (maximum encoder value) can be used to set the maximum number of available bits. By default this is set to 0xFFFF FFFF, which corresponds to 32 bits (20 single-turn bits and 12 multi-turn bits). The calculation is based on the following equation.
The parameter Encoder Sub Mask (absolute range maximum value) indicates how many bits of the maximum encoder value are single-turn bits. The default setting is 20 (and therefore 12 multi-turn bits). The calculation is based on the following equation.
Further calculation example with 13 single-turn bits and 8 multi-turn bits.
Setting the encoder mask
Scaling factor
The scaling factor can be changed by selecting "Axis 1_Enc" and tab Parameter in the NC (see Setting the Scaling Factor). The value can be calculated with the formulas specified below. The calculation is based on the assumption that one revolution corresponds to 360°.
The number of single-turn bits is taken into account in the calculation of the scaling factor. As indicated above, the default setting for EP7211 is 20 single-turn bits. This value is also used for calculating the scaling factor. If the single-turn bit value is changed, the scaling factor must be adjusted.
Calculation of the scaling factor
Setting the Scaling Factor
Scaling output
Enter the value 32 in the Parameter tab for the drive settings under Output Scaling (Velocity).
Output scaling
Position lag monitoring
The position lag monitoring function checks whether the current position lag of an axis has exceeded the limit value. The position lag is the difference between the set value (control value) and the actual value reported back. If the box parameters are set inadequately, the position lag monitoring function may report an error when the axis is moved. During commissioning it may therefore be advisable to increase the limits of the Position lag monitoring slightly.
Note
Damage to equipment, machines and peripheral components possible!
Setting the position lag monitoring parameters too high may result in damage to equipment, machines and peripheral components.
Lag monitoring
Commissioning the motor with the NC
▪
Once the parameters are set, the motor is basically ready for operation. Individual further parameters have to be adapted to the respective application.
▪
To commission the axis, activate the configuration (Ctrl+Shift+F4), select the axis, select tab Online and enable the axis under Set.
▪
Set all tick marks and set Override to 100% (see Fig. Enabling an axis). The axis can then be moved.
Enabling an axis
You can now move the axis with the function keys F1, F2 (Backward) or F3, F4 (Forward).
You can adjust the Kv factor in order to approach a suitable factor. Set the value to 0 initially in order to set the correct reference velocity. For calculating the reference velocity please refer to section "Selecting the maximum velocity". The calculation provides a relatively precise value, although the value may have to be corrected slightly. To this end move the motor with a Kv factor of 0 until the actual velocity matches the setpoint velocity.
Alternatively you can control the axis via the Functions tab. An example is provided below.
▪
Select as Reversing Sequence as the start type.
▪
Enter the required Target Position2, e.g. 12000°.
▪
Enter the required Target Velocity, e.g. 12000°/s.
▪
Enter the required Target Position1, e.g. 0°.
▪
Enter the required Idle Time, e.g. 2 s.
▪
Select Start.
Reversing Sequence
The motor now turns to position 2, remains there for 2 seconds and returns to position 1. This is repeated until Stop is pressed.


Commissioning without NC, status word/control word

Commissioning [image] Start-up and parameter configuration [image] Commissioning without NC, status word/control word
Commissioning without NC, status word/control word
(Master: TwinCAT 2.11 R3)
In principle, the operating modes CST, CSTCA, CSV and CSP can be used without TwinCAT NC.
Output stage enabled via control word
The output stage has to be enabled for each operation mode. To this end enter the following values in the specified order via the PLC control word (MDP742 / DS402) (see Fig. DS402 State Machine).
The respective status messages are output in the status word (MDP742 / DS402).
0hex
80hex (Fault reset)
6hex (Shutdown)
7hex (Switch on)
Fhex (Enable operation)
DS402 State Machine
CST - cyclic synchronous torque
Select Cyclic synchronous torque mode in index 0x7010:03 Modes of operation (MDP) or 0x6060:0 Modes of operation (DS402). In the respective process data, the Predefined PDO Assignment: 'Cyclic synchronous torque mode (CST)' should also be selected (see Process data MDP 742 or DS402 process data). The configuration then has to be reloaded in order to activate the selection.
Index 0x6010:03 Modes of operation display (MDP) or index 0x6061:0 Modes of operation display (DS402) can be used to check the actual mode of the box.
Via the PLC a defined torque can be defined in the variable Target torque as a basis for the box control. The torque is specified in 1000th of the rated current. A value of 1000dec, for example, corresponds to the set index 0x8011:12 Rated current (MDP) or index 0x6075:0 Motor rated current (DS402). The value 1dec corresponds to one 1000th of the rated current.
CSTCA - cyclic synchronous torque with commutation angle
Select Cyclic synchronous torque mode with commutation angle in index 0x7010:03 Modes of operation (MDP) or index 0x6060:0 Modes of operation (DS402). In the respective process data, the Predefined PDO Assignment: 'Cyclic synchronous torque mode with commutation angle mode (CSTCA)' should also be selected (see Process data MDP 742 or DS402 process data). The configuration then has to be reloaded in order to activate the selection.
Index 0x6010:03 Modes of operation display (MDP) or index 0x6061:0 Modes of operation display (DS402) can be used to check the actual mode of the box.
Via the PLC a defined torque can be set in the Target torque variable as a basis for the box control and the angle to be maintained with the set torque can be specified in the Commutation angle variable. The torque is specified in 1000th of the rated current. A value of 1000dec, for example, corresponds to the set index 0x8011:12 Rated current (MDP) or index 0x6075:0 Motor rated current (DS402). The value 1dec corresponds to one 1000th of the rated current.
The angle value must be converted, 65536dec corresponds to 360°.
CSV - cyclic synchronous velocity
Select Cyclic synchronous velocity in index 0x7010:03 Modes of operation (MDP) or index 0x6060:0 Modes of operation (DS402). In the respective process data, the Predefined PDO Assignment: 'Cyclic synchronous velocity mode (CSV)' should also be selected (see Process data MDP 742 or DS402 process data). The configuration then has to be reloaded in order to activate the selection.
Index 0x6010:03 Modes of operation display (MDP) or index 0x6061:0 Modes of operation display (DS402) can be used to check the actual mode of the box.
Via the PLC a defined speed can be set in the variable Target velocity 0x7010:06 (MDP) or 0x60FF:0 (DS402) as a basis for the box control. The constant value Velocity encoder resolution in CoE object 0x9010:14 (MDP) or 0x6090:0 (DS402) corresponds to 1 revolution per second. If this value is entered under Target velocity, the motor speed is 1 rpm. The velocity can be increased by entering a suitable multiple of the Velocity encoder resolution value under Target velocity.
CSP - cyclic synchronous position
Select Cyclic synchronous position in index 0x7010:03 Modes of operation (MDP) or index 0x6060:0 Modes of operation (DS402).
In the respective process data, the Predefined PDO Assignment: 'Cyclic synchronous position mode (CSP)' should also be selected (see Process data MDP 742 or DS402 process data). The configuration then has to be reloaded in order to activate the selection.
Index 0x6010:03 Modes of operation display (MDP) or index 0x6061:0 Modes of operation display (DS402) can be used to check the actual mode of the box.
Via the PLC a defined position can be set in the variable Target position 0x7010:05 (MDP) or 0x607A:0 (DS402) to which the motor is to drive. The calculated scaling factor is taken as the basis for the calculation of the position. The value entered in the Target position variable must be multiplied by the calculated scaling factor.


Settings for the automatic configuration

Commissioning [image] Start-up and parameter configuration [image] Settings for the automatic configuration
Settings for the automatic configuration
(Master TwinCAT 2.11 R3)
The EP7211 offers the option of automatically configuring the connected motor from the AM81xx series. The electronic identification plate integrated in the motor is read and the necessary parameters of the box are adapted accordingly.
The automatic configuration is switched off on delivery. The user has the possibility to adapt the automatic configuration according to the flow chart shown below (see fig. Flow chart for the automatic configuration).
Overwriting of the parameters during automatic configuration
The parameters manually changed by the user in the parameter list of the automatic configuration are automatically overwritten at the next start-up if automatic configuration is switched on.
▪
The automatic configuration can be switched on in the index 0x8001:01 (0x2018:01, DS402 Profile) Enable autoconfig.
▪
In the index 0x8008:02 (0x2018:02, DS402 Profile) Reconfig identical motor, the user can decide in the case of replacing an identical motor whether the box should automatically re-configure the motor (setting = true) or whether the motor should be operated with the stored settings (setting = false). The deactivation of this function can be advantageous, for example, if the user has specially adjusted the motor to his application and does not want to lose these settings after replacing the motor.
▪
In the index 0x8008:03 (0x2018:03, DS402 Profile) Reconfig non-identical motor , the user can decide in the case of replacing a non-identical motor whether the box should automatically re-configure the motor (setting = true) or whether the motor should be operated with the stored settings (setting = false).
Flow chart for the automatic configuration
Parameter list of the automatic configuration
The following parameters are affected by the automatic configuration.
Index (hex) |  | Name | Meaning
MDP 407 Profile | DS402 Profile
8010:12 | 2002:12 | Current loop integral time | is calculated according to the symmetrical optimum
8010:13 | 2002:13 | Current loop proportional gain | is calculated according to the symmetrical optimum
8011:11 | 2003:11 | Max. current | is adopted directly from the electronic identification plate of the connected motor
8011:12 | 2003:12 | Rated current | is adopted directly from the electronic identification plate of the connected motor
8011:13 | 2003:13 | Motor pole pairs | is adopted directly from the electronic identification plate of the connected motor
8011:15 | 2003:15 | Commutation offset | is always set to -90°
8011:16 | 2003:16 | Torque constant | is adopted directly from the electronic identification plate of the connected motor
8011:18 | 2003:18 | Rotor moment of inertia | is adopted directly from the electronic identification plate of the connected motor
8011:19 | 2003:19 | Winding inductance | is adopted directly from the electronic identification plate of the connected motor
8011:1B | 2003:1B | Motor speed limitation | Calculation of the max. speed of the connected motor
8011:2B | 2003:2B | Motor temperature warn level | is adopted directly from the electronic identification plate of the connected motor
8011:2C | 2003:2C | Motor temperature error level | is adopted directly from the electronic identification plate of the connected motor
8011:2D | 2003:2D | Motor thermal time constant | is adopted directly from the electronic identification plate of the connected motor
8012:11 | 2004:11 | Release delay | is adopted directly from the electronic identification plate of the connected motor
8012:12 | 2004:12 | Application delay | is adopted directly from the electronic identification plate of the connected motor
8012:14 | 2004:14 | Brake moment of inertia | is adopted directly from the electronic identification plate of the connected motor


Configure end position monitoring

Commissioning [image] Start-up and parameter configuration [image] Configure end position monitoring
Configure end position monitoring
Software end position monitoring
The TwinCAT NC can be used to set software end position monitoring for EP7211 to ensure the safety of the system. The axis does not move beyond the set position (maximum/minimum end position). End position monitoring can be activated in the Parameter tab for the corresponding axis.
Pull-down menu for activating end position monitoring


Homing

Commissioning [image] Start-up and parameter configuration [image] Homing
Homing
(Master TwinCAT 2.11 R3)
The data given here serve as an example for a servomotor type AM8131-0F20-0000 from Beckhoff Automation. For other motors the values may vary, depending on the application.
Table of contents
Referencing
Function block "MC_Home"
Homing
Referencing
Referencing does not work via the online commissioning tab of the axis (see Fig. Online homing in the NC).
Online homing in the NC
Function block "MC_Home"
▪
Referencing must be done from the PLC. The function block MC_Home from the TC MC2 Lib is used for this purpose.
▪
The following minimum configuration is required in MC_Home.
–
HomingMode enables selection of mode to be used for referencing.
–
Execute is used to initiate homing.
–
bCalibrationCam, which has to be linked with your reference cam, is used to stop homing.
Configuration of the MC_Home block
▪
The following figure Extract from the functional description for MC_Home shows an extract from the functional description of MC_Home. Full information can be found in the corresponding functional description.
Extraction from the functional description for MC_Home
Reference modes
▪
EP7211 can be operated with the following NC reference modes (see Fig. Selection of the reference modes in the NC).
▪
Default: Is suitable as a general setting and for most applications.
Once the motor reaches the reference cam, the direction is reversed. The declining cam signal causes the motor to stop. The reference position is then set.
▪
Software Sync: The C track is modelled virtually.
Selection of the reference modes in the NC
The velocity to be used for homing can also be set in the NC (Fig. Setting the reference velocity).
Setting the reference velocity


Touch Probe

Commissioning [image] Start-up and parameter configuration [image] Touch Probe
Touch Probe
(Master TwinCAT 2.11 R3)
Functional description
The touch probe function saves the current position of the motor when a signal edge is detected on a digital input.
The process data objects required for this can be activated on the Process data tab (see figs. Touch Probe inputs and Touch Probe outputs).
Touch Probe inputs
Touch Probe outputs
Step-by-step
TP1 is used here as an example for the description of the function.
▪
TP1 Enable must be set to true in order to generally activate the Touch Probe function.
▪
Subsequently, you must decide whether the position is to be saved on a positive edge at input 1 (TP1 Enable pos edge = true), on a negative edge (TP1 Enable neg edge = true), or in both cases (both set to ‘true’).
▪
With TP1 Continuous you can decide whether the position is to be saved only at the first event (TP1 Continuous = false) or whether this should take place at every event (TP1 Continuous = true).
For example, if TP1 Continous and TP1 Enablepos edge are set, the position is saved on each positive edge at input 1 of the box.
If TP1 Enable neg edge is set and TP1 Continuous is not set, the position will only be saved on the first negative edge at input 1 of the box. If you wish to repeat this procedure, you must first deactivate TP1 Enable and then activate it again. Then the position is saved again on the first negative edge.
▪
The TP1 Trigger mode has no function with the EP7211.
▪
The saved position of the positive edge can be read in the inputs of the process data under TP1 Pos position, that of the negative edge under TP1 Neg position.
▪
The variables under Touch probe status are for the diagnosis.
▪
The Touch Probe inputs must be addressed with a 1-wire +24 V signal.


Drive profiles

Commissioning [image] Drive profiles
Drive profiles
EP7211 supports the MDP 742 and DS402 drive profiles. Both drive profiles contain the same parameters. The drive profiles define the presentation of the parameters in TwinCAT and the index, under which the respective parameters are arranged in the object directory.
▪
The CoE objects in the MDP 742 (Modular Device Profile) are allocated in the way that is common for the Beckhoff IO modules.
▪
The DS402 drive profile is specified in IEC61800-7-200 (CiA402) and uses a different allocation of the object directory structure.
The drive state machine in both profiles is based on the CiA402 State Machine, which means the functional behavior is identical.
The box is supplied ex factory with the MDP 742 drive profile.
Changing the drive profile
You can change the drive profile by carrying out an EEPROM Update. Select the EEPROM description on the basis of the following table.
Drive profile | EEPROM description
MDP 742 | EP7211-0034
DS402 | EP7211-0035
The EEPROM description is at the same time the name of the IO module in the solution explorer.
The CoE object description and the process data of the drive profiles are different. The motor XML files that match the set profile must be used.


Operation modes

Commissioning [image] Operation modes
Operation modes
Additional information
•
Overview
•
CSV
•
CST
•
CSTCA
•
CSP


Overview

Commissioning [image] Operation modes [image] Overview
Overview
Operation modes CST, CSTCA, CSV and CSP are supported. The operation mode is set in the CoE directory in index 0x7010:03 Modes of operation (MDP) or index 0x6060:0 Modes of operation (DS402). In the respective process data the user can additionally select the respective Predefined PDO Assignment. All required variables are then in the process data.
CSV - cyclic synchronous velocity (velocity control)
EP7211 operates in the cyclic velocity interface in the CSV operation mode. A defined velocity can be set via the Target velocity variable.
CST - cyclic synchronous torque (torque control)
EP7211 operates in the cyclic torque interface in the CST operation mode. A defined torque can be set via the Target torque variable.
CSTCA - cyclic synchronous torque with commutation angle (torque control with commutation angle)
This operation mode is also intended for use with the cyclic torque interface. In addition the user can specify the commutation angle. The variable Commutation angle can be used to set an angle which is to be maintained with a defined torque set in variable Target torque.
CSP - cyclic synchronous position (position control)
EP7211 operates in the cyclic position interface in the CSP operation mode. A defined position can be set via the Target position variable.
For further information on the three operation modes described above please refer to section Commissioning without NC.


CSV

Commissioning [image] Operation modes [image] CSV
CSV
EP7211 operates in the cyclic velocity interface in the CSV operation mode. A defined velocity can be set via the Target velocity variable.
Step-by-Step
▪
Add the box to the configuration as described in the chapter Configuration in TwinCAT.
▪
Link the box with the NC as described in the chapter Integration into the NC configuration.
▪
Import the motor XML file into the Startup directory as described in the chapter Settings in the CoE.
▪
Set the mode of operation in the CoE directory to Cyclic synchronous velocity mode (CSV), Fig. Selection of the mode of operation.
Selection of the mode of operation
▪
Under Predefined PDO assignment, also select Cyclic synchronous velocity mode (CSV), Fig. Selecting a predefined PDO assignment.
Selecting a predefined PDO assignment
▪
Activate the configuration (Ctrl+Shift+F4)
▪
Run through the State Machine of the box. There are two ways to do this:
–
If you use the TwinCAT NC.
The State Machine is run through automatically by the NC. You can enable the axis in the Online tab of the axis.
Set all tick marks and set Override to 100% (see Fig. Set enables). The axis can then be moved.
Set enables
–
If you don’t use the TwinCAT NC.
In this case you must run through the State Machine manually. To do this, follow the instructions in the chapter Commissioning without the NC.
▪
The cyclic variable Target velocity (Fig. Torque specification) can be used to specify a defined velocity. The value in the index 0x9010:14 (0x6090, DS402) Velocity encoder resolution corresponds to 1 rpm.
Torque specification


CST

Commissioning [image] Operation modes [image] CST
CST
EP7211 operates in the cyclic torque interface in the CST operation mode. A defined torque can be set via the Target torque variable.
Step-by-Step
▪
Add the box to the configuration as described in the chapter Configuration in TwinCAT.
▪
Link the box with the NC as described in the chapter Integration into the NC configuration.
▪
Import the motor XML file into the Startup directory as described in the chapter Settings in the CoE.
▪
Set the mode of operation in the CoE directory to Cyclic synchronous torque mode (CST), Fig. Selection of the mode of operation
Selection of the mode of operation
▪
Under Predefined PDO assignment, also select Cyclic synchronous torque mode (CST), Fig. Selecting a predefined PDO assignment
Selecting a predefined PDO assignment
▪
Activate the configuration (Ctrl+Shift+F4)
▪
Run through the State Machine of the box. There are two ways to do this:
–
If you use the TwinCAT NC.
The State Machine is run through automatically by the NC. You can enable the axis in the Online tab of the axis.
Set all tick marks and set Override to 100% (see Fig. Set enabling). The axis can then be moved.
–
If you don’t use the TwinCAT NC.
In this case you must run through the State Machine manually. To do this, follow the instructions in the chapter Commissioning without the NC.
Set enabling
▪
The cyclic variable Target torque (Fig. Torque specification) can be used to specify a defined torque.
Torque specification


CSTCA

Commissioning [image] Operation modes [image] CSTCA
CSTCA
This operation mode is also intended for use with the cyclic torque interface. In addition the user can specify the commutation angle. The variable Commutation angle can be used to set an angle which is to be maintained with a defined torque set in variable Target torque.
Step-by-Step
▪
Add the box to the configuration as described in the chapter Configuration in TwinCAT.
▪
Link the box with the NC as described in the chapter Integration into the NC configuration.
▪
Import the motor XML file into the Startup directory as described in the chapter Settings in the CoE.
▪
Set the mode of operation in the CoE directory to Cyclic synchronous torque mode with commutation angle (CSTCA), Fig. Selection of the mode of operation
Selection of the mode of operation
▪
Under Predefined PDO assignment, also select Cyclic synchronous torque mode with commutation angle (CSTCA), Fig. Selecting a predefined PDO assignment.
Selecting a predefined PDO assignment
▪
Activate the configuration (Ctrl+Shift+F4)
▪
Run through the State Machine of the box. There are two ways to do this:
–
If you use the TwinCAT NC.
The State Machine is run through automatically by the NC. You can enable the axis in the Online tab of the axis.
Set all tick marks and set Override to 100% (see Fig. Set enables). The axis can then be moved.
Set enables
–
If you don’t use the TwinCAT NC.
In this case you must run through the State Machine manually. To do this, follow the instructions in the chapter Commissioning without the NC.
▪
You can specify a defined torque via the cyclic variable Target torque. The value is specified in 1000ths of the rated current and the torque is calculated according to the following equation, where the rated current refers to the value in the index 0x8011:12 rated current.
You can specify a defined angle via the cyclic variable Commutation angle. The value is specified in 360°/216.
Specification of torque and commutation angle


CSP

Commissioning [image] Operation modes [image] CSP
CSP
EP7211 operates in the cyclic position interface in the CSP operation mode. A defined position can be set via the Target position variable.
Minimum cycle time
The cycle time in CSP modus must be 2^n * 125 µs (where n = 1 to 8), i.e. 250 µs, 500 µs, 1 ms, 2 ms, 4 ms, 8 ms, 16 ms or 32 ms.
Step-by-Step
▪
Add the box to the configuration as described in the chapter Configuration in TwinCAT.
▪
Link the box with the NC as described in the chapter Integration into the NC configuration.
▪
Configure the motor with the help of the automatic configuration (OCT types only) using the Drive Manager or import the motor XML file into the Start-up directory as described in the chapter Settings in the CoE.
▪
Set the mode of operation in the CoE directory to Cyclic synchronous position mode (CSP), Fig. Selection of the mode of operation.
Selection of the mode of operation
▪
Under Predefined PDO assignment, also select Cyclic synchronous position mode (CSP), Fig. Selecting a predefined PDO assignment.
Selecting a predefined PDO assignment
▪
Activate the configuration (Ctrl+Shift+F4)
▪
Run through the State Machine of the box. There are two ways to do this:
–
If you use the TwinCAT NC.
The State Machine is run through automatically by the NC. You can enable the axis in the “Online” tab of the axis.
Set all tick marks and set Override to 100% (see Fig. Set enabling). The axis can then be moved.
Set enabling
–
If you don’t use the TwinCAT NC.
In this case you must run through the State Machine manually. To do this, follow the instructions in the chapter Commissioning without the NC.
▪
You can specify a position via the cyclic variable Target position (fig. Position specification). The value must be multiplied by the calculated scaling factor in order to obtain the correct position.
Position specification
Following error monitor
Furthermore, there is an option in CSP mode to activate a following error monitor. The following error monitor is switched off on delivery. In all other modes this is not used and is ignored.
▪
The window of the following error monitor can be adjusted with the Following error window (Index 0x8010:50 MDP742 / Index 0x6065 DS402). The value set here – multiplied by the scaling factor – specifies by what position the actual position may differ from the set position, positively and negatively. The total accepted tolerance is thus twice as large as the position entered in the Following error window (see fig. Following error window).
Following error window
▪
The time (in ms) allowed for a following error exceedance can be set with the Following error time out (Index 0x8010:51 MDP742 / Index 0x6066 DS402). As soon as the target position is exceeded by more than the position entered in the Following error window for the time entered in the Following error time out, the box outputs an error and stops immediately.
▪
The current following error can be read in the Following error actual value (Index 0x6010:09 MDP742 / Index 0x60F4 DS402).
Following error time out
The value 0xFFFFFF (- 1) in the Following error window means that the following error monitor is switched off and corresponds to the delivery state.
The Following error time out is 0x0000 (0) on delivery.


Process data MDP 742

Commissioning [image] Process data MDP 742
Process data MDP 742
Table of contents
• Sync Manger
• PDO Assignment
• Predefined PDO Assignment
Sync Manager (SM)
Sync Manager (SM) The extent of the process data that is made available can be changed through the "Process data" tab (see following Fig.).
Process Data tab SM2, EP7211 (default)
Process Data tab SM3, EP7211 (default)
PDO Assignment
In order to configure the process data, select the desired Sync Manager (SM 2 & 3 can be edited here) in the upper left-hand "Sync Manager" box (see fig. Process data SM3 tab). The process data assigned to this Sync Manager can then be switched on or off in the “PDO Assignment” box underneath. Restarting the EtherCAT system, or reloading the configuration in Config mode (F4), causes the EtherCAT communication to restart, and the process data is transferred from the box.
SM2, PDO Assignment 0x1C12
Index | Size (byte.bit) | Name | PDO Content
0x1600 (default) | 2.0 | DRV Controlword | Index 0x7010:01
0x1601 (default) | 4.0 | DRV Target velocity | Index 0x7010:06
0x1602 | 2.0 | DRV Target torque | Index 0x7010:09
0x1603 | 2.0 | DRV Commutation angle | Index 0x7010:0E
0x1604 | 2.0 | DRV Torque limitation | Index 0x7010:0B
0x1605 | 2.0 | DRV Torque offset | Index 0x7010:0A
0x1606 | 4.0 | DRV Target position | Index 0x7010:05
0x1607 | 2.0 | FB Touch probe control | Index 0x7001:0
 |  |  | Index 0x7001:01 Index 0x7001:02 Index 0x7001:03 Index 0x7001:05 Index 0x7001:06 Index 0x7001:09 Index 0x7001:0A Index 0x7001:0B Index 0x7001:0D Index 0x7001:0E | TP1 Enable TP1 Continous TP1 Trigger mode TP1 Enable pos. edge TP1 Enable neg. edge TP2 Enable TP2 Continous TP2 Trigger mode TP2 Enable pos. edge TP2 Enable neg. edge
SM3, PDO Assignment 0x1C13
Index | Size (byte.bit) | Name | PDO Content
0x1A00 (default) | 4.0 | FB position | Index 0x6000:11
0x1A01 (default) | 2.0 | DRV Statusword | Index 0x6010:01
0x1A02 | 4.0 | DRV Velocity actual value | Index 0x6010:07
0x1A03 | 2.0 | DRV Torque actual value | Index 0x6010:08
0x1A04 | 2.0 | DRV Info data 1 | Index 0x6010:12
0x1A05 | 2.0 | DRV Info data 2 | Index 0x6010:13
0x1A06 | 4.0 | DRV Following error actual value | Index 0x6010:09
0x1A07 | 2.0 | FB Touch probe status | Index 0x6001:0
 |  |  | Index 0x6001:01 Index 0x6001:02 Index 0x6001:03 Index 0x6001:08 Index 0x6001:09 Index 0x6001:0A Index 0x6001:0B Index 0x6001:10 | TP1 Enable TP1 Pos. value stored TP1 Neg. value stored TP1 Input TP2 Enable TP2 Pos. value stored TP2 Neg. value stored TP2 Input
0x1A08 | 4.0 | FB Touch probe 1 pos. position | Index 0x6001:11
0x1A09 | 4.0 | FB Touch probe 1 neg. position | Index 0x6001:12
0x1A0A | 4.0 | FB Touch probe 2 pos. position | Index 0x6001:13
0x1A0B | 4.0 | FB Touch probe 2 neg. position | Index 0x6001:14
Predefined PDO Assignment
The "Predefined PDO Assignment" enables a simplified selection of the process data. The desired function is selected on the lower part of the "Process Data" tab. As a result, all necessary PDOs are automatically activated and the unnecessary PDOs are deactivated.
The following PDO assignments are available:
Name | SM2, PDO assignment | SM3, PDO assignment
Cyclic synchronous velocity mode (CSV) | 0x1600 (DRV Controlword) 0x1601 (DRV Target velocity) | 0x1A00 (FB Position) 0x1A01 (DRV Statusword)
Cyclic synchronous torque mode (CST) | 0x1600 (DRV Controlword) 0x1602 (DRV Target torque) | 0x1A00 (FB Position) 0x1A01 (DRV Statusword) 0x1A03 (DRV Torque actual value)
Cyclic synchronous torque mode with commutation angle (CSTCA) | 0x1600 (DRV Controlword) 0x1602 (DRV Target torque) 0x1603 (DRV Commutation angle) | 0x1A01 (DRV Statusword)
Cyclic synchronous position mode (CSP) | 0x1600 (DRV Controlword) 0x1606 (DRV Target position) | 0x1A00(FB Position) 0x1A01(DRV Statusword)
Process data tab - Predefined PDO Assignment


DS402 process data

Commissioning [image] DS402 process data
DS402 process data
Table of contents
Sync Manager
PDO Assignment
Predefined PDO Assignment
Sync Manager (SM)
Sync Manager (SM). The extent of the process data that is made available can be changed via the "Process data" tab (see Fig. Process data tab SM2 (default)).
Process Data tab SM2 (default)
Process Data tab SM3 (default)
PDO Assignment
In order to configure the process data, select the desired Sync Manager (SM 2 & 3 can be edited) in the upper left-hand "Sync Manager" box (see fig.). The process data assigned to this Sync Manager can then be switched on or off in the “PDO Assignment” box underneath. Restarting the EtherCAT system, or reloading the configuration in Config mode (F4), causes the EtherCAT communication to restart, and the process data is transferred from the box.
SM2, PDO Assignment 0x1C12
Index | Size (byte.bit) | Name | PDO Content
0x1600 (default) | 2.0 | DS402 Controlword | Index 0x6040
0x1601 (default) | 4.0 | DS402 Target velocity | Index 0x60FF
0x1602 | 2.0 | DS402 Target torque | Index 0x6071
0x1603 | 2.0 | DS402 Commutation angle | Index 0x60EA
0x1604 | 2.0 | DS402 Torque limitation | Index 0x6072
0x1605 | 2.0 | DS402 Torque offset | Index 0x2001:11
0x1606 | 4.0 | DS402 Target position | Index 0x607A
0x1607 | 2.0 | DS402 FB Touch probe function | Index 0x60B8
 |  |  | Bit 0 Bit 1 Bit 2 Bit 4 Bit 5 Bit 8 Bit 9 Bit 10 Bit 12 Bit 13 | TP1 Enable TP1 Continous TP1 Trigger mode TP1 Enable pos. edge TP1 Enable neg. edge TP2 Enable TP2 Continous TP2 Trigger mode TP2 Enable pos. edge TP2 Enable neg. edge
SM3, PDO Assignment 0x1C13
Index | Size (byte.bit) | Name | PDO Content
0x1A00 (default) | 2.0 | DS402 Statusword | Index 0x6041
0x1A01 (default) | 4.0 | DS402 Position actual value | Index 0x6064
0x1A02 | 4.0 | DS402 Velocity actual value | Index 0x606C
0x1A03 | 2.0 | DS402 Torque actual value | Index 0x6077
0x1A04 | 4.0 | DS402 Following error actual value | Index 0x60F4
0x1A05 | 2.0 | DS402 Touch probe status | Index 0x60B9
 |  |  | Bit 0 Bit 1 Bit 2 Bit 7 Bit 8 Bit 9 Bit 10 Index 6001:10 | TP1 Enable TP1 Pos. value stored TP1 Neg. value stored TP1 Input TP2 Enable TP2 Pos. value stored TP2 Neg. value stored TP2 Input
0x1A06 | 4.0 | DS402 Touch probe 1 pos. position | Index 0x60BA
0x1A07 | 4.0 | DS402 Touch probe 1 neg. position | Index 0x60BB
0x1A08 | 4.0 | DS402 Touch probe 2 pos. position | Index 0x60BC
0x1A09 | 4.0 | DS402 Touch probe 2 neg. position | Index 0x60BD
Predefined PDO Assignment
The "Predefined PDO Assignment" enables a simplified selection of the process data. The desired function is selected on the lower part of the "Process Data" tab. As a result, all necessary PDOs are automatically activated and the unnecessary PDOs are deactivated.
The following PDO assignments are available:
Name | SM2, PDO assignment | SM3, PDO assignment
Cyclic synchronous velocity mode (CSV) | 0x1600 (DS402 Controlword) 0x1601 (DS402 Target velocity) | 0x1A00 (DS402 Statusword) 0x1A01 (DS402 Position actual value)
Cyclic synchronous torque mode (CST) | 0x1600 (DS402 Controlword) 0x1602 (DS402 Target torque) | 0x1A00 (DS402 Statusword) 0x1A01 (DS402 Position actual value) 0x1A03 (DS402 Torque actual value)
Cyclic synchronous torque mode with commutation angle (CSTCA) | 0x1600 (DS402 Controlword) 0x1602 (DS402 Target torque) 0x1603 (DS402 Commutation angle) | 0x1A00 (DS402 Statusword)
Cyclic synchronous position mode (CSP) | 0x1600 (DS402 Controlword) 0x1606 (DS402 Target position) | 0x1A00 (DS402 Statusword) 0x1A01 (DS402 Position actual value)
Process data tab - Predefined PDO Assignment


Object description (MDP 742)

Commissioning [image] Object description (MDP 742)
Object description (MDP 742)
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Parameterization via the CoE list (CAN over EtherCAT)
The box is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (assignment of PDOs).
Please note the following general CoE information when using/manipulating the CoE parameters:
- Keep a startup list if components have to be replaced
- Differentiation between online/offline dictionary, existence of current XML description
- use "CoE reload" for resetting changes
Note
Risk of damage to the device!
We strongly advise not to change settings in the CoE objects while the axis is active, since this could impair the control.
Additional information
•
Restore object
•
Configuration data
•
Configuration data (vendor-specific)
•
Command object
•
Input data
•
Output data
•
Information / diagnosis data
•
Standard objects


Restore object

Commissioning [image] Object description (MDP 742) [image] Restore object
Restore object
Index 1011 Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default parameters | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to “0x64616F6C” in the set value dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)


Configuration data

Commissioning [image] Object description (MDP 742) [image] Configuration data
Configuration data
Index 8000 FB settings
Index (hex) | Name | Meaning | Data type | Flags | Default
8000:0 | FB Settings | Maximum subindex | UINT8 | RO | 0x13 (19dec)
8000:01 | Invert feedback direction | Inverting the count direction | BOOLEAN | RW | 0x00 (0dec)
8000:02 | Referenced |  | BOOLEAN | RW | 0x00 (0dec)
8000:11 | Device type | 3: OCT (not changeable) | UINT32 | RW | 0x00000003 (3dec)
8000:12 | Single-turn bits | Number of single-turn bits | UINT8 | RW | 0x14 (20dec)
8000:13 | Multi-turn bits | Number of multi-turn bits | UINT8 | RW | 0x0C (12dec)
8000:14 | Observer bandwidth | Bandwidth of the speed observer [Hz] | UINT16 | RW | 0x01F4 (500dec)
8000:15 | Observer feed-forward | Load ratio [%] 100% = load-free 50% = mass moments of inertia of input and output are equal | UINT8 | RW | 0x01 (0dec)
8000:17 | Position Offset |  | UINT32 | RW | 0x00000000 (0dec)
Index 8008 FB OCT Settings
Index (hex) | Name | Meaning | Data type | Flags | Default
8008:0 | FB OCT Settings | Maximum subindex | UINT8 | RO | 0x00 (0dec)
8008:01 | Enable autoconfig | Configuration takes place automatically after the reading of the electronic type plate (see Automatic scanning of the electronic type plates) | BOOLEAN | RW | 0x00 (0dec)
8008:02 | Reconfig identical motor | When replacing identical motors, reconfiguration takes place automatically after reading the electronic type plate. Enable autoconfig must be activated. (see Automatic scanning of the electronic type plates) | BOOLEAN | RW | 0x00 (0dec)
8008:03 | Reconfig non-identical motor | When replacing non-identical motors, reconfiguration takes place automatically after reading the electronic type plate. Enable autoconfig must be activated. (see Automatic scanning of the electronic type plates) | BOOLEAN | RW | 0x00 (0dec)
Index 8010 DRV Amplifier Settings
Index (hex) | Name | Meaning | Data type | Flags | Default
8010:0 | DRV Amplifier Settings | Maximum subindex | UINT8 | RO | 0x42 (66dec)
8010:01 | Enable TxPDOToggle | Show TxPDO toggle in status word (bit 10) | BOOLEAN | RW | 0x00 (0dec)
8010:02 | Enable input cycle counter | 1: enabled Two-bit counter that is incremented with each process data cycle up to a maximum value of 3, after which it starts again at 0 The low bit is represented in bit 10 and the high bit in bit 14 of the Status word. | BOOLEAN | RW | 0x00 (0dec)
8010:11 | Device type | 1: Servo drive (cannot be changed) | UINT32 | RW | 0x00000001 (1dec)
8010:12* | Current loop integral time | Integral component of current controller Unit: 0.1 ms This value is affected by automatic scanning. (see Automatic scanning of the electronic identification plates) | UINT16 | RW | 0x000A (10dec)
8010:13* | Current loop proportional gain | Proportional component of current controller Unit: 0.1 V/A This value is affected by automatic scanning. (see Automatic scanning of the electronic identification plates) | UINT16 | RW | 0x0064 (100dec)
8010:14 | Velocity loop integral time | Integral component of velocity controller Unit: 0.1 ms | UINT32 | RW | 0x00000032 (50dec)
8010:15 | Velocity loop proportional gain | Proportional component of velocity controller Unit: mA / (rad/s) | UINT32 | RW | 0x00000096 (150dec)
8010:17 | Position loop proportional gain | Proportional component position controller Unit: (rad/s) / rad | UINT32 | RW | 0x0000000A (10dec)
8010:19 | Nominal DC link voltage | Nominal DC link voltage Unit: mV | UINT32 | RW | 0x0000BB80 (48000dec)
8010:1A | Min DC link voltage | Minimum DC link voltage Unit: mV | UINT32 | RW | 0x00001A90 (6800dec)
8010:1B | Max DC link voltage | Maximum DC link voltage Unit: mV | UINT32 | RW | 0x0000EA60 (60000dec)
8010:29 | Amplifier I2T warn level | I²T model warning threshold Unit: % | UINT8 | RW | 0x50 (80dec)
8010:2A | Amplifier I2T error level | I²T model error threshold Unit: % | UINT8 | RW | 0x69 (105dec)
8010:2B | Amplifier Temperature warn level | Overtemperature warning threshold Unit: 0.1 °C | UINT16 | RW | 0x0320 (800dec)
8010:2C | Amplifier Temperature error level | Overtemperature error threshold Unit: 0.1 °C | UINT16 | RW | 0x03E8 (1000dec)
8010:31 | Velocity limitation | Velocity limitation Unit: rpm | UINT32 | RW | 0x00040000 (262144dec)
8010:32 | Short-Circuit Brake duration max | Max. duration of armature short circuit brake Unit: ms | UINT16 | RW | 0x03E8 (1000dec)
8010:33 | Stand still window | Standstill window Unit: rpm | UINT16 | RW | 0x0000 (0dec)
*) see index 9009 FB OCT Nameplate
Index (hex) | Name | Meaning | Data type | Flags | Default
8010:39 | Select info data 1 | Selection "Info data 1" Optional display of additional information in the cyclic process data. The following parameters are available. | UINT8 | RW | 0x01 (1dec)
 |  | Torque current (filtered 1ms) [1000th of rated current]
 |  | DC link voltage [mV]
 |  | PCB temperature [0.1 °C]
 |  | Errors: Bit0: ADC Error Bit1: Overcurrent Bit 2: Undervoltage Bit 3: Overvoltage Bit 4: Overtemperature Bit 5: I2T Amplifier Bit 6: I2T Motor Bit 7: Encoder Bit 8: Watchdog
 |  | Warnings: Bit 2: Undervoltage Bit 3: Overvoltage Bit 4: Overtemperature Bit 5: I2T Amplifier Bit 6: I2T Motor Bit 7: Encoder
 |  | I2T Motor [%]
 |  | I2T Amplifier [%]
 |  | Input Level: Bit0: Digital Input 1 Level Bit1: Digital Input 2 Level
8010:3A | Select info data 2 | Selection "Info data 2" Optional display of additional information in the cyclic process data. The following parameters are available. | UINT8 | RW | 0x01 (1dec)
 |  | Torque current (filtered 1ms) [1000th of rated current]
 |  | DC link voltage [mV]
 |  | PCB temperature [0.1 °C]
 |  | Errors: Bit0: ADC Error Bit1: Overcurrent Bit 2: Undervoltage Bit 3: Overvoltage Bit 4: Overtemperature Bit 5: I2T Amplifier Bit 6: I2T Motor Bit 7: Encoder Bit 8: Watchdog
 |  | Warnings: Bit 2: Undervoltage Bit 3: Overvoltage Bit 4: Overtemperature Bit 5: I2T Amplifier Bit 6: I2T Motor Bit 7: Encoder
 |  | I2T Motor [%]
 |  | I2T Amplifier [%]
 |  | Input Level: Bit0: Digital Input 1 Level Bit1: Digital Input 2 Level
8010:41 | Low-pass filter frequency | Low-pass filter frequency Unit: Hz The following values can be set: 0 Hz = off 160 Hz 320 Hz | UINT16 | RW | 0x0140 (320dec)
8010:49 | Halt ramp deceleration | Halt ramp deceleration Unit: 0.1 rad / s² | UINT32 | RW | 0x0000F570 (62832dec)
8010:50 | Following error window | Following error monitor: Following error window Unit: the given value must be multiplied by the corresponding scaling factor 0xFFFFFFFF (-1dec) = following error monitor off Any other value = following error monitor on | UINT32 | RW | 0xFFFFFFFF (-1 dec)
8010:51 | Following error time out | Following error monitor: Timeout Unit: ms If the following error is larger than the following error window for a time that exceeds the timeout, this leads to an error reaction | UINT16 | RW | 0x0000 (0 dec)
8010:52 | Fault reaction option code | Permitted values 0: Disable drive function, motor is free to rotate 1: Slow down on slow down ramp | UINT16 | RW | 0x0000 (0 dec)
8010:53 | Position loop proportional gain | Proportional component position controller Unit: mA / (rad/s) | UINT32 | RW | 0x00000000 (0 dec)
8010:54 | Feature bits | The adjustable motor current values can be interpreted as peak values or rms values. The feature bit enables the conversion. Peak value → Bit 0 = 0 (default) RMS value → Bit 0 = 1 normal output current → Bit 1 = 0 (default) increased output current → Bit 1 = 1 From these, the following combinations can be set: 0dec → normal output current interpreted as peak value 1dec → normal output current interpreted as rms value 2dec → increased output current interpreted as peak value 3dec → increased output current interpreted as rms value | UINT32 | RW | 0x00000000 (0 dec)
*) see index 9009 FB OCT Nameplate
Index 8011 DRV Motor Settings
Index (hex) | Name | Meaning | Data type | Flags | Default
8011:0 | DRV Motor Settings | Maximum subindex | UINT8 | RO | 0x2D (45dec)
8011:11* | Max current | Peak current Unit: mA The adjustable motor current values can be interpreted as peak values or rms values. The feature bit (8010:54) enables the conversion. Peak value → Bit 0 = 0 (default) RMS value → Bit 0 = 1 This value is affected by automatic scanning. (see Automatic scanning of the electronic identification plates) | UINT32 | RW | 0x00001770 (6000dec)
8011:12* | Rated current | Nominal current Unit: mA The adjustable motor current values can be interpreted as peak values or rms values. The feature bit (8010:54) enables the conversion. Peak value → Bit 0 = 0 (default) RMS value → Bit 0 = 1 This value is affected by automatic scanning. (see Automatic scanning of the electronic identification plates) | UINT32 | RW | 0x000003E8 (1000dec)
8011:13* | Motor pole pairs | Number of pole pairs This value is affected by automatic scanning. (see Automatic scanning of the electronic identification plates) | UINT8 | RW | 0x03 (3dec)
8011:15* | Commutation offset | Commutation offset (between electrical zero position and mechanical single-turn zero position) Unit: This value is affected by automatic scanning. (see Automatic scanning of the electronic identification plates) | INT16 | RW | 0x0000 (0dec)
8011:16* | Torque constant | Torque constant Unit: mNm / A This value is affected by automatic scanning. (see Automatic scanning of the electronic identification plates) | UINT32 | RW | 0x00000000 (0dec)
8011:18* | Rotor moment of inertia | Mass moment of inertia of the motor Unit: g cm^2 This value is affected by automatic scanning. (see Automatic scanning of the electronic identification plates) | UINT32 | RW | 0x00000000 (0dec)
8011:19* | Winding inductance | Inductance Unit: 0.1 mH This value is affected by automatic scanning. (see Automatic scanning of the electronic identification plates) | UINT16 | RW | 0x000E (14dec)
8011:1B* | Motor speed limitation | Velocity limitation Unit: rpm This value is affected by automatic scanning. (see Automatic scanning of the electronic identification plates) | UINT32 | RW | 0x00040000 (262144dec)
*) see index 9009 FB OCT Nameplate
Index (hex) | Name | Meaning | Data type | Flags | Default
8011:29 | I2T warn level | I2T model warning threshold Unit: % | UINT8 | RW | 0x50 (80dec)
8011:2A | I2T error level | I2T model error threshold Unit: % | UINT8 | RW | 0x69 (105dec)
8011:2B* | Motor Temperature warn level | Overtemperature warning threshold Unit: 0.1 °C This value is affected by automatic scanning. (see Automatic scanning of the electronic identification plates) | UINT16 | RW | 0x03E8 (1000dec)
8011:2C* | Motor Temperature error level | Overtemperature error threshold Unit: 0.1 °C This value is affected by automatic scanning. (see Automatic scanning of the electronic identification plates) | UINT16 | RW | 0x05DC (1500dec)
8011:2D* | Motor thermal time constant | Thermal time constant Unit: 0.1 s This value is affected by automatic scanning. (see Automatic scanning of the electronic identification plates) | UINT16 | RW | 0x0028 (40dec)
*) see index 9009 FB OCT Nameplate
Index 8012 DRV Brake Settings
Index (hex) | Name | Meaning | Data type | Flags | Default
8012:0 | DRV Brake Settings | Maximum subindex | UINT8 | RO | 0x14 (20dec)
8012:01 | Manual override (release) | Manual release of the motor holding brake | BOOLEAN | RW | 0x00 (0dec)
8012:11* | Release delay | Time the holding brake requires for opening (releasing) after the current was applied This value is affected by automatic scanning. (see Automatic scanning of the electronic type plates) | UINT16 | RW | 0x0000 (0dec)
8012:12* | Application delay | Time the holding brake requires for closing (holding) after the current was switched off This value is affected by automatic scanning. (see Automatic scanning of the electronic type plates) | UINT16 | RW | 0x0000 (0dec)
8012:13 | Emergency application timeout | Time the amplifier waits, until the rotation speed reaches the stand still window after stop request (set rotation speed 0 or Torque off). If the set waiting time is exceeded, the holding brake is triggered independently of the rotation speed. Note: For rotatory axes and the setting „torque off“ in error case, this parameter has to be set at least to the „coast to the stop“ time of the axis. For suspended (hanging) axes and the setting „torque off“ in error case, this parameter has to be set to an appropriate short time, to prevent the axis/load from drop/fall. | UINT16 | RW | 0x0000 (0dec)
8012:14* | Brake moment of inertia | Mass moment of inertia of the brake Unit: g cm^2 This value is affected by automatic scanning. (see Automatic scanning of the electronic type plates) | UINT16 | RW | 0x0000 (0dec)
*) see index 9009 FB OCT Nameplate


Configuration data (vendor-specific)

Commissioning [image] Object description (MDP 742) [image] Configuration data (vendor-specific)
Configuration data (vendor-specific)
Index 801F DRV Vendor data
Index (hex) | Name | Meaning | Data type | Flags | Default
801F:0 | DRV Vendor data | Maximum subindex | UINT8 | RO | 0x14 (20dec)
801F:11 | Amplifier peak current | Peak current of the amplifier (peak value) Unit: mA | UINT32 | RW | 0x00001F40 (8000dec)
801F:12 | Amplifier rated current | Tated current of the amplifier (peak value) Unit: mA | UINT32 | RW | 0x00000FA0 (4000dec)
801F:13 | Amplifier thermal time constant | Thermal time constant of the amplifier Unit: 0.1 ms | UINT16 | RW | 0x0023 (35dec)
801F:14 | Amplifier overcurrent threshold | Threshold value for short-circuit detection Unit: mA | UINT32 | RW | 0x00002EE0 (12000dec)


Command object

Commissioning [image] Object description (MDP 742) [image] Command object
Command object
Index FB00 command
Index (hex) | Name | Meaning |  |  | Data type | Flags | Default
FB00:0 | DCM Command | Max. subindex |  |  | UINT8 | RO | 0x03 (3dec)
FB00:01 | Request | 0x1000 | Clear the Diag History | Clear the Diag History | OCTET-STRING[2] | RW | {0}
 |  | 0x1100 | Get build number | Read out the build number
 |  | 0x1101 | Get build date | Read out the build date
 |  | 0x1102 | Get build time | Read out the build time
 |  | 0x8000 | Software reset | Perform a software reset (hardware is re-initialized with the current CoE configuration; this otherwise happens only during the transition to INIT)
FB00:02 | Status | 0 | Finished, no error, no response | Command terminated without error and without response | UINT8 | RO | 0x00 (0dec)
 |  | 1 | Finished, no error, response | Command terminated without error and with response
 |  | 2 | Finished, error, no response | Command terminated with error and without response
 |  | 3 | Finished, error, response | Command terminated with error and with response
 |  | 255 | Executing | Command is being executed
FB00:03 | Response | dependent on the request |  |  | OCTET-STRING[4] | RO | {0}


Input data

Commissioning [image] Object description (MDP 742) [image] Input data
Input data
Index 6000 FB Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
6000:0 | FB Inputs | Maximum subindex | UINT8 | RO | 0x11 (17dec)
6000:11 | Position | Position | UINT32 | RO | 0x00000000 (0dec)
Index 6001 FB Touch probe inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
6001:0 | FB Touch probe inputs | Maximum subindex | UINT8 | RO | 0x14 (20dec)
6001:01 | TP1 Enable | Touchprobe 1 switched on | BOOLEAN | RO | 0x00 (0dec)
6001:02 | TP1 pos value stored | Positive value of Touchprobe 1 saved | BOOLEAN | RO | 0x00 (0dec)
6001:03 | TP1 Neg value stored | Negative value of Touchprobe 1 saved | BOOLEAN | RO | 0x00 (0dec)
6001:09 | TP2 Enable | Touchprobe 2 switched on | BOOLEAN | RO | 0x00 (0dec)
6001:0A | TP2 pos value stored | Positive value of Touchprobe 2 saved | BOOLEAN | RO | 0x00 (0dec)
6001:0B | TP2 neg value stored | Negative value of Touchprobe 2 saved | BOOLEAN | RO | 0x00 (0dec)
6001:11 | TP1 pos position | Positive value of Touchprobe 1 Unit: the given value must be multiplied by the corresponding scaling factor | UINT32 | RO | 0x00000000 (0dec)
6001:12 | TP1 neg position | Negative value of Touchprobe 1 Unit: the given value must be multiplied by the corresponding scaling factor | UINT32 | RO | 0x00000000 (0dec)
6001:13 | TP2 pos position | Positive value of Touchprobe 2 Unit: the given value must be multiplied by the corresponding scaling factor | UINT32 | RO | 0x00000000 (0dec)
6001:14 | TP2 neg position | Negative value of Touchprobe 2 Unit: the given value must be multiplied by the corresponding scaling factor | UINT32 | RO | 0x00000000 (0dec)
Index 6010 DRV Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
6010:0 | DRV Inputs | Maximum subindex | UINT8 | RO | 0x13 (19dec)
6010:01 | Statusword | Statusword Bit 0: Ready to switch on Bit 1: Switched on Bit 2: Operation enabled Bit 3: Fault Bit 4: reserved Bit 5: Quick stop (inverse) Bit 6: Switch on disabled Bit 7: Warning Bit 8 + 9: reserved Bit 10: TxPDOToggle (selection/deselection via 0x8010:01) Bit 11: Internal limit active Bit 12: Drive follows the command value Bit 13 - 15: reserved | UINT16 | RO | 0x0000 (0dec)
6010:03 | Modes of operation display | Modes of operation display. Permitted values: 9: Cyclic synchronous velocity mode (CSV) 10: Cyclic synchronous torque mode (CST) 11: Cyclic synchronous torque mode with commutation angle (CSTCA) | UINT8 | RO | 0x00 (0dec)
6010:06 | Following error actual value | Following error Unit: the given value must be multiplied by the corresponding scaling factor | INT32 | RO | 0x00000000 (0dec)
6010:07 | Velocity actual value | Display of the current velocity value Unit: see Index 0x9010:14 | INT32 | RO | 0x00000000 (0dec)
6010:08 | Position actual value | Display of current torque value The value is specified in 1000th of the rated current (0x8011:12) Equation for index 8010:54 = 0 : M = ((Torque actual value / 1000) x (rated current / √2)) x torque constant (8011:16) Equation for index 8010:54 = 1 : M = ((Torque actual value / 1000) x rated current)) x torque constant (8011:16) | INT16 | RO | 0x0000 (0dec)
6010:12 | Info data 1 | Synchronous information (selection via subindex 0x8010:39) | UINT16 | RO | 0x0000 (0dec)
6010:13 | Info data 2 | Synchronous information (selection via subindex 0x8010:3A) | UINT16 | RO | 0x0000 (0dec)


Output data

Commissioning [image] Object description (MDP 742) [image] Output data
Output data
Index 7001 FB Touch probe outputs
Index (hex) | Name | Meaning | Data type | Flags | Default
7001:0 | FB Touch probe outputs | Maximum subindex | UINT8 | RO | 0x0E (14dec)
7001:01 | TP1 Enable | Switch on Touchprobe 1 | BOOLEAN | RO | 0x00 (0dec)
7001:02 | TP1 Continous | 0: triggered only on the first event 1. triggered on every event | BOOLEAN | RO | 0x00 (0dec)
7001:03 | TP1 Trigger mode | Input 1 is triggered (not changeable) | BIT2 | RO | 0x00 (0dec)
7001:05 | TP1 Enable pos edge | Trigger on positive edge | BOOLEAN | RO | 0x00 (0dec)
7001:06 | TP1 Enable neg edge | Trigger on negative edge | BOOLEAN | RO | 0x00 (0dec)
7001:09 | TP2 Enable | Switch on Touchprobe 2 | BOOLEAN | RO | 0x00 (0dec)
7001:0A | TP2 Continous | 0: triggered only on the first event 1. triggered on every event | BOOLEAN | RO | 0x00 (0dec)
7001:0B | TP2 Trigger mode | Input 2 is triggered (not changeable) | BIT2 | RO | 0x00 (0dec)
7001:0D | TP2 Enable pos edge | Trigger on positive edge | BOOLEAN | RO | 0x00 (0dec)
7001:0E | TP2 Enable neg edge | Trigger on negative edge | BOOLEAN | RO | 0x00 (0dec)
Index 7010 DRV Outputs
Index (hex) | Name | Meaning | Data type | Flags | Default
7010:0 | DRV Outputs | Maximum subindex | UINT8 | RO | 0x0E (14dec)
7010:01 | Controlword | Controlword Bit 0: Switch on Bit 1: Enable voltage Bit 2: Quick stop (inverse) Bit 3: Enable operation Bit 4 - 6: reserved Bit 7: Fault reset Bit 8 - 15: reserved | UINT16 | RO | 0x0000 (0dec)
7010:03 | Modes of operation | Permitted values: 0x08: Cyclic synchronous position mode (CSP) 0x09: Cyclic synchronous velocity mode (CSV) 0x0A: Cyclic synchronous torque mode (CST) 0x0B: Cyclic synchronous torque mode with commutation angle (CSTCA) | UINT8 | RW | 0x00 (0dec)
7010:05 | Target position | Configured target position Unit: the value must be multiplied by the corresponding scaling factor | INT32 | RW | 0x00000000 (0dec)
7010:06 | Target velocity | Configured target velocity The velocity scaling can be found in object 0x9010:14 (Velocity encoder resolution) | INT32 | RO | 0x00000000 (0dec)
7010:09 | Target torque | Configured input value for torque monitoring The value is specified in 1000th of the rated current (0x8011:12) Equation for index 8010:54 = 0 : M = ((Torque actual value / 1000) x (rated current / √2)) x torque constant (8011:16) Equation for index 8010:54 = 1 : M = ((Torque actual value / 1000) x rated current)) x torque constant (8011:16) | INT16 | RO | 0x0000 (0dec)
7010:0A | Torque offset | Torque value offset The value is specified in 1000th of the rated current (0x8011:12) Equation for index 8010:54 = 0 : M = ((Torque actual value / 1000) x (rated current / √2)) x torque constant (8011:16) Equation for index 8010:54 = 1 : M = ((Torque actual value / 1000) x rated current)) x torque constant (8011:16) | INT16 | RO | 0x0000 (0dec)
7010:0B | Torque limitation | Torque threshold value for torque monitoring (bipolar limit) The value is specified in 1000th of the rated current (0x8011:12) Equation for index 8010:54 = 0 : M = ((Torque actual value / 1000) x (rated current / √2)) x torque constant (8011:16) Equation for index 8010:54 = 1 : M = ((Torque actual value / 1000) x rated current)) x torque constant (8011:16) | UINT16 | RW | 0x7FFF (32767dec)
7010:0E | Commutation angle | Commutation angle (for CSTCA mode) Unit: 360° / 216 | UINT16 | RO | 0x0000 (0dec)


Information / diagnosis data

Commissioning [image] Object description (MDP 742) [image] Information / diagnosis data
Information / diagnosis data
Index 10F3 Diagnosis History
Index (hex) | Name | Meaning | Data type | Flags | Default
10F3:0 | Diagnosis History | Maximum subindex | UINT8 | RO | 0x37 (55dec)
10F3:01 | Maximum Messages | Maximum number of stored messages. A maximum of 50 messages can be stored | UINT8 | RO | 0x00 (0dec)
10F3:02 | Newest Message | Subindex of the latest message | UINT8 | RO | 0x00 (0dec)
10F3:03 | Newest Acknowledged Message | Subindex of the last confirmed message | UINT8 | RW | 0x00 (0dec)
10F3:04 | New Messages Available | Indicates that a new message is available | BOOLEAN | RO | 0x00 (0dec)
10F3:05 | Flags | not used | UINT16 | RW | 0x0000 (0dec)
10F3:06 | Diagnosis Message 001 | Message 1 | OCTET-STRING[28] | RO | {0}
... | ... | ... | ... | ... | ...
10F3:37 | Diagnosis Message 050 | Message 50 | OCTET-STRING[28] | RO | {0}
Index 10F8 Actual Time Stamp
Index (hex) | Name | Meaning | Data type | Flags | Default
10F8:0 | Actual Time Stamp | Time stamp | UINT64 | RO |
Index 9008 FB OCT Info data
(these data are always read in automatically from the electronic identification plate of the motor and serve purely informative purposes)
Index (hex) | Name | Meaning | Data type | Flags | Default
9008:0 | FB OCT Info data | Maximum subindex | UINT8 | RO | 0x1F (31dec)
9008:11 | Encoder type | Feedback type 2: rotary encoder, unipolar counting | UINT16 | RO | 0x0000 (0dec)
9008:12 | Resolution | Resolution of the feedback Unit: Steps per revolution | UINT32 | RO | 0x00000000 (0dec)
9008:13 | Range | Working area of the feedback. On leaving this range there is an overflow of the position. Unit: Revolutions | UINT32 | RO | 0x00000000 (0dec)
9008:14 | Type Code Name | Name of the feedback | STRING | RO |
9008:15 | Serial No | Serial number of the feedback | STRING | RO |
9008:16 | Firmware Revision No | Revision of the firmware | STRING | RO |
9008:17 | Firmware Date | Date of the firmware | STRING | RO |
9008:18 | EEPROM Size | EEPROM size | UINT16 | RO | 0x0000 (0dec)
9008:19 | Temperature | Temperature Unit: 0.1° | INT16 | RO | 0x0000 (0dec)
9008:1A | LED Current | Current of the feedback LED Unit: 0.1 mA | UINT16 | RO | 0x0000 (0dec)
9008:1B | Supply voltage | Supply voltage of the feedback Unit: mV | UINT32 | RO | 0x00000000 (0dec)
9008:1C | Life- time | Operating hour counter Unit: Minutes | UINT32 | RO | 0x00000000 (0dec)
9008:1D | Received Signal Strength Indicator | Received signal strength at the box Unit: % | UINT16 | RO | 0x0000 (0dec)
9008:1E | Slave Received Signal Strength Indicator | Received signal strength at the encoder Unit: % | UINT16 | RO | 0x0000 (0dec)
9008:1F | Line delay | Running time of the signal in the cable Unit: ns | UINT16 | RO | 0x0000 (0dec)
Index 9009 FB OCT Nameplate
The parameters described in this index are always read from the electronic type plate of the connected motor. These parameters automatically lead to the parameters marked with an asterisk (*) in this chapter, if automatic scanning of the electronic type plate is switched on (index 8008).
Index (hex) | Name | Meaning | Data type | Flags | Default
9009:0 | FB OCT Nameplate | Maximum subindex | UINT8 | RO | 0x24 (36dec)
9009:01 | Motor vendor | Motor vendor | STRING | RO |
9009:02 | Electric motor type | Motor type | STRING | RO |
9009:03 | Serial No | Serial number | STRING | RO |
9009:04 | Order code | Order number (In case of Autoconfig a check is made on the basis of this index as to whether the motor is identical to the predecessor) | STRING | RO |
9009:05 | Motor construction | Type of motor | STRING | RO |
9009:06 | Pole pairs | Number of pole pairs | UINT32 | RO | 0x00000000 (0dec)
9009:07 | Standstill current (rms) | Effective holding current Unit: mA | UINT32 | RO | 0x00000000 (0dec)
9009:08 | Rated current (rms) | Effective rated current Unit: mA | UINT32 | RO | 0x00000000 (0dec)
9009:09 | Peak current (rms) | Effective peak current Unit: mA | UINT32 | RO | 0x00000000 (0dec)
9009:0A | Nominal voltage (rms) | Effective nominal voltage Unit: mV | UINT32 | RO | 0x00000000 (0dec)
9009:0B | Max voltage (rms) | Maximum voltage Unit: mV | UINT32 | RO | 0x00000000 (0dec)
9009:0C | Max winding du/dt | Maximum permissible voltage rise on the winding Unit: kV/s | UINT32 | RO | 0x00000000 (0dec)
9009:0D | Max torque | Maximum torque Unit: mNm | UINT16 | RO | 0x0000 (0dec)
9009:0E | Torque constant | Torque constant Unit: mNm / A | UINT16 | RO | 0x0000 (0dec)
9009:0F | EMK (rms) | Reverse voltage Unit: mV / (rpm) | UINT32 | RO | 0x00000000 (0dec)
9009:10 | Winding resistance Ph-Ph 20°C | Coil resistance Unit: mOhm | UINT16 | RO | 0x0000 (0dec)
9009:11 | Ld Ph-Ph | Inductance in the direction of flow Unit: 0.1 mH | UINT16 | RO | 0x0000 (0dec)
9009:12 | Lq Ph-Ph | Inductance in the torque-forming direction Unit: 0.1 mH | UINT16 | RO | 0x0000 (0dec)
Index (hex)
Name
Meaning
Data type
Flags
Default
9009:13
Max speed
Maximum speed
Unit: rpm
UINT32
RO
0x00000000 (0dec)
9009:14
Moment of inertia
Mass moment of inertia
Unit: g cm^2
UINT16
RO
0x0000 (0dec)
9009:15
T motor warn limit
Motor temperature warning threshold
Unit: 0.1°C
UINT16
RO
0x0000 (0dec)
9009:16
T motor shut down
Motor temperature error threshold
Unit: 0.1°C
UINT16
RO
0x0000 (0dec)
9009:17
Time constant i2t
Time constant I2T model
Unit: s
UINT16
RO
0x0000 (0dec)
9009:18
Motor thermal constant
Thermal time constant of the motor
Unit: s
UINT16
RO
0x0000 (0dec)
9009:1B
Brake type
Brake type
▪
no Brake
▪
holding Brake
STRING
RO
9009:1C
Min brake voltage
Minimum brake voltage
Unit: mV
UINT32
RO
0x00000000 (0dec)
9009:1D
Max brake voltage
Maximum brake voltage
Unit: mV
UINT32
RO
0x00000000 (0dec)
9009:1E
Min brake monitor current
Minimum current for the monitoring of the brake
Unit: mA
UINT32
RO
0x00000000 (0dec)
9009:1F
Brake holding torque
Brake holding torque
Unit: mNm
UINT32
RO
0x00000000 (0dec)
9009:20
Brake T on
Time until the brake is applied
Unit: ms
UINT16
RO
0x0000 (0dec)
9009:21
Brake T off
Time until the brake is released
Unit: ms
UINT16
RO
0x0000 (0dec)
9009:22
Brake reduced holding voltage
Reduced brake voltage
Unit: mV
UINT32
RO
0x00000000 (0dec)
9009:23
Brake time to red. holding volt.
Time from which the brake holds with reduced voltage
Unit: ms
UINT16
RO
0x0000 (0dec)
9009:24
Motor temp sensor connection
Temperature sensor connection
Feedback port (not changeable)
STRING
RO
Index 9010 DRV Info data
Index (hex) | Name | Meaning | Data type | Flags | Default
9010:0 | DRV info data | Maximum subindex | UINT8 | RO | 0x14 (20dec)
9010:11 | Amplifier temperature | Internal temperature of the box Unit: 0.1 °C | UINT16 | RO | 0x0000 (0dec)
9010:12 | DC link voltage | DC link voltage Unit: mV | UINT32 | RO | 0x00000000 (0dec)
9010:13 | Supported drive modes | Information about supported drive modes. (DS402: Object 0x6502) Only modes CSV, CST, CSTCA and CSP are supported Bit 0: PP Bit 1: VL Bit 2: PV Bit 3: TQ Bit 4: R Bit 5: HM Bit 6: IP Bit 7: CSP Bit 8: CSV Bit 9: CST Bit 10: CSTCA Bit 11 - 15: reserved Bit 16-31: Manufacturer-specific | UINT32 | RO | 0x00000000 (0dec)
9010:14 | Velocity encoder resolution | Display of configured encoder increments/s and motor revolutions/s. The velocity encoder resolution is calculated according to the following formula: Velocity Encoder Resolution = (encoder_increments / s ) / (motor_revolutions / s) | UINT32 | RO | 0x00041893 (268435dec)
Index 9018 DRV Info data
Index (hex) | Name | Meaning | Data type | Flags | Default
9018:0 | DRV Info data | Maximum subindex | UINT8 | RO | 0x11 (17dec)
9018:11 | Auxiliary voltage (10 V) | Auxiliary voltage Unit: mV | UINT32 | RO | 0x00000000 (0dec)
Index A010 DRV Amplifier Diag data
Index (hex) | Name | Meaning | Data type | Flags | Default
A010:0 | DRV Amplifier Diag data | Maximum subindex | UINT8 | RO | 0x11 (17dec)
A010:11 | Amplifier I2T temperature | I2T model load Unit: % | UINT8 | RO | 0x00 (0dec)
Index A011 DRV Motor Diag data
Index (hex) | Name | Meaning | Data type | Flags | Default
A011:0 | DRV Motor Diag data | Maximum subindex | UINT8 | RO | 0x13 (19dec)
A011:11 | Motor I2T temperature | I2T model load Einheit: % | UINT8 | RO | 0x00 (0dec)
A011:13 | Motor temperature | Temperature utilization ratio Unit: ° | INT16 | RO | 0x0000 (0dec)


Standard objects

Commissioning [image] Object description (MDP 742) [image] Standard objects
Standard objects
Index 1000 Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: the Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x00001389 (5001dec)
Index 1008 Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EP7211-0034
Index 1009 Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO |
Index 100A Software version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO |
Index 1018 Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x1C2B4052 (472596562dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the low word (bit 0-15) indicates the special terminal number, the high word (bit 16-31) refers to the device description | UINT32 | RO | 0x00000000 (0dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the Low Byte (bit 0-7) of the Low Word contains the year of production, the High Byte (bit 8-15) of the Low Word contains the week of production, the High Word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 Backup parameter handling
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | Information for standardized loading and saving of backup entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum across all backup entries of the EtherCAT slave | UINT32 | RO | 0x00000000 (0dec)
Index 1600 DRV RxPDO-Map Controlword
Index (hex) | Name | Meaning | Data type | Flags | Default
1600:0 | DRV RxPDO-Map Controlword | PDO Mapping RxPDO 1 | UINT8 | RO | 0x01 (1dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (DRV Outputs), entry 0x01 (Controlword)) | UINT32 | RO | 0x7010:01, 16
Index 1601 DRV RxPDO-Map Target velocity
Index (hex) | Name | Meaning | Data type | Flags | Default
1601:0 | DRV RxPDO-Map Target velocity | PDO Mapping RxPDO 2 | UINT8 | RO | 0x01 (1dec)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (DRV Outputs), entry 0x06 (Target velocity)) | UINT32 | RO | 0x7010:06, 32
Index 1602 DRV RxPDO-Map Target torque
Index (hex) | Name | Meaning | Data type | Flags | Default
1602:0 | DRV RxPDO-Map Target torque | PDO Mapping RxPDO 3 | UINT8 | RO | 0x01 (1dec)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (DRV Outputs), entry 0x09 (Target torque)) | UINT32 | RO | 0x7010:09, 16
Index 1603 DRV RxPDO-Map Commutation angle
Index (hex) | Name | Meaning | Data type | Flags | Default
1603:0 | DRV RxPDO-Map Commutation angle | PDO Mapping RxPDO 4 | UINT8 | RO | 0x01 (1dec)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (DRV Outputs), entry 0x0E (Commutation angle)) | UINT32 | RO | 0x7010:0E, 16
Index 1604 DRV RxPDO-Map Torque limitation
Index (hex) | Name | Meaning | Data type | Flags | Default
1604:0 | DRV RxPDO-Map Torque limitation | PDO Mapping RxPDO 5 | UINT8 | RO | 0x01 (1dec)
1604:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (DRV Outputs), entry 0x0B (Torque limitation)) | UINT32 | RO | 0x7010:0B, 16
Index 1605 DRV RxPDO-Map Torque offset
Index (hex) | Name | Meaning | Data type | Flags | Default
1605:0 | DRV RxPDO-Map Torque offset | PDO Mapping RxPDO 6 | UINT8 | RO | 0x01 (1dec)
1605:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (DRV Outputs), entry 0x0A (Torque offset)) | UINT32 | RO | 0x7010:0A, 16
Index 1606 DRV RxPDO-Map Target position
Index (hex) | Name | Meaning | Data type | Flags | Default
1606:0 | DRV RxPDO-Map Target position | PDO Mapping RxPDO 7 | UINT8 | RO | 0x01 (1dec)
1606:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (DRV Outputs), entry 0x05 (Target postion)) | UINT32 | RO | 0x7010:05, 32
Index 1607 FB RxPDO-Map Touch probe control
Index (hex) | Name | Meaning | Data type | Flags | Default
1607:0 | FB RxPDO-Map Touch probe control | PDO Mapping RxPDO 8 | UINT8 | RO | 0x0C (12dec)
1607:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7001 (FB Touch probe outputs), entry 0x01 (TP1 Enable)) | UINT32 | RO | 0x7001:01, 1
1607:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7001 (FB Touch probe outputs), entry 0x02 (TP1 Continous)) | UINT32 | RO | 0x7001:02, 1
1607:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7001 (FB Touch probe outputs), entry 0x03 (TP1 Trigger mode)) | UINT32 | RO | 0x7001:03, 2
1607:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7001 (FB Touch probe outputs), entry 0x05 (TP1 Enable pos edge)) | UINT32 | RO | 0x7001:05, 1
1607:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7001 (FB Touch probe outputs), entry 0x06 (TP1 Enable neg edge)) | UINT32 | RO | 0x7001:06, 1
1607:06 | SubIndex 006 | 6. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1607:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7001 (FB Touch probe outputs), entry 0x09 (TP2 Enable)) | UINT32 | RO | 0x7001:09, 1
1607:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7001 (FB Touch probe outputs), entry 0x0A (TP2 Continous)) | UINT32 | RO | 0x7001:0A, 1
1607:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7001 (FB Touch probe outputs), entry 0x0B (TP2 Trigger mode)) | UINT32 | RO | 0x7001:0B, 2
1607:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7001 (FB Touch probe outputs), entry 0x0D (TP2 Enable pos edge)) | UINT32 | RO | 0x7001:0D, 1
1607:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7001 (FB Touch probe outputs), entry 0x0E (TP2 Enable neg edge)) | UINT32 | RO | 0x7001:0E, 1
1607:0C | SubIndex 012 | 12. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
Index 1A00 FB TxPDO-Map Position
Index (hex) | Name | Meaning | Data type | Flags | Default
1A00:0 | FB TxPDO-Map Position | PDO Mapping TxPDO 1 | UINT8 | RO | 0x01 (1dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (FB Inputs), entry 0x11 (Position)) | UINT32 | RO | 0x6000:11, 32
Index 1A01 DRV TxPDO-Map Statusword
Index (hex) | Name | Meaning | Data type | Flags | Default
1A01:0 | DRV TxPDO-Map Statusword | PDO Mapping TxPDO 2 | UINT8 | RO | 0x01 (1dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DRV Inputs), entry 0x01 (Statusword)) | UINT32 | RO | 0x6010:01, 16
Index 1A02 DRV TxPDO-Map Velocity actual value
Index (hex) | Name | Meaning | Data type | Flags | Default
1A02:0 | DRV TxPDO-Map Velocity actual value | PDO Mapping TxPDO 3 | UINT8 | RO | 0x01 (1dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DRV Inputs), entry 0x07 (Velocity actual value)) | UINT32 | RO | 0x6010:07, 32
Index 1A03 DRV TxPDO-Map Torque actual value
Index (hex) | Name | Meaning | Data type | Flags | Default
1A03:0 | DRV TxPDO-Map Torque actual value | PDO Mapping TxPDO 4 | UINT8 | RO | 0x01 (1dec)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DRV Inputs), entry 0x08 (Torque actual value)) | UINT32 | RO | 0x6010:08, 16
Index 1A04 DRV TxPDO-Map Info data 1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A04:0 | DRV TxPDO-Map Info data 1 | PDO Mapping TxPDO 5 | UINT8 | RO | 0x01 (1dec)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DRV Inputs), entry 0x12 (Info data 1)) | UINT32 | RO | 0x6010:12, 16
Index 1A05 DRV TxPDO-Map Info data 2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A05:0 | DRV TxPDO-Map Info data 2 | PDO Mapping TxPDO 6 | UINT8 | RO | 0x01 (1dec)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DRV Inputs), entry 0x13 (Info data 2)) | UINT32 | RO | 0x6010:13, 16
Index 1A06 DRV TxPDO-Map Following error actual value
Index (hex) | Name | Meaning | Data type | Flags | Default
1A06:0 | DRV TxPDO-Map Following error actual value | PDO Mapping TxPDO 7 | UINT8 | RO | 0x01 (1dec)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DRV Inputs), entry 0x01 (Statusword)) | UINT32 | RO | 0x6010:09, 32
Index 1A07 FB TxPDO-Map Touch probe status
Index (hex) | Name | Meaning | Data type | Flags | Default
1A07:0 | FB TxPDO-Map Touch probe status | PDO Mapping TxPDO 8 | UINT8 | RO | 0x08 (8dec)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DRV Inputs), entry 0x07 (Velocity actual value)) | UINT32 | RO | 0x6001:01, 1
1A07:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6001 (FB Touch probe inputs), entry 0x02 (TP1 pos value stored)) | UINT32 | RO | 0x6001:02, 1
1A07:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6001 (FB Touch probe inputs), entry 0x03 (TP1 Neg value stored)) | UINT32 | RO | 0x6001:03, 1
1A07:04 | SubIndex 004 | 4. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A07:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6001 (FB Touch probe inputs), entry 0x09 (TP2 Enable)) | UINT32 | RO | 0x6001:09, 1
1A07:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6001 (FB Touch probe inputs), entry 0x0A (TP2 pos value stored)) | UINT32 | RO | 0x6001:0A, 1
1A07:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6001 (FB Touch probe inputs), entry 0x0B (TP2 neg value stored)) | UINT32 | RO | 0x6001:0B, 1
1A07:08 | SubIndex 008 | 8. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
Index 1A08 FB TxPDO-Map Touch probe 1 pos position
Index (hex) | Name | Meaning | Data type | Flags | Default
1A08:0 | FB TxPDO-Map Touch probe 1 pos position | PDO Mapping TxPDO 9 | UINT8 | RO | 0x01 (1dec)
1A08:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (FP Touch probe inputs), entry 0x11 (TP1 Pos position)) | UINT32 | RO | 0x6001:11, 32
Index 1A09 FB TxPDO-Map Touch probe 1 neg position
Index (hex) | Name | Meaning | Data type | Flags | Default
1A09:0 | FB TxPDO-Map Touch probe 1 neg position | PDO Mapping TxPDO 10 | UINT8 | RO | 0x01 (1dec)
1A09:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (FB Touch probe inputs), entry 0x12 (TP1 Neg position)) | UINT32 | RO | 0x6001:12, 32
Index 1A0A FB TxPDO-Map Touch probe 2 pos position
Index (hex) | Name | Meaning | Data type | Flags | Default
1A0A:0 | FB TxPDO-Map Touch probe 2 pos position | PDO Mapping TxPDO 11 | UINT8 | RO | 0x01 (1dec)
1A0A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (FB Touch probe inputs), entry 0x13 (TP2 Pos position)) | UINT32 | RO | 0x6001:13, 32
Index 1A0B FB TxPDO-Map Touch probe 2 neg position
Index (hex) | Name | Meaning | Data type | Flags | Default
1A0B:0 | FB TxPDO-Map Touch probe 2 neg position | PDO Mapping TxPDO 12 | UINT8 | RO | 0x01 (1dec)
1A0B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (FB Touch probe inputs), entry 0x14 (TP2 neg position)) | UINT32 | RO | 0x6001:14, 32
Index 1C00 Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the sync managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x02 (2dec)
1C12:01 | Subindex 001 | 1. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1600 (5632dec)
1C12:02 | Subindex 002 | 2. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1601 (5633dec)
1C12:03 | Subindex 003 | 3. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:04 | Subindex 004 | 4. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:05 | Subindex 005 | 5. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:06 | Subindex 006 | 6. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:07 | Subindex 007 | 7. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:08 | Subindex 008 | 8. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 1C13 TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x03 (3dec)
1C13:01 | Subindex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A01 (6657dec)
1C13:03 | Subindex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A02 (6658dec)
1C13:04 | Subindex 004 | 4. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:05 | Subindex 005 | 5. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:06 | Subindex 006 | 6. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:07 | Subindex 007 | 7. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:08 | Subindex 008 | 8. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:09 | Subindex 009 | 9. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0A | Subindex 010 | 10. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0B | Subindex 011 | 11. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0C | Subindex 012 | 12. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 1C32 SM output parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C32:0
SM output parameter
Synchronization parameters for the outputs
UINT8
RO
0x20 (32dec)
1C32:01
Sync mode
Current synchronization mode:
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0000 (0dec)
1C32:02
Cycle time
Cycle time (in ns):
▪
Free Run: Cycle time of the local timer
▪
Synchronous with SM 2 event: Master cycle time
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x0003D090 (250000dec)
1C32:03
Shift time
Time between SYNC0 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0 = 1: free run is supported
▪
Bit 1 = 1: Synchronous with SM 2 event is supported
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 10: Output shift with SYNC1 event (only DC mode)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08)
UINT16
RO
0x4808 (18440dec)
1C32:05
Minimum cycle time
Minimum cycle time (in ns)
UINT32
RO
0x0001E848 (125000dec)
1C32:06
Calc and copy time
Minimum time between SYNC0 and SYNC1 event (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:07
Minimum delay time
UINT32
RO
0x00000000 (0dec)
1C32:08
Command
▪
0: Measurement of the local cycle time is stopped
▪
1: Measurement of the local cycle time is started
The entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, and 0x1C33:09 are updated with the maximum measured values.
For a subsequent measurement the measured values are reset
UINT16
RW
0x0000 (0dec)
1C32:09
Maximum delay time
Time between SYNC1 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:0B
SM event missed counter
Number of missed SM events in OPERATIONAL (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:0C
Cycle exceeded counter
Number of occasions the cycle time was exceeded in OPERATIONAL (cycle was not completed in time or the next cycle began too early)
UINT16
RO
0x0000 (0dec)
1C32:0D
Shift too short counter
Number of occasions that the interval between SYNC0 and SYNC1 event was too short (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:20
Sync error
The synchronization was not correct in the last cycle (outputs were output too late; DC mode only)
BOOLEAN
RO
0x00 (0dec)
Index 1C33 SM input parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
3: DC - Synchron with SYNC1 Event
UINT16
RW
0x0000 (0dec)
1C33:02
Cycle time
as 0x1C32:02
UINT32
RW
0x0003D090 (250000dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00001C52 (7250dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: synchronous with SM 2 event is supported (outputs available)
▪
Bit 1: synchronous with SM 3 event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: input shift through local event (outputs available)
▪
Bit 4-5 = 10: input shift with SYNC1 event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08 or 0x1C33:08)
UINT16
RO
0x4808 (18440dec)
1C33:05
Minimum cycle time
as 0x1C32:05
UINT32
RO
0x0001E848 (125000dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:07
Minimum delay time
UINT32
RO
0x00001C52 (7250dec)
1C33:08
Command
as 0x1C32:08
UINT16
RW
0x0000 (0dec)
1C33:09
Maximum delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00001C52 (7250dec)
1C33:0B
SM event missed counter
as 0x1C32:11
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
as 0x1C32:12
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
as 0x1C32:13
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
as 0x1C32:32
BOOLEAN
RO
0x00 (0dec)
Index F000 Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index spacing of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0002 (2dec)
Index F008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module list
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list | Maximum subindex | UINT8 | RW | 0x02 (2dec)
F010:01 | SubIndex 001 | Encoder profile number | UINT32 | RW | 0x00000201 (513dec)
F010:02 | SubIndex 002 | Servo drive profile number | UINT32 | RW | 0x000002E6 (742dec)
Index FB40 Memory interface
Index (hex) | Name | Meaning | Data type | Flags | Default
FB40:0 | Memory interface | Maximum subindex | UINT8 | RO | 0x03 (3dec)
FB40:01 | Address | reserved | UINT32 | RW | 0x00000000 (0dec)
FB40:02 | Length | reserved | UINT16 | RW | 0x0000 (0dec)
FB40:03 | Data | reserved | OCTET-STRING[8] | RW | {0}


Object description (DS402)

Commissioning [image] Object description (DS402)
Object description (DS402)
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Parameterization via the CoE list (CAN over EtherCAT)
The box is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs). Please note the following general CoE information when using/manipulating the CoE parameters:
- Keep a startup list if components have to be replaced
- Differentiation between online/offline dictionary, existence of current XML description
- use “CoE reload” for resetting changes
Note
Risk of damage to the device!
We strongly advise not to change settings in the CoE objects while the axis is active, since this could impair the control.
Additional information
•
Configuration data
•
Configuration data (vendor-specific)
•
Command object
•
Input/output data
•
Information / diagnosis data
•
Standard objects


Configuration data

Commissioning [image] Object description (DS402) [image] Configuration data
Configuration data
Index 2002 Amplifier Settings
Index (hex) | Name | Meaning | Data type | Flags | Default
2002:0 | Amplifier Settings | Maximum subindex | UINT8 | RO | 0x49 (73dec)
2002:11 | Device type | 1: Servo drive (cannot be changed) | UINT32 | RW | 0x00000001 (1dec)
2002:12* | Current loop integral time | Integral component of current controller Unit: 0.1 ms This value is affected by automatic scanning. (see Automatic scanning of the electronic identification plates) | UINT16 | RW | 0x000A (10dec)
2002:13* | Current loop proportional gain | Proportional component of current controller Unit: 0.1 V/A This value is affected by automatic scanning. (see Automatic scanning of the electronic identification plates) | UINT16 | RW | 0x0064 (100dec)
2002:14 | Velocity loop integral time | Integral component of velocity controller Unit: 0.1 ms | UINT32 | RW | 0x00000032 (50dec)
2002:15 | Velocity loop proportional gain | Proportional component of velocity controller Unit: mA / (rad/s) | UINT32 | RW | 0x00000096 (150dec)
2002:17 | Position loop proportional gain | Proportional component position controller Unit: (rad/s) / rad | UINT32 | RW | 0x0000000A (10dec)
2002:19 | Nominal DC link voltage | Nominal DC link voltage Unit: mV | UINT32 | RW | 0x0000BB80 (48000dec)
2002:1A | Min DC link voltage | Minimum DC link voltage Unit: mV | UINT32 | RW | 0x00001A90 (6800dec)
2002:1B | Max DC link voltage | Maximum DC link voltage Unit: mV | UINT32 | RW | 0x0000EA60 (60000dec)
2002:29 | Amplifier I2T warn level | I²T model warning threshold Unit: % | UINT8 | RW | 0x50 (80dec)
2002:2A | Amplifier I2T error level | I²T model error threshold Unit: % | UINT8 | RW | 0x69 (105dec)
2002:2B | Amplifier temperature warn level | Overtemperature warning threshold Unit: 0.1 °C | UINT16 | RW | 0x0320 (800dec)
2002:2C | Amplifier temperature error level | Overtemperature error threshold Unit: 0.1 °C | UINT16 | RW | 0x03E8 (1000dec)
2002:31 | Velocity limitation | Velocity limitation Unit: rpm | UINT32 | RW | 0x00040000 (262144dec)
2002:32 | Short circuit brake duration max | Max. duration of armature short circuit brake Unit: ms | UINT16 | RW | 0x03E8 (1000dec)
2002:33 | Stand still window | Standstill window Unit: rpm | UINT16 | RW | 0x0000 (0dec)
2002:41 | Low-pass filter frequency | Low-pass filter frequency Unit: Hz The following values can be set: 0 Hz = off 160 Hz 320 Hz | UINT16 | RW | 0x0140 (320dec)
2002:49 | Halt ramp deceleration | Halt ramp deceleration Unit: 0.1 rad / s² | UINT32 | RW | 0x0000F570 (62832dec)
Index (hex) | Name | Meaning | Data type | Flags | Default
2002:53 | Position loop proportional gain | Proportional component position controller Unit: mA / (rad/s) | UINT32 | RW | 0x00000000 (0 dec)
2002:54 | Feature bits | The adjustable motor current values can be interpreted as peak values or rms values. The feature bit (2002:54) enables the conversion. Peak value → Bit 0 = 0 (default) RMS value → Bit 0 = 1 normal output current → Bit 1 = 0 (default) increased output current → Bit 1 = 1 From these, the following combinations can be set: 0dec → normal output current interpreted as peak value 1dec → normal output current interpreted as rms value 2dec → increased output current interpreted as peak value 3dec → increased output current interpreted as rms value | UINT32 | RW | 0x00000000 (0 dec)
2002:55 | Select info data 1 | Selection "Info data 1" Optional display of additional information in the cyclic process data. The following parameters are available. | UINT8 | RW | 0x00 (0 dec)
 |  | Torque current (filtered 1ms) [1000th of rated current]
 |  | DC link voltage [mV]
 |  | PCB temperature [0.1 °C]
 |  | Errors: Bit0: ADC Error Bit1: Overcurrent Bit2: Undervoltage Bit3: Overvoltage Bit4: Overtemperature Bit5: I2T Amplifier Bit6: I2T Motor Bit7: Encoder Bit8: Watchdog
 |  | Warnings: Bit2: Undervoltage Bit3: Overvoltage Bit4: Overtemperature Bit5: I2T Amplifier Bit6: I2T Motor Bit7: Encoder
 |  | I2T Motor [%]
 |  | I2T Amplifier [%]
 |  | Input Level: Bit0: Digital Input 1 Level Bit1: Digital Input 2 Level
2002:56 | Select info data 2 | Selection "Info data 2" Optional display of additional information in the cyclic process data. The following parameters are available. | UINT8 | RW | 0x00 (0 dec)
 |  | Torque current (filtered 1ms) [1000th of rated current]
 |  | DC link voltage [mV]
 |  | PCB temperature [0.1 °C]
 |  | Errors: Bit0: ADC Error Bit1: Overcurrent Bit2: Undervoltage Bit3: Overvoltage Bit4: Overtemperature Bit5: I2T Amplifier Bit6: I2T Motor Bit7: Encoder Bit8: Watchdog
 |  | Warnings: Bit2: Undervoltage Bit3: Overvoltage Bit4: Overtemperature Bit5: I2T Amplifier Bit6: I2T Motor Bit7: Encoder
 |  | I2T Motor [%]
 |  | I2T Amplifier [%]
 |  | Input Level: Bit0: Digital Input 1 Level Bit1: Digital Input 2 Level
*) see index 2059 FB OCT Nameplate
Index 2003 Motor Settings
Index (hex) | Name | Meaning | Data type | Flags | Default
2003:0 | Motor Settings | Maximum subindex | UINT8 | RO | 0x2D (45dec)
2003:11* | Max current | Peak current Unit: mA The adjustable motor current values can be interpreted as peak values or rms values. The feature bit (2002:54) enables the conversion. Peak value → Bit 0 = 0 (default) RMS value → Bit 0 = 1 This value is affected by automatic scanning. (see Automatic scanning of the electronic identification plates) | UINT32 | RW | 0x00001770 (6000dec)
2003:13* | Motor pole pairs | Number of pole pairs This value is affected by automatic scanning. (see Automatic scanning of the electronic identification plates) | UINT8 | RW | 0x03 (3dec)
2003:15* | Commutation offset | Commutation offset (between electrical zero position and mechanical single-turn zero position) Unit: ° This value is affected by automatic scanning. (see Automatic scanning of the electronic identification plates) | INT16 | RW | 0x0000 (0dec)
2003:16* | Torque constant | Torque constant Unit: mNm / A This value is affected by automatic scanning. (see Automatic scanning of the electronic identification plates) | UINT32 | RW | 0x00000000 (0dec)
2003:18* | Rotor moment of inertia | Mass moment of inertia of the motor Unit: g cm^2 This value is affected by automatic scanning. (see Automatic scanning of the electronic identification plates) | UINT32 | RW | 0x00000000 (0dec)
2003:19* | Winding inductance | Inductance Unit: 0.1 mH This value is affected by automatic scanning. (see Automatic scanning of the electronic identification plates) | UINT16 | RW | 0x000E (14dec)
2003:29 | Motor I2T warn level | I2T model warning threshold Unit: % | UINT8 | RW | 0x50 (80dec)
2003:2A | Motor I2T error level | I2T model error threshold Unit: % | UINT8 | RW | 0x69 (105dec)
2003:2B* | Motor Temperature warn level | Overtemperature warning threshold Unit: 0.1 °C This value is affected by automatic scanning. (see Automatic scanning of the electronic identification plates) | UINT16 | RW | 0x0000 (0dec)
2003:2C* | Motor Temperature error level | Overtemperature error threshold Unit: 0.1 °C This value is affected by automatic scanning. (see Automatic scanning of the electronic identification plates) | UINT16 | RW | 0x0000 (0dec)
2003:2D* | Motor thermal time constant | Thermal time constant Unit: 0.1 s This value is affected by automatic scanning. (see Automatic scanning of the electronic identification plates) | UINT16 | RW | 0x0028 (40dec)
*) see index 2059 FB OCT Nameplate
Index 2004 brake settings
Index (hex) | Name | Meaning | Data type | Flags | Default
2004:0 | Brake settings | Maximum subindex | UINT8 | RO | 0x14 (20dec)
2004:01 | Manual override (release) | Manual release of the motor holding brake | BOOLEAN | RW | 0x00 (0dec)
2004:11* | Release delay | Time required by the holding brake for opening (releasing) after the voltage was applied This value is affected by automatic scanning. (see Automatic scanning of the electronic identification plates) | UINT16 | RW | 0x0000 (0dec)
2004:12* | Application delay | Time required by the holding brake for closing (holding) after the voltage was switched off This value is affected by automatic scanning. (see Automatic scanning of the electronic identification plates) | UINT16 | RW | 0x0000 (0dec)
2004:13 | Emergency application timeout | Time that the amplifier waits until the speed has reached the standstill window after the stop request (set speed 0 after halt ramp or Torque off). The holding brake is triggered irrespective of the speed if the set waiting time is exceeded. Note: With rotary axes and the Torque off setting for the error case, this parameter must be adjusted at least to the longest time of the "coasting down" of the axis. With suspended axes and the Torque off setting for the error case, this parameter must be set to a very short time in order to prevent further sagging of the axis/load. | UINT16 | RW | 0x0000 (0dec)
2004:14* | Brake moment of inertia | Mass moment of inertia of the brake Unit: g cm^2 This value is affected by automatic scanning. (see Automatic scanning of the electronic identification plates) | UINT16 | RW | 0x0000 (0dec)
*) see index 2059 FB OCT Nameplate
Index 2010 feedback settings
Index (hex) | Name | Meaning | Data type | Flags | Default
2010:0 | Feedback settings | Maximum subindex | UINT8 | RO | 0x13 (19dec)
2010:01 | Invert feedback direction | Inverting the count direction | BOOLEAN | RW | 0x00 (0dec)
2010:11 | Device type | 3: OCT (not changeable) | UINT32 | RW | 0x00000003 (3dec)
2010:12 | Single-turn bits | Number of single-turn bits | UINT8 | RW | 0x14 (20dec)
2010:13 | Multi-turn bits | Number of multi-turn bits | UINT8 | RW | 0x0C (12dec)
2010:14 | Observer bandwidth | Bandwidth of the speed observer [Hz] | UINT16 | RW | 0x01F4 (500dec)
2010:15 | Observer feed-forward | Load ratio [%] 100% = load-free 50% = mass moments of inertia of input and output are equal | UINT8 | RW | 0x01 (0dec)
Index 2018 OCT Settings
Index (hex) | Name | Meaning | Data type | Flags | Default
2018:0 | OCT Settings | Maximum subindex | UINT8 | RO | 0x03 (3dec)
2018:01 | Enable auto config | Configuration takes place automatically after the reading of the electronic identification plate (see Automatic scanning of the electronic identification plates) | BOOLEAN | RW | 0x00 (0dec)
2018:02 | Reconfig identical motor | When replacing identical motors, reconfiguration takes place automatically after reading the electronic identification plate. Enable autoconfig must be activated. (see Automatic scanning of the electronic identification plates) | BOOLEAN | RW | 0x00 (0dec)
2018:03 | Reconfig non-identical motor | When replacing non-identical motors, reconfiguration takes place automatically after reading the electronic identification plate. Enable autoconfig must be activated. (see Automatic scanning of the electronic identification plates) | BOOLEAN | RW | 0x00 (0dec)


Configuration data (vendor-specific)

Commissioning [image] Object description (DS402) [image] Configuration data (vendor-specific)
Configuration data (vendor-specific)
Index 2020 Vendor data
Index (hex) | Name | Meaning | Data type | Flags | Default
2020:0 | Vendor data | Maximum subindex | UINT8 | RO | 0x15 (21dec)
2020:11 | Amplifier peak current | Peak current of the amplifier (peak value) Unit: mA | UINT32 | RW | 0x00001F40 (8000dec)
2020:12 | Amplifier rated current | Rated current of the amplifier (peak value) Unit: mA | UINT32 | RW | 0x00000FA0 (4000dec)
2020:13 | Amplifier thermal time constant | Thermal time constant of the amplifier Unit: 0.1 ms | UINT16 | RW | 0x0023 (35dec)
2020:14 | Amplifier overcurrent threshold | Threshold value for short-circuit detection Unit: mA | UINT32 | RW | 0x00002EE0 (12000dec)
2020:15 | Max rotary field frequency | Max. rotary field frequency– Unit: Hz | UINT16 | RW | 0x0257 (599dec)


Command object

Commissioning [image] Object description (DS402) [image] Command object
Command object
Index FB00 command
Index (hex) | Name | Meaning | Data type | Flags | Default
FB00:0 | Command | Maximum subindex | UINT8 | RO | 0x03 (3dec)
FB00:01 | Request | reserved | OCTET-STRING[2] | RW | {0}
FB00:02 | Status | reserved | UINT8 | RO | 0x00 (0dec)
FB00:03 | Response | reserved | OCTET-STRING[4] | RO | {0}


Input/output data

Commissioning [image] Object description (DS402) [image] Input/output data
Input/output data
Index 2001 Outputs
Index (hex) | Name | Meaning | Data type | Flags | Default
2001:0 | Outputs | Maximum subindex | UINT8 | RO | 0x11 (17dec)
2001:11 | Torque offset | Torque value offset The value is specified in 1000th of the rated current Equation for index 2002:54 = 0 : M = ((Torque actual value / 1000) x (rated current / √2)) x torque constant (2003:16) Equation for index 2002:54 = 1 : M = ((Torque actual value / 1000) x rated current)) x torque constant (2003:16) | INT16 | RO | 0x0000 (0dec)
Index 2008 Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
2008:0 | Inputs | Maximum subindex | UINT8 | RO | 0x02 (2dec)
2008:01 | Info data1 | Synchronous information (selection via subindex 2002:55) | UINT16 | RO | 0x0000 (0dec)
2008:01 | Info data2 | Synchronous information (selection via subindex 2002:56) | UINT16 | RO | 0x0000 (0dec)
Index 603E TxPDO Data invalid
Index (hex) | Name | Meaning | Data type | Flags | Default
603E:0 | TxPDO Data invalid | Max. subindex | UINT8 | RO | 0x02 (2dec)
603E:02 | Position actual value | 0: The current position is valid 1: The current position is invalid | BOOLEAN | RO P | 0
Index 6040 Controlword
Index (hex) | Name | Meaning | Data type | Flags | Default
6040:0 | Controlword | DS402 Controlword Bit 0: Switch on Bit 1: Enable voltage Bit 2: reserved Bit 3: Enable operation Bit 4 - 6: reserved Bit 7: Fault reset Bit 8 - 15: reserved | UINT16 | RO | 0x0000 (0dec)
Index 6041 Statusword
Index (hex) | Name | Meaning | Data type | Flags | Default
6041:0 | Statusword | DS402 Statusword Bit 0: Ready to switch on Bit 1: Switched on Bit 2: Operation enabled Bit 3: Fault Bit 4: reserved Bit 5: reserved Bit 6: Switch on disabled Bit 7: Warning Bit 8 + 9: reserved Bit 10: TxPDOToggle (selection/deselection via 0x60DA) Bit 11: Internal limit active Bit 12: (Target value ignored) Bit 13 - 15: reserved | UINT16 | RO | 0x0000 (0dec)
Index 605E Fault reaction option code
Index (hex) | Name | Meaning | Data type | Flags | Default
605E:0 | Fault reaction option code | 0: Disable drive function, motor is free to rotate 1: Slow down by slow down ramp | ENUM16BIT | RW | 0
Index 6060 Modes of operation
Index (hex) | Name | Meaning | Data type | Flags | Default
6060:0 | Modes of operation | permitted values: 0x08: Cyclic synchronous position mode (CSP) 0x09: Cyclic synchronous velocity mode (CSV) 0x0A: Cyclic synchronous torque mode (CST) 0x0B: Cyclic synchronous torque mode with commutation angle (CSTCA) | UINT8 | RW | 0x00 (0dec)
Index 6061 Modes of operation display
Index (hex) | Name | Meaning | Data type | Flags | Default
6061:0 | Modes of operation display | permitted values: 8: Cyclic synchronous position mode (CSP) 9: Cyclic synchronous velocity mode (CSV) 10: Cyclic synchronous torque mode (CST) 11: Cyclic synchronous torque mode with commutation angle (CSTCA) | UINT8 | RO | 0x00 (0dec)
Index 6064 Position actual value
Index (hex) | Name | Meaning | Data type | Flags | Default
6064:0 | Position actual value | Position Unit: the given value must be multiplied by the corresponding scaling factor | UINT32 | RO | 0x00000000 (0dec)
Index 6065 Following error window
Index (hex) | Name | Meaning | Data type | Flags | Default
6065:0 | Following error window | Following error monitor: Following error window Unit: the given value must be multiplied by the corresponding scaling factor 0xFFFFFFFF (-1dec) = following error monitor off Any other value = following error monitor on | UINT32 | RO | 0xFFFFFFFF (-1dec)
Index 6066 Following error time out
Index (hex) | Name | Meaning | Data type | Flags | Default
6066:0 | Following error time out | Following error monitor: Timeout Unit: ms If the following error is larger than the following error window for a time that exceeds the timeout, this leads to an error reaction | UINT1616 | RO | 0x0000 (0dec)
Index 606C Velocity actual value
Index (hex) | Name | Meaning | Data type | Flags | Default
606C:0 | Velocity actual value | Display of the current velocity value | INT3232 | RO | 0x00000000 (0dec)
Index 6071 Target torque
Index (hex) | Name | Meaning | Data type | Flags | Default
6071:0 | Target torque | This object shall indicate the configured input value for the torque controller. The value is specified in 1000th of the rated current. Equation for index 2002:54 = 0 : M = ((Torque actual value / 1000) x (rated current / √2)) x torque constant (2003:16) Equation for index 2002:54 = 1 : M = ((Torque actual value / 1000) x rated current)) x torque constant (2003:16) | INT16 | RO | 0x0000 (0dec)
Index 6072 Max torque
Index (hex) | Name | Meaning | Data type | Flags | Default
6072:0 | Max torque | This object limits the target torque for the torque controller (bipolar limit). The value is specified in 1000th of the rated current. Equation for index 2002:54 = 0 : M = ((Torque actual value / 1000) x (rated current / √2)) x torque constant (2003:16) Equation for index 2002:54 = 1 : M = ((Torque actual value / 1000) x rated current)) x torque constant (2003:16) | UINT16 | RW | 0x7FFF (32767dec)
Index 6075 Motor rated current
Index (hex) | Name | Meaning | Data type | Flags | Default
6075:0 | Motor rated current | Motor rated current Unit: mA | UINT32 | RW | 0x000003E8 (1000dec)
Index 6077 Torque actual value
Index (hex) | Name | Meaning | Data type | Flags | Default
6077:0 | Torque actual value | This object shall provide the actual value of the torque. The value is specified in 1000th of the rated current. Equation for index 2002:54 = 0 : M = ((Torque actual value / 1000) x (rated current / √2)) x torque constant (2003:16) Equation for index 2002:54 = 1 : M = ((Torque actual value / 1000) x rated current)) x torque constant (2003:16) | INT16 | RO | 0x0000 (0dec)
Index 6079 DC link circuit voltage
Index (hex) | Name | Meaning | Data type | Flags | Default
6079:0 | DC link circuit voltage | DC link voltage g Unit: mV | UINT32 | RO | 0x00000000 (0dec)
Index 607A Target position
Index (hex) | Name | Meaning | Data type | Flags | Default
607A:0 | Target position | This object shall provide the actual position. Unit: the given value must be multiplied by the corresponding scaling factor | INT32 | RO | 0x00000000 (0dec)
Index 6080 Max motor speed
Index (hex) | Name | Meaning | Data type | Flags | Default
6080:0 | Max motor speed | Velocity limitation Unit: rpm | UINT32 | RW | 0x00040000 (262144dec)
Index 608F Position encoder resolution
Index (hex) | Name | Meaning | Data type | Flags | Default
608F:0 | Position encoder resolution | This object represents the configured encoder increments and the number of motor revolutions. The position encoder resolution is calculated according to the following equation: Position encoder resolution = (encoder increments / motor revolutions) | UINT8 | RO | 0x02 (2dec)
608F:01 | SubIndex 001 | Encoder increments | UINT32 | RO | 0x00000000 (0dec)
608F:02 | SubIndex 002 | Motor revolutions | UINT32 | RO | 0x00000000 (0dec)
Index 6090 Velocity Encoder Resolution
Index (hex) | Name | Meaning | Data type | Flags | Default
6090:0 | Velocity Encoder Resolution | Display of configured encoder increments/s and motor revolutions/s. The velocity encoder resolution is calculated according to the following formula: Velocity Encoder Resolution = (encoder_increments / s ) / (motor_revolutions / s) | UINT32 | RO | 0x00000000 (0dec)
Index 60B8 Touch probe function
Index (hex) | Name | Meaning | Data type | Flags | Default
60B8:0 | Touch probe function | Touch probe function byte | UINT16 | RO | 0x0000 (0dec)
Index 60B9 Touch probe status
Index (hex) | Name | Meaning | Data type | Flags | Default
60B9:0 | Touch probe status | Touch probe status byte | UINT1616 | RO | 0x0000 (0dec)
Index 60BA Touch probe 1 positive edge
Index (hex) | Name | Meaning | Data type | Flags | Default
60BA:0 | Touch probe 1 positive edge | Positive position value of TP 1 Unit: the given value must be multiplied by the corresponding scaling factor | INT32 | RO | 0x00000000 (0dec)
Index 60BB Touch probe 1 negative edge
Index (hex) | Name | Meaning | Data type | Flags | Default
60BB:0 | Touch probe 1 negative edge | Negative position value of TP 1 Unit: the given value must be multiplied by the corresponding scaling factor | INT32 | RO | 0x00000000 (0dec)
Index 60BC Touch probe 2 positive edge
Index (hex) | Name | Meaning | Data type | Flags | Default
60BC:0 | Touch probe 2 positive edge | Positive position value of TP 2 Unit: the given value must be multiplied by the corresponding scaling factor | INT32 | RO | 0x00000000 (0dec)
Index 60BD Touch probe 2 negative edge
Index (hex) | Name | Meaning | Data type | Flags | Default
60BD:0 | Touch probe 2 negative edge | Negative position value of TP 2 Unit: the given value must be multiplied by the corresponding scaling factor | INT32 | RO | 0x00000000 (0dec)
Index 60C2 Interpolation time period
Index (hex) | Name | Meaning | Data type | Flags | Default
60C2:0 | Interpolation time period | Maximum subindex x | UINT8 | RO | 0x02 (2dec)
60C2:01 | Interpolation time period value | This object shall indicate the configured interpolation cycle time. The interpolation time period (sub-index 0x01) value shall be given in 10(interpolation time index) (second). The interpolation time index (sub-index 0x02) shall be dimensionless. | UINT8T8 | RO | 0x00 (0dec)
60C2:02 | Interpolation time index |  | INT8 | RO | 0x00 (0dec)
Index 60D9 Supported functions
Index (hex) | Name | Meaning | Data type | Flags | Default
60D9:0 | Supported functions | This object shall provide information on the supported functions in the device. | UINT3232 | RO | 0x00000000 (0dec)
Index 60DA Function settings
Index (hex) | Name | Meaning | Data type | Flags | Default
60DA:0 | Function settings | This object shall enable/disable supported functions in the device. Bit 0: Enable TxPDOToggle-Bit in Statusword: Bit 10 Bit 1: Enable input cycle counter in Statusword: Bit 13 Bit 2-31: reserved | UINT32 | RW | 0x00000000 (0dec)
Index 60EA Commutation angle
Index (hex) | Name | Meaning | Data type | Flags | Default
60EA:0 | Commutation angle | Electrical commutation angle (for the CSTCA mode) Unit: 5.49 * 10-3 ° | UINT16 | RO | 0x0000 (0dec)
Index 60F4 Following error actual value
Index (hex) | Name | Meaning | Data type | Flags | Default
60F4:0 | Following error actual value | Following error Unit: the given value must be multiplied by the corresponding scaling factor | INT32 | RO | 0x00000000 (0dec)
Index 60FF Target velocity
Index (hex) | Name | Meaning | Data type | Flags | Default
60FF:0 | Target velocity | This object shall indicate the configured target velocity The velocity scaling can be found in object 0x6090 (Velocity encoder resolution) | INT32 | RO | 0x00000000 (0dec)
Index 6403 Motor catalogue number
Index (hex) | Name | Meaning | Data type | Flags | Default
6403:0 | Motor catalogue number | This is the order code from the electronic type plate of the motor, e.g. AM8121-0F20-0000 | STRING | RO |
Index 6502 Supported drive modes
Index (hex) | Name | Meaning | Data type | Flags | Default
6502:0 | Supported drive modes | This object shall provide information on the supported drive modes. (DS402 Object 0x6502) Only modes CSV, CST, CSTCA and CSP are supported Bit 0: PP Bit 1: VL Bit 2: PV Bit 3: TQ Bit 4: R Bit 5: HM Bit 6: IP Bit 7: CSP Bit 8: CSV Bit 9: CST Bit 10: CSTCA Bit 11-15: reserved Bit 16-31: Manufacturer-specific | UINT32 | RO | 0x00000000 (0dec)


Information / diagnosis data

Commissioning [image] Object description (DS402) [image] Information / diagnosis data
Information / diagnosis data
Index 10F3 Diagnosis History
Index (hex) | Name | Meaning | Data type | Flags | Default
10F3:0 | Diagnosis History | Maximum subindex | UINT8 | RO | 0x37 (55dec)
10F3:01 | Maximum Messages | Maximum number of stored messages. A maximum of 50 messages can be stored | UINT8 | RO | 0x00 (0dec)
10F3:02 | Newest Message | Subindex of the latest message | UINT8 | RO | 0x00 (0dec)
10F3:03 | Newest Acknowledged Message | Subindex of the last confirmed message | UINT8 | RW | 0x00 (0dec)
10F3:04 | New Messages Available | Indicates that a new message is available | BOOLEAN | RO | 0x00 (0dec)
10F3:05 | Flags | not used | UINT16 | RW | 0x0000 (0dec)
10F3:06 | Diagnosis Message 001 | Message 1 | OCTET-STRING[28] | RO | {0}
... | ... | ... | ... | ... | ...
10F3:37 | Diagnosis Message 050 | Message 50 | OCTET-STRING[28] | RO | {0}
Index 10F8 Actual Time Stamp
Index (hex) | Name | Meaning | Data type | Flags | Default
10F8:0 | Actual Time Stamp | Time stamp | UINT64 | RO |
Index 2030 Amplifier Diag data
Index (hex) | Name | Meaning | Data type | Flags | Default
2030:0 | Amplifier Diag data | Maximum subindex | UINT8 | RO | 0x11 (17dec)
2030:11 | Amplifier I2T temperature | I2T model load Unit: % | UINT8 | RO | 0x00 (0dec)
Index 2031 Motor Diag data
Index (hex) | Name | Meaning | Data type | Flags | Default
2031:0 | Motor Diag data | Maximum subindex | UINT8 | RO | 0x13 (19dec)
2031:11 | Motor I2T temperature | I2T model load Unit: % | UINT8 | RO | 0x00 (0dec)
2031:13 | Motor temperature | Temperature utilization ratio Unit: ° | UINT16 | RO | 0x0000 (0dec)
Index 2040 Amplifier Info data
Index (hex) | Name | Meaning | Data type | Flags | Default
2040:0 | Amplifier Info data | Maximum subindex | UINT8 | RO | 0x12 (18dec)
2040:11 | Amplifier temperature | Internal temperature of the box Unit: 0.1 °C | UINT16 | RO | 0x0000 (0dec)
2040:12 | DC link voltage | DC link voltage Unit: mV | UINT32 | RO | 0x00000000 (0dec)
Index 2041 Info data
Index (hex) | Name | Meaning | Data type | Flags | Default
2041:0 | Info data | Maximum subindex | UINT8 | RO | 0x11 (17dec)
2041:11 | Auxiliary voltage (10 V) | Auxiliary voltage Unit: mV | UINT32 | RO | 0x00000000 (0dec)
Index 2058 OCT Info data
(these data are always read in automatically from the electronic type plate of the motor and serve purely informative purposes)
Index (hex) | Name | Meaning | Data type | Flags | Default
2058:0 | OCT Info data | Maximum subindex | UINT8 | RO | 0x1F (31dec)
2058:11 | Encoder Type | Feedback type 2: rotary encoder, unipolar counting | UINT16 | RO | 0x0000 (0dec)
2058:12 | Resolution | Resolution of the feedback Unit: Steps per revolution | UINT32 | RO | 0x00000000 (0dec)
2058:13 | Range | Working range of the feedback. On leaving this range there is an overflow of the position. Unit: Revolutions | UINT32 | RO | 0x00000000 (0dec)
2058:14 | Type Code Name | Name of the feedback | STRING | RO |
2058:15 | Serial No | Serial number of the feedback | STRING | RO |
2058:16 | Firmware Revision No | Revision of the firmware | STRING | RO |
2058:17 | Firmware Date | Date of the firmware | STRING | RO |
2058:18 | EEPROM Size | EEPROM size | UINT16 | RO | 0x0000 (0dec)
2058:19 | Temperature | Temperature Unit: 0.1° | INT16 | RO | 0x0000 (0dec)
2058:1A | LED Current | Current of the feedback LED Unit: 0.1 mA | UINT16 | RO | 0x0000 (0dec)
2058:1B | Supply voltage | Supply voltage of the feedback Unit: mV | UINT32 | RO | 0x00000000 (0dec)
2058:1C | Life- time | Operating hour counter Unit: Minutes | UINT32 | RO | 0x00000000 (0dec)
2058:1D | Received Signal Strength Indicator | Received signal strength at the terminal Unit: % | UINT16 | RO | 0x0000 (0dec)
2058:1E | Slave Received Signal Strength Indicator | Received signal strength at the encoder Unit: % | UINT16 | RO | 0x0000 (0dec)
2058:1F | Line delay | Running time of the signal in the cable Unit: ns | UINT16 | RO | 0x0000 (0dec)
Index 2059 OCT Nameplate
The parameters described in this index are always read from the electronic type plate of the connected motor. These parameters automatically lead to the parameters marked with an asterisk (*) in this chapter, if automatic scanning of the electronic type plate is switched on (index 2018).
Index (hex) | Name | Meaning | Data type | Flags | Default
2059:0 | OCT Nameplate | Maximum subindex | UINT8 | RO | 0x24 (36dec)
2059:01 | Motor vendor | Motor vendor | STRING | RO |
2059:02 | Electric motor type | Motor type | STRING | RO |
2059:03 | Serial No | Serial number | STRING | RO |
2059:04 | Order code | Order number (In case of Autoconfig a check is made on the basis of this index as to whether the motor is identical to the predecessor) | STRING | RO |
2059:05 | Motor construction | Type of motor | STRING | RO |
2059:06 | Pole pairs | Number of pole pairs | UINT32 | RO | 0x00000000 (0dec)
2059:07 | Standstill current (rms) | Effective holding current Unit: mA | UINT32 | RO | 0x00000000 (0dec)
2059:08 | Rated current (rms) | Effective rated current Unit: mA | UINT32 | RO | 0x00000000 (0dec)
2059:09 | Peak current (rms) | Effective peak current Unit: mA | UINT32 | RO | 0x00000000 (0dec)
2059:0A | Nominal voltage (rms) | Effective nominal voltage Unit: mV | UINT32 | RO | 0x00000000 (0dec)
2059:0B | Max voltage (rms) | Maximum voltage Unit: mV | UINT32 | RO | 0x00000000 (0dec)
2059:0C | Max winding du/dt | Maximum permissible voltage rise on the winding Unit: kV/s | UINT32 | RO | 0x00000000 (0dec)
2059:0D | Max torque | Maximum torque Unit: mNm | UINT16 | RO | 0x0000 (0dec)
2059:0E | Torque constant | Torque constant Unit: mNm / A | UINT16 | RO | 0x0000 (0dec)
2059:0F | EMK (rms) | Reverse voltage Unit: mV / (rpm) | UINT32 | RO | 0x00000000 (0dec)
2059:10 | Winding resistance Ph-Ph 20°C | Coil resistance Unit: mOhm | UINT16 | RO | 0x0000 (0dec)
2059:11 | Ld Ph-Ph | Inductance in the direction of flow Unit: 0.1 mH | UINT16 | RO | 0x0000 (0dec)
2059:12 | Lq Ph-Ph | Inductance in the torque-forming direction Unit: 0.1 mH | UINT16 | RO | 0x0000 (0dec)
Index (hex)
Name
Meaning
Data type
Flags
Default
2059:13
Max speed
Maximum speed
Unit: rpm
UINT32
RO
0x00000000 (0dec)
2059:14
Moment of inertia
Mass moment of inertia
Unit: g cm^2
UINT16
RO
0x0000 (0dec)
2059:15
T motor warn limit
Motor temperature warning threshold
Unit: 0.1 °C
UINT16
RO
0x0000 (0dec)
2059:16
T motor shut down
Motor temperature error threshold
Unit: 0.1°C
UINT16
RO
0x0000 (0dec)
2059:17
Time constant i2t
Time constant I2T model
Unit: s
UINT16
RO
0x0000 (0dec)
2059:18
Motor thermal constant
Thermal time constant of the motor
Unit: s
UINT16
RO
0x0000 (0dec)
2059:1B
Brake type
Brake type
▪
no Brake
▪
holding Brake
STRING
RO
2059:1C
Min brake voltage
Minimum brake voltage
Unit: mV
UINT32
RO
0x00000000 (0dec)
2059:1D
Max brake voltage
Maximum brake voltage
Unit: mV
UINT32
RO
0x00000000 (0dec)
2059:1E
Min brake monitor current
Minimum current for the monitoring of the brake
Unit: mA
UINT32
RO
0x00000000 (0dec)
2059:1F
Brake holding torque
Brake holding torque
Unit: mNm
UINT32
RO
0x00000000 (0dec)
2059:20
Brake T on
Time until the brake is applied
Unit: ms
UINT16
RO
0x0000 (0dec)
2059:21
Brake T off
Time until the brake is released
Unit: ms
UINT16
RO
0x0000 (0dec)
2059:22
Brake reduced holding voltage
Reduced brake voltage
Unit: mV
UINT32
RO
0x00000000 (0dec)
2059:23
Brake time to red. holding volt.
Time from which the brake holds with reduced voltage
Unit: ms
UINT16
RO
0x0000 (0dec)
2059:24
Motor temp sensor connection
Temperature sensor connection feedback port
(not changeable)
STRING
RO


Standard objects

Commissioning [image] Object description (DS402) [image] Standard objects
Standard objects
Index 1000 Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: the Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x00000192 (402dec)
Index 1001 Error register
Index (hex) | Name | Meaning | Data type | Flags | Default
1001:0 | Error register |  | UINT8 | RO | 0x00 (0dec)
Index 1008 Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EP7211-0034
Index 1009 Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO |
Index 100A Software version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO |
Index 1018 Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x1C2B4052 (472596562dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the Low Word (bit 0-15) indicates the special terminal number, the High Word (bit 16-31) refers to the device description | UINT32 | RO | 0x00000000 (0dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the Low Byte (bit 0-7) of the Low Word contains the year of production, the High Byte (bit 8-15) of the Low Word contains the week of production, the High Word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 1600 DS402 RxPDO-Map Controlword
Index (hex) | Name | Meaning | Data type | Flags | Default
1600:0 | DS402 RxPDO-Map Controlword | PDO Mapping RxPDO 1 | UINT8 | RO | 0x01 (1dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x6040:00, 16
Index 1601 DS402 RxPDO-Map Target velocity
Index (hex) | Name | Meaning | Data type | Flags | Default
1601:0 | DS402 RxPDO-Map Target velocity | PDO Mapping RxPDO 2 | UINT8 | RO | 0x01 (1dec)
1601:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x60FF:00, 32
Index 1602 DS402 RxPDO-Map Target torque
Index (hex) | Name | Meaning | Data type | Flags | Default
1602:0 | DS402 RxPDO-Map Target torque | PDO Mapping RxPDO 3 | UINT8 | RO | 0x01 (1dec)
1602:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x6071:00, 16
Index 1603 DS402 RxPDO-Map Commutation angle
Index (hex) | Name | Meaning | Data type | Flags | Default
1603:0 | DS402 RxPDO-Map Commutation angle | PDO Mapping RxPDO 4 | UINT8 | RO | 0x01 (1dec)
1603:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x60EA:00, 16
Index 1604 DS402 RxPDO-Map Torque limitation
Index (hex) | Name | Meaning | Data type | Flags | Default
1604:0 | DS402 RxPDO-Map Torque limitation | PDO Mapping RxPDO 5 | UINT8 | RO | 0x01 (1dec)
1604:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x6072:00, 16
Index 1605 DS402 RxPDO-Map Torque offset
Index (hex) | Name | Meaning | Data type | Flags | Default
1605:0 | DS402 RxPDO-Map Torque offset | PDO Mapping RxPDO 6 | UINT8 | RO | 0x01 (1dec)
1605:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x2001:11, 16
Index 1606 DS402 RxPDO-Map Target position
Index (hex) | Name | Meaning | Data type | Flags | Default
1606:0 | DS402 RxPDO-Map Target position | PDO Mapping RxPDO 7 | UINT8 | RO | 0x01 (1dec)
1606:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x607A:00, 32
Index 1607 DS402 RxPDO-Map Touch probe function
Index (hex) | Name | Meaning | Data type | Flags | Default
1607:0 | DS402 RxPDO-Map Touch probe function | PDO Mapping RxPDO 8 | UINT8 | RO | 0x01 (1dec)
1607:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x60B8:00, 16
Index 1A00 DS402 TxPDO-Map Statusword
Index (hex) | Name | Meaning | Data type | Flags | Default
1A00:0 | DS402 TxPDO-Map Statusword | PDO Mapping TxPDO 1 | UINT8 | RO | 0x01 (1dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x6041:00, 16
Index 1A01 DS402 TxPDO-Map Position actual value
Index (hex) | Name | Meaning | Data type | Flags | Default
1A01:0 | DS402 TxPDO-Map Position actual value | PDO Mapping TxPDO 2 | UINT8 | RO | 0x01 (1dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x6064:00, 32
Index 1A02 DS402 TxPDO-Map Velocity actual value
Index (hex) | Name | Meaning | Data type | Flags | Default
1A02:0 | DS402 TxPDO-Map Velocity actual value | PDO Mapping TxPDO 3 | UINT8 | RO | 0x01 (1dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x606C:00, 32
Index 1A03 DS402 TxPDO-Map Torque actual value
Index (hex) | Name | Meaning | Data type | Flags | Default
1A03:0 | DS402 TxPDO-Map Torque actual value | PDO Mapping TxPDO 4 | UINT8 | RO | 0x01 (1dec)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x6077:00, 16
Index 1A04 DS402 TxPDO-Map Following error actual value
Index (hex) | Name | Meaning | Data type | Flags | Default
1A04:0 | DS402 TxPDO-Map Following error actual value | PDO Mapping TxPDO 5 | UINT8 | RO | 0x01 (1dec)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x60F4:00, 32
Index 1A05 DS402 TxPDO-Map Touch probe status
Index (hex) | Name | Meaning | Data type | Flags | Default
1A05:0 | DS402 TxPDO-Map Touch probe status | PDO Mapping TxPDO 6 | UINT8 | RO | 0x01 (1dec)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x60B9:00, 16
Index 1A06 DS402 TxPDO-Map Touch probe 1 positive edge
Index (hex) | Name | Meaning | Data type | Flags | Default
1A06:0 | DS402 TxPDO-Map Touch probe 1 positive edge | PDO Mapping TxPDO 7 | UINT8 | RO | 0x01 (1dec)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x60BA:00, 32
Index 1A07 DS402 TxPDO-Map Touch probe 1 negative edge
Index (hex) | Name | Meaning | Data type | Flags | Default
1A07:0 | DS402 TxPDO-Map Touch probe 1 negative edge | PDO Mapping TxPDO 8 | UINT8 | RO | 0x01 (1dec)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x60BB:00, 32
Index 1A08 DS402 TxPDO-Map Touch probe 2 positive edge
Index (hex) | Name | Meaning | Data type | Flags | Default
1A08:0 | DS402 TxPDO-Map Touch probe 2 positive edge | PDO Mapping TxPDO 9 | UINT8 | RO | 0x01 (1dec)
1A08:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x60BC:00, 32
Index 1A09 DS402 TxPDO-Map Touch probe 2 negative edge
Index (hex) | Name | Meaning | Data type | Flags | Default
1A09:0 | DS402 TxPDO-Map Touch probe 2 negative edge | PDO Mapping TxPDO 10 | UINT8 | RO | 0x01 (1dec)
1A09:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x60BD:00, 32
Index 1A0B DS402 TxPDO-Map Info data 1
Index | Name | Meaning | Data type | Flags | Default
1A0B:0 | DS402 TxPDO-Map Info data 1 | PDO Mapping TxPDO 12 | UINT8 | RO | 0x01 (1dec)
1A0B:01 | SubIndex 001 | 1st PDO Mapping entry (object 0x2008 (inputs), entry 0x01 (Info data 1)) | UINT32 | RO | 0x2008:01, 16
Index 1A0C DS402 TxPDO-Map Info data 2
Index | Name | Meaning | Data type | Flags | Default
1A0C:0 | DS402 TxPDO-Map Info data 2 | PDO Mapping TxPDO 13 | UINT8 | RO | 0x01 (1dec)
1A0C:01 | SubIndex 001 | 1st PDO Mapping entry (object 0x2008 (inputs), entry 0x02 (Info data 2)) | UINT32 | RO | 0x2008:02, 16
Index 1C00 Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the sync managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x02 (2dec)
1C12:01 | Subindex 001 | 1. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1600 (5632dec)
1C12:02 | Subindex 002 | 2. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1601 (5633dec)
1C12:03 | Subindex 003 | 3. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:04 | Subindex 004 | 4. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:05 | Subindex 005 | 5. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:06 | Subindex 006 | 6. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:07 | Subindex 007 | 7. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:08 | Subindex 008 | 8. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 1C13 TxPDO assign
Index | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x02 (2dec)
1C13:01 | Subindex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A01 (6657dec)
1C13:03 | Subindex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:04 | Subindex 004 | 4. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:05 | Subindex 005 | 5. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:06 | Subindex 006 | 6. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:07 | Subindex 007 | 7. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:08 | Subindex 008 | 8. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:09 | Subindex 009 | 9. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0A | Subindex 010 | 10. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 1C32 SM output parameter
Index (Hex)
Name
Meaning
Data type
Flags
Default
1C32:0
SM output parameter
Synchronization parameters for the outputs
UINT8
RO
0x20 (32dec)
1C32:01
Sync mode
Current synchronization mode:
▪
3: DC-Mode - Synchronous with SYNC1 event
UINT16
RW
0x0000 (0dec)
1C32:02
Cycle time
Cycle time (in ns):
▪
Free Run: Cycle time of the local timer
▪
Synchronous with SM 2 event: Master cycle time
▪
DC mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x0003D090 (250000dec)
1C32:03
Shift time
Time between SYNC0 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0 = 1: free run is supported
▪
Bit 1 = 1: Synchronous with SM 2 event is supported
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 10: Output shift with SYNC1 event (only DC mode)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08)
UINT16
RO
0x4808 (18440dec)
1C32:05
Minimum cycle time
Minimum cycle time (in ns)
UINT32
RO
0x0001E848 (125000dec)
1C32:06
Calc and copy time
Minimum time between SYNC0 and SYNC1 event (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:07
Minimum delay time
UINT32
RO
0x00000000 (0dec)
1C32:08
Command
▪
0: Measurement of the local cycle time is stopped
▪
1: Measurement of the local cycle time is started
The entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, and 0x1C33:09 are updated with the maximum measured values.
For a subsequent measurement the measured values are reset
UINT16
RW
0x0000 (0dec)
1C32:09
Maximum delay time
Time between SYNC1 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:0B
SM event missed counter
Number of missed SM events in OPERATIONAL (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:0C
Cycle exceeded counter
Number of occasions the cycle time was exceeded in OPERATIONAL (cycle was not completed in time or the next cycle began too early)
UINT16
RO
0x0000 (0dec)
1C32:0D
Shift too short counter
Number of occasions that the interval between SYNC0 and SYNC1 event was too short (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:20
Sync error
The synchronization was not correct in the last cycle (outputs were output too late; DC mode only)
BOOLEAN
RO
0x00 (0dec)
Index 1C33 SM input parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
3: DC - Synchronous with SYNC1 Event
UINT16
RW
0x0000 (0dec)
1C33:02
Cycle time
as 0x1C32:02
UINT32
RW
0x0003D090 (250000dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00001C52 (7250dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: synchronous with SM 2 event is supported (outputs available)
▪
Bit 1: synchronous with SM 3 event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: input shift through local event (outputs available)
▪
Bit 4-5 = 10: input shift with SYNC1 event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08 or 0x1C33:08)
UINT16
RO
0x4808 (18440dec)
1C33:05
Minimum cycle time
as 0x1C32:05
UINT32
RO
0x0001E848 (125000dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:07
Minimum delay time
UINT32
RO
0x00001C52 (7250dec)
1C33:08
Command
as 0x1C32:08
UINT16
RW
0x0000 (0dec)
1C33:09
Maximum delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00001C52 (7250dec)
1C33:0B
SM event missed counter
as 0x1C32:11
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
as 0x1C32:12
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
as 0x1C32:13
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
as 0x1C32:32
BOOLEAN
RO
0x00 (0dec)
Index F008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | see note! | UINT32 | RW | 0x00000000 (0dec)


Appendix

Appendix
Appendix
Additional information
•
General operating conditions
•
Firmware Update EL/ES/EM/ELM/EPxxxx
•
EtherCAT Box- / EtherCAT P Box - Accessories
•
Servo technology - accessories
•
Version identification of EtherCAT devices
•
Support and Service


General operating conditions

Appendix [image] General operating conditions
General operating conditions
Protection degrees (IP-Code)
The standard IEC 60529 (DIN EN 60529) defines the degrees of protection in different classes.
1. Number: dust protection and touch guard | Definition
0 | Non-protected
1 | Protected against access to hazardous parts with the back of a hand. Protected against solid foreign objects of Ø 50 mm
2 | Protected against access to hazardous parts with a finger. Protected against solid foreign objects of Ø 12.5 mm.
3 | Protected against access to hazardous parts with a tool. Protected against solid foreign objects Ø 2.5 mm.
4 | Protected against access to hazardous parts with a wire. Protected against solid foreign objects Ø 1 mm.
5 | Protected against access to hazardous parts with a wire. Dust-protected. Intrusion of dust is not totally prevented, but dust shall not penetrate in a quantity to interfere with satisfactory operation of the device or to impair safety.
6 | Protected against access to hazardous parts with a wire. Dust-tight. No intrusion of dust.
2. Number: water* protection | Definition
0 | Non-protected
1 | Protected against water drops
2 | Protected against water drops when enclosure tilted up to 15°.
3 | Protected against spraying water. Water sprayed at an angle up to 60° on either side of the vertical shall have no harmful effects.
4 | Protected against splashing water. Water splashed against the disclosure from any direction shall have no harmful effects
5 | Protected against water jets
6 | Protected against powerful water jets
7 | Protected against the effects of temporary immersion in water. Intrusion of water in quantities causing harmful effects shall not be possible when the enclosure is temporarily immersed in water for 30 min. in 1 m depth.
*) These protection classes define only protection against water!
Chemical Resistance
The Resistance relates to the Housing of the IP 67 modules and the used metal parts. In the table below you will find some typical resistance.
Character | Resistance
Steam | at temperatures >100°C: not resistant
Sodium base liquor (ph-Value > 12) | at room temperature: resistant > 40°C: not resistant
Acetic acid | not resistant
Argon (technical clean) | resistant
Key
▪
resistant: Lifetime several months
▪
non inherently resistant: Lifetime several weeks
▪
not resistant: Lifetime several hours resp. early decomposition


Firmware Update EL/ES/EM/ELM/EPxxxx

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx
Firmware Update EL/ES/EM/ELM/EPxxxx
This section describes the device update for Beckhoff EtherCAT slaves from the EL/ES, ELM, EM, EK and EP series. A firmware update should only be carried out after consultation with Beckhoff support.
Storage locations
An EtherCAT slave stores operating data in up to three locations:
▪
Depending on functionality and performance EtherCAT slaves have one or several local controllers for processing I/O data. The corresponding program is the so-called firmware in *.efw format.
▪
In some EtherCAT slaves the EtherCAT communication may also be integrated in these controllers. In this case the controller is usually a so-called FPGA chip with *.rbf firmware.
▪
In addition, each EtherCAT slave has a memory chip, a so-called ESI-EEPROM, for storing its own device description (ESI: EtherCAT Slave Information). On power-up this description is loaded and the EtherCAT communication is set up accordingly. The device description is available from the download area of the Beckhoff website at (https://www.beckhoff.de). All ESI files are accessible there as zip files.
Customers can access the data via the EtherCAT fieldbus and its communication mechanisms. Acyclic mailbox communication or register access to the ESC is used for updating or reading of these data.
The TwinCAT System Manager offers mechanisms for programming all three parts with new data, if the slave is set up for this purpose. Generally the slave does not check whether the new data are suitable, i.e. it may no longer be able to operate if the data are unsuitable.
Simplified update by bundle firmware
The update using so-called bundle firmware is more convenient: in this case the controller firmware and the ESI description are combined in a *.efw file; during the update both the firmware and the ESI are changed in the terminal. For this to happen it is necessary
▪
for the firmware to be in a packed format: recognizable by the file name, which also contains the revision number, e.g. ELxxxx-xxxx_REV0016_SW01.efw
▪
for password=1 to be entered in the download dialog. If password=0 (default setting) only the firmware update is carried out, without an ESI update.
▪
for the device to support this function. The function usually cannot be retrofitted; it is a component of many new developments from year of manufacture 2016.
Following the update, its success should be verified
▪
ESI/Revision: e.g. by means of an online scan in TwinCAT ConfigMode/FreeRun – this is a convenient way to determine the revision
▪
Firmware: e.g. by looking in the online CoE of the device
Note
Risk of damage to the device!
✓
Note the following when downloading new device files
1.
Firmware downloads to an EtherCAT device must not be interrupted
2.
Flawless EtherCAT communication must be ensured. CRC errors or LostFrames must be avoided.
3.
The power supply must adequately dimensioned. The signal level must meet the specification.
⇨
In the event of malfunctions during the update process the EtherCAT device may become unusable and require re-commissioning by the manufacturer.
Additional information
•
Device description ESI file/XML
•
Firmware explanation
•
Updating controller firmware *.efw
•
FPGA firmware *.rbf
•
Simultaneous updating of several EtherCAT devices


Device description ESI file/XML

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Device description ESI file/XML
Device description ESI file/XML
Note
Attention regarding update of the ESI description/EEPROM
Some slaves have stored calibration and configuration data from the production in the EEPROM. These are irretrievably overwritten during an update.
The ESI device description is stored locally on the slave and loaded on start-up. Each device description has a unique identifier consisting of slave name (9 characters/digits) and a revision number (4 digits). Each slave configured in the System Manager shows its identifier in the EtherCAT tab:
Device identifier consisting of name EL3204-0000 and revision -0016
The configured identifier must be compatible with the actual device description used as hardware, i.e. the description which the slave has loaded on start-up (in this case EL3204). Normally the configured revision must be the same or lower than that actually present in the terminal network.
For further information on this, please refer to the EtherCAT system documentation.
Update of XML/ESI description
The device revision is closely linked to the firmware and hardware used. Incompatible combinations lead to malfunctions or even final shutdown of the device. Corresponding updates should only be carried out in consultation with Beckhoff support.
Display of ESI slave identifier
The simplest way to ascertain compliance of configured and actual device description is to scan the EtherCAT boxes in TwinCAT mode Config/FreeRun:
Scan the subordinate field by right-clicking on the EtherCAT device
If the found field matches the configured field, the display shows
Configuration is identical
otherwise a change dialog appears for entering the actual data in the configuration.
Change dialog
In this example in Fig. Change dialog, an EL3201-0000-0017 was found, while an EL3201-0000-0016 was configured. In this case the configuration can be adapted with the Copy Before button. The Extended Information checkbox must be set in order to display the revision.
Changing the ESI slave identifier
The ESI/EEPROM identifier can be updated as follows under TwinCAT:
▪
Trouble-free EtherCAT communication must be established with the slave.
▪
The state of the slave is irrelevant.
▪
Right-clicking on the slave in the online display opens the EEPROM Update dialog, Fig. EEPROM Update
EEPROM Update
The new ESI description is selected in the following dialog, see Fig. Selecting the new ESI. The checkbox Show Hidden Devices also displays older, normally hidden versions of a slave.
Selecting the new ESI
A progress bar in the System Manager shows the progress. Data are first written, then verified.
The change only takes effect after a restart.
Most EtherCAT devices read a modified ESI description immediately or after startup from the INIT. Some communication settings such as distributed clocks are only read during power-on. The EtherCAT slave therefore has to be switched off briefly in order for the change to take effect.


Firmware explanation

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Firmware explanation
Firmware explanation
Determining the firmware version
Determining the version on laser inscription
Beckhoff EtherCAT slaves feature serial numbers applied by laser. The serial number has the following structure: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with ser. no.: 12 10 03 02:
12 - week of production 12
10 - year of production 2010
03 - firmware version 03
02 - hardware version 02
Determining the version via the System Manager
The TwinCAT System Manager shows the version of the controller firmware if the master can access the slave online. Click on the E-Bus Terminal whose controller firmware you want to check (in the example terminal 2 (EL3204)) and select the tab CoE Online (CAN over EtherCAT).
CoE Online and Offline CoE
Two CoE directories are available:
• online: This is offered in the EtherCAT slave by the controller, if the EtherCAT slave supports this. This CoE directory can only be displayed if a slave is connected and operational.
• offline: The EtherCAT Slave Information ESI/XML may contain the default content of the CoE. This CoE directory can only be displayed if it is included in the ESI (e.g. “Beckhoff EL5xxx.xml”).
The Advanced button must be used for switching between the two views.
In Fig. Display of EL3204 firmware version the firmware version of the selected EL3204 is shown as 03 in CoE entry 0x100A.
Display of EL3204 firmware version
In (A) TwinCAT 2.11 shows that the Online CoE directory is currently displayed. If this is not the case, the Online directory can be loaded via the Online option in Advanced Settings (B) and double-clicking on AllObjects.


Updating controller firmware *.efw

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Updating controller firmware *.efw
Updating controller firmware *.efw
CoE directory
The Online CoE directory is managed by the controller and stored in a dedicated EEPROM, which is generally not changed during a firmware update.
Switch to the Online tab to update the controller firmware of a slave, see Fig. Firmware Update.
Firmware Update
Proceed as follows, unless instructed otherwise by Beckhoff support. Valid for TwinCAT 2 and 3 as EtherCAT master.
▪
Switch TwinCAT system to ConfigMode/FreeRun with cycle time >= 1 ms (default in ConfigMode is 4 ms). A FW-Update during real time operation is not recommended.
▪
Switch EtherCAT Master to PreOP
▪
Switch slave to INIT (A)
▪
Switch slave to BOOTSTRAP
▪
Check the current status (B, C)
▪
Download the new *efw file (wait until it ends). A pass word will not be neccessary usually.
▪
After the download switch to INIT, then PreOP
▪
Switch off the slave briefly (don't pull under voltage!)
▪
Check within CoE 0x100A, if the FW status was correctly overtaken.


FPGA firmware *.rbf

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] FPGA firmware *.rbf
FPGA firmware *.rbf
If an FPGA chip deals with the EtherCAT communication an update may be accomplished via an *.rbf file.
▪
Controller firmware for processing I/O signals
▪
FPGA firmware for EtherCAT communication (only for terminals with FPGA)
The firmware version number included in the terminal serial number contains both firmware components. If one of these firmware components is modified this version number is updated.
Determining the version via the System Manager
The TwinCAT System Manager indicates the FPGA firmware version. Click on the Ethernet card of your EtherCAT strand (Device 2 in the example) and select the Online tab.
The Reg:0002 column indicates the firmware version of the individual EtherCAT devices in hexadecimal and decimal representation.
FPGA firmware version definition
If the column Reg:0002 is not displayed, right-click the table header and select Properties in the context menu.
Context menu Properties
The Advanced Settings dialog appears where the columns to be displayed can be selected. Under Diagnosis/Online View select the '0002 ETxxxx Build' check box in order to activate the FPGA firmware version display.
Dialog Advanced Settings
Update
For updating the FPGA firmware
▪
of an EtherCAT coupler the coupler must have FPGA firmware version 11 or higher;
▪
of an E-Bus Terminal the terminal must have FPGA firmware version 10 or higher.
Older firmware versions can only be updated by the manufacturer!
Updating an EtherCAT device
The following sequence order have to be met if no other specifications are given (e.g. by the Beckhoff support):
▪
Switch TwinCAT system to ConfigMode/FreeRun with cycle time >= 1 ms (default in ConfigMode is 4 ms). A FW-Update during real time operation is not recommended.
▪
In the TwinCAT System Manager select the terminal for which the FPGA firmware is to be updated (in the example: Terminal 5: EL5001) and
click the Advanced Settings button in the EtherCAT tab:
▪
The Advanced Settings dialog appears. Under ESC Access/E²PROM/FPGA click on Write FPGA button:
▪
Select the file (*.rbf) with the new FPGA firmware, and transfer it to the EtherCAT device:
▪
Wait until download ends
▪
Switch slave current less for a short time (don't pull under voltage!). In order to activate the new FPGA firmware a restart (switching the power supply off and on again) of the EtherCAT device is required.
▪
Check the new FPGA status
Note
Risk of damage to the device!
A download of firmware to an EtherCAT device must not be interrupted in any case! If you interrupt this process by switching off power supply or disconnecting the Ethernet link, the EtherCAT device can only be recommissioned by the manufacturer!


Simultaneous updating of several EtherCAT devices

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Simultaneous updating of several EtherCAT devices
Simultaneous updating of several EtherCAT devices
The firmware and ESI descriptions of several devices can be updated simultaneously, provided the devices have the same firmware file/ESI.
Multiple selection and firmware update
Select the required slaves and carry out the firmware update in BOOTSTRAP mode as described above.


EtherCAT Box- / EtherCAT P Box - Accessories

Appendix [image] EtherCAT Box- / EtherCAT P Box - Accessories
EtherCAT Box- / EtherCAT P Box - Accessories
Fixing
Ordering information | Description
ZS5300-0001 | Mounting rail (500 mm x 129 mm)
Marking material, plugs
Ordering information | Description
ZS5000-0000 | Fieldbus Box set M8 (contact labels, plugs)
ZS5000-0002 | Fieldbus Box set M12 (contact labels, plugs)
ZS5000-0010 | plugs M8, IP67 (50 pieces)
ZS5000-0020 | plugs M12, IP67 (50 pieces)
ZS5100-0000 | marking labels, not printed, 4 stripes at 10 pieces
ZS5100-xxxx | printed marking labels, on request
Tools
Ordering information | Description
ZB8800 | torque wrench for M8 cables with knurl, incl. ratchet
ZB8800-0001 | M12 ratchet for torque wrench ZB8800
ZB8800-0002 | M8 ratchet (field assembly) for torque wrench ZB8800
ZB8801-0000 | torque wrench for hexagonal plugs, adjustable
ZB8801-0001 | torque cable key, M8/wrench size 9, for torque wrench ZB8801-0000
ZB8801-0002 | torque cable key, M12/wrench size 13, for torque wrench ZB8801-0000
ZB8801-0003 | torque cable key, M12 field assembly/wrench size 13, for torque wrench ZB8801-0000
Further accessories
Further accessories may be found at the price list for Beckhoff fieldbus components and at the internet under https://www.beckhoff.com


Servo technology - accessories

Appendix [image] Servo technology - accessories
Servo technology - accessories
Item | Comment
ZK1090-3xxx-xxxx | Cable for EtherCAT signal input and output
ZK2030-xxxx-xxxx, ZK2031-xxxx-xxxx | Cable for 7/8" power supply
AM811x | Servomotor 0.20...0.52 Nm for servo I/Os (EL72xx, EP72xx)
AM812x | Servomotor 0.50…0.80 Nm for servo I/Os (EL72xx, EP72xx)
AM813x | Servomotor 1.35…2.37 Nm for servo I/Os (EL72xx, EP72xx)
AM814x | Servomotor 2.40 Nm for servo I/Os (EL72xx, EP72xx)
ZK47x4-04xx, ZK4000-xxxx | Connection cables for compact drive technology
EL6910 | TwinSAFE Logic Terminal
EP1908 | EtherCAT Box, industrial housing, 8 digital inputs, TwinSAFE, 24 VDC
EL2904 | four-channel digital output terminal, TwinSAFE, 24 VDC, 0.5 A


Version identification of EtherCAT devices

Appendix [image] Version identification of EtherCAT devices
Version identification of EtherCAT devices
Designation
A Beckhoff EtherCAT device has a 14-digit designation, made up of
▪
family key
▪
type
▪
version
▪
revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
Notes
▪
The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
▪
EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
▪
The order identifier is made up of
- family key (EL, EP, CU, ES, KL, CX, etc.)
- type (3314)
- version (-0000)
▪
The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
▪
The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Identification number
Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:
Production lot/batch number/serial number/date code/D number
The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02
Exceptions can occur in the IP67 area, where the following syntax can be used (see respective device documentation):
Syntax: D ww yy x y z u
D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB
Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1
Unique serial number/ID, ID number
In addition, in some series each individual module has its own unique serial number.
See also the further documentation in the area
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Terminals with factory calibration certificate and other measuring terminals
Examples of markings
EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
CU2016 switch with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
EP1258-00001 IP67 EtherCAT Box with batch number/ date code 22090101 and unique serial number 158102
EP1908-0002 IP67 EtherCAT Safety Box with batch number/ date code 071201FF and unique serial number 00346070
EL2904 IP20 safety terminal with batch number/ date code 50110302 and unique serial number 00331701
ELM3604-0002 terminal with unique ID number (QR code) 100001051 and serial/ batch number 44160201
Additional information
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Appendix [image] Version identification of EtherCAT devices [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com