EP7041-xxxx - Stepper motor modules
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
2.4
▪
Front page updated
2.3
▪
Technical data updated
2.2.0
▪
Update safety instructions
▪
Update chapter Mounting
2.1.0
▪
EP7041-3102 added
2.0.0
▪
Migration
1.7.0
▪
Preface updated
▪
Chapter on Nut torques for connectors updated
▪
Chapter on EtherCAT connection updated
▪
Chapter Signal cable updated
▪
Chapter Accessories updated
▪
Chapter Line losses updated
1.6.0
▪
Power connection updated
1.5.0
▪
Technical data updated
1.4.0
▪
Technical data updated
1.3.0
▪
Technical data updated
▪
Object descriptions updated
▪
Basics about Position Interface added
▪
Chapter Accessories updated
▪
Chapter on Nut torque for connectors updated
▪
Chapter Power connection updated
1.2.0
▪
Chapter Configuration of the main parameters updated
▪
Chapter Accessories added
1.1.0
▪
Technical data updated
▪
EP7041-2002 and EP7041-3002 added
▪
Overview of EtherCAT cables extended
▪
Overview of the signal cables updated
▪
Description of the power connection updated
▪
ATEX notes added
▪
Extended temperature range for activated modules documented
1.0.0
▪
Chapter on commissioning and configuration revised
0.6
▪
EP7041-1002 added
▪
Object description updated
▪
Nut torque for connectors added
▪
Overview of the signal cables added
0.5
▪
First preliminary version for EP7041-0002
Firmware and hardware versions
This documentation refers to the firmware and hardware version that was applicable at the time the documentation was written.
The module features are continuously improved and developed further. Modules having earlier production statuses cannot have the same properties as modules with the latest status. However, existing properties are retained and are not changed, so that older modules can always be replaced with new ones.
Documentation | EP7041-0002 |  | EP7041-1002 |  | EP7041-2002 |  | EP7041-3002 |  | EP7041-3102
 | Firmware | Hardware | Firmware | Hardware | Firmware | Hardware | Firmware | Hardware | Firmware | Hardware
2.4 | 11 | 14 | 10 | 12 | 11 | 13 | 07 | 10 | 07 | 07
2.3 | 11 | 14 | 10 | 12 | 11 | 13 | 07 | 10 | 07 | 07
2.2.0 | 11 | 14 | 10 | 12 | 11 | 13 | 07 | 10 | 07 | 06
2.1.0 | 11 | 12 | 10 | 10 | 11 | 11 | 06 | 08 | 06 | 04
2.0.0 | 11 | 11 | 10 | 09 | 11 | 10 | 06 | 08 | - | -
1.7.0 | 11 | 11 | 10 | 09 | 11 | 10 | 06 | 07
1.6.0 | 09 | 10 | 09 | 08 | 10 | 10 | 06 | 07
1.4.0 | 08 | 06 | 08 | 04 | 08 | 06 | 04 | 02
1.3.0 | 08 | 06 | 08 | 04 | 08 | 06 | 04 | 02
1.2.0 | 08 | 03 | 08 | 01 | 08 | 03 | 04 | 02
1.1.0 | 07 | 03 | 07 | 01 | 07 | 03 | 02 | 01
1.0.0 | 04 | 01 | 04 | 00 | - | - | - | -
0.6 | 04 | 01 | 04 | 00
0.5 | 03 | 01 | - | -
The firmware and hardware version (delivery state) can be found in the batch number (D-number) printed on the side of the EtherCAT Box.
Syntax of the batch number (D-number)
D: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with D no. 29 10 02 01:
29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01
Further information on this topic: Version identification of EtherCAT devices.


Product overview

Product overview
Product overview
Additional information
•
EtherCAT Box - Introduction
•
Module overview
•
Introduction
•
Technical data
•
Scope of supply
•
EP7041 - Process image


EtherCAT Box - Introduction

Product overview [image] EtherCAT Box - Introduction
EtherCAT Box - Introduction
The EtherCAT system has been extended with EtherCAT Box modules with protection class IP 67. Through the integrated EtherCAT interface the modules can be connected directly to an EtherCAT network without an additional Coupler Box. The high-performance of EtherCAT is thus maintained into each module.
The extremely low dimensions of only 126 x 30 x 26.5 mm (h x w x d) are identical to those of the Fieldbus Box extension modules. They are thus particularly suitable for use where space is at a premium. The small mass of the EtherCAT modules facilitates applications with mobile I/O interface (e.g. on a robot arm). The EtherCAT connection is established via screened M8 connectors.
EtherCAT Box Modules within an EtherCAT network
The robust design of the EtherCAT Box modules enables them to be used directly at the machine. Control cabinets and terminal boxes are now no longer required. The modules are fully sealed and therefore ideally prepared for wet, dirty or dusty conditions.
Pre-assembled cables significantly simplify EtherCAT and signal wiring. Very few wiring errors are made, so that commissioning is optimized. In addition to pre-assembled EtherCAT, power and sensor cables, field-configurable connectors and cables are available for maximum flexibility. Depending on the application, the sensors and actuators are connected through M8 or M12 connectors.
The EtherCAT modules cover the typical range of requirements for I/O signals with protection class IP67:
▪
digital inputs with different filters (3.0 ms or 10 μs)
▪
digital outputs with 0.5 or 2 A output current
▪
analog inputs and outputs with 16 bit resolution
▪
Thermocouple and RTD inputs
▪
Stepper motor modules
XFC (eXtreme Fast Control Technology) modules, including inputs with time stamp, are also available.
EtherCAT Box with M8 connections for sensors/actuators
EtherCAT Box with M12 connections for sensors/actuators
Basic EtherCAT documentation
You will find a detailed description of the EtherCAT system in the Basic System Documentation for EtherCAT, which is available for download from our website (www.beckhoff.com) under Downloads.
EtherCAT XML Device Description
You will find XML files (XML Device Description Files) for Beckhoff EtherCAT modules on our website (www.beckhoff.com) under Downloads, in the Configuration Files area.


Module overview

Product overview [image] Module overview
Module overview
EP7041 with stepper motor
Module
Output current for stepper motor
Integrated connection for motor supply
Comment
EP7041-0002
2 x 3.5 A rated current,
2 x 5.0 A peak current
M12, female
▪
Designed for particularly quiet and precise motor operation.
EP7041-1002
2 x 1.0 A rated current,
2 x 1.5 A peak current
M12, female
▪
Designed for particularly quiet and precise motor operation.
▪
Smaller output current for stepper motors with lower power consumption.
EP7041-2002
2 x 3.5 A rated current,
2 x 5.0 A peak current
M12, male
▪
Designed for particularly quiet and precise motor operation.
▪
Integrated connector for feeding the motor supply build with pins (male).
EP7041-3002
2 x 3.5 A rated current,
2 x 5.0 A peak current
M12, male
▪
Designed for higher velocities.
▪
Integrated connector for feeding the motor supply build with pins (male).
EP7041-3102
2 x 3.5 A rated current,
2 x 5.0 A peak current
M12, male
▪
Designed for higher velocities.
▪
Integrated connector for feeding the motor supply build with pins (male).
▪
5 VDC encoder supply


Introduction

Product overview [image] Introduction
Introduction
Additional information
•
EP7041-0002, EP7041
•
EP7041-2002
•
EP7041-3002, EP7041-3102


EP7041-0002, EP7041

Product overview [image] Introduction [image] EP7041-0002, EP7041
EP7041-0002, EP7041
EP7041-0002
Stepper Motor modules with interface for incremental encoder
The EP7041-0002 and EP7041-1002 EtherCAT Box Modules are intended for the direct connection of different stepper motors.
Two versions are available:
▪
EP7041-0002: 2 x 3.5 A rated current, (2 x 5.0 A peak current)
▪
EP7041-1002: 2 x 1.0 A rated current, (2 x 1.5 A peak current)
The PWM output stages for two motor coils with compact design are located in the module together with two inputs for limit switches and cover a wide voltage and current range.
A servo axis can easily be realized by connecting an incremental encoder.
Two digital inputs and a digital output (0.5 A) enable connection of limit switches and a motor brake.
The modules can be adjusted to the motor and the application by changing various parameters.
64-fold micro-stepping ensures particularly quiet and precise motor operation.
Quick links
▪
Installation
▪
Configuration


EP7041-2002

Product overview [image] Introduction [image] EP7041-2002
EP7041-2002
EP7041-2002
Stepper Motor modules with interface for incremental encoder
The EP7041-2002 EtherCAT Box is designed for direct connection of different stepper motors.
The PWM output stages for two motor coils with compact design are located in the module together with two inputs for limit switches and cover a wide voltage and current range.
A servo axis can easily be realized by connecting an incremental encoder.
Two digital inputs and a digital output (0.5 A) enable connection of limit switches and a motor brake.
The external motor is fed via an integrated plug.
The EP7041-2002 can be adjusted to the motor and the application by changing various parameters.
64-fold micro-stepping ensures particularly quiet and precise motor operation.
Quick-Links
▪
Installation
▪
Configuration


EP7041-3002, EP7041-3102

Product overview [image] Introduction [image] EP7041-3002, EP7041-3102
EP7041-3002, EP7041-3102
EP7041-3002 and EP7041-3102
Stepper Motor modules with interface for incremental encoder
The EP7041-3002 and EP7041-3102 EtherCAT Box Modules are designed for direct connection of different stepper motors. The PWM output stages for two motor coils with compact design are located in the module together with two inputs for limit switches and cover a wide voltage and current range.
A servo axis can easily be realized by connecting an incremental encoder. The modules supply the incremental encoder with:
EP7041-3002: 24 VDC
EP7041-3102: 5 VDC
Two digital inputs and a digital output (0.5 A) enable connection of limit switches and a motor brake.
The external motor is fed via an integrated plug.
EP7041-3002 and EP7041-3102 are designed for higher velocities and can be adjusted to the motor and the application by changing various parameters.
Quick-Links
▪
Installation
▪
Configuration


Technical data

Product overview [image] Technical data
Technical data
All values are typical values over the entire temperature range, unless stated otherwise.
Technical data
EP7041-0002
EP7041-1002
EP7041-2002
EP7041-3002
EP7041-3102
Fieldbus
Fieldbus
EtherCAT
Connection
2 x M8 socket, green
Electrical isolation
500 V (fieldbus / IO)
Process image
Input: 2 x 16 bit data, 1 x 16 bit status
Output: 2 x 16 bit data, 1 x 16 bit control
Supply voltages
Connection
Feed: 1 x M8 plug, 4-pin, black
Downstream connection: 1 x M8 socket, 4-pin, black
Control voltage US
Nominal voltage
24 VDC (-15 % / +20 %)
Sum current
max. 4 A 1)
Consumers
Module electronics: 120 mA
Peripheral voltage UP
Nominal voltage
24 VDC (-15 % / +20 %)
Sum current
max. 4 A 1)
Consumers
• Encoder
• Digital output: Brake
Motor
Motor type
2-phase stepper motor, unipolar or bipolar
Connection
M12 socket
DC link voltage
max. 50 VDC, not protected against polarity reversal
Connection
M12 socket "2“
M12 connector "2“
Rated current per phase
3.5 A
1.0 A
3.5 A
Peak current per phase
5.0 A at 50 °C
1.5 A
5.0 A at 50 °C
Microstepping
max. 64 microsteps 2)
max. 256 microsteps 2)
Step frequency
max. 32,000 full steps per second (configurable)
Current controller frequency
approx. 30 kHz
Driver circuit
2 x H-bridge
Protective functions
Overload protection, short-circuit protection
Encoder input
encoder type
Incremental encoder with single-ended output drivers:
▪
Push-pull
▪
Open collector 3)
Connection
M12 socket
Signals
A, B, C (reference pulse/zero pulse)
Low level
-3 .. 2 VDC
max. 1 VDC 4)
High level
3.5 .. 28 VDC
2.5 .. 28 VDC 4)
Supply voltage
24 VDC from peripheral voltage UP
5 VDC
Supply current
0.5 A, not short-circuit proof
0.3 A
Pulse frequency
maximum 400,000 increments/s (quadruple evaluation)
1) This value corresponds to the current carrying capacity of the connections for the supply voltages.
2) EP7041 automatically selects the number of microsteps according to the speed
3) Pull-up resistor required
4) These levels apply from hardware version 09. Up to hardware version 08 the following levels apply:
▪
Low level: -3 .. 2 VDC
▪
High level: 3.5 .. 28 VDC
Technical data | EP7041-0002 | EP7041-1002 | EP7041-2002 | EP7041-3002 | EP7041-3102
Digital inputs: limit switch
Number | 2
Connection | M12 socket
Signal voltage "0" | -3 V ... 2 V
Signal voltage "1" | 3.5 V ... 28 V
Input current | 5 mA
Digital output: Brake
Number | 1
Connection | M12 socket
Output voltage | 24 VDC from peripheral voltage UP
Output current | 0.5 A, short-circuit proof
Environmental conditions
Ambient temperature during operation | -25 .. +60 °C 0 .. +55 °C according to ATEX, see special conditions
Ambient temperature during storage | -40 .. +85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Mechanics
Dimensions | approx. 126 x 30 x 26.5 mm (without connectors)
Weight | approx. 165 g
Installation position | up to 40 °C ambient temperature: variable over 40 °C ambient temperature: distance between 2 stepper motor modules at least 20 mm
Approvals and conformity
Approvals | CE, ATEX


Scope of supply

Product overview [image] Scope of supply
Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EtherCAT Box EP7041
▪
1x protective cap for supply voltage input, M8, transparent (pre-assembled)
▪
1x protective cap for supply voltage output, M8, black (pre-assembled)
▪
2x protective cap for EtherCAT socket, M8, green (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


EP7041 - Process image

Product overview [image] EP7041 - Process image
EP7041 - Process image
The TwinCAT System Manager displays the EP7041 data in a tree structure.
The tree shows
▪
ENC Status compact: encoder status
▪
STM Status: Stepper Motor Status
▪
ENC Control compact: Encoder Control
▪
STM Control: Stepper Motor Control
▪
STM Velocity: Stepper Motor Velocity
ENC Status compact
The status information for the encoder can be found under ENC Status compact.
STM Status
The status information for the stepper motor can be found under STM Status.
ENC Control compact
The control parameters for the encoder can be found under ENC Control compact.
STM Control
The control parameters for the stepper motor can be found under STM Control.
STM Velocity
The velocity settings for the stepper motor can be found under STM Velocity.


Installation

Installation
Installation
Additional information
•
Mounting
•
Connection
•
ATEX notes


Mounting

Installation [image] Mounting
Mounting
Additional information
•
Dimensions
•
Fixing
•
Tightening torques for plug connectors


Dimensions

Installation [image] Mounting [image] Dimensions
Dimensions
Dimensions
All dimensions are given in millimeters.
Housing features
Housing material | PA6 (polyamide)
Sealing compound | polyurethane
Mounting | two fastening holes Ø 3.5 mm for M3
Metal parts | brass, nickel-plated
Contacts | CuZn, gold-plated
Power feed through | max. 4 A
Installation position | variable
Protection class | IP65, IP66, IP67 (conforms to EN 60529) when screwed together
Dimensions (H x W x D) | approx. 126 x 30 x 26.5 mm (without connectors)


Fixing

Installation [image] Mounting [image] Fixing
Fixing
Note
Dirt during assembly
Dirty connectors can lead to malfunctions. Protection class IP67 can only be guaranteed if all cables and connectors are connected.
•
Protect the plug connectors against dirt during the assembly.
Mount the module with two M3 screws on the fastening holes in the corners of the module. The fastening holes have no thread.


Tightening torques for plug connectors

Installation [image] Mounting [image] Tightening torques for plug connectors
Tightening torques for plug connectors
Screw connectors tight with a torque wrench. (e.g. ZB8801 from Beckhoff)
Connector diameter | Tightening torque
M8 | 0.4 Nm
M12 | 0.6 Nm


Connection

Installation [image] Connection
Connection
Additional information
•
Supply voltages
•
EtherCAT
•
Stepper motor, brake, encoder


Supply voltages

Installation [image] Connection [image] Supply voltages
Supply voltages
The EtherCAT Box is supplied with two supply voltages. The ground potentials of the supply voltages are galvanically connected together.
▪
Control voltage US
▪
Peripheral voltage UP
Redirection of the supply voltages
The IN and OUT power connections are bridged in the module (not IP204x-Bxxx and IE204x). The supply voltages US and UP can thus easily be transferred from EtherCAT Box to EtherCAT Box.
Note
Pay attention to the maximum permissible current!
Pay attention also for the redirection of the supply voltages US and UP, the maximum permissible current for M8 connectors of 4 A must not be exceeded!
Additional information
•
Connectors
•
Status LEDs
•
Conductor losses


Connectors

Installation [image] Connection [image] Supply voltages [image] Connectors
Connectors
Note
Risk of confusion: supply voltages and EtherCAT
Defect possible through incorrect insertion.
•
Observe the color coding of the connectors:
black: Supply voltages
green: EtherCAT
Connectors for supply voltages
M8 connector
Contact | Function | Description | Core color 1)
1 | US | Control voltage | Brown
2 | UP | Peripheral voltage | White
3 | GNDS | GND to US | Blue
4 | GNDP | GND to UP | Black
1) The core colors apply to cables of the type: Beckhoff ZK2020-3xxx-xxxx


Status LEDs

Installation [image] Connection [image] Supply voltages [image] Status LEDs
Status LEDs
Connectors + LEDs
Status LEDs for the supply voltages
LED | Display | Meaning
US (control voltage) | off | Supply voltage US is not present
 | green illuminated | Supply voltage US is present
UP (peripheral voltage) | off | Supply voltage UP is not present
 | green illuminated | Supply voltage UP is present


Conductor losses

Installation [image] Connection [image] Supply voltages [image] Conductor losses
Conductor losses
Take into account the voltage drop on the supply line when planning a system. Avoid the voltage drop being so high that the supply voltage at the box lies below the minimum nominal voltage.
Variations in the voltage of the power supply unit must also be taken into account.
Voltage drop on the supply line
Leitungsverluste M8 2A
Leitungsverluste M8 4A


EtherCAT

Installation [image] Connection [image] EtherCAT
EtherCAT
Additional information
•
Connectors
•
Status LEDs
•
Cables


Connectors

Installation [image] Connection [image] EtherCAT [image] Connectors
Connectors
Note
Risk of confusion: supply voltages and EtherCAT
Defect possible through incorrect insertion.
•
Observe the color coding of the connectors:
black: Supply voltages
green: EtherCAT
EtherCAT Box Modules have two green M8 sockets for the incoming and downstream EtherCAT connections.
EtherCAT connectors
Connection
M8 socket, 4-pin – connection
M8 socket
EtherCAT | M8 connector | Core colors
Signal | Contact | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 and old versions of ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | 1 | yellow1) | orange/white | white/orange
Tx - | 4 | orange1) | orange | orange
Rx + | 2 | white1) | blue/white | white/green
Rx - | 3 | blue1) | blue | green
Shield | Housing | Shield | Shield | Shield
1) Core colors according to EN 61918
Adaptation of core colors for cables ZB9030, ZB9032 and ZK1090-3xxxx-xxxx
For standardization, the core colors of the ZB9030, ZB9032 and ZK1090-3xxx-xxxx cables have been changed to the EN61918 core colors: yellow, orange, white, blue. So there are different color codes in circulation. The electrical properties of the cables have been retained when the core colors were changed.


Status LEDs

Installation [image] Connection [image] EtherCAT [image] Status LEDs
Status LEDs
EtherCAT status LEDs
L/A (Link/Act)
A green LED labelled "L/A" is located next to each EtherCAT socket. The LED indicates the communication state of the respective socket:
LED | Meaning
off | no connection to the connected EtherCAT device
lit | LINK: connection to the connected EtherCAT device
flashes | ACT: communication with the connected EtherCAT device
Run
Each EtherCAT slave has a green LED labelled "Run". The LED signals the status of the slave in the EtherCAT network:
LED | Meaning
off | Slave is in "Init" state
flashes uniformly | Slave is in "Pre-Operational“ state
flashes sporadically | Slave is in "Safe-Operational" state
lit | Slave is in "Operational" state
Description of the EtherCAT slave states


Cables

Installation [image] Connection [image] EtherCAT [image] Cables
Cables
For connecting EtherCAT devices only shielded Ethernet cables that meet the requirements of at least category 5 (CAT5) according to EN 50173 or ISO/IEC 11801 should be used.
EtherCAT uses four wires for signal transmission.
Thanks to automatic line detection ("Auto MDI-X"), both symmetrical (1:1) or cross-over cables can be used between Beckhoff EtherCAT.
Detailed recommendations for the cabling of EtherCAT devices


Stepper motor, brake, encoder

Installation [image] Connection [image] Stepper motor, brake, encoder
Stepper motor, brake, encoder
Additional information
•
Signal connection
•
Status LEDs


Signal connection

Installation [image] Connection [image] Stepper motor, brake, encoder [image] Signal connection
Signal connection
Signal connection EP7041-3002
Note
Note the numbering of the M12 sockets
Mixing up the M12 connectors can damage the module.
M12 socket no. 1: Stepper motor connection
Stepper motor connection
M12-Socket no. 2: Connection for motor supply
Note
The motor supply connection is not protected against polarity reversal
Defect possible through polarity reversal.
•
Ensure that the polarity is correct.
Connection for motor supply with EP7041-0002 and EP7041-1002
Connection for motor supply with EP7041-2002 and EP7041-3002
M12 socket no. 3: Connection for digital inputs and outputs
The signal connection of the digital inputs and outputs is done via M12 connectors.
Connection for digital inputs and outputs
The sensors are supplied with a common maximum current of 0.5 A from the control voltage Us.
The output is short-circuit-proof and is protected against polarity reversal.
LEDs indicate the signal state of the inputs and outputs.
M12 socket no. 4: Encoder connection
Note
The encoder supply voltage is not short-circuit proof.
Risk of damage due to short circuit.
•
Avoid short-circuiting the encoder supply voltage "V Enc“.
Encoder
Encoder connection


Status LEDs

Installation [image] Connection [image] Stepper motor, brake, encoder [image] Status LEDs
Status LEDs
LEDs EP7041-3002
Status LEDs at the M12 connections
Connection | LED | Display | Meaning
M12 socket no. 1: Stepper motor | S left | green | Motor control is enabled (Index 0x6010:02 is set) and EP7041 is ready to operate
 |  | yellow | If motor is disabled: motor control in standby
 |  |  | If motor is enabled: warning, configuration error. Check the motor status.
 |  | red | Error: Check DiagData (Index 0xA010)
 | R right | green | Motor is turning
 |  | red | internal error
M12 socket no. 2: Motor supply | V left | off | Motor supply voltage is not present
 |  | green | Motor supply voltage is present
 | O right | off | Binary output (M12 socket no. 3, pin 5) switched off (0 V)
 |  | green | Binary output (M12 socket no. 3, pin 5) switched on (24 V)
M12 socket no. 3: binary inputs binary output | DI 1 left | off | there is no signal (0 V) on binary input 1 (M12 socket no. 3, pin 4)
 |  | green | there is no signal (24 V) on binary input 1 (M12 socket no. 3, pin 4)
 | DI 2 right | off | there is no signal (0 V) on binary input 2 (M12 socket no. 3, pin 2)
 |  | green | there is no signal (24 V) on binary input 2 (M12 socket no. 3, pin 2)
M12 socket no. 4: Encoder | C left | flashes | Encoder track C
 | A right | flashes | Encoder track A


ATEX notes

Installation [image] ATEX notes
ATEX notes
Additional information
•
ATEX - Special conditions
•
BG2000 - EtherCAT Box protection enclosures
•
ATEX Documentation


ATEX - Special conditions

Installation [image] ATEX notes [image] ATEX - Special conditions
ATEX - Special conditions
SmallWarningYellow WARNING
Observe the special conditions for the intended use of EtherCAT Box modules in potentially explosive areas – directive 94/9/EU.
•
The certified components are to be installed with a BG2000-0000 or BG2000-0010 protection enclosure that guarantees a protection against mechanical hazards!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of 0 to 55°C for the use of EtherCAT Box modules in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0: 2006
▪
EN 60079-15: 2005
Marking
The EtherCAT Box modules certified for potentially explosive areas bear the following marking:
II 3 G Ex nA II T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
or
II 3 G Ex nA nC IIC T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
Batch number (D number)
The EtherCAT Box modules bear a batch number (D number) that is structured as follows:
D: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with batch number 29 10 02 01:
29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01


BG2000 - EtherCAT Box protection enclosures

Installation [image] ATEX notes [image] BG2000 - EtherCAT Box protection enclosures
BG2000 - EtherCAT Box protection enclosures
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the EtherCAT system into a safe, powered down state before starting installation, disassembly or wiring of the modules!
ATEX
SmallWarningYellow WARNING
Mount a protection enclosure!
To fulfill the special conditions according to ATEX, a BG2000-0000 or BG2000-0010 protection enclosure has to be mounted over the EtherCAT Box.
Installation
Put the cables for EtherCAT, power supply and sensors/actuators through the hole of the protection enclosure.
BG2000 - putting the cables
Fix the wires for EtherCAT, power supply and sensors/actuators to the EtherCAT Box.
BG2000 - fixing the cables
Mount the protection enclosure over the EtherCAT Box.
BG2000 - mounting the protection enclosure


ATEX Documentation

Installation [image] ATEX notes [image] ATEX Documentation
ATEX Documentation
Notes about operation of EtherCAT Box Modules (EPxxxx-xxxx) in potentially explosive areas (ATEX)
Pay also attention to the continuative documentationNotes about operation of EtherCAT Box Modules (EPxxxx-xxxx) in potentially explosive areas (ATEX) that is available in the download area of the Beckhoff homepage http:\\www.beckhoff.com!


Commissioning/Configuration

Commissioning/Configuration
Commissioning/Configuration
Additional information
•
Integration in TwinCAT
•
CoE objects EP7041-0002, EP7041-1002, EP7041-2002
•
CoE objects EP7041-3002, EP7041-3102


Integration in TwinCAT

Commissioning/Configuration [image] Integration in TwinCAT
Integration in TwinCAT
Additional information
•
Inserting into the EtherCAT network
•
Configuration via TwinCAT
•
Integration into the NC configuration
•
Configuration of the main parameters
•
Basic principles for the Positioning Interface
•
Application example
•
Restoring the delivery state


Inserting into the EtherCAT network

Commissioning/Configuration [image] Integration in TwinCAT [image] Inserting into the EtherCAT network
Inserting into the EtherCAT network
Installation of the latest XML device description
Please ensure that you have installed the latest XML device description in TwinCAT. This can be downloaded from the Beckhoff website (http://www.beckhoff.de/english/download/elconfg.htm?id=1983920606140) and installed according to the installation instructions.
At the Beckhoff TwinCAT System Manager the configuration tree can be build in two different ways:
▪
by scanning for existing hardware (called "online") and
▪
by manual inserting/appending of fieldbus devices, couplers and slaves.
Automatic scanning in of the box
▪
The EtherCAT system must be in a safe, de-energized state before the EtherCAT modules are connected to the EtherCAT network!
▪
Switch on the operating voltage, open the TwinCAT System Manager (Config mode), and scan in the devices (see Fig. 1). Acknowledge all dialogs with "OK", so that the configuration is in "FreeRun" mode.
Scanning in the configuration (I/O Devices -> right-click -> Scan Devices...)
Appending a module manually
▪
The EtherCAT system must be in a safe, de-energized state before the EtherCAT modules are connected to the EtherCAT network!
▪
Switch on the operating voltage, open the TwinCAT System Manager (Config mode)
▪
Append a new I/O device. In the dialog that appears select the device EtherCAT (Direct Mode), and confirm with OK.
Appending a new I/O device (I/O Devices -> right-click -> Append Device...)
Selecting the device EtherCAT
▪
Append a new box.
Appending a new box (Device -> right-click -> Append Box...)
▪
In the dialog that appears select the desired box (e.g. EP2816-0008), and confirm with OK.
Selecting a Box (e.g. EP2816-0008)
Appended Box in the TwinCAT tree


Configuration via TwinCAT

Commissioning/Configuration [image] Integration in TwinCAT [image] Configuration via TwinCAT
Configuration via TwinCAT
In the left-hand window of the TwinCAT System Manager, click on the branch of the EtherCAT Box you wish to configure (EP2816-0008 in this example).
Branch of the EtherCAT box to be configured
In the right-hand window of the TwinCAT System manager, various tabs are now available for configuring the EtherCAT Box.
General tab
General tab
Name | Name of the EtherCAT device
Id | Number of the EtherCAT device
Type | EtherCAT device type
Comment | Here you can add a comment (e.g. regarding the system).
Disabled | Here you can deactivate the EtherCAT device.
Create symbols | Access to this EtherCAT slave via ADS is only available if this checkbox is activated.
EtherCAT tab
EtherCAT tab
Type | EtherCAT device type
Product/Revision | Product and revision number of the EtherCAT device
Auto Inc Addr. | Auto increment address of the EtherCAT device. The auto increment address can be used for addressing each EtherCAT device in the communication ring through its physical position. Auto increment addressing is used during the start-up phase when the EtherCAT master allocates addresses to the EtherCAT devices. With auto increment addressing the first EtherCAT slave in the ring has the address 0000hex. For each further slave the address is decremented by 1 (FFFFhex, FFFEhex etc.).
EtherCAT Addr. | Fixed address of an EtherCAT slave. This address is allocated by the EtherCAT master during the start-up phase. Tick the checkbox to the left of the input field in order to modify the default value.
Previous Port | Name and port of the EtherCAT device to which this device is connected. If it is possible to connect this device with another one without changing the order of the EtherCAT devices in the communication ring, then this combobox is activated and the EtherCAT device to which this device is to be connected can be selected.
Advanced Settings | This button opens the dialogs for advanced settings.
The link at the bottom of the tab points to the product page for this EtherCAT device on the web.
Process Data tab
Indicates the configuration of the process data. The input and output data of the EtherCAT slave are represented as CANopen process data objects (PDO). The user can select a PDO via PDO assignment and modify the content of the individual PDO via this dialog, if the EtherCAT slave supports this function.
Process Data tab
Sync Manager
Lists the configuration of the Sync Manager (SM).
If the EtherCAT device has a mailbox, SM0 is used for the mailbox output (MbxOut) and SM1 for the mailbox input (MbxIn).
SM2 is used for the output process data (outputs) and SM3 (inputs) for the input process data.
If an input is selected, the corresponding PDO assignment is displayed in the PDO Assignment list below.
PDO Assignment
PDO assignment of the selected Sync Manager. All PDOs defined for this Sync Manager type are listed here:
▪
If the output Sync Manager (outputs) is selected in the Sync Manager list, all RxPDOs are displayed.
▪
If the input Sync Manager (inputs) is selected in the Sync Manager list, all TxPDOs are displayed.
The selected entries are the PDOs involved in the process data transfer. In the tree diagram of the System Manager these PDOs are displayed as variables of the EtherCAT device. The name of the variable is identical to the Name parameter of the PDO, as displayed in the PDO list. If an entry in the PDO assignment list is deactivated (not selected and greyed out), this indicates that the input is excluded from the PDO assignment. In order to be able do select a greyed out PDO, the currently selected PDO has to be deselected first.
Activation of PDO assignment
•
the EtherCAT slave has to run through the PS status transition cycle (from pre-operational to safe-operational) once (see Online tab),
•
and the System Manager has to reload the EtherCAT slaves ( [image] button)
PDO list
List of all PDOs supported by this EtherCAT device. The content of the selected PDOs is displayed in the PDO Content list. The PDO configuration can be modified by double-clicking on an entry.
Column | Description
Index | PDO index.
Size | Size of the PDO in bytes.
Name | Name of the PDO. If this PDO is assigned to a Sync Manager, it appears as a variable of the slave with this parameter as the name.
Flags | F | Fixed content: The content of this PDO is fixed and cannot be changed by the System Manager.
 | M | Mandatory PDO. This PDO is mandatory and must therefore be assigned to a Sync Manager! Consequently, this PDO cannot be deleted from the PDO Assignment list
SM | Sync Manager to which this PDO is assigned. If this entry is empty, this PDO does not take part in the process data traffic.
SU | Sync unit to which this PDO is assigned.
PDO Content
Indicates the content of the PDO. If flag F (fixed content) of the PDO is not set the content can be modified.
Download
If the device is intelligent and has a mailbox, the configuration of the PDO and the PDO assignments can be downloaded to the device. This is an optional feature that is not supported by all EtherCAT slaves.
PDO Assignment
If this check box is selected, the PDO assignment that is configured in the PDO Assignment list is downloaded to the device on startup. The required commands to be sent to the device can be viewed in the Startup tab.
PDO Configuration
If this check box is selected, the configuration of the respective PDOs (as shown in the PDO list and the PDO Content display) is downloaded to the EtherCAT slave.
Startup tab
The Startup tab is displayed if the EtherCAT slave has a mailbox and supports the CANopen over EtherCAT (CoE) or Servo drive over EtherCAT protocol. This tab indicates which download requests are sent to the mailbox during startup. It is also possible to add new mailbox requests to the list display. The download requests are sent to the slave in the same order as they are shown in the list.
Startup tab
Column
Description
Transition
Transition to which the request is sent. This can either be
▪
the transition from pre-operational to safe-operational (PS), or
▪
the transition from safe-operational to operational (SO).
If the transition is enclosed in "<>" (e.g. <PS>), the mailbox request is fixed and cannot be modified or deleted by the user.
Protocol
Type of mailbox protocol
Index
Index of the object
Data
Date on which this object is to be downloaded.
Comment
Description of the request to be sent to the mailbox
Move Up | This button moves the selected request up by one position in the list.
Move Down | This button moves the selected request down by one position in the list.
New | This button adds a new mailbox download request to be sent during startup.
Delete | This button deletes the selected entry.
Edit | This button edits an existing request.
CoE - Online tab
The additional CoE - Online tab is displayed if the EtherCAT slave supports the CANopen over EtherCAT (CoE) protocol. This dialog lists the content of the object directory of the slave (SDO upload) and enables the user to modify the content of an object from this list. Details for the objects of the individual EtherCAT devices can be found in the device-specific object descriptions.
CoE - Online tab
Object list display
Column | Description
Index | Index and subindex of the object
Name | Name of the object
Flags | RW | The object can be read, and data can be written to the object (read/write)
 | RO | The object can be read, but no data can be written to the object (read only)
 | P | An additional P identifies the object as a process data object.
Value | Value of the object
Update List | The Update list button updates all objects in the displayed list
Auto Update | If this check box is selected, the content of the objects is updated automatically.
Advanced | The Advanced button opens the Advanced Settings dialog. Here you can specify which objects are displayed in the list.
Advanced settings
Online - via SDO information | If this option button is selected, the list of the objects included in the object directory of the slave is uploaded from the slave via SDO information. The list below can be used to specify which object types are to be uploaded.
Offline - via EDS file | If this option button is selected, the list of the objects included in the object directory is read from an EDS file provided by the user.
Online tab
Online tab
State Machine
Init | This button attempts to set the EtherCAT device to the Init state.
Pre-Op | This button attempts to set the EtherCAT device to the pre-operational state.
Op | This button attempts to set the EtherCAT device to the operational state.
Bootstrap | This button attempts to set the EtherCAT device to the Bootstrap state.
Safe-Op | This button attempts to set the EtherCAT device to the safe-operational state.
Clear Error | This button attempts to delete the fault display. If an EtherCAT slave fails during change of state it sets an error flag. Example: An EtherCAT slave is in PREOP state (pre-operational). The master now requests the SAFEOP state (safe-operational). If the slave fails during change of state it sets the error flag. The current state is now displayed as ERR PREOP. When the Clear Error button is pressed the error flag is cleared, and the current state is displayed as PREOP again.
Current State | Indicates the current state of the EtherCAT device.
Requested State | Indicates the state requested for the EtherCAT device.
DLL Status
Indicates the DLL status (data link layer status) of the individual ports of the EtherCAT slave. The DLL status can have four different states:
Status | Description
No Carrier / Open | No carrier signal is available at the port, but the port is open.
No Carrier / Closed | No carrier signal is available at the port, and the port is closed.
Carrier / Open | A carrier signal is available at the port, and the port is open.
Carrier / Closed | A carrier signal is available at the port, but the port is closed.
File Access over EtherCAT
Download | With this button a file can be written to the EtherCAT device.
Upload | With this button a file can be read from the EtherCAT device.


Integration into the NC configuration

Commissioning/Configuration [image] Integration in TwinCAT [image] Integration into the NC configuration
Integration into the NC configuration
(Master: TwinCAT 2.11)
Installation of the latest XML device description
Please ensure that you have installed the corresponding latest XML device description in TwinCAT. This can be downloaded from the Beckhoff website (http://www.beckhoff.de/german/default.htm?download/elconfg.htm) and installed according to the installation instructions.
Integration into the NC can be accomplished as follows:
▪
The terminal must already have been inserted manually under I/O devices or have been scanned in by the system (see section "Inserting the terminal in the EtherCAT Terminal network").
▪
First add a new task. Right-click on NC configuration and select "Append Task..." (see Fig. Adding a new task).
▪
Rename the task if required and confirm with OK.
Adding a new task
▪
Right-click on Axes, then add a new axis (see Fig. Linking the axis with the terminal).
Adding a new axis
▪
Select Continuous Axis type and confirm with OK (see Fig. 3).
Selecting and confirming the axis type
▪
Left-click your axis to select it. Under the Settings tab select "Link To..." (see Fig. Linking the axis with the terminal).
Linking the axis with the terminal
▪
Select the right terminal (Stepper Drive (MDP 703)) and confirm with OK.
Selecting the right terminal
▪
All main links between the NC configuration and the terminal are set automatically (see Fig. "Automatic linking of all main variables")
Automatic linking of all main variables
▪
Several parameters have to be set before the motor can be started up. The values can be found in section "Configuration of the main parameters". Please set these parameters before continuing with the motor commissioning procedure.
Commissioning the motor with the NC
▪
Once the parameters are set, the motor is basically ready for operation. Individual further parameters have to be adapted to the respective application.
▪
To commission the axis, activate the configuration (Ctrl+Shift+F4), select the axis, select tab Online and enable the axis under Set.
▪
Set all check marks and set Override to 100 (see Fig. 7). The axis can then be moved.
Enabling an axis
You can now move the axis with the function keys F1, F2 (Backward) or F3, F4 (Forward).
Alternatively you can control the axis via the Functions tab.
Example
▪
Select as Reversing Sequence as the start mode.
▪
Enter the required Target Position1, e.g. 5000°.
▪
Enter the required Target Velocity, e.g. 1200°/s.
▪
Enter the required Target Position2, e.g. 0°.
▪
Enter the required Idle Time, e.g. 1 s.
▪
Select Start.
Axis control, "Functions" tab
The motor now travels to Position 1, remains there for 1 s and then returns to Position 2. This is repeated until you click Stop.


Configuration of the main parameters

Commissioning/Configuration [image] Integration in TwinCAT [image] Configuration of the main parameters
Configuration of the main parameters
The data specified here apply to an AS 1050-0120 stepper motor and are intended as an example. For other motors the values may vary, depending on the application.
Setting the CoE objects
Execution of changes
Changes to CoE objects are only executed after the module has been placed in the Init state. Changes are only active after that.
Adaptation of current and voltage
Note
The motor may overheat!
In order to prevent overheating of the connected motor it is important to adapt the current and voltage output from the stepper interface to the motor.
To do this, set the indices 0x8010:01 Maximal current and 0x8010:03 Nominal voltage in the CoE register to suitable values (see Fig. Adaptation of current and voltage).
Reduced current can be set in index 0x8010:02. This reduces the coil current when at a standstill (and therefore the power dissipation). Please note that the torque is also reduced.
Adaptation of current and voltage
Base frequency selection
Microstepping is set to 1/64 and cannot be changed. However, the base frequency can be changed (default: 2000). To do this, mark the module and select the CoE Online tab. Change the base frequency by double-clicking on the index 0x8012:05 Speed range (Fig. Setting the base frequency).
Setting the base frequency
Selecting the feedback system
The module with encoder connections provides a choice of two possibilities for the feedback system:
▪
Internal Counter (default): Use internal counter for position feedback
▪
Encoder: Use external encoder for position feedback
Setting the feedback type
By default, the stepper module is set to internal counter. If an external encoder is used, the setting must be changed by double-clicking on the index 0x8012:08 Feedback type in the Enum menu (Fig. Selecting the feedback system).
Selecting the feedback system
KA factor (EP7041-0002 and EP7041-1002 only)
The KA factor can be used to adapt the current during the acceleration phases. The current increase is calculated as follows.
Current increase in mA = speed difference x KA / 1000
The steeper the speed ramp, the higher the current increase.
Speed ramps
This value can be set in index 0x8011:07 Ka factor (curr.) (see fig. Setting the KA factor).
Setting the KA factor
NC settings
Reference speed selection
The maximum speed can be calculated from the base frequency and the motor frequency.
v max = base frequency / motor frequency = (2000 full steps / s) / (200 full steps / rev) = 10 revolutions / s
The reference speed can be calculated by multiplying the maximum speed with the distance per revolution.
v ref = 10 revolutions / s x 360° = 3600 °/ s
Reference speed parameter
Dead time compensation
The dead time compensation should theoretically be 3 cycles of the NC cycle time, although in practice 4 cycles are preferable. At a cycle time of 2 ms it should therefore be 0.008 s. The dead time compensation can be found under Advanced Settings in the encoder parameters.
Dead time compensation parameter
Scaling factor
The scaling factor can be changed by selecting NC Axis 1_Enc and the Parameter tab in the NC (see fig. Setting the scaling factor (example with encoder)). The value can be calculated with the formulas specified below.
Setting the scaling factor (example with encoder)
Calculation of the scaling factor
with encoder:
SF = distance per revolution / increments x 4 = 360° / 1024 x 4 = 0.087890625 mm / INC
without encoder:
SF = distance per revolution / full steps x microsteps = 360° / 200 x 64 = 0.028125 mm / INC
Position lag monitoring
The position lag monitoring function checks whether the current position lag of an axis has exceeded the limit value. The position lag is the difference between the set value (control value) and the actual value reported back. If the terminal parameters are set inadequately, the position lag monitoring function may report an error when the axis is moved. During commissioning it may therefore be advisable to increase the limits of the Position lag monitoring slightly.
Note
ATTENTION: Damage to equipment, machines and peripheral components possible!
Setting the position lag monitoring parameters too high may result in damage to equipment, machines and peripheral components.
Position lag monitoring parameters
Kv factors (only with external encoder)
In the NC two proportional factors Kv can be set under Axis 1_Ctrl on the Parameter tab. First select the position controller Type with two P constants (with KA) under the NC Controller tab. The two P constants are for the Standstill range and for the Moving range (see Fig. Setting the proportional factor KV). The factors can be used to set the start-up torque and the braking torque to a different value than the drive torque. The threshold value can be set directly below (Position control: Velocity threshold V dyn) between 0.0 (0%) and 1.0 (100%). Fig. Velocity ramp with KV factor limit values shows a speed ramp with thresholds of 30%. The Kv factor for Standstill (t1 and t3) can be different than the Kv factor for Moving (t2). In this case the same factor was used, since for stepper motors this function is less crucial than for DC motors.
Speed ramp with KV factor limit values
Setting the proportional factor KV
Dead band for position errors
Microstepping can be used to target 200 x 64 = 12800 positions. Since the encoder can only scan 1024 x 4 = 4096 positions, positions between two encoder scan points may not be picked up correctly, in which case the terminal will control around this position. The dead band for position errors is a tolerance range within which the position is regarded as "reached" (Fig. Dead band for position errors).
Dead band for position errors
Setting the acceleration time
In order to pass through any resonances that may occur as quickly as possible, the ramps for the acceleration time and the deceleration time should be as steep as possible.
Setting the acceleration time


Basic principles for the Positioning Interface

Commissioning/Configuration [image] Integration in TwinCAT [image] Basic principles for the Positioning Interface
Basic principles for the Positioning Interface
The Positioning interface offers the user a possibility to implement travel commands directly on the terminal.
Additional information
•
Predefined PDO Assignment
•
Parameter set
•
Information and diagnostic data
•
States of the internal state machine
•
Standard sequence of a travel command
•
Start types
•
Modulo - general description
•
Examples of two travel commands with a dynamic change of the target position


Predefined PDO Assignment

Commissioning/Configuration [image] Integration in TwinCAT [image] Basic principles for the Positioning Interface [image] Predefined PDO Assignment
Predefined PDO Assignment
The "Predefined PDO Assignment" enables a simplified selection of the process data. Select the function "Positioning interface" or "Positioning interface compact" in the lower part of the Process data tab. As a result, all necessary PDOs are automatically activated and the unnecessary PDOs are deactivated.
Predefined PDO Assignment


Parameter set

Commissioning/Configuration [image] Integration in TwinCAT [image] Basic principles for the Positioning Interface [image] Parameter set
Parameter set
Two objects are at the user’s disposal in the CoE for the configuration – the "POS Settings" (Index 0x8020) and the "POS Features" (Index 0x8021).
Settings objects in the CoE
POS Settings: Velocity min.:
For reasons of performance when ramping down to the target position, the terminal needs a safety margin of 0.5%. That means that, depending on the maximum velocity reached and the configured deceleration, the time is calculated at which the deceleration ramp begins. In order to always reach the destination reliably, 0.5% is subtracted from the position determined. If the deceleration ramp has ended and the destination has not yet been reached, the terminal drives at the velocity “Velocity min.” to the destination. It must be configured in such a way that the motor is able to stop abruptly and without a step loss at this velocity.
Velocity max.:
The maximum velocity with which the motor drives during a travel command
"Speed range" (index 0x8012:05) [applies to EL70x1]
Velocity min./max. are standardized to the configured "Speed range" (Index 0x8012:05). This means that for a "Speed range" of 4000 full steps/second, for example, for a speed output of 100% (i.e. 4000 full steps/second) 10,000 should be entered under "Velocity max.", and 5,000 for 50% (i.e. 2000 full steps/second).
Acceleration pos.:
Acceleration time in the positive direction of rotation.
The 5 parameters for acceleration also refer to the set “Speed range” and are given in ms. With a setting of 1000, the terminal accelerates the motor from 0 to 100% in 1000 ms. At a speed of 50% the acceleration time is linearly reduced to half accordingly.
Acceleration neg.:
Acceleration time in the negative direction of rotation.
Deceleration pos.:
Deceleration time in the positive direction of rotation.
Deceleration neg.:
Deceleration time in the negative direction of rotation.
Emergency deceleration:
Emergency deceleration time (both directions of rotation). If “Emergency stop” is set in the appropriate PDO, the motor is stopped within this time.
Calibration position:
The current counter value is loaded with this value after calibration.
Calibration velocity (towards plc cam):
Velocity with which the motor travels towards the cam during calibration.
Calibration velocity (off plc cam):
Velocity with which the motor travels away from the cam during calibration.
Target window:
Target window of the travel distance control. "In-Target" is set if the motor comes to a stop within this target window.
In-Target timeout:
"In-Target" is not set if the motor is not within the target window after the expiry of the travel distance control after this set time. This condition can be recognized only by checking the falling edge of “Busy”.
Dead time compensation:
Compensation of the internal propagation delays. This parameter does not have to be changed with standard applications.
Modulo factor:
The “Modulo factor” is referred to for the calculation of the target position and the direction of rotation in the modulo operating modes. It refers to the controlled system.
Modulo tolerance window:
Tolerance window for the determination of the start condition of the modulo operating modes.
POS Features:
Start type:
The "Start type" specifies the type of calculation used to determine the target position (see below).
Time information:
The meaning of the "Actual drive time" displayed is configured by this parameter. At present this value cannot be changed, since there are no further selection options. The elapsed time of the travel command is displayed.
Invert calibration cam search direction:
In relation to a positive direction of rotation, the direction of the search for the calibration cam is configured here (travel towards the cam).
Invert sync impulse search direction:
In relation to a positive direction of rotation, the direction of the search is configured here in accordance with the HW sync pulse (travel away from the cam).


Information and diagnostic data

Commissioning/Configuration [image] Integration in TwinCAT [image] Basic principles for the Positioning Interface [image] Information and diagnostic data
Information and diagnostic data
Via the information and diagnostic data, the user can obtain a more exact statement about which error occurred during a travel command.
Diagnostic objects in the CoE
POS Info data:
Status word:
The "Status word" reflects the status bits used in Index 0xA020 in a data word, in order to be able to process them more simply in the PLC. The positions of the bits correspond to the number of the subindex-1.
Bit 0: Command rejected
Bit 1: Command aborded
Bit 2: Target overrun
State (drive controller):
The current status of the internal state machine is displayed here (see below).
POS Diag data:
Command rejected:
A dynamic change of the target position is not accepted each time by the terminal, since this is then not possible. The new command is rejected in this case and indicated by the setting of this bit.
These 3 diagnostic bits are transmitted synchronously to the controller by setting “Warning” in the PDO.
Command aborted:
The current travel command was prematurely aborted due to an internal error or by an "Emergency stop".
Target overrun:
In the case of a dynamic change of the target position, the change may take place at a relatively late point in time. The consequence of this may be that a change in the direction of rotation is necessary and that the new target position may be overrun. “Target overrun” is set if this occurs.


States of the internal state machine

Commissioning/Configuration [image] Integration in TwinCAT [image] Basic principles for the Positioning Interface [image] States of the internal state machine
States of the internal state machine
The state (drive controller) (Index 0x9020:03) provides information about the current state of the internal state machine. For diagnostic purposes this can be read out by the PLC for the propagation delay. The internal cycle works constantly with 250 µs. A connected PLC cycle is very probably slower (e.g. 1 ms). For this reason it may be the case that some states are not visible at all in the PLC, since these will sometimes run through only one internal cycle.
Name | ID | Description
INIT | 0x0000 | Initialization/preparation for the next travel command.
IDLE | 0x0001 | Wait for the next travel command.
START | 0x0010 | The new command is evaluated and the corresponding calculations are performed.
ACCEL | 0x0011 | Acceleration phase.
CONST | 0x0012 | Constant phase
DECEL | 0x0013 | Deceleration phase
EMCY | 0x0020 | An "Emergency stop" has been triggered.
STOP | 0x0021 | The motor has stopped.
CALI_START | 0x0100 | Start of a calibration command.
CALI_GO_CAM | 0x0110 | The motor is being driven towards the cam.
CALI_ON_CAM | 0x0111 | The cam has been reached.
CALI_GO_SYNC | 0x0120 | The motor is being driven in the direction of the HW sync pulse.
CALI_LEAVE_CAM | 0x0121 | The motor is being driven away from the cam.
CALI_STOP | 0x0130 | End of the calibration phase.
CALIBRATED | 0x0140 | The motor is calibrated.
NOT_CALIBRATED | 0x0141 | The motor is not calibrated.
PRE_TARGET | 0x1000 | The set position has been reached; the position controller "pulls" the motor further into the target; "In-Target timeout" is started here.
TARGET | 0x1001 | The motor has reached the target window within the timeout.
TARGET_RESTART | 0x1002 | A dynamic change of the target position is processed here.
END | 0x2000 | End of the positioning phase.
WARNING | 0x4000 | A warning state occurred during the travel command; this is processed here.
ERROR | 0x8000 | An error state occurred during the travel command; this is processed here.
UNDEFINED | 0xFFFF | Undefined state (can occur, for example, if the driver stage has no control voltage).
Table 1: States of the internal state machine


Standard sequence of a travel command

Commissioning/Configuration [image] Integration in TwinCAT [image] Basic principles for the Positioning Interface [image] Standard sequence of a travel command
Standard sequence of a travel command
The “normally” sequence of a travel command is shown in the following flow diagram.
Coarse distinction is made between these four stages:
Startup
Test the system and the ready status of the motor.
Start positioning
Write all variables and calculate the desired target position with the appropriate “Start type”. Subsequently, start the travel command.
Evaluate status
Monitor the terminal state and, if necessary, dynamically change the target position.
Error handling
In case of error, procure the necessary information from the CoE and evaluate it.
Flow diagram for a travel command


Start types

Commissioning/Configuration [image] Integration in TwinCAT [image] Basic principles for the Positioning Interface [image] Start types
Start types
The Positioning interface offers different types of positioning. The following table contains all commands supported; these are divided into 4 groups.
Name | Command | Group | Description
ABSOLUTE | 0x0001 | Standard | Absolute positioning to a specified target position
RELATIVE | 0x0002 |  | Relative positioning to a calculated target position; a specified position difference is added to the current position
ENDLESS_PLUS | 0x0003 |  | Endless travel in the positive direction of rotation (direct specification of a speed)
ENDLESS_MINUS | 0x0004 |  | Endless travel in the negative direction of rotation (direct specification of a speed)
ADDITIVE | 0x0006 |  | Additive positioning to a calculated target position; a specified position difference is added to the last target position
ABSOLUTE_CHANGE | 0x1001 | Standard Ext. | Dynamic change of the target position during a travel command to a new absolute position
RELATIVE_CHANGE | 0x1002 |  | Dynamic change of the target position during a travel command to a new relative position (the current changing position value is used here also)
ADDITIVE_CHANGE | 0x1006 |  | Dynamic change of the target position during a travel command to a new additive position (the last target position is used here)
MODULO_SHORT | 0x0105 | Modulo | Modulo positioning along the shortest path to the modulo position (positive or negative), calculated by the "Modulo factor" (Index 0x8020:0E)
MODULO_SHORT_EXT | 0x0115 |  | Modulo positioning along the shortest path to the modulo position; the "Modulo tolerance window" (Index 0x8020:0F) is ignored
MODULO_PLUS | 0x0205 |  | Modulo positioning in the positive direction of rotation to the calculated modulo position
MODULO_PLUS_EXT | 0x0215 |  | Modulo positioning in the positive direction of rotation to the calculated modulo position; the "Modulo tolerance window" is ignored
MODULO_MINUS | 0x0305 |  | Modulo positioning in the negative direction of rotation to the calculated modulo position
MODULO_MINUS_EXT | 0x0315 |  | Modulo positioning in the negative direction of rotation to the calculated modulo position; the "Modulo tolerance window" is ignored
MODULO_CURRENT | 0x0405 |  | Modulo positioning in the last direction of rotation to the calculated modulo position
MODULO_CURRENT_EXT | 0x0415 |  | Modulo positioning in the last direction of rotation to the calculated modulo position; the "Modulo tolerance window" is ignored
CALI_PLC_CAM | 0x6000 | Calibration | Start a calibration with cam (digital inputs)
CALI_HW_SYNC | 0x6100 |  | Start a calibration with cam and HW sync pulse (C-track)
SET_CALIBRATION | 0x6E00 |  | Manually set the terminal to "Calibrated"
SET_CALIBRATION_AUTO | 0x6E01 |  | Automatically set the terminal to "Calibrated" on the first rising edge on "Enable"
CLEAR_CALIBRATION | 0x6F00 |  | Manually delete the calibration
Table 2: Supported “Start types” of the “Positioning interface”
ABSOLUTE
The absolute positioning represents the simplest positioning case. A position B is specified and travelled to from the start point A.
Absolute positioning
RELATIVE
In relative positioning, the user specifies a position delta S, which is added to the current position A, producing the target position B.
Relative positioning
ENDLESS_PLUS / ENDLESS_MINUS
The two start types ENDLESS_PLUS and ENDLESS_MINUS offer the possibility in the Positioning Interface to specify a direct motor velocity in order to travel endlessly in the positive or negative direction with the specified accelerations.
Endless travel
ADDITIVE
For additive positioning, the position delta S specified by the user is added to the target position E used for the last travel command in order to calculate the target position B.
This kind of positioning resembles the relative positioning, but there is a difference. If the last travel command was completed successfully, the new target position is the same. If there was an error, however, be it that the motor entered a stall state or an Emergency stop was triggered, the current position is arbitrary and not foreseeable. The user now has the advantage that he can use the last target position for the calculation of the following target position.
Additive positioning
ABSOLUTE_CHANGE / RELATIVE_CHANGE / ADDITIVE_CHANGE
These three kinds of positioning are completely identical to those described above. The important difference thereby is that the user uses these commands during an active travel command in order to dynamically specify a new target position.
The same rules and conditions apply as to the “normal” start types. ABSOLUTE_CHANGE and ADDITIVE_CHANGE are unique in the calculation of the target position i.e. in absolute positioning an absolute position is specified and in additive positioning a position delta is added to the momentarily active target position.
Note
Caution when using the RELATIVE_CHANGE positioning
The change by means of RELATIVE_CHANGE must be used with caution, since the current position of the motor is also used here as the start position. Due to propagation delays in the system, the position indicated in the PDO never corresponds to the actual position of the motor! Therefore a difference to the desired target position always results in the calculation of the transferred position delta.
Time of the change of the target position
A change of the target position cannot take place at an arbitrary point in time. If the calculation of the output parameters shows that the new target position cannot be readily reached, the command is rejected by the terminal and the Command rejected bit is set. This is the case, for example, at standstill (since the terminal expects a standard positioning here) and in the acceleration phase (since at this point the braking time cannot be calculated yet).
CALI_PLC_CAM / CALI_HW_SYNC / SET_CALIBRATION / SET_CALIBRATION_AUTO / CLEAR_CALIBRATION:
The simplest calibration case is calibration by cam only (connected to one digital input).
Here, the motor travels in the 1st step with velocity 1 (Index 0x8020:09) in direction 1 (Index 0x8021:13) towards the cam. Subsequently, in the 2nd step, it travels with velocity 2 (Index 0x8020:0A) in direction 2 (Index 0x8021:14) away from the cam. After the In-Target timeout"(Index 0x8020:0C) has elapsed, the calibration position (Index 0x8020:08) is taken on by the terminal as the current position.
Note
Observe the switching hysteresis of the cam switch
With this simple calibration it must be noted that the position detection of the cam is only exact to a certain degree. The digital inputs are not interrupt-controlled and are "only" polled. The internal propagation delays may therefore result in a system-related position difference.
Calibration with cam
For a more precise calibration, an HW sync pulse (C-track) is used in addition to the cam. This calibration proceeds in exactly the same way as described above, up to the point at which the motor travels away from the cam. The travel is not stopped immediately; instead, the sync pulse is awaited. Subsequently, the In-Target timeout runs down again and the calibration position is taken on by the terminal as the current position.
Calibration with cam and C-track
If calibration by hardware is not possible due to the circumstances of the application, the user can also set the Calibrated bit manually or automatically. The manual setting or deletion takes place with the commands SET_CALIBRATION and CLEAR_CALIBRATION.
It is simpler, however, if the standard start types (Index 0x8021:01) are set to SET_CALIBRATION_AUTO. The Calibrated bit will now be set automatically by the first rising edge on Enable. The command is conceived only for this purpose; therefore, it does not make sense to use it via the synchronous data exchange.


Modulo - general description

Commissioning/Configuration [image] Integration in TwinCAT [image] Basic principles for the Positioning Interface [image] Modulo - general description
Modulo - general description
MODULO
The modulo position of the axis is a piece of additional information about the absolute axis position. Modulo positioning represents the required target position in a different way. Contrary to the standard types of positioning, the modulo positioning has several pitfalls, since the desired target position can be interpreted differently.
The modulo positioning refers in principle to the Modulo factor (Index 0x8020:0E), which can be set in the CoE. In the following examples, a rotary axis with a "Modulo factor" equivalent to 360 degrees is assumed.
The Modulo tolerance window (Index 0x8020:0F) defines a position window around the current modulo target position of the axis. The window width is twice the specified value (set position ± tolerance value). A detailed description of the tolerance window is provided below.
The positioning of an axis is always referenced to its current actual position. The actual position of an axis is normally the position moved to with the last travel command. Under certain circumstances (incorrect positioning due to the axis stalling, or a very coarse resolution of the connected encoder), however, a position not expected by the user may arise. If this possibility is not considered, subsequent positioning may lead to unexpected behavior.
Effect of the modulo tolerance window - modulo target position 0° in positive direction
Example
An axis is positioned to 0°, with the result that subsequently the actual position of the axis is exactly 0°. A further modulo travel command to 360° in positive direction results in a full turn, with the subsequent modulo position of the axis of once again being exactly 0°. If the axis comes to a stop somewhat in front of or behind the target position for mechanical reasons, the next travel command does not behave as one would expect. If the actual position lies slightly below 0° (see fig. Calibration with cam, below left), a new travel command to 0° in the positive direction leads only to a minimal movement. The deviation that arose beforehand is compensated and the position is subsequently exactly 0° once more. If the position lies slightly above 0°, however, the same travel command leads to a full revolution in order to reach the exact position of 0° again. This problem occurs if complete turns by 360° or multiples of 360° were initiated. For positioning to an angle that is significantly different from the current modulo position, the travel command is unambiguous.
In order to solve the problem, a "Modulo tolerance window" (Index 0x8020:0F) can be parameterized. This ensures that small deviations from the position that are within the window do not lead to different axis behavior. If, for example, a window of 1° is parameterized, in the case described above the axis will behave identically, as long the actual position is between 359° and 1°. If the position exceeds 0° by less than 1°, the axis is re-positioned in positive direction at a modulo start. In both cases, a target position of 0° therefore leads to minimum movement to exactly 0°. A target position of 360° leads to a full turn in both cases.
For values that are within the window range, the modulo tolerance window can therefore lead to movements against the specified direction. For small windows this is usually not a problem, because system deviations between set and actual position are compensated in both directions. This means that the tolerance window may also be used for axes that may only be moved in one direction due to their construction.
Modulo positioning by less than one turn
Modulo positioning from a starting position to a non-identical target position is unambiguous and requires no special consideration. A modulo target position in the range [0 ≤; position < 360] reaches the required target in less than one whole turn. No motion occurs if target position and starting position are identical. Target positions of more than 360° lead to one or more full turns before the axis travels to the required target position.
For a movement from 270° to 0°, a modulo target position of 0° (not 360°) should therefore be specified, because 360° is outside the basic range and would lead to an additional turn.
The modulo positioning distinguishes between three direction specifications: positive direction, negative direction and along the shortest path (MODULO_PLUS, MODULO_MINUS, MODULO_SHORT). For positioning along the shortest path, target positions of more than 360° are not sensible, because the movement towards the target is always direct. In contrast to positive or negative direction, it is therefore not possible to carry out several turns before the axis moves to the target.
Note
Only basic periods of less than 360° are permitted
For modulo positioning with start type "MODULO_SHORT", only modulo target positions within the basic period (e.g. less than 360°) are permitted, otherwise an error is returned.
Positioning without the modulo tolerance window
The "Modulo tolerance window" (Index 0x8020:0F) is always taken into account in the "normal" types of modulo positioning. However, this is less desirable in some situations. In order to eliminate this "disadvantage", the comparable start types "MODULO_SHORT_EXT", "MODULO_PLUS_EXT", "MODULO_MINUS_EXT" and "MODULO_CURRENT_EXT" can be used, which ignore the modulo tolerance window.
The following table shows examples of modulo positioning with less than one revolution.
Modulo start type | Absolute start position | Modulo target position | Relative travel path | Absolute end position | Modulo end position
MODULO_PLUS | 90° | 0° | 270° | 360° | 0°
MODULO_PLUS | 90° | 360° | 630° | 720° | 0°
MODULO_PLUS | 90° | 720° | 990° | 1080° | 0°
MODULO_MINUS | 90° | 0° | -90° | 0° | 0°
MODULO_MINUS | 90° | 360° | -450° | -360° | 0°
MODULO_MINUS | 90° | 720° | -810° | -720° | 0°
MODULO_SHORT | 90° | 0° | -90° | 0° | 0°
Modulo positioning with full turns
In principle, modulo positioning by one or full turns are no different than positioning to an angle that differs from the starting position. No motion occurs if target position and starting position are identical. For a full turn, 360° has to be added to the starting position. The behavior described in the example shows that special attention must be paid to positionings with whole revolutions. The following table shows positioning examples for a starting position of approximately 90°. The modulo tolerance window is set to 1° here. Special cases for which the starting position is outside this window are identified.
The following table shows examples of modulo positioning with whole revolutions
Modulo start type | Absolute start position | Modulo target position | Relative travel path | Absolute end position | Modulo end position | Note
MODULO_PLUS | 90.00° | 90.00° | 0.00° | 90.00° | 90.00° |
MODULO_PLUS | 90.90° | 90.00° | -0.90° | 90.00° | 90.00° |
MODULO_PLUS | 91.10° | 90.00° | 358.90° | 450.00° | 90.00° | outside TF
MODULO_PLUS | 89.10° | 90.00° | 0.90° | 90.00° | 90.00° |
MODULO_PLUS | 88.90° | 90.00° | 1.10° | 90.00° | 90.00° | outside TF
MODULO_PLUS | 90.00° | 450.00 | 360.00° | 450.00° | 90.00° |
MODULO_PLUS | 90.90° | 450.00° | 359.10° | 450.00° | 90.00° |
MODULO_PLUS | 91.10° | 450.00° | 718.90° | 810.00° | 90.00° | outside TF
MODULO_PLUS | 89.10° | 450.00° | 360.90° | 450.00° | 90.00° |
MODULO_PLUS | 88.90° | 450.00° | 361.10° | 450.00° | 90.00° | outside TF
MODULO_PLUS | 90.00° | 810.00 | 720.00° | 810.00° | 90.00° |
MODULO_PLUS | 90.90° | 810.00 | 719.10° | 810.00° | 90.00° |
MODULO_PLUS | 91.10° | 810.00 | 1078.90° | 1170.00° | 90.00° | outside TF
MODULO_PLUS | 89.10° | 810.00 | 720.90° | 810.00° | 90.00° |
MODULO_PLUS | 88.90° | 810.00 | 721.10° | 810.00° | 90.00° | outside TF
MODULO_MINUS | 90.00° | 90.00° | 0.00° | 90.00° | 90.00° |
MODULO_MINUS | 90.90° | 90.00° | -0.90° | 90.00° | 90.00° |
MODULO_MINUS | 91.10° | 90.00° | -1.10° | 90.00° | 90.00° | outside TF
MODULO_MINUS | 89.10° | 90.00° | 0.90° | 90.00° | 90.00° |
MODULO_MINUS | 88.90° | 90.00° | -358.90° | -270.00° | 90.00° | outside TF
MODULO_MINUS | 90.00° | 450.00° | -360.00° | -270.00° | 90.00° |
MODULO_MINUS | 90.90° | 450.00° | -360.90° | -270.00° | 90.00° |
MODULO_MINUS | 91.10° | 450.00° | -361.10° | -270.00° | 90.00° | outside TF
MODULO_MINUS | 89.10° | 450.00° | -359.10° | -270.00° | 90.00° |
MODULO_MINUS | 88.90° | 450.00° | -718.90° | -630.00° | 90.00° | outside TF
MODULO_MINUS | 90.00° | 810.00° | -720.00° | -630.00° | 90.00° |
MODULO_MINUS | 90.90° | 810.00° | -720.90° | -630.00° | 90.00° |
MODULO_MINUS | 91.10° | 810.00° | -721.10° | -630.00° | 90.00° | outside TF
MODULO_MINUS | 89.10° | 810.00° | -719.10° | -630.00° | 90.00° |
MODULO_MINUS | 88.90° | 810.00° | -1078.90° | -990.00° | 90.00° | outside TF


Examples of two travel commands with a dynamic change of the target position

Commissioning/Configuration [image] Integration in TwinCAT [image] Basic principles for the Positioning Interface [image] Examples of two travel commands with a dynamic change of the target position
Examples of two travel commands with a dynamic change of the target position
Without overrun of the target position
Time
POS Outputs
POS Inputs
Description
t1:
Execute = 1
Target position = 200000
Velocity = 2000
Start type = 0x0001
Acceleration = 1000
Deceleration = 1000
Busy = 1
Accelerate = 1
▪
Specification of the first parameter
▪
Start of the acceleration phase
t2:
Accelerate = 0
▪
End of the acceleration phase
t3:
Target position = 100000
Velocity = 1500
Start type = 0x1001
Acceleration = 2000
Deceleration = 2000
▪
Change of the parameters
▪
Activation by new start types
t4:
Decelerate = 1
▪
Start of the deceleration phase
t5:
Execute = 0
Busy = 0
In-Target = 1
Decelerate = 0
▪
End of the deceleration phase
▪
Motor is at the new target position
t6 - t9:
▪
Absolute travel back to the start position 0
Scope recording without overrunning the target position
The axis scaling refers only to the positions, not to the speed or the status bits.
With overrun of the target position
Time
POS Outputs
POS Inputs
Description
t1:
Execute = 1
Target position = 200000
Velocity = 5000
Start type = 0x0001
Acceleration = 3000
Deceleration = 5000
Busy = 1
Accelerate = 1
▪
Specification of the 1st parameter
▪
Start of the 1st acceleration phase
t2:
Accelerate = 0
▪
End of the 1st acceleration phase
t3:
Target position = 100000
Velocity = 1500
Start type = 0x1001
Acceleration = 1000
Deceleration = 2000
Warning = 1
Decelerate = 1
▪
Change of the parameters
▪
Activation by new start types
▪
Warning of overrunning the target position
▪
Start of the 1st deceleration phase
t4:
Accelerate = 1
Decelerate = 0
▪
End of the 1st deceleration phase
▪
Start of the 2nd acceleration phase in the opposite direction
t5:
Accelerate = 0
Decelerate = 1
▪
End of the 2nd acceleration phase
▪
Start of the 2nd deceleration phase
t6:
Execute = 0
Busy = 0
In-Target = 1
Decelerate = 0
▪
End of the 2nd deceleration phase
▪
Motor is at the new target position
t7 - t10:
▪
Absolute travel back to the start position 0
Scope recording with overrunning of the final target position
The axis scaling refers only to the positions, not to the speed or the status bits.


Application example

Commissioning/Configuration [image] Integration in TwinCAT [image] Application example
Application example
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Motor control with visualization
Sample program ( )
Used Master: TwinCAT 2.11 (for older versions the control loop has to be programmed manually; in this case it is already implemented in the NC).
This application example demonstrates movement of a motor to any position or in continuous mode with the aid of visualization. The velocity, the starting acceleration and the deceleration can be specified.
The sample program consists of 2 files (PLC file and System Manager file).
First open the PLC file and compile it so that you have the *.tpy file available that is required for the System Manager.
Please note that you may have to adjust the target platform in the PLC program (default: PC or CX 8x86). If required, you can select the right target platform in the Resources -> Controller configuration tab.
Selection of the target platform
Please note the following for the System Manager file:
▪
Start the System Manager in Config mode.
▪
Please ensure that the I/O configuration matches your actual configuration. In the sample program only one EL7041 is integrated. If further terminals are connected you have to add them or re-scan your configuration.
▪
You have to adjust the MAC address. To do this, click on your EtherCAT device, then select the Adapter tab and click on Search after the MAC address (see Fig. Selecting the MAC address). Select the right adapter.
Selecting the MAC address
▪
In the PLC configuration you have to adjust the path for the PLC program. Click on the appended PLC program and select the tab IEC1131 (see Fig. Changing the PLC path). Select Change and enter the correct path.
Changing the PLC path
▪
Under NC configuration an EL7041 is already linked to the NC. To change the link or add additional devices proceed as described under "Integration into the NC configuration".
The PLC program is configured as follows. The libraries TcMC.lib and TcNC.lib must be integrated (see Fig. Required libraries).
Required libraries
Once this is done, certain global variables are declared (see Fig. Global variables). The data types PLCTONC_AXLESTRUCT and NCTOPLC_AXLESTRUCT deal with the communication between the PLC and the NC.
Global variables
Once the global variables have been declared, programming can commence. Start with declaring local variables (see Fig. Local variables).
MC_Direction is an enumeration type that specifies the direction of movement for the MC_MoveVelocity function block, which in turn initiates continuous travel of the motor.
An axis reset is carried out with the MC_Reset function block. Absolute positioning is carried out with the MC_MoveAbsolute function block. The current axis position can be read with the MC_ActualPosition function block.
MC_Power enables the axis; MC_Stop is required for stopping the axis.
Local variables
The program code is as follows (see Fig. Program code):
Program code
The motor can then be operated with the aid of the following visualization (see Fig. Visualization).
Press Enable to enable the axis. In "Free run mode" you can now use the Left or Right buttons, and the motor will run with a speed defined under fbMoveVelocity_Axis_1 in the selected direction. In "Absolute mode" you can specify a Velocity, Acceleration, Deceleration and the Setpoint Position and initiate the motion with Start Job. If no values are entered for acceleration and deceleration the default value of the NC is used.
Visualization
Information on function blocks and data types
Further information on the function blocks and data types used can be found in the Beckhoff Information System.


Restoring the delivery state

Commissioning/Configuration [image] Integration in TwinCAT [image] Restoring the delivery state
Restoring the delivery state
To restore the delivery state for backup objects in ELxxxx terminals / EPxxxx- and EPPxxxx boxes, the CoE object Restore default parameters, SubIndex 001 can be selected in the TwinCAT System Manager (Config mode).
Selecting the Restore default parameters PDO
Double-click on SubIndex 001 to enter the Set Value dialog. Enter the value 1684107116 in field Dec or the value 0x64616F6C in field Hex and confirm with OK.
All backup objects are reset to the delivery state.
Entering a restore value in the Set Value dialog
Alternative restore value
In some older terminals / boxes the backup objects can be switched with an alternative restore value:
Decimal value: 1819238756
Hexadecimal value: 0x6C6F6164
An incorrect entry for the restore value has no effect.


CoE objects EP7041-0002, EP7041-1002, EP7041-2002

Commissioning/Configuration [image] CoE objects EP7041-0002, EP7041-1002, EP7041-2002
CoE objects EP7041-0002, EP7041-1002, EP7041-2002
Additional information
•
Object description and parameterization


Object description and parameterization

Commissioning/Configuration [image] CoE objects EP7041-0002, EP7041-1002, EP7041-2002 [image] Object description and parameterization
Object description and parameterization
Applies to EP7041-0002, EP7041-1002 and EP7041-2002.
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Parameterization via the CoE list (CAN over EtherCAT)
The EtherCAT device is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs).
Introduction
The CoE overview contains objects for different intended applications:
▪
Objects required for parameterization during commissioning
▪
Objects for indicating internal settings (may be fixed)
▪
Further profile-specific objects indicating inputs, outputs and status information
The following section first describes the objects required for normal operation, followed by a complete overview of missing objects.
Additional information
•
Objects for commissioning
•
Standardobjekte (0x1000 .. 0x1FFF)
•
Profile-specific objects (0x6000 .. 0xFFFF)


Objects for commissioning

Commissioning/Configuration [image] CoE objects EP7041-0002, EP7041-1002, EP7041-2002 [image] Object description and parameterization [image] Objects for commissioning
Objects for commissioning
Index 1011 Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default parameters | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" in the set value dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)
Index 8000 ENC Settings Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
8000:0 | ENC Settings Ch.1 | Maximum subindex | UINT8 | RO | 0x0F (15dec)
8000:08 | Disable filter | Deactivates the input filters. | BOOLEAN | RW | 0x00 (0dec)
8000:0A | Enable micro increments | The lower 8 bits of the counter value are extrapolated. | BOOLEAN | RW | 0x00 (0dec)
8000:0E | Reversion of rotation | Activates reversion of rotation of the encoder. | BOOLEAN | RW | 0x00 (0dec)
Index 8010 STM Motor Settings Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
8010:0 | STM Motor Settings Ch.1 | Maximum subindex | UINT8 | RO | 0x11 (17dec)
8010:01 | Maximal current | Maximum permanent motor coil current (unit: 1 mA) | UINT16 | RW | 0x1388 (5000dec)
8010:02 | Reduced current | Reduced coil current (reduced torque, unit: 1 mA) | UINT16 | RW | 0x09C4 (2500dec)
8010:03 | Nominal voltage | Nominal voltage (supply voltage) of the motor (unit: 1 mV) | UINT16 | RW | 0xC350 (50000dec)
8010:04 | Motor coil resistance | Internal resistance of a coil (unit: 0.01 ohm) | UINT16 | RW | 0x0064 (100dec)
8010:05 | Motor EMF | Motor countervoltage (unit: 1 mV / 1000 digit) | UINT16 | RW | 0x0000 (0dec)
8010:06 | Motor fullsteps | Motor full steps per revolution | UINT16 | RW | 0x00C8 (200dec)
8010:07 | Encoder increments (4-fold) | Encoder increments per revolution (quadruple evaluation) | UINT16 | RW | 0x0000 (0dec)
8010:09 | Start velocity | Maximum possible start velocity of the motor | UINT16 | RW | 0x0064 (100dec)
8010:10 | Drive on delay time | Switch-on delay of the driver stage (unit: ms) | UINT16 | RW | 0x0064 (100dec)
8010:11 | Drive off delay time | Switch-off delay of the driver stage (unit: ms) | UINT16 | RW | 0x0096 (150dec)
Index 8011 STM Controller Settings Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
8011:0 | STM Controller Settings Ch.1 | Maximum subindex | UINT8 | RO | 0x06 (6dec)
8011:01 | Kp factor (curr.) | Kp control factor (proportional component) for the current controller (unit: 0.001) | UINT16 | RW | 0x00C8 (200dec)
8011:02 | Ki factor (curr.) | Ki control factor (integral component) for the current controller (unit: 0.001) | UINT16 | RW | 0x0002 (2dec)
8011:03 | Inner window (curr.) | Inner window for the I component of the current controller (unit: 1%) | UINT8 | RW | 0x00 (0dec)
8011:05 | Outer window (curr.) | Outer window for the I component of the current controller (unit: 1%) | UINT8 | RW | 0x00 (0dec)
8011:06 | Filter cut off frequency (curr.) | Filter limit frequency of the current controller (low-pass, unit: 1 Hz) | UINT16 | RW | 0x0000 (0dec)
8011:07 | Ka factor (curr.) | Ka control factor (acceleration component) for the current controller (unit: 0.001) | UINT16 | RW | 0x0000 (0dec)
8011:08 | Kd factor (curr.) | Kd control factor (deceleration component) for the currentcontroller (unit: 0.001) | UINT16 | RW | 0x0064 (100dec)
Index 8012 STM Features Ch.1
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8012:0 | STM Features Ch.1 | Maximum subindex |  | UINT8 | RO | 0x36 (54dec)
8012:01 | Operation mode | Operation mode (currently only direct velocity is supported) |  | BIT4 | RW | 0x01 (1dec)
 |  | 0 | Automatic
 |  | 1 | Direct velocity
 |  | 2 | Velocity controller
 |  | 3 | Position controller
8012:05 | Speed range | Preselection of the speed range |  | BIT3 | RW | 0x01 (1dec)
 |  | 0 | 1000 full steps/second
 |  | 1 | 2000 full steps/second
 |  | 2 | 4000 full steps/second
 |  | 3 | 8000 full steps/second
 |  | 4 | 16000 full steps/second
 |  | 5 | 32000 full steps/second
8012:08 | Feedback type | Selection of the feedback system |  | BIT1 | RW | 0x01 (1dec)
 |  | 0 | External encoder
 |  | 1 | Internal counter
8012:09 | Invert motor polarity | Activates reversal of the motor rotation direction. |  | BOOLEAN | RW | 0x00 (0dec)
8012:11 | Select info data 1 | Select "Info data 1" (see 0x6010:11) |  | UINT8 | RW | 0x03 (3dec)
 |  | 0 | Status word
 |  | 1 | Motor voltage coil A (unit 1 mV)
 |  | 2 | Motor voltage coil B (unit 1 mV)
 |  | 3 | Motor current coil A (unit 1 mA)
 |  | 4 | Motor current coil B (unit 1 mA)
 |  | 5 | Duty cycle coil A (unit 1%)
 |  | 6 | Duty cycle coil B (unit 1%)
 |  | 7 | Current velocity (value range +/- 10000)
 |  | ... | reserved
 |  | 101 | Internal temperature of the driver card
 |  | ... | reserved
 |  | 103 | Control voltage
 |  | 104 | Motor supply voltage
 |  | ... | reserved
 |  | 150 | Drive – Status word
 |  | 151 | Drive - State
 |  | 152 | Drive – Position lag (low word)
 |  | 153 | Drive – Position lag (high word)
 |  | ... | reserved
 |  | 255 | reserved
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8012:19 | Select info data 2 | Selection "Info data 2" |  | UINT8 | RW | 0x04 (4dec)
 |  | 0 | Status word
 |  | 1 | Motor voltage coil A (unit 1 mV)
 |  | 2 | Motor voltage coil B (unit 1 mV)
 |  | 3 | Motor current coil A (unit 1 mA)
 |  | 4 | Motor current coil B (unit 1 mA)
 |  | 5 | Duty cycle coil A (unit 1%)
 |  | 6 | Duty cycle coil B (unit 1%)
 |  | 7 | Current velocity (value range +/- 10000)
 |  | ... | reserved
 |  | 101 | Internal temperature of the driver card
 |  | ... | reserved
 |  | 103 | Control voltage
 |  | 104 | Motor supply voltage
 |  | ... | reserved
 |  | 150 | Drive – Status word
 |  | 151 | Drive – State
 |  | 152 | Drive – Position lag (low word)
 |  | 153 | Drive – Position lag (high word)
 |  | ... | reserved
 |  | 255 | reserved
8012:30 | Invert digital input 1 | Inversion of digital input 1 |  | BOOLEAN | RW | 0x00 (0dec)
8012:31 | Invert digital input 2 | Inversion of digital input 2 |  | BOOLEAN | RW | 0x00 (0dec)
8012:32 | Function for input 1 | Selection of the function for input 1 |  | BIT4 | RW | 0x00 (0dec)
 |  | 0 | Normal input
 |  | 1 | Hardware Enable
 |  | 2 | Plc cam
 |  | 3 | Auto start
8012:36 | Function for input 2 | Selection of the function for input 2 |  | BIT4 | RW | 0x00 (0dec)
 |  | 0 | Normal input
 |  | 1 | Hardware Enable
 |  | 2 | Plc cam
 |  | 3 | Auto start
8012:3A | Function for output 1 | Selection of the function for output 1 |  | BIT4 | RW | 0x00 (0dec)
 |  | 0 | Normal output
 |  | 1 | Brake If the bit in 0x7010:01 is set, the output is switched with the delay time set in 0x8010:10 and 0x8010:11 of the driver stage.
Index 8013 STM Controller Settings 2 Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
8013:0 | STM Controller Settings 2 Ch.1 | Maximum subindex | UINT8 | RO | 0x06 (6dec)
8013:01 | Kp factor (velo.) | Kp control factor (proportional component) for the velocity controller (unit: 0.001) | UINT16 | RW | 0x03E8 (1000dec)
8013:02 | Ki factor (velo.) | Ki control factor (integral component) for the velocity controller (unit: 0.001) | UINT16 | RW | 0x0000 (0dec)
8013:03 | Inner window (velo.) | Inner window for the I component of the velocity controller (unit: 1%) | UINT8 | RW | 0x00 (0dec)
8013:05 | Outer window (velo.) | Outer window for the I component of the velocity controller (unit: 1%) | UINT8 | RW | 0x00 (0dec)
8013:06 | Filter cut off frequency (velo.) | Filter limit frequency of the velocity controller (low-pass, unit: 1 Hz) | UINT16 | RW | 0x0000 (0dec)
Index 8020 POS Settings Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
8020:0 | POS Settings Ch.1 | Maximum subindex | UINT8 | RO | 0x10(16dec)
8020:01 | Velocity min. | Minimum set velocity (range: 0-10000) | INT16 | RW | 0x0064 (100dec)
8020:02 | Velocity max. | Maximum set velocity (range: 0-10000) | INT16 | RW | 0x2710 (10000dec)
8020:03 | Acceleration pos. | Acceleration in positive direction of rotation (unit: 1 ms) | UINT16 | RW | 0x03E8 (1000dec)
8020:04 | Acceleration neg. | Acceleration in negative direction of rotation (unit: 1 ms) | UINT16 | RW | 0x03E8 (1000dec)
8020:05 | Deceleration pos. | Deceleration in positive direction of rotation (unit: 1 ms) | UINT16 | RW | 0x03E8 (1000dec)
8020:06 | Deceleration neg. | Deceleration in negative direction of rotation (unit: 1 ms) | UINT16 | RW | 0x03E8 (1000dec)
8020:07 | Emergency deceleration | Emergency deceleration (both directions of rotation, unit: 1 ms) | UINT16 | RW | 0x0064 (100dec)
8020:08 | Calibration position | Calibration position | UINT32 | RW | 0x00000000 (0dec)
8020:09 | Calibration velocity (towards plc cam) | Calibration velocity towards the cam (range: 0-10000) | INT16 | RW | 0x0064 (100dec)
8020:0A | Calibration Velocity (off plc cam) | Calibration velocity away from the cam (range: 0-10000) | INT16 | RW | 0x000A (10dec)
8020:0B | Target window | Target window | UINT16 | RW | 0x000A (10dec)
8020:0C | In-Target timeout | Timeout at target position (unit: 1 ms) | UINT16 | RW | 0x03E8 (1000dec)
8020:0D | Dead time compensation | Dead time compensation (unit: 1 µs) | INT16 | RW | 0x0032 (50dec)
8020:0E | Modulo factor | Modulo factor/position | UINT32 | RW | 0x00000000 (0dec)
8020:0F | Modulo tolerance window | Tolerance window for modulo positioning | UINT32 | RW | 0x00000000 (0dec)
8020:10 | Position lag max. | max. position lag | UINT16 | RW | 0x0000 (0dez)
Index 8021 POS Features Ch.1
Index | Name | Meaning | Data type | Flags | Default value
8021:0 | POS Features Ch.1 | Maximum subindex | UINT8 | RO | 0x16 (22dec)
8021:01 | Start type | permitted values: | UINT16 | RW | 0x0001 (1dec)
 |  | 0: Idle
 |  | 1: Absolute
 |  | 2: Relative
 |  | 3: Endless plus
 |  | 4: Endless minus
 |  | 6: Additive
 |  | 24832: Calibration (Hardware sync)
 |  | 24576: Calibration (Plc cam)
 |  | 28416: Calibration (Clear manual)
 |  | 28160: Calibration (Set manual)
 |  | 28161: Calibration (Set manual auto)
 |  | 1029: Modulo current
 |  | 773: Modulo minus
 |  | 517: Modulo plus
 |  | 261: Modulo short
8021:11 | Time information | permitted values: | BIT2 | RW | 0x00 (0dec)
 |  | 0: Elapsed time current drive time since start of the travel command
8021:13 | Invert calibration cam search direction | Inversion of the direction of rotation towards the cam | BOOLEAN | RW | 0x01 (1dec)
8021:14 | Invert sync impulse search direction | Inversion of the direction of rotation away from the cam | BOOLEAN | RW | 0x00 (0dec)
8021:15 | Emergency stop on position lag error | Triggers an emergency stop if the maximum following error is exceeded | BOOLEAN | RW | 0x00 (0dec)
8021:16 | Enhanced diag history | Provides detailed messages about the status of the positioning interface in the diag history | BOOLEAN | RW | 0x00 (0dec)
Index FB00 STM Command
Index (hex) | Name | Meaning |  | Data type | Flags | Default
FB00:0 | STM Command | Maximum subindex |  | UINT8 | RO | 0x03 (3dec)
FB00:01 | Request | Requesting a command |  | OCTET-STRING[2] | RW | {0}
 |  | 0x8000 | Software reset
FB00:02 | Status | Status of the command |  | UINT8 | RO | 0x00 (0dec)
 |  | 0 | No error, without return value
 |  | 1 | No error, with return value
 |  | 2 | With error, without return value
 |  | 3 | With error, with return value
 |  | ... | reserved
 |  | 255 | Command execution active
FB00:03 | Response | Return value of the executed command |  | OCTET-STRING[4] | RO | {0}


Standardobjekte (0x1000 .. 0x1FFF)

Commissioning/Configuration [image] CoE objects EP7041-0002, EP7041-1002, EP7041-2002 [image] Object description and parameterization [image] Standardobjekte (0x1000 .. 0x1FFF)
Standardobjekte (0x1000 .. 0x1FFF)
The standard objects have the same meaning for all EtherCAT slaves.
Index 1000 Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x00001389 (5001dec)
Index 1008 Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EP7041-0002
Index 1009 Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO | 00
Index 100A Software version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO | 01
Index 1018 Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x1B813052 (461451346dez)
1018:03 | Revision | Revision number of the EtherCAT slave; the low word (bit 0-15) indicates the special terminal number, the high word (bit 16-31) refers to the device description | UINT32 | RO | 0x00100000 (1048576dez)
1018:04 | Serial number | Serial number of the EtherCAT slave; the low byte (bit 0-7) of the low word contains the year of production, the high byte (bit 8-15) of the low word contains the week of production, the high word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | Information for standardized loading and saving of backup entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum across all backup entries of the EtherCAT slave | UINT32 | RO | 0x00000000 (0dec)
Index 10F3 Diagnosis History
Index (hex) | Name | Meaning | Data type | Flags | Default
10F3:0 | Diagnosis History | Maximum Subindex | UINT8 | RO | 0x37 (55dec)
10F3:01 | Maximum Messages | Maximum number of stored messages. A maximum of 50 messages can be stored. | UINT8 | RO | 0x00 (0dec)
10F3:02 | Newest Message | Subindex of the latest message | UINT8 | RO | 0x00 (0dec)
10F3:03 | Newest Acknowledged Message | Subindex of the last confirmed message | UINT8 | RW | 0x00 (0dec)
10F3:04 | New Messages Available | Indicates that a new message is available | BOOLEAN | RO | 0x00 (0dec)
10F3:05 | Flags | not used | UINT16 | RW | 0x0000 (0dec)
10F3:06 | Diagnosis Message 001 | Message 1 | OCTET-STRING[28] | RO | {0}
... | ... | ... | ... | ... | ...
10F3:37 | Diagnosis Message 050 | Message 50 | OCTET-STRING[28] | RO | {0}
Index 10F8 Actual Time Stamp
Index (hex) | Name | Meaning | Data type | Flags | Default
10F8:0 | Actual Time Stamp | Time stamp | UINT64 | RO |
Index 1400 ENC RxPDO-Par Control compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1400:0 | ENC RxPDO-Par Control compact | PDO Parameter RxPDO 1 | UINT8 | RO | 0x06 (6dec)
1400:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 1 | OCTET-STRING[6] | RO | 01 16 00 00 00 00
Index 1401 ENC RxPDO-Par Control
Index (hex) | Name | Meaning | Data type | Flags | Default
1401:0 | ENC RxPDO-Par Control | PDO Parameter RxPDO 2 | UINT8 | RO | 0x06 (6dec)
1401:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 2 | OCTET-STRING[6] | RO | 00 16 00 00 00 00
Index 1403 STM RxPDO-Par Position
Index (hex) | Name | Meaning | Data type | Flags | Default
1403:0 | STM RxPDO-Par Position | PDO Parameter RxPDO 4 | UINT8 | RO | 0x06 (6dec)
1403:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 4 | OCTET-STRING[6] | RO | 04 16 05 16 06 16
Index 1404 STM RxPDO-Par Velocity
Index (hex) | Name | Meaning | Data type | Flags | Default
1404:0 | STM RxPDO-Par Velocity | PDO Parameter RxPDO 5 | UINT8 | RO | 0x06 (6dec)
1404:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 5 | OCTET-STRING[6] | RO | 03 16 05 16 06 16
Index 1405 POS RxPDO-Par Control compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1405:0 | POS RxPDO-Par Control compact | PDO Parameter RxPDO 6 | UINT8 | RO | 0x06 (6dec)
1405:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 6 | OCTET-STRING[6] | RO | 03 16 04 16 06 16
Index 1406 POS RxPDO-Par Control
Index (hex) | Name | Meaning | Data type | Flags | Default
1406:0 | POS RxPDO-Par Control | PDO Parameter RxPDO 7 | UINT8 | RO | 0x06 (6dec)
1406:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 7 | OCTET-STRING[6] | RO | 03 16 04 16 05 16
Index 1407 POS RxPDO-Par Control 2
Index (hex) | Name | Meaning | Data type | Flags | Default
1407:0 | POS RxPDO-Par Control | PDO Parameter RxPDO 8 | UINT8 | RO | 0x06 (6dez)
1407:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 8 | OCTET-STRING[6] | RO | 03 16 04 16 05 16
Index 1600 ENC RxPDO-Map Control compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1600:0 | ENC RxPDO-Map Control compact | PDO Mapping RxPDO 1 | UINT8 | RO | 0x07 (7dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01, 1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:02, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7000:04, 1
1600:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1600:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1600:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 16
Index 1601 ENC RxPDO-Map Control
Index (hex) | Name | Meaning | Data type | Flags | Default
1601:0 | ENC RxPDO-Map Control | PDO Mapping RxPDO 2 | UINT8 | RO | 0x07 (7dec)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:02, 1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03, 1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7000:04, 1
1601:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1601:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1601:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 32
Index 1602 STM RxPDO-Map Control
Index (hex) | Name | Meaning | Data type | Flags | Default
1602:0 | STM RxPDO-Map Control | PDO Mapping RxPDO 3 | UINT8 | RO | 0x07 (7dec)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (STM Outputs Ch.1), entry 0x01 (Enable)) | UINT32 | RO | 0x7010:01, 1
1602:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (STM Outputs Ch.1), entry 0x02 (Reset)) | UINT32 | RO | 0x7010:02, 1
1602:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (STM Outputs Ch.1), entry 0x03 (Reduce torque)) | UINT32 | RO | 0x7010:03, 1
1602:04 | SubIndex 004 | 4. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1602:05 | SubIndex 005 | 5. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1602:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7010 (STM Outputs Ch.1), entry 0x0C (Digital output 1)) | UINT32 | RO | 0x7010:0C, 1
1602:07 | SubIndex 007 | 7. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
Index 1603 STM RxPDO-Map Position
Index (hex) | Name | Meaning | Data type | Flags | Default
1603:0 | STM RxPDO-Map Position | PDO Mapping RxPDO 4 | UINT8 | RO | 0x01 (1dec)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (STM Outputs Ch.1), entry 0x11 (Position)) | UINT32 | RO | 0x7010:11, 32
Index 1604 STM RxPDO-Map Velocity
Index (hex) | Name | Meaning | Data type | Flags | Default
1604:0 | STM RxPDO-Map Velocity | PDO Mapping RxPDO 5 | UINT8 | RO | 0x01 (1dec)
1604:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (STM Outputs Ch.1), entry 0x21 (Velocity)) | UINT32 | RO | 0x7010:21, 16
Index 1605 POS RxPDO-Map Control compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1605:0 | POS RxPDO-Map Control compact | PDO Mapping RxPDO 6 | UINT8 | RO | 0x05 (5dec)
1605:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x01 (Execute)) | UINT32 | RO | 0x7020:01, 1
1605:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x02 (Emergency stop)) | UINT32 | RO | 0x7020:02, 1
1605:03 | SubIndex 003 | 3. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
1605:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1605:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x11 (Target position)) | UINT32 | RO | 0x7020:11, 32
Index 1606 POS RxPDO-Map Control
Index (hex) | Name | Meaning | Data type | Flags | Default
1606:0 | POS RxPDO-Map Control | PDO Mapping RxPDO 7 | UINT8 | RO | 0x09 (9dec)
1606:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x01 (Execute)) | UINT32 | RO | 0x7020:01, 1
1606:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x02 (Emergency stop)) | UINT32 | RO | 0x7020:02, 1
1606:03 | SubIndex 003 | 3. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
1606:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1606:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x11 (Target position)) | UINT32 | RO | 0x7020:11, 32
1606:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x21 (Velocity)) | UINT32 | RO | 0x7020:21, 16
1606:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x22 (Start type)) | UINT32 | RO | 0x7020:22, 16
1606:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x23 (Acceleration)) | UINT32 | RO | 0x7020:23, 16
1606:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x24 (Deceleration)) | UINT32 | RO | 0x7020:24, 16
Index 1607 POS RxPDO-Map Control 2
Index (hex) | Name | Meaning | Data type | Flags | Default
1607:0 | POS RxPDO-Map Control 2 | PDO Mapping RxPDO 8 | UINT8 | RO | 0x09 (9dez)
1607:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x0000:00,2
1607:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7020 (POS Outputs 2 Ch.1), entry 0x03 (Enable auto start)) | UINT32 | RO | 0x7020:03, 1
1607:03 | SubIndex 003 | 3. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00,5
1607:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1607:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7021 (POS Outputs 2 Ch.1), entry 0x11 (Target position)) | UINT32 | RO | 0x7021:11, 32
1607:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7021 (POS Outputs 2 Ch.1), entry 0x21 (Velocity)) | UINT32 | RO | 0x7021:21, 16
1607:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7021 (POS Outputs 2 Ch.1), entry 0x22 (Start type)) | UINT32 | RO | 0x7021:22, 16
1607:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7021 (POS Outputs 2 Ch.1), entry 0x23 (Acceleration)) | UINT32 | RO | 0x7021:23, 16
1607:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7021 (POS Outputs 2 Ch.1), entry 0x24 (Deceleration)) | UINT32 | RO | 0x7021:24, 16
Index 1800 ENC TxPDO-Par Status compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1800:0 | ENC TxPDO-Par Status compact | PDO Parameter TxPDO 1 | UINT8 | RO | 0x06 (6dec)
1800:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 1 | OCTET-STRING[2] | RO | 01 1A
Index 1801 ENC TxPDO-Par Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1801:0 | ENC TxPDO-Par Status | PDO Parameter TxPDO 2 | UINT8 | RO | 0x06 (6dec)
1801:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 2 | OCTET-STRING[2] | RO | 00 1A
Index 1805 POS TxPDO-Par Status compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1805:0 | POS TxPDO-Par Status compact | PDO Parameter TxPDO 7 | UINT8 | RO | 0x06 (6dez)
1805:06 | Exclude TxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 7 | OCTET-STRING[2] | RO | 06 1A
Index 1806 POS TxPDO-Par Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1806:0 | POS TxPDO-Par Status | PDO Parameter TxPDO 8 | UINT8 | RO | 0x06 (6dez)
1806:06 | Exclude TxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 8 | OCTET-STRING[2] | RO | 05 1A
Index 1A00 ENC TxPDO-Map Status compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1A00:0 | ENC TxPDO-Map Status compact | PDO Mapping TxPDO 1 | UINT8 | RO | 0x11 (17dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A00:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6000:0D, 1
1A00:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A00:0E | SubIndex 014 | 14. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A00:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1800 (ENC TxPDO-Par Status compact), entry 0x09) | UINT32 | RO | 0x1800:09, 1
1A00:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 16
1A00:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 16
Index 1A01 ENC TxPDO-Map Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1A01:0 | ENC TxPDO-Map Status | PDO Mapping TxPDO 2 | UINT8 | RO | 0x11 (17dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A01:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6000:0D, 1
1A01:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A01:0E | SubIndex 014 | 14. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A01:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1801 (ENC TxPDO-Par Status), entry 0x09) | UINT32 | RO | 0x1801:09, 1
1A01:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
1A01:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 32
Index 1A02 ENC TxPDO-Map Timest. compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1A02:0 | ENC TxPDO-Map Timest. compact | PDO Mapping TxPDO 3 | UINT8 | RO | 0x01 (1dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x16 (Timestamp)) | UINT32 | RO | 0x6000:16, 32
Index 1A03 STM TxPDO-Map Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1A03:0 | STM TxPDO-Map Status | PDO Mapping TxPDO 4 | UINT8 | RO | 0x0E (14dec)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x01 (Ready to enable)) | UINT32 | RO | 0x6010:01, 1
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x02 (Ready)) | UINT32 | RO | 0x6010:02, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x03 (Warning)) | UINT32 | RO | 0x6010:03, 1
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x04 (Error)) | UINT32 | RO | 0x6010:04, 1
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x05 (Moving positive)) | UINT32 | RO | 0x6010:05, 1
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x06 (Moving negative)) | UINT32 | RO | 0x6010:06, 1
1A03:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x07 (Torque reduced)) | UINT32 | RO | 0x6010:07, 1
1A03:08 | SubIndex 008 | 8. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x6010:08, 1
1A03:09 | SubIndex 009 | 9. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1A03:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x0C (Digital input 1)) | UINT32 | RO | 0x6010:0C, 1
1A03:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x0D (Digital input 2)) | UINT32 | RO | 0x6010:0D, 1
1A03:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x6010:0E, 1
1A03:0D | SubIndex 013 | 13. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A03:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1803, entry 0x09) | UINT32 | RO | 0x6010:10, 1
Index 1A04 STM TxPDO-Map Synchron info data
Index (hex) | Name | Meaning | Data type | Flags | Default
1A04:0 | STM TxPDO-Map Synchron info data | PDO Mapping TxPDO 5 | UINT8 | RO | 0x02 (2dec)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x11 (Info data 1)) | UINT32 | RO | 0x6010:11, 16
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x12 (Info data 2)) | UINT32 | RO | 0x6010:12, 16
Index 1A05 POS TxPDO-Map Status compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1A05:0 | POS TxPDO-Map Status compact | PDO Mapping TxPDO 7 | UINT8 | RO | 0x09 (9dez)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x01 (Busy)) | UINT32 | RO | 0x6020:01, 1
1A05:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x02 (In-Target)) | UINT32 | RO | 0x6020:02, 1
1A05:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x03 (Warning)) | UINT32 | RO | 0x6020:03, 1
1A05:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x04 (Error)) | UINT32 | RO | 0x6020:04, 1
1A05:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x05 (Calibrated)) | UINT32 | RO | 0x6020:05, 1
1A05:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x06 (Accelerate)) | UINT32 | RO | 0x6020:06, 1
1A05:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x07 (Decelerate)) | UINT32 | RO | 0x6020:07, 1
1A05:08 | SubIndex 008 | 8. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A05:09 | SubIndex 009 | 9. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1A06 POS TxPDO-Map Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1A06:0 | POS TxPDO-Map Status compact | PDO Mapping TxPDO 7 | UINT8 | RO | 0x09 (9dez)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x01 (Busy)) | UINT32 | RO | 0x6020:01, 1
1A06:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x02 (In-Target)) | UINT32 | RO | 0x6020:02, 1
1A06:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x03 (Warning)) | UINT32 | RO | 0x6020:03, 1
1A06:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x04 (Error)) | UINT32 | RO | 0x6020:04, 1
1A06:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x05 (Calibrated)) | UINT32 | RO | 0x6020:05, 1
1A06:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x06 (Accelerate)) | UINT32 | RO | 0x6020:06, 1
1A06:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x07 (Decelerate)) | UINT32 | RO | 0x6020:07, 1
1A06:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x08 (Ready to execute)) | UINT32 | RO | 0x6020:08, 1
1A06:09 | SubIndex 009 | 9. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1A06:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x11 (Actual position)) | UINT32 | RO | 0x6020:11, 32
1A06:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x21 (Actual velocity)) | UINT32 | RO | 0x6020:21, 16
1A06:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x22 (Actual drive time)) | UINT32 | RO | 0x6020:22, 32
Index 1A07 STM TxPDO-Map Internal position
Index (hex) | Name | Meaning | Data type | Flags | Default
1A07:0 | POS TxPDO-Map Status | PDO Mapping TxPDO 8 | UINT8 | RO | 0x01 (1dez)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x14 (Internal position)) | UINT32 | RO | 0x6010:14, 32
Index 1A08 STM TxPDO-Map External position
Index (hex) | Name | Meaning | Data type | Flags | Default
1A08:0 | POS TxPDO-Map Status | PDO Mapping TxPDO 8 | UINT8 | RO | 0x01 (1dez)
1A08:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x115 (External position)) | UINT32 | RO | 0x6010:15, 32
Index 1A09 POS TxPDO-Map Actual position lag
Index (hex) | Name | Meaning | Data type | Flags | Default
1A09:0 | POS TxPDO-Map Status | PDO Mapping TxPDO 8 | UINT8 | RO | 0x01 (1dez)
1A09:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (STM Inputs Ch.1), entry 0x23 (Actual position lag)) | UINT32 | RO | 0x6020:23, 32
Index 1C00 Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x03 (3dez)
1C12:01 | Subindex 001 | 1. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1600 (5632dez)
1C12:02 | Subindex 002 | 2. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1602 (5634dez)
1C12:03 | Subindex 003 | 3. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1604 (5636dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x02 (2dez)
1C13:01 | Subindex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | Subindex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A03 (6659dez)
1C13:03 | Subindex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dez)
1C13:04 | Subindex 004 | 4. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dez)
1C13:05 | Subindex 005 | 5. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dez)
1C13:06 | Subindex 006 | 6. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dez)
1C13:07 | Subindex 007 | 7. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dez)
1C13:08 | Subindex 008 | 8. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dez)
Index 1C32 SM output parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C32:0
SM output parameter
Synchronization parameters for the outputs
UINT8
RO
0x20 (32dec)
1C32:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dec)
1C32:02
Cycle time
Cycle time (in ns):
▪
Free Run: Cycle time of the local timer
▪
Synchron with SM 2 Event: Master cycle time
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dec)
1C32:03
Shift time
Time between SYNC0 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0 = 1: free run is supported
▪
Bit 1 = 1: Synchronous with SM 2 event is supported
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 10: Output shift with SYNC1 event (only DC mode)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08)
UINT16
RO
0xC007 (49159dec)
1C32:05
Minimum cycle time
Minimum cycle time (in ns)
UINT32
RO
0x000249F0 (150000dec)
1C32:06
Calc and copy time
Minimum time between SYNC0 and SYNC1 event (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:08
Command
▪
0: Measurement of the local cycle time is stopped
▪
1: Measurement of the local cycle time is started
The entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 are updated with the maximum measured values.
For a subsequent measurement the measured values are reset
UINT16
RW
0x0000 (0dec)
1C32:09
Delay time
Time between SYNC1 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:0B
SM event missed counter
Number of missed SM events in OPERATIONAL (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:0C
Cycle exceeded counter
Number of occasions the cycle time was exceeded in OPERATIONAL (cycle was not completed in time or the next cycle began too early)
UINT16
RO
0x0000 (0dec)
1C32:0D
Shift too short counter
Number of occasions that the interval between SYNC0 and SYNC1 event was too short (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:20
Sync error
The synchronization was not correct in the last cycle (outputs were output too late; DC mode only)
BOOLEAN
RO
0x00 (0dec)
Index 1C33 SM input parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchronous with SM 3 Event (no outputs available)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchronous with SM 2 Event (outputs available)
UINT16
RW
0x0022 (34dec)
1C33:02
Cycle time
as 0x1C32:02
UINT32
RW
0x000F4240 (1000000dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: Synchronous with SM 2 Event is supported (outputs available)
▪
Bit 1: Synchronous with SM 3 Event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: Input shift through local event (outputs available)
▪
Bit 4-5 = 10: Input shift with SYNC1 event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08 or 0x1C33:08)
UINT16
RO
0xC007 (49159dec)
1C33:05
Minimum cycle time
as 0x1C32:05
UINT32
RO
0x000249F0 (150000dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:08
Command
as 0x1C32:08
UINT16
RW
0x0000 (0dec)
1C33:09
Delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:0B
SM event missed counter
as 0x1C32:11
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
as 0x1C32:12
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
as 0x1C32:13
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
as 0x1C32:32
BOOLEAN
RO
0x00 (0dec)


Profile-specific objects (0x6000 .. 0xFFFF)

Commissioning/Configuration [image] CoE objects EP7041-0002, EP7041-1002, EP7041-2002 [image] Object description and parameterization [image] Profile-specific objects (0x6000 .. 0xFFFF)
Profile-specific objects (0x6000 .. 0xFFFF)
The profile-specific objects have the same meaning for all EtherCAT slaves that support the profile 5001.
Index 6000 ENC Inputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
6000:0 | ENC Inputs Ch.1 | Maximum subindex | UINT8 | RO | 0x16 (22dec)
6000:01 | Latch C valid | The counter value was latched with the C track. | BOOLEAN | RO | 0x00 (0dec)
6000:02 | Latch extern valid | The counter value was stored via the external latch. | BOOLEAN | RO | 0x00 (0dec)
6000:03 | Set counter done | The counter was set. | BOOLEAN | RO | 0x00 (0dec)
6000:04 | Counter underflow | Counter underflow. | BOOLEAN | RO | 0x00 (0dec)
6000:05 | Counter overflow | Counter overflow. | BOOLEAN | RO | 0x00 (0dec)
6000:08 | Extrapolation stall | The extrapolated part of the counter is invalid | BOOLEAN | RO | 0x00 (0dec)
6000:09 | Status of input A | Status of the A-input. | BOOLEAN | RO | 0x00 (0dec)
6000:0A | Status of input B | Status of the B-input. | BOOLEAN | RO | 0x00 (0dec)
6000:0B | Status of input C | Status of the C-input. | BOOLEAN | RO | 0x00 (0dec)
6000:0D | Status of extern latch | Status of the ext. latch input. | BOOLEAN | RO | 0x00 (0dec)
6000:0E | Sync error | The Sync error bit is only required for DC mode. It indicates whether a synchronization error has occurred during the previous cycle. | BOOLEAN | RO | 0x00 (0dec)
6000:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
6000:11 | Counter value | The counter value. | UINT32 | RO | 0x00000000 (0dec)
6000:12 | Latch value | The latch value. | UINT32 | RO | 0x00000000 (0dec)
6000:16 | Timestamp | Time stamp of the last counter change. | UINT32 | RO | 0x00000000 (0dec)
Index 6010 STM Inputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
6010:0 | STM Inputs Ch.1 | Maximum subindex | UINT8 | RO | 0x12 (18dec)
6010:01 | Ready to enable | Driver stage is ready for enabling | BOOLEAN | RO | 0x00 (0dec)
6010:02 | Ready | Driver stage is ready for operation | BOOLEAN | RO | 0x00 (0dec)
6010:03 | Warning | A warning has occurred | BOOLEAN | RO | 0x00 (0dec)
6010:04 | Error | An error has occurred (see index 0xA010) | BOOLEAN | RO | 0x00 (0dec)
6010:05 | Moving positive | Motor turns in positive direction | BOOLEAN | RO | 0x00 (0dec)
6010:06 | Moving negative | Motor turns in negative direction | BOOLEAN | RO | 0x00 (0dec)
6010:07 | Torque reduced | Reduced torque is active | BOOLEAN | RO | 0x00 (0dec)
6010:0C | Digital input 1 | Digital input 1 | BOOLEAN | RO | 0x00 (0dec)
6010:0D | Digital input 2 | Digital input 2 | BOOLEAN | RO | 0x00 (0dec)
6010:0E | Sync error | The Sync error bit is only required for DC mode. It indicates whether a synchronization error has occurred during the previous cycle. | BOOLEAN | RO | 0x00 (0dec)
6010:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
6010:11 | Info data 1 | Synchronous information (selection via subindex 0x8012:11) | UINT16 | RO | 0x0000 (0dec)
6010:12 | Info data 2 | Synchronous information (selection via subindex 0x8012:19) | UINT16 | RO | 0x0000 (0dec)
6010:14 | Internal position | Internal microstep position | UINT32 | RO | 0x00000000 (0dez)
6010:15 | External position | Encoder position | UINT32 | RO | 0x00000000 (0dez)
Index 6020 POS Inputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
6020:0 | POS Inputs Ch.1 | Maximum subindex | UINT8 | RO | 0x22 (34dec)
6020:01 | Busy | A current travel command is active | BOOLEAN | RO | 0x00 (0dec)
6020:02 | In-Target | Motor has arrived at target | BOOLEAN | RO | 0x00 (0dec)
6020:03 | Warning | A warning has occurred | BOOLEAN | RO | 0x00 (0dec)
6020:04 | Error | an error has occurred | BOOLEAN | RO | 0x00 (0dec)
6020:05 | Calibrated | Motor is calibrated | BOOLEAN | RO | 0x00 (0dec)
6020:06 | Accelerate | Motor is in the acceleration phase | BOOLEAN | RO | 0x00 (0dec)
6020:07 | Decelerate | Motor is in the deceleration phase | BOOLEAN | RO | 0x00 (0dec)
6020:08 | Ready to execute |  | BOOLEAN | RO | 0x00 (0dec)
6020:11 | Actual position | Current target position of the travel command generator | UINT32 | RO | 0x00007FFF (32767dec)
6020:21 | Actual velocity | Current set velocity of the travel command generator | INT16 | RO | 0x0000 (0dec)
6020:22 | Actual drive time | Travel command time information (see subindex 0x8021:11) | UINT32 | RO | 0x00000000 (0dec)
6020:23 | Actual position lag |  | UINT32 | RO | 0x00000000 (0dec)
Index 7000 ENC Outputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
7000:0 | ENC Outputs Ch.1 | Maximum subindex | UINT8 | RO | 0x11 (17dec)
7000:01 | Enable latch C | Activate latching via the C-track. | BOOLEAN | RO | 0x00 (0dec)
7000:02 | Enable latch extern on positive edge | Activate external latch with positive edge. | BOOLEAN | RO | 0x00 (0dec)
7000:03 | Set counter | Set the counter value. | BOOLEAN | RO | 0x00 (0dec)
7000:04 | Enable latch extern on negative edge | Activate external latch with negative edge. | BOOLEAN | RO | 0x00 (0dec)
7000:11 | Set counter value | This is the counter value to be set via "Set counter". | UINT32 | RO | 0x00000000 (0dec)
Index 7010 STM Outputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
7010:0 | STM Outputs Ch.1 | Maximum subindex | UINT8 | RO | 0x21 (33dec)
7010:01 | Enable | activates the output stage (see subindex 0x8012:3A) | BOOLEAN | RO | 0x00 (0dec)
7010:02 | Reset | all errors that may have occurred are reset by setting this bit (rising edge) | BOOLEAN | RO | 0x00 (0dec)
7010:03 | Reduce torque | Activation of reduced torque (coil current) (see subindex 0x8010:02) | BOOLEAN | RO | 0x00 (0dec)
7010:0C | Digital output 1 | Signal at digital output 1 | BOOLEAN | RO | 0x00 (0dec)
7010:11 | Position | Set position | UINT32 | RO | 0x00000000 (0dec)
7010:21 | Velocity | Set velocity | INT16 | RO | 0x0000 (0dec)
Index 7020 POS Outputs Ch.1
Index (hex) | Name | Meaning |  |  |  | Data type | Flags | Default
7020:0 | POS Outputs Ch.1 | Maximum subindex |  |  |  | UINT8 | RO | 0x24 (36dec)
7020:01 | Execute | Start travel command (rising edge), or prematurely abort travel command (falling edge) |  |  |  | BOOLEAN | RO | 0x00 (0dec)
7020:02 | Emergency Stop | Prematurely abort travel command with an emergency ramp (rising edge) |  |  |  | BOOLEAN | RO | 0x00 (0dec)
7020:11 | Target position | Specification of the target position |  |  |  | UINT32 | RO | 0x00007FFF (32767dec)
7020:21 | Velocity | Specification of the maximum set velocity |  |  |  | INT16 | RO | 0x0000 (0dec)
7020:22 | Start type | Specification of the start types | 0x0000 | Idle | No travel command is being executed | UINT16 | RO | 0x0000 (0dec)
 |  |  | 0x0001 | Absolute | Absolute target position
 |  |  | 0x0002 | Relative | Target position relative to the start position
 |  |  | 0x0003 | Endless plus | Endless driving in positive direction of rotation
 |  |  | 0x0004 | Endless minus | Endless driving in negative direction of rotation
 |  |  | 0x0105 | Modulo short | Shortest distance to the next modulo position
 |  |  | 0x0115 | Modulo short extended | Shortest distance to the next modulo position (without modulo window)
 |  |  | 0x0205 | Modulo plus | Drive in positive direction of rotation to the next modulo position
 |  |  | 0x0215 | Modulo plus extended | Drive in positive direction of rotation to the next modulo position (without modulo window)
 |  |  | 0x0305 | Modulo minus | Drive in negative direction of rotation to the next modulo position
 |  |  | 0x0315 | Modulo minus extended | Drive in negative direction of rotation to the next modulo position (without modulo window)
 |  |  | 0x0405 | Modulo current | Drive in the last implemented direction of rotation to the next modulo position
 |  |  | 0x0415 | Modulo current extended | Drive in the last implemented direction of rotation to the next modulo position (without modulo window)
 |  |  | 0x0006 | Additive | New target position relative/additive to the last target position
 |  |  | 0x6000 | Calibration, Plc cam | Calibration with cam
 |  |  | 0x6100 | Calibration, Hw sync | Calibration with cam and C-track
 |  |  | 0x6E00 | Calibration, set manual | Set calibration manually
 |  |  | 0x6E01 | Calibration, set manual auto | Set calibration automatically
 |  |  | 0x6F00 | Calibration, clear manual | Clear calibration manually
7020:23 | Acceleration | Acceleration specification |  |  |  | UINT16 | RO | 0x0000 (0dec)
7020:24 | Deceleration | Deceleration specification |  |  |  | UINT16 | RO | 0x0000 (0dec)
Index 7021 POS Outputs 2 Ch.1 (part 1)
Index (hex) | Name | Meaning | Data type | Flags | Default value
7021:0 | POS Outputs Ch.1 | Maximum subindex | UINT8 | RO | 0x24 (36dec)
7021:03 | Enable auto start | Enable auto start | BOOLEAN | RO | 0x00 (0dec)
7021:11 | Target position | Specification of the target position | UINT32 | RO | 0x00000000 (0dec)
7021:21 | Velocity | Specification of the maximum set velocity | INT16 | RO | 0x0000 (0dec)
Index 7021 POS Outputs 2 Ch.1 (part 2)
Index (hex) | Name | Meaning | Data type | Flags | Default value
7021:22 | Start type
 | 0x0000 Idle: No travel command is being executed |  | UINT16 | RO | 0x0000 (0dec)
 | 0x0001 Absolute: Absolute target position |  | UINT16 | RO | 0x0000 (0dec)
 | 0x1001 Absolute (Change): Change during an active travel command |  | UINT16 | RO | 0x0000 (0dec)
 | 0x0002 Relative: Target position relative to the current position |  | UINT16 | RO | 0x0000 (0dec)
 | 0x1002 Relative (Change): Change during an active travel command |  | UINT16 | RO | 0x0000 (0dec)
 | 0x0003 Endless plus: Endless driving in positive direction of rotation |  | UINT16 | RO | 0x0000 (0dec)
 | 0x0004 Endless minus: Endless driving in negative direction of rotation |  | UINT16 | RO | 0x0000 (0dec)
 | 0x0105 Modulo short: Shortest distance to the next modulo position |  | UINT16 | RO | 0x0000 (0dec)
 | 0x0115 Modulo short extended: Shortest distance to the next modulo position (without modulo window) |  | UINT16 | RO | 0x0000 (0dec)
 | 0x0205 Modulo plus: Drive in positive direction of rotation to the next modulo position |  | UINT16 | RO | 0x0000 (0dec)
 | 0x0215 Modulo plus extended: Drive in positive direction of rotation to the next modulo position (without modulo window) |  | UINT16 | RO | 0x0000 (0dec)
 | 0x0305 Modulo minus: Drive in negative direction of rotation to the next modulo position |  | UINT16 | RO | 0x0000 (0dec)
 | 0x0315 Modulo minus extended: Drive in negative direction of rotation to the next modulo position (without modulo window) |  | UINT16 | RO | 0x0000 (0dec)
 | 0x0405 Modulo current: Drive in the last implemented direction of rotation to the next modulo position |  | UINT16 | RO | 0x0000 (0dec)
 | 0x0415 Modulo current extended: Drive in the last implemented direction of rotation to the next modulo position (without modulo window) |  | UINT16 | RO | 0x0000 (0dec)
 | 0x0006 Additive: New target position relative/additive to the last target position |  | UINT16 | RO | 0x0000 (0dec)
 | 0x1006 Additive (Change): Change during an active travel command |  | UINT16 | RO | 0x0000 (0dec)
 | 0x6000 Calibration, PLC cam: Calibration with cam |  | UINT16 | RO | 0x0000 (0dec)
 | 0x6100 Calibration, HW sync: Calibration with cam and C-track |  | UINT16 | RO | 0x0000 (0dec)
 | 0x6E00 Calibration, set manual: Set calibration manually |  | UINT16 | RO | 0x0000 (0dec)
 | 0x6E01 Calibration, set manual auto: Set automatic calibration, for "Enable = 1" |  | UINT16 | RO | 0x0000 (0dec)
 | 0x6F00 Calibration, clear manual: Clear calibration manually |  | UINT16 | RO | 0x0000 (0dec)
7021:23 | Acceleration | Acceleration specification | UINT16 | RO | 0x0000 (0dec)
7021:24 | Deceleration | Deceleration specification | UINT16 | RO | 0x0000 (0dec)
Index F081 Download revision
Index (hex) | Name | Meaning | Data type | Flags | Default
F081:0 | Download revision | Reserved | UINT8 | RO | 0x01 (1dec)
F081:01 | Revision number | Reserved | UINT32 | RW | 0x00000000 (0dec)
Index 9010 STM Info data Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
9010:0 | STM Info data Ch.1 | Maximum subindex | UINT8 | RO | 0x08 (8dec)
9010:01 | Status word | Status word (see index 0xA010) | UINT16 | RO | 0x0000 (0dec)
9010:02 | Motor coil voltage A | Motor voltage coil A (unit 1 mV) | UINT16 | RO | 0x0000 (0dec)
9010:03 | Motor coil voltage B | Motor voltage coil B (unit 1 mV) | UINT16 | RO | 0x0000 (0dec)
9010:04 | Motor coil current A | Motor current coil A (unit 1 mA) | INT16 | RO | 0x0000 (0dec)
9010:05 | Motor coil current B | Motor current coil B (unit 1 mA) | INT16 | RO | 0x0000 (0dec)
9010:06 | Duty cycle A | Duty cycle coil A (unit 1%) | INT8 | RO | 0x00 (0dec)
9010:07 | Duty cycle B | Duty cycle coil B (unit 1%) | INT8 | RO | 0x00 (0dec)
9010:08 | Motor velocity | Current velocity (value range +/- 10000) | INT16 | RO | 0x0000 (0dec)
Index 9020 POS Info data Ch.1
Index | Name | Meaning | Data type | Flags | Default value
9020:0 | POS Info data Ch.1 | Maximum subindex | UINT8 | RO | 0x04 (4dec)
9020:03 | State (drive controller) | permitted values: | UINT16 | RO | 0x0000 (0dec)
 |  | 0: Init
 |  | 1: Idle
 |  | 272: Go cam
 |  | 273: On cam
 |  | 16: Start
 |  | 17: Acceleration
 |  | 18: Constant
 |  | 19: Deceleration
 |  | 288: Go sync impulse
 |  | 289: Leave cam
 |  | 4096: Pre target
 |  | 4097: In target
 |  | 32: Emergency Stop
 |  | 33: Normal stop
 |  | 304: Calibration stop
 |  | 8192: Drive end
 |  | 8193: Wait for init
 |  | 320: Is calibrated
 |  | 321: Not calibrated
 |  | 16384: Drive warning
 |  | 32768: Error
 |  | 65535: Undefined
 |  | 256: Calibration start
9020:04 | Actual position lag | Current step error | INT32 | RO | 0x00000000 (0dec)
Index A010 STM Diag data Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
A010:0 | STM Diag data Ch.1 | Maximum subindex | UINT8 | RO | 0x11 (17dec)
A010:01 | Saturated | Driver stage operates with maximum duty cycle | BOOLEAN | RO | 0x00 (0dec)
A010:02 | Over temperature | Internal terminal temperature is higher than 80°C (see subindex 0xF80F:04) | BOOLEAN | RO | 0x00 (0dec)
A010:03 | Torque overload | Motor current is higher than the rated current | BOOLEAN | RO | 0x00 (0dec)
A010:04 | Under voltage | Motor supply voltage is 20% lower than the configured rated voltage (warning) or motor supply voltage is lower than 8 V (error, see 0xA010:09) | BOOLEAN | RO | 0x00 (0dec)
A010:05 | Over voltage | Motor supply voltage is 10% higher than the configured nominal voltage | BOOLEAN | RO | 0x00 (0dec)
A010:06 | Short circuit A | Short circuit in motor coil A | BOOLEAN | RO | 0x00 (0dec)
A010:07 | Short circuit B | Short circuit in motor coil B | BOOLEAN | RO | 0x00 (0dec)
A010:08 | No control power | Control voltage at the power contacts is less than 12 V | BOOLEAN | RO | 0x00 (0dec)
A010:09 | Misc error | Initialization of the terminal failed or supply voltage is lower than 8 V or internal temperature of the terminal is higher than 100°C (see Subindex 0xF80F:05) | BOOLEAN | RO | 0x00 (0dec)
A010:11 | Actual operation mode | Current operation mode (relevant for activated automatic mode, see 0x8012:01) | BIT4 | RO | 0x00 (0dec)
Index A020 POS Diag data Ch.1
Index | Name | Meaning | Data type | Flags | Default value
A020:0 | POS Diag data Ch.1 | Maximum subindex | UINT8 | RO | 0x06 (6dec)
A020:01 | Command rejected | Travel command was rejected | BOOLEAN | RO | 0x00 (0dec)
A020:02 | Command aborted | Travel command was aborted | BOOLEAN | RO | 0x00 (0dec)
A020:03 | Target overrun | Target position was overrun in the opposite direction | BOOLEAN | RO | 0x00 (0dec)
A020:04 | Target timeout | The target window was not reached within the in-target timeout | BOOLEAN | RO | 0x00 (0dec)
A020:05 | Position lag | The maximum following error was exceeded | BOOLEAN | RO | 0x00 (0dec)
A020:06 | Emergency Stop | An emergency stop was triggered (automatic or manual) | BOOLEAN | RO | 0x00 (0dec)
Index F000 Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0002 (2dec)
Index F008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module list
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list | Maximum subindex | UINT8 | RW | 0x02 (2dec)
F010:01 | SubIndex 001 | Profile number of the encoder interface | UINT32 | RW | 0x000001FF (511dec)
F010:02 | SubIndex 002 | Profile number of the stepper motor interface | UINT32 | RW | 0x000002BF (703dec)
Index F80F STM Vendor data
Index (hex) | Name | Meaning | Data type | Flags | Default
F80F:0 | STM Vendor data | Maximum subindex | UINT8 | RO | 0x08 (8dec)
F80F:01 | PWM Frequency | DC link frequency (unit: 1 Hz) | UINT16 | RW | 0x7530 (30000dec)
F80F:02 | Deadtime | Dead time for pulse width modulation | UINT16 | RW | 0x0102 (258dec)
F80F:03 | Deadtime space | Duty cycle limitation | UINT16 | RW | 0x0009 (9dec)
F80F:04 | Warning temperature | Threshold for temperature warning (unit: 1°C, see subindex 0xA010:02) | INT8 | RW | 0x50 (80dec)
F80F:05 | Switch off temperature | Switch-off temperature (unit: 1°C) | INT8 | RW | 0x64 (100dec)
F80F:06 | Analog trigger point | Trigger point for AD conversion | UINT16 | RW | 0x000A (10dec)
F80F:07 | Calibration offset A | Current measurement offset calibration for coil A (set by the manufacturer) | INT16 | RW | 0x0000 (0dec)
F80F:08 | Calibration offset B | Current measurement offset calibration for coil B (set by the manufacturer) | INT16 | RW | 0x0000 (0dec)
Index F900 STM Info data
Index (hex) | Name | Meaning | Data type | Flags | Default
F900:0 | STM Info data | Maximum subindex | UINT8 | RO | 0x06 (6dec)
F900:01 | Software version (driver) | Software version of the driver card | STRING | RO | {0}
F900:02 | Internal temperature | Internal terminal temperature (unit: 1℃) | INT8 | RO | 0x00 (0dec)
F900:04 | Control voltage | Control voltage (unit: 1 mV) | UINT16 | RO | 0x0000 (0dec)
F900:05 | Motor supply voltage | Motor supply voltage (unit: 1 mV) | UINT16 | RO | 0x0000 (0dec)
F900:06 | Cycle time | Measured cycle time (unit: 1 µs) | UINT16 | RO | 0x0000 (0dec)


CoE objects EP7041-3002, EP7041-3102

Commissioning/Configuration [image] CoE objects EP7041-3002, EP7041-3102
CoE objects EP7041-3002, EP7041-3102
Additional information
•
Object description and parameterization


Object description and parameterization

Commissioning/Configuration [image] CoE objects EP7041-3002, EP7041-3102 [image] Object description and parameterization
Object description and parameterization
Applies to EP7041-3002 and EP7041-3102
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Parameterization via the CoE list (CAN over EtherCAT)
The EtherCAT device is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs).
Introduction
The CoE overview contains objects for different intended applications:
▪
Objects required for parameterization during commissioning
▪
Objects for indicating internal settings (may be fixed)
▪
Further profile-specific objects indicating inputs, outputs and status information
The following section first describes the objects required for normal operation, followed by a complete overview of missing objects.
Additional information
•
Objects for commissioning
•
Standard objects (0x1000 .. 0x1FFF)
•
Profile-specific objects (0x6000 .. 0xFFFF)


Objects for commissioning

Commissioning/Configuration [image] CoE objects EP7041-3002, EP7041-3102 [image] Object description and parameterization [image] Objects for commissioning
Objects for commissioning
Index 1011 Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default parameters | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" in the set value dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)
Index 8000 ENC Settings Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
8000:0 | ENC Settings Ch.1 | Maximum subindex | UINT8 | RO | 0x0F (15dec)
8000:08 | Disable filter | Deactivates the input filters. | BOOLEAN | RW | 0x00 (0dec)
8000:0A | Enable micro increments | The lower 8 bits of the counter value are extrapolated. | BOOLEAN | RW | 0x00 (0dec)
8000:0E | Reversion of rotation | Activates reversion of rotation of the encoder. | BOOLEAN | RW | 0x00 (0dec)
Index 8010 STM Motor Settings Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
8010:0 | STM Motor Settings Ch.1 | Maximum subindex | UINT8 | RO | 0x11 (17dec)
8010:01 | Maximal current | Maximum permanent motor coil current (unit: 1 mA) | UINT16 | RW | 0x1388 (5000dec)
8010:02 | Reduced current | Reduced coil current (reduced torque, unit: 1 mA) | UINT16 | RW | 0x09C4 (2500dec)
8010:03 | Nominal voltage | Nominal voltage (supply voltage) of the motor (unit: 1 mV) | UINT16 | RW | 0xC350 (50000dec)
8010:06 | Motor fullsteps | Motor full steps per revolution | UINT16 | RW | 0x00C8 (200dec)
8010:07 | Encoder increments (4-fold) | Encoder increments per revolution (quadruple evaluation) | UINT16 | RW | 0x0000 (0dec)
8010:09 | Start velocity | Maximum possible start velocity of the motor | UINT16 | RW | 0x0000 (0dec)
8010:10 | Drive on delay time | Switch-on delay of the driver stage (unit: ms) | UINT16 | RW | 0x0064 (100dec)
8010:11 | Drive off delay time | Switch-off delay of the driver stage (unit: ms) | UINT16 | RW | 0x0096 (150dec)
Index 8012 STM Features Ch.1
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8012:0 | STM Features Ch.1 | Maximum subindex |  | UINT8 | RO | 0x45 (69dec)
8012:01 | Operation mode | Operation mode (currently only direct velocity is supported) |  | BIT4 | RW | 0x00 (0dec)
 |  | 0 | Automatic
 |  | 1 | Direct velocity
 |  | 2 | Velocity controller
 |  | 3 | Position controller
8012:05 | Speed range | Preselection of the speed range |  | BIT3 | RW | 0x01 (1dec)
 |  | 0 | 1000 full steps/second
 |  | 1 | 2000 full steps/second
 |  | 2 | 4000 full steps/second
 |  | 3 | 8000 full steps/second
 |  | 4 | 16000 full steps/second
 |  | 5 | 32000 full steps/second
8012:08 | Feedback type | Selection of the feedback system |  | BIT1 | RW | 0x01 (1dec)
 |  | 0 | External encoder
 |  | 1 | Internal counter
8012:09 | Invert motor polarity | Activates reversal of the motor rotation direction. |  | BOOLEAN | RW | 0x00 (0dec)
8012:11 | Select info data 1 | Select "Info data 1" (see 0x6010:11) |  | UINT8 | RW | 0x00 (0dec)
 |  | 0 | Status word
 |  | 1 | reserved
 |  | ... | ...
 |  | 6 | reserved
 |  | 7 | Current velocity (value range +/- 10000)
 |  | 8 | reserved
 |  | 9 | Status word 2
 |  | 10 | Motor: Load
 |  | 11 | Motor: "Smart Current"
 |  | 12 | reserved
 |  | ... | ...
 |  | 100 | reserved
 |  | 101 | Internal temperature of the driver card
 |  | ... | reserved
 |  | 103 | Control voltage
 |  | 104 | Motor supply: Voltage
 |  | ... | reserved
 |  | 106 | Motor supply: Current
 |  | 107 | reserved
 |  | ... | ...
 |  | 149 | reserved
 |  | 150 | Position interface - status word
 |  | 151 | Position interface - status of the internal state machine
 |  | 152 | Position interface – lag error (low word)
 |  | 153 | Position interface – lag error (high word)
 |  | 154 | reserved
 |  | ... | ...
 |  | 255 | reserved
Index 8012 STM Features Ch.1
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8012:19 | Select info data 2 | Selection "Info data 2" (see 0x8012:11) |  | UINT8 | RW | 0x09 (9dec)
8012:30 | Invert digital input 1 | Inversion of digital input 1 |  | BOOLEAN | RW | 0x00 (0dec)
8012:31 | Invert digital input 2 | Inversion of digital input 2 |  | BOOLEAN | RW | 0x00 (0dec)
8012:32 | Function for input 1 | Selection of the function for input 1 |  | BIT4 | RW | 0x00 (0dec)
 |  | 0 | Normal input
 |  | 1 | Hardware Enable
8012:36 | Function for input 2 | Selection of the function for input 2 |  | BIT4 | RW | 0x00 (0dec)
 |  | 0 | Normal input
 |  | 1 | Hardware Enable
8012:3A | Function for output 1 | Selection of the function for output 1 |  | BIT4 | RW | 0x00 (0dec)
 |  | 0 | Normal output
 |  | 1 | Brake If the bit in 0x7010:01 is set, the output is switched with the delay time set in 0x8010:10 and 0x8010:11 of the driver stage.
8012:45 | Microstepping | 0 | Full step | BIT4 | RW | 0x08 (8dec)
 |  | 1 | Half step
 |  | 2 | 1/4 micro-step
 |  | 3 | 1/8 micro-step
 |  | 4 | 1/16 micro-step
 |  | 5 | 1/32 micro-step
 |  | 6 | 1/64 micro-step
 |  | 7 | 1/128 micro-step
 |  | 8 | 1/256 micro-step
Index 8013 STM Controller Settings 2 Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
8013:0 | STM Controller Settings 2 Ch.1 | Maximum subindex | UINT8 | RO | 0x07 (7dec)
8013:01 | Kp factor (velo./pos.) | Kp control factor (proportional component) for the velocity controller (unit: 0.001) | UINT16 | RW | 0x03E8 (1000dec)
8013:02 | Ki factor (velo./pos.) | Ki control factor (integral component) for the velocity controller (unit: 0.001) | UINT16 | RW | 0x0000 (0dec)
8013:03 | Inner window (velo./pos.) | Inner window for the I component of the velocity controller (unit: 1%) | UINT8 | RW | 0x00 (0dec)
8013:05 | Outer window (velo./pos.) | Outer window for the I component of the velocity controller (unit: 1%) | UINT8 | RW | 0x00 (0dec)
8013:06 | Filter cut off frequency (velo./pos.) | Filter limit frequency of the velocity controller (low-pass, unit: 1 Hz) | UINT16 | RW | 0x0000 (0dec)
8013:07 | Ka factor (velo./pos.) | Ka control factor of the velocity/position controller | UINT16 | RW | 0x0000 (0dec)
Index 8014 STM Motor Features Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
8014:0 | STM Motor Features Ch.1 | Maximum subindex | UINT8 | RO | 0x31 (49dec)
8014:01 | Chopper: Mode |  | BIT2 | RW | 0x00 (0dec)
8014:03 | Chopper: Off time |  | BIT4 | RW | 0x05 (5dec)
8014:07 | Chopper: Comparator disabled |  | BOOLEAN | RW | 0x00 (0dec)
8014:08 | Chopper: Fast decay time |  | BIT4 | RW | 0x03 (3dec)
8014:0C | Chopper: Sine wave offset |  | BIT4 | RW | 0x03 (3dec)
8014:11 | Chopper: Hysteresis start value |  | BIT3 | RW | 0x02 (2dec)
8014:14 | Chopper: Hysteresis end value |  | BIT4 | RW | 0x06 (6dec)
8014:18 | Chopper: Hysteresis decrement time |  | BIT2 | RW | 0x00 (0dec)
8014:1A | Stall guard: Filter enable |  | BOOLEAN | RW | 0x01 (1dec)
8014:1B | Stall guard: Current up step width |  | BIT2 | RW | 0x00 (0dec)
8014:1D | Stall guard: Current down step speed |  | BIT2 | RW | 0x00 (0dec)
8014:1F | Stall guard: Minimum current |  | BIT1 | RW | 0x00 (0dec)
8014:21 | Stall guard: Minimum value |  | BIT4 | RW | 0x00 (0dec)
8014:25 | Stall guard: Hysteresis value |  | BIT4 | RW | 0x00 (0dec)
8014:31 | Stall guard: Threshold value |  | INT8 | RW | 0x01 (1dec)
Index 8020 POS Settings Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
8020:0 | POS Settings Ch.1 | Maximum subindex | UINT8 | RO | 0x0F (15dec)
8020:01 | Velocity min. | Minimum target velocity (range: 0 ... 10000) | INT16 | RW | 0x0064 (100dec)
8020:02 | Velocity max. | Maximum target velocity (range: 0 ... 10000) | INT16 | RW | 0x2710 (10000dec)
8020:03 | Acceleration pos. | Acceleration in positive direction of rotation (unit: 1 ms) | UINT16 | RW | 0x03E8 (1000dec)
8020:04 | Acceleration neg. | Acceleration in negative direction of rotation (unit: 1 ms) | UINT16 | RW | 0x03E8 (1000dec)
8020:05 | Deceleration pos. | Deceleration in positive direction of rotation (unit: 1 ms) | UINT16 | RW | 0x03E8 (1000dec)
8020:06 | Deceleration neg. | Deceleration in negative direction of rotation (unit: 1 ms) | UINT16 | RW | 0x03E8 (1000dec)
8020:07 | Emergency deceleration | Emergency deceleration (both directions of rotation, unit: 1 ms) | UINT16 | RW | 0x0064 (100dec)
8020:08 | Calibration position | Calibration position | UINT32 | RW | 0x00000000 (0dec)
8020:09 | Calibration velocity (towards plc cam) | Calibration velocity towards the cam (range: 0 ... 10000) | INT16 | RW | 0x0064 (100dec)
8020:0A | Calibration Velocity (off plc cam) | Calibration velocity away from the cam (range: 0 ... 10000) | INT16 | RW | 0x000A (10dec)
8020:0B | Target window | Target window | UINT16 | RW | 0x000A (10dec)
8020:0C | In-Target timeout | Timeout at target position (unit: 1 ms) | UINT16 | RW | 0x03E8 (1000dec)
8020:0D | Dead time compensation | Dead time compensation (unit: 1 µs) | INT16 | RW | 0x0032 (50dec)
8020:0E | Modulo factor | Modulo factor/position | UINT32 | RW | 0x00000000 (0dec)
8020:0F | Modulo tolerance window | Tolerance window for modulo positioning | UINT32 | RW | 0x00000000 (0dec)
Index 8021 POS Features Ch.1
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8021:0 | POS Features Ch.1 | Maximum subindex |  | UINT8 | RO | 0x14 (20dec)
8021:01 | Start type | Standard start type |  | UINT16 | RW | 0x0001 (1dec)
8021:11 | Time information | Time information in subindex 0x6pp0:22 ("Actual drive time") |  | BIT2 | RW | 0x00 (0dec)
 |  | 0 | Elapsed time: current drive time since start of the travel command
 |  | ... | reserved
8021:13 | Invert calibration cam search direction | Inversion of the direction of rotation towards the cam |  | BOOLEAN | RW | 0x01 (1dec)
8021:14 | Invert sync impulse search direction | Inversion of the direction of rotation away from the cam |  | BOOLEAN | RW | 0x00 (0dec)
Index FB00 STM Command
Index (hex) | Name | Meaning |  | Data type | Flags | Default
FB00:0 | STM Command | Maximum subindex |  | UINT8 | RO | 0x03 (3dec)
FB00:01 | Request | Requesting a command |  | OCTET-STRING[2] | RW | {0}
 |  | 0x8000 | Software reset
FB00:02 | Status | Status of the command |  | UINT8 | RO | 0x00 (0dec)
 |  | 0 | No error, without return value
 |  | 1 | No error, with return value
 |  | 2 | With error, without return value
 |  | 3 | With error, with return value
 |  | ... | reserved
 |  | 255 | Command execution active
FB00:03 | Response | Return value of the executed command (dependent on the command) |  | OCTET-STRING[4] | RO | {0}


Standard objects (0x1000 .. 0x1FFF)

Commissioning/Configuration [image] CoE objects EP7041-3002, EP7041-3102 [image] Object description and parameterization [image] Standard objects (0x1000 .. 0x1FFF)
Standard objects (0x1000 .. 0x1FFF)
The standard objects have the same meaning for all EtherCAT slaves.
Index 1000 Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x00001389 (5001dec)
Index 1008 Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EP7041-3002
Index 1009 Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO | 00
Index 100A Software version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO | 02
Index 1018 Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x1B814052 (461455442dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the low word (bit 0-15) indicates the special terminal number, the high word (bit 16-31) refers to the device description | UINT32 | RO | 0x00100BBA (1051578dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the low byte (bit 0-7) of the low word contains the year of production, the high byte (bit 8-15) of the low word contains the week of production, the high word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 Backup parameter handling
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | Information for standardized loading and saving of backup entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum across all backup entries of the EtherCAT slave | UINT32 | RO | 0x00000000 (0dec)
Index 10F3 Diagnosis History
Index (hex) | Name | Meaning | Data type | Flags | Default
10F3:0 | Diagnosis History | Maximum Subindex | UINT8 | RO | 0x37 (55dec)
10F3:01 | Maximum Messages | Maximum number of stored messages. A maximum of 50 messages can be stored. | UINT8 | RO | 0x00 (0dec)
10F3:02 | Newest Message | Subindex of the latest message | UINT8 | RO | 0x00 (0dec)
10F3:03 | Newest Acknowledged Message | Subindex of the last confirmed message | UINT8 | RW | 0x00 (0dec)
10F3:04 | New Messages Available | Indicates that a new message is available | BOOLEAN | RO | 0x00 (0dec)
10F3:05 | Flags | not used | UINT16 | RW | 0x0000 (0dec)
10F3:06 | Diagnosis Message 001 | Message 1 | OCTET-STRING[28] | RO | {0}
... | ... | ... | ... | ... | ...
10F3:37 | Diagnosis Message 050 | Message 50 | OCTET-STRING[28] | RO | {0}
Index 10F8 Actual Time Stamp
Index (hex) | Name | Meaning | Data type | Flags | Default
10F8:0 | Actual Time Stamp | Time stamp | UINT64 | RO |
Index 1400 ENC RxPDO-Par Control compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1400:0 | ENC RxPDO-Par Control compact | PDO Parameter RxPDO 1 | UINT8 | RO | 0x06 (6dec)
1400:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 1 | OCTET-STRING[6] | RO | 01 16 00 00 00 00
Index 1401 ENC RxPDO-Par Control
Index (hex) | Name | Meaning | Data type | Flags | Default
1401:0 | ENC RxPDO-Par Control | PDO Parameter RxPDO 2 | UINT8 | RO | 0x06 (6dec)
1401:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 2 | OCTET-STRING[6] | RO | 00 16 00 00 00 00
Index 1403 STM RxPDO-Par Position
Index (hex) | Name | Meaning | Data type | Flags | Default
1403:0 | STM RxPDO-Par Position | PDO Parameter RxPDO 4 | UINT8 | RO | 0x06 (6dec)
1403:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 4 | OCTET-STRING[6] | RO | 04 16 05 16 06 16
Index 1404 STM RxPDO-Par Velocity
Index (hex) | Name | Meaning | Data type | Flags | Default
1404:0 | STM RxPDO-Par Velocity | PDO Parameter RxPDO 5 | UINT8 | RO | 0x06 (6dec)
1404:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 5 | OCTET-STRING[6] | RO | 03 16 05 16 06 16
Index 1405 POS RxPDO-Par Control compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1405:0 | POS RxPDO-Par Control compact | PDO Parameter RxPDO 6 | UINT8 | RO | 0x06 (6dec)
1405:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 6 | OCTET-STRING[6] | RO | 03 16 04 16 06 16
Index 1406 POS RxPDO-Par Control
Index (hex) | Name | Meaning | Data type | Flags | Default
1406:0 | POS RxPDO-Par Control | PDO Parameter RxPDO 7 | UINT8 | RO | 0x06 (6dec)
1406:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 7 | OCTET-STRING[6] | RO | 03 16 04 16 05 16
Index 1407 POS RxPDO-Par Control 2
Index (hex) | Name | Meaning | Data type | Flags | Default
1407:0 | POS RxPDO-Par Control | PDO Parameter RxPDO 8 | UINT8 | RO | 0x06 (6dez)
1407:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 8 | OCTET-STRING[6] | RO | 03 16 04 16 05 16
Index 1600 ENC RxPDO-Map Control compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1600:0 | ENC RxPDO-Map Control compact | PDO Mapping RxPDO 1 | UINT8 | RO | 0x07 (7dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01, 1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:02, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7000:04, 1
1600:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1600:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1600:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 16
Index 1601 ENC RxPDO-Map Control
Index (hex) | Name | Meaning | Data type | Flags | Default
1601:0 | ENC RxPDO-Map Control | PDO Mapping RxPDO 2 | UINT8 | RO | 0x07 (7dec)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:02, 1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03, 1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7000:04, 1
1601:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1601:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1601:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 32
Index 1602 STM RxPDO-Map Control
Index (hex) | Name | Meaning | Data type | Flags | Default
1602:0 | STM RxPDO-Map Control | PDO Mapping RxPDO 3 | UINT8 | RO | 0x07 (7dec)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (STM Outputs Ch.1), entry 0x01 (Enable)) | UINT32 | RO | 0x7010:01, 1
1602:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (STM Outputs Ch.1), entry 0x02 (Reset)) | UINT32 | RO | 0x7010:02, 1
1602:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (STM Outputs Ch.1), entry 0x03 (Reduce torque)) | UINT32 | RO | 0x7010:03, 1
1602:04 | SubIndex 004 | 4. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1602:05 | SubIndex 005 | 5. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1602:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7010 (STM Outputs Ch.1), entry 0x0C (Digital output 1)) | UINT32 | RO | 0x7010:0C, 1
1602:07 | SubIndex 007 | 7. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
Index 1603 STM RxPDO-Map Position
Index (hex) | Name | Meaning | Data type | Flags | Default
1603:0 | STM RxPDO-Map Position | PDO Mapping RxPDO 4 | UINT8 | RO | 0x01 (1dec)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (STM Outputs Ch.1), entry 0x11 (Position)) | UINT32 | RO | 0x7010:11, 32
Index 1604 STM RxPDO-Map Velocity
Index (hex) | Name | Meaning | Data type | Flags | Default
1604:0 | STM RxPDO-Map Velocity | PDO Mapping RxPDO 5 | UINT8 | RO | 0x01 (1dec)
1604:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (STM Outputs Ch.1), entry 0x21 (Velocity)) | UINT32 | RO | 0x7010:21, 16
Index 1605 POS RxPDO-Map Control compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1605:0 | POS RxPDO-Map Control compact | PDO Mapping RxPDO 6 | UINT8 | RO | 0x05 (5dec)
1605:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x01 (Execute)) | UINT32 | RO | 0x7020:01, 1
1605:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x02 (Emergency stop)) | UINT32 | RO | 0x7020:02, 1
1605:03 | SubIndex 003 | 3. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
1605:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1605:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x11 (Target position)) | UINT32 | RO | 0x7020:11, 32
Index 1606 POS RxPDO-Map Control
Index (hex) | Name | Meaning | Data type | Flags | Default
1606:0 | POS RxPDO-Map Control | PDO Mapping RxPDO 7 | UINT8 | RO | 0x09 (9dec)
1606:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x01 (Execute)) | UINT32 | RO | 0x7020:01, 1
1606:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x02 (Emergency stop)) | UINT32 | RO | 0x7020:02, 1
1606:03 | SubIndex 003 | 3. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
1606:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1606:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x11 (Target position)) | UINT32 | RO | 0x7020:11, 32
1606:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x21 (Velocity)) | UINT32 | RO | 0x7020:21, 16
1606:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x22 (Start type)) | UINT32 | RO | 0x7020:22, 16
1606:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x23 (Acceleration)) | UINT32 | RO | 0x7020:23, 16
1606:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x24 (Deceleration)) | UINT32 | RO | 0x7020:24, 16
Index 1607 POS RxPDO-Map Control 2
Index (hex) | Name | Meaning | Data type | Flags | Default
1607:0 | POS RxPDO-Map Control 2 | PDO Mapping RxPDO 8 | UINT8 | RO | 0x09 (9dez)
1607:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x0000:00,2
1607:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7020 (POS Outputs 2 Ch.1), entry 0x03 (Enable auto start)) | UINT32 | RO | 0x7020:03, 1
1607:03 | SubIndex 003 | 3. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00,5
1607:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1607:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7021 (POS Outputs 2 Ch.1), entry 0x11 (Target position)) | UINT32 | RO | 0x7021:11, 32
1607:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7021 (POS Outputs 2 Ch.1), entry 0x21 (Velocity)) | UINT32 | RO | 0x7021:21, 16
1607:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7021 (POS Outputs 2 Ch.1), entry 0x22 (Start type)) | UINT32 | RO | 0x7021:22, 16
1607:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7021 (POS Outputs 2 Ch.1), entry 0x23 (Acceleration)) | UINT32 | RO | 0x7021:23, 16
1607:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7021 (POS Outputs 2 Ch.1), entry 0x24 (Deceleration)) | UINT32 | RO | 0x7021:24, 16
Index 1800 ENC TxPDO-Par Status compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1800:0 | ENC TxPDO-Par Status compact | PDO Parameter TxPDO 1 | UINT8 | RO | 0x06 (6dec)
1800:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 1 | OCTET-STRING[2] | RO | 01 1A
Index 1801 ENC TxPDO-Par Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1801:0 | ENC TxPDO-Par Status | PDO Parameter TxPDO 2 | UINT8 | RO | 0x06 (6dec)
1801:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 2 | OCTET-STRING[2] | RO | 00 1A
Index 1806 POS TxPDO-Par Status compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1806:0 | POS TxPDO-Par Status compact | PDO parameter TxPDO 7 | UINT8 | RO | 0x06 (6dec)
1806:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 7 | OCTET-STRING[2] | RO | 07 1A
Index 1807 POS TxPDO-Par Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1807:0 | POS TxPDO-Par Status | PDO parameter TxPDO 8 | UINT8 | RO | 0x06 (6dec)
1807:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 8 | OCTET-STRING[2] | RO | 06 1A
Index 1A00 ENC TxPDO-Map Status compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1A00:0 | ENC TxPDO-Map Status compact | PDO Mapping TxPDO 1 | UINT8 | RO | 0x11 (17dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A00:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6000:0D, 1
1A00:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A00:0E | SubIndex 014 | 14. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A00:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1800 (ENC TxPDO-Par Status compact), entry 0x09) | UINT32 | RO | 0x1800:09, 1
1A00:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 16
1A00:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 16
Index 1A01 ENC TxPDO-Map Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1A01:0 | ENC TxPDO-Map Status | PDO Mapping TxPDO 2 | UINT8 | RO | 0x11 (17dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A01:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6000:0D, 1
1A01:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A01:0E | SubIndex 014 | 14. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A01:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1801 (ENC TxPDO-Par Status), entry 0x09) | UINT32 | RO | 0x1801:09, 1
1A01:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
1A01:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 32
Index 1A02 ENC TxPDO-Map Timest. compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1A02:0 | ENC TxPDO-Map Timest. compact | PDO Mapping TxPDO 3 | UINT8 | RO | 0x01 (1dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x16 (Timestamp)) | UINT32 | RO | 0x6000:16, 32
Index 1A03 STM TxPDO-Map Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1A03:0 | STM TxPDO-Map Status | PDO Mapping TxPDO 4 | UINT8 | RO | 0x0E (14dec)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x01 (Ready to enable)) | UINT32 | RO | 0x6010:01, 1
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x02 (Ready)) | UINT32 | RO | 0x6010:02, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x03 (Warning)) | UINT32 | RO | 0x6010:03, 1
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x04 (Error)) | UINT32 | RO | 0x6010:04, 1
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x05 (Moving positive)) | UINT32 | RO | 0x6010:05, 1
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x06 (Moving negative)) | UINT32 | RO | 0x6010:06, 1
1A03:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x07 (Torque reduced)) | UINT32 | RO | 0x6010:07, 1
1A03:08 | SubIndex 008 | 8. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x6010:08, 1
1A03:09 | SubIndex 009 | 9. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1A03:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x0C (Digital input 1)) | UINT32 | RO | 0x6010:0C, 1
1A03:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x0D (Digital input 2)) | UINT32 | RO | 0x6010:0D, 1
1A03:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x6010:0E, 1
1A03:0D | SubIndex 013 | 13. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A03:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1803, entry 0x09) | UINT32 | RO | 0x6010:10, 1
Index 1A04 STM TxPDO-Map Synchron info data
Index (hex) | Name | Meaning | Data type | Flags | Default
1A04:0 | STM TxPDO-Map Synchron info data | PDO Mapping TxPDO 5 | UINT8 | RO | 0x02 (2dec)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x11 (Info data 1)) | UINT32 | RO | 0x6010:11, 16
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x12 (Info data 2)) | UINT32 | RO | 0x6010:12, 16
Index 1A05 STM TxPDO-Map Motor load
Index (hex) | Name | Meaning | Data type | Flags | Default
1A05:0 | STM TxPDO-Map Motor load | PDO Mapping TxPDO 6 | UINT8 | RO | 0x01 (1dec)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x01 (Busy)) | UINT32 | RO | 0x6010:13, 16
Index 1A06 POS TxPDO-Map Status compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1A06:0 | POS TxPDO-Map Status compact | PDO Mapping TxPDO 7 | UINT8 | RO | 0x09 (9dec)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x01 (Busy)) | UINT32 | RO | 0x6020:01, 1
1A06:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x02 (In-Target)) | UINT32 | RO | 0x6020:02, 1
1A06:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x03 (Warning)) | UINT32 | RO | 0x6020:03, 1
1A06:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x04 (Error)) | UINT32 | RO | 0x6020:04, 1
1A06:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x05 (Calibrated)) | UINT32 | RO | 0x6020:05, 1
1A06:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x06 (Accelerate)) | UINT32 | RO | 0x6020:06, 1
1A06:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x07 (Decelerate)) | UINT32 | RO | 0x6020:07, 1
1A06:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x08 (Ready to execute)) | UINT32 | RO | 0x6020:08, 1
1A06:09 | SubIndex 009 | 9. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1A07 POS TxPDO-Map Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1A07:0 | POS TxPDO-Map Status | PDO Mapping TxPDO 8 | UINT8 | RO | 0x0C (12dec)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x01 (Busy)) | UINT32 | RO | 0x6020:01, 1
1A07:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x02 (In-Target)) | UINT32 | RO | 0x6020:02, 1
1A07:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x03 (Warning)) | UINT32 | RO | 0x6020:03, 1
1A07:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x04 (Error)) | UINT32 | RO | 0x6020:04, 1
1A07:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x05 (Calibrated)) | UINT32 | RO | 0x6020:05, 1
1A07:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x06 (Accelerate)) | UINT32 | RO | 0x6020:06, 1
1A07:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x07 (Decelerate)) | UINT32 | RO | 0x6020:07, 1
1A07:08 | SubIndex 008 | 8. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A07:09 | SubIndex 009 | 9. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1A07:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x11 (Actual position)) | UINT32 | RO | 0x6020:11, 32
1A07:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x21 (Actual velocity)) | UINT32 | RO | 0x6020:21, 16
1A07:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x22 (Actual drive time)) | UINT32 | RO | 0x6020:22, 32
Index 1A08 STM TxPDO-Map Internal Position
Index (hex) | Name | Meaning | Data type | Flags | Default
1A08:0 | STM TxPDO-Map Internal Position | PDO Mapping TxPDO 9 | UINT8 | RO | 0x01 (1dec)
1A08:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (STM Inputs Ch. 1), entry 0x14 (Internal Position)) | UINT32 | RO | 0x6010:14, 32
Index 1A09 STM TxPDO-Map External Position
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A09:0 | STM TxPDO-Map External Position | PDO Mapping TxPDO 10 | UINT8 | RO | 0x01 (1dec)
1A09:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (STM Inputs Ch. 1), entry 0x15 (External Position)) | UINT32 | RO | 0x6010:15, 32
Index 1A0A POS TxPDO-Map Actual Position lag
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0A:0 | POS TxPDO-Map Actual Position lag | PDO Mapping TxPDO 11 | UINT8 | RO | 0x01 (1dec)
1A0A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (POS Inputs Ch. 1), entry 0x23 (Actual position lag)) | UINT32 | RO | 0x6020:23, 32
Index 1C00 Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x03 (3dez)
1C12:01 | Subindex 001 | 1. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1600 (5632dez)
1C12:02 | Subindex 002 | 2. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1602 (5634dez)
1C12:03 | Subindex 003 | 3. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1604 (5636dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x02 (2dec)
1C13:01 | Subindex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A03 (6659dec)
1C13:03 | Subindex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:04 | Subindex 004 | 4. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:05 | Subindex 005 | 5. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:06 | Subindex 006 | 6. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:07 | Subindex 007 | 7. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:08 | Subindex 008 | 8. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:09 | Subindex 009 | 9. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 1C32 SM output parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C32:0
SM output parameter
Synchronization parameters for the outputs
UINT8
RO
0x20 (32dec)
1C32:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dec)
1C32:02
Cycle time
Cycle time (in ns):
▪
Free Run: Cycle time of the local timer
▪
Synchron with SM 2 Event: Master cycle time
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dec)
1C32:03
Shift time
Time between SYNC0 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0 = 1: free run is supported
▪
Bit 1 = 1: Synchronous with SM 2 event is supported
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 10: Output shift with SYNC1 event (only DC mode)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08)
UINT16
RO
0xC007 (49159dec)
1C32:05
Minimum cycle time
Minimum cycle time (in ns)
UINT32
RO
0x0003D090 (250000dec)
1C32:06
Calc and copy time
Minimum time between SYNC0 and SYNC1 event (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:07
Minimum delay time
UINT32
RO
0x00000000 (0dec)
1C32:08
Command
▪
0: Measurement of the local cycle time is stopped
▪
1: Measurement of the local cycle time is started
The entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 are updated with the maximum measured values.
For a subsequent measurement the measured values are reset
UINT16
RW
0x0000 (0dec)
1C32:09
Maximum delay time
Time between SYNC1 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:0B
SM event missed counter
Number of missed SM events in OPERATIONAL (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:0C
Cycle exceeded counter
Number of occasions the cycle time was exceeded in OPERATIONAL (cycle was not completed in time or the next cycle began too early)
UINT16
RO
0x0000 (0dec)
1C32:0D
Shift too short counter
Number of occasions that the interval between SYNC0 and SYNC1 event was too short (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:20
Sync error
The synchronization was not correct in the last cycle (outputs were output too late; DC mode only)
BOOLEAN
RO
0x00 (0dec)
Index 1C33 SM input parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchronous with SM 3 Event (no outputs available)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchronous with SM 2 Event (outputs available)
UINT16
RW
0x0022 (34dec)
1C33:02
Cycle time
as 0x1C32:02
UINT32
RW
0x000F4240 (1000000dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: Synchronous with SM 2 Event is supported (outputs available)
▪
Bit 1: Synchronous with SM 3 Event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: Input shift through local event (outputs available)
▪
Bit 4-5 = 10: Input shift with SYNC1 event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08 or 0x1C33:08)
UINT16
RO
0xC007 (49159dec)
1C33:05
Minimum cycle time
as 0x1C32:05
UINT32
RO
0x0003D090 (250000dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:07
Minimum delay time
UINT32
RO
0x00000000 (0dec)
1C33:08
Command
as 0x1C32:08
UINT16
RW
0x0000 (0dec)
1C33:09
Maximum delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:0B
SM event missed counter
as 0x1C32:11
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
as 0x1C32:12
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
as 0x1C32:13
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
as 0x1C32:32
BOOLEAN
RO
0x00 (0dec)


Profile-specific objects (0x6000 .. 0xFFFF)

Commissioning/Configuration [image] CoE objects EP7041-3002, EP7041-3102 [image] Object description and parameterization [image] Profile-specific objects (0x6000 .. 0xFFFF)
Profile-specific objects (0x6000 .. 0xFFFF)
The profile-specific objects have the same meaning for all EtherCAT slaves that support the profile 5001.
Index 6000 ENC Inputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
6000:0 | ENC Inputs Ch.1 | Maximum subindex | UINT8 | RO | 0x16 (22dec)
6000:01 | Latch C valid | The counter value was latched with the C track. | BOOLEAN | RO | 0x00 (0dec)
6000:02 | Latch extern valid | The counter value was stored via the external latch. | BOOLEAN | RO | 0x00 (0dec)
6000:03 | Set counter done | The counter was set. | BOOLEAN | RO | 0x00 (0dec)
6000:04 | Counter underflow | Counter underflow. | BOOLEAN | RO | 0x00 (0dec)
6000:05 | Counter overflow | Counter overflow. | BOOLEAN | RO | 0x00 (0dec)
6000:08 | Extrapolation stall | The extrapolated part of the counter is invalid | BOOLEAN | RO | 0x00 (0dec)
6000:09 | Status of input A | Status of the A-input. | BOOLEAN | RO | 0x00 (0dec)
6000:0A | Status of input B | Status of the B-input. | BOOLEAN | RO | 0x00 (0dec)
6000:0B | Status of input C | Status of the C-input. | BOOLEAN | RO | 0x00 (0dec)
6000:0D | Status of extern latch | Status of the ext. latch input. | BOOLEAN | RO | 0x00 (0dec)
6000:0E | Sync error | The Sync error bit is only required for DC mode. It indicates whether a synchronization error has occurred during the previous cycle. | BOOLEAN | RO | 0x00 (0dec)
6000:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
6000:11 | Counter value | The counter value. | UINT32 | RO | 0x00000000 (0dec)
6000:12 | Latch value | The latch value. | UINT32 | RO | 0x00000000 (0dec)
6000:16 | Timestamp | Time stamp of the last counter change. | UINT32 | RO | 0x00000000 (0dec)
Index 6010 STM Inputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
6010:0 | STM Inputs Ch.1 | Maximum subindex | UINT8 | RO | 0x12 (18dec)
6010:01 | Ready to enable | Driver stage is ready for enabling | BOOLEAN | RO | 0x00 (0dec)
6010:02 | Ready | Driver stage is ready for operation | BOOLEAN | RO | 0x00 (0dec)
6010:03 | Warning | A warning has occurred | BOOLEAN | RO | 0x00 (0dec)
6010:04 | Error | An error has occurred (see index 0xA010) | BOOLEAN | RO | 0x00 (0dec)
6010:05 | Moving positive | Motor turns in positive direction | BOOLEAN | RO | 0x00 (0dec)
6010:06 | Moving negative | Motor turns in negative direction | BOOLEAN | RO | 0x00 (0dec)
6010:07 | Torque reduced | Reduced torque is active | BOOLEAN | RO | 0x00 (0dec)
6010:0C | Digital input 1 | Digital input 1 | BOOLEAN | RO | 0x00 (0dec)
6010:0D | Digital input 2 | Digital input 2 | BOOLEAN | RO | 0x00 (0dec)
6010:0E | Sync error | The Sync error bit is only required for DC mode. It indicates whether a synchronization error has occurred during the previous cycle. | BOOLEAN | RO | 0x00 (0dec)
6010:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
6010:11 | Info data 1 | Synchronous information (selection via subindex 0x8012:11) | UINT16 | RO | 0x0000 (0dec)
6010:12 | Info data 2 | Synchronous information (selection via subindex 0x8012:19) | UINT16 | RO | 0x0000 (0dec)
6010:14 | Internal position | Internal microstep position | UINT32 | RO | 0x00000000 (0dec)
1010:15 | External position | Encoder position | UINT32 | RO | 0x00000000 (0dec)
Index 6020 POS Inputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
6020:0 | POS Inputs Ch.1 | Maximum subindex | UINT8 | RO | 0x22 (34dec)
6020:01 | Busy | A current travel command is active | BOOLEAN | RO | 0x00 (0dec)
6020:02 | In-Target | Motor has arrived at target | BOOLEAN | RO | 0x00 (0dec)
6020:03 | Warning | A warning has occurred | BOOLEAN | RO | 0x00 (0dec)
6020:04 | Error | an error has occurred | BOOLEAN | RO | 0x00 (0dec)
6020:05 | Calibrated | Motor is calibrated | BOOLEAN | RO | 0x00 (0dec)
6020:06 | Accelerate | Motor is in the acceleration phase | BOOLEAN | RO | 0x00 (0dec)
6020:07 | Decelerate | Motor is in the deceleration phase | BOOLEAN | RO | 0x00 (0dec)
6020:08 | Ready to execute |  | BOOLEAN | RO | 0x00 (0dec)
6020:11 | Actual position | Current target position of the travel command generator | UINT32 | RO | 0x00007FFF (32767dec)
6020:21 | Actual velocity | Current set velocity of the travel command generator | INT16 | RO | 0x0000 (0dec)
6020:22 | Actual drive time | Travel command time information (see subindex 0x8021:11) | UINT32 | RO | 0x00000000 (0dec)
6020:23 | Actual position lag |  | UINT32 | RO | 0x00000000 (0dec)
Index 7000 ENC Outputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
7000:0 | ENC Outputs Ch.1 | Maximum subindex | UINT8 | RO | 0x11 (17dec)
7000:01 | Enable latch C | Activate latching via the C-track. | BOOLEAN | RO | 0x00 (0dec)
7000:02 | Enable latch extern on positive edge | Activate external latch with positive edge. | BOOLEAN | RO | 0x00 (0dec)
7000:03 | Set counter | Set the counter value. | BOOLEAN | RO | 0x00 (0dec)
7000:04 | Enable latch extern on negative edge | Activate external latch with negative edge. | BOOLEAN | RO | 0x00 (0dec)
7000:11 | Set counter value | This is the counter value to be set via "Set counter". | UINT32 | RO | 0x00000000 (0dec)
Index 7010 STM Outputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
7010:0 | STM Outputs Ch.1 | Maximum subindex | UINT8 | RO | 0x21 (33dec)
7010:01 | Enable | activates the output stage (see subindex 0x8012:3A) | BOOLEAN | RO | 0x00 (0dec)
7010:02 | Reset | all errors that may have occurred are reset by setting this bit (rising edge) | BOOLEAN | RO | 0x00 (0dec)
7010:03 | Reduce torque | Activation of reduced torque (coil current) (see subindex 0x8010:02) | BOOLEAN | RO | 0x00 (0dec)
7010:0C | Digital output 1 | Signal at digital output 1 | BOOLEAN | RO | 0x00 (0dec)
7010:11 | Position | Set position | UINT32 | RO | 0x00000000 (0dec)
7010:21 | Velocity | Set velocity | INT16 | RO | 0x0000 (0dec)
Index 7020 POS Outputs Ch.1
Index (hex) | Name | Meaning |  |  |  | Data type | Flags | Default
7020:0 | POS Outputs Ch.1 | Maximum subindex |  |  |  | UINT8 | RO | 0x24 (36dec)
7020:01 | Execute | Start travel command (rising edge), or prematurely abort travel command (falling edge) |  |  |  | BOOLEAN | RO | 0x00 (0dec)
7020:02 | Emergency Stop | Prematurely abort travel command with an emergency ramp (rising edge) |  |  |  | BOOLEAN | RO | 0x00 (0dec)
7020:11 | Target position | Specification of the target position |  |  |  | UINT32 | RO | 0x00007FFF (32767dec)
7020:21 | Velocity | Specification of the maximum set velocity |  |  |  | INT16 | RO | 0x0000 (0dec)
7020:22 | Start type | Specification of the start types | 0x0000 | Idle | No travel command is being executed | UINT16 | RO | 0x0000 (0dec)
 |  |  | 0x0001 | Absolute | Absolute target position
 |  |  | 0x0002 | Relative | Target position relative to the start position
 |  |  | 0x0003 | Endless plus | Endless driving in positive direction of rotation
 |  |  | 0x0004 | Endless minus | Endless driving in negative direction of rotation
 |  |  | 0x0105 | Modulo short | Shortest distance to the next modulo position
 |  |  | 0x0115 | Modulo short extended | Shortest distance to the next modulo position (without modulo window)
 |  |  | 0x0205 | Modulo plus | Drive in positive direction of rotation to the next modulo position
 |  |  | 0x0215 | Modulo plus extended | Drive in positive direction of rotation to the next modulo position (without modulo window)
 |  |  | 0x0305 | Modulo minus | Drive in negative direction of rotation to the next modulo position
 |  |  | 0x0315 | Modulo minus extended | Drive in negative direction of rotation to the next modulo position (without modulo window)
 |  |  | 0x0405 | Modulo current | Drive in the last implemented direction of rotation to the next modulo position
 |  |  | 0x0415 | Modulo current extended | Drive in the last implemented direction of rotation to the next modulo position (without modulo window)
 |  |  | 0x0006 | Additive | New target position relative/additive to the last target position
 |  |  | 0x6000 | Calibration, Plc cam | Calibration with cam
 |  |  | 0x6100 | Calibration, Hw sync | Calibration with cam and C-track
 |  |  | 0x6E00 | Calibration, set manual | Set calibration manually
 |  |  | 0x6E01 | Calibration, set manual auto | Set calibration automatically
 |  |  | 0x6F00 | Calibration, clear manual | Clear calibration manually
7020:23 | Acceleration | Acceleration specification |  |  |  | UINT16 | RO | 0x0000 (0dec)
7020:24 | Deceleration | Deceleration specification |  |  |  | UINT16 | RO | 0x0000 (0dec)
Index 7021 POS Outputs 2 Ch.1 (part 1)
Index (hex) | Name | Meaning | Data type | Flags | Default value
7021:0 | POS Outputs Ch.1 | Maximum subindex | UINT8 | RO | 0x24 (36dec)
7021:03 | Enable auto start | Enable auto start | BOOLEAN | RO | 0x00 (0dec)
7021:11 | Target position | Specification of the target position | UINT32 | RO | 0x00000000 (0dec)
7021:21 | Velocity | Specification of the maximum set velocity | INT16 | RO | 0x0000 (0dec)
Index 7021 POS Outputs 2 Ch.1 (part 2)
Index (hex) | Name | Meaning | Data type | Flags | Default value
7021:22 | Start type
 | 0x0000 Idle: No travel command is being executed |  | UINT16 | RO | 0x0000 (0dec)
 | 0x0001 Absolute: Absolute target position |  | UINT16 | RO | 0x0000 (0dec)
 | 0x1001 Absolute (Change): Change during an active travel command |  | UINT16 | RO | 0x0000 (0dec)
 | 0x0002 Relative: Target position relative to the current position |  | UINT16 | RO | 0x0000 (0dec)
 | 0x1002 Relative (Change): Change during an active travel command |  | UINT16 | RO | 0x0000 (0dec)
 | 0x0003 Endless plus: Endless driving in positive direction of rotation |  | UINT16 | RO | 0x0000 (0dec)
 | 0x0004 Endless minus: Endless driving in negative direction of rotation |  | UINT16 | RO | 0x0000 (0dec)
 | 0x0105 Modulo short: Shortest distance to the next modulo position |  | UINT16 | RO | 0x0000 (0dec)
 | 0x0115 Modulo short extended: Shortest distance to the next modulo position (without modulo window) |  | UINT16 | RO | 0x0000 (0dec)
 | 0x0205 Modulo plus: Drive in positive direction of rotation to the next modulo position |  | UINT16 | RO | 0x0000 (0dec)
 | 0x0215 Modulo plus extended: Drive in positive direction of rotation to the next modulo position (without modulo window) |  | UINT16 | RO | 0x0000 (0dec)
 | 0x0305 Modulo minus: Drive in negative direction of rotation to the next modulo position |  | UINT16 | RO | 0x0000 (0dec)
 | 0x0315 Modulo minus extended: Drive in negative direction of rotation to the next modulo position (without modulo window) |  | UINT16 | RO | 0x0000 (0dec)
 | 0x0405 Modulo current: Drive in the last implemented direction of rotation to the next modulo position |  | UINT16 | RO | 0x0000 (0dec)
 | 0x0415 Modulo current extended: Drive in the last implemented direction of rotation to the next modulo position (without modulo window) |  | UINT16 | RO | 0x0000 (0dec)
 | 0x0006 Additive: New target position relative/additive to the last target position |  | UINT16 | RO | 0x0000 (0dec)
 | 0x1006 Additive (Change): Change during an active travel command |  | UINT16 | RO | 0x0000 (0dec)
 | 0x6000 Calibration, PLC cam: Calibration with cam |  | UINT16 | RO | 0x0000 (0dec)
 | 0x6100 Calibration, HW sync: Calibration with cam and C-track |  | UINT16 | RO | 0x0000 (0dec)
 | 0x6E00 Calibration, set manual: Set calibration manually |  | UINT16 | RO | 0x0000 (0dec)
 | 0x6E01 Calibration, set manual auto: Set automatic calibration, for "Enable = 1" |  | UINT16 | RO | 0x0000 (0dec)
 | 0x6F00 Calibration, clear manual: Clear calibration manually |  | UINT16 | RO | 0x0000 (0dec)
7021:23 | Acceleration | Acceleration specification | UINT16 | RO | 0x0000 (0dec)
7021:24 | Deceleration | Deceleration specification | UINT16 | RO | 0x0000 (0dec)
Index 9010 STM Info data Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
9010:0 | STM Info data Ch.1 | Maximum subindex | UINT8 | RO | 0x0C (12dec)
9010:01 | Status word |  | UINT16 | RO | 0x0000 (0dec)
9010:08 | Motor velocity |  | INT16 | RO | 0x0000 (0dec)
9010:09 | Internal position |  | UINT32 | RO | 0x00000000 (0dec)
9010:0A | Status word 2 |  | UINT16 | RO | 0x0000 (0dec)
9010:0B | Motor load |  | UINT16 | RO | 0x0000 (0dec)
9010:0C | Motor smart current |  | UINT8 | RO | 0x00 (0dec)
Index 9020 POS Info data Ch.1
Index (hex) | Motor smart current>Name | Meaning | UINT8>Data type | RO>Flags | 0x00 (0dec)>default
9020:0 | POS Info data Ch.1 | Maximum subindex | UINT8 | RO | 0x03 (3dec)
9020:01 | Status word |  | UINT16 | RO | 0x0000 (0dec)
9020:03 | State (drive controller) |  | UINT16 | RO | 0xFFFF (65535dec)
Index 9020 POS Info data Ch.1
Index (hex) | State (drive controller)>Name | Meaning | UINT16>Data type | RO>Flags | 0xFFFF (65535dec)>default
9020:0 | POS Info data Ch.1 | Maximum subindex | UINT8 | RO | 0x03 (3dec)
9020:01 | Status word |  | UINT16 | RO | 0x0000 (0dec)
9020:03 | State (drive controller) |  | UINT16 | RO | 0xFFFF (65535dec)
Index A010 STM Diag data Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
A010:0 | STM Diag data Ch.1 | Maximum subindex | UINT8 | RO | 0x11 (17dec)
A010:01 | Saturated |  | BOOLEAN | RO | 0x00 (0dec)
A010:02 | Over temperature |  | BOOLEAN | RO | 0x00 (0dec)
A010:03 | Torque overload |  | BOOLEAN | RO | 0x00 (0dec)
A010:04 | Under voltage |  | BOOLEAN | RO | 0x00 (0dec)
A010:05 | Over voltage |  | BOOLEAN | RO | 0x00 (0dec)
A010:06 | Short circuit |  | BOOLEAN | RO | 0x00 (0dec)
A010:08 | No control power |  | BOOLEAN | RO | 0x00 (0dec)
A010:09 | Misc error |  | BOOLEAN | RO | 0x00 (0dec)
A010:0A | Configuration |  | BOOLEAN | RO | 0x00 (0dec)
A010:0B | Motor stall |  | BOOLEAN | RO | 0x00 (0dec)
A010:11 | Actual operation mode |  | BIT4 | RO | 0x00 (0dec)
Index A020 POS Diag data Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
A020:0 | POS Diag data Ch.1 | Maximum subindex | UINT8 | RO | 0x03 (3dec)
A020:01 | Command rejected |  | BOOLEAN | RO | 0x00 (0dec)
A020:02 | Command aborted |  | BOOLEAN | RO | 0x00 (0dec)
A020:03 | Target overrun |  | BOOLEAN | RO | 0x00 (0dec)
Index F000 Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | Maximum sub-index | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0003 (3dec)
Index F008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word |  | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module list
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list | Maximum subindex | UINT8 | RW | 0x03 (3dec)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x000001FF (511dec)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x000002BF (703dec)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x000002C0 (704dec)
Index F081 Download revision
Index (hex) | Name | Meaning | Data type | Flags | Default
F081:0 | Download revision | Reserved | UINT8 | RO | 0x01 (1dec)
F081:01 | Revision number | Reserved | UINT32 | RW | 0x00000000 (0dec)
Index F80F STM Vendor data
Index (hex) | Name | Meaning | Data type | Flags | Default
F80F:0 | STM Vendor data | Maximum subindex | UINT8 | RO | 0x09 (9dec)
F80F:04 | Warning temperature |  | INT8 | RW | 0x50 (80dec)
F80F:05 | Switch off temperature |  | INT8 | RW | 0x64 (100dec)
F80F:09 | Maximum current |  | UINT16 | RW | 0x1DC9 (7625dec)
Index F81F STM Vendor data 2
Index (hex) | Name | Meaning | Data type | Flags | Default
F81F:0 | STM Vendor data 2 | Maximum subindex | UINT8 | RO | 0x0A (10dec)
F81F:01 | Slope control low side |  | BIT2 | RW | 0x00 (0dec)
F81F:03 | Slope control high side |  | BIT2 | RW | 0x00 (0dec)
F81F:05 | Sense voltage |  | BIT1 | RW | 0x00 (0dec)
F81F:08 | Blank time |  | BIT2 | RW | 0x03 (3dec)
Index F900 STM Info data
Index (hex) | Name | Meaning | Data type | Flags | Default
F900:0 | STM Info data | Maximum subindex | UINT8 | RO | 0x07 (7dec)
F900:01 | Software version (driver) |  | STRING | RO |
F900:02 | Internal temperature |  | INT8 | RO | 0x00 (0dec)
F900:04 | Control voltage |  | UINT16 | RO | 0x0000 (0dec)
F900:05 | Motor supply voltage |  | UINT16 | RO | 0x0000 (0dec)
F900:06 | Cycle time |  | UINT16 | RO | 0x0000 (0dec)
F900:07 | Motor supply current |  | UINT16 | RO | 0x0000 (0dec)


Appendix

Appendix
Appendix
Additional information
•
General operating conditions
•
EtherCAT Box- / EtherCAT P Box - Accessories
•
Version identification of EtherCAT devices
•
Support and Service


General operating conditions

Appendix [image] General operating conditions
General operating conditions
Protection degrees (IP-Code)
The standard IEC 60529 (DIN EN 60529) defines the degrees of protection in different classes.
1. Number: dust protection and touch guard | Definition
0 | Non-protected
1 | Protected against access to hazardous parts with the back of a hand. Protected against solid foreign objects of Ø 50 mm
2 | Protected against access to hazardous parts with a finger. Protected against solid foreign objects of Ø 12.5 mm.
3 | Protected against access to hazardous parts with a tool. Protected against solid foreign objects Ø 2.5 mm.
4 | Protected against access to hazardous parts with a wire. Protected against solid foreign objects Ø 1 mm.
5 | Protected against access to hazardous parts with a wire. Dust-protected. Intrusion of dust is not totally prevented, but dust shall not penetrate in a quantity to interfere with satisfactory operation of the device or to impair safety.
6 | Protected against access to hazardous parts with a wire. Dust-tight. No intrusion of dust.
2. Number: water* protection | Definition
0 | Non-protected
1 | Protected against water drops
2 | Protected against water drops when enclosure tilted up to 15°.
3 | Protected against spraying water. Water sprayed at an angle up to 60° on either side of the vertical shall have no harmful effects.
4 | Protected against splashing water. Water splashed against the disclosure from any direction shall have no harmful effects
5 | Protected against water jets
6 | Protected against powerful water jets
7 | Protected against the effects of temporary immersion in water. Intrusion of water in quantities causing harmful effects shall not be possible when the enclosure is temporarily immersed in water for 30 min. in 1 m depth.
*) These protection classes define only protection against water!
Chemical Resistance
The Resistance relates to the Housing of the IP 67 modules and the used metal parts. In the table below you will find some typical resistance.
Character | Resistance
Steam | at temperatures >100°C: not resistant
Sodium base liquor (ph-Value > 12) | at room temperature: resistant > 40°C: not resistant
Acetic acid | not resistant
Argon (technical clean) | resistant
Key
▪
resistant: Lifetime several months
▪
non inherently resistant: Lifetime several weeks
▪
not resistant: Lifetime several hours resp. early decomposition


EtherCAT Box- / EtherCAT P Box - Accessories

Appendix [image] EtherCAT Box- / EtherCAT P Box - Accessories
EtherCAT Box- / EtherCAT P Box - Accessories
Fixing
Ordering information | Description
ZS5300-0001 | Mounting rail (500 mm x 129 mm)
Marking material, plugs
Ordering information | Description
ZS5000-0000 | Fieldbus Box set M8 (contact labels, plugs)
ZS5000-0002 | Fieldbus Box set M12 (contact labels, plugs)
ZS5000-0010 | plugs M8, IP67 (50 pieces)
ZS5000-0020 | plugs M12, IP67 (50 pieces)
ZS5100-0000 | marking labels, not printed, 4 stripes at 10 pieces
ZS5100-xxxx | printed marking labels, on request
Tools
Ordering information | Description
ZB8800 | torque wrench for M8 cables with knurl, incl. ratchet
ZB8800-0001 | M12 ratchet for torque wrench ZB8800
ZB8800-0002 | M8 ratchet (field assembly) for torque wrench ZB8800
ZB8801-0000 | torque wrench for hexagonal plugs, adjustable
ZB8801-0001 | torque cable key, M8/wrench size 9, for torque wrench ZB8801-0000
ZB8801-0002 | torque cable key, M12/wrench size 13, for torque wrench ZB8801-0000
ZB8801-0003 | torque cable key, M12 field assembly/wrench size 13, for torque wrench ZB8801-0000
Further accessories
Further accessories may be found at the price list for Beckhoff fieldbus components and at the internet under https://www.beckhoff.com


Version identification of EtherCAT devices

Appendix [image] Version identification of EtherCAT devices
Version identification of EtherCAT devices
Designation
A Beckhoff EtherCAT device has a 14-digit designation, made up of
▪
family key
▪
type
▪
version
▪
revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
Notes
▪
The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
▪
EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
▪
The order identifier is made up of
- family key (EL, EP, CU, ES, KL, CX, etc.)
- type (3314)
- version (-0000)
▪
The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
▪
The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Identification number
Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:
Production lot/batch number/serial number/date code/D number
The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02
Exceptions can occur in the IP67 area, where the following syntax can be used (see respective device documentation):
Syntax: D ww yy x y z u
D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB
Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1
Unique serial number/ID, ID number
In addition, in some series each individual module has its own unique serial number.
See also the further documentation in the area
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Terminals with factory calibration certificate and other measuring terminals
Examples of markings
EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
CU2016 switch with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
EP1258-00001 IP67 EtherCAT Box with batch number/ date code 22090101 and unique serial number 158102
EP1908-0002 IP67 EtherCAT Safety Box with batch number/ date code 071201FF and unique serial number 00346070
EL2904 IP20 safety terminal with batch number/ date code 50110302 and unique serial number 00331701
ELM3604-0002 terminal with unique ID number (QR code) 100001051 and serial/ batch number 44160201
Additional information
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Appendix [image] Version identification of EtherCAT devices [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com