EP622x-xxxx - IO-Link master in protection class IP67
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Modifications
2.0
▪
EP6224-0042 added
▪
EP6228-0042 added
▪
EP6228-3142 added
▪
Technical data updated
▪
Structure update
1.5
▪
IO-Link master principles updated
▪
IO-Link configuration updated
1.4
▪
Update Technical data
▪
EP6228-3132 added
1.3.0
▪
Update Technical data
▪
Safety instructions new layout
1.2.5
▪
EP6228-x0x2 – Technical Data updated
▪
Safety instructions adapted to IEC 82079-1.
1.2.4
▪
EP6228-3032 added
▪
EP6224-x022 – Technical Data updated
▪
EP6228-x0x2 – Technical Data updated
▪
EP6228-x0x2 – Introduction updated
▪
EP622x Module overview updated
▪
Conductor losses 7/8" added
▪
Configuration with TwinCAT - explanation of tab and IO-Link Master updated
1.2.3
▪
Object description and parameterization updated
▪
IO-Link principles updated
1.2.2
▪
Object description and parameterization updated
1.2.1
▪
Nut torques for connectors updated
1.2.0
▪
EP6228-0022 added
▪
Object description and parameterization updated
▪
EP6224-x022 Process image updated
▪
Images for IO-Link and sensor cable updated
1.1.0
▪
Power Connection updated
1.0.0
▪
First release
0.6
▪
Corrections
0.5
▪
First preliminary version
Firmware and hardware versions
This documentation refers to the firmware and hardware version that was applicable at the time the documentation was written.
The module features are continuously improved and developed further. Modules having earlier production statuses cannot have the same properties as modules with the latest status. However, existing properties are retained and are not changed, so that older modules can always be replaced with new ones.
The firmware and hardware version (delivery state) can be found in the batch number (D-number) printed on the side of the EtherCAT Box.
Syntax of the batch number (D number)
D: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with D No. 29 10 02 01:
29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01
Further information on this topic: Version identification of EtherCAT devices.


Product group: EtherCAT Box Modules

Product group: EtherCAT Box Modules
Product group: EtherCAT Box Modules
EtherCAT Box modules are I/O modules for industrial controllers.
They comply with protection class IP67 and are intended for use outside the control cabinet in wet, dirty or dusty industrial environments.
EtherCAT Box modules communicate with the controller via the EtherCAT fieldbus. They each have two connections for EtherCAT communication and for the power supply:
▪
Feed
▪
Downstream connection
This enables the cabling of EtherCAT Box modules in a line structure:
EtherCAT Box downstream connection example
EtherCAT Box modules: Example of cabling in a line structure


Product overview

Product overview
Product overview
Additional information
•
Module overview
•
IO-Link master with Class A ports
•
IO-Link master with Class B ports
•
IO-Link master with Class A ports and Class B ports


Module overview

Product overview [image] Module overview
Module overview
Product | Number of ports Class A | Number of ports Class B | Number of digital inputs | EtherCAT connections | Maximum supply current for IO-Link devices
 |  |  |  |  | L+ 1) per port | L+ 1) in total | P24 1) per port | P24 1) in total
EP6224-0042 | 4 | - | 8 | M12 | 1.4 A | 5.6 A | - | -
EP6224-2022 | 4 | - | - | M8 | 1.4 A | 4 A | - | -
EP6224-3022 | - | 4 | - | M8 | 1.4 A | 4 A | 2 A | 4 A
EP6228-0022 | 8 | - | - | M8 | 1.4 A | 4 A | - | -
EP6228-0042 | 8 | - | 8 2) | M12 | 1.4 A | 11.2 A | - | -
EP6228-3032 | - | 8 | - | M8 | 1.4 A | 11.2 A | 4 A 3) | 16 A
EP6228-3132 | 4 | 4 | 4 2) | M8 | 1.4 A | 11.2 A | 4 A 3) | 16 A
EP6228-3142 | 4 | 4 | 4 2) | M12 | 1.4 A | 11.2 A | 4 A 3) | 16 A
1) Supply voltages for IO-Link devices:
▪
L+ : Supply voltage for sensors and logic.
▪
P24: Supply voltage for actuators. Only available on Class B ports.
2) These digital inputs are located at pin 2 of the IO-Link Class A ports.
The digital inputs are independent of the IO-Link communication. You can therefore connect an IO-Link device and a digital sensor to the Class A ports, for example.
3) This value is also the maximum sum current for a port pair. The port pairs are specified in the Technical Data.


IO-Link master with Class A ports

Product overview [image] IO-Link master with Class A ports
IO-Link master with Class A ports
Additional information
•
EP6224-0042
•
EP6224-2022
•
EP6228-0022
•
EP6228-0042
•
Technical data


EP6224-0042

Product overview [image] IO-Link master with Class A ports [image] EP6224-0042
EP6224-0042
4-channel IO-Link master, Class A, 8 x digital input
The EP6224-0042 IO-Link module enables connection of up to four IO-Link devices, e.g. actuators, sensors or combinations of both. In addition, the EP6224-0042 offers further digital inputs on the four upper free M12 ports. A point-to-point connection is used between the box and the IO-Link device. The terminal is parameterized via the EtherCAT master. IO-Link is designed as an intelligent link between the fieldbus level and the sensor, wherein parameterization information can be exchanged bidirectionally via the IO-Link connection. The parameterization of the IO-Link devices with service data can be done from TwinCAT via ADS or very conveniently via the integrated IO-Link configuration tool.
In the standard setting, the four IO-Link channels of the EP6224-0042 operate as a 4-channel input module, 24 V DC, which communicates with connected IO-Link devices, parameterizes them and, if necessary, changes their operating mode. Each IO-Link port can optionally be used only as input or output.
Quick links
Technical data
Process image
Dimensions
Connections: Supply voltages
Connections: IO-Link
Connections: Digital inputs
Commissioning and configuration
Additional information
•
Process image EP6224-0042
•
Scope of supply EP6224-0042


Process image EP6224-0042

Product overview [image] IO-Link master with Class A ports [image] EP6224-0042 [image] Process image EP6224-0042
Process image EP6224-0042
EP6224-0042 Prozessabbild | TC3 IO-Link-Modul Symbol Module 1
 |  | See chapter Diagnosis
 | TC3 IO-Link-Modul Symbol Module 2
 |  | Status variables of the IO-Link ports
 | TC3 IO-Link-Modul Symbol Module 3 1)
 |  | Process data of the IO-Link device at port 1 (connector X03)
 | TC3 IO-Link-Modul Symbol Module 4 1)
 |  | Process data of the IO-Link device at port 2 (connector X04)
 | TC3 IO-Link-Modul Symbol Module 5 1)
 |  | Process data of the IO-Link device at port 3 (connector X07)
 | TC3 IO-Link-Modul Symbol Module 6 1)
 |  | Process data of the IO-Link device at port 4 (connector X08)
 | TC3 IO-Link-Modul Symbol Module 7
 |  | Digital inputs. The names of the input variables contain the name of the socket and the pin number of the corresponding input
Assignment of connectors, ports and process data
Connector | IO-Link port | Process data of the IO-Link device | Status variable of the IO-Link port
X03 | 1 | TC3 IO-Link-Modul Symbol Module 3 1) | TC3 InputVariable Symbol State Ch1
X04 | 2 | TC3 IO-Link-Modul Symbol Module 4 1) | TC3 InputVariable Symbol State Ch2
X07 | 3 | TC3 IO-Link-Modul Symbol Module 5 1) | TC3 InputVariable Symbol State Ch3
X08 | 4 | TC3 IO-Link-Modul Symbol Module 6 1) | TC3 InputVariable Symbol State Ch4
1) The modules "Module 3" to "Module 6" only exist in the process data if the corresponding IO-Link ports have been configured.


Scope of supply EP6224-0042

Product overview [image] IO-Link master with Class A ports [image] EP6224-0042 [image] Scope of supply EP6224-0042
Scope of supply EP6224-0042
Make sure that the following components are included in the scope of delivery:
▪
1x EP6224-0042 EtherCAT Box
▪
1x Protective cap for supply voltage output, 7/8”, black (pre-fitted)
▪
2x protective cap for EtherCAT socket, M12 (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


EP6224-2022

Product overview [image] IO-Link master with Class A ports [image] EP6224-2022
EP6224-2022
4-channel IO-Link master
The EP6224 IO-Link module enables connection of up to four IO-Link devices, e.g. actuators, sensors or combinations of both. A point-to-point connection is used between the terminal and the device. The terminal is parameterised via the EtherCAT master. IO-Link is designed as an intelligent link between the fieldbus level and the sensor, wherein parameterisation information can be exchanged bidirectionally via the IO-Link connection. The parameterisation of the IO-Link devices with service data can be done from TwinCAT via ADS or very conveniently via the integrated IO-Link configuration tool.
In the standard setting, the EP6224 functions as a 4-channel input terminal, 24 V DC, which communicates with connected IO-Link devices, parameterises them and, if necessary, changes their operating mode.
Quick links
Technical data
Process image
Dimensions
Connections: Supply voltages
Connections: IO-Link
Commissioning and configuration
Additional information
•
Process image EP6224-2022
•
Scope of supply EP6224-2022


Process image EP6224-2022

Product overview [image] IO-Link master with Class A ports [image] EP6224-2022 [image] Process image EP6224-2022
Process image EP6224-2022
EP6224-2022 Prozessabbild | TC3 IO-Link-Modul Symbol Module 1
 |  | See chapter Diagnosis
 | TC3 IO-Link-Modul Symbol Module 2
 |  | Status variables of the IO-Link ports
 | TC3 IO-Link-Modul Symbol Module 3 1)
 |  | Process data of the IO-Link device at port 1
 | TC3 IO-Link-Modul Symbol Module 4 1)
 |  | Process data of the IO-Link device at port 2
 | TC3 IO-Link-Modul Symbol Module 5 1)
 |  | Process data of the IO-Link device at port 3
 | TC3 IO-Link-Modul Symbol Module 6 1)
 |  | Process data of the IO-Link device at port 4
Assignment of connectors, ports and process data
Connector | IO-Link port | Process data of the IO-Link device | Status variable of the IO-Link port
1 | 1 | TC3 IO-Link-Modul Symbol Module 3 1) | TC3 InputVariable Symbol State Ch1
2 | 2 | TC3 IO-Link-Modul Symbol Module 4 1) | TC3 InputVariable Symbol State Ch2
3 | 3 | TC3 IO-Link-Modul Symbol Module 5 1) | TC3 InputVariable Symbol State Ch3
4 | 4 | TC3 IO-Link-Modul Symbol Module 6 1) | TC3 InputVariable Symbol State Ch4
1) The modules "Module 3" to "Module 6" only exist in the process data if the corresponding IO-Link ports have been configured.


Scope of supply EP6224-2022

Product overview [image] IO-Link master with Class A ports [image] EP6224-2022 [image] Scope of supply EP6224-2022
Scope of supply EP6224-2022
Make sure that the following components are included in the scope of delivery:
▪
1x EP6224-2022 EtherCAT Box
▪
1x protective cap for supply voltage input, M8, transparent (pre-assembled)
▪
1x protective cap for supply voltage output, M8, black (pre-assembled)
▪
2x protective cap for EtherCAT socket, M8, green (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


EP6228-0022

Product overview [image] IO-Link master with Class A ports [image] EP6228-0022
EP6228-0022
8-channel IO-Link master
The EP6228 IO-Link module enables connection of up to eight IO-Link devices, e.g. IO-Link box modules, actuators, sensors or combinations thereof. A point-to-point connection is used between the module and the device. The terminal is parameterised via the EtherCAT master. IO-Link is designed as an intelligent link between the fieldbus level and the sensor, wherein parameterisation information can be exchanged bidirectionally via the IO-Link connection. The parameterisation of the IO-Link devices with service data can be done from TwinCAT via ADS or very conveniently via the integrated IO-Link configuration tool.
In the standard setting, the EP6228 functions as a 8-channel input terminal, 24 V DC, which communicates with connected IO-Link devices, parameterises them and, if necessary, changes their operating mode.
Quick links
Technical data
Process image
Dimensions
Connections: Supply voltages
Connections: IO-Link
Commissioning and configuration
Additional information
•
Process image EP6228-0022
•
Scope of supply


Process image EP6228-0022

Product overview [image] IO-Link master with Class A ports [image] EP6228-0022 [image] Process image EP6228-0022
Process image EP6228-0022
EP6228-0022 Prozessabbild | TC3 IO-Link-Modul Symbol Module 1
 |  | See chapter Diagnostics
 | TC3 IO-Link-Modul Symbol Module 2
 |  | Status variables of the IO-Link ports
 | TC3 IO-Link-Modul Symbol Module 3 1)
 |  | Process data of the IO-Link device at port 1
 | TC3 IO-Link-Modul Symbol Module 4 1)
 |  | Process data of the IO-Link device at port 2
 | TC3 IO-Link-Modul Symbol Module 5 1)
 |  | Process data of the IO-Link device at port 3
 | TC3 IO-Link-Modul Symbol Module 6 1)
 |  | Process data of the IO-Link device at port 4
 | TC3 IO-Link-Modul Symbol Module 7 1)
 |  | Process data of the IO-Link device at port 5
 | TC3 IO-Link-Modul Symbol Module 8 1)
 |  | Process data of the IO-Link device at port 6
 | TC3 IO-Link-Modul Symbol Module 9 1)
 |  | Process data of the IO-Link device at port 7
 | TC3 IO-Link-Modul Symbol Module 10 1)
 |  | Process data of the IO-Link device at port 8
1) The modules "Module 3" to "Module 6" only exist in the process data if the corresponding IO-Link ports have been configured.
Assignment of connectors, ports and process data
Connector | IO-Link port | Process data of the IO-Link device | Status variable of the IO-Link port
1 | 1 | TC3 IO-Link-Modul Symbol Module 3 1) | TC3 InputVariable Symbol State Ch1
2 | 2 | TC3 IO-Link-Modul Symbol Module 4 1) | TC3 InputVariable Symbol State Ch2
3 | 3 | TC3 IO-Link-Modul Symbol Module 5 1) | TC3 InputVariable Symbol State Ch3
4 | 4 | TC3 IO-Link-Modul Symbol Module 6 1) | TC3 InputVariable Symbol State Ch4
5 | 5 | TC3 IO-Link-Modul Symbol Module 7 1) | TC3 InputVariable Symbol State Ch5
6 | 6 | TC3 IO-Link-Modul Symbol Module 8 1) | TC3 InputVariable Symbol State Ch6
7 | 7 | TC3 IO-Link-Modul Symbol Module 9 1) | TC3 InputVariable Symbol State Ch7
8 | 8 | TC3 IO-Link-Modul Symbol Module 10 1) | TC3 InputVariable Symbol State Ch8
1) The modules "Module 3" to "Module 10" only exist in the process data if the corresponding IO-Link ports have been configured.


Scope of supply

Product overview [image] IO-Link master with Class A ports [image] EP6228-0022 [image] Scope of supply
Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EP6228-0022 EtherCAT Box
▪
1x protective cap for supply voltage input, M8, transparent (pre-assembled)
▪
1x protective cap for supply voltage output, M8, black (pre-assembled)
▪
2x protective cap for EtherCAT socket, M8, green (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


EP6228-0042

Product overview [image] IO-Link master with Class A ports [image] EP6228-0042
EP6228-0042
8-channel IO-Link master, Class A, 8 x digital input
The EP6228-0042 IO-Link module enables connection of up to eight IO-Link devices, e.g. IO-Link box modules, actuators, sensors or combinations thereof. In addition, the EP6228-0042 offers additional digital inputs on the four Class A master ports. A point-to-point connection is used between the module and the device. The terminal is parameterized via the EtherCAT master. IO-Link is designed as an intelligent link between the fieldbus level and the sensor, wherein parameterization information can be exchanged bidirectionally via the IO-Link connection. The parameterization of the IO-Link devices with service data can be done from TwinCAT via ADS or very conveniently via the integrated IO-Link configuration tool.
In the standard setting, the EP6228-0042 functions as a 8-channel input terminal, 24 V DC, which communicates with connected IO-Link devices, parameterizes them and, if necessary, changes their operating mode.
Quick links
Technical data
Process image
Dimensions
Connections: Supply voltages
Connections: IO-Link
Commissioning and configuration
Additional information
•
Process image EP6228-0042
•
Scope of supply EP6228-0042


Process image EP6228-0042

Product overview [image] IO-Link master with Class A ports [image] EP6228-0042 [image] Process image EP6228-0042
Process image EP6228-0042
EP6228-0042 Prozessabbild | TC3 IO-Link-Modul Symbol Module 1
 |  | See chapter Diagnostics
 | TC3 IO-Link-Modul Symbol Module 2
 |  | Status variables of the IO-Link ports
 | TC3 IO-Link-Modul Symbol Module 3 1)
 |  | Process data of the IO-Link device at port 1
 | TC3 IO-Link-Modul Symbol Module 4 1)
 |  | Process data of the IO-Link device at port 2
 | TC3 IO-Link-Modul Symbol Module 5 1)
 |  | Process data of the IO-Link device at port 3
 | TC3 IO-Link-Modul Symbol Module 6 1)
 |  | Process data of the IO-Link device at port 4
 | TC3 IO-Link-Modul Symbol Module 7 1)
 |  | Process data of the IO-Link device at port 5
 | TC3 IO-Link-Modul Symbol Module 8 1)
 |  | Process data of the IO-Link device at port 6
 | TC3 IO-Link-Modul Symbol Module 9 1)
 |  | Process data of the IO-Link device at port 7
 | TC3 IO-Link-Modul Symbol Module 10 1)
 |  | Process data of the IO-Link device at port 8
 | TC3 IO-Link-Modul Symbol Module 11 1)
 |  | Digital inputs.
1) The modules "Module 3" to "Module 10" only exist in the process data if the corresponding IO-Link ports have been configured.
Assignment of connectors, ports and process data
Connector | IO-Link port | Process data of the IO-Link device | Status variable of the IO-Link port | Digital input
X01 | 1 | TC3 IO-Link-Modul Symbol Module 3 1) | TC3 InputVariable Symbol State Ch1 | TC3 InputVariable Symbol Pin 2 Ch1
X02 | 2 | TC3 IO-Link-Modul Symbol Module 4 1) | TC3 InputVariable Symbol State Ch2 | TC3 InputVariable Symbol Pin 2 Ch2
X03 | 3 | TC3 IO-Link-Modul Symbol Module 5 1) | TC3 InputVariable Symbol State Ch3 | TC3 InputVariable Symbol Pin 2 Ch3
X04 | 4 | TC3 IO-Link-Modul Symbol Module 6 1) | TC3 InputVariable Symbol State Ch4 | TC3 InputVariable Symbol Pin 2 Ch4
X05 | 5 | TC3 IO-Link-Modul Symbol Module 7 1) | TC3 InputVariable Symbol State Ch5 | TC3 InputVariable Symbol Pin 2 Ch5
X06 | 6 | TC3 IO-Link-Modul Symbol Module 8 1) | TC3 InputVariable Symbol State Ch6 | TC3 InputVariable Symbol Pin 2 Ch6
X07 | 7 | TC3 IO-Link-Modul Symbol Module 9 1) | TC3 InputVariable Symbol State Ch7 | TC3 InputVariable Symbol Pin 2 Ch7
X08 | 8 | TC3 IO-Link-Modul Symbol Module 10 1) | TC3 InputVariable Symbol State Ch8 | TC3 InputVariable Symbol Pin 2 Ch8
1) The modules "Module 3" to "Module 10" only exist in the process data if the corresponding IO-Link ports have been configured.


Scope of supply EP6228-0042

Product overview [image] IO-Link master with Class A ports [image] EP6228-0042 [image] Scope of supply EP6228-0042
Scope of supply EP6228-0042
Make sure that the following components are included in the scope of delivery:
▪
1x EP6228-0042 EtherCAT Box
▪
1x Protective cap for supply voltage output, 7/8”, black (pre-fitted)
▪
2x protective cap for EtherCAT socket, M12 (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


Technical data

Product overview [image] IO-Link master with Class A ports [image] Technical data
Technical data
Technical data | EP6224-0042 | EP6224-2022 | EP6228-0022 | EP6228-0042
Fieldbus
Fieldbus | EtherCAT
Input connection | M12 socket, 4-pin | M8 socket, 4-pin | M8 socket, 4-pin | M12 socket, 4-pin
Downstream connection | M12 socket, 4-pin | M8 socket, 4-pin | M8 socket, 4-pin | M12 socket, 4-pin
Electrical isolation | 500 V (fieldbus / IO)
Supply voltages
Power supply connection | 7/8" connector, 5-pin | M8 connector, 4-pin | M8 connector, 4-pin | 7/8" connector, 5-pin
Downstream connection | 7/8" socket, 5-pin | M8 socket, 4-pin | M8 socket, 4-pin | 7/8" socket, 5-pin
Control voltage US
Nominal voltage | 24 VDC (-15 % / +20 %)
Sum current 1) | max. 16 A | max. 4 A | max. 4 A | max. 16 A
Current consumption from US | 130 mA
Further consumers | IO-Link devices: L+ (sensor / logic supply)
Peripheral voltage UP
Nominal voltage | 24 VDC (-15 % / +20 %)
Sum current 1) | max. 16 A | max. 4 A | max. 4 A | max. 16 A
Current consumption from UP | None. UP is only forwarded.
IO-Link
Number of ports Class A | 4 | 4 | 8 | 8
Connection | 4x M12 socket, 4-pin |  | 8x M12 socket, 4-pin
Cable length | max. 20 m
Specification | IO-Link V1.1
Data rate | COM1: 4.8 kbit/s COM2: 38.4 kbit/s COM3: 230.4 kbit/s
Sensor/logic supply L+ | 24 VDC from the control voltage US
 | max. 1.4 A per port, short-circuit proof | max. 1.4 A per port, short-circuit proof max. 4.0 A in total | max. 1.4 A per port, short-circuit proof max. 4.0 A in total | max. 1.4 A per port, short-circuit proof
Actuator supply P24 | -
IO-Link port as digital input 2)
Input filter | none
IO-Link port as digital output 2)
Output current | max. 200 mA, not short-circuit proof
1) This value corresponds to the current carrying capacity per pin of the connections for the supply voltages.
2) You can also configure each IO-Link port as a digital input or digital output.
 | EP6224-0042 | EP6224-2022 | EP6228-0022 | EP6228-0042
Digital inputs
Number | 8 | - | - | 8
Connection | 4x M12 socket | - | - | 8x M12 socket 3)
Characteristics | Type 3 according to EN61131-2 Compatible with type 1 | - | - | Type 3 according to EN61131-2 Compatible with type 1
Input filter | 10 µs | - | - | 10 µs
Signal voltage "0" | up to 9.35 V | - | - | up to 9.35 V
Signal voltage "1" | from 10.5 V | - | - | from 10.5 V
Input current | 3 mA | - | - | 3 mA
Environmental conditions
Ambient temperature during operation | -25…+60 °C -25...+55 °C according to cURus
Ambient temperature during storage | -40…+85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Mechanics
Weight | approx. 440 g | approx. 250 g | approx. 250 g | approx. 440 g
Installation position | variable
Approvals and conformity
Approvals | CE cURus in preparation | CE cURus | CE cURus | CE cURus in preparation
3) The digital inputs of EP6228-0042 are located at pin 2 of the IO-Link ports.
Additional checks
The boxes have been subjected to the following checks:
Verification | Explanation
Vibration | 10 frequency sweeps in 3 axes
 | 5 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 35 g, 11 ms


IO-Link master with Class B ports

Product overview [image] IO-Link master with Class B ports
IO-Link master with Class B ports
Additional information
•
EP6224-3022
•
EP6228-3032
•
Technical data


EP6224-3022

Product overview [image] IO-Link master with Class B ports [image] EP6224-3022
EP6224-3022
4-channel IO-Link master
The EP6224 IO-Link module enables connection of up to four IO-Link devices, e.g. actuators, sensors or combinations of both. A point-to-point connection is used between the terminal and the device. The terminal is parameterised via the EtherCAT master. IO-Link is designed as an intelligent link between the fieldbus level and the sensor, wherein parameterisation information can be exchanged bidirectionally via the IO-Link connection. The parameterisation of the IO-Link devices with service data can be done from TwinCAT via ADS or very conveniently via the integrated IO-Link configuration tool.
In the standard setting, the EP6224 functions as a 4-channel input terminal, 24 V DC, which communicates with connected IO-Link devices, parameterises them and, if necessary, changes their operating mode.
Quick links
Technical data
Process image
Dimensions
Connections: Supply voltages
Connections: IO-Link
Commissioning and configuration
Additional information
•
Process image EP6224-3022
•
Scope of supply EP6224-3022


Process image EP6224-3022

Product overview [image] IO-Link master with Class B ports [image] EP6224-3022 [image] Process image EP6224-3022
Process image EP6224-3022
EP6224-3022 Prozessabbild | TC3 IO-Link-Modul Symbol Module 1
 |  | See chapter Diagnosis
 | TC3 IO-Link-Modul Symbol Module 2
 |  | Status variables of the IO-Link ports
 | TC3 IO-Link-Modul Symbol Module 3 1)
 |  | Process data of the IO-Link device at port 1
 | TC3 IO-Link-Modul Symbol Module 4 1)
 |  | Process data of the IO-Link device at port 2
 | TC3 IO-Link-Modul Symbol Module 5 1)
 |  | Process data of the IO-Link device at port 3
 | TC3 IO-Link-Modul Symbol Module 6 1)
 |  | Process data of the IO-Link device at port 4
Assignment of connectors, ports and process data
Connector | IO-Link port | Process data of the IO-Link device | Status variable of the IO-Link port
1 | 1 | TC3 IO-Link-Modul Symbol Module 3 1) | TC3 InputVariable Symbol State Ch1
2 | 2 | TC3 IO-Link-Modul Symbol Module 4 1) | TC3 InputVariable Symbol State Ch2
3 | 3 | TC3 IO-Link-Modul Symbol Module 5 1) | TC3 InputVariable Symbol State Ch3
4 | 4 | TC3 IO-Link-Modul Symbol Module 6 1) | TC3 InputVariable Symbol State Ch4
1) The modules "Module 3" to "Module 6" only exist in the process data if the corresponding IO-Link ports have been configured.


Scope of supply EP6224-3022

Product overview [image] IO-Link master with Class B ports [image] EP6224-3022 [image] Scope of supply EP6224-3022
Scope of supply EP6224-3022
Make sure that the following components are included in the scope of delivery:
▪
1x EP6224-3022 EtherCAT Box
▪
1x protective cap for supply voltage input, M8, transparent (pre-assembled)
▪
1x protective cap for supply voltage output, M8, black (pre-assembled)
▪
2x protective cap for EtherCAT socket, M8, green (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


EP6228-3032

Product overview [image] IO-Link master with Class B ports [image] EP6228-3032
EP6228-3032
8-channel IO-Link master
The EP6228 IO-Link module enables connection of up to eight IO-Link devices, e.g. IO-Link box modules, actuators, sensors or combinations thereof. A point-to-point connection is used between the module and the device. The terminal is parameterised via the EtherCAT master. IO-Link is designed as an intelligent link between the fieldbus level and the sensor, wherein parameterisation information can be exchanged bidirectionally via the IO-Link connection. The parameterisation of the IO-Link devices with service data can be done from TwinCAT via ADS or very conveniently via the integrated IO-Link configuration tool.
In the standard setting, the EP6228 functions as a 8-channel input terminal, 24 V DC, which communicates with connected IO-Link devices, parameterises them and, if necessary, changes their operating mode.
Quick links
Technical data
Process image
Dimensions
Connections: Supply voltages
Connections: IO-Link
Commissioning and configuration
Additional information
•
Process image EP6228-3032
•
Scope of supply EP6228-3032


Process image EP6228-3032

Product overview [image] IO-Link master with Class B ports [image] EP6228-3032 [image] Process image EP6228-3032
Process image EP6228-3032
EP6228-3032 Prozessabbild | TC3 IO-Link-Modul Symbol Module 1
 |  | See chapter Diagnostics
 | TC3 IO-Link-Modul Symbol Module 2
 |  | Status variables of the IO-Link ports
 | TC3 IO-Link-Modul Symbol Module 3 1)
 |  | Process data of the IO-Link device at port 1
 | TC3 IO-Link-Modul Symbol Module 4 1)
 |  | Process data of the IO-Link device at port 2
 | TC3 IO-Link-Modul Symbol Module 5 1)
 |  | Process data of the IO-Link device at port 3
 | TC3 IO-Link-Modul Symbol Module 6 1)
 |  | Process data of the IO-Link device at port 4
 | TC3 IO-Link-Modul Symbol Module 7 1)
 |  | Process data of the IO-Link device at port 5
 | TC3 IO-Link-Modul Symbol Module 8 1)
 |  | Process data of the IO-Link device at port 6
 | TC3 IO-Link-Modul Symbol Module 9 1)
 |  | Process data of the IO-Link device at port 7
 | TC3 IO-Link-Modul Symbol Module 10 1)
 |  | Process data of the IO-Link device at port 8
1) The modules "Module 3" to "Module 10" only exist in the process data if the corresponding IO-Link ports have been configured.
Assignment of connectors, ports and process data
Connector | IO-Link port | Process data of the IO-Link device | Status variable of the IO-Link port
X01 | 1 | TC3 IO-Link-Modul Symbol Module 3 1) | TC3 InputVariable Symbol State Ch1
X02 | 2 | TC3 IO-Link-Modul Symbol Module 4 1) | TC3 InputVariable Symbol State Ch2
X03 | 3 | TC3 IO-Link-Modul Symbol Module 5 1) | TC3 InputVariable Symbol State Ch3
X04 | 4 | TC3 IO-Link-Modul Symbol Module 6 1) | TC3 InputVariable Symbol State Ch4
X05 | 5 | TC3 IO-Link-Modul Symbol Module 7 1) | TC3 InputVariable Symbol State Ch5
X06 | 6 | TC3 IO-Link-Modul Symbol Module 8 1) | TC3 InputVariable Symbol State Ch6
X07 | 7 | TC3 IO-Link-Modul Symbol Module 9 1) | TC3 InputVariable Symbol State Ch7
X08 | 8 | TC3 IO-Link-Modul Symbol Module 10 1) | TC3 InputVariable Symbol State Ch8
1) The modules "Module 3" to "Module 10" only exist in the process data if the corresponding IO-Link ports have been configured.


Scope of supply EP6228-3032

Product overview [image] IO-Link master with Class B ports [image] EP6228-3032 [image] Scope of supply EP6228-3032
Scope of supply EP6228-3032
Make sure that the following components are included in the scope of delivery:
▪
1x EP6228-3032 EtherCAT Box
▪
1x Protective cap for supply voltage output, 7/8”, black (pre-fitted)
▪
2x protective cap for EtherCAT socket, M8, green (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


Technical data

Product overview [image] IO-Link master with Class B ports [image] Technical data
Technical data
All values are typical values over the entire temperature range, unless stated otherwise.
Technical data | EP6224-3022 | EP6228-3032
Fieldbus
Fieldbus | EtherCAT
Connection | 2 x M8 socket, green
Electrical isolation | 500 V (fieldbus / IO)
Supply voltages
Power supply connection | M8 plug, 4-pin | 7/8" connector, 5-pin
Downstream connection | M8 socket, 4-pin | 7/8" socket, 5-pin
Control voltage US
Nominal voltage | 24 VDC (-15 % / +20 %)
Sum current 1) | max. 4 A | max. 16 A
Current consumption from US | 130 mA
Further consumers | IO-Link devices: L+ (sensor / logic supply)
Peripheral voltage UP
Nominal voltage | 24 VDC (-15 % / +20 %)
Sum current 1) | max. 4 A | max. 16 A
UP consumer | IO-Link devices Class B: P24 (actuator supply)
IO-Link
Number of ports Class B | 4 | 8
Connection | 4x M12 socket, 5-pin | 8x M12 socket, 5-pin
Cable length | max. 20 m
Specification | IO-Link V1.1
Data rate | COM1: 4.8 kbit/s COM2: 38.4 kbit/s COM3: 230.4 kbit/s
Sensor / logic supply L+ | 24 VDC from the control voltage US
 | max. 1.4 A per port, short-circuit proof max. 4.0 A in total | max. 1.4 A per port, short-circuit proof
Actuator supply P24 | 24 VDC from peripheral voltage UP
 | max. 2.0 A per port max. 4.0 A in total, short-circuit proof | max. 4.0 A per port pair 3), short-circuit proof
IO-Link port as digital input 2)
Input filter | none
IO-Link port as digital output 2)
Output current | max. 200 mA, not short-circuit proof
1) This value corresponds to the current carrying capacity per pin of the connections for the supply voltages.
2) You can also configure each IO-Link port as a digital input or digital output.
3) Port pairs with common limitation of the actuator supply P24:
▪
1 + 5
▪
2 + 6
▪
3 + 7
▪
4 + 8
 | EP6224-3022 | EP6228-3032
Environmental conditions
Ambient temperature during operation | -25…+60 °C -25...+55 °C according to cURus
Ambient temperature during storage | -40…+85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Mechanics
Weight | approx. 250 g | approx. 440 g
Installation position | variable
Approvals and conformity
Approvals | CE cURus | CE cURus in preparation
Additional checks
The boxes have been subjected to the following checks:
Verification | Explanation
Vibration | 10 frequency sweeps in 3 axes
 | 5 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 35 g, 11 ms


IO-Link master with Class A ports and Class B ports

Product overview [image] IO-Link master with Class A ports and Class B ports
IO-Link master with Class A ports and Class B ports
Additional information
•
EP6228-3132
•
EP6228-3142
•
Technical data


EP6228-3132

Product overview [image] IO-Link master with Class A ports and Class B ports [image] EP6228-3132
EP6228-3132
8-channel IO-Link master, 4 x Class A, 4 x Class B, 4 x digital input
The EP6228-3132 IO-Link module enables connection of up to eight IO-Link devices, e.g. IO-Link box modules, actuators, sensors or combinations thereof. The EP6228-3132 additionally offers further digital inputs on the four Class A master ports. A point-to-point connection is used between the module and the device. The terminal is parameterized via the EtherCAT master. IO-Link is designed as an intelligent link between the fieldbus level and the sensor, wherein parameterization information can be exchanged bidirectionally via the IO-Link connection. The parameterization of the IO-Link devices can be done from TwinCAT via ADS or very conveniently via the integrated IO-Link configuration tool.
In the standard setting, the EP6228-3132 functions as a 8-channel input terminal, 24 V DC, which communicates with connected IO-Link devices, parameterizes them and, if necessary, changes their operating mode.
Quick links
Technical data
Process image
Dimensions
Connections: Supply voltages
Connections: IO-Link
Commissioning and configuration
Additional information
•
Process image EP6228-3132
•
Scope of supply EP6228-3132


Process image EP6228-3132

Product overview [image] IO-Link master with Class A ports and Class B ports [image] EP6228-3132 [image] Process image EP6228-3132
Process image EP6228-3132
EP6228-3132 Prozessabbild | TC3 IO-Link-Modul Symbol Module 1
 |  | See chapter Diagnosis
 | TC3 IO-Link-Modul Symbol Module 2
 |  | Status variables of the IO-Link ports
 | TC3 IO-Link-Modul Symbol Module 3 1)
 |  | Process data of the IO-Link device at port 1
 | TC3 IO-Link-Modul Symbol Module 4 1)
 |  | Process data of the IO-Link device at port 2
 | TC3 IO-Link-Modul Symbol Module 5 1)
 |  | Process data of the IO-Link device at port 3
 | TC3 IO-Link-Modul Symbol Module 6 1)
 |  | Process data of the IO-Link device at port 4
 | TC3 IO-Link-Modul Symbol Module 7 1)
 |  | Process data of the IO-Link device at port 5
 | TC3 IO-Link-Modul Symbol Module 8 1)
 |  | Process data of the IO-Link device at port 6
 | TC3 IO-Link-Modul Symbol Module 9 1)
 |  | Process data of the IO-Link device at port 7
 | TC3 IO-Link-Modul Symbol Module 10 1)
 |  | Process data of the IO-Link device at port 8
 | TC3 IO-Link-Modul Symbol Module 11 1)
 |  | Digital inputs of ports 1, 2, 5, 6 (Class A ports)
1) The modules "Module 3" to "Module 10" only exist in the process data if the corresponding IO-Link ports have been configured.
Assignment of connectors, ports and process data
Connector | IO-Link port | Process data of the IO-Link device | Status variable of the IO-Link port | Digital input
X01 | 1 | TC3 IO-Link-Modul Symbol Module 3 1) | TC3 InputVariable Symbol State Ch1 | TC3 InputVariable Symbol Pin 2 Ch1
X02 | 2 | TC3 IO-Link-Modul Symbol Module 4 1) | TC3 InputVariable Symbol State Ch2 | TC3 InputVariable Symbol Pin 2 Ch2
X03 | 3 | TC3 IO-Link-Modul Symbol Module 5 1) | TC3 InputVariable Symbol State Ch3 | -
X04 | 4 | TC3 IO-Link-Modul Symbol Module 6 1) | TC3 InputVariable Symbol State Ch4 | -
X05 | 5 | TC3 IO-Link-Modul Symbol Module 7 1) | TC3 InputVariable Symbol State Ch5 | TC3 InputVariable Symbol Pin 2 Ch5
X06 | 6 | TC3 IO-Link-Modul Symbol Module 8 1) | TC3 InputVariable Symbol State Ch6 | TC3 InputVariable Symbol Pin 2 Ch6
X07 | 7 | TC3 IO-Link-Modul Symbol Module 9 1) | TC3 InputVariable Symbol State Ch7 | -
X08 | 8 | TC3 IO-Link-Modul Symbol Module 10 1) | TC3 InputVariable Symbol State Ch8 | -
1) The modules "Module 3" to "Module 10" only exist in the process data if the corresponding IO-Link ports have been configured.


Scope of supply EP6228-3132

Product overview [image] IO-Link master with Class A ports and Class B ports [image] EP6228-3132 [image] Scope of supply EP6228-3132
Scope of supply EP6228-3132
Make sure that the following components are included in the scope of delivery:
▪
1x EP6228-3132 EtherCAT Box
▪
1x Protective cap for supply voltage output, 7/8”, black (pre-fitted)
▪
2x protective cap for EtherCAT socket, M8, green (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


EP6228-3142

Product overview [image] IO-Link master with Class A ports and Class B ports [image] EP6228-3142
EP6228-3142
8-channel IO-Link master, 4 x Class A, 4 x Class B, 4 x digital input
The EP6228-3142 IO-Link module enables connection of up to eight IO-Link devices, e.g. IO-Link box modules, actuators, sensors or combinations thereof. The EP6228-3142 additionally offers further digital inputs on the four Class A master ports. A point-to-point connection is used between the module and the device. The terminal is parameterized via the EtherCAT master. IO-Link is designed as an intelligent link between the fieldbus level and the sensor, wherein parameterization information can be exchanged bidirectionally via the IO-Link connection. The parameterization of the IO-Link devices can be done from TwinCAT via ADS or very conveniently via the integrated IO-Link configuration tool.
In the standard setting, the EP6228-3142 functions as a 8-channel input terminal, 24 V DC, which communicates with connected IO-Link devices, parameterizes them and, if necessary, changes their operating mode.
Quick links
Technical data
Process image
Dimensions
Connections: Supply voltages
Connections: IO-Link
Commissioning and configuration
Additional information
•
Process image EP6228-3142
•
Scope of supply EP6228-3142


Process image EP6228-3142

Product overview [image] IO-Link master with Class A ports and Class B ports [image] EP6228-3142 [image] Process image EP6228-3142
Process image EP6228-3142
EP6228-3142 Prozessabbild | TC3 IO-Link-Modul Symbol Module 1
 |  | See chapter Diagnosis
 | TC3 IO-Link-Modul Symbol Module 2
 |  | Status variables of the IO-Link ports
 | TC3 IO-Link-Modul Symbol Module 3 1)
 |  | Process data of the IO-Link device at port 1 (Class A port)
 | TC3 IO-Link-Modul Symbol Module 4 1)
 |  | Process data of the IO-Link device at port 2 (Class A port)
 | TC3 IO-Link-Modul Symbol Module 5 1)
 |  | Process data of the IO-Link device at port 3 (Class B port)
 | TC3 IO-Link-Modul Symbol Module 6 1)
 |  | Process data of the IO-Link device at port 4 (Class B port)
 | TC3 IO-Link-Modul Symbol Module 7 1)
 |  | Process data of the IO-Link device at port 5 (Class A port)
 | TC3 IO-Link-Modul Symbol Module 8 1)
 |  | Process data of the IO-Link device at port 6 (Class A port)
 | TC3 IO-Link-Modul Symbol Module 9 1)
 |  | Process data of the IO-Link device at port 7 (Class B port)
 | TC3 IO-Link-Modul Symbol Module 10 1)
 |  | Process data of the IO-Link device at port 8 (Class B port)
 | TC3 IO-Link-Modul Symbol Module 11 1)
 |  | Digital inputs of ports 1, 2, 5, 6 (Class A ports)
1) The modules "Module 3" to "Module 10" only exist in the process data if the corresponding IO-Link ports have been configured.
Assignment of connectors, ports and process data
Connector | IO-Link port | Process data of the IO-Link device | Status variable of the IO-Link port | Digital input
X01 | 1 | TC3 IO-Link-Modul Symbol Module 3 1) | TC3 InputVariable Symbol State Ch1 | TC3 InputVariable Symbol Pin 2 Ch1
X02 | 2 | TC3 IO-Link-Modul Symbol Module 4 1) | TC3 InputVariable Symbol State Ch2 | TC3 InputVariable Symbol Pin 2 Ch2
X03 | 3 | TC3 IO-Link-Modul Symbol Module 5 1) | TC3 InputVariable Symbol State Ch3 | -
X04 | 4 | TC3 IO-Link-Modul Symbol Module 6 1) | TC3 InputVariable Symbol State Ch4 | -
X05 | 5 | TC3 IO-Link-Modul Symbol Module 7 1) | TC3 InputVariable Symbol State Ch5 | TC3 InputVariable Symbol Pin 2 Ch5
X06 | 6 | TC3 IO-Link-Modul Symbol Module 8 1) | TC3 InputVariable Symbol State Ch6 | TC3 InputVariable Symbol Pin 2 Ch6
X07 | 7 | TC3 IO-Link-Modul Symbol Module 9 1) | TC3 InputVariable Symbol State Ch7 | -
X08 | 8 | TC3 IO-Link-Modul Symbol Module 10 1) | TC3 InputVariable Symbol State Ch8 | -
1) The modules "Module 3" to "Module 10" only exist in the process data if the corresponding IO-Link ports have been configured.


Scope of supply EP6228-3142

Product overview [image] IO-Link master with Class A ports and Class B ports [image] EP6228-3142 [image] Scope of supply EP6228-3142
Scope of supply EP6228-3142
Make sure that the following components are included in the scope of delivery:
▪
1x EP6228-3142 EtherCAT Box
▪
1x Protective cap for supply voltage output, 7/8”, black (pre-fitted)
▪
2x protective cap for EtherCAT socket, M12 (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


Technical data

Product overview [image] IO-Link master with Class A ports and Class B ports [image] Technical data
Technical data
All values are typical values over the entire temperature range, unless stated otherwise.
Technical data | EP6228-3132 | EP6228-3142
Fieldbus
Fieldbus | EtherCAT
Connection | 2 x M8 socket | 2 x M12 socket
Electrical isolation | 500 V (fieldbus / IO)
Supply voltages
Power supply connection | 7/8" connector, 5-pin
Downstream connection | 7/8" socket, 5-pin
Control voltage US
Nominal voltage | 24 VDC (-15 % / +20 %)
Sum current 1) | max. 16 A
Current consumption from US | 130 mA
Further consumers | IO-Link devices: L+ (sensor / logic supply)
Peripheral voltage UP
Nominal voltage | 24 VDC (-15 % / +20 %)
Sum current 1) | max. 16 A
UP consumer | IO-Link devices Class B: P24 (actuator supply)
IO-Link
Number of ports Class A | 4
Number of ports Class B | 4
Connection | Class A ports: 4x M12 socket, 4-pin Class B ports: 4x M12 socket, 5-pin
Cable length | max. 20 m
Specification | IO-Link V1.1
Data rate | COM1: 4.8 kbit/s COM2: 38.4 kbit/s COM3: 230.4 kbit/s
Sensor / logic supply L+ | 24 VDC from the control voltage US max. 1.4 A per port, short-circuit proof
Actuator supply P24 | 24 VDC from peripheral voltage UP max. 4.0 A per port pair 3), short-circuit proof
IO-Link port as digital input 2)
Input filter | none
IO-Link port as digital output 2)
Output current | max. 200 mA, not short-circuit proof
1) This value corresponds to the current carrying capacity per pin of the connections for the supply voltages.
2) You can also configure each IO-Link port as a digital input or digital output.
3) Port pairs with common limitation of the actuator supply P24:
▪
3 + 7
▪
4 + 8
Technical data | EP6228-3132 | EP6228-3142
Digital inputs
Number | 4
Connection | 4x M12 socket 4)
Characteristics | Type 3 according to EN 61131-2, compatible with type 1
Input filter | 10 µs
Signal voltage "0" | up to 9.35 V
Signal voltage "1" | from 10.5 V
Input current | 3 mA
Environmental conditions
Ambient temperature during operation | -25…+60 °C -25...+55 °C according to cURus
Ambient temperature during storage | -40…+85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Mechanics
Weight | approx. 440 g
Installation position | variable
Approvals and conformity
Approvals | CE cURus in preparation
4) These digital inputs are located at pin 2 of the IO-Link Class A ports.
Additional checks
The boxes have been subjected to the following checks:
Verification | Explanation
Vibration | 10 frequency sweeps in 3 axes
 | 5 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 35 g, 11 ms


IO-Link master principles

IO-Link master principles
IO-Link master principles
Additional information
•
Topology
•
Ports
•
„Data storage“ function


Mounting and connections

Mounting and connections
Mounting and connections
Additional information
•
Mounting
•
Connections
•
UL Requirements


Mounting

Mounting and connections [image] Mounting
Mounting
Additional information
•
Dimensions
•
Mounting
•
Tightening torques for plug connectors
•
Functional earth (FE)


Dimensions

Mounting and connections [image] Mounting [image] Dimensions
Dimensions
EP6224-2022, EP6224-3022
Dimensions
All dimensions are given in millimeters.
Housing features
Housing material | PA6 (polyamide)
Sealing compound | polyurethane
Mounting | two fastening holes Ø 4.5 mm for M4
Metal parts | brass, nickel-plated
Contacts | CuZn, gold-plated
Power feed through | max. 4 A
Mounting position | variable
Protection class | IP65, IP66, IP67 (conforms to EN 60529) when screwed together
Dimensions (H x W x D) | approx. 126 x 60 x 26.5 mm (without connectors)
EP6228-0022
Dimensions
All dimensions are given in millimeters.
Housing features
Housing material | PA6 (polyamide)
Sealing compound | polyurethane
Mounting | two fastening holes Ø 4.5 mm for M4
Metal parts | brass, nickel-plated
Contacts | CuZn, gold-plated
Power feed through | max. 4 A
Mounting position | variable
Protection class | IP65, IP66, IP67 (conforms to EN 60529) when screwed together
Dimensions (H x W x D) | approx. 126 x 60 x 26.5 mm (without connectors)
EP6228-xx32, EP6228-xx42
Dimensions
All dimensions are given in millimeters.
Housing features
Housing material | PA6 (polyamide)
Sealing compound | polyurethane
Mounting | two fastening holes Ø 4.5 mm for M4
Metal parts | brass, nickel-plated
Contacts | CuZn, gold-plated
Power feed through | max. 16 A at 40°C (according to IEC 60512-3)
Mounting position | variable
Protection class | IP65, IP66, IP67 (conforms to EN 60529) when screwed together
Dimensions (H x W x D) | approx. 150 x 60 x 26.5 mm (without connectors)


Mounting

Mounting and connections [image] Mounting [image] Mounting
Mounting
Note
Dirt during assembly
Dirty connectors can lead to malfunctions. Protection class IP67 can only be guaranteed if all cables and connectors are connected.
•
Protect the plug connectors against dirt during the assembly.
Mount the module with two M4 screws in the centrally located fastening holes.


Tightening torques for plug connectors

Mounting and connections [image] Mounting [image] Tightening torques for plug connectors
Tightening torques for plug connectors
Screw connectors tight with a torque wrench. (e.g. ZB8801 from Beckhoff)
Connector diameter | Tightening torque
M8 | 0.4 Nm
M12 | 0.6 Nm
7/8” | 1.5 Nm


Functional earth (FE)

Mounting and connections [image] Mounting [image] Functional earth (FE)
Functional earth (FE)
The fastening holes also serve as connections for the functional earth (FE).
Make sure that the box is earthed with low impedance via both fastening screws. You can achieve this, for example, by mounting the box on a grounded machine bed.
FE connection via fastening holes
Functional earth via the fastening holes


Connections

Mounting and connections [image] Connections
Connections
Guidelines
Follow these guidelines to ensure IP67 protection:
▪
Mount connectors with the specified torque. Use a torque wrench, e.g. Beckhoff ZB8801.
▪
Seal unused connectors with protective caps.
▪
Ensure the correct seating of pre-assembled protective caps.
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Additional information
•
Supply voltage
•
EtherCAT
•
IO-Link
•
Digital inputs: EP6224-0042 - X01, X02, X05, X06


Supply voltage

Mounting and connections [image] Connections [image] Supply voltage
Supply voltage
The EtherCAT Box is supplied with two supply voltages. The supply voltages are electrically isolated in the EtherCAT Box.
▪
Control voltage US
▪
Peripheral voltage UP
Additional information
•
M8 connector
•
7/8" plug connectors


M8 connector

Mounting and connections [image] Connections [image] Supply voltage [image] M8 connector
M8 connector
Note
Defect possible through incorrect insertion
M8 connector for supply voltages have the same design as M8 connectors for EtherCAT. Observe the color coding of the connectors in order to avoid incorrect insertion:
black: Supply voltage
green: EtherCAT
Two connectors at the low-end of the modules are used for feeding and routing the supply voltages:
▪
Power supply: IN plug, left
▪
Downstream connection: OUT socket, right
Connectors + LEDs
Connector for the supply voltages
Connection
M8 connector
Contact | Function | Description | Core color 1)
1 | US | Control voltage | Brown
2 | UP | Peripheral voltage | White
3 | GNDS | GND to US | Blue
4 | GNDP | GND to UP | Black
1) The core colors apply to cables of the type: Beckhoff ZK2020-xxxx-xxxx
Additional information
•
Status LEDs
•
Conductor losses


Status LEDs

Mounting and connections [image] Connections [image] Supply voltage [image] M8 connector [image] Status LEDs
Status LEDs
Connectors + LEDs
Status LEDs for the supply voltages
LED | Display | Meaning
US (control voltage) | off | Supply voltage US is not present
 | green illuminated | Supply voltage US is present
UP (peripheral voltage) | off | Supply voltage UP is not present
 | green illuminated | Supply voltage UP is present


Conductor losses

Mounting and connections [image] Connections [image] Supply voltage [image] M8 connector [image] Conductor losses
Conductor losses
Take into account the voltage drop on the supply line when planning a system. Avoid the voltage drop being so high that the supply voltage at the box lies below the minimum nominal voltage.
Variations in the voltage of the power supply unit must also be taken into account.
Voltage drop on the supply line
Leitungsverluste M8 2A
Leitungsverluste M8 4A


7/8" plug connectors

Mounting and connections [image] Connections [image] Supply voltage [image] 7/8" plug connectors
7/8" plug connectors
Two connectors at the low-end of the modules are used for feeding and routing the supply voltages:
▪
Power supply: IN plug, left
▪
Downstream connection: OUT socket, right
Connectors + LEDs
Connector for the supply voltages
Connection
7/8 Zoll In+Out Kontaktbelegung
7/8" plug connectors
Contact | Function | Description | Core color 1)
1 | GNDP | GND to UP | black
2 | GNDS | GND to US | blue
3 | FE 2) | Functional earth 2) | grey
4 | US | Peripheral voltage | brown
5 | UP | Peripheral voltage | white
1) The core colors apply to cables of the type: Beckhoff ZK203x-xxxx.
2) With EP6228-3022 and EP6228-3132 Pin 3 is not connected directly to functional earth (FE), but via a parallel connection of a resistor 1 MΩ and a capacitor 270 pF.
Additional information
•
Status LEDs
•
Conductor losses


Status LEDs

Mounting and connections [image] Connections [image] Supply voltage [image] 7/8" plug connectors [image] Status LEDs
Status LEDs
Connectors + LEDs
Status LEDs for the supply voltages
LED | Display | Meaning
US (control voltage) | off | Supply voltage US is not present
 | green illuminated | Supply voltage US is present
UP (peripheral voltage) | off | Supply voltage UP is not present
 | green illuminated | Supply voltage UP is present


Conductor losses

Mounting and connections [image] Connections [image] Supply voltage [image] 7/8" plug connectors [image] Conductor losses
Conductor losses
Take into account the voltage drop on the supply line when planning a system. Avoid the voltage drop being so high that the supply voltage at the box lies below the minimum nominal voltage.
Variations in the voltage of the power supply unit must also be taken into account.
Voltage drop on the supply line
Leitungsverluste 7/8" 2A
Leitungsverluste 7/8" 4A


EtherCAT

Mounting and connections [image] Connections [image] EtherCAT
EtherCAT
Additional information
•
Connectors
•
Status LEDs
•
Cables


Connectors

Mounting and connections [image] Connections [image] EtherCAT [image] Connectors
Connectors
Note
Risk of confusion: supply voltages and EtherCAT
Defect possible through incorrect insertion.
•
Observe the color coding of the connectors:
black: Supply voltages
green: EtherCAT
EtherCAT Box modules have two green M8 or M12 sockets for the incoming and outgoing EtherCAT connections.
M8 sockets | M12 sockets
EtherCAT connections | EtherCAT connections
M8 socket, 4-pin – connection | M12 socket, D-coded EtherCAT/Ethernet
Assignment
There are various different standards for the assignment and colors of connectors and cables for EtherCAT.
EtherCAT | Plug connector |  |  | Cable |  | Standard
Signal | M8 | M12 | RJ451 | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 and old versions of ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | Pin 1 | Pin 1 | Pin 1 | yellow2 | orange/white3 | white/orange
Tx - | Pin 4 | Pin 3 | Pin 2 | orange2 | orange3 | orange
Rx + | Pin 2 | Pin 2 | Pin 3 | white2 | blue/white3 | white/green
Rx - | Pin 3 | Pin 4 | Pin 6 | blue2 | blue3 | green
Shield | Housing |  | Shroud | Shield | Shield | Shield
1) colored markings according to EN 61918 in the four-pin RJ45 connector ZS1090-0003
2) wire colors according to EN 61918
3) wire colors
Assimilation of color coding for cable ZB9030, ZB9032 and ZK1090-3xxxx-xxxx (with M8 connectors)
For unification, the prevalent cables ZB9030, ZB9032 and ZK1090-3xxx-xxxx were changed to the colors of EN61918 (yellow, orange, white, blue). So different color coding exists. But the electrical properties are absolutely identical.


Status LEDs

Mounting and connections [image] Connections [image] EtherCAT [image] Status LEDs
Status LEDs
EtherCAT connections
EtherCAT connections
L/A (Link/Act)
A green LED labelled "L/A" is located next to each EtherCAT socket. The LED indicates the communication state of the respective socket:
LED | Meaning
off | no connection to the connected EtherCAT device
lit | LINK: connection to the connected EtherCAT device
flashes | ACT: communication with the connected EtherCAT device
Run
Each EtherCAT slave has a green LED labelled "Run". The LED signals the status of the slave in the EtherCAT network:
LED | Meaning
off | Slave is in "Init" state
flashes uniformly | Slave is in "Pre-Operational“ state
flashes sporadically | Slave is in "Safe-Operational" state
lit | Slave is in "Operational" state
Description of the EtherCAT slave states


Cables

Mounting and connections [image] Connections [image] EtherCAT [image] Cables
Cables
For connecting EtherCAT devices only shielded Ethernet cables that meet the requirements of at least category 5 (CAT5) according to EN 50173 or ISO/IEC 11801 should be used.
EtherCAT uses four wires for signal transmission.
Thanks to automatic line detection ("Auto MDI-X"), both symmetrical (1:1) or cross-over cables can be used between Beckhoff EtherCAT.
Detailed recommendations for the cabling of EtherCAT devices


IO-Link

Mounting and connections [image] Connections [image] IO-Link
IO-Link
Additional information
•
Connector
•
Status LEDs


Connector

Mounting and connections [image] Connections [image] IO-Link [image] Connector
Connector
The IO-Link ports are implemented as M12 sockets.
M12 socket
EP6224-0042 - X03, X04, X07, X08
EP6224-2022
EP6228-0022
Contact | Function | Description | Core color 1)
1 | L+ | Supply voltage (US1) | brown
2 | - | - | white
3 | L- | GND | blue
4 | C/Q | IO-Link data | black
5 | - | - | grey
EP6228-0042
Contact | Function | Description | Core color 1)
1 | L+ | Supply voltage (US1) | brown
2 | DI | Digital input | white
3 | L- | GND | blue
4 | C/Q | IO-Link data | black
5 | - | - | grey
EP6224-3022
EP6228-3032
Contact | Function | Description | Core color 1)
1 | L+ | Sensor/logic supply (US1) | brown
2 | P24 | Actuator supply (UP1) | white
3 | L- | GND to L+ | blue
4 | C/Q | IO-Link data | black
5 | N24 | GND to P24 | grey
1) The core colors apply to M12 cables from Beckhoff: ZK2000-5xxx, ZK2000-6xxx, ZK2000-7xxx
M12 socket
EP6228-3132
EP6228-3142
Contact | X01, X02, X05, X06: Class A ports |  | X03, X04, X07, X08: Class B ports |  | Core color 1)
 | Function | Description | Function | Description
1 | L+ | Supply voltage (US1) | L+ | Sensor/logic supply (US1) | brown
2 | DI | Digital input | P24 | Actuator supply (UP1) | white
3 | L- | GND | L- | GND to L+ | blue
4 | C/Q | IO-Link data | C/Q | IO-Link data | black
5 | - | - | N24 | GND to P24 | grey
1) The core colors apply to M12 cables from Beckhoff: ZK2000-5xxx, ZK2000-6xxx, ZK2000-7xxx


Status LEDs

Mounting and connections [image] Connections [image] IO-Link [image] Status LEDs
Status LEDs
IO-Link Port LEDs
Status LEDs of an IO-Link port
1 - IO-Link
LED signal
Meaning
off
Possibilities:
▪
Port not configured
▪
Logic level low 1)
red illuminated
flashes sporadically green
Possibilities:
▪
IO-Link connection attempt
▪
No IO-Link device connected
▪
Incorrect IO-Link device connected
▪
IO-Link device defective
flashing green
IO-Link communication active
green illuminated
Logic level high 1)
1) Port configured as digital input or output
2 - Digital input DI (EP6228-0042, EP6228-3132, EP6228-3142)
The LED lights up when a high level is present on the digital input DI.


Digital inputs: EP6224-0042 - X01, X02, X05, X06

Mounting and connections [image] Connections [image] Digital inputs: EP6224-0042 - X01, X02, X05, X06
Digital inputs: EP6224-0042 - X01, X02, X05, X06
Pin assignment
M12 socket
Pin | Function | Core color 1)
1 | US1 2) | brown
2 | Input B | white
3 | GNDS | blue
4 | Input A | black
5 | Functional earth FE | grey
1) The core colors apply to M12 cables from Beckhoff: ZK2000-5xxx, ZK2000-6xxx, ZK2000-7xxx
2) US1 serves as sensor supply voltage. It is branched off from the US supply voltage.
Connection examples
Digital inputs M12, connection examples
Status LEDs
Each M12 socket with digital inputs has two green LEDs. An LED lights up when a high level is detected at the respective input.
Status-LEDs von M12-Buchsen
Status LEDs at M12 sockets


UL Requirements

Mounting and connections [image] UL Requirements
UL Requirements
The installation of the EtherCAT Box Modules certified by UL has to meet the following requirements.
Supply voltage
SmallWarningYellow CAUTION
CAUTION!
This UL requirements are valid for all supply voltages of all marked EtherCAT Box Modules!
For the compliance of the UL requirements the EtherCAT Box Modules should only be supplied
•
by a 24 VDC supply voltage, supplied by an isolating source and protected by means of a fuse (in accordance with UL248), rated maximum 4 Amp, or
•
by a 24 VDC power source, that has to satisfy NEC class 2.
A NEC class 2 power supply shall not be connected in series or parallel with another (class 2) power source!
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, the EtherCAT Box Modules must not be connected to unlimited power sources!
Networks
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, EtherCAT Box Modules must not be connected to telecommunication networks!
Ambient temperature range
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, EtherCAT Box Modules has to be operated only at an ambient temperature range of 0 to 55°C!
Marking for UL
All EtherCAT Box Modules certified by UL (Underwriters Laboratories) are marked with the following label.
UL label


Commissioning and configuration

Commissioning and configuration
Commissioning and configuration
Additional information
•
Integration in TwinCAT
•
IO-Link configuration
•
Restoring the delivery state
•
Decommissioning


Integration in TwinCAT

Commissioning and configuration [image] Integration in TwinCAT
Integration in TwinCAT
The procedure for integration in TwinCAT is described in this Quick start guide.


IO-Link configuration

Commissioning and configuration [image] IO-Link configuration
IO-Link configuration
Additional information
•
Opening the configuration tool
•
Assigning devices to ports
•
Supplementing the device catalog
•
Parameterizing a port
•
Parameterizing a device
•
Configuring a port as a digital input/output
•
Activating the configuration


Opening the configuration tool

Commissioning and configuration [image] IO-Link configuration [image] Opening the configuration tool
Opening the configuration tool
➢
Requirement: an IO-Link master has been added in the Solution Explorer under the "I/O" entry.
1.
Double-click on the IO-Link master.
⇨
A device editor for the IO-Link master opens.
2.
Click on the "IO-Link" tab.
⇨
The IO-Link configuration tool opens.
IO-Link configuration tool with marking
Overview
The configuration tool contains two fields:
▪
„Ports“
The left-hand field "Ports" shows a list of the ports of the IO-Link master. If a device has been assigned to a port, the device designation is shown next to the port.
▪
„Catalog“
The right-hand field "Catalog" shows the device catalog. The device catalog contains a list of the IO-Link devices for which a device description exists in the local TwinCAT installation.
Changes in the IO-Link configuration tool only become effective when you activate the IO-Link configuration.


Assigning devices to ports

Commissioning and configuration [image] IO-Link configuration [image] Assigning devices to ports
Assigning devices to ports
There are four ways of assigning devices to ports:
Selecting a device from the device catalog
1.
Search for the desired device in the "Catalog" field.
Not available? Supplementing the device catalog
2.
Assign the device to a port. There are two ways to do this:
- Pull the device onto the desired port by drag-and-drop.
- Right-click on the device
Click on "Add to Port n" in the context menu.
⇨
The device is assigned to the port
Importing the device description file IODD
1.
Supplementing the device catalog > "Import from the file system"
2.
Select a device from the device catalog
⇨
The device is assigned to the port
Scanning devices
➢
Requirement: the master and the devices are cabled and supplied with voltage.
1.
Click on the "Scan Devices" button.
⇨
The IO-Link master requests all connected devices to identify themselves. Each detected device is automatically assigned to the port to which it is connected.
Entering the device description manually
1.
Right-click on a port.
2.
Click on "Create Device" in the context menu.
⇨
A dialog box opens.
3.
Enter the items of information that describe the IO-Link device.


Supplementing the device catalog

Commissioning and configuration [image] IO-Link configuration [image] Supplementing the device catalog
Supplementing the device catalog
Following the installation of TwinCAT, the device catalog contains only the device descriptions of IO-Link devices from Beckhoff. There are two ways of supplementing the catalog:
Importing from the online database "IODDfinder"
➢
Requirement: the PC can access the Internet
1.
Click on the "IODDfinder" button.
2.
Search for the desired device.
3.
Click on the image in the "Picture" column.
⇨
The device description is downloaded and added to the device catalog.
Importing from the file system
1.
Click on the "Import device description" button
2.
Open a device description file (IODD) in the dialog box that opens
⇨
The device description is added to the device catalog.


Parameterizing a port

Commissioning and configuration [image] IO-Link configuration [image] Parameterizing a port
Parameterizing a port
➢
Requirement: A device is assigned to the port. Assigning devices to ports.
1.
In the "Ports" field, right-click on the port
2.
Click on "Settings"
⇨
The "Settings" tab opens


Parameterizing a device

Commissioning and configuration [image] IO-Link configuration [image] Parameterizing a device
Parameterizing a device
➢
Requirement: The device is assigned to a port. Assigning devices to ports.
1.
In the "Ports" field, right-click on the device
2.
Click on "Parameters"
⇨
The "Parameters" tab opens
Buttons
▪
„Read“
Read the parameter values from the device.
▪
„Write“
Write the parameter values to the device.
▪
„Set default“
Set the parameter values to the default values. The default values are adopted from the device description file. Die Standardwerte werden aus der Gerätebeschreibung im Device-Katalog übernommen.
▪
„Store“
Store the current parameter values in the Parameter Server. „Data Storage“.


Configuring a port as a digital input/output

Commissioning and configuration [image] IO-Link configuration [image] Configuring a port as a digital input/output
Configuring a port as a digital input/output
IO-Link ports can also be configured as digital inputs or digital outputs. This allows digital sensors and actuators having no IO-Link functionality to be connected to IO-Link ports.
1.
Expand the "Std-I/O" tree node in the "Catalog" field
⇨
The operating modes "dig in" and "dig out" appear
2.
Configure the desired port. There are two ways to do this:
1. Drag-and-drop: pull "dig in" or "dig out" onto the port in the "Ports" field
2. Right-click on "dig in" or "dig out" and click on "Add to Port n“


Activating the configuration

Commissioning and configuration [image] IO-Link configuration [image] Activating the configuration
Activating the configuration
Changes in the IO-Link configuration tool only become effective when you activate the IO-Link configuration.
There are two ways to activate the IO-Link configuration:
▪
Click on the "Reload Devices" button
TC3 Button Reload Devices
▪
Activate the TwinCAT configuration:
Click on the "Activate Configuration" button
TC3 Button Activate Configuration


Restoring the delivery state

Commissioning and configuration [image] Restoring the delivery state
Restoring the delivery state
To restore the delivery state for backup objects in ELxxxx terminals / EPxxxx- and EPPxxxx boxes, the CoE object Restore default parameters, SubIndex 001 can be selected in the TwinCAT System Manager (Config mode).
Selecting the Restore default parameters PDO
Double-click on SubIndex 001 to enter the Set Value dialog. Enter the value 1684107116 in field Dec or the value 0x64616F6C in field Hex and confirm with OK.
All backup objects are reset to the delivery state.
Entering a restore value in the Set Value dialog
Alternative restore value
In some older terminals / boxes the backup objects can be switched with an alternative restore value:
Decimal value: 1819238756
Hexadecimal value: 0x6C6F6164
An incorrect entry for the restore value has no effect.


Decommissioning

Commissioning and configuration [image] Decommissioning
Decommissioning
SmallWarningYellow WARNING
Risk of electric shock!
Bring the bus system into a safe, de-energized state before starting disassembly of the devices!
Disposal
In order to dispose of the device, it must be removed.
In accordance with the WEEE Directive 2012/19/EU, Beckhoff takes back old devices and accessories in Germany for proper disposal. Transport costs will be borne by the sender.
Return the old devices with the note "for disposal" to:
Beckhoff Automation GmbH & Co. KG
Service Department
Stahlstraße 31
D-33415 Verl


Diagnosis

Diagnosis
Diagnosis
Additional information
•
IO-Link Events
•
ADS Error Codes


IO-Link Events

Diagnosis [image] IO-Link Events
IO-Link Events
Some of the IO-Link sensors forward events that occur to the master. These events may be items of information, warnings or error messages, e.g. short circuit or overheating.
The IO-Link master reports these events by setting the Device Diag bit. Further information on the events can be read via the CoE directory or the DiagHistory tab.
DiagHistory tab
The events are arranged according to type (information, warning, error), flag, occurrence of the event (time stamp) and message (port number & event code).
The meaning of the individual messages can be taken from the vendor documentation. The IO-Link device can be directly allocated on the basis of the port number. The events occurring can be managed using the various buttons.
▪
Update History: if the "Auto Update" field is not selected, then the current events can be displayed via the "Update History" button
▪
Auto Update: if this field is selected, then the list of events occurring is automatically updated
▪
Only new Messages: if this field is selected, then only those messages that have not yet been confirmed are displayed.
▪
Ack. Messages: an event that occurs is reported via the Device Diag. Confirming the message will reset the bit to 0.
▪
Export Diag History: the events that have occurred can be exported as a "txt" file and thus archived.
▪
Advanced: this field currently (as at 3rd quarter 2015) has no function.


ADS Error Codes

Diagnosis [image] ADS Error Codes
ADS Error Codes
Error codes are generated in the event of an error during ADS access to an IO-Link device.
The error code contains information about the error category, origin and instance. The possible error codes are listed in table „Error Codes“.
Additional information about a certain error (S_APP_DEV) is listed in table „Additional Code“:
Example of an AdsReturnCode
AdsReturnCode 0x80110700
80: Device Application Error (IO-Link Spec),
11: Index not Available (IO-Link Spec),
0700: General ADS Error
Error Codes (IO-Link Spec)
Type | Origin | Name | Category | Mode | Instance | Value (Hi Byte, hex) | Comment
PDU buffer overflow | remote | S_PDU_BUFFER | ERROR | SiNGLE SHOT | DL | 52 | Device buffer is too small for storing the complete PDU
PDU checksum error (master) | local | M_PDU_CHECK | ERROR | SiNGLE SHOT | DL | 56 | Calculated PDU checksum in master does not match actual received SPDU
PDU checksum error (device) | remote | S_PDU_CHECK | ERROR | SiNGLE SHOT | DL | 56 | Calculated PDU checksum in device does not match actual received SPDU
PDU flow control error | remote | S_PDU_FLOW | ERROR | SiNGLE SHOT | DL | 56 | Violation of flow control rule during transfer of SPDU between master and device
Illegal PDU service primitive (master) | local | M_PDU_ILLEGAL | ERROR | SiNGLE SHOT | AL | 57 | Unknown service primitive or wrong response e.g. Read Response on Write Request
Illegal PDU service primitive (device) | local / remote | S_PDU_ILLEGAL | ERROR | SiNGLE SHOT | AL | 58 | Unknown service primitive e.g. different protocol revision
Communication error | remote | COM_ERR |  | SiNGLE SHOT | unknown | 10 | Negative service response initiated by a communication error, e.g.. IO-Link connection interrupted
Device application error | remote | S_APP_DEV** | ERROR | SiNGLE SHOT | APP | 80 | Service PDU transferred, but not processed due to device error. See error details in Additional Code**
Additional Code (IO-Link Spec)
Type | Value (Lo Byte, hex) | Comment
No details | 00 | Device buffer is too small for storing the complete PDU
Index not available | 11 | Calculated PDU checksum in master does not match actual received SPDU
Subindex not available | 12 | Calculated PDU checksum in device does not match actual received SPDU
Service temporarily not available | 20 | Violation of flow control rule during transfer of SPDU between master and device
Service temporarily not available, local control | 21 | Unknown service primitive or wrong response e.g. Read Response on Write Request
Service temporarily not available, device control | 22 | Unknown service primitive e.g. different protocol revision
Access denied | 23 | Negative service response initiated by a communication error, eg. IO-Link connection interrupted
Parameter value out of range | 30 | Service PDU transferred, but not processed due to device error. See error details in Additional Code
Parameter value above limit | 31 | Service PDU transferred, but not processed due to device error. See error details in Additional Code
Parameter value below limit | 32 | Service PDU transferred, but not processed due to device error. See error details in Additional Code
Interfering parameter | 40 | Service PDU transferred, but not processed due to device error. See error details in Additional Code
Application failure | 81 | Service PDU transferred, but not processed due to device error. See error details in Additional Code
Application not ready | 82 | Service PDU transferred, but not processed due to device error. See error details in Additional Code


CoE parameters

CoE parameters
CoE parameters
Additional information
•
Object description and parameterization


Object description and parameterization

CoE parameters [image] Object description and parameterization
Object description and parameterization
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Parameterization via the CoE list (CAN over EtherCAT)
The EtherCAT device is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs). Please note the following general CoE notes when using/manipulating the CoE parameters:
- Keep a startup list if components have to be replaced
- Differentiation between online/offline dictionary, existence of current XML description
- use “CoE reload” for resetting changes
Introduction
The CoE overview contains objects for different intended applications:
▪
Objects required for parameterization during commissioning.
▪
Objects intended for regular operation, e.g. through ADS access.
▪
Objects for indicating internal settings (may be fixed).
▪
Profile specific objects, for exposition the status of the inputs and outputs.
The following section first describes the objects require for normal operation, followed by a complete overview of other objects.
Additional information
•
Objects for commissioning
•
Objects for regular operation
•
Standard objects (0x1000-0x1FFF)
•
Profile specific objects (0x6000-0xFFFF)


Objects for commissioning

CoE parameters [image] Object description and parameterization [image] Objects for commissioning
Objects for commissioning
Index 1011 Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default parameters | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" in the set value dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)
Index 80n0 IO Settings Ch.1 - 4 (for 0 ≤ n ≤ 3)
Index (hex) | Name | Meaning | Data type | Flags | Default
80n0:0 | IO Settings Ch.1- 4 | IO Settings Channel x | UINT8 | RW | 0x28 (40dez)
80n0:04 | Device ID | The device ID is used for validating the IO link device. | UINT32 | RW | 0x00000000 (0dez)
80n0:05 | VendorID | The vendor ID is used for validating the manufacturer of the IO link device. | UINT32 | RW | 0x00000000 (0dez)
80n0:20 | IO-Link Revision | ID of the specification version based on which the IO link device communicates. Bit 0-3: MinorRev Bit 4-7: MajorRev | UINT8 | RW | 0x00 (0dez)
80n0:21 | Frame capability | The Frame capability indicates certain functionalities of the IO link device (e.g. SPDU supported). Bit 0: SPDU Bit 1: Type1 Bit 7: PHY1 | UINT8 | RW | 0x00 (0dez)
80n0:22 | Min cycle time | The cycle time refers to the communication between the IO link master and the IO link device. This value is transferred in the IO link format for Min Cycle Time. Bit 6 und 7: Time Base Bit 0 to 5: Multiplier 0x00: The IO-Link master automatically uses the smallest possible update time of the IO-Link device. | UINT8 | RW | 0x00 (0dez)
80n0:23 | Offset time | reserved | UINT8 | RW | 0x00 (0dez)
80n0:24 | Process data in length | These parameters are transferred in the IO link format for "Process data in length". Bit 7: BYTE (indicates whether the value in LENGTH interpreted as bit length [bit not set] or as byte length + 1 [bit set] Bit 6: SIO (indicates whether the device supports the standard IO mode [bit set]) Bit 0 to 4: LENGTH (length of the process data) | UINT8 | RW | 0x00 (0dez)
Index (hex) | Name | Meaning | Data type | Flags | Default
80n0:25 | Process data out length | These parameters are transferred in the IO link format for "Process data out length". Bit 7: BYTE (indicates whether the value in LENGTH interpreted as bit length [bit not set] or as byte length + 1 [bit set] Bit 6: SIO (indicates whether the device supports the standard IO mode [bit set]) Bit 0 to 4: LENGTH (length of the process data) | UINT8 | RW | 0x00 (0dez)
80n0:26 | Compatible ID | reserved | UINT16 | RW | 0x0000 (0dez)
80n0:27 | Reserved | reserved | UINT16 | RW | 0x0000 (0dez)
80n0:28 | Master Control | 0: IO link port inactive 1: IO link port as digital input port 2: IO link port as digital output port 3: IO link port in communication via the IO link protocol 4:IO link port in communication via the IO link protocol. IO link state is ComStop (none cyclic communication, data are exchanged on demand). | UINT16 | RW | 0x0000 (0dez)


Objects for regular operation

CoE parameters [image] Object description and parameterization [image] Objects for regular operation
Objects for regular operation
In normal functional range the EL6224 has no such objects.
Complete overview


Standard objects (0x1000-0x1FFF)

CoE parameters [image] Object description and parameterization [image] Standard objects (0x1000-0x1FFF)
Standard objects (0x1000-0x1FFF)
The standard objects of all EtherCAT slaves have the same meaning.
Index 1000 Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device Type of the EtherCAT slave: The Lo-Word contains the supported CoE Profile (5001). The Hi-Word contains the Module Profile corresponding to the Modular Device Profile. | UINT32 | RO | 0x184C1389 (407638921dez)
Index 1008 Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EP6224
Index 1009 Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slaves | STRING | RO | 01
Index 100A Software version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slaves | STRING | RO | 01
Index 1018 Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | contains informations to identify the EtherCAT slave | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x18503052 (407908434dez)
1018:03 | Revision | Revision number of the EtherCAT-Slave, the Lo-Word (Bit 0-15) indicates the special functions terminal number; the Hi-Word (Bit 16-31) refers to the device description. | UINT32 | RO | 0x00100000 (1048576dez)
1018:04 | Serial number | Serial number of the EtherCAT-Slave, the Lo-Byte (Bit 0-7) of the Lo-Word contains the year of manufacturing, the Hi-Byte (Bit 8-15) of the Lo-Word contains the week of manufacturing, the Hi-Word (Bit 16-31) is 0 . | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | contains informations for the standardized Upload and Download of the Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksum over all backup entries | UINT32 | RO | 0x00000000 (0dez)
Index 1600 IO RxPDOPDO-Map Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1600:0 | IO RxPDOPDO-Map Ch.1 | PDO Mapping RxPDO 1 | UINT8 | RW | 0x01 (1dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
Index 1601 IO RxPDOPDO-Map Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1601:0 | IO RxPDOPDO-Map Ch.2 | PDO Mapping RxPDO 2 | UINT8 | RW | 0x01 (1dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
Index 1602 IO RxPDOPDO-Map Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1602:0 | IO RxPDOPDO-Map Ch.3 | PDO Mapping RxPDO 3 | UINT8 | RW | 0x01 (1dez)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
Index 1603 IO RxPDOPDO-Map Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
1603:0 | IO RxPDOPDO-Map Ch.4 | PDO Mapping RxPDO 4 | UINT8 | RW | 0x01 (1dez)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
Index 1A00 IO TxPDOPDO-Map Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A00:0 | IO TxPDOPDO-Map Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RW | 0x01 (1dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
Index 1A01 IO TxPDOPDO-Map Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A01:0 | IO TxPDOPDO-Map Ch.2 | PDO Mapping TxPDO 2 | UINT8 | RW | 0x01 (1dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
Index 1A02 IO TxPDOPDO-Map Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1A02:0 | IO TxPDOPDO-Map Ch.3 | PDO Mapping TxPDO 3 | UINT8 | RW | 0x01 (1dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
Index 1A03 IO TxPDOPDO-Map Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
1A03:0 | IO TxPDOPDO-Map Ch.4 | PDO Mapping TxPDO 4 | UINT8 | RW | 0x01 (1dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
Index 1A04 TxPDOeState TxPDO-Map Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1A04:0 | TxPDOeState TxPDO-Map Device | PDO Mapping TxPDO 5 | UINT8 | RW | 0x04 (4dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF100 (Diagnosis Status data), entry 0x01 (State Ch1)) | UINT32 | RW | 0xF100:01, 8
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF100 (Diagnosis Status data), entry 0x02 (State Ch2)) | UINT32 | RW | 0xF100:02, 8
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF100 (Diagnosis Status data), entry 0x03 (State Ch3)) | UINT32 | RW | 0xF100:03, 8
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF100 (Diagnosis Status data), entry 0x04 (State Ch4)) | UINT32 | RW | 0xF100:04, 8
Index 1C00Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Usage of the Sync Manager channels | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x04 (4dez)
1C12:01 | SubIndex 001 | 1. assigned RxPDO (contains the index of the corresponding RxPDO Mapping object) | UINT16 | RW | 0x1600 (5632dez)
1C12:02 | SubIndex 002 | 2. assigned RxPDO (contains the index of the corresponding RxPDO Mapping object) | UINT16 | RW | 0x1601 (5633dez)
1C12:03 | SubIndex 003 | 3. assigned RxPDO (contains the index of the corresponding RxPDO Mapping object) | UINT16 | RW | 0x1602 (5634dez)
1C12:04 | SubIndex 004 | 4. assigned RxPDO (contains the index of the corresponding RxPDO Mapping object) | UINT16 | RW | 0x1603 (5635dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x05 (5dez)
1C13:01 | SubIndex 001 | 1. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | SubIndex 002 | 2. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A01 (6657dez)
1C13:03 | SubIndex 003 | 3. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A02 (6658dez)
1C13:04 | SubIndex 004 | 4. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A03 (6659dez)
1C13:05 | SubIndex 005 | 5. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object)) | UINT16 | RW | 0x1A04 (6660dez)
Index 1C32 SM output parameter
Index (hex) | Name | Meaning | Data type | Flags | Default
1C32:0 | SM output parameter | Synchronization parameter of the outputs | UINT8 | RO | 0x20 (32dez)
1C32:01 | Sync mode | actual synchronization mode: 0: Free Run 1: Synchron with SM 2 Event 2: DC-Mode - Synchron with SYNC0 Event 3: DC-Mode - Synchron with SYNC1 Event | UINT16 | RW | 0x0000 (0dez)
1C32:02 | Cycle time | Cycle time (in ns): Free Run: cycle time of the local timer Synchron with SM 2 Event: Cycle time of the master DC-Mode: SYNC0/SYNC1 Cycle time | UINT32 | RW | 0x000186A0 (100000dez)
1C32:03 | Shift time | Time between SYNC0 Event and Outputs Valid (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C32:04 | Sync modes supported | Supported synchronization modes: Bit 0 = 1: Free Run is supported Bit 1 = 1: Synchron with SM 2 Event is supported Bit 2-3 = 01: DC-Mode is supported Bit 4-5 = 10: Output Shift with SYNC1 Event (only DC-Mode) Bit 14 = 1: dynamic times (could be measured Messen by writing 1C32:08) | UINT16 | RO | 0xC007 (49159dez)
1C32:05 | Minimum cycle time | Minimum cycle time supported (in ns) | UINT32 | RO | 0x000186A0 (100000dez)
1C32:06 | Calc and copy time | Minimal time between SYNC0 and SYNC1 Event (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C32:08 | Command | 0: Measurement of the times will be stopped 1: Measurement of the times will be started The Entries 1C32:03, 1C32:05, 1C32:06, 1C32:09, 1C33:03, 1C33:06, 1C33:09 will be updated with the maximum measured values. | UINT16 | RW | 0x0000 (0dez)
1C32:09 | Delay time | Time between SYNC1 Event and Outputs Valid (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C32:0B | SM event missed counter | Number of the missed SM-Events in state OPERATIONAL (only in DC Mode) | UINT16 | RO | 0x0000 (0dez)
1C32:0C | Cycle exceeded counter | Number of the exceeded cycles in state OPERATIONAL | UINT16 | RO | 0x0000 (0dez)
1C32:0D | Shift too short counter | Number of the too short distances between SYNC0 and SYNC1 Event (only in DC Mode) | UINT16 | RO | 0x0000 (0dez)
1C32:20 | Sync error | TRUE: In the last cycle the synchronization was not correct (only in DC Mode) | BOOLEAN | RO | 0x00 (0dez)
Index 1C33 SM input parameter
Index (hex) | Name | Meaning | Data type | Flags | Default
1C33:0 | SM input parameter | Synchronization parameter of the inputs | UINT8 | RO | 0x20 (32dez)
1C33:01 | Sync mode | actual synchronization mode: 0: Free Run 1: Synchron with SM 3 Event (no Outputs available) 2: DC - Synchron with SYNC0 Event 3: DC - Synchron with SYNC1 Event 34: Synchron with SM 2 Event (Outputs available) | UINT16 | RW | 0x0000 (0dez)
1C33:02 | Cycle time | same as 1C32:02 | UINT32 | RW | 0x000186A0 (100000dez)
1C33:03 | Shift time | time between SYNC0-Event and Input Latch (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:04 | Sync modes supported | Supported synchronization modes: Bit 0: Free Run is supported Bit 1: Synchron with SM 2 Event is supported (Outputs available) Bit 1: Synchron with SM 3 Event is supported (no Outputs available) Bit 2-3 = 01: DC-Mode is supported Bit 4-5 = 01: Input Shift with local event (Outputs available) Bit 4-5 = 10: Input Shift with SYNC1 Event (no Outputs available) Bit 14 = 1: dynamic times (could be measured Messen by writing 1C32:08 or 1C33:08) | UINT16 | RO | 0xC007 (49159dez)
1C33:05 | Minimum cycle time | same as 1C32:05 | UINT32 | RO | 0x000186A0 (100000dez)
1C33:06 | Calc and copy time | time between Input Latch and the availability of the inputs for the master (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:08 | Command | same as 1C32:08 | UINT16 | RW | 0x0000 (0dez)
1C33:09 | Delay time | time between SYNC1-Event and Input Latch (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:0B | SM event missed counter | same as 1C32:11 | UINT16 | RO | 0x0000 (0dez)
1C33:0C | Cycle exceeded counter | same as 1C32:12 | UINT16 | RO | 0x0000 (0dez)
1C33:0D | Shift too short counter | same as 1C32:13 | UINT16 | RO | 0x0000 (0dez)
1C33:20 | Sync error | same as 1C32:32 | BOOLEAN | RO | 0x00 (0dez)


Profile specific objects (0x6000-0xFFFF)

CoE parameters [image] Object description and parameterization [image] Profile specific objects (0x6000-0xFFFF)
Profile specific objects (0x6000-0xFFFF)
The profile specific objects have the same meaning for all EtherCAT Slaves which support the profile 5001.
Index 60n0 IO Inputs Ch.1 - 4 (for 0 ≤ n ≤ 3)
Index (hex) | Name | Meaning | Data type | Flags | Default
60n0:0 | IO Inputs Ch.1 - 4 | Max. Subindex | UINT8 | RO | 0x00 (0dez)
60n0:01 | Subindex 001 | IO-Link input process data |  |  |
... | ... | ... |  |  |
60n0:10 | Subindex 016 | IO-Link input process data |  |  |
Index 70n0 IO Outputs Ch.1 - 4 (for 0 ≤ n ≤ 3)
Index (hex) | Name | Meaning | Data type | Flags | Default
70n0:0 | IO Outputs Ch.1 - 4 | Max. Subindex | UINT8 | RO | 0x00 (0dez)
70n0:01 | Subindex 001 | IO-Link output process data |  |  |
... | ... | ... |  |  |
70n0:10 | Subindex 016 | IO-Link output process data |  |  |
Index 90n0 IO Info data Ch.1 - 4 (for 0 ≤ n ≤ 3)
Index (hex) | Name | Meaning | Data type | Flags | Default
90n0:0 | IO Info data Ch.1 - 4 | Max. Subindex | UINT8 | RO | 0x27 (39dez)
90n0:04 | Device ID | The device ID is used for validating the IO link device. | UINT32 | RO | 0x00000000 (0dez)
90n0:05 | VendorID | The vendor ID is used for validating the manufacturer of the IO link device. | UINT32 | RO | 0x00000000 (0dez)
90n0:07 | IO-Link revision | ID of the specification version based on which the IO link device communicates. Bit 0-3: MinorRev Bit 4-7: MajorRev | UINT8 | RO | 0x00 (0dez)
90n0:20 | FrameCapability | The Frame Capability indicates certain functionalities of the IO link device (e.g. SPDU supported). Bit 0: SPDU Bit 1: Type1 Bit 7: PHY1 | UINT8 | RO | 0x00 (0
90n0:21 | Min cycle time | The cycle time refers to the communication between the IO link master and the IO link device. This value is transferred in the IO link format for Min Cycle Time. Bit 6 und 7: Time Base Bit 0 to 5: Multiplier | UINT8 | RO | 0x00 (0dez)
90n0:22 | Offset time | reserved | UINT8 | RO | 0x00 (0dez)
90n0:23 | Process data in length | These parameters are transferred in the IO link format for "Process data in length". Bit 7: BYTE (indicates whether the value in LENGTH interpreted as bit length [bit not set] or as byte length + 1 [bit set] Bit 6: SIO (indicates whether the device supports the standard IO mode [bit set]) Bit 0 bis 4: LENGTH (length of the process data) | UINT8 | RO | 0x00 (0dez)
90n0:24 | Process data out length | These parameters are transferred in the IO link format for "Process data out length". Bit 7: BYTE (indicates whether the value in LENGTH interpreted as bit length [bit not set] or as byte length + 1 [bit set] Bit 6: SIO (indicates whether the device supports the standard IO mode [bit set]) Bit 0 bis 4: LENGTH (length of the process data) | UINT8 | RO | 0x00 (0dez)
90n0:26 | Reserved | reserved | UINT16 | RO | 0x0000 (0dez)
90n0:27 | Reserved2 | reserved | UINT16 | RO | 0x0000 (0dez)
Index A0n0 IO Diag data Ch.1 - 4 (for 0 ≤ n ≤ 3)
Index (hex) | Name | Meaning | Data type | Flags | Default
A0n0:0 | IO Diag data Ch.1 - 4 | Max. Subindex | UINT8 | RO | 0x02 (2dez)
A0n0:01 | IO-Link State | The value of the IO link state corresponds to a state from the IO link master state machine 0: INACTIVE 1: DIGINPUT 2: DIGOUTPUT 3: ESTABLISHCOMM 4: INITMASTER 5: INITDEVICE 7: PREOPERATE 8: OPERATE 9: STOP | UINT8 | RO | 0x00 (0dez)
A0n0:02 | Lost Frames | This parameter counts the number of lost IO link telegrams. This value is deleted whenever IO link starts up, otherwise it is incremented continuously. | UINT8 | RO | 0x00 (0dez)
Index F000 Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information about the Modular Device Profile | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Index distance between the objects of two channels | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0004 (4dez)
Index F008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list | Max. Subindex | UINT8 | RW | 0x04 (4dez)
F010:01 | SubIndex 001 | - | UINT32 | RW | 0x0000184C (6220dez)
F010:02 | SubIndex 002 | - | UINT32 | RW | 0x0000184C (6220dez)
F010:03 | SubIndex 003 | - | UINT32 | RW | 0x0000184C (6220dez)
F010:04 | SubIndex 004 | - | UINT32 | RW | 0x0000184C (6220dez)
Index F100 Diagnosis Status data
Index (hex) | Name | Meaning | Data type | Flags | Default
F100:0 | Diagnosis Status data | Max. Subindex | UINT8 | RO | 0x04 (4dez)
F100:01 | State Ch1 | Statusbyte Ch. 1 | UINT8 | RO | 0x00 (0dez)
F100:02 | State Ch2 | Statusbyte Ch. 2 | UINT8 | RO | 0x00 (0dez)
F100:03 | State Ch3 | Statusbyte Ch. 3 | UINT8 | RO | 0x00 (0dez)
F100:04 | State Ch4 | Statusbyte Ch. 4 | UINT8 | RO | 0x00 (0dez)
Index F900 Info data
Index (hex) | Name | Meaning | Data type | Flags | Default
F900:0 | Info data | Max. Subindex | UINT8 | RO | 0x09 (9dez)
F900:01 | IO-Link Version | - | UINT8 | RO | 0x10 (16dez)


Appendix

Appendix
Appendix
Additional information
•
General operating conditions
•
EtherCAT Box- / EtherCAT P Box - Accessories
•
Version identification of EtherCAT devices
•
Support and Service


General operating conditions

Appendix [image] General operating conditions
General operating conditions
Protection degrees (IP-Code)
The standard IEC 60529 (DIN EN 60529) defines the degrees of protection in different classes.
1. Number: dust protection and touch guard | Definition
0 | Non-protected
1 | Protected against access to hazardous parts with the back of a hand. Protected against solid foreign objects of Ø 50 mm
2 | Protected against access to hazardous parts with a finger. Protected against solid foreign objects of Ø 12.5 mm.
3 | Protected against access to hazardous parts with a tool. Protected against solid foreign objects Ø 2.5 mm.
4 | Protected against access to hazardous parts with a wire. Protected against solid foreign objects Ø 1 mm.
5 | Protected against access to hazardous parts with a wire. Dust-protected. Intrusion of dust is not totally prevented, but dust shall not penetrate in a quantity to interfere with satisfactory operation of the device or to impair safety.
6 | Protected against access to hazardous parts with a wire. Dust-tight. No intrusion of dust.
2. Number: water* protection | Definition
0 | Non-protected
1 | Protected against water drops
2 | Protected against water drops when enclosure tilted up to 15°.
3 | Protected against spraying water. Water sprayed at an angle up to 60° on either side of the vertical shall have no harmful effects.
4 | Protected against splashing water. Water splashed against the disclosure from any direction shall have no harmful effects
5 | Protected against water jets
6 | Protected against powerful water jets
7 | Protected against the effects of temporary immersion in water. Intrusion of water in quantities causing harmful effects shall not be possible when the enclosure is temporarily immersed in water for 30 min. in 1 m depth.
*) These protection classes define only protection against water!
Chemical Resistance
The Resistance relates to the Housing of the IP 67 modules and the used metal parts. In the table below you will find some typical resistance.
Character | Resistance
Steam | at temperatures >100°C: not resistant
Sodium base liquor (ph-Value > 12) | at room temperature: resistant > 40°C: not resistant
Acetic acid | not resistant
Argon (technical clean) | resistant
Key
▪
resistant: Lifetime several months
▪
non inherently resistant: Lifetime several weeks
▪
not resistant: Lifetime several hours resp. early decomposition


EtherCAT Box- / EtherCAT P Box - Accessories

Appendix [image] EtherCAT Box- / EtherCAT P Box - Accessories
EtherCAT Box- / EtherCAT P Box - Accessories
Fixing
Ordering information | Description
ZS5300-0001 | Mounting rail (500 mm x 129 mm)
Marking material, plugs
Ordering information | Description
ZS5000-0000 | Fieldbus Box set M8 (contact labels, plugs)
ZS5000-0002 | Fieldbus Box set M12 (contact labels, plugs)
ZS5000-0010 | plugs M8, IP67 (50 pieces)
ZS5000-0020 | plugs M12, IP67 (50 pieces)
ZS5100-0000 | marking labels, not printed, 4 stripes at 10 pieces
ZS5100-xxxx | printed marking labels, on request
Tools
Ordering information | Description
ZB8800 | torque wrench for M8 cables with knurl, incl. ratchet
ZB8800-0001 | M12 ratchet for torque wrench ZB8800
ZB8800-0002 | M8 ratchet (field assembly) for torque wrench ZB8800
ZB8801-0000 | torque wrench for hexagonal plugs, adjustable
ZB8801-0001 | torque cable key, M8/wrench size 9, for torque wrench ZB8801-0000
ZB8801-0002 | torque cable key, M12/wrench size 13, for torque wrench ZB8801-0000
ZB8801-0003 | torque cable key, M12 field assembly/wrench size 13, for torque wrench ZB8801-0000
Further accessories
Further accessories may be found at the price list for Beckhoff fieldbus components and at the internet under https://www.beckhoff.com


Version identification of EtherCAT devices

Appendix [image] Version identification of EtherCAT devices
Version identification of EtherCAT devices
Designation
A Beckhoff EtherCAT device has a 14-digit designation, made up of
▪
family key
▪
type
▪
version
▪
revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
Notes
▪
The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
▪
EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
▪
The order identifier is made up of
- family key (EL, EP, CU, ES, KL, CX, etc.)
- type (3314)
- version (-0000)
▪
The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
▪
The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Identification number
Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:
Production lot/batch number/serial number/date code/D number
The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02
Exceptions can occur in the IP67 area, where the following syntax can be used (see respective device documentation):
Syntax: D ww yy x y z u
D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB
Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1
Unique serial number/ID, ID number
In addition, in some series each individual module has its own unique serial number.
See also the further documentation in the area
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Terminals with factory calibration certificate and other measuring terminals
Examples of markings
EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
CU2016 switch with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
EP1258-00001 IP67 EtherCAT Box with batch number/ date code 22090101 and unique serial number 158102
EP1908-0002 IP67 EtherCAT Safety Box with batch number/ date code 071201FF and unique serial number 00346070
EL2904 IP20 safety terminal with batch number/ date code 50110302 and unique serial number 00331701
ELM3604-0002 terminal with unique ID number (QR code) 100001051 and serial/ batch number 44160201
Additional information
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Appendix [image] Version identification of EtherCAT devices [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com


Ports

IO-Link master principles [image] Ports
Ports
Two classes of IO-Link ports are defined in the IO-Link specification:
Class A ports
Class A ports are intended for the connection of IO-Link devices of the type sensor.
Contacts of a class A port:
▪
Supply voltage for the IO-Link device: L+, L-
▪
Data line for serial communication or switching signals: C/Q
▪
Data line for switching signals (optional): DI/DQ
Class B ports
Class B ports are intended for the connection of IO-Link devices of the type actuator.
Contacts of a class B port:
▪
Two electrically isolated supply voltages for the IO-Link device:
–
Sensor/logic supply: L+, L-
–
Actuator supply: P24, N24
▪
Data line for serial communication or switching signals: C/Q


Topology

IO-Link master principles [image] Topology
Topology
The IO-Link master serves as a gateway between an automation system (EtherCAT) and the IO-Link devices. It has several IO-Link ports, to each of which an IO-Link device can be connected.
IO-Link Grundlagen Beispiel
IO-Link topology


„Data storage“ function

IO-Link master principles [image] „Data storage“ function
„Data storage“ function
The IO-Link Master supports the „Data storage“ function. It can save a non-volatile copy of the parameters of connected devices.
If a device fails, its parameters remain in the memory of the IO-Link Master.
If a defective device is replaced by a new, identical device, the master can automatically parameterize the new device with the stored parameters.