EP6224 - IO-Link Master with protection class IP67
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC®and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents:
EP1590927, EP1789857, DE102004044764, DE102007017835
with corresponding applications or registrations in various other countries.
The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of symbols
In this documentation the following symbols are used with an accompanying safety instruction or note. The safety instructions must be read carefully and followed without fail!
DANGER
Serious risk of injury!
Failure to follow the safety instructions associated with this symbol directly endangers the life and health of persons.
WARNING
Risk of injury!
Failure to follow the safety instructions associated with this symbol endangers the life and health of persons.
CAUTION
Personal injuries!
Failure to follow the safety instructions associated with this symbol can lead to injuries to persons.
Attention
Damage to the environment or devices
Failure to follow the instructions associated with this symbol can lead to damage to the environment or equipment.
Note
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Changes
1.1.1
▪
EP6224 Module overview updated
1.1.0
▪
Power Connection updated
1.0.0
▪
first publication
0.6
▪
corrections
0.5
▪
first preliminary version
Firm and hardware version
The documentation refers to the firm and hardware status that was valid at the time it was prepared.
The properties of the modules are subject to continuous development and improvement. Modules having earlier production statuses cannot have the same properties as modules with the latest status. Existing properties, however, are always retained and are not changed, so that these modules can always be replaced by new ones.
The firmware and hardware version (delivery state) can be found in the batch number (D number) printed at the side of the IO-Link box module.
Syntax of the batch number (D number)
D: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with D No. 29 10 02 01:
29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01


EtherCAT Box - Introduction

EtherCAT Box - Introduction
EtherCAT Box - Introduction
The EtherCAT system has been extended with EtherCAT Box modules with protection class IP 67. Through the integrated EtherCAT interface the modules can be connected directly to an EtherCAT network without an additional Coupler Box. The high-performance of EtherCAT is thus maintained into each module.
The extremely low dimensions of only 126 x 30 x 26.5 mm (h x w x d) are identical to those of the Fieldbus Box extension modules. They are thus particularly suitable for use where space is at a premium. The small mass of the EtherCAT modules facilitates applications with mobile I/O interface (e.g. on a robot arm). The EtherCAT connection is established via screened M8 connectors.
EtherCAT Box Modules within an EtherCAT network
The robust design of the EtherCAT Box modules enables them to be used directly at the machine. Control cabinets and terminal boxes are now no longer required. The modules are fully sealed and therefore ideally prepared for wet, dirty or dusty conditions.
Pre-assembled cables significantly simplify EtherCAT and signal wiring. Very few wiring errors are made, so that commissioning is optimized. In addition to pre-assembled EtherCAT, power and sensor cables, field-configurable connectors and cables are available for maximum flexibility. Depending on the application, the sensors and actuators are connected through M8 or M12 connectors.
The EtherCAT modules cover the typical range of requirements for I/O signals with protection class IP67:
▪
digital inputs with different filters (3.0 ms or 10 μs)
▪
digital outputs with 0.5 or 2 A output current
▪
analog inputs and outputs with 16 bit resolution
▪
Thermocouple and RTD inputs
▪
Stepper motor modules
XFC (eXtreme Fast Control Technology) modules, including inputs with time stamp, are also available.
EtherCAT Box with M8 connections for sensors/actuators
EtherCAT Box with M12 connections for sensors/actuators
Note
Basic EtherCAT documentation
You will find a detailed description of the EtherCAT system in the Basic System Documentation for EtherCAT, which is available for download from our website (www.beckhoff.com) under Downloads.
Note
XML files
You will find XML files (XML Device Description Files) for Beckhoff EtherCAT modules on our website (www.beckhoff.com) under Downloads, in the Configuration Files area.


Product overview

Product overview
Product overview
Additional information
•
EP6224 Module overview
•
EPI1008


EP6224 Module overview

Product overview [image] EP6224 Module overview
EP6224 Module overview
IO-Link Master
Module | Signal connection | IO-Link interfaces | Specification version | Comment
EP6224-2022 | 4 x M12 | 4 | IO-Link V1.1, Class A | wide body
EP6224-3022 | 4 x M12 | 4 | IO-Link V1.1, Class B | wide body


EPI1008

Product overview [image] EPI1008
EPI1008
Additional information
•
EP6224-x022 - Introduction
•
EP6224-x022 - Technical Data
•
EP6224-x022 - Process image


EP6224-x022 - Introduction

Product overview [image] EPI1008 [image] EP6224-x022 - Introduction
EP6224-x022 - Introduction
EP6224-2022
EP6224-3022
IO-Link master
The EP6224 IO-Link module enables connection of up to four IO-Link devices, e.g. actuators, sensors, combinations of both or the EPIxxxx modules from Beckhoff. A point-to-point connection is used between the module and the device. IO-Link is designed as an intelligent link between the fieldbus level and the sensor, wherein parameterisation information can be exchanged bidirectionally via the IO-Link connection. The parameterisation of the IO-Link devices with service data can be done from TwinCAT via ADS or System Manager.
In the standard setting, the EP6224 functions as a 4-channel input module, 24 V DC, which communicates with connected IO-Link devices, parameterises them and, if necessary, changes their operating mode. Beckhoff offers with the EP6224-2022 a class A master and with the EP6224-3022 a class B master.
Quick Links
Dimensions
Commissioning/Configuration IO-Link master


EP6224-x022 - Technical Data

Product overview [image] EPI1008 [image] EP6224-x022 - Technical Data
EP6224-x022 - Technical Data
Technical data | EP6224-2022 | EP6224-3022
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Data transfer rates | 4.8 kBaud (COM 1), 38.4 kBaud (COM 2), 230.4 kBaud (COM 3)
IO-Link connection | 1 x M12 socket, a-coded
IO-Link interfaces | 4
Specification version | IO-Link V1.1, Class A | IO-Link V1.1, Class B
Nominal input voltage | 24 VDC (-15%/+20%)
Cable length (IO-Link) | max. 20 m
Sensor supply | 24 V DC, 1.4 A, for all 4 ports, port class A | 24 V DC, 1.4 A, for all 4 ports, port class B
Current consumption from US (without sensor current) | typ. 130 mA + load
Power supply connection | Feed: 1 x M8 male socket, 4-pin; downstream connection: 1 x M8 female socket, 4-pin
Electrical isolation | 500 V
Weight | approx. 250 g
Permissible ambient temperature during operation | 0°C ... +55°C
Permissible ambient temperature during storage | -25°C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable
Approvals | CE


EP6224-x022 - Process image

Product overview [image] EPI1008 [image] EP6224-x022 - Process image
EP6224-x022 - Process image
Channel 1 to Channel 4
The EtherCAT box EP6224-x022 contains 4 IO-Link ports. You can also connect one IO-Link device at one IO-Link Port. In the figure below, you can see as an example the process image of the EP6224-2022. If a digital input module is connected to the Channel 1, the inputs of this IO-Link device are listed in the process image under IO Inputs Channel 1.
EP6224-x022, Process image


Basic communication principles - EtherCAT

Basic communication principles - EtherCAT
Basic communication principles - EtherCAT
Additional information
•
Configuration via TwinCAT – explanation tabs
•
Restoring the delivery state of an EtherCAT device
•
EtherCAT state machine


Configuration via TwinCAT – explanation tabs

Basic communication principles - EtherCAT [image] Configuration via TwinCAT – explanation tabs
Configuration via TwinCAT – explanation tabs
In the left-hand window of the TwinCAT System Manager, click on the branch of the IO-Link box you wish to configure.
Branch of the IO-Link box to be configured
In the right-hand window of the TwinCAT System manager, various tabs are now available for configuring the IO-Link box.
General tab
General tab
Name | Name of the IO-Link master
Id | Number of the IO-Link master
Type | IO-Link master type
Comment | Here you can add a comment (e.g. regarding the system).
Disabled | Here you can deactivate the IO-Link master.
Create symbols | Access to this IO-Link master via ADS is only available if this control box is activated.
EtherCAT tab
EtherCAT tab
Type | IO-Link master device type
Product/Revision | Product and revision number of the IO-Link master
Auto Inc Addr. | Auto increment address of the IO-Link master. The auto increment address can be used for addressing each EtherCAT device or each IO-Link master in the communication ring through its physical position. Auto increment addressing is used during the start-up phase when the IO-Link master allocates addresses to the EtherCAT devices or IO-Link masters. With auto increment addressing the first EtherCAT device in the ring has the address 0000hex. For each further slave the address is decremented by 1 (FFFFhex, FFFEhex etc.).
EtherCAT Addr. | Fixed address of an EtherCAT device/IO-Link master. This address is allocated by the EtherCAT device/IO-Link master during the start-up phase. Tick the control box to the left of the input field in order to modify the default value.
Previous Port | Name and port of the EtherCAT device/IO-Link master to which this device is connected. If it is possible to connect this device with another one without changing the order of the EtherCAT devices/IO-Link masters in the communication ring, then this combination field is activated and the EtherCAT device or the IO-Link master to which this device is to be connected can be selected.
Advanced Settings | This button opens the dialogs for advanced settings.
The link at the bottom of the tab points to the product page for this IO-Link master on the web.
Process Data tab
Indicates the configuration of the process data. The input and output data of the IO-Link master are represented as CANopen process data objects (PDO). The user can select a PDO via PDO assignment and modify the content of the individual PDO via this dialog, if the IO-Link master supports this function.
Process Data tab
Sync Manager
Lists the configuration of the Sync Manager (SM).
If the IO-Link master has a mailbox, SM0 is used for the mailbox output (MbxOut) and SM1 for the mailbox input (MbxIn).
SM2 is used for the output process data (outputs) and SM3 (inputs) for the input process data.
If an input is selected, the corresponding PDO assignment is displayed in the PDO Assignment list below.
PDO Assignment
PDO assignment of the selected Sync Manager. All PDOs defined for this Sync Manager type are listed here:
▪
If the output Sync Manager (outputs) is selected in the Sync Manager list, all RxPDOs are displayed.
▪
If the input Sync Manager (inputs) is selected in the Sync Manager list, all TxPDOs are displayed.
The selected entries are the PDOs involved in the process data transfer. In the tree diagram of the System Manager these PDOs are displayed as variables of the IO-Link master. The name of the variable is identical to the Name parameter of the PDO, as displayed in the PDO list. If an entry in the PDO assignment list is deactivated (not selected and greyed out), this indicates that the input is excluded from the PDO assignment. In order to be able to select a greyed out PDO, the currently selected PDO has to be deselected first.
Note
Activation of PDO assignment
•
the IO-Link master has to run through the PS status transition cycle (from pre-operational to safe-operational) once (see Online tab),
•
and the System Manager has to reload the IO-Link master ( [image] button)
PDO list
List of all PDOs supported by this IO-Link master. The content of the selected PDOs is displayed in the PDO Content list. The PDO configuration can be modified by double-clicking on an entry.
Column | Description
Index | PDO index.
Size | Size of the PDO in bytes.
Name | Name of the PDO. If this PDO is assigned to a Sync Manager, it appears as a variable of the slave with this parameter as the name.
Flags | F | Fixed content: The content of this PDO is fixed and cannot be changed by the System Manager.
 | M | Mandatory PDO. This PDO is mandatory and must therefore be assigned to a Sync Manager! Consequently, this PDO cannot be deleted from the PDO Assignment list
SM | Sync Manager to which this PDO is assigned. If this entry is empty, this PDO does not take part in the process data traffic.
SU | Sync unit to which this PDO is assigned.
PDO Content
Indicates the content of the PDO. If flag F (fixed content) of the PDO is not set the content can be modified.
Download
If the device is intelligent and has a mailbox, the configuration of the PDO and the PDO assignments can be downloaded to the device. This is an optional feature that is not supported by all IO-Link masters.
PDO Assignment
If this check box is selected, the PDO assignment that is configured in the PDO Assignment list is downloaded to the device on startup. The required commands to be sent to the device can be viewed in the Startup tab.
PDO Configuration
If this check box is selected, the configuration of the respective PDOs (as shown in the PDO list and the PDO Content display) is downloaded to the IO-Link master.
Startup tab
The Startup tab is displayed if the IO-Link master has a mailbox and supports the CANopen over EtherCAT (CoE) or Servo drive over EtherCAT protocol. This tab indicates which download requests are sent to the mailbox during startup. It is also possible to add new mailbox requests to the list display. The download requests are sent to the master in the same order as they are shown in the list.
Startup tab
Column
Description
Transition
Transition to which the request is sent. This can either be
▪
the transition from pre-operational to safe-operational (PS), or
▪
the transition from safe-operational to operational (SO).
If the transition is enclosed in "<>" (e.g. <PS>), the mailbox request is fixed and cannot be modified or deleted by the user.
Protocol
Type of mailbox protocol
Index
Index of the object
Data
Date on which this object is to be downloaded.
Comment
Description of the request to be sent to the mailbox
Move Up | This button moves the selected request up by one position in the list.
Move Down | This button moves the selected request down by one position in the list.
New | This button adds a new mailbox download request to be sent during startup.
Delete | This button deletes the selected entry.
Edit | This button edits an existing request.
CoE - Online tab
The additional CoE - Online tab is displayed if the IO-Link master supports the CANopen over EtherCAT (CoE) protocol. This dialog lists the content of the object list of the slave (SDO upload) and enables the user to modify the content of an object from this list. Details for the objects of the individual IO-Link devices can be found in the device-specific object descriptions.
CoE - Online tab
Object list display
Column | Description
Index | Index and sub-index of the object
Name | Name of the object
Flags | RW | The object can be read, and data can be written to the object (read/write)
 | RO | The object can be read, but no data can be written to the object (read only)
 | P | An additional P identifies the object as a process data object.
Value | Value of the object
Update List | The Update list button updates all objects in the displayed list
Auto Update | If this check box is selected, the content of the objects is updated automatically.
Advanced | The Advanced button opens the Advanced Settings dialog. Here you can specify which objects are displayed in the list.
Advanced Settings
Online - via SDO Information | If this option button is selected, the list of the objects included in the object list of the device is uploaded from the master via SDO information. The list below can be used to specify which object types are to be uploaded.
Offline - via EDS File | If this option button is selected, the list of the objects included in the object list is read from an EDS file provided by the user.
Diag History tab
Logged diagnosis messages from the controller protocol can be read out on the “Diag History” tab. The diagnosis buffer operates as a ring buffer with a current maximum size of 1000 entries.
Karteireiter Diag History
Diag History tab
The possible errors are grouped into three types:
▪
Info: e.g. information about the connection establishment
▪
Warning: e.g. PROFINET diagnosis alarms
▪
Error: e.g. loss of connection
“AddInfo” indicates whether additional information about the event is available. If this is marked by “Yes”, the additional information can be fetched and displayed by clicking on the respective message. In the case of a diagnosis alarm (“Diagnosis” appears), the precise diagnosis information can be fetched at the corresponding level (device, API or module).
The complete diagnosis buffer is cleared by pressing the “Clear Diag History” button.
The displayed messages can be saved in a .TXT file by pressing the “Export Diag History” button.
Online tab
Online tab
State Machine
Init | This button attempts to set the IO-Link master to the Init state.
Pre-Op | This button attempts to set the IO-Link master to the pre-operational state.
Op | This button attempts to set the IO-Link master to the operational state.
Bootstrap | This button attempts to set the IO-Link master to the Bootstrap state.
Safe-Op | This button attempts to set the IO-Link master to the safe-operational state.
Clear Error | This button attempts to delete the fault display. If an IO-Link master fails during change of state it sets an error flag. Example: An IO-Link master is in PREOP state (pre-operational). The master now requests the SAFEOP state (safe-operational). If the master fails during change of state it sets the error flag. The current state is now displayed as ERR PREOP. When the Clear Error button is pressed the error flag is cleared, and the current state is displayed as PREOP again.
Current State | Indicates the current state of the IO-Link master.
Requested State | Indicates the state requested for the IO-Link master.


Restoring the delivery state of an EtherCAT device

Basic communication principles - EtherCAT [image] Restoring the delivery state of an EtherCAT device
Restoring the delivery state of an EtherCAT device
To restore the delivery state for backup objects of the EP6224-xxxx (IO-Link Master), the CoE object “Restore default parameters”, “Subindex 001” can be selected in the TwinCAT System Manager (Config mode) (see following figure).
Selecting the Restore default parameters PDO
Double-click on “SubIndex 001” to enter the “Set Value dialog” (see following figure). Enter the value 1684107116 in field “Dec” or the value 0x64616F6C in field “Hex” and confirm with OK.
All backup objects are reset to the delivery state.
Entering a restore value in the Set Value Dialog


EtherCAT state machine

Basic communication principles - EtherCAT [image] EtherCAT state machine
EtherCAT state machine
The state of the EtherCAT slave is controlled via the EtherCAT State Machine (ESM). Depending upon the state, different functions are accessible or executable in the EtherCAT slave. Specific commands must be sent by the EtherCAT master to the device in each state, particularly during the bootup of the slave.
A distinction is made between the following states:
▪
Init
▪
Pre-Operational
▪
Safe-Operational and
▪
Operational
▪
Boot
The regular state of each EtherCAT slave after bootup is the OP state.
EtherCAT state machine
Init
After switch-on the EtherCAT slave in the Init state. No mailbox or process data communication is possible. The EtherCAT master initializes sync manager channels 0 and 1 for mailbox communication.
Pre-Operational (Pre-Op)
During the transition between Init and Pre-Op the EtherCAT slave checks whether the mailbox was initialized correctly.
In Pre-Op state mailbox communication is possible, but not process data communication. The EtherCAT master initializes the sync manager channels for process data (from sync manager channel 2), the FMMU channels and, if the slave supports configurable mapping, PDO mapping or the sync manager PDO assignment. In this state the settings for the process data transfer and perhaps terminal-specific parameters that may differ from the default settings are also transferred.
Safe-Operational (Safe-Op)
During transition between Pre-Op and Safe-Op the EtherCAT slave checks whether the sync manager channels for process data communication and, if required, the distributed clocks settings are correct. Before it acknowledges the change of state, the EtherCAT slave copies current input data into the associated DP-RAM areas of the EtherCAT slave controller (ECSC).
In Safe-Op state mailbox and process data communication is possible, although the slave keeps its outputs in a safe state, while the input data are updated cyclically.
Operational (Op)
Before the EtherCAT master switches the EtherCAT slave from Safe-Op to Op it must transfer valid output data.
In the Op state the slave copies the output data of the masters to its outputs. Process data and mailbox communication is possible.
Boot
In the Boot state the slave firmware can be updated. The Boot state can only be reached via the Init state.
In the Boot state mailbox communication via the file access over EtherCAT (FoE) protocol is possible, but no other mailbox communication and no process data communication.


IO-Link basics

IO-Link basics
IO-Link basics
IO-Link represents a communication system for the connection of intelligent sensors and actuators to an automation system in the IEC 61131-9 standard under the designation "Single-drop digital communication interface for small sensors and actuators" (SDCI).
Both the electrical connection data and the communication protocol are standardized and summarized in the IO-Link specification.
Note
IO-Link specification
The development of the EP6224-xxxx was subject to the IO-Link specification 1.1. At the time of the preparation of this documentation, the IO-Link specification is entering the IEC standardization and will be adopted in extended form as IEC 61131-9. The new designation SDCI will be introduced at the same time. As a member of the respective committee, Beckhoff supports the development of IO-Link and reflects changes to the specification in its products.
An IO-Link system consists of an IO-Link master, one or more IO-Link devices and sensors or actuators. The IO-Link master provides the interface to the higher-level controller and controls communication with the connected IO-Link devices. The Beckhoff EP6224-xxxx IO-Link Master module has four IO-Link ports. One IO-Link device can be connected to each of them. IO-Link is not a fieldbus, but rather a peer-to-peer connection (see following figure).
IO-Link overview: Peer-to-Peer communication
The connected IO-Link devices possess individual parameter information, which is recognized during automatic scanning with TwinCAT and adopted into the System Manager. Offline can be read module specific information in form of an IO-Link Device Description (IODD) and adapted in TwinCAT.
Parameter data exchange
An intelligent IO-Link sensor/actuator (marked in the previous figure with “Sensor (IO-Link Device)”) can support parameterization by SPDUs (Service Protocol Data Units). The PLC must explicitly query or, when marked as such, send these acyclic service data.
Note
SPDU access
TwinCAT supports access via ADS and via the EP6224-xxxx CoE directory.
The respective parameter is addressed via the so-called SPDU index. The following ranges are available:
Designation | Index range
System | 0x00..0x0F
Identification | 0x10..0x1F
Diagnostic | 0x20..0x2F
Communication | 0x30..0x3F
Preferred Index | 0x40..0xFE
Extended Index | 0x0100..0x3FFF
 | The range 0x4000 to 0xFFFF is reserved
The use and implementation of these ranges is the responsibility of the sensor/actuator manufacturer. For clarification, just a few of the possible indices are listed here. Please take a look at the relevant chapter “Object description and parameterization”.
Index | Name
0010 | Vendor Name
0011 | Vendor Text
0012 | Product Name
0013 | Product ID
0015 | Serial Number
0016 | Hardware Revision
0017 | Firmware Revision
... | ...


Mounting and Access

Mounting and Access
Mounting and Access
Additional information
•
Mounting
•
EtherCAT
•
IO-Link
•
Power supply


Mounting

Mounting and Access [image] Mounting
Mounting
Additional information
•
Dimensions
•
Fixing
•
Nut torque for connectors


Dimensions

Mounting and Access [image] Mounting [image] Dimensions
Dimensions
Dimensions of the EtherCAT Box Modules
All dimensions are given in millimeters.
Housing properties
EtherCAT Box | lean body | wide body
Housing material | PA6 (polyamide)
Casting compound | Polyurethane
Mounting | two fastening holes Ø 3 mm for M3 | two fastening holes Ø 3 mm for M3 two fastening holes Ø 4,5 mm for M4
Metal parts | Brass, nickel-plated
Contacts | CuZn, gold-plated
Power feed through | max. 4 A
Installation position | variable
Protection class | IP65, IP66, IP67 (conforms to EN 60529) when screwed together
Dimensions (H x W x D) | ca. 126 x 30 x 26,5 mm | ca. 126 x 60 x 26,5 mm
Weight | approx. 125 g, depending on module type | approx. 250 g, depending on module type


Fixing

Mounting and Access [image] Mounting [image] Fixing
Fixing
Note
Note or pointer
While mounting the modules, protect all connectors, especially the IP-Link, against contamination! Only with connected cables or plugs the protection class IP67 is guaranteed! Unused connectors have to be protected with the right plugs! See for plug sets in the catalogue.
Modules with narrow housing are mounted with two M3 bolts.
Modules with wide housing are mounted with two M3 bolts to the fixing holes located at the corners or mounted with two M4 bolts to the fixing holes located centrally.
The bolts must be longer than 15 mm. The fixing holes of the modules are not threaded.
When assembling, remember that the fieldbus connectors increases the overall height. See chapter accessories.
Mounting Rail ZS5300-0001
The mounting rail ZS5300-0001 (500 mm x 129 mm) allows the time saving assembly of modules.
The rail is made of stainless steel, 1.5 mm thick, with already pre-made M3 threads for the modules. The rail has got 5.3 mm slots to mount it via M5 screws to the machine.
Mounting Rail ZS5300-000
The mounting rail is 500 mm long, that way 15 narrow modules can be mounted with a distance of 2 mm between two modules. The rail can be cut to length for the application.
Mounting Rail ZS5300-0011
The mounting rail ZS5300-0011 (500 mm x 129 mm) has in addition to the M3 treads also pre-made M4 treads to fix 60 mm wide modules via their middle holes.
Up to 14 narrow or 7 wide modules may be mixed mounted.


Nut torque for connectors

Mounting and Access [image] Mounting [image] Nut torque for connectors
Nut torque for connectors
M8 connectors
It is recommended to pull the M8 connectors tight with a nut torque of 0.4 Nm.
EtherCAT Box with M8 connectors
M12 connectors
It is recommended to pull the M12 connectors tight with a nut torque of 0.6 Nm.
EtherCAT Box with M8 and M12 connectors
7/8" connectors
It is recommended to pull the 7/8" connectors tight with a nut torque of 1.5 Nm.
7/8" connectors
Torque socket wrenches
ZB8801 torque socket wrench
Note
Ensure the right torque
Use the torque socket wrenches available by Beckhoff to pull the connectors tight (see accessories)!


EtherCAT

Mounting and Access [image] EtherCAT
EtherCAT
Additional information
•
EtherCAT connection
•
EtherCAT - Fieldbus LEDs


EtherCAT connection

Mounting and Access [image] EtherCAT [image] EtherCAT connection
EtherCAT connection
For the incoming and ongoing EtherCAT connection,
▪
the EtherCAT Box (EPxxxx) has two M8 sockets, marked in green
▪
the Coupler Box (FBB-x110) has two M12 sockets
EtherCAT Box: M8 (30 mm housing)
EtherCAT Box: M8 60 mm housing (EP9214 for example )
Coupler Box: M12
Assignment
There are various different standards for the assignment and colors of connectors and cables for Ethernet/EtherCAT.
Ethernet/EtherCAT |  | Plug connector |  |  | Cable |  | Standard
Signal | Description | M8 | M12 | RJ451 | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 and old versions of ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | Transmit Data+ | Pin 1 | Pin 1 | Pin 1 | yellow2 | orange/white3 | white/orange
Tx - | Transmit Data- | Pin 4 | Pin 3 | Pin 2 | orange2 | orange3 | orange
Rx + | Receive Data+ | Pin 2 | Pin 2 | Pin 3 | white2 | blue/white3 | white/green
Rx - | Receive Data- | Pin 3 | Pin 4 | Pin 6 | blue2 | blue3 | green
Shield | Shield | Housing |  | Shroud | Screen | Screen | Screen
1) colored markings according to EN 61918 in the four-pin RJ45 connector ZS1090-0003
2) wire colors according to EN 61918
3) wire colors
Note
Assimilation of color coding for cable ZB9030, ZB9032 and ZK1090-3xxxx-xxxx (with M8 connectors)
For unification the prevalent cables ZB9030, ZB9032 and ZK1090-3xxx-xxxx this means the pre assembled cables with M8 connectors were changed to the colors of EN61918 (yellow, orange, white, blue).So different color coding exists. But the electrical properties are absolutely identical.
EtherCAT connectors
The following connectors can be supplied for use in Beckhoff EtherCAT systems.
Designation | Plug connector | Comment
ZS1090-0003 | RJ45 | four-pin, IP20, for field assembly
ZS1090-0004 | M12 | four-pin, IP67, for field assembly
ZS1090-0005 | RJ45 | eight-pin, IP20, for field assembly, suitable for Gigabit Ethernet
ZS1090-0006 | M8 | four-pin, IP67, for field assembly
ZS1090-0007 | M8 socket | four-pin, IP67, for field assembly, for ZB903x cable
ZS1090-1006 | M8 plug | four-pin, IP67, for field assembly up to OD = 6.5 mm
ZS1090-1007 | M8 socket | four-pin, IP67, for field assembly up to OD = 6.5 mm


EtherCAT - Fieldbus LEDs

Mounting and Access [image] EtherCAT [image] EtherCAT - Fieldbus LEDs
EtherCAT - Fieldbus LEDs
EtherCAT-LEDs
LED display
LED | Display | Meaning
IN L/A | off | no connection to the preceding EtherCAT module
 | Lit | LINK: connection to the preceding EtherCAT module
 | flashing | ACT: Communication with the preceding EtherCAT module
OUT L/A | off | no connection to the following EtherCAT module
 | Lit | LINK: connection to the following EtherCAT module
 | flashing | ACT: Communication with the following EtherCAT module
Run | off | Status of the EtherCAT module is Init
 | flashes quickly | Status of the EtherCAT module is pre-operational
 | flashes slowly | Status of the EtherCAT module is safe-operational
 | Lit | Status of the EtherCAT module is operational
Note
EtherCAT statuses
The various statuses in which an EtherCAT module may be found are described in the Basic System Documentation for EtherCAT, which is available for download from our website (www.beckhoff.com) under Downloads.


IO-Link

Mounting and Access [image] IO-Link
IO-Link
Additional information
•
Connection IO-Link Master


Connection IO-Link Master

Mounting and Access [image] IO-Link [image] Connection IO-Link Master
Connection IO-Link Master
IO-Link interface
Different IO-Link pin assignments are determined in the IO-Link specification. This will be discussed in the next part.
Port Class A (type A): The function of pin 2 and pin 5 is not predetermined. The manufacturer can prove pin 2 with an additional digital channel. In the Class A master/device from Beckhoff the pin 2 is not assigned.
Anschlussbelegung IO-Link Device_Beckhoff
Pin assignment Port Class A
Port Class B (type B): Devices with an increased current demand becomes an additional power supply which is provided via pin 2 and pin 5.
Anschlussbelegung Port Class B IO-Link
Pin assignment Port Class B
The switching and communication line is marked with (C/Q).
Beckhoff offers an IO-Link master in Class A variant (EP6224-2022) and an IO-Link master in Class B variant (EP6224-3022).
The IO-Link Master (EP6224-xxxx) has an a- coded M12 socket for the outgoing IO-Link connection.
IO-Link connection, Master
Wire color
The wire colors of the IO-Link cable to the corresponding pin assignment of the IO-Link connector:
Pin | Wire color
1 | brown
2 | white
3 | blue
4 | black
5 | grey
IO-Link cable
Example IO-Link cable: male to female
The deliverable cables for the IO-Link system from Beckhoff can be found under the following link under the point “Accessories”: http://beckhoff.de/english.asp?fieldbus_box/data_sheets.htm?id=69033899254355
Note
IO-Link cable
For the Class A master/device from Beckhoff is a 3-wire IO-Link cable sufficient. The Class B master/device needs a 5-wire IO-Link cable.


Power supply

Mounting and Access [image] Power supply
Power supply
Additional information
•
Power Connection
•
Status LEDs for power supply
•
Power cable conductor losses M8


Power Connection

Mounting and Access [image] Power supply [image] Power Connection
Power Connection
The feeding and forwarding of supply voltages is done via two M8 connectors at the bottom end of the modules:
▪
IN: left M8 connector for feeding the supply voltages
▪
OUT: right M8 connector for forwarding the supply voltages
EtherCAT Box, Connectors for power supply
Pin assignment M8, Power In and Power Out
PIN assignment
Pin | Voltage
1 | Control voltage Us, +24 VDC
2 | Auxiliary voltage Up, +24 VDC
3 | GNDs* | *) may be connected internally to each other depending on the module: see specific module descriptions
4 | GNDp*
The pins M8 connectors carry a maximum current of 4 A.
Two LEDs display the status of the supply voltages.
Attention
Don't confuse the power connectors with the EtherCAT connectors!
Never connect the power cables (M8, 24 VDC) with the green marked EtherCAT sockets of the EtherCAT Box Modules! This can damage the modules!
Control voltage Us: 24 VDC
Power is supplied to the fieldbus, the processor logic, the inputs and the sensors from the 24 VDC control voltage Us. The control voltage is electrically isolated from the fieldbus circuitry.
Auxiliary voltage Up 24 VDC
The Auxiliary voltage Up supplies the digital outputs; it can be brought in separately. If the load voltage is switched off, the fieldbus functions and the power supply and functionality of the inputs are retained.
Redirection of the supply voltages
The IN and OUT power connections are bridged in the module (not IP204x-Bxxx and IE204x). The supply voltages Us and Up can thus easily be transferred from EtherCAT Box to EtherCAT Box.
Attention
Pay attention to the maximum permissible current!
Pay attention also for the redirection of the supply voltages Us and Up, the maximum permissible current for M8 connectors of 4 A must not be exceeded!
Supply via EP92x4-0023 PowerBox modules
If the machine requires higher current or if the EtherCAT Box Modules are installed far away from the control cabinet with included power supply, the usage of four cannel power distribution modules EP9214 or EP9224 (with integrated data logging, see www.beckhoff.com/EP9224) is recommended.
With these modules intelligent power distribution concepts with up to 2 x 16 A and a maximum of 2.5 mm² cable cross-section can be realized.
EP92x4-0023, Connectors for Power In and Power Out
Pin assignment 7/8”, Power In and Power Out
Electrical isolation
Digital modules
In the digital input/output modules, the grounds of the control voltage (GNDs) and the auxiliary voltage (GNDp) are connected to each other!
Check this at the documentation of each used EtherCAT Box.
Analog modules
In the analog input/output modules the grounds of the control voltage (GNDs) and the auxiliary voltage (GNDp) are separated from each other in order to ensure electrical isolation of the analog signals from the control voltage.
In some of the analog modules the sensors or actuators are supplied by Up - this means, for instance, that in the case of 0...10 V inputs, any reference voltage (0...30 V) may be connected to Up; this is then available to the sensors (e.g. smoothed 10 V for measuring potentiometers).
Details of the power supply may be taken from the specific module descriptions.
Attention
Electrical isolation may be cancelled!
If digital and analog fieldbus boxes are connected directly via four-core power leads, the analog signals in the fieldbus boxes may be no longer electrically isolated from the control voltage!


Status LEDs for power supply

Mounting and Access [image] Power supply [image] Status LEDs for power supply
Status LEDs for power supply
Status LEDs for power supply
LED display
LED | Display | Meaning
Us (Control voltage) | off | The power supply voltage Us is not present
 | green illuminated | The power supply voltage Us is present
 | red illuminated | Because of overload (current > 0.5 A) the sensor supply generated from power supply voltage Us was switched off for all sensors fed from this.
Up (Auxiliary voltage) | off | The power supply voltage Up is not present
 | green illuminated | The power supply voltage Up is present


Power cable conductor losses M8

Mounting and Access [image] Power supply [image] Power cable conductor losses M8
Power cable conductor losses M8
The ZK2020-xxxx-yyyy power cables should not exceed the total length of 15 m at 4 A (with continuation). When planning the cabling, note that at 24 V nominal voltage, the functionality of the module can no longer be assured if the voltage drop reaches 6 V. Variations in the output voltage from the power supply unit must also be taken into account.
Power cable conductor losses
Example
8 m power cable with 0.34 mm² cross-section has a voltage drop of 3.2 V at 4 A.
Note
EP92x4 Power Distribution Modules
With EP9214 and EP9224 Power Distribution Modules intelligent concepts for voltage supply are available. Further information may be found under www.beckhoff.com/EP9224.


Cabling

Cabling
Cabling
Additional information
•
Cabling EtherCAT
•
Cabling IO-Link


Cabling EtherCAT

Cabling [image] Cabling EtherCAT
Cabling EtherCAT
A list of the EtherCAT cable, power cable, sensor cable, Ethernet-/EtherCAT connectors and the field assembled connectors can be found at the following link: http://download.beckhoff.com/download/document/catalog/main_catalog/english/Beckhoff_EtherCAT-Box-Accessories.pdf
You can find the corresponding data sheets at the following link: http://beckhoff.de/english/fieldbus_box/data_sheets.htm?id=69033899254355
EtherCAT cable
For connecting EtherCAT devices only shielded Ethernet cables that meet the requirements of at least category 5 (CAT5) according to EN 50173 or ISO/IEC 11801 should be used.
Note
Recommendations about cabling
You may get detailed recommendations about cabling EtherCAT from the documentation "Recommendations for the design of the infrastructure for EtherCAT/Ethernet", that is available for download at www.Beckhoff.com.
EtherCAT uses 4 wires for signal transfer.
Due to automatic cable detection (auto-crossing) symmetric (1:1) or cross-over cables can be used between EtherCAT devices from Beckhoff.
Power cable


Cabling IO-Link

Cabling [image] Cabling IO-Link
Cabling IO-Link
A list of the EtherCAT cable, power cable, sensor cable, IO-Link cable, Ethernet-/EtherCAT connectors and the field assembled connectors can be found at the following link: http://download.beckhoff.com/download/document/catalog/main_catalog/english/Beckhoff_EtherCAT-Box-Accessories.pdf
You can find the corresponding data sheets at the following link: http://beckhoff.de/english/fieldbus_box/data_sheets.htm?id=69033899254355
IO-Link cable
Example IO-Link cable: male to female
The IO-Link master is connected via a unshielded, up to 20 m long, 3-wire (Type A) or 5-wire (Type B) cable with the IO-Link Device. The IO-Link Cables are in straight and angled version available. For more information on IO-Link connection, see: Connection IO-Link Master
Sensor cable
Selection of the from Beckhoff deliverable sensor cables


UL Requirements

UL Requirements
UL Requirements
The installation of the EtherCAT Box Modules certified by UL has to meet the following requirements.
Supply voltage
CAUTION
CAUTION!
•
by a 24 VDC supply voltage, supplied by an isolating source and protected by means of a fuse (in accordance with UL248), rated maximum 4 Amp, or
•
by a 24 VDC power source, that has to satisfy NEC class 2.
A NEC class 2 power supply shall not be connected in series or parallel with another (class 2) power source!
CAUTION
CAUTION!
To meet the UL requirements, the EtherCAT Box Modules must not be connected to unlimited power sources!
Networks
CAUTION
CAUTION!
To meet the UL requirements, EtherCAT Box Modules must not be connected to telecommunication networks!
Ambient temperature range
CAUTION
CAUTION!
To meet the UL requirements, EtherCAT Box Modules has to be operated only at an ambient temperature range of 0 to 55°C!
Marking for UL
All EtherCAT Box Modules certified by UL (Underwriters Laboratories) are marked with the following label.
UL label


ATEX Notes

ATEX Notes
ATEX Notes
Additional information
•
ATEX - Special conditions
•
BG2000-0000 - EtherCAT Box protection enclosure
•
ATEX Documentation


ATEX - Special conditions

ATEX Notes [image] ATEX - Special conditions
ATEX - Special conditions
WARNING
Observe the special conditions for the intended use of EtherCAT Box modules in potentially explosive areas – directive 94/9/EU.
•
The certified components are to be installed in the BG2000-0000 protection enclosure that guarantees a protection against mechanical hazards!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observethe permissible ambient temperature range of 0 - 55°C for the use of EtherCAT Box modules in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0: 2006
▪
EN 60079-15: 2005
Marking
The EtherCAT Box modules certified for potentially explosive areas bear the following marking:
II 3 G Ex nA II T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
II 3 G Ex nA nC IIC T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
Batch number (D number)
The EtherCAT Box modules bear a batch number (D number) that is structured as follows:
D: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Beispiel mit Ser. Nr.: 29 10 02 01:
29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01


BG2000-0000 - EtherCAT Box protection enclosure

ATEX Notes [image] BG2000-0000 - EtherCAT Box protection enclosure
BG2000-0000 - EtherCAT Box protection enclosure
WARNING
Risk of electric shock and damage of device!
Bring the EtherCAT system into a safe, powered down state before starting installation, disassembly or wiring of the modules!
ATEX
The BG2000-0000 protection enclosure has to be mounted over a single EtherCAT Box to fulfill the special conditions according to ATEX.
Installation
Put the cables for EtherCAT, power supply and sensors/actuators through the hole of the BG2000-0000 protection enclosure.
BG2000-0000, putting the cables
Fix the wires for EtherCAT, power supply and sensors/actuators to the EtherCAT Box.
BG2000-0000, fixing the cables
Mount the BG2000-0000 protection enclosure over the EtherCAT Box.
BG2000-0000, mounting the protection enclosure


ATEX Documentation

ATEX Notes [image] ATEX Documentation
ATEX Documentation
Note
Notes about operation of EtherCAT Box Modules (EPxxxx-xxxx) in potentially explosive areas (ATEX)
Pay also attention to the continuative documentationNotes about operation of EtherCAT Box Modules (EPxxxx-xxxx) in potentially explosive areas (ATEX) that is available in the download area of the Beckhoff homepage http:\\www.beckhoff.com!


Commissioning/Configuration

Commissioning/Configuration
Commissioning/Configuration
Additional information
•
IO-Link master
•
Object description and parameterization


IO-Link master

Commissioning/Configuration [image] IO-Link master
IO-Link master
Additional information
•
Offline configuration settings - TwinCAT (master)
•
Online configuration settings - TwinCAT (master)


Offline configuration settings - TwinCAT (master)

Commissioning/Configuration [image] IO-Link master [image] Offline configuration settings - TwinCAT (master)
Offline configuration settings - TwinCAT (master)
In this part of the documentation is the manual configuration of the IO-Link master in TwinCAT described.
Distinction between Online and Offline
The distinction between online and offline refers to the presence of the actual I/O environment (drives, terminals, box-modules). If the configuration is to be prepared in advance of the system configuration as a programming system, e.g. on a laptop, this is only possible in “Offline configuration” mode. In this case all components have to be entered manually in the configuration, e.g. based on the electrical design (as described under Offline configuration settings - TwinCAT (device)).
If the designed control system is already connected to the EtherCAT system and all components are energized and the infrastructure is ready for operation, the TwinCAT configuration can simply be generated through “scanning” from the runtime system. This is referred to as online configuration.
In any case, during each startup the EtherCAT master/ IO-Link master checks whether the devices it finds match the configuration. This test can be parameterized in the extended device settings.
To take advantage of the current features/settings of the master, the latest version of the ESI file should always be downloaded. Therefore it is necessary to consider the following note first.
Note
Installation of the latest ESI-XML device description
The TwinCAT SystemManager needs the device description files for the devices to be used in order to generate the configuration in online or offline mode. The device description are contained in the so-called ESI files (EtherCAT Slave Information) in XML format. These files can be requested from the respective manufacturer and are made available for download. The ESI files for Beckhoff EtherCAT devices are available on the Beckhoff website (http://www.beckhoff.de/english/download/elconfg.htm?id=1983920606140). The ESI files should be saved in the TwinCAT installation directory (default: C:\TwinCAT\IO\EtherCAT). The files are read (once) when a new System Manager window is opened. A TwinCAT installation includes the set of Beckhoff ESI files that was current at the time when the TwinCAT build was created. For TwinCAT 2.11 and higher, the ESI directory can be uploaded from the System Manager, if the programming PC is connected to the internet (TwinCAT → EtherCAT-Devices → Update Device Description…) Update EtherCAT Device Description
Appending a module manually
▪
The EtherCAT system must be in a safe, de-energized state before the EtherCAT modules are connected to the EtherCAT network!
▪
Switch on the operating voltage, open the TwinCAT System Manager (Config mode)
▪
Append a new I/O device. In the dialog that appears select the device EtherCAT (Direct Mode), and confirm with OK.
Anfügen eines neuen E_A-Gerätes
Appending a new I/O device (I/O Devices -> right-click -> Append Device...)
Auswahl des Gerätes (EtherCAT)
Selecting the device EtherCAT
▪
Append a new box.
Anfügen einer neuen Box
Appending a new box (Device -> right-click -> Append Box...)
▪
In the dialog that appears select the desired box (e.g. EP6224-2022), and confirm with OK.
Auswahl einer Box
Selecting a Box (e.g. EP6224-2022)
Angefügte Box im TwinCAT-Baum
Appended Box in the TwinCAT tree
In this section is described, how to configure the IO-Link master in TwinCAT and the integration of IO-Link devices.
Configuration of the IO-Link master
Configuration of the IO-Link master requires a plug-in, which is usually supplied with the TwinCAT installation. When the IO-Link master is added to the TwinCAT System Manager (see section Commissioning/Configuration) an additional tab called IO-Link is created (see following figure). If the tab is not displayed, the associated System Manager extension is missing. The extension is available for download from the Beckhoff website http://beckhoff.de/english.asp?download/elconfg.htm?id=1983920606140.
"IO-Link" tab


Online configuration settings - TwinCAT (master)

Commissioning/Configuration [image] IO-Link master [image] Online configuration settings - TwinCAT (master)
Online configuration settings - TwinCAT (master)
In this part of the documentation is the configuration of a physically existing IO-Link master in TwinCAT described.
Online configuration “Scan” (TwinCAT 3.x)
Distinction between Online and Offline
The distinction between online and offline refers to the presence of the actual I/O environment (drives, terminals, box-modules). If the configuration is to be prepared in advance of the system configuration as a programming system, e.g. on a laptop, this is only possible in “Offline configuration” mode. In this case all components have to be entered manually in the configuration, e.g. based on the electrical design (as described under Offline configuration settings - TwinCAT (device)).
If the designed control system is already connected to the EtherCAT system and all components are energized and the infrastructure is ready for operation, the TwinCAT configuration can simply be generated through “scanning” from the runtime system. This is referred to as online configuration.
In any case, during each startup the EtherCAT master/ IO-Link master checks whether the devices it finds match the configuration. This test can be parameterized in the extended slave settings.
To take advantage of the current features/settings of the master, the latest version of the ESI file should always be downloaded. Therefore it is necessary to consider the following note first.
Note
Installation of the latest ESI-XML device description
The TwinCAT SystemManager needs the device description files for the devices to be used in order to generate the configuration in online or offline mode. The device description are contained in the so-called ESI files (EtherCAT Slave Information) in XML format. These files can be requested from the respective manufacturer and are made available for download. The ESI files for Beckhoff EtherCAT devices are available on the Beckhoff website (http://www.beckhoff.de/english/download/elconfg.htm?id=1983920606140). The ESI files should be saved in the TwinCAT installation directory (default: C:\TwinCAT\IO\EtherCAT). The files are read (once) when a new System Manager window is opened. A TwinCAT installation includes the set of Beckhoff ESI files that was current at the time when the TwinCAT build was created. For TwinCAT 2.11 and higher, the ESI directory can be uploaded from the System Manager, if the programming PC is connected to the internet (TwinCAT → EtherCAT-Devices → Update Device Description…) Update EtherCAT Device Description
The following conditions must be met before a configuration can be set up:
▪
the real EtherCAT and IO-Link hardware (devices, couplers, drives) must be present and installed
▪
the master/devices must be connected via EtherCAT cables and IO-Link cables in the same way as they are intended to be used later
▪
the devices/modules be connected to the power supply and ready for communication
▪
TwinCAT must be in CONFIG mode on the target system.
The online scan process consists of:
▪
detecting the EtherCAT device (Ethernet Port at the IPC)
▪
detecting the connected EtherCAT devices. This step can be carried out independent of the precending step.
▪
troubleshooting
The scan with existing configuration can also be carried out for com parison.
Detecting/scanning of the EtherCAT device
The online device search can be used if the TwinCAT system is in CONFIG mode (blue TwinCAT icon or blue indication in the System Manager).
TwinCAT CONFIG mode display
Note
Online scanning in Config mode
The online search is not available in RUN mode (production operation).
Note the differentiation between TwinCAT programming system and TwinCAT target system. The TwinCAT icon next to the Windows clock always shows the TwinCAT mode of the local IPC. The System Manager window shows the TwinCAT state of the target system.
TwinCAT target und local System
Right-clicking on “I/O Devices” in the configuration tree opens the search dialog.
Scan Devices
This scan mode not only tries to find EtherCAT devices (or Ethernet ports that can be used as such), but also NOVRAM, fieldbus cards, SMB etc. Not all devices can be found automatically.
Hinweis automatischer Gerätescan
note for automatic device scan
Ethernet ports with installed TwinCAT real-time driver are shown as “RT Ethernet” devices. An EtherCAT frame is sent to these ports for testing purposes. If the scan agent detects from the response that an EtherCAT slave is connected, the port is immediately shown as an “EtherCAT Device”.
detected Ethernet devices
After confirmation with “OK” a device scan is suggested for all selected devices, see following figure.
Detecting/Scanning the EtherCAT devices
Note
Online scan functionality
During a scan the master queries the identity information of the EtherCAT slaves from the slave EEPROM. The name and revision are used for determining the type. The respective devices are located in the stored ESI data and integrated in the configuration tree in the default state defined there.
If an EtherCAT device was created in the configuration (manually or through a scan), the I/O field can be scanned for devices/slaves.
Scan for Boxes
scan query after automatic creation of an EtherCAT device
The configuration has been build and directly shifted into the online state (OPERATIONAL). The EtherCAT system should then be in a functional cyclic state, as shown in the following figure.
online display example
Please note:
▪
all slaves should be in OP state
▪
the EtherCAT master should be in “Actual State” OP
▪
“frames/sec” should match the cycle time taking into account the sent number of frames
▪
no excessive “LostFrames” or CRC errors should occur
The configuration is now complete. It can be modified as described under the offline procedure.
The connected IO-Link master (EP6224-3022) is displayed in the TwinCAT structure as you can see in the figure below.
Master-Anzeige_Nach Scan for Boxes
Master display after scan for boxes
Troubleshooting
Various effects may occur during scanning.
▪
An unknown device is detected, i.e. an EtherCAT slave for which no ESI XML description is available. In this case the System Manager offers to read any ESI that maybe stored in the device.
▪
Device are not detected property
▪
Possible reasons include:
–
faulty data links, resulting in data loss during the scan
–
slave has invalid device description
–
The connections and devices should be checked in a targeted manner, e.g. via the emergency scan.
Then re-run the scan.
Scan over existing configuration
If a scan is initiated for an existing configuration, the actual I/O environment may match the configuration exactly or it may differ. This enables the configuration to be compared.
Configuration is identical
identical configuration
If differences are detected, they are shown in the correction dialog, so that the user can modify the configuration as required.
correction dialog
It is advisable to tick the “Extended Information” check box to reveal differences in the revision.
Colour | Explanation
green | This EtherCAT slave matches the entry on the other side. Both type and revision match.
blue | This EtherCAT slave is present on the other side, but in a different revision. If the found revision is higher than the configured revision, the slave maybe used provided compatibility issues are taken into account. If the found revision is lower than the configured revision, it is likely that the slave cannot be used. The found device may not support all functions that the master expects based on the higher revision number.
light blue | This EtherCAT slave is ignored („Ignore“ button).
red | This EtherCAT slave is not present on the other side.
Note
Device selection based on revision, compatibility
The ESI description also defines the process image, the communication type between master and slave/device and the device functions, if applicable. The physical device (firmware, if available) has to support the communication queries/settings of the master. This is backward compatible, i.e. newer devices (higher revision) should be supported if the EtherCAT master addresses them as an older revision. The following compatibility rule of thumb is to be assumed for Beckhoff EtherCAT Terminals/Boxes:
device revision in the system >= device revision in the configuration
This also enables subsequent replacement of devices without changing the configuration (different specifications are possible for drives). Example: If an EL2521-0025-1018 is specified in the configuration, an EL 2521-0025-1019 or higher (-1020, -1021) can be used in practice.
If current ESI descriptions are available in the TwinCAT system, the last revision offered in the selection dialog matches the Beckhoff state of production. It is recommended to use the last device revision when creating a new configuration, if current Beckhoff devices are used in the real application. Older revisions should only be used if older devices from stock are to be used in the application.
correction dialog with modifications
Once all modifications have been saved or accepted, click “OK” to transfer them to the real *.tsm configuration.


Object description and parameterization

Commissioning/Configuration [image] Object description and parameterization
Object description and parameterization
Note
EtherCAT XML Device Description
The description correspond to the display of the CoE objects from the EtherCAT XML Device Description. It is strongly recommended to download the latest revision of the corresponding XML file from the Beckhoff website (http://www.beckhoff.de/german/default.htm?download/elconfg.htm) and follow the installation instructions.
Note
Parameterization
Boxes/Terminals parameterization will be conducted by the CoE-tab (double- click on the referring object), see below.
Introduction
The CoE overview contains objects for different intended applications:
▪
Objects required for parameterization during commissioning.
▪
Objects intended for regular operation, e.g. through ADS access.
▪
Objects for indicating internal settings (may be fixed).
▪
Profile specific objects, for exposition the status of the inputs and outputs.
The following section first describes the objects require for normal operation, followed by a complete overview of other objects.
Objects for commissioning
Index 1011 Restore default parameters
Index | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore the default settings in the EtherCAT slave | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" ("Set Value Dialog") all terminal-specific objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dez)
Index 80n0 IO Settings Ch.1 - 4 (for 0 ≤ n ≤ 3)
Index | Name | Meaning | Data type | Flags | Default
80n0:0 | IO Settings Ch.1- 4 | Max. Subindex | UINT8 | RO | 0x28 (40dez)
80n0:04 | Device ID | The device ID is used for validating the IO link device. | UINT32 | RW | 0x00000000 (0dez)
80n0:05 | VendorID | The vendor ID is used for validating the manufacturer of the IO link device. | UINT32 | RW | 0x00000000 (0dez)
80n0:07 | IO-Link Revision | ID of the specification version based on which the IO link device communicates. Bit 0-3: MinorRev Bit 4-7: MajorRev | UINT8 | RW | 0x00 (0dez)
80n0:20 | FrameCapability | The Frame Capability indicates certain functionalities of the IO link device (e.g. SPDU supported). Bit 0: SPDU Bit 1: Type1 Bit 7: PHY1 | UINT8 | RW | 0x00 (0dez)
80n0:21 | Min cycle time | The cycle time refers to the communication between the IO link master and the IO link device. This value is transferred in the IO link format for Min Cycle Time. Bit 6 und 7: Time Base Bit 0 to 5: Multiplier | UINT8 | RW | 0x00 (0dez)
80n0:22 | Offset time | reserved | UINT8 | RW | 0x00 (0dez)
80n0:23 | Process data in length | These parameters are transferred in the IO link format for "Process data in length". Bit 7: BYTE (indicates whether the value in LENGTH interpreted as bit length [bit not set] or as byte length + 1 [bit set] Bit 6: SIO (indicates whether the device supports the standard IO mode [bit set]) Bit 0 to 4: LENGTH (length of the process data) | UINT8 | RW | 0x00 (0dez)
80n0:24 | Process data out length | These parameters are transferred in the IO link format for "Process data out length". Bit 7: BYTE (indicates whether the value in LENGTH interpreted as bit length [bit not set] or as byte length + 1 [bit set] Bit 6: SIO (indicates whether the device supports the standard IO mode [bit set]) Bit 0 to 4: LENGTH (length of the process data) | UINT8 | RW | 0x00 (0dez)
80n0:26 | Compatible ID | reserved | UINT16 | RW | 0x0000 (0dez)
80n0:27 | Reserved | reserved | UINT16 | RW | 0x0000 (0dez)
80n0:28 | Master Control | 0: IO link port inactive 1: IO link port as digital input port 2: IO link port as digital output port 3: IO link port in communication via the IO link protocol 4: IO link port in communication via the IO link protocol. IO link state is ComStop (none cyclic communication, data are exchanged on demand). | UINT16 | RW | 0x0000 (0dez)
Objects for regular operation
In normal functional range the EL6224 has no such objects.
Complete overview
Standard objects (0x1000-0x1FFF)
The standard objects of all EtherCAT slaves have the same meaning.
Index 1000 Device type
Index | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device Type of the EtherCAT slave: The Lo-Word contains the supported CoE Profile (5001). The Hi-Word contains the Module Profile corresponding to the Modular Device Profile. | UINT32 | RO | 0x184C1389 (407638921dez)
Index 1008 Device name
Index | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EP6224
Index 1009 Hardware version
Index | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slaves | STRING | RO | 01
Index 100A Software version
Index | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slaves | STRING | RO | 01
Index 1018 Identity
Index | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | contains informations to identify the EtherCAT slave | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x18503052 (407908434dez)
1018:03 | Revision | Revision number of the EtherCAT-Slave, the Lo-Word (Bit 0-15) indicates the special functions terminal number; the Hi-Word (Bit 16-31) refers to the device description. | UINT32 | RO | 0x00100000 (1048576dez)
1018:04 | Serial number | Serial number of the EtherCAT-Slave, the Lo-Byte (Bit 0-7) of the Lo-Word contains the year of manufacturing, the Hi-Byte (Bit 8-15) of the Lo-Word contains the week of manufacturing, the Hi-Word (Bit 16-31) is 0 . | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | contains informations for the standardized Upload and Download of the Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksum over all backup entries | UINT32 | RO | 0x00000000 (0dez)
Index 1600 IO RxPDOPDO-Map Ch.1
Index | Name | Meaning | Data type | Flags | Default
1600:0 | IO RxPDOPDO-Map Ch.1 | PDO Mapping RxPDO 1 | UINT8 | RW | 0x01 (1dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
Index 1601 IO RxPDOPDO-Map Ch.2
Index | Name | Meaning | Data type | Flags | Default
1601:0 | IO RxPDOPDO-Map Ch.2 | PDO Mapping RxPDO 2 | UINT8 | RW | 0x01 (1dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
Index 1602 IO RxPDOPDO-Map Ch.3
Index | Name | Meaning | Data type | Flags | Default
1602:0 | IO RxPDOPDO-Map Ch.3 | PDO Mapping RxPDO 3 | UINT8 | RW | 0x01 (1dez)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
Index 1603 IO RxPDOPDO-Map Ch.4
Index | Name | Meaning | Data type | Flags | Default
1603:0 | IO RxPDOPDO-Map Ch.4 | PDO Mapping RxPDO 4 | UINT8 | RW | 0x01 (1dez)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
Index 1A00 IO TxPDOPDO-Map Ch.1
Index | Name | Meaning | Data type | Flags | Default
1A00:0 | IO TxPDOPDO-Map Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RW | 0x01 (1dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
Index 1A01 IO TxPDOPDO-Map Ch.2
Index | Name | Meaning | Data type | Flags | Default
1A01:0 | IO TxPDOPDO-Map Ch.2 | PDO Mapping TxPDO 2 | UINT8 | RW | 0x01 (1dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
Index 1A02 IO TxPDOPDO-Map Ch.3
Index | Name | Meaning | Data type | Flags | Default
1A02:0 | IO TxPDOPDO-Map Ch.3 | PDO Mapping TxPDO 3 | UINT8 | RW | 0x01 (1dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
Index 1A03 IO TxPDOPDO-Map Ch.4
Index | Name | Meaning | Data type | Flags | Default
1A03:0 | IO TxPDOPDO-Map Ch.4 | PDO Mapping TxPDO 4 | UINT8 | RW | 0x01 (1dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
Index 1A04 TxPDOeState TxPDO-Map Device
Index | Name | Meaning | Data type | Flags | Default
1A04:0 | TxPDOeState TxPDO-Map Device | PDO Mapping TxPDO 5 | UINT8 | RW | 0x04 (4dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF100 (Diagnosis Status data), entry 0x01 (State Ch1)) | UINT32 | RW | 0xF100:01, 8
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF100 (Diagnosis Status data), entry 0x02 (State Ch2)) | UINT32 | RW | 0xF100:02, 8
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF100 (Diagnosis Status data), entry 0x03 (State Ch3)) | UINT32 | RW | 0xF100:03, 8
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF100 (Diagnosis Status data), entry 0x04 (State Ch4)) | UINT32 | RW | 0xF100:04, 8
Index 1C00Sync manager type
Index | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Usage of the Sync Manager channels | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x04 (4dez)
1C12:01 | SubIndex 001 | 1. assigned RxPDO (contains the index of the corresponding RxPDO Mapping object) | UINT16 | RW | 0x1600 (5632dez)
1C12:02 | SubIndex 002 | 2. assigned RxPDO (contains the index of the corresponding RxPDO Mapping object) | UINT16 | RW | 0x1601 (5633dez)
1C12:03 | SubIndex 003 | 3. assigned RxPDO (contains the index of the corresponding RxPDO Mapping object) | UINT16 | RW | 0x1602 (5634dez)
1C12:04 | SubIndex 004 | 4. assigned RxPDO (contains the index of the corresponding RxPDO Mapping object) | UINT16 | RW | 0x1603 (5635dez)
Index 1C32SM output parameter
Index | Name | Meaning | Data type | Flags | Default
1C32:0 | SM output parameter | Synchronization parameter of the outputs | UINT8 | RO | 0x20 (32dez)
1C32:01 | Sync mode | actual synchronization mode: 0: Free Run 1: Synchron with SM 2 Event 2: DC-Mode - Synchron with SYNC0 Event 3: DC-Mode - Synchron with SYNC1 Event | UINT16 | RW | 0x0000 (0dez)
1C32:02 | Cycle time | Cycle time (in ns): Free Run: cycle time of the local timer Synchron with SM 2 Event: Cycle time of the master DC-Mode: SYNC0/SYNC1 Cycle time | UINT32 | RW | 0x000186A0 (100000dez)
1C32:03 | Shift time | Time between SYNC0 Event and Outputs Valid (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C32:04 | Sync modes supported | Supported synchronization modes: Bit 0 = 1: Free Run is supported Bit 1 = 1: Synchron with SM 2 Event is supported Bit 2-3 = 01: DC-Mode is supported Bit 4-5 = 10: Output Shift with SYNC1 Event (only DC-Mode) Bit 14 = 1: dynamic times (could be measured Messen by writing 1C32:08) | UINT16 | RO | 0xC007 (49159dez)
1C32:05 | Minimum cycle time | Minimum cycle time supported (in ns) | UINT32 | RO | 0x000186A0 (100000dez)
1C32:06 | Calc and copy time | Minimal time between SYNC0 and SYNC1 Event (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C32:08 | Command | 0: Measurement of the times will be stopped 1: Measurement of the times will be started The Entries 1C32:03, 1C32:05, 1C32:06, 1C32:09, 1C33:03, 1C33:06, 1C33:09 will be updated with the maximum measured values. | UINT16 | RW | 0x0000 (0dez)
1C32:09 | Delay time | Time between SYNC1 Event and Outputs Valid (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C32:0B | SM event missed counter | Number of the missed SM-Events in state OPERATIONAL (only in DC Mode) | UINT16 | RO | 0x0000 (0dez)
1C32:0C | Cycle exceeded counter | Number of the exceeded cycles in state OPERATIONAL | UINT16 | RO | 0x0000 (0dez)
1C32:0D | Shift too short counter | Number of the too short distances between SYNC0 and SYNC1 Event (only in DC Mode) | UINT16 | RO | 0x0000 (0dez)
1C32:20 | Sync error | TRUE: In the last cycle the synchronization was not correct (only in DC Mode) | BOOLEAN | RO | 0x00 (0dez)
Index 1C33SM input parameter
Index | Name | Meaning | Data type | Flags | Default
1C33:0 | SM input parameter | Synchronization parameter of the inputs | UINT8 | RO | 0x20 (32dez)
1C33:01 | Sync mode | actual synchronization mode: 0: Free Run 1: Synchron with SM 3 Event (no Outputs available) 2: DC - Synchron with SYNC0 Event 3: DC - Synchron with SYNC1 Event 34: Synchron with SM 2 Event (Outputs available) | UINT16 | RW | 0x0000 (0dez)
1C33:02 | Cycle time | same as 1C32:02 | UINT32 | RW | 0x000186A0 (100000dez)
1C33:03 | Shift time | time between SYNC0-Event and Input Latch (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:04 | Sync modes supported | Supported synchronization modes: Bit 0: Free Run is supported Bit 1: Synchron with SM 2 Event is supported (Outputs available) Bit 1: Synchron with SM 3 Event is supported (no Outputs available) Bit 2-3 = 01: DC-Mode is supported Bit 4-5 = 01: Input Shift with local event (Outputs available) Bit 4-5 = 10: Input Shift with SYNC1 Event (no Outputs available) Bit 14 = 1: dynamic times (could be measured Messen by writing 1C32:08 or 1C33:08) | UINT16 | RO | 0xC007 (49159dez)
1C33:05 | Minimum cycle time | same as 1C32:05 | UINT32 | RO | 0x000186A0 (100000dez)
1C33:06 | Calc and copy time | time between Input Latch and the availability of the inputs for the master (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:08 | Command | same as 1C32:08 | UINT16 | RW | 0x0000 (0dez)
1C33:09 | Delay time | time between SYNC1-Event and Input Latch (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:0B | SM event missed counter | same as 1C32:11 | UINT16 | RO | 0x0000 (0dez)
1C33:0C | Cycle exceeded counter | same as 1C32:12 | UINT16 | RO | 0x0000 (0dez)
1C33:0D | Shift too short counter | same as 1C32:13 | UINT16 | RO | 0x0000 (0dez)
1C33:20 | Sync error | same as 1C32:32 | BOOLEAN | RO | 0x00 (0dez)
Profile specific objects (0x6000-0xFFFF)
The profile specific objects have the same meaning for all EtherCAT Slaves which support the profile 5001.
Index 60n0 IO Inputs Ch.1 - 4 (for 0 ≤ n ≤ 3)
Index | Name | Meaning | Data type | Flags | Default
70n0:0 | IO Outputs Ch.1 - 4 | Max. Subindex | UINT8 | RO | 0x00 (0dez)
70n0:01 | Subindex 001 | IO-Link output process data |  |  |
... | ... | ... |  |  |
70n0:10 | Subindex 016 | IO-Link output process data |  |  |
Index 90n0 IO Info data Ch.1 - 4 (for 0 ≤ n ≤ 3)
Index | Name | Meaning | Data type | Flags | Default
90n0:0 | IO Info data Ch.1 - 4 | Max. Subindex | UINT8 | RO | 0x27 (39dez)
90n0:04 | Device ID | The device ID is used for validating the IO link device. | UINT32 | RO | 0x00000000 (0dez)
90n0:05 | VendorID | The vendor ID is used for validating the manufacturer of the IO link device. | UINT32 | RO | 0x00000000 (0dez)
90n0:07 | IO-Link revision | ID of the specification version based on which the IO link device communicates. Bit 0-3: MinorRev Bit 4-7: MajorRev | UINT8 | RO | 0x00 (0dez)
90n0:20 | FrameCapability | The Frame Capability indicates certain functionalities of the IO link device (e.g. SPDU supported). Bit 0: SPDU Bit 1: Type1 Bit 7: PHY1 | UINT8 | RO | 0x00 (0
90n0:21 | Min cycle time | The cycle time refers to the communication between the IO link master and the IO link device. This value is transferred in the IO link format for Min Cycle Time. Bit 6 und 7: Time Base Bit 0 to 5: Multiplier | UINT8 | RO | 0x00 (0dez)
90n0:22 | Offset time | reserved | UINT8 | RO | 0x00 (0dez)
90n0:23 | Process data in length | These parameters are transferred in the IO link format for "Process data in length". Bit 7: BYTE (indicates whether the value in LENGTH interpreted as bit length [bit not set] or as byte length + 1 [bit set] Bit 6: SIO (indicates whether the device supports the standard IO mode [bit set]) Bit 0 bis 4: LENGTH (length of the process data) | UINT8 | RO | 0x00 (0dez)
90n0:24 | Process data out length | These parameters are transferred in the IO link format for "Process data out length". Bit 7: BYTE (indicates whether the value in LENGTH interpreted as bit length [bit not set] or as byte length + 1 [bit set] Bit 6: SIO (indicates whether the device supports the standard IO mode [bit set]) Bit 0 bis 4: LENGTH (length of the process data) | UINT8 | RO | 0x00 (0dez)
90n0:26 | Reserved | reserved | UINT16 | RO | 0x0000 (0dez)
90n0:27 | Reserved2 | reserved | UINT16 | RO | 0x0000 (0dez)
Index A0n0 IO Diag data Ch.1 - 4 (for 0 ≤ n ≤ 3)
Index | Name | Meaning | Data type | Flags | Default
A0n0:0 | IO Diag data Ch.1 - 4 | Max. Subindex | UINT8 | RO | 0x02 (2dez)
A0n0:01 | IO-Link State | The value of the IO link state corresponds to a state from the IO link master state machine 0: INACTIVE 1: DIGINPUT 2: DIGOUTPUT 3: ESTABLISHCOMM 4: INITMASTER 5: INITDEVICE 8: OPERATE 9: STOP | UINT8 | RO | 0x00 (0dez)
A0n0:02 | Lost Frames | This parameter counts the number of lost IO link telegrams. This value is deleted whenever IO link starts up, otherwise it is incremented continuously. | UINT8 | RO | 0x00 (0dez)
Index F000 Modular device profile
Index | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information about the Modular Device Profile | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Index distance between the objects of two channels | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0004 (4dez)
Index F008 Code word
Index | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index | Name | Meaning | Data type | Flags | Default
F010:0 | Module list | Max. Subindex | UINT8 | RW | 0x04 (4dez)
F010:01 | SubIndex 001 | - | UINT32 | RW | 0x0000184C (6220dez)
F010:02 | SubIndex 002 | - | UINT32 | RW | 0x0000184C (6220dez)
F010:03 | SubIndex 003 | - | UINT32 | RW | 0x0000184C (6220dez)
F010:04 | SubIndex 004 | - | UINT32 | RW | 0x0000184C (6220dez)
Index F100 Diagnosis Status data
Index | Name | Meaning | Data type | Flags | Default
F100:0 | Diagnosis Status data | Max. Subindex | UINT8 | RO | 0x04 (4dez)
F100:01 | State Ch1 | Statusbyte Ch. 1 | UINT8 | RO | 0x00 (0dez)
F100:02 | State Ch2 | Statusbyte Ch. 2 | UINT8 | RO | 0x00 (0dez)
F100:03 | State Ch3 | Statusbyte Ch. 3 | UINT8 | RO | 0x00 (0dez)
F100:04 | State Ch4 | Statusbyte Ch. 4 | UINT8 | RO | 0x00 (0dez)
Index F900 Info data
Index | Name | Meaning | Data type | Flags | Default
F900:0 | Info data | Max. Subindex | UINT8 | RO | 0x09 (9dez)
F900:01 | IO-Link Version | - | UINT8 | RO | 0x10 (16dez)


Error handling and diagnosis

Error handling and diagnosis
Error handling and diagnosis
Additional information
•
Ex6224 – ADS Error Codes


Ex6224 – ADS Error Codes

Error handling and diagnosis [image] Ex6224 – ADS Error Codes
Ex6224 – ADS Error Codes
Error codes are generated in the event of an error during ADS access to an IO-Link device.
The error code contains information about the error category, origin and instance. The possible error codes are listed in table „Error Codes“.
Additional information about a certain error (S_APP_DEV) is listed in table „Additional Code“:
Example of an AdsReturnCode
AdsReturnCode 0x80110700
80: Device Application Error (IO-Link Spec),
11: Index not Available (IO-Link Spec),
0700: General ADS Error
Error Codes (IO-Link Spec)
Type | Origin | Name | Category | Mode | Instance | Value (Hi Byte, hex) | Comment
PDU buffer overflow | remote | S_PDU_BUFFER | ERROR | SiNGLE SHOT | DL | 52 | Device buffer is too small for storing the complete PDU
PDU checksum error (master) | local | M_PDU_CHECK | ERROR | SiNGLE SHOT | DL | 56 | Calculated PDU checksum in master does not match actual received SPDU
PDU checksum error (device) | remote | S_PDU_CHECK | ERROR | SiNGLE SHOT | DL | 56 | Calculated PDU checksum in device does not match actual received SPDU
PDU flow control error | remote | S_PDU_FLOW | ERROR | SiNGLE SHOT | DL | 56 | Violation of flow control rule during transfer of SPDU between master and device
Illegal PDU service primitive (master) | local | M_PDU_ILLEGAL | ERROR | SiNGLE SHOT | AL | 57 | Unknown service primitive or wrong response e.g. Read Response on Write Request
Illegal PDU service primitive (device) | local / remote | S_PDU_ILLEGAL | ERROR | SiNGLE SHOT | AL | 58 | Unknown service primitive e.g. different protocol revision
Communication error | remote | COM_ERR |  | SiNGLE SHOT | unknown | 10 | Negative service response initiated by a communication error, e.g.. IO-Link connection interrupted
Device application error | remote | S_APP_DEV** | ERROR | SiNGLE SHOT | APP | 80 | Service PDU transferred, but not processed due to device error. See error details in Additional Code**
Additional Code (IO-Link Spec)
Type | Value (Lo Byte, hex) | Comment
No details | 00 | Device buffer is too small for storing the complete PDU
Index not available | 11 | Calculated PDU checksum in master does not match actual received SPDU
Subindex not available | 12 | Calculated PDU checksum in device does not match actual received SPDU
Service temporarily not available | 20 | Violation of flow control rule during transfer of SPDU between master and device
Service temporarily not available, local control | 21 | Unknown service primitive or wrong response e.g. Read Response on Write Request
Service temporarily not available, device control | 22 | Unknown service primitive e.g. different protocol revision
Access denied | 23 | Negative service response initiated by a communication error, eg. IO-Link connection interrupted
Parameter value out of range | 30 | Service PDU transferred, but not processed due to device error. See error details in Additional Code
Parameter value above limit | 31 | Service PDU transferred, but not processed due to device error. See error details in Additional Code
Parameter value below limit | 32 | Service PDU transferred, but not processed due to device error. See error details in Additional Code
Interfering parameter | 40 | Service PDU transferred, but not processed due to device error. See error details in Additional Code
Application failure | 81 | Service PDU transferred, but not processed due to device error. See error details in Additional Code
Application not ready | 82 | Service PDU transferred, but not processed due to device error. See error details in Additional Code


Appendix

Appendix
Appendix
Additional information
•
General operating conditions
•
IP67 Box - Accessories


General operating conditions

Appendix [image] General operating conditions
General operating conditions
Protection degrees (IP-Code)
The standard IEC 60529 (DIN EN 60529) defines the degrees of protection in different classes.
1. Number: dust protection and touch guard | Definition
0 | Non-protected
1 | Protected against access to hazardous parts with the back of a hand. Protected against solid foreign objects of Ø 50 mm
2 | Protected against access to hazardous parts with a finger. Protected against solid foreign objects of Ø 12,5 mm.
3 | Protected against access to hazardous parts with a tool. Protected against solid foreign objects Ø 2,5 mm.
4 | Protected against access to hazardous parts with a wire. Protected against solid foreign objects Ø 1 mm.
5 | Protected against access to hazardous parts with a wire. Dust-protected. Intrusion of dust is not totally prevented, but dust shall not penetrate in a quantity to interfere with satisfactory operation of the device or to impair safety.
6 | Protected against access to hazardous parts with a wire. Dust-tight. No intrusion of dust.
2. Number: water* protection | Definition
0 | Non-protected
1 | Protected against water drops
2 | Protected against water drops when enclosure tilted up to 15°.
3 | Protected against spraying water. Water sprayed at an angle up to 60° on either side of the vertical shall have no harmful effects.
4 | Protected against splashing water. Water splashed against the disclosure from any direction shall have no harmful effects
5 | Protected against water jets
6 | Protected against powerful water jets
7 | Protected against the effects of temporary immersion in water. Intrusion of water in quantities causing harmful effects shall not be possible when the enclosure is temporarily immersed in water for 30 min. in 1 m depth.
*) These protection classes define only protection against water!
Chemical Resistance
The Resistance relates to the Housing of the Fieldbus/EtherCAT Box and the used metal parts. In the table below you will find some typical resistance.
Character | Resistance
Steam | at temperatures >100°C: not resistant
Sodium base liquor (ph-Value > 12) | at room temperature: resistant > 40°C: not resistant
Acetic acid | not resistant
Argon (technical clean) | resistant
Key
resistant: Lifetime several months
non inherently resistant: Lifetime several weeks
not resistant: Lifetime several hours resp. early decomposition


IP67 Box - Accessories

Appendix [image] IP67 Box - Accessories
IP67 Box - Accessories
Fixing
Ordering information | Description
ZS5300-0001 | Mounting rail (500 mm x 129 mm)
Marking material, plugs
Ordering information | Description
ZS5000-0000 | Fieldbus Box set M8 (contact labels, plugs)
ZS5000-0002 | Fieldbus Box set M12 (contact labels, plugs)
ZS5000-0010 | plugs M8, IP67 (50 pieces)
ZS5000-0020 | plugs M12, IP67 (50 pieces)
ZS5100-0000 | marking labels, not printed, 4 stripes at 10 pieces
ZS5100-xxxx | printed marking labels, on request
Tools
Ordering information | Description
ZB8800 | torque socket wrench with ratchet wrench for M8 connectors (over molded)
ZB8800-0001 | ratchet wrench for M8 connectors (field assembly)
ZB8800-0002 | ratchet wrench for M12 connectors (over molded)
ZB8801 | torque wrench adjustable for M8 and M12 connectors
ZB8801-0001 | ratched wrench for M8 connectors (over molded)
ZB8801-0002 | ratched wrench for M8 connectors (field assembly) and M12 connectors (over molded)
ZB8801-0003 | ratched wrench for M12 connectors (field assembly)
Note
Further accessories
Further accessories may be found at the price list for Beckhoff fieldbus components and at the internet under http://www.beckhoff.de/english/fieldbus_box/data_sheets.htm?id=69033899254355.