EP5xxx-xxxx - Angle and Position Measurement
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
2.5
▪
Front page updated
▪
Scope of supply added
▪
Structure update
2.4
▪
EP5101-0011: corrected the color of the error LED
▪
EP5151-0002: corrected the color of the error LED
2.3.0
▪
Note Shielding added
2.2.0
▪
Update chapter EP5001-0002 - Signal connection
2.1.0
▪
EP5101-2011 added
▪
Update chapter Mounting
▪
Update chapter Comissioninig/Configuration
▪
Structural update
2.0.0
▪
Migration
▪
EP5001-0002 added
▪
Renamed to EP5xxx
▪
Several chapters updated
1.6.0
▪
Pin assignment updated
▪
Status LEDs updated
▪
Chapter on Nut torque for connectors updated
▪
Accessories updated
1.5.0
▪
Power Connection updated
1.4.0
▪
Introduction expanded
1.3.0
▪
EP5101-1002 and EP5151-0002 added to title page
▪
EP51x1 - EP5101-1002 and EP5151-0002 added to Introduction
▪
EP5151 signal level (interface signal level) added
▪
Status LEDs extended with EP5101-1002 and EP5151-0002
▪
Technical data extended with EP5101-1002 and EP5151-0002
▪
Encoder connection, M12, 8-pin extended with EP5151
▪
Information on basic function principles amended
▪
Parameters and modes amended
▪
EP5151-0002 process image added
▪
EP5101-0002 process image amended
▪
Notes on the documentation updated
▪
Support & Service updated
▪
Safety instructions updated
▪
EtherCAT cables updated
▪
EtherCAT Box accessories updated
▪
Nut torques for connectors updated
▪
EtherCAT connection updated
▪
Mounting instructions updated
1.2.0
▪
Interface signal level amended (single-ended and differential signals)
1.1.0
▪
Description of the power connection updated
▪
Notes on using EtherCAT Box modules (EPxxxx-xxxx) in potentially explosive atmospheres (ATEX) added to documentation.
1.0.0
▪
First release
Firmware and hardware versions
This documentation refers to the firmware and hardware version that was applicable at the time the documentation was written.
The module features are continuously improved and developed further. Modules having earlier production statuses cannot have the same properties as modules with the latest status. However, existing properties are retained and are not changed, so that older modules can always be replaced with new ones.
The firmware and hardware version (delivery state) can be found in the batch number (D-number) printed on the side of the EtherCAT Box.
Syntax of the batch number (D-number)
D: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with D no. 29 10 02 01:
29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01
Further information on this topic: Version identification of EtherCAT devices.


EtherCAT Box - Introduction

EtherCAT Box - Introduction
EtherCAT Box - Introduction
The EtherCAT system has been extended with EtherCAT Box modules with protection class IP 67. Through the integrated EtherCAT interface the modules can be connected directly to an EtherCAT network without an additional Coupler Box. The high-performance of EtherCAT is thus maintained into each module.
The extremely low dimensions of only 126 x 30 x 26.5 mm (h x w x d) are identical to those of the Fieldbus Box extension modules. They are thus particularly suitable for use where space is at a premium. The small mass of the EtherCAT modules facilitates applications with mobile I/O interface (e.g. on a robot arm). The EtherCAT connection is established via screened M8 connectors.
EtherCAT Box Modules within an EtherCAT network
The robust design of the EtherCAT Box modules enables them to be used directly at the machine. Control cabinets and terminal boxes are now no longer required. The modules are fully sealed and therefore ideally prepared for wet, dirty or dusty conditions.
Pre-assembled cables significantly simplify EtherCAT and signal wiring. Very few wiring errors are made, so that commissioning is optimized. In addition to pre-assembled EtherCAT, power and sensor cables, field-configurable connectors and cables are available for maximum flexibility. Depending on the application, the sensors and actuators are connected through M8 or M12 connectors.
The EtherCAT modules cover the typical range of requirements for I/O signals with protection class IP67:
▪
digital inputs with different filters (3.0 ms or 10 μs)
▪
digital outputs with 0.5 or 2 A output current
▪
analog inputs and outputs with 16 bit resolution
▪
Thermocouple and RTD inputs
▪
Stepper motor modules
XFC (eXtreme Fast Control Technology) modules, including inputs with time stamp, are also available.
EtherCAT Box with M8 connections for sensors/actuators
EtherCAT Box with M12 connections for sensors/actuators
Basic EtherCAT documentation
You will find a detailed description of the EtherCAT system in the Basic System Documentation for EtherCAT, which is available for download from our website (www.beckhoff.com) under Downloads.
EtherCAT XML Device Description
You will find XML files (XML Device Description Files) for Beckhoff EtherCAT modules on our website (www.beckhoff.com) under Downloads, in the Configuration Files area.


Product overview

Product overview
Product overview
Additional information
•
Module overview EP5xxx
•
EP5001-0002
•
EP5101-x002
•
EP5101-x011
•
EP5151-0002


Module overview EP5xxx

Product overview [image] Module overview EP5xxx
Module overview EP5xxx
SSI encoder interface
Module | Connection encoder/sensor | Number of channels | Sensor supply | Comment
EP5001-0002 | M12, screw type | 1 | 24 VDC | Distributed-Clocks
Incremental encoder interface with differential inputs
Module | Connection encoder/sensor | Number of channels | Sensor supply | Comment
EP5101-0002 | M12, screw-type, 8-pin | 1 | +5 VDC, 150 mA (VCC) | Distributed clocks, 4 million increments/second
EP5101-1002 |  | 1 | 24 VDC, 500 mA (VCC)
EP5101-0011 | D-Sub-socket, 15-pin | 1 | +5 VDC, 150 mA (VCC) | Distributed clocks 4 million increments/second Latch, gate
EP5101-2011 |  | 1 |  | Distributed clocks 20 million increments/second Latch, gate
Incremental encoder interface with single-ended inputs
Module | Connection encoder/sensor | Number of channels | Sensor supply | Comment
EP5151-0002 | M12, screw-type, 8-pin | 1 | 24 VDC, 0.5 A | Distributed clocks 4 million increments/second Latch, gate


EP5001-0002

Product overview [image] EP5001-0002
EP5001-0002
Additional information
•
EP5001-0002 - Introduction
•
EP5001-0002 - Technical data
•
EP5001-0002 - Scope of supply
•
EP5001-0002 - Process image


EP5001-0002 - Introduction

Product overview [image] EP5001-0002 [image] EP5001-0002 - Introduction
EP5001-0002 - Introduction
EP5001-0002
EP5001-0002 SSI encoder interface
The EP5001-0002 EtherCAT Box is an interface for direct connection of an SSI encoder with differential inputs (RS422). The interface circuit generates a pulse for reading the encoder, and makes the incoming data stream available to the controller as a data word in the process image. Various operating modes, transmission frequencies and bit widths can be permanently stored in a control register. The encoder is connected via an 8-pin M12 socket.
Quick links


EP5001-0002 - Technical data

Product overview [image] EP5001-0002 [image] EP5001-0002 - Technical data
EP5001-0002 - Technical data
Technical data | EP5001-0002
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Number of channels | 1
Channel connections | M12, screw type
Encoder connection | Binary input: D+, D-, binary outputs: CI+, CI-
Rated voltage | 24 VDC (-15%/+ 20%)
Signal type | differential (RS422)
Distributed-Clocks | yes
Data transfer rates | Adjustable up to 1 MHz, 250 kHz preset
Serial input | 24-bit width (adjustable)
Data direction | Read
Power supply connection | Power supply: 1 x M8 connector, 4-pin; downstream connection: 1 x M8 socket, 4-pin
Current consumption from US | typ. 130 mA + sensor supply
Width in the process image | 1 x 32-bit input, 8-bit status
Electrical isolation | 500 V
Special features | Baud rate, coding and data length are adjustable
Weight | app. 165 g
Operating/storage temperature | 0…+55 °C / -25…+85 °C
Vibration/shock resistance | conforms to EN 60068-2-6/EN 60068-2-27
EMC immunity/emission | conforms to EN 61000-6-2/EN 61000-6-4
Protect. class / installation pos. | IP65/66/67 (according to EN 60529)/variable
Approvals | CE


EP5001-0002 - Scope of supply

Product overview [image] EP5001-0002 [image] EP5001-0002 - Scope of supply
EP5001-0002 - Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EtherCAT Box EP5001-0002
▪
2x protective cap for EtherCAT socket, M8, green (pre-assembled)
▪
1x protective cap for supply voltage input, M8, transparent (pre-assembled)
▪
1x protective cap for supply voltage output, M8, black (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


EP5001-0002 - Process image

Product overview [image] EP5001-0002 [image] EP5001-0002 - Process image
EP5001-0002 - Process image
TwinCAT shows the data of the EP5001-0002 in a tree structure.
EP5001-0002 - ProcDataTree
SSI Inputs
Status
▪
Data error
SSI input error
▪
Frame error
Wrong data frame
▪
Power failure
An encoder-specific error has occurred. Enabling through Enable Power failure bit (index 0x8000:02)
▪
Sync error
EtherCAT error, see EtherCAT system documentation
▪
TxPDO State
See object description
▪
TxPDO Toggle
See object description
Counter value
Current encoder counter value


EP5101-x002

Product overview [image] EP5101-x002
EP5101-x002
Additional information
•
EP5101-x002 - Introduction
•
EP5101-x002 - Technical data
•
EP5101-x002 - Scope of supply
•
EP5101-x002 - Process image


EP5101-x002 - Introduction

Product overview [image] EP5101-x002 [image] EP5101-x002 - Introduction
EP5101-x002 - Introduction
EP5101-x0xx | Incremental encoder interface with differential inputs
The EtherCAT Box EP5101-x0xx is an interface for direct connection of incremental encoders with differential inputs (RS422). A 32/16-bit counter with quadrature decoder as well as a 32/16-bit latch for the zero pulse can be read, set or activated. Incremental encoders with a fault message output can be connected to the status input of the interface. A period measurement with a resolution of up to 100 ns is possible. The gate input allows the counter to be disabled; the latch input accepts the counter reading on the rising edge. The EP5101-1002 has a 24 VDC sensor supply.
Due to the optional interpolating micro-increment function, the EP5101 can supply even more precise axis positions for dynamic axes. In addition to that it supports the synchronous reading of the encoder value together with other input data in the EtherCAT system via high precision EtherCAT Distributed Clocks (DC).
The encoder is connected via an 8-pin M12 socket (EP5101-0002 and EP5101-1002) or via a 15-pin D-sub socket (EP5101-0011 and EP5101-2011). In the M12 version not all signals are available.
Quick links


EP5101-x002 - Technical data

Product overview [image] EP5101-x002 [image] EP5101-x002 - Technical data
EP5101-x002 - Technical data
Technical data | EP5101-0002 | EP5101-1002
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Number of encoder inputs | 1
Encoder connection | A, EP5101-x0xx - Technische Daten_Aneg , B, EP5101-x0xx - Technische Daten_Bneg , C, Grafik aus EP5101-x0xx - Technische Daten_Cneg (RS422/RS485 differential inputs) also single-ended connection (5 V ±20%) possible
Encoder connection | M12 socket, 8-pin
Encoder supply | +5 VDC, 150 mA | +24 VDC
Counter | 32 bit or 16 bit, binary
Limit frequency | 4 million increments/s (with four-fold evaluation)
Quadrature decoder | Four-fold evaluation
Zero-pulse latch | Bit 16
Commands | read, set, enable
Distributed Clocks | yes
Supply of the module electronics | from the control voltage US
Current consumption of the module electronics | typically 130 mA + load
Power supply connection | Power supply: 1 x M8 plug, 4-pole Onward connection: 1 x M8 socket, 4-pole
Process image | Inputs: 32 bit data, 8 bit status Outputs: 16 bit data, 8 bit control
Electrical isolation | Control voltage / fieldbus: 500 V
Permissible ambient temperature during operation | -25...+60°C 0...+55°C conforms to ATEX -25...+55°C conforms to cURus
Permissible ambient temperature during storage | -40...+85°C
Vibration / shock resistance | conforms toEN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms toEN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable
Approvals | CE, cURus, ATEX | CE, cURus


EP5101-x002 - Scope of supply

Product overview [image] EP5101-x002 [image] EP5101-x002 - Scope of supply
EP5101-x002 - Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EtherCAT Box EP5101-x002
▪
2x protective cap for EtherCAT socket, M8, green (pre-assembled)
▪
1x protective cap for supply voltage input, M8, transparent (pre-assembled)
▪
1x protective cap for supply voltage output, M8, black (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


EP5101-x002 - Process image

Product overview [image] EP5101-x002 [image] EP5101-x002 - Process image
EP5101-x002 - Process image
TwinCAT shows the data of the EP5101-0002 and EP5101-1002 in a tree structure, using the EP5101-0002 as an example.
EP5101-0002 - ProcDataTree
ENC Status Compact
Input data of the encoder interface
Status
▪
Latch C valid
New data are available in the process data Latch value. Reset via Enable latch C
▪
Set Counter done
Acknowledgement for setting the Set counter
▪
Counter underflow
The counter is lower than the lowest counter value that can be displayed
▪
Counter overflow
The counter is higher than the highest counter value that can be displayed
▪
Open circuit
One of the channels (A, B or C) has an open circuit (configurable for each channel via CoE)
▪
Extrapolation stall
Micro-increment value invalid (when micro-increment evaluation is enabled -> index 0x8000:0A)
▪
Status of Input A, B,C
Status of inputs A, B and C
▪
Sync error
EtherCAT error, see EtherCAT system documentation
▪
TxPDO State
See object description
▪
TxPDO Toggle
See object description
Counter value
Current encoder counter value
Latch value
Counter value of the encoder with rising edge at the latch input
ENC Control Compact
Output data of the encoder interface.
Control
▪
Enable latch C
Input C is activated. When an edge is encountered, the Counter value is stored in Latch value.
▪
Set counter
When a positive edge is encountered, the Set counter value is transferred to the Counter value
Set Counter value
Preselection value for Counter value


EP5101-x011

Product overview [image] EP5101-x011
EP5101-x011
Additional information
•
EP5101-x011 - Introduction
•
EP5101-x011 - Technical data
•
EP5101-x011 - Scope of supply
•
EP5101-0011 - Process image
•
EP5101-2011 - Process image


EP5101-x011 - Introduction

Product overview [image] EP5101-x011 [image] EP5101-x011 - Introduction
EP5101-x011 - Introduction
EP5101-x0xx | Incremental encoder interface with differential inputs
The EtherCAT Box EP5101-x0xx is an interface for direct connection of incremental encoders with differential inputs (RS422). A 32/16-bit counter with quadrature decoder as well as a 32/16-bit latch for the zero pulse can be read, set or activated. Incremental encoders with a fault message output can be connected to the status input of the interface. A period measurement with a resolution of up to 100 ns is possible. The gate input allows the counter to be disabled; the latch input accepts the counter reading on the rising edge. The EP5101-1002 has a 24 VDC sensor supply.
Due to the optional interpolating micro-increment function, the EP5101 can supply even more precise axis positions for dynamic axes. In addition to that it supports the synchronous reading of the encoder value together with other input data in the EtherCAT system via high precision EtherCAT Distributed Clocks (DC).
The encoder is connected via an 8-pin M12 socket (EP5101-0002 and EP5101-1002) or via a 15-pin D-sub socket (EP5101-0011 and EP5101-2011). In the M12 version not all signals are available.
Quick links


EP5101-x011 - Technical data

Product overview [image] EP5101-x011 [image] EP5101-x011 - Technical data
EP5101-x011 - Technical data
Technical data | EP5101-0011 | EP5101-2011
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Number of encoder inputs | 1
Encoder connection | A, EP5101-x0xx - Technische Daten_Aneg , B, EP5101-x0xx - Technische Daten_Bneg , C, Grafik aus EP5101-x0xx - Technische Daten_Cneg (RS422/RS485 differential inputs) also single-ended connection (5 V ±20%) possible, Latch, Gate
Encoder connection | D-Sub-socket, 15-pin
Encoder supply | +5 VDC, 150 mA
Counter | 32 bit or 16 bit, binary
Limit frequency | 4 million increments/s (with four-fold evaluation) | 20 million increments/s (with four-fold evaluation)
Quadrature decoder | Four-fold evaluation
Zero-pulse latch | Bit 16
Commands | read, set, enable
Distributed Clocks | yes
Supply of the module electronics | from the control voltage US
Current consumption of the module electronics | typically 130 mA + load
Power supply connection | Power supply: 1 x M8 plug, 4-pole Onward connection: 1 x M8 socket, 4-pole
Process image | Inputs: 32 bit data, 8 bit status Outputs: 16 bit data, 8 bit control
Electrical isolation | Control voltage / fieldbus: 500 V
Permissible ambient temperature during operation | -25...+60°C -25...+55°C conforms to cURus
Permissible ambient temperature during storage | -40...+85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable
Approvals | CE, cURus


EP5101-x011 - Scope of supply

Product overview [image] EP5101-x011 [image] EP5101-x011 - Scope of supply
EP5101-x011 - Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EtherCAT Box EP5101-x011
▪
2x protective cap for EtherCAT socket, M8, green (pre-assembled)
▪
1x protective cap for supply voltage input, M8, transparent (pre-assembled)
▪
1x protective cap for supply voltage output, M8, black (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


EP5101-0011 - Process image

Product overview [image] EP5101-x011 [image] EP5101-0011 - Process image
EP5101-0011 - Process image
TwinCAT shows the data of the EP5101-0011 in a tree structure.
ENC Status Compact
Status
▪
Latch C valid
New data are available in the process data Latch value. Reset via Enable latch C
▪
Latch extern valid
New data are available in the process data Latch value. Reset through Enable latch extern on positive/negative edge
▪
Set Counter done
Acknowledgement for setting the Set counter
▪
Counter underflow
The counter is lower than the lowest counter value that can be displayed
▪
Counter overflow
The counter is higher than the highest counter value that can be displayed
▪
Status of input status
Status of the error signal (typically from the encoder)
▪
Open circuit
One of the channels (A, B or C) has an open circuit (configurable for each channel via CoE)
▪
Extrapolation stall
Micro-increment value invalid (when micro-increment evaluation is enabled -> index 0x8000:0A)
▪
Status of Input A, B,C
Status of inputs A, B and C
▪
Status of input gate
Status of the gate input
▪
Status of extern latch
Status of the latch input
▪
Sync error
EtherCAT error, see EtherCAT system documentation
▪
TxPDO State
See object description
▪
TxPDO Toggle
See object description
Counter value
Current encoder counter value
Latch value
Counter value of the encoder with rising edge at the latch input
ENC Control Compact
Output data of the encoder interface.
Control
▪
Enable latch C
Input C is activated. When an edge is encountered, the Counter value is stored in Latch value.
▪
Enable latch extern on positive edge
External latch input is enabled. When a positive edge is encountered, the Counter value is stored in Latch value.
▪
Set counter
When a positive edge is encountered, the Set counter value is transferred to the Counter value
▪
Enable latch extern on negative edge
External latch input is enabled. When a negative edge is encountered, the Counter value is stored in Latch value.
Set Counter value
Preselection value for Counter value


EP5101-2011 - Process image

Product overview [image] EP5101-x011 [image] EP5101-2011 - Process image
EP5101-2011 - Process image
TwinCAT shows the data of the EP5101-2011 in a tree structure.
ENC Status Compact
Status
▪
Latch C valid
New data are available in the process data Latch value. Reset via Enable latch C
▪
Latch extern valid
New data are available in the process data Latch value. Reset through Enable latch extern on positive/negative edge
▪
Set Counter done
Acknowledgement for setting the Set counter
▪
Status of input status
Status of the error signal (typically from the encoder)
▪
Open circuit
One of the channels (A, B or C) has an open circuit (configurable for each channel via CoE)
▪
Status of Input A, B,C
Status of inputs A, B and C
▪
Status of input gate
Status of the gate input
▪
Status of extern latch
Status of the latch input
▪
Sync error
EtherCAT error, see EtherCAT system documentation
▪
TxPDO State
See object description
▪
TxPDO Toggle
See object description
Counter value
Current encoder counter value
Latch value
Counter value of the encoder with rising edge at the latch input
ENC Control Compact
Output data of the encoder interface.
Control
▪
Enable latch C
Input C is activated. When an edge is encountered, the Counter value is stored in Latch value.
▪
Enable latch extern on positive edge
External latch input is enabled. When a positive edge is encountered, the Counter value is stored in Latch value.
▪
Set counter
When a positive edge is encountered, the Set counter value is transferred to the Counter value
▪
Enable latch extern on negative edge
External latch input is enabled. When a negative edge is encountered, the Counter value is stored in Latch value.
Set Counter value
Preselection value for Counter value


EP5151-0002

Product overview [image] EP5151-0002
EP5151-0002
Additional information
•
EP5151-0002 – Introduction
•
EP5151-0002 - Technical data
•
EP5151-0002 - Scope of supply
•
EP5151-0002 - Process image


EP5151-0002 – Introduction

Product overview [image] EP5151-0002 [image] EP5151-0002 – Introduction
EP5151-0002 – Introduction
EP5151-0002 | Incremental encoder interface with single-ended inputs
The EP5151-0002 EtherCAT Box is an interface for direct connection of incremental encoders with 24 V DC inputs. A 32/16-bit counter with quadrature decoder as well as a 32/16-bit latch for the zero pulse can be read, set or activated. A period measurement with a resolution of up to 100 ns is possible.
Due to the optional interpolating micro-increment function, the EP5151-0002 can supply even more precise axis positions for dynamic axes. In addition to that it supports the synchronous reading of the encoder value together with other input data in the EtherCAT system via high precision EtherCAT Distributed Clocks (DC). The encoder is connected via an 8-pin M12 socket.


EP5151-0002 - Technical data

Product overview [image] EP5151-0002 [image] EP5151-0002 - Technical data
EP5151-0002 - Technical data
Technical data | EP5151-0002
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Number of encoder inputs | 1
Encoder connection | A, B,C, (24 VDC), Latch, Gate
Encoder connection | M12 socket, 8-pin
Encoder supply | +24 VDC
Counter | 32 bit or 16 bit, binary
Limit frequency | 4 million increments/s (with fourfold evaluation)
Quadrature decoder | Four-fold evaluation
Zero-pulse latch | Bit 16
Commands | read, set, enable
Distributed Clocks | yes
Supply of the module electronics | from the control voltage US
Current consumption of the module electronics | typically 130 mA + load
Power supply connection | Power supply: 1 x M8 plug, 4-pole Onward connection: 1 x M8 socket, 4-pole
Process image | Inputs: 32 bit data, 8 bit status Outputs: 16 bit data, 8 bit control
Electrical isolation | Control voltage / fieldbus: 500 V
Permissible ambient temperature during operation | -25...+60°C -25...+55°C conforms to cURus
Permissible ambient temperature during storage | -40...+85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable
Approvals | CE, cURus


EP5151-0002 - Scope of supply

Product overview [image] EP5151-0002 [image] EP5151-0002 - Scope of supply
EP5151-0002 - Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EtherCAT Box EP5151-0002
▪
2x protective cap for EtherCAT socket, M8, green (pre-assembled)
▪
1x protective cap for supply voltage input, M8, transparent (pre-assembled)
▪
1x protective cap for supply voltage output, M8, black (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


EP5151-0002 - Process image

Product overview [image] EP5151-0002 [image] EP5151-0002 - Process image
EP5151-0002 - Process image
ENC Status Compact
Status
▪
Latch C valid
New data are available in the process data Latch value. Reset via Enable latch C
▪
Latch extern valid
New data are available in the process data Latch value. Reset through Enable latch extern on positive/negative edge
▪
Set Counter done
Acknowledgement for setting the Set counter
▪
Counter underflow
The counter is lower than the lowest counter value that can be displayed
▪
Counter overflow
The counter is higher than the highest counter value that can be displayed
▪
Status of input status
Status of the error signal (typically from the encoder)
▪
Open circuit
One of the channels (A, B or C) has an open circuit (configurable for each channel via CoE)
▪
Extrapolation stall
Micro-increment value invalid (when micro-increment evaluation is enabled -> index 0x8000:0A)
▪
Status of Input A, B,C
Status of inputs A, B and C
▪
Status of input gate
Status of the gate input
▪
Status of extern latch
Status of the latch input
▪
Sync error
EtherCAT error, see EtherCAT system documentation
▪
TxPDO State
See object description
▪
TxPDO Toggle
See object description
Counter value
Current encoder counter value
Latch value
Counter value of the encoder with rising edge at the latch input
ENC Control Compact
Output data of the encoder interface.
Control
▪
Enable latch C
Input C is activated. When an edge is encountered, the Counter value is stored in Latch value.
▪
Enable latch extern on positive edge
External latch input is enabled. When a positive edge is encountered, the Counter value is stored in Latch value.
▪
Set counter
When a positive edge is encountered, the Set counter value is transferred to the Counter value
▪
Enable latch extern on negative edge
External latch input is enabled. When a negative edge is encountered, the Counter value is stored in Latch value.
Set Counter value
Preselection value for Counter value


Mounting and connection

Mounting and connection
Mounting and connection
Additional information
•
Mounting
•
EtherCAT
•
Supply voltages
•
Signal connection and meaning of the LEDs
•
UL Requirements
•
ATEX notes


Mounting

Mounting and connection [image] Mounting
Mounting
Additional information
•
Dimensions
•
Fixing
•
Additional checks


Dimensions

Mounting and connection [image] Mounting [image] Dimensions
Dimensions
Dimensions
All dimensions are given in millimeters.
Housing features
Housing material | PA6 (polyamide)
Sealing compound | polyurethane
Mounting | two fastening holes Ø 3.5 mm for M3
Metal parts | brass, nickel-plated
Contacts | CuZn, gold-plated
Power feed through | max. 4 A
Installation position | variable
Protection class | IP65, IP66, IP67 (conforms to EN 60529) when screwed together
Dimensions (H x W x D) | approx. 126 x 30 x 26.5 mm (without connectors)


Fixing

Mounting and connection [image] Mounting [image] Fixing
Fixing
Note
Dirt during assembly
Dirty connectors can lead to malfunctions. Protection class IP67 can only be guaranteed if all cables and connectors are connected.
•
Protect the plug connectors against dirt during the assembly.
Mount the module with two M3 screws on the fastening holes in the corners of the module. The fastening holes have no thread.


Additional checks

Mounting and connection [image] Mounting [image] Additional checks
Additional checks
The boxes have undergone the following additional tests:
Verification | Explanation
Vibration | 10 frequency runs in 3 axes
 | 5 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 35 g, 11 ms


EtherCAT

Mounting and connection [image] EtherCAT
EtherCAT
Additional information
•
Connectors
•
Status LEDs
•
Cables


Connectors

Mounting and connection [image] EtherCAT [image] Connectors
Connectors
Note
Risk of confusion: supply voltages and EtherCAT
Defect possible through incorrect insertion.
•
Observe the color coding of the connectors:
black: Supply voltages
green: EtherCAT
EtherCAT Box Modules have two green M8 sockets for the incoming and downstream EtherCAT connections.
EtherCAT connectors
Connection
M8 socket, 4-pin – connection
M8 socket
EtherCAT | M8 connector | Core colors
Signal | Contact | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 and old versions of ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | 1 | yellow1) | orange/white | white/orange
Tx - | 4 | orange1) | orange | orange
Rx + | 2 | white1) | blue/white | white/green
Rx - | 3 | blue1) | blue | green
Shield | Housing | Shield | Shield | Shield
1) Core colors according to EN 61918
Adaptation of core colors for cables ZB9030, ZB9032 and ZK1090-3xxxx-xxxx
For standardization, the core colors of the ZB9030, ZB9032 and ZK1090-3xxx-xxxx cables have been changed to the EN61918 core colors: yellow, orange, white, blue. So there are different color codes in circulation. The electrical properties of the cables have been retained when the core colors were changed.


Status LEDs

Mounting and connection [image] EtherCAT [image] Status LEDs
Status LEDs
EtherCAT status LEDs
L/A (Link/Act)
A green LED labelled "L/A" is located next to each EtherCAT socket. The LED indicates the communication state of the respective socket:
LED | Meaning
off | no connection to the connected EtherCAT device
lit | LINK: connection to the connected EtherCAT device
flashes | ACT: communication with the connected EtherCAT device
Run
Each EtherCAT slave has a green LED labelled "Run". The LED signals the status of the slave in the EtherCAT network:
LED | Meaning
off | Slave is in "Init" state
flashes uniformly | Slave is in "Pre-Operational“ state
flashes sporadically | Slave is in "Safe-Operational" state
lit | Slave is in "Operational" state
Description of the EtherCAT slave states


Cables

Mounting and connection [image] EtherCAT [image] Cables
Cables
For connecting EtherCAT devices only shielded Ethernet cables that meet the requirements of at least category 5 (CAT5) according to EN 50173 or ISO/IEC 11801 should be used.
EtherCAT uses four wires for signal transmission.
Thanks to automatic line detection ("Auto MDI-X"), both symmetrical (1:1) or cross-over cables can be used between Beckhoff EtherCAT.
Detailed recommendations for the cabling of EtherCAT devices


Supply voltages

Mounting and connection [image] Supply voltages
Supply voltages
The EtherCAT Box is supplied with two supply voltages. The supply voltages are electrically isolated in the EtherCAT Box.
▪
Control voltage US
▪
Peripheral voltage UP
Redirection of the supply voltages
The IN and OUT power connections are bridged in the module (not IP204x-Bxxx and IE204x). The supply voltages US and UP can thus easily be transferred from EtherCAT Box to EtherCAT Box.
Note
Pay attention to the maximum permissible current!
Pay attention also for the redirection of the supply voltages US and UP, the maximum permissible current for M8 connectors of 4 A must not be exceeded!
Additional information
•
Connectors
•
Status LEDs
•
Conductor losses


Connectors

Mounting and connection [image] Supply voltages [image] Connectors
Connectors
Note
Risk of confusion: supply voltages and EtherCAT
Defect possible through incorrect insertion.
•
Observe the color coding of the connectors:
black: Supply voltages
green: EtherCAT
Connectors for supply voltages
M8 connector
Contact | Function | Description | Core color 1)
1 | US | Control voltage | Brown
2 | UP | Peripheral voltage | White
3 | GNDS | GND to US | Blue
4 | GNDP | GND to UP | Black
1) The core colors apply to cables of the type: Beckhoff ZK2020-3xxx-xxxx


Status LEDs

Mounting and connection [image] Supply voltages [image] Status LEDs
Status LEDs
Connectors + LEDs
Status LEDs for the supply voltages
LED | Display | Meaning
US (control voltage) | off | Supply voltage US is not present
 | green illuminated | Supply voltage US is present
UP (peripheral voltage) | off | Supply voltage UP is not present
 | green illuminated | Supply voltage UP is present


Conductor losses

Mounting and connection [image] Supply voltages [image] Conductor losses
Conductor losses
Take into account the voltage drop on the supply line when planning a system. Avoid the voltage drop being so high that the supply voltage at the box lies below the minimum nominal voltage.
Variations in the voltage of the power supply unit must also be taken into account.
Voltage drop on the supply line
Leitungsverluste M8 2A
Leitungsverluste M8 4A


Signal connection and meaning of the LEDs

Mounting and connection [image] Signal connection and meaning of the LEDs
Signal connection and meaning of the LEDs
Additional information
•
Shielding
•
EP5001-0002 - Signal connection
•
EP5101-x0xx - Signal connection
•
EP5151-0002 - Signal connection


Shielding

Mounting and connection [image] Signal connection and meaning of the LEDs [image] Shielding
Shielding
Shielding
Encoder, analog sensors and actors should always be connected with shielded, twisted paired wires.


EP5001-0002 - Signal connection

Mounting and connection [image] Signal connection and meaning of the LEDs [image] EP5001-0002 - Signal connection
EP5001-0002 - Signal connection
EP5001-0002, pin assignment M12
LED indicators - meanings
EP5001-0002, LEDs
LED | green | red
Data | Encoder supply switched on (operational state, not short-circuited) | SSI without power supply Open circuit on the SSI data input D+ or D- Data cables interchanged The SSI input is at Low level, no data transfer takes place. Incorrect parameterization in the CoE Wire breakage in the clock lines
CLOCK | No function


EP5101-x0xx - Signal connection

Mounting and connection [image] Signal connection and meaning of the LEDs [image] EP5101-x0xx - Signal connection
EP5101-x0xx - Signal connection
Encoder pin assignment, M12, socket, 8-pin
EP5101-0002, EP5101-1002 pin assignment
EP5101-0002, EP5101-1002 LEDs
LED indicators - meanings
Connection | LED | Display | Meaning
M12 | A | off | Input A / track A low
 |  | green | Input A / track A high
 | B | off | Input B / track B low
 |  | green | Input B / track B high
 | C | off | Input C / track C low
 |  | green | Input C / track C high
Encoder pin assignment, D-sub socket, 15-pin
EP5101-0011, pin assignment
EP5101-0011, LEDs
LED indicators - meanings
Connection | LED | Display | Meaning
D sub | A | off | Input A / track A low
 |  | green | Input A / track A high
 | B | off | Input B / track B low
 |  | green | Input B / track B high
 | C | off | Input C / track C low
 |  | green | Input C / track C high
 | L | off | Input Latch low
 |  | green | Input Latch high
 | G | off | Input Gate low
 |  | green | Input Gate high
 | E | off | Input Error low
 |  | red | Input Error high


EP5151-0002 - Signal connection

Mounting and connection [image] Signal connection and meaning of the LEDs [image] EP5151-0002 - Signal connection
EP5151-0002 - Signal connection
Encoder connection, M12 socket, 8-pin
EP5151-0002, pin assignment
LED indicators - meanings
EP5151-0002, LEDs
Connection | LED | Display | Meaning
M12 | A | off | Input A / track A low
 |  | green | Input A / track A high
 | B | off | Input B / track B low
 |  | green | Input B / track B high
 | C | off | Input C / track C low
 |  | green | Input C / track C high
 | L | off | Input Latch low
 |  | green | Input Latch high
 | G | off | Input Gate low
 |  | green | Input Gate high
 | E | off | Input Error low
 |  | red | Input Error high


UL Requirements

Mounting and connection [image] UL Requirements
UL Requirements
The installation of the EtherCAT Box Modules certified by UL has to meet the following requirements.
Supply voltage
SmallWarningYellow CAUTION
CAUTION!
This UL requirements are valid for all supply voltages of all marked EtherCAT Box Modules!
For the compliance of the UL requirements the EtherCAT Box Modules should only be supplied
•
by a 24 VDC supply voltage, supplied by an isolating source and protected by means of a fuse (in accordance with UL248), rated maximum 4 Amp, or
•
by a 24 VDC power source, that has to satisfy NEC class 2.
A NEC class 2 power supply shall not be connected in series or parallel with another (class 2) power source!
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, the EtherCAT Box Modules must not be connected to unlimited power sources!
Networks
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, EtherCAT Box Modules must not be connected to telecommunication networks!
Ambient temperature range
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, EtherCAT Box Modules has to be operated only at an ambient temperature range of 0 to 55°C!
Marking for UL
All EtherCAT Box Modules certified by UL (Underwriters Laboratories) are marked with the following label.
UL label


ATEX notes

Mounting and connection [image] ATEX notes
ATEX notes
Additional information
•
ATEX - Special conditions
•
BG2000 - EtherCAT Box protection enclosures
•
ATEX Documentation


ATEX - Special conditions

Mounting and connection [image] ATEX notes [image] ATEX - Special conditions
ATEX - Special conditions
SmallWarningYellow WARNING
Observe the special conditions for the intended use of EtherCAT Box modules in potentially explosive areas – directive 94/9/EU.
•
The certified components are to be installed with a BG2000-0000 or BG2000-0010 protection enclosure that guarantees a protection against mechanical hazards!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of 0 to 55°C for the use of EtherCAT Box modules in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0: 2006
▪
EN 60079-15: 2005
Marking
The EtherCAT Box modules certified for potentially explosive areas bear the following marking:
II 3 G Ex nA II T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
or
II 3 G Ex nA nC IIC T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
Batch number (D number)
The EtherCAT Box modules bear a batch number (D number) that is structured as follows:
D: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with batch number 29 10 02 01:
29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01


BG2000 - EtherCAT Box protection enclosures

Mounting and connection [image] ATEX notes [image] BG2000 - EtherCAT Box protection enclosures
BG2000 - EtherCAT Box protection enclosures
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the EtherCAT system into a safe, powered down state before starting installation, disassembly or wiring of the modules!
ATEX
SmallWarningYellow WARNING
Mount a protection enclosure!
To fulfill the special conditions according to ATEX, a BG2000-0000 or BG2000-0010 protection enclosure has to be mounted over the EtherCAT Box.
Installation
Put the cables for EtherCAT, power supply and sensors/actuators through the hole of the protection enclosure.
BG2000 - putting the cables
Fix the wires for EtherCAT, power supply and sensors/actuators to the EtherCAT Box.
BG2000 - fixing the cables
Mount the protection enclosure over the EtherCAT Box.
BG2000 - mounting the protection enclosure


ATEX Documentation

Mounting and connection [image] ATEX notes [image] ATEX Documentation
ATEX Documentation
Notes about operation of EtherCAT Box Modules (EPxxxx-xxxx) in potentially explosive areas (ATEX)
Pay also attention to the continuative documentationNotes about operation of EtherCAT Box Modules (EPxxxx-xxxx) in potentially explosive areas (ATEX) that is available in the download area of the Beckhoff homepage http:\\www.beckhoff.com!


Commissioning/Configuration

Commissioning/Configuration
Commissioning/Configuration
Additional information
•
Integration in TwinCAT
•
EP5001-0002 - Parameters and modes
•
EP51x1-x0xx - Parameters and modes
•
EP5001 - Interface signal level
•
EP5101 - Interface signal level
•
EP5151 - Interface signal level
•
EP5001-0002 - Object description and parameterization
•
EP5101-0002, EP5101-1002 - Object description and parameterization - normal operating mode
•
EP5101-0011 - Object description and parameterization - normal operating mode
•
EP5101-2011 - Object description and parameterization - normal operating mode
•
EP5151-0002 - Object description and parameterization - normal operating mode
•
Restoring the delivery state


Integration in TwinCAT

Commissioning/Configuration [image] Integration in TwinCAT
Integration in TwinCAT
The procedure for integration in TwinCAT is described in this Quick start guide.


EP5001-0002 - Parameters and modes

Commissioning/Configuration [image] EP5001-0002 - Parameters and modes
EP5001-0002 - Parameters and modes
Additional information
•
Process data
•
DC (Distributed Clocks)
•
Features CoE


Process data

Commissioning/Configuration [image] EP5001-0002 - Parameters and modes [image] Process data
Process data
The EP5001-0002 can have 16 bit status data and a 32-bit counter value.
EP5001-0002
Additional information
•
EP5001-0002 - PDO assignment


EP5001-0002 - PDO assignment

Commissioning/Configuration [image] EP5001-0002 - Parameters and modes [image] Process data [image] EP5001-0002 - PDO assignment
EP5001-0002 - PDO assignment
EP5001-0002 - PDOAssignment
PDO assignment and content; example: EP5001-0002
The PDO 0x1A00 configuration of the EP5001-0002 cannot be changed.
PDO Assignment
SM3, PDO Assignment 0x1C13
Index | Index of excluded PDOs | Size (byte.bit) | Name | PDO Content (index - name)
0x1A00 (default) |  | 6.0 | SSI Inputs | 0x6000:01 - Data error 0x6000:02 - Frame error 0x6000:03 - Power failure 0x6000:0E - Sync error 0x6000:0F - TxPDO State 0x6000:10 - TxPDO Toggle 0x6000:11 - Counter value (32-Bit)


DC (Distributed Clocks)

Commissioning/Configuration [image] EP5001-0002 - Parameters and modes [image] DC (Distributed Clocks)
DC (Distributed Clocks)
Describes whether the module is operated with support from distributed clocks:
Distributed Clocks
▪
FreeRun: The module operates frame-triggered. Cyclic operation is started via the SyncManagers during EtherCAT frame processing.
▪
DC-Synchron: Cyclic operation in the module is started by the local distributed clock at exact intervals. The start time is chosen such that it coincides with other output slaves in the EtherCAT system.
▪
DC-Synchron (input based): as DC-Synchron mode, with the cyclic start time chosen such that it coincides with other input slaves in the EtherCAT system.


Features CoE

Commissioning/Configuration [image] EP5001-0002 - Parameters and modes [image] Features CoE
Features CoE
Further settings can be selected in the CoE (CAN over EtherCAT)-list.
Parameterization via the CoE list (CAN over EtherCAT)
Please note the following general CoE notes when using/manipulating the CoE parameters:
•
Keep a startup list if components have to be replaced
•
Differentiation between online/offline dictionary, existence of current XML description
•
“CoE-Reload” for resetting the changes
The following CoE settings from objects 0x8000 and 0x800D are possible and are shown below in their default settings:
EP5001-0002 - CoE_0x800x
EP5001-0002 - default setting for objects 0x8000 and 0x800D
The parameters are described in the object description chapter.
SSI settings
▪
Index 0x8000:01, Disable Frame Error
If the bit is set to TRUE, data errors such as invalid telegram size are no longer shown in the Data error process data.
▪
Index 0x8000:02, Enable Power failure bit
If the bit is set to TRUE, the last bit (LSB) in the SSI telegram is interpreted as PowerFail bit of the SSI slave and shown in the process data.
▪
Index 0x8000:03, Enable Inhibit time
If the bit is set to TRUE, the system waits at least until the Min. Inhibit time (index 0x8000:13) has elapsed when the next SSI communication starts, even if the next start request has already been issued via EtherCAT or distributed clocks.
▪
Index 0x8000:04, Enable test mode
Only for production purposes.
▪
Index 0x8000:06, SSI-encoding
Dual or gray coding setting (standard).
▪
Index 0x8000:09, SSI-baudrate
should be set to 125, 250, 500 kbaud (default) or 1 Mbaud.
▪
Index 0x8000:0F, SSI-frame type
25, 13 or variable bit width (default: 25).
▪
Index 0x8000:11, SSI-frame size
Total data volume including PowerFail bit.
▪
Index 0x8000:12, SSI-data length
Data volume without PowerFail bit.
▪
Index 0x8000:13, Min. Inhibit time [µs]
See index 0x8000:03.
SSI advanced settings
▪
Index 0x800D:01, Encoder power supply on
Switches the 24 V supply voltage
▪
Index 0x800D:02, Encoder direction pin on
Switches the 24 V supply at the Direction pin
▪
Index 0x800D:03, Encoder reset pin on
Switches the 24 V supply at the Reset pin
The total size of the data depends on the encoder used. It is also type-specific whether a power-fail bit or another auxiliary bit is supported. The counter value in the Counter Value index 0x6000:11 is determined based on the value entered in object SSI data length index 0x8000:12.
A few example configurations are shown below:
Specification of the encoder |  |  | CoE settings of the EP5001-0002
ST | MT | Error bit | 0x8000:0F SSI-frame type | 0x8000:11 SSI-frame size | 0x8000:12 SSI-data length | 0x8000:02 Enable power failure bit
13 | 0 | 0 | 1: Single-turn analysis is active | 13 | 13 | 0: Power failure bit is not active
12 | 12 | 1 | 0: Multi-turn analysis is active | 25 | 24 | 1: Power failure bit is active
12 | 12 | 0 | 2: Variable analysis is active | 24 | 24 | 0: Power failure bit is not active
12 | 13 | 0 | 2: Variable analysis is active | 25 | 25 | 0: Power failure bit is not active
16 | 16 | 0 | 2: Variable analysis is active | 32 | 32 | 0: Power failure bit is not active
16 | 0 | 0 | 2: Variable analysis is active | 16 | 16 | 0: Power failure bit is not active
13 | 16 | 1 | 2: Variable analysis is active | 30 | 29 | 1: Power failure bit is active
12 | 12 | 2 | 2: Variable analysis is active | 26* | 26* | 0: Power failure bit is not active
*) Analysis of the data and division into position and auxiliary bits must take place in the PLC.
If the encoder offers more than 1 auxiliary bit, this can be done by means of suitable configuration of the objects 0x8000:11 SSI frame size and 0x80n0 SSI data length. The maximum size of 32 bits must be considered here. If the parameters have the same size, the Counter Value index 0x6000:11 does not only show the position, but also additional bits. Analysis of the data and division into position and auxiliary bits must take place in the PLC.
If the settings are not made correctly in the CoE, or if there is an error at the inputs, this is indicated via the status bits
Data Error (Index 0x6000:01) | Frame error (Index 0x6000:02) | Possible error type
TRUE | FALSE | SSI input error: - SSI without power supply - Broken wire at SSI data inputs D+ or D- If no data communication takes place the SSI input of the terminal is on low level.
FALSE | TRUE | There is an incorrect data frame, the data frame was not concluded with zero, or possibly - Wire breakage in the clock lines - Incorrect parameterization in the CoE
TRUE | TRUE | - Broken wire at SSI data inputs D+ or D- - Data cables interchanged
FALSE | FALSE | If bits are shifted in the counter value despite correct CoE parameterization, this may be to do with the clock lines being swapped


EP51x1-x0xx - Parameters and modes

Commissioning/Configuration [image] EP51x1-x0xx - Parameters and modes
EP51x1-x0xx - Parameters and modes
Additional information
•
Process data
•
DC (Distributed Clocks)
•
Features CoE


Process data

Commissioning/Configuration [image] EP51x1-x0xx - Parameters and modes [image] Process data
Process data
16 or 32 bit process data
The EP51x1 can be operated both with 16 bit process data (default) or 32 bit process data. This can be set via the Predefined PDO Assignment in the Process Data table tab.
16 or 32 bit process data
Main PDO
Selection of basic process data
Main PDO, example: EP5101-0011
A: Selection of data direction: input or output | C: Explanatory notes for PDOs
B: Selection of (optional) PDOs (process data objects) | D: PDO content
▪
compact: The process data can be represented with 16 bits (compact) or with 32 bits.
Optional PDOs
Optional PDOs, in addition to the main PDO:
▪
PDO 1 (0x1A02 or 0x1A03): The frequency or the period can be selected as optional PDO 1.
▪
PDO 2 (0x1A04 or 0x1A05): In one of the DC modes a 32 bit or 64 bit timestamp can be selected. The timestamp specifies the time of the last registered increment edge, based on the Distributed Clocks system.
PDO assignment and contents
The PDO assignment and contents may differ for different Boxes. For PDO content and assignment please refer to the
•
Process Data tab of the TwinCAT System Manager or the
•
PDOs assignment chapter for the respective Box.
Additional information
•
EP5101-x002 - PDO assignment
•
EP5101-0011 - PDO assignment
•
EP5101-2011 - PDO assignment
•
EP5151-0002 - PDO assignment


EP5101-x002 - PDO assignment

Commissioning/Configuration [image] EP51x1-x0xx - Parameters and modes [image] Process data [image] EP5101-x002 - PDO assignment
EP5101-x002 - PDO assignment
PDO assignment and content; example: EP5101-0002
PDO Assignment
To configure the process data, select the required Sync Manager (SM 2 or SM 3 can be changed) in the Sync Manager field at the top left (see illustration above). The process data assigned to this Sync Manager can then be switched on or off in the PDO Assignment field below. Restarting the EtherCAT system, or reloading the configuration in configuration mode (F4), causes the EtherCAT communication to restart, and the process data is transferred from the terminal.
SM2, PDO Assignment 0x1C12
Index | Index of excluded PDOs | Size (byte.bit) | Name | PDO Content (index - name)
0x1600 (default) | 0x1601 | 4.0 | ENC Control compact | 0x7000:01 - Enable Latch C 0x7000:03 - Set counter 0x7000:11 - Set counter value (16-bit)
0x1601 | 0x1600 | 6.0 | ENC Control | 0x7000:01 - Enable Latch C 0x7000:03 - Set counter 0x7000:11 - Set counter value (32-bit)
SM3, PDO Assignment 0x1C13
Index | Index of excluded PDOs | Size (byte.bit) | Name | PDO Content (index - name)
0x1A00 (default) | 0x1A01 | 6.0 | ENC Status compact | 0x6000:01 - Latch C valid 0x6000:03 - Set counter done 0x6000:04 - Counter underflow 0x6000:05 - Counter overflow 0x6000:07 - Open circuit 0x6000:08 - Extrapolation stall 0x6000:09 - Status of input A 0x6000:0A - Status of input B 0x6000:0B - Status of input C 0x1C32:20 - Sync error 0x1800:07 - TxPDO State 0x1800:09 - TxPDO Toggle 0x6000:11 - Counter value (16-Bit) 0x6000:12 - Latch value (16-Bit)
0x1A01 | 0x1A00 | 10.0 | ENC Status | 0x6000:01 - Latch C valid 0x6000:03 - Set counter done 0x6000:04 - Counter underflow 0x6000:05 - Counter overflow 0x6000:07 - Open circuit 0x6000:08 - Extrapolation stall 0x6000:09 - Status of input A 0x6000:0A - Status of input B 0x6000:0B - Status of input C 0x1C32:20 - Sync error 0x1800:07 - TxPDO State 0x1800:09 - TxPDO Toggle 0x6000:11 - Counter value (32-Bit) 0x6000:12 - Latch value (32-Bit)
0x1A02 | 0x1A03 | 4.0 | ENC Frequency | 0x6000:13 - Frequency value
0x1A03 | 0x1A02 | 4.0 | ENC Period | 0x6000:14 - Period value
0x1A04 | 0x1A05 | 8.0 | ENC Timest. | 0x6000:16 - timestamp (64-bit)
0x1A05 | 0x1A04 | 4.0 | ENC Timest. compact | 0x6000:16 - timestamp compact (32-bit)


EP5101-0011 - PDO assignment

Commissioning/Configuration [image] EP51x1-x0xx - Parameters and modes [image] Process data [image] EP5101-0011 - PDO assignment
EP5101-0011 - PDO assignment
PDO assignment and content; example: EP5101-0011
PDO Assignment
To configure the process data, select the required Sync Manager (SM 2 or SM 3 can be changed) in the Sync Manager field at the top left (see illustration above). The process data assigned to this Sync Manager can then be switched on or off in the PDO Assignment field below. Restarting the EtherCAT system, or reloading the configuration in configuration mode (F4), causes the EtherCAT communication to restart, and the process data is transferred from the terminal.
SM2, PDO Assignment 0x1C12
Index | Index of excluded PDOs | Size (byte.bit) | Name | PDO Content (index - name)
0x1600 (default) | 0x1601 | 4.0 | ENC Control compact | 0x7000:01 - Enable Latch C 0x7000:02 - Enable Latch extern on positive edge 0x7000:03 - Set counter 0x7000:04 - Enable Latch extern on negative edge 0x7000:11 - Set counter value (16-bit)
0x1601 | 0x1600 | 6.0 | ENC Control | 0x7000:01 - Enable Latch C 0x7000:02 - Enable Latch extern on positive edge 0x7000:03 - Set counter 0x7000:04 - Enable Latch extern on negative edge 0x7000:11 - Set counter value (32-bit)
SM3, PDO Assignment 0x1C13
Index | Index of excluded PDOs | Size (byte.bit) | Name | PDO Content
0x1A00 (default) | 0x1A01 | 6.0 | ENC Status compact | 0x6000:01 - Latch C valid 0x6000:02 - Latch extern valid 0x6000:03 - Set counter done 0x6000:04 - Counter underflow 0x6000:05 - Counter overflow 0x6000:06 - Status of input status 0x6000:07 - Open circuit 0x6000:08 - Extrapolation stall 0x6000:09 - Status of input A 0x6000:0A - Status of input B 0x6000:0B - Status of input C 0x6000:0C - Status of input gate 0x6000:0D - Status of extern latch 0x1C32:20 - Sync error 0x1800:07 - TxPDO State 0x1800:09 - TxPDO Toggle 0x6000:11 - Counter value (16-Bit) 0x6000:12 - Latch value (16-Bit)
0x1A01 | 0x1A00 | 10.0 | ENC Status | 0x6000:01 - Latch C valid 0x6000:02 - Latch extern valid 0x6000:03 - Set counter done 0x6000:04 - Counter underflow 0x6000:05 - Counter overflow 0x6000:06 - Status of input status 0x6000:07 - Open circuit 0x6000:08 - Extrapolation stall 0x6000:09 - Status of input A 0x6000:0A - Status of input B 0x6000:0B - Status of input C 0x6000:0C - Status of input gate 0x6000:0D - Status of extern latch 0x1C32:20 - Sync error 0x1800:07 - TxPDO State 0x1800:09 - TxPDO Toggle 0x6000:11 - Counter value (32-Bit) 0x6000:12 - Latch value (32-Bit)
0x1A02 | 0x1A03 | 4.0 | ENC Frequency | 0x6000:13 - Frequency value
0x1A03 | 0x1A02 | 4.0 | ENC Period | 0x6000:14 - Period value
0x1A04 | 0x1A05 | 8.0 | ENC Timest. | 0x6000:16 - timestamp (64-bit)
0x1A05 | 0x1A04 | 4.0 | ENC Timest. compact | 0x6000:16 - timestamp compact (32-bit)


EP5101-2011 - PDO assignment

Commissioning/Configuration [image] EP51x1-x0xx - Parameters and modes [image] Process data [image] EP5101-2011 - PDO assignment
EP5101-2011 - PDO assignment
PDO assignment and content, EP5101-2011
PDO Assignment
To configure the process data, select the required Sync Manager (SM 2 or SM 3 can be changed) in the Sync Manager field at the top left (see illustration above). The process data assigned to this Sync Manager can then be switched on or off in the PDO Assignment field below. Restarting the EtherCAT system, or reloading the configuration in configuration mode (F4), causes the EtherCAT communication to restart, and the process data is transferred from the terminal.
SM2, PDO Assignment 0x1C12
Index | Index of excluded PDOs | Size (byte.bit) | Name | PDO Content (index - name)
0x1600 | 0x1601 | 6.0 | ENC Control | 0x7000:01 - Enable Latch C 0x7000:02 - Enable Latch extern on positive edge 0x7000:03 - Set counter 0x7000:04 - Enable Latch extern on negative edge 0x7000:11 - Set counter value (32-bit)
0x1601 (default) | 0x1600 | 4.0 | ENC Control compact | 0x7000:01 - Enable Latch C 0x7000:02 - Enable Latch extern on positive edge 0x7000:03 - Set counter 0x7000:04 - Enable Latch extern on negative edge 0x7000:11 - Set counter value (16-bit)
SM3, PDO Assignment 0x1C13
Index | Index of excluded PDOs | Size (byte.bit) | Name | PDO Content (index - name)
0x1A00 | 0x1A01 | 10.0 | ENC Status | 0x6000:01 - Latch C valid 0x6000:02 - Latch extern valid 0x6000:03 - Set counter done 0x6000:06 - Status of input status 0x6000:07 - Open circuit 0x6000:09 - Status of input A 0x6000:0C - Status of input gate 0x6000:0D - Status of extern latch 0x6000:0E - Sync error 0x6000:0F - TxPDO State 0x6000:10 - TxPDO Toggle 0x6000:11 - Counter value (32-Bit) 0x6000:12 - Latch value (32-Bit)
0x1A01 (default) | 0x1A00 | 6.0 | ENC Status compact | 0x6000:01 - Latch C valid 0x6000:02 - Latch extern valid 0x6000:03 - Set counter done 0x6000:06 - Status of input status 0x6000:07 - Open circuit 0x6000:09 - Status of input A 0x6000:0A - Status of input B 0x6000:0B - Status of input C 0x6000:0C - Status of input gate 0x6000:0D - Status of extern latch 0x6000:0E - Sync error 0x6000:0F - TxPDO State 0x6000:10 - TxPDO Toggle 0x6000:11 - Counter value (16-Bit) 0x6000:12 - Latch value (16-Bit)
0x1A02 | 0x1A03 | 4.0 | ENC Period | 0x6000:14 - Period value
0x1A03 | 0x1A02 | 4.0 | ENC Frequency | 0x6000:13 - Frequency value
0x1A04 | 0x1A05 | 8.0 | ENC Timest. | 0x6000:16 - timestamp (64-bit)
0x1A05 | 0x1A04 | 4.0 | ENC Timest. compact | 0x6000:16 - timestamp compact (32-bit)


EP5151-0002 - PDO assignment

Commissioning/Configuration [image] EP51x1-x0xx - Parameters and modes [image] Process data [image] EP5151-0002 - PDO assignment
EP5151-0002 - PDO assignment
PDO assignment and content; example: EP5151-0002
PDO Assignment
To configure the process data, select the required Sync Manager (SM 2 or SM 3 can be changed) in the Sync Manager field at the top left (see illustration above). The process data assigned to this Sync Manager can then be switched on or off in the PDO Assignment field below. Restarting the EtherCAT system, or reloading the configuration in configuration mode (F4), causes the EtherCAT communication to restart, and the process data is transferred from the terminal.
SM2, PDO Assignment 0x1C12
Index | Index of excluded PDOs | Size (byte.bit) | Name | PDO Content (index - name)
0x1600 (default) | 0x1601 | 4.0 | ENC Control compact | 0x7000:01 - Enable Latch C 0x7000:02 - Enable Latch extern on positive edge 0x7000:03 - Set counter 0x7000:04 - Enable Latch extern on negative edge 0x7000:11 - Set counter value (16-bit)
0x1601 | 0x1600 | 6.0 | ENC Control | 0x7000:01 - Enable Latch C 0x7000:02 - Enable Latch extern on positive edge 0x7000:03 - Set counter 0x7000:04 - Enable Latch extern on negative edge 0x7000:11 - Set counter value (32-bit)
SM3, PDO Assignment 0x1C13
Index | Index of excluded PDOs | Size (byte.bit) | Name | PDO Content (index - name)
0x1A00 (default) | 0x1A01 | 6.0 | ENC Status compact | 0x6000:01 - Latch C valid 0x6000:02 - Latch extern valid 0x6000:03 - Set counter done 0x6000:04 - Counter underflow 0x6000:05 - Counter overflow 0x6000:06 - Status of input status 0x6000:07 - Open circuit 0x6000:08 - Extrapolation stall 0x6000:09 - Status of input A 0x6000:0A - Status of input B 0x6000:0B - Status of input C 0x6000:0C - Status of input gate 0x6000:0D - Status of extern latch 0x1C32:20 - Sync error 0x1800:07 - TxPDO State 0x1800:09 - TxPDO Toggle 0x6000:11 - Counter value (16-Bit) 0x6000:12 - Latch value (16-Bit)
0x1A01 | 0x1A00 | 10.0 | ENC Status | 0x6000:01 - Latch C valid 0x6000:02 - Latch extern valid 0x6000:03 - Set counter done 0x6000:04 - Counter underflow 0x6000:05 - Counter overflow 0x6000:06 - Status of input status 0x6000:07 - Open circuit 0x6000:08 - Extrapolation stall 0x6000:09 - Status of input A 0x6000:0A - Status of input B 0x6000:0B - Status of input C 0x6000:0C - Status of input gate 0x6000:0D - Status of extern latch 0x1C32:20 - Sync error 0x1800:07 - TxPDO State 0x1800:09 - TxPDO Toggle 0x6000:11 - Counter value (32-Bit) 0x6000:12 - Latch value (32-Bit)
0x1A02 | 0x1A03 | 4.0 | ENC Frequency | 0x6000:13 - Frequency value
0x1A03 | 0x1A02 | 4.0 | ENC Period | 0x6000:14 - Period value
0x1A04 | 0x1A05 | 8.0 | ENC Timest. | 0x6000:16 - timestamp (64-bit)
0x1A05 | 0x1A04 | 4.0 | ENC Timest. compact | 0x6000:16 - timestamp compact (32-bit)


DC (Distributed Clocks)

Commissioning/Configuration [image] EP51x1-x0xx - Parameters and modes [image] DC (Distributed Clocks)
DC (Distributed Clocks)
Describes whether the module is operated with support from distributed clocks:
Distributed Clocks
▪
FreeRun: The module operates frame-triggered. Cyclic operation is started via the SyncManagers during EtherCAT frame processing.
▪
DC-Synchron: Cyclic operation in the module is started by the local distributed clock at exact intervals. The start time is chosen such that it coincides with other output slaves in the EtherCAT system.
▪
DC-Synchron (input based): as DC-Synchron mode, with the cyclic start time chosen such that it coincides with other input slaves in the EtherCAT system.


Features CoE

Commissioning/Configuration [image] EP51x1-x0xx - Parameters and modes [image] Features CoE
Features CoE
Depending on the main PDO/optional PDOs further settings can be selected in the CoE list (CAN over EtherCAT).
Parameterization via the CoE list (CAN over EtherCAT)
Please note the following general CoE notes when using/manipulating the CoE parameters:
•
Keep a startup list if components have to be replaced
•
Differentiation between online/offline dictionary, existence of current XML description
•
“CoE-Reload” for resetting the changes
The following CoE settings from object 0x8000 are possible and shown here in their default settings, based on the EP5101-0011 as an example:
Object 0x8000 - default, example: EP5101-0011
The parameters are explained in the object description chapter for the corresponding EtherCAT Box.
▪
Due to the different pin assignment, the following objects are not supported by the EP51x1-x002 modules!
–
0x8000:02 - Enable extern reset
–
0x8000:04 - Gate polarity
–
0x8000:10 - Extern reset polarity
▪
Due to different firmware, the following objects are not supported by the EP5101-2011 module!
–
0x8000:03 - Enable up/down counter
–
0x8000:08 - Disable filter
–
0x8000:0A - Enable micro increments
Additional Notes
Frequency
▪
The time window for the frequency calculation and the resolution can be parameterized in the CoE objects Frequency window 0x8000:11, Frequency scaling 0x8000:13, Frequency resolution 0x8000:15 and Frequency wait time 0x8000:17.
▪
The positive edges of track A are counted within the specified timeframe and the next edge including the time up to it are counted. The waiting time can be set in CoE object 0x8000:17 Frequency Wait Time (unit: ms). The default value is 1.6 sec. This is also the maximum value.
▪
The time window is 10 ms (default), min. 1 µs. With the default setting it is possible to measure frequencies up to approx. 800 kHz. At higher frequencies a smaller value must be selected for the timeframe.
▪
The time is measured with a resolution of 100 ns.
▪
This calculation is carried out in the slave without reference to the distributed clocks system. It is therefore independent of the DC mode.
▪
No frequency measurement is possible if the counter is blocked by the gate. In this case the period can be measured regardless.
▪
A C or external reset restarts the frequency measurement. The last frequency value remains unchanged until a new frequency value is determined.
Frequency measurement
▪
Basic unit 1 µs: all window sizes
Measurement sequence
▪
The measurement starts with a positive edge at track A. The current counter value and time (resolution: 100 ns) are stored.
▪
After the measuring window time has elapsed (index 0x8000:11), the system waits for the subsequent rising edge at track A, or a maximum of 1.6 seconds, or the time from Frequency Wait Time 0x8000:17.
▪
The frequency is calculated from the edge difference and the actual elapsed time.
Frequency measurement principle in enhanced operation mode
Period calculation
▪
This calculation is carried out in the slave without reference to the distributed clocks system. It is therefore independent of the DC mode.
▪
During each cycle the interval between 2 positive edges of input A is counted.
▪
If no edge change occurs for approx. 1.6 s, any period specification is canceled.
Latch
▪
Activation of latch C input (Enable latch C index 0x7000:01) and saving ("latching") of the counter value
–
The counter value is saved when the first external latch pulse (positive edge at input "C") is encountered after the bit has been set (TRUE) in Enable latch C index 0x7000:01 (this has priority over Enable latch extern on positive / negative edge 0x7000:02 / 0x7000:04). The subsequent pulses at the other inputs have no influence on the latch value in index 0x6000:12 if the bit is set.
–
Note for Latch C valid bit: A new counter value at the latch input can only be written once the value of the Latch C valid bit (index 0x6000:01) is FALSE.
▪
Activation of the external latch input ("gate/latch") and latching of the counter value (index 0x7000:02, 0x7000:04) (not for EP5101-x002)
–
When the bit is set (TRUE) in Enable latch extern on positive edge index 0x7000:02, the counter value is saved on the latch input (index 0x6000:12) when the first external latch pulse with rising edge is encountered. The subsequent pulses have no influence on the latch value in index 0x6000:12.
–
When the bit is set (TRUE) in Enable latch extern on negative edge index 0x7000:04, the counter value is saved on the latch input (index 0x6000:12) when the first external latch pulse with falling edge is encountered. The subsequent pulses have no influence on the latch value in index 0x6000:12.
–
Note for Latch extern valid bit: A new counter value cannot be written to the latch input until the value of the Latch extern valid (index 0x6000:02) is FALSE.
Reset
▪
Counter reset via input C:
–
To reset the counter, set the bit in Enable latch C index 0x8000:01.
▪
Resetting the counter via the external latch input (not for EP5101-x002)
–
For a reset via the external latch input, set the bit in Enable extern reset index 0x8000:02
–
Extern reset polarity index 0x8000:10 can be used to select the edge for setting the counter to zero.
• Bit not set: Counter is set to zero with falling edge.
• Bit set: Counter is set to zero with rising edge.
▪
The functions Enable C reset (0x8000:01) and Enable extern reset (0x8000:02) cannot be enabled simultaneously.
Up/down counter
▪
The mode (encoder or up/down counter) can be set via Enable up/down counter index 0x8000:03. (not for EP5101-2011)
–
Click the corresponding row of the index to be parameterized,
–
enter the value "1" in the SetValue dialog and
–
confirm with OK.
▪
Set the gate polarity accordingly via object 0x8000:04.
▪
An additional option for reversing the direction of rotation is to set the Reversion of rotation bit index: 0x8000:0E.
Overflow/underflow (not for EP5101-2011)
▪
Overflow/underflow control is inactive in combination with an activated reset function (C/external).
▪
The underflow bit (0x6000:04) is set if an underflow ...00 ->...FF occurs. It is reset if 2/3 of the counter range are underrun.
▪
The overflow bit (0x6000:05) is set if an overflow FF...-> 0... occurs. It is reset if 1/3 of the counter range is exceeded.
Open circuit detection
▪
A separate open circuit detection can be activated for each of the channels A, B and C (index 0x8000:0B, 0x8000:0C, 0x8000:0D).
▪
Open circuit detection is activated for channels A and B by default.
▪
A differential voltage of < 3.5 V (typical, subject to modification) is interpreted as an open circuit.
▪
If an open circuit is detected, it is indicated as process data Open circuit = TRUE (bit in object Open circuit 0x6000:07 is set). An open circuit is also indicated separately in indices 0xA000:01 (track A), 0xA000:02 (track B) and 0xA000:03 (track C).
▪
TxPDO state also becomes TRUE if an open circuit is detected, since invalid data have to be assumed.
Micro-increments
▪
Works with and without distributed clocks, but in the EP51x1 this is only meaningful in conjunction with one of the DC modes.
▪
By setting the counter value only the integer component can be modified.
▪
The frequency measurement principle in extended mode:
DC-supported micro-increments
The highly constant query cycles (accuracy: 100 ns) of the distributed clocks systems enable the EP51x1 to interpolate axis positions between the counted encoder increments from a certain speed. The interpolation resolution is 8 bit, corresponding to 256 values. A standard encoder with 1,024 lines with 4-way evaluation and micro-increments thus becomes a high-resolution axis encoder with 4096 x 256 = 1,048,567 lines.
If the velocity value falls below the minimum value, this is indicated by the object Extrapolation stall 0x6000:08 in the process data (not for EP5101-2011).


EP5001 - Interface signal level

Commissioning/Configuration [image] EP5001 - Interface signal level
EP5001 - Interface signal level
The EP5001-0002 expects signal levels according to RS485.
The typical output levels apply for a load of 60 ohm or higher.
Differential signal input
Voltage level for differential mode
The EP5001-0002 does not support single-ended mode.


EP5101 - Interface signal level

Commissioning/Configuration [image] EP5101 - Interface signal level
EP5101 - Interface signal level
In differential mode, the EP5101-x00x expects signal levels according to RS422. The data are transferred without ground reference as voltage difference between two cables (signal A and inverted signal /A). The module analyses signal levels in the range -200mV < Vid < +200mV as valid signals. The differential signal must be in the common mode range (<+13.2 V and >-10 V, with respect to GND) (cf. diagram). Signal levels outside this range can lead to destruction
EP5101 signal level interface
In differential mode only the voltage difference is evaluated, so that common-mode interference on the transmission link does not lead to corruption of the wanted signal, since any interference affects both cables simultaneously.
If the EP5101 is only operated in single-ended mode, a nominal level voltage between 3.5 V and 5.5 V is expected.
For the EP5101-x00x versions, open circuit detection is typically enabled in the range -1.5 V > Vid > +1.5 (subject to change).


EP5151 - Interface signal level

Commissioning/Configuration [image] EP5151 - Interface signal level
EP5151 - Interface signal level
The EP5151 expects signal levels according to HTL (push-pull).
Differential signal input
Voltage level for differential mode


EP5001-0002 - Object description and parameterization

Commissioning/Configuration [image] EP5001-0002 - Object description and parameterization
EP5001-0002 - Object description and parameterization
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Parameterization via the CoE list (CAN over EtherCAT)
The EtherCAT device is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs).
Introduction
The CoE overview contains objects for different intended applications:
▪
Objects required for parameterization during commissioning
▪
Objects intended for regular operation, e.g. through ADS access.
▪
Objects for indicating internal settings (may be fixed)
The following section first describes the objects required for normal operation, followed by a complete overview of missing objects.
Index 1000 Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x01F51389 (32838537dec)
Index 1008 Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EP5001-0002
Index 1009 Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO | -
Index 100A Software version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO | -
Index 1011 Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default parameters | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" in the set value dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)
Index 1018 Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x13894052 (327762002dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the Low Word (bit 0-15) indicates the special terminal number, the High Word (bit 16-31) refers to the device description | UINT32 | RO | 0x00000000 (0dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the Low Byte (bit 0-7) of the Low Word contains the year of production, the High Byte (bit 8-15) of the Low Word contains the week of production, the High Word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 Backup parameter handling
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | Information for standardized loading and saving of backup entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum across all backup entries of the EtherCAT slave | UINT32 | RO | 0x00000000 (0dec)
Index 1800 SSI TxPDO-Par Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
1801:0 | SSI TxPDO-Par Inputs | PDO parameter TxPDO 1 | UINT8 | RO | 0x06 (6dec)
1801:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 1 | OCTET-STRING[2] | RO | 00 1A
Index 1A00 SSI TxPDO-Map Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
1A00:0 | SSI TxPDO-Map Inputs | PDO Mapping TxPDO 1 | UINT8 | RO | 0x08 (8dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (SSI Inputs), entry 0x01 (Data error)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (SSI Inputs), entry 0x02 (Frame error)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (SSI Inputs), entry 0x03 (Power failure)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (10 bits align) | UINT32 | RO | 0x0000:00, 10
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (SSI Inputs), entry 0x0E (Sync error)) | UINT32 | RO | 0x6000:0E, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (SSI Inputs), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6000:0F, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (SSI Inputs), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6000:10, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (SSI Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
Index 1C00 Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the Sync Managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x00 (0dec)
Index 1C13 TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RO | 0x02 (2dec)
1C13:01 | SubIndex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RO | 0x1A00 (6656dec)
Index 1C33 SM input parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (no outputs available)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (outputs available)
UINT16
RW
0x0022 (34dec)
1C33:02
Cycle time
Cycle time (in ns):
▪
Free Run: Cycle time of the local timer
▪
Synchron with SM 2 Event: Master cycle time
▪
DC mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: Synchron with SM 2 Event is supported (outputs available)
▪
Bit 1: Synchron with SM 3 Event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: Input shift through local event (outputs available)
▪
Bit 4-5 = 10: Input shift with SYNC1 event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C33:08)
UINT16
RO
0xC00B (49163dec)
1C33:05
Minimum cycle time
Minimum cycle time (in ns)
UINT32
RO
0x00030D40 (0dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:07
Minimum delay time
-
UINT32
RO
0x000001B0 (7600dec)
1C33:08
Command
With this entry the real required process data provision time can be measured.
▪
0: Measurement of the local cycle time is stopped
▪
1: Measurement of the local cycle time is started
The entries 0x1C33:03, 0x1C33:06, 0x1C33:09 are updated with the maximum measured values.
For a subsequent measurement the measured values are reset
UINT16
RW
0x0000 (0dec)
1C33:09
Maximum Delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x000001B0 (7600dec)
1C33:0B
SM event missed counter
Number of missed SM events in OPERATIONAL (DC mode only)
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
Number of occasions the cycle time was exceeded in OPERATIONAL (cycle was not completed in time or the next cycle began too early)
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
Number of occasions that the interval between SYNC0 and SYNC1 event was too short (DC mode only)
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
The synchronization was not correct in the last cycle (outputs were output too late; DC mode only)
BOOLEAN
RO
0x00 (0dec)
Index 6000 SSI Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
6000:0 | SSI Inputs | Length of this object | UINT8 | RO | 0x11 (17dec)
6000:01 | Data error | SSI input error: - SSI without power supply - Broken wire at SSI data inputs D+ or D- - Data cables interchanged If no data communication takes place the SSI input of the terminal is on low level. | BOOLEAN | RO | 0x00 (0dec)
6000:02 | Frame error | The data frame is wrong, i.e. the data frame was not terminated with zero (perhaps wire breakage on clock cables) | BOOLEAN | RO | 0x00 (0dec)
6000:03 | Power failure | An encoder-specific error has occurred. This error bit is only displayed if it was previously enabled through Enable power failure bit index 0x8000:02. | BOOLEAN | RO | 0x00 (0dec)
6000:0E | Sync error | The Sync error bit is only required for DC mode. It indicates whether a synchronization error has occurred during the previous cycle. This means a SYNC signal was triggered in the EP5001-0002, although no new process data were available (0=OK, 1=NOK). | BOOLEAN | RO | 0x00 (0dec)
6000:0F | TxPDO State | Validity of the data of the associated TxPDO (0 = valid, 1 = invalid). | BOOLEAN | RO | 0x00 (0dec)
6000:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
6000:11 | Counter value | Counter value | UINT32 | RO | 0x00000000 (0dec)
Index 8000 SSI Settings
Index (hex) | Name | Meaning | Data type | Flags | Default
8000:0 | SSI Settings | Length of this object | UINT8 | RO | 0x13 (19dec)
8000:01 | Disable frame error | 0: Frame error is not suppressed 1: Frame error is suppressed | BOOLEAN | RW | 0x00 (0dec)
8000:02 | Enable power failure bit | 0: Power failure bit is not active 1: Power failure bit is active: The last bit of the data frame (sensor-specific error bit) is shown as error bit in the Power failure object (index 0x6000:03) and bit 2 of the status word. | BOOLEAN | RW | 0x00 (0dec)
8000:03 | Enable inhibit time | 0: Inhibit time is not active 1: Inhibit time is active | BOOLEAN | RW | 0x00 (0dec)
8000:04 | Enable test mode | 0: Test mode is not active 1: Test mode is active | BOOLEAN | RW | 0x00 (0dec)
8000:06 | SSI-coding | 0: Binary code active 1: Gray code active | BIT1 | RW | 0x01 (1dec)
8000:09 | SSI-baudrate | 0: reserved 1: 1250 kbaud 2: 1000 kbaud 3: 500 kBaud 4: 250 kbaud 5: 125 kbaud 6 - 65535: reserved | BIT3 | RW | 0x03 (3dec)
8000:0F | SSI-frame type | 0: Multi-turn analysis is active (25 bit data frame) 1: Single-turn-analysis is active (13 bit data frame) 2: Variable analysis is active. The length of the data frame (1 to 32 bits) is specified with object SSI frame size (index 0x8000:11). | BIT2 | RW | 0x00 (0dec)
8000:11 | SSI-frame size | Length of the SSI data frame (in bits) | UINT16 | RW | 0x0019 (25dec)
8000:12 | SSI-data length | Data length | UINT16 | RW | 0x0018 (24dec)
8000:13 | Min. inhibit time[µs] | Minimum inhibit time in µs (1 to 65535) | UINT16 | RW | 0x0000 (0dec)
Index 800D SSI Advanced Settings
Index (hex) | Name | Meaning | Data type | Flags | Default
800D:0 | SSI advanced settings | SSI advanced settings |  | RW | 0x03 (3dec)
800D:01 | Encoder power supply on | Switches the 24 V supply voltage |  | RW | 0x01 (1dec)
800D:02 | Encoder direction pin on | Switches the 24 V supply at the direction pin |  | RW | 0x00 (0dec)
800D:03 | Encoder reset pin on | Switches the 24 V supply at the reset pin |  | RW | 0x00 (0dec)
Index F000 Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0001 (1dec)
Index F008 Code word (from FW11 in case of EL5001)
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module list
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list | Length of this object | UINT8 | RW | 0x02 (2dec)
F010:01 | SubIndex 001 | - | UINT32 | RW | 0x000001F5 (501dec)


EP5101-0002, EP5101-1002 - Object description and parameterization - normal operating mode

Commissioning/Configuration [image] EP5101-0002, EP5101-1002 - Object description and parameterization - normal operating mode
EP5101-0002, EP5101-1002 - Object description and parameterization - normal operating mode
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Parameterization via the CoE list (CAN over EtherCAT)
The EtherCAT device is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs).
Additional information
•
Restore object
•
Configuration data
•
Input data
•
Output data
•
Information / diagnostic data (channel specific)
•
Standard objects


Restore object

Commissioning/Configuration [image] EP5101-0002, EP5101-1002 - Object description and parameterization - normal operating mode [image] Restore object
Restore object
Index 1011 Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore the default settings | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" in the set value dialog, all backup objects are reset to their delivery state. Note: Some FW versions also accept the following input: "0x6C6F6164". | UINT32 | RW | 0x00000000 (0dec)


Configuration data

Commissioning/Configuration [image] EP5101-0002, EP5101-1002 - Object description and parameterization - normal operating mode [image] Configuration data
Configuration data
Index 8000 ENC Settings
Index (hex) | Name | Meaning | Data type | Flags | Default
8000:0 | ENC Settings | Maximum subindex | UINT8 | RO | 0x17 (23dec)
8000:01 | Enable C reset | The counter is reset via the C input. | BOOLEAN | RW | 0x00 (0dec)
8000:03 | Enable up/down counter | Enablement of the up/down counter in place of the encoder with the bit set. Increments at input A are counted, input B indicates the count direction. | BOOLEAN | RW | 0x00 (0dec)
8000:08 | Disable filter | 0: Activates the input filter (inputs A, /A, B, /B, C, /C only) 1: Deactivates the input filter If a filter is activated a signal edge must be present for at least 2.4 µs in order to be counted as an increment. | BOOLEAN | RW | 0x01 (1dec)
8000:0A | Enable micro increments | If enabled, in DC mode the EP5101-0002 and EP5101-1002 devices interpolate micro-increments between the integer encoder increments. The lower 8 bits of the Counter Value are used in each case for the display. A 32-bit counter thus becomes a 24+8-bit counter, a 16-bit counter becomes an 8+8-bit counter. | BOOLEAN | RW | 0x00 (0dec)
8000:0B | Open circuit detection A | An open circuit on track A is indicated in object Open circuit (index 0x6000:07) and as a process data. Diagnosis is only possible if the corresponding input is wired differentially. A differential voltage < 3.5 V (typical, subject to change) is detected as a broken wire. | BOOLEAN | RW | 0x01 (1dec)
8000:0C | Open circuit detection B | An open circuit on track B is indicated in object Open circuit (index 0x6000:07) and as a process data. Diagnosis is only possible if the corresponding input is wired differentially. A differential voltage < 3.5 V (typical, subject to change) is detected as a broken wire. | BOOLEAN | RW | 0x01 (1dec)
8000:0D | Open circuit detection C | An open circuit on track C is indicated in object Open circuit (index 0x6000:07) and as a process data. Diagnosis is only possible if the corresponding input is wired differentially. A differential voltage < 3.5 V (typical, subject to change) is detected as a broken wire. | BOOLEAN | RW | 0x00 (0dec)
8000:0E | Reversion of rotation | Activates reversion of rotation | BOOLEAN | RW | 0x00 (0dec)
8000:11 | Frequency window | This is the minimum time over which the frequency is determined; default value 10 ms [resolution: 1 µs]. The number of pulses in the time window + the following is measured. The maximum waiting time is specified in the Frequency Wait Time parameter. The number of pulses is divided by the actual time window size. The determined frequency is output in object Frequency value (index 0x6000:13) and as a process data. The frequency calculation is carried out locally without distributed clocks function. | UINT16 | RW | 0x2710 (10000dec)
8000:13 | Frequency scaling | Scaling of the frequency measurement (must be divided by this value to obtain the unit in Hz): 100: “0.01 Hz” | UINT16 | RW | 0x0064 (100dec)
8000:14 | Period scaling | Resolution of the period in the process data: 100: “100 ns” period value is a multiple of 100 ns 500: “500 ns” period value is a multiple of 500 ns | UINT16 | RW | 0x0064 (100dec)
8000:15 | Frequency resolution | Resolution of the frequency measurement: 100: “0.01 Hz” | UINT16 | RW | 0x0064 (100dec)
8000:16 | Period resolution | Internal resolution of the period measurement: 100: “100 ns” period value is a multiple of 100 ns The period is calculated internally with a resolution of 100 ns. The max. measurable period can then be approx. 1.6 seconds. 500: “500 ns” period value is a multiple of 500 ns Internally the period is calculated with 500 ns resolution. The maximum measurable period is approx. 32.7 ms. The resolution of the process data continues to be the value according to object Period scaling (index 0x8000:14) (e.g. 100 ns [default]). | UINT16 | RW | 0x0064 (100dec)
Index (hex) | Name | Meaning | Data type | Flags | Default
8000:17 | Frequency wait time | Waiting time [ms] for frequency measurement Once the time specified in the frequency window has elapsed, the system waits for the next positive edge from track A. This enables the update speed for the Frequency process data to be optimized, depending on the expected frequencies. The minimum value to be entered here is twice the cycle duration of the smallest measured frequency. T >= 2* (1 / fmin) | UINT16 | RW | 0x0640 (1600dec)


Input data

Commissioning/Configuration [image] EP5101-0002, EP5101-1002 - Object description and parameterization - normal operating mode [image] Input data
Input data
Index 6000 ENC Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
6000:0 | ENC Inputs | Maximum subindex | UINT8 | RO | 0x16 (22dec)
6000:01 | Latch C valid | The counter value was latched with the “C” input. The data with Latch Value (Index 0x6000:12) corresponds to the latched value if the bit is set. To re-enable the latch input, Enable latch C (index 0x7000:01) must be canceled and then reset. | BOOLEAN | RO | 0x00 (0dec)
6000:03 | Set counter done | The counter was set. | BOOLEAN | RO | 0x00 (0dec)
6000:04 | Counter underflow | Counter underflow. Overflow/underflow control is inactive in combination with a reset function (C/external). | BOOLEAN | RO | 0x00 (0dec)
6000:05 | Counter overflow | Counter overflow. Overflow/underflow control is inactive in combination with a reset function (C/external). | BOOLEAN | RO | 0x00 (0dec)
6000:07 | Open circuit | Indicates an open circuit. Configuration via the objects Open circuit detection A Index 0x8000:0B, Open circuit detection B Index 0x8000:0C, Open circuit detection C Index 0x8000:0D | BOOLEAN | RO | 0x00 (0dec)
6000:08 | Extrapolation stall | The extrapolated part of the counter is invalid. | BOOLEAN | RO | 0x00 (0dec)
6000:09 | Status of input A | Status of input A | BOOLEAN | RO | 0x00 (0dec)
6000:0A | Status of input B | Status of input B | BOOLEAN | RO | 0x00 (0dec)
6000:0B | Status of input C | Status of input C | BOOLEAN | RO | 0x00 (0dec)
6000:0E | Sync error | The Sync error bit is only required for DC mode. It indicates whether a synchronization error has occurred during the previous cycle. This means a SYNC signal was triggered in the EP51x1, although no new process data were available (0=OK, 1=NOK). | BOOLEAN | RO | 0x00 (0dec)
6000:0F | TxPDO State | Validity of the data of the associated TxPDO (0 = valid, 1 = invalid). | BOOLEAN | RO | 0x00 (0dec)
6000:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
6000:11 | Counter value | Counter value | UINT32 | RO | 0x00000000 (0dec)
6000:12 | Latch value | Latch value | UINT32 | RO | 0x00000000 (0dec)
6000:13 | Frequency value | The frequency (setting of the scaling and resolution in the objects Frequency scaling index 0x8000:13 and Frequency resolution index 0x8000:15) | UINT32 | RO | 0x00000000 (0dec)
6000:14 | Period value | The cycle duration/period (setting of the scaling and resolution in the objects Period scaling index 0x8000:14 and Period resolution index 0x8000:16) | UINT32 | RO | 0x00000000 (0dec)
6000:16 | Timestamp | Timestamp of the last counter change | UINT64 | RO |


Output data

Commissioning/Configuration [image] EP5101-0002, EP5101-1002 - Object description and parameterization - normal operating mode [image] Output data
Output data
Index 7000 ENC Outputs
Index (hex) | Name | Meaning | Data type | Flags | Default
7000:0 | ENC Outputs | Maximum subindex | UINT8 | RO | 0x11(17dec)
7000:01 | Enable latch C | Activate latching via input “C”. | BOOLEAN | RO | 0x00 (0dec)
7000:03 | Set counter | Set counter value | BOOLEAN | RO | 0x00 (0dec)
7000:11 | Set counter value | The counter value to be set via Set counter (index 0x7000:03). | UINT32 | RO | 0x00000000 (dec)


Information / diagnostic data (channel specific)

Commissioning/Configuration [image] EP5101-0002, EP5101-1002 - Object description and parameterization - normal operating mode [image] Information / diagnostic data (channel specific)
Information / diagnostic data (channel specific)
Index A000 ENC Diag data
Index (hex) | Name | Meaning | Data type | Flags | Default
A000:0 | ENC Diag data | Maximum subindex | UINT8 | RO | 0x03 (3dec)
A000:01 | Open circuit A | Open circuit on track A | BOOLEAN | RO | 0x00 (0dec)
A000:02 | Open circuit B | Open circuit on track B | BOOLEAN | RO | 0x00 (0dec)
A000:03 | Open circuit C | Open circuit on track C | BOOLEAN | RO | 0x00 (0dec)


Standard objects

Commissioning/Configuration [image] EP5101-0002, EP5101-1002 - Object description and parameterization - normal operating mode [image] Standard objects
Standard objects
The standard objects have the same meaning for all EtherCAT slaves.
Index 1000 Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x01FF1389 (33493897dec)
Index 1008 Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EP5101-0002 EP5101-1002
Index 1009 Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO | -
Index 100A Software version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO | -
Index 1018 Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x13ED4052 (334315602dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the Low Word (bit 0-15) indicates the special terminal number, the High Word (bit 16-31) refers to the device description | UINT32 | RO | 0x00000000 (0dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the Low Byte (bit 0-7) of the Low Word contains the year of production, the High Byte (bit 8-15) of the Low Word contains the week of production, the High Word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 Backup parameter handling
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | Information for standardized loading and saving of backup entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum across all backup entries of the EtherCAT slave | UINT32 | RO | 0x00000000 (0dec)
Index 1400 ENC RxPDO-Par Control compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1400:0 | ENC RxPDO-Par Control compact | PDO Parameter RxPDO 1 | UINT8 | RO | 0x06 (6dec)
1400:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 1 | OCTET-STRING[2] | RO | 01 16
Index 1401 ENC RxPDO-Par Control
Index (hex) | Name | Meaning | Data type | Flags | Default
1401:0 | ENC RxPDO-Par Control | PDO Parameter RxPDO 2 | UINT8 | RO | 0x06 (6dec)
1401:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 2 | OCTET-STRING[2] | RO | 00 16
Index 1600 ENC RxPDO-Map Control compact (EP5101-0002)
Index (hex) | Name | Meaning | Data type | Flags | Default
1600:0 | ENC RxPDO-Map Control compact | PDO Mapping RxPDO 3 | UINT8 | RO | 0x06 (6dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01,1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1600:05 | SubIndex 005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1600:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 16
1600:07 | SubIndex 007 | 7. reserved | UINT32 | RO | -
Index 1600 ENC RxPDO-Map Control compact (EP5101-1002)
Index (hex) | Name | Meaning | Data type | Flags | Default
1600:0 | ENC RxPDO-Map Control compact | PDO Mapping RxPDO 3 | UINT8 | RO | 0x07 (7dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01,1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1600:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1600:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1600:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 16
Index 1601 ENC RxPDO-Map Control (EP5101-0002)
Index (hex) | Name | Meaning | Data type | Flags | Default
1601:0 | ENC RxPDO-Map Control compact | PDO Mapping RxPDO | UINT8 | RO | 0x06 (6dec)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01,1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00,1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs), ventry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03,1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00,5
1601:05 | SubIndex 005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00,8
1601:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11,32
1601:07 | SubIndex 007 | 7. reserved | UINT32 | RO | -
Index 1601 ENC RxPDO-Map Control (EP5101-1002)
Index (hex) | Name | Meaning | Data type | Flags | Default
1601:0 | ENC RxPDO-Map Control compact | PDO Mapping RxPDO | UINT8 | RO | 0x07 (7dec)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01,1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00,1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03,1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7000:04,1
1601:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00,4
1601:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00,8
1601:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11,32
Index 1800 ENC TxPDO-Par Status compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1800:0 | ENC TxPDO-Par Status compact | PDO parameter TxPDO 1 | UINT8 | RO | 0x09 (9dec)
1800:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 1. | OCTET-STRING[2] | RO | 01 1A
1800:07 | TxPDO State | The TxPDO state is set if it was not possible to correctly read in the associated input data. | BOOLEAN | RO | 0x00 (0dec)
1800:09 | TxPDO Toggle | The TxPDO toggle is toggled with each update the corresponding input data. | BOOLEAN | RO | 0x00 (0dec)
Index 1801 ENC TxPDO-Par Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1801:0 | ENC TxPDO-Par Status | PDO parameter TxPDO 2 | UINT8 | RO | 0x09 (9dec)
1801:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 2. | OCTET-STRING[2] | RO | 00 1A
1801:07 | TxPDO State | The TxPDO state is set if it was not possible to correctly read in the associated input data. | BOOLEAN | RO | 0x00 (0dec)
1801:09 | TxPDO Toggle | The TxPDO toggle is toggled with each update the corresponding input data. | BOOLEAN | RO | 0x00 (0dec)
Index 1802 ENC TxPDO-Par Frequency
Index (hex) | Name | Meaning | Data type | Flags | Default
1802:0 | ENC TxPDO-Par Frequency | PDO parameter TxPDO 3 | UINT8 | RO | 0x06 (6dec)
1802:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 3. | OCTET-STRING[2] | RO | 03 1A
Index 1803 ENC TxPDO-Par Period
Index (hex) | Name | Meaning | Data type | Flags | Default
1803:0 | ENC TxPDO-Par Period | PDO parameter TxPDO 4 | UINT8 | RO | 0x06 (6dec)
1803:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 4. | OCTET-STRING[2] | RO | 02 1A
Index 1804 ENC TxPDO-Par Timestamp
Index (hex) | Name | Meaning | Data type | Flags | Default
1804:0 | ENC TxPDO-Par Timestamp | PDO parameter TxPDO 5 | UINT8 | RO | 0x06 (6dec)
1804:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 5. | OCTET-STRING[2] | RO | 05 1A
Index 1805 ENC TxPDO-Par Timestamp compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1805:0 | ENC TxPDO-Par Timestamp compact | PDO parameter TxPDO 6 | UINT8 | RO | 0x06 (6dec)
1805:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 6. | OCTET-STRING[2] | RO | 04 1A
Index 1A00 ENC TxPDO-Map Status compact (EP5101-0002)
Index (hex) | Name | Meaning | Data type | Flags | Default
1A00:0 | ENC TxPDO-Map Status compact | ENC TxPDO-Map Status compact | UINT8 | RO | 0x011 (17dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6000:07, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A00:0C | SubIndex 012 | 12. PDO Mapping entry (2 bit align) | UINT32 | RO | 0x0000:00, 2
1A00:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A00:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1800 (ENC TxPDO-Par Status compact), entry 0x07 (TxPDO State) | UINT32 | RO | 0x1800:07, 1
1A00:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1800 (ENC TxPDO-Par Status compact), entry 0x09 (TxPDO Toggle) | UINT32 | RO | 0x1800:09, 1
1A00:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 16
1A00:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 16
1A00:12 | SubIndex 018 | reserved | UINT32 | RO | -
Index 1A00 ENC TxPDO-Map Status compact (EP5101-1002)
Index (hex) | Name | Meaning | Data type | Flags | Default
1A00:0 | ENC TxPDO-Map Status compact | ENC TxPDO-Map Status compact | UINT8 | RO | 0x012 (18dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6000:07, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A00:0C | SubIndex 012 | 12. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1A00:0D | SubIndex 013 | 13. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1A00:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A00:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1800 (ENC TxPDO-Par Status compact), entry 0x07 (TxPDO State) | UINT32 | RO | 0x1800:07, 1
1A00:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x1800 (ENC TxPDO-Par Status compact), entry 0x09 (TxPDO Toggle) | UINT32 | RO | 0x1800:09, 1
1A00:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 16
1A00:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 16
Index 1A01 ENC TxPDO-Map Status (EP5101-0002)
Index (hex) | Name | Meaning | Data type | Flags | Default
1A01:0 | ENC TxPDO-Map Status compact | ENC TxPDO-Map Status | UINT8 | RO | 0x11 (17dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6000:07, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A01:0C | SubIndex 012 | 12. PDO Mapping entry (2 bit align) | UINT32 | RO | 0x0000:00, 2
1A01:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A01:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1801 (ENC TxPDO-Par Status), entry 0x07 (TxPDO State)) | UINT32 | RO | 0x1801:07, 1
1A01:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1801 (ENC TxPDO-Par Status), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1801:09, 1
1A01:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
1A01:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 32
1A01:12 | SubIndex 018 | 18. reserved | UINT32 | RO | -
Index 1A01 ENC TxPDO-Map Status (EP5101-1002)
Index (hex) | Name | Meaning | Data type | Flags | Default
1A01:0 | ENC TxPDO-Map Status compact | ENC TxPDO-Map Status | UINT8 | RO | 0x12 (18dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6000:07, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A01:0C | SubIndex 012 | 12. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1A01:0D | SubIndex 013 | 13. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1A01:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A01:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1801 (ENC TxPDO-Par Status), entry 0x07 (TxPDO State)) | UINT32 | RO | 0x1801:07, 1
1A01:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x1801 (ENC TxPDO-Par Status), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1801:09, 1
1A01:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
1A01:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 32
Index 1A02 ENC TxPDO-Map Frequency
Index (hex) | Name | Meaning | Data type | Flags | Default
1A02:0 | TxPDO map frequency | PDO Mapping TxPDO | UINT8 | RO | 0x01 (1dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x13 (Frequency value)) | UINT32 | RO | 0x6000:13, 32
Index 1A03 ENC TxPDO-Map Period
Index (hex) | Name | Meaning | Data type | Flags | Default
1A03:0 | ENC TxPDO-Map Period | ENC TxPDO-Map Period | UINT8 | RO | 0x01 (1dec)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x14 (Period value)) | UINT32 | RO | 0x6000:14, 32
Index 1A04 ENC TxPDO-Map Timest.
Index (hex) | Name | Meaning | Data type | Flags | Default
1A04:0 | ENC TxPDO-Map Timest. | ENC TxPDO-Map Timest. | UINT8 | RO | 0x01 (1dec)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x16 (Timestamp)) | UINT32 | RO | 0x6000:16, 64
Index 1A05 ENC TxPDO-Map Timest. compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1A05:0 | ENC TxPDO-Map Timest. compact | ENC TxPDO-Map Timest. compact | UINT8 | RO | 0x01 (1dec)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x16 (Timestamp)) | UINT32 | RO | 0x6000:16, 32
Index 1C00 Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the Sync Managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write(Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x01 (1dec)
1C12:01 | SubIndex 001 | 1. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1600 (5632dec)
Index 1C13 TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x01 (1dec)
1C13:01 | SubIndex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | SubIndex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:03 | SubIndex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 1C32 SM output parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C32:0
SM output parameter
Synchronization parameters for the outputs
UINT8
RO
0x20 (32dec)
1C32:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dec)
1C32:02
Cycle time
Cycle time (in ns):
▪
Free Run: Cycle time of the local timer
▪
Synchron with SM 2 Event: Master cycle time
▪
DC mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x00000000 (0dec)
1C32:03
Shift time
Time between SYNC0 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0 = 1: free run is supported
▪
Bit 1 = 1: Synchron with SM 2 Event is supported
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 10: Output shift with SYNC1 event (only DC mode)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08)
UINT16
RO
0xC007 (49159dec)
1C32:05
Minimum cycle time
Minimum cycle time (in ns)
UINT32
RO
0x00000000 (0dec)
1C32:06
Calc and copy time
Minimum time between SYNC0 and SYNC1 event (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:07
Minimum delay time
UINT32
RO
0x00000000 (0dec)
1C32:08
Command
With this entry the real required process data provision time can be measured.
▪
0: Measurement of the local cycle time is stopped
▪
1: Measurement of the local cycle time is started
The entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 are updated with the maximum measured values.
For a subsequent measurement the measured values are reset
UINT16
RW
0x0000 (0dec)
1C32:09
Maximum delay time
Time between SYNC1 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:0B
SM event missed counter
Number of missed SM events in OPERATIONAL (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:0C
Cycle exceeded counter
Number of occasions the cycle time was exceeded in OPERATIONAL (cycle was not completed in time or the next cycle began too early)
UINT16
RO
0x0000 (0dec)
1C32:0D
Shift too short counter
Number of occasions that the interval between SYNC0 and SYNC1 event was too short (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:20
Sync error
The synchronization was not correct in the last cycle (outputs were output too late; DC mode only)
BOOLEAN
RO
0x00 (0dec)
Index 1C33 SM input parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (no outputs available)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (outputs available)
UINT16
RW
0x0022 (34dec)
1C33:02
Cycle time
as 0x1C32:02
UINT32
RW
0x00000000 (0dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: Synchron with SM 2 Event is supported (outputs available)
▪
Bit 1: Synchron with SM 3 Event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: Input shift through local event (outputs available)
▪
Bit 4-5 = 10: Input shift with SYNC1 event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08 or 0x1C33:08)
UINT16
RO
0xC007 (49159dec)
1C33:05
Minimum cycle time
as 0x1C32:05
UINT32
RO
0x00000000 (0dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:07
Minimum delay time
UINT32
RO
0x00000000 (0dec)
1C33:08
Command
as 0x1C32:08
UINT16
RW
0x0000 (0dec)
1C33:09
Maximum delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:0B
SM event missed counter
as 0x1C32:11
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
as 0x1C32:12
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
as 0x1C32:13
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
as 0x1C32:32
BOOLEAN
RO
0x00 (0dec)
Index F000 Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0001 (1dec)
Index F008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module list
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list | Maximum subindex | UINT8 | RW | 0x02 (2dec)
F010:01 | SubIndex 001 | reserved | UINT32 | RW | 0x000001FE (510dec)


EP5101-0011 - Object description and parameterization - normal operating mode

Commissioning/Configuration [image] EP5101-0011 - Object description and parameterization - normal operating mode
EP5101-0011 - Object description and parameterization - normal operating mode
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Parameterization via the CoE list (CAN over EtherCAT)
The EtherCAT device is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs).
Additional information
•
Restore object
•
Configuration data
•
Input data
•
Output data
•
Information / diagnostic data (channel specific)
•
Standard objects


Restore object

Commissioning/Configuration [image] EP5101-0011 - Object description and parameterization - normal operating mode [image] Restore object
Restore object
Index 1011 Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore the default settings | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" in the set value dialog, all backup objects are reset to their delivery state. Note: Some FW versions also accept the following input: 0x6C6F6164". | UINT32 | RW | 0x00000000 (0dec)


Configuration data

Commissioning/Configuration [image] EP5101-0011 - Object description and parameterization - normal operating mode [image] Configuration data
Configuration data
Index 8000 ENC Settings
Index (hex) | Name | Meaning | Data type | Flags | Default
8000:0 | ENC Settings | Maximum subindex | UINT8 | RO | 0x17 (23dec)
8000:01 | Enable C reset | The counter is reset via the C input. | BOOLEAN | RW | 0x00 (0dec)
8000:02 | Enable extern reset | A counter reset is triggered via the external latch input (24 V). | BOOLEAN | RW | 0x00 (0dec)
8000:03 | Enable up/down counter | Enablement of the up/down counter in place of the encoder with the bit set. Increments at input A are counted, input B indicates the count direction. | BOOLEAN | RW | 0x00 (0dec)
8000:04 | Gate polarity | 0: Disable gate 1: Enable pos. gate (gate locks with HIGH signal level) 2: Enable neg. gate (gate locks with LOW signal level) | BIT2 | RW | 0x01 (1dec)
8000:08 | Disable filter | 0: Activates the input filter (inputs A, /A, B, /B, C, /C only) 1: Deactivates the input filter If a filter is activated a signal edge must be present for at least 2.4 µs in order to be counted as an increment. | BOOLEAN | RW | 0x01 (1dec)
8000:0A | Enable micro increments | If DC mode is activated, the EP5101-0011 interpolates micro-increments between the integer encoder increments. The lower 8 bits of the Counter Value are used in each case for the display. A 32-bit counter thus becomes a 24+8-bit counter, a 16-bit counter becomes an 8+8-bit counter. | BOOLEAN | RW | 0x00 (0dec)
8000:0B | Open circuit detection A | An open circuit on track A is indicated in object Open circuit (index 0x6000:07) and as a process data. Diagnosis is only possible if the corresponding input is wired differentially. A differential voltage < 3.5 V (typical, subject to change) is detected as a broken wire. | BOOLEAN | RW | 0x01 (1dec)
8000:0C | Open circuit detection B | An open circuit on track B is indicated in object Open circuit (index 0x6000:07) and as a process data. Diagnosis is only possible if the corresponding input is wired differentially. A differential voltage < 3.5 V (typical, subject to change) is detected as a broken wire. | BOOLEAN | RW | 0x01 (1dec)
8000:0D | Open circuit detection C | An open circuit on track C is indicated in object Open circuit (index 0x6000:07) and as a process data. Diagnosis is only possible if the corresponding input is wired differentially. A differential voltage < 3.5 V (typical, subject to change) is detected as a broken wire. | BOOLEAN | RW | 0x00 (0dec)
8000:0E | Reversion of rotation | Activates reversion of rotation | BOOLEAN | RW | 0x00 (0dec)
8000:10 | Extern reset polarity | 0: Fall (the counter is set to zero with a falling edge) 1: Rise (the counter is set to zero with a rising edge) | BIT2 | RW | 0x01 (1dec)
8000:11 | Frequency window | This is the minimum time over which the frequency is determined; default value 10 ms [resolution: 1 µs]. The number of pulses in the time window + the following is measured. The maximum waiting time is specified in the Frequency Wait Time parameter. The number of pulses is divided by the actual time window size. The determined frequency is output in object Frequency value (index 0x6000:13) and as a process data. The frequency calculation is carried out locally without distributed clocks function. | UINT16 | RW | 0x2710 (10000dec)
8000:13 | Frequency scaling | Scaling of the frequency measurement (must be divided by this value to obtain the unit in Hz): 100: “0.01 Hz” | UINT16 | RW | 0x0064 (100dec)
8000:14 | Period scaling | Resolution of the period in the process data: 100: “100 ns” period value is a multiple of 100 ns 500: “500 ns” period value is a multiple of 500 ns | UINT16 | RW | 0x0064 (100dec)
8000:15 | Frequency resolution | Resolution of the frequency measurement: 100: “0.01 Hz” | UINT16 | RW | 0x0064 (100dec)
Index (hex) | Name | Meaning | Data type | Flags | Default
8000:16 | Period resolution | Internal resolution of the period measurement: 100: “100 ns” period value is a multiple of 100 ns The period is calculated internally with a resolution of 100 ns. The max. measurable period can then be approx. 1.6 seconds. 500: “500 ns” period value is a multiple of 500 ns Internally the period is calculated with 500 ns resolution. The maximum measurable period is approx. 32.7 ms. The resolution of the process data continues to be the value according to object Period scaling (index 0x8000:14) (e.g. 100 ns [default]). | UINT16 | RW | 0x0064 (100dec)
8000:17 | Frequency wait time | Waiting time [ms] for frequency measurement Once the time specified in the frequency window has elapsed, the system waits for the next positive edge from track A. This enables the update speed for the Frequency process data to be optimized, depending on the expected frequencies. The minimum value to be entered here is twice the cycle duration of the smallest measured frequency. T >= 2* (1 / fmin) | UINT16 | RW | 0x0640 (1600dec)


Input data

Commissioning/Configuration [image] EP5101-0011 - Object description and parameterization - normal operating mode [image] Input data
Input data
Index 6000 ENC Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
6000:0 | ENC Inputs | Maximum subindex | UINT8 | RO | 0x16 (22dec)
6000:01 | Latch C valid | The counter value was latched with the “C” input. The data with Latch Value (Index 0x6000:12) corresponds to the latched value if the bit is set. To re-enable the latch input, Enable latch C (index 0x7000:01) must be canceled and then reset. | BOOLEAN | RO | 0x00 (0dec)
6000:02 | Latch extern valid | The counter value was locked via the external latch. The data with Latch Value (Index 0x6000:12) corresponds to the latched value if the bit is set. To re-enable the latch input, Enable latch extern on positive edge (index 0x7000:02) or object Enable latch extern on negative edge (index 0x7000:04) must first be canceled and then reset. | BOOLEAN | RO | 0x00 (0dec)
6000:03 | Set counter done | The counter was set. | BOOLEAN | RO | 0x00 (0dec)
6000:04 | Counter underflow | Counter underflow. Overflow/underflow control is inactive in combination with a reset function (C/external). | BOOLEAN | RO | 0x00 (0dec)
6000:05 | Counter overflow | Counter overflow. Overflow/underflow control is inactive in combination with a reset function (C/external). | BOOLEAN | RO | 0x00 (0dec)
6000:06 | Status of input status | State of the status input (alarm “input 1”) | BOOLEAN | RO | 0x00 (0dec)
6000:07 | Open circuit | Indicates an open circuit. Configuration via the objects: Open circuit detection A Index0x8000:0B, Open circuit detection B Index0x8000:0C, Open circuit detection C Index0x8000:0D | BOOLEAN | RO | 0x00 (0dec)
6000:08 | Extrapolation stall | The extrapolated part of the counter is invalid. | BOOLEAN | RO | 0x00 (0dec)
6000:09 | Status of input A | Status of input A | BOOLEAN | RO | 0x00 (0dec)
6000:0A | Status of input B | Status of input B | BOOLEAN | RO | 0x00 (0dec)
6000:0B | Status of input C | Status of input C | BOOLEAN | RO | 0x00 (0dec)
6000:0C | Status of input gate | The state of the gate input | BOOLEAN | RO | 0x00 (0dec)
6000:0D | Status of extern ledge | Status of the extern latch input | BOOLEAN | RO | 0x00 (0dec)
6000:0E | Sync error | The Sync error bit is only required for DC mode. It indicates whether a synchronization error has occurred during the previous cycle. This means a SYNC signal was triggered in the EP5101-0011, although no new process data were available (0=OK, 1=NOK). | BOOLEAN | RO | 0x00 (0dec)
6000:0F | TxPDO State | Validity of the data of the associated TxPDO (0 = valid, 1 = invalid). | BOOLEAN | RO | 0x00 (0dec)
6000:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
6000:11 | Counter value | Counter value | UINT32 | RO | 0x00000000 (0dec)
6000:12 | Latch value | Latch value | UINT32 | RO | 0x00000000 (0dec)
6000:13 | Frequency value | The frequency (setting of the scaling in index 0x8000:13 and resolution in index 0x8000:15) | UINT32 | RO | 0x00000000 (0dec)
6000:14 | Period value | The cycle duration/period (setting of the scaling in index 0x8000:14 and resolution in index 0x8000:16) | UINT32 | RO | 0x00000000 (0dec)
6000:16 | Timestamp | Timestamp of the last counter change | UINT64 | RO |


Output data

Commissioning/Configuration [image] EP5101-0011 - Object description and parameterization - normal operating mode [image] Output data
Output data
Index 7000 ENC Outputs
Index (hex) | Name | Meaning | Data type | Flags | Default
7000:0 | ENC Outputs | Maximum subindex | UINT8 | RO | 0x11(17dec)
7000:01 | Enable latch C | Activate latching via input “C”. | BOOLEAN | RO | 0x00 (0dec)
7000:01 | Enable latch extern on positive edge | Activate external latch with positive edge. | BOOLEAN | RO | 0x00 (0dec)
7000:03 | Set counter | Set counter value | BOOLEAN | RO | 0x00 (0dec)
7000:04 | Enable latch extern on negative edge | Activate external latch with negative edge. | BOOLEAN | RO | 0x00 (0dec)
7000:11 | Set counter value | The counter value to be set via Set counter (index 0x7000:03). | UINT32 | RO | 0x00000000 (dec)


Information / diagnostic data (channel specific)

Commissioning/Configuration [image] EP5101-0011 - Object description and parameterization - normal operating mode [image] Information / diagnostic data (channel specific)
Information / diagnostic data (channel specific)
Index A000 ENC Diag data
Index (hex) | Name | Meaning | Data type | Flags | Default
A000:0 | ENC Diag data | Maximum subindex | UINT8 | RO | 0x03 (3dec)
A000:01 | Open circuit A | Open circuit on track A | BOOLEAN | RO | 0x00 (0dec)
A000:02 | Open circuit B | Open circuit on track B | BOOLEAN | RO | 0x00 (0dec)
A000:03 | Open circuit C | Open circuit on track C | BOOLEAN | RO | 0x00 (0dec)


Standard objects

Commissioning/Configuration [image] EP5101-0011 - Object description and parameterization - normal operating mode [image] Standard objects
Standard objects
The standard objects have the same meaning for all EtherCAT slaves.
Index 1000 Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x01FF1389 (33493897dec)
Index 1008 Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EP5101-0011
Index 1009 Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO | -
Index 100A Software version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO | -
Index 1018 Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x13ED4052 (334315602dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the Low Word (bit 0-15) indicates the special terminal number, the High Word (bit 16-31) refers to the device description | UINT32 | RO | 0x00000000 (0dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the Low Byte (bit 0-7) of the Low Word contains the year of production, the High Byte (bit 8-15) of the Low Word contains the week of production, the High Word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 Backup parameter handling
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | Information for standardized loading and saving of backup entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum across all backup entries of the EtherCAT slave | UINT32 | RO | 0x00000000 (0dec)
Index 1400 ENC RxPDO-Par Control compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1400:0 | ENC RxPDO-Par Control compact | PDO Parameter RxPDO 1 | UINT8 | RO | 0x06 (6dec)
1400:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 1 | OCTET-STRING[2] | RO | 01 16
Index 1401 ENC RxPDO-Par Control
Index (hex) | Name | Meaning | Data type | Flags | Default
1401:0 | ENC RxPDO-Par Control | PDO Parameter RxPDO 2 | UINT8 | RO | 0x06 (6dec)
1401:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 2 | OCTET-STRING[2] | RO | 00 16
Index 1600 ENC RxPDO-Map Control compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1600:0 | ENC RxPDO-Map Control compact | PDO Mapping RxPDO 3 | UINT8 | RO | 0x07 (7dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01,1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:02,1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs),entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7000:04, 1
1600:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1600:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1600:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 16
Index 1601 ENC RxPDO-Map Control
Index (hex) | Name | Meaning | Data type | Flags | Default
1601:0 | ENC RxPDO-Map Control compact | PDO Mapping RxPDO | UINT8 | RO | 0x07 (7dec)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01,1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:02,1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x700:03,1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x700:04,1
1601:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00,4
1601:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00,8
1601:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11,32
Index 1800 ENC TxPDO-Par Status compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1800:0 | ENC TxPDO-Par Status | PDO parameter TxPDO 1 | UINT8 | RO | 0x09 (9dec)
1800:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 1 | OCTET-STRING[2] | RO | 01 1A
1800:07 | TxPDO State | The TxPDO state is set if it was not possible to correctly read in the associated input data | BOOLEAN | RO | 0x00 (0dec)
1800:09 | TxPDO Toggle | The TxPDO toggle is toggled with each update the corresponding input data | BOOLEAN | RO | 0x00 (0dec)
Index 1801 ENC TxPDO-Par Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1801:0 | ENC TxPDO-Par Status compact | PDO parameter TxPDO 2 | UINT8 | RO | 0x09 (9dec)
1801:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 2 | OCTET-STRING[2] | RO | 00 1A
1801:07 | TxPDO State | The TxPDO state is set if it was not possible to correctly read in the associated input data | BOOLEAN | RO | 0x00 (0dec)
1801:09 | TxPDO Toggle | The TxPDO toggle is toggled with each update the corresponding input data | BOOLEAN | RO | 0x00 (0dec)
Index 1802 ENC TxPDO-Par Frequency
Index (hex) | Name | Meaning | Data type | Flags | Default
1802:0 | ENC TxPDO-Par Frequency | PDO parameter TxPDO 3 | UINT8 | RO | 0x06 (6dec)
1802:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 3 | OCTET-STRING[2] | RO | 03 1A
Index 1803 ENC TxPDO-Par Period
Index (hex) | Name | Meaning | Data type | Flags | Default
1803:0 | ENC TxPDO-Par Period | PDO parameter TxPDO 4 | UINT8 | RO | 0x06 (6dec)
1803:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 4 | OCTET-STRING[2] | RO | 02 1A
Index 1804 ENC TxPDO-Par Timest.
Index (hex) | Name | Meaning | Data type | Flags | Default
1804:0 | ENC TxPDO-Par Timest. | PDO parameter TxPDO 5 | UINT8 | RO | 0x06 (6dec)
1804:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 5 | OCTET-STRING[2] | RO | 05 1A
Index 1805 ENC TxPDO-Par Timest. compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1805:0 | ENC TxPDO-Par Timest. compact | PDO parameter TxPDO 6 | UINT8 | RO | 0x06 (6dec)
1805:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 6 | OCTET-STRING[2] | RO | 04 1A
Index 1A00 ENC TxPDO-Map Status compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1A00:0 | ENC TxPDO-Map Status | ENC TxPDO-Map Status compact | UINT8 | RO | 0x012 (18dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x06 (Status of input status)) | UINT32 | RO | 0x6000:06, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6000:07, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A00:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0C (Status of input gate)) | UINT32 | RO | 0x6000:0C; 2
1A00:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6000:0D; 2
1A00:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A00:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1800 (ENC TxPDO-Par Status compact), entry 0x07 (TxPDO State) | UINT32 | RO | 0x1800:07, 1
1A00:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x1800 (ENC TxPDO-Par Status compact), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1800:09, 1
1A00:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 16
1A00:12 | SubIndex 018 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 16
Index 1A01 ENC TxPDO-Map Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1A01:0 | ENC TxPDO-Map Status compact | PDO Mapping TxPDO 2 | UINT8 | RO | 0x12 (18dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x06 (Status of input status)) | UINT32 | RO | 0x6000:06, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6000:07, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A01:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0C (Status of input gate)) | UINT32 | RO | 0x6000:0C, 1
1A01:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0D (Status of extern latch)) | UINT32 |  | 0x6000:0D, 1
1A01:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A01:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1801 (ENC TxPDO-Par Status), entry 0x07 (TxPDO State)) |  |  | 0x1801:07, 1
1A01:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x1801 (ENC TxPDO-Par Status), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1801:09, 1
1A01:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 16
1A01:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 16
Index 1A02 ENC TxPDO-Map Frequency
Index (hex) | Name | Meaning | Data type | Flags | Default
1A02:0 | TxPDO map frequency | PDO Mapping TxPDO | UINT8 | RO | 0x01 (1dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (Inputs), entry 0x13 (Frequency value)) | UINT32 | RO | 0x6000:13, 32
Index 1A03 ENC TxPDO-Map Period
Index (hex) | Name | Meaning | Data type | Flags | Default
1A03:0 | ENC TxPDO-Map Period | ENC TxPDO-Map Period | UINT8 | RO | 0x01 (1dec)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x14 (Period value)) | UINT32 | RO | 0x6000:14, 32
Index 1A04 ENC TxPDO-Map Timest.
Index (hex) | Name | Meaning | Data type | Flags | Default
1A04:0 | ENC TxPDO-Map Timest. compact | PDO Mapping TxPDO | UINT8 | RO | 0x01 (1dec)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x16 (Timestamp)) | UINT32 | RO | 0x6000:16, 64
Index 1A05 ENC TxPDO-Map Timest. compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1A05:0 | ENC TxPDO-Map Timest. compact | PDO Mapping TxPDO | UINT8 | RO | 0x01 (1dec)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x16 (Timestamp)) | UINT32 | RO | 0x6000:16, 32
Index 1C00 Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the Sync Managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write(Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x01 (1dec)
1C12:01 | SubIndex 001 | 1. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1600 (5632dec)
Index 1C13 TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x01 (1dec)
1C13:01 | SubIndex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | SubIndex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:03 | SubIndex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 1C32 SM output parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C32:0
SM output parameter
Synchronization parameters for the outputs
UINT8
RO
0x20 (32dec)
1C32:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dec)
1C32:02
Cycle time
Cycle time (in ns):
▪
Free Run: Cycle time of the local timer
▪
Synchron with SM 2 Event: Master cycle time
▪
DC mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x00000000 (0dec)
1C32:03
Shift time
Time between SYNC0 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0 = 1: free run is supported
▪
Bit 1 = 1: Synchron with SM 2 Event is supported
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 10: Output shift with SYNC1 event (only DC mode)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08)
UINT16
RO
0xC007 (49159dec)
1C32:05
Minimum cycle time
Minimum cycle time (in ns)
UINT32
RO
0x00000000 (0dec)
1C32:06
Calc and copy time
Minimum time between SYNC0 and SYNC1 event (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:08
Command
With this entry the real required process data provision time can be measured.
▪
0: Measurement of the local cycle time is stopped
▪
1: Measurement of the local cycle time is started
The entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 are updated with the maximum measured values.
For a subsequent measurement the measured values are reset.
UINT16
RW
0x0000 (0dec)
1C32:09
Maximum delay time
Time between SYNC1 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:0B
SM event missed counter
Number of missed SM events in OPERATIONAL (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:0C
Cycle exceeded counter
Number of occasions the cycle time was exceeded in OPERATIONAL (cycle was not completed in time or the next cycle began too early)
UINT16
RO
0x0000 (0dec)
1C32:0D
Shift too short counter
Number of occasions that the interval between SYNC0 and SYNC1 event was too short (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:20
Sync error
The synchronization was not correct in the last cycle (outputs were output too late; DC mode only)
BOOLEAN
RO
0x00 (0dec)
Index 1C33 SM input parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (no outputs available)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (outputs available)
UINT16
RW
0x0022 (34dec)
1C33:02
Cycle time
as 0x1C32:02
UINT32
RW
0x00000000 (0dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: Synchron with SM 2 Event is supported (outputs available)
▪
Bit 1: Synchron with SM 3 Event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: Input shift through local event (outputs available)
▪
Bit 4-5 = 10: Input shift with SYNC1 event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08 or 0x1C33:08)
UINT16
RO
0xC007 (49159dec)
1C33:05
Minimum cycle time
as 0x1C32:05
UINT32
RO
0x00000000 (0dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:07
Minimum delay time
UINT32
RO
0x00000000 (0dec)
1C33:08
Command
as 0x1C32:08
UINT16
RW
0x0000 (0dec)
1C33:09
Delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:0B
SM event missed counter
as 0x1C32:11
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
as 0x1C32:12
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
as 0x1C32:13
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
as 0x1C32:32
BOOLEAN
RO
0x00 (0dec)
Index F000 Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0001 (1dec)
Index F008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module list
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list | Maximum subindex | UINT8 | RW | 0x02 (2dec)
F010:01 | SubIndex 001 | reserved | UINT32 | RW | 0x000001FE (510dec)
F010:02 | SubIndex 002 | reserved | UINT32 | RW | 0x000001FF (511dec)


EP5101-2011 - Object description and parameterization - normal operating mode

Commissioning/Configuration [image] EP5101-2011 - Object description and parameterization - normal operating mode
EP5101-2011 - Object description and parameterization - normal operating mode
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Parameterization via the CoE list (CAN over EtherCAT)
The EtherCAT device is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs).
Additional information
•
Restore object
•
Configuration data
•
Input data
•
Output data
•
Information / diagnostic data (channel specific)
•
Standard objects


Restore object

Commissioning/Configuration [image] EP5101-2011 - Object description and parameterization - normal operating mode [image] Restore object
Restore object
Index 1011 Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore the default settings | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" in the set value dialog, all backup objects are reset to their delivery state. Note: Some FW versions also accept the following input: 0x6C6F6164". | UINT32 | RW | 0x00000000 (0dec)


Configuration data

Commissioning/Configuration [image] EP5101-2011 - Object description and parameterization - normal operating mode [image] Configuration data
Configuration data
Index 8000 ENC Settings
Index (hex) | Name | Meaning | Data type | Flags | Default
8000:0 | ENC Settings | Maximum subindex | UINT8 | RO | 0x17 (23dec)
8000:01 | Enable C reset | The counter is reset via the C input. | BOOLEAN | RW | 0x00 (0dec)
8000:02 | Enable extern reset | A counter reset is triggered via the external latch input (24 V). | BOOLEAN | RW | 0x00 (0dec)
8000:04 | Gate polarity | 0: Disable gate 1: Enable pos. gate (gate locks with HIGH signal level) 2: Enable neg. gate (gate locks with LOW signal level) | BIT2 | RW | 0x01 (1dec)
8000:0B | Open circuit detection A | An open circuit on track A is indicated in object Open circuit (index 0x6000:07) and as a process data. Diagnosis is only possible if the corresponding input is wired differentially. A differential voltage < 3.5 V (typical, subject to change) is detected as a broken wire. | BOOLEAN | RW | 0x01 (1dec)
8000:0C | Open circuit detection B | An open circuit on track B is indicated in object Open circuit (index 0x6000:07) and as a process data. Diagnosis is only possible if the corresponding input is wired differentially. A differential voltage < 3.5 V (typical, subject to change) is detected as a broken wire. | BOOLEAN | RW | 0x01 (1dec)
8000:0D | Open circuit detection C | An open circuit on track C is indicated in object Open circuit (index 0x6000:07) and as a process data. Diagnosis is only possible if the corresponding input is wired differentially. A differential voltage < 3.5 V (typical, subject to change) is detected as a broken wire. | BOOLEAN | RW | 0x00 (0dec)
8000:0E | Reversion of rotation | Activates reversion of rotation | BOOLEAN | RW | 0x00 (0dec)
8000:10 | Extern reset polarity | 0: Fall (the counter is set to zero with a falling edge) 1: Rise (the counter is set to zero with a rising edge) | BIT2 | RW | 0x01 (1dec)
8000:11 | Frequency window | This is the minimum time over which the frequency is determined; default value 10 ms [resolution: 1 µs]. The number of pulses in the time window + the following is measured. The maximum waiting time is specified in the Frequency Wait Time parameter. The number of pulses is divided by the actual time window size. The determined frequency is output in object Frequency value (index 0x6000:13) and as a process data. The frequency calculation is carried out locally without distributed clocks function. | UINT16 | RW | 0x2710 (10000dec)
8000:13 | Frequency scaling | Scaling of the frequency measurement (must be divided by this value to obtain the unit in Hz): 100: “0.01 Hz” | UINT16 | RW | 0x0064 (100dec)
8000:14 | Period scaling | Resolution of the period in the process data: 100: “100 ns” period value is a multiple of 100 ns 500: “500 ns” period value is a multiple of 500 ns | UINT16 | RW | 0x0064 (100dec)
8000:15 | Frequency resolution | Resolution of the frequency measurement: 100: “0.01 Hz” | UINT16 | RW | 0x0064 (100dec)
8000:16 | Period resolution | Internal resolution of the period measurement: 100: “100 ns” period value is a multiple of 100 ns The period is calculated internally with a resolution of 100 ns. The max. measurable period can then be approx. 1.6 seconds. 500: “500 ns” period value is a multiple of 500 ns Internally the period is calculated with 500 ns resolution. The maximum measurable period is approx. 32.7 ms. The resolution of the process data continues to be the value according to object Period scaling (index 0x8000:14) (e.g. 100 ns [default]). | UINT16 | RW | 0x0064 (100dec)
Index (hex) | Name | Meaning | Data type | Flags | Default
8000:17 | Frequency wait time | Waiting time [ms] for frequency measurement Once the time specified in the frequency window has elapsed, the system waits for the next positive edge from track A. This enables the update speed for the Frequency process data to be optimized, depending on the expected frequencies. The minimum value to be entered here is twice the cycle duration of the smallest measured frequency. T >= 2* (1 / fmin) | UINT16 | RW | 0x0640 (1600dec)


Input data

Commissioning/Configuration [image] EP5101-2011 - Object description and parameterization - normal operating mode [image] Input data
Input data
Index 6000 ENC Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
6000:0 | ENC Inputs | Maximum subindex | UINT8 | RO | 0x16 (22dec)
6000:01 | Latch C valid | The counter value was latched with the “C” input. The data with Latch Value (Index 0x6000:12) corresponds to the latched value if the bit is set. To re-enable the latch input, Enable latch C (index 0x7000:01) must be canceled and then reset. | BOOLEAN | RO | 0x00 (0dec)
6000:02 | Latch extern valid | The counter value was locked via the external latch. The data with Latch Value (Index 0x6000:12) corresponds to the latched value if the bit is set. To re-enable the latch input, Enable latch extern on positive edge (index 0x7000:02) or object Enable latch extern on negative edge (index 0x7000:04) must first be canceled and then reset. | BOOLEAN | RO | 0x00 (0dec)
6000:03 | Set counter done | The counter was set. | BOOLEAN | RO | 0x00 (0dec)
6000:06 | Status of input status | State of the status input (alarm “input 1”) | BOOLEAN | RO | 0x00 (0dec)
6000:07 | Open circuit | Indicates an open circuit. Configuration via the objects: Open circuit detection A Index 0x8000:0B, Open circuit detection B Index 0x8000:0C, Open circuit detection C Index 0x8000:0D | BOOLEAN | RO | 0x00 (0dec)
6000:09 | Status of input A | Status of input A | BOOLEAN | RO | 0x00 (0dec)
6000:0A | Status of input B | Status of input B | BOOLEAN | RO | 0x00 (0dec)
6000:0B | Status of input C | Status of input C | BOOLEAN | RO | 0x00 (0dec)
6000:0C | Status of input gate | The state of the gate input | BOOLEAN | RO | 0x00 (0dec)
6000:0D | Status of extern ledge | Status of the extern latch input | BOOLEAN | RO | 0x00 (0dec)
6000:0E | Sync error | The Sync error bit is only required for DC mode. It indicates whether a synchronization error has occurred during the previous cycle. This means a SYNC signal was triggered in the EP5101-2011, although no new process data were available (0=OK, 1=NOK). | BOOLEAN | RO | 0x00 (0dec)
6000:0F | TxPDO State | Validity of the data of the associated TxPDO (0 = valid, 1 = invalid). | BOOLEAN | RO | 0x00 (0dec)
6000:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
6000:11 | Counter value | Counter value | UINT32 | RO | 0x00000000 (0dec)
6000:12 | Latch value | Latch value | UINT32 | RO | 0x00000000 (0dec)
6000:13 | Frequency value | The frequency (setting of the scaling and resolution in index 0x8000:13 and 0x8000:15) | UINT32 | RO | 0x00000000 (0dec)
6000:14 | Period value | The cycle duration/period (setting of the scaling and resolution in index 0x8000:14 and 0x8000:16) | UINT32 | RO | 0x00000000 (0dec)
6000:16 | Timestamp | Timestamp of the last counter change | UINT64 | RO |


Output data

Commissioning/Configuration [image] EP5101-2011 - Object description and parameterization - normal operating mode [image] Output data
Output data
Index 7000 ENC Outputs
Index (hex) | Name | Meaning | Data type | Flags | Default
7000:0 | ENC Outputs | Maximum subindex | UINT8 | RO | 0x11(17dec)
7000:01 | Enable latch C | Activate latching via input “C”. | BOOLEAN | RO | 0x00 (0dec)
7000:02 | Enable latch extern on positive edge | Activate external latch with positive edge. | BOOLEAN | RO | 0x00 (0dec)
7000:03 | Set counter | Set counter value | BOOLEAN | RO | 0x00 (0dec)
7000:04 | Enable latch extern on negative edge | Activate external latch with negative edge. | BOOLEAN | RO | 0x00 (0dec)
7000:11 | Set counter value | The counter value to be set via Set counter (index 0x7000:03). | UINT32 | RO | 0x00000000 (dec)


Information / diagnostic data (channel specific)

Commissioning/Configuration [image] EP5101-2011 - Object description and parameterization - normal operating mode [image] Information / diagnostic data (channel specific)
Information / diagnostic data (channel specific)
Index A000 ENC Diag data
Index (hex) | Name | Meaning | Data type | Flags | Default
A000:0 | ENC Diag data | Maximum subindex | UINT8 | RO | 0x04 (4dec)
A000:01 | Open circuit A | Open circuit on track A | BOOLEAN | RO | 0x00 (0dec)
A000:02 | Open circuit B | Open circuit on track B | BOOLEAN | RO | 0x00 (0dec)
A000:03 | Open circuit C | Open circuit on track C | BOOLEAN | RO | 0x00 (0dec)
A000:04 | Field power failure | Field bus voltage error | BOOLEAN | RO | 0x00 (0dec)


Standard objects

Commissioning/Configuration [image] EP5101-2011 - Object description and parameterization - normal operating mode [image] Standard objects
Standard objects
The standard objects have the same meaning for all EtherCAT slaves.
Index 1000 Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x01FF1389 (5001dec)
Index 1008 Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EP5101-2011
Index 1009 Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO | -
Index 100A Software version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO | -
Index 1018 Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x13ED4052 (334315602dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the Low Word (bit 0-15) indicates the special terminal number, the High Word (bit 16-31) refers to the device description | UINT32 | RO | 0x00000000 (0dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the Low Byte (bit 0-7) of the Low Word contains the year of production, the High Byte (bit 8-15) of the Low Word contains the week of production, the High Word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 Backup parameter handling
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | Information for standardized loading and saving of backup entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum across all backup entries of the EtherCAT slave | UINT32 | RO | 0x00000000 (0dec)
Index 1400 ENC RxPDO-Par Control
Index (hex) | Name | Meaning | Data type | Flags | Default
1400:0 | ENC RxPDO-Par Control | PDO Parameter RxPDO 1 | UINT8 | RO | 0x06 (6dec)
1400:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 1 | OCTET-STRING[2] | RO | 01 16
Index 1401 ENC RxPDO-Par Control compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1401:0 | ENC RxPDO-Par Control compact | PDO Parameter RxPDO 2 | UINT8 | RO | 0x06 (6dec)
1401:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 2 | OCTET-STRING[2] | RO | 00 16
Index 1600 ENC RxPDO-Map Control
Index (hex) | Name | Meaning | Data type | Flags | Default
1600:0 | ENC RxPDO-Map Control | PDO Mapping RxPDO 3 | UINT8 | RO | 0x07 (7dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01,1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:02,1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs),entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7000:04, 1
1600:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1600:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1600:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x700:11, 32
Index 1601 ENC RxPDO-Map Control compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1601:0 | ENC RxPDO-Map Control compact | PDO Mapping RxPDO | UINT8 | RO | 0x07 (7dec)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01,1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7002:00,1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x700:03,1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x700:04,1
1601:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00,4
1601:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00,8
1601:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11,16
Index 1800 ENC TxPDO-Par Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1800:0 | ENC TxPDO-Par Status | PDO parameter TxPDO 1 | UINT8 | RO | 0x06 (6dec)
1800:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 1 | OCTET-STRING[2] | RO | 01 1A
Index 1801 ENC TxPDO-Par Status compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1801:0 | ENC TxPDO-Par Status compact | PDO parameter TxPDO 2 | UINT8 | RO | 0x06 (6dec)
1801:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 2 | OCTET-STRING[2] | RO | 00 1A
Index 1802 ENC TxPDO-Par Period
Index (hex) | Name | Meaning | Data type | Flags | Default
1802:0 | ENC TxPDO-Par Period | PDO parameter TxPDO 3 | UINT8 | RO | 0x06 (6dec)
1802:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 3 | OCTET-STRING[2] | RO | 03 1A
Index 1803 ENC TxPDO-Par Frequency
Index (hex) | Name | Meaning | Data type | Flags | Default
1803:0 | ENC TxPDO-Par Frequency | PDO parameter TxPDO 4 | UINT8 | RO | 0x06 (6dec)
1803:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 4 | OCTET-STRING[2] | RO | 02 1A
Index 1804 ENC TxPDO-Par Timest.
Index (hex) | Name | Meaning | Data type | Flags | Default
1804:0 | ENC TxPDO-Par Timest. | PDO parameter TxPDO 5 | UINT8 | RO | 0x06 (6dec)
1804:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 5 | OCTET-STRING[2] | RO | 05 1A
Index 1805 ENC TxPDO-Par Timest. compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1805:0 | ENC TxPDO-Par Timest. compact | PDO parameter TxPDO 6 | UINT8 | RO | 0x06 (6dec)
1805:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 6 | OCTET-STRING[2] | RO | 04 1A
Index 1A00 ENC TxPDO-Map Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1A00:0 | ENC TxPDO-Map Status | ENC TxPDO-Map Status compact | UINT8 | RO | 0x011 (17dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x06 (Status of input status)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6000:07, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0C (Status of input gate)) | UINT32 | RO | 0x6000:0C, 1
1A00:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6000:0D, 1
1A00:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0E (Sync error)) | UINT32 | RO | 0x6000:0E, 1
1A00:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6000:0F, 1
1A00:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6000:10, 1
1A00:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
1A00:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 16
Index 1A01 ENC TxPDO-Map Status compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1A01:0 | ENC TxPDO-Map Status compact | PDO Mapping TxPDO 2 | UINT8 | RO | 0x11 (17dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x06 (Status of input status)) | UINT32 | RO | 0x6000:06, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6000:07, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0C (Status of input gate)) | UINT32 | RO | 0x6000:0C, 1
1A01:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6000:0D, 1
1A01:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0E (Sync error)) | UINT32 | RO | 0x6000:0E, 1
1A01:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6000:0F, 1
1A01:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6000:10, 1
1A01:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 16
1A01:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 16
Index 1A02 ENC TxPDO-Map Period
Index (hex) | Name | Meaning | Data type | Flags | Default
1A02:0 | TxPDO map period | PDO Mapping TxPDO | UINT8 | RO | 0x01 (1dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (Inputs), entry 0x14 (Period value)) | UINT32 | RO | 0x6000:14, 32
Index 1A03 ENC TxPDO-Map Frequency
Index (hex) | Name | Meaning | Data type | Flags | Default
1A03:0 | ENC TxPDO-Map Frequency | ENC TxPDO-Map Frequency | UINT8 | RO | 0x01 (1dec)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x13 (Frequency value)) | UINT32 | RO | 0x6010:13,32)
Index 1A04 ENC TxPDO-Map Timest.
Index (hex) | Name | Meaning | Data type | Flags | Default
1A04:0 | ENC TxPDO-Map Timest. compact | PDO Mapping TxPDO | UINT8 | RO | 0x01 (1dec)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x16 (Timestamp)) | UINT32 | RO | 0x6000:16, 64
Index 1A05 ENC TxPDO-Map Timest. compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1A05:0 | ENC TxPDO-Map Timest. compact | PDO Mapping TxPDO | UINT8 | RO | 0x01 (1dec)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x16 (Timestamp)) | UINT32 | RO | 0x6000:16, 32
Index 1C00 Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the Sync Managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write(Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x01 (1dec)
1C12:01 | SubIndex 001 | 1. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1600 (5632dec)
Index 1C13 TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x01 (1dec)
1C13:01 | SubIndex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | SubIndex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:03 | SubIndex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 1C32 SM output parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C32:0
SM output parameter
Synchronization parameters for the outputs
UINT8
RO
0x20 (32dec)
1C32:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dec)
1C32:02
Cycle time
Cycle time (in ns):
▪
Free Run: Cycle time of the local timer
▪
Synchron with SM 2 Event: Master cycle time
▪
DC mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x00000000 (0dec)
1C32:03
Shift time
Time between SYNC0 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0 = 1: free run is supported
▪
Bit 1 = 1: Synchron with SM 2 Event is supported
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 10: Output shift with SYNC1 event (only DC mode)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08)
UINT16
RO
0xC007 (49159dec)
1C32:05
Minimum cycle time
Minimum cycle time (in ns)
UINT32
RO
0x00000000 (0dec)
1C32:06
Calc and copy time
Minimum time between SYNC0 and SYNC1 event (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:06
Minimum delay time
UINT32
RO
0x00000000 (0dec)
1C32:08
Command
With this entry the real required process data provision time can be measured.
▪
0: Measurement of the local cycle time is stopped
▪
1: Measurement of the local cycle time is started
The entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 are updated with the maximum measured values.
For a subsequent measurement the measured values are reset
UINT16
RW
0x0000 (0dec)
1C32:09
Maximum delay time
Time between SYNC1 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:0B
SM event missed counter
Number of missed SM events in OPERATIONAL (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:0C
Cycle exceeded counter
Number of occasions the cycle time was exceeded in OPERATIONAL (cycle was not completed in time or the next cycle began too early)
UINT16
RO
0x0000 (0dec)
1C32:0D
Shift too short counter
Number of occasions that the interval between SYNC0 and SYNC1 event was too short (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:20
Sync error
The synchronization was not correct in the last cycle (outputs were output too late; DC mode only)
BOOLEAN
RO
0x00 (0dec)
Index 1C33 SM input parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (no outputs available)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (outputs available)
UINT16
RW
0x0022 (34dec)
1C33:02
Cycle time
as 0x1C32:02
UINT32
RW
0x00000000 (0dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: Synchron with SM 2 Event is supported (outputs available)
▪
Bit 1: Synchron with SM 3 Event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: Input shift through local event (outputs available)
▪
Bit 4-5 = 10: Input shift with SYNC1 event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08 or 0x1C33:08)
UINT16
RO
0xC007 (49159dec)
1C33:05
Minimum cycle time
as 0x1C32:05
UINT32
RO
0x00000000 (0dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:06
Minimum delay time
UINT32
RO
0x00000000 (0dec)
1C33:08
Command
as 0x1C32:08
UINT16
RW
0x0000 (0dec)
1C33:09
Maximum delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:0B
SM event missed counter
as 0x1C32:11
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
as 0x1C32:12
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
as 0x1C32:13
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
as 0x1C32:32
BOOLEAN
RO
0x00 (0dec)
Index F000 Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0001 (1dec)
Index F008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module list
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list | Maximum subindex | UINT8 | RW | 0x02 (2dec)
F010:01 | SubIndex 001 | reserved | UINT32 | RW | 0x000001FF (511dec)


EP5151-0002 - Object description and parameterization - normal operating mode

Commissioning/Configuration [image] EP5151-0002 - Object description and parameterization - normal operating mode
EP5151-0002 - Object description and parameterization - normal operating mode
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Parameterization via the CoE list (CAN over EtherCAT)
The EtherCAT device is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs).
Additional information
•
Restore object
•
Configuration data
•
Input data
•
Output data
•
Standard objects


Restore object

Commissioning/Configuration [image] EP5151-0002 - Object description and parameterization - normal operating mode [image] Restore object
Restore object
Index 1011 Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore the default settings | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" in the set value dialog, all backup objects are reset to their delivery state. Note: Some FW versions also accept the following input: 0x6C6F6164". | UINT32 | RW | 0x00000000 (0dec)


Configuration data

Commissioning/Configuration [image] EP5151-0002 - Object description and parameterization - normal operating mode [image] Configuration data
Configuration data
Index 8000 ENC Settings
Index (hex) | Name | Meaning | Data type | Flags | Default
8000:0 | ENC Settings | Maximum subindex | UINT8 | RO | 0x17 (23dec)
8000:01 | Enable C reset | The counter is reset via the C input. | BOOLEAN | RW | 0x00 (0dec)
8000:02 | Enable extern reset | A counter reset is triggered via the external latch input (24 V). | BOOLEAN | RW | 0x00 (0dec)
8000:03 | Enable up/down counter | Enablement of the up/down counter in place of the encoder with the bit set. Increments at input A are counted, input B indicates the count direction. | BOOLEAN | RW | 0x00 (0dec)
8000:04 | Gate polarity | 0: Disable gate 1: Enable pos. gate (gate locks with HIGH signal level) 2: Enable neg. gate (gate locks with LOW signal level) | BIT2 | RW | 0x01 (1dec)
8000:08 | Disable filter | 0: Activates the input filter (inputs A, /A, B, /B, C, /C only) 1: Deactivates the input filter If a filter is activated a signal edge must be present for at least 2.4 µs in order to be counted as an increment. | BOOLEAN | RW | 0x01 (1dec)
8000:0A | Enable micro increments | If DC mode is activated, the EP5151-0002 interpolates micro-increments between the integer encoder increments. The lower 8 bits of the Counter Value are used in each case for the display. A 32-bit counter thus becomes a 24+8-bit counter, a 16-bit counter becomes an 8+8-bit counter. | BOOLEAN | RW | 0x00 (0dec)
8000:0B | Open circuit detection A | An open circuit on track A is indicated in object Open circuit (index 0x6000:07) and as a process data. Diagnosis is only possible if the corresponding input is wired differentially. A differential voltage < 3.5 V (typical, subject to change) is detected as a broken wire. | BOOLEAN | RW | 0x01 (1dec)
8000:0C | Open circuit detection B | An open circuit on track B is indicated in object Open circuit (index 0x6000:07) and as a process data. Diagnosis is only possible if the corresponding input is wired differentially. A differential voltage < 3.5 V (typical, subject to change) is detected as a broken wire. | BOOLEAN | RW | 0x01 (1dec)
8000:0D | Open circuit detection C | An open circuit on track C is indicated in object Open circuit (index 0x6000:07) and as a process data. Diagnosis is only possible if the corresponding input is wired differentially. A differential voltage < 3.5 V (typical, subject to change) is detected as a broken wire. | BOOLEAN | RW | 0x00 (0dec)
8000:0E | Reversion of rotation | Activates reversion of rotation | BOOLEAN | RW | 0x00 (0dec)
8000:10 | Extern reset polarity | 0: Fall (the counter is set to zero with a falling edge) 1: Rise (the counter is set to zero with a rising edge) | BIT2 | RW | 0x01 (1dec)
8000:11 | Frequency window | This is the minimum time over which the frequency is determined; default value 10 ms [resolution: 1 µs]. The number of pulses in the time window + the following is measured. The maximum waiting time is specified in the Frequency Wait Time parameter. The number of pulses is divided by the actual time window size. The determined frequency is output in object Frequency value (index 0x6000:13) and as a process data. The frequency calculation is carried out locally without distributed clocks function. | UINT16 | RW | 0x2710 (10000dec)
8000:13 | Frequency scaling | Scaling of the frequency measurement (must be divided by this value to obtain the unit in Hz): 100: “0.01 Hz” | UINT16 | RW | 0x0064 (100dec)
8000:14 | Period scaling | Resolution of the period in the process data: 100: “100 ns” period value is a multiple of 100 ns 500: “500 ns” period value is a multiple of 500 ns | UINT16 | RW | 0x0064 (100dec)
8000:15 | Frequency resolution | Resolution of the frequency measurement: 100: “0.01 Hz” | UINT16 | RW | 0x0064 (100dec)
Index (hex) | Name | Meaning | Data type | Flags | Default
8000:16 | Period resolution | Internal resolution of the period measurement: 100: “100 ns” period value is a multiple of 100 ns The period is calculated internally with a resolution of 100 ns. The max. measurable period can then be approx. 1.6 seconds. 500: “500 ns” period value is a multiple of 500 ns Internally the period is calculated with 500 ns resolution. The maximum measurable period is approx. 32.7 ms. The resolution of the process data continues to be the value according to object Period scaling (index 0x8000:14) (e.g. 100 ns [default]). | UINT16 | RW | 0x0064 (100dec)
8000:17 | Frequency wait time | Waiting time [ms] for frequency measurement Once the time specified in the frequency window has elapsed, the system waits for the next positive edge from track A. This enables the update speed for the Frequency process data to be optimized, depending on the expected frequencies. The minimum value to be entered here is twice the cycle duration of the smallest measured frequency. T >= 2* (1 / fmin) | UINT16 | RW | 0x0640 (1600dec)


Input data

Commissioning/Configuration [image] EP5151-0002 - Object description and parameterization - normal operating mode [image] Input data
Input data
Index 6000 ENC Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
6000:0 | ENC Inputs | Maximum subindex | UINT8 | RO | 0x16 (22dec)
6000:01 | Latch C valid | The counter value was latched with the “C” input. The data with Latch Value (Index 0x6000:12) corresponds to the latched value if the bit is set. To re-enable the latch input, Enable latch C (index 0x7000:01) must be canceled and then reset. | BOOLEAN | RO | 0x00 (0dec)
6000:02 | Latch extern valid | The counter value was locked via the external latch. The data with Latch Value (Index 0x6000:12) corresponds to the latched value if the bit is set. To re-enable the latch input, Enable latch extern on positive edge (index 0x7000:02) or object Enable latch extern on negative edge (index 0x7000:04) must first be canceled and then reset. | BOOLEAN | RO | 0x00 (0dec)
6000:03 | Set counter done | The counter was set. | BOOLEAN | RO | 0x00 (0dec)
6000:04 | Counter underflow | Counter underflow. Overflow/underflow control is inactive in combination with a reset function (C/external). | BOOLEAN | RO | 0x00 (0dec)
6000:05 | Counter overflow | Counter overflow. Overflow/underflow control is inactive in combination with a reset function (C/external). | BOOLEAN | RO | 0x00 (0dec)
6000:06 | Status of input status | State of the status input (alarm “input 1”) | BOOLEAN | RO | 0x00 (0dec)
6000:07 | Open circuit | Indicates an open circuit. Configuration via object: Open circuit detection A Index 0x8000:0B, Open circuit detection B Index 0x8000:0C, Open circuit detection C Index 0x8000:0D, | BOOLEAN | RO | 0x00 (0dec)
6000:08 | Extrapolation stall | The extrapolated part of the counter is invalid. | BOOLEAN | RO | 0x00 (0dec)
6000:09 | Status of input A | Status of input A | BOOLEAN | RO | 0x00 (0dec)
6000:0A | Status of input B | Status of input B | BOOLEAN | RO | 0x00 (0dec)
6000:0B | Status of input C | Status of input C | BOOLEAN | RO | 0x00 (0dec)
6000:0C | Status of input gate | The state of the gate input | BOOLEAN | RO | 0x00 (0dec)
6000:0D | Status of extern ledge | Status of the extern latch input | BOOLEAN | RO | 0x00 (0dec)
6000:0E | Sync error | The Sync error bit is only required for DC mode. It indicates whether a synchronization error has occurred during the previous cycle. This means a SYNC signal was triggered in the EP5151-0002, although no new process data were available (0=OK, 1=NOK). | BOOLEAN | RO | 0x00 (0dec)
6000:0F | TxPDO State | Validity of the data of the associated TxPDO (0 = valid, 1 = invalid). | BOOLEAN | RO | 0x00 (0dec)
6000:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
6000:11 | Counter value | Counter value | UINT32 | RO | 0x00000000 (0dec)
6000:12 | Latch value | Latch value | UINT32 | RO | 0x00000000 (0dec)
6000:13 | Frequency value | The frequency (setting of the scaling in index 0x8000:13 and resolution in index 0x8000:15) | UINT32 | RO | 0x00000000 (0dec)
6000:14 | Period value | The cycle duration/period (setting of the scaling in index 0x8000:14 and resolution in index 0x8000:16) | UINT32 | RO | 0x00000000 (0dec)
6000:16 | Timestamp | Timestamp of the last counter change | UINT64 | RO |


Output data

Commissioning/Configuration [image] EP5151-0002 - Object description and parameterization - normal operating mode [image] Output data
Output data
Index 7000 ENC Outputs
Index (hex) | Name | Meaning | Data type | Flags | Default
7000:0 | ENC Outputs | Maximum subindex | UINT8 | RO | 0x11(17dec)
7000:01 | Enable latch C | Activate latching via input “C”. | BOOLEAN | RO | 0x00 (0dec)
7000:01 | Enable latch extern on positive edge | Activate external latch with positive edge. | BOOLEAN | RO | 0x00 (0dec)
7000:03 | Set counter | Set counter value | BOOLEAN | RO | 0x00 (0dec)
7000:04 | Enable latch extern on negative edge | Activate external latch with negative edge. | BOOLEAN | RO | 0x00 (0dec)
7000:11 | Set counter value | The counter value to be set via Set counter (index 0x7000:03). | UINT32 | RO | 0x00000000 (dec)


Standard objects

Commissioning/Configuration [image] EP5151-0002 - Object description and parameterization - normal operating mode [image] Standard objects
Standard objects
The standard objects have the same meaning for all EtherCAT slaves.
Index 1000 Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x01FF1389 (33493897dec)
Index 1008 Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EP5151-0002
Index 1009 Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO | -
Index 100A Software version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO | -
Index 1018 Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x13ED4052 (334315602dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the Low Word (bit 0-15) indicates the special terminal number, the High Word (bit 16-31) refers to the device description | UINT32 | RO | 0x00000000 (0dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the Low Byte (bit 0-7) of the Low Word contains the year of production, the High Byte (bit 8-15) of the Low Word contains the week of production, the High Word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 Backup parameter handling
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | Information for standardized loading and saving of backup entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum across all backup entries of the EtherCAT slave | UINT32 | RO | 0x00000000 (0dec)
Index 1400 ENC RxPDO-Par Control compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1400:0 | ENC RxPDO-Par Control compact | PDO Parameter RxPDO 1 | UINT8 | RO | 0x06 (6dec)
1400:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 1 | OCTET-STRING[2] | RO | 01 16
Index 1401 ENC RxPDO-Par Control
Index (hex) | Name | Meaning | Data type | Flags | Default
1401:0 | ENC RxPDO-Par Control | PDO Parameter RxPDO 2 | UINT8 | RO | 0x06 (6dec)
1401:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 2 | OCTET-STRING[2] | RO | 00 16
Index 1600 ENC RxPDO-Map Control compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1600:0 | ENC RxPDO-Map Control compact | PDO Mapping RxPDO 3 | UINT8 | RO | 0x07 (7dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01,1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:02,1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7000:04, 1
1600:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1600:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1600:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 16
Index 1601 ENC RxPDO-Map Control
Index (hex) | Name | Meaning | Data type | Flags | Default
1601:0 | ENC RxPDO-Map Control | PDO Mapping RxPDO | UINT8 | RO | 0x07 (7dec)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01,1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:02,1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x700:03,1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x700:04,1
1601:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00,4
1601:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00,8
1601:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11,32
Index 1800 ENC TxPDO-Par Status compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1800:0 | ENC TxPDO-Par Status compact | PDO parameter TxPDO 1 | UINT8 | RO | 0x09 (9dec)
1800:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 1. | OCTET-STRING[2] | RO | 01 1A
1800:07 | TxPDO State | The TxPDO state is set if it was not possible to correctly read in the associated input data. | BOOLEAN | RO | 0x00 (0dec)
1800:09 | TxPDO Toggle | The TxPDO toggle is toggled with each update the corresponding input data. | BOOLEAN | RO | 0x00 (0dec)
Index 1801 ENC TxPDO-Par Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1801:0 | ENC TxPDO-Par Status | PDO parameter TxPDO 2 | UINT8 | RO | 0x09 (9dec)
1801:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 2. | OCTET-STRING[2] | RO | 00 1A
1801:07 | TxPDO State | The TxPDO state is set if it was not possible to correctly read in the associated input data. | BOOLEAN | RO | 0x00 (0dec)
1801:09 | TxPDO Toggle | The TxPDO toggle is toggled with each update the corresponding input data. | BOOLEAN | RO | 0x00 (0dec)
Index 1802 ENC TxPDO-Par Frequency
Index (hex) | Name | Meaning | Data type | Flags | Default
1802:0 | ENC TxPDO-Par Frequency | PDO parameter TxPDO 3 | UINT8 | RO | 0x06 (6dec)
1802:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 3. | OCTET-STRING[2] | RO | 03 1A
Index 1803 ENC TxPDO-Par Period
Index (hex) | Name | Meaning | Data type | Flags | Default
1803:0 | ENC TxPDO-Par Period | PDO parameter TxPDO 4 | UINT8 | RO | 0x06 (6dec)
1803:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 4. | OCTET-STRING[2] | RO | 02 1A
Index 1804 ENC TxPDO-Par Timestamp
Index (hex) | Name | Meaning | Data type | Flags | Default
1804:0 | ENC TxPDO-Par Timestamp | PDO parameter TxPDO 5 | UINT8 | RO | 0x06 (6dec)
1804:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 5. | OCTET-STRING[2] | RO | 05 1A
Index 1805 ENC TxPDO-Par Timestamp compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1805:0 | ENC TxPDO-Par Timestamp compact | PDO parameter TxPDO 6 | UINT8 | RO | 0x06 (6dec)
1805:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 6. | OCTET-STRING[2] | RO | 04 1A
Index 1A00 ENC TxPDO-Map Status compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1A00:0 | ENC TxPDO-Map Status | ENC TxPDO-Map Status compact | UINT8 | RO | 0x012 (18dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x06 (Status of input status)) | UINT32 | RO | 0x6000:06, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6000:07, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A00:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0C (Status of input gate)) | UINT32 | RO | 0x6000:0C, 1
1A00:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6000:0D, 1
1A00:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A00:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1800 (ENC TxPDO-Par Status compact), entry 0x07 (TxPDO State) | UINT32 | RO | 0x1800:07, 1
1A00:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x1800 (ENC TxPDO-Par Status compact), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1800:09, 1
1A00:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 16
1A00:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 16
Index 1A01 ENC TxPDO-Map Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1A01:0 | ENC TxPDO-Map Status compact | PDO Mapping TxPDO 2 | UINT8 | RO | 0x12 (17dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x06 (Status of input status)) | UINT32 | RO | 0x6000:06, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6000:07, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A01:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0C (Status of input gate)) | UINT32 | RO | 0x6000:0C, 1
1A01:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6000:0D, 1
1A01:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A01:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1801 (ENC TxPDO-Par Status), entry 0x07 (TxPDO State)) | UINT32 | RO | 0x1801:07, 1
1A01:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x1801 (ENC TxPDO-Par Status), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1801:09, 1
1A01:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
1A01:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 32
Index 1A02 ENC TxPDO-Map Frequency
Index (hex) | Name | Meaning | Data type | Flags | Default
1A02:0 | TxPDO map frequency | PDO Mapping TxPDO | UINT8 | RO | 0x01 (1dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (Inputs), entry 0x13 (Frequency value)) | UINT32 | RO | 0x6000:13, 32
Index 1A03 ENC TxPDO-Map Period
Index (hex) | Name | Meaning | Data type | Flags | Default
1A03:0 | ENC TxPDO-Map Period | ENC TxPDO-Map Period | UINT8 | RO | 0x01 (1dec)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x14 (Period value)) | UINT32 | RO | 0x6000:14,32
Index 1A04 ENC TxPDO-Map Timest.
Index (hex) | Name | Meaning | Data type | Flags | Default
1A04:0 | ENC TxPDO-Map Timest. compact | PDO Mapping TxPDO | UINT8 | RO | 0x01 (1dec)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x16 (Timestamp)) | UINT32 | RO | 0x6000:16, 64
Index 1A05 ENC TxPDO-Map Timest. compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1A05:0 | ENC TxPDO-Map Timest. compact | PDO Mapping TxPDO | UINT8 | RO | 0x01 (1dec)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x16 (Timestamp)) | UINT32 | RO | 0x6000:16, 32
Index 1C00 Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the Sync Managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write(Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x01 (1dec)
1C12:01 | SubIndex 001 | 1. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1600 (5632dec)
Index 1C13 TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x01 (1dec)
1C13:01 | SubIndex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | SubIndex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:03 | SubIndex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 1C32 SM output parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C32:0
SM output parameter
Synchronization parameters for the outputs
UINT8
RO
0x20 (32dec)
1C32:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dec)
1C32:02
Cycle time
Cycle time (in ns):
▪
Free Run: Cycle time of the local timer
▪
Synchron with SM 2 Event: Master cycle time
▪
DC mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x00000000 (0dec)
1C32:03
Shift time
Time between SYNC0 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0 = 1: free run is supported
▪
Bit 1 = 1: Synchron with SM 2 Event is supported
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 10: Output shift with SYNC1 event (only DC mode)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08)
UINT16
RO
0xC007 (49159dec)
1C32:05
Minimum cycle time
Minimum cycle time (in ns)
UINT32
RO
0x00000000 (0dec)
1C32:06
Calc and copy time
Minimum time between SYNC0 and SYNC1 event (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:07
Minimum delay time
UINT32
RO
0x00000000 (0dec)
1C32:08
Command
With this entry the real required process data provision time can be measured.
▪
0: Measurement of the local cycle time is stopped
▪
1: Measurement of the local cycle time is started
The entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 are updated with the maximum measured values.
For a subsequent measurement the measured values are reset
UINT16
RW
0x0000 (0dec)
1C32:09
Maximum delay time
Time between SYNC1 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:0B
SM event missed counter
Number of missed SM events in OPERATIONAL (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:0C
Cycle exceeded counter
Number of occasions the cycle time was exceeded in OPERATIONAL (cycle was not completed in time or the next cycle began too early)
UINT16
RO
0x0000 (0dec)
1C32:0D
Shift too short counter
Number of occasions that the interval between SYNC0 and SYNC1 event was too short (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:20
Sync error
The synchronization was not correct in the last cycle (outputs were output too late; DC mode only)
BOOLEAN
RO
0x00 (0dec)
Index 1C33 SM input parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (no outputs available)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (outputs available)
UINT16
RW
0x0022 (34dec)
1C33:02
Cycle time
as 0x1C32:02
UINT32
RW
0x00000000 (0dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: Synchron with SM 2 Event is supported (outputs available)
▪
Bit 1: Synchron with SM 3 Event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: Input shift through local event (outputs available)
▪
Bit 4-5 = 10: Input shift with SYNC1 event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08 or 0x1C33:08)
UINT16
RO
0xC007 (49159dec)
1C33:05
Minimum cycle time
as 0x1C32:05
UINT32
RO
0x00000000 (0dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:06
Minimum delay time
UINT32
RO
0x00000000 (0dec)
1C33:08
Command
as 0x1C32:08
UINT16
RW
0x0000 (0dec)
1C33:09
Maximum delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:0B
SM event missed counter
as 0x1C32:11
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
as 0x1C32:12
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
as 0x1C32:13
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
as 0x1C32:32
BOOLEAN
RO
0x00 (0dec)
Index F000 Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0001 (1dec)
Index F008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module list
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list | Maximum subindex | UINT8 | RW | 0x01 (1dec)
F010:01 | SubIndex 001 | reserved | UINT32 | RW | 0x000001FF (511dec)


Restoring the delivery state

Commissioning/Configuration [image] Restoring the delivery state
Restoring the delivery state
To restore the delivery state for backup objects in ELxxxx terminals / EPxxxx- and EPPxxxx boxes, the CoE object Restore default parameters, SubIndex 001 can be selected in the TwinCAT System Manager (Config mode).
Selecting the Restore default parameters PDO
Double-click on SubIndex 001 to enter the Set Value dialog. Enter the value 1684107116 in field Dec or the value 0x64616F6C in field Hex and confirm with OK.
All backup objects are reset to the delivery state.
Entering a restore value in the Set Value dialog
Alternative restore value
In some older terminals / boxes the backup objects can be switched with an alternative restore value:
Decimal value: 1819238756
Hexadecimal value: 0x6C6F6164
An incorrect entry for the restore value has no effect.


Appendix

Appendix
Appendix
Additional information
•
General operating conditions
•
Accessories
•
Version identification of EtherCAT devices
•
Support and Service


General operating conditions

Appendix [image] General operating conditions
General operating conditions
Protection degrees (IP-Code)
The standard IEC 60529 (DIN EN 60529) defines the degrees of protection in different classes.
1. Number: dust protection and touch guard | Definition
0 | Non-protected
1 | Protected against access to hazardous parts with the back of a hand. Protected against solid foreign objects of Ø 50 mm
2 | Protected against access to hazardous parts with a finger. Protected against solid foreign objects of Ø 12.5 mm.
3 | Protected against access to hazardous parts with a tool. Protected against solid foreign objects Ø 2.5 mm.
4 | Protected against access to hazardous parts with a wire. Protected against solid foreign objects Ø 1 mm.
5 | Protected against access to hazardous parts with a wire. Dust-protected. Intrusion of dust is not totally prevented, but dust shall not penetrate in a quantity to interfere with satisfactory operation of the device or to impair safety.
6 | Protected against access to hazardous parts with a wire. Dust-tight. No intrusion of dust.
2. Number: water* protection | Definition
0 | Non-protected
1 | Protected against water drops
2 | Protected against water drops when enclosure tilted up to 15°.
3 | Protected against spraying water. Water sprayed at an angle up to 60° on either side of the vertical shall have no harmful effects.
4 | Protected against splashing water. Water splashed against the disclosure from any direction shall have no harmful effects
5 | Protected against water jets
6 | Protected against powerful water jets
7 | Protected against the effects of temporary immersion in water. Intrusion of water in quantities causing harmful effects shall not be possible when the enclosure is temporarily immersed in water for 30 min. in 1 m depth.
*) These protection classes define only protection against water!
Chemical Resistance
The Resistance relates to the Housing of the IP 67 modules and the used metal parts. In the table below you will find some typical resistance.
Character | Resistance
Steam | at temperatures >100°C: not resistant
Sodium base liquor (ph-Value > 12) | at room temperature: resistant > 40°C: not resistant
Acetic acid | not resistant
Argon (technical clean) | resistant
Key
▪
resistant: Lifetime several months
▪
non inherently resistant: Lifetime several weeks
▪
not resistant: Lifetime several hours resp. early decomposition


Accessories

Appendix [image] Accessories
Accessories
Mounting
Ordering information | Description
ZS5300-0001 | Mounting rail (500 mm x 129 mm)
Labeling material, protective caps
Ordering information | Description
ZS5000-0010 | Protective cap for M8 sockets, IP67 (50 pieces)
ZS5100-0000 | Inscription labels, unprinted, 4 strips of 10
ZS5000-xxxx | Printed inscription labels on enquiry
Cables
Ordering information | Description
ZK1090-3xxx-xxxx | EtherCAT cable M8, green link to the website
ZK1093-3xxx-xxxx | EtherCAT cable M8, yellow link to the website
ZK2000-81xx-xxxx | Sensor cable M12 8-wire Link zur Website
A complete overview of pre-assembled cables for EtherCAT Box modules can be found here.
Tools
Ordering information | Description
ZB8801-0000 | Torque wrench for plugs, 0.4…1.0 Nm
ZB8801-0001 | Torque cable key for M8 / wrench size 9 for ZB8801-0000
Further accessories
Further accessories can be found in the price list for fieldbus components from Beckhoff and online at https://www.beckhoff.com.


Version identification of EtherCAT devices

Appendix [image] Version identification of EtherCAT devices
Version identification of EtherCAT devices
Designation
A Beckhoff EtherCAT device has a 14-digit designation, made up of
▪
family key
▪
type
▪
version
▪
revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
Notes
▪
The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
▪
EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
▪
The order identifier is made up of
- family key (EL, EP, CU, ES, KL, CX, etc.)
- type (3314)
- version (-0000)
▪
The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
▪
The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Identification number
Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:
Production lot/batch number/serial number/date code/D number
The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02
Exceptions can occur in the IP67 area, where the following syntax can be used (see respective device documentation):
Syntax: D ww yy x y z u
D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB
Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1
Unique serial number/ID, ID number
In addition, in some series each individual module has its own unique serial number.
See also the further documentation in the area
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Terminals with factory calibration certificate and other measuring terminals
Examples of markings
EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
CU2016 switch with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
EP1258-00001 IP67 EtherCAT Box with batch number/ date code 22090101 and unique serial number 158102
EP1908-0002 IP67 EtherCAT Safety Box with batch number/ date code 071201FF and unique serial number 00346070
EL2904 IP20 safety terminal with batch number/ date code 50110302 and unique serial number 00331701
ELM3604-0002 terminal with unique ID number (QR code) 100001051 and serial/ batch number 44160201
Additional information
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Appendix [image] Version identification of EtherCAT devices [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com