EP5101 - EtherCAT Box with Incremental Encoder Interface

BECKHOFF Fieldbus Components

Documentation for

EP5101-0002, EP5101-0011

EtherCAT Box with Incremental Encoder Interface

Version: 1.2.0
Date: 2014-01-14

EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.


Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending

The EtherCAT Technology is covered, including but not limited to the following patent applications and patents:
EP1590927, EP1789857, DE102004044764, DE102007017835
with corresponding applications or registrations in various other countries.

The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.

Copyright

© Beckhoff Automation GmbH.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Safety rules

Consider the following safety instructions and descriptions!
Product specific safety instructions are to be found on the following pages or in the areas mounting, wiring, commissioning etc.

Disclaimer

All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH.

Personnel qualification

This description is only intended for the use of trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.

Description of symbols

The following symbols with a adjoining safety advise or notice are used in this documentation. You have to read the safety advices carefully and adhere them strictly!

DANGER 		Acute risk of injury!
If you do not adhere the safety advise adjoining this symbol, there is immediate danger to life and health of individuals!

WARNING 		Risk of injury!
If you do not adhere the safety advise adjoining this symbol, there is danger to life and health of individuals!

CAUTION 		Hazard to individuals!
If you do not adhere the safety advise adjoining this symbol, there is obvious hazard to individuals!

Attention 		Hazard to devices and environment
If you do not adhere the notice adjoining this symbol, there is obvious hazard to materials and environment.

Note 		Note or pointer
This symbol indicates information that contributes to better understanding.


EP5101 - Documentation issue status

BECKHOFF EP5101: Foreword

Documentation issue status

Version Comment
1.2.0
  • description of voltage levels (single ended and differential levels)
1.1.0
  • Description of power connection updated
  • Note about the Documentation "Notes about operation of EtherCAT Box Modules (EPxxxx-xxxx) in potentially explosive areas (ATEX)" added
1.0.0
  • first release

Firm and hardware version

The documentation refers to the firm and hardware status that was valid at the time it was prepared.

The properties of the modules are subject to continuous development and improvement. Modules having earlier production statuses cannot have the same properties as modules with the latest status. Existing properties, however, are always retained and are not changed, so that these modules can always be replaced by new ones.

Documentation Version | EP5101-0002 |  | EP5101-0011
 | Firmware | Hardware | Firmware | Hardware
1.1.0 | 01 | 04 | 01 | 04
1.0.0 | 01 | 04 | 01 | 04

The firmware and hardware version (delivery state) can be found in the batch number (D number) printed at the side of the EtherCAT Box.

Syntax of the batch number (D number)

WW YY FF HH

WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version

Example with ser. no.: 55 09 01 00:

55 - week of production 55
09 - year of production 2009
01 - firmware version 01
00 - hardware version 00


EtherCAT Box - Introduction

The EtherCAT system has been extended with EtherCAT Box modules with protection class IP 67. Through the integrated EtherCAT interface the modules can be connected directly to an EtherCAT network without an additional Coupler Box. The high-performance of EtherCAT is thus maintained into each module.

The extremely low dimensions of only 126 x 30 x 26.5 mm (H x W x D) are identical to those of the Fieldbus Box extension modules. They are thus particularly suitable for use where space is at a premium. The small mass of the EtherCAT modules facilitates applications with mobile I/O interface (e.g. on a robot arm). The EtherCAT connection is established via screened M8 connectors.

The robust design of the EtherCAT Box modules enables them to be used directly at the machine. Control cabinets and terminal boxes are now no longer required. The modules are fully sealed and therefore ideally prepared for wet, dirty or dusty conditions.

Pre-assembled cables significantly simplify EtherCAT and signal wiring. Very few wiring errors are made, so that commissioning is optimized. In addition to pre-assembled EtherCAT, power and sensor cables, field-configurable connectors and cables are available for maximum flexibility. Depending on the application, the sensors and actuators are connected through M8 or M12 connectors.

The EtherCAT modules cover the typical range of requirements for I/O signals with protection class IP 67:

  • digital inputs with different filters (3.0 ms or 10 μs)

  • digital outputs with 0.5 or 2 A output current

  • analog inputs and outputs with 16 bit resolution

  • Thermocouple and RTD inputs

  • Stepper motor modules

XFC (eXtreme Fast Control Technology) modules, including inputs with time stamp, are also available.

EtherCAT Box with M8 connections for sensors/actuators | EtherCAT Box with M12 connections for sensors/actuators

Note 		Basic EtherCAT documentation
You will find a detailed description of the EtherCAT system in the Basic System Documentation for EtherCAT, which is available for download from our website (www.beckhoff.com) under Downloads.

Note 		XML files
You will find XML files (XML Device Description Files) for Beckhoff EtherCAT modules on our website (www.beckhoff.com) under Downloads, in the Configuration Files area.


EP5101 - Introduction

Incremental Encoder Interface

The EP5101 EtherCAT Box is an interface for the direct connection of incremental encoders with differential inputs (RS485). A 32/16 bit counter with a quadrature decoder and a 32/16 bit latch for the zero pulse can be read, set or enabled. Incremental encoders with alarm outputs can be connected at the interface’s status input. Interval measurement with a resolution of up to 100 ns is possible. The gate input allows the counter to be halted. The counter state is taken over with a rising edge at the latch input.

Due to the optional interpolating microincrement function, the EP5101 can supply even more precise axis positions for dynamic axes. In addition, it supports the synchronous reading of the encoder value together with other input data in the EtherCAT system via high-precision distributed clocks (DC).

The encoder is connected via an 8-pin M12 socket (EP5101-0002) or via a 15-pin D-sub socket (EP5101-0011). In the M12 version not all signals are available.

Quick-Links

Installation

Configuration

UL Requirements for UL approved modules

ATEX - Special conditions for ATEX approved modules


EP5101 - Technical data

Technical data | EP5101-0002 | EP5101-0011
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Number of encoder inputs | 1
Encoder connection | M12 socket, 8 pin | D Sub socket, 15 pin
Encoder supply | +5 VDC, 150 mA
Counter | 32 or 16 Bit, binary
Limit frequency | 4 million increments/s (with 4-fold evaluation)
Quadrature decoder | 4-fold evaluation
Zero impulse latch | 16 Bit
Commands | read, set, enable
Distributed Clocks | yes
Module electronic supply | derived from control voltage Us
Module electronic current consumption | typically 130 mA + load
Power supply connection | Feed: 1 x M8 plug, 4-pin Onward connection: 1 x M8 socket, 4-pin
Process image | Inputs: 32 Bit Data, 8 Bit status Outputs: 16 Bit Data, 8 Bit control
Electrical isolation | Control voltage / fieldbus: 500 V
Permissible ambient temperature during operation | -25°C ... +60°C 0°C ... +55°C (according to ATEX, see special conditions) 0°C ... +55°C (according to cULus see UL Requirements)
Permissible ambient temperature during storage | -40°C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMC resistance/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable
Approvals | CE, cULus, ATEX


EP5101-0002 - Process image

The TwinCAT System Manager shows the EP5101-0002's data within a tree structure.

Under ENC Status Compact you may find the input data of the encoder interface.

Status
  • Latch C valid - new data is available at the process data "latch value". Reset by "Enable latch C"
  • Set Counter done - acknowledgement for setting of "Set counter"
  • Counter underflow - counter undercuts the lowest presentable counter value
  • Counter overflow - counter excesses the highest presentable counter value
  • Open circuit - one channel of A, B and C hat got wire breakage (adjustable per channel via CoE)
  • Extrapolation stall - micro increment value not valid (at activated micro increment evaluation -> Index 8010:0a)
  • Status of Input A - Status of Input A
  • Status of Input B - Status of Input B
  • Status of input C - Status of Input C
  • Sync error - EtherCAT error, see EtherCAT System Documentation
  • TxPDO State - see object description
  • TxPDO Toggle - see object description

Counter value - present counter value of the encoder

Latch value - counter value of the encoder at rising edge at the latch input

Under ENC Control Compact you may find the output data of the encoder interface.
Control
  • Enable latch C - Input C is enabled. At an edge "Counter value" is written to "Latch value".
  • Set counter - At a rising edge "Set Counter value" is transferred into "Counter value".

Set Counter value - preset value for "Counter value"


EP5101-0011 - Process image

EP5101-0011

The TwinCAT System Manager shows the EP5101-0011's data within a tree structure.

Under ENC Status Compact you may find the input data of the encoder interface..

Status
  • Latch C valid - new data is available at the process data "latch value". Reset by "Enable latch C"
  • Set Counter done - acknowledgement for setting of "Set counter"
  • Counter underflow - counter undercuts the lowest presentable counter value
  • Counter overflow - counter excesses the highest presentable counter value
  • Status of input status - state of the error signal (typically incoming from the encoder)
  • Open circuit - one channel of A, B and C hat got wire breakage (adjustable per channel via CoE)
  • Extrapolation stall - micro increment value not valid (at activated micro increment evaluation -> Index 8010:0a)
  • Status of Input A - Status of Input A
  • Status of Input B - Status of Input B
  • Status of input C - Status of Input C
  • Status of input gate - Status of Input Gate
  • Status of extern latch - Status of Latch Input
  • Sync error - EtherCAT error, see EtherCAT System Documentation
  • TxPDO State - see object description
  • TxPDO Toggle - see object description

Counter value - present counter value of the encoder

Latch value - counter value of the encoder at rising edge at the latch input

Under ENC Control Compact you may find the output data of the encoder interface.
Control
  • Enable latch C - Input C is enabled. At an edge "Counter value" is written to "Latch value".
  • Enable latch extern on positive edge - set trigger mode of the latch input -> positive edge
  • Set counter - At a rising edge "Set Counter value" is transferred into "Counter value".
  • Enable latch extern on negative edge - set trigger mode of the latch input -> negative edge

Set Counter value - preset value for "Counter value"


EtherCAT Box - Accessories

Fixing
Ordering information | Fixing
ZS5300-0001 | Mounting rail (500 mm x 129 mm)
Ordering information
Ordering information | Marking material
ZS5000-0000 | Fieldbus Box set M8 (contact labels, plugs)
ZS5000-0002 | Fieldbus Box set M12 (contact labels, plugs)
ZS5000-0010 | plugs M8, IP 67 (50 pieces)
ZS5000-0020 | plugs M12, IP 67 (50 pieces)
ZS5100-0000 | marking labels, not printed, 4 stripes at 10 pieces
ZS5100-xxxx | printed marking labels, on request


EtherCAT Box - Dimensions

BECKHOFF EtherCAT Box: Mounting and cabling

Dimensions

All dimensions are given in millimeters.

General

Technical data | EtherCAT Box
Housing material | PA6 (polyamide), casting compound: Polyurethane
Mounting | 2 x fastening holes for M3
Metal parts | Brass, nickel-plated
Contacts | CuZn, gold-plated
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMC resistance/emission | IEC EN 50082-2 / EN 50081-2
Permissible ambient temperature during operation | 0 ... 55°C
Permissible ambient temperature during storage | -25 ... + 85°C
Installation position | variable
Protection class | IP65/66/67 when screwed together
Dimensions (H x W x D) | approx. 126 x 30 x 26.5 mm
Approvals | CE
Weight | approx. 120 g - 200 g, depending on module type


EPxxxx - Fixing

BECKHOFF EtherCAT Box: Mounting and cabling

Fixing

Note 		Note or pointer
While mounting the modules, protect all connectors, especially the IP-Link, against contamination!

Only with connected cables or plugs the protection class IP67 is guaranteed!
Unused connectors have to be protected with the right plugs! See for plug sets in the catalogue.

Fieldbus Boxes are fastened with two M3 bolts. The bolts must be longer than 15 mm. The fixing holes are not threaded. When assembling, remember that the fieldbus connectors increases the overall height. See chapter accessories.

Mounting Rail ZS5300-0001

The mounting rail ZS5300-0001 (500 mm x 129 mm) allows the time saving assembly of Extension Box modules. The rail is made of stainless steel, 1.5 mm thick, with already premade M3 threads for the modules. The rail can be mounted at the machine with M5 screws (5.3mm slots).

The rail is 500 mm long, that way 15 modules can be mounted with a distance of 2 mm between two modules. The rail can be cut to length for the application.


EPxxxx - Nut tourque for connectors

BECKHOFF EtherCAT Box: Mounting and cabling

Nut torque for connectors

M8 connectors for sensors, actuators, power supply and EtherCAT

It is recommended to pull the M8 connectors for sensors, actuators, power supply and EtherCAT tight with a nut torque of 0.4 Nm.

M12 connectors for sensors and actuators

It is recommended to pull the M12 connectors for sensors and actuators tight with a nut torque of 0.6 Nm.


EtherCAT connection

For the incoming and ongoing EtherCAT connection,

  • the EtherCAT Box (EPxxxx) has two M8 sockets, marked in green
  • the Coupler Box (FBB-x110) has two M12 sockets
EtherCAT Box: M8 | Coupler Box: M12

Assignment

There are various different standards for the assignment and colors of connectors and cables for Ethernet/EtherCAT.

Ethernet/EtherCAT |  | Plug connector |  |  | Cable |  | Standard
Signal | Description | M8 | M12 | RJ451 | ZB9010, ZB9020, ZK1090-6292 | ZB903x, ZK1090-31xx | TIA-568B
Tx + | Transmit Data+ | Pin 1 | Pin 1 | Pin 1 | yellow2 | orange/white3 | white/orange
Tx - | Transmit Data- | Pin 4 | Pin 3 | Pin 2 | orange2 | orange3 | orange
Rx + | Receive Data+ | Pin 2 | Pin 2 | Pin 3 | white2 | blue/white3 | white/green
Rx - | Receive Data- | Pin 3 | Pin 4 | Pin 6 | blue2 | blue3 | green
Shield | Shield | Housing |  | Shroud | Screen | Screen | Screen

1) colored markings according to EN 61918 in the four-pin RJ45 connector ZS1090-0003

2) wire colors according to EN 61918

3) wire colors

EtherCAT connectors

The following connectors can be supplied for use in Beckhoff EtherCAT systems.

Designation | Plug connector | Comment
ZS1090-0003 | RJ45 | four-pin, IP20, for field assembly
ZS1090-0004 | M12 | four-pin, IP67, for field assembly
ZS1090-0005 | RJ45 | eight-pin, IP20, for field assembly, suitable for GigaBit Ethernet
ZS1090-0006 | M8 | four-pin, IP67, for field assembly


EPxxxx - Fieldbus LEDs

BECKHOFF EtherCAT Box: Installation

EtherCAT- Fieldbus LEDs

LED displays
LED | Display | Meaning
IN L/A | off | no connection to the preceding EtherCAT module
 | Lit | LINK: connection to the preceding EtherCAT module
 | flashing | ACT: Communication with the preceding EtherCAT module
OUT L/A | off | no connection to the following EtherCAT module
 | Lit | LINK: connection to the following EtherCAT module
 | flashing | ACT: Communication with the following EtherCAT module
Run | off | Status of the EtherCAT module is Init
 | flashes quickly | Status of the EtherCAT module is pre-operational
 | flashes slowly | Status of the EtherCAT module is safe-operational
 | Lit | Status of the EtherCAT module is operational

Note 		EtherCAT statuses
The various statuses in which an EtherCAT module may be found are described in the Basic System Documentation for EtherCAT, which is available for download from our website (www.beckhoff.com) under Downloads.


EtherCAT cable

For connecting EtherCAT devices only shielded Ethernet cables that meet the requirements of at least category 5 (CAt5) according to EN 50173 or ISO/IEC 11801 should be used.

Note 		Recommendations about cabling
You may get detailed recommendations about cabling EtherCAT from the documentation "Recommendations for the design of the infrastructure for EtherCAT/Ethernet", that is available for download at www.Beckhoff.com.

EtherCAT uses 4 wires for signal transfer. Due to automatic cable detection (auto-crossing) symmetric (1:1) or cross-over cables can be used between EtherCAT devices from Beckhoff.

A selection of cables for EtherCAT follows. Other cables with various lengths will be found in the full Beckhoff catalogue, and under www.beckhoff.com.

Sold by meter

Designation | Description
ZB9010 | CAT 5e, 4-core, for fixed laying, not for M8 connectors
ZB9020 | CAT 5e, 4-core, suitable for drag chain use, not for M8 connectors
ZB9030 | PVC, dmr. 4.9 mm for M8 connectors
ZB9031 | PUR, dmr. 4.8 mm for M8 connectors
ZB9032 | PUR, dmr. 5.4 mm for M8 connectors, high flexibility

Preassembled cables

ZK1090-3100-0xxx: M8 plug - open end, PUR, high flexibility, preassembled

ZK1090-3100- | 0020 | 0050
Length | 2 m | 5 m

ZK1090-3100-3xxx: M8 plug - open end, PVC, high flexibility, preassembled

ZK1090-3100- | 3020 | 3050
Length | 2 m | 5 m

ZK1090-3131-0xxx: 2 x M8 plug, PUR, high flexibility, ready-assembled

ZK1090-3131- | 0001 | 0003 | 0005 | 0010 | 0020 | 0030 | 0040 | 0050 | 0075 | 0100
Length | 0.15 m | 0.3 m | 0.5 m | 1.0 m | 2.0 m | 3.0 m | 4.0 m | 5.0 m | 7.5 m | 10 m
ZK1090-3131- | 0150 | 0200 | 0250 | 0300 | 0350 | 0400 | 0450 | 0500
Length | 15 m | 20 m | 25 m | 30 m | 35 m | 40 m | 45 m | 50 m

ZK1090-3131-3xxx: 2 x M8 plug, PVC, ready-assembled

ZK1090-3131- | 3020 | 3030 | 3040 | 3050 | 3075 | 3100 | 3150 | 3200 | 3250 | 3300
Length | 2.0 m | 3.0 m | 4.0 m | 5.0 m | 7.5 m | 10 m | 15 m | 20 m | 25 m | 30 m
ZK1090-3131- | 3350 | 3400 | 3450 | 3500
Length | 35 m | 40 m | 45 m | 50 m

ZK1090-3132-0xxx: M8 plug - M8 socket, PUR, high flexibility, ready-assembled

ZK1090-3132- | 0002 | 0004 | 0020 | 0050 | 0075 | 0100 | 0150 | 0200 | 0250 | 0300
Length | 0.2 m | 0.4 m | 2.0 m | 5.0 m | 7.5 m | 10 m | 15 m | 20 m | 25 m | 30 m
ZK1090-3132- | 0400 | 0500
Length | 40 m | 50 m

ZK1090-3132-3xxx: M8 plug - M8 socket, PVC, ready-assembled

ZK1090-3132- | 0020 | 0050 | 0100 | 0150 | 0200 | 0250 | 0300 | 0400 | 0500
Length | 2.0 m | 5.0 m | 10 m | 15 m | 20 m | 25 m | 30 m | 40 m | 50 m

ZK1090-3191-0xxx: M8 plug - RJ45 plug, PUR, high flexibility, ready-assembled

ZK1090-3191- | 0004 | 0005 | 0010 | 0020 | 0035 | 0050 | 0070 | 0100 | 0150 | 0200
Length | 0.4 m | 0.5 m | 1 m | 2 m | 3,5 m | 5 m | 7 m | 10 m | 15 m | 20 m
ZK1090-3191- | 0250
Length | 25 m

ZK1090-3191-3xxx: M8 plug - RJ45 plug, PVC, ready-assembled

ZK1090-3191- | 3005 | 3020 | 3050
Length | 0.5 m | 2 m | 5 m

ZK1090-3291-3xxx: M8 socket - RJ45 plug, PVC, ready-assembled

ZK1090-3291- | 0004 | 0005 | 0010 | 0020 | 0050 | 100 | 200 | 250
Length | 0.4 m | 0.5 m | 1 m | 2 m | 5 m | 10 m | 20 m | 25 m

ZK1090-3161-0xxx: M8 plug - M12 plug (d-coded), ready-assembled

ZK1090-3161- | 0010 | 0020 | 0050
Length | 1.0 m | 2.0 m | 5.0 m

ZK1090-6161-0xxx: 2 x M12 plug (d-coded), PVC, ready-assembled

ZK1090-6161- | 0005 | 0010 | 0020 | 0025 | 0050 | 0100
Length | 0.5 m | 1.0 m | 2.0 m | 2.5 m | 5.0 m | 10 m

ZK1090-6292-0xxx: M12 socket - RJ45 plug, ready-assembled

ZK1090-6292- | 0005 | 0020 | 0050 | 0100
Length | 0.5 m | 2 m | 5 m | 10 m

ZK1090-9191-0xxx: 2 x RJ45 plug, patch cable

ZK1090-9191- | 0001 | 0002 | 0005 | 0010 | 0020 | 0030 | 0040 | 0050 | 0100 | 0150
Length | 0.17 m | 0.26 m | 0.5 m | 1.0 m | 2.0 m | 3.0 m | 4.0 m | 5.0 m | 10 m | 15 m
ZK1090-9191- | 0200 | 0250 | 0300 | 0350 | 0400 | 0450 | 0500
Length | 20 m | 25 m | 30 m | 35 m | 40 m | 45 m | 50 m


EtherCAT Box - Power Connection

BECKHOFF EtherCAT Box: Mounting and cabling

Power Connection

The feeding and forwarding of supply voltages is done via two M8 connectors at the bottom end of the modules:

  • IN: left M8 connector for feeding the supply voltages
  • OUT: right M8 connector for forwarding the supply voltages
PIN assignment
Pin | Voltage
1 | Control voltage Us, +24 VDC
2 | Auxiliary voltage Up, +24 VDC
3 | GNDs* | *) may be connected internally to each other depending on the module: see specific module descriptions
4 | GNDp*

The pins M8 connectors carry a maximum current of 4 A.

Two LEDs display the status of the supply voltages.

Attention 		Don't confuse the power connectors with the EtherCAT connectors!
Never connect the power cables (M8, 24 VDC) with the green marked EtherCAT sockets of the EtherCAT Box Modules! This can damage the modules!

Control voltage Us: 24 VDC

Power is supplied to the fieldbus, the processor logic, the inputs and the sensors from the 24 VDC control voltage Us. The control voltage is electrically isolated from the fieldbus circuitry.

Auxiliary voltage Up 24 VDC

The Auxiliary voltage Up supplies the digital outputs; it can be brought in separately. If the load voltage is switched off, the fieldbus functions and the power supply and functionality of the inputs are retained.

Redirection of the supply voltages

The IN and OUT power connections are bridged in the module (not IP204x-Bxxx and IE204x). The supply voltages Us and Up can thus easily be transferred from EtherCAT Box to EtherCAT Box.

Attention 		Pay attention to the maximum permissible current!
Pay attention also for the redirection of the supply voltages Us and Up, the maximum permissible current for M8 connectors of 4 A must not be exceeded!

Electrical isolation

Digital modules

In the digital input/output modules, the grounds of the control voltage (GNDs) and the auxiliary voltage (GNDp) are connected to each other!

Analog modules

In the analog input/output modules the grounds of the control voltage (GNDs) and the auxiliary voltage (GNDp) are separated from each other in order to ensure electrical isolation of the analog signals from the control voltage.

In some of the analog modules the sensors or actuators are supplied by Up - this means, for instance, that in the case of 0...10 V inputs, any reference voltage (0...30 V) may be connected to Up; this is then available to the sensors (e.g. smoothed 10 V for measuring potentiometers).

Details of the power supply may be taken from the specific module descriptions.

Attention 		Electrical isolation may be cancelled!
If digital and analog fieldbus boxes are connected directly via four-core power leads, the analog signals in the fieldbus boxes are no longer electrically isolated from the control voltage!


EtherCAT Box - Status LEDs for power supply

BECKHOFF EtherCAT Box: Mounting and cabling

Status LEDs for power supply

LED | Display | Meaning
Us (Control voltage) | off | The power supply voltage Us is not present
 | green illuminated | The power supply voltage Us is present
 | reed illuminated | Because of overload (current > 0.5 A) the sensor supply generated from power supply voltage Us was switched off for all sensors fed from this.
Up (Auxiliary voltage) | off | The power supply voltage Up is not present
 | green illuminated | The power supply voltage Up is present


Power cables

Ordering data

Order designation | Power lead | Screw-in connector | Contacts | Cross- section | Length
ZK2020-3200-0020 | Straight socket, open end | M8 | 4-pin | 0.34 mm2 | 2.00 m
ZK2020-3200-0050 |  |  |  |  | 5.00 m
ZK2020-3200-0100 |  |  |  |  | 10.00 m
ZK2020-3400-0020 | Angled socket, open end |  |  |  | 2.00 m
ZK2020-3400-0050 |  |  |  |  | 5.00 m
ZK2020-3400-0100 |  |  |  |  | 10.00 m
ZK2020-3132-0001 | Straight socket, straight socket |  |  |  | 0.15 m
ZK2020-3132-0005 |  |  |  |  | 0.50 m
ZK2020-3132-0010 |  |  |  |  | 1.00 m
ZK2020-3132-0020 |  |  |  |  | 2.00 m
ZK2020-3132-0050 |  |  |  |  | 5.00 m
ZK2020-3334-0001 | Angled socket, angled socket |  |  |  | 0.15 m
ZK2020-3334-0005 |  |  |  |  | 0.50 m
ZK2020-3334-0010 |  |  |  |  | 1.00 m
ZK2020-3334-0020 |  |  |  |  | 2.00 m
ZK2020-3334-0050 |  |  |  |  | 5.00 m

Further available power cables may be found in the Beckhoff catalog or on our internet pages (http://www.beckhoff.com).

Technical data

Technical data
Rated voltage according to IEC60 664-1 | 60 VAC / 75 VDC
Contamination level according to IEC 60 664-1 | 3/2
Insulation resistance IEC 60 512-2 | >109 W
Current carrying capacity according to IEC 60512-3 | 4 A
Volume resistance according to IEC 60512-2 | < 5 mW
Protection class according to IEC 60529 | IP65/66/67, when screwed together
Ambient temperature | -30°C to +80°C


ZK2020 - Power cable conductor losses

BECKHOFF Fieldbus Components: Mounting and cabeling

Power cable conductor losses

The ZK2020-xxxx-yyyy power cables should not exceed the total length of 15 m at 4 A (with continuation). When planning the cabling, note that at 24 V nominal voltage, the functionality of the module can no longer be assured if the voltage drop reaches 6 V. Variations in the output voltage from the power supply unit must also be taken into account.

Example

8 m power cable with 0.34 mm² cross-section has a voltage drop of 3.2 V at 4 A.


EtherCAT Box - UL Requirements

BECKHOFF EtherCAT Box: Mounting and cabling

UL Requirements

The installation of the EtherCAT Box Modules certified by UL has to meet the following requirements.

Supply voltage

CAUTION 		CAUTION!
For the compliance of the UL requirements the EtherCAT Box Modules should only be supplied
  • by a 24 VDC supply voltage, supplied by an isolating source and protected by means of a fuse (in accordance with UL248), rated maximum 4 Amp, or
  • by a 24 VDC power source, that has to satisfy NEC class 2.
    A NEC class 2 power supply shall not be connected in series or parallel with another (class 2) power source!
This UL requirements are valid for all supply voltages of all marked EtherCAT Box Modules!

CAUTION 		CAUTION!
To meet the UL requirements, the EtherCAT Box Modules must not be connected to unlimited power sources!

Networks

CAUTION 		CAUTION!
To meet the UL requirements, EtherCAT Box Modules must not be connected to telecommunication networks!

Ambient temperature range

CAUTION 		CAUTION!
To meet the UL requirements, EtherCAT Box Modules has to be operated only at an ambient temperature range of 0 to 55°C!

Marking for UL

All EtherCAT Box Modules certified by UL (Underwriters Laboratories) are marked with the following label.


EtherCAT Box - ATEX - Special conditions

BECKHOFF EtherCAT Box: Monting and wiring

ATEX - Special conditions

WARNING 		Observe the special conditions for the intended use of
EtherCAT Box modules in potentially explosive areas – directive 94/9/EU.
  • The certified components are to be installed in the BG2000-0000 protection enclosure that guarantees a protection against mechanical hazards!
  • If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
  • Observe the permissible ambient temperature range of 0 - 55°C for the use of EtherCAT Box modules in potentially explosive areas!
  • Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
  • The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!

Standards

The fundamental health and safety requirements are fulfilled by compliance with the following standards:

  • EN 60079-0: 2006
  • EN 60079-15: 2005

Marking

The EtherCAT Box modules certified for potentially explosive areas bear one of the following markings:

II 3 G Ex nA II T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C

or

II 3 G Ex nA nC IIC T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C

Batch number (D number)

The EtherCAT Box modules bear a batch number (D number) that is structured as follows:

D: WW YY FF HH

WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version

Example with D No. 29 10 02 01:

29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01


BG2000-0000 - Protective housing for EtherCAT Box

BECKHOFF BG2000-0000: Monting and wiring

BG2000-0000 - EtherCAT Box protection enclosure

WARNING 		Risk of electric shock and damage of device!
Bring the EtherCAT system into a safe, powered down state before starting installation, disassembly or wiring of the modules!

ATEX

The BG2000-0000 protection enclosure has to be mounted over a single EtherCAT Box to fulfill the special conditions according to ATEX.

Installation

  1. Put the wires for EtherCAT, power supply and sensors/actuators through the hole of the BG2000-0000 protection enclosure
  2. Fix the wires for EtherCAT, power supply and sensors/actuators to the EtherCAT Box
  3. Mount the BG2000-0000 protection enclosure over the EtherCAT Box


EtherCAT Box - ATEX Documentation

BECKHOFF EtherCAT Box: Mounting and Cabling

ATEX Documentation

Note 		Notes about operation of EtherCAT Box Modules (EPxxxx-xxxx) in potentially explosive areas (ATEX)
Pay also attention to the continuative documentation

Notes about operation of EtherCAT Box Modules (EPxxxx-xxxx) in potentially explosive areas (ATEX)

that is available in the download area of the Beckhoff homepage http:\\www.beckhoff.com!


Encoder connection, M12 Socket, 8-pin

Meaning of the LED

LED A - Input A / Track A

LED B - Input B / Track B

LED C - Input C / Track C


Encoder connection, D Sub Socket, 15-pin

BECKHOFF EtherCAT Box: Cabeling

Encoder connection, D-Sub socket, 15-pin

Meaning of the LED

LED A - Input A / Track A

LED B - Input B / Track B

LED C - Input C / Track C

LED L - Input Latch

LED G - Input Gate

LED E - Input Error


EP5101 - Status LEDs

Status LEDs at the M12 connectors
Connector | LED | Display | Meaning
M12 socket No. 1-4 | R left | off | no data transmission to D/A converter
 |  | green | data transmission to D/A converter
 | E right | off | correct operation
 |  | rot | Error: wire breakage or measured value out of range
EP5101-0002: Status LEDs at the M12connector
Connector | LED | Display | Meaning
M12 | A | off | Input A / Track A low
 |  | green | Input A / Track A High
 | B | off | Input B / Track B low
 |  | green | Input B / Track B high
 | C | off | Input C / Track C low
 |  | green | Input C / Track C high
EP5101-0011: Status LEDs at the D-Sub connector
Connector | LED | Display | Meaning
D-Sub | A | off | Input A / Track A low
 |  | green | Input A / Track A High
 | B | off | Input B / Track B low
 |  | green | Input B / Track B high
 | C | off | Input C / Track C low
 |  | green | Input C / Track C high
 | L | off | Input Latch low
 |  | green | Input Latch High
 | G | off | Input Gate low
 |  | green | Input Gate high
 | E | off | Input Error low
 |  | green | Input Error high


EtherCAT Box - Inserting into the EtherCAT network

BECKHOFF EtherCAT Box: Commissioning/Configuration

Inserting into the EtherCAT network

Note 		Installation of the latest XML device description
Please ensure that you have installed the latest XML device description in TwinCAT. This can be downloaded from the Beckhoff website (http://www.beckhoff.de/english/default.htm?download/elconfg.htm) and installed according to the installation instructions.

At the Beckhoff TwinCAT System Manager the configuration tree can be build in two different ways:

  • by scanning for existing hardware (called "online") and
  • by manual inserting/appending of fieldbus devices, couplers and slaves.

Automatic scanning in of the box

  • The EtherCAT system must be in a safe, de-energized state before the EtherCAT modules are connected to the EtherCAT network!
  • Switch on the operating voltage, open the TwinCAT System Manager (Config mode), and scan in the devices (see Fig. 1). Acknowledge all dialogs with "OK", so that the configuration is in "FreeRun" mode.

Fig. 1: Scanning in the EtherCAT configuration (I/O Devices-> right-click -> Scan Devices...

Appending a module manually

  • The EtherCAT system must be in a safe, de-energized state before the EtherCAT modules are connected to the EtherCAT network!
  • Switch on the operating voltage, open the TwinCAT System Manager (Config mode)
  • Append a new I/O device (see Fig. 2). In the dialog that appears select the device EtherCAT (Direct Mode), see Fig. 3 and confirm with OK.

Fig. 2: Appending a new I/O device (I/O Devices-> right-click -> Append Device... )

Fig. 3: Selecting the device EtherCAT

  • Append a new box (see Fig. 4).

Fig. 4: Appending a new box (Device -> right-click -> Append Box... )

  • In the dialog that appears select the desired box, and confirm with OK.

Fig. 5: Selecting a Box

Fig. 6: Appended Box in the TwinCAT tree


EPxxxx - Configuration via TwinCAT System Manager

BECKHOFF EtherCAT Box: Configuration

Configuration via TwinCAT System Manager

In the left-hand window of the TwinCAT System Manager, click on the branch of the EtherCAT Box you wish to configure.

In the right-hand window of the TwinCAT System manager, various tabs are now available for configuring the EtherCAT Box.

General tab

Name | Name of the EtherCAT device
Id | Number of the EtherCAT device
Type | EtherCAT device type
Comment | Here you can add a comment (e.g. regarding the system).
Disabled | Here you can deactivate the EtherCAT device.
Create symbols | Access to this EtherCAT slave via ADS is only available if this control box is activated.

EtherCAT tab

Type | EtherCAT device type
Product/Revision | Product and revision number of the EtherCAT device
Auto Inc Addr. | Auto increment address of the EtherCAT device. The auto increment address can be used for addressing each EtherCAT device in the communication ring through its physical position. Auto increment addressing is used during the start-up phase when the EtherCAT master allocates addresses to the EtherCAT devices. With auto increment addressing the first EtherCAT slave in the ring has the address 0000hex. For each further slave the address is decremented by 1 (FFFFhex, FFFEhex etc.).
EtherCAT Addr. | Fixed address of an EtherCAT slave. This address is allocated by the EtherCAT master during the start-up phase. Tick the control box to the left of the input field in order to modify the default value.
Previous Port | Name and port of the EtherCAT device to which this device is connected. If it is possible to connect this device with another one without changing the order of the EtherCAT devices in the communication ring, then this combination field is activated and the EtherCAT device to which this device is to be connected can be selected.
Advanced Settings | This button opens the dialogs for advanced settings.

The link at the bottom of the tab points to the product page for this EtherCAT device on the web.

Process Data tab

Indicates the configuration of the process data. The input and output data of the EtherCAT slave are represented as CANopen process data objects (PDO). The user can select a PDO via PDO assignment and modify the content of the individual PDO via this dialog, if the EtherCAT slave supports this function.

Sync Manager

Lists the configuration of the Sync Manager (SM).
If the EtherCAT device has a mailbox, SM0 is used for the mailbox output (MbxOut) and SM1 for the mailbox input (MbxIn).
SM2 is used for the output process data (outputs) and SM3 (inputs) for the input process data.

If an input is selected, the corresponding PDO assignment is displayed in the PDO Assignment list below.

PDO Assignment

PDO assignment of the selected Sync Manager. All PDOs defined for this Sync Manager type are listed here:

  • If the output Sync Manager (outputs) is selected in the Sync Manager list, all RxPDOs are displayed.
  • If the input Sync Manager (inputs) is selected in the Sync Manager list, all TxPDOs are displayed.

The selected entries are the PDOs involved in the process data transfer. In the tree diagram of the System Manager these PDOs are displayed as variables of the EtherCAT device. The name of the variable is identical to the Name parameter of the PDO, as displayed in the PDO list. If an entry in the PDO assignment list is deactivated (not selected and greyed out), this indicates that the input is excluded from the PDO assignment. In order to be able do select a greyed out PDO, the currently selected PDO has to be deselected first.

Note 		Activation of PDO assignment
If you have changed the PDO assignment, in order to activate the new PDO assignment,
  • the EtherCAT slave has to run through the PS status transition cycle (from pre-operational to safe-operational) once (see Online tab),
  • and the System Manager has to reload the EtherCAT slaves ( [image] button)

PDO list

List of all PDOs supported by this EtherCAT device. The content of the selected PDOs is displayed in the PDO Content list. The PDO configuration can be modified by double-clicking on an entry.

Column | Description
Index | PDO index.
Size | Size of the PDO in bytes.
Name | Name of the PDO. If this PDO is assigned to a Sync Manager, it appears as a variable of the slave with this parameter as the name.
Flags | F | Fixed content: The content of this PDO is fixed and cannot be changed by the System Manager.
 | M | Mandatory PDO. This PDO is mandatory and must therefore be assigned to a Sync Manager! Consequently, this PDO cannot be deleted from the PDO Assignment list
SM | Sync Manager to which this PDO is assigned. If this entry is empty, this PDO does not take part in the process data traffic.
SU | Sync unit to which this PDO is assigned.

PDO Content

Indicates the content of the PDO. If flag F (fixed content) of the PDO is not set the content can be modified.

Download

If the device is intelligent and has a mailbox, the configuration of the PDO and the PDO assignments can be downloaded to the device. This is an optional feature that is not supported by all EtherCAT slaves.

PDO Assignment

If this check box is selected, the PDO assignment that is configured in the PDO Assignment list is downloaded to the device on startup. The required commands to be sent to the device can be viewed in the Startup tab.

PDO Configuration

If this check box is selected, the configuration of the respective PDOs (as shown in the PDO list and the PDO Content display) is downloaded to the EtherCAT slave.

Startup tab

The Startup tab is displayed if the EtherCAT slave has a mailbox and supports the CANopen over EtherCAT (CoE) or Servo drive over EtherCAT protocol. This tab indicates which download requests are sent to the mailbox during startup. It is also possible to add new mailbox requests to the list display. The download requests are sent to the slave in the same order as they are shown in the list.

Column | Description
Transition Transition to which the request is sent. This can either be
  • the transition from pre-operational to safe-operational (PS), or
  • the transition from safe-operational to operational (SO).

If the transition is enclosed in "<>" (e.g. <PS>), the mailbox request is fixed and cannot be modified or deleted by the user.
Protocol | Type of mailbox protocol
Index | Index of the object
Data | Date on which this object is to be downloaded.
Comment | Description of the request to be sent to the mailbox
Move Up | This button moves the selected request up by one position in the list.
Move Down | This button moves the selected request down by one position in the list.
New | This button adds a new mailbox download request to be sent during startup.
Delete | This button deletes the selected entry.
Edit | This button edits an existing request.

CoE - Online tab

The additional CoE - Online tab is displayed if the EtherCAT slave supports the CANopen over EtherCAT (CoE) protocol. This dialog lists the content of the object list of the slave (SDO upload) and enables the user to modify the content of an object from this list. Details for the objects of the individual EtherCAT devices can be found in the device-specific object descriptions.

Object list display
Column | Description
Index | Index and sub-index of the object
Name | Name of the object
Flags | RW | The object can be read, and data can be written to the object (read/write)
 | RO | The object can be read, but no data can be written to the object (read only)
 | P | An additional P identifies the object as a process data object.
Value | Value of the object
Update List | The Update list button updates all objects in the displayed list
Auto Update | If this check box is selected, the content of the objects is updated automatically.
Advanced | The Advanced button opens the Advanced Settings dialog. Here you can specify which objects are displayed in the list.

Online - via SDO Information | If this option button is selected, the list of the objects included in the object list of the slave is uploaded from the slave via SDO information. The list below can be used to specify which object types are to be uploaded.
Offline - via EDS File | If this option button is selected, the list of the objects included in the object list is read from an EDS file provided by the user.

Online tab

State Machine

Init | This button attempts to set the EtherCAT device to the Init state.
Pre-Op | This button attempts to set the EtherCAT device to the pre-operational state.
Op | This button attempts to set the EtherCAT device to the operational state.
Bootstrap | This button attempts to set the EtherCAT device to the Bootstrap state.
Safe-Op | This button attempts to set the EtherCAT device to the safe-operational state.
Clear Error | This button attempts to delete the fault display. If an EtherCAT slave fails during change of state it sets an error flag. Example: An EtherCAT slave is in PREOP state (pre-operational). The master now requests the SAFEOP state (safe-operational). If the slave fails during change of state it sets the error flag. The current state is now displayed as ERR PREOP. When the Clear Error button is pressed the error flag is cleared, and the current state is displayed as PREOP again.
Current State | Indicates the current state of the EtherCAT device.
Requested State | Indicates the state requested for the EtherCAT device.

DLL Status

Indicates the DLL status (data link layer status) of the individual ports of the EtherCAT slave. The DLL status can have four different states:

Status | Description
No Carrier / Open | No carrier signal is available at the port, but the port is open.
No Carrier / Closed | No carrier signal is available at the port, and the port is closed.
Carrier / Open | A carrier signal is available at the port, and the port is open.
Carrier / Closed | A carrier signal is available at the port, but the port is closed.

File Access over EtherCAT

Download | With this button a file can be written to the EtherCAT device.
Upload | With this button a file can be read from the EtherCAT device.


EP5101 - Basic function principles

BECKHOFF EP5101: Commissioning and Configuration

Basic function principles

The EP5101's incremental encoder interface enables connection of incremental encoders with A/B/C track to EtherCAT. A 16-bit counter (in normal operating mode) or a switchable 16/32-bit counter (in enhanced operating mode) with quadrature decoder and a 16-bit latch (in normal operating mode) or 32-bit latch (in enhanced operating mode) can read, set or activated. Differential signals according to RS485 are intended for encoder connection.

In addition to the encoder inputs A, B and C, an additional latch input G1 (24 V) and a gate input G2 (24 V) for locking the counter during operation are available.

The box is supplied as a 4-fold quadrature decoder with complementary analysis of the sensor signals A, B, C. If the incremental encoder has an alarm output it can be connected to the ERROR input of the EP5101. The EL5101-0000 can optionally be operated as a counter module on channel A.

Note 		Monitoring of process data
It is recommended to monitor the process data within each cycle:
  • WcState: if ≠ 0, this EtherCAT device does not take part at process data exchange
  • State: if ≠ 8, this EtherCAT device is not in OP (Operational) state
  • TxPDO State, SyncError: if ≠ 0, no valid process data is available, e.g. caused by wire breakage
  • TxPDO Toggle: if this bit toggles a new set of process data is available

EtherCAT Cycle Time

For the EP5101 a minimum cycle time of 100 µs is recommended. If a faster cycle time is needed, you have to monitor via the toggling process date TxPDO Toggle, when the EP5101 delivers new process data.

Input Impedance EP5101

The signal source must be able to drive the EP5101's input Impedance (typically 220 W, subject to modifications) with adequate voltage levels according to RS485 specification.

Gate / Latch Input

For gate and latch input (24 V) a maximum input frequency of 1 MHz is permitted (subject to modifications).


EP5101 - Parameters and modes

BECKHOFF EP5101: Commissioning and Configuration

Parameters and modes

16 or 32 bit process data

The EP5101 can be operated with 16 Bit process data (default) and also with 32 Bit process data.

This setting can be done via Predefined PDO Assignment at the Process Data tab.

DC (Distributed Clocks)

Describes whether the terminal is operated with distributed clocks support:

  • FreeRun: the module operates frame-triggered. Cyclic operation is started via the SyncManagers of the EtherCAT frame processing.
  • DC-Synchron: Cyclic operation in the module is started by the local distributed clock at exact intervals. The start time is chosen such that it coincides with other output slaves in the EtherCAT system.
  • DC-Synchron (input based): As DC Synchron mode, with the cyclic start time chosen such that it coincides with other input slaves in the EtherCAT system.

Main PDO

Selection of basic process data

A: Selection of data direction: input or output
B: Selection of (optional) PDOs (process data objects)
C: Explanatory notes for PDOs

  • compact: The process data can be represented with 16 bits (compact) or with 32 bits.

Optional PDOs

Optional PDOs, in addition to the main PDO:

  • PDO 1 (1A02 or 1A03): The frequency or the period can be selected as optional PDO 1
  • PDO 2 (1A04 or 1A05): In one of the DC modes a 32-bit or 64-bit timestamp can be selected. The timestamp specifies the time of the last registered increment edge, based on the DistributedClocks system.

Features CoE

Depending on the main PDO/optional PDOs further settings can be selected in the CoE list (CAN over EtherCAT.

Note 		Parameterization via the CoE list (CAN over EtherCAT)
Please note the following general CoE information when using/manipulating the CoE parameters:
  • Maintain startup list in case components have to be replaced
  • Differentiation between online/offline dictionary, existence of current XML description
  • CoE reload for resetting changes

The following CoE settings from object 8000 are possible and are shown below in their default settings:

The parameters are described on page object description.

Because of the different pin assignment not all objects are supported by EP5101-0002.

Further notes

Frequency

  • The time window for the frequency calculation and the resolution can be parameterized in CoE objects 8000:11, 8000:13, 8000:15 and 8000:17.
  • The positive edges for track A within the specified time window and the next edge including the time until then are counted. The waiting time for the edge can be set in CoE object 8000:17 "Frequency Wait Time" (unit: ms). The default value is 1.6 sec. This is also the maximum value.
  • The time window is 10 ms (default), min. 1 µs. The measuring of frequencies up to 800 kHz is possible with the default setting, for higher frequencies you have to set a smaller time window.
  • The time is measured with a resolution of 100 ns.
  • This calculation is carried out in the slave without reference to the distributed clocks system. It is therefore independent of the DC mode.
  • No frequency measurement is possible if the counter is blocked by the gate. In this case the period can be measured regardless.
  • A C or external reset restarts the frequency measurement. The last frequency value remains unchanged until a new frequency value is determined
Frequency measuring
  • Basic unit 1 µs: all window sizes

Measurement sequence

  • The measurement starts with a rising edge at track A. The current counter value and time (resolution: 100 ns) are stored.
  • After the measuring window time has elapsed (index 8000:11), the system waits for the following rising edge at track A or a maximum of 1.6 sec or the time from 8000:17
  • The frequency is calculated from the edge difference and the actual elapsed time.

Fig.: Frequency measurement principle in enhanced operation mode

Period calculation

  • This calculation is carried out in the slave without reference to the distributed clocks system. It is therefore independent of the DC mode.
  • During each cycle the interval between 2 positive edges of input A is counted.
  • If no edge change occurs for approx. 1.6 s, any period specification is cancelled.

Latch

Activation of latch C input (C) and saving (latching) of the counter value (index 7000:01)
  • The counter value is saved at the first external latch pulse (positive edge at input "C") after the bit has been set ("TRUE") in index 7000:01 (has priority before 7000:02 / 7000:04). The subsequent pulses at the other inputs have no influence on the latch value in index 6000:12 if the bit is set.
  • Note for "Latch C valid" bit: A new counter value at the latch input can only be written once the value of the “Latch C valid” bit (index 6000:01) is ‘FALSE’.
Activation of the external latch input ("gate/latch") and latching of the counter value (index 7000:02, 7000:04)
  • The counter value at the latch input (Index 6000:12) will be saved upon the first external latch pulse with a rising edge if the bit (“TRUE”) is set in index 7000:02. The subsequent pulses have no influence on the latch value in index 6000:12.
  • The counter value at the latch input (Index 6000:12) will be saved upon the first external latch pulse with a falling edge if the bit (“TRUE”) is set in index 7000:04. The subsequent pulses have no influence on the latch value in index 6000:12.
  • Note for "Latch extern valid" bit: A new counter value at the latch input can only be written once the value of the “Latch extern valid” bit (index 6000:02) is “FALSE”.

Reset

  • Counter reset (index 8000:01, 8000:02, 8000:10): For a counter reset via input C set the bit in index 8000:01, for a reset via the external latch input set the bit in index 8000:02.
  • The functions "Enable C reset" (8000:01) and "Enable extern reset" (8000:02) cannot be activated simultaneously.
  • Note for "Extern reset polarity", index 8000:10: The edge for setting the counter to zero can be selected via index 8000:10.
    Bit not set: counter is set to zero with falling edge.
    Bit set: counter is set to zero with rising edge.

Up/down counter

  • The mode (encoder or up/down counter) is set via the CoE objects (profile-specific objects, tab CoE - Online, index 8000:03 "Non-volatile settings"). Click on the corresponding row of the index to be parameterized, enter 1 in the SetValue dialog and confirm with OK.
  • Set the gate polarity accordingly via object 8000:04.
  • An additional option for reversing the rotation direction is available by setting the bit in index 8000:0E.

Over-/Underflow

  • Overflow/underflow control is inactive in combination with an activated reset function (C/external).
  • The underflow bit (6000:04) is set if an underflow ...00 ®...FF occurs. It is reset if 2/3 of the counter range are underrun.
  • The overflow bit (6000:05) is set if an overflow FF...® 00... occurs. It is reset if 1/3 of the counter range is exceeded.

Open circuit detection

  • Open-circuit detection can be activated separately for channels A, B and C (index 8000:0B, 8000:0C, 8000:0D).
  • Open-circuit detection is activated for channels A and B by default.
  • A differential voltage of < 3.5 V (typical, subject to modification) is interpreted as an open circuit.
  • If an open circuit is detected, it is indicated as process data open circuit = TRUE. The bit in object 6000:07 is set. Open circuit is indicated separately in indices A000:01 (track A), A000:02 (track B) and A000:03 (track C).
  • TxPDO state also becomes TRUE if an open circuit is detected, since invalid data have to be assumed.

Micro increments

  • Works with and without distributed clocks, but in the EL5101 this is only meaningful in conjunction with one of the DC modes
  • By setting the counter value only the integer component can be modified.
  • The Frequency measurement principle in enhanced operation mode:

The highly constant query cycles (accuracy: 100 ns) of the distributed clocks systems enable the EL5101 to interpolate axis positions between the counted encoder increments from a certain speed. The interpolation resolution is 8 bit, corresponding to 256 values. A standard encoder with 1,024 bars with 4-way evaluation and micro-increments thus becomes a high-resolution axis encoder with

4096 x 256 = 1,048,567 bars.

Underrunning of the minimum velocity is indicated by the object 6000:08 (extrapolation stall) in the process data.


EP5101 - signal level

Voltage level of the interface

The EP5101 expects voltage levels acc. to RS485.

Differential signal level

Abb.: voltage level for differential mode

Single ended mode

Additionally the EP5101 will accept single ended signals. Error bit of the status will be set, though.

This mode should therefore only be used after careful examination.

Abb.: voltage level for single ended mode

For single ended mode, a voltage of HIGH = +5V is expected.


EP5101 - Object overview

BECKHOFF EP5101: Configuration

Object Overview

Note 		EtherCAT XML Device Description
The description correspond to the display of the CoE objects from the EtherCAT XML Device Description. It is strongly recommended to download the latest revision of the corresponding XML file from the Beckhoff website (http://www.beckhoff.com/english/default.htm?download/elconfg.htm) and follow the installation instructions.
Index |  | Name | Flags | Default value
1000 |  | Device type | RO | 0x01FF1389 (33493897dez)
1008 |  | Device name | RO | EP5101-0011
1009 |  | Hardware version | RO | 00
100A |  | Software version | RO | 01
1011:0 | Subindex | Restore default parameters | RO | 0x01 (1dez)
 | 1011:01 | SubIndex 001 | RW | 0x00000000 (0dez)
1018:0 | Subindex | Identity | RO | 0x04 (4dez)
 | 1018:01 | Vendor ID | RO | 0x00000002 (2dez)
 | 1018:02 | Product code | RO | 0x13ED4052 (334315602dez)
 | 1018:03 | Revision | RO | 0x0010000B (1048587dez)
 | 1018:04 | Serial number | RO | 0x00000000 (0dez)
10F0:0 | Subindex | Backup parameter handling | RO | 0x01 (1dez)
 | 10F0:01 | Checksum | RO | 0x00000000 (0dez)
1400:0 | Subindex | ENC RxPDO-Par Control compact | RO | 0x06 (6dez)
 | 1400:06 | Exclude RxPDOs | RO | 01 16
1401:0 | Subindex | ENC RxPDO-Par Control | RO | 0x06 (6dez)
 | 1401:06 | Exclude RxPDOs | RO | 00 16
1600:0 | Subindex | ENC RxPDO-Map Control compact | RO | 0x07 (7dez)
 | 1600:01 | SubIndex 001 | RO | 0x7000:01, 1
 | 1600:02 | SubIndex 002 | RO | 0x7000:02, 1
 | 1600:03 | SubIndex 003 | RO | 0x7000:03, 1
 | 1600:04 | SubIndex 004 | RO | 0x7000:04, 1
 | 1600:05 | SubIndex 005 | RO | 0x0000:00, 4
 | 1600:06 | SubIndex 006 | RO | 0x0000:00, 8
 | 1600:07 | SubIndex 007 | RO | 0x7000:11, 16
1601:0 | Subindex | ENC RxPDO-Map Control | RO | 0x07 (7dez)
 | 1601:01 | SubIndex 001 | RO | 0x7000:01, 1
 | 1601:02 | SubIndex 002 | RO | 0x7000:02, 1
 | 1601:03 | SubIndex 003 | RO | 0x7000:03, 1
 | 1601:04 | SubIndex 004 | RO | 0x7000:04, 1
 | 1601:05 | SubIndex 005 | RO | 0x0000:00, 4
 | 1601:06 | SubIndex 006 | RO | 0x0000:00, 8
 | 1601:07 | SubIndex 007 | RO | 0x7000:11, 32
1800:0 | Subindex | ENC TxPDO-Par Status compact | RO | 0x09 (9dez)
 | 1800:06 | Exclude TxPDOs | RO | 01 1A
 | 1800:07 | TxPDO State | RO | 0x00 (0dez)
 | 1800:09 | TxPDO Toggle | RO | 0x00 (0dez)
1801:0 | Subindex | ENC TxPDO-Par Status | RO | 0x09 (9dez)
 | 1801:06 | Exclude TxPDOs | RO | 00 1A
 | 1801:07 | TxPDO State | RO | 0x00 (0dez)
 | 1801:09 | TxPDO Toggle | RO | 0x00 (0dez)
1802:0 | Subindex | ENC TxPDO-Par Frequency | RO | 0x06 (6dez)
 | 1802:06 | Exclude TxPDOs | RO | 03 1A
1803:0 | Subindex | ENC TxPDO-Par Period | RO | 0x06 (6dez)
 | 1803:06 | Exclude TxPDOs | RO | 02 1A
1804:0 | Subindex | ENC TxPDO-Par Timest. | RO | 0x06 (6dez)
 | 1804:06 | Exclude TxPDOs | RO | 05 1A
1805:0 | Subindex | ENC TxPDO-Par Timest. compact | RO | 0x06 (6dez)
 | 1805:06 | Exclude TxPDOs | RO | 04 1A
1A00:0 | Subindex | ENC TxPDO-Map Status compact | RO | 0x12 (18dez)
 | 1A00:01 | SubIndex 001 | RO | 0x6000:01, 1
 | 1A00:02 | SubIndex 002 | RO | 0x6000:02, 1
 | 1A00:03 | SubIndex 003 | RO | 0x6000:03, 1
 | 1A00:04 | SubIndex 004 | RO | 0x6000:04, 1
 | 1A00:05 | SubIndex 005 | RO | 0x6000:05, 1
 | 1A00:06 | SubIndex 006 | RO | 0x6000:06, 1
 | 1A00:07 | SubIndex 007 | RO | 0x6000:07, 1
 | 1A00:08 | SubIndex 008 | RO | 0x6000:08, 1
 | 1A00:09 | SubIndex 009 | RO | 0x6000:09, 1
 | 1A00:0A | SubIndex 010 | RO | 0x6000:0A, 1
 | 1A00:0B | SubIndex 011 | RO | 0x6000:0B, 1
 | 1A00:0C | SubIndex 012 | RO | 0x6000:0C, 1
 | 1A00:0D | SubIndex 013 | RO | 0x6000:0D, 1
 | 1A00:0E | SubIndex 014 | RO | 0x1C32:20, 1
 | 1A00:0F | SubIndex 015 | RO | 0x1800:07, 1
 | 1A00:10 | SubIndex 016 | RO | 0x1800:09, 1
 | 1A00:11 | SubIndex 017 | RO | 0x6000:11, 16
 | 1A00:12 | SubIndex 018 | RO | 0x6000:12, 16
1A01:0 | Subindex | ENC TxPDO-Map Status | RO | 0x12 (18dez)
 | 1A01:01 | SubIndex 001 | RO | 0x6000:01, 1
 | 1A01:02 | SubIndex 002 | RO | 0x6000:02, 1
 | 1A01:03 | SubIndex 003 | RO | 0x6000:03, 1
 | 1A01:04 | SubIndex 004 | RO | 0x6000:04, 1
 | 1A01:05 | SubIndex 005 | RO | 0x6000:05, 1
 | 1A01:06 | SubIndex 006 | RO | 0x6000:06, 1
 | 1A01:07 | SubIndex 007 | RO | 0x6000:07, 1
 | 1A01:08 | SubIndex 008 | RO | 0x6000:08, 1
 | 1A01:09 | SubIndex 009 | RO | 0x6000:09, 1
 | 1A01:0A | SubIndex 010 | RO | 0x6000:0A, 1
 | 1A01:0B | SubIndex 011 | RO | 0x6000:0B, 1
 | 1A01:0C | SubIndex 012 | RO | 0x6000:0C, 1
 | 1A01:0D | SubIndex 013 | RO | 0x6000:0D, 1
 | 1A01:0E | SubIndex 014 | RO | 0x1C32:20, 1
 | 1A01:0F | SubIndex 015 | RO | 0x1801:07, 1
 | 1A01:10 | SubIndex 016 | RO | 0x1801:09, 1
 | 1A01:11 | SubIndex 017 | RO | 0x6000:11, 32
 | 1A01:12 | SubIndex 018 | RO | 0x6000:12, 32
1A02:0 | Subindex | ENC TxPDO-Map Frequency | RO | 0x01 (1dez)
 | 1A02:01 | SubIndex 001 | RO | 0x6000:13, 32
1A03:0 | Subindex | ENC TxPDO-Map Period | RO | 0x01 (1dez)
 | 1A03:01 | SubIndex 001 | RO | 0x6000:14, 32
1A04:0 | Subindex | ENC TxPDO-Map Timest. | RO | 0x01 (1dez)
 | 1A04:01 | SubIndex 001 | RO | 0x6000:16, 64
1A05:0 | Subindex | ENC TxPDO-Map Timest. compact | RO | 0x01 (1dez)
 | 1A05:01 | SubIndex 001 | RO | 0x6000:16, 32
1C00:0 | Subindex | Sync manager type | RO | 0x04 (4dez)
 | 1C00:01 | SubIndex 001 | RO | 0x01 (1dez)
 | 1C00:02 | SubIndex 002 | RO | 0x02 (2dez)
 | 1C00:03 | SubIndex 003 | RO | 0x03 (3dez)
 | 1C00:04 | SubIndex 004 | RO | 0x04 (4dez)
1C12:0 | Subindex | RxPDO assign | RW | 0x01 (1dez)
 | 1C12:01 | SubIndex 001 | RW | 0x1600 (5632dez)
1C13:0 | Subindex | TxPDO assign | RW | 0x01 (1dez)
 | 1C13:01 | SubIndex 001 | RW | 0x1A00 (6656dez)
 | 1C13:02 | SubIndex 002 | RW | 0x0000 (0dez)
 | 1C13:03 | SubIndex 003 | RW | 0x0000 (0dez)
1C32:0 | Subindex | SM output parameter | RO | 0x20 (32dez)
 | 1C32:01 | Sync mode | RW | 0x0001 (1dez)
 | 1C32:02 | Cycle time | RW | 0x000F4240 (1000000dez)
 | 1C32:03 | Shift time | RO | 0x00000000 (0dez)
 | 1C32:04 | Sync modes supported | RO | 0xC007 (49159dez)
 | 1C32:05 | Minimum cycle time | RO | 0x000103C4 (66500dez)
 | 1C32:06 | Calc and copy time | RO | 0x00000000 (0dez)
 | 1C32:07 | Minimum delay time | RO | 0x00000000 (0dez)
 | 1C32:08 | Command | RW | 0x0000 (0dez)
 | 1C32:09 | Maximum delay time | RO | 0x00000000 (0dez)
 | 1C32:0B | SM event missed counter | RO | 0x0000 (0dez)
 | 1C32:0C | Cycle exceeded counter | RO | 0x0000 (0dez)
 | 1C32:0D | Shift too short counter | RO | 0x0000 (0dez)
 | 1C32:20 | Sync error | RO | 0x00 (0dez)
1C33:0 | Subindex | SM input parameter | RO | 0x20 (32dez)
 | 1C33:01 | Sync mode | RW | 0x0022 (34dez)
 | 1C33:02 | Cycle time | RW | 0x000F4240 (1000000dez)
 | 1C33:03 | Shift time | RO | 0x00000000 (0dez)
 | 1C33:04 | Sync modes supported | RO | 0xC007 (49159dez)
 | 1C33:05 | Minimum cycle time | RO | 0x000103C4 (66500dez)
 | 1C33:06 | Calc and copy time | RO | 0x00000000 (0dez)
 | 1C33:07 | Minimum delay time | RO | 0x00000000 (0dez)
 | 1C33:08 | Command | RW | 0x0000 (0dez)
 | 1C33:09 | Maximum delay time | RO | 0x00000000 (0dez)
 | 1C33:0B | SM event missed counter | RO | 0x0000 (0dez)
 | 1C33:0C | Cycle exceeded counter | RO | 0x0000 (0dez)
 | 1C33:0D | Shift too short counter | RO | 0x0000 (0dez)
 | 1C33:20 | Sync error | RO | 0x00 (0dez)
6000:0 | Subindex | ENC Inputs | RO | 0x16 (22dez)
 | 6000:01 | Latch C valid | RO | 0x00 (0dez)
 | 6000:02 | Latch extern valid | RO | 0x00 (0dez)
 | 6000:03 | Set counter done | RO | 0x00 (0dez)
 | 6000:04 | Counter underflow | RO | 0x00 (0dez)
 | 6000:05 | Counter overflow | RO | 0x00 (0dez)
 | 6000:06 | Status of input status | RO | 0x00 (0dez)
 | 6000:07 | Open circuit | RO | 0x00 (0dez)
 | 6000:08 | Extrapolation stall | RO | 0x00 (0dez)
 | 6000:09 | Status of input A | RO | 0x00 (0dez)
 | 6000:0A | Status of input B | RO | 0x00 (0dez)
 | 6000:0B | Status of input C | RO | 0x00 (0dez)
 | 6000:0C | Status of input gate | RO | 0x00 (0dez)
 | 6000:0D | Status of extern latch | RO | 0x00 (0dez)
 | 6000:0E | Sync error | RO | 0x00 (0dez)
 | 6000:0F | TxPDO State | RO | 0x00 (0dez)
 | 6000:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 6000:11 | Counter value | RO | 0x00000000 (0dez)
 | 6000:12 | Latch value | RO | 0x00000000 (0dez)
 | 6000:13 | Frequency value | RO | 0x00000000 (0dez)
 | 6000:14 | Period value | RO | 0x00000000 (0dez)
 | 6000:16 | Timestamp | RO |
7000:0 | Subindex | ENC Outputs | RO | 0x11 (17dez)
 | 7000:01 | Enable latch C | RO | 0x00 (0dez)
 | 7000:02 | Enable latch extern on positive edge | RO | 0x00 (0dez)
 | 7000:03 | Set counter | RO | 0x00 (0dez)
 | 7000:04 | Enable latch extern on negative edge | RO | 0x00 (0dez)
 | 7000:11 | Set counter value | RO | 0x00000000 (0dez)
8000:0 | Subindex | ENC Settings | RW | 0x17 (23dez)
 | 8000:01 | Enable C reset | RW | 0x00 (0dez)
 | 8000:02 | Enable extern reset | RW | 0x00 (0dez)
 | 8000:03 | Enable up/down counter | RW | 0x00 (0dez)
 | 8000:04 | Gate polarity | RW | 0x01 (1dez)
 | 8000:08 | Disable filter | RW | 0x01 (1dez)
 | 8000:0A | Enable micro increments | RW | 0x00 (0dez)
 | 8000:0B | Open circuit detection A | RW | 0x01 (1dez)
 | 8000:0C | Open circuit detection B | RW | 0x01 (1dez)
 | 8000:0D | Open circuit detection C | RW | 0x00 (0dez)
 | 8000:0E | Reversion of rotation | RW | 0x00 (0dez)
 | 8000:10 | Extern reset polarity | RW | 0x01 (1dez)
 | 8000:11 | Frequency window | RW | 0x2710 (10000dez)
 | 8000:13 | Frequency scaling | RW | 0x0064 (100dez)
 | 8000:14 | Period scaling | RW | 0x0064 (100dez)
 | 8000:15 | Frequency resolution | RW | 0x0064 (100dez)
 | 8000:16 | Period resolution | RW | 0x0064 (100dez)
 | 8000:17 | Frequency wait time | RW | 0x0640 (1600dez)
A000:0 | Subindex | ENC Diag data | RO | 0x03 (3dez)
 | A000:01 | Open circuit A | RO | 0x00 (0dez)
 | A000:02 | Open circuit B | RO | 0x00 (0dez)
 | A000:03 | Open circuit C | RO | 0x00 (0dez)
F000:0 | Subindex | Modular device profile | RO | 0x02 (2dez)
 | F000:01 | Module index distance | RO | 0x0010 (16dez)
 | F000:02 | Maximum number of modules | RO | 0x0001 (1dez)
F008 |  | Code word | RW | 0x00000000 (0dez)
F010:0 | Subindex | Module list | RW | 0x01 (1dez)
 | F010:01 | SubIndex 001 | RW | 0x000001FF (511dez)
Key

Flags:
RO = Read Only
RW = Read/Write


EP5101 - Object description and parameterization

BECKHOFF EP5101: Commissioning and Configuration

Object description and parameterization

Note 		Parameterization
Modules' parameterization will be conducted by the CoE online tab (double-click on the referring object) or the Process data tab (PDO assignment).

Note 		EtherCAT XML Device Description
The description correspond to the display of the CoE objects from the EtherCAT XML Device Description. It is strongly recommended to download the latest revision of the corresponding XML file from the Beckhoff website (http://www.beckhoff.com/english/default.htm?download/elconfg.htm) and follow the installation instructions.

Introduction

The CoE overview contains objects for different intended applications:

  • Objects required for parameterization during commissioning
  • Objects intended for regular operation, e.g. through ADS access
  • Objects for indicating internal settings (may be fixed)
  • Further profile specific object displaying in and outputs as well as status information

The following section first describes the objects require for normal operation, followed by a complete overview of other objects.

Objects for parameterization during commissioning

Index 1011 Restore default parameters
Index | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore the default settings in the EtherCAT slave | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" ("Set Value Dialog") all terminal-specific objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)
Index 8000 ENC Settings
Index | Name | Meaning | Data type | Flags | Default
8000:0 | ENC Settings | Max. subindex | UINT8 | RO | 0x17 (23dec)
8000:01 | Enable C reset | The counter is reset via the C input. | BOOLEAN | RW | 0x00 (0dec)
8000:02 | Enable extern reset | The counter is reset via the external latch input (24V). | BOOLEAN | RW | 0x00 (0dec)
8000:03 Enable up/down counter Enabling the U/D-counter in stead of the encoder
Increments are counted at input A. Input B specifies the counting direction. 		BOOLEAN RW 0x00 (0dec)
8000:04 Gate polarity 0: Disable gate
1: Enable pos. gate (gate activated with "HIGH"-level)
2: Enable neg. gate (gate activated with "LOW"-level) 		BIT2 RW 0x01 (1dec)
8000:08 Disable filter 0: Activates the input filters (only inputs A, /A, B, /B, C, /C)
1: Deactivates the input filters.
If a filter is activated a signal edge must be present for at least 2.4 µs in order to be counted as an increment. 		BOOLEAN RW 0x01 (1dec)
8000:0A | Enable micro increments | If DC mode is activated, the EL5101 interpolates micro-increments between the integer encoder increments. The lower 8 bits of the counter value are used for display purposes. A 32-bit counter thus becomes a 24+8-bit counter, a 16-bit counter becomes a 8+8-bit counter. | BOOLEAN | RW | 0x00 (0dec)
8000:0B Open circuit detection A A broken wire on track A is indicated in index 6000:07.
(diagnostics is only possible, if the associated input is wired differentially)
A differential voltage of < 3.5 V (typical, subject to modification) is interpreted as an open circuit. 		BOOLEAN RW 0x01 (1dec)
8000:0C Open circuit detection B A broken wire on track B is indicated in index 6000:07.
(diagnostics is only possible, if the associated input is wired differentially)
A differential voltage of < 3.5 V (typical, subject to modification) is interpreted as an open circuit. 		BOOLEAN RW 0x01 (1dec)
8000:0D Open circuit detection C A broken wire on track C is indicated in index 6000:07.
(diagnostics is only possible, if the associated input is wired differentially)
A differential voltage of < 3.5 V (typical, subject to modification) is interpreted as an open circuit. 		BOOLEAN RW 0x00 (0dec)
8000:0E | Reversion of rotation | Activates reversal of rotation direction | BOOLEAN | RW | 0x00 (0dec)
8000:10 Extern reset polarity 0: Fall (the counter is set to zero with a falling edge)
1: Rise (the counter is set to zero with a rising edge) 		BIT1 RW 0x01 (1dec)
8000:11 Frequency window This is the minimum time over which the frequency is determined. Default 10 ms [resolution: 1 µs]
The number of pulses in the time window + the following is measured. The maximum waiting time is specified in the "Frequency Wait Time" parameter. The number of pulses is divided by the actual time window size. The determined frequency is output in index 6000:13 and as a process data.
The frequency calculation is carried out locally without distributed clocks function. 		UINT16 RW 0x2710 (10000dec)
8000:13 Frequency scaling Scaling of the frequency measuring (divisor to get the unit in "Hz")

100: "0,01 Hz"

UINT16 RW 0x0064 (100dec)
8000:14 Period scaling Scaling of the period duration

100: "100 ns" period value is multiple of 100 ns

500: "500 ns" period value is multiple of 500 ns

UINT16 RW 0x0064 (100dec)
8000:15 Frequency resolution Resolution of the frequency measuring

100: "0,01 Hz"

UINT16 RW 0x0064 (100dec)
8000:16 Period resolution Internal resolution of the period duration measuring

100: "100 ns" period value is multiple of 100 ns
Internally, the the period will be calculated with a resolution of 100 ns. Therefore, the max. measurable period can be approx. 1.6 seconds

500: "500 ns" period value is multiple of 500 ns
Internally, the the period will be calculated with a resolution of 200 ns; the max. measurable period can be approx. 32.7 ms seconds. The resolution of the process data is furthermore 100 ns (default) according to Index 8004:14 (e.g. 100 ns [default])

UINT16 RW 0x0064 (100dec)
8000:17 Frequency wait time

Waiting time [ms] for frequency measurement

Once the time specified in the frequency window has elapsed, the system waits for the next positive edge from track A. This enables the update speed for the Frequency process data to be optimized, depending on the expected frequencies. It is recommended to enter at least the double period duration of the minimum measuring frequency here.

t >= 2* (1 / fmin)

UINT16 RW 0x0640 (1600dec)

Further objects

Standard objects (0x1000-0x1FFF)

The standard objects of all EtherCAT slaves have the same meaning.

Index 1000 Device type
Index | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device Type of the EtherCAT slave: The Lo-Word contains the supported CoE Profile (5001). The Hi-Word contains the Module Profile corresponding to the Modular Device Profile. | UINT32 | RO | 0x01FF1389 (33493897dec)
Index 1008 Device name
Index | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EP5101-0011
Index 1009 Hardware version
Index | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slaves | STRING | RO | 00
Index 100A Software version
Index | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slaves | STRING | RO | 01
Index 1018 Identity
Index | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | contains information to identify the EtherCAT slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x13ED4052 (334315602dec)
1018:03 | Revision | Revision number of the EtherCAT-Slave, the Lo-Word (Bit 0-15) indicates the special functions terminal number; the Hi-Word (Bit 16-31) refers to the device description. | UINT32 | RO | 0x0010000B (1048587dec)
1018:04 | Serial number | Serial number of the EtherCAT-Slave, the Lo-Byte (Bit 0-7) of the Lo-Word contains the year of manufacturing, the Hi-Byte (Bit 8-15) of the Lo-Word contains the week of manufacturing, the Hi-Word (Bit 16-31) is 0 . | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 Backup parameter handling
Index | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | contains information for the standardized Upload and Download of the Backup Entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum over all backup entries | UINT32 | RO | 0x00000000 (0dec)
Index 1400 ENC RxPDO-Par Control compact
Index | Name | Meaning | Data type | Flags | Default
1400:0 | ENC RxPDO-Par Control compact | PDO Parameter RxPDO 1 | UINT8 | RO | 0x06 (6dec)
1400:06 | Exclude RxPDOs | This entry contains the RxPDOs (Index of the RxPDO Mapping objects) which shall not be transmitted with RxPDO 1 | OCTET-STRING[2] | RO | 01 16
Index 1401 ENC RxPDO-Par Control
Index | Name | Meaning | Data type | Flags | Default
1401:0 | ENC RxPDO-Par Control | PDO Parameter RxPDO 2 | UINT8 | RO | 0x06 (6dec)
1401:06 | Exclude RxPDOs | This entry contains the RxPDOs (Index of the RxPDO Mapping objects) which shall not be transmitted with RxPDO 2 | OCTET-STRING[2] | RO | 00 16
Index 1600 ENC RxPDO-Map Control compact
Index | Name | Meaning | Data type | Flags | Default
1600:0 | ENC RxPDO-Map Control compact | PDO Mapping RxPDO 1 | UINT8 | RO | 0x07 (7dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01, 1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:02, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7000:04, 1
1600:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1600:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1600:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 16
Index 1601 ENC RxPDO-Map Control
Index | Name | Meaning | Data type | Flags | Default
1601:0 | ENC RxPDO-Map Control | PDO Mapping RxPDO 2 | UINT8 | RO | 0x07 (7dec)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:02, 1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03, 1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7000:04, 1
1601:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1601:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1601:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 32
Index 1800 ENC TxPDO-Par Status compact
Index | Name | Meaning | Data type | Flags | Default
1800:0 | ENC TxPDO-Par Status compact | PDO Parameter TxPDO 1 | UINT8 | RO | 0x09 (9dec)
1800:06 | Exclude TxPDOs | This entry contains the TxPDOs (Index of the TxPDO Mapping objects) which shall not be transmitted with TxPDO 1 | OCTET-STRING[2] | RO | 01 1A
1800:07 | TxPDO State | The TxPDO State will be set if the corresponding input data could not be read in correctly | BOOLEAN | RO | 0x00 (0dec)
1800:09 | TxPDO Toggle | the TxPDO Toggle will be toggled with every update of the corresponding input data | BOOLEAN | RO | 0x00 (0dec)
Index 1801 ENC TxPDO-Par Status
Index | Name | Meaning | Data type | Flags | Default
1801:0 | ENC TxPDO-Par Status | PDO Parameter TxPDO 2 | UINT8 | RO | 0x09 (9dec)
1801:06 | Exclude TxPDOs | This entry contains the TxPDOs (Index of the TxPDO Mapping objects) which shall not be transmitted with TxPDO 2 | OCTET-STRING[2] | RO | 00 1A
1801:07 | TxPDO State | The TxPDO State will be set if the corresponding input data could not be read in correctly | BOOLEAN | RO | 0x00 (0dec)
1801:09 | TxPDO Toggle | the TxPDO Toggle will be toggled with every update of the corresponding input data | BOOLEAN | RO | 0x00 (0dec)
Index 1802 ENC TxPDO-Par Frequency
Index | Name | Meaning | Data type | Flags | Default
1802:0 | ENC TxPDO-Par Frequency | PDO Parameter TxPDO 3 | UINT8 | RO | 0x06 (6dec)
1802:06 | Exclude TxPDOs | This entry contains the TxPDOs (Index of the TxPDO Mapping objects) which shall not be transmitted with TxPDO 3 | OCTET-STRING[2] | RO | 03 1A
Index 1803 ENC TxPDO-Par Period
Index | Name | Meaning | Data type | Flags | Default
1803:0 | ENC TxPDO-Par Period | PDO Parameter TxPDO 4 | UINT8 | RO | 0x06 (6dec)
1803:06 | Exclude TxPDOs | This entry contains the TxPDOs (Index of the TxPDO Mapping objects) which shall not be transmitted with TxPDO 4 | OCTET-STRING[2] | RO | 02 1A
Index 1804 ENC TxPDO-Par Timest.
Index | Name | Meaning | Data type | Flags | Default
1804:0 | ENC TxPDO-Par Timest. | PDO Parameter TxPDO 5 | UINT8 | RO | 0x06 (6dec)
1804:06 | Exclude TxPDOs | This entry contains the TxPDOs (Index of the TxPDO Mapping objects) which shall not be transmitted with TxPDO 5 | OCTET-STRING[2] | RO | 05 1A
Index 1805 ENC TxPDO-Par Timest. compact
Index | Name | Meaning | Data type | Flags | Default
1805:0 | ENC TxPDO-Par Timest. compact | PDO Parameter TxPDO 6 | UINT8 | RO | 0x06 (6dec)
1805:06 | Exclude TxPDOs | This entry contains the TxPDOs (Index of the TxPDO Mapping objects) which shall not be transmitted with TxPDO 6 | OCTET-STRING[2] | RO | 04 1A
Index 1A00 ENC TxPDO-Map Status compact
Index | Name | Meaning | Data type | Flags | Default
1A00:0 | ENC TxPDO-Map Status compact | PDO Mapping TxPDO 1 | UINT8 | RO | 0x12 (18dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x06 (Status of input status)) | UINT32 | RO | 0x6000:06, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6000:07, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A00:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0C (Status of input gate)) | UINT32 | RO | 0x6000:0C, 1
1A00:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6000:0D, 1
1A00:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A00:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1800 (ENC TxPDO-Par Status compact), entry 0x07 (TxPDO State)) | UINT32 | RO | 0x1800:07, 1
1A00:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x1800 (ENC TxPDO-Par Status compact), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1800:09, 1
1A00:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 16
1A00:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 16
Index 1A01 ENC TxPDO-Map Status
Index | Name | Meaning | Data type | Flags | Default
1A01:0 | ENC TxPDO-Map Status | PDO Mapping TxPDO 2 | UINT8 | RO | 0x12 (18dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x06 (Status of input status)) | UINT32 | RO | 0x6000:06, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6000:07, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A01:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0C (Status of input gate)) | UINT32 | RO | 0x6000:0C, 1
1A01:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6000:0D, 1
1A01:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A01:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1801 (ENC TxPDO-Par Status), entry 0x07 (TxPDO State)) | UINT32 | RO | 0x1801:07, 1
1A01:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x1801 (ENC TxPDO-Par Status), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1801:09, 1
1A01:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
1A01:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 32
Index 1A02 ENC TxPDO-Map Frequency
Index | Name | Meaning | Data type | Flags | Default
1A02:0 | ENC TxPDO-Map Frequency | PDO Mapping TxPDO 3 | UINT8 | RO | 0x01 (1dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x13 (Frequency value)) | UINT32 | RO | 0x6000:13, 32
Index 1A03 ENC TxPDO-Map Period
Index | Name | Meaning | Data type | Flags | Default
1A03:0 | ENC TxPDO-Map Period | PDO Mapping TxPDO 4 | UINT8 | RO | 0x01 (1dec)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:14, 32
Index 1A04 ENC TxPDO-Map Timest.
Index | Name | Meaning | Data type | Flags | Default
1A04:0 | ENC TxPDO-Map Timest. | PDO Mapping TxPDO 5 | UINT8 | RO | 0x01 (1dec)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:16, 64
Index 1A05 ENC TxPDO-Map Timest. compact
Index | Name | Meaning | Data type | Flags | Default
1A05:0 | ENC TxPDO-Map Timest. compact | PDO Mapping TxPDO 6 | UINT8 | RO | 0x01 (1dec)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x13 (Frequency value)) | UINT32 | RO | 0x6000:16, 32
Index 1C00 Sync manager type
Index | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Usage of the Sync Manager channels | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign
Index | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x01 (1dec)
1C12:01 | Subindex 001 | 1. assigned RxPDO (contains the index of the corresponding RxPDO Mapping object) | UINT16 | RW | 0x1600 (5632dec)
Index 1C13 TxPDO assign
Index | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x01 (1dec)
1C13:01 | Subindex 001 | 1. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:03 | Subindex 003 | 3. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 1C32 SM output parameter
Index | Name | Meaning | Data type | Flags | Default
1C32:0 | SM output parameter | Synchronization parameter of the outputs | UINT8 | RO | 0x20 (32dec)
1C32:01 Sync mode actual synchronization mode:
  • 0: Free Run
  • 1: Synchron with SM 2 Event
  • 2: DC-Mode - Synchron with SYNC0 Event
  • 3: DC-Mode - Synchron with SYNC1 Event
 UINT16 RW 0x0001 (1dec)
1C32:02 Cycle time Cycle time (in ns):
  • Free Run: cycle time of the local timer
  • Synchron with SM 2 Event: Cycle time of the master
  • DC-Mode: SYNC0/SYNC1 Cycle time
 UINT32 RW 0x000F4240 (1000000dec)
1C32:03 | Shift time | Time between SYNC0 Event and Outputs Valid (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dec)
1C32:04 Sync modes supported Supported synchronization modes:
  • Bit 0 = 1: Free Run is supported
  • Bit 1 = 1: Synchron with SM 2 Event is supported
  • Bit 2-3 = 01: DC-Mode is supported
  • Bit 4-5 = 10: Output Shift with SYNC1 Event (only DC-Mode)
  • Bit 14 = 1: dynamic times (could be measured Messen by writing 1C32:08)
 UINT16 RO 0xC007 (49159dec)
1C32:05 | Minimum cycle time | Minimum cycle time supported (in ns) | UINT32 | RO | 0x000103C4 (66500dec)
1C32:06 | Calc and copy time | Minimal time between SYNC0 and SYNC1 Event (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dec)
1C32:07 | Minimum delay time | UINT32 | RO | 0x00000000 (0dec)
1C32:08 Command
  • 0: Measurement of the times will be stopped
  • 1: Measurement of the times will be started

The Entries 1C32:03, 1C32:05, 1C32:06, 1C32:09, 1C33:03, 1C33:06, 1C33:09 will be updated with the maximum measured values.

UINT16 RW 0x0000 (0dec)
1C32:09 | Maximum delay time | Time between SYNC1 Event and Outputs Valid (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dec)
1C32:0B | SM event missed counter | Number of the missed SM-Events in state OPERATIONAL (only in DC Mode) | UINT16 | RO | 0x0000 (0dec)
1C32:0C | Cycle exceeded counter | Number of the exceeded cycles in state OPERATIONAL | UINT16 | RO | 0x0000 (0dec)
1C32:0D | Shift too short counter | Number of the too short distances between SYNC0 and SYNC1 Event (only in DC Mode) | UINT16 | RO | 0x0000 (0dec)
1C32:20 | Sync error | TRUE: In the last cycle the synchronization was not correct (only in DC Mode) | BOOLEAN | RO | 0x00 (0dec)
Index 1C33 SM input parameter
Index | Name | Meaning | Data type | Flags | Default
1C33:0 | SM input parameter | Synchronization parameter of the inputs | UINT8 | RO | 0x20 (32dec)
1C33:01 Sync mode actual synchronization mode:
  • 0: Free Run
  • 1: Synchron with SM 3 Event (no Outputs available)
  • 2: DC - Synchron with SYNC0 Event
  • 3: DC - Synchron with SYNC1 Event
  • 34: Synchron with SM 2 Event (Outputs available)
 UINT16 RW 0x0022 (34dec)
1C33:02 | Cycle time | same as 1C32:02 | UINT32 | RW | 0x000F4240 (1000000dec)
1C33:03 | Shift time | time between SYNC0-Event and Input Latch (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dec)
1C33:04 Sync modes supported Supported synchronization modes:
  • Bit 0: Free Run is supported
  • Bit 1: Synchron with SM 2 Event is supported (Outputs available)
  • Bit 1: Synchron with SM 3 Event is supported (no Outputs available)
  • Bit 2-3 = 01: DC-Mode is supported
  • Bit 4-5 = 01: Input Shift with local event (Outputs available)
  • Bit 4-5 = 10: Input Shift with SYNC1 Event (no Outputs available)
  • Bit 14 = 1: dynamic times (could be measured Messen by writing 1C32:08 or 1C33:08)
 UINT16 RO 0xC007 (49159dec)
1C33:05 | Minimum cycle time | same as 1C32:05 | UINT32 | RO | 0x000103C4 (66500dec)
1C33:06 | Calc and copy time | time between Input Latch and the availability of the inputs for the master (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dec)
1C33:07 | Minimum delay time | UINT32 | RO | 0x00000000 (0dec)
1C33:08 | Command | same as 1C32:08 | UINT16 | RW | 0x0000 (0dec)
1C33:09 | Maximum delay time | time between SYNC1-Event and Input Latch (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dec)
1C33:0B | SM event missed counter | same as 1C32:11 | UINT16 | RO | 0x0000 (0dec)
1C33:0C | Cycle exceeded counter | same as 1C32:12 | UINT16 | RO | 0x0000 (0dec)
1C33:0D | Shift too short counter | same as 1C32:13 | UINT16 | RO | 0x0000 (0dec)
1C33:20 | Sync error | same as 1C32:32 | BOOLEAN | RO | 0x00 (0dec)

Profile specific objects (0x6000-0xFFFF)

The profile specific objects have the same meaning for all EtherCAT Slaves which support the profile 5001.

Index 6000 ENC Inputs
Index | Name | Meaning | Data type | Flags | Default
6000:0 | ENC Inputs | Max. subindex | UINT8 | RO | 0x16 (22dec)
6000:01 | Latch C valid | The counter value was latched with the "C" input. The data of index 6000:12 correspond to the latched value. To reactivate the latch input, the index 7000:01 has to be reset and then set again. | BOOLEAN | RO | 0x00 (0dec)
6000:02 | Latch extern valid | The counter value was latched with the extern latch input. The data of index 6000:12 correspond to the latched value. To reactivate the latch input, the index 7000:02 or index 7000:04 have to be reset and then set again. | BOOLEAN | RO | 0x00 (0dec)
6000:03 | Set counter done | Set counter done | BOOLEAN | RO | 0x00 (0dec)
6000:04 | Counter underflow | Counter underflow. Overflow/underflow control is inactive in combination with a reset function (C/external). | BOOLEAN | RO | 0x00 (0dec)
6000:05 | Counter overflow | Counter overflow. Overflow/underflow control is inactive in combination with a reset function (C/external). | BOOLEAN | RO | 0x00 (0dec)
6000:06 | Status of input status | State of the status input (alarm input 1) | BOOLEAN | RO | 0x00 (0dec)
6000:07 | Open circuit | Indicates an open circuit Configuration via indices 8000:0A, 8000:0B, 8000:0C | BOOLEAN | RO | 0x00 (0dec)
6000:08 | Extrapolation stall | The extrapolated part of the counter value is invalid | BOOLEAN | RO | 0x00 (0dec)
6000:09 | Status of input A | Status of input A | BOOLEAN | RO | 0x00 (0dec)
6000:0A | Status of input B | Status of input B | BOOLEAN | RO | 0x00 (0dec)
6000:0B | Status of input C | Status of input C | BOOLEAN | RO | 0x00 (0dec)
6000:0C | Status of input gate | Status of input gate | BOOLEAN | RO | 0x00 (0dec)
6000:0D | Status of extern latch | Status of extern latch | BOOLEAN | RO | 0x00 (0dec)
6000:0E | Sync error | The Sync error bit is only required for DC mode. It indicates whether a synchronization error has occurred during the previous cycle. This means a SYNC signal was triggered in the EL5101, although no new process data were available (0=OK, 1=NOK). | BOOLEAN | RO | 0x00 (0dec)
6000:0F | TxPDO State | Validity of the data of the associated TxPDO (0 = valid, 1 = invalid). | BOOLEAN | RO | 0x00 (0dec)
6000:10 | TxPDO Toggle | The TxPDO Toggle is toggled by the slave, if the data of the corresponding PDO was updated. | BOOLEAN | RO | 0x00 (0dec)
6000:11 | Counter value | Counter value | UINT32 | RO | 0x00000000 (0dec)
6000:12 | Latch value | Latch value | UINT32 | RO | 0x00000000 (0dec)
6000:13 | Frequency value | Frequency value (setting of scaling and resolution via index 8000:13 und 8000:15) | UINT32 | RO | 0x00000000 (0dec)
6000:14 | Period value | Period value (setting of scaling and resolution via index 8000:14 und 8000:16) | UINT32 | RO | 0x00000000 (0dec)
6000:16 | Timestamp | Timestamp of the last counter change | UINT64 | RO |
Index 7000 ENC Outputs
Index | Name | Meaning | Data type | Flags | Default
7000:0 | ENC Outputs | Max. subindex | UINT8 | RO | 0x11 (17dec)
7000:01 | Enable latch C | Enabling the latch with the "C"-input | BOOLEAN | RO | 0x00 (0dec)
7000:02 | Enable latch extern on positive edge | Enabling the external latch on positive edge | BOOLEAN | RO | 0x00 (0dec)
7000:03 | Set counter | Set counter | BOOLEAN | RO | 0x00 (0dec)
7000:04 | Enable latch extern on negative edge | Enabling the external latch on negative edge | BOOLEAN | RO | 0x00 (0dec)
7000:11 | Set counter value | The counter value, which can be set via „Set counter“ (Index 7000:03) | UINT32 | RO | 0x00000000 (0dec)
Index A000 ENC Diag data
Index | Name | Meaning | Data type | Flags | Default
A000:0 | ENC Diag data | Max. subindex | UINT8 | RO | 0x03 (3dec)
A000:01 | Open circuit A |  | BOOLEAN | RO | 0x00 (0dec)
A000:02 | Open circuit B |  | BOOLEAN | RO | 0x00 (0dec)
A000:03 | Open circuit C |  | BOOLEAN | RO | 0x00 (0dec)
Index F000 Modular device profile
Index | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | general information about the Modular Device Profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance between the objects of two channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | number of channels | UINT16 | RO | 0x0001 (1dec)
Index F008 Code word
Index | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module list
Index | Name | Meaning | Data type | Flags | Default
F010:0 | Module list | Max. subindex | UINT8 | RW | 0x01 (1dec)
F010:01 | SubIndex 001 | reserved | UINT32 | RW | 0x000001FF (511dec)


ELxxxx - restoring the delivery state

BECKHOFF ELxxxx: Configuration

Restoring the delivery state

To restore the delivery state for backup objects in ELxxxx terminals, the CoE object "Restore default parameters", SubIndex 001 can be selected in the TwinCAT System Manager (Config mode) (see Fig. 1)

Fig. 1 Selecting the "Restore default parameters" PDO

Double-click on SubIndex 001 to enter the Set Value dialog. Enter the value 1684107116 in field "Dec" or the value 0x64616F6C in field "Hex" and confirm with OK (Fig. 2).
All backup objects are reset to the delivery state.

Fig. 2 Entering a restore value in the Set Value dialog

Note 		Alternative restore value

In some older terminals the backup objects can be switched with an alternative restore value:

Decimal value: "1819238756"

Hexadecimal value: "0x6C6F6164"

An incorrect entry for the restore value has no effect.


General operating conditions

Protection degrees (IP-Code)

The standard IEC 60529 (DIN EN 60529) defines the degrees of protection in different classes.

1. Number: dust protection and touch guard | Definition
0 | Non-protected
1 | Protected against access to hazardous parts with the back of a hand. Protected against solid foreign objects of Ø50 mm
2 | Protected against access to hazardous parts with a finger. Protected against solid foreign objects of Ø12,5 mm.
3 | Protected against access to hazardous parts with a tool. Protected against solid foreign objects Ø2,5 mm.
4 | Protected against access to hazardous parts with a wire. Protected against solid foreign objects Ø1 mm.
5 | Protected against access to hazardous parts with a wire. Dust-protected. Intrusion of dust is not totally prevented, but dust shall not penetrate in a quantity to interfere with satisfactory operation of the device or to impair safety.
6 | Protected against access to hazardous parts with a wire. Dust-tight. No intrusion of dust.
2. Number: water* protection | Definition
0 | Non-protected
1 | Protected against water drops
2 | Protected against water drops when enclosure tilted up to 15°.
3 | Protected against spraying water. Water sprayed at an angle up to 60° on either side of the vertical shall have no harmful effects.
4 | Protected against splashing water. Water splashed against the disclosure from any direction shall have no harmful effects
5 | Protected against water jets
6 | Protected against powerful water jets
7 | Protected against the effects of temporary immersion in water. Intrusion of water in quantities causing harmful effects shall not be possible when the enclosure is temporarily immersed in water for 30 min. in 1 m depth.

*) These protection classes define only protection against water!

Chemical Resistance

The Resistance relates to the Housing of the Fieldbus Box and the used metal parts.

Character | Resistance
Steam | at temperatures >100°C: not resistant
Sodium base liquor (ph-Value > 12) | at room temperature: resistant > 40°C: not resistant
Acetic acid | not resistant
Argon (technical clean) | resistant
Key

resistant: Lifetime several months
non inherently resistant: Lifetime several weeks
not resistant: Lifetime several hours resp. early decomposition


Support and Service

Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.

Beckhoff's branch offices and representatives

Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!

The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com

You will also find further documentation for Beckhoff components there.

Beckhoff Headquarters

Beckhoff Automation GmbH

Eiserstr. 5
33415 Verl
Germany

Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support

Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:

  • support
  • design, programming and commissioning of complex automation systems
  • and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service

The Beckhoff Service Center supports you in all matters of after-sales service:

  • on-site service
  • repair service
  • spare parts service
  • hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com