EP4378-1022 - EtherCAT Box mit analogen und digitalen Eingängen und Ausgängen
Home
Web_Title EP 150dpi (default)


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Sicherheitshinweise
•
Hinweise zur Dokumentation
•
Ausgabestände der Dokumentation


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentlichte Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version | Kommentar
1.1 | Titelseite aktualisiert
1.0 | Erste Veröffentlichung
Firm- und Hardware-Stände
Diese Dokumentation bezieht sich auf den zum Zeitpunkt ihrer Erstellung gültigen Firm- und Hardware-Stand.
Die Eigenschaften der Module werden stetig weiterentwickelt und verbessert. Module älteren Fertigungsstandes können nicht die gleichen Eigenschaften haben, wie Module neuen Standes. Bestehende Eigenschaften bleiben jedoch erhalten und werden nicht geändert, so dass ältere Module immer durch neue ersetzt werden können.
Dokumentation | Firmware | Hardware
1.1 | 01 | 03
1.0 | 01 | 03
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der EtherCAT Box aufgedruckten Batch-Nummer (D-Nummer) entnehmen.
Syntax der Batch-Nummer (D-Nummer)
D: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit D-Nr. 29 10 02 01:
29 - Produktionswoche 29
10 - Produktionsjahr 2010
02 - Firmware-Stand 02
01 - Hardware-Stand 01
Weitere Informationen zu diesem Thema: Versionsidentifikation von EtherCAT-Geräten.


EtherCAT Box - Einführung

EtherCAT Box - Einführung
EtherCAT Box - Einführung
Das EtherCAT-System wird durch die EtherCAT-Box-Module in Schutzart IP67 erweitert. Durch das integrierte EtherCAT-Interface sind die Module ohne eine zusätzliche Kopplerbox direkt an ein EtherCAT-Netzwerk anschließbar. Die hohe EtherCAT-Performance bleibt also bis in jedes Modul erhalten.
Die außerordentlich geringen Abmessungen von nur 126 x 30 x 26,5 mm (H x B x T) sind identisch zu denen der Feldbus Box Erweiterungsmodule. Sie eignen sich somit besonders für Anwendungsfälle mit beengten Platzverhältnissen. Die geringe Masse der EtherCAT-Module begünstigt u. a. auch Applikationen, bei denen die I/O-Schnittstelle bewegt wird (z. B. an einem Roboterarm). Der EtherCAT-Anschluss erfolgt über geschirmte M8-Stecker.
EtherCAT-Box-Module in einem EtherCAT-Netzwerk
Die robuste Bauweise der EtherCAT-Box-Module erlaubt den Einsatz direkt an der Maschine. Schaltschrank und Klemmenkasten werden hier nicht mehr benötigt. Die Module sind voll vergossen und daher ideal vorbereitet für nasse, schmutzige oder staubige Umgebungsbedingungen.
Durch vorkonfektionierte Kabel vereinfacht sich die EtherCAT- und Signalverdrahtung erheblich. Verdrahtungsfehler werden weitestgehend vermieden und somit die Inbetriebnahmezeiten optimiert. Neben den vorkonfektionierten EtherCAT-, Power- und Sensorleitungen stehen auch feldkonfektionierbare Stecker und Kabel für maximale Flexibilität zur Verfügung. Der Anschluss der Sensorik und Aktorik erfolgt je nach Einsatzfall über M8- oder M12-Steckverbinder.
Die EtherCAT-Module decken das typische Anforderungsspektrum der I/O-Signale in Schutzart IP67 ab:
▪
digitale Eingänge mit unterschiedlichen Filtern (3,0 ms oder 10 μs)
▪
digitale Ausgänge mit 0,5 oder 2 A Ausgangsstrom
▪
analoge Ein- und Ausgänge mit 16 Bit Auflösung
▪
Thermoelement- und RTD-Eingänge
▪
Schrittmotormodule
Auch XFC (eXtreme Fast Control Technology)-Module wie z. B. Eingänge mit Time-Stamp sind verfügbar.
EtherCAT Box mit M8-Anschlüssen für Sensor/Aktoren
EtherCAT Box mit M12-Anschlüssen für Sensor/Aktoren
Basis-Dokumentation zu EtherCAT
Eine detaillierte Beschreibung des EtherCAT-Systems finden Sie in der System Basis-Dokumentation zu EtherCAT, die auf unserer Homepage (www.beckhoff.de) unter Downloads zur Verfügung steht.
XML-Dateien
XML -Dateien (XML Device Description Files) zu EtherCAT-Modulen von Beckhoff finden Sie unter auf unserer Homepage (www.beckhoff.de) unter Downloads im Bereich Konfigurations-Dateien.


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Einführung
•
Technische Daten
•
Lieferumfang
•
Prozessabbild


Einführung

Produktübersicht [image] Einführung
Einführung
EP4378-1022 Inventarbild Website
EP4378-1022
EP4378-1022 | 4+4-Kanal-Analog-Ein-/Ausgang, U/I parametrierbar, + 8-Kanal-Digital-Ein-/Ausgang, 24 V DC/3,0 ms
Die EtherCAT Box EP4378-1022 bietet eine Kombination aus vier analogen Eingängen und vier analogen Ausgängen sowie acht digitalen Ein-/Ausgängen. Die analogen Kanäle können jeweils einzeln parametriert werden, sodass sie entweder Signale im Bereich von ±10 V oder im Bereich von 0/4 bis 20 mA verarbeiten bzw. erzeugen. Die Auflösung der Eingangssignale erfolgt vorzeichenbehaftet mit 16 Bit. Bei den Ausgängen wird die Spannung bzw. der Ausgangsstrom mit einer Auflösung von 15 Bit (Default) galvanisch getrennt zur Prozessebene gespeist. Die digitalen Kanäle eignen sich gemäß der Spezifikation EN 61131-2, Typ 1/3 zum Einlesen von binären Sensoren oder zur Ansteuerung von Aktoren. Die Eingänge haben eine Filterkonstante von 3 ms. Die Ausgänge verarbeiten Lastströme bis 0,5 A und sind kurzschlussfest und verpolungsgeschützt. Alle Kanäle besitzen ein gemeinsames Massepotenzial. Auf den oberen vier M12-Anschlüssen liegt jeweils ein analoger Eingang, ein analoger Ausgang, und ein ohne Konfiguration frei verwendbarer digitaler Ein-/Ausgang, sodass komplexe Endgeräte wie Frequenzumrichter, Hydraulikaggregate, Motorantriebe oder andere mit nur einem Anschlusskabel versorgt werden können. Auf den unteren vier M12-Anschlüssen liegt jeweils ein konfigurationslos frei verwendbarer digitaler Ein-/Ausgang.
Quick Links


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Alle Werte sind typische Werte über den gesamten Temperaturbereich, wenn nicht anders angegeben.
Technische Daten
EP4378-1022
Feldbus
Feldbus
EtherCAT
Anschluss
2 x M8-Buchse, 4-polig, grün
Potenzialtrennung
500 V (Feldbus / IO)
Versorgungsspannungen
Anschluss
Eingang: 1 x M8-Stecker, 4-polig, schwarz
Weiterleitung: 1 x M8-Buchse, 4-polig, schwarz
Steuerspannung US
Nennspannung
24 VDC (-15 % / +20 %)
Summenstrom
max. 4 A 1)
Stromaufnahme aus US
120 mA
Peripheriespannung UP
Nennspannung
24 VDC (-15 % / +20 %)
Summenstrom
max. 4 A 1)
Stromaufnahme aus UP
30 mA
Weitere Verbraucher
▪
Sensoren und Aktoren 2)
▪
Lasten an digitalen Ausgängen
Signal-Eingänge und -Ausgänge
Anschluss
8x M12-Buchse, 5-polig
Bezugsmasse
GNDP (Massepotential der Peripheriespannung UP)
Sensor- / Aktor-Versorgungsspannung
24 VDC aus der Peripheriespannung UP
max. 0,5 A in Summe, kurzschlussfest
Weitere Spezifikationen
Analoge Eingänge
Analoge Ausgänge
Digitale Ein-/Ausgänge
Umgebungsbedingungen
Umgebungstemperatur im Betrieb
-25…+60°C
-25…+55°C gemäß cURus
Umgebungstemperatur bei Lagerung
-40…+85°C
Vibrations- / Schockfestigkeit
gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung
gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart
IP65, IP66, IP67 (gemäß EN 60529)
Mechanik
Abmessungen
ca. 126 x 60 x 26,5 mm (ohne Steckverbinder)
Gewicht
ca. 250 g
Einbaulage
beliebig
Zulassungen und Konformität
Zulassungen
CE, cURus
1) Dieser Wert entspricht der Stromtragfähigkeit der Anschlüsse für die Versorgungsspannungen.
2) „Sensoren und Aktoren“: Geräte, die an den Anschlüssen der Ein-/Ausgänge angeschlossen sind.
Zusätzliche Prüfungen
Die Boxen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3 Achsen
 | 5 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3 Achsen
 | 35 g, 11 ms
Weiterführende Informationen
•
Digitale Ein-/Ausgänge
•
Analoge Eingänge
•
Analoge Ausgänge
•
Messbereiche
•
Ausgangs-Signalbereiche


Digitale Ein-/Ausgänge

Produktübersicht [image] Technische Daten [image] Digitale Ein-/Ausgänge
Digitale Ein-/Ausgänge
Technische Daten | Digitale Ein-/Ausgänge
Anzahl | 8
Eingangs-Spezifikation
Charakteristik | Ähnlich Typ 3 gemäß EN 61131-2, kompatibel mit Typ 1
Eingangsfilter | 3,0 ms
Eingangsstrom | 3 mA bei 24 V
Ausgangs-Spezifikation
Last-Art | ohmsch, induktiv, Lampenlast
Ausgangsspannung | 24 V aus der Peripheriespannung UP
Ausgangsstrom | max. 0,5 A pro Ausgang, kurzschlussfest max. 4 A in Summe


Analoge Eingänge

Produktübersicht [image] Technische Daten [image] Analoge Eingänge
Analoge Eingänge
Hinweise zu analogen Spezifikationen
Technische Daten
Analoge Eingänge
Anzahl
4
Kabel-Länge
max. 30 m
Messbereiche
▪
-10…+10 V (default)
▪
0…10 V
▪
-20…+20 mA
▪
0…20 mA
▪
4…20 mA
Eingangsart
Single-ended
Spannungsfestigkeit
max. 30 VDC
Messfehler
< 0,3 % vom Messbereichs-Endwert
Eingangsfilter, analog
5 kHz Tiefpass
Eingangsfilter, digital
Einstellbar:
▪
FIR 50 Hz
▪
FIR 60 Hz
▪
IIR


Analoge Ausgänge

Produktübersicht [image] Technische Daten [image] Analoge Ausgänge
Analoge Ausgänge
Hinweise zu analogen Spezifikationen
Technische Daten
Analoge Ausgänge
Anzahl
4
Kabel-Länge
max. 30 m
Ausgangs-Signalbereich
▪
-10…+10 V (default)
▪
0…10 V
▪
0…20 mA
▪
4…20 mA
Ausgabefehler
< 0,1 % (Umgebungstemperatur 0…+55 °C)
< 0,2 % (Umgebungstemperatur < 0°C und > 55°C)
vom Signalbereichs-Endwert.
Kurzschlussfest
Ja


Messbereiche

Produktübersicht [image] Technische Daten [image] Messbereiche
Messbereiche
Weiterführende Informationen
•
Messbereich -10…+10 V
•
Messbereich 0…10 V
•
Messbereich -20…+20 mA
•
Messbereich 0…20 mA
•
Messbereich 4…20 mA


Messbereich -10…+10 V

Produktübersicht [image] Technische Daten [image] Messbereiche [image] Messbereich -10…+10 V
Messbereich -10…+10 V
Technische Daten | Messbereich
Eingangswiderstand | > 200 kΩ
Messbereich, nominell | -10…+10 V
Messbereich, Endwert (MBE) | 10 V
Messbereich, technisch nutzbar | -10,737…+10,737 V
PDO Auflösung | 16 Bit inklusive Vorzeichen
PDO LSB (Extended Range) | 327,68 µV
PDO LSB (Legacy Range) | 305,19 µV
Messbereich -10…+10V 16 Bit
Messbereich -10…+10V


Messbereich 0…10 V

Produktübersicht [image] Technische Daten [image] Messbereiche [image] Messbereich 0…10 V
Messbereich 0…10 V
Technische Daten | Messbereich
Eingangswiderstand | > 200 kΩ
Messbereich, nominell | 0…10 V
Messbereich, Endwert (MBE) | 10 V
Messbereich, technisch nutzbar | -0,093…+10,737 V
PDO Auflösung | 16 Bit inklusive Vorzeichen
PDO LSB (Extended Range) | 327,68 µV
PDO LSB (Legacy Range) | 305,19 µV
Messbereich 0…10V 16 Bit
Messbereich 0…10 V


Messbereich -20…+20 mA

Produktübersicht [image] Technische Daten [image] Messbereiche [image] Messbereich -20…+20 mA
Messbereich -20…+20 mA
Technische Daten | Messbereich
Eingangswiderstand | 85 Ω typ.
Messbereich, nominell | -20…+20 mA
Messbereich, Endwert (MBE) | 20 mA
Messbereich, technisch nutzbar | -21,474…+21,474 mA, überstromgeschützt
Absicherung | Interne Überlastbegrenzung, dauerstromfest
PDO Auflösung | 16 Bit inklusive Vorzeichen
PDO LSB (Extended Range) | 655,35 nA
PDO LSB (Legacy Range) | 610,37 nA
Messbereich -20…20mA 16 Bit
Messbereich -20…20mA


Messbereich 0…20 mA

Produktübersicht [image] Technische Daten [image] Messbereiche [image] Messbereich 0…20 mA
Messbereich 0…20 mA
Technische Daten | Messbereich
Eingangswiderstand | 85 Ω typ.
Messbereich, nominell | 0…20 mA
Messbereich, Endwert (MBE) | 20 mA
Messbereich, technisch nutzbar | -0,186…+21,474 mA, überstromgeschützt
Absicherung | Interne Überlastbegrenzung, dauerstromfest
PDO Auflösung | 16 Bit inklusive Vorzeichen
PDO LSB (Extended Range) | 655,35 nA
PDO LSB (Legacy Range) | 610,37 nA
Messbereich 0…20mA 16 Bit
Messbereich 0…20 mA


Messbereich 4…20 mA

Produktübersicht [image] Technische Daten [image] Messbereiche [image] Messbereich 4…20 mA
Messbereich 4…20 mA
Technische Daten | Messbereich
Eingangswiderstand | 85 Ω typ.
Messbereich, nominell | 4…20 mA
Messbereich, Endwert (MBE) | 20 mA
Messbereich, technisch nutzbar | 0 .. +21,179 mA, überstromgeschützt
Absicherung | Interne Überlastbegrenzung, dauerstromfest
PDO Auflösung | 16 Bit inklusive Vorzeichen
PDO LSB (Extended Range) | 524,28 nA
PDO LSB (Legacy Range) | 488,30 nA
Messbereich 4…20mA 16 Bit
Messbereich 4…20mA


Ausgangs-Signalbereiche

Produktübersicht [image] Technische Daten [image] Ausgangs-Signalbereiche
Ausgangs-Signalbereiche
Weiterführende Informationen
•
Ausgangs-Signalbereich -10…+10 V
•
Ausgangs-Signalbereich 0…10 V
•
Ausgangs-Signalbereich 0…20 mA
•
Ausgangs-Signalbereich 4…20 mA


Ausgangs-Signalbereich -10…+10 V

Produktübersicht [image] Technische Daten [image] Ausgangs-Signalbereiche [image] Ausgangs-Signalbereich -10…+10 V
Ausgangs-Signalbereich -10…+10 V
Technische Daten | Ausgangs-Signalbereich
Lastwiderstand | min. 5 kΩ
Signalbereichs-Endwert | 10 V
PDO Auflösung | 16 Bit inklusive Vorzeichen
PDO LSB | 305,19 µV
Ausgangs-Signalbereich -10…+10V


Ausgangs-Signalbereich 0…10 V

Produktübersicht [image] Technische Daten [image] Ausgangs-Signalbereiche [image] Ausgangs-Signalbereich 0…10 V
Ausgangs-Signalbereich 0…10 V
Technische Daten | Ausgangs-Signalbereich
Lastwiderstand | min. 5 kΩ
Signalbereichs-Endwert | 10 V
PDO Auflösung | 16 Bit inklusive Vorzeichen
PDO LSB | 305,19 µV
Ausgangs-Signalbereich 0…10V


Ausgangs-Signalbereich 0…20 mA

Produktübersicht [image] Technische Daten [image] Ausgangs-Signalbereiche [image] Ausgangs-Signalbereich 0…20 mA
Ausgangs-Signalbereich 0…20 mA
Technische Daten | Messbereich
Bürde | max. 350 Ω
Signalbereichs-Endwert | 20 mA
PDO Auflösung | 16 Bit inklusive Vorzeichen
PDO LSB | 610,37 nA
Ausgangs-Signalbereich 0…20mA


Ausgangs-Signalbereich 4…20 mA

Produktübersicht [image] Technische Daten [image] Ausgangs-Signalbereiche [image] Ausgangs-Signalbereich 4…20 mA
Ausgangs-Signalbereich 4…20 mA
Technische Daten | Messbereich
Bürde | max. 350 Ω
Signalbereichs-Endwert | 20 mA
PDO Auflösung | 16 Bit inklusive Vorzeichen
PDO LSB | 488,30 nA
Ausgangs-Signalbereich 4…20mA


Lieferumfang

Produktübersicht [image] Lieferumfang
Lieferumfang
Vergewissern Sie sich, dass folgende Komponenten im Lieferumfang enthalten sind:
▪
1x EtherCAT Box EP4378-1022
▪
2x Schutzkappe für EtherCAT-Buchse, M8, grün (vormontiert)
▪
1x Schutzkappe für Versorgungsspannungs-Eingang, M8, transparent (vormontiert)
▪
1x Schutzkappe für Versorgungsspannungs-Ausgang, M8, schwarz (vormontiert)
▪
10x Beschriftungsschild unbedruckt (1 Streifen à 10 Stück)
Vormontierte Schutzkappen gewährleisten keinen IP67-Schutz
Schutzkappen werden werksseitig vormontiert, um Steckverbinder beim Transport zu schützen. Sie sind u.U. nicht fest genug angezogen, um die Schutzart IP67 zu gewährleisten.
Stellen Sie den korrekten Sitz der Schutzkappen sicher, um die Schutzart IP67 zu gewährleisten.


Prozessabbild

Produktübersicht [image] Prozessabbild
Prozessabbild
Im Prozessabbild befindet sich für jeden Eingang und jeden Ausgang ein Prozessdatenobjekt.
Die Bezeichnung jedes Prozessdatenobjekts beinhaltet den Namen der Buchse und die Pin-Nummer des entsprechenden Eingangs oder Ausgangs. Siehe Steckverbinder-Übersicht.
EP4378-1022 Prozessabbild gesamt
EP4378-1022 Prozessabbild
„DI“: Prozessdaten der digitalen Eingänge
EP4378-1022 Prozessabbild DI
TC3 InputVariable Symbol Input
Digitaler Eingang. Datentyp: BIT.
„AI“: Prozessdaten der analogen Eingänge
EP4378-1022 Prozessabbild AI
TC3 InputVariable Symbol Status
▪
TC3 InputVariable Symbol Underrange
Dieses Bit ist TRUE, wenn der nominelle Messbereich unterschritten wurde. Siehe Messbereichs-Überwachung.
▪
TC3 InputVariable Symbol Overrange
Dieses Bit ist TRUE, wenn der nominelle Messbereich überschritten wurde.
Siehe Messbereichs-Überwachung.
▪
TC3 InputVariable Symbol Limit 1
Status-Bit der Grenzwert-Überwachung.
▪
TC3 InputVariable Symbol Limit 2
Status-Bit der Grenzwert-Überwachung.
▪
TC3 InputVariable Symbol Error
Dieses Bit ist TRUE, wenn der Messwert eine Fehlerschwelle verletzt. In der Werkseinstellung sind die Fehlerschwellen identisch mit den Endwerten des technischen Messbereichs.
Dieses Bit wird außerdem durch rotes Leuchten der LED „A“ signalisiert.
▪
TC3 InputVariable Symbol Sync error
Dieses Bit ist nur im Synchronisationsmodus „Distributed Clocks“ relevant.
Es ist TRUE, wenn in dem vorangegangenen EtherCAT-Zyklus ein Synchronisationsfehler aufgetreten ist.
▪
TC3 InputVariable Symbol TxPDO State
Dieses Bit ist TRUE, wenn aufgrund eines internen Fehlers der Messwert nicht eingelesen werden konnte. Das heißt, wenn dieses Bit TRUE ist, ist der aktuelle Messwert „Value“ ungültig.
▪
TC3 InputVariable Symbol TxPDO Toggle
Die Box invertiert dieses Bit jedes Mal, wenn sie den Messwert „Value“ in den Prozessdaten aktualisiert.
TC3 InputVariable Symbol Value
Der aktuelle Messwert.
Datentyp: INT.
Datenformat: einstellbar (Werkseinstellung: Signed Integer)
„DO“: Prozessdaten der digitalen Ausgänge
EP4378-1022 Prozessabbild DO
TC3 OutputVariable Symbol Output
Digitaler Ausgang. Datentyp: BIT.
„AO“: Prozessdaten der analogen Ausgänge
EP4378-1022 Prozessabbild AO
TC3 OutputVariable Symbol Analog output
Analoger Ausgang. Datentyp: INT.


Montage und Anschluss

Montage und Anschluss
Montage und Anschluss
Weiterführende Informationen
•
Montage
•
Anschlüsse
•
UL-Anforderungen


Montage

Montage und Anschluss [image] Montage
Montage
Weiterführende Informationen
•
Abmessungen
•
Befestigung
•
Funktionserdung (FE)


Abmessungen

Montage und Anschluss [image] Montage [image] Abmessungen
Abmessungen
Abmessungen
Alle Maße sind in Millimeter angegeben.
Gehäuseeigenschaften
Gehäusematerial | PA6 (Polyamid)
Vergussmasse | Polyurethan
Montage | zwei Befestigungslöcher Ø 4,5 mm für M4
Metallteile | Messing, vernickelt
Kontakte | CuZn, vergoldet
Stromweiterleitung | max. 4 A
Einbaulage | beliebig
Schutzart | im verschraubten Zustand IP65, IP66, IP67 (gemäß EN 60529)
Abmessungen (H x B x T) | ca. 126 x 60 x 26,5 mm (ohne Steckverbinder)


Befestigung

Montage und Anschluss [image] Montage [image] Befestigung
Befestigung
Hinweis
Verschmutzung bei der Montage
Verschmutzte Steckverbinder können zu Fehlfunktion führen. Die Schutzart IP67 ist nur gewährleistet, wenn alle Kabel und Stecker angeschlossen sind.
•
Schützen Sie die Steckverbinder bei der Montage vor Verschmutzung.
Montieren Sie das Modul mit zwei M4-Schrauben an den zentriert angeordneten Befestigungslöchern.


Funktionserdung (FE)

Montage und Anschluss [image] Montage [image] Funktionserdung (FE)
Funktionserdung (FE)
Die Befestigungslöcher dienen gleichzeitig als Anschlüsse für die Funktionserdung (FE).
Stellen Sie sicher, dass die Box über beide Befestigungsschrauben niederimpedant geerdet ist. Das erreichen Sie z.B., indem Sie die Box an einem geerdeten Maschinenbett montieren.
FE-Anschluss über Befestigungslöcher
Funktionserdung über die Befestigungslöcher


Anschlüsse

Montage und Anschluss [image] Anschlüsse
Anschlüsse
Weiterführende Informationen
•
Steckverbinder-Übersicht
•
EtherCAT
•
Versorgungsspannungen
•
Signal-Eingänge und -Ausgänge


Steckverbinder-Übersicht

Montage und Anschluss [image] Anschlüsse [image] Steckverbinder-Übersicht
Steckverbinder-Übersicht
EP4378-1022 Steckverbinder-Bezeichnungen
Name | Funktion | Steckverbinder- Typ | Anzugs- Drehmoment
X01 | Signal-Eingänge und -Ausgänge | M12 | 0,6 Nm 1)
X02
X03
X04
X05
X06
X07
X08
X40 | EtherCAT-Eingang | M8-Buchse | 0,4 Nm 1)
X41 | EtherCAT-Weiterleitung | M8-Buchse | 0,4 Nm 1)
X60 | Versorgungsspannungs-Eingang | M8-Stecker | 0,4 Nm 1)
X61 | Versorgungsspannungs-Weiterleitung | M8-Buchse | 0,4 Nm 1)
1) Montieren Sie Stecker an diesen Steckverbindern mit einem Drehmomentschlüssel; z.B. ZB8801 von Beckhoff.
Schutzkappen
▪
Verschließen Sie nicht benutzte Steckverbinder mit Schutzkappen.
▪
Stellen Sie den korrekten Sitz von vormontierten Schutzkappen sicher.
Schutzkappen werden werksseitig vormontiert, um Steckverbinder beim Transport zu schützen. Sie sind u. U. nicht fest genug angezogen, um die Schutzart IP67 zu gewährleisten.


EtherCAT

Montage und Anschluss [image] Anschlüsse [image] EtherCAT
EtherCAT
Weiterführende Informationen
•
Steckverbinder
•
Status-LEDs
•
Leitungen


Steckverbinder

Montage und Anschluss [image] Anschlüsse [image] EtherCAT [image] Steckverbinder
Steckverbinder
Hinweis
Verwechselungs-Gefahr: Versorgungsspannungen und EtherCAT
Defekt durch Fehlstecken möglich.
•
Beachten Sie die farbliche Codierung der Steckverbinder:
schwarz: Versorgungsspannungen
grün: EtherCAT
Für den ankommenden und weiterführenden EtherCAT-Anschluss haben EtherCAT-Box-Module zwei grüne M8-Buchsen.
EtherCAT Steckverbinder
Kontaktbelegung
M8-Buchse 4polig Kontaktbelegung
M8-Buchse
EtherCAT | M8- Steckverbinder | Aderfarben
Signal | Kontakt | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 und alte Versionen von ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | 1 | gelb1) | orange/weiß | weiß/orange
Tx - | 4 | orange1) | orange | orange
Rx + | 2 | weiß1) | blau/weiß | weiß/grün
Rx - | 3 | blau1) | blau | grün
Shield | Gehäuse | Schirm | Schirm | Schirm
1) Aderfarben nach EN 61918
Anpassung der Aderfarben für die Leitungen ZB9030, ZB9032 und ZK1090-3xxxx-xxxx
Zur Vereinheitlichung wurden die Aderfarben der Leitungen ZB9030, ZB9032 und ZK1090-3xxx-xxxx auf die Aderfarben der EN61918 umgestellt: gelb, orange, weiß, blau. Es sind also verschiedene Farbkodierungen im Umlauf. Die elektrischen Eigenschaften der Leitungen sind bei der Umstellung der Aderfarben erhalten geblieben.


Status-LEDs

Montage und Anschluss [image] Anschlüsse [image] EtherCAT [image] Status-LEDs
Status-LEDs
EtherCAT Status-LEDs
L/A (Link/Act)
Neben jeder EtherCAT-Buchse befindet sich eine grüne LED, die mit „L/A“ beschriftet ist. Die LED signalisiert den Kommunikationsstatus der jeweiligen Buchse:
LED | Bedeutung
aus | keine Verbindung zum angeschlossenen EtherCAT-Gerät
leuchtet | LINK: Verbindung zum angeschlossenen EtherCAT-Gerät
blinkt | ACT: Kommunikation mit dem angeschlossenen EtherCAT-Gerät
Run
Jeder EtherCAT-Slave hat eine grüne LED, die mit „Run“ beschriftet ist. Die LED signalisiert den Status des Slaves im EtherCAT-Netzwerk:
LED | Bedeutung
aus | Slave ist im Status „Init“
blinkt gleichmäßig | Slave ist im Status „Pre-Operational“
blinkt vereinzelt | Slave ist im Status „Safe-Operational“
leuchtet | Slave ist im Status „Operational“
Beschreibung der Stati von EtherCAT-Slaves


Leitungen

Montage und Anschluss [image] Anschlüsse [image] EtherCAT [image] Leitungen
Leitungen
Verwenden Sie zur Verbindung von EtherCAT-Geräten geschirmte Ethernet-Kabel, die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen.
EtherCAT nutzt vier Adern für die Signalübertragung.
Aufgrund der automatischen Leitungserkennung „Auto MDI-X“ können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte, als auch gekreuzte Kabel (Cross-Over) verwenden.
Detaillierte Empfehlungen zur Verkabelung von EtherCAT-Geräten


Versorgungsspannungen

Montage und Anschluss [image] Anschlüsse [image] Versorgungsspannungen
Versorgungsspannungen
Die EtherCAT Box wird mit zwei Versorgungsspannungen versorgt. Die Massepotentiale der Versorgungsspannungen sind galvanisch getrennt.
▪
Steuerspannung US
▪
Peripheriespannung UP
Weiterleitung der Versorgungsspannungen
Die Power-Anschlüsse IN und OUT sind im Modul gebrückt. Somit können auf einfache Weise die Versorgungsspannungen US und UP von EtherCAT Box zu EtherCAT Box weitergereicht werden.
Hinweis
Maximalen Strom beachten!
Beachten Sie auch bei der Weiterleitung der Versorgungsspannungen US und UP, dass jeweils der für die M8-Steckverbinder maximal zulässige Strom von 4 A nicht überschritten wird!
Weiterführende Informationen
•
Steckverbinder
•
Status-LEDs
•
Leitungsverluste


Steckverbinder

Montage und Anschluss [image] Anschlüsse [image] Versorgungsspannungen [image] Steckverbinder
Steckverbinder
Hinweis
Verwechselungs-Gefahr: Versorgungsspannungen und EtherCAT
Defekt durch Fehlstecken möglich.
•
Beachten Sie die farbliche Codierung der Steckverbinder:
schwarz: Versorgungsspannungen
grün: EtherCAT
Steckverbinder + LEDs
Steckverbinder für Versorgungsspannungen
M8 4polig In+Out Kontaktbelegung
M8-Steckverbinder
Kontakt | Funktion | Beschreibung | Aderfarbe 1)
1 | US | Steuerspannung | Braun
2 | UP | Peripheriespannung | Weiß
3 | GNDS | GND zu US | Blau
4 | GNDP | GND zu UP | Schwarz
1) Die Aderfarben gelten für Leitungen vom Typ: Beckhoff ZK2020-3xxx-xxxx


Status-LEDs

Montage und Anschluss [image] Anschlüsse [image] Versorgungsspannungen [image] Status-LEDs
Status-LEDs
Steckverbinder + LEDs
Status-LEDs für die Versorgungsspannungen
LED | Anzeige | Bedeutung
US (Steuerspannung) | aus | Versorgungsspannung US nicht vorhanden
 | leuchtet grün | Versorgungsspannung US vorhanden
UP (Peripheriespannung) | aus | Versorgungsspannung UP nicht vorhanden
 | leuchtet grün | Versorgungsspannung UP vorhanden


Leitungsverluste

Montage und Anschluss [image] Anschlüsse [image] Versorgungsspannungen [image] Leitungsverluste
Leitungsverluste
Beachten Sie bei der Planung einer Anlage den Spannungsabfall an der Versorgungs-Zuleitung. Vermeiden Sie, dass der Spannungsabfall so hoch wird, dass die Versorgungsspannungen an der Box die minimale Nennspannung unterschreiten.
Berücksichtigen Sie auch Spannungsschwankungen des Netzteils.
Spannungsabfall an der Versorgungs-Zuleitung
Leitungsverluste M8 2A
Leitungsverluste M8 4A


Signal-Eingänge und -Ausgänge

Montage und Anschluss [image] Anschlüsse [image] Signal-Eingänge und -Ausgänge
Signal-Eingänge und -Ausgänge
Hinweis
Signalbereiche müssen vor der Verkabelung eingestellt werden
Defekt durch falsch eingestellte Signalbereiche möglich.
•
Stellen Sie die Messbereiche und Ausgangs-Signalbereiche ein, bevor Sie Sensoren und Aktoren anschließen.
Weiterführende Informationen
•
Steckverbinder
•
Analoge Sensoren, Anschluss-Beispiele
•
Analoge Aktoren, Anschluss-Beispiele
•
Digitale Sensoren, Anschluss-Beispiele
•
Digitale Aktoren, Anschluss-Beispiele
•
Status-LEDs


Steckverbinder

Montage und Anschluss [image] Anschlüsse [image] Signal-Eingänge und -Ausgänge [image] Steckverbinder
Steckverbinder
M12-Buchsen
Hinweis
Verwechselungsgefahr
Die M12-Buchsen von EP4378-1022 sind unterschiedlich belegt.
Defekt möglich durch Verwechseln von M12-Buchsen.
EMV-Schirmklammer
Applikationsbedingt kann es erforderlich sein, den Schirm der Anschlußkabel ZK2000-7xxx der einzelnen, analogen Kanäle zusätzlich am Signaleingang der Box mit einer Schirmklammer ZB8513-0002 aufzulegen.
M12-Buchse
 | EP4378-1022 Analoge+Digitale IO Markierung Analoge und digitale I/O X01, X02, X05, X06 |  | EP4378-1022 Nur Digitale IO Markierung Nur digitale I/O X03, X04, X07, X08
Pin | Symbol | Beschreibung | Symbol | Beschreibung
1 | UP1 1) | Sensor- / Aktor-Versorgungsspannung | UP1 1) | Sensor- / Aktor-Versorgungsspannung
2 | AIN | Analoger Eingang | - | -
3 | GNDP | Masse | GNDP | Masse
4 | DIO | Digitaler Ein-/Ausgang | DIO | Digitaler Ein-/Ausgang
5 | AOUT | Analoger Ausgang | Schirm 2)
1) Abgezweigt von der Peripheriespannung UP, kurzschlussfest.
2) Der Schirm-Pin ist über eine RC-Kombination an Funktionserde FE angebunden.
GNDP an Pin 3 ist die Bezugs-Masse für alle Eingänge und Ausgänge.


Analoge Sensoren, Anschluss-Beispiele

Montage und Anschluss [image] Anschlüsse [image] Signal-Eingänge und -Ausgänge [image] Analoge Sensoren, Anschluss-Beispiele
Analoge Sensoren, Anschluss-Beispiele
Zweileiter-Anschluss, analoger Sensor
Dreileiter-Anschluss, analoger Sensor


Analoge Aktoren, Anschluss-Beispiele

Montage und Anschluss [image] Anschlüsse [image] Signal-Eingänge und -Ausgänge [image] Analoge Aktoren, Anschluss-Beispiele
Analoge Aktoren, Anschluss-Beispiele
Dreileiter-Anschluss, analoger Aktor


Digitale Sensoren, Anschluss-Beispiele

Montage und Anschluss [image] Anschlüsse [image] Signal-Eingänge und -Ausgänge [image] Digitale Sensoren, Anschluss-Beispiele
Digitale Sensoren, Anschluss-Beispiele
Zweileiter-Anschluss, digitaler Sensor
Dreileiter-Anschluss, digitaler Sensor


Digitale Aktoren, Anschluss-Beispiele

Montage und Anschluss [image] Anschlüsse [image] Signal-Eingänge und -Ausgänge [image] Digitale Aktoren, Anschluss-Beispiele
Digitale Aktoren, Anschluss-Beispiele
Zweileiter-Anschluss, Digitaler Aktor
Dreileiter-Anschluss, digitaler Aktor


Status-LEDs

Montage und Anschluss [image] Anschlüsse [image] Signal-Eingänge und -Ausgänge [image] Status-LEDs
Status-LEDs
An jedem Steckverbinder für Signal-Eingänge und -Ausgänge gibt es Status-LEDs.
Status-LEDs für Signal-Eingänge und -Ausgänge
LED „D“ (links)
Die LED „D“ signalisiert den Status des digitalen Ein-/Ausgangs. Sie leuchtet grün, wenn der Ein-/Ausgang einen High-Pegel ausgibt oder erkennt.
LED „A“ (rechts)
Die LED „A“ signalisiert den Status des analogen Eingangs und des analogen Ausgangs. Im Fehlerfall leuchtet die LED rot. Prüfen Sie die Status-Bits „Error“ des entsprechenden Eingangs, um zu ermitteln, ob der Fehler am Eingang aufgetreten ist.
LED „A“
Status-Bit
„Error“
Beschreibung
aus
x
Der analoge Ausgang ist deaktiviert.
grün
x
Der analoge Ausgang ist aktiviert.
rot
1
Der Messwert des analogen Eingangs ist außerhalb der Fehlerschwellen.
rot
0
Der analoge Ausgang kann den vorgegebenen Strom nicht treiben. Mögliche Gründe:
▪
Drahtbruch.
▪
Die Bürde ist zu hoch. Zulässige Bürde: Siehe Technische Daten der Ausgangs-Signalbereiche.
x = ohne Bedeutung


UL-Anforderungen

Montage und Anschluss [image] UL-Anforderungen
UL-Anforderungen
Die Installation der nach UL zertifizierten EtherCAT Box Module muss den folgenden Anforderungen entsprechen.
Versorgungsspannung
SmallWarningYellow VORSICHT
VORSICHT!
Die folgenden genannten Anforderungen gelten für die Versorgung aller so gekennzeichneten EtherCAT Box Module.
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur mit einer Spannung von 24 VDC versorgt werden, die
•
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
•
von einer Spannungsquelle die NEC class 2 entspricht stammt.
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit unbegrenzten Spannungsquellen verbunden werden!
Netzwerke
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit Telekommunikations-Netzen verbunden werden!
Umgebungstemperatur
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur in einem Umgebungstemperaturbereich von 0 bis 55°C betrieben werden!
Kennzeichnung für UL
Alle nach UL (Underwriters Laboratories) zertifizierten EtherCAT Box Module sind mit der folgenden Markierung gekennzeichnet.
UL-Markierung


Inbetriebnahme und Konfiguration

Inbetriebnahme und Konfiguration
Inbetriebnahme und Konfiguration
Weiterführende Informationen
•
Einbinden in TwinCAT
•
Analoge Eingänge
•
Analoge Ausgänge
•
Wiederherstellen des Auslieferungszustandes
•
Außerbetriebnahme


Einbinden in TwinCAT

Inbetriebnahme und Konfiguration [image] Einbinden in TwinCAT
Einbinden in TwinCAT
Die Vorgehensweise zum Einbinden in TwinCAT ist in dieser Schnellstartanleitung beschrieben.


Analoge Eingänge

Inbetriebnahme und Konfiguration [image] Analoge Eingänge
Analoge Eingänge
Weiterführende Informationen
•
Signalfluss
•
Messbereich
•
Datenformat der Messwerte
•
Filter
•
Grenzwert-Überwachung
•
Abgleich und Skalierung


Signalfluss

Inbetriebnahme und Konfiguration [image] Analoge Eingänge [image] Signalfluss
Signalfluss
Analoge Eingänge Signalfluss
Signalfluss


Messbereich

Inbetriebnahme und Konfiguration [image] Analoge Eingänge [image] Messbereich
Messbereich
Der Messbereich kann für jeden analogen Eingang individuell gewählt werden.
Stellen Sie die Messbereiche in den folgenden CoE-Parametern ein:
Anschluss | CoE-Objekt |  | Parameter
X01 | 810Dhex | AI Advanced Settings Ch.1 | 11hex | Input Type
X02 | 811Dhex | AI Advanced Settings Ch.2 | 11hex | Input Type
X05 | 812Dhex | AI Advanced Settings Ch.3 | 11hex | Input Type
X06 | 813Dhex | AI Advanced Settings Ch.4 | 11hex | Input Type
Mögliche Werte
Wert | Messbereich
2dez (Werkseinstellung) | -10 … +10 V
14dez | 0 … 10 V
17dez | -20 … +20 mA
18dez | 0 … 20 mA
19dez | 4 … 20 mA
In den Technischen Daten finden sie die Spezifikationen für die einzelnen Messbereiche.
Beispiel
Input Type im CoE
CoE-Parameter „Input Type“ für den analogen Eingang an Anschluss X01
Weiterführende Informationen
•
Nomineller und technischer Messbereich
•
Messbereichs-Überwachung: Status-Bits


Nomineller und technischer Messbereich

Inbetriebnahme und Konfiguration [image] Analoge Eingänge [image] Messbereich [image] Nomineller und technischer Messbereich
Nomineller und technischer Messbereich
Der technische Messbereich ist ca. 7 … 8 % größer als der nominelle Messbereich. Genaue Werte finden Sie in den technischen Daten der Messbereiche.
Sie können wählen, ob der technische Messbereich oder der nominelle Messbereich dargestellt wird. Der angegebene Messfehler ist unabhängig davon nur für Messwerte innerhalb des nominellen Messbereichs gewährleistet.
Wählen Sie den dargestellten Messbereich in den folgenden CoE-Parametern aus:
Anschluss | CoE-Objekt |  | Parameter
X01 | 810Dhex | AI Advanced Settings Ch.1 | 12hex | Scaler
X02 | 811Dhex | AI Advanced Settings Ch.2 | 12hex | Scaler
X05 | 812Dhex | AI Advanced Settings Ch.3 | 12hex | Scaler
X06 | 813Dhex | AI Advanced Settings Ch.4 | 12hex | Scaler
Mögliche Werte
Wert | Enum | Beschreibung
0 (Werkseinstellung) | „Extended Range“ | Messbereich = Technischer Messbereich
3 | „Legacy Range“ | Messbereich = Nomineller Messbereich
Beispiel
Scaler im CoE
CoE-Parameter "Scaler" für den analogen Eingang an Anschluss X01


Messbereichs-Überwachung: Status-Bits

Inbetriebnahme und Konfiguration [image] Analoge Eingänge [image] Messbereich [image] Messbereichs-Überwachung: Status-Bits
Messbereichs-Überwachung: Status-Bits
Hinweis
Fehlfunktion der Messbereichs-Überwachung nach falschem Anwender-Abgleich
Die Messbereichs-Überwachung ist im Signalfluss nach dem Anwender-Abgleich angeordnet. Falsche Koeffizienten (Offset, Gain) im Anwender-Abgleich können dazu führen, dass die Messbereichs-Überwachung nicht erwartungsgemäß funktioniert.
Drei Status-Bits signalisieren, ob der aktuelle Messwert eines analogen Eingangs außerhalb des Messbereichs liegt. Siehe Prozessdaten der analogen Eingänge.
Status-Bit „Overrange“
Wenn das Status-Bit „Overrange“ gesetzt ist:
▪
Der aktuelle Messwert ist größer als der Messbereichs-Endwert.
▪
Der in den technischen Daten angegebene Messfehler ist für den aktuellen Messwert nicht gewährleistet.
▪
Wenn „Legacy range“ eingestellt ist, entspricht der aktuelle Wert der Variablen Value nicht dem Messwert.
Der aktuelle Messwert ist größer als der größte darstellbare Wert im „Legacy range“.
Status-Bit „Underrange“
Wenn das Status-Bit „Underrange“ gesetzt ist:
▪
Der aktuelle Messwert ist kleiner als der kleinste Wert des nominellen Messbereichs.
▪
Der in den technischen Daten angegebene Messfehler ist für den aktuellen Messwert nicht gewährleistet.
▪
Wenn „Legacy range“ eingestellt ist, entspricht der aktuelle Wert der Variablen Value nicht dem Messwert.
Der aktuelle Messwert ist kleiner als der kleinste darstellbare Wert im „Legacy range“.
Status-Bit „Error“
Wenn das Status-Bit „Error“ gesetzt ist:
▪
Der aktuelle Messwert ist kleiner als die untere Fehlerschwelle oder größer als die obere Fehlerschwelle.
In der Werkseinstellung liegen die Fehlerschwellen auf dem kleinsten und größten darstellbaren Wert des technischen Messbereichs.
▪
Die LED „A“ leuchtet rot. Sie ist mit dem Status-Bit „Error“ verknüpft.
Weiterführende Informationen
•
Fehlerschwellen


Fehlerschwellen

Inbetriebnahme und Konfiguration [image] Analoge Eingänge [image] Messbereich [image] Messbereichs-Überwachung: Status-Bits [image] Fehlerschwellen
Fehlerschwellen
In der Werkseinstellung liegen die Fehlerschwellen auf dem kleinsten und größten darstellbaren Wert des technischen Messbereichs („Extended range“).
Das Überschreiten der Fehlerschwellen wird für jeden Kanal auf zwei Wegen signalisiert:
▪
Das Status-Bit „Error“ ist TRUE.
▪
Die Status-LED „A“ leuchtet rot.
Die Fehlerschwellen können über CoE-Parameter eingestellt werden.
Empfehlung: passen Sie die Fehlerschwellen an den Ausgangssignal-Bereich des Sensors an.
Untere Fehlerschwelle
Anschluss | CoE-Objekt |  | Parameter
X01 | 810Dhex | AI Advanced Settings Ch.1 | 17hex | Low Range Error
X02 | 811Dhex | AI Advanced Settings Ch.2 | 17hex | Low Range Error
X05 | 812Dhex | AI Advanced Settings Ch.3 | 17hex | Low Range Error
X06 | 813Dhex | AI Advanced Settings Ch.4 | 17hex | Low Range Error
Obere Fehlerschwelle
Anschluss | CoE-Objekt |  | Parameter
X01 | 810Dhex | AI Advanced Settings Ch.1 | 18hex | High Range Error
X02 | 811Dhex | AI Advanced Settings Ch.2 | 18hex | High Range Error
X05 | 812Dhex | AI Advanced Settings Ch.3 | 18hex | High Range Error
X06 | 813Dhex | AI Advanced Settings Ch.4 | 18hex | High Range Error


Datenformat der Messwerte

Inbetriebnahme und Konfiguration [image] Analoge Eingänge [image] Datenformat der Messwerte
Datenformat der Messwerte
Sie können das Datenformat der Messwerte (Eingangsvariablen „Value“ in den Prozessdaten) über die folgenden CoE-Parameter anpassen:
Anschluss | CoE-Objekt |  | Parameter
X01 | 8100hex | AI Settings Ch.1 | 02hex | Presentation
X02 | 8110hex | AI Settings Ch.2 | 02hex | Presentation
X05 | 8120hex | AI Settings Ch.3 | 02hex | Presentation
X06 | 8130hex | AI Settings Ch.4 | 02hex | Presentation
Mögliche Werte
Wert | Datenformat | Beschreibung
0 (Werkseinstellung) | „Signed“ | Zweierkomplement-Darstellung
1 | „Unsigned“ | Es werden nur positive Messwerte dargestellt. Das MSB ist immer 0.
2 | „Absolute MSB sign“ | Darstellung als Absolutwert mit dem MSB als Vorzeichen-Bit.
Beispiel
Presentation im CoE
CoE-Parameter "Presentation" für den analogen Eingang an Anschluss X01


Filter

Inbetriebnahme und Konfiguration [image] Analoge Eingänge [image] Filter
Filter
Der Messwert jedes analogen Eingangs kann mit einem digitalen Filter gefiltert werden.
Weiterführende Informationen
•
Filter aktivieren
•
Filter-Typ auswählen


Filter aktivieren

Inbetriebnahme und Konfiguration [image] Analoge Eingänge [image] Filter [image] Filter aktivieren
Filter aktivieren
Hinweis
Messwert-Sprünge beim Aktivieren oder Deaktivieren von Filtern
Wenn Filter aktiviert oder deaktiviert werden, können kurzzeitig Messwert-Sprünge in den Prozessdaten auftreten, die nicht den physikalischen Werten entsprechen.
Sie können den Filter für jeden Eingang individuell aktivieren. In der Werkseinstellung sind alle Filter deaktivert.
Aktivieren Sie die Filter, indem Sie die folgenden CoE-Parameter auf TRUE setzen:
Anschluss | CoE-Objekt |  | Parameter
X01 | 8100hex | AI Settings Ch.1 | 06 | Enable Filter
X02 | 8110hex | AI Settings Ch.2 | 06 | Enable Filter
X05 | 8120hex | AI Settings Ch.3 | 06 | Enable Filter
X06 | 8130hex | AI Settings Ch.4 | 06 | Enable Filter
Das Aktivieren von Filtern beeinflusst auch den Sychronisationsmodus:
▪
Wenn alle Filter deaktiviert sind, läuft das Gerät im Synchronisationmodus „Synchron mit SM-Event“
▪
Wenn ein oder mehrere Filter aktiviert sind, läuft das Gerät im Synchronisationmodus „Free Run“.
Beispiel
Enable Filter im CoE
CoE-Parameter "Enable filter" für den analogen Eingang an Anschluss X01


Filter-Typ auswählen

Inbetriebnahme und Konfiguration [image] Analoge Eingänge [image] Filter [image] Filter-Typ auswählen
Filter-Typ auswählen
Sie können den Filter-Typ für jeden Eingang individuell auswählen.
Anschluss | CoE-Objekt |  | Parameter
X01 | 8100hex | AI Settings Ch.1 | 15hex | Filter Settings
X02 | 8110hex | AI Settings Ch.2 | 15hex | Filter Settings
X05 | 8120hex | AI Settings Ch.3 | 15hex | Filter Settings
X06 | 8130hex | AI Settings Ch.4 | 15hex | Filter Settings
Mögliche Werte
Wert | Filter-Typ
0 | "50 Hz FIR"
1 | "60 Hz FIR"
2 (Werkseinstellung) | "IIR 1"
3 | "IIR 2"
4 | "IIR 3"
5 | "IIR 4"
6 | "IIR 5"
7 | "IIR 6"
8 | "IIR 7"
9 | "IIR 8"
Nutzen Sie die folgende Beschreibung, um den passenden Filter-Typ für Ihre Anwendung auszuwählen.
FIR-Filter
Das Filter arbeitet als Notch-Filter (Kerbfilter) und bestimmt die Wandlungszeit des Moduls. Je höher die Filterfrequenz, desto schneller ist die Wandlungszeit. Es steht ein 50 Hz und ein 60 Hz Filter zur Verfügung.
Kerbfilter bedeutet, dass der Filter bei der genannten Filterfrequenz und Vielfachen davon Nullstellen (Kerben) im Frequenzgang hat, diese Frequenzen also in der Amplitude dämpft.
Das FIR-Filter arbeitet als nicht-rekursives Filter.
IIR-Filter
Das Filter mit IIR-Charakteristik ist ein zeitdiskretes, lineares, zeitinvariantes Filter, welches in 8 Level eingestellt werden kann (Level 1 = schwaches rekursives Filter, bis Level 8 = starkes rekursives Filter)
Der IIR kann als gleitende Mittelwertberechnung nach einem Tiefpass verstanden werden.
Beispiel
Filter Settings im CoE
CoE-Parameter „Filter Settings“ für den analogen Eingang an Anschluss X01


Grenzwert-Überwachung

Inbetriebnahme und Konfiguration [image] Analoge Eingänge [image] Grenzwert-Überwachung
Grenzwert-Überwachung
Sie können für jeden analogen Eingang zwei Grenzwerte definieren:
▪
Limit 1
▪
Limit 2
Für jeden Grenzwert gibt es eine gleichnamige Variable in den Prozessdaten der analogen Eingänge. Die Variable zeigt an, ob der aktuelle Messwert oberhalb oder unterhalb des Grenzwertes liegt.
Einen Grenzwert definieren
Tragen Sie den Grenzwert in den entsprechenden CoE-Parameter ein.
Wertebereich: 0x8000 .. 0x7FFF (-32768 .. 32767)
Anschluss | CoE-Objekt |  | Parameter
X01 | 8100hex | AI Settings Ch.1 | 13hex | Limit 1
 |  |  | 14hex | Limit 2
X02 | 8110hex | AI Settings Ch.2 | 13hex | Limit 1
 |  |  | 14hex | Limit 2
X05 | 8120hex | AI Settings Ch.3 | 13hex | Limit 1
 |  |  | 14hex | Limit 2
X06 | 8130hex | AI Settings Ch.4 | 13hex | Limit 1
 |  |  | 14hex | Limit 2
Überwachung aktivieren
In der Werkseinstellung ist die Grenzwertüberwachung für beide Grenzwerte deaktiviert.
Setzen Sie den CoE-Parameter für den jeweiligen Grenzwert auf TRUE:
Anschluss | CoE-Objekt |  | Parameter
X01 | 8100hex | AI Settings Ch.1 | 07 | Enable limit 1
 |  |  | 08 | Enable limit 2
X02 | 8110hex | AI Settings Ch.2 | 07 | Enable limit 1
 |  |  | 08 | Enable limit 2
X05 | 8120hex | AI Settings Ch.3 | 07 | Enable limit 1
 |  |  | 08 | Enable limit 2
X06 | 8130hex | AI Settings Ch.4 | 07 | Enable limit 1
 |  |  | 08 | Enable limit 2
Auswerten
Werten Sie die Eingangsvariablen „Limit 1“ und „Limit 2“ in den Prozessdaten gemäß folgender Tabelle aus:
Variablen-Wert | Bedeutung
 | „Swap limit bits“ 1) = FALSE | „Swap limit bits“ 1) = TRUE
0 | Die Überwachung ist für diesen Grenzwert nicht aktiviert.
1 | Der Messwert ist kleiner als der Grenzwert. | Der Messwert ist größer als der Grenzwert.
2 | Der Messwert ist größer als der Grenzwert. | Der Messwert ist kleiner als der Grenzwert.
3 | Der Messwert ist genauso groß wie der Grenzwert.
1) „Swap limit bits“ ist ein CoE-Parameter. In der Werkseinstellung ist „Swap limit bits“ = FALSE.
Anschluss | CoE-Objekt |  | Parameter
X01 | 8100hex | AI Settings Ch.1 | 0Ehex | Swap limit bits
X02 | 8110hex | AI Settings Ch.2 | 0Ehex | Swap limit bits
X03 | 8120hex | AI Settings Ch.3 | 0Ehex | Swap limit bits
X04 | 8130hex | AI Settings Ch.4 | 0Ehex | Swap limit bits


Abgleich und Skalierung

Inbetriebnahme und Konfiguration [image] Analoge Eingänge [image] Abgleich und Skalierung
Abgleich und Skalierung
Weiterführende Informationen
•
Hersteller-Abgleich
•
Anwender-Abgleich
•
Anwender-Skalierung


Hersteller-Abgleich

Inbetriebnahme und Konfiguration [image] Analoge Eingänge [image] Abgleich und Skalierung [image] Hersteller-Abgleich
Hersteller-Abgleich
Jeder analoge Eingang wird werksseitig abgeglichen. Das Ergebnis des Abgleichs sind die Koeffizienten einer Korrekturfunktion. Die Korrekturfunktion lautet:
YV = GV * ( XV - OV )
YV : Messwert nach dem Hersteller-Abgleich
XV : Messwert vor dem Hersteller-Abgleich
GV : Gain des Hersteller-Abgleichs
OV : Offset des Hersteller-Abgleichs
Die Koeffizienten GV und OV sind vom Benutzer nicht veränderbar. Wenn Sie einen Abgleich selbst durchführen wollen, nutzen Sie den Anwender-Abgleich.
Sie finden die Koeffizienten für die unterschiedlichen Messbereiche in den folgenden CoE-Objekten:
Anschluss | CoE-Objekt (nur Lesezugriff)
X01 | 810Fhex | AI Vendor data Ch.1
X02 | 811Fhex | AI Vendor data Ch.2
X05 | 812Fhex | AI Vendor data Ch.3
X06 | 813Fhex | AI Vendor data Ch.4
Hersteller-Abgleich deaktivieren
Hinweis
Messfehler bei deaktiviertem Hersteller-Abgleich
Der in den technischen Daten angegebene Messfehler ist nicht mehr gewährleistet, wenn Sie den Hersteller-Abgleich deaktivieren.
Wenn Sie den Anwender-Abgleich nutzen, kann es sinnvoll sein, den Hersteller-Abgleich zu deaktivieren.
Setzen Sie die folgenden CoE-Parameter auf FALSE, um den Hersteller-Abgleich für den jeweiligen Eingang zu deaktivieren.
Anschluss | CoE-Objekt |  | Parameter
X01 | 8100hex | AI Settings Ch.1 | 0Bhex | Enable vendor calibration
X02 | 8110hex | AI Settings Ch.2 | 0Bhex | Enable vendor calibration
X05 | 8120hex | AI Settings Ch.3 | 0Bhex | Enable vendor calibration
X06 | 8130hex | AI Settings Ch.4 | 0Bhex | Enable vendor calibration


Anwender-Abgleich

Inbetriebnahme und Konfiguration [image] Analoge Eingänge [image] Abgleich und Skalierung [image] Anwender-Abgleich
Anwender-Abgleich
Hinweis
Der Anwender-Abgleich beeinflusst die Messbereichs-Überwachung.
Falsche Abgleich-Koeffizienten können dazu führen, dass sich Status-Bits und Status-LEDs nicht mehr erwartungsgemäß verhalten; siehe Messbereichs-Überwachung.
Der Anwender-Abgleich ist dazu vorgesehen, das Gerät z.B. in einem kleineren Messbereich als dem vom Hersteller abgeglichenen Bereich abzugleichen. Dadurch kann in dem kleineren Messbereich eine höhere Genauigkeit erzielt werden.
Die Korrekturfunktion hat die gleiche Form wie die Korrekturfunktion des Hersteller-Abgleichs:
YU = GU * ( XU – OU )
YU : Messwert nach dem Anwender-Abgleich
XU : Messwert vor dem Anwender-Abgleich
GU : Gain
OU : Offset
Anwender-Abgleich aktivieren
Der Anwender-Abgleich ist werksseitig deaktiviert. Er kann für jeden Eingang individuell aktiviert werden. Setzen Sie dazu den entsprechenden CoE-Index auf TRUE:
Anschluss | CoE-Objekt |  | Parameter
X01 | 8100hex | AI Settings Ch.1 | 0Ahex | Enable user calibration
X02 | 8110hex | AI Settings Ch.2 | 0Ahex | Enable user calibration
X05 | 8120hex | AI Settings Ch.3 | 0Ahex | Enable user calibration
X06 | 8130hex | AI Settings Ch.4 | 0Ahex | Enable user calibration
Abgleich-Koeffizienten einstellen
Stellen Sie die Abgleich-Koeffizienten über die folgen CoE-Parameter ein:
Anschluss | CoE-Objekt |  | Parameter
X01 | 8100hex | AI Settings Ch.1 | 17hex | User calibration offset
 |  |  | 18hex | User calibration gain
X02 | 8110hex | AI Settings Ch.2 | 17hex | User calibration offset
 |  |  | 18hex | User calibration gain
X05 | 8120hex | AI Settings Ch.3 | 17hex | User calibration offset
 |  |  | 18hex | User calibration gain
X06 | 8130hex | AI Settings Ch.4 | 17hex | User calibration offset
 |  |  | 18hex | User calibration gain


Anwender-Skalierung

Inbetriebnahme und Konfiguration [image] Analoge Eingänge [image] Abgleich und Skalierung [image] Anwender-Skalierung
Anwender-Skalierung
Die Übertragungsfunktion der Anwender-Skalierung lautet:
YS = GS * ( XS – OS )
YS : Messwert nach der Anwender-Skalierung
XS : Messwert vor der Anwender-Skalierung
GS : Gain
OS : Offset
Anwender-Skalierung aktivieren
Die Anwender-Skalierung ist werksseitig deaktiviert. Sie kann für jeden Kanal individuell aktiviert werden. Setzen Sie dazu den entsprechenden CoE-Parameter auf TRUE:
Anschluss | CoE-Objekt |  | Parameter
X01 | 8100hex | AI Settings Ch.1 | 01 | Enable user scale
X02 | 8110hex | AI Settings Ch.2 | 01 | Enable user scale
X05 | 8120hex | AI Settings Ch.3 | 01 | Enable user scale
X06 | 8130hex | AI Settings Ch.4 | 01 | Enable user scale
Skalierungs-Koeffizienten einstellen
Stellen Sie die Skalierungs-Koeffizienten über die folgen CoE-Parameter ein:
Anschluss | CoE-Objekt |  | Parameter
X01 | 8100hex | AI Settings Ch.1 | 11hex | User scale offset
 |  |  | 12hex | User scale gain
X02 | 8110hex | AI Settings Ch.2 | 11hex | User scale offset
 |  |  | 12hex | User scale gain
X05 | 8120hex | AI Settings Ch.3 | 11hex | User scale offset
 |  |  | 12hex | User scale gain
X06 | 8130hex | AI Settings Ch.4 | 11hex | User scale offset
 |  |  | 12hex | User scale gain


Analoge Ausgänge

Inbetriebnahme und Konfiguration [image] Analoge Ausgänge
Analoge Ausgänge
Weiterführende Informationen
•
Signalfluss
•
Ausgangs-Signalbereich
•
Verhalten bei Kommunikations-Unterbrechung: Watchdog
•
Abgleich und Skalierung


Signalfluss

Inbetriebnahme und Konfiguration [image] Analoge Ausgänge [image] Signalfluss
Signalfluss
Analoge Ausgänge Signalfluss
Signalfluss


Ausgangs-Signalbereich

Inbetriebnahme und Konfiguration [image] Analoge Ausgänge [image] Ausgangs-Signalbereich
Ausgangs-Signalbereich
Der Ausgangs-Signalbereich kann für jeden analogen Ausgang individuell gewählt werden.
Stellen Sie die Ausgangs-Signalbereiche in den folgenden CoE-Parametern ein:
Anschluss | CoE-Objekt |  | Parameter
X01 | 814Dhex | AO Advanced Settings Ch.1 | 11hex | Output Type
X02 | 815Dhex | AO Advanced Settings Ch.2 | 11hex | Output Type
X05 | 816Dhex | AO Advanced Settings Ch.3 | 11hex | Output Type
X06 | 817Dhex | AO Advanced Settings Ch.4 | 11hex | Output Type
Mögliche Werte
Wert | Ausgangs-Signalbereich
2dez (Werkseinstellung) | -10 … +10 V
14dez | 0 … 10 V
18dez | 0 … 20 mA
19dez | 4 … 20 mA
Beispiel
Output Type im CoE
CoE-Parameter "Output type" für den analogen Ausgang an Anschluss X01


Verhalten bei Kommunikations-Unterbrechung: Watchdog

Inbetriebnahme und Konfiguration [image] Analoge Ausgänge [image] Verhalten bei Kommunikations-Unterbrechung: Watchdog
Verhalten bei Kommunikations-Unterbrechung: Watchdog
Wenn die Kommunikation zwischen der SPS und den analogen Ausgängen unterbrochen wird, erhalten die analogen Ausgänge keine Vorgabe-Werte mehr.
Watchdogs überwachen die Kommunikation und können die Steuerung der analogen Ausgänge übernehmen, wenn die Kommunikation unterbrochen wird.
Es gibt zwei Watchdogs:
▪
Der „SM Watchdog“ überwacht die EtherCAT-Kommunikation.
▪
Der „PDI Watchdog“ überwacht die Kommunikation innerhalb des Moduls.
In der Werkseinstellung sind beide Watchdogs deaktiviert.
Weiterführende Informationen
•
Watchdog aktivieren
•
Reaktionszeit einstellen
•
Verhalten einstellen


Watchdog aktivieren

Inbetriebnahme und Konfiguration [image] Analoge Ausgänge [image] Verhalten bei Kommunikations-Unterbrechung: Watchdog [image] Watchdog aktivieren
Watchdog aktivieren
SmallWarningYellow VORSICHT
Aktoren können sich unerwartet in Bewegung setzen, wenn ein Watchdog aktiv ist
Verletzungen sind möglich.
1.
Im Solution Explorer unter dem Eintrag „I/O“ auf das IO-Modul EP4378-1022 klicken.
2.
Karteireiter „EtherCAT“ auswählen.
3.
Schaltfläche „Advanced Settings“ anklicken.
4.
Menüpunkt „Behaviour“ anklicken
5.
Bei „Set PDI Watchdog“ und/oder „Set SM Watchdog“ einen Haken setzen.
Watchdog aktivieren


Reaktionszeit einstellen

Inbetriebnahme und Konfiguration [image] Analoge Ausgänge [image] Verhalten bei Kommunikations-Unterbrechung: Watchdog [image] Reaktionszeit einstellen
Reaktionszeit einstellen
Die Reaktionszeit ist die Zeit zwischen dem Erkennen einer Kommunikations-Unterbrechung und der Reaktion des Watchdog: Wenn ein Watchdog eine Kommunikations-Unterbrechung erkennt, wartet er die Reaktionszeit ab, bevor er die Steuerung der analogen Ausgänge übernimmt.
Sie können die Reaktionszeit für jeden Watchdog individuell einstellen.
Wählen Sie die die Reaktionszeiten lang genug, um zu verhindern, dass die Watchdogs auch bei sehr kurzen, vorübergehenden Kommunikations-Unterbrechungen reagieren.
Die Reaktionszeiten werden mit dieser Formel berechnet:
tr = mw * (mb + 2) / 25 MHz
tr : Reaktionszeit eines Watchdogs
mw : Watchdog-Multiplier
mb : Basis-Multiplier (Werkseinstellung: 2498dez)
Reaktionszeiten der Watchdogs einstellen


Verhalten einstellen

Inbetriebnahme und Konfiguration [image] Analoge Ausgänge [image] Verhalten bei Kommunikations-Unterbrechung: Watchdog [image] Verhalten einstellen
Verhalten einstellen
Sie können das Verhalten jedes analogen Ausgangs bei einer Kommunikations-Unterbrechung in den folgenden CoE-Parametern einstellen:
Anschluss | CoE-Objekt |  | Parameter
X01 | 8140hex | AO Settings Ch.1 | 05hex | Watchdog
X02 | 8150hex | AO Settings Ch.2 | 05hex | Watchdog
X05 | 8160hex | AO Settings Ch.3 | 05hex | Watchdog
X06 | 8170hex | AO Settings Ch.4 | 05hex | Watchdog
Mögliche Werte
Wert | Enum | Beschreibung
0 (Werkseinstellung) | „Default watchdog value“ | Wenn die Reaktionszeit abgelaufen ist, setzt der Watchdog den Ausgang unverzüglich auf den Default-Wert (siehe unten).
1 | „Watchdog ramp“ | Lineare Rampe zu dem Default-Wert (siehe unten).
2 | „Last output value“ | Wert einfrieren: Der Ausgang gibt weiterhin den letzten Wert aus, der von der Steuerung empfangen wurde, bevor die Kommunikation unterbrochen wurde.
Default-Wert einstellen
Sie können den Default-Wert in den folgenden CoE-Parametern festlegen:
Anschluss | CoE-Objekt |  | Parameter
X01 | 8140hex | AO Settings Ch.1 | 13hex | Default output
X02 | 8150hex | AO Settings Ch.2 | 13hex | Default output
X05 | 8160hex | AO Settings Ch.3 | 13hex | Default output
X06 | 8170hex | AO Settings Ch.4 | 13hex | Default output
Rampe
Sie können festlegen, in welcher Zeit der Default-Wert erreicht wird, wenn das Watchdog-Verhalten auf den Wert 1 „Watchdog ramp“ eingestellt ist.
t = | naktuell - ndefault | / vrampe
t : Zeit in ms bis zum Erreichen des Default-Werts.
naktuell : der letzte Ausgangs-Wert, der vor der Kommunikations-Unterbrechung von der Steuerung empfangen wurde.
ndefault : Default-Wert (CoE-Parameter 81n0:13).
vrampe : Rampen-Geschwindigkeit in digits/ms (CoE-Parameter 81n0:14).


Abgleich und Skalierung

Inbetriebnahme und Konfiguration [image] Analoge Ausgänge [image] Abgleich und Skalierung
Abgleich und Skalierung
Weiterführende Informationen
•
Hersteller-Abgleich
•
Anwender-Abgleich
•
Anwender-Skalierung


Hersteller-Abgleich

Inbetriebnahme und Konfiguration [image] Analoge Ausgänge [image] Abgleich und Skalierung [image] Hersteller-Abgleich
Hersteller-Abgleich
Jeder analoge Ausgang wird werksseitig abgeglichen. Das Ergebnis des Abgleichs sind die Koeffizienten einer Korrekturfunktion. Die Korrekturfunktion lautet:
YV = GV * XV + OV
YV : Messwert nach dem Hersteller-Abgleich
XV : Messwert vor dem Hersteller-Abgleich
GV : Gain des Hersteller-Abgleichs
OV : Offset des Hersteller-Abgleichs
Die Koeffizienten GV und OV sind vom Benutzer nicht veränderbar. Wenn Sie einen Abgleich selbst durchführen wollen, nutzen Sie den Anwender-Abgleich.
Sie finden die Koeffizienten für die unterschiedlichen Ausgangs-Signalbereiche in den folgenden CoE-Objekten:
Anschluss | CoE-Objekt (nur Lesezugriff)
X01 | 814Fhex | AO Vendor data Ch.1
X02 | 815Fhex | AO Vendor data Ch.2
X05 | 816Fhex | AO Vendor data Ch.3
X06 | 817Fhex | AO Vendor data Ch.4
Hersteller-Abgleich deaktivieren
Hinweis
Ausgabefehler bei deaktiviertem Hersteller-Abgleich
Der in den technischen Daten angegebene Ausgabefehler ist nicht mehr gewährleistet, wenn Sie den Hersteller-Abgleich deaktivieren.
Wenn Sie den Anwender-Abgleich nutzen, kann es sinnvoll sein, den Hersteller-Abgleich zu deaktivieren.
Setzen Sie die folgenden CoE-Parameter auf FALSE, um den Hersteller-Abgleich für den jeweiligen Ausgang zu deaktivieren.
Anschluss | Objekt |  | Parameter
X01 | 8140hex | AO Settings Ch.1 | 08hex | Enable vendor calibration
X02 | 8150hex | AO Settings Ch.2 | 08hex | Enable vendor calibration
X05 | 8160hex | AO Settings Ch.3 | 08hex | Enable vendor calibration
X06 | 8170hex | AO Settings Ch.4 | 08hex | Enable vendor calibration


Anwender-Abgleich

Inbetriebnahme und Konfiguration [image] Analoge Ausgänge [image] Abgleich und Skalierung [image] Anwender-Abgleich
Anwender-Abgleich
Der Anwender-Abgleich ist dazu vorgesehen, das Gerät z.B. für einen kleineren Ausgangs-Signalbereich als den vom Hersteller abgeglichenen Bereich abzugleichen. Dadurch kann für den kleineren Ausgangs-Signalbereich eine höhere Genauigkeit erzielt werden.
Die Korrekturfunktion hat die gleiche Form wie die Korrekturfunktion des Hersteller-Abgleichs:
YU = GU * XU + OU
YU : Messwert nach dem Anwender-Abgleich
XU : Messwert vor dem Anwender-Abgleich
GU : Gain
OU : Offset
Anwender-Abgleich aktivieren
Der Anwender-Abgleich ist werksseitig deaktiviert. Er kann für jeden Ausgang individuell aktiviert werden. Setzen Sie dazu den entsprechenden CoE-Index auf TRUE:
Anschluss | CoE-Objekt |  | Parameter
X01 | 8140hex | AO Settings Ch.1 | 07hex | Enable user calibration
X02 | 8150hex | AO Settings Ch.2 | 07hex | Enable user calibration
X05 | 8160hex | AO Settings Ch.3 | 07hex | Enable user calibration
X06 | 8170hex | AO Settings Ch.4 | 07hex | Enable user calibration
Abgleichs-Koeffizienten einstellen
Stellen Sie die Abgleichs-Koeffizienten über die folgenden CoE-Parameter ein:
Anschluss | CoE-Objekt |  | Parameter
X01 | 8140hex | AO Settings Ch.1 | 15hex | User calibration offset
 |  |  | 16hex | User calibration gain
X02 | 8150hex | AO Settings Ch.2 | 15hex | User calibration offset
 |  |  | 16hex | User calibration gain
X05 | 8160hex | AO Settings Ch.3 | 15hex | User calibration offset
 |  |  | 16hex | User calibration gain
X06 | 8170hex | AO Settings Ch.4 | 15hex | User calibration offset
 |  |  | 16hex | User calibration gain


Anwender-Skalierung

Inbetriebnahme und Konfiguration [image] Analoge Ausgänge [image] Abgleich und Skalierung [image] Anwender-Skalierung
Anwender-Skalierung
Die Übertragungsfunktion der Anwender-Skalierung lautet:
YS = GS * XS + OS
YS : Messwert nach der Anwender-Skalierung
XS : Messwert vor der Anwender-Skalierung
GS : Gain
OS : Offset
Anwender-Skalierung aktivieren
Die Anwender-Skalierung ist werksseitig deaktiviert. Sie kann für jeden Kanal individuell aktiviert werden. Setzen Sie dazu den entsprechenden CoE-Parameter auf TRUE:
Anschluss | CoE-Objekt |  | Parameter
X01 | 8140hex | AO Settings Ch.1 | 01 | Enable user scale
X02 | 8150hex | AO Settings Ch.2 | 01 | Enable user scale
X05 | 8160hex | AO Settings Ch.3 | 01 | Enable user scale
X06 | 8170hex | AO Settings Ch.4 | 01 | Enable user scale
Skalierungs-Koeffizienten einstellen
Stellen Sie die Skalierungs-Koeffizienten über die folgen CoE-Parameter ein:
Anschluss | CoE-Objekt |  | Parameter
X01 | 8140hex | AO Settings Ch.1 | 11hex | User scale offset
 |  |  | 12hex | User scale gain
X02 | 8150hex | AO Settings Ch.2 | 11hex | User scale offset
 |  |  | 12hex | User scale gain
X05 | 8160hex | AO Settings Ch.3 | 11hex | User scale offset
 |  |  | 12hex | User scale gain
X06 | 8170hex | AO Settings Ch.4 | 11hex | User scale offset
 |  |  | 12hex | User scale gain


Wiederherstellen des Auslieferungszustandes

Inbetriebnahme und Konfiguration [image] Wiederherstellen des Auslieferungszustandes
Wiederherstellen des Auslieferungszustandes
Um den Auslieferungszustand der Backup-Objekte bei den ELxxxx-Klemmen / EPxxxx- und EPPxxxx-Boxen wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoE-Objekt Restore default parameters, Subindex 001 angewählt werden).
Auswahl des PDO Restore default parameters
Durch Doppelklick auf SubIndex 001 gelangen Sie in den Set Value -Dialog. Tragen Sie im Feld Dec den Wert 1684107116 oder alternativ im Feld Hex den Wert 0x64616F6C ein und bestätigen Sie mit OK.
Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.
Eingabe des Restore-Wertes im Set Value Dialog
Alternativer Restore-Wert
Bei einigen Modulen älterer Bauart lassen sich die Backup-Objekte mit einem alternativen Restore-Wert umstellen:
Dezimalwert: 1819238756
Hexadezimalwert: 0x6C6F6164
Eine falsche Eingabe des Restore-Wertes zeigt keine Wirkung!


Außerbetriebnahme

Inbetriebnahme und Konfiguration [image] Außerbetriebnahme
Außerbetriebnahme
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag!
Setzen Sie das Bus-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Demontage der Geräte beginnen!
Entsorgung
Zur Entsorgung muss das Gerät ausgebaut werden.
Gemäß der WEEE-Richtlinie 2012/19/EU nimmt Beckhoff Altgeräte und Zubehör in Deutschland zur fachgerechten Entsorgung zurück. Die Transportkosten werden vom Absender übernommen.
Senden Sie die Altgeräte mit dem Vermerk „zur Entsorgung“ an:
Beckhoff Automation GmbH & Co. KG
Abteilung Service
Stahlstraße 31
D-33415 Verl


CoE-Parameter

CoE-Parameter
CoE-Parameter
Weiterführende Informationen
•
Zugriff auf CoE-Parameter mit TwinCAT
•
Datenformat von CoE-Parametern
•
Objekt-Verzeichnis
•
Objekt-Beschreibung


Zugriff auf CoE-Parameter mit TwinCAT

CoE-Parameter [image] Zugriff auf CoE-Parameter mit TwinCAT
Zugriff auf CoE-Parameter mit TwinCAT
Manueller Zugriff auf das Parameter-Verzeichnis
Zugriff auf CoE-Parameter mit TwinCAT
➢
Voraussetzung: EP4378-1022 ist im Solution Explorer unter dem Menüpunkt „IO“ als IO-Modul vorhanden.
1.
Klicken Sie im „Solution Explorer“ auf das IO-Modul von EP4378-1022.
2.
Klicken Sie auf den Karteireiter „CoE – Online“.
⇨
Sie sehen das Parameter-Verzeichnis von EP4378-1022. Hier können Sie Parameter überprüfen und einstellen.


Datenformat von CoE-Parametern

CoE-Parameter [image] Datenformat von CoE-Parametern
Datenformat von CoE-Parametern
CoE-Parameter haben unterschiedliche Datenformate.
Im Kapitel Objekt-Beschreibung wird das Datenformat der CoE-Parameter durch Datentyp-Bezeichner spezifiziert:
Datentyp-Bezeichner | Format | Größe
BOOL | True / false | 8 bit
SINT | Short integer | 8 bit
USINT | Unsigned short integer | 8 bit
INT | Integer | 16 bit
UINT | Unsigned integer | 16 bit
DINT | Double integer | 32 bit
UDINT | Unsigned double integer | 32 bit
STRING | Zeichenkette | max. 255 Zeichen, 1 Byte pro Zeichen
Die Datentyp-Bezeichner entsprechen den Datentypen, die auch in TwinCAT in einem SPS-Programm verwendet werden können.


Objekt-Verzeichnis

CoE-Parameter [image] Objekt-Verzeichnis
Objekt-Verzeichnis
Index (hex) | Name
1000 | Device type
1008 | Device name
1009 | Hardware version
100A | Software version
100B | Bootloader version
1011 | Restore default parameters
1018 | Identity
10F0 | Backup parameter handling
1600 | DO RxPDO-Map Outputs
1601 | AO RxPDO-Map Standard Ch.1
1602 | AO RxPDO-Map Standard Ch.2
1603 | AO RxPDO-Map Standard Ch.3
1604 | AO RxPDO-Map Standard Ch.4
1801 | AI TxPDO-Par Standard Ch.1
1802 | AI TxPDO-Par Compact Ch.1
1803 | AI TxPDO-Par Standard Ch.2
1804 | AI TxPDO-Par Compact Ch.2
1805 | AI TxPDO-Par Standard Ch.3
1806 | AI TxPDO-Par Compact Ch.3
1807 | AI TxPDO-Par Standard Ch.4
1808 | AI TxPDO-Par Compact Ch.4
1A00 | DI TxPDO-Map Inputs
1A01 | AI TxPDO-Map Standard Ch.1
1A02 | AI TxPDO-Map Compact Ch.1
1A03 | AI TxPDO-Map Standard Ch.2
1A04 | AI TxPDO-Map Compact Ch.2
1A05 | AI TxPDO-Map Standard Ch.3
1A06 | AI TxPDO-Map Compact Ch.3
1A07 | AI TxPDO-Map Standard Ch.4
1A08 | AI TxPDO-Map Compact Ch.4
1C00 | Sync manager type
1C12 | RxPDO assign
1C13 | TxPDO assign
1C32 | SM output parameter
1C33 | SM input parameter
6000 | DI Inputs
6020 | AI Inputs Ch.1
6030 | AI Inputs Ch.2
6040 | AI Inputs Ch.3
6050 | AI Inputs Ch.4
Index (hex) | Name
7010 | DO Outputs
7060 | AO Outputs Ch.1
7070 | AO Outputs Ch.2
7080 | AO Outputs Ch.3
7090 | AO Outputs Ch.4
8020 | AI Settings Ch.1
802D | AI Advanced Settings Ch.1
802F | AI Vendor data Ch.1
8030 | AI Settings Ch.2
803D | AI Advanced Settings Ch.2
803F | AI Vendor data Ch.2
8040 | AI Settings Ch.3
804D | AI Advanced Settings Ch.3
804F | AI Vendor data Ch.3
8050 | AI Settings Ch.4
805D | AI Advanced Settings Ch.4
805F | AI Vendor data Ch.4
8060 | AO Settings Ch.1
806D | AO Advanced Settings Ch.1
806F | AO Vendor data Ch.1
8070 | AO Settings Ch.2
807D | AO Advanced Settings Ch.2
807F | AO Vendor data Ch.2
8080 | AO Settings Ch.3
808D | AO Advanced Settings Ch.3
808F | AO Vendor data Ch.3
8090 | AO Settings Ch.4
809D | AO Advanced Settings Ch.4
809F | AO Vendor data Ch.4
A020 | AI Diag data Ch.1
A030 | AI Diag data Ch.2
A040 | AI Diag data Ch.3
A050 | AI Diag data Ch.4
A060 | AO Diag data Ch.1
A070 | AO Diag data Ch.2
A080 | AO Diag data Ch.3
A090 | AO Diag data Ch.4
F000 | Modular device profile
F008 | Code word
F010 | Module list
F083 | BTN
FB00 | Command


Objekt-Beschreibung

CoE-Parameter [image] Objekt-Beschreibung
Objekt-Beschreibung
Weiterführende Informationen
•
Objekte zur Parametrierung
•
Standard-Objekte


Objekte zur Parametrierung

CoE-Parameter [image] Objekt-Beschreibung [image] Objekte zur Parametrierung
Objekte zur Parametrierung
Indizes 8100, 8110, 8120, 8130: AI Settings Ch.x
▪
8100hex AI Settings Ch.1: Einstellungen für den analogen Eingang an X01
▪
8110hex AI Settings Ch.2: Einstellungen für den analogen Eingang an X02
▪
8120hex AI Settings Ch.3: Einstellungen für den analogen Eingang an X05
▪
8130hex AI Settings Ch.4: Einstellungen für den analogen Eingang an X06
Zugriffsrechte: Lesen und Schreiben
Subindex (hex) | Name | Beschreibung | Einheit | Datentyp | Default
01 | Enable user scale | Anwender-Skalierung aktivieren. | - | BOOL | FALSE
02 | Presentation | Datenformat der Messwerte auswählen. | - | USINT | 0
06 | Enable filter | Digitales Filter aktivieren. | - | BOOL | FALSE
07 | Enable limit 1 | Die Grenzwert-Überwachung für den Grenzwert „Limit 1“ aktivieren. | - | BOOL | FALSE
08 | Enable limit 2 | Die Grenzwert-Überwachung für den Grenzwert „Limit 2“ aktivieren | - | BOOL | FALSE
0A | Enable user calibration | Anwender-Abgleich aktivieren. | - | BOOL | FALSE
0B | Enable vendor calibration | Hersteller-Abgleich aktivieren. | - | BOOL | TRUE
0E | Swap limit bits | Vergleichsoperation der Grenzwert-Überwachung umkehren. | - | BOOL | FALSE
11 | User scale offset | Offset-Wert für die Anwender-Skalierung. | - | INT | 0
12 | User scale gain | Gain-Wert für die Anwender-Skalierung. | - | DINT | 65536dez
13 | Limit 1 | Grenzwert „Limit 1“ für die Grenzwert-Überwachung. | - | INT | 0
14 | Limit 2 | Grenzwert „Limit 2“ für die Grenzwert-Überwachung. | - | INT | 0
15 | Filter settings | Typ des digitalen Filters auswählen. | - | UINT | 2
17 | User calibration offset | Offset-Wert für den Anwender-Abgleich. | - | INT | 0
18 | User calibration gain | Gain-Wert für den Anwender-Abgleich. | - | INT | 16384dez
Indizes 810D, 811D, 812D, 813D: AI Advanced Settings Ch.n
▪
810Dhex AI Advanced Settings Ch.1: Einstellungen für den analogen Eingang an X01
▪
811Dhex AI Advanced Settings Ch.2: Einstellungen für den analogen Eingang an X02
▪
812Dhex AI Advanced Settings Ch.3: Einstellungen für den analogen Eingang an X05
▪
813Dhex AI Advanced Settings Ch.4: Einstellungen für den analogen Eingang an X06
Zugriffsrechte: Lesen und Schreiben
Subindex (hex) | Name | Beschreibung | Einheit | Datentyp | Default
11 | Input Type | Messbereich einstellen. | - | UINT | 2
12 | Scaler | Nominellen oder technischen Messbereich auswählen. | - | UINT | 0
17 | Low Range Error | Untere Fehlerschwelle. Wenn der Messwert kleiner ist als dieser Parameter, wird das Status-Bit „Error“ gesetzt. | - | DINT | -32768dez
18 | High Range Error | Obere Fehlerschwelle. Wenn der Messwert kleiner ist als dieser Parameter, wird das Status-Bit „Error“ gesetzt. | - | DINT | 32767dez
Indizes 8140, 8150, 8160, 8170: AO Settings Ch.1
▪
8140hex AO Settings Ch.1: Einstellungen für den analogen Ausgang an X01
▪
8150hex AO Settings Ch.2: Einstellungen für den analogen Ausgang an X02
▪
8160hex AO Settings Ch.3: Einstellungen für den analogen Ausgang an X05
▪
8170hex AO Settings Ch.4: Einstellungen für den analogen Ausgang an X06
Zugriffsrechte: Lesen und Schreiben
Subindex (hex) | Name | Beschreibung | Einheit | Datentyp | Default
01 | Enable user scale | Anwender-Skalierung aktivieren. | - | BOOL | FALSE
02 | Presentation | Datenformat der Ausgabewerte auswählen. | - | USINT | 0
05 | Watchdog | Verhalten der analogen Ausgänge bei Kommunikations-Unterbrechung auswählen. | - | USINT | 0
07 | Enable user calibration | Anwender-Abgleich aktivieren. | - | BOOL | FALSE
08 | Enable vendor calibration | Hersteller-Abgleich aktivieren | - | BOOL | TRUE
11 | User scale offset | Offset-Wert der Anwender-Skalierung. | - | INT | 0
12 | User scale gain | Gain-Wert der Anwender-Skalierung. | - | DINT | 65535dez
13 | Default output | Watchdog-Verhalten auswählen. | - | INT | 0
14 | Default output ramp | Änderungsrate des Ausgabewerts.für das Watchdog-Verhalten „Watchdog ramp“ einstellen. | digits / ms | UINT | 65535dez
15 | User calibration offset | Offset-Wert des Anwender-Abgleichs. | - | INT | 0
16 | User calibration gain | Gain-Wert des Anwender-Abgleichs. | - | INT | 16384dez
Indizes 814D, 815D, 816D, 817D: AO Advanced Settings Ch.n
▪
814Dhex AO Advanced Settings Ch.1: Einstellungen für den analogen Ausgang an X01
▪
815Dhex AO Advanced Settings Ch.2: Einstellungen für den analogen Ausgang an X02
▪
816Dhex AO Advanced Settings Ch.3: Einstellungen für den analogen Ausgang an X05
▪
817Dhex AO Advanced Settings Ch.4: Einstellungen für den analogen Ausgang an X06
Zugriffsrechte: Lesen und Schreiben
Subindex (hex) | Name | Beschreibung | Einheit | Datentyp | Default
01 | Output type | Ausgangs-Signalbereich | - | UINT | 2


Standard-Objekte

CoE-Parameter [image] Objekt-Beschreibung [image] Standard-Objekte
Standard-Objekte
Index 1000 Device type
Zugriffsrechte: nur Lesen
Subindex (hex) | Name | Beschreibung | Einheit | Datentyp | Wert
- | Device type | Bit 0 .. 15: Geräteprofil-Nummer Bit 16 .. 31: Moduleprofil-Nummer (Geräteprofil-Nummer 5001: Modular Device Profile MDP) | - | UDINT | 5001dez
Index 1008 Device name
Zugriffsrechte: nur Lesen
Subindex (hex) | Name | Beschreibung | Einheit | Datentyp | Wert
- | Device name | Name des EtherCAT-Geräts | - | STRING | EP4378-1022
Index 1009 Hardware version
Zugriffsrechte: nur Lesen
Subindex (hex) | Name | Beschreibung | Einheit | Datentyp | Wert
- | Hardware version | Hardware-Version des EtherCAT-Geräts | - | STRING | 1)
1) Siehe Firm- und Hardware-Stände.
Index 100A Software version
Zugriffsrechte: nur Lesen
Subindex (hex) | Name | Beschreibung | Einheit | Datentyp | Wert
- | Software version | Firmware-Version des EtherCAT-Geräts | - | STRING | 1)
1) Siehe Firm- und Hardware-Stände.
Index 1018 Identity
Zugriffsrechte: nur Lesen
Subindex (hex) | Name | Beschreibung | Datentyp | Wert
01 | Vendor ID | Hersteller-Kennung (2: Beckhoff Automation) | UDINT | 2dez
02 | Product code | Produkt-Code | UDINT | 111A4052hex
03 | Revision | Bit 0 … 15: Kennzahl der Produkt-Variante Bit 16 … 31: Revision der Gerätebeschreibung (ESI) | UDINT | Bit 0 … 15: 1022dez
04 | Serial number | Reeserviert | UDINT | 0


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Hinweise zu analogen Spezifikationen
•
Allgemeine Betriebsbedingungen
•
Zubehör
•
Versionsidentifikation von EtherCAT-Geräten
•
Support und Service


Hinweise zu analogen Spezifikationen

Anhang [image] Hinweise zu analogen Spezifikationen
Hinweise zu analogen Spezifikationen
Beckhoff IO-Geräte (Klemmen, Boxen, Module) mit analogen Eingängen sind durch eine Reihe technischer Kenndaten charakterisiert, siehe dazu die Technischen Daten in den jeweiligen Dokumentationen.
Zur korrekten Interpretation dieser Kenndaten werden im Folgenden einige Erläuterungen gegeben.
Weiterführende Informationen
•
Messbereichsendwert (MBE)
•
Messfehler/ Messabweichung
•
Temperaturkoeffizient tK [ppm/K]
•
Typisierung SingleEnded / Differentiell
•
Gleichtaktspannung und Bezugsmasse (bezogen auf Differenzeingänge)
•
Spannungsfestigkeit
•
Zeitliche Aspekte der analog/digital Wandlung


Messbereichsendwert (MBE)

Anhang [image] Hinweise zu analogen Spezifikationen [image] Messbereichsendwert (MBE)
Messbereichsendwert (MBE)
Ein IO-Gerät mit analogem Eingang misst über einen nominellen Messbereich, der durch eine obere und eine untere Schranke (Anfangswert und Endwert) begrenzt wird die meist schon der Gerätebezeichnung entnommen werden kann.
Der Bereich zwischen beiden Schranken wird Messspanne genannt und entspricht der Formel (Endwert - Anfangswert). Entsprechend zu Zeigergeräten ist dies die Messskala (vgl. IEC 61131) oder auch der Dynamikumfang.
Für analoge IO-Geräte von Beckhoff gilt, dass als Messbereichsendwert (MBE) des jeweiligen Produkts (auch: Bezugswert) die betragsmäßig größte Schranke gewählt und mit positivem Vorzeichen versehen wird. Dies gilt für symmetrische und asymmetrische Messspannen.
Messbereichsendwert, Messspanne
Für die obigen Beispiele bedeutet dies:
▪
Messbereich 0...10 V: asymmetrisch unipolar, MBE = 10 V, Messspanne = 10 V
▪
Messbereich 4...20 mA: asymmetrisch unipolar, MBE = 20 mA, Messspanne = 16 mA
▪
Messbereich -200...1370°C: asymmetrisch bipolar, MBE = 1370°C, Messspanne = 1570°C
▪
Messbereich -10...+10 V: symmetrisch bipolar, MBE = 10 V, Messspanne = 20 V
Dies gilt entsprechend für analoge Ausgangsklemmen/ -boxen (bzw. verwandten Beckhoff‑Produktgruppen).


Messfehler/ Messabweichung

Anhang [image] Hinweise zu analogen Spezifikationen [image] Messfehler/ Messabweichung
Messfehler/ Messabweichung
Der relative Messfehler (% vom MBE) bezieht sich auf den MBE und wird berechnet als Quotient aus der zahlenmäßig größten Abweichung vom wahren Wert („Messfehler“) in Bezug auf den MBE.
Der Messfehler hat im Allgemeinen Gültigkeit für den gesamten zulässigen Betriebstemperaturbereich, auch „Gebrauchsfehlergrenze“ genannt und enthält zufällige und systematische Anteile auf das bezogene Gerät (also „alle“ Einflüsse wie Temperatur, Eigenrauschen, Alterung usw.).
Er ist immer als positiv/negativ-Spanne mit ± zu verstehen, auch wenn fallweise ohne ± angegeben.
Die maximale Abweichung kann auch direkt angegeben werden.
Beispiel: Messbereich 0...10 V und Messfehler < ± 0,3% MBE → maximale Abweichung ± 30 mV im zulässigen Betriebstemperaturbereich.
Geringerer Messfehler
Da diese Angabe auch die Temperaturdrift beinhaltet, kann bei Sicherstellung einer konstanten Umgebungstemperatur des Geräts und thermischer Stabilisierung in der Regel nach einem Anwenderabgleich von einem signifikant geringeren Messfehler ausgegangen werden.
Dies gilt entsprechend für analoge Ausgangsgeräte.


Temperaturkoeffizient tK [ppm/K]

Anhang [image] Hinweise zu analogen Spezifikationen [image] Temperaturkoeffizient tK [ppm/K]
Temperaturkoeffizient tK [ppm/K]
Eine elektronische Schaltung ist in der Regel mehr oder weniger temperaturabhängig. Im Bereich der analogen Messtechnik bedeutet dies, daß der mittels einer elektronischen Schaltung ermittelte Messwert reproduzierbar in seiner Abweichung vom „wahren“ Wert von der Umgebungs/Betriebstemperatur abhängig ist.
Lindern kann ein Hersteller dies durch Verwendung höherwertiger Bauteile oder Software-Maßnahmen.
Der von Beckhoff ggf. angegebene Temperaturkoeffizient erlaubt es dem Anwender den zu erwartenden Messfehler außerhalb der Grundgenauigkeit bei 23°C zu berechnen.
Aufgrund der umfangreichen Unsicherheitsbetrachtungen, die in die Bestimmungen der Grundgenauigkeit (bei 23°C) eingehen, empfiehlt Beckhoff eine quadratische Summierung.
Beispiel: Grundgenauigkeit bei 23°C sei ±0,01% typ. (MBE), tK = 20 ppm/K typ., gesucht ist die Genauigkeit G35 bei 35°C, somit ΔT = 12K
Anmerkungen:
ppm ≙ 10-6
% ≙ 10-2


Typisierung SingleEnded / Differentiell

Anhang [image] Hinweise zu analogen Spezifikationen [image] Typisierung SingleEnded / Differentiell
Typisierung SingleEnded / Differentiell
Beckhoff unterscheidet analoge Eingänge grundsätzlich in den zwei Typen Single-Ended (SE) und differentiell (DIFF) und steht hier für den unterschiedlichen elektrischen Anschluss bezüglich der Potenzialdifferenz.
In dieser Abbildung sind ein SE und ein DIFF-Modul als 2-kanalige Variante aufgezeigt, exemplarisch für alle mehrkanaligen Ausführungen.
SE und DIFF-Modul als 2-kanalige Variante
Hinweis: gestrichelte Linien bedeuten, dass diese Verbindung nicht unbedingt in jedem SE- oder DIFF-Modul vorhanden sein muss. Galvanisch getrennte Kanäle arbeiten grundsätzlich in differentieller Art, nur dass überhaupt kein direkter (galvanischer) Massebezug im Modul hergestellt ist. Spezifikationsangaben zu empfohlenen und maximalen Spannungen sind jeweils allerdings zu beachten.
Grundsätzlich gilt:
▪
Die analoge Messung erfolgt immer als Spannungsmessung zwischen zwei Potenzialpunkten.
Bei einer Spannungsmessung ist R groß gewählt, um eine hohe Impedanz zu gewährleisten, bei einer Strommessung ist R als Shunt niedrig gewählt. Ist der Messzweck eine Widerstandsbestimmung, erfolgt die Betrachtung entsprechend.
–
Dabei sind diese beiden Punkte bei Beckhoff üblicherweise als Input+/SignalPotenzial und Input-/BezugsPotenzial gekennzeichnet.
–
Für die Messung zwischen zwei Potenzialpunkten sind auch zwei Potenziale heranzuführen.
–
Bei den Begrifflichkeiten „1-Leiter-Anschluss“ oder „3-Leiter-Anschluss“ ist bezüglich der reinen Analog-Messung zu beachten: 3- oder 4-Leiter können zur Sensorversorgung dienen, haben aber mit der eigentlichen Analog-Messung nichts zu tun, diese findet immer zwischen zwei Potenzialen/Leitungen statt.
Dies gilt insbesondere auch für SE, auch wenn hier die Benennung suggeriert, dass nur eine Leitung benötigt wird.
▪
Es ist im Vorfeld der Begriff der "galvanischen Trennung" klarzustellen.
Beckhoff IO-Module verfügen über 1..8 oder mehr analoge Kanäle; bei Betrachtungen bezüglich des Kanalanschluss ist zu unterscheiden
–
wie sich die Kanäle INNERHALB eines Module zueinander stellen oder
–
wie sich die Kanäle MEHRERER Module zueinander stellen.
Ob die Kanäle zueinander direkt in Verbindung stehen wird u. a. mit der Eigenschaft der galvanischen Trennung spezifiziert.
–
Beckhoff Klemmen/ Boxen (bzw. verwandte Produktgruppen) sind immer mit einer galvanischen Trennung von Feld/Analog-Seite zu Bus/EtherCAT-Seite ausgerüstet. Wenn zwei analoge Klemmen/ Boxen also nicht über die Powerkontakte/ Powerleitung miteinander galvanisch verbunden sind, besteht faktisch eine galvanische Trennung zwischen den Modulen.
–
Falls Kanäle innerhalb eines Moduls galvanisch getrennt sind oder ein 1-Kanal-Modul keine Powerkontakte aufweist, handelt es sich faktisch immer um differentielle Kanäle, siehe dazu auch folgende Erläuterungen. Differentielle Kanäle sind nicht zwangsläufig galvanisch getrennt.
▪
Analoge Messkanäle unterliegen technischen Grenzen sowohl bezüglich des empfohlenen bestimmungsgemäßen Betriebsbereichs (Dauerbetrieb) als auch der Zerstörgrenze. Entsprechende Hinweise in den Dokumentationen zu den Klemmen/ Boxen sind zu beachten.
Erläuterung
▪
differentiell (DIFF)
–
Die differentielle Messung ist das flexibelste Konzept. Beide Anschlusspunkte Input+/SignalPotenzial und Input-/BezugsPotenzial sind vom Anwender im Potenzial im Rahmen der technischen Spezifikation frei wählbar.
–
Ein differentieller Kanal kann auch als SE betrieben werden, wenn das BezugsPotenzial von mehreren Sensoren verbunden wird. Dieser Verbindungspunkt kann auch Anlagen-GND sein.
–
Da ein differentieller Kanal intern symmetrisch aufgebaut ist (vgl. Abb. SE und DIFF-Modul als 2-kanalige Variante) stellt sich in der Mitte zwischen den beiden zugeführten Potenzialen ein Mittel-Potenzial ein (X), das gleichbedeutend mit dem internen Ground/Bezugsmasse dieses Kanals ist. Wenn mehrere DIFF-Kanäle ohne galvanische Trennung in einem Modul verbaut sind, kennzeichnet die technische Eigenschaft „UCM (common mode Spannung)“, wie weit die Kanäle in Ihrer Mittenspannung auseinander liegen dürfen.
–
Die interne Bezugsmasse kann ggf. als Anschlusspunkt an der Klemme/ Box zugänglich sein, um ein definiertes GND-Potenzial in der Klemme/ Box zu stabilisieren. Es ist allerdings dann besonders auf die Qualität dieses Potenzials (Rauschfreiheit, Spannungskonstanz) zu achten. An diesen GND-Punkt kann auch eine Leitung angeschlossen werden die dafür sorgt, dass bei der differentiellen Sensorleitung die UCM,max nicht überschritten wird.
Sind differentielle Kanäle nicht galvanisch getrennt, ist i. d. R nur eine UCM,max zulässig. Bei galvanischer Trennung sollte dieses Limit nicht vorhanden sein und die Kanäle dürfen nur bis zur spezifizierten Trennungsgrenze auseinander liegen.
–
Differentielle Messung in Kombination mit korrekter Sensorleitungsverlegung hat den besonderen Vorteil, dass Störungen die auf das Sensorkabel wirken (idealerweise sind Hin- und Rückleitung nebeneinander verlegt, so dass beide Leitungen von Störsignalen gleich getroffen werden) sehr wenig effektive Auswirkung auf die Messung haben, weil beide Leitungen gemeinsam (= common) im Potenzial verschoben werden - umgangssprachlich: Gleichtaktstörungen wirken auf beide Leitungen gleichzeitig in Amplitude und Phasenlage.
–
Trotzdem unterliegt die Unterdrückung von Gleichtaktstörungen innerhalb eines Kanals oder zwischen Kanälen technischen Grenzen, die in den technischen Daten spezifiziert sind.
–
Weitere hilfreiche Ergänzungen dazu sind der Dokumentationsseite Beschaltung von 0/4..20 mA Differenzeingängen (siehe z. B. Dokumentation zu den Klemmen EL30xx) zu entnehmen.
▪
Single Ended (SE)
–
Ist die Analog-Schaltung als SE konzipiert, ist die Input-/Bezugsleitung intern fest auf ein bestimmtes nicht änderbares Potenzial gelegt. Dieses Potenzial muss an mindestens einer Stelle der Klemme/ Box von außen zum Anschluss des Bezugspotenzials zugänglich sein, z. B. über die Powerkontakte/ Powerleitung.
–
SE bietet dem Anwender die Möglichkeit, bei mehreren Kanälen zumindest eine der beiden Sensorleitungen nicht bis zur Klemme/ Box zurückführen zu müssen wie bei DIFF, sondern die Bezugsleitung bereits an den Sensoren zusammenzufassen, z. B. im Anlagen-GND.
–
Nachteilig dabei ist, dass es über die getrennte Vor- und Rückleitung zu Spannungs/Stromveränderungen kommen kann, die von einem SE-Kanal nicht mehr erfasst werden können, s. Gleichtaktstörung. Ein UCM-Effekt kann nicht auftreten da die interne Schaltung der Kanäle eines Moduls ja immer durch Input-/Bezugspotenzial hart miteinander verbunden sind.
Typisierung 2/3/4-Leiter-Anschluss von Stromsensoren
Stromgeber/Sensoren/Feldgeräte (im Folgenden nur „Sensor“ genannt) mit der industriellen 0/4-20mA-Schnittstelle haben typisch eine interne Wandlungselektronik von der physikalischen Messgröße (Temperatur, Strom...) auf den Stromregelausgang. Diese interne Elektronik muss mit Energie (Spannung, Strom) versorgt werden. Die Zuleitungsart dieser Versorgung trennt die Sensoren somit in selbstversorgende oder extern versorgte Sensoren:
Selbstversorgende Sensoren
▪
Die Energie für den Eigenbetrieb bezieht der Sensor über die Sensor/Signal-Leitung + und – selbst.
Damit immer genug Energie für den Eigenbetrieb zur Verfügung steht und eine Drahtbrucherkennung möglich ist, wurde bei der 4-20mA-Schnittstelle als untere Grenze 4 mA festgelegt, d. h. minimal lässt der Sensor 4 mA, maximal 20 mA Strom passieren.
▪
2-Leiter-Anschluss siehe Abb. 2-Leiter-Anschluss, vgl. IEC60381-1
▪
Solche Stromgeber stellen i. d .R. eine Stromsenke dar, möchten also als „variable Last“ zwischen + und – sitzen. Vgl. dazu Angaben des Sensorherstellers.
2-Leiter-Anschluss
Sie sind deshalb nach der Beckhoff-Terminologie wie folgt anzuschließen:
bevorzugt an „single-ended“ Eingänge wenn die +Supply-Anschlüsse der Klemme/ Box gleich mitgenutzt werden sollen - anzuschließen an +Supply und Signal
sie können aber auch an „differentielle“ Eingänge angeschlossen werden, wenn der Schluss nach GND dann applikationsseitig selbst hergestellt wird – polrichtig anzuschließen an +Signal und –Signal
Unbedingt die Hinweisseite Beschaltung von 0/4..20 mA Differenzeingängen (siehe z. B. Dokumentation zu den Klemmen EL30xx) beachten!
Extern versorgte Sensoren
▪
3- und 4-Leiter-Anschluss siehe Abb. Anschluss extern versorgte Sensoren, vgl. IEC60381-1
▪
Die Energie/Betriebsspannung für den Eigenbetrieb bezieht der Sensor aus zwei eigenen Versorgungsleitungen. Für die Signalübertragung der Stromschleife werden ein oder zwei weitere Sensorleitungen verwendet:
–
1 Sensorleitung: nach der Beckhoff-Terminologie sind solche Sensoren an „single-ended“ Eingänge anzuschließen in 3 Leitungen mit +/-/Signal und ggf. FE/Schirm.
–
2 Sensorleitungen: Bei Sensoren mit 4-Leiter-Anschluss nach +Supply/-Supply/+Signal/-Signal ist zu prüfen ob der +Signal mit +Supply oder der –Signal-Anschluss mit –Supply verbunden werden darf.
Ja:
Dann kann entsprechend an einen Beckhoff „single-ended“ Eingang angeschlossen werden.
Nein:
es ist der Beckhoff „differentiell“ Eingang für +Signal und –Signal zu wählen, +Supply und –Supply sind über extra Leitungen anzuschließen.
Unbedingt die Hinweisseite Beschaltung von 0/4..20 mA Differenzeingängen (siehe z. B. Dokumentation zu den Klemmen EL30xx) beachten!
Hinweis: fachspezifische Organisationen wie NAMUR fordern einen nutzbaren Messbereich <4 mA/>20 mA zur Fehlererkennung und Justage, vgl. NAMUR NE043.
Es ist in der Beckhoff Gerätedokumentation einzusehen, ob das jeweilige Gerät solch einen erweiterten Signalbereich unterstützt.
Bei unipolaren Klemmen/ Boxen (und verwandten Produktgruppen) ist üblicherweise eine interne Diode vorhanden, dann ist die Polarität/Stromrichtung zu beachten:
Anschluss extern versorgte Sensoren
Einordnung der Beckhoff-Klemmen/ Boxen - Beckhoff 0/4-20mA Klemmen/ Boxen (und verwandten Produktgruppen) sind als differentiell und single-ended verfügbar:
Single-ended EL3x4x: 0-20 mA, EL3x5x: 4-20 mA, genauso KL und verwandten Produktgruppen | differentiell EL3x1x: 0-20 mA, EL3x2x: 4-20 mA, genauso KL und verwandten Produktgruppen
Stromvorzugsrichtung da interne Diode | Stromvorzugsrichtung da interne Diode
Sind für den Anschluss von extern versorgenden Sensoren im 3/4-Leiter-Anschluss konzipiert. | Die Klemme/ Box ist eine passive differentielle Strommessvorrichtung, „passiv“ bedeutet, dass keine Sensorspeisung erfolgt.
Sind für den Anschluss von selbstversorgenden Sensoren im 2-Leiter-Anschluss konzipiert |
Single-ended
Differential
2-, 3- und 4-Leiter-Anschluss an Single Ended - und Differenz Eingänge


Gleichtaktspannung und Bezugsmasse (bezogen auf Differenzeingänge)

Anhang [image] Hinweise zu analogen Spezifikationen [image] Gleichtaktspannung und Bezugsmasse (bezogen auf Differenzeingänge)
Gleichtaktspannung und Bezugsmasse (bezogen auf Differenzeingänge)
Gleichtaktspannung (CommonMode, Ucm) wird als der Mittelwert der Spannungen an den einzelnen Anschlüssen/Eingängen definiert und wird gegen eine Bezugsmasse gemessen/angegeben.
Gleichtaktspannung (Ucm)
Bei der Definition des zulässigen Gleichtaktspannungsbereiches und bei der Messung der Gleichtaktunterdrückung (CMRR, common mode rejection ratio) bei differenziellen Eingängen ist die Definition der Bezugsmasse wichtig.
Die Bezugsmasse ist auch das Potential, gegen welches der Eingangswiderstand und die Eingangsimpedanz bei single-ended-Eingängen bzw. der Gleichtaktwiderstand und die Gleichtaktimpedanz bei differenziellen Eingängen gemessen werden.
Die Bezugsmasse ist an/bei der Klemme/ Box i.d.R. zugänglich. Orte dafür können Klemmkontakte, Powerkontakte/ Powerleitung oder auch nur eine Tragschiene sein. Zur Verortung siehe Dokumentation, die Bezugsmasse sollte beim betrachteten Gerät angegeben sein.
Bei mehrkanaligen Klemmen/ Boxen mit resistiver (=direkter, ohmscher, galvanischer) oder kapazitiver Verbindung zwischen den Kanälen ist die Bezugsmasse vorzugsweise der Symmetriepunkt aller Kanäle, unter Betrachtung der Verbindungswiderstände.
Beispiele für Bezugsmassen bei Beckhoff IO Geräten:
1.
internes AGND (analog GND) herausgeführt:
EL3102/EL3112, resistive Verbindung der Kanäle untereinander
2.
0V-Powerkontakt:
EL3104/EL3114, resistive Verbindung der Kanäle untereinander an AGND, AGND niederohmig verbunden mit 0V-Powerkontakt
3.
Erde bzw. SGND (shield GND):
–
EL3174-0002: Kanäle haben keine resistive Verbindung untereinander, aber sind kapazitiv durch Ableitkondensatoren an SGND gekoppelt
–
EL3314: keine interne Masse auf die Klemmpunkte herausgeführt, aber kapazitive Kopplung an SGND


Spannungsfestigkeit

Anhang [image] Hinweise zu analogen Spezifikationen [image] Spannungsfestigkeit
Spannungsfestigkeit
Es ist zu unterscheiden zwischen:
▪
Spannungsfestigkeit (Zerstörgrenze): eine Überschreitung kann irreversible Veränderungen an der Elektronik zur Folge haben, Wertbetrachtung dabei
–
gegen eine festgelegte Bezugsmasse oder
–
differentiell
▪
Empfohlener Einsatzspannungsbereich: Bei einer Überschreitung kann nicht mehr von einem spezifikationsgemäßem Betrieb ausgegangen werden, Wertbetrachtung dabei
–
gegen eine festgelegte Bezugsmasse oder
–
differentiell
Empfohlener Einsatzspannungsbereich
Es können in den Gerätedokumentationen besondere Spezifikationsangaben dazu und zur Zeitangabe gemacht werden, unter Berücksichtigung von:
▪
Eigenerwärmung
▪
Nennspannung
▪
Isolationsfestigkeit
▪
Flankensteilheit der Anlege-Spannung bzw. Haltedauern
▪
Normatives Umfeld (z. B. PELV)


Zeitliche Aspekte der analog/digital Wandlung

Anhang [image] Hinweise zu analogen Spezifikationen [image] Zeitliche Aspekte der analog/digital Wandlung
Zeitliche Aspekte der analog/digital Wandlung
Die Umwandlung des stetigen analogen elektrischen Eingangssignals in eine wertdiskrete digitale und maschinenlesbare Form wird in den Beckhoff analogen Eingangsbaugruppen EL/KL/EP mit sog. ADC (analog digital converter) umgesetzt. Obgleich verschiedene ADC-Technologien gängig sind, haben sie alle aus Anwendersicht ein gemeinsames Merkmal: nach dem Ende der Umwandlung steht ein bestimmter digitaler Wert zur Weiterverarbeitung in der Steuerung bereit. Dieser Digitalwert, das sog. Analoge Prozessdatum, steht in einem festen zeitlichen Zusammenhang mit der „Ur-Größe“, dem elektrischen Eingangswert. Deshalb können für Beckhoff analoge Eingangsgeräte auch entsprechende zeitliche Kenndaten ermittelt und spezifiziert werden.
In diesen Prozess sind mehrere funktionale Komponenten involviert, die mehr oder weniger stark ausgeprägt in jeder AI (analog input) Baugruppe wirken:
▪
die elektrische Eingangsschaltung
▪
die Analog/Digital-Wandlung
▪
die digitale Weiterverarbeitung
▪
die finale Bereitstellung der Prozess- und Diagnosedaten zur Abholung an den Feldbus (EtherCAT, K-Bus etc.)
Signalverarbeitung Analogeingang
Aus Anwendersicht sind dabei zwei Aspekte entscheidend:
▪
„Wie oft bekomme ich neue Werte?“, also eine Sampling-Rate im Sinne einer Schnelligkeit in Bezug auf das Gerät/den Kanal
▪
Wieviel Verzögerung verursacht die (gesamte) AD-Wandlung des Gerätes/des Kanals?
Also Hard- und Firmware-Teile in toto. Aus technologischen Gründen muss zur Bestimmung dieser Angabe die Signalcharakteristik betrachtet werden: je nach Signalfrequenz kann es zu unterschiedlichen Laufzeiten durch das System kommen.
Dies ist die „äußere“ Betrachtung des Systems „Beckhoff AI Kanal“ – intern setzt sich insbesondere die Signalverzögerung aus den verschiedenen Anteilen Hardware, Verstärker, Wandlung selbst, Datentransport und Verarbeitung zusammen. Auch kann ggf. intern eine höhere Abtastrate verwendet werden (z.B. bei deltaSigma-Wandlern) als „außen“ aus Anwendersicht angeboten wird. Dies ist aber für ein nutzseitige Betrachtung der Komponente „Beckhoff AI Kanal“ normalerweise ohne Belang bzw. wird entsprechend spezifiziert, falls es doch für die Funktion relevant ist.
Damit können für Beckhoff AI Geräte folgende Spezifikationsangaben zum AI Kanal aus zeitlicher Sicht für den Anwender angegeben werden:
1. Minimale Wandlungszeit [ms, µs]
Dies ist der Kehrwert der maximalen Sampling-Rate [Sps, Samples per second]:
Gibt an, wie oft der analoge Kanal einen neu festgestellten Prozessdatenwert zur Abholung durch den Feldbus bereitstellt. Ob der Feldbus (EtherCAT, K-Bus) diesen dann auch genauso schnell (also im Gleichtakt), schneller (weil der AI Kanal im langsame FreeRun läuft) oder langsamer (z.B. bei Oversampling) abholt, ist dann eine Frage der Einstellung des Feldbusses und welche Betriebsmodi das AI Gerät unterstützt.
Bei EtherCAT Geräten zeigt das sog. ToggleBit bei den Diagnose-PDO an (indem es toggelt), dass ein neu ermittelter Analogwert vorliegt.
Entsprechend kann eine maximale Wandlungszeit, also eine minimal vom AI Gerät unterstützte Samplingrate spezifiziert werden.
Entspricht IEC 61131-2 Kap 7.10.2 2) „Abtast-Wiederholzeit“
2. Typ. Signalverzögerung
Entspricht IEC 61131-2 Kap 7.10.2 1) „Abtastdauer“. Sie inkludiert nach dieser Betrachtung alle geräteinternen Hard- und Firmware-Anteile, aber nicht „äußere“ Verzögerungsanteile aus dem Feldbus oder der Steuerung (TwinCAT).
Diese Verzögerung ist insbesondere relevant für absolute Zeitbetrachtungen, wenn AI Kanäle zum Amplitudenwert auch einen zugehörigen Zeitstempel (timestamp) mitliefern – von dem ja angenommen werden darf, dass er in seinem Zeitwert zu dem außen ehemals physikalisch anliegenden Amplitudenwert passt.
Aufgrund der frequenzabhängigen Laufzeit eines Signals, kann ein dezidierter Wert nur für ein gegebenes Signal spezifiziert werden. Der Wert ist auch abhängig von ggf. veränderlichen Filtereinstellungen des Kanals.
Eine typische Charakterisierung in der Gerätedokumentation kann sein:
2.1 Signalverzögerung (Sprungantwort)
Stichworte: Einschwingzeit
Das Rechtecksignal kann extern mit einem Frequenzgenerator (Impedanz beachten!) erzeugt werden.
Als Erkennungsschwelle wird die 90% Grenze verwendet.
Die Signalverzögerung [ms, µs] ist dann der zeitliche Abstand zwischen dem (idealen) elektrischen Rechtecksignal und der Zeitpunkt wo der analoge Prozesswert die 90% Amplitude erreicht hat.
Diagramm Signalverzögerung (Sprungantwort)
2.2 Signalverzögerung (linear)
Stichwort: Gruppenlaufzeit
Beschreibt die Verzögerung eines frequenzkonstanten Signals
Testsignal kann extern mit einem Frequenzgenerator erzeugt werden, z. B. als Sägezahn oder Sinus. Referenz wäre dann ein zeitgleiches Rechtecksignal.
Die Signalverzögerung [ms, µs] ist dann der zeitliche Abstand zwischen dem eingespeisten elektrischen Signal einer bestimmten Amplitude und dem Moment wo der analoge Prozesswert denselben Wert erreicht.
Dazu muss die Testfrequenz in einem sinnvollen Bereich gewählt werden; diese kann z. B. bei 1/20 der maximalen Sampling-Rate liegen.
Diagramm Signalverzögerung (linear)
3. Weitere Angaben
Weitere Angaben können in der Spezifikation optional angeführt sein, wie z. B.
▪
Tatsächliche Sampling-Rate des ADC (wenn unterschiedlich von der Kanal-Sampling-Rate)
▪
Zeit-Korrekturwerte für Laufzeiten bei unterschiedlichen Filtereinstellungen
▪
usw.


Allgemeine Betriebsbedingungen

Anhang [image] Allgemeine Betriebsbedingungen
Allgemeine Betriebsbedingungen
Schutzarten nach IP-Code
In der Norm IEC 60529 (DIN EN 60529) sind die Schutzgrade festgelegt und nach verschiedenen Klassen eingeteilt. Die Bezeichnung erfolgt in nachstehender Weise.
1. Ziffer: Staub- und Berührungsschutz | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen den Zugang zu gefährlichen Teilen mit dem Handrücken. Geschützt gegen feste Fremdkörper Ø 50 mm
2 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Finger. Geschützt gegen feste Fremdkörper Ø 12,5 mm
3 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Werkzeug. Geschützt gegen feste Fremdkörper Ø 2,5 mm
4 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Geschützt gegen feste Fremdkörper Ø 1 mm
5 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubgeschützt. Eindringen von Staub ist nicht vollständig verhindert, aber der Staub darf nicht in einer solchen Menge eindringen, dass das zufriedenstellende Arbeiten des Gerätes oder die Sicherheit beeinträchtigt wird
6 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubdicht. Kein Eindringen von Staub
2. Ziffer: Wasserschutz* | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen Tropfwasser
2 | Geschützt gegen Tropfwasser, wenn das Gehäuse bis zu 15° geneigt ist
3 | Geschützt gegen Sprühwasser. Wasser, das in einem Winkel bis zu 60° beiderseits der Senkrechten gesprüht wird, darf keine schädliche Wirkung haben
4 | Geschützt gegen Spritzwasser. Wasser, das aus jeder Richtung gegen das Gehäuse spritzt, darf keine schädlichen Wirkungen haben
5 | Geschützt gegen Strahlwasser.
6 | Geschützt gegen starkes Strahlwasser.
7 | Geschützt gegen die Wirkungen beim zeitweiligen Untertauchen in Wasser. Wasser darf nicht in einer Menge eintreten, die schädliche Wirkungen verursacht, wenn das Gehäuse für 30 Minuten in 1 m Tiefe in Wasser untergetaucht ist
*) In diesen Schutzklassen wird nur der Schutz gegen Wasser definiert.
Chemische Beständigkeit
Die Beständigkeit bezieht sich auf das Gehäuse der IP-67-Module und die verwendeten Metallteile. In der nachfolgenden Tabelle finden Sie einige typische Beständigkeiten.
Art | Beständigkeit
Wasserdampf | bei Temperaturen >100°C nicht beständig
Natriumlauge (ph-Wert > 12) | bei Raumtemperatur beständig > 40°C unbeständig
Essigsäure | unbeständig
Argon (technisch rein) | beständig
Legende
▪
beständig: Lebensdauer mehrere Monate
▪
bedingt beständig: Lebensdauer mehrere Wochen
▪
unbeständig: Lebensdauer mehrere Stunden bzw. baldige Zersetzung


Zubehör

Anhang [image] Zubehör
Zubehör
Befestigung
Bestellangabe | Beschreibung
ZS5300-0001 | Montageschiene (500 mm x 129 mm)
Leitungen
Bestellangabe | Beschreibung
ZK1090-3xxx-xxxx | EtherCAT-Leitung M8, grün Link zur Website
ZK1093-3xxx-xxxx | EtherCAT-Leitung M8, gelb Link zur Website
ZK2000-5xxx-xxxx ZK2000-71xx-xxxx | Sensorleitung M12 5-polig Link zur Website
ZK2000-6xxx-xxxx | Sensorleitung M12 4-polig Link zur Website
Eine vollständige Übersicht von vorkonfektionierten Leitungen für EtherCAT-Box-Module finden sie hier.
Beschriftungsmaterial, Schutzkappen
Bestellangabe | Beschreibung
ZS5000-0010 | Schutzkappe für M8-Buchsen, IP67 (50 Stück)
ZS5000-0020 | Schutzkappe M12, IP67 (50 Stück)
ZS5100-0000 | Beschriftungsschilder nicht bedruckt, 4 Streifen à 10 Stück
ZS5000-xxxx | Beschriftungsschilder bedruckt, auf Anfrage
Werkzeug
Bestellangabe | Beschreibung
ZB8801-0000 | Drehmoment-Schraubwerkzeug für Stecker, 0,4…1,0 Nm
ZB8801-0001 | Wechselklinge für M8 / SW9 für ZB8801-0000
ZB8801-0002 | Wechselklinge für M12 / SW13 für ZB8801-0000
ZB8801-0003 | Wechselklinge für M12 feldkonfektionierbar / SW18 für ZB8801-0000
Weiteres Zubehör
Weiteres Zubehör finden Sie in der Preisliste für Feldbuskomponenten von Beckhoff und im Internet auf https://www.beckhoff.de.


Versionsidentifikation von EtherCAT-Geräten

Anhang [image] Versionsidentifikation von EtherCAT-Geräten
Versionsidentifikation von EtherCAT-Geräten
Bezeichnung
Ein Beckhoff EtherCAT-Gerät hat eine 14stellige technische Bezeichnung, die sich zusammensetzt aus
▪
Familienschlüssel
▪
Typ
▪
Version
▪
Revision
Beispiel | Familie | Typ | Version | Revision
EL3314-0000-0016 | EL-Klemme (12 mm, nicht steckbare Anschlussebene) | 3314 (4 kanalige Thermoelementklemme) | 0000 (Grundtyp) | 0016
ES3602-0010-0017 | ES-Klemme (12 mm, steckbare Anschlussebene) | 3602 (2 kanalige Spannungsmessung) | 0010 (Hochpräzise Version) | 0017
CU2008-0000-0000 | CU-Gerät | 2008 (8 Port FastEthernet Switch) | 0000 (Grundtyp) | 0000
Hinweise
▪
die oben genannten Elemente ergeben die technische Bezeichnung, im Folgenden wird das Beispiel EL3314-0000-0016 verwendet.
▪
Davon ist EL3314-0000 die Bestellbezeichnung, umgangssprachlich bei „-0000“ dann oft nur EL3314 genannt. „-0016“ ist die EtherCAT-Revision.
▪
Die Bestellbezeichnung setzt sich zusammen aus
- Familienschlüssel (EL, EP, CU, ES, KL, CX, ...)
- Typ (3314)
- Version (-0000)
▪
Die Revision -0016 gibt den technischen Fortschritt wie z. B. Feature-Erweiterung in Bezug auf die EtherCAT Kommunikation wieder und wird von Beckhoff verwaltet.
Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders z. B. in der Dokumentation angegeben.
Jeder Revision zugehörig und gleichbedeutend ist üblicherweise eine Beschreibung (ESI, EtherCAT Slave Information) in Form einer XML-Datei, die zum Download auf der Beckhoff Webseite bereitsteht.
Die Revision wird seit 2014/01 außen auf den IP20-Klemmen aufgebracht, siehe Abb. „EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)“.
▪
Typ, Version und Revision werden als dezimale Zahlen gelesen, auch wenn sie technisch hexadezimal gespeichert werden.
Identifizierungsnummer
Beckhoff EtherCAT Geräte der verschiedenen Linien verfügen über verschiedene Arten von Identifizierungsnummern:
Produktionslos/Chargennummer/Batch-Nummer/Seriennummer/Date Code/D-Nummer
Als Seriennummer bezeichnet Beckhoff im IO-Bereich im Allgemeinen die 8-stellige Nummer, die auf dem Gerät aufgedruckt oder auf einem Aufkleber angebracht ist. Diese Seriennummer gibt den Bauzustand im Auslieferungszustand an und kennzeichnet somit eine ganze Produktions-Charge, unterscheidet aber nicht die Module einer Charge.
Aufbau der Seriennummer: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit
Ser. Nr.: 12063A02: 12 - Produktionswoche 12 06 - Produktionsjahr 2006 3A - Firmware-Stand 3A 02 - Hardware-Stand 02
Ausnahmen können im IP67-Bereich auftreten, dort kann folgende Syntax verwendet werden (siehe jeweilige Gerätedokumentation):
Syntax: D ww yy x y z u
D - Vorsatzbezeichnung
ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine
Beispiel: D.22081501 Kalenderwoche 22 des Jahres 2008 Firmware-Stand Busplatine: 1 Hardware Stand Busplatine: 5 Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig) Hardware-Stand E/A-Platine: 1
Eindeutige Seriennummer/ID, ID-Nummer
Darüber hinaus verfügt in einigen Serien jedes einzelne Modul über eine eindeutige Seriennummer.
Siehe dazu auch weiterführende Dokumentation im Bereich
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Klemmen mit Werkskalibrierzertifikat und andere Messtechnische Klemmen
Beispiele für Kennzeichnungen
EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer und Revisionskennzeichnung (seit 2014/01)
EK1100 EtherCAT Koppler, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer
CU2016 Switch mit Seriennummer/ Chargennummer
EL3202-0020 mit Seriennummer/ Chargennummer 26131006 und eindeutiger ID-Nummer 204418
EP1258-00001 IP67 EtherCAT Box mit Chargennummer/ DateCode 22090101 und eindeutiger Seriennummer 158102
EP1908-0002 IP67 EtherCAT Safety Box mit Chargennummer/ DateCode 071201FF und eindeutiger Seriennummer 00346070
EL2904 IP20 Safety Klemme mit Chargennummer/ DateCode 50110302 und eindeutiger Seriennummer 00331701
ELM3604-0002 Klemme mit eindeutiger ID-Nummer (QR Code) 100001051 und Seriennummer/ Chargennummer 44160201
Weiterführende Informationen
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Anhang [image] Versionsidentifikation von EtherCAT-Geräten [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
Der Beckhoff Identification Code (BIC) wird vermehrt auf Beckhoff-Produkten zur eindeutigen Identitätsbestimmung des Produkts aufgebracht. Der BIC ist als Data Matrix Code (DMC, Code-Schema ECC200) dargestellt, der Inhalt orientiert sich am ANSI-Standard MH10.8.2-2016.
Beckhoff Identification Code
BIC als Data Matrix Code (DMC, Code-Schema ECC200)
Die Einführung des BIC erfolgt schrittweise über alle Produktgruppen hinweg.
Er ist je nach Produkt an folgenden Stellen zu finden:
▪
auf der Verpackungseinheit
▪
direkt auf dem Produkt (bei ausreichendem Platz)
▪
auf Verpackungseinheit und Produkt
Der BIC ist maschinenlesbar und enthält Informationen, die auch kundenseitig für Handling und Produktverwaltung genutzt werden können.
Jede Information ist anhand des so genannten Datenidentifikators (ANSI MH10.8.2-2016) eindeutig identifizierbar. Dem Datenidentifikator folgt eine Zeichenkette. Beide zusammen haben eine maximale Länge gemäß nachstehender Tabelle. Sind die Informationen kürzer, werden sie um Leerzeichen ergänzt. Die Daten unter den Positionen 1 bis 4 sind immer vorhanden.
Folgende Informationen sind enthalten:
Pos-Nr. | Art der Information | Erklärung | Datenidentifikator | Anzahl Stellen inkl. Datenidentifikator | Beispiel
1 | Beckhoff-Artikelnummer | Beckhoff - Artikelnummer | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Eindeutige Seriennummer, Hinweis s. u. | S | 12 | SBTNk4p562d7
3 | Artikelbezeichnung | Beckhoff Artikelbezeichnung, z. B. EL1008 | 1K | 32 | 1KEL1809
4 | Menge | Menge in Verpackungseinheit, z. B. 1, 10… | Q | 6 | Q1
5 | Chargennummer | Optional: Produktionsjahr und -woche | 2P | 14 | 2P401503180016
6 | ID-/Seriennummer | Optional: vorheriges Seriennummer-System, z. B. bei Safety-Produkten oder kalibrierten Klemmen | 51S | 12 | 51S678294104
7 | Variante | Optional: Produktvarianten-Nummer auf Basis von Standardprodukten | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Weitere Informationsarten und Datenidentifikatoren werden von Beckhoff verwendet und dienen internen Prozessen.
Aufbau des BIC
Beispiel einer zusammengesetzten Information aus den Positionen 1 bis 4 und 6.
Die Datenidentifikatoren sind zur besseren Darstellung jeweils rot markiert:
BTN
Ein wichtiger Bestandteil des BICs ist die Beckhoff Traceability Number (BTN, Pos.-Nr. 2). Die BTN ist eine eindeutige, aus acht Zeichen bestehende Seriennummer, die langfristig alle anderen Seriennummern-Systeme bei Beckhoff ersetzen wird (z. B. Chargenbezeichungen auf IO-Komponenten, bisheriger Seriennummernkreis für Safety-Produkte, etc.). Die BTN wird ebenfalls schrittweise eingeführt, somit kann es vorkommen, dass die BTN noch nicht im BIC codiert ist.
Hinweis
Diese Information wurde sorgfältig erstellt. Das beschriebene Verfahren wird jedoch ständig weiterentwickelt. Wir behalten uns das Recht vor, Verfahren und Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern. Aus den Angaben, Abbildungen und Beschreibungen in dieser Information können keine Ansprüche auf Änderung geltend gemacht werden.


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.