EP4374-0002 - EtherCAT Box with analog inputs and outputs
Home


Foreword

Foreword
Foreword
Additional information
•
Safety instructions
•
Notes on the documentation
•
Documentation Issue Status


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Documentation Issue Status

Foreword [image] Documentation Issue Status
Documentation Issue Status
Version
Comment
2.4
▪
Front page updated
2.3
▪
Technical data corrected and sorted
▪
Optimizations
2.2
▪
Preliminary version
2.1
▪
Safety instructions new layout
▪
EP4374 - Introduction updated
▪
Chapter Montage updated
2.0
▪
Migration
1.1
▪
Power Connection updated
1.0
▪
First release
Firmware and hardware versions
This documentation refers to the firmware and hardware version that was applicable at the time the documentation was written.
The module features are continuously improved and developed further. Modules having earlier production statuses cannot have the same properties as modules with the latest status. However, existing properties are retained and are not changed, so that older modules can always be replaced with new ones.
Documentation | Firmware | Hardware
2.4 | 04 | 11
2.3 | 04 | 08
2.1 | 04 | 08
2.0 | 03 | 06
1.0 | 01 | 00
The firmware and hardware version (delivery state) can be found in the batch number (D-number) printed on the side of the EtherCAT Box.
Syntax of the batch number (D-number)
D: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with D no. 29 10 02 01:
29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01
Further information on this topic: Version identification of EtherCAT devices.


Product group: EtherCAT Box Modules

Product group: EtherCAT Box Modules
Product group: EtherCAT Box Modules
EtherCAT Box modules are I/O modules for industrial controllers.
They comply with protection class IP67 and are intended for use outside the control cabinet in wet, dirty or dusty industrial environments.
EtherCAT Box modules communicate with the controller via the EtherCAT fieldbus. They each have two connections for EtherCAT communication and for the power supply:
▪
Feed
▪
Downstream connection
This enables the cabling of EtherCAT Box modules in a line structure:
EtherCAT Box downstream connection example
EtherCAT Box modules: Example of cabling in a line structure


Product overview

Product overview
Product overview
Additional information
•
Introduction
•
Technical data
•
Scope of supply
•
Process image


Introduction

Product overview [image] Introduction
Introduction
EP4374-0002
EtherCAT Box with analog inputs and outputs
EP4374-0002 has two analog inputs and two analog outputs. The signal range can be individually parameterized for each analog input and output:
▪
-10 .. +10 V
▪
0 .. 10 V
▪
0 .. 20 mA
▪
4 .. 20 mA


Technical data

Product overview [image] Technical data
Technical data
Technical data
EP4374-0002
Fieldbus
Fieldbus
EtherCAT
Connection
2 x M8 socket, green
Electrical isolation
500 V (fieldbus / IO)
Process image
Inputs: 2 x 16 bit
Outputs: 2 x 16 bit
Supply
Connection
Feed: 1 x M8 plug, 4-pin
Downstream connection: 1 x M8 socket, 4-pin
Current carrying capacity of the connections
4 A per US and UP
Control voltage US
24 VDC (-15 % / +20 %)
Peripheral voltage UP
0 .. 30 VDC
Supply of the module electronics
from the control voltage US
Current consumption of the module
electronics
typically 120 mA
Sensor supply
(Analog input channels)
from the peripheral voltage UP,
not short-circuit protected
Actuator supply
(Analog output channels)
from the peripheral voltage UP,
not short-circuit protected
Analog inputs
Number
2
Connection
M12 sockets, 5-pin. Pin assignment
Signal range
Parameterizable:
▪
-10 .. +10 V (default)
▪
0 .. 10 V
▪
0 .. 20 mA
▪
4 .. 20 mA
Electrical specifications
Analog outputs
Number
2
Connection
M12 sockets, 5-pin. Pin assignment
Output signal range
Parameterizable:
▪
-10 .. +10 V (default)
▪
0 .. 10 V
▪
0 .. 20 mA
▪
4 .. 20 mA
Electrical specifications
Environmental conditions
Ambient temperature during operation
-25 .. +60 °C
0 .. +55 °C according to cURus
0 .. +55 °C according to ATEX
Ambient temperature during storage
-40 .. +85 °C
Vibration / shock resistance
conforms to EN 60068-2-6 / EN 60068-2-27;
see also Additional checks.
EMC immunity / emission
conforms to EN 61000-6-2 / EN 61000-6-4
Protection class
IP65, IP66, IP67 conforms to EN 60529
Technical data | EP4374-0002
Mechanics
Weight | approx. 165 g
Mounting position | variable
Approvals and conformity
Approvals | CE, cURus, ATEX
Analog inputs
The signal range can be switched during operation. The following table shows the electrical specifications depending on the selected signal range.
Technical data | Signal range
 | -10 .. 10 V | 0 .. 10 V | 0 .. 20 mA | 4 .. 20 mA
Input type | Differential
Input resistance | > 200 kΩ | > 200 kΩ | 85 Ω typ. + diode voltage | 85 Ω typ. + diode voltage
Digital resolution | 16-bit | 15-bit | 15-bit | 15-bit
Measuring error | < 0.3 % relative to full scale value
Conversion time | approx. 100 µs
Input filter limit frequency | 5 kHz
Value of the least significant bit | approx. 305 µV | approx. 305 µV | approx. 610 µA | approx. 488 µA
The analog inputs and outputs have a common analog ground potential. The analog ground potential is electrically isolated from all other ground potentials in the box.
Analog outputs
The output signal range can be switched during operation. The following table shows the electrical specifications depending on the selected output signal range.
Technical data | Output signal range
 | -10 .. 10 V | 0 .. 10 V | 0 .. 20 mA | 4 .. 20 mA
Load resistor / load | > 5 kΩ | > 5 kΩ | < 500 Ω | < 500 Ω
Digital resolution | 16-bit | 15-bit | 15-bit | 15-bit
Output error | < 0.1 % (ambient temperature 0 °C ... +55 °C) < 0.2 % (ambient temperature < 0 °C or > 55 °C) related to the final value.
Conversion time | approx. 40 µs
Value of the least significant bit | approx. 305 µV | approx. 305 µV | approx. 610 µA | approx. 488 µA
The analog inputs and outputs have a common analog ground potential. The analog ground potential is electrically isolated from all other ground potentials in the box.
Additional checks
The boxes have been subjected to the following checks:
Verification | Explanation
Vibration | 10 frequency sweeps in 3 axes
 | 5 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 35 g, 11 ms


Scope of supply

Product overview [image] Scope of supply
Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EP4374-0002 EtherCAT Box
▪
2x protective cap for EtherCAT socket, M8, green (pre-assembled)
▪
1x protective cap for supply voltage input, M8, transparent (pre-assembled)
▪
1x protective cap for supply voltage output, M8, black (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


Process image

Product overview [image] Process image
Process image
AI Inputs Channel 1
The data for the first analog channel can be found under AI Inputs Channel 1.
▪
Underrange: Value of the analog input is less than 0/4 mA or -10/0 V
▪
Overrange: Value of the analog input is greater than 20 mA or +10 V
▪
Limit 1: with activated limit 1 (object 0x80x0:07 = 1) means
1: value less than limit 1 (set in object 0x80x0:13)
2: value greater than limit 1 (set in object 0x80x0:13)
3: value equal to limit 1 (set in object 0x80x0:13)
▪
Limit 2: with activated limit 2 (object 0x80x0:08 = 1) means
1: value less than limit 2 (set in object 0x80x0:14)
2: value greater than limit 2 (set in object 0x80x0:14)
3: value equal to limit 2 (set in object 0x80x0:14)
▪
Error: This bit is set if overrange or underrange was detected.
AI Inputs Channel 2
The data of the second analog channel have the same structure as those of the first channel.
AO Outputs Channel 3
The data for the third analog channel can be found under AO Outputs Channel 3.
AO Outputs Channel 4
The data of the forth analog channel have the same structure as those of the third channel.


Mounting and cabling

Mounting and cabling
Mounting and cabling
Additional information
•
Mounting
•
Cabling
•
UL Requirements
•
ATEX notes


Mounting

Mounting and cabling [image] Mounting
Mounting
Additional information
•
Dimensions
•
Fixing


Dimensions

Mounting and cabling [image] Mounting [image] Dimensions
Dimensions
Dimensions
All dimensions are given in millimeters.
Housing features
Housing material | PA6 (polyamide)
Sealing compound | polyurethane
Mounting | two fastening holes Ø 3.5 mm for M3
Metal parts | brass, nickel-plated
Contacts | CuZn, gold-plated
Power feed through | max. 4 A
Installation position | variable
Protection class | IP65, IP66, IP67 (conforms to EN 60529) when screwed together
Dimensions (H x W x D) | approx. 126 x 30 x 26.5 mm (without connectors)


Fixing

Mounting and cabling [image] Mounting [image] Fixing
Fixing
Note
Dirt during assembly
Dirty connectors can lead to malfunctions. Protection class IP67 can only be guaranteed if all cables and connectors are connected.
•
Protect the plug connectors against dirt during the assembly.
Mount the module with two M3 screws on the fastening holes in the corners of the module. The fastening holes have no thread.


Cabling

Mounting and cabling [image] Cabling
Cabling
Guidelines
Follow these guidelines to ensure IP67 protection:
▪
Mount plugs with the torque values specified below. Use a torque wrench, e.g. Beckhoff ZB8801.
▪
Seal unused connectors with protective caps.
▪
Ensure the correct seating of pre-assembled protective caps.
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Connector overview
EP4374 Connector designations
Connector overview
Name | Function | Connector type | Tightening torque
1 | Analog inputs | M12 socket | 0.6 Nm 1)
2
3 | Analog outputs | M12 socket | 0.6 Nm 1)
4
X40 | EtherCAT input | M8 socket | 0.4 Nm 1)
X41 | EtherCAT-Weiterleitung | M8 socket | 0.4 Nm 1)
X60 | Supply voltage input | M8 plug connector | 0.4 Nm 1)
X61 | Supply voltage downstream connection | M8 socket | 0.4 Nm 1)
Additional information
•
Power supply
•
EtherCAT
•
Analog interfaces


Power supply

Mounting and cabling [image] Cabling [image] Power supply
Power supply
The EtherCAT Box is supplied with two supply voltages. The supply voltages are electrically isolated in the EtherCAT Box.
▪
The control voltage US is the supply voltage for:
–
processor logic
–
fieldbus logic
–
analog inputs and outputs
▪
The peripheral voltage UP is the supply voltage for:
–
External sensors: M12 sockets 1 and 2
–
External actuators: M12 sockets 3 and 4
Additional information
•
Connection
•
Status LEDs
•
Conductor losses


Connection

Mounting and cabling [image] Cabling [image] Power supply [image] Connection
Connection
Note
Supply voltages can destroy EtherCAT interfaces
Connectors for supply voltages have the same design as connectors for EtherCAT. They are not protected against mismating.
Avoid mismating.
Observe the color coding of the connectors:
Power supply: black
EtherCAT: green
Two M8 connectors at the low-end of the modules are used for feeding and routing the supply voltages:
▪
IN: left M8 connector for feeding the supply voltages
▪
OUT: right M8 connector for forwarding the supply voltages
Connections for power supply
Pin assignment
M8 connector
Pin | Voltage | Core colors 1)
1 | Control voltage US | Brown
2 | Peripheral voltage UP | White
3 | GNDS | Blue
4 | GNDP | Black
1) The core colors apply to Beckhoff ZK2020-xxxx-xxxx cables
Redirection of the supply voltages
The IN and OUT power connections are bridged in the module (not IP204x-Bxxx and IE204x). The supply voltages US and UP can thus easily be transferred from EtherCAT Box to EtherCAT Box.
Note
Pay attention to the maximum permissible current!
Pay attention also for the redirection of the supply voltages US and UP, the maximum permissible current for M8 connectors of 4 A must not be exceeded!


Status LEDs

Mounting and cabling [image] Cabling [image] Power supply [image] Status LEDs
Status LEDs
Connectors + LEDs
Status LEDs for the supply voltages
LED | Display | Meaning
US (control voltage) | off | Supply voltage US is not present
 | green illuminated | Supply voltage US is present
UP (peripheral voltage) | off | Supply voltage UP is not present
 | green illuminated | Supply voltage UP is present


Conductor losses

Mounting and cabling [image] Cabling [image] Power supply [image] Conductor losses
Conductor losses
Take into account the voltage drop on the supply line when planning a system. Avoid the voltage drop being so high that the supply voltage at the box lies below the minimum nominal voltage.
Variations in the voltage of the power supply unit must also be taken into account.
Voltage drop on the supply line
Leitungsverluste M8 2A
Leitungsverluste M8 4A


EtherCAT

Mounting and cabling [image] Cabling [image] EtherCAT
EtherCAT
Additional information
•
Connectors
•
Status LEDs
•
Cables


Connectors

Mounting and cabling [image] Cabling [image] EtherCAT [image] Connectors
Connectors
Note
Risk of confusion: supply voltages and EtherCAT
Defect possible through incorrect insertion.
•
Observe the color coding of the connectors:
black: Supply voltages
green: EtherCAT
EtherCAT Box Modules have two green M8 sockets for the incoming and downstream EtherCAT connections.
EtherCAT connectors
Connection
M8 socket, 4-pin – connection
M8 socket
EtherCAT | M8 connector | Core colors
Signal | Contact | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 and old versions of ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | 1 | yellow1) | orange/white | white/orange
Tx - | 4 | orange1) | orange | orange
Rx + | 2 | white1) | blue/white | white/green
Rx - | 3 | blue1) | blue | green
Shield | Housing | Shield | Shield | Shield
1) Core colors according to EN 61918
Adaptation of core colors for cables ZB9030, ZB9032 and ZK1090-3xxxx-xxxx
For standardization, the core colors of the ZB9030, ZB9032 and ZK1090-3xxx-xxxx cables have been changed to the EN61918 core colors: yellow, orange, white, blue. So there are different color codes in circulation. The electrical properties of the cables have been retained when the core colors were changed.


Status LEDs

Mounting and cabling [image] Cabling [image] EtherCAT [image] Status LEDs
Status LEDs
EtherCAT status LEDs
L/A (Link/Act)
A green LED labelled "L/A" is located next to each EtherCAT socket. The LED indicates the communication state of the respective socket:
LED | Meaning
off | no connection to the connected EtherCAT device
lit | LINK: connection to the connected EtherCAT device
flashes | ACT: communication with the connected EtherCAT device
Run
Each EtherCAT slave has a green LED labelled "Run". The LED signals the status of the slave in the EtherCAT network:
LED | Meaning
off | Slave is in "Init" state
flashes uniformly | Slave is in "Pre-Operational“ state
flashes sporadically | Slave is in "Safe-Operational" state
lit | Slave is in "Operational" state
Description of the EtherCAT slave states


Cables

Mounting and cabling [image] Cabling [image] EtherCAT [image] Cables
Cables
For connecting EtherCAT devices only shielded Ethernet cables that meet the requirements of at least category 5 (CAT5) according to EN 50173 or ISO/IEC 11801 should be used.
EtherCAT uses four wires for signal transmission.
Thanks to automatic line detection ("Auto MDI-X"), both symmetrical (1:1) or cross-over cables can be used between Beckhoff EtherCAT.
Detailed recommendations for the cabling of EtherCAT devices


Analog interfaces

Mounting and cabling [image] Cabling [image] Analog interfaces
Analog interfaces
Note
Signal ranges must be parameterized before carrying out the cabling
Defects possible due to incorrectly parameterized signal ranges.
•
Parameterize the signal ranges before connecting the sensors and actuators.
•
Parameterize the signal ranges in accordance with the specifications for the intended sensors and actuators.
Note
Risk of confusion: Inputs and outputs
Defects possible due to mixing up of inputs and outputs. The connectors of the inputs and outputs are of the same type.
•
Observe the names of the connectors in order to avoid mistakes.
Additional information
•
Connectors
•
Status LEDs
•
Samples


Connectors

Mounting and cabling [image] Cabling [image] Analog interfaces [image] Connectors
Connectors
M12 sockets
M12 socket
Pin | Inputs 1 and 2 |  | Outputs 3 and 4
 | Symbol | Description | Symbol | Description
1 | UP | Sensor supply + | Out | Analog output
2 | In + | Analog input + | UP | Actuator supply +
3 | GNDP | Sensor supply Ground | Out GND | Analog ground
4 | In - | Analog input - | GNDP | Actuator supply Ground
5 | Shield |  | Shield


Status LEDs

Mounting and cabling [image] Cabling [image] Analog interfaces [image] Status LEDs
Status LEDs
Status LEDs at the M12 connections
Status LEDs at M12 connections 1 and 2 (inputs)
Connection | LED | Display | Meaning
M12 socket no. 1 and 2 | R left | off | No data transfer to the D/A converter
 |  | green | Data transfer to the D/A converter
 | E right | off | Function OK
 |  | red | Error: Open circuit or measured value outside of the measuring range (smaller than 3.5 mA/-11 V or larger than 21 mA/11 V)
Correct function is indicated if the green Run LED is on and the red Error LED is off.
Status LEDs at M12 connections 3 and 4 (outputs)
Connection | LED | Display | Meaning
M12 socket no. 3 and 4 | R left | off | No data transfer to the D/A converter
 |  | green | Data transfer to the D/A converter


Samples

Mounting and cabling [image] Cabling [image] Analog interfaces [image] Samples
Samples
Analog inputs
Signal connection - Analog inputs
The sensor is connected via In+ and In-. The sensor can optionally be operated/supplied with 24 VDC.
Analog outputs
Signal connection - Analog outputs
The actuator is connected via output +/- and output GND. The actuator can optionally be operated/supplied with 24 VDC.


UL Requirements

Mounting and cabling [image] UL Requirements
UL Requirements
The installation of the EtherCAT Box Modules certified by UL has to meet the following requirements.
Supply voltage
SmallWarningYellow CAUTION
CAUTION!
This UL requirements are valid for all supply voltages of all marked EtherCAT Box Modules!
For the compliance of the UL requirements the EtherCAT Box Modules should only be supplied
•
by a 24 VDC supply voltage, supplied by an isolating source and protected by means of a fuse (in accordance with UL248), rated maximum 4 Amp, or
•
by a 24 VDC power source, that has to satisfy NEC class 2.
A NEC class 2 power supply shall not be connected in series or parallel with another (class 2) power source!
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, the EtherCAT Box Modules must not be connected to unlimited power sources!
Networks
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, EtherCAT Box Modules must not be connected to telecommunication networks!
Ambient temperature range
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, EtherCAT Box Modules has to be operated only at an ambient temperature range of 0 to 55°C!
Marking for UL
All EtherCAT Box Modules certified by UL (Underwriters Laboratories) are marked with the following label.
UL label


ATEX notes

Mounting and cabling [image] ATEX notes
ATEX notes
Additional information
•
ATEX - Special conditions
•
BG2000 - EtherCAT Box protection enclosures
•
ATEX Documentation


ATEX - Special conditions

Mounting and cabling [image] ATEX notes [image] ATEX - Special conditions
ATEX - Special conditions
SmallWarningYellow WARNING
Observe the special conditions for the intended use of EtherCAT Box modules in potentially explosive areas – directive 94/9/EU.
•
The certified components are to be installed with a BG2000-0000 or BG2000-0010 protection enclosure that guarantees a protection against mechanical hazards!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of 0 to 55°C for the use of EtherCAT Box modules in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0: 2006
▪
EN 60079-15: 2005
Marking
The EtherCAT Box modules certified for potentially explosive areas bear the following marking:
II 3 G Ex nA II T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
or
II 3 G Ex nA nC IIC T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
Batch number (D number)
The EtherCAT Box modules bear a batch number (D number) that is structured as follows:
D: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with batch number 29 10 02 01:
29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01


BG2000 - EtherCAT Box protection enclosures

Mounting and cabling [image] ATEX notes [image] BG2000 - EtherCAT Box protection enclosures
BG2000 - EtherCAT Box protection enclosures
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the EtherCAT system into a safe, powered down state before starting installation, disassembly or wiring of the modules!
ATEX
SmallWarningYellow WARNING
Mount a protection enclosure!
To fulfill the special conditions according to ATEX, a BG2000-0000 or BG2000-0010 protection enclosure has to be mounted over the EtherCAT Box.
Installation
Put the cables for EtherCAT, power supply and sensors/actuators through the hole of the protection enclosure.
BG2000 - putting the cables
Fix the wires for EtherCAT, power supply and sensors/actuators to the EtherCAT Box.
BG2000 - fixing the cables
Mount the protection enclosure over the EtherCAT Box.
BG2000 - mounting the protection enclosure


ATEX Documentation

Mounting and cabling [image] ATEX notes [image] ATEX Documentation
ATEX Documentation
Notes about operation of EtherCAT Box Modules (EPxxxx-xxxx) in potentially explosive areas (ATEX)
Pay also attention to the continuative documentationNotes about operation of EtherCAT Box Modules (EPxxxx-xxxx) in potentially explosive areas (ATEX) that is available in the download area of the Beckhoff homepage http:\\www.beckhoff.com!


Commissioning and configuration

Commissioning and configuration
Commissioning and configuration
Additional information
•
Configuration in TwinCAT
•
Parameterize signal ranges
•
Object overview
•
Object description and parameterization
•
Restoring the delivery state


Configuration in TwinCAT

Commissioning and configuration [image] Configuration in TwinCAT
Configuration in TwinCAT
An EtherCAT Box must be configured in TwinCAT so that its functions can be used in a PLC program.
The following link will take you to a quick start guide describing the configuration of an EtherCAT Box in TwinCAT:
https://infosys.beckhoff.com/content/1033/epioconfiguration/index.html?id=6991403443235907429


Parameterize signal ranges

Commissioning and configuration [image] Parameterize signal ranges
Parameterize signal ranges
Note
Signal ranges must be parameterized before carrying out the cabling
Defects possible due to incorrectly parameterized signal ranges.
•
Parameterize the signal ranges before connecting the sensors and actuators.
•
Parameterize the signal ranges in accordance with the specifications for the intended sensors and actuators.
The signal range can be individually parameterized for each analog input and output. The parameters that define the signal range are located in the CoE directory:
Interface | CoE Index
Analog input „1“ | F800:01
Analog input „2“ | F800:02
Analog output „3“ | F800:03
Analog output „4“ | F800:04
TwinCAT
Proceed as follows to change the signal range of an analog channel in TwinCAT:
1.
Double-click the IO module EP4374-0002 in the IO tree.
2.
Click on the "CoE - Online" tab.
⇨
The CoE directory is displayed
3.
Search the CoE directory for the index F800:0.
4.
Click on the "+" symbol to the left of Index F800:0.
⇨
The sub-indices of F800:0 are displayed.
5.
Double-click on the subindex of the interface whose signal range you want to change.
⇨
A dialog box "Set Value Dialog" opens.
6.
Select the signal range from the "Enum" drop-down menu.


Object overview

Commissioning and configuration [image] Object overview
Object overview
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Index (hex) |  | Name | Flags | Default value
1000 |  | Device type | RO | 0x00001389 (5001dec)
1008 |  | Device name | RO | EP4374-0002
1009 |  | Hardware version | RO | 00
100A |  | Software version | RO | 02
1011:0 | Subindex | Restore default parameters | RO | 0x01 (1dec)
 | 1011:01 | SubIndex 001 | RW | 0x00000000 (0dec)
1018:0 | Subindex | Identity | RO | 0x04 (4dec)
 | 1018:01 | Vendor ID | RO | 0x00000002 (2dec)
 | 1018:02 | Product code | RO | 0x11164052 (286670930dec)
 | 1018:03 | Revision | RO | 0x00110002 (1114114dec)
 | 1018:04 | Serial number | RO | 0x00000000 (0dec)
10F0:0 | Subindex | Backup parameter handling | RO | 0x01 (1dec)
 | 10F0:01 | Checksum | RO | 0x00000000 (0dec)
1600:0 | Subindex | AO Outputs Ch.3 | RO | 0x01 (1dec)
 | 1600:01 | SubIndex 001 | RO | 0x7020:11, 16
1601:0 | Subindex | AO Outputs Ch.4 | RO | 0x01 (1dec)
 | 1601:01 | SubIndex 001 | RO | 0x7030:11, 16
1800:0 | Subindex | AI Inputs Ch.1 | RO | 0x06 (6dec)
 | 1800:06 | Exclude TxPDOs | RO | 01 1A
1801:0 | Subindex | AI Inputs Compact Ch.1 | RO | 0x06 (6dec)
 | 1801:06 | Exclude TxPDOs | RO | 00 1A
1802:0 | Subindex | AI Inputs Ch.2 | RO | 0x06 (6dec)
 | 1802:06 | Exclude TxPDOs | RO | 03 1A
1803:0 | Subindex | AI Inputs Compact Ch.2 | RO | 0x06 (6dec)
 | 1803:06 | Exclude TxPDOs | RO | 02 1A
1A00:0 | Subindex | AI Inputs Ch.1 | RO | 0x0B (11dec)
 | 1A00:01 | SubIndex 001 | RO | 0x6000:01, 1
 | 1A00:02 | SubIndex 002 | RO | 0x6000:02, 1
 | 1A00:03 | SubIndex 003 | RO | 0x6000:03, 2
 | 1A00:04 | SubIndex 004 | RO | 0x6000:05, 2
 | 1A00:05 | SubIndex 005 | RO | 0x6000:07, 1
 | 1A00:06 | SubIndex 006 | RO | 0x0000:00, 1
 | 1A00:07 | SubIndex 007 | RO | 0x0000:00, 5
 | 1A00:08 | SubIndex 008 | RO | 0x6000:0E, 1
 | 1A00:09 | SubIndex 009 | RO | 0x6000:0F, 1
 | 1A00:0A | SubIndex 010 | RO | 0x6000:10, 1
 | 1A00:0B | SubIndex 011 | RO | 0x6000:11, 16
Index (hex) |  | Name | Flags | Default value
1A01:0 | Subindex | AI Inputs Compact Ch.1 | RO | 0x01 (1dec)
 | 1A01:01 | SubIndex 001 | RO | 0x6000:11, 16
1A02:0 | Subindex | AI Inputs Ch.2 | RO | 0x0B (11dec)
 | 1A02:01 | SubIndex 001 | RO | 0x6010:01, 1
 | 1A02:02 | SubIndex 002 | RO | 0x6010:02, 1
 | 1A02:03 | SubIndex 003 | RO | 0x6010:03, 2
 | 1A02:04 | SubIndex 004 | RO | 0x6010:05, 2
 | 1A02:05 | SubIndex 005 | RO | 0x6010:07, 1
 | 1A02:06 | SubIndex 006 | RO | 0x0000:00, 1
 | 1A02:07 | SubIndex 007 | RO | 0x0000:00, 5
 | 1A02:08 | SubIndex 008 | RO | 0x6010:0E, 1
 | 1A02:09 | SubIndex 009 | RO | 0x6010:0F, 1
 | 1A02:0A | SubIndex 010 | RO | 0x6010:10, 1
 | 1A02:0B | SubIndex 011 | RO | 0x6010:11, 16
1A03:0 | Subindex | AI Inputs Compact Ch.2 | RO | 0x01 (1dec)
 | 1A03:01 | SubIndex 001 | RO | 0x6010:11, 16
1C00:0 | Subindex | Sync manager type | RO | 0x04 (4dec)
 | 1C00:01 | SubIndex 001 | RO | 0x01 (1dec)
 | 1C00:02 | SubIndex 002 | RO | 0x02 (2dec)
 | 1C00:03 | SubIndex 003 | RO | 0x03 (3dec)
 | 1C00:04 | SubIndex 004 | RO | 0x04 (4dec)
1C12:0 | Subindex | RxPDO assign | RW | 0x02 (2dec)
 | 1C12:01 | SubIndex 001 | RW | 0x1600 (5632dec)
 | 1C12:02 | SubIndex 002 | RW | 0x1601 (5633dec)
1C13:0 | Subindex | TxPDO assign | RW | 0x02 (2dec)
 | 1C13:01 | SubIndex 001 | RW | 0x1A00 (6656dec)
 | 1C13:02 | SubIndex 002 | RW | 0x1A02 (6658dec)
1C32:0 | Subindex | SM output parameter | RO | 0x20 (32dec)
 | 1C32:01 | Sync mode | RW | 0x0001 (1dec)
 | 1C32:02 | Cycle time | RW | 0x000F4240 (1000000dec)
 | 1C32:03 | Shift time | RO | 0x00002710 (10000dec)
 | 1C32:04 | Sync modes supported | RO | 0xC007 (49159dec)
 | 1C32:05 | Minimum cycle time | RO | 0x0007A120 (500000dec)
 | 1C32:06 | Calc and copy time | RO | 0x00001388 (5000dec)
 | 1C32:07 | Minimum delay time | RO | 0x00001388 (5000dec)
 | 1C32:08 | Command | RW | 0x0000 (0dec)
 | 1C32:09 | Maximum delay time | RO | 0x00001388 (5000dec)
 | 1C32:0B | SM event missed counter | RO | 0x0000 (0dec)
 | 1C32:0C | Cycle exceeded counter | RO | 0x0000 (0dec)
 | 1C32:0D | Shift too short counter | RO | 0x0000 (0dec)
 | 1C32:20 | Sync error | RO | 0x00 (0dec)
Index (hex) |  | Name | Flags | Default value
1C33:0 | Subindex | SM input parameter | RO | 0x20 (32dec)
 | 1C33:01 | Sync mode | RW | 0x0022 (34dec)
 | 1C33:02 | Cycle time | RW | 0x000F4240 (1000000dec)
 | 1C33:03 | Shift time | RO | 0x00001388 (5000dec)
 | 1C33:04 | Sync modes supported | RO | 0xC007 (49159dec)
 | 1C33:05 | Minimum cycle time | RO | 0x0007A120 (500000dec)
 | 1C33:06 | Calc and copy time | RO | 0x00002710 (10000dec)
 | 1C33:07 | Minimum delay time | RO | 0x00001388 (5000dec)
 | 1C33:08 | Command | RW | 0x0000 (0dec)
 | 1C33:09 | Maximum delay time | RO | 0x00001388 (5000dec)
 | 1C33:0B | SM event missed counter | RO | 0x0000 (0dec)
 | 1C33:0C | Cycle exceeded counter | RO | 0x0000 (0dec)
 | 1C33:0D | Shift too short counter | RO | 0x0000 (0dec)
 | 1C33:20 | Sync error | RO | 0x00 (0dec)
6000:0 | Subindex | AI Inputs Ch.1 | RO | 0x11 (17dec)
 | 6000:01 | Underrange | RO | 0x00 (0dec)
 | 6000:02 | Overrange | RO | 0x00 (0dec)
 | 6000:03 | Limit 1 | RO | 0x00 (0dec)
 | 6000:05 | Limit 2 | RO | 0x00 (0dec)
 | 6000:07 | Error | RO | 0x00 (0dec)
 | 6000:0E | Sync error | RO | 0x00 (0dec)
 | 6000:0F | TxPDO State | RO | 0x00 (0dec)
 | 6000:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6000:11 | Value | RO | 0x0000 (0dec)
6010:0 | Subindex | AI Inputs Ch.2 | RO | 0x11 (17dec)
 | 6010:01 | Underrange | RO | 0x00 (0dec)
 | 6010:02 | Overrange | RO | 0x00 (0dec)
 | 6010:03 | Limit 1 | RO | 0x00 (0dec)
 | 6010:05 | Limit 2 | RO | 0x00 (0dec)
 | 6010:07 | Error | RO | 0x00 (0dec)
 | 6010:0E | Sync error | RO | 0x00 (0dec)
 | 6010:0F | TxPDO State | RO | 0x00 (0dec)
 | 6010:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6010:11 | Value | RO | 0x0000 (0dec)
Index (hex) |  | Name | Flags | Default value
7020:0 | Subindex | AO Outputs Ch.3 | RO | 0x11 (17dec)
 | 7020:11 | Analog output | RO | 0x0000 (0dec)
7030:0 | Subindex | AO Outputs Ch.4 | RO | 0x11 (17dec)
 | 7030:11 | Analog output | RO | 0x0000 (0dec)
8000:0 | Subindex | AI Settings Ch.1 | RW | 0x18 (24dec)
 | 8000:01 | Enable user scale | RW | 0x00 (0dec)
 | 8000:02 | Presentation | RW | 0x00 (0dec)
 | 8000:05 | Siemens bits | RW | 0x00 (0dec)
 | 8000:06 | Enable filter | RW | 0x00 (0dec)
 | 8000:07 | Enable limit 1 | RW | 0x00 (0dec)
 | 8000:08 | Enable limit 2 | RW | 0x00 (0dec)
 | 8000:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8000:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 8000:0E | Swap limit bits | RW | 0x00 (0dec)
 | 8000:11 | User scale offset | RW | 0x0000 (0dec)
 | 8000:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 8000:13 | Limit 1 | RW | 0x0000 (0dec)
 | 8000:14 | Limit 2 | RW | 0x0000 (0dec)
 | 8000:15 | Filter settings | RW | 0x0000 (0dec)
 | 8000:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8000:18 | User calibration gain | RW | 0x4000 (16384dec)
800E:0 | Subindex | AI Internal data Ch.1 | RO | 0x01 (1dec)
 | 800E:01 | ADC raw value | RO | 0x0000 (0dec)
800F:0 | Subindex | AI Vendor data Ch.1 | RW | 0x06 (6dec)
 | 800F:01 | R0 offset | RW | 0x0000 (0dec)
 | 800F:02 | R0 gain | RW | 0x4000 (16384dec)
 | 800F:03 | R1 offset | RW | 0x0000 (0dec)
 | 800F:04 | R1 gain | RW | 0x4000 (16384dec)
 | 800F:05 | R2 offset | RW | 0x0000 (0dec)
 | 800F:06 | R2 gain | RW | 0x4000 (16384dec)
8010:0 | Subindex | AI Settings Ch.2 | RW | 0x18 (24dec)
 | 8010:01 | Enable user scale | RW | 0x00 (0dec)
 | 8010:02 | Presentation | RW | 0x00 (0dec)
 | 8010:05 | Siemens bits | RW | 0x00 (0dec)
 | 8010:06 | Enable filter | RW | 0x00 (0dec)
 | 8010:07 | Enable limit 1 | RW | 0x00 (0dec)
 | 8010:08 | Enable limit 2 | RW | 0x00 (0dec)
 | 8010:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8010:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 8010:0E | Swap limit bits | RW | 0x00 (0dec)
 | 8010:11 | User scale offset | RW | 0x0000 (0dec)
 | 8010:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 8010:13 | Limit 1 | RW | 0x0000 (0dec)
 | 8010:14 | Limit 2 | RW | 0x0000 (0dec)
 | 8010:15 | Filter settings | RW | 0x0000 (0dec)
 | 8010:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8010:18 | User calibration gain | RW | 0x4000 (16384dec)
Index (hex) |  | Name | Flags | Default value
801E:0 | Subindex | AI Internal data Ch.2 | RO | 0x01 (1dec)
 | 801E:01 | ADC raw value | RO | 0x0000 (0dec)
801F:0 | Subindex | AI Vendor data Ch.2 | RW | 0x06 (6dec)
 | 801F:01 | R0 offset | RW | 0x0000 (0dec)
 | 801F:02 | R0 gain | RW | 0x4000 (16384dec)
 | 801F:03 | R1 offset | RW | 0x0000 (0dec)
 | 801F:04 | R1 gain | RW | 0x4000 (16384dec)
 | 801F:05 | R2 offset | RW | 0x0000 (0dec)
 | 801F:06 | R2 gain | RW | 0x4000 (16384dec)
8020:0 | Subindex | AO Settings Ch.3 | RW | 0x16 (22dec)
 | 8020:01 | Enable user scale | RW | 0x00 (0dec)
 | 8020:02 | Presentation | RW | 0x00 (0dec)
 | 8020:05 | Watchdog | RW | 0x00 (0dec)
 | 8020:07 | Enable user calibration | RW | 0x00 (0dec)
 | 8020:08 | Enable vendor calibration | RW | 0x01 (1dec)
 | 8020:11 | User scale offset | RW | 0x0000 (0dec)
 | 8020:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 8020:13 | Default output | RW | 0x0000 (0dec)
 | 8020:14 | Default output ramp | RW | 0xFFFF (65535dec)
 | 8020:15 | User calibration offset | RW | 0x0000 (0dec)
 | 8020:16 | User calibration gain | RW | 0x4000 (16384dec)
802E:0 | Subindex | AO Internal data Ch.3 | RO | 0x01 (1dec)
 | 802E:01 | DAC raw value | RO | 0x0000 (0dec)
802F:0 | Subindex | AO Vendor data Ch.3 | RW | 0x06 (6dec)
 | 802F:01 | R0 Calibration Offset | RW | 0x0000 (0dec)
 | 802F:02 | R0 Calibration Gain | RW | 0x4000 (16384dec)
 | 802F:03 | R1 Calibration Offset | RW | 0x0000 (0dec)
 | 802F:04 | R1 Calibration Gain | RW | 0x4000 (16384dec)
 | 802F:05 | R2 Calibration Offset | RW | 0x0000 (0dec)
 | 802F:06 | R2 Calibration Gain | RW | 0x4000 (16384dec)
Index (hex) |  | Name | Flags | Default value
8030:0 | Subindex | AO Settings Ch.4 | RW | 0x16 (22dec)
 | 8030:01 | Enable user scale | RW | 0x00 (0dec)
 | 8030:02 | Presentation | RW | 0x00 (0dec)
 | 8030:05 | Watchdog | RW | 0x00 (0dec)
 | 8030:07 | Enable user calibration | RW | 0x00 (0dec)
 | 8030:08 | Enable vendor calibration | RW | 0x01 (1dec)
 | 8030:11 | User scale offset | RW | 0x0000 (0dec)
 | 8030:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 8030:13 | Default output | RW | 0x0000 (0dec)
 | 8030:14 | Default output ramp | RW | 0xFFFF (65535dec)
 | 8030:15 | User calibration offset | RW | 0x0000 (0dec)
 | 8030:16 | User calibration gain | RW | 0x4000 (16384dec)
803E:0 | Subindex | AO Internal data Ch.4 | RO | 0x01 (1dec)
 | 803E:01 | DAC raw value | RO | 0x0000 (0dec)
803F:0 | Subindex | AO Vendor data Ch.4 | RW | 0x06 (6dec)
 | 803F:01 | R0 Calibration Offset | RW | 0x0000 (0dec)
 | 803F:02 | R0 Calibration Gain | RW | 0x4000 (16384dec)
 | 803F:03 | R1 Calibration Offset | RW | 0x0000 (0dec)
 | 803F:04 | R1 Calibration Gain | RW | 0x4000 (16384dec)
 | 803F:05 | R2 Calibration Offset | RW | 0x0000 (0dec)
 | 803F:06 | R2 Calibration Gain | RW | 0x4000 (16384dec)
F000:0 | Subindex | Modular device profile | RO | 0x02 (2dec)
 | F000:01 | Module index distance | RO | 0x0010 (16dec)
 | F000:02 | Maximum number of modules | RO | 0x0004 (4dec)
F008 |  | Code word | RW | 0x00000000 (0dec)
F010:0 | Subindex | Module list | RW | 0x04 (4dec)
 | F010:01 | SubIndex 001 | RW | 0x0000012C (300dec)
 | F010:02 | SubIndex 002 | RW | 0x0000012C (300dec)
 | F010:03 | SubIndex 003 | RW | 0x00000190 (400dec)
 | F010:04 | SubIndex 004 | RW | 0x00000190 (400dec)
F800:0 | Subindex | AIAO Range settings | RW | 0x04 (4dec)
 | F800:01 | Input type Ch1 | RW | 0x0000 (0dec)
 | F800:02 | Input type Ch2 | RW | 0x0000 (0dec)
 | F800:03 | Output type Ch3 | RW | 0x0000 (0dec)
 | F800:04 | Output type Ch4 | RW | 0x0000 (0dec)
Legend
Flags:
RO (Read Only): this object can be read only
RW (Read/Write): this object can be read and written to


Object description and parameterization

Commissioning and configuration [image] Object description and parameterization
Object description and parameterization
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Parameterization via the CoE list (CAN over EtherCAT)
The EtherCAT device is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs).
Introduction
The CoE overview contains objects for different intended applications:
▪
Objects required for parameterization during commissioning
▪
Objects intended for regular operation, e. g. through ADS access.
▪
Objects for indicating internal settings (may be fixed)
▪
Further profile-specific objects indicating inputs, outputs and status information
The following section first describes the objects required for normal operation, followed by a complete overview of missing objects.
Additional information
•
Objects to be parameterized during commissioning
•
Objects for regular operation
•
Standard objects (0x1000-0x1FFF)
•
Profile-specific objects (0x6000-0xFFFF)


Objects to be parameterized during commissioning

Commissioning and configuration [image] Object description and parameterization [image] Objects to be parameterized during commissioning
Objects to be parameterized during commissioning
Index 1011 Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default parameters | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" in the set value dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)
Index 8000 AI Settings Ch.1
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8000:0 | AI Settings Ch.1 | Maximum subindex |  | UINT8 | RO | 0x18 (24dec)
8000:01 | Enable user scale | 0bin | User scaling is not active. | BOOLEAN | RW | 0x00 (0dec)
 |  | 1bin | User scale is active.
8000:02 | Presentation | 0dec | Signed presentation | BIT3 | RW | 0x00 (0dec)
 |  | 1dec | Unsigned presentation
 |  | 2dec | Absolute value with MSB as sign (signed amount representation)
8000:05 | Siemens bits |  |  | BOOLEAN | RW | 0x00 (0dec)
8000:06 | Enable filter | 0bin | Filter not enabled | BOOLEAN | RW | 0x00 (0dec)
 |  | 1bin | Filter enabled, which makes PLC-cycle-synchronous data exchange unnecessary
8000:07 | Enable limit 1 | 0bin | Limit 1 not enabled | BOOLEAN | RW | 0x00 (0dec)
 |  | 1bin | Limit 1 enabled
8000:08 | Enable limit 2 | 0bin | Limit 2 not enabled | BOOLEAN | RW | 0x00 (0dec)
 |  | 1bin | Limit 2 enabled
8000:0A | Enable user calibration | 0bin | User calibration not enabled | BOOLEAN | RW | 0x00 (0dec)
 |  | 1bin | User calibration enabled
8000:0B | Enable vendor calibration | 0bin | Vendor calibration not enabled | BOOLEAN | RW | 0x01 (1dec)
 |  | 1bin | Vendor calibration enabled
8000:0E | Swap limit bits | 1bin | Limit bits swapped | BOOLEAN | RW | 0x00 (0dec)
8000:11 | User scale offset | User scaling: Offset |  | INT16 | RW | 0x0000 (0dec)
8000:12 | User scale gain | User scaling: Gain The gain is represented in fixed-point format, with the factor 2-16. The value 1 corresponds to 65535dec (0x00010000hex) and is limited to +/- 0x7FFFF |  | INT32 | RW | 0x00010000 (65536dec)
8000:13 | Limit 1 | First limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8000:14 | Limit 2 | Second limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8000:15 | Filter settings | This object determines the digital filter settings, if it is active via Enable filter (index 0x80n0:06). The possible settings are sequentially numbered. |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0dec | 50 Hz FIR
 |  | 1dec | 60 Hz FIR
 |  | 2dec | IIR 1
 |  | 3dec | IIR 2
 |  | 4dec | IIR 3
 |  | 5dec | IIR 4
 |  | 6dec | IIR 5
 |  | 7dec | IIR 6
 |  | 8dec | IIR 71
 |  | 9dec | IIR 8
8000:17 | User calibration offset | User calibration: Offset |  | INT16 | RW | 0x0000 (0dec)
8000:18 | User calibration gain | User calibration: Gain |  | INT16 | RW | 0x4000 (16384dec)
Index 8010 AI Settings Ch.2
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8010:0 | AI Settings Ch.2 | Maximum subindex |  | UINT8 | RO | 0x18 (24dec)
8010:01 | Enable user scale | 0bin | User scaling is not active. | BOOLEAN | RW | 0x00 (0dec)
 |  | 1bin | User scale is active.
8010:02 | Presentation | 0dec | Signed presentation | BIT3 | RW | 0x00 (0dec)
 |  | 1dec | Unsigned presentation
 |  | 2dec | Absolute value with MSB as sign (signed amount representation)
8010:05 | Siemens bits |  |  | BOOLEAN | RW | 0x00 (0dec)
8010:06 | Enable filter | 0bin | Filter not enabled | BOOLEAN | RW | 0x00 (0dec)
 |  | 1bin | Filter enabled, which makes PLC-cycle-synchronous data exchange unnecessary
8010:07 | Enable limit 1 | 0bin | Limit 1 not enabled | BOOLEAN | RW | 0x00 (0dec)
 |  | 1bin | Limit 1 enabled
8010:08 | Enable limit 2 | 0bin | Limit 2 not enabled | BOOLEAN | RW | 0x00 (0dec)
 |  | 1bin | Limit 2 enabled
8010:0A | Enable user calibration | 0bin | User calibration not enabled | BOOLEAN | RW | 0x00 (0dec)
 |  | 1bin | User calibration enabled
8010:0B | Enable vendor calibration | 0bin | Vendor calibration not enabled | BOOLEAN | RW | 0x01 (1dec)
 |  | 1bin | Vendor calibration enabled
8010:0E | Swap limit bits | 1bin | Limit bits swapped | BOOLEAN | RW | 0x00 (0dec)
8010:11 | User scale offset | User scaling: Offset |  | INT16 | RW | 0x0000 (0dec)
8010:12 | User scale gain | User scaling: Gain The gain is represented in fixed-point format, with the factor 2-16. The value 1 corresponds to 65535dec (0x00010000hex) and is limited to +/- 0x7FFFF |  | INT32 | RW | 0x00010000 (65536dec)
8010:13 | Limit 1 | First limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8010:14 | Limit 2 | Second limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8010:15 | Filter settings | This object determines the digital filter settings, if it is active via Enable filter (index 0x80n0:06). The possible settings are sequentially numbered. |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0dec | 50 Hz FIR
 |  | 1dec | 60 Hz FIR
 |  | 2dec | IIR 1
 |  | 3dec | IIR 2
 |  | 4dec | IIR 3
 |  | 5dec | IIR 4
 |  | 6dec | IIR 5
 |  | 7dec | IIR 6
 |  | 8dec | IIR 71
 |  | 9dec | IIR 8
8010:17 | User calibration offset | User calibration: Offset |  | INT16 | RW | 0x0000 (0dec)
8010:18 | User calibration gain | User calibration: Gain |  | INT16 | RW | 0x4000 (16384dec)
Index 8020 AO Settings Ch.3
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8020:0 | AO Settings Ch.3 | Maximum subindex |  | UINT8 | RO | 0x16 (22dec)
8020:01 | Enable user scale | 0bin | User scaling not active | BOOLEAN | RW | 0x00 (0dec)
 |  | 1bin | User scaling active
8020:02 | Presentation | 0dec | Signed presentation The output value range 0x7pp1:11 is shown as 16 bit signed integer. For unipolar terminals (0-10V or 0-20 mA) the negative range is set to zero. | BIT3 | RW | 0x00 (0dec)
 |  | 1dec | Unsigned presentation The output value range 0x7pp1:11 is shown as 16 bit unsigned integer. Negative values are not possible.
 |  | 2dec | Absolute value with MSB as sign Signed amount representation is active.
 |  | 3dec | Absolute value The absolute value of the signed representation is formed.
8020:05 | Watchdog | 0dec | Default watchdog value The default value (0x8pp0:13) is active. | BIT2 | RW | 0x00 (0dec)
 |  | 1dec | Watchdog ramp The ramp (0x8pp0:14) for moving to the default value ((0x8pp0:13)) is active.
 |  | 2dec | Last output value In the event of an error (triggering of the watchdog) the last process data is output.
8020:07 | Enable user calibration | 0bin | User calibration not active | BOOLEAN | RW | 0x00 (0dec)
 |  | 1bin | User calibration active
8020:08 | Enable vendor calibration | 0bin | Manufacturer calibration not active | BOOLEAN | RW | 0x01 (1dec)
 |  | 1bin | Vendor calibration active
8020:11 | User scale offset | User scaling: Offset |  | INT16 | RW | 0x0000 (0dec)
8020:12 | User scale gain | User scaling: Gain This is the user scaling gain. The gain is represented in fixed-point format, with the factor 2-16. The value one corresponds to 65535 (0x00010000). |  | INT32 | RW | 0x00010000 (65536dec)
8020:13 | Default output | Default output value |  | INT16 | RW | 0x0000 (0dec)
8020:14 | Default output ramp | This value defines the ramps for the ramp-down to the default value. The value is specified in digits/ms. If the entry is 100 and the default value 0, for example, it takes 327 ms (32767/100) for the output value to change from the maximum value (32767) to the default value in the event of a fault. |  | UINT16 | RW | 0xFFFF (65535dec)
8020:15 | User calibration offset | User calibration: Offset |  | INT16 | RW | 0x0000 (0dec)
8020:16 | User calibration gain | User calibration: Gain |  | UINT16 | RW | 0x4000 (16384dec)
Index 8030 AO Settings Ch.4
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8030:0 | AO Settings Ch.4 | Maximum subindex |  | UINT8 | RO | 0x16 (22dec)
8030:01 | Enable user scale | 0bin | User scaling not active | BOOLEAN | RW | 0x00 (0dec)
 |  | 1bin | User scaling active
8030:02 | Presentation | 0dec | Signed presentation The output value range 0x7pp1:11 is shown as 16 bit signed integer. For unipolar terminals (0-10V or 0-20 mA) the negative range is set to zero. | BIT3 | RW | 0x00 (0dec)
 |  | 1dec | Unsigned presentation The output value range 0x7pp1:11 is shown as 16 bit unsigned integer. Negative values are not possible.
 |  | 2dec | Absolute value with MSB as sign Signed amount representation is active.
 |  | 3dec | Absolute value The absolute value of the signed representation is formed.
8030:05 | Watchdog | 0dec | Default watchdog value The default value (0x8pp0:13) is active. | BIT2 | RW | 0x00 (0dec)
 |  | 1dec | Watchdog ramp The ramp (0x8pp0:14) for moving to the default value ((0x8pp0:13)) is active.
 |  | 2dec | Last output value In the event of an error (triggering of the watchdog) the last process data is output.
8030:07 | Enable user calibration | 0bin | User calibration not active | BOOLEAN | RW | 0x00 (0dec)
 |  | 1bin | User calibration active
8030:08 | Enable vendor calibration | 0bin | Manufacturer calibration not active | BOOLEAN | RW | 0x01 (1dec)
 |  | 1bin | Vendor calibration active
8030:11 | User scale offset | User scaling: Offset |  | INT16 | RW | 0x0000 (0dec)
8030:12 | User scale gain | User scaling: Gain This is the user scaling gain. The gain is represented in fixed-point format, with the factor 2-16. The value one corresponds to 65535 (0x00010000). |  | INT32 | RW | 0x00010000 (65536dec)
8030:13 | Default output | Default output value |  | INT16 | RW | 0x0000 (0dec)
8030:14 | Default output ramp | This value defines the ramps for the ramp-down to the default value. The value is specified in digits/ms. If the entry is 100 and the default value 0, for example, it takes 327 ms (32767/100) for the output value to change from the maximum value (32767) to the default value in the event of a fault. |  | UINT16 | RW | 0xFFFF (65535dec)
8030:15 | User calibration offset | User calibration: Offset |  | INT16 | RW | 0x0000 (0dec)
8030:16 | User calibration gain | User calibration: Gain |  | UINT16 | RW | 0x4000 (16384dec)
Index F800 AIAO Range settings
Index (hex) | Name | Meaning |  | Data type | Flags | Default
F800:0 | AIAO Range settings | Maximum subindex |  | UINT8 | RO | 0x04 (4dec)
F800:01 | Input type Ch1 | Input signal range for channel 1 |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0dec | -10…+10 V
 |  | 1dec | 0...20 mA
 |  | 2dec | 4...20 mA
 |  | 3dec | 0...10 V
F800:02 | Input type Ch2 | Input signal range for channel 2 (values see channel 1) |  | UINT16 | RW | 0x0000 (0dec)
F800:03 | Output type Ch3 | Output signal range for channel 3 |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0dec | -10…+10 V
 |  | 1dec | 0...20 mA
 |  | 2dec | 4...20 mA
 |  | 3dec | 0...10 V
F800:04 | Output type Ch4 | Output signal range for channel 4 (values see channel 3) |  | UINT16 | RW | 0x0000 (0dec)


Objects for regular operation

Commissioning and configuration [image] Object description and parameterization [image] Objects for regular operation
Objects for regular operation
The EP4374 has no such objects.


Standard objects (0x1000-0x1FFF)

Commissioning and configuration [image] Object description and parameterization [image] Standard objects (0x1000-0x1FFF)
Standard objects (0x1000-0x1FFF)
The standard objects have the same meaning for all EtherCAT slaves.
Index 1000 Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x00001389 (5001dec)
Index 1008 Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EP4374-0002
Index 1009 Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO | 00
Index 100A Software version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO | 02
Index 1018 Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x11164052 (286670930dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the low word (bit 0-15) indicates the special terminal number, the high word (bit 16-31) refers to the device description | UINT32 | RO | 0x00110002 (1114114dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the low byte (bit 0-7) of the low word contains the year of production, the high byte (bit 8-15) of the low word contains the week of production, the high word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 Backup parameter handling
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | Information for standardized loading and saving of backup entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum across all backup entries of the EtherCAT slave | UINT32 | RO | 0x00000000 (0dec)
Index 1600 AO Outputs Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1600:0 | AO Outputs Ch.3 | PDO Mapping RxPDO 1 | UINT8 | RO | 0x01 (1dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (AO outputs Ch.3), entry 0x11 (Analog output)) | UINT32 | RO | 0x7020:11, 16
Index 1601 AO Outputs Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
1601:0 | AO Outputs Ch.4 | PDO Mapping RxPDO 2 | UINT8 | RO | 0x01 (1dec)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7030 (AO outputs Ch.4), entry 0x11 (Analog output)) | UINT32 | RO | 0x7030:11, 16
Index 1800 AI Inputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1800:0 | AI Inputs Ch.1 | PDO Parameter TxPDO 1 | UINT8 | RO | 0x06 (6dec)
1800:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 1 | OCTET-STRING[2] | RO | 01 1A
Index 1801 AI Inputs Compact Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1801:0 | AI Inputs Compact Ch.1 | PDO Parameter TxPDO 2 | UINT8 | RO | 0x06 (6dec)
1801:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 2 | OCTET-STRING[2] | RO | 00 1A
Index 1802 AI Inputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1802:0 | AI Inputs Ch.2 | PDO Parameter TxPDO 3 | UINT8 | RO | 0x06 (6dec)
1802:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 3 | OCTET-STRING[2] | RO | 03 1A
Index 1803 AI Inputs Compact Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1803:0 | AI Inputs Compact Ch.2 | PDO Parameter TxPDO 4 | UINT8 | RO | 0x06 (6dec)
1803:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 4 | OCTET-STRING[2] | RO | 02 1A
Index 1A00 AI Inputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A00:0 | AI Inputs Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x0B (11dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x01 (Underrange)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x02 (Overrange)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6000:03, 2
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6000:05, 2
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x07 (Error)) | UINT32 | RO | 0x6000:07, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x0E (Sync error)) | UINT32 | RO | 0x6000:0E, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6000:0F, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6000:10, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x11 (Value)) | UINT32 | RO | 0x6000:11, 16
Index 1A01 AI Inputs Compact Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A01:0 | AI Inputs Compact Ch.1 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x01 (1dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x11 (Value)) | UINT32 | RO | 0x6000:11, 16
Index 1A02 AI Inputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A02:0 | AI Inputs Ch.2 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x0B (11dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x01 (Underrange)) | UINT32 | RO | 0x6010:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x02 (Overrange)) | UINT32 | RO | 0x6010:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6010:03, 2
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6010:05, 2
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x07 (Error)) | UINT32 | RO | 0x6010:07, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x0E (Sync error)) | UINT32 | RO | 0x6010:0E, 1
1A02:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6010:0F, 1
1A02:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6010:10, 1
1A02:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x11 (Value)) | UINT32 | RO | 0x6010:11, 16
Index 1A03 AI Inputs Compact Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A03:0 | AI Inputs Compact Ch.2 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x01 (1dec)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x11 (Value)) | UINT32 | RO | 0x6010:11, 16
Index 1C00 Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the sync managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x02 (2dec)
1C12:01 | Subindex 001 | 1st allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1600 (5632dec)
1C12:02 | Subindex 002 | 2nd allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1601 (5633dec)
Index 1C13 TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x02 (2dec)
1C13:01 | Subindex 001 | 1st allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2nd allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A02 (6658dec)
Index 1C33 SM input parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchronous with SM 3 Event (no outputs available)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchronous with SM 2 Event (outputs available)
UINT16
RW
0x0022 (34dec)
1C33:02
Cycle time
as 0x1C32:02
UINT32
RW
0x000F4240 (1000000dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00001388 (5000dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: Synchronous with SM 2 Event is supported (outputs available)
▪
Bit 1: Synchronous with SM 3 Event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: input shift through local event (outputs available)
▪
Bit 4-5 = 10: input shift with SYNC1 event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08 or 0x1C33:08)
UINT16
RO
0xC007 (49159dec)
1C33:05
Minimum cycle time
as 0x1C32:05
UINT32
RO
0x0007A120 (500000dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00002710 (10000dec)
1C33:07
Minimum delay time
UINT32
RO
0x00001388 (5000dec)
1C33:08
Command
as 0x1C32:08
UINT16
RW
0x0000 (0dec)
1C33:09
Maximum delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00001388 (5000dec)
1C33:0B
SM event missed counter
as 0x1C32:11
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
as 0x1C32:12
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
as 0x1C32:13
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
as 0x1C32:32
BOOLEAN
RO
0x00 (0dec)
Index 1C32 SM output parameter
Index (hex) | Name | Meaning |  |  | Data type | Flags | Default
1C32:0 | SM output parameter | Synchronization parameters for the outputs |  |  | UINT8 | RO | 0x20 (32dec)
1C32:01 | Sync mode | Value | Current synchronization mode |  | UINT16 | RW | 0x0001 (1dec)
 |  | 0 | Free Run
 |  | 1 | Synchron with SM 2 Event
 |  | 2 | DC-Mode - Synchron with SYNC0 Event
 |  | 3 | DC-Mode - Synchron with SYNC1 Event
1C32:02 | Cycle time | Cycle time (in ns): |  |  | UINT32 | RW | 0x000F4240 (1000000dec)
 |  | Free Run |  | Cycle time of the local timer
 |  | Synchron with SM 2 Event |  | Master cycle time
 |  | DC-Mode |  | SYNC0/SYNC1 Cycle Time
1C32:03 | Shift time | Time between SYNC0 event and output of the outputs (in ns, DC mode only) |  |  | UINT32 | RO | 0x00002710 (10000dez)
1C32:04 | Sync modes supported | Bit | Value | Supported synchronization modes: | UINT16 | RO | 0xC007 (49159dec)
 |  | 0 | 1 | free run is supported
 |  | 1 | 1 | Synchronous with SM 2 event is supported
 |  | 3.2 | 01 | DC mode is supported
 |  | 5.4 | 10 | Output shift with SYNC1 event (only DC mode)
 |  | 14 | 1 | dynamic times (measurement through writing of 0x1C32:08)
1C32:05 | Minimum cycle time | Minimum cycle time (in ns) |  |  | UINT32 | RO | 0x0007A120 (500000dez)
1C32:06 | Calc and copy time | Minimum time between SYNC0 and SYNC1 event (in ns, DC mode only) |  |  | UINT32 | RO | 0x00001388 (5000dez)
1C32:07 | Minimum delay time |  |  |  | UINT32 | RO | 0x00001388 (5000dez)
1C32:08 | Command | 0 | Measurement of the local cycle time is stopped |  | UINT16 | RW | 0x0000 (0dec)
 |  | 1 | Measurement of the local cycle time is started
 |  | The entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09
1C32:09 | Maximum Delay time | Time between SYNC1 event and output of the outputs (in ns, DC mode only) |  |  | UINT32 | RO | 0x00001388 (5000dez)
1C32:0B | SM event missed counter | Number of missed SM events in OPERATIONAL (DC mode only) |  |  | UINT16 | RO | 0x0000 (0dec)
1C32:0C | Cycle exceeded counter | Number of occasions the cycle time was exceeded in OPERATIONAL (cycle was not completed in time or the next cycle began too early) |  |  | UINT16 | RO | 0x0000 (0dec)
1C32:0D | Shift too short counter | Number of occasions that the interval between SYNC0 and SYNC1 event was too short (DC mode only) |  |  | UINT16 | RO | 0x0000 (0dec)
1C32:20 | Sync error | The synchronization was not correct in the last cycle (outputs were output too late; DC mode only) |  |  | BOOLEAN | RO | 0x00 (0dec)


Profile-specific objects (0x6000-0xFFFF)

Commissioning and configuration [image] Object description and parameterization [image] Profile-specific objects (0x6000-0xFFFF)
Profile-specific objects (0x6000-0xFFFF)
The profile-specific objects have the same meaning for all EtherCAT slaves that support the profile 5001.
Index 6000 AI Inputs Ch.1
Index (hex) | Name | Meaning |  | Data type | Flags | Default
6000:0 | AI Inputs Ch.1 |  |  | UINT8 | RO | 0x11 (17dec)
6000:01 | Underrange | Underrange event active |  | BOOLEAN | RO | 0x00 (0dec)
6000:02 | Overrange | Overrange event active |  | BOOLEAN | RO | 0x00 (0dec)
6000:03 | Limit 1 | Bit 0 = 1bin | Value greater than limit 1 | BIT2 | RO | 0x00 (0dec)
 |  | Bit 1 = 1bin | Value less than limit 1
6000:05 | Limit 2 | Bit 0 = 1bin | Value greater than limit 2 | BIT2 | RO | 0x00 (0dec)
 |  | Bit 1 = 1bin | Value less than limit 2
6000:07 | Error | Bit set when Over- or Underrange |  | BOOLEAN | RO | 0x00 (0dec)
6000:0E | Sync error |  |  | BOOLEAN | RO | 0x00 (0dec)
6000:0F | TxPDO State |  |  | BOOLEAN | RO | 0x00 (0dec)
6000:10 | TxPDO Toggle |  |  | BOOLEAN | RO | 0x00 (0dec)
6000:11 | Value |  |  | INT16 | RO | 0x0000 (0dec)
Index 6010 AI Inputs Ch.2
Index (hex) | Name | Meaning |  | Data type | Flags | Default
6010:0 | AI Inputs Ch.2 |  |  | UINT8 | RO | 0x11 (17dec)
6010:01 | Underrange | Underrange event active |  | BOOLEAN | RO | 0x00 (0dec)
6010:02 | Overrange | Overrange event active |  | BOOLEAN | RO | 0x00 (0dec)
6010:03 | Limit 1 | Bit 0 = 1bin | Value greater than limit 1 | BIT2 | RO | 0x00 (0dec)
 |  | Bit 1 = 1bin | Value less than limit 1
6010:05 | Limit 2 | Bit 0 = 1bin | Value greater than limit 2 | BIT2 | RO | 0x00 (0dec)
 |  | Bit 1 = 1bin | Value less than limit 2
6010:07 | Error | Bit set when Over- or Underrange |  | BOOLEAN | RO | 0x00 (0dec)
6010:0E | Sync error |  |  | BOOLEAN | RO | 0x00 (0dec)
6010:0F | TxPDO State |  |  | BOOLEAN | RO | 0x00 (0dec)
6010:10 | TxPDO Toggle |  |  | BOOLEAN | RO | 0x00 (0dec)
6010:11 | Value |  |  | INT16 | RO | 0x0000 (0dec)
Index 7020 AO Outputs Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
7020:0 | AO Outputs Ch.3 |  | UINT8 | RO | 0x11 (17dec)
7020:11 | Analog output | Analog output data | INT16 | RO | 0x0000 (0dec)
Index 7030 AO Outputs Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
7030:0 | AO Outputs Ch.4 |  | UINT8 | RO | 0x11 (17dec)
7030:11 | Analog output | Analog output data | INT16 | RO | 0x0000 (0dec)
Index 800E AI Internal data Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
800E:0 | AI Internal data Ch.1 |  | UINT8 | RO | 0x01 (1dec)
800E:01 | ADC raw value |  | INT16 | RO | 0x0000 (0dec)
Index 800F AI Vendor data Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
800F:0 | AI Vendor data Ch.1 |  | UINT8 | RO | 0x06 (6dec)
800F:01 | R0 offset |  | INT16 | RW | 0x0000 (0dec)
800F:02 | R0 gain |  | INT16 | RW | 0x4000 (16384dec)
800F:03 | R1 offset |  | INT16 | RW | 0x0000 (0dec)
800F:04 | R1 gain |  | INT16 | RW | 0x4000 (16384dec)
800F:05 | R2 offset |  | INT16 | RW | 0x0000 (0dec)
800F:06 | R2 gain |  | INT16 | RW | 0x4000 (16384dec)
Index 801E AI Internal data Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
801E:0 | AI Internal data Ch.2 |  | UINT8 | RO | 0x01 (1dec)
801E:01 | ADC raw value |  | INT16 | RO | 0x0000 (0dec)
Index 801F AI Vendor data Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
801F:0 | AI Vendor data Ch.2 |  | UINT8 | RO | 0x06 (6dec)
801F:01 | R0 offset |  | INT16 | RW | 0x0000 (0dec)
801F:02 | R0 gain |  | INT16 | RW | 0x4000 (16384dec)
801F:03 | R1 offset |  | INT16 | RW | 0x0000 (0dec)
801F:04 | R1 gain |  | INT16 | RW | 0x4000 (16384dec)
801F:05 | R2 offset |  | INT16 | RW | 0x0000 (0dec)
801F:06 | R2 gain |  | INT16 | RW | 0x4000 (16384dec)
Index 802E AO Internal data Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
802E:0 | AO Internal data Ch.3 |  | UINT8 | RO | 0x01 (1dec)
802E:01 | DAC raw value | This is the raw DAC value. | UINT16 | RO | 0x0000 (0dec)
Index 802F AO Vendor data Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
802F:0 | AO Vendor data Ch.3 |  | UINT8 | RO | 0x06 (6dec)
802F:01 | R0 Calibration Offset | Vendor calibration: Offset for +/-10 V | INT16 | RW | 0x0000 (0dec)
802F:02 | R0 Calibration Gain | Vendor calibration: Gain for +/-10 V | UINT16 | RW | 0x4000 (16384dec)
802F:03 | R1 Calibration Offset | Vendor calibration: Offset for 0-20 mA | INT16 | RW | 0x0000 (0dec)
802F:04 | R1 Calibration Gain | Vendor calibration: Gain for 0-20 mA | UINT16 | RW | 0x4000 (16384dec)
802F:05 | R2 Calibration Offset | Vendor calibration: Offset for 4-20 mA | INT16 | RW | 0x0000 (0dec)
802F:06 | R2 Calibration Gain | Vendor calibration: Gain for 4-20 mA | UINT16 | RW | 0x4000 (16384dec)
Index 803E AO Internal data Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
803E:0 | AO Internal data Ch.4 |  | UINT8 | RO | 0x01 (1dec)
803E:01 | DAC raw value | This is the raw DAC value. | UINT16 | RO | 0x0000 (0dec)
Index 803F AO Vendor data Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
803F:0 | AO Vendor data Ch.4 |  | UINT8 | RO | 0x06 (6dec)
803F:01 | R0 Calibration Offset | Vendor calibration: Offset for +/-10 V | INT16 | RW | 0x0000 (0dec)
803F:02 | R0 Calibration Gain | Vendor calibration: Gain for +/-10 V | UINT16 | RW | 0x4000 (16384dec)
803F:03 | R1 Calibration Offset | Vendor calibration: Offset for 0-20 mA | INT16 | RW | 0x0000 (0dec)
803F:04 | R1 Calibration Gain | Vendor calibration: Gain for 0-20 mA | UINT16 | RW | 0x4000 (16384dec)
803F:05 | R2 Calibration Offset | Vendor calibration: Offset for 4-20 mA | INT16 | RW | 0x0000 (0dec)
803F:06 | R2 Calibration Gain | Vendor calibration: Gain for 4-20 mA | UINT16 | RW | 0x4000 (16384dec)
Index F000 Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0004 (4dec)
Index F008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word |  | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module list
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list |  | UINT8 | RW | 0x04 (4dec)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x0000012C (300dec)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x0000012C (300dec)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x00000190 (400dec)
F010:04 | SubIndex 004 |  | UINT32 | RW | 0x00000190 (400dec)


Restoring the delivery state

Commissioning and configuration [image] Restoring the delivery state
Restoring the delivery state
To restore the delivery state for backup objects in ELxxxx terminals / EPxxxx- and EPPxxxx boxes, the CoE object Restore default parameters, SubIndex 001 can be selected in the TwinCAT System Manager (Config mode).
Selecting the Restore default parameters PDO
Double-click on SubIndex 001 to enter the Set Value dialog. Enter the value 1684107116 in field Dec or the value 0x64616F6C in field Hex and confirm with OK.
All backup objects are reset to the delivery state.
Entering a restore value in the Set Value dialog
Alternative restore value
In some older terminals / boxes the backup objects can be switched with an alternative restore value:
Decimal value: 1819238756
Hexadecimal value: 0x6C6F6164
An incorrect entry for the restore value has no effect.


Appendix

Appendix
Appendix
Additional information
•
General operating conditions
•
Accessories
•
Version identification of EtherCAT devices
•
Support and Service


General operating conditions

Appendix [image] General operating conditions
General operating conditions
Protection degrees (IP-Code)
The standard IEC 60529 (DIN EN 60529) defines the degrees of protection in different classes.
1. Number: dust protection and touch guard | Definition
0 | Non-protected
1 | Protected against access to hazardous parts with the back of a hand. Protected against solid foreign objects of Ø 50 mm
2 | Protected against access to hazardous parts with a finger. Protected against solid foreign objects of Ø 12.5 mm.
3 | Protected against access to hazardous parts with a tool. Protected against solid foreign objects Ø 2.5 mm.
4 | Protected against access to hazardous parts with a wire. Protected against solid foreign objects Ø 1 mm.
5 | Protected against access to hazardous parts with a wire. Dust-protected. Intrusion of dust is not totally prevented, but dust shall not penetrate in a quantity to interfere with satisfactory operation of the device or to impair safety.
6 | Protected against access to hazardous parts with a wire. Dust-tight. No intrusion of dust.
2. Number: water* protection | Definition
0 | Non-protected
1 | Protected against water drops
2 | Protected against water drops when enclosure tilted up to 15°.
3 | Protected against spraying water. Water sprayed at an angle up to 60° on either side of the vertical shall have no harmful effects.
4 | Protected against splashing water. Water splashed against the disclosure from any direction shall have no harmful effects
5 | Protected against water jets
6 | Protected against powerful water jets
7 | Protected against the effects of temporary immersion in water. Intrusion of water in quantities causing harmful effects shall not be possible when the enclosure is temporarily immersed in water for 30 min. in 1 m depth.
*) These protection classes define only protection against water!
Chemical Resistance
The Resistance relates to the Housing of the IP 67 modules and the used metal parts. In the table below you will find some typical resistance.
Character | Resistance
Steam | at temperatures >100°C: not resistant
Sodium base liquor (ph-Value > 12) | at room temperature: resistant > 40°C: not resistant
Acetic acid | not resistant
Argon (technical clean) | resistant
Key
▪
resistant: Lifetime several months
▪
non inherently resistant: Lifetime several weeks
▪
not resistant: Lifetime several hours resp. early decomposition


Accessories

Appendix [image] Accessories
Accessories
Mounting
Ordering information | Description
ZS5300-0001 | Mounting rail (500 mm x 129 mm)
Cables
Ordering information | Description
ZK1090-3xxx-xxxx | EtherCAT cable M8, green link to the website
ZK1093-3xxx-xxxx | EtherCAT cable M8, yellow link to the website
ZK2000-5xxx-xxxx ZK2000-71xx-xxxx | Sensor cable M12 5-wire Link to website
ZK2000-6xxx-xxxx | Sensor cable M12 4-wire Link to website
A complete overview of pre-assembled cables for EtherCAT Box modules can be found here.
Labeling material, protective caps
Ordering information | Description
ZS5000-0010 | Protective cap for M8 sockets, IP67 (50 pieces)
ZS5000-0020 | Protective cap M12, IP67 (50 pieces)
ZS5100-0000 | Inscription labels, unprinted, 4 strips of 10
ZS5000-xxxx | Printed inscription labels on enquiry
Tools
Ordering information | Description
ZB8801-0000 | Torque wrench for plugs, 0.4…1.0 Nm
ZB8801-0001 | Torque cable key for M8 / wrench size 9 for ZB8801-0000
ZB8801-0002 | Torque cable key for M12 / wrench size 13 for ZB8801-0000
ZB8801-0003 | Torque cable key for M12 field assembly / wrench size 18 for ZB8801-0000
Further accessories
Further accessories can be found in the price list for fieldbus components from Beckhoff and online at https://www.beckhoff.com.


Version identification of EtherCAT devices

Appendix [image] Version identification of EtherCAT devices
Version identification of EtherCAT devices
Designation
A Beckhoff EtherCAT device has a 14-digit designation, made up of
▪
family key
▪
type
▪
version
▪
revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
Notes
▪
The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
▪
EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
▪
The order identifier is made up of
- family key (EL, EP, CU, ES, KL, CX, etc.)
- type (3314)
- version (-0000)
▪
The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
▪
The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Identification number
Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:
Production lot/batch number/serial number/date code/D number
The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02
Exceptions can occur in the IP67 area, where the following syntax can be used (see respective device documentation):
Syntax: D ww yy x y z u
D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB
Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1
Unique serial number/ID, ID number
In addition, in some series each individual module has its own unique serial number.
See also the further documentation in the area
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Terminals with factory calibration certificate and other measuring terminals
Examples of markings
EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
CU2016 switch with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
EP1258-00001 IP67 EtherCAT Box with batch number/ date code 22090101 and unique serial number 158102
EP1908-0002 IP67 EtherCAT Safety Box with batch number/ date code 071201FF and unique serial number 00346070
EL2904 IP20 safety terminal with batch number/ date code 50110302 and unique serial number 00331701
ELM3604-0002 terminal with unique ID number (QR code) 100001051 and serial/ batch number 44160201
Additional information
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Appendix [image] Version identification of EtherCAT devices [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com