EP3744-x041 - EtherCAT Box with digital inputs, outputs and differential pressure inputs
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation Issue Status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation Issue Status

Foreword [image] Documentation Issue Status
Documentation Issue Status
Version
Comment
2.4
▪
Front page updated
2.3
▪
Pressure measuring ranges made clearer
▪
Structure update
2.2
▪
Update technical data
2.1
▪
Update Safety instructions
▪
Correction in chapter Process image
▪
Update chapter Mounting
2.0.0
▪
Migration
1.3.0
▪
Chapter Settings added
1.2.0
▪
Power Connection updated
1.1.0
▪
Front page updated
▪
EP3744-1041 added to EP3744-x041 introduction
▪
EP3744-1041 added to Technical Data
▪
Process image heading adapted
▪
Support and Service updated
▪
Safety instructions updated
▪
Notes on the documentation updated
▪
EtherCAT connection updated
▪
Nut torques for connectors updated
▪
EtherCAT cables updated
1.0.0
▪
First release
0.1.0
▪
Preliminary version
Firmware and hardware versions
This documentation refers to the firmware and hardware version that was applicable at the time the documentation was written.
The module features are continuously improved and developed further. Modules having earlier production statuses cannot have the same properties as modules with the latest status. However, existing properties are retained and are not changed, so that older modules can always be replaced with new ones.
The firmware and hardware version (delivery state) can be found in the batch number (D-number) printed on the side of the EtherCAT Box.
Syntax of the batch number (D-number)
D: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with D no. 29 10 02 01:
29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01
Further information on this topic: Version identification of EtherCAT devices.


EtherCAT Box - Introduction

EtherCAT Box - Introduction
EtherCAT Box - Introduction
The EtherCAT system has been extended with EtherCAT Box modules with protection class IP 67. Through the integrated EtherCAT interface the modules can be connected directly to an EtherCAT network without an additional Coupler Box. The high-performance of EtherCAT is thus maintained into each module.
The extremely low dimensions of only 126 x 30 x 26.5 mm (h x w x d) are identical to those of the Fieldbus Box extension modules. They are thus particularly suitable for use where space is at a premium. The small mass of the EtherCAT modules facilitates applications with mobile I/O interface (e.g. on a robot arm). The EtherCAT connection is established via screened M8 connectors.
EtherCAT Box Modules within an EtherCAT network
The robust design of the EtherCAT Box modules enables them to be used directly at the machine. Control cabinets and terminal boxes are now no longer required. The modules are fully sealed and therefore ideally prepared for wet, dirty or dusty conditions.
Pre-assembled cables significantly simplify EtherCAT and signal wiring. Very few wiring errors are made, so that commissioning is optimized. In addition to pre-assembled EtherCAT, power and sensor cables, field-configurable connectors and cables are available for maximum flexibility. Depending on the application, the sensors and actuators are connected through M8 or M12 connectors.
The EtherCAT modules cover the typical range of requirements for I/O signals with protection class IP67:
▪
digital inputs with different filters (3.0 ms or 10 μs)
▪
digital outputs with 0.5 or 2 A output current
▪
analog inputs and outputs with 16 bit resolution
▪
Thermocouple and RTD inputs
▪
Stepper motor modules
XFC (eXtreme Fast Control Technology) modules, including inputs with time stamp, are also available.
EtherCAT Box with M8 connections for sensors/actuators
EtherCAT Box with M12 connections for sensors/actuators
Basic EtherCAT documentation
You will find a detailed description of the EtherCAT system in the Basic System Documentation for EtherCAT, which is available for download from our website (www.beckhoff.com) under Downloads.
EtherCAT XML Device Description
You will find XML files (XML Device Description Files) for Beckhoff EtherCAT modules on our website (www.beckhoff.com) under Downloads, in the Configuration Files area.


Product overview

Product overview
Product overview
Additional information
•
Introduction
•
Technical data
•
Scope of supply
•
Process image


Introduction

Product overview [image] Introduction
Introduction
EP3744-0041, EP3744-1041
EtherCAT Box with 6 digital inputs (24 VDC, 10 µs), 2 digital outputs (24 VDC, 0.5 A) and reference pressure inputs
The EP3744-x041 EtherCAT Box with six digital inputs and two digital outputs records binary control signals from the process level and transfers them, electrically isolated, to the controller. The signal status is indicated by LEDs, the signals are connected via 3-pole M8 plug connectors (sockets).
Four pneumatic connections (6 mm) offer the possibility to directly measure differential pressure. This value is measured or calculated in relation to the fifth reference pressure connection (6 mm).
The sensors and outputs are supplied from the control voltage Us. Since only one GND is available on the M8 plug for the inputs and outputs, this alternative supply was selected.
The load voltage Up is not used in the input module, but may optionally be connected in order to be relayed downstream.
Pressure measurement with EP3744-0041
The pressure is measured as an absolute value or as a differential value relative to the fifth connection via an integrated 6 mm fitting. The pressure values are available as 16-bit values. Measurement can take place between -1 bar and +1 bar, wherein the value is output relative to the fifth connection, e.g. for vacuum measurement in relation to the ambient pressure at the suction grippers. In absolute pressure mode, pressures between 0 and 1 bar can be measured.
Pressure measurement with EP3744-1041
The pressure is measured as an absolute value or as a differential value relative to the fifth connection via an integrated 6 mm fitting. The pressure values are available as 16-bit values. Measurement can take place between -7 bar and +7 bar, wherein the value is output relative to the fifth connection, e.g. for vacuum measurement in relation to the ambient pressure at the suction grippers. In absolute pressure mode, pressures between 0 and 7 bar can be measured.
Quick links


Technical data

Product overview [image] Technical data
Technical data
All values are typical values over the entire temperature range, unless stated otherwise.
Technical data
EP3744-0041
EP3744-1041
Fieldbus
Fieldbus
EtherCAT
Connection
2 x M8 socket, green
Electrical isolation
500 V (fieldbus / IO)
Minimum cycle time
700 µs
Supply voltages
Connection
Feed: 1 x M8 plug, 4-pin, black
Downstream connection: 1 x M8 socket, 4-pin, black
Control voltage US
Nominal voltage
24 VDC (-15 % / +20 %)
Sum current
max. 4 A 1)
Current consumption from US
120 mA
Further consumers
▪
Sensors
▪
Loads at digital outputs
Undervoltage detection
< 18 VDC
Peripheral voltage UP
Nominal voltage
24 VDC (-15 % / +20 %)
Sum current
max. 4 A 1)
Current consumption from UP
None. UP is only forwarded.
Undervoltage detection
< 18 VDC
Pressure inputs
Number
4
+ 1 reference input for the differential pressure measurement
Connections
Fittings, d = 6 mm
Type of pressure measurement
Ajustable:
▪
Absolute pressure measurement
▪
Differential pressure measurement (factory setting)
Absolute pressure measuring range
0 … 1 bar 2)
(0 … 15 psi)
0 … 7 bar 2)
(0 … 100 psi)
Differential pressure measuring range 3)
-1 … +1 bar
(-15 … +15 psi)
-7 … +7 bar
(-100 … +100 psi)
Resolution
1 mbar per LSB
Measuring error
3% of the full scale value
Conversion time
5 EtherCAT cycles
(Note the minimum EtherCAT cycle time, see above)
Permissible media
non-aggressive gases
Maximum overload of an input
3 bar absolute pressure 2)
21 bar absolute pressure 2)
1) This value corresponds to the current carrying capacity of the connections for the supply voltages.
2) 0 bar = vacuum
1 bar = ambient pressure
3) Even in the case of differential pressure measurement, the absolute pressure measuring range must not be exceeded at any pressure input.
Technical data | EP3744-0041 | EP3744-1041
Digital inputs
Number | 6
Connection | 4 M8 sockets (sockets 0, 1, 2, 3)
Characteristics | EN 61131-2 type 3, compatible with type 1
Signal voltage "0" | -3…+5 V
Signal voltage "1" | +11…+30 V
Input current | 3 mA at 24 V
Sensor supply | 24 VDC from the control voltage US max. 0.5 A in total, short-circuit proof
Digital outputs
Number | 2
Connection | 2 M8 sockets (sockets 2 and 3)
Nominal voltage | 24 V from the control voltage US
Output current | max. 0.5 A per output, individually short-circuit proof
Mechanics
Installation position | variable
Environmental conditions
Ambient temperature during operation | -25 .. +60 °C -25 .. +55 °C according to cURus
Ambient temperature during storage | -40 .. +85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 conforms to EN 60529
Approvals and conformity
Approvals | CE, cURus
Additional checks
The boxes have been subjected to the following checks:
Verification | Explanation
Vibration | 10 frequency sweeps in 3 axes
 | 5 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 35 g, 11 ms
Additional information
•
Absolute pressure measuring range


Absolute pressure measuring range

Product overview [image] Technical data [image] Absolute pressure measuring range
Absolute pressure measuring range
The absolute pressure measuring range must be adhered to for each pressure connection, regardless of the chosen measurement method (absolute pressure / differential pressure):
Absolute pressure measuring ranges
Absolute pressure measuring ranges


Scope of supply

Product overview [image] Scope of supply
Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EtherCAT Box EP3744-x041
▪
2x protective cap for EtherCAT socket, M8, green (pre-assembled)
▪
1x protective cap for supply voltage input, M8, transparent (pre-assembled)
▪
1x protective cap for supply voltage output, M8, black (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


Process image

Product overview [image] Process image
Process image
Kanal 1 bis Kanal 16
The six digital inputs of the module can be found under DIG Inputs 1 to 6.
▪
Input 1 - socket 0, pin 4
▪
Input 2 - socket 0, pin 2
▪
Input 3 - socket 1, pin 4
▪
Input 4 - socket 1, pin 2
▪
Input 5 - socket 2, pin 4
▪
Input 6 - socket 3, pin 4
The four pressure measuring inputs of the module can be found under AI Inputs Channel 1 to 4.
▪
Underrange: the pressure has fallen below the underrange value
▪
Overrange: the pressure has exceeded the overrange value
▪
Limit1: the Limit1 value specified in the CoE objects was reached
▪
Limit2: the Limit2 value specified in the CoE objects was reached
▪
Error: one of the above events has occurred
▪
Value: the measured pressure value in the unit pre-scaled in the CoE objects (e.g. mbar)
The diagnostic data for the module can be found under DEV Inputs Device.
▪
Safe State Active: there was an interruption in communication, causing the outputs to change to the safe state
▪
Sync error: a synchronization error has occurred
▪
Undervoltage Us: the voltage Us is less than approx. 18 VDC
▪
Undervoltage Up: the voltage Up is less than approx. 18 VDC
▪
TxPDO Toggle: EtherCAT variable for displaying a transmitted date of receipt (see general EtherCAT documentation)
The two digital outputs of the module can be found under DIG Outputs 1 and 2.
▪
Output 1 - socket 2, pin 2
▪
Output 2 - socket 3, pin 2
The output variables for setting or resetting the outputs of the module can be found under DEV Output Device.
▪
Set safe state: the outputs change to the safe state (see CoE objects)
▪
Reset Outputs: reserved
These are standard EtherCAT variables; more information in the general EtherCAT manual.


Mounting and connection

Mounting and connection
Mounting and connection
Additional information
•
Mounting
•
Connection
•
UL Requirements


Mounting

Mounting and connection [image] Mounting
Mounting
Additional information
•
Dimensions
•
Fixing
•
Tightening torques for connectors


Dimensions

Mounting and connection [image] Mounting [image] Dimensions
Dimensions
Dimensions
All dimensions are given in millimeters.
Housing features
Housing material | PA6 (polyamide)
Sealing compound | polyurethane
Mounting | two fastening holes Ø 3.5 mm for M3
Metal parts | brass, nickel-plated
Contacts | CuZn, gold-plated
Power feed through | max. 4 A
Installation position | variable
Protection class | IP65, IP66, IP67 (conforms to EN 60529) when screwed together
Dimensions (H x W x D) | approx. 126 x 30 x 26.5 mm (without connectors)


Fixing

Mounting and connection [image] Mounting [image] Fixing
Fixing
Note
Dirt during assembly
Dirty connectors can lead to malfunctions. Protection class IP67 can only be guaranteed if all cables and connectors are connected.
•
Protect the plug connectors against dirt during the assembly.
Mount the module with two M3 screws on the fastening holes in the corners of the module. The fastening holes have no thread.


Tightening torques for connectors

Mounting and connection [image] Mounting [image] Tightening torques for connectors
Tightening torques for connectors
Screw M8 connectors tight with a torque wrench. (e.g. ZB8801 from Beckhoff)
Torque: 0.4 Nm.


Connection

Mounting and connection [image] Connection
Connection
Additional information
•
EtherCAT
•
Supply voltages
•
Pressure inputs
•
Digital inputs and outputs


EtherCAT

Mounting and connection [image] Connection [image] EtherCAT
EtherCAT
Additional information
•
Connectors
•
Status LEDs
•
Cables


Connectors

Mounting and connection [image] Connection [image] EtherCAT [image] Connectors
Connectors
Note
Risk of confusion: supply voltages and EtherCAT
Defect possible through incorrect insertion.
•
Observe the color coding of the connectors:
black: Supply voltages
green: EtherCAT
EtherCAT Box Modules have two green M8 sockets for the incoming and downstream EtherCAT connections.
EtherCAT connectors
Connection
M8 socket, 4-pin – connection
M8 socket
EtherCAT | M8 connector | Core colors
Signal | Contact | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 and old versions of ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | 1 | yellow1) | orange/white | white/orange
Tx - | 4 | orange1) | orange | orange
Rx + | 2 | white1) | blue/white | white/green
Rx - | 3 | blue1) | blue | green
Shield | Housing | Shield | Shield | Shield
1) Core colors according to EN 61918
Adaptation of core colors for cables ZB9030, ZB9032 and ZK1090-3xxxx-xxxx
For standardization, the core colors of the ZB9030, ZB9032 and ZK1090-3xxx-xxxx cables have been changed to the EN61918 core colors: yellow, orange, white, blue. So there are different color codes in circulation. The electrical properties of the cables have been retained when the core colors were changed.


Status LEDs

Mounting and connection [image] Connection [image] EtherCAT [image] Status LEDs
Status LEDs
EtherCAT status LEDs
L/A (Link/Act)
A green LED labelled "L/A" is located next to each EtherCAT socket. The LED indicates the communication state of the respective socket:
LED | Meaning
off | no connection to the connected EtherCAT device
lit | LINK: connection to the connected EtherCAT device
flashes | ACT: communication with the connected EtherCAT device
Run
Each EtherCAT slave has a green LED labelled "Run". The LED signals the status of the slave in the EtherCAT network:
LED | Meaning
off | Slave is in "Init" state
flashes uniformly | Slave is in "Pre-Operational“ state
flashes sporadically | Slave is in "Safe-Operational" state
lit | Slave is in "Operational" state
Description of the EtherCAT slave states


Cables

Mounting and connection [image] Connection [image] EtherCAT [image] Cables
Cables
For connecting EtherCAT devices only shielded Ethernet cables that meet the requirements of at least category 5 (CAT5) according to EN 50173 or ISO/IEC 11801 should be used.
EtherCAT uses four wires for signal transmission.
Thanks to automatic line detection ("Auto MDI-X"), both symmetrical (1:1) or cross-over cables can be used between Beckhoff EtherCAT.
Detailed recommendations for the cabling of EtherCAT devices


Supply voltages

Mounting and connection [image] Connection [image] Supply voltages
Supply voltages
The EtherCAT Box is supplied with two supply voltages. The supply voltages are electrically isolated in the EtherCAT Box.
▪
Control voltage US
▪
Peripheral voltage UP
Redirection of the supply voltages
The IN and OUT power connections are bridged in the module (not IP204x-Bxxx and IE204x). The supply voltages US and UP can thus easily be transferred from EtherCAT Box to EtherCAT Box.
Note
Pay attention to the maximum permissible current!
Pay attention also for the redirection of the supply voltages US and UP, the maximum permissible current for M8 connectors of 4 A must not be exceeded!
Additional information
•
Connectors
•
Status LEDs
•
Conductor losses


Connectors

Mounting and connection [image] Connection [image] Supply voltages [image] Connectors
Connectors
Note
Risk of confusion: supply voltages and EtherCAT
Defect possible through incorrect insertion.
•
Observe the color coding of the connectors:
black: Supply voltages
green: EtherCAT
Connectors for supply voltages
M8 connector
Contact | Function | Description | Core color 1)
1 | US | Control voltage | Brown
2 | UP | Peripheral voltage | White
3 | GNDS | GND to US | Blue
4 | GNDP | GND to UP | Black
1) The core colors apply to cables of the type: Beckhoff ZK2020-3xxx-xxxx


Status LEDs

Mounting and connection [image] Connection [image] Supply voltages [image] Status LEDs
Status LEDs
Connectors + LEDs
Status LEDs for the supply voltages
LED | Display | Meaning
US (control voltage) | off | Supply voltage US is not present
 | green illuminated | Supply voltage US is present
UP (peripheral voltage) | off | Supply voltage UP is not present
 | green illuminated | Supply voltage UP is present


Conductor losses

Mounting and connection [image] Connection [image] Supply voltages [image] Conductor losses
Conductor losses
Take into account the voltage drop on the supply line when planning a system. Avoid the voltage drop being so high that the supply voltage at the box lies below the minimum nominal voltage.
Variations in the voltage of the power supply unit must also be taken into account.
Voltage drop on the supply line
Leitungsverluste M8 2A
Leitungsverluste M8 4A


Pressure inputs

Mounting and connection [image] Connection [image] Pressure inputs
Pressure inputs
SmallWarningYellow CAUTION
Compressed air
•
Before connecting or disconnecting the module, check if the system is under pressure.
⇨
The compressed air connections must not be opened while the system is under pressure.
•
The general safety and installation instructions for handling compressed air must be observed.
Signal connection
Pressure measuring inputs, 6 mm pneumatic hose
The connection for pressure measurement is made via fittings for standard pneumatic hoses (6 mm). The values are output as a reference to the lower left measuring channel.
The values of the reference channel are not available in the process data, but in the CoE objects.


Digital inputs and outputs

Mounting and connection [image] Connection [image] Digital inputs and outputs
Digital inputs and outputs
Digital inputs/outputs M8, 4-pin
The EP3744 has four 4-pin M8 sockets.
Sockets 0 and 1 each have two digital inputs; sockets 2 and 3 each have one input and one output.
The signals are connected via M8 connectors
Socket 0 and 1
Socket 2 and 3
The sensors are supplied with a common maximum current of 0.5 A from the control voltage Us.
Light emitting diodes indicate the signal state of the inputs.
Additional information
•
Status LEDs at the signal connections


Status LEDs at the signal connections

Mounting and connection [image] Connection [image] Digital inputs and outputs [image] Status LEDs at the signal connections
Status LEDs at the signal connections
LED displays
LED | Display | Meaning
STATUS 1-4 | green illuminated | a signal (24 V) is present on at least one input of channels 1-6 or one of the outputs 1 or 2 is switched on
Us | off | The supply voltage, Us, is not present
 | green illuminated | The supply voltage, Us, is present
 | red illuminated | short circuit on the power supply for sensor outputs of Us
Up | off | The supply voltage, Up, is not present
 | green illuminated | The supply voltage, Up, is present


UL Requirements

Mounting and connection [image] UL Requirements
UL Requirements
The installation of the EtherCAT Box Modules certified by UL has to meet the following requirements.
Supply voltage
SmallWarningYellow CAUTION
CAUTION!
This UL requirements are valid for all supply voltages of all marked EtherCAT Box Modules!
For the compliance of the UL requirements the EtherCAT Box Modules should only be supplied
•
by a 24 VDC supply voltage, supplied by an isolating source and protected by means of a fuse (in accordance with UL248), rated maximum 4 Amp, or
•
by a 24 VDC power source, that has to satisfy NEC class 2.
A NEC class 2 power supply shall not be connected in series or parallel with another (class 2) power source!
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, the EtherCAT Box Modules must not be connected to unlimited power sources!
Networks
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, EtherCAT Box Modules must not be connected to telecommunication networks!
Ambient temperature range
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, EtherCAT Box Modules has to be operated only at an ambient temperature range of 0 to 55°C!
Marking for UL
All EtherCAT Box Modules certified by UL (Underwriters Laboratories) are marked with the following label.
UL label


Commissioning/Configuration

Commissioning/Configuration
Commissioning/Configuration
Additional information
•
Absolute pressure / differential pressure
•
Filter
•
Limit value monitoring
•
Restoring the delivery state
•
Firmware Update EL/ES/EM/EPxxxx


Absolute pressure / differential pressure

Commissioning/Configuration [image] Absolute pressure / differential pressure
Absolute pressure / differential pressure
Note
Differential pressure measurement: Also observe the absolute pressure measuring range
•
Even in the case of differential pressure measurement, the absolute pressure measuring range must not be exceeded at any pressure input. See Technical data.
You can set the pressure measurement method individually for each pressure connection:
▪
Absolute pressure
▪
Differential pressure (factory setting) in relation to the reference connection X5
Set the pressure measurement method in the following CoE parameters:
Pressure connection | CoE object |  | Parameter
X1 | 8020hex | AI Settings Ch.1 | 19hex | Range
X2 | 8030hex | AI Settings Ch.2 | 19hex | Range
X3 | 8040hex | AI Settings Ch.3 | 19hex | Range
X4 | 8050hex | AI Settings Ch.4 | 19hex | Range
Possible values
Value | Enum
7dec | “Absolute Pressure Measurement”
8dec (factory setting) | “Differential Pressure Measurement to Reference Sensor”


Filter

Commissioning/Configuration [image] Filter
Filter
FIR and IIR filter
The EP3744 Box is equipped with a digital filter which, depending on its settings, can adopt the characteristics of a Finite Impulse Response filter (FIR filter), or an Infinite Impulse Response filter (IIR filter). The filter can also be deactivated.
The filter characteristics are set via index 0x8020:15
The filter frequencies are set centrally for all channels of the EP3744 Box via index 0x8020:15 (channel 1). The corresponding indices 0x80n0:15 of the other channels have no parameterization function.
FIR filter
The filter works as a notch filter and determines the conversion time of the box. It is parameterized via the index 0x8020:15. The higher the filter frequency, the faster the conversion time. A 50 Hz and a 60 Hz filter are available.
Notch filter means that the filter has zeros (notches) in the frequency response at the filter frequency and multiples thereof, i.e. it attenuates the amplitude at these frequencies.
The FIR filter functions as a non-recursive filter, which can be adjusted by the parameterization of the object 0x8020:15.
Typical attenuation curve of notch filter at 50 Hz
Filter data FIR filter (1-4-channel boxes)
Filter | Attenuation | Limit frequency (-3 dB)
50 Hz FIR | > 50 dB | 22 Hz
60 Hz FIR | > 40 dB | 26 Hz
Filter data FIR filter (8-channel boxes)
Filter | Attenuation | Limit frequency (-3 dB)
50 Hz FIR | > 50 dB | 23 Hz
60 Hz FIR | > 50 dB | 27 Hz
IIR filter
The filter with IIR characteristics is a discrete time, linear, time invariant filter that can be set to eight levels (level 1 = weak recursive filter, up to level 8 = strong recursive filter).
The IIR can be understood to be a moving average value calculation after a low-pass filter.
By means of the synchronization mode FreeRun, the IIR filter works with an internal cycle time of 500 µs (1, 2 or 4 channels) or 1 ms (8 channels).
Filter data for IIR filter
IIR filter | Limit frequency with internal box cycle time 1 ms (-3 dB)
IIR 1 | 168 Hz
IIR 2 | 88 Hz
IIR 3 | 43 Hz
IIR 4 | 21 Hz
IIR 5 | 10.5 Hz
IIR 6 | 5.2 Hz
IIR 7 | 2.5 Hz
IIR 8 | 1.2 Hz
Conversion time & FIR and IIR filters, index 0x80n0:06
The typical conversion time and trigger mode depend on
▪
the selected filter setting (default: 50 Hz)
▪
the setting in the CoE register 0x1C33:01
–
by manual parameterization in the System Manager. CAUTION: Enter any changes made in the StartUp list!
–
by the StartUp list as an automatic parameter download during the EtherCAT start phase. CAUTION: Entries are implemented only after activation of the configuration!
The conversion time is the time interval in which the EP3744 makes a new measured value available. A new measured value is displayed by toggling “TxPDO Toggle” (index 0x60n0:10).


Limit value monitoring

Commissioning/Configuration [image] Limit value monitoring
Limit value monitoring
Limit 1 and Limit 2, Index 0x80n0:13, Index 0x80n0:14
If the limits of the values that can be entered in indices 0x80n0:13 and 0x80n0:14 are violated, the bits in indices 0x60n0:03 and 0x60n0:05 are set accordingly (see sample below). The indices 0x80n0:07 or 0x80n0:08 serve to activate the limit value monitoring.
Output limit n (2-bit):
▪
0: not active
▪
1: Value is smaller than the limit value
▪
2: Value is larger than the limit value
▪
3: Value is equal to the limit value
Linking in the PLC with 2-bit values
The limit information consists of 2 bits. Limitn can be linked to the PLC or a task in the System Manager.
▪
PLC:
IEC61131-PLC contains no 2-bit data type that can be linked with this process data directly. To transfer the limit information, you should therefore define an input byte, for example, and link the limit to the VariableSizeMismatch dialog, as described in the diagram Linking 2-bit variable with additional task.
Input byte definition
▪
Additional task
2-bit variables can be created in the System Manager.
Linking of 2-bit variable to additional task
Sample for EL3062:
Channel 1; Limit1 and Limit2 enabled, Limit 1 = 2.8 V, Limit 2 = 7.4 V, representation: signed integer
Entry in Index 0x80n0:13 (Limit 1):
(2.8 V / 10 V) x 216 / 2 - 1 = 9,174dec
Entry in Index 0x80n0:14 (Limit 2):
(7.4 V / 10 V) x 216 / 2 - 1 = 24,247dec
Output:
Input channel 1 | Index 0x6000:03 | Index 0x6000:05
1.8 V | 0x01hex, (Limit 1, limit value undershot) | 0x01hex, (Limit 2, limit value undershot)
2.8 V | 0x03hex, (Limit 1, limit value reached) | 0x01hex, (Limit 2, limit value undershot)
4.2 V | 0x02hex, (Limit 1, limit value exceeded) | 0x01hex, (Limit 2, limit value undershot)
8.5 V | 0x02hex, (Limit 1, limit value exceeded) | 0x02hex, (Limit 2, limit value exceeded)


Restoring the delivery state

Commissioning/Configuration [image] Restoring the delivery state
Restoring the delivery state
To restore the delivery state for backup objects in ELxxxx terminals / EPxxxx- and EPPxxxx boxes, the CoE object Restore default parameters, SubIndex 001 can be selected in the TwinCAT System Manager (Config mode).
Selecting the Restore default parameters PDO
Double-click on SubIndex 001 to enter the Set Value dialog. Enter the value 1684107116 in field Dec or the value 0x64616F6C in field Hex and confirm with OK.
All backup objects are reset to the delivery state.
Entering a restore value in the Set Value dialog
Alternative restore value
In some older terminals / boxes the backup objects can be switched with an alternative restore value:
Decimal value: 1819238756
Hexadecimal value: 0x6C6F6164
An incorrect entry for the restore value has no effect.


Firmware Update EL/ES/EM/EPxxxx

Commissioning/Configuration [image] Firmware Update EL/ES/EM/EPxxxx
Firmware Update EL/ES/EM/EPxxxx
This section describes the device update for Beckhoff EtherCAT slaves from the EL/ES, EM, EK and EP series. A firmware update should only be carried out after consultation with Beckhoff support.
Storage locations
An EtherCAT slave stores operating data in up to 3 locations:
▪
Depending on functionality and performance EtherCAT slaves have one or several local controllers for processing I/O data. The corresponding program is the so-called firmware in *.efw format.
▪
In some EtherCAT slaves the EtherCAT communication may also be integrated in these controllers. In this case the controller is usually a so-called FPGA chip with *.rbf firmware.
▪
In addition, each EtherCAT slave has a memory chip, a so-called ESI-EEPROM, for storing its own device description (ESI: EtherCAT Slave Information). On power-up this description is loaded and the EtherCAT communication is set up accordingly. The device description is available from the download area of the Beckhoff website at (http://www.beckhoff.de). All ESI files are accessible there as zip files.
Customers can access the data via the EtherCAT fieldbus and its communication mechanisms. Acyclic mailbox communication or register access to the ESC is used for updating or reading of these data.
The TwinCAT System Manager offers mechanisms for programming all 3 parts with new data, if the slave is set up for this purpose. Generally the slave does not check whether the new data are suitable, i.e. it may no longer be able to operate if the data are unsuitable.
Note
Risk of damage to the device!
Note the following when downloading new device files
• Firmware downloads to an EtherCAT device must not be interrupted
• Flawless EtherCAT communication must be ensured. CRC errors or LostFrames must be avoided.
• The power supply must adequately dimensioned. The signal level must meet the specification.
In the event of malfunctions during the update process the EtherCAT device may become unusable and require re-commissioning by the manufacturer.
Device description ESI file/XML
Note
Notice regarding update of the ESI description/EEPROM
Some slaves have stored calibration and configuration data from the production in the EEPROM. These are irretrievably overwritten during an update.
The ESI device description is stored locally on the slave and loaded on start-up. Each device description has a unique identifier consisting of slave name (9 characters/digits) and a revision number (4 digits). Each slave configured in the System Manager shows its identifier in the EtherCAT tab:
Device identifier consisting of name EL3204-0000 and revision -0016
The configured identifier must be compatible with the actual device description used as hardware, i.e. the description which the slave has loaded on start-up (in this case EL3204). Normally the configured revision must be the same or lower than that actually present in the terminal network.
For further information on this, please refer to the EtherCAT system documentation.
Update of XML/ESI description
The device revision is closely linked to the firmware and hardware used. Incompatible combinations lead to malfunctions or even final shutdown of the device. Corresponding updates should only be carried out in consultation with Beckhoff support.
Display of ESI slave identifier
The simplest way to ascertain compliance of configured and actual device description is to scan the EtherCAT boxes in TwinCAT mode Config/FreeRun:
Scan Boxes
Scan the subordinate field by right-clicking on the EtherCAT device in Config/FreeRun mode
If the found field matches the configured field, the display shows
Configuration is identical
otherwise a change dialog appears for entering the actual data in the configuration.
Change dialog
In this example in Fig. Change dialog, an EL3201-0000-0017 was found, while an EL3201-0000-0016 was configured. In this case the configuration can be adapted with the Copy Before button. The Extended Information checkbox must be set in order to display the revision.
Changing the ESI slave identifier
The ESI/EEPROM identifier can be updated as follows under TwinCAT:
▪
Trouble-free EtherCAT communication must be established with the slave.
▪
The state of the slave is irrelevant.
▪
Right-clicking on the slave in the online display opens the EEPROM Update dialog, Fig. EEPROM Update
EEPROM Update
The new ESI description is selected in the following dialog, see Fig. Selecting the new ESI. The checkbox Show Hidden Devices also displays older, normally hidden versions of a slave.
Selecting the new ESI
A progress bar in the System Manager shows the progress. Data are first written, then verified.
The change only takes effect after a restart.
Most EtherCAT devices read a modified ESI description immediately or after startup from the INIT. Some communication settings such as distributed clocks are only read during power-on. The EtherCAT slave therefore has to be switched off briefly in order for the change to take effect.
Determining the firmware version
Determining the version on laser inscription
Beckhoff EtherCAT Box feature batch numbers (D number) applied by laser. The D-number has the following structure: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with D-no.: 12 10 03 02:
12 - week of production 12
10 - year of production 2010
03 - firmware version 03
02 - hardware version 02
Determining the version via the System Manager
The TwinCAT System Manager shows the version of the controller firmware if the master can access the slave online. Click on the E-Bus Terminal whose controller firmware you want to check (in the example terminal 2 (EL3204)) and select the tab CoE Online (CAN over EtherCAT).
CoE Online and Offline CoE
Two CoE directories are available:
• online: This is offered in the EtherCAT slave by the controller, if the EtherCAT slave does supported it. This CoE directory can only be displayed if a slave is connected and operational.
• offline: The EtherCAT Slave Information ESI/XML may contain the default content of the CoE. This CoE directory can only be displayed if it is included in the ESI (e.g. Beckhoff EL5xxx.xml).
The Advanced button must be used for switching between the two views.
In Fig. Display of EL3204 firmware version the firmware version of the selected EL3204 is shown as 03 in CoE entry 0x100A.
Display of EL3204 firmware version
In (A) TwinCAT 2.11 shows that the Online CoE directory is currently displayed. If this is not the case, the Online directory can be loaded via the Online option in Advanced Settings (B) and double-clicking on AllObjects.
Updating controller firmware *.efw
CoE directory
The Online CoE directory is managed by the controller and stored in a dedicated EEPROM, which is generally not changed during a firmware update.
Switch to the Online tab to update the controller firmware of a slave, see Fig. Firmware Update.
Firmware Update
Proceed as follows, unless instructed otherwise by Beckhoff support.
▪
Switch slave to INIT (A)
▪
Switch slave to BOOTSTRAP
▪
Check the current status (B, C)
▪
Download the new *efw file
▪
After the download switch to INIT, then OP
▪
Switch off the slave briefly
FPGA firmware *.rbf
If an FPGA chip deals with the EtherCAT communication an update may be accomplished via an *.rbf file.
▪
Controller firmware for processing I/O signals
▪
FPGA firmware for EtherCAT communication (only for terminals with FPGA)
The firmware version number included in the terminal serial number contains both firmware components. If one of these firmware components is modified this version number is updated.
Determining the version via the System Manager
The TwinCAT System Manager indicates the FPGA firmware version. Click on the Ethernet card of your EtherCAT strand (Device 2 in the example) and select the Online tab.
The Reg:0002 column indicates the firmware version of the individual EtherCAT devices in hexadecimal and decimal representation.
FPGA firmware version definition
If the column Reg:0002 is not displayed, right-click the table header and select Properties in the context menu.
Context menu Properties
The Advanced Settings dialog appears where the columns to be displayed can be selected. Under Diagnosis/Online View select the '0002 ETxxxx Build' check box in order to activate the FPGA firmware version display.
Dialog Advanced Settings
Update
For updating the FPGA firmware
▪
of an EtherCAT coupler the coupler must have FPGA firmware version 11 or higher;
▪
of an E-Bus Terminal the terminal must have FPGA firmware version 10 or higher.
Older firmware versions can only be updated by the manufacturer!
Updating an EtherCAT device
In the TwinCAT System Manager select the terminal for which the FPGA firmware is to be updated (in the example: Terminal 5: EL5001) and click the Advanced Settings button in the EtherCAT tab.
Select dialog Advanced Settings
The Advanced Settings dialog appears. Under ESC Access/E²PROM/FPGA click on Write FPGA button,
Select dialog Write FPGA
Select file
Select the file (*.rbf) with the new FPGA firmware, and transfer it to the EtherCAT device.
Note
Risk of damage to the device!
A firmware download to an EtherCAT device must never be interrupted! If this process is cancelled, the supply voltage switched off or the Ethernet connection interrupted, the EtherCAT device can only be recommissioned by the manufacturer!
In order to activate the new FPGA firmware a restart (switching the power supply off and on again) of the EtherCAT device is required.
Simultaneous updating of several EtherCAT devices
The firmware and ESI descriptions of several devices can be updated simultaneously, provided the devices have the same firmware file/ESI.
Multiple selection and firmware update
Select the required slaves and carry out the firmware update in BOOTSTRAP mode as described above.


CoE parameters

CoE parameters
CoE parameters
Additional information
•
Object overview
•
Object description and parameterization


Object overview

CoE parameters [image] Object overview
Object overview
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Index (hex) |  | Name | Flags | Default value
1000 |  | Device type | RO | 0x00001389 (5001dec)
1008 |  | Device name | RO | EP3744-0041
1009 |  | Hardware version | RO | 00
100A |  | Software version | RO | 03
1011 | Subindex | Restore default parameters | RO | 0x01 (1dec)
 | 0x1011:01 | SubIndex 001 | RW | 0x00000000 (0dec)
1018:0 | Subindex | Identity | RO | 0x04 (4dec)
 | 0x1018:01 | Vendor ID | RO | 0x00000002 (2dec)
 | 0x1018:02 | Product code | RO | 0x0EA04052 (245383250dec)
 | 0x1018:03 | Revision | RO | 0x00000000 (0dec)
 | 0x1018:04 | Serial number | RO | 0x00000000 (0dec)
10F0:0 | Subindex | Backup parameter handling | RO | 0x01 (1dec)
 | 0x10F0:01 | Checksum | RO | 0x00000000 (0dec)
1600:0 | Subindex | DIG RxPDO-Map Outputs | RO | 0x03 (3dec)
 | 0x1600:01 | SubIndex 001 | RO | 0x7010:01, 1
 | 0x1600:02 | SubIndex 002 | RO | 0x7010:02, 1
 | 0x1600:03 | SubIndex 003 | RO | 0x0000:00, 14
1601:0 | Subindex | DEV RxPDO-Map Outputs Device | RO | 0x02 (2dec)
 | 0x1601:01 | SubIndex 001 | RO | 0xF700:01, 1
 | 0x1601:02 | SubIndex 002 | RO | 0x0000:00, 15
1A00:0 | Subindex | DIG TxPDO-Map Inputs | RO | 0x07 (7dec)
 | 0x1A00:01 | SubIndex 001 | RO | 0x6000:01, 1
 | 0x1A00:02 | SubIndex 002 | RO | 0x6000:02, 1
 | 0x1A00:03 | SubIndex 003 | RO | 0x6000:03, 1
 | 0x1A00:04 | SubIndex 004 | RO | 0x6000:04, 1
 | 0x1A00:05 | SubIndex 005 | RO | 0x6000:05, 1
 | 0x1A00:06 | SubIndex 006 | RO | 0x6000:06, 1
 | 0x1A00:07 | SubIndex 007 | RO | 0x0000:00, 10
1A01:0 | Subindex | AI TxPDO-Map Inputs Ch.1 | RO | 0x09 (9dec)
 | 0x1A01:01 | SubIndex 001 | RO | 0x6020:01, 1
 | 0x1A01:02 | SubIndex 002 | RO | 0x6020:02, 1
 | 0x1A01:03 | SubIndex 003 | RO | 0x6020:03, 2
 | 0x1A01:04 | SubIndex 004 | RO | 0x6020:05, 2
 | 0x1A01:05 | SubIndex 005 | RO | 0x6020:07, 1
 | 0x1A01:06 | SubIndex 006 | RO | 0x0000:00, 7
 | 0x1A01:07 | SubIndex 007 | RO | 0x6020:0F, 1
 | 0x1A01:08 | SubIndex 008 | RO | 0x6020:10, 1
 | 0x1A01:09 | SubIndex 009 | RO | 0x6020:11, 32
Index (hex) |  | Name | Flags | Default value
1A02:0 | Subindex | AI TxPDO-Map Inputs Ch.2 | RO | 0x09 (9dec)
 | 0x1A02:01 | SubIndex 001 | RO | 0x6030:01, 1
 | 0x1A02:02 | SubIndex 002 | RO | 0x6030:02, 1
 | 0x1A02:03 | SubIndex 003 | RO | 0x6030:03, 2
 | 0x1A02:04 | SubIndex 004 | RO | 0x6030:05, 2
 | 0x1A02:05 | SubIndex 005 | RO | 0x6030:07, 1
 | 0x1A02:06 | SubIndex 006 | RO | 0x0000:00, 7
 | 0x1A02:07 | SubIndex 007 | RO | 0x6030:0F, 1
 | 0x1A02:08 | SubIndex 008 | RO | 0x6030:10, 1
 | 0x1A02:09 | SubIndex 009 | RO | 0x6030:11, 32
1A03:0 | Subindex | AI TxPDO-Map Inputs Ch.3 | RO | 0x09 (9dec)
 | 0x1A03:01 | SubIndex 001 | RO | 0x6040:01, 1
 | 0x1A03:02 | SubIndex 002 | RO | 0x6040:02, 1
 | 0x1A03:03 | SubIndex 003 | RO | 0x6040:03, 2
 | 0x1A03:04 | SubIndex 004 | RO | 0x6040:05, 2
 | 0x1A03:05 | SubIndex 005 | RO | 0x6040:07, 1
 | 0x1A03:06 | SubIndex 006 | RO | 0x0000:00, 7
 | 0x1A03:07 | SubIndex 007 | RO | 0x6040:0F, 1
 | 0x1A03:08 | SubIndex 008 | RO | 0x6040:10, 1
 | 0x1A03:09 | SubIndex 009 | RO | 0x6040:11, 32
1A04:0 | Subindex | AI TxPDO-Map Inputs Ch.4 | RO | 0x09 (9dec)
 | 0x1A04:01 | SubIndex 001 | RO | 0x6050:01, 1
 | 0x1A04:02 | SubIndex 002 | RO | 0x6050:02, 1
 | 0x1A04:03 | SubIndex 003 | RO | 0x6050:03, 2
 | 0x1A04:04 | SubIndex 004 | RO | 0x6050:05, 2
 | 0x1A04:05 | SubIndex 005 | RO | 0x6050:07, 1
 | 0x1A04:06 | SubIndex 006 | RO | 0x0000:00, 7
 | 0x1A04:07 | SubIndex 007 | RO | 0x6050:0F, 1
 | 0x1A04:08 | SubIndex 008 | RO | 0x6050:10, 1
 | 0x1A04:09 | SubIndex 009 | RO | 0x6050:11, 32
1A05:0 | Subindex | DEV TxPDO-Map Inputs Device | RO | 0x07 (7dec)
 | 0x1A05:01 | SubIndex 001 | RO | 0xF600:01, 1
 | 0x1A05:02 | SubIndex 002 | RO | 0x0000:00, 15
 | 0x1A05:03 | SubIndex 003 | RO | 0xF611:01, 1
 | 0x1A05:04 | SubIndex 004 | RO | 0xF611:02, 1
 | 0x1A05:05 | SubIndex 005 | RO | 0x0000:00, 13
 | 0x1A05:06 | SubIndex 006 | RO | 0xF611:10, 1
 | 0x1A05:07 | SubIndex 007 | RO | 0x0000:00, 96
1C00:0 | Subindex | Sync manager type | RO | 0x04 (4dec)
 | 0x1C00:01 | SubIndex 001 | RO | 0x01 (1dec)
 | 0x1C00:02 | SubIndex 002 | RO | 0x02 (2dec)
 | 0x1C00:03 | SubIndex 003 | RO | 0x03 (3dec)
 | 0x1C00:04 | SubIndex 004 | RO | 0x04 (4dec)
1C12:0 | Subindex | RxPDO assign | RW | 0x02 (2dec)
 | 0x1C12:01 | SubIndex 001 | RW | 0x1600 (5632dec)
 | 0x1C12:02 | SubIndex 002 | RW | 0x1601 (5633dec)
1C13:0 | Subindex | TxPDO assign | RW | 0x06 (6dec)
 | 0x1C13:01 | SubIndex 001 | RW | 0x1A00 (6656dec)
 | 0x1C13:02 | SubIndex 002 | RW | 0x1A01 (6657dec)
 | 0x1C13:03 | SubIndex 003 | RW | 0x1A02 (6658dec)
 | 0x1C13:04 | SubIndex 004 | RW | 0x1A03 (6659dec)
 | 0x1C13:05 | SubIndex 005 | RW | 0x1A04 (6660dec)
 | 0x1C13:06 | SubIndex 006 | RW | 0x1A05 (6661dec)
Index (hex) |  | Name | Flags | Default value
1C32:0 | Subindex | SM output parameter | RO | 0x20 (32dec)
 | 0x1C32:01 | Sync mode | RW | 0x0001 (1dec)
 | 0x1C32:02 | Cycle time | RW | 0x003D0900 (4000000dec)
 | 0x1C32:03 | Shift time | RO | 0x00000384 (900dec)
 | 0x1C32:04 | Sync modes supported | RO | 0xC007 (49159dec)
 | 0x1C32:05 | Minimum cycle time | RO | 0x000F4240 (1000000dec)
 | 0x1C32:06 | Calc and copy time | RO | 0x00000000 (0dec)
 | 0x1C32:07 | Minimum delay time | RO | 0x00000384 (900dec)
 | 0x1C32:08 | Command | RW | 0x0000 (0dec)
 | 0x1C32:09 | Maximum delay time | RO | 0x00000384 (900dec)
 | 0x1C32:0B | SM event missed counter | RO | 0x0000 (0dec)
 | 0x1C32:0C | Cycle exceeded counter | RO | 0x0000 (0dec)
 | 0x1C32:0D | Shift too short counter | RO | 0x0000 (0dec)
 | 0x1C32:20 | Sync error | RO | 0x00 (0dec)
1C33:0 | Subindex | SM input parameter | RO | 0x20 (32dec)
 | 0x1C33:01 | Sync mode | RW | 0x0022 (34dec)
 | 0x1C33:02 | Cycle time | RW | 0x003D0900 (4000000dec)
 | 0x1C33:03 | Shift time | RO | 0x00000384 (900dec)
 | 0x1C33:04 | Sync modes supported | RO | 0xC007 (49159dec)
 | 0x1C33:05 | Minimum cycle time | RO | 0x000F4240 (1000000dec)
 | 0x1C33:06 | Calc and copy time | RO | 0x00000000 (0dec)
 | 0x1C33:07 | Minimum delay time | RO | 0x00000384 (900dec)
 | 0x1C33:08 | Command | RW | 0x0000 (0dec)
 | 0x1C33:09 | Maximum delay time | RO | 0x00000384 (900dec)
 | 0x1C33:0B | SM event missed counter | RO | 0x0000 (0dec)
 | 0x1C33:0C | Cycle exceeded counter | RO | 0x0000 (0dec)
 | 0x1C33:0D | Shift too short counter | RO | 0x0000 (0dec)
 | 0x1C33:20 | Sync error | RO | 0x00 (0dec)
6000:0 | Subindex | Dig Inputs | RO | 0x06 (6dec)
 | 0x6000:01 | Input 1 | RO | 0x00 (0dec)
 | 0x6000:02 | Input 2 | RO | 0x00 (0dec)
 | 0x6000:03 | Input 3 | RO | 0x00 (0dec)
 | 0x6000:04 | Input 4 | RO | 0x00 (0dec)
 | 0x6000:05 | Input 5 | RO | 0x00 (0dec)
 | 0x6000:06 | Input 6 | RO | 0x00 (0dec)
6020:0 | Subindex | AI Inputs Ch.1 | RO | 0x11 (17dec)
 | 0x6020:01 | Underrange | RO | 0x00 (0dec)
 | 0x6020:02 | Overrange | RO | 0x00 (0dec)
 | 0x6020:03 | Limit 1 | RO | 0x00 (0dec)
 | 0x6020:05 | Limit 2 | RO | 0x00 (0dec)
 | 0x6020:07 | Error | RO | 0x00 (0dec)
 | 0x6020:0F | TxPDO State | RO | 0x00 (0dec)
 | 0x6020:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 0x6020:11 | Value | RO | 0x00000000 (0dec)
6030:0 | Subindex | AI Inputs Ch.2 | RO | 0x11 (17dec)
 | 0x6030:01 | Underrange | RO | 0x00 (0dec)
 | 0x6030:02 | Overrange | RO | 0x00 (0dec)
 | 0x6030:03 | Limit 1 | RO | 0x00 (0dec)
 | 0x6030:05 | Limit 2 | RO | 0x00 (0dec)
 | 0x6030:07 | Error | RO | 0x00 (0dec)
 | 0x6030:0F | TxPDO State | RO | 0x00 (0dec)
 | 0x6030:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 0x6030:11 | Value | RO | 0x00000000 (0dec)
Index (hex) |  | Name | Flags | Default value
6040:0 | Subindex | AI Inputs Ch.3 | RO | 0x11 (17dec)
 | 0x6040:01 | Underrange | RO | 0x00 (0dec)
 | 0x6040:02 | Overrange | RO | 0x00 (0dec)
 | 0x6040:03 | Limit 1 | RO | 0x00 (0dec)
 | 0x6040:05 | Limit 2 | RO | 0x00 (0dec)
 | 0x6040:07 | Error | RO | 0x00 (0dec)
 | 0x6040:0F | TxPDO State | RO | 0x00 (0dec)
 | 0x6040:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 0x6040:11 | Value | RO | 0x00000000 (0dec)
6050:0 | Subindex | AI Inputs Ch.4 | RO | 0x11 (17dec)
 | 0x6050:01 | Underrange | RO | 0x00 (0dec)
 | 0x6050:02 | Overrange | RO | 0x00 (0dec)
 | 0x6050:03 | Limit 1 | RO | 0x00 (0dec)
 | 0x6050:05 | Limit 2 | RO | 0x00 (0dec)
 | 0x6050:07 | Error | RO | 0x00 (0dec)
 | 0x6050:0F | TxPDO State | RO | 0x00 (0dec)
 | 0x6050:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 0x6050:11 | Value | RO | 0x00000000 (0dec)
7010:0 | Subindex | Dig Outputs | RO | 0x02 (2dec)
 | 0x7010:01 | Output 1 | RO | 0x00 (0dec)
 | 0x7010:02 | Output 2 | RO | 0x00 (0dec)
8010:0 | Subindex | Safe state active | RW | 0x02 (2dec)
 | 0x8010:01 | Output 1 | RW | 0x00 (0dec)
 | 0x8010:02 | Output 2 | RW | 0x00 (0dec)
8011:0 | Subindex | Safe state value | RW | 0x02 (2dec)
 | 0x8011:01 | Output 1 | RW | 0x00 (0dec)
 | 0x8011:02 | Output 2 | RW | 0x00 (0dec)
8020:0 | Subindex | AI Settings Ch.1 | RW | 0x19 (25dec)
 | 0x8020:01 | Enable user scale | RW | 0x00 (0dec)
 | 0x8020:06 | Enable filter | RW | 0x01 (1dec)
 | 0x8020:07 | Enable limit 1 | RW | 0x00 (0dec)
 | 0x8020:08 | Enable limit 2 | RW | 0x00 (0dec)
 | 0x8020:0A | Enable user calibration | RW | 0x00 (0dec)
 | 0x8020:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 0x8020:11 | User scale offset | RW | 0x00000000 (0dec)
 | 0x8020:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 0x8020:13 | Limit 1 | RW | 0x0000 (0dec)
 | 0x8020:14 | Limit 2 | RW | 0x0000 (0dec)
 | 0x8020:15 | Filter settings | RW | 0x0000 (0dec)
 | 0x8020:17 | User calibration offset | RW | 0x00000000 (0dec)
 | 0x8020:18 | User calibration gain | RW | 0x4000 (16384dec)
 | 0x8020:19 | Range | RW | 0x0008 (8dec)
802E:0 | Subindex | AI Internal data Ch.1 | RO | 0x01 (1dec)
 | 0x802E:01 | ADC raw value | RO | 0x00000000 (0dec)
802F:0 | Subindex | AI Vendor data Ch.1 | RW | 0x04 (4dec)
 | 0x802F:01 | Calibration offset pressure | RW | 0x00000000 (0dec)
 | 0x802F:02 | Calibration gain pressure | RW | 0x4000 (16384dec)
 | 0x802F:03 | Calibration offset temp | RW | 0x00000000 (0dec)
 | 0x802F:04 | Calibration gain temp | RW | 0x0000 (0dec)
Index (hex) |  | Name | Flags | Default value
8030:0 | Subindex | AI Settings Ch.2 | RW | 0x19 (25dec)
 | 0x8030:01 | Enable user scale | RW | 0x00 (0dec)
 | 0x8030:06 | Enable filter | RW | 0x01 (1dec)
 | 0x8030:07 | Enable limit 1 | RW | 0x00 (0dec)
 | 0x8030:08 | Enable limit 2 | RW | 0x00 (0dec)
 | 0x8030:0A | Enable user calibration | RW | 0x00 (0dec)
 | 0x8030:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 0x8030:11 | User scale offset | RW | 0x00000000 (0dec)
 | 0x8030:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 0x8030:13 | Limit 1 | RW | 0x0000 (0dec)
 | 0x8030:14 | Limit 2 | RW | 0x0000 (0dec)
 | 0x8030:15 | Filter settings | RW | 0x0000 (0dec)
 | 0x8030:17 | User calibration offset | RW | 0x00000000 (0dec)
 | 0x8030:18 | User calibration gain | RW | 0x4000 (16384dec)
 | 0x8030:19 | Range | RW | 0x0008 (8dec)
803E:0 | Subindex | AI Internal data Ch.2 | RO | 0x01 (1dec)
 | 0x803E:01 | ADC raw value | RO | 0x00000000 (0dec)
803F:0 | Subindex | AI Vendor data Ch.2 | RW | 0x04 (4dec)
 | 0x803F:01 | Calibration offset pressure | RW | 0x00000000 (0dec)
 | 0x803F:02 | Calibration gain pressure | RW | 0x4000 (16384dec)
 | 0x803F:03 | Calibration offset temp | RW | 0x00000000 (0dec)
 | 0x803F:04 | Calibration gain temp | RW | 0x0000 (0dec)
8040:0 | Subindex | AI Settings Ch.3 | RW | 0x19 (25dec)
 | 0x8040:01 | Enable user scale | RW | 0x00 (0dec)
 | 0x8040:06 | Enable filter | RW | 0x01 (1dec)
 | 0x8040:07 | Enable limit 1 | RW | 0x00 (0dec)
 | 0x8040:08 | Enable limit 2 | RW | 0x00 (0dec)
 | 0x8040:0A | Enable user calibration | RW | 0x00 (0dec)
 | 0x8040:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 0x8040:11 | User scale offset | RW | 0x00000000 (0dec)
 | 0x8040:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 0x8040:13 | Limit 1 | RW | 0x0000 (0dec)
 | 0x8040:14 | Limit 2 | RW | 0x0000 (0dec)
 | 0x8040:15 | Filter settings | RW | 0x0000 (0dec)
 | 0x8040:17 | User calibration offset | RW | 0x00000000 (0dec)
 | 0x8040:18 | User calibration gain | RW | 0x4000 (16384dec)
 | 0x8040:19 | Range | RW | 0x0008 (8dec)
804E:0 | Subindex | AI Internal data Ch.3 | RO | 0x01 (1dec)
 | 0x804E:01 | ADC raw value | RO | 0x00000000 (0dec)
804F:0 | Subindex | AI Vendor data Ch.3 | RW | 0x04 (4dec)
 | 0x804F:01 | Calibration offset pressure | RW | 0x00000000 (0dec)
 | 0x804F:02 | Calibration gain pressure | RW | 0x4000 (16384dec)
 | 0x804F:03 | Calibration offset temp | RW | 0x00000000 (0dec)
 | 0x804F:04 | Calibration gain temp | RW | 0x0000 (0dec)
Index (hex) |  | Name | Flags | Default value
8050:0 | Subindex | AI Settings Ch.4 | RW | 0x19 (25dec)
 | 0x8050:01 | Enable user scale | RW | 0x00 (0dec)
 | 0x8050:06 | Enable filter | RW | 0x01 (1dec)
 | 0x8050:07 | Enable limit 1 | RW | 0x00 (0dec)
 | 0x8050:08 | Enable limit 2 | RW | 0x00 (0dec)
 | 0x8050:0A | Enable user calibration | RW | 0x00 (0dec)
 | 0x8050:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 0x8050:11 | User scale offset | RW | 0x00000000 (0dec)
 | 0x8050:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 0x8050:13 | Limit 1 | RW | 0x0000 (0dec)
 | 0x8050:14 | Limit 2 | RW | 0x0000 (0dec)
 | 0x8050:15 | Filter settings | RW | 0x0000 (0dec)
 | 0x8050:17 | User calibration offset | RW | 0x00000000 (0dec)
 | 0x8050:18 | User calibration gain | RW | 0x4000 (16384dec)
 | 0x8050:19 | Range | RW | 0x0008 (8dec)
805E:0 | Subindex | AI Internal data Ch.4 | RO | 0x01 (1dec)
 | 0x805E:01 | ADC raw value | RO | 0x00000000 (0dec)
805F:0 | Subindex | AI Vendor data Ch.4 | RW | 0x04 (4dec)
 | 0x805F:01 | Calibration offset pressure | RW | 0x00000000 (0dec)
 | 0x805F:02 | Calibration gain pressure | RW | 0x4000 (16384dec)
 | 0x805F:03 | Calibration offset temp | RW | 0x00000000 (0dec)
 | 0x805F:04 | Calibration gain temp | RW | 0x0000 (0dec)
F000:0 | Subindex | Modular device profile | RO | 0x02 (2dec)
 | 0xF000:01 | Module index distance | RO | 0x0010 (16dec)
 | 0xF000:02 | Maximum number of modules | RO | 0x0006 (6dec)
F008 |  | Code word | RW | 0x00000000 (0dec)
F010:0 | Subindex | Module list | RW | 0x06 (6dec)
 | 0xF010:01 | SubIndex 001 | RW | 0x00000118 (280dec)
 | 0xF010:02 | SubIndex 002 | RW | 0x00000118 (280dec)
 | 0xF010:03 | SubIndex 003 | RW | 0x0000012C (300dec)
 | 0xF010:04 | SubIndex 004 | RW | 0x0000012C (300dec)
 | 0xF010:05 | SubIndex 005 | RW | 0x0000012C (300dec)
 | 0xF010:06 | SubIndex 006 | RW | 0x0000012C (300dec)
F600:0 | Subindex | DEV Inputs Safe State Active | RO | 0x01 (1dec)
 | 0xF600:01 | Safe State Active | RO | 0x00 (0dec)
F611:0 | Subindex | DEV Inputs Undervoltage | RO | 0x10 (16dec)
 | 0xF611:01 | Undervoltage Us | RO | 0x00 (0dec)
 | 0xF611:02 | Undervoltage Up | RO | 0x00 (0dec)
 | 0xF611:10 | TxPDO Toggle | RO | 0x00 (0dec)
F700:0 | Subindex | DEV Outputs Set Safe State | RO | 0x01 (1dec)
 | 0xF700:01 | Set safe state | RO | 0x00 (0dec)
F800:0 | Subindex | AI Settings Reference | RW | 0x18 (24dec)
 | 0xF800:0A | Enable user calibration | RW | 0x00 (0dec)
 | 0xF800:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 0xF800:17 | User calibration offset | RW | 0x00000000 (0dec)
 | 0xF800:18 | User calibration gain | RW | 0x4000 (16384dec)
F80E:0 | Subindex | AI Internal data Reference | RO | 0x02 (2dec)
 | 0xF80E:01 | ADC raw value 1 | RO | 0x00000000 (0dec)
 | 0xF80E:02 | ADC raw value 2 | RO | 0x00000000 (0dec)
F80F:0 | Subindex | AI Vendor data Reference | RW | 0x04 (4dec)
 | 0xF80F:01 | Calibration offset pressure | RW | 0x00000000 (0dec)
 | 0xF80F:02 | Calibration gain pressure | RW | 0x4000 (16384dec)
 | 0xF80F:03 | Calibration offset temp | RW | 0x00000000 (0dec)
 | 0xF80F:04 | Calibration gain temp | RW | 0x0000 (0dec)
Legend
Flags:
RO = Read Only
RW = Read/Write


Object description and parameterization

CoE parameters [image] Object description and parameterization
Object description and parameterization
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Parameterization via the CoE list (CAN over EtherCAT)
The EtherCAT device is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs).
Introduction
The CoE overview contains objects for different intended applications:
▪
Objects required for parameterization during commissioning
▪
Objects for indicating internal settings (may be fixed)
▪
Further profile-specific objects indicating inputs, outputs and status information
The following section first describes the objects required for normal operation, followed by a complete overview of missing objects.
Additional information
•
Objects to be parameterized during commissioning
•
Standard objects (0x1000-0x1FFF)
•
Profile specific objects (0x6000-0xFFFF)


Objects to be parameterized during commissioning

CoE parameters [image] Object description and parameterization [image] Objects to be parameterized during commissioning
Objects to be parameterized during commissioning
Index 1011 Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default parameters | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" in the set value dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)
Index 8010 Safe state active
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8010:0 | Safe state active |  |  | UINT8 | RO | 0x02 (2dec)
8010:01 | Output 1 | 0 | Output State will remain unchanged during OP-> SafeOP | BOOLEAN | RW | 0x00 (0dec)
 |  | 1 | Output will go to Safe State during OP-> SafeOP
8010:02 | Output 2 | 0 | Output State will remain unchanged during OP-> SafeOP | BOOLEAN | RW | 0x00 (0dec)
 |  | 1 | Output will go to Safe State during OP-> SafeOP
Index 8011 Safe state value
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8011:0 | Safe state value |  |  | UINT8 | RO | 0x02 (2dec)
8011:01 | Output 1 | 0 | Output -> 0 in case of Safe State condition | BOOLEAN | RW | 0x00 (0dec)
 |  | 1 | Output -> 1 in case of Safe State condition
8011:02 | Output 2 | 0 | Output -> 0 in case of Safe State condition | BOOLEAN | RW | 0x00 (0dec)
 |  | 1 | Output -> 1 in case of Safe State condition
Index 8020 AI settings Ch.1 (parameterization of channel 1)
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8020:0 | AI Settings Ch.1 | Maximum subindex |  | UINT8 | RO | 0x19 (25dec)
8020:01 | Enable user scale | 1 | User scale is active. | BOOLEAN | RW | 0x00 (0dec)
8020:06 | Enable filter | 1 | Enable filter, which makes PLC-cycle-synchronous data exchange unnecessary | BOOLEAN | RW | 0x01 (1dec)
8020:07 | Enable limit 1 | 1 | Limit 1 enabled | BOOLEAN | RW | 0x00 (0dec)
8020:08 | Enable limit 2 | 1 | Limit 2 enabled | BOOLEAN | RW | 0x00 (0dec)
8020:0A | Enable user calibration | 1 | Enabling of the user calibration | BOOLEAN | RW | 0x00 (0dec)
8020:0B | Enable vendor calibration | 1 | Enabling of the vendor calibration | BOOLEAN | RW | 0x01 (1dec)
8020:11 | User scale offset | User scale offset |  | INT32 | RW | 0x00000000 (0dec)
8020:12 | User scale gain | User scale gain. The gain is represented in fixed-point format, with the factor 2-16. The value 1 corresponds to 65535dez (0x00010000hex) and is limited to +/- 0x7FFFF |  | INT32 | RW | 0x00010000 (65536dec)
8020:13 | Limit 1 | First limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8020:14 | Limit 2 | Second limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8020:15 | Filter settings | This object determines the digital filter settings for all channels of the module, if it is activated via Enable filter (index 0x80n0:06). The possible settings are sequentially numbered. |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 50 Hz FIR
 |  | 1 | 60 Hz FIR
 |  | 2 | IIR 1
 |  | 3 | IIR 2
 |  | 4 | IIR 3
 |  | 5 | IIR 4
 |  | 6 | IIR 5
 |  | 7 | IIR 6
 |  | 8 | IIR 7
 |  | 9 | IIR 8
8020:17 | User calibration offset |  |  | INT32 | RW | 0x00000000 (0dec)
8020:18 | User calibration gain |  |  | INT16 | RW | 0x4000 (16384dec)
8020:19 | Range | Permissible values: |  | UINT16 | RW | 0x0008 (8dec)
 |  | 8 | Differential pressure measurement relative to the reference sensor
 |  | 7 | Absolute pressure measurement
Index 8030 AI settings Ch.2 (parameterization of channel 2)
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8030:0 | AI Settings Ch.2 | Maximum subindex |  | UINT8 | RO | 0x19 (25dec)
8030:01 | Enable user scale | 1 | User scale is active. | BOOLEAN | RW | 0x00 (0dec)
8030:06 | Enable filter | 1 | Enable filter, which makes PLC-cycle-synchronous data exchange unnecessary | BOOLEAN | RW | 0x01 (1dec)
8030:07 | Enable limit 1 | 1 | Limit 1 enabled | BOOLEAN | RW | 0x00 (0dec)
8030:08 | Enable limit 2 | 1 | Limit 2 enabled | BOOLEAN | RW | 0x00 (0dec)
8030:0A | Enable user calibration | 1 | Enabling of the user calibration | BOOLEAN | RW | 0x00 (0dec)
8030:0B | Enable vendor calibration | 1 | Enabling of the vendor calibration | BOOLEAN | RW | 0x01 (1dec)
8030:11 | User scale offset | User scale offset |  | INT32 | RW | 0x00000000 (0dec)
8030:12 | User scale gain | User scale gain. The gain is represented in fixed-point format, with the factor 2-16. The value 1 corresponds to 65535dez (0x00010000hex) and is limited to +/- 0x7FFFF |  | INT32 | RW | 0x00010000 (65536dec)
8030:13 | Limit 1 | First limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8030:14 | Limit 2 | Second limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8030:15 | Filter settings | This object shows the digital filter settings. The filter settings can only be read here. They are set via channel 1 for all channels of the module. |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 50 Hz FIR
 |  | 1 | 60 Hz FIR
 |  | 2 | IIR 1
 |  | 3 | IIR 2
 |  | 4 | IIR 3
 |  | 5 | IIR 4
 |  | 6 | IIR 5
 |  | 7 | IIR 6
 |  | 8 | IIR 7
 |  | 9 | IIR 8
8030:17 | User calibration offset |  |  | INT32 | RW | 0x00000000 (0dec)
8030:18 | User calibration gain |  |  | INT16 | RW | 0x4000 (16384dec)
8030:19 | Range | Permissible values: |  | UINT16 | RW | 0x0008 (8dec)
 |  | 8 | Differential pressure measurement relative to the reference sensor
 |  | 7 | Absolute pressure measurement
Index 8040 AI settings Ch.3 (parameterization of channel 3)
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8040:0 | AI Settings Ch.3 | Maximum subindex |  | UINT8 | RO | 0x19 (25dec)
8040:01 | Enable user scale | 1 | User scale is active. | BOOLEAN | RW | 0x00 (0dec)
8040:06 | Enable filter | 1 | Enable filter, which makes PLC-cycle-synchronous data exchange unnecessary | BOOLEAN | RW | 0x01 (1dec)
8040:07 | Enable limit 1 | 1 | Limit 1 enabled | BOOLEAN | RW | 0x00 (0dec)
8040:08 | Enable limit 2 | 1 | Limit 2 enabled | BOOLEAN | RW | 0x00 (0dec)
8040:0A | Enable user calibration | 1 | Enabling of the user calibration | BOOLEAN | RW | 0x00 (0dec)
8040:0B | Enable vendor calibration | 1 | Enabling of the vendor calibration | BOOLEAN | RW | 0x01 (1dec)
8040:11 | User scale offset | User scale offset |  | INT32 | RW | 0x00000000 (0dec)
8040:12 | User scale gain | User scale gain. The gain is represented in fixed-point format, with the factor 2-16. The value 1 corresponds to 65535dez (0x00010000hex) and is limited to +/- 0x7FFFF |  | INT32 | RW | 0x00010000 (65536dec)
8040:13 | Limit 1 | First limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8040:14 | Limit 2 | Second limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8040:15 | Filter settings | This object shows the digital filter settings. The filter settings can only be read here. They are set via channel 1 for all channels of the module. |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 50 Hz FIR
 |  | 1 | 60 Hz FIR
 |  | 2 | IIR 1
 |  | 3 | IIR 2
 |  | 4 | IIR 3
 |  | 5 | IIR 4
 |  | 6 | IIR 5
 |  | 7 | IIR 6
 |  | 8 | IIR 7
 |  | 9 | IIR 8
8040:17 | User calibration offset |  |  | INT32 | RW | 0x00000000 (0dec)
8040:18 | User calibration gain |  |  | INT16 | RW | 0x4000 (16384dec)
8040:19 | Range | Permissible values: |  | UINT16 | RW | 0x0008 (8dec)
 |  | 8 | Differential pressure measurement relative to the reference sensor
 |  | 7 | Absolute pressure measurement
Index 8050 AI Settings Ch.3 (parameterization of channel 4)
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8050:0 | AI Settings Ch.4 | Maximum subindex |  | UINT8 | RO | 0x19 (25dec)
8050:01 | Enable user scale | 1 | User scale is active. | BOOLEAN | RW | 0x00 (0dec)
8050:06 | Enable filter | 1 | Enable filter, which makes PLC-cycle-synchronous data exchange unnecessary | BOOLEAN | RW | 0x01 (1dec)
8050:07 | Enable limit 1 | 1 | Limit 1 enabled | BOOLEAN | RW | 0x00 (0dec)
8050:08 | Enable limit 2 | 1 | Limit 2 enabled | BOOLEAN | RW | 0x00 (0dec)
8050:0A | Enable user calibration | 1 | Enabling of the user calibration | BOOLEAN | RW | 0x00 (0dec)
8050:0B | Enable vendor calibration | 1 | Enabling of the vendor calibration | BOOLEAN | RW | 0x01 (1dec)
8050:11 | User scale offset | User scale offset |  | INT32 | RW | 0x00000000 (0dec)
8050:12 | User scale gain | User scale gain. The gain is represented in fixed-point format, with the factor 2-16. The value 1 corresponds to 65535dez (0x00010000hex) and is limited to +/- 0x7FFFF |  | INT32 | RW | 0x00010000 (65536dec)
8050:13 | Limit 1 | First limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8050:14 | Limit 2 | Second limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8050:15 | Filter settings | This object shows the digital filter settings. The filter settings can only be read here. They are set via channel 1 for all channels of the module. |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 50 Hz FIR
 |  | 1 | 60 Hz FIR
 |  | 2 | IIR 1
 |  | 3 | IIR 2
 |  | 4 | IIR 3
 |  | 5 | IIR 4
 |  | 6 | IIR 5
 |  | 7 | IIR 6
 |  | 8 | IIR 7
 |  | 9 | IIR 8
8050:17 | User calibration offset |  |  | INT32 | RW | 0x00000000 (0dec)
8050:18 | User calibration gain |  |  | INT16 | RW | 0x4000 (16384dec)
8050:19 | Range | Permissible values: |  | UINT16 | RW | 0x0008 (8dec)
 |  | 8 | Differential pressure measurement relative to the reference sensor
 |  | 7 | Absolute pressure measurement


Standard objects (0x1000-0x1FFF)

CoE parameters [image] Object description and parameterization [image] Standard objects (0x1000-0x1FFF)
Standard objects (0x1000-0x1FFF)
The standard objects of all EtherCAT slaves have the same meaning.
Index 1000 Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Lo-Word contains the supported CoE Profile (5001). The Hi-Word contains the Module Profile corresponding to the Modular Device Profile. | UINT32 | RO | 0x00001389 (5001dec)
Index 1008 Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EP3744-0041
Index 1009: Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slaves | STRING | RO |
Index 100A Software version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slaves | STRING | RO | 00
Index 1018 Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | contains information to identify the EtherCAT slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x0EA04052 (245383250dec)
1018:03 | Revision | Revision number of the EtherCAT-Slave, the Lo-Word (Bit 0-15) indicates the special functions terminal number; the Hi-Word (Bit 16-31) refers to the device description. | UINT32 | RO | 0x00000000 (0dec)
1018:04 | Serial number | Serial number of the EtherCAT-Slave, the Lo-Byte (Bit 0-7) of the Lo-Word contains the year of manufacturing, the Hi-Byte (Bit 8-15) of the Lo-Word contains the week of manufacturing, the Hi-Word (Bit 16-31) is 0. | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 Backup parameter handling
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | contains information for the standardized Upload and Download of the Backup Entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum over all backup entries | UINT32 | RO | 0x00000000 (0dec)
Index 1600 DIG RxPDO-Map Outputs
Index (hex) | Name | Meaning | Data type | Flags | Default
1600:0 | DIG RxPDO-Map Outputs | PDO Mapping RxPDO 1 | UINT8 | RO | 0x03 (3dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (Dig Outputs), entry 0x01 (Output 1)) | UINT32 | RO | 0x7010:01, 1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (Dig Outputs), entry 0x02 (Output 2)) | UINT32 | RO | 0x7010:02, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (14 bits align) | UINT32 | RO | 0x0000:00, 14
Index 1601 DEV RxPDO-Map Outputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1601:0 | DEV RxPDO-Map Outputs Device | PDO Mapping RxPDO 2 | UINT8 | RO | 0x02 (2dec)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF700 (DEV Outputs Set Safe State), entry 0x01 (Set safe state)) | UINT32 | RO | 0xF700:01, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF700 (DEV Outputs Set Safe State), entry 0x02 (Reset Outputs)) | UINT32 | RO | 0x0000:00, 15
Index 1A00 DIG TxPDO-Map Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
1A00:0 | DIG TxPDO-Map Inputs | PDO Mapping TxPDO 1 | UINT8 | RO | 0x07 (7dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (Dig Inputs), entry 0x01 (Input 1)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (Dig Inputs), entry 0x02 (Input 2)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (Dig Inputs), entry 0x03 (Input 3)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (Dig Inputs), entry 0x04 (Input 4)) | UINT32 | RO | 0x6000:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (Dig Inputs), entry 0x05 (Input 5)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (Dig Inputs), entry 0x06 (Input 6)) | UINT32 | RO | 0x6000:06, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (10 bits align) | UINT32 | RO | 0x0000:00, 10
Index 1A01 AI TxPDO-Map Inputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A01:0 | AI TxPDO-Map Inputs Ch.1 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x09 (9dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (AI Inputs Ch.1), entry 0x01 (Underrange)) | UINT32 | RO | 0x6020:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (AI Inputs Ch.1), entry 0x02 (Overrange)) | UINT32 | RO | 0x6020:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (AI Inputs Ch.1), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6020:03, 2
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (AI Inputs Ch.1), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6020:05, 2
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (AI Inputs Ch.1), entry 0x07 (Error)) | UINT32 | RO | 0x6020:07, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020 (AI Inputs Ch.1), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6020:0F, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6020 (AI Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6020:10, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6020 (AI Inputs Ch.1), entry 0x11 (Value)) | UINT32 | RO | 0x6020:11, 32
Index 1A02 AI TxPDO-Map Inputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A02:0 | AI TxPDO-Map Inputs Ch.2 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x09 (9dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6030 (AI Inputs Ch.2), entry 0x01 (Underrange)) | UINT32 | RO | 0x6030:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6030 (AI Inputs Ch.2), entry 0x02 (Overrange)) | UINT32 | RO | 0x6030:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6030 (AI Inputs Ch.2), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6030:03, 2
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6030 (AI Inputs Ch.2), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6030:05, 2
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6030 (AI Inputs Ch.2), entry 0x07 (Error)) | UINT32 | RO | 0x6030:07, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6030 (AI Inputs Ch.2), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6030:0F, 1
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6030 (AI Inputs Ch.2), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6030:10, 1
1A02:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6030 (AI Inputs Ch.2), entry 0x11 (Value)) | UINT32 | RO | 0x6030:11, 32
Index 1A03 AI TxPDO-Map Inputs Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1A03:0 | AI TxPDO-Map Inputs Ch.3 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x09 (9dec)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6040 (AI Inputs Ch.3), entry 0x01 (Underrange)) | UINT32 | RO | 0x6040:01, 1
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6040 (AI Inputs Ch.3), entry 0x02 (Overrange)) | UINT32 | RO | 0x6040:02, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6040 (AI Inputs Ch.3), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6040:03, 2
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6040 (AI Inputs Ch.3), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6040:05, 2
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6040 (AI Inputs Ch.3), entry 0x07 (Error)) | UINT32 | RO | 0x6040:07, 1
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A03:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6040 (AI Inputs Ch.3), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6040:0F, 1
1A03:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6040 (AI Inputs Ch.3), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6040:10, 1
1A03:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6040 (AI Inputs Ch.3), entry 0x11 (Value)) | UINT32 | RO | 0x6040:11, 32
Index 1A04 AI TxPDO-Map Inputs Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
1A04:0 | AI TxPDO-Map Inputs Ch.4 | PDO Mapping TxPDO 5 | UINT8 | RO | 0x09 (9dec)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6050 (AI Inputs Ch.4), entry 0x01 (Underrange)) | UINT32 | RO | 0x6050:01, 1
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6050 (AI Inputs Ch.4), entry 0x02 (Overrange)) | UINT32 | RO | 0x6050:02, 1
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6050 (AI Inputs Ch.4), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6050:03, 2
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6050 (AI Inputs Ch.4), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6050:05, 2
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6050 (AI Inputs Ch.4), entry 0x07 (Error)) | UINT32 | RO | 0x6050:07, 1
1A04:06 | SubIndex 006 | 6. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A04:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6050 (AI Inputs Ch.4), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6050:0F, 1
1A04:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6050 (AI Inputs Ch.4), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6050:10, 1
1A04:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6050 (AI Inputs Ch.4), entry 0x11 (Value)) | UINT32 | RO | 0x6050:11, 32
Index 1A05 DEV TxPDO-Map Inputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1A05:0 | DEV TxPDO-Map Inputs Device | PDO Mapping TxPDO 6 | UINT8 | RO | 0x07 (7dec)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF600 (DEV Inputs Safe State Active), entry 0x01 (Safe State Active)) | UINT32 | RO | 0xF600:01, 1
1A05:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1A05:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF611 (DEV Inputs Undervoltage), entry 0x01 (Undervoltage Us )) | UINT32 | RO | 0xF611:01, 1
1A05:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF611 (DEV Inputs Undervoltage), entry 0x02 (Undervoltage Up)) | UINT32 | RO | 0xF611:02, 1
1A05:05 | SubIndex 005 | 5. PDO Mapping entry (13 bits align) | UINT32 | RO | 0x0000:00, 13
1A05:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF611 (DEV Inputs Undervoltage), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0xF611:10, 1
1A05:07 | SubIndex 007 | 7. PDO Mapping entry (96 bits align) | UINT32 | RO | 0x0000:00, 96
Index 1C00 Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Usage of the Sync Manager channels | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x02 (2dec)
1C12:01 | Subindex 001 | 1. assigned RxPDO (contains the index of the corresponding RxPDO Mapping object) | UINT16 | RW | 0x1600 (5632dec)
1C12:02 | Subindex 002 | 2. assigned RxPDO (contains the index of the corresponding RxPDO Mapping object) | UINT16 | RW | 0x1601 (5633dec)
Index 1C13 TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x06 (6dec)
1C13:01 | Subindex 001 | 1. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A01 (6657dec)
1C13:03 | Subindex 003 | 3. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A02 (6658dec)
1C13:04 | Subindex 004 | 4. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A03 (6659dec)
1C13:05 | Subindex 005 | 5. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A04 (6660dec)
1C13:06 | Subindex 006 | 6. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A05 (6661dec)
Index 1C32 SM output parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C32:0
SM output parameter
Synchronization parameter of the outputs
UINT8
RO
0x20 (32dec)
1C32:01
Sync mode
actual synchronization mode:
▪
0: Free Run
▪
1: Synchronous with SM 2 Event
▪
2: DC-Mode - Synchronous with SYNC0 Event
▪
3: DC-Mode - Synchronous with SYNC1 Event
UINT16
RW
0x0001 (1dec)
1C32:02
Cycle time
Cycle time (in ns):
▪
Free Run: cycle time of the local timer
▪
Synchronous with SM 2 Event: Cycle time of the master
▪
DC-Mode: SYNC0/SYNC1 Cycle time
UINT32
RW
0x003D0900 (4000000dec)
1C32:03
Shift time
Time between SYNC0 Event and Outputs Valid (in ns, only in DC-Mode)
UINT32
RO
0x00000384 (900dec)
1C32:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0 = 1: Free Run is supported
▪
Bit 1 = 1: Synchronous with SM 2 Event is supported
▪
Bit 2-3 = 01: DC-Mode is supported
▪
Bit 4-5 = 10: Output Shift with SYNC1 Event (only DC-Mode)
▪
Bit 14 = 1: dynamic times (could be measured by writing 0x1C32:08)
UINT16
RO
0xC007 (49159dec)
1C32:05
Minimum cycle time
Minimum cycle time supported (in ns)
UINT32
RO
0x000F4240 (1000000dec)
1C32:06
Calc and copy time
Minimal time between SYNC0 and SYNC1 Event (in ns, only in DC-Mode)
UINT32
RO
0x00000000 (0dec)
1C32:07
Minimum delay time
UINT32
RO
0x00000384 (900dec)
1C32:08
Command
▪
0: Measurement of the times will be stopped
▪
1: Measurement of the times will be started
The Entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 will be updated with the maximum measured values.
UINT16
RW
0x0000 (0dec)
1C32:09
Maximum delay time
Time between SYNC1 Event and Outputs Valid (in ns, only in DC-Mode)
UINT32
RO
0x00000384 (900dec)
1C32:0B
SM event missed counter
Number of the missed SM-Events in state OPERATIONAL (only in DC Mode)
UINT16
RO
0x0000 (0dec)
1C32:0C
Cycle exceeded counter
Number of exceeded cycles in state OPERATIONAL
UINT16
RO
0x0000 (0dec)
1C32:0D
Shift too short counter
Number of inadequate distances between SYNC0 and SYNC1 events (only in DC Mode)
UINT16
RO
0x0000 (0dec)
1C32:20
Sync error
TRUE: In the last cycle the synchronization was not correct (only in DC Mode)
BOOLEAN
RO
0x00 (0dec)
Index 1C33 SM input parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameter of the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
actual synchronization mode:
▪
0: Free Run
▪
1: Synchronous with SM 3 Event (no Outputs available)
▪
2: DC - Synchronous with SYNC0 Event
▪
3: DC - Synchronous with SYNC1 Event
▪
34: Synchronous with SM 2 Event (Outputs available)
UINT16
RW
0x0022 (34dec)
1C33:02
Cycle time
same as 0x1C32:02
UINT32
RW
0x003D0900 (4000000dec)
1C33:03
Shift time
time between SYNC0-Event and Input Latch (in ns, only in DC-Mode)
UINT32
RO
0x00000384 (900dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: Free Run is supported
▪
Bit 1: Synchronous with SM 2 Event is supported (Outputs available)
▪
Bit 1: Synchronous with SM 3 Event is supported (no Outputs available)
▪
Bit 2-3 = 01: DC-Mode is supported
▪
Bit 4-5 = 01: Input Shift with local event (Outputs available)
▪
Bit 4-5 = 10: Input Shift with SYNC1 Event (no Outputs available)
▪
Bit 14 = 1: dynamic times (could be measured by writing 0x1C32:08 or 0x1C33:08)
UINT16
RO
0xC007 (49159dec)
1C33:05
Minimum cycle time
same as 0x1C32:05
UINT32
RO
0x000F4240 (1000000dec)
1C33:06
Calc and copy time
time between Input Latch and the availability of the inputs for the master (in ns, only in DC-Mode)
UINT32
RO
0x00000000 (0dec)
1C33:07
Minimum delay time
UINT32
RO
0x00000384 (900dec)
1C33:08
Command
same as 0x1C32:08
UINT16
RW
0x0000 (0dec)
1C33:09
Maximum delay time
time between SYNC1-Event and Input Latch (in ns, only in DC-Mode)
UINT32
RO
0x00000384 (900dec)
1C33:0B
SM event missed counter
same as 0x1C32:11
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
same as 0x1C32:12
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
same as 0x1C32:13
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
same as 0x1C32:32
BOOLEAN
RO
0x00 (0dec)


Profile specific objects (0x6000-0xFFFF)

CoE parameters [image] Object description and parameterization [image] Profile specific objects (0x6000-0xFFFF)
Profile specific objects (0x6000-0xFFFF)
Profile specific objects (0x6000-0xFFFF)
The profile specific objects have the same meaning for all EtherCAT Slaves which support the profile 5001.
Index 6020 AI Inputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
6020:0 | AI Inputs Ch.1 |  | UINT8 | RO | 0x11 (17dec)
6020:01 | Underrange | Underrange event active | BOOLEAN | RO | 0x00 (0dec)
6020:02 | Overrange | Overrange event active | BOOLEAN | RO | 0x00 (0dec)
6020:03 | Limit 1 |  | BIT2 | RO | 0x00 (0dec)
6020:05 | Limit 2 | Bit0: Value greater than Limit2 Bit1: Value smaller than Limit2 | BIT2 | RO | 0x00 (0dec)
6020:07 | Error | Bit set when Over- or Underrange | BOOLEAN | RO | 0x00 (0dec)
6020:0F | TxPDO State |  | BOOLEAN | RO | 0x00 (0dec)
6020:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)
6020:11 | Value |  | INT32 | RO | 0x00000000 (0dec)
Index 6030 AI Inputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
6030:0 | AI Inputs Ch.2 |  | UINT8 | RO | 0x11 (17dec)
6030:01 | Underrange | Underrange event active | BOOLEAN | RO | 0x00 (0dec)
6030:02 | Overrange | Overrange event active | BOOLEAN | RO | 0x00 (0dec)
6030:03 | Limit 1 |  | BIT2 | RO | 0x00 (0dec)
6030:05 | Limit 2 | Bit0: Value greater than Limit2 Bit1: Value smaller than Limit2 | BIT2 | RO | 0x00 (0dec)
6030:07 | Error | Bit set when Over- or Underrange | BOOLEAN | RO | 0x00 (0dec)
6030:0F | TxPDO State |  | BOOLEAN | RO | 0x00 (0dec)
6030:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)
6030:11 | Value |  | INT32 | RO | 0x00000000 (0dec)
Index 6040 AI Inputs Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
6040:0 | AI Inputs Ch.3 |  | UINT8 | RO | 0x11 (17dec)
6040:01 | Underrange | Underrange event active | BOOLEAN | RO | 0x00 (0dec)
6040:02 | Overrange | Overrange event active | BOOLEAN | RO | 0x00 (0dec)
6040:03 | Limit 1 |  | BIT2 | RO | 0x00 (0dec)
6040:05 | Limit 2 | Bit0: Value greater than Limit2 Bit1: Value smaller than Limit2 | BIT2 | RO | 0x00 (0dec)
6040:07 | Error | Bit set when Over- or Underrange | BOOLEAN | RO | 0x00 (0dec)
6040:0F | TxPDO State |  | BOOLEAN | RO | 0x00 (0dec)
6040:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)
6040:11 | Value |  | INT32 | RO | 0x00000000 (0dec)
Index 6050 AI Inputs Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
6050:0 | AI Inputs Ch.4 |  | UINT8 | RO | 0x11 (17dec)
6050:01 | Underrange | Underrange event active | BOOLEAN | RO | 0x00 (0dec)
6050:02 | Overrange | Overrange event active | BOOLEAN | RO | 0x00 (0dec)
6050:03 | Limit 1 |  | BIT2 | RO | 0x00 (0dec)
6050:05 | Limit 2 | Bit0: Value greater than Limit2 Bit1: Value smaller than Limit2 | BIT2 | RO | 0x00 (0dec)
6050:07 | Error | Bit set when Over- or Underrange | BOOLEAN | RO | 0x00 (0dec)
6050:0F | TxPDO State |  | BOOLEAN | RO | 0x00 (0dec)
6050:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)
6050:11 | Value |  | INT32 | RO | 0x00000000 (0dec)
Index 6000 Dig Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
6000:0 | Dig Inputs |  | UINT8 | RO | 0x06 (6dec)
6000:01 | Input 1 |  | BOOLEAN | RO | 0x00 (0dec)
6000:02 | Input 2 |  | BOOLEAN | RO | 0x00 (0dec)
6000:03 | Input 3 |  | BOOLEAN | RO | 0x00 (0dec)
6000:04 | Input 4 |  | BOOLEAN | RO | 0x00 (0dec)
6000:05 | Input 5 |  | BOOLEAN | RO | 0x00 (0dec)
6000:06 | Input 6 |  | BOOLEAN | RO | 0x00 (0dec)
Index 7010 Dig Outputs
Index (hex) | Name | Meaning | Data type | Flags | Default
7010:0 | Dig Outputs |  | UINT8 | RO | 0x02 (2dec)
7010:01 | Output 1 |  | BOOLEAN | RO | 0x00 (0dec)
7010:02 | Output 2 |  | BOOLEAN | RO | 0x00 (0dec)
Index 802E AI Internal data Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
802E:0 | AI Internal data Ch.1 |  | UINT8 | RO | 0x01 (1dec)
802E:01 | ADC raw value |  | INT32 | RO | 0x00000000 (0dec)
Index 802F AI Vendor data Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
802F:0 | AI Vendor data Ch.1 |  | UINT8 | RO | 0x04 (4dec)
802F:01 | Calibration offset pressure |  | INT32 | RW | 0x00000000 (0dec)
802F:02 | Calibration gain pressure |  | INT16 | RW | 0x4000 (16384dec)
802F:03 | Calibration offset temp |  | INT32 | RW | 0x00000000 (0dec)
802F:04 | Calibration gain temp |  | INT16 | RW | 0x0000 (0dec)
Index 803E AI Internal data Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
803E:0 | AI Internal data Ch.2 |  | UINT8 | RO | 0x01 (1dec)
803E:01 | ADC raw value |  | INT32 | RO | 0x00000000 (0dec)
Index 803F AI Vendor data Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
803F:0 | AI Vendor data Ch.2 |  | UINT8 | RO | 0x04 (4dec)
803F:01 | Calibration offset pressure |  | INT32 | RW | 0x00000000 (0dec)
803F:02 | Calibration gain pressure |  | INT16 | RW | 0x4000 (16384dec)
803F:03 | Calibration offset temp |  | INT32 | RW | 0x00000000 (0dec)
803F:04 | Calibration gain temp |  | INT16 | RW | 0x0000 (0dec)
Index 804E AI Internal data Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
804E:0 | AI Internal data Ch.3 |  | UINT8 | RO | 0x01 (1dec)
804E:01 | ADC raw value |  | INT32 | RO | 0x00000000 (0dec)
Index 804F AI Vendor data Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
804F:0 | AI Vendor data Ch.3 |  | UINT8 | RO | 0x04 (4dec)
804F:01 | Calibration offset pressure |  | INT32 | RW | 0x00000000 (0dec)
804F:02 | Calibration gain pressure |  | INT16 | RW | 0x4000 (16384dec)
804F:03 | Calibration offset temp |  | INT32 | RW | 0x00000000 (0dec)
804F:04 | Calibration gain temp |  | INT16 | RW | 0x0000 (0dec)
Index 805E AI Internal data Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
805E:0 | AI Internal data Ch.4 |  | UINT8 | RO | 0x01 (1dec)
805E:01 | ADC raw value |  | INT32 | RO | 0x00000000 (0dec)
Index 805F AI Vendor data Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
805F:0 | AI Vendor data Ch.4 |  | UINT8 | RO | 0x04 (4dec)
805F:01 | Calibration offset pressure |  | INT32 | RW | 0x00000000 (0dec)
805F:02 | Calibration gain pressure |  | INT16 | RW | 0x4000 (16384dec)
805F:03 | Calibration offset temp |  | INT32 | RW | 0x00000000 (0dec)
805F:04 | Calibration gain temp |  | INT16 | RW | 0x0000 (0dec)
Index F000 Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | general information about the Modular Device Profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance between the objects of two channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | number of channels | UINT16 | RO | 0x0006 (6dec)
Index F008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word |  | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module list
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list |  | UINT8 | RW | 0x06 (6dec)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x00000118 (280dec)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x00000118 (280dec)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x0000012C (300dec)
F010:04 | SubIndex 004 |  | UINT32 | RW | 0x0000012C (300dec)
F010:05 | SubIndex 005 |  | UINT32 | RW | 0x0000012C (300dec)
F010:06 | SubIndex 006 |  | UINT32 | RW | 0x0000012C (300dec)
Index F600 DEV Inputs Safe State Active
Index (hex) | Name | Meaning | Data type | Flags | Default
F600:0 | DEV Inputs Safe State Active |  | UINT8 | RO | 0x01 (1dec)
F600:01 | Safe State Active | 1: Outputs are in Safe State 0: Outputs are in Normal State | BOOLEAN | RO | 0x00 (0dec)
Index F611 DEV Inputs Undervoltage
Index (hex) | Name | Meaning | Data type | Flags | Default
F611:0 | DEV Inputs Undervoltage |  | UINT8 | RO | 0x10 (16dec)
F611:01 | Undervoltage Us | Us ≤ 18 V | BOOLEAN | RO | 0x00 (0dec)
F611:02 | Undervoltage Up | Up ≤ 18 V | BOOLEAN | RO | 0x00 (0dec)
F611:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)
Index F700 DEV Outputs Set Safe State
Index (hex) | Name | Meaning | Data type | Flags | Default
F700:0 | DEV Outputs Set Safe State |  | UINT8 | RO | 0x01 (1dec)
F700:01 | Set safe state | Set Device to Safe State | BOOLEAN | RO | 0x00 (0dec)
Index F800 AI Settings Reference
Index (hex) | Name | Meaning | Data type | Flags | Default
F800:0 | AI Settings Reference |  | UINT8 | RO | 0x18 (24dec)
F800:0A | Enable user calibration |  | BOOLEAN | RW | 0x00 (0dec)
F800:0B | Enable vendor calibration |  | BOOLEAN | RW | 0x01 (1dec)
F800:17 | User calibration offset |  | INT32 | RW | 0x00000000 (0dec)
F800:18 | User calibration gain |  | INT16 | RW | 0x4000 (16384dec)
Index F80E AI Internal data Reference
Index (hex) | Name | Meaning | Data type | Flags | Default
F80E:0 | AI Internal data Reference |  | UINT8 | RO | 0x02 (2dec)
F80E:01 | ADC raw value 1 | Pressure Value | INT32 | RO | 0x00000000 (0dec)
F80E:02 | ADC raw value 2 | Pressure Value | INT32 | RO | 0x00000000 (0dec)
Index F80F AI Vendor data Reference
Index (hex) | Name | Meaning | Data type | Flags | Default
F80F:0 | AI Vendor data Reference |  | UINT8 | RO | 0x04 (4dec)
F80F:01 | Calibration offset pressure |  | INT32 | RW | 0x00000000 (0dec)
F80F:02 | Calibration gain pressure |  | INT16 | RW | 0x4000 (16384dec)
F80F:03 | Calibration offset temp |  | INT32 | RW | 0x00000000 (0dec)
F80F:04 | Calibration gain temp |  | INT16 | RW | 0x0000 (0dec)


Appendix

Appendix
Appendix
Additional information
•
General operating conditions
•
EtherCAT Box- / EtherCAT P Box - Accessories
•
Version identification of EtherCAT devices
•
Support and Service


General operating conditions

Appendix [image] General operating conditions
General operating conditions
Protection degrees (IP-Code)
The standard IEC 60529 (DIN EN 60529) defines the degrees of protection in different classes.
1. Number: dust protection and touch guard | Definition
0 | Non-protected
1 | Protected against access to hazardous parts with the back of a hand. Protected against solid foreign objects of Ø 50 mm
2 | Protected against access to hazardous parts with a finger. Protected against solid foreign objects of Ø 12.5 mm.
3 | Protected against access to hazardous parts with a tool. Protected against solid foreign objects Ø 2.5 mm.
4 | Protected against access to hazardous parts with a wire. Protected against solid foreign objects Ø 1 mm.
5 | Protected against access to hazardous parts with a wire. Dust-protected. Intrusion of dust is not totally prevented, but dust shall not penetrate in a quantity to interfere with satisfactory operation of the device or to impair safety.
6 | Protected against access to hazardous parts with a wire. Dust-tight. No intrusion of dust.
2. Number: water* protection | Definition
0 | Non-protected
1 | Protected against water drops
2 | Protected against water drops when enclosure tilted up to 15°.
3 | Protected against spraying water. Water sprayed at an angle up to 60° on either side of the vertical shall have no harmful effects.
4 | Protected against splashing water. Water splashed against the disclosure from any direction shall have no harmful effects
5 | Protected against water jets
6 | Protected against powerful water jets
7 | Protected against the effects of temporary immersion in water. Intrusion of water in quantities causing harmful effects shall not be possible when the enclosure is temporarily immersed in water for 30 min. in 1 m depth.
*) These protection classes define only protection against water!
Chemical Resistance
The Resistance relates to the Housing of the IP 67 modules and the used metal parts. In the table below you will find some typical resistance.
Character | Resistance
Steam | at temperatures >100°C: not resistant
Sodium base liquor (ph-Value > 12) | at room temperature: resistant > 40°C: not resistant
Acetic acid | not resistant
Argon (technical clean) | resistant
Key
▪
resistant: Lifetime several months
▪
non inherently resistant: Lifetime several weeks
▪
not resistant: Lifetime several hours resp. early decomposition


EtherCAT Box- / EtherCAT P Box - Accessories

Appendix [image] EtherCAT Box- / EtherCAT P Box - Accessories
EtherCAT Box- / EtherCAT P Box - Accessories
Fixing
Ordering information | Description
ZS5300-0001 | Mounting rail (500 mm x 129 mm)
Marking material, plugs
Ordering information | Description
ZS5000-0000 | Fieldbus Box set M8 (contact labels, plugs)
ZS5000-0002 | Fieldbus Box set M12 (contact labels, plugs)
ZS5000-0010 | plugs M8, IP67 (50 pieces)
ZS5000-0020 | plugs M12, IP67 (50 pieces)
ZS5100-0000 | marking labels, not printed, 4 stripes at 10 pieces
ZS5100-xxxx | printed marking labels, on request
Tools
Ordering information | Description
ZB8800 | torque wrench for M8 cables with knurl, incl. ratchet
ZB8800-0001 | M12 ratchet for torque wrench ZB8800
ZB8800-0002 | M8 ratchet (field assembly) for torque wrench ZB8800
ZB8801-0000 | torque wrench for hexagonal plugs, adjustable
ZB8801-0001 | torque cable key, M8/wrench size 9, for torque wrench ZB8801-0000
ZB8801-0002 | torque cable key, M12/wrench size 13, for torque wrench ZB8801-0000
ZB8801-0003 | torque cable key, M12 field assembly/wrench size 13, for torque wrench ZB8801-0000
Further accessories
Further accessories may be found at the price list for Beckhoff fieldbus components and at the internet under https://www.beckhoff.com


Version identification of EtherCAT devices

Appendix [image] Version identification of EtherCAT devices
Version identification of EtherCAT devices
Designation
A Beckhoff EtherCAT device has a 14-digit designation, made up of
▪
family key
▪
type
▪
version
▪
revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
Notes
▪
The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
▪
EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
▪
The order identifier is made up of
- family key (EL, EP, CU, ES, KL, CX, etc.)
- type (3314)
- version (-0000)
▪
The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
▪
The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Identification number
Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:
Production lot/batch number/serial number/date code/D number
The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02
Exceptions can occur in the IP67 area, where the following syntax can be used (see respective device documentation):
Syntax: D ww yy x y z u
D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB
Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1
Unique serial number/ID, ID number
In addition, in some series each individual module has its own unique serial number.
See also the further documentation in the area
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Terminals with factory calibration certificate and other measuring terminals
Examples of markings
EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
CU2016 switch with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
EP1258-00001 IP67 EtherCAT Box with batch number/ date code 22090101 and unique serial number 158102
EP1908-0002 IP67 EtherCAT Safety Box with batch number/ date code 071201FF and unique serial number 00346070
EL2904 IP20 safety terminal with batch number/ date code 50110302 and unique serial number 00331701
ELM3604-0002 terminal with unique ID number (QR code) 100001051 and serial/ batch number 44160201
Additional information
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Appendix [image] Version identification of EtherCAT devices [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com