EP3356-0022 – EtherCAT Box for precise load cell analysis (resistor bridge), 24-bit
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
1.4
▪
Front page updated
1.3
▪
Parallel connection of resistor bridges made clearer
1.2
▪
Technical Data updated
1.1.0
▪
Update Safety instructions
▪
Update chapter Mounting and Cabling
1.0.4
▪
Technical Data updated
▪
Signal connection updated
1.0.3
▪
Basic function principles updated
1.0.2
▪
Nut torque for connectors updated
1.0.1
▪
Analog voltage inputs M12 and meaning of the LEDs updated
1.0.0
▪
First publication
0.5
▪
First preliminary version
Firm and hardware version
The documentation refers to the firm and hardware status that was valid at the time it was prepared.
The properties of the modules are subject to continuous development and improvement. Modules having earlier production statuses cannot have the same properties as modules with the latest status. Existing properties, however, are always retained and are not changed, so that these modules can always be replaced by new ones.
The firmware and hardware version (delivery state) can be found in the batch number (D number) printed at the side of the EtherCAT Box.
Syntax of the batch number (D number)
D: WW YY FF HH | Example with D No. 29 10 02 01:
WW - week of production (calendar week) | 29 - week of production 29
YY - year of production | 10 - year of production 2010
FF - firmware version | 02 - firmware version 02
HH - hardware version | 01 - hardware version 01
Further information on this topic: Version identification of EtherCAT devices.


Product overview

Product overview
Product overview
Additional information
•
EP3356-0022 - Introduction
•
EP3356-0022 - Technical data
•
Scope of supply


EP3356-0022 - Introduction

Product overview [image] EP3356-0022 - Introduction
EP3356-0022 - Introduction
EP3356-0022
1-channel precise load cell analysis (resistor bridge), 24 bit
The EP3356 EtherCAT Box enables direct connection of a resistor bridge or load cell in a 4-wire connection technology. The ratio between the bridge voltage UD and the supply voltage UREF is determined simultaneously in the input circuit and the final load value is calculated as a process value on the basis of the settings in the EP3356. With automatic self-calibration (can be deactivated), dynamic filters and distributed clock support, the EP3356 with measuring cycles of 100 µs can be used for fast and precise monitoring of torque or vibration sensors.
The EP3356 can also be used to analyze up to four resistor bridges connected in parallel: Further Information
Quick links


EP3356-0022 - Technical data

Product overview [image] EP3356-0022 - Technical data
EP3356-0022 - Technical data
Technical data | EP3356-0022
Number of inputs | 2, for 1 resistor bridge in full bridge technology
Signal connection sockets | M12
Resolution | 24 Bit, 32 bit presentation
Conversion time | 0.1 ms…250 ms, configurable, max. 10,000 samples/s
Nominal voltage | 24 VDC (-15 %/+20 %)
Distributed Clocks | yes
selectable modes | yes (2)
Measuring error | <±0.01 % for the calculated load value in relation to the final load value with a 12 V feed and 24 mV bridge voltage (hence nominal strain gauge characteristic value of 2 mV/V), self-calibration active, 50 Hz filter active. Attention: Due to external influences such as temperature drifts and HF-disturbances may possibly occur a not insignificant error!
Measuring range UD | max. -27 mV…+27 mV typ. (see note concerning voltage measuring recommended: -25 mV…+25 mV rated voltage
Measuring range Uref | max. -13.8 V…+13.8 V typ. (see note concerning voltage measuring recommended: -12 V…+12 V rated voltage
Supported nominal sensitivity | all, resolution of parameter: 0.01 µV/V Recommended: 0.5 mV/V…4 mV/V
Min. strain gauge resistor | parallel operation of strain gauges only with suitable strain gauges recommended
Input filter limit frequency (hardware) | 10 kHz low pass (-3 dB)
Filter (software) | Present 50 Hz, Configurable: 50/60 Hz FIR notch filter, IIR low pass 4-fold averager
Internal resistance | >200 kΩ (Uref), > 1 MΩ (Ud)
Special features | self-calibration, quadruple averager, dynamic filters, fast data sampling, parallel connection
Sensor supply Uref | Uref = 10 V (supplied by the EP3356 from UP) max. 350 mA
Current consumption from US (without sensor current) | 120 mA
Power supply connection | feed: 1 x M8 male socket, 4-pin downstream connection: 1 x M8 female socket, 4-pin
Permissible ambient temperature during operation | -25 .. +60 °C -25 .. +55 °C (according to cURus, see UL Requirements)
Permissible ambient temperature during storage | -40°C…+85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Dimensions | 126 mm x 60 mm x 40 mm
Weight | approx.. 450 g
Installation position | variable
Protection class | IP65, IP66, IP67 (according to EN 60529)
Approvals | CE, cURus
Additional information
•
Additional checks


Additional checks

Product overview [image] EP3356-0022 - Technical data [image] Additional checks
Additional checks
The boxes have undergone the following additional tests:
Verification | Explanation
Vibration | 10 frequency runs in 3 axes
 | 5 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 35 g, 11 ms


Scope of supply

Product overview [image] Scope of supply
Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EtherCAT Box EP3356-0022
▪
2x protective cap for EtherCAT socket, M8, green (pre-assembled)
▪
1x protective cap for supply voltage input, M8, transparent (pre-assembled)
▪
1x protective cap for supply voltage output, M8, black (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


Basic principles of strain gauge technology

Basic principles of strain gauge technology
Basic principles of strain gauge technology
Basic information on the technological field of "strain gauges/load cells" as metrological instruments is to be given below. The information is of general nature; it is up to the user to check the extent to which it applies to his application.
▪
Strain gauges serve either to directly measure the static (0 to a few Hz) or dynamic (up to several KHz) elongations, compressions or torsions of a body by being directly fixed to it, or to measure various forces or movements as part of a sensor (e.g. load cells/force transducers, displacement sensor, vibration sensors).
▪
In the case of the optical strain gauge (e.g. Bragg grating), an application of force causes a proportional change in the optical characteristics of a fiber used as a sensor. Light with a certain wavelength is fed into the sensor. Depending upon the deformation of the grating, which is laser-cut into the sensor, due to the mechanical load, part of the light is reflected and evaluated using a suitable measuring transducer (interrogator).
The commonest principle in the industrial environment is the electrical strain gauge. There are many common terms for this type of sensor: load cell, weighbridge, etc.
Structure of electrical strain gauges
A strain gauge consists of a carrier material (e.g. stretchable plastic film) with an applied metal film from which a lattice of electrically conductive resistive material is worked in very different geometrical forms, depending on the requirements.
Strain gauge
This utilizes a behavior whereby, for example in the case of strain, the length of a metallic resistance network increases and its diameter decreases, as a result of which its electrical resistance increases proportionally.
ΔR/R = k*ε
ε = Δl/l thereby corresponds to the elongation; the strain sensitivity is called the k-factor. This also gives rise to the typical track layout inside the strain gauge: the resistor track or course is laid in a meandering pattern in order to expose the longest possible length to the strain.
Example
The elongation ε = 0.1 % of a strain gauge with k-factor 2 causes an increase in the resistance of 0.2 %. Typical resistive materials are constantan (k~2) or platinum tungsten (92PT, 8W with k ~4). In the case of semiconductor strain gauges a silicon structure is glued to a carrier material. The conductivity is changed primarily by deformation of the crystal lattice (piezo-resistive effect); k-factors of up to 200 can be achieved.
Measurement of signals
The change in resistance of an individual strain gauge can be determined in principle by resistance measurement (current/voltage measurement) using a 2/3/4-conductor measurement technique
Usually 1/2/4 strain gauges are arranged in a Wheatstone bridge (-> quarter/half/full bridge); the nominal resistance/impedance R0 of all strain gauges (and the auxiliary resistors used if necessary) is usually equivalent to R1=R2=R3=R4=R0. Typical values in the non-loaded state are R0 = 120 Ω, 350 Ω, 700 Ω and 1 kΩ.
The full bridge possesses the best characteristics such as linearity in the feeding of current/voltage, four times the sensitivity of the quarter-bridge as well as systematic compensation of disturbing influences such as temperature drift and creeping. In order to achieve high sensitivity, the 4 individual strain gauges are arranged on the carrier in such a way that 2 are elongated and 2 are compressed in each case.
quarter, half and full bridge
The measuring bridges can be operated with constant current, constant voltage, or also with AC voltage using the carrier frequency method.
Measuring procedure
The Beckhoff EL/KL335x Terminals and the EP3356 Box support only the constant excitation
▪
Full bridge strain gauge at constant voltage (ratiometric measurement)
Since the relative resistance change ΔR is low in relation to the nominal resistance R0, a simplified equation is given for the strain gauge in the Wheatstone bridge arrangement:
UD/UV = ¼ * (ΔR1-ΔR2+ΔR3-ΔR4)/R0
ΔR usually has a positive sign in the case of elongation and a minus sign in the case of compression.
A suitable measuring instrument measures the bridge supply voltage UV (or USupply) and the resulting bridge voltage UD (or UBridge), and forms the quotients from both voltages, i.e. the ratio. After further calculation and scaling the measured value is output, e.g. in kg. Due to the division of UD and UV the measurement is in principle independent of changes in the supply voltage.
If the voltages UV and UD are measured simultaneously, i.e. at the same moment, and placed in relation to each other, then this is referred to as a ratiometric measurement.
The advantage of this is that (with simultaneous measurement!) brief changes in the supply voltage (e.g. EMC effects) or a generally inaccurate or unstable supply voltage likewise have no effect on the measurement.
A change in UV by e.g. 1 % creates the same percentage change in UD according to the above equation. Due to the simultaneous measurement of UD and UV the error cancels itself out completely during the division.
4-conductor vs. 6-conductor connection
If supplied with a constant voltage of 5 to 12 V a not insignificant current flows of e.g. 12 V/350 Ω = 34.3 mA. This leads not only to dissipated heat, wherein the specification of the strain gauge employed must not be exceeded, but possibly also to measuring errors in the case of inadequate wiring due to line losses not being taken into account or compensated.
In principle a full bridge can be operated with a 4-conductor connection (2 conductors for the supply UV and 2 for the measurement of the bridge voltage UD).
If, for example, a 25 m copper cable (feed + return = 50 m) with a cross section q of 0.25 mm² is used, this results in a line resistance of
RL = l/ (κ * q) = 50 m / (58 S*m/mm² * 0.25 mm²) = 3.5 Ω
If this value remains constant, then the error resulting from it can be calibrated out. However, assuming a realistic temperature change of, for example, 30° the line resistance RL changes by
ΔRL =30° * 3.9 * 10-4 * 3.5 Ω = 0.41 Ω
In relation to a 350 Ω measuring bridge this means a measuring error of > 0.1 %.
4-conductor connection
This can be remedied by a 6-conductor connection, in particular for precision applications (only possible with EL3356).
6-conductor connection
The supply voltage UV is thereby fed to the strain gauge (= current carrying conductor). The incoming supply voltage Uref is only measured with high impedance directly at the measuring bridge in exactly the same way as the bridge voltage UD with two currentless return conductors in each case. The conductor-related errors are hence omitted.
Since these are very small voltage levels of the order of mV and µV, all conductors should be shielded. The shield must be connected to pin 5 of the M12 connector.
EP3356-0022: No 6-conductor connection necessary
The connection of a strain gauge over 4-conductor with the EP3356-0022 is sufficient because due to the shorter cable lengths no measurement errors occur.
Structure of a load cell with a strain gauge
One application of the strain gauge is the construction of load cells.
This involves gluing strain gauges (full bridges as a rule) to an elastic mechanical carrier, e.g. a double-bending beam spring element, and additionally covered to protect against environmental influences.
The individual strain gauges are aligned for maximum output signals according to the load direction (2 strain gauges in the elongation direction and 2 in the compression direction).
Example of a load cell
The most important characteristic data of a load cell
Characteristic data
Please enquire tot he sensor manufacturer regarding the exact characteristic data!
Nominal load Emax
Maximum permissible load for normal operation, e.g. 10 kg
Nominal characteristic value mV/V
The nominal characteristic value 2 mV/V means that, with a supply of US=10 V and at the full load Emax of the load cell, the maximum output voltage UD = 10 V * 2 mV/V *E = 20 mV. The nominal characteristic value is always a nominal value – a manufacturer’s test report is included with good load cells stating the characteristic value determined for the individual load cell, e.g. 2.0782 mV/V.
Minimum calibration value Vmin
This indicates the smallest mass that can be measured without the maximum permissible error of the load cell being exceeded [RevT].
This value is represented either by the equation Vmin = Emax / n (where n is an integer, e.g. 10000), or in % of Emax (e.g. 0.01).
This means that a load cell with Emax = 10 kg has a maximum resolution of
Vmin = 10 kg / 10000 = 1 g or Vmin = 10 kg * 0.01 % = 1 g.
Accuracy class according to OIML R60
The accuracy class is indicated by a letter (A, B, C or D) and an additional number, which encodes the scale interval d with a maximum number nmax (*1000); e.g. C4 means Class C with maximally 4000d scale intervals.
The classes specify a maximum and minimum limit for scale intervals d:
▪
A: 50,000 – unlimited
▪
B: 5000 – 100,000
▪
C: 500 – 10,000
▪
D: 500 – 1000
The scale interval nmax = 4000d states that, with a load cell with a resolution of Vmin = 1 g, a calibratable set of scales can be built that has a maximum measuring range of 4000d * Vmin = 4 kg. Since Vmin is thereby a minimum specification, an 8 kg set of scales could be built – if the application allows – with the same load cell, wherein the calibratable resolution would then fall to 8 kg/4000d = 2 g. From another point of view the scale interval nmax is a maximum specification; hence, the above load cell could be used to build a set of scales with a measuring range of 4 kg, but a resolution of only 2000 divisions = 2 g, if this is adequate for the respective application. Also the classes differ in certain error limits related to non-repeatability/creep/TC
Accuracy class according to PTB
The European accuracy classes are defined in an almost identical way (source: PTB).
Class | Calibration values | Minimum load | Max/e
 |  |  | Minimum value | Maximum value
| Fine scales | 0.001 g <= e | 100 e | 50000 |
|| Precision scales | g <= e <=0.05 g g <= e | 20 e 50 e | 100 5000 | 100000 100000
||| Commercial scales | g <= e <=2 g g <= e | 20 e 20 e | 100 500 | 10000 10000
|||| Coarse scales | 5 g <= e | 10 e | 100 | 1000
Minimum application range or minimum measuring range in % of rated load
This is the minimum measuring range/measuring range interval, which a calibratable load cell/set of scales must cover.
Example: above load cell Emax = 10 kg; minimum application range e.g. 40 % Emax
The used measuring range of the load cell must be at least 4 kg. The minimum application range can lie in any range between Emin and Emax, e.g. between 2 kg and 6 kg if a tare mass of 2 kg already exists for structural reasons. A relationship between nmax and Vmin is thereby likewise apparent: 4000 * 1 g = 4 kg .
There are further important characteristic values, which are for the most part self-explanatory and need not be discussed further here, such as nominal characteristic value tolerance, input/output resistance, recommended supply voltage, nominal temperature range etc.
Parallel connection of strain gauges
It is usual to distribute a load mechanically to several strain gauge load cells at the same time. Hence, for example, the 3-point bearing of a silo container on 3 load cells can be realized. Taking into account wind loads and loading dynamics, the total loading of the silo including the dead weight of the container can thus be measured.
The load cells connected mechanically in parallel are usually also connected electrically in parallel.
Since the four M12 sockets of the EP3356 are internally connected to one another, an external parallel connection is not necessary: if several load cells are connected to the EP3356, they are automatically connected in parallel. Up to four load cells can be connected.
The three load cells in the above example (silo container) can thus be connected to any three of the M12 sockets of the EP3356.
Note:
▪
the load cells must be matched to each other and approved by the manufacturer for this mode of operation
▪
the impedance of the load cells must be large enough that the maximum output current of the reference voltage Uref is not exceeded: 350 mA.
Example: Parallel connection of three load cells. Up to four load cells can be connected in parallel.
Sources of error/disturbance variables
Inherent electrical noise of the load cell
Electrical conductors exhibit so-called thermal noise (thermal/Johnson noise), which is caused by irregular temperature-dependent movements of the electrons in the conductor material. The resolution of the bridge signal is already limited by this physical effect. The rms value en of the noise can be calculated by en = √4kTRB
In the case of a load cell with R0 = 350 Ω at an ambient temperature T = 20 °C (= 293 K) and a bandwidth of the measuring transducer of 50 Hz (and Boltzmann constant k = 1.38 * 10-23 J/K), the rms en= 16.8 nV. The peak-peak noise epp is thus approx. epp ~ 4* en = 67.3 nV.
Example:
In relation to the maximum output voltage Uout-max of a bridge with 2 mV/V and Us = 5 V, this corresponds to Uout-max = 5 V * 2 mV/V = 10 mV. (For the nominal load) this results in a maximum resolution of 10 mV/67.3 nV = 148588 digits. Converted into bit resolution: ln(148588)/ln(2) = 17 bits. Interpretation: a higher digital measuring resolution than 17 bits is thus inappropriate for such an analog signal in the first step. If a higher measuring resolution is used, then additional measures may need to be taken in the evaluation chain in order to obtain the higher information content from the signal, e.g. hardware low-pass filter or software algorithms.
This resolution applies alone to the measuring bridge without any further interferences. The resolution of the measuring signal can be increased by reducing the bandwidth of the measuring unit.
If the strain gauge is glued to a carrier (load cell) and wired up, both external electrical disturbances (e.g. thermovoltage at connection points) and mechanical vibrations in the vicinity (machines, drives, transformers (mechanical and audible 50 Hz vibration due to magnetostriction etc.)) can additionally impair the result of measurement.
Creep
Under a constant load, spring materials can further deform in the load direction. This process is reversible, but it generates a slowly changing measured value during the static measurement. In an ideal case the error can be compensated by constructive measures (geometry, adhesives).
Hysteresis
If even elongation and compression of the load cell take place, then the output voltage does not follow exactly the same curve, since the deformation of the strain gauge and the carrier may be different due to the adhesive and its layer thickness.
Temperature drift (inherent heating, ambient temperature)
Relatively large currents can flow in strain gauge applications, e.g. I = US/R0 = 10 V / 350 Ω = 26 mA. The power dissipation at the sensor is thus PV = U*I = 10 V * 26 mA = 260 mW. Depending on application/carrier material (= cooling) and ambient temperature, a not insignificant error can arise that is termed apparent elongation. The sensor manufacturers integrate suitable compensation elements in their strain gauges.
Inadequate circuit technology
As already shown, a full bridge may be able (due to the system) to fully compensate non-linearity, creep and temperature drift. Wiring-related measuring errors are avoided by the 6-conductor connection.
References
Some organizations are listed below that provide the specifications or documents for the technological field of weighing technology:
▪
OIML (ORGANISATION INTERNATIONALE DE MÉTROLOGIE LÉGALE) www.oiml.org/en
▪
PTB - Physikalisch-Technischen Bundesanstalt www.ptb.de/cms/
▪
www.eichamt.de
▪
WELMEC - European cooperation in legal metrology www.welmec.org
▪
DAkkS – Deutsche Akkreditierungsstelle www.dakks.de
▪
Fachgemeinschaft Waagen (AWA) im Verband Deutscher Maschinen- und Anlagenbau VDMA www.vdma.org


Mounting and Cabling

Mounting and Cabling
Mounting and Cabling
Additional information
•
Mounting
•
EtherCAT
•
Supply voltages
•
Resistor bridge
•
UL Requirements


Mounting

Mounting and Cabling [image] Mounting
Mounting
Additional information
•
Dimensions
•
Fixing
•
Tightening torques for plug connectors
•
Functional earth (FE)


Dimensions

Mounting and Cabling [image] Mounting [image] Dimensions
Dimensions
All dimensions are given in millimeters.
Housing features
Housing material | PA6 (polyamide)
Sealing compound | polyurethane
Mounting | two fastening holes Ø 4.5 mm for M4
Metal parts | brass, nickel-plated
Contacts | CuZn, gold-plated
Power feed through | max. 4 A
Installation position | variable
Protection class | IP65, IP66, IP67 (conforms to EN 60529) when screwed together
Dimensions (H x W x D) | approx. 126 x 60 x 26.5 mm (without connectors)


Fixing

Mounting and Cabling [image] Mounting [image] Fixing
Fixing
Note
Dirt during assembly
Dirty connectors can lead to malfunctions. Protection class IP67 can only be guaranteed if all cables and connectors are connected.
•
Protect the plug connectors against dirt during the assembly.
Mount the module with two M4 screws in the centrally located fastening holes.


Tightening torques for plug connectors

Mounting and Cabling [image] Mounting [image] Tightening torques for plug connectors
Tightening torques for plug connectors
Screw connectors tight with a torque wrench. (e.g. ZB8801 from Beckhoff)
Connector diameter | Tightening torque
M8 | 0.4 Nm
M12 | 0.6 Nm


Functional earth (FE)

Mounting and Cabling [image] Mounting [image] Functional earth (FE)
Functional earth (FE)
The fastening holes also serve as connections for the functional earth (FE).
Make sure that the box is earthed with low impedance via both fastening screws. You can achieve this, for example, by mounting the box on a grounded machine bed.
FE connection via fastening holes
Functional earth via the fastening holes


EtherCAT

Mounting and Cabling [image] EtherCAT
EtherCAT
Additional information
•
Connectors
•
Status LEDs
•
Cables


Connectors

Mounting and Cabling [image] EtherCAT [image] Connectors
Connectors
Note
Risk of confusion: supply voltages and EtherCAT
Defect possible through incorrect insertion.
•
Observe the color coding of the connectors:
black: Supply voltages
green: EtherCAT
EtherCAT Box Modules have two green M8 sockets for the incoming and downstream EtherCAT connections.
EtherCAT connectors
Connection
M8 socket, 4-pin – connection
M8 socket
EtherCAT | M8 connector | Core colors
Signal | Contact | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 and old versions of ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | 1 | yellow1) | orange/white | white/orange
Tx - | 4 | orange1) | orange | orange
Rx + | 2 | white1) | blue/white | white/green
Rx - | 3 | blue1) | blue | green
Shield | Housing | Shield | Shield | Shield
1) Core colors according to EN 61918
Adaptation of core colors for cables ZB9030, ZB9032 and ZK1090-3xxxx-xxxx
For standardization, the core colors of the ZB9030, ZB9032 and ZK1090-3xxx-xxxx cables have been changed to the EN61918 core colors: yellow, orange, white, blue. So there are different color codes in circulation. The electrical properties of the cables have been retained when the core colors were changed.


Status LEDs

Mounting and Cabling [image] EtherCAT [image] Status LEDs
Status LEDs
EtherCAT Status LEDs
L/A (Link/Act)
A green LED labelled "L/A" is located next to each EtherCAT socket. The LED indicates the communication state of the respective socket:
LED | Meaning
off | no connection to the connected EtherCAT device
lit | LINK: connection to the connected EtherCAT device
flashes | ACT: communication with the connected EtherCAT device
Run
Each EtherCAT slave has a green LED labelled "Run". The LED signals the status of the slave in the EtherCAT network:
LED | Meaning
off | Slave is in "Init" state
flashes uniformly | Slave is in "Pre-Operational“ state
flashes sporadically | Slave is in "Safe-Operational" state
lit | Slave is in "Operational" state
Description of the EtherCAT slave states


Cables

Mounting and Cabling [image] EtherCAT [image] Cables
Cables
For connecting EtherCAT devices only shielded Ethernet cables that meet the requirements of at least category 5 (CAT5) according to EN 50173 or ISO/IEC 11801 should be used.
EtherCAT uses four wires for signal transmission.
Thanks to automatic line detection ("Auto MDI-X"), both symmetrical (1:1) or cross-over cables can be used between Beckhoff EtherCAT.
Detailed recommendations for the cabling of EtherCAT devices


Supply voltages

Mounting and Cabling [image] Supply voltages
Supply voltages
The EtherCAT Box is supplied with two supply voltages. The supply voltages are electrically isolated in the EtherCAT Box.
▪
Control voltage US
▪
Peripheral voltage UP
Redirection of the supply voltages
The IN and OUT power connections are bridged in the module (not IP204x-Bxxx and IE204x). The supply voltages US and UP can thus easily be transferred from EtherCAT Box to EtherCAT Box.
Note
Pay attention to the maximum permissible current!
Pay attention also for the redirection of the supply voltages US and UP, the maximum permissible current for M8 connectors of 4 A must not be exceeded!
Additional information
•
Connectors
•
Status LEDs
•
Conductor losses


Connectors

Mounting and Cabling [image] Supply voltages [image] Connectors
Connectors
Note
Risk of confusion: supply voltages and EtherCAT
Defect possible through incorrect insertion.
•
Observe the color coding of the connectors:
black: Supply voltages
green: EtherCAT
Connectors + LEDs
Connectors for supply voltages
M8 connector
Contact | Function | Description | Core color 1)
1 | US | Control voltage | Brown
2 | UP | Peripheral voltage | White
3 | GNDS | GND to US | Blue
4 | GNDP | GND to UP | Black
1) The core colors apply to cables of the type: Beckhoff ZK2020-3xxx-xxxx


Status LEDs

Mounting and Cabling [image] Supply voltages [image] Status LEDs
Status LEDs
Connectors + LEDs
Status LEDs for the supply voltages
LED | Display | Meaning
US (control voltage) | off | Supply voltage US is not present
 | green illuminated | Supply voltage US is present
UP (peripheral voltage) | off | Supply voltage UP is not present
 | green illuminated | Supply voltage UP is present


Conductor losses

Mounting and Cabling [image] Supply voltages [image] Conductor losses
Conductor losses
Take into account the voltage drop on the supply line when planning a system. Avoid the voltage drop being so high that the supply voltage at the box lies below the minimum nominal voltage.
Variations in the voltage of the power supply unit must also be taken into account.
Voltage drop on the supply line
Leitungsverluste M8 2A
Leitungsverluste M8 4A


Resistor bridge

Mounting and Cabling [image] Resistor bridge
Resistor bridge
The EP3356 enables the connection of a resistor bridge or load cell in a 4-wire connection technology.
Resistor bridge
The cable shield must be connected to pin 5 of the M12 connector.
The four M12 sockets of the EP3356 are internally connected to one another. Therefore, you can connect a resistor bridge to any M12 socket.
You can also connect several resistor bridges in parallel: Example.
The voltage Uref is 10 V and is generated in the EP3356 from UP.
Do not earth the sensor cable shield at the sensor end
If a shielded sensor cable is used, it should not be earthed at the sensor end. Otherwise measurement deviations may occur in certain system configurations.
Meanings of the LEDs
LEDs EP3356-0022
LED
Color
Meaning
RUN
green
This LED indicates the boxes operating state:
off
State of the EtherCAT State Machine: INIT = Initialization of the box
blinking
State of the EtherCAT State Machine: PREOP = Setting for mailbox communication and variant standard settings
single flash
State of the EtherCAT State Machine: SAFEOP = Channel checking of the Sync Manager and the Distributed Clocks: Outputs stay in safe operation mode
on
State of the EtherCAT State Machine: OP = Normal operation mode, mailbox- and process data communication possible
flickering
State of the EtherCAT State Machine: BOOTSTRAP = mode for firmware updates of the box
Stdy
green
on
The measuring value is steady
off
The measuring value is not steady
Msr
grün
on
Measuring active (valid process data)
off
▪
Self-calibration active (if LED self calibration is lit) or
▪
Self-test active (if LED self test is lit)
▪
filters are initialized
S-Cal
green
on
Self-calibration active
▪
Process data are not valid
S-Test
green
on
Self-test active
▪
Process data are not valid
ErrD
red
on
Channel 1 (strain gauge differential signal) is out of valid value range.
ErrR
red
on
Channel 2 (reference voltage) is out of valid value range. Possible reasons:
▪
The reference voltage Uref is not present. Check if the supply voltage UP is present: Uref is internally generated from UP.
▪
The reference voltage Uref has dropped due to overload.


UL Requirements

Mounting and Cabling [image] UL Requirements
UL Requirements
The installation of the EtherCAT Box Modules certified by UL has to meet the following requirements.
Supply voltage
SmallWarningYellow CAUTION
CAUTION!
This UL requirements are valid for all supply voltages of all marked EtherCAT Box Modules!
For the compliance of the UL requirements the EtherCAT Box Modules should only be supplied
•
by a 24 VDC supply voltage, supplied by an isolating source and protected by means of a fuse (in accordance with UL248), rated maximum 4 Amp, or
•
by a 24 VDC power source, that has to satisfy NEC class 2.
A NEC class 2 power supply shall not be connected in series or parallel with another (class 2) power source!
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, the EtherCAT Box Modules must not be connected to unlimited power sources!
Networks
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, EtherCAT Box Modules must not be connected to telecommunication networks!
Ambient temperature range
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, EtherCAT Box Modules has to be operated only at an ambient temperature range of 0 to 55°C!
Marking for UL
All EtherCAT Box Modules certified by UL (Underwriters Laboratories) are marked with the following label.
UL label


Commissioning/Configuration

Commissioning/Configuration
Commissioning/Configuration
Additional information
•
Integration in TwinCAT
•
EtherCAT slave process data settings (PDO)
•
Basic function principles
•
Application notes
•
Calibration and adjustment
•
Notices on analog specifications
•
Voltage measurement
•
Distributed Clocks mode
•
Process data
•
Object description and parameterization
•
Example program
•
Restoring the delivery state


Integration in TwinCAT

Commissioning/Configuration [image] Integration in TwinCAT
Integration in TwinCAT
The procedure for integration in TwinCAT is described in this Quick start guide.


EtherCAT slave process data settings (PDO)

Commissioning/Configuration [image] EtherCAT slave process data settings (PDO)
EtherCAT slave process data settings (PDO)
The process data transferred by an EtherCAT slave during each cycle (Process Data Objects, PDOs) are user data which the application expects to be updated cyclically or which are sent to the slave. To this end the EtherCAT master (Beckhoff TwinCAT) parameterizes each EtherCAT slave during the start-up phase to define which process data (size in bits/bytes, source location, transmission type) it wants to transfer to or from this slave. Incorrect configuration can prevent successful start-up of the slave.
For Beckhoff EtherCAT EL/ES/EP slaves the following applies in general:
▪
The input/output process data supported by the device are defined by the manufacturer in the ESI/XML description. The TwinCAT EtherCAT Master uses the ESI description to configure the slave correctly.
▪
The process data can be modified in the system manager. See the device documentation. Examples of modifications include: Mask out a channel, displaying additional cyclic information, 16-bit display instead of 8-bit data size, etc.
▪
In so-called “intelligent” EtherCAT devices the process data information is also stored in the CoE directory. Any changes in the CoE directory that lead to different PDO settings prevent successful startup of the slave. It is not advisable to deviate from the designated process data, because the device firmware (if available) is adapted to these PDO combinations.
If the device documentation envisages modification of process data, proceed as follows (see illustration below).
▪
A: Select the device to configure
▪
B: In the “Process Data” tab select Input or Output under SyncManager (C)
▪
D: The PDOs can be selected or deselected
▪
H: The new process data are visible as linkable variables in the system manager. The new process data are active once the configuration has been activated and TwinCAT has been restarted (or the EtherCAT master has been restarted)
▪
E: If a slave supports this, Input and Output PDO can be modified simultaneously by selecting a so-called PDO record (“predefined PDO settings”).
Konfigurieren der Prozessdaten1
Configuring the process data
Manual modification of the process data
According to the ESI description, a PDO can be identified as "fixed" with a flag "F" in the PDO overview (see previous illustration, J). The configuration of such PDOs cannot be changed, even if TwinCAT offers the associated dialog (“Edit”). In particular, CoE content cannot be displayed as cyclic process data. This generally also applies in cases where a device supports download of the PDO configuration, “G”. In case of incorrect configuration the EtherCAT slave usually refuses to start and change to OP state. The System Manager displays an “invalid SM cfg” logger message:
`Box 1 (EP3356)` (0022): state change aborted (requested ‚SAFEOP`, back to ‚PREOP`), `Box1 (EP3356)` (0022): `PREOP to SAFEOP`failed! Error: `check device state for SAFEOP`, AL Status `0x0012`read and 0x0004` expected. AL status code `0x001e – invalid SM IN cfg` This error message „invalid SM IN cfg“ or „invalid SM OUT cfg“ provides an indication of the reason for the failed start.


Basic function principles

Commissioning/Configuration [image] Basic function principles
Basic function principles
The measuring functions of the EP3356 can be described as follows:
▪
The EP3356-0022 Analog Input Box are used to acquire the supply voltage to a load cell as a reference voltage, and the differential voltage that is proportional to the force acting on the cell.
▪
It is compulsory to connect a full bridge. If there is only a quarter or half bridge available, you have to add external auxiliary bridges. In this case you have to modify the nominal characteristic value.
▪
The reference and differential voltages are measured simultaneously
▪
Since the two voltages are measured at the same time, there is basically no need for a high-precision reference voltage with respect to the level. On changing the reference voltage, the differential voltage across the full bridge changes by the same degree. Therefore a stabilized reference voltage should be used that is subject to only low fluctuations (e.g. the EL95xx supply terminal)
▪
The change of the quotient of the differential and reference voltages corresponds to the relative force acting on the load cell.
▪
The quotient is converted into a weight and is output as process data.
▪
The data processing is subject to the following filtering procedures:
–
the analog converter (ADC) integrates over 76 samples
–
calculation of mean values in the averager (if activated)
–
software filter IIR/FIR (if activated)
▪
The EP3356 has an automatic compensation/self-calibration function. Default state: self-calibration activated, execution every 3 minutes
–
errors in the analog input stages (temperature drift, long-term drift etc.) are checked by regular automatic calibration, and compensated to bring the measurement within the permitted tolerance range.
–
the automatic function can be deactivated or activated in a controlled manner
▪
The EP3356 can also be used as a 2-channel analog input box for voltage measurement.
▪
The EP3356 has a timestamp function that can be activated through Distributed Clocks. The filter functionality is not available in Distributed Clocks mode.
General notes
▪
The measuring range should always be used as widely as possible in order to achieve a high measuring accuracy. Please consider the max. input voltage (see technical data).
Max. input voltages
▪
Parallel operation of load cells is possible with the EP3356. Please note:
–
Load cells approved and calibrated by the load cell manufacturer for parallel operation should be used. The nominal characteristic values [mV/V], zero offset [mV/V] and impedance [Ω, ohm] are then usually adjusted accordingly.
Example: Parallel connection
▪
Load cell signals have a low amplitude and are occasionally very sensitive to electromagnetic interference. Considering the typical system characteristics and taking into account the technical possibilities, purposeful state-of-the-art EMC protective measures are to be taken. In the case of high electromagnetic interference levels, it may be helpful to additionally connect the cable screen before the box using suitable screening material.
▪
the minimum permissible assigned EtherCAT cycle time for the EP3356 is 100 µs.
▪
If the EP3356-0022 is to be used in Distributed Clocks mode:
–
DC must be activated
–
the Process data Timestamp must be activated. The filter functionality is not available then.
Signal flow diagram
Block diagram of EP3356-0022
The EP3356 processes the data in the following order:
▪
Hardware low-pass 10 kHz
▪
2-channel simultaneous sampling at 10.5/105.5 kSps with 64-fold oversampling by delta-sigma (ΔΣ) converter and internal pre-filtration
▪
4-fold averager (can be deactivated)
▪
Software filter (can be deactivated)
▪
Calculating the weight
Measurement principle of delta-sigma (ΔΣ) converter
The measurement principle employed in the EP3356, with real sampling in MHz range, shifts aliasing effects into a very high frequency range, so that normally no such effects are to be expected in the KHz range.
Averager
In order to make use of the high data rates of the Analog-to-Digital converter (ADC) even with slow cycle times, a mean value filter is connected after the ADC. This determines the sliding mean value of the last 4 measured values. This function can be deactivated for each mode via the CoE object "Mode X enable averager".
Software filter
The EP3356 is equipped with a digital software filter which, depending on its settings, can adopt the characteristics of a Finite Impulse Response filter (FIR filter), or an Infinite Impulse Response filter (IIR filter). The filter is activated by default as 50 Hz-FIR.
In the respective measuring mode the filter can be activated (0x8000:01, 0x8000:02) and parameterized (0x8000:11, 0x8000:12).
FIR 50/60 Hz
▪
The filter performs a notch filter function and determines the conversion time of the box. The higher the filter frequency, the faster the conversion time. A 50 Hz and a 60 Hz filter are available. Notch filter means that the filter has zeros (notches) in the frequency response at the filter frequency and multiples thereof, i.e. it attenuates the amplitude at these frequencies. The FIR filter operates as a non-recursive filter.
PDO filter
▪
The filter behaves like the 50/60 Hz FIR filter described above. However, the filter frequency can be adjusted here in 0.1 Hz steps by means of an output data object. The filter frequency range extends from 0.1 Hz to 200 Hz and can be reparameterised during operation. To do this the PDO 0x1601 (“RMB filter frequency”) must be displayed in the process data and the entry “PDO filter frequency” must be selected in the object 0x8000:11. This function allows the EP3356 to suppress interference of a known frequency in the measuring signal. A typical application, for example, is a silo that is filled and weighed by a driven screw conveyor. The rotary speed of the screw conveyor is known and can be adopted into the object as a frequency. Thus mechanical oscillations can be removed from the measuring signal.
Notch characteristic/amplitude curve and step response of the FIR filter
IIR-Filter 1 to 8
▪
The filter with IIR characteristics is a discrete time, linear, time invariant filter that can be set to eight levels (level 1 = weak recursive filter, up to level 8 = strong recursive filter). The IIR can be understood to be a moving average value calculation after a low-pass filter.
Step response and Bode diagramm of the IIR filter
Overview of conversion times
Filter Settings | Value | PDO update time | Filter property | Limit frequency (-3 dB) [Hz] (typ.) | Comment | Rise time 10-90 % [s] (typ.)
Filter deactivated | - | Cycle-synchronous,, min. 100 µs | - | - | - | -
0 | FIR 50 Hz | 312.5 µs | 50 Hz notch filter | 22 Hz | Typ. conversion time 312.5 µs | 0.013
1 | FIR 60 Hz | 260.4 µs | 60 Hz notch filter | 25 Hz | Typ. conversion time 260.4 µs | 0.016
2 | IIR1 | Cycle-synchronous (up to min. 100 µs) | Low-pass | 2000 Hz | a0=1/21 = 0.5 | 0.0003
3 | IIR2 |  | Low-pass | 500 Hz | a0=1/22 = 0.25 | 0.0008
4 | IIR3 |  | Low-pass | 125 Hz | a0=1/24 = 62.5e-3 | 0.0035
5 | IIR4 |  | Low-pass | 30 Hz | a0=1/26 = 15.6e-3 | 0.014
6 | IIR5 |  | Low-pass | 8 Hz | a0=1/28 = 3.91e-3 | 0.056
7 | IIR6 |  | Low-pass | 2 Hz | a0=1/210 = 977e-6 | 0.225
8 | IIR7 |  | Low-pass | 0.5 Hz | a0=1/212 = 244e-6 | 0.9
9 | IIR8 |  | Low-pass | 0.1 Hz | a0=1/214 = 61.0e-6 | 3.6
10 | Dynamic IIR |  | The filter changes dynamically between the filters IIR1 to IIR8
11 | PDO Filter frequency | 1/PDO Value[Hz]*64 | Notch filter with adjustable frequency | ca. 0,443 * PDO Value [Hz] | - | -
Filter and cycle time
If the FIR filters (50 Hz or 60 Hz) are switched on, the process data are updated maximally with the specified conversion time (see table). The IIR filter works cycle-synchronously. Hence, a new measured value is available in each PLC cycle.
At which point the filters can be adjusted is described in the chapter “Object description and parameterization” for example under index 0x8000:12.
IIR filter
Differential equation: Yn = Xn * a0 + Yn-1 * b1 with a0 + b1 = 1
a0 = (see table), b1 = 1 - a0
Dynamic IIR Filter
The dynamic IIR filter automatically switches through the 8 different IIR filters depending on the weight change. The idea:
▪
The target state is always the IIR8-Filter, i.e. the greatest possible damping and hence a very calm measured value.
▪
In the input variable changes rapidly the filter is opened, i.e. switched to the next lower filter (if still possible). This gives the signal edge more weight and the measured value curve can follow the load quickly.
▪
If the measured value changes very little the filter is closed, i.e. switched to the next higher filter (if still possible). Hence the static state is mapped with a high accuracy.
▪
The evaluation as to whether a downward change of filter is required or whether an upward change is possible takes place continuously at fixed time intervals.
Parameterization takes place via the CoE entries 0x8000:13 and 0x8000:14. Evaluation takes place according to 2 parameters:
▪
The "Dynamic filter change time" object (0x8000:13) is used to set the time interval at which the existing signal is re-evaluated.
▪
Object 0x8000:14 is used to specify the maximum deviation that is permissible during this time without filter switching occurring.
Example:
The dynamic filter is to be adjusted in such a manner that a maximum slope of 0.5 digits per 100 ms (5 digits per second) is possible without the filter being opened. This results in a "calm" measured value. In the case of a faster change, however, it should be possible to immediately follow the load.
▪
Dynamic filter change time (0x8000:13) = 10 (equivalent to 100 ms)
▪
Object 0x8000:14 is used to specify the maximum deviation that is permissible during this time without filter switching occurring.
The measured value curve is shown below for a slower (left) and faster (right) change.
Effect of dynamic IIR filters
▪
Left: The scales are slowly loaded. The change in the weight (delta/time) remains below the mark of 0.5 digits per 100 ms. The filter therefore remains unchanged at the strongest level (IIR8), resulting in a low-fluctuation measured value.
▪
Right: The scales are suddenly loaded. The change in the weight immediately exceeds the limit value of 0.5 digits per 100 ms. The filter is opened every 100 ms by one level (IIR8 --> IIR7 --> IIR6 etc.) and the display value immediately follows the jump. After the removal of the weight the signal quickly falls again. If the change in the weight is less than 0.5 digit per 100 ms, the filter is set one level stronger every 100 ms until IIR8 is reached. The green line is intended to clarify the decreasing "noise level"
Calculating the weight
Each measurement of the analog inputs is followed by the calculation of the resulting weight or the resulting force, which is made up of the ratio of the measuring signal to the reference signal and of several calibrations.
YR = (UDiff / Uref) x Ai | (1.0) | Calculation of the raw value in mV/V
YL = ( (YR – CZB) / (Cn – CZB) ) * Emax | (1.1) | Calculation of the weight
YS = YL * AS | (1.2) | Scaling factor (e.g. factor 1000 for rescaling from kg to g)
YG = YS * (G / 9.80665) | (1.3) | Influence of acceleration of gravity
YAUS = YG x Gain - Tara | (1.4) | Gain and Tare
Legend
Name | Designation | CoE Index
UDiff | Bridge voltage/differential voltage of the sensor element, after averager and filter |
Uref | Bridge supply voltage/reference signal of the sensor element, after averager and filter |
Ai | Internal gain, not changeable. This factor accounts fort he unit standardisation from mV to V and the different full-scale deflections of the input channels |
Cn | Nominal characteristic value of the sensor element (unit mV/V, e.g. nominally 2 mV/V or 2.0234 mV/V according to calibration protocol) | 8000:23
CZB | Zero balance of the sensor element (unit mV/V, e.g. -0.0142 according to calibration protocol) | 8000:25
Emax | Nominal load of the sensor element | 8000:24
AS | Scaling factor (e.g. factor 1000 for rescaling from kg to g) | 8000:27
G | Acceleration of gravity in m/s^2 (default: 9.80665 ms/s^2) | 8000:26
Gain |  | 8000:21
Tare |  | 8000:22
Conversion mode
The so–called conversion mode determines the speed and latency of the analog measurement in the EP3356. The characteristics:
Mode | Meaning | typ. latency | typ. current consumption
0 | High precision Analog conversion at 10.5 kSps (samples per second) Slow conversion and thus high accuracy | 7,2 ms | 70 % (see Technical data regarding nominal value)
1 | High speed / low latency Analog conversion at 105.5 kSps (samples per second) Fast conversion with low latency | 0,72 ms | 100 % (see Technical data regarding nominal value)
Due to the conversion principle of the EP3356, the analog voltage is only available as a digital value after a defined time. This is shown in figure below.
A step signal 0->1 is applied to the input. The measured value is reached and readable within the defined accuracy after 7.2 ms or 0.72 ms, depending on the conversion mode 0/1. At this time the timestamp is also acquired in Distributed Clocks mode. In real operation a step signal is not normally connected, but rather a higher frequency but constant signal. The EP3356 then maps the input signal with the corresponding latency for further processing, for which reason faster querying of the sampling unit at shorter intervals than the latency (EP3356 allows up to 100 µs) makes sense for true-to-detail mapping of the analog input signal.
Latency of the Analog-to-Digital converter
It is not possible to change the specified latency.
Beyond that the following are individually adjustable in each mode via CoE
▪
activation of the averager
▪
activation of the filter
▪
type of filter
Setting parameters in CoE belonging to the individual modes
Mode change
In particular for dynamic weighing procedures it may make sense to considerably change the measuring characteristic during the weighing procedure. For example, if a bulk material is filled by the sack within 5 seconds, a very open filter should initially be used so that the measured value quickly follows the fill level. During this phase it is of no importance that the measured value is very inaccurate and subject to high fluctuations. If the sack is >90 % full, filling must be slowed down and the loading must be followed with higher accuracy; the filter must be closed. Therefore the two conversion modes can be switched via the process data bit "Sample mode" in the EP3356 in relation to the processing of the analog values.
The mode change takes about 30 ms, during which time the measured values are invalid and indicate this by the status byte.
Sample mode switching


Application notes

Commissioning/Configuration [image] Application notes
Application notes
Symmetric reference potential
The EP3356 measures the two voltages Usupply und Ubridge independently of each other. The measuring accuracy can be increased still further if an internal coupling is employed to prevent the internal measuring circuits from drifting apart. To this end the EP3356 has an internal switch that is closed in the default state and establishes a potential reference between the internal electronics and the bridge point.
Internal switch for increasing the measuring accuracy
If several strain gauges are supplied by the same power supply and equalising currents flow that falsify the measurement, the switch can be opened via CoE 0x8000:05. Alternatively, electrically isolated strain gauge supplies are to be installed.
Open-circuit recognition
The EP3356 has no express open-circuit recognition facility. If one of the bridge wires is broken, however, the voltage measured there generally moves towards the final value, thus displaying an error in the status word. Over/underrange of the supply voltage is likewise indicated.
Input freeze
If the box is placed in the freeze state by InputFreeze in the control word, no further analog measured values are relayed to the internal filter. This function is usable, for example, if a filling surge is expected from the application that would unnecessarily overdrive the filters due to the force load. This would result in a certain amount of time elapsing until the filter had settled again. The user himself must determine a sensible InputFreeze time for his filling procedure.
For clarification: temporal control of the InputFreeze and the decision regarding its use must be realised by the user in the PLC, they are not components of the EP3356.
In the following example (recorded with Scope2) impulses on a 15 kg load cell are recorded; the filter is wide open at IIR1 so that steep edges occur in the signal.
Impulses on a load cell with and without InputFreeze
Explanation: The weight (A) is shown in blue; the state of the InputFreeze variable, which can be controlled by the PLC program and can be TRUE/FALSE, is shown in red (B). The first two impulses (C) lead to large peak deflections in the signal. After that the following is activated in the PLC program (see example program):
▪
if the measured value for the last cycle (cycle time 100 µs) has changed by more than 10 g (indicating a sudden load), bInputFreeze is set to TRUE for 50 ms by a TOF block on the EP3356
The effect can be seen in (D): The peak load is no longer acknowledged by the EP3356. If it is optimally adapted to the expected force impulse, the EP3356 can measure the current load value without overshoot.
Gravity adaption
The calculation of the weight depends on the gravitation/the Earth's gravitational force/acceleration due to gravity at the place of installation of the scales. In general, acceleration due to the gravitational pull of the earth at the place of installation is not equal to the defined standard value of g = 9.80665 m/s². For example, 4 zones of acceleration due to gravity are defined in Germany, in which a local acceleration due to gravity of 9.807 m/s² to 9.813 m/s² is to be assumed. Hence, within Germany alone there is a clear dispersion of the order of parts per thousand for acceleration due to gravity, which has a direct effect on the measured weight in accordance with the equation FG = m*g!
If
▪
load cells are used in the theoretical calibration with characteristic values according to the sensor certificate
▪
calibration weights are used whose weight at the place of installation of the scales is by nature different to that at the place of origin
▪
scales of the accuracy class I to III are to be realized
▪
scales that are generally independent of acceleration due to gravity are to be realized
then one should check whether the gravity correction needs to be adapted via object 0x8000:26.
Idling recognition
Weighing is a dynamic procedure that can lead to large jumps in the bridge voltage and thus to the calculation of the value. Following a change in load, the measured value must first "settle" so that the process value is evaluable in the controller. The evaluation of the measured value and the decision over the degree of calmness can be done in the controller; however, the EP3356 also offers this function, which is activated by default. The result is output in the status word.
▪
If the load value remains within a range of values y for longer than time x, then the SteadyState is activated in the StatusWord.
▪
SteadyState is set to FALSE as soon as this condition no longer applies.
▪
The parameters x and y can be specified in the CoE
▪
The evaluation is naturally considerably affected by the filter setting
In the following example (recorded with TwinCAT Scope2), a 15 kg load cell is suddenly unloaded and loaded with 547 g. SteadyState is subject to a window time from 100 ms and a tolerance of 8 g (15 kg nominal value, scaling 1000; see CoE).
Load cell loaded and unloaded
Official calibration capability
"Official calibration" is a special kind of calibration that is accomplished according to special regulations with the involvement of trained personnel using prescribed aids. The use of "officially calibrated" scales is mandatory in the Central European region, in particular for the filling of foodstuffs. This ensures the correctness of the weighed quantities in a particular way.
The EP3356 cannot be officially calibrated as individual device. However, it can be integrated as element in applications that can then be equipped by the integrator with the required characteristics for official calibration capability using appropriate means.


Calibration and adjustment

Commissioning/Configuration [image] Calibration and adjustment
Calibration and adjustment
The term "calibration" can be applied in 3 different ways to the EP3356:
▪
Sensor calibration: once-only calibration of the employed sensor (strain gauge) during commissioning of the system
▪
Self-calibration: continuously repeated self-calibration of the box for the improvement of the measuring accuracy
▪
Tare: repeated gross/net compensation by taring
Sensor calibration
The EP3356 is matched to the characteristic curve of the sensor element by means of the calibration. Two values are required for this procedure: the initial value without a load ("zero balance") and fully loaded ("rated output"). These values can be determined by a calibration protocol or by a calibration using calibration weights.
Adaptation to the sensor curve
Calibration by means of compensation in the system
In the "practical" calibration, measurement takes place first with the scales unloaded, then with a defined load on the scales. The EP3356 automatically calculates the existing sensor characteristic values from the measured values.
Sequence:
1.
Perform a CoE reset with object 0x1011:01, see Restoring the delivery state
2.
Set scale factor to 1000 (0x8000:27) (for declaration of weight in g)
3.
Set gravity of earth (0x8000:26) if necessary (default: 9.806650)
4.
Set gain to (0x8000:21) = 1
5.
Set tare to 0 (0x8000:22)
6.
Set the filter (0x8000:11) to the strongest level: IIR8
7.
Specify the nominal load of the sensor in 0x8000:24 ("Nominal load")
8.
Zero balance: Do not load the scales. As soon as the measured value indicates a constant value for at least 10 seconds, execute the command "0x0101" (257dec) on CoE object 0xFB00:01. This command causes the current mV/V value (0x9000:11) to be entered in the "Zero balance" object. Check: CoE objects 0xFB00:02 and 0xFB00:03 must contain "0" after execution
9.
Load the scales with a reference load. This should be at least 20 % of the rated load. The larger the reference load, the better the sensor values can be calculated. In object 0x8000:28 ("Reference load"), enter the load in the same unit as the rated load (0x8000:24). As soon as the measured value indicates a constant value for at least 10 seconds, execute the command "0x0102" (258dec) on CoE object 0xFB00:01. By means of this command the EP3356 determines the output value for the nominal weight ("Rated output") Check: CoE objects 0xFB00:02 and 0xFB00:03 must contain "0" after execution.
10.
Reset: execute the command "0x0000" (0dec) on CoE object 0xFB00:01.
11.
Set the filter to a lower stage.
Calibration according to the sensor calibration protocol (theoretical calibration)
The sensor characteristic values according to the manufacturer's certificate are communicated here directly to the EP3356, so that it can calculate the load.
1.
Perform a CoE reset with object 0x1011:01, see Restoring the delivery state
2.
Set scale factor to 1000 (0x8000:27) (for declaration of weight in g)
3.
Set gravity of earth (0x8000:26) if necessary (default: 9.806650)
4.
Set gain to (0x8000:21) = 1
5.
Set tare to 0 (0x8000:22)
6.
Specify the nominal load of the sensor in 0x8000:24 ("Nominal load")
7.
Adopt the "Rated output" (mV/V value 0x8000:23) from the calibration protocol
8.
Adopt the "Zero balance" (0x8000:25) from the calibration protocol
Calibration
The calibration is of great importance for the accuracy of the system. In order to increase this, the filter should be set as strong as possible over the entire calibration phase. It may take several seconds before a static value is obtained.
Local storage
The values modified during the theoretical and practical calibration are stored in a local EEPROM. This can be written to up to 1 million time. In order to prolong the life of the EEPROM, therefore, the commands should not be executed cyclically.
Self-calibration of the measuring amplifiers
The measuring amplifiers are periodically subjected to examination and self-calibration. Several analog switches are provided for this purpose, so that the various calibration signals can be connected. It is important for this process that the entire signal path, including all passive components, is examined at every phase of the calibration. Only the interference suppression elements (L/C combination) and the analog switches themselves cannot be examined. In addition, a self-test is carried out at longer intervals.
The self-calibration is carried out every 3 minutes in the default setting.
Self-calibration
▪
The time interval is set in 100 ms steps with object 0x8000:31; default: 3 min. Duration approx. 150 ms
Self-test
▪
is additional carried out together with every nth self-calibration. The multiple (n) is set with object 0x8000:32; default: 10 additional duration approx. 70 ms.
By means of the self-calibration of the input stages at the two operating points (zero point and final value), the two measuring channels are calibrated to each other.
Interface for controller
The self-calibration takes place automatically at the defined intervals. In order to prevent calibration during a time-critical measurement, the automatic calibration can be disabled via the "Disable calibration" bit in ControlWord, also permanently. If it should be additional necessary to carry out a manual test, this is started by a rising edge of the "Start manual calibration" bit in the process image.
While the box is performing a self-calibration or a self-test, the "Calibration in progress" bit is set in the process image. Once started, a self-calibration/self-test cannot be aborted.
If the self-calibration has been disabled by "Disable calibration", it can nevertheless be started by the "Start calibration" process data bit.
Self-calibration
The self-calibration takes place for the first time directly after starting up the box. At this point the external reference voltage must already be applied. If the reference voltage is only applied later, the self-calibration must be manually initiated (process data bit: „Start calibration“). The self-calibration must be executed at least once after each start-up. The supply voltage must be applied during the self-calibration, since otherwise the necessary reference voltages cannot be generated. A lower measuring accuracy is to be expected if the self-calibration is disabled for a longer period or permanently.
After a change of the settings in the CoE (range x80nn), a self-calibration will be executed in each case (also for DisabledCalibration = TRUE), because the settings have an influence to the measuring procedure. CoE settings should be done as far as possible out of running measuring procedures.
Taring
When taring, the scales are "zeroed" using an arbitrary applied load; i.e. an offset correction is performed. This is necessary for the gross/net compensation of goods that cannot be weighed without a container that has a mass of its own.
The EP3356 supports 2 tarings; it is recommended to set a strong filter when taring.
Temporary tare
▪
The correction value is NOT stored in the box and is lost in the event of a power failure. To this end the command "0x0001" is executed on CoE object 0xFB00:01 (binary dialog in the System Manager: "01 00"). This sets the tare object (0x8000:22) such that the display value is 0. Note: in the case of a device restart (INIT → OP) the tare is not deleted. In addition this tare can be executed via the control word:
Permanent tare
▪
The correction value is stored locally in the boxes EEPROM and is not lost in the event of a power failure. To this end the command "0x0002" is executed on CoE object 0xFB00:01 (binary dialog in the System Manager: "02 00"). This sets the tare object (0x8000:22) such that the display value is 0.
Local storage
The values modified during the theoretical and practical calibration are stored in a local EEPROM. This can be written to up to 1 million time. In order to prolong the life of the EEPROM, therefore, the commands should not be executed cyclically.
Commands
The functions discussed above are carried out by means of commands in the standardized object 0xFB00.
Index | Name | Comment
FB00:01 | Request | Entry of the command to be executed
FB00:02 | Status | Status of the command currently being executed 0: Command executed without error 255: Command is being executed
FB00:03 | Response | Optional response value of the command
The function blocks FB_EcCoESdoWrite and FB_EcCoESdoRead from the TcEtherCAT.lib (contained in the standard TwinCAT installation) can be used in order to execute the commands from the PLC.
Commands of the EP3356
The following commands can be transferred to the box via the CoE entry 0xFB00:01.
Command | Comment
0x0101 | Execute zero balance
0x0102 | Execute calibration
0x0001 | Execute tare procedure (value is NOT saved in the boxes EEprom)
0x0002 | Execute tare procedure (value is saved in the boxes EEprom)


Notices on analog specifications

Commissioning/Configuration [image] Notices on analog specifications
Notices on analog specifications
Beckhoff I/O devices (terminals, boxes) with analog inputs are characterized by a number of technical characteristic data; refer to the technical data in the respective documents.
Some explanations are given below for the correct interpretation of these characteristic data.
Full scale value
An I/O device with an analog input measures over a nominal measuring range that is limited by an upper and a lower limit (initial value and end value); these can usually be taken from the terminal/box designation. The range between the two limits is called the measuring span and corresponds to the equation (end value - initial value). Analogous to pointing devices this is the measuring scale (see IEC 61131) or also the dynamic range. For analog I/O devices from Beckhoff the rule is that the limit with the largest value is chosen as the full scale value of the respective product (also called the reference value) and is given a positive sign. This applies to both symmetrical and asymmetrical measuring spans.
Measuring range
For the above examples this means:
▪
Measuring range 0 to 10 V: asymmetric unipolar, full scale value = 10 V, measuring span = 10 V
▪
Measuring range 4 to 20 mA: asymmetric unipolar, full scale value = 20 mA, measuring span = 16 mA
▪
Measuring range -200 to 1370 °C: asymmetric bipolar, full scale value = 1370 °C, measuring span = 1570 °C
▪
Measuring range -10 to +10 V: symmetric bipolar, full scale value = 10 V, measuring span = 20 V
This applies equally for analog output terminals/boxes.
± Measuring error [% of the full scale value] (also: measurement error)
The relative measuring error is referenced to the full scale value and is calculated as the quotient of the largest numerical deviation from the true value (‘measuring error’) referenced to the full scale value.
The measuring error is generally valid for the entire permitted operating temperature range, also called the ‘usage error limit’ and contains random and systematic portions of the referred device (i.e. ‘all’ influences such as temperature, inherent noise, aging, etc.).
It always to be regarded as a positive/negative span with ±, even if it is specified without ± in some cases.
The maximum deviation can also be specified directly.
Example: Measuring range 0 to 10 V and measuring error < ± 0.3 % full scale value → maximum deviation ± 30 mV in the permissible operating temperature range.
Notice: since this specification also includes the temperature drift, a significantly lower measuring error can usually be assumed in case of a constant ambient temperature and thermal stabilization of the device. This applies equally for analog output terminals/boxes.
Single-ended/differential typification
For analog inputs Beckhoff makes a basic distinction between two types: single-ended (SE) and differential (DIFF), referring to the difference in electrical connection with regard to the potential difference.
The diagram shows two-channel versions of an SE module and a DIFF module as examples for all multi-channel versions.
Single-ended/differential typification
Notice: Dashed lines indicate that the respective connection may not necessarily be present in each SE or DIFF module.
The basic rule:
▪
Analog measurements always take the form of voltage measurements between two potential points. For voltage measurements a large R is used, in order to ensure a high impedance. For current measurements a small R is used as shunt. If the purpose is resistance measurement, corresponding considerations are applied.
–
Beckhoff generally refers to these two points as input+/signal potential and input-/reference potential.
–
For measurements between two potential points two potentials have to be supplied.
–
Regarding the terms "single-wire connection" or "three-wire connection", please note the following for pure analog measurements: three- or four-wire connections can be used for sensor supply, but are not involved in the actual analog measurement, which always takes place between two potentials/wires. In particular this also applies to SE, even though the term suggest that only one wire is required.
▪
The term "electrical isolation" should be clarified in advance. Beckhoff IO modules feature 1…8 or more analog channels; with regard to the channel connection a distinction is made in terms of:
–
how the channels WITHIN a module relate to each other, or
–
how the channels of SEVERAL modules relate to each other.
The property of electrical isolation indicates whether the channels are directly connected to each other.
▪
Beckhoff terminals/boxes always feature electrical isolation between the field/analog side and the bus/EtherCAT side. In other words, if two analog terminals/boxes are not connected via the power contacts, the modules are effectively electrically isolated.
▪
If channels within a module are electrically isolated, or if a single-channel module has no power contacts, the channels are effectively always differential. See also explanatory notes below. Differential channels are not necessarily electrically isolated.
▪
Analog measuring channels are subject to technical limits, both in terms of the recommended operating range (continuous operation) and the destruction limit. Please refer to the respective terminal documentation for further details.
Explanation
▪
Differential
–
Differential measurement is the most flexible concept. The user can freely choose both connection points, input+/signal potential and input-/reference potential, within the framework of the technical specification.
–
A differential channel can also be operated as SE, if the reference potential of several sensors is linked. This interconnection may take place via the system GND.
–
Since a differential is configured symmetrically internally (see diagram), there will be a mid-potential (X) between the two supplied potentials that is the same as the internal ground/reference ground for this channel. If several DIFF channels are used in a module without electrical isolation, the technical property VCM (common-mode voltage) indicates the degree to which the mean voltage of the channels may differ.
–
The internal reference ground may be accessible as connection point at the terminal/box, in order to stabilize a defined GND potential in the terminal/box. In this case it is particularly important to pay attention to the quality of this potential (noiselessness, voltage stability). At this GND point a wire may be connected to make sure that VCM,max is not exceeded in the differential sensor cable. If differential channels are not electrically isolated, usually only one VCM,max is permitted. If the channels are electrically isolated this limit should not apply, and the channels voltages may differ up to the specified separation limit.
–
Differential measurement in combination with correct sensor wiring has the special advantage that any interference affecting the sensor cable (ideally the feed and return line are arranged side by side, so that interference signals have the same effect on both wires) has very little effect on the measurement, since the potential of both lines varies jointly (hence the term common mode). In simple terms: Common-mode interference has the same effect on both wires in terms of amplitude and phasing.
–
Nevertheless, the suppression of common-mode interference within a channel or between channels is subject to technical limits, which are specified in the technical data.
▪
Single Ended
–
If the analog circuit is designed as SE, the input/reference wire is internally fixed to a certain potential that cannot be changed. This potential must be accessible from outside on at least one point for connecting the reference potential, e.g. via the power contacts.
–
In other words, in situations with several channels SE offers users the option to avoid returning at least one of the two sensor cables to the terminal/box (in contrast to DIFF). Instead, the reference wire can be consolidated at the sensors, e.g. in the system GND.
–
A disadvantage of this approach is that the separate feed and return line can result in voltage/current variations, which a SE channel may no longer be able to handle. See common-mode interference. A VCM effect cannot occur, since the module channels are internally always 'hard-wired' through the input/reference potential.
Typification of the 2/3/4-wire connection of current sensors
Current transducers/sensors/field devices (referred to in the following simply as ‘sensor’) with the industrial 0/4-20 mA interface typically have internal transformation electronics for the physical measured variable (temperature, current, etc.) at the current control output. These internal electronics must be supplied with energy (voltage, current). The type of cable for this supply thus separates the sensors into self-supplied or externally supplied sensors:
▪
Self-supplied sensors
–
The sensor draws the energy for its own operation via the sensor/signal cable + and -. So that enough energy is always available for the sensor’s own operation and open-circuit detection is possible, a lower limit of 4 mA has been specified for the 4-20 mA interface; i.e. the sensor allows a minimum current of 4 mA and a maximum current of 20 mA to pass.
–
For a 2-wire connection; see IEC60381-1
–
Such current transducers generally represent a current sink and thus like to sit between + and – as a ‘variable load’. Refer also to the sensor manufacturer’s information.
Therefore, they are to be connected according to the Beckhoff terminology as follows:
▪
preferably to ‘single-ended’ inputs if the +Supply connections of the terminal/box are also to be used - connect to +Supply and Signal
▪
the sensor draws the energy/operating voltage for its own operation from 2 supply cables of its own. One or two further sensor cables are used for the signal transmission of the current loop:
Externally supplied sensors
▪
3- and 4-wire connection see Fig. Connection of externally supplied sensors, cf. IEC60381-1
▪
the sensor draws the energy/operating voltage for its own operation from 2 supply cables of its own. One or two further sensor cables are used for the signal transmission of the current loop:
1.
sensor cable: according to the Beckhoff terminology such sensors are to be connected to ‘single-ended’ inputs in 3 cables with +/-/Signal lines and if necessary FE/shield
2.
sensor cables: In the case of sensors with 4-wire connection according to +-/+Signal/-Signal, you must check whether +Signal may be connected to +Supply or –Signal to –Supply.
–
Yes: then you can connect accordingly to a Beckhoff ‘single-ended’ input.
–
the Beckhoff ‘differential’ input for +Signal and –Signal is to be selected; +Supply and –Supply are to be connected via additional cables.
Notice: expert organizations such as NAMUR demand a usable measuring range <4 mA/>20 mA for error detection and adjustment, see also NAMUR NE043.
The Beckhoff device documentation must be consulted in order to see whether the respective device supports such an extended signal range.
In general the polarity/direction of current is to be observed due to the internal diode!
2/3/4-wire connection as single-ended or differential connection technology


Voltage measurement

Commissioning/Configuration [image] Voltage measurement
Voltage measurement
The EP3356 principally offers a 2-channel voltage measurement on one box with 2 very different measuring ranges of ±25 mV and ±12 V nominal voltage. The load on the one connected strain gauge can be calculated from the two simultaneously measured voltages; the EP3356 already performs this calculation in the box and thus represents a 1-channel box in the sense of load calculation.
The following applies to the individual channels:
▪
Channel 1:
–
Typical measuring range approx. -13.5 V to 0 to +13.5 V (equivalent to process value 0x80.00.00.00 to 0 to 0x7F.FF.FF.FF)
–
Nominal measuring range: -12 V... 0 ... +12 V
–
max. permissible voltage -UD vs. +UD: ±13.5 V
–
Measuring error < ±0.1 % of the full scale value, 50 Hz filter active
▪
Channel 2:
–
Typical measuring range approx. -27 mV to 0 to +27 mV (equivalent to process value 0x80.00.00.00 to 0 to 0x7F.FF.FF.FF)
–
Nominal measuring range: -25 mV... 0 ... +25 mV
–
max. permissible voltage -Uref vs. +Uref: ±27 mV
–
Measuring error < ±0.1 % of the full scale value, 50 Hz filter active
▪
in strain gauge mode the connected strain gauge guarantees that no impermissibly high potential differences arise inside and outside the circuit.
In the standard setting the EP3356 operates as a 1-channel strain gauge monitor with the process image; the box can be switched to 2-channel voltage measurement by changing the process data. See the notes on the process image regarding this. If the EP3356 is not used as a load measuring box, but rather as a 2-channel analog input measuring box, the following must be observed:
▪
The CoE settings are to be found for:
–
Channel 1: objects under 0x8010:xx
–
Channel 2: objects under 0x8020:xx
–
the strain gauge objects under x8000:xx have no function. Exception: the averager (0x8000:03) can also be used in voltage measuring mode and applies to both channels simultaneously.
▪
Self-calibration is not possible and useful.
▪
The two analog channels are not calibrated by the manufacturer, since this is not required for the relative measurement in strain gauge mode. This means, for example, for channel 1 with a nominal measuring range of ±12 V or a typical measuring range of ±13.5 V, that the maximum measured value 0x7F.FF.FF.FF can be output by one terminal/box for example as 13.4 V and by another as 13.6 V. If terminals/boxes output identical process values for identical applied voltages, meaning that they are exchangeable, each channel must be calibrated by the user by making settings for each channel in the CoE. The user calibration (CoE 0x80n0:17 [offset], 0x80n0:18 [gain]) or the user scaling (CoE 0x80n0:11 [offset], 0x80n0:12 [gain]) can be used for this.
Voltage measurement
In the voltage measuring mode the EL3356 is to be connected to external GND with a single-ended connection. In addition the internal GND reference is to be closed by the CoE switch SymmetricReferencePotential. The EP3356 “supply” is not usable because the box internally generated 10 V.


Distributed Clocks mode

Commissioning/Configuration [image] Distributed Clocks mode
Distributed Clocks mode
In the Distributed Clocks mode (DC mode), the precise timestamp is recorded for each measured value and transmitted to the controller as cyclic process data. To this end
▪
DC must be activated. To do this, select DC-Synchron (input based) on the "DC" tab
▪
The PDO x1A03 in the Process data management is to be activated in the SyncManager 3 "Inputs"
Activation of DC and PDO timestamp in the TwinCAT System Manager
The EP3356 operates free running with a cyclic, but not equidistant measurement; the time intervals between 2 measured values are therefore not constant. For this reason the 64-bit timestamp delivered with the process value must be evaluated by the user.
In order to suppress falsification of the measurement results by upstream filters, both the software filter and the averager are deactivated in this operating mode. The measurement/calculation and provision of the measured value in the process data therefore takes place at the conversion rate corresponding to the mode: 10.5 kSps or 105.5 kSps
The minimum permissible EtherCAT cycle time is 100 µs for the EP3356 with and without DC mode.
Time stamp
See Notes on latency regarding the time when the actual timestamp is acquired.


Process data

Commissioning/Configuration [image] Process data
Process data
This section describes the individual PDOs and their content. A PDO (Process Data Object) is a unit on cyclically transmitted process values. Such a unit can be an individual variable (e.g. the weight as a 32-bit value) or a group/structure of variables. The individual PDOs can be activated or deactivated separately in the TwinCAT System Manager. The "Process data" tab is used for this (visible only if the box is selected on the left). A change in the composition of the process data in the TwinCAT System Manager becomes effective only after restarting the EtherCAT system.
The EP3356 can be used in 2 basic operating modes
▪
1-channel strain gauge evaluation (strain gauge, balance beam, load cell): Here, both analog input voltages are measured internally, they are calculated locally according to the internal settings in the box and the resulting load value is output to the controller as a cyclic process value. The box is to be regarded as a 1-channel box. The load value can be output as an integer or as a float/real representation.
▪
2-channel voltage measurement: Both analog input voltages are output directly as process values; no load calculation takes place. The value and status information can be output for each channel.
The basic operating mode of the EP3356 is determined by the selection of the process data (PDO).
Selection of process data
The process data of the EP3356 are set up in the TwinCAT System Manager. The individual PDOs can be activated or deactivated separately. The "Process data" tab is used for this (visible only if the box is selected on the left).
EP3356 Prozessdatenauswahl im TwinCAT Systemmanager1
EP3356 - process data selection in the TwinCAT System Manager
If the box is selected in the System Manager (A), the Process data tab (B) shows the PDO selection. The two SyncManagers of the inputs (SM3) and outputs (SM2) can be changed (C). If one of the two is clicked on, the PDO possible for this SyncManager appears underneath it (D). PDOs that are already activated have an activated checkbox in front of them; this is activated by clicking on it.
The process data which then belong to the device are listed underneath it (G). So that the individual bit meanings are visible, e.g. in the Status status word, and can be separately linked (G), ShowSubVariables must be activated in the System Manager (F). The bit position at which the subvariables are located in the status or control word Ctrl) can be taken from the address overview (H) or the following information.
Predefined PDO Assignment
In order to simplify the configuration, typical configuration combinations of process data are stored in the device description. The predefined configurations can be selected in the process data overview. Therefore the function is available only if the ESI/XML files are saved in the system (downloadable from the Beckhoff website).
The following combinations are possible (see also previous figure, E):
▪
Standard (INT32): [Default setting] load calculation; 32-bit integer load value as final value according to the calculation specifications in the CoE, no further conversion necessary in the PLC
▪
Standard (REAL): Load calculation; 32-bit floating-point load value as final value according to the calculation specifications in the CoE, no further conversion necessary in the PLC
▪
2x AnalogIn (Standard): 2-channel voltage measurement, 32-bit integer voltage value with additional information (under-range, over-range, error, TxPdoToggle)
▪
2x AnalogIn (Compact): 2-channel voltage measurement, 32-bit integer voltage value only
Default process image
The default process image is standard (INT32).
Default process image, EP3356
Function of the variables
Variable: Status
Meaning: The status word (SW) is located in the input process image, and is transmitted from box to the controller.
Bit | SW. 15 | SW. 14 | SW. 13 | SW.12 | SW. 11 | SW. 10 | SW. 9 | SW. 8 | SW. 7 | SW. 6 | SW. 5 | SW. 4 | SW. 3 | SW. 2 | SW. 1 | SW. 0
Name | TxPDO Toggle | - | Sync Error | - | - | - | - | Steady State | Calibration in progress | Error | - | - | Data invalid | - | Overrange | -
Meaning | Toggles 0→1->0 with each updated data set | - | Synchronisation error |  |  |  |  | Idling recognition | Calibration in progress | Collective error display | - | - | Input data are invalid | - | Measuring range exceeded | -
Variable: Value
Meaning: Calculated 32-bit DINT load value in unit [1], with sign
Variable: Value (Real)
Meaning: Calculated 32-bit fixed point REAL load value with mantissa and exponent in unit [1]
The format matches the REAL format of IEC 61131-3, which in turn is based on the REAL format of IEC 559. A REAL number (single precision) is defined as follows (See also Beckhoff InfoSys: TwinCAT PLC Control: standard data types). In accordance with IEC 61131 this 32-bit variable can be directly linked with a FLOAT variable of the PLC.
Bitposition (from the left) | 1 | 8 | 23 (+1 „hidden bit“, see IE559)
Function | Sign | Exponent | Mantissa
Variable: WcState
Meaning: Cyclic diagnostic variable; „0“ indicates correct data transmission
Variable: Status
Meaning: State of the EtherCAT device; State.3 = TRUE indicates correct operation in OP
Variable: AdsAddr
Meaning: AmsNet address of the EtherCAT device from AmsNetId (in this case: 192.168.0.20.5.1) and port (in this case: 1003)
Variable: Ctrl
Meaning: The control word (CW) is located in the output process image, and is transmitted from the controller to the box.
Bit | CW. 15 | CW. 14 | CW. 13 | CW. 12 | CW. 11 | CW. 10 | CW. 9 | CW. 8 | CW. 7 | CW. 6 | CW. 5 | CW. 4 | CW. 3 | CW. 2 | CW. 1 | CW. 0
Name | - |  |  |  |  |  |  |  |  |  |  | Tara | Sample Mode | Input Freeze | Disable Calibration | Start Calibration
Meaning | - |  |  |  |  |  |  |  |  |  |  | starts tare | mode switching (EL3356-0010 and EP3356-0022only) | stops the measurement | Switches the automatic self-calibration off | Starts the self-calibration immediately
See also the example program for the dissection of the Status and CTRL variable.
Variants (Predefined PDO)
Fixed-point representation of the load
The display of the load value can also be converted already in the box into a point representation. To do this the input PDOs are to be changed as follows:
Load value in fixed-point representation
Variable: Value (Real)
Meaning: Calculated 32-bit fixed point REAL load value with mantissa and exponent in unit [1]
The format matches the REAL format of IEC 61131-3, which in turn is based on the REAL format of IEC 559. A REAL number (single precision) is defined as follows (See also Beckhoff InfoSys: TwinCAT PLC Control: standard data types). This 32-bit variable can be linked directly with a FLOAT variable of the PLC according to IEC61131.
Bit position (from left) | 1 | 8 | 23 (+1 „hidden bit“, see IEC 559)
Function | Sign | Exponent | Mantissa
Voltage measurement
The EP3356 can also be used as a 2-channel analog input box for voltage measurement, see Notes.
EP3356-0022 Spannungsmessung Predefined1 PDO
Voltage measurement
Variable | Meaning
Underrange | Measurement is below range
Overrange | Measuring range exceeded
Error | Collective error display
TxPDO Toggle | Toggles 0→1→0 with each updated data set
Value | Right-justified voltage value over the respective measuring range (Range of values 0x80.00.00.00…0…0x7F.FF.FF.FF) Channel 1: supply voltage Channel 2: bridge voltage
Distributed Clocks
In DC mode (Distributed Clocks) the process data x1A03 Timestamp must be activated.
Also, the variables DcOutputShift and DcInputShift are displayed in the process data in DC mode. Upon activation of the configuration these are calculated once in the unit [ns] on the basis of the set EtherCAT cycle time (observe assigned task!) and DC shift times from the EtherCAT master settings. In the InputBased operating mode, DcInputShift indicates by how many nanoseconds [ns] before or after the global Sync the box determines your process data. For further information on this, see the EtherCAT system description.
Since the EP3356 is not DC-triggered but determines the timestamp itself, these values have no meaning in the EP3356.
Sync Manager (SM)
PDO Assignment
Inputs: SM3, PDO Assignment 0x1C13
Index | Index of excluded PDOs | Size (byte.bit) | Name | PDO content Index - Name
0x1A00 (default) | - | 2.0 | RMB Status (Resistor Measurement Bridge) | 0x6000:02 - Overrange 0x6000:04 - Data invalid 0x6000:07 - Error 0x6000:08 - Calibration in progress 0x6000:09 - Steady State 0x1C32:20 - Sync Error 0x1800:09 - TxPDO Toggle
0x1A01 (default) | 0x1A02 0x1A04 0x1A05 0x1A06 0x1A07 | 4.0 | RMB Value (INT 32) | 0x6000:11 - Value
0x1A02 | 0x1A01 0x1A04 0x1A05 0x1A06 0x1A07 | 4.0 | RMB Value (Real) | 0x6000:12 - Value
0x1A03 | 0x1A04 0x1A05 0x1A06 0x1A07 | 8.0 | RMB Timestamp | 0x6000:13 - Value
0x1A04 | 0x1A00 0x1A01 0x1A02 0x1A03 0x1A05 | 6.0 | AI Standard Channel 1 (Analog Input) | 0x6010:01 - Underrange 0x6010:02 - Overrange 0x6010:07 - Error 0x6010:10 - TxPDO Toggle 0x6010:11 - Value
0x1A05 | 0x1A00 0x1A01 0x1A02 0x1A03 0x1A04 | 4.0 | AI Standard Channel 1 (Analog Input) | 0x6010:11 - Value
0x1A06 | 0x1A00 0x1A01 0x1A02 0x1A03 0x1A07 | 6.0 | AI Standard Channel 2 (Analog Input) | 0x6020:01 - Underrange 0x6020:02 - Overrange 0x6020:07 - Error 0x6020:10 - TxPDO Toggle 0x6020:11 - Value
0x1A07 | 0x1A00 0x1A01 0x1A02 0x1A03 0x1A06 | 4.0 | AI Standard Channel 2 (Analog Input) | 0x6020:11 - Value
Outputs: SM2, PDO-Zuordnung 0x1C12
Index | Index ausgeschlossener PDOs | Größe (Byte.Bit) | Name | PDO Inhalt
0x1600 (default) | - | 2.0 | RMB Control (Resistor Measurement bridge) | 0x7000:01 - Start calibration 0x7000:02 - Disable calibration 0x7000:03 - Input freeze 0x7000:04 - Sample Mode (only EL3356-0010/EP3356-0022) 0x7000:05 - Tara


Object description and parameterization

Commissioning/Configuration [image] Object description and parameterization
Object description and parameterization
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Parameterization via the CoE list (CAN over EtherCAT)
The EtherCAT device is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs).
Index 1011 Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore the default settings in the EtherCAT slave | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" ("Set Value Dialog") all terminal/box-specific objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)
Index 8000 RMB Settings
Index (hex) | Name | Meaning | Data type | Flags | Default
8000:0 | RMB Settings | Max. subindex | UINT8 | RO | 0x32 (50dec)
8000:01 | Mode0 enable filter | 0: No filters active. The terminal/box operates cycle synchronous 1: The filter settings of subindex 0x8000:11 or 0x8000:12 are active. | BOOLEAN | RW | 0x01 (1dec)
8000:02 | Mode1 enable filter (Only EL3356-0010, EP3356-0022) |  | BOOLEAN | RW | 0x01 (1dec)
8000:03 | Mode0 enable averager | Activates hardware averager | BOOLEAN | RW | 0x01 (1dec)
8000:04 | Mode1 enable averager (Only EL3356-0010, EP3356-0022) |  | BOOLEAN | RW | 0x01 (1dec)
8000:05 | Symmetric reference potential | Activates symmetric measurement | BOOLEAN | RW | 0x01 (1dec)
8000:11 | Mode0 filter settings | 0: FIR 50 Hz 1: FIR 60 Hz 2: IIR 1 3: IIR 2 4: IIR 3 5: IIR 4 6: IIR 5 7: IIR 6 8: IIR 7 9: IIR 8 10: Dynamic IIR 11: PDO Filter frequency see filters | UINT16 | RW | 0x0000 (0dec)
8000:12 | Mode1 filter settings (Only EL3356-0010, EP3356-0022) |  | UINT16 | RW | 0x0000 (0dec)
8000:13 | Dynamic filter change time | Sampling rate of dynamic filter switching Scaling 0.01 ms (100 = 1 s) (only if filters are active and "dynamic IIR" is selected) | UINT16 | RW | 0x000A (10dec)
8000:14 | Dynamic filter delta | Limit value of dynamic filter switching (only if filters are active and "dynamic IIR" is selected) | REAL32 | RW | 0x41A00000 (1101004800dec) = 20.0
8000:21 | Gain | Scaling factor | REAL32 | RW | 0x3F800000 (1065353216dec) = 1.0
8000:22 | Tara | Offset of process data value | REAL32 | RW | 0x00000000 (0dec) = 0.0
Index (hex) | Name | Meaning | Data type | Flags | Default
8000:23 | Rated output | Nominal sensitivity of sensor element in mV/V | REAL32 | RW | 0x40000000 (1073741824dec) = 2.0
8000:24 | Nominal load | Nominal load of force transducer/load cell/etc. (e.g. in kg or N, ....) | REAL32 | RW | 0x40A00000 (1084227584dec) = 5.0
8000:25 | Zero balance | Zero point offset in mV/V | REAL32 | RW | 0x00000000 (0dec) = 0.0
8000:26 | Gravity of earth | Current gravity of earth (default 9.806650) | REAL32 | RW | 0x411CE80A (1092413450dec) = 9.806650
8000:27 | Scale factor | This factor is for rescaling of the process data, e.g. for changing the indication from "kg" to "g", you shall enter the factor "1000" here. | REAL32 | RW | 0x447A0000 (1148846080dec) = 1000.0
8000:28 | Reference load | Reference weight for manual calibration | REAL32 | RW | 0x40A00000 (1084227584dec) = 5.0
8000:29 | Steady state window | Time constant for the "steady state" bit (Idling recognition) | UINT16 | RW | 0x03E8 (1000dec)
8000:2A | Steady state tolerance | Tolerance window for the "steady state" bit | UINT32 | RW | 0x00000005 (5dec)
8000:31 | Calibration interval | Calibration interval for the automatic calibration of the terminal/box (unit: 100 ms) The automatic calibration can be prevented by setting the process data bit "Disable calibration" | UINT16 | RW | 0x0708 (1800dec)
8000:32 | Test interval | This object contains the testing interval for the cyclic self test of the terminal/box This interval is always a multiple (default: 10dec) of the calibration interval (0x8000:31So the delivery state of the testing interval result from 10 x 180 s = 1800 s. The self test can be prevented by setting the process data bit "Disable calibration" | UINT16 | RW | 0x000A (10dec)
Index 8010, 8020 AI Settings
Index (hex) | Name | Meaning | Data type | Flags | Default
80n0:0 | AI Settings | Max. subindex | UINT8 | RO | 0x18 (24dec)
80n0:01 | Enable user scale | User scale is enabled, if bit is set | BOOLEAN | RW | 0x00 (0dec)
80n0:06 | Enable filter | Activates filter | BOOLEAN | RW | 0x01 (1dec)
80n0:0A | Enable user calibration | User calibration is enabled, if bit is set | BOOLEAN | RW | 0x00 (0dec)
80n0:0B | Enable vendor calibration | Vendor calibration is enabled, if bit is set | BOOLEAN | RW | 0x01 (1dec)
80n0:11 | User scale offset | User scale offset | INT32 | RW | 0x00000000 (0dec)
80n0:12 | User scale gain | User scale gain The gain is represented in fixed-point format, with the factor 2-16. A value of 1 for the gain factor therefore corresponds to 65535dec (0x00010000hex) and is limited to 0x7FFFF. | INT32 | RW | 0x00010000 (65536dec)
80n0:15 | Filter settings | This object defines the digital filter settings, if it is activated with index 0x80n0:06 . The possible settings are numbered consecutively 0: 50 Hz FIR 1: 60 Hz FIR 2: IIR 1 3: IIR 2 4: IIR 3 5: IIR 4 6: IIR 5 7: IIR 6 8: IIR 7 9: IIR 8 | UINT16 | RW | 0x0000 (0dec)
80n0:17 | User calibration offset | User calibration offset | INT32 | RW | 0x00000000 (0dec)
80n0:18 | User calibration gain | User calibration gain | INT16 | RW | 0x4000 (16384dec)
Command object, Index FB00 RMB Command
Index (hex) | Name | Meaning | Data type | Flags | Default
FB00:0 | RMB Command | Max. subindex | UINT8 | RO | 0x03 (3dec)
FB00:01 | Request | Via the request object, commands can be sent to the terminal/box Command: - 0x0101: Zero adjustment - 0x0102: Calibration - 0x0001 Tara setting - 0x0002 Tara setting (Data are saved into the EEPROM) see commands | OCTET-STRING[2] | RW | {0}
FB00:02 | Status | State of the current executed command 0: Command executed without errors 255: Execution of command | UINT8 | RO | 0x00 (0dec)
FB00:03 | Response | Optional return value of the command | OCTET-STRING[4] | RO | {0}
Input data, Index 6000 RMB Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
6000:0 | RMB Inputs | Max. subindex | UINT8 | RO | 0x13 (19dec)
6000:02 | Overrange | The measuring value has reached its terminal/box value | BOOLEAN | RO | 0x00 (0dec)
6000:04 | Data invalid | The indicated process data are not valid, e.g. during calibration | BOOLEAN | RO | 0x00 (0dec)
6000:07 | Error | An error has occurred | BOOLEAN | RO | 0x00 (0dec)
6000:08 | Calibration in progress | Calibration in progress. The process data indicate the last valid measuring value | BOOLEAN | RO | 0x00 (0dec)
6000:09 | Steady state |  | BOOLEAN | RO | 0x00 (0dec)
6000:0E | Sync error | TRUE: In the last cycle the synchronization was not correct (only in DC-Mode) | BOOLEAN | RO | 0x00 (0dec)
6000:10 | TxPDO Toggle | The TxPDO Toggle is toggled by the slave, if the data of the corresponding PDO was updated. | BOOLEAN | RO | 0x00 (0dec)
6000:11 | Value | Measuring value as 32 Bit SIGNED INTEGER | INT32 | RO | 0x61746144 (1635017028dec)
6000:12 | Value (Real) | Measuring value as REAL | REAL32 | RO | 0x00000000 (0dec)
6000:13 | Timestamp | Timestamp of current measuring value (only EL3356-0010/EP3356-0022 in DC-Mode) | UINT64 | RO |
Input data Index 6010, 6020 AI Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
60n0:0 | AI Inputs | Max. subindex | UINT8 | RO | 0x11 (17dec)
60n0:01 | Underrange | Value falls below the measuring range | BOOLEAN | RO | 0x00 (0dec)
60n0:02 | Overrange | Measurement range is exceeded. | BOOLEAN | RO | 0x00 (0dec)
60n0:07 | Error | An error has occurred, e.g.: - Over- / underrange Udif - Over- / underrange Uref - the external Uref is too low (between-1 V and +1 V) - Data invalid | BOOLEAN | RO | 0x00 (0dec)
60n0:10 | TxPDO Toggle | The TxPDO Toggle is toggled by the slave, if the data of the corresponding PDO was updated. | BOOLEAN | RO | 0x00 (0dec)
60n0:11 | Value | 32 Bit measuring value | INT32 | RO | 0x00000000 (0dec)
Output data, Index 7000 RMB Outputs
Index (hex) | Name | Meaning | Data type | Flags | Default
7000:0 | RMB Outputs | Max. subindex | UINT8 | RO | 0x05 (5dec)
7000:01 | Start calibration | The calibration can be started manually with a rising edge. Therefore, an automatic start of the calibration at an inappropriate point of time can be prevented. | BOOLEAN | RO | 0x00 (0dec)
7000:02 | Disable calibration | 0: The automatic calibration is active 1: The automatic calibration is inactive | BOOLEAN | RO | 0x00 (0dec)
7000:03 | Input freeze | The process data and the digital filter will be frozen | BOOLEAN | RO | 0x00 (0dec)
7000:04 | Sample mode | Selection of the sampling mode: 0: 10.5 kHz High precision 1: 105 kHz Low latency | BOOLEAN | RO | 0x00 (0dec)
7000:05 | Tara | The process data can be set to zero with a rising edge. The tara value is not stored in the EEPROM and is lost after a reset of the terminal/box | BOOLEAN | RO | 0x00 (0dec)
7000:11 | Filter frequency | Filter frequency of the variable PDO filter in 0.1 Hz, see filter Wertebereich: value range: 1 ... 2000 (equates to 0,1 ... 200 Hz) From a value 0 or >2000, the filter behaves like a 50 Hz FIR filter | UINT16 | RO | 0x00 (0dec)
Information-/diagnostic data, Index 801E, 802E AI Internal data
Index (hex) | Name | Meaning | Data type | Flags | Default
801E:0 | AI Internal data | Max. subindex | UINT8 | RO | 0x01 (1dec)
801E:01 | ADC raw value 1 | ADC raw value | INT32 | RO | 0x00000000 (0dec)
Index 9000 RMB Info data
Index (hex) | Name | Meaning | Data type | Flags | Default
9000:0 | RMB Info data | Max. subindex | UINT8 | RO | 0x11 (17dec)
9000:11 | mV/V | Current mV/V value | REAL32 | RO | 0x00000000 (0dec)
Index A000 RMB Diag data
Index (hex) | Name | Meaning | Data type | Flags | Default
A000:0 | RMB Diag data | Max. subindex | UINT8 | RO | 0x18 (24dec)
A000:11 | No internal referecnce supply | No internal reference voltage at ADC input (URef channel) | BOOLEAN | RO | 0x00 (0dec)
A000:12 | No internal referecnce bridge | No internal reference voltage at ADC input (UDif channel | BOOLEAN | RO | 0x00 (0dec)
A000:13 | No external reference supply | The external reference voltage is below ±1 V | BOOLEAN | RO | 0x00 (0dec)
A000:15 | Overrange bridge | Overranged measuring value in the bridge section | BOOLEAN | RO | 0x00 (0dec)
A000:16 | Underrange bridge | Underranged measuring value in the bridge section | BOOLEAN | RO | 0x00 (0dec)
A000:17 | Overrange supply | Overranged measuring value of the reference voltage | BOOLEAN | RO | 0x00 (0dec)
A000:18 | Underrange supply | Underranged measuring value of the reference voltage | BOOLEAN | RO | 0x00 (0dec)
Vendor configuration data, Index 801F, 802F AI Vendor data
Index (hex) | Name | Meaning | Data type | Flags | Default
801F:0 | AI Vendor data | Max. subindex | UINT8 | RO | 0x02 (2dec)
801F:01 | Calibration offset | Offset (vendor calibration)) | INT32 | RW | 0x01E10000 (31522816dec)
801F:02 | Calibration gain | Gain (vendor calibration)) | INT16 | RW | 0x4000 (16384dec)
Standard objects, Index 1000 Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The low word contains the CoE profile used (5001). The high word contains the module profile according to the modular device profile. | UINT32 | RO | 0x01681389 (23597961dec)
Index 1008 Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EL3356 / EP3356
Index 1009 Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO | 00
Index 100A Software version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO | 01
Index 1018 Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x0D1C3052 (219951186dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the low word (bit 0-15) indicates the special terminal/box number, the high word (bit 16-31) refers to the device description | UINT32 | RO | 0x00100000 (1048576dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the low byte (bit 0-7) of the low word contains the year of production, the high byte (bit 8-15) of the low word contains the week of production, the high word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 Backup parameter handling
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | Information for standardized loading and saving of backup entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum across all backup entries of the EtherCAT slave | UINT32 | RO | 0x00000000 (0dec)
Index 1600 RMB RxPDO-Map Control
Index (hex) | Name | Meaning | Data type | Flags | Default
1600:0 | RMB RxPDO-Map Control | PDO Mapping RxPDO-Map control | UINT8 | RO | 0x07 (7dec)
1600:01 | Subindex 001 | 1. PDO Mapping entry (object 0x7000 (RMB outputs), entry 0x01 (Start calibration)) | OCTET-STRING[10] | RO | 0x7000:01, 1
1600:02 | Subindex 002 | 2. PDO Mapping entry (object 0x7000 (RMB outputs), entry 0x02 (Disable calibration)) | OCTET-STRING[10] | RO | 0x7000:02, 1
1600:03 | Subindex 003 | 3. PDO Mapping entry (object 0x7000 (RMB outputs), entry 0x03 (Input freeze)) | OCTET-STRING[10] | RO | 0x7000:03, 1
1600:04 | Subindex 004 | 4. PDO Mapping entry (1 bits align) | OCTET-STRING[10] | RO | 0x0000:00, 1
1600:05 | Subindex 005 | 5. PDO Mapping entry (object 0x7000 (RMB outputs), entry 0x05 (Tara)) | OCTET-STRING[10] | RO | 0x7000:05, 1
1600:06 | Subindex 006 | 6. PDO Mapping entry (3 bits align) | OCTET-STRING[10] | RO | 0x0000:00, 3
1600:07 | Subindex 007 | 7. PDO Mapping entry (8 bits align) | OCTET-STRING[10] | RO | 0x0000:00, 8
Index 1601 RMB RxPDO-Map-Filter frequency
Index (hex) | Name | Meaning | Data type | Flags | Default
1601:0 | RMB RxPDO-Map Filter frequency | PDO Mapping RxPDO-Map Filter frequency | UINT8 | RO | 0x01 (1dec)
1601:01 | Subindex 001 | 1. PDO Mapping entry (object 0x7000 (RMB ouputs), entry 0x11 (Start calibration)) | OCTET-STRING[10] | RO | 0x7000:11, 16
Index 1800 RMB TxPDO-Par Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1800:0 | RMB TxPDO-Par Status | PDO Parameter TxPDO 1 | UINT8 | RO | 0x06 (6dec)
1800:06 | Exclude TxPDOs | This entry contains the TxPDOs (Index of the TxPDO Mapping objects) which shall not be transmitted with TxPDO 1 | OCTET-STRING[10] | RO | 04 1A 05 1A 06 1A 07 1A 00 00
Index 1801 RMB TxPDO-Par Value (INT 32)
Index (hex) | Name | Meaning | Data type | Flags | Default
1801:0 | RMB TxPDO-Par Value (INT32) | PDO Parameter TxPDO 2 | UINT8 | RO | 0x06 (6dec)
1801:06 | Exclude TxPDOs | This entry contains the TxPDOs (Index of the TxPDO Mapping objects) which shall not be transmitted with TxPDO 2 | OCTET-STRING[10] | RO | 02 1A 04 1A 05 1A 06 1A 07 1A
Index 1802 RMB TxPDO-Par Value (Real)
Index (hex) | Name | Meaning | Data type | Flags | Default
1802:0 | RMB TxPDO-Par Value (Real) | PDO Parameter TxPDO 3 | UINT8 | RO | 0x06 (6dec)
1802:06 | Exclude TxPDOs | This entry contains the TxPDOs (Index of the TxPDO Mapping objects) which shall not be transmitted with TxPDO 3 | OCTET-STRING[10] | RO | 01 1A 04 1A 05 1A 06 1A 07 1A
Index 1803 RMB TxPDO-Par Timestamp
Index (hex) | Name | Meaning | Data type | Flags | Default
1803:0 | RMB TxPDO-Par Timestamp | PDO Parameter TxPDO 4 | UINT8 | RO | 0x06 (6dec)
1803:06 | Exclude TxPDOs | This entry contains the TxPDOs (Index of the TxPDO Mapping objects) which shall not be transmitted with TxPDO 4 | OCTET-STRING[10] | RO | 04 1A 05 1A 06 1A 07 1A 00 00
Index 1804 AI TxPDO-Par Standard Ch. 1
Index (hex) | Name | Meaning | Data type | Flags | Default
1804:0 | AI TxPDO-Par Standard Ch.1 | PDO Parameter TxPDO 5 | UINT8 | RO | 0x06 (6dec)
1804:06 | Exclude TxPDOs | This entry contains the TxPDOs (Index of the TxPDO Mapping objects) which shall not be transmitted with TxPDO 5 | OCTET-STRING[10] | RO | 05 1A 00 1A 01 1A 02 1A 03 1A
Index 1805 AI TxPDO-Par Compact Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1805:0 | AI TxPDO-Par Compact Ch.1 | PDO Parameter TxPDO 6 | UINT8 | RO | 0x06 (6dec)
1805:06 | Exclude TxPDOs | This entry contains the TxPDOs (Index of the TxPDO Mapping objects) which shall not be transmitted with TxPDO 6 | OCTET-STRING[10] | RO | 04 1A 00 1A 01 1A 02 1A 03 1A
Index 1806 AI TxPDO-Par Standard Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1806:0 | AI TxPDO-Par Standard Ch.2 | PDO Parameter TxPDO 7 | UINT8 | RO | 0x06 (6dec)
1806:06 | Exclude TxPDOs | This entry contains the TxPDOs (Index of the TxPDO Mapping objects) which shall not be transmitted with TxPDO 7 | OCTET-STRING[10] | RO | 07 1A 00 1A 01 1A 02 1A 03 1A
Index 1807 AI TxPDO-Par Compact Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1807:0 | AI TxPDO-Par Compact Ch.2 | PDO Parameter TxPDO 8 | UINT8 | RO | 0x06 (6dec)
1807:06 | Exclude TxPDOs | This entry contains the TxPDOs (Index of the TxPDO Mapping objects) which shall not be transmitted with TxPDO 8 | OCTET-STRING[10] | RO | 06 1A 00 1A 01 1A 02 1A 03 1A
Index 1A00 RMB TxPDO-Map Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1A00:0 | RMB TxPDO-Map Status | PDO Mapping RxPDO-Map Status | UINT8 | RO | 0x0C (12dec)
1A00:01 | Subindex 001 | 1. PDO Mapping entry (1 bits align) | OCTET-STRING[10] | RO | 0x0000:00, 1
1A00:02 | Subindex 002 | 2. PDO Mapping entry (object 0x6000 (RMB inputs), entry 0x02 (Overrange)) | OCTET-STRING[10] | RO | 0x6000:02, 1
1A00:03 | Subindex 003 | 3. PDO Mapping entry (1 bits align) | OCTET-STRING[10] | RO | 0x0000:00, 1
1A00:04 | Subindex 004 | 4. PDO Mapping entry (object 0x6000 (RMB inputs), entry 0x04 (Data invalid)) | OCTET-STRING[10] | RO | 0x6000:04, 1
1A00:05 | Subindex 005 | 5. PDO Mapping entry (2 bits align) | OCTET-STRING[10] | RO | 0x0000:00, 2
1A00:06 | Subindex 006 | 6. PDO Mapping entry (object 0x6000 (RMB inputs), entry 0x07 (Error)) | OCTET-STRING[10] | RO | 0x6000:07, 1
1A00:07 | Subindex 007 | 7. PDO Mapping entry (object 0x6000 (RMB inputs), entry 0x08 (Calibration in progress)) | OCTET-STRING[10] | RO | 0x6000:08, 1
1A00:08 | Subindex 008 | 8. PDO Mapping entry (object 0x6000 (RMB inputs), entry 0x09 (Steady state)) | OCTET-STRING[10] | RO | 0x6000:09, 1
1A00:09 | Subindex 009 | 9. PDO Mapping entry (4 bits align) | OCTET-STRING[10] | RO | 0x0000:00, 4
1A00:0A | Subindex 010 | 10. PDO Mapping entry (object 0x6000 (RMB inputs), entry 0x0E (Sync error)) | OCTET-STRING[10] | RO | 0x6000:0E, 1
1A00:0B | Subindex 011 | 11. PDO Mapping entry (1 bits align) | OCTET-STRING[10] | RO | 0x0000:00, 1
1A00:0C | Subindex 012 | 12. PDO Mapping entry (object 0x6000 (RMB inputs), entry 0x10 (TxPDO Toggle)) | OCTET-STRING[10] | RO | 0x6000:10, 1
Index 1A01 RMB TxPDO-Map Value (INT32)
Index (hex) | Name | Meaning | Data type | Flags | Default
1A01:0 | RMB TxPDO-Map Value (INT32) | PDO Mapping Value (INT32) | UINT8 | RW | 0x01 (1dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (RMB inputs), entry 0x11 (Value)) | UINT32 | RW | 0x6000:11, 32
Index 1A02 RMB TxPDO-Map Value (Real)
Index (hex) | Name | Meaning | Data type | Flags | Default
1A02:0 | RMB TxPDO-Map Value (real) | PDO Mapping Value (real) | UINT8 | RW | 0x01 (1dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (RMB inputs), entry 0x12 (Value (real))) | UINT32 | RW | 0x6000:12, 32
Index 1A03 RMB TxPDO-Map Timestamp
Index (hex) | Name | Meaning | Data type | Flags | Default
1A03:0 | RMB TxPDO-Map Timestamp | PDO Mapping Value Timestamp | UINT8 | RW | 0x01 (1dec)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x0000, entry 0x00) | UINT64 | RW | 0x0000:00, 64
Index 1A04 AI TxPDO-Map Standard Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A04:0 | AI supply TxPDO-Map Standard Ch. 1 | PDO Mapping TxPDO Standard Ch. 1 | UINT8 | RW | 0x07 (7dec)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (AI supply Inputs), entry 0x01 (Underrange)) | UINT32 | RW | 0x6010:01, 1
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (AI supply Inputs), entry 0x02 (Overrange)) | UINT32 | RW | 0x6010:02, 1
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (4 bits align) | UINT32 | RW | 0x0000:00, 4
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (AI supply Inputs), entry 0x04 (Error)) | UINT32 | RW | 0x6010:07, 1
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
1A04:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010, entry 0x10 (TxPDO Toggle)) | UINT32 | RW | 0x6010:10, 1
1A04:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010, entry 0x11 (Value)) | UINT32 | RW | 0x6010:11, 32
Index 1A05 AI TxPDO-Map Compact Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A05:0 | AI supply TxPDO-Map Compact Ch. 1 | PDO Mapping TxPDO Compact Ch. 1 | UINT8 | RW | 0x01 (1dec)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010, entry 0x11 (Value)) | UINT32 | RW | 0x6010:11, 32
Index 1A06 AI TxPDO-Map Standard Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A06:0 | AI supply TxPDO-Map Standard Ch. 2 | PDO Mapping TxPDO Standard Ch. 2 | UINT8 | RW | 0x07 (7dec)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (AI supply Inputs), entry 0x01 (Underrange)) | UINT32 | RW | 0x6020:01, 1
1A06:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (AI supply Inputs), entry 0x02 (Overrange)) | UINT32 | RW | 0x6020:02, 1
1A06:03 | SubIndex 003 | 3. PDO Mapping entry (4 bits align) | UINT32 | RW | 0x0000:00, 4
1A06:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (AI supply Inputs), entry 0x04 (Error)) | UINT32 | RW | 0x6020:07, 1
1A06:05 | SubIndex 005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
1A06:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6020, entry 0x10 (TxPDO Toggle)) | UINT32 | RW | 0x6020:10, 1
1A06:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020, entry 0x11 (Value)) | UINT32 | RW | 0x6020:11, 32
Index 1A07 AI TxPDO-Map Compact Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A07:0 | AI supply TxPDO-Map Compact Ch. 2 | PDO Mapping TxPDO Compact Ch. 2 | UINT8 | RW | 0x01 (1dec)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020, entry 0x11 (Value)) | UINT32 | RW | 0x6020:11, 32
Index 1C00 Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Usage of the Sync Manager channels | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x01 (1dec)
1C12:01 | Subindex 001 | 1. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1600 (5632dec)
1C12:02 | Subindex 002 | 2. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | -
Index 1C13 TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x01 (1dec)
1C13:01 | Subindex 001 | 1. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A01 (6657dec)
1C13:03 | Subindex 003 | 3. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | -
Index 1C32 SM output parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C32:0
SM output parameter
Synchronization parameter of the outputs
UINT8
RO
0x20 (32dec)
1C32:01
Sync mode
Actual synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (no Outputs available)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dec)
1C32:02
Cycle time
Cycle time (in ns):
▪
Free Run: cycle time of the local timer
▪
Synchron with SM 2 Event: Cycle time of the master
▪
DC-Mode: SYNC0/SYNC1 Cycle time
UINT32
RW
0x000C65D4 (812500dec)
1C32:03
Shift time
Time between SYNC0-Event and Input Latch (in ns, only in DC-Mode)
UINT32
RO
0x00000000 (0dec)
1C32:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0 = 1: Free Run is supported
▪
Bit 1 = 1: Synchron with SM 2 Event is supported
▪
Bit 2-3 = 01: DC-Mode is supported
▪
Bit 4-5 = 01: Input Shift with local event (Outputs available)
▪
Bit 4-5 = 10: Output Shift with SYNC1 Event (only DC mode)
▪
Bit 14 = 1: dynamic times (could be measured by writing 0x1C32:08)
UINT16
RO
0xC007 (49159dec)
1C32:05
Minimum cycle time
Minimum cycle time supported (in ns)
UINT32
RO
0x0000C350 (50000dec)
1C32:06
Calc and copy time
Minimum time between SYNC0 and SYNC1 event (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C32:07
Minimum delay time
UINT32
RO
0x00000000 (0dec)
1C32:08
Command
▪
0: Measurement of the times will be stopped
▪
1: Measurement of the times will be started
The Entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 will be updated with the maximum measured values.
The measured valued well be reset, if measured again
UINT16
RW
0x0000 (0dec)
1C32:09
Maximum Delay time
Time between SYNC1-Event and output latch (in ns, only in DC mode)
UINT32
RO
0x00000000 (0dec)
1C32:0B
SM event missed counter
Number of the missed SM-Events in state OPERATIONAL (only in DC Mode)
UINT16
RO
0x0000 (0dec)
1C32:0C
Cycle exceeded counter
Number of the exceeded cycles in state OPERATIONAL
UINT16
RO
0x0000 (0dec)
1C32:0D
Shift too short counter
Number of the too short distances between SYNC0 and SYNC1 Event (only in DC Mode)
UINT16
RO
0x0000 (0dec)
1C32:20
Sync error
TRUE: In the last cycle the synchronization was not correct (only in DC-Mode)
BOOLEAN
RO
0x00 (0dec)
Index 1C33 SM input parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameter of the outputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Actual synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (no Outputs available)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: synchronous with SM 2 event (outputs available)
UINT16
RW
0x0022 (34dec)
1C33:02
Cycle time
same as 0x1C32:02
UINT32
RW
0x000C65D4 (812500dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: synchronous with SM 2 event is supported (outputs available)
▪
Bit 1: synchronous with SM 3 event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: input shift through local event (outputs available)
▪
Bit 4-5 = 10: input shift with SYNC1 event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08 or 1C33:08)
UINT16
RO
0xC007 (49159dec)
1C33:05
Minimum cycle time
same as 0x1C32:05
UINT32
RO
0x0000C350 (50000dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:07
Minimum delay time
UINT32
RO
0x00000000 (0dec)
1C33:08
Command
same as 0x1C32:08
UINT16
RW
0x0000 (0dec)
1C33:09
Maximum Delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:0B
SM event missed counter
same as 0x1C32:11
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
same as 0x1C32:12
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
same as 0x1C32:13
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
same as 0x1C32:32
BOOLEAN
RO
0x00 (0dec)
Index F000 Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index spacing of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0001 (1dec)
Index F008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module list
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list | Max. subindex | UINT8 | RW | 0x03 (3dec)
F010:01 | SubIndex 001 | RMB | UINT32 | RW | 0x00000172 (370dec)
F010:02 | SubIndex 002 | AI | UINT32 | RW | 0x0000012C (300dec)
F010:03 | SubIndex 003 | AI | UINT32 | RW | 0x0000012C (300dec)


Example program

Commissioning/Configuration [image] Example program
Example program
Using the example programs
This document contains sample applications of our products for certain areas of application. The application notes provided here are based on typical features of our products and only serve as examples. The notes contained in this document explicity do not refer to specific applications. The customer is therefore responsible for assessing and deciding whether the product is suitable for a particular application. We accept no responsibility for the completeness and correctness of the source code contained in this document. We reserve the right to modify the content of this document at any time and accept no responsibility for errors and missing information.
In this example program an EP3356 is addressed by a PLC program (for TwinCAT 2). The Zip-file ( ) contains the PLC*.pro and the System Manager*.tsm. The box can be operated via simple visualization; the function InputFreeze is programmed out by way of example.
Use of the example program
The EP3356 EtherCAT Box is to be connected as shown below:
Anschluss der Wägezelle
EP3356: Connection of the load sensor/full bridge
The sensor power supply of 10 V is produced in EP3356.
Procedure for starting the program
▪
After clicking the Download button, save the zip file locally on your hard disk, and unzip the *.TSM (configuration) and the *.PRO (PLC program) files into a temporary working folder
▪
Run the *.TSM file and the *.PRO file; the TwinCAT System Manger and TwinCAT PLC will open
▪
Connect the hardware in accordance with one of the two previous figures and connect the Ethernet adapter of your PC to the EtherCAT coupler / EtherCAT box (further information on this can be found in the corresponding coupler manuals)
▪
Select the local Ethernet adapter (with real-time driver, if one) under System configuration, I/O configuration, I/O devices, Device (EtherCAT); on the "Adapter" tab choose "Search...", select the appropriate adapter and confirm (see the following two figures)
Searching the Ethernet adapter
Selection and confirmation of the Ethernet adapter
▪
Activation of the configuration and confirmation (see the following two figures)
Activation of the configuration
Confirming the activation of the configuration
▪
Confirming new variable mapping, restart in RUN mode (see the following two figures)
Generating variable mapping
Restarting TwinCAT in RUN mode
▪
In TwinCAT PLC, under the "Project" menu, select "Rebuild all" to compile the project (see following figure)
Compile project
In TwinCAT PLC: log in with the "F11" button, confirm loading the program (see following figure), run the program with the "F5" button
Confirming program start


Restoring the delivery state

Commissioning/Configuration [image] Restoring the delivery state
Restoring the delivery state
To restore the delivery state for backup objects in ELxxxx terminals / EPxxxx- and EPPxxxx boxes, the CoE object Restore default parameters, SubIndex 001 can be selected in the TwinCAT System Manager (Config mode).
Selecting the Restore default parameters PDO
Double-click on SubIndex 001 to enter the Set Value dialog. Enter the value 1684107116 in field Dec or the value 0x64616F6C in field Hex and confirm with OK.
All backup objects are reset to the delivery state.
Entering a restore value in the Set Value dialog
Alternative restore value
In some older terminals / boxes the backup objects can be switched with an alternative restore value:
Decimal value: 1819238756
Hexadecimal value: 0x6C6F6164
An incorrect entry for the restore value has no effect.


Appendix

Appendix
Appendix
Additional information
•
General operating conditions
•
Accessories
•
Version identification of EtherCAT devices
•
Support and Service


General operating conditions

Appendix [image] General operating conditions
General operating conditions
Protection degrees (IP-Code)
The standard IEC 60529 (DIN EN 60529) defines the degrees of protection in different classes.
1. Number: dust protection and touch guard | Definition
0 | Non-protected
1 | Protected against access to hazardous parts with the back of a hand. Protected against solid foreign objects of Ø 50 mm
2 | Protected against access to hazardous parts with a finger. Protected against solid foreign objects of Ø 12.5 mm.
3 | Protected against access to hazardous parts with a tool. Protected against solid foreign objects Ø 2.5 mm.
4 | Protected against access to hazardous parts with a wire. Protected against solid foreign objects Ø 1 mm.
5 | Protected against access to hazardous parts with a wire. Dust-protected. Intrusion of dust is not totally prevented, but dust shall not penetrate in a quantity to interfere with satisfactory operation of the device or to impair safety.
6 | Protected against access to hazardous parts with a wire. Dust-tight. No intrusion of dust.
2. Number: water* protection | Definition
0 | Non-protected
1 | Protected against water drops
2 | Protected against water drops when enclosure tilted up to 15°.
3 | Protected against spraying water. Water sprayed at an angle up to 60° on either side of the vertical shall have no harmful effects.
4 | Protected against splashing water. Water splashed against the disclosure from any direction shall have no harmful effects
5 | Protected against water jets
6 | Protected against powerful water jets
7 | Protected against the effects of temporary immersion in water. Intrusion of water in quantities causing harmful effects shall not be possible when the enclosure is temporarily immersed in water for 30 min. in 1 m depth.
*) These protection classes define only protection against water!
Chemical Resistance
The Resistance relates to the Housing of the IP 67 modules and the used metal parts. In the table below you will find some typical resistance.
Character | Resistance
Steam | at temperatures >100°C: not resistant
Sodium base liquor (ph-Value > 12) | at room temperature: resistant > 40°C: not resistant
Acetic acid | not resistant
Argon (technical clean) | resistant
Key
▪
resistant: Lifetime several months
▪
non inherently resistant: Lifetime several weeks
▪
not resistant: Lifetime several hours resp. early decomposition


Accessories

Appendix [image] Accessories
Accessories
Mounting
Ordering information | Description
ZS5300-0001 | Mounting rail (500 mm x 129 mm)
Cables
Ordering information | Description
ZK1090-3xxx-xxxx | EtherCAT cable M8, green link to the website
ZK1093-3xxx-xxxx | EtherCAT cable M8, yellow link to the website
ZK2000-5xxx-xxxx ZK2000-71xx-xxxx | Sensor cable M12 5-wire Link to website
ZK2000-6xxx-xxxx | Sensor cable M12 4-wire Link to website
A complete overview of pre-assembled cables for EtherCAT Box modules can be found here.
Labeling material, protective caps
Ordering information | Description
ZS5000-0010 | Protective cap for M8 sockets, IP67 (50 pieces)
ZS5000-0020 | Protective cap M12, IP67 (50 pieces)
ZS5100-0000 | Inscription labels, unprinted, 4 strips of 10
ZS5000-xxxx | Printed inscription labels on enquiry
Tools
Ordering information | Description
ZB8801-0000 | Torque wrench for plugs, 0.4…1.0 Nm
ZB8801-0001 | Torque cable key for M8 / wrench size 9 for ZB8801-0000
ZB8801-0002 | Torque cable key for M12 / wrench size 13 for ZB8801-0000
ZB8801-0003 | Torque cable key for M12 field assembly / wrench size 18 for ZB8801-0000
Further accessories
Further accessories can be found in the price list for fieldbus components from Beckhoff and online at https://www.beckhoff.com.


Version identification of EtherCAT devices

Appendix [image] Version identification of EtherCAT devices
Version identification of EtherCAT devices
Designation
A Beckhoff EtherCAT device has a 14-digit designation, made up of
▪
family key
▪
type
▪
version
▪
revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
Notes
▪
The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
▪
EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
▪
The order identifier is made up of
- family key (EL, EP, CU, ES, KL, CX, etc.)
- type (3314)
- version (-0000)
▪
The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
▪
The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Identification number
Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:
Production lot/batch number/serial number/date code/D number
The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02
Exceptions can occur in the IP67 area, where the following syntax can be used (see respective device documentation):
Syntax: D ww yy x y z u
D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB
Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1
Unique serial number/ID, ID number
In addition, in some series each individual module has its own unique serial number.
See also the further documentation in the area
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Terminals with factory calibration certificate and other measuring terminals
Examples of markings
EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
CU2016 switch with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
EP1258-00001 IP67 EtherCAT Box with batch number/ date code 22090101 and unique serial number 158102
EP1908-0002 IP67 EtherCAT Safety Box with batch number/ date code 071201FF and unique serial number 00346070
EL2904 IP20 safety terminal with batch number/ date code 50110302 and unique serial number 00331701
ELM3604-0002 terminal with unique ID number (QR code) 100001051 and serial/ batch number 44160201
Additional information
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Appendix [image] Version identification of EtherCAT devices [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com