EP3204-0002 & EP3314-0002 - EtherCAT Box for Pt100 (RTD) and for thermocouples
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
2.3
▪
Chapter „EP3314 – Settings“ added
▪
Structure update
2.2
▪
Object descriptions corrected
▪
Structure update
2.1.0
▪
Chapter EP3204 – Data stream and calculation of the process data added
▪
Update of chapter Mounting and connection
▪
Correction technical data in chapter Power cables
▪
Structural update
2.0.1
▪
EP3204-0002 - Technical data updated
2.0.0
▪
Migration
▪
Structure update
1.2.0
▪
EP3204 - object description and parameterization updated
▪
EP3314 - object description and parameterization updated
▪
Foreword updated
▪
Technical data updated
1.1.0
▪
Power Connection updated
1.0.0
▪
ATEX notes added
▪
Technical data updated
▪
Extended temperature range for activated modules documented
▪
Overview of EtherCAT cables extended
▪
Description of the power connection updated
▪
Description of the status LEDs for the power supply added
0.6
▪
Object descriptions corrected
0.5
▪
First preliminary version
Firmware and hardware versions
This documentation refers to the firmware and hardware version that was applicable at the time the documentation was written.
The module features are continuously improved and developed further. Modules having earlier production statuses cannot have the same properties as modules with the latest status. However, existing properties are retained and are not changed, so that older modules can always be replaced with new ones.
Documentation Version | EP3204-0002 |  | EP3314-0002
 | Firmware | Hardware | Firmware | Hardware
2.3 | 07 | 19 | 06 | 16
2.2 | 07 | 17 | 06 | 16
2.1.0 | 07 | 13 | 06 | 14
2.0.1 | 07 | 10 | 05 | 11
2.0.0 | 07 | 10 | 05 | 11
1.2.0 | 05 | 08 | 05 | 09
1.1.0 | 05 | 08 | 05 | 09
1.0.0 | 05 | 05 | 02 | 05
0.6 | 03 | 01 | 01 | 01
0.5 | 03 | 01 | 01 | 01
The firmware and hardware version (delivery state) can be found in the batch number (D-number) printed on the side of the EtherCAT Box.
Syntax of the batch number (D-number)
D: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with D no. 29 10 02 01:
29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01
Further information on this topic: Version identification of EtherCAT devices.


EtherCAT Box

EtherCAT Box
EtherCAT Box
Additional information
•
EtherCAT Box - Introduction
•
Module overview


EtherCAT Box - Introduction

EtherCAT Box [image] EtherCAT Box - Introduction
EtherCAT Box - Introduction
The EtherCAT system has been extended with EtherCAT Box modules with protection class IP 67. Through the integrated EtherCAT interface the modules can be connected directly to an EtherCAT network without an additional Coupler Box. The high-performance of EtherCAT is thus maintained into each module.
The extremely low dimensions of only 126 x 30 x 26.5 mm (h x w x d) are identical to those of the Fieldbus Box extension modules. They are thus particularly suitable for use where space is at a premium. The small mass of the EtherCAT modules facilitates applications with mobile I/O interface (e.g. on a robot arm). The EtherCAT connection is established via screened M8 connectors.
EtherCAT Box Modules within an EtherCAT network
The robust design of the EtherCAT Box modules enables them to be used directly at the machine. Control cabinets and terminal boxes are now no longer required. The modules are fully sealed and therefore ideally prepared for wet, dirty or dusty conditions.
Pre-assembled cables significantly simplify EtherCAT and signal wiring. Very few wiring errors are made, so that commissioning is optimized. In addition to pre-assembled EtherCAT, power and sensor cables, field-configurable connectors and cables are available for maximum flexibility. Depending on the application, the sensors and actuators are connected through M8 or M12 connectors.
The EtherCAT modules cover the typical range of requirements for I/O signals with protection class IP67:
▪
digital inputs with different filters (3.0 ms or 10 μs)
▪
digital outputs with 0.5 or 2 A output current
▪
analog inputs and outputs with 16 bit resolution
▪
Thermocouple and RTD inputs
▪
Stepper motor modules
XFC (eXtreme Fast Control Technology) modules, including inputs with time stamp, are also available.
EtherCAT Box with M8 connections for sensors/actuators
EtherCAT Box with M12 connections for sensors/actuators
Basic EtherCAT documentation
You will find a detailed description of the EtherCAT system in the Basic System Documentation for EtherCAT, which is available for download from our website (www.beckhoff.com) under Downloads.
EtherCAT XML Device Description
You will find XML files (XML Device Description Files) for Beckhoff EtherCAT modules on our website (www.beckhoff.com) under Downloads, in the Configuration Files area.


Module overview

EtherCAT Box [image] Module overview
Module overview
Analog input modules, 24 VDC
Module | Number of inputs | Signal connection | Comment
EP3204-0002 | 4 | M12 | Pt100 (RTD)
EP3314-0002 | 4 | M12 | Thermocouples


EP3204

EP3204
EP3204
Additional information
•
Introduction
•
Technical data
•
Process image
•
Scope of supply


Introduction

EP3204 [image] Introduction
Introduction
EP3204-0002
EtherCAT Box with four analog inputs for PT100 (RTD)
The EP3204 EtherCAT Box with analog inputs enables direct connection of resistance sensors. The module circuit can operate sensors with 2-, 3- and 4-wire technology. Linearisation over the full temperature range is realized with the aid of a microprocessor. The temperature range can be selected freely. The module can also be used for simple resistance measurement, with the output in ohms. The module's standard settings are: Resolution 0.1°C in the temperature range of PT100 sensors in 4-wire connection. Sensor malfunctions such as broken wires are indicated by error LEDs.
The module is quite versatile, but the default values are selected in such a way that in most cases it is not necessary to perform configuration. The input filter and associated conversion times can be set within a wide range, and several data output formats may be chosen. The inputs can, if required, be scaled differently, and automatic limit monitoring is also available. EtherCAT is used for parameterization purposes.
Quick links


Technical data

EP3204 [image] Technical data
Technical data
All values are typical values over the entire temperature range, unless stated otherwise.
Technical data
EP3204-0002
Fieldbus
Fieldbus
EtherCAT
Connection
2x M8 socket, 4-pin, green
Electrical isolation
500 V (fieldbus / IO)
Supply voltages
Connection
Input: 1 x M8 plug, 4-pin, black
Downstream connection: 1 x M8 socket, 4-pin, black
Control voltage US
Nominal voltage
24 VDC (-15 % / +20 %)
Sum current
max. 4 A 1)
Current consumption from US
120 mA
Peripheral voltage UP
Nominal voltage
24 VDC (-15 % / +20 %)
Sum current
max. 4 A 1)
Current consumption from UP
None. UP is only forwarded.
RTD inputs
Number
4
Connector
4 x M12 socket
Sensor types
▪
Platinum RTD: Pt100, Pt200, Pt500, Pt1000
▪
Nickel RTD: Ni100, Ni120, Ni1000
▪
Resistance/potentiometer up to 4095 Ω
Connection technology
▪
2-wire connection
▪
3-wire connection
▪
4-wire connection
Electrical isolation
The measuring channels have a common isolated ground potential.
Measuring current RL+, RL-
Max. 0.5 mA, load-dependent
Measuring range
Platinum RTD: -200 .. +850 °C
Nickel RTD: -60 .. +250 °C (Ni120: -60 .. +320 °C)
Resistance: 0 .. 4095 Ω
Measuring error
Max. ±0.5 K (Pt sensors in 4-wire connection)
Digital resolution
16-bit
Value of an LSB
Temperature measurement:
Standard: 0.1 °C
High-precision: 0.01 °C
Resistance measurement:
Measuring range 1023 Ω: 1/64 Ω
Measuring range 4095 Ω: 1/16 Ω
Filter
Digital filter. Cut-off frequency parameterizable: 5 Hz .. 30 kHz.
Conversion time
2 .. 800 ms, depending on the parameterization.
Default: approx. 85 ms
Diagnostics
▪
Open-circuit recognition
▪
Limit value monitoring
1) This value corresponds to the current carrying capacity of the connections for the supply voltages.
Technical data | EP3204-0002
Mechanics
Installation position | variable
Weight | approx. 165 g
Environmental conditions
Ambient temperature during operation | -25…+60 °C -25…+55 °C according to cURus 0…+55 °C according to ATEX
Ambient temperature during storage | -40…+85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27; see also Additional checks.
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 conforms to EN 60529
Approvals and conformity
Approvals | CE, cURus, ATEX
Additional checks
The boxes have been subjected to the following checks:
Verification | Explanation
Vibration | 10 frequency sweeps in 3 axes
 | 5 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 35 g, 11 ms


Process image

EP3204 [image] Process image
Process image
RTD RTDInputs Channel 1
The data for the first analog channel can be found under RTD RTDInputs Channel 1.
AI Standard Channel 2 to 4
The data of analog channels 2 to 4 have the same structure as those of the 1st channel.


Scope of supply

EP3204 [image] Scope of supply
Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EtherCAT Box EP3204-0002
▪
1x protective cap for supply voltage input, M8, transparent (pre-assembled)
▪
1x protective cap for supply voltage output, M8, black (pre-assembled)
▪
2x protective cap for EtherCAT socket, M8, green (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


EP3314

EP3314
EP3314
Additional information
•
Introduction
•
Technical data
•
Process image
•
Scope of supply
•
Basics of thermocouple technology


Introduction

EP3314 [image] Introduction
Introduction
EP3314-0002
EtherCAT Box with four analog inputs for thermocouples
The EP3314 EtherCAT Box with analog inputs enables direct connection of four thermocouples. The module circuit can operate thermocouple sensors in a 2-wire configuration. Linearisation over the full temperature range is realized with the aid of a microprocessor. The temperature range can be selected freely. The error LEDs indicate a broken wire. Compensation for the cold junction is made through a temperature measurement in the connecting plugs. This means that standard extension leads can be connected. The EP3314 also enables millivolt measurement.
The module is quite versatile, but the default values are selected in such a way that in most cases it is not necessary to perform configuration. The input filter and associated conversion times can be set within a wide range, and several data output formats may be chosen. The inputs can, if required, be scaled differently, and automatic limit monitoring is also available. EtherCAT is used for parameterization purposes. The parameters are stored in the module. For temperature compensation a PT1000 element is required. Beckhoff offers a plug connector with temperature compensation (ZS2000-3712).
Quick links


Technical data

EP3314 [image] Technical data
Technical data
All values are typical values over the entire temperature range, unless stated otherwise.
Technical data
EP3314-0002
Fieldbus
Fieldbus
EtherCAT
Connection
2x M8 socket, 4-pin, green
Electrical isolation
500 V (fieldbus / IO)
Supply voltages
Connection
Input: 1 x M8 plug, 4-pin, black
Downstream connection: 1 x M8 socket, 4-pin, black
Control voltage US
Nominal voltage
24 VDC (-15 % / +20 %)
Sum current
max. 4 A 1)
Current consumption from US
120 mA
Peripheral voltage UP
Nominal voltage
24 VDC (-15 % / +20 %)
Sum current
max. 4 A 1)
Current consumption from UP
None. UP is only forwarded.
Thermocouple inputs
Number
4
Connector
4 x M12 socket
Cable length to thermocouple
max. 30 m
Sensor types
▪
Thermocouples
▪
Sensors with a voltage output of up to ±75 mV
Electrical isolation
The measuring channels have a common isolated ground potential.
Measuring ranges
Thermocouples: depending on type.
Voltage measurement: ±30 mV, ±60 mV, ±75 mV
Measuring error
Thermocouple type K: max. ±0.3 %,
relative to the full scale value
Digital resolution
16-bit
Value of an LSB
Thermocouple: 0.1 °C
Voltage measurement:
Measuring range 30 mV: 1 µV
Measuring range 60 mV: 2 µV
Measuring range 75 mV: 4 µV
Filter
Digital filter. Filter frequency adjustable from 5 Hz … 30 kHz
Conversion time
approx. 2.5 s to 20 ms, depending on configuration and filter setting.
Default: approx. 250 ms
Diagnostics
▪
Open-circuit recognition
▪
Limit value monitoring
1) This value corresponds to the current carrying capacity of the connections for the supply voltages.
Technical data | EP3314-0002
Mechanics
Dimensions | approx. 126 x 30 x 26.5 mm (without connectors)
Weight | approx. 165 g
Installation position | variable
Environmental conditions
Ambient temperature during operation | -25…+60 °C -25…+55 °C according to cURus 0…+55 °C according to ATEX
Ambient temperature during storage | -40…+85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27; see also Additional checks.
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 conforms to EN 60529
Approvals and conformity
Approvals | CE, cURus, ATEX
Additional checks
The boxes have been subjected to the following checks:
Verification | Explanation
Vibration | 10 frequency sweeps in 3 axes
 | 5 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 35 g, 11 ms
Overview of suitable thermocouples
The following thermocouples are suitable for temperature measurement:
Type (according to EN60584-1) | Element | Implemented temperature range | Color coding (sheath - plus pole - minus pole)
B | Pt30%Rh-Pt6Rh | 600°C to 1800°C | grey - grey - white
C * | W5%Re-W25%Re | 0°C to 2320°C | n.d.
E | NiCr-CuNi | -100°C to 1000°C | violet - violet - white
J | Fe-CuNi | -100°C to 1200°C | black - black - white
K | NiCr-Ni | -200°C to 1370°C | green - green - white
L ** | Fe-CuNi | 0°C to 900°C | blue - red - blue
N | NiCrSi-NiSi | -100°C to 1300°C | pink - pink - white
R | Pt13%Rh-Pt | 0°C to 1767°C | orange - orange - white
S | Pt10%Rh-Pt | 0°C to 1760°C | orange - orange - white
T | Cu-CuNi | -200°C to 400°C | brown - brown - white
U ** | Cu-CuNi | 0°C to 600°C | brown - red - brown
* not standardized according to EN60584-1
** according to DIN 43710


Process image

EP3314 [image] Process image
Process image
Process image
TC Inputs Channel 1
EPP3314-0002 Prozessabbild - TC Inputs Channel 1
▪
TC3 InputVariable Symbol Underrange
Measurement is below range
▪
TC3 InputVariable Symbol Overrange
Measuring range exceeded
▪
TC3 InputVariable Symbol Limit 1
Status variable of the limit value monitoring
0: The limit value monitoring is disabled
1: The measured value is smaller than the limit value
2: The measured value is greater than the limit value
3: The measured value is exactly the same size as the limit value
▪
TC3 InputVariable Symbol Limit 2
Status variable of the limit value monitoring
▪
TC3 InputVariable Symbol Error
The current measured value "Value" is invalid.
Possible reasons: Wire breakage, Underrange, Overrange
▪
TC3 InputVariable Symbol TxPDO State
If this bit is TRUE, the current measured value "Value" is invalid.
▪
TC3 InputVariable Symbol TxPDO Toggle
The box inverts this bit every time it updates the measured value "Value" in the process data.
This allows the currently required conversion time to be derived.
TC3 InputVariable Symbol Value
The current measured value. Unit: 1/10 °C.
TC Inputs Channel 2 bis 4
The process data objects of channels 2…4 have exactly the same structure as those of channel 1.


Scope of supply

EP3314 [image] Scope of supply
Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EtherCAT Box EP3314-0002
▪
1x protective cap for supply voltage input, M8, transparent (pre-assembled)
▪
1x protective cap for supply voltage output, M8, black (pre-assembled)
▪
2x protective cap for EtherCAT socket, M8, green (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


Basics of thermocouple technology

EP3314 [image] Basics of thermocouple technology
Basics of thermocouple technology
Thermocouples are temperature sensors. The application areas of thermocouples are very diverse due to their low cost, fast detection of temperature differences, wide temperature ranges, high temperature limits and availability in a wide range of types and sizes.
Measuring principle and configuration
Temperature measurement with a thermocouple is based on the Seebeck effect, which was discovered in the 1820s by the German physicist Thomas Johann Seebeck. The Seebeck effect, also known as thermoelectric effect, describes a charge shift in a conductive material due to a temperature gradient along the conductor. The magnitude of the charge shift depends on the magnitude of the temperature difference and the respective conductor material.
In thermocouples this charge shift is used to generate a voltage. Two different conductor materials are connected at one end. This is the measuring point at which the temperature is to be determined. At the other end the conductors are not connected. This open end, where the transition to the measuring electronics is located, is the cold junction. A temperature difference occurs between the cold junction and the measuring point, which can be measured via the voltage between the conductors at the open end. The voltage depends on the conductor materials used and the temperature difference. It is in the range of a few mV.
Structure and principle of a thermocouple
If only one material were used for a thermocouple, the charge shift in both conductors would be identical, so that no potential difference between the two conductors at the open end could be measured.
The temperature measurement with thermocouples is therefore actually a voltage measurement, based on which a temperature can be determined from the known characteristic curve. In addition, the measuring procedure is not absolute but differential, since no absolute temperature (with the reference point 0 °C) is determined, but the temperature difference between the measuring point and the cold junction.
For the evaluation of thermocouples, measuring electronics are required that can evaluate small voltages in the mV range with sufficiently high resolution and accuracy. Thermocouples are active sensors, which means that no sensor supply is required to measure the temperature.
Thermocouple types
There are different types of thermocouples, which consist of different combinations of conductor materials. Each material combination has specific properties and is suitable for certain applications. The different thermocouple types are distinguished by letters.
Due to the different material combinations, the different thermocouple types have different characteristic values. They differ in the temperature limits and the characteristic voltage/temperature curve. In order to be able to differentiate between the thermocouple types, the color codes for the sheath, the positive pole and the negative pole are defined in various standards.
The following table shows common thermocouple types with the specification of the materials used, the defined temperature ranges and the color coding.
Type (conforms to EN60584-1) | Element | Measuring range * |  | Average temperature coefficient | Voltage at FSV | Color coding (sheath - plus pole - minus pole)
 |  | min | max
B | Pt30%Rh-Pt6Rh | 600 °C | 1820 °C | 6 µV/K | 13.820 mV | grey - grey - white
C ** | W5%Re-W25%Re | -18 °C | 2316 °C | 15 µV/K | 37.070 mV | n.d.
E | NiCr-CuNi | -270 °C | 1000 °C | 65 µV/K | 76.373 mV | violet - violet - white
J | Fe-CuNi | -210 °C | 1200 °C | 54 µV/K | 69.553 mV | black - black - white
K | NiCr-Ni | -270 °C | 1372 °C | 42 µV/K | 54.886 mV | green - green - white
L *** | Fe-CuNi | -200 °C | 900 °C | 54 µV/K | 53.140 mV | blue - red - blue
N | NiCrSi-NiSi | -270 °C | 1300 °C | 27 µV/K | 47.513 mV | pink - pink - white
R | Pt13%Rh-Pt | -50 °C | 1768 °C | 10 µV/K | 21.101 mV | orange - orange - white
S | Pt10%Rh-Pt | -50 °C | 1768 °C | 10 µV/K | 18.693 mV | orange - orange - white
T | Cu-CuNi | -270 °C | 400 °C | 40 µV/K | 20.872 mV | brown - brown - white
U *** | Cu-CuNi | -200 °C | 600 °C | 40 µV/K | 34.310 mV | brown - red - brown
*The specified measuring range refers to the maximum possible measuring range of the specified thermocouple type. The possible measuring range with the thermocouple terminals may be limited. The specification of the possible measuring range of the thermocouple terminals can be taken from the technical data in the documentation.
**not standardized according to EN60584-1
***conforms to DIN 43710
The thermocouple must be selected according to the operating conditions. Therefore, not only the uncertainty must be taken into account, but also the other properties of the different thermocouple types. For an application with small temperature fluctuations, it is advantageous to select a thermocouple type with a high thermovoltage per temperature change. In an application where the temperature to be measured is very high, it is important to observe the maximum operating temperature.
Characteristic curve
Type-specific reference tables are available for determining the temperature difference to a measured thermovoltage. A simple conversion of the voltage into a temperature with a temperature coefficient, as is often approximated in resistance thermometers, is not possible because the relationship between voltage and temperature is clearly non-linear over the entire measuring range. The changing temperature coefficient results in a non-linear characteristic voltage/temperature curve. This characteristic curve is in turn dependent on the thermocouple type, so that each type has its own non-linear characteristic voltage/temperature curve. As an example, the characteristic curves for typical thermocouple types are shown in the following diagram. The non-linearity is particularly evident in the temperature range below 0 °C.
Characteristic voltage/temperature curves of different thermocouple types
Thermocouples are subject to unavoidable and irreversible changes during practical application, which leads to ever-increasing measurement uncertainties over time. In other words: the measurement becomes more and more incorrect over time. These changes are also referred to as aging and depend on various influencing factors. Examples of these influences are mechanical and chemical stresses on the thermocouples. Mechanical stresses are deformations of the conductors, which change the crystal structure of the metals. This leads to incorrect thermovoltages. Chemical stresses are also changes in the crystal structure of the metals or oxidation, which change the thermal properties of the conductors, resulting in a change in the characteristic curve. This influence can be reduced by installation in gas-tight protection tubes.
Pluggable connections
Open wire ends or suitable thermocouple connectors can be used to connect thermocouples to measuring devices and evaluation electronics or to connect a thermocouple to thermo or compensating cables.
Ideally, the contacts of such a thermocouple connector are made of the material of the respective thermocouple. This results in a thermovoltage-free transition at the connection points. The plugs are color-coded depending on the type, e.g. type K is green. Labelling on the housing and different contact shapes are intended to avoid polarity reversal.
Verlängerungen und Anschluss von Thermoelementen.png
There are several common sizes: standard, mini, micro.
A special feature is the white connector, which is designed with normal copper contacts, almost like a normal non-TC connector. This makes it universally applicable for all TC types, although it has the disadvantage that it does not create a thermovoltage-free transition. Far more common than the white plug is the white "universal" socket on the measuring device. This allows any TC plug to be plugged into the device. The measuring device must then determine the cold junction temperature in this plug transition.
Extensions and connection of thermocouples
In some cases it is useful to extend the thermocouple and thus to move the cold junction to a particular location, where the temperature can be kept constant or measured by simple means. For this purpose the thermocouple must be extended. This can be done with a thermo or compensation wire. Thermo cables are made of the same material as the thermocouple itself. Compensating cables, on the other hand, are usually made of cheaper materials with similar thermal properties. Both types are therefore suitable for extending a thermocouple to a remote cold junction. With compensating cables, care must be taken to ensure that the material used has similar thermal properties but not identical properties. The thermal properties only apply in a narrowly limited temperature range. At the transition from thermocouple to compensation wire, another thermocouple is created. This results in small thermovoltage distortions, which influence the measurement result. If the compensating cables are used outside the specified temperature range, the accuracy of the temperature measurement will be further affected and the measurement result will deteriorate.
Sensor circuit
Changing the sensor circuit through additional elements such as selector switches or multiplexers can affect the measuring accuracy. In such switches, small local thermovoltages can be generated which distort the measurement. If such components cannot be avoided in the application, their influence should be carefully examined.
Maximum cable length to the thermocouple
Without additional protective measures, the maximum cable length from the measuring module (terminal, box) to the thermocouple is 30 m. For longer cable lengths, suitable surge protection should be provided.
Determination of the absolute temperature
Temperature measurement with a thermocouple is a differential temperature measurement, in which the temperature difference between the measuring point and the reference junction, also known as cold junction, is determined. To determine the absolute temperature at the measuring point, the measured thermovoltage must therefore be corrected by the thermovoltage at the cold junction. With the corrected thermovoltage, the temperature at the measuring point can then be determined from suitable tables or characteristic curves. Due to the non-linearity of the characteristic curve, it is imperative that this calculation is carried out with the voltages and not with the temperature. Otherwise, there would be a significant error in the measurement.
In general, the absolute temperature is calculated using the following relationship:
Umeasuring point = Uthermo + Ucold junction
Tmeasuring point = f(Umeasuring point)
In the following section, the absolute temperature is determined as an example based on correction of the thermovoltages and the temperature. The example calculation can be used to illustrate the error resulting from incorrect correction.
Sought: Tmeasuring point
Known: Thermocouple type K, Uthermo = 24.255 mV, Tcold junction = 22 °C
Option 1: Correction of thermovoltages – CORRECT
The thermovoltage at the cold junction Ucold junction must be determined based on the known temperature Tcold junction from the characteristic voltage/temperature curve or table for thermocouple type K:
Ucold junction = U(22 °C) = 0.879 mV
The thermovoltage at the measuring point can then be determined with reference to 0 °C:
Umeasuring point = Uthermo + Ucold junction = 24.255 mV + 0.879 mV = 25.134 mV
The corresponding temperature value can then be determined for thermocouple type K based on the determined thermovoltage from the characteristic voltage/temperature curve or table:
Tmeasuring point = T(25.134 mV) ≈ 605.5 °C
Option 2: Temperature correction – WRONG
In principle, the temperature difference between the cold junction and the measuring point Tthermo could be determined based on the known thermovoltage Uthermo from the characteristic voltage/temperature curve or table for thermocouple type K:
Tthermo = T(24.255 mV) = 585 °C
The temperature of the measuring point could then be determined with reference to 0 °C:
Tmeasuring point = Tthermo + Tcold junction = 585 °C + 22 °C = 607 °C
Note that there is a temperature difference of 1.5 °C between the value with the proper correction (voltage correction, option 1) and the value with the incorrect correction (temperature correction, option 2).
Cold junction compensation / CJC
The correction of the thermovoltage value to determine the absolute temperature value is referred to as cold junction compensation. In order to determine an absolute temperature value that is as accurate as possible, the temperature at the cold junction must either be kept constant at a known value or measured continuously during the measurement with the smallest possible uncertainty. In some applications, the cold junction may be in an ice bath (0 °C), for example. In this case the temperature determined via the thermovoltage corresponds to both the temperature difference and the absolute temperature. In many applications, however, this option cannot be implemented, so that cold junction compensation is necessary.
As a cold junction in thermocouple evaluation with Bus Terminals, the cold junction temperature is measured at the transition from the thermocouple to the copper contacts. This value is measured continuously during operation in order to correct the determined values internally.
Evaluation of thermocouples with thermocouple terminals
Beckhoff thermocouple modules (terminals, box) can evaluate thermocouples of different types. Linearization of the characteristic curves and determination of the reference temperature takes place directly in the module. The module can be fully configured via the Bus Coupler or the controller. Different output formats may be selected or own scaling activated. Linearization of the characteristic curve and determination and calculation of the reference temperature (temperature at the connection contacts of the module) can be deactivated, so the module can be used as a [mV] measuring device or with an external cold junction. In addition to the internal evaluation of the measured voltage for conversion into a temperature, the raw voltage value can be transferred from the terminal to the control system for further processing.
Temperature measurement with thermocouples generally comprises three steps:
▪
Measuring the electrical voltage
▪
Optional: Temperature measurement of the internal cold junction
▪
Software-based conversion of the voltage into a temperature value according to the set TC type (K, J, …)
All three steps can take place locally in the Beckhoff measuring module. Module-based transformation can be disabled if the conversion is to take place in the higher-level control system. Depending on the module type, several TC conversions are available, which differ in terms of their software implementation.
Uncertainties in the evaluation of thermocouples with thermocouple terminals
The TC measurement consists of a chain of measuring and computing elements that affect the attainable measurement deviation:
Concatenation of the uncertainties in temperature measurement with thermocouples
When measuring a temperature, there are various factors influencing the accuracy, from which the total inaccuracy (total uncertainty) is then derived.
Uncertainty of the voltage measurement
First and foremost, measuring a temperature with thermocouples is not based on an actual temperature measurement, but a voltage measurement with subsequent conversion into a temperature. The accuracy of the voltage measurement is therefore the basis for the accuracy of the temperature determination. Since a change of 1 °C at the sensor causes a change in the single-digit µV range, depending on the thermocouple type, even a small uncertainty of the voltage measurement has a large influence on the final result.
Uncertainty of the temperature conversion
The conversion of the measured voltage into a temperature is carried out during evaluation either by means of value tables from the characteristic voltage/temperature curve of a thermocouple type or by approximation based on a polynomial. Due to the non-linearity of the characteristic voltage/temperature curve, both options are only approximations of the actual values, so that the conversion results in a further (small) mathematical uncertainty component.
Uncertainty of the cold junction evaluation
Cold junction compensation in thermocouple terminals must be carried out at the transition from the thermocouple to the copper contacts of the electronics. However, in many cases the temperature at this point cannot be measured directly for mechanical reasons. In this case the temperature of the cold junction has to be approximated at a distance of a few millimeters or through an average value of the housing temperatures. Since the exact value cannot be determined in this way, this results in further uncertainty.
Uncertainty of the sensor
The three factors influencing the uncertainty referred to above relate to the uncertainties in the evaluation of the thermocouples. The accuracy of the thermocouple itself is another factor and must also be taken into account.
Since temperature measurement with thermocouples is actually a voltage measurement and the thermocouples have a non-linear characteristic voltage/temperature curve, it is not possible to simply add up the individual temperature uncertainties to obtain the total uncertainty. To calculate the total uncertainty, all temperature values must be converted into the corresponding voltage value of the respective thermocouple type. When the temperatures are added together an error occurs, as described in the example in the chapter on "Determination of the absolute temperature".
The following diagram shows an example of an analysis of the uncertainties associated with the evaluation of a thermocouple for an EL331x thermocouple terminal with internal cold junction compensation and conversion of the voltage into a temperature via a second degree polynomial. The diagram does not take into account the uncertainty of the thermocouple itself, which is an additional factor.
Example for an uncertainty analysis of the evaluation of thermocouples with thermocouple terminals
It is clear from the diagram that the uncertainty of the measured temperature depends on the temperature to be measured. Especially in the lower temperature range, where there is a strong non-linearity of voltage and temperature, the uncertainty of the temperature measurement increases significantly.
Beckhoff offers several products for the evaluation of thermocouples, including
▪
EL331x: EtherCAT input terminals with 1-8 channels
▪
EL3314-0002: high-precision EtherCAT input terminal, electrically isolated
▪
EL3314-0010: high-precision EtherCAT input terminal
▪
EL3314-0030: high-precision EtherCAT input terminal, with external calibration certificate
▪
EL3314-0090: EtherCAT input terminal, TwinSAFE SC
▪
ELM370x-xxxx: EtherCAT measurement technology series, multi-functional input, 24 bit, 10 ksps
▪
ELM334x: EtherCAT measurement technology series, thermocouple input, miniature TC connector
▪
EP3314, EPP3314: EtherCAT IP67 Box
▪
KL331x: K-bus input terminals with 1-4 channels
▪
EJ3318: EtherCAT plug-in module
The current overview can be found at www.beckhoff.de


Mounting and connection

Mounting and connection
Mounting and connection
Additional information
•
Mounting
•
Connection
•
UL Requirements
•
ATEX notes


Mounting

Mounting and connection [image] Mounting
Mounting
Additional information
•
Dimensions
•
Fixing
•
Tightening torques for plug connectors


Dimensions

Mounting and connection [image] Mounting [image] Dimensions
Dimensions
Dimensions
All dimensions are given in millimeters.
Housing features
Housing material | PA6 (polyamide)
Sealing compound | polyurethane
Mounting | two fastening holes Ø 3.5 mm for M3
Metal parts | brass, nickel-plated
Contacts | CuZn, gold-plated
Power feed through | max. 4 A
Installation position | variable
Protection class | IP65, IP66, IP67 (conforms to EN 60529) when screwed together
Dimensions (H x W x D) | approx. 126 x 30 x 26.5 mm (without connectors)


Fixing

Mounting and connection [image] Mounting [image] Fixing
Fixing
Note
Dirt during assembly
Dirty connectors can lead to malfunctions. Protection class IP67 can only be guaranteed if all cables and connectors are connected.
•
Protect the plug connectors against dirt during the assembly.
Mount the module with two M3 screws on the fastening holes in the corners of the module. The fastening holes have no thread.


Tightening torques for plug connectors

Mounting and connection [image] Mounting [image] Tightening torques for plug connectors
Tightening torques for plug connectors
Screw connectors tight with a torque wrench. (e.g. ZB8801 from Beckhoff)
Connector diameter | Tightening torque
M8 | 0.4 Nm
M12 | 0.6 Nm


Connection

Mounting and connection [image] Connection
Connection
Additional information
•
Supply voltages
•
EtherCAT
•
Signal connection


Supply voltages

Mounting and connection [image] Connection [image] Supply voltages
Supply voltages
The EtherCAT Box is supplied with two supply voltages. The supply voltages are electrically isolated in the EtherCAT Box.
▪
Control voltage US
▪
Peripheral voltage UP
Redirection of the supply voltages
The IN and OUT power connections are bridged in the module (not IP204x-Bxxx and IE204x). The supply voltages US and UP can thus easily be transferred from EtherCAT Box to EtherCAT Box.
Note
Pay attention to the maximum permissible current!
Pay attention also for the redirection of the supply voltages US and UP, the maximum permissible current for M8 connectors of 4 A must not be exceeded!
Additional information
•
Connectors
•
Status LEDs
•
Conductor losses


Connectors

Mounting and connection [image] Connection [image] Supply voltages [image] Connectors
Connectors
Note
Risk of confusion: supply voltages and EtherCAT
Defect possible through incorrect insertion.
•
Observe the color coding of the connectors:
black: Supply voltages
green: EtherCAT
Connectors for supply voltages
M8 connector
Contact | Function | Description | Core color 1)
1 | US | Control voltage | Brown
2 | UP | Peripheral voltage | White
3 | GNDS | GND to US | Blue
4 | GNDP | GND to UP | Black
1) The core colors apply to cables of the type: Beckhoff ZK2020-3xxx-xxxx


Status LEDs

Mounting and connection [image] Connection [image] Supply voltages [image] Status LEDs
Status LEDs
Connectors + LEDs
Status LEDs for the supply voltages
LED | Display | Meaning
US (control voltage) | off | Supply voltage US is not present
 | green illuminated | Supply voltage US is present
UP (peripheral voltage) | off | Supply voltage UP is not present
 | green illuminated | Supply voltage UP is present


Conductor losses

Mounting and connection [image] Connection [image] Supply voltages [image] Conductor losses
Conductor losses
Take into account the voltage drop on the supply line when planning a system. Avoid the voltage drop being so high that the supply voltage at the box lies below the minimum nominal voltage.
Variations in the voltage of the power supply unit must also be taken into account.
Voltage drop on the supply line
Leitungsverluste M8 2A
Leitungsverluste M8 4A


EtherCAT

Mounting and connection [image] Connection [image] EtherCAT
EtherCAT
Additional information
•
Connectors
•
Status LEDs
•
Cables


Connectors

Mounting and connection [image] Connection [image] EtherCAT [image] Connectors
Connectors
Note
Risk of confusion: supply voltages and EtherCAT
Defect possible through incorrect insertion.
•
Observe the color coding of the connectors:
black: Supply voltages
green: EtherCAT
EtherCAT Box Modules have two green M8 sockets for the incoming and downstream EtherCAT connections.
EtherCAT connectors
Connection
M8 socket, 4-pin – connection
M8 socket
EtherCAT | M8 connector | Core colors
Signal | Contact | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 and old versions of ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | 1 | yellow1) | orange/white | white/orange
Tx - | 4 | orange1) | orange | orange
Rx + | 2 | white1) | blue/white | white/green
Rx - | 3 | blue1) | blue | green
Shield | Housing | Shield | Shield | Shield
1) Core colors according to EN 61918
Adaptation of core colors for cables ZB9030, ZB9032 and ZK1090-3xxxx-xxxx
For standardization, the core colors of the ZB9030, ZB9032 and ZK1090-3xxx-xxxx cables have been changed to the EN61918 core colors: yellow, orange, white, blue. So there are different color codes in circulation. The electrical properties of the cables have been retained when the core colors were changed.


Status LEDs

Mounting and connection [image] Connection [image] EtherCAT [image] Status LEDs
Status LEDs
EtherCAT status LEDs
L/A (Link/Act)
A green LED labelled "L/A" is located next to each EtherCAT socket. The LED indicates the communication state of the respective socket:
LED | Meaning
off | no connection to the connected EtherCAT device
lit | LINK: connection to the connected EtherCAT device
flashes | ACT: communication with the connected EtherCAT device
Run
Each EtherCAT slave has a green LED labelled "Run". The LED signals the status of the slave in the EtherCAT network:
LED | Meaning
off | Slave is in "Init" state
flashes uniformly | Slave is in "Pre-Operational“ state
flashes sporadically | Slave is in "Safe-Operational" state
lit | Slave is in "Operational" state
Description of the EtherCAT slave states


Cables

Mounting and connection [image] Connection [image] EtherCAT [image] Cables
Cables
For connecting EtherCAT devices only shielded Ethernet cables that meet the requirements of at least category 5 (CAT5) according to EN 50173 or ISO/IEC 11801 should be used.
EtherCAT uses four wires for signal transmission.
Thanks to automatic line detection ("Auto MDI-X"), both symmetrical (1:1) or cross-over cables can be used between Beckhoff EtherCAT.
Detailed recommendations for the cabling of EtherCAT devices


Signal connection

Mounting and connection [image] Connection [image] Signal connection
Signal connection
Additional information
•
EP3204: Pt100 (RTD)
•
EP3314: Thermocouples
•
Status LEDs at the signal connections


EP3204: Pt100 (RTD)

Mounting and connection [image] Connection [image] Signal connection [image] EP3204: Pt100 (RTD)
EP3204: Pt100 (RTD)
The advantage of four-wire technique is that the error resulting from the cable and contacts is included in the measurement and cancelled out. In the 3-wire technique, the line resistance to the resistance sensor is measured in one direction only, and is multiplied by two. This requires the outward and return lines to have approximately the same ohmic resistance. An error is present in the two-wire technique; temperature differences and cable cross-sections can make this error vary considerably.
Signal connection - PT100 (RTD)
Supply voltage
US - supplies the electronics for the fieldbus and for the sensor. It is electrically isolated from UP.
UP - Is not required for the function of the module, and does not have to be fed in.
Note
Redirection of the supply voltages
If you use UP to pass the power on, and you connect a module in which US and UP are not electrically isolated (e.g. any digital module) then the electrical isolation is removed by the downstream connection.


EP3314: Thermocouples

Mounting and connection [image] Connection [image] Signal connection [image] EP3314: Thermocouples
EP3314: Thermocouples
The temperature compensation is fed to the outside of the modules. This means that in the connector the temperature compensation is measured directly at the connection point. This allows the temperature to be measured with significantly better accuracy. Beckhoff offer a connector (ZS2000-3712) for this. The temperature compensation can also be carried out at a location other than the Fieldbus Box. You must then wire a PT1000 between pins 1 and 3. The longer the cables you choose to use, the larger is the measurement error caused by the length of the conductor, conductor losses and interference.
Signal connection - thermocouple
Supply voltage
US - supplies the electronics for the fieldbus and for the sensor. It is electrically isolated from UP.
UP - Is not required for the function of the module, and does not have to be fed in.
Note
Redirection of the supply voltages
If you use UP to pass the power on, and you connect a module in which US and UP are not electrically isolated (e.g. any digital module) then the electrical isolation is removed by the downstream connection.


Status LEDs at the signal connections

Mounting and connection [image] Connection [image] Signal connection [image] Status LEDs at the signal connections
Status LEDs at the signal connections
There is a green Run LED and a red Error LED for each channel.
Correct function is indicated if the green Run LED is on and the red Error is off.
Status LEDs at the signal connections
Connection
LED
Display
Meaning
M12 socket no. 1-4
R
left
off
No data transfer to the A/D converter
green
Data transfer to A/D converter
E
right
off
Function OK
red
Error:
▪
Broken wire or
▪
measured value outside measuring range or
▪
temperature compensation outside the valid range


UL Requirements

Mounting and connection [image] UL Requirements
UL Requirements
The installation of the EtherCAT Box Modules certified by UL has to meet the following requirements.
Supply voltage
SmallWarningYellow CAUTION
CAUTION!
This UL requirements are valid for all supply voltages of all marked EtherCAT Box Modules!
For the compliance of the UL requirements the EtherCAT Box Modules should only be supplied
•
by a 24 VDC supply voltage, supplied by an isolating source and protected by means of a fuse (in accordance with UL248), rated maximum 4 Amp, or
•
by a 24 VDC power source, that has to satisfy NEC class 2.
A NEC class 2 power supply shall not be connected in series or parallel with another (class 2) power source!
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, the EtherCAT Box Modules must not be connected to unlimited power sources!
Networks
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, EtherCAT Box Modules must not be connected to telecommunication networks!
Ambient temperature range
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, EtherCAT Box Modules has to be operated only at an ambient temperature range of 0 to 55°C!
Marking for UL
All EtherCAT Box Modules certified by UL (Underwriters Laboratories) are marked with the following label.
UL label


ATEX notes

Mounting and connection [image] ATEX notes
ATEX notes
Additional information
•
ATEX - Special conditions
•
BG2000 - EtherCAT Box protection enclosures
•
ATEX Documentation


ATEX - Special conditions

Mounting and connection [image] ATEX notes [image] ATEX - Special conditions
ATEX - Special conditions
SmallWarningYellow WARNING
Observe the special conditions for the intended use of EtherCAT Box modules in potentially explosive areas – directive 94/9/EU.
•
The certified components are to be installed with a BG2000-0000 or BG2000-0010 protection enclosure that guarantees a protection against mechanical hazards!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of 0 to 55°C for the use of EtherCAT Box modules in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0: 2006
▪
EN 60079-15: 2005
Marking
The EtherCAT Box modules certified for potentially explosive areas bear the following marking:
II 3 G Ex nA II T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
or
II 3 G Ex nA nC IIC T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
Batch number (D number)
The EtherCAT Box modules bear a batch number (D number) that is structured as follows:
D: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with batch number 29 10 02 01:
29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01


BG2000 - EtherCAT Box protection enclosures

Mounting and connection [image] ATEX notes [image] BG2000 - EtherCAT Box protection enclosures
BG2000 - EtherCAT Box protection enclosures
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the EtherCAT system into a safe, powered down state before starting installation, disassembly or wiring of the modules!
ATEX
SmallWarningYellow WARNING
Mount a protection enclosure!
To fulfill the special conditions according to ATEX, a BG2000-0000 or BG2000-0010 protection enclosure has to be mounted over the EtherCAT Box.
Installation
Put the cables for EtherCAT, power supply and sensors/actuators through the hole of the protection enclosure.
BG2000 - putting the cables
Fix the wires for EtherCAT, power supply and sensors/actuators to the EtherCAT Box.
BG2000 - fixing the cables
Mount the protection enclosure over the EtherCAT Box.
BG2000 - mounting the protection enclosure


ATEX Documentation

Mounting and connection [image] ATEX notes [image] ATEX Documentation
ATEX Documentation
Notes about operation of EtherCAT Box Modules (EPxxxx-xxxx) in potentially explosive areas (ATEX)
Pay also attention to the continuative documentationNotes about operation of EtherCAT Box Modules (EPxxxx-xxxx) in potentially explosive areas (ATEX) that is available in the download area of the Beckhoff homepage http:\\www.beckhoff.com!


Commissioning/Configuration

Commissioning/Configuration
Commissioning/Configuration
Additional information
•
Integration in TwinCAT
•
EP3204 – Data stream and calculation of the process data
•
EP3204 - object overview
•
EP3204 - object description and parameterization
•
EP3314 - Settings
•
EP3314 - object overview
•
EP3314 - object description and parameterization
•
Restoring the delivery state
•
Decommissioning


Integration in TwinCAT

Commissioning/Configuration [image] Integration in TwinCAT
Integration in TwinCAT
The procedure for integration in TwinCAT is described in this Quick start guide.


EP3204 – Data stream and calculation of the process data

Commissioning/Configuration [image] EP3204 – Data stream and calculation of the process data
EP3204 – Data stream and calculation of the process data
Additional information
•
Vendor calibration
•
User calibration and linearization
•
Scaling, limits and formatting
•
Summary
•
Two-point user calibration


Vendor calibration

Commissioning/Configuration [image] EP3204 – Data stream and calculation of the process data [image] Vendor calibration
Vendor calibration
Additional information
•
2 and 4-wire resistance measurement
•
3-wire resistance measurement


2 and 4-wire resistance measurement

Commissioning/Configuration [image] EP3204 – Data stream and calculation of the process data [image] Vendor calibration [image] 2 and 4-wire resistance measurement
2 and 4-wire resistance measurement
Whether a measurement is executed as a 2 or 4-wire measurement is determined by the connection points at which the measurement takes place. A comparison value is stored in the firmware for both measuring methods.
▪
With the 2-wire measurement
–
a current is applied between the contact points RL+ und RL- and the voltage drop is measured in order to determine the resistance.
–
The parasitic line resistance cannot be determined by the box itself, but must be entered as a correction value in the CoE register 0x80n0:1B.
▪
With the 4-wire measurement
–
the sensor current is applied between the contact points RL+ und RL- of the M12 socket and the voltage drop at the contact points R+ and R- is used to measure the resistance.
–
The conducting wire is thus not part of the measuring circuit and is not incorporated into the measurement as a source of error.
Resistance measurement with a 4-wire, 3-wire and 2-wire connection technique
The box uses the following calculation rule:
Data flow: resistance measurement with a 2 and 4-wire connection technique
With the values:
 | Index in the CoE directory with n: channel number with 0 ≤ n ≤ 3 (channel 1 - 4)
X: Raw value | 0x80nE:01
 | PT100 |  | PT1000
 | 2-wire | 4-wire | 2-wire | 4-wire
Gv: Vendor Gain | 0x80nF:04 | 0x80nF:06 | 0x80nF:0A | 0x80nF:0C
Ov: Vendor Offset | 0x80nF:03 | 0x80nF:05 | 0x80nF:09 | 0x80nF:0B
YR: Output value in 1/256 Ω | 0x80nE:02
Overflow YR after 16 bits
This value is only for fault finding. The register overflows after 16 bits, i.e. at 65536.


3-wire resistance measurement

Commissioning/Configuration [image] EP3204 – Data stream and calculation of the process data [image] Vendor calibration [image] 3-wire resistance measurement
3-wire resistance measurement
▪
With the 3-wire measurement
–
a defined current is initially applied between the contact points RL+ und RL- and the resistance between them is determined on the basis of the voltage drop.
–
The same procedure is subsequently carried out at the contact points RL+ und R-.
–
The difference between the two measurements is the line resistance of one of the cores of the sensor cable. By knowing the line resistance the resulting measuring error can be compensated.
–
The cores of the sensor cable must have the same resistance in order for the method to work.
Resistance measurement with a 4-wire, 3-wire and 2-wire connection technique
The box uses the following calculation rule
Data flow: resistance measurement with a 3-wire connection technique
With the values:
 | Index in the CoE directory with n: channel number with 0 ≤ n ≤ 3 (channel 1 - 4)
X1: raw value of the 1st measurement | 0x80nE:01
X2: raw value of the 2nd measurement | 0x80nE:03
 | PT100 | PT1000
Gv1: Vendor gain, 1st measurement | 0x80nF:04 | 0x80nF:0A
Ov1: Vendor offset, 1st measurement | 0x80nF:03 | 0x80nF:09
Gv2: Vendor gain, 2nd measurement | 0x80nF:02 | 0x80nF:08
Ov2: Vendor offset, 2nd measurement | 0x80nF:01 | 0x80nF:07
YR1: Output value in 1/256 Ω | 0x80nE:02
YR2: Output value in 1/256 Ω | 0x80nE:04
YR: Output value in 1/256 Ω
Overflow YR1 and YR2 after 16 bits
These values are only for fault finding. The registers overflow after 16 bits, i.e. at 65536.


User calibration and linearization

Commissioning/Configuration [image] EP3204 – Data stream and calculation of the process data [image] User calibration and linearization
User calibration and linearization
▪
The calibrated measured value may also be modified by the user calibration values.
▪
The result of the resistance measurement is mapped onto a temperature value. The fundamental linearization function cannot be modified by the user.
▪
The user scaling is only included after the linearization.
The box uses the following calculation rule
Data flow: user compensation and linearization
With the values:
 | Index in the CoE directory with n: channel number with 0 ≤ n ≤ 3 (channel 1 - 4)
XV: Output value of the vendor calibration
GU: User Gain | 0x80n0:18
OU: User Offset | 0x80n0:17
Yint: Output value in 1/256 Ω prior to the linearization


Scaling, limits and formatting

Commissioning/Configuration [image] EP3204 – Data stream and calculation of the process data [image] Scaling, limits and formatting
Scaling, limits and formatting
▪
Following the calculation of the resistance value, the scaling and the limit bits are evaluated.
▪
The result is formatted in accordance with the set presentation and copied into the process image.
The box uses the following calculation rule
Data flow: user scaling, limit evaluation, error bits and formatting
With the values:
 | Index in the CoE directory with n: channel number with 0 ≤ n ≤ 3 (channel 1 - 4)
Ylin: Output value in 1/100 °C
GS: User Scale Gain | 0x80n0:12
OS: User Scale Offset | 0x80n0:11
Y: Output value PDO


Summary

Commissioning/Configuration [image] EP3204 – Data stream and calculation of the process data [image] Summary
Summary
Summary of the calculation rules:
With the values:
 | Index in the CoE directory with n: channel number with 0 ≤ n ≤ 3 (channel 1 - 4)
X1: Raw value of the 1st measurement | 0x80nE:01
X2: Raw value of the 2nd measurement | 0x80nE:03
 | PT100 |  | PT1000
 | 2-wire | 4-wire | 2-wire | 4-wire
Gv: Vendor Gain | 0x80nF:04 | 0x80nF:06 | 0x80nF:0A | 0x80nF:0C
Ov: Vendor Offset | 0x80nF:03 | 0x80nF:05 | 0x80nF:09 | 0x80nF:0B
 | 3-wire
Gv1: Vendor gain, 1st measurement | 0x80nF:04 |  | 0x80nF:0A
Ov1: Vendor offset, 1st measurement | 0x80nF:03 |  | 0x80nF:09
Gv2: Vendor gain, 2nd measurement | 0x80nF:02 |  | 0x80nF:08
Ov2: Vendor offset, 2nd measurement | 0x80nF:01 |  | 0x80nF:07
GU: User Gain | 0x80n0:18
OU: User Scale Offset | 0x80n0:17
GS: User Scale Gain | 0x80n0:12
OS: User Scale Offset | 0x80n0:11
ƒlin: Function for mapping to the selected method of representation |
ƒpres: Linearization function |
YR1: Output value in 1/256 Ω | 0x80nE:02
YR2: Output value in 1/256 Ω | 0x80nE:04
Y: Output value PDO |
Overflow YR1 and YR2 after 16 bits
These values are only for fault finding. The registers overflow after 16 bits, i.e. at 65536.


Two-point user calibration

Commissioning/Configuration [image] EP3204 – Data stream and calculation of the process data [image] Two-point user calibration
Two-point user calibration
The vendor calibration is to be deactivated via index (0x80n0:0B).
Up to FW version 07 the deactivation of the vendor calibration only results in the vendor gain being set to 214 (fixed-point representation for 1.0). The vendor offset remains unchanged and is still included. This results in the following with vendor calibration deactivated:
Since the last part of the term is constant, a user calibration can be performed despite the unavoidable influence of the vendor offset. The influence of the vendor offset can thereby be fully compensated.
The following method is to be applied:
Carry out two reference measurements with Y1(X1) and Y2(X2). Then the following applies:
GU and OU are to be rounded to the nearest whole number and entered in index 0x80n0:18 and index 0x80n0:17.
X | Raw value (0x80nE:01)
OV: | Vendor Offset (index depends on the mode, see chapter Vendor calibration)
GU: | User Gain (0x80n0:18)
OU: | User Offset (0x80n0:17)
gf: | Gain as a floating value
OR: | Offset as a raw value
Xn: | Measured raw value with reference measurement n
Yn: | Reference value in 1/256 Ω
Yint: | Output value in 1/256 Ω prior to the linearization
Note
Yn: Use of the raw value
Since the resistance value in index 0x8xxE:02 overflows, the raw value in index 0x8xxE:01 is used for Yn.
Additional information
•
Example


Example

Commissioning/Configuration [image] EP3204 – Data stream and calculation of the process data [image] Two-point user calibration [image] Example
Example
Channel 1 is to be calibrated with four-wire connection at two points with 100 Ω and 350 Ω. The vendor offset for the 2-wire calibration is -2607 (taken from index 0x800F:03).
The following measured values are recorded:
100 Ω through precision resistor | X1 = 25600 (1/256 Ω)
171125, read in index 0x800E:01 | Y1 = 171125
350 Ω through precision resistor | X2 = 89600 (1/256 Ω)
592224, read in index 0x800E:01 | Y2 = 592224
With the equations (1) - (3):
the resulting values for gf, GU and OU are:
The indices accept only integer values. The following entries are to be made in the CoE:
Index 0x8000:17 = -12
Index 0x8000:18 = 9960
Subsequently the vendor calibration is to be deactivated (0x8000:0B) and the user calibration activated (0x8000:0A).


EP3204 - object overview

Commissioning/Configuration [image] EP3204 - object overview
EP3204 - object overview
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Index (hex) |  | Name | Flags | Default value
1000 |  | Device type | RO | 0x01401389 (20976521dec)
1008 |  | Device name | RO | EPP3204-0002
1009 |  | Hardware version | RO | 01
100A |  | Software version | RO | 03
1011:0 | Subindex | Restore default parameters | RO | 0x01 (1dec)
 | 1011:01 | SubIndex 001 | RW | 0x00000000 (0dec)
1018:0 | Subindex | Identity | RO | 0x04 (4dec)
 | 1018:01 | Vendor ID | RO | 0x00000002 (2dec)
 | 1018:02 | Product code | RO | 0x0C844052 (209993810dec)
 | 1018:03 | Revision | RO | 0x00120002 (1179650dec)
 | 1018:04 | Serial number | RO | 0x00000000 (0dec)
10F0:0 | Subindex | Backup parameter handling | RO | 0x01 (1dec)
 | 10F0:01 | Checksum | RO | 0x00000000 (0dec)
1A00:0 | Subindex | RTD TxPDO-Map RTDInputs Ch.1 | RO | 0x0A (10dec)
 | 1A00:01 | SubIndex 001 | RO | 0x6000:01, 1
 | 1A00:02 | SubIndex 002 | RO | 0x6000:02, 1
 | 1A00:03 | SubIndex 003 | RO | 0x6000:03, 2
 | 1A00:04 | SubIndex 004 | RO | 0x6000:05, 2
 | 1A00:05 | SubIndex 005 | RO | 0x6000:07, 1
 | 1A00:06 | SubIndex 006 | RO | 0x0000:00, 6
 | 1A00:07 | SubIndex 007 | RO | 0x6000:0E, 1
 | 1A00:08 | SubIndex 008 | RO | 0x1800:07, 1
 | 1A00:09 | SubIndex 009 | RO | 0x1800:09, 1
 | 1A00:0A | SubIndex 010 | RO | 0x6000:11, 16
1A01:0 | Subindex | RTD TxPDO-Map RTDInputs Ch.2 | RO | 0x0A (10dec)
 | 1A01:01 | SubIndex 001 | RO | 0x6010:01, 1
 | 1A01:02 | SubIndex 002 | RO | 0x6010:02, 1
 | 1A01:03 | SubIndex 003 | RO | 0x6010:03, 2
 | 1A01:04 | SubIndex 004 | RO | 0x6010:05, 2
 | 1A01:05 | SubIndex 005 | RO | 0x6010:07, 1
 | 1A01:06 | SubIndex 006 | RO | 0x0000:00, 6
 | 1A01:07 | SubIndex 007 | RO | 0x6010:0E, 1
 | 1A01:08 | SubIndex 008 | RO | 0x1801:07, 1
 | 1A01:09 | SubIndex 009 | RO | 0x1801:09, 1
 | 1A01:0A | SubIndex 010 | RO | 0x6010:11, 16
1A02:0 | Subindex | RTD TxPDO-Map RTDInputs Ch.3 | RO | 0x0A (10dec)
 | 1A02:01 | SubIndex 001 | RO | 0x6020:01, 1
 | 1A02:02 | SubIndex 002 | RO | 0x6020:02, 1
 | 1A02:03 | SubIndex 003 | RO | 0x6020:03, 2
 | 1A02:04 | SubIndex 004 | RO | 0x6020:05, 2
 | 1A02:05 | SubIndex 005 | RO | 0x6020:07, 1
 | 1A02:06 | SubIndex 006 | RO | 0x0000:00, 6
 | 1A02:07 | SubIndex 007 | RO | 0x6020:0E, 1
 | 1A02:08 | SubIndex 008 | RO | 0x1802:07, 1
 | 1A02:09 | SubIndex 009 | RO | 0x1802:09, 1
 | 1A02:0A | SubIndex 010 | RO | 0x6020:11, 16
Index (hex) |  | Name | Flags | Default value
1A03:0 | Subindex | RTD TxPDO-Map RTDInputs Ch.4 | RO | 0x0A (10dec)
 | 1A03:01 | SubIndex 001 | RO | 0x6030:01, 1
 | 1A03:02 | SubIndex 002 | RO | 0x6030:02, 1
 | 1A03:03 | SubIndex 003 | RO | 0x6030:03, 2
 | 1A03:04 | SubIndex 004 | RO | 0x6030:05, 2
 | 1A03:05 | SubIndex 005 | RO | 0x6030:07, 1
 | 1A03:06 | SubIndex 006 | RO | 0x0000:00, 6
 | 1A03:07 | SubIndex 007 | RO | 0x6030:0E, 1
 | 1A03:08 | SubIndex 008 | RO | 0x1803:07, 1
 | 1A03:09 | SubIndex 009 | RO | 0x1803:09, 1
 | 1A03:0A | SubIndex 010 | RO | 0x6030:11, 16
1C00:0 | Subindex | Sync manager type | RO | 0x04 (4dec)
 | 1C00:01 | SubIndex 001 | RO | 0x01 (1dec)
 | 1C00:02 | SubIndex 002 | RO | 0x02 (2dec)
 | 1C00:03 | SubIndex 003 | RO | 0x03 (3dec)
 | 1C00:04 | SubIndex 004 | RO | 0x04 (4dec)
1C12:0 | Subindex | RxPDO assign | RW | 0x00 (0dec)
1C13:0 | Subindex | TxPDO assign | RW | 0x04 (4dec)
 | 1C13:01 | SubIndex 001 | RW | 0x1A00 (6656dec)
 | 1C13:02 | SubIndex 002 | RW | 0x1A01 (6657dec)
 | 1C13:03 | SubIndex 003 | RW | 0x1A02 (6658dec)
 | 1C13:04 | SubIndex 004 | RW | 0x1A03 (6659dec)
1C33:0 | Subindex | SM input parameter | RO | 0x20 (32dec)
 | 1C33:01 | Sync mode | RW | 0x0000 (0dec)
 | 1C33:02 | Cycle time | RW | 0x000F4240 (1000000dec)
 | 1C33:03 | Shift time | RO | 0x00000000 (0dec)
 | 1C33:04 | Sync modes supported | RO | 0xC007 (49159dec)
 | 1C33:05 | Minimum cycle time | RO | 0x00002710 (10000dec)
 | 1C33:06 | Calc and copy time | RO | 0x00000000 (0dec)
 | 1C33:07 | Minimum delay time | RO | 0x00000000 (0dec)
 | 1C33:08 | Command | RW | 0x0000 (0dec)
 | 1C33:09 | Maximum Delay time | RO | 0x00000000 (0dec)
 | 1C33:0B | SM event missed counter | RO | 0x0000 (0dec)
 | 1C33:0C | Cycle exceeded counter | RO | 0x0000 (0dec)
 | 1C33:0D | Shift too short counter | RO | 0x0000 (0dec)
 | 1C33:20 | Sync error | RO | 0x00 (0dec)
6000:0 | Subindex | RTD Inputs Ch.1 | RO | 0x11 (17dec)
 | 6000:01 | Underrange | RO | 0x00 (0dec)
 | 6000:02 | Overrange | RO | 0x00 (0dec)
 | 6000:03 | Limit 1 | RO | 0x00 (0dec)
 | 6000:05 | Limit 2 | RO | 0x00 (0dec)
 | 6000:07 | Error | RO | 0x00 (0dec)
 | 6000:0E | Sync error | RO | 0x00 (0dec)
 | 6000:0F | TxPDO State | RO | 0x00 (0dec)
 | 6000:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6000:11 | Value | RO | 0x0000 (0dec)
6010:0 | Subindex | RTD Inputs Ch.2 | RO | 0x11 (17dec)
 | 6010:01 | Underrange | RO | 0x00 (0dec)
 | 6010:02 | Overrange | RO | 0x00 (0dec)
 | 6010:03 | Limit 1 | RO | 0x00 (0dec)
 | 6010:05 | Limit 2 | RO | 0x00 (0dec)
 | 6010:07 | Error | RO | 0x00 (0dec)
 | 6010:0E | Sync error | RO | 0x00 (0dec)
 | 6010:0F | TxPDO State | RO | 0x00 (0dec)
 | 6010:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6010:11 | Value | RO | 0x0000 (0dec)
Index (hex) |  | Name | Flags | Default value
6020:0 | Subindex | RTD Inputs Ch.3 | RO | 0x11 (17dec)
 | 6020:01 | Underrange | RO | 0x00 (0dec)
 | 6020:02 | Overrange | RO | 0x00 (0dec)
 | 6020:03 | Limit 1 | RO | 0x00 (0dec)
 | 6020:05 | Limit 2 | RO | 0x00 (0dec)
 | 6020:07 | Error | RO | 0x00 (0dec)
 | 6020:0E | Sync error | RO | 0x00 (0dec)
 | 6020:0F | TxPDO State | RO | 0x00 (0dec)
 | 6020:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6020:11 | Value | RO | 0x0000 (0dec)
6030:0 | Subindex | RTD Inputs Ch.4 | RO | 0x11 (17dec)
 | 6030:01 | Underrange | RO | 0x00 (0dec)
 | 6030:02 | Overrange | RO | 0x00 (0dec)
 | 6030:03 | Limit 1 | RO | 0x00 (0dec)
 | 6030:05 | Limit 2 | RO | 0x00 (0dec)
 | 6030:07 | Error | RO | 0x00 (0dec)
 | 6030:0E | Sync error | RO | 0x00 (0dec)
 | 6030:0F | TxPDO State | RO | 0x00 (0dec)
 | 6030:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6030:11 | Value | RO | 0x0000 (0dec)
8000:0 | Subindex | RTD Settings Ch.1 | RW | 0x1B (27dec)
 | 8000:01 | Enable user scale | RW | 0x00 (0dec)
 | 8000:02 | Presentation | RW | 0x00 (0dec)
 | 8000:05 | Siemens bits | RW | 0x00 (0dec)
 | 8000:06 | Enable filter | RW | 0x00 (0dec)
 | 8000:07 | Enable limit 1 | RW | 0x00 (0dec)
 | 8000:08 | Enable limit 2 | RW | 0x00 (0dec)
 | 8000:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8000:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 8000:0E | Swap limit bits | RW | 0x00 (0dec)
 | 8000:11 | User scale offset | RW | 0x0000 (0dec)
 | 8000:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 8000:13 | Limit 1 | RW | 0x0000 (0dec)
 | 8000:14 | Limit 2 | RW | 0x0000 (0dec)
 | 8000:15 | Filter settings | RW | 0x0000 (0dec)
 | 8000:16 | Calibration interval | RW | 0x0000 (0dec)
 | 8000:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8000:18 | User calibration gain | RW | 0x4000 (16384dec)
 | 8000:19 | RTD element | RW | 0x0000 (0dec)
 | 8000:1A | Connection technology | RW | 0x0000 (0dec)
 | 8000:1B | Wire calibration 1/32 Ohm | RW | 0x0000 (0dec)
800E:0 | Subindex | RTD Internal data Ch.1 | RO | 0x04 (4dec)
 | 800E:01 | ADC raw value 1 | RO | 0x00000000 (0dec)
 | 800E:02 | Resistor 1 | RO | 0x0000 (0dec)
 | 800E:03 | ADC raw value 2 | RO | 0x00000000 (0dec)
 | 800E:04 | Resistor 2 | RO | 0x0000 (0dec)
800F:0 | Subindex | RTD Vendor data Ch.1 | RW | 0x07 (7dec)
 | 800F:01 | Calibration offset 3-wire | RW | 0x0000 (0dec)
 | 800F:02 | Calibration gain 3-wire | RW | 0x4000 (16384dec)
 | 800F:03 | Calibration offset 2-wire | RW | 0x0000 (0dec)
 | 800F:04 | Calibration gain 2-wire | RW | 0x4000 (16384dec)
 | 800F:05 | Calibration offset 4-wire | RW | 0x0000 (0dec)
 | 800F:06 | Calibration gain 4-wire | RW | 0x4000 (16384dec)
 | 800F:07 | PGA Gain Correction | RW | 0x0000 (0dec)
Index (hex) |  | Name | Flags | Default value
8010:0 | Subindex | RTD Settings Ch.2 | RW | 0x1B (27dec)
 | 8010:01 | Enable user scale | RW | 0x00 (0dec)
 | 8010:02 | Presentation | RW | 0x00 (0dec)
 | 8010:05 | Siemens bits | RW | 0x00 (0dec)
 | 8010:06 | Enable filter | RW | 0x00 (0dec)
 | 8010:07 | Enable limit 1 | RW | 0x00 (0dec)
 | 8010:08 | Enable limit 2 | RW | 0x00 (0dec)
 | 8010:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8010:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 8010:0E | Swap limit bits | RW | 0x00 (0dec)
 | 8010:11 | User scale offset | RW | 0x0000 (0dec)
 | 8010:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 8010:13 | Limit 1 | RW | 0x0000 (0dec)
 | 8010:14 | Limit 2 | RW | 0x0000 (0dec)
 | 8010:15 | Filter settings | RW | 0x0000 (0dec)
 | 8010:16 | Calibration interval | RW | 0x0000 (0dec)
 | 8010:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8010:18 | User calibration gain | RW | 0x4000 (16384dec)
 | 8010:19 | RTD element | RW | 0x0000 (0dec)
 | 8010:1A | Connection technology | RW | 0x0000 (0dec)
 | 8010:1B | Wire calibration 1/32 Ohm | RW | 0x0000 (0dec)
801E:0 | Subindex | RTD Internal data Ch.2 | RO | 0x04 (4dec)
 | 801E:01 | ADC raw value 1 | RO | 0x00000000 (0dec)
 | 801E:02 | Resistor 1 | RO | 0x0000 (0dec)
 | 801E:03 | ADC raw value 2 | RO | 0x00000000 (0dec)
 | 801E:04 | Resistor 2 | RO | 0x0000 (0dec)
801F | Subindex | RTD Vendor data Ch.2 | RW | 0x07 (7dec)
 | 801F:01 | Calibration offset 3-wire | RW | 0x0000 (0dec)
 | 801F:02 | Calibration gain 3-wire | RW | 0x4000 (16384dec)
 | 801F:03 | Calibration offset 2-wire | RW | 0x0000 (0dec)
 | 801F:04 | Calibration gain 2-wire | RW | 0x4000 (16384dec)
 | 801F:05 | Calibration offset 4-wire | RW | 0x0000 (0dec)
 | 801F:06 | Calibration gain 4-wire | RW | 0x4000 (16384dec)
 | 801F:07 | PGA Gain Correction | RW | 0x0000 (0dec)
8020:0 | Subindex | RTD Settings Ch.3 | RW | 0x1B (27dec)
 | 8020:01 | Enable user scale | RW | 0x00 (0dec)
 | 8020:02 | Presentation | RW | 0x00 (0dec)
 | 8020:05 | Siemens bits | RW | 0x00 (0dec)
 | 8020:06 | Enable filter | RW | 0x00 (0dec)
 | 8020:07 | Enable limit 1 | RW | 0x00 (0dec)
 | 8020:08 | Enable limit 2 | RW | 0x00 (0dec)
 | 8020:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8020:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 8020:0E | Swap limit bits | RW | 0x00 (0dec)
 | 8020:11 | User scale offset | RW | 0x0000 (0dec)
 | 8020:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 8020:13 | Limit 1 | RW | 0x0000 (0dec)
 | 8020:14 | Limit 2 | RW | 0x0000 (0dec)
 | 8020:15 | Filter settings | RW | 0x0000 (0dec)
 | 8020:16 | Calibration interval | RW | 0x0000 (0dec)
 | 8020:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8020:18 | User calibration gain | RW | 0x4000 (16384dec)
 | 8020:19 | RTD element | RW | 0x0000 (0dec)
 | 8020:1A | Connection technology | RW | 0x0000 (0dec)
 | 8020:1B | Wire calibration 1/32 Ohm | RW | 0x0000 (0dec)
Index (hex) |  | Name | Flags | Default value
802E:0 | Subindex | RTD Internal data Ch.3 | RO | 0x04 (4dec)
 | 802E:01 | ADC raw value 1 | RO | 0x00000000 (0dec)
 | 802E:02 | Resistor 1 | RO | 0x0000 (0dec)
 | 802E:03 | ADC raw value 2 | RO | 0x00000000 (0dec)
 | 802E:04 | Resistor 2 | RO | 0x0000 (0dec)
802F:0 | Subindex | RTD Vendor data Ch.3 | RW | 0x07 (7dec)
 | 802F:01 | Calibration offset 3-wire | RW | 0x0000 (0dec)
 | 802F:02 | Calibration gain 3-wire | RW | 0x4000 (16384dec)
 | 802F:03 | Calibration offset 2-wire | RW | 0x0000 (0dec)
 | 802F:04 | Calibration gain 2-wire | RW | 0x4000 (16384dec)
 | 802F:05 | Calibration offset 4-wire | RW | 0x0000 (0dec)
 | 802F:06 | Calibration gain 4-wire | RW | 0x4000 (16384dec)
 | 802F:07 | PGA Gain Correction | RW | 0x0000 (0dec)
8030:0 | Subindex | RTD Settings Ch.4 | RW | 0x1B (27dec)
 | 8030:01 | Enable user scale | RW | 0x00 (0dec)
 | 8030:02 | Presentation | RW | 0x00 (0dec)
 | 8030:05 | Siemens bits | RW | 0x00 (0dec)
 | 8030:06 | Enable filter | RW | 0x00 (0dec)
 | 8030:07 | Enable limit 1 | RW | 0x00 (0dec)
 | 8030:08 | Enable limit 2 | RW | 0x00 (0dec)
 | 8030:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8030:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 8030:0E | Swap limit bits | RW | 0x00 (0dec)
 | 8030:11 | User scale offset | RW | 0x0000 (0dec)
 | 8030:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 8030:13 | Limit 1 | RW | 0x0000 (0dec)
 | 8030:14 | Limit 2 | RW | 0x0000 (0dec)
 | 8030:15 | Filter settings | RW | 0x0000 (0dec)
 | 8030:16 | Calibration interval | RW | 0x0000 (0dec)
 | 8030:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8030:18 | User calibration gain | RW | 0x4000 (16384dec)
 | 8030:19 | RTD element | RW | 0x0000 (0dec)
 | 8030:1A | Connection technology | RW | 0x0000 (0dec)
 | 8030:1B | Wire calibration 1/32 Ohm | RW | 0x0000 (0dec)
803E:0 | Subindex | RTD Internal data Ch.4 | RO | 0x04 (4dec)
 | 803E:01 | ADC raw value 1 | RO | 0x00000000 (0dec)
 | 803E:02 | Resistor 1 | RO | 0x0000 (0dec)
 | 803E:03 | ADC raw value 2 | RO | 0x00000000 (0dec)
 | 803E:04 | Resistor 2 | RO | 0x0000 (0dec)
803F:0 | Subindex | RTD Vendor data Ch.4 | RW | 0x07 (7dec)
 | 803F:01 | Calibration offset 3-wire | RW | 0x0000 (0dec)
 | 803F:02 | Calibration gain 3-wire | RW | 0x4000 (16384dec)
 | 803F:03 | Calibration offset 2-wire | RW | 0x0000 (0dec)
 | 803F:04 | Calibration gain 2-wire | RW | 0x4000 (16384dec)
 | 803F:05 | Calibration offset 4-wire | RW | 0x0000 (0dec)
 | 803F:06 | Calibration gain 4-wire | RW | 0x4000 (16384dec)
 | 803F:07 | PGA Gain Correction | RW | 0x0000 (0dec)
F000:0 | Subindex | Modular device profile | RO | 0x02 (2dec)
 | F000:01 | Module index distance | RO | 0x0010 (16dec)
 | F000:02 | Maximum number of modules | RO | 0x0004 (4dec)
F008 |  | Code word | RW | 0x00000000 (0dec)
F010:0 | Subindex | Module list | RW | 0x04 (4dec)
 | F010:01 | SubIndex 001 | RW | 0x00000140 (320dec)
 | F010:02 | SubIndex 002 | RW | 0x00000140 (320dec)
 | F010:03 | SubIndex 003 | RW | 0x00000140 (320dec)
 | F010:04 | SubIndex 004 | RW | 0x00000140 (320dec)
Index (hex) |  | Name | Flags | Default value
F080:0 | Subindex | Channel Enable | RO | 0x04 (4dec)
 | F080:01 | SubIndex 001 | RW | 0xFF (255dec)
 | F080:02 | SubIndex 002 | RW | 0xFF (255dec)
 | F080:03 | SubIndex 003 | RW | 0xFF (255dec)
 | F080:04 | SubIndex 004 | RW | 0xFF (255dec)
Key
Flags:
RO (Read Only): this object can be read only
RW (Read/Write): this object can be read and written to


EP3204 - object description and parameterization

Commissioning/Configuration [image] EP3204 - object description and parameterization
EP3204 - object description and parameterization
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Parameterization via the CoE list (CAN over EtherCAT)
The EtherCAT device is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs).
Introduction
The CoE overview contains objects for different intended applications:
▪
Objects required for parameterization during commissioning
▪
Objects intended for regular operation, e.g. through ADS access.
▪
Objects for indicating internal settings (may be fixed)
▪
Further profile-specific objects indicating inputs, outputs and status information
The following section first describes the objects required for normal operation, followed by a complete overview of missing objects.
Additional information
•
Objects to be parameterized during commissioning
•
Objects for regular operation
•
Standard objects (0x1000-0x1FFF)
•
Profile-specific objects (0x6000-0xFFFF)


Objects to be parameterized during commissioning

Commissioning/Configuration [image] EP3204 - object description and parameterization [image] Objects to be parameterized during commissioning
Objects to be parameterized during commissioning
Index 1011: Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default parameters | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" in the set value dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)
Index 8000: RTD Settings Ch.1
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8000:0 | RTD Settings Ch.1 | Maximum subindex |  | UINT8 | RO | 0x1B (27dec)
8000:01 | Enable user scale | Activates user scaling |  | BOOLEAN | RW | 0x00 (0dec)
8000:02 | Presentation | Presentation of the measured value |  | BIT3 | RW | 0x00 (0dec)
 |  | 0 | Signed, in two's complement
 |  | 1 | Most significant bit as sign
 |  | 2 | High-resolution (1/100 °C steps)
8000:05 | Siemens bits | The S5 bits are displayed in the three low-order bits |  | BOOLEAN | RW | 0x00 (0dec)
8000:06 | Enable filter | Enable filter, which makes PLC-cycle-synchronous data exchange unnecessary |  | BOOLEAN | RW | 0x00 (0dec)
8000:07 | Enable limit 1 | Activates limit check for limit 1 |  | BOOLEAN | RW | 0x00 (0dec)
8000:08 | Enable limit 2 | Activates limit check for limit 2 |  | BOOLEAN | RW | 0x00 (0dec)
8000:0A | Enable user calibration | Activates user calibration |  | BOOLEAN | RW | 0x00 (0dec)
8000:0B | Enable vendor calibration | Activates vendor calibration |  | BOOLEAN | RW | 0x01 (1dec)
8000:0E | Swap limit bits | Swaps the two limit bits, in order to achieve compatibility with older hardware versions. |  | BOOLEAN | RW | 0x00 (0dec)
8000:11 | User scale offset | User scaling offset |  | INT16 | RW | 0x0000 (0dec)
8000:12 | User scale gain | Gain of the user scaling |  | INT32 | RW | 0x00010000 (65536dec)
8000:13 | Limit 1 | Value for limit 1 |  | INT16 | RW | 0x0000 (0dec)
8000:14 | Limit 2 | Value for limit 2 |  | INT16 | RW | 0x0000 (0dec)
8000:15 | Filter settings | Filter settings |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 50 Hz
 |  | 1 | 60 Hz
 |  | 2 | 100 Hz
 |  | 3 | 500 Hz
 |  | 4 | 1 kHz
 |  | 5 | 2 kHz
 |  | 6 | 3.75 kHz
 |  | 7 | 7.5 kHz
 |  | 8 | 15 kHz
 |  | 9 | 30 kHz
 |  | 10 | 5 Hz
 |  | 11 | 10 Hz
8000:16 | Calibration interval | reserved |  | UINT16 | RW | 0x0000 (0dec)
8000:17 | User calibration offset | User calibration offset |  | INT16 | RW | 0x0000 (0dec)
8000:18 | User calibration gain | Gain of the user calibration |  | UINT16 | RW | 0x4000 (16384dec)
8000:19 | RTD element | Sensor type |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | PT100
 |  | 1 | Ni100
 |  | 2 | PT1000
 |  | 3 | PT500
 |  | 4 | PT200
 |  | 5 | Ni1000
 |  | 6 | Ni1000 (Siemens)
 |  | 7 | Ni120
 |  | 8 | Resistance measurement with 1/16 ohm resolution
 |  | 9 | Resistance measurement with 1/64 ohm resolution
Index 8000: RTD Settings Ch.1
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8000:1A | Connection technology | Connection technology: |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 2-wire
 |  | 1 | 3-wire
 |  | 2 | 4-wire
 |  | 3 | No sensor connected (only supported by hardware version 00): This setting skips the whole measurement, thus speeding up the data acquisition for the other channels. The green status LED of the respective channel remains lit. The error bit of a deactivated channel is canceled and no longer set.
8000:1B | Wire calibration 1/32 Ohm | Only for 2-wire measurements: contains the resistance of the supply line for the temperature sensor (in 1/32 ohm). |  | INT16 | RW | 0x0000 (0dec)
Index 8010: RTD Settings Ch.2
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8010:0 | RTD Settings Ch.2 | Maximum subindex |  | UINT8 | RO | 0x1B (27dec)
8010:01 | Enable user scale | Activates user scaling |  | BOOLEAN | RW | 0x00 (0dec)
8010:02 | Presentation | Presentation of the measured value |  | BIT3 | RW | 0x00 (0dec)
 |  | 0 | Signed, in two's complement
 |  | 1 | Most significant bit as sign
 |  | 2 | High-resolution (1/100 °C steps)
8010:05 | Siemens bits | The S5 bits are displayed in the three low-order bits |  | BOOLEAN | RW | 0x00 (0dec)
8010:06 | Enable filter | Enable filter, which makes PLC-cycle-synchronous data exchange unnecessary |  | BOOLEAN | RW | 0x00 (0dec)
8010:07 | Enable limit 1 | Activates limit check for limit 1 |  | BOOLEAN | RW | 0x00 (0dec)
8010:08 | Enable limit 2 | Activates limit check for limit 2 |  | BOOLEAN | RW | 0x00 (0dec)
8010:0A | Enable user calibration | Activates user calibration |  | BOOLEAN | RW | 0x00 (0dec)
8010:0B | Enable vendor calibration | Activates manufacturer calibration |  | BOOLEAN | RW | 0x01 (1dec)
8010:0E | Swap limit bits | Swaps the two limit bits, in order to achieve compatibility with older hardware versions. |  | BOOLEAN | RW | 0x00 (0dec)
8010:11 | User scale offset | User scaling offset |  | INT16 | RW | 0x0000 (0dec)
8010:12 | User scale gain | Gain of the user scaling |  | INT32 | RW | 0x00010000 (65536dec)
8010:13 | Limit 1 | Value for limit 1 |  | INT16 | RW | 0x0000 (0dec)
8010:14 | Limit 2 | Value for limit 2 |  | INT16 | RW | 0x0000 (0dec)
8010:15 | Filter settings | Filter settings |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 50 Hz
 |  | 1 | 60 Hz
 |  | 2 | 100 Hz
 |  | 3 | 500 Hz
 |  | 4 | 1 kHz,
 |  | 5 | 2 kHz
 |  | 6 | 3.75 kHz
 |  | 7 | 7.5 kHz
 |  | 8 | 15 kHz
 |  | 9 | 30 kHz
 |  | 10 | 5 Hz
 |  | 11 | 10 Hz
8010:16 | Calibration interval | reserved |  | UINT16 | RW | 0x0000 (0dec)
8010:17 | User calibration offset | User calibration offset |  | INT16 | RW | 0x0000 (0dec)
8010:18 | User calibration gain | Gain of the user calibration |  | UINT16 | RW | 0x4000 (16384dec)
Index 8010: RTD Settings Ch.2
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8010:19 | RTD element | Sensor type |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | PT100
 |  | 1 | Ni100
 |  | 2 | PT1000
 |  | 3 | PT500
 |  | 4 | PT200
 |  | 5 | Ni1000
 |  | 6 | Ni1000 (Siemens)
 |  | 7 | Ni120
 |  | 8 | Resistance measurement with 1/16 ohm resolution
 |  | 9 | Resistance measurement with 1/64 ohm resolution
8010:1A | Connection technology | Connection technology: |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 2-wire
 |  | 1 | 3-wire
 |  | 2 | 4-wire
 |  | 3 | No sensor connected (only supported by hardware version 00): This setting skips the whole measurement, thus speeding up the data acquisition for the other channels. The green status LED of the respective channel remains lit. The error bit of a deactivated channel is cancelled and no longer set.
8010:1B | Wire calibration 1/32 Ohm | Only for 2-wire measurements: contains the resistance of the supply line for the temperature sensor (in 1/32 ohm). |  | INT16 | RW | 0x0000 (0dec)
Index 8020: RTD Settings Ch.3
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8020:0 | RTD Settings Ch.3 | Maximum subindex |  | UINT8 | RO | 0x1B (27dec)
8020:01 | Enable user scale | Activates user scaling |  | BOOLEAN | RW | 0x00 (0dec)
8020:02 | Presentation | Presentation of the measured value |  | BIT3 | RW | 0x00 (0dec)
 |  | 0 | Signed, in two's complement
 |  | 1 | Most significant bit as sign
 |  | 2 | High-resolution (1/100 °C steps)
8020:05 | Siemens bits | The S5 bits are displayed in the three low-order bits |  | BOOLEAN | RW | 0x00 (0dec)
8020:06 | Enable filter | Enable filter, which makes PLC-cycle-synchronous data exchange unnecessary |  | BOOLEAN | RW | 0x00 (0dec)
8020:07 | Enable limit 1 | Activates limit check for limit 1 |  | BOOLEAN | RW | 0x00 (0dec)
8020:08 | Enable limit 2 | Activates limit check for limit 2 |  | BOOLEAN | RW | 0x00 (0dec)
8020:0A | Enable user calibration | Activates user calibration |  | BOOLEAN | RW | 0x00 (0dec)
8020:0B | Enable vendor calibration | Activates vendor calibration |  | BOOLEAN | RW | 0x01 (1dec)
8020:0E | Swap limit bits | Swaps the two limit bits, in order to achieve compatibility with older hardware versions. |  | BOOLEAN | RW | 0x00 (0dec)
8020:11 | User scale offset | User scaling offset |  | INT16 | RW | 0x0000 (0dec)
8020:12 | User scale gain | Gain of the user scaling |  | INT32 | RW | 0x00010000 (65536dec)
8020:13 | Limit 1 | Value for limit 1 |  | INT16 | RW | 0x0000 (0dec)
8020:14 | Limit 2 | Value for limit 2 |  | INT16 | RW | 0x0000 (0dec)
Index 8020: RTD Settings Ch.3
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8020:15 | Filter settings | Filter settings |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 50 Hz
 |  | 1 | 60 Hz
 |  | 2 | 100 Hz
 |  | 3 | 500 Hz
 |  | 4 | 1 kHz,
 |  | 5 | 2 kHz
 |  | 6 | 3.75 kHz
 |  | 7 | 7.5 kHz
 |  | 8 | 15 kHz
 |  | 9 | 30 kHz
 |  | 10 | 5 Hz
 |  | 11 | 10 Hz
8020:16 | Calibration interval | reserved |  | UINT16 | RW | 0x0000 (0dec)
8020:17 | User calibration offset | User calibration offset |  | INT16 | RW | 0x0000 (0dec)
8020:18 | User calibration gain | Gain of the user calibration |  | UINT16 | RW | 0x4000 (16384dec)
8020:19 | RTD element | Sensor type |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | PT100
 |  | 1 | Ni100
 |  | 2 | PT1000
 |  | 3 | PT500
 |  | 4 | PT200
 |  | 5 | Ni1000
 |  | 6 | Ni1000 (Siemens)
 |  | 7 | Ni120
 |  | 8 | Resistance measurement with 1/16 ohm resolution
 |  | 9 | Resistance measurement with 1/64 ohm resolution
8020:1A | Connection technology | Connection technology: |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 2-wire
 |  | 1 | 3-wire
 |  | 2 | 4-wire
 |  | 3 | No sensor connected (only supported by hardware version 00): This setting skips the whole measurement, thus speeding up the data acquisition for the other channels. The green status LED of the respective channel remains lit. The error bit of a deactivated channel is canceled and no longer set.
8020:1B | Wire calibration 1/32 Ohm | Only for 2-wire measurements: contains the resistance of the supply line for the temperature sensor (in 1/32 ohm). |  | INT16 | RW | 0x0000 (0dec)
Index 8030: RTD Settings Ch.4
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8030:0 | RTD Settings Ch.4 | Maximum subindex |  | UINT8 | RO | 0x1B (27dec)
8030:01 | Enable user scale | Activates user scaling |  | BOOLEAN | RW | 0x00 (0dec)
8030:02 | Presentation | Presentation of the measured value |  | BIT3 | RW | 0x00 (0dec)
 |  | 0 | Signed, in two's complement
 |  | 1 | Most significant bit as sign
 |  | 2 | High-resolution (1/100 °C steps)
8030:05 | Siemens bits | The S5 bits are displayed in the three low-order bits |  | BOOLEAN | RW | 0x00 (0dec)
8030:06 | Enable filter | Enable filter, which makes PLC-cycle-synchronous data exchange unnecessary |  | BOOLEAN | RW | 0x00 (0dec)
8030:07 | Enable limit 1 | Activates limit check for limit 1 |  | BOOLEAN | RW | 0x00 (0dec)
8030:08 | Enable limit 2 | Activates limit check for limit 2 |  | BOOLEAN | RW | 0x00 (0dec)
Index 8030: RTD Settings Ch.4
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8030:0A | Enable user calibration | Activates user calibration |  | BOOLEAN | RW | 0x00 (0dec)
8030:0B | Enable vendor calibration | Activates vendor calibration |  | BOOLEAN | RW | 0x01 (1dec)
8030:0E | Swap limit bits | Swaps the two limit bits, in order to achieve compatibility with older hardware versions. |  | BOOLEAN | RW | 0x00 (0dec)
8030:11 | User scale offset | User scaling offset |  | INT16 | RW | 0x0000 (0dec)
8030:12 | User scale gain | Gain of the user scaling |  | INT32 | RW | 0x00010000 (65536dec)
8030:13 | Limit 1 | Value for limit 1 |  | INT16 | RW | 0x0000 (0dec)
8030:14 | Limit 2 | Value for limit 2 |  | INT16 | RW | 0x0000 (0dec)
8030:15 | Filter settings | Filter settings |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 50 Hz
 |  | 1 | 60 Hz
 |  | 2 | 100 Hz
 |  | 3 | 500 Hz
 |  | 4 | 1 kHz,
 |  | 5 | 2 kHz
 |  | 6 | 3.75 kHz
 |  | 7 | 7.5 kHz
 |  | 8 | 15 kHz
 |  | 9 | 30 kHz
 |  | 10 | 5 Hz
 |  | 11 | 10 Hz
8030:16 | Calibration interval | reserved |  | UINT16 | RW | 0x0000 (0dec)
8030:17 | User calibration offset | User calibration offset |  | INT16 | RW | 0x0000 (0dec)
8030:18 | User calibration gain | Gain of the user calibration |  | UINT16 | RW | 0x4000 (16384dec)
8030:19 | RTD element | Sensor type |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | PT100
 |  | 1 | Ni100
 |  | 2 | PT1000
 |  | 3 | PT500
 |  | 4 | PT200
 |  | 5 | Ni1000
 |  | 6 | Ni1000 (Siemens)
 |  | 7 | Ni120
 |  | 8 | Resistance measurement with 1/16 ohm resolution
 |  | 9 | Resistance measurement with 1/64 ohm resolution
8030:1A | Connection technology | Connection technology: |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 2-wire
 |  | 1 | 3-wire
 |  | 2 | 4-wire
 |  | 3 | No sensor connected (only supported by hardware version 00): This setting skips the whole measurement, thus speeding up the data acquisition for the other channels. The green status LED of the respective channel remains lit. The error bit of a deactivated channel is canceled and no longer set.
8030:1B | Wire calibration 1/32 Ohm | Only for 2-wire measurements: contains the resistance of the supply line for the temperature sensor (in 1/32 ohm). |  | INT16 | RW | 0x0000 (0dec)


Objects for regular operation

Commissioning/Configuration [image] EP3204 - object description and parameterization [image] Objects for regular operation
Objects for regular operation
EPP3204 has no such objects.


Standard objects (0x1000-0x1FFF)

Commissioning/Configuration [image] EP3204 - object description and parameterization [image] Standard objects (0x1000-0x1FFF)
Standard objects (0x1000-0x1FFF)
The standard objects have the same meaning for all EtherCAT slaves.
Index 1000: Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Low-Word contains the CoE profile used (5001). The High-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x01401389 (20976521dec)
Index 1008: Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EP3204-0002
Index 1009: Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO | 05
Index 100A: Software version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO | 07
Index 1018: Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x0C844052 (209993810dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the low word (bit 0-15) indicates the special terminal number, the high word (bit 16-31) refers to the device description | UINT32 | RO | 0x00120002 (1179650dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the low byte (bit 0-7) of the low word contains the year of production, the high byte (bit 8-15) of the low word contains the week of production, the high word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 10F0: Backup parameter handling
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | Information for standardized loading and saving of backup entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum across all backup entries of the EtherCAT slave | UINT32 | RO | 0x00000000 (0dec)
Index 1A00: RTD TxPDO-Map RTDInputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A00:0 | RTD TxPDO-Map RTDInputs Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x09 (9dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry | UINT32 | RO | 0x6000:03, 2
1A00:04 | SubIndex 004 | 4. PDO Mapping entry | UINT32 | RO | 0x6000:05, 2
1A00:05 | SubIndex 005 | 5. PDO Mapping entry | UINT32 | RO | 0x6000:07, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A00:07 | SubIndex 007 | 7. PDO Mapping entry | UINT32 | RO | 0x6000:0, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry | UINT32 | RO | 0x6000:10, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry | UINT32 | RO | 0x6000:11, 16
Index 1A01: RTD TxPDO-Map RTDInputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A01:0 | RTD TxPDO-Map RTDInputs Ch.2 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x09 (9dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x6010:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry | UINT32 | RO | 0x6010:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry | UINT32 | RO | 0x6010:03, 2
1A01:04 | SubIndex 004 | 4. PDO Mapping entry | UINT32 | RO | 0x6010:05, 2
1A01:05 | SubIndex 005 | 5. PDO Mapping entry | UINT32 | RO | 0x6010:07, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A01:07 | SubIndex 007 | 7. PDO Mapping entry | UINT32 | RO | 0x6010:0F, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry | UINT32 | RO | 0x6010:10, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry | UINT32 | RO | 0x6010:11, 16
Index 1A02: RTD TxPDO-Map RTDInputs Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1A02:0 | RTD TxPDO-Map RTDInputs Ch.3 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x09 (9dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x6020:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry | UINT32 | RO | 0x6020:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry | UINT32 | RO | 0x6020:03, 2
1A02:04 | SubIndex 004 | 4. PDO Mapping entry | UINT32 | RO | 0x6020:05, 2
1A02:05 | SubIndex 005 | 5. PDO Mapping entry | UINT32 | RO | 0x6020:07, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A02:07 | SubIndex 007 | 7. PDO Mapping entry | UINT32 | RO | 0x6020:0F, 1
1A02:08 | SubIndex 008 | 8. PDO Mapping entry | UINT32 | RO | 0x6020:10, 1
1A02:09 | SubIndex 009 | 9. PDO Mapping entry | UINT32 | RO | 0x6020:11, 16
Index 1A03: RTD TxPDO-Map RTDInputs Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
1A03:0 | RTD TxPDO-Map RTDInputs Ch.4 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x09 (9dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x6030:01, 1
1A03:02 | SubIndex 002 | 2. PDO Mapping entry | UINT32 | RO | 0x6030:02, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry | UINT32 | RO | 0x6030:03, 2
1A03:04 | SubIndex 004 | 4. PDO Mapping entry | UINT32 | RO | 0x6030:05, 2
1A03:05 | SubIndex 005 | 5. PDO Mapping entry | UINT32 | RO | 0x6030:07, 1
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A03:07 | SubIndex 007 | 7. PDO Mapping entry | UINT32 | RO | 0x6030:0F, 1
1A03:08 | SubIndex 008 | 8. PDO Mapping entry | UINT32 | RO | 0x6030:10, 1
1A03:09 | SubIndex 009 | 9. PDO Mapping entry | UINT32 | RO | 0x6030:11, 16
Index 1C00: Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the sync managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12: RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x00 (0dec)
Index 1C13: TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x04 (4dec)
1C13:01 | Subindex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A01 (6657dec)
1C13:03 | Subindex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A02 (6658dec)
1C13:04 | Subindex 004 | 4. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A03 (6659dec)
Index 1C33: SM input parameter
Index (hex) | Name | Meaning | Data type | Flags | Default
1C33:0 | SM input parameter | Maximum subindex | UINT8 | RO | 0x20 (32dec)
1C33:01 | Sync mode |  | UINT16 | RW | 0x0000 (0dec)
1C33:02 | Cycle time |  | UINT32 | RW | 0x000F4240 (1000000dec)
1C33:03 | Shift time |  | UINT32 | RO | 0x00000000 (0dec)
1C33:04 | Sync modes supported |  | UINT16 | RO | 0xC007 (49159dec)
1C33:05 | Minimum cycle time |  | UINT32 | RO | 0x00002710 (10000dec)
1C33:06 | Calc and copy time |  | UINT32 | RO | 0x00000000 (0dec)
1C33:07 | Minimum delay time |  | UINT32 | RO | 0x00000000 (0dec)
1C33:08 | Command |  | UINT16 | RW | 0x0000 (0dec)
1C33:09 | Maximum Delay time |  | UINT32 | RO | 0x00000000 (0dec)
1C33:0B | SM event missed counter |  | UINT16 | RO | 0x0000 (0dec)
1C33:0C | Cycle exceeded counter |  | UINT16 | RO | 0x0000 (0dec)
1C33:0D | Shift too short counter |  | UINT16 | RO | 0x0000 (0dec)
1C33:20 | Sync error |  | BOOLEAN | RO | 0x00 (0dec)


Profile-specific objects (0x6000-0xFFFF)

Commissioning/Configuration [image] EP3204 - object description and parameterization [image] Profile-specific objects (0x6000-0xFFFF)
Profile-specific objects (0x6000-0xFFFF)
The profile-specific objects have the same meaning for all EtherCAT slaves that support the profile 5001.
Index 6000: RTD Inputs Ch.1
Index (hex) | Name | Meaning |  | Data type | Flags | Default
6000:0 | RTD Inputs Ch.1 | Maximum subindex |  | UINT8 | RO | 0x11 (17dec)
6000:01 | Underrange | Is set if the value falls below the operating range of the sensor or the process record contains the lowest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6000:02 | Overrange | Is set if the value exceeds the operating range of the sensor or the process record contains the highest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6000:03 | Limit 1 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6000:05 | Limit 2 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6000:07 | Error | The error bit is set if the process data is invalid (wire breakage, overrange, underrange). |  | BOOLEAN | RO | 0x00 (0dec)
6000:0E | Sync error | Only in DC: bit is set if the slave is not able to operate synchronous with master, because it cannot keep up with the cycle time. |  | BOOLEAN | RO | 0x00 (0dec)
6000:0F | TxPDO State | Validity of the data of the associated TxPDO |  | BOOLEAN | RO | 0x00 (0dec)
 |  | 0 | valid
 |  | 1 | invalid
6000:10 | TxPDO Toggle | TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. |  | BOOLEAN | RO | 0x00 (0dec)
6000:11 | Value | Analog input date |  | INT16 | RO | 0x0000 (0dec)
Index 6010: RTD Inputs Ch.2
Index (hex) | Name | Meaning |  | Data type | Flags | Default
6010:0 | RTD Inputs Ch.2 | Maximum subindex |  | UINT8 | RO | 0x11 (17dec)
6010:01 | Underrange | Is set if the value falls below the operating range of the sensor or the process record contains the lowest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6010:02 | Overrange | Is set if the value exceeds the operating range of the sensor or the process record contains the highest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6010:03 | Limit 1 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6010:05 | Limit 2 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6010:07 | Error | The error bit is set if the process data is invalid (wire breakage, overrange, underrange). |  | BOOLEAN | RO | 0x00 (0dec)
6010:0E | Sync error | Only in DC: bit is set if the slave is not able to operate synchronous with master, because it cannot keep up with the cycle time. |  | BOOLEAN | RO | 0x00 (0dec)
6010:0F | TxPDO State | Validity of the data of the associated TxPDO |  | BOOLEAN | RO | 0x00 (0dec)
 |  | 0 | valid
 |  | 1 | invalid
6010:10 | TxPDO Toggle | TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. |  | BOOLEAN | RO | 0x00 (0dec)
6010:11 | Value | Analog input date |  | INT16 | RO | 0x0000 (0dec)
Index 6020: RTD Inputs Ch.3
Index (hex) | Name | Meaning |  | Data type | Flags | Default
6020:0 | RTD Inputs Ch.3 | Maximum subindex |  | UINT8 | RO | 0x11 (17dec)
6020:01 | Underrange | Is set if the value falls below the operating range of the sensor or the process record contains the lowest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6020:02 | Overrange | Is set if the value exceeds the operating range of the sensor or the process record contains the highest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6020:03 | Limit 1 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6020:05 | Limit 2 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6020:07 | Error | The error bit is set if the process data is invalid (cable break, overrange, underrange) |  | BOOLEAN | RO | 0x00 (0dec)
6020:0E | Sync error | Only in DC: bit is set if the slave is not able to operate synchronous with master, because it cannot keep up with the cycle time. |  | BOOLEAN | RO | 0x00 (0dec)
6020:0F | TxPDO State | Validity of the data of the associated TxPDO |  | BOOLEAN | RO | 0x00 (0dec)
 |  | 0 | valid
 |  | 1 | invalid
6020:10 | TxPDO Toggle | TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. |  | BOOLEAN | RO | 0x00 (0dec)
6020:11 | Value | Analog input date |  | INT16 | RO | 0x0000 (0dec)
Index 6030: RTD Inputs Ch.4
Index (hex) | Name | Meaning |  | Data type | Flags | Default
6030:0 | RTD Inputs Ch.4 | Maximum subindex |  | UINT8 | RO | 0x11 (17dec)
6030:01 | Underrange | Is set if the value falls below the operating range of the sensor or the process record contains the lowest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6030:02 | Overrange | Is set if the value exceeds the operating range of the sensor or the process record contains the highest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6030:03 | Limit 1 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6030:05 | Limit 2 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6030:07 | Error | The error bit is set if the process data is invalid (wire breakage, overrange, underrange). |  | BOOLEAN | RO | 0x00 (0dec)
6030:0E | Sync error | Only in DC: bit is set if the slave is not able to operate synchronous with master, because it cannot keep up with the cycle time. |  | BOOLEAN | RO | 0x00 (0dec)
6030:0F | TxPDO State | Validity of the data of the associated TxPDO |  | BOOLEAN | RO | 0x00 (0dec)
 |  | 0 | valid
 |  | 1 | invalid
6030:10 | TxPDO Toggle | TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. |  | BOOLEAN | RO | 0x00 (0dec)
6030:11 | Value | Analog input date |  | INT16 | RO | 0x0000 (0dec)
Index 800E: RTD Internal data Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
800E:0 | RTD Internal data Ch.1 | Maximum subindex | UINT8 | RO | 0x04 (4dec)
800E:01 | ADC raw value 1 | Raw value of the analog/digital converter | INT32 | RO | 0x00000000 (0dec)
800E:02 | Resistor 1 | Resistance value of the first measurement | UINT16 | RO | 0x0000 (0dec)
800E:03 | ADC raw value 2 | Raw value of the analog/digital converter | INT32 | RO | 0x00000000 (0dec)
800E:04 | Resistor 2 | Resistance value of the second measurement | UINT16 | RO | 0x0000 (0dec)
Index 800F: RTD Vendor data Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
800F:0 | RTD Vendor data Ch.1 | Maximum subindex | UINT8 | RO | 0x07 (7dec)
800F:01 | Calibration offset 3-wire | Calibration for 3-wire measurement: Offset | INT16 | RW | 0x0000 (0dec)
800F:02 | Calibration gain 3-wire | Calibration for 3-wire measurement: Gain | UINT16 | RW | 0x4000 (16384dec)
800F:03 | Calibration offset 2-wire | Calibration for 2-wire measurement: Offset | INT16 | RW | 0x0000 (0dec)
800F:04 | Calibration gain 2-wire | Calibration for 2-wire measurement: Gain | UINT16 | RW | 0x4000 (16384dec)
800F:05 | Calibration offset 4-wire | Calibration for 4-wire measurement: Offset | INT16 | RW | 0x0000 (0dec)
800F:06 | Calibration gain 4-wire | Calibration for 4-wire measurement: Gain | UINT16 | RW | 0x4000 (16384dec)
800F:07 | PGA Gain Correction | Gain correction for PT1000 measurement | INT16 | RW | 0x0000 (0dec)
Index 801E: RTD Internal data Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
801E:0 | RTD Internal data Ch.2 | Maximum subindex | UINT8 | RO | 0x04 (4dec)
801E:01 | ADC raw value 1 | Raw value of the analog/digital converter | INT32 | RO | 0x00000000 (0dec)
801E:02 | Resistor 1 | Resistance value of the first measurement | UINT16 | RO | 0x0000 (0dec)
801E:03 | ADC raw value 2 | Raw value of the analog/digital converter | INT32 | RO | 0x00000000 (0dec)
801E:04 | Resistor 2 | Resistance value of the second measurement | UINT16 | RO | 0x0000 (0dec)
Index 801F: RTD Vendor data Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
801F:0 | RTD Vendor data Ch.2 | Maximum subindex | UINT8 | RO | 0x07 (7dec)
801F:01 | Calibration offset 3-wire | Calibration for 3-wire measurement: Offset | INT16 | RW | 0x0000 (0dec)
801F:02 | Calibration gain 3-wire | Calibration for 3-wire measurement: Gain | UINT16 | RW | 0x4000 (16384dec)
801F:03 | Calibration offset 2-wire | Calibration for 2-wire measurement: Offset | INT16 | RW | 0x0000 (0dec)
801F:04 | Calibration gain 2-wire | Calibration for 2-wire measurement: Gain | UINT16 | RW | 0x4000 (16384dec)
801F:05 | Calibration offset 4-wire | Calibration for 4-wire measurement: Offset | INT16 | RW | 0x0000 (0dec)
801F:06 | Calibration gain 4-wire | Calibration for 4-wire measurement: Gain | UINT16 | RW | 0x4000 (16384dec)
801F:07 | PGA Gain Correction | Gain correction for PT1000 measurement | INT16 | RW | 0x0000 (0dec)
Index 802E: RTD Internal data Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
802E:0 | RTD Internal data Ch.3 | Maximum subindex | UINT8 | RO | 0x04 (4dec)
802E:01 | ADC raw value 1 | Raw value of the analog/digital converter | INT32 | RO | 0x00000000 (0dec)
802E:02 | Resistor 1 | Resistance value of the first measurement | UINT16 | RO | 0x0000 (0dec)
802E:03 | ADC raw value 2 | Raw value of the analog/digital converter | INT32 | RO | 0x00000000 (0dec)
802E:04 | Resistor 2 | Resistance value of the second measurement | UINT16 | RO | 0x0000 (0dec)
Index 802F: RTD Vendor data Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
802F:0 | RTD Vendor data Ch.3 | Maximum subindex | UINT8 | RO | 0x07 (7dec)
802F:01 | Calibration offset 3-wire | Calibration for 3-wire measurement: Offset | INT16 | RW | 0x0000 (0dec)
802F:02 | Calibration gain 3-wire | Calibration for 3-wire measurement: Gain | UINT16 | RW | 0x4000 (16384dec)
802F:03 | Calibration offset 2-wire | Calibration for 2-wire measurement: Offset | INT16 | RW | 0x0000 (0dec)
802F:04 | Calibration gain 2-wire | Calibration for 2-wire measurement: Gain | UINT16 | RW | 0x4000 (16384dec)
802F:05 | Calibration offset 4-wire | Calibration for 4-wire measurement: Offset | INT16 | RW | 0x0000 (0dec)
802F:06 | Calibration gain 4-wire | Calibration for 4-wire measurement: Gain | UINT16 | RW | 0x4000 (16384dec)
802F:07 | PGA Gain Correction | Gain correction for PT1000 measurement | INT16 | RW | 0x0000 (0dec)
Index 803E: RTD Internal data Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
803E:0 | RTD Internal data Ch.4 | Maximum subindex | UINT8 | RO | 0x04 (4dec)
803E:01 | ADC raw value 1 | Raw value of the analog/digital converter | INT32 | RO | 0x00000000 (0dec)
803E:02 | Resistor 1 | Resistance value of the first measurement | UINT16 | RO | 0x0000 (0dec)
803E:03 | ADC raw value 2 | Raw value of the analog/digital converter | INT32 | RO | 0x00000000 (0dec)
803E:04 | Resistor 2 | Resistance value of the second measurement | UINT16 | RO | 0x0000 (0dec)
Index 803F: RTD Vendor data Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
803F:0 | RTD Vendor data Ch.4 |  | UINT8 | RO | 0x07 (7dec)
803F:01 | Calibration offset 3-wire | Calibration for 3-wire measurement: Offset | INT16 | RW | 0x0000 (0dec)
803F:02 | Calibration gain 3-wire | Calibration for 3-wire measurement: Gain | UINT16 | RW | 0x4000 (16384dec)
803F:03 | Calibration offset 2-wire | Calibration for 2-wire measurement: Offset | INT16 | RW | 0x0000 (0dec)
803F:04 | Calibration gain 2-wire | Calibration for 2-wire measurement: Gain | UINT16 | RW | 0x4000 (16384dec)
803F:05 | Calibration offset 4-wire | Calibration for 4-wire measurement: Offset | INT16 | RW | 0x0000 (0dec)
803F:06 | Calibration gain 4-wire | Calibration for 4-wire measurement: Gain | UINT16 | RW | 0x4000 (16384dec)
803F:07 | PGA Gain Correction | Gain correction for PT1000 measurement | INT16 | RW | 0x0000 (0dec)
Index F000: Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | Maximum subindex | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index spacing for the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0004 (4dec)
Index F008: Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dec)
Index F010: Module list
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list | Maximum subindex | UINT8 | RW | 0x04 (4dec)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x00000140 (320dec)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x00000140 (320dec)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x00000140 (320dec)
F010:04 | SubIndex 004 |  | UINT32 | RW | 0x00000140 (320dec)
Index F080: Channel Enable
Index (hex) | Name | Meaning |  |  | Data type | Flags | Default
F080:0 | Channel Enable | Maximum subindex |  |  | UINT8 | RO | 0x04 (4dec)
F080:01 | SubIndex 001 | 0 | Channel 1 disabled | (from hardware version 01 deactivated channels are not measured, and the green LED R for these channels goes out) | BOOLEAN | RW | 0x01 (1dec)
 |  | 1 | Channel 1 enabled
F080:02 | SubIndex 002 | 0 | Channel 2 disabled |  | BOOLEAN | RW | 0x01 (1dec)
 |  | 1 | Channel 2 enabled
F080:03 | SubIndex 003 | 0 | Channel 3 disabled |  | BOOLEAN | RW | 0x01 (1dec)
 |  | 1 | Channel 3 enabled
F080:04 | SubIndex 004 | 0 | Channel 4 disabled |  | BOOLEAN | RW | 0x01 (1dec)
 |  | 1 | Channel 5 enabled


EP3314 - Settings

Commissioning/Configuration [image] EP3314 - Settings
EP3314 - Settings
Additional information
•
Presentation, index 0x80n0:02
•
Siemens bits, index 0x80n0:05
•
Underrange, Overrange
•
Filter
•
Limit 1 and Limit 2
•
Calibration


Presentation, index 0x80n0:02

Commissioning/Configuration [image] EP3314 - Settings [image] Presentation, index 0x80n0:02
Presentation, index 0x80n0:02
In the delivery state, the measured value is output in increments of 1/10° C in two's complement format (signed integer).
Index 0x80n0:02 offers the possibility to change the method of representation of the measured value.
Measured value | Output (hexadecimal) | Output (signed integer, decimal)
-200.0 °C | 0nF830 | -2000
-100.0 °C | 0nFC18 | -1000
-0.1 °C | 0nFFFF | -1
0.0 °C | 0n0000 | 0
0.1 °C | 0n0001 | 1
100.0 °C | 0n03E8 | 1000
200.0 °C | 0n07D0 | 2000
500.0 °C | 0x1388 | 5000
850.0 °C | 0x2134 | 8500
1000.0 °C | 0x2170 | 10000
Table 2: Output of measured value and process data
▪
Signed Integer:
The measured value is presented in two’s complement format.
Maximum presentation range for 16 bit = -32768 .. +32767
–
Example:
–
1000 0000 0000 0000bin = 0x8000hex = - 32768dec
–
1111 1111 1111 1110bin = 0nFFFEhex = - 2dec
–
1111 1111 1111 1111bin = 0nFFFFhex = - 1dec
–
0000 0000 0000 0001bin = 0n0001hex = +1dec
–
0000 0000 0000 0010bin = 0n0002hex = +2dec
–
0111 1111 1111 1111bin = 0x7FFFhex = +32767dec
▪
Absolute value with MSB as sign:
The measured value is output in magnitude-sign format.
Maximum presentation range for 16 bit = -32767 .. +32767
–
Example:
–
1111 1111 1111 1111bin = 0nFFFFhex = - 32767dec
–
1000 0000 0000 0010bin = 0x8002hex = - 2dec
–
1000 0000 0000 0001bin = 0x8001hex = - 1dec
–
0000 0000 0000 0001bin = 0n0001hex = +1dec
–
0000 0000 0000 0010bin = 0n0002hex = +2dec
–
0111 1111 1111 1111bin = 0x7FFFhex = +32767dec
▪
High resolution (1/100 C°):
The measured value is output in 1/100 °C steps.


Siemens bits, index 0x80n0:05

Commissioning/Configuration [image] EP3314 - Settings [image] Siemens bits, index 0x80n0:05
Siemens bits, index 0x80n0:05
If the bit in index 0x80n0:05 is set, status displays are shown for the lowest 3 bits. In the error case "overrange" or "underrange", bit 0 is set.


Underrange, Overrange

Commissioning/Configuration [image] EP3314 - Settings [image] Underrange, Overrange
Underrange, Overrange
Undershoot and overshoot of the measuring range (underrange, overrange), index 0x60n0:02, 0x60n0:03
▪
Uk > Ukmax: Index 0x60n0:02 and index 0x60n0:07 (overrange and error bit) are set. The linearization of the characteristic curve is continued with the coefficients of the overrange limit up to the limit stop of the A/D converter or to the maximum value of 0x7FFF.
▪
Uk < Ukmax: Index 0x60n0:01 and index 0x60n0:07 (underrange and error bit) are set. The linearization of the characteristic curve is continued with the coefficients of the underrange limit up to the limit stop of the A/D converter or to the minimum value of 0x8000.
For overrange or underrange the red error LED is switched on.


Filter

Commissioning/Configuration [image] EP3314 - Settings [image] Filter
Filter
Each analog input has a digital filter. The filter is a notch filter.
The filter is always active; it cannot be disabled. None of the "Enable Filter" parameters have any effect:
0x8000:06, 0x8010:06, 0x8020:06, 0x8030:06.
Configuring the filter
You can set the filter frequency in the parameter 0x8000:15 "Filter Settings". This parameter affects all channels. The "Filter Settings" parameters of the other channels have no effect:
0x8010:15, 0x8020:15, 0x8030:15.
Influence on the conversion time
The higher the filter frequency, the shorter the conversion time.


Limit 1 and Limit 2

Commissioning/Configuration [image] EP3314 - Settings [image] Limit 1 and Limit 2
Limit 1 and Limit 2
Limit 1 and limit 2, index 0x80n0:13, index 0x80n0:14
A temperature range can be set that is limited by the values in the indices 0x80n0:13 and 0x80n0:14. If the limit values are overshot, the bits in indices 0x80n0:07 and 0x80n0:08 are set.
The temperature value is entered with a resolution of 0.1 °C.
Example:
Limit 1= 30 °C
Value index 0x80n0:13 = 300


Calibration

Commissioning/Configuration [image] EP3314 - Settings [image] Calibration
Calibration
Vendor calibration, index 0x80n0:0B
The vendor calibration is enabled via index 0x80n0:0B. Parameterization takes place via the indices
▪
0x80nF:01
Thermocouple offset (vendor calibration)
▪
0x80nF:02
Thermocouple gain (vendor calibration)
▪
0x80nF:03
Reference point offset [Pt1000] (vendor calibration)
▪
0x80nF:04
Reference point gain [Pt1000] (vendor calibration)
Vendor and user calibration
User calibration (index 0x80n0:0A) should only be performed instead of the vendor calibration (index 0x80n0:0B), but this is generally only necessary in exceptional cases.
User calibration , index 0x80n0:0A
User calibration is enabled via index 0x80n0:0A. Parameterization takes place via the indices
▪
0x80n0:17
Thermocouple offset (index 0x80nF:01, user calibration)
▪
0x80n0:18
Thermocouple gain (index 0x80nF:02, user calibration)
User scaling, index 0x80n0:01
The user scaling is enabled via index 0x80n0:01. Parameterization takes place via the indices
▪
0x80n0:11
User scaling offset

The offset describes a vertical shift of the characteristic curve by a linear amount.
At a resolution of 0.1°, 1 digit(dec) corresponds to an increase in measured value by 0.1°
At a resolution of 0.01°, 1 digit(dec) corresponds to an increase in measured value by 0.01
▪
0x80n0:12
User scaling gain
▪

The default value of 65536(dec) corresponds to gain = 1.
The new gain value for 2-point user calibration after offset calibration is determined as follows:

Gain_new = reference temperature / measured value x 65536(dec)
Calculation of process data
The concept "calibration", which has historical roots at Beckhoff, is used here even if it has nothing to do with the deviation statements of a calibration certificate. Actually, this is a description of the vendor or customer calibration data/adjustment data used by the device during operation in order to maintain the assured measuring accuracy.
The box constantly records measured values and saves the raw values from its A/D converter in the ADC raw value objects 0x80nE:01, 0x80nE:02. After each recording of the analog signal, the correction calculation takes place with the vendor and user calibration data as well as the user scaling, if these are activated (see following picture).
Calculation of process data
Calculation | Designation
XADC | Output of the A/D converter
XF | Output value after the filter
YH = (XADC – BH) x AH x 2-14 | Measured value after vendor calibration,
YA = (YH – BA) x AA x 2-14 | Measured value after vendor and user calibration
YS= YA x AS x 2-16 + BS | Measured value following user scaling
Legend
Name | Designation | Index
XADC | Output value of the A/D converter | 0x80nE:01
XF | Output value after the filter | -
BH | Vendor calibration offset (not changeable) | 0x80nF:01
AH | Vendor calibration gain (not changeable) | 0x80nF:02
BA | User calibration offset (can be activated via index 0x80n0:0A) | 0x80n0:17
AA | User calibration gain (can be activated via index 0x80n0:0A) | 0x80n0:18
BS | User scaling offset (can be activated via index 0x80n0:01) | 0x80n0:11
AS | User scaling gain (can be activated via index 0x80n0:01) | 0x80n0:12
YS | Process data for controller | -
Measurement result
The accuracy of the result may be reduced if the measured value is smaller than 32767 / 4 due to one or more multiplications.


EP3314 - object overview

Commissioning/Configuration [image] EP3314 - object overview
EP3314 - object overview
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Index (hex) |  | Name | Flags | Default value
1000 |  | Device type | RO | 0x014A1389 (21631881dec)
1008 |  | Device name | RO | EP3314-0002
1009 |  | Hardware version | RO | 00
100A |  | Software version | RO | 01
1011:0 | Subindex | Restore default parameters | RO | 0x01 (1dec)
 | 1011:01 | SubIndex 001 | RW | 0x00000000 (0dec)
1018:0 | Subindex | Identity | RO | 0x04 (4dec)
 | 1018:01 | Vendor ID | RO | 0x00000002 (2dec)
 | 1018:02 | Product code | RO | 0x0CF24052 (217202770dec)
 | 1018:03 | Revision | RO | 0x00100002 (1048578dec)
 | 1018:04 | Serial number | RO | 0x00000000 (0dec)
10F0:0 | Subindex | Backup parameter handling | RO | 0x01 (1dec)
 | 10F0:01 | Checksum | RO | 0x00000000 (0dec)
1600:0 | Subindex | TC RxPDO-Map Outputs Ch.1 | RO | 0x01 (1dec)
 | 1600:01 | SubIndex 001 | RO | 0x7000:11, 16
1601:0 | Subindex | TC RxPDO-Map Outputs Ch.2 | RO | 0x01 (1dec)
 | 1601:01 | SubIndex 001 | RO | 0x7010:11, 16
1602:0 | Subindex | TC RxPDO-Map Outputs Ch.3 | RO | 0x01 (1dec)
 | 1602:01 | SubIndex 001 | RO | 0x7020:11, 16
1603:0 | Subindex | TC RxPDO-Map Outputs Ch.4 | RO | 0x01 (1dec)
 | 1603:01 | SubIndex 001 | RO | 0x7030:11, 16
1A00:0 | Subindex | TC TxPDO-Map TCInputs Ch.1 | RO | 0x0A (10dec)
 | 1A00:01 | SubIndex 001 | RO | 0x6000:01, 1
 | 1A00:02 | SubIndex 002 | RO | 0x6000:02, 1
 | 1A00:03 | SubIndex 003 | RO | 0x6000:03, 2
 | 1A00:04 | SubIndex 004 | RO | 0x6000:05, 2
 | 1A00:05 | SubIndex 005 | RO | 0x6000:07, 1
 | 1A00:06 | SubIndex 006 | RO | 0x0000:00, 6
 | 1A00:07 | SubIndex 007 | RO | 0x6000:0E, 1
 | 1A00:08 | SubIndex 008 | RO | 0x1800:07, 1
 | 1A00:09 | SubIndex 009 | RO | 0x1800:09, 1
 | 1A00:0A | SubIndex 010 | RO | 0x6000:11, 16
Index (hex) |  | Name | Flags | Default value
1A01:0 | Subindex | TC TxPDO-Map TCInputs Ch.2 | RO | 0x0A (10dec)
 | 1A01:01 | SubIndex 001 | RO | 0x6010:01, 1
 | 1A01:02 | SubIndex 002 | RO | 0x6010:02, 1
 | 1A01:03 | SubIndex 003 | RO | 0x6010:03, 2
 | 1A01:04 | SubIndex 004 | RO | 0x6010:05, 2
 | 1A01:05 | SubIndex 005 | RO | 0x6010:07, 1
 | 1A01:06 | SubIndex 006 | RO | 0x0000:00, 6
 | 1A01:07 | SubIndex 007 | RO | 0x6010:0E, 1
 | 1A01:08 | SubIndex 008 | RO | 0x1801:07, 1
 | 1A01:09 | SubIndex 009 | RO | 0x1801:09, 1
 | 1A01:0A | SubIndex 010 | RO | 0x6010:11, 16
1A02:0 | Subindex | TC TxPDO-Map TCInputs Ch.3 | RO | 0x0A (10dec)
 | 1A02:01 | SubIndex 001 | RO | 0x6020:01, 1
 | 1A02:02 | SubIndex 002 | RO | 0x6020:02, 1
 | 1A02:03 | SubIndex 003 | RO | 0x6020:03, 2
 | 1A02:04 | SubIndex 004 | RO | 0x6020:05, 2
 | 1A02:05 | SubIndex 005 | RO | 0x6020:07, 1
 | 1A02:06 | SubIndex 006 | RO | 0x0000:00, 6
 | 1A02:07 | SubIndex 007 | RO | 0x6020:0E, 1
 | 1A02:08 | SubIndex 008 | RO | 0x1802:07, 1
 | 1A02:09 | SubIndex 009 | RO | 0x1802:09, 1
 | 1A02:0A | SubIndex 010 | RO | 0x6020:11, 16
1A03:0 | Subindex | TC TxPDO-Map TCInputs Ch.4 | RO | 0x0A (10dec)
 | 1A03:01 | SubIndex 001 | RO | 0x6030:01, 1
 | 1A03:02 | SubIndex 002 | RO | 0x6030:02, 1
 | 1A03:03 | SubIndex 003 | RO | 0x6030:03, 2
 | 1A03:04 | SubIndex 004 | RO | 0x6030:05, 2
 | 1A03:05 | SubIndex 005 | RO | 0x6030:07, 1
 | 1A03:06 | SubIndex 006 | RO | 0x0000:00, 6
 | 1A03:07 | SubIndex 007 | RO | 0x6030:0E, 1
 | 1A03:08 | SubIndex 008 | RO | 0x1803:07, 1
 | 1A03:09 | SubIndex 009 | RO | 0x1803:09, 1
 | 1A03:0A | SubIndex 010 | RO | 0x6030:11, 16
1C00:0 | Subindex | Sync manager type | RO | 0x04 (4dec)
 | 1C00:01 | SubIndex 001 | RO | 0x01 (1dec)
 | 1C00:02 | SubIndex 002 | RO | 0x02 (2dec)
 | 1C00:03 | SubIndex 003 | RO | 0x03 (3dec)
 | 1C00:04 | SubIndex 004 | RO | 0x04 (4dec)
Index (hex) |  | Name | Flags | Default value
1C12:0 | Subindex | RxPDO assign | RW | 0x00 (0dec)
 | 1C12:01 | SubIndex 001 | RW | 0x0000 (0dec)
 | 1C12:02 | SubIndex 002 | RW | 0x0000 (0dec)
 | 1C12:03 | SubIndex 003 | RW | 0x0000 (0dec)
 | 1C12:04 | SubIndex 004 | RW | 0x0000 (0dec)
1C13:0 | Subindex | TxPDO assign | RW | 0x04 (4dec)
 | 1C13:01 | SubIndex 001 | RW | 0x1A00 (6656dec)
 | 1C13:02 | SubIndex 002 | RW | 0x1A01 (6657dec)
 | 1C13:03 | SubIndex 003 | RW | 0x1A02 (6658dec)
 | 1C13:04 | SubIndex 004 | RW | 0x1A03 (6659dec)
1C32:0 | Subindex | SM output parameter | RO | 0x20 (32dec)
 | 1C32:01 | Sync mode | RW | 0x0000 (0dec)
 | 1C32:02 | Cycle time | RW | 0x000F4240 (1000000dec)
 | 1C32:03 | Shift time | RO | 0x00000000 (0dec)
 | 1C32:04 | Sync modes supported | RO | 0xC007 (49159dec)
 | 1C32:05 | Minimum cycle time | RO | 0x00002710 (10000dec)
 | 1C32:06 | Calc and copy time | RO | 0x00000000 (0dec)
 | 1C32:07 | Minimum delay time | RO | 0x00000000 (0dec)
 | 1C32:08 | Command | RW | 0x0000 (0dec)
 | 1C32:09 | Maximum Delay time | RO | 0x00000000 (0dec)
 | 1C32:0B | SM event missed counter | RO | 0x0000 (0dec)
 | 1C32:0C | Cycle exceeded counter | RO | 0x0000 (0dec)
 | 1C32:0D | Shift too short counter | RO | 0x0000 (0dec)
 | 1C32:20 | Sync error | RO | 0x00 (0dec)
1C33:0 | Subindex | SM input parameter | RO | 0x20 (32dec)
 | 1C33:01 | Sync mode | RW | 0x0000 (0dec)
 | 1C33:02 | Cycle time | RW | 0x000F4240 (1000000dec)
 | 1C33:03 | Shift time | RO | 0x00000000 (0dec)
 | 1C33:04 | Sync modes supported | RO | 0xC007 (49159dec)
 | 1C33:05 | Minimum cycle time | RO | 0x00002710 (10000dec)
 | 1C33:06 | Calc and copy time | RO | 0x00000000 (0dec)
 | 1C33:07 | Minimum delay time | RO | 0x00000000 (0dec)
 | 1C33:08 | Command | RW | 0x0000 (0dec)
 | 1C33:09 | Maximum Delay time | RO | 0x00000000 (0dec)
 | 1C33:0B | SM event missed counter | RO | 0x0000 (0dec)
 | 1C33:0C | Cycle exceeded counter | RO | 0x0000 (0dec)
 | 1C33:0D | Shift too short counter | RO | 0x0000 (0dec)
 | 1C33:20 | Sync error | RO | 0x00 (0dec)
6000:0 | Subindex | TC Inputs Ch.1 | RO | 0x11 (17dec)
 | 6000:01 | Underrange | RO | 0x00 (0dec)
 | 6000:02 | Overrange | RO | 0x00 (0dec)
 | 6000:03 | Limit 1 | RO | 0x00 (0dec)
 | 6000:05 | Limit 2 | RO | 0x00 (0dec)
 | 6000:07 | Error | RO | 0x00 (0dec)
 | 6000:0E | Sync error | RO | 0x00 (0dec)
 | 6000:0F | TxPDO State | RO | 0x00 (0dec)
 | 6000:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6000:11 | Value | RO | 0x0000 (0dec)
Index (hex) |  | Name | Flags | Default value
6010:0 | Subindex | TC Inputs Ch.2 | RO | 0x11 (17dec)
 | 6010:01 | Underrange | RO | 0x00 (0dec)
 | 6010:02 | Overrange | RO | 0x00 (0dec)
 | 6010:03 | Limit 1 | RO | 0x00 (0dec)
 | 6010:05 | Limit 2 | RO | 0x00 (0dec)
 | 6010:07 | Error | RO | 0x00 (0dec)
 | 6010:0E | Sync error | RO | 0x00 (0dec)
 | 6010:0F | TxPDO State | RO | 0x00 (0dec)
 | 6010:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6010:11 | Value | RO | 0x0000 (0dec)
6020:0 | Subindex | TC Inputs Ch.3 | RO | 0x11 (17dec)
 | 6020:01 | Underrange | RO | 0x00 (0dec)
 | 6020:02 | Overrange | RO | 0x00 (0dec)
 | 6020:03 | Limit 1 | RO | 0x00 (0dec)
 | 6020:05 | Limit 2 | RO | 0x00 (0dec)
 | 6020:07 | Error | RO | 0x00 (0dec)
 | 6020:0E | Sync error | RO | 0x00 (0dec)
 | 6020:0F | TxPDO State | RO | 0x00 (0dec)
 | 6020:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6020:11 | Value | RO | 0x0000 (0dec)
6030:0 | Subindex | TC Inputs Ch.4 | RO | 0x11 (17dec)
 | 6030:01 | Underrange | RO | 0x00 (0dec)
 | 6030:02 | Overrange | RO | 0x00 (0dec)
 | 6030:03 | Limit 1 | RO | 0x00 (0dec)
 | 6030:05 | Limit 2 | RO | 0x00 (0dec)
 | 6030:07 | Error | RO | 0x00 (0dec)
 | 6030:0E | Sync error | RO | 0x00 (0dec)
 | 6030:0F | TxPDO State | RO | 0x00 (0dec)
 | 6030:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6030:11 | Value | RO | 0x0000 (0dec)
7000:0 | Subindex | TC Outputs Ch.1 | RO | 0x11 (17dec)
 | 7000:11 | CJCompensation | RO | 0x0000 (0dec)
7010:0 | Subindex | TC Outputs Ch.2 | RO | 0x11 (17dec)
 | 7010:11 | CJCompensation | RO | 0x0000 (0dec)
7020:0 | Subindex | TC Outputs Ch.3 | RO | 0x11 (17dec)
 | 7020:11 | CJCompensation | RO | 0x0000 (0dec)
7030:0 | Subindex | TC Outputs Ch.4 | RO | 0x11 (17dec)
 | 7030:11 | CJCompensation | RO | 0x0000 (0dec)
Index (hex) |  | Name | Flags | Default value
8000:0 | Subindex | TC Settings Ch.1 | RW | 0x1B (27dec)
 | 8000:01 | Enable user scale | RW | 0x00 (0dec)
 | 8000:02 | Presentation | RW | 0x00 (0dec)
 | 8000:05 | Siemens bits | RW | 0x00 (0dec)
 | 8000:06 | Enable filter | RW | 0x00 (0dec)
 | 8000:07 | Enable limit 1 | RW | 0x00 (0dec)
 | 8000:08 | Enable limit 2 | RW | 0x00 (0dec)
 | 8000:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8000:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 8000:0C | Coldjunction compensation | RW | 0x00 (0dec)
 | 8000:0E | Swap limit bits | RW | 0x00 (0dec)
 | 8000:11 | User scale offset | RW | 0x0000 (0dec)
 | 8000:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 8000:13 | Limit 1 | RW | 0x0000 (0dec)
 | 8000:14 | Limit 2 | RW | 0x0000 (0dec)
 | 8000:15 | Filter settings | RW | 0x0000 (0dec)
 | 8000:16 | Calibration interval | RW | 0x0000 (0dec)
 | 8000:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8000:18 | User calibration gain | RW | 0x4000 (16384dec)
 | 8000:19 | Sensor type | RW | 0x0000 (0dec)
 | 8000:1B | Wire calibration 1/32 Ohm | RW | 0x0000 (0dec)
800E:0 | Subindex | TC Internal data Ch.1 | RO | 0x05 (5dec)
 | 800E:01 | ADC raw value TC | RO | 0x00000000 (0dec)
 | 800E:02 | ADC raw value PT1000 | RO | 0x00000000 (0dec)
 | 800E:03 | CJ temperature | RO | 0x0000 (0dec)
 | 800E:04 | CJ voltage | RO | 0x0000 (0dec)
 | 800E:05 | CJ resistor | RO | 0x0000 (0dec)
800F:0 | Subindex | TC Vendor data Ch.1 | RW | 0x04 (4dec)
 | 800F:01 | Calibration offset TC | RW | 0x0000 (0dec)
 | 800F:02 | Calibration gain TC | RW | 0x4000 (16384dec)
 | 800F:03 | Calibration offset CJ | RW | 0x0000 (0dec)
 | 800F:04 | Calibration gain CJ | RW | 0x4000 (16384dec)
8010:0 | Subindex | TC Settings Ch.2 | RW | 0x1B (27dec)
 | 8010:01 | Enable user scale | RW | 0x00 (0dec)
 | 8010:02 | Presentation | RW | 0x00 (0dec)
 | 8010:05 | Siemens bits | RW | 0x00 (0dec)
 | 8010:06 | Enable filter | RW | 0x00 (0dec)
 | 8010:07 | Enable limit 1 | RW | 0x00 (0dec)
 | 8010:08 | Enable limit 2 | RW | 0x00 (0dec)
 | 8010:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8010:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 8010:0C | Coldjunction compensation | RW | 0x00 (0dec)
 | 8010:0E | Swap limit bits | RW | 0x00 (0dec)
 | 8010:11 | User scale offset | RW | 0x0000 (0dec)
 | 8010:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 8010:13 | Limit 1 | RW | 0x0000 (0dec)
 | 8010:14 | Limit 2 | RW | 0x0000 (0dec)
 | 8010:15 | Filter settings | RW | 0x0000 (0dec)
 | 8010:16 | Calibration interval | RW | 0x0000 (0dec)
 | 8010:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8010:18 | User calibration gain | RW | 0x4000 (16384dec)
 | 8010:19 | Sensor type | RW | 0x0000 (0dec)
 | 8010:1B | Wire calibration 1/32 Ohm | RW | 0x0000 (0dec)
Index (hex) |  | Name | Flags | Default value
801E:0 | Subindex | TC Internal data Ch.2 | RO | 0x05 (5dec)
 | 801E:01 | ADC raw value TC | RO | 0x00000000 (0dec)
 | 801E:02 | ADC raw value PT1000 | RO | 0x00000000 (0dec)
 | 801E:03 | CJ temperature | RO | 0x0000 (0dec)
 | 801E:04 | CJ voltage | RO | 0x0000 (0dec)
 | 801E:05 | CJ resistor | RO | 0x0000 (0dec)
801F:0 | Subindex | TC Vendor data Ch.2 | RW | 0x04 (4dec)
 | 801F:01 | Calibration offset TC | RW | 0x0000 (0dec)
 | 801F:02 | Calibration gain TC | RW | 0x4000 (16384dec)
 | 801F:03 | Calibration offset CJ | RW | 0x0000 (0dec)
 | 801F:04 | Calibration gain CJ | RW | 0x4000 (16384dec)
8020:0 | Subindex | TC Settings Ch.3 | RW | 0x1B (27dec)
 | 8020:01 | Enable user scale | RW | 0x00 (0dec)
 | 8020:02 | Presentation | RW | 0x00 (0dec)
 | 8020:05 | Siemens bits | RW | 0x00 (0dec)
 | 8020:06 | Enable filter | RW | 0x00 (0dec)
 | 8020:07 | Enable limit 1 | RW | 0x00 (0dec)
 | 8020:08 | Enable limit 2 | RW | 0x00 (0dec)
 | 8020:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8020:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 8020:0C | Coldjunction compensation | RW | 0x00 (0dec)
 | 8020:0E | Swap limit bits | RW | 0x00 (0dec)
 | 8020:11 | User scale offset | RW | 0x0000 (0dec)
 | 8020:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 8020:13 | Limit 1 | RW | 0x0000 (0dec)
 | 8020:14 | Limit 2 | RW | 0x0000 (0dec)
 | 8020:15 | Filter settings | RW | 0x0000 (0dec)
 | 8020:16 | Calibration interval | RW | 0x0000 (0dec)
 | 8020:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8020:18 | User calibration gain | RW | 0x4000 (16384dec)
 | 8020:19 | Sensor type | RW | 0x0000 (0dec)
 | 8020:1B | Wire calibration 1/32 Ohm | RW | 0x0000 (0dec)
802E:0 | Subindex | TC Internal data Ch.3 | RO | 0x05 (5dec)
 | 802E:01 | ADC raw value TC | RO | 0x00000000 (0dec)
 | 802E:02 | ADC raw value PT1000 | RO | 0x00000000 (0dec)
 | 802E:03 | CJ temperature | RO | 0x0000 (0dec)
 | 802E:04 | CJ voltage | RO | 0x0000 (0dec)
 | 802E:05 | CJ resistor | RO | 0x0000 (0dec)
802F:0 | Subindex | TC Vendor data Ch.3 | RW | 0x04 (4dec)
 | 802F:01 | Calibration offset TC | RW | 0x0000 (0dec)
 | 802F:02 | Calibration gain TC | RW | 0x4000 (16384dec)
 | 802F:03 | Calibration offset CJ | RW | 0x0000 (0dec)
 | 802F:04 | Calibration gain CJ | RW | 0x4000 (16384dec)
Index (hex) |  | Name | Flags | Default value
8030:0 | Subindex | TC Settings Ch.4 | RW | 0x1B (27dec)
 | 8030:01 | Enable user scale | RW | 0x00 (0dec)
 | 8030:02 | Presentation | RW | 0x00 (0dec)
 | 8030:05 | Siemens bits | RW | 0x00 (0dec)
 | 8030:06 | Enable filter | RW | 0x00 (0dec)
 | 8030:07 | Enable limit 1 | RW | 0x00 (0dec)
 | 8030:08 | Enable limit 2 | RW | 0x00 (0dec)
 | 8030:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8030:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 8030:0C | Coldjunction compensation | RW | 0x00 (0dec)
 | 8030:0E | Swap limit bits | RW | 0x00 (0dec)
 | 8030:11 | User scale offset | RW | 0x0000 (0dec)
 | 8030:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 8030:13 | Limit 1 | RW | 0x0000 (0dec)
 | 8030:14 | Limit 2 | RW | 0x0000 (0dec)
 | 8030:15 | Filter settings | RW | 0x0000 (0dec)
 | 8030:16 | Calibration interval | RW | 0x0000 (0dec)
 | 8030:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8030:18 | User calibration gain | RW | 0x4000 (16384dec)
 | 8030:19 | Sensor type | RW | 0x0000 (0dec)
 | 8030:1B | Wire calibration 1/32 Ohm | RW | 0x0000 (0dec)
803E:0 | Subindex | TC Internal data Ch.4 | RO | 0x05 (5dec)
 | 803E:01 | ADC raw value TC | RO | 0x00000000 (0dec)
 | 803E:02 | ADC raw value PT1000 | RO | 0x00000000 (0dec)
 | 803E:03 | CJ temperature | RO | 0x0000 (0dec)
 | 803E:04 | CJ voltage | RO | 0x0000 (0dec)
 | 803E:05 | CJ resistor | RO | 0x0000 (0dec)
803F:0 | Subindex | TC Vendor data Ch.4 | RW | 0x04 (4dec)
 | 803F:01 | Calibration offset TC | RW | 0x0000 (0dec)
 | 803F:02 | Calibration gain TC | RW | 0x4000 (16384dec)
 | 803F:03 | Calibration offset CJ | RW | 0x0000 (0dec)
 | 803F:04 | Calibration gain CJ | RW | 0x4000 (16384dec)
F000:0 | Subindex | Modular device profile | RO | 0x02 (2dec)
 | F000:01 | Module index distance | RO | 0x0010 (16dec)
 | F000:02 | Maximum number of modules | RO | 0x0004 (4dec)
F008 |  | Code word | RW | 0x00000000 (0dec)
F010:0 | Subindex | Module list | RW | 0x04 (4dec)
 | F010:01 | SubIndex 001 | RW | 0x0000014A (330dec)
 | F010:02 | SubIndex 002 | RW | 0x0000014A (330dec)
 | F010:03 | SubIndex 003 | RW | 0x0000014A (330dec)
 | F010:04 | SubIndex 004 | RW | 0x0000014A (330dec)
F080:0 | Subindex | Channel Enable | RO | 0x04 (4dec)
 | F080:01 | SubIndex 001 | RW | 0xFF (255dec)
 | F080:02 | SubIndex 002 | RW | 0xFF (255dec)
 | F080:03 | SubIndex 003 | RW | 0xFF (255dec)
 | F080:04 | SubIndex 004 | RW | 0xFF (255dec)
Key
Flags:
RO (Read Only): this object can be read only
RW (Read/Write): this object can be read and written to


EP3314 - object description and parameterization

Commissioning/Configuration [image] EP3314 - object description and parameterization
EP3314 - object description and parameterization
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Parameterization via the CoE list (CAN over EtherCAT)
The EtherCAT device is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs).
Introduction
The CoE overview contains objects for different intended applications:
▪
Objects required for parameterization during commissioning
▪
Objects intended for regular operation, e.g. through ADS access
▪
Objects for indicating internal settings (may be fixed)
▪
Further profile-specific objects indicating inputs, outputs and status information
The following section first describes the objects required for normal operation, followed by a complete overview of missing objects.
Additional information
•
Objects to be parameterized during commissioning
•
Objects for regular operation
•
Standard objects (0x1000-0x1FFF)
•
Profile-specific objects (0x6000-0xFFFF)


Objects to be parameterized during commissioning

Commissioning/Configuration [image] EP3314 - object description and parameterization [image] Objects to be parameterized during commissioning
Objects to be parameterized during commissioning
Index 1011: Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default parameters | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" in the set value dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)
Index 8000: TC Settings Ch.1
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8000:0 | TC Settings Ch.1 | Maximum subindex |  | UINT8 | RO | 0x1B (27dec)
8000:01 | Enable user scale | Activates user scaling |  | BOOLEAN | RW | 0x00 (0dec)
8000:02 | Presentation | Presentation of the measured value |  | BIT3 | RW | 0x00 (0dec)
 |  | 0 | Signed, in two's complement
 |  | 1 | Most significant bit as sign
 |  | 2 | High-resolution (1/100 °C steps)
8000:05 | Siemens bits | The S5 bits are displayed in the three low-order bits |  | BOOLEAN | RW | 0x00 (0dec)
8000:06 | Enable filter | This parameter is without effect. The filter is always enabled. |  | BOOLEAN | RW | 0x00 (0dec)
8000:07 | Enable limit 1 | Activates limit check for limit 1 |  | BOOLEAN | RW | 0x00 (0dec)
8000:08 | Enable limit 2 | Activates limit check for limit 2 |  | BOOLEAN | RW | 0x00 (0dec)
8000:0A | Enable user calibration | Activates user calibration |  | BOOLEAN | RW | 0x00 (0dec)
8000:0B | Enable vendor calibration | Activates vendor calibration |  | BOOLEAN | RW | 0x01 (1dec)
8000:0C | Cold junction compensation | Cold junction compensation |  | BIT2 | RW | 0x00 (0dec)
 |  | 0 | Cold junction compensation takes place via the PT-1000 in the plug connector.
 |  | 1 | Cold junction compensation is not active.
 |  | 2 | Cold junction compensation takes place via the process data.
 |  | 3 | Same as value 0.
8000:0E | Swap limit bits | Swaps the two limit bits, in order to achieve compatibility with older hardware versions. |  | BOOLEAN | RW | 0x00 (0dec)
8000:11 | User scale offset | User scaling: Offset |  | INT16 | RW | 0x0000 (0dec)
8000:12 | User scale gain | User scaling: Gain |  | INT32 | RW | 0x00010000 (65536dec)
8000:13 | Limit 1 | Value for limit 1 |  | INT16 | RW | 0x0000 (0dec)
8000:14 | Limit 2 | Value for limit 2 |  | INT16 | RW | 0x0000 (0dec)
8000:15 | Filter settings | Filter settings (Ch1. applies to all channels) |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 50 Hz
 |  | 1 | 60 Hz
 |  | 2 | 100 Hz
 |  | 3 | 500 Hz
 |  | 4 | 1 kHz,
 |  | 5 | 2 kHz
 |  | 6 | 3.75 kHz
 |  | 7 | 7.5 kHz
 |  | 8 | 15 kHz
 |  | 9 | 30 kHz
 |  | 10 | 5 Hz
 |  | 11 | 10 Hz
8000:16 | Calibration interval | reserved |  | UINT16 | RW | 0x0000 (0dec)
8000:17 | User calibration offset | User calibration: Offset |  | INT16 | RW | 0x0000 (0dec)
8000:18 | User calibration gain | User calibration: Gain |  | UINT16 | RW | 0x4000 (16384dec)
Index 8000: TC Settings Ch.1
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8000:19 | Sensor type | Thermocouple |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | Type K -200 °C to 1370 °C
 |  | 1 | Type J -100°C to 1200°C
 |  | 2 | Type L 0°C to 900°C
 |  | 3 | Type E -100°C to 1000°C
 |  | 4 | Type T -200°C to 400°C
 |  | 5 | Type N -100°C to 1300°C
 |  | 6 | Type U 0°C to 600°C
 |  | 7 | Type B 600°C to 1800°C
 |  | 8 | Type R 0°C to 1767°C
 |  | 9 | Type S 0°C to 1760°C
 |  | 10 | Type C 0°C to 2320°C
 |  | 100 | ± 30 mV (1 µV resolution)
 |  | 101 | ± 60 mV (2 µV resolution)
 |  | 102 | ± 75 mV (4 µV resolution)
8000:1B | Wire calibration 1/32 ohm | Only for 2-wire measurements: contains the resistance of the supply line for the temperature sensor (in 1/32 ohm). |  | INT16 | RW | 0x0000 (0dec)
Index 8010: TC Settings Ch.2
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8010:0 | TC Settings Ch.2 | Maximum subindex |  | UINT8 | RO | 0x1B (27dec)
8010:01 | Enable user scale | Activates user scaling |  | BOOLEAN | RW | 0x00 (0dec)
8010:02 | Presentation | Presentation of the measured value |  | BIT3 | RW | 0x00 (0dec)
 |  | 0 | Signed, in two's complement
 |  | 1 | Most significant bit as sign
 |  | 2 | High-resolution (1/100 °C steps)
8010:05 | Siemens bits | The S5 bits are displayed in the three low-order bits |  | BOOLEAN | RW | 0x00 (0dec)
8010:06 | Enable filter | This parameter is without effect. The filter is always enabled. |  | BOOLEAN | RW | 0x00 (0dec)
8010:07 | Enable limit 1 | Activates limit check for limit 1 |  | BOOLEAN | RW | 0x00 (0dec)
8010:08 | Enable limit 2 | Activates limit check for limit 2 |  | BOOLEAN | RW | 0x00 (0dec)
8010:0A | Enable user calibration | Activates user calibration |  | BOOLEAN | RW | 0x00 (0dec)
8010:0B | Enable vendor calibration | Activates vendor calibration |  | BOOLEAN | RW | 0x01 (1dec)
8010:0C | Cold junction compensation | Cold junction compensation |  | BIT2 | RW | 0x00 (0dec)
 |  | 0 | Cold junction compensation takes place via the PT-1000 in the plug connector.
 |  | 1 | Cold junction compensation is not active.
 |  | 2 | Cold junction compensation takes place via the process data.
 |  | 3 | Cold junction compensation takes place via the PT-1000 in the plug connector of channel 1.
8010:0E | Swap limit bits | Swaps the two limit bits, in order to achieve compatibility with older hardware versions. |  | BOOLEAN | RW | 0x00 (0dec)
8010:11 | User scale offset | User scaling: Offset |  | INT16 | RW | 0x0000 (0dec)
8010:12 | User scale gain | User scaling: Gain |  | INT32 | RW | 0x00010000 (65536dec)
8010:13 | Limit 1 | Value for limit 1 |  | INT16 | RW | 0x0000 (0dec)
8010:14 | Limit 2 | Value for limit 2 |  | INT16 | RW | 0x0000 (0dec)
Index 8010: TC Settings Ch.2
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8010:15 | Filter settings | This parameter is without effect. The respective parameter of channel 1 applies to all channels: 0x8000:15 “Filter settings”. |  | UINT16 | RW | 0x0000 (0dec)
8010:16 | Calibration interval | reserved |  | UINT16 | RW | 0x0000 (0dec)
8010:17 | User calibration offset | User calibration: Offset |  | INT16 | RW | 0x0000 (0dec)
8010:18 | User calibration gain | User calibration: Gain |  | UINT16 | RW | 0x4000 (16384dec)
8010:19 | Sensor type | Thermocouple |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | Type K -200 °C to 1370 °C
 |  | 1 | Type J -100°C to 1200°C
 |  | 2 | Type L 0°C to 900°C
 |  | 3 | Type E -100°C to 1000°C
 |  | 4 | Type T -200°C to 400°C
 |  | 5 | Type N -100°C to 1300°C
 |  | 6 | Type U 0°C to 600°C
 |  | 7 | Type B 600°C to 1800°C
 |  | 8 | Type R 0°C to 1767°C
 |  | 9 | Type S 0°C to 1760°C
 |  | 10 | Type C 0°C to 2320°C
 |  | 100 | ± 30 mV (1 µV resolution)
 |  | 101 | ± 60 mV (2 µV resolution)
 |  | 102 | ± 75 mV (4 µV resolution)
8010:1B | Wire calibration 1/32 Ohm | Only for 2-wire measurements: contains the resistance of the supply line for the temperature sensor (in 1/32 ohm). |  | INT16 | RW | 0x0000 (0dec)
Index 8020: TC Settings Ch.3
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8020:0 | TC Settings Ch.3 | Maximum subindex |  | UINT8 | RO | 0x1B (27dec)
8020:01 | Enable user scale | Activates user scaling |  | BOOLEAN | RW | 0x00 (0dec)
8020:02 | Presentation | Presentation of the measured value |  | BIT3 | RW | 0x00 (0dec)
 |  | 0 | Signed, in two's complement
 |  | 1 | Most significant bit as sign
 |  | 2 | High-resolution (1/100 °C steps)
8020:05 | Siemens bits | The S5 bits are displayed in the three low-order bits |  | BOOLEAN | RW | 0x00 (0dec)
8020:06 | Enable filter | This parameter is without effect. The filter is always enabled. |  | BOOLEAN | RW | 0x00 (0dec)
8020:07 | Enable limit 1 | Activates limit check for limit 1 |  | BOOLEAN | RW | 0x00 (0dec)
8020:08 | Enable limit 2 | Activates limit check for limit 2 |  | BOOLEAN | RW | 0x00 (0dec)
8020:0A | Enable user calibration | Activates user calibration |  | BOOLEAN | RW | 0x00 (0dec)
8020:0B | Enable vendor calibration | Activates vendor calibration |  | BOOLEAN | RW | 0x01 (1dec)
Index 8020: TC Settings Ch.3
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8020:0C | Cold junction compensation | Cold junction compensation |  | BIT2 | RW | 0x00 (0dec)
 |  | 0 | Cold junction compensation takes place via the PT-1000 in the plug connector.
 |  | 1 | Cold junction compensation is not active.
 |  | 2 | Cold junction compensation takes place via the process data.
 |  | 3 | Cold junction compensation takes place via the PT-1000 in the plug connector of channel 1.
8020:0E | Swap limit bits | Swaps the two limit bits, in order to achieve compatibility with older hardware versions. |  | BOOLEAN | RW | 0x00 (0dec)
8020:11 | User scale offset | User scaling: Offset |  | INT16 | RW | 0x0000 (0dec)
8020:12 | User scale gain | User scaling: Gain |  | INT32 | RW | 0x00010000 (65536dec)
8020:13 | Limit 1 | Value for limit 1 |  | INT16 | RW | 0x0000 (0dec)
8020:14 | Limit 2 | Value for limit 2 |  | INT16 | RW | 0x0000 (0dec)
8020:15 | Filter settings | This parameter is without effect. The respective parameter of channel 1 applies to all channels: 0x8000:15 “Filter settings”. |  | UINT16 | RW | 0x0000 (0dec)
8020:16 | Calibration interval | reserved |  | UINT16 | RW | 0x0000 (0dec)
8020:17 | User calibration offset | User calibration: Offset |  | INT16 | RW | 0x0000 (0dec)
8020:18 | User calibration gain | User calibration: Gain |  | UINT16 | RW | 0x4000 (16384dec)
8020:19 | Sensor type | Thermocouple |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | Type K -200 °C to 1370 °C
 |  | 1 | Type J -100°C to 1200°C
 |  | 2 | Type L 0°C to 900°C
 |  | 3 | Type E -100°C to 1000°C
 |  | 4 | Type T -200°C to 400°C
 |  | 5 | Type N -100°C to 1300°C
 |  | 6 | Type U 0°C to 600°C
 |  | 7 | Type B 600°C to 1800°C
 |  | 8 | Type R 0°C to 1767°C
 |  | 9 | Type S 0°C to 1760°C
 |  | 10 | Type C 0°C to 2320°C
 |  | 100 | ± 30 mV (1 µV resolution)
 |  | 101 | ± 60 mV (2 µV resolution)
 |  | 102 | ± 75 mV (4 µV resolution)
8020:1B | Wire calibration 1/32 ohm | Only for 2-wire measurements: contains the resistance of the supply line for the temperature sensor (in 1/32 ohm). |  | INT16 | RW | 0x0000 (0dec)
Index 8030: TC Settings Ch.4
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8030:0 | TC Settings Ch.4 | Maximum subindex |  | UINT8 | RO | 0x1B (27dec)
8030:01 | Enable user scale | Activates user scaling |  | BOOLEAN | RW | 0x00 (0dec)
8030:02 | Presentation | Presentation of the measured value |  | BIT3 | RW | 0x00 (0dec)
 |  | 0 | Signed, in two's complement
 |  | 1 | Most significant bit as sign
 |  | 2 | High-resolution (1/100 °C steps)
8030:05 | Siemens bits | The S5 bits are displayed in the three low-order bits |  | BOOLEAN | RW | 0x00 (0dec)
8030:06 | Enable filter | This parameter is without effect. The filter is always enabled. |  | BOOLEAN | RW | 0x00 (0dec)
8030:07 | Enable limit 1 | Activates limit check for limit 1 |  | BOOLEAN | RW | 0x00 (0dec)
8030:08 | Enable limit 2 | Activates limit check for limit 2 |  | BOOLEAN | RW | 0x00 (0dec)
8030:0A | Enable user calibration | Activates user calibration |  | BOOLEAN | RW | 0x00 (0dec)
8030:0B | Enable vendor calibration | Activates vendor calibration |  | BOOLEAN | RW | 0x01 (1dec)
8030:0C | Cold junction compensation | Cold junction compensation |  | BIT2 | RW | 0x00 (0dec)
 |  | 0 | Cold junction compensation takes place via the PT-1000 in the plug connector.
 |  | 1 | Cold junction compensation is not active.
 |  | 2 | Cold junction compensation takes place via the process data.
 |  | 3 | Cold junction compensation takes place via the PT-1000 in the plug connector of channel 1.
8030:0E | Swap limit bits | Swaps the two limit bits, in order to achieve compatibility with older hardware versions. |  | BOOLEAN | RW | 0x00 (0dec)
8030:11 | User scale offset | User scaling: Offset |  | INT16 | RW | 0x0000 (0dec)
8030:12 | User scale gain | User scaling: Gain |  | INT32 | RW | 0x00010000 (65536dec)
8030:13 | Limit 1 | Value for limit 1 |  | INT16 | RW | 0x0000 (0dec)
8030:14 | Limit 2 | Value for limit 2 |  | INT16 | RW | 0x0000 (0dec)
8030:15 | Filter settings | This parameter is without effect. The respective parameter of channel 1 applies to all channels: 0x8000:15 “Filter settings”. |  | UINT16 | RW | 0x0000 (0dec)
8030:16 | Calibration interval | reserved |  | UINT16 | RW | 0x0000 (0dec)
8030:17 | User calibration offset | User calibration: Offset |  | INT16 | RW | 0x0000 (0dec)
8030:18 | User calibration gain | User calibration: Gain |  | UINT16 | RW | 0x4000 (16384dec)
Index 8030: TC Settings Ch.4
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8030:19 | Sensor type | Thermocouple |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | Type K -200 °C to 1370 °C
 |  | 1 | Type J -100°C to 1200°C
 |  | 2 | Type L 0°C to 900°C
 |  | 3 | Type E -100°C to 1000°C
 |  | 4 | Type T -200°C to 400°C
 |  | 5 | Type N -100°C to 1300°C
 |  | 6 | Type U 0°C to 600°C
 |  | 7 | Type B 600°C to 1800°C
 |  | 8 | Type R 0°C to 1767°C
 |  | 9 | Type S 0°C to 1760°C
 |  | 10 | Type C 0°C to 2320°C
 |  | 100 | ± 30 mV (1 µV resolution)
 |  | 101 | ± 60 mV (2 µV resolution)
 |  | 102 | ± 75 mV (4 µV resolution)
8030:1B | Wire calibration 1/32 ohm | Only for 2-wire measurements: contains the resistance of the supply line for the temperature sensor (in 1/32 ohm). |  | INT16 | RW | 0x0000 (0dec)


Objects for regular operation

Commissioning/Configuration [image] EP3314 - object description and parameterization [image] Objects for regular operation
Objects for regular operation
The EP3314 has no such objects.


Standard objects (0x1000-0x1FFF)

Commissioning/Configuration [image] EP3314 - object description and parameterization [image] Standard objects (0x1000-0x1FFF)
Standard objects (0x1000-0x1FFF)
The standard objects have the same meaning for all EtherCAT slaves.
Index 1000: Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Low-Word contains the CoE profile used (5001). The High-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x014A1389 (21631881dec)
Index 1008: Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EP3314-0002
Index 1009: Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO | 00
Index 100A: Software version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO | 01
Index 1018: Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x0CF24052 (217202770dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the low word (bit 0-15) indicates the special terminal number, the high word (bit 16-31) refers to the device description | UINT32 | RO | 0x00100002 (1048578dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the low byte (bit 0-7) of the low word contains the year of production, the high byte (bit 8-15) of the low word contains the week of production, the high word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 10F0: Backup parameter handling
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | Information for standardized loading and saving of backup entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum across all backup entries of the EtherCAT slave | UINT32 | RO | 0x00000000 (0dec)
Index 1600: TC RxPDO-Map Outputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1600:0 | TC RxPDO-Map Outputs Ch.1 | PDO Mapping RxPDO 1 | UINT8 | RO | 0x01 (1dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (TC Outputs Ch.1), entry 0x11 (CJCompensation)) | UINT32 | RO | 0x7000:11, 16
Index 1601: TC RxPDO-Map Outputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1601:0 | TC RxPDO-Map Outputs Ch.2 | PDO Mapping RxPDO 2 | UINT8 | RO | 0x01 (1dec)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (TC Outputs Ch.2), entry 0x11 (CJCompensation)) | UINT32 | RO | 0x7010:11, 16
Index 1602: TC RxPDO-Map Outputs Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1602:0 | TC RxPDO-Map Outputs Ch.3 | PDO Mapping RxPDO 3 | UINT8 | RO | 0x01 (1dec)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (TC Outputs Ch.3), entry 0x11 (CJCompensation)) | UINT32 | RO | 0x7020:11, 16
Index 1603: TC RxPDO-Map Outputs Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
1603:0 | TC RxPDO-Map Outputs Ch.4 | PDO Mapping RxPDO 4 | UINT8 | RO | 0x01 (1dec)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7030 (TC Outputs Ch.4), entry 0x11 (CJCompensation)) | UINT32 | RO | 0x7030:11, 16
Index 1A00: TC TxPDO-Map TCInputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A00:0 | TC TxPDO-Map TCInputs Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x0A (10dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (TC Inputs Ch.1), entry 0x01 (Underrange)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (TC Inputs Ch.1), entry 0x02 (Overrange)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (TC Inputs Ch.1), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6000:03, 2
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (TC Inputs Ch.1), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6000:05, 2
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (TC Inputs Ch.1), entry 0x07 (Error)) | UINT32 | RO | 0x6000:07, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (TC Inputs Ch.1), entry 0x0E (Sync error)) | UINT32 | RO | 0x6000:0E, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1800, entry 0x07) | UINT32 | RO | 0x1800:07, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x1800, entry 0x09) | UINT32 | RO | 0x1800:09, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (TC Inputs Ch.1), entry 0x11 (Value)) | UINT32 | RO | 0x6000:11, 16
Index 1A01: TC TxPDO-Map TCInputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A01:0 | TC TxPDO-Map TCInputs Ch.2 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x0A (10dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (TC Inputs Ch.2), entry 0x01 (Underrange)) | UINT32 | RO | 0x6010:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (TC Inputs Ch.2), entry 0x02 (Overrange)) | UINT32 | RO | 0x6010:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (TC Inputs Ch.2), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6010:03, 2
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (TC Inputs Ch.2), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6010:05, 2
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (TC Inputs Ch.2), entry 0x07 (Error)) | UINT32 | RO | 0x6010:07, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (TC Inputs Ch.2), entry 0x0E (Sync error)) | UINT32 | RO | 0x6010:0E, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1801, entry 0x07) | UINT32 | RO | 0x1801:07, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x1801, entry 0x09) | UINT32 | RO | 0x1801:09, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6010 (TC Inputs Ch.2), entry 0x11 (Value)) | UINT32 | RO | 0x6010:11, 16
Index 1A02: TC TxPDO-Map TCInputs Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1A02:0 | TC TxPDO-Map TCInputs Ch.3 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x0A (10dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (TC Inputs Ch.3), entry 0x01 (Underrange)) | UINT32 | RO | 0x6020:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (TC Inputs Ch.3), entry 0x02 (Overrange)) | UINT32 | RO | 0x6020:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (TC Inputs Ch.3), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6020:03, 2
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (TC Inputs Ch.3), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6020:05, 2
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (TC Inputs Ch.3), entry 0x07 (Error)) | UINT32 | RO | 0x6020:07, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020 (TC Inputs Ch.3), entry 0x0E (Sync error)) | UINT32 | RO | 0x6020:0E, 1
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1802, entry 0x07) | UINT32 | RO | 0x1802:07, 1
1A02:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x1802, entry 0x09) | UINT32 | RO | 0x1802:09, 1
1A02:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6020 (TC Inputs Ch.3), entry 0x11 (Value)) | UINT32 | RO | 0x6020:11, 16
Index 1A03: TC TxPDO-Map TCInputs Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
1A03:0 | TC TxPDO-Map TCInputs Ch.4 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x0A (10dec)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6030 (TC Inputs Ch.4), entry 0x01 (Underrange)) | UINT32 | RO | 0x6030:01, 1
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6030 (TC Inputs Ch.4), entry 0x02 (Overrange)) | UINT32 | RO | 0x6030:02, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6030 (TC Inputs Ch.4), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6030:03, 2
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6030 (TC Inputs Ch.4), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6030:05, 2
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6030 (TC Inputs Ch.4), entry 0x07 (Error)) | UINT32 | RO | 0x6030:07, 1
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
1A03:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6030 (TC Inputs Ch.4), entry 0x0E (Sync error)) | UINT32 | RO | 0x6030:0E, 1
1A03:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1803, entry 0x07) | UINT32 | RO | 0x1803:07, 1
1A03:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x1803, entry 0x09) | UINT32 | RO | 0x1803:09, 1
1A03:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6030 (TC Inputs Ch.4), entry 0x11 (Value)) | UINT32 | RO | 0x6030:11, 16
Index 1C00: Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the sync managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12: RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x00 (0dec)
1C12:01 | Subindex 001 | 1. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:02 | Subindex 002 | 2. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:03 | Subindex 003 | 3. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:04 | Subindex 004 | 4. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 1C13: TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x04 (4dec)
1C13:01 | Subindex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A01 (6657dec)
1C13:03 | Subindex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A02 (6658dec)
1C13:04 | Subindex 004 | 4. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A03 (6659dec)
Index 1C32: SM output parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C32:0
SM output parameter
Synchronization parameters for the outputs
UINT8
RO
0x20 (32dec)
1C32:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchronous with SM 2 event
▪
2: DC-Mode - Synchronous with SYNC0 Event
▪
3: DC-Mode - Synchronous with SYNC1 event
UINT16
RW
0x0000 (0dec)
1C32:02
Cycle time
Cycle time (in ns):
▪
Free Run: Cycle time of the local timer
▪
Synchronous with SM 2 event: Master cycle time
▪
DC mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dec)
1C32:03
Shift time
Time between SYNC0 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0 = 1: free run is supported
▪
Bit 1 = 1: Synchronous with SM 2 event is supported
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 10: Output shift with SYNC1 event (only DC mode)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08)
UINT16
RO
0xC007 (49159dec)
1C32:05
Minimum cycle time
Minimum cycle time (in ns)
UINT32
RO
0x00002710 (10000dec)
1C32:06
Calc and copy time
Minimum time between SYNC0 and SYNC1 event (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:07
Minimum delay time
UINT32
RO
0x00000000 (0dec)
1C32:08
Command
▪
0: Measurement of the local cycle time is stopped
▪
1: Measurement of the local cycle time is started
The entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 are updated with the maximum measured values.
For a subsequent measurement the measured values are reset
UINT16
RW
0x0000 (0dec)
1C32:09
Maximum Delay time
Time between SYNC1 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:0B
SM event missed counter
Number of missed SM events in OPERATIONAL (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:0C
Cycle exceeded counter
Number of occasions the cycle time was exceeded in OPERATIONAL (cycle was not completed in time or the next cycle began too early)
UINT16
RO
0x0000 (0dec)
1C32:0D
Shift too short counter
Number of occasions that the interval between SYNC0 and SYNC1 event was too short (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:20
Sync error
The synchronization was not correct in the last cycle (outputs were output too late; DC mode only)
BOOLEAN
RO
0x00 (0dec)
Index 1C33: SM input parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchronous with SM 3 Event (no outputs available)
▪
2: DC - Synchronous with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (outputs available)
UINT16
RW
0x0000 (0dec)
1C33:02
Cycle time
as 0x1C32:02
UINT32
RW
0x000F4240 (1000000dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: Synchron with SM 2 Event is supported (outputs available)
▪
Bit 1: Synchron with SM 3 Event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: input shift through local event (outputs available)
▪
Bit 4-5 = 10: input shift with SYNC1 event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08 or 0x1C33:08)
UINT16
RO
0xC007 (49159dec)
1C33:05
Minimum cycle time
as 0x1C32:05
UINT32
RO
0x00002710 (10000dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:07
Minimum delay time
UINT32
RO
0x00000000 (0dec)
1C33:08
Command
as 0x1C32:08
UINT16
RW
0x0000 (0dec)
1C33:09
Maximum Delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:0B
SM event missed counter
as 0x1C32:11
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
as 0x1C32:12
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
as 0x1C32:13
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
as 0x1C32:32
BOOLEAN
RO
0x00 (0dec)


Profile-specific objects (0x6000-0xFFFF)

Commissioning/Configuration [image] EP3314 - object description and parameterization [image] Profile-specific objects (0x6000-0xFFFF)
Profile-specific objects (0x6000-0xFFFF)
The profile-specific objects have the same meaning for all EtherCAT slaves that support the profile 5001.
Index 6000: TC Inputs Ch.1
Index (hex) | Name | Meaning |  | Data type | Flags | Default
6000:0 | TC Inputs Ch.1 | Maximum subindex |  | UINT8 | RO | 0x11 (17dec)
6000:01 | Underrange | Is set if the value falls below the operating range of the sensor or the process record contains the lowest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6000:02 | Overrange | Is set if the value exceeds the operating range of the sensor or the process record contains the highest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6000:03 | Limit 1 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6000:05 | Limit 2 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6000:07 | Error | The error bit is set if the process data is invalid (cable break, overrange, underrange) |  | BOOLEAN | RO | 0x00 (0dec)
6000:0E | Sync error | Only in DC: bit is set if the slave is not able to operate synchronous with master, because it cannot keep up with the cycle time. |  | BOOLEAN | RO | 0x00 (0dec)
6000:0F | TxPDO State | Validity of the data of the associated TxPDO |  | BOOLEAN | RO | 0x00 (0dec)
 |  | 0 | valid
 |  | 1 | invalid
6000:10 | TxPDO Toggle | TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. |  | BOOLEAN | RO | 0x00 (0dec)
6000:11 | Value | Analog input value (resolution in 1/10 °C) |  | INT16 | RO | 0x0000 (0dec)
Index 6010: TC Inputs Ch.2
Index (hex) | Name | Meaning |  | Data type | Flags | Default
6010:0 | TC Inputs Ch.2 | Maximum subindex |  | UINT8 | RO | 0x11 (17dec)
6010:01 | Underrange | Is set if the value falls below the operating range of the sensor or the process record contains the lowest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6010:02 | Overrange | Is set if the value exceeds the operating range of the sensor or the process record contains the highest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6010:03 | Limit 1 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6010:05 | Limit 2 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6010:07 | Error | The error bit is set if the process data is invalid (cable break, overrange, underrange) |  | BOOLEAN | RO | 0x00 (0dec)
6010:0E | Sync error | Only in DC: bit is set if the slave is not able to operate synchronous with master, because it cannot keep up with the cycle time. |  | BOOLEAN | RO | 0x00 (0dec)
6010:0F | TxPDO State | Validity of the data of the associated TxPDO |  | BOOLEAN | RO | 0x00 (0dec)
 |  | 0 | valid
 |  | 1 | invalid
6010:10 | TxPDO Toggle | TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. |  | BOOLEAN | RO | 0x00 (0dec)
6010:11 | Value | Analog input value (resolution in 1/10 °C) |  | INT16 | RO | 0x0000 (0dec)
Index 6020: TC Inputs Ch.3
Index (hex) | Name | Meaning |  | Data type | Flags | Default
6020:0 | TC Inputs Ch.3 | Maximum subindex |  | UINT8 | RO | 0x11 (17dec)
6020:01 | Underrange | Is set if the value falls below the operating range of the sensor or the process record contains the lowest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6020:02 | Overrange | Is set if the value exceeds the operating range of the sensor or the process record contains the highest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6020:03 | Limit 1 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6020:05 | Limit 2 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6020:07 | Error | The error bit is set if the process data is invalid (cable break, overrange, underrange) |  | BOOLEAN | RO | 0x00 (0dec)
6020:0E | Sync error | Only in DC: bit is set if the slave is not able to operate synchronous with master, because it cannot keep up with the cycle time. |  | BOOLEAN | RO | 0x00 (0dec)
6020:0F | TxPDO State | Validity of the data of the associated TxPDO |  | BOOLEAN | RO | 0x00 (0dec)
 |  | 0 | valid
 |  | 1 | invalid
6020:10 | TxPDO Toggle | TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. |  | BOOLEAN | RO | 0x00 (0dec)
6020:11 | Value | Analog input value (resolution in 1/10°C) |  | INT16 | RO | 0x0000 (0dec)
Index 6030: TC Inputs Ch.4
Index (hex) | Name | Meaning |  | Data type | Flags | Default
6030:0 | TC Inputs Ch.4 | Maximum subindex |  | UINT8 | RO | 0x11 (17dec)
6030:01 | Underrange | Is set if the value falls below the operating range of the sensor or the process record contains the lowest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6030:02 | Overrange | Is set if the value exceeds the operating range of the sensor or the process record contains the highest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6030:03 | Limit 1 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit reached
 |  | 3 | Set limit exceeded
6030:05 | Limit 2 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit reached
 |  | 3 | Set limit exceeded
6030:07 | Error | The error bit is set if the process data is invalid (cable break, overrange, underrange) |  | BOOLEAN | RO | 0x00 (0dec)
6030:0E | Sync error | Only in DC: bit is set if the slave is not able to operate synchronous with master, because it cannot keep up with the cycle time. |  | BOOLEAN | RO | 0x00 (0dec)
6030:0F | TxPDO State | Validity of the data of the associated TxPDO |  | BOOLEAN | RO | 0x00 (0dec)
 |  | 0 | valid
 |  | 1 | invalid
6030:10 | TxPDO Toggle | TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. |  | BOOLEAN | RO | 0x00 (0dec)
6030:11 | Value | Analog input value (resolution in 1/10°C) |  | INT16 | RO | 0x0000 (0dec)
Index 7000: TC Outputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
7000:0 | TC Outputs Ch.1 | Maximum subindex | UINT8 | RO | 0x11 (17dec)
7000:11 | CJCompensation | Temperature of the cold junction (resolution in 1/10°C) (index 0x8000:0C, comparison via the process data)) | INT16 | RO | 0x0000 (0dec)
Index 7010: TC Outputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
7010:0 | TC Outputs Ch.2 | Maximum subindex | UINT8 | RO | 0x11 (17dec)
7010:11 | CJCompensation | Temperature of the cold junction (resolution in 1/10°C) (index 0x8000:0C, comparison via the process data) | INT16 | RO | 0x0000 (0dec)
Index 7020: TC Outputs Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
7020:0 | TC Outputs Ch.3 | Maximum subindex | UINT8 | RO | 0x11 (17dec)
7020:11 | CJCompensation | Temperature of the cold junction (resolution in 1/10°C) (index 0x8020:0C, comparison via the process data) | INT16 | RO | 0x0000 (0dec)
Index 7030: TC Outputs Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
7030:0 | TC Outputs Ch.4 | Maximum subindex | UINT8 | RO | 0x11 (17dec)
7030:11 | CJCompensation | Temperature of the cold junction (resolution in 1/10°C) (index 0x8030:0C, comparison via the process data) | INT16 | RO | 0x0000 (0dec)
Index 800E: TC Internal data Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
800E:0 | TC Internal data Ch.1 | Maximum subindex | UINT8 | RO | 0x05 (5dec)
800E:01 | ADC raw value TC | Raw value of the analog/digital converter for the thermocouple | INT32 | RO | 0x00000000 (0dec)
800E:02 | ADC raw value PT1000 | Raw value of the analog/digital converter for the PT1000 | INT32 | RO | 0x00000000 (0dec)
800E:03 | CJ temperature | Cold junction temperature (resolution 1/10 °C) | INT16 | RO | 0x0000 (0dec)
800E:04 | CJ voltage | Cold junction voltage (resolution 1 µV) | INT16 | RO | 0x0000 (0dec)
800E:05 | CJ resistor | Cold junction resistance for PT1000 temperature sensor (resolution 1/10 ohm) | UINT16 | RO | 0x0000 (0dec)
Index 800F: TC Vendor data Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
800F:0 | TC Vendor data Ch.1 | Maximum subindex | UINT8 | RO | 0x04 (4dec)
800F:01 | Calibration offset TC | Manufacturer calibration for thermocouple: Offset | INT16 | RW | 0x0000 (0dec)
800F:02 | Calibration gain TC | Manufacturer calibration for thermocouple: Gain | UINT16 | RW | 0x4000 (16384dec)
800F:03 | Calibration offset CJ | Manufacturer calibration for cold junction (PT1000): Offset | INT16 | RW | 0x0000 (0dec)
800F:04 | Calibration gain CJ | Manufacturer calibration for cold junction (PT1000): Gain | UINT16 | RW | 0x4000 (16384dec)
Index 801E: TC Internal data Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
801E:0 | TC Internal data Ch.2 | Maximum subindex | UINT8 | RO | 0x05 (5dec)
801E:01 | ADC raw value TC | Raw value of the analog/digital converter for the thermocouple | INT32 | RO | 0x00000000 (0dec)
801E:02 | ADC raw value PT1000 | Raw value of the analog/digital converter for the PT1000 | INT32 | RO | 0x00000000 (0dec)
801E:03 | CJ temperature | Cold junction temperature (resolution 1/10 °C) | INT16 | RO | 0x0000 (0dec)
801E:04 | CJ voltage | Cold junction voltage (resolution 1 µV) | INT16 | RO | 0x0000 (0dec)
801E:05 | CJ resistor | Cold junction resistance for PT1000 temperature sensor (resolution 1/10 ohm) | UINT16 | RO | 0x0000 (0dec)
Index 801F: TC Vendor data Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
801F:0 | TC Vendor data Ch.2 | Maximum subindex | UINT8 | RO | 0x04 (4dec)
801F:01 | Calibration offset TC | Manufacturer calibration for thermocouple: Offset | INT16 | RW | 0x0000 (0dec)
801F:02 | Calibration gain TC | Manufacturer calibration for thermocouple: Gain | UINT16 | RW | 0x4000 (16384dec)
801F:03 | Calibration offset CJ | Manufacturer calibration for cold junction (PT1000): Offset | INT16 | RW | 0x0000 (0dec)
801F:04 | Calibration gain CJ | Manufacturer calibration for cold junction (PT1000): Gain | UINT16 | RW | 0x4000 (16384dec)
Index 802E: TC Internal data Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
802E:0 | TC Internal data Ch.3 | Maximum subindex | UINT8 | RO | 0x05 (5dec)
802E:01 | ADC raw value TC | Raw value of the analog/digital converter for the thermocouple | INT32 | RO | 0x00000000 (0dec)
802E:02 | ADC raw value PT1000 | Raw value of the analog/digital converter for the PT1000 | INT32 | RO | 0x00000000 (0dec)
802E:03 | CJ temperature | Cold junction temperature (resolution 1/10°C) | INT16 | RO | 0x0000 (0dec)
802E:04 | CJ voltage | Cold junction voltage (resolution 1 µV) | INT16 | RO | 0x0000 (0dec)
802E:05 | CJ resistor | Cold junction resistance for PT1000 temperature sensor (resolution 1/10 ohm) | UINT16 | RO | 0x0000 (0dec)
Index 802F: TC Vendor data Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
802F:0 | TC Vendor data Ch.3 | Maximum subindex | UINT8 | RO | 0x04 (4dec)
802F:01 | Calibration offset TC | Manufacturer calibration for thermocouple: Offset | INT16 | RW | 0x0000 (0dec)
802F:02 | Calibration gain TC | Manufacturer calibration for thermocouple: Gain | UINT16 | RW | 0x4000 (16384dec)
802F:03 | Calibration offset CJ | Manufacturer calibration for cold junction (PT1000): Offset | INT16 | RW | 0x0000 (0dec)
802F:04 | Calibration gain CJ | Manufacturer calibration for cold junction (PT1000): Gain | UINT16 | RW | 0x4000 (16384dec)
Index 803E: TC Internal data Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
803E:0 | TC Internal data Ch.4 | Maximum subindex | UINT8 | RO | 0x05 (5dec)
803E:01 | ADC raw value TC | Raw value of the analog/digital converter for the thermocouple | INT32 | RO | 0x00000000 (0dec)
803E:02 | ADC raw value PT1000 | Raw value of the analog/digital converter for the PT1000 | INT32 | RO | 0x00000000 (0dec)
803E:03 | CJ temperature | Cold junction temperature (resolution 1/10°C) | INT16 | RO | 0x0000 (0dec)
803E:04 | CJ voltage | Cold junction voltage (resolution 1 µV) | INT16 | RO | 0x0000 (0dec)
803E:05 | CJ resistor | Cold junction resistance for PT1000 temperature sensor (resolution 1/10 ohm) | UINT16 | RO | 0x0000 (0dec)
Index 803F: TC Vendor data Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
803F:0 | TC Vendor data Ch.4 | Maximum subindex | UINT8 | RO | 0x04 (4dec)
803F:01 | Calibration offset TC | Manufacturer calibration for thermocouple: Offset | INT16 | RW | 0x0000 (0dec)
803F:02 | Calibration gain TC | Manufacturer calibration for thermocouple: Gain | UINT16 | RW | 0x4000 (16384dec)
803F:03 | Calibration offset CJ | Manufacturer calibration for cold junction (PT1000): Offset | INT16 | RW | 0x0000 (0dec)
803F:04 | Calibration gain CJ | Manufacturer calibration for cold junction (PT1000): Gain | UINT16 | RW | 0x4000 (16384dec)
Index F000: Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | Maximum subindex | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index spacing for the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0004 (4dec)
Index F008: Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dec)
Index F010: Module list
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list | Maximum subindex | UINT8 | RW | 0x04 (4dec)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x0000014A (330dec)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x0000014A (330dec)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x0000014A (330dec)
F010:04 | SubIndex 004 |  | UINT32 | RW | 0x0000014A (330dec)
Index F080: Channel Enable
Index (hex) | Name | Meaning |  |  | Data type | Flags | Default
F080:0 | Channel Enable | Maximum subindex |  |  | UINT8 | RO | 0x04 (4dec)
F080:01 | SubIndex 001 | 0 | Channel 1 disabled | (from hardware version 01 deactivated channels are not measured, and the green LED R for these channels goes out) | BOOLEAN | RW | 0x01 (1dec)
 |  | 1 | Channel 1 enabled
F080:02 | SubIndex 002 | 0 | Channel 2 disabled |  | BOOLEAN | RW | 0x01 (1dec)
 |  | 1 | Channel 2 enabled
F080:03 | SubIndex 003 | 0 | Channel 3 disabled |  | BOOLEAN | RW | 0x01 (1dec)
 |  | 1 | Channel 3 enabled
F080:04 | SubIndex 004 | 0 | Channel 4 disabled |  | BOOLEAN | RW | 0x01 (1dec)
 |  | 1 | Channel 5 enabled


Restoring the delivery state

Commissioning/Configuration [image] Restoring the delivery state
Restoring the delivery state
To restore the delivery state for backup objects in ELxxxx terminals / EPxxxx- and EPPxxxx boxes, the CoE object Restore default parameters, SubIndex 001 can be selected in the TwinCAT System Manager (Config mode).
Selecting the Restore default parameters PDO
Double-click on SubIndex 001 to enter the Set Value dialog. Enter the value 1684107116 in field Dec or the value 0x64616F6C in field Hex and confirm with OK.
All backup objects are reset to the delivery state.
Entering a restore value in the Set Value dialog
Alternative restore value
In some older terminals / boxes the backup objects can be switched with an alternative restore value:
Decimal value: 1819238756
Hexadecimal value: 0x6C6F6164
An incorrect entry for the restore value has no effect.


Decommissioning

Commissioning/Configuration [image] Decommissioning
Decommissioning
SmallWarningYellow WARNING
Risk of electric shock!
Bring the bus system into a safe, de-energized state before starting disassembly of the devices!
Disposal
In order to dispose of the device, it must be removed.
In accordance with the WEEE Directive 2012/19/EU, Beckhoff takes back old devices and accessories in Germany for proper disposal. Transport costs will be borne by the sender.
Return the old devices with the note "for disposal" to:
Beckhoff Automation GmbH & Co. KG
Service Department
Stahlstraße 31
D-33415 Verl


Appendix

Appendix
Appendix
Additional information
•
General operating conditions
•
EtherCAT Box- / EtherCAT P Box - Accessories
•
Version identification of EtherCAT devices
•
Support and Service


General operating conditions

Appendix [image] General operating conditions
General operating conditions
Protection degrees (IP-Code)
The standard IEC 60529 (DIN EN 60529) defines the degrees of protection in different classes.
1. Number: dust protection and touch guard | Definition
0 | Non-protected
1 | Protected against access to hazardous parts with the back of a hand. Protected against solid foreign objects of Ø 50 mm
2 | Protected against access to hazardous parts with a finger. Protected against solid foreign objects of Ø 12.5 mm.
3 | Protected against access to hazardous parts with a tool. Protected against solid foreign objects Ø 2.5 mm.
4 | Protected against access to hazardous parts with a wire. Protected against solid foreign objects Ø 1 mm.
5 | Protected against access to hazardous parts with a wire. Dust-protected. Intrusion of dust is not totally prevented, but dust shall not penetrate in a quantity to interfere with satisfactory operation of the device or to impair safety.
6 | Protected against access to hazardous parts with a wire. Dust-tight. No intrusion of dust.
2. Number: water* protection | Definition
0 | Non-protected
1 | Protected against water drops
2 | Protected against water drops when enclosure tilted up to 15°.
3 | Protected against spraying water. Water sprayed at an angle up to 60° on either side of the vertical shall have no harmful effects.
4 | Protected against splashing water. Water splashed against the disclosure from any direction shall have no harmful effects
5 | Protected against water jets
6 | Protected against powerful water jets
7 | Protected against the effects of temporary immersion in water. Intrusion of water in quantities causing harmful effects shall not be possible when the enclosure is temporarily immersed in water for 30 min. in 1 m depth.
*) These protection classes define only protection against water!
Chemical Resistance
The Resistance relates to the Housing of the IP 67 modules and the used metal parts. In the table below you will find some typical resistance.
Character | Resistance
Steam | at temperatures >100°C: not resistant
Sodium base liquor (ph-Value > 12) | at room temperature: resistant > 40°C: not resistant
Acetic acid | not resistant
Argon (technical clean) | resistant
Key
▪
resistant: Lifetime several months
▪
non inherently resistant: Lifetime several weeks
▪
not resistant: Lifetime several hours resp. early decomposition


EtherCAT Box- / EtherCAT P Box - Accessories

Appendix [image] EtherCAT Box- / EtherCAT P Box - Accessories
EtherCAT Box- / EtherCAT P Box - Accessories
Fixing
Ordering information | Description
ZS5300-0001 | Mounting rail (500 mm x 129 mm)
Marking material, plugs
Ordering information | Description
ZS5000-0000 | Fieldbus Box set M8 (contact labels, plugs)
ZS5000-0002 | Fieldbus Box set M12 (contact labels, plugs)
ZS5000-0010 | plugs M8, IP67 (50 pieces)
ZS5000-0020 | plugs M12, IP67 (50 pieces)
ZS5100-0000 | marking labels, not printed, 4 stripes at 10 pieces
ZS5100-xxxx | printed marking labels, on request
Tools
Ordering information | Description
ZB8800 | torque wrench for M8 cables with knurl, incl. ratchet
ZB8800-0001 | M12 ratchet for torque wrench ZB8800
ZB8800-0002 | M8 ratchet (field assembly) for torque wrench ZB8800
ZB8801-0000 | torque wrench for hexagonal plugs, adjustable
ZB8801-0001 | torque cable key, M8/wrench size 9, for torque wrench ZB8801-0000
ZB8801-0002 | torque cable key, M12/wrench size 13, for torque wrench ZB8801-0000
ZB8801-0003 | torque cable key, M12 field assembly/wrench size 13, for torque wrench ZB8801-0000
Further accessories
Further accessories may be found at the price list for Beckhoff fieldbus components and at the internet under https://www.beckhoff.com


Version identification of EtherCAT devices

Appendix [image] Version identification of EtherCAT devices
Version identification of EtherCAT devices
Designation
A Beckhoff EtherCAT device has a 14-digit designation, made up of
▪
family key
▪
type
▪
version
▪
revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
Notes
▪
The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
▪
EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
▪
The order identifier is made up of
- family key (EL, EP, CU, ES, KL, CX, etc.)
- type (3314)
- version (-0000)
▪
The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
▪
The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Identification number
Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:
Production lot/batch number/serial number/date code/D number
The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02
Exceptions can occur in the IP67 area, where the following syntax can be used (see respective device documentation):
Syntax: D ww yy x y z u
D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB
Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1
Unique serial number/ID, ID number
In addition, in some series each individual module has its own unique serial number.
See also the further documentation in the area
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Terminals with factory calibration certificate and other measuring terminals
Examples of markings
EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
CU2016 switch with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
EP1258-00001 IP67 EtherCAT Box with batch number/ date code 22090101 and unique serial number 158102
EP1908-0002 IP67 EtherCAT Safety Box with batch number/ date code 071201FF and unique serial number 00346070
EL2904 IP20 safety terminal with batch number/ date code 50110302 and unique serial number 00331701
ELM3604-0002 terminal with unique ID number (QR code) 100001051 and serial/ batch number 44160201
Additional information
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Appendix [image] Version identification of EtherCAT devices [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com