EP2xxx - EtherCAT Box modules with digital outputs
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC® and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, DE102004044764, DE102007017835 with corresponding applications or registrations in various other countries.
The TwinCAT Technology is covered, including but not limited to the following patent applications and patents: EP0851348, US6167425 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
2.9.0
▪
EP2008-000x - switching times added
▪
EP2816-00xx - Variants -0004, -0008 and -0010 combined in one chapter
▪
Process image screenshots updated to TwinCAT 3
▪
Dimensional drawings in chapter "Mounting" completed
2.8.0
▪
EP2817-0008 - Introduction updated
▪
EP2817-0008 – Technical data updated
▪
EP2xxx – Module overview updated
2.7.0
▪
EP2316-0008 – Process image updated
▪
EP2816-0004 – Process image updated
▪
EP2816-0008 – Process image updated
▪
EP2316-0010 – Process image updated
▪
EP2316-0008, EPP2316-0008 – Configuration updated
2.6.1
▪
Chapter EP2316-0008, EPP2316-0008 – Configuration updated
2.6.0
▪
Chapter Digital inputs/outputs M8 and M12 added
2.5.0
▪
EP2038-000x – Technical data updated
2.4.0
▪
Conductor losses 7/8" added
2.3.0
▪
Torque wrench diagram updated
▪
Power Connection updated
2.2.0
▪
EP2008-0022 added
▪
EP2038-000x added
▪
EP2816-0004 added
▪
EP2349-002x added
2.1.0
▪
EP2328-0001 added
▪
Technical data updated
▪
Nut torques for connectors extended
2.0.0
▪
Migration
▪
Technical data updated
1.5.0
▪
EP2817-0008 added
1.4.0
▪
EP2316-0003: Description of status LEDs updated
▪
EP2809-0021 and EP2809-0022 updated
▪
Overview of EtherCAT cables extended
▪
Mounting instructions for protection enclosure BG2000-0000 revised
▪
Chapter Accessories added
▪
EP2028-0032 added
▪
Definitions for the behavior of the outputs in case of a short circuit updated
1.3.0
▪
ATEX notes added
▪
Extended temperature range for activated modules documented
▪
EP2316-0003, EP2809-0021 and EP2809-0022 added
▪
Description of the power connection updated
▪
Description of sensor supply by EP2338 corrected
▪
Technical data of the 2624-0002 updated
▪
Object descriptions for EP2316-0008 and EP2816-0008 / EP2816-0010 added
▪
Overview of EtherCAT cables extended
1.2.0
▪
EP2308-0002 and EP2624-0002 added
▪
Introduction of EP2338-000x updated
▪
Technical data: Current consumption values amended
▪
Nut torque for connectors added
1.1.0
▪
Notes on sensor supply corrected
1.0.0
▪
Technical data updated
▪
Signal connection updated
Version
Comment
0.7
▪
Signal connection extended
▪
Description of status LEDs added
▪
Explanation of the serial number adapted to the new standard
0.6
▪
EP2316-0008 added
▪
EP2338-0001 and EP2338-0002 added
▪
Signal connection extended
0.5
▪
First preliminary version
Firmware and hardware versions
This documentation refers to the firmware and hardware version that was applicable at the time the documentation was written.
The module features are continuously improved and developed further. Modules having earlier production statuses cannot have the same properties as modules with the latest status. However, existing properties are retained and are not changed, so that older modules can always be replaced with new ones.
The firmware and hardware version (delivery state) can be found in the batch number (D-number) printed on the side of the EtherCAT Box.
Syntax of the batch number (D-number):
D: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with D no. 29 10 02 01:
29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01


Product overview

Product overview
Product overview
Additional information
•
EtherCAT Box - Introduction
•
EP2xxx module overview
•
EP2008-00xx
•
EP2028-000x
•
EP2028-0032
•
EP2038-000x
•
EP2308, EP2318, EP2328
•
EP2316-0003, EP2316-0008
•
EP2338-x00x
•
EP2339-002x
•
EP2349-002x
•
EP2624-0002
•
EP2809-002x
•
EP2816-00xx
•
EP2817-0008


EtherCAT Box - Introduction

Product overview [image] EtherCAT Box - Introduction
EtherCAT Box - Introduction
The EtherCAT system has been extended with EtherCAT Box modules with protection class IP 67. Through the integrated EtherCAT interface the modules can be connected directly to an EtherCAT network without an additional Coupler Box. The high-performance of EtherCAT is thus maintained into each module.
The extremely low dimensions of only 126 x 30 x 26.5 mm (h x w x d) are identical to those of the Fieldbus Box extension modules. They are thus particularly suitable for use where space is at a premium. The small mass of the EtherCAT modules facilitates applications with mobile I/O interface (e.g. on a robot arm). The EtherCAT connection is established via screened M8 connectors.
EtherCAT Box Modules within an EtherCAT network
The robust design of the EtherCAT Box modules enables them to be used directly at the machine. Control cabinets and terminal boxes are now no longer required. The modules are fully sealed and therefore ideally prepared for wet, dirty or dusty conditions.
Pre-assembled cables significantly simplify EtherCAT and signal wiring. Very few wiring errors are made, so that commissioning is optimized. In addition to pre-assembled EtherCAT, power and sensor cables, field-configurable connectors and cables are available for maximum flexibility. Depending on the application, the sensors and actuators are connected through M8 or M12 connectors.
The EtherCAT modules cover the typical range of requirements for I/O signals with protection class IP67:
▪
digital inputs with different filters (3.0 ms or 10 μs)
▪
digital outputs with 0.5 or 2 A output current
▪
analog inputs and outputs with 16 bit resolution
▪
Thermocouple and RTD inputs
▪
Stepper motor modules
XFC (eXtreme Fast Control Technology) modules, including inputs with time stamp, are also available.
EtherCAT Box with M8 connections for sensors/actuators
EtherCAT Box with M12 connections for sensors/actuators
Basic EtherCAT documentation
You will find a detailed description of the EtherCAT system in the Basic System Documentation for EtherCAT, which is available for download from our website (www.beckhoff.com) under Downloads.
EtherCAT XML Device Description
You will find XML files (XML Device Description Files) for Beckhoff EtherCAT modules on our website (www.beckhoff.com) under Downloads, in the Configuration Files area.


EP2xxx module overview

Product overview [image] EP2xxx module overview
EP2xxx module overview
Digital output modules
Module | Signal connection | Number of outputs | Current | Comment
EP2008-0001 | 8 x M8 | 8 | 0.5 A (Σ 4 A) | Maximum of the total of all outputs 4 A
EP2008-0002 | 4 x M12 | 8 | 0.5 A (Σ 4 A) | Maximum of the total of all outputs 4 A
EP2008-0022 | 8 x M12 | 8 | 0.5 A (Σ 4 A) | Maximum of the total of all outputs 4 A
EP2028-0001 | 8 x M8 | 8 | 2.0 A (Σ 4 A) | Maximum of the total of all outputs 4 A
EP2028-0002 | 4 x M12 | 8 | 2.0 A (Σ 4 A) | Maximum of the total of all outputs 4 A
EP2028-0032 | 8 x M12 | 8 | 2.8 A (Σ 16 A) | Maximum of the total of all outputs 16 A
EP2038-0001 | 8 x M8 | 8 | 2.0 A (Σ 4 A) | Maximum of the total of all outputs 4 A
EP2038-0002 | 4 x M12 | 8 | 2.0 A (Σ 4 A) | Maximum of the total of all outputs 4 A
EP2624-0002 | 4 x M12 | 4 | 0.5 AAC / 2 ADC | Relay module with 4 make contacts
EP2809-0021 | 16 x M8 | 16 | 0.5 A (Σ 4 A) | wide housing
EP2809-0022 | 16 x M12 | 16 | 0.5 A (Σ 4 A) | wide housing
EP2816-0004 | 1 x M16, 19-pin | 16 | 0.5 A (Σ 4 A) | Maximum of the total of all outputs 4 A
EP2816-0008 | 1 x D-sub 25 | 16 | 0.5 A (Σ 4 A) | Maximum of the total of all outputs 4 A
EP2816-0010 | 2 x D-sub 8 | 16 | 0.5 A (Σ 4 A) | Maximum of the total of all outputs 4 A
EP2817-0008 | 1 x D-sub 25 | 24 | 0.5 A (Σ 4 A) | Maximum of the total of all outputs 4 A
Digital combination modules
Module | Signal connection | Number of outputs | Current | Number of inputs | Filter
EP2308-0001 | 8 x M8 | 4 | 0.5 A | 4 | 3.0 ms
EP2308-0002 | 4 x M12 | 4 | 0.5 A | 4 | 3.0 ms
EP2316-0003 | 2 x ZS2001 | 8 | 0.5 A | 8 | 10 µs
EP2316-0008 | 1 x D-sub 25 | 8 | 0.5 A | 8 | 10 µs
EP2318-0001 | 8 x M8 | 4 | 0.5 A | 4 | 10 µs
EP2318-0002 | 4 x M12 | 4 | 0.5 A | 4 | 10 µs
EP2328-0001 | 4 x M8 | 4 | 2.0 A (Σ 4 A) | 4 | 3.0 ms
EP2328-0002 | 4 x M12 | 4 | 2.0 A (Σ 4 A) | 4 | 3.0 ms
EP2338-0001 | 8 x M8 | 0 to 8 | 0.5 A (Σ 4 A) | 8 to 0 | 10 µs
EP2338-0002 | 4 x M12 | 0 to 8 | 0.5 A (Σ 4 A) | 8 to 0 | 10 µs
EP2339-0021 | 16 x M8 | 0 to 16 | 0.5 A (Σ 4 A) | 16 to 0 | 3.0 ms
EP2339-0022 | 8 x M12 | 0 to 16 | 0.5 A (Σ 4 A) | 16 to 0 | 3.0 ms
EP2349-0021 | 16 x M8 | 0 to 16 | 0.5 A (Σ 4 A) | 16 to 0 | 10 µs
EP2349-0022 | 8 x M12 | 0 to 16 | 0.5 A (Σ 4 A) | 16 to 0 | 10 µs


EP2008-00xx

Product overview [image] EP2008-00xx
EP2008-00xx
Additional information
•
EP2008 - Introduction
•
EP2008 - Technical data
•
EP2008-000x - Process image


EP2008 - Introduction

Product overview [image] EP2008-00xx [image] EP2008 - Introduction
EP2008 - Introduction
EP2008-0001
EP2008-0002
EP2008-0022
8 digital outputs 24 VDC, Imax 0.5 A
The EP2008 EtherCAT Box with digital outputs connects binary control signals from the controller to the actuators at the process level. The eight outputs process load currents up to 0.5 A and indicate their signal state via LEDs.
The signal connection is made optionally via M8 (EP2008-0001) or M12 connectors (EP2008-0002, EP2008-0022). The outputs are short-circuit proof and protected against inverse connection.
Quick links
Installation
UL requirements
ATEX - Special conditions


EP2008 - Technical data

Product overview [image] EP2008-00xx [image] EP2008 - Technical data
EP2008 - Technical data
Technical data | EP2008-0001 | EP2008-0002 | EP2008-0022
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Number of outputs | 8
Output connections | M8 | M12 | M12
Load type | ohmic, inductive, lamp load
Nominal output voltage | 24 VDC (-15%/+20%)
Output current | max. 0.5 A per channel
Short circuit current | typically 1.5 A
Rise time trise max. 1) | 100 µs
Fall time tfall max. 1) | 150 µs
Supply of the module electronics | from the control voltage Us
Current consumption of the module electronics | typically 120 mA
Output driver supply | from load voltage Up
Output driver current consumption | typically 8 mA per channel
Power supply connection | Feed: 1 x M8 plug, 4-pin Downstream connection: 1 x M8 socket, 4-pin
Electrical isolation | 500 V (fieldbus / IO)
Permissible ambient temperature during operation | -25°C ... +60°C 0°C ... +55°C (conforms to cURus, see UL requirements) 0°C ... +55°C (conforms to ATEX, see special conditions)
Permissible ambient temperature during storage | -40 °C ... +85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Mounting position | variable
Approvals | CE, cURus, ATEX
1) Electrical switching times of the output driver.
The switching times were measured without load and recorded with threshold values of 10% and 90%, as shown in the figure below.
When estimating the switching times of a system, also consider the latency time of the fieldbus.
Digital output - t_rise t_fall
Switching times of the output driver


EP2008-000x - Process image

Product overview [image] EP2008-00xx [image] EP2008-000x - Process image
EP2008-000x - Process image
Channel 1 to Channel 8
Under Channel 1 to Channel 8 you will find the 8 digital outputs of the module (here as an example the EP2008-0001).
Data types
TC3 OutputVariableContainer Symbol Channel n
TC3 OutputVariable Symbol indent Output: BIT


EP2028-000x

Product overview [image] EP2028-000x
EP2028-000x
Additional information
•
EP2028 - Introduction
•
EP2028 - Technical data
•
EP2028-000x - Process image


EP2028 - Introduction

Product overview [image] EP2028-000x [image] EP2028 - Introduction
EP2028 - Introduction
EP2028
8 digital outputs 24 VDC, Imax 2 A (Σ 4 A)
The EP2028 EtherCAT Box with digital outputs connects binary control signals from the controller to the actuators at the process level. The eight outputs process load currents up to 2 A each, although the total current is limited to 4 A. This makes these modules particularly suitable for applications in which not all of the outputs are active at the same time, or in which not all actuators require signal currents of 2 A.
The signal state is indicated by means of LEDs. The signals are connected optionally via M8 connectors (EP2028-0010) or M12 connectors (EP2028-0002). The outputs are short-circuit proof and protected against inverse connection.
Quick links
Installation
UL requirements
ATEX - Special conditions


EP2028 - Technical data

Product overview [image] EP2028-000x [image] EP2028 - Technical data
EP2028 - Technical data
Technical data | EP2028-0001 | EP2028-0002
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Number of outputs | 8
Output connections | M8 | M12
Load type | ohmic, inductive, lamp load
Nominal output voltage | 24 VDC (-15%/+20%)
Output current | max. 2.0 A per channel, sum current of all outputs max. 4.0 A
Short circuit current | maximum 4.0 A
Supply of the module electronics | from the control voltage Us
Current consumption of the module electronics | typically 120 mA
Output driver supply | from load voltage Up
Output driver current consumption | typically 8 mA per channel
Power supply connection | Feed: 1 x M8 plug, 4-pin Downstream connection: 1 x M8 socket, 4-pin
Electrical isolation | 500 V (fieldbus / IO)
Permissible ambient temperature during operation | -25 °C ... +60 °C 0 °C ... +55 °C (conforms to cURus, see UL requirements) 0 °C ... +55 °C (according to ATEX, see special conditions)
Permissible ambient temperature during storage | -40 °C ... +85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Mounting position | variable
Approvals | CE, cURus, ATEX


EP2028-000x - Process image

Product overview [image] EP2028-000x [image] EP2028-000x - Process image
EP2028-000x - Process image
Channel 1 to Channel 8
Under Channel 1 to Channel 8 you will find the 8 digital outputs of the module (here as an example the EP2028-0001).
Data types
TC3 OutputVariableContainer Symbol Channel n
TC3 OutputVariable Symbol indent Output: BIT


EP2028-0032

Product overview [image] EP2028-0032
EP2028-0032
Additional information
•
EP2028-0032 - Introduction
•
EP2028-0032 - Technical data
•
EP2028-00xx - Process image


EP2028-0032 - Introduction

Product overview [image] EP2028-0032 [image] EP2028-0032 - Introduction
EP2028-0032 - Introduction
EP2028-0032
8 digital outputs 24 VDC, Imax 2.8 A (Σ 16 A)
The EP2028-0032 EtherCAT Box with digital outputs connects binary control signals from the controller to the actuators at the process level.
The eight outputs process load currents up to 2.8 A each, although the total current is limited to 16 A.
This makes these modules particularly suitable for applications in which a high simultaneity factor is required with a high equalizing current.
The signal state is indicated by means of LEDs. The signals are connected via M12 connectors. The outputs are short-circuit proof and protected against inverse connection.
Pins 2 and 4 of channels 0 and 1, channels 2 and 3, channels 4 and 5 and channels 6 and 7 are connected.
This means that actuators that require two outputs can also be connected via an M12 cable.
Quick links
Conductor losses 7/8"
Installation
Actuator connection
UL requirements


EP2028-0032 - Technical data

Product overview [image] EP2028-0032 [image] EP2028-0032 - Technical data
EP2028-0032 - Technical data
Technical data | EP2028-0032
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Number of outputs | 8
Output connections | M12
Load type | ohmic, inductive, lamp load
Nominal output voltage | 24 VDC (-15%/+20%)
Output current | max. 2.8 A per channel, sum current of all outputs max. 16 A at 40 °C
Short circuit current | maximum 4.0 A
Supply of the module electronics | from the control voltage Us
Current consumption of the module electronics | typically 120 mA
Output driver supply | from load voltage Up
Output driver current consumption | typically 8 mA per channel
Power supply connection | Feed: 1 x 7/8" plug, 5-pin Downstream connection: 1 x 7/8" socket, 5-pin
Electrical isolation | 500 V (fieldbus / IO)
Permissible ambient temperature during operation | -25°C ... +60°C 0°C ... +55°C (conforms to cURus, see UL requirements)
Permissible ambient temperature during storage | -40 °C ... +85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Mounting position | variable
Approvals | CE, cURus


EP2028-00xx - Process image

Product overview [image] EP2028-0032 [image] EP2028-00xx - Process image
EP2028-00xx - Process image
Channel 1 to Channel 8
Under Channel 1 to Channel 8 you will find the 8 digital outputs of the module (here as an example the EP2028-0001).
Data types
TC3 OutputVariableContainer Symbol Channel n
TC3 OutputVariable Symbol indent Output: BIT


EP2038-000x

Product overview [image] EP2038-000x
EP2038-000x
Additional information
•
EP2038-000x - Introduction
•
EP2038-000x - Technical data
•
EP2038-000x - Status LEDs
•
EP2038-0001 - Process image


EP2038-000x - Introduction

Product overview [image] EP2038-000x [image] EP2038-000x - Introduction
EP2038-000x - Introduction
EP2038-0001
EP2038-0002
8-channel digital output 24 VDC, IMAX 2 A (Ʃ 4 A), with diagnostics
The EP2038 EtherCAT Box with digital outputs connects binary control signals from the controller to the actuators at the process level. The eight outputs process load currents up to 2 A each, although the total current is limited to 4 A. This makes these modules particularly suitable for applications in which not all of the outputs are active at the same time, or in which not all actuators require signal currents of 2 A.
The signal state is indicated by status LEDs. The EP2038 offers output diagnostics in the form of short circuit and open circuit detection per channel. The signals are optionally connected via M8 (EP2038-0001) or M12 (EP2038-0002) screw type connectors.
Quick links
Installation
UL Requirements


EP2038-000x - Technical data

Product overview [image] EP2038-000x [image] EP2038-000x - Technical data
EP2038-000x - Technical data
Technical data | EP2038-0001 | EP2038-0002
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Number of outputs | 8
Output connections | M8 | M12
Load type | ohmic, inductive, lamp load
Nominal output voltage | 24 VDC (-15 % / +20 %)
Output current | max. 2 A per channel, sum current of all outputs max. 4 A
Minimum permitted load | typ. 20 mA + load
Diagnostics | Short circuit, open circuit detection (min. load > 200 mA)
Supply of the module electronics | from the control voltage Us
Current consumption of the module electronics | typically 120 mA
Short circuit current | max. 7 A
Power supply connection | Feed: 1 x M8 plug, 4-pin Downstream connection: 1 x M8 socket, 4-pin
Electrical isolation | 500 V (fieldbus / IO)
Distributed clocks | -
Weight | approx. 165 g
Permissible ambient temperature during operation | -25 °C ... +60 °C 0 °C ... +55 °C (conforms to cURus, see UL requirements)
Permissible ambient temperature during storage | -40°C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (according to EN 60529)
Mounting position | variable
Approvals | CE, cURus


EP2038-000x - Status LEDs

Product overview [image] EP2038-000x [image] EP2038-000x - Status LEDs
EP2038-000x - Status LEDs
EP2038-0001, EP2038-0002 - Status LEDs
LED Displays
LED | Display | Meaning
STATUS 0-7 | green illuminated | the respective output is active
 | red illuminated | the respective output has an error
Us | off | The supply voltage, Us, is not present
 | green illuminated | The supply voltage, Us, is present
Up | off | The supply voltage, Up, is not present
 | green illuminated | The supply voltage, Up, is present


EP2038-0001 - Process image

Product overview [image] EP2038-000x [image] EP2038-0001 - Process image
EP2038-0001 - Process image
Channel 1 to Channel 8
Under Diag Channel 1 to Diag Channel 8 you will find the diagnostic inputs of the 8 digital outputs of the module. Under Channel 1 to Channel 8 you will find the 8 digital outputs of the module (here as an example the EP2038-0001).
Data types
TC3 InputVariableContainer Symbol Diag Channel n
 TC3 InputVariable Symbol indent Input: BIT
TC3 OutputVariableContainer Symbol Channel n
TC3 OutputVariable Symbol indent Output: BIT


EP2308, EP2318, EP2328

Product overview [image] EP2308, EP2318, EP2328
EP2308, EP2318, EP2328
Additional information
•
EP2308, EP2318, EP2328 - Introduction
•
EP2308, EP2318 - Technical Data
•
EP2328 - Technical Data
•
EP2308-000x, EP2318-000x, EP2328-000x - Process image


EP2308, EP2318, EP2328 - Introduction

Product overview [image] EP2308, EP2318, EP2328 [image] EP2308, EP2318, EP2328 - Introduction
EP2308, EP2318, EP2328 - Introduction
EP2308, EP2318, EP2328
4 digital inputs 24 VDC and 4 digital outputs 24 VDC, Imax 0.5 A or 2 A
The EP2308, EP2318 and EP2328 EtherCAT-Box modules combine four digital inputs and four digital outputs in one device.
The state of each signal is indicated by means of light emitting diodes. The signals are optionally connected via M8 connectors (EP23x8-0001) or M12 connectors (EP23x8-0002).
Various filter constants are available for the inputs. The outputs process load currents up to 0.5 A (EP2308, EP2318) or 2 A (EP2328) and are short-circuit proof and protected against inverse polarity.
Quick links
Installation
UL requirements
ATEX - Special conditions


EP2308, EP2318 - Technical Data

Product overview [image] EP2308, EP2318, EP2328 [image] EP2308, EP2318 - Technical Data
EP2308, EP2318 - Technical Data
Technical data | EP2308-0001 | EP2308-0002 | EP2318-0001 | EP2318-0002
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Number of inputs | 4
Input connections | M8 | M12 | M8 | M12
Nominal input voltage | 24 VDC (-15%/+20%)
Input filter | 3.0 ms | 3.0 ms | 10 µs | 10 µs
Signal voltage "0" | -3...+5 V (EN 61131-2, type 3)
Signal voltage "1" | +11...+30 V (EN 61131-2, type 3)
Input current | typically 3 mA (EN 61131-2, type 3)
Sensor supply | derived from control voltage, max. 0.5 A total, short-circuit proof
Number of outputs | 4
Output connections | M8 | M12 | M8 | M12
Load type | ohmic, inductive, lamp load
Nominal output voltage | 24 VDC (-15%/+20%)
Output current | max. 0.5 A per channel
Short circuit current | maximum 1.5 A
Supply of the module electronics | from the control voltage Us
Current consumption of the module electronics | typically 120 mA
Output driver supply | from load voltage Up
Output driver current consumption | typically 8 mA per channel
Power supply connection | Feed: 1 x M8 plug, 4-pin Downstream connection: 1 x M8 socket, 4-pin
Electrical isolation | 500 V (fieldbus / IO)
Permissible ambient temperature during operation | -25 °C ... +60 °C 0 °C ... +55 °C (conforms to cURus, see UL requirements) 0 °C ... +55 °C (according to ATEX, see special conditions)
Permissible ambient temperature during storage | -40 °C ... +85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Mounting position | variable
Approvals | CE, cURus, ATEX


EP2328 - Technical Data

Product overview [image] EP2308, EP2318, EP2328 [image] EP2328 - Technical Data
EP2328 - Technical Data
Technical data | EP2328-0001 | EP2328-0002
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Number of inputs | 4
Input connections | M8 | M12
Nominal input voltage | 24 VDC (-15%/+20%)
Input filter | 3.0 ms
Signal voltage "0" | -3...+5 V (EN 61131-2, type 3)
Signal voltage "1" | +11...+30 V (EN 61131-2, type 3)
Input current | typically 3 mA (EN 61131-2, type 3)
Sensor supply | derived from control voltage, max. 0.5 A total, short-circuit proof
Number of outputs | 4
Output connections | M8 | M12
Load type | ohmic, inductive, lamp load
Nominal output voltage | 24 VDC (-15%/+20%)
Output current | max. 2.0 A per channel, sum current of all outputs max. 4 A
Short circuit current | maximum 4.0 A
Supply of the module electronics | from the control voltage Us
Current consumption of the module electronics | typically 120 mA
Output driver supply | from load voltage Up
Output driver current consumption | typically 8 mA per channel
Power supply connection | Feed: 1 x M8 plug, 4-pin Downstream connection: 1 x M8 socket, 4-pin
Electrical isolation | 500 V (fieldbus / IO)
Permissible ambient temperature during operation | -25 °C ... +60 °C 0 °C ... +55 °C (conforms to cURus, see UL requirements) 0 °C ... +55 °C (according to ATEX, see special conditions)
Permissible ambient temperature during storage | -40 °C ... +85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Mounting position | variable
Approvals | CE, cURus, ATEX


EP2308-000x, EP2318-000x, EP2328-000x - Process image

Product overview [image] EP2308, EP2318, EP2328 [image] EP2308-000x, EP2318-000x, EP2328-000x - Process image
EP2308-000x, EP2318-000x, EP2328-000x - Process image
DI Inputs
Under Channel 1 to Channel 4 you will find the 4 digital inputs of the module (in the example the EP2308-0001).
Data types
TC3 InputVariableContainer Symbol Channel n
TC3 InputVariable Symbol indent Input: BIT
DO Outputs
Under Channel 5 to Channel 8 you will find the 4 digital outputs of the module (in the example the EP2308-0001).
Data types
TC3 OutputVariableContainer Symbol Channel n
TC3 OutputVariable Symbol indent Output: BIT


EP2316-0003, EP2316-0008

Product overview [image] EP2316-0003, EP2316-0008
EP2316-0003, EP2316-0008
Additional information
•
EP2316-0003 - Introduction
•
EP2316-0008 - Introduction
•
EP2316-000x - Technical Data
•
EP2316-0008 - Status LEDs
•
EP2316-0008 - Process image


EP2316-0003 - Introduction

Product overview [image] EP2316-0003, EP2316-0008 [image] EP2316-0003 - Introduction
EP2316-0003 - Introduction
EP2316-0003
8 digital inputs, 24 V DC, 8 digital outputs, 24 VDC, Imax 0.5 A
The EP2316 EtherCAT Box combines eight digital inputs and eight digital outputs in one device . The inputs are available with a 10 μs filter constant.
The outputs process load currents up to 0.5 A, are short-circuit proof and protected against inverse polarity. Signal state and status are indicated by LEDs.
The signal connection is made via two ZS2001 connectors with spring-loaded system, optionally available with 1 or 3 pins. The module is delivered without connector.
Quick links
Installation
Configuration
UL Requirements


EP2316-0008 - Introduction

Product overview [image] EP2316-0003, EP2316-0008 [image] EP2316-0008 - Introduction
EP2316-0008 - Introduction
EP2316-0008
8 digital inputs, 24 V DC, 8 digital outputs, 24 VDC, Imax 0.5 A
The EP2316 EtherCAT Box combines eight digital inputs and eight digital outputs in one device . The inputs are available with a 10 μs filter constant.
The outputs process load currents up to 0.5 A, are short-circuit proof and protected against inverse polarity.
The signal connection is made through a 25-pin D-Sub socket.
The signal state and the status are displayed in groups by light emitting diodes.
Quick links
Installation
Configuration
UL requirements


EP2316-000x - Technical Data

Product overview [image] EP2316-0003, EP2316-0008 [image] EP2316-000x - Technical Data
EP2316-000x - Technical Data
Technical data | EP2316-0003 | EP2316-0008
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Number of inputs | 8
Input connections | ZS2001 connector | 25-pin D-Sub socket (pins 1 – 8)
Nominal input voltage | 24 VDC (-15%/+20%)
Input filter | 10 µs
Signal voltage "0" | -3...+5 V (EN 61131-2, type 3)
Signal voltage "1" | +11...+30 V (EN 61131-2, type 3)
Input current | typically 3 mA (EN 61131-2, type 3)
Sensor supply | derived from control voltage, max. 0.5 A total, short-circuit proof
Number of outputs | 8
Output connections | ZS2001 connector | 25-pin D-Sub socket (pins 9 – 16)
Load type | ohmic, inductive, lamp load
Nominal output voltage | 24 VDC (-15%/+20%)
Output current | max. 0.5 A per channel, individually short-circuit proof, sum current of all outputs max. 4 A
Short circuit current | maximum 1.5 A
Supply of the module electronics | from the control voltage Us
Current consumption of the module electronics | typically 120 mA
Output driver supply | from load voltage Up
Output driver current consumption | max. 30 mA for all channels
Power supply connection | Feed: 1 x M8 plug, 4-pin Downstream connection: 1 x M8 socket, 4-pin
Electrical isolation | 500 V (fieldbus / IO)
Permissible ambient temperature during operation | -25 °C ... +60 °C | -25 °C ... +60 °C 0 °C ... +55 °C (conforms to cURus, see UL requirements)
Permissible ambient temperature during storage | -40 °C ... +85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20 | IP65, IP66, IP67 (conforms to EN 60529)
Mounting position | variable
Approvals | CE, cURus


EP2316-0008 - Status LEDs

Product overview [image] EP2316-0003, EP2316-0008 [image] EP2316-0008 - Status LEDs
EP2316-0008 - Status LEDs
EP2316-0008 - Status LEDs
LED Displays
LED | Display | Meaning
STATUS 1-8 | green illuminated | A signal (24 V) is present at a least one of the inputs for channels 1-8
STATUS 9-16 | green illuminated | at least one of the outputs for channel 9-16 is set
 | red illuminated | at least one output of channels 9-16 has an error
Us | off | The supply voltage, Us, is not present
 | green illuminated | The supply voltage, Us, is present
Up | off | The supply voltage, Up, is not present
 | green illuminated | The supply voltage, Up, is present


EP2316-0008 - Process image

Product overview [image] EP2316-0003, EP2316-0008 [image] EP2316-0008 - Process image
EP2316-0008 - Process image
DIG Inputs
You will find the 8 digital inputs of the module under DIG Inputs.
Data types
TC3 InputVariableContainer Symbol DIG Inputs
TC3 InputVariable Symbol indent Input n: BIT
TC3 InputVariable Symbol indent Sync Error: BIT
DIG Diag Inputs
You will find the diagnostic inputs for the module's 8 digital outputs under DIG Diag Inputs.
Data types
TC3 InputVariableContainer Symbol DIG Diag Inputs
 TC3 InputVariable Symbol indent Diag Input n: BIT
Diag Input n
Indicates an error on Output n.
DIG Inputs Device
You will find the module's status inputs under DIG Inputs Device.
Data types
TC3 InputVariableContainer Symbol DIG Inputs Device
 TC3 InputVariable Symbol indent Safe state active: BIT
TC3 InputVariable Symbol indent Error channel 1: BIT
TC3 InputVariable Symbol indent Error channel 2: BIT
TC3 InputVariable Symbol indent Sync error: BIT
TC3 InputVariable Symbol indent TxPDO Toggle: BIT
Safe state active
Indicates whether the safe state has been assumed. The display only works if the network transmits process input data, i.e. in the network states Operational (OP) and Safe-Operational (Safe-OP), but not in the network state INIT.
Error channel X
Indicates an error on channel X.
Sync Error
See EtherCAT system documentation. The EtherCAT system documentation is available on the Beckhoff homepage under Downloads.
TxPDO Toggle
See EtherCAT system documentation.
DIG Outputs
You will find the 8 digital outputs of the module under DIG Outputs.
Data types
TC3 OutputVariableContainer Symbol DIG Outputs
TC3 OutputVariable Symbol indent Output n: BIT
DIG Outputs Device
You will find the module's control outputs under DIG Outputs Device.
Data types
TC3 OutputVariableContainer Symbol DIG Outputs Device
TC3 OutputVariable Symbol indent Set safe state: BIT
TC3 OutputVariable Symbol indent Reset outputs: BIT
Set safe state
Sets the module to the safe state.
Reset outputs
Resets the error bits "Error channel X" of the module. The outputs are reactivated.


EP2338-x00x

Product overview [image] EP2338-x00x
EP2338-x00x
Additional information
•
EP2338 - Introduction
•
EP2338 - Technical Data
•
EP2338-x00x - Process image


EP2338 - Introduction

Product overview [image] EP2338-x00x [image] EP2338 - Introduction
EP2338 - Introduction
EP2338-0001, EP2338-1001
EP2338-0002, EP2338-1002
8 digital inputs or outputs, 24 VDC
The EP2338 EtherCAT Box has eight digital channels, each of which can optionally be operated as an input or as an output. A configuration whether a channel is to be used as input or output is not required; the input circuit is internally fixed to the output driver so that a set output is automatically displayed in the input process image.
The outputs process load currents up to 0.5 A, are short-circuit proof and protected against inverse polarity.
The inputs have a filter constant of 10 µs (EP2338-0001, EP2338-0002) or a filter constant of 3 ms (EP2338-1001, EP2338-1002).
The state of each signal is indicated by means of light emitting diodes. The signals are optionally connected via M8 (EP2338-x001) or M12 connectors (EP2338-x002).
Supply of the connected sensors from Up, not from Us
In contrast to many other modules, the EP2338 EtherCAT Box supplies digital sensors from the Up peripheral voltage and not from the Us control voltage! This is because the connections can be used either as input or output. Nevertheless, an overload of the sensor supply (current > 0.5 A) is also indicated here by the illuminated red Us LED.
Note
For switch-off in the event of a fault, do not supply sensors externally
If the design of your installation is such that the power supply voltage Up is switched off in the event of a fault, you must not power the connected sensors externally, but only through the EP23x8! Otherwise, when the Up energy is switched off, the EP23x8 can continue to draw energy from the external sensor supply, and the outputs will not be switched off.
Quick links
Installation
UL requirements
ATEX - Special conditions


EP2338 - Technical Data

Product overview [image] EP2338-x00x [image] EP2338 - Technical Data
EP2338 - Technical Data
Technical data | EP2338-0001 | EP2338-1001 | EP2338-0002 | EP2338-1002
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Number of outputs | 8 to 0
Output connections | M8 |  | M12
Load type | ohmic, inductive, lamp load
Nominal output voltage | 24 VDC (-15%/+20%)
Output current | max. 0.5 A per channel
Short circuit current | maximum 1.5 A
Supply of the module electronics | from the control voltage Us
Current consumption of the module electronics | typically 120 mA
Output driver supply | from load voltage Up
Output driver current consumption | typically 20 mA
Number of inputs | 0 to 8
Input connections | M8 |  | M12
Nominal input voltage | 24 VDC (-15%/+20%)
Input filter | 10 µs | 3 ms | 10 µs | 3 ms
Signal voltage "0" | -3...+5 V (EN 61131-2, type 3)
Signal voltage "1" | +11...+30 V (EN 61131-2, type 3)
Input current | typically 3 mA (EN 61131-2, type 3)
Sensor supply | from the peripheral voltage Up, max. 0.5 A, total short-circuit proof
Power supply connection | Feed: 1 x M8 plug, 4-pin Downstream connection: 1 x M8 socket, 4-pin
Electrical isolation | 500 V (fieldbus / IO)
Permissible ambient temperature during operation | -25° C ... +60 °C 0 °C ... +55 °C (conforms to cURus, see UL requirements) 0 °C ... +55 °C (according to ATEX, see special conditions)
Permissible ambient temperature during storage | -40 °C ... +85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Mounting position | variable
Approvals | CE, cURus, ATEX


EP2338-x00x - Process image

Product overview [image] EP2338-x00x [image] EP2338-x00x - Process image
EP2338-x00x - Process image
DI Inputs
Under Channel 1 to Channel 8 you will find the 8 digital inputs of the module (in the example the EP2338-0001).
Data types
TC3 InputVariableContainer Symbol Channel n
 TC3 InputVariable Symbol indent Input: BIT
DO Outputs
Under Channel 1 to Channel 8 you will find the 8 digital outputs of the module (in the example the EP2338-0001).
Data types
TC3 OutputVariableContainer Symbol Channel n
 TC3 OutputVariable Symbol indent Output: BIT


EP2339-002x

Product overview [image] EP2339-002x
EP2339-002x
Additional information
•
EP2339-0021 - Introduction
•
EP2339-0022 - Introduction
•
EP2339 - Technical Data
•
EP2339-0021 - Process image


EP2339-0021 - Introduction

Product overview [image] EP2339-002x [image] EP2339-0021 - Introduction
EP2339-0021 - Introduction
EP2339-0021
16 digital inputs or outputs, 24 VDC
The EP2339-0021 EtherCAT Box has 16 digital channels, each of which can be operated as inputs or outputs. A configuration whether a channel is to be used as input or output is not required; the input circuit is internally fixed to the output driver so that a set output is automatically displayed in the input process image.
The outputs process load currents up to 0.5 A, are short-circuit proof and protected against inverse polarity.
The filter constant of the inputs is 3 ms.
The state of each signal is indicated by means of light emitting diodes. The signals are connected via M8 connectors.
Supply of the connected sensors from Up, not from Us
In contrast to many other modules, the EP2339-0021 EtherCAT Box supplies digital sensors from the Up peripheral voltage and not from the Us control voltage! This is because the connections can be used either as input or output. Nevertheless, an overload of the sensor supply (current > 0.5 A) is also indicated here by the illuminated red Us LED.
Note
For shutdown in the event of a fault, do not supply sensors externally
If the design of your installation is such that the power supply voltage Up is switched off in the event of a fault, you must not power the connected sensors externally, but only through the EP2339-0021! Otherwise, when the Up energy is switched off, the EP2339-0021 can continue to draw energy from the external sensor supply, and the outputs will not be switched off.
Quick links
Installation
UL Requirements


EP2339-0022 - Introduction

Product overview [image] EP2339-002x [image] EP2339-0022 - Introduction
EP2339-0022 - Introduction
EP2339-0022
16 digital inputs or outputs, 24 VDC
The EP2339-0022 EtherCAT Box has 16 digital channels, each of which can be operated as inputs or outputs. A configuration whether a channel is to be used as input or output is not required; the input circuit is internally fixed to the output driver so that a set output is automatically displayed in the input process image.
The outputs process load currents up to 0.5 A, are short-circuit proof and protected against inverse polarity.
The filter constant of the inputs is 3 ms.
The state of each signal is indicated by means of light emitting diodes. The signals are connected via M12 connectors.
Supply of the connected sensors from Up, not from Us
In contrast to many other modules, the EP2339-0022 EtherCAT Box supplies digital sensors from the Up peripheral voltage and not from the Us control voltage! This is because the connections can be used either as input or output. Nevertheless, an overload of the sensor supply (current > 0.5 A) is also indicated here by the illuminated red Us LED.
Note
For switch-off in the event of a fault, do not supply sensors externally
If the design of your installation is such that the power supply voltage Up is switched off in the event of a fault, you must not power the connected sensors externally, but only through the EP2339-0022! Otherwise, when the Up energy is switched off, the EP2339-0022 can continue to draw energy from the external sensor supply, and the outputs will not be switched off.
Quick links
Installation
UL Requirements


EP2339 - Technical Data

Product overview [image] EP2339-002x [image] EP2339 - Technical Data
EP2339 - Technical Data
Technical data | EP2339-0021 | EP2339-0022
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Number of outputs | 16 to 0
Output connections | M8 | M12
Load type | ohmic, inductive, lamp load
Nominal output voltage | 24 VDC (-15%/+20%)
Output current | max. 0.5 A per channel
Short circuit current | maximum 1.5 A
Supply of the module electronics | from the control voltage Us
Current consumption of the module electronics | typically 120 mA
Output driver supply | from load voltage Up
Output driver current consumption | typically 20 mA
Input connections | M8 | M12
Number of inputs | 0 to 16
Nominal input voltage | 24 VDC (-15%/+20%)
Input filter | 3.0 ms
Signal voltage "0" | -3...+5 V (EN 61131-2, type 3)
Signal voltage "1" | +11...+30 V (EN 61131-2, type 3)
Input current | typically 3 mA (EN 61131-2, type 3)
Sensor supply | from the peripheral voltage Up, max. 0.5 A, total short-circuit proof
Power supply connection | Feed: 1 x M8 plug, 4-pin Downstream connection: 1 x M8 socket, 4-pin
Electrical isolation | 500 V (fieldbus / IO)
Permissible ambient temperature during operation | -25 °C ... +60 °C
Permissible ambient temperature during storage | -40 °C ... +85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Mounting position | variable
Approvals | CE


EP2339-0021 - Process image

Product overview [image] EP2339-002x [image] EP2339-0021 - Process image
EP2339-0021 - Process image
Inputs
Under Channel 1 to Channel 16 you will find the 16 digital inputs of the module (here as an example the EP2339-0021).
Data types
TC3 InputVariableContainer Symbol Channel n
TC3 InputVariable Symbol indent Input: BIT
Outputs
Under Channel 1 to Channel 16 you will find the 16 digital outputs of the module (here as an example the EP2339-0021).
Data types
TC3 OutputVariableContainer Symbol Channel n
TC3 OutputVariable Symbol indent Output: BIT


EP2349-002x

Product overview [image] EP2349-002x
EP2349-002x
Additional information
•
EP2349-002x - Introduction
•
EP2349-002x - Technical data
•
EP2349-002x - Process image


EP2349-002x - Introduction

Product overview [image] EP2349-002x [image] EP2349-002x - Introduction
EP2349-002x - Introduction
EP2349-0021
EP2349-0022
16 digital inputs or outputs, 24 VDC, freely selectable, 10 µs filter
The EP2349 EtherCAT Box has 16 freely selectable digital inputs or outputs on one device. The filter constant of the inputs is 10 µs. The outputs are short-circuit proof and protected against inverse connection and process load currents up to 0.5 A, whereby the total current is limited to 4 A. The state of each signal is indicated by means of light emitting diodes. The signals are optionally connected via M8 (EP2349-0021) or M12 (EP2349-0022) connectors. The sensors are powered by the load voltage UP.
Supply of the connected sensors from Up, not from Us
In contrast to many other modules, the EP2349-002x EtherCAT Box supplies digital sensors from the Up peripheral voltage and not from the Us control voltage! This is because the connections can be used either as input or output. Nevertheless, an overload of the sensor supply (current > 0.5 A) is also indicated here by the illuminated red Us LED.
Note
For shutdown in the event of a fault, do not supply sensors externally
If the design of your installation is such that the power supply voltage Up is switched off in the event of a fault, you must not power the connected sensors externally, but only through the EP2349-002x! Otherwise, when the Up energy is switched off, the EP2349-002x can continue to draw energy from the external sensor supply, and the outputs will not be switched off.
Quick links
Installation
UL Requirements


EP2349-002x - Technical data

Product overview [image] EP2349-002x [image] EP2349-002x - Technical data
EP2349-002x - Technical data
Technical data | EP2349-0021 | EP2349-0022
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Number of outputs | 16 to 0
Output connections | M8 | M12
Load type | ohmic, inductive, lamp load
Nominal output voltage | 24 VDC (-15%/+20%)
Output current | max. 0.5 A each channel, individually short-circuit proof, sum current max. 4 A
Short circuit current | maximum 1.5 A
Supply of the module electronics | from the control voltage Us
Current consumption of the module electronics | typically 130 mA
Output driver supply | from load voltage Up
Output driver current consumption | typically 20 mA
Input connections | M8 | M12
Number of inputs | 0 to 16
Nominal input voltage | 24 VDC (-15%/+20%)
Input filter | 10 µs
Signal voltage "0" | -3...+5 V (EN 61131-2, type 3)
Signal voltage "1" | +11...+30 V (EN 61131-2, type 3)
Input current | typically 6 mA (EN 61131-2, type 3)
Sensor supply | from the peripheral voltage Up, max. 0.5 A, total short-circuit proof
Power supply connection | Feed: 1 x M8 plug, 4-pin Downstream connection: 1 x M8 socket, 4-pin
Electrical isolation | 500 V (fieldbus / IO)
Weight | approx. 250 g
Permissible ambient temperature during operation | 0 °C ... +55 °C
Permissible ambient temperature during storage | -25 °C ... +85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Mounting position | variable
Approvals | CE


EP2349-002x - Process image

Product overview [image] EP2349-002x [image] EP2349-002x - Process image
EP2349-002x - Process image
Inputs
Under Channel 1 to Channel 16 you will find the 16 digital inputs of the module (here as an example the EP2349-0021).
Data types
TC3 InputVariableContainer Symbol Channel n
TC3 InputVariable Symbol indent Input: BIT
Outputs
Under Channel 17 to Channel 32 you will find the 16 digital outputs of the module (here as an example the EP2349-0021).
Data types
TC3 OutputVariableContainer Symbol Channel n
TC3 OutputVariable Symbol indent Output: BIT


EP2624-0002

Product overview [image] EP2624-0002
EP2624-0002
Additional information
•
EP2624-0002 - Introduction
•
EP2624-0002 - Technical data
•
EP2624-0002 - Process image


EP2624-0002 - Introduction

Product overview [image] EP2624-0002 [image] EP2624-0002 - Introduction
EP2624-0002 - Introduction
EP2624-0002
Relay module with four single contacts, 25 VAC / 30 VDC
The EP2624-0002 EtherCAT Box has four relays with potential-free contacts. The relays switch voltages up to 25 VAC or 30 VDC.
The EtherCAT Box indicates the signal state of the individual relays by means of LEDs. The power supply is passed through.
Quick links
Installation
UL requirements
ATEX notes


EP2624-0002 - Technical data

Product overview [image] EP2624-0002 [image] EP2624-0002 - Technical data
EP2624-0002 - Technical data
Technical data | EP2624-0002
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Number of outputs | 4 make contacts
Output connections | M12
Load type | ohmic, inductive, lamp load
Nominal output voltage | 25 VAC / 30 VDC
Ohmic switching current | 0.5 AAC / 2 ADC per channel
Minimum permitted load | 10 µA at 10 mVDC
Mechanical switching cycles | min. 1 x 108
Electrical switching cycles | min. 2 x 105 (1 A / 30 VDC)
Supply of the module electronics | from the control voltage Us
Current consumption of the module electronics | typically 200 mA
Power supply connection | Feed: 1 x M8 plug, 4-pin Downstream connection: 1 x M8 socket, 4-pin
Electrical isolation | 500 V (fieldbus / IO)
Permissible ambient temperature during operation | -25 °C ... +60 °C 0 °C ... +55 °C (conforms to cURus, see UL requirements) 0 °C ... +55 °C (according to ATEX, see special conditions)
Permissible ambient temperature during storage | -40 °C ... +85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Mounting position | variable
Approvals | CE, cURus, ATEX


EP2624-0002 - Process image

Product overview [image] EP2624-0002 [image] EP2624-0002 - Process image
EP2624-0002 - Process image
Channel 1 to Channel 4
Under Channel 1 to Channel 4 you will find the 4 digital outputs of the module.
Data types
TC3 OutputVariableContainer Symbol Channel n
TC3 OutputVariable Symbol indent Output: BIT


EP2809-002x

Product overview [image] EP2809-002x
EP2809-002x
Additional information
•
EP2809-0021 - Introduction
•
EP2809-0022 - Introduction
•
EP2809 - Technical data
•
EP2809-0021 - Process image


EP2809-0021 - Introduction

Product overview [image] EP2809-002x [image] EP2809-0021 - Introduction
EP2809-0021 - Introduction
EP2809-0021
16 digital outputs 24 VDC, Imax 0.5 A (Σ 4 A)
The EP2809-0021 EtherCAT Box with digital outputs connects binary control signals from the controller to the actuators at the process level.
The 16 outputs process load currents up to 0.5 A each, although the total current is limited to 4 A. This makes these modules particularly suitable for applications in which not all of the outputs are active at the same time, or in which not all of the actuators draw 0.5 A signal current.
The signal state is indicated by means of LEDs. The signals are connected via M8 connectors All outputs are short-circuit proof and protected against inverse connection.
Quick links
Installation
UL Requirements


EP2809-0022 - Introduction

Product overview [image] EP2809-002x [image] EP2809-0022 - Introduction
EP2809-0022 - Introduction
EP2809-0022
16 digital outputs 24 VDC, Imax 0.5 A (Σ 4 A)
The EP2809-0022 EtherCAT Box with digital outputs connects binary control signals from the controller to the actuators at the process level.
The 16 outputs process load currents up to 0.5 A each, although the total current is limited to 4 A. This makes these modules particularly suitable for applications in which not all of the outputs are active at the same time, or in which not all actuators require signal currents of 0.5 A.
The signal state is indicated by means of LEDs. The signals are connected via M12 connectors. All outputs are short-circuit proof and protected against inverse connection.
Quick links
Installation
UL requirements


EP2809 - Technical data

Product overview [image] EP2809-002x [image] EP2809 - Technical data
EP2809 - Technical data
Technical data | EP2809-0021 |  | EP2809-0022
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Number of outputs | 16
Output connections | M8 |  | M12
Load type | ohmic, inductive, lamp load
Nominal output voltage | 24 VDC (-15%/+20%)
Output current | max. 0.5 A per channel, sum current of all outputs max. 4.0 A
Short circuit current | maximum 4.0 A
Supply of the module electronics | from the control voltage Us
Current consumption of the module electronics | typically 120 mA
Output driver supply | from load voltage Up
Output driver current consumption | typically 20 mA
Power supply connection | Feed: 1 x M8 plug, 4-pin Downstream connection: 1 x M8 socket, 4-pin
Electrical isolation | 500 V (fieldbus / IO)
Permissible ambient temperature during operation | -25 °C ... +60 °C | -25 °C ... +60 °C 0 °C ... +55 °C (conforms to cURus, see UL requirements)
Permissible ambient temperature during storage | -40 °C ... +85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Mounting position | variable
Approvals | CE | CE, cURus


EP2809-0021 - Process image

Product overview [image] EP2809-002x [image] EP2809-0021 - Process image
EP2809-0021 - Process image
Channel 1 to Channel 16
Under Channel 1 to Channel 16 you will find the 16 digital outputs of the module (here as an example the EP2809-0021).
Data types
TC3 OutputVariableContainer Symbol Channel n
TC3 OutputVariable Symbol indent Output: BIT


EP2816-00xx

Product overview [image] EP2816-00xx
EP2816-00xx
Additional information
•
EP2816-0004 - Introduction
•
EP2816-0008 - Introduction
•
EP2816-0010 - Introduction
•
EP2816-00xx - Technical data
•
EP2816-0004, EP2816-0008 - Status LEDs
•
EP2816-0010 - Status LEDs
•
EP2816-00xx - Process image


EP2816-0004 - Introduction

Product overview [image] EP2816-00xx [image] EP2816-0004 - Introduction
EP2816-0004 - Introduction
EP2816-0004
16 digital outputs 24 VDC, IMAX 0,5 A (∑ 4 A)
The EP2816-0004 EtherCAT Box with digital outputs connects binary control signals from the controller to the actuators at the process level.
The 16 outputs process load currents up to 0.5 A each, although the total current is limited to 4 A. This makes these modules particularly suitable for applications in which not all of the outputs are active at the same time, or in which not all actuators require signal currents of 0.5 A.
All the outputs are short-circuit proof, protected against inverse connection and have diagnostic facilities. An output short-circuit is recognized and passed on to the control level.
The status of the outputs is indicated in groups by status LEDs.
The signal connection is made via a 19-pin M16 socket and is ideally suited for valve terminals with multi-pin plug connection.
Quick links
Installation
Configuration
UL requirements


EP2816-0008 - Introduction

Product overview [image] EP2816-00xx [image] EP2816-0008 - Introduction
EP2816-0008 - Introduction
EP2816-0008
16 digital outputs 24 VDC, Imax 0.5 A (Σ 4 A)
The EP2816-0008 EtherCAT Box with digital outputs connects binary control signals from the controller to the actuators at the process level.
The 16 outputs process load currents up to 0.5 A each, although the total current is limited to 4 A. This makes these modules particularly suitable for applications in which not all of the outputs are active at the same time, or in which not all actuators require signal currents of 0.5 A.
All the outputs are short-circuit proof, protected against inverse connection and have diagnostic facilities. An output short-circuit is recognized and passed on to the control level.
The status of the outputs is indicated in groups by status LEDs.
The signal connection is made through a 25-pin D-Sub socket.
Quick links
Installation
Configuration
UL requirements


EP2816-0010 - Introduction

Product overview [image] EP2816-00xx [image] EP2816-0010 - Introduction
EP2816-0010 - Introduction
EP2816-0010
16 digital outputs 24 VDC, Imax 0.5 A (Σ 4 A)
The EP2816-0010 EtherCAT Box with digital outputs connects binary control signals from the controller to the actuators at the process level.
The 16 outputs process load currents up to 0.5 A each, although the total current is limited to 4 A. This makes these modules particularly suitable for applications in which not all of the outputs are active at the same time, or in which not all actuators require signal currents of 0.5 A.
All the outputs are short-circuit proof, protected against inverse connection and have diagnostic facilities. An output short-circuit is recognized and passed on to the control level.
The status of the outputs is indicated in groups by status LEDs.
The signal connection is made through two 9-pin D-sub sockets.
Quick links
Installation
Configuration
UL requirements


EP2816-00xx - Technical data

Product overview [image] EP2816-00xx [image] EP2816-00xx - Technical data
EP2816-00xx - Technical data
Technical data | EP2816-0004 | EP2816-0008 | EP2816-0010
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Number of outputs | 16
Output connections | M16, 19-pin | 25-pin D-sub socket | Two 9-pin D-sub sockets
Load type | ohmic, inductive, lamp load
Nominal output voltage | 24 VDC (-15%/+20%)
Output current | max. 0.5 A per channel, individually short-circuit proof, sum current of all outputs max. 4.0 A
Short circuit current | maximum 1.5 A
Supply of the module electronics | from the control voltage Us
Current consumption of the module electronics | typically 120 mA
Output driver supply | from load voltage Up
Output driver current consumption | max. 30 mA for all channels
Power supply connection | Feed: 1 x M8 plug, 4-pin Downstream connection: 1 x M8 socket, 4-pin
Electrical isolation | 500 V (fieldbus / IO)
Permissible ambient temperature during operation | -25 °C ... +60 °C 0 °C ... +55 °C (conforms to cURus, see UL requirements)
Permissible ambient temperature during storage | -40 °C ... +85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Mounting position | variable
Approvals | CE, cURus


EP2816-0004, EP2816-0008 - Status LEDs

Product overview [image] EP2816-00xx [image] EP2816-0004, EP2816-0008 - Status LEDs
EP2816-0004, EP2816-0008 - Status LEDs
EP2816-0004 and EP2816-0008 - Status LEDs
LED Displays
LED | Display | Meaning
STATUS 1-8 | green illuminated | at least one of the outputs for channel 1-8 is set
 | red illuminated | at least one of the outputs for channel 1-8 has a short-circuit
STATUS 9-16 | green illuminated | at least one of the outputs for channel 9-16 is set
 | red illuminated | at least one of the outputs for channel 9-16 has a short-circuit
Us | off | The supply voltage, Us, is not present
 | green illuminated | The supply voltage, Us, is present
Up | off | The supply voltage, Up, is not present
 | green illuminated | The supply voltage, Up, is present


EP2816-0010 - Status LEDs

Product overview [image] EP2816-00xx [image] EP2816-0010 - Status LEDs
EP2816-0010 - Status LEDs
EP2816-0010 - Status LEDs
LED Displays
LED | Display | Meaning
STATUS 1-8 | green illuminated | at least one of the outputs for channel 1-8 is set
 | red illuminated | at least one of the outputs for channel 1-8 has a short-circuit
STATUS 9-16 | green illuminated | at least one of the outputs for channel 9-16 is set
 | red illuminated | at least one of the outputs for channel 9-16 has a short-circuit
Us | off | The supply voltage, Us, is not present
 | green illuminated | The supply voltage, Us, is present
Up | off | The supply voltage, Up, is not present
 | green illuminated | The supply voltage, Up, is present


EP2816-00xx - Process image

Product overview [image] EP2816-00xx [image] EP2816-00xx - Process image
EP2816-00xx - Process image
DIG Diag Inputs Channel 1
You will find the diagnostic inputs for the module's first 8 digital outputs under DIG Diag Inputs Channel 1.
Data types
TC3 InputVariableContainer Symbol DIG Diag Inputs Channel 1
TC3 InputVariable Symbol indent Diag Input n: BIT
Diag Input n
Indicates an error on Output n.
DIG Diag Inputs Channel 2
You will find the diagnostic inputs for the module's second 8 digital outputs under DIG Diag Inputs Channel 2.
Data types
TC3 InputVariableContainer Symbol DIG Diag Inputs Channel 2
TC3 InputVariable Symbol indent Diag Input n: BIT
Diag Input n
Indicates an error on Output n.
DIG Inputs Device
You will find the module's status inputs under DIG Inputs Device.
Data types
TC3 InputVariableContainer Symbol DIG Inputs Device
TC3 InputVariable Symbol indent Safe state active: BIT
TC3 InputVariable Symbol indent Error channel 1: BIT
TC3 InputVariable Symbol indent Error channel 1: BIT
TC3 InputVariable Symbol indent Sync error: BIT
TC3 InputVariable Symbol indent TxPDO Toggle: BIT
Safe state active
Indicates whether the safe state has been assumed. The display only works if the network transmits process input data, i.e. in the network states Safe-Operational (Safe-OP) and Operational (OP), but not in the network state INIT.
Error channel X
Indicates an error on channel X.
Sync Error
See EtherCAT system documentation. The EtherCAT system documentation is available on the Beckhoff homepage under Downloads.
TxPDO Toggle
See EtherCAT system documentation.
DIG Outputs Channel 1
You will find the first 8 digital outputs of the module under DIG Outputs Channel 1.
Data types
TC3 OutputVariableContainer Symbol DIG Output Channel 1
TC3 OutputVariable Symbol indent Output n: BIT
DIG Outputs Channel 2
You will find the second 8 digital outputs of the module under DIG Outputs Channel 2.
Data types
TC3 OutputVariableContainer Symbol DIG Output Channel 2
TC3 OutputVariable Symbol indent Output n: BIT
DIG Outputs Device
You will find the module's control outputs under DIG Outputs Device.
Data types
TC3 OutputVariableContainer Symbol DIG Outputs Device
TC3 OutputVariable Symbol indent Set safe state: BIT
 TC3 OutputVariable Symbol indent Reset outputs: BIT
Set safe state
Sets the module to the safe state.
Reset outputs
Resets the error bits "Error channel X" of the module. The outputs are reactivated.


EP2817-0008

Product overview [image] EP2817-0008
EP2817-0008
Additional information
•
EP2817-0008 - Introduction
•
EP2817-0008 - Technical data
•
EP2817-0008 - Status LEDs
•
EP2817-0008 - Process image


EP2817-0008 - Introduction

Product overview [image] EP2817-0008 [image] EP2817-0008 - Introduction
EP2817-0008 - Introduction
EP2817-0008
24 digital outputs 24 VDC, Imax 0.5 A
The EP2817-0008 EtherCAT Box with digital outputs connects binary control signals from the controller to the actuators at the process level.
The twenty-four outputs process load currents up to 0.5 A each.
All the outputs are short-circuit proof, protected against inverse connection and have diagnostic facilities. An output short-circuit is recognized and passed on to the controller.
The signal connection is made through a 25-pin D-Sub socket.
The signal state is indicated for signal groups through status-light emitting diodes.
Quick links
Installation
Configuration
UL requirements


EP2817-0008 - Technical data

Product overview [image] EP2817-0008 [image] EP2817-0008 - Technical data
EP2817-0008 - Technical data
Technical data | EP2817-0008
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Number of outputs | 24
Output connections | 25-pin D-sub socket
Load type | ohmic, inductive, lamp load
Rated voltage outputs | 24 VDC (-15%/+20%)
Output current | max. 0.5 A each channel, individually short-circuit proof, sum current max. 4.0 A
Short circuit current | maximum 1.0 A
Diagnostics | Undervoltage detection <18 VDC for Us and Up
Supply of the module electronics | from the control voltage Us
Current consumption of the module electronics | typically 120 mA
Output driver supply | from load voltage Up
Output driver current consumption | max. 30 mA for all channels
Power supply connection | Feed: 1 x M8 plug, 4-pin Downstream connection: 1 x M8 socket, 4-pin
Electrical isolation | 500 V (fieldbus / IO)
Permissible ambient temperature during operation | -25 °C ... +60 °C 0 °C ... +55 °C (conforms to cURus, see UL requirements)
Permissible ambient temperature during storage | -40 °C ... +85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Mounting position | variable
Approvals | CE, cURus


EP2817-0008 - Status LEDs

Product overview [image] EP2817-0008 [image] EP2817-0008 - Status LEDs
EP2817-0008 - Status LEDs
EP2817-0008 - Status LEDs
LED Displays
LED | Display | Meaning
STATUS 1-12 | green illuminated | at least one of the outputs for channel 1-12 is set
 | red illuminated | at least one output of channels 1-12 has an error
STATUS 13-24 | green illuminated | at least one of the outputs for channel 13-24 is set
 | red illuminated | at least one output of channels 13 - 24 has an error
Us | off | The supply voltage, Us, is not present
 | green illuminated | The supply voltage, Us, is present
Up | off | The supply voltage, Up, is not present
 | green illuminated | The supply voltage, Up, is present


EP2817-0008 - Process image

Product overview [image] EP2817-0008 [image] EP2817-0008 - Process image
EP2817-0008 - Process image
DIG Diag Inputs Channel 1
Under DIG Diag Inputs Channel 1 - 3 you will find the diagnostic inputs of the 8 digital outputs (DIG Outputs Channel 1 - 3) of the module.
Data types
TC3 InputVariableContainer Symbol DIG Diag Inputs Channel 1
TC3 InputVariable Symbol indent Diag Input n: BIT
Diag Input n
Indicates an error at output n, i.e. an output switched ON is OFF, or an output switched OFF is ON
DIG Inputs Device
You will find the module's status inputs under DIG Inputs Device.
Data types
TC3 InputVariableContainer Symbol DIG Inputs Device
TC3 InputVariable Symbol indent Safe state active: BIT
TC3 InputVariable Symbol indent Error channel 1: BIT
TC3 InputVariable Symbol indent Error channel 2: BIT
TC3 InputVariable Symbol indent Error channel 3: BIT
TC3 InputVariable Symbol indent Us Undervoltage: BIT
TC3 InputVariable Symbol indent Up Undervoltage: BIT
TC3 InputVariable Symbol indent Sync error: BIT
TC3 InputVariable Symbol indent TxPDO Toggle: BIT
Safe state active
Indicates whether the safe state has been assumed. The display only works if the network transmits process input data, i.e. in the network states Pre-Operational (PRE-OP) and Operational (OP), but not in the network state INIT.
Error channel n
Indicates an error on channel n.
Us Undervoltage
Indicates that the voltage Us < approx. 18V.
Up Undervoltage
Indicates that the voltage Up < approx. 18V.
Sync Error
See EtherCAT system documentation. The EtherCAT system documentation is available on the Beckhoff homepage under Downloads.
TxPDO Toggle
See EtherCAT system documentation.
DIG Outputs Channel n
Under DIG Outputs Channel 1 - 3 you will find 8 digital outputs of each module.
Data types
TC3 OutputVariableContainer Symbol DIG Output Channel 1
TC3 OutputVariable Symbol indent Output n: BIT
The assignment is always made in pairs on the left and right side of the D-SUB connector in order to systematically connect double-switching valves.
Type | Output 2 | Output 4 | Output 6 | Output 8 | Output 10 | Output 12 | Output 14 | Output 16 | Output 18 | Output 20 | Output 22 | Output 24 |
Pin | 14 | 15 | 16 | 17 | 18 | 19 | 20 | 21 | 22 | 23 | 24 | 25 |
Type | Output 1 | Output 3 | Output 5 | Output 7 | Output 9 | Output 11 | Output 13 | Output 15 | Output 17 | Output 19 | Output 21 | Output 23 | GND
Pin | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13
DIG Outputs Device
You will find the module's control outputs under DIG Outputs Device.
Data types
TC3 OutputVariableContainer Symbol DIG Outputs Device
TC3 OutputVariable Symbol indent Set safe state: BIT
 TC3 OutputVariable Symbol indent Reset outputs: BIT
Set safe state
Sets the module to the safe state.
Reset outputs
Resets the error bits "Error channel X" of the module. The outputs are reactivated.


Mounting and cabling

Mounting and cabling
Mounting and cabling
Additional information
•
Mounting
•
EtherCAT
•
Power supply
•
UL Requirements
•
ATEX notes
•
Signal connection
•
Cabling


Mounting

Mounting and cabling [image] Mounting
Mounting
Additional information
•
Dimensions EPxxxx-xx0x and EPxxxx-xx1x
•
Dimensions EPxxxx-xx2x
•
Dimensions EPxxxx-xx3x
•
Fixing
•
Nut torque for connectors


Dimensions EPxxxx-xx0x and EPxxxx-xx1x

Mounting and cabling [image] Mounting [image] Dimensions EPxxxx-xx0x and EPxxxx-xx1x
Dimensions EPxxxx-xx0x and EPxxxx-xx1x
Dimensions
All dimensions are given in millimeters.
Housing features
Housing material | PA6 (polyamide)
Sealing compound | polyurethane
Mounting | two fastening holes Ø 3.5 mm for M3
Metal parts | brass, nickel-plated
Contacts | CuZn, gold-plated
Power feed through | max. 4 A
Mounting position | variable
Protection class | IP65, IP66, IP67 (conforms to EN 60529) when screwed together
Dimensions (H x W x D) | approx. 126 x 30 x 26.5 mm


Dimensions EPxxxx-xx2x

Mounting and cabling [image] Mounting [image] Dimensions EPxxxx-xx2x
Dimensions EPxxxx-xx2x
Dimensions
All dimensions are given in millimeters.
Housing features
Housing material | PA6 (polyamide)
Sealing compound | polyurethane
Mounting | two fastening holes Ø 4.5 mm for M4
Metal parts | brass, nickel-plated
Contacts | CuZn, gold-plated
Power feed through | max. 4 A
Mounting position | variable
Protection class | IP65, IP66, IP67 (conforms to EN 60529) when screwed together
Dimensions (H x W x D) | approx. 126 x 60 x 26.5 mm


Dimensions EPxxxx-xx3x

Mounting and cabling [image] Mounting [image] Dimensions EPxxxx-xx3x
Dimensions EPxxxx-xx3x
Dimensions
All dimensions are given in millimeters.
Housing features
Housing material | PA6 (polyamide)
Sealing compound | polyurethane
Mounting | two fastening holes Ø 4.5 mm for M4
Metal parts | brass, nickel-plated
Contacts | CuZn, gold-plated
Power feed through | max. 16 A at 40°C (according to IEC 60512-3)
Mounting position | variable
Protection class | IP65, IP66, IP67 (conforms to EN 60529) when screwed together
Dimensions (H x W x D) | approx. 150 x 60 x 26.5 mm


Fixing

Mounting and cabling [image] Mounting [image] Fixing
Fixing
Protection of connectors against contamination!
While mounting the modules, protect all connectors, especially the IP-Link, against contamination! Only with connected cables or plugs the protection class IP67 is guaranteed! Unused connectors have to be protected with the right plugs! See for plug sets in the catalogue.
Modules with narrow housing are mounted with two M3 bolts.
Modules with wide housing are mounted with two M3 bolts to the fixing holes located at the corners or mounted with two M4 bolts to the fixing holes located centrally.
The bolts must be longer than 15 mm. The fixing holes of the modules are not threaded.
When assembling, remember that the fieldbus connectors increases the overall height. See chapter accessories.
Mounting Rail ZS5300-0001
The mounting rail ZS5300-0001 (500 mm x 129 mm) allows the time saving assembly of modules.
The rail is made of stainless steel, 1.5 mm thick, with already pre-made M3 threads for the modules. The rail has got 5.3 mm slots to mount it via M5 screws to the machine.
Mounting Rail ZS5300-000
The mounting rail is 500 mm long, that way 15 narrow modules can be mounted with a distance of 2 mm between two modules. The rail can be cut to length for the application.
Mounting Rail ZS5300-0011
The mounting rail ZS5300-0011 (500 mm x 129 mm) has in addition to the M3 treads also pre-made M4 treads to fix 60 mm wide modules via their middle holes.
Up to 14 narrow or 7 wide modules may be mixed mounted.


Nut torque for connectors

Mounting and cabling [image] Mounting [image] Nut torque for connectors
Nut torque for connectors
M8 connectors
It is recommended to pull the M8 connectors tight with a nut torque of 0.4 Nm. When using the torque control screwdriver ZB8800 is also a max. torque of 0.5 Nm permissible.
EtherCAT Box with M8 connectors
M12 connectors
It is recommended to pull the M12 connectors tight with a nut torque of 0.6 Nm.
EtherCAT Box with M8 and M12 connectors
7/8" plug connectors
We recommend fastening the 7/8" plug connectors with a torque of 1.5 Nm.
7/8" plug connectors
Torque socket wrenches
ZB8801 torque socket wrench
Ensure the right torque
Use the torque socket wrenches available by Beckhoff to pull the connectors tight (ZB8800, ZB8801-0000)!


EtherCAT

Mounting and cabling [image] EtherCAT
EtherCAT
Additional information
•
EtherCAT connection
•
EtherCAT - Fieldbus LEDs


EtherCAT connection

Mounting and cabling [image] EtherCAT [image] EtherCAT connection
EtherCAT connection
For the incoming and ongoing EtherCAT connection,
▪
the EtherCAT Box (EPxxxx) has two M8 sockets, marked in green
▪
the Coupler Box (FBB-x110) has two M12 sockets
EtherCAT Box: M8, 30 mm housing
EtherCAT Box: M860 mm housing (example: EP9214)
Coupler Box: M12
Assignment
There are various different standards for the assignment and colors of connectors and cables for EtherCAT.
EtherCAT | Plug connector |  |  | Cable |  | Standard
Signal | M8 | M12 | RJ451 | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 and old versions of ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | Pin 1 | Pin 1 | Pin 1 | yellow2 | orange/white3 | white/orange
Tx - | Pin 4 | Pin 3 | Pin 2 | orange2 | orange3 | orange
Rx + | Pin 2 | Pin 2 | Pin 3 | white2 | blue/white3 | white/green
Rx - | Pin 3 | Pin 4 | Pin 6 | blue2 | blue3 | green
Shield | Housing |  | Shroud | Shield | Shield | Shield
1) colored markings according to EN 61918 in the four-pin RJ45 connector ZS1090-0003
2) wire colors according to EN 61918
3) wire colors
Assimilation of color coding for cable ZB9030, ZB9032 and ZK1090-3xxxx-xxxx (with M8 connectors)
For unification the prevalent cables ZB9030, ZB9032 and ZK1090-3xxx-xxxx this means the pre assembled cables with M8 connectors were changed to the colors of EN61918 (yellow, orange, white, blue).So different color coding exists. But the electrical properties are absolutely identical.
EtherCAT connector
The following connectors can be supplied for use in Beckhoff EtherCAT systems.
Name | Connector | Comment
ZS1090-0003 | RJ45 | four-pole, IP20, field-configurable
ZS1090-0004 | M12, male | four-pin, IP67, for field assembly
ZS1090-0005 | RJ45 | eight-pole, IP20, field-configurable, suitable for gigabit Ethernet
ZS1090-0006 | M8 plug connector | four-pole, IP67, field-configurable, for cable type ZB903x
ZS1090-0007 | M8 socket | four-pole, IP67, field-configurable, for cable type ZB903x
ZS1090-1006 | M8 plug connector | four-pole, IP67, field-configurable up to OD = 6.5 mm
ZS1090-1007 | M8 socket | four-pole, IP67, field-configurable up to OD = 6.5 mm


EtherCAT - Fieldbus LEDs

Mounting and cabling [image] EtherCAT [image] EtherCAT - Fieldbus LEDs
EtherCAT - Fieldbus LEDs
EtherCAT-LEDs
LED display
LED | Display | Meaning
IN L/A | off | no connection to the preceding EtherCAT module
 | Lit | LINK: connection to the preceding EtherCAT module
 | flashing | ACT: Communication with the preceding EtherCAT module
OUT L/A | off | no connection to the following EtherCAT module
 | Lit | LINK: connection to the following EtherCAT module
 | flashing | ACT: Communication with the following EtherCAT module
Run | off | Status of the EtherCAT module is Init
 | flashes quickly | Status of the EtherCAT module is pre-operational
 | flashes slowly | Status of the EtherCAT module is safe-operational
 | Lit | Status of the EtherCAT module is operational
EtherCAT statuses
The various statuses in which an EtherCAT module may be found are described in the Basic System Documentation for EtherCAT, which is available for download from our website (www.beckhoff.com) under Downloads.


Power supply

Mounting and cabling [image] Power supply
Power supply
Additional information
•
Power Connection
•
Status LEDs for power supply
•
Power cable conductor losses M8
•
Conductor losses 7/8"


Power Connection

Mounting and cabling [image] Power supply [image] Power Connection
Power Connection
The feeding and forwarding of supply voltages is done via two M8 connectors at the bottom end of the modules:
▪
IN: left M8 connector for feeding the supply voltages
▪
OUT: right M8 connector for forwarding the supply voltages
EtherCAT Box, Connectors for power supply
Pin assignment M8, Power In and Power Out
PIN assignment
Pin | Voltage
1 | Control voltage Us, +24 VDC
2 | Auxiliary voltage Up, +24 VDC
3 | GNDs* | *) may be connected internally to each other depending on the module: see specific module descriptions
4 | GNDp*
The pins M8 connectors carry a maximum current of 4 A.
Two LEDs display the status of the supply voltages.
Note
Don't confuse the power connectors with the EtherCAT connectors!
Never connect the power cables (M8, 24 VDC) with the green marked EtherCAT sockets of the EtherCAT Box Modules! This can damage the modules!
Control voltage US: 24 VDC
Power is supplied to the fieldbus, the processor logic, the inputs and the sensors from the 24 VDC control voltage US. The control voltage is electrically isolated from the fieldbus circuitry.
Peripheral voltage UP: 24 VDC
The peripheral voltage UP supplies the digital outputs; it can be brought in separately. Hence, if the load voltage is switched off, the fieldbus function as well as the supply and function of the inputs are retained.
Redirection of the supply voltages
The IN and OUT power connections are bridged in the module (not IP204x-Bxxx and IE204x). The supply voltages Us and Up can thus easily be transferred from EtherCAT Box to EtherCAT Box.
Note
Pay attention to the maximum permissible current!
Pay attention also for the redirection of the supply voltages Us and Up, the maximum permissible current for M8 connectors of 4 A must not be exceeded!
Supply via EP92x4-0023 PowerBox modules
If the machine requires higher current or if the EtherCAT Box Modules are installed far away from the control cabinet with included power supply, the usage of four cannel power distribution modules EP9214 or EP9224 (with integrated data logging, see www.beckhoff.com/EP9224) is recommended.
With these modules intelligent power distribution concepts with up to 2 x 16 A and a maximum of 2.5 mm² cable cross-section can be realized.
EP92x4-0023, Connectors for Power In and Power Out
Pin assignment 7/8”, Power In and Power Out
Electrical isolation
Digital modules
In the digital input/output modules, the grounds of the control voltage (GNDs) and the auxiliary voltage (GNDp) are connected to each other!
Check this at the documentation of each used EtherCAT Box.
Analog modules
In the analog input/output modules the grounds of the control voltage (GNDs) and the auxiliary voltage (GNDp) are separated from each other in order to ensure electrical isolation of the analog signals from the control voltage.
In some of the analog modules the sensors or actuators are supplied by Up - this means, for instance, that in the case of 0...10 V inputs, any reference voltage (0...30 V) may be connected to Up; this is then available to the sensors (e.g. smoothed 10 V for measuring potentiometers).
Details of the power supply may be taken from the specific module descriptions.
Note
Electrical isolation may be cancelled!
If digital and analog fieldbus boxes are connected directly via four-core power leads, the analog signals in the fieldbus boxes may be no longer electrically isolated from the control voltage!


Status LEDs for power supply

Mounting and cabling [image] Power supply [image] Status LEDs for power supply
Status LEDs for power supply
Status LEDs for power supply
LED display
LED | Display | Meaning
Us (Control voltage) | off | The power supply voltage Us is not present
 | green illuminated | The power supply voltage Us is present
 | red illuminated | Because of overload (current > 0.5 A) the sensor supply generated from power supply voltage Us was switched off for all sensors fed from this.
Up (Auxiliary voltage) | off | The power supply voltage Up is not present
 | green illuminated | The power supply voltage Up is present


Power cable conductor losses M8

Mounting and cabling [image] Power supply [image] Power cable conductor losses M8
Power cable conductor losses M8
The ZK2020-xxxx-yyyy power cables should not exceed the total length of 15 m at 4 A (with continuation). When planning the cabling, note that at 24 V nominal voltage, the functionality of the module can no longer be assured if the voltage drop reaches 6 V. Variations in the output voltage from the power supply unit must also be taken into account.
Power cable conductor losses
Example
8 m power cable with 0.34 mm² cross-section has a voltage drop of 3.2 V at 4 A.
EP92x4 Power Distribution Modules
With EP9214 and EP9224 Power Distribution Modules intelligent concepts for voltage supply are available. Further information may be found under www.beckhoff.com/EP9224.


Conductor losses 7/8"

Mounting and cabling [image] Power supply [image] Conductor losses 7/8"
Conductor losses 7/8"
In the case of the power cables ZK2030-xxxx-yyy, a total length of 15 m should not be exceeded at 16 A. When wiring, note that with a rated voltage of 24 V the function of the modules can no longer be guaranteed from a voltage drop of 6 V. Variations in the output voltage from the power supply unit must also be taken into account.
ZK2030-xxxx-yyy - Conductor losses
Alternatively, larger cable cross-section can be used, e.g. 2.5 mm2.


UL Requirements

Mounting and cabling [image] UL Requirements
UL Requirements
The installation of the EtherCAT Box Modules certified by UL has to meet the following requirements.
Supply voltage
SmallWarningYellow CAUTION
CAUTION!
This UL requirements are valid for all supply voltages of all marked EtherCAT Box Modules!
For the compliance of the UL requirements the EtherCAT Box Modules should only be supplied
•
by a 24 VDC supply voltage, supplied by an isolating source and protected by means of a fuse (in accordance with UL248), rated maximum 4 Amp, or
•
by a 24 VDC power source, that has to satisfy NEC class 2.
A NEC class 2 power supply shall not be connected in series or parallel with another (class 2) power source!
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, the EtherCAT Box Modules must not be connected to unlimited power sources!
Networks
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, EtherCAT Box Modules must not be connected to telecommunication networks!
Ambient temperature range
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, EtherCAT Box Modules has to be operated only at an ambient temperature range of 0 to 55°C!
Marking for UL
All EtherCAT Box Modules certified by UL (Underwriters Laboratories) are marked with the following label.
UL label


ATEX notes

Mounting and cabling [image] ATEX notes
ATEX notes
Additional information
•
ATEX - Special conditions
•
BG2000 - EtherCAT Box protection enclosures
•
ATEX Documentation


ATEX - Special conditions

Mounting and cabling [image] ATEX notes [image] ATEX - Special conditions
ATEX - Special conditions
SmallWarningYellow WARNING
Observe the special conditions for the intended use of EtherCAT Box modules in potentially explosive areas – directive 94/9/EU.
•
The certified components are to be installed with a BG2000-0000 or BG2000-0010 protection enclosure that guarantees a protection against mechanical hazards!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of 0 to 55°C for the use of EtherCAT Box modules in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0: 2006
▪
EN 60079-15: 2005
Marking
The EtherCAT Box modules certified for potentially explosive areas bear the following marking:
II 3 G Ex nA II T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
or
II 3 G Ex nA nC IIC T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
Batch number (D number)
The EtherCAT Box modules bear a batch number (D number) that is structured as follows:
D: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with batch number 29 10 02 01:
29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01


BG2000 - EtherCAT Box protection enclosures

Mounting and cabling [image] ATEX notes [image] BG2000 - EtherCAT Box protection enclosures
BG2000 - EtherCAT Box protection enclosures
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the EtherCAT system into a safe, powered down state before starting installation, disassembly or wiring of the modules!
ATEX
SmallWarningYellow WARNING
Mount a protection enclosure!
To fulfill the special conditions according to ATEX, a BG2000-0000 or BG2000-0010 protection enclosure has to be mounted over the EtherCAT Box.
Installation
Put the cables for EtherCAT, power supply and sensors/actuators through the hole of the protection enclosure.
BG2000 - putting the cables
Fix the wires for EtherCAT, power supply and sensors/actuators to the EtherCAT Box.
BG2000 - fixing the cables
Mount the protection enclosure over the EtherCAT Box.
BG2000 - mounting the protection enclosure


ATEX Documentation

Mounting and cabling [image] ATEX notes [image] ATEX Documentation
ATEX Documentation
Notes about operation of EtherCAT Box Modules (EPxxxx-xxxx) in potentially explosive areas (ATEX)
Pay also attention to the continuative documentationNotes about operation of EtherCAT Box Modules (EPxxxx-xxxx) in potentially explosive areas (ATEX) that is available in the download area of the Beckhoff homepage http:\\www.beckhoff.com!


Signal connection

Mounting and cabling [image] Signal connection
Signal connection
Additional information
•
Digital outputs M8 and M12
•
Digital outputs M12 for EP2028-0032
•
Digital inputs M8 and M12
•
Digital inputs/outputs M8 and M12
•
Digital outputs D-Sub 25, 16 channels
•
Digital outputs D-Sub 25, 24 channels
•
Digital outputs D-Sub 9, 8 channels
•
digital inputs and outputs D-sub 25
•
Digital inputs and outputs ZS2001, 8 channels


Digital outputs M8 and M12

Mounting and cabling [image] Signal connection [image] Digital outputs M8 and M12
Digital outputs M8 and M12
The digital output modules forward the binary control signals of the automation device to the actuators at the process level.
The signals are connected via M8 connectors (EP2xxx-0001) or M12 connectors (EP2xxx-0002).
Digital outputs M8 and M12
The outputs are short-circuit proof and protected against inverse connection.
LEDs indicate the signal state of the outputs.


Digital outputs M12 for EP2028-0032

Mounting and cabling [image] Signal connection [image] Digital outputs M12 for EP2028-0032
Digital outputs M12 for EP2028-0032
The digital outputs / actuators are connected via M12 sockets.
The pins 2 and 4 of the signal sockets 0 and 1, 2 and 3, 4 and 5, 6 and 7 are internally connected.
This means that actuators that require two outputs can also be connected via an M12 cable.
Digitale Ausgänge M12 (FBB_M12_Double_Connectors_1.png)
Digital outputs M12 for EP2028-0032
Light emitting diodes indicate the signal state of the inputs.


Digital inputs M8 and M12

Mounting and cabling [image] Signal connection [image] Digital inputs M8 and M12
Digital inputs M8 and M12
The digital input modules acquire the binary control signals from the process level and transmit them to the higher-level automation unit.
The signals are optionally connected via screw-in M8 connectors (EPxxxx-0001) or screw-in M12 connectors (EPxxxx-0002).
Digital inputs M8 and M12
The sensors are supplied from the control voltage Us with a maximum current of 0.5 A.
The state of the signals is indicated by light emitting diodes.


Digital inputs/outputs M8 and M12

Mounting and cabling [image] Signal connection [image] Digital inputs/outputs M8 and M12
Digital inputs/outputs M8 and M12
The EPP2338-x00x have digital channels which can be operated as inputs or outputs.
If the channels are operated as digital inputs, the modules record the binary control signals from the process level and transport them to the higher-level automation device. The sensors are powered by the load voltage UP.
If the channels are operated as a digital output, the modules forward the binary control signals of the automation device to the actuators at the process level. The outputs are short-circuit proof and protected against inverse connection.
The signal connection is made via M8 connectors (EPPxxxx-xxx1) or M12 connectors (EPPxxxx-xxxx2).
Digital inputs/outputs M8
Digital inputs/outputs M12
LEDs indicate the signal state of the inputs/outputs.


Digital outputs D-Sub 25, 16 channels

Mounting and cabling [image] Signal connection [image] Digital outputs D-Sub 25, 16 channels
Digital outputs D-Sub 25, 16 channels
The EP2816 digital output modules forward the binary control signals of the automation device to the actuators at the process level.
The 16 outputs supply load currents up to 0.5 A, although the total current from all the outputs must not exceed 4 A.
The signal connection is made through a 25-pin D-Sub socket.
The outputs are short-circuit proof and protected against inverse connection.
Digital outputs D-Sub 25, 16 outputs


Digital outputs D-Sub 25, 24 channels

Mounting and cabling [image] Signal connection [image] Digital outputs D-Sub 25, 24 channels
Digital outputs D-Sub 25, 24 channels
The EP2817-0008 digital output modules forward the binary control signals of the automation device to the actuators at the process level.
The 24 outputs supply load currents up to 0.5 A, although the total current from all the outputs must not exceed 4 A.
The signal connection is made through a 25-pin D-Sub socket.
The outputs are short-circuit proof and protected against inverse connection.
Digital outputs D-Sub 25, 24 channels


Digital outputs D-Sub 9, 8 channels

Mounting and cabling [image] Signal connection [image] Digital outputs D-Sub 9, 8 channels
Digital outputs D-Sub 9, 8 channels
The IE2808 digital output module transmits the binary control signals from the automation device on to the actuators at the process level.
The 8 outputs supply load currents up to 0.5 A, although the total current from all the outputs must not exceed 4 A.
The signal connection is made through two 9-pin D-sub sockets.
The outputs are short-circuit proof and protected against inverse connection.
Digital outputs D-Sub 9, 8 channels


digital inputs and outputs D-sub 25

Mounting and cabling [image] Signal connection [image] digital inputs and outputs D-sub 25
digital inputs and outputs D-sub 25
The EP2316-0008 digital combination module
▪
connects the binary control signals from the automation device on to the actuators at the process level.
▪
acquires the binary control signals from the process level and transmits them to the higher-level automation unit.
The 8 outputs supply load currents up to 0.5 A, although the total current from all the outputs must not exceed 4 A. The outputs are short-circuit proof and protected against inverse connection.
The sensors are supplied from the control voltage Us.
Digital inputs and outputs D-sub 25


Digital inputs and outputs ZS2001, 8 channels

Mounting and cabling [image] Signal connection [image] Digital inputs and outputs ZS2001, 8 channels
Digital inputs and outputs ZS2001, 8 channels
The digital outputs forward the binary control signals of the automation device to the actuators at the process level. The 8 outputs process load currents up to 0.5 A, and indicate their signal state through LEDs. The signal is optionally connected via various ZS2001 connectors. The outputs are short-circuit proof and protected against inverse connection.
The digital inputs acquire the binary control signals from the process level and transmit them to the higher-level automation device. The signal state is indicated by means of LEDs. The signal is optionally connected via various ZS2001 connectors.
The sensors are supplied from the control voltage US. The load voltage, UP, is required for the output drivers. If UP and US are used for passing the power on, the maximum current must not exceed the 4 A.
Inputs
Digital inputs ZS2001, 8 channels
The diagram shows the connection of 8 sensors in single-wire technology as well as one sensor each in two-wire and three-wire technology.
Please note for ZS2001-0004 connectors: two bridges (24 V and 0 V) are required to supply the terminal points for two- and three-wire connection technology.
Outputs
Digital outputs ZS2001, 8 channels
The diagram shows the connection of 8 actuators in single-wire technology and one actuator each in two-wire and three-wire technology.
Please note for ZS2001-0004 connectors: two bridges (24 V and 0 V) are required to supply the terminal points for two- and three-wire connection technology.
Additional information
•
Ordering information for KM plug-in connector
•
Technical data of the KM connectors


Ordering information for KM plug-in connector

Mounting and cabling [image] Signal connection [image] Digital inputs and outputs ZS2001, 8 channels [image] Ordering information for KM plug-in connector
Ordering information for KM plug-in connector
ZS2001-0001, ZS2001-0002: KM connectors for single wire connection
ZS2001-0004: KM connectors for three-wire connection
Order designation | Signal LEDs | Connection technology
 |  | single-wire | two-wire | three-wire
ZS2001-0001 | no | yes | no | no
ZS2001-0002 | yes | yes | no | no
ZS2001-0004 | yes | yes | yes | yes


Technical data of the KM connectors

Mounting and cabling [image] Signal connection [image] Digital inputs and outputs ZS2001, 8 channels [image] Technical data of the KM connectors
Technical data of the KM connectors
Technical data | ZS2001-0001 | ZS2001-0002 | ZS2001-0004
Number of terminal points | 10 | 10 | 30
Signal LEDs | no | yes | yes
Nominal voltage | 50 VDC | 24 VDC | 24 VDC
Nominal current | 2 A
Wire cross-section | 0.5 mm2 ... 1.5 mm2
Strip length | 8 mm
Dimensions (W x H x D) | approx. 42mm x 10.3mm x 26.9mm | approx. 42mm x 12.7mm x 26.9mm | approx. 42mm x 20.8mm x 26.9mm
Weight | approx. 10 g | approx. 10 g | approx. 20 g
Permissible ambient temperature range during operation | 0 °C ... + 55 °C
Permissible ambient temperature range during storage | -25 °C ... + 85 °C
Permissible relative air humidity | 95 %, no condensation
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Mounting position | variable
Approval | CE


Cabling

Mounting and cabling [image] Cabling
Cabling
A list of EtherCAT cables, power cables, sensor cables, Ethernet/EtherCAT connectors and field-configurable connectors can be found under the following link: https://beckhoff.de/english/fieldbus_box/ethercat_box_accessories_overview.htm?id=25525466903389
The corresponding data sheets can be found under the following link:
https://beckhoff.de/english/ethercat-box/ethercat_box_cables.htm?id=690338951657421
EtherCAT cables
ZK1090-3131-0xxx
For connecting EtherCAT devices, only use shielded Ethernet cables with a minimum specification of category 5 (CAT5) according to EN 50173 or ISO/IEC 11801.
Wiring recommendations
Detailed recommendations for EtherCAT cabling can be found in the documentation "Design recommendations for EtherCAT/Ethernet infrastructure", which is available for download from www.beckhoff.de.
EtherCAT uses four cable wires for signal transmission.
Due to automatic cable detection (auto-crossing) symmetric (1:1) or cross-over cables can be used between EtherCAT devices from Beckhoff.
Power cable
ZK2020-3132-0xxx
Sensor cables
Sensorkabel - Beckhoff.png
Selection of Beckhoff sensor cables


Commissioning/Configuration

Commissioning/Configuration
Commissioning/Configuration
Additional information
•
Inserting into the EtherCAT network
•
Configuration via TwinCAT
•
Behavior of the outputs in case of error (only EPxx16 and EPxx17)
•
EP2316-0008 / EPP2816-0008 - Object description and parameterization
•
EP2816-0008 - Object description and parameterization
•
EP2817-0008 - Object description and parameterization
•
Restoring the delivery state


Inserting into the EtherCAT network

Commissioning/Configuration [image] Inserting into the EtherCAT network
Inserting into the EtherCAT network
Installation of the latest XML device description
Please ensure that you have installed the latest XML device description in TwinCAT. This can be downloaded from the Beckhoff website (http://www.beckhoff.de/english/download/elconfg.htm?id=1983920606140) and installed according to the installation instructions.
At the Beckhoff TwinCAT System Manager the configuration tree can be build in two different ways:
▪
by scanning for existing hardware (called "online") and
▪
by manual inserting/appending of fieldbus devices, couplers and slaves.
Automatic scanning in of the box
▪
The EtherCAT system must be in a safe, de-energized state before the EtherCAT modules are connected to the EtherCAT network!
▪
Switch on the operating voltage, open the TwinCAT System Manager (Config mode), and scan in the devices (see Fig. 1). Acknowledge all dialogs with "OK", so that the configuration is in "FreeRun" mode.
Scanning in the configuration (I/O Devices -> right-click -> Scan Devices...)
Appending a module manually
▪
The EtherCAT system must be in a safe, de-energized state before the EtherCAT modules are connected to the EtherCAT network!
▪
Switch on the operating voltage, open the TwinCAT System Manager (Config mode)
▪
Append a new I/O device. In the dialog that appears select the device EtherCAT (Direct Mode), and confirm with OK.
Appending a new I/O device (I/O Devices -> right-click -> Append Device...)
Selecting the device EtherCAT
▪
Append a new box.
Appending a new box (Device -> right-click -> Append Box...)
▪
In the dialog that appears select the desired box (e.g. EP2816-0008), and confirm with OK.
Selecting a Box (e.g. EP2816-0008)
Appended Box in the TwinCAT tree


Configuration via TwinCAT

Commissioning/Configuration [image] Configuration via TwinCAT
Configuration via TwinCAT
In the left-hand window of the TwinCAT System Manager, click on the branch of the EtherCAT Box you wish to configure (EP2816-0008 in this example).
Branch of the EtherCAT box to be configured
In the right-hand window of the TwinCAT System manager, various tabs are now available for configuring the EtherCAT Box.
General tab
General tab
Name | Name of the EtherCAT device
Id | Number of the EtherCAT device
Type | EtherCAT device type
Comment | Here you can add a comment (e.g. regarding the system).
Disabled | Here you can deactivate the EtherCAT device.
Create symbols | Access to this EtherCAT slave via ADS is only available if this checkbox is activated.
EtherCAT tab
EtherCAT tab
Type | EtherCAT device type
Product/Revision | Product and revision number of the EtherCAT device
Auto Inc Addr. | Auto increment address of the EtherCAT device. The auto increment address can be used for addressing each EtherCAT device in the communication ring through its physical position. Auto increment addressing is used during the start-up phase when the EtherCAT master allocates addresses to the EtherCAT devices. With auto increment addressing the first EtherCAT slave in the ring has the address 0000hex. For each further slave the address is decremented by 1 (FFFFhex, FFFEhex etc.).
EtherCAT Addr. | Fixed address of an EtherCAT slave. This address is allocated by the EtherCAT master during the start-up phase. Tick the checkbox to the left of the input field in order to modify the default value.
Previous Port | Name and port of the EtherCAT device to which this device is connected. If it is possible to connect this device with another one without changing the order of the EtherCAT devices in the communication ring, then this combobox is activated and the EtherCAT device to which this device is to be connected can be selected.
Advanced Settings | This button opens the dialogs for advanced settings.
The link at the bottom of the tab points to the product page for this EtherCAT device on the web.
Process Data tab
Indicates the configuration of the process data. The input and output data of the EtherCAT slave are represented as CANopen process data objects (PDO). The user can select a PDO via PDO assignment and modify the content of the individual PDO via this dialog, if the EtherCAT slave supports this function.
Process Data tab
Sync Manager
Lists the configuration of the Sync Manager (SM).
If the EtherCAT device has a mailbox, SM0 is used for the mailbox output (MbxOut) and SM1 for the mailbox input (MbxIn).
SM2 is used for the output process data (outputs) and SM3 (inputs) for the input process data.
If an input is selected, the corresponding PDO assignment is displayed in the PDO Assignment list below.
PDO Assignment
PDO assignment of the selected Sync Manager. All PDOs defined for this Sync Manager type are listed here:
▪
If the output Sync Manager (outputs) is selected in the Sync Manager list, all RxPDOs are displayed.
▪
If the input Sync Manager (inputs) is selected in the Sync Manager list, all TxPDOs are displayed.
The selected entries are the PDOs involved in the process data transfer. In the tree diagram of the System Manager these PDOs are displayed as variables of the EtherCAT device. The name of the variable is identical to the Name parameter of the PDO, as displayed in the PDO list. If an entry in the PDO assignment list is deactivated (not selected and greyed out), this indicates that the input is excluded from the PDO assignment. In order to be able do select a greyed out PDO, the currently selected PDO has to be deselected first.
Activation of PDO assignment
•
the EtherCAT slave has to run through the PS status transition cycle (from pre-operational to safe-operational) once (see Online tab),
•
and the System Manager has to reload the EtherCAT slaves ( [image] button)
PDO list
List of all PDOs supported by this EtherCAT device. The content of the selected PDOs is displayed in the PDO Content list. The PDO configuration can be modified by double-clicking on an entry.
Column | Description
Index | PDO index.
Size | Size of the PDO in bytes.
Name | Name of the PDO. If this PDO is assigned to a Sync Manager, it appears as a variable of the slave with this parameter as the name.
Flags | F | Fixed content: The content of this PDO is fixed and cannot be changed by the System Manager.
 | M | Mandatory PDO. This PDO is mandatory and must therefore be assigned to a Sync Manager! Consequently, this PDO cannot be deleted from the PDO Assignment list
SM | Sync Manager to which this PDO is assigned. If this entry is empty, this PDO does not take part in the process data traffic.
SU | Sync unit to which this PDO is assigned.
PDO Content
Indicates the content of the PDO. If flag F (fixed content) of the PDO is not set the content can be modified.
Download
If the device is intelligent and has a mailbox, the configuration of the PDO and the PDO assignments can be downloaded to the device. This is an optional feature that is not supported by all EtherCAT slaves.
PDO Assignment
If this check box is selected, the PDO assignment that is configured in the PDO Assignment list is downloaded to the device on startup. The required commands to be sent to the device can be viewed in the Startup tab.
PDO Configuration
If this check box is selected, the configuration of the respective PDOs (as shown in the PDO list and the PDO Content display) is downloaded to the EtherCAT slave.
Startup tab
The Startup tab is displayed if the EtherCAT slave has a mailbox and supports the CANopen over EtherCAT (CoE) or Servo drive over EtherCAT protocol. This tab indicates which download requests are sent to the mailbox during startup. It is also possible to add new mailbox requests to the list display. The download requests are sent to the slave in the same order as they are shown in the list.
Startup tab
Column
Description
Transition
Transition to which the request is sent. This can either be
▪
the transition from pre-operational to safe-operational (PS), or
▪
the transition from safe-operational to operational (SO).
If the transition is enclosed in "<>" (e.g. <PS>), the mailbox request is fixed and cannot be modified or deleted by the user.
Protocol
Type of mailbox protocol
Index
Index of the object
Data
Date on which this object is to be downloaded.
Comment
Description of the request to be sent to the mailbox
Move Up | This button moves the selected request up by one position in the list.
Move Down | This button moves the selected request down by one position in the list.
New | This button adds a new mailbox download request to be sent during startup.
Delete | This button deletes the selected entry.
Edit | This button edits an existing request.
CoE - Online tab
The additional CoE - Online tab is displayed if the EtherCAT slave supports the CANopen over EtherCAT (CoE) protocol. This dialog lists the content of the object directory of the slave (SDO upload) and enables the user to modify the content of an object from this list. Details for the objects of the individual EtherCAT devices can be found in the device-specific object descriptions.
CoE - Online tab
Object list display
Column | Description
Index | Index and subindex of the object
Name | Name of the object
Flags | RW | The object can be read, and data can be written to the object (read/write)
 | RO | The object can be read, but no data can be written to the object (read only)
 | P | An additional P identifies the object as a process data object.
Value | Value of the object
Update List | The Update list button updates all objects in the displayed list
Auto Update | If this check box is selected, the content of the objects is updated automatically.
Advanced | The Advanced button opens the Advanced Settings dialog. Here you can specify which objects are displayed in the list.
Advanced settings
Online - via SDO information | If this option button is selected, the list of the objects included in the object directory of the slave is uploaded from the slave via SDO information. The list below can be used to specify which object types are to be uploaded.
Offline - via EDS file | If this option button is selected, the list of the objects included in the object directory is read from an EDS file provided by the user.
Online tab
Online tab
State Machine
Init | This button attempts to set the EtherCAT device to the Init state.
Pre-Op | This button attempts to set the EtherCAT device to the pre-operational state.
Op | This button attempts to set the EtherCAT device to the operational state.
Bootstrap | This button attempts to set the EtherCAT device to the Bootstrap state.
Safe-Op | This button attempts to set the EtherCAT device to the safe-operational state.
Clear Error | This button attempts to delete the fault display. If an EtherCAT slave fails during change of state it sets an error flag. Example: An EtherCAT slave is in PREOP state (pre-operational). The master now requests the SAFEOP state (safe-operational). If the slave fails during change of state it sets the error flag. The current state is now displayed as ERR PREOP. When the Clear Error button is pressed the error flag is cleared, and the current state is displayed as PREOP again.
Current State | Indicates the current state of the EtherCAT device.
Requested State | Indicates the state requested for the EtherCAT device.
DLL Status
Indicates the DLL status (data link layer status) of the individual ports of the EtherCAT slave. The DLL status can have four different states:
Status | Description
No Carrier / Open | No carrier signal is available at the port, but the port is open.
No Carrier / Closed | No carrier signal is available at the port, and the port is closed.
Carrier / Open | A carrier signal is available at the port, and the port is open.
Carrier / Closed | A carrier signal is available at the port, but the port is closed.
File Access over EtherCAT
Download | With this button a file can be written to the EtherCAT device.
Upload | With this button a file can be read from the EtherCAT device.


Behavior of the outputs in case of error (only EPxx16 and EPxx17)

Commissioning/Configuration [image] Behavior of the outputs in case of error (only EPxx16 and EPxx17)
Behavior of the outputs in case of error (only EPxx16 and EPxx17)
In the TwinCAT System Manager, you can set parameters for the modules
▪
EP2316-0003
▪
EP2316-0008
▪
EP2816-00xx
▪
EP2817-0008
in the register tab C0E - Online.
The description of the parameter settings is done here using module EP2316-0008, but applies to all these modules.
Behavior of the outputs in case of network failure
You can use bit 8000:0n (Safe State Active) to specify whether channel n should assume a certain value (Safe State Value) when data transmission is interrupted.
With bit 8001:0n (Safe State Value) you define this value for channel n.
Safe State Value during network start-up
The network transmits output process data only in the network states Save-Operational (SAFE-OP) and Operational (OP). Also at the network states INIT, Pre-Operational (PRE-OP) and BOOT passed through during network start-up no output process data is transmitted. If Safe State is activated for an output, this output also adopts the specified value during network start-up.
8000:0 - DIG Safe state active Ch.1
Observe the maximum short-circuit current!
When dimensioning the power supply unit and choosing the fuses, observe that the short-circuit current is approximately 1.7 A.
EP2316-0008 - 8000:0 - DIG Safe state active Ch.1
8000:01 to 8000:08 - DIG Safe state active Ch.1, Output 1 to Output 8 (default: TRUE)
Specifies whether or not the outputs should adopt a safe state in the case of a network failure.
Value | Meaning
FALSE | Safe state disabled
TRUE | Safe state enabled
8001:01 to 8001:08 - DIG Safe state value Ch.1, Output 1 to Output 8 (default: FALSE)
Specifies what the safe state is.
Value | Meaning
FALSE | Output switched off
TRUE | Output switched on
Behavior of the outputs in the event of a short circuit
F800:0 - DO Settings (Safe State Value)
EP2316-0008 - F800:0 - DO Settings (Safe State Value)
F800:01 - Disable shut off (default: FALSE)
Value | Meaning
FALSE | In the event of a short circuit at one output, all outputs of the module are switched off. This disabling can be removed through the process data value Reset Outputs.
TRUE | In the event of a short circuit at an output, only this output of the module is switched off. After the short circuit has been removed, this output is automatically enabled again. see "Extracted nested table 4"
F800:11 - Switch off time (default: 0x03E8, 1000dec)
Here you can enter a time in milliseconds. During this time, the module checks whether the short circuit has been eliminated by switching itself on again.
Default = 1000 ms (depending on module type and internal cycle time). Errors are only displayed after this time.


EP2316-0008 / EPP2816-0008 - Object description and parameterization

Commissioning/Configuration [image] EP2316-0008 / EPP2816-0008 - Object description and parameterization
EP2316-0008 / EPP2816-0008 - Object description and parameterization
Parameterization
The Terminal/Box is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (assignment of PDOs).
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. It is strongly recommended to download the latest revision of the corresponding XML file from the Beckhoff website (http://www.beckhoff.com/english/default.htm?download/elconfg.htm) and follow the installation instructions.
Introduction
The CoE overview contains objects for different intended applications:
▪
Objects required for parameterization during commissioning
▪
Objects intended for regular operation, e.g. through ADS access.
▪
Objects for indicating internal settings (may be fixed)
▪
Further profile-specific objects indicating inputs, outputs and status information
The following section first describes the objects required for normal operation, followed by a complete overview of missing objects.
Objects to be parameterized during commissioning
Index 1011 Restore default parameters
Index | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default settings | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to 0x64616F6C in the set value dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)
Index 8000 DIG Safe state active
The outputs for which the DIG Safe state active bit is set are switched to the values specified in Safe state value in the event that the Operational (OP) status is left.
Status Operational (OP) is left if communication to the master is interrupted, for example at power breakdown at the master or wire breakage.
Index | Name | Meaning | Data type | Flags | Default
8000:0 | DIG Safe state active |  | UINT8 | RO | 0x08 (8dec)
8000:01 | Output 1 | 0bin: DIG Safe state for output 1 is switched off 1bin: DIG Safe state for output 1 is switched on | boolean | RW | 1bin
8000:02 | Output 2 | 0bin: DIG Safe state for output 2 is switched off 1bin: DIG Safe state for output 2 is switched on | boolean | RW | 1bin
8000:03 | Output 3 | 0bin: DIG Safe state for output 3 is switched off 1bin: DIG Safe state for output 3 is switched on | boolean | RW | 1bin
8000:04 | Output 4 | 0bin: DIG Safe state for output 4 is switched off 1bin: DIG Safe state for output 4 is switched on | boolean | RW | 1bin
8000:05 | Output 5 | 0bin: DIG Safe state for output 5 is switched off 1bin: DIG Safe state for output 5 is switched on | boolean | RW | 1bin
8000:06 | Output 6 | 0bin: DIG Safe state for output 6 is switched off 1bin: DIG Safe state for output 6 is switched on | boolean | RW | 1bin
8000:07 | Output 7 | 0bin: DIG Safe state for output 7 is switched off 1bin: DIG Safe state for output 7 is switched on | boolean | RW | 1bin
8000:08 | Output 8 | 0bin: DIG Safe state for output 8 is switched off 1bin: DIG Safe state for output 8 is switched on | boolean | RW | 1bin
Index 8001 DIG Safe state value
The values to which the outputs are switched when the status Operational (OP) is left are specified here.
Index | Name | Meaning | Data type | Flags | Default
8001:0 | DIG Safe state value |  | UINT8 | RO | 0x08 (8dec)
8001:01 | Output 1 | 0bin: DIG Safe state for output 1 = 0 1bin: DIG Safe state for output 1 = 1 | boolean | RW | 0bin
8001:02 | Output 2 | 0bin: DIG Safe state for output 2 = 0 1bin: DIG Safe state for output 2 = 1 | boolean | RW | 0bin
8001:03 | Output 3 | 0bin: DIG Safe state for output 3 = 0 1bin: DIG Safe state for output 3 = 1 | boolean | RW | 0bin
8001:04 | Output 4 | 0bin: DIG Safe state for output 4 = 0 1bin: DIG Safe state for output 4 = 1 | boolean | RW | 0bin
8001:05 | Output 5 | 0bin: DIG Safe state for output 5 = 0 1bin: DIG Safe state for output 5 = 1 | boolean | RW | 0bin
8001:06 | Output 6 | 0bin: DIG Safe state for output 6 = 0 1bin: DIG Safe state for output 6 = 1 | boolean | RW | 0bin
8001:07 | Output 7 | 0bin: DIG Safe state for output 7 = 0 1bin: DIG Safe state for output 7 = 1 | boolean | RW | 0bin
8001:08 | Output 8 | 0bin: DIG Safe state for output 8 = 0 1bin: DIG Safe state for output 8 = 1 | boolean | RW | 0bin
Objects for regular operation
The EP2316/EPP2316 has no such objects.
Additional objects
Standard objects (0x1000-0x1FFF)
The standard objects have the same meaning for all EtherCAT/EtherCAT P slaves.
Index 1000 Device type
Index | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT/EtherCAT P slave: The Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x01181389 (18355081dec)
Index 1008 Device name
Index | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT/EtherCAT P slave | string | RO | EP2316-0008
Index 1009 Hardware version
Index | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT/EtherCAT P slave | string | RO | 01
Index 100A Software Version
Index | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT/EtherCAT P slave | string | RO | 03
Index 1018 Identity
Index | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Manufacturer ID of the EtherCAT/EtherCAT P slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT/EtherCAT P slave | UINT32 | RO | 0x090C4052 (151797842dec)
1018:03 | Revision | Revision number of the EtherCAT/EtherCAT P slave, the low word (bit 0-15) identifies the special terminal number, the high word (bit 16-31) refers to the device description | UINT32 | RO | 0x00120008 (1179656dec)
1018:04 | Serial number | Serial number of the EtherCAT/EtherCAT P slave, the low byte (Bit 0-7) of the low word contains the year of production, the high byte (Bit 8-15) of the low word contains the week of production, the high word (Bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 Backup parameter handling
Index | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | Information for standardized loading and saving of backup entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum of all backup entries of the EtherCAT/EtherCAT P slave | UINT32 | RO | 0x00000000 (0dec)
Index 1600 DIG RxPDO-Map Outputs
Index | Name | Meaning | Data type | Flags | Default
1600:0 | DIG RxPDO-Map Outputs | PDO Mapping RxPDO 1 | UINT8 | RO | 0x09 (9dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (DO Outputs Ch.1), entry 0x01 (Output 1)) | UINT32 | RO | 0x7000:01, 1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (DO Outputs Ch.1), entry 0x02 (Output 2)) | UINT32 | RO | 0x7000:02, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (DO Outputs Ch.1), entry 0x03 (Output 3)) | UINT32 | RO | 0x7000:03, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (DO Outputs Ch.1), entry 0x04 (Output 4)) | UINT32 | RO | 0x7000:04, 1
1600:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7000 (DO Outputs Ch.1), entry 0x05 (Output 5)) | UINT32 | RO | 0x7000:05, 1
1600:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7000 (DO Outputs Ch.1), entry 0x06 (Output 6)) | UINT32 | RO | 0x7000:06, 1
1600:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (DO Outputs Ch.1), entry 0x07 (Output 7)) | UINT32 | RO | 0x7000:07, 1
1600:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7000 (DO Outputs Ch.1), entry 0x08 (Output 8)) | UINT32 | RO | 0x7000:08, 1
1600:09 | SubIndex 009 | 9. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1601 DIG RxPDO-Map Outputs Device
Index | Name | Meaning | Data type | Flags | Default
1601:0 | DIG RxPDO-Map Outputs Device | PDO Mapping RxPDO 2 | UINT8 | RO | 0x03 (3dec)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF700 (DIG Outputs), entry 0x01 (Set safe state)) | UINT32 | RO | 0xF700:01, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF700 (DIG Outputs), entry 0x02 (Reset outputs)) | UINT32 | RO | 0xF700:02, 1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (14 bits align) | UINT32 | RO | 0x0000:00, 14
Index 1A00 DIG TxPDO-Map Inputs
Index | Name | Meaning | Data type | Flags | Default
1A00:0 | DIG TxPDO-Map Inputs | PDO Mapping TxPDO 1 | UINT8 | RO | 0x0B (11dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (DI Inputs Ch.1), entry 0x01 (Input 1)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x02 (Input 2)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x03 (Input 3)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x04 (Input 4)) | UINT32 | RO | 0x6000:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x05 (Input 5)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x06 (Input 6)) | UINT32 | RO | 0x6000:06, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x07 (Input 7)) | UINT32 | RO | 0x6000:07, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x08 (Input 8)) | UINT32 | RO | 0x6000:08, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
Index 1A01 DIG TxPDO-Map Diag Inputs
Index | Name | Meaning | Data type | Flags | Default
1A01:0 | DIG TxPDO-Map Diag Inputs | PDO Mapping TxPDO 2 | UINT8 | RO | 0x09 (9dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF600 (DO Inputs), entry 0x01 (Safe state active)) | UINT32 | RO | 0x6001:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF600 (DO Inputs), entry 0x02 (Error channel 1)) | UINT32 | RO | 0x6001:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x6001:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x6001:04, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x6001:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x1800, entry 0x09) | UINT32 | RO | 0x6001:06, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6001 (DO Diag Inputs Ch.1), entry 0x07 (Diag Input 7)) | UINT32 | RO | 0x6001:07, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6001 (DO Diag Inputs Ch.1), entry 0x08 (Diag Input 8)) | UINT32 | RO | 0x6001:08, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1A02 DIG TxPDO-Map Inputs Device
Index | Name | Meaning | Data type | Flags | Default
1A02:0 | DIG TxPDO-Map Inputs Device | PDO Mapping TxPDO 3 | UINT8 | RO | 0x07 (7dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF600 (DO Inputs), entry 0x01 (Safe state active)) | UINT32 | RO | 0xF600:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF600 (DO Inputs), entry 0x02 (Error channel 1)) | UINT32 | RO | 0xF600:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (11 bits align) | UINT32 | RO | 0xF600:03, 1
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x0000:00, 10
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x1C32:20, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x1800, entry 0x09) | UINT32 | RO | 0x0000:00, 1
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x1800, entry 0x09) | UINT32 | RO | 0x1800:09, 1
Index 1C00 Sync manager type
Index | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the Sync Managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign
Index | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x02 (2dec)
1C12:01 | Subindex 001 | 1. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1600 (5632dec)
1C12:02 | Subindex 002 | 2. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1601 (5633dec)
Index 1C13 TxPDO assign
Index | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x03 (3dec)
1C13:01 | Subindex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A01 (6657dec)
1C13:03 | Subindex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A02 (6658dec)
Index 1C32 SM output parameter
Index
Name
Meaning
Data type
Flags
Default
1C32:0
SM output parameter
Synchronization parameters for the outputs
UINT8
RO
0x20 (32dec)
1C32:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dec)
1C32:02
Cycle time
Cycle time (in ns):
▪
Free Run: Cycle time of the local timer
▪
Synchron with SM 2 Event: Master cycle time
▪
DC mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000186A0 (100000dec)
1C32:03
Shift time
Time between SYNC0 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0 = 1: free run is supported
▪
Bit 1 = 1: Synchron with SM 2 Event is supported
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 10: Output Shift with SYNC1 event (only DC mode)
▪
Bit 14 = 1: dynamic times (measurement through writing of 1C32:08)
UINT16
RO
0xC007 (49159dec)
1C32:05
Minimum cycle time
Minimum cycle time (in ns)
UINT32
RO
0x000124F8 (75000dec)
1C32:06
Calc and copy time
Minimum time between SYNC0 and SYNC1 event (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:08
Command
▪
0: Measurement of the local cycle time is stopped
▪
1: Measurement of the local cycle time is started
The entries 1C32:03, 1C32:05, 1C32:06, 1C32:09, 1C33:03, 1C33:06, 1C33:09 are updated with the maximum measured values.
For a subsequent measurement the measured values are reset
UINT16
RW
0x0000 (0dec)
1C32:09
Delay time
Time between SYNC1 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:0B
SM event missed counter
Number of missed SM events in OPERATIONAL (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:0C
Cycle exceeded counter
Number of occasions the cycle time was exceeded in OPERATIONAL (cycle was not completed in time or the next cycle began too early)
UINT16
RO
0x0000 (0dec)
1C32:0D
Shift too short counter
Number of occasions that the interval between SYNC0 and SYNC1 event was too short (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:20
Sync error
The synchronization was not correct in the last cycle (outputs were output too late; DC mode only)
boolean
RO
0x00 (0dec)
Index 1C33 SM input parameter
Index
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (no outputs available)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (outputs available)
UINT16
RW
0x0022 (34dec)
1C33:02
Cycle time
as 1C32:02
UINT32
RW
0x000186A0 (100000dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: Synchron with SM 2 Event is supported (outputs available)
▪
Bit 1: Synchron with SM 3 Event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: Input Shift through local event (outputs available)
▪
Bit 4-5 = 10: Input Shift with SYNC1 event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 1C32:08 or 1C33:08)
UINT16
RO
0xC007 (49159dec)
1C33:05
Minimum cycle time
as 1C32:05
UINT32
RO
0x000124F8 (75000dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:08
Command
as 1C32:08
UINT16
RW
0x0000 (0dec)
1C33:09
Delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:0B
SM event missed counter
as 1C32:11
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
as 1C32:12
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
as 1C32:13
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
as 1C32:32
boolean
RO
0x00 (0dec)
Profile-specific objects (0x6000-0xFFFF)
The profile-specific objects have the same meaning for all EtherCAT slaves that support the profile 5001.
Index 6000 DIG Inputs Ch.1
Index | Name | Meaning | Data type | Flags | Default
6000:0 | DIG Inputs Ch.1 |  | UINT8 | RO | 0x0E (14dec)
6000:01 | Input 1 |  | boolean | RO | 0x00 (0dec)
6000:02 | Input 2 |  | boolean | RO | 0x00 (0dec)
6000:03 | Input 3 |  | boolean | RO | 0x00 (0dec)
6000:04 | Input 4 |  | boolean | RO | 0x00 (0dec)
6000:05 | Input 5 |  | boolean | RO | 0x00 (0dec)
6000:06 | Input 6 |  | boolean | RO | 0x00 (0dec)
6000:07 | Input 7 |  | boolean | RO | 0x00 (0dec)
6000:08 | Input 8 |  | boolean | RO | 0x00 (0dec)
6000:0E | Sync Error |  | boolean | RO | 0x00 (0dec)
Index 6001 DIG Diag Inputs Ch.1
Index | Name | Meaning | Data type | Flags | Default
6001:0 | DIG Diag Inputs Ch.1 |  | UINT8 | RO | 0x08 (8dec)
6001:01 | Diag Input 1 |  | boolean | RO | 0x00 (0dec)
6001:02 | Diag Input 2 |  | boolean | RO | 0x00 (0dec)
6001:03 | Diag Input 3 |  | boolean | RO | 0x00 (0dec)
6001:04 | Diag Input 4 |  | boolean | RO | 0x00 (0dec)
6001:05 | Diag Input 5 |  | boolean | RO | 0x00 (0dec)
6001:06 | Diag Input 6 |  | boolean | RO | 0x00 (0dec)
6001:07 | Diag Input 7 |  | boolean | RO | 0x00 (0dec)
6001:08 | Diag Input 8 |  | boolean | RO | 0x00 (0dec)
Index 7000 DIG Outputs Ch.1
Index | Name | Meaning | Data type | Flags | Default
7000:0 | DIG Outputs Ch.1 |  | UINT8 | RO | 0x08 (8dec)
7000:01 | Output 1 |  | boolean | RO | 0x00 (0dec)
7000:02 | Output 2 |  | boolean | RO | 0x00 (0dec)
7000:03 | Output 3 |  | boolean | RO | 0x00 (0dec)
7000:04 | Output 4 |  | boolean | RO | 0x00 (0dec)
7000:05 | Output 5 |  | boolean | RO | 0x00 (0dec)
7000:06 | Output 6 |  | boolean | RO | 0x00 (0dec)
7000:07 | Output 7 |  | boolean | RO | 0x00 (0dec)
7000:08 | Output 8 |  | boolean | RO | 0x00 (0dec)
Index F000 Modular device profile
Index | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0001 (1dec)
Index F008 Code word
Index | Name | Meaning | Data type | Flags | Default
F008:0 | Code word |  | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module list
Index | Name | Meaning | Data type | Flags | Default
F010:0 | Module list |  | UINT8 | RW | 0x01 (1dec)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x00000118 (280dec)
Index F600 DIG Inputs
Index | Name | Meaning | Data type | Flags | Default
F600:0 | DIG Inputs |  | UINT8 | RO | 0x10 (16dec)
F600:01 | Safe state active |  | boolean | RO | 0x00 (0dec)
F600:02 | Error channel 1 |  | boolean | RO | 0x00 (0dec)
F600:03 | Error channel 2 |  | boolean | RO | 0x00 (0dec)
F600:0E | Sync Error |  | boolean | RO | 0x00 (0dec)
F600:10 | TxPDO Toggle |  | boolean | RO | 0x00 (0dec)
Index F700 DIG Outputs
Index | Name | Meaning | Data type | Flags | Default
F700:0 | DIG Outputs |  | UINT8 | RO | 0x02 (2dec)
F700:01 | Set safe state |  | boolean | RO | 0x00 (0dec)
F700:02 | Reset outputs |  | boolean | RO | 0x00 (0dec)
Index F800 DIG Settings
Index | Name | Meaning | Data type | Flags | Default
F800:0 | DIG Settings |  | UINT8 | RO | 0x11 (17dec)
F800:01 | Disable shut off |  | boolean | RW | 0x00 (0dec)
F800:11 | Switch off time |  | UINT16 | RW | 0x03E8 (1000dec)
Also see about this
•
Configuration via TwinCAT
•
Configuration via TwinCAT


EP2816-0008 - Object description and parameterization

Commissioning/Configuration [image] EP2816-0008 - Object description and parameterization
EP2816-0008 - Object description and parameterization
Parameterization
The terminal is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (assignment of PDOs).
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. It is strongly recommended to download the latest revision of the corresponding XML file from the Beckhoff website (http://www.beckhoff.com/english/default.htm?download/elconfg.htm) and follow the installation instructions.
Introduction
The CoE overview contains objects for different intended applications:
▪
Objects required for parameterization during commissioning
▪
Objects intended for regular operation, e.g. through ADS access
▪
Objects for indicating internal settings (may be fixed)
▪
Further profile-specific objects indicating inputs, outputs and status information
The following section first describes the objects required for normal operation, followed by a complete overview of missing objects.
Objects to be parameterized during commissioning
Index 1011 Restore default parameters
Index | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default settings | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" in the Set Value Dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)
Index 8000 DIG Safe state active Ch.1
The outputs for which the DIG Safe state active bit is set are switched to the values specified in Safe state value in the event that the Operational (OP) status is left.
Status Operational (OP) is left if communication to the master is interrupted, for example at power breakdown at the master or cable breakage.
Index | Name | Meaning | Data type | Flags | Default
8000:0 | DIG Safe state active |  | UINT8 | RO | 0x08 (8dec)
8000:01 | Output 1 | 0bin: DIG Safe state for output 1 is switched off 1bin: DIG Safe state for output 1 is switched on | boolean | RW | 1bin
8000:02 | Output 2 | 0bin: DIG Safe state for output 2 is switched off 1bin: DIG Safe state for output 2 is switched on | boolean | RW | 1bin
8000:03 | Output 3 | 0bin: DIG Safe state for output 3 is switched off 1bin: DIG Safe state for output 3 is switched on | boolean | RW | 1bin
8000:04 | Output 4 | 0bin: DIG Safe state for output 4 is switched off 1bin: DIG Safe state for output 4 is switched on | boolean | RW | 1bin
8000:05 | Output 5 | 0bin: DIG Safe state for output 5 is switched off 1bin: DIG Safe state for output 5 is switched on | boolean | RW | 1bin
8000:06 | Output 6 | 0bin: DIG Safe state for output 6 is switched off 1bin: DIG Safe state for output 6 is switched on | boolean | RW | 1bin
8000:07 | Output 7 | 0bin: DIG Safe state for output 7 is switched off 1bin: DIG Safe state for output 7 is switched on | boolean | RW | 1bin
8000:08 | Output 8 | 0bin: DIG Safe state for output 8 is switched off 1bin: DIG Safe state for output 8 is switched on | boolean | RW | 1bin
Index 8001 DIG Safe state value Ch.1
The values to which the outputs are switched when the status Operational (OP) is left are specified here.
Index | Name | Meaning | Data type | Flags | Default
8001:0 | DIG Safe state value |  | UINT8 | RO | 0x08 (8dec)
8001:01 | Output 1 | 0bin: DIG Safe state value for output 1 = 0 1bin: DIG Safe state value for output 1 = 1 | boolean | RW | 0x00 (0dec)
8001:02 | Output 2 | 0bin: DIG Safe state value for output 2 = 0 1bin: DIG Safe state value for output 2 = 1 | boolean | RW | 0x00 (0dec)
8001:03 | Output 3 | 0bin: DIG Safe state value for output 3 = 0 1bin: DIG Safe state value for output 3 = 1 | boolean | RW | 0x00 (0dec)
8001:04 | Output 4 | 0bin: DIG Safe state value for output 4 = 0 1bin: DIG Safe state value for output 4 = 1 | boolean | RW | 0x00 (0dec)
8001:05 | Output 5 | 0bin: DIG Safe state value for output 5 = 0 1bin: DIG Safe state value for output 5 = 1 | boolean | RW | 0x00 (0dec)
8001:06 | Output 6 | 0bin: DIG Safe state value for output 6 = 0 1bin: DIG Safe state value for output 6 = 1 | boolean | RW | 0x00 (0dec)
8001:07 | Output 7 | 0bin: DIG Safe state value for output 7 = 0 1bin: DIG Safe state value for output 7 = 1 | boolean | RW | 0x00 (0dec)
8001:08 | Output 8 | 0bin: DIG Safe state value for output 8 = 0 1bin: DIG Safe state value for output 8 = 1 | boolean | RW | 0x00 (0dec)
Index 8010 DIG Safe state active Ch.2
The outputs for which the DIG Safe state active bit is set are switched to the values specified in Safe state value in the event that the Operational (OP) status is left.
Status Operational (OP) is left if communication to the master is interrupted, for example at power breakdown at the master or wire breakage.
Index | Name | Meaning | Data type | Flags | Default
8010:0 | DIG Safe state active |  | UINT8 | RO | 0x08 (8dec)
8010:01 | Output 9 | 0bin: DIG Safe state for output 9 is switched off 1bin: DIG Safe state for output 9 is switched on | boolean | RW | 1bin
8010:02 | Output 10 | 0bin: DIG Safe state for output 10 is switched off 1bin: DIG Safe state for output 10 is switched on | boolean | RW | 1bin
8010:03 | Output 11 | 0bin: DIG Safe state for output 11 is switched off 1bin: DIG Safe state for output 11 is switched on | boolean | RW | 1bin
8010:04 | Output 12 | 0bin: DIG Safe state for output 12 is switched off 1bin: DIG Safe state for output 12 is switched on | boolean | RW | 1bin
8010:05 | Output 13 | 0bin: DIG Safe state for output 13 is switched off 1bin: DIG Safe state for output 13 is switched on | boolean | RW | 1bin
8010:06 | Output 14 | 0bin: DIG Safe state for output 14 is switched off 1bin: DIG Safe state for output 14 is switched on | boolean | RW | 1bin
8010:07 | Output 15 | 0bin: DIG Safe state for output 15 is switched off 1bin: DIG Safe state for output 15 is switched on | boolean | RW | 1bin
8010:08 | Output 16 | 0bin: DIG Safe state for output 16 is switched off 1bin: DIG Safe state for output 16 is switched on | boolean | RW | 1bin
Index 8011 DIG Safe state value Ch.2
The values to which the outputs are switched when the status Operational (OP) is left are specified here.
Index | Name | Meaning | Data type | Flags | Default
8011:0 | DIG Safe state value |  | UINT8 | RO | 0x08 (8dec)
8011:01 | Output 9 | 0bin: DIG Safe state value for output 9 = 0 1bin: DIG Safe state value for output 9 = 1 | boolean | RW | 0x00 (0dec)
8011:02 | Output 10 | 0bin: DIG Safe state value for output 10 = 0 1bin: DIG Safe state value for output 10 = 1 | boolean | RW | 0x00 (0dec)
8011:03 | Output 11 | 0bin: DIG Safe state value for output 11 = 0 1bin: DIG Safe state value for output 11 = 1 | boolean | RW | 0x00 (0dec)
8011:04 | Output 12 | 0bin: DIG Safe state value for output 12 = 0 1bin: DIG Safe state value for output 12 = 1 | boolean | RW | 0x00 (0dec)
8011:05 | Output 13 | 0bin: DIG Safe state value for output 13 = 0 1bin: DIG Safe state value for output 13 = 1 | boolean | RW | 0x00 (0dec)
8011:06 | Output 14 | 0bin: DIG Safe state value for output 14 = 0 1bin: DIG Safe state value for output 14 = 1 | boolean | RW | 0x00 (0dec)
8011:07 | Output 15 | 0bin: DIG Safe state value for output 15 = 0 1bin: DIG Safe state value for output 15 = 1 | boolean | RW | 0x00 (0dec)
8011:08 | Output 16 | 0bin: DIG Safe state value for output 16 = 0 1bin: DIG Safe state value for output 16 = 1 | boolean | RW | 0x00 (0dec)
Objects for regular operation
The EP2xxx have no such objects.
Additional objects
Standard objects (0x1000-0x1FFF)
The standard objects have the same meaning for all EtherCAT slaves.
Index 1000 Device type
Index | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x01181389 (18355081dec)
Index 1008 Device name
Index | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | string | RO | EP2816-0008
Index 1009 Hardware version
Index | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | string | RO | 02
Index 100A Software Version
Index | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | string | RO | 05
Index 1018 Identity
Index | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x0B004052 (184565842dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the low word (bit 0-15) indicates the special terminal number, the high word (bit 16-31) refers to the device description | UINT32 | RO | 0x00130008 (1245192dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the Low Byte (bit 0-7) of the Low Word contains the year of production, the High Byte (bit 8-15) of the Low Word contains the week of production, the High Word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 Backup parameter handling
Index | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | Information for standardized loading and saving of backup entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum across all backup entries of the EtherCAT slave | UINT32 | RO | 0x00000000 (0dec)
Index 1600 DIG RxPDO-Map Outputs Ch.1
Index | Name | Meaning | Data type | Flags | Default
1600:0 | DIG RxPDO-Map Outputs Ch.1 | PDO Mapping RxPDO 1 | UINT8 | RO | 0x09 (9dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (DO Outputs Ch.1), entry 0x01 (Output 1)) | UINT32 | RO | 0x7000:01, 1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (DO Outputs Ch.1), entry 0x02 (Output 2)) | UINT32 | RO | 0x7000:02, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (DO Outputs Ch.1), entry 0x03 (Output 3)) | UINT32 | RO | 0x7000:03, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (DO Outputs Ch.1), entry 0x04 (Output 4)) | UINT32 | RO | 0x7000:04, 1
1600:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7000 (DO Outputs Ch.1), entry 0x05 (Output 5)) | UINT32 | RO | 0x7000:05, 1
1600:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7000 (DO Outputs Ch.1), entry 0x06 (Output 6)) | UINT32 | RO | 0x7000:06, 1
1600:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (DO Outputs Ch.1), entry 0x07 (Output 7)) | UINT32 | RO | 0x7000:07, 1
1600:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7000 (DO Outputs Ch.1), entry 0x08 (Output 8)) | UINT32 | RO | 0x7000:08, 1
1600:09 | SubIndex 009 | 9. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1601 DIG RxPDO-Map Outputs Ch.2
Index | Name | Meaning | Data type | Flags | Default
1601:0 | DIG RxPDO-Map Outputs Ch.2 | PDO Mapping RxPDO 2 | UINT8 | RO | 0x09 (9dec)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (DO Outputs Ch.2), entry 0x01 (Output 1)) | UINT32 | RO | 0x7010:01, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (DO Outputs Ch.2), entry 0x02 (Output 2)) | UINT32 | RO | 0x7010:02, 1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (DO Outputs Ch.2), entry 0x03 (Output 3)) | UINT32 | RO | 0x7010:03, 1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7010 (DO Outputs Ch.2), entry 0x04 (Output 4)) | UINT32 | RO | 0x7010:04, 1
1601:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7010 (DO Outputs Ch.2), entry 0x05 (Output 5)) | UINT32 | RO | 0x7010:05, 1
1601:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7010 (DO Outputs Ch.2), entry 0x06 (Output 6)) | UINT32 | RO | 0x7010:06, 1
1601:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7010 (DO Outputs Ch.2), entry 0x07 (Output 7)) | UINT32 | RO | 0x7010:07, 1
1601:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7010 (DO Outputs Ch.2), entry 0x08 (Output 8)) | UINT32 | RO | 0x7010:08, 1
1601:09 | SubIndex 009 | 9. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1602 DIG RxPDO-Map Outputs Device
Index | Name | Meaning | Data type | Flags | Default
1602:0 | DIG RxPDO-Map Outputs Device | PDO Mapping RxPDO 3 | UINT8 | RO | 0x03 (3dec)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF700 (DO Outputs), entry 0x01 (Set safe state)) | UINT32 | RO | 0xF700:01, 1
1602:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF700 (DO Outputs), entry 0x02 (Reset outputs)) | UINT32 | RO | 0xF700:02, 1
1602:03 | SubIndex 003 | 3. PDO Mapping entry (14 bits align) | UINT32 | RO | 0x0000:00, 14
Index 1A00 DIG TxPDO-Map Diag Inputs Ch.1
Index | Name | Meaning | Data type | Flags | Default
1A00:0 | DIG TxPDO-Map Diag Inputs Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x09 (9dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (DI Inputs Ch.1), entry 0x01 (Input 1)) | UINT32 | RO | 0x6001:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x02 (Input 2)) | UINT32 | RO | 0x6001:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x03 (Input 3)) | UINT32 | RO | 0x6001:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x04 (Input 4)) | UINT32 | RO | 0x6001:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x05 (Input 5)) | UINT32 | RO | 0x6001:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x06 (Input 6)) | UINT32 | RO | 0x6001:06, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x07 (Input 7)) | UINT32 | RO | 0x6001:07, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x08 (Input 8)) | UINT32 | RO | 0x6001:08, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1A01 DIG TxPDO-Map Diag Inputs Ch.2
Index | Name | Meaning | Data type | Flags | Default
1A01:0 | DIG TxPDO-Map Diag Inputs Ch.2 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x09 (9dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DO Inputs Ch.2), entry 0x01 (Input 1)) | UINT32 | RO | 0x6011:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (DO Inputs Ch.2), entry 0x02 (Input 2)) | UINT32 | RO | 0x6011:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (DO Inputs Ch.2), entry 0x03 (Input 3)) | UINT32 | RO | 0x6011:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (DO Inputs Ch.2), entry 0x04 (Input 4)) | UINT32 | RO | 0x6011:04, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (DO Inputs Ch.2), entry 0x05 (Input 5)) | UINT32 | RO | 0x6011:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (DO Inputs Ch.2), entry 0x06 (Input 6)) | UINT32 | RO | 0x6011:06, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (DO Inputs Ch.2), entry 0x07 (Input 7)) | UINT32 | RO | 0x6011:07, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (DO Inputs Ch.2), entry 0x08 (Input 8)) | UINT32 | RO | 0x6011:08, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1A02 DIG TxPDO-Map Inputs Device
Index | Name | Meaning | Data type | Flags | Default
1A02:0 | DIG TxPDO-Map Inputs Device | PDO Mapping TxPDO 3 | UINT8 | RO | 0x07 (7dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF600 (DO Inputs), entry 0x01 (Safe state active)) | UINT32 | RO | 0xF600:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF600 (DO Inputs), entry 0x02 (Error channel 1)) | UINT32 | RO | 0xF600:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF600 (DO Inputs), entry 0x03 (Error channel 2)) | UINT32 | RO | 0xF600:03, 1
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (10 bits align) | UINT32 | RO | 0x0000:00, 10
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF600 (DO Inputs), entry 0x0E (Sync Error)) | UINT32 | RO | 0x1C32:20, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x1800, entry 0x09) | UINT32 | RO | 0x1800:09, 1
Index 1C00 Sync manager type
Index | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the Sync Managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign
Index | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x03 (3dec)
1C12:01 | Subindex 001 | 1. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1600 (5632dec)
1C12:02 | Subindex 002 | 2. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1601 (5633dec)
1C12:03 | Subindex 003 | 3. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1602 (5634dec)
Index 1C13 TxPDO assign
Index | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x03 (3dec)
1C13:01 | Subindex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A01 (6657dec)
1C13:03 | Subindex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A02 (6658dec)
Index 1C32 SM output parameter
Index
Name
Meaning
Data type
Flags
Default
1C32:0
SM output parameter
Synchronization parameters for the outputs
UINT8
RO
0x20 (32dec)
1C32:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dec)
1C32:02
Cycle time
Cycle time (in ns):
▪
Free Run: Cycle time of the local timer
▪
Synchron with SM 2 Event: Master cycle time
▪
DC mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dec)
1C32:03
Shift time
Time between SYNC0 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00020F58 (135000dec)
1C32:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0 = 1: free run is supported
▪
Bit 1 = 1: Synchron with SM 2 Event is supported
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 10: Output Shift with SYNC1 event (only DC mode)
▪
Bit 14 = 1: dynamic times (measurement through writing of 1C32:08)
UINT16
RO
0xC007 (49159dec)
1C32:05
Minimum cycle time
Minimum cycle time (in ns)
UINT32
RO
0x00030D40 (200000dec)
1C32:06
Calc and copy time
Minimum time between SYNC0 and SYNC1 event (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:07
Minimum delay time
UINT32
RO
0x00020F58 (135000dec)
1C32:08
Command
▪
0: Measurement of the local cycle time is stopped
▪
1: Measurement of the local cycle time is started
The entries 1C32:03, 1C32:05, 1C32:06, 1C32:09, 1C33:03, 1C33:06, 1C33:09 are updated with the maximum measured values.
For a subsequent measurement the measured values are reset
UINT16
RW
0x0000 (0dec)
1C32:09
Maximum Delay time
Time between SYNC1 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00020F58 (135000dec)
1C32:0B
SM event missed counter
Number of missed SM events in OPERATIONAL (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:0C
Cycle exceeded counter
Number of occasions the cycle time was exceeded in OPERATIONAL (cycle was not completed in time or the next cycle began too early)
UINT16
RO
0x0000 (0dec)
1C32:0D
Shift too short counter
Number of occasions that the interval between SYNC0 and SYNC1 event was too short (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:20
Sync error
The synchronization was not correct in the last cycle (outputs were output too late; DC mode only)
boolean
RO
0x00 (0dec)
Index 1C33 SM input parameter
Index
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (no outputs available)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (outputs available)
UINT16
RW
0x0022 (34dec)
1C33:02
Cycle time
as 1C32:02
UINT32
RW
0x000F4240 (1000000dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: Synchron with SM 2 Event is supported (outputs available)
▪
Bit 1: Synchron with SM 3 Event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: Input Shift through local event (outputs available)
▪
Bit 4-5 = 10: Input Shift with SYNC1 event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 1C32:08 or 1C33:08)
UINT16
RO
0xC007 (49159dec)
1C33:05
Minimum cycle time
as 1C32:05
UINT32
RO
0x00030D40 (200000dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:07
Minimum delay time
UINT32
RO
0x00000000 (0dec)
1C33:08
Command
as 1C32:08
UINT16
RW
0x0000 (0dec)
1C33:09
Maximum Delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:0B
SM event missed counter
as 1C32:11
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
as 1C32:12
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
as 1C32:13
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
as 1C32:32
boolean
RO
0x00 (0dec)
Profile-specific objects (0x6000-0xFFFF)
The profile-specific objects have the same meaning for all EtherCAT slaves that support the profile 5001.
Index 6001 DIG Diag Inputs Ch.1
Index | Name | Meaning | Data type | Flags | Default
6001:0 | DIG Diag Inputs Ch.1 |  | UINT8 | RO | 0x08 (8dec)
6001:01 | Diag Input 1 |  | boolean | RO | 0x00 (0dec)
6001:02 | Diag Input 2 |  | boolean | RO | 0x00 (0dec)
6001:03 | Diag Input 3 |  | boolean | RO | 0x00 (0dec)
6001:04 | Diag Input 4 |  | boolean | RO | 0x00 (0dec)
6001:05 | Diag Input 5 |  | boolean | RO | 0x00 (0dec)
6001:06 | Diag Input 6 |  | boolean | RO | 0x00 (0dec)
6001:07 | Diag Input 7 |  | boolean | RO | 0x00 (0dec)
6001:08 | Diag Input 8 |  | boolean | RO | 0x00 (0dec)
Index 6011 DIG Diag Inputs Ch.2
Index | Name | Meaning | Data type | Flags | Default
6011:0 | DIG Diag Inputs Ch.2 |  | UINT8 | RO | 0x08 (8dec)
6011:01 | Diag Input 1 |  | boolean | RO | 0x00 (0dec)
6011:02 | Diag Input 2 |  | boolean | RO | 0x00 (0dec)
6011:03 | Diag Input 3 |  | boolean | RO | 0x00 (0dec)
6011:04 | Diag Input 4 |  | boolean | RO | 0x00 (0dec)
6011:05 | Diag Input 5 |  | boolean | RO | 0x00 (0dec)
6011:06 | Diag Input 6 |  | boolean | RO | 0x00 (0dec)
6011:07 | Diag Input 7 |  | boolean | RO | 0x00 (0dec)
6011:08 | Diag Input 8 |  | boolean | RO | 0x00 (0dec)
Index 7000 DIG Outputs Ch.1
Index | Name | Meaning | Data type | Flags | Default
7000:0 | DIG Outputs Ch.1 |  | UINT8 | RO | 0x08 (8dec)
7000:01 | Output 1 |  | boolean | RO | 0x00 (0dec)
7000:02 | Output 2 |  | boolean | RO | 0x00 (0dec)
7000:03 | Output 3 |  | boolean | RO | 0x00 (0dec)
7000:04 | Output 4 |  | boolean | RO | 0x00 (0dec)
7000:05 | Output 5 |  | boolean | RO | 0x00 (0dec)
7000:06 | Output 6 |  | boolean | RO | 0x00 (0dec)
7000:07 | Output 7 |  | boolean | RO | 0x00 (0dec)
7000:08 | Output 8 |  | boolean | RO | 0x00 (0dec)
Index 7010 DIG Outputs Ch.2
Index | Name | Meaning | Data type | Flags | Default
7010:0 | DIG Outputs Ch.2 |  | UINT8 | RO | 0x08 (8dec)
7010:01 | Output 1 |  | boolean | RO | 0x00 (0dec)
7010:02 | Output 2 |  | boolean | RO | 0x00 (0dec)
7010:03 | Output 3 |  | boolean | RO | 0x00 (0dec)
7010:04 | Output 4 |  | boolean | RO | 0x00 (0dec)
7010:05 | Output 5 |  | boolean | RO | 0x00 (0dec)
7010:06 | Output 6 |  | boolean | RO | 0x00 (0dec)
7010:07 | Output 7 |  | boolean | RO | 0x00 (0dec)
7010:08 | Output 8 |  | boolean | RO | 0x00 (0dec)
Index F000 Modular device profile
Index | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0002 (2dec)
Index F008 Code word
Index | Name | Meaning | Data type | Flags | Default
F008:0 | Code word |  | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module list
Index | Name | Meaning | Data type | Flags | Default
F010:0 | Module list |  | UINT8 | RW | 0x02 (2dec)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x00000118 (280dec)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x00000118 (280dec)
Index F600 DIG Inputs
Index | Name | Meaning | Data type | Flags | Default
F600:0 | DIG Inputs |  | UINT8 | RO | 0x10 (16dec)
F600:01 | Safe state active |  | boolean | RO | 0x00 (0dec)
F600:02 | Error channel 1 |  | boolean | RO | 0x00 (0dec)
F600:03 | Error channel 2 |  | boolean | RO | 0x00 (0dec)
F600:0E | Sync error |  | boolean | RO | 0x00 (0dec)
F600:10 | TxPDO Toggle |  | boolean | RO | 0x00 (0dec)
Index F700 DIG Outputs
Index | Name | Meaning | Data type | Flags | Default
F700:0 | DIG Outputs |  | UINT8 | RO | 0x02 (2dec)
F700:01 | Set safe state |  | boolean | RO | 0x00 (0dec)
F700:02 | Reset outputs |  | boolean | RO | 0x00 (0dec)
Index F800 DIG Settings
Index | Name | Meaning | Data type | Flags | Default
F800:0 | DIG Settings |  | UINT8 | RO | 0x11 (17dec)
F800:01 | Disable shut off |  | boolean | RW | 0x00 (0dec)
F800:11 | Switch off time |  | UINT16 | RW | 0x03E8 (1000dec)
Also see about this
•
Configuration via TwinCAT
•
Configuration via TwinCAT


EP2817-0008 - Object description and parameterization

Commissioning/Configuration [image] EP2817-0008 - Object description and parameterization
EP2817-0008 - Object description and parameterization
Parameterization
The terminal is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (assignment of PDOs).
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. It is strongly recommended to download the latest revision of the corresponding XML file from the Beckhoff website (http://www.beckhoff.com/english/default.htm?download/elconfg.htm) and follow the installation instructions.
Introduction
The CoE overview contains objects for different intended applications:
▪
Objects required for parameterization during commissioning
▪
Objects for indicating internal settings (may be fixed)
▪
Further profile-specific objects indicating inputs, outputs and status information
The following section first describes the objects required for normal operation, followed by a complete overview of missing objects.
Objects to be parameterized during commissioning
Index 1011 Restore default parameters
Index | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default settings | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to 0x64616F6C in the set value dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)
Index 8000 DIG Safe state active Ch.1
The outputs for which the DIG Safe state active bit is set are switched to the values specified in Safe state value in the event that the Operational (OP) status is left.
Status Operational (OP) is left if communication to the master is interrupted, for example at power breakdown at the master or cable breakage.
Index | Name | Meaning | Data type | Flags | Default
8000:0 | DIG Safe state active |  | UINT8 | RO | 0x08 (8dec)
8000:01 | Output 1 | 0bin: DIG Safe state for output 1 is switched off 1bin: DIG Safe state for output 1 is switched on | boolean | RW | 1bin
8000:02 | Output 2 | 0bin: DIG Safe state for output 2 is switched off 1bin: DIG Safe state for output 2 is switched on | boolean | RW | 1bin
8000:03 | Output 3 | 0bin: DIG Safe state for output 3 is switched off 1bin: DIG Safe state for output 3 is switched on | boolean | RW | 1bin
8000:04 | Output 4 | 0bin: DIG Safe state for output 4 is switched off 1bin: DIG Safe state for output 4 is switched on | boolean | RW | 1bin
8000:05 | Output 5 | 0bin: DIG Safe state for output 5 is switched off 1bin: DIG Safe state for output 5 is switched on | boolean | RW | 1bin
8000:06 | Output 6 | 0bin: DIG Safe state for output 6 is switched off 1bin: DIG Safe state for output 6 is switched on | boolean | RW | 1bin
8000:07 | Output 7 | 0bin: DIG Safe state for output 7 is switched off 1bin: DIG Safe state for output 7 is switched on | boolean | RW | 1bin
8000:08 | Output 8 | 0bin: DIG Safe state for output 8 is switched off 1bin: DIG Safe state for output 8 is switched on | boolean | RW | 1bin
Index 8001 DIG Safe state value Ch.1
The values to which the outputs are switched when the status Operational (OP) is left are specified here.
Index | Name | Meaning | Data type | Flags | Default
8001:0 | DIG Safe state value |  | UINT8 | RO | 0x08 (8dec)
8001:01 | Output 1 | 0bin: DIG Safe state value for output 1 = 0 1bin: DIG Safe state value for output 1 = 1 | boolean | RW | 0x00 (0dec)
8001:02 | Output 2 | 0bin: DIG Safe state value for output 2 = 0 1bin: DIG Safe state value for output 2 = 1 | boolean | RW | 0x00 (0dec)
8001:03 | Output 3 | 0bin: DIG Safe state value for output 3 = 0 1bin: DIG Safe state value for output 3 = 1 | boolean | RW | 0x00 (0dec)
8001:04 | Output 4 | 0bin: DIG Safe state value for output 4 = 0 1bin: DIG Safe state value for output 4 = 1 | boolean | RW | 0x00 (0dec)
8001:05 | Output 5 | 0bin: DIG Safe state value for output 5 = 0 1bin: DIG Safe state value for output 5 = 1 | boolean | RW | 0x00 (0dec)
8001:06 | Output 6 | 0bin: DIG Safe state value for output 6 = 0 1bin: DIG Safe state value for output 6 = 1 | boolean | RW | 0x00 (0dec)
8001:07 | Output 7 | 0bin: DIG Safe state value for output 7 = 0 1bin: DIG Safe state value for output 7 = 1 | boolean | RW | 0x00 (0dec)
8001:08 | Output 8 | 0bin: DIG Safe state value for output 8 = 0 1bin: DIG Safe state value for output 8 = 1 | boolean | RW | 0x00 (0dec)
Index 8010 DIG Safe state active Ch.2
The outputs for which the DIG Safe state active bit is set are switched to the values specified in Safe state value in the event that the Operational (OP) status is left.
Status Operational (OP) is left if communication to the master is interrupted, for example at power breakdown at the master or wire breakage.
Index | Name | Meaning | Data type | Flags | Default
8010:0 | DIG Safe state active |  | UINT8 | RO | 0x08 (8dec)
8010:01 | Output 9 | 0bin: DIG Safe state for output 9 is switched off 1bin: DIG Safe state for output 9 is switched on | boolean | RW | 1bin
8010:02 | Output 10 | 0bin: DIG Safe state for output 10 is switched off 1bin: DIG Safe state for output 10 is switched on | boolean | RW | 1bin
8010:03 | Output 11 | 0bin: DIG Safe state for output 11 is switched off 1bin: DIG Safe state for output 11 is switched on | boolean | RW | 1bin
8010:04 | Output 12 | 0bin: DIG Safe state for output 12 is switched off 1bin: DIG Safe state for output 12 is switched on | boolean | RW | 1bin
8010:05 | Output 13 | 0bin: DIG Safe state for output 13 is switched off 1bin: DIG Safe state for output 13 is switched on | boolean | RW | 1bin
8010:06 | Output 14 | 0bin: DIG Safe state for output 14 is switched off 1bin: DIG Safe state for output 14 is switched on | boolean | RW | 1bin
8010:07 | Output 15 | 0bin: DIG Safe state for output 15 is switched off 1bin: DIG Safe state for output 15 is switched on | boolean | RW | 1bin
8010:08 | Output 16 | 0bin: DIG Safe state for output 16 is switched off 1bin: DIG Safe state for output 16 is switched on | boolean | RW | 1bin
Index 8011 DIG Safe state value Ch.2
The values to which the outputs are switched when the status Operational (OP) is left are specified here.
Index | Name | Meaning | Data type | Flags | Default
8011:0 | DIG Safe state value |  | UINT8 | RO | 0x08 (8dec)
8011:01 | Output 9 | 0bin: DIG Safe state value for output 9 = 0 1bin: DIG Safe state value for output 9 = 1 | boolean | RW | 0x00 (0dec)
8011:02 | Output 10 | 0bin: DIG Safe state value for output 10 = 0 1bin: DIG Safe state value for output 10 = 1 | boolean | RW | 0x00 (0dec)
8011:03 | Output 11 | 0bin: DIG Safe state value for output 11 = 0 1bin: DIG Safe state value for output 11 = 1 | boolean | RW | 0x00 (0dec)
8011:04 | Output 12 | 0bin: DIG Safe state value for output 12 = 0 1bin: DIG Safe state value for output 12 = 1 | boolean | RW | 0x00 (0dec)
8011:05 | Output 13 | 0bin: DIG Safe state value for output 13 = 0 1bin: DIG Safe state value for output 13 = 1 | boolean | RW | 0x00 (0dec)
8011:06 | Output 14 | 0bin: DIG Safe state value for output 14 = 0 1bin: DIG Safe state value for output 14 = 1 | boolean | RW | 0x00 (0dec)
8011:07 | Output 15 | 0bin: DIG Safe state value for output 15 = 0 1bin: DIG Safe state value for output 15 = 1 | boolean | RW | 0x00 (0dec)
8011:08 | Output 16 | 0bin: DIG Safe state value for output 16 = 0 1bin: DIG Safe state value for output 16 = 1 | boolean | RW | 0x00 (0dec)
Index 8020 DIG Safe state active Ch.3
The outputs for which the DIG Safe state active bit is set are switched to the values specified in Safe state value in the event that the Operational (OP) status is left.
Status Operational (OP) is left if communication to the master is interrupted, for example at power breakdown at the master or cable breakage.
Index | Name | Meaning | Data type | Flags | Default
8020:0 | DIG Safe state active |  | UINT8 | RO | 0x08 (8dec)
8020:01 | Output 17 | 0bin: DIG Safe state for output 17 is switched off 1bin: DIG Safe state for output 17 is switched on | boolean | RW | 1bin
8020:02 | Output 18 | 0bin: DIG Safe state for output 18 is switched off 1bin: DIG Safe state for output 18 is switched on | boolean | RW | 1bin
8020:03 | Output 19 | 0bin: DIG Safe state for output 19 is switched off 1bin: DIG Safe state for output 19 is switched on | boolean | RW | 1bin
8020:04 | Output 20 | 0bin: DIG Safe state for output 20 is switched off 1bin: DIG Safe state for output 20 is switched on | boolean | RW | 1bin
8020:05 | Output 21 | 0bin: DIG Safe state for output 21 is switched off 1bin: DIG Safe state for output 21 is switched on | boolean | RW | 1bin
8020:06 | Output 22 | 0bin: DIG Safe state for output 22 is switched off 1bin: DIG Safe state for output 22 is switched on | boolean | RW | 1bin
8020:07 | Output 23 | 0bin: DIG Safe state for output 23 is switched off 1bin: DIG Safe state for output 23 is switched on | boolean | RW | 1bin
8020:08 | Output 24 | 0bin: DIG Safe state for output 24 is switched off 1bin: DIG Safe state for output 24 is switched on | boolean | RW | 1bin
Index 8021 DIG Safe state value Ch.3
The values to which the outputs are switched when the status Operational (OP) is left are specified here.
Index | Name | Meaning | Data type | Flags | Default
8021:0 | DIG Safe state value |  | UINT8 | RO | 0x08 (8dec)
8021:01 | Output 17 | 0bin: DIG Safe state value for output 17 = 0 1bin: DIG Safe state value for output 17 = 1 | boolean | RW | 0bin
8021:02 | Output 18 | 0bin: DIG Safe state value for output 18 = 0 1bin: DIG Safe state value for output 18 = 1 | boolean | RW | 0bin
8021:03 | Output 19 | 0bin: DIG Safe state value for output 19 = 0 1bin: DIG Safe state value for output 19 = 1 | boolean | RW | 0bin
8021:04 | Output 20 | 0bin: DIG Safe state value for output 20 = 0 1bin: DIG Safe state value for output 20 = 1 | boolean | RW | 0bin
8021:05 | Output 21 | 0bin: DIG Safe state value for output 21 = 0 1bin: DIG Safe state value for output 21 = 1 | boolean | RW | 0bin
8021:06 | Output 22 | 0bin: DIG Safe state value for output 22 = 0 1bin: DIG Safe state value for output 22 = 1 | boolean | RW | 0bin
8021:07 | Output 23 | 0bin: DIG Safe state value for output 23 = 0 1bin: DIG Safe state value for output 23 = 1 | boolean | RW | 0bin
8021:08 | Output 24 | 0bin: DIG Safe state value for output 24 = 0 1bin: DIG Safe state value for output 24 = 1 | boolean | RW | 0bin
Further objects
Standard objects (0x1000-0x1FFF)
The standard objects of all EtherCAT slaves have the same Meaning.
Index 1000 Device type
Index | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Lo-Word contains the supported CoE Profile (5001). The Hi-Word contains the Module Profile corresponding to the Modular Device Profile. | UINT32 | RO | 0x01181389 (18355081dec)
Index 1008 Device name
Index | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | string | RO | EP2817-0008
Index 1009 Hardware version
Index | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slaves | string | RO |
Index 100A Software version
Index | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slaves | string | RO | 00
Index 1018 Identity
Index | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | contains information to identify the EtherCAT slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x0B014052 (184631378dec)
1018:03 | Revision | Revision number of the EtherCAT-Slave, the Lo-Word (Bit 0-15) indicates the special functions terminal number; the Hi-Word (Bit 16-31) refers to the device description. | UINT32 | RO | 0x00000000 (0dec)
1018:04 | Serial number | Serial number of the EtherCAT-Slave, the Lo-Byte (Bit 0-7) of the Lo-Word contains the year of manufacturing, the Hi-Byte (Bit 8-15) of the Lo-Word contains the week of manufacturing, the Hi-Word (Bit 16-31) is 0 . | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 Backup parameter handling
Index | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | contains information for the standardized Upload and Download of the Backup Entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum over all backup entries | UINT32 | RO | 0x00000000 (0dec)
Index 1600 DIG RxPDO-Map OutputsCh.1
Index | Name | Meaning | Data type | Flags | Default
1600:0 | DIG RxPDO-Map OutputsCh.1 | PDO Mapping RxPDO 1 | UINT8 | RO | 0x09 (9dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (DIG Outputs Ch.1), entry 0x01 (Output 1)) | UINT32 | RO | 0x7000:01, 1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (DIG Outputs Ch.1), entry 0x02 (Output 2)) | UINT32 | RO | 0x7000:02, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (DIG Outputs Ch.1), entry 0x03 (Output 3)) | UINT32 | RO | 0x7000:03, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (DIG Outputs Ch.1), entry 0x04 (Output 4)) | UINT32 | RO | 0x7000:04, 1
1600:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7000 (DIG Outputs Ch.1), entry 0x05 (Output 5)) | UINT32 | RO | 0x7000:05, 1
1600:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7000 (DIG Outputs Ch.1), entry 0x06 (Output 6)) | UINT32 | RO | 0x7000:06, 1
1600:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (DIG Outputs Ch.1), entry 0x07 (Output 7)) | UINT32 | RO | 0x7000:07, 1
1600:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7000 (DIG Outputs Ch.1), entry 0x08 (Output 8)) | UINT32 | RO | 0x7000:08, 1
1600:09 | SubIndex 009 | 9. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1601 DIG RxPDO-Map OutputsCh.2
Index | Name | Meaning | Data type | Flags | Default
1601:0 | DIG RxPDO-Map OutputsCh.2 | PDO Mapping RxPDO 2 | UINT8 | RO | 0x09 (9dec)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (DIG Outputs Ch.2), entry 0x01 (Output 1)) | UINT32 | RO | 0x7010:01, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (DIG Outputs Ch.2), entry 0x02 (Output 2)) | UINT32 | RO | 0x7010:02, 1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (DIG Outputs Ch.2), entry 0x03 (Output 3)) | UINT32 | RO | 0x7010:03, 1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7010 (DIG Outputs Ch.2), entry 0x04 (Output 4)) | UINT32 | RO | 0x7010:04, 1
1601:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7010 (DIG Outputs Ch.2), entry 0x05 (Output 5)) | UINT32 | RO | 0x7010:05, 1
1601:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7010 (DIG Outputs Ch.2), entry 0x06 (Output 6)) | UINT32 | RO | 0x7010:06, 1
1601:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7010 (DIG Outputs Ch.2), entry 0x07 (Output 7)) | UINT32 | RO | 0x7010:07, 1
1601:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7010 (DIG Outputs Ch.2), entry 0x08 (Output 8)) | UINT32 | RO | 0x7010:08, 1
1601:09 | SubIndex 009 | 9. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1602 DIG RxPDO-Map OutputsCh.3
Index | Name | Meaning | Data type | Flags | Default
1602:0 | DIG RxPDO-Map OutputsCh.3 | PDO Mapping RxPDO 3 | UINT8 | RO | 0x09 (9dec)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (DIG Outputs Ch.3), entry 0x01 (Output 1)) | UINT32 | RO | 0x7020:01, 1
1602:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7020 (DIG Outputs Ch.3), entry 0x02 (Output 2)) | UINT32 | RO | 0x7020:02, 1
1602:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7020 (DIG Outputs Ch.3), entry 0x03 (Output 3)) | UINT32 | RO | 0x7020:03, 1
1602:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7020 (DIG Outputs Ch.3), entry 0x04 (Output 4)) | UINT32 | RO | 0x7020:04, 1
1602:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7020 (DIG Outputs Ch.3), entry 0x05 (Output 5)) | UINT32 | RO | 0x7020:05, 1
1602:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7020 (DIG Outputs Ch.3), entry 0x06 (Output 6)) | UINT32 | RO | 0x7020:06, 1
1602:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7020 (DIG Outputs Ch.3), entry 0x07 (Output 7)) | UINT32 | RO | 0x7020:07, 1
1602:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7020 (DIG Outputs Ch.3), entry 0x08 (Output 8)) | UINT32 | RO | 0x7020:08, 1
1602:09 | SubIndex 009 | 9. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1603 DIG RxPDO-Map Outputs Device
Index | Name | Meaning | Data type | Flags | Default
1603:0 | DIG RxPDO-Map Outputs Device | PDO Mapping RxPDO 4 | UINT8 | RO | 0x03 (3dec)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF700 (DIG Outputs), entry 0x01 (Set safe state)) | UINT32 | RO | 0xF700:01, 1
1603:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF700 (DIG Outputs), entry 0x02 (Reset outputs)) | UINT32 | RO | 0xF700:02, 1
1603:03 | SubIndex 003 | 3. PDO Mapping entry (14 bits align) | UINT32 | RO | 0x0000:00, 14
Index 1A00 DIG TxPDO-Map Diag Inputs Ch.1
Index | Name | Meaning | Data type | Flags | Default
1A00:0 | DIG TxPDO-Map Diag Inputs Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x09 (9dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (DIG Diag Inputs Ch.1), entry 0x01 (Diag Input 1)) | UINT32 | RO | 0x6001:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6001 (DIG Diag Inputs Ch.1), entry 0x02 (Diag Input 2)) | UINT32 | RO | 0x6001:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6001 (DIG Diag Inputs Ch.1), entry 0x03 (Diag Input 3)) | UINT32 | RO | 0x6001:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6001 (DIG Diag Inputs Ch.1), entry 0x04 (Diag Input 4)) | UINT32 | RO | 0x6001:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6001 (DIG Diag Inputs Ch.1), entry 0x05 (Diag Input 5)) | UINT32 | RO | 0x6001:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6001 (DIG Diag Inputs Ch.1), entry 0x06 (Diag Input 6)) | UINT32 | RO | 0x6001:06, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6001 (DIG Diag Inputs Ch.1), entry 0x07 (Diag Input 7)) | UINT32 | RO | 0x6001:07, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6001 (DIG Diag Inputs Ch.1), entry 0x08 (Diag Input 8)) | UINT32 | RO | 0x6001:08, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1A01 DIG TxPDO-Map Diag Inputs Ch.2
Index | Name | Meaning | Data type | Flags | Default
1A01:0 | DIG TxPDO-Map Diag Inputs Ch.2 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x09 (9dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (DIG Diag Inputs Ch.2), entry 0x01 (Diag Input 1)) | UINT32 | RO | 0x6011:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6011 (DIG Diag Inputs Ch.2), entry 0x02 (Diag Input 2)) | UINT32 | RO | 0x6011:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6011 (DIG Diag Inputs Ch.2), entry 0x03 (Diag Input 3)) | UINT32 | RO | 0x6011:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6011 (DIG Diag Inputs Ch.2), entry 0x04 (Diag Input 4)) | UINT32 | RO | 0x6011:04, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6011 (DIG Diag Inputs Ch.2), entry 0x05 (Diag Input 5)) | UINT32 | RO | 0x6011:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6011 (DIG Diag Inputs Ch.2), entry 0x06 (Diag Input 6)) | UINT32 | RO | 0x6011:06, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6011 (DIG Diag Inputs Ch.2), entry 0x07 (Diag Input 7)) | UINT32 | RO | 0x6011:07, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6011 (DIG Diag Inputs Ch.2), entry 0x08 (Diag Input 8)) | UINT32 | RO | 0x6011:08, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1A02 DIG TxPDO-Map Diag Inputs Ch.3
Index | Name | Meaning | Data type | Flags | Default
1A02:0 | DIG TxPDO-Map Diag Inputs Ch.3 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x09 (9dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6021 (DIG Diag Inputs Ch.3), entry 0x01 (Diag Input 1)) | UINT32 | RO | 0x6021:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6021 (DIG Diag Inputs Ch.3), entry 0x02 (Diag Input 2)) | UINT32 | RO | 0x6021:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6021 (DIG Diag Inputs Ch.3), entry 0x03 (Diag Input 3)) | UINT32 | RO | 0x6021:03, 1
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6021 (DIG Diag Inputs Ch.3), entry 0x04 (Diag Input 4)) | UINT32 | RO | 0x6021:04, 1
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6021 (DIG Diag Inputs Ch.3), entry 0x05 (Diag Input 5)) | UINT32 | RO | 0x6021:05, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6021 (DIG Diag Inputs Ch.3), entry 0x06 (Diag Input 6)) | UINT32 | RO | 0x6021:06, 1
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6021 (DIG Diag Inputs Ch.3), entry 0x07 (Diag Input 7)) | UINT32 | RO | 0x6021:07, 1
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6021 (DIG Diag Inputs Ch.3), entry 0x08 (Diag Input 8)) | UINT32 | RO | 0x6021:08, 1
1A02:09 | SubIndex 009 | 9. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1A03 DIG TxPDO-Map Inputs Device
Index | Name | Meaning | Data type | Flags | Default
1A03:0 | DIG TxPDO-Map Inputs Device | PDO Mapping TxPDO 4 | UINT8 | RO | 0x0A (10dec)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF600 (DIG Inputs), entry 0x01 (Safe state active)) | UINT32 | RO | 0xF600:01, 1
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF600 (DIG Inputs), entry 0x02 (Error channel 1)) | UINT32 | RO | 0xF600:02, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF600 (DIG Inputs), entry 0x03 (Error channel 2)) | UINT32 | RO | 0xF600:03, 1
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF600 (DIG Inputs), entry 0x04 (Error channel 3)) | UINT32 | RO | 0xF600:04, 1
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF600 (DIG Inputs), entry 0x05 (Us Undervoltage)) | UINT32 | RO | 0xF600:05, 1
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF600 (DIG Inputs), entry 0x06 (Up Undervoltage)) | UINT32 | RO | 0xF600:06, 1
1A03:07 | SubIndex 007 | 7. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A03:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF600 (DIG Inputs), entry 0x0E (Sync error)) | UINT32 | RO | 0xF600:0E, 1
1A03:09 | SubIndex 009 | 9. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A03:0A | SubIndex 010 | 10. PDO Mapping entry (object 0xF600 (DIG Inputs), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0xF600:10, 1
Index 1C00 Sync manager type
Index | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Usage of the Sync Manager channels | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign
Index | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x04 (4dec)
1C12:01 | Subindex 001 | 1. assigned RxPDO (contains the index of the corresponding RxPDO Mapping object) | UINT16 | RW | 0x1600 (5632dec)
1C12:02 | Subindex 002 | 2. assigned RxPDO (contains the index of the corresponding RxPDO Mapping object) | UINT16 | RW | 0x1601 (5633dec)
1C12:03 | Subindex 003 | 3. assigned RxPDO (contains the index of the corresponding RxPDO Mapping object) | UINT16 | RW | 0x1602 (5634dec)
1C12:04 | Subindex 004 | 4. assigned RxPDO (contains the index of the corresponding RxPDO Mapping object) | UINT16 | RW | 0x1603 (5635dec)
Index 1C13 TxPDO assign
Index | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x04 (4dec)
1C13:01 | Subindex 001 | 1. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A01 (6657dec)
1C13:03 | Subindex 003 | 3. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A02 (6658dec)
1C13:04 | Subindex 004 | 4. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A03 (6659dec)
Index 1C32SM Output parameter
Index
Name
Meaning
Data type
Flags
Default
1C32:0
SM output parameter
Synchronization parameter of the outputs
UINT8
RO
0x20 (32dec)
1C32:01
Sync mode
actual synchronization mode:
▪
0: Free Run
▪
1: Synchronous with SM 2 Event
▪
2: DC-Mode - Synchronous with SYNC0 Event
▪
3: DC-Mode - Synchronous with SYNC1 Event
UINT16
RW
0x0001 (1dec)
1C32:02
Cycle time
Cycle time (in ns):
▪
Free Run: cycle time of the local timer
▪
Synchronous with SM 2 Event: Cycle time of the master
▪
DC mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x003D0900 (4000000dec)
1C32:03
Shift time
Time between SYNC0 Event and Outputs Valid (in ns, only in DC-Mode)
UINT32
RO
0x00000000 (0dec)
1C32:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0 = 1: Free Run is supported
▪
Bit 1 = 1: Synchronous with SM 2 Event is supported
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 10: Output Shift with SYNC1 Event (only DC-Mode)
▪
Bit 14 = 1: dynamic times (could be measured by writing 1C32:08)
UINT16
RO
0x000A (10dec)
1C32:05
Minimum cycle time
Minimum cycle time supported (in ns)
UINT32
RO
0x000493E0 (300000dec)
1C32:06
Calc and copy time
Minimal time between SYNC0 and SYNC1 Event (in ns, only in DC-Mode)
UINT32
RO
0x00000000 (0dec)
1C32:07
Minimum delay time
UINT32
RO
0x00000000 (0dec)
1C32:08
Command
▪
0: Measurement of the times will be stopped
▪
1: Measurement of the times will be started
The Entries 1C32:03, 1C32:05, 1C32:06, 1C32:09, 1C33:03, 1C33:06, 1C33:09 will be updated with the maximum measured values.
UINT16
RW
0x0000 (0dec)
1C32:09
Maximum delay time
Time between SYNC1 Event and Outputs Valid (in ns, only in DC-Mode)
UINT32
RO
0x00000000 (0dec)
1C32:0B
SM event missed counter
Number of the missed SM-Events in state OPERATIONAL (only in DC Mode)
UINT16
RO
0x0000 (0dec)
1C32:0C
Cycle exceeded counter
Number of exceeded cycles in state OPERATIONAL
UINT16
RO
0x0000 (0dec)
1C32:0D
Shift too short counter
Number of inadequate distances between SYNC0 and SYNC1 events (only in DC Mode)
UINT16
RO
0x0000 (0dec)
1C32:20
Sync error
TRUE: In the last cycle the synchronization was not correct (only in DC Mode)
boolean
RO
0x00 (0dec)
Index 1C33 SM input parameter
Index
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameter of the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
actual synchronization mode:
▪
0: Free Run
▪
1: Synchronous with SM 3 Event (no Outputs available)
▪
2: DC - Synchronous with SYNC0 Event
▪
3: DC - Synchronous with SYNC1 Event
▪
34: Synchronous with SM 2 Event (Outputs available)
UINT16
RW
0x0022 (34dec)
1C33:02
Cycle time
same as 1C32:02
UINT32
RW
0x003D0900 (4000000dec)
1C33:03
Shift time
time between SYNC0-Event and Input Latch (in ns, only in DC-Mode)
UINT32
RO
0x00000000 (0dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: Free Run is supported
▪
Bit 1: Synchronous with SM 2 Event is supported (Outputs available)
▪
Bit 1: Synchronous with SM 3 Event is supported (no Outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: Input Shift with local event (Outputs available)
▪
Bit 4-5 = 10: Input Shift with SYNC1 Event (no Outputs available)
▪
Bit 14 = 1: dynamic times (could be measured by writing 1C32:08 or 1C33:08)
UINT16
RO
0x000A (10dec)
1C33:05
Minimum cycle time
same as 1C32:05
UINT32
RO
0x000493E0 (300000dec)
1C33:06
Calc and copy time
time between Input Latch and the availability of the inputs for the master (in ns, only in DC-Mode)
UINT32
RO
0x00000000 (0dec)
1C33:07
Minimum delay time
UINT32
RO
0x00000000 (0dec)
1C33:08
Command
same as 1C32:08
UINT16
RW
0x0000 (0dec)
1C33:09
Maximum delay time
time between SYNC1-Event and Input Latch (in ns, only in DC-Mode)
UINT32
RO
0x00000000 (0dec)
1C33:0B
SM event missed counter
same as 1C32:11
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
same as 1C32:12
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
same as 1C32:13
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
same as 1C32:32
boolean
RO
0x00 (0dec)
Profile specific objects (0x6000-0xFFFF)
The profile specific objects have the same meaning for all EtherCAT Slaves which support the profile 5001.
Index 6001 DIG Diag Inputs Ch.1
Index | Name | Meaning | Data type | Flags | Default
6001:0 | DIG Diag Inputs Ch.1 |  | UINT8 | RO | 0x08 (8dec)
6001:01 | Diag Input 1 |  | boolean | RO | 0x00 (0dec)
6001:02 | Diag Input 2 |  | boolean | RO | 0x00 (0dec)
6001:03 | Diag Input 3 |  | boolean | RO | 0x00 (0dec)
6001:04 | Diag Input 4 |  | boolean | RO | 0x00 (0dec)
6001:05 | Diag Input 5 |  | boolean | RO | 0x00 (0dec)
6001:06 | Diag Input 6 |  | boolean | RO | 0x00 (0dec)
6001:07 | Diag Input 7 |  | boolean | RO | 0x00 (0dec)
6001:08 | Diag Input 8 |  | boolean | RO | 0x00 (0dec)
Index 6011 DIG Diag Inputs Ch.2
Index | Name | Meaning | Data type | Flags | Default
6011:0 | DIG Diag Inputs Ch.2 |  | UINT8 | RO | 0x08 (8dec)
6011:01 | Diag Input 1 |  | boolean | RO | 0x00 (0dec)
6011:02 | Diag Input 2 |  | boolean | RO | 0x00 (0dec)
6011:03 | Diag Input 3 |  | boolean | RO | 0x00 (0dec)
6011:04 | Diag Input 4 |  | boolean | RO | 0x00 (0dec)
6011:05 | Diag Input 5 |  | boolean | RO | 0x00 (0dec)
6011:06 | Diag Input 6 |  | boolean | RO | 0x00 (0dec)
6011:07 | Diag Input 7 |  | boolean | RO | 0x00 (0dec)
6011:08 | Diag Input 8 |  | boolean | RO | 0x00 (0dec)
Index 6021 DIG Diag Inputs Ch.3
Index | Name | Meaning | Data type | Flags | Default
6021:0 | DIG Diag Inputs Ch.3 |  | UINT8 | RO | 0x08 (8dec)
6021:01 | Diag Input 1 |  | boolean | RO | 0x00 (0dec)
6021:02 | Diag Input 2 |  | boolean | RO | 0x00 (0dec)
6021:03 | Diag Input 3 |  | boolean | RO | 0x00 (0dec)
6021:04 | Diag Input 4 |  | boolean | RO | 0x00 (0dec)
6021:05 | Diag Input 5 |  | boolean | RO | 0x00 (0dec)
6021:06 | Diag Input 6 |  | boolean | RO | 0x00 (0dec)
6021:07 | Diag Input 7 |  | boolean | RO | 0x00 (0dec)
6021:08 | Diag Input 8 |  | boolean | RO | 0x00 (0dec)
Index 7000 DIG Outputs Ch.1
Index | Name | Meaning | Data type | Flags | Default
7000:0 | DIG Outputs Ch.1 |  | UINT8 | RO | 0x08 (8dec)
7000:01 | Output 1 |  | boolean | RO | 0x00 (0dec)
7000:02 | Output 2 |  | boolean | RO | 0x00 (0dec)
7000:03 | Output 3 |  | boolean | RO | 0x00 (0dec)
7000:04 | Output 4 |  | boolean | RO | 0x00 (0dec)
7000:05 | Output 5 |  | boolean | RO | 0x00 (0dec)
7000:06 | Output 6 |  | boolean | RO | 0x00 (0dec)
7000:07 | Output 7 |  | boolean | RO | 0x00 (0dec)
7000:08 | Output 8 |  | boolean | RO | 0x00 (0dec)
Index 7010 DIG Outputs Ch.2
Index | Name | Meaning | Data type | Flags | Default
7010:0 | DIG Outputs Ch.2 |  | UINT8 | RO | 0x08 (8dec)
7010:01 | Output 1 |  | boolean | RO | 0x00 (0dec)
7010:02 | Output 2 |  | boolean | RO | 0x00 (0dec)
7010:03 | Output 3 |  | boolean | RO | 0x00 (0dec)
7010:04 | Output 4 |  | boolean | RO | 0x00 (0dec)
7010:05 | Output 5 |  | boolean | RO | 0x00 (0dec)
7010:06 | Output 6 |  | boolean | RO | 0x00 (0dec)
7010:07 | Output 7 |  | boolean | RO | 0x00 (0dec)
7010:08 | Output 8 |  | boolean | RO | 0x00 (0dec)
Index 7020 DIG Outputs Ch.3
Index | Name | Meaning | Data type | Flags | Default
7020:0 | DIG Outputs Ch.3 |  | UINT8 | RO | 0x08 (8dec)
7020:01 | Output 1 |  | boolean | RO | 0x00 (0dec)
7020:02 | Output 2 |  | boolean | RO | 0x00 (0dec)
7020:03 | Output 3 |  | boolean | RO | 0x00 (0dec)
7020:04 | Output 4 |  | boolean | RO | 0x00 (0dec)
7020:05 | Output 5 |  | boolean | RO | 0x00 (0dec)
7020:06 | Output 6 |  | boolean | RO | 0x00 (0dec)
7020:07 | Output 7 |  | boolean | RO | 0x00 (0dec)
7020:08 | Output 8 |  | boolean | RO | 0x00 (0dec)
Index F000 Modular device profile
Index | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | general information about the Modular Device Profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance between the objects of two channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | number of channels | UINT16 | RO | 0x0003 (3dec)
Index F008 Code word
Index | Name | Meaning | Data type | Flags | Default
F008:0 | Code word |  | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module list
Index | Name | Meaning | Data type | Flags | Default
F010:0 | Module list |  | UINT8 | RW | 0x03 (3dec)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x00000118 (280dec)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x00000118 (280dec)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x00000118 (280dec)
Index F600 DIG Inputs
Index | Name | Meaning | Data type | Flags | Default
F600:0 | DIG Inputs |  | UINT8 | RO | 0x10 (16dec)
F600:01 | Safe state active |  | boolean | RO | 0x00 (0dec)
F600:02 | Error channel 1 |  | boolean | RO | 0x00 (0dec)
F600:03 | Error channel 2 |  | boolean | RO | 0x00 (0dec)
F600:04 | Error channel 3 |  | boolean | RO | 0x00 (0dec)
F600:05 | Us Undervoltage |  | boolean | RO | 0x00 (0dec)
F600:06 | Up Undervoltage |  | boolean | RO | 0x00 (0dec)
F600:0E | Sync error |  | boolean | RO | 0x00 (0dec)
F600:10 | TxPDO Toggle |  | boolean | RO | 0x00 (0dec)
Index F700 DIG Outputs
Index | Name | Meaning | Data type | Flags | Default
F700:0 | DIG Outputs |  | UINT8 | RO | 0x02 (2dec)
F700:01 | Set safe state |  | boolean | RO | 0x00 (0dec)
F700:02 | Reset outputs |  | boolean | RO | 0x00 (0dec)
Index F800 DIG Settings
Index | Name | Meaning | Data type | Flags | Default
F800:0 | DIG Settings |  | UINT8 | RO | 0x11 (17dec)
F800:01 | Disable shut off |  | boolean | RW | 0x00 (0dec)
F800:11 | Switch off time |  | UINT16 | RW | 0x000A (10dec)
Also see about this
•
Configuration via TwinCAT
•
Configuration via TwinCAT


Restoring the delivery state

Commissioning/Configuration [image] Restoring the delivery state
Restoring the delivery state
To restore the delivery state for backup objects in ELxxxx terminals / EPxxxx- and EPPxxxx boxes, the CoE object Restore default parameters, SubIndex 001 can be selected in the TwinCAT System Manager (Config mode).
Selecting the Restore default parameters PDO
Double-click on SubIndex 001 to enter the Set Value dialog. Enter the value 1684107116 in field Dec or the value 0x64616F6C in field Hex and confirm with OK.
All backup objects are reset to the delivery state.
Entering a restore value in the Set Value dialog
Alternative restore value
In some older terminals / boxes the backup objects can be switched with an alternative restore value:
Decimal value: 1819238756
Hexadecimal value: 0x6C6F6164
An incorrect entry for the restore value has no effect.


Appendix

Appendix
Appendix
Additional information
•
General operating conditions
•
EtherCAT Box- / EtherCAT P Box - Accessories
•
Support and Service


General operating conditions

Appendix [image] General operating conditions
General operating conditions
Protection degrees (IP-Code)
The standard IEC 60529 (DIN EN 60529) defines the degrees of protection in different classes.
1. Number: dust protection and touch guard | Definition
0 | Non-protected
1 | Protected against access to hazardous parts with the back of a hand. Protected against solid foreign objects of Ø 50 mm
2 | Protected against access to hazardous parts with a finger. Protected against solid foreign objects of Ø 12.5 mm.
3 | Protected against access to hazardous parts with a tool. Protected against solid foreign objects Ø 2.5 mm.
4 | Protected against access to hazardous parts with a wire. Protected against solid foreign objects Ø 1 mm.
5 | Protected against access to hazardous parts with a wire. Dust-protected. Intrusion of dust is not totally prevented, but dust shall not penetrate in a quantity to interfere with satisfactory operation of the device or to impair safety.
6 | Protected against access to hazardous parts with a wire. Dust-tight. No intrusion of dust.
2. Number: water* protection | Definition
0 | Non-protected
1 | Protected against water drops
2 | Protected against water drops when enclosure tilted up to 15°.
3 | Protected against spraying water. Water sprayed at an angle up to 60° on either side of the vertical shall have no harmful effects.
4 | Protected against splashing water. Water splashed against the disclosure from any direction shall have no harmful effects
5 | Protected against water jets
6 | Protected against powerful water jets
7 | Protected against the effects of temporary immersion in water. Intrusion of water in quantities causing harmful effects shall not be possible when the enclosure is temporarily immersed in water for 30 min. in 1 m depth.
*) These protection classes define only protection against water!
Chemical Resistance
The Resistance relates to the Housing of the IP 67 modules and the used metal parts. In the table below you will find some typical resistance.
Character | Resistance
Steam | at temperatures >100°C: not resistant
Sodium base liquor (ph-Value > 12) | at room temperature: resistant > 40°C: not resistant
Acetic acid | not resistant
Argon (technical clean) | resistant
Key
▪
resistant: Lifetime several months
▪
non inherently resistant: Lifetime several weeks
▪
not resistant: Lifetime several hours resp. early decomposition


EtherCAT Box- / EtherCAT P Box - Accessories

Appendix [image] EtherCAT Box- / EtherCAT P Box - Accessories
EtherCAT Box- / EtherCAT P Box - Accessories
Fixing
Ordering information | Description
ZS5300-0001 | Mounting rail (500 mm x 129 mm)
Marking material, plugs
Ordering information | Description
ZS5000-0000 | Fieldbus Box set M8 (contact labels, plugs)
ZS5000-0002 | Fieldbus Box set M12 (contact labels, plugs)
ZS5000-0010 | plugs M8, IP67 (50 pieces)
ZS5000-0020 | plugs M12, IP67 (50 pieces)
ZS5100-0000 | marking labels, not printed, 4 stripes at 10 pieces
ZS5100-xxxx | printed marking labels, on request
Tools
Ordering information | Description
ZB8800 | torque wrench for M8 cables with knurl, incl. ratchet
ZB8800-0001 | M12 ratchet for torque wrench ZB8800
ZB8800-0002 | M8 ratchet (field assembly) for torque wrench ZB8800
ZB8801-0000 | torque wrench for hexagonal plugs, adjustable
ZB8801-0001 | torque cable key, M8/wrench size 9, for torque wrench ZB8801-0000
ZB8801-0002 | torque cable key, M12/wrench size 13, for torque wrench ZB8801-0000
ZB8801-0003 | torque cable key, M12 field assembly/wrench size 13, for torque wrench ZB8801-0000
Further accessories
Further accessories may be found at the price list for Beckhoff fieldbus components and at the internet under https://www.beckhoff.com


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com