EP1xxx-xxxx - EtherCAT Box modules with digital inputs
Home
Web_Title EP 96dpi


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
3.0
▪
Front page updated
▪
Scope of supply added
2.8
▪
EP18x9-0042: Technical data and connections updated
2.7
▪
EP1809-0042 added
▪
EP1816-0003 added
▪
EP1819-0021 added
▪
EP1859-0042 added
2.6
▪
Signal connection of EP1816-3008 corrected
▪
Protection enclosure BG2000-0010 added
▪
EP1098-0001 introduction: 2-wire connection corrected
▪
EP1816-1008 added
2.5.0
▪
EP1816-3008 added
2.4.1
▪
EP1111-0000 – technical data updated
2.4.0
▪
Nut torques for connectors updated
2.3.0
▪
Torque wrench diagram updated
▪
Power connection updated
2.2.0
▪
EP1008-0022 added
▪
EP1819-0021 added
▪
Cabling adjusted
2.1.0
▪
Nut torques for connectors extended
2.0.0
▪
Migration
▪
Technical data updated
1.4.0
▪
Accessories chapter added
▪
Chapter on Nut torques for connectors updated
▪
Chapter on EtherCAT connection updated
▪
Chapter on BG2000-0000 - protective housing for EtherCAT Box updated
1.3.0
▪
EP1111-0000 added
▪
EP1098-0001 and EP1098-0002 added
▪
EP1809-0021, EP1809-0022 and EP1819-0022 updated
1.2.0
▪
ATEX notes added
▪
Extended temperature range for activated modules documented
▪
EP1809-0021, EP1809-0022 and EP1819-0022 added
▪
Description of the power connection updated
▪
Overview of EtherCAT cables extended
1.1.0
▪
Technical data: Current consumption values amended
▪
Nut torques for connectors added
1.0.0
▪
Process data description extended
0.7
▪
Description of status LEDs added
▪
Signal connection extended
▪
Explanation of the serial number adapted to the new standard
0.6
▪
Signal connection extended
0.5
▪
First preliminary version
Firmware and hardware versions
This documentation refers to the firmware and hardware version that was applicable at the time the documentation was written.
The module features are continuously improved and developed further. Modules having earlier production statuses cannot have the same properties as modules with the latest status. However, existing properties are retained and are not changed, so that older modules can always be replaced with new ones.
The firmware and hardware version (delivery state) can be found in the batch number (D-number) printed on the side of the EtherCAT Box.
Syntax of the batch number (D-number)
D: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with D no. 29 10 02 01:
29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01
Further information on this topic: Version identification of EtherCAT devices.


EtherCAT Box - Introduction

EtherCAT Box - Introduction
EtherCAT Box - Introduction
The EtherCAT system has been extended with EtherCAT Box modules with protection class IP 67. Through the integrated EtherCAT interface the modules can be connected directly to an EtherCAT network without an additional Coupler Box. The high-performance of EtherCAT is thus maintained into each module.
The extremely low dimensions of only 126 x 30 x 26.5 mm (h x w x d) are identical to those of the Fieldbus Box extension modules. They are thus particularly suitable for use where space is at a premium. The small mass of the EtherCAT modules facilitates applications with mobile I/O interface (e.g. on a robot arm). The EtherCAT connection is established via screened M8 connectors.
EtherCAT Box Modules within an EtherCAT network
The robust design of the EtherCAT Box modules enables them to be used directly at the machine. Control cabinets and terminal boxes are now no longer required. The modules are fully sealed and therefore ideally prepared for wet, dirty or dusty conditions.
Pre-assembled cables significantly simplify EtherCAT and signal wiring. Very few wiring errors are made, so that commissioning is optimized. In addition to pre-assembled EtherCAT, power and sensor cables, field-configurable connectors and cables are available for maximum flexibility. Depending on the application, the sensors and actuators are connected through M8 or M12 connectors.
The EtherCAT modules cover the typical range of requirements for I/O signals with protection class IP67:
▪
digital inputs with different filters (3.0 ms or 10 μs)
▪
digital outputs with 0.5 or 2 A output current
▪
analog inputs and outputs with 16 bit resolution
▪
Thermocouple and RTD inputs
▪
Stepper motor modules
XFC (eXtreme Fast Control Technology) modules, including inputs with time stamp, are also available.
EtherCAT Box with M8 connections for sensors/actuators
EtherCAT Box with M12 connections for sensors/actuators
Basic EtherCAT documentation
You will find a detailed description of the EtherCAT system in the Basic System Documentation for EtherCAT, which is available for download from our website (www.beckhoff.com) under Downloads.
EtherCAT XML Device Description
You will find XML files (XML Device Description Files) for Beckhoff EtherCAT modules on our website (www.beckhoff.com) under Downloads, in the Configuration Files area.


Product overview

Product overview
Product overview
Additional information
•
Module overview
•
EP1008, EP1018
•
EP1098-0001
•
EP1111-0000
•
EP1258-000x
•
EP1809, EP1819
•
EP1809-0042
•
EP1816-0003
•
EP1816-x008
•
EP1859-0042


Module overview

Product overview [image] Module overview
Module overview
Module | Number of inputs | Filter | Signal connection | EtherCAT connection | Comment
EP1008-0001 | 8 | 3.0 ms | 8x M8 | M8 |
EP1008-0002 | 8 | 3.0 ms | 4x M12 | M8 |
EP1008-0022 | 8 | 3,0 ms | 8x M12 | M8 |
EP1018-0001 | 8 | 10 µs | 8x M8 | M8 |
EP1018-0002 | 8 | 10 µs | 4x M12 | M8 |
EP1098-0001 | 8 | 10 µs | 8x M8 | M8 | ground switching
EP1111-0000 | 3 ID switches | - | - | M8 | for identification of EtherCAT groups
EP1258-0001 | 8 | 10 µs | 8x M8 | M8 | 2 inputs with time stamp
EP1258-0002 | 8 | 10 µs | 4x M12 | M8 | 2 inputs with time stamp
EP1809-0021 | 16 | 3.0 ms | 16x M8 | M8 |
EP1809-0022 | 16 | 3.0 ms | 8x M12 | M8 |
EP1809-0042 | 16 | 3.0 ms | 8x M12 | M12 |
EP1816-0003 | 16 | 10 µs | 2x ZS2001 | M8 | Pluggable spring-loaded terminal
EP1816-0008 | 16 | 10 µs | 1x D-Sub 25 | M8 |
EP1816-1008 | 16 | 10 µs | 1x D-Sub 25 | M8 | Undervoltage detection
EP1816-3008 | 16 | 10 µs | 1x D-Sub 25 | M8 | Undervoltage detection, accelerometers
EP1819-0021 | 16 | 10 µs | 16x M8 | M8 |
EP1819-0022 | 16 | 10 µs | 8x M12 | M8 |
EP1859-0042 | 8 | 3.0 ms | 8x M12 | M12 | 8 digital outputs


EP1008, EP1018

Product overview [image] EP1008, EP1018
EP1008, EP1018
Additional information
•
EP1008, EP1018 - Introduction
•
EP1008, EP1018 - Technical Data
•
EP1008, EP1018 - Scope of supply
•
EP1008-00xx - Process image


EP1008, EP1018 - Introduction

Product overview [image] EP1008, EP1018 [image] EP1008, EP1018 - Introduction
EP1008, EP1018 - Introduction
EP1008-0001, EP1008-0002, EP1018-0001, EP1018-0002
EP1008-0022 inkl FE
EP1008-0022
8 digital inputs 24 VDC
The EP1008 and EP1018 EtherCAT Box modules with digital inputs acquire binary control signals from the process level, and transfer them, electrically isolated, to the controller.
The status of the signal is displayed by light emitting diodes; the signal connection is made optionally through M8 connectors (EP1008-0001, EP1018-0001) or M12 connectors (EP1008-0002, EP1018-0002, EP1008-0022). These versions have input filters of different speeds.
The sensors are supplied from the control voltage Us. The load voltage Up is not used in the input module, but may be connected in order to be relayed downstream.
Quick links
EP1008-0001:
Technical data
Process image
Dimensions
Signal connection
EP1008-0002:
Technical data
Process image
Dimensions
Signal connection
EP1008-0022:
Technical data
Process image
Dimensions
Functional earth (FE)
Signal connection
EP1018-0001:
Technical data
Process image
Dimensions
Signal connection
EP1018-0002:


EP1008, EP1018 - Technical Data

Product overview [image] EP1008, EP1018 [image] EP1008, EP1018 - Technical Data
EP1008, EP1018 - Technical Data
Technical data | EP1008-0001 | EP1008-0002 | EP1008-0022 | EP1018-0001 | EP1018-0002
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Number of inputs | 8
Input connections | M8 | M12 | M12 | M8 | M12
Nominal input voltage | 24 VDC (-15%/+20%)
Input filter | 3,0 ms | 3,0 ms | 3,0 ms | 10 µs | 10 µs
"0" signal voltage | -3...+5 V (EN 61131-2, Type 3)
"1" signal voltage | +11...+30 V (EN 61131-2, Type 3)
Input current | typically 3 mA (EN 61131-2, Type 3)
Module electronic supply | derived from control voltage Us
Module electronic current consumption | typically 120 mA
Sensor supply | derived from control voltage, Us
Sensor current consumption | max. 0.5 A total, short-circuit proof
Power supply connection | Feed: 1 x M8 plug, 4-pin Onward connection: 1 x M8 socket, 4-pin
Process image | 8 input bits
Electrical isolation Fieldbus GNDS / GNDP | 500 V no | 500 V no | 500 V yes | 500 V no | 500 V no
Permissible ambient temperature during operation | -25 . +60°C 0 .. +55°C according to cURus 0 .. +55°C according to ATEX
Permissible ambient temperature during storage | -40 .. +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable
Approvals | CE, cURus, ATEX


EP1008, EP1018 - Scope of supply

Product overview [image] EP1008, EP1018 [image] EP1008, EP1018 - Scope of supply
EP1008, EP1018 - Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EtherCAT Box
▪
2x protective cap for EtherCAT socket, M8, green (pre-assembled)
▪
1x protective cap for supply voltage input, M8, transparent (pre-assembled)
▪
1x protective cap for supply voltage output, M8, black (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


EP1008-00xx - Process image

Product overview [image] EP1008, EP1018 [image] EP1008-00xx - Process image
EP1008-00xx - Process image
Channel 1 to Channel 8
You will find the 8 digital inputs to the module (here using the EP1008-0001 as an example) under Channel 1 to Channel 8.
EP1008-00xx, process image


EP1098-0001

Product overview [image] EP1098-0001
EP1098-0001
Additional information
•
EP1098-0001 - Introduction
•
EP1098-0001 - Technical Data
•
EP1098-0001 - Scope of supply
•
EP1098-0001 - Process image


EP1098-0001 - Introduction

Product overview [image] EP1098-0001 [image] EP1098-0001 - Introduction
EP1098-0001 - Introduction
EP1098-0001
8 digital inputs, 24 VDC, ground switching
The EP1098-0001 EtherCAT Box with digital inputs acquires the binary control signals from the process level and transmits them, in an electrically isolated form, to the controller.
The status of the signal is displayed by light emitting diodes. The signal connection is made through M8 connectors (EP1098 -0001) or M12 connectors (EP1098 -0002).
The sensors are supplied from the control voltage Us. The load voltage Up is not used in the input module, but may be connected in order to be relayed downstream.
Quick links


EP1098-0001 - Technical Data

Product overview [image] EP1098-0001 [image] EP1098-0001 - Technical Data
EP1098-0001 - Technical Data
Technical data | EP1098-0001
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Number of inputs | 8 (negative switching)
Input connections | M8
Nominal input voltage | 24 VDC (-15%/+20%)
Input filter | 10 µs
"0" signal voltage | 11…30 V
"1" signal voltage | 0…7 V
Input current | typically 2.5 mA (EN 61131-2, Type 3)
Module electronic supply | derived from control voltage Us
Module electronic current consumption | typically 120 mA
Sensor supply | derived from control voltage, Us
Sensor current consumption | max. 0.5 A total, short-circuit proof
Power supply connection | Feed: 1 x M8 plug, 4-pin Onward connection: 1 x M8 socket, 4-pin
Process image | 8 input bits
Electrical isolation Fieldbus GNDS / GNDP | 500 V no
Permissible ambient temperature during operation | -25 .. +60°C -25 .. +55°C according to cURus
Permissible ambient temperature during storage | -40 .. +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable
Approvals | CE, cURus


EP1098-0001 - Scope of supply

Product overview [image] EP1098-0001 [image] EP1098-0001 - Scope of supply
EP1098-0001 - Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EtherCAT Box EP1098-0001
▪
2x protective cap for EtherCAT socket, M8, green (pre-assembled)
▪
1x protective cap for supply voltage input, M8, transparent (pre-assembled)
▪
1x protective cap for supply voltage output, M8, black (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


EP1098-0001 - Process image

Product overview [image] EP1098-0001 [image] EP1098-0001 - Process image
EP1098-0001 - Process image
Channel 1 to Channel 8
You will find the 8 digital inputs to the module (here using the EP1098-0001 as an example) under Channel 1 to Channel 8.
EP1098-0001, Process image


EP1111-0000

Product overview [image] EP1111-0000
EP1111-0000
Additional information
•
EP1111-0000 - Introduction
•
EP1111-0000 - Technical Data
•
EP1111-0000 - Scope of supply
•
EP1111-0000 - Process image


EP1111-0000 - Introduction

Product overview [image] EP1111-0000 [image] EP1111-0000 - Introduction
EP1111-0000 - Introduction
EP1111-0000
EtherCAT Box with ID switch
The EP1111-0000 EtherCAT Box has three decimal ID switches, with which a group of EtherCAT components can be assigned an ID. This group can be present in any position in the EtherCAT network, as a result of which variable topologies can be realized in a simple manner.
The EtherCAT connection is established via shielded M8 connectors with direct display of link and activity status. The Run LED indicates the status of the EP1111.
Quick links
HotConnect in the EtherCAT system documentation.
Technical data
Process image
Dimensions
Setting the Hot Connect ID


EP1111-0000 - Technical Data

Product overview [image] EP1111-0000 [image] EP1111-0000 - Technical Data
EP1111-0000 - Technical Data
Technical data | EP1111-0000
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Task within EtherCAT system | identification of any EtherCAT group in the EtherCAT network
Number of ID switches | 3
Positions per ID switch | 10
Number of different IDs | 999
Module electronic supply | derived from control voltage Us
Module electronic current consumption | typically 120 mA
Power supply connection | Feed: 1 x M8 plug, 4-pin Onward connection: 1 x M8 socket, 4-pin
Process image | 2 byte input data
Electrical isolation Fieldbus GNDS / GNDP | 500 V yes
Weight | app. 165 g
Permissible ambient temperature during operation | -25 .. +60°C -25 .. +55°C according to cURus
Permissible ambient temperature during storage | -40 .. +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable
Approvals | CE, cURus


EP1111-0000 - Scope of supply

Product overview [image] EP1111-0000 [image] EP1111-0000 - Scope of supply
EP1111-0000 - Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EtherCAT Box EP1111-0000
▪
2x protective cap for EtherCAT socket, M8, green (pre-assembled)
▪
1x protective cap for supply voltage input, M8, transparent (pre-assembled)
▪
1x protective cap for supply voltage output, M8, black (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


EP1111-0000 - Process image

Product overview [image] EP1111-0000 [image] EP1111-0000 - Process image
EP1111-0000 - Process image
ID inputs
You will find input data of the ID switches under under ID Inputs.
EP1111-0000, ID inputs


EP1258-000x

Product overview [image] EP1258-000x
EP1258-000x
Additional information
•
EP1258-000x - Introduction
•
EP1258-000x - Technical Data
•
EP1258-000x - Scope of supply
•
EP1258-0001 - Process image


EP1258-000x - Introduction

Product overview [image] EP1258-000x [image] EP1258-000x - Introduction
EP1258-000x - Introduction
EP1258-0001, EP1258-0002
8 digital inputs 24 VDC (two channels with time stamp)
The EP1258 EtherCAT Box with digital inputs acquires fast binary control signals from the process level and transmits them, electrically isolated, to the controller.
The status of the signal is displayed by light emitting diodes; the signal connection is made optionally through M8 connectors (EP1258-0001) or M12 connectors (EP1258-0002). Both modules have 10 μs input filters.
The sensors are supplied from the control voltage US. The peripheral voltage UP is not used in the input module, but may be connected in order to be relayed downstream.
Distributed Clocks
Channels 0 and 1 are assigned a time stamp that shows the time of the last edge change with a resolution of 1 ns. This technology enables signals to be traced exactly over time and synchronized with the clocks distributed across the system. With this technology, machine-wide parallel hardware wiring of digital inputs or encoder signals for synchronization purposes is often no longer required. As a result, equally timed reactions, independent of the bus cycle time, are to a large extent possible. Distributed Clocks in the EtherCAT system documentation.
Quick links
EP1258-0001
Technical data
Dimensions
Signal connection
EP1258-0002


EP1258-000x - Technical Data

Product overview [image] EP1258-000x [image] EP1258-000x - Technical Data
EP1258-000x - Technical Data
Technical data | EP1258-0001 | EP1258-0002
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Number of inputs | 8
Input connections | M8 | M12
Nominal input voltage | 24 VDC (-15%/+20%)
Input filter | 10 µs
"0" signal voltage | -3...+5 V (similar to EN 61131-2, Type 3)
"1" signal voltage | +11...+30 V (similar to EN 61131-2, Type 3)
Input current | typically 3 mA (similar to EN 61131-2, Type 3)
Module electronic supply | derived from control voltage Us
Module electronic current consumption | typically 120 mA
Sensor supply | derived from control voltage Us
Sensor current consumption | max. 0.5 A total, short-circuit proof
Power supply connection | Feed: 1 x M8 plug, 4-pin Onward connection: 1 x M8 socket, 4-pin
Resolution time stamp | 1 ns (Channel 0/1)
Precision of the time stamp | 10 ns (+ input delay) (Channel 0/1)
Precision of the distributed clocks | < 100 ns (Channel 0/1)
Process image | 8 input bits , 36 byte time stamp
Electrical isolation Fieldbus GNDS / GNDP | 500 V no
Permissible ambient temperature during operation | -25 .. +60°C -25 .. +55°C according to cURus 0 .. +55°C according to ATEX
Permissible ambient temperature during storage | -40°C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable
Approvals | CE, cURus, ATEX


EP1258-000x - Scope of supply

Product overview [image] EP1258-000x [image] EP1258-000x - Scope of supply
EP1258-000x - Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EtherCAT Box EP1258-000x
▪
2x protective cap for EtherCAT socket, M8, green (pre-assembled)
▪
1x protective cap for supply voltage input, M8, transparent (pre-assembled)
▪
1x protective cap for supply voltage output, M8, black (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


EP1258-0001 - Process image

Product overview [image] EP1258-000x [image] EP1258-0001 - Process image
EP1258-0001 - Process image
Channel 1 to Channel 8
You will find the 8 digital inputs to the module (here using the EP1258-0001 as an example) under Channel 1 to Channel 8.
EP1258-0001, Process image


EP1809, EP1819

Product overview [image] EP1809, EP1819
EP1809, EP1819
Additional information
•
EP1809-0021, EP1819-0021 - Introduction
•
EP1809-0022, EP1819-0022 - Introduction
•
EP1809, EP1819 - Technical data
•
EP1809, EP1819 - Scope of supply
•
EP1809-0021 - Process image


EP1809-0021, EP1819-0021 - Introduction

Product overview [image] EP1809, EP1819 [image] EP1809-0021, EP1819-0021 - Introduction
EP1809-0021, EP1819-0021 - Introduction
EP18x9-0021 inkl FE
EP1809-0021, EP1819-0021
16 digital inputs 24 VDC
The EtherCAT modules EP1809-0021 and EP1819-0021 with digital inputs acquire binary control signals from the process level and transmit them, in an electrically isolated form, to the controller. The state of the signals is indicated by light emitting diodes. The signals are connected via M8 connectors.
The sensors are supplied from the box supply voltage US. The auxiliary voltage UP is not used in the input module, but may be connected in order to be relayed downstream.
Quick links


EP1809-0022, EP1819-0022 - Introduction

Product overview [image] EP1809, EP1819 [image] EP1809-0022, EP1819-0022 - Introduction
EP1809-0022, EP1819-0022 - Introduction
EP18x9-0022 inkl FE
EP1809-0022, EP1819-0022
16 digital inputs 24 VDC
The EP1809-0022 and EP1819-0022 modules with digital inputs acquire the binary control signals from the process level and transmit them, in an electrically isolated form, to the controller. The state of the signals is indicated by light emitting diodes. The signals are connected via M12 connectors. These versions are distinguished by input filters of different speeds.
The sensors are supplied from the box supply voltage US. The auxiliary voltage UP is not used in the input module, but may be connected in order to be relayed downstream.
Quick links


EP1809, EP1819 - Technical data

Product overview [image] EP1809, EP1819 [image] EP1809, EP1819 - Technical data
EP1809, EP1819 - Technical data
Technical data | EP1809-0021 | EP1809-0022 | EP1819-0021 | EP1819-0022
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Number of inputs | 16
Input connections | M8 | M12 | M8 | M12
Nominal input voltage | 24 VDC (-15%/+20%)
Input filter | 3 ms | 3 ms | 10 µs | 10 µs
"0" signal voltage | -3...+5 V (similar to EN 61131-2, Type 3)
"1" signal voltage | +11...+30 V (similar to EN 61131-2, Type 3)
Input current | typically 3 mA (similar to EN 61131-2, Type 3)
Module electronic supply | derived from control voltage Us
Module electronic current consumption | typically 130 mA (without sensor current)
Sensor supply | derived from control voltage Us
Sensor current consumption | max. 0.5 A total, short-circuit proof
Power supply connection | Feed: 1 x M8 plug, 4-pin Onward connection: 1 x M8 socket, 4-pin
Process image | 16 input bits
Electrical isolation Fieldbus GNDS / GNDP | 500 V yes
Permissible ambient temperature during operation | -25 .. +60°C -25 .. +55°C according to cURus
Permissible ambient temperature during storage | -40 .. +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable
Approvals | CE, cURus


EP1809, EP1819 - Scope of supply

Product overview [image] EP1809, EP1819 [image] EP1809, EP1819 - Scope of supply
EP1809, EP1819 - Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EtherCAT Box
▪
2x protective cap for EtherCAT socket, M8, green (pre-assembled)
▪
1x protective cap for supply voltage input, M8, transparent (pre-assembled)
▪
1x protective cap for supply voltage output, M8, black (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


EP1809-0021 - Process image

Product overview [image] EP1809, EP1819 [image] EP1809-0021 - Process image
EP1809-0021 - Process image
Channel 1 to Channel 16
You will find the 16 digital inputs to the module (here using the EP1809-0021 as an example) under Channel 1 to Channel 16.
EP1809-0021, Process image


EP1809-0042

Product overview [image] EP1809-0042
EP1809-0042
Additional information
•
EP1809-0042 - Introduction
•
EP1809-0042 - Technical data
•
EP1809-0042 - Scope of supply
•
EP1809-0042 - Process image


EP1809-0042 - Introduction

Product overview [image] EP1809-0042 [image] EP1809-0042 - Introduction
EP1809-0042 - Introduction
EP1809-0042 inkl FE
EP1809-0042
16-channel digital input 24 V DC, 3.0 ms
The EP1809-0042 EtherCAT Box with digital inputs acquires the binary control signals from the process level and transmits them, in an electrically isolated form, to the controller. The state of the signals is indicated by light emitting diodes. The signals are connected via M12 screw type connectors.
The sensors are supplied from the box supply voltage US. The auxiliary voltage UP is not used in the input module, but may be connected in order to be relayed downstream.
Quick links


EP1809-0042 - Technical data

Product overview [image] EP1809-0042 [image] EP1809-0042 - Technical data
EP1809-0042 - Technical data
All values are typical values over the entire temperature range, unless stated otherwise.
Technical data | EP1809-0042
Fieldbus | EtherCAT
Fieldbus connection | 2x M12 socket, D-coded, 4-pin, green
Number of inputs | 16
Input connections | 8x M12 socket
Nominal input voltage | 24 VDC (-15%/+20%)
Input filter | 3 ms
Signal voltage "0" | -3...+5 V (similar to EN 61131-2, type 3)
Signal voltage "1" | +11...+30 V (similar to EN 61131-2, Type 3)
Input current | 6 mA (similar to EN 61131-2, type 3)
Supply of the module electronics | from the control voltage US
Current consumption of the module electronics | 130 mA
Sensor supply | from the control voltage US max. 0.5 A in total, short-circuit proof
Power supply connection | Input: 1 x 7/8" plug, 5-pin Downstream connection: 1 x 7/8" socket, 5-pin max. 16 A per pin
Process image | 16 input bits
Electrical isolation Fieldbus GNDS / GNDP | 500 V yes
Permissible ambient temperature during operation | -25…+60°C -25…+55 °C conforms to cURus
Permissible ambient temperature during storage | -40…+85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable
Weight | approx. 440 g
Approvals | CE, cURus in preparation


EP1809-0042 - Scope of supply

Product overview [image] EP1809-0042 [image] EP1809-0042 - Scope of supply
EP1809-0042 - Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EtherCAT Box EP1809-0042
▪
2x protective cap for EtherCAT socket, M12 (pre-assembled)
▪
1x Protective cap for supply voltage output, 7/8”, black (pre-fitted)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


EP1809-0042 - Process image

Product overview [image] EP1809-0042 [image] EP1809-0042 - Process image
EP1809-0042 - Process image
The process image contains a process data object for each digital input.
The name of each process data object contains the name of the socket and the pin number of the corresponding digital input.
EP1809-0042 - Process image


EP1816-0003

Product overview [image] EP1816-0003
EP1816-0003
Additional information
•
EP1816-x008 - Introduction
•
EP1816-0003 - Technical data
•
EP1816-0003 - Scope of supply
•
EP1816-0003 - Process image


EP1816-x008 - Introduction

Product overview [image] EP1816-0003 [image] EP1816-x008 - Introduction
EP1816-x008 - Introduction
EP1816-0003
EP1816-0003 | 16-channel digital input 24 V DC
The EP1816-0003 EtherCAT Box with digital inputs acquires the binary control signals from the process level and transmits them, in an electrically isolated form, to the controller. The state of the signals is indicated by light emitting diodes. For the signal connection connectors with a spring-loaded system are used, optionally available with 1 or 3 pins. The module is supplied without connectors.
The sensors are supplied from the box supply voltage US. The auxiliary voltage UP is not used in the input module, but may be connected in order to be relayed downstream.
Quick links


EP1816-0003 - Technical data

Product overview [image] EP1816-0003 [image] EP1816-0003 - Technical data
EP1816-0003 - Technical data
Technical data | EP1816-0003
Fieldbus | EtherCAT
Fieldbus connection | 2x M8 socket, 4-pin, green
Distributed clocks | yes
Number of inputs | 16
Input connections | 2x pluggable spring-loaded terminals ZS2001 (not included in the scope of delivery)
Nominal input voltage | 24 VDC (-15%/+20%)
Input filter | 10 µs
Signal voltage "0" | -3...+5 V (EN 61131-2, type 3)
Signal voltage "1" | +11...+30 V (EN 61131-2, type 3)
Input current | typically 3 mA (EN 61131-2, type 3)
Supply of the module electronics | from the control voltage Us
Current consumption of the module electronics | typically 120 mA
Sensor supply | from the control voltage Us
Sensor current consumption | max. 0.5 A, short-circuit proof overall
Power supply connection | Power supply: 1 x M8 plug, 4-pin Downstream connection: 1 x M8 socket, 4-pin
Electrical isolation Fieldbus GNDS / GNDP | 500 V no
Ambient temperature during operation | -25 .. +60°C -25 .. +55°C according to cURus
Ambient temperature during storage | -40 .. +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (according to EN 60529)
Installation position | variable
Approvals | CE, cURus


EP1816-0003 - Scope of supply

Product overview [image] EP1816-0003 [image] EP1816-0003 - Scope of supply
EP1816-0003 - Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EtherCAT Box EP1816-0003
▪
2x protective cap for EtherCAT socket, M8, green (pre-assembled)
▪
1x protective cap for supply voltage input, M8, transparent (pre-assembled)
▪
1x protective cap for supply voltage output, M8, black (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


EP1816-0003 - Process image

Product overview [image] EP1816-0003 [image] EP1816-0003 - Process image
EP1816-0003 - Process image
EP1816-0003 Prozessabbild gesamt
EP1816-0003 Process image
DIG Inputs Channel n
EP1816-0003 Prozessabbild DIG Inputs Channel 1
EP1816-0003 Prozessabbild DIG Inputs Channel 2
▪
TC3 InputVariable Symbol Input x
Digital inputs.
▪
TC3 InputVariable Symbol Sync error
This bit is only relevant in Distributed Clocks mode.
It is TRUE if a synchronization error occurred during the elapsed EtherCAT cycle.
▪
TC3 InputVariable Symbol TxPDO Toggle
This bit is inverted each time the digital inputs are updated.


EP1816-x008

Product overview [image] EP1816-x008
EP1816-x008
Additional information
•
EP1816-x008 - Introduction
•
EP1816-x008 - Technical data
•
EP1816-000x - Scope of supply
•
EP1816-0008 - Process image
•
EP1816-1008 – Process image
•
EP1816-3008 - Process image


EP1816-x008 - Introduction

Product overview [image] EP1816-x008 [image] EP1816-x008 - Introduction
EP1816-x008 - Introduction
EP1816-x008
EP1816-x008 | 16-channel digital input
The EP1816-x008 EtherCAT Box with digital inputs acquires the binary control signals from the process level and transmits them, in an electrically isolated form, to the controller. The state of the signals is indicated by light emitting diodes. The signals are connected via 25-pin D-sub socket.
The sensors are supplied from the box supply voltage US. The auxiliary voltage UP is not used in the input module, but may be connected in order to be relayed downstream.
EP1816-3008 has two internal 3-axis accelerometers with 16 bits and a selectable resolution of ±2 g, ±4 g, ±8 g and ±16 g. The sampling frequency is 1 Hz to 5 KHz. Possible applications include the recording of vibrations and shocks/oscillations, and furthermore inclination measurements in all three axes.
Quick links


EP1816-x008 - Technical data

Product overview [image] EP1816-x008 [image] EP1816-x008 - Technical data
EP1816-x008 - Technical data
Technical data | EP1816-0008 | EP1816-1008 | EP1816-3008
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Number of inputs | 16
Input connections | 25-pin Sub-D socket
Nominal input voltage | 24 VDC (-15%/+20%)
Input filter | 10 µs
"0" Signal voltage | -3...+5 V (EN 61131-2, Typ 3)
"1" Signal voltage | +11...+30 V (EN 61131-2, Typ 3)
Input current | typically 3 mA (EN 61131-2, Typ 3)
Minimum cycle time | - | - | > 500 µs
Diagnostics | - | Undervoltage detection: < 18 VDC for Us and Up
Supply of the module circuitry | From the control voltage Us
Current consumption of the module circuitry | typically 120 mA
Sensor supply | From the control voltage Us
Current consumption of the sensors | max. 0.5 A, short-circuit-proof overall
Power supply connection | Power supply: 1 x M8 plug, 4-pin Onward connection: 1 x M8 socket, 4-pin
Electrical isolation Fieldbus GNDS / GNDP | 500 V no | 500 V yes
Ambient temperature during operation | -25 .. +60°C -25 .. +55°C according to cURus
Ambient temperature during storage | -40°C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (according to EN 60529)
Installation position | variable
Technical approvals | CE, cURus
Accelerometers (EP1816-3008)
Technical data | Accelerometers
Sensor type | Two 3-axis sensors / offset by 90°
Resolution | 16 bit raw data; 1 mg / LSB
Measuring range | ±2g/±4g/±8g/±16g configurable
Special features | Self-test
Sampling rate | 1 Hz to 5 kHz
Maximum transfer rate
The EP1816-3008 reads sensors with sampling rates between 1 Hz and 5 kHz. Since the smallest cycle time is limited to 500 μs due to the internal processing, the resulting maximum transfer rate is 2.5 kHz


EP1816-000x - Scope of supply

Product overview [image] EP1816-x008 [image] EP1816-000x - Scope of supply
EP1816-000x - Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EtherCAT Box EP1816-000x
▪
2x protective cap for EtherCAT socket, M8, green (pre-assembled)
▪
1x protective cap for supply voltage input, M8, transparent (pre-assembled)
▪
1x protective cap for supply voltage output, M8, black (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


EP1816-0008 - Process image

Product overview [image] EP1816-x008 [image] EP1816-0008 - Process image
EP1816-0008 - Process image
EP1816-0008 Prozessabbild gesamt
EP1816-0008 Process image
DIG Inputs Channel 1
You will find the first 8 digital inputs of the module under DIG Inputs Channel 1.
EP1816-x008 Prozessabbild DIG Inputs Channel 1
EP1816-0008 process image, DIG Inputs Channel 1
DIG Inputs Channel 2
You will find the second 8 digital inputs of the module under DIG Inputs Channel 2.
EP1816-x008 Prozessabbild DIG Inputs Channel 2
EP1816-0008 process image, DIG Inputs Channel 2


EP1816-1008 – Process image

Product overview [image] EP1816-x008 [image] EP1816-1008 – Process image
EP1816-1008 – Process image
EP1816-1008 Prozessabbild gesamt
EP1816-1008 Process image
DIG Inputs Channel 1
You will find the first 8 digital inputs of the module under DIG Inputs Channel 1.
EP1816-x008 Prozessabbild DIG Inputs Channel 1
EP1816-1008 process image, DIG Inputs Channel 1
DIG Inputs Channel 2
You will find the second 8 digital inputs of the module under DIG Inputs Channel 2.
EP1816-x008 Prozessabbild DIG Inputs Channel 2
EP1816-1008 process image, DIG Inputs Channel 2
DIG Inputs Device
The status bits can be found under DIG Inputs Device.
EP1816-1008,-3008 Prozessabbild DIG Inputs Device
EP1816-1008 process image, DIG Inputs Device


EP1816-3008 - Process image

Product overview [image] EP1816-x008 [image] EP1816-3008 - Process image
EP1816-3008 - Process image
EP1816-3008 Prozessabbild gesamt
EP1816-3008 Process image
DIG Inputs Channel 1
You will find the first 8 digital inputs of the module under DIG Inputs Channel 1.
EP1816-x008 Prozessabbild DIG Inputs Channel 1
EP1816-3008 process image, DIG Inputs Channel 1
DIG Inputs Channel 2
You will find the second 8 digital inputs of the module under DIG Inputs Channel 2.
EP1816-x008 Prozessabbild DIG Inputs Channel 2
EP1816-3008 process image, DIG Inputs Channel 2
DIG Inputs Device
The status bits can be found under DIG Inputs Device.
EP1816-1008,-3008 Prozessabbild DIG Inputs Device
EP1816-3008 process image, DIG Inputs Device
AI Inputs Channel 1 to 6
EP1816-3008 Prozessabbild AI Inputs Ch1
EP1816-3008 process image, AI inputs
The data for the two accelerometers can be found under AI inputs Channel
▪
Status Error: error relating to the communication with the accelerometer
▪
Value: 16 bit acceleration value
Assignment of the acceleration axes to variables in the process image


EP1859-0042

Product overview [image] EP1859-0042
EP1859-0042
Additional information
•
EP1859-0042 - Introduction
•
EP1859-0042 - Technical data
•
EP1859-0042 - Scope of supply
•
EP1859-0042 - Process image


EP1859-0042 - Introduction

Product overview [image] EP1859-0042 [image] EP1859-0042 - Introduction
EP1859-0042 - Introduction
EP1809-0042 inkl FE
EP1859-0042
8 x digital input + 8 x digital output 24 V DC, Imax = 0.5 A, 3.0 ms
The EP1859-0042 EtherCAT Box has eight digital inputs (four M12 sockets on the left) and eight digital outputs (four M12 sockets on the right). The inputs have a filter of 3.0 ms. The outputs process load currents up to 0.5 A, are short-circuit proof and protected against polarity reversal. The state of the signals is indicated by light emitting diodes. The signals are connected via M12 screw type connectors.
EP1859-0042 DI DO
The sensors are supplied from the box supply voltage US. The outputs are supplied via UP. The outputs are short-circuit proof and protected against inverse connection.
Quick links
Technical data
Process image
Dimensions
Functional earth (FE)
Signal connection, inputs: X01, X02, X03, X04
Signal connection, outputs: X05, X06, X07, X08


EP1859-0042 - Technical data

Product overview [image] EP1859-0042 [image] EP1859-0042 - Technical data
EP1859-0042 - Technical data
All values are typical values over the entire temperature range, unless stated otherwise.
Technical data | EP1859-0042
Fieldbus | EtherCAT
Fieldbus connection | 2x M12 socket, D-coded, 4-pin, green
Number of inputs | 8
Input connections | 4x M12 socket: X01, X02, X03, X04
Nominal input voltage | 24 VDC (-15%/+20%)
Input filter | 3 ms
Signal voltage "0" | -3...+5 V (similar to EN 61131-2, type 3)
Signal voltage "1" | +11...+30 V (similar to EN 61131-2, Type 3)
Input current | 6 mA (similar to EN 61131-2, type 3)
Sensor supply | from the control voltage US max. 0.5 A in total, short-circuit proof
Number of outputs | 8
Output connections | 4x M12 socket: X05, X06, X07, X08
Output current | max. 0.5 A per channel, individually short-circuit proof
Load type | Ohmic, inductive, lamp load
Actuator supply | from the peripheral voltage UP max. 0.5 A in total, short-circuit proof
Power supply connection | Input: 1 x 7/8" plug, 5-pin Downstream connection: 1 x 7/8" socket, 5-pin max. 16 A pro Pin
Supply of the module electronics | from the control voltage US
Current consumption of the module electronics | 130 mA
Electrical isolation Fieldbus GNDS / GNDP | 500 V yes
Permissible ambient temperature during operation | -25°C…+60°C -25…+55 °C conforms to cURus
Permissible ambient temperature during storage | -40°C…+85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable
Weight | approx. 440 g
Approvals | CE, cURus in preparation


EP1859-0042 - Scope of supply

Product overview [image] EP1859-0042 [image] EP1859-0042 - Scope of supply
EP1859-0042 - Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EtherCAT Box EP1859-0042
▪
2x protective cap for EtherCAT socket, M12 (pre-assembled)
▪
1x Protective cap for supply voltage output, 7/8”, black (pre-fitted)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


EP1859-0042 - Process image

Product overview [image] EP1859-0042 [image] EP1859-0042 - Process image
EP1859-0042 - Process image
The process image contains a process data object for each digital input.
The name of each process data object contains the name of the socket and the pin number of the corresponding digital input.
EP1859-0042 - Process image


Mounting and connection

Mounting and connection
Mounting and connection
Additional information
•
Mounting
•
Connections
•
UL Requirements
•
ATEX notes


Mounting

Mounting and connection [image] Mounting
Mounting
Additional information
•
Dimensions EPxxxx-xx0x and EPxxxx-xx1x
•
Dimensions EPxxxx-xx2x
•
EPxxxx-xx42 dimensions
•
Fixing
•
Functional earth (FE)
•
Additional checks


Dimensions EPxxxx-xx0x and EPxxxx-xx1x

Mounting and connection [image] Mounting [image] Dimensions EPxxxx-xx0x and EPxxxx-xx1x
Dimensions EPxxxx-xx0x and EPxxxx-xx1x
Dimensions
All dimensions are given in millimeters.
Housing features
Housing material | PA6 (polyamide)
Sealing compound | polyurethane
Mounting | two fastening holes Ø 3.5 mm for M3
Metal parts | brass, nickel-plated
Contacts | CuZn, gold-plated
Power feed through | max. 4 A
Installation position | variable
Protection class | IP65, IP66, IP67 (conforms to EN 60529) when screwed together
Dimensions (H x W x D) | approx. 126 x 30 x 26.5 mm (without connectors)


Dimensions EPxxxx-xx2x

Mounting and connection [image] Mounting [image] Dimensions EPxxxx-xx2x
Dimensions EPxxxx-xx2x
Dimensions
All dimensions are given in millimeters.
Housing features
Housing material | PA6 (polyamide)
Sealing compound | polyurethane
Mounting | two fastening holes Ø 4.5 mm for M4
Metal parts | brass, nickel-plated
Contacts | CuZn, gold-plated
Power feed through | max. 4 A
Installation position | variable
Protection class | IP65, IP66, IP67 (conforms to EN 60529) when screwed together
Dimensions (H x W x D) | approx. 126 x 60 x 26.5 mm (without connectors)


EPxxxx-xx42 dimensions

Mounting and connection [image] Mounting [image] EPxxxx-xx42 dimensions
EPxxxx-xx42 dimensions
Dimensions
All dimensions are given in millimeters.
Housing features
Housing material | PA6 (polyamide)
Sealing compound | polyurethane
Mounting | two fastening holes Ø 4.5 mm for M4
Metal parts | brass, nickel-plated
Contacts | CuZn, gold-plated
Power feed through | max. 16 A at 40°C (according to IEC 60512-3)
Installation position | variable
Protection class | IP65, IP66, IP67 (conforms to EN 60529) when screwed together
Dimensions (H x W x D) | approx. 150 x 60 x 26.5 mm (without connectors)


Fixing

Mounting and connection [image] Mounting [image] Fixing
Fixing
Protection of connectors against contamination!
While mounting the modules, protect all connectors, especially the IP-Link, against contamination! Only with connected cables or plugs the protection class IP67 is guaranteed! Unused connectors have to be protected with the right plugs! See for plug sets in the catalogue.
Modules with narrow housing are mounted with two M3 bolts.
Modules with wide housing are mounted with two M3 bolts to the fixing holes located at the corners or mounted with two M4 bolts to the fixing holes located centrally.
The bolts must be longer than 15 mm. The fixing holes of the modules are not threaded.
When assembling, remember that the fieldbus connectors increases the overall height. See chapter accessories.
Mounting Rail ZS5300-0001
The mounting rail ZS5300-0001 (500 mm x 129 mm) allows the time saving assembly of modules.
The rail is made of stainless steel, 1.5 mm thick, with already pre-made M3 threads for the modules. The rail has got 5.3 mm slots to mount it via M5 screws to the machine.
Mounting Rail ZS5300-000
The mounting rail is 500 mm long, that way 15 narrow modules can be mounted with a distance of 2 mm between two modules. The rail can be cut to length for the application.
Mounting Rail ZS5300-0011
The mounting rail ZS5300-0011 (500 mm x 129 mm) has in addition to the M3 treads also pre-made M4 treads to fix 60 mm wide modules via their middle holes.
Up to 14 narrow or 7 wide modules may be mixed mounted.


Functional earth (FE)

Mounting and connection [image] Mounting [image] Functional earth (FE)
Functional earth (FE)
EtherCAT Box modules of types EPxxxx-002x and EPxxxx-0042 must be grounded:
The fastening holes also serve as connections for the functional earth (FE).
Make sure that the box is earthed with low impedance via both fastening screws. You can achieve this, for example, by mounting the box on a grounded machine bed.
FE connection via fastening holes
Functional earth via the fastening holes


Additional checks

Mounting and connection [image] Mounting [image] Additional checks
Additional checks
The boxes have undergone the following additional tests:
Verification | Explanation
Vibration | 10 frequency runs in 3 axes
 | 5 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 35 g, 11 ms


Connections

Mounting and connection [image] Connections
Connections
Additional information
•
Tightening torques for plug connectors
•
EtherCAT
•
Supply voltages
•
Digital inputs
•
Digital outputs (EP1859-0042 only)


Tightening torques for plug connectors

Mounting and connection [image] Connections [image] Tightening torques for plug connectors
Tightening torques for plug connectors
Screw connectors tight with a torque wrench. (e.g. ZB8801 from Beckhoff)
Connector diameter | Tightening torque
M8 | 0.4 Nm
M12 | 0.6 Nm
7/8” | 1.5 Nm


EtherCAT

Mounting and connection [image] Connections [image] EtherCAT
EtherCAT
Additional information
•
Connectors
•
Status LEDs
•
Cables


Connectors

Mounting and connection [image] Connections [image] EtherCAT [image] Connectors
Connectors
Note
Risk of confusion: supply voltages and EtherCAT
Defect possible through incorrect insertion.
•
Observe the color coding of the connectors:
black: Supply voltages
green: EtherCAT
EtherCAT Box modules have two green M8 or M12 sockets for the incoming and outgoing EtherCAT connections.
M8 sockets |  | M12 sockets
EtherCAT connections | EtherCAT connections | EtherCAT connections
M8 socket, 4-pin – connection |  | M12 socket, D-coded EtherCAT/Ethernet
Assignment
There are various different standards for the assignment and colors of connectors and cables for EtherCAT.
EtherCAT | Plug connector |  |  | Cable |  | Standard
Signal | M8 | M12 | RJ451 | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 and old versions of ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | Pin 1 | Pin 1 | Pin 1 | yellow2 | orange/white3 | white/orange
Tx - | Pin 4 | Pin 3 | Pin 2 | orange2 | orange3 | orange
Rx + | Pin 2 | Pin 2 | Pin 3 | white2 | blue/white3 | white/green
Rx - | Pin 3 | Pin 4 | Pin 6 | blue2 | blue3 | green
Shield | Housing |  | Shroud | Shield | Shield | Shield
1) colored markings according to EN 61918 in the four-pin RJ45 connector ZS1090-0003
2) wire colors according to EN 61918
3) wire colors
Assimilation of color coding for cable ZB9030, ZB9032 and ZK1090-3xxxx-xxxx (with M8 connectors)
For unification, the prevalent cables ZB9030, ZB9032 and ZK1090-3xxx-xxxx were changed to the colors of EN61918 (yellow, orange, white, blue). So different color coding exists. But the electrical properties are absolutely identical.


Status LEDs

Mounting and connection [image] Connections [image] EtherCAT [image] Status LEDs
Status LEDs
EtherCAT connections
EtherCAT connections
EtherCAT connections
L/A (Link/Act)
A green LED labelled "L/A" is located next to each EtherCAT socket. The LED indicates the communication state of the respective socket:
LED | Meaning
off | no connection to the connected EtherCAT device
lit | LINK: connection to the connected EtherCAT device
flashes | ACT: communication with the connected EtherCAT device
Run
Each EtherCAT slave has a green LED labelled "Run". The LED signals the status of the slave in the EtherCAT network:
LED | Meaning
off | Slave is in "Init" state
flashes uniformly | Slave is in "Pre-Operational“ state
flashes sporadically | Slave is in "Safe-Operational" state
lit | Slave is in "Operational" state
Description of the EtherCAT slave states


Cables

Mounting and connection [image] Connections [image] EtherCAT [image] Cables
Cables
For connecting EtherCAT devices only shielded Ethernet cables that meet the requirements of at least category 5 (CAT5) according to EN 50173 or ISO/IEC 11801 should be used.
EtherCAT uses four wires for signal transmission.
Thanks to automatic line detection ("Auto MDI-X"), both symmetrical (1:1) or cross-over cables can be used between Beckhoff EtherCAT.
Detailed recommendations for the cabling of EtherCAT devices


Supply voltages

Mounting and connection [image] Connections [image] Supply voltages
Supply voltages
The EtherCAT Box is supplied with two supply voltages.
▪
Control voltage US
Power is supplied to the fieldbus, the processor logic, the inputs and the sensors from the control voltage US.
▪
Peripheral voltage UP
The peripheral voltage UP supplies the digital outputs; it can be brought in separately. Hence, if the peripheral voltage is switched off, the fieldbus function as well as the supply and function of the inputs are retained.
Redirection of the supply voltages
The power IN and OUT connections are bridged in the module. Hence, the supply voltages Us and Up can be passed from EtherCAT Box to EtherCAT Box in a simple manner.
Note
Note the maximum current!
Ensure that the permitted current for the connectors is not exceeded when routing the supply voltages US and UP:
M8 connector: max. 4 A
7/8" connector: max 16 A
Additional information
•
Connectors
•
Status LEDs
•
Conductor losses


Connectors

Mounting and connection [image] Connections [image] Supply voltages [image] Connectors
Connectors
M8 connector |  | 7/8" connector
Connector | Connector | Connectors + LEDs
M8 4polig In+Out Kontaktbelegung |  | 7/8 Zoll In+Out Kontaktbelegung
Function | M8 | 7/8" | Description | Core color 1)
US | 1 | 4 | Control voltage | Brown
UP | 2 | 5 | Peripheral voltage | White
GNDS | 3 | 2 | GND to US | Blue
GNDP | 4 | 1 | GND to UP | Black
FE | - | 3 | Functional earth | Grey
1) The core colors apply to cables of the type: Beckhoff ZK2020-xxxx-xxxx
GNDS and GNDP are linked for modules of the following types:
▪
EPxxxx-0001
▪
EPxxxx-0002
▪
EPxxxx-0008
Note
The electrical isolation between GNDS and GNDP can be removed
In some EtherCAT Box modules the ground potentials GNDS and GNDP are linked.
If several EtherCAT Box modules are supplied with the same electrically isolated voltages, check whether there is an EtherCAT Box among them in which the ground potentials are linked.


Status LEDs

Mounting and connection [image] Connections [image] Supply voltages [image] Status LEDs
Status LEDs
Connectors + LEDs
Status LEDs for the supply voltages
LED | Display | Meaning
US (control voltage) | off | Supply voltage US is not present
 | green illuminated | Supply voltage US is present
 | red illuminated | Due to overload (current > 0.5 A), the sensor supply generated from the supply voltage US was switched off for all sensors supplied from it.
UP (peripheral voltage) | Off | Supply voltage UP is not present
 | green illuminated | Supply voltage UP is present
 | red illuminated (EP1859-0042 only) | Due to overload (current > 0.5 A), the sensor supply generated from the supply voltage UP was switched off for all sensors supplied from it.


Conductor losses

Mounting and connection [image] Connections [image] Supply voltages [image] Conductor losses
Conductor losses
Take into account the voltage drop on the supply line when planning a system. Avoid the voltage drop being so high that the supply voltage at the box lies below the minimum nominal voltage.
Variations in the voltage of the power supply unit must also be taken into account.
Voltage drop on cables with M8 connectors
Leitungsverluste M8 2A
Leitungsverluste M8 4A
Voltage drop on cables with 7/8" connectors
Leitungsverluste 7/8" 2A
Leitungsverluste 7/8" 4A


Digital inputs

Mounting and connection [image] Connections [image] Digital inputs
Digital inputs
Additional information
•
M8 sockets
•
M12 sockets
•
M12 sockets of EP1008-0022
•
M12 sockets of EP18x9-0042
•
Pluggable spring-loaded terminals
•
D-sub sockets, 25-pin


M8 sockets

Mounting and connection [image] Connections [image] Digital inputs [image] M8 sockets
M8 sockets
Pin assignment
M8 socket 3-pole, 10mm indented
M8 socket, 3-pin
Pin | Function | Core color 1)
1 | US1 2) | brown
3 | GNDS | blue
4 | Input | black
1) The wire colors apply to 3-wire M8 cables from Beckhoff: ZK2000-2xxx
2) US1 serves as sensor supply voltage. It is branched off from the US supply voltage.
Connection examples
Digital inputs M8, connection examples
Status LEDs
There is a green LED next to each M8 socket. The LED lights up when a high level is detected at the digital input.
Status LED at an M8 socket


M12 sockets

Mounting and connection [image] Connections [image] Digital inputs [image] M12 sockets
M12 sockets
Note
EP1008-0022 and EP18x9-0042 have different pin assignments.
Pin assignment of the digital inputs of EP1008-0022
Pin assignment of the digital inputs of EP18x9-0042
M12 socket
Pin | Function | Core color 1)
1 | US1 2) | brown
2 | Input B | white
3 | GNDS | blue
4 | Input A | black
5 | - | grey
1) The core colors apply to M12 cables from Beckhoff: ZK2000-5xxx, ZK2000-6xxx, ZK2000-7xxx
2) US1 serves as sensor supply voltage. It is branched off from the US supply voltage.
Connection examples
Digital inputs M12, connection examples
Status LEDs
Each M12 socket has two green LEDs. An LED lights up when a high level is detected at the respective input.
Status-LEDs von M12-Buchsen
Status LEDs of M12 sockets


M12 sockets of EP1008-0022

Mounting and connection [image] Connections [image] Digital inputs [image] M12 sockets of EP1008-0022
M12 sockets of EP1008-0022
Note
This pin assignment is only valid for EP1008-0022
Pin assignment of the digital inputs (M12) of other EtherCAT Box modules
M12 socket
Pin | Function | Core color 1)
1 | US1 2) | brown
2 | - | white
3 | GNDS | blue
4 | Input | black
5 | - | grey
1) The core colors apply to M12 cables from Beckhoff: ZK2000-5xxx, ZK2000-6xxx, ZK2000-7xxx
2) US1 serves as sensor supply voltage. It is branched off from the US supply voltage.
Connection examples
Digital inputs M12, connection examples
Status LEDs
Each M12 socket has a green LED. The LED lights up when a high level is detected at the digital input.
Status-LED M12-Buchse EP1008-0022
Status LED on an M12 socket for EP1008-0022


M12 sockets of EP18x9-0042

Mounting and connection [image] Connections [image] Digital inputs [image] M12 sockets of EP18x9-0042
M12 sockets of EP18x9-0042
Note
This pin assignment is only valid for EP18x9-0042
Pin assignment of the digital inputs (M12) of other EtherCAT Box modules
Pin assignment of the digital outputs of EP1859-0042
M12 socket
Pin | EP18x9-0042 | Core color 1)
1 | US1 2) | brown
2 | Input B | white
3 | GNDS | blue
4 | Input A | black
5 | FE (Functional earth) | grey
1) The core colors apply to M12 cables from Beckhoff: ZK2000-5xxx, ZK2000-6xxx, ZK2000-7xxx
2) US1 serves as sensor supply voltage. It is branched off from the US supply voltage.
Connection examples
Digital inputs M12, connection examples
Status LEDs
Each M12 socket has two green LEDs. An LED lights up when a high level is detected at the respective input.
Status-LEDs von M12-Buchsen
Status LEDs of M12 sockets


Pluggable spring-loaded terminals

Mounting and connection [image] Connections [image] Digital inputs [image] Pluggable spring-loaded terminals
Pluggable spring-loaded terminals
Pin assignment
ZS2001
Contact | Function
0 | Input 1
1 | Input 2
2 | Input 3
3 | Input 4
4 | Input 5
5 | Input 6
6 | Input 7
7 | Input 8
"24" | US1
"0V" | GNDS
ZS2001-0004 has three rows with ten terminal contacts each. The first row is occupied as shown in the table. The second and third rows are designed to distribute the supply voltage and ground. See connection examples:
Connection examples
ZS2001 Digitale Eingänge, eingerückt
Digital inputs ZS2001, 8 channels
The diagram shows the connection of 8 sensors in single-wire technology as well as one sensor each in two-wire and three-wire technology.
Please note for ZS2001-0004 connectors: two bridges (24 V and 0 V) are required to supply the terminal points for two- and three-wire connection technology.
Status LEDs
ZS2001-0002 and ZS2001-0004 have a green status LED for each digital input. An LED lights up when a high level is detected at the corresponding input.


D-sub sockets, 25-pin

Mounting and connection [image] Connections [image] Digital inputs [image] D-sub sockets, 25-pin
D-sub sockets, 25-pin
Pin assignment
D-Sub25-Buchse, 10mm eingerückt
D-sub socket, 25-pin
Pin | EP1816-0008 | EP1816-1008 | EP1816-3008
1 | Channel 1, Input 1 | US1 1) | US1 1)
2 | Channel 1, Input 2 | GNDS | GNDS
3 | Channel 1, Input 3 | Channel 1, Input 1 | Channel 1, Input 1
4 | Channel 1, Input 4 | Channel 1, Input 2 | Channel 1, Input 2
5 | Channel 1, Input 5 | Channel 1, Input 3 | Channel 1, Input 3
6 | Channel 1, Input 6 | Channel 1, Input 4 | Channel 1, Input 4
7 | Channel 1, Input 7 | Channel 1, Input 5 | Channel 1, Input 5
8 | Channel 1, Input 8 | Channel 1, Input 6 | Channel 1, Input 6
9 | Channel 2, Input 1 | Channel 1, Input 7 | Channel 1, Input 7
10 | Channel 2, Input 2 | Channel 1, Input 8 | Channel 1, Input 8
11 | Channel 2, Input 3 | Channel 2, Input 1 | Channel 2, Input 1
12 | Channel 2, Input 4 | Channel 2, Input 2 | Channel 2, Input 2
13 | Channel 2, Input 5 | Channel 2, Input 3 | Channel 2, Input 3
14 | Channel 2, Input 6 | Channel 2, Input 4 | Channel 2, Input 4
15 | Channel 2, Input 7 | Channel 2, Input 5 | Channel 2, Input 5
16 | Channel 2, Input 8 | Channel 2, Input 6 | Channel 2, Input 6
17 | US1 1) | Channel 2, Input 7 | Channel 2, Input 7
18 | US1 1) | Channel 2, Input 8 | Channel 2, Input 8
19 | US1 1) | US1 1) | US1 1)
20 | US1 1) | US1 1) | US1 1)
21 | US1 1) | US1 1) | US1 1)
22 | US1 1) | US1 1) | US1 1)
23 | GNDS | GNDS | GNDS
24 | GNDS | GNDS | GNDS
25 | GNDS | GNDS | GNDS
1) US1 serves as sensor supply voltage. It is branched off from the US supply voltage.
Connection examples
Digital inputs D-sub, connection examples
Status LEDs
The D-sub socket has two green status LEDs.
D-Sub 25 Status-LEDs
D-sub 25 status LEDs


Digital outputs (EP1859-0042 only)

Mounting and connection [image] Connections [image] Digital outputs (EP1859-0042 only)
Digital outputs (EP1859-0042 only)
Additional information
•
M12 sockets


M12 sockets

Mounting and connection [image] Connections [image] Digital outputs (EP1859-0042 only) [image] M12 sockets
M12 sockets
Pin assignment
M12 socket
Pin | Function | Core color 1)
1 | UP1 2) | brown
2 | Output B | white
3 | GNDP | blue
4 | Output A | black
5 | FE (Functional earth) | grey
1) The core colors apply to M12 cables from Beckhoff: ZK2000-5xxx, ZK2000-6xxx, ZK2000-7xxx
2) UP1 serves as actuator supply voltage. It is branched off from the UP supply voltage.
Connection examples
Digital outputs M12, connection examples
Status LEDs
LEDs indicate the signal state of the outputs.
Status-LEDs von M12-Buchsen
Status LEDs of M12 sockets


UL Requirements

Mounting and connection [image] UL Requirements
UL Requirements
The installation of the EtherCAT Box Modules certified by UL has to meet the following requirements.
Supply voltage
SmallWarningYellow CAUTION
CAUTION!
This UL requirements are valid for all supply voltages of all marked EtherCAT Box Modules!
For the compliance of the UL requirements the EtherCAT Box Modules should only be supplied
•
by a 24 VDC supply voltage, supplied by an isolating source and protected by means of a fuse (in accordance with UL248), rated maximum 4 Amp, or
•
by a 24 VDC power source, that has to satisfy NEC class 2.
A NEC class 2 power supply shall not be connected in series or parallel with another (class 2) power source!
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, the EtherCAT Box Modules must not be connected to unlimited power sources!
Networks
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, EtherCAT Box Modules must not be connected to telecommunication networks!
Ambient temperature range
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, EtherCAT Box Modules has to be operated only at an ambient temperature range of 0 to 55°C!
Marking for UL
All EtherCAT Box Modules certified by UL (Underwriters Laboratories) are marked with the following label.
UL label


ATEX notes

Mounting and connection [image] ATEX notes
ATEX notes
Additional information
•
ATEX - Special conditions
•
BG2000 - EtherCAT Box protection enclosures
•
ATEX Documentation


ATEX - Special conditions

Mounting and connection [image] ATEX notes [image] ATEX - Special conditions
ATEX - Special conditions
SmallWarningYellow WARNING
Observe the special conditions for the intended use of EtherCAT Box modules in potentially explosive areas – directive 94/9/EU.
•
The certified components are to be installed with a BG2000-0000 or BG2000-0010 protection enclosure that guarantees a protection against mechanical hazards!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of 0 to 55°C for the use of EtherCAT Box modules in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0: 2006
▪
EN 60079-15: 2005
Marking
The EtherCAT Box modules certified for potentially explosive areas bear the following marking:
II 3 G Ex nA II T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
or
II 3 G Ex nA nC IIC T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
Batch number (D number)
The EtherCAT Box modules bear a batch number (D number) that is structured as follows:
D: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with batch number 29 10 02 01:
29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01


BG2000 - EtherCAT Box protection enclosures

Mounting and connection [image] ATEX notes [image] BG2000 - EtherCAT Box protection enclosures
BG2000 - EtherCAT Box protection enclosures
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the EtherCAT system into a safe, powered down state before starting installation, disassembly or wiring of the modules!
ATEX
SmallWarningYellow WARNING
Mount a protection enclosure!
To fulfill the special conditions according to ATEX, a BG2000-0000 or BG2000-0010 protection enclosure has to be mounted over the EtherCAT Box.
Installation
Put the cables for EtherCAT, power supply and sensors/actuators through the hole of the protection enclosure.
BG2000 - putting the cables
Fix the wires for EtherCAT, power supply and sensors/actuators to the EtherCAT Box.
BG2000 - fixing the cables
Mount the protection enclosure over the EtherCAT Box.
BG2000 - mounting the protection enclosure


ATEX Documentation

Mounting and connection [image] ATEX notes [image] ATEX Documentation
ATEX Documentation
Notes about operation of EtherCAT Box Modules (EPxxxx-xxxx) in potentially explosive areas (ATEX)
Pay also attention to the continuative documentationNotes about operation of EtherCAT Box Modules (EPxxxx-xxxx) in potentially explosive areas (ATEX) that is available in the download area of the Beckhoff homepage http:\\www.beckhoff.com!


Commissioning and configuration

Commissioning and configuration
Commissioning and configuration
Additional information
•
Integration in TwinCAT
•
Setting the Hot Connect ID (EP1111-0000 only)
•
Accelerometers (EP1816-3008)
•
Restoring the delivery state
•
Decommissioning


Integration in TwinCAT

Commissioning and configuration [image] Integration in TwinCAT
Integration in TwinCAT
The procedure for integration in TwinCAT is described in this Quick start guide.


Setting the Hot Connect ID (EP1111-0000 only)

Commissioning and configuration [image] Setting the Hot Connect ID (EP1111-0000 only)
Setting the Hot Connect ID (EP1111-0000 only)
The units, tens and hundreds digits of the ID each have their own ID switch. The ID switches are labelled accordingly:
▪
X 1
▪
X 10
▪
X 100
Sample
ID switches sample


Accelerometers (EP1816-3008)

Commissioning and configuration [image] Accelerometers (EP1816-3008)
Accelerometers (EP1816-3008)
EP1816-3008 has two accelerometers. Each accelerometer measures the acceleration in three axes.
The accelerometers are offset by 90°. This enables a plausibility check of the measured values.
EP1816-3008 can also convert the measured values into inclination angles: Presentation of the measured values.
Assignment of the acceleration axes to variables in the process image
EPP1816-3008 acceleration axes
Acceleration axes of EP1816-3008
Assignment of the inclination axes to variables in the process image
EPP1816-3008 inclination axes
Inclination axes of EP1816-3008
Additional information
•
Parameters


Parameters

Commissioning and configuration [image] Accelerometers (EP1816-3008) [image] Parameters
Parameters
Measuring range
CoE index 8080:11 „Range“
Value | Measuring range
03dec (default) | +/- 2 g
04dec | +/- 4 g
05dec | +/- 8 g
06dec | +/- 16 g
Sampling rate
CoE index 8080:0D „Mode“
Value | Sampling rate
04dec | 1 Hz
05dec | 10 Hz
06dec | 25 Hz
07dec | 50 Hz
08dec | 100 Hz
09dec | 250 Hz
10dec | 400 Hz
11dec | 1600 Hz
12dec (default) | 5000 Hz
Presentation of the measured values
CoE index 8080:1D „Presentation“
Value | Format designation | Description
03dec (default) | Raw Values | The measured acceleration values are output as raw values.
04dec | Horizontal Off-Axis Angle | The measured acceleration values are converted into inclination angles.
05dec | milli G (mG) | The measured acceleration values are output in mg.


Restoring the delivery state

Commissioning and configuration [image] Restoring the delivery state
Restoring the delivery state
To restore the delivery state for backup objects in ELxxxx terminals / EPxxxx- and EPPxxxx boxes, the CoE object Restore default parameters, SubIndex 001 can be selected in the TwinCAT System Manager (Config mode).
Selecting the Restore default parameters PDO
Double-click on SubIndex 001 to enter the Set Value dialog. Enter the value 1684107116 in field Dec or the value 0x64616F6C in field Hex and confirm with OK.
All backup objects are reset to the delivery state.
Entering a restore value in the Set Value dialog
Alternative restore value
In some older terminals / boxes the backup objects can be switched with an alternative restore value:
Decimal value: 1819238756
Hexadecimal value: 0x6C6F6164
An incorrect entry for the restore value has no effect.


Decommissioning

Commissioning and configuration [image] Decommissioning
Decommissioning
SmallWarningYellow WARNING
Risk of electric shock!
Bring the bus system into a safe, de-energized state before starting disassembly of the devices!
Disposal
In order to dispose of the device, it must be removed.
In accordance with the WEEE Directive 2012/19/EU, Beckhoff takes back old devices and accessories in Germany for proper disposal. Transport costs will be borne by the sender.
Return the old devices with the note "for disposal" to:
Beckhoff Automation GmbH & Co. KG
Service Department
Stahlstraße 31
D-33415 Verl


CoE parameters (EP1816-xxxx only)

CoE parameters (EP1816-xxxx only)
CoE parameters (EP1816-xxxx only)
Additional information
•
EP1816-0008 - Object Overview
•
EP1816-0008 - Object description and parameterization
•
EP1816-3008 - Object overview
•
EP1816-3008 - Object description and parameterization


EP1816-0008 - Object Overview

CoE parameters (EP1816-xxxx only) [image] EP1816-0008 - Object Overview
EP1816-0008 - Object Overview
EtherCAT XML Device Description
The description corresponds to the display of the CoE objects from the EtherCAT XML Device Description. It is strongly recommended to download the latest revision of the corresponding XML file from the Beckhoff website (http://www.beckhoff.com/english/default.htm?download/elconfg.htm) and follow the installation instructions.
Index |  | Name | Flags | Default value
1000 |  | Device type | RO | 0x01181389 (18355081dec)
1008 |  | Device name | RO | EP1816-0008
1009 |  | Hardware version | RO | 00
100A |  | Software version | RO | 01
1011:0 | SubIndex | Restore default parameters | RO | 0x01 (1dec)
 | 1011:01 | SubIndex 001 | RW | 0x00000000 (0dec)
1018:0 | SubIndex | Identity | RO | 0x04 (4dec)
 | 1018:01 | Vendor ID | RO | 0x00000002 (2dec)
 | 1018:02 | Product code | RO | 0x07184052 (119029842dec)
 | 1018:03 | Revision | RO | 0x00100008 (1048584dec)
 | 1018:04 | Serial number | RO | 0x00000000 (0dec)
10F0:0 | SubIndex | Backup parameter handling | RO | 0x01 (1dec)
 | 10F0:01 | Checksum | RO | 0x00000000 (0dec)
1A00:0 | SubIndex | DO TxPDO-Map Inputs Ch.1 | RO | 0x0B (11dec)
 | 1A00:01 | SubIndex 001 | RO | 0x6000:01, 1
 | 1A00:02 | SubIndex 002 | RO | 0x6000:02, 1
 | 1A00:03 | SubIndex 003 | RO | 0x6000:03, 1
 | 1A00:04 | SubIndex 004 | RO | 0x6000:04, 1
 | 1A00:05 | SubIndex 005 | RO | 0x6000:05, 1
 | 1A00:06 | SubIndex 006 | RO | 0x6000:06, 1
 | 1A00:07 | SubIndex 007 | RO | 0x6000:07, 1
 | 1A00:08 | SubIndex 008 | RO | 0x6000:08, 1
 | 1A00:09 | SubIndex 009 | RO | 0x0000:00, 5
 | 1A00:0A | SubIndex 010 | RO | 0x1C32:20, 1
 | 1A00:0B | SubIndex 011 | RO | 0x0000:00, 2
1A01:0 | SubIndex | DO TxPDO-Map Inputs Ch.2 | RO | 0x0B (11dec)
 | 1A01:01 | SubIndex 001 | RO | 0x6010:01, 1
 | 1A01:02 | SubIndex 002 | RO | 0x6010:02, 1
 | 1A01:03 | SubIndex 003 | RO | 0x6010:03, 1
 | 1A01:04 | SubIndex 004 | RO | 0x6010:04, 1
 | 1A01:05 | SubIndex 005 | RO | 0x6010:05, 1
 | 1A01:06 | SubIndex 006 | RO | 0x6010:06, 1
 | 1A01:07 | SubIndex 007 | RO | 0x6010:07, 1
 | 1A01:08 | SubIndex 008 | RO | 0x6010:08, 1
 | 1A01:09 | SubIndex 009 | RO | 0x0000:00, 5
 | 1A01:0A | SubIndex 010 | RO | 0x1C32:20, 1
 | 1A01:0B | SubIndex 011 | RO | 0x0000:00, 2
1C00:0 | SubIndex | Sync manager type | RO | 0x04 (4dec)
 | 1C00:01 | SubIndex 001 | RO | 0x01 (1dec)
 | 1C00:02 | SubIndex 002 | RO | 0x02 (2dec)
 | 1C00:03 | SubIndex 003 | RO | 0x03 (3dec)
 | 1C00:04 | SubIndex 004 | RO | 0x04 (4dec)
1C12:0 | SubIndex | RxPDO assign | RO | 0x00 (0dec)
1C13:0 | SubIndex | TxPDO assign | RO | 0x02 (2dec)
 | 1C13:01 | SubIndex 001 | RO | 0x1A00 (6656dec)
 | 1C13:02 | SubIndex 002 | RO | 0x1A01 (6657dec)
Index |  | Name | Flags | Default value
1C33:0 | SubIndex | SM input parameter | RO | 0x20 (32dec)
 | 1C33:01 | Sync mode | RW | 0x0022 (34dec)
 | 1C33:02 | Cycle time | RW | 0x000186A0 (100000dec)
 | 1C33:03 | Shift time | RO | 0x00000000 (0dec)
 | 1C33:04 | Sync modes supported | RO | 0xC007 (49159dec)
 | 1C33:05 | Minimum cycle time | RO | 0x000124F8 (75000dec)
 | 1C33:06 | Calc and copy time | RO | 0x00000000 (0dec)
 | 1C33:08 | Command | RW | 0x0000 (0dec)
 | 1C33:09 | Delay time | RO | 0x00000000 (0dec)
 | 1C33:0B | SM event missed counter | RO | 0x0000 (0dec)
 | 1C33:0C | Cycle exceeded counter | RO | 0x0000 (0dec)
 | 1C33:0D | Shift too short counter | RO | 0x0000 (0dec)
 | 1C33:20 | Sync error | RO | 0x00 (0dec)
6000:0 | SubIndex | DO Inputs Ch.1 | RO | 0x0E (14dec)
 | 6000:01 | Input 1 | RO | 0x00 (0dec)
 | 6000:02 | Input 2 | RO | 0x00 (0dec)
 | 6000:03 | Input 3 | RO | 0x00 (0dec)
 | 6000:04 | Input 4 | RO | 0x00 (0dec)
 | 6000:05 | Input 5 | RO | 0x00 (0dec)
 | 6000:06 | Input 6 | RO | 0x00 (0dec)
 | 6000:07 | Input 7 | RO | 0x00 (0dec)
 | 6000:08 | Input 8 | RO | 0x00 (0dec)
 | 6000:0E | Sync Error | RO | 0x00 (0dec)
6010:0 | SubIndex | DO Inputs Ch.2 | RO | 0x0E (14dec)
 | 6010:01 | Input 1 | RO | 0x00 (0dec)
 | 6010:02 | Input 2 | RO | 0x00 (0dec)
 | 6010:03 | Input 3 | RO | 0x00 (0dec)
 | 6010:04 | Input 4 | RO | 0x00 (0dec)
 | 6010:05 | Input 5 | RO | 0x00 (0dec)
 | 6010:06 | Input 6 | RO | 0x00 (0dec)
 | 6010:07 | Input 7 | RO | 0x00 (0dec)
 | 6010:08 | Input 8 | RO | 0x00 (0dec)
 | 6010:0E | Sync Error | RO | 0x00 (0dec)
F000:0 | SubIndex | Modular device profile | RO | 0x02 (2dec)
 | F000:01 | Module index distance | RO | 0x0010 (16dec)
 | F000:02 | Maximum number of modules | RO | 0x0002 (2dec)
F008 |  | Code word | RW | 0x00000000 (0dec)
F010:0 | SubIndex | Module list | RW | 0x02 (2dec)
 | F010:01 | SubIndex 001 | RW | 0x00000118 (280dec)
 | F010:02 | SubIndex 002 | RW | 0x00000118 (280dec)
Key
Flags:
RO = Read Only
RW = Read/Write


EP1816-0008 - Object description and parameterization

CoE parameters (EP1816-xxxx only) [image] EP1816-0008 - Object description and parameterization
EP1816-0008 - Object description and parameterization
Parameterization
The terminal is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs).
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website (http://beckhoff.de/german/download/elconfg.htm?id=1983920606140) and installing it according to the installation instructions.
Introduction
The CoE overview contains objects for different intended applications:
▪
Objects required for parameterization during commissioning
▪
Objects intended for regular operation, e.g. through ADS access
▪
Objects for indicating internal settings (may be fixed)
The following section first describes the objects required for normal operation, followed by a complete overview of missing objects.
Objects to be parameterized during commissioning
Objects to be parameterized during commissioning
Index 1011 Restore default parameters
Index | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default parameters | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to 0x64616F6C in the set value dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)
Objects for regular operation
The EP1816 has no such objects.
Additional objects
Standard objects (0x1000-0x1FFF)
The standard objects have the same meaning for all EtherCAT slaves.
Index 1000 Device type
Index | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x01181389 (18355081dec)
Index 1008 Device name
Index | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | string | RO | EP1816-0008
Index 1009 Hardware version
Index | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | string | RO | 00
Index 100A Software version
Index | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | string | RO | 01
Index 1018 Identity
Index | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x07184052 (119029842dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the low word (bit 0-15) indicates the special terminal number, the high word (bit 16-31) refers to the device description | UINT32 | RO | 0x00100008 (1048584dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the low byte (bit 0-7) of the low word contains the year of production, the high byte (bit 8-15) of the low word contains the week of production, the high word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 Backup parameter handling
Index | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | Information for standardized loading and saving of backup entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum across all backup entries of the EtherCAT slave | UINT32 | RO | 0x00000000 (0dec)
Index 1A00 DO TxPDO-Map Inputs Ch.1
Index | Name | Meaning | Data type | Flags | Default
1A00:0 | DO TxPDO-Map Inputs Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x0B (11dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x01 (Input 1)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x02 (Input 2)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x03 (Input 3)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x04 (Input 4)) | UINT32 | RO | 0x6000:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x05 (Input 5)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x06 (Input 6)) | UINT32 | RO | 0x6000:06, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x07 (Input 7)) | UINT32 | RO | 0x6000:07, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x08 (Input 8)) | UINT32 | RO | 0x6000:08, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x1C32, entry 0x20) | UINT32 | RO | 0x1C32:20, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
Index 1A01 DO TxPDO-Map Inputs Ch.2
Index | Name | Meaning | Data type | Flags | Default
1A01:0 | DO TxPDO-Map Inputs Ch.2 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x0B (11dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DO Inputs Ch.2), entry 0x01 (Input 1)) | UINT32 | RO | 0x6010:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (DO Inputs Ch.2), entry 0x02 (Input 2)) | UINT32 | RO | 0x6010:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (DO Inputs Ch.2), entry 0x03 (Input 3)) | UINT32 | RO | 0x6010:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (DO Inputs Ch.2), entry 0x04 (Input 4)) | UINT32 | RO | 0x6010:04, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (DO Inputs Ch.2), entry 0x05 (Input 5)) | UINT32 | RO | 0x6010:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (DO Inputs Ch.2), entry 0x06 (Input 6)) | UINT32 | RO | 0x6010:06, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (DO Inputs Ch.2), entry 0x07 (Input 7)) | UINT32 | RO | 0x6010:07, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (DO Inputs Ch.2), entry 0x08 (Input 8)) | UINT32 | RO | 0x6010:08, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x1C32, entry 0x20) | UINT32 | RO | 0x1C32:20, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
Index 1C00 Sync manager type
Index | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the sync managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign
Index | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RO | 0x00 (0dec)
Index 1C13 TxPDO assign
Index | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RO | 0x02 (2dec)
1C13:01 | Subindex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RO | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RO | 0x1A01 (6657dec)
Index 1C33 SM input parameter
Index
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchronous with SM 3 Event (no outputs available)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchronous with SM 2 Event (outputs available)
UINT16
RW
0x0022 (34dec)
1C33:02
Cycle time
Cycle time (in ns):
▪
Synchron with SM 2 Event: Master cycle time
▪
DC mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000186A0 (100000dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: Synchronous with SM 2 Event is supported (outputs available)
▪
Bit 1: Synchronous with SM 3 Event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: Input shift through local event (outputs available)
▪
Bit 4-5 = 10: Input shift with SYNC1 event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 1C32:08 )
UINT16
RO
0xC007 (49159dec)
1C33:05
Minimum cycle time
Minimum cycle time (in ns)
UINT32
RO
0x000124F8 (75000dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:08
Command
▪
0: Measurement of the local cycle time is stopped
▪
1: Measurement of the local cycle time is started
The entries 1C33:03, 1C33:06, 1C33:07, 1C33:09 are updated with the maximum measured values.
For a subsequent measurement the measured values are reset
UINT16
RW
0x0000 (0dec)
1C33:09
Delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:0B
SM event missed counter
Number of missed SM events in OPERATIONAL (DC mode only)
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
Number of occasions the cycle time was exceeded in OPERATIONAL (cycle was not completed in time or the next cycle began too early)
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
Number of occasions that the interval between SYNC0 and SYNC1 event was too short (DC mode only)
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
The synchronization was not correct in the last cycle (outputs were output too late; DC mode only)
boolean
RO
0x00 (0dec)
Profile-specific objects (0x6000-0xFFFF)
The profile-specific objects have the same meaning for all EtherCAT slaves that support the profile 5001.
Index 6000 DO Inputs Ch.1
Index | Name | Meaning | Data type | Flags | Default
6000:0 | DO Inputs Ch.1 |  | UINT8 | RO | 0x0E (14dec)
6000:01 | Input 1 |  | boolean | RO | 0x00 (0dec)
6000:02 | Input 2 |  | boolean | RO | 0x00 (0dec)
6000:03 | Input 3 |  | boolean | RO | 0x00 (0dec)
6000:04 | Input 4 |  | boolean | RO | 0x00 (0dec)
6000:05 | Input 5 |  | boolean | RO | 0x00 (0dec)
6000:06 | Input 6 |  | boolean | RO | 0x00 (0dec)
6000:07 | Input 7 |  | boolean | RO | 0x00 (0dec)
6000:08 | Input 8 |  | boolean | RO | 0x00 (0dec)
6000:0E | Sync Error |  | boolean | RO | 0x00 (0dec)
Index 6010 DO Inputs Ch.2
Index | Name | Meaning | Data type | Flags | Default
6010:0 | DO Inputs Ch.2 |  | UINT8 | RO | 0x0E (14dec)
6010:01 | Input 1 |  | boolean | RO | 0x00 (0dec)
6010:02 | Input 2 |  | boolean | RO | 0x00 (0dec)
6010:03 | Input 3 |  | boolean | RO | 0x00 (0dec)
6010:04 | Input 4 |  | boolean | RO | 0x00 (0dec)
6010:05 | Input 5 |  | boolean | RO | 0x00 (0dec)
6010:06 | Input 6 |  | boolean | RO | 0x00 (0dec)
6010:07 | Input 7 |  | boolean | RO | 0x00 (0dec)
6010:08 | Input 8 |  | boolean | RO | 0x00 (0dec)
6010:0E | Sync Error |  | boolean | RO | 0x00 (0dec)
Index F000 Modular device profile
Index | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0002 (2dec)
Index F008 Code word
Index | Name | Meaning | Data type | Flags | Default
F008:0 | Code word |  | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module list
Index | Name | Meaning | Data type | Flags | Default
F010:0 | Module list |  | UINT8 | RW | 0x02 (2dec)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x00000118 (280dec)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x00000118 (280dec)


EP1816-3008 - Object overview

CoE parameters (EP1816-xxxx only) [image] EP1816-3008 - Object overview
EP1816-3008 - Object overview
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area on the Beckhoff website (http://www.beckhoff.de/german/default.htm?download/elconfg.htm) and installing it according to the installation instructions.
Index (hex) |  | Name | Flags | Default value
1000 |  | Device type | RO | 0x00001389 (5001dec)
1008 |  | Device name | RO | EP1816-3008
1009 |  | Hardware version | RO |
100A |  | Software version | RO | 03
1011:0 | Subindex | Restore default parameters | RO | 0x01 (1dec)
 | 0x1011:01 | SubIndex 001 | RW | 0x00000000 (0dec)
1018:0 | Subindex | Identity | RO | 0x04 (4dec)
 | 0x1018:01 | Vendor ID | RO | 0x00000002 (2dec)
 | 0x1018:02 | Product code | RO | 0x05E44052 (98844754dec)
 | 01018:03 | Revision | RO | 0x00000000 (0dec)
 | 0x1018:04 | Serial number | RO | 0x00000000 (0dec)
10F0:0 | Subindex | Backup parameter handling | RO | 0x01 (1dec)
 | 0x10F0:01 | Checksum | RO | 0x00000000 (0dec)
1A00:0 | Subindex | DIG TxPDO-Map Inputs Ch.1 | RO | 0x09 (9dec)
 | 0x1A00:01 | SubIndex 001 | RO | 0x6000:01, 1
 | 0x1A00:02 | SubIndex 002 | RO | 0x6000:02, 1
 | 0x1A00:03 | SubIndex 003 | RO | 0x6000:03, 1
 | 0x1A00:04 | SubIndex 004 | RO | 0x6000:04, 1
 | 0x1A00:05 | SubIndex 005 | RO | 0x6000:05, 1
 | 0x1A00:06 | SubIndex 006 | RO | 0x6000:06, 1
 | 0x1A00:07 | SubIndex 007 | RO | 0x6000:07, 1
 | 0x1A00:08 | SubIndex 008 | RO | 0x6000:08, 1
 | 0x1A00:09 | SubIndex 009 | RO | 0x0000:00, 8
1A01:0 | Subindex | DIG TxPDO-Map Inputs Ch.2 | RO | 0x09 (9dec)
 | 0x1A01:01 | SubIndex 001 | RO | 0x6010:01, 1
 | 0x1A01:02 | SubIndex 002 | RO | 0x6010:02, 1
 | 0x1A01:03 | SubIndex 003 | RO | 0x6010:03, 1
 | 0x1A01:04 | SubIndex 004 | RO | 0x6010:04, 1
 | 0x1A01:05 | SubIndex 005 | RO | 0x6010:05, 1
 | 0x1A01:06 | SubIndex 006 | RO | 0x6010:06, 1
 | 0x1A01:07 | SubIndex 007 | RO | 0x6010:07, 1
 | 0x1A01:08 | SubIndex 008 | RO | 0x6010:08, 1
 | 0x1A01:09 | SubIndex 009 | RO | 0x0000:00, 8
1A02:0 | Subindex | AI TxPDO-Map Inputs Ch.1 | RO | 0x05 (5dec)
 | 0x1A02:01 | SubIndex 001 | RO | 0x0000:00, 6
 | 0x1A02:02 | SubIndex 002 | RO | 0x6020:07, 1
 | 0x1A02:03 | SubIndex 003 | RO | 0x0000:00, 8
 | 0x1A02:04 | SubIndex 004 | RO | 0x6020:10, 1
 | 0x1A02:05 | SubIndex 005 | RO | 0x6020:11, 16
1A03:0 | Subindex | AI TxPDO-Map Inputs Ch.2 | RO | 0x05 (5dec)
 | 0x1A03:01 | SubIndex 001 | RO | 0x0000:00, 6
 | 0x1A03:02 | SubIndex 002 | RO | 0x6030:07, 1
 | 0x1A03:03 | SubIndex 003 | RO | 0x0000:00, 8
 | 0x1A03:04 | SubIndex 004 | RO | 0x6030:10, 1
 | 0x1A03:05 | SubIndex 005 | RO | 0x6030:11, 16
Index (hex) |  | Name | Flags | Default value
1A04:0 | Subindex | AI TxPDO-Map Inputs Ch.3 | RO | 0x05 (5dec)
 | 0x1A04:01 | SubIndex 001 | RO | 0x0000:00, 6
 | 0x1A04:02 | SubIndex 002 | RO | 0x6040:07, 1
 | 0x1A04:03 | SubIndex 003 | RO | 0x0000:00, 8
 | 0x1A04:04 | SubIndex 004 | RO | 0x6040:10, 1
 | 0x1A04:05 | SubIndex 005 | RO | 0x6040:11, 16
1A05:0 | Subindex | AI TxPDO-Map Inputs Ch.4 | RO | 0x05 (5dec)
 | 0x1A05:01 | SubIndex 001 | RO | 0x0000:00, 6
 | 0x1A05:02 | SubIndex 002 | RO | 0x6050:07, 1
 | 0x1A05:03 | SubIndex 003 | RO | 0x0000:00, 8
 | 0x1A05:04 | SubIndex 004 | RO | 0x6050:10, 1
 | 0x1A05:05 | SubIndex 005 | RO | 0x6050:11, 16
1A06:0 | Subindex | AI TxPDO-Map Inputs Ch.5 | RO | 0x05 (5dec)
 | 0x1A06:01 | SubIndex 001 | RO | 0x0000:00, 6
 | 0x1A06:02 | SubIndex 002 | RO | 0x6060:07, 1
 | 0x1A06:03 | SubIndex 003 | RO | 0x0000:00, 8
 | 0x1A06:04 | SubIndex 004 | RO | 0x6060:10, 1
 | 0x1A06:05 | SubIndex 005 | RO | 0x6060:11, 16
1A07:0 | Subindex | AI TxPDO-Map Inputs Ch.6 | RO | 0x05 (5dec)
 | 0x1A07:01 | SubIndex 001 | RO | 0x0000:00, 6
 | 0x1A07:02 | SubIndex 002 | RO | 0x6070:07, 1
 | 0x1A07:03 | SubIndex 003 | RO | 0x0000:00, 8
 | 0x1A07:04 | SubIndex 004 | RO | 0x6070:10, 1
 | 0x1A07:05 | SubIndex 005 | RO | 0x6070:11, 16
1A08:0 | Subindex | DIG TxPDO-Map Inputs Device | RO | 0x04 (4dec)
 | 0x1A08:01 | SubIndex 001 | RO | 0xF600:01, 1
 | 0x1A08:02 | SubIndex 002 | RO | 0xF600:02, 1
 | 0x1A08:03 | SubIndex 003 | RO | 0x0000:00, 13
 | 0x1A08:04 | SubIndex 004 | RO | 0xF600:10, 1
1C00:0 | Subindex | Sync manager type | RO | 0x04 (4dec)
 | 0x1C00:01 | SubIndex 001 | RO | 0x01 (1dec)
 | 0x1C00:02 | SubIndex 002 | RO | 0x02 (2dec)
 | 0x1C00:03 | SubIndex 003 | RO | 0x03 (3dec)
 | 0x1C00:04 | SubIndex 004 | RO | 0x04 (4dec)
1C12:0 | Subindex | RxPDO assign | RO | 0x00 (0dec)
1C13:0 | Subindex | TxPDO assign | RO | 0x09 (9dec)
 | 0x1C13:01 | SubIndex 001 | RO | 0x1A00 (6656dec)
 | 0x1C13:02 | SubIndex 002 | RO | 0x1A01 (6657dec)
 | 0x1C13:03 | SubIndex 003 | RO | 0x1A02 (6658dec)
 | 0x1C13:04 | SubIndex 004 | RO | 0x1A03 (6659dec)
 | 0x1C13:05 | SubIndex 005 | RO | 0x1A04 (6660dec)
 | 0x1C13:06 | SubIndex 006 | RO | 0x1A05 (6661dec)
 | 0x1C13:07 | SubIndex 007 | RO | 0x1A06 (6662dec)
 | 0x1C13:08 | SubIndex 008 | RO | 0x1A07 (6663dec)
 | 0x1C13:09 | SubIndex 009 | RO | 0x1A08 (6664dec)
Index (hex) |  | Name | Flags | Default value
1C33:0 | Subindex | SM input parameter | RO | 0x20 (32dec)
 | 0x1C33:01 | Sync mode | RW | 0x0022 (34dec)
 | 0x1C33:02 | Cycle time | RW | 0x003D0900 (4000000dec)
 | 0x1C33:03 | Shift time | RO | 0x00000000 (0dec)
 | 0x1C33:04 | Sync modes supported | RO | 0xC007 (49159dec)
 | 0x1C33:05 | Minimum cycle time | RO | 0x00030D40 (200000dec)
 | 0x1C33:06 | Calc and copy time | RO | 0x00000000 (0dec)
 | 0x1C33:07 | Minimum delay time | RO | 0x00000000 (0dec)
 | 0x1C33:08 | Command | RW | 0x0000 (0dec)
 | 0x1C33:09 | Maximum delay time | RO | 0x00000000 (0dec)
 | 0x1C33:0B | SM event missed counter | RO | 0x0000 (0dec)
 | 0x1C33:0C | Cycle exceeded counter | RO | 0x0000 (0dec)
 | 0x1C33:0D | Shift too short counter | RO | 0x0000 (0dec)
 | 0x1C33:20 | Sync error | RO | 0x00 (0dec)
6000:0 | Subindex | DIG Inputs Ch.1 | RO | 0x08 (8dec)
 | 0x6000:01 | Input 1 | RO | 0x00 (0dec)
 | 0x6000:02 | Input 2 | RO | 0x00 (0dec)
 | 0x6000:03 | Input 3 | RO | 0x00 (0dec)
 | 0x6000:04 | Input 4 | RO | 0x00 (0dec)
 | 0x6000:05 | Input 5 | RO | 0x00 (0dec)
 | 0x6000:06 | Input 6 | RO | 0x00 (0dec)
 | 0x6000:07 | Input 7 | RO | 0x00 (0dec)
 | 0x6000:08 | Input 8 | RO | 0x00 (0dec)
6010:0 | Subindex | DIG Inputs Ch.2 | RO | 0x08 (8dec)
 | 0x6010:01 | Input 1 | RO | 0x00 (0dec)
 | 0x6010:02 | Input 2 | RO | 0x00 (0dec)
 | 0x6010:03 | Input 3 | RO | 0x00 (0dec)
 | 0x6010:04 | Input 4 | RO | 0x00 (0dec)
 | 0x6010:05 | Input 5 | RO | 0x00 (0dec)
 | 0x6010:06 | Input 6 | RO | 0x00 (0dec)
 | 0x6010:07 | Input 7 | RO | 0x00 (0dec)
 | 0x6010:08 | Input 8 | RO | 0x00 (0dec)
6020:0 | Subindex | AI Inputs Ch.1 | RO | 0x11 (17dec)
 | 0x6020:07 | Error | RO | 0x00 (0dec)
 | 0x6020:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 0x6020:11 | Value | RO | 0x0000 (0dec)
6030:0 | Subindex | AI Inputs Ch.2 | RO | 0x11 (17dec)
 | 0x6030:07 | Error | RO | 0x00 (0dec)
 | 0x6030:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 0x6030:11 | Value | RO | 0x0000 (0dec)
6040:0 | Subindex | AI Inputs Ch.3 | RO | 0x11 (17dec)
 | 0x6040:07 | Error | RO | 0x00 (0dec)
 | 0x6040:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 0x6040:11 | Value | RO | 0x0000 (0dec)
6050:0 | Subindex | AI Inputs Ch.4 | RO | 0x11 (17dec)
 | 0x6050:07 | Error | RO | 0x00 (0dec)
 | 0x6050:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 0x6050:11 | Value | RO | 0x0000 (0dec)
6060:0 | Subindex | AI Inputs Ch.5 | RO | 0x11 (17dec)
 | 0x6060:07 | Error | RO | 0x00 (0dec)
 | 0x6060:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 0x6060:11 | Value | RO | 0x0000 (0dec)
6070:0 | Subindex | AI Inputs Ch.6 | RO | 0x11 (17dec)
 | 0x6070:07 | Error | RO | 0x00 (0dec)
 | 0x6070:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 0x6070:11 | Value | RO | 0x0000 (0dec)
Index (hex) |  | Name | Flags | Default value
8020:0 | Subindex | AI Settings Ch.1 | RW | 0x18 (24dec)
 | 0x8020:01 | Enable user scale | RW | 0x00 (0dec)
 | 0x8020:0A | Enable user calibration | RW | 0x00 (0dec)
 | 0x8020:0B | Enable vendor calibration | RW | 0x00 (0dec)
 | 0x8020:11 | User scale offset | RW | 0x0000 (0dec)
 | 0x8020:12 | User scale gain | RW | 0x02A00000 (44040192dec)
 | 0x8020:17 | User calibration offset | RW | 0x0000 (0dec)
 | 0x8020:18 | User calibration gain | RW | 0x0000 (0dec)
802F:0 | Subindex | AI Vendor data Ch.1 | RW | 0x02 (2dec)
 | 0x802F:01 | Calibration Offset | RW | 0x0000 (0dec)
 | 0x802F:02 | Calibration Gain | RW | 0x0000 (0dec)
8030:0 | Subindex | AI Settings Ch.2 | RW | 0x18 (24dec)
 | 0x8030:01 | Enable user scale | RW | 0x00 (0dec)
 | 0x8030:0A | Enable user calibration | RW | 0x00 (0dec)
 | 0x8030:0B | Enable vendor calibration | RW | 0x00 (0dec)
 | 0x8030:11 | User scale offset | RW | 0x0000 (0dec)
 | 0x8030:12 | User scale gain | RW | 0x02A00000 (44040192dec)
 | 0x8030:17 | User calibration offset | RW | 0x0000 (0dec)
 | 0x8030:18 | User calibration gain | RW | 0x0000 (0dec)
803F:0 | Subindex | AI Vendor data Ch.2 | RW | 0x02 (2dec)
 | 0x803F:01 | Calibration Offset | RW | 0x0000 (0dec)
 | 0x803F:02 | Calibration Gain | RW | 0x0000 (0dec)
8040:0 | Subindex | AI Settings Ch.3 | RW | 0x18 (24dec)
 | 0x8040:01 | Enable user scale | RW | 0x00 (0dec)
 | 0x8040:0A | Enable user calibration | RW | 0x00 (0dec)
 | 0x8040:0B | Enable vendor calibration | RW | 0x00 (0dec)
 | 0x8040:11 | User scale offset | RW | 0x0000 (0dec)
 | 0x8040:12 | User scale gain | RW | 0x02A00000 (44040192dec)
 | 0x8040:17 | User calibration offset | RW | 0x0000 (0dec)
 | 0x8040:18 | User calibration gain | RW | 0x0000 (0dec)
804F:0 | Subindex | AI Vendor data Ch.3 | RW | 0x02 (2dec)
 | 0x804F:01 | Calibration Offset | RW | 0x0000 (0dec)
 | 0x804F:02 | Calibration Gain | RW | 0x0000 (0dec)
8050:0 | Subindex | AI Settings Ch.4 | RW | 0x18 (24dec)
 | 0x8050:01 | Enable user scale | RW | 0x00 (0dec)
 | 0x8050:0A | Enable user calibration | RW | 0x00 (0dec)
 | 0x8050:0B | Enable vendor calibration | RW | 0x00 (0dec)
 | 0x8050:11 | User scale offset | RW | 0x0000 (0dec)
 | 0x8050:12 | User scale gain | RW | 0x02A00000 (44040192dec)
 | 0x8050:17 | User calibration offset | RW | 0x0000 (0dec)
 | 0x8050:18 | User calibration gain | RW | 0x0000 (0dec)
805F:0 | Subindex | AI Vendor data Ch.4 | RW | 0x02 (2dec)
 | 0x805F:01 | Calibration Offset | RW | 0x0000 (0dec)
 | 0x805F:02 | Calibration Gain | RW | 0x0000 (0dec)
8060:0 | Subindex | AI Settings Ch.5 | RW | 0x18 (24dec)
 | 0x8060:01 | Enable user scale | RW | 0x00 (0dec)
 | 0x8060:0A | Enable user calibration | RW | 0x00 (0dec)
 | 0x8060:0B | Enable vendor calibration | RW | 0x00 (0dec)
 | 0x8060:11 | User scale offset | RW | 0x0000 (0dec)
 | 0x8060:12 | User scale gain | RW | 0x02A00000 (44040192dec)
 | 0x8060:17 | User calibration offset | RW | 0x0000 (0dec)
 | 0x8060:18 | User calibration gain | RW | 0x0000 (0dec)
806F:0 | Subindex | AI Vendor data Ch.5 | RW | 0x02 (2dec)
 | 0x806F:01 | Calibration Offset | RW | 0x0000 (0dec)
 | 0x806F:02 | Calibration Gain | RW | 0x0000 (0dec)
Index (hex) |  | Name | Flags | Default value
8070:0 | Subindex | AI Settings Ch.6 | RW | 0x18 (24dec)
 | 0x8070:01 | Enable user scale | RW | 0x00 (0dec)
 | 0x8070:0A | Enable user calibration | RW | 0x00 (0dec)
 | 0x8070:0B | Enable vendor calibration | RW | 0x00 (0dec)
 | 0x8070:11 | User scale offset | RW | 0x0000 (0dec)
 | 0x8070:12 | User scale gain | RW | 0x02A00000 (44040192dec)
 | 0x8070:17 | User calibration offset | RW | 0x0000 (0dec)
 | 0x8070:18 | User calibration gain | RW | 0x0000 (0dec)
807F:0 | Subindex | AI Vendor data Ch.6 | RW | 0x02 (2dec)
 | 0x807F:01 | Calibration Offset | RW | 0x0000 (0dec)
 | 0x807F:02 | Calibration Gain | RW | 0x0000 (0dec)
8080:0 | Subindex | SAI Settings | RW | 0x11 (17dec)
 | 0x8080:0D | Mode | RW | 0x0000 (0dec)
 | 0x8080:11 | Range | RW | 0x0000 (0dec)
F000:0 | Subindex | Modular device profile | RO | 0x02 (2dec)
 | 0xF000:01 | Module index distance | RO | 0x0010 (16dec)
 | 0xF000:02 | Maximum number of modules | RO | 0x0009 (9dec)
F008 |  | Code word | RW | 0x00000000 (0dec)
F010:0 | Subindex | Module list | RW | 0x09 (9dec)
 | 0xF010:01 | SubIndex 001 | RW | 0x00000118 (280dec)
 | 0xF010:02 | SubIndex 002 | RW | 0x00000118 (280dec)
 | 0xF010:03 | SubIndex 003 | RW | 0x0000012C (300dec)
 | 0xF010:04 | SubIndex 004 | RW | 0x0000012C (300dec)
 | 0xF010:05 | SubIndex 005 | RW | 0x0000012C (300dec)
 | 0xF010:06 | SubIndex 006 | RW | 0x0000012C (300dec)
 | 0xF010:07 | SubIndex 007 | RW | 0x0000012C (300dec)
 | 0xF010:08 | SubIndex 008 | RW | 0x0000012C (300dec)
 | 0xF010:09 | SubIndex 009 | RW | 0x00000168 (360dec)
F600:0 | Subindex | DIG Inputs | RO | 0x10 (16dec)
 | 0xF600:01 | Us Undervoltage | RO | 0x00 (0dec)
 | 0xF600:02 | Up Undervoltage | RO | 0x00 (0dec)
 | 0xF600:10 | TxPDO Toggle | RO | 0x00 (0dec)
Key
Flags:
RO (Read Only): this object can be read only
RW (Read/Write): this object can be read and written to


EP1816-3008 - Object description and parameterization

CoE parameters (EP1816-xxxx only) [image] EP1816-3008 - Object description and parameterization
EP1816-3008 - Object description and parameterization
Parameterization
The terminal is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs).
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Introduction
The CoE overview contains objects for different intended applications:
▪
Objects required for parameterization during commissioning
▪
Objects for indicating internal settings (may be fixed)
▪
Further profile-specific objects indicating inputs, outputs and status information
The following section first describes the objects required for normal operation, followed by a complete overview of missing objects.
Additional information
•
Objects to be parameterized during commissioning
•
Standard objects (0x1000-0x1FFF)
•
Profile-specific objects (0x6000-0xFFFF)


Objects to be parameterized during commissioning

CoE parameters (EP1816-xxxx only) [image] EP1816-3008 - Object description and parameterization [image] Objects to be parameterized during commissioning
Objects to be parameterized during commissioning
Index 8020 AI Settings Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
8020:0 | AI Settings Ch.1 |  | UINT8 | RO | 0x18 (24dec)
8020:01 | Enable user scale |  | BOOLEAN | RW | 0x00 (0dec)
8020:0A | Enable user calibration |  | BOOLEAN | RW | 0x00 (0dec)
8020:0B | Enable vendor calibration |  | BOOLEAN | RW | 0x00 (0dec)
8020:11 | User scale offset |  | INT16 | RW | 0x0000 (0dec)
8020:12 | User scale gain |  | INT32 | RW | 0x02A00000 (44040192dec)
8020:17 | User calibration offset |  | INT16 | RW | 0x0000 (0dec)
8020:18 | User calibration gain |  | INT16 | RW | 0x0000 (0dec)
Index 802F AI Vendor data Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
802F:0 | AI Vendor data Ch.1 |  | UINT8 | RO | 0x02 (2dec)
802F:01 | Calibration Offset |  | INT16 | RW | 0x0000 (0dec)
802F:02 | Calibration Gain |  | INT16 | RW | 0x0000 (0dec)
Index 8030 AI Settings Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
8030:0 | AI Settings Ch.2 |  | UINT8 | RO | 0x18 (24dec)
8030:01 | Enable user scale |  | BOOLEAN | RW | 0x00 (0dec)
8030:0A | Enable user calibration |  | BOOLEAN | RW | 0x00 (0dec)
8030:0B | Enable vendor calibration |  | BOOLEAN | RW | 0x00 (0dec)
8030:11 | User scale offset |  | INT16 | RW | 0x0000 (0dec)
8030:12 | User scale gain |  | INT32 | RW | 0x02A00000 (44040192dec)
8030:17 | User calibration offset |  | INT16 | RW | 0x0000 (0dec)
8030:18 | User calibration gain |  | INT16 | RW | 0x0000 (0dec)
Index 803F AI Vendor data Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
803F:0 | AI Vendor data Ch.2 |  | UINT8 | RO | 0x02 (2dec)
803F:01 | Calibration Offset |  | INT16 | RW | 0x0000 (0dec)
803F:02 | Calibration Gain |  | INT16 | RW | 0x0000 (0dec)
Index 8040 AI Settings Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
8040:0 | AI Settings Ch.3 |  | UINT8 | RO | 0x18 (24dec)
8040:01 | Enable user scale |  | BOOLEAN | RW | 0x00 (0dec)
8040:0A | Enable user calibration |  | BOOLEAN | RW | 0x00 (0dec)
8040:0B | Enable vendor calibration |  | BOOLEAN | RW | 0x00 (0dec)
8040:11 | User scale offset |  | INT16 | RW | 0x0000 (0dec)
8040:12 | User scale gain |  | INT32 | RW | 0x02A00000 (44040192dec)
8040:17 | User calibration offset |  | INT16 | RW | 0x0000 (0dec)
8040:18 | User calibration gain |  | INT16 | RW | 0x0000 (0dec)
Index 804F AI Vendor data Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
804F:0 | AI Vendor data Ch.3 |  | UINT8 | RO | 0x02 (2dec)
804F:01 | Calibration Offset |  | INT16 | RW | 0x0000 (0dec)
804F:02 | Calibration Gain |  | INT16 | RW | 0x0000 (0dec)
Index 8050 AI Settings Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
8050:0 | AI Settings Ch.4 |  | UINT8 | RO | 0x18 (24dec)
8050:01 | Enable user scale |  | BOOLEAN | RW | 0x00 (0dec)
8050:0A | Enable user calibration |  | BOOLEAN | RW | 0x00 (0dec)
8050:0B | Enable vendor calibration |  | BOOLEAN | RW | 0x00 (0dec)
8050:11 | User scale offset |  | INT16 | RW | 0x0000 (0dec)
8050:12 | User scale gain |  | INT32 | RW | 0x02A00000 (44040192dec)
8050:17 | User calibration offset |  | INT16 | RW | 0x0000 (0dec)
8050:18 | User calibration gain |  | INT16 | RW | 0x0000 (0dec)
Index 805F AI Vendor data Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
805F:0 | AI Vendor data Ch.4 |  | UINT8 | RO | 0x02 (2dec)
805F:01 | Calibration Offset |  | INT16 | RW | 0x0000 (0dec)
805F:02 | Calibration Gain |  | INT16 | RW | 0x0000 (0dec)
Index 8060 AI Settings Ch.5
Index (hex) | Name | Meaning | Data type | Flags | Default
8060:0 | AI Settings Ch.5 |  | UINT8 | RO | 0x18 (24dec)
8060:01 | Enable user scale |  | BOOLEAN | RW | 0x00 (0dec)
8060:0A | Enable user calibration |  | BOOLEAN | RW | 0x00 (0dec)
8060:0B | Enable vendor calibration |  | BOOLEAN | RW | 0x00 (0dec)
8060:11 | User scale offset |  | INT16 | RW | 0x0000 (0dec)
8060:12 | User scale gain |  | INT32 | RW | 0x02A00000 (44040192dec)
8060:17 | User calibration offset |  | INT16 | RW | 0x0000 (0dec)
8060:18 | User calibration gain |  | INT16 | RW | 0x0000 (0dec)
Index 806F AI Vendor data Ch.5
Index (hex) | Name | Meaning | Data type | Flags | Default
806F:0 | AI Vendor data Ch.5 |  | UINT8 | RO | 0x02 (2dec)
806F:01 | Calibration Offset |  | INT16 | RW | 0x0000 (0dec)
806F:02 | Calibration Gain |  | INT16 | RW | 0x0000 (0dec)
Index 8070 AI Settings Ch.6
Index (hex) | Name | Meaning | Data type | Flags | Default
8070:0 | AI Settings Ch.6 |  | UINT8 | RO | 0x18 (24dec)
8070:01 | Enable user scale |  | BOOLEAN | RW | 0x00 (0dec)
8070:0A | Enable user calibration |  | BOOLEAN | RW | 0x00 (0dec)
8070:0B | Enable vendor calibration |  | BOOLEAN | RW | 0x00 (0dec)
8070:11 | User scale offset |  | INT16 | RW | 0x0000 (0dec)
8070:12 | User scale gain |  | INT32 | RW | 0x02A00000 (44040192dec)
8070:17 | User calibration offset |  | INT16 | RW | 0x0000 (0dec)
8070:18 | User calibration gain |  | INT16 | RW | 0x0000 (0dec)
Index 807F AI Vendor data Ch.6
Index (hex) | Name | Meaning | Data type | Flags | Default
807F:0 | AI Vendor data Ch.6 |  | UINT8 | RO | 0x02 (2dec)
807F:01 | Calibration Offset |  | INT16 | RW | 0x0000 (0dec)
807F:02 | Calibration Gain |  | INT16 | RW | 0x0000 (0dec)
Index 8080 SAI Settings
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8080:0 | SAI Settings |  |  | UINT8 | RO | 0x11 (17dec)
8080:0D | Mode | permitted values: |  | UINT16 | RW | 0x0000 (0dec)
 |  | 4 | 1 Hz
 |  | 5 | 10 Hz
 |  | 6 | 25 Hz
 |  | 7 | 50 Hz
 |  | 8 | 100 Hz
 |  | 9 | 200 Hz
 |  | 10 | 400 Hz
 |  | 11 | 1600 Hz
 |  | 12 | 5000 Hz
8080:11 | Range | permitted values: |  | UINT16 | RW | 0x0000 (0dec)
 |  | 3 | +/- 2G
 |  | 4 | +/- 4G
 |  | 5 | +/- 8G
 |  | 6 | +/-16G


Standard objects (0x1000-0x1FFF)

CoE parameters (EP1816-xxxx only) [image] EP1816-3008 - Object description and parameterization [image] Standard objects (0x1000-0x1FFF)
Standard objects (0x1000-0x1FFF)
The standard objects have the same meaning for all EtherCAT slaves.
Index 1000Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x00001389 (5001dec)
Index 1008Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EP1816-3008
Index 1009Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO |
Index 100ASoftware version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO | 03
Index 1011 Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters |  | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 |  | UINT32 | RW | 0x00000000 (0dec)
Index 1018Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x05E44052 (98844754dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the low word (bit 0-15) indicates the special terminal number, the high word (bit 16-31) refers to the device description | UINT32 | RO | 0x00000000 (0dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the low byte (bit 0-7) of the low word contains the year of production, the high byte (bit 8-15) of the low word contains the week of production, the high word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 Backup parameter handling
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling |  | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum |  | UINT32 | RO | 0x00000000 (0dec)
Index 1A00 DIG TxPDO-Map Inputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A00:0 | DIG TxPDO-Map Inputs Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x09 (9dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (DIG Inputs Ch.1), entry 0x01 (Input 1)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (DIG Inputs Ch.1), entry 0x02 (Input 2)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (DIG Inputs Ch.1), entry 0x03 (Input 3)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (DIG Inputs Ch.1), entry 0x04 (Input 4)) | UINT32 | RO | 0x6000:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (DIG Inputs Ch.1), entry 0x05 (Input 5)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (DIG Inputs Ch.1), entry 0x06 (Input 6)) | UINT32 | RO | 0x6000:06, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (DIG Inputs Ch.1), entry 0x07 (Input 7)) | UINT32 | RO | 0x6000:07, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (DIG Inputs Ch.1), entry 0x08 (Input 8)) | UINT32 | RO | 0x6000:08, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1A01 DIG TxPDO-Map Inputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A01:0 | DIG TxPDO-Map Inputs Ch.2 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x09 (9dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DIG Inputs Ch.2), entry 0x01 (Input 1)) | UINT32 | RO | 0x6010:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (DIG Inputs Ch.2), entry 0x02 (Input 2)) | UINT32 | RO | 0x6010:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (DIG Inputs Ch.2), entry 0x03 (Input 3)) | UINT32 | RO | 0x6010:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (DIG Inputs Ch.2), entry 0x04 (Input 4)) | UINT32 | RO | 0x6010:04, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (DIG Inputs Ch.2), entry 0x05 (Input 5)) | UINT32 | RO | 0x6010:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (DIG Inputs Ch.2), entry 0x06 (Input 6)) | UINT32 | RO | 0x6010:06, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (DIG Inputs Ch.2), entry 0x07 (Input 7)) | UINT32 | RO | 0x6010:07, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (DIG Inputs Ch.2), entry 0x08 (Input 8)) | UINT32 | RO | 0x6010:08, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1A02 AI TxPDO-Map Inputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A02:0 | AI TxPDO-Map Inputs Ch.1 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x05 (5dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (13 bits align) | UINT32 | RO | 0x0000:00, 6
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x1C33 (SM input parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x6020:07, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 8
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (AI Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6020:10, 1
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (AI Inputs Ch.1), entry 0x11 (Value)) | UINT32 | RO | 0x6020:11, 16
Index 1A03 AI TxPDO-Map Inputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A03:0 | AI TxPDO-Map Inputs Ch.2 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x05 (5dec)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (13 bits align) | UINT32 | RO | 0x0000:00, 6
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x1C33 (SM input parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x6030:07, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 8
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6030 (AI Inputs Ch.2), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6030:10, 1
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6030 (AI Inputs Ch.2), entry 0x11 (Value)) | UINT32 | RO | 0x6030:11, 16
Index 1A04 AI TxPDO-Map Inputs Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1A04:0 | AI TxPDO-Map Inputs Ch.3 | PDO Mapping TxPDO 5 | UINT8 | RO | 0x05 (5dec)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (13 bits align) | UINT32 | RO | 0x0000:00, 6
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x1C33 (SM input parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x6040:07, 1
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 8
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6040 (AI Inputs Ch.3), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6040:10, 1
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6040 (AI Inputs Ch.3), entry 0x11 (Value)) | UINT32 | RO | 0x6040:11, 16
Index 1A05 AI TxPDO-Map Inputs Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
1A05:0 | AI TxPDO-Map Inputs Ch.4 | PDO Mapping TxPDO 6 | UINT8 | RO | 0x05 (5dec)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (13 bits align) | UINT32 | RO | 0x0000:00, 6
1A05:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x1C33 (SM input parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x6050:07, 1
1A05:03 | SubIndex 003 | 3. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 8
1A05:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6050 (AI Inputs Ch.4), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6050:10, 1
1A05:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6050 (AI Inputs Ch.4), entry 0x11 (Value)) | UINT32 | RO | 0x6050:11, 16
Index 1A06 AI TxPDO-Map Inputs Ch.5
Index (hex) | Name | Meaning | Data type | Flags | Default
1A06:0 | AI TxPDO-Map Inputs Ch.5 | PDO Mapping TxPDO 7 | UINT8 | RO | 0x05 (5dec)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (13 bits align) | UINT32 | RO | 0x0000:00, 6
1A06:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x1C33 (SM input parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x6060:07, 1
1A06:03 | SubIndex 003 | 3. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 8
1A06:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6060 (AI Inputs Ch.5), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6060:10, 1
1A06:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6060 (AI Inputs Ch.5), entry 0x11 (Value)) | UINT32 | RO | 0x6060:11, 16
Index 1A07 AI TxPDO-Map Inputs Ch.6
Index (hex) | Name | Meaning | Data type | Flags | Default
1A07:0 | AI TxPDO-Map Inputs Ch.6 | PDO Mapping TxPDO 8 | UINT8 | RO | 0x05 (5dec)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (13 bits align) | UINT32 | RO | 0x0000:00, 6
1A07:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x1C33 (SM input parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x6070:07, 1
1A07:03 | SubIndex 003 | 3. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 8
1A07:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6070 (AI Inputs Ch.6), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6070:10, 1
1A07:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6070 (AI Inputs Ch.6), entry 0x11 (Value)) | UINT32 | RO | 0x6070:11, 16
Index 1A08 DIG TxPDO-Map Inputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1A08:0 | DIG TxPDO-Map Inputs Device | PDO Mapping TxPDO 9 | UINT8 | RO | 0x04 (4dec)
1A08:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF600 (DIG Inputs), entry 0x01 (Us Undervoltage)) | UINT32 | RO | 0xF600:01, 1
1A08:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF600 (DIG Inputs), entry 0x02 (Up Undervoltage)) | UINT32 | RO | 0xF600:02, 1
1A08:03 | SubIndex 003 | 3. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 13
1A08:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF600 (DIG Inputs), entry 0x0E (Sync error)) | UINT32 | RO | 0xF600:10, 1
Index 1C00Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the sync managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RO | 0x00 (0dec)
Index 1C13 TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RO | 0x09 (9dec)
1C13:01 | Subindex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RO | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RO | 0x1A01 (6657dec)
1C13:03 | Subindex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RO | 0x1A02 (6658dec)
1C13:04 | Subindex 004 | 4. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RO | 0x1A03 (6659dec)
1C13:05 | Subindex 005 | 5. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RO | 0x1A04 (6660dec)
1C13:06 | Subindex 006 | 6. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RO | 0x1A05 (6661dec)
1C13:07 | Subindex 007 | 7. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RO | 0x1A06 (6662dec)
1C13:08 | Subindex 008 | 8. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RO | 0x1A07 (6663dec)
1C13:09 | Subindex 009 | 9. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RO | 0x1A08 (6664dec)
Index 1C33SM input parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchronous with SM 3 Event (no outputs available)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchronous with SM 2 Event (outputs available)
UINT16
RW
0x0022 (34dec)
1C33:02
Cycle time
as 0x1C32:02
UINT32
RW
0x003D0900 (4000000dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: Synchronous with SM 2 Event is supported (outputs available)
▪
Bit 1: Synchronous with SM 3 Event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: Input shift through local event (outputs available)
▪
Bit 4-5 = 10: Input shift with SYNC1 event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08 or 0x1C33:08)
UINT16
RO
0xC007 (49159dec)
1C33:05
Minimum cycle time
as 0x1C32:05
UINT32
RO
0x00030D40 (200000dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:07
Minimum delay time
UINT32
RO
0x00000000 (0dec)
1C33:08
Command
as 0x1C32:08
UINT16
RW
0x0000 (0dec)
1C33:09
Maximum delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:0B
SM event missed counter
as 0x1C32:11
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
as 0x1C32:12
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
as 0x1C32:13
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
as 0x1C32:32
BOOLEAN
RO
0x00 (0dec)


Profile-specific objects (0x6000-0xFFFF)

CoE parameters (EP1816-xxxx only) [image] EP1816-3008 - Object description and parameterization [image] Profile-specific objects (0x6000-0xFFFF)
Profile-specific objects (0x6000-0xFFFF)
The profile-specific objects have the same meaning for all EtherCAT slaves that support the profile 5001.
Index 6000 DIG Inputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
6000:0 | DIG Inputs Ch.1 |  | UINT8 | RO | 0x08 (8dec)
6000:01 | Input 1 |  | BOOLEAN | RO | 0x00 (0dec)
6000:02 | Input 2 |  | BOOLEAN | RO | 0x00 (0dec)
6000:03 | Input 3 |  | BOOLEAN | RO | 0x00 (0dec)
6000:04 | Input 4 |  | BOOLEAN | RO | 0x00 (0dec)
6000:05 | Input 5 |  | BOOLEAN | RO | 0x00 (0dec)
6000:06 | Input 6 |  | BOOLEAN | RO | 0x00 (0dec)
6000:07 | Input 7 |  | BOOLEAN | RO | 0x00 (0dec)
6000:08 | Input 8 |  | BOOLEAN | RO | 0x00 (0dec)
Index 6010 DIG Inputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
6010:0 | DIG Inputs Ch.2 |  | UINT8 | RO | 0x08 (8dec)
6010:01 | Input 1 |  | BOOLEAN | RO | 0x00 (0dec)
6010:02 | Input 2 |  | BOOLEAN | RO | 0x00 (0dec)
6010:03 | Input 3 |  | BOOLEAN | RO | 0x00 (0dec)
6010:04 | Input 4 |  | BOOLEAN | RO | 0x00 (0dec)
6010:05 | Input 5 |  | BOOLEAN | RO | 0x00 (0dec)
6010:06 | Input 6 |  | BOOLEAN | RO | 0x00 (0dec)
6010:07 | Input 7 |  | BOOLEAN | RO | 0x00 (0dec)
6010:08 | Input 8 |  | BOOLEAN | RO | 0x00 (0dec)
Index 6020 AI Inputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
6020:0 | AI Inputs Ch.1 |  | UINT8 | RO | 0x11 (17dec)
6020:07 | Error |  | BOOLEAN | RO | 0x00 (0dec)
6020:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)
6020:11 | Value |  | INT16 | RO | 0x0000 (0dec)
Index 6030 AI Inputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
6030:0 | AI Inputs Ch.2 |  | UINT8 | RO | 0x11 (17dec)
6030:07 | Error |  | BOOLEAN | RO | 0x00 (0dec)
6030:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)
6030:11 | Value |  | INT16 | RO | 0x0000 (0dec)
Index 6040 AI Inputs Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
6040:0 | AI Inputs Ch.3 |  | UINT8 | RO | 0x11 (17dec)
6040:07 | Error |  | BOOLEAN | RO | 0x00 (0dec)
6040:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)
6040:11 | Value |  | INT16 | RO | 0x0000 (0dec)
Index 6050 AI Inputs Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
6050:0 | AI Inputs Ch.4 |  | UINT8 | RO | 0x11 (17dec)
6050:07 | Error |  | BOOLEAN | RO | 0x00 (0dec)
6050:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)
6050:11 | Value |  | INT16 | RO | 0x0000 (0dec)
Index 6060 AI Inputs Ch.5
Index (hex) | Name | Meaning | Data type | Flags | Default
6060:0 | AI Inputs Ch.5 |  | UINT8 | RO | 0x11 (17dec)
6060:07 | Error |  | BOOLEAN | RO | 0x00 (0dec)
6060:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)
6060:11 | Value |  | INT16 | RO | 0x0000 (0dec)
Index 6070 AI Inputs Ch.6
Index (hex) | Name | Meaning | Data type | Flags | Default
6070:0 | AI Inputs Ch.6 |  | UINT8 | RO | 0x11 (17dec)
6070:07 | Error |  | BOOLEAN | RO | 0x00 (0dec)
6070:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)
6070:11 | Value |  | INT16 | RO | 0x0000 (0dec)
Index F000 Modular device profile
Index (hex) | Maximum number of modules>Name | Meaning | UINT16>Data type | RO>Flags | 0x0009 (9dec)>Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance |  | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules |  | UINT16 | RO | 0x0009 (9dec)
Index F008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word |  | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module list
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list |  | UINT8 | RW | 0x09 (9dec)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x00000118 (280dec)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x00000118 (280dec)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x0000012C (300dec)
F010:04 | SubIndex 004 |  | UINT32 | RW | 0x0000012C (300dec)
F010:05 | SubIndex 005 |  | UINT32 | RW | 0x0000012C (300dec)
F010:06 | SubIndex 006 |  | UINT32 | RW | 0x0000012C (300dec)
F010:07 | SubIndex 007 |  | UINT32 | RW | 0x0000012C (300dec)
F010:08 | SubIndex 008 |  | UINT32 | RW | 0x0000012C (300dec)
F010:09 | SubIndex 009 |  | UINT32 | RW | 0x00000168 (360dec)
Index F600 DIG Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
F600:0 | DIG Inputs |  | UINT8 | RO | 0x10 (16dec)
F600:01 | Us Undervoltage |  | BOOLEAN | RO | 0x00 (0dec)
F600:02 | Up Undervoltage |  | BOOLEAN | RO | 0x00 (0dec)
F600:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)


Appendix

Appendix
Appendix
Additional information
•
General operating conditions
•
EtherCAT Box- / EtherCAT P Box - Accessories
•
Version identification of EtherCAT devices
•
Support and Service


General operating conditions

Appendix [image] General operating conditions
General operating conditions
Protection degrees (IP-Code)
The standard IEC 60529 (DIN EN 60529) defines the degrees of protection in different classes.
1. Number: dust protection and touch guard | Definition
0 | Non-protected
1 | Protected against access to hazardous parts with the back of a hand. Protected against solid foreign objects of Ø 50 mm
2 | Protected against access to hazardous parts with a finger. Protected against solid foreign objects of Ø 12.5 mm.
3 | Protected against access to hazardous parts with a tool. Protected against solid foreign objects Ø 2.5 mm.
4 | Protected against access to hazardous parts with a wire. Protected against solid foreign objects Ø 1 mm.
5 | Protected against access to hazardous parts with a wire. Dust-protected. Intrusion of dust is not totally prevented, but dust shall not penetrate in a quantity to interfere with satisfactory operation of the device or to impair safety.
6 | Protected against access to hazardous parts with a wire. Dust-tight. No intrusion of dust.
2. Number: water* protection | Definition
0 | Non-protected
1 | Protected against water drops
2 | Protected against water drops when enclosure tilted up to 15°.
3 | Protected against spraying water. Water sprayed at an angle up to 60° on either side of the vertical shall have no harmful effects.
4 | Protected against splashing water. Water splashed against the disclosure from any direction shall have no harmful effects
5 | Protected against water jets
6 | Protected against powerful water jets
7 | Protected against the effects of temporary immersion in water. Intrusion of water in quantities causing harmful effects shall not be possible when the enclosure is temporarily immersed in water for 30 min. in 1 m depth.
*) These protection classes define only protection against water!
Chemical Resistance
The Resistance relates to the Housing of the IP 67 modules and the used metal parts. In the table below you will find some typical resistance.
Character | Resistance
Steam | at temperatures >100°C: not resistant
Sodium base liquor (ph-Value > 12) | at room temperature: resistant > 40°C: not resistant
Acetic acid | not resistant
Argon (technical clean) | resistant
Key
▪
resistant: Lifetime several months
▪
non inherently resistant: Lifetime several weeks
▪
not resistant: Lifetime several hours resp. early decomposition


EtherCAT Box- / EtherCAT P Box - Accessories

Appendix [image] EtherCAT Box- / EtherCAT P Box - Accessories
EtherCAT Box- / EtherCAT P Box - Accessories
Fixing
Ordering information | Description
ZS5300-0001 | Mounting rail (500 mm x 129 mm)
Marking material, plugs
Ordering information | Description
ZS5000-0000 | Fieldbus Box set M8 (contact labels, plugs)
ZS5000-0002 | Fieldbus Box set M12 (contact labels, plugs)
ZS5000-0010 | plugs M8, IP67 (50 pieces)
ZS5000-0020 | plugs M12, IP67 (50 pieces)
ZS5100-0000 | marking labels, not printed, 4 stripes at 10 pieces
ZS5100-xxxx | printed marking labels, on request
Tools
Ordering information | Description
ZB8800 | torque wrench for M8 cables with knurl, incl. ratchet
ZB8800-0001 | M12 ratchet for torque wrench ZB8800
ZB8800-0002 | M8 ratchet (field assembly) for torque wrench ZB8800
ZB8801-0000 | torque wrench for hexagonal plugs, adjustable
ZB8801-0001 | torque cable key, M8/wrench size 9, for torque wrench ZB8801-0000
ZB8801-0002 | torque cable key, M12/wrench size 13, for torque wrench ZB8801-0000
ZB8801-0003 | torque cable key, M12 field assembly/wrench size 13, for torque wrench ZB8801-0000
Further accessories
Further accessories may be found at the price list for Beckhoff fieldbus components and at the internet under https://www.beckhoff.com


Version identification of EtherCAT devices

Appendix [image] Version identification of EtherCAT devices
Version identification of EtherCAT devices
Designation
A Beckhoff EtherCAT device has a 14-digit designation, made up of
▪
family key
▪
type
▪
version
▪
revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
Notes
▪
The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
▪
EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
▪
The order identifier is made up of
- family key (EL, EP, CU, ES, KL, CX, etc.)
- type (3314)
- version (-0000)
▪
The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
▪
The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Identification number
Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:
Production lot/batch number/serial number/date code/D number
The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02
Exceptions can occur in the IP67 area, where the following syntax can be used (see respective device documentation):
Syntax: D ww yy x y z u
D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB
Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1
Unique serial number/ID, ID number
In addition, in some series each individual module has its own unique serial number.
See also the further documentation in the area
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Terminals with factory calibration certificate and other measuring terminals
Examples of markings
EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
CU2016 switch with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
EP1258-00001 IP67 EtherCAT Box with batch number/ date code 22090101 and unique serial number 158102
EP1908-0002 IP67 EtherCAT Safety Box with batch number/ date code 071201FF and unique serial number 00346070
EL2904 IP20 safety terminal with batch number/ date code 50110302 and unique serial number 00331701
ELM3604-0002 terminal with unique ID number (QR code) 100001051 and serial/ batch number 44160201
Additional information
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Appendix [image] Version identification of EtherCAT devices [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com