EP1816-3008 - EtherCAT-Box with digital inputs and accelerometers

BECKHOFF Fieldbus components

Documentation for

EP1816-3008

EtherCAT-Box with digital inputs and accelerometers

Version: 1.1.0
Date: 2015-07-08

EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.


Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending

The EtherCAT Technology is covered, including but not limited to the following patent applications and patents:
EP1590927, EP1789857, DE102004044764, DE102007017835
with corresponding applications or registrations in various other countries.

The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.

Copyright

© Beckhoff Automation GmbH, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Safety rules

Consider the following safety instructions and descriptions!
Product specific safety instructions are to be found on the following pages or in the areas mounting, wiring, commissioning etc.

Disclaimer

All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH.

Personnel qualification

This description is only intended for the use of trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.

Description of symbols

The following symbols with a adjoining safety advise or notice are used in this documentation. You have to read the safety advices carefully and adhere them strictly!

DANGER 		Acute risk of injury!
If you do not adhere the safety advise adjoining this symbol, there is immediate danger to life and health of individuals!

WARNING 		Risk of injury!
If you do not adhere the safety advise adjoining this symbol, there is danger to life and health of individuals!

CAUTION 		Hazard to individuals!
If you do not adhere the safety advise adjoining this symbol, there is obvious hazard to individuals!

Attention 		Hazard to devices and environment
If you do not adhere the notice adjoining this symbol, there is obvious hazard to materials and environment.

Note 		Note or pointer
This symbol indicates information that contributes to better understanding.


EP1816-3008 - Documentation issue status

BECKHOFF EP1816-3008: Foreword

Documentation issue status

Version Comment
1.1.0
  • Technical data updated
  • Power Connection updated
1.0.0
  • Sample program for angle calculation added
  • Notes about firmware update added
0.5.0
  • Preliminary version (only German)
0.1.0
  • Internal version (only German)

Firm and hardware version

The documentation refers to the firm and hardware status that was valid at the time it was prepared.

The properties of the modules are subject to continuous development and improvement. Modules having earlier production statuses cannot have the same properties as modules with the latest status. Existing properties, however, are always retained and are not changed, so that these modules can always be replaced by new ones.

Documentation version | EP1816-3008
 | Firmware | Hardware
1.1.0 | 01 | 02
1.0.0 | 01 | 02
0.5.0 | 01 | 01
0.1.0 | 01 | 00

The firmware and hardware version (delivery state) can be found in the batch number (D number) printed at the side of the EtherCAT Box.

Syntax of the batch number (D number)

D: WW YY FF HH

WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version

Example with D No. 29 10 02 01:

29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01


EtherCAT Box - Introduction

The EtherCAT system has been extended with EtherCAT Box modules with protection class IP 67. Through the integrated EtherCAT interface the modules can be connected directly to an EtherCAT network without an additional Coupler Box. The high-performance of EtherCAT is thus maintained into each module.

The extremely low dimensions of only 126 x 30 x 26.5 mm (H x W x D) are identical to those of the Fieldbus Box extension modules. They are thus particularly suitable for use where space is at a premium. The small mass of the EtherCAT modules facilitates applications with mobile I/O interface (e.g. on a robot arm). The EtherCAT connection is established via screened M8 connectors.

The robust design of the EtherCAT Box modules enables them to be used directly at the machine. Control cabinets and terminal boxes are now no longer required. The modules are fully sealed and therefore ideally prepared for wet, dirty or dusty conditions.

Pre-assembled cables significantly simplify EtherCAT and signal wiring. Very few wiring errors are made, so that commissioning is optimized. In addition to pre-assembled EtherCAT, power and sensor cables, field-configurable connectors and cables are available for maximum flexibility. Depending on the application, the sensors and actuators are connected through M8 or M12 connectors.

The EtherCAT modules cover the typical range of requirements for I/O signals with protection class IP 67:

  • digital inputs with different filters (3.0 ms or 10 μs)

  • digital outputs with 0.5 or 2 A output current

  • analog inputs and outputs with 16 bit resolution

  • Thermocouple and RTD inputs

  • Stepper motor modules

XFC (eXtreme Fast Control Technology) modules, including inputs with time stamp, are also available.

EtherCAT Box with M8 connections for sensors/actuators | EtherCAT Box with M12 connections for sensors/actuators

Note 		Basic EtherCAT documentation
You will find a detailed description of the EtherCAT system in the Basic System Documentation for EtherCAT, which is available for download from our website (www.beckhoff.com) under Downloads.

Note 		XML files
You will find XML files (XML Device Description Files) for Beckhoff EtherCAT modules on our website (www.beckhoff.com) under Downloads, in the Configuration Files area.


EP1816-3008 - Introduction

16 digital inputs 24 VDC, 2 x 3G acceleration sensors

The EP1816-3008 EtherCAT Box with digital inputs acquires binary control signals from the process level and transfers them, with electrical isolation, to the controller. The signal status is indicated by light emitting diodes; the signal connection is made through a 25-pin Sub-D socket.

In addition the EP1816-3008 has two 3-axis acceleration sensors.

The sensors are supplied from the control voltage Us. The load voltage Up is not used in the input module, but may be connected in order to be relayed downstream.

Installation

UL requirements for UL-approved modules


EP1816-3008 - Technical Data

BECKHOFF EP1816-3008: Product overview

Technical data

Technical data | EP1816-3008
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Number of inputs | 16
Input connections | 25 pin SUB-D socket
Rated input voltage | 24 VDC (-15%/+20%)
Input filter | 10 µs
"0" signal voltage | -3...+5 V (EN 61131-2, type 3)
"1" signal voltage | +11...+30 V (EN 61131-2, type 3)
Input current | typically 3 mA (EN 61131-2, Type 3)
Minimum cycle time | > 500 µsec
Diagnostics | Undervoltage detection < 18 VDC for Us and Up
Supply of the module circuitry | from the control voltage Us
Current consumption of the module circuitry | typically 120 mA
Sensor supply | from the control voltage Us
Current consumption of the sensors | max. 0.5 A, short-circuit-proof overall
Power supply connection | Feed: 1 x M8 plug, 4-pin Onward connection: 1 x M8 socket, 4-pin
Electrical isolation | Control voltage/fieldbus: yes
Permissible ambient temperature during operation | -25°C ... +60°C 0°C ... +55°C (according to cULus, see UL requirements)
Permissible ambient temperature during storage | -40°C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (according to EN 60529)
Installation position | variable
Approvals | CE, cULus
Technical data | Acceleration sensors
Sensor type | Two 3-axis sensors / offset by 90°
Resolution | 16 Bit Raw-Data; 1mg / LSB
Measuring range | ±2g/±4g/±8g/±16g configurable
Special features | Self-test
Scan frequency | 1 Hz to 5 kHz

Note 		Maximum transmission frequency
The EP1816-3008 reads sensors with a scan frequency from 1 Hz up to 5 kHz. Because the minimum cycle time is limited to 500 µs due to the internal processing, a maximum transmission frequency of 2,5 kHz results.


EP1816-3008 - Process image

DIG Inputs Channel 1 and 2
The 16 digital inputs of the module can be found under DIG Inputs Channel n.
AI Inputs Channel 1 to 6
The data for the two acceleration sensors can be found under AI inputs Channel
  • Status Error: error relating to the communication with the acceleration sensor
  • Value: 16 bit acceleration value

AI Inputs Channel 1 value: sensor 1, axis +X

AI Inputs Channel 2 value: sensor 1, axis +Y

AI Inputs Channel 3 value: sensor 1, axis -Z

AI Inputs Channel 1 value: sensor 2, axis +Y

AI Inputs Channel 2 value: sensor 2, axis -X

AI Inputs Channel 3 value: sensor 2, axis -Z
DIG Inputs Device
16 bit status bit of the module


EtherCAT Box - Dimensions

BECKHOFF EtherCAT Box: Mounting and cabling

Dimensions

All dimensions are given in millimeters.

General

Technical data | EtherCAT Box
Housing material | PA6 (polyamide), casting compound: Polyurethane
Mounting | 2 x fastening holes for M3
Metal parts | Brass, nickel-plated
Contacts | CuZn, gold-plated
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMC resistance/emission | IEC EN 50082-2 / EN 50081-2
Permissible ambient temperature during operation | 0 ... 55°C
Permissible ambient temperature during storage | -25 ... + 85°C
Installation position | variable
Protection class | IP65/66/67 when screwed together
Dimensions (H x W x D) | approx. 126 x 30 x 26.5 mm
Approvals | CE
Weight | approx. 120 g - 200 g, depending on module type


EPxxxx - Fixing

BECKHOFF EtherCAT Box: Mounting and cabling

Fixing

Note 		Note or pointer
While mounting the modules, protect all connectors, especially the IP-Link, against contamination!

Only with connected cables or plugs the protection class IP67 is guaranteed!
Unused connectors have to be protected with the right plugs! See for plug sets in the catalogue.

Modules with narrow housing are mounted with two M3 bolts.
Modules with wide housing are mounted with two M3 bolts to the fixing holes located at the corners or mounted with two M4 bolts to the fixing holes located centrally.

The bolts must be longer than 15 mm. The fixing holes of the modules are not threaded.

When assembling, remember that the fieldbus connectors increases the overall height. See chapter accessories.

Mounting Rail ZS5300-0001

The mounting rail ZS5300-0001 (500 mm x 129 mm) allows the time saving assembly of modules.

The rail is made of stainless steel, 1.5 mm thick, with already pre-made M3 threads for the modules. The rail has got 5.3 mm slots to mount it via M5 screws to the machine.

The mounting rail is 500 mm long, that way 15 narrow modules can be mounted with a distance of 2 mm between two modules. The rail can be cut to length for the application.


EPxxxx - Nut tourque for connectors

BECKHOFF EtherCAT Box: Mounting and cabling

Nut torque for connectors

M8 connectors

It is recommended to pull the M8 connectors tight with a nut torque of 0.4 Nm.

M12 connectors

It is recommended to pull the M12 connectors tight with a nut torque of 0.6 Nm.

Torque socket wrenches

Note 		Ensure the right torque
Use the torque socket wrenches available by Beckhoff to pull the connectors tight (see accessories)!


EtherCAT connection

For the incoming and ongoing EtherCAT connection,

  • the EtherCAT Box (EPxxxx) has two M8 sockets, marked in green
  • the Coupler Box (FBB-x110) has two M12 sockets
EtherCAT Box: M8 | Coupler Box: M12

Assignment

There are various different standards for the assignment and colors of connectors and cables for Ethernet/EtherCAT.

Ethernet/EtherCAT |  | Plug connector |  |  | Cable |  | Standard
Signal | Description | M8 | M12 | RJ451 | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 and old versions of ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | Transmit Data+ | Pin 1 | Pin 1 | Pin 1 | yellow2 | orange/white3 | white/orange
Tx - | Transmit Data- | Pin 4 | Pin 3 | Pin 2 | orange2 | orange3 | orange
Rx + | Receive Data+ | Pin 2 | Pin 2 | Pin 3 | white2 | blue/white3 | white/green
Rx - | Receive Data- | Pin 3 | Pin 4 | Pin 6 | blue2 | blue3 | green
Shield | Shield | Housing |  | Shroud | Screen | Screen | Screen

1) colored markings according to EN 61918 in the four-pin RJ45 connector ZS1090-0003

2) wire colors according to EN 61918

3) wire colors

Note 		Assimilation of color coding for cable ZB9030, ZB9032 and ZK1090-3xxxx-xxxx (with M8 connectors)

For unification the prevalent cables ZB9030, ZB9032 and ZK1090-3xxx-xxxx
this means the pre assembled cables with M8 connectors
were changed to the colors of EN61918 (yellow, orange, white, blue).

So different color coding exists. But the electrical properties are absolutely identical.

EtherCAT connectors

The following connectors can be supplied for use in Beckhoff EtherCAT systems.

Designation | Plug connector | Comment
ZS1090-0003 | RJ45 | four-pin, IP20, for field assembly
ZS1090-0004 | M12 | four-pin, IP67, for field assembly
ZS1090-0005 | RJ45 | eight-pin, IP20, for field assembly, suitable for GigaBit Ethernet
ZS1090-0006 | M8 | four-pin, IP67, for field assembly


EPxxxx - Fieldbus LEDs

BECKHOFF EtherCAT Box: Installation

EtherCAT- Fieldbus LEDs

LED displays
LED | Display | Meaning
IN L/A | off | no connection to the preceding EtherCAT module
 | Lit | LINK: connection to the preceding EtherCAT module
 | flashing | ACT: Communication with the preceding EtherCAT module
OUT L/A | off | no connection to the following EtherCAT module
 | Lit | LINK: connection to the following EtherCAT module
 | flashing | ACT: Communication with the following EtherCAT module
Run | off | Status of the EtherCAT module is Init
 | flashes quickly | Status of the EtherCAT module is pre-operational
 | flashes slowly | Status of the EtherCAT module is safe-operational
 | Lit | Status of the EtherCAT module is operational

Note 		EtherCAT statuses
The various statuses in which an EtherCAT module may be found are described in the Basic System Documentation for EtherCAT, which is available for download from our website (www.beckhoff.com) under Downloads.


EtherCAT cable

For connecting EtherCAT devices only shielded Ethernet cables that meet the requirements of at least category 5 (CAt5) according to EN 50173 or ISO/IEC 11801 should be used.

Note 		Recommendations about cabling
You may get detailed recommendations about cabling EtherCAT from the documentation "Recommendations for the design of the infrastructure for EtherCAT/Ethernet", that is available for download at www.Beckhoff.com.

EtherCAT uses 4 wires for signal transfer. Due to automatic cable detection (auto-crossing) symmetric (1:1) or cross-over cables can be used between EtherCAT devices from Beckhoff.

A selection of cables for EtherCAT follows. Other cables with various lengths will be found in the full Beckhoff catalogue, and under www.beckhoff.com.

Sold by meter

Designation | Description
ZB9010 | CAT 5e, 4-core, for fixed laying, not for M8 connectors
ZB9020 | CAT 5e, 4-core, suitable for drag chain use, not for M8 connectors
ZB9030 | PVC, dmr. 4.9 mm for M8 connectors
ZB9031 | PUR, dmr. 4.8 mm for M8 connectors
ZB9032 | PUR, dmr. 5.4 mm for M8 connectors, high flexibility

Preassembled cables

ZK1090-3100-0xxx: M8 plug - open end, PUR, high flexibility, preassembled

ZK1090-3100- | 0020 | 0050
Length | 2 m | 5 m

ZK1090-3100-3xxx: M8 plug - open end, PVC, high flexibility, preassembled

ZK1090-3100- | 3020 | 3050
Length | 2 m | 5 m

ZK1090-3131-0xxx: 2 x M8 plug, PUR, high flexibility, ready-assembled

ZK1090-3131- | 0001 | 0003 | 0005 | 0010 | 0020 | 0030 | 0040 | 0050 | 0075 | 0100
Length | 0.15 m | 0.3 m | 0.5 m | 1.0 m | 2.0 m | 3.0 m | 4.0 m | 5.0 m | 7.5 m | 10 m
ZK1090-3131- | 0150 | 0200 | 0250 | 0300 | 0350 | 0400 | 0450 | 0500
Length | 15 m | 20 m | 25 m | 30 m | 35 m | 40 m | 45 m | 50 m

ZK1090-3131-3xxx: 2 x M8 plug, PVC, ready-assembled

ZK1090-3131- | 3020 | 3030 | 3040 | 3050 | 3075 | 3100 | 3150 | 3200 | 3250 | 3300
Length | 2.0 m | 3.0 m | 4.0 m | 5.0 m | 7.5 m | 10 m | 15 m | 20 m | 25 m | 30 m
ZK1090-3131- | 3350 | 3400 | 3450 | 3500
Length | 35 m | 40 m | 45 m | 50 m

ZK1090-3132-0xxx: M8 plug - M8 socket, PUR, high flexibility, ready-assembled

ZK1090-3132- | 0002 | 0004 | 0020 | 0050 | 0075 | 0100 | 0150 | 0200 | 0250 | 0300
Length | 0.2 m | 0.4 m | 2.0 m | 5.0 m | 7.5 m | 10 m | 15 m | 20 m | 25 m | 30 m
ZK1090-3132- | 0400 | 0500
Length | 40 m | 50 m

ZK1090-3132-3xxx: M8 plug - M8 socket, PVC, ready-assembled

ZK1090-3132- | 0020 | 0050 | 0100 | 0150 | 0200 | 0250 | 0300 | 0400 | 0500
Length | 2.0 m | 5.0 m | 10 m | 15 m | 20 m | 25 m | 30 m | 40 m | 50 m

ZK1090-3191-0xxx: M8 plug - RJ45 plug, PUR, high flexibility, ready-assembled

ZK1090-3191- | 0004 | 0005 | 0010 | 0020 | 0035 | 0050 | 0070 | 0100 | 0150 | 0200
Length | 0.4 m | 0.5 m | 1 m | 2 m | 3,5 m | 5 m | 7 m | 10 m | 15 m | 20 m
ZK1090-3191- | 0250
Length | 25 m

ZK1090-3191-3xxx: M8 plug - RJ45 plug, PVC, ready-assembled

ZK1090-3191- | 3005 | 3020 | 3050
Length | 0.5 m | 2 m | 5 m

ZK1090-3291-3xxx: M8 socket - RJ45 plug, PVC, ready-assembled

ZK1090-3291- | 0004 | 0005 | 0010 | 0020 | 0050 | 100 | 200 | 250
Length | 0.4 m | 0.5 m | 1 m | 2 m | 5 m | 10 m | 20 m | 25 m

ZK1090-3161-0xxx: M8 plug - M12 plug (d-coded), ready-assembled

ZK1090-3161- | 0010 | 0020 | 0050
Length | 1.0 m | 2.0 m | 5.0 m

ZK1090-6161-0xxx: 2 x M12 plug (d-coded), PVC, ready-assembled

ZK1090-6161- | 0005 | 0010 | 0020 | 0025 | 0050 | 0100
Length | 0.5 m | 1.0 m | 2.0 m | 2.5 m | 5.0 m | 10 m

ZK1090-6191-0xxx: M12 plug - RJ45 plug, ready-assembled

ZK1090-6191- | 0005 | 0010 | 0020 | 0025 | 0050 | 0100
Length | 0.5 m | 1.0 m | 2.0 m | 2.5 m | 5.0 m | 10 m

ZK1090-6292-0xxx: M12 socket - RJ45 plug, ready-assembled

ZK1090-6292- | 0005 | 0020 | 0050 | 0100
Length | 0.5 m | 2 m | 5 m | 10 m

ZK1090-9191-0xxx: 2 x RJ45 plug, patch cable

ZK1090-9191- | 0001 | 0002 | 0005 | 0010 | 0020 | 0030 | 0040 | 0050 | 0100 | 0150
Length | 0.17 m | 0.26 m | 0.5 m | 1.0 m | 2.0 m | 3.0 m | 4.0 m | 5.0 m | 10 m | 15 m
ZK1090-9191- | 0200 | 0250 | 0300 | 0350 | 0400 | 0450 | 0500
Length | 20 m | 25 m | 30 m | 35 m | 40 m | 45 m | 50 m


EtherCAT Box - Power Connection

BECKHOFF EtherCAT Box: Mounting and cabling

Power Connection

The feeding and forwarding of supply voltages is done via two M8 connectors at the bottom end of the modules:

  • IN: left M8 connector for feeding the supply voltages
  • OUT: right M8 connector for forwarding the supply voltages

PIN assignment
Pin | Voltage
1 | Control voltage Us, +24 VDC
2 | Auxiliary voltage Up, +24 VDC
3 | GNDs* | *) may be connected internally to each other depending on the module: see specific module descriptions
4 | GNDp*

The pins M8 connectors carry a maximum current of 4 A.

Two LEDs display the status of the supply voltages.

Attention 		Don't confuse the power connectors with the EtherCAT connectors!
Never connect the power cables (M8, 24 VDC) with the green marked EtherCAT sockets of the EtherCAT Box Modules! This can damage the modules!

Control voltage Us: 24 VDC

Power is supplied to the fieldbus, the processor logic, the inputs and the sensors from the 24 VDC control voltage Us. The control voltage is electrically isolated from the fieldbus circuitry.

Auxiliary voltage Up 24 VDC

The Auxiliary voltage Up supplies the digital outputs; it can be brought in separately. If the load voltage is switched off, the fieldbus functions and the power supply and functionality of the inputs are retained.

Redirection of the supply voltages

The IN and OUT power connections are bridged in the module (not IP204x-Bxxx and IE204x). The supply voltages Us and Up can thus easily be transferred from EtherCAT Box to EtherCAT Box.

Attention 		Pay attention to the maximum permissible current!
Pay attention also for the redirection of the supply voltages Us and Up, the maximum permissible current for M8 connectors of 4 A must not be exceeded!

Supply via EP92x4-0023 PowerBox modules

If the machine requires higher current or if the EtherCAT Box Modules are installed far away from the control cabinet with included power supply, the usage of four cannel power distribution modules EP9214 or EP9224 (with integrated data logging, see www.beckhoff.com/EP9224) is recommended.

With these modules intelligent power distribution concepts with up to 2 x 16 A and a maximum of 2.5 mm² cable cross-section can be realized.

Electrical isolation

Digital modules

In the digital input/output modules, the grounds of the control voltage (GNDs) and the auxiliary voltage (GNDp) are connected to each other!

Check this at the documentation of each used EtherCAT Box.

Analog modules

In the analog input/output modules the grounds of the control voltage (GNDs) and the auxiliary voltage (GNDp) are separated from each other in order to ensure electrical isolation of the analog signals from the control voltage.

In some of the analog modules the sensors or actuators are supplied by Up - this means, for instance, that in the case of 0...10 V inputs, any reference voltage (0...30 V) may be connected to Up; this is then available to the sensors (e.g. smoothed 10 V for measuring potentiometers).

Details of the power supply may be taken from the specific module descriptions.

Attention 		Electrical isolation may be cancelled!
If digital and analog fieldbus boxes are connected directly via four-core power leads, the analog signals in the fieldbus boxes may be no longer electrically isolated from the control voltage!


EtherCAT Box - Status LEDs for power supply

BECKHOFF EtherCAT Box: Mounting and cabling

Status LEDs for power supply

LED | Display | Meaning
Us (Control voltage) | off | The power supply voltage Us is not present
 | green illuminated | The power supply voltage Us is present
 | reed illuminated | Because of overload (current > 0.5 A) the sensor supply generated from power supply voltage Us was switched off for all sensors fed from this.
Up (Auxiliary voltage) | off | The power supply voltage Up is not present
 | green illuminated | The power supply voltage Up is present


Power cables

Ordering data

Order designation | Power lead | Screw-in connector | Contacts | Cross- section | Length
ZK2020-3200-0020 | Straight socket, open end | M8 | 4-pin | 0.34 mm2 | 2.00 m
ZK2020-3200-0050 |  |  |  |  | 5.00 m
ZK2020-3200-0100 |  |  |  |  | 10.00 m
ZK2020-3400-0020 | Angled socket, open end |  |  |  | 2.00 m
ZK2020-3400-0050 |  |  |  |  | 5.00 m
ZK2020-3400-0100 |  |  |  |  | 10.00 m
ZK2020-3132-0001 | Straight socket, straight socket |  |  |  | 0.15 m
ZK2020-3132-0005 |  |  |  |  | 0.50 m
ZK2020-3132-0010 |  |  |  |  | 1.00 m
ZK2020-3132-0020 |  |  |  |  | 2.00 m
ZK2020-3132-0050 |  |  |  |  | 5.00 m
ZK2020-3334-0001 | Angled socket, angled socket |  |  |  | 0.15 m
ZK2020-3334-0005 |  |  |  |  | 0.50 m
ZK2020-3334-0010 |  |  |  |  | 1.00 m
ZK2020-3334-0020 |  |  |  |  | 2.00 m
ZK2020-3334-0050 |  |  |  |  | 5.00 m

Further available power cables may be found in the Beckhoff catalog or on our internet pages (http://www.beckhoff.com).

Technical data

Technical data
Rated voltage according to IEC60 664-1 | 60 VAC / 75 VDC
Contamination level according to IEC 60 664-1 | 3/2
Insulation resistance IEC 60 512-2 | >109 W
Current carrying capacity according to IEC 60512-3 | 4 A
Volume resistance according to IEC 60512-2 | < 5 mW
Protection class according to IEC 60529 | IP65/66/67, when screwed together
Ambient temperature | -30°C to +80°C


ZK2020 - Power cable conductor losses

BECKHOFF Fieldbus Components: Mounting and cabeling

Power cable conductor losses

The ZK2020-xxxx-yyyy power cables should not exceed the total length of 15 m at 4 A (with continuation). When planning the cabling, note that at 24 V nominal voltage, the functionality of the module can no longer be assured if the voltage drop reaches 6 V. Variations in the output voltage from the power supply unit must also be taken into account.

Example

8 m power cable with 0.34 mm² cross-section has a voltage drop of 3.2 V at 4 A.


EtherCAT Box - UL Requirements

BECKHOFF EtherCAT Box: Mounting and cabling

UL Requirements

The installation of the EtherCAT Box Modules certified by UL has to meet the following requirements.

Supply voltage

CAUTION 		CAUTION!
For the compliance of the UL requirements the EtherCAT Box Modules should only be supplied
  • by a 24 VDC supply voltage, supplied by an isolating source and protected by means of a fuse (in accordance with UL248), rated maximum 4 Amp, or
  • by a 24 VDC power source, that has to satisfy NEC class 2.
    A NEC class 2 power supply shall not be connected in series or parallel with another (class 2) power source!
This UL requirements are valid for all supply voltages of all marked EtherCAT Box Modules!

CAUTION 		CAUTION!
To meet the UL requirements, the EtherCAT Box Modules must not be connected to unlimited power sources!

Networks

CAUTION 		CAUTION!
To meet the UL requirements, EtherCAT Box Modules must not be connected to telecommunication networks!

Ambient temperature range

CAUTION 		CAUTION!
To meet the UL requirements, EtherCAT Box Modules has to be operated only at an ambient temperature range of 0 to 55°C!

Marking for UL

All EtherCAT Box Modules certified by UL (Underwriters Laboratories) are marked with the following label.


EP1816-3008 - Signal connection

BECKHOFF EP1816-3008: Mounting and cabling

Signal connection

Digital inputs/outputs, 24 VDC: 25 pin SUB-D socket

The digital input modules EP100x acquire the binary control signals from the process level and transmit them to the higher-level automation device.

The signal connection is made through a 25-pin sub-D socket.

The sensors are supplied from the control voltage Us. The load voltage Up is not used in the input module, but may be connected in order to be relayed downstream.

EP1816-3008

Attention 		Please note the special pin assignment of the EP1816-3008.
The pin assignment of the EP1816-3008 differs from the EP1816-0008!
In particular, the supply voltage and GND connections differ.
Incorrect connection could damage the terminal devices, if these are not short-circuit-proof.


EP1816-3008 - Acceleration sensors

BECKHOFF EP1816-3008: Mounting and cabling

Acceleration sensors

2 x 3G acceleration sensors

The EP1816-3008 EtherCAT Box features 2 3-axis acceleration sensors.

They are fitted on the underside the PCB at 90° angles.

Fig: Location of the acceleration sensors

The image shows a top view and a side view of the EtherCAT Box. It shows the location of the acceleration sensors within the Box. The green line indicates the location of the PCB. The acceleration sensors are numbered 1 and 2. They are mounted on the underside of the PCB.

In this position, gravity (which is a form of acceleration), is displayed as a negative value when the Box is in its normal operating position on a flat, level surface, e.g. on a test bench.

Process values | Allocated acceleration value
AI Inputs Channel1 value | Sensor 1, +X axis
AI Inputs Channel2 value | Sensor 1, +Y axis
AI Inputs Channel3 value | Sensor 1, -Z axis
AI Inputs Channel4 value | Sensor 2, +Y axis
AI Inputs Channel5 value | Sensor 2, -X axis
AI Inputs Channel6 value | Sensor 2, -Z axis


EtherCAT Box - Inserting into the EtherCAT network

BECKHOFF EtherCAT Box: Commissioning/Configuration

Inserting into the EtherCAT network

Note 		Installation of the latest XML device description
Please ensure that you have installed the latest XML device description in TwinCAT. This can be downloaded from the Beckhoff website (http://www.beckhoff.de/english/default.htm?download/elconfg.htm) and installed according to the installation instructions.

At the Beckhoff TwinCAT System Manager the configuration tree can be build in two different ways:

  • by scanning for existing hardware (called "online") and
  • by manual inserting/appending of fieldbus devices, couplers and slaves.

Automatic scanning in of the box

  • The EtherCAT system must be in a safe, de-energized state before the EtherCAT modules are connected to the EtherCAT network!
  • Switch on the operating voltage, open the TwinCAT System Manager (Config mode), and scan in the devices (see Fig. 1). Acknowledge all dialogs with "OK", so that the configuration is in "FreeRun" mode.

Fig. 1: Scanning in the EtherCAT configuration (I/O Devices-> right-click -> Scan Devices...

Appending a module manually

  • The EtherCAT system must be in a safe, de-energized state before the EtherCAT modules are connected to the EtherCAT network!
  • Switch on the operating voltage, open the TwinCAT System Manager (Config mode)
  • Append a new I/O device (see Fig. 2). In the dialog that appears select the device EtherCAT (Direct Mode), see Fig. 3 and confirm with OK.

Fig. 2: Appending a new I/O device (I/O Devices-> right-click -> Append Device... )

Fig. 3: Selecting the device EtherCAT

  • Append a new box (see Fig. 4).

Fig. 4: Appending a new box (Device -> right-click -> Append Box... )

  • In the dialog that appears select the desired box, and confirm with OK.

Fig. 5: Selecting a Box

Fig. 6: Appended Box in the TwinCAT tree


EPxxxx - Configuration via TwinCAT System Manager

BECKHOFF EtherCAT Box: Configuration

Configuration via TwinCAT System Manager

In the left-hand window of the TwinCAT System Manager, click on the branch of the EtherCAT Box you wish to configure.

In the right-hand window of the TwinCAT System manager, various tabs are now available for configuring the EtherCAT Box.

General tab

Name | Name of the EtherCAT device
Id | Number of the EtherCAT device
Type | EtherCAT device type
Comment | Here you can add a comment (e.g. regarding the system).
Disabled | Here you can deactivate the EtherCAT device.
Create symbols | Access to this EtherCAT slave via ADS is only available if this control box is activated.

EtherCAT tab

Type | EtherCAT device type
Product/Revision | Product and revision number of the EtherCAT device
Auto Inc Addr. | Auto increment address of the EtherCAT device. The auto increment address can be used for addressing each EtherCAT device in the communication ring through its physical position. Auto increment addressing is used during the start-up phase when the EtherCAT master allocates addresses to the EtherCAT devices. With auto increment addressing the first EtherCAT slave in the ring has the address 0000hex. For each further slave the address is decremented by 1 (FFFFhex, FFFEhex etc.).
EtherCAT Addr. | Fixed address of an EtherCAT slave. This address is allocated by the EtherCAT master during the start-up phase. Tick the control box to the left of the input field in order to modify the default value.
Previous Port | Name and port of the EtherCAT device to which this device is connected. If it is possible to connect this device with another one without changing the order of the EtherCAT devices in the communication ring, then this combination field is activated and the EtherCAT device to which this device is to be connected can be selected.
Advanced Settings | This button opens the dialogs for advanced settings.

The link at the bottom of the tab points to the product page for this EtherCAT device on the web.

Process Data tab

Indicates the configuration of the process data. The input and output data of the EtherCAT slave are represented as CANopen process data objects (PDO). The user can select a PDO via PDO assignment and modify the content of the individual PDO via this dialog, if the EtherCAT slave supports this function.

Sync Manager

Lists the configuration of the Sync Manager (SM).
If the EtherCAT device has a mailbox, SM0 is used for the mailbox output (MbxOut) and SM1 for the mailbox input (MbxIn).
SM2 is used for the output process data (outputs) and SM3 (inputs) for the input process data.

If an input is selected, the corresponding PDO assignment is displayed in the PDO Assignment list below.

PDO Assignment

PDO assignment of the selected Sync Manager. All PDOs defined for this Sync Manager type are listed here:

  • If the output Sync Manager (outputs) is selected in the Sync Manager list, all RxPDOs are displayed.
  • If the input Sync Manager (inputs) is selected in the Sync Manager list, all TxPDOs are displayed.

The selected entries are the PDOs involved in the process data transfer. In the tree diagram of the System Manager these PDOs are displayed as variables of the EtherCAT device. The name of the variable is identical to the Name parameter of the PDO, as displayed in the PDO list. If an entry in the PDO assignment list is deactivated (not selected and greyed out), this indicates that the input is excluded from the PDO assignment. In order to be able do select a greyed out PDO, the currently selected PDO has to be deselected first.

Note 		Activation of PDO assignment
If you have changed the PDO assignment, in order to activate the new PDO assignment,
  • the EtherCAT slave has to run through the PS status transition cycle (from pre-operational to safe-operational) once (see Online tab),
  • and the System Manager has to reload the EtherCAT slaves ( [image] button)

PDO list

List of all PDOs supported by this EtherCAT device. The content of the selected PDOs is displayed in the PDO Content list. The PDO configuration can be modified by double-clicking on an entry.

Column | Description
Index | PDO index.
Size | Size of the PDO in bytes.
Name | Name of the PDO. If this PDO is assigned to a Sync Manager, it appears as a variable of the slave with this parameter as the name.
Flags | F | Fixed content: The content of this PDO is fixed and cannot be changed by the System Manager.
 | M | Mandatory PDO. This PDO is mandatory and must therefore be assigned to a Sync Manager! Consequently, this PDO cannot be deleted from the PDO Assignment list
SM | Sync Manager to which this PDO is assigned. If this entry is empty, this PDO does not take part in the process data traffic.
SU | Sync unit to which this PDO is assigned.

PDO Content

Indicates the content of the PDO. If flag F (fixed content) of the PDO is not set the content can be modified.

Download

If the device is intelligent and has a mailbox, the configuration of the PDO and the PDO assignments can be downloaded to the device. This is an optional feature that is not supported by all EtherCAT slaves.

PDO Assignment

If this check box is selected, the PDO assignment that is configured in the PDO Assignment list is downloaded to the device on startup. The required commands to be sent to the device can be viewed in the Startup tab.

PDO Configuration

If this check box is selected, the configuration of the respective PDOs (as shown in the PDO list and the PDO Content display) is downloaded to the EtherCAT slave.

Startup tab

The Startup tab is displayed if the EtherCAT slave has a mailbox and supports the CANopen over EtherCAT (CoE) or Servo drive over EtherCAT protocol. This tab indicates which download requests are sent to the mailbox during startup. It is also possible to add new mailbox requests to the list display. The download requests are sent to the slave in the same order as they are shown in the list.

Column | Description
Transition Transition to which the request is sent. This can either be
  • the transition from pre-operational to safe-operational (PS), or
  • the transition from safe-operational to operational (SO).

If the transition is enclosed in "<>" (e.g. <PS>), the mailbox request is fixed and cannot be modified or deleted by the user.
Protocol | Type of mailbox protocol
Index | Index of the object
Data | Date on which this object is to be downloaded.
Comment | Description of the request to be sent to the mailbox
Move Up | This button moves the selected request up by one position in the list.
Move Down | This button moves the selected request down by one position in the list.
New | This button adds a new mailbox download request to be sent during startup.
Delete | This button deletes the selected entry.
Edit | This button edits an existing request.

CoE - Online tab

The additional CoE - Online tab is displayed if the EtherCAT slave supports the CANopen over EtherCAT (CoE) protocol. This dialog lists the content of the object list of the slave (SDO upload) and enables the user to modify the content of an object from this list. Details for the objects of the individual EtherCAT devices can be found in the device-specific object descriptions.

Object list display
Column | Description
Index | Index and sub-index of the object
Name | Name of the object
Flags | RW | The object can be read, and data can be written to the object (read/write)
 | RO | The object can be read, but no data can be written to the object (read only)
 | P | An additional P identifies the object as a process data object.
Value | Value of the object
Update List | The Update list button updates all objects in the displayed list
Auto Update | If this check box is selected, the content of the objects is updated automatically.
Advanced | The Advanced button opens the Advanced Settings dialog. Here you can specify which objects are displayed in the list.

Online - via SDO Information | If this option button is selected, the list of the objects included in the object list of the slave is uploaded from the slave via SDO information. The list below can be used to specify which object types are to be uploaded.
Offline - via EDS File | If this option button is selected, the list of the objects included in the object list is read from an EDS file provided by the user.

Online tab

State Machine

Init | This button attempts to set the EtherCAT device to the Init state.
Pre-Op | This button attempts to set the EtherCAT device to the pre-operational state.
Op | This button attempts to set the EtherCAT device to the operational state.
Bootstrap | This button attempts to set the EtherCAT device to the Bootstrap state.
Safe-Op | This button attempts to set the EtherCAT device to the safe-operational state.
Clear Error | This button attempts to delete the fault display. If an EtherCAT slave fails during change of state it sets an error flag. Example: An EtherCAT slave is in PREOP state (pre-operational). The master now requests the SAFEOP state (safe-operational). If the slave fails during change of state it sets the error flag. The current state is now displayed as ERR PREOP. When the Clear Error button is pressed the error flag is cleared, and the current state is displayed as PREOP again.
Current State | Indicates the current state of the EtherCAT device.
Requested State | Indicates the state requested for the EtherCAT device.

DLL Status

Indicates the DLL status (data link layer status) of the individual ports of the EtherCAT slave. The DLL status can have four different states:

Status | Description
No Carrier / Open | No carrier signal is available at the port, but the port is open.
No Carrier / Closed | No carrier signal is available at the port, and the port is closed.
Carrier / Open | A carrier signal is available at the port, and the port is open.
Carrier / Closed | A carrier signal is available at the port, but the port is closed.

File Access over EtherCAT

Download | With this button a file can be written to the EtherCAT device.
Upload | With this button a file can be read from the EtherCAT device.


EP1816-3008 - Acceleration measuring

BECKHOFF EP1816-3008: Commissioning aund configuration

Acceleration measuring

Resolution and display

By default the data from the acceleration sensors, in each case X, Y and Z axis values, are displayed as RAW data, i.e. directly in the form in which they are transferred from the sensors.

Fig.: CoE object 8080:1D

Alternatively, the data can be converted to 1mG / LSB. To this end CoE object 8080:1D must be set accordingly.

Fig.: Setting for output in mG

Example for acceleration value display in TwinCAT ScopeView 2

Fig.: EP1816-3008, movement of the box in the 3 axes, resulting acceleration values

Color | Meaning
Blue | sensor 1, Z axis
Red | sensor 1, X axis
Green | sensor 1, Y axis


EP1816-3008 - Update Frequency

The update rate of the sensor data is set via CoE object 8080:0D. On delivery this is set to 5 kHz.


EP1816-3008 - Angle measurement

BECKHOFF EP1816-3008: Commissioning aud configuration

Angle measurement

The angle relative to gravity can be calculated directly in the EP1816-3008 (CoE object 8080:1D).

However, the complex trigonometric calculations would have undue impact on the cycle time of the Box, so that in this mode the angle resolution is limited to 1°.

In cases where higher resolution and precision is required, the calculations should be executed on a PC. The sensors used are capable of a precision of less than 0.1°.

Since the angle values are derived from the acceleration values, which are subject to certain noise, they have to be filtered via suitable algorithms.

In simple cases this could be moving average, for example.

Fig.: Single measurement, process data as acceleration values, calculation on a PC

Fig.: Signal noise in detail

Colour | Meaning
Red | Angle measured with 1024-step encoder / 4-way analysis for reference
Green | Angle trigonometrically calculated on a PC, without noise suppression
blue | Fast algorithm
yellow | Arithmetic mean (1000 sliding values)

Direct measurement in the EP1816-3008

For direct measurement CoE object 8080:1D Presentation must be set to "Horizontal Off-Axis Angle".

The angle is displayed with a resolution of 1°. Since the value is still noisy, filtering on the PC is recommended.

Fig.: red = angle values from EP1816-3008, green = after arithmetic mean calculation on the PC.

Reference directions

  • "Power supply high / EtherCAT connection low" -> negative angle X
  • "Power supply low / EtherCAT connection high" -> positive angle X
  • "Box tilted to the left (top to the left)" -> positive angle Y
  • "Box tilted to the right (top to the right)" -> negative angle Y
Color | Meaning
AI Inputs Channel 1: Input 1 | -180° to +180° relative to X
AI Inputs Channel 2: Input 2 | -180° to +180° relative to Y
AI Inputs Channel 3: Input 3 | 0
AI Inputs Channel 4: Input 4 | -180° to +180° relative to Y
AI Inputs Channel 5: Input 5 | -180° to +180° relative to X
AI Inputs Channel 6: Input 6 | 0

Calculation based on the acceleration values

If the calculation takes place on the PC, the "Presentation" in CoE object 8080:1D must be set to Milli-G.

Variable | Meaning
AI Inputs Channel 1 | +X1
AI Inputs Channel 2 | +Y1
AI Inputs Channel 3 | -Z1
AI Inputs Channel 4 | +Y2
AI Inputs Channel 5 | -X2
AI Inputs Channel 6 | -Z2
Winkel X = atan2[sqrt(Z1 * Z1 + Y1 * Y1), |X1)].

IF Z1 < 0
     THEN
          Winkel X = 90° - Winkel X,
     ELSE
          Winkel X = Winkel X + 90°.

IF Z1 >0
     THEN
          Winkel = - Winkel

Sample program

Attention 		Using the sample program
This publication contains statements about the suitability of our products for certain areas of application. These statements are based on typical features of our products. The examples shown in this publication are for demonstration purposes only. The information provided herein should not be regarded as specific operation characteristics. It is incumbent on the customer to check and decide whether a product is suitable for use in a particular application. We do not give any warranty that the source code which is made available with this publication is complete or accurate. This publication may be changed from time to time without prior notice. No liability is assumed for errors and/or omissions.

Please click onto the symbol to download the sample program from this documentation:


EP1816-3008 - Object overview

BECKHOFF EP1816-3008: Commissioning and configuration

Object overview

Notice 		EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area on the Beckhoff website (http://www.beckhoff.de/german/default.htm?download/elconfg.htm) and installing it according to the installation instructions.
Index |  | Name | Flags | Default value
1000 |  | Device type | RO | 0x00001389 (5001dec)
1008 |  | Device name | RO | EP1816-3008
1009 |  | Hardware version | RO |
100A |  | Software version | RO | 03
1011:0 | Subindex | Restore default parameters | RO | 0x01 (1dec)
 | 1011:01 | SubIndex 001 | RW | 0x00000000 (0dec)
1018:0 | Subindex | Identity | RO | 0x04 (4dec)
 | 1018:01 | Vendor ID | RO | 0x00000002 (2dec)
 | 1018:02 | Product code | RO | 0x05E44052 (98844754dec)
 | 1018:03 | Revision | RO | 0x00000000 (0dec)
 | 1018:04 | Serial number | RO | 0x00000000 (0dec)
10F0:0 | Subindex | Backup parameter handling | RO | 0x01 (1dec)
 | 10F0:01 | Checksum | RO | 0x00000000 (0dec)
1A00:0 | Subindex | DIG TxPDO-Map Inputs Ch.1 | RO | 0x09 (9dec)
 | 1A00:01 | SubIndex 001 | RO | 0x6000:01, 1
 | 1A00:02 | SubIndex 002 | RO | 0x6000:02, 1
 | 1A00:03 | SubIndex 003 | RO | 0x6000:03, 1
 | 1A00:04 | SubIndex 004 | RO | 0x6000:04, 1
 | 1A00:05 | SubIndex 005 | RO | 0x6000:05, 1
 | 1A00:06 | SubIndex 006 | RO | 0x6000:06, 1
 | 1A00:07 | SubIndex 007 | RO | 0x6000:07, 1
 | 1A00:08 | SubIndex 008 | RO | 0x6000:08, 1
 | 1A00:09 | SubIndex 009 | RO | 0x0000:00, 8
1A01:0 | Subindex | DIG TxPDO-Map Inputs Ch.2 | RO | 0x09 (9dec)
 | 1A01:01 | SubIndex 001 | RO | 0x6010:01, 1
 | 1A01:02 | SubIndex 002 | RO | 0x6010:02, 1
 | 1A01:03 | SubIndex 003 | RO | 0x6010:03, 1
 | 1A01:04 | SubIndex 004 | RO | 0x6010:04, 1
 | 1A01:05 | SubIndex 005 | RO | 0x6010:05, 1
 | 1A01:06 | SubIndex 006 | RO | 0x6010:06, 1
 | 1A01:07 | SubIndex 007 | RO | 0x6010:07, 1
 | 1A01:08 | SubIndex 008 | RO | 0x6010:08, 1
 | 1A01:09 | SubIndex 009 | RO | 0x0000:00, 8
1A02:0 | Subindex | AI TxPDO-Map Inputs Ch.1 | RO | 0x05 (5dec)
 | 1A02:01 | SubIndex 001 | RO | 0x0000:00, 6
 | 1A02:02 | SubIndex 002 | RO | 0x6020:07, 1
 | 1A02:03 | SubIndex 003 | RO | 0x0000:00, 8
 | 1A02:04 | SubIndex 004 | RO | 0x6020:10, 1
 | 1A02:05 | SubIndex 005 | RO | 0x6020:11, 16
1A03:0 | Subindex | AI TxPDO-Map Inputs Ch.2 | RO | 0x05 (5dec)
 | 1A03:01 | SubIndex 001 | RO | 0x0000:00, 6
 | 1A03:02 | SubIndex 002 | RO | 0x6030:07, 1
 | 1A03:03 | SubIndex 003 | RO | 0x0000:00, 8
 | 1A03:04 | SubIndex 004 | RO | 0x6030:10, 1
 | 1A03:05 | SubIndex 005 | RO | 0x6030:11, 16
1A04:0 | Subindex | AI TxPDO-Map Inputs Ch.3 | RO | 0x05 (5dec)
 | 1A04:01 | SubIndex 001 | RO | 0x0000:00, 6
 | 1A04:02 | SubIndex 002 | RO | 0x6040:07, 1
 | 1A04:03 | SubIndex 003 | RO | 0x0000:00, 8
 | 1A04:04 | SubIndex 004 | RO | 0x6040:10, 1
 | 1A04:05 | SubIndex 005 | RO | 0x6040:11, 16
1A05:0 | Subindex | AI TxPDO-Map Inputs Ch.4 | RO | 0x05 (5dec)
 | 1A05:01 | SubIndex 001 | RO | 0x0000:00, 6
 | 1A05:02 | SubIndex 002 | RO | 0x6050:07, 1
 | 1A05:03 | SubIndex 003 | RO | 0x0000:00, 8
 | 1A05:04 | SubIndex 004 | RO | 0x6050:10, 1
 | 1A05:05 | SubIndex 005 | RO | 0x6050:11, 16
1A06:0 | Subindex | AI TxPDO-Map Inputs Ch.5 | RO | 0x05 (5dec)
 | 1A06:01 | SubIndex 001 | RO | 0x0000:00, 6
 | 1A06:02 | SubIndex 002 | RO | 0x6060:07, 1
 | 1A06:03 | SubIndex 003 | RO | 0x0000:00, 8
 | 1A06:04 | SubIndex 004 | RO | 0x6060:10, 1
 | 1A06:05 | SubIndex 005 | RO | 0x6060:11, 16
1A07:0 | Subindex | AI TxPDO-Map Inputs Ch.6 | RO | 0x05 (5dec)
 | 1A07:01 | SubIndex 001 | RO | 0x0000:00, 6
 | 1A07:02 | SubIndex 002 | RO | 0x6070:07, 1
 | 1A07:03 | SubIndex 003 | RO | 0x0000:00, 8
 | 1A07:04 | SubIndex 004 | RO | 0x6070:10, 1
 | 1A07:05 | SubIndex 005 | RO | 0x6070:11, 16
1A08:0 | Subindex | DIG TxPDO-Map Inputs Device | RO | 0x04 (4dec)
 | 1A08:01 | SubIndex 001 | RO | 0xF600:01, 1
 | 1A08:02 | SubIndex 002 | RO | 0xF600:02, 1
 | 1A08:03 | SubIndex 003 | RO | 0x0000:00, 13
 | 1A08:04 | SubIndex 004 | RO | 0xF600:10, 1
1C00:0 | Subindex | Sync manager type | RO | 0x04 (4dec)
 | 1C00:01 | SubIndex 001 | RO | 0x01 (1dec)
 | 1C00:02 | SubIndex 002 | RO | 0x02 (2dec)
 | 1C00:03 | SubIndex 003 | RO | 0x03 (3dec)
 | 1C00:04 | SubIndex 004 | RO | 0x04 (4dec)
1C12:0 | Subindex | RxPDO assign | RO | 0x00 (0dec)
1C13:0 | Subindex | TxPDO assign | RO | 0x09 (9dec)
 | 1C13:01 | SubIndex 001 | RO | 0x1A00 (6656dec)
 | 1C13:02 | SubIndex 002 | RO | 0x1A01 (6657dec)
 | 1C13:03 | SubIndex 003 | RO | 0x1A02 (6658dec)
 | 1C13:04 | SubIndex 004 | RO | 0x1A03 (6659dec)
 | 1C13:05 | SubIndex 005 | RO | 0x1A04 (6660dec)
 | 1C13:06 | SubIndex 006 | RO | 0x1A05 (6661dec)
 | 1C13:07 | SubIndex 007 | RO | 0x1A06 (6662dec)
 | 1C13:08 | SubIndex 008 | RO | 0x1A07 (6663dec
 | 1C13:09 | SubIndex 009 | RO | 0x1A08 (6664dec
1C33:0 | Subindex | SM input parameter | RO | 0x20 (32dec)
 | 1C33:01 | Sync mode | RW | 0x0022 (34dec)
 | 1C33:02 | Cycle time | RW | 0x003D0900 (4000000dec)
 | 1C33:03 | Shift time | RO | 0x00000000 (0dec)
 | 1C33:04 | Sync modes supported | RO | 0xC007 (49159dec)
 | 1C33:05 | Minimum cycle time | RO | 0x00030D40 (200000dec)
 | 1C33:06 | Calc and copy time | RO | 0x00000000 (0dec)
 | 1C33:07 | Minimum delay time | RO | 0x00000000 (0dec)
 | 1C33:08 | Command | RW | 0x0000 (0dec)
 | 1C33:09 | Maximum delay time | RO | 0x00000000 (0dec)
 | 1C33:0B | SM event missed counter | RO | 0x0000 (0dec)
 | 1C33:0C | Cycle exceeded counter | RO | 0x0000 (0dec)
 | 1C33:0D | Shift too short counter | RO | 0x0000 (0dec)
 | 1C33:20 | Sync error | RO | 0x00 (0dec)
6000:0 | Subindex | DIG Inputs Ch.1 | RO | 0x08 (8dec)
 | 6000:01 | Input 1 | RO | 0x00 (0dec)
 | 6000:02 | Input 2 | RO | 0x00 (0dec)
 | 6000:03 | Input 3 | RO | 0x00 (0dec)
 | 6000:04 | Input 4 | RO | 0x00 (0dec)
 | 6000:05 | Input 5 | RO | 0x00 (0dec)
 | 6000:06 | Input 6 | RO | 0x00 (0dec)
 | 6000:07 | Input 7 | RO | 0x00 (0dec)
 | 6000:08 | Input 8 | RO | 0x00 (0dec)
6010:0 | Subindex | DIG Inputs Ch.2 | RO | 0x08 (8dec)
 | 6010:01 | Input 1 | RO | 0x00 (0dec)
 | 6010:02 | Input 2 | RO | 0x00 (0dec)
 | 6010:03 | Input 3 | RO | 0x00 (0dec)
 | 6010:04 | Input 4 | RO | 0x00 (0dec)
 | 6010:05 | Input 5 | RO | 0x00 (0dec)
 | 6010:06 | Input 6 | RO | 0x00 (0dec)
 | 6010:07 | Input 7 | RO | 0x00 (0dec)
 | 6010:08 | Input 8 | RO | 0x00 (0dec)
6020:0 | Subindex | AI Inputs Ch.1 | RO | 0x11 (17dec)
 | 6020:07 | Error | RO | 0x00 (0dec)
 | 6020:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6020:11 | Value | RO | 0x0000 (0dec)
6030:0 | Subindex | AI Inputs Ch.2 | RO | 0x11 (17dec)
 | 6030:07 | Error | RO | 0x00 (0dec)
 | 6030:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6030:11 | Value | RO | 0x0000 (0dec)
6040:0 | Subindex | AI Inputs Ch.3 | RO | 0x11 (17dec)
 | 6040:07 | Error | RO | 0x00 (0dec)
 | 6040:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6040:11 | Value | RO | 0x0000 (0dec)
6050:0 | Subindex | AI Inputs Ch.4 | RO | 0x11 (17dec)
 | 6050:07 | Error | RO | 0x00 (0dec)
 | 6050:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6050:11 | Value | RO | 0x0000 (0dec)
6060:0 | Subindex | AI Inputs Ch.5 | RO | 0x11 (17dec)
 | 6060:07 | Error | RO | 0x00 (0dec)
 | 6060:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6060:11 | Value | RO | 0x0000 (0dec)
6070:0 | Subindex | AI Inputs Ch.6 | RO | 0x11 (17dec)
 | 6070:07 | Error | RO | 0x00 (0dec)
 | 6070:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6070:11 | Value | RO | 0x0000 (0dec)
8020:0 | Subindex | AI Settings Ch.1 | RW | 0x18 (24dec)
 | 8020:01 | Enable user scale | RW | 0x00 (0dec)
 | 8020:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8020:0B | Enable vendor calibration | RW | 0x00 (0dec)
 | 8020:11 | User scale offset | RW | 0x0000 (0dec)
 | 8020:12 | User scale gain | RW | 0x02A00000 (44040192dec)
 | 8020:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8020:18 | User calibration gain | RW | 0x0000 (0dec)
802F:0 | Subindex | AI Vendor data Ch.1 | RW | 0x02 (2dec)
 | 802F:01 | Calibration Offset | RW | 0x0000 (0dec)
 | 802F:02 | Calibration Gain | RW | 0x0000 (0dec)
8030:0 | Subindex | AI Settings Ch.2 | RW | 0x18 (24dec)
 | 8030:01 | Enable user scale | RW | 0x00 (0dec)
 | 8030:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8030:0B | Enable vendor calibration | RW | 0x00 (0dec)
 | 8030:11 | User scale offset | RW | 0x0000 (0dec)
 | 8030:12 | User scale gain | RW | 0x02A00000 (44040192dec)
 | 8030:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8030:18 | User calibration gain | RW | 0x0000 (0dec)
803F:0 | Subindex | AI Vendor data Ch.2 | RW | 0x02 (2dec)
 | 803F:01 | Calibration Offset | RW | 0x0000 (0dec)
 | 803F:02 | Calibration Gain | RW | 0x0000 (0dec)
8040:0 | Subindex | AI Settings Ch.3 | RW | 0x18 (24dec)
 | 8040:01 | Enable user scale | RW | 0x00 (0dec)
 | 8040:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8040:0B | Enable vendor calibration | RW | 0x00 (0dec)
 | 8040:11 | User scale offset | RW | 0x0000 (0dec)
 | 8040:12 | User scale gain | RW | 0x02A00000 (44040192dec)
 | 8040:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8040:18 | User calibration gain | RW | 0x0000 (0dec)
804F:0 | Subindex | AI Vendor data Ch.3 | RW | 0x02 (2dec)
 | 804F:01 | Calibration Offset | RW | 0x0000 (0dec)
 | 804F:02 | Calibration Gain | RW | 0x0000 (0dec)
8050:0 | Subindex | AI Settings Ch.4 | RW | 0x18 (24dec)
 | 8050:01 | Enable user scale | RW | 0x00 (0dec)
 | 8050:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8050:0B | Enable vendor calibration | RW | 0x00 (0dec)
 | 8050:11 | User scale offset | RW | 0x0000 (0dec)
 | 8050:12 | User scale gain | RW | 0x02A00000 (44040192dec)
 | 8050:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8050:18 | User calibration gain | RW | 0x0000 (0dec)
805F:0 | Subindex | AI Vendor data Ch.4 | RW | 0x02 (2dec)
 | 805F:01 | Calibration Offset | RW | 0x0000 (0dec)
 | 805F:02 | Calibration Gain | RW | 0x0000 (0dec)
8060:0 | Subindex | AI Settings Ch.5 | RW | 0x18 (24dec)
 | 8060:01 | Enable user scale | RW | 0x00 (0dec)
 | 8060:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8060:0B | Enable vendor calibration | RW | 0x00 (0dec)
 | 8060:11 | User scale offset | RW | 0x0000 (0dec)
 | 8060:12 | User scale gain | RW | 0x02A00000 (44040192dec)
 | 8060:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8060:18 | User calibration gain | RW | 0x0000 (0dec)
806F:0 | Subindex | AI Vendor data Ch.5 | RW | 0x02 (2dec)
 | 806F:01 | Calibration Offset | RW | 0x0000 (0dec)
 | 806F:02 | Calibration Gain | RW | 0x0000 (0dec)
8070:0 | Subindex | AI Settings Ch.6 | RW | 0x18 (24dec)
 | 8070:01 | Enable user scale | RW | 0x00 (0dec)
 | 8070:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8070:0B | Enable vendor calibration | RW | 0x00 (0dec)
 | 8070:11 | User scale offset | RW | 0x0000 (0dec)
 | 8070:12 | User scale gain | RW | 0x02A00000 (44040192dec)
 | 8070:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8070:18 | User calibration gain | RW | 0x0000 (0dec)
807F:0 | Subindex | AI Vendor data Ch.6 | RW | 0x02 (2dec)
 | 807F:01 | Calibration Offset | RW | 0x0000 (0dec)
 | 807F:02 | Calibration Gain | RW | 0x0000 (0dec)
8080:0 | Subindex | SAI Settings | RW | 0x11 (17dec)
 | 8080:0D | Mode | RW | 0x0000 (0dec)
 | 8080:11 | Range | RW | 0x0000 (0dec)
F000:0 | Subindex | Modular device profile | RO | 0x02 (2dec)
 | F000:01 | Module index distance | RO | 0x0010 (16dec)
 | F000:02 | Maximum number of modules | RO | 0x0009 (9dec)
F008 |  | Code word | RW | 0x00000000 (0dec)
F010:0 | Subindex | Module list | RW | 0x09 (9dec)
 | F010:01 | SubIndex 001 | RW | 0x00000118 (280dez)
 | F010:02 | SubIndex 002 | RW | 0x00000118 (280dez)
 | F010:03 | SubIndex 003 | RW | 0x0000012C (300dec)
 | F010:04 | SubIndex 004 | RW | 0x0000012C (300dec)
 | F010:05 | SubIndex 005 | RW | 0x0000012C (300dec)
 | F010:06 | SubIndex 006 | RW | 0x0000012C (300dez)
 | F010:07 | SubIndex 007 | RW | 0x0000012C (300dec)
 | F010:08 | SubIndex 008 | RW | 0x0000012C (300dec)
 | F010:09 | SubIndex 009 | RW | 0x00000168 (360dec)
F600:0 | Subindex | DIG Inputs | RO | 0x10 (16dec)
 | F600:01 | Us Undervoltage | RO | 0x00 (0dec)
 | F600:02 | Up Undervoltage | RO | 0x00 (0dec)
 | F600:10 | TxPDO Toggle | RO | 0x00 (0dec)
Key

Flags:
RO (Read Only): this object can be read only
RW (Read/Write): this object can be read and written to


EP1816-3008 - Object description

BECKHOFF EP1816-3008: Commissioning and configuration

Object description and parameterization

Notice 		Parameterization
The terminal is parameterized via the CoE Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs).

Notice 		EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area on the Beckhoff website (http://www.beckhoff.de/german/default.htm?download/elconfg.htm) and installing it according to the installation instructions.

Introduction

The CoE overview contains objects for different intended applications:

  • Objects required for parameterization during commissioning
  • Objects intended for regular operation, e.g. through ADS access.
  • Objects for indicating internal settings (may be fixed)
  • Further profile-specific objects indicating inputs, outputs and status information

The following section first describes the objects required for normal operation, followed by a complete overview of missing objects.

Objects to be parameterized during commissioning

Index 8020 AI Settings Ch.1
Index | Name | Meaning | Data type | Flags | Default
8020:0 | AI Settings Ch.1 |  | UINT8 | RO | 0x18 (24dec)
8020:01 | Enable user scale |  | BOOLEAN | RW | 0x00 (0dec)
8020:0A | Enable user calibration |  | BOOLEAN | RW | 0x00 (0dec)
8020:0B | Enable vendor calibration |  | BOOLEAN | RW | 0x00 (0dec)
8020:11 | User scale offset |  | INT16 | RW | 0x0000 (0dec)
8020:12 | User scale gain |  | INT32 | RW | 0x02A00000 (44040192dec)
8020:17 | User calibration offset |  | INT16 | RW | 0x0000 (0dec)
8020:18 | User calibration gain |  | INT16 | RW | 0x0000 (0dec)
Index 802F AI Vendor data Ch.1
Index | Name | Meaning | Data type | Flags | Default
802F:0 | AI Vendor data Ch.1 |  | UINT8 | RO | 0x02 (2dec)
802F:01 | Calibration Offset |  | INT16 | RW | 0x0000 (0dec)
802F:02 | Calibration Gain |  | INT16 | RW | 0x0000 (0dec)
Index 8030 AI Settings Ch.2
Index | Name | Meaning | Data type | Flags | Default
8030:0 | AI Settings Ch.2 |  | UINT8 | RO | 0x18 (24dec)
8030:01 | Enable user scale |  | BOOLEAN | RW | 0x00 (0dec)
8030:0A | Enable user calibration |  | BOOLEAN | RW | 0x00 (0dec)
8030:0B | Enable vendor calibration |  | BOOLEAN | RW | 0x00 (0dec)
8030:11 | User scale offset |  | INT16 | RW | 0x0000 (0dec)
8030:12 | User scale gain |  | INT32 | RW | 0x02A00000 (44040192dec)
8030:17 | User calibration offset |  | INT16 | RW | 0x0000 (0dec)
8030:18 | User calibration gain |  | INT16 | RW | 0x0000 (0dec)
Index 803F AI Vendor data Ch.2
Index | Name | Meaning | Data type | Flags | Default
803F:0 | AI Vendor data Ch.2 |  | UINT8 | RO | 0x02 (2dec)
803F:01 | Calibration Offset |  | INT16 | RW | 0x0000 (0dec)
803F:02 | Calibration Gain |  | INT16 | RW | 0x0000 (0dec)
Index 8040 AI Settings Ch.3
Index | Name | Meaning | Data type | Flags | Default
8040:0 | AI Settings Ch.3 |  | UINT8 | RO | 0x18 (24dec)
8040:01 | Enable user scale |  | BOOLEAN | RW | 0x00 (0dec)
8040:0A | Enable user calibration |  | BOOLEAN | RW | 0x00 (0dec)
8040:0B | Enable vendor calibration |  | BOOLEAN | RW | 0x00 (0dec)
8040:11 | User scale offset |  | INT16 | RW | 0x0000 (0dec)
8040:12 | User scale gain |  | INT32 | RW | 0x02A00000 (44040192dec)
8040:17 | User calibration offset |  | INT16 | RW | 0x0000 (0dec)
8040:18 | User calibration gain |  | INT16 | RW | 0x0000 (0dec)
Index 804F AI Vendor data Ch.3
Index | Name | Meaning | Data type | Flags | Default
804F:0 | AI Vendor data Ch.3 |  | UINT8 | RO | 0x02 (2dec)
804F:01 | Calibration Offset |  | INT16 | RW | 0x0000 (0dec)
804F:02 | Calibration Gain |  | INT16 | RW | 0x0000 (0dec)
Index 8050 AI Settings Ch.4
Index | Name | Meaning | Data type | Flags | Default
8050:0 | AI Settings Ch.4 |  | UINT8 | RO | 0x18 (24dec)
8050:01 | Enable user scale |  | BOOLEAN | RW | 0x00 (0dec)
8050:0A | Enable user calibration |  | BOOLEAN | RW | 0x00 (0dec)
8050:0B | Enable vendor calibration |  | BOOLEAN | RW | 0x00 (0dec)
8050:11 | User scale offset |  | INT16 | RW | 0x0000 (0dec)
8050:12 | User scale gain |  | INT32 | RW | 0x02A00000 (44040192dec)
8050:17 | User calibration offset |  | INT16 | RW | 0x0000 (0dec)
8050:18 | User calibration gain |  | INT16 | RW | 0x0000 (0dec)
Index 805F AI Vendor data Ch.4
Index | Name | Meaning | Data type | Flags | Default
805F:0 | AI Vendor data Ch.4 |  | UINT8 | RO | 0x02 (2dec)
805F:01 | Calibration Offset |  | INT16 | RW | 0x0000 (0dec)
805F:02 | Calibration Gain |  | INT16 | RW | 0x0000 (0dec)
Index 8060 AI Settings Ch.5
Index | Name | Meaning | Data type | Flags | Default
8060:0 | AI Settings Ch.5 |  | UINT8 | RO | 0x18 (24dec)
8060:01 | Enable user scale |  | BOOLEAN | RW | 0x00 (0dec)
8060:0A | Enable user calibration |  | BOOLEAN | RW | 0x00 (0dec)
8060:0B | Enable vendor calibration |  | BOOLEAN | RW | 0x00 (0dec)
8060:11 | User scale offset |  | INT16 | RW | 0x0000 (0dec)
8060:12 | User scale gain |  | INT32 | RW | 0x02A00000 (44040192dec)
8060:17 | User calibration offset |  | INT16 | RW | 0x0000 (0dec)
8060:18 | User calibration gain |  | INT16 | RW | 0x0000 (0dec)
Index 806F AI Vendor data Ch.5
Index | Name | Meaning | Data type | Flags | Default
806F:0 | AI Vendor data Ch.5 |  | UINT8 | RO | 0x02 (2dec)
806F:01 | Calibration Offset |  | INT16 | RW | 0x0000 (0dec)
806F:02 | Calibration Gain |  | INT16 | RW | 0x0000 (0dec)
Index 8070 AI Settings Ch.6
Index | Name | Meaning | Data type | Flags | Default
8070:0 | AI Settings Ch.6 |  | UINT8 | RO | 0x18 (24dec)
8070:01 | Enable user scale |  | BOOLEAN | RW | 0x00 (0dec)
8070:0A | Enable user calibration |  | BOOLEAN | RW | 0x00 (0dec)
8070:0B | Enable vendor calibration |  | BOOLEAN | RW | 0x00 (0dec)
8070:11 | User scale offset |  | INT16 | RW | 0x0000 (0dec)
8070:12 | User scale gain |  | INT32 | RW | 0x02A00000 (44040192dec)
8070:17 | User calibration offset |  | INT16 | RW | 0x0000 (0dec)
8070:18 | User calibration gain |  | INT16 | RW | 0x0000 (0dec)
Index 807F AI Vendor data Ch.6
Index | Name | Meaning | Data type | Flags | Default
807F:0 | AI Vendor data Ch.6 |  | UINT8 | RO | 0x02 (2dec)
807F:01 | Calibration Offset |  | INT16 | RW | 0x0000 (0dec)
807F:02 | Calibration Gain |  | INT16 | RW | 0x0000 (0dec)
Index 8080 SAI Settings
Index | Name | Meaning |  | Data type | Flags | Default
8080:0 | SAI Settings |  |  | UINT8 | RO | 0x11 (17dec)
8080:0D | Mode | permitted values: |  | UINT16 | RW | 0x0000 (0dec)
 |  | 4 | 1 Hz
 |  | 5 | 10 Hz
 |  | 6 | 25 Hz
 |  | 7 | 50 Hz
 |  | 8 | 100 Hz
 |  | 9 | 200 Hz
 |  | 10 | 400 Hz
 |  | 11 | 1600 Hz
 |  | 12 | 5000 Hz
8080:11 | Range | permitted values: |  | UINT16 | RW | 0x0000 (0dec)
 |  | 3 | +/- 2G
 |  | 4 | +/- 4G
 |  | 5 | +/- 8G
 |  | 6 | +/-16G

Additional objects

Standard objects (0x1000-0x1FFF)

The standard objects have the same meaning for all EtherCAT slaves.

Index 1000Device type
Index | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: the Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x00001389 (5001dec)
Index 1008Device name
Index | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EP1816-3008
Index 1009Hardware version
Index | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO |
Index 100ASoftware version
Index | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO | 03
Index 1011 Restore default parameters
Index | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters |  | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 |  | UINT32 | RW | 0x00000000 (0dec)
Index 1018Identity
Index | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x05E44052 (98844754dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the low word (bit 0-15) indicates the special terminal number, the high word (bit 16-31) refers to the device description | UINT32 | RO | 0x00000000 (0dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the low byte (bit 0-7) of the low word contains the year of production, the high byte (bit 8-15) of the low word contains the week of production, the high word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 Backup parameter handling
Index | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling |  | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum |  | UINT32 | RO | 0x00000000 (0dec)
Index 1A00 DIG TxPDO-Map Inputs Ch.1
Index | Name | Meaning | Data type | Flags | Default
1A00:0 | DIG TxPDO-Map Inputs Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x09 (9dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (DIG Inputs Ch.1), entry 0x01 (Input 1)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (DIG Inputs Ch.1), entry 0x02 (Input 2)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (DIG Inputs Ch.1), entry 0x03 (Input 3)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (DIG Inputs Ch.1), entry 0x04 (Input 4)) | UINT32 | RO | 0x6000:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (DIG Inputs Ch.1), entry 0x05 (Input 5)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (DIG Inputs Ch.1), entry 0x06 (Input 6)) | UINT32 | RO | 0x6000:06, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (DIG Inputs Ch.1), entry 0x07 (Input 7)) | UINT32 | RO | 0x6000:07, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (DIG Inputs Ch.1), entry 0x08 (Input 8)) | UINT32 | RO | 0x6000:08, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1A01 DIG TxPDO-Map Inputs Ch.2
Index | Name | Meaning | Data type | Flags | Default
1A01:0 | DIG TxPDO-Map Inputs Ch.2 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x09 (9dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DIG Inputs Ch.2), entry 0x01 (Input 1)) | UINT32 | RO | 0x6010:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (DIG Inputs Ch.2), entry 0x02 (Input 2)) | UINT32 | RO | 0x6010:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (DIG Inputs Ch.2), entry 0x03 (Input 3)) | UINT32 | RO | 0x6010:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (DIG Inputs Ch.2), entry 0x04 (Input 4)) | UINT32 | RO | 0x6010:04, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (DIG Inputs Ch.2), entry 0x05 (Input 5)) | UINT32 | RO | 0x6010:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (DIG Inputs Ch.2), entry 0x06 (Input 6)) | UINT32 | RO | 0x6010:06, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (DIG Inputs Ch.2), entry 0x07 (Input 7)) | UINT32 | RO | 0x6010:07, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (DIG Inputs Ch.2), entry 0x08 (Input 8)) | UINT32 | RO | 0x6010:08, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1A02 AI TxPDO-Map Inputs Ch.1
Index | Name | Meaning | Data type | Flags | Default
1A02:0 | AI TxPDO-Map Inputs Ch.1 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x05 (5dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (13 bits align) | UINT32 | RO | 0x0000:00, 6
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x1C33 (SM input parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x6020:07, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 8
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (AI Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6020:10, 1
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (AI Inputs Ch.1), entry 0x11 (Value)) | UINT32 | RO | 0x6020:11, 16
Index 1A03 AI TxPDO-Map Inputs Ch.2
Index | Name | Meaning | Data type | Flags | Default
1A03:0 | AI TxPDO-Map Inputs Ch.2 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x05 (5dec)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (13 bits align) | UINT32 | RO | 0x0000:00, 6
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x1C33 (SM input parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x6030:07, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 8
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6030 (AI Inputs Ch.2), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6030:10, 1
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6030 (AI Inputs Ch.2), entry 0x11 (Value)) | UINT32 | RO | 0x6030:11, 16
Index 1A04 AI TxPDO-Map Inputs Ch.3
Index | Name | Meaning | Data type | Flags | Default
1A04:0 | AI TxPDO-Map Inputs Ch.3 | PDO Mapping TxPDO 5 | UINT8 | RO | 0x05 (5dec)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (13 bits align) | UINT32 | RO | 0x0000:00, 6
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x1C33 (SM input parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x6040:07, 1
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 8
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6040 (AI Inputs Ch.3), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6040:10, 1
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6040 (AI Inputs Ch.3), entry 0x11 (Value)) | UINT32 | RO | 0x6040:11, 16
Index 1A05 AI TxPDO-Map Inputs Ch.4
Index | Name | Meaning | Data type | Flags | Default
1A05:0 | AI TxPDO-Map Inputs Ch.4 | PDO Mapping TxPDO 6 | UINT8 | RO | 0x05 (5dec)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (13 bits align) | UINT32 | RO | 0x0000:00, 6
1A05:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x1C33 (SM input parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x6050:07, 1
1A05:03 | SubIndex 003 | 3. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 8
1A05:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6050 (AI Inputs Ch.4), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6050:10, 1
1A05:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6050 (AI Inputs Ch.4), entry 0x11 (Value)) | UINT32 | RO | 0x6050:11, 16
Index 1A06 AI TxPDO-Map Inputs Ch.5
Index | Name | Meaning | Data type | Flags | Default
1A06:0 | AI TxPDO-Map Inputs Ch.5 | PDO Mapping TxPDO 7 | UINT8 | RO | 0x05 (5dec)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (13 bits align) | UINT32 | RO | 0x0000:00, 6
1A06:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x1C33 (SM input parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x6060:07, 1
1A06:03 | SubIndex 003 | 3. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 8
1A06:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6060 (AI Inputs Ch.5), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6060:10, 1
1A06:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6060 (AI Inputs Ch.5), entry 0x11 (Value)) | UINT32 | RO | 0x6060:11, 16
Index 1A07 AI TxPDO-Map Inputs Ch.6
Index | Name | Meaning | Data type | Flags | Default
1A07:0 | AI TxPDO-Map Inputs Ch.6 | PDO Mapping TxPDO 8 | UINT8 | RO | 0x05 (5dec)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (13 bits align) | UINT32 | RO | 0x0000:00, 6
1A07:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x1C33 (SM input parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x6070:07, 1
1A07:03 | SubIndex 003 | 3. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 8
1A07:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6070 (AI Inputs Ch.6), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6070:10, 1
1A07:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6070 (AI Inputs Ch.6), entry 0x11 (Value)) | UINT32 | RO | 0x6070:11, 16
Index 1A08 DIG TxPDO-Map Inputs Device
Index | Name | Meaning | Data type | Flags | Default
1A08:0 | DIG TxPDO-Map Inputs Device | PDO Mapping TxPDO 9 | UINT8 | RO | 0x04 (4dec)
1A08:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF600 (DIG Inputs), entry 0x01 (Us Undervoltage)) | UINT32 | RO | 0xF600:01, 1
1A08:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF600 (DIG Inputs), entry 0x02 (Up Undervoltage)) | UINT32 | RO | 0xF600:02, 1
1A08:03 | SubIndex 003 | 3. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 13
1A08:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF600 (DIG Inputs), entry 0x0E (Sync error)) | UINT32 | RO | 0xF600:10, 1
Index 1C00Sync manager type
Index | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the sync managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign
Index | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RO | 0x00 (0dec)
Index 1C13 TxPDO assign
Index | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RO | 0x09 (9dec)
1C13:01 | Subindex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RO | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RO | 0x1A01 (6657dec)
1C13:03 | Subindex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RO | 0x1A02 (6658dec)
1C13:04 | Subindex 004 | 4. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RO | 0x1A03 (6659dec)
1C13:05 | Subindex 005 | 5. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RO | 0x1A04 (6660dec)
1C13:06 | Subindex 006 | 6. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RO | 0x1A05 (6661dec)
1C13:07 | Subindex 007 | 7. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RO | 0x1A06 (6662dec)
1C13:08 | Subindex 008 | 8. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RO | 0x1A07 (6663dec
1C13:09 | Subindex 009 | 9. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RO | 0x1A08 (6664dec
Index 1C33SM input parameter
Index | Name | Meaning | Data type | Flags | Default
1C33:0 | SM input parameter | Synchronization parameters for the inputs | UINT8 | RO | 0x20 (32dec)
1C33:01 Sync mode Current synchronization mode:
  • 0: Free Run
  • 1: synchronous with SM 3 event (no outputs available)
  • 2: DC - Synchron with SYNC0 Event
  • 3: DC - Synchron with SYNC1 Event
  • 34: synchronous with SM 2 event (outputs available)
 UINT16 RW 0x0022 (34dec)
1C33:02 | Cycle time | as 1C32:02 | UINT32 | RW | 0x003D0900 (4000000dec)
1C33:03 | Shift time | Time between SYNC0 event and reading of the inputs (in ns, only DC mode) | UINT32 | RO | 0x00000000 (0dec)
1C33:04 Sync modes supported Supported synchronization modes:
  • Bit 0: free run is supported
  • Bit 1: synchronous with SM 2 event is supported (outputs available)
  • Bit 1: synchronous with SM 3 event is supported (no outputs available)
  • Bit 2-3 = 01: DC mode is supported
  • Bit 4-5 = 01: input shift through local event (outputs available)
  • Bit 4-5 = 10: input shift with SYNC1 event (no outputs available)
  • Bit 14 = 1: dynamic times (measurement through writing of 1C32:08 or 1C33:08)
 UINT16 RO 0xC007 (49159dec)
1C33:05 | Minimum cycle time | as 1C32:05 | UINT32 | RO | 0x00030D40 (200000dec)
1C33:06 | Calc and copy time | Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode) | UINT32 | RO | 0x00000000 (0dec)
1C33:07 | Minimum delay time | UINT32 | RO | 0x00000000 (0dec)
1C33:08 | Command | as 1C32:08 | UINT16 | RW | 0x0000 (0dec)
1C33:09 | Maximum delay time | Time between SYNC1 event and reading of the inputs (in ns, only DC mode) | UINT32 | RO | 0x00000000 (0dec)
1C33:0B | SM event missed counter | as 1C32:11 | UINT16 | RO | 0x0000 (0dec)
1C33:0C | Cycle exceeded counter | as 1C32:12 | UINT16 | RO | 0x0000 (0dec)
1C33:0D | Shift too short counter | as 1C32:13 | UINT16 | RO | 0x0000 (0dec)
1C33:20 | Sync error | as 1C32:32 | BOOLEAN | RO | 0x00 (0dec)

Profile-specific objects (0x6000-0xFFFF)

The profile-specific objects have the same meaning for all EtherCAT slaves that support the profile 5001.

Index 6000 DIG Inputs Ch.1
Index | Name | Meaning | Data type | Flags | Default
6000:0 | DIG Inputs Ch.1 |  | UINT8 | RO | 0x08 (8dec)
6000:01 | Input 1 |  | BOOLEAN | RO | 0x00 (0dec)
6000:02 | Input 2 |  | BOOLEAN | RO | 0x00 (0dec)
6000:03 | Input 3 |  | BOOLEAN | RO | 0x00 (0dec)
6000:04 | Input 4 |  | BOOLEAN | RO | 0x00 (0dec)
6000:05 | Input 5 |  | BOOLEAN | RO | 0x00 (0dec)
6000:06 | Input 6 |  | BOOLEAN | RO | 0x00 (0dec)
6000:07 | Input 7 |  | BOOLEAN | RO | 0x00 (0dec)
6000:08 | Input 8 |  | BOOLEAN | RO | 0x00 (0dec)
Index 6010 DIG Inputs Ch.2
Index | Name | Meaning | Data type | Flags | Default
6010:0 | DIG Inputs Ch.2 |  | UINT8 | RO | 0x08 (8dec)
6010:01 | Input 1 |  | BOOLEAN | RO | 0x00 (0dec)
6010:02 | Input 2 |  | BOOLEAN | RO | 0x00 (0dec)
6010:03 | Input 3 |  | BOOLEAN | RO | 0x00 (0dec)
6010:04 | Input 4 |  | BOOLEAN | RO | 0x00 (0dec)
6010:05 | Input 5 |  | BOOLEAN | RO | 0x00 (0dec)
6010:06 | Input 6 |  | BOOLEAN | RO | 0x00 (0dec)
6010:07 | Input 7 |  | BOOLEAN | RO | 0x00 (0dec)
6010:08 | Input 8 |  | BOOLEAN | RO | 0x00 (0dec)
Index 6020 AI Inputs Ch.1
Index | Name | Meaning | Data type | Flags | Default
6020:0 | AI Inputs Ch.1 |  | UINT8 | RO | 0x11 (17dec)
6020:07 | Error |  | BOOLEAN | RO | 0x00 (0dec)
6020:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)
6020:11 | Value |  | INT16 | RO | 0x0000 (0dec)
Index 6030 AI Inputs Ch.2
Index | Name | Meaning | Data type | Flags | Default
6030:0 | AI Inputs Ch.2 |  | UINT8 | RO | 0x11 (17dec)
6030:07 | Error |  | BOOLEAN | RO | 0x00 (0dec)
6030:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)
6030:11 | Value |  | INT16 | RO | 0x0000 (0dec)
Index 6040 AI Inputs Ch.3
Index | Name | Meaning | Data type | Flags | Default
6040:0 | AI Inputs Ch.3 |  | UINT8 | RO | 0x11 (17dec)
6040:07 | Error |  | BOOLEAN | RO | 0x00 (0dec)
6040:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)
6040:11 | Value |  | INT16 | RO | 0x0000 (0dec)
Index 6050 AI Inputs Ch.4
Index | Name | Meaning | Data type | Flags | Default
6050:0 | AI Inputs Ch.4 |  | UINT8 | RO | 0x11 (17dec)
6050:07 | Error |  | BOOLEAN | RO | 0x00 (0dec)
6050:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)
6050:11 | Value |  | INT16 | RO | 0x0000 (0dec)
Index 6060 AI Inputs Ch.5
Index | Name | Meaning | Data type | Flags | Default
6060:0 | AI Inputs Ch.5 |  | UINT8 | RO | 0x11 (17dec)
6060:07 | Error |  | BOOLEAN | RO | 0x00 (0dec)
6060:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)
6060:11 | Value |  | INT16 | RO | 0x0000 (0dec)
Index 6070 AI Inputs Ch.6
Index | Name | Meaning | Data type | Flags | Default
6070:0 | AI Inputs Ch.6 |  | UINT8 | RO | 0x11 (17dec)
6070:07 | Error |  | BOOLEAN | RO | 0x00 (0dec)
6070:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)
6070:11 | Value |  | INT16 | RO | 0x0000 (0dec)
Index F000 Modular device profile
Index | Maximum number of modules>Name | Meaning | UINT16>Data type | RO>Flags | 0x0009 (9dec)>Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance |  | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules |  | UINT16 | RO | 0x0009 (9dec)
Index F008 Code word
Index | Name | Meaning | Data type | Flags | Default
F008:0 | Code word |  | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module list
Index | Name | Meaning | Data type | Flags | Default
F010:0 | Module list |  | UINT8 | RW | 0x09 (9dec)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x00000118 (280dez)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x00000118 (280dez)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x0000012C (300dec)
F010:04 | SubIndex 004 |  | UINT32 | RW | 0x0000012C (300dec)
F010:05 | SubIndex 005 |  | UINT32 | RW | 0x0000012C (300dec)
F010:06 | SubIndex 006 |  | UINT32 | RW | 0x0000012C (300dec)
F010:07 | SubIndex 007 |  | UINT32 | RW | 0x0000012C (300dec)
F010:08 | SubIndex 008 |  | UINT32 | RW | 0x0000012C (300dec)
F010:09 | SubIndex 009 |  | UINT32 | RW | 0x00000168 (360dec)
Index F600 DIG Inputs
Index | Name | Meaning | Data type | Flags | Default
F600:0 | DIG Inputs |  | UINT8 | RO | 0x10 (16dec)
F600:01 | Us Undervoltage |  | BOOLEAN | RO | 0x00 (0dec)
F600:02 | Up Undervoltage |  | BOOLEAN | RO | 0x00 (0dec)
F600:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)


ELxxxx - restoring the delivery state

BECKHOFF ELxxxx: Configuration

Restoring the delivery state

To restore the delivery state for backup objects in ELxxxx terminals, the CoE object "Restore default parameters", SubIndex 001 can be selected in the TwinCAT System Manager (Config mode) (see Fig. 1)

Fig. 1 Selecting the "Restore default parameters" PDO

Double-click on SubIndex 001 to enter the Set Value dialog. Enter the value 1684107116 in field "Dec" or the value 0x64616F6C in field "Hex" and confirm with OK (Fig. 2).
All backup objects are reset to the delivery state.

Fig. 2 Entering a restore value in the Set Value dialog

Note 		Alternative restore value

In some older terminals the backup objects can be switched with an alternative restore value:

Decimal value: "1819238756"

Hexadecimal value: "0x6C6F6164"

An incorrect entry for the restore value has no effect.


EtherCAT - Firmware

BECKHOFF EtherCAT: Device Update

Firmware EL/ES/EM/EPxxxx

This section describes the device update for Beckhoff EtherCAT slaves from the EL/ES, EM, EK and EP series. A firmware update should only be carried out after consultation with Beckhoff support.

Table of contents
• Storage locations
• Device description ESI file/XML
• Frimware version definition
• Updating Controller firmware *.efw
• FPGA firmware update *.rbf
• Multiple update

Storage locations

An EtherCAT slave stores operating data in up to 3 locations:

  • Depending on functionality and performance EtherCAT slaves have one or several local controllers for processing I/O data. The corresponding program is the so-called firmware in *.efw format.
  • In some EtherCAT slaves the EtherCAT communication may also be integrated in these controllers. In this case the controller is usually a so-called FPGA chip with *.rbf firmware.
  • In addition each EtherCAT slave has a memory chip for storing its own device description, a so-called EEPROM. On power-up this description is loaded and the EtherCAT communication is set up accordingly. The device description is available from the download area of the Beckhoff website at http://www.beckhoff.com . All ESI files (EtherCAT Slave Information) are available in ZIP format.

Customers can access the data via the EtherCAT fieldbus and its communication mechanisms. Acyclic mailbox communication or register access to the ESC is used for updating or reading of these data.

The TwinCAT System Manager offers mechanisms for programming all 3 parts with new data, if the slave is set up for this purpose. Generally the slave does not check whether the new data are suitable, i.e. it may no longer be able to operate if the data are unsuitable.

Attention 		Risk of damage to the device!
Note the following when downloading new device files
  • Firmware downloads to an EtherCAT device must not be interrupted
  • Flawless EtherCAT communication must be ensured. CRC errors or Lost Frames must be avoided.
  • The power supply must adequately dimensioned. The signal level must meet the specification.

In the event of malfunctions during the update process the EtherCAT device may become unusable and require re-commissioning by the manufacturer.

Device description ESI file/XML

Attention 		Notice regarding update of the ESI description/EEPROM
Some slaves have stored calibration and configuration data from the production in the EEPROM. These are irretrievably overwritten during an update.

The ESI device description is stored locally on the slave and loaded on start-up. Each device description has a unique identifier consisting of slave name (9 characters/digits) and a revision number (4 digits). Each slave configured in the System Manager shows its identifier in the EtherCAT tab:

Fig. 1: Device identifier consisting of name EL3204-0000 and revision -0016

The configured identifier must be compatible with the actual device description used as hardware, i.e. the description which the slave has loaded on start-up (in this case EL3204). Generally the configured revision must be equal or lower than the version used in the terminal network.

For further information please refer to the EtherCAT System Documentation.

Note 		Update of XML/ESI description
The device revision is closely linked to the firmware and hardware used. Incompatible combinations lead to malfunctions or even final shutdown of the device.
Corresponding updates should only be carried out in consultation with Beckhoff support.

Display of ESI slave identifier

The simplest way to ascertain compliance of configured and actual device description is to scan the EtherCAT boxes in TwinCAT mode Config/Freerun:

Fig. 2: Scan the subordinate field by right-clicking on the EtherCAT device in Config/FreeRun mode

If the found field matches the configured field, the display shows

Fig. 3: Configuration is identical

otherwise a change dialog for entering the actual data in the configuration.

Fig. 4: Change dialog

In the example shown in Fig. 4. an EL3201-0000-0017 was found, while an EL3201-0000-0016 had been configured. In this case it makes sense to adapt the configuration with the Copy Before button. The Extended Information checkbox must be set in order to have the revision displayed.

Changing the ESI slave identifier

The ESI/EEPROM identifier can be updated as follows under TwinCAT:

  • The EtherCAT communication with the slave must be flawless.
  • The state of the slave is irrelevant.
  • Right-click on the slave in the online display to bring up the EEPROM Update dialog, Fig. 5

Fig. 5: EEPROM Update

Select the new ESI description in the following dialog, see Fig. 6. The ShowHiddenDevices checkbox also shows older, usually hidden slave versions.

Fig. 6: Selecting the new ESI

A progress bar in the System Manager shows the progress. Data are first written, then verified.

Note 		The change only takes effect after a restart.
Most EtherCAT devices read a modified ESI description immediately or after startup from the INIT. Some communication settings such as distributed clocks are only read during power-on.
The EtherCAT slave therefore has to be switched off briefly in order for the change to take effect.

Determining the firmware version

Determining the version on laser inscription

Beckhoff EtherCAT slaves feature serial numbers applied by laser. The serial number has the following structure: KK YY FF HH

KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version

Example with ser. no.: 12 10 03 02:

12 - week of production 12
10 - year of production 2010
03 - firmware version 03
02 - hardware version 02

Determining the version via the System Manager

The TwinCAT System Manager shows the version of the controller firmware if the master can access the slave online. Click on the E-Bus Terminal whose controller firmware you want to check (in the example terminal 2 (EL3204)) and select the tab CoE Online (CAN over EtherCAT).

Note 		CoE Online and Offline CoE
Two CoE directories are available:
  • online: This is offered in the EtherCAT slave by the controller, if the EtherCAT slave does supported it.
    This CoE directory can only be displayed if a slave is connected and operational.
  • offline: The EtherCAT Slave Information ESI/XML may contain the default content of the CoE.
    This CoE directory can only be displayed if it is included in the ESI (e.g. "Beckhoff EL5xxx.xml").

The Advanced button must be used for switching between the two views.

In Fig. 7 the firmware version of the selected EL3204 is shown as 03 in CoE entry x100A.

Fig. 7: Display of EL3204 firmware version

In (A) TwinCAT 2.11 shows that the Online CoE directory is currently displayed. If this is not the case, the Online directory can be loaded via the Online option in Advanced Settings (B) and double-clicking on AllObjects.

Updating controller firmware *.efw

Note 		CoE directory
The Online CoE directory is managed by the controller and stored in a dedicated EEPROM, which is generally not changed during a firmware update.

To update the controller firmware of a slave switch to tab Online, see Fig. 8.

Fig. 8: Firmware Update

Proceed as follows, unless instructed otherwise by Beckhoff support.

  • Switch slave to INIT (A)
  • Switch slave to BOOTSTRAP
  • Check the current status (B, C)
  • Download the new *efw file
  • After the download switch to INIT, then OP
  • Switch off the slave briefly

FPGA firmware *.rbf

If an FPGA chip deals with the EtherCAT communication an update may be accomplished via an *.rbf file.

  • Controller firmware for processing I/O signals
  • FPGA firmware for EtherCAT communication (only for terminals with FPGA)

The firmware version number included in the terminal serial number contains both firmware components. If one of these firmware components is modified this version number is updated.

Determining the version via the System Manager

The TwinCAT System Manager indicates the FPGA firmware version. Click on the Ethernet card of your EtherCAT strand (Device 2 in the example) and select the Online tab.

The Reg:0002 column indicates the firmware version of the individual EtherCAT devices in hexadecimal and decimal representation.

Fig. 9: FPGA firmware version definition

If the column Reg:0002 is not displayed, right-click the table header and select Properties... in the context menu.

Fig. 10: Context menu Properties

The Advanced Settings dialog appears where the columns to be displayed can be selected. Under Diagnosis/Online View select the '0002 ETxxxx Build' check box in order to activate the FPGA firmware version display.

Fig. 11: Dialog Advanced Settings

Update

For updating the FPGA firmware

  • of an EtherCAT coupler the coupler must have FPGA firmware version 11 or higher;
  • of an E-Bus Terminal the terminal must have FPGA firmware version 10 or higher.

Older firmware versions can only be updated by the manufacturer!

Updating an EtherCAT device

In the TwinCAT System Manager select the terminal whose FPGA firmware you want to update (in this example terminal 5: EL5001) and
click on Advanced Settings in the EtherCAT tab.

Fig. 12: Select dialog Advanced Settings

The Advanced Settings dialog appears. Under ESC Access/E²PROM/FPGA click on Write FPGA button,

Fig. 13: Select dialog Write FPGA

select the file (*.rbf) with the new FPGA firmware, and transfer it to the EtherCAT device.

Attention 		Risk of damage to the device!
A firmware download to an EtherCAT device must never be interrupted!

If this process is cancelled, the supply voltage switched off or the Ethernet connection interrupted, the EtherCAT device can only be recommissioned by the manufacturer!

In order to activate the new FPGA firmware a restart (switching the power supply off and on again) of the EtherCAT device is required.

Simultaneous updating of several EtherCAT devices

The firmware and ESI descriptions of several devices can be updated simultaneously, provided the devices have the same firmware file/ESI.

Fig. 14: Multiple selection and firmware update

Select the required slaves and carry out the firmware update in BOOTSTRAP mode as described above.


General operating conditions

Protection degrees (IP-Code)

The standard IEC 60529 (DIN EN 60529) defines the degrees of protection in different classes.

1. Number: dust protection and touch guard | Definition
0 | Non-protected
1 | Protected against access to hazardous parts with the back of a hand. Protected against solid foreign objects of Ø50 mm
2 | Protected against access to hazardous parts with a finger. Protected against solid foreign objects of Ø12,5 mm.
3 | Protected against access to hazardous parts with a tool. Protected against solid foreign objects Ø2,5 mm.
4 | Protected against access to hazardous parts with a wire. Protected against solid foreign objects Ø1 mm.
5 | Protected against access to hazardous parts with a wire. Dust-protected. Intrusion of dust is not totally prevented, but dust shall not penetrate in a quantity to interfere with satisfactory operation of the device or to impair safety.
6 | Protected against access to hazardous parts with a wire. Dust-tight. No intrusion of dust.
2. Number: water* protection | Definition
0 | Non-protected
1 | Protected against water drops
2 | Protected against water drops when enclosure tilted up to 15°.
3 | Protected against spraying water. Water sprayed at an angle up to 60° on either side of the vertical shall have no harmful effects.
4 | Protected against splashing water. Water splashed against the disclosure from any direction shall have no harmful effects
5 | Protected against water jets
6 | Protected against powerful water jets
7 | Protected against the effects of temporary immersion in water. Intrusion of water in quantities causing harmful effects shall not be possible when the enclosure is temporarily immersed in water for 30 min. in 1 m depth.

*) These protection classes define only protection against water!

Chemical Resistance

The Resistance relates to the Housing of the Fieldbus Box and the used metal parts.

Character | Resistance
Steam | at temperatures >100°C: not resistant
Sodium base liquor (ph-Value > 12) | at room temperature: resistant > 40°C: not resistant
Acetic acid | not resistant
Argon (technical clean) | resistant
Key

resistant: Lifetime several months
non inherently resistant: Lifetime several weeks
not resistant: Lifetime several hours resp. early decomposition


Support und Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.

Beckhoff Support

Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:

  • Support
  • Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
  • umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com

Beckhoff Service

Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:

  • Vor-Ort-Service
  • Reparaturservice
  • Ersatzteilservice
  • Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com

Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.

Beckhoff Firmenzentrale

Beckhoff Automation GmbH

Eiserstr. 5
33415 Verl
Deutschland

Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com

Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de

Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.


EP1816-3008 - Introduction

BECKHOFF EP1816-3008: Mounting and cabling

Operating modes

2 x 3G acceleration sensors

The EP1816-3008 EtherCAT Box features 2 3-axis acceleration sensors.

They are fitted on the underside the PCB at 90° angles.

The image shows a top view and a side view of the EtherCAT Box. It shows the location of the acceleration sensors within the Box. The green line indicates the location of the PCB. The acceleration sensors are numbered 1 and 2. They are mounted on the underside of the PCB.

In this position, gravity (which is a form of acceleration), is displayed as a negative value when the Box is in its normal operating position on a flat, level surface, e.g. on a test bench.

Process data mode

By default the data from the acceleration sensors, in each case X, Y and Z axis values, are displayed as RAW data, i.e. directly in the form in which they are transferred from the sensors.

Fig.: CoE object 8080:1D

For display as angle the CoE parameter 8080:1D must be set to value 4, "Horizontal Off-Axis-Angle".


EtherCAT Box - Accessories

Fixing
Ordering information | Description
ZS5300-0001 | Mounting rail (500 mm x 129 mm)
Marking material, plugs
Ordering information | Description
ZS5000-0000 | Fieldbus Box set M8 (contact labels, plugs)
ZS5000-0002 | Fieldbus Box set M12 (contact labels, plugs)
ZS5000-0010 | plugs M8, IP67 (50 pieces)
ZS5000-0020 | plugs M12, IP67 (50 pieces)
ZS5100-0000 | marking labels, not printed, 4 stripes at 10 pieces
ZS5100-xxxx | printed marking labels, on request
Tools
Ordering information | Description
ZB8800 | Torque socket wrench with ratchet wrench for M8 connectors (over molded)
ZB8800-0001 | ratchet wrench for M8 connectors (field assembly)
ZB8800-0002 | ratchet wrench for M12 connectors (over molded)

Note 		Further accessories
Further accessories may be found at the price list for Beckhoff fieldbus components and at the internet under www.beckhoff.com.