EtherCAT Box with 8 digital inputs and 2 counters
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation Issue Status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation Issue Status

Foreword [image] Documentation Issue Status
Documentation Issue Status
Version
Comment
2.2
▪
Front page updated
▪
Scope of supply added
▪
Structure update
2.1.0
▪
Update Safety instructions
▪
Correction chapter Power cable
▪
Update chapter Mounting
2.0.0
▪
Migration
▪
Basic function principles chapter corrected
1.1.0
▪
Power Connection updated
1.0.0
▪
First release
Firmware and hardware versions
This documentation refers to the firmware and hardware version that was applicable at the time the documentation was written.
The module features are continuously improved and developed further. Modules having earlier production statuses cannot have the same properties as modules with the latest status. However, existing properties are retained and are not changed, so that older modules can always be replaced with new ones.
Documentation Version | Firmware | Hardware
2.2 | 04 | 08
2.1 | 04 | 06
2.0.0 | 04 | 05
1.0.0 | 02 | 00
The firmware and hardware version (delivery state) can be found in the batch number (D-number) printed on the side of the EtherCAT Box.
Syntax of the batch number (D-number)
WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with D no.: 55 09 01 00:
55 - week of production 55
09 - year of production 2009
01 - firmware version 01
00 - hardware version 001
Further information on this topic: Version identification of EtherCAT devices.


EtherCAT Box - Introduction

EtherCAT Box - Introduction
EtherCAT Box - Introduction
The EtherCAT system has been extended with EtherCAT Box modules with protection class IP 67. Through the integrated EtherCAT interface the modules can be connected directly to an EtherCAT network without an additional Coupler Box. The high-performance of EtherCAT is thus maintained into each module.
The extremely low dimensions of only 126 x 30 x 26.5 mm (h x w x d) are identical to those of the Fieldbus Box extension modules. They are thus particularly suitable for use where space is at a premium. The small mass of the EtherCAT modules facilitates applications with mobile I/O interface (e.g. on a robot arm). The EtherCAT connection is established via screened M8 connectors.
EtherCAT Box Modules within an EtherCAT network
The robust design of the EtherCAT Box modules enables them to be used directly at the machine. Control cabinets and terminal boxes are now no longer required. The modules are fully sealed and therefore ideally prepared for wet, dirty or dusty conditions.
Pre-assembled cables significantly simplify EtherCAT and signal wiring. Very few wiring errors are made, so that commissioning is optimized. In addition to pre-assembled EtherCAT, power and sensor cables, field-configurable connectors and cables are available for maximum flexibility. Depending on the application, the sensors and actuators are connected through M8 or M12 connectors.
The EtherCAT modules cover the typical range of requirements for I/O signals with protection class IP67:
▪
digital inputs with different filters (3.0 ms or 10 μs)
▪
digital outputs with 0.5 or 2 A output current
▪
analog inputs and outputs with 16 bit resolution
▪
Thermocouple and RTD inputs
▪
Stepper motor modules
XFC (eXtreme Fast Control Technology) modules, including inputs with time stamp, are also available.
EtherCAT Box with M8 connections for sensors/actuators
EtherCAT Box with M12 connections for sensors/actuators
Basic EtherCAT documentation
You will find a detailed description of the EtherCAT system in the Basic System Documentation for EtherCAT, which is available for download from our website (www.beckhoff.com) under Downloads.
EtherCAT XML Device Description
You will find XML files (XML Device Description Files) for Beckhoff EtherCAT modules on our website (www.beckhoff.com) under Downloads, in the Configuration Files area.


Product overview

Product overview
Product overview
Additional information
•
Introduction
•
Technical data
•
Process image


Introduction

Product overview [image] Introduction
Introduction
EP1518-0002
8 digital inputs (24 VDC), 2 counters
The EP1518-0002 EtherCAT Box with digital inputs acquires binary control signals from the process level and transfers them, with electrical isolation, to the controller.
The signal state is indicated by means of light emitting diodes. Connection is via M12 connectors. The input filters can be set between 0 and 100 ms via EtherCAT.
Inputs 0 and 4 can be used as up/down counters (32-bit). Inputs 1 and 5 operate as GATES and inputs 2 and 6 control Up/Down.
The EP1518 has three modes of operation that can be selected via the PDOs using the Sync-Manager:
▪
2 digital inputs and 2 counters (delivery state)
▪
5 digital inputs and 1 counter
▪
8 digital inputs
All inputs continue to be shown in the process image even in the counter operation modes. Signal acquisition takes place with the filter times set via CoE.
Irrespective of that, the counter pulses are always counted with a filter of 150 µs. Further parameters can be set via the CoE objects.
The sensors are supplied via the control voltage US in two groups of four sensors each. Any short circuits on the sensor side are detected and reported to the controller.
The load voltage Up is not used in the input module, but may optionally be connected in order to be relayed downstream.
Quick links


Technical data

Product overview [image] Technical data
Technical data
Technical data | EP1518-0002
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Number of inputs | 8, 2 of which can be used as 32-bit up/down counters
Input connections | M12
Nominal input voltage | 24 VDC (-15%/+20%)
Input filter (binary inputs) | adjustable 10 µs…100 ms
Input filter (counter input) | 150 µs
"0" signal voltage | -3...+5 V (EN 61131-2, type 3)
"1" signal voltage | +11...+30 V (EN 61131-2, type 3)
Input current | typically 3 mA (EN 61131-2, type 3)
Module electronic supply | derived from control voltage Us
Module electronic current consumption | typically 120 mA
Sensor supply | derived from control voltage Us
Sensor current consumption | max. 0.5 A per 4 sensors, short-circuit proof
Power supply connection | Power supply: 1 x M8 plug, 4-pole Onward connection: 1 x M8 socket, 4-pole
Input process image | 8 bits data, 8 bits diagnostics, 48 bits counter
Output process image | 48 bits counter
Distributed clocks | yes
Electrical isolation control voltage/fieldbus | 500 V
Weight | approx. 165 g
Permissible ambient temperature during operation | -25°C ... +60°C 0°C ... +55°C (conforms to cULus, see UL requirements) 0°C ... +55°C (conforms to ATEX, see special conditions)
Permissible ambient temperature during storage | -40°C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable
Approvals | CE, cULus, ATEX


Process image

Product overview [image] Process image
Process image
The process image depends on the selected operation mode.
Operation mode: 2 counters and 2 digital inputs (delivery state)
The input data of the 1st counter can be found under CNT Input Channel 1.
The adoption of the Set counter bit from CNT Output Channel 1 is displayed with Set counter done.
The adoption of the Inhibit counter bit from CNT Output Channel 1 is displayed with Counter inhibited.
Status of input UD shows the status of the Up/Down counter input of the 1st counter.
Status of input clock shows the status of the input clock input of the 1st counter.
Sync Error, TxPDO State and TxPDO Toggle are standard EtherCAT process data.
The input data of the 2nd counter can be found under CNT Input Channel 2. Their structure corresponds to that of the 1st counter.
DIG Inputs shows the states of the individual inputs irrespective of the selected operation mode.
Error channel 1 displays a short circuit of the supply voltage Us to digital inputs 0 to 3.
Error channel 2 displays a short circuit of the supply voltage Us to digital inputs 4 to 7.
The output data of the 1st counter can be found under CNT Output Channel 1.
The setting of Set counter activates the adoption of the Set Counter Value into the Counter Value of the 1st counter.
The setting of Inhibit Counter disables the 1st counter.
Alternatively the counter can be disabled or enabled by the physical GATE input.
The two values are XORed.
The output data of the 2nd counter can be found under CNT Output Channel 1. Their structure corresponds to that of the 1st counter.
Operation mode: 1 counter and 5 digital inputs
The input data of the 1st counter can be found under CNT Input Channel 1.
The adoption of the Set counter bit from CNT Output Channel 1 is displayed with Set counter done.
The adoption of the Inhibit counter bit from CNT Output Channel 1 is displayed with Counter inhibited.
Status of input UD shows the status of the Up/Down counter input of the 1st counter.
Status of input clock shows the status of the input clock input of the 1st counter.
Sync Error, TxPDO State and TxPDO Toggle are standard EtherCAT process data.
DIG Inputs shows the states of the individual inputs irrespective of the selected operation mode.
Error channel 1 displays a short circuit of the supply voltage Us to digital inputs 0 to 3.
Error channel 2 displays a short circuit of the supply voltage Us to digital inputs 4 to 7.
The output data of the 1st counter can be found under CNT Output Channel 1.
The setting of Set counter activates the adoption of the Set Counter Value into the Counter Value of the 1st counter.
The setting of Inhibit Counter disables the 1st counter.
Alternatively the counter can be disabled or enabled by the physical GATE input.
The two values are XORed.
Operation mode: 8 digital inputs
DIG Inputs shows the states of the individual inputs irrespective of the selected mode.
Error channel 1 displays a short circuit of the supply voltage Us to digital inputs 0 to 3.
Error channel 2 displays a short circuit of the supply voltage Us to digital inputs 4 to 7.


Installation

Installation
Installation
Additional information
•
Mounting
•
Connection
•
UL Requirements
•
ATEX notes


Mounting

Installation [image] Mounting
Mounting
Additional information
•
Dimensions
•
Fixing
•
Tightening torques for plug connectors


Dimensions

Installation [image] Mounting [image] Dimensions
Dimensions
Dimensions
All dimensions are given in millimeters.
Housing features
Housing material | PA6 (polyamide)
Sealing compound | polyurethane
Mounting | two fastening holes Ø 3.5 mm for M3
Metal parts | brass, nickel-plated
Contacts | CuZn, gold-plated
Power feed through | max. 4 A
Installation position | variable
Protection class | IP65, IP66, IP67 (conforms to EN 60529) when screwed together
Dimensions (H x W x D) | approx. 126 x 30 x 26.5 mm (without connectors)


Fixing

Installation [image] Mounting [image] Fixing
Fixing
Note
Dirt during assembly
Dirty connectors can lead to malfunctions. Protection class IP67 can only be guaranteed if all cables and connectors are connected.
•
Protect the plug connectors against dirt during the assembly.
Mount the module with two M3 screws on the fastening holes in the corners of the module. The fastening holes have no thread.


Tightening torques for plug connectors

Installation [image] Mounting [image] Tightening torques for plug connectors
Tightening torques for plug connectors
Screw connectors tight with a torque wrench. (e.g. ZB8801 from Beckhoff)
Connector diameter | Tightening torque
M8 | 0.4 Nm
M12 | 0.6 Nm


Connection

Installation [image] Connection
Connection
Additional information
•
EtherCAT
•
Supply voltages
•
Signal connection
•
Status LEDs at the signal connections


EtherCAT

Installation [image] Connection [image] EtherCAT
EtherCAT
Additional information
•
Connectors
•
Status LEDs
•
Cables


Connectors

Installation [image] Connection [image] EtherCAT [image] Connectors
Connectors
Note
Risk of confusion: supply voltages and EtherCAT
Defect possible through incorrect insertion.
•
Observe the color coding of the connectors:
black: Supply voltages
green: EtherCAT
EtherCAT Box Modules have two green M8 sockets for the incoming and downstream EtherCAT connections.
EtherCAT connectors
Connection
M8 socket, 4-pin – connection
M8 socket
EtherCAT | M8 connector | Core colors
Signal | Contact | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 and old versions of ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | 1 | yellow1) | orange/white | white/orange
Tx - | 4 | orange1) | orange | orange
Rx + | 2 | white1) | blue/white | white/green
Rx - | 3 | blue1) | blue | green
Shield | Housing | Shield | Shield | Shield
1) Core colors according to EN 61918
Adaptation of core colors for cables ZB9030, ZB9032 and ZK1090-3xxxx-xxxx
For standardization, the core colors of the ZB9030, ZB9032 and ZK1090-3xxx-xxxx cables have been changed to the EN61918 core colors: yellow, orange, white, blue. So there are different color codes in circulation. The electrical properties of the cables have been retained when the core colors were changed.


Status LEDs

Installation [image] Connection [image] EtherCAT [image] Status LEDs
Status LEDs
EtherCAT status LEDs
L/A (Link/Act)
A green LED labelled "L/A" is located next to each EtherCAT socket. The LED indicates the communication state of the respective socket:
LED | Meaning
off | no connection to the connected EtherCAT device
lit | LINK: connection to the connected EtherCAT device
flashes | ACT: communication with the connected EtherCAT device
Run
Each EtherCAT slave has a green LED labelled "Run". The LED signals the status of the slave in the EtherCAT network:
LED | Meaning
off | Slave is in "Init" state
flashes uniformly | Slave is in "Pre-Operational“ state
flashes sporadically | Slave is in "Safe-Operational" state
lit | Slave is in "Operational" state
Description of the EtherCAT slave states


Cables

Installation [image] Connection [image] EtherCAT [image] Cables
Cables
For connecting EtherCAT devices only shielded Ethernet cables that meet the requirements of at least category 5 (CAT5) according to EN 50173 or ISO/IEC 11801 should be used.
EtherCAT uses four wires for signal transmission.
Thanks to automatic line detection ("Auto MDI-X"), both symmetrical (1:1) or cross-over cables can be used between Beckhoff EtherCAT.
Detailed recommendations for the cabling of EtherCAT devices


Supply voltages

Installation [image] Connection [image] Supply voltages
Supply voltages
The EtherCAT Box is supplied with two supply voltages. The ground potentials of the supply voltages are galvanically connected together.
▪
Control voltage US
▪
Peripheral voltage UP
Redirection of the supply voltages
The IN and OUT power connections are bridged in the module (not IP204x-Bxxx and IE204x). The supply voltages US and UP can thus easily be transferred from EtherCAT Box to EtherCAT Box.
Note
Pay attention to the maximum permissible current!
Pay attention also for the redirection of the supply voltages US and UP, the maximum permissible current for M8 connectors of 4 A must not be exceeded!
Additional information
•
Connectors
•
Status LEDs for the power supply
•
Conductor losses


Connectors

Installation [image] Connection [image] Supply voltages [image] Connectors
Connectors
Note
Risk of confusion: supply voltages and EtherCAT
Defect possible through incorrect insertion.
•
Observe the color coding of the connectors:
black: Supply voltages
green: EtherCAT
Connectors for supply voltages
M8 connector
Contact | Function | Description | Core color 1)
1 | US | Control voltage | Brown
2 | UP | Peripheral voltage | White
3 | GNDS | GND to US | Blue
4 | GNDP | GND to UP | Black
1) The core colors apply to cables of the type: Beckhoff ZK2020-3xxx-xxxx


Status LEDs for the power supply

Installation [image] Connection [image] Supply voltages [image] Status LEDs for the power supply
Status LEDs for the power supply
Status LEDs for the power supply
All LEDs, green and red, are activated once briefly during the initialization phase of the box.
LED | Display | Meaning
Us (control voltage) | off | The supply voltage, Us, is not present
 | green illuminated | The supply voltage, Us, is present
 | red illuminated | Due to overload (current > 0.5 A), the sensor supply generated from the supply voltage Us is switched off for all sensors in group 1 (inputs 0 to 3) or group 2 (inputs 4 to 7) that it supplies.
Up (peripheral voltage) | off | The supply voltage, Up, is not present
 | green illuminated | The supply voltage, Up, is present


Conductor losses

Installation [image] Connection [image] Supply voltages [image] Conductor losses
Conductor losses
Take into account the voltage drop on the supply line when planning a system. Avoid the voltage drop being so high that the supply voltage at the box lies below the minimum nominal voltage.
Variations in the voltage of the power supply unit must also be taken into account.
Voltage drop on the supply line
Leitungsverluste M8 2A
Leitungsverluste M8 4A


Signal connection

Installation [image] Connection [image] Signal connection
Signal connection
Digital inputs M8 and M12
The digital input modules acquire the binary control signals from the process level and transmit them to the higher-level automation device.
The signals are connected via M8 connectors (EPxxxx-0001) or M12 connectors (EPxxxx-0002).
Signal connection - digital inputs M8 and M12
The sensors are supplied with a common maximum current of 0.5 A from the control voltage Us.
Light emitting diodes indicate the signal state of the inputs.


Status LEDs at the signal connections

Installation [image] Connection [image] Status LEDs at the signal connections
Status LEDs at the signal connections
Irrespective of the operation mode set, each channel indicates the status of its connected sensor by a green LED adjacent to the signal socket.
Status LEDs at the signal connections
Connection | LED | Display | Meaning
M12 socket no. 1 | channel 0, channel 1 | off | input not set
 |  | green | input set
M12 socket no. 2 | channel 2, channel 3 | off | input not set
 |  | green | input set
M12 socket no. 3 | channel 4, channel 5 | off | input not set
 |  | green | input set
M12 socket no. 4 | channel 6, channel 7 | off | input not set
 |  | green | input set


UL Requirements

Installation [image] UL Requirements
UL Requirements
The installation of the EtherCAT Box Modules certified by UL has to meet the following requirements.
Supply voltage
SmallWarningYellow CAUTION
CAUTION!
This UL requirements are valid for all supply voltages of all marked EtherCAT Box Modules!
For the compliance of the UL requirements the EtherCAT Box Modules should only be supplied
•
by a 24 VDC supply voltage, supplied by an isolating source and protected by means of a fuse (in accordance with UL248), rated maximum 4 Amp, or
•
by a 24 VDC power source, that has to satisfy NEC class 2.
A NEC class 2 power supply shall not be connected in series or parallel with another (class 2) power source!
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, the EtherCAT Box Modules must not be connected to unlimited power sources!
Networks
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, EtherCAT Box Modules must not be connected to telecommunication networks!
Ambient temperature range
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, EtherCAT Box Modules has to be operated only at an ambient temperature range of 0 to 55°C!
Marking for UL
All EtherCAT Box Modules certified by UL (Underwriters Laboratories) are marked with the following label.
UL label


ATEX notes

Installation [image] ATEX notes
ATEX notes
Additional information
•
ATEX - Special conditions
•
BG2000 - EtherCAT Box protection enclosures
•
ATEX Documentation


ATEX - Special conditions

Installation [image] ATEX notes [image] ATEX - Special conditions
ATEX - Special conditions
SmallWarningYellow WARNING
Observe the special conditions for the intended use of EtherCAT Box modules in potentially explosive areas – directive 94/9/EU.
•
The certified components are to be installed with a BG2000-0000 or BG2000-0010 protection enclosure that guarantees a protection against mechanical hazards!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of 0 to 55°C for the use of EtherCAT Box modules in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0: 2006
▪
EN 60079-15: 2005
Marking
The EtherCAT Box modules certified for potentially explosive areas bear the following marking:
II 3 G Ex nA II T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
or
II 3 G Ex nA nC IIC T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
Batch number (D number)
The EtherCAT Box modules bear a batch number (D number) that is structured as follows:
D: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with batch number 29 10 02 01:
29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01


BG2000 - EtherCAT Box protection enclosures

Installation [image] ATEX notes [image] BG2000 - EtherCAT Box protection enclosures
BG2000 - EtherCAT Box protection enclosures
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the EtherCAT system into a safe, powered down state before starting installation, disassembly or wiring of the modules!
ATEX
SmallWarningYellow WARNING
Mount a protection enclosure!
To fulfill the special conditions according to ATEX, a BG2000-0000 or BG2000-0010 protection enclosure has to be mounted over the EtherCAT Box.
Installation
Put the cables for EtherCAT, power supply and sensors/actuators through the hole of the protection enclosure.
BG2000 - putting the cables
Fix the wires for EtherCAT, power supply and sensors/actuators to the EtherCAT Box.
BG2000 - fixing the cables
Mount the protection enclosure over the EtherCAT Box.
BG2000 - mounting the protection enclosure


ATEX Documentation

Installation [image] ATEX notes [image] ATEX Documentation
ATEX Documentation
Notes about operation of EtherCAT Box Modules (EPxxxx-xxxx) in potentially explosive areas (ATEX)
Pay also attention to the continuative documentationNotes about operation of EtherCAT Box Modules (EPxxxx-xxxx) in potentially explosive areas (ATEX) that is available in the download area of the Beckhoff homepage http:\\www.beckhoff.com!


Commissioning and configuration

Commissioning and configuration
Commissioning and configuration
Additional information
•
Integration in TwinCAT
•
Distributed Clocks (DC)
•
Distributed Clocks and EP1518
•
Configuration of the EP1518
•
CoE objects


Integration in TwinCAT

Commissioning and configuration [image] Integration in TwinCAT
Integration in TwinCAT
The procedure for integration in TwinCAT is described in this Quick start guide.


Distributed Clocks (DC)

Commissioning and configuration [image] Distributed Clocks (DC)
Distributed Clocks (DC)
EtherCAT System Documentation
A basic introduction to the topic of EtherCAT and Distributed Clocks is available in the Download area on the Beckhoff homepage: EtherCAT System Documentation.
The EtherCAT Box supports Distributed Clocks functionality. In order for the Box to be able to make the current counter value available in the designated process data in time before the arrival of the querying EtherCAT datagram, a suitable signal must be generated cyclically within the terminal. This signal can be triggered in the Box through 2 events: the SyncManager (SM) and the distributed clock (DC). Under operation mode selection the following options are available (see Fig. "DC" (Disributed Clocks) tab)
▪
SM-synchron
The SynManager event occurs when an EtherCAT frame successfully exchanges process data with the EP1518. Frame-triggered, the current counter value is thus cyclically determined, but with the low temporal jitter of the Ethernet frame.
▪
DC-synchron
In DC operation mode determination of the counter value is triggered cyclically at constant intervals through the integrated DC unit, synchronous with the bus cycle as standard. More uniform polling offers higher-quality position data for a higher-level control algorithm, for example. In the EP1518 the SYNC0 signal acts as trigger.
DC tab (Distributed Clocks)
When DC-Synchron operation mode is activated TwinCAT selects settings that ensure reliable operation of the Box with current position data. This means that determination of the current counter value is triggered by the SYNC0 signal at highly constant intervals and in good time (i.e. with an adequate safety buffer) before retrieving EtherCAT datagram is started.
If necessary, the SYNC0 signal can be shifted along the time axis to the right/later or left/earlier in associated dialogs by specifying a user-defined shift time, see Fig. Advanced Distributed Clock (DC) settings.
▪
A right-shift (positive shift value) will delay the counter value query, which means the position value becomes more current from the PLC perspective. However, this increases the risk that the position determination may not be finished in time before the arrival of EtherCAT frame, so that no current position value is available in this cycle.
▪
A left-shift (negative shift value) means the counter value will be queried earlier, resulting in older position values, with an associated increase in the safety buffer before the arrival of the EtherCAT datagram. This setting may be useful in systems with high real-time jitter, if no Industrial PCs from Beckhoff are used for control purposes, for example.
Note
Risk of device damage
The mentioned notes and information should be used advisedly.
The EtherCAT master automatically allocates SYNC0 and SYNC1 settings that support reliable and timely process data acquisition.
User intervention at this point may lead to undesired behavior.
If these settings are changed in the System Manager, no plausibility checks are carried out on the software side. Correct function of the terminal with all conceivable setting options cannot be guaranteed.
Default setting
The cyclic reading of the inputs is triggered by the SYNC0 pulse (interrupt) of the DC in the EtherCAT Box. The EtherCAT master sets the Sync Unit Cycle time value to the PLC cycle time and therefore the EtherCAT cycle time as standard. See Fig. Advanced Distributed Clock (DC) settings: 4000 µs = 4 ms, as TwinCAT is in configuration mode.
DC settings
Advanced settings for Distributed Clocks (DC)
SYNC0
Sync Unit cycle: a multiple of the bus cycle time. The counter value is periodically determined at this interval (in µs).
User defined
Any number up to 232 ns, or about 4.3 seconds. Use of decimal points is allowed.
Shift Time
The Shift Time can be used to shift the SYNC0 pulse for this EtherCAT Box relative to other Boxes/Terminals and the global SYNC pulse in nanosecond steps. If the inputs of several Boxes are read simultaneously, the same value must be entered here.
Based on input reference
If this option is activated an additional Input Shift is added to the configurable terminal-specific SYNC0 shift (user defined). This value is calculated and made available by the EtherCAT master (SysMan/Device EtherCAT/Tab EtherCAT/Advanced Settings/Distributed Clocks/Input Shift Time). As a result, all the input terminals in the system (EL1xxx, EL3xxx, EP1xxx, EP3xxx) read their inputs as close as possible to the time of the EtherCAT frame that will fetch them, thereby supplying the most recent possible input data to the controller.
Enable SYNC0
Automatically activated in DC-synchron operation mode.
SYNC1
Additional SYNC pulse, derived from SYNC0 or from the DC itself.
DC settings for EtherCAT master
Higher-level distributed clock parameters can be modified under advanced settings for the EtherCAT master. Refer also to the basic introduction to the topic of EtherCAT and Distributed Clocks; download: the Distributed Clocks system description.
EtherCAT Master, EtherCAT tab, Advanced Settings


Distributed Clocks and EP1518

Commissioning and configuration [image] Distributed Clocks and EP1518
Distributed Clocks and EP1518
Digital inputs and Distributed Clocks
If the Distributed Clock of the EP1518 is activated, the digital inputs are read in without the set filter promptly before the arrival of the querying EtherCAT datagram.


Configuration of the EP1518

Commissioning and configuration [image] Configuration of the EP1518
Configuration of the EP1518
Additional information
•
Basic Function Principles
•
Operation modes
•
Counter settings
•
Restoring the delivery state


Basic Function Principles

Commissioning and configuration [image] Configuration of the EP1518 [image] Basic Function Principles
Basic Function Principles
The EP1518 EtherCAT Box has 8 digital inputs. Of these, inputs 0, 1 and 2 as well as 4, 5 and 6 can each be used for one counter. The states of the individual inputs are always illustrated in the process image, irrespective of their use.
Input | M8 | M12 | Properties
0 | Socket 1, pin 4 | Socket 1, pin 4 | Digital input or counter input 1
1 | Socket 2, pin 4 | Socket 1, pin 2 | Digital input or Gate 1
2 | Socket 3, pin 4 | Socket 2, pin 4 | Digital input or Up/Down 1
3 | Socket 4, pin 4 | Socket 2, pin 2 | Digital input
4 | Socket 5, pin 4 | Socket 3, pin 4 | Digital input or counter input 2
5 | Socket 6, pin 4 | Socket 3, pin 2 | Digital input or Gate 2
6 | Socket 7, pin 4 | Socket 4, pin 4 | Digital input or Up/Down 2
7 | Socket 8, pin 4 | Socket 4, pin 2 | Digital input
Operation modes
The EP1518 can be operated in 3 modes; the mode is set by selecting the PDOs in the Sync-Manager:
Operation mode | Number of counter channels | Number of "free" digital inputs | Properties
2 up/down counters (32-bit) | 2 | 2 | Single pulses are counted at the counter inputs. The gate input or the software gate enables the counter. The count direction is specified via CoE.
2 up/down counters (32-bit) | 1 | 5
8 digital inputs, no counter | - | 8 | digital inputs: Filter for inputs 0 and 4 permanently set to 150 µs. The filter setting for the other inputs is configurable by software.
The GATE and Up/Down inputs can be converted to standard inputs.
Counting mode
The following settings for GATE and Up/Down can be combined and apply independently to each counter.
Counting mode with standard setting (up counter)
In the delivery state the Counter Value is incremented on each rising edge. The count direction is up.
The counter is disabled by applying a high level to the GATE input or by setting the Inhibit Counters bit.
Counting mode with standard setting
Counting mode with reversed count direction (down counter)
The count direction is changed by applying a high level to the Up/Down input or by setting the CoE object 0x80x0:04 Count down. The count direction is down.
Counting mode with reversed counting direction
Counting mode with inverted (negated) GATE input
In the default setting the counter is disabled by applying a high level to the GATE input or by setting the Inhibit Counters bit
Setting the CoE object 0x80x0:05 Enable input gate activates the counter if GATE is set and deactivates it if GATE is not set.
Counting mode with inverted GATE input
CoE for inverting the GATE input


Operation modes

Commissioning and configuration [image] Configuration of the EP1518 [image] Operation modes
Operation modes
Operation mode selection
The EP1518 can be operated in 3 modes:
▪
Two up/down counters (delivery state)
▪
One up/down counter
▪
8 digital inputs
The setting takes place by selecting the PDOs in the Sync-Manager:
Operation mode | Number of 32-bit counters | Number of "free" digital inputs | Properties
2 up/down counters | 2 | 2 | Single pulses at the counter inputs are counted; the Gate input or the software gate enables the counter; count direction via CoE
1 up/down counters | 1 | 5
8 digital inputs, no counter | - | 8 | digital inputs: Filter for inputs 0 and 4 permanently set to 150 µs. The filter setting for the other inputs is configurable by software.
Operation mode settings of the PDOs | 0x1600 | 0x1601 | 0x1A00 | 0x1A01 | 0x1A02 | 0x1A03 | Comments
2 up/down counters (32-bit) | 1 | 1 | 1 | 1 | 0/1 | 0/1 | 2 counters, digital inputs, diagnosis of Us
1 up/down counters (32-bit) | 1 | 0 | 1 | 0 | 0/1 | 0/1
8 digital inputs, no counter | 0 | 0 | 0 | 0 | 0/1 | 0/1 | digital inputs: Filter for inputs 0 and 4 permanently set to 150 µs. The filter setting for the other inputs is configurable by software.
The module parameters are set in the CoE objects 0x8000:0 for counter 1, 0x8010:0 for counter 2 and 0x8022:0 for the digital inputs. (integrate links)
The second counter is always active internally
Internally the second counter is always active, so that when switching from one 32-bit counter to two 32-bit counters the previous incoming pulses were counted in the second counter and saved in the Counter Value.
Two up/down counters
This is the delivery mode of the EP1518.
Setting of the PDOs 0x1600 and 0x1601, default settings of the objects 0x8000 to 0x8022:0
Setting of the PDOs 0x1A00 to 0x1A03, default settings of the objects 0x8000 to 0x8002:0
The PDOs 0x1600, 0x1601 as well as 0x1A00, 0x1A01, 0x1A02 and 0x1A03 are activated. The meaning of the individual objects is explained in the object description.
One up/down counter (0x1601 deactivated, 0x1A01 deactivated)
This mode can be set as follows:
Setting the PDOs 0x1600
Setting the PDOs 0x1A00, 0x1A02 and 0x1A03
The PDOs 0x1600 as well as 0x1A00, 0x1A02 and 0x1A03 are activated. The CoE objects are identical to the 2 x 32-bit counter operation mode.
8 digital inputs, no counter
This mode can be set as follows:
Setting the PDOs 0x1A02 and 0x1A03
The PDOs 0x1A02 and 0x1A03 are activated. The meaning of the individual objects is explained in the object description.


Counter settings

Commissioning and configuration [image] Configuration of the EP1518 [image] Counter settings
Counter settings
Enabling the GATE and Up/Down inputs as standard inputs
By setting the CoE objects Enable Input gate and Enable input UD, the inputs are no longer allocated to the counters, but are used as standard inputs.
Enabling the inputs
Setting the counter to a value specified by the process data
The counter (counter value) can be set to any desired value by the controller.
To do this, set the desired value in Set counter value. The value is then adopted by Counter value on a rising edge of the Set counter control bit.
Setting the counter
Automatic setting/resetting of the counter to a defined value
If a desired value is set in Counter reload value and the Enable reload bit is activated, the counter is set to 0 or to the set value if the specified value is exceeded or fallen below (depending on the counting direction).
Automatic setting of the counter


Restoring the delivery state

Commissioning and configuration [image] Configuration of the EP1518 [image] Restoring the delivery state
Restoring the delivery state
To restore the delivery state for backup objects in ELxxxx terminals / EPxxxx- and EPPxxxx boxes, the CoE object Restore default parameters, SubIndex 001 can be selected in the TwinCAT System Manager (Config mode).
Selecting the Restore default parameters PDO
Double-click on SubIndex 001 to enter the Set Value dialog. Enter the value 1684107116 in field Dec or the value 0x64616F6C in field Hex and confirm with OK.
All backup objects are reset to the delivery state.
Entering a restore value in the Set Value dialog
Alternative restore value
In some older terminals / boxes the backup objects can be switched with an alternative restore value:
Decimal value: 1819238756
Hexadecimal value: 0x6C6F6164
An incorrect entry for the restore value has no effect.


CoE objects

Commissioning and configuration [image] CoE objects
CoE objects
Additional information
•
Object overview
•
Object description and parameterization


Object overview

Commissioning and configuration [image] CoE objects [image] Object overview
Object overview
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Index (hex) |  | Name | Flags | Default value
1000 |  | Device type | RO | 0x00001389 (5001dec)
1008 |  | Device name | RO | EP1518-0002
1009 |  | Hardware version | RO | 00
100A |  | Software version | RO | 01.03
1011:0 | Subindex | Restore default parameters | RO | 0x01 (1dec)
 | 1011:01 | SubIndex 001 | RW | 0x00000000 (0dec)
1018:0 | Subindex | Identity | RO | 0x04 (4dec)
 | 1018:01 | Vendor ID | RO | 0x00000002 (2dec)
 | 1018:02 | Product code | RO | 0x05EE4052 (99500114dec)
 | 1018:03 | Revision | RO | 0x00100002 (1048578dec)
 | 1018:04 | Serial number | RO | 0x00000000 (0dec)
10F0:0 | Subindex | Backup parameter handling | RO | 0x01 (1dec)
 | 10F0:01 | Checksum | RO | 0x00000000 (0dec)
1600:0 | Subindex | CNT RxPDO-Map Outputs Ch.1 | RO | 0x05 (5dec)
 | 1600:01 | SubIndex 001 | RO | 0x0000:00, 2
 | 1600:02 | SubIndex 002 | RO | 0x7000:03, 1
 | 1600:03 | SubIndex 003 | RO | 0x7000:04, 1
 | 1600:04 | SubIndex 004 | RO | 0x0000:00, 12
 | 1600:05 | SubIndex 005 | RO | 0x7000:11, 32
1601:0 | Subindex | CNT RxPDO-Map Outputs Ch.2 | RO | 0x05 (5dec)
 | 1601:01 | SubIndex 001 | RO | 0x0000:00, 2
 | 1601:02 | SubIndex 002 | RO | 0x7010:03, 1
 | 1601:03 | SubIndex 003 | RO | 0x7010:04, 1
 | 1601:04 | SubIndex 004 | RO | 0x0000:00, 12
 | 1601:05 | SubIndex 005 | RO | 0x7010:11, 32
1A00:0 | Subindex | CNT TxPDO-Map InputsCh.1 | RO | 0x0A (10dec)
 | 1A00:01 | SubIndex 001 | RO | 0x0000:00, 2
 | 1A00:02 | SubIndex 002 | RO | 0x6000:03, 1
 | 1A00:03 | SubIndex 003 | RO | 0x6000:04, 1
 | 1A00:04 | SubIndex 004 | RO | 0x6000:05, 1
 | 1A00:05 | SubIndex 005 | RO | 0x6000:06, 1
 | 1A00:06 | SubIndex 006 | RO | 0x0000:00, 7
 | 1A00:07 | SubIndex 007 | RO | 0x6000:0E, 1
 | 1A00:08 | SubIndex 008 | RO | 0x6000:0F, 1
 | 1A00:09 | SubIndex 009 | RO | 0x6000:10, 1
 | 1A00:0A | SubIndex 010 | RO | 0x6000:11, 32
Index (hex) |  | Name | Flags | Default value
1A01:0 | Subindex | CNT TxPDO-Map Inputs Ch.2 | RO | 0x0A (10dec)
 | 1A01:01 | SubIndex 001 | RO | 0x0000:00, 2
 | 1A01:02 | SubIndex 002 | RO | 0x6010:03, 1
 | 1A01:03 | SubIndex 003 | RO | 0x6010:04, 1
 | 1A01:04 | SubIndex 004 | RO | 0x6010:05, 1
 | 1A01:05 | SubIndex 005 | RO | 0x6010:06, 1
 | 1A01:06 | SubIndex 006 | RO | 0x0000:00, 7
 | 1A01:07 | SubIndex 007 | RO | 0x6010:0E, 1
 | 1A01:08 | SubIndex 008 | RO | 0x6010:0F, 1
 | 1A01:09 | SubIndex 009 | RO | 0x6010:10, 1
 | 1A01:0A | SubIndex 010 | RO | 0x6010:11, 32
1A02:0 | Subindex | DIG TxPDO-Map Inputs | RO | 0x09 (9dec)
 | 1A02:01 | SubIndex 001 | RO | 0x6020:01, 1
 | 1A02:02 | SubIndex 002 | RO | 0x6020:02, 1
 | 1A02:03 | SubIndex 003 | RO | 0x6020:03, 1
 | 1A02:04 | SubIndex 004 | RO | 0x6020:04, 1
 | 1A02:05 | SubIndex 005 | RO | 0x6020:05, 1
 | 1A02:06 | SubIndex 006 | RO | 0x6020:06, 1
 | 1A02:07 | SubIndex 007 | RO | 0x6020:07, 1
 | 1A02:08 | SubIndex 008 | RO | 0x6020:08, 1
 | 1A02:09 | SubIndex 009 | RO | 0x0000:00, 8
1A03:0 | Subindex | DIG TxPDO-Map Inputs Device | RO | 0x07 (7dec)
 | 1A03:01 | SubIndex 001 | RO | 0x0000:00, 1
 | 1A03:02 | SubIndex 002 | RO | 0xF600:02, 1
 | 1A03:03 | SubIndex 003 | RO | 0xF600:03, 1
 | 1A03:04 | SubIndex 004 | RO | 0x0000:00, 10
 | 1A03:05 | SubIndex 005 | RO | 0xF600:0E, 1
 | 1A03:06 | SubIndex 006 | RO | 0xF600:0F, 1
 | 1A03:07 | SubIndex 007 | RO | 0xF600:10, 1
1C00:0 | Subindex | Sync manager type | RO | 0x04 (4dec)
 | 1C00:01 | SubIndex 001 | RO | 0x01 (1dec)
 | 1C00:02 | SubIndex 002 | RO | 0x02 (2dec)
 | 1C00:03 | SubIndex 003 | RO | 0x03 (3dec)
 | 1C00:04 | SubIndex 004 | RO | 0x04 (4dec)
1C12:0 | Subindex | RxPDO assign | RW | 0x02 (2dec)
 | 1C12:01 | SubIndex 001 | RW | 0x1600 (5632dec)
 | 1C12:02 | SubIndex 002 | RW | 0x1601 (5633dec)
1C13:0 | Subindex | TxPDO assign | RW | 0x04 (4dec)
 | 1C13:01 | SubIndex 001 | RW | 0x1A00 (6656dec)
 | 1C13:02 | SubIndex 002 | RW | 0x1A01 (6657dec)
 | 1C13:03 | SubIndex 003 | RW | 0x1A02 (6658dec)
 | 1C13:04 | SubIndex 004 | RW | 0x1A03 (6659dec)
Index (hex) |  | Name | Flags | Default value
1C32:0 | Subindex | SM output parameter | RO | 0x20 (32dec)
 | 1C32:01 | Sync mode | RW | 0x0001 (1dec)
 | 1C32:02 | Cycle time | RW | 0x000F4240 (1000000dec)
 | 1C32:03 | Shift time | RO | 0x00000000 (0dec)
 | 1C32:04 | Sync modes supported | RO | 0xC007 (49159dec)
 | 1C32:05 | Minimum cycle time | RO | 0x0003D090 (250000dec)
 | 1C32:06 | Calc and copy time | RO | 0x00000000 (0dec)
 | 1C32:07 | Minimum delay time | RO | 0x00000000 (0dec)
 | 1C32:08 | Command | RW | 0x0000 (0dec)
 | 1C32:09 | Maximum delay time | RO | 0x00000000 (0dec)
 | 1C32:0B | SM event missed counter | RO | 0x0000 (0dec)
 | 1C32:0C | Cycle exceeded counter | RO | 0x0000 (0dec)
 | 1C32:0D | Shift too short counter | RO | 0x0000 (0dec)
 | 1C32:20 | Sync error | RO | 0x00 (0dec)
1C33:0 | Subindex | SM input parameter | RO | 0x20 (32dec)
 | 1C33:01 | Sync mode | RW | 0x0022 (34dec)
 | 1C33:02 | Cycle time | RW | 0x000F4240 (1000000dec)
 | 1C33:03 | Shift time | RO | 0x00000000 (0dec)
 | 1C33:04 | Sync modes supported | RO | 0xC007 (49159dec)
 | 1C33:05 | Minimum cycle time | RO | 0x0003D090 (250000dec)
 | 1C33:06 | Calc and copy time | RO | 0x00000000 (0dec)
 | 1C33:07 | Minimum delay time | RO | 0x00000000 (0dec)
 | 1C33:08 | Command | RW | 0x0000 (0dec)
 | 1C33:09 | Maximum delay time | RO | 0x00000000 (0dec)
 | 1C33:0B | SM event missed counter | RO | 0x0000 (0dec)
 | 1C33:0C | Cycle exceeded counter | RO | 0x0000 (0dec)
 | 1C33:0D | Shift too short counter | RO | 0x0000 (0dec)
 | 1C33:20 | Sync error | RO | 0x00 (0dec)
6000:0 | Subindex | CNT Inputs | RO | 0x11 (17dec)
 | 6000:03 | Set counter done | RO | 0x00 (0dec)
 | 6000:04 | Counter inhibited | RO | 0x00 (0dec)
 | 6000:05 | Status of input UD | RO | 0x00 (0dec)
 | 6000:06 | Status of input clock | RO | 0x00 (0dec)
 | 6000:0E | Sync error | RO | 0x00 (0dec)
 | 6000:0F | TxPDO State | RO | 0x00 (0dec)
 | 6000:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6000:11 | Counter value | RO | 0x00000000 (0dec)
6010:0 | Subindex | CNT Inputs | RO | 0x11 (17dec)
 | 6010:03 | Set counter done | RO | 0x00 (0dec)
 | 6010:04 | Counter inhibited | RO | 0x00 (0dec)
 | 6010:05 | Status of input UD | RO | 0x00 (0dec)
 | 6010:06 | Status of input clock | RO | 0x00 (0dec)
 | 6010:0E | Sync error | RO | 0x00 (0dec)
 | 6010:0F | TxPDO State | RO | 0x00 (0dec)
 | 6010:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6010:11 | Counter value | RO | 0x00000000 (0dec)
Index (hex) |  | Name | Flags | Default value
6020:0 | Subindex | DIG Inputs | RO | 0x08 (8dec)
 | 6020:01 | Input 0 | RO | 0x00 (0dec)
 | 6020:02 | Input 1 | RO | 0x00 (0dec)
 | 6020:03 | Input 2 | RO | 0x00 (0dec)
 | 6020:04 | Input 3 | RO | 0x00 (0dec)
 | 6020:05 | Input 4 | RO | 0x00 (0dec)
 | 6020:06 | Input 5 | RO | 0x00 (0dec)
 | 6020:07 | Input 6 | RO | 0x00 (0dec)
 | 6020:08 | Input 7 | RO | 0x00 (0dec)
7000:0 | Subindex | CNT Outputs | RO | 0x11 (17dec)
 | 7000:03 | Set counter | RO | 0x00 (0dec)
 | 7000:04 | Inhibit counter | RO | 0x00 (0dec)
 | 7000:11 | Set counter value | RO | 0x00000000 (0dec)
7010:0 | Subindex | CNT Outputs | RO | 0x11 (17dec)
 | 7010:03 | Set counter | RO | 0x00 (0dec)
 | 7010:04 | Inhibit counter | RO | 0x00 (0dec)
 | 7010:11 | Set counter value | RO | 0x00000000 (0dec)
8000:0 | Subindex | CNT Settings | RW | 0x13 (19dec)
 | 8000:03 | Enable reload | RW | 0x00 (0dec)
 | 8000:04 | Count down | RW | 0x00 (0dec)
 | 8000:05 | Operating mode | RW | 0x01 (1dec)
 | 8000:13 | Counter reload value | RW | 0x00000000 (0dec)
8010:0 | Subindex | CNT Settings | RW | 0x13 (19dec)
 | 8010:03 | Enable reload | RW | 0x00 (0dec)
 | 8010:04 | Count down | RW | 0x00 (0dec)
 | 8010:05 | Operating mode | RW | 0x01 (1dec)
 | 8010:13 | Counter reload value | RW | 0x00000000 (0dec)
8022:0 | Subindex | DIG Filter Settings | RW | 0x08 (8dec)
 | 8022:01 | Input 0 | RW | 0x00 (0dec)
 | 8022:02 | Input 1 | RW | 0x00 (0dec)
 | 8022:03 | Input 2 | RW | 0x00 (0dec)
 | 8022:04 | Input 3 | RW | 0x00 (0dec)
 | 8022:05 | Input 4 | RW | 0x00 (0dec)
 | 8022:06 | Input 5 | RW | 0x00 (0dec)
 | 8022:07 | Input 6 | RW | 0x00 (0dec)
 | 8022:08 | Input 7 | RW | 0x00 (0dec)
F000:0 | Subindex | Modular device profile | RO | 0x02 (2dec)
 | F000:01 | Module index distance | RO | 0x0010 (16dec)
 | F000:02 | Maximum number of modules | RO | 0x0003 (3dec)
F008 |  | Code word | RW | 0x00000000 (0dec)
F010:0 | Subindex | Module list | RW | 0x03 (3dec)
 | F010:01 | SubIndex 001 | RW | 0x00000096 (150dec)
 | F010:02 | SubIndex 002 | RW | 0x00000096 (150dec)
 | F010:03 | SubIndex 003 | RW | 0x00000118 (280dec)
Index (hex) |  | Name | Flags | Default value
F600:0 | Subindex | DIG Inputs | RO | 0x10 (16dec)
 | F600:02 | Error channel 1 | RO | 0x00 (0dec)
 | F600:03 | Error channel 2 | RO | 0x00 (0dec)
 | F600:0E | Sync error | RO | 0x00 (0dec)
 | F600:0F | TxPDO State | RO | 0x00 (0dec)
 | F600:10 | TxPDO Toggle | RO | 0x00 (0dec)
Key
Flags:
RO (Read Only): this object can be read only
RW (Read/Write): this object can be read and written to


Object description and parameterization

Commissioning and configuration [image] CoE objects [image] Object description and parameterization
Object description and parameterization
Parameterization
The terminal is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (assignment of PDOs).
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area on the Beckhoff website (http://www.beckhoff.de/german/default.htm?download/elconfg.htm) and installing it according to the installation instructions.
Introduction
The CoE overview contains objects for different intended applications:
▪
Objects required for parameterization during commissioning
▪
Objects intended for regular operation, e.g. through ADS access.
▪
Objects for indicating internal settings (may be fixed)
▪
Further profile-specific objects indicating inputs, outputs and status information
The following section first describes the objects required for normal operation, followed by a complete overview of missing objects.
Additional objects
Additional information
•
Objects to be parameterized during commissioning
•
Standard objects (0x1000-0x1FFF)
•
Profile-specific objects (0x6000-0xFFFF)


Objects to be parameterized during commissioning

Commissioning and configuration [image] CoE objects [image] Object description and parameterization [image] Objects to be parameterized during commissioning
Objects to be parameterized during commissioning
Index 1011 Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default parameters | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" in the set value dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)
Index 8000 CNT Settings
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8000:0 | CNT Settings | Maximum subindex |  | UINT8 | RO | 0x13 (19dec)
8000:03 | Enable reload | The counter counts to the value in index 0x8000:13 |  | BOOLEAN | RW | 0x00 (0dec)
8000:04 | Count down | Counting direction: |  | BOOLEAN | RW | 0x00 (0dec)
 |  | 0bin | Forward
 |  | 1bin | Down
8000:05 | Operating mode | Operation mode |  | BIT2 | RW | 0x01 (1dec)
 |  | 01bin | Enable pos. gate (gate inhibits with positive level)
 |  | 10bin | Enable neg. gate (gate inhibits with negative level)
8000:13 | Counter reload value | The limit that can be activated via "Enable reload" (index 0x8000:03). If counting upward, the counter counts up to this limit and, on exceeding it, starts again from zero. If counting downward, the counter counts down to 0 and, on falling below 0, is reloaded with the value from this register. |  | UINT32 | RW | 0x00000000 (0dec)
Index 8010 CNT Settings
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8010:0 | CNT Settings | Maximum subindex |  | UINT8 | RO | 0x13 (19dec)
8010:03 | Enable reload | The counter counts to the value in index 0x8010:13 |  | BOOLEAN | RW | 0x00 (0dec)
8010:04 | Count down | Counting direction: |  | BOOLEAN | RW | 0x00 (0dec)
 |  | 0bin | Forward
 |  | 1bin | Down
8010:05 | Operating mode | Operation mode |  | BIT2 | RW | 0x01 (1dec)
 |  | 01bin | Enable pos. gate (gate inhibits with positive level)
 |  | 10bin | Enable neg. gate (gate inhibits with negative level)
8010:13 | Counter reload value | The limit that can be activated via "Enable reload" (index 0x8010:03). If counting upward, the counter counts up to this limit and, on exceeding it, starts again from zero. If counting downward, the counter counts down to 0 and, on falling below 0, is reloaded with the value from this register. |  | UINT32 | RW | 0x00000000 (0dec)
Index 8022 DIG Filter Settings
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8022:0 | DIG Filter Settings | Maximum subindex |  | UINT8 | RO | 0x08 (8dec)
8022:01 | Input 0 | Filter time for the input |  | UINT8 | RW | 0x00 (0dec)
 |  | 0dec | 10 µs
 |  | 1dec | 200 µs
 |  | 2dec | 1 ms
 |  | 3dec | 3 ms
 |  | 4dec | 10 ms
 |  | 5dec | 100 ms
8022:02 | Input 1 | see 0x8022:01 |  | UINT8 | RW | 0x00 (0dec)
8022:03 | Input 2 | see 0x8022:01 |  | UINT8 | RW | 0x00 (0dec)
8022:04 | Input 3 | see 0x8022:01 |  | UINT8 | RW | 0x00 (0dec)
8022:05 | Input 4 | see 0x8022:01 |  | UINT8 | RW | 0x00 (0dec)
8022:06 | Input 5 | see 0x8022:01 |  | UINT8 | RW | 0x00 (0dec)
8022:07 | Input 6 | see 0x8022:01 |  | UINT8 | RW | 0x00 (0dec)
8022:08 | Input 7 | see 0x8022:01 |  | UINT8 | RW | 0x00 (0dec)


Standard objects (0x1000-0x1FFF)

Commissioning and configuration [image] CoE objects [image] Object description and parameterization [image] Standard objects (0x1000-0x1FFF)
Standard objects (0x1000-0x1FFF)
The standard objects have the same meaning for all EtherCAT slaves.
Index 1000 Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x00001389 (5001dec)
Index 1008 Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EP1518-0002
Index 1009 Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO | 00
Index 100A Software Version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO | 01.03
Index 1018 Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x05EE4052 (99500114dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the low word (bit 0-15) indicates the special terminal number, the high word (bit 16-31) refers to the device description | UINT32 | RO | 0x00100002 (1048578dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the low byte (bit 0-7) of the low word contains the year of production, the high byte (bit 8-15) of the low word contains the week of production, the high word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 Backup parameter handling
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | Information for standardized loading and saving of backup entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum across all backup entries of the EtherCAT slave | UINT32 | RO | 0x00000000 (0dec)
Index 1600 CNT RxPDO-Map Outputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1600:0 | CNT RxPDO-Map Outputs Ch.1 | PDO Mapping RxPDO 1 | UINT8 | RO | 0x05 (5dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7040 (DO Outputs), entry 0x01 (Output 0)) | UINT32 | RO | 0x0000:00, 2
1600:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x7000:03, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (CNT Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:04, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7010 (CNT Outputs), entry 0x04 (Inhibit counter)) | UINT32 | RO | 0x0000:00, 12
1600:05 | SubIndex 005 | 5. PDO Mapping entry (12 bits align) | UINT32 | RO | 0x7000:11, 32
Index 1601 CNT RxPDO-Map OutputsCh.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1601:0 | CNT RxPDO-Map Outputs Ch.2 | PDO Mapping RxPDO 2 | UINT8 | RO | 0x05 (5dec)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (CNT Outputs), entry 0x01 (Enable output functions)) | UINT32 | RO | 0x0000:00, 2
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7020 (CNT Outputs), entry 0x02 (Set output)) | UINT32 | RO | 0x7010:03, 1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7020 (CNT Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7010:04, 1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7020 (CNT Outputs), entry 0x04 (Inhibit counter)) | UINT32 | RO | 0x0000:00, 12
1601:05 | SubIndex 005 | 5. PDO Mapping entry (12 bits align) | UINT32 | RO | 0x7010:11, 32
Index 1A00 CNT TxPDO-Map InputsCh.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A00:0 | CNT TxPDO-Map InputsCh.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x0A (10dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (DI Inputs Ch.1), entry 0x01 (Input 0)) | UINT32 | RO | 0x0000:00, 2
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (DI Inputs Ch.1), entry 0x02 (Input 1)) | UINT32 | RO | 0x6000:03, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (DI Inputs Ch.1), entry 0x03 (Input 2)) | UINT32 | RO | 0x6000:04, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (DI Inputs Ch.1), entry 0x04 (Input 3)) | UINT32 | RO | 0x6000:05, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (DI Inputs Ch.1), entry 0x05 (Input 4)) | UINT32 | RO | 0x6000:06, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (DI Inputs Ch.1), entry 0x06 (Input 5)) | UINT32 | RO | 0x0000:00, 7
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (DI Inputs Ch.1), entry 0x06 (Input 6)) | UINT32 | RO | 0x6000:0E, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (DI Inputs Ch.1), entry 0x08 (Input 7)) | UINT32 | RO | 0x6000:0F, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x6000:10, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (CNT Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
Index 1A01 CNT TxPDO-Map InputsCh.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A01:0 | CNT TxPDO-Map Inputs Ch.2 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x0A (10dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 2
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (CNT Inputs), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6010:03, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (CNT Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6010:04, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (CNT Inputs), entry 0x04 (Counter inhibited)) | UINT32 | RO | 0x6010:05, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (CNT Inputs), entry 0x05 (Status of input UD)) | UINT32 | RO | 0x6010:06, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6020 (CNT Inputs), entry 0x06 (Status of input clock)) | UINT32 | RO | 0x0000:00, 7
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x6010:0E, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6020 (CNT Inputs), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6010:0F, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6020 (CNT Inputs), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6010:10, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6010 (CNT Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6010:11, 32
Index 1A02 DIG TxPDO-Map Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
1A02:0 | DIG TxPDO-Map Inputs | PDO Mapping TxPDO 3 | UINT8 | RO | 0x09 (9dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x6020:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6030 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6020:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6030 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6020:03, 1
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6030 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6020:04, 1
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x6020:05, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6030 (ENC Inputs), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6020:06, 1
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6030 (ENC Inputs), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6020:07, 1
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6030 (ENC Inputs), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6020:08, 1
1A02:09 | SubIndex 009 | 9. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1A03 DIG TxPDO-Map Inputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1A03:0 | DIG TxPDO-Map Inputs Device | PDO Mapping TxPDO 4 | UINT8 | RO | 0x07 (7dec)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF600 (DIG Inputs), entry 0x02 (Error channel 1)) | UINT32 | RO | 0xF600:02, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF600 (DIG Inputs), entry 0x03 (Error channel 2)) | UINT32 | RO | 0xF600:03, 1
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (10 bits align) | UINT32 | RO | 0x0000:00, 10
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF600 (DIG Inputs), entry 0x0E (Sync error)) | UINT32 | RO | 0xF600:0E, 1
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (1 bits align) | UINT32 | RO | 0xF600:0F, 1
1A03:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF600 (DIG Inputs), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0xF600:10, 1
Index 1C00 Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the sync managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x02 (2dec)
1C12:01 | Subindex 001 | 1. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1600 (5632dec)
1C12:02 | Subindex 002 | 2. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1601 (5633dec)
Index 1C13 TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x04 (4dec)
1C13:01 | Subindex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A01 (6657dec)
1C13:03 | Subindex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A02 (6658dec)
1C13:04 | Subindex 004 | 4. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A03 (6659dec)
Index 1C32 SM output parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C32:0
SM output parameter
Synchronization parameters for the outputs
UINT8
RO
0x20 (32dec)
1C32:01
Sync mode
▪
0: Free Run
▪
1: Synchronous with SM 2 event
▪
2: DC-Mode - Synchronous with SYNC0 Event
▪
3: DC-Mode - Synchronous with SYNC1 event
UINT16
RW
0x0001 (1dec)
1C32:02
Cycle time
Cycle time (in ns):
▪
Synchronous with SM 2 event: Master cycle time
▪
DC mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dec)
1C32:03
Shift time
Time between SYNC0 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0 = 1: free run is supported
▪
Bit 1 = 1: synchronous with SM 2 event is supported
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 10: Output shift with SYNC1 event (only DC mode)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08)
UINT16
RO
0xC007 (49159dec)
1C32:05
Minimum cycle time
Minimum cycle time (in ns)
UINT32
RO
0x0003D090 (250000dec)
1C32:06
Calc and copy time
Minimum time between SYNC0 and SYNC1 event (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:07
Minimum delay time
Minimum time between SYNC1 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:08
Command
▪
0: Measurement of the local cycle time is stopped
▪
1: Measurement of the local cycle time is started
The entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:07, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:07 and 0x1C33:09 are updated with the maximum measured values.
For a subsequent measurement the measured values are reset
UINT16
RW
0x0000 (0dec)
1C32:09
Maximum delay time
Minimum time between SYNC1 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:0B
SM event missed counter
Number of missed SM events in OPERATIONAL (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:0C
Cycle exceeded counter
Number of occasions the cycle time was exceeded in OPERATIONAL (cycle was not completed in time or the next cycle began too early)
UINT16
RO
0x0000 (0dec)
1C32:0D
Shift too short counter
Number of occasions that the interval between SYNC0 and SYNC1 event was too short (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:20
Sync error
The synchronization was not correct in the last cycle (outputs were output too late; DC mode only)
BOOLEAN
RO
0x00 (0dec)
Index 1C33 SM input parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchronous with SM 3 Event (no outputs available)
▪
2: DC - Synchronous with SYNC0 Event
▪
3: DC - Synchronous with SYNC1 Event
▪
34: Synchronous with SM 2 event (outputs available)
UINT16
RW
0x0022 (34dec)
1C33:02
Cycle time
as 0x1C32:02
UINT32
RW
0x000F4240 (1000000dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: Synchronous with SM 2 Event is supported (outputs available)
▪
Bit 1: Synchronous with SM 3 Event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: Input shift through local event (outputs available)
▪
Bit 4-5 = 10: Input shift with SYNC1 event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08 or 0x1C33:08)
UINT16
RO
0xC007 (49159dec)
1C33:05
Minimum cycle time
as 0x1C32:05
UINT32
RO
0x0003D090 (250000dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:07
Minimum delay time
as 0x1C32:07
UINT32
RO
0x00000000 (0dec)
1C33:08
Command
as 0x1C32:08
UINT16
RW
0x0000 (0dec)
1C33:09
Maximum delay time
as 0x1C32:09
UINT32
RO
0x00000000 (0dec)
1C33:0B
SM event missed counter
as 0x1C32:11
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
as 0x1C32:12
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
as 0x1C32:13
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
as 0x1C32:32
BOOLEAN
RO
0x00 (0dec)


Profile-specific objects (0x6000-0xFFFF)

Commissioning and configuration [image] CoE objects [image] Object description and parameterization [image] Profile-specific objects (0x6000-0xFFFF)
Profile-specific objects (0x6000-0xFFFF)
The profile-specific objects have the same meaning for all EtherCAT slaves that support the profile 5001.
Index 6000 CNT Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
6000:0 | CNT Inputs | Maximum subindex | UINT8 | RO | 0x11 (17dec)
6000:03 | Set counter done | The counter was set | BOOLEAN | RO | 0x00 (0dec)
6000:04 | Counter inhibited | The counter is stopped for as long as this bit is set | BOOLEAN | RO | 0x00 (0dec)
6000:05 | Status of input UD | The state of the up/down input | BOOLEAN | RO | 0x00 (0dec)
6000:06 | Status of input clock | The state of the clock input | BOOLEAN | RO | 0x00 (0dec)
6000:0E | Sync error | Synchronization error | BOOLEAN | RO | 0x00 (0dec)
6000:0F | TxPDO State | Validity of the data of the associated TxPDO (0 = valid, 1 = invalid) | BOOLEAN | RO | 0x00 (0dec)
6000:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated | BOOLEAN | RO | 0x00 (0dec)
6000:11 | Counter value | Counter value | UINT32 | RO | 0x00000000 (0dec)
Index 6010 CNT Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
6010:0 | CNT Inputs | Maximum subindex | UINT8 | RO | 0x11 (17dec)
6010:03 | Set counter done | The counter was set | BOOLEAN | RO | 0x00 (0dec)
6010:04 | Counter inhibited | The counter is stopped for as long as this bit is set | BOOLEAN | RO | 0x00 (0dec)
6010:05 | Status of input UD | The state of the up/down input | BOOLEAN | RO | 0x00 (0dec)
6010:06 | Status of input clock | The state of the clock input | BOOLEAN | RO | 0x00 (0dec)
6010:0E | Sync error | Synchronization error | BOOLEAN | RO | 0x00 (0dec)
6010:0F | TxPDO State | Validity of the data of the associated TxPDO (0 = valid, 1 = invalid) | BOOLEAN | RO | 0x00 (0dec)
6010:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated | BOOLEAN | RO | 0x00 (0dec)
6010:11 | Counter value | Counter value | UINT32 | RO | 0x00000000 (0dec)
Index 6020 DIG Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
6020:0 | DIG Inputs | Maximum subindex | UINT8 | RO | 0x08 (8dec)
6020:01 | Input 0 | Digital input 0 | BOOLEAN | RO | 0x00 (0dec)
6020:02 | Input 1 | Digital input 1 | BOOLEAN | RO | 0x00 (0dec)
6020:03 | Input 2 | Digital input 2 | BOOLEAN | RO | 0x00 (0dec)
6020:04 | Input 3 | Digital input 3 | BOOLEAN | RO | 0x00 (0dec)
6020:05 | Input 4 | Digital input 4 | BOOLEAN | RO | 0x00 (0dec)
6020:06 | Input 5 | Digital input 5 | BOOLEAN | RO | 0x00 (0dec)
6020:07 | Input 6 | Digital input 6 | BOOLEAN | RO | 0x00 (0dec)
6020:08 | Input 7 | Digital input 7 | BOOLEAN | RO | 0x00 (0dec)
Index 7000 CNT Outputs
Index (hex) | Name | Meaning | Data type | Flags | Default
7000:0 | CNT Outputs | Maximum subindex | UINT8 | RO | 0x11 (17dec)
7000:03 | Set counter | Set counter value | BOOLEAN | RO | 0x00 (0dec)
7000:04 | Inhibit counter | The counter is stopped, as long as this bit is active. The previous counter state is retained. | BOOLEAN | RO | 0x00 (0dec)
7000:11 | Set counter value | This is the counter value to be set via “Set counter” (index 0x7000:03). | UINT32 | RO | 0x00000000 (0dec)
Index 7010 CNT Outputs
Index (hex) | Name | Meaning | Data type | Flags | Default
7010:0 | CNT Outputs | Maximum subindex | UINT8 | RO | 0x11 (17dec)
7010:03 | Set counter | Set counter value | BOOLEAN | RO | 0x00 (0dec)
7010:04 | Inhibit counter | The counter is stopped, as long as this bit is active. The previous counter state is retained. | BOOLEAN | RO | 0x00 (0dec)
7010:11 | Set counter value | This is the counter value to be set via “Set counter” (index 0x7000:03). | UINT32 | RO | 0x00000000 (0dec)
Index F000 Modular Device Profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0003 (3dec)
Index F008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module List
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list | Maximum subindex | UINT8 | RW | 0x03 (3dec)
F010:01 | SubIndex 001 | reserved | UINT32 | RW | 0x00000096 (150dec)
F010:02 | SubIndex 002 | reserved | UINT32 | RW | 0x00000096 (150dec)
F010:03 | SubIndex 003 | reserved | UINT32 | RW | 0x00000118 (280dec)
Index F600 DIG Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
F600:0 | DIG Inputs | Maximum subindex | UINT8 | RO | 0x10 (16dec)
F600:02 | Error channel 1 | If this bit is set, a short circuit has been detected in the supply voltage to sensor group 1 (inputs 0 - 3). | BOOLEAN | RO | 0x00 (0dec)
F600:03 | Error channel 2 | If this bit is set, a short circuit has been detected in the supply voltage to sensor group 2 (inputs 4 - 7). | BOOLEAN | RO | 0x00 (0dec)
F600:0E | Sync error | Synchronization error | BOOLEAN | RO | 0x00 (0dec)
F600:0F | TxPDO State | Validity of the data of the associated TxPDO (0 = valid, 1 = invalid) | BOOLEAN | RO | 0x00 (0dec)
F600:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated | BOOLEAN | RO | 0x00 (0dec)


Appendix

Appendix
Appendix
Additional information
•
General operating conditions
•
Accessories
•
Version identification of EtherCAT devices
•
Support and Service


General operating conditions

Appendix [image] General operating conditions
General operating conditions
Protection degrees (IP-Code)
The standard IEC 60529 (DIN EN 60529) defines the degrees of protection in different classes.
1. Number: dust protection and touch guard | Definition
0 | Non-protected
1 | Protected against access to hazardous parts with the back of a hand. Protected against solid foreign objects of Ø 50 mm
2 | Protected against access to hazardous parts with a finger. Protected against solid foreign objects of Ø 12.5 mm.
3 | Protected against access to hazardous parts with a tool. Protected against solid foreign objects Ø 2.5 mm.
4 | Protected against access to hazardous parts with a wire. Protected against solid foreign objects Ø 1 mm.
5 | Protected against access to hazardous parts with a wire. Dust-protected. Intrusion of dust is not totally prevented, but dust shall not penetrate in a quantity to interfere with satisfactory operation of the device or to impair safety.
6 | Protected against access to hazardous parts with a wire. Dust-tight. No intrusion of dust.
2. Number: water* protection | Definition
0 | Non-protected
1 | Protected against water drops
2 | Protected against water drops when enclosure tilted up to 15°.
3 | Protected against spraying water. Water sprayed at an angle up to 60° on either side of the vertical shall have no harmful effects.
4 | Protected against splashing water. Water splashed against the disclosure from any direction shall have no harmful effects
5 | Protected against water jets
6 | Protected against powerful water jets
7 | Protected against the effects of temporary immersion in water. Intrusion of water in quantities causing harmful effects shall not be possible when the enclosure is temporarily immersed in water for 30 min. in 1 m depth.
*) These protection classes define only protection against water!
Chemical Resistance
The Resistance relates to the Housing of the IP 67 modules and the used metal parts. In the table below you will find some typical resistance.
Character | Resistance
Steam | at temperatures >100°C: not resistant
Sodium base liquor (ph-Value > 12) | at room temperature: resistant > 40°C: not resistant
Acetic acid | not resistant
Argon (technical clean) | resistant
Key
▪
resistant: Lifetime several months
▪
non inherently resistant: Lifetime several weeks
▪
not resistant: Lifetime several hours resp. early decomposition


Accessories

Appendix [image] Accessories
Accessories
Mounting
Ordering information | Description
ZS5300-0001 | Mounting rail (500 mm x 129 mm)
Cables
Ordering information | Description
ZK1090-3xxx-xxxx | EtherCAT cable M8, green link to the website
ZK1093-3xxx-xxxx | EtherCAT cable M8, yellow link to the website
ZK2000-5xxx-xxxx ZK2000-71xx-xxxx | Sensor cable M12 5-wire Link to website
ZK2000-6xxx-xxxx | Sensor cable M12 4-wire Link to website
A complete overview of pre-assembled cables for EtherCAT Box modules can be found here.
Labeling material, protective caps
Ordering information | Description
ZS5000-0010 | Protective cap for M8 sockets, IP67 (50 pieces)
ZS5000-0020 | Protective cap M12, IP67 (50 pieces)
ZS5100-0000 | Inscription labels, unprinted, 4 strips of 10
ZS5000-xxxx | Printed inscription labels on enquiry
Tools
Ordering information | Description
ZB8801-0000 | Torque wrench for plugs, 0.4…1.0 Nm
ZB8801-0001 | Torque cable key for M8 / wrench size 9 for ZB8801-0000
ZB8801-0002 | Torque cable key for M12 / wrench size 13 for ZB8801-0000
ZB8801-0003 | Torque cable key for M12 field assembly / wrench size 18 for ZB8801-0000
Further accessories
Further accessories can be found in the price list for fieldbus components from Beckhoff and online at https://www.beckhoff.com.


Version identification of EtherCAT devices

Appendix [image] Version identification of EtherCAT devices
Version identification of EtherCAT devices
Designation
A Beckhoff EtherCAT device has a 14-digit designation, made up of
▪
family key
▪
type
▪
version
▪
revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
Notes
▪
The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
▪
EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
▪
The order identifier is made up of
- family key (EL, EP, CU, ES, KL, CX, etc.)
- type (3314)
- version (-0000)
▪
The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
▪
The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Identification number
Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:
Production lot/batch number/serial number/date code/D number
The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02
Exceptions can occur in the IP67 area, where the following syntax can be used (see respective device documentation):
Syntax: D ww yy x y z u
D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB
Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1
Unique serial number/ID, ID number
In addition, in some series each individual module has its own unique serial number.
See also the further documentation in the area
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Terminals with factory calibration certificate and other measuring terminals
Examples of markings
EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
CU2016 switch with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
EP1258-00001 IP67 EtherCAT Box with batch number/ date code 22090101 and unique serial number 158102
EP1908-0002 IP67 EtherCAT Safety Box with batch number/ date code 071201FF and unique serial number 00346070
EL2904 IP20 safety terminal with batch number/ date code 50110302 and unique serial number 00331701
ELM3604-0002 terminal with unique ID number (QR code) 100001051 and serial/ batch number 44160201
Additional information
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Appendix [image] Version identification of EtherCAT devices [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com