EP1122 - EtherCAT Branch

BECKHOFF Fieldbus Components

Documentation for

EP1122

EtherCAT Branch with IP67 Protection Class

Version: 1.1.0
Date: 2015-05-12

EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.


Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending

The EtherCAT Technology is covered, including but not limited to the following patent applications and patents:
EP1590927, EP1789857, DE102004044764, DE102007017835
with corresponding applications or registrations in various other countries.

The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.

Copyright

© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Safety rules

Consider the following safety instructions and descriptions!
Product specific safety instructions are to be found on the following pages or in the areas mounting, wiring, commissioning etc.

Disclaimer

All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.

Personnel qualification

This description is only intended for the use of trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.

Description of symbols

The following symbols with a adjoining safety advise or notice are used in this documentation. You have to read the safety advices carefully and adhere them strictly!

DANGER 		Acute risk of injury!
If you do not adhere the safety advise adjoining this symbol, there is immediate danger to life and health of individuals!

WARNING 		Risk of injury!
If you do not adhere the safety advise adjoining this symbol, there is danger to life and health of individuals!

CAUTION 		Hazard to individuals!
If you do not adhere the safety advise adjoining this symbol, there is obvious hazard to individuals!

Attention 		Hazard to devices and environment
If you do not adhere the notice adjoining this symbol, there is obvious hazard to materials and environment.

Note 		Note or pointer
This symbol indicates information that contributes to better understanding.


EP1122 - Documentation issue status

BECKHOFF EP1122: Vorwort

Documentation issue status

Version Comment
1.1.0
  • Foreword updated
  • Mounting and cabling updated
1.0.0
  • First release

Firm and hardware version

The documentation refers to the firm and hardware status that was valid at the time it was prepared.

The properties of the modules are subject to continuous development and improvement. Modules having earlier production statuses cannot have the same properties as modules with the latest status. Existing properties, however, are always retained and are not changed, so that these modules can always be replaced by new ones.

The firmware and hardware version (delivery state) can be found in the batch number (D number) printed at the side of the EtherCAT Box.

Syntax of the batch number (D number)

D: WW YY FF HH

WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version

Example with D No. 29 10 02 01:

29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01


EtherCAT Box - Introduction

The EtherCAT system has been extended with EtherCAT Box modules with protection class IP 67. Through the integrated EtherCAT interface the modules can be connected directly to an EtherCAT network without an additional Coupler Box. The high-performance of EtherCAT is thus maintained into each module.

The extremely low dimensions of only 126 x 30 x 26.5 mm (H x W x D) are identical to those of the Fieldbus Box extension modules. They are thus particularly suitable for use where space is at a premium. The small mass of the EtherCAT modules facilitates applications with mobile I/O interface (e.g. on a robot arm). The EtherCAT connection is established via screened M8 connectors.

The robust design of the EtherCAT Box modules enables them to be used directly at the machine. Control cabinets and terminal boxes are now no longer required. The modules are fully sealed and therefore ideally prepared for wet, dirty or dusty conditions.

Pre-assembled cables significantly simplify EtherCAT and signal wiring. Very few wiring errors are made, so that commissioning is optimized. In addition to pre-assembled EtherCAT, power and sensor cables, field-configurable connectors and cables are available for maximum flexibility. Depending on the application, the sensors and actuators are connected through M8 or M12 connectors.

The EtherCAT modules cover the typical range of requirements for I/O signals with protection class IP 67:

  • digital inputs with different filters (3.0 ms or 10 μs)

  • digital outputs with 0.5 or 2 A output current

  • analog inputs and outputs with 16 bit resolution

  • Thermocouple and RTD inputs

  • Stepper motor modules

XFC (eXtreme Fast Control Technology) modules, including inputs with time stamp, are also available.

EtherCAT Box with M8 connections for sensors/actuators | EtherCAT Box with M12 connections for sensors/actuators

Note 		Basic EtherCAT documentation
You will find a detailed description of the EtherCAT system in the Basic System Documentation for EtherCAT, which is available for download from our website (www.beckhoff.com) under Downloads.

Note 		XML files
You will find XML files (XML Device Description Files) for Beckhoff EtherCAT modules on our website (www.beckhoff.com) under Downloads, in the Configuration Files area.


EP1122 - Introduction

The 2-port EtherCAT junction enables configuration of EtherCAT star topologies.
A modular EtherCAT junction can be realized by using several EP1122 units.

Individual devices or complete EtherCAT strands can be connected at the junction ports.
The EtherCAT junctions are connected via M8 sockets with direct display of link and activity status. The Run LED indicates the status of the EP1122.

Through TwinCAT and other suitable EtherCAT masters the EP1122 also supports coupling and uncoupling of EtherCAT strands during operation (hot connect).


EP1122 - Technical data

BECKHOFF EP1122: Product overview

Technical data

Technical data | EP1122-0001
Task within the EtherCAT system | Coupling of EtherCAT junctions
Transmission medium | Ethernet 100BASE-TX (min. CAT5)
Cable length between 2 devices | max. 100 m
Protocols | EtherCAT
Baud rate | 100 Mbaud
Configuration | no address and configuration settings required
Bus connection | 4 x M8 (1 x IN, 3 x Out)
Power supply | 24VDC
Current consumption | typically 120 mA
Permissible ambient temperature range during operation | -25°C ... +60°C 0 °C ... +55 °C (according to cULus, see UL requirements) 0°C ... +55 °C (according to ATEX, see special conditions)
Permissible ambient temperature range during storage | -40°C ... + 85°C
Permissible relative humidity | 95%, no condensation
Vibration / shock resistance | according to EN 60068-2-6 / EN 60068-2-27
EMC immunity/emission | according to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67
Installation position | Variable
Approval | CE, cULus, ATEX


EtherCAT junction – Basic function principles

BECKHOFF EtherCAT: Communication basics

Basic function principles of EtherCAT junctions

Some Beckhoff EtherCAT devices can be used for junctions in the EtherCAT segment. These include EK1122, EK1521, EP1122 or also CU1128. In the following examples only the EK1122 is used. The technical and system characteristics of the other devices are similar.

EtherCAT handling in the slaves

With EtherCAT as fieldbus protocol a wide range of bus topologies can be used: line, star and tree topology, with redundancy support even ring topology. The simplest topology is the line topology, in which each EtherCAT slave hands data over to the only available next slave, see Fig. 1.

Fig. 1: EtherCAT line topology

If EK1100 EtherCAT couplers are used, for example, junctions and therefore a kind of tree topology is possible, see Fig. 2.

Fig. 2: Line topology with extensions

The basic principle is that internally the Ethernet frame(s) with the EtherCAT protocol data continue to be transported in a logical ring:

  • the EtherCAT master sends the frame on the two outgoing lines of the Ethernet cable
  • this frame passes each slave once,
  • is reversed by the last slave in the logical sequence
  • and is returned to the master through each EtherCAT slave via two return lines of the Ethernet cable without further processing.

At short cycle times in the order of 50 µs at 20,000 Ethernet frames are in transit in the EtherCAT system every second, plus acyclic organizational frames. The master awaits the return of the sent frames, which return the device input data to the master, for example. Telegram transfer between slaves is link-based: An EtherCAT slave will only forward a frame if a 'link' signal to the next device is present. Normally it can be assumed that the downstream device correctly processes each EtherCAT telegram and returns or process it at the end.

The crucial factor for forwarding EtherCAT telegrams is that a link signal is reported only from one slave to the next if both slaves are actually ready for real-time participation in data processing. Specifically, this means that an EtherCAT slave should not open the respective Ethernet port until it is ready to receive and forward an Ethernet frame immediately.

A switch or router is usually used for standard Ethernet traffic forwarding. Any collisions or frame losses are compensated through frame repetition in the higher level protocol layers (e.g. TCP). This mode is generally not used for EtherCAT due to the short cycle times and the real-time requirement. Some Ethernet devices such as special switches, for example, report a link to the remote terminal even if they will only be ready for data processing in a few milliseconds. This behavior is particularly noticeable in media converters from 100Base-TX (copper) to 100Base-Fx (optical fiber), which may report a link to the preceding EtherCAT slave even if the optical fiber connection is interrupted, depending on the setting on the copper side.

Fast link detection is therefore a central component of each ESC (EtherCAT slave controller, hardware processing unit for the EtherCAT protocol). According to the EtherCAT specification an ESC can have and control 1 to 4 ports. Via an open port it can handle outgoing and incoming Ethernet traffic. Fig. 3 shows the direction of the data flow in a fully configured ESC. In the EtherCAT datagrams the data are only processed between ports 0 (A) and 3 (D) in the EtherCAT processing unit.

Fig. 3: Direction of data flow in the ESC

Ideally link detection and therefore port handling in the ESC should be fast enough that lost frame events are avoided even at 100 µs cycle time. Nevertheless, at least one lost frame can never be ruled out if a connection is disconnected while an Ethernet frame is in transit on this line and in the bus segment downstream of the separation point.

Implementation: EL terminal

A standard EtherCAT slave such as a Beckhoff EL terminal has 2 ports:

  • one for incoming frames (port 0 [A])
  • one for outgoing frames (e.g. port [D]).

The other two ports are internally closed in the ESC. An EtherCAT telegram enters the processing unit via port 0 (A)/top and is forwarded to the next slave via port 3 (D)/left, if a link to this port exists - see green arrows. This is the case if a further EL terminal is connected to the right.

If no link exists, the frame is forwarded to port 1(B) via the purple route. This and port 2 (C) have no link and therefore return the frame to port 0 (A), where the frame leaves via the same Ethernet port through which it arrived at the slave. This is the case if the terminal acts as end terminal.

An EtherCAT device with a single port is therefore only of limited use, since it can only be used as end device.

Implementation: EK1100 EtherCAT coupler

In the EK1100 EtherCAT coupler 3 of the 4 available ports are used, so that a connection to the right to terminals and via an RJ45 socket to further couplers is possible, see Fig. 2. In the EK1100 the processing unit is not used for process data exchange.

Implementation: EK1122 EtherCAT junction

In the EK1122 all 4 ESC ports can be connected - two via the internal E-bus and two via the RJ45 sockets with Ethernet configuration. In the TwinCAT System Manager the link statuses of ports 0, 1, 2 and 3 are indicated via the online display as port A, B, C and D, see Fig. 7.

Implementation: EK1521 / EK1521-0010 / EK1561 EtherCAT junction

As in the EK1100, three ESC ports can be connected in these junctions: Two via E-bus within the terminal and one via the SC socket/versatile link and optical fiber cable/POF line.

Implementation: CU1128 EtherCAT junction

The CU1128 integrates three ESCs, which means eight ports in total are available to users. The three ESCs are interconnected via E-bus.

Example configuration with EK1122

The following section describes the link characteristics under TwinCAT and its representation in the System Manager.

Fig. 4: Example configuration

The TwinCAT online topology shows the wiring scheme, see Fig. 5. The EK1122 is selected, so that further information is shown. The green bars above the slaves indicate the correct RUN state in all slaves.

Fig. 5: Online topology

An error is now generated by disconnecting the connection between the upper RJ45 socket (X1) and the EL3102 device. Within a few µs the ESC in the EK1122 detects the lost link and automatically closes the affected port. This has the effect that the next incoming EtherCAT telegram is immediately forwarded to port D (port 3) and the EL4732. The link is therefore missing and the System Manager indicates this in the online display, see Fig. 6.

Fig. 6: Example configuration with interrupted cable

The System Manager messages can be interpreted as follows:

  • Address 1002 - EK1122: "OP LNK:MIS D": The slave is in OP state, although a link is missing at port D (3) that should be present according to the configuration
  • Address 1003 - EK1100: "INIT NO_COMM": Since communication with this slave is interrupted its state is shown as INIT
  • Address 1004 - EL3104: ditto

Note 		Logger output
The logger output can be displayed in the lower part of the System Manager (Display--> Show Logger Output).

This may be helpful for diagnostic purposes (for link interruptions and other situations).

In the topology display any slaves affected by interruption are shown with a red border, see Fig. 7.

Fig. 7: Topology display for interrupted line

Please note the acyclic frame display in Fig. 4 and 6, see Fig. 8.

Fig. 8: Comparison of the frame displays in the System Manager from Fig. 4 and 6

The image on the left shows a small number (2) of acyclic frames sent by the master during the respective second - all slaves are operating properly. The image on the right shows a significant increase (currently 77 acyclic frames/sec): the EtherCAT master has quickly detected that not all slaves are properly taking part in the data exchange. Once the master has located the fault, it continuously tries to restore the connection.

Reconnection

Once the connection has been restored, the EK1122 reports to the master that a link is present again at port D (3). The EtherCAT master will then make its process data available again for this section. One the preparations are complete, it will instruct the EK1122 to re-open port D (3) for regular data exchange. Cyclic and acyclic data traffic with the other EtherCAT slaves continues normally.

Note 		External access to EtherCAT diagnostics
The system offers a wide range of options for accessing status and diagnostic information and EtherCAT master functions from the PLC. Almost all information displayed by the System Manager online can also be retrieved via ADS (see figures on this page). System Manager functions can also be triggered via PLC or ADS.

Please refer to the relevant sections in the Beckhoff Information System and the notes on EtherCAT diagnostics.


EtherCAT - EtherCAT basics

BECKHOFF EtherCAT: Communication basics

EtherCAT basics

Please refer to the chapter EtherCAT System Documentation for the EtherCAT fieldbus basics.


EtherCAT - General notes for setting the watchdog

BECKHOFF EtherCAT: Communication basics

General notes for setting the watchdog

ELxxxx terminals are equipped with a safety feature (watchdog) that switches off the outputs after a specifiable time e.g. in the event of an interruption of the process data traffic, depending on the device and settings, e.g. in OFF state.

The EtherCAT slave controller (ESC) in the EL2xxx terminals features 2 watchdogs:

  • SM watchdog (default: 100 ms)
  • PDI watchdog (default: 100 ms)

SM watchdog (SyncManager Watchdog)

The SyncManager watchdog is reset after each successful EtherCAT process data communication with the terminal. If no EtherCAT process data communication takes place with the terminal for longer than the set and activated SM watchdog time, e.g. in the event of a line interruption, the watchdog is triggered and the outputs are set to FALSE. The OP state of the terminal is unaffected. The watchdog is only reset after a successful EtherCAT process data access. Set the monitoring time as described below.

The SyncManager watchdog monitors correct and timely process data communication with the ESC from the EtherCAT side.

PDI watchdog (Process Data Watchdog)

If no PDI communication with the EtherCAT slave controller (ESC) takes place for longer than the set and activated PDI watchdog time, this watchdog is triggered.
PDI (Process Data Interface) is the internal interface between the ESC and local processors in the EtherCAT slave, for example. The PDI watchdog can be used to monitor this communication for failure.

The PDI watchdog monitors correct and timely process data communication with the ESC from the application side.

The settings of the SM- and PDI-watchdog must be done for each slave separately in the TwinCAT System Manager.

Fig. 1 EtherCAT tab -> Advanced Settings -> Behavior -> Watchdog

Notes:

  • the multiplier is valid for both watchdogs.
  • each watchdog has its own timer setting, the outcome of this in summary with the multiplier is a resulting time.
  • Important: the multiplier/timer setting is only loaded into the slave at the start up, if the checkbox is activated.
    If the checkbox is not activated, nothing is downloaded and the ESC settings remain unchanged.

Multiplier

Both watchdogs receive their pulses from the local terminal cycle, divided by the watchdog multiplier:

1/25 MHz * (watchdog multiplier + 2) = 100 µs (for default setting of 2498 for the multiplier)

The standard setting of 1000 for the SM watchdog corresponds to a release time of 100 ms.

The value in multiplier + 2 corresponds to the number of basic 40 ns ticks representing a watchdog tick.
The multiplier can be modified in order to adjust the watchdog time over a larger range.

Example "Set SM watchdog"

This checkbox enables manual setting of the watchdog times. If the outputs are set and the EtherCAT communication is interrupted, the SM watchdog is triggered after the set time and the outputs are erased. This setting can be used for adapting a terminal to a slower EtherCAT master or long cycle times. The default SM watchdog setting is 100 ms. The setting range is 0..65535. Together with a multiplier with a range of 1..65535 this covers a watchdog period between 0..~170 seconds.

Calculation

Multiplier = 2498 → watchdog base time = 1 25 MHz * (2498 + 2) = 0.0001 seconds = 100 µs
SM watchdog = 10000 → 10000 * 100 µs = 1 second watchdog monitoring time

CAUTION 		CAUTION! Undefined state possible!
The function for switching off of the SM watchdog via SM watchdog = 0 is only implemented in terminals from version -0016.
In previous versions this operating mode should not be used.

CAUTION 		CAUTION! Damage of devices and undefined state possible!
If the SM watchdog is activated and a value of 0 is entered the watchdog switches off completely. This is the deactivation of the watchdog!
Set outputs are NOT set in a safe state, if the communication is interrupted.

Note 		Outputs in SAFEOP state
The default set watchdog monitoring sets the outputs of the module in a safe state - depending on the settings in SAFEOP and OP - e.g. in OFF state.
If this is prevented by deactivation of the watchdog monitoring in the module, the outputs can be switched or set also in the SAFEOP state.


EtherCAT State Machine

The state of the EtherCAT slave is controlled via the EtherCAT State Machine (ESM). Depending upon the state, different functions are accessible or executable in the EtherCAT slave. Specific commands must be sent by the EtherCAT master to the device in each state, particularly during the bootup of the slave.

A distinction is made between the following states:

  • Init
  • Pre-Operational
  • Safe-Operational and
  • Operational
  • Boot

The regular state of each EtherCAT slave after bootup is the OP state.

Init

After switch-on the EtherCAT slave in the Init state. No mailbox or process data communication is possible. The EtherCAT master initializes sync manager channels 0 and 1 for mailbox communication.

Pre-Operational (Pre-Op)

During the transition between Init and Pre-Op the EtherCAT slave checks whether the mailbox was initialized correctly.

In Pre-Op state mailbox communication is possible, but not process data communication. The EtherCAT master initializes the sync manager channels for process data (from sync manager channel 2), the FMMU channels and, if the slave supports configurable mapping, PDO mapping or the sync manager PDO assignment. In this state the settings for the process data transfer and perhaps terminal-specific parameters that may differ from the default settings are also transferred.

Safe-Operational (Safe-Op)

During transition between Pre-Op and Safe-Op the EtherCAT slave checks whether the sync manager channels for process data communication and, if required, the distributed clocks settings are correct. Before it acknowledges the change of state, the EtherCAT slave copies current input data into the associated DP-RAM areas of the EtherCAT slave controller (ECSC).

In Safe-Op state mailbox and process data communication is possible, although the slave keeps its outputs in a safe state, while the input data are updated cyclically.

Note 		Outputs in SAFEOP state
The default set watchdog monitoring sets the outputs of the module in a safe state - depending on the settings in SAFEOP and OP - e.g. in OFF state.
If this is prevented by deactivation of the watchdog monitoring in the module, the outputs can be switched or set also in the SAFEOP state.

Operational (Op)

Before the EtherCAT master switches the EtherCAT slave from Safe-Op to Op it must transfer valid output data.

In the Op state the slave copies the output data of the masters to its outputs. Process data and mailbox communication is possible.

Boot

In the Boot state the slave firmware can be updated. The Boot state can only be reached via the Init state.

In the Boot state mailbox communication via the file access over EtherCAT (FoE) protocol is possible, but no other mailbox communication and no process data communication.


EtherCAT - CoE Interface

BECKHOFF EtherCAT: Communication basics

CoE-Interface

This device has no CoE.

Detailed information on the CoE interface can be found in the EtherCAT system documentation on the Beckhoff website.


EtherCAT Box - Dimensions

BECKHOFF EtherCAT Box: Mounting and cabling

Dimensions

All dimensions are given in millimeters.

Housing properties

EtherCAT Box | lean body | wide body
Housing material | PA6 (polyamide)
Casting compound | Polyurethane
Mounting | two fastening holes Ø 3 mm for M3 | two fastening holes Ø 3 mm for M3 two fastening holes Ø 4,5 mm for M4
Metal parts | Brass, nickel-plated
Contacts | CuZn, gold-plated
Power feed through | max. 4 A
Installation position | variable
Protection class | IP65, IP66 and IP67, conforms to EN 60529 (with screwed sockets)
Dimensions (H x W x D) | app. 126 x 30 x 26.5 mm | app. 126 x 60 x 26.5 mm
Weight | approx. 125 g, depending on module type | approx. 250 g, depending on module type


EPxxxx - Fixing

BECKHOFF EtherCAT Box: Mounting and cabling

Fixing

Note 		Note or pointer
While mounting the modules, protect all connectors, especially the IP-Link, against contamination!

Only with connected cables or plugs the protection class IP67 is guaranteed!
Unused connectors have to be protected with the right plugs! See for plug sets in the catalogue.

Modules with narrow housing are mounted with two M3 bolts.
Modules with wide housing are mounted with two M3 bolts to the fixing holes located at the corners or mounted with two M4 bolts to the fixing holes located centrally.

The bolts must be longer than 15 mm. The fixing holes of the modules are not threaded.

When assembling, remember that the fieldbus connectors increases the overall height. See chapter accessories.

Mounting Rail ZS5300-0001

The mounting rail ZS5300-0001 (500 mm x 129 mm) allows the time saving assembly of modules.

The rail is made of stainless steel, 1.5 mm thick, with already pre-made M3 threads for the modules. The rail has got 5.3 mm slots to mount it via M5 screws to the machine.

The mounting rail is 500 mm long, that way 15 narrow modules can be mounted with a distance of 2 mm between two modules. The rail can be cut to length for the application.

Mounting Rail ZS5300-0011

The mounting rail ZS5300-0011 (500 mm x 129 mm) has in addition to the M3 treads also pre-made M4 treads to fix 60 mm wide modules via their middle holes.

Up to 14 narrow or 7 wide modules may be mixed mounted.


EPxxxx - Nut tourque for connectors

BECKHOFF EtherCAT Box: Mounting and cabling

Nut torque for connectors

M8 connectors

It is recommended to pull the M8 connectors tight with a nut torque of 0.4 Nm.

M12 connectors

It is recommended to pull the M12 connectors tight with a nut torque of 0.6 Nm.

Torque socket wrenches

Note 		Ensure the right torque
Use the torque socket wrenches available by Beckhoff to pull the connectors tight (see accessories)!


EtherCAT connection

For the incoming and ongoing EtherCAT connection,

  • the EtherCAT Box (EPxxxx) has two M8 sockets, marked in green
  • the Coupler Box (FBB-x110) has two M12 sockets
EtherCAT Box: M8 (30 mm housing) | EtherCAT Box: M8 60 mm housing (EP9214 for example ) | Coupler Box: M12

Assignment

There are various different standards for the assignment and colors of connectors and cables for Ethernet/EtherCAT.

Ethernet/EtherCAT |  | Plug connector |  |  | Cable |  | Standard
Signal | Description | M8 | M12 | RJ451 | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 and old versions of ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | Transmit Data+ | Pin 1 | Pin 1 | Pin 1 | yellow2 | orange/white3 | white/orange
Tx - | Transmit Data- | Pin 4 | Pin 3 | Pin 2 | orange2 | orange3 | orange
Rx + | Receive Data+ | Pin 2 | Pin 2 | Pin 3 | white2 | blue/white3 | white/green
Rx - | Receive Data- | Pin 3 | Pin 4 | Pin 6 | blue2 | blue3 | green
Shield | Shield | Housing |  | Shroud | Screen | Screen | Screen

1) colored markings according to EN 61918 in the four-pin RJ45 connector ZS1090-0003

2) wire colors according to EN 61918

3) wire colors

Note 		Assimilation of color coding for cable ZB9030, ZB9032 and ZK1090-3xxxx-xxxx (with M8 connectors)

For unification the prevalent cables ZB9030, ZB9032 and ZK1090-3xxx-xxxx
this means the pre assembled cables with M8 connectors
were changed to the colors of EN61918 (yellow, orange, white, blue).

So different color coding exists. But the electrical properties are absolutely identical.

EtherCAT connectors

The following connectors can be supplied for use in Beckhoff EtherCAT systems.

Designation | Plug connector | Comment
ZS1090-0003 | RJ45 | four-pin, IP20, for field assembly
ZS1090-0004 | M12 male | four-pin, IP67, for field assembly
ZS1090-0005 | RJ45 | eight-pin, IP20, for field assembly, suitable for GigaBit Ethernet
ZS1090-0006 | M8 male | four-pin, IP67, for field assembly, for ZB903x cable
ZS1090-0007 | M8 female | four-pin, IP67, for field assembly, for ZB903x cable
ZS1090-1006 | M8 male | four-pin, IP67, for field assembly up to OD = 6.5 mm
ZS1090-1007 | M8 female | four-pin, IP67, for field assembly up to OD = 6.5 mm


EPxxxx - Fieldbus LEDs

BECKHOFF EtherCAT Box: Installation

EtherCAT- Fieldbus LEDs

LED displays
LED | Display | Meaning
IN L/A | off | no connection to the preceding EtherCAT module
 | Lit | LINK: connection to the preceding EtherCAT module
 | flashing | ACT: Communication with the preceding EtherCAT module
OUT L/A | off | no connection to the following EtherCAT module
 | Lit | LINK: connection to the following EtherCAT module
 | flashing | ACT: Communication with the following EtherCAT module
Run | off | Status of the EtherCAT module is Init
 | flashes quickly | Status of the EtherCAT module is pre-operational
 | flashes slowly | Status of the EtherCAT module is safe-operational
 | Lit | Status of the EtherCAT module is operational

Note 		EtherCAT statuses
The various statuses in which an EtherCAT module may be found are described in the Basic System Documentation for EtherCAT, which is available for download from our website (www.beckhoff.com) under Downloads.


EtherCAT Box - Power Connection

BECKHOFF EtherCAT Box: Mounting and cabling

Power Connection

The feeding and forwarding of supply voltages is done via two M8 connectors at the bottom end of the modules:

  • IN: left M8 connector for feeding the supply voltages
  • OUT: right M8 connector for forwarding the supply voltages

PIN assignment
Pin | Voltage
1 | Control voltage Us, +24 VDC
2 | Auxiliary voltage Up, +24 VDC
3 | GNDs* | *) may be connected internally to each other depending on the module: see specific module descriptions
4 | GNDp*

The pins M8 connectors carry a maximum current of 4 A.

Two LEDs display the status of the supply voltages.

Attention 		Don't confuse the power connectors with the EtherCAT connectors!
Never connect the power cables (M8, 24 VDC) with the green marked EtherCAT sockets of the EtherCAT Box Modules! This can damage the modules!

Control voltage Us: 24 VDC

Power is supplied to the fieldbus, the processor logic, the inputs and the sensors from the 24 VDC control voltage Us. The control voltage is electrically isolated from the fieldbus circuitry.

Auxiliary voltage Up 24 VDC

The Auxiliary voltage Up supplies the digital outputs; it can be brought in separately. If the load voltage is switched off, the fieldbus functions and the power supply and functionality of the inputs are retained.

Redirection of the supply voltages

The IN and OUT power connections are bridged in the module (not IP204x-Bxxx and IE204x). The supply voltages Us and Up can thus easily be transferred from EtherCAT Box to EtherCAT Box.

Attention 		Pay attention to the maximum permissible current!
Pay attention also for the redirection of the supply voltages Us and Up, the maximum permissible current for M8 connectors of 4 A must not be exceeded!

Supply via EP92x4-0023 PowerBox modules

If the machine requires higher current or if the EtherCAT Box Modules are installed far away from the control cabinet with included power supply, the usage of four cannel power distribution modules EP9214 or EP9224 (with integrated data logging, see www.beckhoff.com/EP9224) is recommended.

With these modules intelligent power distribution concepts with up to 2 x 16 A and a maximum of 2.5 mm² cable cross-section can be realized.

Electrical isolation

Digital modules

In the digital input/output modules, the grounds of the control voltage (GNDs) and the auxiliary voltage (GNDp) are connected to each other!

Check this at the documentation of each used EtherCAT Box.

Analog modules

In the analog input/output modules the grounds of the control voltage (GNDs) and the auxiliary voltage (GNDp) are separated from each other in order to ensure electrical isolation of the analog signals from the control voltage.

In some of the analog modules the sensors or actuators are supplied by Up - this means, for instance, that in the case of 0...10 V inputs, any reference voltage (0...30 V) may be connected to Up; this is then available to the sensors (e.g. smoothed 10 V for measuring potentiometers).

Details of the power supply may be taken from the specific module descriptions.

Attention 		Electrical isolation may be cancelled!
If digital and analog fieldbus boxes are connected directly via four-core power leads, the analog signals in the fieldbus boxes may be no longer electrically isolated from the control voltage!


EtherCAT Box - Status LEDs for power supply

BECKHOFF EtherCAT Box: Mounting and cabling

Status LEDs for power supply

LED | Display | Meaning
Us (Control voltage) | off | The power supply voltage Us is not present
 | green illuminated | The power supply voltage Us is present
 | reed illuminated | Because of overload (current > 0.5 A) the sensor supply generated from power supply voltage Us was switched off for all sensors fed from this.
Up (Auxiliary voltage) | off | The power supply voltage Up is not present
 | green illuminated | The power supply voltage Up is present


EtherCAT Box - UL Requirements

BECKHOFF EtherCAT Box: Mounting and cabling

UL Requirements

The installation of the EtherCAT Box Modules certified by UL has to meet the following requirements.

Supply voltage

CAUTION 		CAUTION!
For the compliance of the UL requirements the EtherCAT Box Modules should only be supplied
  • by a 24 VDC supply voltage, supplied by an isolating source and protected by means of a fuse (in accordance with UL248), rated maximum 4 Amp, or
  • by a 24 VDC power source, that has to satisfy NEC class 2.
    A NEC class 2 power supply shall not be connected in series or parallel with another (class 2) power source!
This UL requirements are valid for all supply voltages of all marked EtherCAT Box Modules!

CAUTION 		CAUTION!
To meet the UL requirements, the EtherCAT Box Modules must not be connected to unlimited power sources!

Networks

CAUTION 		CAUTION!
To meet the UL requirements, EtherCAT Box Modules must not be connected to telecommunication networks!

Ambient temperature range

CAUTION 		CAUTION!
To meet the UL requirements, EtherCAT Box Modules has to be operated only at an ambient temperature range of 0 to 55°C!

Marking for UL

All EtherCAT Box Modules certified by UL (Underwriters Laboratories) are marked with the following label.


EtherCAT Box - ATEX - Special conditions

BECKHOFF EtherCAT Box: Monting and wiring

ATEX - Special conditions

WARNING 		Observe the special conditions for the intended use of
EtherCAT Box modules in potentially explosive areas – directive 94/9/EU.
  • The certified components are to be installed in the BG2000-0000 protection enclosure that guarantees a protection against mechanical hazards!
  • If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
  • Observe the permissible ambient temperature range of 0 - 55°C for the use of EtherCAT Box modules in potentially explosive areas!
  • Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
  • The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!

Standards

The fundamental health and safety requirements are fulfilled by compliance with the following standards:

  • EN 60079-0: 2006
  • EN 60079-15: 2005

Marking

The EtherCAT Box modules certified for potentially explosive areas bear the following marking:

II 3 G Ex nA II T4

DEKRA 11ATEX0080 X Ta: 0 - 55°C

or

II 3 G Ex nA nC IIC T4

DEKRA 11ATEX0080 X Ta: 0 - 55°C

Batch number (D number)

The EtherCAT Box modules bear a batch number (D number) that is structured as follows:

D: WW YY FF HH

WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version

Beispiel mit Ser. Nr.: 29 10 02 01:

29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01


BG2000-0000 - Protective housing for EtherCAT Box

BECKHOFF BG2000-0000: Monting and wiring

BG2000-0000 - EtherCAT Box protection enclosure

WARNING 		Risk of electric shock and damage of device!
Bring the EtherCAT system into a safe, powered down state before starting installation, disassembly or wiring of the modules!

ATEX

The BG2000-0000 protection enclosure has to be mounted over a single EtherCAT Box to fulfill the special conditions according to ATEX.

Installation

1.

Put the wires for EtherCAT, power supply and sensors/actuators through the hole of the BG2000-0000 protection enclosure.

2.

Fix the wires for EtherCAT, power supply and sensors/actuators to the EtherCAT Box.

3.

Mount the BG2000-0000 protection enclosure over the EtherCAT Box.


EtherCAT Box - ATEX Documentation

BECKHOFF EtherCAT Box: Mounting and Cabling

ATEX Documentation

Note 		Notes about operation of EtherCAT Box Modules (EPxxxx-xxxx) in potentially explosive areas (ATEX)
Pay also attention to the continuative documentation

Notes about operation of EtherCAT Box Modules (EPxxxx-xxxx) in potentially explosive areas (ATEX)

that is available in the download area of the Beckhoff homepage http:\\www.beckhoff.com!


EP1122 - Application notes

BECKHOFF EP1122: Application notes

Application notes

Settings and port assignment

For normal operation the EP1122 can be used with default settings.

The port ID used in the TwinCAT System Manager is mapped on the EP1122 as follows:

Port assignment

EtherCAT signal input = port A

EtherCAT signal output = port C

EtherCAT Port 1 = Port D

EtherCAT Port 2 = Port B


EP1122 - diagnostic LEDs

BECKHOFF EP1122: Error handling and diagnosis

Diagnostic LEDs

LEDs for fieldbus diagnosis

LED |  | Display | State | Description
LINK / ACT (ECAT IN / ECAT OUT /Port1/Port2) | green | off | - | no connection on the EtherCAT strand
 |  | on | linked | EtherCAT device connected
 |  | flashing | active | Communication with EtherCAT device

LED diagnostics EtherCAT state machine

LED | Color | Meaning
RUN | green | This LED shows the operating state of the Box:
 |  | off | State of the EtherCAT state machine: INIT = initialization of the Box
 |  | Single flash | State of the EtherCAT state machine: PREOP = function for mailbox communication and different standard-settings set
 |  | flashing | State of the EtherCAT state machine: SAFEOP = verification of the sync manager channels and the distributed clocks. Outputs remain in safe state
 |  | on | State of the EtherCAT state machine: OP = normal operating state; mailbox-and process data communication is possible
 |  | flickering | State of the EtherCAT state machine: BOOTSTRAP = function for Box firmware updates


General operating conditions

Protection degrees (IP-Code)

The standard IEC 60529 (DIN EN 60529) defines the degrees of protection in different classes.

1. Number: dust protection and touch guard | Definition
0 | Non-protected
1 | Protected against access to hazardous parts with the back of a hand. Protected against solid foreign objects of Ø50 mm
2 | Protected against access to hazardous parts with a finger. Protected against solid foreign objects of Ø12,5 mm.
3 | Protected against access to hazardous parts with a tool. Protected against solid foreign objects Ø2,5 mm.
4 | Protected against access to hazardous parts with a wire. Protected against solid foreign objects Ø1 mm.
5 | Protected against access to hazardous parts with a wire. Dust-protected. Intrusion of dust is not totally prevented, but dust shall not penetrate in a quantity to interfere with satisfactory operation of the device or to impair safety.
6 | Protected against access to hazardous parts with a wire. Dust-tight. No intrusion of dust.
2. Number: water* protection | Definition
0 | Non-protected
1 | Protected against water drops
2 | Protected against water drops when enclosure tilted up to 15°.
3 | Protected against spraying water. Water sprayed at an angle up to 60° on either side of the vertical shall have no harmful effects.
4 | Protected against splashing water. Water splashed against the disclosure from any direction shall have no harmful effects
5 | Protected against water jets
6 | Protected against powerful water jets
7 | Protected against the effects of temporary immersion in water. Intrusion of water in quantities causing harmful effects shall not be possible when the enclosure is temporarily immersed in water for 30 min. in 1 m depth.

*) These protection classes define only protection against water!

Chemical Resistance

The Resistance relates to the Housing of the Fieldbus Box and the used metal parts.

Character | Resistance
Steam | at temperatures >100°C: not resistant
Sodium base liquor (ph-Value > 12) | at room temperature: resistant > 40°C: not resistant
Acetic acid | not resistant
Argon (technical clean) | resistant
Key

resistant: Lifetime several months
non inherently resistant: Lifetime several weeks
not resistant: Lifetime several hours resp. early decomposition


EtherCAT Box - Accessories

Fixing
Ordering information | Description
ZS5300-0001 | Mounting rail (500 mm x 129 mm)
Marking material, plugs
Ordering information | Description
ZS5000-0000 | Fieldbus Box set M8 (contact labels, plugs)
ZS5000-0002 | Fieldbus Box set M12 (contact labels, plugs)
ZS5000-0010 | plugs M8, IP67 (50 pieces)
ZS5000-0020 | plugs M12, IP67 (50 pieces)
ZS5100-0000 | marking labels, not printed, 4 stripes at 10 pieces
ZS5100-xxxx | printed marking labels, on request
Tools
Ordering information | Description
ZB8800 | Torque socket wrench with ratchet wrench for M8 connectors (over molded)
ZB8800-0001 | ratchet wrench for M8 connectors (field assembly)
ZB8800-0002 | ratchet wrench for M12 connectors (over molded)

Note 		Further accessories
Further accessories may be found at the price list for Beckhoff fieldbus components and at the internet under www.beckhoff.com.


Support and Service

Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.

Beckhoff's branch offices and representatives

Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!

The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com

You will also find further documentation for Beckhoff components there.

Beckhoff Headquarters

Beckhoff Automation GmbH & Co. KG

Huelshorstweg 20
33415 Verl
Germany

Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support

Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:

  • support
  • design, programming and commissioning of complex automation systems
  • and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service

The Beckhoff Service Center supports you in all matters of after-sales service:

  • on-site service
  • repair service
  • spare parts service
  • hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com