EP1122-0001 - 2-Port-EtherCAT-Abzweig
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentlichte Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
1.2
▪
Erste Veröffentlichung im pdf-Format
1.1
▪
Vorwort aktualisiert
▪
Montage und Anschluss aktualisiert
1.0
▪
Erste Veröffentlichung
Firm- und Hardware-Stände
Diese Dokumentation bezieht sich auf den zum Zeitpunkt ihrer Erstellung gültigen Firm- und Hardware-Stand.
Die Eigenschaften der Module werden stetig weiterentwickelt und verbessert. Module älteren Fertigungsstandes können nicht die gleichen Eigenschaften haben, wie Module neuen Standes. Bestehende Eigenschaften bleiben jedoch erhalten und werden nicht geändert, so dass ältere Module immer durch neue ersetzt werden können.
Dokumentation | Firmware | Hardware
1.2 | 02 | 05
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der EtherCAT Box aufgedruckten Batch-Nummer (D-Nummer) entnehmen.
Syntax der Batch-Nummer (D-Nummer)
D: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit D-Nr. 29 10 02 01:
29 - Produktionswoche 29
10 - Produktionsjahr 2010
02 - Firmware-Stand 02
01 - Hardware-Stand 01
Weitere Informationen zu diesem Thema: Versionsidentifikation von EtherCAT-Geräten.


EtherCAT Box - Einführung

EtherCAT Box - Einführung
EtherCAT Box - Einführung
Das EtherCAT-System wird durch die EtherCAT-Box-Module in Schutzart IP67 erweitert. Durch das integrierte EtherCAT-Interface sind die Module ohne eine zusätzliche Kopplerbox direkt an ein EtherCAT-Netzwerk anschließbar. Die hohe EtherCAT-Performance bleibt also bis in jedes Modul erhalten.
Die außerordentlich geringen Abmessungen von nur 126 x 30 x 26,5 mm (H x B x T) sind identisch zu denen der Feldbus Box Erweiterungsmodule. Sie eignen sich somit besonders für Anwendungsfälle mit beengten Platzverhältnissen. Die geringe Masse der EtherCAT-Module begünstigt u. a. auch Applikationen, bei denen die I/O-Schnittstelle bewegt wird (z. B. an einem Roboterarm). Der EtherCAT-Anschluss erfolgt über geschirmte M8-Stecker.
EtherCAT-Box-Module in einem EtherCAT-Netzwerk
Die robuste Bauweise der EtherCAT-Box-Module erlaubt den Einsatz direkt an der Maschine. Schaltschrank und Klemmenkasten werden hier nicht mehr benötigt. Die Module sind voll vergossen und daher ideal vorbereitet für nasse, schmutzige oder staubige Umgebungsbedingungen.
Durch vorkonfektionierte Kabel vereinfacht sich die EtherCAT- und Signalverdrahtung erheblich. Verdrahtungsfehler werden weitestgehend vermieden und somit die Inbetriebnahmezeiten optimiert. Neben den vorkonfektionierten EtherCAT-, Power- und Sensorleitungen stehen auch feldkonfektionierbare Stecker und Kabel für maximale Flexibilität zur Verfügung. Der Anschluss der Sensorik und Aktorik erfolgt je nach Einsatzfall über M8- oder M12-Steckverbinder.
Die EtherCAT-Module decken das typische Anforderungsspektrum der I/O-Signale in Schutzart IP67 ab:
▪
digitale Eingänge mit unterschiedlichen Filtern (3,0 ms oder 10 μs)
▪
digitale Ausgänge mit 0,5 oder 2 A Ausgangsstrom
▪
analoge Ein- und Ausgänge mit 16 Bit Auflösung
▪
Thermoelement- und RTD-Eingänge
▪
Schrittmotormodule
Auch XFC (eXtreme Fast Control Technology)-Module wie z. B. Eingänge mit Time-Stamp sind verfügbar.
EtherCAT Box mit M8-Anschlüssen für Sensor/Aktoren
EtherCAT Box mit M12-Anschlüssen für Sensor/Aktoren
Basis-Dokumentation zu EtherCAT
Eine detaillierte Beschreibung des EtherCAT-Systems finden Sie in der System Basis-Dokumentation zu EtherCAT, die auf unserer Homepage (www.beckhoff.de) unter Downloads zur Verfügung steht.
XML-Dateien
XML -Dateien (XML Device Description Files) zu EtherCAT-Modulen von Beckhoff finden Sie unter auf unserer Homepage (www.beckhoff.de) unter Downloads im Bereich Konfigurations-Dateien.


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Einführung
•
Technische Daten
•
Lieferumfang


Einführung

Produktübersicht [image] Einführung
Einführung
EP1122-0001 | 2-Port-EtherCAT-Abzweig
Der 2-Port-EtherCAT-Abzweig ermöglicht es, EtherCAT-Sterntopologien aufzubauen. Durch das Verwenden mehrerer EP1122 in einer Station lässt sich ein modularer EtherCAT-Sternverteiler realisieren.
An den Abzweigports können einzelne Geräte oder auch ganze EtherCAT-Stränge angeschlossen werden. Der Anschluss der EtherCAT-Abzweige erfolgt über schraubbare, geschirmte M8-Stecker, an denen direkt Link- und Activity-Status angezeigt werden. Die Run-LED zeigt den Status des EP1122 an. Mit TwinCAT und anderen geeigneten EtherCAT-Mastern unterstützt der EP1122 auch das An- und Abkoppeln von EtherCAT-Strängen im laufenden Betrieb (Hot-Connect).
Quick Links


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Alle Werte sind typische Werte über den gesamten Temperaturbereich, wenn nicht anders angegeben.
Technische Daten | EP1122-0001
EtherCAT
Anschluss | 4x M8-Buchse, 4-polig (1 Eingang, 3 Ausgänge)
Übertragungsmedium | EtherCAT-Kabel
Leitungslänge | max. 100 m zwischen zwei Geräten (100BASE-TX)
Baudrate | 100 MBaud
Versorgungsspannungen
Anschluss | Eingang: 1 x M8-Stecker, 4-polig, schwarz Weiterleitung: 1 x M8-Buchse, 4-polig, schwarz
Steuerspannung US
Nennspannung | 24 VDC (-15 % / +20 %)
Summenstrom | max. 4 A 1)
Stromaufnahme aus US | 120 mA
Peripheriespannung UP
Nennspannung | 24 VDC (-15 % / +20 %)
Summenstrom | max. 4 A 1)
Stromaufnahme aus UP | Keine. UP wird nur weitergeleitet.
Umgebungsbedingungen
Umgebungstemperatur im Betrieb | -25…+60 °C -25…+55 °C gemäß cURus 0…+55 °C gemäß ATEX
Umgebungstemperatur bei Lagerung | -40…+85 °C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27; siehe auch Zusätzliche Prüfungen.
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 gemäß EN 60529
Mechanik
Abmessungen | ca. 126 x 30 x 26,5 mm (ohne Steckverbinder)
Gewicht | ca. 165 g
Einbaulage | beliebig
Zulassungen und Konformität
Zulassungen | CE, cURus, ATEX
1) Dieser Wert entspricht der Stromtragfähigkeit der Anschlüsse für die Versorgungsspannungen.
Zusätzliche Prüfungen
Die Boxen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3 Achsen
 | 5 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3 Achsen
 | 35 g, 11 ms


Lieferumfang

Produktübersicht [image] Lieferumfang
Lieferumfang
Vergewissern Sie sich, dass folgende Komponenten im Lieferumfang enthalten sind:
▪
1x EtherCAT Box EP1122-0001
▪
4x Schutzkappe für EtherCAT-Buchse, M8, grün (vormontiert)
▪
1x Schutzkappe für Versorgungsspannungs-Eingang, M8, transparent (vormontiert)
▪
1x Schutzkappe für Versorgungsspannungs-Ausgang, M8, schwarz (vormontiert)
▪
10x Beschriftungsschild unbedruckt (1 Streifen à 10 Stück)
Vormontierte Schutzkappen gewährleisten keinen IP67-Schutz
Schutzkappen werden werksseitig vormontiert, um Steckverbinder beim Transport zu schützen. Sie sind u.U. nicht fest genug angezogen, um die Schutzart IP67 zu gewährleisten.
Stellen Sie den korrekten Sitz der Schutzkappen sicher, um die Schutzart IP67 zu gewährleisten.


Funktionsgrundlagen EtherCAT-Abzweige

Funktionsgrundlagen EtherCAT-Abzweige
Funktionsgrundlagen EtherCAT-Abzweige
Es sind einige Beckhoff EtherCAT-Geräte verfügbar, die für Abzweige im EtherCAT-Strang verwendet werden können. Dazu gehören EK1122, EK1521, EP1122 oder auch CU1128 und EP9128. Aufgrund der gleichen Systematik und ähnlichen technischen Eigenschaften dieser Geräte wird in den folgenden Beispielen nur der EK1122 verwendet.
EtherCAT-Handling in den Slaves
Beim Einsatz von EtherCAT als Feldbusprotokoll sind viele verschiedene Bustopologien anwendbar: Linie-, Stern-, Baumtopologie und mit Redundanz-Unterstützung sogar Ringtopologie. Die einfachste Topologie ist die Linientopologie, bei der jeder EtherCAT-Slave die Daten an den einzigen nächsten weiterreicht.
EtherCAT Linientopologie
Beim Einsatz von z.B. EtherCAT-Kopplern EK1100 ist auch ein Abzweig und damit eine Art Baumtopologie möglich.
Linientopologie mit Erweiterungen
Grundlegend dabei ist, dass intern der oder die Ethernet-Frame(s) mit den EtherCAT-Protokolldaten weiterhin in einem logischen Ring befördert werden:
▪
der EtherCAT-Master sendet den Frame auf den beiden Hin-Leitungen des Ethernet-Kabels aus
▪
dieser Frame durchläuft einmalig jeden Slave
▪
wird vom logisch letzten Slave dann gewendet und
▪
auf den beiden Rück-Leitungen des Ethernet-Kabels dann ohne weiteres Processing wieder durch jeden EtherCAT-Slave zum Master zurückbefördert
Bei kurzen Zykluszeiten von z.B. 50 µs sind dabei mindestens 20.000 Ethernet Frames je Sekunde im dem EtherCAT-System unterwegs, zuzüglich azyklischer Organisationsframes. Der Master erwartet dabei auf die Rückkehr der ausgesandten Frames, die z.B. die Eingangsdaten der Teilnehmer zum Master zurücktransportieren. Die Weiterleitung der Telegramme von einem Slave zum nächsten ist dabei link-basiert: nur wenn ein "Link"-Signal zum nächsten Teilnehmer besteht, sendet ein EtherCAT-Slave einen Frame weiter. Im Normalfall ist davon auszugehen, dass der nachfolgende Teilnehmer jedes EtherCAT-Telegramm auch korrekt weiterbearbeitet und am Schluss ggf. zurücksendet bzw. weiterleitet.
Entscheidend bei der Weiterleitung von EtherCAT-Telegrammen ist also, dass ein Link-Signal erst dann von einem Slave zum anderen gemeldet wird, wenn beide wirklich bereit sind in Echtzeit an der Datenverarbeitung teilzunehmen. Konkret darf ein EtherCAT-Slave also erst dann den jeweiligen Ethernet-Port öffnen, wenn er umgehend einen Ethernet-Frame annehmen und weiterleiten kann.
Um üblichen Ethernet-Verkehr weiterzuleiten wird i.d.R. ein Switch oder Router eingesetzt. Treten dort Kollisionen oder Frame-Verluste auf, wird dies von übergeordneten Protokollschichten (z.B. TCP) durch Frame-Wiederholung ausgeglichen. Diese Betriebsart ist bei EtherCAT aufgrund der kurzen Zykluszeiten und des Echtzeit-Anspruchs standardmäßig nicht im Einsatz. Einige Ethernet-Geräte wie z.B. spezielle Switche melden bereits einen Link zur Gegenstelle, obwohl sie erst in einigen Millisekunden zur Datenverarbeitung bereit sind. Besonders auffällig wird dieses Verhalten bei Medienkonvertern von 100Base-TX (Kupfer) nach 100Base-Fx (Lichtwellenleiter), die je nach Einstellung auf der Kupferseite zum vorhergehenden EtherCAT-Slave einen Link melden, obwohl die LWL-Verbindung unterbrochen ist.
Deshalb ist die schnelle Link-Detektion ein zentraler Bestandteil eines jeden ESC (EtherCAT Slave Controller, Hardwareverarbeitungseinheit des EtherCAT-Protokolls). Laut EtherCAT-Spezifikation kann ein ESC über 1 bis 4 Ports verfügen, die er von sich aus kontrolliert. Öffnet er einen Port, ist dort abgehender und ankommender Ethernet-Verkehr möglich. Die Datenflussrichtung in einem vollausgebauten ESC ist in Abb. 3. gezeigt - dabei werden die Daten in den EtherCAT-Datagrammen nur zwischen Port 0 (A) und 3 (D) in der EtherCAT-Processing-Unit verarbeitet.
Datenflussrichtung im ESC
Idealerweise findet die Link-Erkennung und damit das Port-Handling im ESC so schnell statt, dass selbst bei 100 µs Zykluszeit kein Lost-Frame-Ereignis auftritt. Dennoch ist zumindest ein verlorener Frame nie auszuschließen, falls nämlich eine Verbindung getrennt wird, während ein Ethernet-Frame gerade genau auf diesem Kabel bzw. in dem Bussegment hinter der Trennstelle unterwegs ist.
Umsetzung: EL-Klemme
Ein üblicher EtherCAT-Slave wie z.B. Beckhoff EL-Klemmen verfügt über 2 Ports:
▪
einen für ankommende Frames (Port 0 [A])
▪
und einen für abgehende Frames (z.B. Port [D]).
Die anderen beiden Ports sind intern im ESC geschlossen. Ein EtherCAT-Telegramm gelangt über Port 0 (A)/oben zur Processing-Unit und wird dann über Port 3 (D)/links zum nächsten Slave weitergereicht, falls ein Link zu diesem besteht - s. grüne Pfeile. Das ist dann der Fall, wenn rechts eine weitere EL-Klemme gesteckt ist.
Besteht kein Link, wird der Frame über den violetten Weg zum Port 1(B) weitergereicht. Dieser und auch Port 2 (C) haben keinen Link und reichen den Frame damit zum Port 0 (A) zurück, wo der Frame über den gleichen Ethernet-Port über den er am Slave ankam, diesen wieder verlässt. Das ist der Fall, wenn die betrachtete Klemme als Endklemme fungiert.
Ein EtherCAT-Teilnehmer mit nur einem Port ist somit nur begrenzt einsetzbar, da er nur als End-Teilnehmer eingesetzt werden kann.
Umsetzung: EK1100 EtherCAT-Koppler
Im EtherCAT-Koppler EK1100 werden 3 von den 4 verfügbaren Ports genutzt und damit ein Anschluss nach rechts zu Klemmen und über eine RJ45-Buchse zu weiteren Kopplern ermöglicht, siehe Abb. Linientopologie mit Erweiterungen. Die Processing-Unit wird im EK1100 nicht zum Prozessdatenaustausch genutzt.
Umsetzung: EK1122 EtherCAT-Abzweig
Im EK1122 können alle 4 Ports des ESC verbunden werden. Zwei über den klemmeninternen E-Bus und zwei über die RJ45-Buchsen mit Ethernet-Physik. Im TwinCAT Systemmanager werden die Link-Stati der Ports 0, 1, 2 und 3 über die Online-Anzeige mitgeteilt - dort werden sie mit Port A, B, C und D bezeichnet, siehe Abb. Topologie Anzeige bei unterbrochener Leitung.
Umsetzung: EK1521/EK1521-0010/EK1561 EtherCAT-Abzweig
Im o.g. Abzweigen können wie im EK1100 3 Ports des ESC verbunden werden. Zwei über den klemmeninternen E-Bus und einer über die SC-Buchse/Versatile Link per LWL-Leitung/POF-Leitung.
Umsetzung: CU1128 und EP9128 EtherCAT-Abzweige
Im CU1128 sind 3 ESC integriert, es können somit insgesamt 8 Ports durch Anwender belegt werden. Die 3 ESC sind untereinander über E-Bus verbunden.
Beispielkonfiguration mit EK1122
Im Folgenden soll nun beispielhaft das Linkverhalten unter TwinCAT und seine Darstellung im Systemmanager erläutert werden.
Beispielkonfiguration mit EK1122
In der TwinCAT Online-Topologie ist der Verdrahtungsplan ersichtlich, siehe Abb. Online-Topologie. Markiert ist darin der EK1122, so dass weitere Informationen dargestellt werden. Die grünen Balken über den Slaves zeigen den ordnungsgemäßen RUN-State in allen Slaves an.
Online-Topologie
Nun soll ein Fehler erzeugt werden: die Verbindung der oberen RJ45-Buchse (X1) zur EL3102 wird getrennt. Innerhalb weniger µs erkennt die ESC in der EK1122 den verlorenen Link und schließt den betroffenen Port selbsttätig. Damit wird das nächste ankommende EtherCAT-Telegramm sofort zum Port D (Port 3) und der EL4732 weitergereicht. Damit fehlt hier der Link und der Systemmanager kennzeichnet dies in der Online-Anzeige, siehe Abb. Beispielkonfiguration mit unterbrochener Leitung.
Beispielkonfiguration mit unterbrochener Leitung
Die Meldungen des Systemmanager sind wie folgt zu deuten:
▪
Adresse 1002 - EK1122: "OP LNK:MIS D" - Slave ist weiterhin im OP-State, vermisst aber einen laut Konfiguration vorhandenen Link an Port D (3)
▪
Adresse 1003 - EK1100: "INIT NO_COMM" - da keine Kommunikation mehr zu diesem Slave besteht, wird er als im INIT-State befindlich geführt
▪
Adresse 1004 - EL3104: dto.
Logger-Ausgabe
Im unteren Teil des Systemmanagers ikann die Logger-Ausgabe eingeblendet werden (Anzeige --> Zeige Logger Ausgabe). Dort werden nicht nur bei Linkunterbrechungen hilfreiche Meldungen zur weiteren Interpretation ausgegeben.
In der Topologieansicht zeigt sich diese Unterbrechung durch eine rote Umrandung der betroffenen Slaves, siehe folgende Abb.
Topologieansicht bei unterbrochener Leitung
Man beachte die Anzeige der azyklischen Frames für Abb. Beispielkonfiguration mit EK1122 und für Abb. Beispielkonfiguration mit unterbrochener Leitung.
Gegenüberstellung der Frame-Anzeigen
Im linken Bildauszug sind nur sehr wenige (2) azyklische Frames in der betreffenden Sekunde vom Master ausgesendet worden - alle Slaves sind ordnungsgemäß in Betrieb. Im rechten Bildauszug ist dagegen mit aktuell 77 azyklischen Frames/sec ein deutlicher Anstieg zu verzeichnen: der EtherCAT Master hat schnell erkannt, dass nicht alle Slaves störungsfrei am Datenaustausch teilnehmen. Nachdem er die Störung lokalisiert hat, versucht er nun fortlaufend die Verbindung wiederherzustellen.
Verbindungswiederherstellung
Wird nun in diesem Beispiel die Verbindung wiederhergestellt, meldet der EK1122 an den Master, dass am Port D (3) wieder ein Link anliegt. Der EtherCAT Master wird dann seine Prozessdaten für diesen Abschnitt wieder entsprechend bereitstellen. Wenn die Vorbereitungen abgeschlossen sind, wird er den EK1122 anweisen, den Port D (3) für den regulären Datenaustausch wieder zu öffnen. Der zyklische und azyklische Datenverkehr mit den anderen EtherCAT Slaves läuft dabei selbstverständlich weiter.
Externer Zugriff auf die EtherCAT-Diagnose
Es bestehen umfangreiche Möglichkeiten, aus der PLC heraus auf Zustände, Diagnoseinformationen und Funktionen des EtherCAT-Masters zuzugreifen. Auch über ADS sind fast alle Informationen, die der Systemmanager online darstellt (s. Abbildungen auf dieser Seite) abrufbar. Ebenso können Aktionen des Systemmanagers über PLC oder ADS ausgelöst werden. Beachten Sie dazu entsprechende Informationen im Beckhoff Information System und Erläuterungen zur EtherCAT Diagnose.


Montage und Anschluss

Montage und Anschluss
Montage und Anschluss
Weiterführende Informationen
•
Abmessungen
•
Befestigung
•
Anschluss
•
UL-Anforderungen
•
ATEX-Hinweise


Abmessungen

Montage und Anschluss [image] Abmessungen
Abmessungen
Alle Maße sind in Millimeter angegeben.
Gehäuseeigenschaften
Gehäusematerial | PA6 (Polyamid)
Vergussmasse | Polyurethan
Montage | zwei Befestigungslöcher Ø 3,5 mm für M3
Metallteile | Messing, vernickelt
Kontakte | CuZn, vergoldet
Stromweiterleitung | max. 4 A
Einbaulage | beliebig
Schutzart | im verschraubten Zustand IP65, IP66, IP67 (gemäß EN 60529)
Abmessungen (H x B x T) | ca. 126 x 30 x 26,5 mm (ohne Steckverbinder)


Befestigung

Montage und Anschluss [image] Befestigung
Befestigung
Hinweis
Verschmutzung bei der Montage
Verschmutzte Steckverbinder können zu Fehlfunktion führen. Die Schutzart IP67 ist nur gewährleistet, wenn alle Kabel und Stecker angeschlossen sind.
•
Schützen Sie die Steckverbinder bei der Montage vor Verschmutzung.
Montieren Sie das Modul mit zwei M3-Schrauben an den Befestigungslöchern in den Ecken des Moduls. Die Befestigungslöcher haben kein Gewinde.


Anschluss

Montage und Anschluss [image] Anschluss
Anschluss
Weiterführende Informationen
•
Übersicht
•
EtherCAT
•
Versorgungsspannungen


Übersicht

Montage und Anschluss [image] Anschluss [image] Übersicht
Übersicht
Name | Funktion | Steckverbinder | Anzugs- Drehmoment
X1 | EtherCAT-Abzweig, Port D | M8-Buchse | 0,4 Nm 1)
X2 | EtherCAT-Abzweig, Port B | M8-Buchse | 0,4 Nm 1)
X40 | EtherCAT-Eingang, Port A | M8-Buchse | 0,4 Nm 1)
X41 | EtherCAT-Weiterleitung, Port C | M8-Buchse | 0,4 Nm 1)
X60 | Versorgungsspannungs-Eingang | M8-Stecker | 0,4 Nm 1)
X61 | Versorgungsspannungs-Weiterleitung | M8-Buchse | 0,4 Nm 1)
1) Montieren Sie Stecker an diesen Steckverbindern mit einem Drehmomentschlüssel; z.B. ZB8801 von Beckhoff.


EtherCAT

Montage und Anschluss [image] Anschluss [image] EtherCAT
EtherCAT
Weiterführende Informationen
•
Steckverbinder
•
Status-LEDs
•
Leitungen


Steckverbinder

Montage und Anschluss [image] Anschluss [image] EtherCAT [image] Steckverbinder
Steckverbinder
Hinweis
Verwechselungs-Gefahr: Versorgungsspannungen und EtherCAT
Defekt durch Fehlstecken möglich.
•
Beachten Sie die farbliche Codierung der Steckverbinder:
schwarz: Versorgungsspannungen
grün: EtherCAT
Die EtherCAT-Anschlüsse sind als grüne M8-Buchsen ausgeführt.
M8-Buchse 4polig Kontaktbelegung
EtherCAT Steckverbinder
EtherCAT | M8- Steckverbinder | Aderfarben
Signal | Kontakt | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 und alte Versionen von ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | 1 | gelb1) | orange/weiß | weiß/orange
Tx - | 4 | orange1) | orange | orange
Rx + | 2 | weiß1) | blau/weiß | weiß/grün
Rx - | 3 | blau1) | blau | grün
Shield | Gehäuse | Schirm | Schirm | Schirm
1) Aderfarben nach EN 61918
Anpassung der Aderfarben für die Leitungen ZB9030, ZB9032 und ZK1090-3xxxx-xxxx
Zur Vereinheitlichung wurden die Aderfarben der Leitungen ZB9030, ZB9032 und ZK1090-3xxx-xxxx auf die Aderfarben der EN61918 umgestellt: gelb, orange, weiß, blau. Es sind also verschiedene Farbkodierungen im Umlauf. Die elektrischen Eigenschaften der Leitungen sind bei der Umstellung der Aderfarben erhalten geblieben.


Status-LEDs

Montage und Anschluss [image] Anschluss [image] EtherCAT [image] Status-LEDs
Status-LEDs
L/A (Link/Act)
Neben jeder EtherCAT-Buchse befindet sich eine grüne LED, die mit „L/A“ beschriftet ist. Die LED signalisiert den Kommunikationsstatus der jeweiligen Buchse:
LED | Bedeutung
aus | keine Verbindung zum angeschlossenen EtherCAT-Gerät
leuchtet | LINK: Verbindung zum angeschlossenen EtherCAT-Gerät
blinkt | ACT: Kommunikation mit dem angeschlossenen EtherCAT-Gerät
Run
Jeder EtherCAT-Slave hat eine grüne LED, die mit „Run“ beschriftet ist. Die LED signalisiert den Status des Slaves im EtherCAT-Netzwerk:
LED | Bedeutung
aus | Slave ist im Status „Init“
blinkt gleichmäßig | Slave ist im Status „Pre-Operational“
blinkt vereinzelt | Slave ist im Status „Safe-Operational“
leuchtet | Slave ist im Status „Operational“
Beschreibung der Stati von EtherCAT-Slaves


Leitungen

Montage und Anschluss [image] Anschluss [image] EtherCAT [image] Leitungen
Leitungen
Verwenden Sie zur Verbindung von EtherCAT-Geräten geschirmte Ethernet-Kabel, die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen.
EtherCAT nutzt vier Adern für die Signalübertragung.
Aufgrund der automatischen Leitungserkennung „Auto MDI-X“ können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte, als auch gekreuzte Kabel (Cross-Over) verwenden.
Detaillierte Empfehlungen zur Verkabelung von EtherCAT-Geräten


Versorgungsspannungen

Montage und Anschluss [image] Anschluss [image] Versorgungsspannungen
Versorgungsspannungen
Die EtherCAT Box wird mit zwei Versorgungsspannungen versorgt. Die Massepotentiale der Versorgungsspannungen sind galvanisch getrennt.
▪
Steuerspannung US
▪
Peripheriespannung UP
Weiterleitung der Versorgungsspannungen
Die Power-Anschlüsse IN und OUT sind im Modul gebrückt. Somit können auf einfache Weise die Versorgungsspannungen US und UP von EtherCAT Box zu EtherCAT Box weitergereicht werden.
Hinweis
Maximalen Strom beachten!
Beachten Sie auch bei der Weiterleitung der Versorgungsspannungen US und UP, dass jeweils der für die M8-Steckverbinder maximal zulässige Strom von 4 A nicht überschritten wird!
Weiterführende Informationen
•
Steckverbinder
•
Status-LEDs
•
Leitungsverluste


Steckverbinder

Montage und Anschluss [image] Anschluss [image] Versorgungsspannungen [image] Steckverbinder
Steckverbinder
Hinweis
Verwechselungs-Gefahr: Versorgungsspannungen und EtherCAT
Defekt durch Fehlstecken möglich.
•
Beachten Sie die farbliche Codierung der Steckverbinder:
schwarz: Versorgungsspannungen
grün: EtherCAT
Steckverbinder für Versorgungsspannungen
M8 4polig In+Out Kontaktbelegung
M8-Steckverbinder
Kontakt | Funktion | Beschreibung | Aderfarbe 1)
1 | US | Steuerspannung | Braun
2 | UP | Peripheriespannung | Weiß
3 | GNDS | GND zu US | Blau
4 | GNDP | GND zu UP | Schwarz
1) Die Aderfarben gelten für Leitungen vom Typ: Beckhoff ZK2020-3xxx-xxxx


Status-LEDs

Montage und Anschluss [image] Anschluss [image] Versorgungsspannungen [image] Status-LEDs
Status-LEDs
Steckverbinder + LEDs
Status-LEDs für die Versorgungsspannungen
LED | Anzeige | Bedeutung
US (Steuerspannung) | aus | Versorgungsspannung US nicht vorhanden
 | leuchtet grün | Versorgungsspannung US vorhanden
UP (Peripheriespannung) | aus | Versorgungsspannung UP nicht vorhanden
 | leuchtet grün | Versorgungsspannung UP vorhanden


Leitungsverluste

Montage und Anschluss [image] Anschluss [image] Versorgungsspannungen [image] Leitungsverluste
Leitungsverluste
Beachten Sie bei der Planung einer Anlage den Spannungsabfall an der Versorgungs-Zuleitung. Vermeiden Sie, dass der Spannungsabfall so hoch wird, dass die Versorgungsspannungen an der Box die minimale Nennspannung unterschreiten.
Berücksichtigen Sie auch Spannungsschwankungen des Netzteils.
Spannungsabfall an der Versorgungs-Zuleitung
Leitungsverluste M8 2A
Leitungsverluste M8 4A


UL-Anforderungen

Montage und Anschluss [image] UL-Anforderungen
UL-Anforderungen
Die Installation der nach UL zertifizierten EtherCAT Box Module muss den folgenden Anforderungen entsprechen.
Versorgungsspannung
SmallWarningYellow VORSICHT
VORSICHT!
Die folgenden genannten Anforderungen gelten für die Versorgung aller so gekennzeichneten EtherCAT Box Module.
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur mit einer Spannung von 24 VDC versorgt werden, die
•
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
•
von einer Spannungsquelle die NEC class 2 entspricht stammt.
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit unbegrenzten Spannungsquellen verbunden werden!
Netzwerke
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit Telekommunikations-Netzen verbunden werden!
Umgebungstemperatur
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur in einem Umgebungstemperaturbereich von 0 bis 55°C betrieben werden!
Kennzeichnung für UL
Alle nach UL (Underwriters Laboratories) zertifizierten EtherCAT Box Module sind mit der folgenden Markierung gekennzeichnet.
UL-Markierung


ATEX-Hinweise

Montage und Anschluss [image] ATEX-Hinweise
ATEX-Hinweise
Weiterführende Informationen
•
ATEX - Besondere Bedingungen
•
BG2000 - Schutzgehäuse für EtherCAT Box
•
ATEX-Dokumentation


ATEX - Besondere Bedingungen

Montage und Anschluss [image] ATEX-Hinweise [image] ATEX - Besondere Bedingungen
ATEX - Besondere Bedingungen
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von EtherCAT-Box-Modulen in explosionsgefährdeten Bereichen – Richtlinie 94/9/EG!
•
Die zertifizierten Komponenten sind mit einem Schutzgehäuse BG2000-0000 oder BG2000-0010 zu errichten, das einen Schutz gegen mechanische Gefahr gewährleistet!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten Sie beim Einsatz von EtherCAT-Box-Modulen in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 bis 55°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0: 2006
▪
EN 60079-15: 2005
Kennzeichnung
Die für den explosionsgefährdeten Bereich zertifizierten EtherCAT-Box-Module tragen folgende Kennzeichnung:
II 3 G Ex nA II T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
oder
II 3 G Ex nA nC IIC T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
Batch-Nummer (D-Nummer)
Die EtherCAT-Box-Module tragen eine Batch-Nummer (D-Nummer), die wie folgt aufgebaut ist:
D: KW JJ FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Batch-Nummer 29 10 02 01:
29 - Produktionswoche 29
10 - Produktionsjahr 2010
02 - Firmware-Stand 02
01 - Hardware-Stand 01


BG2000 - Schutzgehäuse für EtherCAT Box

Montage und Anschluss [image] ATEX-Hinweise [image] BG2000 - Schutzgehäuse für EtherCAT Box
BG2000 - Schutzgehäuse für EtherCAT Box
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das EtherCAT-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Module beginnen!
ATEX
SmallWarningYellow WARNUNG
Schutzgehäuse montieren!
Um die Einhaltung der besonderen Bedingungen gemäß ATEX zu erfüllen, muss ein Schutzgehäuse BG2000-0000 oder BG2000-0010 über der EtherCAT Box montiert werden!
Installation
Schieben Sie die Anschlussleitungen für EtherCAT, Spannungsversorgung und die Sensoren/Aktoren durch die Öffnung des Schutzgehäuses.
BG2000 - Anschlussleitungen durchschieben
Schrauben Sie die Anschlussleitungen für die EtherCAT, Spannungsversorgung und die Sensoren/Aktoren an der EtherCAT Box fest.
BG2000 - Anschlussleitungen festschrauben
Montieren Sie das Schutzgehäuse über der EtherCAT Box.
BG2000 - Schutzgehäuse montieren


ATEX-Dokumentation

Montage und Anschluss [image] ATEX-Hinweise [image] ATEX-Dokumentation
ATEX-Dokumentation
Hinweise zum Einsatz von EtherCAT-Box-Modulen (EPxxxx-xxxx) in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation
Hinweise zum Einsatz von EtherCAT-Box-Modulen (EPxxxx-xxxx) in explosionsgefährdeten Bereichen (ATEX) die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


Inbetriebnahme

Inbetriebnahme
Inbetriebnahme
Weiterführende Informationen
•
Einbinden in ein TwinCAT-Projekt


Einbinden in ein TwinCAT-Projekt

Inbetriebnahme [image] Einbinden in ein TwinCAT-Projekt
Einbinden in ein TwinCAT-Projekt
Die Vorgehensweise zum Einbinden in ein TwinCAT-Projekt ist in dieser Schnellstartanleitung beschrieben.


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Allgemeine Betriebsbedingungen
•
Zubehör
•
Versionsidentifikation von EtherCAT-Geräten
•
Support und Service


Allgemeine Betriebsbedingungen

Anhang [image] Allgemeine Betriebsbedingungen
Allgemeine Betriebsbedingungen
Schutzarten nach IP-Code
In der Norm IEC 60529 (DIN EN 60529) sind die Schutzgrade festgelegt und nach verschiedenen Klassen eingeteilt. Die Bezeichnung erfolgt in nachstehender Weise.
1. Ziffer: Staub- und Berührungsschutz | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen den Zugang zu gefährlichen Teilen mit dem Handrücken. Geschützt gegen feste Fremdkörper Ø 50 mm
2 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Finger. Geschützt gegen feste Fremdkörper Ø 12,5 mm
3 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Werkzeug. Geschützt gegen feste Fremdkörper Ø 2,5 mm
4 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Geschützt gegen feste Fremdkörper Ø 1 mm
5 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubgeschützt. Eindringen von Staub ist nicht vollständig verhindert, aber der Staub darf nicht in einer solchen Menge eindringen, dass das zufriedenstellende Arbeiten des Gerätes oder die Sicherheit beeinträchtigt wird
6 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubdicht. Kein Eindringen von Staub
2. Ziffer: Wasserschutz* | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen Tropfwasser
2 | Geschützt gegen Tropfwasser, wenn das Gehäuse bis zu 15° geneigt ist
3 | Geschützt gegen Sprühwasser. Wasser, das in einem Winkel bis zu 60° beiderseits der Senkrechten gesprüht wird, darf keine schädliche Wirkung haben
4 | Geschützt gegen Spritzwasser. Wasser, das aus jeder Richtung gegen das Gehäuse spritzt, darf keine schädlichen Wirkungen haben
5 | Geschützt gegen Strahlwasser.
6 | Geschützt gegen starkes Strahlwasser.
7 | Geschützt gegen die Wirkungen beim zeitweiligen Untertauchen in Wasser. Wasser darf nicht in einer Menge eintreten, die schädliche Wirkungen verursacht, wenn das Gehäuse für 30 Minuten in 1 m Tiefe in Wasser untergetaucht ist
*) In diesen Schutzklassen wird nur der Schutz gegen Wasser definiert.
Chemische Beständigkeit
Die Beständigkeit bezieht sich auf das Gehäuse der IP-67-Module und die verwendeten Metallteile. In der nachfolgenden Tabelle finden Sie einige typische Beständigkeiten.
Art | Beständigkeit
Wasserdampf | bei Temperaturen >100°C nicht beständig
Natriumlauge (ph-Wert > 12) | bei Raumtemperatur beständig > 40°C unbeständig
Essigsäure | unbeständig
Argon (technisch rein) | beständig
Legende
▪
beständig: Lebensdauer mehrere Monate
▪
bedingt beständig: Lebensdauer mehrere Wochen
▪
unbeständig: Lebensdauer mehrere Stunden bzw. baldige Zersetzung


Zubehör

Anhang [image] Zubehör
Zubehör
Befestigung
Bestellangabe | Beschreibung
ZS5300-0001 | Montageschiene (500 mm x 129 mm)
Beschriftungsmaterial, Schutzkappen
Bestellangabe | Beschreibung
ZS5000-0010 | Schutzkappe für M8-Buchsen, IP67 (50 Stück)
ZS5100-0000 | Beschriftungsschilder nicht bedruckt, 4 Streifen à 10 Stück
ZS5000-xxxx | Beschriftungsschilder bedruckt, auf Anfrage
Leitungen
Bestellangabe | Beschreibung
ZK1090-3xxx-xxxx | EtherCAT-Leitung M8, grün Link zur Website
ZK1093-3xxx-xxxx | EtherCAT-Leitung M8, gelb Link zur Website
ZK2020-3xxx-xxxx | Powerleitung M8, 4-polig Link zur Website
Eine vollständige Übersicht von vorkonfektionierten Leitungen für EtherCAT-Box-Module finden sie hier.
Werkzeug
Bestellangabe | Beschreibung
ZB8801-0000 | Drehmoment-Schraubwerkzeug für Stecker, 0,4…1,0 Nm
ZB8801-0001 | Wechselklinge für M8 / SW9 für ZB8801-0000
Weiteres Zubehör
Weiteres Zubehör finden Sie in der Preisliste für Feldbuskomponenten von Beckhoff und im Internet auf https://www.beckhoff.de.


Versionsidentifikation von EtherCAT-Geräten

Anhang [image] Versionsidentifikation von EtherCAT-Geräten
Versionsidentifikation von EtherCAT-Geräten
Bezeichnung
Ein Beckhoff EtherCAT-Gerät hat eine 14stellige technische Bezeichnung, die sich zusammensetzt aus
▪
Familienschlüssel
▪
Typ
▪
Version
▪
Revision
Beispiel | Familie | Typ | Version | Revision
EL3314-0000-0016 | EL-Klemme (12 mm, nicht steckbare Anschlussebene) | 3314 (4 kanalige Thermoelementklemme) | 0000 (Grundtyp) | 0016
ES3602-0010-0017 | ES-Klemme (12 mm, steckbare Anschlussebene) | 3602 (2 kanalige Spannungsmessung) | 0010 (Hochpräzise Version) | 0017
CU2008-0000-0000 | CU-Gerät | 2008 (8 Port FastEthernet Switch) | 0000 (Grundtyp) | 0000
Hinweise
▪
die oben genannten Elemente ergeben die technische Bezeichnung, im Folgenden wird das Beispiel EL3314-0000-0016 verwendet.
▪
Davon ist EL3314-0000 die Bestellbezeichnung, umgangssprachlich bei „-0000“ dann oft nur EL3314 genannt. „-0016“ ist die EtherCAT-Revision.
▪
Die Bestellbezeichnung setzt sich zusammen aus
- Familienschlüssel (EL, EP, CU, ES, KL, CX, ...)
- Typ (3314)
- Version (-0000)
▪
Die Revision -0016 gibt den technischen Fortschritt wie z. B. Feature-Erweiterung in Bezug auf die EtherCAT Kommunikation wieder und wird von Beckhoff verwaltet.
Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders z. B. in der Dokumentation angegeben.
Jeder Revision zugehörig und gleichbedeutend ist üblicherweise eine Beschreibung (ESI, EtherCAT Slave Information) in Form einer XML-Datei, die zum Download auf der Beckhoff Webseite bereitsteht.
Die Revision wird seit 2014/01 außen auf den IP20-Klemmen aufgebracht, siehe Abb. „EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)“.
▪
Typ, Version und Revision werden als dezimale Zahlen gelesen, auch wenn sie technisch hexadezimal gespeichert werden.
Identifizierungsnummer
Beckhoff EtherCAT Geräte der verschiedenen Linien verfügen über verschiedene Arten von Identifizierungsnummern:
Produktionslos/Chargennummer/Batch-Nummer/Seriennummer/Date Code/D-Nummer
Als Seriennummer bezeichnet Beckhoff im IO-Bereich im Allgemeinen die 8-stellige Nummer, die auf dem Gerät aufgedruckt oder auf einem Aufkleber angebracht ist. Diese Seriennummer gibt den Bauzustand im Auslieferungszustand an und kennzeichnet somit eine ganze Produktions-Charge, unterscheidet aber nicht die Module einer Charge.
Aufbau der Seriennummer: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit
Ser. Nr.: 12063A02: 12 - Produktionswoche 12 06 - Produktionsjahr 2006 3A - Firmware-Stand 3A 02 - Hardware-Stand 02
Ausnahmen können im IP67-Bereich auftreten, dort kann folgende Syntax verwendet werden (siehe jeweilige Gerätedokumentation):
Syntax: D ww yy x y z u
D - Vorsatzbezeichnung
ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine
Beispiel: D.22081501 Kalenderwoche 22 des Jahres 2008 Firmware-Stand Busplatine: 1 Hardware Stand Busplatine: 5 Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig) Hardware-Stand E/A-Platine: 1
Eindeutige Seriennummer/ID, ID-Nummer
Darüber hinaus verfügt in einigen Serien jedes einzelne Modul über eine eindeutige Seriennummer.
Siehe dazu auch weiterführende Dokumentation im Bereich
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Klemmen mit Werkskalibrierzertifikat und andere Messtechnische Klemmen
Beispiele für Kennzeichnungen
EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer und Revisionskennzeichnung (seit 2014/01)
EK1100 EtherCAT Koppler, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer
CU2016 Switch mit Seriennummer/ Chargennummer
EL3202-0020 mit Seriennummer/ Chargennummer 26131006 und eindeutiger ID-Nummer 204418
EP1258-00001 IP67 EtherCAT Box mit Chargennummer/ DateCode 22090101 und eindeutiger Seriennummer 158102
EP1908-0002 IP67 EtherCAT Safety Box mit Chargennummer/ DateCode 071201FF und eindeutiger Seriennummer 00346070
EL2904 IP20 Safety Klemme mit Chargennummer/ DateCode 50110302 und eindeutiger Seriennummer 00331701
ELM3604-0002 Klemme mit eindeutiger ID-Nummer (QR Code) 100001051 und Seriennummer/ Chargennummer 44160201
Weiterführende Informationen
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Anhang [image] Versionsidentifikation von EtherCAT-Geräten [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
Der Beckhoff Identification Code (BIC) wird vermehrt auf Beckhoff-Produkten zur eindeutigen Identitätsbestimmung des Produkts aufgebracht. Der BIC ist als Data Matrix Code (DMC, Code-Schema ECC200) dargestellt, der Inhalt orientiert sich am ANSI-Standard MH10.8.2-2016.
Beckhoff Identification Code
BIC als Data Matrix Code (DMC, Code-Schema ECC200)
Die Einführung des BIC erfolgt schrittweise über alle Produktgruppen hinweg.
Er ist je nach Produkt an folgenden Stellen zu finden:
▪
auf der Verpackungseinheit
▪
direkt auf dem Produkt (bei ausreichendem Platz)
▪
auf Verpackungseinheit und Produkt
Der BIC ist maschinenlesbar und enthält Informationen, die auch kundenseitig für Handling und Produktverwaltung genutzt werden können.
Jede Information ist anhand des so genannten Datenidentifikators (ANSI MH10.8.2-2016) eindeutig identifizierbar. Dem Datenidentifikator folgt eine Zeichenkette. Beide zusammen haben eine maximale Länge gemäß nachstehender Tabelle. Sind die Informationen kürzer, werden sie um Leerzeichen ergänzt. Die Daten unter den Positionen 1 bis 4 sind immer vorhanden.
Folgende Informationen sind enthalten:
Pos-Nr. | Art der Information | Erklärung | Datenidentifikator | Anzahl Stellen inkl. Datenidentifikator | Beispiel
1 | Beckhoff-Artikelnummer | Beckhoff - Artikelnummer | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Eindeutige Seriennummer, Hinweis s. u. | S | 12 | SBTNk4p562d7
3 | Artikelbezeichnung | Beckhoff Artikelbezeichnung, z. B. EL1008 | 1K | 32 | 1KEL1809
4 | Menge | Menge in Verpackungseinheit, z. B. 1, 10… | Q | 6 | Q1
5 | Chargennummer | Optional: Produktionsjahr und -woche | 2P | 14 | 2P401503180016
6 | ID-/Seriennummer | Optional: vorheriges Seriennummer-System, z. B. bei Safety-Produkten oder kalibrierten Klemmen | 51S | 12 | 51S678294104
7 | Variante | Optional: Produktvarianten-Nummer auf Basis von Standardprodukten | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Weitere Informationsarten und Datenidentifikatoren werden von Beckhoff verwendet und dienen internen Prozessen.
Aufbau des BIC
Beispiel einer zusammengesetzten Information aus den Positionen 1 bis 4 und 6.
Die Datenidentifikatoren sind zur besseren Darstellung jeweils rot markiert:
BTN
Ein wichtiger Bestandteil des BICs ist die Beckhoff Traceability Number (BTN, Pos.-Nr. 2). Die BTN ist eine eindeutige, aus acht Zeichen bestehende Seriennummer, die langfristig alle anderen Seriennummern-Systeme bei Beckhoff ersetzen wird (z. B. Chargenbezeichungen auf IO-Komponenten, bisheriger Seriennummernkreis für Safety-Produkte, etc.). Die BTN wird ebenfalls schrittweise eingeführt, somit kann es vorkommen, dass die BTN noch nicht im BIC codiert ist.
Hinweis
Diese Information wurde sorgfältig erstellt. Das beschriebene Verfahren wird jedoch ständig weiterentwickelt. Wir behalten uns das Recht vor, Verfahren und Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern. Aus den Angaben, Abbildungen und Beschreibungen in dieser Information können keine Ansprüche auf Änderung geltend gemacht werden.


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.