ELM3xxx - Short documentation measurement modules
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status
•
Version identification of EtherCAT devices


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
2.4
▪
Description and specifications for ELM3542 and ELM3544 added (provisionally)
▪
Chapter "Common technical data", subsection "General information on measuring accuracy/measurement uncertainty" updated
▪
Addenda of technical data for ELM36xx and ELM35xx and additionally within chapter "Firmware Update"
▪
Adaption of each specification of technical data for ELM30xx to ELM37xx carried out
2.3
▪
First publication


Version identification of EtherCAT devices

Foreword [image] Version identification of EtherCAT devices
Version identification of EtherCAT devices
Designation
A Beckhoff EtherCAT device has a 14-digit designation, made up of
▪
family key
▪
type
▪
version
▪
revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
Notes
▪
The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
▪
EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
▪
The order identifier is made up of
- family key (EL, EP, CU, ES, KL, CX, etc.)
- type (3314)
- version (-0000)
▪
The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
▪
The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Identification number
Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:
Production lot/batch number/serial number/date code/D number
The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02
Exceptions can occur in the IP67 area, where the following syntax can be used (see respective device documentation):
Syntax: D ww yy x y z u
D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB
Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1
Unique serial number/ID, ID number
In addition, in some series each individual module has its own unique serial number.
See also the further documentation in the area
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Terminals with factory calibration certificate and other measuring terminals
Examples of markings
EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
CU2016 switch with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
EP1258-00001 IP67 EtherCAT Box with batch number/ date code 22090101 and unique serial number 158102
EP1908-0002 IP67 EtherCAT Safety Box with batch number/ date code 071201FF and unique serial number 00346070
EL2904 IP20 safety terminal with batch number/ date code 50110302 and unique serial number 00331701
ELM3604-0002 terminal with unique ID number (QR code) 100001051 and serial/ batch number 44160201
Additional information
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Foreword [image] Version identification of EtherCAT devices [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Product overview

Product overview
Product overview
Additional information
•
Description
•
Common technical data
•
Process data interpretation
•
General information on measuring accuracy/measurement uncertainty
•
ELM300x
•
ELM310x
•
ELM314x
•
ELM350x
•
ELM354x
•
ELM360x
•
ELM370x
•
Start


Description

Product overview [image] Description
Description
The analog input terminals of the ELM3xxx series can be used for measuring electrical parameters in several measuring ranges. They forward the measured values to the controller via the EtherCAT fieldbus.
The measuring ranges that can be covered include:
▪
voltage bipolar ±20 mV ... ±30 V, unipolar 0..10 V, 0..5 V
▪
current in the ranges ±20 mA , 4..20 mA, 0..20 mA, fault indication based on NAMUR NE43
▪
Resistor bridge, strain gauge (SG): ¼ bridge (quarter bridge) 350 Ω + 120 Ω, ½ bridge (half bridge) and 1/1 bridge (full bridge) in 2 to 6-wire connection
▪
electrical resistance R: 0...5 kΩ in 2 to 4-wire connection
▪
as a result, also temperature with RTD conversion in the corresponding resistance range (PT100, PT1000, etc.)
▪
Potentiometer from 1 kΩ
▪
Vibration sensors conforming to IEPE standard
▪
Temperature measurement with thermocouples (TC), including integrated cold junction measurement
▪
LVDT/carrier frequency on request
The measurement modules are currently divided into 3 series
▪
ELM3x0x – the basic series (refer to the module specification for the specific properties)
–
This is the universal device class for dynamic (fast) applications
–
Max. sampling rates 10,000 ... 50,000 Sps
–
Simultaneous sampling of the channels in the module
–
In general, basic accuracy of 100 ppmFSV @ 23 °C
▪
ELM3x4x - the economy series (refer to the module specification for the specific properties)
–
This is the cost-effective device class for multichannel applications and slowly changing signals
–
Max. sampling rates up to 1,000 Sps
–
Multiplex sampling of the channels in the module (in succession)
–
In general, basic accuracy of 100 ppmFSV @ 10..40 °C
–
simple supply through power contacts and connection for 24 V sensor supply
▪
The system components EKM1101, ELM9410
–
The EKM1101 EtherCAT coupler and the ELM9410 power feed terminal are comparable to the standard components EK1101 or EL9410 respectively in terms of operation, but they additionally offer
–
extensive real-time diagnostics: incoming/outgoing voltages and currents, temperature, vibrations, etc.
–
Electrical isolation of E-bus and power contact supply for trouble-free measurement operation
–
They can be used as supplements to the ELM3xxx modules if their properties are of advantage, but there is no obligation to do so. ELM3xxx modules can also be used with the standard couplers and EL9410. Accordingly, EKM1101/ELM9410 can also be used on standard EL/ES terminals.
–
See documentation for the system components
The name key for the ELM3xxx modules is as follows
The devices have several technical features that facilitate the measurement operation. Availability depends on the device and series; please refer to the specific documentation.
▪
The channels of a module are fully independent and can be parameterized separately.
▪
Various pluggable connection levels are offered ex factory; currently BNC, PushIn and LEMO.
▪
An analog channel can measure beyond the nominal range specified above. This simplifies commissioning and troubleshooting. The resulting technical measuring range is approx. 107% of the nominal range. The "extended range" property can be disabled, in order to make the behavior compatible with the EL30/31/36xx "legacy range".
▪
The ELM3xxx devices consistently operate with 24 bit resolution
▪
Each channel operates with EtherCAT Distributed Clocks. Each measured value therefore has a specific timestamp with ns resolution.
▪
There are terminals with a singular function, e.g. only voltage measurement, but also multi-function modules, which support several or all of the measuring ranges listed above.
▪
Even the singular types offer high measuring range flexibility, for example the ELM35xx for strain gauges/weighing applications. The integrated supply and the switchable auxiliary resistors enable direct connection of a resistor bridge (strain gauge SG) or load cell with 2-/3-/4-/6-wire connection technology, a fixed resistor, a PTC or a potentiometer.
▪
The terminals/channels operate with a fixed sampling rate; currently 1,000 ... 50,000 Sps (samples per second) depending on the model. If a lower rate is required in the application, each channel can decimate independently.
▪
Each channel has two configurable numeric software filters up to FIR 39th order (40 taps) or IIR 6th order. Both filters can be set based on an integrated list (a number of low-pass, high-pass, mean value filters) or a freely selectable coefficient table.
▪
Non-linear characteristic sensor curves can be corrected flexibly through an integrated sampling points table. Simple mathematical operations are also possible.
▪
Sensor commissioning is facilitated by the AutoScale function at two measuring points.
▪
Each terminal has a unique ID number, which is printed and electronically readable.
▪
The optionally available factory working standard calibration certificate for the ELM3xxx-0020 can be assigned via this ID number. Re-calibration can be carried out by Beckhoff or external calibration service providers. An ISO17025 or DAkkS calibration is also possible on request.
The individual terminals are presented below.


Common technical data

Product overview [image] Common technical data
Common technical data
Technical data | ELM3xxx
Distributed Clocks | Yes, with oversampling (n = 1…100, accuracy << 1 µs)
Special features | Extended range 107 %, freely configurable numeric filters, TrueRMS, integrator/differentiator, non-linear scaling, PeakHold
Functional diagnosis | Yes
Electrical isolation bus/channel | 500 V DC (1 min. typical test voltage)
Electrical isolation channel /channel | -
Current consumption power contacts | -
Configuration | No address or configuration set up
Note on wire length | Signal cable lengths to the sensor / encoder over 3 m must be shielded, the shield design must be in line with the state of the art and be effective. For larger cable lengths > 30 m, a suitable surge protection should be provided if appropriate interference could affect the signal cable.
Note on mounting | Connector not in scope of supply, see section Notes to connection technology
Dimensions (W x H x D) | See section Housing
Mounting | on 35 mm rail conforms to EN 60715
Permissible operating altitude range | 0 to 2000 m (derating at higher altitudes on request)
Permissible relative humidity | 95 %, no condensation
Vibration/shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation position | variable
Approval | CE


Process data interpretation

Product overview [image] Process data interpretation
Process data interpretation
With regard to the output of the cyclic process data, the whole measuring range presents itself as follows:
Basic range of a process data value
The channel for this terminal features an option to set the measuring range either to the conventional Beckhoff type: "nominal full-scale value = PDO end value: Legacy Range" or the new method "technical full-scale value = PDO end value: Extended Range".
▪
Extended Range mode
–
technical full scale value = PDO end value 0x007FFFFF.
–
For information purposes, the channel can measure up to approx. 107% beyond the nominal range, although accuracy specifications etc. are then no longer valid.
–
Outside the nominal measuring range, the Overrange or Underrange bit is set.
–
For further diagnosis, the error bit and the error LED are set, if configurable limits are exceeded. By default the limits are set to the technical measuring range, although they can be narrowed by the customer.
Example: In 4…20 mA measuring mode, the limit is set to 0 mA, although it can be customized in the CoE, e.g. to 3.6 mA, in order to enable earlier detection of sensor faults.
–
The Extended Range mode is the default setting for the terminal.
–
The mode is defined through the non-periodic rational LSB step size and an integer end value. The step size can therefore be used in a PLC program without rounding error.
▪
Legacy Range mode
–
Nominal full scale value = PDO end value.
–
Compatible with existing interface from EL30xx/EL31xx/EL36xx.
–
Overrange/Underrange, Error bit and Error LED are set simultaneously if the nominal/technical measuring range is exceeded.
–
Can be optionally activated in the terminal.
–
The mode is defined by an integer end value; not a whole number of the LSB step is accepted for it.


General information on measuring accuracy/measurement uncertainty

Product overview [image] General information on measuring accuracy/measurement uncertainty
General information on measuring accuracy/measurement uncertainty
For basic information regarding the explanatory notes below, please refer to chapter "Notes on analog measured values", particularly full scale value.
This guidance could be worth to read for saving effort, time and perhaps money, too.
Basic information on measurement technology:
Using measuring devices an attempt is made with a greater or lesser degree of expenditure to determine the "true value" of a measured variable, for example the ambient temperature. For various practical reasons this is not conclusively possible. Depending on the expenditure, the measurement/measured value is subject to a random measuring error that cannot be eliminated. With its practically determined specification data, Beckhoff provides an approach with which the residual measurement uncertainty can theoretically be calculated in the individual case. The following paragraphs serve this purpose.
General notes
No special maintenance required, although an annual inspection is recommended for the terminal.
If a factory calibration certificate is available for the device, a recalibration interval recommendation of 1 year applies, unless otherwise specified.
Notes regarding the specification data:
▪
Measurement specifications are usually specified as "% of nominal full scale value" = % full scale value (%FSV), unless otherwise specified
▪
In conjunction with each individual value "typical" means that on average this parameter has the specified value. For individual terminals the parameter may deviate from the typical value. Once example is the current consumption.
▪
In the context of a limit (parameter is typically max./min. X) or with two limits (parameter is typically between X and Y) "typical" means that this parameter tends to be between the limits for individual terminals. Deviations are possible, however; see confidence level. Once example is noise. Usually no measurements are made, in order to be able to make statements about standard deviations or result frequencies. A typical value is usually indicated as such after the unit.
▪
The confidence level is 95%, unless otherwise specified.
▪
When the system is operated in an environment that is subject to EMC noise, the following items are required for compliance with the specification
–
an EL9070 shield terminal positioned to the left of the terminal
–
twisted and shielded signal line, at least earthed on one side
▪
If not other specified, measurement errors etc. will be stated in electrical DC operation (no use of AC values). Measurement of an AC value influences the frequency slope of the analog input and therefore the measurement itself.
Note on the temperature
The temperature within/outside the device affects the measurement through the electronics. A measuring setup is generally characterized by a temperature dependence, which is specified in the form of a temperature drift, for example. The specifications are based on a constant ambient temperature. Variable conditions (e.g. heating of the control cabinet, sudden temperature drop due to opening of the control cabinet in cold weather) resulting in a temperature change may alter the measured values through dynamic and heterogeneous temperature distribution. To rectify such effects, the temperature inside the device can be read online from the CoE and used for compensation. Some devices indicate electrically that they have thermally stabilized as well; see diagnosis features.
The specification data apply:
▪
after a warm-up time under operating voltage and in fieldbus mode of least 60 minutes at constant ambient temperature
–
Practical note: after power-on the device already warms up exponentially such that the major part of the warming depending on the module within a short time of approximately 10 to 15 minutes is passing through and the measuring characteristics moving within the specification limits.
–
For clarification: typical trend of an inner temperature (no significance for a particular module):
–
Some devices displays by the CoE object 0xF900:02 that they are thermally stabilized and ∆T within the device is very small. This can be evaluated by application.
▪
in horizontal installation position, taking account of the minimum distances
▪
at free convection (no forced ventilation)
▪
provided the specification data are adhered to
Under different conditions, a user-specific compensation is required.
Notes on calculation with the specification data:
The independent specification data can be divided into two groups:
▪
the data on offset/gain deviation, non-linearity, repeatability whose effect on the measurement cannot be influenced by the user. These are summarized by Beckhoff according to the calculation below to the so-called "basic accuracy at 23°C".
▪
the specification data whose effect on the measurement can be influenced by the user, namely
–
the noise: Effect influenced by sample rate, filtering
–
the temperature: Effect influenced by air conditioning, shielding, control cabinet cooling, ...
The independent individual accuracy data are to be added quadratically according to the formula below in order to determine a total measurement accuracy - if there are no special conditions that that contradict a uniform distribution and thus the quadratic approach (RSS - root of the sum of the squares).
For measurement ranges where the temperature coefficient is given as TcTerminal only:
EOffset | : | Offset specification (at 23°C)
EGain | : | Gain/scale specification (at 23°C)
ENoise, PtP | : | Noise specification as a peak-to-peak value (applies to all temperatures)
MV | : | Measured value
FSV | : | Full scale value
ELin | : | Non-linearity error over the entire measuring range (applies to all temperatures)
ERep | : | Repeatability (applies to all temperatures)
TcOffset | : | Temperature coefficient offset
TcGain | : | Temperature coefficient gain
TcTerminal | : | Temperature coefficient of the terminal
ΔT | : | Difference between the ambient temperature and the specified basic temperature (23°C unless specified otherwise)
EAge | : | Error coefficient of ageing
NYears | : | Number of years
ETotal | : | Theoretical calculated total error
Let's say, for example, we have the following values by a determined measurement value of 8.13 V and 10 V measurement mode (FSV = 10 V) and NYears = 0:
▪
Gain specification: EGain = 60 ppmFSV
▪
Offset specification: EOffset = 70 ppmFSV
▪
Non-linearity: ELin = 25 ppmFSV
▪
Repeatability: ERep = 20 ppmFSV
▪
Noise (without filtering): ENoise, PtP = 100 ppmpeak-to-peak
▪
Temperature coefficients:
–
TcGain = 8 ppm/K
–
TcOffset = 5 ppmFSV/K
Then the theoretical possible total measurement accuracy at ΔT = 12K to the basic temperature can be calculated as follows:
or = ±0.0143.. %FSV
Remarks:
ppm ≙ 10-6
% ≙ 10-2
In general, you can calculate as follows
▪
If only the application at 23°C is to be considered:
Total measurement accuracy = basic accuracy & noise according to above formula
▪
If the application at 23°C is to be considered with slow measurement (=average value formation/filtering):
Total measurement accuracy = basic accuracy
▪
If the general use is to be considered with known temperature range and incl. noise:
Total measurement accuracy = basic accuracy & noise & temperature values according to above formula
Beckhoff usually gives the specification data symmetrically in [±%], i.e. for example ±0.01% or ±100 ppm. Accordingly, therefore, the unsigned total window would be double the value. A peak-to-peak specification is also a total window specification; the symmetrical value is thus half of it. In the quadratic calculation below, the symmetrical "one-sided" value is to be inserted without a sign. Noise is usually specified in peak-to-peak form, therefore the equation for the noise value already contains the divisor /2.
Example:
▪
symmetrical specification: ±0.01% (equivalent to ±100 ppm) e.g. in case of offset specification
▪
Total window: 0.02% (200 ppm)
▪
To be used in the equation: 0.01% (100 ppm)
The total measurement accuracy calculated in this way is to be regarded again as a symmetrical maximum value and thus to be provided with ± and ≤ for further use.
Example:
▪
ETotal = 100 ppm
▪
For further use: "≤ ± 100 ppm"
To put it in words: "The offset of the individual accuracy specifications under the given conditions produced a window of 200 ppm that lies symmetrically around the individual measured value. The measured value specification x thus has an uncertainty of x ±100 ppm; the true value thus lies 95% in this range."
The noise component can be omitted
The noise component FNoise can be omitted from the above equation (= 0) if the average value of a set of samples is considered instead of a single sample. The averaging can take place in the PLC, or it can be done by a filter in the analog channel. The output value of a moving average of many samples has an almost eliminated noise component. The achievable accuracy increases if the noise component is decreasing.
Note
Error coefficient of ageing
If the specification value for the aging of Beckhoff is not (yet) specified, it must be assumed to be 0 when considering measurement uncertainty, as in the above example, even if in reality it can be assumed over the operating time that the measurement uncertainty of the device under consideration changes, colloquially the measured value "drifts".
Experience has shown that the order of magnitude for an annual change (10,000 h) can be assumed to be the basic accuracy of the instrument under consideration if it is operated according to specification. This is an informative statement, without specification character, exceptions are possible. In general, the change in ageing will be very application-specific. A general ageing specification from Beckhoff will therefore be a guideline rather than a guaranteed upper limit when published.
If the measurement uncertainty consideration in the application shows that aging over the desired operating time can endanger the measurement success, Beckhoff recommends a cyclical check (recalibration) of the measurement channel, both with regard to sensor, cabling and Beckhoff measurement terminal. In this way, potential long-term changes in the measurement chain can be detected early and, if necessary, even the trigger (e.g. overtemperature) can be eliminated. See also the further notes in the chapter "Metrology and EtherCAT terminals - basic concepts".
Basic accuracy and averaging
✓
The basic accuracy will be designated separate for simplified usage.
1.
The basic accuracy includes the offset/gain error, non-linearity and repeatability, but not the temperature coefficient nor the noise and is thereby a subset of the above given complete calculation. It is possible to increase the measurement accuracy beyond the basic accuracy by means of the offset correction.
2.
"Averaging" means that the value was obtained from the arithmetic average of usually 100,000 values for the elimination of the noise. Besides, the terminals internal averaging process need not be used absolutely. If resources available, accumulation of average can be executed within the PLC also.
Measurement accuracy of the measurement value (of reading)
In several cases the „Accuracy related to the up-to-date measurement value” i.e. „Accuracy of value” is requested instead of the „Accuracy related to the full scale value (FSV)”.
This value could easily be calculated from the data given by the specification, as the total accuracy consists of a measurement value and full scale value depending part and an exclusive full scale value depending part:


ELM300x

Product overview [image] ELM300x
ELM300x
Additional information
•
ELM300x - Introduction
•
ELM300x - Technical data


ELM300x - Introduction

Product overview [image] ELM300x [image] ELM300x - Introduction
ELM300x - Introduction
ELM3002-0000, ELM3004-0000
2 and 4 channel analog input terminal ±30 V…±20 mV, 24 bit, 10/ 20 ksps
The ELM300x EtherCAT Terminals are designed for flexible voltage measurement from 20 mV to 30 V in eleven measuring ranges. The measuring range is selected in the CoE, as are the other setting options such as the filter parameters. Irrespective of the signal configuration, all ELM modules have the same technological properties. The ELM300x modules for voltage measurement offer a maximum sampling rate of 10,000 or 20,000 samples per second. The 2-pin plug (push-in) can be removed for maintenance purposes without releasing the individual wires.
There are variants with factory calibration certificate and a recalibration service for the ELM series in preparation.
Quick-Links
• EtherCAT basics
• Mounting and wiring
• Process data overview
• Connection view
• Object description and parameterization


ELM300x - Technical data

Product overview [image] ELM300x [image] ELM300x - Technical data
ELM300x - Technical data
Technical data | ELM3002-000x | ELM3004-000x
Analog inputs | 2 channel (differential) | 4 channel (differential)
Time relation between channels to each other | Simultaneous conversion of all channels in the terminal, synchronous conversion between terminals, if DistributedClocks will be used
ADC conversion method | deltaSigma ΔΣ with internal sample rate
 | 5.12 MSps | 8 MSps
Limit frequency input filter hardware (see information in section ELM Features/ Firmware filter concept) | Before AD converter: hardware low pass -3dB @ 30 kHz type butterworth 3th order Within ADC after conversion:
 | low pass -3dB @ 5.3 kHz, ramp-up time 150 µs | low pass -3dB @ 2.6 kHz, ramp-up time 300 µs
 | type sinc3/average filter The ramp-up time/ settling time/ delay caused by the filtering will be considered within the DistributedClocks-Timestamp.
Resolution | 24 Bit (including sign)
Connection technology | 2 wire
Connection type | push-in cageclamp, service plug, 2-pin
Sampling rate (per channel, simultaneous) | 50 µs/20 kSps | 100 µs/10 kSps
 | free down sampling by Firmware via decimation factor
Oversampling | 1…100 selectable
Supported EtherCAT cycle time (depending on the operation mode) | DistributedClocks: min. 100 µs, max. 10 ms FrameTriggered/Synchron: min. 200 µs, max. 100 ms FreeRun: not yet supported
Connection diagnosis | Wire break/short cut
Surge voltage protection of the inputs related to ‑Uv (internal ground) | +IN1, -IN1: at approx. 12 ±0.5 V (within 30 V-Mode at approx. 37 ±1 V)
Current consumption via E-bus | typ. 330 mA | typ. 470 mA
Thermal power dissipation | typ. 3 W
Dielectric strength - destruction limit | max. permitted short-term/continuous voltage between contact points ±I1, ±I2, +Uv and –Uv: non-supplied ±40 V, supplied ±36 V Note: -Uv corresponds to internal AGND
Recommended operation voltage range to compliance with specification | max. permitted voltage during specified normal operation between ±I1 and ±I2: typ. ±10 V against –Uv Note: -Uv corresponds to internal AGND
Electrical isolation channel/channel *) | no
Electrical isolation channel/Ebus *) | yes, 500V/1min.typ. test
Electrical isolation channel/SGND *) | yes, 500V/1min.typ. test
Weight | approx. 350 g
Permissible ambient temperature range during operation | -25…+60 °C
Permissible ambient temperature range during storage | -40…+85 °C
*) see notes to potential groups in chapter “Mounting and wiring/ Power supply, potential groups”
Overview measurement ranges (ELM300x):
Measurement | Connection technology | FSV | Mode | Maximum value/ value range
Voltage | 2 wire | ±30 V | Extended | ±32.212.. V
 |  |  | Legacy | ±30 V
 |  | ±10 V | Extended | ±10.737.. V
 |  |  | Legacy | ±10 V
 |  | ±5 V | Extended | ±5.368.. V
 |  |  | Legacy | ±5 V
 |  | ±2.5 V | Extended | ±2.684.. V
 |  |  | Legacy | ±2.5 V
 |  | ±1.25 V | Extended | ±1.490.. V
 |  |  | Legacy | ±1.25 V
 |  | ±640 mV | Extended | ±687.2.. mV
 |  |  | Legacy | ±640 mV
 |  | ±320 mV | Extended | ±343.6.. mV
 |  |  | Legacy | ±320 mV
 |  | ±160 mV | Extended | ±171.8.. mV
 |  |  | Legacy | ±160 mV
 |  | ±80 mV | Extended | ±85.9.. mV
 |  |  | Legacy | ±80 mV
 |  | ±40 mV | Extended | ±42.95.. mV
 |  |  | Legacy | ±40 mV
 |  | ±20 mV | Extended | ±21.474.. mV
 |  |  | Legacy | ±20 mV
Voltage | 2 wire | +10 V | Extended | 0…10.737.. V
 |  |  | Legacy | 0…10 V
 |  | +5 V | Extended | 0…5.368.. V
 |  |  | Legacy | 0…5 V
Overview measurement ranges, Bipolar
Overview measurement ranges, Unipolar
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.
Additional information
•
Measurement ±30 V
•
Measurement ±10 V
•
Measurement ±5 V
•
Measurement ±2.5 V
•
Measurement ±1.25 V
•
Measurement ±640 mV
•
Measurement ±320 mV
•
Measurement ±160 mV
•
Measurement ±80 mV
•
Measurement ±40 mV
•
Measurement ±20 mV
•
Measurement 0…5 V
•
Measurement 0…10 V


Measurement ±30 V

Product overview [image] ELM300x [image] ELM300x - Technical data [image] Measurement ±30 V
Measurement ±30 V
Measurement mode | ±30 V
Internal resistance | >500 kΩ differential
Impedance | Value to follow
Measuring range, nominal | -30…+30 V
Measuring range, end value (full scale value) | 30 V
Measuring range, technically usable | -32.212…+32.212 V
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 3.84 µV | 983.04 µV
PDO LSB (Legacy Range) | 3.576.. µV | 915.55.. µV
Preliminary specifications:
Measurement mode |  | ±30 V
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 65 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 65 ppm
Non-linearity over the whole measuring range | ELin | < 45 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 7.64
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.5 ppmFSV |  | < 20 [digits]
 | Max. SNR | > 112.0 dB
Temperature coefficient | TcGain | < 11 ppm/K typ.
 | TcOffset | < 10 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >68 dB typ. | 50 Hz: >68 dB typ. |  | 1 kHz: >52 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >68 dB typ. | 50 Hz: >100 dB typ. |  | 1 kHz: >100 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation ±30 V measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement ±10 V

Product overview [image] ELM300x [image] ELM300x - Technical data [image] Measurement ±10 V
Measurement ±10 V
Measurement mode | ±10 V
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -10…+10 V
Measuring range, end value (full scale value) | 10 V
Measuring range, technically usable | -10.737…+10.737 V
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 1.28 µV | 327.68 µV
PDO LSB (Legacy Range) | 1.192.. µV | 305.18.. µV
Preliminary specifications:
Measurement mode |  | ±10 V
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 60 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 2.55
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation ±10 V measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement ±5 V

Product overview [image] ELM300x [image] ELM300x - Technical data [image] Measurement ±5 V
Measurement ±5 V
Measurement mode | ±5 V
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -5…+5 V
Measuring range, end value (full scale value) | 5 V
Measuring range, technically usable | -5.368…+5.368 V
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 640 nV | 163.84 µV
PDO LSB (Legacy Range) | 596.. nV | 152.59.. µV
Preliminary specifications:
Measurement mode |  | ±5 V
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 1.27
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation ±5 V measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement ±2.5 V

Product overview [image] ELM300x [image] ELM300x - Technical data [image] Measurement ±2.5 V
Measurement ±2.5 V
Measurement mode | ±2.5 V
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -2.5…+2.5 V
Measuring range, end value (full scale value) | 2.5 V
Measuring range, technically usable | -2.684…+2.684 V
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 320 nV | 81.92 µV
PDO LSB (Legacy Range) | 298.. nV | 76.29.. µV
Preliminary specifications:
Measurement mode |  | ±2.5 V
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 90 ppmFSV |  | < 703 [digits]
 | ENoise, RMS | < 17 ppmFSV |  | < 133 [digits]
 | Max. SNR | > 95.4 dB
 | Noisedensity@1kHz | < 0.60
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 9 ppmFSV |  | < 70 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation ±2.5 V measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement ±1.25 V

Product overview [image] ELM300x [image] ELM300x - Technical data [image] Measurement ±1.25 V
Measurement ±1.25 V
Measurement mode | ±1.25 V
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -1.25…+1.25 V
Measuring range, end value (full scale value) | 1.25 V
Measuring range, technically usable | -1.490…+1.490 V
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 160 nV | 40.96 µV
PDO LSB (Legacy Range) | 149.. nV | 38.14.. µV
Preliminary specifications:
Measurement mode |  | ±1.25 V
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 90 ppmFSV |  | < 703 [digits]
 | ENoise, RMS | < 17 ppmFSV |  | < 133 [digits]
 | Max. SNR | > 95.4 dB
 | Noisedensity@1kHz | < 0.30
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 9 ppmFSV |  | < 70 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation ±1.25 V measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement ±640 mV

Product overview [image] ELM300x [image] ELM300x - Technical data [image] Measurement ±640 mV
Measurement ±640 mV
Measurement mode | ±640 mV
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -640…+640 mV
Measuring range, end value (full scale value) | 640 mV
Measuring range, technically usable | -687.2…+687.2 mV
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 81.92 nV | 20.97152 µV
PDO LSB (Legacy Range) | 76.29.. nV | 19.53.. µV
Preliminary specifications:
Measurement mode |  | ±640 mV
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 90 ppmFSV |  | < 703 [digits]
 | ENoise, RMS | < 17 ppmFSV |  | < 133 [digits]
 | Max. SNR | > 95.4 dB
 | Noisedensity@1kHz | < 0.15
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 9 ppmFSV |  | < 70 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation ±640 mV measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement ±320 mV

Product overview [image] ELM300x [image] ELM300x - Technical data [image] Measurement ±320 mV
Measurement ±320 mV
Measurement mode | ±320 mV
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -320…+320 mV
Measuring range, end value (full scale value) | 320 mV
Measuring range, technically usable | -343.6…+343.6 mV
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 40.96 nV | 10.48576 µV
PDO LSB (Legacy Range) | 38.14.. nV | 9.765.. µV
Preliminary specifications:
Measurement mode |  | ±320 mV
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 90 ppmFSV |  | < 703 [digits]
 | ENoise, RMS | < 17 ppmFSV |  | < 133 [digits]
 | Max. SNR | > 95.4 dB
 | Noisedensity@1kHz | 76.93
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 9 ppmFSV |  | < 70 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation ±320 mV measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement ±160 mV

Product overview [image] ELM300x [image] ELM300x - Technical data [image] Measurement ±160 mV
Measurement ±160 mV
Measurement mode | ±160 mV
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -160…+160 mV
Measuring range, end value (full scale value) | 160 mV
Measuring range, technically usable | -171.8…+171.8 mV
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 20.48 nV | 5.24288 µV
PDO LSB (Legacy Range) | 19.07.. nV | 4.882.. µV
Preliminary specifications:
Measurement mode |  | ±160 mV
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 120 ppmFSV |  | < 938 [digits]
 | ENoise, RMS | < 22 ppmFSV |  | < 172 [digits]
 | Max. SNR | > 93.2 dB
 | Noisedensity@1kHz | < 49.78
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 13 ppmFSV |  | < 102 [digits]
 | ENoise, RMS | < 2.5 ppmFSV |  | < 20 [digits]
 | Max. SNR | > 112.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation ±160 mV measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement ±80 mV

Product overview [image] ELM300x [image] ELM300x - Technical data [image] Measurement ±80 mV
Measurement ±80 mV
Measurement mode | ±80 mV
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -80…+80 mV
Measuring range, end value (full scale value) | 80 mV
Measuring range, technically usable | -85.9…+85.9 mV
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 10.24 nV | 2.62144 µV
PDO LSB (Legacy Range) | 9.536.. nV | 2.441.. µV
Preliminary specifications:
Measurement mode |  | ±80 mV
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 160 ppmFSV |  | < 1250 [digits]
 | ENoise, RMS | < 37 ppmFSV |  | < 289 [digits]
 | Max. SNR | > 88.6 dB
 | Noisedensity@1kHz | < 41.86
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 18 ppmFSV |  | < 141 [digits]
 | ENoise, RMS | < 3.5 ppmFSV |  | < 27 [digits]
 | Max. SNR | > 109.1 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation ±80 mV measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement ±40 mV

Product overview [image] ELM300x [image] ELM300x - Technical data [image] Measurement ±40 mV
Measurement ±40 mV
Measurement mode | ±40 mV
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -40…+40 mV
Measuring range, end value (full scale value) | 40 mV
Measuring range, technically usable | -42.95…+42.95 mV
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 5.12 nV | 1.31072 µV
PDO LSB (Legacy Range) | 4.768.. nV | 1.220.. µV
Preliminary specifications:
Measurement mode |  | ±40 mV
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.02% = 200 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 175 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 65 ppm
Non-linearity over the whole measuring range | ELin | < 45 ppmFSV
Repeatability | ERep | < 30 ppmFSV
Noise (without filtering) | ENoise, PtP | < 375 ppmFSV |  | < 2930 [digits]
 | ENoise, RMS | < 75 ppmFSV |  | < 586 [digits]
 | Max. SNR | > 82.5 dB
 | Noisedensity@1kHz | < 42.43
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 40 ppmFSV |  | < 313 [digits]
 | ENoise, RMS | < 5.5 ppmFSV |  | < 43 [digits]
 | Max. SNR | > 105.2 dB
Temperature coefficient | TcGain | 8 ppm/K typ.
 | TcOffset | 6 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | Value to follow
Representation ±40 mV measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement ±20 mV

Product overview [image] ELM300x [image] ELM300x - Technical data [image] Measurement ±20 mV
Measurement ±20 mV
Measurement mode | ±20 mV
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -20…+20 mV
Measuring range, end value (full scale value) | 20 mV
Measuring range, technically usable | -21.474…+21.474 mV
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 2.56 nV | 655.36 nV
PDO LSB (Legacy Range) | 2.384.. nV | 610.37.. nV
Preliminary specifications:
Measurement mode |  | ±20 mV
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.03% = 300 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 260 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 100 ppm
Non-linearity over the whole measuring range | ELin | < 90 ppmFSV
Repeatability | ERep | < 35 ppmFSV
Noise (without filtering) | ENoise, PtP | < 750 ppmFSV |  | < 5859 [digits]
 | ENoise, RMS | < 150 ppmFSV |  | < 1172 [digits]
 | Max. SNR | > 76.5 dB
 | Noisedensity@1kHz | < 42.43
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 75 ppmFSV |  | < 586 [digits]
 | ENoise, RMS | < 11.5 ppmFSV |  | < 90 [digits]
 | Max. SNR | > 98.8 dB
Temperature coefficient | TcGain | < 12 ppm/K typ.
 | TcOffset | < 12 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | Value to follow
Representation ±20 mV measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement 0…5 V

Product overview [image] ELM300x [image] ELM300x - Technical data [image] Measurement 0…5 V
Measurement 0…5 V
Measurement mode | 0…5 V
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | 0…5 V
Measuring range, end value (full scale value) | 5 V
Measuring range, technically usable | 0…5.368 V
PDO resolution | 23 bit (unsigned) | 15 bit (unsigned)
PDO LSB (Extended Range) | 640 nV | 163.84 µV
Preliminary specifications:
Measurement mode |  | 0…5 V
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 1.27
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation 0…5 V measurement range
Note: The channel also works in electrically bipolar mode and records negative values in the unipolar measuring ranges (measurement from 0 V, 0 mA, 4 mA, 0 Ω). This enables the channel to provide a precise diagnosis even with signals < 0. In these measuring ranges the limit value for the "Underrange Error" in Extended Mode is -1% of the full scale value (FSV). The limit value can be set in CoE object 0x80n0:32. This avoids irritating error messages if the channel is not wired (e.g. without sensor) or the electrical signal fluctuates slightly around zero. The process data value of 0x00000000 is not undershot.
If the "UnderrangeError" detection is to be set even less sensitive, the magnitude of the negative limit value in the CoE object referred to above can be set even higher.
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement 0…10 V

Product overview [image] ELM300x [image] ELM300x - Technical data [image] Measurement 0…10 V
Measurement 0…10 V
Measurement mode | 0…10 V
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | 0…10 V
Measuring range, end value (full scale value) | 10 V
Measuring range, technically usable | 0…+10.737 V
PDO resolution | 23 bit (unsigned) | 15 bit (unsigned)
PDO LSB (Extended Range) | 1.28 µV | 327.68 µV
Preliminary specifications:
Measurement mode |  | 0…10 V
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 60 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 2.55
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation 0…10 V measurement range
Note: The channel also works in electrically bipolar mode and records negative values in the unipolar measuring ranges (measurement from 0 V, 0 mA, 4 mA, 0 Ω). This enables the channel to provide a precise diagnosis even with signals < 0. In these measuring ranges the limit value for the "Underrange Error" in Extended Mode is -1% of the full scale value (FSV). The limit value can be set in CoE object 0x80n0:32. This avoids irritating error messages if the channel is not wired (e.g. without sensor) or the electrical signal fluctuates slightly around zero. The process data value of 0x00000000 is not undershot.
If the "UnderrangeError" detection is to be set even less sensitive, the magnitude of the negative limit value in the CoE object referred to above can be set even higher.
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


ELM310x

Product overview [image] ELM310x
ELM310x
Additional information
•
ELM310x - Introduction
•
ELM310x - Technical data


ELM310x - Introduction

Product overview [image] ELM310x [image] ELM310x - Introduction
ELM310x - Introduction
ELM3102-0000, ELM3104-0000
2 and 4 channel analog input terminal -20/0/+4…+20 mA, 24 bit, 10/ 20 ksps
The ELM310x EtherCAT Terminals are designed for flexible current measurement in the range from -20 to +20 mA. They offer selectable measuring ranges of -20/0/4 to ±20 mA as well as current measurement according to NAMUR NE43.
The measuring range is selected in the CoE, as are the other setting options such as the filter parameters. Irrespective of the signal configuration, all ELM modules have the same technological properties. The ELM310x modules for current measurement offer a maximum sampling rate of 10,000 or 20,000 samples per second. The 2-pin plug (push-in) can be removed for maintenance purposes without releasing the individual wires.
There are variants with factory calibration certificate and a recalibration service for the ELM series in preparation.
Quick-Links
• EtherCAT basics
• Mounting and wiring
• Process data overview
• Connection view
• Object description and parameterization


ELM310x - Technical data

Product overview [image] ELM310x [image] ELM310x - Technical data
ELM310x - Technical data
Technical data | ELM3102-000x | ELM3104-000x
Analog inputs | 2 channel (differential) | 4 channel (differential)
Time relation between channels to each other | Simultaneous conversion of all channels in the terminal, synchronous conversion between terminals, if DistributedClocks will be used
ADC conversion method | deltaSigma ΔΣ with internal sample rate
 | 5.12 MSps | 8 MSps
Limit frequency input filter hardware (see information in section ELM Features/ Firmware filter concept) | Before AD converter: hardware low pass -3dB @ 30 kHz type butterworth 3th order Within ADC after conversion:
 | low pass -3dB @ 5.3 kHz, ramp-up time 150 µs | low pass -3dB @ 2.6 kHz, ramp-up time 300 µs
 | type sinc3/average filter The ramp-up time/ settling time/ delay caused by the filtering will be considered within the DistributedClocks-Timestamp.
Resolution | 24 Bit (including sign)
Connection technology | 2 wire
Connection type | push-in cageclamp, service plug, 2-pin
Sampling rate (per channel, simultaneous) | 50 µs/20 kSps | 100 µs/10 kSps
 | free down sampling by Firmware via decimation factor
Oversampling | 1…100 selectable
Supported EtherCAT cycle time (depending on the operation mode) | DistributedClocks: min. 100 µs, max. 10 ms FrameTriggered/Synchron: min. 200 µs, max. 100 ms FreeRun: not supported
Connection diagnosis | Recommended: 4…20 mA measurement range
Surge voltage protection of the inputs related to ‑Uv (internal ground) | +IN1, -IN1: at approx. 12 ±0.5 V
Current consumption via E-bus | typ. 340 mA | typ. 490 mA
Thermal power dissipation | typ. 3 W
Dielectric strength - destruction limit | max. permitted short-term/continuous voltage between contact points ±I1, ±I2, +Uv and –Uv: non-supplied ±40 V, supplied ±36 V Note: -Uv corresponds to internal AGND
Recommended operation voltage range to compliance with specification | max. permitted voltage during specified normal operation between ±I1 and ±I2: typ. ±10 V against –Uv Note: -Uv corresponds to internal AGND
Electrical isolation channel/channel *) | no
Electrical isolation channel/Ebus *) | yes, 500V/1min.typ. test
Electrical isolation channel/SGND *) | yes, 500V/1min.typ. test
Weight | approx. 350 g
Permissible ambient temperature range during operation | -25…+60 °C
Permissible ambient temperature range during storage | -40…+85 °C
*) see notes to potential groups in chapter “Mounting and wiring/ Power supply, potential groups”
Overview measurement ranges (ELM310x):
Measurement | Connection technology | FSV | Mode | Maximum value/ value range
Current | 2 wire | ±20 mA | Extended | ±21.474.. mA
 |  |  | Legacy | ±20 mA
 |  | +20 mA | Extended | 0…21.474.. mA
 |  |  | Legacy | 0…20 mA
 |  | +20 mA | Extended | 0…21.179 mA
 |  |  | Legacy | 4…20 mA
 |  | +20 mA | Extended | 3.6…21 mA
 |  |  | Legacy | 4…20 mA
Overview measurement ranges, Bipolar
Overview measurement ranges, Unipolar
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.
Additional information
•
Measurement ±20 mA
•
Measurement 0…20 mA
•
Measurement 4…20 mA
•
Measurement 3.6…21 mA (NAMUR NE43)


Measurement ±20 mA

Product overview [image] ELM310x [image] ELM310x - Technical data [image] Measurement ±20 mA
Measurement ±20 mA
Measurement mode | ±20 mA
Internal resistance | 150 Ω typ.
Impedance | Tbd.
Measuring range, nominal | -20…+20 mA
Measuring range, end value (full scale value) | 20 mA
Measuring range, technically usable | -21.474…+21.474 mA, overcurrent-protected
Fuse protection | Internal overload limiting, continuous current resistant
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 2.56 nA | 655.36 nA
PDO LSB (Legacy Range) | 2.384.. nA | 610.37.. nA
Common-mode voltage Vcm | max. ±10V related to -Uv (internal ground)
Preliminary specifications:
Measurement mode |  | ±20 mA
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 65 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 50 ppm
Non-linearity over the whole measuring range | ELin | < 40 ppmFSV
Repeatability | ERep | < 40 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 5.09
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 15 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) | DC: < 3 nA/V typ. | 50 Hz: < 5 nA/V typ. | 1 kHz: < 80 nA/V typ.
Common-mode rejection ratio (with 50Hz FIR filtering) | DC: < 3 nA/V typ. | 50 Hz: < 3 nA/V typ. | 1 kHz: < 3 nA/V typ.
Largest short-term deviation during a specified electrical interference test | Value to follow [ppm] typ. (FSV)
Current measurement range ±20 mA
Representation current measurement range ±20 mA
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement 0…20 mA

Product overview [image] ELM310x [image] ELM310x - Technical data [image] Measurement 0…20 mA
Measurement 0…20 mA
Measurement mode | 0...20 mA
Internal resistance | 150 Ω typ.
Impedance | Tbd.
Measuring range, nominal | 0…20 mA
Measuring range, end value (full scale value) | 20 mA
Measuring range, technically usable | 0 …21.474 mA
Fuse protection | Internal overload limiting, continuous current resistant
PDO resolution | 23 bit (unsigned) | 16 bit (including sign)
PDO LSB (Extended Range) | 2.56 nA | 655.36 nA
PDO LSB (Legacy Range) | 2.384.. nA | 610.37.. nA
Common-mode voltage Vcm | max. ±10V related to -Uv (internal ground)
Preliminary specifications:
Measurement mode |  | 0...20 mA
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 65 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 50 ppm
Non-linearity over the whole measuring range | ELin | < 40 ppmFSV
Repeatability | ERep | < 40 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 5.09
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 15 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: < 3 nA/V typ. | 50 Hz: < 5 nA/V typ. |  | 1 kHz: < 80 nA/V typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: < 3 nA/V typ. | 50 Hz: < 3 nA/V typ. |  | 1 kHz: < 3 nA/V typ.
Largest short-term deviation during a specified electrical interference test |  | Value to follow [ppm] typ. (FSV)
Current measurement range 0…20 mA
Representation current measurement range 0…20 mA
Note: The channel also works in electrically bipolar mode and records negative values in the unipolar measuring ranges (measurement from 0 V, 0 mA, 4 mA, 0 Ω). This enables the channel to provide a precise diagnosis even with signals < 0. In these measuring ranges the limit value for the "Underrange Error" in Extended Mode is -1% of the full scale value (FSV). The limit value can be set in CoE object 0x80n0:32. This avoids irritating error messages if the channel is not wired (e.g. without sensor) or the electrical signal fluctuates slightly around zero. The process data value of 0x00000000 is not undershot.
If the "UnderrangeError" detection is to be set even less sensitive, the magnitude of the negative limit value in the CoE object referred to above can be set even higher.
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement 4…20 mA

Product overview [image] ELM310x [image] ELM310x - Technical data [image] Measurement 4…20 mA
Measurement 4…20 mA
Measurement mode | 4…20 mA
Internal resistance | 150 Ω typ.
Impedance | Tbd.
Measuring range, nominal | 4…20 mA
Measuring range, end value (full scale value) | 20 mA
Measuring range, technically usable | 0…21.179 mA
Fuse protection | Internal overload limiting, continuous current resistant
PDO resolution | 24 Bit | 16 Bit
PDO LSB (Extended Range) | 2.048 nA | 524.288 nA
PDO LSB (Legacy Range) | 1.907.. nA | 488.29.. nA
Common-mode voltage Vcm | max. ±10V related to -Uv (internal ground)
Preliminary specifications:
Measurement mode |  | 4…20 mA
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 65 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 50 ppm
Non-linearity over the whole measuring range | ELin | < 40 ppmFSV
Repeatability | ERep | < 40 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 5.09
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 15 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: < 3 nA/V typ. | 50 Hz: < 5 nA/V typ. |  | 1 kHz: < 80 nA/V typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: < 3 nA/V typ. | 50 Hz: < 3 nA/V typ. |  | 1 kHz: < 3 nA/V typ.
Largest short-term deviation during a specified electrical interference test |  | Value to follow [ppmFSV] typ.
Current measurement range 4…20 mA
Representation current measurement range 4…20 mA
Note: The channel also works in electrically bipolar mode and records negative values in the unipolar measuring ranges (measurement from 0 V, 0 mA, 4 mA, 0 Ω). This enables the channel to provide a precise diagnosis even with signals < 0. In these measuring ranges the limit value for the "Underrange Error" in Extended Mode is -1% of the full scale value (FSV). The limit value can be set in CoE object 0x80n0:32. This avoids irritating error messages if the channel is not wired (e.g. without sensor) or the electrical signal fluctuates slightly around zero. The process data value of 0x00000000 is not undershot.
If the "UnderrangeError" detection is to be set even less sensitive, the magnitude of the negative limit value in the CoE object referred to above can be set even higher.
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement 3.6…21 mA (NAMUR NE43)

Product overview [image] ELM310x [image] ELM310x - Technical data [image] Measurement 3.6…21 mA (NAMUR NE43)
Measurement 3.6…21 mA (NAMUR NE43)
Measurement mode | 3.6…21 mA (NAMUR NE43)
Internal resistance | 150 Ω typ.
Impedance | Tbd.
Measuring range, nominal | 4…20 mA
Measuring range, end value (full scale value) | 20 mA
Measuring range, technically usable | 3.6…21 mA
Fuse protection | Internal overload limiting, continuous current resistant
PDO resolution | 24 Bit | 16 Bit
PDO LSB (Extended Range) | 2.048 nA | 524.288 nA
PDO LSB (Legacy Range) | n.a.
Common-mode voltage Vcm | max. ±10V related to -Uv (internal ground)
Preliminary specifications:
Measurement mode |  | 3.6…21 mA (NAMUR NE43)
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 65 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 50 ppm
Non-linearity over the whole measuring range | ELin | < 40 ppmFSV
Repeatability | ERep | < 40 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 5.09
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 15 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: < 3 nA/V typ. | 50 Hz: < 5 nA/V typ. |  | 1 kHz: < 80 nA/V typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: < 3 nA/V typ. | 50 Hz: < 3 nA/V typ. |  | 1 kHz: < 3 nA/V typ.
Largest short-term deviation during a specified electrical interference test |  | Value to follow [ppmFSV] typ.
Current measuring range 3.6…21 mA (NAMUR)
Chart: current measuring range 3.6…21 mA (NAMUR)
Only Extended Range mode for measuring range 4 mA NAMUR
Legacy Range mode is not available for this measurement range. The Extended Range Mode will be set automatically and although a corresponding write access to the CoE Object 0x8000:2E (Scaler) is not declined, the parameter is not changed.


ELM314x

Product overview [image] ELM314x
ELM314x
Additional information
•
ELM314x - Introduction
•
ELM314x - Technical data


ELM314x - Introduction

Product overview [image] ELM314x [image] ELM314x - Introduction
ELM314x - Introduction
ELM314x
2, 4, 6 and 8-channel analog input, ±10…±1.25 V, ±20 mA, 24 bit, 1 ksps
The 2-, 4-, 6- or 8-channel ELM314x EtherCAT Terminals in the Economy line can be set to current or voltage measurement channel by channel, offering sampling rates of up to 1 ksps per channel. Analog signals in the ranges from ±1.25 to ±10 V, 0 to 10 V, ±20 mA or 0/4 to 20 mA can be processed. The settings for U or I measurement mode and the desired measuring ranges can be selected via the control system and TwinCAT in the CoE interface. Here it is also possible to select the extensive diagnostics features for unattended long-term use. The 2-, 4- or 6-pin push-in connectors can be removed for maintenance purposes; they enable a direct supply of connected sensors. The power contacts on the side simplify the potential distribution directly on the DIN rail. The typical EtherCAT features are available: distributed clocks functionality with timestamp and the familiar data features of the basic line such as filtering, true RMS calculation and more. Variants with factory calibration certificate and recalibration service on request are in preparation for the ELM measurement modules.
There are variants with factory calibration certificate and a recalibration service for the ELM series in preparation.
Quick-Links
• EtherCAT basics
• Mounting and wiring
• Process data overview
• Connection view measuring voltage
• Connection view measuring current
• Power contacts ELM314x
• Object description and parameterization


ELM314x - Technical data

Product overview [image] ELM314x [image] ELM314x - Technical data
ELM314x - Technical data
Technical data | ELM3142-000x | ELM3144-000x | ELM3146-000x | ELM3148-000x
Analog inputs | 2 channel (differential) | 4 channel (differential) | 6 channel (differential) | 8 channel (differential)
Time relation between channels to each other | Simultaneous conversion of all channels in the terminal (multiplex), synchronous conversion between terminals, if DistributedClocks will be used. Timestamp each channel, typ. sampling offset related to cannel 1:
 | Ch.1: 0 µs Ch.2: +200 µs | Ch.1: 0 µs Ch.2: +200 µs Ch.3: +400 µs Ch.4: +600 µs | Ch.1: 0 µs Ch.2: +100 µs Ch.3: +200 µs Ch.4: +300 µs Ch.5: +400 µs Ch.6: +500 µs | Ch.1: 0 µs Ch.2: +100 µs Ch.3: +200 µs Ch.4: +300 µs Ch.5: +400 µs Ch.6: +500 µs Ch.7: +600 µs Ch.8: +700 µs
ADC conversion method | deltaSigma ΔΣ with internal sample rate 8 MSps
Limit frequency input filter hardware (see information in section ELM Features/ Firmware filter concept) | Before AD converter: hardware low pass -3dB @ 330 Hz type butterworth 1th order Within ADC after conversion: low pass -3dB @ 2.75 kHz type sinc5/average filter The ramp-up time/ settling time/ delay caused by the filtering will be considered within the DistributedClocks-Timestamp.
Resolution | 24 Bit (including sign)
Connection technology | 2/3/4 wire
Connection type | push-in cageclamp, service plug, 4-pin |  | push-in cageclamp, service plug, 6-pin
Sampling rate (per channel, simultaneous) | 1 ms/ 1 kSps
 | free down sampling by Firmware via decimation factor, possible effective sampling interval each channel: 1 ms + n*25 µs
Oversampling | 1…20 selectable
Supported EtherCAT cycle time (depending on the operation mode) | DistributedClocks: min. 100 µs, max. 10 ms FrameTriggered/Synchron: min. 200 µs, max. 100 ms FreeRun: not yet supported
Connection diagnosis | Wire break/short cut
Current consumption via E-bus | typ. 250 mA |  |  | typ. 300 mA
Current consumption via power contacts | Load-dependent (power contacts are only passed through for sensor supply)
Thermal power dissipation | typ. 2 W
Dielectric strength - destruction limit | max. permissible short-term / permanent voltage between the contact points: ± 30 V
Recommended operation voltage range to compliance with specification | max. permitted voltage during specified normal operation tbd
Weight | approx. 350 g
Permissible ambient temperature range during operation | 0…+55 °C
Permissible ambient temperature range during storage | -25…+85 °C
Overview measurement ranges (ELM314x):
Measurement | Connection technology | FSV | Mode | Maximum value/ value range
Voltage | 2 wire | ±10 V | Extended | ±10.737.. V
 |  |  | Legacy | ±10 V
 |  | ±5 V | Extended | ±5.368.. V
 |  |  | Legacy | ±5 V
 |  | ±2.5 V | Extended | ±2.684.. V
 |  |  | Legacy | ±2.5 V
 |  | ±1.25 V | Extended | ±1.490.. V
 |  |  | Legacy | ±1.25 V
Voltage | 2 wire | +10 V | Extended | 0…10.737.. V
 |  |  | Legacy | 0…10 V
 |  | +5 V | Extended | 0…5.368.. V
 |  |  | Legacy | 0…5 V
Current | 2 wire | ±20 mA | Extended | ±21.474.. mA
 |  |  | Legacy | ±20 mA
 |  | +20 mA | Extended | 0…21.474.. mA
 |  |  | Legacy | 0…20 mA
 |  | +20 mA | Extended | 0…21.179 mA
 |  |  | Legacy | 4…20 mA
 |  | +20 mA | Extended | 3.6…21 mA
 |  |  | Legacy | 4…20 mA
Overview measurement ranges, Bipolar
Overview measurement ranges, Unipolar
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.
Additional information
•
Measurement ±10 V
•
Measurement ±5 V
•
Measurement ±2.5 V
•
Measurement ±1.25 V
•
Measurement 0…5 V
•
Measurement 0…10 V
•
Measurement ±20 mA
•
Measurement 0…20 mA
•
Measurement 4…20 mA
•
Measurement 3.6…21 mA (NAMUR NE43)


Measurement ±10 V

Product overview [image] ELM314x [image] ELM314x - Technical data [image] Measurement ±10 V
Measurement ±10 V
Measurement mode | ±10 V
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -10…+10 V
Measuring range, end value (full scale value) | 10 V
Measuring range, technically usable | -10.737…+10.737 V
PDO resolution | 24 bit (including sign)
PDO LSB (Extended Range) | 1.28 µV
PDO LSB (Legacy Range) | 1.192.. µV
Preliminary specifications:
Measurement mode |  |  | ±10 V
Basic accuracy: Measuring deviation at 23°C, with averaging |  |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) |  | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) |  | EGain | < 60 ppm
Non-linearity over the whole measuring range |  | ELin | < 25 ppmFSV
Repeatability |  | ERep | < 20 ppmFSV
Noise (without filtering) |  | ENoise, PtP | < 100 ppmFSV < 781 [digits]
 |  | ENoise, RMS | < 18 ppmFSV < 141 [digits]
 |  | Max. SNR | > 94.9 dB
 |  | Noisedensity@1kHz | < 2.55
Noise (with 50Hz FIR filtering) |  | ENoise, PtP | < 10 ppmFSV < 78 [digits]
 |  | ENoise, RMS | < 2.0 ppmFSV < 16 [digits]
 |  | Max. SNR | > 114.0 dB
Temperature coefficient |  | TcGain | < 8 ppm/K typ.
 |  | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) | DC: |  | >115 dB typ.
 | 50 Hz: |  | >105 dB typ.
 | 1 kHz: |  | >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) | DC: |  | >115 dB typ.
 | 50 Hz: |  | >115 dB typ.
 | 1 kHz: |  | >115 dB typ
Largest short-term deviation during a specified electrical interference test |  |  | ±0.03% = 300 ppmFSV typ.
Representation ±10 V measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.
ELM314x_Frequency response ±10 V.png
Frequency response of measuring range ±10 V, fsampling = 1 kHz, integrated filters 1/2 deactivated


Measurement ±5 V

Product overview [image] ELM314x [image] ELM314x - Technical data [image] Measurement ±5 V
Measurement ±5 V
Measurement mode | ±5 V
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -5…+5 V
Measuring range, end value (full scale value) | 5 V
Measuring range, technically usable | -5.368…+5.368 V
PDO resolution | 24 bit (including sign)
PDO LSB (Extended Range) | 640 nV
PDO LSB (Legacy Range) | 596.. nV
Preliminary specifications:
Measurement mode |  | ±5 V
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 1.27
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation ±5 V measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.
ELM314x_Frequency response ±5 V.png
Frequency response of measuring range ±5 V, fsampling = 1 kHz, integrated filters 1/2 deactivated


Measurement ±2.5 V

Product overview [image] ELM314x [image] ELM314x - Technical data [image] Measurement ±2.5 V
Measurement ±2.5 V
Measurement mode | ±2.5 V
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -2.5…+2.5 V
Measuring range, end value (full scale value) | 2.5 V
Measuring range, technically usable | -2.684…+2.684 V
PDO resolution | 24 bit (including sign)
PDO LSB (Extended Range) | 320 nV
PDO LSB (Legacy Range) | 298.. nV
Preliminary specifications:
Measurement mode |  | ±2.5 V
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 90 ppmFSV |  | < 703 [digits]
 | ENoise, RMS | < 17 ppmFSV |  | < 133 [digits]
 | Max. SNR | > 95.4 dB
 | Noisedensity@1kHz | < 0.60
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 9 ppmFSV |  | < 70 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation ±2.5 V measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.
ELM314x_Frequency response ±2.5 V.png
Frequency response of measuring range ±2.5 V, fsampling = 1 kHz, integrated filters 1/2 deactivated


Measurement ±1.25 V

Product overview [image] ELM314x [image] ELM314x - Technical data [image] Measurement ±1.25 V
Measurement ±1.25 V
Measurement mode | ±1.25 V
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -1.25…+1.25 V
Measuring range, end value (full scale value) | 1.25 V
Measuring range, technically usable | -1.490…+1.490 V
PDO resolution | 24 bit (including sign)
PDO LSB (Extended Range) | 160 nV
PDO LSB (Legacy Range) | 149.. nV
Preliminary specifications:
Measurement mode |  | ±1.25 V
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 90 ppmFSV |  | < 703 [digits]
 | ENoise, RMS | < 17 ppmFSV |  | < 133 [digits]
 | Max. SNR | > 95.4 dB
 | Noisedensity@1kHz | < 0.30
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 9 ppmFSV |  | < 70 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation ±1.25 V measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.
ELM314x_Frequency response ±1.25 V.png
Frequency response of measuring range ±1.25 V, fsampling = 1 kHz, integrated filters 1/2 deactivated


Measurement 0…5 V

Product overview [image] ELM314x [image] ELM314x - Technical data [image] Measurement 0…5 V
Measurement 0…5 V
Measurement mode | 0…5 V
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | 0…5 V
Measuring range, end value (full scale value) | 5 V
Measuring range, technically usable | 0…5.368 V
PDO resolution | 23 bit (unsigned)
PDO LSB (Extended Range) | 640 nV
Preliminary specifications:
Measurement mode |  | 0…5 V
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 1.27
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation 0…5 V measurement range
Note: The channel also works in electrically bipolar mode and records negative values in the unipolar measuring ranges (measurement from 0 V, 0 mA, 4 mA, 0 Ω). This enables the channel to provide a precise diagnosis even with signals < 0. In these measuring ranges the limit value for the "Underrange Error" in Extended Mode is -1% of the full scale value (FSV). The limit value can be set in CoE object 0x80n0:32. This avoids irritating error messages if the channel is not wired (e.g. without sensor) or the electrical signal fluctuates slightly around zero. The process data value of 0x00000000 is not undershot.
If the "UnderrangeError" detection is to be set even less sensitive, the magnitude of the negative limit value in the CoE object referred to above can be set even higher.
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.
ELM314x_Frequency response 0..5 V.png
Frequency response of measuring range 0..5 V, fsampling = 1 kHz, integrated filters 1/2 deactivated


Measurement 0…10 V

Product overview [image] ELM314x [image] ELM314x - Technical data [image] Measurement 0…10 V
Measurement 0…10 V
Measurement mode | 0…10 V
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | 0…10 V
Measuring range, end value (full scale value) | 10 V
Measuring range, technically usable | 0…+10.737 V
PDO resolution | 23 bit (unsigned)
PDO LSB (Extended Range) | 1.28 µV
Preliminary specifications:
Measurement mode |  | 0…10 V
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 60 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 2.55
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation 0…10 V measurement range
Note: The channel also works in electrically bipolar mode and records negative values in the unipolar measuring ranges (measurement from 0 V, 0 mA, 4 mA, 0 Ω). This enables the channel to provide a precise diagnosis even with signals < 0. In these measuring ranges the limit value for the "Underrange Error" in Extended Mode is -1% of the full scale value (FSV). The limit value can be set in CoE object 0x80n0:32. This avoids irritating error messages if the channel is not wired (e.g. without sensor) or the electrical signal fluctuates slightly around zero. The process data value of 0x00000000 is not undershot.
If the "UnderrangeError" detection is to be set even less sensitive, the magnitude of the negative limit value in the CoE object referred to above can be set even higher.
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.
ELM314x_Frequency response 0..10 V.png
Frequency response of measuring range 0..10 V, fsampling = 1 kHz, integrated filters 1/2 deactivated


Measurement ±20 mA

Product overview [image] ELM314x [image] ELM314x - Technical data [image] Measurement ±20 mA
Measurement ±20 mA
Measurement mode | ±20 mA
Internal resistance | 150 Ω typ.
Impedance | Tbd.
Measuring range, nominal | -20…+20 mA
Measuring range, end value (full scale value) | 20 mA
Measuring range, technically usable | -21.474…+21.474 mA, overcurrent-protected
Fuse protection | Internal overload limiting, continuous current resistant
PDO resolution | 24 bit (including sign)
PDO LSB (Extended Range) | 2.56 nA
PDO LSB (Legacy Range) | 2.384.. nA
Common-mode voltage Vcm | max. ±10V related to -Uv (internal ground)
Preliminary specifications:
Measurement mode |  | ±20 mA
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 65 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 50 ppm
Non-linearity over the whole measuring range | ELin | < 40 ppmFSV
Repeatability | ERep | < 40 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 5.09
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 15 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) | DC: < 3 nA/V typ. | 50 Hz: < 5 nA/V typ. | 1 kHz: < 80 nA/V typ.
Common-mode rejection ratio (with 50Hz FIR filtering) | DC: < 3 nA/V typ. | 50 Hz: < 3 nA/V typ. | 1 kHz: < 3 nA/V typ.
Largest short-term deviation during a specified electrical interference test | Value to follow [ppm] typ. (FSV)
Current measurement range ±20 mA
Representation current measurement range ±20 mA
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement 0…20 mA

Product overview [image] ELM314x [image] ELM314x - Technical data [image] Measurement 0…20 mA
Measurement 0…20 mA
Measurement mode | 0...20 mA
Internal resistance | 150 Ω typ.
Impedance | Tbd.
Measuring range, nominal | 0…20 mA
Measuring range, end value (full scale value) | 20 mA
Measuring range, technically usable | 0 …21.474 mA
Fuse protection | Internal overload limiting, continuous current resistant
PDO resolution | 23 bit (unsigned)
PDO LSB (Extended Range) | 2.56 nA
PDO LSB (Legacy Range) | 2.384.. nA
Common-mode voltage Vcm | max. ±10V related to -Uv (internal ground)
Preliminary specifications:
Measurement mode |  | 0...20 mA
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 65 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 50 ppm
Non-linearity over the whole measuring range | ELin | < 40 ppmFSV
Repeatability | ERep | < 40 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 5.09
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 15 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: < 3 nA/V typ. | 50 Hz: < 5 nA/V typ. |  | 1 kHz: < 80 nA/V typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: < 3 nA/V typ. | 50 Hz: < 3 nA/V typ. |  | 1 kHz: < 3 nA/V typ.
Largest short-term deviation during a specified electrical interference test |  | Value to follow [ppm] typ. (FSV)
Current measurement range 0…20 mA
Representation current measurement range 0…20 mA
Note: The channel also works in electrically bipolar mode and records negative values in the unipolar measuring ranges (measurement from 0 V, 0 mA, 4 mA, 0 Ω). This enables the channel to provide a precise diagnosis even with signals < 0. In these measuring ranges the limit value for the "Underrange Error" in Extended Mode is -1% of the full scale value (FSV). The limit value can be set in CoE object 0x80n0:32. This avoids irritating error messages if the channel is not wired (e.g. without sensor) or the electrical signal fluctuates slightly around zero. The process data value of 0x00000000 is not undershot.
If the "UnderrangeError" detection is to be set even less sensitive, the magnitude of the negative limit value in the CoE object referred to above can be set even higher.
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement 4…20 mA

Product overview [image] ELM314x [image] ELM314x - Technical data [image] Measurement 4…20 mA
Measurement 4…20 mA
Measurement mode | 4…20 mA
Internal resistance | 150 Ω typ.
Impedance | Tbd.
Measuring range, nominal | 4…20 mA
Measuring range, end value (full scale value) | 20 mA
Measuring range, technically usable | 0…21.179 mA
Fuse protection | Internal overload limiting, continuous current resistant
PDO resolution | 24 Bit
PDO LSB (Extended Range) | 2.048 nA
PDO LSB (Legacy Range) | 1.907.. nA
Common-mode voltage Vcm | max. ±10V related to -Uv (internal ground)
Preliminary specifications:
Measurement mode |  | 4…20 mA
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 65 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 50 ppm
Non-linearity over the whole measuring range | ELin | < 40 ppmFSV
Repeatability | ERep | < 40 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 5.09
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 15 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: < 3 nA/V typ. | 50 Hz: < 5 nA/V typ. |  | 1 kHz: < 80 nA/V typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: < 3 nA/V typ. | 50 Hz: < 3 nA/V typ. |  | 1 kHz: < 3 nA/V typ.
Largest short-term deviation during a specified electrical interference test |  | Value to follow [ppmFSV] typ.
Current measurement range 4…20 mA
Representation current measurement range 4…20 mA
Note: The channel also works in electrically bipolar mode and records negative values in the unipolar measuring ranges (measurement from 0 V, 0 mA, 4 mA, 0 Ω). This enables the channel to provide a precise diagnosis even with signals < 0. In these measuring ranges the limit value for the "Underrange Error" in Extended Mode is -1% of the full scale value (FSV). The limit value can be set in CoE object 0x80n0:32. This avoids irritating error messages if the channel is not wired (e.g. without sensor) or the electrical signal fluctuates slightly around zero. The process data value of 0x00000000 is not undershot.
If the "UnderrangeError" detection is to be set even less sensitive, the magnitude of the negative limit value in the CoE object referred to above can be set even higher.
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement 3.6…21 mA (NAMUR NE43)

Product overview [image] ELM314x [image] ELM314x - Technical data [image] Measurement 3.6…21 mA (NAMUR NE43)
Measurement 3.6…21 mA (NAMUR NE43)
Measurement mode | 3.6…21 mA (NAMUR NE43)
Internal resistance | 150 Ω typ.
Impedance | Tbd.
Measuring range, nominal | 4…20 mA
Measuring range, end value (full scale value) | 20 mA
Measuring range, technically usable | 3.6…21 mA
Fuse protection | Internal overload limiting, continuous current resistant
PDO resolution | 24 Bit
PDO LSB (Extended Range) | 2.048 nA
PDO LSB (Legacy Range) | n.a.
Common-mode voltage Vcm | max. ±10V related to -Uv (internal ground)
Preliminary specifications:
Measurement mode |  | 3.6…21 mA (NAMUR NE43)
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 65 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 50 ppm
Non-linearity over the whole measuring range | ELin | < 40 ppmFSV
Repeatability | ERep | < 40 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 5.09
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 15 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: < 3 nA/V typ. | 50 Hz: < 5 nA/V typ. |  | 1 kHz: < 80 nA/V typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: < 3 nA/V typ. | 50 Hz: < 3 nA/V typ. |  | 1 kHz: < 3 nA/V typ.
Largest short-term deviation during a specified electrical interference test |  | Value to follow [ppmFSV] typ.
Current measuring range 3.6…21 mA (NAMUR)
Chart: current measuring range 3.6…21 mA (NAMUR)
Only Extended Range mode for measuring range 4 mA NAMUR
Legacy Range mode is not available for this measurement range. The Extended Range Mode will be set automatically and although a corresponding write access to the CoE Object 0x8000:2E (Scaler) is not declined, the parameter is not changed.


ELM350x

Product overview [image] ELM350x
ELM350x
Additional information
•
ELM350x - Introduction
•
ELM350x - Technical data


ELM350x - Introduction

Product overview [image] ELM350x [image] ELM350x - Introduction
ELM350x - Introduction
ELM3502-0000, ELM3504-0000
2 and 4 channel measuring bridge analysis, full/half/quarter bridge, 24 bit, 10/ 20 ksps
The ELM350x EtherCAT Terminals are designed for the evaluation of measuring bridges in full-bridge, half-bridge and quarter-bridge configuration. The terminals feature internally switchable supplementary resistors. The feed is integrated. Like all other parameters, the supply voltage is adjustable in the CoE. Irrespective of the signal configuration, all ELM modules have the same technological properties. The ELM350x modules for the evaluation of measuring bridges offer a maximum sampling rate of 10,000 or 20,000 samples per second. The 6-pin plug (push-in) can be removed for maintenance purposes without releasing the individual wires.
There are variants with factory calibration certificate and a recalibration service for the ELM series in preparation.
Quick-Links
• EtherCAT basics
• Mounting and wiring
• Process data overview
• Connection view
• Object description and parameterization


ELM350x - Technical data

Product overview [image] ELM350x [image] ELM350x - Technical data
ELM350x - Technical data
Technical data | ELM3502 | ELM3504
Analog inputs | 2 channel (differential) | 4 channel (differential)
Time relation between channels to each other | Simultaneous conversion of all channels in the terminal, synchronous conversion between terminals, if DistributedClocks will be used
ADC conversion method | deltaSigma ΔΣ with internal sample rate
 | 5.12 MSps | 8 MSps
Limit frequency input filter hardware (see information in section ELM Features/ Firmware filter concept) | Before AD converter: hardware low pass -3dB @ 30 kHz type butterworth 3th order Within ADC after conversion:
 | low pass -3dB @ 5.3 kHz, ramp-up time 150 µs | low pass -3dB @ 2.6 kHz, ramp-up time 300 µs
 | type sinc3/average filter The ramp-up time/ settling time/ delay caused by the filtering will be considered within the DistributedClocks-Timestamp.
Resolution | 24 Bit (including sign)
Connection technology | 2/ 3 / 4 / 5 / 6 wire
Connection type | push-in cageclamp, service plug, 6-pin
Sampling rate (per channel, simultaneous) | 50 µs/20 kSps | 100 µs/10 kSps
 | free down sampling by Firmware via decimation factor
Oversampling | 1…100 selectable
Operation range DMS | Quarter bridge (1 kΩ, 350 Ω, 120 Ω) half bridge, full bridge, internal bridge extension and feeding-in supply adjustable
Supported EtherCAT cycle time (depending on the operation mode) | DistributedClocks: min. 100 µs, max. 10 ms FrameTriggered/Synchron: min. 200 µs, max. 100 ms FreeRun: not supported
Connection diagnosis | Wire break/short cut
Surge voltage protection of the inputs related to ‑Uv (internal ground) | tbd
Current consumption via E-bus | 450 mA typ. | 720 mA typ.
Thermal power dissipation | typ. 3 W
Dielectric strength - destruction limit | max. permitted short-term/continuous voltage between contact points ±I1, ±I2, +Uv and –Uv: non-supplied ±40 V, supplied ±36 V Note: -Uv corresponds to internal AGND
Recommended operation voltage range to compliance with specification | max. permitted voltage during specified normal operation between ±I1 and ±I2: typ. ±10 V against –Uv Note: -Uv corresponds to internal AGND
Electrical isolation channel/channel *) | no
Electrical isolation channel/Ebus *) | yes, 500V/1min.typ. test
Electrical isolation channel/SGND *) | yes, 500V/1min.typ. test
Weight | approx. 350 g
Permissible ambient temperature range during operation | -25…+60 °C | -25…+55 °C
Permissible ambient temperature range during storage | -40…+85 °C
*) see notes to potential groups in chapter “Mounting and wiring/ Power supply, potential groups”
Overview measurement ranges (ELM350x):
Measurement | Connection technology | FSV | Mode | Maximum value/ value range
Voltage | 2 wire | ±10 V | Extended | ±10.737.. V
 |  |  | Legacy | ±10 V
 |  | ±80 mV | Extended | ±85.9.. mV
 |  |  | Legacy | ±80 mV
PT1000 | 2/3/4 wire | 2000 Ω | Legacy | 266 °C
Potentiometer | 3/5 wire | ±1 V/V | Extended | ±1 V/V
 |  |  | Legacy
Full bridge | 4/6 wire | ±32 mV/V | Extended | ±34.359.. mV/V
 |  |  | Legacy | ±32 mV/V
 |  | ±8 mV/V | Extended | ±8.5899.. mV/V
 |  |  | Legacy | ±8 mV/V
 |  | ±4 mV/V | Extended | ±4.2949.. mV/V
 |  |  | Legacy | ±4 mV/V
 |  | ±2 mV/V | Extended | ±2.1474.. mV/V
 |  |  | Legacy | ±2 mV/V
Half bridge | 3/5 wire | ±16 mV/V | Extended | ±17.179.. mV/V
 |  |  | Legacy | ±16 mV/V
 |  | ±8 mV/V | Extended | ±8.5899.. mV/V
 |  |  | Legacy | ±8 mV/V
 |  | ±4 mV/V | Extended | ±4.2949.. mV/V
 |  |  | Legacy | ±4 mV/V
 |  | ±2 mV/V | Extended | ±2.1474.. mV/V
 |  |  | Legacy | ±2 mV/V
Quarter bridge 120/350/1000 Ω | 2/3 wire | ±32 mV/V | Extended | ±34.359.. mV/V
 |  |  | Legacy | ±32 mV/V
 |  | ±8 mV/V | Extended | ±8.5899.. mV/V
 |  |  | Legacy | ±8 mV/V
 |  | ±4 mV/V | Extended | ±4.2949.. mV/V
 |  |  | Legacy | ±4 mV/V
 |  | ±2 mV/V | Extended | ±2.1474.. mV/V
 |  |  | Legacy | ±2 mV/V
Overview measurement ranges, Bipolar
Overview measurement ranges, Unipolar
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.
Additional information
•
Measurement ±10 V
•
Measurement ±80 mV
•
RTD/PT1000 measurement
•
Potentiometer measurement
•
Measurement SG 1/1 bridge (full bridge) 4/6-wire connection
•
Measurement SG 1/2 bridge (half bridge) 3/5-wire connection
•
Measurement SG 1/4 bridge (quarter-bridge) 2/3-wire connection


Measurement ±10 V

Product overview [image] ELM350x [image] ELM350x - Technical data [image] Measurement ±10 V
Measurement ±10 V
Measurement mode | ±10 V
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -10…+10 V
Measuring range, end value (full scale value) | 10 V
Measuring range, technically usable | -10.737…+10.737 V
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 1.28 µV | 327.68 µV
PDO LSB (Legacy Range) | 1.192.. µV | 305.18.. µV
Preliminary specifications:
Measurement mode |  | ±10 V
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01 % = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 60 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 2.55
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2,0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation ±10 V measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement ±80 mV

Product overview [image] ELM350x [image] ELM350x - Technical data [image] Measurement ±80 mV
Measurement ±80 mV
Measurement mode | ±80 mV
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -80…+80 mV
Measuring range, end value (full scale value) | 80 mV
Measuring range, technically usable | -85.9…+85.9 mV
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 10.24 nV | 2.62144 µV
PDO LSB (Legacy Range) | 9.536.. nV | 2.441.. µV
Preliminary specifications:
Measurement mode |  | ±80 mV
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 160 ppmFSV |  | < 1250 [digits]
 | ENoise, RMS | < 37 ppmFSV |  | < 289 [digits]
 | Max. SNR | > 88.6 dB
 | Noisedensity@1kHz | < 41.86
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 18 ppmFSV |  | < 141 [digits]
 | ENoise, RMS | < 3.5 ppmFSV |  | < 27 [digits]
 | Max. SNR | > 109.1 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation ±80 mV measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


RTD/PT1000 measurement

Product overview [image] ELM350x [image] ELM350x - Technical data [image] RTD/PT1000 measurement
RTD/PT1000 measurement
RTD specification and conversion
Temperature measurement with a resistance-dependent RTD sensor generally consists of two steps:
▪
Electrical measurement of the resistance, if necessary in several ohmic measuring ranges
▪
Conversion (transformation) of the resistance into a temperature value by software means according to the set RTD type (PT100, PT1000…).
Both steps can take place locally in the Beckhoff measurement module. The transformation in the module can also be deactivated if it is to be calculated on a higher level in the control. Depending on the module type, several RTD conversions can be implemented which only differs in software. This means for Beckhoff RTD measurement modules that
▪
a specification table of the electrical resistance measurement is given
▪
and based on this, the effect for the temperature measurement is given below depending on the supported RTD type. Note that RTD characteristic curves are always realized as higher-order equations or by a sampling points table in the software, therefore a linear R→T transfer only makes sense in a narrow range.
Application on the ELM350x
The ELM350x supports the measurement of resistances up to 2 kΩ in 2/3/4‑wire measurement and the conversion of PT1000 RTD sensors up to 2000 Ω / 266 °C.
Although the ELM350x does not support a sole resistance measurement (without conversion to temperature), a resistance specification is given here because the temperature measurement is based on it.
Note on 2-/3-/4-wire connection in R/RTD mode
With 2‑wire measurement, the line resistance of the sensor supply lines influences the measured value. If a reduction of this systematic error component is desirable for 2‑wire measurements, the resistance of the supply line to the measuring resistance should be taken into account, in which case the resistance of the supply line has to be determined first. Taking into account the uncertainty associated with this supply line resistance, it can then be included statically in the calculation, in the EL3751 via 0x8000:13 and in the ELM350x/ ELM370x via 0x80n0:13. Any change in resistance of the supply line due to ageing, for example, is not taken into account automatically.
A 3‑wire measurement enables the systematic component to be eliminated, assuming that the two supply lines are identical. With this type of measurement, the lead resistance of a supply line is measured continuously. The value determined in this way is then deducted twice from the measurement result, thereby eliminating the line resistance. Technically, this leads to a significantly more reliable measurement. However, taking into account the measurement uncertainty, the gain from the 3‑wire connection is less significant, since this assumption is subject to high uncertainty, in view of the fact that the individual line that was not measured may be damaged, or a varying resistance may have gone unnoticed.
Therefore, although technically the 3‑wire connection is a tried and tested approach, for measurements that are methodological assessed based on measurement uncertainty, we strongly recommend fully‑compensated 4‑wire connection.
With both 2‑wire and 3‑wire connection, the contact resistances of the terminal contacts influence the measuring process. The measuring accuracy can be further increased by a user‑side adjustment with the signal connection plugged in.
Note
Measurement of small resistances
Especially for measurements in the range < 10 Ω, the 4‑wire connection is absolutely necessary due to the relatively high supply and contact resistances. It should also be considered that with such low resistances the relative measurement error in relation to the full scale value (FSV) can become high ‑ for such measurements resistance measurement terminals with small measuring ranges such as EL3692 in 4‑wire measurement should be used if necessary.
Corresponding considerations also lead to the common connection methods in bridge operation:
▪
Full bridge: 4‑wire connection without line compensation, 6‑wire connection with full line compensation
▪
Half bridge: 3‑wire connection without line compensation, 5‑wire connection with full line compensation
▪
Quarter bridge: 2‑wire connection without line compensation, 3‑wire connection with theoretical line compensation and 4‑wire connection with full line compensation
Resistance measurement 2 kΩ |  |  | 3 wire | 4 wire
Operation mode |  |  | 3 V feed voltage, fixed setting on +Uv Internal 1 kΩ reference resistance at –I2 Supply current is given by: 3 V / (1 kΩ + Rmeasurement) → max. 3 mA
Measuring range, nominal |  |  | 2 kΩ (corresponds to PT1000 + 266°C)
Measuring range, end value (full scale value) |  |  | 2 kΩ
Measuring range, technically usable |  |  | 0…2 kΩ
PDO resolution (Extended range) |  |  | Extended range is not supported for resistance measurement
PDO resolution (Legacy range) |  |  | Resistance measurement not available as separate measuring range on ELM350x
Basic accuracy: Measuring error at 23°C, with averaging, with offset |  |  | < ± 0.012%FSV < ± 120 ppmFSV < ± 240 mΩ | < ± 0.011%FSV < ± 110 ppmFSV < ± 220 mΩ
Offset/Zero Point deviation (at 23°C) | EOffset |  | < 40 ppm | < 30 ppm
Gain/scale/amplification deviation (at 23°C) | EGain |  | < 90 ppmFSV | < 80 ppmFSV
Non-linearity over the whole measuring range | ELin |  | < 65 ppmFSV | < 65 ppmFSV
Repeatability (at 23°C) | ERep |  | < 10 ppmFSV | < 10 ppmFSV
Noise (without filtering, at 23°C) | ENoise, PtP |  | < 220 ppmFSV < 1719 digits < 440 mΩ | < 220 ppmFSV < 1719 digits < 440 mΩ
 | ENoise, RMS |  | < 37 ppmFSV < 289 digits < 74 mΩ | < 37 ppmFSV < 289 digits < 74 mΩ
 | Max. SNR |  | > 88.6 dB | > 88.6 dB
 | Noisedensity@1kHz |  | < 1.05 | < 1.05
Noise (with 50 Hz FIR filtering, at 23°C) | ENoise, PtP |  | < 14 ppmFSV < 109 digits < 28 mΩ | < 14 ppmFSV < 109 digits < 28 mΩ
 | ENoise, RMS |  | < 2.3 ppmFSV < 18 digits < 4.6 mΩ | < 2.3 ppmFSV < 18 digits < 4.6 mΩ
 | Max. SNR |  | > 112.8 dB | > 112.8 dB
Common-mode rejection ratio (without filtering)3 |  |  | tbd | tbd
Common-mode rejection ratio (with 50 Hz FIR filtering)3 |  |  | tbd | tbd
Temperature coefficient |  | TcGain | < 10 ppm/K | < 10 ppm/K
 |  | TcOffset | < 4 ppmFSV/K < 8 mΩ/K | < 1.5 ppmFSV/K < 3 mΩ/K
Largest short-term deviation during a specified electrical interference test |  |  | ±tbd%FSV = ±tbd ppmFSV typ. | ±tbd%FSV = ±tbd ppmFSV typ.
RTD measuring range
Chart: RTD measuring range
In temperature mode, only the legacy range is available, the extended range is not available.
The temperature display in [°C/digit] (e.g. 0.1°/digit or 0.01°/digit) is independent from the electrical measurement. It is “just” a display setting and results from the PDO setting, see chapter "Comissioning".
Data for the sensor types in the following table
The values for the sensor types listed in the following table are shown here merely for informative purposes as an orientation aid. All data are given without guarantee and must be cross-checked against the data sheet for the respective sensor employed.
The RTD measurement consists of a chain of measuring and computing elements that affect the attainable measurement deviation:
The given resistance specification is decisive for the attainable temperature measurement accuracy. It is applied to the possible RTD types in the following.
On account of
▪
the non-linearity existing in the RTD and thus the high dependency of the specification data on the sensor temperature Tsens and
▪
the influence of the ambient temperature on the analog input device employed (leads to a change in Tmeasured on account of ∆Tambient although Tsens = constant)
no detailed temperature specification table is given in the following, but
▪
a short table specifying the electrical measuring range and orientation value for the basic accuracy
▪
a graph of the basic accuracy over Tsens (this at two example ambient temperatures so that the attainable basic accuracy is implied on account of the actual existing ambient temperature)
▪
equations for calculating further parameters (offset/gain/non-linearity/repeatability/noise) if necessary from the resistance specification at the desired operating point
RTD types supported by the ELM350x:
RTD temperature measurement | PT1000 3-wire | PT1000 4-wire
Electrical measuring range used | 2 kΩ
Starting value | -200 °C ≈ 185.2 Ω
End value | 266 °C ≈ 2000 Ω
PDO LSB (legacy range only) | 0.1/0.01/0.001 °C/digit, depending on PDO setting
Basic accuracy: Measurement deviation at 23 °C terminal environment, with averaging | ≈ ±0.043 K @ Tsens = 0 °C | ≈ ±0.042 K @ Tsens = 0 °C
Basic accuracy for PT1000, 3-wire connection:
Basic accuracy for PT1000, 4-wire connection:
If further specification data are of interest, they can or must be calculated from the values given in the resistance specification.
The sequence:
▪
General: The conversion is explained here only for one measuring point (a certain input signal); the steps simply have to be repeated in case of several measuring points (up to the entire measuring range).
▪
If the measured resistance at the measured temperature measuring point is unknown, the measured value (MW) in [Ω ] must be determined:
MW = RMeasuring point (TMeasuring point) with the help of an R→T table
▪
The deviation at this resistance value is calculated
–
Via the total equation
–
or a single value, e.g. ESingle = 15 ppmFSV
–
the measurement uncertainty in [Ω] must be calculated:
EResistance(RMeasuring point) = ETotal(RMeasuring point) * FSV
or: EResistance(RMeasuring point) = ESingle(RMeasuring point) * FSV
or (if already known) e.g.: EResistance(RMeasuring point) = 0.03 Ω
▪
The slope at the point used must then be determined:
ΔRproK(TMeasuring point) = [ R(TMeasuring point + 1 °C) – R(TMeasuring point )] / 1 °C
with the help of an R→T table
▪
The temperature measurement uncertainty can be calculated from the resistance measurement uncertainty and the slope
ETemp(RMeasuring point) = (EResistance(TMeasuring point)) / (ΔRproK(TMeasuring point) )
▪
To determine the error of the entire system consisting of RTD and ELM350x in [°C], the two errors must be added together quadratically:
The numerical values used in the following three examples are for illustration purposes. The specification values given in the technical data remain authoritative.
Example 1:
Basic accuracy of an ELM3504 at 35 °C ambient temperature, measurement of -100 °C in the PT1000 interface (4-wire), without the influence of noise and aging:
TMeasuring point = -100 °C
MW = RPT1000, -100 °C = 602.56 Ω
= 86.238 ppmFSV
EResistance(RMeasuring point) = 86.238 ppmFSV * 2000 Ω = 0.1725 Ω
ΔRproK(TMeasuring point) = (R(-99 °C) – R(-100 °C)) / (1 °C) = 4.05 Ω/°C
EELM3504@35°C, PT1000, -100 °C = (0.1725 Ω)/(4.05 Ω/°C) ≈ 0.043 °C (means ±0.043 °C)
Example 2:
Consideration of the repeatability alone under the above conditions:
TMeasuring point = -100 °C
MW = RMeasuring point (-100 °C) = 602.56 Ω
ESingle = 10 ppmFSV
EResistance= 10 ppmFSV * 2000 Ω = 0.02 Ω
ΔRproK(TMeasuring point) = (R-99 °C – R-100 °C) / 1 °C = 4.05 Ω/°C
ETemp(RMeasuring point) = 0.02 Ω / 4.05 Ω/°C ≈ 0.005 °C (means ±0.005 °C)
Example 3:
Consideration of the RMS noise alone without filter under the above conditions:
TMeasuring point = -100 °C
MW = RMeasuring point (-100 °C) = 602.56 Ω
ESingle = 37 ppmFSV
EResistance= 37 ppmFSV * 2000 Ω = 0.074 Ω
ΔRproK(TMeasuring point) = (R-99 °C – R-100 °C) / 1 °C = 4.05 Ω/°C
ETemp(RMeasuring point) = 0.074 Ω / 4.05 Ω/°C ≈ 0.018 °C (means ± 0.018 °C)
Example 4:
If the noise ENoise, PtP of the above example terminal is considered not for one sensor point -100 °C but in general, the following plot results:


Potentiometer measurement

Product overview [image] ELM350x [image] ELM350x - Technical data [image] Potentiometer measurement
Potentiometer measurement
The potentiometer should be supplied with the integrated power supply unit (max. 5 V, configurable). The slider voltage is then measured relative to the supply voltage and output in %. Technical, the measurement is similar to a strain gauge half bridge.
Potentiometers from 1 kΩ can be used.
Diagnostics
▪
Slider breakage: full-scale deflection or 0 display
▪
Supply interruption: full-scale deflection or 0 display
Measurement mode |  |  | Potentiometer (5 wire)
Operation mode |  |  | The supply voltage is configurable via CoE, 0.5…5 V
Measuring range, nominal |  |  | -1…1 V/V
Measuring range, end value (full scale value) |  |  | 1 V/V
Measuring range, technically usable |  |  | -1…1 V/V
PDO resolution |  |  | 24 bit (incl. sign)
PDO LSB (Extended Range) |  |  | 0.128 ppm
PDO LSB (Legacy Range) |  |  | 0.119… ppm
Basic accuracy: Measuring deviation at 23°C, with averaging | without offset 2 |  | < ± 0.0025 %FSV < ± 25 ppmFSV < ± 25 µV/V
 | with offset 2 |  | < ± 0.0075 %FSV < ± 75 ppmFSV < ± 75 µV/V
Offset/Zero Point deviation (at 23°C) | EOffset |  | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain |  | < 20 ppm
Non-linearity over the whole measuring range | ELin |  | < 15 ppmFSV
Repeatability | ERep |  | < 1 ppmFSV
Noise (peak-to-peak, without filtering, at 23°C) | ENoise, PtP |  | < 105 ppmFSV < 820 digits
 | ENoise, RMS |  | < 18 ppmFSV < 137 digits
 | Max. SNR |  | > 95.1 dB
 | Noisedensity @1kHz |  | < 0.18
Noise (peak-to-peak, with 50Hz filtering, at 23°C) | ENoise, PtP |  | < 9 ppmFSV < 70 digits
 | ENoise, RMS |  | < 1.5 ppmFSV < 12 digits
 | Max. SNR |  | > 116.5 dB
Common-mode rejection ratio (without filtering)3 |  |  | DC: tbd [image] typ. | 50 Hz: tbd [image] typ. | 1 kHz: tbd [image] typ.
Common-mode rejection ratio (with 50Hz filtering)3 |  |  | DC: tbd [image] typ. | 50 Hz: tbd [image] typ. | 1 kHz: tbd [image] typ.
Temperature coefficient |  | TcGain | < 1 ppm/K
 |  | TcOffset | < 1 ppmFSV/K
Largest short-term deviation during a specified electrical interference test |  |  | tbd %FSV = tbd ppmFSV typ.
2) A regular offset adjustment with connected potentiometer is recommended. The given offset specification of the terminal is therefore practically irrelevant. Therefore, specification values with and without offset are given here. In practice, the offset component can be eliminated by the terminal functions Tare and also ZeroOffset or in the controller by a higher-level tare function. The offset deviation over time can change, therefore Beckhoff recommends a regular offset adjustment or careful observation of the change.
3) Values related to a common mode interference between SGND and internal ground.
Potentiometer measurement range
Representation potentiometer measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement SG 1/1 bridge (full bridge) 4/6-wire connection

Product overview [image] ELM350x [image] ELM350x - Technical data [image] Measurement SG 1/1 bridge (full bridge) 4/6-wire connection
Measurement SG 1/1 bridge (full bridge) 4/6-wire connection
To determine the measuring error:
The nominal/technical measuring range is specified in "mV/V"; the maximum permitted supply voltage is 5 V. The maximum nominal measuring range that can be used for the bridge voltage is therefore ±32 mV/V * 5 V = ±160 mV; the internal circuits are configured accordingly.
The internal measurement is ratiometric, i.e. the feed voltage and the bridge voltage are not measured absolutely, but as a ratio.
The integrated supply can be used as power supply. An external supply is permitted, as long as 5 V is not exceeded.
The following is the specification given for the 6 wire connection. External line resistances are compensated by the 6 wire connection and the full bridge is detected directly from the measuring channel.
In the 4 wire connection, the terminal generally has the same specification, but its view of the connected full bridge is clouded by the unclear and temperature-dependent lead resistances within cables and connectors. In this respect, the overall system "full bridge + leads + measurement channel" will practically not achieve specification values given below. The lead resistances (cables, connectors, ...) have an effect especially on the gain error, also depending on the temperature.
The gain error can be estimated by (R+uv (1+ ∆T* TCCu) + R-uv(1+∆T* TCCu) )/Rnom with TCCu~3930 ppm/K, Rnom e.g. 350 Ω and R+uv or R-uv lead resistances respectively.
Note
Increase measurement accuracy: switcheable shunt
By a user-side adjustment with plugged signal connection, the measurement accuracy can be further increased. The ELM350x and ELM370x terminals also have a shunt resistor which can be switched from their CoE directory (0x80n0:08).
The use of the measurement channel in the 6 wire connection is recommended, especially when significant resistors such as a lightning arrester are put into the line.
Note: specifications apply for 5 V SG excitation and symmetric 350R SG.
Note: Data are valid from production week 01 / 2019 and
▪
for ELM3502: HW03
▪
for ELM3504: HW04
Measurement mode |  | StrainGauge/SG 1/1 Bridge 4/6 wire
 |  | 32 mV | 8 mV |  | 4 mV |  | 2 mV
Integrated power supply |  | 1…5 V adjustable, max. supply/excitation 21 mA (internal electronic overload protection) therefore 120R strain gauge: up to 2.5 V; 350R strain gauge: up to 5.0 V
Measuring range, nominal |  | -32 … +32 mV/V | -8 … +8 mV/V | -4 … +4 mV/V |  | -2 … +2 mV/V
Measuring range, end value (FSV) |  | 32 mV/V | 8 mV/V | 4 mV/V |  | 2 mV/V
Measuring range, technically usable |  | -34,359 … +34,359 mV/V | -8,590 … +8,590 mV/V | -4,295 … +4,295 mV/V |  | -2,147 … +2,147 mV/V
PDO resolution |  | 24 Bit (incl. sign)
PDO LSB (Extended Range) |  | 0.128 ppm
PDO LSB (Legacy Range) |  | 0.119… ppm
Basic accuracy: Measuring deviation at 23°C, with averaging | without offset 2) | < ±0,0025%MBE < ±25 ppmMBE < ±0,80 µV/V | < ±0,006%MBE < ±60 ppmMBE < ±0,48 µV/V | < ±0,0085%MBE < ±85 ppmMBE < ±0,34 µV/V |  | < ±0,013%MBE < ±130 ppmMBE < ±0,26 µV/V
 | with offset 2) | < ±0,0075%MBE < ±75 ppmMBE < ±2,40 µV/V | < ±0,015%MBE < ±150 ppmMBE < ±1,20 µV/V | < ±0,03%MBE < ±300 ppmMBE < ±1,20 µV/V typ |  | < ±0,06%MBE < ±600 ppmMBE < ±1,20 µV/V typ
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmMBE | < 140 ppmMBE | < 280 ppmMBE |  | < 580 ppmMBE
Gain/scale/amplification deviation (at 23°C) | EGain | < 20 ppm | < 50 ppm | < 70 ppm |  | < 110 ppm
Non-linearity over the whole measuring range | ELin | < 15 ppmMBE | < 30 ppmMBE | < 45 ppmMBE |  | < 65 ppmMBE
Repeatability (at 23°C) | ERep | < 5 ppmMBE | < 10 ppmMBE | < 15 ppmMBE |  | < 20 ppmMBE
Noise (without filtering, at 23°C) | ENoise, PtP | < 150 ppmMBE < 1172 digits < 4,80 µV/V | < 400 ppmMBE < 3125 digits < 3,2 µV/V | < 750 ppmMBE < 5859 digits < 3,0 µV/V |  | < 1500 ppmMBE < 11719 digits < 3,0 µV/V
 | ENoise, RMS | < 25 ppmMBE < 195 digits < 0,80 µV/V | < 70 ppmMBE < 547 digits < 0,56 µV/V | < 140 ppmMBE < 1094 digits < 0,56 µV/V |  | < 280 ppmMBE < 2188 digits < 0,56 µV/V
 | Max. SNR | > 92,0 dB | > 83,1 dB | > 77,1 dB |  | > 71,1 dB
 | Noisedensity@1kHz | < 11,31 | < 7,92 | < 7,92 |  | < 7,92
Noise (with 50 Hz FIR filter, at 23°C) | ENoise, PtP | < 15 ppmMBE < 117 digits < 0,48 µV/V | < 30 ppmMBE < 234 digits < 0,24 µV/V | < 60 ppmMBE < 469 digits < 0,24 µV/V |  | < 110 ppmMBE < 859 digits < 0,22 µV/V
 | ENoise, RMS | < 2,5 ppmMBE < 20 digits < 0,08 µV/V | < 5,0 ppmMBE < 39 digits < 0,04 µV/V | < 10,0 ppmMBE < 78 digits < 0,04 µV/V |  | < 20,0 ppmMBE < 156 digits < 0,04 µV/V
 | Max. SNR | > 112,0 dB | > 106,0 dB | > 100,0 dB |  | > 94,0 dB
Common-mode rejection ratio (without filtering)3 | DC | tbd | tbd | tbd |  | tbd
 | 50 Hz | tbd | tbd | tbd |  | tbd
 | 1 kHz | tbd | tbd | tbd |  | tbd
Common-mode rejection ratio (with 50Hz filtering)3 | DC | tbd | tbd | tbd |  | tbd
 | 50 Hz | tbd | tbd | tbd |  | tbd
 | 1 kHz | tbd | tbd | tbd |  | tbd
Temperature coefficient | TcGain | < 1 ppm/K | < 2 ppm/K | < 3 ppm/K |  | < 5 ppm/K
 | TcOffset | < 1,2 ppmMBE/K < 0,04 | < 5 ppmMBE/K < 0,04 | < 12 ppmMBE/K < 0,05 |  | < 25 ppmMBE/K < 0,05
Largest short-term deviation during a specified electrical interference test |  | tbd %FSV | tbd %FSV | tbd %FSV |  | tbd %FSV
Input impedance ±Input 1 | Differential | tbd | tbd | tbd |  | tbd
 | CommonMode | tbd | tbd | tbd |  | tbd
Input impedance ±Input 2 | 3 wire | No usage of this input in this mode
 | Differential | tbd typ. | tbd typ. | tbd typ. |  | tbd typ.
 | CommonMode | tbd typ. | tbd typ. | tbd typ. |  | tbd typ.
2) In real bridge measurement, an offset adjustment is usually carried out after installation. The given offset specification of the terminal is therefore practically irrelevant. Therefore, specification values with and without offset are given here. In practice, the offset component can be eliminated by the terminal functions Tare and also ZeroOffset or in the controller by a higher-level tare function. The offset deviation of a bridge measurement over time can change, therefore Beckhoff recommends a regular offset adjustment or careful observation of the change.
3) Values related to a common mode interference between SGND and internal ground.
Full bridge calculation:
The strain relationship (µStrain, µε) is as follows:


Measurement SG 1/2 bridge (half bridge) 3/5-wire connection

Product overview [image] ELM350x [image] ELM350x - Technical data [image] Measurement SG 1/2 bridge (half bridge) 3/5-wire connection
Measurement SG 1/2 bridge (half bridge) 3/5-wire connection
To determine the measuring error:
The nominal/technical measuring range is specified in "mV/V"; the maximum permitted supply voltage is 5 V. The maximum nominal measuring range that can be used for the bridge voltage is therefore ±16 mV/V * 5V = ±80 mV; the internal circuits are designed for the 160 mV of the full bridge measurement.
The internal measurement is ratiometric, i.e. the feed voltage and the bridge voltage are not measured absolutely, but as a ratio.
The integrated supply can be used as power supply. An external supply is permitted, as long as 5 V is not exceeded.
The following is the specification given for the 5 wire connection. External line resistances are compensated by the 5 wire connection and the half-bridge is detected directly from the measuring channel.
In the 3 wire connection, the terminal generally has the same specification, but its view of the connected half-bridge is clouded by the unclear and temperature-dependent lead resistances within cables and connectors. In this respect, the overall system "half-bridge + leads + measurement channel" will practically not achieve specification values given below. The lead resistances (cables, connectors, ...) have an effect especially on the gain error, also depending on the temperature.
The gain error can be estimated by (R+uv (1+ ∆T* TCCu) + R-uv(1+∆T* TCCu) )/Rnom with TCCu~3930 ppm/K, Rnom e.g. 350 Ω and R+uv or R-uv lead resistances respectively.
The use of the measurement channel in the 5 wire connection is recommended.
Note: specifications apply for 3.5 V SG excitation and symmetric 350R SG.
Note: Adjustment of the half-bridge measurement and thus validity of the data from production week 2018/ 50 and
▪
for ELM3502: HW03
▪
for ELM3504: HW04
Measurement mode |  | StrainGauge/SG ¼ Bridge 3/5 wire
 |  | 16 mV |  | 8 mV |  | 4 mV |  | 2 mV
Integrated power supply |  | 1…5 V adjustable, max. supply/excitation 21 mA (internal electronic overload protection) therefore 120R strain gauge: up to 2.5 V; 350R strain gauge: up to 5.0 V
Measuring range, nominal |  | -16 … 16 mV/V |  | -8 … 8 mV/V | -4 … 4 mV/V |  | -2 … 2 mV/V
Measuring range, end value (FSV) |  | 16 mV/V |  | 8 mV/V | 4 mV/V |  | 2 mV/V
Measuring range, technically usable |  | -17.179 … 17.179 mV/V |  | -8.589 … 8.589 mV/V | -4.294 … 4.294 mV/V |  | -2.147 … 2.147 mV/V
PDO resolution |  | 24 Bit (incl. sign)
PDO LSB (Extended Range) |  | 0.128 ppm
PDO LSB (Legacy Range) |  | 0.119… ppm
Basic accuracy: Measuring deviation at 23°C, with averaging | without offset 2) | < ±0.011%FSV < ±110 ppmFSV < ±1.76 µV/V | < ±0.022%FSV < ±220 ppmFSV < ±1.76 µV/V |  | < ±0.044%FSV < ±440 ppmFSV < ±1.76 µV/V |  | < ±0.0925%FSV < ±925 ppmFSV < ±1.85 µV/V
 | with offset 2) | < ±0.04%FSV < ±400 ppmFSV < ±6.40 µV/V | < ±0.075%FSV < ±750 ppmFSV < ±6.00 µV/V |  | < ±0.14%FSV < ±1400 ppmFSV < ±5.60 µV/V |  | < ±0.27%FSV < ±2700 ppmFSV < ±5.40 µV/V
Offset/Zero Point deviation (at 23°C) | EOffset | < 385 ppmFSV | < 715 ppmFSV |  | < 1325 ppmFSV |  | < 2530 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 70 ppm | < 130 ppm |  | < 260 ppm |  | < 510 ppm
Non-linearity over the whole measuring range | ELin | < 85 ppmFSV | < 175 ppmFSV |  | < 350 ppmFSV |  | < 760 ppmFSV
Repeatability (at 23°C) | ERep | < 12 ppmFSV | < 25 ppmFSV |  | < 50 ppmFSV |  | < 120 ppmFSV
Noise (without filtering, at 23°C) | ENoise, PtP | < 1100 ppmFSV < 8594 digits < 17.60 µV/V | < 2200 ppmFSV < 17188 digits < 17.60 µV/V |  | < 4400 ppmFSV < 34375 digits < 17.60 µV/V |  | < 8800 ppmFSV < 68750 digits < 17.60 µV/V
 | ENoise, RMS | < 150 ppmFSV < 1172 digits < 2.40 µV/V | < 300 ppmFSV < 2344 digits < 2.40 µV/V |  | < 600 ppmFSV < 4688 digits < 2.40 µV/V |  | < 1200 ppmFSV < 9375 digits < 2.40 µV/V
 | Max. SNR | > 76.5 dB | > 70.5 dB |  | > 64.4 dB |  | > 58.4 dB
 | Noisedensity@1kHz | < 33.94 | < 33.94 |  | < 33.94 |  | < 33.94
Noise (with 50 Hz FIR filter, at 23°C) | ENoise, PtP | < 150 ppmFSV < 1172 digits < 2.40 µV/V | < 300 ppmFSV < 2344 digits < 2.40 µV/V |  | < 600 ppmFSV < 4688 digits < 2.40 µV/V |  | < 1200 ppmFSV < 9375 digits < 2.40 µV/V
 | ENoise, RMS | < 25.0 ppmFSV < 195 digits < 0.40 µV/V | < 50.0 ppmFSV < 391 digits < 0.40 µV/V |  | < 100.0 ppmFSV < 781 digits < 0.40 µV/V |  | < 200 ppmFSV < 1563 digits < 0.40 µV/V
 | Max. SNR | > 92.0 dB | > 86.0 dB |  | > 80.0 dB |  | > 74.0 dB
Common-mode rejection ratio (without filtering)3 |  | tbd | tbd |  | tbd |  | tbd
Common-mode rejection ratio (with 50Hz filtering)3 |  | tbd | tbd |  | tbd |  | tbd
Temperature coefficient | TcGain | < 5 ppm/K | < 8 ppm/K |  | < 15 ppm/K |  | < 25 ppm/K
 | TcOffset | < 15 ppmFSV/K < 0.24 µV/V/K | < 25 ppmFSV/K < 0.20 µV/V/K |  | < 45 ppmFSV/K < 0.18 µV/V/K |  | < 90 ppmFSV/K < 0.18 µV/V/K
Largest short-term deviation during a specified electrical interference test |  | tbd %FSV | tbd %FSV |  | tbd %FSV |  | tbd %FSV
Input impedance ±Input 1 | Differential | tbd | tbd |  | tbd |  | tbd
 | CommonMode | tbd | tbd |  | tbd |  | tbd
Input impedance ±Input 2 | 3 wire | No usage of this input in this mode
 | Differential | tbd typ. | tbd typ. |  | tbd typ. |  | tbd typ.
 | CommonMode | tbd typ. | tbd typ. |  | tbd typ. |  | tbd typ.
2) In real bridge measurement, an offset adjustment is usually carried out after installation. The given offset specification of the terminal is therefore practically irrelevant. Therefore, specification values with and without offset are given here. In practice, the offset component can be eliminated by the terminal functions Tare and also ZeroOffset or in the controller by a higher-level tare function. The offset deviation of a bridge measurement over time can change, therefore Beckhoff recommends a regular offset adjustment or careful observation of the change.
3) Values related to a common mode interference between SGND and internal ground.
Note
Transition resistances of the terminal contacts
The transition resistance values of the terminal contacts affect the measurement. The measuring accuracy can be further increased by a user-side adjustment with the signal connection plugged in.
Validity of property values
The resistor of the bridge is positioned parallel to the internal resistor of the terminal and leads to an offset shifting respectively. The Beckhoff factory calibration will be carried out with the half bridge 350 Ω, thus the values specified above are directly valid for the 350 Ω half bridge. By connection of another dimensioned half-bridge is to:
•
perform a balancing (offset correction) by the terminal itself or the control/PLC on application side
•
or the abstract offset error have to be entered into the balancing parameter S0 of the terminal. Example: a 350 Ω half bridge correlates by the compensated effect of the input resistor (2 MΩ) during factory calibration 0.26545 %FSV (16 mV/V), that corresponds to 20738 digits.
Half bridge calculation:
R3/4 are the internal switchable input resistors of the terminal. Other configurations (e.g. R1/4 or R1/3 variable) of half bridges are not supported.
The strain relationship (µStrain, µε) is as follows:
N should be chosen based on the mechanical configuration of the variable resistors (Poisson, 2 active uniaxial, …). The channel value (PDO) is interpreted directly [mV/V]:


Measurement SG 1/4 bridge (quarter-bridge) 2/3-wire connection

Product overview [image] ELM350x [image] ELM350x - Technical data [image] Measurement SG 1/4 bridge (quarter-bridge) 2/3-wire connection
Measurement SG 1/4 bridge (quarter-bridge) 2/3-wire connection
Notes
▪
In practice, quarter-bridge measurement is not recommended in 2-wire mode. Common copper supply lines with inherent resistance (e.g. approx. 17 mΩ/m with 1 mm² stranded wire) and very high temperature sensitivity (approx. 4000 ppm/K, approx. 0.4%/K) have a significant influence on the calculation, which can only be corrected through continuous offset and gain adjustment. Only 3-wire operation should be used.
▪
Specifications apply to 5 V strain gauge excitation.
▪
Data valid from production week 21/2019 and for ELM3502: HW03, for ELM3504: HW04
▪
Specifications only apply when using ferrules and for cross-sections of 0.5 mm² or more. For smaller cross-sections, increased transition resistance is to be expected.
▪
Avoid repeated insertion/extraction of the push-in connectors in quarter-bridge operation, since this may increase the contact resistance
▪
Integrated power supply: 1…5 V adjustable, max. supply/excitation 21 mA (internal electronic overload protection)
Measurement mode |  | StrainGauge/SG ¼ Bridge 120 Ω 2/3 wire
 |  | 32 mV/V FSV |  | 8 mV/V FSV |  | 4 mV/V 5) (comp.) |  | 2 mV/V 5) (comp.)
Measuring range, nominal |  | ±32 mV/V [corresponds to ±64,000 µε at K=2] 120 ± 15.36 Ω |  | ±8 mV/V [corresponds to ±16,000 µε at K=2] 120 ± 3.84 Ω |  | ±4 mV/V [corresponds to ±8,000 µε at K=2] 120 ± 1.92 Ω |  | ±2 mV/V [corresponds to ±4,000 µε at K=2] 120 ± 0.96 Ω
Measuring range, end value (FSV) |  | 32 mV/V |  | 8 mV/V |  | 4 mV/V |  | 2 mV/V
Measuring range, technically usable |  | ±34.359... mV/V |  | ±8.589... mV/V |  | ±4.294... mV/V |  | ±2.147... mV/V
PDO resolution |  | 24 Bit (incl. sign)
PDO LSB (Extended Range) |  | 0.128 ppm 4.096 nV/V | 0.128 ppm 1.024 nV/V |  | 0.128 ppm 0.512 nV/V |  | 0.128 ppm 0.256 nV/V
PDO LSB (Legacy Range) |  | 0.119… ppm 3.814.. nV/V | 0.119… ppm 0.9535 nV/V |  | 0.119… ppm 0.47675 nV/V |  | 0.119… ppm 0.238375 nV/V
Basic accuracy: Measuring deviation at 23°C, with averaging | without offset 2) | < ±0.026%FSV < ±260 ppmFSV < ±8.3 µV/V | < ±0.08%FSV < ±800 ppmFSV < ±6.4 µV/V |  | < ±0.16%FSV < ±1600 ppmFSV < ±6.4 µV/V |  | < ±0.32%FSV < ±3200 ppmFSV < ±6.4 µV/V
 | with offset 2) | < ±0.1%FSV < ±1000 ppmFSV < ±32.0 µV/V | < ±0.4%FSV < ±4000 ppmFSV < ±32.0 µV/V |  | < ±0.8%FSV < ±8000 ppmFSV < ±32.0 µV/V |  | < ±1.6%FSV < ±16000 ppmFSV < ±32.0 µV/V
Offset/Zero Point deviation (at 23°C) | EOffset | < 960 ppmFSV | < 3920 ppmFSV |  | < 7840 ppmFSV |  | < 15680 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 160 ppm | < 440 ppm |  | < 880 ppm |  | < 1760 ppm
Non-linearity over the whole measuring range | ELin | < 200 ppmFSV | < 650 ppmFSV |  | < 1300 ppmFSV |  | < 2600 ppmFSV
Repeatability (at 23°C) | ERep | < 25 ppmFSV | < 100 ppmFSV |  | < 200 ppmFSV |  | < 400 ppmFSV
Noise (without filtering, at 23°C) | ENoise, PtP | < 310 ppmFSV < 2422 digits < 9.92 µV/V | < 1200 ppmFSV < 9375 digits < 9.60 µV/V |  | < 2400 ppmFSV < 18750 digits < 9.60 µV/V |  | < 4800 ppmFSV < 37500 digits < 9.60 µV/V
 | ENoise, RMS | < 50 ppmFSV < 391 digits < 1.60 µV/V | < 200 ppmFSV < 1563 digits < 1.60 µV/V |  | < 400 ppmFSV < 3125 digits < 1.60 µV/V |  | < 800 ppmFSV < 6250 digits < 1.60 µV/V
 | Max. SNR | > 86.0 dB | > 74.0 dB |  | > 68.0 dB |  | > tbd dB
 | Noisedensity@1kHz | < 0.02 | < 0.02 |  | < 0.02 |  | < 0.02
Noise (with 50 Hz FIR filter, at 23°C) | ENoise, PtP | < 24 ppmFSV < 188 digits < 0.77 µV/V | < 72 ppmFSV < 563 digits < 0.58 µV/V |  | < 144 ppmFSV < 1125 digits < 0.58 µV/V |  | < 288 ppmFSV < 2250 digits < 0.58 µV/V
 | ENoise, RMS | < 4.0 ppmFSV < 31 digits < 0.13 µV/V | < 12.0 ppmFSV < 94 digits < 0.10 µV/V |  | < 24.0 ppmFSV < 188 digits < 0.10 µV/V |  | < 48.0 ppmFSV < 375 digits < 0.10 µV/V
 | Max. SNR | > 108.0 dB | > 98.4 dB |  | > 92.4 dB |  | > 86.4 dB
Common-mode rejection ratio (without filtering)3 |  | tbd | tbd |  | tbd |  | tbd
Common-mode rejection ratio (with 50Hz filtering)3 |  | tbd | tbd |  | tbd |  | tbd
Temperature coefficient | TcGain | < 20 ppm/K | < 48 ppm/K |  | < 96 ppm/K |  | < 192 ppm/K
 | TcOffset | < 50 ppmFSV/K < 1.60 µV/V/K | < 180 ppmFSV/K < 1.44 µV/V/K |  | < 360 ppmFSV/K < 1.44 µV/V/K |  | < 720 ppmFSV/K < 1.44 µV/V/K
Largest short-term deviation during a specified electrical interference test |  | tbd %FSV | tbd %FSV |  | tbd %FSV |  | tbd %FSV
Input impedance ±Input 1 | Differential | tbd | tbd |  | tbd |  | tbd
 | CommonMode | tbd | tbd |  | tbd |  | tbd
Input impedance ±Input 2 | 3 wire | No usage of this input in this mode
 | Differential | tbd typ. | tbd typ. |  | tbd typ. |  | tbd typ.
 | CommonMode | tbd typ. | tbd typ. |  | tbd typ. |  | tbd typ.
Measurement mode |  | StrainGauge/SG ¼ Bridge 350 Ω 2/3 wire
 |  | 32 mV/V FSV |  | 8 mV/V FSV |  | 4 mV/V 5) (comp.) |  | 2 mV/V 5) (comp.)
Measuring range, nominal |  | ±32 mV/V [corresponds to ±64,000 µε at K=2] 120 ± 15.36 Ω |  | ±8 mV/V [corresponds to ±16,000 µε at K=2] 120 ± 3.84 Ω |  | ±4 mV/V [corresponds to ±8,000 µε at K=2] 120 ± 1.92 Ω |  | ±2 mV/V [corresponds to ±4,000 µε at K=2] 120 ± 0.96 Ω
Measuring range, end value (FSV) |  | 32 mV/V |  | 8 mV/V |  | 4 mV/V |  | 2 mV/V
Measuring range, technically usable |  | ±34.359... mV/V |  | ±8.589... mV/V |  | ±4.294... mV/V |  | ±2.147... mV/V
PDO resolution |  | 24 Bit (incl. sign)
PDO LSB (Extended Range) |  | 0.128 ppm 4.096 nV/V | 0.128 ppm 1.024 nV/V |  | 0.128 ppm 0.512 nV/V |  | 0.128 ppm 0.256 nV/V
PDO LSB (Legacy Range) |  | 0.119… ppm 3.814.. nV/V | 0.119… ppm 0.9535 nV/V |  | 0.119… ppm 0.47675 nV/V |  | 0.119… ppm 0.238375 nV/V
Basic accuracy: Measuring deviation at 23°C, with averaging | without offset 2) | < ±0.022%FSV < ±220 ppmFSV < ±7.0 µV/V | < ±0.08%FSV < ±800 ppmFSV < ±6.4 µV/V |  | < ±0.16%FSV < ±1600 ppmFSV < ±6.4 µV/V |  | < ±0.32%FSV < ±3200 ppmFSV < ±6.4 µV/V
 | with offset 2) | < ±0.1%FSV < ±1000 ppmFSV < ±32.0 µV/V | < ±0.4%FSV < ±4000 ppmFSV < ±32.0 µV/V |  | < ±0.8%FSV < ±8000 ppmFSV < ±32.0 µV/V |  | < ±1.6%FSV < ±16000 ppmFSV < ±32.0 µV/V
Offset/Zero Point deviation (at 23°C) | EOffset | < 970 ppmFSV | < 3920 ppmFSV |  | < 7840 ppmFSV |  | < 15680 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 120 ppm | < 380 ppm |  | < 760 ppm |  | < 1520 ppm
Non-linearity over the whole measuring range | ELin | < 180 ppmFSV | < 690 ppmFSV |  | < 1380 ppmFSV |  | < 2760 ppmFSV
Repeatability (at 23°C) | ERep | < 25 ppmFSV | < 100 ppmFSV |  | < 200 ppmFSV |  | < 400 ppmFSV
Noise (without filtering, at 23°C) | ENoise, PtP | < 320 ppmFSV < 2500 digits < 10.24 µV/V | < 1200 ppmFSV < 9375 digits < 9.60 µV/V |  | < 2400 ppmFSV < 18750 digits < 9.60 µV/V |  | < 4800 ppmFSV < 37500 digits < 9.60 µV/V
 | ENoise, RMS | < 55 ppmFSV < 430 digits < 1.76 µV/V | < 200 ppmFSV < 1563 digits < 1.60 µV/V |  | < 400 ppmFSV < 3125 digits < 1.60 µV/V |  | < 800 ppmFSV < 6250 digits < 1.60 µV/V
 | Max. SNR | > 85.2 dB | > 74.0 dB |  | > 68.0 dB |  | > 61.9 dB
 | Noisedensity@1kHz | < 0.02 | < 0.02 |  | < 0.02 |  | < 0.02
Noise (with 50 Hz FIR filter, at 23°C) | ENoise, PtP | < 18 ppmFSV < 141 digits < 0.58 µV/V | < 72 ppmFSV < 563 digits < 0.58 µV/V |  | < 144 ppmFSV < 1125 digits < 0.58 µV/V |  | < 288 ppmFSV < 2250 digits < 0.58 µV/V
 | ENoise, RMS | < 3.0 ppmFSV < 23 digits < 0.10 µV/V | < 12.0 ppmFSV < 94 digits < 0.10 µV/V |  | < 24.0 ppmFSV < 188 digits < 0.10 µV/V |  | < 48.0 ppmFSV < 375 digits < 0.10 µV/V
 | Max. SNR | < 18 ppmFSV < 141 digits < 0.58 µV/V | < 72 ppmFSV < 563 digits < 0.58 µV/V |  | < 144 ppmFSV < 1125 digits < 0.58 µV/V |  | < 288 ppmFSV < 2250 digits < 0.58 µV/V
Common-mode rejection ratio (without filtering)3 |  | tbd | tbd |  | tbd |  | tbd
Common-mode rejection ratio (with 50Hz filtering)3 |  | tbd | tbd |  | tbd |  | tbd
Temperature coefficient | TcGain | < 12 ppm/K | < 50 ppm/K |  | < 100 ppm/K |  | < 200 ppm/K
 | TcOffset | < 30 ppmFSV/K < 0.96 µV/V/K | < 110 ppmFSV/K < 0.88 µV/V/K |  | < 220 ppmFSV/K < 0.88 µV/V/K |  | < 440 ppmFSV/K < 0.88 µV/V/K
Largest short-term deviation during a specified electrical interference test |  | tbd %FSV | tbd %FSV |  | tbd %FSV |  | tbd %FSV
Input impedance ±Input 1 | Differential | tbd | tbd |  | tbd |  | tbd
 | CommonMode | tbd | tbd |  | tbd |  | tbd
Input impedance ±Input 2 | 3 wire |
 | Differential | tbd typ. | tbd typ. |  | tbd typ. |  | tbd typ.
 | CommonMode | tbd typ. | tbd typ. |  | tbd typ. |  | tbd typ.
Measurement mode |  | StrainGauge/SG ¼ Bridge 1 kΩ (2/3 wire)
 |  | 32 mV/V FSV |  | 8 mV/V FSV | 4 mV/V FSV 5) (comp.) | 2 mV/V FSV 5) (comp.)
Measuring range, nominal |  | ±32 mV/V [corresponds to ±64,000 µε at K=2] 1000 ± 128 Ω |  | ±8 mV/V [corresponds to ±16,000 µε at K=2] 1000 ± 32 Ω | ±4 mV/V [corresponds to ±8,000 µε at K=2] 1000 ± 16 Ω | ±2 mV/V [corresponds to ±4,000 µε at K=2] 1000 ± 8 Ω
Measuring range, end value (FSV) |  | 32 mV/V 128 Ω |  | 8 mV/V 32 Ω | 4 mV/V 16 Ω | 2 mV/V 8 Ω
Measuring range, technically usable |  | ±34.359... mV/V |  | ±8.589... mV/V | ±4.294... mV/V | ±2.147... mV/V
PDO resolution |  | 24 Bit (incl. sign)
PDO LSB (Extended Range) |  | 0.128 ppm 4.096 nV/V |  | 0.128 ppm 1.024 nV/V | 0.128 ppm 0.512 nV/V | 0.128 ppm 0.256 nV/V
PDO LSB (Legacy Range) |  | 0.119… ppm 3.814.. nV/V |  | 0.119… ppm 0.9535 nV/V | 0.119… ppm 0.47675 nV/V | 0.119… ppm 0.238375 nV/V
Basic accuracy: Measuring deviation at 23°C, with averaging | without offset 2) | < ±0.02 %FSV < ±200 ppmFSV < ±6.4 µV/V |  | < ±0.065%FSV < ±650 ppmFSV < ±5.2 µV/V | < ±0.13%FSV < ±1300 ppmFSV < ±5.2 µV/V | < ±0.26%FSV < ±2600 ppmFSV < ±5.2 µV/V
 | with averaging | < ±0.1%FSV < ±1000 ppmFSV < ±32 µV/V |  | < ±0.4%FSV < ±4000 ppmFSV < ±32 µV/V | < ±0.8%FSV < ±8000 ppmFSV < ±32 µV/V | < ±1.6%FSV < ±16000 ppmFSV < ±32 µV/V
Offset/Zero Point deviation (at 23°C) | EOffset | < 980 ppmFSV |  | < 3940 ppmFSV | < 7880 ppmFSV | < 15760 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 105 ppm |  | < 305 ppm | < 610 ppm | < 1220 ppm
Non-linearity over the whole measuring range | ELin | < 165 ppmFSV |  | < 560 ppmFSV | < 1120 ppmFSV | < 2240 ppmFSV
Repeatability (at 23°C) | ERep | < 25 ppmFSV |  | < 120 ppmFSV | < 240 ppmFSV | < 480 ppmFSV
Noise (without filtering, at 23°C) | ENoise, PtP | < 400 ppmFSV < 3125 digits < 12.80 µV/V |  | < 1350 ppmFSV < 10547 digits < 10.80 µV/V | < 2700 ppmFSV < 21094 digits < 10.80 µV/V | < 5400 ppmFSV < 42188 digits < 10.80 µV/V
 | ENoise, RMS | < 65 ppmFSV < 508 digits < 2.08 µV/V |  | < 240 ppmFSV < 1875 digits < 1.92 µV/V | < 480 ppmFSV < 3750 digits < 1.92 µV/V | < 960 ppmFSV < 7500 digits < 1.92 µV/V
 | Max. SNR | > 83.7 dB |  | > 72.4 dB | > 66.4 dB | > 60.4 dB
 | Noisedensity@1kHz | 0.03 |  | 0.03 | 0.03 | 0.03
Noise (with 50 Hz FIR filter, at 23°C) | ENoise, PtP | < 60 ppmFSV < 469 digits < 1.92 µV/V |  | < 240 ppmFSV < 1875 digits < 1.92 µV/V | < 480 ppmFSV < 3750 digits < 1.92 µV/V | < 960 ppmFSV < 7500 digits < 1.92 µV/V
 | ENoise, RMS | < 10.0 ppmFSV < 78 digits < 0.32 µV/V |  | < 40.0 ppmFSV < 313 digits < 0.32 µV/V | < 80.0 ppmFSV < 625 digits < 0.32 µV/V | < 160.0 ppmFSV < 1250 digits < 0.32 µV/V
 | Max. SNR | > 100.0 dB |  | > 88.0 dB | > 81.9 dB | > 75.9 dB
Common-mode rejection ratio (without filtering)3 |  | tbd |  | tbd | tbd | tbd
Common-mode rejection ratio (with 50Hz filtering)3 |  | tbd |  | tbd | tbd | tbd
Temperature coefficient, typ | TcGain | < 13 ppm/K |  | < 25 ppm/K | < 50 ppm/K | < 100 ppm/K
 | TcOffset | < 60 ppmFSV/K < 1.92 µV/V/K |  | < 230 ppmFSV/K < 1.84 µV/V/K | < 460 ppmFSV/K < 1.84 µV/V/K | < 920 ppmFSV/K < 1.84 µV/V/K
Largest short-term deviation during a specified electrical interference test |  | tbd %FSV |  | tbd %FSV | tbd %FSV | tbd %FSV
Input impedance ±Input 1 | Differential | tbd |  | tbd | tbd | tbd
 | CommonMode | tbd |  | tbd | tbd | tbd
Input impedance ±Input 2 | 3 wire | No usage of this input in this mode
 | Differential | tbd typ. | tbd typ. |  | tbd typ. | tbd typ.
 | CommonMode | tbd typ. | tbd typ. |  | tbd typ. | tbd typ.
2) In real bridge measurement, an offset adjustment is usually carried out after installation. The given offset specification of the terminal is therefore practically irrelevant. Therefore, specification values with and without offset are given here. In practice, the offset component can be eliminated by the terminal functions Tare and also ZeroOffset or in the controller by a higher-level tare function. The offset deviation of a bridge measurement over time can change, therefore Beckhoff recommends a regular offset adjustment or careful observation of the change.
3) Values refer to common-mode interference between SGND and internal GND.
4) The offset specification does not apply to 2-wire operation, since the offset is increased on the device side. Offset adjustment is recommended, see Tare or Zero offset function.
5) The channel measures electrically to 8 [image], but displays its measured value scaled to 2 or 4 [image]. The Compensated function facilitates measurement of low levels even with high offset.
Note
Transition resistances of the terminal contacts
The transition resistance values of the terminal contacts affect the measurement. The measuring accuracy can be further increased by a user-side adjustment with the signal connection plugged in.
The temperature sensitivity of the terminal and thus of the measurement setup can be reduced if an external, more temperature-stable supplementary resistor is used for terminal operation in half-bridge or even full-bridge mode instead of the internal supplementary resistor for quarter-bridge mode.
To calculate the quarter-bridge:
R2/3/4 are the terminal-internal switchable supplementary resistors, R1 is the (nominally equal-sized) variable quarter-bridge.
The strain relationship (µStrain, µε) is as follows:
For the quarter-bridge, N=1 always applies.
The relationship between UIN/UV and R1 is non-linear:
The ELM350x devices apply internal linearization so that the output is already linearized
since the internal calculation is based on UV'.


ELM354x

Product overview [image] ELM354x
ELM354x
Additional information
•
ELM354x - Introduction
•
ELM354x - Technical data


ELM354x - Introduction

Product overview [image] ELM354x [image] ELM354x - Introduction
ELM354x - Introduction
ELM3542-0000, ELM3544-0000
2 and 4 channel measuring bridge analysis, full/half/quarter bridge, 24 bit, 1 ksps, TEDS
The ELM3542 and ELM3544 EtherCAT Terminals from the ELM3x4x economy series are designed for the evaluation of measuring bridges in full bridge, half bridge and quarter bridge configuration. With a maximum data rate of 1 ksps per channel they are ideally suited for the recording of less dynamic procedures, such as slow oscillations and corresponding weighing procedures. In return, they measure with extremely low noise and are temperature-stable up to an ambient temperature of 60 °C. The integrated bridge supply can supply 1 to 12 V and, like all other parameters, is adjustable online in the CoE at runtime. In addition, the ELM3542 features a connection for one TEDS‑IC in the sensor per channel – this way the SG can be electronically read, detected and also written immediately upon plugging in. Apart from that, the ELM354x have all the features familiar from the fast ELM350x basic series, such as internally switchable extension resistors and comprehensive sensor and function diagnostics for industrial 24/7 operation. The 6‑pin connector (push-in) is removable for maintenance purposes without releasing the individual wires.
Available on request as variant with factory calibration certificate or ISO 17025‑/DAkkS-compliant certificate including Beckhoff recalibration service.
Quick-Links
• EtherCAT basics
• Mounting and wiring
• Process data overview
• Connection view
• Object description and parameterization


ELM354x - Technical data

Product overview [image] ELM354x [image] ELM354x - Technical data
ELM354x - Technical data
Technical data | ELM3542 | ELM3544
Analog inputs | 2 channel (differential) | 4 channel (differential)
Time relation between channels to each other | Successive conversion of all channels in the terminal (multiplex), synchronous conversion between terminals, if DistributedClocks will be used. Timestamp each channel, typ. sampling offset related to cannel 1:
 | Ch.1: 0 ms Ch.2: +200 µs z (t.b.d.) | Ch.1: 0 ms Ch.2: +200 µs Ch.3: +400 µs Ch.4: +600 µs
ADC conversion method | ΔΣ (deltaSigma) with internal sample rate 8 msps
Limit frequency input filter hardware (see information in section ELM Features/ Firmware filter concept) | Before AD converter: hardware low pass -3dB @ 380 kHz (16.544 kHz for quarter bridge in 4 wire connection) (tbd.) type butterworth 1th order Within ADC after conversion: low pass -3dB @ 2.75 kHz type sinc5/average filter or sinc3 (tbd.)
 | The ramp-up time/ settling time/ delay caused by the filtering will be considered within the DistributedClocks-Timestamp.
Resolution | 24 Bit (including sign)
Connection technology | 2/ 3 / 4 / 5 / 6/ 7 wire | 2/ 3 / 4 / 5 / 6 wire
Connection type | push-in cageclamp, service plug, 6-pin
Sampling rate (per channel, simultaneous) | 1 ms/1 kSps
 | free down sampling by Firmware via decimation factor, possible effective sampling interval each channel: 1 ms + n*25 µs (tbd.)
Oversampling | 1…20 selectable
Supported EtherCAT cycle time (depending on the operation mode) | DistributedClocks: min. 100 µs, max. 10 ms (tbd.) FrameTriggered/Synchron: min. 200 µs, max. 100 ms (tbd.) FreeRun: not yet supported
Operation range DMS | Quarter bridge (1 kΩ, 350 Ω, 120 Ω) half bridge, full bridge, internal bridge extension and feeding-in supply adjustable (tbd.)
Connection diagnosis | Preliminary information (tbd.): Channel-by-channel open-circuit detection of the connection cables (running operation or triggered diagnosis, up to 6 wires) Channel by channel short-circuit detection of all lines among each other (triggered diagnosis, up to 6 lines) Additional process data and diagnostic evaluation of the connected sensor via TEDS interface
Surge voltage protection of the inputs related to ‑Uv (internal ground) | tbd
Special features | Bridge feeding-in supply free adjustable 1.5 V to 12 V (electronic overload protection 120 mA each channel) tbd. 2 wire TEDS interface (IEEE 1451.4 class 2 MMI, multiplex-operation) External shunt calibration possible | Bridge feeding-in supply free adjustable 1.5 V to 12 V (electronic overload protection 65 mA each channel) tbd.
Current consumption via E-bus | 50 mA typ. (tbd) | 50 mA typ. (tbd)
Current consumption via power contacts | 60 mA typ. + Load, total max. 150 mA typ. | 70 mA typ. + Load, total max. 240 mA typ.
Thermal power dissipation | typ. 3 W
Dielectric strength - destruction limit | max. permitted short-term/continuous voltage between contact points ±I1, ±I2, +Uv and –Uv: non-supplied ±30 V, supplied ±30 V (tbd.) Note: -Uv corresponds to internal AGND
Recommended operation voltage range to compliance with specification | tbd.
Electrical isolation channel/channel *) | no
Electrical isolation channel/Ebus *) | yes, 500V/1min.typ. test
Electrical isolation channel/SGND *) | yes, 500V/1min.typ. test
Weight | approx. 350 g
Permissible ambient temperature range during operation | -25…+60 °C | -25…+55 °C
Permissible ambient temperature range during storage | -40…+85 °C
*) see notes to potential groups in chapter “Mounting and wiring/ Power supply, potential groups”
Overview measurement ranges (ELM354x):
Measurement | Connection technology | FSV | Mode | Maximum value/ value range
Full bridge | 4/6 wire | ±32 mV/V | Extended | ±34.359.. mV/V
 |  |  | Legacy | ±32 mV/V
 |  | ±8 mV/V | Extended | ±8.5899.. mV/V
 |  |  | Legacy | ±8 mV/V
 |  | ±4 mV/V | Extended | ±4.2949.. mV/V
 |  |  | Legacy | ±4 mV/V
 |  | ±2 mV/V | Extended | ±2.1474.. mV/V
 |  |  | Legacy | ±2 mV/V
Half bridge | 3/5 wire | ±16 mV/V | Extended | ±17.179.. mV/V
 |  |  | Legacy | ±16 mV/V
 |  | ±8 mV/V | Extended | ±8.5899.. mV/V
 |  |  | Legacy | ±8 mV/V
 |  | ±4 mV/V | Extended | ±4.2949.. mV/V
 |  |  | Legacy | ±4 mV/V
 |  | ±2 mV/V | Extended | ±2.1474.. mV/V
 |  |  | Legacy | ±2 mV/V
Quarter bridge 120/350/1000 Ω | 2/3 wire | ±32 mV/V | Extended | ±34.359.. mV/V
 |  |  | Legacy | ±32 mV/V
 |  | ±8 mV/V | Extended | ±8.5899.. mV/V
 |  |  | Legacy | ±8 mV/V
 |  | ±4 mV/V | Extended | ±4.2949.. mV/V
 |  |  | Legacy | ±4 mV/V
 |  | ±2 mV/V | Extended | ±2.1474.. mV/V
 |  |  | Legacy | ±2 mV/V
Overview measurement ranges, Bipolar
Overview measurement ranges, Unipolar
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


ELM360x

Product overview [image] ELM360x
ELM360x
Additional information
•
ELM360x - Introduction
•
ELM360x - Technical data


ELM360x - Introduction

Product overview [image] ELM360x [image] ELM360x - Introduction
ELM360x - Introduction
ELM3602-0002, ELM3604-0002, ELM3602-0000, ELM3604-0000
2 and 4 channel IEPE analysis, 24 bit, 20/ 50 ksps, BNC
The ELM360x EtherCAT Terminals are designed for the evaluation of IEPE sensors (Integrated Electronics Piezo-Electric) with and without TEDS, which are mainly used for vibration diagnostics and acoustics. The constant current feed can be set to 0/2/4 mA. The input characteristics are also flexibly adjustable from DC to 10 Hz as high pass filter. The ELM360x basically measures sensor voltages (single ended) up to 20 V AC/DC, but the internal scaler function can be used if, for example, an output in acceleration [m/s²] is desired. The TEDS data of a sensor can be read out and written.
Possible applications:
▪
Acquisition of AC voltage from IEPE sensors (oscillation measurement, acustics)
▪
Measurement of mV voltages over current shunts (AC/DC)
Note: due to single ended configuration possible on low side shunts only
▪
Common measurement of voltages up to 20 V single ended (AC/DC)
Irrespective of the signal configuration, all ELM3x0x modules have the same functional properties. The ELM360x modules for IEPE evaluation offer a maximum sampling rate of 20,000 or 50,000 samples per second.
Two connector variants were offered: due to IEPE sensors are often connected via coaxial cables, the ELM360x-0002 modules features BNC connectors; the ELM360x-0000 provides the control‑cabinet‑friendly PushIn. In strong EMC burdened environments, the PushIn connector can be preferred because here shield and signal ground can be performed separately.
The variant with factory calibration certificate ELM360x‑002x and a recalibration service for the ELM series are in preparation.
Quick-Links
• EtherCAT basics
• Mounting and wiring
• Process data overview
• Connection view
• Object description and parameterization


ELM360x - Technical data

Product overview [image] ELM360x [image] ELM360x - Technical data
ELM360x - Technical data
Technical data
ELM3602-000x
ELM3604-000x
Analog inputs
2 channel (single ended)
4 channel (single ended)
Time relation between channels to each other
Simultaneous conversion of all channels in the terminal, synchronous conversion between terminals, if DistributedClocks will be used
ADC conversion method
deltaSigma ΔΣ with internal sample rate
8 MSps
5.12 MSps
Limit frequency input filter hardware
(see information in section
ELM Features/ Firmware filter concept)
Before AD converter:
hardware low pass -3dB @ 30 kHz
type butterworth 3th order
Within ADC after conversion:
low pass -3dB @ 13.6 kHz, ramp-up time 60 µs
low pass -3dB @ 5.3 kHz, ramp-up time 150 µs
type sinc3/average filter
The ramp-up time/ settling time/ delay caused by the filtering will be considered within the DistributedClocks-Timestamp.
Resolution
24 Bit (including sign)
Connection technology
2 wire
Connection type
Variant ELM360x-0000:
push-in cageclamp, service plug, 2-pin
Variant ELM360x-0002:
BNC, shielded (shield is the analog ground, electrically isolated from housing)
Sampling rate (per channel)
20 µs/50 kSps
50 µs/20 kSps
free down sampling by Firmware via decimation factor
Oversampling
1…100 selectable
Type of sampling
Simultaneous (all channels simultaneously)
Supported EtherCAT cycle time
(depending on the operation mode)
DistributedClocks: min. 100 µs, max. 10 ms
FrameTriggered/Synchron: min. 200 µs, max. 100 ms
FreeRun: not supported
Internal resistance
>2 MΩ
Operation range IEPE
Current feeding 2 + 4 mA, which can be switched off
TEDS supported
Acquiring of the modulated AC voltage
AC/DC Coupling (configurable parameters of high pass)
Connection diagnosis
Wire break/short cut
Surge voltage protection of the inputs related to GND
Input1: at > +24 V and < -8 V respectively
Current consumption via E-bus
typ. 460 mA
typ. 650 mA
Thermal power dissipation
typ. 3 W
Dielectric strength - destruction limit
max. permitted short-term/continuous voltage
▪
Voltage between each contact point ±I1, ±I2, +Uv and ‑Uv: non-supplied ±40 V, supplied ±36 V
▪
Voltage between every contact point and SGND (shield, mounting rail): ±36 V
Note: -Uv corresponds to internal AGND
Recommended operation voltage range to compliance with specification
max. permitted voltage during specified normal operation
▪
±I1 and ±I2: typ. ±10 V against –Uv
▪
For ELM360x
related to GND: -5...+21.5 V
Note: -Uv corresponds to internal AGND
Electrical isolation channel/channel *)
no
Electrical isolation channel/Ebus *)
yes, 500V/1min.typ. test
Electrical isolation channel/SGND *)
no
Weight
approx. 350 g
Permissible ambient temperature range during operation
-25…+60 °C
Permissible ambient temperature range during storage
-40…+85 °C
*) see notes to potential groups in chapter “Mounting and wiring/ Power supply, potential groups”
Overview measurement ranges (ELM360x):
The ELM360x can measure with respect to GND in the range of -5 V...+21.5 V.
Measurement | Connection technology | FSV | Mode | Maximum value/ value range
Voltage | 2 wire | ±10 V )* | Extended | ±10.737.. V
 |  |  | Legacy | ±10 V
 |  | ±5 V | Extended | ±5.368.. V
 |  |  | Legacy | ±5 V
 |  | ±2.5 V | Extended | ±2.684.. V
 |  |  | Legacy | ±2.5 V
 |  | ±1.25 V | Extended | ±1.490.. V
 |  |  | Legacy | ±1.25 V
 |  | ±640 mV | Extended | ±687.2.. mV
 |  |  | Legacy | ±640 mV
 |  | ±320 mV | Extended | ±343.6.. mV
 |  |  | Legacy | ±320 mV
 |  | ±160 mV | Extended | ±171.8.. mV
 |  |  | Legacy | ±160 mV
 |  | ±80 mV | Extended | ±85.9.. mV
 |  |  | Legacy | ±80 mV
 |  | ±40 mV | Extended | ±42.95.. mV
 |  |  | Legacy | ±40 mV
 |  | ±20 mV | Extended | ±21.474.. mV
 |  |  | Legacy | ±20 mV
*) The input voltage must not fall below -5 V with respect to GND, the measuring accuracy is then no longer given. This means a measurement down to -10 V with respect to GND is only possible if at the same time an offset of at least +5 V is applied, as is usual with IEPE supply.
Measurement | Connection technology | FSV | Mode | Maximum value/ value range
Voltage | 2 wire | +10 V | Extended | 0…10.737.. V
 |  |  | Legacy | 0…10 V
 |  | +20 V | Extended | 0…21.474.. V
 |  |  | Legacy | 0…20 V
Overview measurement ranges, Bipolar
Overview measurement ranges, Unipolar
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.
Additional information
•
IEPE high pass properties
•
Measurement ±10 V
•
Measurement ±5 V
•
Measurement ±2.5 V
•
Measurement ±1.25 V
•
Measurement ±640 mV
•
Measurement ±320 mV
•
Measurement ±160 mV
•
Measurement ±80 mV
•
Measurement ±40 mV
•
Measurement ±20 mV
•
Measurement 0…10 V
•
Measurement 0…20 V


IEPE high pass properties

Product overview [image] ELM360x [image] ELM360x - Technical data [image] IEPE high pass properties
IEPE high pass properties
For optional regulation of the IEPE bias voltage, the ELM360x has an adjustable 1 st order high-pass filter. See also section "IEPE AC Coupling".
The typical frequency response in the 2.5 V measuring range is as follows:
Note: if other dynamic filter properties are desired, proceed as follows:
▪
Operate the terminal ELM360x in the measuring range „0..20V“
▪
Deactivate IEPE AC coupling in the respective channel
▪
The channel now measures with 23 bit + sign over 20 V, including the bias voltage which is usually 10..16 V. With a user implementation of a high-pass filter using TwinCAT programming (within the PLC), the bias component (DC component) can now be suppressed on the control side. The now reduced signal resolution of the measuring range ±2.5 V with 24 bits to 20 V with 23 bits has to be considered. In return, the user receives full digital control over the behavior in the lower frequency range.


Measurement ±10 V

Product overview [image] ELM360x [image] ELM360x - Technical data [image] Measurement ±10 V
Measurement ±10 V
Measurement mode | ±10 V
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -10…+10 V *)
Measuring range, end value (full scale value) | 10 V
Measuring range, technically usable | -10.737…+10.737 V *)
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 1.28 µV | 327.68 µV
PDO LSB (Legacy Range) | 1.192.. µV | 305.18.. µV
*) The input voltage must not fall below -5 V with respect to GND, the measuring accuracy is then no longer given. This means a measurement down to -10 V with respect to GND is only possible if at the same time an offset of at least +5 V is applied, as is usual with IEPE supply.
Preliminary specifications:
Measurement mode |  | ±10 V
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 60 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 2.55
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation ±10 V measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.
Freqresp_ELM3604_±10 V_20 ksps_filter_1_2_deactivated_en.png
Frequency response ELM3604, ±10 V measuring range, fsampling = 20 ksps, integrated filter 1 and 2 deactivated


Measurement ±5 V

Product overview [image] ELM360x [image] ELM360x - Technical data [image] Measurement ±5 V
Measurement ±5 V
Measurement mode | ±5 V
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -5…+5 V
Measuring range, end value (full scale value) | 5 V
Measuring range, technically usable | -5.368…+5.368 V
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 640 nV | 163.84 µV
PDO LSB (Legacy Range) | 596.. nV | 152.59.. µV
Preliminary specifications:
Measurement mode |  | ±5 V
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 1.27
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation ±5 V measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.
Freqresp_ELM3604_±5 V_20 ksps_filter_1_2_deactivated_en.png
Frequency response ELM3604, ±5 V measuring range, fsampling = 20 ksps, integrated filter 1 and 2 deactivated


Measurement ±2.5 V

Product overview [image] ELM360x [image] ELM360x - Technical data [image] Measurement ±2.5 V
Measurement ±2.5 V
Measurement mode | ±2.5 V
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -2.5…+2.5 V
Measuring range, end value (full scale value) | 2.5 V
Measuring range, technically usable | -2.684…+2.684 V
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 320 nV | 81.92 µV
PDO LSB (Legacy Range) | 298.. nV | 76.29.. µV
Preliminary specifications:
Measurement mode |  | ±2.5 V
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 90 ppmFSV |  | < 703 [digits]
 | ENoise, RMS | < 17 ppmFSV |  | < 133 [digits]
 | Max. SNR | > 95.4 dB
 | Noisedensity@1kHz | < 0.60
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 9 ppmFSV |  | < 70 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation ±2.5 V measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.
Freqresp_ELM3604_±2.5 V_20 ksps_filter_1_2_deactivated_en.png
Frequency response ELM3604, ±2.5 V measuring range, fsampling = 20 ksps, integrated filter 1 and 2 deactivated
Freqresp_ELM3604_±2.5 V_50 ksps_filter_1_2_deactivated_en.png
Frequency response ELM3602, ±2.5 V measuring range, fsampling = 50 ksps, integrated filter 1 and 2 deactivated


Measurement ±1.25 V

Product overview [image] ELM360x [image] ELM360x - Technical data [image] Measurement ±1.25 V
Measurement ±1.25 V
Measurement mode | ±1.25 V
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -1.25…+1.25 V
Measuring range, end value (full scale value) | 1.25 V
Measuring range, technically usable | -1.490…+1.490 V
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 160 nV | 40.96 µV
PDO LSB (Legacy Range) | 149.. nV | 38.14.. µV
Preliminary specifications:
Measurement mode |  | ±1.25 V
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 90 ppmFSV |  | < 703 [digits]
 | ENoise, RMS | < 17 ppmFSV |  | < 133 [digits]
 | Max. SNR | > 95.4 dB
 | Noisedensity@1kHz | < 0.30
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 9 ppmFSV |  | < 70 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation ±1.25 V measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.
Freqresp_ELM3604_±1.25 V_20 ksps_filter_1_2_deactivated_en.png
Frequency response ELM3604, ±1.25 V measuring range, fsampling = 20 ksps, integrated filter 1 and 2 deactivated


Measurement ±640 mV

Product overview [image] ELM360x [image] ELM360x - Technical data [image] Measurement ±640 mV
Measurement ±640 mV
Measurement mode | ±640 mV
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -640…+640 mV
Measuring range, end value (full scale value) | 640 mV
Measuring range, technically usable | -687.2…+687.2 mV
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 81.92 nV | 20.97152 µV
PDO LSB (Legacy Range) | 76.29.. nV | 19.53.. µV
Preliminary specifications:
Measurement mode |  | ±640 mV
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 90 ppmFSV |  | < 703 [digits]
 | ENoise, RMS | < 17 ppmFSV |  | < 133 [digits]
 | Max. SNR | > 95.4 dB
 | Noisedensity@1kHz | < 0.15
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 9 ppmFSV |  | < 70 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation ±640 mV measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.
Frequency response: see specification of ±10 V measurement range


Measurement ±320 mV

Product overview [image] ELM360x [image] ELM360x - Technical data [image] Measurement ±320 mV
Measurement ±320 mV
Measurement mode | ±320 mV
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -320…+320 mV
Measuring range, end value (full scale value) | 320 mV
Measuring range, technically usable | -343.6…+343.6 mV
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 40.96 nV | 10.48576 µV
PDO LSB (Legacy Range) | 38.14.. nV | 9.765.. µV
Preliminary specifications:
Measurement mode |  | ±320 mV
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 90 ppmFSV |  | < 703 [digits]
 | ENoise, RMS | < 17 ppmFSV |  | < 133 [digits]
 | Max. SNR | > 95.4 dB
 | Noisedensity@1kHz | 76.93
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 9 ppmFSV |  | < 70 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation ±320 mV measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.
Frequency response: see specification of ±10 V measurement range


Measurement ±160 mV

Product overview [image] ELM360x [image] ELM360x - Technical data [image] Measurement ±160 mV
Measurement ±160 mV
Measurement mode | ±160 mV
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -160…+160 mV
Measuring range, end value (full scale value) | 160 mV
Measuring range, technically usable | -171.8…+171.8 mV
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 20.48 nV | 5.24288 µV
PDO LSB (Legacy Range) | 19.07.. nV | 4.882.. µV
Preliminary specifications:
Measurement mode |  | ±160 mV
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 120 ppmFSV |  | < 938 [digits]
 | ENoise, RMS | < 22 ppmFSV |  | < 172 [digits]
 | Max. SNR | > 93.2 dB
 | Noisedensity@1kHz | < 49.78
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 13 ppmFSV |  | < 102 [digits]
 | ENoise, RMS | < 2.5 ppmFSV |  | < 20 [digits]
 | Max. SNR | > 112.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation ±160 mV measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.
Frequency response: see specification of ±10 V measurement range


Measurement ±80 mV

Product overview [image] ELM360x [image] ELM360x - Technical data [image] Measurement ±80 mV
Measurement ±80 mV
Measurement mode | ±80 mV
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -80…+80 mV
Measuring range, end value (full scale value) | 80 mV
Measuring range, technically usable | -85.9…+85.9 mV
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 10.24 nV | 2.62144 µV
PDO LSB (Legacy Range) | 9.536.. nV | 2.441.. µV
Preliminary specifications:
Measurement mode |  | ±80 mV
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 160 ppmFSV |  | < 1250 [digits]
 | ENoise, RMS | < 37 ppmFSV |  | < 289 [digits]
 | Max. SNR | > 88.6 dB
 | Noisedensity@1kHz | < 41.86
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 18 ppmFSV |  | < 141 [digits]
 | ENoise, RMS | < 3.5 ppmFSV |  | < 27 [digits]
 | Max. SNR | > 109.1 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation ±80 mV measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.
Frequency response: see specification of ±10 V measurement range


Measurement ±40 mV

Product overview [image] ELM360x [image] ELM360x - Technical data [image] Measurement ±40 mV
Measurement ±40 mV
Measurement mode | ±40 mV
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -40…+40 mV
Measuring range, end value (full scale value) | 40 mV
Measuring range, technically usable | -42.95…+42.95 mV
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 5.12 nV | 1.31072 µV
PDO LSB (Legacy Range) | 4.768.. nV | 1.220.. µV
Preliminary specifications:
Measurement mode |  | ±40 mV
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.02% = 200 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 175 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 65 ppm
Non-linearity over the whole measuring range | ELin | < 45 ppmFSV
Repeatability | ERep | < 30 ppmFSV
Noise (without filtering) | ENoise, PtP | < 375 ppmFSV |  | < 2930 [digits]
 | ENoise, RMS | < 75 ppmFSV |  | < 586 [digits]
 | Max. SNR | > 82.5 dB
 | Noisedensity@1kHz | < 42.43
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 40 ppmFSV |  | < 313 [digits]
 | ENoise, RMS | < 5.5 ppmFSV |  | < 43 [digits]
 | Max. SNR | > 105.2 dB
Temperature coefficient | TcGain | 8 ppm/K typ.
 | TcOffset | 6 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | Value to follow
Representation ±40 mV measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.
Frequency response: see specification of ±10 V measurement range


Measurement ±20 mV

Product overview [image] ELM360x [image] ELM360x - Technical data [image] Measurement ±20 mV
Measurement ±20 mV
Measurement mode | ±20 mV
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -20…+20 mV
Measuring range, end value (full scale value) | 20 mV
Measuring range, technically usable | -21.474…+21.474 mV
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 2.56 nV | 655.36 nV
PDO LSB (Legacy Range) | 2.384.. nV | 610.37.. nV
Preliminary specifications:
Measurement mode |  | ±20 mV
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.03% = 300 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 260 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 100 ppm
Non-linearity over the whole measuring range | ELin | < 90 ppmFSV
Repeatability | ERep | < 35 ppmFSV
Noise (without filtering) | ENoise, PtP | < 750 ppmFSV |  | < 5859 [digits]
 | ENoise, RMS | < 150 ppmFSV |  | < 1172 [digits]
 | Max. SNR | > 76.5 dB
 | Noisedensity@1kHz | < 42.43
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 75 ppmFSV |  | < 586 [digits]
 | ENoise, RMS | < 11.5 ppmFSV |  | < 90 [digits]
 | Max. SNR | > 98.8 dB
Temperature coefficient | TcGain | < 12 ppm/K typ.
 | TcOffset | < 12 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | Value to follow
Representation ±20 mV measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.
Frequency response: see specification of ±10 V measurement range


Measurement 0…10 V

Product overview [image] ELM360x [image] ELM360x - Technical data [image] Measurement 0…10 V
Measurement 0…10 V
Measurement mode | 0…10 V
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | 0…10 V
Measuring range, end value (full scale value) | 10 V
Measuring range, technically usable | 0…+10.737 V
PDO resolution | 23 bit (unsigned) | 15 bit (unsigned)
PDO LSB (Extended Range) | 1.28 µV | 327.68 µV
Preliminary specifications:
Measurement mode |  | 0…10 V
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 60 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 2.55
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation 0…10 V measurement range
Note: The channel also works in electrically bipolar mode and records negative values in the unipolar measuring ranges (measurement from 0 V, 0 mA, 4 mA, 0 Ω). This enables the channel to provide a precise diagnosis even with signals < 0. In these measuring ranges the limit value for the "Underrange Error" in Extended Mode is -1% of the full scale value (FSV). The limit value can be set in CoE object 0x80n0:32. This avoids irritating error messages if the channel is not wired (e.g. without sensor) or the electrical signal fluctuates slightly around zero. The process data value of 0x00000000 is not undershot.
If the "UnderrangeError" detection is to be set even less sensitive, the magnitude of the negative limit value in the CoE object referred to above can be set even higher.
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.
Frequency response: see specification of ±10 V measurement range


Measurement 0…20 V

Product overview [image] ELM360x [image] ELM360x - Technical data [image] Measurement 0…20 V
Measurement 0…20 V
Measurement mode | 0…20 V
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | 0…20 V
Measuring range, end value (full scale value) | 20 V
Measuring range, technically usable | 0…+21.474 V
PDO resolution | 23 bit (unsigned) | 15 bit (unsigned)
PDO LSB (Extended Range) | 2.56 µV | 655.36 µV
Preliminary specifications:
Measurement mode |  | 0…20 V
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 60 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 2.55
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation 0…20 V measurement range
Note: The channel also works in electrically bipolar mode and records negative values in the unipolar measuring ranges (measurement from 0 V, 0 mA, 4 mA, 0 Ω). This enables the channel to provide a precise diagnosis even with signals < 0. In these measuring ranges the limit value for the "Underrange Error" in Extended Mode is -1% of the full scale value (FSV). The limit value can be set in CoE object 0x80n0:32. This avoids irritating error messages if the channel is not wired (e.g. without sensor) or the electrical signal fluctuates slightly around zero. The process data value of 0x00000000 is not undershot.
If the "UnderrangeError" detection is to be set even less sensitive, the magnitude of the negative limit value in the CoE object referred to above can be set even higher.
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.
Frequency response: see specification of ±10 V measurement range


ELM370x

Product overview [image] ELM370x
ELM370x
Additional information
•
ELM370x - Introduction
•
ELM370x - Technical data


ELM370x - Introduction

Product overview [image] ELM370x [image] ELM370x - Introduction
ELM370x - Introduction
ELM3702-0000, ELM3704-0000, ELM3704-0001
2 and 4 channel multi-functional input, 24 bit, 10 ksps
The EtherCAT Terminals from the ELM series were developed in order to enable the high-quality measurement of common electrical signals in the industrial environment. Flexibly usable measurement modules are especially useful in laboratory and testing technology environments. Therefore the ELM370x multifunction modules feature an input circuit that can be set to over 30 different types of electrical connection via EtherCAT: from voltages of ±30 V to ±20 mV, thus supporting thermocouples and IEPE, a current of ±20 mA, a resistance measurement of 5 kΩ and thus also temperature RTDs (PT100, etc.), measuring bridges and potentiometers, and all of this with a 2- to 6-wire connection, depending on the type. Thus, most electrical measuring tasks can be solved with just a single module. There is a choice of different connection types:
The ELM3704-0001 with its high-quality LEMO connectors is mainly designed for laboratory use, where sensor configurations are changed on a daily basis, but a stable and reliable plug connection is nevertheless required. The 6-pin version with push-in (ELM3704-0000/ELM3702-0000) on the other hand is ideal for industrial use where a plug is unplugged less frequently for maintenance purposes and fast wiring is much more important.
The other ELM3xxx modules are price-optimised versions of the basic class and thus ideal for use in machines with planned and foreseeable usage scenarios in which the measurement method of an analog input channel does not need to be changed at runtime. In return, they may have advanced features, like the ELM360x modules (IEPE evaluation), which offer a switchable feed.
Quick-Links
• EtherCAT basics
• Mounting and wiring
• Process data overview
• Connection view
• Object description and parameterization


ELM370x - Technical data

Product overview [image] ELM370x [image] ELM370x - Technical data
ELM370x - Technical data
Technical data | ELM3702 |  | ELM3704
Analog inputs | 2 channel (differential) |  | 4 channel (differential)
Time relation between channels to each other | Simultaneous conversion of all channels in the terminal, synchronous conversion between terminals, if DistributedClocks will be used
ADC conversion method | deltaSigma ΔΣ with internal sample rate
 | 5.12 MSps | 5.12 MSps
Limit frequency input filter hardware (see information in section ELM Features/ Firmware filter concept) | Before AD converter: hardware low pass -3dB @ 30 kHz type butterworth 3th order Within ADC after conversion:
 | ow pass -3dB @ 5.3 kHz, ramp-up time 150 µs | low pass -3dB @ 5.3 kHz, ramp-up time 150 µs
 | type sinc3/average filter The ramp-up time/ settling time/ delay caused by the filtering will be considered within the DistributedClocks-Timestamp.
Resolution | 24 Bit (including sign)
Connection technology | 2/ 3 / 4 / 5 / 6 wire
Connection type | push-in cageclamp, service plug, 6-pin | ELM3704-0000: push-in cageclamp, service plug, 6-pin
 |  | ELM3704-0001: 8 pol. LEMO 1B
Sampling rate (per channel, simultaneous) | 100 µs/10 kSps free down sampling by Firmware via decimation factor
Oversampling | 1…100 selectable
Supported EtherCAT cycle time (depending on the operation mode) | DistributedClocks: min. 100 µs, max. 10 ms FrameTriggered/Synchron: min. 200 µs, max. 100 ms FreeRun: not yet supported
Internal resistance | > 500 kΩ (60 V); > 4 MΩ (other); 150 Ω (current)
Operation range voltage measurement | ±60/10/5/2.5/1.25 V, ±640/320/160/80/40/20 mV, 0…5/10 V, (2 wire connection)
Operation range current measurement | ±20 mA, 0/4…20 mA, NAMUR NE43, (2 wire connection)
Operation range DMS | Full bridge (±2/4/8/32 mV/V), feeding-in supply adjustable up to 5V (4/ 6 wire connection)
 | Half bridge (±2/16 mV/V), internal switched bridge extension, feeding-in supply adjustable up to 5V (3/ 5 wire connection)
 | Quarter bridge 120 Ω and 350 Ω (±2/4/8/32 mV/V), internal switched bridge extension, feeding-in supply adjustable up to 2.5V (2/ 3 wire connection)
Operation range IEPE | Measurement ranges ±2.5/5/10 V adjustable, current feeding 2 mA, acquiring of the modulated AC voltage AC/DC Coupling (configurable parameters of high pass, 2 wire connection) Note: TEDS Class 1 not supported
Operation range potentiometer | Potentiometer ≥ 1 kΩ, supply integrated and adjustable 0…5 V, (3/ 5 wire connection)
Operation range resistance | 0…50 Ω, 0…200 Ω, 0…500 Ω, 0…2 kΩ, 0…5 kΩ (2/3/4 wire connection)
Operation range temperature (RTD) | PT100, PT200, PT500, PT1000, Ni100, Ni120, Ni1000, div. KT/KTY (2/ 3/ 4 wire connection)
Operation range temperature (thermocouple) | Type K, J, L, E, T, N, U, B, R, S, C; cold junction measurement internal/ external (2 wire connection)
Connection diagnosis | Wire break/short cut
Surge voltage protection of the inputs related to GND | tbd
Current consumption via E-bus | typ. 720 mA
Thermal power dissipation | typ. 3 W
Dielectric strength - destruction limit | max. permitted short-term/continuous voltage between contact points ±I1, ±I2, +Uv and –Uv: non-supplied ±40 V, supplied ±36 V Note: -Uv corresponds to internal AGND
Recommended operation voltage range to compliance with specification | max. permitted voltage during specified normal operation between ±I1 and ±I2: typ. ±35 V against –Uv in measurement range 60 V typ. ±10 V against –Uv in all other measurement ranges than 60 V Note: -Uv corresponds to internal AGND
Electrical isolation channel/channel *) | no
Electrical isolation channel/Ebus *) | yes, 500V/1min.typ. test
Electrical isolation channel/SGND *) | yes, 500V/1min.typ. test
Weight | approx. 350 g
Permissible ambient temperature range during operation | -25…+60 °C
Permissible ambient temperature range during storage | -40…+85 °C
*) see notes to potential groups in chapter “Mounting and wiring/ Power supply, potential groups”
Note
Extended Range mode not available
The Extended Range mode is not available for RTD measurement.
•
Until FW07: Object 0x8000:2E (Scaler) will be ignored by this setting. The “Legacy Range Mode” applies in the background.
•
Since FW08: Object 0x8000:2E (Scaler) will then be set to the “Legacy Range Mode”. A change is not possible as long RTD measurement range is selected.
Overview measurement ranges (ELM370x):
Measurement | Connection technology | FSV | Mode | Maximum value/ value range
Voltage | 2 wire | ±60 V | Extended | ±64.414.. V
 |  |  | Legacy | ±60 V
 |  | ±10 V | Extended | ±10.737.. V
 |  |  | Legacy | ±10 V
 |  | ±5 V | Extended | ±5.368.. V
 |  |  | Legacy | ±5 V
 |  | ±2.5 V | Extended | ±2.684.. V
 |  |  | Legacy | ±2.5 V
 |  | ±1.25 V | Extended | ±1.490.. V
 |  |  | Legacy | ±1.25 V
 |  | ±640 mV | Extended | ±687.2.. mV
 |  |  | Legacy | ±640 mV
 |  | ±320 mV | Extended | ±343.6.. mV
 |  |  | Legacy | ±320 mV
 |  | ±160 mV | Extended | ±171.8.. mV
 |  |  | Legacy | ±160 mV
 |  | ±80 mV | Extended | ±85.9.. mV
 |  |  | Legacy | ±80 mV
 |  | ±40 mV | Extended | ±42.95.. mV
 |  |  | Legacy | ±40 mV
 |  | ±20 mV | Extended | ±21.474.. mV
 |  |  | Legacy | ±20 mV
Voltage | 2 wire | +10 V | Extended | 0…10.737.. V
 |  |  | Legacy | 0…10 V
 |  | +5 V | Extended | 0…5.368.. V
 |  |  | Legacy | 0…5 V
Current | 2 wire | ±20 mA | Extended | ±21.474.. mA
 |  |  | Legacy | ±20 mA
 |  | +20 mA | Extended | 0…21.474.. mA
 |  |  | Legacy | 0…20 mA
 |  | +20 mA | Extended | 0…21.179 mA
 |  |  | Legacy | 4…20 mA
 |  | +20 mA | Extended | 3.6…21 mA
 |  |  | Legacy | 4…20 mA
Resistance | 2 wire | 5 kΩ | Extended | 0 Ω…5.368 kΩ
 |  |  | Legacy | 0…5 kΩ
 |  | 2 kΩ | Extended | 0 Ω…2.147 kΩ
 |  |  | Legacy | 0…2 kΩ
 |  | 500 Ω | Extended | 0 Ω…536.8 Ω
 |  |  | Legacy | 0…500 Ω
 |  | 200 Ω | Extended | 0 Ω…214.7 Ω
 |  |  | Legacy | 0…200 Ω
 |  | 50 Ω | Extended | 0 Ω…53.68 Ω
 |  |  | Legacy | 0…50 Ω
Potentiometer | 3/5 wire | ±1 V/V | Extended | ±1 V/V
 |  |  | Legacy
Full bridge | 4/6 wire | ±32 mV/V | Extended | ±34.359.. mV/V
 |  |  | Legacy | ±32 mV/V
 |  | ±4 mV/V | Extended | ±4.2949.. mV/V
 |  |  | Legacy | ±4 mV/V
 |  | ±2 mV/V | Extended | ±2.1474.. mV/V
 |  |  | Legacy | ±2 mV/V
Half bridge | 3/5 wire | ±16 mV/V | Extended | ±17.179.. mV/V
 |  |  | Legacy | ±16 mV/V
 |  | ±2 mV/V | Extended | ±2.1474.. mV/V
 |  |  | Legacy | ±2 mV/V
Quarter bridge 120/350/1000 Ω | 2/3 wire | ±32 mV/V | Extended | ±34.359.. mV/V
 |  |  | Legacy | ±32 mV/V
 |  | ±8 mV/V | Extended | ±8.5899.. mV/V
 |  |  | Legacy | ±8 mV/V
 |  | ±4 mV/V | Extended | ±4.2949.. mV/V
 |  |  | Legacy | ±4 mV/V
 |  | ±2 mV/V | Extended | ±2.1474.. mV/V
 |  |  | Legacy | ±2 mV/V
Voltage (IEPE) | 2 wire | ±10 V | Extended | ±10.737.. V
 |  |  | Legacy | ±10 V
 |  | ±5 V | Extended | ±5.368.. V
 |  |  | Legacy | ±5 V
 |  | ±2.5 V | Extended | ±2.684.. V
 |  |  | Legacy | ±2.5 V
 |  | +20 V | Extended | 0…21.474.. V
 |  |  | Legacy | 0…20 V
 |  | +10 V | Extended | 0…10.737.. V
 |  |  | Legacy | 0…10 V
Temperature thermo couple (TC) | 2 wire | ±80 mV | Legacy | Depending on type up to 2320°C
Temperature RTD | 2/3/4 wire | 5 kΩ | Legacy | Depending on type up to 300°C
 |  | 2 kΩ
 |  | 500 Ω
 |  | 200 Ω
 |  | 50 Ω
Overview measurement ranges, Bipolar
Overview measurement ranges, Unipolar
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.
Additional information
•
Measurement 5V/ 10V/ ±20 mV..±60 V
•
Measurement ±20 mA/ 0..20 mA/ 4..20 mA/NAMUR
•
Measurement resistance
•
RTD measurement
•
Potentiometer measurement
•
Measurement SG 1/1 bridge (full bridge) 4/6-wire connection
•
Measurement SG 1/2 bridge (half bridge) 3/5-wire connection
•
Measurement SG 1/4 bridge (quarter-bridge) 2/3-wire connection
•
Measurement IEPE 10 V/ 20 V/ ±2,5 V..±10 V
•
Thermocouple measurement


Measurement 5V/ 10V/ ±20 mV..±60 V

Product overview [image] ELM370x [image] ELM370x - Technical data [image] Measurement 5V/ 10V/ ±20 mV..±60 V
Measurement 5V/ 10V/ ±20 mV..±60 V
Additional information
•
Measurement ±60 V
•
Measurement ±10 V
•
Measurement ±5 V
•
Measurement ±2.5 V
•
Measurement ±1.25 V
•
Measurement ±640 mV
•
Measurement ±320 mV
•
Measurement ±160 mV
•
Measurement ±80 mV
•
Measurement ±40 mV
•
Measurement ±20 mV
•
Measurement 0…5 V
•
Measurement 0…10 V


Measurement ±60 V

Product overview [image] ELM370x [image] ELM370x - Technical data [image] Measurement 5V/ 10V/ ±20 mV..±60 V [image] Measurement ±60 V
Measurement ±60 V
Measurement mode | ±60 V
Internal resistance | >500 kΩ differential
Impedance | Value to follow
Measuring range, nominal | -60…+60 V
Measuring range, end value (full scale value) | 60 V
Measuring range, technically usable | -64.414…+64.414 V
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 7.68 µV | 1.966 mV
PDO LSB (Legacy Range) | 7.152.. µV | 1.831.. mV
Measurement mode |  | ±60 V
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±(tbd)% = (tbd)ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < (tbd)ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < (tbd)ppm
Non-linearity over the whole measuring range | ELin | < (tbd)ppmFSV
Repeatability | ERep | < (tbd)ppmFSV
Noise (without filtering) | ENoise, PtP | < (tbd)ppmFSV |  | < (tbd) [digits]
 | ENoise, RMS | < (tbd)ppmFSV |  | < (tbd) [digits]
 | Max. SNR | > (tbd) dB
 | Noisedensity@1kHz | < (tbd)
Noise (with 50Hz FIR filtering) | ENoise, PtP | < (tbd) ppmFSV |  | < (tbd) [digits]
 | ENoise, RMS | < (tbd) ppmFSV |  | < (tbd) [digits]
 | Max. SNR | > (tbd) dB
Temperature coefficient | TcGain | < (tbd) ppm/K typ.
 | TcOffset | < (tbd) ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >(tbd) dB typ. | 50 Hz: >(tbd) dB typ. |  | 1 kHz: >(tbd) dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >(tbd) dB typ. | 50 Hz: >(tbd) dB typ. |  | 1 kHz: >(tbd) dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±(tbd)% = (tbd) ppmFSV typ.
Representation ±60 V measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement ±10 V

Product overview [image] ELM370x [image] ELM370x - Technical data [image] Measurement 5V/ 10V/ ±20 mV..±60 V [image] Measurement ±10 V
Measurement ±10 V
Measurement mode | ±10 V
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -10…+10 V *)
Measuring range, end value (full scale value) | 10 V
Measuring range, technically usable | -10.737…+10.737 V
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 1.28 µV | 327.68 µV
PDO LSB (Legacy Range) | 1.192.. µV | 305.18.. µV
*) For IEPE measurement applies: The input voltage must not fall below -5 V with respect to GND, the measuring accuracy is then no longer given. This means a measurement down to -10 V with respect to GND is only possible if at the same time an offset of at least +5 V is applied, as is usual with IEPE supply.
Preliminary specifications:
Measurement mode |  | ±10 V
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 60 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 2.55
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation ±10 V measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement ±5 V

Product overview [image] ELM370x [image] ELM370x - Technical data [image] Measurement 5V/ 10V/ ±20 mV..±60 V [image] Measurement ±5 V
Measurement ±5 V
Measurement mode | ±5 V
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -5…+5 V
Measuring range, end value (full scale value) | 5 V
Measuring range, technically usable | -5.368…+5.368 V
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 640 nV | 163.84 µV
PDO LSB (Legacy Range) | 596.. nV | 152.59.. µV
Preliminary specifications:
Measurement mode |  | ±5 V
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 1.27
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation ±5 V measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement ±2.5 V

Product overview [image] ELM370x [image] ELM370x - Technical data [image] Measurement 5V/ 10V/ ±20 mV..±60 V [image] Measurement ±2.5 V
Measurement ±2.5 V
Measurement mode | ±2.5 V
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -2.5…+2.5 V
Measuring range, end value (full scale value) | 2.5 V
Measuring range, technically usable | -2.684…+2.684 V
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 320 nV | 81.92 µV
PDO LSB (Legacy Range) | 298.. nV | 76.29.. µV
Preliminary specifications:
Measurement mode |  | ±2.5 V
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 90 ppmFSV |  | < 703 [digits]
 | ENoise, RMS | < 17 ppmFSV |  | < 133 [digits]
 | Max. SNR | > 95.4 dB
 | Noisedensity@1kHz | < 0.60
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 9 ppmFSV |  | < 70 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation ±2.5 V measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement ±1.25 V

Product overview [image] ELM370x [image] ELM370x - Technical data [image] Measurement 5V/ 10V/ ±20 mV..±60 V [image] Measurement ±1.25 V
Measurement ±1.25 V
Measurement mode | ±1.25 V
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -1.25…+1.25 V
Measuring range, end value (full scale value) | 1.25 V
Measuring range, technically usable | -1.490…+1.490 V
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 160 nV | 40.96 µV
PDO LSB (Legacy Range) | 149.. nV | 38.14.. µV
Preliminary specifications:
Measurement mode |  | ±1.25 V
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 90 ppmFSV |  | < 703 [digits]
 | ENoise, RMS | < 17 ppmFSV |  | < 133 [digits]
 | Max. SNR | > 95.4 dB
 | Noisedensity@1kHz | < 0.30
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 9 ppmFSV |  | < 70 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation ±1.25 V measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement ±640 mV

Product overview [image] ELM370x [image] ELM370x - Technical data [image] Measurement 5V/ 10V/ ±20 mV..±60 V [image] Measurement ±640 mV
Measurement ±640 mV
Measurement mode | ±640 mV
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -640…+640 mV
Measuring range, end value (full scale value) | 640 mV
Measuring range, technically usable | -687.2…+687.2 mV
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 81.92 nV | 20.97152 µV
PDO LSB (Legacy Range) | 76.29.. nV | 19.53.. µV
Preliminary specifications:
Measurement mode |  | ±640 mV
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 90 ppmFSV |  | < 703 [digits]
 | ENoise, RMS | < 17 ppmFSV |  | < 133 [digits]
 | Max. SNR | > 95.4 dB
 | Noisedensity@1kHz | < 0.15
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 9 ppmFSV |  | < 70 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation ±640 mV measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement ±320 mV

Product overview [image] ELM370x [image] ELM370x - Technical data [image] Measurement 5V/ 10V/ ±20 mV..±60 V [image] Measurement ±320 mV
Measurement ±320 mV
Measurement mode | ±320 mV
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -320…+320 mV
Measuring range, end value (full scale value) | 320 mV
Measuring range, technically usable | -343.6…+343.6 mV
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 40.96 nV | 10.48576 µV
PDO LSB (Legacy Range) | 38.14.. nV | 9.765.. µV
Preliminary specifications:
Measurement mode |  | ±320 mV
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 90 ppmFSV |  | < 703 [digits]
 | ENoise, RMS | < 17 ppmFSV |  | < 133 [digits]
 | Max. SNR | > 95.4 dB
 | Noisedensity@1kHz | 76.93
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 9 ppmFSV |  | < 70 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation ±320 mV measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement ±160 mV

Product overview [image] ELM370x [image] ELM370x - Technical data [image] Measurement 5V/ 10V/ ±20 mV..±60 V [image] Measurement ±160 mV
Measurement ±160 mV
Measurement mode | ±160 mV
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -160…+160 mV
Measuring range, end value (full scale value) | 160 mV
Measuring range, technically usable | -171.8…+171.8 mV
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 20.48 nV | 5.24288 µV
PDO LSB (Legacy Range) | 19.07.. nV | 4.882.. µV
Preliminary specifications:
Measurement mode |  | ±160 mV
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 120 ppmFSV |  | < 938 [digits]
 | ENoise, RMS | < 22 ppmFSV |  | < 172 [digits]
 | Max. SNR | > 93.2 dB
 | Noisedensity@1kHz | < 49.78
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 13 ppmFSV |  | < 102 [digits]
 | ENoise, RMS | < 2.5 ppmFSV |  | < 20 [digits]
 | Max. SNR | > 112.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation ±160 mV measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement ±80 mV

Product overview [image] ELM370x [image] ELM370x - Technical data [image] Measurement 5V/ 10V/ ±20 mV..±60 V [image] Measurement ±80 mV
Measurement ±80 mV
Measurement mode | ±80 mV
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -80…+80 mV
Measuring range, end value (full scale value) | 80 mV
Measuring range, technically usable | -85.9…+85.9 mV
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 10.24 nV | 2.62144 µV
PDO LSB (Legacy Range) | 9.536.. nV | 2.441.. µV
Preliminary specifications:
Measurement mode |  | ±80 mV
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 160 ppmFSV |  | < 1250 [digits]
 | ENoise, RMS | < 37 ppmFSV |  | < 289 [digits]
 | Max. SNR | > 88.6 dB
 | Noisedensity@1kHz | < 41.86
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 18 ppmFSV |  | < 141 [digits]
 | ENoise, RMS | < 3.5 ppmFSV |  | < 27 [digits]
 | Max. SNR | > 109.1 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation ±80 mV measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement ±40 mV

Product overview [image] ELM370x [image] ELM370x - Technical data [image] Measurement 5V/ 10V/ ±20 mV..±60 V [image] Measurement ±40 mV
Measurement ±40 mV
Measurement mode | ±40 mV
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -40…+40 mV
Measuring range, end value (full scale value) | 40 mV
Measuring range, technically usable | -42.95…+42.95 mV
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 5.12 nV | 1.31072 µV
PDO LSB (Legacy Range) | 4.768.. nV | 1.220.. µV
Preliminary specifications:
Measurement mode |  | ±40 mV
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.02% = 200 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 175 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 65 ppm
Non-linearity over the whole measuring range | ELin | < 45 ppmFSV
Repeatability | ERep | < 30 ppmFSV
Noise (without filtering) | ENoise, PtP | < 375 ppmFSV |  | < 2930 [digits]
 | ENoise, RMS | < 75 ppmFSV |  | < 586 [digits]
 | Max. SNR | > 82.5 dB
 | Noisedensity@1kHz | < 42.43
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 40 ppmFSV |  | < 313 [digits]
 | ENoise, RMS | < 5.5 ppmFSV |  | < 43 [digits]
 | Max. SNR | > 105.2 dB
Temperature coefficient | TcGain | 8 ppm/K typ.
 | TcOffset | 6 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | Value to follow
Representation ±40 mV measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement ±20 mV

Product overview [image] ELM370x [image] ELM370x - Technical data [image] Measurement 5V/ 10V/ ±20 mV..±60 V [image] Measurement ±20 mV
Measurement ±20 mV
Measurement mode | ±20 mV
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -20…+20 mV
Measuring range, end value (full scale value) | 20 mV
Measuring range, technically usable | -21.474…+21.474 mV
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 2.56 nV | 655.36 nV
PDO LSB (Legacy Range) | 2.384.. nV | 610.37.. nV
Preliminary specifications:
Measurement mode |  | ±20 mV
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.03% = 300 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 260 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 100 ppm
Non-linearity over the whole measuring range | ELin | < 90 ppmFSV
Repeatability | ERep | < 35 ppmFSV
Noise (without filtering) | ENoise, PtP | < 750 ppmFSV |  | < 5859 [digits]
 | ENoise, RMS | < 150 ppmFSV |  | < 1172 [digits]
 | Max. SNR | > 76.5 dB
 | Noisedensity@1kHz | < 42.43
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 75 ppmFSV |  | < 586 [digits]
 | ENoise, RMS | < 11.5 ppmFSV |  | < 90 [digits]
 | Max. SNR | > 98.8 dB
Temperature coefficient | TcGain | < 12 ppm/K typ.
 | TcOffset | < 12 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | Value to follow
Representation ±20 mV measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement 0…5 V

Product overview [image] ELM370x [image] ELM370x - Technical data [image] Measurement 5V/ 10V/ ±20 mV..±60 V [image] Measurement 0…5 V
Measurement 0…5 V
Measurement mode | 0…5 V
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | 0…5 V
Measuring range, end value (full scale value) | 5 V
Measuring range, technically usable | 0…5.368 V
PDO resolution | 23 bit (unsigned) | 15 bit (unsigned)
PDO LSB (Extended Range) | 640 nV | 163.84 µV
Preliminary specifications:
Measurement mode |  | 0…5 V
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 1.27
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation 0…5 V measurement range
Note: The channel also works in electrically bipolar mode and records negative values in the unipolar measuring ranges (measurement from 0 V, 0 mA, 4 mA, 0 Ω). This enables the channel to provide a precise diagnosis even with signals < 0. In these measuring ranges the limit value for the "Underrange Error" in Extended Mode is -1% of the full scale value (FSV). The limit value can be set in CoE object 0x80n0:32. This avoids irritating error messages if the channel is not wired (e.g. without sensor) or the electrical signal fluctuates slightly around zero. The process data value of 0x00000000 is not undershot.
If the "UnderrangeError" detection is to be set even less sensitive, the magnitude of the negative limit value in the CoE object referred to above can be set even higher.
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement 0…10 V

Product overview [image] ELM370x [image] ELM370x - Technical data [image] Measurement 5V/ 10V/ ±20 mV..±60 V [image] Measurement 0…10 V
Measurement 0…10 V
Measurement mode | 0…10 V
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | 0…10 V
Measuring range, end value (full scale value) | 10 V
Measuring range, technically usable | 0…+10.737 V
PDO resolution | 23 bit (unsigned) | 15 bit (unsigned)
PDO LSB (Extended Range) | 1.28 µV | 327.68 µV
Preliminary specifications:
Measurement mode |  | 0…10 V
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 60 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 2.55
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation 0…10 V measurement range
Note: The channel also works in electrically bipolar mode and records negative values in the unipolar measuring ranges (measurement from 0 V, 0 mA, 4 mA, 0 Ω). This enables the channel to provide a precise diagnosis even with signals < 0. In these measuring ranges the limit value for the "Underrange Error" in Extended Mode is -1% of the full scale value (FSV). The limit value can be set in CoE object 0x80n0:32. This avoids irritating error messages if the channel is not wired (e.g. without sensor) or the electrical signal fluctuates slightly around zero. The process data value of 0x00000000 is not undershot.
If the "UnderrangeError" detection is to be set even less sensitive, the magnitude of the negative limit value in the CoE object referred to above can be set even higher.
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement ±20 mA/ 0..20 mA/ 4..20 mA/NAMUR

Product overview [image] ELM370x [image] ELM370x - Technical data [image] Measurement ±20 mA/ 0..20 mA/ 4..20 mA/NAMUR
Measurement ±20 mA/ 0..20 mA/ 4..20 mA/NAMUR
Additional information
•
Measurement ±20 mA
•
Measurement 0…20 mA
•
Measurement 4…20 mA
•
Measurement 3.6…21 mA (NAMUR NE43)


Measurement ±20 mA

Product overview [image] ELM370x [image] ELM370x - Technical data [image] Measurement ±20 mA/ 0..20 mA/ 4..20 mA/NAMUR [image] Measurement ±20 mA
Measurement ±20 mA
Measurement mode | ±20 mA
Internal resistance | 150 Ω typ.
Impedance | Tbd.
Measuring range, nominal | -20…+20 mA
Measuring range, end value (full scale value) | 20 mA
Measuring range, technically usable | -21.474…+21.474 mA, overcurrent-protected
Fuse protection | Internal overload limiting, continuous current resistant
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 2.56 nA | 655.36 nA
PDO LSB (Legacy Range) | 2.384.. nA | 610.37.. nA
Common-mode voltage Vcm | max. ±10V related to -Uv (internal ground)
Preliminary specifications:
Measurement mode |  | ±20 mA
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 65 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 50 ppm
Non-linearity over the whole measuring range | ELin | < 40 ppmFSV
Repeatability | ERep | < 40 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 5.09
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 15 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) | DC: < 3 nA/V typ. | 50 Hz: < 5 nA/V typ. | 1 kHz: < 80 nA/V typ.
Common-mode rejection ratio (with 50Hz FIR filtering) | DC: < 3 nA/V typ. | 50 Hz: < 3 nA/V typ. | 1 kHz: < 3 nA/V typ.
Largest short-term deviation during a specified electrical interference test | Value to follow [ppm] typ. (FSV)
Current measurement range ±20 mA
Representation current measurement range ±20 mA
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement 0…20 mA

Product overview [image] ELM370x [image] ELM370x - Technical data [image] Measurement ±20 mA/ 0..20 mA/ 4..20 mA/NAMUR [image] Measurement 0…20 mA
Measurement 0…20 mA
Measurement mode | 0...20 mA
Internal resistance | 150 Ω typ.
Impedance | Tbd.
Measuring range, nominal | 0…20 mA
Measuring range, end value (full scale value) | 20 mA
Measuring range, technically usable | 0 …21.474 mA
Fuse protection | Internal overload limiting, continuous current resistant
PDO resolution | 23 bit (unsigned) | 16 bit (including sign)
PDO LSB (Extended Range) | 2.56 nA | 655.36 nA
PDO LSB (Legacy Range) | 2.384.. nA | 610.37.. nA
Common-mode voltage Vcm | max. ±10V related to -Uv (internal ground)
Preliminary specifications:
Measurement mode |  | 0...20 mA
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 65 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 50 ppm
Non-linearity over the whole measuring range | ELin | < 40 ppmFSV
Repeatability | ERep | < 40 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 5.09
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 15 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: < 3 nA/V typ. | 50 Hz: < 5 nA/V typ. |  | 1 kHz: < 80 nA/V typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: < 3 nA/V typ. | 50 Hz: < 3 nA/V typ. |  | 1 kHz: < 3 nA/V typ.
Largest short-term deviation during a specified electrical interference test |  | Value to follow [ppm] typ. (FSV)
Current measurement range 0…20 mA
Representation current measurement range 0…20 mA
Note: The channel also works in electrically bipolar mode and records negative values in the unipolar measuring ranges (measurement from 0 V, 0 mA, 4 mA, 0 Ω). This enables the channel to provide a precise diagnosis even with signals < 0. In these measuring ranges the limit value for the "Underrange Error" in Extended Mode is -1% of the full scale value (FSV). The limit value can be set in CoE object 0x80n0:32. This avoids irritating error messages if the channel is not wired (e.g. without sensor) or the electrical signal fluctuates slightly around zero. The process data value of 0x00000000 is not undershot.
If the "UnderrangeError" detection is to be set even less sensitive, the magnitude of the negative limit value in the CoE object referred to above can be set even higher.
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement 4…20 mA

Product overview [image] ELM370x [image] ELM370x - Technical data [image] Measurement ±20 mA/ 0..20 mA/ 4..20 mA/NAMUR [image] Measurement 4…20 mA
Measurement 4…20 mA
Measurement mode | 4…20 mA
Internal resistance | 150 Ω typ.
Impedance | Tbd.
Measuring range, nominal | 4…20 mA
Measuring range, end value (full scale value) | 20 mA
Measuring range, technically usable | 0…21.179 mA
Fuse protection | Internal overload limiting, continuous current resistant
PDO resolution | 24 Bit | 16 Bit
PDO LSB (Extended Range) | 2.048 nA | 524.288 nA
PDO LSB (Legacy Range) | 1.907.. nA | 488.29.. nA
Common-mode voltage Vcm | max. ±10V related to -Uv (internal ground)
Preliminary specifications:
Measurement mode |  | 4…20 mA
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 65 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 50 ppm
Non-linearity over the whole measuring range | ELin | < 40 ppmFSV
Repeatability | ERep | < 40 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 5.09
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 15 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: < 3 nA/V typ. | 50 Hz: < 5 nA/V typ. |  | 1 kHz: < 80 nA/V typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: < 3 nA/V typ. | 50 Hz: < 3 nA/V typ. |  | 1 kHz: < 3 nA/V typ.
Largest short-term deviation during a specified electrical interference test |  | Value to follow [ppmFSV] typ.
Current measurement range 4…20 mA
Representation current measurement range 4…20 mA
Note: The channel also works in electrically bipolar mode and records negative values in the unipolar measuring ranges (measurement from 0 V, 0 mA, 4 mA, 0 Ω). This enables the channel to provide a precise diagnosis even with signals < 0. In these measuring ranges the limit value for the "Underrange Error" in Extended Mode is -1% of the full scale value (FSV). The limit value can be set in CoE object 0x80n0:32. This avoids irritating error messages if the channel is not wired (e.g. without sensor) or the electrical signal fluctuates slightly around zero. The process data value of 0x00000000 is not undershot.
If the "UnderrangeError" detection is to be set even less sensitive, the magnitude of the negative limit value in the CoE object referred to above can be set even higher.
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement 3.6…21 mA (NAMUR NE43)

Product overview [image] ELM370x [image] ELM370x - Technical data [image] Measurement ±20 mA/ 0..20 mA/ 4..20 mA/NAMUR [image] Measurement 3.6…21 mA (NAMUR NE43)
Measurement 3.6…21 mA (NAMUR NE43)
Measurement mode | 3.6…21 mA (NAMUR NE43)
Internal resistance | 150 Ω typ.
Impedance | Tbd.
Measuring range, nominal | 4…20 mA
Measuring range, end value (full scale value) | 20 mA
Measuring range, technically usable | 3.6…21 mA
Fuse protection | Internal overload limiting, continuous current resistant
PDO resolution | 24 Bit | 16 Bit
PDO LSB (Extended Range) | 2.048 nA | 524.288 nA
PDO LSB (Legacy Range) | n.a.
Common-mode voltage Vcm | max. ±10V related to -Uv (internal ground)
Preliminary specifications:
Measurement mode |  | 3.6…21 mA (NAMUR NE43)
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 65 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 50 ppm
Non-linearity over the whole measuring range | ELin | < 40 ppmFSV
Repeatability | ERep | < 40 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 5.09
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 15 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: < 3 nA/V typ. | 50 Hz: < 5 nA/V typ. |  | 1 kHz: < 80 nA/V typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: < 3 nA/V typ. | 50 Hz: < 3 nA/V typ. |  | 1 kHz: < 3 nA/V typ.
Largest short-term deviation during a specified electrical interference test |  | Value to follow [ppmFSV] typ.
Current measuring range 3.6…21 mA (NAMUR)
Chart: current measuring range 3.6…21 mA (NAMUR)
Only Extended Range mode for measuring range 4 mA NAMUR
Legacy Range mode is not available for this measurement range. The Extended Range Mode will be set automatically and although a corresponding write access to the CoE Object 0x8000:2E (Scaler) is not declined, the parameter is not changed.


Measurement resistance

Product overview [image] ELM370x [image] ELM370x - Technical data [image] Measurement resistance
Measurement resistance
Note on measuring resistances or resistance ratios
With 2‑wire measurement, the line resistance of the sensor supply lines influences the measured value. If a reduction of this systematic error component is desirable for 2‑wire measurements, the resistance of the supply line to the measuring resistance should be taken into account, in which case the resistance of the supply line has to be determined first. Taking into account the uncertainty associated with this supply line resistance, it can then be included statically in the calculation, in the EL3751 via 0x8000:13 and in the ELM350x/ ELM370x via 0x80n0:13. Any change in resistance of the supply line due to ageing, for example, is not taken into account automatically.
A 3‑wire measurement enables the systematic component to be eliminated, assuming that the two supply lines are identical. With this type of measurement, the lead resistance of a supply line is measured continuously. The value determined in this way is then deducted twice from the measurement result, thereby eliminating the line resistance. Technically, this leads to a significantly more reliable measurement. However, taking into account the measurement uncertainty, the gain from the 3‑wire connection is less significant, since this assumption is subject to high uncertainty, in view of the fact that the individual line that was not measured may be damaged, or a varying resistance may have gone unnoticed.
Therefore, although technically the 3‑wire connection is a tried and tested approach, for measurements that are methodological assessed based on measurement uncertainty, we strongly recommend fully‑compensated 4‑wire connection.
With both 2‑wire and 3‑wire connection, the contact resistances of the terminal contacts influence the measuring process. The measuring accuracy can be further increased by a user‑side adjustment with the signal connection plugged in.
Note
Measurement of small resistances
Especially for measurements in the range < 10 Ω, the 4‑wire connection is absolutely necessary due to the relatively high supply and contact resistances. It should also be considered that with such low resistances the relative measurement error in relation to the full scale value (FSV) can become high ‑ for such measurements resistance measurement terminals with small measuring ranges such as EL3692 in 4‑wire measurement should be used if necessary.
Corresponding considerations also lead to the common connection methods in bridge operation:
▪
Full bridge: 4‑wire connection without line compensation, 6‑wire connection with full line compensation
▪
Half bridge: 3‑wire connection without line compensation, 5‑wire connection with full line compensation
▪
Quarter bridge: 2‑wire connection without line compensation, 3‑wire connection with theoretical line compensation and 4‑wire connection with full line compensation
Measurement electrical resistance 5 kΩ
Measurement mode |  | Electrical resistance 0..5 kΩ
Operation mode |  | 2.5 V feed voltage, fixed setting n +Uv 5 kΩ reference resistance at ‑I2 Supply current is given by: 2.5 V / (5 kΩ + Rmeasurement)
Measuring range, nominal |  | 0…5 kΩ
Measuring range, end value (full scale value) |  | 5 kΩ
Measuring range, technically usable |  | 0 Ω…5.368 kΩ
PDO resolution |  | 23 Bit (unsigned)
PDO LSB (Extended Range) |  | 640 µΩ
PDO LSB (Legacy Range) |  | 596.. µΩ
Basic accuracy: Measuring deviation at 23°C, with averaging |  | 2-wire connection: ±(tbd)% typ. (FSV) 3-wire connection: ±(tbd)% typ. (FSV) 4-wire connection: ±(tbd)% typ. (FSV)
Temperature coefficient (Terminal) | TcTerminal | < (tbd) ppm/K typ.
Measurement mode |  | Resistance (2 wire) |  |  |  | Resistance (3 wire) |  |  |  | Resistance (4 wire)
Offset/Zero Point deviation (at 23°C) | EOffset | < (tbd) [ppmFSV] |  |  |  | < (tbd) [ppmFSV] |  |  |  | < (tbd) [ppmFSV]
Gain/scale/amplification deviation (at 23°C) | EGain | < (tbd) [ppm] |  |  |  | < (tbd) [ppm] |  |  |  | < (tbd) [ppm]
Non-linearity over the whole measuring range | ELin | < (tbd) [ppmFSV] |  |  |  | < (tbd) [ppmFSV] |  |  |  | < (tbd) [ppmFSV]
Repeatability | ERep | < (tbd) [ppmFSV] |  |  |  | < (tbd) [ppmFSV] |  |  |  | < (tbd) [ppmFSV]
Noise (without filtering) | ENoise, PtP | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits]
 | ENoise, RMS | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits]
 | Max. SNR | > (tbd) [dB] |  |  |  | > (tbd) [dB] |  |  |  | > (tbd) [dB]
 | Noisedensity@1kHz | < (tbd) |  |  |  | < (tbd) |  |  |  | < (tbd)
Noise (with 50 Hz FIR filtering) | ENoise, PtP | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits]
 | ENoise, RMS | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits]
 | Max. SNR | > (tbd) [dB] |  |  |  | > (tbd) [dB] |  |  |  | > (tbd) [dB]
Common-mode rejection ratio (without filtering)3 |  | DC: < (tbd) Ω/V typ. | 50 Hz: < (tbd) kΩ/V typ. |  | 1 kHz: < (tbd) kΩ/V typ. | DC: < (tbd) Ω/V typ. | 50 Hz: < (tbd) kΩ/V typ. |  | 1 kHz: < (tbd) kΩ/V typ. | DC: < (tbd) Ω/V typ. | 50 Hz: < (tbd) kΩ/V typ. |  | 1 kHz: < (tbd) kΩ/V typ.
Common-mode rejection ratio (with 50 Hz FIR filtering)3 |  | DC: < (tbd) Ω/V typ. | 50 Hz: < (tbd) Ω/V typ. |  | 1 kHz: < (tbd) Ω/V typ. | DC: < (tbd) Ω/V typ. | 50 Hz: < (tbd) kΩ/V typ. |  | 1 kHz: < (tbd) kΩ/V typ. | DC: < (tbd) Ω/V typ. | 50 Hz: < (tbd) kΩ/V typ. |  | 1 kHz: < (tbd) kΩ/V typ.
Largest short-term deviation during a specified electrical interference test |  | ±(tbd)%FSV = ±(tbd) ppmFSV typ. |  |  |  | ±(tbd)%FSV = ±(tbd) ppmFSV typ. |  |  |  | ±(tbd)%FSV = ±(tbd) ppmFSV typ.
3) Values related to a common mode interference between SGND and internal ground.
Resistance measurement range 5 kΩ
Representation resistance measurement range 5 kΩ
Note: The channel also works in electrically bipolar mode and records negative values in the unipolar measuring ranges (measurement from 0 V, 0 mA, 4 mA, 0 Ω). This enables the channel to provide a precise diagnosis even with signals < 0. In these measuring ranges the limit value for the "Underrange Error" in Extended Mode is -1% of the full scale value (FSV). The limit value can be set in CoE object 0x80n0:32. This avoids irritating error messages if the channel is not wired (e.g. without sensor) or the electrical signal fluctuates slightly around zero. The process data value of 0x00000000 is not undershot.
If the "UnderrangeError" detection is to be set even less sensitive, the magnitude of the negative limit value in the CoE object referred to above can be set even higher.
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.
Measurement electrical resistance 2 kΩ
Measurement mode |  | Electrical resistance 0..2 kΩ
Operation mode |  | 2.5 V feed voltage, fixed setting n +Uv 5 kΩ reference resistance at ‑I2 Supply current is given by: 2.5 V / (5 kΩ + Rmeasurement)
Measuring range, nominal |  | 0…2 kΩ
Measuring range, end value (full scale value) |  | 2 kΩ
Measuring range, technically usable |  | 0 Ω… 2.147 kΩ
PDO resolution |  | 23 Bit (unsigned)
PDO LSB (Extended Range) |  | 256 µΩ
PDO LSB (Legacy Range) |  | 238.. µΩ
Basic accuracy: Measuring deviation at 23°C, with averaging |  | 2-wire connection: ±(tbd)% typ. (FSV) 3-wire connection: ±(tbd)% typ. (FSV) 4-wire connection: ±(tbd)% typ. (FSV)
Temperature coefficient (Terminal) | TcTerminal | < (tbd) ppm/K typ.
Measurement mode |  | Resistance (2 wire) |  |  |  | Resistance (3 wire) |  |  |  | Resistance (4 wire)
Offset/Zero Point deviation (at 23°C) | EOffset | < (tbd) [ppmFSV] |  |  |  | < (tbd) [ppmFSV] |  |  |  | < (tbd) [ppmFSV]
Gain/scale/amplification deviation (at 23°C) | EGain | < (tbd) [ppm] |  |  |  | < (tbd) [ppm] |  |  |  | < (tbd) [ppm]
Non-linearity over the whole measuring range | ELin | < (tbd) [ppmFSV] |  |  |  | < (tbd) [ppmFSV] |  |  |  | < (tbd) [ppmFSV]
Repeatability | ERep | < (tbd) [ppmFSV] |  |  |  | < (tbd) [ppmFSV] |  |  |  | < (tbd) [ppmFSV]
Noise (without filtering) | ENoise, PtP | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits]
 | ENoise, RMS | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits]
 | Max. SNR | > (tbd) [dB] |  |  |  | > (tbd) [dB] |  |  |  | > (tbd) [dB]
 | Noisedensity@1kHz | < (tbd) |  |  |  | < (tbd) |  |  |  | < (tbd)
Noise (with 50 Hz FIR filtering) | ENoise, PtP | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits]
 | ENoise, RMS | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits]
 | Max. SNR | > (tbd) [dB] |  |  |  | > (tbd) [dB] |  |  |  | > (tbd) [dB]
Common-mode rejection ratio (without filtering)3 |  | DC: < (tbd) Ω/V typ. | 50 Hz: < (tbd) kΩ/V typ. |  | 1 kHz: < (tbd) kΩ/V typ. | DC: < (tbd) Ω/V typ. | 50 Hz: < (tbd) kΩ/V typ. |  | 1 kHz: < (tbd) kΩ/V typ. | DC: < (tbd) Ω/V typ. | 50 Hz: < (tbd) kΩ/V typ. |  | 1 kHz: < (tbd) kΩ/V typ.
Common-mode rejection ratio (with 50 Hz FIR filtering)3 |  | DC: < (tbd) Ω/V typ. | 50 Hz: < (tbd) Ω/V typ. |  | 1 kHz: < (tbd) Ω/V typ. | DC: < (tbd) Ω/V typ. | 50 Hz: < (tbd) kΩ/V typ. |  | 1 kHz: < (tbd) kΩ/V typ. | DC: < (tbd) Ω/V typ. | 50 Hz: < (tbd) kΩ/V typ. |  | 1 kHz: < (tbd) kΩ/V typ.
Largest short-term deviation during a specified electrical interference test |  | ±(tbd)%FSV = ±(tbd) ppmFSV typ. |  |  |  | ±(tbd)%FSV = ±(tbd) ppmFSV typ. |  |  |  | ±(tbd)%FSV = ±(tbd) ppmFSV typ.
3) Values related to a common mode interference between SGND and internal ground.
Representation Widerstandsmeasurement range 2 kΩ
Note: The channel also works in electrically bipolar mode and records negative values in the unipolar measuring ranges (measurement from 0 V, 0 mA, 4 mA, 0 Ω). This enables the channel to provide a precise diagnosis even with signals < 0. In these measuring ranges the limit value for the "Underrange Error" in Extended Mode is -1% of the full scale value (FSV). The limit value can be set in CoE object 0x80n0:32. This avoids irritating error messages if the channel is not wired (e.g. without sensor) or the electrical signal fluctuates slightly around zero. The process data value of 0x00000000 is not undershot.
If the "UnderrangeError" detection is to be set even less sensitive, the magnitude of the negative limit value in the CoE object referred to above can be set even higher.
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.
Measurement electrical resistance 500 Ω
Measurement mode |  | Electrical resistance 0..500 Ω
Operation mode |  | 4.5 V feed voltage, fixed setting n +Uv 5 kΩ reference resistance at ‑I2 Supply current is given by: 4.5 V / (5 kΩ + Rmeasurement)
Measuring range, nominal |  | 0…500 Ω
Measuring range, end value (full scale value) |  | 500 Ω
Measuring range, technically usable |  | 0 Ω…536.8 Ω
PDO resolution |  | 23 Bit (unsigned)
PDO LSB (Extended Range) |  | 64 µΩ
PDO LSB (Legacy Range) |  | 59.6.. µΩ
Basic accuracy: Measuring deviation at 23°C, with averaging |  | 2-wire connection: ±(tbd)% typ. (FSV) 3-wire connection: ±(tbd)% typ. (FSV) 4-wire connection: ±(tbd)% typ. (FSV)
Temperature coefficient (Terminal) | TcTerminal | < (tbd) ppm/K typ.
Measurement mode |  | Resistance (2 wire) |  |  |  | Resistance (3 wire) |  |  |  | Resistance (4 wire)
Offset/Zero Point deviation (at 23°C) | EOffset | < (tbd) [ppmFSV] |  |  |  | < (tbd) [ppmFSV] |  |  |  | < (tbd) [ppmFSV]
Gain/scale/amplification deviation (at 23°C) | EGain | < (tbd) [ppm] |  |  |  | < (tbd) [ppm] |  |  |  | < (tbd) [ppm]
Non-linearity over the whole measuring range | ELin | < (tbd) [ppmFSV] |  |  |  | < (tbd) [ppmFSV] |  |  |  | < (tbd) [ppmFSV]
Repeatability | ERep | < (tbd) [ppmFSV] |  |  |  | < (tbd) [ppmFSV] |  |  |  | < (tbd) [ppmFSV]
Noise (without filtering) | ENoise, PtP | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits]
 | ENoise, RMS | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits]
 | Max. SNR | > (tbd) [dB] |  |  |  | > (tbd) [dB] |  |  |  | > (tbd) [dB]
 | Noisedensity@1kHz | < (tbd) |  |  |  | < (tbd) |  |  |  | < (tbd)
Noise (with 50 Hz FIR filtering) | ENoise, PtP | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits]
 | ENoise, RMS | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits]
 | Max. SNR | > (tbd) [dB] |  |  |  | > (tbd) [dB] |  |  |  | > (tbd) [dB]
Common-mode rejection ratio (without filtering)3 |  | DC: < (tbd) Ω/V typ. | 50 Hz: < (tbd) kΩ/V typ. |  | 1 kHz: < (tbd) kΩ/V typ. | DC: < (tbd) Ω/V typ. | 50 Hz: < (tbd) kΩ/V typ. |  | 1 kHz: < (tbd) kΩ/V typ. | DC: < (tbd) Ω/V typ. | 50 Hz: < (tbd) kΩ/V typ. |  | 1 kHz: < (tbd) kΩ/V typ.
Common-mode rejection ratio (with 50 Hz FIR filtering)3 |  | DC: < (tbd) Ω/V typ. | 50 Hz: < (tbd) Ω/V typ. |  | 1 kHz: < (tbd) Ω/V typ. | DC: < (tbd) Ω/V typ. | 50 Hz: < (tbd) kΩ/V typ. |  | 1 kHz: < (tbd) kΩ/V typ. | DC: < (tbd) Ω/V typ. | 50 Hz: < (tbd) kΩ/V typ. |  | 1 kHz: < (tbd) kΩ/V typ.
Largest short-term deviation during a specified electrical interference test |  | ±(tbd)%FSV = ±(tbd) ppmFSV typ. |  |  |  | ±(tbd)%FSV = ±(tbd) ppmFSV typ. |  |  |  | ±(tbd)%FSV = ±(tbd) ppmFSV typ.
3) Values related to a common mode interference between SGND and internal ground.
Representation Widerstandsmeasurement range 500 Ω
Note: The channel also works in electrically bipolar mode and records negative values in the unipolar measuring ranges (measurement from 0 V, 0 mA, 4 mA, 0 Ω). This enables the channel to provide a precise diagnosis even with signals < 0. In these measuring ranges the limit value for the "Underrange Error" in Extended Mode is -1% of the full scale value (FSV). The limit value can be set in CoE object 0x80n0:32. This avoids irritating error messages if the channel is not wired (e.g. without sensor) or the electrical signal fluctuates slightly around zero. The process data value of 0x00000000 is not undershot.
If the "UnderrangeError" detection is to be set even less sensitive, the magnitude of the negative limit value in the CoE object referred to above can be set even higher.
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.
Measurement electrical resistance 200 Ω
Measurement mode |  | Electrical resistance 0..200 Ω
Operation mode |  | 4.5 V feed voltage, fixed setting n +Uv 5 kΩ reference resistance at ‑I2 Supply current is given by: 4.5 V / (5 kΩ + Rmeasurement)
Measuring range, nominal |  | 0…200 Ω
Measuring range, end value (full scale value) |  | 200 Ω
Measuring range, technically usable |  | 0 Ω… 214.7 Ω
PDO resolution |  | 23 Bit (unsigned)
PDO LSB (Extended Range) |  | 25.6 µΩ
PDO LSB (Legacy Range) |  | 23.8.. µΩ
Basic accuracy: Measuring deviation at 23°C, with averaging |  | 2-wire connection: ±(tbd)% typ. (FSV) 3-wire connection: ±(tbd)% typ. (FSV) 4-wire connection: ±(tbd)% typ. (FSV)
Temperature coefficient (Terminal) | TcTerminal | < (tbd) ppm/K typ.
Measurement mode |  | Resistance (2 wire) |  |  |  | Resistance (3 wire) |  |  |  | Resistance (4 wire)
Offset/Zero Point deviation (at 23°C) | EOffset | < (tbd) [ppmFSV] |  |  |  | < (tbd) [ppmFSV] |  |  |  | < (tbd) [ppmFSV]
Gain/scale/amplification deviation (at 23°C) | EGain | < (tbd) [ppm] |  |  |  | < (tbd) [ppm] |  |  |  | < (tbd) [ppm]
Non-linearity over the whole measuring range | ELin | < (tbd) [ppmFSV] |  |  |  | < (tbd) [ppmFSV] |  |  |  | < (tbd) [ppmFSV]
Repeatability | ERep | < (tbd) [ppmFSV] |  |  |  | < (tbd) [ppmFSV] |  |  |  | < (tbd) [ppmFSV]
Noise (without filtering) | ENoise, PtP | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits]
 | ENoise, RMS | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits]
 | Max. SNR | > (tbd) [dB] |  |  |  | > (tbd) [dB] |  |  |  | > (tbd) [dB]
 | Noisedensity@1kHz | < (tbd) |  |  |  | < (tbd) |  |  |  | < (tbd)
Noise (with 50 Hz FIR filtering) | ENoise, PtP | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits]
 | ENoise, RMS | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits]
 | Max. SNR | > (tbd) [dB] |  |  |  | > (tbd) [dB] |  |  |  | > (tbd) [dB]
Common-mode rejection ratio (without filtering)3 |  | DC: < (tbd) Ω/V typ. | 50 Hz: < (tbd) kΩ/V typ. |  | 1 kHz: < (tbd) kΩ/V typ. | DC: < (tbd) Ω/V typ. | 50 Hz: < (tbd) kΩ/V typ. |  | 1 kHz: < (tbd) kΩ/V typ. | DC: < (tbd) Ω/V typ. | 50 Hz: < (tbd) kΩ/V typ. |  | 1 kHz: < (tbd) kΩ/V typ.
Common-mode rejection ratio (with 50 Hz FIR filtering)3 |  | DC: < (tbd) Ω/V typ. | 50 Hz: < (tbd) Ω/V typ. |  | 1 kHz: < (tbd) Ω/V typ. | DC: < (tbd) Ω/V typ. | 50 Hz: < (tbd) kΩ/V typ. |  | 1 kHz: < (tbd) kΩ/V typ. | DC: < (tbd) Ω/V typ. | 50 Hz: < (tbd) kΩ/V typ. |  | 1 kHz: < (tbd) kΩ/V typ.
Largest short-term deviation during a specified electrical interference test |  | ±(tbd)%FSV = ±(tbd) ppmFSV typ. |  |  |  | ±(tbd)%FSV = ±(tbd) ppmFSV typ. |  |  |  | ±(tbd)%FSV = ±(tbd) ppmFSV typ.
3) Values related to a common mode interference between SGND and internal ground.
Representation Widerstandsmeasurement range 200 Ω
Note: The channel also works in electrically bipolar mode and records negative values in the unipolar measuring ranges (measurement from 0 V, 0 mA, 4 mA, 0 Ω). This enables the channel to provide a precise diagnosis even with signals < 0. In these measuring ranges the limit value for the "Underrange Error" in Extended Mode is -1% of the full scale value (FSV). The limit value can be set in CoE object 0x80n0:32. This avoids irritating error messages if the channel is not wired (e.g. without sensor) or the electrical signal fluctuates slightly around zero. The process data value of 0x00000000 is not undershot.
If the "UnderrangeError" detection is to be set even less sensitive, the magnitude of the negative limit value in the CoE object referred to above can be set even higher.
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.
Measurement electrical resistance 50 Ω
Measurement mode |  | Electrical resistance 0..50 Ω
Operation mode |  | 4.5 V feed voltage, fixed setting n +Uv 5 kΩ reference resistance at ‑I2 Supply current is given by: 4.5 V / (5 kΩ + Rmeasurement)
Measuring range, nominal |  | 0…50 Ω
Measuring range, end value (full scale value) |  | 50 Ω
Measuring range, technically usable |  | 0 Ω…53.68 Ω
PDO resolution |  | 23 Bit (unsigned)
PDO LSB (Extended Range) |  | 6.4 µΩ
PDO LSB (Legacy Range) |  | 5.96.. µΩ
Basic accuracy: Measuring deviation at 23°C, with averaging |  | 2-wire connection: ±(tbd)% typ. (FSV) 3-wire connection: ±(tbd)% typ. (FSV) 4-wire connection: ±(tbd)% typ. (FSV)
Temperature coefficient (Terminal) | TcTerminal | < (tbd) ppm/K typ.
Measurement mode |  | Resistance (2 wire) |  |  |  | Resistance (3 wire) |  |  |  | Resistance (4 wire)
Offset/Zero Point deviation (at 23°C) | EOffset | < (tbd) [ppmFSV] |  |  |  | < (tbd) [ppmFSV] |  |  |  | < (tbd) [ppmFSV]
Gain/scale/amplification deviation (at 23°C) | EGain | < (tbd) [ppm] |  |  |  | < (tbd) [ppm] |  |  |  | < (tbd) [ppm]
Non-linearity over the whole measuring range | ELin | < (tbd) [ppmFSV] |  |  |  | < (tbd) [ppmFSV] |  |  |  | < (tbd) [ppmFSV]
Repeatability | ERep | < (tbd) [ppmFSV] |  |  |  | < (tbd) [ppmFSV] |  |  |  | < (tbd) [ppmFSV]
Noise (without filtering) | ENoise, PtP | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits]
 | ENoise, RMS | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits]
 | Max. SNR | > (tbd) [dB] |  |  |  | > (tbd) [dB] |  |  |  | > (tbd) [dB]
 | Noisedensity@1kHz | < (tbd) |  |  |  | < (tbd) |  |  |  | < (tbd)
Noise (with 50 Hz FIR filtering) | ENoise, PtP | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits]
 | ENoise, RMS | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits] |  | < (tbd) [ppmFSV] |  | < (tbd) [digits]
 | Max. SNR | > (tbd) [dB] |  |  |  | > (tbd) [dB] |  |  |  | > (tbd) [dB]
Common-mode rejection ratio (without filtering)3 |  | DC: < (tbd) Ω/V typ. | 50 Hz: < (tbd) kΩ/V typ. |  | 1 kHz: < (tbd) kΩ/V typ. | DC: < (tbd) Ω/V typ. | 50 Hz: < (tbd) kΩ/V typ. |  | 1 kHz: < (tbd) kΩ/V typ. | DC: < (tbd) Ω/V typ. | 50 Hz: < (tbd) kΩ/V typ. |  | 1 kHz: < (tbd) kΩ/V typ.
Common-mode rejection ratio (with 50 Hz FIR filtering)3 |  | DC: < (tbd) Ω/V typ. | 50 Hz: < (tbd) Ω/V typ. |  | 1 kHz: < (tbd) Ω/V typ. | DC: < (tbd) Ω/V typ. | 50 Hz: < (tbd) kΩ/V typ. |  | 1 kHz: < (tbd) kΩ/V typ. | DC: < (tbd) Ω/V typ. | 50 Hz: < (tbd) kΩ/V typ. |  | 1 kHz: < (tbd) kΩ/V typ.
Largest short-term deviation during a specified electrical interference test |  | ±(tbd)%FSV = ±(tbd) ppmFSV typ. |  |  |  | ±(tbd)%FSV = ±(tbd) ppmFSV typ. |  |  |  | ±(tbd)%FSV = ±(tbd) ppmFSV typ.
3) Values related to a common mode interference between SGND and internal ground.
Representation Widerstandsmeasurement range 50 Ω
Note: The channel also works in electrically bipolar mode and records negative values in the unipolar measuring ranges (measurement from 0 V, 0 mA, 4 mA, 0 Ω). This enables the channel to provide a precise diagnosis even with signals < 0. In these measuring ranges the limit value for the "Underrange Error" in Extended Mode is -1% of the full scale value (FSV). The limit value can be set in CoE object 0x80n0:32. This avoids irritating error messages if the channel is not wired (e.g. without sensor) or the electrical signal fluctuates slightly around zero. The process data value of 0x00000000 is not undershot.
If the "UnderrangeError" detection is to be set even less sensitive, the magnitude of the negative limit value in the CoE object referred to above can be set even higher.
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


RTD measurement

Product overview [image] ELM370x [image] ELM370x - Technical data [image] RTD measurement
RTD measurement
RTD specification and conversion
Temperature measurement with a resistance-dependent RTD sensor generally consists of two steps:
▪
Electrical measurement of the resistance, if necessary in several ohmic measuring ranges
▪
Conversion (transformation) of the resistance into a temperature value by software means according to the set RTD type (PT100, PT1000…).
Both steps can take place locally in the Beckhoff measurement module. The transformation in the module can also be deactivated if it is to be calculated on a higher level in the control. Depending on the module type, several RTD conversions can be implemented which only differs in software. This means for Beckhoff RTD measurement modules that
▪
a specification table of the electrical resistance measurement is given
▪
and based on this, the effect for the temperature measurement is given below depending on the supported RTD type. Note that RTD characteristic curves are always realized as higher-order equations or by a sampling points table in the software, therefore a linear R→T transfer only makes sense in a narrow range.
Application on ELM370x
Basically the electrical resistance measurement range is independent adjustable of the RTD transformation. Thus achievable temperature measuring accuracy depending on the electrical resistance measuring ranges are given in the following. When choosing the combination, make sure that the correct and sufficient electrical resistance measurement range depending on application selection is made, e.g. would be the 50 Ω range in combination with a PT1000 sensor rarely useful only. So a setting have to be chosen for
▪
electrical resistance measurement range within CoE 0x80n0:01
▪
the transformation type within CoE 0x80n0:14
Note to 2/3/4 wire connection in R/RTD operation
With 2‑wire measurement, the line resistance of the sensor supply lines influences the measured value. If a reduction of this systematic error component is desirable for 2‑wire measurements, the resistance of the supply line to the measuring resistance should be taken into account, in which case the resistance of the supply line has to be determined first. Taking into account the uncertainty associated with this supply line resistance, it can then be included statically in the calculation, in the EL3751 via 0x8000:13 and in the ELM350x/ ELM370x via 0x80n0:13. Any change in resistance of the supply line due to ageing, for example, is not taken into account automatically.
A 3‑wire measurement enables the systematic component to be eliminated, assuming that the two supply lines are identical. With this type of measurement, the lead resistance of a supply line is measured continuously. The value determined in this way is then deducted twice from the measurement result, thereby eliminating the line resistance. Technically, this leads to a significantly more reliable measurement. However, taking into account the measurement uncertainty, the gain from the 3‑wire connection is less significant, since this assumption is subject to high uncertainty, in view of the fact that the individual line that was not measured may be damaged, or a varying resistance may have gone unnoticed.
Therefore, although technically the 3‑wire connection is a tried and tested approach, for measurements that are methodological assessed based on measurement uncertainty, we strongly recommend fully‑compensated 4‑wire connection.
With both 2‑wire and 3‑wire connection, the contact resistances of the terminal contacts influence the measuring process. The measuring accuracy can be further increased by a user‑side adjustment with the signal connection plugged in.
Note
Measurement of small resistances
Especially for measurements in the range < 10 Ω, the 4‑wire connection is absolutely necessary due to the relatively high supply and contact resistances. It should also be considered that with such low resistances the relative measurement error in relation to the full scale value (FSV) can become high ‑ for such measurements resistance measurement terminals with small measuring ranges such as EL3692 in 4‑wire measurement should be used if necessary.
Corresponding considerations also lead to the common connection methods in bridge operation:
▪
Full bridge: 4‑wire connection without line compensation, 6‑wire connection with full line compensation
▪
Half bridge: 3‑wire connection without line compensation, 5‑wire connection with full line compensation
▪
Quarter bridge: 2‑wire connection without line compensation, 3‑wire connection with theoretical line compensation and 4‑wire connection with full line compensation
RTD measuring range
Chart: RTD measuring range
In temperature mode, only the legacy range is available, the extended range is not available.
The temperature display in [°C/digit] (e.g. 0.1°/digit or 0.01°/digit) is independent from the electrical measurement. It is “just” a display setting and results from the PDO setting, see chapter "Comissioning".
Data for the sensor types in the following table
The values for the sensor types listed in the following table are shown here merely for informative purposes as an orientation aid. All data are given without guarantee and must be cross-checked against the data sheet for the respective sensor employed.
The RTD measurement consists of a chain of measuring and computing elements that affect the attainable measurement deviation:
The given resistance specification is decisive for the attainable temperature measurement accuracy. It is applied to the possible RTD types in the following.
On account of
▪
the non-linearity existing in the RTD and thus the high dependency of the specification data on the sensor temperature Tsens and
▪
the influence of the ambient temperature on the analog input device employed (leads to a change in Tmeasured on account of ∆Tambient although Tsens = constant)
no detailed temperature specification table is given in the following, but
▪
a short table specifying the electrical measuring range and orientation value for the basic accuracy
▪
a graph of the basic accuracy over Tsens (this at two example ambient temperatures so that the attainable basic accuracy is implied on account of the actual existing ambient temperature)
▪
equations for calculating further parameters (offset/gain/non-linearity/repeatability/noise) if necessary from the resistance specification at the desired operating point
Supported RTD types and transformations supported by the ELM370x from FW01 on:
▪
None
▪
PT100 (-200...850°C)
▪
NI100 (-60...250°C)
▪
PT1000 (-200...850°C)
▪
PT500 (-200...850°C)
▪
PT200 (-200...850°C)
▪
NI1000 (-60...250°C)
▪
NI1000 TK5000 (-30...160°C)
▪
NI120 (-60...320°C)
▪
KT100/110/130/210/230 KTY10/11/13/16/19 (-50...150°C)
▪
KTY81/82-110,120,150 (-50...150°C)
▪
KTY81-121 (-50...150°C)
▪
KTY81-122 (-50...150°C)
▪
KTY81-151 (-50...150°C)
▪
KTY81-152 (-50...150°C)
▪
KTY81/82-210,220,250 (-50...150°C)
▪
KTY81-221 (-50...150°C)
▪
KTY81-222 (-50...150°C)
▪
KTY81-251 (-50...150°C)
▪
KTY81-252 (-50...150°C)
▪
KTY83-110,120,150 (-50...175°C)
▪
KTY83-121 (-50...175°C)
▪
KTY83-122 (-50...175°C)
▪
KTY83-151 (-50...175°C)
▪
KTY83-152 (-50...175°C)
▪
KTY84-130,150 (-40...300°C)
▪
KTY84-151 (-40...300°C)
▪
KTY21/23-6 (-50...150°C)
▪
KTY1x-5 (-50...150°C)
▪
KTY1x-7 (-50...150°C)
▪
KTY21/23-5 (-50...150°C)
▪
KTY21/23-7 (-50...150°C)
▪
B-Parameter
▪
DIN IEC 60751
▪
Steinhart Hart
Specification PT1000 in Measuring range 2kΩ
(Preliminary information)
Temperature measurement RTD | PT1000 3 wire | PT1000 4 wire
Used electrical measuring range | 2 kΩ
Start value | -200°C ≈ 185.2 Ω
End value | 266°C ≈ 2000 Ω
PDO LSB (Legacy Range only) | 0.1/0.01/0.001°C/digit, depending on PDO setting
Basic accuracy: Measuring deviation at 23°C terminals environment temperature, with averaging, typ. | < ±0.043 K @ Tsens = 0°C | < ±0.042 K @ Tsens = 0°C
Basic accuracy for PT1000, 3 wire connection:
Basic accuracy for PT1000, 4 wire connection:
More specification values in preparation.
▪
If further specification data are of interest, they can or must be calculated from the values given in the resistance specification.
The sequence:
▪
General: The conversion is explained here only for one measuring point (a certain input signal); the steps simply have to be repeated in case of several measuring points (up to the entire measuring range).
▪
If the measured resistance at the measured temperature measuring point is unknown, the measured value (MW) in [Ω ] must be determined:
MW = RMeasuring point (TMeasuring point) with the help of an R→T table
▪
The deviation at this resistance value is calculated
–
Via the total equation
–
or a single value, e.g. ESingle = 15 ppmFSV
–
the measurement uncertainty in [Ω] must be calculated:
EResistance(RMeasuring point) = ETotal(RMeasuring point) * FSV
or: EResistance(RMeasuring point) = ESingle(RMeasuring point) * FSV
or (if already known) e.g.: EResistance(RMeasuring point) = 0.03 Ω
▪
The slope at the point used must then be determined:
ΔRproK(TMeasuring point) = [ R(TMeasuring point + 1 °C) – R(TMeasuring point )] / 1 °C
with the help of an R→T table
▪
The temperature measurement uncertainty can be calculated from the resistance measurement uncertainty and the slope
ETemp(RMeasuring point) = (EResistance(TMeasuring point)) / (ΔRproK(TMeasuring point) )
▪
To determine the error of the entire system consisting of RTD and ELM350x in [°C], the two errors must be added together quadratically:
The numerical values used in the following three examples are for illustration purposes. The specification values given in the technical data remain authoritative.
Example 1:
Basic accuracy of an ELM3504 at 35 °C ambient temperature, measurement of -100 °C in the PT1000 interface (4-wire), without the influence of noise and aging:
TMeasuring point = -100 °C
MW = RPT1000, -100 °C = 602.56 Ω
= 86.238 ppmFSV
EResistance(RMeasuring point) = 86.238 ppmFSV * 2000 Ω = 0.1725 Ω
ΔRproK(TMeasuring point) = (R(-99 °C) – R(-100 °C)) / (1 °C) = 4.05 Ω/°C
EELM3504@35°C, PT1000, -100 °C = (0.1725 Ω)/(4.05 Ω/°C) ≈ 0.043 °C (means ±0.043 °C)
Example 2:
Consideration of the repeatability alone under the above conditions:
TMeasuring point = -100 °C
MW = RMeasuring point (-100 °C) = 602.56 Ω
ESingle = 10 ppmFSV
EResistance= 10 ppmFSV * 2000 Ω = 0.02 Ω
ΔRproK(TMeasuring point) = (R-99 °C – R-100 °C) / 1 °C = 4.05 Ω/°C
ETemp(RMeasuring point) = 0.02 Ω / 4.05 Ω/°C ≈ 0.005 °C (means ±0.005 °C)
Example 3:
Consideration of the RMS noise alone without filter under the above conditions:
TMeasuring point = -100 °C
MW = RMeasuring point (-100 °C) = 602.56 Ω
ESingle = 37 ppmFSV
EResistance= 37 ppmFSV * 2000 Ω = 0.074 Ω
ΔRproK(TMeasuring point) = (R-99 °C – R-100 °C) / 1 °C = 4.05 Ω/°C
ETemp(RMeasuring point) = 0.074 Ω / 4.05 Ω/°C ≈ 0.018 °C (means ± 0.018 °C)
Example 4:
If the noise ENoise, PtP of the above example terminal is considered not for one sensor point -100 °C but in general, the following plot results:


Potentiometer measurement

Product overview [image] ELM370x [image] ELM370x - Technical data [image] Potentiometer measurement
Potentiometer measurement
The potentiometer should be supplied with the integrated power supply unit (max. 5 V, configurable). The slider voltage is then measured relative to the supply voltage and output in %. Technical, the measurement is similar to a strain gauge half bridge.
Potentiometers from 1 kΩ can be used.
Diagnostics
▪
Slider breakage: full-scale deflection or 0 display
▪
Supply interruption: full-scale deflection or 0 display
Measurement mode |  |  | Potentiometer (3/ 5 wire)
Operation mode |  |  | The supply voltage is configurable via CoE, 0.5…5 V
Measuring range, nominal |  |  | -1…1 V/V
Measuring range, end value (full scale value) |  |  | 1 V/V
Measuring range, technically usable |  |  | -1…1 V/V
PDO resolution |  |  | 24 bit (incl. sign)
PDO LSB (Extended Range) |  |  | 0.128 ppm
PDO LSB (Legacy Range) |  |  | 0.119… ppm
Basic accuracy: Measuring deviation at 23°C, with averaging |  |  | tbd %FSV = tbd ppmFSV
Input impedance ±Input 1 (Internal resistance) |  |  | Differential tbd typ.
 |  |  | CommonMode tbd typ. Methodology: Resistor against -UV, capacitance against SGND
Input impedance ±Input 2 (Internal resistance) |  |  | Differential tbd typ.
 |  |  | CommonMode tbd typ. Methodology: Resistor against -UV (+2.5V), capacitance against SGND
Offset/Zero Point deviation (at 23°C) | EOffset |  | tbd [ppmFSV]
Gain/scale/amplification deviation (at 23°C) | EGain |  | tbd [ppm]
Non-linearity over the whole measuring range | ELin |  | tbd [ppmFSV]
Repeatability | ERep |  | tbd [ppmFSV]
Noise (peak-to-peak, without filtering) | ENoise, PtP |  | tbd [ppmFSV] |  | tbd [digits]
 | ENoise, RMS |  | tbd [ppmFSV] |  | tbd [digits]
 | Max. SNR |  | tbd [dB]
 | Noisedensity @1kHz |  | tbd
Noise (peak-to-peak, with 50Hz filtering) | ENoise, PtP |  | tbd [ppmFSV] |  | tbd [digits]
 | ENoise, RMS |  | tbd [ppmFSV] |  | tbd [digits]
 | Max. SNR |  | tbd [dB]
Common-mode rejection ratio (without filtering)3 |  |  | DC: tbd [image] typ. | 50 Hz: tbd [image] typ. |  | 1 kHz: tbd [image] typ.
Common-mode rejection ratio (with 50Hz filtering)3 |  |  | DC: tbd [image] typ. | 50 Hz: tbd [image] typ. |  | 1 kHz: tbd [image] typ.
Temperature coefficient |  | TcGain | tbd ppm/K typ.
 |  | TcOffset | tbd ppmFSV/K typ.
Largest short-term deviation during a specified electrical interference test |  |  | tbd %FSV = tbd ppmFSV typ.
2) A regular offset adjustment with connected potentiometer is recommended. The given offset specification of the terminal is therefore practically irrelevant. Therefore, specification values with and without offset are given here. In practice, the offset component can be eliminated by the terminal functions Tare and also ZeroOffset or in the controller by a higher-level tare function. The offset deviation over time can change, therefore Beckhoff recommends a regular offset adjustment or careful observation of the change.
3) Values related to a common mode interference between SGND and internal ground.
Potentiometer measurement range
Representation potentiometer measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement SG 1/1 bridge (full bridge) 4/6-wire connection

Product overview [image] ELM370x [image] ELM370x - Technical data [image] Measurement SG 1/1 bridge (full bridge) 4/6-wire connection
Measurement SG 1/1 bridge (full bridge) 4/6-wire connection
To determine the measuring error:
The nominal/technical measuring range is specified in "mV/V"; the maximum permitted supply voltage is 5 V. The maximum nominal measuring range that can be used for the bridge voltage is therefore ±32 mV/V * 5 V = ±160 mV; the internal circuits are configured accordingly.
The internal measurement is ratiometric, i.e. the feed voltage and the bridge voltage are not measured absolutely, but as a ratio.
The integrated supply can be used as power supply. An external supply is permitted, as long as 5 V is not exceeded.
The following is the specification given for the 6 wire connection. External line resistances are compensated by the 6 wire connection and the full bridge is detected directly from the measuring channel.
In the 4 wire connection, the terminal generally has the same specification, but its view of the connected full bridge is clouded by the unclear and temperature-dependent lead resistances within cables and connectors. In this respect, the overall system "full bridge + leads + measurement channel" will practically not achieve specification values given below. The lead resistances (cables, connectors, ...) have an effect especially on the gain error, also depending on the temperature.
The gain error can be estimated by (R+uv (1+ ∆T* TCCu) + R-uv(1+∆T* TCCu) )/Rnom with TCCu~3930 ppm/K, Rnom e.g. 350 Ω and R+uv or R-uv lead resistances respectively.
Note
Increase measurement accuracy: switcheable shunt
By a user-side adjustment with plugged signal connection, the measurement accuracy can be further increased. The ELM350x and ELM370x terminals also have a shunt resistor which can be switched from their CoE directory (0x80n0:08).
The use of the measurement channel in the 6 wire connection is recommended, especially when significant resistors such as a lightning arrester are put into the line.
Note: specifications apply for 5 V SG excitation and symmetric 350R SG.
Note: Data are valid from production week 01 / 2019 and
▪
for ELM3502: HW03
▪
for ELM3504: HW04
(Preliminary information)
Measurement mode |  | StrainGauge/SG 1/1 Bridge 4/6 wire
 |  | 32 mV |  | 4 mV |  | 2 mV
Integrated power supply |  | 1…5 V adjustable, max. supply/excitation 21 mA (internal electronic overload protection) therefore 120R strain gauge: up to 2.5 V; 350R strain gauge: up to 5.0 V
Measuring range, nominal |  | -32 … +32 mV/V | -4 … +4 mV/V |  | -2 … +2 mV/V
Measuring range, end value (FSV) |  | 32 mV/V | 4 mV/V |  | 2 mV/V
Measuring range, technically usable |  | -34,359 … +34,359 mV/V | -4,295 … +4,295 mV/V |  | -2,147 … +2,147 mV/V
PDO resolution |  | 24 Bit (incl. sign)
PDO LSB (Extended Range) |  | 0.128 ppm
PDO LSB (Legacy Range) |  | 0.119… ppm
Basic accuracy: Measuring deviation at 23°C, with averaging | without offset 2) | < ±0,0025%MBE < ±25 ppmMBE < ±0,80 µV/V | < ±0,0085%MBE < ±85 ppmMBE < ±0,34 µV/V |  | < ±0,013%MBE < ±130 ppmMBE < ±0,26 µV/V
 | with offset 2) | < ±0,0075%MBE < ±75 ppmMBE < ±2,40 µV/V | < ±0,03%MBE < ±300 ppmMBE < ±1,20 µV/V typ |  | < ±0,06%MBE < ±600 ppmMBE < ±1,20 µV/V typ
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmMBE | < 280 ppmMBE |  | < 580 ppmMBE
Gain/scale/amplification deviation (at 23°C) | EGain | < 20 ppm | < 70 ppm |  | < 110 ppm
Non-linearity over the whole measuring range | ELin | < 15 ppmMBE | < 45 ppmMBE |  | < 65 ppmMBE
Repeatability (at 23°C) | ERep | < 5 ppmMBE | < 15 ppmMBE |  | < 20 ppmMBE
Noise (without filtering, at 23°C) | ENoise, PtP | < 150 ppmMBE < 1172 digits < 4,80 µV/V | < 750 ppmMBE < 5859 digits < 3,0 µV/V |  | < 1500 ppmMBE < 11719 digits < 3,0 µV/V
 | ENoise, RMS | < 25 ppmMBE < 195 digits < 0,80 µV/V | < 140 ppmMBE < 1094 digits < 0,56 µV/V |  | < 280 ppmMBE < 2188 digits < 0,56 µV/V
 | Max. SNR | > 92,0 dB | > 77,1 dB |  | > 71,1 dB
 | Noisedensity@1kHz | < 11,31 | < 7,92 |  | < 7,92
Noise (with 50 Hz FIR filter, at 23°C) | ENoise, PtP | < 15 ppmMBE < 117 digits < 0,48 µV/V | < 60 ppmMBE < 469 digits < 0,24 µV/V |  | < 110 ppmMBE < 859 digits < 0,22 µV/V
 | ENoise, RMS | < 2,5 ppmMBE < 20 digits < 0,08 µV/V | < 10,0 ppmMBE < 78 digits < 0,04 µV/V |  | < 20,0 ppmMBE < 156 digits < 0,04 µV/V
 | Max. SNR | > 112,0 dB | > 100,0 dB |  | > 94,0 dB
Common-mode rejection ratio (without filtering)3 | DC | tbd | tbd |  | tbd
 | 50 Hz | tbd | tbd |  | tbd
 | 1 kHz | tbd | tbd |  | tbd
Common-mode rejection ratio (with 50Hz filtering)3 | DC | tbd | tbd |  | tbd
 | 50 Hz | tbd | tbd |  | tbd
 | 1 kHz | tbd | tbd |  | tbd
Temperature coefficient | TcGain | < 1 ppm/K | < 3 ppm/K |  | < 5 ppm/K
 | TcOffset | < 1,2 ppmMBE/K < 0,04 | < 12 ppmMBE/K < 0,05 |  | < 25 ppmMBE/K < 0,05
Largest short-term deviation during a specified electrical interference test |  | tbd %FSV | tbd %FSV |  | tbd %FSV
Input impedance ±Input 1 | Differential | tbd | tbd |  | tbd
 | CommonMode | tbd | tbd |  | tbd
Input impedance ±Input 2 | 3 wire | No usage of this input in this mode
 | Differential | tbd typ. | tbd typ. |  | tbd typ.
 | CommonMode | tbd typ. | tbd typ. |  | tbd typ.
2) In real bridge measurement, an offset adjustment is usually carried out after installation. The given offset specification of the terminal is therefore practically irrelevant. Therefore, specification values with and without offset are given here. In practice, the offset component can be eliminated by the terminal functions Tare and also ZeroOffset or in the controller by a higher-level tare function. The offset deviation of a bridge measurement over time can change, therefore Beckhoff recommends a regular offset adjustment or careful observation of the change.
3) Values related to a common mode interference between SGND and internal ground.
Full bridge calculation:
The strain relationship (µStrain, µε) is as follows:


Measurement SG 1/2 bridge (half bridge) 3/5-wire connection

Product overview [image] ELM370x [image] ELM370x - Technical data [image] Measurement SG 1/2 bridge (half bridge) 3/5-wire connection
Measurement SG 1/2 bridge (half bridge) 3/5-wire connection
To determine the measuring error:
The nominal/technical measuring range is specified in "mV/V"; the maximum permitted supply voltage is 5 V. The maximum nominal measuring range that can be used for the bridge voltage is therefore ±16 mV/V * 5V = ±80 mV; the internal circuits are designed for the 160 mV of the full bridge measurement.
The internal measurement is ratiometric, i.e. the feed voltage and the bridge voltage are not measured absolutely, but as a ratio.
The integrated supply can be used as power supply. An external supply is permitted, as long as 5 V is not exceeded.
The following is the specification given for the 5 wire connection. External line resistances are compensated by the 5 wire connection and the half-bridge is detected directly from the measuring channel.
In the 3 wire connection, the terminal generally has the same specification, but its view of the connected half-bridge is clouded by the unclear and temperature-dependent lead resistances within cables and connectors. In this respect, the overall system "half-bridge + leads + measurement channel" will practically not achieve specification values given below. The lead resistances (cables, connectors, ...) have an effect especially on the gain error, also depending on the temperature.
The gain error can be estimated by (R+uv (1+ ∆T* TCCu) + R-uv(1+∆T* TCCu) )/Rnom with TCCu~3930 ppm/K, Rnom e.g. 350 Ω and R+uv or R-uv lead resistances respectively.
The use of the measurement channel in the 5 wire connection is recommended.
Measurement mode
SG 1/2 bridge
Integrated power supply
1…5 V adjustable, max. supply/excitation 21 mA (internal electronic overload protection) therefore
▪
120R strain gauge: up to 2.5 V
▪
350R strain gauge: up to 5.0 V
Note: specifications apply for 3.5 V SG excitation and symmetric 350R SG.
Note: Adjustment of the half-bridge measurement and thus validity of the data from production week 2018/ 50
(Preliminary information)
Measurement mode |  | SG 1/2-Bridge (16 mV) | SG 1/2-Bridge (2 mV)
Basic accuracy: Measuring deviation at 23°C, with averaging | without offset | < ±120 [ppmFSV] typ. | <±900 [ppmFSV] typ.
 | with offset | < ±500 [ppmFSV] typ. | < ±2700 [ppmFSV] typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 485 [ppmFSV] | < 2550 [ppmFSV]
Gain/scale/amplification deviation (at 23°C) | EGain | < 70 [ppm] | < 500 [ppm]
Non-linearity over the whole measuring range | ELin | < 90 [ppmFSV] | < 740 [ppmFSV]
Repeatability | ERep | < 40 [ppmFSV] | < 120 [ppmFSV]
Noise (without filtering) | ENoise, PtP | < 1100 [ppmFSV] < 8594 [digits] | < 8800 [ppmFSV] < 68750 [digits]
 | ENoise, RMS | < 150 [ppmFSV] < 1172 [digits] | < 1200 [ppmFSV] < 9375 [digits]
 | Max. SNR | > 76.5 [dB] | > 58.4 [dB]
 | Noisedensity@1kHz | < 33.94 | < 33.94
Noise (with 50 Hz FIR filtering) | ENoise, PtP | < 150 [ppmFSV] < 1172 [digits] | < 1200 [ppmFSV] < 9375 [digits]
 | ENoise, RMS | < 25.0 [ppmFSV] < 195 [digits] | < 200 [ppmFSV] < 1563 [digits]
 | Max. SNR | > 92.0 [dB] | > 74.0 [dB]
Common-mode rejection ratio (without filtering)3 | DC: | tbd [image] typ. | tbd [image] typ.
 | 50 Hz: | tbd [image] typ. | tbd [image] typ.
 | 1 kHz: | tbd [image] typ. | tbd [image] typ.
Common-mode rejection ratio (with 50 Hz FIR filtering)3 | DC: | tbd [image] typ. | tbd [image] typ.
 | 50 Hz: | tbd [image] typ. | tbd [image] typ.
 | 1 kHz: | tbd [image] typ. | tbd [image] typ.
Temperature coefficient | TcGain | tbd ppm/K typ. | tbd ppm/K typ.
 | TcOffset | tbd ppmFSV/K typ. | tbd ppmFSV/K typ.
Largest short-term deviation during a specified electrical interference test |  | tbd | tbd
Input impedance ±Input 1 (Internal resistance) |  | Differential: tbd typ. | Differential: tbd typ.
 |  | CommonMode: tbd typ. | CommonMode: tbd typ.
Input impedance ±Input 2 (Internal resistance) |  | 3 wire: No usage of this input in this mode | 3 wire: No usage of this input in this mode
 |  | Differential: tbd typ. | Differential: tbd typ.
 |  | CommonMode: tbd typ. | CommonMode: tbd typ.
3) Values related to a common mode interference between SGND and internal ground.
Note
Transition resistances of the terminal contacts
The transition resistance values of the terminal contacts affect the measurement. The measuring accuracy can be further increased by a user-side adjustment with the signal connection plugged in.
Validity of property values
The resistor of the bridge is positioned parallel to the internal resistor of the terminal and leads to an offset shifting respectively. The Beckhoff factory calibration will be carried out with the half bridge 350 Ω, thus the values specified above are directly valid for the 350 Ω half bridge. By connection of another dimensioned half-bridge is to:
•
perform a balancing (offset correction) by the terminal itself or the control/PLC on application side
•
or the abstract offset error have to be entered into the balancing parameter S0 of the terminal. Example: a 350 Ω half bridge correlates by the compensated effect of the input resistor (2 MΩ) during factory calibration 0.26545 %FSV (16 mV/V), that corresponds to 20738 digits.
Half bridge calculation:
R3/4 are the internal switchable input resistors of the terminal. Other configurations (e.g. R1/4 or R1/3 variable) of half bridges are not supported.
The strain relationship (µStrain, µε) is as follows:
N should be chosen based on the mechanical configuration of the variable resistors (Poisson, 2 active uniaxial, …). The channel value (PDO) is interpreted directly [mV/V]:


Measurement SG 1/4 bridge (quarter-bridge) 2/3-wire connection

Product overview [image] ELM370x [image] ELM370x - Technical data [image] Measurement SG 1/4 bridge (quarter-bridge) 2/3-wire connection
Measurement SG 1/4 bridge (quarter-bridge) 2/3-wire connection
Notes
▪
In practice, quarter-bridge measurement is not recommended in 2-wire mode. Common copper supply lines with inherent resistance (e.g. approx. 17 mΩ/m with 1 mm² stranded wire) and very high temperature sensitivity (approx. 4000 ppm/K, approx. 0.4%/K) have a significant influence on the calculation, which can only be corrected through continuous offset and gain adjustment. Only 3-wire operation should be used.
▪
Specifications apply to 5 V strain gauge excitation.
▪
Specifications only apply when using ferrules and for cross-sections of 0.5 mm² or more. For smaller cross-sections, increased transition resistance is to be expected.
▪
Avoid repeated insertion/extraction of the push-in connectors in quarter-bridge operation, since this may increase the contact resistance
▪
Integrated power supply: 1…5 V adjustable, max. supply/excitation 21 mA (internal electronic overload protection)
(Preliminary information)
Measurement mode |  | SG 1/4-Bridge 120 Ω (3 wire)
 |  | 32 mV/V FSV | 8 mV/V FSV | 4 mV/V 5) FSV (comp.) | 2 mV/V 5) FSV (comp.)
Measuring range, nominal |  | ±32 mV/V [corresponds to ±64,000 µε at K=2] 120 ± 15.36 Ω | ±8 mV/V [corresponds to ±16,000 µε at K=2] 120 ± 3.84 Ω | ±4 mV/V [corresponds to ±8,000 µε at K=2] 120 ± 1.92 Ω | ±2 mV/V [corresponds to ±4,000 µε at K=2] 120 ± 0.96 Ω
Measuring range, end value (FSV) |  | 32 mV/V | 8 mV/V | 4 mV/V | 2 mV/V
Measuring range, technically usable |  | ±34.359... mV/V | ±8.589... mV/V | ±4.294... mV/V | ±2.147... mV/V
PDO resolution |  | 24 Bit (incl. sign)
PDO LSB (Extended Range) |  | 0,128 ppm 4,096 nV/V | 0,128 ppm 1,024 nV/V | 0,128 ppm 0,512 nV/V | 0,128 ppm 0,256 nV/V
PDO LSB (Legacy Range) |  | 0,119… ppm 3,814.. nV/V | 0,119… ppm 0,9535 nV/V | 0,119… ppm 0,47675 nV/V | 0,119… ppm 0,238375 nV/V
Basic accuracy: Measuring deviation at 23°C, with averaging, without offset 2) |  | < ±0,026%MBE < ±260 ppmMBE < ±8,3 µV/V | < ±0,08%MBE < ±800 ppmMBE < ±6,4 µV/V | < ±0,16%MBE < ±1600 ppmMBE < ±6,4 µV/V | < ±0,32%MBE < ±3200 ppmMBE < ±6,4 µV/V
Basic accuracy: Measuring deviation at 23°C, with averaging, with offset 2) |  | < ±0,1%MBE < ±1000 ppmMBE < ±32,0 µV/V | < ±0,4%MBE < ±4000 ppmMBE < ±32,0 µV/V | < ±0,8%MBE < ±8000 ppmMBE < ±32,0 µV/V | < ±1,6%MBE < ±16000 ppmMBE < ±32,0 µV/V
Offset/Zero Point deviation (at 23°C) | EOffset | < 960 ppmMBE | < 3920 ppmMBE | < 7840 ppmMBE | < 15680 ppmMBE
Gain/scale/amplification deviation (at 23°C) | EGain | < 160 ppm | < 440 ppm | < 880 ppm | < 1760 ppm
Non-linearity over the whole measuring range | ELin | < 200 ppmMBE | < 650 ppmMBE | < 1300 ppmMBE | < 2600 ppmMBE
Repeatability (at 23°C) | ERep | < 25 ppmMBE | < 100 ppmMBE | < 200 ppmMBE | < 400 ppmMBE
Noise (without filtering, at 23°C) | ENoise, PtP | < 310 ppmMBE < 2422 digits < 9,92 µV/V | < 1200 ppmMBE < 9375 digits < 9,60 µV/V | < 2400 ppmMBE < 18750 digits < 9,60 µV/V | < 4800 ppmMBE < 37500 digits < 9,60 µV/V
 | ENoise, RMS | < 50 ppmMBE < 391 digits < 1,60 µV/V | < 200 ppmMBE < 1563 digits < 1,60 µV/V | < 400 ppmMBE < 3125 digits < 1,60 µV/V | < 800 ppmMBE < 6250 digits < 1,60 µV/V
 | Max. SNR | > 86,0 dB | > 74,0 dB | > 68,0 dB | > tbd dB
 | Noisedensity@1kHz | < 0.02 | < 0.02 | < 0.02 | < 0.02
Noise (with 50 Hz FIR filter, at 23°C) | ENoise, PtP | < 24 ppmMBE < 188 digits < 0,77 µV/V | < 72 ppmMBE < 563 digits < 0,58 µV/V | < 144 ppmMBE < 1125 digits < 0,58 µV/V | < 288 ppmMBE < 2250 digits < 0,58 µV/V
 | ENoise, RMS | < 4,0 ppmMBE < 31 digits < 0,13 µV/V | < 12,0 ppmMBE < 94 digits < 0,10 µV/V | < 24,0 ppmMBE < 188 digits < 0,10 µV/V | < 48,0 ppmMBE < 375 digits < 0,10 µV/V
 | Max. SNR | > 108,0 dB | > 98,4 dB | > 92,4 dB | > 86,4 dB
Common-mode rejection ratio (without filtering)3 |  | tbd | tbd | tbd | tbd
Common-mode rejection ratio (with 50Hz filtering)3 |  | tbd | tbd | tbd | tbd
Temperature coefficient | TcGain | < 20 ppm/K | < 48 ppm/K | < 96 ppm/K | < 192 ppm/K
 | TcOffset | < 50 ppmMBE/K < 1,60 µV/V/K | < 180 ppmMBE/K < 1,44 µV/V/K | < 360 ppmMBE/K < 1,44 µV/V/K | < 720 ppmMBE/K < 1,44 µV/V/K
Largest short-term deviation during a specified electrical interference test |  | tbd %FSV typ. | tbd %FSV typ. | tbd %FSV typ. | tbd %FSV typ.
(Preliminary information)
Measurement mode |  | SG 1/4-Bridge 350 Ω (3 wire)
 |  | 32 mV/V FSV | 8 mV/V FSV | 4 mV/V FSV (comp.) | 2 mV/V FSV (comp.)
Measuring range, nominal |  | ±32 mV/V [corresponds to ±64,000 µε at K=2] 350 ± 44.8 Ω | ±8 mV/V [corresponds to ±16,000 µε at K=2] 350 ± 11.2 Ω | ±4 mV/V [corresponds to ±8,000 µε at K=2] 350 ± 15.6 Ω | ±2 mV/V [corresponds to ±4,000 µε at K=2] 350 ± 2.8 Ω
Measuring range, end value (FSV) |  | 32 mV/V | 8 mV/V | 4 mV/V | 2 mV/V
Measuring range, technically usable |  | ±34.359... mV/V | ±8.589... mV/V | ±4.294... mV/V | ±2.147... mV/V
PDO resolution |  | 24 Bit (incl. sign) | 24 Bit (incl. sign) | 24 Bit (incl. sign) | 24 Bit (incl. sign)
PDO LSB (Extended Range) |  | 4.096 nV/V | 1.024 nV/V | 0.512 nV/V | 0.256 nV/V
PDO LSB (Legacy Range) |  | 3.814.. nV/V | 0.9535 nV/V | 0.47675 nV/V | 0.238375 nV/V
Basic accuracy: Measuring deviation at 23°C, with averaging, without offset 2) |  | < ±0,022%MBE < ±220 ppmMBE < ±7,0 µV/V | < ±0,08%MBE < ±800 ppmMBE < ±6,4 µV/V | < ±0,16%MBE < ±1600 ppmMBE < ±6,4 µV/V | < ±0,32%MBE < ±3200 ppmMBE < ±6,4 µV/V
Basic accuracy: Measuring deviation at 23°C, with averaging, with offset 2) |  | < ±0,1%MBE < ±1000 ppmMBE < ±32,0 µV/V | < ±0,4%MBE < ±4000 ppmMBE < ±32,0 µV/V | < ±0,8%MBE < ±8000 ppmMBE < ±32,0 µV/V | < ±1,6%MBE < ±16000 ppmMBE < ±32,0 µV/V
Offset/Zero Point deviation (at 23°C) | EOffset | < 970 ppmMBE | < 3920 ppmMBE | < 7840 ppmMBE | < 15680 ppmMBE
Gain/scale/amplification deviation (at 23°C) | EGain | < 120 ppm | < 380 ppm | < 760 ppm | < 1520 ppm
Non-linearity over the whole measuring range | ELin | < 180 ppmMBE | < 690 ppmMBE | < 1380 ppmMBE | < 2760 ppmMBE
Repeatability (at 23°C) | ERep | < 25 ppmMBE | < 100 ppmMBE | < 200 ppmMBE | < 400 ppmMBE
Noise (without filtering, at 23°C) | ENoise, PtP | < 320 ppmMBE < 2500 digits < 10,24 µV/V | < 1200 ppmMBE < 9375 digits < 9,60 µV/V | < 2400 ppmMBE < 18750 digits < 9,60 µV/V | < 4800 ppmMBE < 37500 digits < 9,60 µV/V
 | ENoise, RMS | < 55 ppmMBE < 430 digits < 1,76 µV/V | < 200 ppmMBE < 1563 digits < 1,60 µV/V | < 400 ppmMBE < 3125 digits < 1,60 µV/V | < 800 ppmMBE < 6250 digits < 1,60 µV/V
 | Max. SNR | > 85,2 dB | > 74,0 dB | > 68,0 dB | > 61,9 dB
 | Noisedensity@1kHz | <0.02 | < 0.02 | < 0.02 | < 0.02
Noise (with 50 Hz FIR filter, at 23°C) | ENoise, PtP | < 18 ppmMBE < 141 digits < 0,58 µV/V | < 72 ppmMBE < 563 digits < 0,58 µV/V | < 144 ppmMBE < 1125 digits < 0,58 µV/V | < 288 ppmMBE < 2250 digits < 0,58 µV/V
 | ENoise, RMS | < 3,0 ppmMBE < 23 digits < 0,10 µV/V | < 12,0 ppmMBE < 94 digits < 0,10 µV/V | < 24,0 ppmMBE < 188 digits < 0,10 µV/V | < 48,0 ppmMBE < 375 digits < 0,10 µV/V
 | Max. SNR | > 110,5 dB | > 98,4 dB | > 92,4 dB | > 86,4 dB
Common-mode rejection ratio (without filtering)3 |  | tbd | tbd | tbd | tbd
Common-mode rejection ratio (with 50Hz filtering)3 |  | tbd | tbd | tbd | tbd
Temperature coefficient | TcGain | < 12 ppm/K | < 50 ppm/K | < 100 ppm/K | < 200 ppm/K
 | TcOffset | < 30 ppmMBE/K < 0,96 µV/V/K | < 110 ppmMBE/K < 0,88 µV/V/K | < 220 ppmMBE/K < 0,88 µV/V/K | < 440 ppmMBE/K < 0,88 µV/V/K
Largest short-term deviation during a specified electrical interference test |  | tbd %FSV typ. | tbd %FSV typ. | tbd %FSV typ. | tbd %FSV typ.
2) In real bridge measurement, an offset adjustment is usually carried out after installation. The given offset specification of the terminal is therefore practically irrelevant. Therefore, specification values with and without offset are given here. In practice, the offset component can be eliminated by the terminal functions Tare and also ZeroOffset or in the controller by a higher-level tare function. The offset deviation of a bridge measurement over time can change, therefore Beckhoff recommends a regular offset adjustment or careful observation of the change.
3) Values refer to common-mode interference between SGND and internal GND.
4) The offset specification does not apply to 2-wire operation, since the offset is increased on the device side. Offset adjustment is recommended, see Tare or Zero offset function.
5) The channel measures electrically to 8 [image], but displays its measured value scaled to 2 or 4 [image]. The Compensated function facilitates measurement of low levels even with high offset.
Note
Transition resistances of the terminal contacts
The transition resistance values of the terminal contacts affect the measurement. The measuring accuracy can be further increased by a user-side adjustment with the signal connection plugged in.
The temperature sensitivity of the terminal and thus of the measurement setup can be reduced if an external, more temperature-stable supplementary resistor is used for terminal operation in half-bridge or even full-bridge mode instead of the internal supplementary resistor for quarter-bridge mode.
To calculate the quarter-bridge:
R2/3/4 are the terminal-internal switchable supplementary resistors, R1 is the (nominally equal-sized) variable quarter-bridge.
The strain relationship (µStrain, µε) is as follows:
For the quarter-bridge, N=1 always applies.
The relationship between UIN/UV and R1 is non-linear:
The ELM350x devices apply internal linearization so that the output is already linearized
since the internal calculation is based on UV'.


Measurement IEPE 10 V/ 20 V/ ±2,5 V..±10 V

Product overview [image] ELM370x [image] ELM370x - Technical data [image] Measurement IEPE 10 V/ 20 V/ ±2,5 V..±10 V
Measurement IEPE 10 V/ 20 V/ ±2,5 V..±10 V
Additional information
•
IEPE high pass properties
•
Measurement ±10 V
•
Measurement ±5 V
•
Measurement ±2.5 V
•
Measurement 0…20 V
•
Measurement 0…10 V


IEPE high pass properties

Product overview [image] ELM370x [image] ELM370x - Technical data [image] Measurement IEPE 10 V/ 20 V/ ±2,5 V..±10 V [image] IEPE high pass properties
IEPE high pass properties
For optional regulation of the IEPE bias voltage, the ELM370x has an adjustable 1 st order high-pass filter. See also section "IEPE AC Coupling".
The typical frequency response in the 2.5 V measuring range is as follows:
Note: if other dynamic filter properties are desired, proceed as follows:
▪
Operate the terminal ELM370x in the measuring range „0..20V“
▪
Deactivate IEPE AC coupling in the respective channel
▪
The channel now measures with 23 bit + sign over 20 V, including the bias voltage which is usually 10..16 V. With a user implementation of a high-pass filter using TwinCAT programming (within the PLC), the bias component (DC component) can now be suppressed on the control side. The now reduced signal resolution of the measuring range ±2.5 V with 24 bits to 20 V with 23 bits has to be considered. In return, the user receives full digital control over the behavior in the lower frequency range.


Measurement ±10 V

Product overview [image] ELM370x [image] ELM370x - Technical data [image] Measurement IEPE 10 V/ 20 V/ ±2,5 V..±10 V [image] Measurement ±10 V
Measurement ±10 V
Measurement mode | ±10 V
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -10…+10 V *)
Measuring range, end value (full scale value) | 10 V
Measuring range, technically usable | -10.737…+10.737 V
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 1.28 µV | 327.68 µV
PDO LSB (Legacy Range) | 1.192.. µV | 305.18.. µV
*) For IEPE measurement applies: The input voltage must not fall below -5 V with respect to GND, the measuring accuracy is then no longer given. This means a measurement down to -10 V with respect to GND is only possible if at the same time an offset of at least +5 V is applied, as is usual with IEPE supply.
Preliminary specifications:
Measurement mode |  | ±10 V
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 60 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 2.55
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation ±10 V measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement ±5 V

Product overview [image] ELM370x [image] ELM370x - Technical data [image] Measurement IEPE 10 V/ 20 V/ ±2,5 V..±10 V [image] Measurement ±5 V
Measurement ±5 V
Measurement mode | ±5 V
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -5…+5 V
Measuring range, end value (full scale value) | 5 V
Measuring range, technically usable | -5.368…+5.368 V
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 640 nV | 163.84 µV
PDO LSB (Legacy Range) | 596.. nV | 152.59.. µV
Preliminary specifications:
Measurement mode |  | ±5 V
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 1.27
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation ±5 V measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement ±2.5 V

Product overview [image] ELM370x [image] ELM370x - Technical data [image] Measurement IEPE 10 V/ 20 V/ ±2,5 V..±10 V [image] Measurement ±2.5 V
Measurement ±2.5 V
Measurement mode | ±2.5 V
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | -2.5…+2.5 V
Measuring range, end value (full scale value) | 2.5 V
Measuring range, technically usable | -2.684…+2.684 V
PDO resolution | 24 bit (including sign) | 16 bit (including sign)
PDO LSB (Extended Range) | 320 nV | 81.92 µV
PDO LSB (Legacy Range) | 298.. nV | 76.29.. µV
Preliminary specifications:
Measurement mode |  | ±2.5 V
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 90 ppmFSV |  | < 703 [digits]
 | ENoise, RMS | < 17 ppmFSV |  | < 133 [digits]
 | Max. SNR | > 95.4 dB
 | Noisedensity@1kHz | < 0.60
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 9 ppmFSV |  | < 70 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation ±2.5 V measurement range
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement 0…20 V

Product overview [image] ELM370x [image] ELM370x - Technical data [image] Measurement IEPE 10 V/ 20 V/ ±2,5 V..±10 V [image] Measurement 0…20 V
Measurement 0…20 V
Measurement mode | 0…20 V
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | 0…20 V
Measuring range, end value (full scale value) | 20 V
Measuring range, technically usable | 0…+21.474 V
PDO resolution | 23 bit (unsigned) | 15 bit (unsigned)
PDO LSB (Extended Range) | 2.56 µV | 655.36 µV
Preliminary specifications:
Measurement mode |  | 0…20 V
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 60 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 2.55
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation 0…20 V measurement range
Note: The channel also works in electrically bipolar mode and records negative values in the unipolar measuring ranges (measurement from 0 V, 0 mA, 4 mA, 0 Ω). This enables the channel to provide a precise diagnosis even with signals < 0. In these measuring ranges the limit value for the "Underrange Error" in Extended Mode is -1% of the full scale value (FSV). The limit value can be set in CoE object 0x80n0:32. This avoids irritating error messages if the channel is not wired (e.g. without sensor) or the electrical signal fluctuates slightly around zero. The process data value of 0x00000000 is not undershot.
If the "UnderrangeError" detection is to be set even less sensitive, the magnitude of the negative limit value in the CoE object referred to above can be set even higher.
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Measurement 0…10 V

Product overview [image] ELM370x [image] ELM370x - Technical data [image] Measurement IEPE 10 V/ 20 V/ ±2,5 V..±10 V [image] Measurement 0…10 V
Measurement 0…10 V
Measurement mode | 0…10 V
Internal resistance | >4 MΩ differential
Impedance | Value to follow
Measuring range, nominal | 0…10 V
Measuring range, end value (full scale value) | 10 V
Measuring range, technically usable | 0…+10.737 V
PDO resolution | 23 bit (unsigned) | 15 bit (unsigned)
PDO LSB (Extended Range) | 1.28 µV | 327.68 µV
Preliminary specifications:
Measurement mode |  | 0…10 V
Basic accuracy: Measuring deviation at 23°C, with averaging |  | < ±0.01% = 100 ppmFSV typ.
Offset/Zero Point deviation (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification deviation (at 23°C) | EGain | < 60 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 2.55
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.03% = 300 ppmFSV typ.
Representation 0…10 V measurement range
Note: The channel also works in electrically bipolar mode and records negative values in the unipolar measuring ranges (measurement from 0 V, 0 mA, 4 mA, 0 Ω). This enables the channel to provide a precise diagnosis even with signals < 0. In these measuring ranges the limit value for the "Underrange Error" in Extended Mode is -1% of the full scale value (FSV). The limit value can be set in CoE object 0x80n0:32. This avoids irritating error messages if the channel is not wired (e.g. without sensor) or the electrical signal fluctuates slightly around zero. The process data value of 0x00000000 is not undershot.
If the "UnderrangeError" detection is to be set even less sensitive, the magnitude of the negative limit value in the CoE object referred to above can be set even higher.
Note: In Extended Range Mode the Underrange/Overrange display in the PDO status has the character of an information/warning when the nominal measuring range is exceeded, i.e. no Error is displayed in the PDO status and LED. If the technical measuring range is also exceeded, Error = TRUE is also displayed. The detection limit for Underrange/Overrange Error can be set in the CoE.
In Legacy Range mode, an Underrange/Overrange event also leads to an Error in the PDO status.


Thermocouple measurement

Product overview [image] ELM370x [image] ELM370x - Technical data [image] Thermocouple measurement
Thermocouple measurement
Note
Thermocouple basics
The following sections assume that the reader is familiar with the contents of the chapter on "Fundamentals of thermocouple technology".
Application to ELM370x
The ELM370x supports voltage measurement and conversion of various thermocouple types, see following list.
For voltage measurement, the specified electrical measuring range specified for the respective TC type is used.
TC measuring range
Chart: TC measuring range
In temperature mode, only the legacy range is available, the extended range is not available.
The temperature display in [°C/digit] (e.g. 0.1°/digit or 0.01°/digit) is independent from the electrical measurement. It is “just” a display setting and results from the PDO setting, see chapter "Comissioning".
TC types supported by the ELM370x (from FW02):
▪
A-1 0...2300°C
▪
A-2 0...1800°C
▪
A-3 0...1800°C
▪
Au/Pt 0...1000°C
▪
B 200...1820°C
▪
C 0...2329°C
▪
D 0...2490°C
▪
E -270...1000°C
▪
G 1000...2300°C
▪
J -210...1200°C
▪
K -270...1372°C
▪
L -50...900°C
▪
N -270...1300°C
▪
P (PLII) 0...1395°C
▪
Pt/Pd 0...1500°C
▪
R -50...1768°C
▪
S -50...1768°C
▪
T -270...400°C
▪
U -50...600°C
The specification data for each type are listed below.
Additional information
•
TC measurement with Beckhoff modules
•
Specification of the thermocouple measurement


TC measurement with Beckhoff modules

Product overview [image] ELM370x [image] ELM370x - Technical data [image] Thermocouple measurement [image] TC measurement with Beckhoff modules
TC measurement with Beckhoff modules
Thermocouple specification and conversion
Temperature measurement with thermocouples generally comprises three steps:
▪
Measuring the electrical voltage
▪
Optional: Temperature measurement of the internal cold junction
▪
Optional: Software-based conversion of the voltage into a temperature value according to the set thermocouple type (K, J, …)
All three steps can take place locally in the Beckhoff measuring module. Module-based transformation can be disabled if the conversion is to take place in the higher-level control system. Depending on the module type, several thermocouple conversions are available, which differ in terms of their software implementation.
For Beckhoff thermocouple measuring modules this means that
▪
a specification of the electrical voltage measurement is provided
▪
and, based on this, the effect on temperature measurement is specified depending on the supported thermocouple type. Note that thermocouple characteristic curves are always realized as higher-order equations or by a sampling points table in the software, therefore a linear U→T transfer only makes sense in a narrow range.
Data for the sensor types in the following table
The values for the sensor types listed in the following table are shown here merely for informative purposes as an orientation aid. All data are given without guarantee and must be cross-checked against the data sheet for the respective sensor employed.
The thermocouple measurement consists of a chain of measuring and computing elements that affect the attainable measurement deviation:
The given voltage specification is decisive for the achievable temperature measuring accuracy. It is applied to the possible thermocouple types in the following.
On account of
▪
the strong non-linearity that exists with thermocouple, which suggests a meaningful use of a thermocouple in a limited temperature range (if possible)
▪
influence of the possibly used internal cold junction
▪
the possible use of an external cold junction, the specification of which is not known at this point, and
▪
the influence of the ambient temperature on the analog input device used in the voltage and cold junction measurement (leads to a change in Tmeasured due to ∆Tambient)
detailed temperature specification tables are not given below, but rather
▪
one short table per thermocouple type
–
indicating the electrical measuring range used in the voltage measurement
–
indicating the entire technically usable measuring range supported by the module. This is also the linearization range of the temperature transformation, usually the application range of the respective thermocouple specified in the standards.
Note: the electrical measuring range is designed to cover the entire linearization range. The entire temperature measuring range can therefore be used
–
with specification of the measuring range recommended by Beckhoff for this type. It is a subset of the technically usable measuring range and covers the measuring range commonly used in industry in which a relatively good measurement uncertainty is achieved.
Since thermocouples have a non-linear characteristic curve across the entire implemented linearization range as shown in the chapter on thermocouple principles, the specification of measurement uncertainty over this entire range as the so-called basic accuracy would be unrealistic and even misleading. A much better uncertainty is achieved in the temperature range commonly used in industry. Nevertheless, it is of course possible to use the module outside of the "recommended measuring range" (but within the "technically usable measuring range")
–
with the specified measurement uncertainty in the "recommended measuring range" at an ambient temperature of 23 °C and 55 °C, where the measurement uncertainty at 55 °C corresponds to the value for 23 °C ±32 °C.
Thus, the measurement uncertainty at other ambient temperatures in the recommended measuring range can be approximately interpolated or extrapolated. The values can also be taken from the specification plot.
Attention when determining the TC [K/Kamb] (temperature coefficient): the specified values do not necessarily have to be available for the same Tsens! To determine TC, read the measurement uncertainty values from the plot at Tsens and calculate TC.
▪
the "Specification Plot": a comprehensive specification statement as a graphical representation of the measurement uncertainty for Tsens at the two aforementioned ambient temperatures and additionally 39 °C in the entire technically usable measuring range. The representation of the measurement uncertainty at 39 °C ambient temperatures (mean temperature between 23 °C and 55 °C) shows the non-linear influence of the temperature on the measurement uncertainty.
If accuracy values outside of the "recommended measuring range" are required, they can thus be read graphically here.
▪
some formulas to calculate further parameters (offset/gain/non-linearity/repeatability/nois) from the specification at the desired operation point if required
Notes on the calculation of detailed specifications
If further specifications are of interest, they can or must be calculated from the values given in the voltage specification.
The sequence:
▪
General: The conversion is explained here only for one measuring point (a certain input signal); the steps simply have to be repeated in case of several measuring points (up to the entire measuring range).
▪
The determination of the entire temperature error at a measuring point results from two steps
–
Determination of the temperature error from the error of the voltage measurement
–
Determination of the error by the cold junction measurement at the temperature of the measuring point
–
Note: Due to the non-linearity of the thermocouples, it is not possible to easily add the temperature errors
▪
If the measured voltage is not known at the measured temperature measuring point, the measured value (MV) must be determined in [mV]:
MW = RMeasuring point (TMeasuring point) with the help of an U→T table
▪
The deviation is calculated at this voltage value
–
Via the total equation
–
or a single value, e.g. FSingle = 15 ppmFSV
–
the measurement uncertainty in [mV] must be calculated:
Fvoltage(Umeasuring point) =FTotal(Umeasuring point) *FSV
or: Fvoltage(Umeasuring point) =FSingle(Umeasuring point) *FSV
or (if already known) e.g.: Fvoltage(Umeasuring point) =0.003 mV
–
Also, for the calculation of the cold junction error required for further calculations, the entire error must be calculated using the above equation.
▪
The slope at the point used must then be determined:
ΔUproK(Tmeasuring point) = [U(Tmeasuring point + 1 °C) - U(Tmeasuring point )] / 1 °C
with the help of an U→T table
▪
The cold junction error is given as a temperature in °C. The temperature error must then be converted into a voltage error in [mV] via the slope at the temperature measuring point:
FCJC, U(Tmeasuring point) =FCJC, T * ΔUproK(Tmeasuring point)
▪
The combined error in [mV] must then be calculated using a square addition of the voltage error and the cold junction error:
▪
–
For calibrated thermocouples, the thermocouple error can also be included at this point in order to determine the combined error of the entire system in [mV]. For this purpose, all three error influences in [mV] (voltage, cold junction, thermocouple) must be added squarely.
▪
The temperature measurement uncertainty can be calculated via the voltage measurement uncertainty and the slope
FTemp(Umeasuring point) = (Fvoltage+CJC(Tmeasuring point)) / (ΔUproK(Tmeasuring point))
The numerical values used in the following three examples are for illustration purposes. The specification values given in the technical data remain authoritative.
Sample 1:
Basic accuracy of an ELM3704 at 35 °C ambient, measurement of 400 °C with thermocouple type K, without noise and aging influences:
Tmeasuring point = 400 °C
MW = UType K, 400°C = 16.397 mV
= 100.196 ppmFSV
FVoltage(Umeasuring point) = 100.196 ppmFSV * 80 mV = 8.016 µV
ΔUperK(Tmeasuring point) = (U(401 °C) - U(400 °C)) / (1 °C) = 42.243 µV/°C
FCJC, T = tbd.
FCJC, U(Tmeasuring point) = tbd °C * 42.243 µV/°C = tbd µV
FVoltage+CJC = tbd.
FELM3704@35°C, type K, 400°C = (Fvoltage+CJC µV)/( 42.243 µV/°C) ≈ tbd °C (means ±tbd °C)
Sample 2:
Consideration of the repeatability alone under the above conditions:
Tmeasuring point = 400 °C
MW=Umeasuring point (400 °C) = 16.397 mV
FSingle = 20 ppmFSV
FVoltage = 20 ppmFSV * 80 mV = 1.6 µV
ΔUperK(Tmeasuring point) = (U(401 °C) - U(400 °C)) / (1 °C) = 42.243 µV/°C
FCJC, single = tbd °C
FCJC, Single, U(Tmeasuring point) = tbd °C * 42.243 µV/°C = tbd µV
FVoltage+CJC = tbd.
FTemp(Umeasuring point) = (Fvoltage+CJC µV)/( 42.243 µV/°C) ≈ tbd °C (means ±tbd °C)
Sample 3:
Consideration of the RMS noise alone without filter under the above conditions:
Tmeasuring point = 400 °C
MW=Umeasuring point (400 °C) = 16.397 mV
FSingle = 37 ppmFSV
FVoltage = 37 ppmFSV * 80 mV = 2.96 µV
ΔUperK(Tmeasuring point) = (U(401 °C) - U(400 °C)) / (1 °C) = 42.243 µV/°C
FCJC, single = tbd °C
FCJC, Single, U(Tmeasuring point) = tbd °C * 42.243 µV/°C = tbd µV
FVoltage+CJC = tbd.
FTemp(Umeasuring point) = (Fvoltage+CJC µV)/( 42.243 µV/°C) ≈ tbd °C (means ±tbd °C)


Specification of the thermocouple measurement

Product overview [image] ELM370x [image] ELM370x - Technical data [image] Thermocouple measurement [image] Specification of the thermocouple measurement
Specification of the thermocouple measurement
The following tables with the TC specification apply only when using the internal cold junction. In the ELM370x, each channel has its own cold junction sensor.
The ELM370x can also be used with an external cold junction if required. The uncertainties must then be determined for the external cold junction on the application side. The temperature value of the external cold junction must then be communicated to the ELM370x via the process data for its own calculation. The effect on the TC measurement must then be calculated on the system side.
Thermal stabilization
The specification values for the measurement of the cold junction given here apply only if the following times are adhered to for thermal stabilization at constant ambient temperature
▪
after switching on: 60 min
▪
after changing wiring/connectors: 15 min
Ambient air in motion
For a constant TC measurement, thermally stable environmental conditions around the ELM module are important. Air movements around the module with a possibly varying air temperature must be avoided. If these are unavoidable, the separately available zs9100-0003 shielding hood should be used for thermal shielding. The following specification was created without a shielding hood in a quiet environment.
Shield connection for ELM series ZS9100-0003.png
Wire cross-section
Depending on the temperature gradient, the TC wire supplies heat to the ELM connector or removes heat from it. Even under thermally constant conditions, this leads to an offset deviation. If very accurate measurement is required, this can have a disruptive effect. The above values apply to a wire thickness of 0.2 mm (0.0314 mm²). For thicker wires up to 0.4 mm, up to 0.5 K measurement uncertainty can additional arise, see the following sample measurement series:
Specification of the internal cold junction measurement
Measurement mode |  | Cold junction
Basic accuracy: Measurement deviation at 23 °C, with averaging |  | < ±0.6 °C
Non-linearity over the whole measuring range | FLin | < tbd °C
Repeatability | FRep | < tbd °C
Noise (without filtering) | FNoise, PtP | < tbd °C
 | FNoise, RMS | < tbd °C
 | Max. SNR | > tbd dB
 | Noise density@1 kHz | < tbd °C/sqrt(Hz)
Noise (with 50 Hz FIR filter) | FNoise, PtP | < tbd °C
 | FNoise, RMS | < tbd °C
 | Max. SNR | > tbd dB
Temperature coefficient | Tc | < tbd K/K typ.
In the following, the achievable temperature measurement uncertainty is now specified for the individual TC types.
Note: Preliminary values printed in italics
Temperature measurement TC |  | Type B
Electrical measuring range used |  | ± 80 mV
Measuring range, technically usable |  | +200 °C ≈ 0.178 mV … +1820 °C ≈ 13.820 mV
Measuring range, end value (full scale value) |  | +1820 °C
Measuring range, recommended |  | 750 °C … +1800 °C
PDO LSB |  | 0.1/0.01/0.001 °C/digit, depending on PDO setting
Uncertainty in the recommended measuring range, with averaging | @ 23 °C ambient temperature | ± 0.98 K ≈ ± 0.05 %FSV
 | @ 55 °C ambient temperature | ± 3.7 K ≈ ± 0.2 %FSV
Temperature coefficient (Change of the measured value by changing of the terminal ambient temperature) |  | Because the value is strongly dependent by the sensor temperature as shown on the bottom given specification plot, it has to be basically derived by the specification plot. For a better approach the measurement uncertainty at Tambient=39°C as the middle between 23°C and 55°C is additionally informative represented in order to clarify the non-linear course.
Measurement uncertainty for TC type B:
ELM370x TC Element_B.png
Temperature measurement TC |  | Type C
Electrical measuring range used |  | ± 80 mV
Measuring range, technically usable |  | 0 °C ≈ 0 mV … +2320 °C ≈ 37.107 mV
Measuring range, end value (full scale value) |  | +2320 °C
Measuring range, recommended |  | 0 °C … +2000 °C
PDO LSB |  | 0.1/0.01/0.001 °C/digit, depending on PDO setting
Uncertainty in the recommended measuring range, with averaging | @ 23 °C ambient temperature | ± 0.78 K ≈ ± 0.03 %FSV
 | @ 55 °C ambient temperature | ± 2.4 K ≈ ± 0.10 %FSV
Temperature coefficient (Change of the measured value by changing of the terminal ambient temperature) |  | Because the value is strongly dependent by the sensor temperature as shown on the bottom given specification plot, it has to be basically derived by the specification plot. For a better approach the measurement uncertainty at Tambient=39°C as the middle between 23°C and 55°C is additionally informative represented in order to clarify the non-linear course.
Measurement uncertainty for TC type C:
ELM370x TC Element_C.png
Temperature measurement TC |  | Type E
Electrical measuring range used |  | ± 80 mV
Measuring range, technically usable |  | -270 °C ≈ -9.835 mV … +1000 °C ≈ 76.373 mV
Measuring range, end value (full scale value) |  | +1000 °C
Measuring range, recommended |  | -100 °C … +1000 °C
PDO LSB |  | 0.1/0.01/0.001 °C/digit, depending on PDO setting
Uncertainty in the recommended measuring range, with averaging | @ 23 °C ambient temperature | ± 0.61 K ≈ ± 0.06 %FSV
 | @ 55 °C ambient temperature | ± 0.96 K ≈ ± 0.09 %FSV
Temperature coefficient (Change of the measured value by changing of the terminal ambient temperature) |  | Because the value is strongly dependent by the sensor temperature as shown on the bottom given specification plot, it has to be basically derived by the specification plot. For a better approach the measurement uncertainty at Tambient=39°C as the middle between 23°C and 55°C is additionally informative represented in order to clarify the non-linear course.
Measurement uncertainty for TC type E:
ELM370x TC Element_E.png
Temperature measurement TC |  | Type J
Electrical measuring range used |  | ± 80 mV
Measuring range, technically usable |  | -210 °C ≈ -8.095 mV … +1200 °C ≈ +69.553 mV
Measuring range, end value (full scale value) |  | +1200 °C
Measuring range, recommended |  | -100 °C … +1200 °C
PDO LSB |  | 0.1/0.01/0.001 °C/digit, depending on PDO setting
Uncertainty in the recommended measuring range, with averaging | @ 23 °C ambient temperature | ± 0.62 K ≈ ± 0.05 %FSV
 | @ 55 °C ambient temperature | ± 1.0 K ≈ ± 0.08 %FSV
Temperature coefficient (Change of the measured value by changing of the terminal ambient temperature) |  | Because the value is strongly dependent by the sensor temperature as shown on the bottom given specification plot, it has to be basically derived by the specification plot. For a better approach the measurement uncertainty at Tambient=39°C as the middle between 23°C and 55°C is additionally informative represented in order to clarify the non-linear course.
Measurement uncertainty for TC type J:
ELM370x TC Element_J.png
Temperature measurement TC |  | Type K
Electrical measuring range used |  | ± 80 mV
Measuring range, technically usable |  | -270 °C ≈ -6.458 mV … 1372 °C ≈ 54.886 mV
Measuring range, end value (full scale value) |  | +1372 °C
Measuring range, recommended |  | -100 °C … +1000 °C
PDO LSB |  | 0.1/0.01/0.001 °C/digit, depending on PDO setting
Uncertainty in the recommended measuring range, with averaging | @ 23 °C ambient temperature | ± 0.63 K ≈ ± 0.04 %FSV
 | @ 55 °C ambient temperature | ± 1.1 K ≈ ± 0.08 %FSV
Temperature coefficient (Change of the measured value by changing of the terminal ambient temperature) |  | Because the value is strongly dependent by the sensor temperature as shown on the bottom given specification plot, it has to be basically derived by the specification plot. For a better approach the measurement uncertainty at Tambient=39°C as the middle between 23°C and 55°C is additionally informative represented in order to clarify the non-linear course.
Measurement uncertainty for TC type K:
ELM370x TC Element_K.png
Temperature measurement TC |  | Type L
Electrical measuring range used |  | ± 80 mV
Measuring range, technically usable |  | -50 °C ≈ -2.510 mV … +900 °C ≈ 52.430 mV
Measuring range, end value (full scale value) |  | +900 °C
Measuring range, recommended |  | 0 °C … +900 °C
PDO LSB |  | 0.1/0.01/0.001 °C/digit, depending on PDO setting
Uncertainty in the recommended measuring range, with averaging | @ 23 °C ambient temperature | ± 0.61 K ≈ ± 0.07 %FSV
 | @ 55 °C ambient temperature | ± 0.92 K ≈ ± 0.1 %FSV
Temperature coefficient (Change of the measured value by changing of the terminal ambient temperature) |  | Because the value is strongly dependent by the sensor temperature as shown on the bottom given specification plot, it has to be basically derived by the specification plot. For a better approach the measurement uncertainty at Tambient=39°C as the middle between 23°C and 55°C is additionally informative represented in order to clarify the non-linear course.
Measurement uncertainty for TC type L:
ELM370x TC Element_L.png
Temperature measurement TC |  | Type N
Electrical measuring range used |  | ± 80 mV
Measuring range, technically usable |  | -270 °C ≈ -4.346 mV … +1300 °C ≈ 47.513 mV
Measuring range, end value (full scale value) |  | +1300 °C
Measuring range, recommended |  | 0 °C … +1200 °C
PDO LSB |  | 0.1/0.01/0.001 °C/digit, depending on PDO setting
Uncertainty in the recommended measuring range, with averaging | @ 23 °C ambient temperature | ± 0.64 K ≈ ± 0.05 %FSV
 | @ 55 °C ambient temperature | ± 1.3 K ≈ ± 0.1 %FSV
Temperature coefficient (Change of the measured value by changing of the terminal ambient temperature) |  | Because the value is strongly dependent by the sensor temperature as shown on the bottom given specification plot, it has to be basically derived by the specification plot. For a better approach the measurement uncertainty at Tambient=39°C as the middle between 23°C and 55°C is additionally informative represented in order to clarify the non-linear course.
Measurement uncertainty for TC type N:
ELM370x TC Element_N.png
Temperature measurement TC |  | Type R
Electrical measuring range used |  | ± 80 mV
Measuring range, technically usable |  | -50 °C ≈ -0.226 mV … +1768 °C ≈ 21.101 mV
Measuring range, end value (full scale value) |  | +1768 °C
Measuring range, recommended |  | 250 °C … +1700 °C
PDO LSB |  | 0.1/0.01/0.001 °C/digit, depending on PDO setting
Uncertainty in the recommended measuring range, with averaging | @ 23 °C ambient temperature | ± 0.85 K ≈ ± 0.05 %FSV
 | @ 55 °C ambient temperature | ± 2.9 K ≈ ± 0.16 %FSV
Temperature coefficient (Change of the measured value by changing of the terminal ambient temperature) |  | Because the value is strongly dependent by the sensor temperature as shown on the bottom given specification plot, it has to be basically derived by the specification plot. For a better approach the measurement uncertainty at Tambient=39°C as the middle between 23°C and 55°C is additionally informative represented in order to clarify the non-linear course.
Measurement uncertainty for TC type R:
ELM370x TC Element_R.png
Temperature measurement TC |  | Type S
Electrical measuring range used |  | ± 80 mV
Measuring range, technically usable |  | -50 °C ≈ -0.236 mV … +1768 °C ≈ 18.693 mV
Measuring range, end value (full scale value) |  | +1768 °C
Measuring range, recommended |  | 250 °C … +1700 °C
PDO LSB |  | 0.1/0.01/0.001 °C/digit, depending on PDO setting
Uncertainty in the recommended measuring range, with averaging | @ 23 °C ambient temperature | ± 0.87 K ≈ ± 0.05 %FSV
 | @ 55 °C ambient temperature | ± 3.1 K ≈ ± 0.17 %FSV
Temperature coefficient (Change of the measured value by changing of the terminal ambient temperature) |  | Because the value is strongly dependent by the sensor temperature as shown on the bottom given specification plot, it has to be basically derived by the specification plot. For a better approach the measurement uncertainty at Tambient=39°C as the middle between 23°C and 55°C is additionally informative represented in order to clarify the non-linear course.
Measurement uncertainty for TC type S:
ELM370x TC Element_S.png
Temperature measurement TC |  | Type T
Electrical measuring range used |  | ± 80 mV
Measuring range, technically usable |  | -270 °C ≈ -6.258 mV …. +400 °C ≈ 20.872 mV
Measuring range, end value (full scale value) |  | +400 °C
Measuring range, recommended |  | -100 °C … +400 °C
PDO LSB |  | 0.1/0.01/0.001 °C/digit, depending on PDO setting
Uncertainty in the recommended measuring range, with averaging | @ 23 °C ambient temperature | ± 0.63 K ≈ ± 0.16 %FSV
 | @ 55 °C ambient temperature | ± 1.2 K ≈ ± 0.3 %FSV
Temperature coefficient (Change of the measured value by changing of the terminal ambient temperature) |  | Because the value is strongly dependent by the sensor temperature as shown on the bottom given specification plot, it has to be basically derived by the specification plot. For a better approach the measurement uncertainty at Tambient=39°C as the middle between 23°C and 55°C is additionally informative represented in order to clarify the non-linear course.
Measurement uncertainty for TC type T:
ELM370x TC Element_T.png
Temperature measurement TC |  | Type U
Electrical measuring range used |  | ± 80 mV
Measuring range, technically usable |  | -50 °C ≈ -1.850 mV … +600 °C ≈ 33.600 mV
Measuring range, end value (full scale value) |  | +600 °C
Measuring range, recommended |  | 0 °C … +600 °C
PDO LSB |  | 0.1/0.01/0.001 °C/digit, depending on PDO setting
Uncertainty in the recommended measuring range, with averaging | @ 23 °C ambient temperature | ± 0.62 K ≈ ± 0.10 %FSV
 | @ 55 °C ambient temperature | ± 1.0 K ≈ ± 0.16 %FSV
Temperature coefficient (Change of the measured value by changing of the terminal ambient temperature) |  | Because the value is strongly dependent by the sensor temperature as shown on the bottom given specification plot, it has to be basically derived by the specification plot. For a better approach the measurement uncertainty at Tambient=39°C as the middle between 23°C and 55°C is additionally informative represented in order to clarify the non-linear course.
Measurement uncertainty for TC type U:
ELM370x TC Element_U.png


Start

Product overview [image] Start
Start
For commissioning:
▪
mount the terminal as described in the chapter Mounting and wiring.
▪
configure the terminal in TwinCAT as described in the chapter Commissioning.


Commissioning

Commissioning
Commissioning
Additional information
•
CoE overview
•
Sample programs
•
Notes to short documentation


CoE overview

Commissioning [image] CoE overview
CoE overview
Additional information
•
ELM30xx
•
ELM31xx
•
ELM35xx
•
ELM36xx
•
ELM37xx


ELM30xx

Commissioning [image] CoE overview [image] ELM30xx
ELM30xx
Additional information
•
0x10F3 Diagnosis History
•
0x60n0 PAI Status Ch.[n+1]
•
0x60n1 PAI Samples Ch.[n+1] (24 Bit)
•
0x60n2 PAI Samples Ch.[n+1] (16 Bit)
•
0x60n5 PAI Timestamp Ch.[n+1]
•
0x60n6 PAI Synchronous Oversampling Ch.[n+1]
•
0x70n0 PAI Control Ch.[n+1]
•
0x80n0 PAI Settings Ch.[n+1]
•
0x80n1 PAI Filter 1 Settings Ch.[n+1]
•
0x80n3 PAI Filter 2 Settings Ch.[n+1]
•
0x80n5 PAI Scaler Settings Ch.[n+1] – not ELM35xx
•
0x80nE PAI User Calibration Ch.[n+1]
•
0x80nF PAI Vendor Calibration Data Ch.[n+1]
•
0x90n0 PAI Internal Data Ch.[n+1]
•
0x90n2 PAI Info Data Ch.[n+1]
•
0x90nF PAI Calibration Dates Ch.[n+1]
•
0xF000 Modular device profile
•
0xF008 Code word
•
0xF009 Password Protection
•
0xF010 Module list
•
0xF083 BTN
•
0xF900 PAI Info Data
•
0xF912 Filter info
•
0xFB00 PAI Command


0x10F3 Diagnosis History

Commissioning [image] CoE overview [image] ELM30xx [image] 0x10F3 Diagnosis History
0x10F3 Diagnosis History
Index (hex) | Name | Meaning | Data type | Flags | Default
10F3:0 | Diagnosis History | Max. Subindex | UINT8 | RO | 0x15 (21dec)
10F3:01 | Maximum Messages | Maximum Messages | UINT8 | RO | 0x00 (0dec)
10F3:02 | Newest Message | Newest Message | UINT8 | RO | 0x00 (0dec)
10F3:03 | Newest Acknowledged Message | Subindex of last Acknowledged Message | UINT8 | RW | 0x00 (0dec)
10F3:04 | New Messages Available | True: New Messages Available | BOOLEAN | RO | 0x00 (0dec)
10F3:05 | Flags | Diagnosis message options (see ETG specification) | UINT16 | RW | 0x0000 (0dec)
10F3:06 .10F3:15 | Diagnosis Message 001... Diagnosis Message 016 | Diagnosis Message No. 01...16 | OCTET-STRING[22] | RO | {0}


0x60n0 PAI Status Ch.[n+1]

Commissioning [image] CoE overview [image] ELM30xx [image] 0x60n0 PAI Status Ch.[n+1]
0x60n0 PAI Status Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
60n0:0 | PAI Status Ch.[n+1] |  | UINT8 | RO | 0x0F (15dec)
60n0:01 | No of Samples | Number of valid samples within the PDO samples | UINT8 | RO | 0x00 (0dec)
60n0:09 | Error | TRUE: General error | BOOLEAN | RO | 0x00 (0dec)
60n0:0A | Underrange | TRUE: Measurement event underflow | BOOLEAN | RO | 0x00 (0dec)
60n0:0B | Overrange | TRUE: Measurement event overflow | BOOLEAN | RO | 0x00 (0dec)
60n0:0D | Diag | TRUE: New diagnostic message available | BOOLEAN | RO | 0x00 (0dec)
60n0:0E | TxPDO State | TRUE: data invalid | BOOLEAN | RO | 0x00 (0dec)
60n0:0F | Input cycle counter | Incremented by one when values have changed | BIT2 | RO | 0x00 (0dec)


0x60n1 PAI Samples Ch.[n+1] (24 Bit)

Commissioning [image] CoE overview [image] ELM30xx [image] 0x60n1 PAI Samples Ch.[n+1] (24 Bit)
0x60n1 PAI Samples Ch.[n+1] (24 Bit)
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
ELM3x0x:
Index (hex) | Name | Meaning | Data type | Flags | Default
60n1:0 | PAI Samples Ch.[n+1] |  | UINT8 | RO | 0x64 (100dec)
60n1:01 | Sample | Samples | INT32 | RO | 0x00000000 (0dec)
… | … | … | … | … | …
60n1:64 | Sample | Samples | INT32 | RO | 0x00000000 (0dec)
ELM3x4x:
Index (hex) | Name | Meaning | Data type | Flags | Default
60n1:0 | PAI Samples Ch.[n+1] |  | UINT8 | RO | 0x20 (32dec)
60n1:01 | Sample | Samples | INT32 | RO | 0x00000000 (0dec)
… | … | … | … | … | …
60n1:20 | Sample | Samples | INT32 | RO | 0x00000000 (0dec)


0x60n2 PAI Samples Ch.[n+1] (16 Bit)

Commissioning [image] CoE overview [image] ELM30xx [image] 0x60n2 PAI Samples Ch.[n+1] (16 Bit)
0x60n2 PAI Samples Ch.[n+1] (16 Bit)
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels (not ELM3x4x):
Index (hex) | Name | Meaning | Data type | Flags | Default
60n2:0 | PAI Samples Ch.[n+1] |  | UINT8 | RO | 0x64 (100dec)
60n2:01 | Sample | Samples | INT16 | RO | 0x0000 (0dec)
… | … | … | … | … | …
60n2:64 | Sample | Samples | INT16 | RO | 0x0000 (0dec)


0x60n5 PAI Timestamp Ch.[n+1]

Commissioning [image] CoE overview [image] ELM30xx [image] 0x60n5 PAI Timestamp Ch.[n+1]
0x60n5 PAI Timestamp Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
60n5:0 | PAI Timestamp Ch.[n+1] |  | UINT8 | RO | 0x02 (2dec)
60n5:01 | Low | Timestamp (low) | UINT32 | RO | 0x00000000 (0dec)
60n5:02 | Hi | Timestamp (hi) | UINT32 | RO | 0x00000000 (0dec)


0x60n6 PAI Synchronous Oversampling Ch.[n+1]

Commissioning [image] CoE overview [image] ELM30xx [image] 0x60n6 PAI Synchronous Oversampling Ch.[n+1]
0x60n6 PAI Synchronous Oversampling Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
60n6:0 | PAI Synchronous Oversampling Ch.[n+1] |  | RO | UINT8 | 0x01 (1dec)
60n6:01 | Internal Buffer |  | RO | UINT16 | 0x0000 (0dec)


0x70n0 PAI Control Ch.[n+1]

Commissioning [image] CoE overview [image] ELM30xx [image] 0x70n0 PAI Control Ch.[n+1]
0x70n0 PAI Control Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
70n0:0 | PAI Control Ch.[n+1] |  | UINT8 | RO | 0x02 (2dec)
70n0:01 | Integrator Reset | Restart of the integration with each edge | BOOLEAN | RO | 0x00 (0dec)
70n0:02 | Peak Hold Reset | Start new peak value detection with each edge | BOOLEAN | RO | 0x00 (0dec)


0x80n0 PAI Settings Ch.[n+1]

Commissioning [image] CoE overview [image] ELM30xx [image] 0x80n0 PAI Settings Ch.[n+1]
0x80n0 PAI Settings Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
80n0:0 | PAI Settings Ch.[n+1] |  | UINT8 | RO | 0x41 (65dec)
80n0:01 | Interface | Selection of the measurement configuration: 0 – None 1 - U ±30 V 2 - U ±10 V 3 - U ±5 V 4 - U ±2.5 V 5 - U ±1.25 V 6 - U ±640 mV 7 - U ±320 mV 8 - U ±160 mV 9 - U ±80 mV 10 - U ±40 mV 11 - U ±20 mV 14 - U 0...10 V 15 - U 0...5 V | UINT16 | RW | 0x0000 (0dec)
80n0:04 | Start Connection Test | Start connection test with rising edge (see section “Broken wire detection/ optional connection diagnosis”) | BOOLEAN | RW | 0x00 (FALSE)
80n0:06 | Enable Autorange | Autorange (Enable/ Disable) | BOOLEAN | RW | 0x00 (FALSE)
80n0:16 | Filter 1 | Options for filter 1: 0 – None 1 - FIR Notch 50 Hz 2 - FIR Notch 60 Hz 3 - FIR LP 100 Hz 4 - FIR LP 1000 Hz 5 - FIR HP 150 Hz 16 - IIR Notch 50 Hz 17 - IIR Notch 60 Hz 18 - IIR Butterw. LP 5th Ord. 1 Hz 19 - IIR Butterw. LP 5th Ord. 25 Hz 20 - IIR Butterw. LP 5th Ord. 100 Hz 21 - IIR Butterw. LP 5th Ord. 250 Hz 22 - IIR Butterw. LP 5th Ord. 1000 Hz 32 - User defined FIR Filter 33 - User defined IIR Filter 34 - User defined Average Filter | UINT16 | RW | 0x0000 (0dec)
80n0:17 | Average Filter 1 No of Samples | Number of samples for user-defined Average Filter 1 | UINT16 | RW | 0x00C8 (200dec)
80n0:18 | Decimation Factor | Factor of the individual sampling rate (min. 1) | UINT16 | RW | 0x0001 (1dec)
80n0:19 | Filter 2 | Options for filter 2: 0 – None 1 - IIR 1 2 - IIR 2 3 - IIR 3 4 - IIR 4 5 - IIR 5 6 - IIR 6 7 - IIR 7 8 - IIR 8 16 - User defined FIR Filter 17 - User defined IIR Filter 18 - User defined Average Filter | UINT16 | RW | 0x0000 (0dec)
80n0:1A | Average Filter 2 No of Samples | Number of samples for user-defined Average Filter 2 | UINT16 | RW | 0x00C8 (200dec)
80n0:1B | True RMS No. of Samples | Number of samples for "True RMS" calculation (min. 1, max. 1000); also see chapter TrueRMS (extended maximum values for ELM36xx) | UINT16 | RW | 0x00C8 (200dec)
80n0:1C | Enable True RMS | Activation of "True RMS" calculation | BOOLEAN | RW | 0x00 (FALSE)
80n0:1D | Enable Frequency Counter | Enable Frequency Counter | BOOLEAN | RW | 0x00 (FALSE)
80n0:2B | Extended Functions | Options for future functions/settings 0 – Disabled ELM35xx: 1 – Load Cell Analysis | UINT16 | RW | 0x0000 (0dec)
80n0:2C | Integrator/Differentiator | Options: 0 – Off 1 – Integrator 1x 2 – Integrator 2x (* 3 – Differentiator 1x 4 – Differentiator 2x (* | UINT16 | RW | 0x0000 (0dec)
80n0:2D | Differentiator Samples Delta | Distance of samples for the differentiation; max. value = 1000; except ELM36xx with max value = 5000 | UINT16 | RW | 0x0001 (1dec)
80n0:2E | Scaler | Scaling (enum): 0 – Extended Range 1 – Linear 2 – Lookup Table 3 – Legacy Range 4 – Lookup Table (additive) Optional: 5 – Extended Functions | UINT16 | RW | 0x0000 (0dec)
80n0:2F | Lookup Table Length | Anzahl Stützstellen der LookUp‑Tabelle | UINT16 | RW | 0x0064 (100dec)
80n0:30 | Low Limiter | Smallest PDO output value | INT32 | RW | 0x80000000 (‑2147483648dec)
80n0:31 | High Limiter | Largest PDO output value | INT32 | RW | 0x7FFFFFFF (2147483647dec)
80n0:32 | Low Range Error | Lowest limit at which the error bit and the error LED are set | INT32 | RW | 0xFF800000 (‑8388608dec)
80n0:33 | High Range Error | Highest limit at which the error bit and the error LED are set | INT32 | RW | 0x007FFFFF (8388607dec)
80n0:34 | Timestamp Correction | Value for correcting StartNextLatchTime (timestamp of the first sample) | INT32 | RW | 0xFFFB6C20 (‑300000dec)
80n0:40 | Filter 1 Type Info | Filter 1 type information | STRING | RW | N/A
80n0:41 | Filter 2 Type Info | Filter 2 type information | STRING | RW | N/A
(* Functionality is only available from FW03


0x80n1 PAI Filter 1 Settings Ch.[n+1]

Commissioning [image] CoE overview [image] ELM30xx [image] 0x80n1 PAI Filter 1 Settings Ch.[n+1]
0x80n1 PAI Filter 1 Settings Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
80n1:0 | PAI Filter 1 Settings Ch.[n+1] |  | UINT8 | RO | 0x28 (40dec)
80n1:01 | Filter Coefficient 1 | Coefficients for filter 1 | INT32 | RO | 0x00000000 (0dec)
… | … | … | … | … | …
80n1:28 | Filter Coefficient 40 | Coefficients for filter 1 | INT32 | RO | 0x00000000 (0dec)


0x80n3 PAI Filter 2 Settings Ch.[n+1]

Commissioning [image] CoE overview [image] ELM30xx [image] 0x80n3 PAI Filter 2 Settings Ch.[n+1]
0x80n3 PAI Filter 2 Settings Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
80n3:0 | PAI Filter 2 Settings Ch.[n+1] |  | UINT8 | RO | 0x28 (40dec)
80n3:01 | Filter Coefficient 1 | Coefficients for filter 2 | INT32 | RO | 0x00000000 (0dec)
… | … | … | … | … | …
80n3:28 | Filter Coefficient 40 | Coefficients for filter 2 | INT32 | RO | 0x00000000 (0dec)


0x80n5 PAI Scaler Settings Ch.[n+1] – not ELM35xx

Commissioning [image] CoE overview [image] ELM30xx [image] 0x80n5 PAI Scaler Settings Ch.[n+1] – not ELM35xx
0x80n5 PAI Scaler Settings Ch.[n+1] – not ELM35xx
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
80n5:0 | PAI Scaler Settings Ch.[n+1] | Scaling values offset/gain or LookUp table with 50 x/y value pairs | UINT8 | RO | 0x64 (100dec)
80n5:01 | Scaler Offset/ Scaler Value 1 | Scaling offset oder LookUp x value 1 | INT32 | RW | 0x00000000 (0dec)
80n5:02 | Scaler-Gain/ Scaler Value 2 | Scaling gain oder LookUp y value 1 | INT32 | RW | 0x00000000 (0dec)
80n5:03 | Scaler Value 3 | LookUp x value 2 | INT32 | RW | 0x00000000 (0dec)
80n5:04 | Scaler Value 4 | LookUp y value 2 | INT32 | RW | 0x00000000 (0dec)
.. | .. | .. | .. | .. | ..
80n5:63 | Scaler Value 99 | LookUp x value 50 | INT32 | RW | 0x00000000 (0dec)
80n5:64 | Scaler Value 100 | LookUp y value 50 | INT32 | RW | 0x00000000 (0dec)


0x80nE PAI User Calibration Ch.[n+1]

Commissioning [image] CoE overview [image] ELM30xx [image] 0x80nE PAI User Calibration Ch.[n+1]
0x80nE PAI User Calibration Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
80nE:0 | PAI User Calibration Data Ch.1 |  | UINT8 | RO | 0x0C (12dec)
80nE:01 | Calibration Date | Date of calibration | OCTET-STRING[4] | RW | -
80nE:02 | Signature | Signature of the calibration values | OCTET-STRING[256] | RW | -
80nE:03 | S0 | Offset | REAL32 | RW | 0x00000000 (0dec)
80nE:04 | S1 | Coefficient for first-order samples (S1 * sample) | REAL32 | RW | 0x3F800000 (1.0dec)
80nE:05 | S2 | Coefficient for second-order samples (S2 * sample²) | REAL32 | RW | 0x00000000 (0.0dec)
80nE:06 | S3 | Coefficient for third-order samples (S3 * sample³) | REAL32 | RW | 0x00000000 (0.0dec)
80nE:07 | T1 | Temperature coefficient for first-order temperature value (T1 * temp) | REAL32 | RW | 0x00000000 (0.0dec)
80nE:08 | T1S1 | Combined coefficient for first-order gain and temperature values (T1S1 * temp * sample) | REAL32 | RW | 0x00000000 (0.0dec)
80nE:09 | T2 | Temperature coefficient for second-order temperature value (T2 * temp²) | REAL32 | RW | 0x00000000 (0.0dec)
80nE:0A | T2S1 | Combined coefficient for second-order gain and temperature values (T2S1 * temp² * sample) | REAL32 | RW | 0x00000000 (0.0dec)
80nE:0B | T3 | Temperature coefficient for third-order temperature value (T3 * temp³) | REAL32 | RW | 0x00000000 (0.0dec)
80nE:0C | T3S1 | Combined coefficient for third-order gain and temperature values (T3S1 * temp³ * sample) | REAL32 | RW | 0x00000000 (0.0dec)


0x80nF PAI Vendor Calibration Data Ch.[n+1]

Commissioning [image] CoE overview [image] ELM30xx [image] 0x80nF PAI Vendor Calibration Data Ch.[n+1]
0x80nF PAI Vendor Calibration Data Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
80nF:0 | PAI Vendor Calibration Data Ch.1 |  | UINT8 | RO | 0x0C (12dec)
80nF:01 | Calibration Date | Date of calibration | OCTET-STRING[4] | RW | -
80nF:02 | Signature | Signature of the calibration values | OCTET-STRING[256] | RW | -
80nF:03 | S0 | Offset | REAL32 | RW | 0x00000000 (0dec)
80nF:04 | S1 | Coefficient for first-order samples (S1 * sample) | REAL32 | RW | 0x3F800000 (1.0dec)
80nF:05 | S2 | Coefficient for second-order samples (S2 * sample²) | REAL32 | RW | 0x00000000 (0.0dec)
80nF:06 | S3 | Coefficient for third-order samples (S3 * sample³) | REAL32 | RW | 0x00000000 (0.0dec)
80nF:07 | T1 | Temperature coefficient for first-order temperature value (T1 * temp) | REAL32 | RW | 0x00000000 (0.0dec)
80nF:08 | T1S1 | Combined coefficient for first-order gain and temperature values (T1S1 * temp * sample) | REAL32 | RW | 0x00000000 (0.0dec)
80nF:09 | T2 | Temperature coefficient for second-order temperature value (T2 * temp²) | REAL32 | RW | 0x00000000 (0.0dec)
80nF:0A | T2S1 | Combined coefficient for second-order gain and temperature values (T2S1 * temp² * sample) | REAL32 | RW | 0x00000000 (0.0dec)
80nF:0B | T3 | Temperature coefficient for third-order temperature value (T3 * temp³) | REAL32 | RW | 0x00000000 (0.0dec)
80nF:0C | T3S1 | Combined coefficient for third-order gain and temperature values (T3S1 * temp³ * sample) | REAL32 | RW | 0x00000000 (0.0dec)


0x90n0 PAI Internal Data Ch.[n+1]

Commissioning [image] CoE overview [image] ELM30xx [image] 0x90n0 PAI Internal Data Ch.[n+1]
0x90n0 PAI Internal Data Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
90n0:0 | PAI Internal Data Ch.[n+1] |  | UINT8 | RO | 0x22 (34dec)
90n0:02 | ADC Raw Value | ADC Raw Value | INT32 | RO | 0x00000000 (0dec)
90n0:03 | Calibration Value | Value after calibration | INT32 | RO | 0x00000000 (0dec)
90n0:04 | Zero Offset Value | Zero offset value | INT32 | RO | 0x00000000 (0dec)
90n0:07 | Actual Negative Peak Hold | Current absolute minimum value | INT32 | RO | 0x00000000 (0dec)
90n0:08 | Actual Positive Peak Hold | Current absolute maximum value | INT32 | RO | 0x00000000 (0dec)
90n0:09 | Previous Negative Peak Hold | Absolute minimum value up to last rising edge of "Peak Hold Reset" | INT32 | RO | 0x00000000 (0dec)
90n0:0A | Previous Positive Peak Hold | Absolute maximum value up to last rising edge of "Peak Hold Reset" | INT32 | RO | 0x00000000 (0dec)
90n0:0B | Filter 1 Value | Value after filter 1 | INT32 | RO | 0x00000000 (0dec)
90n0:0C | Filter 2 Value | Value after filter 2 | INT32 | RO | 0x00000000 (0dec)
90n0:0D | True RMS Value | Value after "True RMS" calculation | INT32 | RO | 0x00000000 (0dec)
90n0:0E | Extended Functions Value | Value after advanced (optional) function | INT32 | RO | 0x00000000 (0dec)
90n0:0F | Integrator/Differentiator Value | Value after integration or differentiation | INT32 | RO | 0x00000000 (0dec)
90n0:10 | Scaler Value | Value after scaling | INT32 | RO | 0x00000000 (0dec)
90n0:11 | Limiter Value | Value after limitation | INT32 | RO | 0x00000000 (0dec)
90n0:21 | Signal Frequency | Frequency of the input signal | UINT32 | RO | 0x00000000 (0dec)
90n0:22 | Signal Duty Cycle | Duty Cycle of the input signal | UINT8 | RO | 0x00 (0dec)
Note:
For ELM3004-0000-0016 the subindices 03 and 04 are arranged as follows:
Index (hex) | Name | Meaning | Data type | Flags | Default
90n0:03 | Zero Offset Value | Zero offset value | INT32 | RO | 0x00000000 (0dec)
90n0:04 | Calibration Value | Value after calibration | INT32 | RO | 0x00000000 (0dec)


0x90n2 PAI Info Data Ch.[n+1]

Commissioning [image] CoE overview [image] ELM30xx [image] 0x90n2 PAI Info Data Ch.[n+1]
0x90n2 PAI Info Data Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
90n2:0 | PAI Info Data Ch.[n+1] |  | UINT8 | RO | 0x12 (18dec)
90n2:01 | Effective Sample Rate | Effective Sample Rate | UINT32 | RO | 0x00000000 (0dec)
90n2:02 | Channel Temperature | Temperature of the channel | REAL32 | RO | 0x00000000 (0dec)
90n2:03 | Min. Channel Temperature | Minimal temperature of the channel | REAL32 | RO | 0x00000000 (0dec)
90n2:04 | Max. Channel Temperature | Maximal temperature of the channel | REAL32 | RO | 0x00000000 (0dec)
90n2:05 | Overload Time | Absolute time during overload "Overload" means that the channel is electrically overloaded. This is a non-recommendable condition that may eventually lead to atypical aging or even damage. This condition should be avoided. Its accumulated duration is displayed here informatively. | UINT32 | RO | 0x00000000 (0dec)
90n2:06 | Saturation Time | Absolute time during saturation "Saturation" means that the measuring range of the ADC of the channel is fully utilized, the ADC thus outputs its maximum value and the measured value can no longer be used. "Saturation" is therefore a pre-deregistration, with further signal increase it comes to "overload". The saturation state is not fundamentally harmful, but it indicates an insufficient dimensioning of the measurement channel. Its accumulated response time is displayed here informatively. | UINT32 | RO | 0x00000000 (0dec)
90n2:07 | Overtemperature Time (Channel) | Time of exceeded temperature of the channel | UINT32 | RO | 0x00000000 (0dec)
90n2:11 | Vendor Calibration Counter | Counter of the vendor calibration (related to the selected interface) The counter counts +1 when data has changed and the memory code word is written. Depending on the adjustment method, the counter may therefore count several times. | UINT16 | RO | 0x0000 (0dec)
90n2:12 | User Calibration Counter | Counter of the user calibration (related to the selected interface) The counter counts +1 when data has changed and the memory code word is written. Depending on the adjustment method, the counter may therefore count several times. | UINT16 | RO | 0x0000 (0dec)


0x90nF PAI Calibration Dates Ch.[n+1]

Commissioning [image] CoE overview [image] ELM30xx [image] 0x90nF PAI Calibration Dates Ch.[n+1]
0x90nF PAI Calibration Dates Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels:
Index (hex) | Name | Meaning | Data type | Flags | Default
90nF:0 | PAI Calibration Dates |  | UINT8 | RO | 0x8F (143dec)
90nF:01 | Vendor U ±30V |  | OCTET-STRING[4] | RO | {0}
90nF:02 | Vendor U ±10V |  | OCTET-STRING[4] | RO | {0}
90nF:03 | Vendor U ±5V |  | OCTET-STRING[4] | RO | {0}
90nF:04 | Vendor U ±2.5V |  | OCTET-STRING[4] | RO | {0}
90nF:05 | Vendor U ±1.25V |  | OCTET-STRING[4] | RO | {0}
90nF:06 | Vendor U ±640mV |  | OCTET-STRING[4] | RO | {0}
90nF:07 | Vendor U ±320mV |  | OCTET-STRING[4] | RO | {0}
90nF:08 | Vendor U ±160mV |  | OCTET-STRING[4] | RO | {0}
90nF:09 | Vendor U ±80mV |  | OCTET-STRING[4] | RO | {0}
90nF:0A | Vendor U ±40mV |  | OCTET-STRING[4] | RO | {0}
90nF:0B | Vendor U ±20mV |  | OCTET-STRING[4] | RO | {0}
90nF:0E | Vendor U 0...10 V |  | OCTET-STRING[4] | RO | {0}
90nF:0F | Vendor U 0...5 V |  | OCTET-STRING[4] | RO | {0}
90nF:81 | User ±30V |  | OCTET-STRING[4] | RO | {0}
90nF:82 | User ±10V |  | OCTET-STRING[4] | RO | {0}
90nF:83 | User ±5V |  | OCTET-STRING[4] | RO | {0}
90nF:84 | User ±2.5V |  | OCTET-STRING[4] | RO | {0}
90nF:85 | User ±1.25V |  | OCTET-STRING[4] | RO | {0}
90nF:86 | User ±640mV |  | OCTET-STRING[4] | RO | {0}
90nF:87 | User ±320mV |  | OCTET-STRING[4] | RO | {0}
90nF:88 | User ±160mV |  | OCTET-STRING[4] | RO | {0}
90nF:89 | User ±80mV |  | OCTET-STRING[4] | RO | {0}
90nF:8A | User ±40mV |  | OCTET-STRING[4] | RO | {0}
90nF:8B | User ±20mV |  | OCTET-STRING[4] | RO | {0}
90nF:8E | User 0...10V |  | OCTET-STRING[4] | RO | {0}
90nF:8F | User 0...5V |  | OCTET-STRING[4] | RO | {0}


0xF000 Modular device profile

Commissioning [image] CoE overview [image] ELM30xx [image] 0xF000 Modular device profile
0xF000 Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0004 (4dec)


0xF008 Code word

Commissioning [image] CoE overview [image] ELM30xx [image] 0xF008 Code word
0xF008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word |  | UINT32 | RW | 0x00000000 (0dec)


0xF009 Password Protection

Commissioning [image] CoE overview [image] ELM30xx [image] 0xF009 Password Protection
0xF009 Password Protection
Index (hex) | Name | Meaning | Data type | Flags | Default
F009:0 | Password protection |  | UINT32 | RW | 0x00000000 (0dec)


0xF010 Module list

Commissioning [image] CoE overview [image] ELM30xx [image] 0xF010 Module list
0xF010 Module list
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list |  | UINT8 | RW | n
F010:01 | Subindex 001 |  | UINT32 | RW | 0x0000015E (350dec)
... | ... | ... | ... | ... | ...
F010:n | Subindex n |  | UINT32 | RW | 0x0000015E (350dec)
n = number of existing channels by the terminal


0xF083 BTN

Commissioning [image] CoE overview [image] ELM30xx [image] 0xF083 BTN
0xF083 BTN
Index (hex) | Name | Meaning | Data type | Flags | Default
F083:0 | BTN | Beckhoff Traceability Number | STRING | RO | 00000000
Note: this object exists from revision -0018 (ELM3148 from revision -0017) and the FW from release date >2019/03 only


0xF900 PAI Info Data

Commissioning [image] CoE overview [image] ELM30xx [image] 0xF900 PAI Info Data
0xF900 PAI Info Data
Index (hex) | Name | Meaning | Data type | Flags | Default
F900:0 | PAI Info Data |  | UINT8 | RO | 0x13 (19dec)
F900:01 | CPU Usage | CPU load in [%]* | UINT16 | RO | 0x0000 (0dec)
F900:02 | Device State | Device State Permitted values: 0 – OK 1 – Warm Up | UINT16 | RO | 0x0000 (0dec)
F900:03 | Operating Time | Operating time in [min] | UINT32 | RO | 0x00000000 (0dec)
F900:04 | Overtemperature Time (Device) | Time of overtemperature of the device | UINT32 | RO | 0x00000000 (0dec)
F900:11 | Device Temperature | Measured temperature in the terminal | REAL32 | RO | 0x00000000 (0dec)
F900:12 | Min. Device Temperature | Lowest measured temperature in the terminal | REAL32 | RO | 0x00000000 (0dec)
F900:13 | Max. Device Temperature | Highest measured temperature in the terminal | REAL32 | RO | 0x00000000 (0dec)
*) This value depends of additional enabled features (Filters, True RMS, ...); the more functions of the terminal are in use, the greater is the value. Notice amongst others the „Input cycle counter“ (PAI Status). The CPU load is an informative value with particularly regard to the "Device-specific Diag messages".


0xF912 Filter info

Commissioning [image] CoE overview [image] ELM30xx [image] 0xF912 Filter info
0xF912 Filter info
Index (hex) | Name | Meaning | Data type | Flags | Default
F912:0 | Filter info |  | UINT8 | RO | m
F912:01 | Info header | Basic information for the filter designer | OCTET‑STRING[8] | RO | {0}
F912:02 | Filter 1 | Informations for the filter designer | OCTET‑STRING[30] | RO | {0}
... | ... | ... | ... | ... | ...
F912:m | Filter n | Informations for the filter designer | OCTET‑STRING[30] | RO | {0}
m = (2 · No. of channels) + 1
Note: availability of CoE Objekt “0xF912 Filter info”:
Terminal | since FW version | Revision
ELM3002 | 02 | -0017
ELM3004 | 03 | -0018


0xFB00 PAI Command

Commissioning [image] CoE overview [image] ELM30xx [image] 0xFB00 PAI Command
0xFB00 PAI Command
Index (hex) | Name | Meaning | Data type | Flags | Default
FB00:0 | PAI Command |  | UINT8 | RO | 0x03 (3dec)
FB00:01 | Request | Command request The respective functional chapters explain which value is to be entered here. | OCTET-STRING[2] | RW | {0}
FB00:02 | Status | Command status This indicates that the command is still running or has been executed. Functional dependent, see respective sections. Otherwise: 0: Command not existing 1: executed without errors 2,3: executed not successful 100..200: indicates the execution progress (100 = 0% etc.) 255: function is busy, if [100..200] won’t be used as progress display | UINT8 | RO | 0x00 (0dec)
FB00:03 | Response | Command response If the transferred command returns a response, it will be displayed here. Functional dependent, see resprective sections. | OCTET-STRING[6] | RO | {0}


ELM31xx

Commissioning [image] CoE overview [image] ELM31xx
ELM31xx
Additional information
•
0x10F3 Diagnosis History
•
0x60n0 PAI Status Ch.[n+1]
•
0x60n1 PAI Samples Ch.[n+1] (24 Bit)
•
0x60n2 PAI Samples Ch.[n+1] (16 Bit)
•
0x60n5 PAI Timestamp Ch.[n+1]
•
0x60n6 PAI Synchronous Oversampling Ch.[n+1]
•
0x70n0 PAI Control Ch.[n+1]
•
0x80n0 PAI Settings Ch.[n+1]
•
0x80n1 PAI Filter 1 Settings Ch.[n+1]
•
0x80n3 PAI Filter 2 Settings Ch.[n+1]
•
0x80n5 PAI Scaler Settings Ch.[n+1] – not ELM35xx
•
0x80nE PAI User Calibration Ch.[n+1]
•
0x80nF PAI Vendor Calibration Data Ch.[n+1]
•
0x90n0 PAI Internal Data Ch.[n+1]
•
0x90n2 PAI Info Data Ch.[n+1]
•
0x90nF PAI Calibration Dates Ch.[n+1]
•
0xF000 Modular device profile
•
0xF008 Code word
•
0xF009 Password Protection
•
0xF010 Module list
•
0xF083 BTN
•
0xF800 PAI Settings Device - ELM314x only
•
0xF900 PAI Info Data
•
0xF912 Filter info
•
0xFB00 PAI Command


0x10F3 Diagnosis History

Commissioning [image] CoE overview [image] ELM31xx [image] 0x10F3 Diagnosis History
0x10F3 Diagnosis History
Index (hex) | Name | Meaning | Data type | Flags | Default
10F3:0 | Diagnosis History | Max. Subindex | UINT8 | RO | 0x15 (21dec)
10F3:01 | Maximum Messages | Maximum Messages | UINT8 | RO | 0x00 (0dec)
10F3:02 | Newest Message | Newest Message | UINT8 | RO | 0x00 (0dec)
10F3:03 | Newest Acknowledged Message | Subindex of last Acknowledged Message | UINT8 | RW | 0x00 (0dec)
10F3:04 | New Messages Available | True: New Messages Available | BOOLEAN | RO | 0x00 (0dec)
10F3:05 | Flags | Diagnosis message options (see ETG specification) | UINT16 | RW | 0x0000 (0dec)
10F3:06 .10F3:15 | Diagnosis Message 001... Diagnosis Message 016 | Diagnosis Message No. 01...16 | OCTET-STRING[22] | RO | {0}


0x60n0 PAI Status Ch.[n+1]

Commissioning [image] CoE overview [image] ELM31xx [image] 0x60n0 PAI Status Ch.[n+1]
0x60n0 PAI Status Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
60n0:0 | PAI Status Ch.[n+1] |  | UINT8 | RO | 0x0F (15dec)
60n0:01 | No of Samples | Number of valid samples within the PDO samples | UINT8 | RO | 0x00 (0dec)
60n0:09 | Error | TRUE: General error | BOOLEAN | RO | 0x00 (0dec)
60n0:0A | Underrange | TRUE: Measurement event underflow | BOOLEAN | RO | 0x00 (0dec)
60n0:0B | Overrange | TRUE: Measurement event overflow | BOOLEAN | RO | 0x00 (0dec)
60n0:0D | Diag | TRUE: New diagnostic message available | BOOLEAN | RO | 0x00 (0dec)
60n0:0E | TxPDO State | TRUE: data invalid | BOOLEAN | RO | 0x00 (0dec)
60n0:0F | Input cycle counter | Incremented by one when values have changed | BIT2 | RO | 0x00 (0dec)


0x60n1 PAI Samples Ch.[n+1] (24 Bit)

Commissioning [image] CoE overview [image] ELM31xx [image] 0x60n1 PAI Samples Ch.[n+1] (24 Bit)
0x60n1 PAI Samples Ch.[n+1] (24 Bit)
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
ELM3x0x:
Index (hex) | Name | Meaning | Data type | Flags | Default
60n1:0 | PAI Samples Ch.[n+1] |  | UINT8 | RO | 0x64 (100dec)
60n1:01 | Sample | Samples | INT32 | RO | 0x00000000 (0dec)
… | … | … | … | … | …
60n1:64 | Sample | Samples | INT32 | RO | 0x00000000 (0dec)
ELM3x4x:
Index (hex) | Name | Meaning | Data type | Flags | Default
60n1:0 | PAI Samples Ch.[n+1] |  | UINT8 | RO | 0x20 (32dec)
60n1:01 | Sample | Samples | INT32 | RO | 0x00000000 (0dec)
… | … | … | … | … | …
60n1:20 | Sample | Samples | INT32 | RO | 0x00000000 (0dec)


0x60n2 PAI Samples Ch.[n+1] (16 Bit)

Commissioning [image] CoE overview [image] ELM31xx [image] 0x60n2 PAI Samples Ch.[n+1] (16 Bit)
0x60n2 PAI Samples Ch.[n+1] (16 Bit)
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels (not ELM3x4x):
Index (hex) | Name | Meaning | Data type | Flags | Default
60n2:0 | PAI Samples Ch.[n+1] |  | UINT8 | RO | 0x64 (100dec)
60n2:01 | Sample | Samples | INT16 | RO | 0x0000 (0dec)
… | … | … | … | … | …
60n2:64 | Sample | Samples | INT16 | RO | 0x0000 (0dec)


0x60n5 PAI Timestamp Ch.[n+1]

Commissioning [image] CoE overview [image] ELM31xx [image] 0x60n5 PAI Timestamp Ch.[n+1]
0x60n5 PAI Timestamp Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
60n5:0 | PAI Timestamp Ch.[n+1] |  | UINT8 | RO | 0x02 (2dec)
60n5:01 | Low | Timestamp (low) | UINT32 | RO | 0x00000000 (0dec)
60n5:02 | Hi | Timestamp (hi) | UINT32 | RO | 0x00000000 (0dec)


0x60n6 PAI Synchronous Oversampling Ch.[n+1]

Commissioning [image] CoE overview [image] ELM31xx [image] 0x60n6 PAI Synchronous Oversampling Ch.[n+1]
0x60n6 PAI Synchronous Oversampling Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
60n6:0 | PAI Synchronous Oversampling Ch.[n+1] |  | RO | UINT8 | 0x01 (1dec)
60n6:01 | Internal Buffer |  | RO | UINT16 | 0x0000 (0dec)


0x70n0 PAI Control Ch.[n+1]

Commissioning [image] CoE overview [image] ELM31xx [image] 0x70n0 PAI Control Ch.[n+1]
0x70n0 PAI Control Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
70n0:0 | PAI Control Ch.[n+1] |  | UINT8 | RO | 0x02 (2dec)
70n0:01 | Integrator Reset | Restart of the integration with each edge | BOOLEAN | RO | 0x00 (0dec)
70n0:02 | Peak Hold Reset | Start new peak value detection with each edge | BOOLEAN | RO | 0x00 (0dec)


0x80n0 PAI Settings Ch.[n+1]

Commissioning [image] CoE overview [image] ELM31xx [image] 0x80n0 PAI Settings Ch.[n+1]
0x80n0 PAI Settings Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
80n0:0 | PAI Settings Ch.[n+1] |  | UINT8 | RO | 0x41 (65dec)
80n0:01 | Interface | Selection of the measurement configuration: 0 – None ELM31xx: 17 - I ±20 mA 18 - I 0...20 mA 19 - I 4...20 mA 20 - I 4...20 mA NAMUR ELM314x: 2 - U ±10 V 3 - U ±5 V 4 - U ±2.5 V 5 - U ±1.25 V 14 - U 0...10 V 15 - U 0...5 V | UINT16 | RW | 0x0000 (0dec)
80n0:04 | Start Connection Test | Start connection test with rising edge (see section “Broken wire detection/ optional connection diagnosis”) | BOOLEAN | RW | 0x00 (FALSE)
80n0:06 (ELM314x only) | Enable Autorange | Autorange (Enable/ Disable) | BOOLEAN | RW | 0x00 (FALSE)
80n0:09 (ELM314x only) | Disable Offset Compensation | Offset Compensation (Enable/ Disable) | BOOLEAN | RW | 0x00 (FALSE)
80n0:16 | Filter 1 | Options for filter 1: 0 – None 1 - FIR Notch 50 Hz 2 - FIR Notch 60 Hz 3 - FIR LP 100 Hz 4 - FIR LP 1000 Hz 5 - FIR HP 150 Hz 16 - IIR Notch 50 Hz 17 - IIR Notch 60 Hz 18 - IIR Butterw. LP 5th Ord. 1 Hz 19 - IIR Butterw. LP 5th Ord. 25 Hz 20 - IIR Butterw. LP 5th Ord. 100 Hz 21 - IIR Butterw. LP 5th Ord. 250 Hz 22 - IIR Butterw. LP 5th Ord. 1000 Hz 32 - User defined FIR Filter 33 - User defined IIR Filter 34 - User defined Average Filter | UINT16 | RW | 0x0000 (0dec)
80n0:17 | Average Filter 1 No of Samples | Number of samples for user-defined Average Filter 1 | UINT16 | RW | 0x00C8 (200dec)
80n0:18 | Decimation Factor | Factor of the individual sampling rate (min. 1) | UINT16 | RW | 0x0001 (1dec)
80n0:19 | Filter 2 | Options for filter 2: 0 – None 1 - IIR 1 2 - IIR 2 3 - IIR 3 4 - IIR 4 5 - IIR 5 6 - IIR 6 7 - IIR 7 8 - IIR 8 16 - User defined FIR Filter 17 - User defined IIR Filter 18 - User defined Average Filter | UINT16 | RW | 0x0000 (0dec)
80n0:1A | Average Filter 2 No of Samples | Number of samples for user-defined Average Filter 2 | UINT16 | RW | 0x00C8 (200dec)
80n0:1B | True RMS No. of Samples | Number of samples for "True RMS" calculation (min. 1, max. 1000); also see chapter TrueRMS (extended maximum values for ELM36xx) | UINT16 | RW | 0x00C8 (200dec)
80n0:1C | Enable True RMS | Activation of "True RMS" calculation | BOOLEAN | RW | 0x00 (FALSE)
80n0:1D | Enable Frequency Counter | Enable Frequency Counter | BOOLEAN | RW | 0x00 (FALSE)
80n0:2B | Extended Functions | Options for future functions/settings 0 – Disabled ELM35xx: 1 – Load Cell Analysis | UINT16 | RW | 0x0000 (0dec)
80n0:2C | Integrator/Differentiator | Options: 0 – Off 1 – Integrator 1x 2 – Integrator 2x (* 3 – Differentiator 1x 4 – Differentiator 2x (* | UINT16 | RW | 0x0000 (0dec)
80n0:2D | Differentiator Samples Delta | Distance of samples for the differentiation; max. value = 1000; except ELM36xx with max value = 5000 | UINT16 | RW | 0x0001 (1dec)
80n0:2E | Scaler | Scaling (enum): 0 – Extended Range 1 – Linear 2 – Lookup Table 3 – Legacy Range 4 – Lookup Table (additive) Optional: 5 – Extended Functions | UINT16 | RW | 0x0000 (0dec)
80n0:2F | Lookup Table Length | Anzahl Stützstellen der LookUp‑Tabelle | UINT16 | RW | 0x0064 (100dec)
80n0:30 | Low Limiter | Smallest PDO output value | INT32 | RW | 0x80000000 (‑2147483648dec)
80n0:31 | High Limiter | Largest PDO output value | INT32 | RW | 0x7FFFFFFF (2147483647dec)
80n0:32 | Low Range Error | Lowest limit at which the error bit and the error LED are set | INT32 | RW | 0xFF800000 (‑8388608dec)
80n0:33 | High Range Error | Highest limit at which the error bit and the error LED are set | INT32 | RW | 0x007FFFFF (8388607dec)
80n0:34 | Timestamp Correction | Value for correcting StartNextLatchTime (timestamp of the first sample) | INT32 | RW | 0xFFFB6C20 (‑300000dec)
80n0:40 | Filter 1 Type Info | Filter 1 type information | STRING | RW | N/A
80n0:41 | Filter 2 Type Info | Filter 2 type information | STRING | RW | N/A
(* Functionality is only available from FW03


0x80n1 PAI Filter 1 Settings Ch.[n+1]

Commissioning [image] CoE overview [image] ELM31xx [image] 0x80n1 PAI Filter 1 Settings Ch.[n+1]
0x80n1 PAI Filter 1 Settings Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
80n1:0 | PAI Filter 1 Settings Ch.[n+1] |  | UINT8 | RO | 0x28 (40dec)
80n1:01 | Filter Coefficient 1 | Coefficients for filter 1 | INT32 | RO | 0x00000000 (0dec)
… | … | … | … | … | …
80n1:28 | Filter Coefficient 40 | Coefficients for filter 1 | INT32 | RO | 0x00000000 (0dec)


0x80n3 PAI Filter 2 Settings Ch.[n+1]

Commissioning [image] CoE overview [image] ELM31xx [image] 0x80n3 PAI Filter 2 Settings Ch.[n+1]
0x80n3 PAI Filter 2 Settings Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
80n3:0 | PAI Filter 2 Settings Ch.[n+1] |  | UINT8 | RO | 0x28 (40dec)
80n3:01 | Filter Coefficient 1 | Coefficients for filter 2 | INT32 | RO | 0x00000000 (0dec)
… | … | … | … | … | …
80n3:28 | Filter Coefficient 40 | Coefficients for filter 2 | INT32 | RO | 0x00000000 (0dec)


0x80n5 PAI Scaler Settings Ch.[n+1] – not ELM35xx

Commissioning [image] CoE overview [image] ELM31xx [image] 0x80n5 PAI Scaler Settings Ch.[n+1] – not ELM35xx
0x80n5 PAI Scaler Settings Ch.[n+1] – not ELM35xx
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
80n5:0 | PAI Scaler Settings Ch.[n+1] | Scaling values offset/gain or LookUp table with 50 x/y value pairs | UINT8 | RO | 0x64 (100dec)
80n5:01 | Scaler Offset/ Scaler Value 1 | Scaling offset oder LookUp x value 1 | INT32 | RW | 0x00000000 (0dec)
80n5:02 | Scaler-Gain/ Scaler Value 2 | Scaling gain oder LookUp y value 1 | INT32 | RW | 0x00000000 (0dec)
80n5:03 | Scaler Value 3 | LookUp x value 2 | INT32 | RW | 0x00000000 (0dec)
80n5:04 | Scaler Value 4 | LookUp y value 2 | INT32 | RW | 0x00000000 (0dec)
.. | .. | .. | .. | .. | ..
80n5:63 | Scaler Value 99 | LookUp x value 50 | INT32 | RW | 0x00000000 (0dec)
80n5:64 | Scaler Value 100 | LookUp y value 50 | INT32 | RW | 0x00000000 (0dec)


0x80nE PAI User Calibration Ch.[n+1]

Commissioning [image] CoE overview [image] ELM31xx [image] 0x80nE PAI User Calibration Ch.[n+1]
0x80nE PAI User Calibration Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
80nE:0 | PAI User Calibration Data Ch.1 |  | UINT8 | RO | 0x0C (12dec)
80nE:01 | Calibration Date | Date of calibration | OCTET-STRING[4] | RW | -
80nE:02 | Signature | Signature of the calibration values | OCTET-STRING[256] | RW | -
80nE:03 | S0 | Offset | REAL32 | RW | 0x00000000 (0dec)
80nE:04 | S1 | Coefficient for first-order samples (S1 * sample) | REAL32 | RW | 0x3F800000 (1.0dec)
80nE:05 | S2 | Coefficient for second-order samples (S2 * sample²) | REAL32 | RW | 0x00000000 (0.0dec)
80nE:06 | S3 | Coefficient for third-order samples (S3 * sample³) | REAL32 | RW | 0x00000000 (0.0dec)
80nE:07 | T1 | Temperature coefficient for first-order temperature value (T1 * temp) | REAL32 | RW | 0x00000000 (0.0dec)
80nE:08 | T1S1 | Combined coefficient for first-order gain and temperature values (T1S1 * temp * sample) | REAL32 | RW | 0x00000000 (0.0dec)
80nE:09 | T2 | Temperature coefficient for second-order temperature value (T2 * temp²) | REAL32 | RW | 0x00000000 (0.0dec)
80nE:0A | T2S1 | Combined coefficient for second-order gain and temperature values (T2S1 * temp² * sample) | REAL32 | RW | 0x00000000 (0.0dec)
80nE:0B | T3 | Temperature coefficient for third-order temperature value (T3 * temp³) | REAL32 | RW | 0x00000000 (0.0dec)
80nE:0C | T3S1 | Combined coefficient for third-order gain and temperature values (T3S1 * temp³ * sample) | REAL32 | RW | 0x00000000 (0.0dec)


0x80nF PAI Vendor Calibration Data Ch.[n+1]

Commissioning [image] CoE overview [image] ELM31xx [image] 0x80nF PAI Vendor Calibration Data Ch.[n+1]
0x80nF PAI Vendor Calibration Data Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
80nF:0 | PAI Vendor Calibration Data Ch.1 |  | UINT8 | RO | 0x0C (12dec)
80nF:01 | Calibration Date | Date of calibration | OCTET-STRING[4] | RW | -
80nF:02 | Signature | Signature of the calibration values | OCTET-STRING[256] | RW | -
80nF:03 | S0 | Offset | REAL32 | RW | 0x00000000 (0dec)
80nF:04 | S1 | Coefficient for first-order samples (S1 * sample) | REAL32 | RW | 0x3F800000 (1.0dec)
80nF:05 | S2 | Coefficient for second-order samples (S2 * sample²) | REAL32 | RW | 0x00000000 (0.0dec)
80nF:06 | S3 | Coefficient for third-order samples (S3 * sample³) | REAL32 | RW | 0x00000000 (0.0dec)
80nF:07 | T1 | Temperature coefficient for first-order temperature value (T1 * temp) | REAL32 | RW | 0x00000000 (0.0dec)
80nF:08 | T1S1 | Combined coefficient for first-order gain and temperature values (T1S1 * temp * sample) | REAL32 | RW | 0x00000000 (0.0dec)
80nF:09 | T2 | Temperature coefficient for second-order temperature value (T2 * temp²) | REAL32 | RW | 0x00000000 (0.0dec)
80nF:0A | T2S1 | Combined coefficient for second-order gain and temperature values (T2S1 * temp² * sample) | REAL32 | RW | 0x00000000 (0.0dec)
80nF:0B | T3 | Temperature coefficient for third-order temperature value (T3 * temp³) | REAL32 | RW | 0x00000000 (0.0dec)
80nF:0C | T3S1 | Combined coefficient for third-order gain and temperature values (T3S1 * temp³ * sample) | REAL32 | RW | 0x00000000 (0.0dec)


0x90n0 PAI Internal Data Ch.[n+1]

Commissioning [image] CoE overview [image] ELM31xx [image] 0x90n0 PAI Internal Data Ch.[n+1]
0x90n0 PAI Internal Data Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
90n0:0 | PAI Internal Data Ch.[n+1] |  | UINT8 | RO | 0x22 (34dec)
90n0:02 | ADC Raw Value | ADC Raw Value | INT32 | RO | 0x00000000 (0dec)
90n0:03 | Calibration Value | Value after calibration | INT32 | RO | 0x00000000 (0dec)
90n0:04 | Zero Offset Value | Zero offset value | INT32 | RO | 0x00000000 (0dec)
90n0:07 | Actual Negative Peak Hold | Current absolute minimum value | INT32 | RO | 0x00000000 (0dec)
90n0:08 | Actual Positive Peak Hold | Current absolute maximum value | INT32 | RO | 0x00000000 (0dec)
90n0:09 | Previous Negative Peak Hold | Absolute minimum value up to last rising edge of "Peak Hold Reset" | INT32 | RO | 0x00000000 (0dec)
90n0:0A | Previous Positive Peak Hold | Absolute maximum value up to last rising edge of "Peak Hold Reset" | INT32 | RO | 0x00000000 (0dec)
90n0:0B | Filter 1 Value | Value after filter 1 | INT32 | RO | 0x00000000 (0dec)
90n0:0C | Filter 2 Value | Value after filter 2 | INT32 | RO | 0x00000000 (0dec)
90n0:0D | True RMS Value | Value after "True RMS" calculation | INT32 | RO | 0x00000000 (0dec)
90n0:0E | Extended Functions Value | Value after advanced (optional) function | INT32 | RO | 0x00000000 (0dec)
90n0:0F | Integrator/Differentiator Value | Value after integration or differentiation | INT32 | RO | 0x00000000 (0dec)
90n0:10 | Scaler Value | Value after scaling | INT32 | RO | 0x00000000 (0dec)
90n0:11 | Limiter Value | Value after limitation | INT32 | RO | 0x00000000 (0dec)
90n0:20 | DC Bias Voltage | DC bias voltage in AC operation | REAL32 | RO | 0x00000000 (0dec)
90n0:21 | Signal Frequency | Frequency of the input signal | UINT32 | RO | 0x00000000 (0dec)
90n0:22 | Signal Duty Cycle | Duty Cycle of the input signal | UINT8 | RO | 0x00 (0dec)


0x90n2 PAI Info Data Ch.[n+1]

Commissioning [image] CoE overview [image] ELM31xx [image] 0x90n2 PAI Info Data Ch.[n+1]
0x90n2 PAI Info Data Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
90n2:0 | PAI Info Data Ch.[n+1] |  | UINT8 | RO | 0x12 (18dec)
90n2:01 | Effective Sample Rate | Effective Sample Rate | UINT32 | RO | 0x00000000 (0dec)
90n2:02 | Channel Temperature | Temperature of the channel | REAL32 | RO | 0x00000000 (0dec)
90n2:03 | Min. Channel Temperature | Minimal temperature of the channel | REAL32 | RO | 0x00000000 (0dec)
90n2:04 | Max. Channel Temperature | Maximal temperature of the channel | REAL32 | RO | 0x00000000 (0dec)
90n2:05 | Overload Time | Absolute time during overload "Overload" means that the channel is electrically overloaded. This is a non-recommendable condition that may eventually lead to atypical aging or even damage. This condition should be avoided. Its accumulated duration is displayed here informatively. | UINT32 | RO | 0x00000000 (0dec)
90n2:06 | Saturation Time | Absolute time during saturation "Saturation" means that the measuring range of the ADC of the channel is fully utilized, the ADC thus outputs its maximum value and the measured value can no longer be used. "Saturation" is therefore a pre-deregistration, with further signal increase it comes to "overload". The saturation state is not fundamentally harmful, but it indicates an insufficient dimensioning of the measurement channel. Its accumulated response time is displayed here informatively. | UINT32 | RO | 0x00000000 (0dec)
90n2:07 | Overtemperature Time (Channel) | Time of exceeded temperature of the channel | UINT32 | RO | 0x00000000 (0dec)
90n2:11 | Vendor Calibration Counter | Counter of the vendor calibration (related to the selected interface) The counter counts +1 when data has changed and the memory code word is written. Depending on the adjustment method, the counter may therefore count several times. | UINT16 | RO | 0x0000 (0dec)
90n2:12 | User Calibration Counter | Counter of the user calibration (related to the selected interface) The counter counts +1 when data has changed and the memory code word is written. Depending on the adjustment method, the counter may therefore count several times. | UINT16 | RO | 0x0000 (0dec)


0x90nF PAI Calibration Dates Ch.[n+1]

Commissioning [image] CoE overview [image] ELM31xx [image] 0x90nF PAI Calibration Dates Ch.[n+1]
0x90nF PAI Calibration Dates Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels:
ELM310x:
Index (hex) | Name | Meaning | Data type | Flags | Default
90nF:0 | PAI Calibration Dates |  | UINT8 | RO | 0x94 (148dec)
90nF:11 | Vendor I ±20 mA |  | OCTET-STRING[4] | RO | {0}
90nF:12 | Vendor I 0…20 mA |  | OCTET-STRING[4] | RO | {0}
90nF:13 | Vendor I 4…20 mA |  | OCTET-STRING[4] | RO | {0}
90nF:14 | Vendor I 4…20 mA (NAMUR) |  | OCTET-STRING[4] | RO | {0}
90nF:91 | User I ±20 mA |  | OCTET-STRING[4] | RO | {0}
90nF:92 | User I 0…20 mA |  | OCTET-STRING[4] | RO | {0}
90nF:93 | User I 4…20 mA |  | OCTET-STRING[4] | RO | {0}
90nF:94 | User I 4…20 mA (NAMUR) |  | OCTET-STRING[4] | RO | {0}
ELM314x:
Index (hex) | Name | Meaning | Data type | Flags | Default
90nF:0 | PAI Calibration Dates |  | UINT8 | RO | 0x94 (148dez)
90nF:02 | Vendor U ±10 V |  | OCTET-STRING[4] | RO | {0}
90nF:03 | Vendor U ±5 V |  | OCTET-STRING[4] | RO | {0}
90nF:04 | Vendor U ±2.5 V |  | OCTET-STRING[4] | RO | {0}
90nF:05 | Vendor U ±1.25 V |  | OCTET-STRING[4] | RO | {0}
90nF:0E | Vendor U 0..10 V |  | OCTET-STRING[4] | RO | {0}
90nF:0F | Vendor U 0..5 V |  | OCTET-STRING[4] | RO | {0}
90nF:11 | Vendor I ±20 mA |  | OCTET-STRING[4] | RO | {0}
90nF:12 | Vendor I 0…20 mA |  | OCTET-STRING[4] | RO | {0}
90nF:13 | Vendor I 4…20 mA |  | OCTET-STRING[4] | RO | {0}
90nF:14 | Vendor I 4…20 mA (NAMUR) |  | OCTET-STRING[4] | RO | {0}
90nF:82 | User U ±10 V |  | OCTET-STRING[4] | RO | {0}
90nF:83 | User U ±5 V |  | OCTET-STRING[4] | RO | {0}
90nF:84 | User U ±2.5 V |  | OCTET-STRING[4] | RO | {0}
90nF:85 | User U ±1.25 V |  | OCTET-STRING[4] | RO | {0}
90nF:8E | User U 0..10 V |  | OCTET-STRING[4] | RO | {0}
90nF:8F | User U 0..5 V |  | OCTET-STRING[4] | RO | {0}
90nF:91 | User I ±20 mA |  | OCTET-STRING[4] | RO | {0}
90nF:92 | User I 0…20 mA |  | OCTET-STRING[4] | RO | {0}
90nF:93 | User I 4…20 mA |  | OCTET-STRING[4] | RO | {0}
90nF:94 | User I 4…20 mA (NAMUR) |  | OCTET-STRING[4] | RO | {0}


0xF000 Modular device profile

Commissioning [image] CoE overview [image] ELM31xx [image] 0xF000 Modular device profile
0xF000 Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0004 (4dec)


0xF008 Code word

Commissioning [image] CoE overview [image] ELM31xx [image] 0xF008 Code word
0xF008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word |  | UINT32 | RW | 0x00000000 (0dec)


0xF009 Password Protection

Commissioning [image] CoE overview [image] ELM31xx [image] 0xF009 Password Protection
0xF009 Password Protection
Index (hex) | Name | Meaning | Data type | Flags | Default
F009:0 | Password protection |  | UINT32 | RW | 0x00000000 (0dec)


0xF010 Module list

Commissioning [image] CoE overview [image] ELM31xx [image] 0xF010 Module list
0xF010 Module list
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list |  | UINT8 | RW | n
F010:01 | Subindex 001 |  | UINT32 | RW | 0x0000015E (350dec)
... | ... | ... | ... | ... | ...
F010:n | Subindex n |  | UINT32 | RW | 0x0000015E (350dec)
n = number of existing channels by the terminal


0xF083 BTN

Commissioning [image] CoE overview [image] ELM31xx [image] 0xF083 BTN
0xF083 BTN
Index (hex) | Name | Meaning | Data type | Flags | Default
F083:0 | BTN | Beckhoff Traceability Number | STRING | RO | 00000000
Note: this object exists from revision -0018 (ELM3148 from revision -0017) and the FW from release date >2019/03 only


0xF800 PAI Settings Device - ELM314x only

Commissioning [image] CoE overview [image] ELM31xx [image] 0xF800 PAI Settings Device - ELM314x only
0xF800 PAI Settings Device - ELM314x only
ELM314x only:
Index (hex) | Name | Meaning | Data type | Flags | Default
F800:0 | PAI Settings Device |  | UINT8 | RO | 0x01 (1dez)
F800:01 | Connect Up- to GNDA | TRUE: Up- with GNDA connected | BOOLEAN | RW | 0x00 (0dez)


0xF900 PAI Info Data

Commissioning [image] CoE overview [image] ELM31xx [image] 0xF900 PAI Info Data
0xF900 PAI Info Data
Index (hex) | Name | Meaning | Data type | Flags | Default
F900:0 | PAI Info Data |  | UINT8 | RO | ELM3x0x: 0x13 (19dec) ELM314x: 0x20 (32dec)
F900:01 | CPU Usage | CPU load in [%]* | UINT16 | RO | 0x0000 (0dec)
F900:02 | Device State | Device State Permitted values: 0 – OK 1 – Warm Up | UINT16 | RO | 0x0000 (0dec)
F900:03 | Operating Time | Operating time in [min] | UINT32 | RO | 0x00000000 (0dec)
F900:04 | Overtemperature Time (Device) | Time of overtemperature of the device | UINT32 | RO | 0x00000000 (0dec)
F900:11 | Device Temperature | Measured temperature in the terminal | REAL32 | RO | 0x00000000 (0dec)
F900:12 | Min. Device Temperature | Lowest measured temperature in the terminal | REAL32 | RO | 0x00000000 (0dec)
F900:13 | Max. Device Temperature | Highest measured temperature in the terminal | REAL32 | RO | 0x00000000 (0dec)
F900:20 (ELM314x only) | Status Up | Up status | BOOLEAN | RO | 0x00 (0dec)
*) This value depends of additional enabled features (Filters, True RMS, ...); the more functions of the terminal are in use, the greater is the value. Notice amongst others the „Input cycle counter“ (PAI Status). The CPU load is an informative value with particularly regard to the "Device-specific Diag messages".


0xF912 Filter info

Commissioning [image] CoE overview [image] ELM31xx [image] 0xF912 Filter info
0xF912 Filter info
Index (hex) | Name | Meaning | Data type | Flags | Default
F912:0 | Filter info |  | UINT8 | RO | m
F912:01 | Info header | Basic information for the filter designer | OCTET‑STRING[8] | RO | {0}
F912:02 | Filter 1 | Informations for the filter designer | OCTET‑STRING[30] | RO | {0}
... | ... | ... | ... | ... | ...
F912:m | Filter n | Informations for the filter designer | OCTET‑STRING[30] | RO | {0}
m = (2 · No. of channels) + 1
Note: availability of CoE Objekt “0xF912 Filter info”:
Terminal | since FW version | Revision
ELM310x | 02 | -0017
ELM314x | 01 | -0016


0xFB00 PAI Command

Commissioning [image] CoE overview [image] ELM31xx [image] 0xFB00 PAI Command
0xFB00 PAI Command
Index (hex) | Name | Meaning | Data type | Flags | Default
FB00:0 | PAI Command |  | UINT8 | RO | 0x03 (3dec)
FB00:01 | Request | Command request The respective functional chapters explain which value is to be entered here. | OCTET-STRING[2] | RW | {0}
FB00:02 | Status | Command status This indicates that the command is still running or has been executed. Functional dependent, see respective sections. Otherwise: 0: Command not existing 1: executed without errors 2,3: executed not successful 100..200: indicates the execution progress (100 = 0% etc.) 255: function is busy, if [100..200] won’t be used as progress display | UINT8 | RO | 0x00 (0dec)
FB00:03 | Response | Command response If the transferred command returns a response, it will be displayed here. Functional dependent, see resprective sections. | OCTET-STRING[6] | RO | {0}


ELM35xx

Commissioning [image] CoE overview [image] ELM35xx
ELM35xx
Additional information
•
0x10F3 Diagnosis History
•
0x60n0 PAI Status Ch.[n+1]
•
0x60n1 PAI Samples Ch.[n+1] (24 Bit)
•
0x60n2 PAI Samples Ch.[n+1] (16 Bit)
•
0x60n3 PAI Samples Ch.[n+1] (24 Bit) – ELM35xx only
•
0x60n5 PAI Timestamp Ch.[n+1]
•
0x60n6 PAI Synchronous Oversampling Ch.[n+1]
•
0x70n0 PAI Control Ch.[n+1]
•
0x80n0 PAI Settings Ch.[n+1]
•
0x80n1 PAI Filter 1 Settings Ch.[n+1]
•
0x80n3 PAI Filter 2 Settings Ch.[n+1]
•
0x80n6 PAI Scaler Settings Ch.[n+1] – ELM35xx only
•
0x80nA PAI Extended Settings Ch.[n+1] - ELM35xx, ELM37xx only
•
0x80nE PAI User Calibration Ch.[n+1]
•
0x80nF PAI Vendor Calibration Data Ch.[n+1]
•
0x90n0 PAI Internal Data Ch.[n+1]
•
0x90n2 PAI Info Data Ch.[n+1]
•
0x90nF PAI Calibration Dates Ch.[n+1]
•
0xF000 Modular device profile
•
0xF008 Code word
•
0xF009 Password Protection
•
0xF010 Module list
•
0xF083 BTN
•
0xF900 PAI Info Data
•
0xF912 Filter info
•
0xFB00 PAI Command
•
0x80n0:01 PAI Settings.Interface


0x10F3 Diagnosis History

Commissioning [image] CoE overview [image] ELM35xx [image] 0x10F3 Diagnosis History
0x10F3 Diagnosis History
Index (hex) | Name | Meaning | Data type | Flags | Default
10F3:0 | Diagnosis History | Max. Subindex | UINT8 | RO | 0x15 (21dec)
10F3:01 | Maximum Messages | Maximum Messages | UINT8 | RO | 0x00 (0dec)
10F3:02 | Newest Message | Newest Message | UINT8 | RO | 0x00 (0dec)
10F3:03 | Newest Acknowledged Message | Subindex of last Acknowledged Message | UINT8 | RW | 0x00 (0dec)
10F3:04 | New Messages Available | True: New Messages Available | BOOLEAN | RO | 0x00 (0dec)
10F3:05 | Flags | Diagnosis message options (see ETG specification) | UINT16 | RW | 0x0000 (0dec)
10F3:06 .10F3:15 | Diagnosis Message 001... Diagnosis Message 016 | Diagnosis Message No. 01...16 | OCTET-STRING[22] | RO | {0}


0x60n0 PAI Status Ch.[n+1]

Commissioning [image] CoE overview [image] ELM35xx [image] 0x60n0 PAI Status Ch.[n+1]
0x60n0 PAI Status Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
60n0:0 | PAI Status Ch.[n+1] |  | UINT8 | RO | 0x0F (15dec)
60n0:01 | No of Samples | Number of valid samples within the PDO samples | UINT8 | RO | 0x00 (0dec)
60n0:09 | Error | TRUE: General error | BOOLEAN | RO | 0x00 (0dec)
60n0:0A | Underrange | TRUE: Measurement event underflow | BOOLEAN | RO | 0x00 (0dec)
60n0:0B | Overrange | TRUE: Measurement event overflow | BOOLEAN | RO | 0x00 (0dec)
60n0:0D | Diag | TRUE: New diagnostic message available | BOOLEAN | RO | 0x00 (0dec)
60n0:0E | TxPDO State | TRUE: data invalid | BOOLEAN | RO | 0x00 (0dec)
60n0:0F | Input cycle counter | Incremented by one when values have changed | BIT2 | RO | 0x00 (0dec)


0x60n1 PAI Samples Ch.[n+1] (24 Bit)

Commissioning [image] CoE overview [image] ELM35xx [image] 0x60n1 PAI Samples Ch.[n+1] (24 Bit)
0x60n1 PAI Samples Ch.[n+1] (24 Bit)
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
ELM3x0x:
Index (hex) | Name | Meaning | Data type | Flags | Default
60n1:0 | PAI Samples Ch.[n+1] |  | UINT8 | RO | 0x64 (100dec)
60n1:01 | Sample | Samples | INT32 | RO | 0x00000000 (0dec)
… | … | … | … | … | …
60n1:64 | Sample | Samples | INT32 | RO | 0x00000000 (0dec)
ELM3x4x:
Index (hex) | Name | Meaning | Data type | Flags | Default
60n1:0 | PAI Samples Ch.[n+1] |  | UINT8 | RO | 0x20 (32dec)
60n1:01 | Sample | Samples | INT32 | RO | 0x00000000 (0dec)
… | … | … | … | … | …
60n1:20 | Sample | Samples | INT32 | RO | 0x00000000 (0dec)


0x60n2 PAI Samples Ch.[n+1] (16 Bit)

Commissioning [image] CoE overview [image] ELM35xx [image] 0x60n2 PAI Samples Ch.[n+1] (16 Bit)
0x60n2 PAI Samples Ch.[n+1] (16 Bit)
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels (not ELM3x4x):
Index (hex) | Name | Meaning | Data type | Flags | Default
60n2:0 | PAI Samples Ch.[n+1] |  | UINT8 | RO | 0x64 (100dec)
60n2:01 | Sample | Samples | INT16 | RO | 0x0000 (0dec)
… | … | … | … | … | …
60n2:64 | Sample | Samples | INT16 | RO | 0x0000 (0dec)


0x60n3 PAI Samples Ch.[n+1] (24 Bit) – ELM35xx only

Commissioning [image] CoE overview [image] ELM35xx [image] 0x60n3 PAI Samples Ch.[n+1] (24 Bit) – ELM35xx only
0x60n3 PAI Samples Ch.[n+1] (24 Bit) – ELM35xx only
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
ELM3x0x:
Index (hex) | Name | Meaning | Data type | Flags | Default
60n1:0 | PAI Samples Ch.[n+1] |  | UINT8 | RO | 0x64 (100dec)
60n1:01 | Sample | Samples | INT32 | RO | 0x00000000 (0dec)
… | … | … | … | … | …
60n1:64 | Sample | Samples | INT32 | RO | 0x00000000 (0dec)
ELM3x4x:
Index (hex) | Name | Meaning | Data type | Flags | Default
60n1:0 | PAI Samples Ch.[n+1] |  | UINT8 | RO | 0x20 (32dec)
60n1:01 | Sample | Samples | INT32 | RO | 0x00000000 (0dec)
… | … | … | … | … | …
60n1:20 | Sample | Samples | INT32 | RO | 0x00000000 (0dec)


0x60n5 PAI Timestamp Ch.[n+1]

Commissioning [image] CoE overview [image] ELM35xx [image] 0x60n5 PAI Timestamp Ch.[n+1]
0x60n5 PAI Timestamp Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
60n5:0 | PAI Timestamp Ch.[n+1] |  | UINT8 | RO | 0x02 (2dec)
60n5:01 | Low | Timestamp (low) | UINT32 | RO | 0x00000000 (0dec)
60n5:02 | Hi | Timestamp (hi) | UINT32 | RO | 0x00000000 (0dec)


0x60n6 PAI Synchronous Oversampling Ch.[n+1]

Commissioning [image] CoE overview [image] ELM35xx [image] 0x60n6 PAI Synchronous Oversampling Ch.[n+1]
0x60n6 PAI Synchronous Oversampling Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
60n6:0 | PAI Synchronous Oversampling Ch.[n+1] |  | RO | UINT8 | 0x01 (1dec)
60n6:01 | Internal Buffer |  | RO | UINT16 | 0x0000 (0dec)


0x70n0 PAI Control Ch.[n+1]

Commissioning [image] CoE overview [image] ELM35xx [image] 0x70n0 PAI Control Ch.[n+1]
0x70n0 PAI Control Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
70n0:0 | PAI Control Ch.[n+1] |  | UINT8 | RO | 0x02 (2dec)
70n0:01 | Integrator Reset | Restart of the integration with each edge | BOOLEAN | RO | 0x00 (0dec)
70n0:02 | Peak Hold Reset | Start new peak value detection with each edge | BOOLEAN | RO | 0x00 (0dec)


0x80n0 PAI Settings Ch.[n+1]

Commissioning [image] CoE overview [image] ELM35xx [image] 0x80n0 PAI Settings Ch.[n+1]
0x80n0 PAI Settings Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
80n0:0 | PAI Settings Ch.[n+1] |  | UINT8 | RO | 0x41 (65dec)
80n0:01 | Interface | Selection of the measurement configuration: 0 – None ELM350x/ ELM354x: 2 - U ±10 V 9 - U ±80 mV 14 – U 0..10 V 42 - PT1000 2Wire 43 - PT1000 3Wire 65 - Poti 3Wire 66 - Poti 5Wire more.. | UINT16 | RW | 0x0000 (0dec)
80n0:02 (ELM35xx only) | Sensor Supply | Sensor supply: ELM350x/ ELM354x: 0 - 0.0 V 2 - 1.0 V 3 - 1.5 V 4 - 2.0 V 5 - 2.5 V 6 - 3.0 V 7 - 3.5 V 8 - 4.0 V 9 - 4.5 V 10 - 5.0 V 65535 - External Supply ELM354x: 11 - 5.5 V 12 - 6.0 V 13 - 6.5 V 14 - 7.0 V 15 - 7.5 V 16 - 8.0 V 17 - 8.5 V 18 - 9.0 V 19 - 9.5 V 20 - 10.0 V 21 - 10.5 V 22 - 11.0 V 23 - 11.5 V 24 - 12.0 V | UINT16 | RW | 0x0000 (0dec)
80n0:04 | Start Connection Test | Start connection test with rising edge (see section “Broken wire detection/ optional connection diagnosis”) | BOOLEAN | RW | 0x00 (FALSE)
80n0:08 | Enable Shunt Calibration | Shunt calibration (Enable/ Disable) | BOOLEAN | RW | 0x00 (FALSE)
80n0:09 (ELM314x only) | Disable Offset Compensation | Offset Compensation (Enable/ Disable) | BOOLEAN | RW | 0x00 (FALSE)
80n0:13 | Wire Resistance Compensation | Wire resistance compensation | REAL32 | RW | 0x00000000 (0dec)
80n0:16 | Filter 1 | Options for filter 1: 0 – None 1 - FIR Notch 50 Hz 2 - FIR Notch 60 Hz 3 - FIR LP 100 Hz 4 - FIR LP 1000 Hz 5 - FIR HP 150 Hz 16 - IIR Notch 50 Hz 17 - IIR Notch 60 Hz 18 - IIR Butterw. LP 5th Ord. 1 Hz 19 - IIR Butterw. LP 5th Ord. 25 Hz 20 - IIR Butterw. LP 5th Ord. 100 Hz 21 - IIR Butterw. LP 5th Ord. 250 Hz 22 - IIR Butterw. LP 5th Ord. 1000 Hz 32 - User defined FIR Filter 33 - User defined IIR Filter 34 - User defined Average Filter | UINT16 | RW | 0x0000 (0dec)
80n0:17 | Average Filter 1 No of Samples | Number of samples for user-defined Average Filter 1 | UINT16 | RW | 0x00C8 (200dec)
80n0:18 | Decimation Factor | Factor of the individual sampling rate (min. 1) | UINT16 | RW | 0x0001 (1dec)
80n0:19 | Filter 2 | Options for filter 2: 0 – None 1 - IIR 1 2 - IIR 2 3 - IIR 3 4 - IIR 4 5 - IIR 5 6 - IIR 6 7 - IIR 7 8 - IIR 8 16 - User defined FIR Filter 17 - User defined IIR Filter 18 - User defined Average Filter | UINT16 | RW | 0x0000 (0dec)
80n0:1A | Average Filter 2 No of Samples | Number of samples for user-defined Average Filter 2 | UINT16 | RW | 0x00C8 (200dec)
80n0:1B | True RMS No. of Samples | Number of samples for "True RMS" calculation (min. 1, max. 1000); also see chapter TrueRMS (extended maximum values for ELM36xx) | UINT16 | RW | 0x00C8 (200dec)
80n0:1C | Enable True RMS | Activation of "True RMS" calculation | BOOLEAN | RW | 0x00 (FALSE)
80n0:1D | Enable Frequency Counter | Enable Frequency Counter | BOOLEAN | RW | 0x00 (FALSE)
80n0:1E | Reset Load Cycle Counter | Reset Load Cycle Counter | BOOLEAN | RW | 0x00 (FALSE)
80n0:2B | Extended Functions | Options for future functions/settings 0 – Disabled ELM35xx: 1 – Load Cell Analysis | UINT16 | RW | 0x0000 (0dec)
80n0:2C | Integrator/Differentiator | Options: 0 – Off 1 – Integrator 1x 2 – Integrator 2x (* 3 – Differentiator 1x 4 – Differentiator 2x (* | UINT16 | RW | 0x0000 (0dec)
80n0:2D | Differentiator Samples Delta | Distance of samples for the differentiation; max. value = 1000; except ELM36xx with max value = 5000 | UINT16 | RW | 0x0001 (1dec)
80n0:2E | Scaler | Scaling (enum): 0 – Extended Range 1 – Linear 2 – Lookup Table 3 – Legacy Range 4 – Lookup Table (additive) Optional: 5 – Extended Functions | UINT16 | RW | 0x0000 (0dec)
80n0:2F | Lookup Table Length | Anzahl Stützstellen der LookUp‑Tabelle | UINT16 | RW | 0x0064 (100dec)
80n0:32 | Low Range Error | Lowest limit at which the error bit and the error LED are set | INT32 | RW | 0xFF800000 (‑8388608dec)
80n0:33 | High Range Error | Highest limit at which the error bit and the error LED are set | INT32 | RW | 0x007FFFFF (8388607dec)
80n0:34 | Timestamp Correction | Value for correcting StartNextLatchTime (timestamp of the first sample) | INT32 | RW | 0xFFFB6C20 (‑300000dec)
80n0:35 | Low Limiter | Smallest PDO output value | REAL32 | RW | 0xFF7FFFFD (-8388611dec)
80n0:36 | High Limiter | Largest PDO output value | REAL32 | RW | 0x7F7FFFFD (2139095037dec)
80n0:37 | Bridge Resistance | Bridge resistance | REAL32 | RW | 0x43AF0000 (1135542272dec)
80n0:38 | Wire Resistance Uv- | Wire resistance Uv– | REAL32 | RW | 0x00000000 (0dec)
80n0:39 | Wire Resistance Uv+ | Wire resistance Uv+ | REAL32 | RW | 0x00000000 (0dec)
80n0:3A | Low Load Cycle Limit | Low load cycle limit | REAL32 | RW | 0x00000000 (0dec)
80n0:3B | High Load Cycle Limit | High load cycle limit | REAL32 | RW | 0x00000000 (0dec)
80n0:40 | Filter 1 Type Info | Filter 1 type information | STRING | RW | N/A
80n0:41 | Filter 2 Type Info | Filter 2 type information | STRING | RW | N/A
(* Functionality is only available from FW03


0x80n1 PAI Filter 1 Settings Ch.[n+1]

Commissioning [image] CoE overview [image] ELM35xx [image] 0x80n1 PAI Filter 1 Settings Ch.[n+1]
0x80n1 PAI Filter 1 Settings Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
80n1:0 | PAI Filter 1 Settings Ch.[n+1] |  | UINT8 | RO | 0x28 (40dec)
80n1:01 | Filter Coefficient 1 | Coefficients for filter 1 | INT32 | RO | 0x00000000 (0dec)
… | … | … | … | … | …
80n1:28 | Filter Coefficient 40 | Coefficients for filter 1 | INT32 | RO | 0x00000000 (0dec)


0x80n3 PAI Filter 2 Settings Ch.[n+1]

Commissioning [image] CoE overview [image] ELM35xx [image] 0x80n3 PAI Filter 2 Settings Ch.[n+1]
0x80n3 PAI Filter 2 Settings Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
80n3:0 | PAI Filter 2 Settings Ch.[n+1] |  | UINT8 | RO | 0x28 (40dec)
80n3:01 | Filter Coefficient 1 | Coefficients for filter 2 | INT32 | RO | 0x00000000 (0dec)
… | … | … | … | … | …
80n3:28 | Filter Coefficient 40 | Coefficients for filter 2 | INT32 | RO | 0x00000000 (0dec)


0x80n6 PAI Scaler Settings Ch.[n+1] – ELM35xx only

Commissioning [image] CoE overview [image] ELM35xx [image] 0x80n6 PAI Scaler Settings Ch.[n+1] – ELM35xx only
0x80n6 PAI Scaler Settings Ch.[n+1] – ELM35xx only
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
80n6:0 | PAI Scaler Settings Ch.[n+1] | Scaling values offset/gain or LookUp table with 50 x/y value pairs | UINT8 | RO | 0x64 (100dec)
80n6:01 | Scaler Offset/ Scaler Value 1 | Scaling offset oder LookUp x value 1 | REAL32 | RW | 0x00000000 (0dec)
80n6:02 | Scaler-Gain/ Scaler Value 2 | Scaling gain oder LookUp y value 1 | REAL32 | RW | 0x00000000 (0dec)
80n6:03 | Scaler Value 3 | LookUp x value 2 | REAL32 | RW | 0x00000000 (0dec)
80n6:04 | Scaler Value 4 | LookUp y value 2 | REAL32 | RW | 0x00000000 (0dec)
.. | .. | .. | .. | .. | ..
80n6:63 | Scaler Value 99 | LookUp x value 50 | REAL32 | RW | 0x00000000 (0dec)
80n6:64 | Scaler Value 100 | LookUp y value 50 | REAL32 | RW | 0x00000000 (0dec)


0x80nA PAI Extended Settings Ch.[n+1] - ELM35xx, ELM37xx only

Commissioning [image] CoE overview [image] ELM35xx [image] 0x80nA PAI Extended Settings Ch.[n+1] - ELM35xx, ELM37xx only
0x80nA PAI Extended Settings Ch.[n+1] - ELM35xx, ELM37xx only
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
(Special settings for the „Extended Functions“)
Index (hex) | Name | Meaning | Data type | Flags | Default
80nA:0 | PAI Extended Settings Ch.[n+1] | Special settings for the „Extended Functions“ | UINT8 | RO | 0x05 (5dec)
80nA:01 | Sensitivity (Compression) | Sensitivity (mech. compression) | REAL32 | RW | 0x40000000 (1073741824dec)
80nA:02 | Sensitivity (Tension) | Sensitivity (mech. tension) | REAL32 | RW | 0xC0000000 (-1073741824dec)
80nA:03 | Zero Balance | Zero balance | REAL32 | RW | 0x00000000 (0dec)
80nA:04 | Maximum Capacity | Maximum capacity | REAL32 | RW | 0x40A00000 (1084227584dec)
80nA:05 | Gravity of Earth | Gravity of earth | REAL32 | RW | 0x411CE80A (1092413450dec)


0x80nE PAI User Calibration Ch.[n+1]

Commissioning [image] CoE overview [image] ELM35xx [image] 0x80nE PAI User Calibration Ch.[n+1]
0x80nE PAI User Calibration Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
80nE:0 | PAI User Calibration Data Ch.1 |  | UINT8 | RO | 0x0C (12dec)
80nE:01 | Calibration Date | Date of calibration | OCTET-STRING[4] | RW | -
80nE:02 | Signature | Signature of the calibration values | OCTET-STRING[256] | RW | -
80nE:03 | S0 | Offset | REAL32 | RW | 0x00000000 (0dec)
80nE:04 | S1 | Coefficient for first-order samples (S1 * sample) | REAL32 | RW | 0x3F800000 (1.0dec)
80nE:05 | S2 | Coefficient for second-order samples (S2 * sample²) | REAL32 | RW | 0x00000000 (0.0dec)
80nE:06 | S3 | Coefficient for third-order samples (S3 * sample³) | REAL32 | RW | 0x00000000 (0.0dec)
80nE:07 | T1 | Temperature coefficient for first-order temperature value (T1 * temp) | REAL32 | RW | 0x00000000 (0.0dec)
80nE:08 | T1S1 | Combined coefficient for first-order gain and temperature values (T1S1 * temp * sample) | REAL32 | RW | 0x00000000 (0.0dec)
80nE:09 | T2 | Temperature coefficient for second-order temperature value (T2 * temp²) | REAL32 | RW | 0x00000000 (0.0dec)
80nE:0A | T2S1 | Combined coefficient for second-order gain and temperature values (T2S1 * temp² * sample) | REAL32 | RW | 0x00000000 (0.0dec)
80nE:0B | T3 | Temperature coefficient for third-order temperature value (T3 * temp³) | REAL32 | RW | 0x00000000 (0.0dec)
80nE:0C | T3S1 | Combined coefficient for third-order gain and temperature values (T3S1 * temp³ * sample) | REAL32 | RW | 0x00000000 (0.0dec)


0x80nF PAI Vendor Calibration Data Ch.[n+1]

Commissioning [image] CoE overview [image] ELM35xx [image] 0x80nF PAI Vendor Calibration Data Ch.[n+1]
0x80nF PAI Vendor Calibration Data Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
80nF:0 | PAI Vendor Calibration Data Ch.1 |  | UINT8 | RO | 0x0C (12dec)
80nF:01 | Calibration Date | Date of calibration | OCTET-STRING[4] | RW | -
80nF:02 | Signature | Signature of the calibration values | OCTET-STRING[256] | RW | -
80nF:03 | S0 | Offset | REAL32 | RW | 0x00000000 (0dec)
80nF:04 | S1 | Coefficient for first-order samples (S1 * sample) | REAL32 | RW | 0x3F800000 (1.0dec)
80nF:05 | S2 | Coefficient for second-order samples (S2 * sample²) | REAL32 | RW | 0x00000000 (0.0dec)
80nF:06 | S3 | Coefficient for third-order samples (S3 * sample³) | REAL32 | RW | 0x00000000 (0.0dec)
80nF:07 | T1 | Temperature coefficient for first-order temperature value (T1 * temp) | REAL32 | RW | 0x00000000 (0.0dec)
80nF:08 | T1S1 | Combined coefficient for first-order gain and temperature values (T1S1 * temp * sample) | REAL32 | RW | 0x00000000 (0.0dec)
80nF:09 | T2 | Temperature coefficient for second-order temperature value (T2 * temp²) | REAL32 | RW | 0x00000000 (0.0dec)
80nF:0A | T2S1 | Combined coefficient for second-order gain and temperature values (T2S1 * temp² * sample) | REAL32 | RW | 0x00000000 (0.0dec)
80nF:0B | T3 | Temperature coefficient for third-order temperature value (T3 * temp³) | REAL32 | RW | 0x00000000 (0.0dec)
80nF:0C | T3S1 | Combined coefficient for third-order gain and temperature values (T3S1 * temp³ * sample) | REAL32 | RW | 0x00000000 (0.0dec)


0x90n0 PAI Internal Data Ch.[n+1]

Commissioning [image] CoE overview [image] ELM35xx [image] 0x90n0 PAI Internal Data Ch.[n+1]
0x90n0 PAI Internal Data Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
90n0:0 | PAI Internal Data Ch.[n+1] |  | UINT8 | RO | 0x22 (34dec)
90n0:02 | ADC Raw Value | ADC Raw Value | INT32 | RO | 0x00000000 (0dec)
90n0:03 | Calibration Value | Value after calibration | INT32 | RO | 0x00000000 (0dec)
90n0:04 | Zero Offset Value | Zero offset value | INT32 | RO | 0x00000000 (0dec)
90n0:07 | Actual Negative Peak Hold | Current absolute minimum value | INT32 | RO | 0x00000000 (0dec)
90n0:08 | Actual Positive Peak Hold | Current absolute maximum value | INT32 | RO | 0x00000000 (0dec)
90n0:09 | Previous Negative Peak Hold | Absolute minimum value up to last rising edge of "Peak Hold Reset" | INT32 | RO | 0x00000000 (0dec)
90n0:0A | Previous Positive Peak Hold | Absolute maximum value up to last rising edge of "Peak Hold Reset" | INT32 | RO | 0x00000000 (0dec)
90n0:0B | Filter 1 Value | Value after filter 1 | INT32 | RO | 0x00000000 (0dec)
90n0:0C | Filter 2 Value | Value after filter 2 | INT32 | RO | 0x00000000 (0dec)
90n0:0D | True RMS Value | Value after "True RMS" calculation | INT32 | RO | 0x00000000 (0dec)
90n0:0E | Extended Functions Value | Value after advanced (optional) function | INT32 | RO | 0x00000000 (0dec)
90n0:0F | Integrator/Differentiator Value | Value after integration or differentiation | INT32 | RO | 0x00000000 (0dec)
90n0:10 | Scaler Value | Value after scaling | INT32 | RO | 0x00000000 (0dec)
90n0:11 | Limiter Value | Value after limitation | INT32 | RO | 0x00000000 (0dec)
90n0:21 | Signal Frequency | Frequency of the input signal | UINT32 | RO | 0x00000000 (0dec)
90n0:22 | Signal Duty Cycle | Duty Cycle of the input signal | UINT8 | RO | 0x00 (0dec)


0x90n2 PAI Info Data Ch.[n+1]

Commissioning [image] CoE overview [image] ELM35xx [image] 0x90n2 PAI Info Data Ch.[n+1]
0x90n2 PAI Info Data Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
90n2:0 | PAI Info Data Ch.[n+1] |  | UINT8 | RO | 0x12 (18dec)
90n2:01 | Effective Sample Rate | Effective Sample Rate | UINT32 | RO | 0x00000000 (0dec)
90n2:02 | Channel Temperature | Temperature of the channel | REAL32 | RO | 0x00000000 (0dec)
90n2:03 | Min. Channel Temperature | Minimal temperature of the channel | REAL32 | RO | 0x00000000 (0dec)
90n2:04 | Max. Channel Temperature | Maximal temperature of the channel | REAL32 | RO | 0x00000000 (0dec)
90n2:05 | Overload Time | Absolute time during overload "Overload" means that the channel is electrically overloaded. This is a non-recommendable condition that may eventually lead to atypical aging or even damage. This condition should be avoided. Its accumulated duration is displayed here informatively. | UINT32 | RO | 0x00000000 (0dec)
90n2:06 | Saturation Time | Absolute time during saturation "Saturation" means that the measuring range of the ADC of the channel is fully utilized, the ADC thus outputs its maximum value and the measured value can no longer be used. "Saturation" is therefore a pre-deregistration, with further signal increase it comes to "overload". The saturation state is not fundamentally harmful, but it indicates an insufficient dimensioning of the measurement channel. Its accumulated response time is displayed here informatively. | UINT32 | RO | 0x00000000 (0dec)
90n2:07 | Overtemperature Time (Channel) | Time of exceeded temperature of the channel | UINT32 | RO | 0x00000000 (0dec)
90n2:10 | Load Cycle Counter | Load Cycle Counter | UINT32 | RO | 0x00000000 (0dec)
90n2:11 | Vendor Calibration Counter | Counter of the vendor calibration (related to the selected interface) The counter counts +1 when data has changed and the memory code word is written. Depending on the adjustment method, the counter may therefore count several times. | UINT16 | RO | 0x0000 (0dec)
90n2:12 | User Calibration Counter | Counter of the user calibration (related to the selected interface) The counter counts +1 when data has changed and the memory code word is written. Depending on the adjustment method, the counter may therefore count several times. | UINT16 | RO | 0x0000 (0dec)


0x90nF PAI Calibration Dates Ch.[n+1]

Commissioning [image] CoE overview [image] ELM35xx [image] 0x90nF PAI Calibration Dates Ch.[n+1]
0x90nF PAI Calibration Dates Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels:
Index (hex) | Name | Meaning | Data type | Flags | Default
90nF:0 | PAI Calibration Dates |  | UINT8 | RO | 0xC4 (196dec)
90nF:01 | Vendor U ±10 V |  | OCTET-STRING[4] | RO | {0}
90nF:02 | Vendor U ±80 mV |  | OCTET-STRING[4] | RO | {0}
90nF:03 | Vendor U 0..10 V |  | OCTET-STRING[4] | RO | {0}
90nF:04 | Vendor PT1000 2 Wire |  | OCTET-STRING[4] | RO | {0}
90nF:05 | Vendor PT1000 3 Wire |  | OCTET-STRING[4] | RO | {0}
90nF:06 | Vendor PT1000 4 Wire |  | OCTET-STRING[4] | RO | {0}
90nF:07 | Vendor Poti 3 Wire |  | OCTET-STRING[4] | RO | {0}
90nF:08 | Vendor Poti 5 Wire |  | OCTET-STRING[4] | RO | {0}
90nF:09 | Vendor SG Full-Bridge 4Wire 2 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:0A | Vendor SG Full-Bridge 4Wire 2 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:0B | Vendor SG Full-Bridge 4Wire 4 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:0C | Vendor SG Full-Bridge 4Wire 4 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:0D | Vendor SG Full-Bridge 4Wire 8 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:0E | Vendor SG Full-Bridge 4Wire 32 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:0F | Vendor SG Full-Bridge 6Wire 2 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:10 | Vendor SG Full-Bridge 6Wire 2 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:11 | Vendor SG Full-Bridge 6Wire 4 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:12 | Vendor SG Full-Bridge 6Wire 4 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:13 | Vendor SG Full-Bridge 6Wire 8 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:14 | Vendor SG Full-Bridge 6Wire 32 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:15 | Vendor SG Half-Bridge 3Wire 2 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:16 | Vendor SG Half-Bridge 3Wire 2 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:17 | Vendor SG Half-Bridge 3Wire 4 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:18 | Vendor SG Half-Bridge 3Wire 4 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:19 | Vendor SG Half-Bridge 3Wire 8 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:1A | Vendor SG Half-Bridge 3Wire 16 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:1B | Vendor SG Half-Bridge 5Wire 2 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:1C | Vendor SG Half-Bridge 5Wire 2 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:1D | Vendor SG Half-Bridge 5Wire 4 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:1E | Vendor SG Half-Bridge 5Wire 4 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:1F | Vendor SG Half-Bridge 5Wire 8 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:20 | Vendor SG Half-Bridge 5Wire 16 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:21 | Vendor SG Quarter-Bridge 2Wire 120R 2 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:22 | Vendor SG Quarter-Bridge 2Wire 120R 2 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:23 | Vendor SG Quarter-Bridge 2Wire 120R 4 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:24 | Vendor SG Quarter-Bridge 2Wire 120R 4 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:25 | Vendor SG Quarter-Bridge 2Wire 120R 8 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:26 | Vendor SG Quarter-Bridge 2Wire 120R 32 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:27 | Vendor SG Quarter-Bridge 3Wire 120R 2 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:28 | Vendor SG Quarter-Bridge 3Wire 120R 2 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:29 | Vendor SG Quarter-Bridge 3Wire 120R 4 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:2A | Vendor SG Quarter-Bridge 3Wire 120R 4 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:2B | Vendor SG Quarter-Bridge 3Wire 120R 8 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:2C | Vendor SG Quarter-Bridge 3Wire 120R 32 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:2D | Vendor SG Quarter-Bridge 2Wire 350R 2 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:2E | Vendor SG Quarter-Bridge 2Wire 350R 2 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:2F | Vendor SG Quarter-Bridge 2Wire 350R 4 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:30 | Vendor SG Quarter-Bridge 2Wire 350R 4 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:31 | Vendor SG Quarter-Bridge 2Wire 350R 8 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:32 | Vendor SG Quarter-Bridge 2Wire 350R 32 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:33 | Vendor SG Quarter-Bridge 3Wire 350R 2 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:34 | Vendor SG Quarter-Bridge 3Wire 350R 2 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:35 | Vendor SG Quarter-Bridge 3Wire 350R 4 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:36 | Vendor SG Quarter-Bridge 3Wire 350R 4 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:37 | Vendor SG Quarter-Bridge 3Wire 350R 8 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:38 | Vendor SG Quarter-Bridge 3Wire 350R 32 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:39 | Vendor SG Quarter-Bridge 2Wire 1k 2 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:3A | Vendor SG Quarter-Bridge 2Wire 1k 2 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:3B | Vendor SG Quarter-Bridge 2Wire 1k 4 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:3C | Vendor SG Quarter-Bridge 2Wire 1k 4 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:3D | Vendor SG Quarter-Bridge 2Wire 1k 8 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:3E | Vendor SG Quarter-Bridge 2Wire 1k 32 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:3F | Vendor SG Quarter-Bridge 3Wire 1k 2 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:40 | Vendor SG Quarter-Bridge 3Wire 1k 2 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:41 | Vendor SG Quarter-Bridge 3Wire 1k 4 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:42 | Vendor SG Quarter-Bridge 3Wire 1k 4 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:43 | Vendor SG Quarter-Bridge 3Wire 1k 8 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:44 | Vendor SG Quarter-Bridge 3Wire 1k 32 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:81 | User U ±10 V |  | OCTET-STRING[4] | RO | {0}
90nF:82 | User U ±80 mV |  | OCTET-STRING[4] | RO | {0}
90nF:83 | User U 0..10 V |  | OCTET-STRING[4] | RO | {0}
90nF:84 | User PT1000 2 Wire |  | OCTET-STRING[4] | RO | {0}
90nF:85 | User PT1000 3 Wire |  | OCTET-STRING[4] | RO | {0}
90nF:86 | User PT1000 4 Wire |  | OCTET-STRING[4] | RO | {0}
90nF:87 | User Poti 3 Wire |  | OCTET-STRING[4] | RO | {0}
90nF:88 | User Poti 5 Wire |  | OCTET-STRING[4] | RO | {0}
90nF:89 | User SG Full-Bridge 4Wire 2 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:8A | User SG Full-Bridge 4Wire 2 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:8B | User SG Full-Bridge 4Wire 4 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:8C | User SG Full-Bridge 4Wire 4 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:8D | User SG Full-Bridge 4Wire 8 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:8E | User SG Full-Bridge 4Wire 32 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:8F | User SG Full-Bridge 6Wire 2 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:90 | User SG Full-Bridge 6Wire 2 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:91 | User SG Full-Bridge 6Wire 4 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:92 | User SG Full-Bridge 6Wire 4 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:93 | User SG Full-Bridge 6Wire 8 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:94 | User SG Full-Bridge 6Wire 32 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:95 | User SG Half-Bridge 3Wire 2 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:96 | User SG Half-Bridge 3Wire 2 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:97 | User SG Half-Bridge 3Wire 4 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:98 | User SG Half-Bridge 3Wire 4 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:99 | User SG Half-Bridge 3Wire 8 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:9A | User SG Half-Bridge 3Wire 16 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:9B | User SG Half-Bridge 5Wire 2 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:9C | User SG Half-Bridge 5Wire 2 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:9D | User SG Half-Bridge 5Wire 4 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:9E | User SG Half-Bridge 5Wire 4 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:9F | User SG Half-Bridge 5Wire 8 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:A0 | User SG Half-Bridge 5Wire 16 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:A1 | User SG Quarter-Bridge 2Wire 120R 2 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:A2 | User SG Quarter-Bridge 2Wire 120R 2 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:A3 | User SG Quarter-Bridge 2Wire 120R 4 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:A4 | User SG Quarter-Bridge 2Wire 120R 4 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:A5 | User SG Quarter-Bridge 2Wire 120R 8 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:A6 | User SG Quarter-Bridge 2Wire 120R 32 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:A7 | User SG Quarter-Bridge 3Wire 120R 2 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:A8 | User SG Quarter-Bridge 3Wire 120R 2 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:A9 | User SG Quarter-Bridge 3Wire 120R 4 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:AA | User SG Quarter-Bridge 3Wire 120R 4 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:AB | User SG Quarter-Bridge 3Wire 120R 8 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:AC | User SG Quarter-Bridge 3Wire 120R 32 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:AD | User SG Quarter-Bridge 2Wire 350R 2 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:AE | User SG Quarter-Bridge 2Wire 350R 2 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:AF | User SG Quarter-Bridge 2Wire 350R 4 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:B0 | User SG Quarter-Bridge 2Wire 350R 4 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:B1 | User SG Quarter-Bridge 2Wire 350R 8 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:B2 | User SG Quarter-Bridge 2Wire 350R 32 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:B3 | User SG Quarter-Bridge 3Wire 350R 2 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:B4 | User SG Quarter-Bridge 3Wire 350R 2 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:B5 | User SG Quarter-Bridge 3Wire 350R 4 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:B6 | User SG Quarter-Bridge 3Wire 350R 4 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:B7 | User SG Quarter-Bridge 3Wire 350R 8 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:B8 | User SG Quarter-Bridge 3Wire 350R 32 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:B9 | User SG Quarter-Bridge 2Wire 1k 2 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:BA | User SG Quarter-Bridge 2Wire 1k 2 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:BB | User SG Quarter-Bridge 2Wire 1k 4 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:BC | User SG Quarter-Bridge 2Wire 1k 4 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:BD | User SG Quarter-Bridge 2Wire 1k 8 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:BE | User SG Quarter-Bridge 2Wire 1k 32 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:BF | User SG Quarter-Bridge 3Wire 1k 2 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:C0 | User SG Quarter-Bridge 3Wire 1k 2 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:C1 | User SG Quarter-Bridge 3Wire 1k 4 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:C2 | User SG Quarter-Bridge 3Wire 1k 4 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:C3 | User SG Quarter-Bridge 3Wire 1k 8 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:C4 | User SG Quarter-Bridge 3Wire 1k 32 mV/V |  | OCTET-STRING[4] | RO | {0}


0xF000 Modular device profile

Commissioning [image] CoE overview [image] ELM35xx [image] 0xF000 Modular device profile
0xF000 Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0004 (4dec)


0xF008 Code word

Commissioning [image] CoE overview [image] ELM35xx [image] 0xF008 Code word
0xF008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word |  | UINT32 | RW | 0x00000000 (0dec)


0xF009 Password Protection

Commissioning [image] CoE overview [image] ELM35xx [image] 0xF009 Password Protection
0xF009 Password Protection
Index (hex) | Name | Meaning | Data type | Flags | Default
F009:0 | Password protection |  | UINT32 | RW | 0x00000000 (0dec)


0xF010 Module list

Commissioning [image] CoE overview [image] ELM35xx [image] 0xF010 Module list
0xF010 Module list
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list |  | UINT8 | RW | n
F010:01 | Subindex 001 |  | UINT32 | RW | 0x0000015E (350dec)
... | ... | ... | ... | ... | ...
F010:n | Subindex n |  | UINT32 | RW | 0x0000015E (350dec)
n = number of existing channels by the terminal


0xF083 BTN

Commissioning [image] CoE overview [image] ELM35xx [image] 0xF083 BTN
0xF083 BTN
Index (hex) | Name | Meaning | Data type | Flags | Default
F083:0 | BTN | Beckhoff Traceability Number | STRING | RO | 00000000
Note: this object exists from revision -0018 (ELM3148 from revision -0017) and the FW from release date >2019/03 only


0xF900 PAI Info Data

Commissioning [image] CoE overview [image] ELM35xx [image] 0xF900 PAI Info Data
0xF900 PAI Info Data
Index (hex) | Name | Meaning | Data type | Flags | Default
F900:0 | PAI Info Data |  | UINT8 | RO | 0x13 (19dec)
F900:01 | CPU Usage | CPU load in [%]* | UINT16 | RO | 0x0000 (0dec)
F900:02 | Device State | Device State Permitted values: 0 – OK 1 – Warm Up | UINT16 | RO | 0x0000 (0dec)
F900:03 | Operating Time | Operating time in [min] | UINT32 | RO | 0x00000000 (0dec)
F900:04 | Overtemperature Time (Device) | Time of overtemperature of the device | UINT32 | RO | 0x00000000 (0dec)
F900:11 | Device Temperature | Measured temperature in the terminal | REAL32 | RO | 0x00000000 (0dec)
F900:12 | Min. Device Temperature | Lowest measured temperature in the terminal | REAL32 | RO | 0x00000000 (0dec)
F900:13 | Max. Device Temperature | Highest measured temperature in the terminal | REAL32 | RO | 0x00000000 (0dec)
*) This value depends of additional enabled features (Filters, True RMS, ...); the more functions of the terminal are in use, the greater is the value. Notice amongst others the „Input cycle counter“ (PAI Status). The CPU load is an informative value with particularly regard to the "Device-specific Diag messages".


0xF912 Filter info

Commissioning [image] CoE overview [image] ELM35xx [image] 0xF912 Filter info
0xF912 Filter info
Index (hex) | Name | Meaning | Data type | Flags | Default
F912:0 | Filter info |  | UINT8 | RO | m
F912:01 | Info header | Basic information for the filter designer | OCTET‑STRING[8] | RO | {0}
F912:02 | Filter 1 | Informations for the filter designer | OCTET‑STRING[30] | RO | {0}
... | ... | ... | ... | ... | ...
F912:m | Filter n | Informations for the filter designer | OCTET‑STRING[30] | RO | {0}
m = (2 · No. of channels) + 1
Note: availability of CoE Objekt “0xF912 Filter info”:
Terminal | since FW version | Revision
ELM350x | 01 | -0016


0xFB00 PAI Command

Commissioning [image] CoE overview [image] ELM35xx [image] 0xFB00 PAI Command
0xFB00 PAI Command
Index (hex) | Name | Meaning | Data type | Flags | Default
FB00:0 | PAI Command |  | UINT8 | RO | 0x03 (3dec)
FB00:01 | Request | Command request The respective functional chapters explain which value is to be entered here. | OCTET-STRING[2] | RW | {0}
FB00:02 | Status | Command status This indicates that the command is still running or has been executed. Functional dependent, see respective sections. Otherwise: 0: Command not existing 1: executed without errors 2,3: executed not successful 100..200: indicates the execution progress (100 = 0% etc.) 255: function is busy, if [100..200] won’t be used as progress display | UINT8 | RO | 0x00 (0dec)
FB00:03 | Response | Command response If the transferred command returns a response, it will be displayed here. Functional dependent, see resprective sections. | OCTET-STRING[6] | RO | {0}


0x80n0:01 PAI Settings.Interface

Commissioning [image] CoE overview [image] ELM35xx [image] 0x80n0:01 PAI Settings.Interface
0x80n0:01 PAI Settings.Interface
ELM350x/ELM354x: 0x80n0:01 PAI Settings.Interface (0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels) - continued
Index (hex)
Meaning
Data type
Flags
Default
80n0:01
Selection of the measurement configuration (continued):
0x80n0 PAI Settings
...
ELM350x:
49 - SG 1/4 2 Wire 120R
50 - SG 1/4 3 Wire 120R
51 - SG 1/4 2 Wire 350R
52 - SG 1/4 3 Wire 350R
53 - SG 1/2 3 Wire 16 mV/V
54 - SG 1/2 5 Wire 16 mV/V
55 - SG 1/1 4 Wire 32 mV/V
56 - SG 1/1 6 Wire 32 mV/V
57 - SG 1/4 2 Wire 1k
58 - SG 1/4 3 Wire 1k
59 - SG 1/2 3 Wire 2 mV/V
60 - SG 1/2 5 Wire 2 mV/V
61 - SG 1/1 4 Wire 2 mV/V
62 - SG 1/1 6 Wire 2 mV/V
63 - SG 1/1 4 Wire 4 mV/V
64 - SG 1/1 6 Wire 4 mV/V
ELM354x:
259 - SG Full-Bridge 4Wire 2 mV/V
260 - SG Full-Bridge 4Wire 2 mV/V compensated
261 - SG Full-Bridge 4Wire 4 mV/V
262 - SG Full-Bridge 4Wire 4 mV/V compensated
263 - SG Full-Bridge 4Wire 8 mV/V
268 - SG Full-Bridge 4Wire 32 mV/V
291 - SG Full-Bridge 6Wire 2 mV/V
292 - SG Full-Bridge 6Wire 2 mV/V compensated
293 - SG Full-Bridge 6Wire 4 mV/V
294 - SG Full-Bridge 6Wire 4 mV/V compensated
295 - SG Full-Bridge 6Wire 8 mV/V
300 - SG Full-Bridge 6Wire 32 mV/V
323 - SG Half-Bridge 3Wire 2 mV/V
324 - SG Half-Bridge 3Wire 2 mV/V compensated
325 - SG Half-Bridge 3Wire 4 mV/V
326 - SG Half-Bridge 3Wire 4 mV/V compensated
327 - SG Half-Bridge 3Wire 8 mV/V
329 - SG Half-Bridge 3Wire 16 mV/V
355 - SG Half-Bridge 5Wire 2 mV/V
356 - SG Half-Bridge 5Wire 2 mV/V compensated
357 - SG Half-Bridge 5Wire 4 mV/V
358 - SG Half-Bridge 5Wire 4 mV/V compensated
359 - SG Half-Bridge 5Wire 8 mV/V
361 - SG Half-Bridge 5Wire 16 mV/V
388 - SG Quarter-Bridge 2Wire 120R 2 mV/V compensated
390 - SG Quarter-Bridge 2Wire 120R 4 mV/V compensated
391 - SG Quarter-Bridge 2Wire 120R 8 mV/V
396 - SG Quarter-Bridge 2Wire 120R 32 mV/V
420 - SG Quarter-Bridge 3Wire 120R 2 mV/V compensated
422 - SG Quarter-Bridge 3Wire 120R 4 mV/V compensated
423 - SG Quarter-Bridge 3Wire 120R 8 mV/V
428 - SG Quarter-Bridge 3Wire 120R 32 mV/V
452 - SG Quarter-Bridge 2Wire 350R 2 mV/V compensated
454 - SG Quarter-Bridge 2Wire 350R 4 mV/V compensated
455 - SG Quarter-Bridge 2Wire 350R 8 mV/V
460 - SG Quarter-Bridge 2Wire 350R 32 mV/V
484 - SG Quarter-Bridge 3Wire 350R 2 mV/V compensated
486 - SG Quarter-Bridge 3Wire 350R 4 mV/V compensated
487 - SG Quarter-Bridge 3Wire 350R 8 mV/V
492 - SG Quarter-Bridge 3Wire 350R 32 mV/V
516 - SG Quarter-Bridge 2Wire 1k 2 mV/V compensated
518 - SG Quarter-Bridge 2Wire 1k 4 mV/V compensated
519 - SG Quarter-Bridge 2Wire 1k 8 mV/V
524 - SG Quarter-Bridge 2Wire 1k 32 mV/V
548 - SG Quarter-Bridge 3Wire 1k 2 mV/V compensated
550 - SG Quarter-Bridge 3Wire 1k 4 mV/V compensated
551 - SG Quarter-Bridge 3Wire 1k 8 mV/V
556 - SG Quarter-Bridge 3Wire 1k 32 mV/V
UINT16
RW
0x0000 (0dec)


ELM36xx

Commissioning [image] CoE overview [image] ELM36xx
ELM36xx
Additional information
•
0x10F3 Diagnosis History
•
0x60n0 PAI Status Ch.[n+1]
•
0x60n1 PAI Samples Ch.[n+1] (24 Bit)
•
0x60n2 PAI Samples Ch.[n+1] (16 Bit)
•
0x60n5 PAI Timestamp Ch.[n+1]
•
0x60n6 PAI Synchronous Oversampling Ch.[n+1]
•
0x70n0 PAI Control Ch.[n+1]
•
0x80n0 PAI Settings Ch.[n+1]
•
0x80n1 PAI Filter 1 Settings Ch.[n+1]
•
0x80n3 PAI Filter 2 Settings Ch.[n+1]
•
0x80n5 PAI Scaler Settings Ch.[n+1] – not ELM35xx
•
0x80nE PAI User Calibration Ch.[n+1]
•
0x80nF PAI Vendor Calibration Data Ch.[n+1]
•
0x90n0 PAI Internal Data Ch.[n+1]
•
0x90n2 PAI Info Data Ch.[n+1]
•
0x90nF PAI Calibration Dates Ch.[n+1]
•
0xB0n0 PAI TEDS Interface Ch.[n+1]
•
0xF000 Modular device profile
•
0xF008 Code word
•
0xF009 Password Protection
•
0xF010 Module list
•
0xF083 BTN
•
0xF900 PAI Info Data
•
0xF912 Filter info
•
0xFB00 PAI Command


0x10F3 Diagnosis History

Commissioning [image] CoE overview [image] ELM36xx [image] 0x10F3 Diagnosis History
0x10F3 Diagnosis History
Index (hex) | Name | Meaning | Data type | Flags | Default
10F3:0 | Diagnosis History | Max. Subindex | UINT8 | RO | 0x15 (21dec)
10F3:01 | Maximum Messages | Maximum Messages | UINT8 | RO | 0x00 (0dec)
10F3:02 | Newest Message | Newest Message | UINT8 | RO | 0x00 (0dec)
10F3:03 | Newest Acknowledged Message | Subindex of last Acknowledged Message | UINT8 | RW | 0x00 (0dec)
10F3:04 | New Messages Available | True: New Messages Available | BOOLEAN | RO | 0x00 (0dec)
10F3:05 | Flags | Diagnosis message options (see ETG specification) | UINT16 | RW | 0x0000 (0dec)
10F3:06 .10F3:15 | Diagnosis Message 001... Diagnosis Message 016 | Diagnosis Message No. 01...16 | OCTET-STRING[22] | RO | {0}


0x60n0 PAI Status Ch.[n+1]

Commissioning [image] CoE overview [image] ELM36xx [image] 0x60n0 PAI Status Ch.[n+1]
0x60n0 PAI Status Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
60n0:0 | PAI Status Ch.[n+1] |  | UINT8 | RO | 0x0F (15dec)
60n0:01 | No of Samples | Number of valid samples within the PDO samples | UINT8 | RO | 0x00 (0dec)
60n0:09 | Error | TRUE: General error | BOOLEAN | RO | 0x00 (0dec)
60n0:0A | Underrange | TRUE: Measurement event underflow | BOOLEAN | RO | 0x00 (0dec)
60n0:0B | Overrange | TRUE: Measurement event overflow | BOOLEAN | RO | 0x00 (0dec)
60n0:0D | Diag | TRUE: New diagnostic message available | BOOLEAN | RO | 0x00 (0dec)
60n0:0E | TxPDO State | TRUE: data invalid | BOOLEAN | RO | 0x00 (0dec)
60n0:0F | Input cycle counter | Incremented by one when values have changed | BIT2 | RO | 0x00 (0dec)


0x60n1 PAI Samples Ch.[n+1] (24 Bit)

Commissioning [image] CoE overview [image] ELM36xx [image] 0x60n1 PAI Samples Ch.[n+1] (24 Bit)
0x60n1 PAI Samples Ch.[n+1] (24 Bit)
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
ELM3x0x:
Index (hex) | Name | Meaning | Data type | Flags | Default
60n1:0 | PAI Samples Ch.[n+1] |  | UINT8 | RO | 0x64 (100dec)
60n1:01 | Sample | Samples | INT32 | RO | 0x00000000 (0dec)
… | … | … | … | … | …
60n1:64 | Sample | Samples | INT32 | RO | 0x00000000 (0dec)
ELM3x4x:
Index (hex) | Name | Meaning | Data type | Flags | Default
60n1:0 | PAI Samples Ch.[n+1] |  | UINT8 | RO | 0x20 (32dec)
60n1:01 | Sample | Samples | INT32 | RO | 0x00000000 (0dec)
… | … | … | … | … | …
60n1:20 | Sample | Samples | INT32 | RO | 0x00000000 (0dec)


0x60n2 PAI Samples Ch.[n+1] (16 Bit)

Commissioning [image] CoE overview [image] ELM36xx [image] 0x60n2 PAI Samples Ch.[n+1] (16 Bit)
0x60n2 PAI Samples Ch.[n+1] (16 Bit)
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels (not ELM3x4x):
Index (hex) | Name | Meaning | Data type | Flags | Default
60n2:0 | PAI Samples Ch.[n+1] |  | UINT8 | RO | 0x64 (100dec)
60n2:01 | Sample | Samples | INT16 | RO | 0x0000 (0dec)
… | … | … | … | … | …
60n2:64 | Sample | Samples | INT16 | RO | 0x0000 (0dec)


0x60n5 PAI Timestamp Ch.[n+1]

Commissioning [image] CoE overview [image] ELM36xx [image] 0x60n5 PAI Timestamp Ch.[n+1]
0x60n5 PAI Timestamp Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
60n5:0 | PAI Timestamp Ch.[n+1] |  | UINT8 | RO | 0x02 (2dec)
60n5:01 | Low | Timestamp (low) | UINT32 | RO | 0x00000000 (0dec)
60n5:02 | Hi | Timestamp (hi) | UINT32 | RO | 0x00000000 (0dec)


0x60n6 PAI Synchronous Oversampling Ch.[n+1]

Commissioning [image] CoE overview [image] ELM36xx [image] 0x60n6 PAI Synchronous Oversampling Ch.[n+1]
0x60n6 PAI Synchronous Oversampling Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
60n6:0 | PAI Synchronous Oversampling Ch.[n+1] |  | RO | UINT8 | 0x01 (1dec)
60n6:01 | Internal Buffer |  | RO | UINT16 | 0x0000 (0dec)


0x70n0 PAI Control Ch.[n+1]

Commissioning [image] CoE overview [image] ELM36xx [image] 0x70n0 PAI Control Ch.[n+1]
0x70n0 PAI Control Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
70n0:0 | PAI Control Ch.[n+1] |  | UINT8 | RO | 0x02 (2dec)
70n0:01 | Integrator Reset | Restart of the integration with each edge | BOOLEAN | RO | 0x00 (0dec)
70n0:02 | Peak Hold Reset | Start new peak value detection with each edge | BOOLEAN | RO | 0x00 (0dec)


0x80n0 PAI Settings Ch.[n+1]

Commissioning [image] CoE overview [image] ELM36xx [image] 0x80n0 PAI Settings Ch.[n+1]
0x80n0 PAI Settings Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
80n0:0 | PAI Settings Ch.[n+1] |  | UINT8 | RO | 0x41 (65dec)
80n0:01 | Interface | Selection of the measurement configuration: 0 – None 97 - IEPE ±10 V 98 - IEPE ±5 V 99 - IEPE ±2.5 V 100 - IEPE ±1.25 V 101 - IEPE ±640 mV 102 - IEPE ±320 mV 103 - IEPE ±160 mV 104 - IEPE ±80 mV 105 - IEPE ±40 mV 106 - IEPE ±20 mV 107 - IEPE 0..20 V 108 - IEPE 0..10 V | UINT16 | RW | 0x0000 (0dec)
80n0:03 | IEPE AC Coupling | 0 - Off (DC Coupling) 1 - 0.001 Hz 2 - 0.01 Hz 3 - 0.1 Hz 4 - 1 Hz 5 - 10 Hz | UINT16 | RW | 0x0000 (0dec)
80n0:04 | Start Connection Test | Start connection test with rising edge (see section “Broken wire detection/ optional connection diagnosis”) | BOOLEAN | RW | 0x00 (FALSE)
80n0:07 | IEPE Bias Current | 0 - 0 mA 1 - 2 mA 2 - 4 mA | BIT4 | RW | 0x00 (0dec)
80n0:16 | Filter 1 | Options for filter 1: 0 – None 1 - FIR Notch 50 Hz 2 - FIR Notch 60 Hz 3 - FIR LP 100 Hz 4 - FIR LP 1000 Hz 5 - FIR HP 150 Hz 16 - IIR Notch 50 Hz 17 - IIR Notch 60 Hz 18 - IIR Butterw. LP 5th Ord. 1 Hz 19 - IIR Butterw. LP 5th Ord. 25 Hz 20 - IIR Butterw. LP 5th Ord. 100 Hz 21 - IIR Butterw. LP 5th Ord. 250 Hz 22 - IIR Butterw. LP 5th Ord. 1000 Hz 32 - User defined FIR Filter 33 - User defined IIR Filter 34 - User defined Average Filter | UINT16 | RW | 0x0000 (0dec)
80n0:17 | Average Filter 1 No of Samples | Number of samples for user-defined Average Filter 1 | UINT16 | RW | 0x00C8 (200dec)
80n0:18 | Decimation Factor | Factor of the individual sampling rate (min. 1) | UINT16 | RW | 0x0001 (1dec)
80n0:19 | Filter 2 | Options for filter 2: 0 – None 1 - IIR 1 2 - IIR 2 3 - IIR 3 4 - IIR 4 5 - IIR 5 6 - IIR 6 7 - IIR 7 8 - IIR 8 16 - User defined FIR Filter 17 - User defined IIR Filter 18 - User defined Average Filter | UINT16 | RW | 0x0000 (0dec)
80n0:1A | Average Filter 2 No of Samples | Number of samples for user-defined Average Filter 2 | UINT16 | RW | 0x00C8 (200dec)
80n0:1B | True RMS No. of Samples | Number of samples for "True RMS" calculation (min. 1, max. 1000); also see chapter TrueRMS (extended maximum values for ELM36xx) | UINT16 | RW | 0x00C8 (200dec)
80n0:1C | Enable True RMS | Activation of "True RMS" calculation | BOOLEAN | RW | 0x00 (FALSE)
80n0:1D | Enable Frequency Counter | Enable Frequency Counter | BOOLEAN | RW | 0x00 (FALSE)
80n0:2B | Extended Functions | Options for future functions/settings 0 – Disabled ELM35xx: 1 – Load Cell Analysis | UINT16 | RW | 0x0000 (0dec)
80n0:2C | Integrator/Differentiator | Options: 0 – Off 1 – Integrator 1x 2 – Integrator 2x (* 3 – Differentiator 1x 4 – Differentiator 2x (* | UINT16 | RW | 0x0000 (0dec)
80n0:2D | Differentiator Samples Delta | Distance of samples for the differentiation; max. value = 1000; except ELM36xx with max value = 5000 | UINT16 | RW | 0x0001 (1dec)
80n0:2E | Scaler | Scaling (enum): 0 – Extended Range 1 – Linear 2 – Lookup Table 3 – Legacy Range 4 – Lookup Table (additive) Optional: 5 – Extended Functions | UINT16 | RW | 0x0000 (0dec)
80n0:2F | Lookup Table Length | Anzahl Stützstellen der LookUp‑Tabelle | UINT16 | RW | 0x0064 (100dec)
80n0:30 | Low Limiter | Smallest PDO output value | INT32 | RW | 0x80000000 (‑2147483648dec)
80n0:31 | High Limiter | Largest PDO output value | INT32 | RW | 0x7FFFFFFF (2147483647dec)
80n0:32 | Low Range Error | Lowest limit at which the error bit and the error LED are set | INT32 | RW | 0xFF800000 (‑8388608dec)
80n0:33 | High Range Error | Highest limit at which the error bit and the error LED are set | INT32 | RW | 0x007FFFFF (8388607dec)
80n0:34 | Timestamp Correction | Value for correcting StartNextLatchTime (timestamp of the first sample) | INT32 | RW | 0xFFFB6C20 (‑300000dec)
80n0:40 | Filter 1 Type Info | Filter 1 type information | STRING | RW | N/A
80n0:41 | Filter 2 Type Info | Filter 2 type information | STRING | RW | N/A
(* Functionality is only available from FW03


0x80n1 PAI Filter 1 Settings Ch.[n+1]

Commissioning [image] CoE overview [image] ELM36xx [image] 0x80n1 PAI Filter 1 Settings Ch.[n+1]
0x80n1 PAI Filter 1 Settings Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
80n1:0 | PAI Filter 1 Settings Ch.[n+1] |  | UINT8 | RO | 0x28 (40dec)
80n1:01 | Filter Coefficient 1 | Coefficients for filter 1 | INT32 | RO | 0x00000000 (0dec)
… | … | … | … | … | …
80n1:28 | Filter Coefficient 40 | Coefficients for filter 1 | INT32 | RO | 0x00000000 (0dec)


0x80n3 PAI Filter 2 Settings Ch.[n+1]

Commissioning [image] CoE overview [image] ELM36xx [image] 0x80n3 PAI Filter 2 Settings Ch.[n+1]
0x80n3 PAI Filter 2 Settings Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
80n3:0 | PAI Filter 2 Settings Ch.[n+1] |  | UINT8 | RO | 0x28 (40dec)
80n3:01 | Filter Coefficient 1 | Coefficients for filter 2 | INT32 | RO | 0x00000000 (0dec)
… | … | … | … | … | …
80n3:28 | Filter Coefficient 40 | Coefficients for filter 2 | INT32 | RO | 0x00000000 (0dec)


0x80n5 PAI Scaler Settings Ch.[n+1] – not ELM35xx

Commissioning [image] CoE overview [image] ELM36xx [image] 0x80n5 PAI Scaler Settings Ch.[n+1] – not ELM35xx
0x80n5 PAI Scaler Settings Ch.[n+1] – not ELM35xx
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
80n5:0 | PAI Scaler Settings Ch.[n+1] | Scaling values offset/gain or LookUp table with 50 x/y value pairs | UINT8 | RO | 0x64 (100dec)
80n5:01 | Scaler Offset/ Scaler Value 1 | Scaling offset oder LookUp x value 1 | INT32 | RW | 0x00000000 (0dec)
80n5:02 | Scaler-Gain/ Scaler Value 2 | Scaling gain oder LookUp y value 1 | INT32 | RW | 0x00000000 (0dec)
80n5:03 | Scaler Value 3 | LookUp x value 2 | INT32 | RW | 0x00000000 (0dec)
80n5:04 | Scaler Value 4 | LookUp y value 2 | INT32 | RW | 0x00000000 (0dec)
.. | .. | .. | .. | .. | ..
80n5:63 | Scaler Value 99 | LookUp x value 50 | INT32 | RW | 0x00000000 (0dec)
80n5:64 | Scaler Value 100 | LookUp y value 50 | INT32 | RW | 0x00000000 (0dec)


0x80nE PAI User Calibration Ch.[n+1]

Commissioning [image] CoE overview [image] ELM36xx [image] 0x80nE PAI User Calibration Ch.[n+1]
0x80nE PAI User Calibration Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
80nE:0 | PAI User Calibration Data Ch.1 |  | UINT8 | RO | 0x0C (12dec)
80nE:01 | Calibration Date | Date of calibration | OCTET-STRING[4] | RW | -
80nE:02 | Signature | Signature of the calibration values | OCTET-STRING[256] | RW | -
80nE:03 | S0 | Offset | REAL32 | RW | 0x00000000 (0dec)
80nE:04 | S1 | Coefficient for first-order samples (S1 * sample) | REAL32 | RW | 0x3F800000 (1.0dec)
80nE:05 | S2 | Coefficient for second-order samples (S2 * sample²) | REAL32 | RW | 0x00000000 (0.0dec)
80nE:06 | S3 | Coefficient for third-order samples (S3 * sample³) | REAL32 | RW | 0x00000000 (0.0dec)
80nE:07 | T1 | Temperature coefficient for first-order temperature value (T1 * temp) | REAL32 | RW | 0x00000000 (0.0dec)
80nE:08 | T1S1 | Combined coefficient for first-order gain and temperature values (T1S1 * temp * sample) | REAL32 | RW | 0x00000000 (0.0dec)
80nE:09 | T2 | Temperature coefficient for second-order temperature value (T2 * temp²) | REAL32 | RW | 0x00000000 (0.0dec)
80nE:0A | T2S1 | Combined coefficient for second-order gain and temperature values (T2S1 * temp² * sample) | REAL32 | RW | 0x00000000 (0.0dec)
80nE:0B | T3 | Temperature coefficient for third-order temperature value (T3 * temp³) | REAL32 | RW | 0x00000000 (0.0dec)
80nE:0C | T3S1 | Combined coefficient for third-order gain and temperature values (T3S1 * temp³ * sample) | REAL32 | RW | 0x00000000 (0.0dec)


0x80nF PAI Vendor Calibration Data Ch.[n+1]

Commissioning [image] CoE overview [image] ELM36xx [image] 0x80nF PAI Vendor Calibration Data Ch.[n+1]
0x80nF PAI Vendor Calibration Data Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
80nF:0 | PAI Vendor Calibration Data Ch.1 |  | UINT8 | RO | 0x0C (12dec)
80nF:01 | Calibration Date | Date of calibration | OCTET-STRING[4] | RW | -
80nF:02 | Signature | Signature of the calibration values | OCTET-STRING[256] | RW | -
80nF:03 | S0 | Offset | REAL32 | RW | 0x00000000 (0dec)
80nF:04 | S1 | Coefficient for first-order samples (S1 * sample) | REAL32 | RW | 0x3F800000 (1.0dec)
80nF:05 | S2 | Coefficient for second-order samples (S2 * sample²) | REAL32 | RW | 0x00000000 (0.0dec)
80nF:06 | S3 | Coefficient for third-order samples (S3 * sample³) | REAL32 | RW | 0x00000000 (0.0dec)
80nF:07 | T1 | Temperature coefficient for first-order temperature value (T1 * temp) | REAL32 | RW | 0x00000000 (0.0dec)
80nF:08 | T1S1 | Combined coefficient for first-order gain and temperature values (T1S1 * temp * sample) | REAL32 | RW | 0x00000000 (0.0dec)
80nF:09 | T2 | Temperature coefficient for second-order temperature value (T2 * temp²) | REAL32 | RW | 0x00000000 (0.0dec)
80nF:0A | T2S1 | Combined coefficient for second-order gain and temperature values (T2S1 * temp² * sample) | REAL32 | RW | 0x00000000 (0.0dec)
80nF:0B | T3 | Temperature coefficient for third-order temperature value (T3 * temp³) | REAL32 | RW | 0x00000000 (0.0dec)
80nF:0C | T3S1 | Combined coefficient for third-order gain and temperature values (T3S1 * temp³ * sample) | REAL32 | RW | 0x00000000 (0.0dec)


0x90n0 PAI Internal Data Ch.[n+1]

Commissioning [image] CoE overview [image] ELM36xx [image] 0x90n0 PAI Internal Data Ch.[n+1]
0x90n0 PAI Internal Data Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
90n0:0 | PAI Internal Data Ch.[n+1] |  | UINT8 | RO | 0x22 (34dec)
90n0:02 | ADC Raw Value | ADC Raw Value | INT32 | RO | 0x00000000 (0dec)
90n0:03 | Calibration Value | Value after calibration | INT32 | RO | 0x00000000 (0dec)
90n0:04 | Zero Offset Value | Zero offset value | INT32 | RO | 0x00000000 (0dec)
90n0:07 | Actual Negative Peak Hold | Current absolute minimum value | INT32 | RO | 0x00000000 (0dec)
90n0:08 | Actual Positive Peak Hold | Current absolute maximum value | INT32 | RO | 0x00000000 (0dec)
90n0:09 | Previous Negative Peak Hold | Absolute minimum value up to last rising edge of "Peak Hold Reset" | INT32 | RO | 0x00000000 (0dec)
90n0:0A | Previous Positive Peak Hold | Absolute maximum value up to last rising edge of "Peak Hold Reset" | INT32 | RO | 0x00000000 (0dec)
90n0:0B | Filter 1 Value | Value after filter 1 | INT32 | RO | 0x00000000 (0dec)
90n0:0C | Filter 2 Value | Value after filter 2 | INT32 | RO | 0x00000000 (0dec)
90n0:0D | True RMS Value | Value after "True RMS" calculation | INT32 | RO | 0x00000000 (0dec)
90n0:0E | Extended Functions Value | Value after advanced (optional) function | INT32 | RO | 0x00000000 (0dec)
90n0:0F | Integrator/Differentiator Value | Value after integration or differentiation | INT32 | RO | 0x00000000 (0dec)
90n0:10 | Scaler Value | Value after scaling | INT32 | RO | 0x00000000 (0dec)
90n0:11 | Limiter Value | Value after limitation | INT32 | RO | 0x00000000 (0dec)
90n0:20 | DC Bias Voltage | DC bias voltage in AC operation | REAL32 | RO | 0x00000000 (0dec)
90n0:21 | Signal Frequency | Frequency of the input signal | UINT32 | RO | 0x00000000 (0dec)
90n0:22 | Signal Duty Cycle | Duty Cycle of the input signal | UINT8 | RO | 0x00 (0dec)


0x90n2 PAI Info Data Ch.[n+1]

Commissioning [image] CoE overview [image] ELM36xx [image] 0x90n2 PAI Info Data Ch.[n+1]
0x90n2 PAI Info Data Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
90n2:0 | PAI Info Data Ch.[n+1] |  | UINT8 | RO | 0x12 (18dec)
90n2:01 | Effective Sample Rate | Effective Sample Rate | UINT32 | RO | 0x00000000 (0dec)
90n2:02 | Channel Temperature | Temperature of the channel | REAL32 | RO | 0x00000000 (0dec)
90n2:03 | Min. Channel Temperature | Minimal temperature of the channel | REAL32 | RO | 0x00000000 (0dec)
90n2:04 | Max. Channel Temperature | Maximal temperature of the channel | REAL32 | RO | 0x00000000 (0dec)
90n2:05 | Overload Time | Absolute time during overload "Overload" means that the channel is electrically overloaded. This is a non-recommendable condition that may eventually lead to atypical aging or even damage. This condition should be avoided. Its accumulated duration is displayed here informatively. | UINT32 | RO | 0x00000000 (0dec)
90n2:06 | Saturation Time | Absolute time during saturation "Saturation" means that the measuring range of the ADC of the channel is fully utilized, the ADC thus outputs its maximum value and the measured value can no longer be used. "Saturation" is therefore a pre-deregistration, with further signal increase it comes to "overload". The saturation state is not fundamentally harmful, but it indicates an insufficient dimensioning of the measurement channel. Its accumulated response time is displayed here informatively. | UINT32 | RO | 0x00000000 (0dec)
90n2:07 | Overtemperature Time (Channel) | Time of exceeded temperature of the channel | UINT32 | RO | 0x00000000 (0dec)
90n2:11 | Vendor Calibration Counter | Counter of the vendor calibration (related to the selected interface) The counter counts +1 when data has changed and the memory code word is written. Depending on the adjustment method, the counter may therefore count several times. | UINT16 | RO | 0x0000 (0dec)
90n2:12 | User Calibration Counter | Counter of the user calibration (related to the selected interface) The counter counts +1 when data has changed and the memory code word is written. Depending on the adjustment method, the counter may therefore count several times. | UINT16 | RO | 0x0000 (0dec)


0x90nF PAI Calibration Dates Ch.[n+1]

Commissioning [image] CoE overview [image] ELM36xx [image] 0x90nF PAI Calibration Dates Ch.[n+1]
0x90nF PAI Calibration Dates Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels:
Index (hex) | Name | Meaning | Data type | Flags | Default
90nF:0 | PAI Calibration Dates |  | UINT8 | RO | 0xEC (236dec)
90nF:61 | Vendor IEPE ±10 V |  | OCTET-STRING[4] | RO | {0}
90nF:62 | Vendor IEPE ±5 V |  | OCTET-STRING[4] | RO | {0}
90nF:63 | Vendor IEPE ±2.5 V |  | OCTET-STRING[4] | RO | {0}
90nF:64 | Vendor IEPE ±1.25 V |  | OCTET-STRING[4] | RO | {0}
90nF:65 | Vendor IEPE ±640 mV |  | OCTET-STRING[4] | RO | {0}
90nF:66 | Vendor IEPE ±320 mV |  | OCTET-STRING[4] | RO | {0}
90nF:67 | Vendor IEPE ±160 mV |  | OCTET-STRING[4] | RO | {0}
90nF:68 | Vendor IEPE ±80 mV |  | OCTET-STRING[4] | RO | {0}
90nF:69 | Vendor IEPE ±40 mV |  | OCTET-STRING[4] | RO | {0}
90nF:6A | Vendor IEPE ±20 mV |  | OCTET-STRING[4] | RO | {0}
90nF:6B | Vendor IEPE 0..20 V |  | OCTET-STRING[4] | RO | {0}
90nF:E1 | Vendor IEPE 0..10 V |  | OCTET-STRING[4] | RO | {0}
90nF:E2 | User IEPE ±5 V |  | OCTET-STRING[4] | RO | {0}
90nF:E3 | User IEPE ±2.5 V |  | OCTET-STRING[4] | RO | {0}
90nF:E4 | User IEPE ±1.25 V |  | OCTET-STRING[4] | RO | {0}
90nF:E5 | User IEPE ±640 mV |  | OCTET-STRING[4] | RO | {0}
90nF:E6 | User IEPE ±320 mV |  | OCTET-STRING[4] | RO | {0}
90nF:E7 | User IEPE ±160 mV |  | OCTET-STRING[4] | RO | {0}
90nF:E8 | User IEPE ±80 mV |  | OCTET-STRING[4] | RO | {0}
90nF:E9 | User IEPE ±40 mV |  | OCTET-STRING[4] | RO | {0}
90nF:EA | User IEPE ±20 mV |  | OCTET-STRING[4] | RO | {0}
90nF:EB | User IEPE 0..20 V |  | OCTET-STRING[4] | RO | {0}
90nF:EC | User IEPE 0..10 V |  | OCTET-STRING[4] | RO | {0}


0xB0n0 PAI TEDS Interface Ch.[n+1]

Commissioning [image] CoE overview [image] ELM36xx [image] 0xB0n0 PAI TEDS Interface Ch.[n+1]
0xB0n0 PAI TEDS Interface Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels:
Index (hex) | Name | Meaning | Data type | Flags | Default
B0n1:0 | PAI TEDS Interface Ch.1 |  | UINT8 | RO | 0x08 (8dec)
B0n1:01 | Request | Commands to the ELM terminals | OCTET-STRING[4] | RW | {0}
B0n1:02 | Status | CC = status code LL = data length | OCTET-STRING[2] | RO | {0}
B0n1:03 | Family Code | URN (Unique Registration Number | OCTET-STRING[1] | RW | {0}
B0n1:05 | Serial Number |  | OCTET-STRING[6] | RW | {0}
B0n1:07 | CRC |  | OCTET-STRING[1] | RW | {0}
B0n1:08 | TEDS Data | TEDS content | OCTET-STRING[128] | RW | {0}


0xF000 Modular device profile

Commissioning [image] CoE overview [image] ELM36xx [image] 0xF000 Modular device profile
0xF000 Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0004 (4dec)


0xF008 Code word

Commissioning [image] CoE overview [image] ELM36xx [image] 0xF008 Code word
0xF008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word |  | UINT32 | RW | 0x00000000 (0dec)


0xF009 Password Protection

Commissioning [image] CoE overview [image] ELM36xx [image] 0xF009 Password Protection
0xF009 Password Protection
Index (hex) | Name | Meaning | Data type | Flags | Default
F009:0 | Password protection |  | UINT32 | RW | 0x00000000 (0dec)


0xF010 Module list

Commissioning [image] CoE overview [image] ELM36xx [image] 0xF010 Module list
0xF010 Module list
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list |  | UINT8 | RW | n
F010:01 | Subindex 001 |  | UINT32 | RW | 0x0000015E (350dec)
... | ... | ... | ... | ... | ...
F010:n | Subindex n |  | UINT32 | RW | 0x0000015E (350dec)
n = number of existing channels by the terminal


0xF083 BTN

Commissioning [image] CoE overview [image] ELM36xx [image] 0xF083 BTN
0xF083 BTN
Index (hex) | Name | Meaning | Data type | Flags | Default
F083:0 | BTN | Beckhoff Traceability Number | STRING | RO | 00000000
Note: this object exists from revision -0018 (ELM3148 from revision -0017) and the FW from release date >2019/03 only


0xF900 PAI Info Data

Commissioning [image] CoE overview [image] ELM36xx [image] 0xF900 PAI Info Data
0xF900 PAI Info Data
Index (hex) | Name | Meaning | Data type | Flags | Default
F900:0 | PAI Info Data |  | UINT8 | RO | 0x13 (19dec)
F900:01 | CPU Usage | CPU load in [%]* | UINT16 | RO | 0x0000 (0dec)
F900:02 | Device State | Device State Permitted values: 0 – OK 1 – Warm Up | UINT16 | RO | 0x0000 (0dec)
F900:03 | Operating Time | Operating time in [min] | UINT32 | RO | 0x00000000 (0dec)
F900:04 | Overtemperature Time (Device) | Time of overtemperature of the device | UINT32 | RO | 0x00000000 (0dec)
F900:11 | Device Temperature | Measured temperature in the terminal | REAL32 | RO | 0x00000000 (0dec)
F900:12 | Min. Device Temperature | Lowest measured temperature in the terminal | REAL32 | RO | 0x00000000 (0dec)
F900:13 | Max. Device Temperature | Highest measured temperature in the terminal | REAL32 | RO | 0x00000000 (0dec)
*) This value depends of additional enabled features (Filters, True RMS, ...); the more functions of the terminal are in use, the greater is the value. Notice amongst others the „Input cycle counter“ (PAI Status). The CPU load is an informative value with particularly regard to the "Device-specific Diag messages".


0xF912 Filter info

Commissioning [image] CoE overview [image] ELM36xx [image] 0xF912 Filter info
0xF912 Filter info
Index (hex) | Name | Meaning | Data type | Flags | Default
F912:0 | Filter info |  | UINT8 | RO | m
F912:01 | Info header | Basic information for the filter designer | OCTET‑STRING[8] | RO | {0}
F912:02 | Filter 1 | Informations for the filter designer | OCTET‑STRING[30] | RO | {0}
... | ... | ... | ... | ... | ...
F912:m | Filter n | Informations for the filter designer | OCTET‑STRING[30] | RO | {0}
m = (2 · No. of channels) + 1
Note: availability of CoE Objekt “0xF912 Filter info”:
Terminal | since FW version | Revision
ELM360x | 03 | -0017


0xFB00 PAI Command

Commissioning [image] CoE overview [image] ELM36xx [image] 0xFB00 PAI Command
0xFB00 PAI Command
Index (hex) | Name | Meaning | Data type | Flags | Default
FB00:0 | PAI Command |  | UINT8 | RO | 0x03 (3dec)
FB00:01 | Request | Command request The respective functional chapters explain which value is to be entered here. | OCTET-STRING[2] | RW | {0}
FB00:02 | Status | Command status This indicates that the command is still running or has been executed. Functional dependent, see respective sections. Otherwise: 0: Command not existing 1: executed without errors 2,3: executed not successful 100..200: indicates the execution progress (100 = 0% etc.) 255: function is busy, if [100..200] won’t be used as progress display | UINT8 | RO | 0x00 (0dec)
FB00:03 | Response | Command response If the transferred command returns a response, it will be displayed here. Functional dependent, see resprective sections. | OCTET-STRING[6] | RO | {0}


ELM37xx

Commissioning [image] CoE overview [image] ELM37xx
ELM37xx
Additional information
•
0x10F3 Diagnosis History
•
0x60n0 PAI Status Ch.[n+1]
•
0x60n1 PAI Samples Ch.[n+1] (24 Bit)
•
0x60n2 PAI Samples Ch.[n+1] (16 Bit)
•
0x60n3 PAI Samples Ch.[n+1] (24 Bit) – ELM35xx only
•
0x60n5 PAI Timestamp Ch.[n+1]
•
0x60n6 PAI Synchronous Oversampling Ch.[n+1]
•
0x70n0 PAI Control Ch.[n+1]
•
0x70n1 PAI TC Ch.[n+1]
•
0x80n0 PAI Settings Ch.[n+1]
•
0x80n1 PAI Filter 1 Settings Ch.[n+1]
•
0x80n3 PAI Filter 2 Settings Ch.[n+1]
•
0x80n5 PAI Scaler Settings Ch.[n+1] – not ELM35xx
•
0x80nA PAI Extended Settings Ch.[n+1]
•
0x80nE PAI User Calibration Ch.[n+1]
•
0x80nF PAI Vendor Calibration Data Ch.[n+1]
•
0x90n0 PAI Internal Data Ch.[n+1]
•
0x90n2 PAI Info Data Ch.[n+1]
•
0x90nF PAI Calibration Dates Ch.[n+1]
•
0xF000 Modular device profile
•
0xF008 Code word
•
0xF009 Password Protection
•
0xF010 Module list
•
0xF083 BTN
•
0xF900 PAI Info Data
•
0xF912 Filter info
•
0xFB00 PAI Command


0x10F3 Diagnosis History

Commissioning [image] CoE overview [image] ELM37xx [image] 0x10F3 Diagnosis History
0x10F3 Diagnosis History
Index (hex) | Name | Meaning | Data type | Flags | Default
10F3:0 | Diagnosis History | Max. Subindex | UINT8 | RO | 0x15 (21dec)
10F3:01 | Maximum Messages | Maximum Messages | UINT8 | RO | 0x00 (0dec)
10F3:02 | Newest Message | Newest Message | UINT8 | RO | 0x00 (0dec)
10F3:03 | Newest Acknowledged Message | Subindex of last Acknowledged Message | UINT8 | RW | 0x00 (0dec)
10F3:04 | New Messages Available | True: New Messages Available | BOOLEAN | RO | 0x00 (0dec)
10F3:05 | Flags | Diagnosis message options (see ETG specification) | UINT16 | RW | 0x0000 (0dec)
10F3:06 .10F3:15 | Diagnosis Message 001... Diagnosis Message 016 | Diagnosis Message No. 01...16 | OCTET-STRING[22] | RO | {0}


0x60n0 PAI Status Ch.[n+1]

Commissioning [image] CoE overview [image] ELM37xx [image] 0x60n0 PAI Status Ch.[n+1]
0x60n0 PAI Status Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
60n0:0 | PAI Status Ch.[n+1] |  | UINT8 | RO | 0x0F (15dec)
60n0:01 | No of Samples | Number of valid samples within the PDO samples | UINT8 | RO | 0x00 (0dec)
60n0:09 | Error | TRUE: General error | BOOLEAN | RO | 0x00 (0dec)
60n0:0A | Underrange | TRUE: Measurement event underflow | BOOLEAN | RO | 0x00 (0dec)
60n0:0B | Overrange | TRUE: Measurement event overflow | BOOLEAN | RO | 0x00 (0dec)
60n0:0D | Diag | TRUE: New diagnostic message available | BOOLEAN | RO | 0x00 (0dec)
60n0:0E | TxPDO State | TRUE: data invalid | BOOLEAN | RO | 0x00 (0dec)
60n0:0F | Input cycle counter | Incremented by one when values have changed | BIT2 | RO | 0x00 (0dec)


0x60n1 PAI Samples Ch.[n+1] (24 Bit)

Commissioning [image] CoE overview [image] ELM37xx [image] 0x60n1 PAI Samples Ch.[n+1] (24 Bit)
0x60n1 PAI Samples Ch.[n+1] (24 Bit)
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
ELM3x0x:
Index (hex) | Name | Meaning | Data type | Flags | Default
60n1:0 | PAI Samples Ch.[n+1] |  | UINT8 | RO | 0x64 (100dec)
60n1:01 | Sample | Samples | INT32 | RO | 0x00000000 (0dec)
… | … | … | … | … | …
60n1:64 | Sample | Samples | INT32 | RO | 0x00000000 (0dec)
ELM3x4x:
Index (hex) | Name | Meaning | Data type | Flags | Default
60n1:0 | PAI Samples Ch.[n+1] |  | UINT8 | RO | 0x20 (32dec)
60n1:01 | Sample | Samples | INT32 | RO | 0x00000000 (0dec)
… | … | … | … | … | …
60n1:20 | Sample | Samples | INT32 | RO | 0x00000000 (0dec)


0x60n2 PAI Samples Ch.[n+1] (16 Bit)

Commissioning [image] CoE overview [image] ELM37xx [image] 0x60n2 PAI Samples Ch.[n+1] (16 Bit)
0x60n2 PAI Samples Ch.[n+1] (16 Bit)
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels (not ELM3x4x):
Index (hex) | Name | Meaning | Data type | Flags | Default
60n2:0 | PAI Samples Ch.[n+1] |  | UINT8 | RO | 0x64 (100dec)
60n2:01 | Sample | Samples | INT16 | RO | 0x0000 (0dec)
… | … | … | … | … | …
60n2:64 | Sample | Samples | INT16 | RO | 0x0000 (0dec)


0x60n3 PAI Samples Ch.[n+1] (24 Bit) – ELM35xx only

Commissioning [image] CoE overview [image] ELM37xx [image] 0x60n3 PAI Samples Ch.[n+1] (24 Bit) – ELM35xx only
0x60n3 PAI Samples Ch.[n+1] (24 Bit) – ELM35xx only
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
ELM3x0x:
Index (hex) | Name | Meaning | Data type | Flags | Default
60n1:0 | PAI Samples Ch.[n+1] |  | UINT8 | RO | 0x64 (100dec)
60n1:01 | Sample | Samples | INT32 | RO | 0x00000000 (0dec)
… | … | … | … | … | …
60n1:64 | Sample | Samples | INT32 | RO | 0x00000000 (0dec)
ELM3x4x:
Index (hex) | Name | Meaning | Data type | Flags | Default
60n1:0 | PAI Samples Ch.[n+1] |  | UINT8 | RO | 0x20 (32dec)
60n1:01 | Sample | Samples | INT32 | RO | 0x00000000 (0dec)
… | … | … | … | … | …
60n1:20 | Sample | Samples | INT32 | RO | 0x00000000 (0dec)


0x60n5 PAI Timestamp Ch.[n+1]

Commissioning [image] CoE overview [image] ELM37xx [image] 0x60n5 PAI Timestamp Ch.[n+1]
0x60n5 PAI Timestamp Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
60n5:0 | PAI Timestamp Ch.[n+1] |  | UINT8 | RO | 0x02 (2dec)
60n5:01 | Low | Timestamp (low) | UINT32 | RO | 0x00000000 (0dec)
60n5:02 | Hi | Timestamp (hi) | UINT32 | RO | 0x00000000 (0dec)


0x60n6 PAI Synchronous Oversampling Ch.[n+1]

Commissioning [image] CoE overview [image] ELM37xx [image] 0x60n6 PAI Synchronous Oversampling Ch.[n+1]
0x60n6 PAI Synchronous Oversampling Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
60n6:0 | PAI Synchronous Oversampling Ch.[n+1] |  | RO | UINT8 | 0x01 (1dec)
60n6:01 | Internal Buffer |  | RO | UINT16 | 0x0000 (0dec)


0x70n0 PAI Control Ch.[n+1]

Commissioning [image] CoE overview [image] ELM37xx [image] 0x70n0 PAI Control Ch.[n+1]
0x70n0 PAI Control Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
70n0:0 | PAI Control Ch.[n+1] |  | UINT8 | RO | 0x09 (9dec)
70n0:01 | Integrator Reset | Restart of the integration with each edge | BOOLEAN | RO | 0x00 (0dec)
70n0:02 | Peak Hold Reset | Start new peak value detection with each edge | BOOLEAN | RO | 0x00 (0dec)
70n0:09 | Invalidate | Switching off channel external | BOOLEAN | RO | 0x00 (0dec)


0x70n1 PAI TC Ch.[n+1]

Commissioning [image] CoE overview [image] ELM37xx [image] 0x70n1 PAI TC Ch.[n+1]
0x70n1 PAI TC Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
70n1:0 | PAI TC Ch.[n+1] |  | UINT8 | RO | 0x01 (1dec)
70n1:01 | Cold Junction Temperature | Cold Junction Temperature [°C] | REAL32 | RO | 0x00000000 (0dec)


0x80n0 PAI Settings Ch.[n+1]

Commissioning [image] CoE overview [image] ELM37xx [image] 0x80n0 PAI Settings Ch.[n+1]
0x80n0 PAI Settings Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex)
Name
Meaning
Data type
Flags
Default
80n0:0
PAI Settings
Ch.[n+1]
UINT8
RO
0x41 (65dec)
80n0:01
Interface
Selection of the measurement configuration:
0 – None
1 - U ±60 V
2 - U ±10 V
3 - U ±5 V
4 - U ±2.5 V
5 - U ±1.25 V
6 - U ±640 mV
7 - U ±320 mV
8 - U ±160 mV
9 - U ±80 mV
10 - U ±40 mV
11 - U ±20 mV
14 - U 0...10 V
15 - U 0...5 V
17 - I ±20 mA
18 - I 0...20 mA
19 - I 4...20 mA
20 - I 4...20 mA NAMUR
33 - RTD/R 2Wire
34 - RTD/R 3Wire
35 - RTD/R 4Wire
49 - SG 1/4 2Wire 120R
50 - SG 1/4 3Wire 120R
51 - SG 1/4 2Wire 350R
52 - SG 1/4 3Wire 350R
57 - SG 1/2 3Wire 4 mV/V
58 - SG 1/2 5Wire 4 mV/V
59 - SG 1/2 3Wire 2 mV/V
60 - SG 1/2 5Wire 2 mV/V
61 - SG 1/1 4Wire 4 mV/V
62 - SG 1/1 6Wire 4 mV/V
65 - Poti 3Wire
66 - Poti 5Wire
81 - TC CJC
97 - IEPE ±5 V
98 - IEPE ±2.5 V
99 - IEPE ±1.25 V
UINT16
RW
0x0000 (0dec)
80n0:02
Sensor Supply
Sensor supply:
0 - 0.0 V
2 - 1.0 V
3 - 1.5 V
4 - 2.0 V
5 - 2.5 V
6 - 3.0 V
7 - 3.5 V
8 - 4.0 V
9 - 4.5 V
10 - 5.0 V
65535 - External Supply
UINT16
RW
0x0000 (0dec)
80n0:03
IEPE AC Coupling
0 - Off (DC Coupling)
1 - 0.001 Hz
2 - 0.01 Hz
3 - 0.1 Hz
4 - 1 Hz
5 - 10 Hz
UINT16
RW
0x0000 (0dec)
80n0:04
Start Connection Test
Start connection test with rising edge (see section “Broken wire detection/ optional connection diagnosis”)
BOOLEAN
RW
0x00 (FALSE)
80n0:05
Coldjunction Compensation
0 - Intern
1 - None
2 - Extern Processdata
BIT2
RW
0x00 (0dec)
80n0:06
Enable Autorange
Autorange (Enable/ Disable)
BOOLEAN
RW
0x00 (FALSE)
80n0:08
Enable Shunt Calibration
Shunt calibration (Enable/ Disable)
BOOLEAN
RW
0x00 (FALSE)
80n0:13
Wire Resistance Compensation
Wire resistance compensation
REAL32
RW
0x00000000 (0dec)
80n0:14
RTD Element
0 – None
1 - PT100 (-200...850°C)
2 - NI100 (-60...250°C)
3 - PT1000 (-200...850°C)
4 - PT500 (-200...850°C)
5 - PT200 (-200...850°C)
6 - NI1000 (-60...250°C)
7 - NI1000 100°C: 1500Ohm (-30...160°C)
8 - NI120 (-60...320°C)
9 - KT100/110/130/210/230
KTY10/11/13/16/19
(-50...150°C)
10 - KTY81/82-110,120,150 (-50...150°C)
11 - KTY81-121 (-50...150°C)
12 - KTY81-122 (-50...150°C)
13 - KTY81-151 (-50...150°C)
14 - KTY81-152 (-50...150°C)
15 - KTY81/82-210,220,
250 (-50...150°C)
16 - KTY81-221 (-50...150°C)
17 - KTY81-222 (-50...150°C)
18 - KTY81-251 (-50...150°C)
19 - KTY81-252 (-50...150°C)
20 - KTY83-110,120,150
(-50...175°C)
21 - KTY83-121 (-50...175°C)
22 - KTY83-122 (-50...175°C)
23 - KTY83-151 (-50...175°C)
24 - KTY83-152 (-50...175°C)
25 - KTY84-130,150
(-40...300°C)
26 - KTY84-151 (-40...300°C)
27 - KTY21/23-6 (-50...150°C)
28 - KTY1x-5 (-50...150°C)
29 - KTY1x-7 (-50...150°C)
30 - KTY21/23-5 (-50...150°C)
31 - KTY21/23-7 (-50...150°C)
64 - B-Parameter Equation
(8006)
65 - DIN IEC 60751 Equation
(8006)
66 - Steinhart Hart Equation
(8006)
UINT16
RW
0x0000 (0dez)
80n0:15
TC Element
0 – None
1 - K -270...1372°C
2 - J -210...1200°C
3 - L -50...900°C
4 - E -270...1000°C
5 - T -270...400°C
6 - N -270...1300°C
7 - U -50...600°C
8 - B 200...1820°C
9 - R -50...1768°C
10 - S -50...1768°C
11 - C 0...2329°C
13 – D 0...2490°C
14 – G 1000...2300°C
15 – P (PLII) 0...1395°C
16 - Au//Pt 0...1000°C
17 – Pt/Pd 0...1500°C
18 – A-1 0...2500°C
19 – A-2 0...1800°C
20 – A-3 0...1800°C
UINT16
RW
0x0000 (0dez)
80n0:16
Filter 1
Options for filter 1:
0 – None
1 - FIR Notch 50 Hz
2 - FIR Notch 60 Hz
3 - FIR LP 100 Hz
4 - FIR LP 1000 Hz
5 - FIR HP 150 Hz
16 - IIR Notch 50 Hz
17 - IIR Notch 60 Hz
18 - IIR Butterw. LP 5th Ord. 1 Hz
19 - IIR Butterw. LP 5th Ord. 25 Hz
20 - IIR Butterw. LP 5th Ord. 100 Hz
21 - IIR Butterw. LP 5th Ord. 250 Hz
22 - IIR Butterw. LP 5th Ord. 1000 Hz
32 - User defined FIR Filter
33 - User defined IIR Filter
34 - User defined Average Filter
UINT16
RW
0x0000 (0dec)
80n0:17
Average Filter 1 No of Samples
Number of samples for user-defined Average Filter 1
UINT16
RW
0x00C8 (200dec)
80n0:18
Decimation Factor
Factor of the individual sampling rate (min. 1)
UINT16
RW
0x0001 (1dec)
80n0:19
Filter 2
Options for filter 2:
0 – None
1 - IIR 1
2 - IIR 2
3 - IIR 3
4 - IIR 4
5 - IIR 5
6 - IIR 6
7 - IIR 7
8 - IIR 8
16 - User defined FIR Filter
17 - User defined IIR Filter
18 - User defined Average Filter
UINT16
RW
0x0000 (0dec)
80n0:1A
Average Filter 2 No of Samples
Number of samples for user-defined Average Filter 2
UINT16
RW
0x00C8 (200dec)
80n0:1B
True RMS No. of Samples
Number of samples for "True RMS" calculation (min. 1, max. 1000);
also see chapter TrueRMS (extended maximum values for ELM36xx)
UINT16
RW
0x00C8 (200dec)
80n0:1C
Enable True RMS
Activation of "True RMS" calculation
BOOLEAN
RW
0x00 (FALSE)
80n0:1D
Enable Frequency Counter
Enable Frequency Counter
BOOLEAN
RW
0x00 (FALSE)
80n0:1E
Reset Load Cycle Counter
Reset Load Cycle Counter
BOOLEAN
RW
0x00 (FALSE)
80n0:2B
Extended Functions
Options for future functions/settings
0 – Disabled
ELM35xx:
1 – Load Cell Analysis
UINT16
RW
0x0000 (0dec)
80n0:2C
Integrator/Differentiator
Options:
0 – Off
1 – Integrator 1x
2 – Integrator 2x (*
3 – Differentiator 1x
4 – Differentiator 2x (*
UINT16
RW
0x0000 (0dec)
80n0:2D
Differentiator Samples Delta
Distance of samples for the differentiation; max. value = 1000; except ELM36xx with max value = 5000
UINT16
RW
0x0001 (1dec)
80n0:2E
Scaler
Scaling (enum):
0 – Extended Range
1 – Linear
2 – Lookup Table
3 – Legacy Range
4 – Lookup Table (additive)
Optional:
5 – Extended Functions
UINT16
RW
0x0000 (0dec)
80n0:2F
Lookup Table Length
Anzahl Stützstellen der LookUp‑Tabelle
UINT16
RW
0x0064 (100dec)
80n0:32
Low Range Error
Lowest limit at which the error bit and the error LED are set
INT32
RW
0xFF800000
(‑8388608dec)
80n0:33
High Range Error
Highest limit at which the error bit and the error LED are set
INT32
RW
0x007FFFFF
(8388607dec)
80n0:34
Timestamp Correction
Value for correcting StartNextLatchTime (timestamp of the first sample)
INT32
RW
0xFFFB6C20
(‑300000dec)
80n0:35
Low Limiter
Smallest PDO output value
REAL32
RW
0xFF7FFFFD
(-8388611dec)
80n0:36
High Limiter
Largest PDO output value
REAL32
RW
0x7F7FFFFD
(2139095037dec)
80n0:37
Bridge Resistance
Bridge resistance
REAL32
RW
0x43AF0000
(1135542272dec)
80n0:38
Wire Resistance Uv-
Wire resistance Uv–
REAL32
RW
0x00000000 (0dec)
80n0:39
Wire Resistance Uv+
Wire resistance Uv+
REAL32
RW
0x00000000 (0dec)
80n0:3A
Low Load Cycle Limit
Low load cycle limit
REAL32
RW
0x00000000 (0dec)
80n0:3B
High Load Cycle Limit
High load cycle limit
REAL32
RW
0x00000000 (0dec)
80n0:3C
TC CJ Value
Value of the cold junction
REAL32
RW
0x00000000 (0dez)
80n0:40
Filter 1 Type Info
Filter 1 type information
STRING
RW
N/A
80n0:41
Filter 2 Type Info
Filter 2 type information
STRING
RW
N/A
(* Functionality is only available from FW03


0x80n1 PAI Filter 1 Settings Ch.[n+1]

Commissioning [image] CoE overview [image] ELM37xx [image] 0x80n1 PAI Filter 1 Settings Ch.[n+1]
0x80n1 PAI Filter 1 Settings Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
80n1:0 | PAI Filter 1 Settings Ch.[n+1] |  | UINT8 | RO | 0x28 (40dec)
80n1:01 | Filter Coefficient 1 | Coefficients for filter 1 | INT32 | RO | 0x00000000 (0dec)
… | … | … | … | … | …
80n1:28 | Filter Coefficient 40 | Coefficients for filter 1 | INT32 | RO | 0x00000000 (0dec)


0x80n3 PAI Filter 2 Settings Ch.[n+1]

Commissioning [image] CoE overview [image] ELM37xx [image] 0x80n3 PAI Filter 2 Settings Ch.[n+1]
0x80n3 PAI Filter 2 Settings Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
80n3:0 | PAI Filter 2 Settings Ch.[n+1] |  | UINT8 | RO | 0x28 (40dec)
80n3:01 | Filter Coefficient 1 | Coefficients for filter 2 | INT32 | RO | 0x00000000 (0dec)
… | … | … | … | … | …
80n3:28 | Filter Coefficient 40 | Coefficients for filter 2 | INT32 | RO | 0x00000000 (0dec)


0x80n5 PAI Scaler Settings Ch.[n+1] – not ELM35xx

Commissioning [image] CoE overview [image] ELM37xx [image] 0x80n5 PAI Scaler Settings Ch.[n+1] – not ELM35xx
0x80n5 PAI Scaler Settings Ch.[n+1] – not ELM35xx
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
80n5:0 | PAI Scaler Settings Ch.[n+1] | Scaling values offset/gain or LookUp table with 50 x/y value pairs | UINT8 | RO | 0x64 (100dec)
80n5:01 | Scaler Offset/ Scaler Value 1 | Scaling offset oder LookUp x value 1 | INT32 | RW | 0x00000000 (0dec)
80n5:02 | Scaler-Gain/ Scaler Value 2 | Scaling gain oder LookUp y value 1 | INT32 | RW | 0x00000000 (0dec)
80n5:03 | Scaler Value 3 | LookUp x value 2 | INT32 | RW | 0x00000000 (0dec)
80n5:04 | Scaler Value 4 | LookUp y value 2 | INT32 | RW | 0x00000000 (0dec)
.. | .. | .. | .. | .. | ..
80n5:63 | Scaler Value 99 | LookUp x value 50 | INT32 | RW | 0x00000000 (0dec)
80n5:64 | Scaler Value 100 | LookUp y value 50 | INT32 | RW | 0x00000000 (0dec)


0x80nA PAI Extended Settings Ch.[n+1]

Commissioning [image] CoE overview [image] ELM37xx [image] 0x80nA PAI Extended Settings Ch.[n+1]
0x80nA PAI Extended Settings Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
(Special settings for the „Extended Functions“)
Index (hex) | Name | Meaning | Data type | Flags | Default
80nA:0 | PAI Extended Settings Ch.[n+1] | Special settings for the „Extended Functions“ | UINT8 | RO | 0x05 (5dec)
80nA:01 | Sensitivity (Compression) | Sensitivity (mech. compression) | REAL32 | RW | 0x40000000 (1073741824dec)
80nA:02 | Sensitivity (Tension) | Sensitivity (mech. tension) | REAL32 | RW | 0xC0000000 (-1073741824dec)
80nA:03 | Zero Balance | Zero balance | REAL32 | RW | 0x00000000 (0dec)
80nA:04 | Maximum Capacity | Maximum capacity | REAL32 | RW | 0x40A00000 (1084227584dec)
80nA:05 | Gravity of Earth | Gravity of earth | REAL32 | RW | 0x411CE80A (1092413450dec)


0x80nE PAI User Calibration Ch.[n+1]

Commissioning [image] CoE overview [image] ELM37xx [image] 0x80nE PAI User Calibration Ch.[n+1]
0x80nE PAI User Calibration Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
80nE:0 | PAI User Calibration Data Ch.1 |  | UINT8 | RO | 0x0C (12dec)
80nE:01 | Calibration Date | Date of calibration | OCTET-STRING[4] | RW | -
80nE:02 | Signature | Signature of the calibration values | OCTET-STRING[256] | RW | -
80nE:03 | S0 | Offset | REAL32 | RW | 0x00000000 (0dec)
80nE:04 | S1 | Coefficient for first-order samples (S1 * sample) | REAL32 | RW | 0x3F800000 (1.0dec)
80nE:05 | S2 | Coefficient for second-order samples (S2 * sample²) | REAL32 | RW | 0x00000000 (0.0dec)
80nE:06 | S3 | Coefficient for third-order samples (S3 * sample³) | REAL32 | RW | 0x00000000 (0.0dec)
80nE:07 | T1 | Temperature coefficient for first-order temperature value (T1 * temp) | REAL32 | RW | 0x00000000 (0.0dec)
80nE:08 | T1S1 | Combined coefficient for first-order gain and temperature values (T1S1 * temp * sample) | REAL32 | RW | 0x00000000 (0.0dec)
80nE:09 | T2 | Temperature coefficient for second-order temperature value (T2 * temp²) | REAL32 | RW | 0x00000000 (0.0dec)
80nE:0A | T2S1 | Combined coefficient for second-order gain and temperature values (T2S1 * temp² * sample) | REAL32 | RW | 0x00000000 (0.0dec)
80nE:0B | T3 | Temperature coefficient for third-order temperature value (T3 * temp³) | REAL32 | RW | 0x00000000 (0.0dec)
80nE:0C | T3S1 | Combined coefficient for third-order gain and temperature values (T3S1 * temp³ * sample) | REAL32 | RW | 0x00000000 (0.0dec)


0x80nF PAI Vendor Calibration Data Ch.[n+1]

Commissioning [image] CoE overview [image] ELM37xx [image] 0x80nF PAI Vendor Calibration Data Ch.[n+1]
0x80nF PAI Vendor Calibration Data Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
80nF:0 | PAI Vendor Calibration Data Ch.1 |  | UINT8 | RO | 0x0C (12dec)
80nF:01 | Calibration Date | Date of calibration | OCTET-STRING[4] | RW | -
80nF:02 | Signature | Signature of the calibration values | OCTET-STRING[256] | RW | -
80nF:03 | S0 | Offset | REAL32 | RW | 0x00000000 (0dec)
80nF:04 | S1 | Coefficient for first-order samples (S1 * sample) | REAL32 | RW | 0x3F800000 (1.0dec)
80nF:05 | S2 | Coefficient for second-order samples (S2 * sample²) | REAL32 | RW | 0x00000000 (0.0dec)
80nF:06 | S3 | Coefficient for third-order samples (S3 * sample³) | REAL32 | RW | 0x00000000 (0.0dec)
80nF:07 | T1 | Temperature coefficient for first-order temperature value (T1 * temp) | REAL32 | RW | 0x00000000 (0.0dec)
80nF:08 | T1S1 | Combined coefficient for first-order gain and temperature values (T1S1 * temp * sample) | REAL32 | RW | 0x00000000 (0.0dec)
80nF:09 | T2 | Temperature coefficient for second-order temperature value (T2 * temp²) | REAL32 | RW | 0x00000000 (0.0dec)
80nF:0A | T2S1 | Combined coefficient for second-order gain and temperature values (T2S1 * temp² * sample) | REAL32 | RW | 0x00000000 (0.0dec)
80nF:0B | T3 | Temperature coefficient for third-order temperature value (T3 * temp³) | REAL32 | RW | 0x00000000 (0.0dec)
80nF:0C | T3S1 | Combined coefficient for third-order gain and temperature values (T3S1 * temp³ * sample) | REAL32 | RW | 0x00000000 (0.0dec)


0x90n0 PAI Internal Data Ch.[n+1]

Commissioning [image] CoE overview [image] ELM37xx [image] 0x90n0 PAI Internal Data Ch.[n+1]
0x90n0 PAI Internal Data Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
90n0:0 | PAI Internal Data Ch.[n+1] |  | UINT8 | RO | 0x22 (34dec)
90n0:01 | Connector Temperature | Temperature on the connectors | REAL32 | RO | 0x00000000 (0dec)
90n0:02 | ADC Raw Value | ADC Raw Value | INT32 | RO | 0x00000000 (0dec)
90n0:03 | Calibration Value | Value after calibration | INT32 | RO | 0x00000000 (0dec)
90n0:04 | Zero Offset Value | Zero offset value | INT32 | RO | 0x00000000 (0dec)
90n0:05 | Resistor Value | Resistor Value | INT32 | RO | 0x00000000 (0dec)
90n0:06 | TC/RTD Value | TC/RTD Value | INT32 | RO | 0x00000000 (0dec)
90n0:07 | Actual Negative Peak Hold | Current absolute minimum value | INT32 | RO | 0x00000000 (0dec)
90n0:08 | Actual Positive Peak Hold | Current absolute maximum value | INT32 | RO | 0x00000000 (0dec)
90n0:09 | Previous Negative Peak Hold | Absolute minimum value up to last rising edge of "Peak Hold Reset" | INT32 | RO | 0x00000000 (0dec)
90n0:0A | Previous Positive Peak Hold | Absolute maximum value up to last rising edge of "Peak Hold Reset" | INT32 | RO | 0x00000000 (0dec)
90n0:0B | Filter 1 Value | Value after filter 1 | INT32 | RO | 0x00000000 (0dec)
90n0:0C | Filter 2 Value | Value after filter 2 | INT32 | RO | 0x00000000 (0dec)
90n0:0D | True RMS Value | Value after "True RMS" calculation | INT32 | RO | 0x00000000 (0dec)
90n0:0E | Extended Functions Value | Value after advanced (optional) function | INT32 | RO | 0x00000000 (0dec)
90n0:0F | Integrator/Differentiator Value | Value after integration or differentiation | INT32 | RO | 0x00000000 (0dec)
90n0:10 | Scaler Value | Value after scaling | INT32 | RO | 0x00000000 (0dec)
90n0:11 | Limiter Value | Value after limitation | INT32 | RO | 0x00000000 (0dec)
90n0:20 | DC Bias Voltage | DC bias voltage in AC operation | REAL32 | RO | 0x00000000 (0dec)
90n0:21 | Signal Frequency | Frequency of the input signal | UINT32 | RO | 0x00000000 (0dec)
90n0:22 | Signal Duty Cycle | Duty Cycle of the input signal | UINT8 | RO | 0x00 (0dec)


0x90n2 PAI Info Data Ch.[n+1]

Commissioning [image] CoE overview [image] ELM37xx [image] 0x90n2 PAI Info Data Ch.[n+1]
0x90n2 PAI Info Data Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels
Index (hex) | Name | Meaning | Data type | Flags | Default
90n2:0 | PAI Info Data Ch.[n+1] |  | UINT8 | RO | 0x12 (18dec)
90n2:01 | Effective Sample Rate | Effective Sample Rate | UINT32 | RO | 0x00000000 (0dec)
90n2:02 | Channel Temperature | Temperature of the channel | REAL32 | RO | 0x00000000 (0dec)
90n2:03 | Min. Channel Temperature | Minimal temperature of the channel | REAL32 | RO | 0x00000000 (0dec)
90n2:04 | Max. Channel Temperature | Maximal temperature of the channel | REAL32 | RO | 0x00000000 (0dec)
90n2:05 | Overload Time | Absolute time during overload "Overload" means that the channel is electrically overloaded. This is a non-recommendable condition that may eventually lead to atypical aging or even damage. This condition should be avoided. Its accumulated duration is displayed here informatively. | UINT32 | RO | 0x00000000 (0dec)
90n2:06 | Saturation Time | Absolute time during saturation "Saturation" means that the measuring range of the ADC of the channel is fully utilized, the ADC thus outputs its maximum value and the measured value can no longer be used. "Saturation" is therefore a pre-deregistration, with further signal increase it comes to "overload". The saturation state is not fundamentally harmful, but it indicates an insufficient dimensioning of the measurement channel. Its accumulated response time is displayed here informatively. | UINT32 | RO | 0x00000000 (0dec)
90n2:07 | Overtemperature Time (Channel) | Time of exceeded temperature of the channel | UINT32 | RO | 0x00000000 (0dec)
90n2:10 | Load Cycle Counter | Load Cycle Counter | UINT32 | RO | 0x00000000 (0dec)
90n2:11 | Vendor Calibration Counter | Counter of the vendor calibration (related to the selected interface) The counter counts +1 when data has changed and the memory code word is written. Depending on the adjustment method, the counter may therefore count several times. | UINT16 | RO | 0x0000 (0dec)
90n2:12 | User Calibration Counter | Counter of the user calibration (related to the selected interface) The counter counts +1 when data has changed and the memory code word is written. Depending on the adjustment method, the counter may therefore count several times. | UINT16 | RO | 0x0000 (0dec)


0x90nF PAI Calibration Dates Ch.[n+1]

Commissioning [image] CoE overview [image] ELM37xx [image] 0x90nF PAI Calibration Dates Ch.[n+1]
0x90nF PAI Calibration Dates Ch.[n+1]
0 ≤ n ≤ m, n+1 = Channel number, m+1 = max. No. of channels:
Index (hex) | Name | Meaning | Data type | Flags | Default
90nF:0 | PAI Calibration Dates |  | UINT8 | RO | 0xC3 (195dec)
90nF:01 | Vendor U ±60 V |  | OCTET-STRING[4] | RO | {0}
90nF:02 | Vendor U ±10 V |  | OCTET-STRING[4] | RO | {0}
90nF:03 | Vendor U ±5 V |  | OCTET-STRING[4] | RO | {0}
90nF:04 | Vendor U ±2.5 V |  | OCTET-STRING[4] | RO | {0}
90nF:05 | Vendor U ±1.25 V |  | OCTET-STRING[4] | RO | {0}
90nF:06 | Vendor U ±640 mV |  | OCTET-STRING[4] | RO | {0}
90nF:07 | Vendor U ±320 mV |  | OCTET-STRING[4] | RO | {0}
90nF:08 | Vendor U ±160 mV |  | OCTET-STRING[4] | RO | {0}
90nF:09 | Vendor U ±80 mV |  | OCTET-STRING[4] | RO | {0}
90nF:0A | Vendor U ±40 mV |  | OCTET-STRING[4] | RO | {0}
90nF:0B | Vendor U ±20 mV |  | OCTET-STRING[4] | RO | {0}
90nF:0C | Vendor U 0..10 V |  | OCTET-STRING[4] | RO | {0}
90nF:0D | Vendor U 0..5 V |  | OCTET-STRING[4] | RO | {0}
90nF:0E | Vendor I ±20 mA |  | OCTET-STRING[4] | RO | {0}
90nF:0F | Vendor I 0..20 mA |  | OCTET-STRING[4] | RO | {0}
90nF:10 | Vendor I 4..20 mA |  | OCTET-STRING[4] | RO | {0}
90nF:11 | Vendor I 4..20 mA (NAMUR) |  | OCTET-STRING[4] | RO | {0}
90nF:12 | Vendor Poti 3Wire |  | OCTET-STRING[4] | RO | {0}
90nF:13 | Vendor Poti 5Wire |  | OCTET-STRING[4] | RO | {0}
90nF:14 | Vendor TC 80 mV |  | OCTET-STRING[4] | RO | {0}
90nF:15 | Vendor TC CJC |  | OCTET-STRING[4] | RO | {0}
90nF:16 | Vendor IEPE ±10 V |  | OCTET-STRING[4] | RO | {0}
90nF:17 | Vendor IEPE ±5 V |  | OCTET-STRING[4] | RO | {0}
90nF:18 | Vendor IEPE ±2.5 V |  | OCTET-STRING[4] | RO | {0}
90nF:19 | Vendor IEPE 0..20 V |  | OCTET-STRING[4] | RO | {0}
90nF:1A | Vendor IEPE 0..10 V |  | OCTET-STRING[4] | RO | {0}
90nF:1B | Vendor SG Full-Bridge 4Wire 2 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:1C | Vendor SG Full-Bridge 4Wire 4 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:1D | Vendor SG Full-Bridge 4Wire 32 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:1E | Vendor SG Full-Bridge 6Wire 2 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:1F | Vendor SG Full-Bridge 6Wire 4 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:20 | Vendor SG Full-Bridge 6Wire 32 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:21 | Vendor SG Half-Bridge 3Wire 2 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:22 | Vendor SG Half-Bridge 3Wire 16 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:23 | Vendor SG Half-Bridge 5Wire 2 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:24 | Vendor SG Half-Bridge 5Wire 16 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:25 | Vendor SG Quarter-Bridge 2Wire 120R 2 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:26 | Vendor SG Quarter-Bridge 2Wire 120R 4 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:27 | Vendor SG Quarter-Bridge 2Wire 120R 8 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:28 | Vendor SG Quarter-Bridge 2Wire 120R 32 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:29 | Vendor SG Quarter-Bridge 3Wire 120R 2 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:2A | Vendor SG Quarter-Bridge 3Wire 120R 4 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:2B | Vendor SG Quarter-Bridge 3Wire 120R 8 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:2C | Vendor SG Quarter-Bridge 3Wire 120R 32 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:2D | Vendor SG Quarter-Bridge 2Wire 350R 2 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:2E | Vendor SG Quarter-Bridge 2Wire 350R 4 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:2F | Vendor SG Quarter-Bridge 2Wire 350R 8 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:30 | Vendor SG Quarter-Bridge 2Wire 350R 32 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:31 | Vendor SG Quarter-Bridge 3Wire 350R 2 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:32 | Vendor SG Quarter-Bridge 3Wire 350R 4 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:33 | Vendor SG Quarter-Bridge 3Wire 350R 8 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:34 | Vendor SG Quarter-Bridge 3Wire 350R 32 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:35 | Vendor R/RTD 2Wire 5k |  | OCTET-STRING[4] | RO | {0}
90nF:36 | Vendor R/RTD 3Wire 5k |  | OCTET-STRING[4] | RO | {0}
90nF:37 | Vendor R/RTD 4Wire 5k |  | OCTET-STRING[4] | RO | {0}
90nF:38 | Vendor R/RTD 2Wire 2k |  | OCTET-STRING[4] | RO | {0}
90nF:39 | Vendor R/RTD 3Wire 2k |  | OCTET-STRING[4] | RO | {0}
90nF:3A | Vendor R/RTD 4Wire 2k |  | OCTET-STRING[4] | RO | {0}
90nF:3B | Vendor R/RTD 2Wire 500R |  | OCTET-STRING[4] | RO | {0}
90nF:3C | Vendor R/RTD 3Wire 500R |  | OCTET-STRING[4] | RO | {0}
90nF:3D | Vendor R/RTD 4Wire 500R |  | OCTET-STRING[4] | RO | {0}
90nF:3E | Vendor R/RTD 2Wire 200R |  | OCTET-STRING[4] | RO | {0}
90nF:3F | Vendor R/RTD 3Wire 200R |  | OCTET-STRING[4] | RO | {0}
90nF:40 | Vendor R/RTD 4Wire 200R |  | OCTET-STRING[4] | RO | {0}
90nF:41 | Vendor R/RTD 2Wire 50R |  | OCTET-STRING[4] | RO | {0}
90nF:42 | Vendor R/RTD 3Wire 50R |  | OCTET-STRING[4] | RO | {0}
90nF:43 | Vendor R/RTD 4Wire 50R |  | OCTET-STRING[4] | RO | {0}
90nF:81 | User U ±60 V |  | OCTET-STRING[4] | RO | {0}
90nF:82 | User U ±10 V |  | OCTET-STRING[4] | RO | {0}
90nF:83 | User U ±5 V |  | OCTET-STRING[4] | RO | {0}
90nF:84 | User U ±2.5 V |  | OCTET-STRING[4] | RO | {0}
90nF:85 | User U ±1.25 V |  | OCTET-STRING[4] | RO | {0}
90nF:86 | User U ±640 mV |  | OCTET-STRING[4] | RO | {0}
90nF:87 | User U ±320 mV |  | OCTET-STRING[4] | RO | {0}
90nF:88 | User U ±160 mV |  | OCTET-STRING[4] | RO | {0}
90nF:89 | User U ±80 mV |  | OCTET-STRING[4] | RO | {0}
90nF:8A | User U ±40 mV |  | OCTET-STRING[4] | RO | {0}
90nF:8B | User U ±20 mV |  | OCTET-STRING[4] | RO | {0}
90nF:8C | User U 0..10 V |  | OCTET-STRING[4] | RO | {0}
90nF:8D | User U 0..5 V |  | OCTET-STRING[4] | RO | {0}
90nF:8E | User I ±20 mA |  | OCTET-STRING[4] | RO | {0}
90nF:8F | User I 0..20 mA |  | OCTET-STRING[4] | RO | {0}
90nF:90 | User I 4..20 mA |  | OCTET-STRING[4] | RO | {0}
90nF:91 | User I 4..20 mA (NAMUR) |  | OCTET-STRING[4] | RO | {0}
90nF:92 | User Poti 3Wire |  | OCTET-STRING[4] | RO | {0}
90nF:93 | User Poti 5Wire |  | OCTET-STRING[4] | RO | {0}
90nF:94 | User TC 80 mV |  | OCTET-STRING[4] | RO | {0}
90nF:95 | User TC CJC |  | OCTET-STRING[4] | RO | {0}
90nF:96 | User IEPE ±10 V |  | OCTET-STRING[4] | RO | {0}
90nF:97 | User IEPE ±5 V |  | OCTET-STRING[4] | RO | {0}
90nF:98 | User IEPE ±2.5 V |  | OCTET-STRING[4] | RO | {0}
90nF:99 | User IEPE 0..20 V |  | OCTET-STRING[4] | RO | {0}
90nF:9A | User IEPE 0..10 V |  | OCTET-STRING[4] | RO | {0}
90nF:9B | User SG Full-Bridge 4Wire 2 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:9C | User SG Full-Bridge 4Wire 4 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:9D | User SG Full-Bridge 4Wire 32 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:9E | User SG Full-Bridge 6Wire 2 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:9F | User SG Full-Bridge 6Wire 4 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:A0 | User SG Full-Bridge 6Wire 32 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:A1 | User SG Half-Bridge 3Wire 2 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:A2 | User SG Half-Bridge 3Wire 16 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:A3 | User SG Half-Bridge 5Wire 2 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:A4 | User SG Half-Bridge 5Wire 16 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:A5 | User SG Quarter-Bridge 2Wire 120R 2 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:A6 | User SG Quarter-Bridge 2Wire 120R 4 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:A7 | User SG Quarter-Bridge 2Wire 120R 8 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:A8 | User SG Quarter-Bridge 2Wire 120R 32 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:A9 | User SG Quarter-Bridge 3Wire 120R 2 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:AA | User SG Quarter-Bridge 3Wire 120R 4 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:AB | User SG Quarter-Bridge 3Wire 120R 8 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:AC | User SG Quarter-Bridge 3Wire 120R 32 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:AD | User SG Quarter-Bridge 2Wire 350R 2 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:AE | User SG Quarter-Bridge 2Wire 350R 4 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:AF | User SG Quarter-Bridge 2Wire 350R 8 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:B0 | User SG Quarter-Bridge 2Wire 350R 32 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:B1 | User SG Quarter-Bridge 3Wire 350R 2 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:B2 | User SG Quarter-Bridge 3Wire 350R 4 mV/V compensated |  | OCTET-STRING[4] | RO | {0}
90nF:B3 | User SG Quarter-Bridge 3Wire 350R 8 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:B4 | User SG Quarter-Bridge 3Wire 350R 32 mV/V |  | OCTET-STRING[4] | RO | {0}
90nF:B5 | User R/RTD 2Wire 5k |  | OCTET-STRING[4] | RO | {0}
90nF:B6 | User R/RTD 3Wire 5k |  | OCTET-STRING[4] | RO | {0}
90nF:B7 | User R/RTD 4Wire 5k |  | OCTET-STRING[4] | RO | {0}
90nF:B8 | User R/RTD 2Wire 2k |  | OCTET-STRING[4] | RO | {0}
90nF:B9 | User R/RTD 3Wire 2k |  | OCTET-STRING[4] | RO | {0}
90nF:BA | User R/RTD 4Wire 2k |  | OCTET-STRING[4] | RO | {0}
90nF:BB | User R/RTD 2Wire 500R |  | OCTET-STRING[4] | RO | {0}
90nF:BC | User R/RTD 3Wire 500R |  | OCTET-STRING[4] | RO | {0}
90nF:BD | User R/RTD 4Wire 500R |  | OCTET-STRING[4] | RO | {0}
90nF:BE | User R/RTD 2Wire 200R |  | OCTET-STRING[4] | RO | {0}
90nF:BF | User R/RTD 3Wire 200R |  | OCTET-STRING[4] | RO | {0}
90nF:C0 | User R/RTD 4Wire 200R |  | OCTET-STRING[4] | RO | {0}
90nF:C1 | User R/RTD 2Wire 50R |  | OCTET-STRING[4] | RO | {0}
90nF:C2 | User R/RTD 3Wire 50R |  | OCTET-STRING[4] | RO | {0}
90nF:C3 | User R/RTD 4Wire 50R |  | OCTET-STRING[4] | RO | {0}


0xF000 Modular device profile

Commissioning [image] CoE overview [image] ELM37xx [image] 0xF000 Modular device profile
0xF000 Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0004 (4dec)


0xF008 Code word

Commissioning [image] CoE overview [image] ELM37xx [image] 0xF008 Code word
0xF008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word |  | UINT32 | RW | 0x00000000 (0dec)


0xF009 Password Protection

Commissioning [image] CoE overview [image] ELM37xx [image] 0xF009 Password Protection
0xF009 Password Protection
Index (hex) | Name | Meaning | Data type | Flags | Default
F009:0 | Password protection |  | UINT32 | RW | 0x00000000 (0dec)


0xF010 Module list

Commissioning [image] CoE overview [image] ELM37xx [image] 0xF010 Module list
0xF010 Module list
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list |  | UINT8 | RW | n
F010:01 | Subindex 001 |  | UINT32 | RW | 0x0000015E (350dec)
... | ... | ... | ... | ... | ...
F010:n | Subindex n |  | UINT32 | RW | 0x0000015E (350dec)
n = number of existing channels by the terminal


0xF083 BTN

Commissioning [image] CoE overview [image] ELM37xx [image] 0xF083 BTN
0xF083 BTN
Index (hex) | Name | Meaning | Data type | Flags | Default
F083:0 | BTN | Beckhoff Traceability Number | STRING | RO | 00000000
Note: this object exists from revision -0018 (ELM3148 from revision -0017) and the FW from release date >2019/03 only


0xF900 PAI Info Data

Commissioning [image] CoE overview [image] ELM37xx [image] 0xF900 PAI Info Data
0xF900 PAI Info Data
Index (hex) | Name | Meaning | Data type | Flags | Default
F900:0 | PAI Info Data |  | UINT8 | RO | 0x13 (19dec)
F900:01 | CPU Usage | CPU load in [%]* | UINT16 | RO | 0x0000 (0dec)
F900:02 | Device State | Device State Permitted values: 0 – OK 1 – Warm Up | UINT16 | RO | 0x0000 (0dec)
F900:03 | Operating Time | Operating time in [min] | UINT32 | RO | 0x00000000 (0dec)
F900:04 | Overtemperature Time (Device) | Time of overtemperature of the device | UINT32 | RO | 0x00000000 (0dec)
F900:11 | Device Temperature | Measured temperature in the terminal | REAL32 | RO | 0x00000000 (0dec)
F900:12 | Min. Device Temperature | Lowest measured temperature in the terminal | REAL32 | RO | 0x00000000 (0dec)
F900:13 | Max. Device Temperature | Highest measured temperature in the terminal | REAL32 | RO | 0x00000000 (0dec)
*) This value depends of additional enabled features (Filters, True RMS, ...); the more functions of the terminal are in use, the greater is the value. Notice amongst others the „Input cycle counter“ (PAI Status). The CPU load is an informative value with particularly regard to the "Device-specific Diag messages".


0xF912 Filter info

Commissioning [image] CoE overview [image] ELM37xx [image] 0xF912 Filter info
0xF912 Filter info
Index (hex) | Name | Meaning | Data type | Flags | Default
F912:0 | Filter info |  | UINT8 | RO | m
F912:01 | Info header | Basic information for the filter designer | OCTET‑STRING[8] | RO | {0}
F912:02 | Filter 1 | Informations for the filter designer | OCTET‑STRING[30] | RO | {0}
... | ... | ... | ... | ... | ...
F912:m | Filter n | Informations for the filter designer | OCTET‑STRING[30] | RO | {0}
m = (2 · No. of channels) + 1
Note: availability of CoE Objekt “0xF912 Filter info”:
Terminal | since FW version | Revision
ELM370x | 01 | -0016


0xFB00 PAI Command

Commissioning [image] CoE overview [image] ELM37xx [image] 0xFB00 PAI Command
0xFB00 PAI Command
Index (hex) | Name | Meaning | Data type | Flags | Default
FB00:0 | PAI Command |  | UINT8 | RO | 0x03 (3dec)
FB00:01 | Request | Command request The respective functional chapters explain which value is to be entered here. | OCTET-STRING[2] | RW | {0}
FB00:02 | Status | Command status This indicates that the command is still running or has been executed. Functional dependent, see respective sections. Otherwise: 0: Command not existing 1: executed without errors 2,3: executed not successful 100..200: indicates the execution progress (100 = 0% etc.) 255: function is busy, if [100..200] won’t be used as progress display | UINT8 | RO | 0x00 (0dec)
FB00:03 | Response | Command response If the transferred command returns a response, it will be displayed here. Functional dependent, see resprective sections. | OCTET-STRING[6] | RO | {0}


Sample programs

Commissioning [image] Sample programs
Sample programs
Using the sample programs
This document contains sample applications of our products for certain areas of application. The application notes provided here are based on typical features of our products and only serve as examples. The notes contained in this document explicitly do not refer to specific applications. The customer is therefore responsible for assessing and deciding whether the product is suitable for a particular application. We accept no responsibility for the completeness and correctness of the source code contained in this document. We reserve the right to modify the content of this document at any time and accept no responsibility for errors and missing information.
Preparations for starting the sample programs (tnzip file / TwinCAT 3)
▪
Click on the download button to save the Zip archive locally on your hard disk, then unzip the *.tnzip archive file in a temporary folder.
Opening the *. tnzip archive
▪
Select the .tnzip file (sample program).
▪
A further selection window opens. Select the destination directory for storing the project.
▪
For a description of the general PLC commissioning procedure and starting the program please refer to the terminal documentation or the EtherCAT system documentation.
▪
The EtherCAT device of the example should usually be declared your present system. After selection of the EtherCAT device in the “Solutionexplorer” select the “Adapter” tab and click on “Search...”:
Search of the existing HW configuration for the EtherCAT configuration of the example
▪
Checking NetId: the “EtherCAT” tab of the EtherCAT device shows the configured NetId: .
The first 4 numbers have to be identical with the project NetId of the target system. The project NetId can be viewed within the TwinCAT environment above, where a pull down menu can be opened to choose a target system (by clicking right in the text field). The number blocks are placed in brackets there next to each computer name of a target system.
▪
Modify the NetId: By right clicking on “EtherCAT device” within the solution explorer a context menu opens where “Change NetId...” have to be selected. The first four numbers of the NetId of the target computer have to be entered; the both last values are 4.1 usually.
Example:
–
NetId of project: myComputer (123.45.67.89.1.1)
–
Entry via „Change NetId...“: 123.45.67.89.4.1
Preparation to start the sample program (tpzip file/ TwinCAT 3)
▪
After clicking the Download button, save the zip file locally on your hard disk, and unzip the *.tpzip -archive file into a temporary working folder.
▪
Create a new TwinCAT project as described in section:
TwinCAT Quickstart, TwinCAT 3, Startup
▪
Open the context menu of "PLC" within the "Solutionexplorer" and select "Add Existing Item..."
▪
Select the beforehand unpacked .tpzip file (sample program).
Additional information
•
Sample program 1 and 2 (offset/gain)
•
Sample program 3 (write lookup table)
•
Sample program 4 (generate LookUp table)
•
Sample program 5 (write filter coefficients)
•
Sample program 6 (interlacing of measured values)
•
Sample program 7 (general decimation in the PLC)
•
Sample program 8 (diagnosis messages)
•
Sample program 9 (measuring range combination)
•
Sample program 10 (reading and writing TEDS data)
•
Sample program 11 (FB for real time diagnosis)
•
Sample program 12 (scripts for generation and transformation of filter coefficients)
•
Sample program 13 (R/W signature of calibration)


Sample program 1 and 2 (offset/gain)

Commissioning [image] Sample programs [image] Sample program 1 and 2 (offset/gain)
Sample program 1 and 2 (offset/gain)
Download TwinCAT 3 project:
Program description
1.
Calculating of an Offset correction value by the amplitude of an input alternating voltage (with DC content respectively) and step by step entry of that value via CoE access into the terminal until a minimal deviation to zero of the measured value (“wOFFSET_MIN_VAL_REF”) is reached.
2.
(If 1. executed:) Calculation of a Gain value and step by step entry of that value via CoE access into the terminal until “nPRESET_MAX_VAL” as for the measured value is reached.
Variable declaration sample programs 1 and 2
PROGRAM MAIN
VAR_INPUT
// Use an external Switch to start justify Offset/Gain
bEnable AT%I* :BOOL;
PAI_Sample AT%I* :DINT; // Variable link to terminal input Ch.1
END_VAR
VAR
// "Main" State controlling Offset/Gain adjusting:
nMainCal_State :BYTE:=0;
// ===============================================
// For CoE Object 0x8005 access:
fb_coe_write :FB_EcCoESdoWrite;
// Enter your Net-Id here:
userNetId :T_AmsNetId := '191.168.1.1.4.1';
// Enter terminals adress here:
userSlaveAddr :UINT := 1003;
wCoEIndexScaler :WORD := 16#8005;
bySubIndScalGain :BYTE := 16#02;
bySubIndScalOffs :BYTE := 16#01;
nADSErrId :UDINT; // Copy of ADS-Error ID
// ===============================================
// Variables for calculation
fb_get_min_max :FB_GET_MIN_MAX;
// Variables used for offset scaling:
nSTATE_SCALE_OFFSET :INT := 0;
bStartScaleOffset :BOOL := FALSE;
bScaleOffsetDone :BOOL := FALSE;
fOffsetDeviationVal :REAL;
fScalerOffset_COE :LREAL := 0;
wOFFSET_MIN_VAL_REF :WORD := 2000; // Deviation tolerance
// Variables used for gain scaling:
nSTATE_SCALE_GAIN :INT := 0;
bStartScaleGain :BOOL := FALSE;
bScaleGainDone :BOOL := FALSE;
fScalerGain_COE :REAL := 1;
nPRESET_MAX_VAL :DINT := 3000000; // Target amplitude value
nMaxAmplVal :DINT;
// ===============================================
// Variables for intermediate results
nValue :DINT; // Used for Offset (adding)
fValue :REAL; // Used for Gain (multiply)
END_VAR
Execution part:
// Example program 1 and 2 program code:
// =====================================
IF bEnable AND (nMainCal_State = 0) THEN // Poll Switch
nMainCal_State := 10;
END_IF
CASE nMainCal_State OF // Main-State Procedure
10:
bStartScaleOffset:=TRUE; // Start with Offset scaling
nMainCal_State := nMainCal_State + 1; // next state
11:
IF bScaleOffsetDone THEN
bStartScaleGain := TRUE; // Continue with gain scaling
nMainCal_State := nMainCal_State + 1;
END_IF
12:
IF bScaleGainDone THEN
nMainCal_State := nMainCal_State + 1; // all done
END_IF
13:
IF NOT bEnable THEN
nMainCal_State :=0; // Initalization for next start by user
END_IF
END_CASE
// ----- Offset scaling -----
IF bStartScaleOffset THEN
CASE nSTATE_SCALE_OFFSET OF
0:
bScaleOffsetDone := FALSE; // Initialization of confirmation flag
nSTATE_SCALE_OFFSET := nSTATE_SCALE_OFFSET + 1;
1:
fb_get_min_max(nInputValue:=PAI_Sample); // Get min/max Values by current Sample value
IF fb_get_min_max.bRESULT THEN // Wait if Limit-Values are valid
fb_coe_write(bExecute := FALSE); // Prepare CoE access
nSTATE_SCALE_OFFSET := nSTATE_SCALE_OFFSET + 1; // Min/Max Values valid - go to next state
END_IF
2:
// Calculate current offset deviation
fOffsetDeviationVal :=
LREAL_TO_REAL(ABS(fb_get_min_max.nMinVal)
- ((ABS(fb_get_min_max.nMaxVal)
+ ABS(fb_get_min_max.nMinVal))/2));
// Offset deviation check:
IF ABS(fOffsetDeviationVal) < wOFFSET_MIN_VAL_REF THEN
// Deviation in acceptable range - offset scaling done
bScaleOffsetDone := TRUE;
bStartScaleOffset := FALSE;
nSTATE_SCALE_OFFSET := 0;
ELSE
// Calculate new offset value (consider pre-assigned value)
nValue := LREAL_TO_DINT(fScalerOffset_COE + fOffsetDeviationVal);
// ..proceed zero-point shift: write value into CoE Object
fb_coe_write(
sNetId:= userNetId,
nSlaveAddr:= userSlaveAddr,
nSubIndex:= bySubIndScalOffs,
nIndex:= wCoEIndexScaler,
pSrcBuf:= ADR(nValue), // Offset-Value (CoE 0x8005:01)
cbBufLen:= SIZEOF(nValue),
bExecute:= TRUE,
tTimeout:= T#1S,
bBusy=> ,
bError=> ,
nErrId=> );
nSTATE_SCALE_OFFSET := nSTATE_SCALE_OFFSET + 1;
END_IF
3:
fb_coe_write();
IF fb_coe_write.bError THEN
nSTATE_SCALE_OFFSET := 100;
ELSE
IF NOT fb_coe_write.bBusy THEN
fScalerOffset_COE := DINT_TO_LREAL(nValue);
nSTATE_SCALE_OFFSET := 0;
END_IF
END_IF
100:
// Copy Error ID for interpretation:
nADSErrId := fb_coe_write.nErrId;
END_CASE
END_IF
// ----- Justify gain: write calculated value in CoE - Object 0x8005 -----
IF bStartScaleGain THEN
CASE nSTATE_SCALE_GAIN OF
0:
bScaleGainDone := FALSE; // Initialization of confirmation flag
nSTATE_SCALE_GAIN := nSTATE_SCALE_GAIN + 1;
1:
// Get min/max Values by current Sample value:
fb_get_min_max(nInputValue:=PAI_Sample);
IF fb_get_min_max.bRESULT THEN // Wait if Limit-Values are valid
fb_coe_write(bExecute := FALSE); // Prepare CoE access
nSTATE_SCALE_GAIN := nSTATE_SCALE_GAIN + 1; // Min/Max Values valid - go to next state
END_IF
2:
// Get current amplitude for calculating the gain value:
nMaxAmplVal := MAX(ABS(fb_get_min_max.nMaxVal), ABS(fb_get_min_max.nMinVal));
// Avoid division by zero:
IF nMaxAmplVal = 0 THEN
nSTATE_SCALE_GAIN := 100;
ELSE
// Calculate Gain:
fValue := DINT_TO_REAL(nPRESET_MAX_VAL)/DINT_TO_REAL(nMaxAmplVal) * fScalerGain_COE;
// Shift gain value by 16 Bit left and convert to DINT:
nValue := REAL_TO_DINT(fValue * 65536);
// Write to CoE Index:
fb_coe_write(
sNetId:= userNetId,
nSlaveAddr:= userSlaveAddr,
nSubIndex:= bySubIndScalGain,
nIndex:= wCoEIndexScaler,
pSrcBuf:= ADR(nValue), // Gain-Value (CoE 0x8005:02)
cbBufLen:= SIZEOF(nValue),
bExecute:= TRUE,
tTimeout:= T#1S,
bBusy=> ,
bError=> ,
nErrId=> );
nSTATE_SCALE_GAIN := nSTATE_SCALE_GAIN + 1;
END_IF
3:
fb_coe_write();
IF fb_coe_write.bError THEN
nSTATE_SCALE_GAIN := 100;
ELSE
IF NOT fb_coe_write.bBusy THEN
fScalerGain_COE := fValue;
bStartScaleGain := FALSE; // gain scaling done
bScaleGainDone := TRUE;
nSTATE_SCALE_GAIN := 0; // Set initial state
END_IF
END_IF
100:
// Copy Error ID for interpretation:
nADSErrId := fb_coe_write.nErrId;
END_CASE
END_IF
Additional information
•
Function block FB_GET_MIN_MAX


Function block FB_GET_MIN_MAX

Commissioning [image] Sample programs [image] Sample program 1 and 2 (offset/gain) [image] Function block FB_GET_MIN_MAX
Function block FB_GET_MIN_MAX
Declaration part:
FUNCTION_BLOCK FB_GET_MIN_MAX
VAR CONSTANT
// Counter initialization dependent by
// lowest input frequency 1/(2*f*cyclTime)
// used during offset adjust
CMMcnt :UINT := 200;
END_VAR
VAR_INPUT
bInit :BOOL := TRUE;
nInputValue :DINT;END_VAR
VAR_OUTPUT
bRESULT :BOOL;
nMaxVal :DINT :=0;
nMinVal :DINT :=0;
END_VAR
VAR
nMaxValCnt :UINT;
nMinValCnt :UINT;
bValidMinVal :BOOL;
bValidMaxVal :BOOL;
END_VAR
Execution part:
IF bInit THEN
nMaxValCnt :=CMMcnt;
nMinValCnt :=CMMcnt;
nMaxVal := 0;
nMinVal := 0;
bInit := FALSE;
END_IF
// Assertions: new min/max values exists:
bValidMaxVal := TRUE;
bValidMinVal := TRUE;
// Filter min/max values
IF nMaxVal < nInputValue THEN
bValidMaxVal := FALSE;
nMaxVal := nInputValue; // Max value was found
END_IF
IF nMinVal > nInputValue THEN
bValidMinVal := FALSE;
nMinVal := nInputValue; // Min value was found
END_IF
// Count down, if no new value come in:
IF bValidMaxVal AND nMaxValCnt > 0 THEN
nMaxValCnt := nMaxValCnt - 1;
END_IF
// Count down, if no new value come in:
IF bValidMinVal AND nMinValCnt > 0 THEN
nMinValCnt := nMinValCnt - 1;
END_IF
IF ((nMaxValCnt = 0) AND (nMinValCnt = 0)) THEN
// Consequence: min/max determined
bInit := TRUE; // Prepare next call
bRESULT := TRUE; // Sign valid results
ELSE
bRESULT := FALSE; // Sign still invalid results
END_IF


Sample program 3 (write lookup table)

Commissioning [image] Sample programs [image] Sample program 3 (write lookup table)
Sample program 3 (write lookup table)
Download TwinCAT 3 project:
Program description
Transmission of LookUp table interpolation values for mapping of an equation f(x) = x3 via CoE into the terminal.
Variable declaration sample program 3
PROGRAM MAIN
VAR
//LookUp-Table (LUT) generated by: MBE * x³
aLUT:ARRAY[0..99] OF DINT :=
[
-7812500,-7812500,-7493593,-6894382,
-7174765,-6051169,-6855859,-5279674,-6536953,-4576709,
-6218125,-3939087,-5899218,-3363620,-5580390,-2847120,
-5261484,-2386402,-4942578,-1978275,-4623750,-1619555,
-4304843,-1307052,-3985937,-1037580,-3667109,-807951,
-3348203,-614978,-3029375,-455472,-2710468,-326248,
-2391562,-224117,-2072734,-145892,-1753828,-88385,
-1434921,-48409,-1116093,-22776,-797187,-8300,
-478281,-1792,-159453,-66,159453,66,
478281,1792,797187,8300,1116093,22776,
1434921,48409,1753828,88385,2072734,145892,
2391562,224117,2710468,326248,3029375,455472,
3348203,614978,3667109,807951,3985937,1037580,
4304843,1307052,4623750,1619555,4942578,1978275,
5261484,2386402,5580390,2847120,5899218,3363620,
6218125,3939087,6536953,4576709,6855859,5279674,
7174765,6051169,7493593,6894382,7812500,7812500
];
// For CoE 0x8000 and 0x8005 - write values:
// ===============================================
wCoEIndexScaler :WORD := 16#8005; // CoE Index
wState :BYTE := 0; // Write status
fb_coe_writeEx :FB_EcCoESdoWriteEx; // Function Block for writing in CoE
userNetId :T_AmsNetId := '172.128.1.1.5.1'; // Have to be entered
userSlaveAddr :UINT := 1003; // Have to be entered
bWriteLUT2CoE :BOOL:=FALSE; // Sign for start writing
bError :BOOL:=FALSE; // Sign for any error
END_VAR
Remarks:
▪
The variable "startWrite" (BOOL) is also declared in sample program 4.
▪
The variable 'userNetId' must include the EtherCAT net ID of the device. It can be viewed in the "EtherCAT" tab under "Device (EtherCAT)".
▪
The variable "userSlaveAddr" must contain the EtherCAT address of the terminal.
Sample program for transferring the LookUp table:
Execution part:
// Example program 3:
// ###### Write Lookup-Table in CoE Objekt 0x8005: #######
IF bWriteLUT2CoE THEN
CASE wState OF
0:
fb_coe_writeEx(bExecute := FALSE);// Prepare CoE-Access
wState := wState + 1;// Next state
1:
// Write 100 X/Y LookUp-Table entries
fb_coe_writeEx(
sNetId:= userNetId,
nSlaveAddr:= userSlaveAddr,
nSubIndex:= 1,
nIndex:= wCoEIndexScaler,
pSrcBuf:= ADR(aLUT),
cbBufLen:= SIZEOF(aLUT),
bCompleteAccess:= TRUE,
bExecute:= TRUE
);
wState := wState + 1; // Next state
2:
// Proceed with writing to CoE
fb_coe_writeEx();
IF NOT fb_coe_writeEx.bBusy THEN
wState := 0;// Done
bWriteLUT2CoE := FALSE;
bError := fb_coe_writeEx.bError; // See nErrId if TRUE
END_IF
END_CASE
END_IF
A simple variable query, e.g. via button linked with bEnable, can be used to initiate the transfer. The variable declaration must contain
VAR_INPUT
bEnable AT%I* :BOOL;
END_VAR
and the following program lines:
IF bEnable AND NOT startWrite THEN
bWriteLUT2CoE := TRUE;
END_IF


Sample program 4 (generate LookUp table)

Commissioning [image] Sample programs [image] Sample program 4 (generate LookUp table)
Sample program 4 (generate LookUp table)
Download TwinCAT 3 project:
Program description / function:
Inclusion of LookUp table interpolation values from a terminal input signal to a field variable (and optional subsequent transfer of the LookUp table interpolation values via CoE access to the terminal using sample program 3).
It is envisaged to use a ramp generator with a trigger input, whose level, in conjunction with an input of a digital input terminal (e.g. EL1002) sets the variable "bStartRecord" to TRUE via a link (e.g. push button connected to +24 V). This allows recording of the values to be synchronized with the ramp input voltage. Alternatively, an output terminal can be used (e.g. EL2002), whose output controls the trigger input and whose output is then set to TRUE via the TwinCAT development environment ("bStartRecord" would then have to be declared as AT%Q* and linked to a terminal output).
Variable declaration sample program 4
// Variablendeklaration for example program 4
PROGRAM MAIN
VAR CONSTANT
nEndX : BYTE := 50; // Number of support values
END_VAR
VAR
nPAISampleIn AT%I* : DINT; // PDO PAISamples
bStartRecord AT%I* : BOOL; // +Electrical junction to trigger ramp
bGetMinMax : BOOL := FALSE;
bRecordLUT : BOOL := FALSE;
r_trigStartRecord : R_TRIG;
nX : BYTE := 0;
aValues : ARRAY[0..nEndX-1] OF DINT;
nYstepValue : DINT;
tp_timer : TP;
ton_timer : TON;
nMinValue : DINT := 7812500;
nMaxValue : DINT := -7812500;
nYvalue : DINT;
tRepeatTimerValue : TIME := T#51MS;
aLUT : ARRAY[0..99] OF DINT;
END_VAR
Execution part:
// Example program 4:
// ################# Recording of 50 sample points: #################
// a) Determination of min./max. values (corresponding to the value range of the sensor)
tp_timer(IN:=bGetMinMax, PT:=T#2.51S); // Periodic duration of ramp (+reserve)
IF tp_timer.Q THEN
nMinValue := MIN(nPAISampleIn, nMinValue);
nMaxValue := MAX(nPAISampleIn, nMaxValue);
END_IF
// b) Recording of values: Start
r_trigStartRecord(CLK:=bStartRecord);
IF r_trigStartRecord.Q THEN
nX := 0;
memset(ADR(aLUT), 0 , 100);
bRecordLUT := TRUE;
END_IF
ton_timer();
IF bRecordLUT OR ton_timer.Q THEN
bRecordLUT := FALSE;
ton_timer(IN:=FALSE);
IF(nX < nEndX) THEN
// b.1) Record of values:
aValues[nX] := nPAISampleIn;
nX := nX + 1;
ton_timer(IN:=TRUE, PT:=tRepeatTimerValue); // T=2,5s/49 = 51ms
ELSE
// b.2) Recording end:
// Create linearized values:
nYstepValue := (nMaxValue - nMinValue) / nEndX; // Y steps
nYvalue := aValues[0]; // Common start value of the LUT
FOR nX:=0 TO nEndX DO
// Create LUT (X = actual values, Y = target values):
aLUT[nX*2] := aValues[nX]; // X value
aLUT[nX*2+1] := nYvalue; // Y value
// next Y value of the LUT (make a "straight"):
nYvalue := nYvalue + nYstepValue; // f(x) = b+x
END_FOR
END_IF
END_IF


Sample program 5 (write filter coefficients)

Commissioning [image] Sample programs [image] Sample program 5 (write filter coefficients)
Sample program 5 (write filter coefficients)
Download TwinCAT 3 project:
Program description
Transmission of exemplary filter coefficients via CoE access into the terminal.
General settings
•
The function block "FB_EcCoESdoWrite" requires the "Tc2_EtherCAT" library
•
<AmsNetID> must show the local device EtherCAT NetID in inverted commas (e.g. '168.57.1.1.5.1')
•
<DeviceEtherCATAddress> must show the local device EtherCAT address of the EL3751 terminal (e.g. 1007)
Variable declaration sample program 5
PROGRAM MAIN
// Variable declaration example program 5
VAR CONSTANT
NumOfFilterCoeff :BYTE:=40;
END_VAR
VAR
// Function block of library "Tc2_EtherCAT" for CoE Object access:
fb_coe_write :FB_EcCoESdoWrite;
userNetId :T_AmsNetId := '???';
userSlaveAddr :UINT := ???;
// Writing PLC state for coefficients transfer (Set to 0 for start)
wState :BYTE:=255;
index :BYTE:=1; // Start index for coefficients transfer
wCoEIndexUserFilterCoeffizents :WORD:=16#8001;
aFilterCoeffs:ARRAY[0..NumOfFilterCoeff] OF LREAL :=
[
// Example filter coefficients FIR band pass: 3600..3900 Hz
// Usage: "User defined FIR Filter" (32)
0.03663651655662163,
0.04299467480848277,
-0.007880289104928245,
0.0664029021294729,
-0.0729038234874446,
-0.00005849791174519834,
0.05628409460964408,
-0.0525134329294473,
0.026329003448584205,
0.00027114381194760643,
-0.03677629552114248,
0.06743018479714939,
-0.0560894442193289,
0.0009722394088121363,
0.05676876756757213,
-0.07775650809213645,
0.05330627422911416,
0.0009941073749156226,
-0.055674804078696793,
0.07874009379691002,
-0.055674804078696793,
0.0009941073749156226,
0.05330627422911416,
-0.07775650809213645,
0.05676876756757213,
0.0009722394088121363,
-0.0560894442193289,
0.06743018479714939,
-0.03677629552114248,
0.00027114381194760643,
0.026329003448584205,
-0.0525134329294473,
0.05628409460964408,
-0.00005849791174519834,
-0.0729038234874446,
0.0664029021294729,
-0.007880289104928245,
0.04299467480848277,
0.03663651655662163,
0
];
nValue :DINT; // Temporary variable
END_VAR
Execution part:
// Example program 5:
// writes filter coefficients of
// "User defined FIR Filter" (32)
// incl. example coefficients for band pass
// Note: writing possible, if CoE Object
// PAI Settings Ch.1 (0x8000:16) has value 32 or 33 set, only!
// (32 = User defined FIR Filter / 33 = User defined IIR Filter)
// ===============================================================
CASE wState OF
0:
fb_coe_write(bExecute := FALSE);// Prepare CoE access
wState := wState + 1;// Go to next state
1:
//nValue := REAL_TO_DINT(DINT_TO_REAL(aFilterCoeffs[index]) *16384);
nValue := LREAL_TO_DINT(aFilterCoeffs[index] * 1073741824); // Bit-shift factor: 2^30
// Write filter coefficients (max. 40 entries)
fb_coe_write(
sNetId:= userNetId,
nSlaveAddr:= userSlaveAddr,
nSubIndex:= index,
nIndex:= wCoEIndexUserFilterCoeffizents,
pSrcBuf:= ADR(nValue),
cbBufLen:= SIZEOF(nValue),
bExecute:= TRUE,
tTimeout:= T#1S
);
wState := wState + 1; // Go to next state
2:
// Execute writing to CoE
fb_coe_write();
IF fb_coe_write.bError THEN
wState := 100; // Error case
ELSE
IF NOT fb_coe_write.bBusy THEN
index := index + 1;
IF index <= (NumOfFilterCoeff) THEN
fb_coe_write(bExecute := FALSE);// Prepare the next CoE access
wState := 1;// Write next value
ELSE
wState := 255;// Done
END_IF
END_IF
END_IF
100:
; // Error handling
255:
; // Go on..
END_CASE


Sample program 6 (interlacing of measured values)

Commissioning [image] Sample programs [image] Sample program 6 (interlacing of measured values)
Sample program 6 (interlacing of measured values)
Program description / function
In some use cases a particularly fine temporal resolution of the signal is desired, e.g. so that many measuring points are available for an FFT. Two ways to do this are shown below:
▪
Use of an analog input module with the correspondingly high sampling rate, e.g. 20 ksps.
▪
Use of two analog input modules with half the sampling rate, i.e. 10 ksps, and so-called interlacing of measured values; the result is likewise a 20 ksps sampling of the signal.
The second way is described in this sample: Use of two EL3751 EtherCAT Terminals, each with a maximum sampling rate of 10 kSps (and thus a conversion time of 100 µs in this case, cf. chapter "Temporal aspects of the analog/digital conversion"). Due to their parallel connection, both terminals are fed the same signal simultaneously and are configured by Distributed Clocks in such a way that they sample not at the same time, but offset by half the conversion time (in this case: 50 µs). If the two measured data streams are now combined alternately in the controller, i.e. "interlaced", the result is a net measured data stream of 20 ksps.
Process of interlacing the input data
The following configuration is used for this purpose:
Configuration and setup for sample program 6: Doubling of the sample rate with 2 x EL3751
The sample is also available with corresponding adaptations for other EL3xxx/ELM3xxx terminals or boxes. There may then be different oversampling factors, shift times, etc. The optionally existing task with 50 µs in sample 6a may then also not be usable.
So that the input values can be successively combined to form a total value, a corresponding shift time is necessary for each channel/terminal; in this sample 50 µs for the second terminal. This is set in the "Advanced settings" for Distributed Clocks ("DC" tab) for the second terminal:
Setting the DC shift time for terminal 2
Some notes and restrictions
▪
This principle can be implemented with two (as described above) or more terminals; the limit is the shift time fineness of 1 µs.
▪
The terminals used must support Distributed Clocks. Oversampling is helpful, but not necessary. The sampling methods simultaneous vs. multiplex must be considered; see corresponding documentation with the question: "when the channels sample their values in relation to Distributed Clocks".
▪
Although this approach doubles the sampling rate of the signal under observation, the frequency response and attenuation specified in the technical data for the terminal still apply! It is therefore not possible to read signals that are twice as fast with twice the sampling rate. Sample: the EL3751 with a sampling rate of 10 ksps can meaningfully (alias-free) read signals up to half the sampling rate = 5 kHz. This limit remains even with multiple parallel sampling! The attenuation of -3 dB at 3 kHz given as an example also applies to the interlaced sum signal.
▪
Only one EtherCAT terminal can be functionally time-shifted as a whole by Distributed Clocks shift time, not the individual channel of a terminal. The shift then affects all the channels of a terminal. Therefore, for the given principle, two or more terminals/boxes must always be used; the interlacing of two channels of the same terminal/box is not possible.
▪
The specified measurement uncertainty must be observed: the unavoidably different real measurement uncertainty and thus the amplitude difference between the two terminals or their channels used on the same signal can become visible as a noise component after interlacing. Therefore, terminals should be used for this principle that exhibit a much smaller measurement uncertainty than is necessary for the application. It is expressly recommended to carry out an explicit user calibration of at least the offset of the two electrically interconnected channels in order to minimize this effect.
▪
Terminals with the same HW/FW version should be used.
Sample program
This setting, like the base time and the task cycle time, is already configured in the sample program:
Download TwinCAT 3 project / sample program 6a:
In the following section, the simplest form of input value interlacing in Structured Text is initially shown with oversampling = 1 for each input value: each of two elements of a field variable receives a value from a terminal. The variable can be used for further processing and is shown here in the TwinCAT ScopeView. In the EL3751 the programming instructions are assigned to a 100 µs task:
Variable declaration sample program 6a
PROGRAM MAIN
VAR
nSamples_1 AT%I* :DINT; // EL3751 input with no added shift time
nSamples_2 AT%I* :DINT; // EL3751 input with -50 µs added shift time
aCollectedResult :ARRAY[0..1] OF DINT;
END_VAR
Execution part:
// Example program 6a:
// 100 µs task
// ============================================================
aCollectedResult[0] := nSamples_1; // Put 1st Value of sequence into array
// Pattern: 1.1.1.1...
aCollectedResult[1] := nSamples_2; // Put n-th Value of sequence into array (2nd here)
// Pattern: .2.2.2.2...
// ============================================================
// Result pattern: 12121212... (--> see scope view dots)
For an input signal with sine 5 kHz and 2.5 V amplitude, for example, the TwinCAT ScopeView provides the following results:
Oversampling 20 ksps with 2 x EL3751 with input signals (below) and result signal (top)
The upper diagram shows the total signal and the two input signals (nSample_1, nSample_2), with a time shift of 50 µs relative to each other, within 18 s in compressed form. The total input signal (nCollectedResult) indicates the interlacing of the two input signals.
The following diagram (enhanced through highlighting) shows how the input signals (nSample_1, nSample_2) contribute to the structure of the total input signal:
Oversampling 20 ksps with 2 x EL3751 shows input value 1 and input value 2 alternately for a result value
Under certain conditions, both inputs can be combined into a single variable in a correspondingly fast task. For this purpose the sample program contains an additional task with 50 µs cycle time, which is required for representing the input signals in the SopeView and contains a variable (nCollected) to which both inputs are assigned alternately:
// 50 µs task
// ============================================================
// Junction of the two inputs
nCollected := SEL(nToggle, MAIN.nSamples_1_, MAIN.nSamples_2_);
nToggle := NOT nToggle;
The input variables required for the ScopeView are read in this task from the 100 µs task, so that the individual values can be represented at 50 µs intervals.
Variant with 2 x oversampling 10 = oversampling 20
If, for example, an oversampling factor of 10 is used for both input terminals, a field variable is used for the total measured value. A simple loop can be used for interlacing the input values, which reads the values sequentially into a field variable for the resulting result variable:
Variable declaration sample program 6b
PROGRAM MAIN
VAR
aSamples_1 AT%I* :ARRAY[0..9] OF DINT; // EL3751 input with no added shift time
aSamples_2 AT%I* :ARRAY[0..9] OF DINT; // EL3751 input with -50 µs added shift time
aCollectedResult :ARRAY[0..19] OF DINT;
// ===================================================
nPos :BYTE;
END_VAR
Execution part:
// Example program 6b:
// 1 ms task
// ============================================================
FOR nPos := 0 TO 9 DO
// Put 1st Value of sequence into array:
aCollectedResult[2*nPos] := aSamples_1[nPos];
// Put n-th value of sequence into array (2nd here):
aCollectedResult[2*nPos+1] := aSamples_2[nPos];
END_FOR
Download TwinCAT 3 project / sample program 6b:
Sample program 6b returns the same result, except that the total input signal is only available in the form of a field variable with 20 elements.


Sample program 7 (general decimation in the PLC)

Commissioning [image] Sample programs [image] Sample program 7 (general decimation in the PLC)
Sample program 7 (general decimation in the PLC)
The EL3751 or ELM3xxx can only decimate their basic sampling rate fmax by integer multiples, see chapter "Decimation". To realize any other sampling rates (ftarget < fmax) for a channel, you can proceed as follows, for example:
▪
Operate the terminal/channel at the maximum sampling rate and transfer the data to the controller (PLC) via EtherCAT/oversampling
▪
In the PLC/C++, on the time axis, convert to the desired sampling rate, e.g. by linear interpolation based on the timestamp for each input value (sample). Since the EL3751/ELM3xxx units provide time-equidistant samples based on distributed clocks, this is easily possible.
For example, a sinusoidal signal decimated with 50/44.1 = 1/0.882 can be represented as follows:
–
Green: corresponds to original analog signal (input), approx. 432 Hz
–
Blue (O): corresponds to sampling of the EL3751/ELM3xxx with fmax of 10,000 sps; a sampling interval of 100 µs
–
Red (X): corresponds to signal converted by PLC to 8820 sps (factor 0.882) and thus a time interval of approx. 113.37.. µs
▪
Note: The term "decimation" is applied both to the calculation in the terminal (see chapter "Decimation") and to the conversion in the PLC program. The following refers to the conversion in the PLC.
▪
Since the time interval of the desired sampling after decimation in the PLC is usually no longer an integer (finite) number, value/time pairs are used for representation in the PLC/Scope, i.e. an X time value is assigned to each Y value. Such value/time pairs can easily be displayed with TwinCAT ScopeView in XY mode. See also infosys.beckhoff.com:
TwinCAT3 → TExxxx | TC3 Engineering → TE13xx | TC3 ScopeView → Configuration → XY‑Graph
▪
The conversion also has consequences for further processing in PLC/C/ADS:
–
A PLC/EtherCAT/TwinCAT system tends to be set up such that a constant number of samples is processed per cycle. Usually this is now no longer the case: a different number of samples has to be processed from cycle to cycle (specified by the program variable nResultNoOfSamples).
–
While a time stamp per signal value has so far remained relatively insignificant, the method of conversion of the decimation process used here, however, means that the respective timestamp per signal value must be taken into account in an elementary manner.
▪
The non-constant number of samples is not visible in the TwinCAT XY Scope because some values are sporadically drawn twice, and this should be taken into account; it may be advisable to use an intermediate buffer for further processing.
▪
For orientation of the currently valid number of samples per task cycle, the program provides the variable nResultNoOfSamples. It indicates which values in the array variable contain valid values in a task cycle (indicates the field number - 1).
The following sample program, which also contains the XY representation in the TwinCAT Scope, serves as a guide. Due to the above-mentioned problem relating to the non-constant number of valid samples, the program returns the array pair aVarDecResult_TS and aVarDecResult for the Scope with the same number of elements as for the input value aSamples_1 (value = nOVS). If there are fewer values in a task run, the last value is simply entered repeatedly (similar to "sample & hold"). The ScopeView was configured as follows for the recording:
Property |  | Value
ScopeNodeProperties | ViewDetauilLevel | ExtendedXYOnly
 | Record time | 00:00:00:05
ChartXYNodeProperties | Default Display Width | 0,00:00:00,050:000
 | Max Data Points | 200000
XYChannelNodeProperties | Marks | On
 | Mark Size | 5
 | Mark Color | (other than line color)
For an illustrative representation, the ScopeView recording was started first and then the program, which limits the decimated values to one second:
IF nOVS_CycleCount = 1000000000 THEN
;
bEnable := FALSE;// Stop after 1s just for recording
ELSE
...
This line can, of course, be commented out for further adjustments:
//bEnable := FALSE;// Stop after 1s just for recording
Notes:
▪
the target sampling rate ftarget should be close to the sample rate fmax, so that it is possible to evaluate a time interval between two decimated values. The desired decimation may require further parameters such as task cycle time, oversampling factor etc. to be adjusted both in the configuration and as variable initialization in the sample program (see figure "Process of variable decimation of the sample program", which illustrates the functionality of the program code).
▪
Basically, the conversion process in this sample program causes distortions in the result in relation to the original signal shape when decimating with fractional rational factors (see signal curve). In concrete terms, deviations from the original signal curve only occur in those sections where the time derivative value (the slope) is not constant. For example, input values of a sine signal in the non-linear sections are distorted by the interpolation performed in the program:
In the frequency spectrum, for example by a calculation with 20 Hz sinus signal, sampled with 500 sps and decimated to 441 sps, this is illustrated as follows:
▪
If no low-pass filtering corresponding to ftarget is performed on the data stream, aliasing effects will occur! It is therefore advisable to perform low-pass filtering in the PLC, e.g. with the TC3 Controller Toolbox or the TC3 Filter Library, before the conversion/decimation is performed. Suitable filters can easily be created with the TE1310 FilterDesigner. For more information, see www.beckhoff.com:
Automation → TwinCAT 3 → TE1xxx | TC3 Engineering → TE1310 | TC3 Filter Designer
Alternatively, the filters available in the EL3751/ELM3xxx can, of course, be set to the suitable low-pass frequency; the TwinCAT Filter Designer is also helpful for this.
▪
Entries of decimation factors within the program (nDecimationValue) should have a value > 1. The program code supports down sampling only.
E.g.: If a terminal such as ELM3602-0002 (2-channel IEPE evaluation) provides a data stream with oversampling of 50 ksps at 100 µs cycle time, this sample code can decimate to 44.1 ksps. In the sample program, the cycle ticks in the task configuration should be changed from 5 to 1 and the corresponding program variable nTaskCycle_ns from 500000 to 100000. See the following image section of ScopeView XY:
Decimation from 20 µs (left) to 22.675.. µs (right) with ELM3602
The decimation factor is given by entering the value "50/44.1" for nDecimationValue in the sample. If this sample is used for the EL3751 with 500 µs cycle time and 5x oversampling, the sampling interval of 100 µs, which originates from the EL3751, is converted to approx. 113.378.. µs. This sample is designed accordingly.
The decimation in the program is freely selectable and must be configured with an oversampling factor and a task cycle time. The variable nOVS must contain the same oversampling factor as set in the process data configuration.
Download sample program 7:
▪
Configuration: IPC + EK1100 + EL3751 + EL9011:
▪
Configuration: IPC + EK1100 + ELM3602‑0002 + EL9011:
General information
The time at which the EtherCAT frames are passed to the terminal is subject to fluctuations, referred to as EtherCAT frame jitter. If these fluctuations are large in relation to the cycle time, it is possible that data is fetched late from the terminal, and dropouts/duplications may occur in the scope display. Such effects can be diagnosed with TwinCAT EtherCAT diagnostics. In the sample program for the ELM3602, the variable nEqualTimeStampsCnt is available for this kind of verification. The variable is incremented if such a failure occurs. It can be remedied by changing the DC ShiftTime of the terminal; see the EtherCAT system documentation.
Declaration
// THIS CODE IS ONLY AN EXAMPLE - YOU HAVE TO CHECK APTITUDE FOR YOUR APPLICATION
PROGRAM MAIN
VAR CONSTANT
// User decimation factor e.g. 50 to 44.1 kSps:
nDecimationValue :LREAL := 50/44.1; // 50/20;
nOVS :BYTE := 5; // Oversampling factor
nTaskCycle_ns :UDINT := 500000; // PlcTask configured cycle time in ns
nOVSTimeInterval_ns :UDINT := LREAL_TO_UDINT(nTaskCycle_ns/nOVS); // OVS interval
nDecTimeInterval_ns :LREAL := nDecimationValue * nOVSTimeInterval_ns; // Decimation interval
END_VAR
VAR
aSamples_1 AT%I* :ARRAY[0..nOVS-1] OF DINT; // Link to the terminal PDO
aOVS_SampleSets :ARRAY[0..(2*nOVS)-1] OF DINT; // 2 OVS sample sets
nVarDecResult :DINT; // The calculated interpolated value
tVarDecResult :LREAL; // Decimation timestamp
aVarDecResult :ARRAY[0..nOVS-1] OF DINT; // Decimation result values
aVarDecResult_TS :ARRAY[0..nOVS-1] OF LREAL; // Decimation result timestamps
nResultNoOfSamples :BYTE; // This is for the user for further processing
nDivVar :INT; // Value for selection of the target input element
tDecVar_InTaskCycle :LREAL:=0; // Time span for all decimation timestamps within a task cycle
i :BYTE:=0; // Common loop counter
nDX :LREAL; // X-Difference: target input element to decimation element
nDY :DINT; // Y-Difference: two values for interpolation
sVal :LREAL; // Slope for calculation of new value
bEnable :BOOL:=FALSE; // Start/Stop conversion to decimation values
nOVS_CycleCount :ULINT := 0; // Time value for every OVS sample
// Values for testing
bTEST_VALUES_ENABLED :BOOL := FALSE; // No input value needed, if TRUE
nPhi :LREAL := 1.4; // Start angle for sinus simulation
// For visualization only:
aOVS_Samples :ARRAY[0..nOVS-1] OF DINT; // 2 OVS sample sets (value)
aOVS_Samples_TS :ARRAY[0..nOVS-1] OF ULINT; // 2 OVS sample sets (timestamp)
END_VAR
Program
// 500 µs Task
FOR i:= 0 TO nOVS-1 DO
// Shift OVS set to left and update on right:
aOVS_SampleSets[i] := aOVS_SampleSets[i+nOVS]; // Transfer "samples set" to the left side
IF bTEST_VALUES_ENABLED THEN
// Simulate values:
aOVS_SampleSets[i+nOVS] := LREAL_TO_DINT(1000000 * SIN(nPhi));
nPhi := nPhi + 0.01;//0.003141592653;
ELSE
// Fill current new samples set on right:
aOVS_SampleSets[i+nOVS] := aSamples_1[i];
END_IF
END_FOR
IF bEnable THEN
nResultNoOfSamples := 0; // Use for further processing
FOR i := 0 TO nOVS-1 DO
nDivVar := TRUNC_INT(tDecVar_InTaskCycle/nOVSTimeInterval_ns);
// Check, if new value is in grid
IF (nDivVar = i) THEN
nResultNoOfSamples := nResultNoOfSamples + 1;
// Calc slope by the left and right element values (dy/dx):
nDY := aOVS_SampleSets[i+1] - aOVS_SampleSets[i];
sVal := DINT_TO_LREAL(nDY)/nOVSTimeInterval_ns;
// Get the time (difference) from the left side element start to the desired time point:
nDX := tDecVar_InTaskCycle
- TRUNC_INT(tDecVar_InTaskCycle/nOVSTimeInterval_ns)
* UDINT_TO_LREAL(nOVSTimeInterval_ns);
// Calc timestamp
tVarDecResult := nDX + ULINT_TO_LREAL(nOVS_CycleCount);
// Calc new value:
nVarDecResult :=
LREAL_TO_DINT(DINT_TO_LREAL(aOVS_SampleSets[i]) + sVal * nDX);
// next decimation time step
tDecVar_InTaskCycle := tDecVar_InTaskCycle + nDecTimeInterval_ns;
tDecVar_InTaskCycle := tDecVar_InTaskCycle
- INT_TO_UDINT(TRUNC_INT(tDecVar_InTaskCycle/nTaskCycle_ns))
* nTaskCycle_ns;
END_IF
// Fill timestamp and new value allocated to the field element of its timestamp
aVarDecResult_TS[i] := tVarDecResult;
aVarDecResult[i] := nVarDecResult;
// For visualization of the original input:
aOVS_Samples[i] := aOVS_SampleSets[i];
aOVS_Samples_TS[i] := nOVS_CycleCount;
// Count the task cycle timestamp
nOVS_CycleCount := nOVS_CycleCount + nOVSTimeInterval_ns;
END_FOR
END_IF
IF nOVS_CycleCount = 1000000000 THEN
bEnable := FALSE;// Stop after 1s just for recording
IF NOT bEnable THEN
bEnable := TRUE; // OVS‑Samples transferred complete into both array sets
END_IF
END_IF


Sample program 8 (diagnosis messages)

Commissioning [image] Sample programs [image] Sample program 8 (diagnosis messages)
Sample program 8 (diagnosis messages)
Download TwinCAT 3 project:
Program description
This sample program reads several CoE Objects of the terminal and yet 0x10F3 „Diagnosis History“ that contains user specific diagnosis data:
Diagnosis message No.01...16 (0x10F3:06...0x10F3:15). Format of a message (consider little endian):
[dddd cccc ffff mmmm tttttttttttttttt pppp(i) kk(i)]
dddd = DiagCode: z.B. (00 E0): 0xE000 standard Beckhoff Message
cccc = ProductCode (21 50): 0x5021 = Code for ELM
ffff = Flags, amongst others indication of the number (i) of parameters (pppp kk) to be given.
E.g. (02 00) = 0x0002; bit 4 is set, when not in DC operation
mmmm = Message ID – respective text can be found here: basic principles of diag messages
tttttttttttttttt = TimeStamp
pppp(i) = Datatype of the parameters, e.g. (05 00) = 0x0005 for datatype UINT8
kk(i) = parameter value
e.g. 2 x UINT8 parameters as indicated by ffff (Flags), with values 0x3C and 0x89
= “05003C050089“
Preparation to start the sample program (tpzip file/ TwinCAT 3)
▪
After clicking the Download button, save the zip file locally on your hard disk, and unzip the *.tpzip -archive file into a temporary working folder.
▪
Create a new TwinCAT project as described in section:
TwinCAT Quickstart, TwinCAT 3, Startup
▪
Open the context menu of "PLC" within the "Solutionexplorer" and select "Add Existing Item..."
▪
Select the beforehand unpacked .tpzip file (sample program).
The further procedure is described in section TwinCAT Quickstart, TwinCAT 3, Starting the controller.


Sample program 9 (measuring range combination)

Commissioning [image] Sample programs [image] Sample program 9 (measuring range combination)
Sample program 9 (measuring range combination)
In some applications it can be of interest to measure a value with very fine resolution in a small range, but still detect high deflections. If it is an AC/DC signal that has to be resolved around 0, the following approach can be used: Two inputs of an ELM module are electrically connected to simultaneously measure the signal, but with different measuring ranges.
Principle of combining two measuring channels with FSV1 and FSV2
The dynamic range of a typical 24-bit voltage or current measurement range with the absolute PDO end value of 223 (bit 24 is sign) is 20 · log(223) ≈ 138.5 dB (without consideration of measurement uncertainties). Now it is possible to connect two (or more) inputs of a measuring system of the same measurement type with different measurement range end values (FSV1, FSV2, FSVn) in parallel to increase the dynamic range. The measured input value is then logged with two measuring ranges FSV1 and FSV2 through combination of two inputs. If FSV2 < FSV1 is selected and thus a lower resolution of FSV2 than FSV1, the low resolution of FSV2 is available if the magnitude of the measured input value is <= FSV2, and the measured input value can also be acquired for the larger range up to <= FSV1.
Note: The general definition is used to calculate the dynamic range:
Dynamic range = largest measured value / smallest unit
For output in dB accordingly with 20 · log(FSV / ResolutionFSV). In this sample, using a combination of FSV1 and FSV2, the calculation is as follows:
Dynamic range = 20 · log(FSV1 / ResolutionFSV2).
The following sample program is based on a parallel connection of two input channels of the ELM3602-0002:
Possible structure for the "Measurement range combination" sample program
Program description / function
The FSV1 of channel 1 is selected as ± 5 V, the FSV2 of channel 2 as ±80 mV. The program takes the measured input value from either channel 1 or channel 2 for a common variable depending on the magnitude of the unsigned amount of the measured input value: Initially, the limit value of 107% of the FSV2 (8388607) is verified.
In the CoE object directory, the following settings should be applied in the in the PAI settings objects, according to the variables nFSV_HI and nFSV_LO:
0x8000:01 → ±5 V
0x8010:01→ ±80 mV
Scaling for both channels: "Extended Range"; no filters active (corresponds to the default setting of the terminal).
Variables declaration:
PROGRAM MAIN
VAR CONSTANT
nFSV_PDO : REAL := 7812500;
nMAX_PDO : REAL := 8388607;
nEXT_F : REAL := nMAX_PDO/nFSV_PDO;
nFSV_HI : REAL := 5; // V
nFSV_LO : REAL := 0.08; // V
nStep_HI : REAL := nFSV_HI/nFSV_PDO;
nStep_LO : REAL := nFSV_LO/nFSV_PDO;
END_VAR
VAR
nSamplesIn1 AT%I* : DINT;
nSamplesIn2 AT%I* : DINT;
nValueCombi : LINT;
nValueCombi_LREAL : LREAL;
nKF : REAL := nFSV_HI/nFSV_LO;
nLimit : REAL := nMAX_PDO;
nPDO1_REAL : LREAL;
nPDO2_REAL : LREAL;
// Voltage values:
nVoltage1 : LREAL;
nVoltage2 : LREAL;
nVoltageComb : LREAL;
END_VAR
Program code:
nPDO1_REAL := DINT_TO_LREAL(nSamplesIn1);
nPDO2_REAL := DINT_TO_LREAL(nSamplesIn2);
IF ABS(nPDO2_REAL) >= nLimit THEN
nValueCombi_LREAL := nPDO1_REAL*nKF;
ELSE
nValueCombi_LREAL := nPDO2_REAL;
END_IF
nValueCombi := LREAL_TO_LINT(nValueCombi_LREAL);
nVoltage1 := nPDO1_REAL * nFSV_HI/nFSV_PDO;
nVoltage2 := nPDO2_REAL * nFSV_LO/nFSV_PDO;
nVoltageComb := nValueCombi_LREAL * nFSV_LO/nFSV_PDO;
An application of this sample with a ±5 V FSV1 and a ±80 mV FSV2 and an input signal of ±5.68 V shows the voltage curve at input 1, input 2 and both combined inputs as a continuous range in the lowest recording. In the recording of input 2 the range of +/- overflow is marked (negative/ positive clipping):
Combination of two channels of the ELM3602-0002 with ±5 V and ±80 mV measuring range
With an applied delta voltage of approx. 86 mV ±5 mV, the transition range is indicated by the voltage characteristic of input 2 (values < 0 V):
Combination of two channels of the ELM3602-0002: Supply of a delta voltage in the positive transition range
The following applies to the (preset) extended range of both channels (without taking any measurement uncertainties into account):
If the dynamic range for the ± 5 V measuring range is approx. 20 · log (5.368 / 6.4E-7) ≈ 138.47 dB, the combination of two channels of the terminal can be used to increase the dynamic range to approx. 20 × log (5.368 / 1.024E-8) ≈ 174.39 dB (with the limitation of a coarser resolution in the range of approx. ± 85.9 mV to ± 5.37 V).
Please note that under these conditions the terminal always displays errors via the error LED and the error bit and outputs error messages to the TwinCAT environment due to regularly occurring overflow of a measuring channel.


Sample program 10 (reading and writing TEDS data)

Commissioning [image] Sample programs [image] Sample program 10 (reading and writing TEDS data)
Sample program 10 (reading and writing TEDS data)
Program description / function
This sample program illustrates how to read/write the data of a separate TEDS module (TEDS = Transducer Electronic Data Sheet). Such TEDS modules are available on the market for retrofitting sensors or actuators, in order to identify the device after installation or to read out specific data (calibration, manufacturer etc.). The device used in this example was an HBM TEDS 1−TEDS−BOARD−L, version 2018.
This sample program is expressly intended as a feasibility demonstration. Specifically, there is no claim to interoperability with any other TEDS modules. It is the responsibility of users to transfer the methods formulated here to their own implementations.
This demonstration does not cover TEDS modules that are integrated in the sensor and communicate on the sensor lines. This is common for IEPE (vibration) or strain gauges/measuring bridges. It is possible to connect an IEPE sensor equipped with TEDS to Beckhoff ELM3602/ELM3604 terminals.
The following configuration is required:
[EK1100] + [EL2262] + [EL9505] + [EL1262-0050] + EL9011
The configuration can control 2 TEDS modules. Only single-channel operation is shown in the example.
Wiring for sample program 3
The voltage divider can be dimensioned with R1 = 2180 Ω (e.g. 680 Ω + 1500 Ω), R2 = 680 Ω and Z = 5,1 V for example.
Notes on the program (visualization)
First the URN has to be read (A). Only then are further functions available.
The program determines the URN for each bit by reinitializing the module, since the terminal for the input causes a time offset that is too large (see "Bit repeat count" at the top right).
Data can be written either by entering hexadecimal values (B) or a text string (ASCII) (C); hexadecimal values must be separated by spaces in the text field. Which of the two inputs is to be used for writing can be specified with the checkbox “Write ASCII data” (E):
Visualization of the sample program for TEDS with EL1262-0050 and EL2262
The basic function after the identified URN is (D) reading (READ MEM) and writing (WRITE MEM) TEDS data. By issuing such a command, the associated command statement is generated in the text field (H) and can also be changed and then executed with "Execute command". Via +/- the TEDS address or page can be changed (F). Both the start address and "page" can be entered directly for read / write accesses.
The hexadecimal data (B) of text field #1 to #4 each represent 32 bytes of the total read/write buffer size of 128 bytes, as configured in the sample program. If the checkbox “Complete read size” (G) is unchecked, only text field #1 will be used for writing usually (except the module supports page sizes > 32 byte). Accordingly, only the first characters of the ASCII data text will be written. In any case, the number of bytes as a page of the module is configured will be used. Note, that the module usually supports write access to addresses of a multiple value of the page size only (so, e.g. assuming a page size of 32 bytes and an address 234 is input, an error 0x35 ‘writing fail’ will occur when WRITE MEM is commanded and confirmed; but 352 is valid and results no error).
Selection of “Include application register” provides whether the application register shall be written or read additionally (G).
Download:
See information about the TEDS feature of the ELM3xxx in section “ELM Features/ TEDS”.


Sample program 11 (FB for real time diagnosis)

Commissioning [image] Sample programs [image] Sample program 11 (FB for real time diagnosis)
Sample program 11 (FB for real time diagnosis)
The following function block can be used as a template for a real time diagnosis application of an analog input terminal in TwinCAT PLC. It has to be placed between the terminal and the application and evaluates the diagnostic variables coming from the terminal. The measurement values will be unchanged passed through.
The function block is written for the ELM3602‑0002 with oversampling=5 and should be understood as a functional example and must be adapted if necessary to
▪
other terminals, if necessary other value data types
▪
other oversampling values
It can be extended with data-processing code or further particular diagnostics or assigned to a completely different terminal type (analog output EL4xxx, Encoder EL5xxx, ...).
The function block between the terminal and the PLC can be schematically illustrated as follows:
Function block as an example for analysis of diagnostics information of the terminal
Simplified linking via structure variable
This example program takes the opportunity to describe a TwinCAT function that simplifies the linking of complex PDO structures.
This function block would have to be linked to all real time variables of the terminal: inputs and outputs; here e.g. for the ELM3602:
This time-consuming process can be simplified and accelerated by structuring in TwinCAT 3. Therefore, in this chapter two alternative variants in TwinCAT 3.1 are presented, as with a few clicks a structure can be defined in the PLC which corresponds to the process image of the terminal.
The respective variant of the function block FB_REALTIME_DIAGNOSIS is included in the two example programs. It contains variables with an application-specific data type. This is a structure created by TwinCAT 3. Because the structure generated by TwinCAT directly maps the PDO structure of the terminal, it is not necessary that a suitable structure must be elaborately created or individual variables must be linked to individual data types. Only a link at a higher level (Status, Samples, Control, ...) is required.
This and all configurations are already included in the respective example program:
▪
Example program (variant A – using the “Plc” tab of the terminal):
▪
Example program (variant B – using of “Create SM/PDO Variables” by the advanced settings of the terminal):
Variant A, “Plc” tab:
In general, the generation of this special PDO data type is activated via the PLC settings of the terminal (tab “Plc"): there the check box "Create PLC Data Type" is set ("Copy" then transfers this character string to the clipboard):
Creation of PDO variables (TwinCAT version >= V3.1.4024.0)
The setting "Per Channel” can be set if not for all but for one only the structure shall be created.
The address assignments for inputs (%ATI*) and outputs (%ATQ*) are already within this generated structure. Inputs and outputs are therefore summarized in this structure.
The variables declaration within the function block FB_REALTIME_DIAGNOSIS then contains:
stELM3602Special : MDP5001_350_EB559ACD;
Read access is provided to the inputs of the terminal via the substructure MDP5001_350_Input and write access to the outputs via the substructure MDP5001_350_Output of the structure stELM3602Special.
Variant B, “Create SM/PDO variables“:
Commonly, the generation of this specific PDO data type incl. the PDO element will be activated via the EtherCAT settings of the terminal: within the advanced settings under “General”/ "Behavior" the checkbox "Create SM/PDO Variables“ in “Process Data” is to set:
Create SM_PDO vars_en.png
Creation of the SmPdoVariables (TwinCAT version >= V3.1.4022.30)
The data type is visible by selecting the object and can be copied to the clipboard there:
Seek the generated data type of SmPdoVariables
The variables declaration within the function block FB_REALTIME_DIAGNOSIS then contains:
st_SM2 AT%Q* : ECAT_ELM3602_0002_SM_3412CB6A;
st_SM3 AT%I* : ECAT_ELM3602_0002_SM_87A01A51;
The read access to the inputs of the application is provided via the structure st_SM3 and write access to the outputs via the structure st_SM2. These data structures corresponds to the automatically added new PDO element "SmPdoVariables".


Sample program 12 (scripts for generation and transformation of filter coefficients)

Commissioning [image] Sample programs [image] Sample program 12 (scripts for generation and transformation of filter coefficients)
Sample program 12 (scripts for generation and transformation of filter coefficients)
Download link:
For explanations of application see chapter "Exemplary calculation of IIR/FIR filter coefficients".


Sample program 13 (R/W signature of calibration)

Commissioning [image] Sample programs [image] Sample program 13 (R/W signature of calibration)
Sample program 13 (R/W signature of calibration)
The terminal features an advanced calibration mechanism to store, among other things, an individual signature with 256 bytes, which results from the calibration data. In this way the customer could provide a calibration with a specific signature, e.g. to detect unauthorized internal manipulation of the calibration data; see also chapter "Calibration/Adjustment/Synchronization (vendor and user)".
The function block described below can be used as a basis for an implementation in TwinCAT on a PLC. To simplify matters, only a CRC16 was used in this sample to serve a "signature" limited to two bytes. At a commented point in the FB implementation, another signature algorithm can be implemented, which can be up to 256 bytes long.
The sample function block is included in the TwinCAT 3 archive, which is available for download together with a visualization:
Explanatory notes for the visualization "Calibration_Signature_RW"
The input variables of the ADS address and the "InputToggle" must be linked again if another terminal (than ELM3602) is used for the sample. This must be entered in the field after starting the sample program. Alternatively, it can be entered before the start as initialization of the input variable "sTerminalTypeIn" of the function block "FB_VisuUpdate":
sTerminalTypeIn : T_MaxString := 'ELM3602';
After the program start
The function block "FB_CalibrationSignature" is called in read mode by the visualization when channel +/- or interface +/- or "read" is actuated and in write mode when "write" is actuated. If, after reading, the calculated and the read signature match, bCmpResult becomes TRUE (no inequality). After a write access the entry remains in the read CoE and can be checked by reading (a write access does not change the state of bCmpResult).
Visualization of the sample implementation: Calibration signature
The variable bError (visualization representation: "R/W Error") provides information about a general error that has occurred when accessing the terminal as well as the failure to find stored terminal information (either the entry in the GVL is missing or the terminal is not present).
Explanatory notes for FB_CalibrationSignature
The interface of the function block is structured as follows:
VAR_INPUT
bInitialize : BOOL := FALSE; // Ist Initialisiert
bEnable : BOOL := FALSE; // Aktiviere Baustein
tAmsNetIdArr : AMSADDR; // Ads-Adresse der Klemme
nIfSlectCoE : WORD; // Interface Nummer für das CoE
nChSelectCoE : WORD := 1; // Kanalnummer
eOption : E_CALSIG_OPTIONS; // Zugriff get/set (lese/schreibe)
stCoEPAIInfoDataCalCnt : ST_CoE; // Kal.-Zähler Objekt (El3751/ ELM)
END_VAR
VAR_OUTPUT
bDone : BOOL; // Prozedur abgeschlossen
bCmpResult : BOOL; // Signatur-Vergleich: TRUE = Gleich
nInterfaceUserCalCnt : WORD; // Wert des Kalibirungszählers
bError : BOOL; // Fehlerfall
bCancel : BOOL; // Abbruch (Fehlerfall)
nErrorId : UDINT;// Fehlernummer (alle Quellen)
anSigDataOutCoE : ARRAY[0..(GVL_CoE.nSigLen-1)] OF BYTE; // Signatur gespeichert
anSigDataOutCalc : ARRAY[0..(GVL_CoE.nSigLen-1)] OF BYTE; // Signatur berechnet
END_VAR
For initialization the "Net Id" and "Port No." must be transferred to the variable "tAmsNetIdArr" of the FB instance. In addition, the CoE object for reading the calibration counter must be transferred via 'stCoEPAIInfoDataCalCnt', since this is different for the ELM3xxx and EL3751 terminals.
A call is made with "bEnable := TRUE" for activation and with specification of the interface number (nIfSlectCoE) that applies to the terminal to be addressed, the channel (nChSelectCoE) and for reading the stored signature "eOption := E_CALSIG_OPTIONS.get" or for writing "eOption := E_CALSIG_OPTIONS.set".
Then the function block is called until the output variable "bDone" is TRUE.
The outputs anSigDataOutCalc, anSigDataOutCoE, nInterfaceUserCalCnt and bCmpResult will provide content according to the selected option and the calculated/stored terminal data.
To attempt to clear an error that has occurred in the case of "bError" = TRUE, the FB can be called with "bInit := FALSE" (e.g. if the channel number or the interface number has been corrected according to the addressed terminal). The "nErrorId" can be used for evaluation.
In the function block, the signature calculation can be changed/extended at the following point:
// Berechne Signatur
// ============== Anwender Code hier ==============
// Beispiel: einfache CRC:
nCrc := nIfSlectCoE + nChSelectCoE; // Voreinstellung des Startwertes
nCrc := F_DATA_TO_CRC16_CCITT(ADR(aData), nDataLen, nCrc); // Berechne "Signatur"
memset(ADR(anSigDataOutCalc), 16#FF, GVL_CoE.nSigLen);
memcpy(ADR(anSigDataOutCalc), ADR(nCrc), 2); // <- Abhängig von Verschlüsselungsart
// =================================================


Notes to short documentation

Commissioning [image] Notes to short documentation
Notes to short documentation
Note
This short documentation does not contain any further information within this chapter. For the complete documentation please contact the Beckhoff sales department responsible for you.


ELM Features

ELM Features
ELM Features
Note
This short documentation does not contain any further information within this chapter. For the complete documentation please contact the Beckhoff sales department responsible for you.


Commissioning on EtherCAT Master

Commissioning on EtherCAT Master
Commissioning on EtherCAT Master
Additional information
•
General Notes - EtherCAT Slave Application
•
TwinCAT Quick Start
•
TwinCAT Development Environment
•
EtherCAT basics
•
EtherCAT cabling – wire-bound
•
General notes for setting the watchdog
•
EtherCAT State Machine
•
CoE Interface
•
Distributed Clock


General Notes - EtherCAT Slave Application

Commissioning on EtherCAT Master [image] General Notes - EtherCAT Slave Application
General Notes - EtherCAT Slave Application
This summary briefly deals with a number of aspects of EtherCAT Slave operation under TwinCAT. More detailed information on this may be found in the corresponding sections of, for instance, the EtherCAT System Documentation.
Diagnosis in real time: WorkingCounter, EtherCAT State and Status
Generally speaking an EtherCAT Slave provides a variety of diagnostic information that can be used by the controlling task.
This diagnostic information relates to differing levels of communication. It therefore has a variety of sources, and is also updated at various times.
Any application that relies on I/O data from a fieldbus being correct and up to date must make diagnostic access to the corresponding underlying layers. EtherCAT and the TwinCAT System Manager offer comprehensive diagnostic elements of this kind. Those diagnostic elements that are helpful to the controlling task for diagnosis that is accurate for the current cycle when in operation (not during commissioning) are discussed below.
Selection of the diagnostic information of an EtherCAT Slave
In general, an EtherCAT Slave offers
▪
communication diagnosis typical for a slave (diagnosis of successful participation in the exchange of process data, and correct operating mode)
This diagnosis is the same for all slaves.

as well as
▪
function diagnosis typical for a channel (device-dependent)
See the corresponding device documentation
The colors in Fig. Selection of the diagnostic information of an EtherCAT Slave also correspond to the variable colors in the System Manager, see Fig. Basic EtherCAT Slave Diagnosis in the PLC.
Colour | Meaning
yellow | Input variables from the Slave to the EtherCAT Master, updated in every cycle
red | Output variables from the Slave to the EtherCAT Master, updated in every cycle
green | Information variables for the EtherCAT Master that are updated acyclically. This means that it is possible that in any particular cycle they do not represent the latest possible status. It is therefore useful to read such variables through ADS.
Fig. Basic EtherCAT Slave Diagnosis in the PLC shows an example of an implementation of basic EtherCAT Slave Diagnosis. A Beckhoff EL3102 (2-channel analogue input terminal) is used here, as it offers both the communication diagnosis typical of a slave and the functional diagnosis that is specific to a channel. Structures are created as input variables in the PLC, each corresponding to the process image.
Basic EtherCAT Slave Diagnosis in the PLC
The following aspects are covered here:
Code
Function
Implementation
Application/evaluation
A
The EtherCAT Master's diagnostic information
updated acyclically (yellow) or provided acyclically (green).
At least the DevState is to be evaluated for the most recent cycle in the PLC.
The EtherCAT Master's diagnostic information offers many more possibilities than are treated in the EtherCAT System Documentation. A few keywords:
▪
CoE in the Master for communication with/through the Slaves
▪
Functions from TcEtherCAT.lib
▪
Perform an OnlineScan
B
In the example chosen (EL3102) the EL3102 comprises two analogue input channels that transmit a single function status for the most recent cycle.
Status
▪
the bit significations may be found in the device documentation
▪
other devices may supply more information, or none that is typical of a slave
In order for the higher-level PLC task (or corresponding control applications) to be able to rely on correct data, the function status must be evaluated there. Such information is therefore provided with the process data for the most recent cycle.
C
For every EtherCAT Slave that has cyclic process data, the Master displays, using what is known as a WorkingCounter, whether the slave is participating successfully and without error in the cyclic exchange of process data. This important, elementary information is therefore provided for the most recent cycle in the System Manager
1.
at the EtherCAT Slave, and, with identical contents
2.
as a collective variable at the EtherCAT Master (see Point A)
for linking.
WcState (Working Counter)
0: valid real-time communication in the last cycle
1: invalid real-time communication
This may possibly have effects on the process data of other Slaves that are located in the same SyncUnit
In order for the higher-level PLC task (or corresponding control applications) to be able to rely on correct data, the communication status of the EtherCAT Slave must be evaluated there. Such information is therefore provided with the process data for the most recent cycle.
D
Diagnostic information of the EtherCAT Master which, while it is represented at the slave for linking, is actually determined by the Master for the Slave concerned and represented there. This information cannot be characterized as real-time, because it
▪
is only rarely/never changed, except when the system starts up
▪
is itself determined acyclically (e.g. EtherCAT Status)
State
current Status (INIT..OP) of the Slave. The Slave must be in OP (=8) when operating normally.
AdsAddr
The ADS address is useful for communicating from the PLC/task via ADS with the EtherCAT Slave, e.g. for reading/writing to the CoE. The AMS-NetID of a slave corresponds to the AMS-NetID of the EtherCAT Master; communication with the individual Slave is possible via the port (= EtherCAT address).
Information variables for the EtherCAT Master that are updated acyclically. This means that it is possible that in any particular cycle they do not represent the latest possible status. It is therefore possible to read such variables through ADS.
Note
Diagnostic information
It is strongly recommended that the diagnostic information made available is evaluated so that the application can react accordingly.
CoE Parameter Directory
The CoE parameter directory (CanOpen-over-EtherCAT) is used to manage the set values for the slave concerned. Changes may, in some circumstances, have to be made here when commissioning a relatively complex EtherCAT Slave. It can be accessed through the TwinCAT System Manager, see Fig. EL3102, CoE directory:
EL3102, CoE directory
EtherCAT System Documentation
The comprehensive description in the EtherCAT System Documentation (EtherCAT Basics --> CoE Interface) must be observed!
A few brief extracts:
▪
Whether changes in the online directory are saved locally in the slave depends on the device. EL terminals (except the EL66xx) are able to save in this way.
▪
The user must manage the changes to the StartUp list.
Commissioning aid in the TwinCAT System Manager
Commissioning interfaces are being introduced as part of an ongoing process for EL/EP EtherCAT devices. These are available in TwinCAT System Managers from TwinCAT 2.11R2 and above. They are integrated into the System Manager through appropriately extended ESI configuration files.
Example of commissioning aid for a EL3204
This commissioning process simultaneously manages
▪
CoE Parameter Directory
▪
DC/FreeRun mode
▪
the available process data records (PDO)
Although the “Process Data”, “DC”, “Startup” and “CoE-Online” that used to be necessary for this are still displayed, it is recommended that, if the commissioning aid is used, the automatically generated settings are not changed by it.
The commissioning tool does not cover every possible application of an EL/EP device. If the available setting options are not adequate, the user can make the DC, PDO and CoE settings manually, as in the past.
EtherCAT State: automatic default behaviour of the TwinCAT System Manager and manual operation
After the operating power is switched on, an EtherCAT Slave must go through the following statuses
▪
INIT
▪
PREOP
▪
SAFEOP
▪
OP
to ensure sound operation. The EtherCAT Master directs these statuses in accordance with the initialization routines that are defined for commissioning the device by the ES/XML and user settings (Distributed Clocks (DC), PDO, CoE). See also the section on "Principles of Communication, EtherCAT State Machine" in this connection. Depending how much configuration has to be done, and on the overall communication, booting can take up to a few seconds.
The EtherCAT Master itself must go through these routines when starting, until it has reached at least the OP target state.
The target state wanted by the user, and which is brought about automatically at start-up by TwinCAT, can be set in the System Manager. As soon as TwinCAT reaches the status RUN, the TwinCAT EtherCAT Master will approach the target states.
Standard setting
The advanced settings of the EtherCAT Master are set as standard:
▪
EtherCAT Master: OP
▪
Slaves: OP
This setting applies equally to all Slaves.
Default behaviour of the System Manager
In addition, the target state of any particular Slave can be set in the “Advanced Settings” dialogue; the standard setting is again OP.
Default target state in the Slave
Manual Control
There are particular reasons why it may be appropriate to control the states from the application/task/PLC. For instance:
▪
for diagnostic reasons
▪
to induce a controlled restart of axes
▪
because a change in the times involved in starting is desirable
In that case it is appropriate in the PLC application to use the PLC function blocks from the TcEtherCAT.lib, which is available as standard, and to work through the states in a controlled manner using, for instance, FB_EcSetMasterState.
It is then useful to put the settings in the EtherCAT Master to INIT for master and slave.
PLC function blocks
Note regarding E-Bus current
EL/ES terminals are placed on the DIN rail at a coupler on the terminal strand. A Bus Coupler can supply the EL terminals added to it with the E-bus system voltage of 5 V; a coupler is thereby loadable up to 2 A as a rule. Information on how much current each EL terminal requires from the E-bus supply is available online and in the catalogue. If the added terminals require more current than the coupler can supply, then power feed terminals (e.g. EL9410) must be inserted at appropriate places in the terminal strand.
The pre-calculated theoretical maximum E-Bus current is displayed in the TwinCAT System Manager as a column value. A shortfall is marked by a negative total amount and an exclamation mark; a power feed terminal is to be placed before such a position.
Illegally exceeding the E-Bus current
From TwinCAT 2.11 and above, a warning message “E-Bus Power of Terminal...” is output in the logger window when such a configuration is activated:
Warning message for exceeding E-Bus current
Note
Caution! Malfunction possible!
The same ground potential must be used for the E-Bus supply of all EtherCAT terminals in a terminal block!


TwinCAT Quick Start

Commissioning on EtherCAT Master [image] TwinCAT Quick Start
TwinCAT Quick Start
TwinCAT is a development environment for real-time control including multi-PLC system, NC axis control, programming and operation. The whole system is mapped through this environment and enables access to a programming environment (including compilation) for the controller. Individual digital or analog inputs or outputs can also be read or written directly, in order to verify their functionality, for example.
For further information please refer to http://infosys.beckhoff.com:
▪
EtherCAT Systemmanual:
Fieldbus Components → EtherCAT Terminals → EtherCAT System Documentation → Setup in the TwinCAT System Manager
▪
TwinCAT 2 → TwinCAT System Manager → I/O - Configuration
▪
In particular, TwinCAT driver installation:
Fieldbus components → Fieldbus Cards and Switches → FC900x – PCI Cards for Ethernet → Installation
Devices contain the terminals for the actual configuration. All configuration data can be entered directly via editor functions (offline) or via the “Scan” function (online):
▪
“offline”: The configuration can be customized by adding and positioning individual components. These can be selected from a directory and configured.
–
The procedure for offline mode can be found under http://infosys.beckhoff.com:
TwinCAT 2 → TwinCAT System Manager → IO - Configuration → Adding an I/O Device
▪
“online”: The existing hardware configuration is read
–
See also http://infosys.beckhoff.com:
Fieldbus components → Fieldbus cards and switches → FC900x – PCI Cards for Ethernet → Installation → Searching for devices
The following relationship is envisaged from user PC to the individual control elements:
Relationship between user side (commissioning) and installation
The user inserting of certain components (I/O device, terminal, box...) is the same in TwinCAT 2 and TwinCAT 3. The descriptions below relate to the online procedure.
Sample configuration (actual configuration)
Based on the following sample configuration, the subsequent subsections describe the procedure for TwinCAT 2 and TwinCAT 3:
▪
Control system (PLC) CX2040 including CX2100-0004 power supply unit
▪
Connected to the CX2040 on the right (E-bus):
EL1004 (4-channel digital input terminal 24 VDC)
▪
Linked via the X001 port (RJ-45): EK1100 EtherCAT Coupler
▪
Connected to the EK1100 EtherCAT coupler on the right (E-bus):
EL2008 (8-channel digital output terminal 24 VDC; 0.5 A)
▪
(Optional via X000: a link to an external PC for the user interface)
Control configuration with Embedded PC, input (EL1004) and output (EL2008)
Note that all combinations of a configuration are possible; for example, the EL1004 terminal could also be connected after the coupler, or the EL2008 terminal could additionally be connected to the CX2040 on the right, in which case the EK1100 coupler wouldn’t be necessary.
Additional information
•
TwinCAT 2
•
TwinCAT 3


TwinCAT 2

Commissioning on EtherCAT Master [image] TwinCAT Quick Start [image] TwinCAT 2
TwinCAT 2
Startup
TwinCAT basically uses two user interfaces: the TwinCAT System Manager for communication with the electromechanical components and TwinCAT PLC Control for the development and compilation of a controller. The starting point is the TwinCAT System Manager.
After successful installation of the TwinCAT system on the PC to be used for development, the TwinCAT 2 System Manager displays the following user interface after startup:
Initial TwinCAT 2 user interface
Generally, TwinCAT can be used in local or remote mode. Once the TwinCAT system including the user interface (standard) is installed on the respective PLC, TwinCAT can be used in local mode and thereby the next step is “Insert Device”.
If the intention is to address the TwinCAT runtime environment installed on a PLC as development environment remotely from another system, the target system must be made known first. In the menu under “Actions” → “Choose Target System...”, via the symbol “ [image] ” or the “F8” key, open the following window:
Selection of the target system
Use “Search (Ethernet)...” to enter the target system. Thus a next dialog opens to either:
▪
enter the known computer name after “Enter Host Name / IP:” (as shown in red)
▪
perform a “Broadcast Search” (if the exact computer name is not known)
▪
enter the known computer IP or AmsNetID.
Specify the PLC for access by the TwinCAT System Manager: selection of the target system
Once the target system has been entered, it is available for selection as follows (a password may have to be entered):
After confirmation with “OK” the target system can be accessed via the System Manager.
Adding devices
In the configuration tree of the TwinCAT 2 System Manager user interface on the left, select “I/O Devices” and then right-click to open a context menu and select “Scan Devices…”, or start the action in the menu bar via [image]. The TwinCAT System Manager may first have to be set to “Config mode” via [image] or via menu
“Actions” → “Set/Reset TwinCAT to Config Mode…” (Shift + F4).
Select “Scan Devices...”
Confirm the warning message, which follows, and select “EtherCAT” in the dialog:
Automatic detection of I/O devices: selection the devices to be integrated
Confirm the message “Find new boxes”, in order to determine the terminals connected to the devices. “Free Run” enables manipulation of input and output values in “Config mode” and should also be acknowledged.
Based on the sample configuration described at the beginning of this section, the result is as follows:
Mapping of the configuration in the TwinCAT 2 System Manager
The whole process consists of two stages, which may be performed separately (first determine the devices, then determine the connected elements such as boxes, terminals, etc.). A scan can also be initiated by selecting “Device ...” from the context menu, which then reads the elements present in the configuration below:
Reading of individual terminals connected to a device
This functionality is useful if the actual configuration is modified at short notice.
Programming and integrating the PLC
TwinCAT PLC Control is the development environment for the creation of the controller in different program environments: TwinCAT PLC Control supports all languages described in IEC 61131-3. There are two text-based languages and three graphical languages.
▪
Text-based languages
–
Instruction List (IL)
–
Structured Text (ST)
▪
Graphical languages
–
Function Block Diagram (FBD)
–
Ladder Diagram (LD)
–
The Continuous Function Chart Editor (CFC)
–
Sequential Function Chart (SFC)
The following section refers to Structured Text (ST).
After starting TwinCAT PLC Control, the following user interface is shown for an initial project:
TwinCAT PLC Control after startup
Sample variables and a sample program have been created and stored under the name “PLC_example.pro”:
Sample program with variables after a compile process (without variable integration)
Warning 1990 (missing “VAR_CONFIG”) after a compile process indicates that the variables defined as external (with the ID “AT%I*” or “AT%Q*”) have not been assigned. After successful compilation, TwinCAT PLC Control creates a “*.tpy” file in the directory in which the project was stored. This file (“*.tpy”) contains variable assignments and is not known to the System Manager, hence the warning. Once the System Manager has been notified, the warning no longer appears.
First, integrate the TwinCAT PLC Control project in the System Manager via the context menu of the PLC configuration; right-click and select “Append PLC Project…”:
Appending the TwinCAT PLC Control project
Select the PLC configuration “PLC_example.tpy” in the browser window that opens. The project including the two variables identified with “AT” are then integrated in the configuration tree of the System Manager:
PLC project integrated in the PLC configuration of the System Manager
The two variables “bEL1004_Ch4” and “nEL2008_value” can now be assigned to certain process objects of the I/O configuration.
Assigning variables
Open a window for selecting a suitable process object (PDO) via the context menu of a variable of the integrated project “PLC_example” and via “Modify Link...” “Standard”:
Creating the links between PLC variables and process objects
In the window that opens, the process object for the variable “bEL1004_Ch4” of type BOOL can be selected from the PLC configuration tree:
Selecting PDO of type BOOL
According to the default setting, certain PDO objects are now available for selection. In this sample the input of channel 4 of the EL1004 terminal is selected for linking. In contrast, the checkbox “All types” must be ticked for creating the link for the output variables, in order to allocate a set of eight separate output bits to a byte variable. The following diagram shows the whole process:
Selecting several PDOs simultaneously: activate “Continuous” and “All types”
Note that the “Continuous” checkbox was also activated. This is designed to allocate the bits contained in the byte of the variable “nEL2008_value” sequentially to all eight selected output bits of the EL2008 terminal. In this way it is possible to subsequently address all eight outputs of the terminal in the program with a byte corresponding to bit 0 for channel 1 to bit 7 for channel 8 of the PLC. A special symbol ( [image]) at the yellow or red object of the variable indicates that a link exists. The links can also be checked by selecting a “Goto Link Variable” from the context menu of a variable. The object opposite, in this case the PDO, is automatically selected:
Application of a “Goto Link” variable, using “MAIN.bEL1004_Ch4” as a sample
The process of assigning variables to the PDO is completed via the menu selection “Actions” → “Generate Mappings”, key Ctrl+M or by clicking on the symbol [image] in the menu.
This can be visualized in the configuration:
The process of creating links can also take place in the opposite direction, i.e. starting with individual PDOs to variable. However, in this example it would then not be possible to select all output bits for the EL2008, since the terminal only makes individual digital outputs available. If a terminal has a byte, word, integer or similar PDO, it is possible to allocate this a set of bit-standardized variables (type “BOOL”). Here, too, a “Goto Link Variable” from the context menu of a PDO can be executed in the other direction, so that the respective PLC instance can then be selected.
Activation of the configuration
The allocation of PDO to PLC variables has now established the connection from the controller to the inputs and outputs of the terminals. The configuration can now be activated. First, the configuration can be verified via [image] (or via “Actions” → “Check Configuration”). If no error is present, the configuration can be activated via [image] (or via “Actions” → “Activate Configuration…”) to transfer the System Manager settings to the runtime system. Confirm the messages “Old configurations are overwritten!” and “Restart TwinCAT system in Run mode” with “OK”.
A few seconds later the real-time status [image] is displayed at the bottom right in the System Manager. The PLC system can then be started as described below.
Starting the controller
Starting from a remote system, the PLC control has to be linked with the Embedded PC over Ethernet via “Online” → “Choose Run-Time System…”:
Choose target system (remote)
In this sample “Runtime system 1 (port 801)” is selected and confirmed. Link the PLC with the real-time system via menu option “Online” → “Login”, the F11 key or by clicking on the symbol [image]. The control program can then be loaded for execution. This results in the message “No program on the controller! Should the new program be loaded?”, which should be acknowledged with “Yes”. The runtime environment is ready for the program start:
PLC Control logged in, ready for program startup
The PLC can now be started via “Online” → “Run”, F5 key or [image].


TwinCAT 3

Commissioning on EtherCAT Master [image] TwinCAT Quick Start [image] TwinCAT 3
TwinCAT 3
Startup
TwinCAT makes the development environment areas available together with Microsoft Visual Studio: after startup, the project folder explorer appears on the left in the general window area (cf. “TwinCAT System Manager” of TwinCAT 2) for communication with the electromechanical components.
After successful installation of the TwinCAT system on the PC to be used for development, TwinCAT 3 (shell) displays the following user interface after startup:
Initial TwinCAT 3 user interface
First create a new project via [image] (or under “File”→“New”→ “Project…”). In the following dialog make the corresponding entries as required (as shown in the diagram):
Create new TwinCAT project
The new project is then available in the project folder explorer:
New TwinCAT3 project in the project folder explorer
Generally, TwinCAT can be used in local or remote mode. Once the TwinCAT system including the user interface (standard) is installed on the respective PLC, TwinCAT can be used in local mode and thereby the next step is “Insert Device”.
If the intention is to address the TwinCAT runtime environment installed on a PLC as development environment remotely from another system, the target system must be made known first. Via the symbol in the menu bar:
expand the pull-down menu:
and open the following window:
Selection dialog: Choose the target system
Use “Search (Ethernet)...” to enter the target system. Thus a next dialog opens to either:
▪
enter the known computer name after “Enter Host Name / IP:” (as shown in red)
▪
perform a “Broadcast Search” (if the exact computer name is not known)
▪
enter the known computer IP or AmsNetID.
Specify the PLC for access by the TwinCAT System Manager: selection of the target system
Once the target system has been entered, it is available for selection as follows (a password may have to be entered):
After confirmation with “OK” the target system can be accessed via the Visual Studio shell.
Adding devices
In the project folder explorer of the Visual Studio shell user interface on the left, select “Devices” within element “I/O”, then right-click to open a context menu and select “Scan” or start the action via [image] in the menu bar. The TwinCAT System Manager may first have to be set to “Config mode” via [image] or via the menu “TwinCAT” → “Restart TwinCAT (Config mode)”.
Select “Scan”
Confirm the warning message, which follows, and select “EtherCAT” in the dialog:
Automatic detection of I/O devices: selection the devices to be integrated
Confirm the message “Find new boxes”, in order to determine the terminals connected to the devices. “Free Run” enables manipulation of input and output values in “Config mode” and should also be acknowledged.
Based on the sample configuration described at the beginning of this section, the result is as follows:
Mapping of the configuration in VS shell of the TwinCAT3 environment
The whole process consists of two stages, which may be performed separately (first determine the devices, then determine the connected elements such as boxes, terminals, etc.). A scan can also be initiated by selecting “Device ...” from the context menu, which then reads the elements present in the configuration below:
Reading of individual terminals connected to a device
This functionality is useful if the actual configuration is modified at short notice.
Programming the PLC
TwinCAT PLC Control is the development environment for the creation of the controller in different program environments: TwinCAT PLC Control supports all languages described in IEC 61131-3. There are two text-based languages and three graphical languages.
▪
Text-based languages
–
Instruction List (IL)
–
Structured Text (ST)
▪
Graphical languages
–
Function Block Diagram (FBD)
–
Ladder Diagram (LD)
–
The Continuous Function Chart Editor (CFC)
–
Sequential Function Chart (SFC)
The following section refers to Structured Text (ST).
In order to create a programming environment, a PLC subproject is added to the project sample via the context menu of “PLC” in the project folder explorer by selecting “Add New Item….”:
Adding the programming environment in “PLC”
In the dialog that opens select “Standard PLC project” and enter “PLC_example” as project name, for example, and select a corresponding directory:
Specifying the name and directory for the PLC programming environment
The “Main” program, which already exists by selecting “Standard PLC project”, can be opened by double-clicking on “PLC_example_project” in “POUs”. The following user interface is shown for an initial project:
Initial “Main” program of the standard PLC project
To continue, sample variables and a sample program have now been created:
Sample program with variables after a compile process (without variable integration)
The control program is now created as a project folder, followed by the compile process:
Start program compilation
The following variables, identified in the ST/ PLC program with “AT%”, are then available in under “Assignments” in the project folder explorer:
Assigning variables
Via the menu of an instance - variables in the “PLC” context, use the “Modify Link…” option to open a window for selecting a suitable process object (PDO) for linking:
Creating the links between PLC variables and process objects
In the window that opens, the process object for the variable “bEL1004_Ch4” of type BOOL can be selected from the PLC configuration tree:
Selecting PDO of type BOOL
According to the default setting, certain PDO objects are now available for selection. In this sample the input of channel 4 of the EL1004 terminal is selected for linking. In contrast, the checkbox “All types” must be ticked for creating the link for the output variables, in order to allocate a set of eight separate output bits to a byte variable. The following diagram shows the whole process:
Selecting several PDOs simultaneously: activate “Continuous” and “All types”
Note that the “Continuous” checkbox was also activated. This is designed to allocate the bits contained in the byte of the variable “nEL2008_value” sequentially to all eight selected output bits of the EL2008 terminal. In this way it is possible to subsequently address all eight outputs of the terminal in the program with a byte corresponding to bit 0 for channel 1 to bit 7 for channel 8 of the PLC. A special symbol ( [image]) at the yellow or red object of the variable indicates that a link exists. The links can also be checked by selecting a “Goto Link Variable” from the context menu of a variable. The object opposite, in this case the PDO, is automatically selected:
Application of a “Goto Link” variable, using “MAIN.bEL1004_Ch4” as a sample
The process of creating links can also take place in the opposite direction, i.e. starting with individual PDOs to variable. However, in this example it would then not be possible to select all output bits for the EL2008, since the terminal only makes individual digital outputs available. If a terminal has a byte, word, integer or similar PDO, it is possible to allocate this a set of bit-standardized variables (type “BOOL”). Here, too, a “Goto Link Variable” from the context menu of a PDO can be executed in the other direction, so that the respective PLC instance can then be selected.
Note on the type of variable assignment
The following type of variable assignment can only be used from TwinCAT version V3.1.4024.4 onwards and is only available for terminals with a microcontroller.
In TwinCAT it is possible to create a structure from the mapped process data of a terminal. An instance of this structure can then be created in the PLC, so it is possible to access the process data directly from the PLC without having to declare own variables.
The procedure for the EL3001 1-channel analog input terminal -10...+10 V is shown as an example.
1.
First the required process data must be selected in the “Process data” tab in TwinCAT.
2.
After that, the PLC data type must be generated in the tab “PLC” via the check box.
3.
The data type in the “Data Type” field can then be copied using the “Copy” button.
Creating a PLC data type
4.
An instance of the data structure of the copied data type must then be created in the PLC.
Instance_of_struct
5.
Then the project folder must be created. This can be done either via the key combination “CTRL + Shift + B” or via the “Build” tab in TwinCAT.
6.
The structure in the “PLC” tab of the terminal must then be linked to the created instance.
Linking the structure
7.
In the PLC the process data can then be read or written via the structure in the program code.
Reading a variable from the structure of the process data
Activation of the configuration
The allocation of PDO to PLC variables has now established the connection from the controller to the inputs and outputs of the terminals. The configuration can now be activated with [image] or via the menu under “TwinCAT” in order to transfer settings of the development environment to the runtime system. Confirm the messages “Old configurations are overwritten!” and “Restart TwinCAT system in Run mode” with “OK”. The corresponding assignments can be seen in the project folder explorer:
A few seconds later the corresponding status of the Run mode is displayed in the form of a rotating symbol [image] at the bottom right of the VS shell development environment. The PLC system can then be started as described below.
Starting the controller
Select the menu option “PLC” → “Login” or click on [image] to link the PLC with the real-time system and load the control program for execution. This results in the message No program on the controller! Should the new program be loaded?, which should be acknowledged with “Yes”. The runtime environment is ready for program start by click on symbol [image], the “F5” key or via “PLC” in the menu selecting “Start”. The started programming environment shows the runtime values of individual variables:
TwinCAT development environment (VS shell): logged-in, after program startup
The two operator control elements for stopping [image] and logout [image] result in the required action (accordingly also for stop “Shift + F5”, or both actions can be selected via the PLC menu).


TwinCAT Development Environment

Commissioning on EtherCAT Master [image] TwinCAT Development Environment
TwinCAT Development Environment
The Software for automation TwinCAT (The Windows Control and Automation Technology) will be distinguished into:
▪
TwinCAT 2: System Manager (Configuration) & PLC Control (Programming)
▪
TwinCAT 3: Enhancement of TwinCAT 2 (Programming and Configuration takes place via a common Development Environment)
Details:
▪
TwinCAT 2:
–
Connects I/O devices to tasks in a variable-oriented manner
–
Connects tasks to tasks in a variable-oriented manner
–
Supports units at the bit level
–
Supports synchronous or asynchronous relationships
–
Exchange of consistent data areas and process images
–
Datalink on NT - Programs by open Microsoft Standards (OLE, OCX, ActiveX, DCOM+, etc.)
–
Integration of IEC 61131-3-Software-SPS, Software- NC and Software-CNC within Windows NT/2000/XP/Vista, Windows 7, NT/XP Embedded, CE
–
Interconnection to all common fieldbusses
–
More…
Additional features:
▪
TwinCAT 3 (eXtended Automation):
–
Visual-Studio®-Integration
–
Choice of the programming language
–
Supports object orientated extension of IEC 61131-3
–
Usage of C/C++ as programming language for real time applications
–
Connection to MATLAB®/Simulink®
–
Open interface for expandability
–
Flexible run-time environment
–
Active support of Multi-Core- und 64-Bit-Operatingsystem
–
Automatic code generation and project creation with the TwinCAT Automation Interface
–
More…
Within the following sections commissioning of the TwinCAT Development Environment on a PC System for the control and also the basically functions of unique control elements will be explained.
Please see further information to TwinCAT 2 and TwinCAT 3 at http://infosys.beckhoff.com.
Additional information
•
Installation of the TwinCAT real-time driver
•
Notes regarding ESI device description
•
TwinCAT ESI Updater
•
Distinction between Online and Offline
•
OFFLINE configuration creation
•
ONLINE configuration creation
•
EtherCAT subscriber configuration


Installation of the TwinCAT real-time driver

Commissioning on EtherCAT Master [image] TwinCAT Development Environment [image] Installation of the TwinCAT real-time driver
Installation of the TwinCAT real-time driver
In order to assign real-time capability to a standard Ethernet port of an IPC controller, the Beckhoff real-time driver has to be installed on this port under Windows.
This can be done in several ways. One option is described here.
In the System Manager call up the TwinCAT overview of the local network interfaces via Options → Show Real Time Ethernet Compatible Devices.
System Manager “Options” (TwinCAT 2)
This have to be called up by the Menü “TwinCAT” within the TwinCAT 3 environment:
Call up under VS Shell (TwinCAT 3)
The following dialog appears:
Overview of network interfaces
Interfaces listed under “Compatible devices” can be assigned a driver via the “Install” button. A driver should only be installed on compatible devices.
A Windows warning regarding the unsigned driver can be ignored.
Alternatively an EtherCAT-device can be inserted first of all as described in chapter Offline configuration creation, section “Creating the EtherCAT device” in order to view the compatible ethernet ports via its EtherCAT properties (tab “Adapter”, button “Compatible Devices…”):
EtherCAT device properties(TwinCAT 2): click on “Compatible Devices…” of tab “Adapte””
TwinCAT 3: the properties of the EtherCAT device can be opened by double click on “Device .. (EtherCAT)” within the Solution Explorer under “I/O”:
After the installation the driver appears activated in the Windows overview for the network interface (Windows Start → System Properties → Network)
Windows properties of the network interface
A correct setting of the driver could be:
Exemplary correct driver setting for the Ethernet port
Other possible settings have to be avoided:
Incorrect driver settings for the Ethernet port
IP address of the port used
IP address/DHCP
In most cases an Ethernet port that is configured as an EtherCAT device will not transport general IP packets. For this reason and in cases where an EL6601 or similar devices are used it is useful to specify a fixed IP address for this port via the “Internet Protocol TCP/IP” driver setting and to disable DHCP. In this way the delay associated with the DHCP client for the Ethernet port assigning itself a default IP address in the absence of a DHCP server is avoided. A suitable address space is 192.168.x.x, for example.
TCP/IP setting for the Ethernet port


Notes regarding ESI device description

Commissioning on EtherCAT Master [image] TwinCAT Development Environment [image] Notes regarding ESI device description
Notes regarding ESI device description
Installation of the latest ESI device description
The TwinCAT EtherCAT master/System Manager needs the device description files for the devices to be used in order to generate the configuration in online or offline mode. The device descriptions are contained in the so-called ESI files (EtherCAT Slave Information) in XML format. These files can be requested from the respective manufacturer and are made available for download. An *.xml file may contain several device descriptions.
The ESI files for Beckhoff EtherCAT devices are available on the Beckhoff website.
The ESI files should be stored in the TwinCAT installation directory.
Default settings:
▪
TwinCAT 2: C:\TwinCAT\IO\EtherCAT
▪
TwinCAT 3: C:\TwinCAT\3.1\Config\Io\EtherCAT
The files are read (once) when a new System Manager window is opened, if they have changed since the last time the System Manager window was opened.
A TwinCAT installation includes the set of Beckhoff ESI files that was current at the time when the TwinCAT build was created.
For TwinCAT 2.11/TwinCAT 3 and higher, the ESI directory can be updated from the System Manager, if the programming PC is connected to the Internet; by
▪
TwinCAT 2: Option → “Update EtherCAT Device Descriptions”
▪
TwinCAT 3: TwinCAT → EtherCAT Devices → “Update Device Descriptions (via ETG Website)…”
The TwinCAT ESI Updater is available for this purpose.
ESI
The *.xml files are associated with *.xsd files, which describe the structure of the ESI XML files. To update the ESI device descriptions, both file types should therefore be updated.
Device differentiation
EtherCAT devices/slaves are distinguished by four properties, which determine the full device identifier. For example, the device identifier EL2521-0025-1018 consists of:
▪
family key “EL”
▪
name “2521”
▪
type “0025”
▪
and revision “1018”
Identifier structure
The order identifier consisting of name + type (here: EL2521-0010) describes the device function. The revision indicates the technical progress and is managed by Beckhoff. In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation. Each revision has its own ESI description. See further notes.
Online description
If the EtherCAT configuration is created online through scanning of real devices (see section Online setup) and no ESI descriptions are available for a slave (specified by name and revision) that was found, the System Manager asks whether the description stored in the device should be used. In any case, the System Manager needs this information for setting up the cyclic and acyclic communication with the slave correctly.
OnlineDescription information window (TwinCAT 2)
In TwinCAT 3 a similar window appears, which also offers the Web update:
Information window OnlineDescription (TwinCAT 3)
If possible, the Yes is to be rejected and the required ESI is to be requested from the device manufacturer. After installation of the XML/XSD file the configuration process should be repeated.
Note
Changing the “usual” configuration through a scan
✓
If a scan discovers a device that is not yet known to TwinCAT, distinction has to be made between two cases. Taking the example here of the EL2521-0000 in the revision 1019
1.
no ESI is present for the EL2521-0000 device at all, either for the revision 1019 or for an older revision. The ESI must then be requested from the manufacturer (in this case Beckhoff).
2.
an ESI is present for the EL2521-0000 device, but only in an older revision, e.g. 1018 or 1017.
In this case an in-house check should first be performed to determine whether the spare parts stock allows the integration of the increased revision into the configuration at all. A new/higher revision usually also brings along new features. If these are not to be used, work can continue without reservations with the previous revision 1018 in the configuration. This is also stated by the Beckhoff compatibility rule.
Refer in particular to the chapter “General notes on the use of Beckhoff EtherCAT IO components” and for manual configuration to the chapter “Offline configuration creation”.
If the OnlineDescription is used regardless, the System Manager reads a copy of the device description from the EEPROM in the EtherCAT slave. In complex slaves the size of the EEPROM may not be sufficient for the complete ESI, in which case the ESI would be incomplete in the configurator. Therefore it’s recommended using an offline ESI file with priority in such a case.
The System Manager creates for online recorded device descriptions a new file “OnlineDescription0000...xml” in its ESI directory, which contains all ESI descriptions that were read online.
File OnlineDescription.xml created by the System Manager
Is a slave desired to be added manually to the configuration at a later stage, online created slaves are indicated by a prepended symbol “>” in the selection list (see Figure Indication of an online recorded ESI of EL2521 as an example).
Indication of an online recorded ESI of EL2521 as an example
If such ESI files are used and the manufacturer's files become available later, the file OnlineDescription.xml should be deleted as follows:
▪
close all System Manager windows
▪
restart TwinCAT in Config mode
▪
delete “OnlineDescription0000...xml”
▪
restart TwinCAT System Manager
This file should not be visible after this procedure, if necessary press <F5> to update
OnlineDescription for TwinCAT 3.x
In addition to the file described above “OnlineDescription0000...xml”, a so called EtherCAT cache with new discovered devices is created by TwinCAT 3.x, e.g. under Windows 7:

(Please note the language settings of the OS!)
You have to delete this file, too.
Faulty ESI file
If an ESI file is faulty and the System Manager is unable to read it, the System Manager brings up an information window.
Information window for faulty ESI file (left: TwinCAT 2; right: TwinCAT 3)
Reasons may include:
▪
Structure of the *.xml does not correspond to the associated *.xsd file → check your schematics
▪
Contents cannot be translated into a device description → contact the file manufacturer


TwinCAT ESI Updater

Commissioning on EtherCAT Master [image] TwinCAT Development Environment [image] TwinCAT ESI Updater
TwinCAT ESI Updater
For TwinCAT 2.11 and higher, the System Manager can search for current Beckhoff ESI files automatically, if an online connection is available:
Using the ESI Updater (>= TwinCAT 2.11)
The call up takes place under:
“Options” → “Update EtherCAT Device Descriptions”
Selection under TwinCAT 3:
Using the ESI Updater (TwinCAT 3)
The ESI Updater (TwinCAT 3) is a convenient option for automatic downloading of ESI data provided by EtherCAT manufacturers via the Internet into the TwinCAT directory (ESI = EtherCAT slave information). TwinCAT accesses the central ESI ULR directory list stored at ETG; the entries can then be viewed in the Updater dialog, although they cannot be changed there.
The call up takes place under:
“TwinCAT” → “EtherCAT Devices” → “Update Device Description (via ETG Website)…”.


Distinction between Online and Offline

Commissioning on EtherCAT Master [image] TwinCAT Development Environment [image] Distinction between Online and Offline
Distinction between Online and Offline
The distinction between online and offline refers to the presence of the actual I/O environment (drives, terminals, EJ-modules). If the configuration is to be prepared in advance of the system configuration as a programming system, e.g. on a laptop, this is only possible in “Offline configuration” mode. In this case all components have to be entered manually in the configuration, e.g. based on the electrical design.
If the designed control system is already connected to the EtherCAT system and all components are energised and the infrastructure is ready for operation, the TwinCAT configuration can simply be generated through “scanning” from the runtime system. This is referred to as online configuration.
In any case, during each startup the EtherCAT master checks whether the slaves it finds match the configuration. This test can be parameterised in the extended slave settings. Refer to note “Installation of the latest ESI-XML device description”.
For preparation of a configuration:
▪
the real EtherCAT hardware (devices, couplers, drives) must be present and installed
▪
the devices/modules must be connected via EtherCAT cables or in the terminal/ module strand in the same way as they are intended to be used later
▪
the devices/modules be connected to the power supply and ready for communication
▪
TwinCAT must be in CONFIG mode on the target system.
The online scan process consists of:
▪
detecting the EtherCAT device (Ethernet port at the IPC)
▪
detecting the connected EtherCAT devices. This step can be carried out independent of the preceding step
▪
troubleshooting
The scan with existing configuration can also be carried out for comparison.


OFFLINE configuration creation

Commissioning on EtherCAT Master [image] TwinCAT Development Environment [image] OFFLINE configuration creation
OFFLINE configuration creation
Creating the EtherCAT device
Create an EtherCAT device in an empty System Manager window.
Append EtherCAT device (left: TwinCAT 2; right: TwinCAT 3)
Select type “EtherCAT” for an EtherCAT I/O application with EtherCAT slaves. For the present publisher/subscriber service in combination with an EL6601/EL6614 terminal select “EtherCAT Automation Protocol via EL6601”.
Selecting the EtherCAT connection (TwinCAT 2.11, TwinCAT 3)
Then assign a real Ethernet port to this virtual device in the runtime system.
Selecting the Ethernet port
This query may appear automatically when the EtherCAT device is created, or the assignment can be set/modified later in the properties dialog; see Fig. “EtherCAT device properties (TwinCAT 2)”.
EtherCAT device properties (TwinCAT 2)
TwinCAT 3: the properties of the EtherCAT device can be opened by double click on “Device .. (EtherCAT)” within the Solution Explorer under “I/O”:
Selecting the Ethernet port
Ethernet ports can only be selected for EtherCAT devices for which the TwinCAT real-time driver is installed. This has to be done separately for each port. Please refer to the respective installation page.
Defining EtherCAT slaves
Further devices can be appended by right-clicking on a device in the configuration tree.
Appending EtherCAT devices (left: TwinCAT 2; right: TwinCAT 3)
The dialog for selecting a new device opens. Only devices for which ESI files are available are displayed.
Only devices are offered for selection that can be appended to the previously selected device. Therefore the physical layer available for this port is also displayed (Fig. “Selection dialog for new EtherCAT device”, A). In the case of cable-based Fast-Ethernet physical layer with PHY transfer, then also only cable-based devices are available, as shown in Fig. “Selection dialog for new EtherCAT device”. If the preceding device has several free ports (e.g. EK1122 or EK1100), the required port can be selected on the right-hand side (A).
Overview of physical layer
▪
“Ethernet”: cable-based 100BASE-TX: EK couplers, EP boxes, devices with RJ45/M8/M12 connector
▪
“E-Bus”: LVDS “terminal bus”, “EJ-module”: EL/ES terminals, various modular modules
The search field facilitates finding specific devices (since TwinCAT 2.11 or TwinCAT 3).
Selection dialog for new EtherCAT device
By default only the name/device type is used as selection criterion. For selecting a specific revision of the device the revision can be displayed as “Extended Information”.
Display of device revision
In many cases several device revisions were created for historic or functional reasons, e.g. through technological advancement. For simplification purposes (see Fig. “Selection dialog for new EtherCAT device”) only the last (i.e. highest) revision and therefore the latest state of production is displayed in the selection dialog for Beckhoff devices. To show all device revisions available in the system as ESI descriptions tick the “Show Hidden Devices” check box, see Fig. “Display of previous revisions”.
Display of previous revisions
Device selection based on revision, compatibility
The ESI description also defines the process image, the communication type between master and slave/device and the device functions, if applicable. The physical device (firmware, if available) has to support the communication queries/settings of the master. This is backward compatible, i.e. newer devices (higher revision) should be supported if the EtherCAT master addresses them as an older revision. The following compatibility rule of thumb is to be assumed for Beckhoff EtherCAT Terminals/ Boxes/ EJ-modules:
device revision in the system >= device revision in the configuration
This also enables subsequent replacement of devices without changing the configuration (different specifications are possible for drives).
Example
If an EL2521-0025-1018 is specified in the configuration, an EL2521-0025-1018 or higher (-1019, -1020) can be used in practice.
Name/revision of the terminal
If current ESI descriptions are available in the TwinCAT system, the last revision offered in the selection dialog matches the Beckhoff state of production. It is recommended to use the last device revision when creating a new configuration, if current Beckhoff devices are used in the real application. Older revisions should only be used if older devices from stock are to be used in the application.
In this case the process image of the device is shown in the configuration tree and can be parameterized as follows: linking with the task, CoE/DC settings, plug-in definition, startup settings, ...
EtherCAT terminal in the TwinCAT tree (left: TwinCAT 2; right: TwinCAT 3)


ONLINE configuration creation

Commissioning on EtherCAT Master [image] TwinCAT Development Environment [image] ONLINE configuration creation
ONLINE configuration creation
Detecting/scanning of the EtherCAT device
The online device search can be used if the TwinCAT system is in CONFIG mode. This can be indicated by a symbol right below in the information bar:
▪
on TwinCAT 2 by a blue display “Config Mode” within the System Manager window: .
▪
on TwinCAT 3 within the user interface of the development environment by a symbol [image].
TwinCAT can be set into this mode:
▪
TwinCAT 2: by selection of [image] in the Menubar or by “Actions” → “Set/Reset TwinCAT to Config Mode…”
▪
TwinCAT 3: by selection of [image] in the Menubar or by “TwinCAT” → “Restart TwinCAT (Config Mode)”
Online scanning in Config mode
The online search is not available in RUN mode (production operation). Note the differentiation between TwinCAT programming system and TwinCAT target system.
The TwinCAT 2 icon ( [image]) or TwinCAT 3 icon ( [image]) within the Windows-Taskbar always shows the TwinCAT mode of the local IPC. Compared to that, the System Manager window of TwinCAT 2 or the user interface of TwinCAT 3 indicates the state of the target system.
Differentiation local/target system (left: TwinCAT 2; right: TwinCAT 3)
Right-clicking on “I/O Devices” in the configuration tree opens the search dialog.
Scan Devices (left: TwinCAT 2; right: TwinCAT 3)
This scan mode attempts to find not only EtherCAT devices (or Ethernet ports that are usable as such), but also NOVRAM, fieldbus cards, SMB etc. However, not all devices can be found automatically.
Note for automatic device scan (left: TwinCAT 2; right: TwinCAT 3)
Ethernet ports with installed TwinCAT real-time driver are shown as “RT Ethernet” devices. An EtherCAT frame is sent to these ports for testing purposes. If the scan agent detects from the response that an EtherCAT slave is connected, the port is immediately shown as an “EtherCAT Device” .
Detected Ethernet devices
Via respective checkboxes devices can be selected (as illustrated in Fig. “Detected Ethernet devices” e.g. Device 3 and Device 4 were chosen). After confirmation with “OK” a device scan is suggested for all selected devices, see Fig.: “Scan query after automatic creation of an EtherCAT device”.
Selecting the Ethernet port
Ethernet ports can only be selected for EtherCAT devices for which the TwinCAT real-time driver is installed. This has to be done separately for each port. Please refer to the respective installation page.
Detecting/Scanning the EtherCAT devices
Online scan functionality
During a scan the master queries the identity information of the EtherCAT slaves from the slave EEPROM. The name and revision are used for determining the type. The respective devices are located in the stored ESI data and integrated in the configuration tree in the default state defined there.
Example default state
Note
Slave scanning in practice in series machine production
The scanning function should be used with care. It is a practical and fast tool for creating an initial configuration as a basis for commissioning. In series machine production or reproduction of the plant, however, the function should no longer be used for the creation of the configuration, but if necessary for comparison with the defined initial configuration.Background: since Beckhoff occasionally increases the revision version of the delivered products for product maintenance reasons, a configuration can be created by such a scan which (with an identical machine construction) is identical according to the device list; however, the respective device revision may differ from the initial configuration.
Example:
Company A builds the prototype of a machine B, which is to be produced in series later on. To do this the prototype is built, a scan of the IO devices is performed in TwinCAT and the initial configuration “B.tsm” is created. The EL2521-0025 EtherCAT terminal with the revision 1018 is located somewhere. It is thus built into the TwinCAT configuration in this way:
Installing EthetCAT terminal with revision -1018
Likewise, during the prototype test phase, the functions and properties of this terminal are tested by the programmers/commissioning engineers and used if necessary, i.e. addressed from the PLC “B.pro” or the NC. (the same applies correspondingly to the TwinCAT 3 solution files).
The prototype development is now completed and series production of machine B starts, for which Beckhoff continues to supply the EL2521-0025-0018. If the commissioning engineers of the series machine production department always carry out a scan, a B configuration with the identical contents results again for each machine. Likewise, A might create spare parts stores worldwide for the coming series-produced machines with EL2521-0025-1018 terminals.
After some time Beckhoff extends the EL2521-0025 by a new feature C. Therefore the FW is changed, outwardly recognizable by a higher FW version and a new revision -1019. Nevertheless the new device naturally supports functions and interfaces of the predecessor version(s); an adaptation of “B.tsm” or even “B.pro” is therefore unnecessary. The series-produced machines can continue to be built with “B.tsm” and “B.pro”; it makes sense to perform a comparative scan against the initial configuration “B.tsm” in order to check the built machine.
However, if the series machine production department now doesn’t use “B.tsm”, but instead carries out a scan to create the productive configuration, the revision -1019 is automatically detected and built into the configuration:
Detection of EtherCAT terminal with revision -1019
This is usually not noticed by the commissioning engineers. TwinCAT cannot signal anything either, since virtually a new configuration is created. According to the compatibility rule, however, this means that no EL2521-0025-1018 should be built into this machine as a spare part (even if this nevertheless works in the vast majority of cases).
In addition, it could be the case that, due to the development accompanying production in company A, the new feature C of the EL2521-0025-1019 (for example, an improved analog filter or an additional process data for the diagnosis) is discovered and used without in-house consultation. The previous stock of spare part devices are then no longer to be used for the new configuration “B2.tsm” created in this way. Þ if series machine production is established, the scan should only be performed for informative purposes for comparison with a defined initial configuration. Changes are to be made with care!
If an EtherCAT device was created in the configuration (manually or through a scan), the I/O field can be scanned for devices/slaves.
Scan query after automatic creation of an EtherCAT device (left: TwinCAT 2; right: TwinCAT 3)
Manual triggering of a device scan on a specified EtherCAT device (left: TwinCAT 2; right: TwinCAT 3)
In the System Manager (TwinCAT 2) or the User Interface (TwinCAT 3) the scan process can be monitored via the progress bar at the bottom in the status bar.
Scan progressexemplary by TwinCAT 2
The configuration is established and can then be switched to online state (OPERATIONAL).
Config/FreeRun query (left: TwinCAT 2; right: TwinCAT 3)
In Config/FreeRun mode the System Manager display alternates between blue and red, and the EtherCAT device continues to operate with the idling cycle time of 4 ms (default setting), even without active task (NC, PLC).
Displaying of “Free Run” and “Config Mode” toggling right below in the status bar
TwinCAT can also be switched to this state by using a button (left: TwinCAT 2; right: TwinCAT 3)
The EtherCAT system should then be in a functional cyclic state, as shown in Fig. Online display example.
Online display example
Please note:
▪
all slaves should be in OP state
▪
the EtherCAT master should be in “Actual State” OP
▪
“frames/sec” should match the cycle time taking into account the sent number of frames
▪
no excessive “LostFrames” or CRC errors should occur
The configuration is now complete. It can be modified as described under manual procedure.
Troubleshooting
Various effects may occur during scanning.
▪
An unknown device is detected, i.e. an EtherCAT slave for which no ESI XML description is available.
In this case the System Manager offers to read any ESI that may be stored in the device. This case is described in the chapter “Notes regarding ESI device description”.
▪
Device are not detected properly
Possible reasons include:
–
faulty data links, resulting in data loss during the scan
–
slave has invalid device description
The connections and devices should be checked in a targeted manner, e.g. via the emergency scan.
Then re-run the scan.
Faulty identification
In the System Manager such devices may be set up as EK0000 or unknown devices. Operation is not possible or meaningful.
Scan over existing Configuration
Note
Change of the configuration after comparison
With this scan (TwinCAT 2.11 or 3.1) only the device properties vendor (manufacturer), device name and revision are compared at present! A “ChangeTo” or “Copy” should only be carried out with care, taking into consideration the Beckhoff IO compatibility rule (see above). The device configuration is then replaced by the revision found; this can affect the supported process data and functions.
If a scan is initiated for an existing configuration, the actual I/O environment may match the configuration exactly or it may differ. This enables the configuration to be compared.
Identical configuration (left: TwinCAT 2; right: TwinCAT 3)
If differences are detected, they are shown in the correction dialog, so that the user can modify the configuration as required.
Correction dialog
It is advisable to tick the “Extended Information” check box to reveal differences in the revision.
Color
Explanation
green
This EtherCAT slave matches the entry on the other side. Both type and revision match.
blue
This EtherCAT slave is present on the other side, but in a different revision. This other revision can have other default values for the process data as well as other/additional functions.
If the found revision is higher than the configured revision, the slave may be used provided compatibility issues are taken into account.
If the found revision is lower than the configured revision, it is likely that the slave cannot be used. The found device may not support all functions that the master expects based on the higher revision number.
light blue
This EtherCAT slave is ignored (“Ignore” button)
red
▪
This EtherCAT slave is not present on the other side.
▪
It is present, but in a different revision, which also differs in its properties from the one specified.
The compatibility principle then also applies here: if the found revision is higher than the configured revision, use is possible provided compatibility issues are taken into account, since the successor devices should support the functions of the predecessor devices.
If the found revision is lower than the configured revision, it is likely that the slave cannot be used. The found device may not support all functions that the master expects based on the higher revision number.
Device selection based on revision, compatibility
The ESI description also defines the process image, the communication type between master and slave/device and the device functions, if applicable. The physical device (firmware, if available) has to support the communication queries/settings of the master. This is backward compatible, i.e. newer devices (higher revision) should be supported if the EtherCAT master addresses them as an older revision. The following compatibility rule of thumb is to be assumed for Beckhoff EtherCAT Terminals/ Boxes/ EJ-modules:
device revision in the system >= device revision in the configuration
This also enables subsequent replacement of devices without changing the configuration (different specifications are possible for drives).
Example
If an EL2521-0025-1018 is specified in the configuration, an EL2521-0025-1018 or higher (-1019, -1020) can be used in practice.
Name/revision of the terminal
If current ESI descriptions are available in the TwinCAT system, the last revision offered in the selection dialog matches the Beckhoff state of production. It is recommended to use the last device revision when creating a new configuration, if current Beckhoff devices are used in the real application. Older revisions should only be used if older devices from stock are to be used in the application.
In this case the process image of the device is shown in the configuration tree and can be parameterized as follows: linking with the task, CoE/DC settings, plug-in definition, startup settings, ...
Correction dialog with modifications
Once all modifications have been saved or accepted, click “OK” to transfer them to the real *.tsm configuration.
Change to Compatible Type
TwinCAT offers a function Change to Compatible Type… for the exchange of a device whilst retaining the links in the task.
Dialog “Change to Compatible Type…” (left: TwinCAT 2; right: TwinCAT 3)
This function is preferably to be used on AX5000 devices.
Change to Alternative Type
The TwinCAT System Manager offers a function for the exchange of a device: Change to Alternative Type
TwinCAT 2 Dialog Change to Alternative Type
If called, the System Manager searches in the procured device ESI (in this example: EL1202-0000) for details of compatible devices contained there. The configuration is changed and the ESI-EEPROM is overwritten at the same time – therefore this process is possible only in the online state (ConfigMode).


EtherCAT subscriber configuration

Commissioning on EtherCAT Master [image] TwinCAT Development Environment [image] EtherCAT subscriber configuration
EtherCAT subscriber configuration
In the left-hand window of the TwinCAT 2 System Manager or the Solution Explorer of the TwinCAT 3 Development Environment respectively, click on the element of the terminal within the tree you wish to configure (in the example: EL3751 Terminal 3).
Branch element as terminal EL3751
In the right-hand window of the TwinCAT System Manager (TwinCAT 2) or the Development Environment (TwinCAT 3), various tabs are now available for configuring the terminal. And yet the dimension of complexity of a subscriber determines which tabs are provided. Thus as illustrated in the example above the terminal EL3751 provides many setup options and also a respective number of tabs are available. On the contrary by the terminal EL1004 for example the tabs “General”, “EtherCAT”, “Process Data” and “Online“ are available only. Several terminals, as for instance the EL6695 provide special functions by a tab with its own terminal name, so “EL6695” in this case. A specific tab “Settings” by terminals with a wide range of setup options will be provided also (e.g. EL3751).
“General” tab
“General” tab
Name | Name of the EtherCAT device
Id | Number of the EtherCAT device
Type | EtherCAT device type
Comment | Here you can add a comment (e.g. regarding the system).
Disabled | Here you can deactivate the EtherCAT device.
Create symbols | Access to this EtherCAT slave via ADS is only available if this control box is activated.
“EtherCAT” tab
“EtherCAT” tab
Type | EtherCAT device type
Product/Revision | Product and revision number of the EtherCAT device
Auto Inc Addr. | Auto increment address of the EtherCAT device. The auto increment address can be used for addressing each EtherCAT device in the communication ring through its physical position. Auto increment addressing is used during the start-up phase when the EtherCAT master allocates addresses to the EtherCAT devices. With auto increment addressing the first EtherCAT slave in the ring has the address 0000hex. For each further slave the address is decremented by 1 (FFFFhex, FFFEhex etc.).
EtherCAT Addr. | Fixed address of an EtherCAT slave. This address is allocated by the EtherCAT master during the start-up phase. Tick the control box to the left of the input field in order to modify the default value.
Previous Port | Name and port of the EtherCAT device to which this device is connected. If it is possible to connect this device with another one without changing the order of the EtherCAT devices in the communication ring, then this combination field is activated and the EtherCAT device to which this device is to be connected can be selected.
Advanced Settings | This button opens the dialogs for advanced settings.
The link at the bottom of the tab points to the product page for this EtherCAT device on the web.
“Process Data” tab
Indicates the configuration of the process data. The input and output data of the EtherCAT slave are represented as CANopen process data objects (Process Data Objects, PDOs). The user can select a PDO via PDO assignment and modify the content of the individual PDO via this dialog, if the EtherCAT slave supports this function.
“Process Data” tab
The process data (PDOs) transferred by an EtherCAT slave during each cycle are user data which the application expects to be updated cyclically or which are sent to the slave. To this end the EtherCAT master (Beckhoff TwinCAT) parameterizes each EtherCAT slave during the start-up phase to define which process data (size in bits/bytes, source location, transmission type) it wants to transfer to or from this slave. Incorrect configuration can prevent successful start-up of the slave.
For Beckhoff EtherCAT EL, ES, EM, EJ and EP slaves the following applies in general:
▪
The input/output process data supported by the device are defined by the manufacturer in the ESI/XML description. The TwinCAT EtherCAT Master uses the ESI description to configure the slave correctly.
▪
The process data can be modified in the System Manager. See the device documentation.
Examples of modifications include: mask out a channel, displaying additional cyclic information, 16-bit display instead of 8-bit data size, etc.
▪
In so-called “intelligent” EtherCAT devices the process data information is also stored in the CoE directory. Any changes in the CoE directory that lead to different PDO settings prevent successful startup of the slave. It is not advisable to deviate from the designated process data, because the device firmware (if available) is adapted to these PDO combinations.
If the device documentation allows modification of process data, proceed as follows (see Figure Configuring the process data).
▪
A: select the device to configure
▪
B: in the “Process Data” tab select Input or Output under SyncManager (C)
▪
D: the PDOs can be selected or deselected
▪
H: the new process data are visible as linkable variables in the System Manager
The new process data are active once the configuration has been activated and TwinCAT has been restarted (or the EtherCAT master has been restarted)
▪
E: if a slave supports this, Input and Output PDO can be modified simultaneously by selecting a so-called PDO record (“predefined PDO settings”).
Configuring the process data
Manual modification of the process data
According to the ESI description, a PDO can be identified as “fixed” with the flag “F” in the PDO overview (Fig. Configuring the process data, J). The configuration of such PDOs cannot be changed, even if TwinCAT offers the associated dialog (“Edit”). In particular, CoE content cannot be displayed as cyclic process data. This generally also applies in cases where a device supports download of the PDO configuration, “G”. In case of incorrect configuration the EtherCAT slave usually refuses to start and change to OP state. The System Manager displays an “invalid SM cfg” logger message: This error message (“invalid SM IN cfg” or “invalid SM OUT cfg”) also indicates the reason for the failed start.
A detailed description can be found at the end of this section.
“Startup” tab
The Startup tab is displayed if the EtherCAT slave has a mailbox and supports the CANopen over EtherCAT (CoE) or Servo drive over EtherCAT protocol. This tab indicates which download requests are sent to the mailbox during startup. It is also possible to add new mailbox requests to the list display. The download requests are sent to the slave in the same order as they are shown in the list.
“Startup” tab
Column
Description
Transition
Transition to which the request is sent. This can either be
▪
the transition from pre-operational to safe-operational (PS), or
▪
the transition from safe-operational to operational (SO).
If the transition is enclosed in “<>” (e.g. <PS>), the mailbox request is fixed and cannot be modified or deleted by the user.
Protocol
Type of mailbox protocol
Index
Index of the object
Data
Date on which this object is to be downloaded.
Comment
Description of the request to be sent to the mailbox
Move Up | This button moves the selected request up by one position in the list.
Move Down | This button moves the selected request down by one position in the list.
New | This button adds a new mailbox download request to be sent during startup.
Delete | This button deletes the selected entry.
Edit | This button edits an existing request.
“CoE - Online” tab
The additional CoE - Online tab is displayed if the EtherCAT slave supports the CANopen over EtherCAT (CoE) protocol. This dialog lists the content of the object list of the slave (SDO upload) and enables the user to modify the content of an object from this list. Details for the objects of the individual EtherCAT devices can be found in the device-specific object descriptions.
“CoE - Online” tab
Object list display
Column | Description
Index | Index and sub-index of the object
Name | Name of the object
Flags | RW | The object can be read, and data can be written to the object (read/write)
 | RO | The object can be read, but no data can be written to the object (read only)
 | P | An additional P identifies the object as a process data object.
Value | Value of the object
Update List | The Update list button updates all objects in the displayed list
Auto Update | If this check box is selected, the content of the objects is updated automatically.
Advanced | The Advanced button opens the Advanced Settings dialog. Here you can specify which objects are displayed in the list.
Dialog “Advanced settings”
Online - via SDO Information | If this option button is selected, the list of the objects included in the object list of the slave is uploaded from the slave via SDO information. The list below can be used to specify which object types are to be uploaded.
Offline - via EDS File | If this option button is selected, the list of the objects included in the object list is read from an EDS file provided by the user.
“Online” tab
“Online” tab
State Machine
Init | This button attempts to set the EtherCAT device to the Init state.
Pre-Op | This button attempts to set the EtherCAT device to the pre-operational state.
Op | This button attempts to set the EtherCAT device to the operational state.
Bootstrap | This button attempts to set the EtherCAT device to the Bootstrap state.
Safe-Op | This button attempts to set the EtherCAT device to the safe-operational state.
Clear Error | This button attempts to delete the fault display. If an EtherCAT slave fails during change of state it sets an error flag. Example: An EtherCAT slave is in PREOP state (pre-operational). The master now requests the SAFEOP state (safe-operational). If the slave fails during change of state it sets the error flag. The current state is now displayed as ERR PREOP. When the Clear Error button is pressed the error flag is cleared, and the current state is displayed as PREOP again.
Current State | Indicates the current state of the EtherCAT device.
Requested State | Indicates the state requested for the EtherCAT device.
DLL Status
Indicates the DLL status (data link layer status) of the individual ports of the EtherCAT slave. The DLL status can have four different states:
Status | Description
No Carrier / Open | No carrier signal is available at the port, but the port is open.
No Carrier / Closed | No carrier signal is available at the port, and the port is closed.
Carrier / Open | A carrier signal is available at the port, and the port is open.
Carrier / Closed | A carrier signal is available at the port, but the port is closed.
File Access over EtherCAT
Download | With this button a file can be written to the EtherCAT device.
Upload | With this button a file can be read from the EtherCAT device.
“DC” tab (Distributed Clocks)
“DC” tab (Distributed Clocks)
Operation Mode
Options (optional):
▪
FreeRun
▪
SM-Synchron
▪
DC-Synchron (Input based)
▪
DC-Synchron
Advanced Settings…
Advanced settings for readjustment of the real time determinant TwinCAT-clock
Detailed information to Distributed Clocks is specified on http://infosys.beckhoff.com:
Fieldbus Components → EtherCAT Terminals → EtherCAT System documentation → EtherCAT basics → Distributed Clocks
Additional information
•
Detailed description of Process Data tab


Detailed description of Process Data tab

Commissioning on EtherCAT Master [image] TwinCAT Development Environment [image] EtherCAT subscriber configuration [image] Detailed description of Process Data tab
Detailed description of Process Data tab
Sync Manager
Lists the configuration of the Sync Manager (SM).
If the EtherCAT device has a mailbox, SM0 is used for the mailbox output (MbxOut) and SM1 for the mailbox input (MbxIn).
SM2 is used for the output process data (outputs) and SM3 (inputs) for the input process data.
If an input is selected, the corresponding PDO assignment is displayed in the PDO Assignment list below.
PDO Assignment
PDO assignment of the selected Sync Manager. All PDOs defined for this Sync Manager type are listed here:
▪
If the output Sync Manager (outputs) is selected in the Sync Manager list, all RxPDOs are displayed.
▪
If the input Sync Manager (inputs) is selected in the Sync Manager list, all TxPDOs are displayed.
The selected entries are the PDOs involved in the process data transfer. In the tree diagram of the System Manager these PDOs are displayed as variables of the EtherCAT device. The name of the variable is identical to the Name parameter of the PDO, as displayed in the PDO list. If an entry in the PDO assignment list is deactivated (not selected and greyed out), this indicates that the input is excluded from the PDO assignment. In order to be able to select a greyed out PDO, the currently selected PDO has to be deselected first.
Activation of PDO assignment
✓
If you have changed the PDO assignment, in order to activate the new PDO assignment,
1.
the EtherCAT slave has to run through the PS status transition cycle (from pre-operational to safe-operational) once (see Online tab),
2.
and the System Manager has to reload the EtherCAT slaves
( [image] button for TwinCAT 2 or [image] button for TwinCAT 3)
PDO list
List of all PDOs supported by this EtherCAT device. The content of the selected PDOs is displayed in the PDO Content list. The PDO configuration can be modified by double-clicking on an entry.
Column | Description
Index | PDO index.
Size | Size of the PDO in bytes.
Name | Name of the PDO. If this PDO is assigned to a Sync Manager, it appears as a variable of the slave with this parameter as the name.
Flags | F | Fixed content: The content of this PDO is fixed and cannot be changed by the System Manager.
 | M | Mandatory PDO. This PDO is mandatory and must therefore be assigned to a Sync Manager! Consequently, this PDO cannot be deleted from the PDO Assignment list
SM | Sync Manager to which this PDO is assigned. If this entry is empty, this PDO does not take part in the process data traffic.
SU | Sync unit to which this PDO is assigned.
PDO Content
Indicates the content of the PDO. If flag F (fixed content) of the PDO is not set the content can be modified.
Download
If the device is intelligent and has a mailbox, the configuration of the PDO and the PDO assignments can be downloaded to the device. This is an optional feature that is not supported by all EtherCAT slaves.
PDO Assignment
If this check box is selected, the PDO assignment that is configured in the PDO Assignment list is downloaded to the device on startup. The required commands to be sent to the device can be viewed in the Startup tab.
PDO Configuration
If this check box is selected, the configuration of the respective PDOs (as shown in the PDO list and the PDO Content display) is downloaded to the EtherCAT slave.


EtherCAT basics

Commissioning on EtherCAT Master [image] EtherCAT basics
EtherCAT basics
Please refer to the EtherCAT System Documentation for the EtherCAT fieldbus basics.


EtherCAT cabling – wire-bound

Commissioning on EtherCAT Master [image] EtherCAT cabling – wire-bound
EtherCAT cabling – wire-bound
The cable length between two EtherCAT devices must not exceed 100 m. This results from the FastEthernet technology, which, above all for reasons of signal attenuation over the length of the cable, allows a maximum link length of 5 + 90 + 5 m if cables with appropriate properties are used. See also the Design recommendations for the infrastructure for EtherCAT/Ethernet.
Cables and connectors
For connecting EtherCAT devices only Ethernet connections (cables + plugs) that meet the requirements of at least category 5 (CAt5) according to EN 50173 or ISO/IEC 11801 should be used. EtherCAT uses 4 wires for signal transfer.
EtherCAT uses RJ45 plug connectors, for example. The pin assignment is compatible with the Ethernet standard (ISO/IEC 8802-3).
Pin | Color of conductor | Signal | Description
1 | yellow | TD + | Transmission Data +
2 | orange | TD - | Transmission Data -
3 | white | RD + | Receiver Data +
6 | blue | RD - | Receiver Data -
Due to automatic cable detection (auto-crossing) symmetric (1:1) or cross-over cables can be used between EtherCAT devices from Beckhoff.
Recommended cables
Suitable cables for the connection of EtherCAT devices can be found on the Beckhoff website!
E-Bus supply
A bus coupler can supply the EL terminals added to it with the E-bus system voltage of 5 V; a coupler is thereby loadable up to 2 A as a rule (see details in respective device documentation).
Information on how much current each EL terminal requires from the E-bus supply is available online and in the catalogue. If the added terminals require more current than the coupler can supply, then power feed terminals (e.g. EL9410) must be inserted at appropriate places in the terminal strand.
The pre-calculated theoretical maximum E-Bus current is displayed in the TwinCAT System Manager. A shortfall is marked by a negative total amount and an exclamation mark; a power feed terminal is to be placed before such a position.
System manager current calculation
Note
Malfunction possible!
The same ground potential must be used for the E-Bus supply of all EtherCAT terminals in a terminal block!


General notes for setting the watchdog

Commissioning on EtherCAT Master [image] General notes for setting the watchdog
General notes for setting the watchdog
ELxxxx terminals are equipped with a safety feature (watchdog) that switches off the outputs after a specifiable time e.g. in the event of an interruption of the process data traffic, depending on the device and settings, e.g. in OFF state.
The EtherCAT slave controller (ESC) in the EL2xxx terminals features two watchdogs:
▪
SM watchdog (default: 100 ms)
▪
PDI watchdog (default: 100 ms)
SM watchdog (SyncManager Watchdog)
The SyncManager watchdog is reset after each successful EtherCAT process data communication with the terminal. If no EtherCAT process data communication takes place with the terminal for longer than the set and activated SM watchdog time, e.g. in the event of a line interruption, the watchdog is triggered and the outputs are set to FALSE. The OP state of the terminal is unaffected. The watchdog is only reset after a successful EtherCAT process data access. Set the monitoring time as described below.
The SyncManager watchdog monitors correct and timely process data communication with the ESC from the EtherCAT side.
PDI watchdog (Process Data Watchdog)
If no PDI communication with the EtherCAT slave controller (ESC) takes place for longer than the set and activated PDI watchdog time, this watchdog is triggered.
PDI (Process Data Interface) is the internal interface between the ESC and local processors in the EtherCAT slave, for example. The PDI watchdog can be used to monitor this communication for failure.
The PDI watchdog monitors correct and timely process data communication with the ESC from the application side.
The settings of the SM- and PDI-watchdog must be done for each slave separately in the TwinCAT System Manager.
EtherCAT tab -> Advanced Settings -> Behavior -> Watchdog
Notes:
▪
the multiplier is valid for both watchdogs.
▪
each watchdog has its own timer setting, the outcome of this in summary with the multiplier is a resulting time.
▪
Important: the multiplier/timer setting is only loaded into the slave at the start up, if the checkbox is activated.
If the checkbox is not activated, nothing is downloaded and the ESC settings remain unchanged.
Multiplier
Multiplier
Both watchdogs receive their pulses from the local terminal cycle, divided by the watchdog multiplier:
1/25 MHz * (watchdog multiplier + 2) = 100 µs (for default setting of 2498 for the multiplier)
The standard setting of 1000 for the SM watchdog corresponds to a release time of 100 ms.
The value in multiplier + 2 corresponds to the number of basic 40 ns ticks representing a watchdog tick.
The multiplier can be modified in order to adjust the watchdog time over a larger range.
Example “Set SM watchdog”
This checkbox enables manual setting of the watchdog times. If the outputs are set and the EtherCAT communication is interrupted, the SM watchdog is triggered after the set time and the outputs are erased. This setting can be used for adapting a terminal to a slower EtherCAT master or long cycle times. The default SM watchdog setting is 100 ms. The setting range is 0...65535. Together with a multiplier with a range of 1...65535 this covers a watchdog period between 0...~170 seconds.
Calculation
Multiplier = 2498 → watchdog base time = 1 / 25 MHz * (2498 + 2) = 0.0001 seconds = 100 µs
SM watchdog = 10000 → 10000 * 100 µs = 1 second watchdog monitoring time
SmallWarningYellow CAUTION
Undefined state possible!
The function for switching off of the SM watchdog via SM watchdog = 0 is only implemented in terminals from version -0016. In previous versions this operating mode should not be used.
SmallWarningYellow CAUTION
Damage of devices and undefined state possible!
If the SM watchdog is activated and a value of 0 is entered the watchdog switches off completely. This is the deactivation of the watchdog! Set outputs are NOT set in a safe state, if the communication is interrupted.


EtherCAT State Machine

Commissioning on EtherCAT Master [image] EtherCAT State Machine
EtherCAT State Machine
The state of the EtherCAT slave is controlled via the EtherCAT State Machine (ESM). Depending upon the state, different functions are accessible or executable in the EtherCAT slave. Specific commands must be sent by the EtherCAT master to the device in each state, particularly during the bootup of the slave.
A distinction is made between the following states:
▪
Init
▪
Pre-Operational
▪
Safe-Operational and
▪
Operational
▪
Boot
The regular state of each EtherCAT slave after bootup is the OP state.
States of the EtherCAT State Machine
Init
After switch-on the EtherCAT slave in the Init state. No mailbox or process data communication is possible. The EtherCAT master initializes sync manager channels 0 and 1 for mailbox communication.
Pre-Operational (Pre-Op)
During the transition between Init and Pre-Op the EtherCAT slave checks whether the mailbox was initialized correctly.
In Pre-Op state mailbox communication is possible, but not process data communication. The EtherCAT master initializes the sync manager channels for process data (from sync manager channel 2), the FMMU channels and, if the slave supports configurable mapping, PDO mapping or the sync manager PDO assignment. In this state the settings for the process data transfer and perhaps terminal-specific parameters that may differ from the default settings are also transferred.
Safe-Operational (Safe-Op)
During transition between Pre-Op and Safe-Op the EtherCAT slave checks whether the sync manager channels for process data communication and, if required, the distributed clocks settings are correct. Before it acknowledges the change of state, the EtherCAT slave copies current input data into the associated DP-RAM areas of the EtherCAT slave controller (ECSC).
In Safe-Op state mailbox and process data communication is possible, although the slave keeps its outputs in a safe state, while the input data are updated cyclically.
Outputs in SAFEOP state
The default set watchdog monitoring sets the outputs of the module in a safe state - depending on the settings in SAFEOP and OP - e.g. in OFF state. If this is prevented by deactivation of the watchdog monitoring in the module, the outputs can be switched or set also in the SAFEOP state.
Operational (Op)
Before the EtherCAT master switches the EtherCAT slave from Safe-Op to Op it must transfer valid output data.
In the Op state the slave copies the output data of the masters to its outputs. Process data and mailbox communication is possible.
Boot
In the Boot state the slave firmware can be updated. The Boot state can only be reached via the Init state.
In the Boot state mailbox communication via the file access over EtherCAT (FoE) protocol is possible, but no other mailbox communication and no process data communication.


CoE Interface

Commissioning on EtherCAT Master [image] CoE Interface
CoE Interface
General description
The CoE interface (CAN application protocol over EtherCAT)) is used for parameter management of EtherCAT devices. EtherCAT slaves or the EtherCAT master manage fixed (read only) or variable parameters which they require for operation, diagnostics or commissioning.
CoE parameters are arranged in a table hierarchy. In principle, the user has read access via the fieldbus. The EtherCAT master (TwinCAT System Manager) can access the local CoE lists of the slaves via EtherCAT in read or write mode, depending on the attributes.
Different CoE parameter types are possible, including string (text), integer numbers, Boolean values or larger byte fields. They can be used to describe a wide range of features. Examples of such parameters include manufacturer ID, serial number, process data settings, device name, calibration values for analog measurement or passwords.
The order is specified in two levels via hexadecimal numbering: (main)index, followed by subindex. The value ranges are
▪
Index: 0x0000 …0xFFFF (0...65535dez)
▪
SubIndex: 0x00…0xFF (0...255dez)
A parameter localized in this way is normally written as 0x8010:07, with preceding “0x” to identify the hexadecimal numerical range and a colon between index and subindex.
The relevant ranges for EtherCAT fieldbus users are:
▪
0x1000: This is where fixed identity information for the device is stored, including name, manufacturer, serial number etc., plus information about the current and available process data configurations.
▪
0x8000: This is where the operational and functional parameters for all channels are stored, such as filter settings or output frequency.
Other important ranges are:
▪
0x4000: here are the channel parameters for some EtherCAT devices. Historically, this was the first parameter area before the 0x8000 area was introduced. EtherCAT devices that were previously equipped with parameters in 0x4000 and changed to 0x8000 support both ranges for compatibility reasons and mirror internally.
▪
0x6000: Input PDOs (“input” from the perspective of the EtherCAT master)
▪
0x7000: Output PDOs (“output” from the perspective of the EtherCAT master)
Availability
Not every EtherCAT device must have a CoE list. Simple I/O modules without dedicated processor usually have no variable parameters and therefore no CoE list.
If a device has a CoE list, it is shown in the TwinCAT System Manager as a separate tab with a listing of the elements:
“CoE Online” tab
The figure above shows the CoE objects available in device “EL2502”, ranging from 0x1000 to 0x1600. The subindices for 0x1018 are expanded.
Data management and function “NoCoeStorage”
Some parameters, particularly the setting parameters of the slave, are configurable and writeable. This can be done in write or read mode
▪
via the System Manager (Fig. “CoE Online” tab) by clicking
This is useful for commissioning of the system/slaves. Click on the row of the index to be parameterized and enter a value in the “SetValue” dialog.
▪
from the control system/PLC via ADS, e.g. through blocks from the TcEtherCAT.lib library
This is recommended for modifications while the system is running or if no System Manager or operating staff are available.
Data management
If slave CoE parameters are modified online, Beckhoff devices store any changes in a fail-safe manner in the EEPROM, i.e. the modified CoE parameters are still available after a restart.
The situation may be different with other manufacturers.

An EEPROM is subject to a limited lifetime with respect to write operations. From typically 100,000 write operations onwards it can no longer be guaranteed that new (changed) data are reliably saved or are still readable. This is irrelevant for normal commissioning. However, if CoE parameters are continuously changed via ADS at machine runtime, it is quite possible for the lifetime limit to be reached. Support for the NoCoeStorage function, which suppresses the saving of changed CoE values, depends on the firmware version.
Please refer to the technical data in this documentation as to whether this applies to the respective device.
•
If the function is supported: the function is activated by entering the code word 0x12345678 once in CoE 0xF008 and remains active as long as the code word is not changed. After switching the device on it is then inactive. Changed CoE values are not saved in the EEPROM and can thus be changed any number of times.
•
Function is not supported: continuous changing of CoE values is not permissible in view of the lifetime limit.
Startup list
Changes in the local CoE list of the terminal are lost if the terminal is replaced. If a terminal is replaced with a new Beckhoff terminal, it will have the default settings. It is therefore advisable to link all changes in the CoE list of an EtherCAT slave with the Startup list of the slave, which is processed whenever the EtherCAT fieldbus is started. In this way a replacement EtherCAT slave can automatically be parameterized with the specifications of the user.
If EtherCAT slaves are used which are unable to store local CoE values permanently, the Startup list must be used.
Recommended approach for manual modification of CoE parameters
▪
Make the required change in the System Manager
The values are stored locally in the EtherCAT slave
▪
If the value is to be stored permanently, enter it in the Startup list.
The order of the Startup entries is usually irrelevant.
Startup list in the TwinCAT System Manager
The Startup list may already contain values that were configured by the System Manager based on the ESI specifications. Additional application-specific entries can be created.
Online/offline list
While working with the TwinCAT System Manager, a distinction has to be made whether the EtherCAT device is “available”, i.e. switched on and linked via EtherCAT and therefore online, or whether a configuration is created offline without connected slaves.
In both cases a CoE list as shown in Fig. “CoE online tab” is displayed. The connectivity is shown as offline/online.
▪
If the slave is offline
–
The offline list from the ESI file is displayed. In this case modifications are not meaningful or possible.
–
The configured status is shown under Identity.
–
No firmware or hardware version is displayed, since these are features of the physical device.
–
Offline is shown in red.
Offline list
▪
If the slave is online
–
The actual current slave list is read. This may take several seconds, depending on the size and cycle time.
–
The actual identity is displayed
–
The firmware and hardware version of the equipment according to the electronic information is displayed
–
Online is shown in green.
Online list
Channel-based order
The CoE list is available in EtherCAT devices that usually feature several functionally equivalent channels. For example, a 4-channel analog 0...10 V input terminal also has four logical channels and therefore four identical sets of parameter data for the channels. In order to avoid having to list each channel in the documentation, the placeholder “n” tends to be used for the individual channel numbers.
In the CoE system 16 indices, each with 255 subindices, are generally sufficient for representing all channel parameters. The channel-based order is therefore arranged in 16dec/10hex steps. The parameter range 0x8000 exemplifies this:
▪
Channel 0: parameter range 0x8000:00 ... 0x800F:255
▪
Channel 1: parameter range 0x8010:00 ... 0x801F:255
▪
Channel 2: parameter range 0x8020:00 ... 0x802F:255
▪
...
This is generally written as 0x80n0.
Detailed information on the CoE interface can be found in the EtherCAT system documentation on the Beckhoff website.


Distributed Clock

Commissioning on EtherCAT Master [image] Distributed Clock
Distributed Clock
The distributed clock represents a local clock in the EtherCAT slave controller (ESC) with the following characteristics:
▪
Unit 1 ns
▪
Zero point 1.1.2000 00:00
▪
Size 64 bit (sufficient for the next 584 years; however, some EtherCAT slaves only offer 32-bit support, i.e. the variable overflows after approx. 4.2 seconds)
▪
The EtherCAT master automatically synchronizes the local clock with the master clock in the EtherCAT bus with a precision of < 100 ns.
For detailed information please refer to the EtherCAT system description.


Housing

Housing
Housing
Dimensions: ELM terminals
Additional information
•
Housing data
•
Notes on connection technology
•
Accessories


Housing data

Housing [image] Housing data
Housing data
Housing data
ELM-Type | Plug-/ Connector | Width | Height | Depth
ELM3002-0000 ELM3004-0000 ELM3102-0000 ELM3104-0000 ELM3502-0000 ELM3504-0000 ELM3602-0000 ELM3604-0000 ELM3702-0000 ELM3704-0000 | push-in, for direct wiring, plug connector detachable for service | 33 mm | 100 mm | 95 mm
ELM3602-0002 ELM3604-0002 | BNC (female) |  |  | 115 mm
ELM3704-0001 | LEMO (female), series B multipole, size 1, 8 pol. “308”(1 |  |  | 98 mm
1) | Socket 8 pol. LEMO ECG


Notes on connection technology

Housing [image] Notes on connection technology
Notes on connection technology
Connection type: Push-in with service plug
The wires are plugged in directly; for solid wires no tools are required, i.e. after the insulation has been stripped, the wire is simply pushed into the contact point. The same principle applies for the ferrule. Free stranded wire ends can also be connected in this way; in this case the wire clamping mechanism has to be opened by operating the pushing device.
Like in standard terminals, the wires are released via the contact release device, using a screwdriver or pushing device.
The cables must not be pulled/ pushed live or under load.
For maintenance purposes, e.g. during service, the entire plug-in body can be removed from the Beckhoff terminal without releasing the individual wires. Use a screwdriver (e.g. Beckhoff ZB8700) to release the central release device and pull the cables to release the connector body.
Additionally the service plug don’t have specified switching power, also it must not be pulled/ pushed live or under load, too.
The permitted conductor cross-sections and the strip length are shown in the following table.
Wire cross-section (solid wire) | 0.2 ... 1.5 mm2
Wire cross-section (stranded wire) | 0.2 ... 1.5 mm2
Wire cross-section (stranded) | 0.25 ... 0.75 mm2 (with ferrule with plastic collar)
Wire cross-section (stranded wire) | 0.25 ... 1.5 mm2 (with ferrule without plastic collar)
Current rating, permanent | 5 A
Conductor (AWG) | 24 – 14 | 14: THHN, THWN
Strip length | 8 ... 9 mm / 0.31 – 0.35 in
Releasing the contact
The push-in connector is supplied with the terminal.
The push-in connector is designed as a service plug.
Maximum number of mating cycles: 10
The connector with connected wires can be removed by pushing the unlocking tab (red) in the direction of the arrow, e.g. with a screwdriver, thereby releasing the unlocking device.
Push in connector take out.png
Meticulous cleanliness must be ensured when the connector is re-inserted. Do not touch the pins in the device tray. Push in the connector until it latches audibly and the front of the plug is flush with the ELM housing.
Connection type: BNC
No connector plug is provided for terminals with BNC socket (coaxial). A wide range of BNC plug connectors is available commercially.
Push the connector without tilting, and lock the bayonet closure by turning it 90°. Release in reverse order. Ensure cleanliness.
Note the installation instructions for connector assembly.
Impedance data (50 Ω, 75 Ω) are only relevant for high-frequency applications, i.e. for frequencies in the MHz range or above. Unless specified otherwise, Beckhoff Terminals therefore do not feature 50 or 75 Ω power matching.
Connection type: LEMO
No connector plug is provided for terminals with LEMO connection. LEMO offers a wide range of connectors, from which the best match can be selected for the respective cable (depending on sealing, cable diameter, housing material, angled/straight).
Beckhoff currently (2019) does not offer LEMO plug connectors for resale.
Follow the installation instructions provided by LEMO for connector assembly.
LEMO series B connectors are self-locking in the socket, i.e. they do not have to be tightened. To release the connector, pull the housing, which automatically releases the lock.


Accessories

Housing [image] Accessories
Accessories
The following accessories are currently available for the analog input terminals of the ELM3xxx series
Additional information
•
Shield connection ZS9100-0002
•
Shielding hood ZS9100-0003
•
Replacement push-in ZS2001-000x


Shield connection ZS9100-0002

Housing [image] Accessories [image] Shield connection ZS9100-0002
Shield connection ZS9100-0002
The shield connection is an optional component, which can be installed on the underside of the ELMxxxx housing. It has to be ordered separately.
It is used as a low-resistance earthing connection at the housing, to deal with electrical interference signals arriving via the cable screen. The fault signals are then directed to the DIN rail via the metallic ELM housing and the integrated grounding springs. For this to work, the DIN rail/control cabinet also has to have a low-resistance connection, of course.
Note: Electrical faults usually occur in the form of high-frequency signals. Therefore, it is important to not only ensure a good low-resistance connection for DC signals (continuity test with a multimeter), but also to ensure its effectiveness for high-frequency signals in the form of a low-impedance connection. This should be tested with special measuring devices, unless the general installation instructions regarding EMC-compliant control cabinet construction are observed.
The shield connection should be used as follows:
▪
Lever off the plastic cover from the ELM housing and retain if for later reuse, if required
▪
Attach the shield connection with the screw provided. Clean the contact surfaces, as appropriate. The second screw hole remains free in case a PE connection is required.
▪
Strip the signal cable, feed it through the shield clamp and hand-tighten the clamp (recommended screw tightening torque: 0.5 Nm)
▪
Apply the signal cable wires at the plug connector.
▪
For disassembly, proceed in reverse order.
Note: the shield connection does not act as strain relief!
Alternative shield connection methods for analog signal lines:
▪
Beckhoff shielding connection system ZB8500 https://www.beckhoff.com/zb8500/
▪
Separate shield connection depending on requirements


Shielding hood ZS9100-0003

Housing [image] Accessories [image] Shielding hood ZS9100-0003
Shielding hood ZS9100-0003
The shielding hood is an optional component for the ELMxxxx housing series. It has to be ordered separately.
It does not affect the visibility of the LED displays of the module.
The shielding hood has two purposes
▪
Electromagnetic shielding of faults
If push-in connectors are used, they represent a gateway for faults in the terminal, due to the fact that they are made of plastic. The shielding hood can be installed (either right away or retrospectively) in order to form an enclosed metallic cage around the terminal and the signal cable.
Alternatively, ELMxxxx terminals with shielded plug connectors can be used (e.g. LEMO, BNC), in which case the shielding hood is not required.
▪
Thermal shielding for thermocouple measurements
If the ELM3xxx terminal is used for measuring temperatures with thermocouples, the integrated cold junction measurement contributes significantly to the overall uncertainty. Thermal turbulence caused by air flowing past and radiant heat can lead to large temperature gradients around the plug, resulting in fluctuating temperature measurements. The shielding hood facilitates a thermally stabilized environment around the plug, which helps to increase the measuring accuracy.
Between one and four commercially available signal lines up to approx. 7 mm shield diameter (usually corresponds to approx. 9 mm outer diameter) can be connected.
Technical data | ZS9100-0003
Weight | approx. 190 g
Dimensions (W x H x D) | 26 x 145 x 93 mm effective extended width after mounting: 74 mm
Permissible ambient temperature range during operation and storage | -40…+85 °C
Vibration/shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27 Usage restriction: see below
Protection class | IP 20
Installation position | variable
Approval | CE
The shielding hood should be installed as follows:
▪
Use a screwdriver to lever off the two painted plastic covers on the top and bottom of the ELM housing; retain the covers for later reuse
▪
Slide on the shield connection and fasten it with the three screws provided. The fourth screw hole is intended for a PE connection, if required.
▪
Remove the sheathing from the signal cables and insert the wires into the connectors (A). Then push the shield braid into the EMC clamp (B) and fasten the cable to the strain relief clip (C) using the cable tie provided. Follow the cable manufacturer's recommendations for the bending radius.
▪
The shield braid should rest on the conductive foam block (D). This block ensures EMC-compliant sealing when the hood is closed.
▪
Position the hood and hand-tighten it with the knurled screw. Ensure that the unpainted sections and the foam block are in close contact.
▪
For disassembly, proceed in reverse order.
Any component identification should be replicated on the hood.
Note
Note for use under vibration load
An application of the ELM module with mounted shielding hood ZS9100-0003 under vibration and shock effect in the direction of DIN rail track (red arrow) is, regardless of the installation position, not allowed.
If vibration / shock inevitably occurs during operation, an installation position must be selected which does not load the ELM module and accordingly the shielding hood in the indicated direction of the arrow.
Basically, an additional mechanical support of the shielding hood and cables respectively is recommended for vibration / shock.
Also see about this
•
Housing


Replacement push-in ZS2001-000x

Housing [image] Accessories [image] Replacement push-in ZS2001-000x
Replacement push-in ZS2001-000x
The black push-in service plugs for ELM/EKM modules can be ordered separately as spare parts. Per unit 10 pieces are included.
ZS2001-000x
Number of poles | Designation
2 | ZS2001-0006
4 | ZS2001-0007
6 | ZS2001-0008
10 | ZS2001-0009


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Common notes to the power contacts
•
Installation positions
•
Mounting of Passive Terminals
•
Notes regarding connectors and wiring
•
Shielding concept
•
Power supply, potential groups
•
ELM/EKM terminal mounting on DIN rail
•
Protective earth (PE)
•
Connection notes for 20 mA measurement
•
LED indicators - meanings
•
Power contacts ELM314x


Common notes to the power contacts

Mounting and wiring [image] Common notes to the power contacts
Common notes to the power contacts
If the ELM module or the terminal doesn’t have own wheeling of electricity or supply of the power contacts, the terminal on its right mustn’t have sticking out power contacts on the left side. They would be free accessible if the ELM module or the terminal would be pulled out from the DIN rail.
Also see about this
•
ELM/EKM terminal mounting on DIN rail


Installation positions

Mounting and wiring [image] Installation positions
Installation positions
Note
Constraints regarding installation position and operating temperature range
Please refer to the technical data for a terminal to ascertain whether any restrictions regarding the installation position and/or the operating temperature range have been specified. When installing high power dissipation terminals ensure that an adequate spacing is maintained between other components above and below the terminal in order to guarantee adequate ventilation!
Optimum installation position (standard)
The optimum installation position requires the mounting rail to be installed horizontally and the connection surfaces of the EL/KL terminals to face forward (see Fig. “Recommended distances for standard installation position”). The terminals are ventilated from below, which enables optimum cooling of the electronics through convection. "From below" is relative to the acceleration of gravity.
Recommended distances for standard installation position
Compliance with the distances shown in Fig. “Recommended distances for standard installation position” is recommended.
Other installation positions
All other installation positions are characterized by different spatial arrangement of the mounting rail - see Fig “Other installation positions”.
The minimum distances to ambient specified above also apply to these installation positions.
Other installation positions


Mounting of Passive Terminals

Mounting and wiring [image] Mounting of Passive Terminals
Mounting of Passive Terminals
Hint for mounting passive terminals
EtherCAT Bus Terminals (ELxxxx / ESxxxx), which do not take an active part in data transfer within the bus terminal block are so called Passive Terminals. The Passive Terminals have no current consumption out of the E-Bus To ensure an optimal data transfer, you must not directly string together more than 2 Passive Terminals!
Examples for mounting passive terminals (highlighted)
Correct configuration
Incorrect configuration


Notes regarding connectors and wiring

Mounting and wiring [image] Notes regarding connectors and wiring
Notes regarding connectors and wiring
It is in the very nature of EtherCAT I/O modules/terminals/boxes that they have two connection sides: one to the fieldbus for communication with the module, which is obligatory, the other to the signal/sensor/actuator to facilitate proper use of the module. The “outer” connection side usually features contacting options for connecting outgoing wires.
Only few I/O devices do not have a second side. Examples include the EL6070 license key terminal and the EL6090 display terminal.
Notes and suggestions for dealing with the connection options are provided below
▪
Manufacturer specifications/notes for connection options must be followed. Any special tools that may have been provided must be used as intended, so that gas-tightness is ensured through the crimping pressure.
▪
Any detachable connection system is subject to a specified maximum number of connection cycles. Each connection/disconnection operation results in wear through friction, mechanical stretching/relaxation, possibly ingress of contaminants/gases/liquids/condensation, contact discharge, modification of the electrical properties and of the contact point (ohmic contact resistance). In other words, releasing/connecting a contact results in mechanical, chemical and therefore ultimately electrical changes.
In terms of the application scenario it is therefore important to select suitable connection systems or devices with suitable connection systems:
–
For connections that are more or less permanent, it may make sense to use connectors/contacts with a maximum number of mating cycles (as specified by the manufacturer) of 10 to 100 cycles. This may be the case if devices are installed/wired only once, and over the entire lifetime rewiring is only expected to become necessary during maintenance work.
–
For connections that have to be detached on a regular basis, connectors/contacts with a maximum number of mating cycles of 1,000 or higher should be selected. Such connections can typically be found in laboratory environments, where the cabling may be changed several times each day but high-quality contact must nevertheless be ensured over many years.
▪
When handling and assembling connectors/contacts it is essential to avoid contact with hand perspiration/liquids, even for low-tech connections (open stranded wire, cage clamp/push-in). Acidic/alkaline liquids may have a very aggressive effect on the contact surface and quickly lead to structural changes and oxidation layers. These are very disruptive for analog measurements, particularly since they undermine the reproducibility of measurements and can therefore result (if known) in large systematic measurement uncertainty. It may be possible to rectify the problem by thorough follow-up cleaning.
▪
The actual/expected load during operation must be taken into account when selecting connectors.
▪
Abnormal vibrations can lead to microfriction/corrosion and change the electrical properties, potentially resulting in complete loss of contact.
▪
Temperature variations affect the mechanical strength of the connection and the spring forces in metallic components.
▪
Exposure to gas or liquid can damage the connection, particularly if the gas or liquid penetrates to the actual contact region and is unable to escape from there.
▪
Of high relevance for analog measurements is the electrical quality of the connection, both in the short term during commissioning and over the service life under external influences and perhaps repeated mating cycles. This is expressed in the repeatability of the transition. The influence should be checked against the expected accuracy. Of particular relevance is the (frequency dependent) contact resistance. Effects can be:
–
Increasing the contact resistance results in a voltage drop when power is transmitted, potentially leading to critical self-heating.
–
The internal voltage drop can distort corresponding measurements. In order to avoid negative effects, 4/5/6-wire connections should be used in SG/resistance measurements, since non-live contacts are no longer affected by a distorting voltage drop. The popular 3-wire connection for resistance measurement (PT100, PT1000 etc.) does not provide absolute protection, since the singular line cannot be diagnosed. Current/voltage measurements in industrial environments are less sensitive to contact changes.
–
A defective contact surface can lead to random resistance values, depending on the contact position and temperature. This makes reproducible measurements difficult.
▪
The effort for establishing the connection, including assembling the cables and connectors, generally increases with increasing transmission quality requirements. This applies to the tools, diligence and time required. Examples:
–
Cage clamp/push-in connections (e.g. Beckhoff EL terminals), which are common in automation applications, can be established or released in a few seconds with or without ferrule. A screwdriver or push pin is sufficient. On the other hand, in many cases the (ohmic) repeatability is insufficient for high-precision measurements in the SG/R range.
–
Some 10 minutes and costs of some 10 euros should be assumed for assembly a lab-standard LEMO/ODU connector (Beckhoff ELM3704-0001), depending on the number of poles. The result is a top-quality connection system with a high number of permissible mating cycles.
–
An intermediate solution can be field-configurable M8/M12 connections. For reasons of tightness, they are more elaborate to assemble (soldering or insulation displacement contact, if necessary), although the maximum number of mating cycles is similar to maintenance connectors.
▪
A pre-assembled connection should be subjected to electrical/mechanical testing before commissioning: visual inspection, pull-out test, crimp height measurement, resistance measurement etc.


Shielding concept

Mounting and wiring [image] Shielding concept
Shielding concept
Together with the shield busbar, the prefabricated cables from Beckhoff Automation offer optimum protection against electromagnetic interference.
It is highly recommended to apply the shield as close as possible to the terminal, in order to minimize operational disturbances.
Connection of the motor cable to the shield busbar
Fasten the shield busbar supports 1 to the DIN rail 2. The mounting rail 2 must be in contact with the metallic rear wall of the control cabinet over a wide area. Install the shield busbar 3 as shown below.
As an alternative, a shield busbar clamp 3a can be screwed directly to the metallic rear wall of the control cabinet (fig. “shield busbar clamp”)
Shield busbar
Shield busbar clamp
Connect the cores 4 of the motor cable 5, then attach the copper-sheathed end 6 of the motor cable 5 with the shield clamp 7 to the shield busbar 3 or shield busbar clamp 3a. Tighten the screw 8 to the stop.
Fasten the PE clamp 9 to the shield busbar 3 or shield busbar clamp 3a. Clamp the PE core 10 of the motor cable 5 under the PE clamp 9.
Shield connection
Connection of the feedback cable to the motor
Twisting of the feedback cable cores
The feedback cable cores should be twisted, in order to avoid operational disturbances.
When screwing the feedback plug to the motor, the shield of the feedback cable is connected via the metallic plug fastener.
On the terminal side the shield can also be connected. Connect the cores of the feedback cable and attach the copper-sheathed end of the feedback cable to the shield busbar 3 or shield busbar clamp 3a with the shield clamp 7. The motor cable and the feedback cable can be connected to the shield clamp 7 with the screw 8.


Power supply, potential groups

Mounting and wiring [image] Power supply, potential groups
Power supply, potential groups
The terminals from the ELM3xxx series have different structures depending on their function. In general the electronics consists internally
▪
of a communication section on the E-bus, the so-called bus side
This section is directly connected to the internal 5 V supply of the E-bus. It is not directly accessible from the user side.
▪
of a signal section for the connection of the input/output signals, the so-called field side.
The two sections are always electrically isolated.
Depending on the module the internal electronics can be powered via the E-bus, via the optional power contacts, or via both. See the relevant notes about this in the respective device specification.
The plug employed can also affect the potential groups.
The external system GND (DIN rail, SGND, PE, FE) is always present and represents the reference ground.
In the following the permissible potential difference is referred to only as "Insulation"; the exact specification (value, type and, if applicable, insulating strength) can be found in the respective terminal specifications.
The following potential schemata may be specified for the ELM3xxx:
Variant A
Properties:
▪
electrical isolation at a specified level
–
between field and E-bus: yes
–
between field and SGND: yes
–
between E-bus and SGND: yes
–
between the channels: no
▪
Power contacts in use: no
▪
Connection type: Push-in
▪
Applies to:
ELM300x-0000, ELM310x-0000, ELM350x-0000, ELM360x-0000, ELM370x-0000
Variant B
Properties:
▪
electrical isolation at a specified level
–
between field and E-bus: yes
–
between field and SGND: no, overvoltage protection diode to internal analog GND (AGND)
–
between E-bus and SGND: yes
–
between the channels: no
▪
Power contacts in use: no
▪
Connection type: ELM3xxx-0002 BNC, isolated from housing, BNC shield is internally connected to AGND
▪
Applies to: ELM360x-0002
Variant C
Properties:
▪
electrical isolation at a specified level
–
between field and E-bus: yes
–
between field and SGND: yes
–
between E-bus and SGND: yes
–
between the channels: no
▪
Power contacts in use: yes, but not used for internal supply, not electrically connected, only pass-through
▪
Connection type: Push-in
▪
Applies to: ELM314x-0000


ELM/EKM terminal mounting on DIN rail

Mounting and wiring [image] ELM/EKM terminal mounting on DIN rail
ELM/EKM terminal mounting on DIN rail
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Assembly
The ELM terminal modules are locked to commercially available 35 mm mounting rails (DIN rails according to EN 60715) as following described:
▪
The The ELM terminal module can easily be latched onto the DIN rail. Thererfore the clips of the module on top and down side have to be opened first:
Opening the clips on top and down side by lifting them e.g. with a screw driver
▪
Insert the ELM terminal module to other already on the DIN rail arranged moduls together with tongue and groove and push the terminals against the mounting rail, until it clicks onto the touchdown point of the mounting rail. Then close the both clips on top and down side of the module respectively:
Push-in of the ELM terminal module and closing the mounting rail clips top and down
▪
During closing of the both clips there mustn't be a disruptive mechanical resistance being noticeable. The clips have to be snapped so that they're ending flat with the housing:
Attention: If the ELM terminal module is clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.
Disassembly
Each ELM terminal is secured by a lock on the mounting rail, which must be released for disassembly. The procedure for demounting have to be done in reverse order as described in Assembly:
1.
Release the mounting rail lock of the ELM terminal module on the top and down side and you can pull the terminal out of the bus terminal block easily without excessive force.
2.
Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal out of the bus terminal block.
Opening of the upper and lower mounting rail lock and pull out the ELM terminal module
Connections within a bus terminal block
The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components: The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.


Protective earth (PE)

Mounting and wiring [image] Protective earth (PE)
Protective earth (PE)
The housings of the ELM/EKM series are made of die-cast zinc and are thus metallic. This results in a need for clarification regarding the use of protective earthing against the risk of electric shock.
Attention: The relevant application standards refer to the surrounding control cabinet/control box as "housing", whereas this documentation refers to the Beckhoff terminal as "housing".
See also chapter "Earthing: PE vs. FE vs. Grounding" in this documentation.
The housing offers the option of an M3 bolted connection for connecting a ring terminal to PE.
The procedure for this is as follows:
▪
Lever off the plastic cover from the ELM housing and retain if for later reuse, if required
▪
Secure the previously prepared ring terminal, which was crimped to the protective conductor, using an M3x4 screw; max. torque 0.5 Nm. Use a suitable tool.
ATTENTION: The screw must not be longer than specified, in order to avoid it protruding into the interior, where it could cause damage. This would be evident if the unit is sent in for repair.
▪
Connect the PE cable to the protective conductor system.
Notes on whether a PE connection is necessary in the specific application
▪
A PE connection is required if the terminal could pose a risk of electric shock due to an inadmissible contact voltage. A distinction is made between two causes:
–
if the terminal is subjected to high internal voltages (not SELV/PELV), this high voltage may reach the housing in the event of a fault. For such terminals, a PE connection is essential. See the corresponding mechanical options at the module. For background information please refer to product and device standards such as EN 61010.
Note: The terminals of type ELM3004, ELM3002, ELM3104, ELM3102, ELM3504, ELM3502, ELM3604, ELM3602, ELM3704, ELM3702 operate with low voltage SELV/PELV, so that there is usually no potential risk.
–
A connection to the protective earth conductor system must nevertheless be provided if the terminal operates with protective extra-low voltage (SELV/PELV), but there is a risk that a live conductor may come into contact with the housing in the event of a fault, resulting in unacceptable touch voltage. This is stipulated by application standards such as EN60204‑1 or EN61439‑1 relating to control cabinet design.
▪
It is therefore always necessary to check in which environment the application is used to ascertain whether a PE connection is required.
Note on protective earth (PE) with regard to analog measurements
The protective earth conductor system is specifically designed for discharging high currents. This may result in significant high-frequency interference, which could adversely affect an analog measuring device if it is/has to be connected to the protective conductor system. In such cases, a strictly star-shaped configuration of the FE and PE systems may be advisable, in order to have as few interference sources as possible on the PE system that are close to the analog measuring system. Ideally, no PE connection should be used at all. However, in this case the installation must comply with the two conditions referred to above, which may necessitate splitting the system into a high-voltage and a low-voltage control cabinet, so that no PE would be required for the latter.


Connection notes for 20 mA measurement

Mounting and wiring [image] Connection notes for 20 mA measurement
Connection notes for 20 mA measurement
Additional information
•
Configuration of 0/4..20 mA differential inputs


Configuration of 0/4..20 mA differential inputs

Mounting and wiring [image] Connection notes for 20 mA measurement [image] Configuration of 0/4..20 mA differential inputs
Configuration of 0/4..20 mA differential inputs
This section describes the 0/4..20 mA differential inputs for terminal series EL301x, EL302x, EL311x, EL312x and terminals EL3174, EL3612, EL3742 and EL3751.
For the single-ended 20 mA inputs the terminal series EL304x, EL305x, EL314x, EL315x, EL317x, EL318x and EL375x they only apply with regard to technical transferability and also for devices whose analogue input channels have a common related ground potential (and therefore the channels are not to each other and/or not to power supply electrically isolated). Herewith an example for an electrically isolated device is the terminal EL3174-0002.
Technical background
The internal input electronics of the terminals referred to above have the following characteristic (see Fig. Internal connection diagram for 0/4..20 mA inputs):
▪
Differential current measurement, i.e. concrete potential reference is primarily not required.
The system limit applies is the individual terminal EL30xx/EL31xx.
▪
Current measurement via a 33 Ω shunt per channel, resulting in a maximum voltage drop of 660 mV via the shunt
▪
Internal resistor configuration with GND point (A) central to the shunt
The configuration of the resistors is symmetric, such that the potential of (A) is central relative to the voltage drop via the shunt.
▪
All channels within the terminal have this GNDint potential in common.
▪
the common GNDint potential (A)
–
is connected for 1 and 2 channel terminals to a terminal point and not with GNDPC (power contact).
–
is connected for 4 channel terminals with GNDPC
▪
The center point of the voltage drop over the 33 Ω shunt is referred to common mode point (CMP).
According to the technical product data, the maximum permitted UCM voltage (common mode) refers to the potential between the CMP of a channel and the internal GND or the potential between the CMP of 2 channels within a terminal.
It must not exceed the specified limit (typically ±10 or ±35 V).
Accordingly, for multi-channel measurements UCMspecifications must be followed.
Internal connection diagram 0/4...20 mA inputs
The block diagram for a 2 channel terminal shows the linked GND points within the terminal (Fig. Internal connection for 0/4..20 mA inputs of a EL3xx2):
Internal connection diagram for 0/4..20 mA inputs of a EL3xx2
For all channels within the terminal UCM-max must not be exceeded.
UCM for 0/4..20 mA inputs
If UCM of an analog input channel is exceeded, internal equalizing currents result in erroneous measurements.
For 1 and 2 channel terminals the internal GND is therefore fed out to a terminal point, so that the UCM specification can be met through application-specific configuration of this GND point, even in cases of atypical sensor configuration.
Example 1
The 2-channel EL3012 is connected to 2 sensors, which are supplied with 5 and 24 V. Both current measurements are executed as low-side measurements. This connection type is permitted, because at Imax CMPch1 and CMPch2 are approx. 330 mV above 0 V, which means that UCM is always < 0.5 V. The requirement of UCM < 10 V (applicable to EL30xx) is therefore adhered to.
Example 1: low-side measurement
If the EL30x1/EL30x2 or EL31x1/EL31x2 terminals have no external GNDint connection, the GNDint potential can adjust itself as required (referred to as "floating"). Please note that for this mode reduced measuring accuracy is to be expected.
Example 1a
Accordingly, this also applies if the floating point GNDINT is connected to another potential.
Example 1a, high-side measurement
Example 2
The same EL3012 is now again connected with the two 20 mA sensors, although this time with one low-side measurement at 5 V and one high-side measurement at 12 V. This results in significant potential differences UCM > 10 V (applicable to EL30xx) between the two channels, which is not permitted.
Example 2, high-side/low-side measurement
To rectify this, GNDint can in this case be connected externally with an auxiliary potential of 6 V relative to "0 V". The resulting A/GNDint will be in the middle, i.e. approx. 0.3 V or 11.6 V.
Example 3
In the EL3xx4 terminals GNDint is internally connected with the negative power contact. The choice of potential is therefore limited.
Invalid EL3xx4 configuration
The resulting CMP is 23.6 V, i.e. >> 10 V (applicable to EL30xx). The EL30x4/EL31x4 terminals should therefore be configured such that CMP is always less than UCM,max.
Summary
This results in certain concrete specifications for external connection with 0/4..20 mA sensors:
▪
We recommended connecting GNDint with a low-impedance potential, because this significantly improves the measuring accuracy of the EL30xx/31xx.
Please note the instructions relating to the UCM potential reference.
▪
The UCM potential reference must be adhered to between CMP ↔ GNDint and CMPch(x) ↔ CMPch(y).
If this cannot be guaranteed, the single-channel version should be used.
▪
Terminal configuration:
–
EL3xx1/EL3xx2: GNDint is connected to terminal point for external connection.
GNDint should be connected externally such that condition 2 is met.
–
EL3xx4: GND is connected with the negative power contact.
The external connection should be such that condition 2 is met.
If the sensor cable is shielded, the shield should not be connected with the GNDint terminal point but with a dedicated low-impedance shield point.
▪
If terminal points of several EL30xx/EL31xx terminals are connected with each other, ensure that condition 2 is met.
Connection of GNDint
In the EL30x1/EL30x2 and EL31x1/EL31x2 terminals the internal GND, GNDint connection is fed out to terminal contacts.
To achieve a precise measurement result GNDint should be connected to a suitable external low-impedance potential, taking account the specifications for UCM.
In the EL30x4/EL31x4 terminals GNDint is already connected with the negative power contact. Here too the specifications for UCM must be followed.


LED indicators - meanings

Mounting and wiring [image] LED indicators - meanings
LED indicators - meanings
LEDs of ELM terminals
LED | Color | Meaning
RUN | green | off | State of the EtherCAT State Machine: INIT = initialization of the module
 |  | flashing | State of the EtherCAT State Machine: PREOP = function for mailbox communication and different standard-settings set
 |  | single flash | State of the EtherCAT State Machine: SAFEOP = check the channels of the Sync Manager and the Distributed Clocks (if supported)
 |  | on | State of the EtherCAT State Machine: OP = normal operating state; mailbox and process data communication is possible
 |  | flickering | State of the EtherCAT State Machine: BOOTSTRAP = function for firmware updates of the module
LED
Color
Meaning
OK
(1…n)
green
No error
rot
Error display, along with error bit in the status, for
▪
Measuring range error (not for underrange/overrange!)
▪
Set measuring type is not calibrated (see CoE object 0x80nF PAI Vendor Calibration Data)
▪
Processor overload (see CoE object 0xF900 PAI Info Data)
▪
ADC in "saturation"
▪
Analog circuit "in overload", over voltage detected at inputs; see notes in section "Common technical data” and following section "Connection"
▪
Oversampling Error in Synchron Mode
flashing
Active self‑test of terminal;
see chapter ELM Features/ Self-test and self-test report
off
No operation


Power contacts ELM314x

Mounting and wiring [image] Power contacts ELM314x
Power contacts ELM314x
The power contacts (looped through, usually 24V/ 0V) are connected to the terminal points of the ELM314x for sensor supply as follows:
ELM314x power contacts.png
Connections of the power contacts of the ELM314x
Table:
Terminal | ELM3142-0000 | ELM3144-0000 | ELM3146-0000 | ELM3148-0000
Connector | X001, X002 | X001..X004 | X003, X004 | X001..X004
24 V | Terminal point 3 | Terminal point 3 | Terminal points 1, 3, 5 | Terminal point 5
0 V | Terminal point 4 | Terminal point 4 | Terminal points 2, 4, 6 | Terminal point 6
Note: the electrical power to be taken from the terminal points depends on the lowest value of the following factors:
▪
electrical continuous load of the power contacts in the terminal wheeling: 10 A
▪
electrical continuous load of the terminal point, see section "Housing/ Housing data"
▪
capacity of the feeding coupler/ power feed terminal to the power contacts
▪
permissible maximum outgoing cumulative current of the contacts each ELM314x: 2 A


Appendix

Appendix
Appendix
Additional information
•
Diagnostics – basic principles of diag messages
•
TcEventLogger and IO
•
UL notice
•
Continuative documentation about explosion protection
•
EtherCAT AL Status Codes
•
Firmware Update EL/ES/EM/ELM/EPxxxx
•
Firmware compatibility
•
Firmware compatibility - passive terminals
•
Restoring the delivery state
•
Notes on analog measured values
•
Support and Service
•
Reshipment and return


Diagnostics – basic principles of diag messages

Appendix [image] Diagnostics – basic principles of diag messages
Diagnostics – basic principles of diag messages
DiagMessages designates a system for the transmission of messages from the EtherCAT Slave to the EtherCAT Master/TwinCAT. The messages are stored by the device in its own CoE under 0x10F3 and can be read by the application or the System Manager. An error message referenced via a code is output for each event stored in the device (warning, error, status change).
Definition
The DiagMessages system is defined in the ETG (EtherCAT Technology Group) in the guideline ETG.1020, chapter 13 “Diagnosis handling”. It is used so that pre-defined or flexible diagnostic messages can be conveyed from the EtherCAT Slave to the Master. In accordance with the ETG, the process can therefore be implemented supplier-independently. Support is optional. The firmware can store up to 250 DiagMessages in its own CoE.
Each DiagMessage consists of
▪
Diag Code (4-byte)
▪
Flags (2-byte; info, warning or error)
▪
Text ID (2-byte; reference to explanatory text from the ESI/XML)
▪
Timestamp (8-byte, local slave time or 64-bit Distributed Clock time, if available)
▪
Dynamic parameters added by the firmware
The DiagMessages are explained in text form in the ESI/XML file belonging to the EtherCAT device: on the basis of the Text ID contained in the DiagMessage, the corresponding plain text message can be found in the languages contained in the ESI/XML. In the case of Beckhoff products these are usually German and English.
Via the entry NewMessagesAvailable the user receives information that new messages are available.
DiagMessages can be confirmed in the device: the last/latest unconfirmed message can be confirmed by the user.
In the CoE both the control entries and the history itself can be found in the CoE object 0x10F3:
DiagMessages in the CoE
The subindex of the latest DiagMessage can be read under 0x10F3:02.
Support for commissioning
The DiagMessages system is to be used above all during the commissioning of the plant. The diagnostic values e.g. in the StatusWord of the device (if available) are helpful for online diagnosis during the subsequent continuous operation.
TwinCAT System Manager implementation
From TwinCAT 2.11 DiagMessages, if available, are displayed in the device’s own interface. Operation (collection, confirmation) also takes place via this interface.
Implementation of the DiagMessage system in the TwinCAT System Manager
The operating buttons (B) and the history read out (C) can be seen on the Diag History tab (A). The components of the message:
▪
Info/Warning/Error
▪
Acknowledge flag (N = unconfirmed, Q = confirmed)
▪
Time stamp
▪
Text ID
▪
Plain text message according to ESI/XML data
The meanings of the buttons are self-explanatory.
DiagMessages within the ADS Logger/Eventlogger
Since TwinCAT 3.1 build 4022 DiagMessages send by the terminal are shown by the TwinCAT ADS Logger. Given that DiagMessages are represented IO- comprehensive at one place, commissioning will be simplified. In addition, the logger output could be stored into a data file – hence DiagMessages are available long-term for analysis.
DiagMessages are actually only available locally in CoE 0x10F3 in the terminal and can be read out manually if required, e.g. via the DiagHistory mentioned above.
In the latest developments, the EtherCAT Terminals are set by default to report the presence of a DiagMessage as emergency via EtherCAT; the event logger can then retrieve the DiagMessage. The function is activated in the terminal via 0x10F3:05, so such terminals have the following entry in the StartUp list by default:
Startup List
If the function is to be deactivated because, for example, many messages come in or the EventLogger is not used, the StartUp entry can be deleted or set to 0.
Reading messages into the PLC
- In preparation -
Interpretation
Time stamp
The time stamp is obtained from the local clock of the terminal at the time of the event. The time is usually the distributed clock time (DC) from register x910.
Please note: When EtherCAT is started, the DC time in the reference clock is set to the same time as the local IPC/TwinCAT time. From this moment the DC time may differ from the IPC time, since the IPC time is not adjusted. Significant time differences may develop after several weeks of operation without a EtherCAT restart. As a remedy, external synchronization of the DC time can be used, or a manual correction calculation can be applied, as required: The current DC time can be determined via the EtherCAT master or from register x901 of the DC slave.
Structure of the Text ID
The structure of the MessageID is not subject to any standardization and can be supplier-specifically defined. In the case of Beckhoff EtherCAT devices (EL, EP) it usually reads according to xyzz:
x | y | zz
0: Systeminfo 2: reserved 1: Info 4: Warning 8: Error | 0: System 1: General 2: Communication 3: Encoder 4: Drive 5: Inputs 6: I/O general 7: reserved | Error number
Example: Message 0x4413 --> Drive Warning Number 0x13
Overview of text IDs
Specific text IDs are listed in the device documentation.
Text ID | Type | Place | Text Message | Additional comment
0x0001 | Information | System | No error | No error
0x0002 | Information | System | Communication established | Connection established
0x0003 | Information | System | Initialization: 0x%X, 0x%X, 0x%X | General information; parameters depend on event. See device documentation for interpretation.
0x1000 | Information | System | Information: 0x%X, 0x%X, 0x%X | General information; parameters depend on event. See device documentation for interpretation.
0x1012 | Information | System | EtherCAT state change Init - PreOp |
0x1021 | Information | System | EtherCAT state change PreOp - Init |
0x1024 | Information | System | EtherCAT state change PreOp - Safe-Op |
0x1042 | Information | System | EtherCAT state change SafeOp - PreOp |
0x1048 | Information | System | EtherCAT state change SafeOp - Op |
0x1084 | Information | System | EtherCAT state change Op - SafeOp |
0x1100 | Information | General | Detection of operation mode completed: 0x%X, %d | Detection of the mode of operation ended
0x1135 | Information | General | Cycle time o.k.: %d | Cycle time OK
0x1157 | Information | General | Data manually saved (Idx: 0x%X, SubIdx: 0x%X) | Data saved manually
0x1158 | Information | General | Data automatically saved (Idx: 0x%X, SubIdx: 0x%X) | Data saved automatically
0x1159 | Information | General | Data deleted (Idx: 0x%X, SubIdx: 0x%X) | Data deleted
0x117F | Information | General | Information: 0x%X, 0x%X, 0x%X | Information
0x1201 | Information | Communication | Communication re-established | Communication to the field side restored This message appears, for example, if the voltage was removed from the power contacts and re-applied during operation.
0x1300 | Information | Encoder | Position set: %d, %d | Position set - StartInputhandler
0x1303 | Information | Encoder | Encoder Supply ok | Encoder power supply unit OK
0x1304 | Information | Encoder | Encoder initialization successfully, channel: %X | Encoder initialization successfully completed
0x1305 | Information | Encoder | Sent command encoder reset, channel: %X | Send encoder reset command
0x1400 | Information | Drive | Drive is calibrated: %d, %d | Drive is calibrated
0x1401 | Information | Drive | Actual drive state: 0x%X, %d | Current drive status
0x1705 | Information |  | CPU usage returns in normal range (< 85%%) | Processor load is back in the normal range
0x1706 | Information |  | Channel is not in saturation anymore | Channel is no longer in saturation
0x1707 | Information |  | Channel is not in overload anymore | Channel is no longer overloaded
0x170A | Information |  | No channel range error anymore | A measuring range error is no longer active
0x170C | Information |  | Calibration data saved | Calibration data were saved
0x170D | Information |  | Calibration data will be applied and saved after sending the command “0x5AFE” | Calibration data are not applied and saved until the command "0x5AFE" is sent.
Text ID | Type | Place | Text Message | Additional comment
0x2000 | Information | System | %s: %s |
0x2001 | Information | System | %s: Network link lost | Network connection lost
0x2002 | Information | System | %s: Network link detected | Network connection found
0x2003 | Information | System | %s: no valid IP Configuration - Dhcp client started | Invalid IP configuration
0x2004 | Information | System | %s: valid IP Configuration (IP: %d.%d.%d.%d) assigned by Dhcp server %d.%d.%d.%d | Valid IP configuration, assigned by the DHCP server
0x2005 | Information | System | %s: Dhcp client timed out | DHCP client timeout
0x2006 | Information | System | %s: Duplicate IP Address detected (%d.%d.%d.%d) | Duplicate IP address found
0x2007 | Information | System | %s: UDP handler initialized | UDP handler initialized
0x2008 | Information | System | %s: TCP handler initialized | TCP handler initialized
0x2009 | Information | System | %s: No more free TCP sockets available | No free TCP sockets available.
Text ID
Type
Place
Text Message
Additional comment
0x4000
Warning
Warning: 0x%X, 0x%X, 0x%X
General warning; parameters depend on event. See device documentation for interpretation.
0x4001
Warning
System
Warning: 0x%X, 0x%X, 0x%X
0x4002
Warning
System
%s: %s Connection Open (IN:%d OUT:%d API:%dms) from %d.%d.%d.%d successful
0x4003
Warning
System
%s: %s Connection Close (IN:%d OUT:%d) from %d.%d.%d.%d successful
0x4004
Warning
System
%s: %s Connection (IN:%d OUT:%d) with %d.%d.%d.%d timed out
0x4005
Warning
System
%s: %s Connection Open (IN:%d OUT:%d) from %d.%d.%d.%d denied (Error: %u)
0x4006
Warning
System
%s: %s Connection Open (IN:%d OUT:%d) from %d.%d.%d.%d denied (Input Data Size expected: %d Byte(s) received: %d Byte(s))
0x4007
Warning
System
%s: %s Connection Open (IN:%d OUT:%d) from %d.%d.%d.%d denied (Output Data Size expected: %d Byte(s) received: %d Byte(s))
0x4008
Warning
System
%s: %s Connection Open (IN:%d OUT:%d) from %d.%d.%d.%d denied (RPI:%dms not supported -> API:%dms)
0x4101
Warning
General
Terminal-Overtemperature
Overtemperature. The internal temperature of the terminal exceeds the parameterized warning threshold.
0x4102
Warning
General
Discrepancy in the PDO-Configuration
The selected PDOs do not match the set operating mode.
Sample: Drive operates in velocity mode, but the velocity PDO is but not mapped in the PDOs.
0x417F
Warning
General
Warning: 0x%X, 0x%X, 0x%X
0x428D
Warning
General
Challenge is not Random
0x4300
Warning
Encoder
Subincrements deactivated: %d, %d
Sub-increments deactivated (despite activated configuration)
0x4301
Warning
Encoder
Encoder-Warning
General encoder error
0x4302
Warning
Encoder
Maximum frequency of the input signal is nearly reached (channel %d)
0x4303
Warning
Encoder
Limit counter value was reduced because of the PDO configuration (channel %d)
0x4304
Warning
Encoder
Reset counter value was reduced because of the PDO configuration (channel %d)
0x4400
Warning
Drive
Drive is not calibrated: %d, %d
Drive is not calibrated
0x4401
Warning
Drive
Starttype not supported: 0x%X, %d
Start type is not supported
0x4402
Warning
Drive
Command rejected: %d, %d
Command rejected
0x4405
Warning
Drive
Invalid modulo subtype: %d, %d
Modulo sub-type invalid
0x4410
Warning
Drive
Target overrun: %d, %d
Target position exceeded
0x4411
Warning
Drive
DC-Link undervoltage (Warning)
The DC link voltage of the terminal is lower than the parameterized minimum voltage. Activation of the output stage is prevented.
0x4412
Warning
Drive
DC-Link overvoltage (Warning)
The DC link voltage of the terminal is higher than the parameterized maximum voltage. Activation of the output stage is prevented.
0x4413
Warning
Drive
I2T-Model Amplifier overload (Warning)
▪
The amplifier is being operated outside the specification.
▪
The I2T-model of the amplifier is incorrectly parameterized.
0x4414
Warning
Drive
I2T-Model Motor overload (Warning)
▪
The motor is being operated outside the parameterized rated values.
▪
The I2T-model of the motor is incorrectly parameterized.
0x4415
Warning
Drive
Speed limitation active
The maximum speed is limited by the parameterized objects (e.g. velocity limitation, motor speed limitation). This warning is output if the set velocity is higher than one of the parameterized limits.
0x4416
Warning
Drive
Step lost detected at position: 0x%X%X
Step loss detected
0x4417
Warning
Drive
Motor overtemperature
The internal temperature of the motor exceeds the parameterized warning threshold
0x4418
Warning
Drive
Limit: Current
Limit: current is limited
0x4419
Warning
Drive
Limit: Amplifier I2T-model exceeds 100%%
The threshold values for the maximum current were exceeded.
0x441A
Warning
Drive
Limit: Motor I2T-model exceeds 100%%
Limit: Motor I2T-model exceeds 100%
0x441B
Warning
Drive
Limit: Velocity limitation
The threshold values for the maximum speed were exceeded.
0x441C
Warning
Drive
STO while the axis was enabled
An attempt was made to activate the axis, despite the fact that no voltage is present at the STO input.
0x4600
Warning
General IO
Wrong supply voltage range
Supply voltage not in the correct range
0x4610
Warning
General IO
Wrong output voltage range
Output voltage not in the correct range
0x4705
Warning
Processor usage at %d %%
Processor load at %d %%
0x470A
Warning
EtherCAT Frame missed (change Settings or DC Operation Mode or Sync0 Shift Time)
EtherCAT frame missed (change DC Operation Mode or Sync0 Shift Time under Settings)
Text ID
Type
Place
Text Message
Additional comment
0x8000
Error
System
%s: %s
0x8001
Error
System
Error: 0x%X, 0x%X, 0x%X
General error; parameters depend on event. See device documentation for interpretation.
0x8002
Error
System
Communication aborted
Communication aborted
0x8003
Error
System
Configuration error: 0x%X, 0x%X, 0x%X
General; parameters depend on event.
See device documentation for interpretation.
0x8004
Error
System
%s: Unsuccessful FwdOpen-Response received from %d.%d.%d.%d (%s) (Error: %u)
0x8005
Error
System
%s: FwdClose-Request sent to %d.%d.%d.%d (%s)
0x8006
Error
System
%s: Unsuccessful FwdClose-Response received from %d.%d.%d.%d (%s) (Error: %u)
0x8007
Error
System
%s: Connection with %d.%d.%d.%d (%s) closed
0x8100
Error
General
Status word set: 0x%X, %d
Error bit set in the status word
0x8101
Error
General
Operation mode incompatible to PDO interface: 0x%X, %d
Mode of operation incompatible with the PDO interface
0x8102
Error
General
Invalid combination of Inputs and Outputs PDOs
Invalid combination of input and output PDOs
0x8103
Error
General
No variable linkage
No variables linked
0x8104
Error
General
Terminal-Overtemperature
The internal temperature of the terminal exceeds the parameterized error threshold. Activation of the terminal is prevented
0x8105
Error
General
PD-Watchdog
Communication between the fieldbus and the output stage is secured by a Watchdog. The axis is stopped automatically if the fieldbus communication is interrupted.
▪
The EtherCAT connection was interrupted during operation.
▪
The Master was switched to Config mode during operation.
0x8135
Error
General
Cycle time has to be a multiple of 125 µs
The IO or NC cycle time divided by 125 µs does not produce a whole number.
0x8136
Error
General
Configuration error: invalid sampling rate
Configuration error: Invalid sampling rate
0x8137
Error
General
Electronic type plate: CRC error
Content of the external name plate memory invalid.
0x8140
Error
General
Sync Error
Real-time violation
0x8141
Error
General
Sync%X Interrupt lost
Sync%X Interrupt lost
0x8142
Error
General
Sync Interrupt asynchronous
Sync Interrupt asynchronous
0x8143
Error
General
Jitter too big
Jitter limit violation
0x817F
Error
General
Error: 0x%X, 0x%X, 0x%X
0x8200
Error
Communication
Write access error: %d, %d
Error while writing
0x8201
Error
Communication
No communication to field-side (Auxiliary voltage missing)
▪
There is no voltage applied to the power contacts.
▪
A firmware update has failed.
0x8281
Error
Communication
Ownership failed: %X
0x8282
Error
Communication
To many Keys founded
0x8283
Error
Communication
Key Creation failed: %X
0x8284
Error
Communication
Key loading failed
0x8285
Error
Communication
Reading Public Key failed: %X
0x8286
Error
Communication
Reading Public EK failed: %X
0x8287
Error
Communication
Reading PCR Value failed: %X
0x8288
Error
Communication
Reading Certificate EK failed: %X
0x8289
Error
Communication
Challenge could not be hashed: %X
0x828A
Error
Communication
Tickstamp Process failed
0x828B
Error
Communication
PCR Process failed: %X
0x828C
Error
Communication
Quote Process failed: %X
0x82FF
Error
Communication
Bootmode not activated
Boot mode not activated
0x8300
Error
Encoder
Set position error: 0x%X, %d
Error while setting the position
0x8301
Error
Encoder
Encoder increments not configured: 0x%X, %d
Encoder increments not configured
0x8302
Error
Encoder
Encoder error
The amplitude of the resolver is too small
0x8303
Error
Encoder
Encoder power missing (channel %d)
0x8304
Error
Encoder
Encoder communication error, channel: %X
Encoder communication error
0x8305
Error
Encoder
EnDat2.2 is not supported, channel: %X
EnDat2.2 is not supported
0x8306
Error
Encoder
Delay time, tolerance limit exceeded, 0x%X, channel: %X
Runtime measurement, tolerance exceeded
0x8307
Error
Encoder
Delay time, maximum value exceeded, 0x%X, channel: %X
Runtime measurement, maximum value exceeded
0x8308
Error
Encoder
Unsupported ordering designation, 0x%X, channel: %X (only 02 and 22 is supported)
Wrong EnDat order ID
0x8309
Error
Encoder
Encoder CRC error, channel: %X
Encoder CRC error
0x830A
Error
Encoder
Temperature %X could not be read, channel: %X
Temperature cannot be read
0x830C
Error
Encoder
Encoder Single-Cycle-Data Error, channel. %X
CRC error detected. Check the transmission path and the CRC polynomial
0x830D
Error
Encoder
Encoder Watchdog Error, channel. %X
The sensor has not responded within a predefined time period
0x8310
Error
Encoder
Initialisation error
0x8311
Error
Encoder
Maximum frequency of the input signal is exceeded (channel %d)
0x8312
Error
Encoder
Encoder plausibility error (channel %d)
0x8313
Error
Encoder
Configuration error (channel %d)
0x8314
Error
Encoder
Synchronisation error
0x8315
Error
Encoder
Error status input (channel %d)
0x8400
Error
Drive
Incorrect drive configuration: 0x%X, %d
Drive incorrectly configured
0x8401
Error
Drive
Limiting of calibration velocity: %d, %d
Limitation of the calibration velocity
0x8402
Error
Drive
Emergency stop activated: 0x%X, %d
Emergency stop activated
0x8403
Error
Drive
ADC Error
Error during current measurement in the ADC
0x8404
Error
Drive
Overcurrent
Overcurrent in phase U, V or W
0x8405
Error
Drive
Invalid modulo position: %d
Modulo position invalid
0x8406
Error
Drive
DC-Link undervoltage (Error)
The DC link voltage of the terminal is lower than the parameterized minimum voltage. Activation of the output stage is prevented.
0x8407
Error
Drive
DC-Link overvoltage (Error)
The DC link voltage of the terminal is higher than the parameterized maximum voltage. Activation of the output stage is prevented.
0x8408
Error
Drive
I2T-Model Amplifier overload (Error)
▪
The amplifier is being operated outside the specification.
▪
The I2T-model of the amplifier is incorrectly parameterized.
0x8409
Error
Drive
I2T-Model motor overload (Error)
▪
The motor is being operated outside the parameterized rated values.
▪
The I2T-model of the motor is incorrectly parameterized.
0x840A
Error
Drive
Overall current threshold exceeded
Total current exceeded
0x8415
Error
Drive
Invalid modulo factor: %d
Modulo factor invalid
0x8416
Error
Drive
Motor overtemperature
The internal temperature of the motor exceeds the parameterized error threshold. The motor stops immediately. Activation of the output stage is prevented.
0x8417
Error
Drive
Maximum rotating field velocity exceeded
Rotary field speed exceeds the value specified for dual use (EU 1382/2014).
0x841C
Error
Drive
STO while the axis was enabled
An attempt was made to activate the axis, despite the fact that no voltage is present at the STO input.
0x8550
Error
Inputs
Zero crossing phase %X missing
Zero crossing phase %X missing
0x8551
Error
Inputs
Phase sequence Error
Wrong direction of rotation
0x8552
Error
Inputs
Overcurrent phase %X
Overcurrent phase %X
0x8553
Error
Inputs
Overcurrent neutral wire
Overcurrent neutral wire
0x8581
Error
Inputs
Wire broken Ch %D
Wire broken Ch %d
0x8600
Error
General IO
Wrong supply voltage range
Supply voltage not in the correct range
0x8601
Error
General IO
Supply voltage to low
Supply voltage too low
0x8602
Error
General IO
Supply voltage to high
Supply voltage too high
0x8603
Error
General IO
Over current of supply voltage
Overcurrent of supply voltage
0x8610
Error
General IO
Wrong output voltage range
Output voltage not in the correct range
0x8611
Error
General IO
Output voltage to low
Output voltage too low
0x8612
Error
General IO
Output voltage to high
Output voltage too high
0x8613
Error
General IO
Over current of output voltage
Overcurrent of output voltage
0x8700
Error
Channel/Interface not calibrated
Channel/interface not synchronized
0x8701
Error
Operating time was manipulated
Operating time was manipulated
0x8702
Error
Oversampling setting is not possible
Oversampling setting not possible
0x8703
Error
No slave controller found
No slave controller found
0x8704
Error
Slave controller is not in Bootstrap
Slave controller is not in bootstrap
0x8705
Error
Processor usage to high (>= 100%%)
Processor load too high (>= 100%%)
0x8706
Error
Channel in saturation
Channel in saturation
0x8707
Error
Channel overload
Channel overload
0x8708
Error
Overloadtime was manipulated
Overload time was manipulated
0x8709
Error
Saturationtime was manipulated
Saturation time was manipulated
0x870A
Error
Channel range error
Measuring range error for the channel
0x870B
Error
no ADC clock
No ADC clock available
0xFFFF
Information
Debug: 0x%X, 0x%X, 0x%X
Debug: 0x%X, 0x%X, 0x%X


TcEventLogger and IO

Appendix [image] TcEventLogger and IO
TcEventLogger and IO
The TwinCAT 3 EventLogger provides an interface for the exchange of messages between TwinCAT components and non-TwinCAT components.
Schematic representation TCEventLogger
Refer to the explanations in the TwinCAT EventLogger documentation, e.g. in the Beckhoff InfoSys https://infosys.beckhoff.com/ → TwinCAT 3 → TE1000 XAE → Technologies → EventLogger.
The EventLogger saves to a local database under ..\TwinCAT\3.1\Boot\LoggedEvents.db and, unlike the VisualStudio Error Window, is designed for continuous recording.
IO devices can also be a source of messages. If so-called DiagMessages are generated in the IO device, they can be collected by TwinCAT over EtherCAT and displayed in the TcEventLogger with the appropriate device setting. This facilitates the central management of events that hinder operation, as a textual diagnosis no longer needs to be programmed out in the application for each individual IO device. The messages/events can be displayed directly in the TwinCAT HMI, for example, and thus facilitate the diagnosis.
Notes:
▪
This feature is supported from TwinCAT 3.1 build 4022.16.
▪
TwinCAT may be in the RUN or CONFIG mode
▪
On the manufacturer side, the IO device regarded must (1) generate local DiagMessages and (2) be fundamentally capable of transmitting them as events over EtherCAT. This is not the case with all EtherCAT IO devices/terminals/boxes from Beckhoff.
The messages managed by the EventLogger can be output in or read from
▪
the HMI → EventGrid
▪
C#
▪
the PLC
▪
TwinCAT Engineering → Logged Events
The use of the EventLogger with EtherCAT IO with TwinCAT 3.1 build 4022.22 during commissioning is explained below.
▪
The EventLogger window may need to be displayed in the TwinCAT Engineering
Display EventLogger window
▪
Some DiagMessages and the resulting Logged Events are shown below, taking an ELM3602-0002 as an example
Display DiagMessages and Logged Events
▪
Filtering by entries and language is possible in the Logger window.
German: 1031
English: 1033
Setting filter language
▪
If an EtherCAT slave is enabled by default to transmit DiagMessages as events over EtherCAT, this can be activated/deactivated for each individual slave in the CoE 0x10F3:05. TRUE means that the slave provides events for collection via EtherCAT, while FALSE deactivates the function.
Activating/deactivating event transmission
▪
In the respective EtherCAT slave, various "causes" can lead to it transmitting DiagMessages or events. If only some of these are to be generated, you can read in the device documentation whether and how individual causes can be deactivated, e.g. through CoE settings.
▪
Settings for the TwinCAT EventLogger can be found under Tools/Options
Settings TwinCAT EventLogger


UL notice

Appendix [image] UL notice
UL notice
culus-logo
Application
Beckhoff EtherCAT modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
culus-logo
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
culus-logo
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
Basic principles
UL certification according to UL508. Devices with this kind of certification are marked by this sign:


Continuative documentation about explosion protection

Appendix [image] Continuative documentation about explosion protection
Continuative documentation about explosion protection
Explosion protection for terminal systems
Pay also attention to the continuative documentation

Notes on the use of the Beckhoff terminal systems in hazardous areas according to ATEX and IECEx

that is available for download on the Beckhoff homepage https:\\www.beckhoff.com!


EtherCAT AL Status Codes

Appendix [image] EtherCAT AL Status Codes
EtherCAT AL Status Codes
For detailed information please refer to the EtherCAT system description.


Firmware Update EL/ES/EM/ELM/EPxxxx

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx
Firmware Update EL/ES/EM/ELM/EPxxxx
This section describes the device update for Beckhoff EtherCAT slaves from the EL/ES, ELM, EM, EK and EP series. A firmware update should only be carried out after consultation with Beckhoff support.
Storage locations
An EtherCAT slave stores operating data in up to three locations:
▪
Depending on functionality and performance EtherCAT slaves have one or several local controllers for processing I/O data. The corresponding program is the so-called firmware in *.efw format.
▪
In some EtherCAT slaves the EtherCAT communication may also be integrated in these controllers. In this case the controller is usually a so-called FPGA chip with *.rbf firmware.
▪
In addition, each EtherCAT slave has a memory chip, a so-called ESI-EEPROM, for storing its own device description (ESI: EtherCAT Slave Information). On power-up this description is loaded and the EtherCAT communication is set up accordingly. The device description is available from the download area of the Beckhoff website at (https://www.beckhoff.de). All ESI files are accessible there as zip files.
Customers can access the data via the EtherCAT fieldbus and its communication mechanisms. Acyclic mailbox communication or register access to the ESC is used for updating or reading of these data.
The TwinCAT System Manager offers mechanisms for programming all three parts with new data, if the slave is set up for this purpose. Generally the slave does not check whether the new data are suitable, i.e. it may no longer be able to operate if the data are unsuitable.
Simplified update by bundle firmware
The update using so-called bundle firmware is more convenient: in this case the controller firmware and the ESI description are combined in a *.efw file; during the update both the firmware and the ESI are changed in the terminal. For this to happen it is necessary
▪
for the firmware to be in a packed format: recognizable by the file name, which also contains the revision number, e.g. ELxxxx-xxxx_REV0016_SW01.efw
▪
for password=1 to be entered in the download dialog. If password=0 (default setting) only the firmware update is carried out, without an ESI update.
▪
for the device to support this function. The function usually cannot be retrofitted; it is a component of many new developments from year of manufacture 2016.
Following the update, its success should be verified
▪
ESI/Revision: e.g. by means of an online scan in TwinCAT ConfigMode/FreeRun – this is a convenient way to determine the revision
▪
Firmware: e.g. by looking in the online CoE of the device
Note
Risk of damage to the device!
✓
Note the following when downloading new device files
1.
Firmware downloads to an EtherCAT device must not be interrupted
2.
Flawless EtherCAT communication must be ensured. CRC errors or LostFrames must be avoided.
3.
The power supply must adequately dimensioned. The signal level must meet the specification.
⇨
In the event of malfunctions during the update process the EtherCAT device may become unusable and require re-commissioning by the manufacturer.
Additional information
•
Device description ESI file/XML
•
Firmware explanation
•
Updating controller firmware *.efw
•
FPGA firmware *.rbf
•
Simultaneous updating of several EtherCAT devices


Device description ESI file/XML

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Device description ESI file/XML
Device description ESI file/XML
Note
Attention regarding update of the ESI description/EEPROM
Some slaves have stored calibration and configuration data from the production in the EEPROM. These are irretrievably overwritten during an update.
The ESI device description is stored locally on the slave and loaded on start-up. Each device description has a unique identifier consisting of slave name (9 characters/digits) and a revision number (4 digits). Each slave configured in the System Manager shows its identifier in the EtherCAT tab:
Device identifier consisting of name EL3204-0000 and revision -0016
The configured identifier must be compatible with the actual device description used as hardware, i.e. the description which the slave has loaded on start-up (in this case EL3204). Normally the configured revision must be the same or lower than that actually present in the terminal network.
For further information on this, please refer to the EtherCAT system documentation.
Update of XML/ESI description
The device revision is closely linked to the firmware and hardware used. Incompatible combinations lead to malfunctions or even final shutdown of the device. Corresponding updates should only be carried out in consultation with Beckhoff support.
Display of ESI slave identifier
The simplest way to ascertain compliance of configured and actual device description is to scan the EtherCAT boxes in TwinCAT mode Config/FreeRun:
Scan the subordinate field by right-clicking on the EtherCAT device
If the found field matches the configured field, the display shows
Configuration is identical
otherwise a change dialog appears for entering the actual data in the configuration.
Change dialog
In this example in Fig. Change dialog, an EL3201-0000-0017 was found, while an EL3201-0000-0016 was configured. In this case the configuration can be adapted with the Copy Before button. The Extended Information checkbox must be set in order to display the revision.
Changing the ESI slave identifier
The ESI/EEPROM identifier can be updated as follows under TwinCAT:
▪
Trouble-free EtherCAT communication must be established with the slave.
▪
The state of the slave is irrelevant.
▪
Right-clicking on the slave in the online display opens the EEPROM Update dialog, Fig. EEPROM Update
EEPROM Update
The new ESI description is selected in the following dialog, see Fig. Selecting the new ESI. The checkbox Show Hidden Devices also displays older, normally hidden versions of a slave.
Selecting the new ESI
A progress bar in the System Manager shows the progress. Data are first written, then verified.
The change only takes effect after a restart.
Most EtherCAT devices read a modified ESI description immediately or after startup from the INIT. Some communication settings such as distributed clocks are only read during power-on. The EtherCAT slave therefore has to be switched off briefly in order for the change to take effect.


Firmware explanation

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Firmware explanation
Firmware explanation
Determining the firmware version
Determining the version on laser inscription
Beckhoff EtherCAT slaves feature serial numbers applied by laser. The serial number has the following structure: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with ser. no.: 12 10 03 02:
12 - week of production 12
10 - year of production 2010
03 - firmware version 03
02 - hardware version 02
Determining the version via the System Manager
The TwinCAT System Manager shows the version of the controller firmware if the master can access the slave online. Click on the E-Bus Terminal whose controller firmware you want to check (in the example terminal 2 (EL3204)) and select the tab CoE Online (CAN over EtherCAT).
CoE Online and Offline CoE
Two CoE directories are available:
• online: This is offered in the EtherCAT slave by the controller, if the EtherCAT slave supports this. This CoE directory can only be displayed if a slave is connected and operational.
• offline: The EtherCAT Slave Information ESI/XML may contain the default content of the CoE. This CoE directory can only be displayed if it is included in the ESI (e.g. “Beckhoff EL5xxx.xml”).
The Advanced button must be used for switching between the two views.
In Fig. Display of EL3204 firmware version the firmware version of the selected EL3204 is shown as 03 in CoE entry 0x100A.
Display of EL3204 firmware version
In (A) TwinCAT 2.11 shows that the Online CoE directory is currently displayed. If this is not the case, the Online directory can be loaded via the Online option in Advanced Settings (B) and double-clicking on AllObjects.


Updating controller firmware *.efw

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Updating controller firmware *.efw
Updating controller firmware *.efw
CoE directory
The Online CoE directory is managed by the controller and stored in a dedicated EEPROM, which is generally not changed during a firmware update.
Switch to the Online tab to update the controller firmware of a slave, see Fig. Firmware Update.
Firmware Update
Proceed as follows, unless instructed otherwise by Beckhoff support. Valid for TwinCAT 2 and 3 as EtherCAT master.
▪
Switch TwinCAT system to ConfigMode/FreeRun with cycle time >= 1 ms (default in ConfigMode is 4 ms). A FW-Update during real time operation is not recommended.
▪
Switch EtherCAT Master to PreOP
▪
Switch slave to INIT (A)
▪
Switch slave to BOOTSTRAP
▪
Check the current status (B, C)
▪
Download the new *efw file (wait until it ends). A pass word will not be neccessary usually.
▪
After the download switch to INIT, then PreOP
▪
Switch off the slave briefly (don't pull under voltage!)
▪
Check within CoE 0x100A, if the FW status was correctly overtaken.


FPGA firmware *.rbf

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] FPGA firmware *.rbf
FPGA firmware *.rbf
If an FPGA chip deals with the EtherCAT communication an update may be accomplished via an *.rbf file.
▪
Controller firmware for processing I/O signals
▪
FPGA firmware for EtherCAT communication (only for terminals with FPGA)
The firmware version number included in the terminal serial number contains both firmware components. If one of these firmware components is modified this version number is updated.
Determining the version via the System Manager
The TwinCAT System Manager indicates the FPGA firmware version. Click on the Ethernet card of your EtherCAT strand (Device 2 in the example) and select the Online tab.
The Reg:0002 column indicates the firmware version of the individual EtherCAT devices in hexadecimal and decimal representation.
FPGA firmware version definition
If the column Reg:0002 is not displayed, right-click the table header and select Properties in the context menu.
Context menu Properties
The Advanced Settings dialog appears where the columns to be displayed can be selected. Under Diagnosis/Online View select the '0002 ETxxxx Build' check box in order to activate the FPGA firmware version display.
Dialog Advanced Settings
Update
For updating the FPGA firmware
▪
of an EtherCAT coupler the coupler must have FPGA firmware version 11 or higher;
▪
of an E-Bus Terminal the terminal must have FPGA firmware version 10 or higher.
Older firmware versions can only be updated by the manufacturer!
Updating an EtherCAT device
The following sequence order have to be met if no other specifications are given (e.g. by the Beckhoff support):
▪
Switch TwinCAT system to ConfigMode/FreeRun with cycle time >= 1 ms (default in ConfigMode is 4 ms). A FW-Update during real time operation is not recommended.
▪
In the TwinCAT System Manager select the terminal for which the FPGA firmware is to be updated (in the example: Terminal 5: EL5001) and
click the Advanced Settings button in the EtherCAT tab:
▪
The Advanced Settings dialog appears. Under ESC Access/E²PROM/FPGA click on Write FPGA button:
▪
Select the file (*.rbf) with the new FPGA firmware, and transfer it to the EtherCAT device:
▪
Wait until download ends
▪
Switch slave current less for a short time (don't pull under voltage!). In order to activate the new FPGA firmware a restart (switching the power supply off and on again) of the EtherCAT device is required.
▪
Check the new FPGA status
Note
Risk of damage to the device!
A download of firmware to an EtherCAT device must not be interrupted in any case! If you interrupt this process by switching off power supply or disconnecting the Ethernet link, the EtherCAT device can only be recommissioned by the manufacturer!


Simultaneous updating of several EtherCAT devices

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Simultaneous updating of several EtherCAT devices
Simultaneous updating of several EtherCAT devices
The firmware and ESI descriptions of several devices can be updated simultaneously, provided the devices have the same firmware file/ESI.
Multiple selection and firmware update
Select the required slaves and carry out the firmware update in BOOTSTRAP mode as described above.


Firmware compatibility

Appendix [image] Firmware compatibility
Firmware compatibility
Beckhoff EtherCAT devices are delivered with the latest available firmware version. Compatibility of firmware and hardware is mandatory; not every combination ensures compatibility. The overview below shows the hardware versions on which a firmware can be operated.
Note
▪
It is recommended to use the newest possible firmware for the respective hardware.
▪
Beckhoff is not under any obligation to provide customers with free firmware updates for delivered products.
Note
Risk of damage to the device!
Pay attention to the instructions for firmware updates on the separate page. If a device is placed in BOOTSTRAP mode for a firmware update, it does not check when downloading whether the new firmware is suitable. This can result in damage to the device! Therefore, always make sure that the firmware is suitable for the hardware version!
ELM3002
Hardware (HW) | Firmware (FW) | Revision no. | Release date
00 – 03* | 01 | 0016 | 2017/09
 | 02 | 0017 | 2018/04
 | 03* | 0017 | 2018/10
ELM3004
Hardware (HW) | Firmware (FW) | Revision no. | Release date
00 – 04* | 01 | 0016 | 2017/06
 | 02 | 0017 | 2017/10
 | 03 | 0017 | 2018/03
 | 04 | 0018 | 2018/08
 | 05* | 0018 | 2018/10
ELM3102
Hardware (HW) | Firmware (FW) | Revision no. | Release date
00 – 03* | 01 | 0016 | 2017/09
 | 02 | 0017 | 2018/04
 | 03 | 0017 | 2018/10
 | 04* | 0017 | 2019/08
ELM3104
Hardware (HW) | Firmware (FW) | Revision no. | Release date
00 – 04* | 01 | 0016 | 2017/07
 | 02 | 0017 | 2018/04
 | 03* | 0017 | 2018/10
 | 04* | 0017 | 2019/08
ELM3142
Hardware (HW) | Firmware (FW) | Revision no. | Release date
00 | 01 | 0016 |
ELM3144
Hardware (HW) | Firmware (FW) | Revision no. | Release date
00 | 01 | 0016 |
ELM3146
Hardware (HW) | Firmware (FW) | Revision no. | Release date
00 | 01 | 0016 |
ELM3148
Hardware (HW) | Firmware (FW) | Revision no. | Release date
00 | 01 | 0016 | 2019/02
01 | 02 | 0016 |
ELM3502
Hardware (HW) | Firmware (FW) | Revision no. | Release date
00 – 02 | 01 | 0016 | 2018/07
 | 02 | 0017 | 2018/10
00 – 03* | 03 | 0018 | 2019/05
 | 04* | 0018 | 2019/07
ELM3504
Hardware (HW) | Firmware (FW) | Revision no. | Release date
00 – 03 | 01 | 0016 | 2018/07
 | 02 | 0017 | 2018/10
00 - 04* | 03* | 0018 | 2019/07
ELM3602
Hardware (HW) | Firmware (FW) | Revision no. | Release date
00 – 03* | 01 | 0016 | 2018/01
 | 02 | 0016 | 2018/02
 | 03 | 0017 | 2018/04
 | 04 | 0017 | 2018/09
 | 05* | 0017 | 2019/01
ELM3604
Hardware (HW) | Firmware (FW) | Revision no. | Release date
00 – 03* | 01 | 0016 | 2018/01
 | 02 | 0016 | 2018/03
 | 03 | 0017 | 2018/04
 | 04 | 0017 | 2018/09
 | 05* | 0017 | 2019/01
ELM3702-0000
Hardware (HW) | Firmware (FW) | Revision no. | Release date
00 | 01 | 0016 |
ELM3704-0000
Hardware (HW) | Firmware (FW) | Revision no. | Release date
00 | 01 | 0016 |
ELM3704-0001
Hardware (HW) | Firmware (FW) | Revision no. | Release date
00 | 01 | 0016 |
*) This is the current compatible firmware/hardware version at the time of the preparing this documentation. Check on the Beckhoff web page whether more up-to-date documentation is available.


Firmware compatibility - passive terminals

Appendix [image] Firmware compatibility - passive terminals
Firmware compatibility - passive terminals
The passive terminals ELxxxx terminal series have no firmware to update.


Restoring the delivery state

Appendix [image] Restoring the delivery state
Restoring the delivery state
To restore the delivery state for backup objects in ELxxxx terminals, the CoE object Restore default parameters, SubIndex 001 can be selected in the TwinCAT System Manager (Config mode) (see Fig. Selecting the Restore default parameters PDO)
Selecting the Restore default parameters PDO
Double-click on SubIndex 001 to enter the Set Value dialog. Enter the value 1684107116 in field Dec or the value 0x64616F6C in field Hex and confirm with OK (Fig. Entering a restore value in the Set Value dialog).
All backup objects are reset to the delivery state.
Entering a restore value in the Set Value dialog
Alternative restore value
In some older terminals the backup objects can be switched with an alternative restore value: Decimal value: 1819238756, Hexadecimal value: 0x6C6F6164An incorrect entry for the restore value has no effect.


Notes on analog measured values

Appendix [image] Notes on analog measured values
Notes on analog measured values
Additional information
•
Notices on analog specifications
•
Notes regarding analog equipment - shielding and earth
•
Notes on analog aspects ‑ dynamic signals
•
Notes on analog aspects to EL3751/ ELM3xxx
•
Note on Beckhoff calibration certificates
•
Readjusting the specification


Notices on analog specifications

Appendix [image] Notes on analog measured values [image] Notices on analog specifications
Notices on analog specifications
Beckhoff I/O devices (terminals, boxes, modules) with analog inputs are characterized by a number of technical characteristic data; refer to the technical data in the respective documents.
Some explanations are given below for the correct interpretation of these characteristic data.
Additional information
•
Full scale value (FSV)
•
Measuring error/ measurement deviation
•
Temperature coefficient tK [ppm/K]
•
Single-ended/differential typification
•
Common-mode voltage and reference ground (based on differential inputs)
•
Dielectric strength
•
Temporal aspects of analog/digital conversion


Full scale value (FSV)

Appendix [image] Notes on analog measured values [image] Notices on analog specifications [image] Full scale value (FSV)
Full scale value (FSV)
An I/O device with an analog input measures over a nominal measuring range that is limited by an upper and a lower limit (initial value and end value); these can usually be taken from the device designation.
The range between the two limits is called the measuring span and corresponds to the equation (end value - initial value). Analogous to pointing devices this is the measuring scale (see IEC 61131) or also the dynamic range.
For analog I/O devices from Beckhoff the rule is that the limit with the largest value is chosen as the full scale value of the respective product (also called the reference value) and is given a positive sign. This applies to both symmetrical and asymmetrical measuring spans.
Full scale value, measuring span
For the above examples this means:
▪
Measuring range 0...10 V: asymmetric unipolar, full scale value = 10 V, measuring span = 10 V
▪
Measuring range 4...20 mA: asymmetric unipolar, full scale value = 20 mA, measuring span = 16 mA
▪
Measuring range -200...1370°C: asymmetric bipolar, full scale value = 1370°C, measuring span = 1570°C
▪
Measuring range -10...+10 V: symmetric bipolar, full scale value = 10 V, measuring span = 20 V
This applies to analog output terminals/ boxes (and related Beckhoff product groups).


Measuring error/ measurement deviation

Appendix [image] Notes on analog measured values [image] Notices on analog specifications [image] Measuring error/ measurement deviation
Measuring error/ measurement deviation
The relative measuring error (% of the full scale value) is referenced to the full scale value and is calculated as the quotient of the largest numerical deviation from the true value (‘measuring error’) referenced to the full scale value.
The measuring error is generally valid for the entire permitted operating temperature range, also called the ‘usage error limit’ and contains random and systematic portions of the referred device (i.e. ‘all’ influences such as temperature, inherent noise, aging, etc.).
It is always to be regarded as a positive/negative span with ±, even if it is specified without ± in some cases.
The maximum deviation can also be specified directly.
Example: Measuring range 0...10 V and measuring error < ± 0.3 % full scale value → maximum deviation ± 30 mV in the permissible operating temperature range.
Lower measuring error
Since this specification also includes the temperature drift, a significantly lower measuring error can usually be assumed in case of a constant ambient temperature of the device and thermal stabilization after a user calibration.
This applies to analog output devices.


Temperature coefficient tK [ppm/K]

Appendix [image] Notes on analog measured values [image] Notices on analog specifications [image] Temperature coefficient tK [ppm/K]
Temperature coefficient tK [ppm/K]
An electronic circuit is usually temperature dependent to a greater or lesser degree. In analog measurement technology this means that when a measured value is determined by means of an electronic circuit, its deviation from the “true” value is reproducibly dependent on the ambient/operating temperature.
A manufacturer can alleviate this by using components of a higher quality or by software means.
The temperature coefficient, when indicated, specified by Beckhoff allows the user to calculate the expected measuring error outside the basic accuracy at 23 °C.
Due to the extensive uncertainty considerations that are incorporated in the determination of the basic accuracy (at 23 °C), Beckhoff recommends a quadratic summation.
Example: Let the basic accuracy at 23 °C be ±0.01% typ. (full scale value), tK = 20 ppm/K typ.; the accuracy A35 at 35 °C is wanted, hence ΔT = 12 K
General information about the measuring error_formula_en.png
Remarks:
ppm ≙ 10-6
% ≙ 10-2


Single-ended/differential typification

Appendix [image] Notes on analog measured values [image] Notices on analog specifications [image] Single-ended/differential typification
Single-ended/differential typification
For analog inputs Beckhoff makes a basic distinction between two types: single-ended (SE) and differential (DIFF), referring to the difference in electrical connection with regard to the potential difference.
The diagram shows two-channel versions of an SE module and a DIFF module as examples for all multi-channel versions.
SE and DIFF module as 2-channel version
Note: Dashed lines indicate that the respective connection may not necessarily be present in each SE or DIFF module. Electrical isolated channels are operating as differential type in general, hence there is no direct relation (voltaic) to ground within the module established at all. Indeed, specified information to recommended and maximum voltage levels have to be taken into account.
The basic rule:
▪
Analog measurements always take the form of voltage measurements between two potential points.
For voltage measurements a large R is used, in order to ensure a high impedance. For current measurements a small R is used as shunt. If the purpose is resistance measurement, corresponding considerations are applied.
–
Beckhoff generally refers to these two points as input+/signal potential and input-/reference potential.
–
For measurements between two potential points two potentials have to be supplied.
–
Regarding the terms “single-wire connection” or “three-wire connection”, please note the following for pure analog measurements: three- or four-wire connections can be used for sensor supply, but are not involved in the actual analog measurement, which always takes place between two potentials/wires.
In particular this also applies to SE, even though the term suggest that only one wire is required.
▪
The term “electrical isolation” should be clarified in advance.
Beckhoff IO modules feature 1..8 or more analog channels; with regard to the channel connection a distinction is made in terms of:
–
how the channels WITHIN a module relate to each other, or
–
how the channels of SEVERAL modules relate to each other.

The property of electrical isolation indicates whether the channels are directly connected to each other.
–
Beckhoff terminals/ boxes (and related product groups) always feature electrical isolation between the field/analog side and the bus/EtherCAT side. In other words, if two analog terminals/ boxes are not connected via the power contacts (cable), the modules are effectively electrically isolated.
–
If channels within a module are electrically isolated, or if a single-channel module has no power contacts, the channels are effectively always differential. See also explanatory notes below. Differential channels are not necessarily electrically isolated.
▪
Analog measuring channels are subject to technical limits, both in terms of the recommended operating range (continuous operation) and the destruction limit. Please refer to the respective terminal/ box documentation for further details.
Explanation
▪
differential (DIFF)
–
Differential measurement is the most flexible concept. The user can freely choose both connection points, input+/signal potential and input-/reference potential, within the framework of the technical specification.
–
A differential channel can also be operated as SE, if the reference potential of several sensors is linked. This interconnection may take place via the system GND.
–
Since a differential channel is configured symmetrically internally (cf. Fig. SE and DIFF module as 2-channel variant), there will be a mid-potential (X) between the two supplied potentials that is the same as the internal ground/reference ground for this channel. If several DIFF channels are used in a module without electrical isolation, the technical property VCM (common-mode voltage) indicates the degree to which the mean voltage of the channels may differ.
–
The internal reference ground may be accessible as connection point at the terminal/ box, in order to stabilize a defined GND potential in the terminal/ box. In this case it is particularly important to pay attention to the quality of this potential (noiselessness, voltage stability). At this GND point a wire may be connected to make sure that VCM,max is not exceeded in the differential sensor cable.
If differential channels are not electrically isolated, usually only one VCM, max is permitted. If the channels are electrically isolated this limit should not apply, and the channels voltages may differ up to the specified separation limit.
–
Differential measurement in combination with correct sensor wiring has the special advantage that any interference affecting the sensor cable (ideally the feed and return line are arranged side by side, so that interference signals have the same effect on both wires) has very little effect on the measurement, since the potential of both lines varies jointly (hence the term common mode). In simple terms: Common-mode interference has the same effect on both wires in terms of amplitude and phasing.
–
Nevertheless, the suppression of common-mode interference within a channel or between channels is subject to technical limits, which are specified in the technical data.
–
Further helpfully information on this topic can be found on the documentation page Configuration of 0/4..20 mA differential inputs (see documentation for the EL30xx terminals, for example).
▪
Single Ended (SE)
–
If the analog circuit is designed as SE, the input/reference wire is internally fixed to a certain potential that cannot be changed. This potential must be accessible from outside on at least one point for connecting the reference potential, e.g. via the power contacts (cable).
–
In other words, in situations with several channels SE offers users the option to avoid returning at least one of the two sensor cables to the terminal/ box (in contrast to DIFF). Instead, the reference wire can be consolidated at the sensors, e.g. in the system GND.
–
A disadvantage of this approach is that the separate feed and return line can result in voltage/current variations, which a SE channel may no longer be able to handle. See common-mode interference. A VCM effect cannot occur, since the module channels are internally always 'hard-wired' through the input/reference potential.
Typification of the 2/3/4-wire connection of current sensors
Current transducers/sensors/field devices (referred to in the following simply as ‘sensor’) with the industrial 0/4-20 mA interface typically have internal transformation electronics for the physical measured variable (temperature, current, etc.) at the current control output. These internal electronics must be supplied with energy (voltage, current). The type of cable for this supply thus separates the sensors into self-supplied or externally supplied sensors:
Self-supplied sensors
▪
The sensor draws the energy for its own operation via the sensor/signal cable + and -.
So that enough energy is always available for the sensor’s own operation and open-circuit detection is possible, a lower limit of 4 mA has been specified for the 4-20 mA interface; i.e. the sensor allows a minimum current of 4 mA and a maximum current of 20 mA to pass.
▪
2-wire connection see Fig. 2-wire connection, cf. IEC60381-1
▪
Such current transducers generally represent a current sink and thus like to sit between + and – as a ‘variable load’. Refer also to the sensor manufacturer’s information.
2-wire connection
Therefore, they are to be connected according to the Beckhoff terminology as follows:
preferably to ‘single-ended’ inputs if the +Supply connections of the terminal/ box are also to be used - connect to +Supply and Signal
they can, however, also be connected to ‘differential’ inputs, if the termination to GND is then manufactured on the application side – to be connected with the right polarity to +Signal and –Signal
It is important to refer to the information page Configuration of 0/4..20 mA differential inputs (see documentation for the EL30xx terminals, for example)!
Externally supplied sensors
▪
3- and 4-wire connection see Fig. Connection of externally supplied sensors, cf. IEC60381-1
▪
the sensor draws the energy/operating voltage for its own operation from two supply cables of its own. One or two further sensor cables are used for the signal transmission of the current loop:
–
1 sensor cable: according to the Beckhoff terminology such sensors are to be connected to ‘single-ended’ inputs in 3 cables with +/-/Signal lines and if necessary FE/shield
–
2 sensor cables: for sensors with 4-wire connection based on +supply/-supply/+signal/-signal, check whether +signal can be connected to +supply or –signal to –supply.
- Yes: then you can connect accordingly to a Beckhoff ‘single-ended’ input.
- No: the Beckhoff ‘differential’ input for +Signal and –Signal is to be selected; +Supply and –Supply are to be connected via additional cables.
It is important to refer to the information page Configuration of 0/4..20 mA differential inputs (see documentation for the EL30xx terminals, for example)!
Note: expert organizations such as NAMUR demand a usable measuring range <4 mA/>20 mA for error detection and adjustment, see also NAMUR NE043.
The Beckhoff device documentation must be consulted in order to see whether the respective device supports such an extended signal range.
Usually there is an internal diode existing within unipolar terminals/ boxes (and related product groups), in this case the polarity/direction of current have to be observed.
Connection of externally supplied sensors
Classification of the Beckhoff terminals/ boxes - Beckhoff 0/4-20 mA terminals/ boxes (and related product groups) are available as differential and single-ended terminals/ boxes (and related product groups):
Single-ended EL3x4x: 0-20 mA, EL3x5x: 4-20 mA; KL and related product groups exactly the same | Differential EL3x1x: 0-20 mA, EL3x2x: 4-20 mA; KL and related product groups exactly the same
Preferred current direction because of internal diode | Preferred current direction because of internal diode
Designed for the connection of externally-supplied sensors with a 3/4-wire connection | The terminal/ box is a passive differential current measuring device; passive means that the sensor is not supplied with power.
Designed for the connection of self-supplied sensors with a 2-wire connection |
Single-ended
Differential
2-, 3- and 4-wire connection at single-ended and differential inputs


Common-mode voltage and reference ground (based on differential inputs)

Appendix [image] Notes on analog measured values [image] Notices on analog specifications [image] Common-mode voltage and reference ground (based on differential inputs)
Common-mode voltage and reference ground (based on differential inputs)
Common-mode voltage (Vcm) is defined as the average value of the voltages of the individual connections/inputs and is measured/specified against reference ground.
Common-mode voltage (Vcm)
The definition of the reference ground is important for the definition of the permitted common-mode voltage range and for measurement of the common-mode rejection ratio (CMRR) for differential inputs.
The reference ground is also the potential against which the input resistance and the input impedance for single-ended inputs or the common-mode resistance and the common-mode impedance for differential inputs is measured.
The reference ground is usually accessible at or near the terminal/ box, e.g. at the terminal contacts, power contacts (cable) or a mounting rail. Please refer to the documentation regarding positioning. The reference ground should be specified for the device under consideration.
For multi-channel terminals/ boxes with resistive (=direct, ohmic, galvanic) or capacitive connection between the channels, the reference ground should preferably be the symmetry point of all channels, taking into account the connection resistances.
Reference ground samples for Beckhoff IO devices:
1.
Internal AGND fed out: EL3102/EL3112, resistive connection between the channels
2.
0V power contact: EL3104/EL3114, resistive connection between the channels and AGND; AGND connected to 0V power contact with low-resistance
3.
Earth or SGND (shield GND):
–
EL3174-0002: Channels have no resistive connection between each other, although they are capacitively coupled to SGND via leakage capacitors
–
EL3314: No internal ground fed out to the terminal points, although capacitive coupling to SGND


Dielectric strength

Appendix [image] Notes on analog measured values [image] Notices on analog specifications [image] Dielectric strength
Dielectric strength
A distinction should be made between:
▪
Dielectric strength (destruction limit): Exceedance can result in irreversible changes to the electronics
–
Against a specified reference ground
–
Differential
▪
Recommended operating voltage range: If the range is exceeded, it can no longer be assumed that the system operates as specified
–
Against a specified reference ground
–
Differential
Recommended operating voltage range
The device documentation may contain particular specifications and timings, taking into account:
▪
Self-heating
▪
Rated voltage
▪
Insulating strength
▪
Edge steepness of the applied voltage or holding periods
▪
Normative environment (e.g. PELV)


Temporal aspects of analog/digital conversion

Appendix [image] Notes on analog measured values [image] Notices on analog specifications [image] Temporal aspects of analog/digital conversion
Temporal aspects of analog/digital conversion
The conversion of the constant electrical input signal to a value-discrete digital and machine-readable form takes place in the analog Beckhoff EL/KL/EP input modules with ADC (analog digital converter). Although different ADC technologies are in use, from a user perspective they all have a common characteristic: after the conversion a certain digital value is available in the controller for further processing. This digital value, the so-called analog process data, has a fixed temporal relationship with the “original parameter”, i.e. the electrical input value. Therefore, corresponding temporal characteristic data can be determined and specified for Beckhoff analogue input devices.
This process involves several functional components, which act more or less strongly in every AI (analog input) module:
▪
the electrical input circuit
▪
the analog/digital conversion
▪
the digital further processing
▪
the final provision of the process and diagnostic data for collection at the fieldbus (EtherCAT, K‑bus, etc.)
Signal processing analog input
Two aspects are crucial from a user perspective:
▪
“How often do I receive new values?”, i.e. a sampling rate in terms of speed with regard to the device/channel
▪
What delay does the (whole) AD conversion of the device/channel cause?
I.e. the hardware and firmware components in its entirety. For technological reasons, the signal characteristics must be taken into account when determining this information: the run times through the system differ, depending on the signal frequency.
This is the “external” view of the “Beckhoff AI channel” system – internally the signal delay in particular is composed of different components: hardware, amplifier, conversion itself, data transport and processing. Internally a higher sampling rate may be used (e.g. in the deltaSigma converters) than is offered “externally” from the user perspective. From a user perspective of the “Beckhoff AI channel” component this is usually irrelevant or is specified accordingly, if it is relevant for the function.
For Beckhoff AI devices the following specification parameters for the AI channel are available for the user from a temporal perspective:
1. Minimum conversion time [ms, µs]
This is the reciprocal value of the maximum sampling rate [sps, samples per second]:
Indicates how often the analog channel makes a newly detected process data value available for collection by the fieldbus. Whether the fieldbus (EtherCAT, K-bus) fetches the value with the same speed (i.e. synchronous), or more quickly (if the AI channel operates in slow FreeRun mode) or more slowly (e.g. with oversampling), is then a question of the fieldbus setting and which modes the AI device supports.
For EtherCAT devices the so-called toggle bit indicates (by toggling) for the diagnostic PDOs when a newly determined analog value is available.
Accordingly, a maximum conversion time, i.e. a smallest sampling rate supported by the AI device, can be specified.
Corresponds to IEC 61131-2, section 7.10.2 2, “Sampling repeat time”
2. Typical signal delay
Corresponds to IEC 61131-2, section 7.10.2 1, “Sampling duration”. From this perspective it includes all internal hardware and firmware components, but not “external” delay components from the fieldbus or the controller (TwinCAT).
This delay is particularly relevant for absolute time considerations, if AI channels also provide a time stamp that corresponds to the amplitude value – which can be assumed to match the physically prevailing amplitude value at the time.
Due to the frequency-dependent signal delay time, a dedicated value can only be specified for a given signal. The value also depends on potentially variable filter settings of the channel.
A typical characterization in the device documentation may be:
2.1 Signal delay (step response)
Keywords: Settling time
The square wave signal can be generated externally with a frequency generator (note impedance!)
The 90 % limit is used as detection threshold.
The signal delay [ms, µs] is then the time interval between the (ideal) electrical square wave signal and the time at which the analog process value has reached the 90 % amplitude.
Diagram signal delay (step response)
2.2 Signal delay (linear)
Keyword: Group delay
Describes the delay of a signal with constant frequency
A test signal can be generated externally with a frequency generator, e.g. as sawtooth or sine. A simultaneous square wave signal would be used as reference.
The signal delay [ms, µs] is then the interval between the applied electrical signal with a particular amplitude and the moment at which the analog process value reaches the same value.
A meaningful range must be selected for the test frequency, e.g. 1/20 of the maximum sampling rate.
Diagram signal delay (linear)
3. Additional Information
May be provided in the specification, e.g.
▪
Actual sampling rate of the ADC (if different from the channel sampling rate)
▪
Time correction values for run times with different filter settings
▪
etc.


Notes regarding analog equipment - shielding and earth

Appendix [image] Notes on analog measured values [image] Notes regarding analog equipment - shielding and earth
Notes regarding analog equipment - shielding and earth
Meticulous application of the term “earth” is required, particularly when it comes to reliable use of analog (measuring) signals. The conductive coupling of different potentials, such as earth potential and a housing potential or the earth points of analog devices, can have different aims:
1.
Earthing as protective measure against the occurrence of dangerous touch voltages (PE)
2.
Earthing for definition of a common signal potential, in order to ensure the function of analog measurements, for example
3.
Earthing for discharging of interference or internally generated emissions (FE); keywords: interference immunity and interference emission
In each case the user should be clear which of the above aims is to be achieved through the respective measures. The respective reference earth can have different potential!
The observations, measures and effects described below primarily refer to 3. “FE/functional earth”, taking into account the requirements of 2. “Common reference potential”. Information and specifications relating to 1. “PE” can be found in the relevant guidelines, such as VDE0100, and is not part of this section on analog equipment. The focus and application area of the following notes is for the scope of analog signal transmission.
The terms “protective earth” and “functional earth”
This section primarily deals with functional earth (FE,
symbol: ) as a functionally relevant regular part of an installation, in contrast to protective earth (PE, symbol: ), which is intended to protect persons from excessive touch voltages.
This document
This document provides general recommendations based on practical experience, without taking into account specific features of particular installations. These recommendations should be regarded as a collection of technical solution options. System manufacturers should check to what extent the measures described here are applicable to their system, and which of the suggested measures should be implemented. To this end, different measuring and testing techniques should be used. Any problems should be examined thoroughly, in order to ascertain the trigger and the fault location.
This document attempts to deal with a complex issue and does not claim to be exhaustive. We gladly accept suggestions or critical comments.
Lightning protection
Lightning protection aspects are not considered.
Potentially explosive areas
Special regulations and procedures may apply for potentially explosive atmospheres and supply lines for such areas, which are not covered by this documentation.
Reference to individual documents
Special instructions and documentation relating to the devices used must be followed.
Recommended procedure in the event of a conspicuousness
1.
Use this document, other publicly available documents/standards and manufacturer documentation to familiarise yourself with the background and practical characteristics of EMC interference.
Reflect on the mechanism of action between source of interference → transfer path → interference sink.
2.
Use the specified diagnostic methods to isolate the interference sink, i.e. the location/device that does not work properly
3.
Reflect on how the fault could have occurred, taking into account the background information from section 1.
4.
Use the information and solution proposals provided to weigh up system-specific options or normative specifications/restrictions. We recommend to only change one component at a time, in order to verify the effectiveness of the respective measure.
5.
At the same time, use the specified diagnostic methods to ascertain whether the source of interference or the transfer path has been found.
Functional chain: source of interference – coupling – interference sink
The undesirable effect of a source of interference on an interference sink via the coupling can be reduced or completely suppressed through the measures described below. A fault results in modification of a wanted signal. In the worst case, the recipient of the wanted signal is no longer able to interpret the information content, or its operation is disturbed due to the modified amplitude/frequency or even electrical damaged.
The fault can be transferred by wire or by radiation.
A device can simultaneously act as source of interference and as interference sink (depending on the effective direction).
A cable/device acts as source of interference [image] through strong/weak interference effect (emissions, interference emission) due to (e.g.)
▪
strong/weak interference effect through emissions, i.e. interference emissions
▪
insufficient suppression through shielding, chokes, filters
▪
insufficient avoidance through discharge facilities, spark gaps, incorrectly dimensioned termination resistors
A cable/device acts as interference sink [image] through strong/weak susceptibility to interference, i.e. inadequate immunity to interference due to (e.g.)
▪
missing or inadequately implemented protection components: shielding, compensating elements, discharge facilities, spark gaps
In general, the following mechanisms are available for coupling a fault with the wanted signal:
Shielding measures or interference generation prevention may be applied as remedial action.
Galvanic coupling – measures against transfer:
▪
Separation of different potentials, avoidance of equalising currents
▪
Star wiring, no ladder network
Capacitive coupling – measures against transfer:
▪
Spatial separation
▪
Full, close-meshed shielding of the signal cable without interruption or holes.
Holes in the sense of this documentation are uncovered areas of the order of centimetres.
Significant signal components can be emitted or unintentionally received from a hole with a size of 10 % of the wavelengths.
▪
Single-sided, low-impedance connection of the shielding to system earth
Inductive coupling – measures against transfer:
▪
spatial separation
▪
Shielding, see capacitive coupling
▪
Two-sided, low-impedance connection of the shielding to system earth
▪
Equidirectional, tight twisting (high twisting rate) of the analog signal cables with each other
Wireless coupling - measures:
▪
Short cable lengths
▪
Shielding, see capacitive coupling
Common signal potential, basic measures and notices
In some applications the reference potentials of different devices have to be linked, e.g. in order to be able to perform a measurement.
▪
Usually, no equalising currents should flow via such connections – for remedial measures see the following section.
▪
Buffer amplifiers may have to be used in some cases
▪
Potential-free connections on the device side may be suitable in some cases – note the permitted potential difference!
FE/shielding, basic measures and information
A list of exemplary measures, taking into account the information provided above, which may be considered in order to reduce interference, is provided below.
▪
Temporal effectiveness: the effectiveness of implemented measures may reduce over time and should therefore be checked regularly, particularly in the event of anomalies. Negative influencing factors include broken wire, oxidation at contact points, mechanical damage, change in earthing characteristics, change in environment (new interference sources?), etc.
▪
Selected reference potential
–
The reference potential used for discharge/earthing may itself be subject to interference, so that a connection to it may introduce more interference in the system than it discharges. In this case, a different, low-interference reference potential should be used.
–
To ensure good discharge, it may be helpful to install a separate FE earthing point in the building and use it for sensitive signals/shielding.
Caution in the event of lightning strike: a lightning strike in the vicinity can result in large potential differences between buildings and earth, which can affect locally separated earthing equipment. Spark gaps may be able to prevent equipment damage. VDE guidelines must be followed!
Wanted signal routing
▪
Cable routing
–
The cable connections should be as short as possible
–
The denser the cables can be laid over a metallic area/equipotential bonding, the less interference can be introduced, and the more interference is discharged capacitively via earth.
–
Analog signal cables that are susceptible to interference and load cables with strong interference potential:
- parallel installation, with a distance of at least 20 cm from each other
- avoid parallel installation
- unshielded cables should be twisted, if possible
- provide shielding through metallic isolating strips
–
Use wire end sleeves or cable sockets to connect flexible cables/strands. Tinning is no longer permitted.
–
Unused wires/cables should be earthed on one side as a minimum.
▪
Shielding
–
Shielding must not be used to function as N or PE conductor.
Functional earth intended for improving EMC (electromagnetic compatibility) must not be used as protective earth according to VDE 0100.
–
The shielding should not be used to carry discharge/fault currents.
–
Some connection technologies as coax requires signal ground and shield on the same conductor. This can be disadvantageous in specific environments. So it should be checked, if another connection method can be used that provides a separate shield as e.g. triax.
▪
Shield configuration
–
If braided screen is used, it should consist of tin-coated/nickel-plated copper. Aluminium braid may be suitable, provided the specific properties are taken into account.
–
For cables shielded with braid, the cover should be 60% to 95%.
–
In special cases magnetic shielding using magnetically conductive, highly permeable material may be required.
–
Cable shielding may consist of braid and/or electrically conductive foil. The use of foil on its own is inappropriate, since it can easily be interrupted.
–
Contacting of the electrically conductive foil alone for the purpose of shield coupling is not permitted; the braiding must be contacted. Amongst others, the contacting of the electrically conductive foil confects a too low galvanic coupling and is moreover mechanical less resistant.
–
Earthed metal tubes used for shrouding cable can offer additional shielding
▪
Shield connection
–
For discharge purposes, a “good connection” should be aimed for, i.e.
- low-impedance connection → cross-section as large as possible, fine-wired, perhaps earthing strap
- short cables
- large-area contact, perhaps EMC gasket
- 360°, if possible
- metallic conductive components without contaminants, lacquer, fat, oxide layer
- Pig tails (braid twisted at the end or wire attached to the braid) significantly reduce the effectiveness of the shield coupling. It’s strictly recommended not to use it – particularly with regard to increased immunity to interference requirements.
Beckhoff offers the ZB8500 shield connection system for this purpose. And also see section “Shielding concept”.
▪
Hum interference may occur if several cables that are connected on both sides run between two devices (“earth loop”). However, opening of the shield on one side can significantly reduce the shield effectiveness. A better solution is coupling of the respective shield on one side via a coupling capacitor (C = 10.. 100nF, bipolar). This provides separation for DC, while currents from HF influence can still be discharged.
The coupling capacitor C must have adequate dielectric strength. In some situations it may be advisable to connect a resistance R in the MΩ range parallel to the capacitor.
SmallWarningYellow CAUTION
Potentially explosive atmospheres
Note special regulations for potentially explosive atmospheres!
▪
If the shielded cable continues after the shield contact, the further free cable length under shielding should be no longer than a few segments of 10 cm. This also applies to cables within control cabinets.
▪
Manufacturers sometimes equip devices with an RC combination between earth and PE. On the one hand this can achieve good discharge capacity for HF interference, on the other hand the device may not be damaged inadvertently through high leakage currents. Such an RC combination on the device side as connection between earth and PE counts as earth-free coupling.

A high-resistance resistor prevents excessive leakage currents. The capacitor short-circuits high-frequency peaks with low impedance. A specified dielectric strength applies for the combination.
Good interference protection can be achieved if a shielded cable is laid completely earth-free (only RC connection on both sides).
▪
If a shielded cable has a drain wire, connection of this conductor to the shield coupling only is inadequate. At the cable end the shield and the drain wire should be connected together at the designated shield point.
▪
Connection of the shielding with sources of interference - only expected outside the control cabinet
–
Apply the shielding at the control cabinet entry
–
Continuation of the shielding within the control cabinet may not be necessary
▪
Connection of the shielding with sources of interference - also expected inside the control cabinet
–
see: notices on control cabinet design
–
The shielding should be opened after the entry into the control cabinet, applied and then continued up to the terminal. At the device it should be contacted again (terminal contact or separate shield coupling).
Equalisation of potential difference
▪
If signal or communication lines are run over longer distances, the installation should be checked for potential differences. Example: ribbon conductors in a wind turbine tower. To prevent equalising currents in the shielding:
–
suitable equipotential bonding conductors can be provided
–
optical fibre can be used
–
buffer amplifiers can be used
▪
The equipotential bonding conductor should be fine-wired, so that it has a large surface area to ensure effectiveness for high-frequency interference currents. In addition, compliance with the minimum diameters according to IEC 60364-5-54 is required
–
copper 6 mm²
–
aluminium 16 mm²
–
steel 50 mm²
▪
The earthing system should have a star configuration.
▪
The PE connection replaces neither HF earthing nor the shielding, but is required for safety reasons.
▪
Lightning protection may have to be provided.
▪
Atmospheric influences can lead to significant potential shifts.
Additional safety measures
▪
For connected inductors and capacitors protective circuits/extinguishing equipment must be provided on the device side, in order to prevent voltage peaks as long the connected device does not already support such a performance.
▪
Filter components against interference emission should be used if necessary, e.g. in the form of current-compensating chokes or toroidal core ferrites
▪
Pick up the power supply for the measuring equipment in a star shape from the central supply source.
Lay the feed and return wire together side by side
▪
Thermoelectric effects in the mV range could have a disturbing effect to analog signals and also
–
Avoid potential differences between different materials
–
Check the temperature or material, if necessary
Practice-oriented diagnostic methods for system examination
The following section lists some options for checking the effectiveness of shielding measures:
▪
Visual inspection
▪
Acoustic inspection (listen for voltage flash-overs)
▪
Voltage measurement with voltmeter between suspect system points
▪
Monitoring of voltages on shielding conductors with an oscilloscope that is suitable for high frequencies
▪
Current measurement of equalising currents on the shielding cable with a clamp-on ammeter.
The current on the shielding should not exceed a few milliamps (True RMS).
▪
Continuity measurement of the shielding and checking for unacceptable shunt
▪
Temperature measurement of surge arresters; the contact point will warm up in the presence of high current passage and high contact resistance


Notes on analog aspects ‑ dynamic signals

Appendix [image] Notes on analog measured values [image] Notes on analog aspects ‑ dynamic signals
Notes on analog aspects ‑ dynamic signals
This chapter deals with the problem of measurement/acquisition of actual analog electrical signals from the industrial automation environment. Such signals are generated by sensors and measured by automation components. With this information, the (software-based) control system perceives the physical system reality and derives follow-up actions from it.
The signals are formed electrically and measured analogously as
▪
signals via industrial interfaces 10 V, 20 mA, …
▪
signals from the sensor directly: voltage of a battery [V], bridge signal [mV/V], current measurement [A], resistance [Ω]…
Signals that do not have to be measured electrically but are already present virtually in the control system can also be analyzed with the tools listed below, but are not the focus of this document.
Introduction
This chapter deals with the usual "circumstances" of real analog sensor signals in industrial environments, which are considered "over time", in the course of which information is transmitted to the controller in the form of
▪
amplitude or signal level, or "signal is present", "signal is not present"
▪
frequency or
▪
a mixture thereof
In practical terms and based on actual examples, this means
▪
the signals are "constant" → battery measurement (but only without load)
▪
or are constantly changing, unpredictable, e.g.:
Weighing in continuous operation.png
(continuous weighing process)

Excitation of a magnetic valve (1).png
(excitation of a solenoid valve)
▪
In most cases they are not constantly cyclic "deterministic", like a 1 kHz sine wave from a frequency generator, but have pauses and change their frequency, i.e. they are "stochastic", e.g.:
Excitation of a magnetic valve (2).png
(excitation of a solenoid valve)
▪
Sometimes they are very steep-edged:
▪
Or not:
Signal of slow slope.png
▪
They are never "ideal" but are subject to disturbance, interference and attenuation:
▪
They can be superimposed, apparently consisting of two superimposed sine signals:
▪
If many frequencies are involved, this is indeed the case:

(the beginning of a song, measured at the loudspeaker)
▪
They change over time, temperature, humidity, installation position, etc.:
▪
And a desired square wave signal (green) quickly becomes something else (red) on the line:
Square wave signal deformed.png
▪
Sometimes all these factors interact, in which case the question arises: "what is the measured value"?
Measurement signal question.png
▪
In any case, they rarely look as ideal and cyclical as here:
Note
The time axis is relative
In the above examples the x/time axis is intentionally not labeled. Whether a signal is fast/slow, flat/steep "only" depends on the evaluation against the set requirement and the measuring time: in a mechanical tensile test (tear test), the signal changes only slightly for a long time, until very steep signal changes in the µs range are suddenly observed at the break point
Although "real" industrial signals are not permanently uniformly ideal and sinusoidal, it is helpful to use the terms and tools of theoretical signal analysis to characterize effects and test the effectiveness of measures. Keywords such as "signal frequency", "edge steepness", "attenuation" and similar can then be applied to the real signal section by section.
This chapter therefore considers the extensive theoretical basis of signal theory (which can be studied via www.wikipedia.com and standard text books) through the eyes of the industrial automation engineer and focuses on
▪
Signal parameters µV..kV, corresponding to Ampere, [image] etc.
▪
Signal frequencies 0 Hz to ~1 MHz
▪
Non-constant signals
▪
that are not ideal
Practical applications
Analog input modules can measure as follows, in order of increasing complexity:
▪
Static electrical variables that do not change over a "short" time: DC voltage or DC current, generally one constant variable, "DC" for short (direct current). This is available e.g. as output voltage of a battery that is not under load.
Note: "short" is a subjective term that very much depends on the particular situation
▪
Dynamic electric variables that change over time: AC voltage or AC current, generally one alternating variable, "AC" for short (alternating current). It has a signal shape that repeats with a certain period. This is present, for example, in the German power supply system with a sinusoidal signal form of 50 Hz or appears in the form of "rapidly" changing measured variables on machines. The reciprocal value of the period value is the frequency f; unit Hz. The maximum value is called amplitude among other things and can refer to the current or voltage value. For a first approach it can be regarded as a constantly repeating, periodic/deterministic signal.
▪
Mixed signals: These are a "mixed form" of several overlaid alternating variables. They take the form of a voltage or current signal containing several alternating variables with different frequencies and amplitudes, and may also contain a DC voltage, which is usually referred to as the "DC component" or "offset". Here too, the first approach should be based on constantly repeating, periodic/deterministic signals
▪
If the signals change in their frequency/amplitude, so-called non-deterministic/stochastic (random) signals, we finally encounter the real cable reality.
A particularly good example of a signal of this kind would be a "noise signal".
It should be noted that the "actual" signals that appear – the "real" signals – are more or less mixed signals, because electronic components are always "lossy" and usually distort a "pure" signal shape. Ideal signals are theoretical variables where no losses are taken into account. Therefore, a signal is specified as a real occurring mixed signal among other things by its maximum amplitude A and the lowest frequency that it contains, i.e. the base frequency.
In addition, the constancy of a frequency in real environments is usually not possible either due to physical conditions. As a rule, it is rather complicated to create an oscillation generating system that is subject to virtually no changes of frequency over time.
Below, we explain what fundamentally needs to be observed when measuring dynamic signals with analog input modules.
Signal theory
The basic accuracies specified in the Beckhoff IO documentation apply in general to static (DC) signals unless stated otherwise. When determining the specification, a DC signal is applied and a measurement is only carried out when the entire measuring system has completely settled down and the measured value does not change within a "short" time. At attempt is made in the production calibration to minimize the residual deviation ∆GDC.
On account of the losses and inertia of resistors, inductances and capacitances in the amplifiers of an electrical input circuit as well as the finite calculation times of digital signal processing blocks, settling requires a certain time (also referred to as settling time). Depending on the layout, this can take between a few nanoseconds and several seconds. Side note: If the thermal settling of the devices/cables also has to be taken into account, it can even take many minutes.
If, on the other hand, a dynamic, time-dependent (AC) signal is measured, the measuring system can never settle to a completely stationary state, because the signal is constantly changing and the rate of change of the AC signal is greater than the settling time of the system. This gives rise to an additional frequency-dependent deviation that is not covered by the DC specification ∆GDC. For example, if the dynamic signal is a sine wave
S(t)=A∙sin(2∙fSignal∙f∙t),
with amplitude A, the additional deviation can be displayed as gain deviation ∆GAC. In reality, this means that Ameasured ≠ Asignal, where not only attenuation Ameasured < Asignal is possible, but also inadvertently amplification Ameasured > Asignal. The total gain deviation then results in
∆Gtot = ∆GAC + ∆GDC (frequency-dependent)
where ∆GAC is the additional gain deviation due to the alternating signal.
Below, a real signal is examined whose signal composition (base frequency, noise, overlaid interferences) changes constantly; nevertheless, an ideal case is assumed with regard to its frequency, which is then constant (f = const.).
Note: since this method has its historical basis in signal transmission in the AC range, the corresponding terms are used: gain/amplification, dB, attenuation and so on. As described later, this often leads to common statements in logarithmic [dB] representation, which have to be converted for low-frequency [ppm] assessment.
The frequency response in dB and ppm
This frequency-dependent deviation can be represented as a so-called frequency response. The frequency response describes the ratio of the output signal to the input signal with regard to the amplitude and the phase for a certain frequency range.
The phase shift is irrelevant in many applications and is therefore often not displayed. However, it should be borne in mind that not only the amplitude of the output signal can change over the frequency, but also the phase of the output signal relative to the input signal.
On a graph of the frequency response, the x-axis always represents the frequency fsignal. The amplitude ratio is displayed either linearly or logarithmically (preferably in the unit dB [decibel]) in the y-axis. Depending on the analysis objective, the linear or logarithmic scaling shows certain characteristics better. It should be emphasized that the scaling (linear/logarithmic) is independent of the unit (Hz, ppm, dB)!
Scaling variants |  | x axis / frequency
 |  | Linear [Hz] | Logarithmic (then preferably in [dB] )
y axis measurement uncertainty Attenuation | Linear | Helpful for accuracy considerations in the ppm range | Unusual, with increasing frequency attenuation is no longer clearly shown
 | Logarithmic (then preferably as attenuation in [dB] ) | Not very helpful the lower frequency range is poorly resolved | Usual for dB representation
The unit dB (decibel, 1/10 Bel) is used to describe the ratios of two values to each other. It has no unit itself! A dB is defined for two powers P1 and P2 by the following equation
With this representation method, for example, it is possible in a system chain with amplifying and attenuating elements to determine a total value simply by the addition and subtraction of the individual values instead of multiplication and division.
For the two electrical power values on the same resistance, the general equation P = U · I, together with Ohm's law, produces a square ratio for the two currents I1 and I2 as well as for the two voltages U1 and U2:

and
transferred to the ratio of the two powers P1 und P2:

and
The square can be written before the logarithm and the following equation thus results in general for two amplitudes A1 and A2 as field variables:
In this context it is helpful to note the following conversions of dB and amplitude ratios:
[dB] | [A2/A1]
40 | 100
20 | 10
3 | 1.414
0 | 1
-3 | 0.707
-20 | 0.1
-40 | 0.01
The following illustration shows the double logarithmic amplitude response of an "ideal", i.e. "calculated" RC circuit configured as a low-pass filter, where R = 1 MΩ and C = 1 nF. Both amplitude and frequency are represented logarithmically:
Amplitude response of a low pass RC circuit
The input signal passes through almost without attenuation up to the frequency marked by the dotted line (fsignal ≈ 159 Hz, amplitude at ‑3 dB, 102 = 100!). Above = to the right of this frequency (obviously even a little before that), the circuit begins to attenuate the input signal noticeably. The marked frequency obviously separates two areas with different behaviors. It is therefore also referred to as the cut-off frequency fc.
Depending on the background to the problem, there are various parameters to describe the amplitude/frequency responses. The ‑3 dB point is one possible parameter and is often used with analog RC filters or digital Butterworth filters.
The graph gives the impression that the amplitude passes through entirely unattenuated up to f = 20 Hz, but that is not the case. Like a view from afar, the dB representation conceals the fact that, from a microscopic point of view with a resolution in % = 1/100 or ppm = 1/1000000 = 10‑6, attenuation does indeed take place. And this is particularly interesting when it comes to analog input modules that are specified with a basic accuracy in the ppm range.
The next illustration shows the same relative attenuation, but in ppm. It is a double-linear representation of the amplitude response of the RC circuit:
Relative "gain" deviation of the RC circuit in ppm up to 50 Hz
The graph shows that at 10 Hz the output amplitude is already smaller relative to the input amplitude by 1968 ppm - in fact a measurement error. Since it is known in concrete terms, this can even be called a measurement error.
From the above table, we therefore select the small attenuation range of interest for metrological modules with some example values:
dB vs. ppm
[dB] | [%] | [ppm]
-0.001 | 0.01 | 115
-0.005 | 0.06 | 575
-0.01 | 0.12 | 1151
-0.02 | 0.23 | 2300
-0.04 | 0.46 | 4595
-0.08 | 0.92 | 9168
-0.2 | 2.28 | 22763
-0.4 | 4.5 | 45007
-0.8 | 8.8 | 87989
-1.6 | 16.82 | 168236
-3 | 29.21 | 292054
An attenuation of ‑3 dB thus means almost 30%FSV or almost 300000 ppmFSV amplitude error! And measurement accuracy of 0.1% corresponds to about 0.01 dB. This sounds dramatic, and rightly so, and is lost in the usual logarithmic dB representation.
The "problem" of the dB representation, however, is mainly due to the fact that a dB representation usually extends over several Hz orders of magnitude - precisely in order to represent the high attenuations and to show linear behavior over wide frequency ranges.
When zooming into the dB representation and for consideration only lower frequency parts, the information is much better:
But before we look at the effect of the frequency response specifically on analog inputs, we need to look at other phenomena.
Filters are everywhere
The above-described "manipulation" of the frequency response takes place by means of so-called filters along the signal processing chain
▪
unavoidably in all electrical, i.e. analog elements
▪
manipulably in the digital, i.e. software elements
Filter can be subdivided according to their application and their implementation. On the one hand, filters are used to influence or change the signal in the time domain, for example to smooth signals or to remove the DC component. Frequency-selecting filters aim to separate certain frequency bands from one another. The above example with the RC circuit is a low-pass filter that allows low frequencies to pass through with almost no attenuation while strongly attenuating higher frequencies. In addition to low-pass filters there are other filter types, such as high-pass filter, band-pass filter and band-stop filter. Other user-defined filters can be designed for other applications that don't fit into these categories, or for complicated applications.
Filters can be constructed either as analog filters (active or passive) or as digital filters in software.
Filters are characterized by their response to certain signal types. Each linear filter has a pulse response or step response and a frequency and phase response. The step response describes the temporal amplitude curve when an (ideal) step is connected to the input; the frequency response describes the amplitude gain (or phase shift) between the output and input signal. If one of the three graphs is known, the other two graphs can be calculated from it.
With many filters, the -3 dB frequency indicates the signal frequency at which the signal is attenuated by -3 dB. As already indicated above, it is also referred to with certain filter types as a cut-off frequency, at which the output power has been halved and the amplitude has fallen to 1/√2 = approx. 70% in comparison with the input amplitude, corresponding to a attenuation of approx. 30%.
Digital filters can be divided into two categories: FIR filters (finite impulse response filters) and IIR filters (infinite impulse response filters). As the names suggest, the two filter types differ by their pulse response in the time range. The following illustrations show the differences in the pulse response of the two filter types:
Example Impulse response of two filters; top FIR filter, bottom IIR filter
FIR filters are described by the mathematical equation
Only input data x(n‑k) are used which are accordingly sampled amplitude and time discrete values. With an FIR filter, the impulse response becomes zero after a finite time, which ultimately means that it is always stable, since there is no feedback, and can exhibit a linear phase response. However, FIR filters require a higher filter order to achieve a performance similar to IIR filters, which results in a longer calculation time. "Higher order" means that more filters have to be calculated one after the other.
IIR filters are described by the following equation
In order to calculate the output value y(n), the previously calculated output data y(n-k) are used in addition to the input data x(n-k). The filter is therefore recursive. For that reason, IIR filters are also called recursive filters. The pulse response of an IIR filter is infinite and thus never settle to zero stationary. This can ultimately lead to instability.
A fundamental effect was mentioned here by the way: the more effect/costly a digital filter is, the higher its complexity and thus the longer its calculation time in the software. This leads in practice to a signal delay.
Nyquist, Shannon and false signals: "Aliasing"
The fundamental sampling theorem states that, if a measuring device samples an analog signal at a constant (steady) sampling rate that is more than twice the highest frequency component present in the signal, the original analog signal can be fully restored from the discrete data points.
(Note: the highest frequency present in the signal is referred to as the bandwidth of this signal.)
After all, this is the actual aim of an analog measurement, i.e. the original signal should be available digitally as accurately as possible ("correct") and complete in the control system for further processing in the program. However, a limit must be imposed here that only signal components (frequency ranges are meant here) that are essential for the further process need to be detected. Ideally, the user will make a conscious choice and reflect this limitation. Example: A slow temperature control must be insensitive to low-frequency signals, because this could disturb the controller.
In order to record the analog signal as accurately as possible, the signal bandwidth fsignal must be limited through suitable filtering (see chapter on "Filters") so that only the desired signal but no interfering signals pass through, and the sampling rate fsampling must be selected such that the signal can be restored from the data points as a true representation of the original signal. We therefore have to examine the relationship between the actual sampling rate fsampling and fsignal.
(Note: each measurement takes place in the two dimensions time and measured variable. Here we concentrate on the temporal dimension, i.e. the sampling).
Theoretical considerations relating to the sampling theorem are illustrated with an analog signal and different sampling rates.
Analog signal (cos) with a frequency of 1 Hz (blue line) sampled at 10 Hz (red circles)
The analog signal with f = 1 Hz was sampled with fsampling = 10 Hz. The largest (and only) frequency component in this sample is 1 Hz, therefore fsignal = 1 Hz and fsampling = 10∙fsignal. It is easy to see that the original analog signal can be reconstructed from the discrete values. For example, a fast Fourier transform (FFT) could be calculated from the above data. This would easily be possible, and the resulting spectrum would extend to fsampling/2 = 5 Hz, with a resolution of 0.2 Hz.
If the analog signal had not been a "pure" sine wave but had been harmonically distorted and noisy, then fsignal would no longer be 1 Hz but usually much larger due to the higher frequency components contained in it. In this case the chosen fsampling must be significantly greater than f, depending on the evaluation aim. This also applies in general terms, as will be explained a little later.
The next figure shows what happens if the fSignal = 1 Hz signal is sampled at fsampling = 2 Hz, i.e. fsampling = 2 · fSignal.
Analog signal (cos) with a frequency of 1 Hz (blue line), sampled at 2 Hz (red circles) and interpolated / "traced" (red line)
Since in this sample a specification resulting from the sampling theorem is just about met, it is still possible to detect the frequency and amplitude of the signal: fsampling is equal to 2 ∙ fSignal.
However, this is no longer possible in general, as the following problem becomes apparent here, if one imagines that the sampling moments would be randomly shifted by 90° relative to the signal. In this case the value of the signal at each sample point would be zero, and it would no longer be possible to detect the frequency or amplitude.
In practice, it is much more likely that the measuring points lie "somewhere" on the signal:
In this case, at least the frequency can still be determined due to the zero crossings, but the peak value (and thus very important signal information) cannot be determined because it is not clear where the measuring points are located on the original signal. In practice, however, neither fsampling nor fsignal will be highly constant, and longer observation will result in variable phasing and the peak value will still be caught "at some point". However, this is of little use with fast-moving industrial signals.
After these theoretical considerations, let us now look at a concrete real example: the induced voltage of a rotating gear wheel on a coil as speed sensor results in the following representation in TwinCAT ScopeView:
TCScopeView_Example signal speed sensor.png
Selecting a higher sampling frequency (sampling rate) would be advantageous here in order to be able to follow the amplitude curve better, because signals seem to overlap here. The zero crossings may be sufficient for speed observation.
The frequency
is also called the Nyquist frequency. If an analog signal contains frequency components equal to or greater than the Nyquist frequency, the original signal can no longer be reconstructed. In practice, the Nyquist frequency is selected to be at least a factor of two to three times greater than the bandwidth of the signal frequency fsignal.
The resulting problem of the non-reconstructable original signal due to fsignal ≥ fNyquist was already hinted at in the previous example. The figure below illustrates the problem.
Analog signal (cos) with a frequency of 1 Hz (blue line), sampled at 1.1 Hz (red circles) and interpolated / "traced" (red line)
Here fsampling = 1.1 · fSignal. The frequency information of the original blue signal has been lost. From the control system point of view (which only "sees" the red measuring points), it appears that the measured red signal is a signal with a lower frequency. This effect is called aliasing because a different frequency is detected. It is a common problem when the fundamental sampling theorem (also called the Shannon-Nyquist sampling theorem) is violated. The apparently detected alias frequency in this case is falias = 0.1 Hz.
The Shannon-Nyquist theorem and alias effects focus solely on the question of whether the original analog signal can be reconstructed from the sampled values. This cannot be the sole criterion for selecting an analog input, but it is an essential one. In practice, there are situations where the sampling theorem is deliberately violated, e.g. in order to reliably detect fast signal changes. Since the user already knows a lot about the analog signal to be measured, such considerations are quite possible and in many cases help to optimize the measuring system.
Further effects
Further phenomena from the field of measurement of alternating variables such as noise, distortion, signal cross-talk and signal delay in detail will be further illuminated here in due time.
Reaction or recording? Or both?
Finally, from an application perspective, it is important to consider whether the application is a response task, a data recording task, or a mixture of both.
▪
Reaction:
–
Example: a distance sensor with a 10 V analog output detects an object approaching on a conveyor belt at 10 m/s and, if 5 V is exceeded, a valve for a paint application should be opened in the shortest possible time. Another extreme example would be current control in a software-controlled magnetic bearing.
–
The following would need to be selected:
# an analog input with high sampling rate, open filter, possibly even DistributedClock timestamp function (although the reference to the absolute world time probably does not matter)
# short EtherCAT cycle time and short PLC cycle time, if necessary 100 µs or less
–
Analog accuracy is secondary here; a long-term recording of the measured values will probably not be carried out either
▪
Data recording
–
Example: a strain test lasting several days on a steel structure with slow movements in the seconds range.
–
The following would need to be selected:
# a precision analog input; important here are low noise and high temperature insensitivity, synchronization across multiple channels, possibly even absolute time synchronization to the GPS clock
# slow EtherCAT cycle time, the analysis program in C/PLC/Matlab will probably demand quite a lot of the controller
–
The sampling rate is probably secondary here. Signals with short rise and fall times as well as attenuation issues due to high frequencies are not expected
▪
In addition to the above extreme examples, most industrial applications are a mixed form of the two. That said, only the user can judge whether a reaction in the 100 µs range is "fast" in view of his problem: for temperature monitoring in the seconds range, this is "too fast", for laser monitoring "too slow".
At the end of the day, therefore, the analog and temporal characteristics of the Beckhoff analog devices have to be judged against the problem.
Effect on analog input devices and the design of the same
Depending on the intended application objective, some basic decisions have to be made by the manufacturer of analog inputs during the design phase. The different answers to the questions
▪
Attenuation: at what frequency does attenuation occur, how does it proceed?
▪
Sampling rate: which signal frequency should be measured at all, and with what accuracy?
▪
Delay: with what delay may the signal arrive in the controller?
have also been formulated at Beckhoff in the form of analog input devices. The user can find the right device for his application with the help of
▪
the Beckhoff documents (e.g. this manual)
▪
Beckhoff Sales
▪
and if necessary practical
tests.
Note
kHz vs. kSps
Note: in order to avoid linguistic misunderstandings in documentation and sales meetings, the incoming signal frequency fsignal is described at Beckhoff with the unit [Hz], and the technical sampling rate fsampling of the analog input with (samples per second) or [kSps] (kilo samples per second).
Here is a rough classification for this:
▪
The EL30xx class with its 10 V/20 mA inputs is designed for simple measurements on slow signals with 12-bit resolution. Therefore, the hardware filter and the sampling rate are set very low.
▪
The EL31xx class (also: EP31xx, EJ31xx) with its 10 V/20 mA inputs with 16-bit resolution is designed for fast signals and reaction tasks. In order to promptly inform the controller of fast-changing signals, even the hardware filter is purposely selected higher than the sampling rate. However, this can lead to alias signals in measuring applications.
▪
The measuring modules of the ELM3xxx class are consistently designed for signal correctness in recording applications; the hardware filter lies well below half the sampling rate with its -3 dB point. The ELM3x0x class "10 kSps" is more suitable for faster tasks, while the ELM3x4x class "1kSps" is more suitable for slower tasks.
▪
Moreover, key data that are suitable for the application area have been specially defined in the various special function terminals, which cannot all be listed here in detail. For example, the EL3632 / EPP3632 has variable hardware filters that can be adapted to the sampling rate.


Notes on analog aspects to EL3751/ ELM3xxx

Appendix [image] Notes on analog measured values [image] Notes on analog aspects to EL3751/ ELM3xxx
Notes on analog aspects to EL3751/ ELM3xxx
Beyond the general instructions relating to analog technology, the following instructions apply for the EL3751 and ELM3xxx (as far as applicable):
▪
The internal GND of the analog terminal is connected to the connection point –Uv. When several terminals are wired, the permitted CommonMode voltage among the terminals must not be exceeded.
▪
The "–Uv"-points must not be connected with each other or with other another potential, although it can be helpful to use it to correct system-specific negative influences.
▪
Voltage measurement at the high-side shunt
A high-side shunt is a shunt that is connected to the positive/upper potential, in which case the negative connection is generally used for switching, hence the term “negative switching”.

In principle, it is possible to use mV measurement at a shunt for current determination with the differential U inputs of the EL3751/ELM3xxx. However, two important limitations must be considered
–
Ucm between the channels (common mode): For multi-channel terminals, Ucm,max (see technical data in this documentation) between the channels must not be exceeded. With a 24 V supply of the loads, it is therefore not possible to use a high-side shunt at 24 V potential on a channel and a low-side shunt at 0 V potential on another channel, because the resulting internal reference ground –Uv would assume a mean value such that Ucm is exceeded.
→ Therefore, only high-side shunts or only low-side shunts should be used at a terminal.
–
Dynamic processes through pulsed current: In general, the current is controlled through pulsing/PWM. Depending on the inductance in the load circuit, this can lead to sudden current changes and therefore voltage changes over the shunt. Ucm at the differential inputs changes accordingly. The channel (this therefore also applies to the single-channel EL3751) is LC-coupled to the internal reference ground –Uv, and the sudden increase in Ucm results in an increase in –Uv. During this transient (several ms), measurement errors may occur when exceeding Ucm,max.
→ PWM current measurement with a high-side shunt in 24 V networks is only possible in the 30 V measuring range.


Note on Beckhoff calibration certificates

Appendix [image] Notes on analog measured values [image] Note on Beckhoff calibration certificates
Note on Beckhoff calibration certificates
Basically every Beckhoff analogue device (input or output) will be justified i.e. will be calibrated during production. This procedure won’t be documented unique. This documentation as a calibration certificate is only provided for devices that are expressly delivered with a certificate.
The calibration certificate (or German: “Kalibrierschein”) entitles the residual error after compensation/adjustment to the used standard (reference device). The calibration certificate (pdf formatted) can be unique allocated to the device via the ID number. It is therefore not a statement about a device class such as e.g. an approval, but always only applies to a single, named device. It is available for download.
By its nature this certificate documents the accuracy of measurement at the time of certificate creation, it contains no assertion about the behavior or change of the measurement accuracy in the future. A calibration certificate acts as a backtracking view to the previous time of usage. By reiterated certification procedures over years (without justification) it allows making conclusions about its ageing behavior, so called calibrate history.
Different "qualities" of a calibration certificate are common:
▪
Beckhoff calibration certificates
Such IP20 terminals can be identified by the product suffix -0020. The certificate is issued in Beckhoff production as pdf.
The terminals can be obtained from Beckhoff and recalibrated by the Beckhoff service department.
▪
ISO17025 calibration certificates
Such IP20 terminals can be identified by the product suffix -0030. The certificate is issued by a service provider on behalf of Beckhoff as a part of Beckhoff production.
The terminals can be obtained from Beckhoff and recalibrated by the Beckhoff service department.
▪
DAkkS calibration certificates (German: "Deutsche Akkreditierungsstelle GmbH")
Such IP20 terminals can be identified by the product suffix -0030. The certificate is issued by a accredited service provider on behalf of Beckhoff as a part of Beckhoff production.
The terminals can be obtained from Beckhoff and recalibrated by the Beckhoff service department.
Beckhoff produces a wide range of analog input/output devices as IP20 terminal or IP67 box. A selection of these is also available with factory/ISO/DAkkS calibration certificates. For specific details, see the technical data of the devices or contact Beckhoff Sales.
Linguistic note
In American English, "calibration" or "alignment" is understood to mean compensation/adjustment, thus a modifying effect on the device. "Verification", on the other hand, refers to observational determination and documentation of the residual error, referred in German language use as “Kalibrierung”.


Readjusting the specification

Appendix [image] Notes on analog measured values [image] Readjusting the specification
Readjusting the specification
The analog input terminal is a function block of the modular DIN rail-mountable IP20 system. It follows that there is an almost infinite number of combination options for modules on the DIN rail, size of the terminal segment, and also a wide range of applications at different ambient temperatures, control cabinet configurations or packing densities. Other influencing factors affecting an analog input terminal as measuring device include cable routing, EMC and earthing measures, the ventilation situation and contamination. In order to ensure reliable replication of the assured specification, despite this variety of factors, a reference configuration is defined below, which should be used as reference environment for verifying the properties of one or several terminals.
NOTE: This does NOT mean that the terminal specification can only be met with this exact configuration. The reference configuration should only be used as an aid for creating a uniform environment for Beckhoff and customer hardware, in order to ensure comparability of the measurement results and simplify the analog communication. This configuration enables undesirable interference in the real system to be separated from the terminal, to facilitate troubleshooting of the system.
The configuration is within the definition space of IEC 61131-2 and essentially follows the rules of EMC-compliant control cabinet construction.
Definition of the environment
▪
The terminals to be examined should be self-cooling through unobstructed natural convection. All further details are based on this premise
▪
The terminals are installed in an enclosed control cabinet. This control cabinet is located in a temperature-controlled environment, e.g. a temperature chamber. The control cabinet should have the following dimensions: 600 mm x 600 mm x 350 mm (width x depth x height). The lid must open to the front.
Representation the mounting position of the DIN rail
▪
A 35 mm x 15 mm DIN rail according to EN 50022 is used for the mounting. This rail is mounted horizontally at the rear panel of the control cabinet. It must extend over the entire width of the control cabinet. The DIN rail must be installed such that the terminals are positioned vertically and exactly centrally in the control cabinet. The terminals should also be centered horizontally.
▪
The DIN rail must conductively connected to the control cabinet. The DIN rail is earthed with a cable (low-interference PE). Ensure the door is properly connected.
▪
The supply lines to the devices under test and the power feed terminals should exit at the front. The space above and below the terminals must be clear. The supply lines should be bundled such that convection in the control cabinet is obstructed as little as possible.
Terminal input leads.png
Arrangement of the supply lines to and from the device under test in the control cabinet
▪
The control cabinet temperature is measured according to IEC 61131-2 at the indicated position at the air inlet point upstream of the terminal when the unit is ventilated. The ambient temperature must be measured with a (verifiable) accuracy of better than ±0.2 °C. The temperature sensor must be mounted horizontally. The temperature outside the control cabinet must be controlled such that the temperature at the measuring point is a constant 23°C.
Thermal environment box_en.png
Dimensions and installation in the control cabinet
▪
The control cabinet must be empty, except the terminals that are part of the measurement configuration, the supply lines and the temperature sensor.
▪
Any other terminals that may be required must be installed outside the control cabinet. The control cabinet feed-through should match the supply lines.
▪
Shielded cables should be used for the signal lines. The shield should be connected to the DIN rail. State of the art shielding should be used; cf. widely available documents, e.g. from ZVEI. Components from the Beckhoff shielding connection system (ZB8500, ZB8510, ZB8520) should be used for this purpose. The shielding should be connected on one side to the devices under test and the control cabinet.
Definition of the configuration
▪
The following terminals are required for the measurement configuration as a minimum; the configuration can include 2-10 devices under test. Configuration as follows, based on two devices under test as an example:
–
1x Bus Coupler EK1100
–
2x terminals to be measured ("devices under test")
–
4x EBUS/KBUS power feed terminal EL9410
–
1x bus end cap/end terminal EL9011
▪
The terminals are then lined up as shown below (for 2 devices under test):
Schematic diagram of the test configuration
▪
For thermal reasons, 2x EL9410 are connected at the end of the terminal segment. These ensure that the preceding EL3751 is operated in a way that is thermally similar to a center position in the terminal segment.
▪
The internal terminal temperature in CoE 0x9000:01 should be regarded as a guide. In the environment referred to above, the internal temperature of the EL3751 is expected to be around 52 ±2 °C. Otherwise, the ambient temperature should be adjusted accordingly.
▪
Both supply voltages (Us and Up) must be connected to the Bus Coupler and all power feed terminals. The operating voltage must be +24 V ±0.5 V, unless an individual terminal requires a different Up voltage.
▪
The ground connections of Us and Up may be short-circuited. The PE connections of the Bus Coupler and the power feed terminals do not have to be connected.
▪
If the devices under test have shielding (functional earth) at a terminal point, this must not be connected, since the terminals have a shield spring on the DIN rail at the rear.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com


Reshipment and return

Appendix [image] Reshipment and return
Reshipment and return
This product is individually packed and sealed. Unless otherwise agreed, Beckhoff can only accept returns in unopened original packaging with the seal intact.