EL6201, EL9520 - EtherCAT Terminals for AS-Interface
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status
•
Version identification of EtherCAT devices


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC® and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, DE102004044764, DE102007017835 with corresponding applications or registrations in various other countries.
The TwinCAT Technology is covered, including but not limited to the following patent applications and patents: EP0851348, US6167425 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
2.4
▪
Update chapter “Object description”
▪
Update structure
▪
Update revision status
2.3
▪
Addenda EL9520
▪
Update chapter “Technical data”
▪
Update chapter "Connection system" -> "Connection"
▪
Update structure
▪
Update revision status
2.2
▪
Update chapter "Object description and parameterization"
▪
Update structure
2.1
▪
Update chapter "Notes on the documentation"
▪
Correction of Technical data
▪
Addenda chapter "TwinCAT Quick Start"
2.0
▪
Migration
▪
Amendments in section "Commissioning"
▪
Amendments in section "Technical data"
▪
Amendments in section "Object description and parameterization"
▪
Update structure
1.5
▪
Update chapter "Technical data"
▪
Addenda chapter "Installation instructions for enhanced mechanical load capacity"
▪
Update revision status
1.4
▪
Update chapter "Technical data"
▪
Section "Connection" updated
▪
Update revision status
1.3
▪
Update chapter "Technical data"
▪
Update chapter "Object description and parameterization"
▪
Update structure
▪
Update revision status
1.2
▪
Update chapter "Technical data"
1.1
▪
Amendments re commissioning
1.0
▪
First public issue
0.8
▪
Amendments & corrections in section "Quickstart"
0.7
▪
Amendments & corrections in section "AS-i Master functionality"
0.6
▪
Addenda & corrections
0.5
▪
Addenda & corrections
0.4
▪
Addenda
0.3
▪
Addenda
0.2
▪
Addenda
0.1
▪
Provisional documentation for EL6201


Version identification of EtherCAT devices

Foreword [image] Version identification of EtherCAT devices
Version identification of EtherCAT devices
Designation
A Beckhoff EtherCAT device has a 14-digit designation, made up of
▪
family key
▪
type
▪
version
▪
revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
Notes
▪
The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
▪
EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
▪
The order identifier is made up of
- family key (EL, EP, CU, ES, KL, CX, etc.)
- type (3314)
- version (-0000)
▪
The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
▪
The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Identification number
Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:
Production lot/batch number/serial number/date code/D number
The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02
Exceptions can occur in the IP67 area, where the following syntax can be used (see respective device documentation):
Syntax: D ww yy x y z u
D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB
Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1
Unique serial number/ID, ID number
In addition, in some series each individual module has its own unique serial number.
See also the further documentation in the area
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Terminals with factory calibration certificate and other measuring terminals
Examples of markings
EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
CU2016 switch with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
EP1258-00001 IP67 EtherCAT Box with batch number/ date code 22090101 and unique serial number 158102
EP1908-0002 IP67 EtherCAT Safety Box with batch number/ date code 071201FF and unique serial number 00346070
EL2904 IP20 safety terminal with batch number/ date code 50110302 and unique serial number 00331701
ELM3604-0002 terminal with unique ID number (QR code) 100001051 and serial/ batch number 44160201


Product overview

Product overview
Product overview
Additional information
•
Introduction
•
Technical data
•
Technology
•
EL9520: AS-i potential feed terminal with filter
•
Start


Introduction

Product overview [image] Introduction
Introduction
EL6201
AS-i logo
AS-Interface master terminal
The EL6201 AS-Interface master terminal enables the direct connection of AS-Interface slaves. The AS-Interface compliant interface supports digital and analog slaves, versions 3.0 (master profile M3; M4). The connected devices are supplied via the EL9520 AS-Interface potential feed terminal with integrated filter.
Quick links


Technical data

Product overview [image] Technical data
Technical data
Technical data | EL6201-0000
AS-Interface channels | 1
Number of slaves | up to 31 in V 2.0; up to 62 in V 2.11, V 3.0
AS-Interface versions | V 2.0, V 2.11, V 3.0 (Rev. 4)
Slave types | Standard: digital and analog, extended: Type 1 (CTT1): S-7.3, S-7.4, Type 2 (CTT2): S-7.5.5, S-7.A.5, S-B.A.5, Type 3 (CTT3): S-7.A.7, S-7.A.A, Type 4 (CTT4): S-7.A.8, S-7.A.9, Type 5 (CTT5): S-6.0, Safety at work: S-0.B, S-7.B
Diagnostics | power failure, slave failure, parameterization fault
AS-Interface address assignment | via configuration or automatic
Cycle time | max. 5 ms (with 31 or 62 slaves)
Connection | 2 lines via spring force technology
Data transfer rates | 167 kbit/s
Distributed clocks | -
Power contacts | no
Electrical isolation | 500 V (AS-Interface/E-bus)
Supply voltage for electronics | via the E-bus
Current consumption | 120 mA (E-Bus), typ. 40 mA/max. 60 mA (AS-Interface)
Configuration | via TwinCAT System Manager
Dimensions (W x H x D) | approx. 15 mm x 100 mm x 70 mm (width aligned: 12 mm)
Weight | approx. 55 g
Assembly | on 35 mm mounting rail conforms to EN 60715
Operating temperature | 0°C ... +55°C
Storage temperature | -25°C ... +85°C
Relative humidity | 95 % no condensation
Vibration/shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27, see also installation instructions for enhanced mechanical load capacity
EMC immunity/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protect. class / installation pos. | IP20 / see note!
AS-Interface certificate | yes, cert. no. 97701
Approvals | CE


Technology

Product overview [image] Technology
Technology
This section provides a short general technical introduction to the technology of the AS interface. Please refer to the following sections for further details.
(Source: (AS-INTERNATIONAL ASSOCIATION e.V.)
AS-i logo
Additional information
•
• AS-i requirements
•
Assembly using the piercing technology
•
AS interface for every topology


• AS-i requirements

Product overview [image] Technology [image] • AS-i requirements
• AS-i requirements
The industry places many different demands on modern automation systems. It demands that the necessary functions are fulfilled at an optimum price-performance ratio. AS-Interface, or AS-i for short, does precisely that. The system is focused on the lower field level. The goal of the development was not a universal fieldbus for all areas of automation, but rather an economically practical system for the lower field level, with which binary sensors and actuators can be simply, reliably and economically networked and connected to the higher control level.
The sensors and actuators can be networked and supplied with power via the AS-i-specific twin-core cable. The cable harnesses of traditional cabling are dispensed with. A massive cost reduction due to the simple wiring, which is possible without extensive training thanks to the proven click-and-go technology. Due to its cost effectiveness the AS-Interface system proves to be a technically and economically practical supplement to the normal fieldbus.
The freely selectable network topology and its simple configuration facilitate the installation of an AS-i network. The susceptibility to faults of other systems frequently leads to delays in the installation, for which reason care was taken with the AS-Interface system to reduce sources of error. Reverse voltage protection by means of the profiled cable is just one corresponding measure.


Assembly using the piercing technology

Product overview [image] Technology [image] Assembly using the piercing technology
Assembly using the piercing technology
The simple assembly of the AS-interface is made possible by the special assembly method, which is also called the piercing technology or, less frequently, the click-and-go method. The technology is based on the use of the usually yellow AS-i cable, a cable with two cores that is protected against polarity reversal. When assembling, the piercing pins of the device to be connected penetrate into the cores of the cable and reliably make the contact. Some advantages:
▪
Direct, simple connection of sensors/actuators or modules
▪
Flat cable with reverse voltage protection
▪
Data and energy in one cable
▪
Piercing technology
▪
Very simple connection method
▪
Secure contacting
▪
Protection class IP67
▪
Cutting to length and stripping of insulation are not necessary
▪
Can be mounted in any place
▪
Trouble-free shifting is possible thanks to the self-healing capability of the cable for each type of cable
Profiled twin-core cable for use with the AS-i technology
Assembly example
Upper and lower half of the AS-i component are disassembled.
The AS-i cable is placed – always without error thanks to its profiling – in the lower half of the AS-i component.
Upper and lower halves are assembled using a simple tool.
Finished assembled junction
The piercing technology ensures the reliable connection of the AS-i component to the AS-i network cable.


AS interface for every topology

Product overview [image] Technology [image] AS interface for every topology
AS interface for every topology
The AS-i protocol guarantees simple expandability. The AS-interface network can be configured like every conventional electrical installation. Every AS-i slave is freely addressable and can be connected to the bus cable in any place. This enables a modular structure and, due to the robust principle of operation, there are no limits to the structure. Any desired network topology may be used, i.e. including star or tree topologies.
Fail-safe
The data are transmitted reliably on the AS-i network. Each AS-Interface telegram is monitored in the receiver with regard to a parity bit and several further independent variables. This ensures extremely high reliability in the detection of single and multiple errors. The use of the AS-Interface in very noisy environments such as welding plants and frequency converters is thus possible without problems.
Standardized economic efficiency
All AS-Interface products conform to the European standard EN 50295 and the world standard IEC 62026-2.
Certified: Economic and reliable
The certification of the AS-i products guarantees the user maximum system security. The products are fully compatible and interchangeable with one another. As a user you can recognize the tested and certified products by the AS-Interface “shadow logo” and the associated test number.


EL9520: AS-i potential feed terminal with filter

Product overview [image] EL9520: AS-i potential feed terminal with filter
EL9520: AS-i potential feed terminal with filter
EL9520
The EL9520 potential feed terminal uncouples the input and output signal through an integrated filter and enables the supply of AS-Interface networks from standard power supply units or another AS-Interface network.
The EL9520 can be used directly next to the EL6201 AS-Interface master terminal. Multiple parallel operation of this combination in an EtherCAT Terminal block is possible and saves several AS-Interface power supply units.
LEDs
LED | Color | Meaning
RUN | green | These LEDs indicate the terminal's operating state:
 |  | off | State of the EtherCAT State Machine: INIT = initialization of the terminal
 |  | flashing | State of the EtherCAT State Machine: PREOP = function for mailbox communication and different standard-settings set
 |  | Single flash | State of the EtherCAT State Machine: SAFEOP = verification of the Sync Manager channels and the distributed clocks. Outputs remain in safe state
 |  | on | State of the EtherCAT State Machine: OP = normal operating state; mailbox and process data communication is possible
 |  | flickering | State of the EtherCAT State Machine: BOOTSTRAP = function for terminal firmware updates
Power | green | off | AS-i voltage is switched off.
 |  | on | AS-i voltage is switched on.
Technical data
Technical data | ELL9520
Input voltage | up to 35 VDC
Output voltage | up to 35 VDC
Input current | max. 2 A
Output current | max. 2 A (not short-circuit-proof)
Current consumption from K-bus | typ. 100 mA
Electrical isolation | 500 V (E-bus/field potential)
Galvanic isolation | no
Configuration | no address or configuration settings required
Bit width in process image | 0 input bits, 0 output bits
Dimensions (W x H x D) | approx. 15 mm x 100 mm x 70 mm (width aligned: 12 mm)
Weight | app. 90 g
Assembly | on 35 mm mounting rail conforms to EN 60715
Permissible ambient temperature during operation | 0°C ... +55°C
Permissible ambient temperature during storage | -25°C ... +85°C
Permissible relative humidity | 95 %, no condensation
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27 see also installation instructions for enhanced mechanical load capacity
EMC resistance burst / ESD | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation position | variable
Approval | CE
AS-Interface certificate | yes, ZU-No. 101601


Start

Product overview [image] Start
Start
For commissioning:
▪
mount the EL6201 as described in the chapter Mounting and wiring
▪
configure the EL6201 in TwinCAT as described in the chapter Commissioning.


Basics communication

Basics communication
Basics communication
Additional information
•
EtherCAT basics
•
EtherCAT cabling – wire-bound
•
General notes for setting the watchdog
•
EtherCAT State Machine
•
CoE Interface


EtherCAT basics

Basics communication [image] EtherCAT basics
EtherCAT basics
Please refer to the EtherCAT System Documentation for the EtherCAT fieldbus basics.


EtherCAT cabling – wire-bound

Basics communication [image] EtherCAT cabling – wire-bound
EtherCAT cabling – wire-bound
The cable length between two EtherCAT devices must not exceed 100 m. This results from the FastEthernet technology, which, above all for reasons of signal attenuation over the length of the cable, allows a maximum link length of 5 + 90 + 5 m if cables with appropriate properties are used. See also the Design recommendations for the infrastructure for EtherCAT/Ethernet.
Cables and connectors
For connecting EtherCAT devices only Ethernet connections (cables + plugs) that meet the requirements of at least category 5 (CAt5) according to EN 50173 or ISO/IEC 11801 should be used. EtherCAT uses 4 wires for signal transfer.
EtherCAT uses RJ45 plug connectors, for example. The pin assignment is compatible with the Ethernet standard (ISO/IEC 8802-3).
Pin | Color of conductor | Signal | Description
1 | yellow | TD + | Transmission Data +
2 | orange | TD - | Transmission Data -
3 | white | RD + | Receiver Data +
6 | blue | RD - | Receiver Data -
Due to automatic cable detection (auto-crossing) symmetric (1:1) or cross-over cables can be used between EtherCAT devices from Beckhoff.
Recommended cables
Suitable cables for the connection of EtherCAT devices can be found on the Beckhoff website!
E-Bus supply
A bus coupler can supply the EL terminals added to it with the E-bus system voltage of 5 V; a coupler is thereby loadable up to 2 A as a rule (see details in respective device documentation).
Information on how much current each EL terminal requires from the E-bus supply is available online and in the catalogue. If the added terminals require more current than the coupler can supply, then power feed terminals (e.g. EL9410) must be inserted at appropriate places in the terminal strand.
The pre-calculated theoretical maximum E-Bus current is displayed in the TwinCAT System Manager. A shortfall is marked by a negative total amount and an exclamation mark; a power feed terminal is to be placed before such a position.
System manager current calculation
Note
Malfunction possible!
The same ground potential must be used for the E-Bus supply of all EtherCAT terminals in a terminal block!


General notes for setting the watchdog

Basics communication [image] General notes for setting the watchdog
General notes for setting the watchdog
ELxxxx terminals are equipped with a safety feature (watchdog) that switches off the outputs after a specifiable time e.g. in the event of an interruption of the process data traffic, depending on the device and settings, e.g. in OFF state.
The EtherCAT slave controller (ESC) in the EL2xxx terminals features 2 watchdogs:
▪
SM watchdog (default: 100 ms)
▪
PDI watchdog (default: 100 ms)
SM watchdog (SyncManager Watchdog)
The SyncManager watchdog is reset after each successful EtherCAT process data communication with the terminal. If no EtherCAT process data communication takes place with the terminal for longer than the set and activated SM watchdog time, e.g. in the event of a line interruption, the watchdog is triggered and the outputs are set to FALSE. The OP state of the terminal is unaffected. The watchdog is only reset after a successful EtherCAT process data access. Set the monitoring time as described below.
The SyncManager watchdog monitors correct and timely process data communication with the ESC from the EtherCAT side.
PDI watchdog (Process Data Watchdog)
If no PDI communication with the EtherCAT slave controller (ESC) takes place for longer than the set and activated PDI watchdog time, this watchdog is triggered.
PDI (Process Data Interface) is the internal interface between the ESC and local processors in the EtherCAT slave, for example. The PDI watchdog can be used to monitor this communication for failure.
The PDI watchdog monitors correct and timely process data communication with the ESC from the application side.
The settings of the SM- and PDI-watchdog must be done for each slave separately in the TwinCAT System Manager.
EtherCAT tab -> Advanced Settings -> Behavior -> Watchdog
Notes:
▪
the multiplier is valid for both watchdogs.
▪
each watchdog has its own timer setting, the outcome of this in summary with the multiplier is a resulting time.
▪
Important: the multiplier/timer setting is only loaded into the slave at the start up, if the checkbox is activated.
If the checkbox is not activated, nothing is downloaded and the ESC settings remain unchanged.
Multiplier
Multiplier
Both watchdogs receive their pulses from the local terminal cycle, divided by the watchdog multiplier:
1/25 MHz * (watchdog multiplier + 2) = 100 µs (for default setting of 2498 for the multiplier)
The standard setting of 1000 for the SM watchdog corresponds to a release time of 100 ms.
The value in multiplier + 2 corresponds to the number of basic 40 ns ticks representing a watchdog tick.
The multiplier can be modified in order to adjust the watchdog time over a larger range.
Example "Set SM watchdog"
This checkbox enables manual setting of the watchdog times. If the outputs are set and the EtherCAT communication is interrupted, the SM watchdog is triggered after the set time and the outputs are erased. This setting can be used for adapting a terminal to a slower EtherCAT master or long cycle times. The default SM watchdog setting is 100 ms. The setting range is 0..65535. Together with a multiplier with a range of 1..65535 this covers a watchdog period between 0..~170 seconds.
Calculation
Multiplier = 2498 → watchdog base time = 1 / 25 MHz * (2498 + 2) = 0.0001 seconds = 100 µs
SM watchdog = 10000 → 10000 * 100 µs = 1 second watchdog monitoring time
SmallWarningYellow CAUTION
Undefined state possible!
The function for switching off of the SM watchdog via SM watchdog = 0 is only implemented in terminals from version -0016. In previous versions this operating mode should not be used.
SmallWarningYellow CAUTION
Damage of devices and undefined state possible!
If the SM watchdog is activated and a value of 0 is entered the watchdog switches off completely. This is the deactivation of the watchdog! Set outputs are NOT set in a safe state, if the communication is interrupted.


EtherCAT State Machine

Basics communication [image] EtherCAT State Machine
EtherCAT State Machine
The state of the EtherCAT slave is controlled via the EtherCAT State Machine (ESM). Depending upon the state, different functions are accessible or executable in the EtherCAT slave. Specific commands must be sent by the EtherCAT master to the device in each state, particularly during the bootup of the slave.
A distinction is made between the following states:
▪
Init
▪
Pre-Operational
▪
Safe-Operational and
▪
Operational
▪
Boot
The regular state of each EtherCAT slave after bootup is the OP state.
States of the EtherCAT State Machine
Init
After switch-on the EtherCAT slave in the Init state. No mailbox or process data communication is possible. The EtherCAT master initializes sync manager channels 0 and 1 for mailbox communication.
Pre-Operational (Pre-Op)
During the transition between Init and Pre-Op the EtherCAT slave checks whether the mailbox was initialized correctly.
In Pre-Op state mailbox communication is possible, but not process data communication. The EtherCAT master initializes the sync manager channels for process data (from sync manager channel 2), the FMMU channels and, if the slave supports configurable mapping, PDO mapping or the sync manager PDO assignment. In this state the settings for the process data transfer and perhaps terminal-specific parameters that may differ from the default settings are also transferred.
Safe-Operational (Safe-Op)
During transition between Pre-Op and Safe-Op the EtherCAT slave checks whether the sync manager channels for process data communication and, if required, the distributed clocks settings are correct. Before it acknowledges the change of state, the EtherCAT slave copies current input data into the associated DP-RAM areas of the EtherCAT slave controller (ECSC).
In Safe-Op state mailbox and process data communication is possible, although the slave keeps its outputs in a safe state, while the input data are updated cyclically.
Outputs in SAFEOP state
The default set watchdog monitoring sets the outputs of the module in a safe state - depending on the settings in SAFEOP and OP - e.g. in OFF state. If this is prevented by deactivation of the watchdog monitoring in the module, the outputs can be switched or set also in the SAFEOP state.
Operational (Op)
Before the EtherCAT master switches the EtherCAT slave from Safe-Op to Op it must transfer valid output data.
In the Op state the slave copies the output data of the masters to its outputs. Process data and mailbox communication is possible.
Boot
In the Boot state the slave firmware can be updated. The Boot state can only be reached via the Init state.
In the Boot state mailbox communication via the file access over EtherCAT (FoE) protocol is possible, but no other mailbox communication and no process data communication.


CoE Interface

Basics communication [image] CoE Interface
CoE Interface
General description
The CoE interface (CANopen over EtherCAT) is used for parameter management of EtherCAT devices. EtherCAT slaves or the EtherCAT master manage fixed (read only) or variable parameters which they require for operation, diagnostics or commissioning.
CoE parameters are arranged in a table hierarchy. In principle, the user has read access via the fieldbus. The EtherCAT master (TwinCAT System Manager) can access the local CoE lists of the slaves via EtherCAT in read or write mode, depending on the attributes.
Different CoE parameter types are possible, including string (text), integer numbers, Boolean values or larger byte fields. They can be used to describe a wide range of features. Examples of such parameters include manufacturer ID, serial number, process data settings, device name, calibration values for analog measurement or passwords.
The order is specified in 2 levels via hexadecimal numbering: (main)index, followed by subindex. The value ranges are
▪
Index: 0x0000 …0xFFFF (0...65535dez)
▪
SubIndex: 0x00…0xFF (0...255dez)
A parameter localized in this way is normally written as 0x8010:07, with preceding "x" to identify the hexadecimal numerical range and a colon between index and subindex.
The relevant ranges for EtherCAT fieldbus users are:
▪
0x1000: This is where fixed identity information for the device is stored, including name, manufacturer, serial number etc., plus information about the current and available process data configurations.
▪
0x8000: This is where the operational and functional parameters for all channels are stored, such as filter settings or output frequency.
Other important ranges are:
▪
0x4000: In some EtherCAT devices the channel parameters are stored here (as an alternative to the 0x8000 range).
▪
0x6000: Input PDOs ("input" from the perspective of the EtherCAT master)
▪
0x7000: Output PDOs ("output" from the perspective of the EtherCAT master)
Availability
Not every EtherCAT device must have a CoE list. Simple I/O modules without dedicated processor usually have no variable parameters and therefore no CoE list.
If a device has a CoE list, it is shown in the TwinCAT System Manager as a separate tab with a listing of the elements:
"CoE Online " tab
The figure above shows the CoE objects available in device "EL2502", ranging from 0x1000 to 0x1600. The subindices for 0x1018 are expanded.
Data management and function "NoCoeStorage"
Some parameters, particularly the setting parameters of the slave, are configurable and writeable. This can be done in write or read mode
▪
via the System Manager (Fig. "CoE Online " tab) by clicking
This is useful for commissioning of the system/slaves. Click on the row of the index to be parameterised and enter a value in the "SetValue" dialog.
▪
from the control system/PLC via ADS, e.g. through blocks from the TcEtherCAT.lib library
This is recommended for modifications while the system is running or if no System Manager or operating staff are available.
Data management
If slave CoE parameters are modified online, Beckhoff devices store any changes in a fail-safe manner in the EEPROM, i.e. the modified CoE parameters are still available after a restart.
The situation may be different with other manufacturers.

An EEPROM is subject to a limited lifetime with respect to write operations. From typically 100,000 write operations onwards it can no longer be guaranteed that new (changed) data are reliably saved or are still readable. This is irrelevant for normal commissioning. However, if CoE parameters are continuously changed via ADS at machine runtime, it is quite possible for the lifetime limit to be reached. Support for the NoCoeStorage function, which suppresses the saving of changed CoE values, depends on the firmware version.
Please refer to the technical data in this documentation as to whether this applies to the respective device.
•
If the function is supported: the function is activated by entering the code word 0x12345678 once in CoE 0xF008 and remains active as long as the code word is not changed. After switching the device on it is then inactive. Changed CoE values are not saved in the EEPROM and can thus be changed any number of times.
•
Function is not supported: continuous changing of CoE values is not permissible in view of the lifetime limit.
Startup list
Changes in the local CoE list of the terminal are lost if the terminal is replaced. If a terminal is replaced with a new Beckhoff terminal, it will have the default settings. It is therefore advisable to link all changes in the CoE list of an EtherCAT slave with the Startup list of the slave, which is processed whenever the EtherCAT fieldbus is started. In this way a replacement EtherCAT slave can automatically be parameterized with the specifications of the user.
If EtherCAT slaves are used which are unable to store local CoE values permanently, the Startup list must be used.
Recommended approach for manual modification of CoE parameters
▪
Make the required change in the System Manager
The values are stored locally in the EtherCAT slave
▪
If the value is to be stored permanently, enter it in the Startup list.
The order of the Startup entries is usually irrelevant.
Startup list in the TwinCAT System Manager
The Startup list may already contain values that were configured by the System Manager based on the ESI specifications. Additional application-specific entries can be created.
Online/offline list
While working with the TwinCAT System Manager, a distinction has to be made whether the EtherCAT device is "available", i.e. switched on and linked via EtherCAT and therefore online, or whether a configuration is created offline without connected slaves.
In both cases a CoE list as shown in Fig. “’CoE online’ tab” is displayed. The connectivity is shown as offline/online.
▪
If the slave is offline
–
The offline list from the ESI file is displayed. In this case modifications are not meaningful or possible.
–
The configured status is shown under Identity.
–
No firmware or hardware version is displayed, since these are features of the physical device.
–
Offline is shown in red.
Offline list
▪
If the slave is online
–
The actual current slave list is read. This may take several seconds, depending on the size and cycle time.
–
The actual identity is displayed
–
The firmware and hardware version of the equipment according to the electronic information is displayed
–
Online is shown in green.
Online list
Channel-based order
The CoE list is available in EtherCAT devices that usually feature several functionally equivalent channels. For example, a 4-channel analog 0..10 V input terminal also has 4 logical channels and therefore 4 identical sets of parameter data for the channels. In order to avoid having to list each channel in the documentation, the placeholder "n" tends to be used for the individual channel numbers.
In the CoE system 16 indices, each with 255 subindices, are generally sufficient for representing all channel parameters. The channel-based order is therefore arranged in 16dec/10hex steps. The parameter range 0x8000 exemplifies this:
▪
Channel 0: parameter range 0x8000:00 ... 0x800F:255
▪
Channel 1: parameter range 0x8010:00 ... 0x801F:255
▪
Channel 2: parameter range 0x8020:00 ... 0x802F:255
▪
...
This is generally written as 0x80n0.
Detailed information on the CoE interface can be found in the EtherCAT system documentation on the Beckhoff website.


Installation

Installation
Installation
Additional information
•
Instructions for ESD protection
•
Installation on mounting rails
•
Installation instructions for enhanced mechanical load capacity
•
Connection
•
Prescribed installation position
•
Positioning of passive Terminals
•
LEDs and connection


Instructions for ESD protection

Installation [image] Instructions for ESD protection
Instructions for ESD protection
Note
Destruction of the devices by electrostatic discharge possible!
The devices contain components at risk from electrostatic discharge caused by improper handling.
•
Please ensure you are electrostatically discharged and avoid touching the contacts of the device directly.
•
Avoid contact with highly insulating materials (synthetic fibers, plastic film etc.).
•
Surroundings (working place, packaging and personnel) should by grounded probably, when handling with the devices.
•
Each assembly must be terminated at the right hand end with an EL9011 or EL9012 bus end cap, to ensure the protection class and ESD protection.
Spring contacts of the Beckhoff I/O components


Installation on mounting rails

Installation [image] Installation on mounting rails
Installation on mounting rails
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Assembly
Attaching on mounting rail
The bus coupler and bus terminals are attached to commercially available 35 mm mounting rails (DIN rails according to EN 60715) by applying slight pressure:
1.
First attach the fieldbus coupler to the mounting rail.
2.
The bus terminals are now attached on the right-hand side of the fieldbus coupler. Join the components with tongue and groove and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
If the terminals are clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.
Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail. At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail. To mount the mounting rails with a height of 7.5 mm under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).
Disassembly
Disassembling of terminal
Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
1.
Pull the terminal by its orange-colored lugs approximately 1 cm away from the mounting rail. In doing so for this terminal the mounting rail lock is released automatically and you can pull the terminal out of the bus terminal block easily without excessive force.
2.
Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal out of the bus terminal block.
Connections within a bus terminal block
The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:
▪
The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
▪
The power contacts deal with the supply for the field electronics and thus represent a supply rail within the bus terminal block. The power contacts are supplied via terminals on the Bus Coupler (up to 24 V) or for higher voltages via power feed terminals.
Power Contacts
During the design of a bus terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts. Power Feed Terminals (KL91xx, KL92xx or EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.
PE power contact
The power contact labeled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Power contact on left side
Note
Possible damage of the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a nominal voltage of 230 V). For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.
SmallWarningYellow WARNING
Risk of electric shock!
The PE power contact must not be used for other potentials!


Installation instructions for enhanced mechanical load capacity

Installation [image] Installation instructions for enhanced mechanical load capacity
Installation instructions for enhanced mechanical load capacity
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminal system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals!
Additional checks
The terminals have undergone the following additional tests:
Verification | Explanation
Vibration | 10 frequency runs in 3 axes
 | 6 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 25 g, 6 ms
Additional installation instructions
For terminals with enhanced mechanical load capacity, the following additional installation instructions apply:
▪
The enhanced mechanical load capacity is valid for all permissible installation positions
▪
Use a mounting rail according to EN 60715 TH35-15
▪
Fix the terminal segment on both sides of the mounting rail with a mechanical fixture, e.g. an earth terminal or reinforced end clamp
▪
The maximum total extension of the terminal segment (without coupler) is:
64 terminals (12 mm mounting with) or 32 terminals (24 mm mounting with)
▪
Avoid deformation, twisting, crushing and bending of the mounting rail during edging and installation of the rail
▪
The mounting points of the mounting rail must be set at 5 cm intervals
▪
Use countersunk head screws to fasten the mounting rail
▪
The free length between the strain relief and the wire connection should be kept as short as possible. A distance of approx. 10 cm should be maintained to the cable duct.


Connection

Installation [image] Connection
Connection
Additional information
•
Connection system
•
Wiring
•
Shielding


Connection system

Installation [image] Connection [image] Connection system
Connection system
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Overview
The Bus Terminal system offers different connection options for optimum adaptation to the respective application:
▪
The terminals of ELxxxx and KLxxxx series with standard wiring include electronics and connection level in a single enclosure.
▪
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level and enable steady wiring while replacing.
▪
The High Density Terminals (HD Terminals) include electronics and connection level in a single enclosure and have advanced packaging density.
Standard wiring (ELxxxx / KLxxxx)
Standard wiring
The terminals of ELxxxx and KLxxxx series have been tried and tested for years.
They feature integrated screwless spring force technology for fast and simple assembly.
Pluggable wiring (ESxxxx / KSxxxx)
Pluggable wiring
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level.
The assembly and wiring procedure is the same as for the ELxxxx and KLxxxx series.
The pluggable connection level enables the complete wiring to be removed as a plug connector from the top of the housing for servicing.
The lower section can be removed from the terminal block by pulling the unlocking tab.
Insert the new component and plug in the connector with the wiring. This reduces the installation time and eliminates the risk of wires being mixed up.
The familiar dimensions of the terminal only had to be changed slightly. The new connector adds about 3 mm. The maximum height of the terminal remains unchanged.
A tab for strain relief of the cable simplifies assembly in many applications and prevents tangling of individual connection wires when the connector is removed.
Conductor cross sections between 0.08 mm2 and 2.5 mm2 can continue to be used with the proven spring force technology.
The overview and nomenclature of the product names for ESxxxx and KSxxxx series has been retained as known from ELxxxx and KLxxxx series.
High Density Terminals (HD Terminals)
High Density Terminals
The Bus Terminals from these series with 16 terminal points are distinguished by a particularly compact design, as the packaging density is twice as large as that of the standard 12 mm Bus Terminals. Massive conductors and conductors with a wire end sleeve can be inserted directly into the spring loaded terminal point without tools.
Wiring HD Terminals
The High Density (HD) Terminals of the ELx8xx and KLx8xx series doesn't support pluggable wiring.
Ultrasonically "bonded" (ultrasonically welded) conductors
Ultrasonically “bonded" conductors
It is also possible to connect the Standard and High Density Terminals with ultrasonically "bonded" (ultrasonically welded) conductors. In this case, please note the tables concerning the wire-size width below!


Wiring

Installation [image] Connection [image] Wiring
Wiring
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Terminals for standard wiring ELxxxx/KLxxxx and for pluggable wiring ESxxxx/KSxxxx
Connecting a cable on a terminal point
Up to eight terminal points enable the connection of solid or finely stranded cables to the Bus Terminal. The terminal points are implemented in spring force technology. Connect the cables as follows:
1.
Open a terminal point by pushing a screwdriver straight against the stop into the square opening above the terminal point. Do not turn the screwdriver or move it alternately (don't toggle).
2.
The wire can now be inserted into the round terminal opening without any force.
3.
The terminal point closes automatically when the pressure is released, holding the wire securely and permanently.
See the following table for the suitable wire size width.
Terminal housing | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Wire size width (single core wires) | 0.08 ... 2.5 mm2 | 0.08 ... 2.5 mm2
Wire size width (fine-wire conductors) | 0.08 ... 2.5 mm2 | 0,08 ... 2.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 1.5 mm2 | 0.14 ... 1.5 mm2
Wire stripping length | 8 ... 9 mm | 9 ... 10 mm
High Density Terminals (HD Terminals) with 16 terminal points
The conductors of the HD Terminals are connected without tools for single-wire conductors using the direct plug-in technique, i.e. after stripping the wire is simply plugged into the terminal point. The cables are released, as usual, using the contact release with the aid of a screwdriver. See the following table for the suitable wire size width.
Terminal housing | High Density Housing
Wire size width (single core wires) | 0.08 ... 1.5 mm2
Wire size width (fine-wire conductors) | 0.25 ... 1.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 0.75 mm2
Wire size width (ultrasonically “bonded" conductors) | only 1.5 mm2
Wire stripping length | 8 ... 9 mm


Shielding

Installation [image] Connection [image] Shielding
Shielding
Shielding
Encoder, analog sensors and actors should always be connected with shielded, twisted paired wires.


Prescribed installation position

Installation [image] Prescribed installation position
Prescribed installation position
Note
Constraints regarding installation position and operating temperature range
When installing the terminals ensure that an adequate spacing is maintained between other components above and below the terminal in order to guarantee adequate ventilation!
Prescribed installation position
The prescribed installation position requires the mounting rail to be installed horizontally and the connection surfaces of the EL/KL terminals to face forward (see Fig. Recommended distances for standard installation position).
The terminals are ventilated from below, which enables optimum cooling of the electronics through convection. "From below" is relative to the acceleration of gravity.
Recommended minimum distances for standard installation position
Compliance with the distances shown in Fig. Recommended distances for standard installation position is strongly recommended.


Positioning of passive Terminals

Installation [image] Positioning of passive Terminals
Positioning of passive Terminals
Hint for positioning of passive terminals in the bus terminal block
EtherCAT Terminals (ELxxxx / ESxxxx), which do not take an active part in data transfer within the bus terminal block are so called passive terminals. The passive terminals have no current consumption out of the E-Bus.
To ensure an optimal data transfer, you must not directly string together more than 2 passive terminals!
Examples for positioning of passive terminals (highlighted)
Correct positioning
Incorrect positioning


LEDs and connection

Installation [image] LEDs and connection
LEDs and connection
EL6201 LEDs
LEDs
LED
Color
Meaning
RUN
green
These LEDs indicate the terminal's operating state:
off
State of the EtherCAT State Machine: INIT = initialization of the terminal
flashing
State of the EtherCAT State Machine: PREOP = function for mailbox communication and different standard-settings set
Single flash
State of the EtherCAT State Machine: SAFEOP = verification of the Sync Manager channels and the distributed clocks.
Outputs remain in safe state
on
State of the EtherCAT State Machine: OP = normal operating state; mailbox and process data communication is possible
flickering
State of the EtherCAT State Machine: BOOTSTRAP = function for terminal firmware updates
AS-i Diag
green
This LED lights up during the AS-i data exchange phase (it flickers in regular operation).
Set switch
green
This LED is on as long as both set inputs are short-circuited.
AS-i Power
green
This LED is on as long as the AS-i power supply is connected and at least one AS-i slave was found.
AS-i fault diagnostics
red
This LED flashes if the nominal and actual configuration do not match.
Possible causes:
▪
AS-i ID code of one or several slaves does not match the currently projected values.
▪
The AS-i I/O code of one or several slaves does not match the currently projected values.
▪
The currently projected AS-i slave was not found.
Protected mode
green
This LED lights up as long as the two protected mode inputs are short-circuited.
AS-i installation
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminals system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals.
Connection of the AS interface
Connection of EL6201 AS-i master
Terminal contact | Name | Use
1 and 5 | SCM | Setting of the configuration mode by briefly bridging contacts 1 and 5
2 and 6 | ASi+ | ASi+ connection (brown). Both terminal points identified with ASi+ are connected internally.
3 and 7 | ASi- | ASi- connection (blue). Both terminal points identified with ASi- are connected internally.
4 and 8 | SPM | The detected slaves from the list of detected slaves can be projected for the protected mode by briefly bridging the two SPM contacts 4 and 8.
Connection AS-i potential supply terminal EL9520
Connection AS-i potential supply terminal EL9520
Terminal contact | Name | Use
1 | Uin+ | Positive voltage input 24 V..35 V
2 | ASi+ | Connection AS-i+ Both terminal points identified with ASi+ are connected internally.
3 | ASi- | Connection AS-i- Both terminal points identified with ASi- are connected internally.
4 |  | not used
5 | Uin- | Negative voltage input 24 V..35 V
6 | ASi+ | Connection AS-i+ Both terminal points identified with ASi+ are connected internally.
7 | ASi- | Connection AS-i- Both terminal points identified with ASi- are connected internally.
8 |  | not used
Wiring of the AS interface
Wiring diagram (example) for EL6201 AS-i master: connection to EL9520 (left), connection to AS-i power supply unit (right)
Since the user data are modulated on the power supply line with the AS-Interface, a special AS-i power supply unit (30.5 VDC) is required.
A further possibility is offered by the EL9520 AS-i potential supply terminal, which provides the supply direct from the EtherCAT Terminal network.


Commissioning

Commissioning
Commissioning
Additional information
•
TwinCAT Quick Start
•
TwinCAT Development Environment
•
General Notes - EtherCAT Slave Application
•
Functionality of the AS-i master
•
Quickstart
•
Further notes on commissioning
•
Object description and parameterization
•
Object description - standard objects


TwinCAT Quick Start

Commissioning [image] TwinCAT Quick Start
TwinCAT Quick Start
TwinCAT is a development environment for real-time control including multi-PLC system, NC axis control, programming and operation. The whole system is mapped through this environment and enables access to a programming environment (including compilation) for the controller. Individual digital or analog inputs or outputs can also be read or written directly, in order to verify their functionality, for example.
For further information please refer to http://infosys.beckhoff.com:
▪
EtherCAT Systemmanual:
Fieldbus Components → EtherCAT Terminals → EtherCAT System Documentation → Setup in the TwinCAT System Manager
▪
TwinCAT 2 → TwinCAT System Manager → I/O - Configuration
▪
In particular, TwinCAT driver installation:
Fieldbus components → Fieldbus Cards and Switches → FC900x – PCI Cards for Ethernet → Installation
Devices contain the terminals for the actual configuration. All configuration data can be entered directly via editor functions (offline) or via the "Scan" function (online):
▪
"offline": The configuration can be customized by adding and positioning individual components. These can be selected from a directory and configured.
–
The procedure for offline mode can be found under http://infosys.beckhoff.com:
TwinCAT 2 → TwinCAT System Manager → IO - Configuration → Adding an I/O Device
▪
"online": The existing hardware configuration is read
–
See also http://infosys.beckhoff.com:
Fieldbus components → Fieldbus cards and switches → FC900x – PCI Cards for Ethernet → Installation → Searching for devices
The following relationship is envisaged from user PC to the individual control elements:
Relationship between user side (commissioning) and installation
The user inserting of certain components (I/O device, terminal, box...) is the same in TwinCAT 2 and TwinCAT 3. The descriptions below relate to the online procedure.
Sample configuration (actual configuration)
Based on the following sample configuration, the subsequent subsections describe the procedure for TwinCAT 2 and TwinCAT 3:
▪
Control system (PLC) CX2040 including CX2100-0004 power supply unit
▪
Connected to the CX2040 on the right (E-bus):
EL1004 (4-channel analog input terminal -10…+10 V)
▪
Linked via the X001 port (RJ-45): EK1100 EtherCAT Coupler
▪
Connected to the EK1100 EtherCAT coupler on the right (E-bus):
EL2008 (8-channel digital output terminal 24 V DC; 0.5 A)
▪
(Optional via X000: a link to an external PC for the user interface)
Control configuration with Embedded PC, input (EL1004) and output (EL2008)
Note that all combinations of a configuration are possible; for example, the EL1004 terminal could also be connected after the coupler, or the EL2008 terminal could additionally be connected to the CX2040 on the right, in which case the EK1100 coupler wouldn’t be necessary.
Additional information
•
TwinCAT 2
•
TwinCAT 3


TwinCAT 2

Commissioning [image] TwinCAT Quick Start [image] TwinCAT 2
TwinCAT 2
Startup
TwinCAT basically uses two user interfaces: the TwinCAT System Manager for communication with the electromechanical components and TwinCAT PLC Control for the development and compilation of a controller. The starting point is the TwinCAT System Manager.
After successful installation of the TwinCAT system on the PC to be used for development, the TwinCAT 2 System Manager displays the following user interface after startup:
Initial TwinCAT 2 user interface
Generally, TwinCAT can be used in local or remote mode. Once the TwinCAT system including the user interface (standard) is installed on the respective PLC, TwinCAT can be used in local mode and thereby the next step is "Insert Device".
If the intention is to address the TwinCAT runtime environment installed on a PLC as development environment remotely from another system, the target system must be made known first. In the menu under "Actions" → "Choose Target System...", via the symbol " [image] " or the "F8" key, open the following window:
Selection of the target system
Use "Search (Ethernet)..." to enter the target system. Thus a next dialog opens to either:
▪
enter the known computer name after "Enter Host Name / IP:" (as shown in red)
▪
perform a "Broadcast Search" (if the exact computer name is not known)
▪
enter the known computer IP or AmsNetID.
Specify the PLC for access by the TwinCAT System Manager: selection of the target system
Once the target system has been entered, it is available for selection as follows (a password may have to be entered):
After confirmation with "OK" the target system can be accessed via the System Manager.
Adding devices
In the configuration tree of the TwinCAT 2 System Manager user interface on the left, select "I/O Devices” and then right-click to open a context menu and select "Scan Devices…", or start the action in the menu bar via [image]. The TwinCAT System Manager may first have to be set to "Config mode" via [image] or via menu
“Actions" → "Set/Reset TwinCAT to Config Mode…" (Shift + F4).
Select "Scan Devices..."
Confirm the warning message, which follows, and select "EtherCAT" in the dialog:
Automatic detection of I/O devices: selection the devices to be integrated
Confirm the message "Find new boxes", in order to determine the terminals connected to the devices. "Free Run" enables manipulation of input and output values in "Config mode" and should also be acknowledged.
Based on the sample configuration described at the beginning of this section, the result is as follows:
Mapping of the configuration in the TwinCAT 2 System Manager
The whole process consists of two stages, which may be performed separately (first determine the devices, then determine the connected elements such as boxes, terminals, etc.). A scan can also be initiated by selecting "Device ..." from the context menu, which then reads the elements present in the configuration below:
Reading of individual terminals connected to a device
This functionality is useful if the actual configuration is modified at short notice.
Programming and integrating the PLC
TwinCAT PLC Control is the development environment for the creation of the controller in different program environments: TwinCAT PLC Control supports all languages described in IEC 61131-3. There are two text-based languages and three graphical languages.
▪
Text-based languages
–
Instruction List (IL)
–
Structured Text (ST)
▪
Graphical languages
–
Function Block Diagram (FBD)
–
Ladder Diagram (LD)
–
The Continuous Function Chart Editor (CFC)
–
Sequential Function Chart (SFC)
The following section refers to Structured Text (ST).
After starting TwinCAT PLC Control, the following user interface is shown for an initial project:
TwinCAT PLC Control after startup
Sample variables and a sample program have been created and stored under the name "PLC_example.pro":
Sample program with variables after a compile process (without variable integration)
Warning 1990 (missing "VAR_CONFIG") after a compile process indicates that the variables defined as external (with the ID "AT%I*" or "AT%Q*") have not been assigned. After successful compilation, TwinCAT PLC Control creates a "*.tpy" file in the directory in which the project was stored. This file (*.tpy) contains variable assignments and is not known to the System Manager, hence the warning. Once the System Manager has been notified, the warning no longer appears.
First, integrate the TwinCAT PLC Control project in the System Manager via the context menu of the PLC configuration; right-click and select "Append PLC Project…":
Appending the TwinCAT PLC Control project
Select the PLC configuration "PLC_example.tpy" in the browser window that opens. The project including the two variables identified with "AT" are then integrated in the configuration tree of the System Manager:
PLC project integrated in the PLC configuration of the System Manager
The two variables "bEL1004_Ch4" and "nEL2008_value" can now be assigned to certain process objects of the I/O configuration.
Assigning variables
Open a window for selecting a suitable process object (PDO) via the context menu of a variable of the integrated project "PLC_example" and via "Modify Link..." "Standard":
Creating the links between PLC variables and process objects
In the window that opens, the process object for the variable “bEL1004_Ch4” of type BOOL can be selected from the PLC configuration tree:
Selecting PDO of type BOOL
According to the default setting, certain PDO objects are now available for selection. In this sample the input of channel 4 of the EL1004 terminal is selected for linking. In contrast, the checkbox "All types" must be ticked for creating the link for the output variables, in order to allocate a set of eight separate output bits to a byte variable. The following diagram shows the whole process:
Selecting several PDOs simultaneously: activate "Continuous" and "All types"
Note that the "Continuous" checkbox was also activated. This is designed to allocate the bits contained in the byte of the variable "nEL2008_value" sequentially to all eight selected output bits of the EL2008 terminal. In this way it is possible to subsequently address all eight outputs of the terminal in the program with a byte corresponding to bit 0 for channel 1 to bit 7 for channel 8 of the PLC. A special symbol ( [image]) at the yellow or red object of the variable indicates that a link exists. The links can also be checked by selecting a "Goto Link Variable” from the context menu of a variable. The object opposite, in this case the PDO, is automatically selected:
Application of a "Goto Link" variable, using "MAIN.bEL1004_Ch4" as a sample
The process of assigning variables to the PDO is completed via the menu selection "Actions" → "Generate Mappings”, key Ctrl+M or by clicking on the symbol [image] in the menu.
This can be visualized in the configuration:
The process of creating links can also take place in the opposite direction, i.e. starting with individual PDOs to variable. However, in this example it would then not be possible to select all output bits for the EL2008, since the terminal only makes individual digital outputs available. If a terminal has a byte, word, integer or similar PDO, it is possible to allocate this a set of bit-standardised variables (type "BOOL"). Here, too, a "Goto Link Variable” from the context menu of a PDO can be executed in the other direction, so that the respective PLC instance can then be selected.
Activation of the configuration
The allocation of PDO to PLC variables has now established the connection from the controller to the inputs and outputs of the terminals. The configuration can now be activated. First, the configuration can be verified via [image] (or via "Actions" → "Check Configuration”). If no error is present, the configuration can be activated via [image] (or via "Actions" → "Activate Configuration…") to transfer the System Manager settings to the runtime system. Confirm the messages "Old configurations are overwritten!" and "Restart TwinCAT system in Run mode" with "OK".
A few seconds later the real-time status [image] is displayed at the bottom right in the System Manager. The PLC system can then be started as described below.
Starting the controller
Starting from a remote system, the PLC control has to be linked with the Embedded PC over Ethernet via "Online" → “Choose Run-Time System…":
Choose target system (remote)
In this sample "Runtime system 1 (port 801)" is selected and confirmed. Link the PLC with the real-time system via menu option "Online" → "Login", the F11 key or by clicking on the symbol [image]. The control program can then be loaded for execution. This results in the message "No program on the controller! Should the new program be loaded?", which should be acknowledged with "Yes". The runtime environment is ready for the program start:
PLC Control logged in, ready for program startup
The PLC can now be started via "Online" → "Run", F5 key or [image].


TwinCAT 3

Commissioning [image] TwinCAT Quick Start [image] TwinCAT 3
TwinCAT 3
Startup
TwinCAT makes the development environment areas available together with Microsoft Visual Studio: after startup, the project folder explorer appears on the left in the general window area (cf. "TwinCAT System Manager" of TwinCAT 2) for communication with the electromechanical components.
After successful installation of the TwinCAT system on the PC to be used for development, TwinCAT 3 (shell) displays the following user interface after startup:
Initial TwinCAT 3 user interface
First create a new project via [image] (or under "File"→“New"→ "Project…"). In the following dialog make the corresponding entries as required (as shown in the diagram):
Create new TwinCAT project
The new project is then available in the project folder explorer:
New TwinCAT3 project in the project folder explorer
Generally, TwinCAT can be used in local or remote mode. Once the TwinCAT system including the user interface (standard) is installed on the respective PLC, TwinCAT can be used in local mode and thereby the next step is "Insert Device".
If the intention is to address the TwinCAT runtime environment installed on a PLC as development environment remotely from another system, the target system must be made known first. Via the symbol in the menu bar:
expand the pull-down menu:
and open the following window:
Selection dialog: Choose the target system
Use "Search (Ethernet)..." to enter the target system. Thus a next dialog opens to either:
▪
enter the known computer name after "Enter Host Name / IP:" (as shown in red)
▪
perform a "Broadcast Search" (if the exact computer name is not known)
▪
enter the known computer IP or AmsNetID.
Specify the PLC for access by the TwinCAT System Manager: selection of the target system
Once the target system has been entered, it is available for selection as follows (a password may have to be entered):
After confirmation with "OK" the target system can be accessed via the Visual Studio shell.
Adding devices
In the project folder explorer of the Visual Studio shell user interface on the left, select "Devices" within element “I/O”, then right-click to open a context menu and select "Scan" or start the action via [image] in the menu bar. The TwinCAT System Manager may first have to be set to "Config mode" via [image] or via the menu "TwinCAT" → "Restart TwinCAT (Config mode)".
Select "Scan"
Confirm the warning message, which follows, and select "EtherCAT" in the dialog:
Automatic detection of I/O devices: selection the devices to be integrated
Confirm the message "Find new boxes", in order to determine the terminals connected to the devices. "Free Run" enables manipulation of input and output values in "Config mode" and should also be acknowledged.
Based on the sample configuration described at the beginning of this section, the result is as follows:
Mapping of the configuration in VS shell of the TwinCAT3 environment
The whole process consists of two stages, which may be performed separately (first determine the devices, then determine the connected elements such as boxes, terminals, etc.). A scan can also be initiated by selecting "Device ..." from the context menu, which then reads the elements present in the configuration below:
Reading of individual terminals connected to a device
This functionality is useful if the actual configuration is modified at short notice.
Programming the PLC
TwinCAT PLC Control is the development environment for the creation of the controller in different program environments: TwinCAT PLC Control supports all languages described in IEC 61131-3. There are two text-based languages and three graphical languages.
▪
Text-based languages
–
Instruction List (IL)
–
Structured Text (ST)
▪
Graphical languages
–
Function Block Diagram (FBD)
–
Ladder Diagram (LD)
–
The Continuous Function Chart Editor (CFC)
–
Sequential Function Chart (SFC)
The following section refers to Structured Text (ST).
In order to create a programming environment, a PLC subproject is added to the project sample via the context menu of "PLC" in the project folder explorer by selecting "Add New Item….":
Adding the programming environment in "PLC"
In the dialog that opens select "Standard PLC project" and enter "PLC_example" as project name, for example, and select a corresponding directory:
Specifying the name and directory for the PLC programming environment
The "Main" program, which already exists by selecting "Standard PLC project", can be opened by double-clicking on "PLC_example_project" in "POUs”. The following user interface is shown for an initial project:
Initial "Main" program of the standard PLC project
To continue, sample variables and a sample program have now been created:
Sample program with variables after a compile process (without variable integration)
The control program is now created as a project folder, followed by the compile process:
Start program compilation
The following variables, identified in the ST/ PLC program with "AT%", are then available in under "Assignments" in the project folder explorer:
Assigning variables
Via the menu of an instance - variables in the "PLC” context, use the "Modify Link…" option to open a window for selecting a suitable process object (PDO) for linking:
Creating the links between PLC variables and process objects
In the window that opens, the process object for the variable "bEL1004_Ch4" of type BOOL can be selected from the PLC configuration tree:
Selecting PDO of type BOOL
According to the default setting, certain PDO objects are now available for selection. In this sample the input of channel 4 of the EL1004 terminal is selected for linking. In contrast, the checkbox "All types" must be ticked for creating the link for the output variables, in order to allocate a set of eight separate output bits to a byte variable. The following diagram shows the whole process:
Selecting several PDOs simultaneously: activate "Continuous" and "All types"
Note that the "Continuous" checkbox was also activated. This is designed to allocate the bits contained in the byte of the variable "nEL2008_value" sequentially to all eight selected output bits of the EL2008 terminal. In this way it is possible to subsequently address all eight outputs of the terminal in the program with a byte corresponding to bit 0 for channel 1 to bit 7 for channel 8 of the PLC. A special symbol ( [image]) at the yellow or red object of the variable indicates that a link exists. The links can also be checked by selecting a "Goto Link Variable” from the context menu of a variable. The object opposite, in this case the PDO, is automatically selected:
Application of a "Goto Link" variable, using "MAIN.bEL1004_Ch4" as a sample
The process of creating links can also take place in the opposite direction, i.e. starting with individual PDOs to variable. However, in this example it would then not be possible to select all output bits for the EL2008, since the terminal only makes individual digital outputs available. If a terminal has a byte, word, integer or similar PDO, it is possible to allocate this a set of bit-standardised variables (type "BOOL"). Here, too, a "Goto Link Variable” from the context menu of a PDO can be executed in the other direction, so that the respective PLC instance can then be selected.
Activation of the configuration
The allocation of PDO to PLC variables has now established the connection from the controller to the inputs and outputs of the terminals. The configuration can now be activated with [image] or via the menu under "TwinCAT" in order to transfer settings of the development environment to the runtime system. Confirm the messages "Old configurations are overwritten!" and "Restart TwinCAT system in Run mode" with "OK". The corresponding assignments can be seen in the project folder explorer:
A few seconds later the corresponding status of the Run mode is displayed in the form of a rotating symbol [image] at the bottom right of the VS shell development environment. The PLC system can then be started as described below.
Starting the controller
Select the menu option "PLC" → "Login" or click on [image] to link the PLC with the real-time system and load the control program for execution. This results in the message "No program on the controller! Should the new program be loaded?", which should be acknowledged with "Yes". The runtime environment is ready for program start by click on symbol [image], the "F5" key or via "PLC" in the menu selecting “Start”. The started programming environment shows the runtime values of individual variables:
TwinCAT development environment (VS shell): logged-in, after program startup
The two operator control elements for stopping [image] and logout [image] result in the required action (accordingly also for stop "Shift + F5", or both actions can be selected via the PLC menu).


TwinCAT Development Environment

Commissioning [image] TwinCAT Development Environment
TwinCAT Development Environment
The Software for automation TwinCAT (The Windows Control and Automation Technology) will be distinguished into:
▪
TwinCAT 2: System Manager (Configuration) & PLC Control (Programming)
▪
TwinCAT 3: Enhancement of TwinCAT 2 (Programming and Configuration takes place via a common Development Environment)
Details:
▪
TwinCAT 2:
–
Connects I/O devices to tasks in a variable-oriented manner
–
Connects tasks to tasks in a variable-oriented manner
–
Supports units at the bit level
–
Supports synchronous or asynchronous relationships
–
Exchange of consistent data areas and process images
–
Datalink on NT - Programs by open Microsoft Standards (OLE, OCX, ActiveX, DCOM+, etc.)
–
Integration of IEC 61131-3-Software-SPS, Software- NC and Software-CNC within Windows NT/2000/XP/Vista, Windows 7, NT/XP Embedded, CE
–
Interconnection to all common fieldbusses
–
More…
Additional features:
▪
TwinCAT 3 (eXtended Automation):
–
Visual-Studio®-Integration
–
Choice of the programming language
–
Supports object orientated extension of IEC 61131-3
–
Usage of C/C++ as programming language for real time applications
–
Connection to MATLAB®/Simulink®
–
Open interface for expandability
–
Flexible run-time environment
–
Active support of Multi-Core- und 64-Bit-Operatingsystem
–
Automatic code generation and project creation with the TwinCAT Automation Interface
–
More…
Within the following sections commissioning of the TwinCAT Development Environment on a PC System for the control and also the basically functions of unique control elements will be explained.
Please see further information to TwinCAT 2 and TwinCAT 3 at http://infosys.beckhoff.com.
Additional information
•
Installation of the TwinCAT real-time driver
•
Notes regarding ESI device description
•
TwinCAT ESI Updater
•
Distinction between Online and Offline
•
OFFLINE configuration creation
•
ONLINE configuration creation
•
EtherCAT subscriber configuration


Installation of the TwinCAT real-time driver

Commissioning [image] TwinCAT Development Environment [image] Installation of the TwinCAT real-time driver
Installation of the TwinCAT real-time driver
In order to assign real-time capability to a standard Ethernet port of an IPC controller, the Beckhoff real-time driver has to be installed on this port under Windows.
This can be done in several ways. One option is described here.
In the System Manager call up the TwinCAT overview of the local network interfaces via Options → Show Real Time Ethernet Compatible Devices.
System Manager “Options” (TwinCAT 2)
This have to be called up by the Menü “TwinCAT” within the TwinCAT 3 environment:
Call up under VS Shell (TwinCAT 3)
The following dialog appears:
Overview of network interfaces
Interfaces listed under “Compatible devices” can be assigned a driver via the “Install” button. A driver should only be installed on compatible devices.
A Windows warning regarding the unsigned driver can be ignored.
Alternatively an EtherCAT-device can be inserted first of all as described in chapter Offline configuration creation, section “Creating the EtherCAT device” in order to view the compatible ethernet ports via its EtherCAT properties (tab „Adapter“, button „Compatible Devices…“):
EtherCAT device properties(TwinCAT 2): click on „Compatible Devices…“ of tab “Adapter”
TwinCAT 3: the properties of the EtherCAT device can be opened by double click on “Device .. (EtherCAT)” within the Solution Explorer under “I/O”:
After the installation the driver appears activated in the Windows overview for the network interface (Windows Start → System Properties → Network)
Windows properties of the network interface
A correct setting of the driver could be:
Exemplary correct driver setting for the Ethernet port
Other possible settings have to be avoided:
Incorrect driver settings for the Ethernet port
IP address of the port used
IP address/DHCP
In most cases an Ethernet port that is configured as an EtherCAT device will not transport general IP packets. For this reason and in cases where an EL6601 or similar devices are used it is useful to specify a fixed IP address for this port via the “Internet Protocol TCP/IP” driver setting and to disable DHCP. In this way the delay associated with the DHCP client for the Ethernet port assigning itself a default IP address in the absence of a DHCP server is avoided. A suitable address space is 192.168.x.x, for example.
TCP/IP setting for the Ethernet port


Notes regarding ESI device description

Commissioning [image] TwinCAT Development Environment [image] Notes regarding ESI device description
Notes regarding ESI device description
Installation of the latest ESI device description
The TwinCAT EtherCAT master/System Manager needs the device description files for the devices to be used in order to generate the configuration in online or offline mode. The device descriptions are contained in the so-called ESI files (EtherCAT Slave Information) in XML format. These files can be requested from the respective manufacturer and are made available for download. An *.xml file may contain several device descriptions.
The ESI files for Beckhoff EtherCAT devices are available on the Beckhoff website.
The ESI files should be stored in the TwinCAT installation directory.
Default settings:
▪
TwinCAT 2: C:\TwinCAT\IO\EtherCAT
▪
TwinCAT 3: C:\TwinCAT\3.1\Config\Io\EtherCAT
The files are read (once) when a new System Manager window is opened, if they have changed since the last time the System Manager window was opened.
A TwinCAT installation includes the set of Beckhoff ESI files that was current at the time when the TwinCAT build was created.
For TwinCAT 2.11/TwinCAT 3 and higher, the ESI directory can be updated from the System Manager, if the programming PC is connected to the Internet; by
▪
TwinCAT 2: Option → “Update EtherCAT Device Descriptions”
▪
TwinCAT 3: TwinCAT → EtherCAT Devices → “Update Device Descriptions (via ETG Website)…”
The TwinCAT ESI Updater is available for this purpose.
ESI
The *.xml files are associated with *.xsd files, which describe the structure of the ESI XML files. To update the ESI device descriptions, both file types should therefore be updated.
Device differentiation
EtherCAT devices/slaves are distinguished by four properties, which determine the full device identifier. For example, the device identifier EL2521-0025-1018 consists of:
▪
family key “EL”
▪
name “2521”
▪
type “0025”
▪
and revision “1018”
Identifier structure
The order identifier consisting of name + type (here: EL2521-0010) describes the device function. The revision indicates the technical progress and is managed by Beckhoff. In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation. Each revision has its own ESI description. See further notes.
Online description
If the EtherCAT configuration is created online through scanning of real devices (see section Online setup) and no ESI descriptions are available for a slave (specified by name and revision) that was found, the System Manager asks whether the description stored in the device should be used. In any case, the System Manager needs this information for setting up the cyclic and acyclic communication with the slave correctly.
OnlineDescription information window (TwinCAT 2)
In TwinCAT 3 a similar window appears, which also offers the Web update:
Information window OnlineDescription (TwinCAT 3)
If possible, the Yes is to be rejected and the required ESI is to be requested from the device manufacturer. After installation of the XML/XSD file the configuration process should be repeated.
Note
Changing the ‘usual’ configuration through a scan
✓
If a scan discovers a device that is not yet known to TwinCAT, distinction has to be made between two cases. Taking the example here of the EL2521-0000 in the revision 1019
1.
no ESI is present for the EL2521-0000 device at all, either for the revision 1019 or for an older revision. The ESI must then be requested from the manufacturer (in this case Beckhoff).
2.
an ESI is present for the EL2521-0000 device, but only in an older revision, e.g. 1018 or 1017.
In this case an in-house check should first be performed to determine whether the spare parts stock allows the integration of the increased revision into the configuration at all. A new/higher revision usually also brings along new features. If these are not to be used, work can continue without reservations with the previous revision 1018 in the configuration. This is also stated by the Beckhoff compatibility rule.
Refer in particular to the chapter ‘General notes on the use of Beckhoff EtherCAT IO components’ and for manual configuration to the chapter ‘Offline configuration creation’.
If the OnlineDescription is used regardless, the System Manager reads a copy of the device description from the EEPROM in the EtherCAT slave. In complex slaves the size of the EEPROM may not be sufficient for the complete ESI, in which case the ESI would be incomplete in the configurator. Therefore it’s recommended using an offline ESI file with priority in such a case.
The System Manager creates for online recorded device descriptions a new file “OnlineDescription0000...xml” in its ESI directory, which contains all ESI descriptions that were read online.
File OnlineDescription.xml created by the System Manager
Is a slave desired to be added manually to the configuration at a later stage, online created slaves are indicated by a prepended symbol “>” in the selection list (see Figure “Indication of an online recorded ESI of EL2521 as an example”).
Indication of an online recorded ESI of EL2521 as an example
If such ESI files are used and the manufacturer's files become available later, the file OnlineDescription.xml should be deleted as follows:
▪
close all System Manager windows
▪
restart TwinCAT in Config mode
▪
delete "OnlineDescription0000...xml"
▪
restart TwinCAT System Manager
This file should not be visible after this procedure, if necessary press <F5> to update
OnlineDescription for TwinCAT 3.x
In addition to the file described above "OnlineDescription0000...xml" , a so called EtherCAT cache with new discovered devices is created by TwinCAT 3.x, e.g. under Windows 7:

(Please note the language settings of the OS!)
You have to delete this file, too.
Faulty ESI file
If an ESI file is faulty and the System Manager is unable to read it, the System Manager brings up an information window.
Information window for faulty ESI file (left: TwinCAT 2; right: TwinCAT 3)
Reasons may include:
▪
Structure of the *.xml does not correspond to the associated *.xsd file → check your schematics
▪
Contents cannot be translated into a device description → contact the file manufacturer


TwinCAT ESI Updater

Commissioning [image] TwinCAT Development Environment [image] TwinCAT ESI Updater
TwinCAT ESI Updater
For TwinCAT 2.11 and higher, the System Manager can search for current Beckhoff ESI files automatically, if an online connection is available:
Using the ESI Updater (>= TwinCAT 2.11)
The call up takes place under:
“Options” → "Update EtherCAT Device Descriptions"
Selection under TwinCAT 3:
Using the ESI Updater (TwinCAT 3)
The ESI Updater (TwinCAT 3) is a convenient option for automatic downloading of ESI data provided by EtherCAT manufacturers via the Internet into the TwinCAT directory (ESI = EtherCAT slave information). TwinCAT accesses the central ESI ULR directory list stored at ETG; the entries can then be viewed in the Updater dialog, although they cannot be changed there.
The call up takes place under:
“TwinCAT“ → „EtherCAT Devices“ → “Update Device Description (via ETG Website)…“.


Distinction between Online and Offline

Commissioning [image] TwinCAT Development Environment [image] Distinction between Online and Offline
Distinction between Online and Offline
The distinction between online and offline refers to the presence of the actual I/O environment (drives, terminals, EJ-modules). If the configuration is to be prepared in advance of the system configuration as a programming system, e.g. on a laptop, this is only possible in “Offline configuration” mode. In this case all components have to be entered manually in the configuration, e.g. based on the electrical design.
If the designed control system is already connected to the EtherCAT system and all components are energised and the infrastructure is ready for operation, the TwinCAT configuration can simply be generated through “scanning” from the runtime system. This is referred to as online configuration.
In any case, during each startup the EtherCAT master checks whether the slaves it finds match the configuration. This test can be parameterised in the extended slave settings. Refer to note “Installation of the latest ESI-XML device description”.
For preparation of a configuration:
▪
the real EtherCAT hardware (devices, couplers, drives) must be present and installed
▪
the devices/modules must be connected via EtherCAT cables or in the terminal/ module strand in the same way as they are intended to be used later
▪
the devices/modules be connected to the power supply and ready for communication
▪
TwinCAT must be in CONFIG mode on the target system.
The online scan process consists of:
▪
detecting the EtherCAT device (Ethernet port at the IPC)
▪
detecting the connected EtherCAT devices. This step can be carried out independent of the preceding step
▪
troubleshooting
The scan with existing configuration can also be carried out for comparison.


OFFLINE configuration creation

Commissioning [image] TwinCAT Development Environment [image] OFFLINE configuration creation
OFFLINE configuration creation
Creating the EtherCAT device
Create an EtherCAT device in an empty System Manager window.
Append EtherCAT device (left: TwinCAT 2; right: TwinCAT 3)
Select type ‘EtherCAT’ for an EtherCAT I/O application with EtherCAT slaves. For the present publisher/subscriber service in combination with an EL6601/EL6614 terminal select “EtherCAT Automation Protocol via EL6601”.
Selecting the EtherCAT connection (TwinCAT 2.11, TwinCAT 3)
Then assign a real Ethernet port to this virtual device in the runtime system.
Selecting the Ethernet port
This query may appear automatically when the EtherCAT device is created, or the assignment can be set/modified later in the properties dialog; see Fig. “EtherCAT device properties (TwinCAT 2)”.
EtherCAT device properties (TwinCAT 2)
TwinCAT 3: the properties of the EtherCAT device can be opened by double click on “Device .. (EtherCAT)” within the Solution Explorer under “I/O”:
Selecting the Ethernet port
Ethernet ports can only be selected for EtherCAT devices for which the TwinCAT real-time driver is installed. This has to be done separately for each port. Please refer to the respective installation page.
Defining EtherCAT slaves
Further devices can be appended by right-clicking on a device in the configuration tree.
Appending EtherCAT devices (left: TwinCAT 2; right: TwinCAT 3)
The dialog for selecting a new device opens. Only devices for which ESI files are available are displayed.
Only devices are offered for selection that can be appended to the previously selected device. Therefore the physical layer available for this port is also displayed (Fig. “Selection dialog for new EtherCAT device”, A). In the case of cable-based Fast-Ethernet physical layer with PHY transfer, then also only cable-based devices are available, as shown in Fig. “Selection dialog for new EtherCAT device”. If the preceding device has several free ports (e.g. EK1122 or EK1100), the required port can be selected on the right-hand side (A).
Overview of physical layer
▪
“Ethernet”: cable-based 100BASE-TX: EK couplers, EP boxes, devices with RJ45/M8/M12 connector
▪
“E-Bus”: LVDS “terminal bus”, “EJ-module”: EL/ES terminals, various modular modules
The search field facilitates finding specific devices (since TwinCAT 2.11 or TwinCAT 3).
Selection dialog for new EtherCAT device
By default only the name/device type is used as selection criterion. For selecting a specific revision of the device the revision can be displayed as “Extended Information”.
Display of device revision
In many cases several device revisions were created for historic or functional reasons, e.g. through technological advancement. For simplification purposes (see Fig. “Selection dialog for new EtherCAT device”) only the last (i.e. highest) revision and therefore the latest state of production is displayed in the selection dialog for Beckhoff devices. To show all device revisions available in the system as ESI descriptions tick the “Show Hidden Devices” check box, see Fig. “Display of previous revisions”.
Display of previous revisions
Device selection based on revision, compatibility
The ESI description also defines the process image, the communication type between master and slave/device and the device functions, if applicable. The physical device (firmware, if available) has to support the communication queries/settings of the master. This is backward compatible, i.e. newer devices (higher revision) should be supported if the EtherCAT master addresses them as an older revision. The following compatibility rule of thumb is to be assumed for Beckhoff EtherCAT Terminals/ Boxes/ EJ-modules:
device revision in the system >= device revision in the configuration
This also enables subsequent replacement of devices without changing the configuration (different specifications are possible for drives).
Example:
If an EL2521-0025-1018 is specified in the configuration, an EL2521-0025-1018 or higher (-1019, -1020) can be used in practice.
Name/revision of the terminal
If current ESI descriptions are available in the TwinCAT system, the last revision offered in the selection dialog matches the Beckhoff state of production. It is recommended to use the last device revision when creating a new configuration, if current Beckhoff devices are used in the real application. Older revisions should only be used if older devices from stock are to be used in the application.
In this case the process image of the device is shown in the configuration tree and can be parameterised as follows: linking with the task, CoE/DC settings, plug-in definition, startup settings, ...
EtherCAT terminal in the TwinCAT tree (left: TwinCAT 2; right: TwinCAT 3)


ONLINE configuration creation

Commissioning [image] TwinCAT Development Environment [image] ONLINE configuration creation
ONLINE configuration creation
Detecting/scanning of the EtherCAT device
The online device search can be used if the TwinCAT system is in CONFIG mode. This can be indicated by a symbol right below in the information bar:
▪
on TwinCAT 2 by a blue display “Config Mode” within the System Manager window: .
▪
on TwinCAT 3 within the user interface of the development environment by a symbol [image].
TwinCAT can be set into this mode:
▪
TwinCAT 2: by selection of [image] in the Menubar or by “Actions” → “Set/Reset TwinCAT to Config Mode…”
▪
TwinCAT 3: by selection of [image] in the Menubar or by „TwinCAT“ → “Restart TwinCAT (Config Mode)“
Online scanning in Config mode
The online search is not available in RUN mode (production operation). Note the differentiation between TwinCAT programming system and TwinCAT target system.
The TwinCAT 2 icon ( [image]) or TwinCAT 3 icon ( [image]) within the Windows-Taskbar always shows the TwinCAT mode of the local IPC. Compared to that, the System Manager window of TwinCAT 2 or the user interface of TwinCAT 3 indicates the state of the target system.
Differentiation local/target system (left: TwinCAT 2; right: TwinCAT 3)
Right-clicking on “I/O Devices” in the configuration tree opens the search dialog.
Scan Devices (left: TwinCAT 2; right: TwinCAT 3)
This scan mode attempts to find not only EtherCAT devices (or Ethernet ports that are usable as such), but also NOVRAM, fieldbus cards, SMB etc. However, not all devices can be found automatically.
Note for automatic device scan (left: TwinCAT 2; right: TwinCAT 3)
Ethernet ports with installed TwinCAT real-time driver are shown as “RT Ethernet” devices. An EtherCAT frame is sent to these ports for testing purposes. If the scan agent detects from the response that an EtherCAT slave is connected, the port is immediately shown as an “EtherCAT Device” .
Detected Ethernet devices
Via respective checkboxes devices can be selected (as illustrated in Fig. “Detected Ethernet devices” e.g. Device 3 and Device 4 were chosen). After confirmation with “OK” a device scan is suggested for all selected devices, see Fig.: “Scan query after automatic creation of an EtherCAT device”.
Selecting the Ethernet port
Ethernet ports can only be selected for EtherCAT devices for which the TwinCAT real-time driver is installed. This has to be done separately for each port. Please refer to the respective installation page.
Detecting/Scanning the EtherCAT devices
Online scan functionality
During a scan the master queries the identity information of the EtherCAT slaves from the slave EEPROM. The name and revision are used for determining the type. The respective devices are located in the stored ESI data and integrated in the configuration tree in the default state defined there.
Example default state
Note
Slave scanning in practice in series machine production
The scanning function should be used with care. It is a practical and fast tool for creating an initial configuration as a basis for commissioning. In series machine production or reproduction of the plant, however, the function should no longer be used for the creation of the configuration, but if necessary for comparison with the defined initial configuration.Background: since Beckhoff occasionally increases the revision version of the delivered products for product maintenance reasons, a configuration can be created by such a scan which (with an identical machine construction) is identical according to the device list; however, the respective device revision may differ from the initial configuration.
Example:
Company A builds the prototype of a machine B, which is to be produced in series later on. To do this the prototype is built, a scan of the IO devices is performed in TwinCAT and the initial configuration ‘B.tsm’ is created. The EL2521-0025 EtherCAT terminal with the revision 1018 is located somewhere. It is thus built into the TwinCAT configuration in this way:
Installing EthetCAT terminal with revision -1018
Likewise, during the prototype test phase, the functions and properties of this terminal are tested by the programmers/commissioning engineers and used if necessary, i.e. addressed from the PLC ‘B.pro’ or the NC. (the same applies correspondingly to the TwinCAT 3 solution files).
The prototype development is now completed and series production of machine B starts, for which Beckhoff continues to supply the EL2521-0025-0018. If the commissioning engineers of the series machine production department always carry out a scan, a B configuration with the identical contents results again for each machine. Likewise, A might create spare parts stores worldwide for the coming series-produced machines with EL2521-0025-1018 terminals.
After some time Beckhoff extends the EL2521-0025 by a new feature C. Therefore the FW is changed, outwardly recognizable by a higher FW version and a new revision -1019. Nevertheless the new device naturally supports functions and interfaces of the predecessor version(s); an adaptation of ‘B.tsm’ or even ‘B.pro’ is therefore unnecessary. The series-produced machines can continue to be built with ‘B.tsm’ and ‘B.pro’; it makes sense to perform a comparative scan against the initial configuration ‘B.tsm’ in order to check the built machine.
However, if the series machine production department now doesn’t use ‘B.tsm’, but instead carries out a scan to create the productive configuration, the revision -1019 is automatically detected and built into the configuration:
Detection of EtherCAT terminal with revision -1019
This is usually not noticed by the commissioning engineers. TwinCAT cannot signal anything either, since virtually a new configuration is created. According to the compatibility rule, however, this means that no EL2521-0025-1018 should be built into this machine as a spare part (even if this nevertheless works in the vast majority of cases).
In addition, it could be the case that, due to the development accompanying production in company A, the new feature C of the EL2521-0025-1019 (for example, an improved analog filter or an additional process data for the diagnosis) is discovered and used without in-house consultation. The previous stock of spare part devices are then no longer to be used for the new configuration ‘B2.tsm’ created in this way.Þ if series machine production is established, the scan should only be performed for informative purposes for comparison with a defined initial configuration. Changes are to be made with care!
If an EtherCAT device was created in the configuration (manually or through a scan), the I/O field can be scanned for devices/slaves.
Scan query after automatic creation of an EtherCAT device (left: TwinCAT 2; right: TwinCAT 3)
Manual triggering of a device scan on a specified EtherCAT device (left: TwinCAT 2; right: TwinCAT 3)
In the System Manager (TwinCAT 2) or the User Interface (TwinCAT 3) the scan process can be monitored via the progress bar at the bottom in the status bar.
Scan progressexemplary by TwinCAT 2
The configuration is established and can then be switched to online state (OPERATIONAL).
Config/FreeRun query (left: TwinCAT 2; right: TwinCAT 3)
In Config/FreeRun mode the System Manager display alternates between blue and red, and the EtherCAT device continues to operate with the idling cycle time of 4 ms (default setting), even without active task (NC, PLC).
Displaying of “Free Run” and “Config Mode” toggling right below in the status bar
TwinCAT can also be switched to this state by using a button (left: TwinCAT 2; right: TwinCAT 3)
The EtherCAT system should then be in a functional cyclic state, as shown in Fig. “Online display example”.
Online display example
Please note:
▪
all slaves should be in OP state
▪
the EtherCAT master should be in “Actual State” OP
▪
“frames/sec” should match the cycle time taking into account the sent number of frames
▪
no excessive “LostFrames” or CRC errors should occur
The configuration is now complete. It can be modified as described under manual procedure.
Troubleshooting
Various effects may occur during scanning.
▪
An unknown device is detected, i.e. an EtherCAT slave for which no ESI XML description is available.
In this case the System Manager offers to read any ESI that may be stored in the device. This case is described in the chapter "Notes regarding ESI device description".
▪
Device are not detected properly
Possible reasons include:
- faulty data links, resulting in data loss during the scan
- slave has invalid device description
The connections and devices should be checked in a targeted manner, e.g. via the emergency scan.
Then re-run the scan.
Faulty identification
In the System Manager such devices may be set up as EK0000 or unknown devices. Operation is not possible or meaningful.
Scan over existing Configuration
Note
Change of the configuration after comparison
With this scan (TwinCAT 2.11 or 3.1) only the device properties vendor (manufacturer), device name and revision are compared at present! A ‘ChangeTo’ or ‘Copy’ should only be carried out with care, taking into consideration the Beckhoff IO compatibility rule (see above). The device configuration is then replaced by the revision found; this can affect the supported process data and functions.
If a scan is initiated for an existing configuration, the actual I/O environment may match the configuration exactly or it may differ. This enables the configuration to be compared.
Identical configuration (left: TwinCAT 2; right: TwinCAT 3)
If differences are detected, they are shown in the correction dialog, so that the user can modify the configuration as required.
Correction dialog
It is advisable to tick the “Extended Information” check box to reveal differences in the revision.
Colour
Explanation
green
This EtherCAT slave matches the entry on the other side. Both type and revision match.
blue
This EtherCAT slave is present on the other side, but in a different revision. This other revision can have other default values for the process data as well as other/additional functions.
If the found revision is higher than the configured revision, the slave may be used provided compatibility issues are taken into account.
If the found revision is lower than the configured revision, it is likely that the slave cannot be used. The found device may not support all functions that the master expects based on the higher revision number.
light blue
This EtherCAT slave is ignored (“Ignore” button)
red
▪
This EtherCAT slave is not present on the other side.
▪
It is present, but in a different revision, which also differs in its properties from the one specified.
The compatibility principle then also applies here: if the found revision is higher than the configured revision, use is possible provided compatibility issues are taken into account, since the successor devices should support the functions of the predecessor devices.
If the found revision is lower than the configured revision, it is likely that the slave cannot be used. The found device may not support all functions that the master expects based on the higher revision number.
Device selection based on revision, compatibility
The ESI description also defines the process image, the communication type between master and slave/device and the device functions, if applicable. The physical device (firmware, if available) has to support the communication queries/settings of the master. This is backward compatible, i.e. newer devices (higher revision) should be supported if the EtherCAT master addresses them as an older revision. The following compatibility rule of thumb is to be assumed for Beckhoff EtherCAT Terminals/ Boxes/ EJ-modules:
device revision in the system >= device revision in the configuration
This also enables subsequent replacement of devices without changing the configuration (different specifications are possible for drives).
Example:
If an EL2521-0025-1018 is specified in the configuration, an EL2521-0025-1018 or higher (-1019, -1020) can be used in practice.
Name/revision of the terminal
If current ESI descriptions are available in the TwinCAT system, the last revision offered in the selection dialog matches the Beckhoff state of production. It is recommended to use the last device revision when creating a new configuration, if current Beckhoff devices are used in the real application. Older revisions should only be used if older devices from stock are to be used in the application.
In this case the process image of the device is shown in the configuration tree and can be parameterised as follows: linking with the task, CoE/DC settings, plug-in definition, startup settings, ...
Correction dialog with modifications
Once all modifications have been saved or accepted, click “OK” to transfer them to the real *.tsm configuration.
Change to Compatible Type
TwinCAT offers a function “Change to Compatible Type…” for the exchange of a device whilst retaining the links in the task.
Dialog “Change to Compatible Type…” (left: TwinCAT 2; right: TwinCAT 3)
This function is preferably to be used on AX5000 devices.
Change to Alternative Type
The TwinCAT System Manager offers a function for the exchange of a device: Change to Alternative Type
TwinCAT 2 Dialog Change to Alternative Type
If called, the System Manager searches in the procured device ESI (in this example: EL1202-0000) for details of compatible devices contained there. The configuration is changed and the ESI-EEPROM is overwritten at the same time – therefore this process is possible only in the online state (ConfigMode).


EtherCAT subscriber configuration

Commissioning [image] TwinCAT Development Environment [image] EtherCAT subscriber configuration
EtherCAT subscriber configuration
In the left-hand window of the TwinCAT 2 System Manager or the Solution Explorer of the TwinCAT 3 Development Environment respectively, click on the element of the terminal within the tree you wish to configure (in the example: EL3751 Terminal 3).
Branch element as terminal EL3751
In the right-hand window of the TwinCAT System manager (TwinCAT 2) or the Development Environment (TwinCAT 3), various tabs are now available for configuring the terminal. And yet the dimension of complexity of a subscriber determines which tabs are provided. Thus as illustrated in the example above the terminal EL3751 provides many setup options and also a respective number of tabs are available. On the contrary by the terminal EL1004 for example the tabs "General", "EtherCAT", "Process Data" and “Online“ are available only. Several terminals, as for instance the EL6695 provide special functions by a tab with its own terminal name, so “EL6695” in this case. A specific tab “Settings” by terminals with a wide range of setup options will be provided also (e.g. EL3751).
„General“ tab
“General” tab
Name | Name of the EtherCAT device
Id | Number of the EtherCAT device
Type | EtherCAT device type
Comment | Here you can add a comment (e.g. regarding the system).
Disabled | Here you can deactivate the EtherCAT device.
Create symbols | Access to this EtherCAT slave via ADS is only available if this control box is activated.
„EtherCAT“ tab
„EtherCAT“ tab
Type | EtherCAT device type
Product/Revision | Product and revision number of the EtherCAT device
Auto Inc Addr. | Auto increment address of the EtherCAT device. The auto increment address can be used for addressing each EtherCAT device in the communication ring through its physical position. Auto increment addressing is used during the start-up phase when the EtherCAT master allocates addresses to the EtherCAT devices. With auto increment addressing the first EtherCAT slave in the ring has the address 0000hex. For each further slave the address is decremented by 1 (FFFFhex, FFFEhex etc.).
EtherCAT Addr. | Fixed address of an EtherCAT slave. This address is allocated by the EtherCAT master during the start-up phase. Tick the control box to the left of the input field in order to modify the default value.
Previous Port | Name and port of the EtherCAT device to which this device is connected. If it is possible to connect this device with another one without changing the order of the EtherCAT devices in the communication ring, then this combination field is activated and the EtherCAT device to which this device is to be connected can be selected.
Advanced Settings | This button opens the dialogs for advanced settings.
The link at the bottom of the tab points to the product page for this EtherCAT device on the web.
“Process Data” tab
Indicates the configuration of the process data. The input and output data of the EtherCAT slave are represented as CANopen process data objects (Process Data Objects, PDOs). The user can select a PDO via PDO assignment and modify the content of the individual PDO via this dialog, if the EtherCAT slave supports this function.
“Process Data” tab
The process data (PDOs) transferred by an EtherCAT slave during each cycle are user data which the application expects to be updated cyclically or which are sent to the slave. To this end the EtherCAT master (Beckhoff TwinCAT) parameterizes each EtherCAT slave during the start-up phase to define which process data (size in bits/bytes, source location, transmission type) it wants to transfer to or from this slave. Incorrect configuration can prevent successful start-up of the slave.
For Beckhoff EtherCAT EL, ES, EM, EJ and EP slaves the following applies in general:
▪
The input/output process data supported by the device are defined by the manufacturer in the ESI/XML description. The TwinCAT EtherCAT Master uses the ESI description to configure the slave correctly.
▪
The process data can be modified in the system manager. See the device documentation.
Examples of modifications include: mask out a channel, displaying additional cyclic information, 16-bit display instead of 8-bit data size, etc.
▪
In so-called “intelligent” EtherCAT devices the process data information is also stored in the CoE directory. Any changes in the CoE directory that lead to different PDO settings prevent successful startup of the slave. It is not advisable to deviate from the designated process data, because the device firmware (if available) is adapted to these PDO combinations.
If the device documentation allows modification of process data, proceed as follows (see Figure “Configuring the process data”).
▪
A: select the device to configure
▪
B: in the “Process Data” tab select Input or Output under SyncManager (C)
▪
D: the PDOs can be selected or deselected
▪
H: the new process data are visible as linkable variables in the system manager
The new process data are active once the configuration has been activated and TwinCAT has been restarted (or the EtherCAT master has been restarted)
▪
E: if a slave supports this, Input and Output PDO can be modified simultaneously by selecting a so-called PDO record (“predefined PDO settings”).
Configuring the process data
Manual modification of the process data
According to the ESI description, a PDO can be identified as “fixed” with the flag “F” in the PDO overview (Fig. “Configuring the process data”, J). The configuration of such PDOs cannot be changed, even if TwinCAT offers the associated dialog (“Edit”). In particular, CoE content cannot be displayed as cyclic process data. This generally also applies in cases where a device supports download of the PDO configuration, “G”. In case of incorrect configuration the EtherCAT slave usually refuses to start and change to OP state. The System Manager displays an “invalid SM cfg” logger message: This error message (“invalid SM IN cfg” or “invalid SM OUT cfg”) also indicates the reason for the failed start.
A detailed description can be found at the end of this section.
„Startup“ tab
The Startup tab is displayed if the EtherCAT slave has a mailbox and supports the CANopen over EtherCAT (CoE) or Servo drive over EtherCAT protocol. This tab indicates which download requests are sent to the mailbox during startup. It is also possible to add new mailbox requests to the list display. The download requests are sent to the slave in the same order as they are shown in the list.
„Startup“ tab
Column
Description
Transition
Transition to which the request is sent. This can either be
▪
the transition from pre-operational to safe-operational (PS), or
▪
the transition from safe-operational to operational (SO).
If the transition is enclosed in "<>" (e.g. <PS>), the mailbox request is fixed and cannot be modified or deleted by the user.
Protocol
Type of mailbox protocol
Index
Index of the object
Data
Date on which this object is to be downloaded.
Comment
Description of the request to be sent to the mailbox
Move Up | This button moves the selected request up by one position in the list.
Move Down | This button moves the selected request down by one position in the list.
New | This button adds a new mailbox download request to be sent during startup.
Delete | This button deletes the selected entry.
Edit | This button edits an existing request.
“CoE – Online” tab
The additional CoE - Online tab is displayed if the EtherCAT slave supports the CANopen over EtherCAT (CoE) protocol. This dialog lists the content of the object list of the slave (SDO upload) and enables the user to modify the content of an object from this list. Details for the objects of the individual EtherCAT devices can be found in the device-specific object descriptions.
“CoE – Online” tab
Object list display
Column | Description
Index | Index and sub-index of the object
Name | Name of the object
Flags | RW | The object can be read, and data can be written to the object (read/write)
 | RO | The object can be read, but no data can be written to the object (read only)
 | P | An additional P identifies the object as a process data object.
Value | Value of the object
Update List | The Update list button updates all objects in the displayed list
Auto Update | If this check box is selected, the content of the objects is updated automatically.
Advanced | The Advanced button opens the Advanced Settings dialog. Here you can specify which objects are displayed in the list.
Dialog “Advanced settings”
Online - via SDO Information | If this option button is selected, the list of the objects included in the object list of the slave is uploaded from the slave via SDO information. The list below can be used to specify which object types are to be uploaded.
Offline - via EDS File | If this option button is selected, the list of the objects included in the object list is read from an EDS file provided by the user.
„Online“ tab
„Online“ tab
State Machine
Init | This button attempts to set the EtherCAT device to the Init state.
Pre-Op | This button attempts to set the EtherCAT device to the pre-operational state.
Op | This button attempts to set the EtherCAT device to the operational state.
Bootstrap | This button attempts to set the EtherCAT device to the Bootstrap state.
Safe-Op | This button attempts to set the EtherCAT device to the safe-operational state.
Clear Error | This button attempts to delete the fault display. If an EtherCAT slave fails during change of state it sets an error flag. Example: An EtherCAT slave is in PREOP state (pre-operational). The master now requests the SAFEOP state (safe-operational). If the slave fails during change of state it sets the error flag. The current state is now displayed as ERR PREOP. When the Clear Error button is pressed the error flag is cleared, and the current state is displayed as PREOP again.
Current State | Indicates the current state of the EtherCAT device.
Requested State | Indicates the state requested for the EtherCAT device.
DLL Status
Indicates the DLL status (data link layer status) of the individual ports of the EtherCAT slave. The DLL status can have four different states:
Status | Description
No Carrier / Open | No carrier signal is available at the port, but the port is open.
No Carrier / Closed | No carrier signal is available at the port, and the port is closed.
Carrier / Open | A carrier signal is available at the port, and the port is open.
Carrier / Closed | A carrier signal is available at the port, but the port is closed.
File Access over EtherCAT
Download | With this button a file can be written to the EtherCAT device.
Upload | With this button a file can be read from the EtherCAT device.
"DC" tab (Distributed Clocks)
"DC" tab (Distributed Clocks)
Operation Mode
Options (optional):
▪
FreeRun
▪
SM-Synchron
▪
DC-Synchron (Input based)
▪
DC-Synchron
Advanced Settings…
Advanced settings for readjustment of the real time determinant TwinCAT-clock
Detailed information to Distributed Clocks are specified on http://infosys.beckhoff.com:
Fieldbus Components → EtherCAT Terminals → EtherCAT System documentation → EtherCAT basics → Distributed Clocks
Additional information
•
Detailed description of Process Data tab


Detailed description of Process Data tab

Commissioning [image] TwinCAT Development Environment [image] EtherCAT subscriber configuration [image] Detailed description of Process Data tab
Detailed description of Process Data tab
Sync Manager
Lists the configuration of the Sync Manager (SM).
If the EtherCAT device has a mailbox, SM0 is used for the mailbox output (MbxOut) and SM1 for the mailbox input (MbxIn).
SM2 is used for the output process data (outputs) and SM3 (inputs) for the input process data.
If an input is selected, the corresponding PDO assignment is displayed in the PDO Assignment list below.
PDO Assignment
PDO assignment of the selected Sync Manager. All PDOs defined for this Sync Manager type are listed here:
▪
If the output Sync Manager (outputs) is selected in the Sync Manager list, all RxPDOs are displayed.
▪
If the input Sync Manager (inputs) is selected in the Sync Manager list, all TxPDOs are displayed.
The selected entries are the PDOs involved in the process data transfer. In the tree diagram of the System Manager these PDOs are displayed as variables of the EtherCAT device. The name of the variable is identical to the Name parameter of the PDO, as displayed in the PDO list. If an entry in the PDO assignment list is deactivated (not selected and greyed out), this indicates that the input is excluded from the PDO assignment. In order to be able to select a greyed out PDO, the currently selected PDO has to be deselected first.
Activation of PDO assignment
✓
If you have changed the PDO assignment, in order to activate the new PDO assignment,
1.
the EtherCAT slave has to run through the PS status transition cycle (from pre-operational to safe-operational) once (see Online tab),
2.
and the System Manager has to reload the EtherCAT slaves
( [image] button for TwinCAT 2 or [image] button for TwinCAT 3)
PDO list
List of all PDOs supported by this EtherCAT device. The content of the selected PDOs is displayed in the PDO Content list. The PDO configuration can be modified by double-clicking on an entry.
Column | Description
Index | PDO index.
Size | Size of the PDO in bytes.
Name | Name of the PDO. If this PDO is assigned to a Sync Manager, it appears as a variable of the slave with this parameter as the name.
Flags | F | Fixed content: The content of this PDO is fixed and cannot be changed by the System Manager.
 | M | Mandatory PDO. This PDO is mandatory and must therefore be assigned to a Sync Manager! Consequently, this PDO cannot be deleted from the PDO Assignment list
SM | Sync Manager to which this PDO is assigned. If this entry is empty, this PDO does not take part in the process data traffic.
SU | Sync unit to which this PDO is assigned.
PDO Content
Indicates the content of the PDO. If flag F (fixed content) of the PDO is not set the content can be modified.
Download
If the device is intelligent and has a mailbox, the configuration of the PDO and the PDO assignments can be downloaded to the device. This is an optional feature that is not supported by all EtherCAT slaves.
PDO Assignment
If this check box is selected, the PDO assignment that is configured in the PDO Assignment list is downloaded to the device on startup. The required commands to be sent to the device can be viewed in the Startup tab.
PDO Configuration
If this check box is selected, the configuration of the respective PDOs (as shown in the PDO list and the PDO Content display) is downloaded to the EtherCAT slave.


General Notes - EtherCAT Slave Application

Commissioning [image] General Notes - EtherCAT Slave Application
General Notes - EtherCAT Slave Application
This summary briefly deals with a number of aspects of EtherCAT Slave operation under TwinCAT. More detailed information on this may be found in the corresponding sections of, for instance, the EtherCAT System Documentation.
Diagnosis in real time: WorkingCounter, EtherCAT State and Status
Generally speaking an EtherCAT Slave provides a variety of diagnostic information that can be used by the controlling task.
This diagnostic information relates to differing levels of communication. It therefore has a variety of sources, and is also updated at various times.
Any application that relies on I/O data from a fieldbus being correct and up to date must make diagnostic access to the corresponding underlying layers. EtherCAT and the TwinCAT System Manager offer comprehensive diagnostic elements of this kind. Those diagnostic elements that are helpful to the controlling task for diagnosis that is accurate for the current cycle when in operation (not during commissioning) are discussed below.
Selection of the diagnostic information of an EtherCAT Slave
In general, an EtherCAT Slave offers
▪
communication diagnosis typical for a slave (diagnosis of successful participation in the exchange of process data, and correct operating mode)
This diagnosis is the same for all slaves.

as well as
▪
function diagnosis typical for a channel (device-dependent)
See the corresponding device documentation
The colors in Fig. “Selection of the diagnostic information of an EtherCAT Slave” also correspond to the variable colors in the System Manager, see Fig. “Basic EtherCAT Slave Diagnosis in the PLC”.
Colour | Meaning
yellow | Input variables from the Slave to the EtherCAT Master, updated in every cycle
red | Output variables from the Slave to the EtherCAT Master, updated in every cycle
green | Information variables for the EtherCAT Master that are updated acyclically. This means that it is possible that in any particular cycle they do not represent the latest possible status. It is therefore useful to read such variables through ADS.
Fig. “Basic EtherCAT Slave Diagnosis in the PLC” shows an example of an implementation of basic EtherCAT Slave Diagnosis. A Beckhoff EL3102 (2-channel analogue input terminal) is used here, as it offers both the communication diagnosis typical of a slave and the functional diagnosis that is specific to a channel. Structures are created as input variables in the PLC, each corresponding to the process image.
Basic EtherCAT Slave Diagnosis in the PLC
The following aspects are covered here:
Code
Function
Implementation
Application/evaluation
A
The EtherCAT Master's diagnostic information
updated acyclically (yellow) or provided acyclically (green).
At least the DevState is to be evaluated for the most recent cycle in the PLC.
The EtherCAT Master's diagnostic information offers many more possibilities than are treated in the EtherCAT System Documentation. A few keywords:
▪
CoE in the Master for communication with/through the Slaves
▪
Functions from TcEtherCAT.lib
▪
Perform an OnlineScan
B
In the example chosen (EL3102) the EL3102 comprises two analogue input channels that transmit a single function status for the most recent cycle.
Status
▪
the bit significations may be found in the device documentation
▪
other devices may supply more information, or none that is typical of a slave
In order for the higher-level PLC task (or corresponding control applications) to be able to rely on correct data, the function status must be evaluated there. Such information is therefore provided with the process data for the most recent cycle.
C
For every EtherCAT Slave that has cyclic process data, the Master displays, using what is known as a WorkingCounter, whether the slave is participating successfully and without error in the cyclic exchange of process data. This important, elementary information is therefore provided for the most recent cycle in the System Manager
1.
at the EtherCAT Slave, and, with identical contents
2.
as a collective variable at the EtherCAT Master (see Point A)
for linking.
WcState (Working Counter)
0: valid real-time communication in the last cycle
1: invalid real-time communication
This may possibly have effects on the process data of other Slaves that are located in the same SyncUnit
In order for the higher-level PLC task (or corresponding control applications) to be able to rely on correct data, the communication status of the EtherCAT Slave must be evaluated there. Such information is therefore provided with the process data for the most recent cycle.
D
Diagnostic information of the EtherCAT Master which, while it is represented at the slave for linking, is actually determined by the Master for the Slave concerned and represented there. This information cannot be characterized as real-time, because it
▪
is only rarely/never changed, except when the system starts up
▪
is itself determined acyclically (e.g. EtherCAT Status)
State
current Status (INIT..OP) of the Slave. The Slave must be in OP (=8) when operating normally.
AdsAddr
The ADS address is useful for communicating from the PLC/task via ADS with the EtherCAT Slave, e.g. for reading/writing to the CoE. The AMS-NetID of a slave corresponds to the AMS-NetID of the EtherCAT Master; communication with the individual Slave is possible via the port (= EtherCAT address).
Information variables for the EtherCAT Master that are updated acyclically. This means that it is possible that in any particular cycle they do not represent the latest possible status. It is therefore possible to read such variables through ADS.
Note
Diagnostic information
It is strongly recommended that the diagnostic information made available is evaluated so that the application can react accordingly.
CoE Parameter Directory
The CoE parameter directory (CanOpen-over-EtherCAT) is used to manage the set values for the slave concerned. Changes may, in some circumstances, have to be made here when commissioning a relatively complex EtherCAT Slave. It can be accessed through the TwinCAT System Manager, see Fig. “EL3102, CoE directory”:
EL3102, CoE directory
EtherCAT System Documentation
The comprehensive description in the EtherCAT System Documentation (EtherCAT Basics --> CoE Interface) must be observed!
A few brief extracts:
▪
Whether changes in the online directory are saved locally in the slave depends on the device. EL terminals (except the EL66xx) are able to save in this way.
▪
The user must manage the changes to the StartUp list.
Commissioning aid in the TwinCAT System Manager
Commissioning interfaces are being introduced as part of an ongoing process for EL/EP EtherCAT devices. These are available in TwinCAT System Managers from TwinCAT 2.11R2 and above. They are integrated into the System Manager through appropriately extended ESI configuration files.
Example of commissioning aid for a EL3204
This commissioning process simultaneously manages
▪
CoE Parameter Directory
▪
DC/FreeRun mode
▪
the available process data records (PDO)
Although the "Process Data", "DC", "Startup" and "CoE-Online" that used to be necessary for this are still displayed, it is recommended that, if the commissioning aid is used, the automatically generated settings are not changed by it.
The commissioning tool does not cover every possible application of an EL/EP device. If the available setting options are not adequate, the user can make the DC, PDO and CoE settings manually, as in the past.
EtherCAT State: automatic default behaviour of the TwinCAT System Manager and manual operation
After the operating power is switched on, an EtherCAT Slave must go through the following statuses
▪
INIT
▪
PREOP
▪
SAFEOP
▪
OP
to ensure sound operation. The EtherCAT Master directs these statuses in accordance with the initialization routines that are defined for commissioning the device by the ES/XML and user settings (Distributed Clocks (DC), PDO, CoE). See also the section on "Principles of Communication, EtherCAT State Machine" in this connection. Depending how much configuration has to be done, and on the overall communication, booting can take up to a few seconds.
The EtherCAT Master itself must go through these routines when starting, until it has reached at least the OP target state.
The target state wanted by the user, and which is brought about automatically at start-up by TwinCAT, can be set in the System Manager. As soon as TwinCAT reaches the status RUN, the TwinCAT EtherCAT Master will approach the target states.
Standard setting
The advanced settings of the EtherCAT Master are set as standard:
▪
EtherCAT Master: OP
▪
Slaves: OP
This setting applies equally to all Slaves.
Default behaviour of the System Manager
In addition, the target state of any particular Slave can be set in the "Advanced Settings" dialogue; the standard setting is again OP.
Default target state in the Slave
Manual Control
There are particular reasons why it may be appropriate to control the states from the application/task/PLC. For instance:
▪
for diagnostic reasons
▪
to induce a controlled restart of axes
▪
because a change in the times involved in starting is desirable
In that case it is appropriate in the PLC application to use the PLC function blocks from the TcEtherCAT.lib, which is available as standard, and to work through the states in a controlled manner using, for instance, FB_EcSetMasterState.
It is then useful to put the settings in the EtherCAT Master to INIT for master and slave.
PLC function blocks
Note regarding E-Bus current
EL/ES terminals are placed on the DIN rail at a coupler on the terminal strand. A Bus Coupler can supply the EL terminals added to it with the E-bus system voltage of 5 V; a coupler is thereby loadable up to 2 A as a rule. Information on how much current each EL terminal requires from the E-bus supply is available online and in the catalogue. If the added terminals require more current than the coupler can supply, then power feed terminals (e.g. EL9410) must be inserted at appropriate places in the terminal strand.
The pre-calculated theoretical maximum E-Bus current is displayed in the TwinCAT System Manager as a column value. A shortfall is marked by a negative total amount and an exclamation mark; a power feed terminal is to be placed before such a position.
Illegally exceeding the E-Bus current
From TwinCAT 2.11 and above, a warning message "E-Bus Power of Terminal..." is output in the logger window when such a configuration is activated:
Warning message for exceeding E-Bus current
Note
Caution! Malfunction possible!
The same ground potential must be used for the E-Bus supply of all EtherCAT terminals in a terminal block!


Functionality of the AS-i master

Commissioning [image] Functionality of the AS-i master
Functionality of the AS-i master
The AS-i functionality is only mentioned briefly in this chapter. Further details can be found in the book AS-Interface by Kriesl/Madelung, published by Hanser (essentially Chapter 4.1). Further information can also be found on the website of the AS-Interface Association (http://www.as-interface.net).
Additional information
•
AS-i status machine
•
Lists
•
Operating modes
•
Operating phases
•
Address assignment of the AS-i slaves
•
Automatic address assignment


AS-i status machine

Commissioning [image] Functionality of the AS-i master [image] AS-i status machine
AS-i status machine
First, an overview of the status machine is provided. Details of the individual operating phases can be found below.
Status machine overview
Initialization
Offline phase: During initialization, there is no AS-i data traffic.
Start-up
Detection phase
During detection phase, the AS-i master initially looks for existing slaves - irrespective of whether they are currently projected or not. This phase is only exited once at least one slave has been found.
Activation phase
During this phase, the slaves that were found are activated depending on the operation mode:
▪
Protected mode: All detected and currently projected slaves are activated, if the I/O ID and ID code of the detected slaves match the currently projected data.
▪
Configuration mode: All detected slaves are activated by the master.
Normal operation
Data exchange phase
Cyclic data exchange between the AS-i master and the activated slaves.
Management phase
At the end of a cycle, the AS-i master enters the management phase, during which it can send a command to a specific slave (if required).
Inclusion phase
The AS-i master then enters the inclusion phase, during which it sends a command to a free slave address, in order to detect new slaves. If there is no response, the master immediately starts the next data exchange phase.


Lists

Commissioning [image] Functionality of the AS-i master [image] Lists
Lists
Lists of the AS-i slaves in configuration and protected mode
LDS - list of detected slaves
This lists all slaves that physically exist in the network, have a valid address and were detected by the master.
LPS - list of currently projected slaves
This list comprises all slaves that the master expects to find in the network. In protected mode, the master only communicates with these slaves and issues a message as soon as additional slaves are detected, or if slaves are missing from this list.
LAS - list of activated slaves
All slaves with which the master communicates. In protected mode, this list corresponds to the LPS, in configuration mode it corresponds to the LDS (LDS).


Operating modes

Commissioning [image] Functionality of the AS-i master [image] Operating modes
Operating modes
Protected mode
In protected mode, only the AS-i slaves that are entered in the LPS are activated. In addition, their configuration (I/O ID and ID codes) must correspond to the projected configuration from the objects
- 0x8pp0:20, 0x8pp0:25 (projected I/O IDs) or
- 0x8pp0:21, 0x8pp0:26 (projected ID codes)
- 0x8pp0:22, 0x8pp0:27 (projected Extended ID codes 1) and
- 0x8pp0:23, 0x8pp0:28 (projected Extended ID codes 2),
if checking of the I/O ID or ID codes is enabled in the indices 0x8pp0:20 (bit 7), 0x8pp0:25 (bit 7) or 0x8pp0:21 (bit 7), 0x8pp0:26 (bit 7) and 0x8pp0:22 (bit 7), 0x8pp0:27 (bit 7), as well as 0x8pp0:23 (bit 7) and 0x8pp0:28 (bit 7).
Automatic addressing is possible, if I/O ID and ID code verification is enabled for all AS-i slaves listed in the LPS, and if precisely one currently projected AS-i slave is missing.
Configuration mode
In configuration mode, all AS-i slaves that are found are activated. Automatic addressing is possible, with the next free address being assigned when a slave with address 0 is found. However, an AS-i address can be manually set via the index 0x2000 (AS-i command interface). All the AS-i slaves found can be projected by setting the set input. In this case, the
▪
corresponding I/O IDs and ID codes are also entered into the indices 0x8pp0:20, 0x8pp0:25 (projected I/O IDs) or 0x8pp0:21, 0x8pp0:26 and 0x8pp0:22, 0x8pp0:27, as well as 0x8pp0:230x8pp0:28 (projected ID codes) and
▪
the check is enabled in the indices 0x8pp0:20 (bit 7), 0x8pp0:25 (bit 7) or 0x8pp0:21 (bit 7), 0x8pp0:26 (bit 7) and 0x8pp0:22 (bit 7), 0x8pp0:27 (bit 7), as well as 0x8pp0:23 (bit 7), 0x8pp0:28 (bit 7) (ID codes).


Operating phases

Commissioning [image] Functionality of the AS-i master [image] Operating phases
Operating phases
Offline
After power-on, the AS-i master goes into offline mode, i.e. there is no communication with the AS-i slaves.
During normal operation, the AS-i master can be put into offline mode (OFFLINE-flag is set) via the process data. The output data of all activated AS-i slaves are set to default value 1bin, and the input data of all activated AS-i slaves are set to default value 0bin. The AS-i master is then in offline mode and will send no further AS-i commands.
Start-up
Detection phase
During the detection phase, the I/O ID and ID codes of all AS-i slaves are queried and entered in parameters
- 0x9pp0:20, 0x9pp0:25 (I/O IDs read) or
- 0x9pp0:21, 0x9pp0:26 (ID codes read),
- 0x9pp0:22, 0x9pp0:27 (Extended ID codes 1 read) and
- 0x9pp0:23, 0x9pp0:28 (Extended ID codes 2 read).
All AS-i slaves found are entered in the List of Detected AS-i Slaves (LDS), index 0xF101. The AS-i master will only enter the activation phase once at least one slave was detected or found.
Activation phase
In protected mode the AS-i master activates only the projected AS-i Slaves from the List of Projected Slaves (LPS, index 0xF103).
In configuration mode, all AS-i slaves that were found during the detection phase are activated. To this end the AS-i master sends a parameterization call (activation parameter, 0x8pp0:24, 0x8pp0:29) and a data call (with the default values 1bin as outputs). All activated slaves are entered in the List of Activated Slaves (LAS, index F102). Once all AS-i slaves have been processed, the AS-i master automatically enters the data exchange phase.
Normal operation
Data exchange phase
During the data exchange phase, the AS-i master exchanges data with each activated AS-i slave. If an AS-i slave does not respond in three consecutive data exchange phases, it is removed from the LAS and the LDS, and its inputs are set to the default value 0bin. Once a data cycle has been completed with all activated AS-i slaves, the AS-i master enters the management phase.
Management phase
During the management phase, an AS-i command is sent if an operating address is to be set via automatic address programming, or if an AS-i command was requested via the AS-i command interface (index 0x2000 ). Otherwise the AS-i master enters the inclusion phase without issuing an AS-i command.
Inclusion phase
During the inclusion phase, only one command is sent. The system will attempt to find and activate new AS-i slaves, and the respective status is updated accordingly. The steps are the same as during the recognition or activation phase, except that they are now distributed over up to seven cycles.


Address assignment of the AS-i slaves

Commissioning [image] Functionality of the AS-i master [image] Address assignment of the AS-i slaves
Address assignment of the AS-i slaves
Address assignment can be done via the AS-i master or via an addressing device. AS-i slaves are usually supplied with address 0. Slaves that were added later are searched under this address, and an address is then assigned. Address 0 is not permitted during the data exchange phase.
The extended addressing is supported from AS-i specification 2.1, so that corresponding slaves can also be given the addresses 1B to 31B. 0B is not permitted.
Normal address assignment
New AS-i slaves usually have address 0. An addressing call command can be initiated via the parameter 0x2000 (AS-i command interface). However, the addressing call command only works if precisely one AS-i slave with address 0 is connected to the bus. A further addressing possibility is shown in the Quickstart section


Automatic address assignment

Commissioning [image] Functionality of the AS-i master [image] Automatic address assignment
Automatic address assignment
Automatic address assignment
Automatic address assignment must be enabled in index 0xF100:03.
Configuration mode
In configuration mode, the next free address is automatically assigned if a slave with address 0 is found.
Protected Mode
In protected mode, an AS-i slave with address 0 is automatically programmed with its new address, if precisely one currently projected AS-i slave is missing, and if no other not currently projected AS-i slave is present at the bus. This enables a (no longer functioning) AS-i slave to be exchanged during operation.


Quickstart

Commissioning [image] Quickstart
Quickstart
No special measures are required for the initial commissioning of the EL6201.
Knowledge of the introductory Technology section is required.
The following examples initially illustrate manual addressing and integration of a digital AS-i slave in the TwinCAT system.
For automatic addressing the EL6201 is commissioned with two digital and one analog AS-i slave, for example.
The EL6201 is commissioned with the following configuration:
▪
Operating system Windows 7 Professional SP1
▪
TwinCAT 2.11 R3 Build 2256, AS-i System Manager Extension installed
▪
Terminal network EK1100, EL1202, EL6201 and EL9010
▪
AS-i standard power supply unit 30.5 V
▪
AS-i slave 2 button / 2 LED
▪
AS-i slave 4 digital inputs
▪
AS-i slave 4 digital outputs
AS-i System Manager extension for 32-bit and 64-bit Windows systems
The AS-i System Manager extension has been tested and runs under 32-bit and 64-bit Windows 7 Professional SP1.
1. Mounting and connection
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminal system and the AS-i power supply unit into a safe, de-energized state before starting installation, disassembly or wiring of the Bus Terminals!
▪
Mount the EL6201 in the terminal network as described in the section Mounting and wiring.
Cable lengths
When using the EL9520 (potential distribution terminal with filter, AS-i power 24), the maximum expansion of the network topology may not exceed 50 m!
When determining the total length, all branches should be included (Fig. Wiring diagram for connecting the AS-i power supply unit and AS-i slaves with the EL6201).
If an AS-i standard power supply unit is used, the maximum topology expansion is 100 m.
Maximum topology extent with standard AS-i power supply and AS-i Power24 supply
▪
Connect the AS-i slave and the standard 24 V power supply unit to the EL6201 according to the following wiring diagram (Fig. Wiring diagram for connecting the AS-i power supply unit and AS-i slaves with the EL6201). Correct connection of the slave as described in the Technology section is required.
▪
Alternatively the AS-i slaves can be supplied with power via the EL9520 AS-i potential supply terminal as described in the Connection section.
Wiring diagram AS-i slave / EL6201
▪
Switch the Bus Terminal system power supply and the AS-i power supply unit on.
2. Configuration
Creating a TwinCAT configuration
New features from firmware 02 and TwinCAT plug-in, version 2.1
Firmware 02:
• Support of M4 master profile for slaves of types 2, 3, 5 (S-7.5.5, S-7.A.5, S-B.A.5; S7.A.7, S-7.A.A; S-6.0) (can be activated via flag in AS-i Control)
• Support of Power24 (can be activated via flag in AS-i Control)
• ExtendedID code can be modified

TwinCAT plug-in, version 2.1:
• Advanced view for new slave types
• New design for more intuitive application
• Simplified project planning, standard and advanced mode
• Optimization for lower resolutions and high DPI settings for optimum operation in suboptimum working environments
Download the latest EtherCAT XML Device Description and the AS-i System Manager Extension
Make sure that you download the latest XML file from the download section on the Beckhoff website and install it in accordance with the installation instructions.
The addressing of the AS-i slaves described below requires the installation of the AS-i System Manager Extension, which you should likewise download and install.
▪
Create a configuration in the TwinCAT System Manager by manually inserting the terminal or scanning it online. Refer to installation chapter TwinCAT 2.x regarding this.
▪
The TwinCAT tree now looks like this:
Configuration tree in the TwinCAT System Manager
Manual addressing of the AS-i slave
AS-i address
The address of a brand new AS-i slave is always "0".
The addressing of a brand new AS-i slave can be done using the TwinCAT System Manager. The installation of the AS-i System Manager Extension is required for this.
▪
Click on the EL6201 in the TwinCAT tree (A) and the “Settings” tab (B). Then click on "AS-i System Overview" (C) to navigate to the AS-i overview below, which shows the AS-i slaves to be addressed.
▪
The "AS-i Config Mode" (D) field in the status bar is shown in blue. If a green field “ASI Protected Mode” is displayed here, click on the field to access the “ASI Config Mode”
Status Bar
The status bar in the system overview indicates the system state. Underlined settings can be changed (switch between config mode/protected mode, activation/deactivation of data exchange).
▪
The slave “0” (E) marked with the yellow dot is the connected slave that has already been detected and which is to be given a valid address
AS-i system overview with the slaves to be addressed
▪
In order to convert the slave address "0" into a valid address, right-click on the yellow dot in the address field "0" so that you can then select an AS-i address via the "Change Address" selection field; for instance the address "1A" in the example.
Address assignment for the AS-i slave
▪
The address is now shown as "Detected and activated" (blue).
Address assignment for the AS-i slave accepted
▪
In order to conclude the projecting for the slave, click on the blue field "ASI Config Mode" (B); the system switches to "ASI Protected Mode" (green field).
▪
In order to enable the AS-i data exchange, click on the grey field "ASI Data Exc INACTIVE"; the field changes to green "ASI Data Exc ACTIVE" (C).
▪
The completed configuration is indicated by the green field “ASI Config OK”.
Switching to "Protected mode" and completion of project planning
Automatic addressing of the AS-i slaves
AS-i-address for automatic addressing
For automatic allocation of AS-i addresses in the EL6201, the connected AS-i slaves must have the address "0" (not addressed).
Successive automatic allocation of addresses is not possible, if a slave is already addressed/projected.
Automatic addressing is also done via the AS-i System Manager extension.
▪
The AS-i slaves referred to above are not yet connected to the AS-i fieldbus line and have the address "0" or come straight from the factory.
▪
Click on the EL6201 in the TwinCAT tree and the "Settings" tab (A). Then click on "AS-i master EL6201" (B) to open the screen shown below.
▪
Ensure that the terminal is in "ASI Config Mode" (blue). If necessary, change the mode by clicking (C).
▪
Set "Auto Programming Mode" in the field "Control PDO" (D).
Activating "Auto Programming Mode"
▪
Now click on "AS-i system Overview" (A), as shown in Fig. Switching to "Protected mode" and completion of project planning. As you can see in the image below, no slave is detected/projected (B).
No slave detected in the AS-i System Overview
▪
Now connect the first slave with the AS-i fieldbus line. The slave is automatically addressed with "1A", as shown below (Fig. The first slave connected is allocated address "1A"). The address is now permanently implemented in the slave.
▪
Now connect further slaves with the AS-i fieldbus line. The slaves are allocated addresses "2A" and "3A", as shown below.
The first slave connected is allocated address "1A"
The second slave connected is allocated address "2A"
Problems during project planning through AS-i "Periphery Fault"
During project planning of a new AS-i slave, an AS-i "Periphery Fault" may put automatic project planning into an undefined state, as indicated by flashing in the project planning overview; see Fig. Undefined state of a slave to be projected.

Remedy:
Click on the grey button "AS-i Data Exc INACTIVE", which switches to green "AS-i Data Exc ACTIVE" (see Fig.). The slaves should then show a stable state "Detected and activated" (blue).
Undefined state of the slave to be projected
Remedy: Activating AS-i data exchange
The third connected slave is allocated address "3A"; switching to "AS-i Protected Mode"; confirming the configuration
▪
Now click on the blue "AS-i Config mode" button to complete the project planning (Fig. The third contacted slave is allocated the address "3A"; switching to "AS-i Protected mode"; confirming the configuration). The green "ASI Protected Mode" button appears (A). Confirm correct project planning with "ASI Config OK" (B).
Failure of a slave in the AS-i configuration
Automatic addressing if a slave is replaced
A faulty slave can be replaced with a brand-new slave or with a slave addressed with "0".
If automatic addressing is used, the new slave will automatically be allocated the address of the replaced slave.
In the event of a fault (interruption of the connection between the slave and the AS-i fieldbus), the affected slave is shown as "Projected, but not detected" (A) - see Fig. Failure of slave "2A". The green "AS-i Config OK" light goes out and switches to a red "AS-i Config NOT OK" (B)
Remedy: Check the connection between the slave and the AS-i fieldbus line. A screw-connection of the slave used in this example may be inadequate, so that the required penetration depth to the fieldbus cable is not achieved.
Failure of slave "2A", marked red
Changes in the AS-i slave overview
The choices available for "ASI System Overview" display are shown in the screens below:
All slaves are shown without configuration details. Detected, projected and active slaves are marked green
Detected and projected slaves shown without details
In order to only show the slaves, which are currently projected and active, right-click in the grey area below the slaves (or select the menu via the button "View") and select "Hide non-existing slaves in overview" in the context menu (Fig. Displaying the detected and currently projected slaves without details)
Detected and projected slaves shown with details
In order to show the details of the slaves, which are currently projected and active, right-click in the grey area below the slaves (or select the menu via the button "View") and select "Show slave details" in the context menu (Fig. Detected and projected slaves shown with details)
Profiles of detected and projected slaves shown with details
Process data of detected and projected slaves shown with details
You can now choose between "Show Slave Info Data" and "Show Process Data" (see Fig. above)
3. Setting the parameters and process data
CoE parameters
If the default CoE parameters are to be changed, they must be saved for each channel in the CoE.
Parameterization via the CoE list (CAN over EtherCAT)
The terminal is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs).
Please note the following general CoE information when using/manipulating the CoE parameters:
- Keep a startup list if components have to be replaced
- Differentiation between online/offline dictionary, existence of current XML description
- use “CoE reload” for resetting changes
The CoE settings can also be loaded via the SPS/PLC/Task at runtime.
4. Operation
If voltage/current is present, the process data will now be exchanged, e.g. in the TwinCAT FreeRun mode, following a TwinCAT restart.


Further notes on commissioning

Commissioning [image] Further notes on commissioning
Further notes on commissioning
System overview
Properties window with further information
Double-click on a slave in the system overview to open a Properties window (see Fig.), where slave settings can be implemented or diagnostic data viewed.
The slave properties show the slave profile and the diagnostic data. Depending on the slave profile, further options are available, such as AS-i string parameters or string parameters for serial slaves. In addition, parameters can be set and the project planning implemented (manual project planning only in Advanced mode).
Left part of the Settings tab
In the left part of the plugins (see Fig.) you can switch between system overview and AS-i master settings or call the Options menu. The AS-i lists provide readily readable information on detected, activated and projected slaves, as well as peripheral errors.
AS-i master view
The AS-i master view shows the configurable system status values. It also shows the firmware version and the extension (plug-in) version, which must be quoted with any support requests.
Project planning
The project planning options via the plug-in differ depending on the selected view; the Advanced view differs from the Standard view as follows:
▪
Standard view
Automatic project planning can be selected (see Fig. Option menu "Project all detected slaves"). The plug-in configures all connected (detected) slaves according to their profile. Once the system has been projected it is ready and operates in protected mode (automatic start in protected mode).
Option menu "Project all detected slaves"
▪
Extended view
In addition, manual project planning options are available. For each slave the required profile can be specified manually via the Properties window
Manual programming
The data can be stored in the startup data or directly in the terminal (CoE) (see Fig.).
Storing the startup data
Automatic project planning is recommended
Notes on the "Auto Programming" function
If the function "Auto Programming" is used in Config mode, each new slave with address 0 is automatically assigned the next free address. Note that slaves with the profile S-6.0 can require several addresses.
Special features of M4 slaves (CTT2, CTT3, CTT5)
▪
Slave type 3
Slaves of type CTT2 (S-7.5.5, S-7.A.5, S-B.A.5) have a further "Objects" tab in the Properties window (see Fig.), which can be used for acyclic communication with the slave via AS-i string command.
M4 slave, "Objects" tab
▪
Slave type 3
Slaves of type CTT3 (S-7.A.7, S-7.A.A, S-7.A.8) can be used in the A or B section (Extended Address mode). The digital I/O data are stored in the analog process image (inputs: 0x6XXX range, outputs: 0x7XXX range) and shown accordingly in the system overview.
▪
Slave type 5
Slaves of type CTT5 (S-6.0) achieve a higher velocity thanks to the use of several slave addresses. Depending on the slave, the number of slave addresses used can be set via the extended ID code. To change the extended ID code the slave address must be 0, see the figure below.
Slave type 5, changing the extended ID code
The process data are stored in the analog slave process data.
Automatic addressing with slaves type 5
If auto-addressing is enabled in config mode, slaves with address 0 are automatically assigned the next free address. Since slaves of type CTT5 require further slave addresses, depending on the start address, there may be overlaps if there are not enough free addresses.
CoE extensions
- Access to M4 profiles
▪
Slaves from CTT2 profile (S-7.5.5, S-7.A.5, S-7.B.A)
- Cyclic communication via analog data object per slave (AODI/AIDI) – address range in CoE 0x6000/0x7000
- Acyclic communication via "AS-i string command" (0x2010-object).
Command structure:
Byte | Content
0 | Increment for new command
1 | 0x02 (Write Parameter string)
2 | Slave address*
3 | Command-Length**
4 - 7 | Reserved
8.. | Command
Example: 01 02 03* 03** 00 00 00 00 10 00 DB
▪
Slaves from CTT3 profile (S-7.A.7, S-7.A.A), slaves from CTT4 profile (S-7.A.8, S-7.A.9) and slaves from CTT5 profile (S-6.0)
- Data from 4I/4O slaves (S-7.A.7) are transferred directly to the digital input and output data
- Data from 8/8O slaves are transferred to the analog data objects (value channel)
- Changing the extended ID code
▪
The extended ID code of a slave can be changed, if the slave has the address 0 (and supports this).
▪
The change is implemented via the object "AS-i command" (0x2000)
Command:
Byte | Content
0 | Increment for new command
1 | 0xC (change ID Code)
2 | New ID Code
Also see about this
•
Technology


Object description and parameterization

Commissioning [image] Object description and parameterization
Object description and parameterization
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Parameterization via the CoE list (CAN over EtherCAT)
The EtherCAT device is parameterized via the CoE-Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs). Please note the following general CoE notes when using/manipulating the CoE parameters:
•
Keep a startup list if components have to be replaced
•
Differentiation between online/offline dictionary, existence of current XML description
•
use “CoE reload” for resetting changes
Additional information
•
Restore object
•
Configuration data
•
Command object
•
Input data
•
Output data
•
Information data
•
Diagnostic data
•
ASI data


Restore object

Commissioning [image] Object description and parameterization [image] Restore object
Restore object
Index 1011 Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default parameters | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" in the set value dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)


Configuration data

Commissioning [image] Object description and parameterization [image] Configuration data
Configuration data
Index 8pp0 AS-i settings slave (for 01 ≤ pp ≤ 1F; slave 1 to slave 31)
Index (hex) | Name | Meaning | Data type | Flags | Default
8pp0:0 | ASI Settings Slave | Max. subindex | UINT8 | RO | > 41 <
8pp0:01 | ASI Address | Slave address (see table below) | UINT16 | RW | 0x0000 (0dec)
Bit | Value | Description
0 - 4 | 0 - 31 (default 0) | Slave address (0=>entry inactive, XX=>entry active) (Slave address arises from bit 4 to bit 8 of the index (0x8pp0)
5 - 11 | - | reserved
12 | 0bin | A-slave or standard slave not projected
 | 1bin | A-slave or standard slave projected
13 | 0bin | B-slave not projected
 | 1bin | B-slave projected
14 - 15 | - | reserved
Index 8pp0 ASI Settings Slave (for 01 ≤ pp ≤ 1F; slave 1 to slave 31)
Index (hex) | Name | Meaning | Data type | Flags | Default
8pp0:20 | IO Configuration (A-slave) | Projected I/O ID (set configuration) In protected mode, the I/O ID of the projected AS-i slaves is checked. The projected 4-bit I/O ID of the AS-i slaves is located in the object 0x8pp0:20 (these objects are read-write and are saved in the Flash of the AS-i master (i.e. they are still present after power off/on)): (see following table) | UINT8 | RW | 0x00 (0dec)
Bit | Value | Description
0 - 3 | 0 - 15 (default 0) | IO Config (A-slave or standard slave)
4 - 6 | - | reserved
7 | 0 | Value is taken into account when comparing set/actual configuration in protected mode
 | 1 | Value is ignored when comparing set/actual configuration in protected mode
Index 8pp0 ASI Settings Slave (for 01 ≤ pp ≤ 1F; slave 1 to slave 31)
Index (hex) | Name | Meaning | Data type | Flags | Default
8pp0:21 | ID code (A-slave) | Projected ID code (nominal configuration) In protected mode, the ID code of the projected AS-i slaves is checked. The projected 4-bit ID codes of the AS-i slaves are located in the object 0x8pp0:21 (these objects are read-write and are saved in the Flash of the AS-i master (i.e. they are still present after power off/on)): (see following table) | UINT8 | RW | 0x00 (0dec)
Bit | Value | Description
0 - 3 | 0 - 15 (default 0) | IO code (A-slave or standard slave)
4 - 6 | - | reserved
7 | 0 | Value is taken into account when comparing set/actual configuration in protected mode
 | 1 | Value is ignored when comparing set/actual configuration in protected mode
Index 8pp0 ASI Settings Slave (for 01 ≤ pp ≤ 1F; slave 1 to slave 31)
Index (hex) | Name | Meaning | Data type | Flags | Default
8pp0:22 | Extended ID code 1 (A-slave) | Projected extended ID code 1 (nominal configuration) In protected mode, the extended ID code 1 of the currently projected AS-i slaves is checked. The projected 4-bit Extended ID codes 1 of the AS-i slaves are located in the object 0x8pp0:22 (these objects are read-write and are saved in the Flash of the AS-i master (i.e. they are still present after power off/on)): (see following table) | UINT8 | RW | 0x00 (0dec)
Bit | Value | Description
0 - 3 | 0 - 15 (default 0) | Extended ID code 1 (A-slave or standard slave)
4 - 6 | - | reserved
7 | 0 | Value is taken into account when comparing set/actual configuration in protected mode
 | 1 | Value is ignored when comparing set/actual configuration in protected mode
Index 8pp0 ASI Settings Slave (for 01 ≤ pp ≤ 1F; slave 1 to slave 31)
Index (hex) | Name | Meaning | Data type | Flags | Default
8pp0:23 | Extended ID code 2 (A-slave) | Projected extended ID code 2 (nominal configuration) In protected mode, the extended ID code 2 of the currently projected AS-i slaves is checked. The projected 4-bit Extended ID codes 1 of the AS-i slaves are located in the object 0x8pp0:23 (these objects are read-write and are saved in the Flash of the AS-i master (i.e. they are still present after power off/on)): (see following table) | UINT8 | RW | 0x00 (0dec)
Bit | Value | Description
0 - 3 | 0 - 15 (default 0) | Extended ID code 2 (A-slave or standard slave)
4 - 6 | - | reserved
7 | 0 | Value is taken into account when comparing set/actual configuration in protected mode
 | 1 | Value is ignored when comparing set/actual configuration in protected mode
Index 8pp0 ASI Settings Slave (for 01 ≤ pp ≤ 1F; slave 1 to slave 31)
Index (hex) | Name | Meaning | Data type | Flags | Default
8pp0:24 | Parameter (A-slave) | Activation parameters for the AS-i slaves During the activation phase (or during the inclusion phase - for AS-i slaves that are added later), 4-bit parameter data are sent once to each AS-i slave prior to the first data exchange. These activation parameters can be specified for each AS-i slave via the objects 0x8pp0:24. The objects 0x8pp0:24 can be read and written and are saved in the Flash of the AS-i master, i.e. they are still present after power off/on of the AS-i master. (see following table) | UINT8 | RW | 0x0F (15dec)
Bit | Value | Description
0 - 3 | 0 - 15 (default 15) | Parameter (A-slave or standard slave)
4 - 7 | - | reserved
Index 8pp0 ASI Settings Slave (for 01 ≤ pp ≤ 1F; slave 1 to slave 31)
Index (hex) | Name | Meaning | Data type | Flags | Default
8pp0:25 | IO Configuration (B-slave) | Projected I/O ID (set configuration) In protected mode, the I/O ID of the projected AS-i slaves is checked. The projected 4-bit I/O ID of the AS-i slaves is located in the object 0x8pp0:20 (these objects are read-write and are saved in the Flash of the AS-i master (i.e. they are still present after power off/on)): (see following table) | UINT8 | RW | 0x00 (0dec)
Bit | Value | Description
0 - 3 | 0 - 15 (default 0) | IO Config (B-slave)
4 - 6 | - | reserved
7 | 0 | Value is taken into account when comparing set/actual configuration in protected mode
 | 1 | Value is ignored when comparing set/actual configuration in protected mode
Index 8pp0 ASI Settings Slave (for 01 ≤ pp ≤ 1F; slave 1 to slave 31)
Index (hex) | Name | Meaning | Data type | Flags | Default
8pp0:26 | ID code (B-slave) | Projected ID code (nominal configuration) In protected mode, the ID code of the projected AS-i slaves is checked. The projected 4-bit ID codes of the AS-i slaves are located in the object 0x8pp0:21 (these objects are read-write and are saved in the Flash of the AS-i master (i.e. they are still present after power off/on)): (see following table) | UINT8 | RW | 0x00 (0dec)
Bit | Value | Description
0 - 3 | 0 - 15 (default 0) | ID code (B-slave)
4 - 6 | - | reserved
7 | 0 | Value is taken into account when comparing set/actual configuration in protected mode
 | 1 | Value is ignored when comparing set/actual configuration in protected mode
Index 8pp0 ASI Settings Slave (for 01 ≤ pp ≤ 1F; slave 1 to slave 31)
Index (hex) | Name | Meaning | Data type | Flags | Default
8pp0:27 | Extended ID Code 1 (B-slave) | Projected extended ID code 1 (nominal configuration) In protected mode, the extended ID code 1 of the currently projected AS-i slaves is checked. The projected 4-bit Extended ID codes 1 of the AS-i slaves are located in the object 0x8pp0:22 (these objects are read-write and are saved in the Flash of the AS-i master (i.e. they are still present after power off/on)): (see following table) | UINT8 | RW | 0x00 (0dec)
Bit | Value | Description
0 - 3 | 0 - 15 (default 0) | Extended ID Code 1 (B-slave)
4 - 6 | - | reserved
7 | 0 | Value is taken into account when comparing set/actual configuration in protected mode
 | 1 | Value is ignored when comparing set/actual configuration in protected mode
Index 8pp0 ASI Settings Slave (for 01 ≤ pp ≤ 1F; slave 1 to slave 31)
Index (hex) | Name | Meaning | Data type | Flags | Default
8pp0:28 | Extended ID Code 2 (B-slave) | Projected extended ID code 2 (nominal configuration) In protected mode, the extended ID code 2 of the currently projected AS-i slaves is checked. The projected 4-bit Extended ID codes 1 of the AS-i slaves are located in the object 0x8pp0:23 (these objects are read-write and are saved in the Flash of the AS-i master (i.e. they are still present after power off/on)): (see following table) | UINT8 | RW | 0x00 (0dec)
Bit | Value | Description
0 - 3 | 0 - 15 (default 0) | Extended ID Code 2 (B-slave)
4 - 6 | - | reserved
7 | 0 | Value is taken into account when comparing set/actual configuration in protected mode
 | 1 | Value is ignored when comparing set/actual configuration in protected mode
Index 8pp0 ASI Settings Slave (for 01 ≤ pp ≤ 1F; slave 1 to slave 31)
Index (hex) | Name | Meaning | Data type | Flags | Default
8pp0:29 | Parameter (B-slave) | Activation parameters for the AS-i slaves During the activation phase (or during the inclusion phase - for AS-i slaves that are added later), 4-bit parameter data are sent once to each AS-i slave prior to the first data exchange. These activation parameters can be specified for each AS-i slave via the objects 0x8pp0:24. The objects 0x8pp0:24 can be read and written and are saved in the Flash of the AS-i master, i.e. they are still present after power off/on of the AS-i master. (see following table) | UINT8 | RW | 0x07 (7dec)
Bit | Value | Description
0 - 2 | 0 - 7 (default 7) | Parameter (B-slave)
3 - 7 | - | reserved


Command object

Commissioning [image] Object description and parameterization [image] Command object
Command object
Index 2000 ASI Command
You can send commands to AS-i slaves with index 2000. This is possible both during the offline phase (no other commands on the AS-i bus) and during the management phase. In the management phase, however, you can address only AS-i slaves that are not activated.
Index (hex) | Name | Meaning | Data type | Flags | Default
2000:0 | ASI Command | Max. subindex | UINT8 | RO | 0x03 (3dec)
2000:01 | Request | Slave address (see table below) | OCTET-STRING[4] | RW | {0}
Bit | Value | Description
0 - 4 | 0 - 255 | Command sequence number (should be incremented so that the command is sent)
8 - 15 | 1 | reserved
 | 2 | reserved
 | 3 | reserved
 | 4 | AS-i command write parameter
 | 5 | reserved
 | 6 | reserved
 | 7 | AS-i command addressing call If an address unequal 0 is specified in bits 16 to 23, the AS-i command "Delete operating address" is called first, since the address can only be set if it was previously set to 0.
 | 8 | reserved
 | 12 | AS-i command change extended ID code (slave must have address 0)
16 - 23 | 0 - 63 | Address of the AS-i slave to which the command is to be sent (32 is not permitted)
24 - 31 | 0 - 31 | AS-i command data: • for AS-i command Write parameter: Parameter data • for AS-i command Addressing call: new address • new ID code with AS-i command change extended ID code
Index 2000 ASI Command
Index (hex) | Name | Meaning | Data type | Flags | Default
2000:02 | Status | (see following table) | UINT8 | RO | 0x00 (0dec)
Bit | Value | Description
0 - 7 | 0 | ASI_COMMAND_READY (command object ready for operation, index 0x2000:01)
 | 1 | ASI_COMMAND_BUSY (command object not ready for operation, index 0x2000:01)
 | 2 - 255 | reserved
Index 2000 ASI Command
Index (hex) | Name | Meaning | Data type | Flags | Default
2000:03 | Response | (see following table) For acknowledgement of AS-i command (AS-i command value bit 4 set): write parameter Bits 31 to 24 return the data handed over in the call of the AS-i command (bits 31 to 24 of the AS-i command). For acknowledgement of AS-i command (AS-i command value bit 7 set): addressing call If the error bit (bit 15) is not set, bits 31 to 24 contain the value 00hex. If the error bit (bit 15) is set, bits 31 to 24 contain an error code. (see following table) | OCTET-STRING[4] | RW | {0}
Bit | Description
0 - 7 | Command sequence number from the request
8 - 14 | Corresponding to bits 8 to 15 of the command call.
15 | Error bit: If bit 15 is set, this means that an error occurred during the execution of the command and an error code is output in bits 31 to 24!
16 - 23 | Address of the AS-i slave to which the command was sent.
Bit | Value | Description
24 - 31 | 0x00 | Address modification was successful.
 | 0x11 | No slave exists with an address that was specified as the old address.
 | 0x22 | Address 0 is currently assigned to another slave. In order to change the address of an AS-i slave, the EL6201 must first assign the address 0 to the slave in order to address it again afterwards from there.
 | 0x36 | A slave with the address that was specified as the new address already exists.
 | 0x47 | After deleting the old address, no slave with address 0 exists.
 | 0x58 | After deleting the old address, an error is generated during reading of the extended ID code 1 of slave 0. Address changes for A/B slaves also require the extended ID code 1.
 | 0x69 | After writing of extended ID code 1, no slave with address 0 exists.
 | 0x6B | After writing of the new address, the slave with the new address is not available during reading of the ID code.
 | 0x6C | After writing of the new address, the slave with the new address is not available during reading of the status.
 | 0x7D | The address could not be saved permanently (non-volatile).
 | 0x7E | The extended ID code of an A/B slave could not be saved permanently (non-volatile).
 | 0x7F | ID code 1 is invalid for A/B slaves
 | 0x83 | The new address is a B address. If slaves are to be operated on two parallel addresses in address areas A and B, e.g. 10A (10) and 10B (42), both slaves have to support B addressing. In this case, the parallel A address contains a slave that does not support B addressing!
 | 0x84 | The new address is a B address. The slave selected with the old address is, however, not an A/B-slave, i.e. it does not support the B-addresses (1B to 31B).
 | 0x85 | The new address is an A address. Slave is not an A/B slave: the associated B slave for the new address exists.
Index 2010 AS-i string command
Object 0x2010 can be used to send string commands to the AS-i slaves (analog slaves with profile 7.4 and CTT2 slaves with M4 profile). This is only possible if the AS-i master is already in the data exchange phase and the "Data Exchange Active" bit in AS-i control is set.
Index (hex) | Name | Bit | Value | Meaning | Data type | Flags | Default
2010:0 | ASI Command | - | - | Max. subindex | UINT8 | RO | 0x03 (3dec)
2010:01 | Request | 0 - 7 | 0 - 255 | Command sequence number (should be incremented so that the command is sent) | OCTET-STRING[256] | RW | {0}
 |  | 8 - 15 | 0, 1, 3 - 9 | reserved
 |  |  | 2 (0x2) | Write CTT2 Parameter String
 |  |  | 10 (0xA) | Write Parameter String
 |  |  | 11 (0xB) | Read Parameter String
 |  |  | 12 (0xC) | Read Diagnosis String
 |  |  | 13 (0xD) | Read ID String
 |  |  | 14 - 255 | reserved
 |  | 16 - 23 | 0 - 31 | Address of the AS-i slave to which the command is to be sent
 |  | 24 - 31 | 0 - 31 | Command length (number of subsequent command bytes/string data) – only CTT2
 |  | 32 - 63 | - | reserved
 |  | 64 - 2047 | xxxx | String data
2010:02 | Status | 0 - 7 | Bit 0 = 0 | ASI_STRING_COMMAND_READY (command object ready for operation, index 0x2010:01) | UINT8 | RO | 0x00 (0dec)
 |  |  | Bit 0 = 1 | ASI_STRING_COMMAND_BUSY (command object not ready for operation, index 0x2010:01)
 |  |  | Bit 1 - 5 | Reserved
 |  |  | Bit 6 | Data exchange not active
 |  |  | Bit 7 | PWR fail
2010:03 | Response | 0 - 7 | Command sequence number from the request |  | OCTET-STRING[256] | RO | {0}
 |  | 8 - 14 | Corresponding to bits 8 to 15 of the command call.
 |  | 15 | Error bit: If bit 15 is set, this means that an error occurred during the execution of the command and an error code is output in bits 31 to 24!
 |  | 16 - 23 | Address of the AS-i slave to which the command was sent.
 |  | 24 - 31 | If the error bit (bit 15) is set, bits 31 to 24 contain an error code.
 |  |  | 0x00 | Command was successfully executed.
 |  |  | 0x10 | Slave is not an analog slave
 |  |  | 0x20 | Slave does not support slave profile 7.4
 |  |  | 0x40 | String transfer is already active
 |  |  | 0x80 | Data exchange is not active
 |  |  | 0x08 | Command is not supported
 |  | 32 - 63 | - | reserved
 |  | 64 - 2047 | xxxx | String data


Input data

Commissioning [image] Object description and parameterization [image] Input data
Input data
Index 6pp0 ASI Analog Inputs Slave (for 01 ≤ pp ≤ 1F; slave 1 to slave 31)
Index (hex) | Name | Meaning | Data type | Flags | Default
6pp0:0 | ASI Analog Inputs Slave | Max. subindex | UINT8 | RO | 0x08 (8dec)
6pp0:01 | State Ch.1 (A-Slave) | Status channel 1 (A-slave) | UINT16 | RO | 0x0000 (0dec)
6pp0:02 | Value Ch.1 (A-Slave) | Input data channel 1 (A-slave) | UINT16 | RO | 0x0000 (0dec)
6pp0:03 | State Ch.2 (A-Slave) | Status channel 2 (A-slave) | UINT16 | RO | 0x0000 (0dec)
6pp0:04 | Value Ch.2 (A-Slave) | Input data channel 2 (A-slave) | UINT16 | RO | 0x0000 (0dec)
6pp0:05 | State Ch.3 (A-Slave) | Status channel 3 (A-slave) | UINT16 | RO | 0x0000 (0dec)
6pp0:06 | Value Ch.3 (A-Slave) | Input data channel 3 (A-slave) | UINT16 | RO | 0x0000 (0dec)
6pp0:07 | State Ch.4 (A-Slave) | Status channel 4 (A-slave) | UINT16 | RO | 0x0000 (0dec)
6pp0:08 | Value Ch.4 (A-Slave) | Input data channel 4 (A-slave) | UINT16 | RO | 0x0000 (0dec)


Output data

Commissioning [image] Object description and parameterization [image] Output data
Output data
Index 7pp0 ASI Analog Outputs Slave (for 01 ≤ pp ≤ 1F; slave 1 to slave 31)
Index (hex) | Name | Meaning | Data type | Flags | Default
7pp0:0 | ASI Analog Outputs Slave | Max. subindex | UINT8 | RO | 0x08 (8dec)
7pp0:01 | State Ch.1 (A-Slave) | Status channel 1 (A-slave) | UINT16 | RW | 0x0000 (0dec)
7pp0:02 | Value Ch.1 (A-Slave) | Output data channel 1 (A-slave) | UINT16 | RW | 0x0000 (0dec)
7pp0:03 | State Ch.2 (A-Slave) | Status channel 2 (A-slave) | UINT16 | RW | 0x0000 (0dec)
7pp0:04 | Value Ch.2 (A-Slave) | Output data channel 2 (A-slave) | UINT16 | RW | 0x0000 (0dec)
7pp0:05 | State Ch.3 (A-Slave) | Status channel 3 (A-slave) | UINT16 | RW | 0x0000 (0dec)
7pp0:06 | Value Ch.3 (A-Slave) | Output data channel 3 (A-slave) | UINT16 | RW | 0x0000 (0dec)
7pp0:07 | State Ch.4 (A-Slave) | Status channel 4 (A-slave) | UINT16 | RW | 0x0000 (0dec)
7pp0:08 | Value Ch.4 (A-Slave) | Output data channel 4 (A-slave) | UINT16 | RW | 0x0000 (0dec)


Information data

Commissioning [image] Object description and parameterization [image] Information data
Information data
Index 10F3 Diagnosis History
Index (hex) | Name | Meaning | Data type | Flags | Default
10F3:0 | Diagnosis History | Maximum subindex | UINT8 | RO | 0x15 (21dec)
10F3:01 | Maximum Messages | reserved | UINT8 | RO | 0x00 (0dec)
10F3:02 | Newest Message | reserved | UINT8 | RO | 0x00 (0dec)
10F3:03 | Newest Acknowledged Message | reserved | UINT8 | RW | 0x00 (0dec)
10F3:04 | New Messages Available | reserved | BOOLEAN | RO | 0x00 (0dec)
10F3:05 | Flags | reserved | UINT16 | RW | 0x0000 (0dec)
10F3:06 - 15 | Diagnosis Message 001 - 016 | reserved | OCTET-STRING[20] | RO | {0}
Index 10F8 Actual Time Stamp
Index (hex) | Name | Meaning | Data type | Flags | Default
10F8:0 | Actual Time Stamp | Time stamp | UINT64 | RO |
Index 9pp0 ASI Info Data Slave (for 00 ≤ pp ≤ 1F; slave 0 to slave 31)
Index (hex) | Name | Meaning | Data type | Flags | Default
9pp0:0 | ASI Info Data Slave | Maximum subindex | UINT8 | RO | 0x29 (41dec)
9pp0:01 | ASI Address | Address of the AS-i slave (actual configuration) | UINT16 | RO | 0x0000 (0dec)
9pp0:20 | IO Configuration (A-Slave) | Read I/O ID (actual configuration) | UINT8 | RO | 0x00 (0dec)
9pp0:21 | ID Code (A-Slave) | Read standard ID code (actual configuration) | UINT8 | RO | 0x00 (0dec)
9pp0:22 | Extended ID Code 1 (A-Slave) | Read extended ID code 1 (actual configuration) | UINT8 | RO | 0x00 (0dec)
9pp0:23 | Extended ID Code 2 (A-Slave) | Read extended ID code 2 (actual configuration) | UINT8 | RO | 0x00 (0dec)
9pp0:24 | Parameter (A-Slave) | Response of the slave to the activation parameter command (see object 0x8pp0:24) | UINT8 | RO | 0x00 (0dec)
9pp0:25 | IO Configuration (B-slave) | Read I/O ID (actual configuration) | UINT8 | RO | 0x00 (0dec)
9pp0:26 | ID code (B-slave) | Read standard ID code (actual configuration) | UINT8 | RO | 0x00 (0dec)
9pp0:27 | Extended ID Code 1 (B-slave) | Read extended ID code 1 (actual configuration) | UINT8 | RO | 0x00 (0dec)
9pp0:28 | Extended ID Code 2 (B-slave) | Read extended ID code 2 (actual configuration) | UINT8 | RO | 0x00 (0dec)
9pp0:29 | Parameter (B-slave) | Response of the slave to the activation parameter command (see object 0x8pp0:29) | UINT8 | RO | 0x00 (0dec)


Diagnostic data

Commissioning [image] Object description and parameterization [image] Diagnostic data
Diagnostic data
Index App0 ASI Diag Data Slave (for 00 ≤ pp ≤ 1F; slave 0 to slave 31)
Index (hex) | Name | Meaning | Data type | Flags | Default
App0:0 | ASI Diag Data Slave 0 | Maximum subindex | UINT8 | RO | 0x12 (18dec)
App0:01 | Communication State (A-Slave) | Slave status (see table below) | UINT16 | RO | 0x00 (0dec)
Description | Value
Slave is in LDS | Bit 0 (LSB)
Slave is in LAS | Bit 1
Slave is in LPS | Bit 2
Slave is in advanced addressing mode (A/B slaves) | Bit 3
In protected mode the slave is only enabled if the EA code of this slave matches the projected slave. | Bit 4
In protected mode the slave is only enabled if the ID code of this slave matches the projected slave. | Bit 5
In protected mode the slave is only enabled if the extended ID code 1 of this slave matches the projected slave. | Bit 6
In protected mode the slave is only enabled if the extended ID code 2 of this slave matches the projected slave. | Bit 7
Slave supports extended ID code 1 and 2 | Bit 8
Slave is an analog slave | Bit 9
Slave is a safety slave | Bit 10
reserved | Bit 11
reserved | Bit 12
Slave requires M4 master (one of the M4 profiles) | Bit 13 (MSB)
Slave has no digital inputs | Bit 14 (MSB)
Slave has no digital outputs | Bit 15 (MSB)
Index App0 ASI Diag Data Slave (for 00 ≤ pp ≤ 1F; slave 0 to slave 31)
Index (hex) | Name | Meaning | Data type | Flags | Default
App0:02 | Status Register (A-Slave) | General status information Last received response of a slave to the command "ReadStatus" (see table below) | UINT8 | RO | 0x00 (0dec)
Bit | Description
0 - 3 | Status register of the slave (default = 0)
4 - 7 | reserved
Index App0 ASI Diag Data Slave (for 00 ≤ pp ≤ 1F; slave 0 to slave 31)
Index (hex) | Name | Meaning | Data type | Flags | Default
App0:03 | Physical Fault Counter (A-Slave) | Counter that increments if a response from the respective AS-i slave had a start bit, stop bit or parity bit error | UINT16 | RO | 0x0000 (0dec)
App0:04 | Timeout Counter (A-Slave) | Counter that increments if the respective AS-i slave did not respond | UINT16 | RO | 0x0000 (0dec)
App0:05 | Response Counter (A-Slave) | Counter that increments if the respective AS-i slave responded correctly | UINT16 | RO | 0x0000 (0dec)
App0:06 | Leave Data-Exchange Counter (A-Slave) | Counter that increments if the respective AS-i slave has been deleted from the LAS, i.e. it did not respond (or correctly respond) three times in succession | UINT16 | RO | 0x0000 (0dec)
App0:07 | Data-Exchange Failed Counter (A-Slave) | Counter that increments if the respective AS-i slave did not respond (or correctly respond) to a data exchange telegram | UINT16 | RO | 0x0000 (0dec)
App0:08 | Timeout Statistics (A-Slave) | Timeouts per telegram in percent | UINT16 | RO | 0x0000 (0dec)
App0:09 | Data-Exchange Repeat Counter (A-Slave) | This counter is incremented if the data exchange has to be repeated (slave responded incorrectly or not all) | UINT16 | RO | 0x0000 (0dec)
App0:0A | Communication State (B-Slave) | Slave Status see "Extracted nested table 13" | UINT8 | RO | 0x00 (0dec)
Description | Value
Slave is in LDS | Bit 0 (LSB)
Slave is in LAS | Bit 1
Slave is in LPS | Bit 2
Slave is in advanced addressing mode (A/B slaves) | Bit 3
In protected mode the slave is only enabled if the EA code of this slave matches the projected slave. | Bit 4
In protected mode the slave is only enabled if the ID code of this slave matches the projected slave. | Bit 5
In protected mode the slave is only enabled if the extended ID code 1 of this slave matches the projected slave. | Bit 6
In protected mode the slave is only enabled if the extended ID code 2 of this slave matches the projected slave. | Bit 7
Slave supports extended ID code 1 and 2 | Bit 8
Slave is an analog slave | Bit 9
Slave is a safety slave | Bit 10
reserved | Bit 11
reserved | Bit 12
Slave requires M4 master (one of the M4 profiles) | Bit 13 (MSB)
Slave has no digital inputs | Bit 14 (MSB)
Slave has no digital outputs | Bit 15 (MSB)
Index App0 ASI Diag Data Slave (for 00 ≤ pp ≤ 1F; slave 0 to slave 31)
Index (hex) | Name | Meaning | Data type | Flags | Default
App0:0B | Status Register (B-Slave) | General status information Last received response of a slave to the command "ReadStatus" (see table below) | UINT8 | RO | 0x00 (0dec)
Bit | Description
0 - 3 | Status register of the slave (default = 0)
4 - 7 | reserved
Index App0 ASI Diag Data Slave (for 00 ≤ pp ≤ 1F; slave 0 to slave 31)
Index (hex) | Name | Meaning | Data type | Flags | Default
App0:0C | Physical Fault Counter (B-Slave) | Counter that increments if a response from the respective AS-i slave had a start bit, stop bit or parity bit error | UINT16 | RO | 0x0000 (0dec)
App0:0D | Timeout Counter (B-Slave) | Counter that increments if the respective AS-i slave did not respond | UINT16 | RO | 0x0000 (0dec)
App0:0E | Response Counter (B-Slave) | Counter that increments if the respective AS-i slave responded correctly | UINT16 | RO | 0x0000 (0dec)
App0:0F | Leave Data-Exchange Counter (B-Slave) | Counter that increments if the respective AS-i slave has been deleted from the LAS, i.e. it did not respond (or correctly respond) three times in succession | UINT16 | RO | 0x0000 (0dec)
App0:10 | Data-Exchange Failed Counter (B-Slave) | Counter that increments if the respective AS-i slave did not respond (or correctly respond) to a data exchange telegram | UINT16 | RO | 0x0000 (0dec)
App0:11 | Timeout Statistics (B-Slave) | Timeouts per telegram in percent | UINT16 | RO | 0x0000 (0dec)
App0:12 | Data-Exchange Repeat Counter (B-Slave) | This counter is incremented if the data exchange has to be repeated (slave responded incorrectly or not all) | UINT16 | RO | 0x0000 (0dec)


ASI data

Commissioning [image] Object description and parameterization [image] ASI data
ASI data
Index F100 ASI Status
Index (hex)
Name
Meaning
Data type
Flags
Default
F100:0
ASI Status
Maximum subindex
UINT8
RO
0x10 (16dec)
F100:01
Configuration okay
Valid AS-i configuration
1bin: the nominal configuration and the actual configuration match (only relevant for protected mode)
BOOLEAN
RO
0x00 (0dec)
F100:02
Power Fail
1bin: a power failure has occurred
BOOLEAN
RO
0x00 (0dec)
F100:03
Auto addressing mode enabled
1bin: automatic addressing is enabled (protected mode must be active)

0bin: automatic addressing is locked:
▪
an AS-i slave with address 0 was found, but no projected AS-i slave is missing or
▪
a non-projected AS-i slave was found
BOOLEAN
RO
0x00 (0dec)
F100:04
Auto addressing mode available
1bin: automatic addressing is available (protected mode must be active and precisely one projected AS-i slave must be missing)
BOOLEAN
RO
0x00 (0dec)
F100:05
Protected mode active
1bin: protected mode is activated
BOOLEAN
RO
0x00 (0dec)
F100:06
Slave with address 0 found
1bin: an AS-i slave with address "0" was found
BOOLEAN
RO
0x00 (0dec)
F100:07
Offline Ready
1bin: The AS-i master is set to offline phase (the outputs of the activated AS-i slaves are set to the default value (1bin), the inputs of the activated AS-i slaves in the controller were also set to the default value (0bin)
BOOLEAN
RO
0x00 (0dec)
F100:08
Normal Operation
1bin: The AS-i master operates in normal mode (the data exchange phase was reached, AS-i outputs and AS-i inputs have the current values)
BOOLEAN
RO
0x00 (0dec)
F100:09
ASI phase
ASI-State Machine:
0: Offline phase
1: Reset phase
2: Detection phase
3: Activation phase
4: Data exchange phase
5: Management phase
6: Inclusion phase
BIT3
RO
0x00 (0dec)
F100:0C***
Power24 Mode
Enabled
Power24 support active
BOOLEAN
RO
0x00 (0dec)
F100:0D***
Power24 Mode
Fail
Power24 mode error
BOOLEAN
RO
0x00 (0dec)
F100:0E***
M4 Profile Support
Enabled
M4 profile support
BOOLEAN
RO
0x00 (0dec)
F100:10
TxPDO Toggle
The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated
BOOLEAN
RO
0x00 (0dec)
***) from firmware 02
Index F101 ASI LDS
This lists all slaves that physically exist in the network, have a valid address and were detected by the master.
Index (hex) | Name | Meaning | Data type | Flags | Default
F101:0 | ASI LDS | Maximum subindex | UINT8 | RO | 0x3F (63dec)
F101:01 | Slave 0 | Slave 0 detected | BOOLEAN | RO | 0x00 (0dec)
F101:02 ... 20 | Slave 1A ... 31A | Slave 1A ... 31A detected | BOOLEAN | RO | 0x00 (0dec)
F101:21 ... 3F | Slave 1B ... 31B | Slave 1B ... 31B detected | BOOLEAN | RO | 0x00 (0dec)
Index F102 ASI LAS
All slaves with which the master communicates. In protected mode, this list corresponds to the LPS, in configuration mode it corresponds to the LDS
Index (hex) | Name | Meaning | Data type | Flags | Default
F102:0 | ASI LAS | Maximum subindex | UINT8 | RO | 0x3F (63dec)
F102:01 | Slave 0 | ** | BOOLEAN | RO | 0x00 (0dec)
F102:02 ...20 | Slave 1A ... 31A | Slave 1A ... 31A enabled | BOOLEAN | RO | 0x00 (0dec)
F102:21 ... 3F | Slave 1B ... 31B | Slave 1B ... 31B enabled | BOOLEAN | RO | 0x00 (0dec)
Index F103 ASI LPS
This list comprises all slaves that the master expects to find in the network. In protected mode, the master only communicates with these slaves and issues a message as soon as additional slaves are detected, or if slaves are missing from this list.
Index (hex) | Name | Meaning | Data type | Flags | Default
F103:0 | ASI LPS | Maximum subindex | UINT8 | RO | 0x3F (63dec)
F103:01 | Slave 0 | ** | BOOLEAN | RO | 0x00 (0dec)
F103:02 ...20 | Slave 1A ... 31A | Slave 1A ... 31A projected | BOOLEAN | RO | 0x00 (0dec)
F103:21 ...3F | Slave 1B... 31B | Slave 1B ... 31B projected | BOOLEAN | RO | 0x00 (0dec)
Index F200 ASI Control
Index (hex) | Name | Meaning | Data type | Flags | Default
F200:0 | ASI Control | Maximum subindex | UINT8 | RO | 0x05 (5dec)
F200:01 | Auto Programming Enable | 0bin: automatic addressing locked. 1bin: automatic addressing enabled | BOOLEAN | RW | 0x00 (0dec)
F200:02 | Go Offline Mode | 1bin: the AS-i master enters the offline phase 0bin: the AS-i master exits the offline phase. | BOOLEAN | RW | 0x00 (0dec)
F200:03 | Data Exchange Active | Enabling of AS-i data exchange: 1bin: the current AS-i outputs are sent to the AS-i slaves, and the received AS-i inputs transferred to the controller. 0bin: the default values (1bin) are sent to the AS-i slaves, the received AS-i inputs are deleted, and the default values (0bin) are transferred to the controller. | BOOLEAN | RW | 0x00 (0dec)
F200:04 | Go Protected Mode | 1bin: activate protected mode | BOOLEAN | RW | 0x00 (0dec)
F200:05 | Go Configuration Mode | 1bin: activate configuration mode | BOOLEAN | RW | 0x00 (0dec)
F200:06*** | Toggle Power24 mode | Activate Power24 mode | BOOLEAN | RW | 0x00 (0dec)
F200:07*** | Toggle M4 Profile Support | Activate M4 Profile support | BOOLEAN | RW | 0x00 (0dec)
***) from firmware 02
Index F600 ASI Digital Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
F600:0 | ASI Digital Inputs | Maximum subindex | UINT8 | RO | 0xF8 (248dec)
F600:01 | Slave 1 Inputs__Slave 1A, DI0 | Slave 1 Inputs__Slave 1A, DI0, digital inputs or safety flags** | BOOLEAN | RO | 0x00 (0dec)
F600:02 | Slave 1 Inputs__Slave 1A, DI1 | Slave 1 Inputs__Slave 1A, DI1, digital inputs or safety flags** | BOOLEAN | RO | 0x00 (0dec)
F600:03 | Slave 1 Inputs__Slave 1A, DI2 | Slave 1 Inputs__Slave 1A, DI2, digital inputs or safety flags** | BOOLEAN | RO | 0x00 (0dec)
F600:04 | Slave 1 Inputs__Slave 1A, DI3 | Slave 1 Inputs__Slave 1A, DI3, digital inputs or safety flags** | BOOLEAN | RO | 0x00 (0dec)
F600:05 | Slave 1 Inputs__Slave 1B, DI0 | Slave 1 Inputs__Slave 1B, DI0, digital inputs | BOOLEAN | RO | 0x00 (0dec)
F600:06 | Slave 1 Inputs__Slave 1B, DI1 | Slave 1 Inputs__Slave 1B, DI1, digital inputs | BOOLEAN | RO | 0x00 (0dec)
F600:07 | Slave 1 Inputs__Slave 1B, DI2 | Slave 1 Inputs__Slave 1B, DI2, digital inputs | BOOLEAN | RO | 0x00 (0dec)
F600:08 | Slave 1 Inputs__Slave 1B, DI3 | Slave 1 Inputs__Slave 1B, DI3, digital inputs | BOOLEAN | RO | 0x00 (0dec)
*** | *** | *** | *** | *** | ***
F600:F1 | Slave 31 Inputs__Slave 31A, DI0 | Slave 31 Inputs__Slave 31A, DI0, digital inputs or safety flags** | BOOLEAN | RO | 0x00 (0dec)
F600:F2 | Slave 31 Inputs__Slave 31A, DI1 | Slave 31 Inputs__Slave 31A, DI1, digital inputs or safety flags** | BOOLEAN | RO | 0x00 (0dec)
F600:F3 | Slave 31 Inputs__Slave 31A, DI2 | Slave 31 Inputs__Slave 31A, DI2, digital inputs or safety flags** | BOOLEAN | RO | 0x00 (0dec)
F600:F4 | Slave 31 Inputs__Slave 31A, DI3 | Slave 31 Inputs__Slave 31A, DI3, digital inputs or safety flags** | BOOLEAN | RO | 0x00 (0dec)
F600:F5 | Slave 31 Inputs__Slave 31B, DI0 | Slave 31 Inputs__Slave 31B, DI0, digital inputs | BOOLEAN | RO | 0x00 (0dec)
F600:F6 | Slave 31 Inputs__Slave 31B, DI1 | Slave 31 Inputs__Slave 31B, DI1, digital inputs | BOOLEAN | RO | 0x00 (0dec)
F600:F7 | Slave 31 Inputs__Slave 31B, DI2 | Slave 31 Inputs__Slave 31B, DI2, digital inputs | BOOLEAN | RO | 0x00 (0dec)
F600:F8 | Slave 31 Inputs__Slave 31B, DI3 | Slave 31 Inputs__Slave 31B, DI3, digital inputs | BOOLEAN | RO | 0x00 (0dec)
**) Safety flags: Information about the state of an AS-i safety slave:
hex | Bit3 | Bit2 | Bit1 | Bit0 | Status
0x7 | 0 | 1 | 1 | 1 | Sensor according to the rules in status ON
0xC | 1 | 1 | 0 | 0 | Sensor in status OFF, but only contact 2 open
0xA | 1 | 0 | 1 | 0 | Sensor in status OFF, but only contact 1 open
0x8 | 1 | 0 | 0 | 0 | Sensor according to the rules in status OFF
SmallWarningYellow WARNING
Evaluation of not permitted!
Evaluation of the safety flags, shown in the process image of EL6201 for controlling safety-relevant functions is not permitted!
They are not allowed to be used for protection functions such as emergency stop, access protection, protected area monitoring, robot area monitoring, press safety valves etc.!
Index F700 ASI Digital Outputs
Index (hex) | Name | Meaning | Data type | Flags | Default
F700:0 | ASI Digital Outputs | Maximum subindex | UINT8 | RO | 0xF8 (248dec)
F700:01 | Slave 1 Outputs__Slave 1A, DO0 | Slave 1 Outputs__Slave 1A, DO0, digital outputs | BOOLEAN | RO | 0x00 (0dec)
F700:02 | Slave 1 Outputs__Slave 1A, DO1 | Slave 1 Outputs__Slave 1A, DO1, digital outputs | BOOLEAN | RO | 0x00 (0dec)
F700:03 | Slave 1 Outputs__Slave 1A, DO2 | Slave 1 Outputs__Slave 1A, DO2, digital outputs | BOOLEAN | RO | 0x00 (0dec)
F700:04 | Slave 1 Outputs__Slave 1A, DO3 | Slave 1 Outputs__Slave 1A, DO3, digital outputs | BOOLEAN | RO | 0x00 (0dec)
F700:05 | Slave 1 Outputs__Slave 1B, DO0 | Slave 1 Outputs__Slave 1B, DO0, digital outputs | BOOLEAN | RO | 0x00 (0dec)
F700:06 | Slave 1 Outputs__Slave 1B, DO1 | Slave 1 Outputs__Slave 1B, DO1, digital outputs | BOOLEAN | RO | 0x00 (0dec)
F700:07 | Slave 1 Outputs__Slave 1B, DO2 | Slave 1 Outputs__Slave 1B, DO2, digital outputs | BOOLEAN | RO | 0x00 (0dec)
F700:08 | Slave 1 Outputs__Slave 1B, DO3 | Slave 1 Outputs__Slave 1B, DO3, digital outputs | BOOLEAN | RO | 0x00 (0dec)
*** | *** | *** | *** | *** | ***
F700:F1 | Slave 31 Outputs__Slave 31A, DO0 | Slave 31 Outputs__Slave 31A, DO0, digital outputs | BOOLEAN | RO | 0x00 (0dec)
F700:F2 | Slave 31 Outputs__Slave 31A, DO1 | Slave 31 Outputs__Slave 31A, DO1, digital outputs | BOOLEAN | RO | 0x00 (0dec)
F700:F3 | Slave 31 Outputs__Slave 31A, DO2 | Slave 31 Outputs__Slave 31A, DO2, digital outputs | BOOLEAN | RO | 0x00 (0dec)
F700:F4 | Slave 31 Outputs__Slave 31A, DO3 | Slave 31 Outputs__Slave 31A, DO3, digital outputs | BOOLEAN | RO | 0x00 (0dec)
F700:F5 | Slave 31 Outputs__Slave 31B, DO0 | Slave 31 Outputs__Slave 31B, DO0, digital outputs | BOOLEAN | RO | 0x00 (0dec)
F700:F6 | Slave 31 Outputs__Slave 31B, DO1 | Slave 31 Outputs__Slave 31B, DO1, digital outputs | BOOLEAN | RO | 0x00 (0dec)
F700:F7 | Slave 31 Outputs__Slave 31B, DO2 | Slave 31 Outputs__Slave 31B, DO2, digital outputs | BOOLEAN | RO | 0x00 (0dec)
F700:F8 | Slave 31 Outputs__Slave 31B, DO3 | Slave 31 Outputs__Slave 31B, DO3, digital outputs | BOOLEAN | RO | 0x00 (0dec)
Index F901 ASI Analog Slaves
Index (hex) | Name | Meaning | Data type | Flags | Default
F901:0 | ASI Analog Slaves | Maximum subindex | UINT8 | RO | 0x3F (63dec)
F901:01 | Slave 0 | Slave 0 is an analog slave | BOOLEAN | RO | 0x00 (0dec)
F901:02 ... 20 | Slave 1A ... 31A | Slave 1A ... 31A is an analog slave | BOOLEAN | RO | 0x00 (0dec)
F901:21 ... 3F | Slave 1B ... 31B | Slave 1B ... 31B is an analog slave | BOOLEAN | RO | 0x00 (0dec)
Index F902 ASI Safety Slaves
Index (hex) | Name | Meaning | Data type | Flags | Default
F902:0 | ASI Safety Slaves | Maximum subindex | UINT8 | RO | 0x3F (63dec)
F902:01 | Slave 0 | Slave 0 is a safety slave | BOOLEAN | RO | 0x00 (0dec)
F902:02 ... 20 | Slave 1A ... 31A | Slave 1A ... 31A is a safety slave | BOOLEAN | RO | 0x00 (0dec)
F902:21 ... 3F | Slave 1B ... 31B | Slave 1B ... 31B is a safety slave | BOOLEAN | RO | 0x00 (0dec)


Object description - standard objects

Commissioning [image] Object description - standard objects
Object description - standard objects
Standard objects
Index 1000 Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x18381389 (406328201dec)
Index 1008 Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EL6201
Index 1009 Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO |
Index 100A Software version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO | 01
Index 1010 Store parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1010:0 | Store parameters | reserved | UINT8 | RO | 0x01 (1dec)
1010:01 | SubIndex 001 | reserved | UINT32 | RW | 0x00000000 (0dec)
Index 1018 Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x18393052 (406401106dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the low word (bit 0-15) indicates the special terminal number, the high word (bit 16-31) refers to the device description | UINT32 | RO | 0x00000000 (0dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the low byte (bit 0-7) of the low word contains the year of production, the high byte (bit 8-15) of the low word contains the week of production, the high word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 Backup parameter handling
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | Information for standardized loading and saving of backup entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum across all backup entries of the EtherCAT slave | UINT32 | RO | 0x00000000 (0dec)
Index 10F2 Backup parameter storage
Index (hex) | Name | Meaning | Data type | Flags | Default
10F2:0 | Backup parameter storage |  | OCTET-STRING[4] | RW | {0}
Index 1601 ASI RxPDO-Map Analog Outputs Slave 1
Index (hex) | Name | Meaning | Data type | Flags | Default
1601:0 | ASI RxPDO-Map Analog Outputs Slave 1 | PDO Mapping RxPDO 2 | UINT8 | RO | 0x08 (8dec)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (ASI Analog Outputs Slave 1 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7010:01, 16
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (ASI Analog Outputs Slave 1 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7010:02, 16
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (ASI Analog Outputs Slave 1 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7010:03, 16
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7010 (ASI Analog Outputs Slave 1 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7010:04, 16
1601:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7010 (ASI Analog Outputs Slave 1 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7010:05, 16
1601:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7010 (ASI Analog Outputs Slave 1 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7010:06, 16
1601:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7010 (ASI Analog Outputs Slave 1 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7010:07, 16
1601:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7010 (ASI Analog Outputs Slave 1 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7010:08, 16
Index 1602 ASI RxPDO-Map Analog Outputs Slave 2
Index (hex) | Name | Meaning | Data type | Flags | Default
1602:0 | ASI RxPDO-Map Analog Outputs Slave 2 | PDO Mapping RxPDO 3 | UINT8 | RO | 0x08 (8dec)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (ASI Analog Outputs Slave 2 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7020:01, 16
1602:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7020 (ASI Analog Outputs Slave 2 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7020:02, 16
1602:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7020 (ASI Analog Outputs Slave 2 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7020:03, 16
1602:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7020 (ASI Analog Outputs Slave 2 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7020:04, 16
1602:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7020 (ASI Analog Outputs Slave 2 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7020:05, 16
1602:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7020 (ASI Analog Outputs Slave 2 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7020:06, 16
1602:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7020 (ASI Analog Outputs Slave 2 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7020:07, 16
1602:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7020 (ASI Analog Outputs Slave 2 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7020:08, 16
Index 1603 ASI RxPDO-Map Analog Outputs Slave 3
Index (hex) | Name | Meaning | Data type | Flags | Default
1603:0 | ASI RxPDO-Map Analog Outputs Slave 3 | PDO Mapping RxPDO 4 | UINT8 | RO | 0x08 (8dec)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7030 (ASI Analog Outputs Slave 3 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7030:01, 16
1603:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7030 (ASI Analog Outputs Slave 3 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7030:02, 16
1603:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7030 (ASI Analog Outputs Slave 3 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7030:03, 16
1603:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7030 (ASI Analog Outputs Slave 3 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7030:04, 16
1603:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7030 (ASI Analog Outputs Slave 3 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7030:05, 16
1603:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7030 (ASI Analog Outputs Slave 3 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7030:06, 16
1603:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7030 (ASI Analog Outputs Slave 3 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7030:07, 16
1603:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7030 (ASI Analog Outputs Slave 3 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7030:08, 16
Index 1604 ASI RxPDO-Map Analog Outputs Slave 4
Index (hex) | Name | Meaning | Data type | Flags | Default
1604:0 | ASI RxPDO-Map Analog Outputs Slave 4 | PDO Mapping RxPDO 5 | UINT8 | RO | 0x08 (8dec)
1604:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7040 (ASI Analog Outputs Slave 4 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7040:01, 16
1604:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7040 (ASI Analog Outputs Slave 4 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7040:02, 16
1604:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7040 (ASI Analog Outputs Slave 4 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7040:03, 16
1604:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7040 (ASI Analog Outputs Slave 4 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7040:04, 16
1604:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7040 (ASI Analog Outputs Slave 4 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7040:05, 16
1604:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7040 (ASI Analog Outputs Slave 4 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7040:06, 16
1604:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7040 (ASI Analog Outputs Slave 4 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7040:07, 16
1604:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7040 (ASI Analog Outputs Slave 4 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7040:08, 16
Index 1605 ASI RxPDO-Map Analog Outputs Slave 5
Index (hex) | Name | Meaning | Data type | Flags | Default
1605:0 | ASI RxPDO-Map Analog Outputs Slave 5 | PDO Mapping RxPDO 6 | UINT8 | RO | 0x08 (8dec)
1605:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7050 (ASI Analog Outputs Slave 5 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7050:01, 16
1605:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7050 (ASI Analog Outputs Slave 5 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7050:02, 16
1605:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7050 (ASI Analog Outputs Slave 5 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7050:03, 16
1605:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7050 (ASI Analog Outputs Slave 5 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7050:04, 16
1605:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7050 (ASI Analog Outputs Slave 5 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7050:05, 16
1605:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7050 (ASI Analog Outputs Slave 5 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7050:06, 16
1605:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7050 (ASI Analog Outputs Slave 5 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7050:07, 16
1605:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7050 (ASI Analog Outputs Slave 5 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7050:08, 16
Index 1606 ASI RxPDO-Map Analog Outputs Slave 6
Index (hex) | Name | Meaning | Data type | Flags | Default
1606:0 | ASI RxPDO-Map Analog Outputs Slave 6 | PDO Mapping RxPDO 7 | UINT8 | RO | 0x08 (8dec)
1606:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7060 (ASI Analog Outputs Slave 6 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7060:01, 16
1606:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7060 (ASI Analog Outputs Slave 6 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7060:02, 16
1606:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7060 (ASI Analog Outputs Slave 6 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7060:03, 16
1606:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7060 (ASI Analog Outputs Slave 6 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7060:04, 16
1606:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7060 (ASI Analog Outputs Slave 6 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7060:05, 16
1606:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7060 (ASI Analog Outputs Slave 6 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7060:06, 16
1606:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7060 (ASI Analog Outputs Slave 6 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7060:07, 16
1606:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7060 (ASI Analog Outputs Slave 6 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7060:08, 16
Index 1607 ASI RxPDO-Map Analog Outputs Slave 7
Index (hex) | Name | Meaning | Data type | Flags | Default
1607:0 | ASI RxPDO-Map Analog Outputs Slave 7 | PDO Mapping RxPDO 8 | UINT8 | RO | 0x08 (8dec)
1607:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7070 (ASI Analog Outputs Slave 7 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7070:01, 16
1607:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7070 (ASI Analog Outputs Slave 7 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7070:02, 16
1607:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7070 (ASI Analog Outputs Slave 7 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7070:03, 16
1607:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7070 (ASI Analog Outputs Slave 7 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7070:04, 16
1607:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7070 (ASI Analog Outputs Slave 7 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7070:05, 16
1607:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7070 (ASI Analog Outputs Slave 7 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7070:06, 16
1607:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7070 (ASI Analog Outputs Slave 7 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7070:07, 16
1607:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7070 (ASI Analog Outputs Slave 7 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7070:08, 16
Index 1608 ASI RxPDO-Map Analog Outputs Slave 8
Index (hex) | Name | Meaning | Data type | Flags | Default
1608:0 | ASI RxPDO-Map Analog Outputs Slave 8 | PDO Mapping RxPDO 9 | UINT8 | RO | 0x08 (8dec)
1608:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7080 (ASI Analog Outputs Slave 8 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7080:01, 16
1608:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7080 (ASI Analog Outputs Slave 8 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7080:02, 16
1608:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7080 (ASI Analog Outputs Slave 8 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7080:03, 16
1608:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7080 (ASI Analog Outputs Slave 8 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7080:04, 16
1608:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7080 (ASI Analog Outputs Slave 8 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7080:05, 16
1608:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7080 (ASI Analog Outputs Slave 8 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7080:06, 16
1608:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7080 (ASI Analog Outputs Slave 8 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7080:07, 16
1608:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7080 (ASI Analog Outputs Slave 8 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7080:08, 16
Index 1609 ASI RxPDO-Map Analog Outputs Slave 9
Index (hex) | Name | Meaning | Data type | Flags | Default
1609:0 | ASI RxPDO-Map Analog Outputs Slave 9 | PDO Mapping RxPDO 10 | UINT8 | RO | 0x08 (8dec)
1609:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7090 (ASI Analog Outputs Slave 9 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7090:01, 16
1609:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7090 (ASI Analog Outputs Slave 9 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7090:02, 16
1609:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7090 (ASI Analog Outputs Slave 9 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7090:03, 16
1609:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7090 (ASI Analog Outputs Slave 9 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7090:04, 16
1609:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7090 (ASI Analog Outputs Slave 9 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7090:05, 16
1609:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7090 (ASI Analog Outputs Slave 9 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7090:06, 16
1609:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7090 (ASI Analog Outputs Slave 9 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7090:07, 16
1609:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7090 (ASI Analog Outputs Slave 9 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7090:08, 16
Index 160A ASI RxPDO-Map Analog Outputs Slave 10
Index (hex) | Name | Meaning | Data type | Flags | Default
160A:0 | ASI RxPDO-Map Analog Outputs Slave 10 | PDO Mapping RxPDO 11 | UINT8 | RO | 0x08 (8dec)
160A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x70A0 (ASI Analog Outputs Slave 10 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x70A0:01, 16
160A:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x70A0 (ASI Analog Outputs Slave 10 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x70A0:02, 16
160A:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x70A0 (ASI Analog Outputs Slave 10 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x70A0:03, 16
160A:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x70A0 (ASI Analog Outputs Slave 10 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x70A0:04, 16
160A:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x70A0 (ASI Analog Outputs Slave 10 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x70A0:05, 16
160A:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x70A0 (ASI Analog Outputs Slave 10 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x70A0:06, 16
160A:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x70A0 (ASI Analog Outputs Slave 10 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x70A0:07, 16
160A:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x70A0 (ASI Analog Outputs Slave 10 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x70A0:08, 16
Index 160B ASI RxPDO-Map Analog Outputs Slave 11
Index (hex) | Name | Meaning | Data type | Flags | Default
160B:0 | ASI RxPDO-Map Analog Outputs Slave 11 | PDO Mapping RxPDO 12 | UINT8 | RO | 0x08 (8dec)
160B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x70B0 (ASI Analog Outputs Slave 11 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x70B0:01, 16
160B:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x70B0 (ASI Analog Outputs Slave 11 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x70B0:02, 16
160B:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x70B0 (ASI Analog Outputs Slave 11 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x70B0:03, 16
160B:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x70B0 (ASI Analog Outputs Slave 11 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x70B0:04, 16
160B:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x70B0 (ASI Analog Outputs Slave 11 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x70B0:05, 16
160B:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x70B0 (ASI Analog Outputs Slave 11 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x70B0:06, 16
160B:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x70B0 (ASI Analog Outputs Slave 11 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x70B0:07, 16
160B:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x70B0 (ASI Analog Outputs Slave 11 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x70B0:08, 16
Index 160C ASI RxPDO-Map Analog Outputs Slave 12
Index (hex) | Name | Meaning | Data type | Flags | Default
160C:0 | ASI RxPDO-Map Analog Outputs Slave 12 | PDO Mapping RxPDO 13 | UINT8 | RO | 0x08 (8dec)
160C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x70C0 (ASI Analog Outputs Slave 12 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x70C0:01, 16
160C:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x70C0 (ASI Analog Outputs Slave 12 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x70C0:02, 16
160C:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x70C0 (ASI Analog Outputs Slave 12 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x70C0:03, 16
160C:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x70C0 (ASI Analog Outputs Slave 12 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x70C0:04, 16
160C:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x70C0 (ASI Analog Outputs Slave 12 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x70C0:05, 16
160C:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x70C0 (ASI Analog Outputs Slave 12 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x70C0:06, 16
160C:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x70C0 (ASI Analog Outputs Slave 12 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x70C0:07, 16
160C:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x70C0 (ASI Analog Outputs Slave 12 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x70C0:08, 16
Index 160D ASI RxPDO-Map Analog Outputs Slave 13
Index (hex) | Name | Meaning | Data type | Flags | Default
160D:0 | ASI RxPDO-Map Analog Outputs Slave 13 | PDO Mapping RxPDO 14 | UINT8 | RO | 0x08 (8dec)
160D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x70D0 (ASI Analog Outputs Slave 13 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x70D0:01, 16
160D:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x70D0 (ASI Analog Outputs Slave 13 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x70D0:02, 16
160D:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x70D0 (ASI Analog Outputs Slave 13 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x70D0:03, 16
160D:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x70D0 (ASI Analog Outputs Slave 13 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x70D0:04, 16
160D:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x70D0 (ASI Analog Outputs Slave 13 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x70D0:05, 16
160D:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x70D0 (ASI Analog Outputs Slave 13 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x70D0:06, 16
160D:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x70D0 (ASI Analog Outputs Slave 13 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x70D0:07, 16
160D:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x70D0 (ASI Analog Outputs Slave 13 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x70D0:08, 16
Index 160E ASI RxPDO-Map Analog Outputs Slave 14
Index (hex) | Name | Meaning | Data type | Flags | Default
160E:0 | ASI RxPDO-Map Analog Outputs Slave 14 | PDO Mapping RxPDO 15 | UINT8 | RO | 0x08 (8dec)
160E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x70E0 (ASI Analog Outputs Slave 14 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x70E0:01, 16
160E:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x70E0 (ASI Analog Outputs Slave 14 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x70E0:02, 16
160E:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x70E0 (ASI Analog Outputs Slave 14 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x70E0:03, 16
160E:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x70E0 (ASI Analog Outputs Slave 14 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x70E0:04, 16
160E:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x70E0 (ASI Analog Outputs Slave 14 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x70E0:05, 16
160E:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x70E0 (ASI Analog Outputs Slave 14 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x70E0:06, 16
160E:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x70E0 (ASI Analog Outputs Slave 14 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x70E0:07, 16
160E:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x70E0 (ASI Analog Outputs Slave 14 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x70E0:08, 16
Index 160F ASI RxPDO-Map Analog Outputs Slave 15
Index (hex) | Name | Meaning | Data type | Flags | Default
160F:0 | ASI RxPDO-Map Analog Outputs Slave 15 | PDO Mapping RxPDO 16 | UINT8 | RO | 0x08 (8dec)
160F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x70F0 (ASI Analog Outputs Slave 15 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x70F0:01, 16
160F:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x70F0 (ASI Analog Outputs Slave 15 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x70F0:02, 16
160F:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x70F0 (ASI Analog Outputs Slave 15 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x70F0:03, 16
160F:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x70F0 (ASI Analog Outputs Slave 15 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x70F0:04, 16
160F:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x70F0 (ASI Analog Outputs Slave 15 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x70F0:05, 16
160F:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x70F0 (ASI Analog Outputs Slave 15 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x70F0:06, 16
160F:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x70F0 (ASI Analog Outputs Slave 15 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x70F0:07, 16
160F:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x70F0 (ASI Analog Outputs Slave 15 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x70F0:08, 16
Index 1610 ASI RxPDO-Map Analog Outputs Slave 16
Index (hex) | Name | Meaning | Data type | Flags | Default
1610:0 | ASI RxPDO-Map Analog Outputs Slave 16 | PDO Mapping RxPDO 17 | UINT8 | RO | 0x08 (8dec)
1610:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7100 (ASI Analog Outputs Slave 16 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7100:01, 16
1610:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7100 (ASI Analog Outputs Slave 16 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7100:02, 16
1610:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7100 (ASI Analog Outputs Slave 16 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7100:03, 16
1610:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7100 (ASI Analog Outputs Slave 16 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7100:04, 16
1610:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7100 (ASI Analog Outputs Slave 16 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7100:05, 16
1610:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7100 (ASI Analog Outputs Slave 16 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7100:06, 16
1610:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7100 (ASI Analog Outputs Slave 16 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7100:07, 16
1610:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7100 (ASI Analog Outputs Slave 16 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7100:08, 16
Index 1611 ASI RxPDO-Map Analog Outputs Slave 17
Index (hex) | Name | Meaning | Data type | Flags | Default
1611:0 | ASI RxPDO-Map Analog Outputs Slave 17 | PDO Mapping RxPDO 18 | UINT8 | RO | 0x08 (8dec)
1611:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7110 (ASI Analog Outputs Slave 17 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7110:01, 16
1611:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7110 (ASI Analog Outputs Slave 17 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7110:02, 16
1611:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7110 (ASI Analog Outputs Slave 17 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7110:03, 16
1611:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7110 (ASI Analog Outputs Slave 17 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7110:04, 16
1611:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7110 (ASI Analog Outputs Slave 17 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7110:05, 16
1611:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7110 (ASI Analog Outputs Slave 17 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7110:06, 16
1611:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7110 (ASI Analog Outputs Slave 17 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7110:07, 16
1611:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7110 (ASI Analog Outputs Slave 17 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7110:08, 16
Index 1612 ASI RxPDO-Map Analog Outputs Slave 18
Index (hex) | Name | Meaning | Data type | Flags | Default
1612:0 | ASI RxPDO-Map Analog Outputs Slave 18 | PDO Mapping RxPDO 19 | UINT8 | RO | 0x08 (8dec)
1612:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7120 (ASI Analog Outputs Slave 18 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7120:01, 16
1612:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7120 (ASI Analog Outputs Slave 18 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7120:02, 16
1612:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7120 (ASI Analog Outputs Slave 18 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7120:03, 16
1612:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7120 (ASI Analog Outputs Slave 18 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7120:04, 16
1612:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7120 (ASI Analog Outputs Slave 18 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7120:05, 16
1612:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7120 (ASI Analog Outputs Slave 18 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7120:06, 16
1612:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7120 (ASI Analog Outputs Slave 18 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7120:07, 16
1612:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7120 (ASI Analog Outputs Slave 18 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7120:08, 16
Index 1613 ASI RxPDO-Map Analog Outputs Slave 19
Index (hex) | Name | Meaning | Data type | Flags | Default
1613:0 | ASI RxPDO-Map Analog Outputs Slave 19 | PDO Mapping RxPDO 20 | UINT8 | RO | 0x08 (8dec)
1613:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7130 (ASI Analog Outputs Slave 19 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7130:01, 16
1613:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7130 (ASI Analog Outputs Slave 19 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7130:02, 16
1613:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7130 (ASI Analog Outputs Slave 19 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7130:03, 16
1613:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7130 (ASI Analog Outputs Slave 19 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7130:04, 16
1613:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7130 (ASI Analog Outputs Slave 19 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7130:05, 16
1613:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7130 (ASI Analog Outputs Slave 19 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7130:06, 16
1613:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7130 (ASI Analog Outputs Slave 19 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7130:07, 16
1613:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7130 (ASI Analog Outputs Slave 19 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7130:08, 16
Index 1614 ASI RxPDO-Map Analog Outputs Slave 20
Index (hex) | Name | Meaning | Data type | Flags | Default
1614:0 | ASI RxPDO-Map Analog Outputs Slave 20 | PDO Mapping RxPDO 21 | UINT8 | RO | 0x08 (8dec)
1614:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7140 (ASI Analog Outputs Slave 20 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7140:01, 16
1614:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7140 (ASI Analog Outputs Slave 20 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7140:02, 16
1614:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7140 (ASI Analog Outputs Slave 20 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7140:03, 16
1614:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7140 (ASI Analog Outputs Slave 20 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7140:04, 16
1614:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7140 (ASI Analog Outputs Slave 20 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7140:05, 16
1614:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7140 (ASI Analog Outputs Slave 20 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7140:06, 16
1614:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7140 (ASI Analog Outputs Slave 20 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7140:07, 16
1614:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7140 (ASI Analog Outputs Slave 20 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7140:08, 16
Index 1615 ASI RxPDO-Map Analog Outputs Slave 21
Index (hex) | Name | Meaning | Data type | Flags | Default
1615:0 | ASI RxPDO-Map Analog Outputs Slave 21 | PDO Mapping RxPDO 22 | UINT8 | RO | 0x08 (8dec)
1615:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7150 (ASI Analog Outputs Slave 21 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7150:01, 16
1615:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7150 (ASI Analog Outputs Slave 21 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7150:02, 16
1615:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7150 (ASI Analog Outputs Slave 21 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7150:03, 16
1615:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7150 (ASI Analog Outputs Slave 21 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7150:04, 16
1615:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7150 (ASI Analog Outputs Slave 21 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7150:05, 16
1615:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7150 (ASI Analog Outputs Slave 21 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7150:06, 16
1615:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7150 (ASI Analog Outputs Slave 21 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7150:07, 16
1615:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7150 (ASI Analog Outputs Slave 21 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7150:08, 16
Index 1616 ASI RxPDO-Map Analog Outputs Slave 22
Index (hex) | Name | Meaning | Data type | Flags | Default
1616:0 | ASI RxPDO-Map Analog Outputs Slave 22 | PDO Mapping RxPDO 23 | UINT8 | RO | 0x08 (8dec)
1616:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7160 (ASI Analog Outputs Slave 22 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7160:01, 16
1616:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7160 (ASI Analog Outputs Slave 22 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7160:02, 16
1616:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7160 (ASI Analog Outputs Slave 22 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7160:03, 16
1616:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7160 (ASI Analog Outputs Slave 22 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7160:04, 16
1616:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7160 (ASI Analog Outputs Slave 22 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7160:05, 16
1616:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7160 (ASI Analog Outputs Slave 22 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7160:06, 16
1616:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7160 (ASI Analog Outputs Slave 22 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7160:07, 16
1616:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7160 (ASI Analog Outputs Slave 22 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7160:08, 16
Index 1617 ASI RxPDO-Map Analog Outputs Slave 23
Index (hex) | Name | Meaning | Data type | Flags | Default
1617:0 | ASI RxPDO-Map Analog Outputs Slave 23 | PDO Mapping RxPDO 24 | UINT8 | RO | 0x08 (8dec)
1617:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7170 (ASI Analog Outputs Slave 23 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7170:01, 16
1617:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7170 (ASI Analog Outputs Slave 23 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7170:02, 16
1617:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7170 (ASI Analog Outputs Slave 23 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7170:03, 16
1617:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7170 (ASI Analog Outputs Slave 23 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7170:04, 16
1617:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7170 (ASI Analog Outputs Slave 23 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7170:05, 16
1617:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7170 (ASI Analog Outputs Slave 23 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7170:06, 16
1617:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7170 (ASI Analog Outputs Slave 23 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7170:07, 16
1617:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7170 (ASI Analog Outputs Slave 23 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7170:08, 16
Index 1618 ASI RxPDO-Map Analog Outputs Slave 24
Index (hex) | Name | Meaning | Data type | Flags | Default
1618:0 | ASI RxPDO-Map Analog Outputs Slave 24 | PDO Mapping RxPDO 25 | UINT8 | RO | 0x08 (8dec)
1618:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7180 (ASI Analog Outputs Slave 24 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7180:01, 16
1618:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7180 (ASI Analog Outputs Slave 24 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7180:02, 16
1618:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7180 (ASI Analog Outputs Slave 24 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7180:03, 16
1618:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7180 (ASI Analog Outputs Slave 24 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7180:04, 16
1618:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7180 (ASI Analog Outputs Slave 24 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7180:05, 16
1618:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7180 (ASI Analog Outputs Slave 24 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7180:06, 16
1618:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7180 (ASI Analog Outputs Slave 24 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7180:07, 16
1618:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7180 (ASI Analog Outputs Slave 24 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7180:08, 16
Index 1619 ASI RxPDO-Map Analog Outputs Slave 25
Index (hex) | Name | Meaning | Data type | Flags | Default
1619:0 | ASI RxPDO-Map Analog Outputs Slave 25 | PDO Mapping RxPDO 26 | UINT8 | RO | 0x08 (8dec)
1619:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7190 (ASI Analog Outputs Slave 25 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7190:01, 16
1619:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7190 (ASI Analog Outputs Slave 25 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7190:02, 16
1619:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7190 (ASI Analog Outputs Slave 25 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7190:03, 16
1619:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7190 (ASI Analog Outputs Slave 25 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7190:04, 16
1619:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7190 (ASI Analog Outputs Slave 25 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7190:05, 16
1619:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7190 (ASI Analog Outputs Slave 25 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7190:06, 16
1619:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7190 (ASI Analog Outputs Slave 25 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7190:07, 16
1619:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7190 (ASI Analog Outputs Slave 25 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7190:08, 16
Index 161A ASI RxPDO-Map Analog Outputs Slave 26
Index (hex) | Name | Meaning | Data type | Flags | Default
161A:0 | ASI RxPDO-Map Analog Outputs Slave 26 | PDO Mapping RxPDO 27 | UINT8 | RO | 0x08 (8dec)
161A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x71A0 (ASI Analog Outputs Slave 26 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x71A0:01, 16
161A:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x71A0 (ASI Analog Outputs Slave 26 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x71A0:02, 16
161A:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x71A0 (ASI Analog Outputs Slave 26 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x71A0:03, 16
161A:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x71A0 (ASI Analog Outputs Slave 26 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x71A0:04, 16
161A:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x71A0 (ASI Analog Outputs Slave 26 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x71A0:05, 16
161A:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x71A0 (ASI Analog Outputs Slave 26 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x71A0:06, 16
161A:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x71A0 (ASI Analog Outputs Slave 26 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x71A0:07, 16
161A:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x71A0 (ASI Analog Outputs Slave 26 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x71A0:08, 16
Index 161B ASI RxPDO-Map Analog Outputs Slave 27
Index (hex) | Name | Meaning | Data type | Flags | Default
161B:0 | ASI RxPDO-Map Analog Outputs Slave 27 | PDO Mapping RxPDO 28 | UINT8 | RO | 0x08 (8dec)
161B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x71B0 (ASI Analog Outputs Slave 27 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x71B0:01, 16
161B:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x71B0 (ASI Analog Outputs Slave 27 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x71B0:02, 16
161B:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x71B0 (ASI Analog Outputs Slave 27 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x71B0:03, 16
161B:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x71B0 (ASI Analog Outputs Slave 27 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x71B0:04, 16
161B:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x71B0 (ASI Analog Outputs Slave 27 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x71B0:05, 16
161B:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x71B0 (ASI Analog Outputs Slave 27 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x71B0:06, 16
161B:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x71B0 (ASI Analog Outputs Slave 27 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x71B0:07, 16
161B:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x71B0 (ASI Analog Outputs Slave 27 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x71B0:08, 16
Index 161C ASI RxPDO-Map Analog Outputs Slave 28
Index (hex) | Name | Meaning | Data type | Flags | Default
161C:0 | ASI RxPDO-Map Analog Outputs Slave 28 | PDO Mapping RxPDO 29 | UINT8 | RO | 0x08 (8dec)
161C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x71C0 (ASI Analog Outputs Slave 28 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x71C0:01, 16
161C:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x71C0 (ASI Analog Outputs Slave 28 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x71C0:02, 16
161C:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x71C0 (ASI Analog Outputs Slave 28 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x71C0:03, 16
161C:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x71C0 (ASI Analog Outputs Slave 28 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x71C0:04, 16
161C:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x71C0 (ASI Analog Outputs Slave 28 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x71C0:05, 16
161C:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x71C0 (ASI Analog Outputs Slave 28 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x71C0:06, 16
161C:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x71C0 (ASI Analog Outputs Slave 28 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x71C0:07, 16
161C:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x71C0 (ASI Analog Outputs Slave 28 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x71C0:08, 16
Index 161D ASI RxPDO-Map Analog Outputs Slave 29
Index (hex) | Name | Meaning | Data type | Flags | Default
161D:0 | ASI RxPDO-Map Analog Outputs Slave 29 | PDO Mapping RxPDO 30 | UINT8 | RO | 0x08 (8dec)
161D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x71D0 (ASI Analog Outputs Slave 29 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x71D0:01, 16
161D:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x71D0 (ASI Analog Outputs Slave 29 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x71D0:02, 16
161D:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x71D0 (ASI Analog Outputs Slave 29 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x71D0:03, 16
161D:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x71D0 (ASI Analog Outputs Slave 29 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x71D0:04, 16
161D:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x71D0 (ASI Analog Outputs Slave 29 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x71D0:05, 16
161D:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x71D0 (ASI Analog Outputs Slave 29 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x71D0:06, 16
161D:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x71D0 (ASI Analog Outputs Slave 29 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x71D0:07, 16
161D:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x71D0 (ASI Analog Outputs Slave 29 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x71D0:08, 16
Index 161E ASI RxPDO-Map Analog Outputs Slave 30
Index (hex) | Name | Meaning | Data type | Flags | Default
161E:0 | ASI RxPDO-Map Analog Outputs Slave 30 | PDO Mapping RxPDO 31 | UINT8 | RO | 0x08 (8dec)
161E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x71E0 (ASI Analog Outputs Slave 30 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x71E0:01, 16
161E:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x71E0 (ASI Analog Outputs Slave 30 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x71E0:02, 16
161E:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x71E0 (ASI Analog Outputs Slave 30 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x71E0:03, 16
161E:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x71E0 (ASI Analog Outputs Slave 30 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x71E0:04, 16
161E:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x71E0 (ASI Analog Outputs Slave 30 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x71E0:05, 16
161E:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x71E0 (ASI Analog Outputs Slave 30 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x71E0:06, 16
161E:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x71E0 (ASI Analog Outputs Slave 30 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x71E0:07, 16
161E:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x71E0 (ASI Analog Outputs Slave 30 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x71E0:08, 16
Index 161F ASI RxPDO-Map Analog Outputs Slave 31
Index (hex) | Name | Meaning | Data type | Flags | Default
161F:0 | ASI RxPDO-Map Analog Outputs Slave 31 | PDO Mapping RxPDO 32 | UINT8 | RO | 0x08 (8dec)
161F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x71F0 (ASI Analog Outputs Slave 31 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x71F0:01, 16
161F:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x71F0 (ASI Analog Outputs Slave 31 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x71F0:02, 16
161F:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x71F0 (ASI Analog Outputs Slave 31 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x71F0:03, 16
161F:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x71F0 (ASI Analog Outputs Slave 31 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x71F0:04, 16
161F:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x71F0 (ASI Analog Outputs Slave 31 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x71F0:05, 16
161F:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x71F0 (ASI Analog Outputs Slave 31 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x71F0:06, 16
161F:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x71F0 (ASI Analog Outputs Slave 31 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x71F0:07, 16
161F:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x71F0 (ASI Analog Outputs Slave 31 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x71F0:08, 16
Index 1640 ASI RxPDO-Map Outputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1640:0 | ASI RxPDO-Map Outputs Device | PDO Mapping RxPDO 65 | UINT8 | RO | 0xF8 (248dec)
1640:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x01 (Slave 1 Outputs__Slave 1A, DO0)) | UINT32 | RO | 0xF700:01, 1
1640:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x02 (Slave 1 Outputs__Slave 1A, DO1)) | UINT32 | RO | 0xF700:02, 1
1640:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x03 (Slave 1 Outputs__Slave 1A, DO2)) | UINT32 | RO | 0xF700:03, 1
1640:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x04 (Slave 1 Outputs__Slave 1A, DO3)) | UINT32 | RO | 0xF700:04, 1
1640:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x05 (Slave 1 Outputs__Slave 1B, DO0)) | UINT32 | RO | 0xF700:05, 1
1640:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x06 (Slave 1 Outputs__Slave 1B, DO1)) | UINT32 | RO | 0xF700:06, 1
1640:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x07 (Slave 1 Outputs__Slave 1B, DO2)) | UINT32 | RO | 0xF700:07, 1
1640:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x08 (Slave 1 Outputs__Slave 1B, DO3)) | UINT32 | RO | 0xF700:08, 1
1640:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x09 (Slave 2 Outputs__Slave 2A, DO0)) | UINT32 | RO | 0xF700:09, 1
1640:0A | SubIndex 010 | 10. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x0A (Slave 2 Outputs__Slave 2A, DO1)) | UINT32 | RO | 0xF700:0A, 1
1640:0B | SubIndex 011 | 11. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x0B (Slave 2 Outputs__Slave 2A, DO2)) | UINT32 | RO | 0xF700:0B, 1
1640:0C | SubIndex 012 | 12. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x0C (Slave 2 Outputs__Slave 2A, DO3)) | UINT32 | RO | 0xF700:0C, 1
1640:0D | SubIndex 013 | 13. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x0D (Slave 2 Outputs__Slave 2B, DO0)) | UINT32 | RO | 0xF700:0D, 1
1640:0E | SubIndex 014 | 14. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x0E (Slave 2 Outputs__Slave 2B, DO1)) | UINT32 | RO | 0xF700:0E, 1
1640:0F | SubIndex 015 | 15. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x0F (Slave 2 Outputs__Slave 2B, DO2)) | UINT32 | RO | 0xF700:0F, 1
Index 1640 ASI RxPDO-Map Outputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1640:10 | SubIndex 016 | 16. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x10 (Slave 2 Outputs__Slave 2B, DO3)) | UINT32 | RO | 0xF700:10, 1
1640:11 | SubIndex 017 | 17. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x11 (Slave 3 Outputs__Slave 3A, DO0)) | UINT32 | RO | 0xF700:11, 1
1640:12 | SubIndex 018 | 18. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x12 (Slave 3 Outputs__Slave 3A, DO1)) | UINT32 | RO | 0xF700:12, 1
1640:13 | SubIndex 019 | 19. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x13 (Slave 3 Outputs__Slave 3A, DO2)) | UINT32 | RO | 0xF700:13, 1
1640:14 | SubIndex 020 | 20. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x14 (Slave 3 Outputs__Slave 3A, DO3)) | UINT32 | RO | 0xF700:14, 1
1640:15 | SubIndex 021 | 21. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x15 (Slave 3 Outputs__Slave 3B, DO0)) | UINT32 | RO | 0xF700:15, 1
1640:16 | SubIndex 022 | 22. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x16 (Slave 3 Outputs__Slave 3B, DO1)) | UINT32 | RO | 0xF700:16, 1
1640:17 | SubIndex 023 | 23. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x17 (Slave 3 Outputs__Slave 3B, DO2)) | UINT32 | RO | 0xF700:17, 1
1640:18 | SubIndex 024 | 24. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x18 (Slave 3 Outputs__Slave 3B, DO3)) | UINT32 | RO | 0xF700:18, 1
1640:19 | SubIndex 025 | 25. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x19 (Slave 4 Outputs__Slave 4A, DO0)) | UINT32 | RO | 0xF700:19, 1
1640:1A | SubIndex 026 | 26. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x1A (Slave 4 Outputs__Slave 4A, DO1)) | UINT32 | RO | 0xF700:1A, 1
1640:1B | SubIndex 027 | 27. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x1B (Slave 4 Outputs__Slave 4A, DO2)) | UINT32 | RO | 0xF700:1B, 1
1640:1C | SubIndex 028 | 28. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x1C (Slave 4 Outputs__Slave 4A, DO3)) | UINT32 | RO | 0xF700:1C, 1
1640:1D | SubIndex 029 | 29. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x1D (Slave 4 Outputs__Slave 4B, DO0)) | UINT32 | RO | 0xF700:1D, 1
1640:1E | SubIndex 030 | 30. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x1E (Slave 4 Outputs__Slave 4B, DO1)) | UINT32 | RO | 0xF700:1E, 1
1640:1F | SubIndex 031 | 31. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x1F (Slave 4 Outputs__Slave 4B, DO2)) | UINT32 | RO | 0xF700:1F, 1
Index 1640 ASI RxPDO-Map Outputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1640:20 | SubIndex 032 | 32. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x20 (Slave 4 Outputs__Slave 4B, DO3)) | UINT32 | RO | 0xF700:20, 1
1640:21 | SubIndex 033 | 33. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x21 (Slave 5 Outputs__Slave 5A, DO0)) | UINT32 | RO | 0xF700:21, 1
1640:22 | SubIndex 034 | 34. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x22 (Slave 5 Outputs__Slave 5A, DO1)) | UINT32 | RO | 0xF700:22, 1
1640:23 | SubIndex 035 | 35. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x23 (Slave 5 Outputs__Slave 5A, DO2)) | UINT32 | RO | 0xF700:23, 1
1640:24 | SubIndex 036 | 36. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x24 (Slave 5 Outputs__Slave 5A, DO3)) | UINT32 | RO | 0xF700:24, 1
1640:25 | SubIndex 037 | 37. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x25 (Slave 5 Outputs__Slave 5B, DO0)) | UINT32 | RO | 0xF700:25, 1
1640:26 | SubIndex 038 | 38. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x26 (Slave 5 Outputs__Slave 5B, DO1)) | UINT32 | RO | 0xF700:26, 1
1640:27 | SubIndex 039 | 39. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x27 (Slave 5 Outputs__Slave 5B, DO2)) | UINT32 | RO | 0xF700:27, 1
1640:28 | SubIndex 040 | 40. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x28 (Slave 5 Outputs__Slave 5B, DO3)) | UINT32 | RO | 0xF700:28, 1
1640:29 | SubIndex 041 | 41. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x29 (Slave 6 Outputs__Slave 6A, DO0)) | UINT32 | RO | 0xF700:29, 1
1640:2A | SubIndex 042 | 42. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x2A (Slave 6 Outputs__Slave 6A, DO1)) | UINT32 | RO | 0xF700:2A, 1
1640:2B | SubIndex 043 | 43. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x2B (Slave 6 Outputs__Slave 6A, DO2)) | UINT32 | RO | 0xF700:2B, 1
1640:2C | SubIndex 044 | 44. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x2C (Slave 6 Outputs__Slave 6A, DO3)) | UINT32 | RO | 0xF700:2C, 1
1640:2D | SubIndex 045 | 45. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x2D (Slave 6 Outputs__Slave 6B, DO0)) | UINT32 | RO | 0xF700:2D, 1
1640:2E | SubIndex 046 | 46. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x2E (Slave 6 Outputs__Slave 6B, DO1)) | UINT32 | RO | 0xF700:2E, 1
1640:2F | SubIndex 047 | 47. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x2F (Slave 6 Outputs__Slave 6B, DO2)) | UINT32 | RO | 0xF700:2F, 1
Index 1640 ASI RxPDO-Map Outputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1640:30 | SubIndex 048 | 48. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x30 (Slave 6 Outputs__Slave 6B, DO3)) | UINT32 | RO | 0xF700:30, 1
1640:31 | SubIndex 049 | 49. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x31 (Slave 7 Outputs__Slave 7A, DO0)) | UINT32 | RO | 0xF700:31, 1
1640:32 | SubIndex 050 | 50. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x32 (Slave 7 Outputs__Slave 7A, DO1)) | UINT32 | RO | 0xF700:32, 1
1640:33 | SubIndex 051 | 51. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x33 (Slave 7 Outputs__Slave 7A, DO2)) | UINT32 | RO | 0xF700:33, 1
1640:34 | SubIndex 052 | 52. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x34 (Slave 7 Outputs__Slave 7A, DO3)) | UINT32 | RO | 0xF700:34, 1
1640:35 | SubIndex 053 | 53. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x35 (Slave 7 Outputs__Slave 7B, DO0)) | UINT32 | RO | 0xF700:35, 1
1640:36 | SubIndex 054 | 54. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x36 (Slave 7 Outputs__Slave 7B, DO1)) | UINT32 | RO | 0xF700:36, 1
1640:37 | SubIndex 055 | 55. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x37 (Slave 7 Outputs__Slave 7B, DO2)) | UINT32 | RO | 0xF700:37, 1
1640:38 | SubIndex 056 | 56. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x38 (Slave 7 Outputs__Slave 7B, DO3)) | UINT32 | RO | 0xF700:38, 1
1640:39 | SubIndex 057 | 57. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x39 (Slave 8 Outputs__Slave 8A, DO0)) | UINT32 | RO | 0xF700:39, 1
1640:3A | SubIndex 058 | 58. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x3A (Slave 8 Outputs__Slave 8A, DO1)) | UINT32 | RO | 0xF700:3A, 1
1640:3B | SubIndex 059 | 59. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x3B (Slave 8 Outputs__Slave 8A, DO2)) | UINT32 | RO | 0xF700:3B, 1
1640:3C | SubIndex 060 | 60. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x3C (Slave 8 Outputs__Slave 8A, DO3)) | UINT32 | RO | 0xF700:3C, 1
1640:3D | SubIndex 061 | 61. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x3D (Slave 8 Outputs__Slave 8B, DO0)) | UINT32 | RO | 0xF700:3D, 1
1640:3E | SubIndex 062 | 62. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x3E (Slave 8 Outputs__Slave 8B, DO1)) | UINT32 | RO | 0xF700:3E, 1
1640:3F | SubIndex 063 | 63. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x3F (Slave 8 Outputs__Slave 8B, DO2)) | UINT32 | RO | 0xF700:3F, 1
Index 1640 ASI RxPDO-Map Outputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1640:40 | SubIndex 064 | 64. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x40 (Slave 8 Outputs__Slave 8B, DO3)) | UINT32 | RO | 0xF700:40, 1
1640:41 | SubIndex 065 | 65. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x41 (Slave 9 Outputs__Slave 9A, DO0)) | UINT32 | RO | 0xF700:41, 1
1640:42 | SubIndex 066 | 66. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x42 (Slave 9 Outputs__Slave 9A, DO1)) | UINT32 | RO | 0xF700:42, 1
1640:43 | SubIndex 067 | 67. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x43 (Slave 9 Outputs__Slave 9A, DO2)) | UINT32 | RO | 0xF700:43, 1
1640:44 | SubIndex 068 | 68. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x44 (Slave 9 Outputs__Slave 9A, DO3)) | UINT32 | RO | 0xF700:44, 1
1640:45 | SubIndex 069 | 69. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x45 (Slave 9 Outputs__Slave 9B, DO0)) | UINT32 | RO | 0xF700:45, 1
1640:46 | SubIndex 070 | 70. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x46 (Slave 9 Outputs__Slave 9B, DO1)) | UINT32 | RO | 0xF700:46, 1
1640:47 | SubIndex 071 | 71. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x47 (Slave 9 Outputs__Slave 9B, DO2)) | UINT32 | RO | 0xF700:47, 1
1640:48 | SubIndex 072 | 72. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x48 (Slave 9 Outputs__Slave 9B, DO3)) | UINT32 | RO | 0xF700:48, 1
1640:49 | SubIndex 073 | 73. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x49 (Slave 10 Outputs__Slave 10A, DO0)) | UINT32 | RO | 0xF700:49, 1
1640:4A | SubIndex 074 | 74. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x4A (Slave 10 Outputs__Slave 10A, DO1)) | UINT32 | RO | 0xF700:4A, 1
1640:4B | SubIndex 075 | 75. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x4B (Slave 10 Outputs__Slave 10A, DO2)) | UINT32 | RO | 0xF700:4B, 1
1640:4C | SubIndex 076 | 76. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x4C (Slave 10 Outputs__Slave 10A, DO3)) | UINT32 | RO | 0xF700:4C, 1
1640:4D | SubIndex 077 | 77. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x4D (Slave 10 Outputs__Slave 10B, DO0)) | UINT32 | RO | 0xF700:4D, 1
1640:4E | SubIndex 078 | 78. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x4E (Slave 10 Outputs__Slave 10B, DO1)) | UINT32 | RO | 0xF700:4E, 1
1640:4F | SubIndex 079 | 79. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x4F (Slave 10 Outputs__Slave 10B, DO2)) | UINT32 | RO | 0xF700:4F, 1
Index 1640 ASI RxPDO-Map Outputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1640:50 | SubIndex 080 | 80. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x50 (Slave 10 Outputs__Slave 10B, DO3)) | UINT32 | RO | 0xF700:50, 1
1640:51 | SubIndex 081 | 81. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x51 (Slave 11 Outputs__Slave 11A, DO0)) | UINT32 | RO | 0xF700:51, 1
1640:52 | SubIndex 082 | 82. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x52 (Slave 11 Outputs__Slave 11A, DO1)) | UINT32 | RO | 0xF700:52, 1
1640:53 | SubIndex 083 | 83. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x53 (Slave 11 Outputs__Slave 11A, DO2)) | UINT32 | RO | 0xF700:53, 1
1640:54 | SubIndex 084 | 84. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x54 (Slave 11 Outputs__Slave 11A, DO3)) | UINT32 | RO | 0xF700:54, 1
1640:55 | SubIndex 085 | 85. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x55 (Slave 11 Outputs__Slave 11B, DO0)) | UINT32 | RO | 0xF700:55, 1
1640:56 | SubIndex 086 | 86. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x56 (Slave 11 Outputs__Slave 11B, DO1)) | UINT32 | RO | 0xF700:56, 1
1640:57 | SubIndex 087 | 87. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x57 (Slave 11 Outputs__Slave 11B, DO2)) | UINT32 | RO | 0xF700:57, 1
1640:58 | SubIndex 088 | 88. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x58 (Slave 11 Outputs__Slave 11B, DO3)) | UINT32 | RO | 0xF700:58, 1
1640:59 | SubIndex 089 | 89. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x59 (Slave 12 Outputs__Slave 12A, DO0)) | UINT32 | RO | 0xF700:59, 1
1640:5A | SubIndex 090 | 90. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x5A (Slave 12 Outputs__Slave 12A, DO1)) | UINT32 | RO | 0xF700:5A, 1
1640:5B | SubIndex 091 | 91. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x5B (Slave 12 Outputs__Slave 12A, DO2)) | UINT32 | RO | 0xF700:5B, 1
1640:5C | SubIndex 092 | 92. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x5C (Slave 12 Outputs__Slave 12A, DO3)) | UINT32 | RO | 0xF700:5C, 1
1640:5D | SubIndex 093 | 93. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x5D (Slave 12 Outputs__Slave 12B, DO0)) | UINT32 | RO | 0xF700:5D, 1
1640:5E | SubIndex 094 | 94. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x5E (Slave 12 Outputs__Slave 12B, DO1)) | UINT32 | RO | 0xF700:5E, 1
1640:5F | SubIndex 095 | 95. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x5F (Slave 12 Outputs__Slave 12B, DO2)) | UINT32 | RO | 0xF700:5F, 1
Index 1640 ASI RxPDO-Map Outputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1640:60 | SubIndex 096 | 96. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x60 (Slave 12 Outputs__Slave 12B, DO3)) | UINT32 | RO | 0xF700:60, 1
1640:61 | SubIndex 097 | 97. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x61 (Slave 13 Outputs__Slave 13A, DO0)) | UINT32 | RO | 0xF700:61, 1
1640:62 | SubIndex 098 | 98. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x62 (Slave 13 Outputs__Slave 13A, DO1)) | UINT32 | RO | 0xF700:62, 1
1640:63 | SubIndex 099 | 99. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x63 (Slave 13 Outputs__Slave 13A, DO2)) | UINT32 | RO | 0xF700:63, 1
1640:64 | SubIndex 100 | 100. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x64 (Slave 13 Outputs__Slave 13A, DO3)) | UINT32 | RO | 0xF700:64, 1
1640:65 | SubIndex 101 | 101. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x65 (Slave 13 Outputs__Slave 13B, DO0)) | UINT32 | RO | 0xF700:65, 1
1640:66 | SubIndex 102 | 102. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x66 (Slave 13 Outputs__Slave 13B, DO1)) | UINT32 | RO | 0xF700:66, 1
1640:67 | SubIndex 103 | 103. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x67 (Slave 13 Outputs__Slave 13B, DO2)) | UINT32 | RO | 0xF700:67, 1
1640:68 | SubIndex 104 | 104. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x68 (Slave 13 Outputs__Slave 13B, DO3)) | UINT32 | RO | 0xF700:68, 1
1640:69 | SubIndex 105 | 105. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x69 (Slave 14 Outputs__Slave 14A, DO0)) | UINT32 | RO | 0xF700:69, 1
1640:6A | SubIndex 106 | 106. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x6A (Slave 14 Outputs__Slave 14A, DO1)) | UINT32 | RO | 0xF700:6A, 1
1640:6B | SubIndex 107 | 107. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x6B (Slave 14 Outputs__Slave 14A, DO2)) | UINT32 | RO | 0xF700:6B, 1
1640:6C | SubIndex 108 | 108. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x6C (Slave 14 Outputs__Slave 14A, DO3)) | UINT32 | RO | 0xF700:6C, 1
1640:6D | SubIndex 109 | 109. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x6D (Slave 14 Outputs__Slave 14B, DO0)) | UINT32 | RO | 0xF700:6D, 1
1640:6E | SubIndex 110 | 110. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x6E (Slave 14 Outputs__Slave 14B, DO1)) | UINT32 | RO | 0xF700:6E, 1
1640:6F | SubIndex 111 | 111. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x6F (Slave 14 Outputs__Slave 14B, DO2)) | UINT32 | RO | 0xF700:6F, 1
Index 1640 ASI RxPDO-Map Outputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1640:70 | SubIndex 112 | 112. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x70 (Slave 14 Outputs__Slave 14B, DO3)) | UINT32 | RO | 0xF700:70, 1
1640:71 | SubIndex 113 | 113. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x71 (Slave 15 Outputs__Slave 15A, DO0)) | UINT32 | RO | 0xF700:71, 1
1640:72 | SubIndex 114 | 114. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x72 (Slave 15 Outputs__Slave 15A, DO1)) | UINT32 | RO | 0xF700:72, 1
1640:73 | SubIndex 115 | 115. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x73 (Slave 15 Outputs__Slave 15A, DO2)) | UINT32 | RO | 0xF700:73, 1
1640:74 | SubIndex 116 | 116. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x74 (Slave 15 Outputs__Slave 15A, DO3)) | UINT32 | RO | 0xF700:74, 1
1640:75 | SubIndex 117 | 117. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x75 (Slave 15 Outputs__Slave 15B, DO0)) | UINT32 | RO | 0xF700:75, 1
1640:76 | SubIndex 118 | 118. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x76 (Slave 15 Outputs__Slave 15B, DO1)) | UINT32 | RO | 0xF700:76, 1
1640:77 | SubIndex 119 | 119. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x77 (Slave 15 Outputs__Slave 15B, DO2)) | UINT32 | RO | 0xF700:77, 1
1640:78 | SubIndex 120 | 120. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x78 (Slave 15 Outputs__Slave 15B, DO3)) | UINT32 | RO | 0xF700:78, 1
1640:79 | SubIndex 121 | 121. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x79 (Slave 16 Outputs__Slave 16A, DO0)) | UINT32 | RO | 0xF700:79, 1
1640:7A | SubIndex 122 | 122. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x7A (Slave 16 Outputs__Slave 16A, DO1)) | UINT32 | RO | 0xF700:7A, 1
1640:7B | SubIndex 123 | 123. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x7B (Slave 16 Outputs__Slave 16A, DO2)) | UINT32 | RO | 0xF700:7B, 1
1640:7C | SubIndex 124 | 124. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x7C (Slave 16 Outputs__Slave 16A, DO3)) | UINT32 | RO | 0xF700:7C, 1
1640:7D | SubIndex 125 | 125. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x7D (Slave 16 Outputs__Slave 16B, DO0)) | UINT32 | RO | 0xF700:7D, 1
1640:7E | SubIndex 126 | 126. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x7E (Slave 16 Outputs__Slave 16B, DO1)) | UINT32 | RO | 0xF700:7E, 1
1640:7F | SubIndex 127 | 127. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x7F (Slave 16 Outputs__Slave 16B, DO2)) | UINT32 | RO | 0xF700:7F, 1
Index 1640 ASI RxPDO-Map Outputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1640:80 | SubIndex 128 | 128. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x80 (Slave 16 Outputs__Slave 16B, DO3)) | UINT32 | RO | 0xF700:80, 1
1640:81 | SubIndex 129 | 129. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x81 (Slave 17 Outputs__Slave 17A, DO0)) | UINT32 | RO | 0xF700:81, 1
1640:82 | SubIndex 130 | 130. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x82 (Slave 17 Outputs__Slave 17A, DO1)) | UINT32 | RO | 0xF700:82, 1
1640:83 | SubIndex 131 | 131. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x83 (Slave 17 Outputs__Slave 17A, DO2)) | UINT32 | RO | 0xF700:83, 1
1640:84 | SubIndex 132 | 132. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x84 (Slave 17 Outputs__Slave 17A, DO3)) | UINT32 | RO | 0xF700:84, 1
1640:85 | SubIndex 133 | 133. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x85 (Slave 17 Outputs__Slave 17B, DO0)) | UINT32 | RO | 0xF700:85, 1
1640:86 | SubIndex 134 | 134. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x86 (Slave 17 Outputs__Slave 17B, DO1)) | UINT32 | RO | 0xF700:86, 1
1640:87 | SubIndex 135 | 135. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x87 (Slave 17 Outputs__Slave 17B, DO2)) | UINT32 | RO | 0xF700:87, 1
1640:88 | SubIndex 136 | 136. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x88 (Slave 17 Outputs__Slave 17B, DO3)) | UINT32 | RO | 0xF700:88, 1
1640:89 | SubIndex 137 | 137. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x89 (Slave 18 Outputs__Slave 18A, DO0)) | UINT32 | RO | 0xF700:89, 1
1640:8A | SubIndex 138 | 138. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x8A (Slave 18 Outputs__Slave 18A, DO1)) | UINT32 | RO | 0xF700:8A, 1
1640:8B | SubIndex 139 | 139. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x8B (Slave 18 Outputs__Slave 18A, DO2)) | UINT32 | RO | 0xF700:8B, 1
1640:8C | SubIndex 140 | 140. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x8C (Slave 18 Outputs__Slave 18A, DO3)) | UINT32 | RO | 0xF700:8C, 1
1640:8D | SubIndex 141 | 141. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x8D (Slave 18 Outputs__Slave 18B, DO0)) | UINT32 | RO | 0xF700:8D, 1
1640:8E | SubIndex 142 | 142. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x8E (Slave 18 Outputs__Slave 18B, DO1)) | UINT32 | RO | 0xF700:8E, 1
1640:8F | SubIndex 143 | 143. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x8F (Slave 18 Outputs__Slave 18B, DO2)) | UINT32 | RO | 0xF700:8F, 1
Index 1640 ASI RxPDO-Map Outputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1640:90 | SubIndex 144 | 144. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x90 (Slave 18 Outputs__Slave 18B, DO3)) | UINT32 | RO | 0xF700:90, 1
1640:91 | SubIndex 145 | 145. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x91 (Slave 19 Outputs__Slave 19A, DO0)) | UINT32 | RO | 0xF700:91, 1
1640:92 | SubIndex 146 | 146. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x92 (Slave 19 Outputs__Slave 19A, DO1)) | UINT32 | RO | 0xF700:92, 1
1640:93 | SubIndex 147 | 147. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x93 (Slave 19 Outputs__Slave 19A, DO2)) | UINT32 | RO | 0xF700:93, 1
1640:94 | SubIndex 148 | 148. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x94 (Slave 19 Outputs__Slave 19A, DO3)) | UINT32 | RO | 0xF700:94, 1
1640:95 | SubIndex 149 | 149. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x95 (Slave 19 Outputs__Slave 19B, DO0)) | UINT32 | RO | 0xF700:95, 1
1640:96 | SubIndex 150 | 150. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x96 (Slave 19 Outputs__Slave 19B, DO1)) | UINT32 | RO | 0xF700:96, 1
1640:97 | SubIndex 151 | 151. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x97 (Slave 19 Outputs__Slave 19B, DO2)) | UINT32 | RO | 0xF700:97, 1
1640:98 | SubIndex 152 | 152. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x98 (Slave 19 Outputs__Slave 19B, DO3)) | UINT32 | RO | 0xF700:98, 1
1640:99 | SubIndex 153 | 153. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x99 (Slave 20 Outputs__Slave 20A, DO0)) | UINT32 | RO | 0xF700:99, 1
1640:9A | SubIndex 154 | 154. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x9A (Slave 20 Outputs__Slave 20A, DO1)) | UINT32 | RO | 0xF700:9A, 1
1640:9B | SubIndex 155 | 155. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x9B (Slave 20 Outputs__Slave 20A, DO2)) | UINT32 | RO | 0xF700:9B, 1
1640:9C | SubIndex 156 | 156. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x9C (Slave 20 Outputs__Slave 20A, DO3)) | UINT32 | RO | 0xF700:9C, 1
1640:9D | SubIndex 157 | 157. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x9D (Slave 20 Outputs__Slave 20B, DO0)) | UINT32 | RO | 0xF700:9D, 1
1640:9E | SubIndex 158 | 158. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x9E (Slave 20 Outputs__Slave 20B, DO1)) | UINT32 | RO | 0xF700:9E, 1
1640:9F | SubIndex 159 | 159. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x9F (Slave 20 Outputs__Slave 20B, DO2)) | UINT32 | RO | 0xF700:9F, 1
Index 1640 ASI RxPDO-Map Outputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1640:A0 | SubIndex 160 | 160. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xA0 (Slave 20 Outputs__Slave 20B, DO3)) | UINT32 | RO | 0xF700:A0, 1
1640:A1 | SubIndex 161 | 161. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xA1 (Slave 21 Outputs__Slave 21A, DO0)) | UINT32 | RO | 0xF700:A1, 1
1640:A2 | SubIndex 162 | 162. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xA2 (Slave 21 Outputs__Slave 21A, DO1)) | UINT32 | RO | 0xF700:A2, 1
1640:A3 | SubIndex 163 | 163. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xA3 (Slave 21 Outputs__Slave 21A, DO2)) | UINT32 | RO | 0xF700:A3, 1
1640:A4 | SubIndex 164 | 164. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xA4 (Slave 21 Outputs__Slave 21A, DO3)) | UINT32 | RO | 0xF700:A4, 1
1640:A5 | SubIndex 165 | 165. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xA5 (Slave 21 Outputs__Slave 21B, DO0)) | UINT32 | RO | 0xF700:A5, 1
1640:A6 | SubIndex 166 | 166. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xA6 (Slave 21 Outputs__Slave 21B, DO1)) | UINT32 | RO | 0xF700:A6, 1
1640:A7 | SubIndex 167 | 167. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xA7 (Slave 21 Outputs__Slave 21B, DO2)) | UINT32 | RO | 0xF700:A7, 1
1640:A8 | SubIndex 168 | 168. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xA8 (Slave 21 Outputs__Slave 21B, DO3)) | UINT32 | RO | 0xF700:A8, 1
1640:A9 | SubIndex 169 | 169. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xA9 (Slave 22 Outputs__Slave 22A, DO0)) | UINT32 | RO | 0xF700:A9, 1
1640:AA | SubIndex 170 | 170. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xAA (Slave 22 Outputs__Slave 22A, DO1)) | UINT32 | RO | 0xF700:AA, 1
1640:AB | SubIndex 171 | 171. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xAB (Slave 22 Outputs__Slave 22A, DO2)) | UINT32 | RO | 0xF700:AB, 1
1640:AC | SubIndex 172 | 172. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xAC (Slave 22 Outputs__Slave 22A, DO3)) | UINT32 | RO | 0xF700:AC, 1
1640:AD | SubIndex 173 | 173. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xAD (Slave 22 Outputs__Slave 22B, DO0)) | UINT32 | RO | 0xF700:AD, 1
1640:AE | SubIndex 174 | 174. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xAE (Slave 22 Outputs__Slave 22B, DO1)) | UINT32 | RO | 0xF700:AE, 1
1640:AF | SubIndex 175 | 175. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xAF (Slave 22 Outputs__Slave 22B, DO2)) | UINT32 | RO | 0xF700:AF, 1
Index 1640 ASI RxPDO-Map Outputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1640:B0 | SubIndex 176 | 176. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xB0 (Slave 22 Outputs__Slave 22B, DO3)) | UINT32 | RO | 0xF700:B0, 1
1640:B1 | SubIndex 177 | 177. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xB1 (Slave 23 Outputs__Slave 23A, DO0)) | UINT32 | RO | 0xF700:B1, 1
1640:B2 | SubIndex 178 | 178. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xB2 (Slave 23 Outputs__Slave 23A, DO1)) | UINT32 | RO | 0xF700:B2, 1
1640:B3 | SubIndex 179 | 179. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xB3 (Slave 23 Outputs__Slave 23A, DO2)) | UINT32 | RO | 0xF700:B3, 1
1640:B4 | SubIndex 180 | 180. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xB4 (Slave 23 Outputs__Slave 23A, DO3)) | UINT32 | RO | 0xF700:B4, 1
1640:B5 | SubIndex 181 | 181. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xB5 (Slave 23 Outputs__Slave 23B, DO0)) | UINT32 | RO | 0xF700:B5, 1
1640:B6 | SubIndex 182 | 182. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xB6 (Slave 23 Outputs__Slave 23B, DO1)) | UINT32 | RO | 0xF700:B6, 1
1640:B7 | SubIndex 183 | 183. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xB7 (Slave 23 Outputs__Slave 23B, DO2)) | UINT32 | RO | 0xF700:B7, 1
1640:B8 | SubIndex 184 | 184. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xB8 (Slave 23 Outputs__Slave 23B, DO3)) | UINT32 | RO | 0xF700:B8, 1
1640:B9 | SubIndex 185 | 185. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xB9 (Slave 24 Outputs__Slave 24A, DO0)) | UINT32 | RO | 0xF700:B9, 1
1640:BA | SubIndex 186 | 186. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xBA (Slave 24 Outputs__Slave 24A, DO1)) | UINT32 | RO | 0xF700:BA, 1
1640:BB | SubIndex 187 | 187. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xBB (Slave 24 Outputs__Slave 24A, DO2)) | UINT32 | RO | 0xF700:BB, 1
1640:BC | SubIndex 188 | 188. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xBC (Slave 24 Outputs__Slave 24A, DO3)) | UINT32 | RO | 0xF700:BC, 1
1640:BD | SubIndex 189 | 189. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xBD (Slave 24 Outputs__Slave 24B, DO0)) | UINT32 | RO | 0xF700:BD, 1
1640:BE | SubIndex 190 | 190. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xBE (Slave 24 Outputs__Slave 24B, DO1)) | UINT32 | RO | 0xF700:BE, 1
1640:BF | SubIndex 191 | 191. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xBF (Slave 24 Outputs__Slave 24B, DO2)) | UINT32 | RO | 0xF700:BF, 1
Index 1640 ASI RxPDO-Map Outputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1640:C0 | SubIndex 192 | 192. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xC0 (Slave 24 Outputs__Slave 24B, DO3)) | UINT32 | RO | 0xF700:C0, 1
1640:C1 | SubIndex 193 | 193. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xC1 (Slave 25 Outputs__Slave 25A, DO0)) | UINT32 | RO | 0xF700:C1, 1
1640:C2 | SubIndex 194 | 194. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xC2 (Slave 25 Outputs__Slave 25A, DO1)) | UINT32 | RO | 0xF700:C2, 1
1640:C3 | SubIndex 195 | 195. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xC3 (Slave 25 Outputs__Slave 25A, DO2)) | UINT32 | RO | 0xF700:C3, 1
1640:C4 | SubIndex 196 | 196. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xC4 (Slave 25 Outputs__Slave 25A, DO3)) | UINT32 | RO | 0xF700:C4, 1
1640:C5 | SubIndex 197 | 197. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xC5 (Slave 25 Outputs__Slave 25B, DO0)) | UINT32 | RO | 0xF700:C5, 1
1640:C6 | SubIndex 198 | 198. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xC6 (Slave 25 Outputs__Slave 25B, DO1)) | UINT32 | RO | 0xF700:C6, 1
1640:C7 | SubIndex 199 | 199. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xC7 (Slave 25 Outputs__Slave 25B, DO2)) | UINT32 | RO | 0xF700:C7, 1
1640:C8 | SubIndex 200 | 200. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xC8 (Slave 25 Outputs__Slave 25B, DO3)) | UINT32 | RO | 0xF700:C8, 1
1640:C9 | SubIndex 201 | 201. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xC9 (Slave 26 Outputs__Slave 26A, DO0)) | UINT32 | RO | 0xF700:C9, 1
1640:CA | SubIndex 202 | 202. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xCA (Slave 26 Outputs__Slave 26A, DO1)) | UINT32 | RO | 0xF700:CA, 1
1640:CB | SubIndex 203 | 203. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xCB (Slave 26 Outputs__Slave 26A, DO2)) | UINT32 | RO | 0xF700:CB, 1
1640:CC | SubIndex 204 | 204. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xCC (Slave 26 Outputs__Slave 26A, DO3)) | UINT32 | RO | 0xF700:CC, 1
1640:CD | SubIndex 205 | 205. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xCD (Slave 26 Outputs__Slave 26B, DO0)) | UINT32 | RO | 0xF700:CD, 1
1640:CE | SubIndex 206 | 206. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xCE (Slave 26 Outputs__Slave 26B, DO1)) | UINT32 | RO | 0xF700:CE, 1
1640:CF | SubIndex 207 | 207. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xCF (Slave 26 Outputs__Slave 26B, DO2)) | UINT32 | RO | 0xF700:CF, 1
Index 1640 ASI RxPDO-Map Outputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1640:D0 | SubIndex 208 | 208. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xD0 (Slave 26 Outputs__Slave 26B, DO3)) | UINT32 | RO | 0xF700:D0, 1
1640:D1 | SubIndex 209 | 209. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xD1 (Slave 27 Outputs__Slave 27A, DO0)) | UINT32 | RO | 0xF700:D1, 1
1640:D2 | SubIndex 210 | 210. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xD2 (Slave 27 Outputs__Slave 27A, DO1)) | UINT32 | RO | 0xF700:D2, 1
1640:D3 | SubIndex 211 | 211. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xD3 (Slave 27 Outputs__Slave 27A, DO2)) | UINT32 | RO | 0xF700:D3, 1
1640:D4 | SubIndex 212 | 212. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xD4 (Slave 27 Outputs__Slave 27A, DO3)) | UINT32 | RO | 0xF700:D4, 1
1640:D5 | SubIndex 213 | 213. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xD5 (Slave 27 Outputs__Slave 27B, DO0)) | UINT32 | RO | 0xF700:D5, 1
1640:D6 | SubIndex 214 | 214. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xD6 (Slave 27 Outputs__Slave 27B, DO1)) | UINT32 | RO | 0xF700:D6, 1
1640:D7 | SubIndex 215 | 215. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xD7 (Slave 27 Outputs__Slave 27B, DO2)) | UINT32 | RO | 0xF700:D7, 1
1640:D8 | SubIndex 216 | 216. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xD8 (Slave 27 Outputs__Slave 27B, DO3)) | UINT32 | RO | 0xF700:D8, 1
1640:D9 | SubIndex 217 | 217. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xD9 (Slave 28 Outputs__Slave 28A, DO0)) | UINT32 | RO | 0xF700:D9, 1
1640:DA | SubIndex 218 | 218. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xDA (Slave 28 Outputs__Slave 28A, DO1)) | UINT32 | RO | 0xF700:DA, 1
1640:DB | SubIndex 219 | 219. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xDB (Slave 28 Outputs__Slave 28A, DO2)) | UINT32 | RO | 0xF700:DB, 1
1640:DC | SubIndex 220 | 220. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xDC (Slave 28 Outputs__Slave 28A, DO3)) | UINT32 | RO | 0xF700:DC, 1
1640:DD | SubIndex 221 | 221. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xDD (Slave 28 Outputs__Slave 28B, DO0)) | UINT32 | RO | 0xF700:DD, 1
1640:DE | SubIndex 222 | 222. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xDE (Slave 28 Outputs__Slave 28B, DO1)) | UINT32 | RO | 0xF700:DE, 1
1640:DF | SubIndex 223 | 223. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xDF (Slave 28 Outputs__Slave 28B, DO2)) | UINT32 | RO | 0xF700:DF, 1
Index 1640 ASI RxPDO-Map Outputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1640:E0 | SubIndex 224 | 224. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xE0 (Slave 28 Outputs__Slave 28B, DO3)) | UINT32 | RO | 0xF700:E0, 1
1640:E1 | SubIndex 225 | 225. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xE1 (Slave 29 Outputs__Slave 29A, DO0)) | UINT32 | RO | 0xF700:E1, 1
1640:E2 | SubIndex 226 | 226. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xE2 (Slave 29 Outputs__Slave 29A, DO1)) | UINT32 | RO | 0xF700:E2, 1
1640:E3 | SubIndex 227 | 227. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xE3 (Slave 29 Outputs__Slave 29A, DO2)) | UINT32 | RO | 0xF700:E3, 1
1640:E4 | SubIndex 228 | 228. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xE4 (Slave 29 Outputs__Slave 29A, DO3)) | UINT32 | RO | 0xF700:E4, 1
1640:E5 | SubIndex 229 | 229. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xE5 (Slave 29 Outputs__Slave 29B, DO0)) | UINT32 | RO | 0xF700:E5, 1
1640:E6 | SubIndex 230 | 230. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xE6 (Slave 29 Outputs__Slave 29B, DO1)) | UINT32 | RO | 0xF700:E6, 1
1640:E7 | SubIndex 231 | 231. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xE7 (Slave 29 Outputs__Slave 29B, DO2)) | UINT32 | RO | 0xF700:E7, 1
1640:E8 | SubIndex 232 | 232. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xE8 (Slave 29 Outputs__Slave 29B, DO3)) | UINT32 | RO | 0xF700:E8, 1
1640:E9 | SubIndex 233 | 233. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xE9 (Slave 30 Outputs__Slave 30A, DO0)) | UINT32 | RO | 0xF700:E9, 1
1640:EA | SubIndex 234 | 234. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xEA (Slave 30 Outputs__Slave 30A, DO1)) | UINT32 | RO | 0xF700:EA, 1
1640:EB | SubIndex 235 | 235. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xEB (Slave 30 Outputs__Slave 30A, DO2)) | UINT32 | RO | 0xF700:EB, 1
1640:EC | SubIndex 236 | 236. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xEC (Slave 30 Outputs__Slave 30A, DO3)) | UINT32 | RO | 0xF700:EC, 1
1640:ED | SubIndex 237 | 237. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xED (Slave 30 Outputs__Slave 30B, DO0)) | UINT32 | RO | 0xF700:ED, 1
1640:EE | SubIndex 238 | 238. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xEE (Slave 30 Outputs__Slave 30B, DO1)) | UINT32 | RO | 0xF700:EE, 1
1640:EF | SubIndex 239 | 239. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xEF (Slave 30 Outputs__Slave 30B, DO2)) | UINT32 | RO | 0xF700:EF, 1
Index 1640 ASI RxPDO-Map Outputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1640:F0 | SubIndex 240 | 240. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xF0 (Slave 30 Outputs__Slave 30B, DO3)) | UINT32 | RO | 0xF700:F0, 1
1640:F1 | SubIndex 241 | 241. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xF1 (Slave 31 Outputs__Slave 31A, DO0)) | UINT32 | RO | 0xF700:F1, 1
1640:F2 | SubIndex 242 | 242. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xF2 (Slave 31 Outputs__Slave 31A, DO1)) | UINT32 | RO | 0xF700:F2, 1
1640:F3 | SubIndex 243 | 243. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xF3 (Slave 31 Outputs__Slave 31A, DO2)) | UINT32 | RO | 0xF700:F3, 1
1640:F4 | SubIndex 244 | 244. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xF4 (Slave 31 Outputs__Slave 31A, DO3)) | UINT32 | RO | 0xF700:F4, 1
1640:F5 | SubIndex 245 | 245. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xF5 (Slave 31 Outputs__Slave 31B, DO0)) | UINT32 | RO | 0xF700:F5, 1
1640:F6 | SubIndex 246 | 246. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xF6 (Slave 31 Outputs__Slave 31B, DO1)) | UINT32 | RO | 0xF700:F6, 1
1640:F7 | SubIndex 247 | 247. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xF7 (Slave 31 Outputs__Slave 31B, DO2)) | UINT32 | RO | 0xF700:F7, 1
1640:F8 | SubIndex 248 | 248. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xF8 (Slave 31 Outputs__Slave 31B, DO3)) | UINT32 | RO | 0xF700:F8, 1
Index 1680 ASI RxPDO-Map Control
Index (hex) | Name | Meaning | Data type | Flags | Default
1680:0 | ASI RxPDO-Map Control | PDO Mapping RxPDO 129 | UINT8 | RO | 0x06 (6dec)
1680:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF200 (ASI Control), entry 0x01 (Auto Programming Enable)) | UINT32 | RO | 0xF200:01, 1
1680:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF200 (ASI Control), entry 0x02 (Go Offline Mode)) | UINT32 | RO | 0xF200:02, 1
1680:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF200 (ASI Control), entry 0x03 (Data Exchange Active)) | UINT32 | RO | 0xF200:03, 1
1680:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF200 (ASI Control), entry 0x04 (Go Protected Mode)) | UINT32 | RO | 0xF200:04, 1
1680:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF200 (ASI Control), entry 0x05 (Go Configuration Mode)) | UINT32 | RO | 0xF200:05, 1
1680:06 | SubIndex 006 | 6. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
Index 1A01 ASI TxPDO-Map Analog Inputs Slave 1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A01:0 | ASI TxPDO-Map Analog Inputs Slave 1 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x08 (8dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (ASI Analog Inputs Slave 1 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6010:01, 16
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (ASI Analog Inputs Slave 1 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6010:02, 16
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (ASI Analog Inputs Slave 1 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6010:03, 16
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (ASI Analog Inputs Slave 1 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6010:04, 16
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (ASI Analog Inputs Slave 1 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6010:05, 16
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (ASI Analog Inputs Slave 1 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6010:06, 16
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (ASI Analog Inputs Slave 1 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6010:07, 16
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (ASI Analog Inputs Slave 1 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6010:08, 16
Index 1A02 ASI TxPDO-Map Analog Inputs Slave 2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A02:0 | ASI TxPDO-Map Analog Inputs Slave 2 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x08 (8dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (ASI Analog Inputs Slave 2 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6020:01, 16
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (ASI Analog Inputs Slave 2 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6020:02, 16
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (ASI Analog Inputs Slave 2 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6020:03, 16
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (ASI Analog Inputs Slave 2 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6020:04, 16
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (ASI Analog Inputs Slave 2 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6020:05, 16
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6020 (ASI Analog Inputs Slave 2 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6020:06, 16
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020 (ASI Analog Inputs Slave 2 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6020:07, 16
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6020 (ASI Analog Inputs Slave 2 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6020:08, 16
Index 1A03 ASI TxPDO-Map Analog Inputs Slave 3
Index (hex) | Name | Meaning | Data type | Flags | Default
1A03:0 | ASI TxPDO-Map Analog Inputs Slave 3 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x08 (8dec)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6030 (ASI Analog Inputs Slave 3 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6030:01, 16
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6030 (ASI Analog Inputs Slave 3 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6030:02, 16
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6030 (ASI Analog Inputs Slave 3 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6030:03, 16
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6030 (ASI Analog Inputs Slave 3 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6030:04, 16
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6030 (ASI Analog Inputs Slave 3 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6030:05, 16
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6030 (ASI Analog Inputs Slave 3 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6030:06, 16
1A03:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6030 (ASI Analog Inputs Slave 3 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6030:07, 16
1A03:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6030 (ASI Analog Inputs Slave 3 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6030:08, 16
Index 1A04 ASI TxPDO-Map Analog Inputs Slave 4
Index (hex) | Name | Meaning | Data type | Flags | Default
1A04:0 | ASI TxPDO-Map Analog Inputs Slave 4 | PDO Mapping TxPDO 5 | UINT8 | RO | 0x08 (8dec)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6040 (ASI Analog Inputs Slave 4 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6040:01, 16
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6040 (ASI Analog Inputs Slave 4 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6040:02, 16
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6040 (ASI Analog Inputs Slave 4 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6040:03, 16
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6040 (ASI Analog Inputs Slave 4 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6040:04, 16
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6040 (ASI Analog Inputs Slave 4 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6040:05, 16
1A04:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6040 (ASI Analog Inputs Slave 4 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6040:06, 16
1A04:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6040 (ASI Analog Inputs Slave 4 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6040:07, 16
1A04:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6040 (ASI Analog Inputs Slave 4 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6040:08, 16
Index 1A05 ASI TxPDO-Map Analog Inputs Slave 5
Index (hex) | Name | Meaning | Data type | Flags | Default
1A05:0 | ASI TxPDO-Map Analog Inputs Slave 5 | PDO Mapping TxPDO 6 | UINT8 | RO | 0x08 (8dec)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6050 (ASI Analog Inputs Slave 5 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6050:01, 16
1A05:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6050 (ASI Analog Inputs Slave 5 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6050:02, 16
1A05:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6050 (ASI Analog Inputs Slave 5 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6050:03, 16
1A05:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6050 (ASI Analog Inputs Slave 5 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6050:04, 16
1A05:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6050 (ASI Analog Inputs Slave 5 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6050:05, 16
1A05:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6050 (ASI Analog Inputs Slave 5 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6050:06, 16
1A05:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6050 (ASI Analog Inputs Slave 5 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6050:07, 16
1A05:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6050 (ASI Analog Inputs Slave 5 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6050:08, 16
Index 1A06 ASI TxPDO-Map Analog Inputs Slave 6
Index (hex) | Name | Meaning | Data type | Flags | Default
1A06:0 | ASI TxPDO-Map Analog Inputs Slave 6 | PDO Mapping TxPDO 7 | UINT8 | RO | 0x08 (8dec)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6060 (ASI Analog Inputs Slave 6 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6060:01, 16
1A06:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6060 (ASI Analog Inputs Slave 6 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6060:02, 16
1A06:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6060 (ASI Analog Inputs Slave 6 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6060:03, 16
1A06:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6060 (ASI Analog Inputs Slave 6 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6060:04, 16
1A06:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6060 (ASI Analog Inputs Slave 6 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6060:05, 16
1A06:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6060 (ASI Analog Inputs Slave 6 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6060:06, 16
1A06:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6060 (ASI Analog Inputs Slave 6 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6060:07, 16
1A06:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6060 (ASI Analog Inputs Slave 6 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6060:08, 16
Index 1A07 ASI TxPDO-Map Analog Inputs Slave 7
Index (hex) | Name | Meaning | Data type | Flags | Default
1A07:0 | ASI TxPDO-Map Analog Inputs Slave 7 | PDO Mapping TxPDO 8 | UINT8 | RO | 0x08 (8dec)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6070 (ASI Analog Inputs Slave 7 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6070:01, 16
1A07:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6070 (ASI Analog Inputs Slave 7 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6070:02, 16
1A07:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6070 (ASI Analog Inputs Slave 7 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6070:03, 16
1A07:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6070 (ASI Analog Inputs Slave 7 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6070:04, 16
1A07:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6070 (ASI Analog Inputs Slave 7 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6070:05, 16
1A07:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6070 (ASI Analog Inputs Slave 7 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6070:06, 16
1A07:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6070 (ASI Analog Inputs Slave 7 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6070:07, 16
1A07:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6070 (ASI Analog Inputs Slave 7 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6070:08, 16
Index 1A08 ASI TxPDO-Map Analog Inputs Slave 8
Index (hex) | Name | Meaning | Data type | Flags | Default
1A08:0 | ASI TxPDO-Map Analog Inputs Slave 8 | PDO Mapping TxPDO 9 | UINT8 | RO | 0x08 (8dec)
1A08:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6080 (ASI Analog Inputs Slave 8 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6080:01, 16
1A08:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6080 (ASI Analog Inputs Slave 8 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6080:02, 16
1A08:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6080 (ASI Analog Inputs Slave 8 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6080:03, 16
1A08:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6080 (ASI Analog Inputs Slave 8 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6080:04, 16
1A08:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6080 (ASI Analog Inputs Slave 8 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6080:05, 16
1A08:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6080 (ASI Analog Inputs Slave 8 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6080:06, 16
1A08:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6080 (ASI Analog Inputs Slave 8 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6080:07, 16
1A08:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6080 (ASI Analog Inputs Slave 8 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6080:08, 16
Index 1A09 ASI TxPDO-Map Analog Inputs Slave 9
Index (hex) | Name | Meaning | Data type | Flags | Default
1A09:0 | ASI TxPDO-Map Analog Inputs Slave 9 | PDO Mapping TxPDO 10 | UINT8 | RO | 0x08 (8dec)
1A09:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6090 (ASI Analog Inputs Slave 9 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6090:01, 16
1A09:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6090 (ASI Analog Inputs Slave 9 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6090:02, 16
1A09:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6090 (ASI Analog Inputs Slave 9 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6090:03, 16
1A09:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6090 (ASI Analog Inputs Slave 9 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6090:04, 16
1A09:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6090 (ASI Analog Inputs Slave 9 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6090:05, 16
1A09:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6090 (ASI Analog Inputs Slave 9 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6090:06, 16
1A09:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6090 (ASI Analog Inputs Slave 9 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6090:07, 16
1A09:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6090 (ASI Analog Inputs Slave 9 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6090:08, 16
Index 1A0A ASI TxPDO-Map Analog Inputs Slave 10
Index (hex) | Name | Meaning | Data type | Flags | Default
1A0A:0 | ASI TxPDO-Map Analog Inputs Slave 10 | PDO Mapping TxPDO 11 | UINT8 | RO | 0x08 (8dec)
1A0A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60A0 (ASI Analog Inputs Slave 10 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x60A0:01, 16
1A0A:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60A0 (ASI Analog Inputs Slave 10 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x60A0:02, 16
1A0A:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60A0 (ASI Analog Inputs Slave 10 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x60A0:03, 16
1A0A:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60A0 (ASI Analog Inputs Slave 10 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x60A0:04, 16
1A0A:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60A0 (ASI Analog Inputs Slave 10 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x60A0:05, 16
1A0A:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60A0 (ASI Analog Inputs Slave 10 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x60A0:06, 16
1A0A:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60A0 (ASI Analog Inputs Slave 10 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x60A0:07, 16
1A0A:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60A0 (ASI Analog Inputs Slave 10 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x60A0:08, 16
Index 1A0B ASI TxPDO-Map Analog Inputs Slave 11
Index (hex) | Name | Meaning | Data type | Flags | Default
1A0B:0 | ASI TxPDO-Map Analog Inputs Slave 11 | PDO Mapping TxPDO 12 | UINT8 | RO | 0x08 (8dec)
1A0B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60B0 (ASI Analog Inputs Slave 11 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x60B0:01, 16
1A0B:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60B0 (ASI Analog Inputs Slave 11 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x60B0:02, 16
1A0B:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60B0 (ASI Analog Inputs Slave 11 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x60B0:03, 16
1A0B:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60B0 (ASI Analog Inputs Slave 11 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x60B0:04, 16
1A0B:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60B0 (ASI Analog Inputs Slave 11 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x60B0:05, 16
1A0B:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60B0 (ASI Analog Inputs Slave 11 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x60B0:06, 16
1A0B:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60B0 (ASI Analog Inputs Slave 11 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x60B0:07, 16
1A0B:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60B0 (ASI Analog Inputs Slave 11 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x60B0:08, 16
Index 1A0C ASI TxPDO-Map Analog Inputs Slave 12
Index (hex) | Name | Meaning | Data type | Flags | Default
1A0C:0 | ASI TxPDO-Map Analog Inputs Slave 12 | PDO Mapping TxPDO 13 | UINT8 | RO | 0x08 (8dec)
1A0C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60C0 (ASI Analog Inputs Slave 12 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x60C0:01, 16
1A0C:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60C0 (ASI Analog Inputs Slave 12 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x60C0:02, 16
1A0C:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60C0 (ASI Analog Inputs Slave 12 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x60C0:03, 16
1A0C:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60C0 (ASI Analog Inputs Slave 12 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x60C0:04, 16
1A0C:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60C0 (ASI Analog Inputs Slave 12 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x60C0:05, 16
1A0C:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60C0 (ASI Analog Inputs Slave 12 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x60C0:06, 16
1A0C:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60C0 (ASI Analog Inputs Slave 12 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x60C0:07, 16
1A0C:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60C0 (ASI Analog Inputs Slave 12 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x60C0:08, 16
Index 1A0D ASI TxPDO-Map Analog Inputs Slave 13
Index (hex) | Name | Meaning | Data type | Flags | Default
1A0D:0 | ASI TxPDO-Map Analog Inputs Slave 13 | PDO Mapping TxPDO 14 | UINT8 | RO | 0x08 (8dec)
1A0D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60D0 (ASI Analog Inputs Slave 13 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x60D0:01, 16
1A0D:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60D0 (ASI Analog Inputs Slave 13 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x60D0:02, 16
1A0D:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60D0 (ASI Analog Inputs Slave 13 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x60D0:03, 16
1A0D:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60D0 (ASI Analog Inputs Slave 13 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x60D0:04, 16
1A0D:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60D0 (ASI Analog Inputs Slave 13 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x60D0:05, 16
1A0D:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60D0 (ASI Analog Inputs Slave 13 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x60D0:06, 16
1A0D:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60D0 (ASI Analog Inputs Slave 13 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x60D0:07, 16
1A0D:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60D0 (ASI Analog Inputs Slave 13 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x60D0:08, 16
Index 1A0E ASI TxPDO-Map Analog Inputs Slave 14
Index (hex) | Name | Meaning | Data type | Flags | Default
1A0E:0 | ASI TxPDO-Map Analog Inputs Slave 14 | PDO Mapping TxPDO 15 | UINT8 | RO | 0x08 (8dec)
1A0E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60E0 (ASI Analog Inputs Slave 14 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x60E0:01, 16
1A0E:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60E0 (ASI Analog Inputs Slave 14 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x60E0:02, 16
1A0E:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60E0 (ASI Analog Inputs Slave 14 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x60E0:03, 16
1A0E:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60E0 (ASI Analog Inputs Slave 14 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x60E0:04, 16
1A0E:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60E0 (ASI Analog Inputs Slave 14 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x60E0:05, 16
1A0E:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60E0 (ASI Analog Inputs Slave 14 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x60E0:06, 16
1A0E:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60E0 (ASI Analog Inputs Slave 14 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x60E0:07, 16
1A0E:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60E0 (ASI Analog Inputs Slave 14 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x60E0:08, 16
Index 1A0F ASI TxPDO-Map Analog Inputs Slave 15
Index (hex) | Name | Meaning | Data type | Flags | Default
1A0F:0 | ASI TxPDO-Map Analog Inputs Slave 15 | PDO Mapping TxPDO 16 | UINT8 | RO | 0x08 (8dec)
1A0F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60F0 (ASI Analog Inputs Slave 15 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x60F0:01, 16
1A0F:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60F0 (ASI Analog Inputs Slave 15 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x60F0:02, 16
1A0F:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60F0 (ASI Analog Inputs Slave 15 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x60F0:03, 16
1A0F:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60F0 (ASI Analog Inputs Slave 15 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x60F0:04, 16
1A0F:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60F0 (ASI Analog Inputs Slave 15 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x60F0:05, 16
1A0F:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60F0 (ASI Analog Inputs Slave 15 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x60F0:06, 16
1A0F:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60F0 (ASI Analog Inputs Slave 15 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x60F0:07, 16
1A0F:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60F0 (ASI Analog Inputs Slave 15 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x60F0:08, 16
Index 1A10 ASI TxPDO-Map Analog Inputs Slave 16
Index (hex) | Name | Meaning | Data type | Flags | Default
1A10:0 | ASI TxPDO-Map Analog Inputs Slave 16 | PDO Mapping TxPDO 17 | UINT8 | RO | 0x08 (8dec)
1A10:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6100 (ASI Analog Inputs Slave 16 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6100:01, 16
1A10:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6100 (ASI Analog Inputs Slave 16 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6100:02, 16
1A10:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6100 (ASI Analog Inputs Slave 16 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6100:03, 16
1A10:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6100 (ASI Analog Inputs Slave 16 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6100:04, 16
1A10:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6100 (ASI Analog Inputs Slave 16 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6100:05, 16
1A10:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6100 (ASI Analog Inputs Slave 16 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6100:06, 16
1A10:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6100 (ASI Analog Inputs Slave 16 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6100:07, 16
1A10:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6100 (ASI Analog Inputs Slave 16 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6100:08, 16
Index 1A11 ASI TxPDO-Map Analog Inputs Slave 17
Index (hex) | Name | Meaning | Data type | Flags | Default
1A11:0 | ASI TxPDO-Map Analog Inputs Slave 17 | PDO Mapping TxPDO 18 | UINT8 | RO | 0x08 (8dec)
1A11:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6110 (ASI Analog Inputs Slave 17 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6110:01, 16
1A11:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6110 (ASI Analog Inputs Slave 17 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6110:02, 16
1A11:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6110 (ASI Analog Inputs Slave 17 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6110:03, 16
1A11:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6110 (ASI Analog Inputs Slave 17 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6110:04, 16
1A11:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6110 (ASI Analog Inputs Slave 17 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6110:05, 16
1A11:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6110 (ASI Analog Inputs Slave 17 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6110:06, 16
1A11:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6110 (ASI Analog Inputs Slave 17 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6110:07, 16
1A11:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6110 (ASI Analog Inputs Slave 17 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6110:08, 16
Index 1A12 ASI TxPDO-Map Analog Inputs Slave 18
Index (hex) | Name | Meaning | Data type | Flags | Default
1A12:0 | ASI TxPDO-Map Analog Inputs Slave 18 | PDO Mapping TxPDO 19 | UINT8 | RO | 0x08 (8dec)
1A12:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6120 (ASI Analog Inputs Slave 18 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6120:01, 16
1A12:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6120 (ASI Analog Inputs Slave 18 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6120:02, 16
1A12:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6120 (ASI Analog Inputs Slave 18 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6120:03, 16
1A12:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6120 (ASI Analog Inputs Slave 18 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6120:04, 16
1A12:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6120 (ASI Analog Inputs Slave 18 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6120:05, 16
1A12:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6120 (ASI Analog Inputs Slave 18 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6120:06, 16
1A12:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6120 (ASI Analog Inputs Slave 18 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6120:07, 16
1A12:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6120 (ASI Analog Inputs Slave 18 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6120:08, 16
Index 1A13 ASI TxPDO-Map Analog Inputs Slave 19
Index (hex) | Name | Meaning | Data type | Flags | Default
1A13:0 | ASI TxPDO-Map Analog Inputs Slave 19 | PDO Mapping TxPDO 20 | UINT8 | RO | 0x08 (8dec)
1A13:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6130 (ASI Analog Inputs Slave 19 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6130:01, 16
1A13:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6130 (ASI Analog Inputs Slave 19 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6130:02, 16
1A13:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6130 (ASI Analog Inputs Slave 19 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6130:03, 16
1A13:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6130 (ASI Analog Inputs Slave 19 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6130:04, 16
1A13:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6130 (ASI Analog Inputs Slave 19 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6130:05, 16
1A13:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6130 (ASI Analog Inputs Slave 19 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6130:06, 16
1A13:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6130 (ASI Analog Inputs Slave 19 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6130:07, 16
1A13:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6130 (ASI Analog Inputs Slave 19 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6130:08, 16
Index 1A14 ASI TxPDO-Map Analog Inputs Slave 20
Index (hex) | Name | Meaning | Data type | Flags | Default
1A14:0 | ASI TxPDO-Map Analog Inputs Slave 20 | PDO Mapping TxPDO 21 | UINT8 | RO | 0x08 (8dec)
1A14:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6140 (ASI Analog Inputs Slave 20 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6140:01, 16
1A14:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6140 (ASI Analog Inputs Slave 20 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6140:02, 16
1A14:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6140 (ASI Analog Inputs Slave 20 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6140:03, 16
1A14:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6140 (ASI Analog Inputs Slave 20 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6140:04, 16
1A14:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6140 (ASI Analog Inputs Slave 20 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6140:05, 16
1A14:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6140 (ASI Analog Inputs Slave 20 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6140:06, 16
1A14:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6140 (ASI Analog Inputs Slave 20 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6140:07, 16
1A14:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6140 (ASI Analog Inputs Slave 20 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6140:08, 16
Index 1A15 ASI TxPDO-Map Analog Inputs Slave 21
Index (hex) | Name | Meaning | Data type | Flags | Default
1A15:0 | ASI TxPDO-Map Analog Inputs Slave 21 | PDO Mapping TxPDO 22 | UINT8 | RO | 0x08 (8dec)
1A15:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6150 (ASI Analog Inputs Slave 21 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6150:01, 16
1A15:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6150 (ASI Analog Inputs Slave 21 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6150:02, 16
1A15:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6150 (ASI Analog Inputs Slave 21 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6150:03, 16
1A15:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6150 (ASI Analog Inputs Slave 21 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6150:04, 16
1A15:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6150 (ASI Analog Inputs Slave 21 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6150:05, 16
1A15:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6150 (ASI Analog Inputs Slave 21 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6150:06, 16
1A15:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6150 (ASI Analog Inputs Slave 21 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6150:07, 16
1A15:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6150 (ASI Analog Inputs Slave 21 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6150:08, 16
Index 1A16 ASI TxPDO-Map Analog Inputs Slave 22
Index (hex) | Name | Meaning | Data type | Flags | Default
1A16:0 | ASI TxPDO-Map Analog Inputs Slave 22 | PDO Mapping TxPDO 23 | UINT8 | RO | 0x08 (8dec)
1A16:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6160 (ASI Analog Inputs Slave 22 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6160:01, 16
1A16:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6160 (ASI Analog Inputs Slave 22 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6160:02, 16
1A16:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6160 (ASI Analog Inputs Slave 22 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6160:03, 16
1A16:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6160 (ASI Analog Inputs Slave 22 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6160:04, 16
1A16:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6160 (ASI Analog Inputs Slave 22 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6160:05, 16
1A16:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6160 (ASI Analog Inputs Slave 22 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6160:06, 16
1A16:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6160 (ASI Analog Inputs Slave 22 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6160:07, 16
1A16:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6160 (ASI Analog Inputs Slave 22 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6160:08, 16
Index 1A17 ASI TxPDO-Map Analog Inputs Slave 23
Index (hex) | Name | Meaning | Data type | Flags | Default
1A17:0 | ASI TxPDO-Map Analog Inputs Slave 23 | PDO Mapping TxPDO 24 | UINT8 | RO | 0x08 (8dec)
1A17:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6170 (ASI Analog Inputs Slave 23 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6170:01, 16
1A17:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6170 (ASI Analog Inputs Slave 23 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6170:02, 16
1A17:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6170 (ASI Analog Inputs Slave 23 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6170:03, 16
1A17:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6170 (ASI Analog Inputs Slave 23 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6170:04, 16
1A17:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6170 (ASI Analog Inputs Slave 23 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6170:05, 16
1A17:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6170 (ASI Analog Inputs Slave 23 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6170:06, 16
1A17:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6170 (ASI Analog Inputs Slave 23 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6170:07, 16
1A17:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6170 (ASI Analog Inputs Slave 23 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6170:08, 16
Index 1A18 ASI TxPDO-Map Analog Inputs Slave 24
Index (hex) | Name | Meaning | Data type | Flags | Default
1A18:0 | ASI TxPDO-Map Analog Inputs Slave 24 | PDO Mapping TxPDO 25 | UINT8 | RO | 0x08 (8dec)
1A18:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6180 (ASI Analog Inputs Slave 24 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6180:01, 16
1A18:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6180 (ASI Analog Inputs Slave 24 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6180:02, 16
1A18:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6180 (ASI Analog Inputs Slave 24 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6180:03, 16
1A18:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6180 (ASI Analog Inputs Slave 24 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6180:04, 16
1A18:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6180 (ASI Analog Inputs Slave 24 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6180:05, 16
1A18:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6180 (ASI Analog Inputs Slave 24 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6180:06, 16
1A18:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6180 (ASI Analog Inputs Slave 24 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6180:07, 16
1A18:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6180 (ASI Analog Inputs Slave 24 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6180:08, 16
Index 1A19 ASI TxPDO-Map Analog Inputs Slave 25
Index (hex) | Name | Meaning | Data type | Flags | Default
1A19:0 | ASI TxPDO-Map Analog Inputs Slave 25 | PDO Mapping TxPDO 26 | UINT8 | RO | 0x08 (8dec)
1A19:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6190 (ASI Analog Inputs Slave 25 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6190:01, 16
1A19:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6190 (ASI Analog Inputs Slave 25 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6190:02, 16
1A19:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6190 (ASI Analog Inputs Slave 25 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6190:03, 16
1A19:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6190 (ASI Analog Inputs Slave 25 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6190:04, 16
1A19:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6190 (ASI Analog Inputs Slave 25 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6190:05, 16
1A19:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6190 (ASI Analog Inputs Slave 25 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6190:06, 16
1A19:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6190 (ASI Analog Inputs Slave 25 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6190:07, 16
1A19:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6190 (ASI Analog Inputs Slave 25 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6190:08, 16
Index 1A1A ASI TxPDO-Map Analog Inputs Slave 26
Index (hex) | Name | Meaning | Data type | Flags | Default
1A1A:0 | ASI TxPDO-Map Analog Inputs Slave 26 | PDO Mapping TxPDO 27 | UINT8 | RO | 0x08 (8dec)
1A1A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x61A0 (ASI Analog Inputs Slave 26 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x61A0:01, 16
1A1A:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x61A0 (ASI Analog Inputs Slave 26 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x61A0:02, 16
1A1A:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x61A0 (ASI Analog Inputs Slave 26 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x61A0:03, 16
1A1A:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x61A0 (ASI Analog Inputs Slave 26 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x61A0:04, 16
1A1A:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x61A0 (ASI Analog Inputs Slave 26 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x61A0:05, 16
1A1A:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x61A0 (ASI Analog Inputs Slave 26 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x61A0:06, 16
1A1A:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x61A0 (ASI Analog Inputs Slave 26 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x61A0:07, 16
1A1A:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x61A0 (ASI Analog Inputs Slave 26 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x61A0:08, 16
Index 1A1B ASI TxPDO-Map Analog Inputs Slave 27
Index (hex) | Name | Meaning | Data type | Flags | Default
1A1B:0 | ASI TxPDO-Map Analog Inputs Slave 27 | PDO Mapping TxPDO 28 | UINT8 | RO | 0x08 (8dec)
1A1B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x61B0 (ASI Analog Inputs Slave 27 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x61B0:01, 16
1A1B:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x61B0 (ASI Analog Inputs Slave 27 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x61B0:02, 16
1A1B:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x61B0 (ASI Analog Inputs Slave 27 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x61B0:03, 16
1A1B:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x61B0 (ASI Analog Inputs Slave 27 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x61B0:04, 16
1A1B:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x61B0 (ASI Analog Inputs Slave 27 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x61B0:05, 16
1A1B:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x61B0 (ASI Analog Inputs Slave 27 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x61B0:06, 16
1A1B:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x61B0 (ASI Analog Inputs Slave 27 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x61B0:07, 16
1A1B:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x61B0 (ASI Analog Inputs Slave 27 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x61B0:08, 16
Index 1A1C ASI TxPDO-Map Analog Inputs Slave 28
Index (hex) | Name | Meaning | Data type | Flags | Default
1A1C:0 | ASI TxPDO-Map Analog Inputs Slave 28 | PDO Mapping TxPDO 29 | UINT8 | RO | 0x08 (8dec)
1A1C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x61C0 (ASI Analog Inputs Slave 28 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x61C0:01, 16
1A1C:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x61C0 (ASI Analog Inputs Slave 28 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x61C0:02, 16
1A1C:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x61C0 (ASI Analog Inputs Slave 28 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x61C0:03, 16
1A1C:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x61C0 (ASI Analog Inputs Slave 28 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x61C0:04, 16
1A1C:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x61C0 (ASI Analog Inputs Slave 28 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x61C0:05, 16
1A1C:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x61C0 (ASI Analog Inputs Slave 28 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x61C0:06, 16
1A1C:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x61C0 (ASI Analog Inputs Slave 28 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x61C0:07, 16
1A1C:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x61C0 (ASI Analog Inputs Slave 28 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x61C0:08, 16
Index 1A1D ASI TxPDO-Map Analog Inputs Slave 29
Index (hex) | Name | Meaning | Data type | Flags | Default
1A1D:0 | ASI TxPDO-Map Analog Inputs Slave 29 | PDO Mapping TxPDO 30 | UINT8 | RO | 0x08 (8dec)
1A1D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x61D0 (ASI Analog Inputs Slave 29 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x61D0:01, 16
1A1D:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x61D0 (ASI Analog Inputs Slave 29 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x61D0:02, 16
1A1D:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x61D0 (ASI Analog Inputs Slave 29 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x61D0:03, 16
1A1D:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x61D0 (ASI Analog Inputs Slave 29 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x61D0:04, 16
1A1D:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x61D0 (ASI Analog Inputs Slave 29 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x61D0:05, 16
1A1D:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x61D0 (ASI Analog Inputs Slave 29 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x61D0:06, 16
1A1D:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x61D0 (ASI Analog Inputs Slave 29 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x61D0:07, 16
1A1D:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x61D0 (ASI Analog Inputs Slave 29 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x61D0:08, 16
Index 1A1E ASI TxPDO-Map Analog Inputs Slave 30
Index (hex) | Name | Meaning | Data type | Flags | Default
1A1E:0 | ASI TxPDO-Map Analog Inputs Slave 30 | PDO Mapping TxPDO 31 | UINT8 | RO | 0x08 (8dec)
1A1E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x61E0 (ASI Analog Inputs Slave 30 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x61E0:01, 16
1A1E:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x61E0 (ASI Analog Inputs Slave 30 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x61E0:02, 16
1A1E:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x61E0 (ASI Analog Inputs Slave 30 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x61E0:03, 16
1A1E:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x61E0 (ASI Analog Inputs Slave 30 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x61E0:04, 16
1A1E:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x61E0 (ASI Analog Inputs Slave 30 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x61E0:05, 16
1A1E:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x61E0 (ASI Analog Inputs Slave 30 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x61E0:06, 16
1A1E:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x61E0 (ASI Analog Inputs Slave 30 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x61E0:07, 16
1A1E:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x61E0 (ASI Analog Inputs Slave 30 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x61E0:08, 16
Index 1A1F ASI TxPDO-Map Analog Inputs Slave 31
Index (hex) | Name | Meaning | Data type | Flags | Default
1A1F:0 | ASI TxPDO-Map Analog Inputs Slave 31 | PDO Mapping TxPDO 32 | UINT8 | RO | 0x08 (8dec)
1A1F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x61F0 (ASI Analog Inputs Slave 31 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x61F0:01, 16
1A1F:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x61F0 (ASI Analog Inputs Slave 31 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x61F0:02, 16
1A1F:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x61F0 (ASI Analog Inputs Slave 31 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x61F0:03, 16
1A1F:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x61F0 (ASI Analog Inputs Slave 31 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x61F0:04, 16
1A1F:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x61F0 (ASI Analog Inputs Slave 31 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x61F0:05, 16
1A1F:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x61F0 (ASI Analog Inputs Slave 31 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x61F0:06, 16
1A1F:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x61F0 (ASI Analog Inputs Slave 31 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x61F0:07, 16
1A1F:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x61F0 (ASI Analog Inputs Slave 31 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x61F0:08, 16
Index 1A40 ASI TxPDO-Map Inputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1A40:0 | ASI TxPDO-Map Inputs Device | PDO Mapping TxPDO 65 | UINT8 | RO | 0xF8 (248dec)
1A40:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x01 (Slave 1 Inputs__Slave 1A, DI0)) | UINT32 | RO | 0xF600:01, 1
1A40:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x02 (Slave 1 Inputs__Slave 1A, DI1)) | UINT32 | RO | 0xF600:02, 1
1A40:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x03 (Slave 1 Inputs__Slave 1A, DI2)) | UINT32 | RO | 0xF600:03, 1
1A40:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x04 (Slave 1 Inputs__Slave 1A, DI3)) | UINT32 | RO | 0xF600:04, 1
1A40:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x05 (Slave 1 Inputs__Slave 1B, DI0)) | UINT32 | RO | 0xF600:05, 1
1A40:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x06 (Slave 1 Inputs__Slave 1B, DI1)) | UINT32 | RO | 0xF600:06, 1
1A40:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x07 (Slave 1 Inputs__Slave 1B, DI2)) | UINT32 | RO | 0xF600:07, 1
1A40:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x08 (Slave 1 Inputs__Slave 1B, DI3)) | UINT32 | RO | 0xF600:08, 1
1A40:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x09 (Slave 2 Inputs__Slave 2A, DI0)) | UINT32 | RO | 0xF600:09, 1
1A40:0A | SubIndex 010 | 10. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x0A (Slave 2 Inputs__Slave 2A, DI1)) | UINT32 | RO | 0xF600:0A, 1
1A40:0B | SubIndex 011 | 11. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x0B (Slave 2 Inputs__Slave 2A, DI2)) | UINT32 | RO | 0xF600:0B, 1
1A40:0C | SubIndex 012 | 12. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x0C (Slave 2 Inputs__Slave 2A, DI3)) | UINT32 | RO | 0xF600:0C, 1
1A40:0D | SubIndex 013 | 13. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x0D (Slave 2 Inputs__Slave 2B, DI0)) | UINT32 | RO | 0xF600:0D, 1
1A40:0E | SubIndex 014 | 14. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x0E (Slave 2 Inputs__Slave 2B, DI1)) | UINT32 | RO | 0xF600:0E, 1
1A40:0F | SubIndex 015 | 15. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x0F (Slave 2 Inputs__Slave 2B, DI2)) | UINT32 | RO | 0xF600:0F, 1
Index 1A40 ASI TxPDO-Map Inputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1A40:10 | SubIndex 016 | 16. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x10 (Slave 2 Inputs__Slave 2B, DI3)) | UINT32 | RO | 0xF600:10, 1
1A40:11 | SubIndex 017 | 17. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x11 (Slave 3 Inputs__Slave 3A, DI0)) | UINT32 | RO | 0xF600:11, 1
1A40:12 | SubIndex 018 | 18. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x12 (Slave 3 Inputs__Slave 3A, DI1)) | UINT32 | RO | 0xF600:12, 1
1A40:13 | SubIndex 019 | 19. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x13 (Slave 3 Inputs__Slave 3A, DI2)) | UINT32 | RO | 0xF600:13, 1
1A40:14 | SubIndex 020 | 20. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x14 (Slave 3 Inputs__Slave 3A, DI3)) | UINT32 | RO | 0xF600:14, 1
1A40:15 | SubIndex 021 | 21. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x15 (Slave 3 Inputs__Slave 3B, DI0)) | UINT32 | RO | 0xF600:15, 1
1A40:16 | SubIndex 022 | 22. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x16 (Slave 3 Inputs__Slave 3B, DI1)) | UINT32 | RO | 0xF600:16, 1
1A40:17 | SubIndex 023 | 23. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x17 (Slave 3 Inputs__Slave 3B, DI2)) | UINT32 | RO | 0xF600:17, 1
1A40:18 | SubIndex 024 | 24. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x18 (Slave 3 Inputs__Slave 3B, DI3)) | UINT32 | RO | 0xF600:18, 1
1A40:19 | SubIndex 025 | 25. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x19 (Slave 4 Inputs__Slave 4A, DI0)) | UINT32 | RO | 0xF600:19, 1
1A40:1A | SubIndex 026 | 26. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x1A (Slave 4 Inputs__Slave 4A, DI1)) | UINT32 | RO | 0xF600:1A, 1
1A40:1B | SubIndex 027 | 27. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x1B (Slave 4 Inputs__Slave 4A, DI2)) | UINT32 | RO | 0xF600:1B, 1
1A40:1C | SubIndex 028 | 28. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x1C (Slave 4 Inputs__Slave 4A, DI3)) | UINT32 | RO | 0xF600:1C, 1
1A40:1D | SubIndex 029 | 29. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x1D (Slave 4 Inputs__Slave 4B, DI0)) | UINT32 | RO | 0xF600:1D, 1
1A40:1E | SubIndex 030 | 30. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x1E (Slave 4 Inputs__Slave 4B, DI1)) | UINT32 | RO | 0xF600:1E, 1
1A40:1F | SubIndex 031 | 31. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x1F (Slave 4 Inputs__Slave 4B, DI2)) | UINT32 | RO | 0xF600:1F, 1
Index 1A40 ASI TxPDO-Map Inputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1A40:20 | SubIndex 032 | 32. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x20 (Slave 4 Inputs__Slave 4B, DI3)) | UINT32 | RO | 0xF600:20, 1
1A40:21 | SubIndex 033 | 33. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x21 (Slave 5 Inputs__Slave 5A, DI0)) | UINT32 | RO | 0xF600:21, 1
1A40:22 | SubIndex 034 | 34. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x22 (Slave 5 Inputs__Slave 5A, DI1)) | UINT32 | RO | 0xF600:22, 1
1A40:23 | SubIndex 035 | 35. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x23 (Slave 5 Inputs__Slave 5A, DI2)) | UINT32 | RO | 0xF600:23, 1
1A40:24 | SubIndex 036 | 36. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x24 (Slave 5 Inputs__Slave 5A, DI3)) | UINT32 | RO | 0xF600:24, 1
1A40:25 | SubIndex 037 | 37. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x25 (Slave 5 Inputs__Slave 5B, DI0)) | UINT32 | RO | 0xF600:25, 1
1A40:26 | SubIndex 038 | 38. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x26 (Slave 5 Inputs__Slave 5B, DI1)) | UINT32 | RO | 0xF600:26, 1
1A40:27 | SubIndex 039 | 39. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x27 (Slave 5 Inputs__Slave 5B, DI2)) | UINT32 | RO | 0xF600:27, 1
1A40:28 | SubIndex 040 | 40. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x28 (Slave 5 Inputs__Slave 5B, DI3)) | UINT32 | RO | 0xF600:28, 1
1A40:29 | SubIndex 041 | 41. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x29 (Slave 6 Inputs__Slave 6A, DI0)) | UINT32 | RO | 0xF600:29, 1
1A40:2A | SubIndex 042 | 42. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x2A (Slave 6 Inputs__Slave 6A, DI1)) | UINT32 | RO | 0xF600:2A, 1
1A40:2B | SubIndex 043 | 43. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x2B (Slave 6 Inputs__Slave 6A, DI2)) | UINT32 | RO | 0xF600:2B, 1
1A40:2C | SubIndex 044 | 44. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x2C (Slave 6 Inputs__Slave 6A, DI3)) | UINT32 | RO | 0xF600:2C, 1
1A40:2D | SubIndex 045 | 45. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x2D (Slave 6 Inputs__Slave 6B, DI0)) | UINT32 | RO | 0xF600:2D, 1
1A40:2E | SubIndex 046 | 46. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x2E (Slave 6 Inputs__Slave 6B, DI1)) | UINT32 | RO | 0xF600:2E, 1
1A40:2F | SubIndex 047 | 47. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x2F (Slave 6 Inputs__Slave 6B, DI2)) | UINT32 | RO | 0xF600:2F, 1
Index 1A40 ASI TxPDO-Map Inputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1A40:30 | SubIndex 048 | 48. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x30 (Slave 6 Inputs__Slave 6B, DI3)) | UINT32 | RO | 0xF600:30, 1
1A40:31 | SubIndex 049 | 49. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x31 (Slave 7 Inputs__Slave 7A, DI0)) | UINT32 | RO | 0xF600:31, 1
1A40:32 | SubIndex 050 | 50. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x32 (Slave 7 Inputs__Slave 7A, DI1)) | UINT32 | RO | 0xF600:32, 1
1A40:33 | SubIndex 051 | 51. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x33 (Slave 7 Inputs__Slave 7A, DI2)) | UINT32 | RO | 0xF600:33, 1
1A40:34 | SubIndex 052 | 52. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x34 (Slave 7 Inputs__Slave 7A, DI3)) | UINT32 | RO | 0xF600:34, 1
1A40:35 | SubIndex 053 | 53. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x35 (Slave 7 Inputs__Slave 7B, DI0)) | UINT32 | RO | 0xF600:35, 1
1A40:36 | SubIndex 054 | 54. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x36 (Slave 7 Inputs__Slave 7B, DI1)) | UINT32 | RO | 0xF600:36, 1
1A40:37 | SubIndex 055 | 55. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x37 (Slave 7 Inputs__Slave 7B, DI2)) | UINT32 | RO | 0xF600:37, 1
1A40:38 | SubIndex 056 | 56. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x38 (Slave 7 Inputs__Slave 7B, DI3)) | UINT32 | RO | 0xF600:38, 1
1A40:39 | SubIndex 057 | 57. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x39 (Slave 8 Inputs__Slave 8A, DI0)) | UINT32 | RO | 0xF600:39, 1
1A40:3A | SubIndex 058 | 58. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x3A (Slave 8 Inputs__Slave 8A, DI1)) | UINT32 | RO | 0xF600:3A, 1
1A40:3B | SubIndex 059 | 59. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x3B (Slave 8 Inputs__Slave 8A, DI2)) | UINT32 | RO | 0xF600:3B, 1
1A40:3C | SubIndex 060 | 60. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x3C (Slave 8 Inputs__Slave 8A, DI3)) | UINT32 | RO | 0xF600:3C, 1
1A40:3D | SubIndex 061 | 61. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x3D (Slave 8 Inputs__Slave 8B, DI0)) | UINT32 | RO | 0xF600:3D, 1
1A40:3E | SubIndex 062 | 62. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x3E (Slave 8 Inputs__Slave 8B, DI1)) | UINT32 | RO | 0xF600:3E, 1
1A40:3F | SubIndex 063 | 63. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x3F (Slave 8 Inputs__Slave 8B, DI2)) | UINT32 | RO | 0xF600:3F, 1
Index 1A40 ASI TxPDO-Map Inputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1A40:40 | SubIndex 064 | 64. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x40 (Slave 8 Inputs__Slave 8B, DI3)) | UINT32 | RO | 0xF600:40, 1
1A40:41 | SubIndex 065 | 65. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x41 (Slave 9 Inputs__Slave 9A, DI0)) | UINT32 | RO | 0xF600:41, 1
1A40:42 | SubIndex 066 | 66. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x42 (Slave 9 Inputs__Slave 9A, DI1)) | UINT32 | RO | 0xF600:42, 1
1A40:43 | SubIndex 067 | 67. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x43 (Slave 9 Inputs__Slave 9A, DI2)) | UINT32 | RO | 0xF600:43, 1
1A40:44 | SubIndex 068 | 68. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x44 (Slave 9 Inputs__Slave 9A, DI3)) | UINT32 | RO | 0xF600:44, 1
1A40:45 | SubIndex 069 | 69. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x45 (Slave 9 Inputs__Slave 9B, DI0)) | UINT32 | RO | 0xF600:45, 1
1A40:46 | SubIndex 070 | 70. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x46 (Slave 9 Inputs__Slave 9B, DI1)) | UINT32 | RO | 0xF600:46, 1
1A40:47 | SubIndex 071 | 71. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x47 (Slave 9 Inputs__Slave 9B, DI2)) | UINT32 | RO | 0xF600:47, 1
1A40:48 | SubIndex 072 | 72. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x48 (Slave 9 Inputs__Slave 9B, DI3)) | UINT32 | RO | 0xF600:48, 1
1A40:49 | SubIndex 073 | 73. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x49 (Slave 10 Inputs__Slave 10A, DI0)) | UINT32 | RO | 0xF600:49, 1
1A40:4A | SubIndex 074 | 74. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x4A (Slave 10 Inputs__Slave 10A, DI1)) | UINT32 | RO | 0xF600:4A, 1
1A40:4B | SubIndex 075 | 75. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x4B (Slave 10 Inputs__Slave 10A, DI2)) | UINT32 | RO | 0xF600:4B, 1
1A40:4C | SubIndex 076 | 76. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x4C (Slave 10 Inputs__Slave 10A, DI3)) | UINT32 | RO | 0xF600:4C, 1
1A40:4D | SubIndex 077 | 77. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x4D (Slave 10 Inputs__Slave 10B, DI0)) | UINT32 | RO | 0xF600:4D, 1
1A40:4E | SubIndex 078 | 78. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x4E (Slave 10 Inputs__Slave 10B, DI1)) | UINT32 | RO | 0xF600:4E, 1
1A40:4F | SubIndex 079 | 79. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x4F (Slave 10 Inputs__Slave 10B, DI2)) | UINT32 | RO | 0xF600:4F, 1
Index 1A40 ASI TxPDO-Map Inputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1A40:50 | SubIndex 080 | 80. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x50 (Slave 10 Inputs__Slave 10B, DI3)) | UINT32 | RO | 0xF600:50, 1
1A40:51 | SubIndex 081 | 81. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x51 (Slave 11 Inputs__Slave 11A, DI0)) | UINT32 | RO | 0xF600:51, 1
1A40:52 | SubIndex 082 | 82. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x52 (Slave 11 Inputs__Slave 11A, DI1)) | UINT32 | RO | 0xF600:52, 1
1A40:53 | SubIndex 083 | 83. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x53 (Slave 11 Inputs__Slave 11A, DI2)) | UINT32 | RO | 0xF600:53, 1
1A40:54 | SubIndex 084 | 84. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x54 (Slave 11 Inputs__Slave 11A, DI3)) | UINT32 | RO | 0xF600:54, 1
1A40:55 | SubIndex 085 | 85. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x55 (Slave 11 Inputs__Slave 11B, DI0)) | UINT32 | RO | 0xF600:55, 1
1A40:56 | SubIndex 086 | 86. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x56 (Slave 11 Inputs__Slave 11B, DI1)) | UINT32 | RO | 0xF600:56, 1
1A40:57 | SubIndex 087 | 87. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x57 (Slave 11 Inputs__Slave 11B, DI2)) | UINT32 | RO | 0xF600:57, 1
1A40:58 | SubIndex 088 | 88. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x58 (Slave 11 Inputs__Slave 11B, DI3)) | UINT32 | RO | 0xF600:58, 1
1A40:59 | SubIndex 089 | 89. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x59 (Slave 12 Inputs__Slave 12A, DI0)) | UINT32 | RO | 0xF600:59, 1
1A40:5A | SubIndex 090 | 90. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x5A (Slave 12 Inputs__Slave 12A, DI1)) | UINT32 | RO | 0xF600:5A, 1
1A40:5B | SubIndex 091 | 91. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x5B (Slave 12 Inputs__Slave 12A, DI2)) | UINT32 | RO | 0xF600:5B, 1
1A40:5C | SubIndex 092 | 92. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x5C (Slave 12 Inputs__Slave 12A, DI3)) | UINT32 | RO | 0xF600:5C, 1
1A40:5D | SubIndex 093 | 93. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x5D (Slave 12 Inputs__Slave 12B, DI0)) | UINT32 | RO | 0xF600:5D, 1
1A40:5E | SubIndex 094 | 94. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x5E (Slave 12 Inputs__Slave 12B, DI1)) | UINT32 | RO | 0xF600:5E, 1
1A40:5F | SubIndex 095 | 95. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x5F (Slave 12 Inputs__Slave 12B, DI2)) | UINT32 | RO | 0xF600:5F, 1
Index 1A40 ASI TxPDO-Map Inputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1A40:60 | SubIndex 096 | 96. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x60 (Slave 12 Inputs__Slave 12B, DI3)) | UINT32 | RO | 0xF600:60, 1
1A40:61 | SubIndex 097 | 97. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x61 (Slave 13 Inputs__Slave 13A, DI0)) | UINT32 | RO | 0xF600:61, 1
1A40:62 | SubIndex 098 | 98. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x62 (Slave 13 Inputs__Slave 13A, DI1)) | UINT32 | RO | 0xF600:62, 1
1A40:63 | SubIndex 099 | 99. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x63 (Slave 13 Inputs__Slave 13A, DI2)) | UINT32 | RO | 0xF600:63, 1
1A40:64 | SubIndex 100 | 100. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x64 (Slave 13 Inputs__Slave 13A, DI3)) | UINT32 | RO | 0xF600:64, 1
1A40:65 | SubIndex 101 | 101. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x65 (Slave 13 Inputs__Slave 13B, DI0)) | UINT32 | RO | 0xF600:65, 1
1A40:66 | SubIndex 102 | 102. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x66 (Slave 13 Inputs__Slave 13B, DI1)) | UINT32 | RO | 0xF600:66, 1
1A40:67 | SubIndex 103 | 103. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x67 (Slave 13 Inputs__Slave 13B, DI2)) | UINT32 | RO | 0xF600:67, 1
1A40:68 | SubIndex 104 | 104. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x68 (Slave 13 Inputs__Slave 13B, DI3)) | UINT32 | RO | 0xF600:68, 1
1A40:69 | SubIndex 105 | 105. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x69 (Slave 14 Inputs__Slave 14A, DI0)) | UINT32 | RO | 0xF600:69, 1
1A40:6A | SubIndex 106 | 106. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x6A (Slave 14 Inputs__Slave 14A, DI1)) | UINT32 | RO | 0xF600:6A, 1
1A40:6B | SubIndex 107 | 107. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x6B (Slave 14 Inputs__Slave 14A, DI2)) | UINT32 | RO | 0xF600:6B, 1
1A40:6C | SubIndex 108 | 108. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x6C (Slave 14 Inputs__Slave 14A, DI3)) | UINT32 | RO | 0xF600:6C, 1
1A40:6D | SubIndex 109 | 109. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x6D (Slave 14 Inputs__Slave 14B, DI0)) | UINT32 | RO | 0xF600:6D, 1
1A40:6E | SubIndex 110 | 110. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x6E (Slave 14 Inputs__Slave 14B, DI1)) | UINT32 | RO | 0xF600:6E, 1
1A40:6F | SubIndex 111 | 111. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x6F (Slave 14 Inputs__Slave 14B, DI2)) | UINT32 | RO | 0xF600:6F, 1
Index 1A40 ASI TxPDO-Map Inputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1A40:70 | SubIndex 112 | 112. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x70 (Slave 14 Inputs__Slave 14B, DI3)) | UINT32 | RO | 0xF600:70, 1
1A40:71 | SubIndex 113 | 113. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x71 (Slave 15 Inputs__Slave 15A, DI0)) | UINT32 | RO | 0xF600:71, 1
1A40:72 | SubIndex 114 | 114. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x72 (Slave 15 Inputs__Slave 15A, DI1)) | UINT32 | RO | 0xF600:72, 1
1A40:73 | SubIndex 115 | 115. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x73 (Slave 15 Inputs__Slave 15A, DI2)) | UINT32 | RO | 0xF600:73, 1
1A40:74 | SubIndex 116 | 116. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x74 (Slave 15 Inputs__Slave 15A, DI3)) | UINT32 | RO | 0xF600:74, 1
1A40:75 | SubIndex 117 | 117. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x75 (Slave 15 Inputs__Slave 15B, DI0)) | UINT32 | RO | 0xF600:75, 1
1A40:76 | SubIndex 118 | 118. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x76 (Slave 15 Inputs__Slave 15B, DI1)) | UINT32 | RO | 0xF600:76, 1
1A40:77 | SubIndex 119 | 119. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x77 (Slave 15 Inputs__Slave 15B, DI2)) | UINT32 | RO | 0xF600:77, 1
1A40:78 | SubIndex 120 | 120. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x78 (Slave 15 Inputs__Slave 15B, DI3)) | UINT32 | RO | 0xF600:78, 1
1A40:79 | SubIndex 121 | 121. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x79 (Slave 16 Inputs__Slave 16A, DI0)) | UINT32 | RO | 0xF600:79, 1
1A40:7A | SubIndex 122 | 122. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x7A (Slave 16 Inputs__Slave 16A, DI1)) | UINT32 | RO | 0xF600:7A, 1
1A40:7B | SubIndex 123 | 123. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x7B (Slave 16 Inputs__Slave 16A, DI2)) | UINT32 | RO | 0xF600:7B, 1
1A40:7C | SubIndex 124 | 124. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x7C (Slave 16 Inputs__Slave 16A, DI3)) | UINT32 | RO | 0xF600:7C, 1
1A40:7D | SubIndex 125 | 125. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x7D (Slave 16 Inputs__Slave 16B, DI0)) | UINT32 | RO | 0xF600:7D, 1
1A40:7E | SubIndex 126 | 126. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x7E (Slave 16 Inputs__Slave 16B, DI1)) | UINT32 | RO | 0xF600:7E, 1
1A40:7F | SubIndex 127 | 127. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x7F (Slave 16 Inputs__Slave 16B, DI2)) | UINT32 | RO | 0xF600:7F, 1
Index 1A40 ASI TxPDO-Map Inputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1A40:80 | SubIndex 128 | 128. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x80 (Slave 16 Inputs__Slave 16B, DI3)) | UINT32 | RO | 0xF600:80, 1
1A40:81 | SubIndex 129 | 129. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x81 (Slave 17 Inputs__Slave 17A, DI0)) | UINT32 | RO | 0xF600:81, 1
1A40:82 | SubIndex 130 | 130. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x82 (Slave 17 Inputs__Slave 17A, DI1)) | UINT32 | RO | 0xF600:82, 1
1A40:83 | SubIndex 131 | 131. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x83 (Slave 17 Inputs__Slave 17A, DI2)) | UINT32 | RO | 0xF600:83, 1
1A40:84 | SubIndex 132 | 132. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x84 (Slave 17 Inputs__Slave 17A, DI3)) | UINT32 | RO | 0xF600:84, 1
1A40:85 | SubIndex 133 | 133. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x85 (Slave 17 Inputs__Slave 17B, DI0)) | UINT32 | RO | 0xF600:85, 1
1A40:86 | SubIndex 134 | 134. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x86 (Slave 17 Inputs__Slave 17B, DI1)) | UINT32 | RO | 0xF600:86, 1
1A40:87 | SubIndex 135 | 135. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x87 (Slave 17 Inputs__Slave 17B, DI2)) | UINT32 | RO | 0xF600:87, 1
1A40:88 | SubIndex 136 | 136. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x88 (Slave 17 Inputs__Slave 17B, DI3)) | UINT32 | RO | 0xF600:88, 1
1A40:89 | SubIndex 137 | 137. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x89 (Slave 18 Inputs__Slave 18A, DI0)) | UINT32 | RO | 0xF600:89, 1
1A40:8A | SubIndex 138 | 138. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x8A (Slave 18 Inputs__Slave 18A, DI1)) | UINT32 | RO | 0xF600:8A, 1
1A40:8B | SubIndex 139 | 139. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x8B (Slave 18 Inputs__Slave 18A, DI2)) | UINT32 | RO | 0xF600:8B, 1
1A40:8C | SubIndex 140 | 140. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x8C (Slave 18 Inputs__Slave 18A, DI3)) | UINT32 | RO | 0xF600:8C, 1
1A40:8D | SubIndex 141 | 141. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x8D (Slave 18 Inputs__Slave 18B, DI0)) | UINT32 | RO | 0xF600:8D, 1
1A40:8E | SubIndex 142 | 142. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x8E (Slave 18 Inputs__Slave 18B, DI1)) | UINT32 | RO | 0xF600:8E, 1
1A40:8F | SubIndex 143 | 143. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x8F (Slave 18 Inputs__Slave 18B, DI2)) | UINT32 | RO | 0xF600:8F, 1
Index 1A40 ASI TxPDO-Map Inputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1A40:90 | SubIndex 144 | 144. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x90 (Slave 18 Inputs__Slave 18B, DI3)) | UINT32 | RO | 0xF600:90, 1
1A40:91 | SubIndex 145 | 145. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x91 (Slave 19 Inputs__Slave 19A, DI0)) | UINT32 | RO | 0xF600:91, 1
1A40:92 | SubIndex 146 | 146. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x92 (Slave 19 Inputs__Slave 19A, DI1)) | UINT32 | RO | 0xF600:92, 1
1A40:93 | SubIndex 147 | 147. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x93 (Slave 19 Inputs__Slave 19A, DI2)) | UINT32 | RO | 0xF600:93, 1
1A40:94 | SubIndex 148 | 148. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x94 (Slave 19 Inputs__Slave 19A, DI3)) | UINT32 | RO | 0xF600:94, 1
1A40:95 | SubIndex 149 | 149. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x95 (Slave 19 Inputs__Slave 19B, DI0)) | UINT32 | RO | 0xF600:95, 1
1A40:96 | SubIndex 150 | 150. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x96 (Slave 19 Inputs__Slave 19B, DI1)) | UINT32 | RO | 0xF600:96, 1
1A40:97 | SubIndex 151 | 151. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x97 (Slave 19 Inputs__Slave 19B, DI2)) | UINT32 | RO | 0xF600:97, 1
1A40:98 | SubIndex 152 | 152. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x98 (Slave 19 Inputs__Slave 19B, DI3)) | UINT32 | RO | 0xF600:98, 1
1A40:99 | SubIndex 153 | 153. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x99 (Slave 20 Inputs__Slave 20A, DI0)) | UINT32 | RO | 0xF600:99, 1
1A40:9A | SubIndex 154 | 154. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x9A (Slave 20 Inputs__Slave 20A, DI1)) | UINT32 | RO | 0xF600:9A, 1
1A40:9B | SubIndex 155 | 155. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x9B (Slave 20 Inputs__Slave 20A, DI2)) | UINT32 | RO | 0xF600:9B, 1
1A40:9C | SubIndex 156 | 156. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x9C (Slave 20 Inputs__Slave 20A, DI3)) | UINT32 | RO | 0xF600:9C, 1
1A40:9D | SubIndex 157 | 157. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x9D (Slave 20 Inputs__Slave 20B, DI0)) | UINT32 | RO | 0xF600:9D, 1
1A40:9E | SubIndex 158 | 158. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x9E (Slave 20 Inputs__Slave 20B, DI1)) | UINT32 | RO | 0xF600:9E, 1
1A40:9F | SubIndex 159 | 159. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x9F (Slave 20 Inputs__Slave 20B, DI2)) | UINT32 | RO | 0xF600:9F, 1
Index 1A40 ASI TxPDO-Map Inputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1A40:A0 | SubIndex 160 | 160. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xA0 (Slave 20 Inputs__Slave 20B, DI3)) | UINT32 | RO | 0xF600:A0, 1
1A40:A1 | SubIndex 161 | 161. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xA1 (Slave 21 Inputs__Slave 21A, DI0)) | UINT32 | RO | 0xF600:A1, 1
1A40:A2 | SubIndex 162 | 162. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xA2 (Slave 21 Inputs__Slave 21A, DI1)) | UINT32 | RO | 0xF600:A2, 1
1A40:A3 | SubIndex 163 | 163. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xA3 (Slave 21 Inputs__Slave 21A, DI2)) | UINT32 | RO | 0xF600:A3, 1
1A40:A4 | SubIndex 164 | 164. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xA4 (Slave 21 Inputs__Slave 21A, DI3)) | UINT32 | RO | 0xF600:A4, 1
1A40:A5 | SubIndex 165 | 165. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xA5 (Slave 21 Inputs__Slave 21B, DI0)) | UINT32 | RO | 0xF600:A5, 1
1A40:A6 | SubIndex 166 | 166. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xA6 (Slave 21 Inputs__Slave 21B, DI1)) | UINT32 | RO | 0xF600:A6, 1
1A40:A7 | SubIndex 167 | 167. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xA7 (Slave 21 Inputs__Slave 21B, DI2)) | UINT32 | RO | 0xF600:A7, 1
1A40:A8 | SubIndex 168 | 168. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xA8 (Slave 21 Inputs__Slave 21B, DI3)) | UINT32 | RO | 0xF600:A8, 1
1A40:A9 | SubIndex 169 | 169. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xA9 (Slave 22 Inputs__Slave 22A, DI0)) | UINT32 | RO | 0xF600:A9, 1
1A40:AA | SubIndex 170 | 170. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xAA (Slave 22 Inputs__Slave 22A, DI1)) | UINT32 | RO | 0xF600:AA, 1
1A40:AB | SubIndex 171 | 171. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xAB (Slave 22 Inputs__Slave 22A, DI2)) | UINT32 | RO | 0xF600:AB, 1
1A40:AC | SubIndex 172 | 172. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xAC (Slave 22 Inputs__Slave 22A, DI3)) | UINT32 | RO | 0xF600:AC, 1
1A40:AD | SubIndex 173 | 173. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xAD (Slave 22 Inputs__Slave 22B, DI0)) | UINT32 | RO | 0xF600:AD, 1
1A40:AE | SubIndex 174 | 174. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xAE (Slave 22 Inputs__Slave 22B, DI1)) | UINT32 | RO | 0xF600:AE, 1
1A40:AF | SubIndex 175 | 175. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xAF (Slave 22 Inputs__Slave 22B, DI2)) | UINT32 | RO | 0xF600:AF, 1
Index 1A40 ASI TxPDO-Map Inputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1A40:B0 | SubIndex 176 | 176. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xB0 (Slave 22 Inputs__Slave 22B, DI3)) | UINT32 | RO | 0xF600:B0, 1
1A40:B1 | SubIndex 177 | 177. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xB1 (Slave 23 Inputs__Slave 23A, DI0)) | UINT32 | RO | 0xF600:B1, 1
1A40:B2 | SubIndex 178 | 178. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xB2 (Slave 23 Inputs__Slave 23A, DI1)) | UINT32 | RO | 0xF600:B2, 1
1A40:B3 | SubIndex 179 | 179. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xB3 (Slave 23 Inputs__Slave 23A, DI2)) | UINT32 | RO | 0xF600:B3, 1
1A40:B4 | SubIndex 180 | 180. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xB4 (Slave 23 Inputs__Slave 23A, DI3)) | UINT32 | RO | 0xF600:B4, 1
1A40:B5 | SubIndex 181 | 181. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xB5 (Slave 23 Inputs__Slave 23B, DI0)) | UINT32 | RO | 0xF600:B5, 1
1A40:B6 | SubIndex 182 | 182. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xB6 (Slave 23 Inputs__Slave 23B, DI1)) | UINT32 | RO | 0xF600:B6, 1
1A40:B7 | SubIndex 183 | 183. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xB7 (Slave 23 Inputs__Slave 23B, DI2)) | UINT32 | RO | 0xF600:B7, 1
1A40:B8 | SubIndex 184 | 184. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xB8 (Slave 23 Inputs__Slave 23B, DI3)) | UINT32 | RO | 0xF600:B8, 1
1A40:B9 | SubIndex 185 | 185. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xB9 (Slave 24 Inputs__Slave 24A, DI0)) | UINT32 | RO | 0xF600:B9, 1
1A40:BA | SubIndex 186 | 186. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xBA (Slave 24 Inputs__Slave 24A, DI1)) | UINT32 | RO | 0xF600:BA, 1
1A40:BB | SubIndex 187 | 187. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xBB (Slave 24 Inputs__Slave 24A, DI2)) | UINT32 | RO | 0xF600:BB, 1
1A40:BC | SubIndex 188 | 188. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xBC (Slave 24 Inputs__Slave 24A, DI3)) | UINT32 | RO | 0xF600:BC, 1
1A40:BD | SubIndex 189 | 189. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xBD (Slave 24 Inputs__Slave 24B, DI0)) | UINT32 | RO | 0xF600:BD, 1
1A40:BE | SubIndex 190 | 190. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xBE (Slave 24 Inputs__Slave 24B, DI1)) | UINT32 | RO | 0xF600:BE, 1
1A40:BF | SubIndex 191 | 191. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xBF (Slave 24 Inputs__Slave 24B, DI2)) | UINT32 | RO | 0xF600:BF, 1
Index 1A40 ASI TxPDO-Map Inputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1A40:C0 | SubIndex 192 | 192. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xC0 (Slave 24 Inputs__Slave 24B, DI3)) | UINT32 | RO | 0xF600:C0, 1
1A40:C1 | SubIndex 193 | 193. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xC1 (Slave 25 Inputs__Slave 25A, DI0)) | UINT32 | RO | 0xF600:C1, 1
1A40:C2 | SubIndex 194 | 194. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xC2 (Slave 25 Inputs__Slave 25A, DI1)) | UINT32 | RO | 0xF600:C2, 1
1A40:C3 | SubIndex 195 | 195. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xC3 (Slave 25 Inputs__Slave 25A, DI2)) | UINT32 | RO | 0xF600:C3, 1
1A40:C4 | SubIndex 196 | 196. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xC4 (Slave 25 Inputs__Slave 25A, DI3)) | UINT32 | RO | 0xF600:C4, 1
1A40:C5 | SubIndex 197 | 197. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xC5 (Slave 25 Inputs__Slave 25B, DI0)) | UINT32 | RO | 0xF600:C5, 1
1A40:C6 | SubIndex 198 | 198. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xC6 (Slave 25 Inputs__Slave 25B, DI1)) | UINT32 | RO | 0xF600:C6, 1
1A40:C7 | SubIndex 199 | 199. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xC7 (Slave 25 Inputs__Slave 25B, DI2)) | UINT32 | RO | 0xF600:C7, 1
1A40:C8 | SubIndex 200 | 200. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xC8 (Slave 25 Inputs__Slave 25B, DI3)) | UINT32 | RO | 0xF600:C8, 1
1A40:C9 | SubIndex 201 | 201. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xC9 (Slave 26 Inputs__Slave 26A, DI0)) | UINT32 | RO | 0xF600:C9, 1
1A40:CA | SubIndex 202 | 202. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xCA (Slave 26 Inputs__Slave 26A, DI1)) | UINT32 | RO | 0xF600:CA, 1
1A40:CB | SubIndex 203 | 203. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xCB (Slave 26 Inputs__Slave 26A, DI2)) | UINT32 | RO | 0xF600:CB, 1
1A40:CC | SubIndex 204 | 204. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xCC (Slave 26 Inputs__Slave 26A, DI3)) | UINT32 | RO | 0xF600:CC, 1
1A40:CD | SubIndex 205 | 205. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xCD (Slave 26 Inputs__Slave 26B, DI0)) | UINT32 | RO | 0xF600:CD, 1
1A40:CE | SubIndex 206 | 206. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xCE (Slave 26 Inputs__Slave 26B, DI1)) | UINT32 | RO | 0xF600:CE, 1
1A40:CF | SubIndex 207 | 207. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xCF (Slave 26 Inputs__Slave 26B, DI2)) | UINT32 | RO | 0xF600:CF, 1
Index 1A40 ASI TxPDO-Map Inputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1A40:D0 | SubIndex 208 | 208. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xD0 (Slave 26 Inputs__Slave 26B, DI3)) | UINT32 | RO | 0xF600:D0, 1
1A40:D1 | SubIndex 209 | 209. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xD1 (Slave 27 Inputs__Slave 27A, DI0)) | UINT32 | RO | 0xF600:D1, 1
1A40:D2 | SubIndex 210 | 210. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xD2 (Slave 27 Inputs__Slave 27A, DI1)) | UINT32 | RO | 0xF600:D2, 1
1A40:D3 | SubIndex 211 | 211. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xD3 (Slave 27 Inputs__Slave 27A, DI2)) | UINT32 | RO | 0xF600:D3, 1
1A40:D4 | SubIndex 212 | 212. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xD4 (Slave 27 Inputs__Slave 27A, DI3)) | UINT32 | RO | 0xF600:D4, 1
1A40:D5 | SubIndex 213 | 213. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xD5 (Slave 27 Inputs__Slave 27B, DI0)) | UINT32 | RO | 0xF600:D5, 1
1A40:D6 | SubIndex 214 | 214. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xD6 (Slave 27 Inputs__Slave 27B, DI1)) | UINT32 | RO | 0xF600:D6, 1
1A40:D7 | SubIndex 215 | 215. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xD7 (Slave 27 Inputs__Slave 27B, DI2)) | UINT32 | RO | 0xF600:D7, 1
1A40:D8 | SubIndex 216 | 216. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xD8 (Slave 27 Inputs__Slave 27B, DI3)) | UINT32 | RO | 0xF600:D8, 1
1A40:D9 | SubIndex 217 | 217. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xD9 (Slave 28 Inputs__Slave 28A, DI0)) | UINT32 | RO | 0xF600:D9, 1
1A40:DA | SubIndex 218 | 218. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xDA (Slave 28 Inputs__Slave 28A, DI1)) | UINT32 | RO | 0xF600:DA, 1
1A40:DB | SubIndex 219 | 219. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xDB (Slave 28 Inputs__Slave 28A, DI2)) | UINT32 | RO | 0xF600:DB, 1
1A40:DC | SubIndex 220 | 220. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xDC (Slave 28 Inputs__Slave 28A, DI3)) | UINT32 | RO | 0xF600:DC, 1
1A40:DD | SubIndex 221 | 221. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xDD (Slave 28 Inputs__Slave 28B, DI0)) | UINT32 | RO | 0xF600:DD, 1
1A40:DE | SubIndex 222 | 222. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xDE (Slave 28 Inputs__Slave 28B, DI1)) | UINT32 | RO | 0xF600:DE, 1
1A40:DF | SubIndex 223 | 223. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xDF (Slave 28 Inputs__Slave 28B, DI2)) | UINT32 | RO | 0xF600:DF, 1
Index 1A40 ASI TxPDO-Map Inputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1A40:E0 | SubIndex 224 | 224. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xE0 (Slave 28 Inputs__Slave 28B, DI3)) | UINT32 | RO | 0xF600:E0, 1
1A40:E1 | SubIndex 225 | 225. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xE1 (Slave 29 Inputs__Slave 29A, DI0)) | UINT32 | RO | 0xF600:E1, 1
1A40:E2 | SubIndex 226 | 226. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xE2 (Slave 29 Inputs__Slave 29A, DI1)) | UINT32 | RO | 0xF600:E2, 1
1A40:E3 | SubIndex 227 | 227. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xE3 (Slave 29 Inputs__Slave 29A, DI2)) | UINT32 | RO | 0xF600:E3, 1
1A40:E4 | SubIndex 228 | 228. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xE4 (Slave 29 Inputs__Slave 29A, DI3)) | UINT32 | RO | 0xF600:E4, 1
1A40:E5 | SubIndex 229 | 229. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xE5 (Slave 29 Inputs__Slave 29B, DI0)) | UINT32 | RO | 0xF600:E5, 1
1A40:E6 | SubIndex 230 | 230. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xE6 (Slave 29 Inputs__Slave 29B, DI1)) | UINT32 | RO | 0xF600:E6, 1
1A40:E7 | SubIndex 231 | 231. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xE7 (Slave 29 Inputs__Slave 29B, DI2)) | UINT32 | RO | 0xF600:E7, 1
1A40:E8 | SubIndex 232 | 232. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xE8 (Slave 29 Inputs__Slave 29B, DI3)) | UINT32 | RO | 0xF600:E8, 1
1A40:E9 | SubIndex 233 | 233. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xE9 (Slave 30 Inputs__Slave 30A, DI0)) | UINT32 | RO | 0xF600:E9, 1
1A40:EA | SubIndex 234 | 234. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xEA (Slave 30 Inputs__Slave 30A, DI1)) | UINT32 | RO | 0xF600:EA, 1
1A40:EB | SubIndex 235 | 235. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xEB (Slave 30 Inputs__Slave 30A, DI2)) | UINT32 | RO | 0xF600:EB, 1
1A40:EC | SubIndex 236 | 236. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xEC (Slave 30 Inputs__Slave 30A, DI3)) | UINT32 | RO | 0xF600:EC, 1
1A40:ED | SubIndex 237 | 237. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xED (Slave 30 Inputs__Slave 30B, DI0)) | UINT32 | RO | 0xF600:ED, 1
1A40:EE | SubIndex 238 | 238. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xEE (Slave 30 Inputs__Slave 30B, DI1)) | UINT32 | RO | 0xF600:EE, 1
1A40:EF | SubIndex 239 | 239. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xEF (Slave 30 Inputs__Slave 30B, DI2)) | UINT32 | RO | 0xF600:EF, 1
Index 1A40 ASI TxPDO-Map Inputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1A40:F0 | SubIndex 240 | 240. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xF0 (Slave 30 Inputs__Slave 30B, DI3)) | UINT32 | RO | 0xF600:F0, 1
1A40:F1 | SubIndex 241 | 241. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xF1 (Slave 31 Inputs__Slave 31A, DI0)) | UINT32 | RO | 0xF600:F1, 1
1A40:F2 | SubIndex 242 | 242. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xF2 (Slave 31 Inputs__Slave 31A, DI1)) | UINT32 | RO | 0xF600:F2, 1
1A40:F3 | SubIndex 243 | 243. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xF3 (Slave 31 Inputs__Slave 31A, DI2)) | UINT32 | RO | 0xF600:F3, 1
1A40:F4 | SubIndex 244 | 244. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xF4 (Slave 31 Inputs__Slave 31A, DI3)) | UINT32 | RO | 0xF600:F4, 1
1A40:F5 | SubIndex 245 | 245. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xF5 (Slave 31 Inputs__Slave 31B, DI0)) | UINT32 | RO | 0xF600:F5, 1
1A40:F6 | SubIndex 246 | 246. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xF6 (Slave 31 Inputs__Slave 31B, DI1)) | UINT32 | RO | 0xF600:F6, 1
1A40:F7 | SubIndex 247 | 247. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xF7 (Slave 31 Inputs__Slave 31B, DI2)) | UINT32 | RO | 0xF600:F7, 1
1A40:F8 | SubIndex 248 | 248. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xF8 (Slave 31 Inputs__Slave 31B, DI3)) | UINT32 | RO | 0xF600:F8, 1
Index 1A80 ASI TxPDO-Map Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1A80:0 | ASI TxPDO-Map Status | PDO Mapping TxPDO 129 | UINT8 | RO | 0x0D (13dec)
1A80:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF100 (ASI Status), entry 0x01 (Configuration okay)) | UINT32 | RO | 0xF100:01, 1
1A80:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF100 (ASI Status), entry 0x02 (Power Fail)) | UINT32 | RO | 0xF100:02, 1
1A80:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF100 (ASI Status), entry 0x03 (Auto addressing mode enabled)) | UINT32 | RO | 0xF100:03, 1
1A80:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF100 (ASI Status), entry 0x04 (Auto addressing mode available)) | UINT32 | RO | 0xF100:04, 1
1A80:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF100 (ASI Status), entry 0x05 (Protected mode active)) | UINT32 | RO | 0xF100:05, 1
1A80:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF100 (ASI Status), entry 0x06 (Slave with address 0 found)) | UINT32 | RO | 0xF100:06, 1
1A80:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF100 (ASI Status), entry 0x07 (Offline Ready)) | UINT32 | RO | 0xF100:07, 1
1A80:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF100 (ASI Status), entry 0x08 (Normal Operation)) | UINT32 | RO | 0xF100:08, 1
1A80:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF100 (ASI Status), entry 0x09 (ASI phase)) | UINT32 | RO | 0xF100:09, 3
1A80:0A | SubIndex 010 | 10. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A80:0B | SubIndex 011 | 11. PDO Mapping entry (object 0xF100 (ASI Status), entry 0x0E (Sync error)) | UINT32 | RO | 0xF100:0E, 1
1A80:0C | SubIndex 012 | 12. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A80:0D | SubIndex 013 | 13. PDO Mapping entry (object 0xF100 (ASI Status), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0xF100:10, 1
Index 1A81 ASI TxPDO-Map LDS
Index (hex) | Name | Meaning | Data type | Flags | Default
1A81:0 | ASI TxPDO-Map LDS | PDO Mapping TxPDO 130 | UINT8 | RO | 0x40 (64dec)
1A81:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x01 (Slave 0)) | UINT32 | RO | 0xF101:01, 1
1A81:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x02 (Slave 1A)) | UINT32 | RO | 0xF101:02, 1
1A81:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x03 (Slave 2A)) | UINT32 | RO | 0xF101:03, 1
1A81:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x04 (Slave 3A)) | UINT32 | RO | 0xF101:04, 1
1A81:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x05 (Slave 4A)) | UINT32 | RO | 0xF101:05, 1
1A81:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x06 (Slave 5A)) | UINT32 | RO | 0xF101:06, 1
1A81:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x07 (Slave 6A)) | UINT32 | RO | 0xF101:07, 1
1A81:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x08 (Slave 7A)) | UINT32 | RO | 0xF101:08, 1
1A81:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x09 (Slave 8A)) | UINT32 | RO | 0xF101:09, 1
1A81:0A | SubIndex 010 | 10. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x0A (Slave 9A)) | UINT32 | RO | 0xF101:0A, 1
1A81:0B | SubIndex 011 | 11. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x0B (Slave 10A)) | UINT32 | RO | 0xF101:0B, 1
1A81:0C | SubIndex 012 | 12. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x0C (Slave 11A)) | UINT32 | RO | 0xF101:0C, 1
1A81:0D | SubIndex 013 | 13. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x0D (Slave 12A)) | UINT32 | RO | 0xF101:0D, 1
1A81:0E | SubIndex 014 | 14. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x0E (Slave 13A)) | UINT32 | RO | 0xF101:0E, 1
1A81:0F | SubIndex 015 | 15. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x0F (Slave 14A)) | UINT32 | RO | 0xF101:0F, 1
Index 1A81 ASI TxPDO-Map LDS
Index (hex) | Name | Meaning | Data type | Flags | Default
1A81:10 | SubIndex 016 | 16. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x10 (Slave 15A)) | UINT32 | RO | 0xF101:10, 1
1A81:11 | SubIndex 017 | 17. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x11 (Slave 16A)) | UINT32 | RO | 0xF101:11, 1
1A81:12 | SubIndex 018 | 18. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x12 (Slave 17A)) | UINT32 | RO | 0xF101:12, 1
1A81:13 | SubIndex 019 | 19. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x13 (Slave 18A)) | UINT32 | RO | 0xF101:13, 1
1A81:14 | SubIndex 020 | 20. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x14 (Slave 19A)) | UINT32 | RO | 0xF101:14, 1
1A81:15 | SubIndex 021 | 21. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x15 (Slave 20A)) | UINT32 | RO | 0xF101:15, 1
1A81:16 | SubIndex 022 | 22. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x16 (Slave 21A)) | UINT32 | RO | 0xF101:16, 1
1A81:17 | SubIndex 023 | 23. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x17 (Slave 22A)) | UINT32 | RO | 0xF101:17, 1
1A81:18 | SubIndex 024 | 24. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x18 (Slave 23A)) | UINT32 | RO | 0xF101:18, 1
1A81:19 | SubIndex 025 | 25. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x19 (Slave 24A)) | UINT32 | RO | 0xF101:19, 1
1A81:1A | SubIndex 026 | 26. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x1A (Slave 25A)) | UINT32 | RO | 0xF101:1A, 1
1A81:1B | SubIndex 027 | 27. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x1B (Slave 26A)) | UINT32 | RO | 0xF101:1B, 1
1A81:1C | SubIndex 028 | 28. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x1C (Slave 27A)) | UINT32 | RO | 0xF101:1C, 1
1A81:1D | SubIndex 029 | 29. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x1D (Slave 28A)) | UINT32 | RO | 0xF101:1D, 1
1A81:1E | SubIndex 030 | 30. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x1E (Slave 29A)) | UINT32 | RO | 0xF101:1E, 1
1A81:1F | SubIndex 031 | 31. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x1F (Slave 30A)) | UINT32 | RO | 0xF101:1F, 1
Index 1A81 ASI TxPDO-Map LDS
Index (hex) | Name | Meaning | Data type | Flags | Default
1A81:20 | SubIndex 032 | 32. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x20 (Slave 31A)) | UINT32 | RO | 0xF101:20, 1
1A81:21 | SubIndex 033 | 33. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x21 (Slave 1B)) | UINT32 | RO | 0xF101:21, 1
1A81:22 | SubIndex 034 | 34. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x22 (Slave 2B)) | UINT32 | RO | 0xF101:22, 1
1A81:23 | SubIndex 035 | 35. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x23 (Slave 3B)) | UINT32 | RO | 0xF101:23, 1
1A81:24 | SubIndex 036 | 36. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x24 (Slave 4B)) | UINT32 | RO | 0xF101:24, 1
1A81:25 | SubIndex 037 | 37. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x25 (Slave 5B)) | UINT32 | RO | 0xF101:25, 1
1A81:26 | SubIndex 038 | 38. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x26 (Slave 6B)) | UINT32 | RO | 0xF101:26, 1
1A81:27 | SubIndex 039 | 39. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x27 (Slave 7B)) | UINT32 | RO | 0xF101:27, 1
1A81:28 | SubIndex 040 | 40. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x28 (Slave 8B)) | UINT32 | RO | 0xF101:28, 1
1A81:29 | SubIndex 041 | 41. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x29 (Slave 9B)) | UINT32 | RO | 0xF101:29, 1
1A81:2A | SubIndex 042 | 42. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x2A (Slave 10B)) | UINT32 | RO | 0xF101:2A, 1
1A81:2B | SubIndex 043 | 43. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x2B (Slave 11B)) | UINT32 | RO | 0xF101:2B, 1
1A81:2C | SubIndex 044 | 44. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x2C (Slave 12B)) | UINT32 | RO | 0xF101:2C, 1
1A81:2D | SubIndex 045 | 45. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x2D (Slave 13B)) | UINT32 | RO | 0xF101:2D, 1
1A81:2E | SubIndex 046 | 46. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x2E (Slave 14B)) | UINT32 | RO | 0xF101:2E, 1
1A81:2F | SubIndex 047 | 47. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x2F (Slave 15B)) | UINT32 | RO | 0xF101:2F, 1
Index 1A81 ASI TxPDO-Map LDS
Index (hex) | Name | Meaning | Data type | Flags | Default
1A81:30 | SubIndex 048 | 48. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x30 (Slave 16B)) | UINT32 | RO | 0xF101:30, 1
1A81:31 | SubIndex 049 | 49. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x31 (Slave 17B)) | UINT32 | RO | 0xF101:31, 1
1A81:32 | SubIndex 050 | 50. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x32 (Slave 18B)) | UINT32 | RO | 0xF101:32, 1
1A81:33 | SubIndex 051 | 51. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x33 (Slave 19B)) | UINT32 | RO | 0xF101:33, 1
1A81:34 | SubIndex 052 | 52. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x34 (Slave 20B)) | UINT32 | RO | 0xF101:34, 1
1A81:35 | SubIndex 053 | 53. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x35 (Slave 21B)) | UINT32 | RO | 0xF101:35, 1
1A81:36 | SubIndex 054 | 54. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x36 (Slave 22B)) | UINT32 | RO | 0xF101:36, 1
1A81:37 | SubIndex 055 | 55. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x37 (Slave 23B)) | UINT32 | RO | 0xF101:37, 1
1A81:38 | SubIndex 056 | 56. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x38 (Slave 24B)) | UINT32 | RO | 0xF101:38, 1
1A81:39 | SubIndex 057 | 57. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x39 (Slave 25B)) | UINT32 | RO | 0xF101:39, 1
1A81:3A | SubIndex 058 | 58. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x3A (Slave 26B)) | UINT32 | RO | 0xF101:3A, 1
1A81:3B | SubIndex 059 | 59. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x3B (Slave 27B)) | UINT32 | RO | 0xF101:3B, 1
1A81:3C | SubIndex 060 | 60. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x3C (Slave 28B)) | UINT32 | RO | 0xF101:3C, 1
1A81:3D | SubIndex 061 | 61. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x3D (Slave 29B)) | UINT32 | RO | 0xF101:3D, 1
1A81:3E | SubIndex 062 | 62. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x3E (Slave 30B)) | UINT32 | RO | 0xF101:3E, 1
1A81:3F | SubIndex 063 | 63. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x3F (Slave 31B)) | UINT32 | RO | 0xF101:3F, 1
1A81:40 | SubIndex 064 | 64. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
Index 1A82 ASI TxPDO-Map LAS
Index (hex) | Name | Meaning | Data type | Flags | Default
1A82:0 | ASI TxPDO-Map LAS | PDO Mapping TxPDO 131 | UINT8 | RO | 0x40 (64dec)
1A82:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x01 (Slave 0)) | UINT32 | RO | 0xF102:01, 1
1A82:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x02 (Slave 1A)) | UINT32 | RO | 0xF102:02, 1
1A82:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x03 (Slave 2A)) | UINT32 | RO | 0xF102:03, 1
1A82:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x04 (Slave 3A)) | UINT32 | RO | 0xF102:04, 1
1A82:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x05 (Slave 4A)) | UINT32 | RO | 0xF102:05, 1
1A82:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x06 (Slave 5A)) | UINT32 | RO | 0xF102:06, 1
1A82:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x07 (Slave 6A)) | UINT32 | RO | 0xF102:07, 1
1A82:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x08 (Slave 7A)) | UINT32 | RO | 0xF102:08, 1
1A82:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x09 (Slave 8A)) | UINT32 | RO | 0xF102:09, 1
1A82:0A | SubIndex 010 | 10. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x0A (Slave 9A)) | UINT32 | RO | 0xF102:0A, 1
1A82:0B | SubIndex 011 | 11. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x0B (Slave 10A)) | UINT32 | RO | 0xF102:0B, 1
1A82:0C | SubIndex 012 | 12. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x0C (Slave 11A)) | UINT32 | RO | 0xF102:0C, 1
1A82:0D | SubIndex 013 | 13. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x0D (Slave 12A)) | UINT32 | RO | 0xF102:0D, 1
1A82:0E | SubIndex 014 | 14. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x0E (Slave 13A)) | UINT32 | RO | 0xF102:0E, 1
1A82:0F | SubIndex 015 | 15. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x0F (Slave 14A)) | UINT32 | RO | 0xF102:0F, 1
Index 1A82 ASI TxPDO-Map LAS
Index (hex) | Name | Meaning | Data type | Flags | Default
1A82:10 | SubIndex 016 | 16. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x10 (Slave 15A)) | UINT32 | RO | 0xF102:10, 1
1A82:11 | SubIndex 017 | 17. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x11 (Slave 16A)) | UINT32 | RO | 0xF102:11, 1
1A82:12 | SubIndex 018 | 18. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x12 (Slave 17A)) | UINT32 | RO | 0xF102:12, 1
1A82:13 | SubIndex 019 | 19. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x13 (Slave 18A)) | UINT32 | RO | 0xF102:13, 1
1A82:14 | SubIndex 020 | 20. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x14 (Slave 19A)) | UINT32 | RO | 0xF102:14, 1
1A82:15 | SubIndex 021 | 21. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x15 (Slave 20A)) | UINT32 | RO | 0xF102:15, 1
1A82:16 | SubIndex 022 | 22. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x16 (Slave 21A)) | UINT32 | RO | 0xF102:16, 1
1A82:17 | SubIndex 023 | 23. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x17 (Slave 22A)) | UINT32 | RO | 0xF102:17, 1
1A82:18 | SubIndex 024 | 24. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x18 (Slave 23A)) | UINT32 | RO | 0xF102:18, 1
1A82:19 | SubIndex 025 | 25. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x19 (Slave 24A)) | UINT32 | RO | 0xF102:19, 1
1A82:1A | SubIndex 026 | 26. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x1A (Slave 25A)) | UINT32 | RO | 0xF102:1A, 1
1A82:1B | SubIndex 027 | 27. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x1B (Slave 26A)) | UINT32 | RO | 0xF102:1B, 1
1A82:1C | SubIndex 028 | 28. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x1C (Slave 27A)) | UINT32 | RO | 0xF102:1C, 1
1A82:1D | SubIndex 029 | 29. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x1D (Slave 28A)) | UINT32 | RO | 0xF102:1D, 1
1A82:1E | SubIndex 030 | 30. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x1E (Slave 29A)) | UINT32 | RO | 0xF102:1E, 1
1A82:1F | SubIndex 031 | 31. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x1F (Slave 30A)) | UINT32 | RO | 0xF102:1F, 1
Index 1A82 ASI TxPDO-Map LAS
Index (hex) | Name | Meaning | Data type | Flags | Default
1A82:20 | SubIndex 032 | 32. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x20 (Slave 31A)) | UINT32 | RO | 0xF102:20, 1
1A82:21 | SubIndex 033 | 33. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x21 (Slave 1B)) | UINT32 | RO | 0xF102:21, 1
1A82:22 | SubIndex 034 | 34. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x22 (Slave 2B)) | UINT32 | RO | 0xF102:22, 1
1A82:23 | SubIndex 035 | 35. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x23 (Slave 3B)) | UINT32 | RO | 0xF102:23, 1
1A82:24 | SubIndex 036 | 36. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x24 (Slave 4B)) | UINT32 | RO | 0xF102:24, 1
1A82:25 | SubIndex 037 | 37. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x25 (Slave 5B)) | UINT32 | RO | 0xF102:25, 1
1A82:26 | SubIndex 038 | 38. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x26 (Slave 6B)) | UINT32 | RO | 0xF102:26, 1
1A82:27 | SubIndex 039 | 39. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x27 (Slave 7B)) | UINT32 | RO | 0xF102:27, 1
1A82:28 | SubIndex 040 | 40. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x28 (Slave 8B)) | UINT32 | RO | 0xF102:28, 1
1A82:29 | SubIndex 041 | 41. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x29 (Slave 9B)) | UINT32 | RO | 0xF102:29, 1
1A82:2A | SubIndex 042 | 42. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x2A (Slave 10B)) | UINT32 | RO | 0xF102:2A, 1
1A82:2B | SubIndex 043 | 43. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x2B (Slave 11B)) | UINT32 | RO | 0xF102:2B, 1
1A82:2C | SubIndex 044 | 44. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x2C (Slave 12B)) | UINT32 | RO | 0xF102:2C, 1
1A82:2D | SubIndex 045 | 45. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x2D (Slave 13B)) | UINT32 | RO | 0xF102:2D, 1
1A82:2E | SubIndex 046 | 46. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x2E (Slave 14B)) | UINT32 | RO | 0xF102:2E, 1
1A82:2F | SubIndex 047 | 47. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x2F (Slave 15B)) | UINT32 | RO | 0xF102:2F, 1
Index 1A82 ASI TxPDO-Map LAS
Index (hex) | Name | Meaning | Data type | Flags | Default
1A82:30 | SubIndex 048 | 48. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x30 (Slave 16B)) | UINT32 | RO | 0xF102:30, 1
1A82:31 | SubIndex 049 | 49. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x31 (Slave 17B)) | UINT32 | RO | 0xF102:31, 1
1A82:32 | SubIndex 050 | 50. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x32 (Slave 18B)) | UINT32 | RO | 0xF102:32, 1
1A82:33 | SubIndex 051 | 51. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x33 (Slave 19B)) | UINT32 | RO | 0xF102:33, 1
1A82:34 | SubIndex 052 | 52. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x34 (Slave 20B)) | UINT32 | RO | 0xF102:34, 1
1A82:35 | SubIndex 053 | 53. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x35 (Slave 21B)) | UINT32 | RO | 0xF102:35, 1
1A82:36 | SubIndex 054 | 54. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x36 (Slave 22B)) | UINT32 | RO | 0xF102:36, 1
1A82:37 | SubIndex 055 | 55. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x37 (Slave 23B)) | UINT32 | RO | 0xF102:37, 1
1A82:38 | SubIndex 056 | 56. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x38 (Slave 24B)) | UINT32 | RO | 0xF102:38, 1
1A82:39 | SubIndex 057 | 57. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x39 (Slave 25B)) | UINT32 | RO | 0xF102:39, 1
1A82:3A | SubIndex 058 | 58. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x3A (Slave 26B)) | UINT32 | RO | 0xF102:3A, 1
1A82:3B | SubIndex 059 | 59. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x3B (Slave 27B)) | UINT32 | RO | 0xF102:3B, 1
1A82:3C | SubIndex 060 | 60. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x3C (Slave 28B)) | UINT32 | RO | 0xF102:3C, 1
1A82:3D | SubIndex 061 | 61. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x3D (Slave 29B)) | UINT32 | RO | 0xF102:3D, 1
1A82:3E | SubIndex 062 | 62. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x3E (Slave 30B)) | UINT32 | RO | 0xF102:3E, 1
1A82:3F | SubIndex 063 | 63. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x3F (Slave 31B)) | UINT32 | RO | 0xF102:3F, 1
1A82:40 | SubIndex 064 | 64. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
Index 1A83 ASI TxPDO-Map LPS
Index (hex) | Name | Meaning | Data type | Flags | Default
1A83:0 | ASI TxPDO-Map LPS | PDO Mapping TxPDO 132 | UINT8 | RO | 0x40 (64dec)
1A83:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x01 (Slave 0)) | UINT32 | RO | 0xF103:01, 1
1A83:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x02 (Slave 1A)) | UINT32 | RO | 0xF103:02, 1
1A83:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x03 (Slave 2A)) | UINT32 | RO | 0xF103:03, 1
1A83:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x04 (Slave 3A)) | UINT32 | RO | 0xF103:04, 1
1A83:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x05 (Slave 4A)) | UINT32 | RO | 0xF103:05, 1
1A83:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x06 (Slave 5A)) | UINT32 | RO | 0xF103:06, 1
1A83:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x07 (Slave 6A)) | UINT32 | RO | 0xF103:07, 1
1A83:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x08 (Slave 7A)) | UINT32 | RO | 0xF103:08, 1
1A83:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x09 (Slave 8A)) | UINT32 | RO | 0xF103:09, 1
1A83:0A | SubIndex 010 | 10. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x0A (Slave 9A)) | UINT32 | RO | 0xF103:0A, 1
1A83:0B | SubIndex 011 | 11. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x0B (Slave 10A)) | UINT32 | RO | 0xF103:0B, 1
1A83:0C | SubIndex 012 | 12. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x0C (Slave 11A)) | UINT32 | RO | 0xF103:0C, 1
1A83:0D | SubIndex 013 | 13. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x0D (Slave 12A)) | UINT32 | RO | 0xF103:0D, 1
1A83:0E | SubIndex 014 | 14. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x0E (Slave 13A)) | UINT32 | RO | 0xF103:0E, 1
1A83:0F | SubIndex 015 | 15. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x0F (Slave 14A)) | UINT32 | RO | 0xF103:0F, 1
Index 1A83 ASI TxPDO-Map LPS
Index (hex) | Name | Meaning | Data type | Flags | Default
1A83:10 | SubIndex 016 | 16. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x10 (Slave 15A)) | UINT32 | RO | 0xF103:10, 1
1A83:11 | SubIndex 017 | 17. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x11 (Slave 16A)) | UINT32 | RO | 0xF103:11, 1
1A83:12 | SubIndex 018 | 18. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x12 (Slave 17A)) | UINT32 | RO | 0xF103:12, 1
1A83:13 | SubIndex 019 | 19. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x13 (Slave 18A)) | UINT32 | RO | 0xF103:13, 1
1A83:14 | SubIndex 020 | 20. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x14 (Slave 19A)) | UINT32 | RO | 0xF103:14, 1
1A83:15 | SubIndex 021 | 21. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x15 (Slave 20A)) | UINT32 | RO | 0xF103:15, 1
1A83:16 | SubIndex 022 | 22. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x16 (Slave 21A)) | UINT32 | RO | 0xF103:16, 1
1A83:17 | SubIndex 023 | 23. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x17 (Slave 22A)) | UINT32 | RO | 0xF103:17, 1
1A83:18 | SubIndex 024 | 24. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x18 (Slave 23A)) | UINT32 | RO | 0xF103:18, 1
1A83:19 | SubIndex 025 | 25. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x19 (Slave 24A)) | UINT32 | RO | 0xF103:19, 1
1A83:1A | SubIndex 026 | 26. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x1A (Slave 25A)) | UINT32 | RO | 0xF103:1A, 1
1A83:1B | SubIndex 027 | 27. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x1B (Slave 26A)) | UINT32 | RO | 0xF103:1B, 1
1A83:1C | SubIndex 028 | 28. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x1C (Slave 27A)) | UINT32 | RO | 0xF103:1C, 1
1A83:1D | SubIndex 029 | 29. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x1D (Slave 28A)) | UINT32 | RO | 0xF103:1D, 1
1A83:1E | SubIndex 030 | 30. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x1E (Slave 29A)) | UINT32 | RO | 0xF103:1E, 1
1A83:1F | SubIndex 031 | 31. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x1F (Slave 30A)) | UINT32 | RO | 0xF103:1F, 1
Index 1A83 ASI TxPDO-Map LPS
Index (hex) | Name | Meaning | Data type | Flags | Default
1A83:20 | SubIndex 032 | 32. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x20 (Slave 31A)) | UINT32 | RO | 0xF103:20, 1
1A83:21 | SubIndex 033 | 33. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x21 (Slave 1B)) | UINT32 | RO | 0xF103:21, 1
1A83:22 | SubIndex 034 | 34. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x22 (Slave 2B)) | UINT32 | RO | 0xF103:22, 1
1A83:23 | SubIndex 035 | 35. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x23 (Slave 3B)) | UINT32 | RO | 0xF103:23, 1
1A83:24 | SubIndex 036 | 36. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x24 (Slave 4B)) | UINT32 | RO | 0xF103:24, 1
1A83:25 | SubIndex 037 | 37. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x25 (Slave 5B)) | UINT32 | RO | 0xF103:25, 1
1A83:26 | SubIndex 038 | 38. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x26 (Slave 6B)) | UINT32 | RO | 0xF103:26, 1
1A83:27 | SubIndex 039 | 39. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x27 (Slave 7B)) | UINT32 | RO | 0xF103:27, 1
1A83:28 | SubIndex 040 | 40. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x28 (Slave 8B)) | UINT32 | RO | 0xF103:28, 1
1A83:29 | SubIndex 041 | 41. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x29 (Slave 9B)) | UINT32 | RO | 0xF103:29, 1
1A83:2A | SubIndex 042 | 42. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x2A (Slave 10B)) | UINT32 | RO | 0xF103:2A, 1
1A83:2B | SubIndex 043 | 43. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x2B (Slave 11B)) | UINT32 | RO | 0xF103:2B, 1
1A83:2C | SubIndex 044 | 44. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x2C (Slave 12B)) | UINT32 | RO | 0xF103:2C, 1
1A83:2D | SubIndex 045 | 45. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x2D (Slave 13B)) | UINT32 | RO | 0xF103:2D, 1
1A83:2E | SubIndex 046 | 46. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x2E (Slave 14B)) | UINT32 | RO | 0xF103:2E, 1
1A83:2F | SubIndex 047 | 47. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x2F (Slave 15B)) | UINT32 | RO | 0xF103:2F, 1
Index 1A83 ASI TxPDO-Map LPS
Index (hex) | Name | Meaning | Data type | Flags | Default
1A83:30 | SubIndex 048 | 48. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x30 (Slave 16B)) | UINT32 | RO | 0xF103:30, 1
1A83:31 | SubIndex 049 | 49. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x31 (Slave 17B)) | UINT32 | RO | 0xF103:31, 1
1A83:32 | SubIndex 050 | 50. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x32 (Slave 18B)) | UINT32 | RO | 0xF103:32, 1
1A83:33 | SubIndex 051 | 51. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x33 (Slave 19B)) | UINT32 | RO | 0xF103:33, 1
1A83:34 | SubIndex 052 | 52. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x34 (Slave 20B)) | UINT32 | RO | 0xF103:34, 1
1A83:35 | SubIndex 053 | 53. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x35 (Slave 21B)) | UINT32 | RO | 0xF103:35, 1
1A83:36 | SubIndex 054 | 54. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x36 (Slave 22B)) | UINT32 | RO | 0xF103:36, 1
1A83:37 | SubIndex 055 | 55. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x37 (Slave 23B)) | UINT32 | RO | 0xF103:37, 1
1A83:38 | SubIndex 056 | 56. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x38 (Slave 24B)) | UINT32 | RO | 0xF103:38, 1
1A83:39 | SubIndex 057 | 57. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x39 (Slave 25B)) | UINT32 | RO | 0xF103:39, 1
1A83:3A | SubIndex 058 | 58. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x3A (Slave 26B)) | UINT32 | RO | 0xF103:3A, 1
1A83:3B | SubIndex 059 | 59. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x3B (Slave 27B)) | UINT32 | RO | 0xF103:3B, 1
1A83:3C | SubIndex 060 | 60. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x3C (Slave 28B)) | UINT32 | RO | 0xF103:3C, 1
1A83:3D | SubIndex 061 | 61. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x3D (Slave 29B)) | UINT32 | RO | 0xF103:3D, 1
1A83:3E | SubIndex 062 | 62. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x3E (Slave 30B)) | UINT32 | RO | 0xF103:3E, 1
1A83:3F | SubIndex 063 | 63. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x3F (Slave 31B)) | UINT32 | RO | 0xF103:3F, 1
1A83:40 | SubIndex 064 | 64. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
Index 1C00Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the sync managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x02 (2dec)
1C12:01 | SubIndex 001 | 1. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1640 (5696dec)
1C12:02 | SubIndex 002 | 2. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1680 (5760dec)
1C12:03 | SubIndex 003 | 3. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:04 | SubIndex 004 | 4. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:05 | SubIndex 005 | 5. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:06 | SubIndex 006 | 6. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:07 | SubIndex 007 | 7. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:08 | SubIndex 008 | 8. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:09 | SubIndex 009 | 9. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:0A | SubIndex 010 | 10. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:0B | SubIndex 011 | 11. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:0C | SubIndex 012 | 12. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:0D | SubIndex 013 | 13. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:0E | SubIndex 014 | 14. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:0F | SubIndex 015 | 15. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 1C12 RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:10 | SubIndex 016 | 16. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:11 | SubIndex 017 | 17. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:12 | SubIndex 018 | 18. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:13 | SubIndex 019 | 19. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:14 | SubIndex 020 | 20. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:15 | SubIndex 021 | 21. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:16 | SubIndex 022 | 22. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:17 | SubIndex 023 | 23. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:18 | SubIndex 024 | 24. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:19 | SubIndex 025 | 25. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:1A | SubIndex 026 | 26. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:1B | SubIndex 027 | 27. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:1C | SubIndex 028 | 28. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:1D | SubIndex 029 | 29. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:1E | SubIndex 030 | 30. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:1F | SubIndex 031 | 31. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:20 | SubIndex 032 | 32. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:21 | SubIndex 033 | 33. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:22 | SubIndex 034 | 34. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 1C13 TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x02 (2dec)
1C13:01 | SubIndex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A40 (6720dec)
1C13:02 | SubIndex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A80 (6784dec)
1C13:03 | SubIndex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:04 | SubIndex 004 | 4. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:05 | SubIndex 005 | 5. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:06 | SubIndex 006 | 6. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:07 | SubIndex 007 | 7. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:08 | SubIndex 008 | 8. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:09 | SubIndex 009 | 9. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0A | SubIndex 010 | 10. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0B | SubIndex 011 | 11. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0C | SubIndex 012 | 12. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0D | SubIndex 013 | 13. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0E | SubIndex 014 | 14. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0F | SubIndex 015 | 15. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 1C13 TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:10 | SubIndex 016 | 16. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:11 | SubIndex 017 | 17. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:12 | SubIndex 018 | 18. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:13 | SubIndex 019 | 19. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:14 | SubIndex 020 | 20. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:15 | SubIndex 021 | 21. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:16 | SubIndex 022 | 22. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:17 | SubIndex 023 | 23. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:18 | SubIndex 024 | 24. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:19 | SubIndex 025 | 25. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:1A | SubIndex 026 | 26. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:1B | SubIndex 027 | 27. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:1C | SubIndex 028 | 28. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:1D | SubIndex 029 | 29. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:1E | SubIndex 030 | 30. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:1F | SubIndex 031 | 31. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:20 | SubIndex 032 | 32. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:21 | SubIndex 033 | 33. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:22 | SubIndex 034 | 34. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:23 | SubIndex 035 | 35. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:24 | SubIndex 036 | 36. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:25 | SubIndex 037 | 37. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 1C32 SM output parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C32:0
SM output parameter
Synchronization parameters for the outputs
UINT8
RO
0x20 (32dec)
1C32:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchronous with SM 2 event
▪
2: DC-Mode - Synchronous with SYNC0 Event
▪
3: DC-Mode - Synchronous with SYNC1 event
UINT16
RW
0x0000 (0dec)
1C32:02
Cycle time
Cycle time (in ns):
▪
Free Run: Cycle time of the local timer
▪
Synchronous with SM 2 event: Master cycle time
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dec)
1C32:03
Shift time
Time between SYNC0 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000384 (900dec)
1C32:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0 = 1: free run is supported
▪
Bit 1 = 1: Synchronous with SM 2 event is supported
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 10: Output shift with SYNC1 event (only DC mode)
▪
Bit 14 = 1: dynamic times (measurement through writing of 1C32:08)
UINT16
RO
0xC007 (49159dec)
1C32:05
Minimum cycle time
Minimum cycle time (in ns)
UINT32
RO
0x00002710 (10000dec)
1C32:06
Calc and copy time
Minimum time between SYNC0 and SYNC1 event (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:07
Minimum delay time
UINT32
RO
0x00000384 (900dec)
1C32:08
Command
▪
0: Measurement of the local cycle time is stopped
▪
1: Measurement of the local cycle time is started
The entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 are updated with the maximum measured values.
For a subsequent measurement the measured values are reset
UINT16
RW
0x0000 (0dec)
1C32:09
Maximum delay time
Time between SYNC1 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000384 (900dec)
1C32:0B
SM event missed counter
Number of missed SM events in OPERATIONAL (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:0C
Cycle exceeded counter
Number of occasions the cycle time was exceeded in OPERATIONAL (cycle was not completed in time or the next cycle began too early)
UINT16
RO
0x0000 (0dec)
1C32:0D
Shift too short counter
Number of occasions that the interval between SYNC0 and SYNC1 event was too short (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:20
Sync error
The synchronization was not correct in the last cycle (outputs were output too late; DC mode only)
BOOLEAN
RO
0x00 (0dec)
Index 1C33 SM input parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchronous with SM 3 Event (no outputs available)
▪
2: DC - Synchronous with SYNC0 Event
▪
3: DC - Synchronous with SYNC1 Event
▪
34: Synchronous with SM 2 Event (outputs available)
UINT16
RW
0x0000 (0dec)
1C33:02
Cycle time
as 0x1C32:02
UINT32
RW
0x000F4240 (1000000dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000384 (900dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: Synchronous with SM 2 Event is supported (outputs available)
▪
Bit 1: Synchronous with SM 3 Event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: input shift through local event (outputs available)
▪
Bit 4-5 = 10: input shift with SYNC1 event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08 or 0x1C33:08)
UINT16
RO
0xC007 (49159dec)
1C33:05
Minimum cycle time
as 0x1C32:05
UINT32
RO
0x00002710 (10000dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:07
Minimum delay time
UINT32
RO
0x00000384 (900dec)
1C33:08
Command
as 0x1C32:08
UINT16
RW
0x0000 (0dec)
1C33:09
Maximum delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000384 (900dec)
1C33:0B
SM event missed counter
as 0x1C32:11
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
as 0x1C32:12
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
as 0x1C32:13
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
as 0x1C32:32
BOOLEAN
RO
0x00 (0dec)
Index F000 Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0020 (32dec)
Index F008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module list
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list | reserved | UINT8 | RW | 0x20 (32dec)
F010:01 - 20 | SubIndex 001 - 032 | reserved | UINT32 | RW | 0x00001838 (6200dec)


Appendix

Appendix
Appendix
Additional information
•
EtherCAT AL Status Codes
•
Firmware compatibility
•
Firmware Update EL/ES/EM/ELM/EPxxxx
•
Restoring the delivery state
•
Support and Service


EtherCAT AL Status Codes

Appendix [image] EtherCAT AL Status Codes
EtherCAT AL Status Codes
For detailed information please refer to the EtherCAT system description.


Firmware compatibility

Appendix [image] Firmware compatibility
Firmware compatibility
Beckhoff EtherCAT devices are delivered with the latest available firmware version. Compatibility of firmware and hardware is mandatory; not every combination ensures compatibility. The overview below shows the hardware versions on which a firmware can be operated.
Note
▪
It is recommended to use the newest possible firmware for the respective hardware.
▪
Beckhoff is not under any obligation to provide customers with free firmware updates for delivered products.
Note
Risk of damage to the device!
Pay attention to the instructions for firmware updates on the separate page.
If a device is placed in BOOTSTRAP mode for a firmware update, it does not check when downloading whether the new firmware is suitable. This can result in damage to the device! Therefore, always make sure that the firmware is suitable for the hardware version!
EL6201-0000
Hardware (HW) | Firmware (FW) | Revision no.. | Release date
01 - 05* | 01 | EL6201-0000-0017 | 2013/01
 | 02 | EL6201-0000-0018 | 2016/01
 | 03* |  | 2019/04
*) This is the current compatible firmware/hardware version at the time of the preparing this documentation. Check on the Beckhoff web page whether more up-to-date documentation is available.


Firmware Update EL/ES/EM/ELM/EPxxxx

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx
Firmware Update EL/ES/EM/ELM/EPxxxx
This section describes the device update for Beckhoff EtherCAT slaves from the EL/ES, ELM, EM, EK and EP series. A firmware update should only be carried out after consultation with Beckhoff support.
Storage locations
An EtherCAT slave stores operating data in up to 3 locations:
▪
Depending on functionality and performance EtherCAT slaves have one or several local controllers for processing I/O data. The corresponding program is the so-called firmware in *.efw format.
▪
In some EtherCAT slaves the EtherCAT communication may also be integrated in these controllers. In this case the controller is usually a so-called FPGA chip with *.rbf firmware.
▪
In addition, each EtherCAT slave has a memory chip, a so-called ESI-EEPROM, for storing its own device description (ESI: EtherCAT Slave Information). On power-up this description is loaded and the EtherCAT communication is set up accordingly. The device description is available from the download area of the Beckhoff website at (https://www.beckhoff.de). All ESI files are accessible there as zip files.
Customers can access the data via the EtherCAT fieldbus and its communication mechanisms. Acyclic mailbox communication or register access to the ESC is used for updating or reading of these data.
The TwinCAT System Manager offers mechanisms for programming all 3 parts with new data, if the slave is set up for this purpose. Generally the slave does not check whether the new data are suitable, i.e. it may no longer be able to operate if the data are unsuitable.
Simplified update by bundle firmware
The update using so-called bundle firmware is more convenient: in this case the controller firmware and the ESI description are combined in a *.efw file; during the update both the firmware and the ESI are changed in the terminal. For this to happen it is necessary
▪
for the firmware to be in a packed format: recognizable by the file name, which also contains the revision number, e.g. ELxxxx-xxxx_REV0016_SW01.efw
▪
for password=1 to be entered in the download dialog. If password=0 (default setting) only the firmware update is carried out, without an ESI update.
▪
for the device to support this function. The function usually cannot be retrofitted; it is a component of many new developments from year of manufacture 2016.
Following the update, its success should be verified
▪
ESI/Revision: e.g. by means of an online scan in TwinCAT ConfigMode/FreeRun – this is a convenient way to determine the revision
▪
Firmware: e.g. by looking in the online CoE of the device
Note
Risk of damage to the device!
Note the following when downloading new device files

• Firmware downloads to an EtherCAT device must not be interrupted
• Flawless EtherCAT communication must be ensured. CRC errors or LostFrames must be avoided.
• The power supply must adequately dimensioned. The signal level must meet the specification.

In the event of malfunctions during the update process the EtherCAT device may become unusable and require re-commissioning by the manufacturer.
Additional information
•
Device description ESI file/XML
•
Firmware explanation
•
Updating controller firmware *.efw
•
FPGA firmware *.rbf
•
Simultaneous updating of several EtherCAT devices


Device description ESI file/XML

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Device description ESI file/XML
Device description ESI file/XML
Note
Attention regarding update of the ESI description/EEPROM
Some slaves have stored calibration and configuration data from the production in the EEPROM. These are irretrievably overwritten during an update.
The ESI device description is stored locally on the slave and loaded on start-up. Each device description has a unique identifier consisting of slave name (9 characters/digits) and a revision number (4 digits). Each slave configured in the System Manager shows its identifier in the EtherCAT tab:
Device identifier consisting of name EL3204-0000 and revision -0016
The configured identifier must be compatible with the actual device description used as hardware, i.e. the description which the slave has loaded on start-up (in this case EL3204). Normally the configured revision must be the same or lower than that actually present in the terminal network.
For further information on this, please refer to the EtherCAT system documentation.
Update of XML/ESI description
The device revision is closely linked to the firmware and hardware used. Incompatible combinations lead to malfunctions or even final shutdown of the device. Corresponding updates should only be carried out in consultation with Beckhoff support.
Display of ESI slave identifier
The simplest way to ascertain compliance of configured and actual device description is to scan the EtherCAT boxes in TwinCAT mode Config/FreeRun:
Scan the subordinate field by right-clicking on the EtherCAT device
If the found field matches the configured field, the display shows
Configuration is identical
otherwise a change dialog appears for entering the actual data in the configuration.
Change dialog
In this example in Fig. Change dialog, an EL3201-0000-0017 was found, while an EL3201-0000-0016 was configured. In this case the configuration can be adapted with the Copy Before button. The Extended Information checkbox must be set in order to display the revision.
Changing the ESI slave identifier
The ESI/EEPROM identifier can be updated as follows under TwinCAT:
▪
Trouble-free EtherCAT communication must be established with the slave.
▪
The state of the slave is irrelevant.
▪
Right-clicking on the slave in the online display opens the EEPROM Update dialog, Fig. EEPROM Update
EEPROM Update
The new ESI description is selected in the following dialog, see Fig. Selecting the new ESI. The checkbox Show Hidden Devices also displays older, normally hidden versions of a slave.
Selecting the new ESI
A progress bar in the System Manager shows the progress. Data are first written, then verified.
The change only takes effect after a restart.
Most EtherCAT devices read a modified ESI description immediately or after startup from the INIT. Some communication settings such as distributed clocks are only read during power-on. The EtherCAT slave therefore has to be switched off briefly in order for the change to take effect.


Firmware explanation

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Firmware explanation
Firmware explanation
Determining the firmware version
Determining the version on laser inscription
Beckhoff EtherCAT slaves feature serial numbers applied by laser. The serial number has the following structure: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with ser. no.: 12 10 03 02:
12 - week of production 12
10 - year of production 2010
03 - firmware version 03
02 - hardware version 02
Determining the version via the System Manager
The TwinCAT System Manager shows the version of the controller firmware if the master can access the slave online. Click on the E-Bus Terminal whose controller firmware you want to check (in the example terminal 2 (EL3204)) and select the tab CoE Online (CAN over EtherCAT).
CoE Online and Offline CoE
Two CoE directories are available:
• online: This is offered in the EtherCAT slave by the controller, if the EtherCAT slave supports this. This CoE directory can only be displayed if a slave is connected and operational.
• offline: The EtherCAT Slave Information ESI/XML may contain the default content of the CoE. This CoE directory can only be displayed if it is included in the ESI (e.g. "Beckhoff EL5xxx.xml").
The Advanced button must be used for switching between the two views.
In Fig. Display of EL3204 firmware version the firmware version of the selected EL3204 is shown as 03 in CoE entry 0x100A.
Display of EL3204 firmware version
In (A) TwinCAT 2.11 shows that the Online CoE directory is currently displayed. If this is not the case, the Online directory can be loaded via the Online option in Advanced Settings (B) and double-clicking on AllObjects.


Updating controller firmware *.efw

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Updating controller firmware *.efw
Updating controller firmware *.efw
CoE directory
The Online CoE directory is managed by the controller and stored in a dedicated EEPROM, which is generally not changed during a firmware update.
Switch to the Online tab to update the controller firmware of a slave, see Fig. Firmware Update.
Firmware Update
Proceed as follows, unless instructed otherwise by Beckhoff support. Valid for TwinCAT 2 and 3 as EtherCAT master.
▪
Switch TwinCAT system to ConfigMode/FreeRun with cycle time >= 1 ms (default in ConfigMode is 4 ms). A FW-Update during real time operation is not recommended.
▪
Switch EtherCAT Master to PreOP
▪
Switch slave to INIT (A)
▪
Switch slave to BOOTSTRAP
▪
Check the current status (B, C)
▪
Download the new *efw file (wait until it ends). A pass word will not be neccessary usually.
▪
After the download switch to INIT, then PreOP
▪
Switch off the slave briefly (don't pull under voltage!)
▪
Check within CoE 0x100A, if the FW status was correctly overtaken.


FPGA firmware *.rbf

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] FPGA firmware *.rbf
FPGA firmware *.rbf
If an FPGA chip deals with the EtherCAT communication an update may be accomplished via an *.rbf file.
▪
Controller firmware for processing I/O signals
▪
FPGA firmware for EtherCAT communication (only for terminals with FPGA)
The firmware version number included in the terminal serial number contains both firmware components. If one of these firmware components is modified this version number is updated.
Determining the version via the System Manager
The TwinCAT System Manager indicates the FPGA firmware version. Click on the Ethernet card of your EtherCAT strand (Device 2 in the example) and select the Online tab.
The Reg:0002 column indicates the firmware version of the individual EtherCAT devices in hexadecimal and decimal representation.
FPGA firmware version definition
If the column Reg:0002 is not displayed, right-click the table header and select Properties in the context menu.
Context menu Properties
The Advanced Settings dialog appears where the columns to be displayed can be selected. Under Diagnosis/Online View select the '0002 ETxxxx Build' check box in order to activate the FPGA firmware version display.
Dialog Advanced Settings
Update
For updating the FPGA firmware
▪
of an EtherCAT coupler the coupler must have FPGA firmware version 11 or higher;
▪
of an E-Bus Terminal the terminal must have FPGA firmware version 10 or higher.
Older firmware versions can only be updated by the manufacturer!
Updating an EtherCAT device
The following sequence order have to be met if no other specifications are given (e.g. by the Beckhoff support):
▪
Switch TwinCAT system to ConfigMode/FreeRun with cycle time >= 1 ms (default in ConfigMode is 4 ms). A FW-Update during real time operation is not recommended.
▪
In the TwinCAT System Manager select the terminal for which the FPGA firmware is to be updated (in the example: Terminal 5: EL5001) and
click the Advanced Settings button in the EtherCAT tab:
▪
The Advanced Settings dialog appears. Under ESC Access/E²PROM/FPGA click on Write FPGA button:
▪
Select the file (*.rbf) with the new FPGA firmware, and transfer it to the EtherCAT device:
▪
Wait until download ends
▪
Switch slave current less for a short time (don't pull under voltage!). In order to activate the new FPGA firmware a restart (switching the power supply off and on again) of the EtherCAT device is required.
▪
Check the new FPGA status
Note
Risk of damage to the device!
A download of firmware to an EtherCAT device must not be interrupted in any case! If you interrupt this process by switching off power supply or disconnecting the Ethernet link, the EtherCAT device can only be recommissioned by the manufacturer!


Simultaneous updating of several EtherCAT devices

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Simultaneous updating of several EtherCAT devices
Simultaneous updating of several EtherCAT devices
The firmware and ESI descriptions of several devices can be updated simultaneously, provided the devices have the same firmware file/ESI.
Multiple selection and firmware update
Select the required slaves and carry out the firmware update in BOOTSTRAP mode as described above.


Restoring the delivery state

Appendix [image] Restoring the delivery state
Restoring the delivery state
To restore the delivery state for backup objects in ELxxxx terminals, the CoE object Restore default parameters, SubIndex 001 can be selected in the TwinCAT System Manager (Config mode) (see Fig. Selecting the Restore default parameters PDO)
Selecting the "Restore default parameters" PDO
Double-click on SubIndex 001 to enter the Set Value dialog. Enter the value 1684107116 in field Dec or the value 0x64616F6C in field Hex and confirm with OK (Fig. Entering a restore value in the Set Value dialog).
All backup objects are reset to the delivery state.
Entering a restore value in the Set Value dialog
Alternative restore value
In some older terminals the backup objects can be switched with an alternative restore value: Decimal value: 1819238756, Hexadecimal value: 0x6C6F6164An incorrect entry for the restore value has no effect.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com