EL3751 - Short documentation 1-channel multi-functional input for analog measurement technology, 24 bit, 10 ksps
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation Issue Status
•
Version identification of EtherCAT devices


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation Issue Status

Foreword [image] Documentation Issue Status
Documentation Issue Status
Version
Comment
3.0
▪
First publication


Version identification of EtherCAT devices

Foreword [image] Version identification of EtherCAT devices
Version identification of EtherCAT devices
Designation
A Beckhoff EtherCAT device has a 14-digit designation, made up of
▪
family key
▪
type
▪
version
▪
revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
Notes
▪
The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
▪
EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
▪
The order identifier is made up of
- family key (EL, EP, CU, ES, KL, CX, etc.)
- type (3314)
- version (-0000)
▪
The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
▪
The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Identification number
Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:
Production lot/batch number/serial number/date code/D number
The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02
Exceptions can occur in the IP67 area, where the following syntax can be used (see respective device documentation):
Syntax: D ww yy x y z u
D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB
Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1
Unique serial number/ID, ID number
In addition, in some series each individual module has its own unique serial number.
See also the further documentation in the area
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Terminals with factory calibration certificate and other measuring terminals
Examples of markings
EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
CU2016 switch with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
EP1258-00001 IP67 EtherCAT Box with batch number/ date code 22090101 and unique serial number 158102
EP1908-0002 IP67 EtherCAT Safety Box with batch number/ date code 071201FF and unique serial number 00346070
EL2904 IP20 safety terminal with batch number/ date code 50110302 and unique serial number 00331701
ELM3604-0002 terminal with unique ID number (QR code) 100001051 and serial/ batch number 44160201
Additional information
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Foreword [image] Version identification of EtherCAT devices [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Product overview

Product overview
Product overview
EL3751 LEDs, connections and assignment
1-channel multi-functional input for analog measurement technology, 24 bit, 10 ksps, differential inputs, oversampling
Additional information
•
Description
•
Technical data


Description

Product overview [image] Description
Description
As a multi-functional input for analog measurement technology, the EL3751 analog input terminal can be used for measuring electrical parameters in several measuring ranges. The respective nominal measuring ranges are:
▪
Voltage between ±5 mV and ±30 V, 0..10 V, 0..5 V
▪
Current in the range ±20 mA , 4..20 mA, 0..20 mA, NAMUR NE43
▪
Resistor bridge, strain gauge (SG): 1/4 bridge (350 Ω + 120 Ω),
1/2 bridge (±16 mV/V) and 1/1 bridge (±32 mV/V) in 2-6 wire connection
▪
Electrical resistance R / temperature with RTD (PT100 etc.): 0…5 kΩ in 2-4 wire connection
▪
Potentiometer up to 1 kΩ
The nominal measuring range referred to above is part of the total available and usable technical measuring range, which for the EL3751 is approx. ±107%, depending on the measuring range. The "extended range" property can be disabled, in order to make the behavior compatible with the EL30/31/36xx "legacy range".
The measurement takes place via a differential input channel. It is digitized with a resolution of 24 bit and 10 ksps and transported electrically isolated from the fieldbus to the higher-level automation device with optional oversampling. The integrated supply and the switchable auxiliary resistors enable direct connection of a resistor bridge (strain gauge SG) or load cell with 2-/3-/4-/6-wire connection technology, a fixed resistor, a PTC or a potentiometer. The signal state of the EtherCAT Terminal is indicated by light emitting diodes.
If a lower sampling rate is required, a data rate reduction (referred to as decimation) can be set internally, based on the fixed analog sampling rate of 10 ksps. The sampling rate of ≤ 10 ksps achieved in this way can then be transferred to the controller via EtherCAT, based on the task cycle time and a suitable oversampling factor.
The terminal has two configurable numeric software filters up to FIR 39th order (40 taps) or IIR 6th order. The first filter is applied to the 10 ksps raw data, the second filter is based on the user-settable decimation, with a view to suppressing aliasing effects. Both filters can be set based on an integrated list (a number of low-pass, high-pass, mean value filters) or a freely selectable coefficient table.
Non-linear characteristic sensor curves can be corrected flexibly through an integrated sampling points table. Simple mathematical operations are also possible.
Each terminal has a unique ID number, which is printed and electronically readable. The optionally available factory calibration certificate (EL3751-0020) can be assigned via this ID number; re-calibration is possible.


Technical data

Product overview [image] Technical data
Technical data
Additional information
•
Common technical data
•
Process data interpretation
•
General information on measuring accuracy/measurement uncertainty
•
Measurement ±30 V
•
Measurement ±10 V
•
Measurement ±5 V
•
Measurement ±2,5 V
•
Measurement ±1,25 V
•
Measurement ±640 mV
•
Measurement ±320 mV
•
Measurement ±160 mV
•
Measurement ±80 mV
•
Measurement ±40 mV
•
Measurement ±20 mV
•
Measurement ±10 mV
•
Measurement ±5 mV
•
Measurement 0…5 V
•
Measurement 0…10 V
•
Measurement ±20 mA
•
Measurement 0…20 mA
•
Measurement 4…20 mA
•
Measurement 3,6…21 mA (NAMUR NE43)
•
Measurement resistance 0…5 kΩ
•
RTD measurement
•
Potentiometer measurement
•
Measurement SG 1/1 bridge (full bridge) 4/6-wire connection
•
Measurement SG 1/2 bridge (half bridge) 3/5-wire connection
•
Measurement SG 1/4 bridge (quarter bridge) 120 Ω 2/3-wire connection
•
Measurement SG 1/4 bridge (quarter bridge) 350 Ω 2/3-wire connection


Common technical data

Product overview [image] Technical data [image] Common technical data
Common technical data
Technical data
EL3751
Analog inputs
1 channel (differential)
Connection technology
2 - 6 wire
Resolution
24 bit including sign, 32 bit display
Selection of oversampling factors
1, 2, 4, 5, 8, 10, 16, 20, 25, 32, 40, 50, 64
ADC conversion method
deltaSigma, 1.28 MHz (internal sampling rate);
30 kHz hardware filter upstream
Limit frequency input filter hardware
In AD converter: -3dB @ 3.2 kHz, mean value filter 5th order
Measuring error
Typically ±0.01% @ 23°C, exceptions for individual measuring ranges, details see function tables and 2) below.
Max. sampling rate/conversion time
10 ksps/ 100 µs (fixed, additionally free downsampling in firmware through decimation factor)
Supported EtherCAT cycle time
(depending on the operation mode)
DistributedClocks: min. 100 µs, max. 25 ms (max. 10 ms recommended)
FrameTriggered/Synchron: min. 200 µs, max. 100 ms
FreeRun: not supported
Signal delay (step response)
tbd
Signal delay (linear)
tbd.
Phase response linear, constant envelope delay
Acquisition method
Simultaneous (1 channel, simultaneous with DC synchronization of several terminals)
Dielectric strength - destruction limit
max. permitted short-term/continuous voltage
▪
Voltage between each contact point ±I1, ±I2, +UV, and –UV,: non-supplied ±40 V, supplied ±36 V
▪
Voltage between every contact point and SGND (shield, mounting rail): see information to electrical isolation
Note: -UV, corresponds to internal GND
Recommended operation voltage range to compliance with specification (UCM, common mode)
max. permitted voltage during specified normal operation
▪
±I1 and ±I2: typ. ±10 V against –UV,
Note: -UV, corresponds to internal GND
Distributed Clocks
Yes, with oversampling
Electrical isolation bus/channel
500 V DC (1 min. typical test voltage)
Electrical isolation channel/channel
(not applicable since 1 channel)
Bit width of the process image (default setting)
32 bit / per value
Supports NoCoeStorage function
Yes
Special features
integrated switchable ¼ bridge extension for 120 and 350 Ω
Higher-order synchronization, PeakHold drag indicator, predefined and freely configurable software filters, TrueRMS, freely selectable downsampling, 2-stage integrator/differentiator, free scaling function (also non-linear), end value limiter, extended/legacy range, line compensation
Available with factory calibration certificate on request
Technical data | EL3751
Supply voltage for electronic | via the E-bus
Current consumption via E-bus | typ. 260 mA
Thermal power dissipation | typ. 1.2 W
Current consumption from the power contacts | none
Permissible operating altitude range | 0 to 2000 m (derating at higher altitudes on request)
Weight | approx. 65g
Permissible ambient temperature range during operation | 0…+55 °C (in horizontal installation position) 0…+45°C (all other installation positions)
Permissible ambient temperature range during storage | -25…+85 °C
Installation position | Operation possible in all installation positions; compliance with full accuracy only possible in horizontal/standard position.
Permissible relative humidity | 95 %, no condensation
Max. sensor wire length | The wire length from the EtherCAT terminal to the sensor/encoder must have max. 30 m without any action of protection. For larger wire lengths a proper over voltage protection (surge protection) is required.
Dimensions (W x H x D) | approx. 15 mm x 100 mm x 70 mm (width aligned: 12 mm)
Mounting | on 35 mm mounting rail conforms to EN 60715
Vibration/shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Approval | CE
2) Dominant part of the basic accuracy is its offset specification (see following tables). The process described in the Offset correction section eliminates this proportion and increases the measurement accuracy considerably.


Process data interpretation

Product overview [image] Technical data [image] Process data interpretation
Process data interpretation
With regard to the output of the cyclic process data, the whole measuring range presents itself as follows:
Basic range of a process data value
The channel for this terminal features an option to set the measuring range either to the conventional Beckhoff type: "nominal full-scale value = PDO end value: Legacy Range" or the new method "technical full-scale value = PDO end value: Extended Range".
▪
Extended Range mode
–
technical full scale value = PDO end value 0x007FFFFF.
–
For information purposes, the channel can measure up to approx. 107% beyond the nominal range, although accuracy specifications etc. are then no longer valid.
–
Outside the nominal measuring range, the Overrange or Underrange bit is set.
–
For further diagnosis, the error bit and the error LED are set, if configurable limits are exceeded. By default the limits are set to the technical measuring range, although they can be narrowed by the customer.
Example: In 4…20 mA measuring mode, the limit is set to 0 mA, although it can be customized in the CoE, e.g. to 3.6 mA, in order to enable earlier detection of sensor faults.
–
The Extended Range mode is the default setting for the terminal.
–
The mode is defined through the non-periodic rational LSB step size and an integer end value. The step size can therefore be used in a PLC program without rounding error.
▪
Legacy Range mode
–
Nominal full scale value = PDO end value.
–
Compatible with existing interface from EL30xx/EL31xx/EL36xx.
–
Overrange/Underrange, Error bit and Error LED are set simultaneously if the nominal/technical measuring range is exceeded.
–
Can be optionally activated in the terminal.
–
The mode is defined by an integer end value; not a whole number of the LSB step is accepted for it.


General information on measuring accuracy/measurement uncertainty

Product overview [image] Technical data [image] General information on measuring accuracy/measurement uncertainty
General information on measuring accuracy/measurement uncertainty
For basic information regarding the explanatory notes below, please refer to chapter "Notes on analog measured values", particularly full scale value.
This guidance could be worth to read for saving effort, time and perhaps money, too.
Basic information on measurement technology:
Using measuring devices an attempt is made with a greater or lesser degree of expenditure to determine the "true value" of a measured variable, for example the ambient temperature. For various practical reasons this is not conclusively possible. Depending on the expenditure, the measurement/measured value is subject to a random measuring error that cannot be eliminated. With its practically determined specification data, Beckhoff provides an approach with which the residual measurement uncertainty can theoretically be calculated in the individual case. The following paragraphs serve this purpose.
General notes
No special maintenance required, although an annual inspection is recommended for the terminal.
If a factory calibration certificate is available for the device, a recalibration interval recommendation of 1 year applies, unless otherwise specified.
Notes regarding the specification data:
▪
Measurement specifications are usually specified as "% of nominal full scale value" = % full scale value (%FSV), unless otherwise specified
▪
In conjunction with each individual value "typical" means that on average this parameter has the specified value. For individual terminals the parameter may deviate from the typical value. Once example is the current consumption.
▪
In the context of a limit (parameter is typically max./min. X) or with two limits (parameter is typically between X and Y) "typical" means that this parameter tends to be between the limits for individual terminals. Deviations are possible, however; see confidence level. Once example is noise. Usually no measurements are made, in order to be able to make statements about standard deviations or result frequencies. A typical value is usually indicated as such after the unit.
▪
The confidence level is 95%, unless otherwise specified.
▪
When the system is operated in an environment that is subject to EMC noise, the following items are required for compliance with the specification
–
an EL9070 shield terminal positioned to the left of the terminal
–
twisted and shielded signal line, at least earthed on one side
▪
If not other specified, measurement errors etc. will be stated in electrical DC operation (no use of AC values). Measurement of an AC value influences the frequency slope of the analog input and therefore the measurement itself.
Note on the temperature
The temperature within/outside the device affects the measurement through the electronics. A measuring setup is generally characterized by a temperature dependence, which is specified in the form of a temperature drift, for example. The specifications are based on a constant ambient temperature. Variable conditions (e.g. heating of the control cabinet, sudden temperature drop due to opening of the control cabinet in cold weather) resulting in a temperature change may alter the measured values through dynamic and heterogeneous temperature distribution. To rectify such effects, the temperature inside the device can be read online from the CoE and used for compensation. Some devices indicate electrically that they have thermally stabilized as well; see diagnosis features.
The specification data apply:
▪
after a warm-up time under operating voltage and in fieldbus mode of least 60 minutes at constant ambient temperature
▪
in horizontal installation position, taking account of the minimum distances
▪
at free convection (no forced ventilation)
▪
provided the specification data are adhered to
Under different conditions, a user-specific compensation is required.
Note on calculation with the specification data:
The individual accuracy specifications (offset/gain error, non-linearity, repeatability, noise) are to be summed quadratically to determine a total measurement accuracy – if there are no special conditions that contradict a uniform distribution and thus the quadratic approach (RSS – root of the sum of the squares). The special designated basic accuracy is a subset of the complete measurement accuracy addition, see note below.
Beckhoff usually gives the specification data symmetrically in [±%], i.e. for example ±0.01% or ±100 ppm. Accordingly, therefore, the unsigned total window would be double the value. A peak-to-peak specification is also a total window specification; the symmetrical value is thus half of it. In the quadratic calculation below, the symmetrical "one-sided" value is to be inserted without a sign. Noise is usually specified in peak-to-peak form, therefore the equation for the noise value already contains the divisor /2.
Example:
▪
symmetrical specification: ±0.01% (equivalent to ±100 ppm) e.g. in case of offset specification
▪
Total window: 0.02% (200 ppm)
▪
To be used in the equation: 0.01% (100 ppm)
The total measurement accuracy calculated in this way is to be regarded again as a symmetrical maximum value and thus to be provided with ± and ≤ for further use.
Example:
▪
ETotal = 100 ppm
▪
For further use: "≤ ± 100 ppm"
To put it in words: "The offset of the individual accuracy specifications under the given conditions produced a window of 200 ppm that lies symmetrically around the individual measured value. The measured value specification x thus has an uncertainty of x ±100 ppm; the true value thus lies 95% in this range."
EOffset | : | Offset specification (at 23°C)
EGain | : | Gain/scale specification (at 23°C)
ENoise, PtP | : | Noise specification as a peak-to-peak value (applies to all temperatures)
MV | : | Measured value
FSV | : | Full scale value
ELin | : | Non-linearity error over the entire measuring range (applies to all temperatures)
ERep | : | Repeatability (applies to all temperatures)
TcOffset | : | Temperature coefficient offset
TcGain | : | Temperature coefficient gain
TcTerminal | : | Temperature coefficient of the terminal
ΔT | : | Difference between the ambient temperature and the specified basic temperature (23°C unless specified otherwise)
EAge | : | Error coefficient of ageing
NYears | : | Number of years
ETotal | : | Theoretical calculated total error
Let's say, for example, we have the following values by a determined measurement value of 8.13 V and 10 V measurement mode (FSV = 10 V) and NYears = 0:
▪
Gain specification: EGain = 60 ppmFSV
▪
Offset specification: EOffset = 70 ppmFSV
▪
Non-linearity: ELin = 25 ppmFSV
▪
Repeatability: ERep = 20 ppmFSV
▪
Noise (without filtering): ENoise, PtP = 100 ppmpeak-to-peak
▪
Temperature coefficients:
–
TcGain = 8 ppm/K
–
TcOffset = 5 ppmFSV/K
Then the theoretical possible total measurement accuracy at ΔT = 12K to the basic temperature can be calculated as follows:
or = ±0.0143.. %FSV
Remarks:
ppm ≙ 10-6
% ≙ 10-2
The noise component can be omitted
The noise component FNoise can be omitted from the above equation (= 0) if the average value of a set of samples is considered instead of a single sample. The averaging can take place in the PLC, or it can be done by a filter in the analog channel. The output value of a moving average of many samples has an almost eliminated noise component. The achievable accuracy increases if the noise component is decreasing.
Basic accuracy and averaging
✓
The basic accuracy will be designated separate for simplified usage.
1.
The basic accuracy includes the offset/gain error, non-linearity and repeatability, but not the temperature coefficient nor the noise and is thereby a subset of the above given complete calculation. It is possible to increase the measurement accuracy beyond the basic accuracy by means of the offset correction.
2.
"Averaging" means that the value was obtained from the arithmetic average of usually 100,000 values for the elimination of the noise. Besides, the terminals internal averaging process need not be used absolutely. If resources available, accumulation of average can be executed within the PLC also.
Measurement accuracy of the measurement value (of reading)
In several cases the „Accuracy related to the up-to-date measurement value” i.e. „Accuracy of value” is requested instead of the „Accuracy related to the full scale value (FSV)”.
This value could easily be calculated from the data given by the specification, as the total accuracy consists of a measurement value and full scale value depending part and an exclusive full scale value depending part:


Measurement ±30 V

Product overview [image] Technical data [image] Measurement ±30 V
Measurement ±30 V
Measurement mode |  | ±30 V
Measuring range, nominal |  | -30…+30 V
Measuring range, end value (full scale value) |  | 30 V
Measuring range, technically usable |  | -32.212…+32.212 V
PDO resolution |  | 24 bit (including sign)
PDO LSB (Extended Range) |  | 3.84 µV
PDO LSB (Legacy Range) |  | 3.576.. µV
Basic accuracy: Measuring error at 23°C, with averaging |  | < ±0.01%FSV = ±100 ppmFSV
Offset/Zero Point error (at 23°C) | EOffset | < 65 ppmFSV
Gain/scale/amplification error (at 23°C) | EGain | < 65 ppm
Non-linearity over the whole measuring range | ELin | < 45 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 7.64
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.5 ppmFSV |  | < 20 [digits]
 | Max. SNR | > 112.0 dB
Temperature coefficient | TcGain | < 11 ppm/K typ.
 | TcOffset | < 10 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >68 dB typ. | 50 Hz: >68 dB typ. |  | 1 kHz: >52 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >68 dB typ. | 50 Hz: >100 dB typ. |  | 1 kHz: >100 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.05%FSV = ±500 ppmFSV typ.
Input impedance ±Input 1 (Internal resistance) |  | Differential 570 kΩ || 11 nF typ.
 |  | CommonMode 140 kΩ || 40 nF typ. Methodology: Resistor against -UV, capacitance against SGND
Input impedance ±Input 2 |  | No usage of this input in this mode
Display ±30 V measuring range
Grafik aus Neues Fragment (i76lrcd2.png)
Frequency response ±30 V measurement range, fsampling = 10 kHz, integrated filter 1/2 deactivated


Measurement ±10 V

Product overview [image] Technical data [image] Measurement ±10 V
Measurement ±10 V
Measurement mode |  | ±10 V
Measuring range, nominal |  | -10…+10 V
Measuring range, end value (full scale value) |  | 10 V
Measuring range, technically usable |  | -10.737…+10.737 V
PDO resolution |  | 24 bit (including sign)
PDO LSB (Extended Range) |  | 1.28 µV
PDO LSB (Legacy Range) |  | 1.192.. µV
Basic accuracy: Measuring error at 23°C, with averaging |  | < ±0.01%FSV = ±100 ppmFSV
Offset/Zero Point error (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification error (at 23°C) | EGain | < 60 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 2.55
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.05%FSV = ±500 ppmFSV typ.
Input impedance ±Input 1 (Internal resistance) |  | Differential 4.1 MΩ || 11 nF typ.
 |  | CommonMode 1 MΩ || 40 nF typ. Methodology: Resistor against -UV, capacitance against SGND
Input impedance ±Input 2 |  | No usage of this input in this mode
According to the Beckhoff „measurement error” (see section “Measuring error/ measurement deviation”) a reference value can be calculated as specified in section “General information on measuring accuracy/measurement uncertainty”.
That result is for the measurement range ±10V by the above given data and an environment temperature of TEnvironment,max = 55°C to ±321 ppmFSV (or 0.032%FSV).
Display ±10 V measuring range
Grafik aus Neues Fragment (itg8mv72.png)
Frequency response ±10 V measurement range, fsampling = 10 kHz, integrated filter 1/2 deactivated


Measurement ±5 V

Product overview [image] Technical data [image] Measurement ±5 V
Measurement ±5 V
Measurement mode |  | ±5 V
Measuring range, nominal |  | -5…+5 V
Measuring range, end value (full scale value) |  | 5 V
Measuring range, technically usable |  | -5,368…+5,368 V
PDO resolution |  | 24 bit (including sign)
PDO LSB (Extended Range) |  | 640 nV
PDO LSB (Legacy Range) |  | 596.. nV
Basic accuracy: Measuring error at 23°C, with averaging |  | < ±0.01%FSV = ±100 ppmFSV
Offset/Zero Point error (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification error (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 1.27
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.05%FSV = ±500 ppmFSV typ.
Input impedance ±Input 1 (Internal resistance) |  | Differential 4.1 MΩ || 11 nF typ.
 |  | CommonMode 1 MΩ || 40 nF typ. Methodology: Resistor against -UV, capacitance against SGND
Input impedance ±Input 2 |  | No usage of this input in this mode
Display ±5 V measuring range
Grafik aus Neues Fragment (ia6g9tt2.png)
Frequency response ±5 V measurement range, fsampling = 10 kHz, integrated filter 1/2 deactivated


Measurement ±2,5 V

Product overview [image] Technical data [image] Measurement ±2,5 V
Measurement ±2,5 V
Measurement mode |  | ±2.5 V
Measuring range, nominal |  | -2.5 … +2.5 V
Measuring range, end value (full scale value) |  | 2.5 V
Measuring range, technically usable |  | -2.684…+2.684 V
PDO resolution |  | 24 bit (including sign)
PDO LSB (Extended Range) |  | 320 nV
PDO LSB (Legacy Range) |  | 298.. nV
Basic accuracy: Measuring error at 23°C, with averaging |  | < ±0.01%FSV = ±100 ppmFSV
Offset/Zero Point error (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification error (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 90 ppmFSV |  | < 703 [digits]
 | ENoise, RMS | < 17 ppmFSV |  | < 133 [digits]
 | Max. SNR | > 95.4 dB
 | Noisedensity@1kHz | < 0.60
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 9 ppmFSV |  | < 70 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.05%FSV = ±500 ppmFSV typ.
Input impedance ±Input 1 (Internal resistance) |  | Differential 4.1 MΩ || 11 nF typ.
 |  | CommonMode 1 MΩ || 40 nF typ. Methodology: Resistor against -UV, capacitance against SGND
Input impedance ±Input 2 |  | No usage of this input in this mode
Display ±2.5 V measuring range
Grafik aus Neues Fragment (i7hf7kj2.png)
Frequency response ±2,5 V measurement range, fsampling = 10 kHz, integrated filter 1/2 deactivated


Measurement ±1,25 V

Product overview [image] Technical data [image] Measurement ±1,25 V
Measurement ±1,25 V
Measurement mode |  | ±1.25 V
Measuring range, nominal |  | -1.25…+1.25 V
Measuring range, end value (full scale value) |  | 1.25 V
Measuring range, technically usable |  | -1.490…+1.490 V
PDO resolution |  | 24 bit (including sign)
PDO LSB (Extended Range) |  | 160 nV
PDO LSB (Legacy Range) |  | 149.. nV
Basic accuracy: Measuring error at 23°C, with averaging |  | < ±0.01%FSV = ±100 ppmFSV
Offset/Zero Point error (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification error (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 90 ppmFSV |  | < 703 [digits]
 | ENoise, RMS | < 17 ppmFSV |  | < 133 [digits]
 | Max. SNR | > 95.4 dB
 | Noisedensity@1kHz | < 0.30
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 9 ppmFSV |  | < 70 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.05%FSV = ±500 ppmFSV typ.
Input impedance ±Input 1 (Internal resistance) |  | Differential 4.1 MΩ || 11 nF typ.
 |  | CommonMode 1 MΩ || 40 nF typ. Methodology: Resistor against -UV, capacitance against SGND
Input impedance ±Input 2 |  | No usage of this input in this mode
Display ±1.25 V measuring range
Grafik aus Neues Fragment (io6gt2t.png)
Frequency response ±1,25 V measurement range, fsampling = 10 kHz, integrated filter 1/2 deactivated


Measurement ±640 mV

Product overview [image] Technical data [image] Measurement ±640 mV
Measurement ±640 mV
Measurement mode |  | ±640 mV
Measuring range, nominal |  | -640…+640 mV
Measuring range, end value (full scale value) |  | 640 mV
Measuring range, technically usable |  | -687.2…+687.2 mV
PDO resolution |  | 24 bit (including sign)
PDO LSB (Extended Range) |  | 81.92 nV
PDO LSB (Legacy Range) |  | 76.29.. nV
Basic accuracy: Measuring error at 23°C, with averaging |  | < ±0.01%FSV = ±100 ppmFSV
Offset/Zero Point error (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification error (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 90 ppmFSV |  | < 703 [digits]
 | ENoise, RMS | < 17 ppmFSV |  | < 133 [digits]
 | Max. SNR | > 95.4 dB
 | Noisedensity@1kHz | < 0.15
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 9 ppmFSV |  | < 70 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.05%FSV = ±500 ppmFSV typ.
Input impedance ±Input 1 (Internal resistance) |  | Differential 4.1 MΩ || 11 nF typ.
 |  | CommonMode 1 MΩ || 40 nF typ. Methodology: Resistor against -UV, capacitance against SGND
Input impedance ±Input 2 |  | No usage of this input in this mode
Display ±640 mV measuring range
Grafik aus Neues Fragment (ierckcr3.png)
Frequency response ±640 mV measurement range, fsampling = 10 kHz, integrated filter 1/2 deactivated


Measurement ±320 mV

Product overview [image] Technical data [image] Measurement ±320 mV
Measurement ±320 mV
Measurement mode |  | ±320 mV
Measuring range, nominal |  | -320…+320 mV
Measuring range, end value (full scale value) |  | 320 mV
Measuring range, technically usable |  | -343.6…+343.6 mV
PDO resolution |  | 24 bit (including sign)
PDO LSB (Extended Range) |  | 40.96 nV
PDO LSB (Legacy Range) |  | 38.14.. nV
Basic accuracy: Measuring error at 23°C, with averaging |  | < ±0.01%FSV = ±100 ppmFSV
Offset/Zero Point error (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification error (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 90 ppmFSV |  | < 703 [digits]
 | ENoise, RMS | < 17 ppmFSV |  | < 133 [digits]
 | Max. SNR | > 95.4 dB
 | Noisedensity@1kHz | < 76.93
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 9 ppmFSV |  | < 70 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.05%FSV = ±500 ppmFSV typ.
Input impedance ±Input 1 (Internal resistance) |  | Differential 4.1 MΩ || 11 nF typ.
 |  | CommonMode 1 MΩ || 40 nF typ. Methodology: Resistor against -UV, capacitance against SGND
Input impedance ±Input 2 |  | No usage of this input in this mode
Display ±320 mV measuring range
Grafik aus Neues Fragment (ih4g4jp3.png)
Frequency response ±320 mV measurement range, fsampling = 10 kHz, integrated filter 1/2 deactivated


Measurement ±160 mV

Product overview [image] Technical data [image] Measurement ±160 mV
Measurement ±160 mV
Measurement mode |  | ±160 mV
Measuring range, nominal |  | -160…+160 mV
Measuring range, end value (full scale value) |  | 160 mV
Measuring range, technically usable |  | -171.8…+171.8 mV
PDO resolution |  | 24 bit (including sign)
PDO LSB (Extended Range) |  | 20.48 nV
PDO LSB (Legacy Range) |  | 19.07.. nV
Basic accuracy: Measuring error at 23°C, with averaging |  | < ±0.01%FSV = ±100 ppmFSV
Offset/Zero Point error (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification error (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 120 ppmFSV |  | < 938 [digits]
 | ENoise, RMS | < 22 ppmFSV |  | < 172 [digits]
 | Max. SNR | > 93.2 dB
 | Noisedensity@1kHz | < 49.78
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 13 ppmFSV |  | < 102 [digits]
 | ENoise, RMS | < 2.5 ppmFSV |  | < 20 [digits]
 | Max. SNR | > 112.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.05%FSV = ±500 ppmFSV typ.
Input impedance ±Input 1 (Internal resistance) |  | Differential 4.1 MΩ || 11 nF typ.
 |  | CommonMode 1 MΩ || 40 nF typ. Methodology: Resistor against -UV, capacitance against SGND
Input impedance ±Input 2 |  | No usage of this input in this mode
Display ±160 mV measuring range
Grafik aus Neues Fragment (ikpiuau.png)
Frequency response ±160 mV measurement range, fsampling = 10 kHz, integrated filter 1/2 deactivated


Measurement ±80 mV

Product overview [image] Technical data [image] Measurement ±80 mV
Measurement ±80 mV
Measurement mode |  | ±80 mV
Measuring range, nominal |  | -80…+80 mV
Measuring range, end value (full scale value) |  | 80 mV
Measuring range, technically usable |  | -85.9…+85.9 mV
PDO resolution |  | 24 bit (including sign)
PDO LSB (Extended Range) |  | 10.24 nV
PDO LSB (Legacy Range) |  | 9.536.. nV
Basic accuracy: Measuring error at 23°C, with averaging |  | < ±0.01%FSV = ±100 ppmFSV
Offset/Zero Point error (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification error (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 160 ppmFSV |  | < 1250 [digits]
 | ENoise, RMS | < 37 ppmFSV |  | < 289 [digits]
 | Max. SNR | > 88.6 dB
 | Noisedensity@1kHz | < 41.86
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 18 ppmFSV |  | < 141 [digits]
 | ENoise, RMS | < 3.5 ppmFSV |  | < 27 [digits]
 | Max. SNR | > 109.1 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.05%FSV = ±500 ppmFSV typ.
Input impedance ±Input 1 (Internal resistance) |  | Differential 4.1 MΩ || 11 nF typ.
 |  | CommonMode 1 MΩ || 40 nF typ. Methodology: Resistor against -UV, capacitance against SGND
Input impedance ±Input 2 |  | No usage of this input in this mode
Display ±80 mV measuring range
Grafik aus Neues Fragment (iabkdhe2.png)
Frequency response ±80 mV measurement range, fsampling = 10 kHz, integrated filter 1/2 deactivated


Measurement ±40 mV

Product overview [image] Technical data [image] Measurement ±40 mV
Measurement ±40 mV
Measurement mode |  | ±40 mV
Measuring range, nominal |  | -40…+40 mV
Measuring range, end value (full scale value) |  | 40 mV
Measuring range, technically usable |  | -42.95…+42.95 V
PDO resolution |  | 24 bit (including sign)
PDO LSB (Extended Range) |  | 5.12 nV
PDO LSB (Legacy Range) |  | 4.768.. nV
Basic accuracy: Measuring error at 23°C, with averaging |  | < ±0.02%FSV = ±200 ppmFSV
Offset/Zero Point error (at 23°C) | EOffset | < 175 ppmFSV
Gain/scale/amplification error (at 23°C) | EGain | < 65 ppm
Non-linearity over the whole measuring range | ELin | < 45 ppmFSV
Repeatability | ERep | < 30 ppmFSV
Noise (without filtering) | ENoise, PtP | < 375 ppmFSV |  | < 2930 [digits]
 | ENoise, RMS | < 75 ppmFSV |  | < 586 [digits]
 | Max. SNR | > 82.5 dB
 | Noisedensity@1kHz | < 42.43
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 40 ppmFSV |  | < 313 [digits]
 | ENoise, RMS | < 5.5 ppmFSV |  | < 43 [digits]
 | Max. SNR | > 105.2 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.1%FSV = ±1000 ppmFSV typ.
Input impedance ±Input 1 (Internal resistance) |  | Differential 4.1 MΩ || 11 nF typ.
 |  | CommonMode 1 MΩ || 40 nF typ. Methodology: Resistor against -UV, capacitance against SGND
Input impedance ±Input 2 |  | No usage of this input in this mode
Display ±40 mV measuring range
Grafik aus Neues Fragment (i9e60t12.png)
Frequency response ±40 mV measurement range, fsampling = 10 kHz, integrated filter 1/2 deactivated


Measurement ±20 mV

Product overview [image] Technical data [image] Measurement ±20 mV
Measurement ±20 mV
Measurement mode |  | ±20 mV
Measuring range, nominal |  | -20…+20 mV
Measuring range, end value (full scale value) |  | 20 mV
Measuring range, technically usable |  | -21.474…+21.474 mV
PDO resolution |  | 24 bit (including sign)
PDO LSB (Extended Range) |  | 2.56 nV
PDO LSB (Legacy Range) |  | 2.384.. nV
Basic accuracy: Measuring error at 23°C, with averaging |  | < ±0.03%FSV = ±300 ppmFSV
Offset/Zero Point error (at 23°C) | EOffset | < 260 ppmFSV
Gain/scale/amplification error (at 23°C) | EGain | < 100 ppm
Non-linearity over the whole measuring range | ELin | < 90 ppmFSV
Repeatability | ERep | < 35 ppmFSV
Noise (without filtering) | ENoise, PtP | < 750 ppmFSV |  | < 5859 [digits]
 | ENoise, RMS | < 150 ppmFSV |  | < 1172 [digits]
 | Max. SNR | > 76.5 dB
 | Noisedensity@1kHz | < 42.43
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 75 ppmFSV |  | < 586 [digits]
 | ENoise, RMS | < 11.5 ppmFSV |  | < 90 [digits]
 | Max. SNR | > 98.8 dB
Temperature coefficient | TcGain | < 12 ppm/K typ.
 | TcOffset | < 12 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.1%FSV = ±1000 ppmFSV typ.
Input impedance ±Input 1 (Internal resistance) |  | Differential 4.1 MΩ || 11 nF typ.
 |  | CommonMode 1 MΩ || 40 nF typ. Methodology: Resistor against -UV, capacitance against SGND
Input impedance ±Input 2 |  | No usage of this input in this mode
Display ±20 mV measuring range


Measurement ±10 mV

Product overview [image] Technical data [image] Measurement ±10 mV
Measurement ±10 mV
Measurement mode |  | ±10 mV
Measuring range, nominal |  | -10…+10 mV
Measuring range, end value (full scale value) |  | 10 mV
Measuring range, technically usable |  | -10.737…+10.737 mV
PDO resolution |  | 24 bit (including sign)
PDO LSB (Extended Range) |  | 1.28 nV
PDO LSB (Legacy Range) |  | 1.192.. nV
Basic accuracy: Measuring error at 23°C, with averaging |  | < ±0.06%FSV = ±600 ppmFSV
Offset/Zero Point error (at 23°C) | EOffset | < 550 ppmFSV
Gain/scale/amplification error (at 23°C) | EGain | < 150 ppm
Non-linearity over the whole measuring range | ELin | < 160 ppmFSV
Repeatability | ERep | < 50 ppmFSV
Noise (without filtering) | ENoise, PtP | < 1200 ppmFSV |  | < 9375 [digits]
 | ENoise, RMS | < 200 ppmFSV |  | < 1563 [digits]
 | Max. SNR | > 74.0 dB
 | Noisedensity@1kHz | < 28.28
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 120 ppmFSV |  | < 938 [digits]
 | ENoise, RMS | < 21.0 ppmFSV |  | < 164 [digits]
 | Max. SNR | > 93.6 dB
Temperature coefficient | TcGain | < 22 ppm/K typ.
 | TcOffset | < 20 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.2%FSV = ±2000 ppmFSV typ.
Input impedance ±Input 1 (Internal resistance) |  | Differential 4.1 MΩ || 11 nF typ.
 |  | CommonMode 1 MΩ || 40 nF typ. Methodology: Resistor against -UV, capacitance against SGND
Input impedance ±Input 2 |  | No usage of this input in this mode
Display ±10 mV measuring range


Measurement ±5 mV

Product overview [image] Technical data [image] Measurement ±5 mV
Measurement ±5 mV
Measurement mode |  | ±5 mV
Measuring range, nominal |  | -5…+5 mV
Measuring range, end value (full scale value) |  | 5 mV
Measuring range, technically usable |  | -5.368…+5.368 mV
PDO resolution |  | 24 bit (including sign)
PDO LSB (Extended Range) |  | 0.64 nV
PDO LSB (Legacy Range) |  | 0.596.. nV
Basic accuracy: Measuring error at 23°C, with averaging |  | < ±0.12%FSV = ±1200 ppmFSV
Offset/Zero Point error (at 23°C) | EOffset | < 1120 ppmFSV
Gain/scale/amplification error (at 23°C) | EGain | < 290 ppm
Non-linearity over the whole measuring range | ELin | < 290 ppmFSV
Repeatability | ERep | < 90 ppmFSV
Noise (without filtering) | ENoise, PtP | < 2400 ppmFSV |  | < 18750 [digits]
 | ENoise, RMS | < 380 ppmFSV |  | < 2969 [digits]
 | Max. SNR | > 68.4 dB
 | Noisedensity@1kHz | < 26.87
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 240 ppmFSV |  | < 1875 [digits]
 | ENoise, RMS | < 42.0 ppmFSV |  | < 328 [digits]
 | Max. SNR | > 87.5 dB
Temperature coefficient | TcGain | < 35 ppm/K typ.
 | TcOffset | < 35 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.2%FSV = ±2000 ppmFSV typ.
Input impedance ±Input 1 (Internal resistance) |  | Differential 4.1 MΩ || 11 nF typ.
 |  | CommonMode 1 MΩ || 40 nF typ. Methodology: Resistor against -UV, capacitance against SGND
Input impedance ±Input 2 |  | No usage of this input in this mode
Display ±5 mV measuring range


Measurement 0…5 V

Product overview [image] Technical data [image] Measurement 0…5 V
Measurement 0…5 V
Measurement mode |  | 0…5 V
Measuring range, nominal |  | 0…5 V
Measuring range, end value (full scale value) |  | 5 V
Measuring range, technically usable |  | 0…5.368 V
PDO resolution |  | 23 bit (unsigned)
PDO LSB (Extended Range) |  | 0.64 µV
Basic accuracy: Measuring error at 23°C, with averaging |  | < ±0.01%FSV = ±100 ppmFSV
Offset/Zero Point error (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification error (at 23°C) | EGain | < 55 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 1.27
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.05%FSV = ±500 ppmFSV typ.
Input impedance ±Input 1 (Internal resistance) |  | Differential 4.1 MΩ || 11 nF typ.
 |  | CommonMode 1 MΩ || 40 nF typ. Methodology: Resistor against -UV, capacitance against SGND
Input impedance ±Input 2 |  | No usage of this input in this mode
Display 0…5 V measuring range
Grafik aus Neues Fragment (ia6g9tt2.png)
Frequency response 0…5 V measurement range, fsampling = 10 kHz, integrated filter 1/2 deactivated


Measurement 0…10 V

Product overview [image] Technical data [image] Measurement 0…10 V
Measurement 0…10 V
Measurement mode |  | 0…10 V
Measuring range, nominal |  | 0…10 V
Measuring range, end value (full scale value) |  | 10 V
Measuring range, technically usable |  | 0…+10.737 V
PDO resolution |  | 23 bit (unsigned)
PDO LSB (Extended Range) |  | 1.28 µV
Basic accuracy: Measuring error at 23°C, with averaging |  | < ±0.01%FSV = ±100 ppmFSV
Offset/Zero Point error (at 23°C) | EOffset | < 70 ppmFSV
Gain/scale/amplification error (at 23°C) | EGain | < 60 ppm
Non-linearity over the whole measuring range | ELin | < 25 ppmFSV
Repeatability | ERep | < 20 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 2.55
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 8 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.05%FSV = ±500 ppmFSV typ.
Input impedance ±Input 1 (Internal resistance) |  | Differential 4.1 MΩ || 11 nF typ.
 |  | CommonMode 1 MΩ || 40 nF typ. Methodology: Resistor against -UV, capacitance against SGND
Input impedance ±Input 2 |  | No usage of this input in this mode
Display 0…10 V measuring range
Grafik aus Neues Fragment (itg8mv72.png)
Frequency response 0…10 V measurement range, fsampling = 10 kHz, integrated filter 1/2 deactivated


Measurement ±20 mA

Product overview [image] Technical data [image] Measurement ±20 mA
Measurement ±20 mA
Measurement mode |  | ±20 mA
Measuring range, nominal |  | -20…+20 mA
Measuring range, end value (full scale value) |  | 20 mA
Measuring range, technically usable |  | -21.474…+21.474 mA, overcurrent-protected
Fuse protection |  | Internal overload limiting, continuous current resistant
PDO resolution |  | 24 bit (including sign)
PDO LSB (Extended Range) |  | 2.56 nA
PDO LSB (Legacy Range) |  | 2.384.. nA
Common-mode voltage Vcm |  | max. +/- 10V related to -Uv (internal ground)
Basic accuracy: Measuring error at 23°C, with averaging |  | < ±0.01%FSV = ±100 ppmFSV
Offset/Zero Point error (at 23°C) | EOffset | < 65 ppmFSV
Gain/scale/amplification error (at 23°C) | EGain | < 50 ppm
Non-linearity over the whole measuring range | ELin | < 40 ppmFSV
Repeatability | ERep | < 40 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 5.09
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 15 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: < 3 nA/V typ. | 50 Hz: < 5 nA/V typ. |  | 1 kHz: < 80 nA/V typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: < 3 nA/V typ. | 50 Hz: < 3 nA/V typ. |  | 1 kHz: < 3 nA/V typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.05%FSV = ±500 ppmFSV typ.
Input impedance ±Input 1 (Internal resistance) |  | Differential 200 Ω || 11 nF typ.
 |  | CommonMode 1 MΩ || 40 nF typ. Methodology: Resistor against -UV, capacitance against SGND
Input impedance ±Input 2 |  | No usage of this input in this mode
Current measuring range ±20 mA
Chart: current measuring range ±20 mA
Grafik aus Neues Fragment (i8011sc2.png)
Frequency response ±20 mA measurement range, fsampling = 10 kHz, integrated filter 1/2 deactivated


Measurement 0…20 mA

Product overview [image] Technical data [image] Measurement 0…20 mA
Measurement 0…20 mA
Measurement mode |  | 0…20 mA
Measuring range, nominal |  | 0…20 mA
Measuring range, end value (full scale value) |  | 20 mA
Measuring range, technically usable |  | 0 …21.474 mA
Fuse protection |  | Internal overload limiting, continuous current resistant
PDO resolution |  | 23 bit (unsigned)
PDO LSB (Extended Range) |  | 2.56 nA
PDO LSB (Legacy Range) |  | 2.384.. nA
Common-mode voltage Vcm |  | max. +/- 10V related to -Uv (internal ground)
Basic accuracy: Measuring error at 23°C, with averaging |  | < ±0.01%FSV = ±100 ppmFSV
Offset/Zero Point error (at 23°C) | EOffset | < 65 ppmFSV
Gain/scale/amplification error (at 23°C) | EGain | < 50 ppm
Non-linearity over the whole measuring range | ELin | < 40 ppmFSV
Repeatability | ERep | < 40 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 5.09
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 15 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: < 3 nA/V typ. | 50 Hz: < 5 nA/V typ. |  | 1 kHz: < 80 nA/V typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: < 3 nA/V typ. | 50 Hz: < 3 nA/V typ. |  | 1 kHz: < 3 nA/V typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.05%FSV = ±500 ppmFSV typ.
Input impedance ±Input 1 (Internal resistance) |  | Differential 200 Ω || 11 nF typ.
 |  | CommonMode 1 MΩ || 40 nF typ. Methodology: Resistor against -UV, capacitance against SGND
Input impedance ±Input 2 |  | No usage of this input in this mode
Current measuring range 0…20 mA
Chart: current measuring range 0…20 mA
Grafik aus Neues Fragment (i8011sc2.png)
Frequency response 0…20 mA measurement range, fsampling = 10 kHz, integrated filter 1/2 deactivated


Measurement 4…20 mA

Product overview [image] Technical data [image] Measurement 4…20 mA
Measurement 4…20 mA
Measurement mode |  | 4…20 mA
Measuring range, nominal |  | 4…20 mA
Measuring range, end value (full scale value) |  | 20 mA
Measuring range, technically usable |  | 0…21.179 mA
Fuse protection |  | Internal overload limiting, continuous current resistant
PDO resolution |  | 24 Bit
PDO LSB (Extended Range) |  | 2.048 nA
PDO LSB (Legacy Range) |  | 1.907.. nA
Common-mode voltage Vcm |  | max. +/- 10V related to -Uv (internal ground)
Basic accuracy: Measuring error at 23°C, with averaging |  | < ±0.01%FSV = ±100 ppmFSV
Offset/Zero Point error (at 23°C) | EOffset | < 65 ppmFSV
Gain/scale/amplification error (at 23°C) | EGain | < 50 ppm
Non-linearity over the whole measuring range | ELin | < 40 ppmFSV
Repeatability | ERep | < 40 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 5.09
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 15 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: < 3 nA/V typ. | 50 Hz: < 5 nA/V typ. |  | 1 kHz: < 80 nA/V typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: < 3 nA/V typ. | 50 Hz: < 3 nA/V typ. |  | 1 kHz: < 3 nA/V typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.05%FSV = ±500 ppmFSV typ.
Input impedance ±Input 1 (Internal resistance) |  | Differential 200 Ω || 11 nF typ.
 |  | CommonMode 1 MΩ || 40 nF typ. Methodology: Resistor against -UV, capacitance against SGND
Input impedance ±Input 2 |  | No usage of this input in this mode
Current measuring range 4…20 mA
Chart: current measuring range 4…20 mA
Grafik aus Neues Fragment (i8011sc2.png)
Frequency response 4…20 mA measurement range, fsampling = 10 kHz, integrated filter 1/2 deactivated


Measurement 3,6…21 mA (NAMUR NE43)

Product overview [image] Technical data [image] Measurement 3,6…21 mA (NAMUR NE43)
Measurement 3,6…21 mA (NAMUR NE43)
Measurement mode |  | 3.6…21 mA (NAMUR NE43)
Measuring range, nominal |  | 4…20 mA
Measuring range, end value (full scale value) |  | 20 mA
Measuring range, technically usable |  | 3.6…21 mA
Fuse protection |  | Internal overload limiting, continuous current resistant
PDO resolution |  | 24 Bit
PDO LSB (Extended Range) |  | 2.048 nA
PDO LSB (Legacy Range) |  | n.a.
Common-mode voltage Vcm |  | max. +/- 10V related to -Uv (internal ground)
Basic accuracy: Measuring error at 23°C, with averaging |  | < ±0.01%FSV = ±100 ppmFSV
Offset/Zero Point error (at 23°C) | EOffset | < 65 ppmFSV
Gain/scale/amplification error (at 23°C) | EGain | < 50 ppm
Non-linearity over the whole measuring range | ELin | < 40 ppmFSV
Repeatability | ERep | < 40 ppmFSV
Noise (without filtering) | ENoise, PtP | < 100 ppmFSV |  | < 781 [digits]
 | ENoise, RMS | < 18 ppmFSV |  | < 141 [digits]
 | Max. SNR | > 94.9 dB
 | Noisedensity@1kHz | < 5.09
Noise (with 50Hz FIR filtering) | ENoise, PtP | < 10 ppmFSV |  | < 78 [digits]
 | ENoise, RMS | < 2.0 ppmFSV |  | < 16 [digits]
 | Max. SNR | > 114.0 dB
Temperature coefficient | TcGain | < 15 ppm/K typ.
 | TcOffset | < 5 ppmFSV/K typ.
Common-mode rejection ratio (without filtering) |  | DC: < 3 nA/V typ. | 50 Hz: < 5 nA/V typ. |  | 1 kHz: < 80 nA/V typ.
Common-mode rejection ratio (with 50Hz FIR filtering) |  | DC: < 3 nA/V typ. | 50 Hz: < 3 nA/V typ. |  | 1 kHz: < 3 nA/V typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.05%FSV = ±500 ppmFSV typ.
Input impedance ±Input 1 (Internal resistance) |  | Differential 200 Ω || 11 nF typ.
 |  | CommonMode 1 MΩ || 40 nF typ. Methodology: Resistor against -UV, capacitance against SGND
Input impedance ±Input 2 |  | No usage of this input in this mode
Current measuring range 3.6…21 mA (NAMUR)
Chart: current measuring range 3.6…21 mA (NAMUR)
Only Extended Range mode for measuring range 4 mA NAMUR
Legacy Range mode is not available for this measurement range. The Extended Range Mode will be set automatically and although a corresponding write access to the CoE Object 0x8000:2E (Scaler) is not declined, the parameter is not changed.
Grafik aus Neues Fragment (i8011sc2.png)
Frequency response 20 mA measurement range, fsampling = 10 kHz, integrated filter 1/2 deactivated


Measurement resistance 0…5 kΩ

Product overview [image] Technical data [image] Measurement resistance 0…5 kΩ
Measurement resistance 0…5 kΩ
With 2-wire measurement, the line resistance of the sensor supply lines influences the measured value. If a reduction of this systematic error component is desirable for 2-wire measurements, the resistance of the supply line to the measuring resistance should be taken into account, in which case the resistance of the supply line has to be determined first. Taking into account the uncertainty associated with this supply line resistance, it can then be included statically in the calculation, in the EL3751 via 0x8000:13. Any change in resistance of the supply line due to ageing, for example, is not taken into account automatically.
A 3-wire measurement enables the systematic component to be eliminated, assuming that the two supply lines are identical. With this measurement type, line resistance of the supply line connected to –Input2 is measured continuously. The value determined in this way is then deducted twice from the measurement result, thereby eliminating the line resistance. Technically, this leads to a significantly more reliable measurement. However, taking into account the measurement uncertainty, the gain from the 3-wire connection is less significant, since this assumption is subject to high uncertainty, in view of the fact that the individual line that was not measured may be damaged, or a varying resistance may have gone unnoticed.
Therefore, although technically the 3-wire connection is a tried and tested approach, for measurements that are methodological assessed based on measurement uncertainty, we strongly recommend fully-compensated 4-wire connection.
Measurement mode |  | Electrical resistance
Operation mode |  | 2.5 V feed voltage, fixed setting n +Uv 5 kΩ reference resistance at –I2 Supply current is given by: 2.5 V / (5 kΩ + Rmeasurement)
Measuring range, nominal |  | 0…5 kΩ
Measuring range, end value (full scale value) |  | 5 kΩ
Measuring range, technically usable |  | 0 Ω…5.368 kΩ *)
PDO resolution |  | 23 bit (unsigned)
PDO LSB (Extended Range) |  | 640 µΩ
PDO LSB (Legacy Range) |  | 596.. µΩ
Basic accuracy: Measuring error at 23°C, with averaging |  | 2-wire connection ±0.05% typ. (full scale value) 3-wire connection ±0.03% typ. (full scale value) 4-wire connection ±0.01% typ. (full scale value)
Temperature coefficient (Terminal) | TcTerminal | < 10 ppm/K typ.
The transition resistance values of the terminal contacts affect the measurement. The measuring error can be reduced further through compensation by the user, with active signal connection.
*) It is not advisable to use the terminal in the range 0 to 10 Ω, due to the relatively low (relative) measuring accuracy in this range. Specialized resistance measuring terminals such as the EL3692 with 4-wire measurement are to be used for such measurements.
Measurement mode |  | Electrical resistance (2 wire)
Offset/Zero Point error (at 23°C) | EOffset | < 475 [ppmFSV]
Gain/scale/amplification error (at 23°C) | EGain | < 150 [ppm]
Non-linearity over the whole measuring range | ELin | < 25 [ppmFSV]
Repeatability | ERep | < 20 [ppmFSV]
Noise (without filtering) | ENoise, PtP | < 220 [ppmFSV] |  | < 1719 [digits]
 | ENoise, RMS | < 45 [ppmFSV] |  | < 352 [digits]
 | Max. SNR | > 86.9 [dB]
 | Noisedensity@1kHz | < 3.18
Noise (with 50 Hz FIR filtering) | ENoise, PtP | < 12 [ppmFSV] |  | < 94 [digits]
 | ENoise, RMS | < 3.0 [ppmFSV] |  | < 23 [digits]
 | Max. SNR | > 110.5 [dB]
Common-mode rejection ratio (without filtering)3 |  | DC: < 150 Ω/V typ. | 50 Hz: < 0.6 kΩ/V typ. |  | 1 kHz: < 3.5 kΩ/V typ.
Common-mode rejection ratio (with 50 Hz FIR filtering)3 |  | DC: < 150 Ω/V typ. | 50 Hz: < 20 Ω/V typ. |  | 1 kHz: < 0.1 Ω/V typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.1%FSV = ±1000 ppmFSV typ.
3) Values related to a common mode interference between SGND and internal ground.
Measurement mode |  | Electrical resistance (3 wire)
Offset/Zero Point error (at 23°C) | EOffset | < 280 [ppmFSV]
Gain/scale/amplification error (at 23°C) | EGain | < 100 [ppm]
Non-linearity over the whole measuring range | ELin | < 25 [ppmFSV]
Repeatability | ERep | < 20 [ppmFSV]
Noise (without filtering) | ENoise, PtP | < 185 [ppmFSV] |  | < 1445 [digits]
 | ENoise, RMS | < 35 [ppmFSV] |  | < 273 [digits]
 | Max. SNR | > 89.1 [dB]
 | Noisedensity@1kHz | < 2.47
Noise (with 50 Hz FIR filtering) | ENoise, PtP | < 11 [ppmFSV] |  | < 86 [digits]
 | ENoise, RMS | < 3.0 [ppmFSV] |  | < 23 [digits]
 | Max. SNR | > 110.5 [dB]
Common-mode rejection ratio (without filtering)3 |  | DC: < 150 Ω/V typ. | 50 Hz: < 0.6 kΩ/V typ. |  | 1 kHz: < 3.5 kΩ/V typ.
Common-mode rejection ratio (with 50 Hz FIR filtering)3 |  | DC: < 150 Ω/V typ. | 50 Hz: < 20 Ω/V typ. |  | 1 kHz: < 0.1 Ω/V typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.1% = 1000 ppmFSV typ.
3) Values related to a common mode interference between SGND and internal ground.
Measurement mode |  | Electrical resistance (4 wire)
Offset/Zero Point error (at 23°C) | EOffset | < 70 [ppmFSV]
Gain/scale/amplification error (at 23°C) | EGain | < 70 [ppm]
Non-linearity over the whole measuring range | ELin | < 15 [ppmFSV]
Repeatability | ERep | < 10 [ppmFSV]
Noise (without filtering) | ENoise, PtP | < 155 [ppmFSV] |  | < 1211 [digits]
 | ENoise, RMS | < 30 [ppmFSV] |  | < 234 [digits]
 | Max. SNR | > 90.5 [dB]
 | Noisedensity@1kHz | < 2.12
Noise (with 50 Hz FIR filtering) | ENoise, PtP | < 9 [ppmFSV] |  | < 70 [digits]
 | ENoise, RMS | < 3.0 [ppmFSV] |  | < 23 [digits]
 | Max. SNR | > 110.5 [dB]
Common-mode rejection ratio (without filtering)3 |  | DC: < 150 Ω/V typ. | 50 Hz: < 0.6 kΩ/V typ. |  | 1 kHz: < 3.5 kΩ/V typ.
Common-mode rejection ratio (with 50 Hz FIR filtering)3 |  | DC: < 150 Ω/V typ. | 50 Hz: < 20 Ω/V typ. |  | 1 kHz: < 0.1 Ω/V typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.1% = 1000 ppmFSV typ.
3) Values related to a common mode interference between SGND and internal ground.
Resistor measuring range 5 kΩ
Chart: resistor measuring range 5 kΩ


RTD measurement

Product overview [image] Technical data [image] RTD measurement
RTD measurement
In RTD measurement range, the measured resistance is internally converted to a temperature based on a set transformation. Since the channel internally measures based on 5 kΩ, the corresponding measurement error should be applied in this measuring range.
In some ranges a (relatively) higher measuring accuracy is achieved, which is why in the table below better temperature accuracy values may be specified for individual sensor types than can be calculated from the 5 kΩ accuracy1).
Please refer to the note on 2/3/4-wire measurement in the preceding chapter "Resistance".
Measurement mode | RTD
Operation mode | 2.5 V feed voltage, fixed setting n +Uv 5 kΩ reference resistance at –I2 Supply current is given by: 2.5 V / (5 kΩ + Rmeasurement) → max. 0.5 mA
PDO resolution | 0.01°C/digit
The transition resistance values of the terminal contacts affect the measurement. The measuring error can be reduced further through compensation by the user, with active signal connection.
The temperature end value corresponds to the nominal full scale value.
RTD measuring range
Chart: RTD measuring range
Data of the sensor types in the following table
The data of the sensor types in the following table is provided for information only and serve as help for orientation. All details of data are without warranty and have to be verified with the data sheet of the respective used sensor.
CoE Enum RTD Element | RTD Type | Temperature Starting value [°C] | Temperature End value [°C] | Achievable accuracy @ sensor temperature (full scale value). 3-wire connection(2 | Achievable accuracy @ sensor temperature (full scale value). 4-wire connection(2 | Temperature coefficient (terminal-specific drift) | Measured value starting value [Ω] | Measured value end value [Ω]
0 | None | - | - | - | - | - | - | -
1 | PT100 | -200 | 850 | ±1K (-200…+850°C) see 1) | ±0.5K (-200…+850°C) see 1) | approx. 0.13 K/K | 18.52 | 390.48
2 | NI100 | -60 | 250 | approx. ±2.68K @ 0°C | approx. ±0.83K @ 0°C | approx. 0.083 K/K | 69.52 | 289.2
3 | PT1000 | -200 | 850 | approx. ±0.38K @ 0°C | approx. ±0.13K @ 0°C | approx. 0.013 K/K | 185.2 | 3904.8
4 | PT500 | -200 | 850 | approx. ±1.03K @ 0°C | approx. ±0.34K @ 0°C | approx. 0.034 K/K | 92.6 | 1952.4
5 | PT200 | -200 | 850 | approx. ±1.96K @ 0°C | approx. ±0.65K @ 0°C | approx. 0.065 K/K | 37.04 | 780.96
6 | NI1000 | -60 | 250 | approx. ±0.34K @ 0°C | approx. ±0.11K @ 0°C | approx. 0.011 K/K | 695.2 | 2892.6
7 | NI1000 (TK5000, 100°C: 1500 Ω) | -30 | 160 | approx. ±0.27K @ 100°C | approx. ±0.089K @ 100°C | approx. 0.009 K/K | 871.7 | 1863.6
8 | NI120 | -60 | 320 | - | - | - | 80.94 | 461.04
9 | KT100/110/130/210/230 KTY10/11/13/16/19 | -50 | 150 | approx. ±0.109K @ 0°C | approx. ±0.036K @ 0°C | approx. 0.0036 K/K | 1036 | 4470
10 | KTY81/82-110.120.150 | -50 | 150 | approx. ±0.216K @ 0°C | approx. ±0.072K @ 0°C | approx. 0.0072 K/K | 515 | 2211
11 | KTY81-121 | -50 | 150 | approx. ±0.219K @ 0°C | approx. ±0.073K @ 0°C | approx. 0.0073 K/K | 510 | 2189
12 | KTY81-122 | -50 | 150 | approx. ±0.214K @ 0°C | approx. ±0.071K @ 0°C | approx. 0.0071 K/K | 520 | 2233
13 | KTY81-151 | -50 | 150 | approx. ±0.222K @ 0°C | approx. ±0.074K @ 0°C | approx. 0.0074 K/K | 502 | 2156
14 | KTY81-152 | -50 | 150 | approx. ±0.211K @ 0°C | approx. ±0.070K @ 0°C | approx. 0.007 K/K | 528 | 2266
15 | KTY81/82-210.220.250 | -50 | 150 | approx. ±0.108K @ 0°C | approx. ±0.036K @ 0°C | approx. 0.0036 K/K | 1030 | 4280
16 | KTY81-221 | -50 | 150 | approx. ±0.109K @ 0°C |  |  | 1019 | 4237
17 | KTY81-222 | -50 | 150 | approx. ±0.107K @ 0°C | approx. ±0.036K @ 0°C | approx. 0.0036 K/K | 1040 | 4323
18 | KTY81-251 | -50 | 150 | approx. ±0.111K @ 0°C | approx. ±0.037K @ 0°C | approx. 0.0037 K/K | 1004 | 4173
19 | KTY81-252 | -50 | 150 | approx. ±0.105K @ 0°C | approx. ±0.035K @ 0°C | approx. 0.0035 K/K | 1055 | 4387
20 | KTY83-110.120.150 | -50 | 175 | approx. ±0.222K @ 0°C | approx. ±0.074K @ 0°C | approx. 0.0074 K/K | 525 | 2535
21 | KTY83-121 | -50 | 175 | approx. ±0.224K @ 0°C | approx. ±0.075K @ 0°C | approx. 0.0075 K/K | 519 | 2509
22 | KTY83-122 | -50 | 175 | approx. ±0.221K @ 0°C | approx. ±0.074K @ 0°C | approx. 0.0074 K/K | 530 | 2560
23 | KTY83-151 | -50 | 175 | approx. ±0.225K @ 0°C | approx. ±0.075K @ 0°C | approx. 0.0075 K/K | 512 | 2471
24 | KTY83-152 | -50 | 175 | approx. ±0.216K @ 0°C | approx. ±0.072K @ 0°C | approx. 0.0072 K/K | 538 | 2598
25 | KTY84-130.150 | -40 | 300 | approx. ±0.384K @ 0°C | approx. ±0.128K @ 0°C | approx. 0.013 K/K | 359 | 2624
26 | KTY84-151 | -40 | 300 | approx. ±0.396K @ 0°C | approx. ±0.132K @ 0°C | approx. 0.013 K/K | 350 | 2558
27 | KTY21/23-6 | -50 | 150 | approx. ±0.22K @ 0°C | approx. ±0.072K @ 0°C | approx. 0.0072 K/K | 518 | 2235
28 | KTY1x-5 | -50 | 150 | approx. ±0.110K @ 0°C | approx. ±0.037K @ 0°C | approx. 0.0037 K/K | 1020 | 4403
29 | KTY1x-7 | -50 | 150 | approx. ±0.107K @ 0°C | approx. ±0.036K @ 0°C | approx. 0.0036 K/K | 1052 | 4537
30 | KTY21/23-5 | -50 | 150 | approx. ±0.220K @ 0°C | approx. ±0.073K @ 0°C | approx. 0.0073 K/K | 510 | 2202
31 | KTY21/23-7 | -50 | 150 | approx. ±0.214K @ 0°C | approx. ±0.071K @ 0°C | approx. 0.0071 K/K | 526 | 2268
1) Achievable at negligible offset part, e.g. through offset correction (ELM3xxx: zero offset function).
Higher measuring accuracy for individual sensor types whose resistance is in the smaller subrange of 0..5 kΩ.
2) Relative error according to the slope of the respective RTD characteristic diagram at 23°C ambient terminal temperature (not taking into account temperature drift of the sensor).
Note
Extended Range mode not available
The Extended Range mode is not available for RTD measurement.
•
Until FW07: Object 0x8000:2E (Scaler) will be ignored by this setting. The “Legacy Range Mode” applies in the background.
•
Since FW08: Object 0x8000:2E (Scaler) will then be set to the “Legacy Range Mode”. A change is not possible as long RTD measurement range is selected.


Potentiometer measurement

Product overview [image] Technical data [image] Potentiometer measurement
Potentiometer measurement
The potentiometer should be supplied with the integrated power supply unit (max. 5 V, configurable). The slider voltage is then measured relative to the supply voltage and output in %. Technical, the measurement is similar to a strain gauge half bridge.
Potentiometers from 1 kΩ can be used.
Diagnostics
▪
Slider breakage: full-scale deflection or 0 display
▪
Supply interruption: full-scale deflection or 0 display
Measurement mode |  |  | Potentiometer (3/ 5 wire)
Operation mode |  |  | The supply voltage is configurable via CoE, 0.5…5 V
Measuring range, nominal |  |  | -1…1 V/V
Measuring range, end value (full scale value) |  |  | 1 V/V
Measuring range, technically usable |  |  | -1…1 V/V
PDO resolution |  |  | 24 bit (incl. sign)
PDO LSB (Extended Range) |  |  | 0.128 ppm
PDO LSB (Legacy Range) |  |  | 0.119… ppm
Basic accuracy: Measuring error at 23°C, with averaging |  |  | < ±0.05%FSV = ±500 ppmFSV
Temperature coefficient (Terminal) |  | TcTerminal | < 15 ppm/K typ.
Input impedance ±Input 1 (Internal resistance) |  |  | Differential 4.1 MΩ || 11 nF typ.
 |  |  | CommonMode 1 MΩ || 40 nF typ. Methodology: Resistor against -UV, capacitance against SGND
Input impedance ±Input 2 (Internal resistance) |  |  | Differential 5 MΩ || 10 nF typ.
 |  |  | CommonMode 1.25 MΩ || 40 nF typ. Methodology: Resistor against -UV (+2.5V), capacitance against SGND
Offset/Zero Point error (at 23°C) | EOffset |  | < 480 [ppmFSV]
Gain/scale/amplification error (at 23°C) | EGain |  | < 100 [ppm]
Non-linearity over the whole measuring range | ELin |  | < 75 [ppmFSV]
Repeatability | ERep |  | < 50 [ppmFSV]
Noise (peak-to-peak, without filtering) | ENoise, PtP |  | < 150 [ppmFSV] |  | < 1172 [digits]
 | ENoise, RMS |  | < 22 [ppmFSV] |  | < 172 [digits]
 | Max. SNR |  | > 93.2 [dB]
 | Noisedensity @1kHz |  | < 0.31
Noise (peak-to-peak, with 50Hz filtering) | ENoise, PtP |  | < 14 [ppmFSV] |  | < 109 [digits]
 | ENoise, RMS |  | < 2.5 [ppmFSV] |  | < 20 [digits]
 | Max. SNR |  | > 112 [dB]
Common-mode rejection ratio (without filtering)3 |  |  | DC: < 3 [image] typ. | 50 Hz: < 9 [image] typ. |  | 1 kHz: < 140 [image] typ.
Common-mode rejection ratio (with 50Hz filtering)3 |  |  | DC: < 3 [image] typ. | 50 Hz: < 0.2 [image] typ. |  | 1 kHz: < 5 [image] typ.
Largest short-term deviation during a specified electrical interference test |  |  | ±0.2%FSV = ±2000 ppmFSV typ.
Potentiometer measuring range
Chart: potentiometer measuring range


Measurement SG 1/1 bridge (full bridge) 4/6-wire connection

Product overview [image] Technical data [image] Measurement SG 1/1 bridge (full bridge) 4/6-wire connection
Measurement SG 1/1 bridge (full bridge) 4/6-wire connection
To determine the measuring error:
The nominal/technical measuring range is specified in "mV/V"; the maximum permitted supply voltage is 5 V. The maximum nominal measuring range that can be used for the bridge voltage is therefore ±32 mV/V * 5 V = ±160 mV; the internal circuits are configured accordingly.
The internal measurement is ratiometric, i.e. the feed voltage and the bridge voltage are not measured absolutely, but as a ratio.
The integrated supply can be used as power supply. An external supply is permitted, as long as 5 V is not exceeded.
Note: specifications apply for 2.5 V SG excitation.
Measurement mode
SG 1/1 bridge
Measuring range, nominal
-32…+32 mV/V
Measuring range, end value (full scale value)
32 mV/V
Measuring range, technically usable
-34.359…+34.359 mV/V
PDO resolution
24 bit (including sign)
PDO LSB (Extended Range)
4.096 nV/V
PDO LSB (Legacy Range)
3.814.. nV/V
Basic accuracy: Measuring error at 23°C, with averaging (2
4-wire connection: ±0.09%FSV = ±900 ppmFSV typ.
6-wire connection: ±0.05%FSV = ±500 ppmFSV typ.
Integrated power supply
0.5…5 V adjustable, max. supply/excitation 21 mA (internal electronic overload protection) therefore
▪
120R strain gauge: up to 2.5 V
▪
350R strain gauge: up to 5.0 V
Temperature coefficient
TcTerminal
< 20 ppm/K typ.
2) Dominant part of the basic accuracy is its offset specification (see following tables). The process described in the Offset correction section eliminates this proportion and increases the measurement accuracy considerably.
Measurement mode |  | SG 1/1 bridge (4 wire)
Offset/Zero Point error (at 23°C) | EOffset | < 850 [ppmFSV]
Gain/scale/amplification error (at 23°C) | EGain | < 200 [ppm]
Non-linearity over the whole measuring range | ELin | < 120 [ppmFSV]
Repeatability | ERep | < 15 [ppmFSV]
Noise (without filtering) | ENoise, PtP | < 320 [ppmFSV] |  | < 2500 [digits]
 | ENoise, RMS | < 56 [ppmFSV] |  | < 438 [digits]
 | Max. SNR | > 85 [dB]
 | Noisedensity@1kHz | < 25.34
Noise (with 50 Hz FIR filtering) | ENoise, PtP | < 18 [ppmFSV] |  | < 141 [digits]
 | ENoise, RMS | < 3.5 [ppmFSV] |  | < 27 [digits]
 | Max. SNR | > 109.1 [dB]
Common-mode rejection ratio (without filtering)3 |  | DC: < 0.15 [image] typ. | 50 Hz: < 0.5 [image] typ. |  | 1 kHz: < 10 [image] typ.
Common-mode rejection ratio (with 50 Hz FIR filtering)3 |  | DC: < 100 [image] typ. | 50 Hz: < 10 [image] typ. |  | 1 kHz: < 1 [image] typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.1%FSV = ±1000 ppmFSV typ.
Input impedance ±Input 1 (Internal resistance) |  | Differential 4.1 MΩ || 11 nF typ.
 |  | CommonMode 1 MΩ || 40 nF typ. Methodology: Resistor against -UV, capacitance against SGND
Input impedance ±Input 2 |  | No usage of this input in this mode
3) Values related to a common mode interference between SGND and internal ground.
Measurement mode |  | SG 1/1 bridge (6 wire)
Offset/Zero Point error (at 23°C) | EOffset | < 470 [ppmFSV]
Gain/scale/amplification error (at 23°C) | EGain | < 120 [ppm]
Non-linearity over the whole measuring range | ELin | < 120 [ppmFSV]
Repeatability | ERep | < 15 [ppmFSV]
Noise (without filtering)4 | ENoise, PtP | < 230 [ppmFSV] |  | < 1797 [digits]
 | ENoise, RMS | < 38 [ppmFSV] |  | < 297 [digits]
 | Max. SNR | > 88.4 [dB]
 | Noisedensity@1kHz | < 17.2
Noise (with 50 Hz FIR filtering)4 | ENoise, PtP | < 18 [ppmFSV] |  | < 141 [digits]
 | ENoise, RMS | < 3.5 [ppmFSV] |  | < 27 [digits]
 | Max. SNR | > 109.1 [dB]
Common-mode rejection ratio (without filtering)3 |  | DC: < 0.15 [image] typ. | 50 Hz: < 0.5 [image] typ. |  | 1 kHz: < 10 [image] typ.
Common-mode rejection ratio (with 50 Hz FIR filtering)3 |  | DC: < 100 [image] typ. | 50 Hz: < 10 [image] typ. |  | 1 kHz: < 1 [image] typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.1%FSV = ±1000 ppmFSV typ.
Input impedance ±Input 1 (Internal resistance) |  | Differential 4.1 MΩ || 11 nF typ.
 |  | CommonMode 1 MΩ || 40 nF typ. Methodology: Resistor against -UV, capacitance against SGND
Input impedance ±Input 2 (Internal resistance) |  | Differential 5 MΩ || 10 nF typ.
 |  | CommonMode 1.25 MΩ || 40 nF typ. Methodology: Resistor against -UV (+2.5V), capacitance against SGND
3) Values related to a common mode interference between SGND and internal ground.
4) Specifications valid for HW Version ≥ 10, only! Valid specifications until HW Version 10 are as follows:
Measurement mode |  | SG 1/1 bridge (6 wire), < HW10
Noise (without filtering) | ENoise, PtP | < 960 [ppmFSV] | < 7500 [digits]
 | ENoise, RMS | < 170 [ppmFSV] | < 1328 [digits]
 | Max. SNR | > 75.4 [dB]
 | Noisedensity@1kHz | < 76.93
Noise (with 50 Hz FIR filtering) | ENoise, PtP | < 77 [ppmFSV] | < 602 [digits]
 | ENoise, RMS | < 15 [ppmFSV] | < 117 [digits]
 | Max. SNR | > 96.5 [dB]
The transition resistance values of the terminal contacts affect the measurement. The measuring error can be reduced further through compensation by the user, with active signal connection.
Full bridge calculation:
The strain relationship (µStrain, µε) is as follows:
The channel value (PDO) is interpreted directly [mV/V]:
Display measuring range SG 1/1 bridge


Measurement SG 1/2 bridge (half bridge) 3/5-wire connection

Product overview [image] Technical data [image] Measurement SG 1/2 bridge (half bridge) 3/5-wire connection
Measurement SG 1/2 bridge (half bridge) 3/5-wire connection
To determine the measuring error:
The nominal/technical measuring range is specified in "mV/V"; the maximum permitted supply voltage is 5 V. The maximum nominal measuring range that can be used for the bridge voltage is therefore ±16 mV/V * 5V = ±80 mV; the internal circuits are designed for the 160 mV of the full bridge measurement.
The internal measurement is ratiometric, i.e. the feed voltage and the bridge voltage are not measured absolutely, but as a ratio.
The integrated supply can be used as power supply. An external supply is permitted, as long as 5 V is not exceeded.
Note: specifications apply for 2.5 V SG excitation.
Measurement mode
SG 1/2 bridge
Measuring range, nominal
-16…+16 mV/V
[corresponds to ±16000 µε at K=2, N=2]
Measuring range, end value (full scale value)
16 mV/V
Measuring range, technically usable
-17.179…+17.179 mV/V
PDO resolution
24 bit (including sign)
PDO LSB (Extended Range)
2.048 nV/V
PDO LSB (Legacy Range)
1.907.. nV/V
Basic accuracy: Measuring error at 23°C, with averaging (2
3-wire connection: ±0.27% typ. (relative to full scale value, q.v. note)
5-wire connection: ±0.09% typ. (relative to full scale value, q.v. note)
Integrated power supply
0.5…5 V adjustable, max. supply/excitation 21 mA (internal electronic overload protection) therefore
▪
120R strain gauge: up to 2.5V
▪
350R strain gauge: up to 5.0V
Temperature coefficient
TcTerminal
<75 ppm/K typ.
(rel. to full scale value, since production 2016 week 10; refer to serial number)
<250 ppm/K typ.
(rel. to full scale value, production until 2016 week 09; refer to serial number)
Input impedance ±Input 1
(Internal resistance)
Differential 4.1 MΩ || 11 nF typ.
CommonMode 1 MΩ || 40 nF typ.
Methodology: Resistor against -UV, capacitance against SGND
Input impedance ±Input 2
(Internal resistance)
Differential 5 MΩ || 10 nF typ.
CommonMode 1.25 MΩ || 40 nF typ.
Methodology: Resistor against -UV (+2.5V), capacitance against SGND
2) Dominant part of the basic accuracy is its offset specification (see following tables). The process described in the Offset correction section eliminates this proportion and increases the measurement accuracy considerably.
Measurement mode |  | SG 1/2 bridge (3 wire)
Offset/Zero Point error (at 23°C) | EOffset | < 2650 ppmFSV (valid since 2018 week 01; value before 2018 week 01: < 3600 ppmFSV)
Gain/scale/amplification error (at 23°C) | EGain | < 290 ppm
Non-linearity over the whole measuring range | ELin | < 390 ppmFSV
Repeatability | ERep | < 50 ppmFSV
Noise (without filtering)4 | ENoise. PtP | < 950 ppmFSV |  | < 7422 [digits]
 | ENoise. RMS | < 145 ppmFSV |  | < 1133 [digits]
 | Max. SNR | > 76.8 dB
 | Noisedensity @1kHz | < 32.81
Noise (with 50 Hz FIR filtering)4 | ENoise. PtP | < 70 ppmFSV |  | < 547 [digits]
 | ENoise. RMS | < 15 ppmFSV |  | < 117 [digits]
 | Max. SNR | > 96.5 dB
Common-mode rejection ratio (without filtering)3 |  | DC: < 150 [image] typ. | 50 Hz: < 600 [image] typ. |  | 1 kHz: < 10 [image] typ.
Common-mode rejection ratio (with 50 Hz FIR filtering)3 |  | DC: < 100 [image] typ. | 50 Hz: < 20 [image] typ. |  | 1 kHz: < 0.1 [image] typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.2%FSV = ±2000 ppmFSV typ.
3) Values related to a common mode interference between SGND and internal ground.
4) Specifications valid for HW Version ≥ 10, only! Valid specifications until HW Version 10 are as follows:
Measurement mode |  | SG 1/2 bridge (3 wire), < HW10
Noise (without filtering) | ENoise. PtP | < 1100 ppmFSV | < 8594 [digits]
 | ENoise. RMS | < 160 ppmFSV | < 1250 [digits]
 | Max. SNR | > 75.9 dB
 | Noisedensity @1kHz | < 36.2
Noise (with 50 Hz FIR filtering) | ENoise. PtP | < 120 ppmFSV | < 938 [digits]
 | ENoise. RMS | < 19 ppmFSV | < 148 [digits]
 | Max. SNR | > 94.4 dB
Measurement mode |  | SG 1/2 bridge (5 wire)
Offset/Zero Point error (at 23°C) | EOffset | < 750 ppmFSV (valid since 2018 week 01; value before 2018 week 01: < 1100 ppmFSV)
Gain/scale/amplification error (at 23°C) | EGain | < 290 ppm
Non-linearity over the whole measuring range | ELin | < 390 ppmFSV
Repeatability | ERep | < 50 ppmFSV
Noise (without filtering)4 | ENoise. PtP | < 1200 ppmFSV |  | < 9375 [digits]
 | ENoise. RMS | < 175 ppmFSV |  | < 1367 [digits]
 | Max. SNR | > 75.1 dB
 | Noisedensity @1kHz | < 39.6
Noise (with 50 Hz FIR filtering)4 | ENoise. PtP | < 70 ppmFSV |  | < 547 [digits]
 | ENoise. RMS | < 14 ppmFSV |  | < 109 [digits]
 | Max. SNR | > 97.1 dB
Common-mode rejection ratio (without filtering)3 |  | DC: < 150 [image] typ. | 50 Hz: < 600 [image] typ. |  | 1 kHz: < 10 [image] typ.
Common-mode rejection ratio (with 50 Hz FIR filtering)3 |  | DC: < 100 [image] typ. | 50 Hz: < 20 [image] typ. |  | 1 kHz: < 0.1 [image] typ.
Largest short-term deviation during a specified electrical interference test |  | ±0.2%FSV = ±2000 ppmFSV typ.
3) Values related to a common mode interference between SGND and internal ground.
4) Specifications valid for HW Version ≥ 10, only! Valid specifications until HW Version 10 are as follows:
Measurement mode |  | SG 1/2 bridge (5 wire), < HW10
Noise (without filtering) | ENoise. PtP | < 1600 ppmFSV | < 12500 [digits]
 | ENoise. RMS | < 240 ppmFSV | < 1875 [digits]
 | Max. SNR | > 72.4 dB
 | Noisedensity @1kHz | < 54.31
Noise (with 50 Hz FIR filtering) | ENoise. PtP | < 96 ppmFSV | < 750 [digits]
 | ENoise. RMS | < 16 ppmFSV | < 125 [digits]
 | Max. SNR | > 95.9 dB
The transition resistance values of the terminal contacts affect the measurement. The measuring error can be reduced further through compensation by the user, with active signal connection.
Validity of property values
The resistor of the bridge is positioned parallel to the internal resistor of the terminal and leads to an offset shifting respectively. The Beckhoff factory calibration will be carried out with the half bridge 350 Ω, thus the values specified above are directly valid for the 350 Ω half bridge. By connection of another dimensioned half-bridge is to:
•
perform a balancing (offset correction) by the terminal itself or the control/PLC on application side
•
or the abstract offset error have to be entered into the balancing parameter S0 of the terminal. Example: a 350 Ω half bridge correlates by the compensated effect of the input resistor (2 MΩ) during factory calibration 0.26545 %FSV (16 mV/V), that corresponds to 20738 digits.
Half bridge calculation:
R3/4 are the internal switchable input resistors of the terminal. Other configurations (e.g. R1/4 or R1/3 variable) of half bridges are not supported.
The strain relationship (µStrain, µε) is as follows:
N should be chosen based on the mechanical configuration of the variable resistors (Poisson, 2 active uniaxial, …). The channel value (PDO) is interpreted directly [mV/V]:
Display measuring range SG 1/2 bridge


Measurement SG 1/4 bridge (quarter bridge) 120 Ω 2/3-wire connection

Product overview [image] Technical data [image] Measurement SG 1/4 bridge (quarter bridge) 120 Ω 2/3-wire connection
Measurement SG 1/4 bridge (quarter bridge) 120 Ω 2/3-wire connection
¹) Please see the remarks to 2/3/4 wire measurement within section for resistance measurement of section “technical data”.
Note: specifications apply for 2.5 V SG excitation.
Measurement mode |  | SG 1/4 bridge 120 Ω
Measuring range, nominal |  | 120 ± 12 Ω or ±25 mV/V [corresponds to 108 Ω…132 Ω] [corresponds to ±50000 µε at K=2]
Measuring range, end value (full scale value) |  | 132 Ω
Measuring range, technically usable |  | 120 ± 12.88.. Ω
PDO resolution |  | 24 bit (including sign)
PDO LSB (Extended Range) |  | 1.536 µΩ/Step
PDO LSB (Legacy Range) |  | 1.430.. µΩ/Step
Basic accuracy: Measuring error at 23°C, with averaging (2 |  | 2-wire connection: 0.05% typ. (relative to full scale value) 3-wire connection: 0.04% typ. (relative to full scale value) 4-wire connection: not possible
Integrated power supply |  | 0.5…2.5 V adjustable, max. supply/excitation 21 mA (internal electronic overload protection)
Temperature coefficient (¹ | TcTerminal | <8 ppm/K typ. (rel. to full scale value, since HW Version 06; refer to serial number) <12 ppm/K typ. (rel. to full scale value, HW Version 04, since production 2016 week 10; refer to serial number) <60 ppm/K typ. (rel. to full scale value, HW Version 01-04, production until 2016 week 09; refer to serial number)
2) Dominant part of the basic accuracy is its offset specification (see following tables). The process described in the Offset correction section eliminates this proportion and increases the measurement accuracy considerably.
Measurement mode |  | SG 1/4 bridge 120 Ω (2 wire)
Offset/Zero Point error (at 23°C) | EOffset | < 420 [ppmFSV]
Gain/scale/amplification error (at 23°C) | EGain | < 250 [ppm]
Non-linearity over the whole measuring range | ELin | < 50 [ppmFSV]
Repeatability (at 23°C) | ERep | < 15 [ppmFSV]
Noise (without filtering, at 23°C) | ENoise, PtP | < 160 [ppmFSV] |  | < 13750 [digits]
 | ENoise, RMS | < 20 [ppmFSV] |  | < 1720 [digits]
 | Max. SNR | > 73.1 [dB]
 | Noisedensity @1kHz | < 37.36
Noise (with 50 Hz FIR filtering, at 23°C) | ENoise, PtP | < 6 [ppmFSV] |  | < 520 [digits]
 | ENoise, RMS | < 1 [ppmFSV] |  | < 86 [digits]
 | Max. SNR | > 99.2 [dB]
Common-mode rejection ratio (without filtering)3 |  | DC: < 0.3 Ω/V typ. | 50 Hz: < 1 Ω/V typ. |  | 1 kHz: < 20 Ω/V typ.
Common-mode rejection ratio (with 50 Hz FIR filtering)3 |  | DC: < 300 mΩ/V typ. | 50 Hz: < 40 mΩ/V typ. |  | 1 kHz: < 0.5 mΩ/V typ.
Largest short-term deviation during a specified electrical interference test |  | ±1%FSV typ.
3) Values related to a common mode interference between SGND and internal ground.
Measurement mode |  | SG 1/4 bridge 120 Ω (3 wire)
Offset/Zero Point error (at 23°C) | EOffset | < 360 [ppmFSV]
Gain/scale/amplification error (at 23°C) | EGain | < 150 [ppm]
Non-linearity over the whole measuring range | ELin | < 50 [ppmFSV]
Repeatability (at 23°C) | ERep | < 15 [ppmFSV]
Noise (without filtering, at 23°C) | ENoise, PtP | < 160 [ppmFSV] |  | < 13750 [digits]
 | ENoise, RMS | < 20 [ppmFSV] |  | < 1720 [digits]
 | Max. SNR | > 73.1 [dB]
 | Noisedensity @1kHz | < 37.36
Noise (with 50 Hz FIR filtering, at 23°C) | ENoise, PtP | < 6 [ppmFSV] |  | < 520 [digits]
 | ENoise, RMS | < 1 [ppmFSV] |  | < 86 [digits]
 | Max. SNR | > 99.2 [dB]
Common-mode rejection ratio (without filtering)3 |  | DC: < 0.3 Ω/V typ. | 50 Hz: < 1 Ω/V typ. |  | 1 kHz: < 20 Ω/V typ.
Common-mode rejection ratio (with 50 Hz FIR filtering)3 |  | DC: < 300 mΩ/V typ. | 50 Hz: < 40 mΩ/V typ. |  | 1 kHz: < 0.5 mΩ/V typ.
Largest short-term deviation during a specified electrical interference test |  | ±1%FSV typ.
3) Values related to a common mode interference between SGND and internal ground.
The transition resistance values of the terminal contacts affect the measurement. The measuring error can be reduced further through compensation by the user, with active signal connection.
The temperature coefficient (Terminal) can be significantly improved through an external, more temperature-stable auxiliary resistor.
Quarter bridge calculation:
The strain relationship (µStrain, µε) is as follows:
For the quarter bridge, N=1 always applies.
The channel value (PDO) can be interpolated in ± 12 Ω or ±25 mV/V:
Display measuring range SG 1/4 bridge 120 Ω


Measurement SG 1/4 bridge (quarter bridge) 350 Ω 2/3-wire connection

Product overview [image] Technical data [image] Measurement SG 1/4 bridge (quarter bridge) 350 Ω 2/3-wire connection
Measurement SG 1/4 bridge (quarter bridge) 350 Ω 2/3-wire connection
¹) Please see the remarks to 2/3/4 wire measurement within section for resistance measurement of section “technical data”.
Note: specifications apply for 2.5 V SG excitation.
Measurement mode |  | SG 1/4 bridge 350 Ω
Measuring range, nominal |  | 350 ± 12 Ω or ±8.571 mV/V [corresponds to 338 Ω…362 Ω] [corresponds to ±17142 µε at K=2]
Measuring range, end value (full scale value) |  | 362 Ω
Measuring range, technically usable |  | 350 ± 12.88.. Ω
PDO resolution |  | 24 bit (including sign)
PDO LSB (Extended Range) |  | 1.536 µΩ/Step
PDO LSB (Legacy Range) |  | 1.430.. µΩ/Step
Basic accuracy: Measuring error at 23°C, with averaging (2 |  | 2-wire connection: 0.03% typ. (relative to full scale value) 3-wire connection: 0.02% typ. (relative to full scale value) 4-wire connection: not possible
Integrated power supply |  | 0.5…5V adjustable, max. supply/excitation 21 mA (internal electronic overload protection)
Temperature coefficient (¹ | TcTerminal | <8 ppm/K typ. (rel. to full scale value, since production 2016 week 10; refer to serial number) <40 ppm/K typ. (rel. to full scale value, production until 2016 week 09; refer to serial number)
2) Dominant part of the basic accuracy is its offset specification (see following tables). The process described in the Offset correction section eliminates this proportion and increases the measurement accuracy considerably.
Measurement mode |  | SG 1/4 bridge 350 Ω (2 wire)
Offset/Zero Point error (at 23°C) | EOffset | < 250 [ppmFSV]
Gain/scale/amplification error (at 23°C) | EGain | < 150 [ppm]
Non-linearity over the whole measuring range | ELin | < 40 [ppmFSV]
Repeatability (at 23°C) | ERep | < 10 [ppmFSV]
Noise (without filtering, at 23°C) | ENoise, PtP | < 105 [ppmFSV] |  | < 24750 [digits]
 | ENoise, RMS | < 18 [ppmFSV] |  | < 4240 [digits]
 | Max. SNR | > 65.3 [dB]
 | Noisedensity @1kHz | < 92.1
Noise (with 50 Hz FIR filtering, at 23°C) | ENoise, PtP | < 6 [ppmFSV] |  | < 1400 [digits]
 | ENoise, RMS | < 1 [ppmFSV] |  | < 236 [digits]
 | Max. SNR | > 90.4 [dB]
Common-mode rejection ratio (without filtering)3 |  | DC: < 2 Ω/V typ. | 50 Hz: < 8 Ω/V typ. |  | 1 kHz: < 150 Ω/V typ.
Common-mode rejection ratio (with 50 Hz FIR filtering)3 |  | DC: < 700 mΩ/V typ. | 50 Hz: < 90 mΩ/V typ. |  | 1 kHz: < 0.5 mΩ/V typ.
Largest short-term deviation during a specified electrical interference test |  | ±1%FSV typ.
3) Values related to a common mode interference between SGND and internal ground.
Measurement mode |  | SG 1/4 bridge 350 Ω (3 wire)
Offset/Zero Point error (at 23°C) | EOffset | < 140 [ppmFSV]
Gain/scale/amplification error (at 23°C) | EGain | < 130 [ppm]
Non-linearity over the whole measuring range | ELin | < 40 [ppmFSV]
Repeatability (at 23°C) | ERep | < 10 [ppmFSV]
Noise (without filtering, at 23°C) | ENoise, PtP | < 105 [ppmFSV] |  | < 24750 [digits]
 | ENoise, RMS | < 18 [ppmFSV] |  | < 4240 [digits]
 | Max. SNR | > 65.3 [dB]
 | Noisedensity @1kHz | < 92.1
Noise (with 50 Hz FIR filtering, at 23°C) | ENoise, PtP | < 6 [ppmFSV] |  | < 1400 [digits]
 | ENoise, RMS | < 1 [ppmFSV] |  | < 236 [digits]
 | Max. SNR | > 90.4 [dB]
Common-mode rejection ratio (without filtering)3 |  | DC: < 2 Ω/V typ. | 50 Hz: < 8 Ω/V typ. |  | 1 kHz: < 150 Ω/V typ.
Common-mode rejection ratio (with 50 Hz FIR filtering)3 |  | DC: < 700 mΩ/V typ. | 50 Hz: < 90 mΩ/V typ. |  | 1 kHz: < 0.5 mΩ/V typ.
Largest short-term deviation during a specified electrical interference test |  | ±1%FSV typ.
3) Values related to a common mode interference between SGND and internal ground.
The transition resistance values of the terminal contacts affect the measurement. The measuring error can be reduced further through compensation by the user, with active signal connection.
The temperature coefficient (Terminal) can be significantly improved through an external, more temperature-stable auxiliary resistor. In addition, a more temperature-stable version is available on request.
Quarter bridge calculation:
The strain relationship (µStrain, µε) is as follows:
For the quarter bridge, N=1 always applies.
The channel value (PDO) can be interpolated in ± 12 Ω or ±8,571 mV/V:
Display measuring range SG 1/4 bridge 350 Ω


Commissioning

Commissioning
Commissioning
Note
This short documentation does not contain any information. For the complete documentation please contact the Beckhoff sales department responsible for you.


EL3751 Features

EL3751 Features
EL3751 Features
Note
This short documentation does not contain any information. For the complete documentation please contact the Beckhoff sales department responsible for you.


Commissioning on EtherCAT Master

Commissioning on EtherCAT Master
Commissioning on EtherCAT Master
Additional information
•
General Notes - EtherCAT Slave Application
•
TwinCAT Quick Start
•
EtherCAT basics
•
EtherCAT cabling – wire-bound
•
General notes for setting the watchdog
•
EtherCAT State Machine
•
CoE Interface
•
Distributed Clock


General Notes - EtherCAT Slave Application

Commissioning on EtherCAT Master [image] General Notes - EtherCAT Slave Application
General Notes - EtherCAT Slave Application
This summary briefly deals with a number of aspects of EtherCAT Slave operation under TwinCAT. More detailed information on this may be found in the corresponding sections of, for instance, the EtherCAT System Documentation.
Diagnosis in real time: WorkingCounter, EtherCAT State and Status
Generally speaking an EtherCAT Slave provides a variety of diagnostic information that can be used by the controlling task.
This diagnostic information relates to differing levels of communication. It therefore has a variety of sources, and is also updated at various times.
Any application that relies on I/O data from a fieldbus being correct and up to date must make diagnostic access to the corresponding underlying layers. EtherCAT and the TwinCAT System Manager offer comprehensive diagnostic elements of this kind. Those diagnostic elements that are helpful to the controlling task for diagnosis that is accurate for the current cycle when in operation (not during commissioning) are discussed below.
Selection of the diagnostic information of an EtherCAT Slave
In general, an EtherCAT Slave offers
▪
communication diagnosis typical for a slave (diagnosis of successful participation in the exchange of process data, and correct operating mode)
This diagnosis is the same for all slaves.

as well as
▪
function diagnosis typical for a channel (device-dependent)
See the corresponding device documentation
The colors in Fig. “Selection of the diagnostic information of an EtherCAT Slave” also correspond to the variable colors in the System Manager, see Fig. “Basic EtherCAT Slave Diagnosis in the PLC”.
Colour | Meaning
yellow | Input variables from the Slave to the EtherCAT Master, updated in every cycle
red | Output variables from the Slave to the EtherCAT Master, updated in every cycle
green | Information variables for the EtherCAT Master that are updated acyclically. This means that it is possible that in any particular cycle they do not represent the latest possible status. It is therefore useful to read such variables through ADS.
Fig. “Basic EtherCAT Slave Diagnosis in the PLC” shows an example of an implementation of basic EtherCAT Slave Diagnosis. A Beckhoff EL3102 (2-channel analogue input terminal) is used here, as it offers both the communication diagnosis typical of a slave and the functional diagnosis that is specific to a channel. Structures are created as input variables in the PLC, each corresponding to the process image.
Basic EtherCAT Slave Diagnosis in the PLC
The following aspects are covered here:
Code
Function
Implementation
Application/evaluation
A
The EtherCAT Master's diagnostic information
updated acyclically (yellow) or provided acyclically (green).
At least the DevState is to be evaluated for the most recent cycle in the PLC.
The EtherCAT Master's diagnostic information offers many more possibilities than are treated in the EtherCAT System Documentation. A few keywords:
▪
CoE in the Master for communication with/through the Slaves
▪
Functions from TcEtherCAT.lib
▪
Perform an OnlineScan
B
In the example chosen (EL3102) the EL3102 comprises two analogue input channels that transmit a single function status for the most recent cycle.
Status
▪
the bit significations may be found in the device documentation
▪
other devices may supply more information, or none that is typical of a slave
In order for the higher-level PLC task (or corresponding control applications) to be able to rely on correct data, the function status must be evaluated there. Such information is therefore provided with the process data for the most recent cycle.
C
For every EtherCAT Slave that has cyclic process data, the Master displays, using what is known as a WorkingCounter, whether the slave is participating successfully and without error in the cyclic exchange of process data. This important, elementary information is therefore provided for the most recent cycle in the System Manager
1.
at the EtherCAT Slave, and, with identical contents
2.
as a collective variable at the EtherCAT Master (see Point A)
for linking.
WcState (Working Counter)
0: valid real-time communication in the last cycle
1: invalid real-time communication
This may possibly have effects on the process data of other Slaves that are located in the same SyncUnit
In order for the higher-level PLC task (or corresponding control applications) to be able to rely on correct data, the communication status of the EtherCAT Slave must be evaluated there. Such information is therefore provided with the process data for the most recent cycle.
D
Diagnostic information of the EtherCAT Master which, while it is represented at the slave for linking, is actually determined by the Master for the Slave concerned and represented there. This information cannot be characterized as real-time, because it
▪
is only rarely/never changed, except when the system starts up
▪
is itself determined acyclically (e.g. EtherCAT Status)
State
current Status (INIT..OP) of the Slave. The Slave must be in OP (=8) when operating normally.
AdsAddr
The ADS address is useful for communicating from the PLC/task via ADS with the EtherCAT Slave, e.g. for reading/writing to the CoE. The AMS-NetID of a slave corresponds to the AMS-NetID of the EtherCAT Master; communication with the individual Slave is possible via the port (= EtherCAT address).
Information variables for the EtherCAT Master that are updated acyclically. This means that it is possible that in any particular cycle they do not represent the latest possible status. It is therefore possible to read such variables through ADS.
Note
Diagnostic information
It is strongly recommended that the diagnostic information made available is evaluated so that the application can react accordingly.
CoE Parameter Directory
The CoE parameter directory (CanOpen-over-EtherCAT) is used to manage the set values for the slave concerned. Changes may, in some circumstances, have to be made here when commissioning a relatively complex EtherCAT Slave. It can be accessed through the TwinCAT System Manager, see Fig. “EL3102, CoE directory”:
EL3102, CoE directory
EtherCAT System Documentation
The comprehensive description in the EtherCAT System Documentation (EtherCAT Basics --> CoE Interface) must be observed!
A few brief extracts:
▪
Whether changes in the online directory are saved locally in the slave depends on the device. EL terminals (except the EL66xx) are able to save in this way.
▪
The user must manage the changes to the StartUp list.
Commissioning aid in the TwinCAT System Manager
Commissioning interfaces are being introduced as part of an ongoing process for EL/EP EtherCAT devices. These are available in TwinCAT System Managers from TwinCAT 2.11R2 and above. They are integrated into the System Manager through appropriately extended ESI configuration files.
Example of commissioning aid for a EL3204
This commissioning process simultaneously manages
▪
CoE Parameter Directory
▪
DC/FreeRun mode
▪
the available process data records (PDO)
Although the "Process Data", "DC", "Startup" and "CoE-Online" that used to be necessary for this are still displayed, it is recommended that, if the commissioning aid is used, the automatically generated settings are not changed by it.
The commissioning tool does not cover every possible application of an EL/EP device. If the available setting options are not adequate, the user can make the DC, PDO and CoE settings manually, as in the past.
EtherCAT State: automatic default behaviour of the TwinCAT System Manager and manual operation
After the operating power is switched on, an EtherCAT Slave must go through the following statuses
▪
INIT
▪
PREOP
▪
SAFEOP
▪
OP
to ensure sound operation. The EtherCAT Master directs these statuses in accordance with the initialization routines that are defined for commissioning the device by the ES/XML and user settings (Distributed Clocks (DC), PDO, CoE). See also the section on "Principles of Communication, EtherCAT State Machine" in this connection. Depending how much configuration has to be done, and on the overall communication, booting can take up to a few seconds.
The EtherCAT Master itself must go through these routines when starting, until it has reached at least the OP target state.
The target state wanted by the user, and which is brought about automatically at start-up by TwinCAT, can be set in the System Manager. As soon as TwinCAT reaches the status RUN, the TwinCAT EtherCAT Master will approach the target states.
Standard setting
The advanced settings of the EtherCAT Master are set as standard:
▪
EtherCAT Master: OP
▪
Slaves: OP
This setting applies equally to all Slaves.
Default behaviour of the System Manager
In addition, the target state of any particular Slave can be set in the "Advanced Settings" dialogue; the standard setting is again OP.
Default target state in the Slave
Manual Control
There are particular reasons why it may be appropriate to control the states from the application/task/PLC. For instance:
▪
for diagnostic reasons
▪
to induce a controlled restart of axes
▪
because a change in the times involved in starting is desirable
In that case it is appropriate in the PLC application to use the PLC function blocks from the TcEtherCAT.lib, which is available as standard, and to work through the states in a controlled manner using, for instance, FB_EcSetMasterState.
It is then useful to put the settings in the EtherCAT Master to INIT for master and slave.
PLC function blocks
Note regarding E-Bus current
EL/ES terminals are placed on the DIN rail at a coupler on the terminal strand. A Bus Coupler can supply the EL terminals added to it with the E-bus system voltage of 5 V; a coupler is thereby loadable up to 2 A as a rule. Information on how much current each EL terminal requires from the E-bus supply is available online and in the catalogue. If the added terminals require more current than the coupler can supply, then power feed terminals (e.g. EL9410) must be inserted at appropriate places in the terminal strand.
The pre-calculated theoretical maximum E-Bus current is displayed in the TwinCAT System Manager as a column value. A shortfall is marked by a negative total amount and an exclamation mark; a power feed terminal is to be placed before such a position.
Illegally exceeding the E-Bus current
From TwinCAT 2.11 and above, a warning message "E-Bus Power of Terminal..." is output in the logger window when such a configuration is activated:
Warning message for exceeding E-Bus current
Note
Caution! Malfunction possible!
The same ground potential must be used for the E-Bus supply of all EtherCAT terminals in a terminal block!


TwinCAT Quick Start

Commissioning on EtherCAT Master [image] TwinCAT Quick Start
TwinCAT Quick Start
TwinCAT is a development environment for real-time control including multi-PLC system, NC axis control, programming and operation. The whole system is mapped through this environment and enables access to a programming environment (including compilation) for the controller. Individual digital or analog inputs or outputs can also be read or written directly, in order to verify their functionality, for example.
For further information please refer to http://infosys.beckhoff.com:
▪
EtherCAT Systemmanual:
Fieldbus Components → EtherCAT Terminals → EtherCAT System Documentation → Setup in the TwinCAT System Manager
▪
TwinCAT 2 → TwinCAT System Manager → I/O - Configuration
▪
In particular, TwinCAT driver installation:
Fieldbus components → Fieldbus Cards and Switches → FC900x – PCI Cards for Ethernet → Installation
Devices contain the terminals for the actual configuration. All configuration data can be entered directly via editor functions (offline) or via the "Scan" function (online):
▪
"offline": The configuration can be customized by adding and positioning individual components. These can be selected from a directory and configured.
–
The procedure for offline mode can be found under http://infosys.beckhoff.com:
TwinCAT 2 → TwinCAT System Manager → IO - Configuration → Adding an I/O Device
▪
"online": The existing hardware configuration is read
–
See also http://infosys.beckhoff.com:
Fieldbus components → Fieldbus cards and switches → FC900x – PCI Cards for Ethernet → Installation → Searching for devices
The following relationship is envisaged from user PC to the individual control elements:
Relationship between user side (commissioning) and installation
The user inserting of certain components (I/O device, terminal, box...) is the same in TwinCAT 2 and TwinCAT 3. The descriptions below relate to the online procedure.
Sample configuration (actual configuration)
Based on the following sample configuration, the subsequent subsections describe the procedure for TwinCAT 2 and TwinCAT 3:
▪
Control system (PLC) CX2040 including CX2100-0004 power supply unit
▪
Connected to the CX2040 on the right (E-bus):
EL1004 (4-channel digital input terminal 24 V DC)
▪
Linked via the X001 port (RJ-45): EK1100 EtherCAT Coupler
▪
Connected to the EK1100 EtherCAT coupler on the right (E-bus):
EL2008 (8-channel digital output terminal 24 V DC; 0.5 A)
▪
(Optional via X000: a link to an external PC for the user interface)
Control configuration with Embedded PC, input (EL1004) and output (EL2008)
Note that all combinations of a configuration are possible; for example, the EL1004 terminal could also be connected after the coupler, or the EL2008 terminal could additionally be connected to the CX2040 on the right, in which case the EK1100 coupler wouldn’t be necessary.
Additional information
•
TwinCAT 2
•
TwinCAT 3


TwinCAT 2

Commissioning on EtherCAT Master [image] TwinCAT Quick Start [image] TwinCAT 2
TwinCAT 2
Startup
TwinCAT basically uses two user interfaces: the TwinCAT System Manager for communication with the electromechanical components and TwinCAT PLC Control for the development and compilation of a controller. The starting point is the TwinCAT System Manager.
After successful installation of the TwinCAT system on the PC to be used for development, the TwinCAT 2 System Manager displays the following user interface after startup:
Initial TwinCAT 2 user interface
Generally, TwinCAT can be used in local or remote mode. Once the TwinCAT system including the user interface (standard) is installed on the respective PLC, TwinCAT can be used in local mode and thereby the next step is "Insert Device".
If the intention is to address the TwinCAT runtime environment installed on a PLC as development environment remotely from another system, the target system must be made known first. In the menu under "Actions" → "Choose Target System...", via the symbol " [image] " or the "F8" key, open the following window:
Selection of the target system
Use "Search (Ethernet)..." to enter the target system. Thus a next dialog opens to either:
▪
enter the known computer name after "Enter Host Name / IP:" (as shown in red)
▪
perform a "Broadcast Search" (if the exact computer name is not known)
▪
enter the known computer IP or AmsNetID.
Specify the PLC for access by the TwinCAT System Manager: selection of the target system
Once the target system has been entered, it is available for selection as follows (a password may have to be entered):
After confirmation with "OK" the target system can be accessed via the System Manager.
Adding devices
In the configuration tree of the TwinCAT 2 System Manager user interface on the left, select "I/O Devices” and then right-click to open a context menu and select "Scan Devices…", or start the action in the menu bar via [image]. The TwinCAT System Manager may first have to be set to "Config mode" via [image] or via menu
“Actions" → "Set/Reset TwinCAT to Config Mode…" (Shift + F4).
Select "Scan Devices..."
Confirm the warning message, which follows, and select "EtherCAT" in the dialog:
Automatic detection of I/O devices: selection the devices to be integrated
Confirm the message "Find new boxes", in order to determine the terminals connected to the devices. "Free Run" enables manipulation of input and output values in "Config mode" and should also be acknowledged.
Based on the sample configuration described at the beginning of this section, the result is as follows:
Mapping of the configuration in the TwinCAT 2 System Manager
The whole process consists of two stages, which may be performed separately (first determine the devices, then determine the connected elements such as boxes, terminals, etc.). A scan can also be initiated by selecting "Device ..." from the context menu, which then reads the elements present in the configuration below:
Reading of individual terminals connected to a device
This functionality is useful if the actual configuration is modified at short notice.
Programming and integrating the PLC
TwinCAT PLC Control is the development environment for the creation of the controller in different program environments: TwinCAT PLC Control supports all languages described in IEC 61131-3. There are two text-based languages and three graphical languages.
▪
Text-based languages
–
Instruction List (IL)
–
Structured Text (ST)
▪
Graphical languages
–
Function Block Diagram (FBD)
–
Ladder Diagram (LD)
–
The Continuous Function Chart Editor (CFC)
–
Sequential Function Chart (SFC)
The following section refers to Structured Text (ST).
After starting TwinCAT PLC Control, the following user interface is shown for an initial project:
TwinCAT PLC Control after startup
Sample variables and a sample program have been created and stored under the name "PLC_example.pro":
Sample program with variables after a compile process (without variable integration)
Warning 1990 (missing "VAR_CONFIG") after a compile process indicates that the variables defined as external (with the ID "AT%I*" or "AT%Q*") have not been assigned. After successful compilation, TwinCAT PLC Control creates a "*.tpy" file in the directory in which the project was stored. This file (*.tpy) contains variable assignments and is not known to the System Manager, hence the warning. Once the System Manager has been notified, the warning no longer appears.
First, integrate the TwinCAT PLC Control project in the System Manager via the context menu of the PLC configuration; right-click and select "Append PLC Project…":
Appending the TwinCAT PLC Control project
Select the PLC configuration "PLC_example.tpy" in the browser window that opens. The project including the two variables identified with "AT" are then integrated in the configuration tree of the System Manager:
PLC project integrated in the PLC configuration of the System Manager
The two variables "bEL1004_Ch4" and "nEL2008_value" can now be assigned to certain process objects of the I/O configuration.
Assigning variables
Open a window for selecting a suitable process object (PDO) via the context menu of a variable of the integrated project "PLC_example" and via "Modify Link..." "Standard":
Creating the links between PLC variables and process objects
In the window that opens, the process object for the variable “bEL1004_Ch4” of type BOOL can be selected from the PLC configuration tree:
Selecting PDO of type BOOL
According to the default setting, certain PDO objects are now available for selection. In this sample the input of channel 4 of the EL1004 terminal is selected for linking. In contrast, the checkbox "All types" must be ticked for creating the link for the output variables, in order to allocate a set of eight separate output bits to a byte variable. The following diagram shows the whole process:
Selecting several PDOs simultaneously: activate "Continuous" and "All types"
Note that the "Continuous" checkbox was also activated. This is designed to allocate the bits contained in the byte of the variable "nEL2008_value" sequentially to all eight selected output bits of the EL2008 terminal. In this way it is possible to subsequently address all eight outputs of the terminal in the program with a byte corresponding to bit 0 for channel 1 to bit 7 for channel 8 of the PLC. A special symbol ( [image]) at the yellow or red object of the variable indicates that a link exists. The links can also be checked by selecting a "Goto Link Variable” from the context menu of a variable. The object opposite, in this case the PDO, is automatically selected:
Application of a "Goto Link" variable, using "MAIN.bEL1004_Ch4" as a sample
The process of assigning variables to the PDO is completed via the menu selection "Actions" → "Generate Mappings”, key Ctrl+M or by clicking on the symbol [image] in the menu.
This can be visualized in the configuration:
The process of creating links can also take place in the opposite direction, i.e. starting with individual PDOs to variable. However, in this example it would then not be possible to select all output bits for the EL2008, since the terminal only makes individual digital outputs available. If a terminal has a byte, word, integer or similar PDO, it is possible to allocate this a set of bit-standardised variables (type "BOOL"). Here, too, a "Goto Link Variable” from the context menu of a PDO can be executed in the other direction, so that the respective PLC instance can then be selected.
Activation of the configuration
The allocation of PDO to PLC variables has now established the connection from the controller to the inputs and outputs of the terminals. The configuration can now be activated. First, the configuration can be verified via [image] (or via "Actions" → "Check Configuration”). If no error is present, the configuration can be activated via [image] (or via "Actions" → "Activate Configuration…") to transfer the System Manager settings to the runtime system. Confirm the messages "Old configurations are overwritten!" and "Restart TwinCAT system in Run mode" with "OK".
A few seconds later the real-time status [image] is displayed at the bottom right in the System Manager. The PLC system can then be started as described below.
Starting the controller
Starting from a remote system, the PLC control has to be linked with the Embedded PC over Ethernet via "Online" → “Choose Run-Time System…":
Choose target system (remote)
In this sample "Runtime system 1 (port 801)" is selected and confirmed. Link the PLC with the real-time system via menu option "Online" → "Login", the F11 key or by clicking on the symbol [image]. The control program can then be loaded for execution. This results in the message "No program on the controller! Should the new program be loaded?", which should be acknowledged with "Yes". The runtime environment is ready for the program start:
PLC Control logged in, ready for program startup
The PLC can now be started via "Online" → "Run", F5 key or [image].


TwinCAT 3

Commissioning on EtherCAT Master [image] TwinCAT Quick Start [image] TwinCAT 3
TwinCAT 3
Startup
TwinCAT makes the development environment areas available together with Microsoft Visual Studio: after startup, the project folder explorer appears on the left in the general window area (cf. "TwinCAT System Manager" of TwinCAT 2) for communication with the electromechanical components.
After successful installation of the TwinCAT system on the PC to be used for development, TwinCAT 3 (shell) displays the following user interface after startup:
Initial TwinCAT 3 user interface
First create a new project via [image] (or under "File"→“New"→ "Project…"). In the following dialog make the corresponding entries as required (as shown in the diagram):
Create new TwinCAT project
The new project is then available in the project folder explorer:
New TwinCAT3 project in the project folder explorer
Generally, TwinCAT can be used in local or remote mode. Once the TwinCAT system including the user interface (standard) is installed on the respective PLC, TwinCAT can be used in local mode and thereby the next step is "Insert Device".
If the intention is to address the TwinCAT runtime environment installed on a PLC as development environment remotely from another system, the target system must be made known first. Via the symbol in the menu bar:
expand the pull-down menu:
and open the following window:
Selection dialog: Choose the target system
Use "Search (Ethernet)..." to enter the target system. Thus a next dialog opens to either:
▪
enter the known computer name after "Enter Host Name / IP:" (as shown in red)
▪
perform a "Broadcast Search" (if the exact computer name is not known)
▪
enter the known computer IP or AmsNetID.
Specify the PLC for access by the TwinCAT System Manager: selection of the target system
Once the target system has been entered, it is available for selection as follows (a password may have to be entered):
After confirmation with "OK" the target system can be accessed via the Visual Studio shell.
Adding devices
In the project folder explorer of the Visual Studio shell user interface on the left, select "Devices" within element “I/O”, then right-click to open a context menu and select "Scan" or start the action via [image] in the menu bar. The TwinCAT System Manager may first have to be set to "Config mode" via [image] or via the menu "TwinCAT" → "Restart TwinCAT (Config mode)".
Select "Scan"
Confirm the warning message, which follows, and select "EtherCAT" in the dialog:
Automatic detection of I/O devices: selection the devices to be integrated
Confirm the message "Find new boxes", in order to determine the terminals connected to the devices. "Free Run" enables manipulation of input and output values in "Config mode" and should also be acknowledged.
Based on the sample configuration described at the beginning of this section, the result is as follows:
Mapping of the configuration in VS shell of the TwinCAT3 environment
The whole process consists of two stages, which may be performed separately (first determine the devices, then determine the connected elements such as boxes, terminals, etc.). A scan can also be initiated by selecting "Device ..." from the context menu, which then reads the elements present in the configuration below:
Reading of individual terminals connected to a device
This functionality is useful if the actual configuration is modified at short notice.
Programming the PLC
TwinCAT PLC Control is the development environment for the creation of the controller in different program environments: TwinCAT PLC Control supports all languages described in IEC 61131-3. There are two text-based languages and three graphical languages.
▪
Text-based languages
–
Instruction List (IL)
–
Structured Text (ST)
▪
Graphical languages
–
Function Block Diagram (FBD)
–
Ladder Diagram (LD)
–
The Continuous Function Chart Editor (CFC)
–
Sequential Function Chart (SFC)
The following section refers to Structured Text (ST).
In order to create a programming environment, a PLC subproject is added to the project sample via the context menu of "PLC" in the project folder explorer by selecting "Add New Item….":
Adding the programming environment in "PLC"
In the dialog that opens select "Standard PLC project" and enter "PLC_example" as project name, for example, and select a corresponding directory:
Specifying the name and directory for the PLC programming environment
The "Main" program, which already exists by selecting "Standard PLC project", can be opened by double-clicking on "PLC_example_project" in "POUs”. The following user interface is shown for an initial project:
Initial "Main" program of the standard PLC project
To continue, sample variables and a sample program have now been created:
Sample program with variables after a compile process (without variable integration)
The control program is now created as a project folder, followed by the compile process:
Start program compilation
The following variables, identified in the ST/ PLC program with "AT%", are then available in under "Assignments" in the project folder explorer:
Assigning variables
Via the menu of an instance - variables in the "PLC” context, use the "Modify Link…" option to open a window for selecting a suitable process object (PDO) for linking:
Creating the links between PLC variables and process objects
In the window that opens, the process object for the variable "bEL1004_Ch4" of type BOOL can be selected from the PLC configuration tree:
Selecting PDO of type BOOL
According to the default setting, certain PDO objects are now available for selection. In this sample the input of channel 4 of the EL1004 terminal is selected for linking. In contrast, the checkbox "All types" must be ticked for creating the link for the output variables, in order to allocate a set of eight separate output bits to a byte variable. The following diagram shows the whole process:
Selecting several PDOs simultaneously: activate "Continuous" and "All types"
Note that the "Continuous" checkbox was also activated. This is designed to allocate the bits contained in the byte of the variable "nEL2008_value" sequentially to all eight selected output bits of the EL2008 terminal. In this way it is possible to subsequently address all eight outputs of the terminal in the program with a byte corresponding to bit 0 for channel 1 to bit 7 for channel 8 of the PLC. A special symbol ( [image]) at the yellow or red object of the variable indicates that a link exists. The links can also be checked by selecting a "Goto Link Variable” from the context menu of a variable. The object opposite, in this case the PDO, is automatically selected:
Application of a "Goto Link" variable, using "MAIN.bEL1004_Ch4" as a sample
The process of creating links can also take place in the opposite direction, i.e. starting with individual PDOs to variable. However, in this example it would then not be possible to select all output bits for the EL2008, since the terminal only makes individual digital outputs available. If a terminal has a byte, word, integer or similar PDO, it is possible to allocate this a set of bit-standardised variables (type "BOOL"). Here, too, a "Goto Link Variable” from the context menu of a PDO can be executed in the other direction, so that the respective PLC instance can then be selected.
Activation of the configuration
The allocation of PDO to PLC variables has now established the connection from the controller to the inputs and outputs of the terminals. The configuration can now be activated with [image] or via the menu under "TwinCAT" in order to transfer settings of the development environment to the runtime system. Confirm the messages "Old configurations are overwritten!" and "Restart TwinCAT system in Run mode" with "OK". The corresponding assignments can be seen in the project folder explorer:
A few seconds later the corresponding status of the Run mode is displayed in the form of a rotating symbol [image] at the bottom right of the VS shell development environment. The PLC system can then be started as described below.
Starting the controller
Select the menu option "PLC" → "Login" or click on [image] to link the PLC with the real-time system and load the control program for execution. This results in the message "No program on the controller! Should the new program be loaded?", which should be acknowledged with "Yes". The runtime environment is ready for program start by click on symbol [image], the "F5" key or via "PLC" in the menu selecting “Start”. The started programming environment shows the runtime values of individual variables:
TwinCAT development environment (VS shell): logged-in, after program startup
The two operator control elements for stopping [image] and logout [image] result in the required action (accordingly also for stop "Shift + F5", or both actions can be selected via the PLC menu).


EtherCAT basics

Commissioning on EtherCAT Master [image] EtherCAT basics
EtherCAT basics
Please refer to the EtherCAT System Documentation for the EtherCAT fieldbus basics.


EtherCAT cabling – wire-bound

Commissioning on EtherCAT Master [image] EtherCAT cabling – wire-bound
EtherCAT cabling – wire-bound
The cable length between two EtherCAT devices must not exceed 100 m. This results from the FastEthernet technology, which, above all for reasons of signal attenuation over the length of the cable, allows a maximum link length of 5 + 90 + 5 m if cables with appropriate properties are used. See also the Design recommendations for the infrastructure for EtherCAT/Ethernet.
Cables and connectors
For connecting EtherCAT devices only Ethernet connections (cables + plugs) that meet the requirements of at least category 5 (CAt5) according to EN 50173 or ISO/IEC 11801 should be used. EtherCAT uses 4 wires for signal transfer.
EtherCAT uses RJ45 plug connectors, for example. The pin assignment is compatible with the Ethernet standard (ISO/IEC 8802-3).
Pin | Color of conductor | Signal | Description
1 | yellow | TD + | Transmission Data +
2 | orange | TD - | Transmission Data -
3 | white | RD + | Receiver Data +
6 | blue | RD - | Receiver Data -
Due to automatic cable detection (auto-crossing) symmetric (1:1) or cross-over cables can be used between EtherCAT devices from Beckhoff.
Recommended cables
Suitable cables for the connection of EtherCAT devices can be found on the Beckhoff website!
E-Bus supply
A bus coupler can supply the EL terminals added to it with the E-bus system voltage of 5 V; a coupler is thereby loadable up to 2 A as a rule (see details in respective device documentation).
Information on how much current each EL terminal requires from the E-bus supply is available online and in the catalogue. If the added terminals require more current than the coupler can supply, then power feed terminals (e.g. EL9410) must be inserted at appropriate places in the terminal strand.
The pre-calculated theoretical maximum E-Bus current is displayed in the TwinCAT System Manager. A shortfall is marked by a negative total amount and an exclamation mark; a power feed terminal is to be placed before such a position.
System manager current calculation
Note
Malfunction possible!
The same ground potential must be used for the E-Bus supply of all EtherCAT terminals in a terminal block!


General notes for setting the watchdog

Commissioning on EtherCAT Master [image] General notes for setting the watchdog
General notes for setting the watchdog
ELxxxx terminals are equipped with a safety feature (watchdog) that switches off the outputs after a specifiable time e.g. in the event of an interruption of the process data traffic, depending on the device and settings, e.g. in OFF state.
The EtherCAT slave controller (ESC) in the EL2xxx terminals features 2 watchdogs:
▪
SM watchdog (default: 100 ms)
▪
PDI watchdog (default: 100 ms)
SM watchdog (SyncManager Watchdog)
The SyncManager watchdog is reset after each successful EtherCAT process data communication with the terminal. If no EtherCAT process data communication takes place with the terminal for longer than the set and activated SM watchdog time, e.g. in the event of a line interruption, the watchdog is triggered and the outputs are set to FALSE. The OP state of the terminal is unaffected. The watchdog is only reset after a successful EtherCAT process data access. Set the monitoring time as described below.
The SyncManager watchdog monitors correct and timely process data communication with the ESC from the EtherCAT side.
PDI watchdog (Process Data Watchdog)
If no PDI communication with the EtherCAT slave controller (ESC) takes place for longer than the set and activated PDI watchdog time, this watchdog is triggered.
PDI (Process Data Interface) is the internal interface between the ESC and local processors in the EtherCAT slave, for example. The PDI watchdog can be used to monitor this communication for failure.
The PDI watchdog monitors correct and timely process data communication with the ESC from the application side.
The settings of the SM- and PDI-watchdog must be done for each slave separately in the TwinCAT System Manager.
EtherCAT tab -> Advanced Settings -> Behavior -> Watchdog
Notes:
▪
the multiplier is valid for both watchdogs.
▪
each watchdog has its own timer setting, the outcome of this in summary with the multiplier is a resulting time.
▪
Important: the multiplier/timer setting is only loaded into the slave at the start up, if the checkbox is activated.
If the checkbox is not activated, nothing is downloaded and the ESC settings remain unchanged.
Multiplier
Multiplier
Both watchdogs receive their pulses from the local terminal cycle, divided by the watchdog multiplier:
1/25 MHz * (watchdog multiplier + 2) = 100 µs (for default setting of 2498 for the multiplier)
The standard setting of 1000 for the SM watchdog corresponds to a release time of 100 ms.
The value in multiplier + 2 corresponds to the number of basic 40 ns ticks representing a watchdog tick.
The multiplier can be modified in order to adjust the watchdog time over a larger range.
Example "Set SM watchdog"
This checkbox enables manual setting of the watchdog times. If the outputs are set and the EtherCAT communication is interrupted, the SM watchdog is triggered after the set time and the outputs are erased. This setting can be used for adapting a terminal to a slower EtherCAT master or long cycle times. The default SM watchdog setting is 100 ms. The setting range is 0..65535. Together with a multiplier with a range of 1..65535 this covers a watchdog period between 0..~170 seconds.
Calculation
Multiplier = 2498 → watchdog base time = 1 / 25 MHz * (2498 + 2) = 0.0001 seconds = 100 µs
SM watchdog = 10000 → 10000 * 100 µs = 1 second watchdog monitoring time
SmallWarningYellow CAUTION
Undefined state possible!
The function for switching off of the SM watchdog via SM watchdog = 0 is only implemented in terminals from version -0016. In previous versions this operating mode should not be used.
SmallWarningYellow CAUTION
Damage of devices and undefined state possible!
If the SM watchdog is activated and a value of 0 is entered the watchdog switches off completely. This is the deactivation of the watchdog! Set outputs are NOT set in a safe state, if the communication is interrupted.


EtherCAT State Machine

Commissioning on EtherCAT Master [image] EtherCAT State Machine
EtherCAT State Machine
The state of the EtherCAT slave is controlled via the EtherCAT State Machine (ESM). Depending upon the state, different functions are accessible or executable in the EtherCAT slave. Specific commands must be sent by the EtherCAT master to the device in each state, particularly during the bootup of the slave.
A distinction is made between the following states:
▪
Init
▪
Pre-Operational
▪
Safe-Operational and
▪
Operational
▪
Boot
The regular state of each EtherCAT slave after bootup is the OP state.
States of the EtherCAT State Machine
Init
After switch-on the EtherCAT slave in the Init state. No mailbox or process data communication is possible. The EtherCAT master initializes sync manager channels 0 and 1 for mailbox communication.
Pre-Operational (Pre-Op)
During the transition between Init and Pre-Op the EtherCAT slave checks whether the mailbox was initialized correctly.
In Pre-Op state mailbox communication is possible, but not process data communication. The EtherCAT master initializes the sync manager channels for process data (from sync manager channel 2), the FMMU channels and, if the slave supports configurable mapping, PDO mapping or the sync manager PDO assignment. In this state the settings for the process data transfer and perhaps terminal-specific parameters that may differ from the default settings are also transferred.
Safe-Operational (Safe-Op)
During transition between Pre-Op and Safe-Op the EtherCAT slave checks whether the sync manager channels for process data communication and, if required, the distributed clocks settings are correct. Before it acknowledges the change of state, the EtherCAT slave copies current input data into the associated DP-RAM areas of the EtherCAT slave controller (ECSC).
In Safe-Op state mailbox and process data communication is possible, although the slave keeps its outputs in a safe state, while the input data are updated cyclically.
Outputs in SAFEOP state
The default set watchdog monitoring sets the outputs of the module in a safe state - depending on the settings in SAFEOP and OP - e.g. in OFF state. If this is prevented by deactivation of the watchdog monitoring in the module, the outputs can be switched or set also in the SAFEOP state.
Operational (Op)
Before the EtherCAT master switches the EtherCAT slave from Safe-Op to Op it must transfer valid output data.
In the Op state the slave copies the output data of the masters to its outputs. Process data and mailbox communication is possible.
Boot
In the Boot state the slave firmware can be updated. The Boot state can only be reached via the Init state.
In the Boot state mailbox communication via the file access over EtherCAT (FoE) protocol is possible, but no other mailbox communication and no process data communication.


CoE Interface

Commissioning on EtherCAT Master [image] CoE Interface
CoE Interface
General description
The CoE interface (CANopen over EtherCAT) is used for parameter management of EtherCAT devices. EtherCAT slaves or the EtherCAT master manage fixed (read only) or variable parameters which they require for operation, diagnostics or commissioning.
CoE parameters are arranged in a table hierarchy. In principle, the user has read access via the fieldbus. The EtherCAT master (TwinCAT System Manager) can access the local CoE lists of the slaves via EtherCAT in read or write mode, depending on the attributes.
Different CoE parameter types are possible, including string (text), integer numbers, Boolean values or larger byte fields. They can be used to describe a wide range of features. Examples of such parameters include manufacturer ID, serial number, process data settings, device name, calibration values for analog measurement or passwords.
The order is specified in 2 levels via hexadecimal numbering: (main)index, followed by subindex. The value ranges are
▪
Index: 0x0000 …0xFFFF (0...65535dez)
▪
SubIndex: 0x00…0xFF (0...255dez)
A parameter localized in this way is normally written as 0x8010:07, with preceding "x" to identify the hexadecimal numerical range and a colon between index and subindex.
The relevant ranges for EtherCAT fieldbus users are:
▪
0x1000: This is where fixed identity information for the device is stored, including name, manufacturer, serial number etc., plus information about the current and available process data configurations.
▪
0x8000: This is where the operational and functional parameters for all channels are stored, such as filter settings or output frequency.
Other important ranges are:
▪
0x4000: In some EtherCAT devices the channel parameters are stored here (as an alternative to the 0x8000 range).
▪
0x6000: Input PDOs ("input" from the perspective of the EtherCAT master)
▪
0x7000: Output PDOs ("output" from the perspective of the EtherCAT master)
Availability
Not every EtherCAT device must have a CoE list. Simple I/O modules without dedicated processor usually have no variable parameters and therefore no CoE list.
If a device has a CoE list, it is shown in the TwinCAT System Manager as a separate tab with a listing of the elements:
"CoE Online " tab
The figure above shows the CoE objects available in device "EL2502", ranging from 0x1000 to 0x1600. The subindices for 0x1018 are expanded.
Data management and function "NoCoeStorage"
Some parameters, particularly the setting parameters of the slave, are configurable and writeable. This can be done in write or read mode
▪
via the System Manager (Fig. "CoE Online " tab) by clicking
This is useful for commissioning of the system/slaves. Click on the row of the index to be parameterised and enter a value in the "SetValue" dialog.
▪
from the control system/PLC via ADS, e.g. through blocks from the TcEtherCAT.lib library
This is recommended for modifications while the system is running or if no System Manager or operating staff are available.
Data management
If slave CoE parameters are modified online, Beckhoff devices store any changes in a fail-safe manner in the EEPROM, i.e. the modified CoE parameters are still available after a restart.
The situation may be different with other manufacturers.

An EEPROM is subject to a limited lifetime with respect to write operations. From typically 100,000 write operations onwards it can no longer be guaranteed that new (changed) data are reliably saved or are still readable. This is irrelevant for normal commissioning. However, if CoE parameters are continuously changed via ADS at machine runtime, it is quite possible for the lifetime limit to be reached. Support for the NoCoeStorage function, which suppresses the saving of changed CoE values, depends on the firmware version.
Please refer to the technical data in this documentation as to whether this applies to the respective device.
•
If the function is supported: the function is activated by entering the code word 0x12345678 once in CoE 0xF008 and remains active as long as the code word is not changed. After switching the device on it is then inactive. Changed CoE values are not saved in the EEPROM and can thus be changed any number of times.
•
Function is not supported: continuous changing of CoE values is not permissible in view of the lifetime limit.
Startup list
Changes in the local CoE list of the terminal are lost if the terminal is replaced. If a terminal is replaced with a new Beckhoff terminal, it will have the default settings. It is therefore advisable to link all changes in the CoE list of an EtherCAT slave with the Startup list of the slave, which is processed whenever the EtherCAT fieldbus is started. In this way a replacement EtherCAT slave can automatically be parameterized with the specifications of the user.
If EtherCAT slaves are used which are unable to store local CoE values permanently, the Startup list must be used.
Recommended approach for manual modification of CoE parameters
▪
Make the required change in the System Manager
The values are stored locally in the EtherCAT slave
▪
If the value is to be stored permanently, enter it in the Startup list.
The order of the Startup entries is usually irrelevant.
Startup list in the TwinCAT System Manager
The Startup list may already contain values that were configured by the System Manager based on the ESI specifications. Additional application-specific entries can be created.
Online/offline list
While working with the TwinCAT System Manager, a distinction has to be made whether the EtherCAT device is "available", i.e. switched on and linked via EtherCAT and therefore online, or whether a configuration is created offline without connected slaves.
In both cases a CoE list as shown in Fig. “’CoE online’ tab” is displayed. The connectivity is shown as offline/online.
▪
If the slave is offline
–
The offline list from the ESI file is displayed. In this case modifications are not meaningful or possible.
–
The configured status is shown under Identity.
–
No firmware or hardware version is displayed, since these are features of the physical device.
–
Offline is shown in red.
Offline list
▪
If the slave is online
–
The actual current slave list is read. This may take several seconds, depending on the size and cycle time.
–
The actual identity is displayed
–
The firmware and hardware version of the equipment according to the electronic information is displayed
–
Online is shown in green.
Online list
Channel-based order
The CoE list is available in EtherCAT devices that usually feature several functionally equivalent channels. For example, a 4-channel analog 0..10 V input terminal also has 4 logical channels and therefore 4 identical sets of parameter data for the channels. In order to avoid having to list each channel in the documentation, the placeholder "n" tends to be used for the individual channel numbers.
In the CoE system 16 indices, each with 255 subindices, are generally sufficient for representing all channel parameters. The channel-based order is therefore arranged in 16dec/10hex steps. The parameter range 0x8000 exemplifies this:
▪
Channel 0: parameter range 0x8000:00 ... 0x800F:255
▪
Channel 1: parameter range 0x8010:00 ... 0x801F:255
▪
Channel 2: parameter range 0x8020:00 ... 0x802F:255
▪
...
This is generally written as 0x80n0.
Detailed information on the CoE interface can be found in the EtherCAT system documentation on the Beckhoff website.


Distributed Clock

Commissioning on EtherCAT Master [image] Distributed Clock
Distributed Clock
The distributed clock represents a local clock in the EtherCAT slave controller (ESC) with the following characteristics:
▪
Unit 1 ns
▪
Zero point 1.1.2000 00:00
▪
Size 64 bit (sufficient for the next 584 years; however, some EtherCAT slaves only offer 32-bit support, i.e. the variable overflows after approx. 4.2 seconds)
▪
The EtherCAT master automatically synchronizes the local clock with the master clock in the EtherCAT bus with a precision of < 100 ns.
For detailed information please refer to the EtherCAT system description.


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Installation positions
•
Positioning of passive Terminals
•
Notes regarding connectors and wiring
•
Shielding concept
•
Installation on mounting rails
•
Connection system
•
LED indicators - meanings
•
Connection


Installation positions

Mounting and wiring [image] Installation positions
Installation positions
Note
Constraints regarding installation position and operating temperature range
Please refer to the technical data for a terminal to ascertain whether any restrictions regarding the installation position and/or the operating temperature range have been specified. When installing high power dissipation terminals ensure that an adequate spacing is maintained between other components above and below the terminal in order to guarantee adequate ventilation!
Optimum installation position (standard)
The optimum installation position requires the mounting rail to be installed horizontally and the connection surfaces of the EL/KL terminals to face forward (see Fig. “Recommended distances for standard installation position”). The terminals are ventilated from below, which enables optimum cooling of the electronics through convection. "From below" is relative to the acceleration of gravity.
Recommended distances for standard installation position
Compliance with the distances shown in Fig. “Recommended distances for standard installation position” is recommended.
Other installation positions
All other installation positions are characterized by different spatial arrangement of the mounting rail - see Fig “Other installation positions”.
The minimum distances to ambient specified above also apply to these installation positions.
Other installation positions


Positioning of passive Terminals

Mounting and wiring [image] Positioning of passive Terminals
Positioning of passive Terminals
Hint for positioning of passive terminals in the bus terminal block
EtherCAT Terminals (ELxxxx / ESxxxx), which do not take an active part in data transfer within the bus terminal block are so called passive terminals. The passive terminals have no current consumption out of the E-Bus.
To ensure an optimal data transfer, you must not directly string together more than 2 passive terminals!
Examples for positioning of passive terminals (highlighted)
Correct positioning
Incorrect positioning


Notes regarding connectors and wiring

Mounting and wiring [image] Notes regarding connectors and wiring
Notes regarding connectors and wiring
It is in the very nature of EtherCAT I/O modules/terminals/boxes that they have two connection sides: one to the fieldbus for communication with the module, which is obligatory, the other to the signal/sensor/actuator to facilitate proper use of the module. The “outer” connection side usually features contacting options for connecting outgoing wires.
Only few I/O devices do not have a second side. Examples include the EL6070 license key terminal and the EL6090 display terminal.
Notes and suggestions for dealing with the connection options are provided below
▪
Manufacturer specifications/notes for connection options must be followed. Any special tools that may have been provided must be used as intended, so that gas-tightness is ensured through the crimping pressure.
▪
Any detachable connection system is subject to a specified maximum number of connection cycles. Each connection/disconnection operation results in wear through friction, mechanical stretching/relaxation, possibly ingress of contaminants/gases/liquids/condensation, contact discharge, modification of the electrical properties and of the contact point (ohmic contact resistance). In other words, releasing/connecting a contact results in mechanical, chemical and therefore ultimately electrical changes.
In terms of the application scenario it is therefore important to select suitable connection systems or devices with suitable connection systems:
–
For connections that are more or less permanent, it may make sense to use connectors/contacts with a maximum number of mating cycles (as specified by the manufacturer) of 10 to 100 cycles. This may be the case if devices are installed/wired only once, and over the entire lifetime rewiring is only expected to become necessary during maintenance work.
–
For connections that have to be detached on a regular basis, connectors/contacts with a maximum number of mating cycles of 1,000 or higher should be selected. Such connections can typically be found in laboratory environments, where the cabling may be changed several times each day but high-quality contact must nevertheless be ensured over many years.
▪
When handling and assembling connectors/contacts it is essential to avoid contact with hand perspiration/liquids, even for low-tech connections (open stranded wire, cage clamp/push-in). Acidic/alkaline liquids may have a very aggressive effect on the contact surface and quickly lead to structural changes and oxidation layers. These are very disruptive for analog measurements, particularly since they undermine the reproducibility of measurements and can therefore result (if known) in large systematic measurement uncertainty. It may be possible to rectify the problem by thorough follow-up cleaning.
▪
The actual/expected load during operation must be taken into account when selecting connectors.
▪
Abnormal vibrations can lead to microfriction/corrosion and change the electrical properties, potentially resulting in complete loss of contact.
▪
Temperature variations affect the mechanical strength of the connection and the spring forces in metallic components.
▪
Exposure to gas or liquid can damage the connection, particularly if the gas or liquid penetrates to the actual contact region and is unable to escape from there.
▪
Of high relevance for analog measurements is the electrical quality of the connection, both in the short term during commissioning and over the service life under external influences and perhaps repeated mating cycles. This is expressed in the repeatability of the transition. The influence should be checked against the expected accuracy. Of particular relevance is the (frequency dependent) contact resistance. Effects can be:
–
Increasing the contact resistance results in a voltage drop when power is transmitted, potentially leading to critical self-heating.
–
The internal voltage drop can distort corresponding measurements. In order to avoid negative effects, 4/5/6-wire connections should be used in SG/resistance measurements, since non-live contacts are no longer affected by a distorting voltage drop. The popular 3-wire connection for resistance measurement (PT100, PT1000 etc.) does not provide absolute protection, since the singular line cannot be diagnosed. Current/voltage measurements in industrial environments are less sensitive to contact changes.
–
A defective contact surface can lead to random resistance values, depending on the contact position and temperature. This makes reproducible measurements difficult.
▪
The effort for establishing the connection, including assembling the cables and connectors, generally increases with increasing transmission quality requirements. This applies to the tools, diligence and time required. Examples:
–
Cage clamp/push-in connections (e.g. Beckhoff EL terminals), which are common in automation applications, can be established or released in a few seconds with or without ferrule. A screwdriver or push pin is sufficient. On the other hand, in many cases the (ohmic) repeatability is insufficient for high-precision measurements in the SG/R range.
–
Some 10 minutes and costs of some 10 euros should be assumed for assembly a lab-standard LEMO/ODU connector (Beckhoff ELM3704-0001), depending on the number of poles. The result is a top-quality connection system with a high number of permissible mating cycles.
–
An intermediate solution can be field-configurable M8/M12 connections. For reasons of tightness, they are more elaborate to assemble (soldering or insulation displacement contact, if necessary), although the maximum number of mating cycles is similar to maintenance connectors.
▪
A pre-assembled connection should be subjected to electrical/mechanical testing before commissioning: visual inspection, pull-out test, crimp height measurement, resistance measurement etc.


Shielding concept

Mounting and wiring [image] Shielding concept
Shielding concept
Together with the shield busbar, the prefabricated cables from Beckhoff Automation offer optimum protection against electromagnetic interference.
It is highly recommended to apply the shield as close as possible to the terminal, in order to minimize operational disturbances.
Connection of the motor cable to the shield busbar
Fasten the shield busbar supports 1 to the DIN rail 2. The mounting rail 2 must be in contact with the metallic rear wall of the control cabinet over a wide area. Install the shield busbar 3 as shown below.
As an alternative, a shield busbar clamp 3a can be screwed directly to the metallic rear wall of the control cabinet (fig. “shield busbar clamp”)
Shield busbar
Shield busbar clamp
Connect the cores 4 of the motor cable 5, then attach the copper-sheathed end 6 of the motor cable 5 with the shield clamp 7 to the shield busbar 3 or shield busbar clamp 3a. Tighten the screw 8 to the stop.
Fasten the PE clamp 9 to the shield busbar 3 or shield busbar clamp 3a. Clamp the PE core 10 of the motor cable 5 under the PE clamp 9.
Shield connection
Connection of the feedback cable to the motor
Twisting of the feedback cable cores
The feedback cable cores should be twisted, in order to avoid operational disturbances.
When screwing the feedback plug to the motor, the shield of the feedback cable is connected via the metallic plug fastener.
On the terminal side the shield can also be connected. Connect the cores of the feedback cable and attach the copper-sheathed end of the feedback cable to the shield busbar 3 or shield busbar clamp 3a with the shield clamp 7. The motor cable and the feedback cable can be connected to the shield clamp 7 with the screw 8.


Installation on mounting rails

Mounting and wiring [image] Installation on mounting rails
Installation on mounting rails
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Assembly
Attaching on mounting rail
The bus coupler and bus terminals are attached to commercially available 35 mm mounting rails (DIN rails according to EN 60715) by applying slight pressure:
1.
First attach the fieldbus coupler to the mounting rail.
2.
The bus terminals are now attached on the right-hand side of the fieldbus coupler. Join the components with tongue and groove and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
If the terminals are clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.
Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail. At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail. To mount the mounting rails with a height of 7.5 mm under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).
Disassembly
Disassembling of terminal
Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
1.
Pull the terminal by its orange-colored lugs approximately 1 cm away from the mounting rail. In doing so for this terminal the mounting rail lock is released automatically and you can pull the terminal out of the bus terminal block easily without excessive force.
2.
Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal out of the bus terminal block.
Connections within a bus terminal block
The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:
▪
The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
▪
The power contacts deal with the supply for the field electronics and thus represent a supply rail within the bus terminal block. The power contacts are supplied via terminals on the Bus Coupler (up to 24 V) or for higher voltages via power feed terminals.
Power Contacts
During the design of a bus terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts. Power Feed Terminals (KL91xx, KL92xx or EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.
PE power contact
The power contact labeled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Power contact on left side
Note
Possible damage of the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a nominal voltage of 230 V). For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.
SmallWarningYellow WARNING
Risk of electric shock!
The PE power contact must not be used for other potentials!


Connection system

Mounting and wiring [image] Connection system
Connection system
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Overview
The Bus Terminal system offers different connection options for optimum adaptation to the respective application:
▪
The terminals of KLxxxx and ELxxxx series with standard wiring include electronics and connection level in a single enclosure.
▪
The terminals of KSxxxx and ESxxxx series feature a pluggable connection level and enable steady wiring while replacing.
▪
The High Density Terminals (HD Terminals) include electronics and connection level in a single enclosure and have advanced packaging density.
Standard wiring
Standard wiring
The terminals of KLxxxx and ELxxxx series have been tried and tested for years.
They feature integrated screwless spring force technology for fast and simple assembly.
Pluggable wiring
Pluggable wiring
The terminals of KSxxxx and ESxxxx series feature a pluggable connection level.
The assembly and wiring procedure for the KS series is the same as for the KLxxxx and ELxxxx series.
The KS/ES series terminals enable the complete wiring to be removed as a plug connector from the top of the housing for servicing.
The lower section can be removed from the terminal block by pulling the unlocking tab.
Insert the new component and plug in the connector with the wiring. This reduces the installation time and eliminates the risk of wires being mixed up.
The familiar dimensions of the terminal only had to be changed slightly. The new connector adds about 3 mm. The maximum height of the terminal remains unchanged.
A tab for strain relief of the cable simplifies assembly in many applications and prevents tangling of individual connection wires when the connector is removed.
Conductor cross sections between 0.08 mm2 and 2.5 mm2 can continue to be used with the proven spring force technology.
The overview and nomenclature of the product names for KSxxxx and ESxxxx series has been retained as known from KLxxxx and ELxxxx series.
High Density Terminals (HD Terminals)
High Density Terminals
The Bus Terminals from these series with 16 connection points are distinguished by a particularly compact design, as the packaging density is twice as large as that of the standard 12 mm Bus Terminals. Massive conductors and conductors with a wire end sleeve can be inserted directly into the spring loaded terminal point without tools.
Wiring HD Terminals
The High Density (HD) Terminals of the KLx8xx and ELx8xx series doesn't support steady wiring.
Ultrasonically "bonded" (ultrasonically welded) conductors
Ultrasonically “bonded" conductors
It is also possible to connect the Standard and High Density Terminals with ultrasonically "bonded" (ultrasonically welded) conductors. In this case, please note the tables concerning the wire-size width below!
Wiring
Terminals for standard wiring ELxxxx/KLxxxx and for pluggable wiring ESxxxx/KSxxxx
Mounting a cable on a terminal connection
Up to eight connections enable the connection of solid or finely stranded cables to the Bus Terminals. The terminals are implemented in spring force technology. Connect the cables as follows:
1.
Open a spring-loaded terminal by slightly pushing with a screwdriver or a rod into the square opening above the terminal.
2.
The wire can now be inserted into the round terminal opening without any force.
3.
The terminal closes automatically when the pressure is released, holding the wire securely and permanently.
Terminal housing | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Wire size width | 0.08 ... 2,5 mm2 | 0.08 ... 2.5 mm2
Wire stripping length | 8 ... 9 mm | 9 ... 10 mm
High Density Terminals ELx8xx, KLx8xx (HD)
The conductors of the HD Terminals are connected without tools for single-wire conductors using the direct plug-in technique, i.e. after stripping the wire is simply plugged into the contact point. The cables are released, as usual, using the contact release with the aid of a screwdriver. See the following table for the suitable wire size width.
Terminal housing | High Density Housing
Wire size width (conductors with a wire end sleeve) | 0.14 ... 0.75 mm2
Wire size width (single core wires) | 0.08 ... 1.5 mm2
Wire size width (fine-wire conductors) | 0.25 ... 1.5 mm2
Wire size width (ultrasonically “bonded" conductors) | only 1.5 mm2 (see notice!)
Wire stripping length | 8 ... 9 mm
Shielding
Shielding
Analog sensors and actors should always be connected with shielded, twisted paired wires.


LED indicators - meanings

Mounting and wiring [image] LED indicators - meanings
LED indicators - meanings
LED | Color | Meaning
EcRun | green | off | State of the EtherCAT State Machine: INIT = initialization of the terminal
 |  | flashing rapidly | State of the EtherCAT State Machine: BOOTSTRAP = function for firmware updates of the terminal
 |  | flashing | State of the EtherCAT State Machine: PREOP = function for mailbox communication and different standard-settings set
 |  | single flash | State of the EtherCAT State Machine: SAFEOP = function for mailbox communication and different standard-settings set Outputs remain in safe state
 |  | on | State of the EtherCAT State Machine: OP = normal operating state; mailbox and process data communication is possible
LED
Color
Meaning
Ok/Error
green
No error
rot
Error display, along with error bit in the status, for
▪
Measuring range error (not for underrange/overrange!)
▪
Set measuring type is not calibrated (see CoE object 0x800F)
▪
Processor overload (see CoE object 0xF900“InfoData“)
▪
ADC in "saturation"
▪
Analog circuit "in overload", over voltage detected at inputs; see notes in section "Technical data” and following section "Connection"
▪
Oversampling Error in Synchron Mode
off
No operation


Connection

Mounting and wiring [image] Connection
Connection
Terminal point |  | Description
Name | No.
+Input 1 | 1 | +Input 1
+Input 2 | 2 | +Input 2
+Uv | 3 | +Supply voltage
Shield | 4 | Shield (FE)/ SGND
-Input 1 | 5 | -Input 1
-Input 2 | 6 | -Input 2
-Uv (GNDint) | 7 | -Supply voltage (internal ground)
Shield | 8 | Shield (FE)/ SGND
The internal surge voltage protection of the inputs related to -Uv (internal ground) will be active as follows:
+IN1, -IN1: at ca. 12 +/- 0.5V (within 30V-Mode at ca. 37 +/- 1V)
+IN2, -IN2: at ca. <-0.3V or >+5.3V


Appendix

Appendix
Appendix
Additional information
•
Sample programs
•
Diagnostics – basic principles of diag messages
•
TcEventLogger and IO
•
CoE overview
•
UL notice
•
ATEX Documentation
•
EtherCAT AL Status Codes
•
Firmware Update EL/ES/EM/ELM/EPxxxx
•
Firmware compatibility - passive terminals
•
Restoring the delivery state
•
Support and Service


Sample programs

Appendix [image] Sample programs
Sample programs
Using the sample programs
This document contains sample applications of our products for certain areas of application. The application notes provided here are based on typical features of our products and only serve as examples. The notes contained in this document explicitly do not refer to specific applications. The customer is therefore responsible for assessing and deciding whether the product is suitable for a particular application. We accept no responsibility for the completeness and correctness of the source code contained in this document. We reserve the right to modify the content of this document at any time and accept no responsibility for errors and missing information.
Preparations for starting the sample programs (tnzip file / TwinCAT 3)
▪
Click on the download button to save the Zip archive locally on your hard disk, then unzip the *.tnzip archive file in a temporary folder.
Opening the *. tnzip archive
▪
Select the .tnzip file (sample program).
▪
A further selection window opens. Select the destination directory for storing the project.
▪
For a description of the general PLC commissioning procedure and starting the program please refer to the terminal documentation or the EtherCAT system documentation.
▪
The EtherCAT device of the example should usually be declared your present system. After selection of the EtherCAT device in the “Solutionexplorer” select the “Adapter” tab and click on “Search...”:
Search of the existing HW configuration for the EtherCAT configuration of the example
▪
Checking NetId: the "EtherCAT" tab of the EtherCAT device shows the configured NetId: .
The first 4 numbers have to be identical with the project NetId of the target system. The project NetId can be viewed within the TwinCAT environment above, where a pull down menu can be opened to choose a target system (by clicking right in the text field). The number blocks are placed in brackets there next to each computer name of a target system.
▪
Modify the NetId: By right clicking on "EtherCAT device" within the solution explorer a context menu opens where "Change NetId..." have to be selected. The first 4 numbers of the NetId of the target computer have to be entered; the both last values are 4.1 usually.
Example:
–
NetId of project: myComputer (123.45.67.89.1.1)
–
Entry via „Change NetId...“: 123.45.67.89.4.1
Additional information
•
Sample program 1 and 2 (offset/gain)
•
Sample program 3 (write lookup table)
•
Sample program 4 (generate LookUp table)
•
Sample program 5 (write filter coefficients)
•
Sample program 6 (interlacing of measured values)
•
Sample program 7 (general decimation in the PLC)
•
Sample program 8 (FB for real time diagnosis)


Sample program 1 and 2 (offset/gain)

Appendix [image] Sample programs [image] Sample program 1 and 2 (offset/gain)
Sample program 1 and 2 (offset/gain)
Download TwinCAT 3 project:
Program description
1.
Calculating of an Offset correction value by the amplitude of an input alternating voltage (with DC content respectively) and step by step entry of that value via CoE access into the terminal until a minimal deviation to zero of the measured value (“wOFFSET_MIN_VAL_REF”) is reached.
2.
(If 1. executed:) Calculation of a Gain value and step by step entry of that value via CoE access into the terminal until “nPRESET_MAX_VAL” as for the measured value is reached.
Variable declaration sample programs 1 and 2
PROGRAM MAIN
VAR_INPUT
// Use an external Switch to start justify Offset/Gain
bEnable AT%I* :BOOL;
PAI_Sample AT%I* :DINT; // Variable link to terminal input Ch.1
END_VAR
VAR
// "Main" State controlling Offset/Gain adjusting:
nMainCal_State :BYTE:=0;
// ===============================================
// For CoE Object 0x8005 access:
fb_coe_write :FB_EcCoESdoWrite;
// Enter your Net-Id here:
userNetId :T_AmsNetId := '191.168.1.1.4.1';
// Enter terminals adress here:
userSlaveAddr :UINT := 1003;
wCoEIndexScaler :WORD := 16#8005;
bySubIndScalGain :BYTE := 16#02;
bySubIndScalOffs :BYTE := 16#01;
nADSErrId :UDINT; // Copy of ADS-Error ID
// ===============================================
// Variables for calculation
fb_get_min_max :FB_GET_MIN_MAX;
// Variables used for offset scaling:
nSTATE_SCALE_OFFSET :INT := 0;
bStartScaleOffset :BOOL := FALSE;
bScaleOffsetDone :BOOL := FALSE;
fOffsetDeviationVal :REAL;
fScalerOffset_COE :LREAL := 0;
wOFFSET_MIN_VAL_REF :WORD := 2000; // Deviation tolerance
// Variables used for gain scaling:
nSTATE_SCALE_GAIN :INT := 0;
bStartScaleGain :BOOL := FALSE;
bScaleGainDone :BOOL := FALSE;
fScalerGain_COE :REAL := 1;
nPRESET_MAX_VAL :DINT := 3000000; // Target amplitude value
nMaxAmplVal :DINT;
// ===============================================
// Variables for intermediate results
nValue :DINT; // Used for Offset (adding)
fValue :REAL; // Used for Gain (multiply)
END_VAR
Execution part:
// Example program 1 and 2 program code:
// =====================================
IF bEnable AND (nMainCal_State = 0) THEN // Poll Switch
nMainCal_State := 10;
END_IF
CASE nMainCal_State OF // Main-State Procedure
10:
bStartScaleOffset:=TRUE; // Start with Offset scaling
nMainCal_State := nMainCal_State + 1; // next state
11:
IF bScaleOffsetDone THEN
bStartScaleGain := TRUE; // Continue with gain scaling
nMainCal_State := nMainCal_State + 1;
END_IF
12:
IF bScaleGainDone THEN
nMainCal_State := nMainCal_State + 1; // all done
END_IF
13:
IF NOT bEnable THEN
nMainCal_State :=0; // Initalization for next start by user
END_IF
END_CASE
// ----- Offset scaling -----
IF bStartScaleOffset THEN
CASE nSTATE_SCALE_OFFSET OF
0:
bScaleOffsetDone := FALSE; // Initialization of confirmation flag
nSTATE_SCALE_OFFSET := nSTATE_SCALE_OFFSET + 1;
1:
fb_get_min_max(nInputValue:=PAI_Sample); // Get min/max Values by current Sample value
IF fb_get_min_max.bRESULT THEN // Wait if Limit-Values are valid
fb_coe_write(bExecute := FALSE); // Prepare CoE access
nSTATE_SCALE_OFFSET := nSTATE_SCALE_OFFSET + 1; // Min/Max Values valid - go to next state
END_IF
2:
// Calculate current offset deviation
fOffsetDeviationVal :=
LREAL_TO_REAL(ABS(fb_get_min_max.nMinVal)
- ((ABS(fb_get_min_max.nMaxVal)
+ ABS(fb_get_min_max.nMinVal))/2));
// Offset deviation check:
IF ABS(fOffsetDeviationVal) < wOFFSET_MIN_VAL_REF THEN
// Deviation in acceptable range - offset scaling done
bScaleOffsetDone := TRUE;
bStartScaleOffset := FALSE;
nSTATE_SCALE_OFFSET := 0;
ELSE
// Calculate new offset value (consider pre-assigned value)
nValue := LREAL_TO_DINT(fScalerOffset_COE + fOffsetDeviationVal);
// ..proceed zero-point shift: write value into CoE Object
fb_coe_write(
sNetId:= userNetId,
nSlaveAddr:= userSlaveAddr,
nSubIndex:= bySubIndScalOffs,
nIndex:= wCoEIndexScaler,
pSrcBuf:= ADR(nValue), // Offset-Value (CoE 0x8005:01)
cbBufLen:= SIZEOF(nValue),
bExecute:= TRUE,
tTimeout:= T#1S,
bBusy=> ,
bError=> ,
nErrId=> );
nSTATE_SCALE_OFFSET := nSTATE_SCALE_OFFSET + 1;
END_IF
3:
fb_coe_write();
IF fb_coe_write.bError THEN
nSTATE_SCALE_OFFSET := 100;
ELSE
IF NOT fb_coe_write.bBusy THEN
fScalerOffset_COE := DINT_TO_LREAL(nValue);
nSTATE_SCALE_OFFSET := 0;
END_IF
END_IF
100:
// Copy Error ID for interpretation:
nADSErrId := fb_coe_write.nErrId;
END_CASE
END_IF
// ----- Justify gain: write calculated value in CoE - Object 0x8005 -----
IF bStartScaleGain THEN
CASE nSTATE_SCALE_GAIN OF
0:
bScaleGainDone := FALSE; // Initialization of confirmation flag
nSTATE_SCALE_GAIN := nSTATE_SCALE_GAIN + 1;
1:
// Get min/max Values by current Sample value:
fb_get_min_max(nInputValue:=PAI_Sample);
IF fb_get_min_max.bRESULT THEN // Wait if Limit-Values are valid
fb_coe_write(bExecute := FALSE); // Prepare CoE access
nSTATE_SCALE_GAIN := nSTATE_SCALE_GAIN + 1; // Min/Max Values valid - go to next state
END_IF
2:
// Get current amplitude for calculating the gain value:
nMaxAmplVal := MAX(ABS(fb_get_min_max.nMaxVal), ABS(fb_get_min_max.nMinVal));
// Avoid division by zero:
IF nMaxAmplVal = 0 THEN
nSTATE_SCALE_GAIN := 100;
ELSE
// Calculate Gain:
fValue := DINT_TO_REAL(nPRESET_MAX_VAL)/DINT_TO_REAL(nMaxAmplVal) * fScalerGain_COE;
// Shift gain value by 16 Bit left and convert to DINT:
nValue := REAL_TO_DINT(fValue * 65536);
// Write to CoE Index:
fb_coe_write(
sNetId:= userNetId,
nSlaveAddr:= userSlaveAddr,
nSubIndex:= bySubIndScalGain,
nIndex:= wCoEIndexScaler,
pSrcBuf:= ADR(nValue), // Gain-Value (CoE 0x8005:02)
cbBufLen:= SIZEOF(nValue),
bExecute:= TRUE,
tTimeout:= T#1S,
bBusy=> ,
bError=> ,
nErrId=> );
nSTATE_SCALE_GAIN := nSTATE_SCALE_GAIN + 1;
END_IF
3:
fb_coe_write();
IF fb_coe_write.bError THEN
nSTATE_SCALE_GAIN := 100;
ELSE
IF NOT fb_coe_write.bBusy THEN
fScalerGain_COE := fValue;
bStartScaleGain := FALSE; // gain scaling done
bScaleGainDone := TRUE;
nSTATE_SCALE_GAIN := 0; // Set initial state
END_IF
END_IF
100:
// Copy Error ID for interpretation:
nADSErrId := fb_coe_write.nErrId;
END_CASE
END_IF
Additional information
•
Function block FB_GET_MIN_MAX


Function block FB_GET_MIN_MAX

Appendix [image] Sample programs [image] Sample program 1 and 2 (offset/gain) [image] Function block FB_GET_MIN_MAX
Function block FB_GET_MIN_MAX
Declaration part:
FUNCTION_BLOCK FB_GET_MIN_MAX
VAR CONSTANT
// Counter initialization dependent by
// lowest input frequency 1/(2*f*cyclTime)
// used during offset adjust
CMMcnt :UINT := 200;
END_VAR
VAR_INPUT
bInit :BOOL := TRUE;
nInputValue :DINT;END_VAR
VAR_OUTPUT
bRESULT :BOOL;
nMaxVal :DINT :=0;
nMinVal :DINT :=0;
END_VAR
VAR
nMaxValCnt :UINT;
nMinValCnt :UINT;
bValidMinVal :BOOL;
bValidMaxVal :BOOL;
END_VAR
Execution part:
IF bInit THEN
nMaxValCnt :=CMMcnt;
nMinValCnt :=CMMcnt;
nMaxVal := 0;
nMinVal := 0;
bInit := FALSE;
END_IF
// Assertions: new min/max values exists:
bValidMaxVal := TRUE;
bValidMinVal := TRUE;
// Filter min/max values
IF nMaxVal < nInputValue THEN
bValidMaxVal := FALSE;
nMaxVal := nInputValue; // Max value was found
END_IF
IF nMinVal > nInputValue THEN
bValidMinVal := FALSE;
nMinVal := nInputValue; // Min value was found
END_IF
// Count down, if no new value come in:
IF bValidMaxVal AND nMaxValCnt > 0 THEN
nMaxValCnt := nMaxValCnt - 1;
END_IF
// Count down, if no new value come in:
IF bValidMinVal AND nMinValCnt > 0 THEN
nMinValCnt := nMinValCnt - 1;
END_IF
IF ((nMaxValCnt = 0) AND (nMinValCnt = 0)) THEN
// Consequence: min/max determined
bInit := TRUE; // Prepare next call
bRESULT := TRUE; // Sign valid results
ELSE
bRESULT := FALSE; // Sign still invalid results
END_IF


Sample program 3 (write lookup table)

Appendix [image] Sample programs [image] Sample program 3 (write lookup table)
Sample program 3 (write lookup table)
Download TwinCAT 3 project:
Program description
Transmission of LookUp table interpolation values for mapping of an equation f(x) = x3 via CoE into the terminal.
Variable declaration sample program 3
PROGRAM MAIN
VAR
//LookUp-Table (LUT) generated by: FSV * x³
aLUT:ARRAY[0..99] OF DINT :=
[
-7812500,-7812500,-7493593,-6894382,
-7174765,-6051169,-6855859,-5279674,-6536953,-4576709,
-6218125,-3939087,-5899218,-3363620,-5580390,-2847120,
-5261484,-2386402,-4942578,-1978275,-4623750,-1619555,
-4304843,-1307052,-3985937,-1037580,-3667109,-807951,
-3348203,-614978,-3029375,-455472,-2710468,-326248,
-2391562,-224117,-2072734,-145892,-1753828,-88385,
-1434921,-48409,-1116093,-22776,-797187,-8300,
-478281,-1792,-159453,-66,159453,66,
478281,1792,797187,8300,1116093,22776,
1434921,48409,1753828,88385,2072734,145892,
2391562,224117,2710468,326248,3029375,455472,
3348203,614978,3667109,807951,3985937,1037580,
4304843,1307052,4623750,1619555,4942578,1978275,
5261484,2386402,5580390,2847120,5899218,3363620,
6218125,3939087,6536953,4576709,6855859,5279674,
7174765,6051169,7493593,6894382,7812500,7812500
];
// For CoE 0x8000 and 0x8005 - write values:
// ===============================================
wCoEIndexScaler :WORD := 16#8005; // CoE Index
wState :BYTE := 0; // Write status
fb_coe_write :FB_EcCoESdoWrite; // Function Block for writing in CoE
userNetId :T_AmsNetId := '172.128.1.1.5.1'; // Have to be entered
userSlaveAddr :UINT := 1001 // Have to be entered
index :BYTE:=0; // LUT-Table index
startWrite :BOOL:=FALSE; // Sign for start writing
END_VAR
Remarks:
▪
The variable "startWrite" (BOOL) is also declared in sample program 4.
▪
The variable 'userNetId' must include the EtherCAT net ID of the device. It can be viewed in the "EtherCAT" tab under "Device (EtherCAT)".
▪
The variable "userSlaveAddr" must contain the EtherCAT address of the terminal.
Sample program for transferring the LookUp table:
Execution part:
// Example program 3:
// ###### Write LookUüp-Table in CoE Objekt 0x8005: #######
IF startWrite THEN
CASE wState OF
0:
fb_coe_write(bExecute := FALSE);// Prepare CoE-Access
wState := wState + 1;// Next state
1:
// Write 100 X/Y LookUp-Table entries
fb_coe_write(
sNetId:= userNetId,
nSlaveAddr:= userSlaveAddr,
nSubIndex:= index+1,
nIndex:= wCoEIndexScaler,
pSrcBuf:= ADR(aLUT[index]),
cbBufLen:= SIZEOF(aLUT[index]),
bExecute:= TRUE,
tTimeout:= T#1S
);
wState := wState + 1; // Next state
2:
// Proceed with writing to CoE
fb_coe_write();
IF fb_coe_write.bError THEN
wState := 100; // Error case
ELSE
IF NOT fb_coe_write.bBusy THEN
index := index + 1;
IF index < 100 THEN
// Prepare next CoE access
fb_coe_write(bExecute := FALSE);
wState := 1;// Write next value
ELSE
wState := 200;// Done
startWrite := FALSE;
END_IF
END_IF
END_IF
100:
; // Error handling..
200:
; // Continue...
END_CASE
END_IF
A simple variable query, e.g. via button linked with bEnable, can be used to initiate the transfer. The variable declaration must contain
VAR_INPUT
bEnable AT%I* :BOOL;
END_VAR
and the following program lines:
IF bEnable AND NOT startWrite THEN
startWrite := TRUE;
END_IF


Sample program 4 (generate LookUp table)

Appendix [image] Sample programs [image] Sample program 4 (generate LookUp table)
Sample program 4 (generate LookUp table)
Download TwinCAT 3 project:
Program description
Recording of LookUp table interpolation values of the input signal of the terminal into an array (and optional subsequent transmission of these LookUp table interpolation values via CoE access by example program 3).
Variable declaration sample program 4
// Variablendeklaration for example program 4
VAR_INPUT
bEnable AT%I* :BOOL;
PAI_Sample AT%I* :DINT; // The linked Variable to the EL3751 Result
END_VAR
VAR
//--------------Already existing? ---------------
// startWrite :BOOL:=FALSE;
//-------------------------------------------------
LUTindex :BYTE:=0; //LUT recording index
timer :tp; // A timer instance
startRecord :BOOL:=FALSE;
aValues :ARRAY[0..49] OF DINT;
nXstartValue :DINT;
nXstepValue :DINT;
CopyLUT :BOOL:=FALSE;
// Value of -2.21 mA by direct measurement:
nTriggerValue :DINT:=-2210000;
END_VAR
Execution part:
// Example program 4:
// ################# Recording of 50 sample points: #################
IF timer.Q THEN
timer();
ELSE
timer(IN:=FALSE);
timer(IN:=TRUE, PT:=T#200MS); // Timer-value 200ms for 0,1Hz ramp
IF startRecord THEN
IF LUTindex < 50 THEN
aValues[LUTindex] := PAI_Samples_1;
LUTindex := LUTindex + 1;
ELSE
nXstartValue := aValues[0];// Start value
nXstepValue := LREAL_TO_DINT(ABS(aValues[49]-nXstartValue) / 49); // Calculating step
startRecord := FALSE;// Stop recording
CopyLUT := TRUE;// Prepare incurring into LUT
END_IF
END_IF
END_IF
IF CopyLUT THEN
// Create LUT with X-Values by recording and equidistant Y-Values:
FOR index := 0 TO 49 DO
// Create LUT X => target values, Y => current values:
// (Initialwerte werden überschrieben)
LUTindex := REAL_TO_BYTE(index*2);
aLUT[LUTindex] := aValues[index];// X-Values
aLUT[LUTindex+1] := nXstartValue;// Y-Values
// Generate next equidistant sample point
nXstartValue := nXstartValue + nXstepValue;
END_FOR
index := 0; // Initialize LUT transmission
startWrite := TRUE;// Start transfer to LUT (see example program 3)
CopyLUT := FALSE;
END_IF
// Condition to start recording (a trigger minimum value):
IF ((PAI_Sample < nTriggerValue) AND (startWrite = FALSE)) THEN
startRecord := TRUE;
END_IF


Sample program 5 (write filter coefficients)

Appendix [image] Sample programs [image] Sample program 5 (write filter coefficients)
Sample program 5 (write filter coefficients)
Download TwinCAT 3 project:
Program description
Transmission of exemplary filter coefficients via CoE access into the terminal.
General settings
•
The function block "FB_EcCoESdoWrite" requires the "Tc2_EtherCAT" library
•
<AmsNetID> must show the local device EtherCAT NetID in inverted commas (e.g. '168.57.1.1.5.1')
•
<DeviceEtherCATAddress> must show the local device EtherCAT address of the EL3751 terminal (e.g. 1007)
Variable declaration sample program 5
PROGRAM MAIN
// Variable declaration example program 5
VAR CONSTANT
NumOfFilterCoeff :BYTE:=40;
END_VAR
VAR
// Function block of library "Tc2_EtherCAT" for CoE Object access:
fb_coe_write :FB_EcCoESdoWrite;
userNetId :T_AmsNetId := '???';
userSlaveAddr :UINT := ???;
// Writing PLC state for coefficients transfer (Set to 0 for start)
wState :BYTE:=255;
index :BYTE:=1; // Start index for coefficients transfer
wCoEIndexUserFilterCoeffizents :WORD:=16#8001;
aFilterCoeffs:ARRAY[0..NumOfFilterCoeff] OF LREAL :=
[
// Example filter coefficients FIR band pass: 3600..3900 Hz
// Usage: "User defined FIR Filter" (32)
0.03663651655662163,
0.04299467480848277,
-0.007880289104928245,
0.0664029021294729,
-0.0729038234874446,
-0.00005849791174519834,
0.05628409460964408,
-0.0525134329294473,
0.026329003448584205,
0.00027114381194760643,
-0.03677629552114248,
0.06743018479714939,
-0.0560894442193289,
0.0009722394088121363,
0.05676876756757213,
-0.07775650809213645,
0.05330627422911416,
0.0009941073749156226,
-0.055674804078696793,
0.07874009379691002,
-0.055674804078696793,
0.0009941073749156226,
0.05330627422911416,
-0.07775650809213645,
0.05676876756757213,
0.0009722394088121363,
-0.0560894442193289,
0.06743018479714939,
-0.03677629552114248,
0.00027114381194760643,
0.026329003448584205,
-0.0525134329294473,
0.05628409460964408,
-0.00005849791174519834,
-0.0729038234874446,
0.0664029021294729,
-0.007880289104928245,
0.04299467480848277,
0.03663651655662163,
0
];
nValue :DINT; // Temporary variable
END_VAR
Execution part:
// Example program 5:
// writes filter coefficients of
// "User defined FIR Filter" (32)
// incl. example coefficients for band pass
// Note: writing possible, if CoE Object
// PAI Settings Ch.1 (0x8000:16) has value 32 or 33 set, only!
// (32 = User defined FIR Filter / 33 = User defined IIR Filter)
// ===============================================================
CASE wState OF
0:
fb_coe_write(bExecute := FALSE);// Prepare CoE access
wState := wState + 1;// Go to next state
1:
//nValue := REAL_TO_DINT(DINT_TO_REAL(aFilterCoeffs[index]) *16384);
nValue := LREAL_TO_DINT(aFilterCoeffs[index] * 1073741824); // Bit-shift factor: 2^30
// Write filter coefficients (max. 40 entries)
fb_coe_write(
sNetId:= userNetId,
nSlaveAddr:= userSlaveAddr,
nSubIndex:= index,
nIndex:= wCoEIndexUserFilterCoeffizents,
pSrcBuf:= ADR(nValue),
cbBufLen:= SIZEOF(nValue),
bExecute:= TRUE,
tTimeout:= T#1S
);
wState := wState + 1; // Go to next state
2:
// Execute writing to CoE
fb_coe_write();
IF fb_coe_write.bError THEN
wState := 100; // Error case
ELSE
IF NOT fb_coe_write.bBusy THEN
index := index + 1;
IF index <= (NumOfFilterCoeff) THEN
fb_coe_write(bExecute := FALSE);// Prepare the next CoE access
wState := 1;// Write next value
ELSE
wState := 255;// Done
END_IF
END_IF
END_IF
100:
; // Error handling
255:
; // Go on..
END_CASE


Sample program 6 (interlacing of measured values)

Appendix [image] Sample programs [image] Sample program 6 (interlacing of measured values)
Sample program 6 (interlacing of measured values)
Program description / function
This sample shows how to use two multi-function input terminals with interconnected inputs, whose measured input values are alternately read by the PLC to achieve a doubling of the maximum sampling rate of a terminal. The following configuration is used for this purpose:
Configuration and setup for sample program 6: Doubling of the sample rate with 2 x EL3751
The example is also applicable for the ELM3xxx terminals with respective adaptions (e.g. 2 x ELM3002). Just the optional present task of 50 µs within example 6a may not be operational.
In order to be able to assemble the input values sequentially to form a total value, a corresponding shift time is necessary for each separate sampled value; in this sample the value for the second terminal is 50 µs. This is set under "Advanced settings" of the terminal under DistributedClocks ("DC" tab):
Setting the DC shift time for terminal 2
This setting, like the base time and the task cycle time, is already configured in the sample program:
Download TwinCAT 3 project / sample program 6a:
Further explanations
The measured values that were readin are usually available to the PLC as a field variable or in a data format suitable for oversampling (total measured value):
Process of interlacing the input data
In the following section, the simplest form of input value interlacing in Structured Text is initially shown with oversampling = 1 for each input value: each of two elements of a field variable receives a value from a terminal. The variable can be used for further processing and is shown here in the TwinCAT ScopeView. In the EL3751 the programming instructions are assigned to a 100 µs task:
Variable declaration sample program 6a
PROGRAM MAIN
VAR
nSamples_1 AT%I* :DINT; // EL3751 input with no added shift time
nSamples_2 AT%I* :DINT; // EL3751 input with -50 µs added shift time
aCollectedResult :ARRAY[0..1] OF DINT;
END_VAR
Execution part:
// Example program 6a:
// 100 µs task
// ============================================================
aCollectedResult[0] := nSamples_1; // Put 1st Value of sequence into array
// Pattern: 1.1.1.1...
aCollectedResult[1] := nSamples_2; // Put n-th Value of sequence into array (2nd here)
// Pattern: .2.2.2.2...
// ============================================================
// Result pattern: 12121212... (--> see scope view dots)
For a signal with sine 5 kHz and 2.5 V amplitude, for example, the TwinCAT ScopeView provides the following results:
Oversampling 20 ksps with 2 x EL3751 with input signals (below) and result signal (top)
The upper diagram shows the total signal and the two input signals (nSample_1, nSample_2), with a time shift of 50 µs relative to each other, within 18 s in compressed form. The total input signal (nCollectedResult) indicates the interlacing of the two input signals.
The following diagram (enhanced through highlighting) shows how the input signals (nSample_1, nSample_2) contribute to the structure of the total input signal:
Oversampling 20 ksps with 2 x EL3751 shows input value 1 and input value 2 alternately for a result value
Under certain conditions, both inputs can be combined into a single variable in a correspondingly fast task. For this purpose the sample program contains an additional task with 50 µs cycle time, which is required for representing the input signals in the SopeView and contains a variable (nCollected) to which both inputs are assigned alternately:
// 50 µs task
// ============================================================
// Junction of the two inputs
nCollected := SEL(nToggle, MAIN.nSamples_1_, MAIN.nSamples_2_);
nToggle := NOT nToggle;
The input variables required for the ScopeView are read in this task from the 100 µs task, so that the individual values can be represented at 50 µs intervals.
Variant with 2 x oversampling 10 = oversampling 20
If, for example, an oversampling factor of 10 is used for both input terminals, a field variable is used for the total measured value. A simple loop can be used for interlacing the input values, which reads the values sequentially into a field variable for the resulting result variable:
Variable declaration sample program 6b
PROGRAM MAIN
VAR
aSamples_1 AT%I* :ARRAY[0..9] OF DINT; // EL3751 input with no added shift time
aSamples_2 AT%I* :ARRAY[0..9] OF DINT; // EL3751 input with -50 µs added shift time
aCollectedResult :ARRAY[0..19] OF DINT;
// ===================================================
nPos :BYTE;
END_VAR
Execution part:
// Example program 6b:
// 1 ms task
// ============================================================
FOR nPos := 0 TO 9 DO
// Put 1st Value of sequence into array:
aCollectedResult[2*nPos] := aSamples_1[nPos];
// Put n-th value of sequence into array (2nd here):
aCollectedResult[2*nPos+1] := aSamples_2[nPos];
END_FOR
Download TwinCAT 3 project / sample program 6b:
Sample program 6b returns the same result, except that the total input signal is only available in the form of a field variable with 20 elements.
Input attenuation of a terminal
Due to the continuing input filtering of a terminal (anti‑aliasing filter), the desired result is not expected for an input signal containing frequency components in the region of 10 kHz, since the input values of a terminal are strongly attenuated in this frequency range.
Interlacing of the input values: note offset differences of the terminals
Before a possible application, the terminals should be subjected to an offset adjustment, so that the result contains as little distortion of the input signal as possible.


Sample program 7 (general decimation in the PLC)

Appendix [image] Sample programs [image] Sample program 7 (general decimation in the PLC)
Sample program 7 (general decimation in the PLC)
The EL3751 or ELM3xxx can only decimate their basic sampling rate fmax by integer multiples, see chapter "Decimation". To realize any other sampling rates (ftarget < fmax) for a channel, you can proceed as follows, for example:
▪
Operate the terminal/channel at the maximum sampling rate and transfer the data to the controller (PLC) via EtherCAT/oversampling
▪
In the PLC/C++, on the time axis, convert to the desired sampling rate, e.g. by linear interpolation based on the timestamp for each input value (sample). Since the EL3751/ELM3xxx units provide time-equidistant samples based on distributed clocks, this is easily possible.
For example, a sinusoidal signal decimated with 50/44.1 = 1/0.882 can be represented as follows:
–
Green: corresponds to original analog signal (input), approx. 432 Hz
–
Blue (O): corresponds to sampling of the EL3751/ELM3xxx with fmax of 10,000 sps; a sampling interval of 100 µs
–
Red (X): corresponds to signal converted by PLC to 8820 sps (factor 0.882) and thus a time interval of approx. 113.37.. µs
▪
Note: The term "decimation" is applied both to the calculation in the terminal (see chapter "Decimation") and to the conversion in the PLC program. The following refers to the conversion in the PLC.
▪
Since the time interval of the desired sampling after decimation in the PLC is usually no longer an integer (finite) number, value/time pairs are used for representation in the PLC/Scope, i.e. an X time value is assigned to each Y value. Such value/time pairs can easily be displayed with TwinCAT ScopeView in XY mode. See also infosys.beckhoff.com:
TwinCAT3 → TExxxx | TC3 Engineering → TE13xx | TC3 ScopeView → Configuration → XY‑Graph
▪
The conversion also has consequences for further processing in PLC/C/ADS:
–
A PLC/EtherCAT/TwinCAT system tends to be set up such that a constant number of samples is processed per cycle. Usually this is now no longer the case: a different number of samples has to be processed from cycle to cycle (specified by the program variable nResultNoOfSamples).
–
While a time stamp per signal value has so far remained relatively insignificant, the method of conversion of the decimation process used here, however, means that the respective timestamp per signal value must be taken into account in an elementary manner.
▪
The non-constant number of samples is not visible in the TwinCAT XY Scope because some values are sporadically drawn twice, and this should be taken into account; it may be advisable to use an intermediate buffer for further processing.
▪
For orientation of the currently valid number of samples per task cycle, the program provides the variable nResultNoOfSamples. It indicates which values in the array variable contain valid values in a task cycle (indicates the field number - 1).
The following sample program, which also contains the XY representation in the TwinCAT Scope, serves as a guide. Due to the above-mentioned problem relating to the non-constant number of valid samples, the program returns the array pair aVarDecResult_TS and aVarDecResult for the Scope with the same number of elements as for the input value aSamples_1 (value = nOVS). If there are fewer values in a task run, the last value is simply entered repeatedly (similar to "sample & hold"). The ScopeView was configured as follows for the recording:
Property |  | Value
ScopeNodeProperties | ViewDetauilLevel | ExtendedXYOnly
 | Record time | 00:00:00:05
ChartXYNodeProperties | Default Display Width | 0,00:00:00,050:000
 | Max Data Points | 200000
XYChannelNodeProperties | Marks | On
 | Mark Size | 5
 | Mark Color | (other than line color)
For an illustrative representation, the ScopeView recording was started first and then the program, which limits the decimated values to one second:
IF nOVS_CycleCount = 1000000000 THEN
;
bEnable := FALSE;// Stop after 1s just for recording
ELSE
...
This line can, of course, be commented out for further adjustments:
//bEnable := FALSE;// Stop after 1s just for recording
Notes:
▪
the target sampling rate ftarget should be close to the sample rate fmax, so that it is possible to evaluate a time interval between two decimated values. The desired decimation may require further parameters such as task cycle time, oversampling factor etc. to be adjusted both in the configuration and as variable initialization in the sample program (see figure "Process of variable decimation of the sample program", which illustrates the functionality of the program code).
▪
Basically, the conversion process in this sample program causes distortions in the result in relation to the original signal shape when decimating with fractional rational factors (see signal curve). In concrete terms, deviations from the original signal curve only occur in those sections where the time derivative value (the slope) is not constant. For example, input values of a sine signal in the non-linear sections are distorted by the interpolation performed in the program:
In the frequency spectrum, for example by a calculation with 20 Hz sinus signal, sampled with 500 sps and decimated to 441 sps, this is illustrated as follows:
▪
If no low-pass filtering corresponding to ftarget is performed on the data stream, aliasing effects will occur! It is therefore advisable to perform low-pass filtering in the PLC, e.g. with the TC3 Controller Toolbox or the TC3 Filter Library, before the conversion/decimation is performed. Suitable filters can easily be created with the TE1310 FilterDesigner. For more information, see www.beckhoff.com:
Automation → TwinCAT 3 → TE1xxx | TC3 Engineering → TE1310 | TC3 Filter Designer
Alternatively, the filters available in the EL3751/ELM3xxx can, of course, be set to the suitable low-pass frequency; the TwinCAT Filter Designer is also helpful for this.
▪
Entries of decimation factors within the program (nDecimationValue) should have a value > 1. The program code supports down sampling only.
E.g.: If a terminal such as ELM3602-0002 (2-channel IEPE evaluation) provides a data stream with oversampling of 50 ksps at 100 µs cycle time, this sample code can decimate to 44.1 ksps. In the sample program, the cycle ticks in the task configuration should be changed from 5 to 1 and the corresponding program variable nTaskCycle_ns from 500000 to 100000. See the following image section of ScopeView XY:
Decimation from 20 µs (left) to 22.675.. µs (right) with ELM3602
The decimation factor is given by entering the value "50/44.1" for nDecimationValue in the sample. If this sample is used for the EL3751 with 500 µs cycle time and 5x oversampling, the sampling interval of 100 µs, which originates from the EL3751, is converted to approx. 113.378.. µs. This sample is designed accordingly.
The decimation in the program is freely selectable and must be configured with an oversampling factor and a task cycle time. The variable nOVS must contain the same oversampling factor as set in the process data configuration.
Download sample program 7:
▪
Configuration: IPC + EK1100 + EL3751 + EL9011:
▪
Configuration: IPC + EK1100 + ELM3602‑0002 + EL9011:
General information
The time at which the EtherCAT frames are passed to the terminal is subject to fluctuations, referred to as EtherCAT frame jitter. If these fluctuations are large in relation to the cycle time, it is possible that data is fetched late from the terminal, and dropouts/duplications may occur in the scope display. Such effects can be diagnosed with TwinCAT EtherCAT diagnostics. In the sample program for the ELM3602, the variable nEqualTimeStampsCnt is available for this kind of verification. The variable is incremented if such a failure occurs. It can be remedied by changing the DC ShiftTime of the terminal; see the EtherCAT system documentation.
Declaration
// THIS CODE IS ONLY AN EXAMPLE - YOU HAVE TO CHECK APTITUDE FOR YOUR APPLICATION
PROGRAM MAIN
VAR CONSTANT
// User decimation factor e.g. 50 to 44.1 kSps:
nDecimationValue :LREAL := 50/44.1; // 50/20;
nOVS :BYTE := 5; // Oversampling factor
nTaskCycle_ns :UDINT := 500000; // PlcTask configured cycle time in ns
nOVSTimeInterval_ns :UDINT := LREAL_TO_UDINT(nTaskCycle_ns/nOVS); // OVS interval
nDecTimeInterval_ns :LREAL := nDecimationValue * nOVSTimeInterval_ns; // Decimation interval
END_VAR
VAR
aSamples_1 AT%I* :ARRAY[0..nOVS-1] OF DINT; // Link to the terminal PDO
aOVS_SampleSets :ARRAY[0..(2*nOVS)-1] OF DINT; // 2 OVS sample sets
nVarDecResult :DINT; // The calculated interpolated value
tVarDecResult :LREAL; // Decimation timestamp
aVarDecResult :ARRAY[0..nOVS-1] OF DINT; // Decimation result values
aVarDecResult_TS :ARRAY[0..nOVS-1] OF LREAL; // Decimation result timestamps
nResultNoOfSamples :BYTE; // This is for the user for further processing
nDivVar :INT; // Value for selection of the target input element
tDecVar_InTaskCycle :LREAL:=0; // Time span for all decimation timestamps within a task cycle
i :BYTE:=0; // Common loop counter
nDX :LREAL; // X-Difference: target input element to decimation element
nDY :DINT; // Y-Difference: two values for interpolation
sVal :LREAL; // Slope for calculation of new value
bEnable :BOOL:=FALSE; // Start/Stop conversion to decimation values
nOVS_CycleCount :ULINT := 0; // Time value for every OVS sample
// Values for testing
bTEST_VALUES_ENABLED :BOOL := FALSE; // No input value needed, if TRUE
nPhi :LREAL := 1.4; // Start angle for sinus simulation
// For visualization only:
aOVS_Samples :ARRAY[0..nOVS-1] OF DINT; // 2 OVS sample sets (value)
aOVS_Samples_TS :ARRAY[0..nOVS-1] OF ULINT; // 2 OVS sample sets (timestamp)
END_VAR
Program
// 500 µs Task
FOR i:= 0 TO nOVS-1 DO
// Shift OVS set to left and update on right:
aOVS_SampleSets[i] := aOVS_SampleSets[i+nOVS]; // Transfer "samples set" to the left side
IF bTEST_VALUES_ENABLED THEN
// Simulate values:
aOVS_SampleSets[i+nOVS] := LREAL_TO_DINT(1000000 * SIN(nPhi));
nPhi := nPhi + 0.01;//0.003141592653;
ELSE
// Fill current new samples set on right:
aOVS_SampleSets[i+nOVS] := aSamples_1[i];
END_IF
END_FOR
IF bEnable THEN
nResultNoOfSamples := 0; // Use for further processing
FOR i := 0 TO nOVS-1 DO
nDivVar := TRUNC_INT(tDecVar_InTaskCycle/nOVSTimeInterval_ns);
// Check, if new value is in grid
IF (nDivVar = i) THEN
nResultNoOfSamples := nResultNoOfSamples + 1;
// Calc slope by the left and right element values (dy/dx):
nDY := aOVS_SampleSets[i+1] - aOVS_SampleSets[i];
sVal := DINT_TO_LREAL(nDY)/nOVSTimeInterval_ns;
// Get the time (difference) from the left side element start to the desired time point:
nDX := tDecVar_InTaskCycle
- TRUNC_INT(tDecVar_InTaskCycle/nOVSTimeInterval_ns)
* UDINT_TO_LREAL(nOVSTimeInterval_ns);
// Calc timestamp
tVarDecResult := nDX + ULINT_TO_LREAL(nOVS_CycleCount);
// Calc new value:
nVarDecResult :=
LREAL_TO_DINT(DINT_TO_LREAL(aOVS_SampleSets[i]) + sVal * nDX);
// next decimation time step
tDecVar_InTaskCycle := tDecVar_InTaskCycle + nDecTimeInterval_ns;
tDecVar_InTaskCycle := tDecVar_InTaskCycle
- INT_TO_UDINT(TRUNC_INT(tDecVar_InTaskCycle/nTaskCycle_ns))
* nTaskCycle_ns;
END_IF
// Fill timestamp and new value allocated to the field element of its timestamp
aVarDecResult_TS[i] := tVarDecResult;
aVarDecResult[i] := nVarDecResult;
// For visualization of the original input:
aOVS_Samples[i] := aOVS_SampleSets[i];
aOVS_Samples_TS[i] := nOVS_CycleCount;
// Count the task cycle timestamp
nOVS_CycleCount := nOVS_CycleCount + nOVSTimeInterval_ns;
END_FOR
END_IF
IF nOVS_CycleCount = 1000000000 THEN
bEnable := FALSE;// Stop after 1s just for recording
IF NOT bEnable THEN
bEnable := TRUE; // OVS‑Samples transferred complete into both array sets
END_IF
END_IF


Sample program 8 (FB for real time diagnosis)

Appendix [image] Sample programs [image] Sample program 8 (FB for real time diagnosis)
Sample program 8 (FB for real time diagnosis)
The following function block can be used as a template for a real time diagnosis application of an analog input terminal in TwinCAT PLC. It has to be placed between the terminal and the application and evaluates the diagnostic variables coming from the terminal. The measurement values will be unchanged passed through.
The function block is written for the ELM3602-0002 with oversampling=5 and should be understood as a functional example and must be adapted if necessary to
▪
other terminals, if necessary other value data types
▪
other oversampling values
It can be extended with data-processing code or further particular diagnostics or assigned to a completely different terminal type (analog output EL4xxx, Encoder EL5xxx, ...).
The function block between the terminal and the PLC can be schematically illustrated as follows:
Function block as an example for analysis of diagnostics information of the terminal
This function block would have to be linked to all variables of the terminal: inputs, outputs and info data. This time-consuming process can be simplified and accelerated by structuring in TwinCAT 3. Therefore, in this chapter two alternative variants in TwinCAT 3.1 are presented, as with a few clicks a structure can be defined in the PLC which corresponds to the process image of the terminal.
The respective variant of the function block FB_REALTIME_DIAGNOSIS is included in the two example programs. It contains variables with an application-specific data type. This is a structure created by TwinCAT 3. Because the structure generated by TwinCAT directly maps the PDO structure of the terminal, it is not necessary that a suitable structure must be elaborately created or individual variables must be linked to individual data types. Only a link at a higher level (Status, Samples, Control, ...) is required.
This and all configurations are already included in the respective tool.
▪
Example program (variant A – using the Plc tab of the terminals configuartion):
▪
Example program (variant B – using the advanced settings of the terminal):
Notes to example program (variant A):
the variables declaration within this function block contains:
stELM3602Special : MDP5001_350_EB559ACD;
Read access is provided to the inputs of the terminal via the substructure MDP5001_350_Input and write access to the outputs via the substructure MDP5001_350_Output of the structure stELM3602Special.
In general, the generation of this special PDO data type is activated via the PLC settings of the terminal (tab “Plc"): there the check box "Create PLC Data Type" and then "Per Channel” was set ("Copy" then transfers this character string to the clipboard):
Creation of PDO variables (TwinCAT version >= V3.1.4024.0)
The address assignments for inputs (%ATI*) and outputs (%ATQ*) are already within this generated structure. Inputs and outputs are therefore summarized in this structure.
Notes to example program (variant B):
the variables declaration within this function block contains:
st_SM2 AT%Q* : ECAT_ELM3602_0002_SM_3412CB6A;
st_SM3 AT%I* : ECAT_ELM3602_0002_SM_87A01A51;
The read access to the inputs of the application is provided via the structure st_SM3 and write access to the outputs via the structure st_SM2. These data structures corresponds to the automatically added new PDO element "SmPdoVariables".
Commonly, the generation of this specific PDO data type incl. the PDO element will be activated via the EtherCAT settings of the terminal: within the advanced settings under “General”/ "Behavior" the checkbox "Create SM/PDO Variables“ in “Process Data” is to set:
Create SM_PDO vars_en.png
Creation of the SmPdoVariables (TwinCAT version >= V3.1.4022.30)
The data type is visible by selecting the object and can be copied to the clipboard there:
Seek the generated data type of SmPdoVariables


Diagnostics – basic principles of diag messages

Appendix [image] Diagnostics – basic principles of diag messages
Diagnostics – basic principles of diag messages
DiagMessages designates a system for the transmission of messages from the EtherCAT Slave to the EtherCAT Master/TwinCAT. The messages are stored by the device in its own CoE under 0x10F3 and can be read by the application or the System Manager. An error message referenced via a code is output for each event stored in the device (warning, error, status change).
Definition
The DiagMessages system is defined in the ETG (EtherCAT Technology Group) in the guideline ETG.1020, chapter 13 “Diagnosis handling”. It is used so that pre-defined or flexible diagnostic messages can be conveyed from the EtherCAT Slave to the Master. In accordance with the ETG, the process can therefore be implemented supplier-independently. Support is optional. The firmware can store up to 250 DiagMessages in its own CoE.
Each DiagMessage consists of
▪
Diag Code (4-byte)
▪
Flags (2-byte; info, warning or error)
▪
Text ID (2-byte; reference to explanatory text from the ESI/XML)
▪
Timestamp (8-byte, local slave time or 64-bit Distributed Clock time, if available)
▪
Dynamic parameters added by the firmware
The DiagMessages are explained in text form in the ESI/XML file belonging to the EtherCAT device: on the basis of the Text ID contained in the DiagMessage, the corresponding plain text message can be found in the languages contained in the ESI/XML. In the case of Beckhoff products these are usually German and English.
Via the entry NewMessagesAvailable the user receives information that new messages are available.
DiagMessages can be confirmed in the device: the last/latest unconfirmed message can be confirmed by the user.
In the CoE both the control entries and the history itself can be found in the CoE object 0x10F3:
DiagMessages in the CoE
The subindex of the latest DiagMessage can be read under x10F3:02.
Support for commissioning
The DiagMessages system is to be used above all during the commissioning of the plant. The diagnostic values e.g. in the StatusWord of the device (if available) are helpful for online diagnosis during the subsequent continuous operation.
TwinCAT System Manager implementation
From TwinCAT 2.11 DiagMessages, if available, are displayed in the device’s own interface. Operation (collection, confirmation) also takes place via this interface.
Implementation of the DiagMessage system in the TwinCAT System Manager
The operating buttons (B) and the history read out (C) can be seen on the Diag History tab (A). The components of the message:
▪
Info/Warning/Error
▪
Acknowledge flag (N = unconfirmed, Q = confirmed)
▪
Time stamp
▪
Text ID
▪
Plain text message according to ESI/XML data
The meanings of the buttons are self-explanatory.
DiagMessages within the ADS Logger/Eventlogger
Since TwinCAT 3.1 build 4022 DiagMessages send by the terminal are shown by the TwinCAT ADS Logger. Given that DiagMessages are represented IO- comprehensive at one place, commissioning will be simplified. In addition, the logger output could be stored into a data file – hence DiagMessages are available long-term for analysis.
Reading messages into the PLC
- In preparation -
Interpretation
Time stamp
The time stamp is obtained from the local clock of the terminal at the time of the event. The time is usually the distributed clock time (DC) from register x910.
Please note: When EtherCAT is started, the DC time in the reference clock is set to the same time as the local IPC/TwinCAT time. From this moment the DC time may differ from the IPC time, since the IPC time is not adjusted. Significant time differences may develop after several weeks of operation without a EtherCAT restart. As a remedy, external synchronization of the DC time can be used, or a manual correction calculation can be applied, as required: The current DC time can be determined via the EtherCAT master or from register x901 of the DC slave.
Structure of the Text ID
The structure of the MessageID is not subject to any standardization and can be supplier-specifically defined. In the case of Beckhoff EtherCAT devices (EL, EP) it usually reads according to xyzz:
x | y | zz
0: Systeminfo 2: reserved 1: Info 4: Warning 8: Error | 0: System 1: General 2: Communication 3: Encoder 4: Drive 5: Inputs 6: I/O general 7: reserved | Error number
Example: Message 0x4413 --> Drive Warning Number 0x13
Overview of text IDs
Specific text IDs are listed in the device documentation.
Text ID | Type | Place | Text Message | Additional comment
0x0001 | Information | System | No error | No error
0x0002 | Information | System | Communication established | Connection established
0x0003 | Information | System | Initialization: 0x%X, 0x%X, 0x%X | General information; parameters depend on event. See device documentation for interpretation.
0x1000 | Information | System | Information: 0x%X, 0x%X, 0x%X | General information; parameters depend on event. See device documentation for interpretation.
0x1012 | Information | System | EtherCAT state change Init - PreOp |
0x1021 | Information | System | EtherCAT state change PreOp - Init |
0x1024 | Information | System | EtherCAT state change PreOp - Safe-Op |
0x1042 | Information | System | EtherCAT state change SafeOp - PreOp |
0x1048 | Information | System | EtherCAT state change SafeOp - Op |
0x1084 | Information | System | EtherCAT state change Op - SafeOp |
0x1100 | Information | General | Detection of operation mode completed: 0x%X, %d | Detection of the mode of operation ended
0x1135 | Information | General | Cycle time o.k.: %d | Cycle time OK
0x1157 | Information | General | Data manually saved (Idx: 0x%X, SubIdx: 0x%X) | Data saved manually
0x1158 | Information | General | Data automatically saved (Idx: 0x%X, SubIdx: 0x%X) | Data saved automatically
0x1159 | Information | General | Data deleted (Idx: 0x%X, SubIdx: 0x%X) | Data deleted
0x117F | Information | General | Information: 0x%X, 0x%X, 0x%X | Information
0x1201 | Information | Communication | Communication re-established | Communication to the field side restored This message appears, for example, if the voltage was removed from the power contacts and re-applied during operation
0x1300 | Information | Encoder | Position set: %d, %d | Position set - StartInputhandler
0x1303 | Information | Encoder | Encoder Supply ok | Encoder power supply unit OK
0x1304 | Information | Encoder | Encoder initialization successfully, channel: %X | Encoder initialization successfully completed
0x1305 | Information | Encoder | Sent command encoder reset, channel: %X | Send encoder reset command
0x1400 | Information | Drive | Drive is calibrated: %d, %d | Drive is calibrated
0x1401 | Information | Drive | Actual drive state: 0x%X, %d | Current drive status
0x1705 | Information |  | CPU usage returns in normal range (< 85%%) | Processor load is back in the normal range
0x1706 | Information |  | Channel is not in saturation anymore | Channel is no longer in saturation
0x1707 | Information |  | Channel is not in overload anymore | Channel is no longer overloaded
0x170A | Information |  | No channel range error anymore | A measuring range error is no longer active
0x170C | Information |  | Calibration data saved | Calibration data were saved
0x170D | Information |  | Calibration data will be applied and saved after sending the command “0x5AFE” | Calibration data are not applied and saved until the command "0x5AFE" is sent
Text ID | Type | Place | Text Message | Additional comment
0x2000 | Information | System | %s: %s |
0x2001 | Information | System | %s: Network link lost | Network connection lost
0x2002 | Information | System | %s: Network link detected | Network connection found
0x2003 | Information | System | %s: no valid IP Configuration - Dhcp client started | Invalid IP configuration
0x2004 | Information | System | %s: valid IP Configuration (IP: %d.%d.%d.%d) assigned by Dhcp server %d.%d.%d.%d | Valid IP configuration, assigned by the DHCP server
0x2005 | Information | System | %s: Dhcp client timed out | DHCP client timeout
0x2006 | Information | System | %s: Duplicate IP Address detected (%d.%d.%d.%d) | Duplicate IP address found
0x2007 | Information | System | %s: UDP handler initialized | UDP handler initialized
0x2008 | Information | System | %s: TCP handler initialized | TCP handler initialized
0x2009 | Information | System | %s: No more free TCP sockets available | No free TCP sockets available.
Text ID | Type | Place | Text Message | Additional comment
0x4000 | Warning |  | Warning: 0x%X, 0x%X, 0x%X | General warning; parameters depend on event. See device documentation for interpretation.
0x4001 | Warning | System | Warning: 0x%X, 0x%X, 0x%X |
0x4002 | Warning | System | %s: %s Connection Open (IN:%d OUT:%d API:%dms) from %d.%d.%d.%d successful |
0x4003 | Warning | System | %s: %s Connection Close (IN:%d OUT:%d) from %d.%d.%d.%d successful |
0x4004 | Warning | System | %s: %s Connection (IN:%d OUT:%d) with %d.%d.%d.%d timed out |
0x4005 | Warning | System | %s: %s Connection Open (IN:%d OUT:%d) from %d.%d.%d.%d denied (Error: %u) |
0x4006 | Warning | System | %s: %s Connection Open (IN:%d OUT:%d) from %d.%d.%d.%d denied (Input Data Size expected: %d Byte(s) received: %d Byte(s)) |
0x4007 | Warning | System | %s: %s Connection Open (IN:%d OUT:%d) from %d.%d.%d.%d denied (Output Data Size expected: %d Byte(s) received: %d Byte(s)) |
0x4008 | Warning | System | %s: %s Connection Open (IN:%d OUT:%d) from %d.%d.%d.%d denied (RPI:%dms not supported -> API:%dms) |
0x4101 | Warning | General | Terminal-Overtemperature | Overtemperature. The internal temperature of the terminal exceeds the parameterized warning threshold
0x4102 | Warning | General | Discrepancy in the PDO-Configuration | The selected PDOs do not match the set operating mode. Sample: Drive operates in velocity mode, but the velocity PDO is but not mapped in the PDOs.
0x417F | Warning | General | Warning: 0x%X, 0x%X, 0x%X |
0x428D | Warning | General | Challenge is not Random |
0x4300 | Warning | Encoder | Subincrements deactivated: %d, %d | Sub-increments deactivated (despite activated configuration)
0x4301 | Warning | Encoder | Encoder-Warning | General encoder error
0x4400 | Warning | Drive | Drive is not calibrated: %d, %d | Drive is not calibrated
0x4401 | Warning | Drive | Starttype not supported: 0x%X, %d | Start type is not supported
0x4402 | Warning | Drive | Command rejected: %d, %d | Command rejected
0x4405 | Warning | Drive | Invalid modulo subtype: %d, %d | Modulo sub-type invalid
0x4410 | Warning | Drive | Target overrun: %d, %d | Target position exceeded
0x4411 | Warning | Drive | DC-Link undervoltage (Warning) | The DC link voltage of the terminal is lower than the parameterized minimum voltage. Activation of the output stage is prevented
0x4412 | Warning | Drive | DC-Link overvoltage (Warning) | The DC link voltage of the terminal is higher than the parameterized maximum voltage. Activation of the output stage is prevented
0x4413 | Warning | Drive | I2T-Model Amplifier overload (Warning) | - The amplifier is being operated outside the specification - The I2T-model of the amplifier is incorrectly parameterized
0x4414 | Warning | Drive | I2T-Model Motor overload (Warning) | - The motor is being operated outside the parameterized rated values - The I2T-model of the motor is incorrectly parameterized
0x4415 | Warning | Drive | Speed limitation active | The maximum speed is limited by the parameterized objects (e.g. velocity limitation, motor speed limitation). This warning is output if the set velocity is higher than one of the parameterized limits
0x4416 | Warning | Drive | Step lost detected at position: 0x%X%X | Step loss detected
0x4417 | Warning | Drive | Motor overtemperature | The internal temperature of the motor exceeds the parameterized warning threshold
0x4418 | Warning | Drive | Limit: Current | Limit: current is limited
0x4419 | Warning | Drive | Limit: Amplifier I2T-model exceeds 100%% | The threshold values for the maximum current were exceeded.
0x441A | Warning | Drive | Limit: Motor I2T-model exceeds 100%% | Limit: Motor I2T-model exceeds 100%
0x441B | Warning | Drive | Limit: Velocity limitation | The threshold values for the maximum speed were exceeded.
0x441C | Warning | Drive | STO while the axis was enabled | An attempt was made to activate the axis, despite the fact that no voltage is present at the STO input.
0x4600 | Warning | General IO | Wrong supply voltage range | Supply voltage not in the correct range
0x4610 | Warning | General IO | Wrong output voltage range | Output voltage not in the correct range
0x4705 | Warning |  | Processor usage at %d %% | Processor load at %d %%
0x470A | Warning |  | EtherCAT Frame missed (change Settings or DC Operation Mode or Sync0 Shift Time) | EtherCAT frame missed (change DC Operation Mode or Sync0 Shift Time under Settings)
Text ID | Type | Place | Text Message | Additional comment
0x8000 | Error | System | %s: %s |
0x8001 | Error | System | Error: 0x%X, 0x%X, 0x%X | General error; parameters depend on event. See device documentation for interpretation.
0x8002 | Error | System | Communication aborted | Communication aborted
0x8003 | Error | System | Configuration error: 0x%X, 0x%X, 0x%X | General; parameters depend on event. See device documentation for interpretation.
0x8004 | Error | System | %s: Unsuccessful FwdOpen-Response received from %d.%d.%d.%d (%s) (Error: %u) |
0x8005 | Error | System | %s: FwdClose-Request sent to %d.%d.%d.%d (%s) |
0x8006 | Error | System | %s: Unsuccessful FwdClose-Response received from %d.%d.%d.%d (%s) (Error: %u) |
0x8007 | Error | System | %s: Connection with %d.%d.%d.%d (%s) closed |
0x8100 | Error | General | Status word set: 0x%X, %d | Error bit set in the status word
0x8101 | Error | General | Operation mode incompatible to PDO interface: 0x%X, %d | Mode of operation incompatible with the PDO interface
0x8102 | Error | General | Invalid combination of Inputs and Outputs PDOs | Invalid combination of input and output PDOs
0x8103 | Error | General | No variable linkage | No variables linked
0x8104 | Error | General | Terminal-Overtemperature | The internal temperature of the terminal exceeds the parameterized error threshold. Activation of the terminal is prevented
0x8105 | Error | General | PD-Watchdog | Communication between the fieldbus and the output stage is secured by a Watchdog. The axis is stopped automatically if the fieldbus communication is interrupted. - The EtherCAT connection was interrupted during operation - The Master was switched to Config mode during operation
0x8135 | Error | General | Cycle time has to be a multiple of 125 µs | The IO or NC cycle time divided by 125 µs does not produce a whole number
0x8136 | Error | General | Configuration error: invalid sampling rate | Configuration error: Invalid sampling rate
0x8137 | Error | General | Electronic type plate: CRC error | Content of the external name plate memory invalid.
0x8140 | Error | General | Sync Error | Real-time violation
0x8141 | Error | General | Sync%X Interrupt lost | Sync%X Interrupt lost
0x8142 | Error | General | Sync Interrupt asynchronous | Sync Interrupt asynchronous
0x8143 | Error | General | Jitter too big | Jitter limit violation
0x817F | Error | General | Error: 0x%X, 0x%X, 0x%X |
0x8200 | Error | Communication | Write access error: %d, %d | Error while writing
0x8201 | Error | Communication | No communication to field-side (Auxiliary voltage missing) | - There is no voltage applied to the power contacts - A firmware update has failed
0x8281 | Error | Communication | Ownership failed: %X |
0x8282 | Error | Communication | To many Keys founded |
0x8283 | Error | Communication | Key Creation failed: %X |
0x8284 | Error | Communication | Key loading failed |
0x8285 | Error | Communication | Reading Public Key failed: %X |
0x8286 | Error | Communication | Reading Public EK failed: %X |
0x8287 | Error | Communication | Reading PCR Value failed: %X |
0x8288 | Error | Communication | Reading Certificate EK failed: %X |
0x8289 | Error | Communication | Challenge could not be hashed: %X |
0x828A | Error | Communication | Tickstamp Process failed |
0x828B | Error | Communication | PCR Process failed: %X |
0x828C | Error | Communication | Quote Process failed: %X |
0x82FF | Error | Communication | Bootmode not activated | Boot mode not activated
0x8300 | Error | Encoder | Set position error: 0x%X, %d | Error while setting the position
0x8301 | Error | Encoder | Encoder increments not configured: 0x%X, %d | Encoder increments not configured
0x8302 | Error | Encoder | Encoder error | The amplitude of the resolver is too small
0x8303 | Error | Encoder | Encoder supply error | Encoder power supply unit error
0x8304 | Error | Encoder | Encoder communication error, channel: %X | Encoder communication error
0x8305 | Error | Encoder | EnDat2.2 is not supported, channel: %X | EnDat2.2 is not supported
0x8306 | Error | Encoder | Delay time, tolerance limit exceeded, 0x%X, channel: %X | Runtime measurement, tolerance exceeded
0x8307 | Error | Encoder | Delay time, maximum value exceeded, 0x%X, channel: %X | Runtime measurement, maximum value exceeded
0x8308 | Error | Encoder | Unsupported ordering designation, 0x%X, channel: %X (only 02 and 22 is supported) | Wrong EnDat order ID
0x8309 | Error | Encoder | Encoder CRC error, channel: %X | Encoder CRC error
0x830A | Error | Encoder | Temperature %X could not be read, channel: %X | Temperature cannot be read
0x8400 | Error | Drive | Incorrect drive configuration: 0x%X, %d | Drive incorrectly configured
0x8401 | Error | Drive | Limiting of calibration velocity: %d, %d | Limitation of the calibration velocity
0x8402 | Error | Drive | Emergency stop activated: 0x%X, %d | Emergency stop activated
0x8403 | Error | Drive | ADC Error | Error during current measurement in the ADC
0x8404 | Error | Drive | Overcurrent | Overcurrent in phase U, V or W
0x8405 | Error | Drive | Invalid modulo position: %d | Modulo position invalid
0x8406 | Error | Drive | DC-Link undervoltage (Error) | The DC link voltage of the terminal is lower than the parameterized minimum voltage. Activation of the output stage is prevented
0x8407 | Error | Drive | DC-Link overvoltage (Error) | The DC link voltage of the terminal is higher than the parameterized maximum voltage. Activation of the output stage is prevented
0x8408 | Error | Drive | I2T-Model Amplifier overload (Error) | - The amplifier is being operated outside the specification - The I2T-model of the amplifier is incorrectly parameterized
0x8409 | Error | Drive | I2T-Model motor overload (Error) | - The motor is being operated outside the parameterized rated values - The I2T-model of the motor is incorrectly parameterized
0x840A | Error | Drive | Overall current threshold exceeded | Total current exceeded
0x8415 | Error | Drive | Invalid modulo factor: %d | Modulo factor invalid
0x8416 | Error | Drive | Motor overtemperature | The internal temperature of the motor exceeds the parameterized error threshold. The motor stops immediately. Activation of the output stage is prevented.
0x8417 | Error | Drive | Maximum rotating field velocity exceeded | Rotary field speed exceeds the value specified for dual use (EU 1382/2014).
0x841C | Error | Drive | STO while the axis was enabled | An attempt was made to activate the axis, despite the fact that no voltage is present at the STO input.
0x8550 | Error | Inputs | Zero crossing phase %X missing | Zero crossing phase %X missing
0x8551 | Error | Inputs | Phase sequence Error | Wrong direction of rotation
0x8552 | Error | Inputs | Overcurrent phase %X | Overcurrent phase %X
0x8553 | Error | Inputs | Overcurrent neutral wire | Overcurrent neutral wire
0x8581 | Error | Inputs | Wire broken Ch %D | Wire broken Ch %d
0x8600 | Error | General IO | Wrong supply voltage range | Supply voltage not in the correct range
0x8601 | Error | General IO | Supply voltage to low | Supply voltage too low
0x8602 | Error | General IO | Supply voltage to high | Supply voltage too high
0x8603 | Error | General IO | Over current of supply voltage | Overcurrent of supply voltage
0x8610 | Error | General IO | Wrong output voltage range | Output voltage not in the correct range
0x8611 | Error | General IO | Output voltage to low | Output voltage too low
0x8612 | Error | General IO | Output voltage to high | Output voltage too high
0x8613 | Error | General IO | Over current of output voltage | Overcurrent of output voltage
0x8700 | Error |  | Channel/Interface not calibrated | Channel/interface not synchronized
0x8701 | Error |  | Operating time was manipulated | Operating time was manipulated
0x8702 | Error |  | Oversampling setting is not possible | Oversampling setting not possible
0x8703 | Error |  | No slave controller found | No slave controller found
0x8704 | Error |  | Slave controller is not in Bootstrap | Slave controller is not in bootstrap
0x8705 | Error |  | Processor usage to high (>= 100%%) | Processor load too high (>= 100%%)
0x8706 | Error |  | Channel in saturation | Channel in saturation
0x8707 | Error |  | Channel overload | Channel overload
0x8708 | Error |  | Overloadtime was manipulated | Overload time was manipulated
0x8709 | Error |  | Saturationtime was manipulated | Saturation time was manipulated
0x870A | Error |  | Channel range error | Measuring range error for the channel
0x870B | Error |  | no ADC clock | No ADC clock available
0xFFFF | Information |  | Debug: 0x%X, 0x%X, 0x%X | Debug: 0x%X, 0x%X, 0x%X


TcEventLogger and IO

Appendix [image] TcEventLogger and IO
TcEventLogger and IO
The TwinCAT 3 EventLogger provides an interface for the exchange of messages between TwinCAT components and non-TwinCAT components.
Schematic representation TCEventLogger
Refer to the explanations in the TwinCAT EventLogger documentation, e.g. in the Beckhoff InfoSys https://infosys.beckhoff.com/ → TwinCAT 3 → TE1000 XAE → Technologies → EventLogger.
The EventLogger saves to a local database under ..\TwinCAT\3.1\Boot\LoggedEvents.db and, unlike the VisualStudio Error Window, is designed for continuous recording.
IO devices can also be a source of messages. If so-called DiagMessages are generated in the IO device, they can be collected by TwinCAT over EtherCAT and displayed in the TcEventLogger with the appropriate device setting. This facilitates the central management of events that hinder operation, as a textual diagnosis no longer needs to be programmed out in the application for each individual IO device. The messages/events can be displayed directly in the TwinCAT HMI, for example, and thus facilitate the diagnosis.
Notes:
▪
This feature is supported from TwinCAT 3.1 build 4022.16.
▪
TwinCAT may be in the RUN or CONFIG mode
▪
On the manufacturer side, the IO device regarded must (1) generate local DiagMessages and (2) be fundamentally capable of transmitting them as events over EtherCAT. This is not the case with all EtherCAT IO devices/terminals/boxes from Beckhoff.
The messages managed by the EventLogger can be output in or read from
▪
the HMI → EventGrid
▪
C#
▪
the PLC
▪
TwinCAT Engineering → Logged Events
The use of the EventLogger with EtherCAT IO with TwinCAT 3.1 build 4022.22 during commissioning is explained below.
▪
The EventLogger window may need to be displayed in the TwinCAT Engineering
Display EventLogger window
▪
Some DiagMessages and the resulting Logged Events are shown below, taking an ELM3602-0002 as an example
Display DiagMessages and Logged Events
▪
Filtering by entries and language is possible in the Logger window.
German: 1031
English: 1033
Setting filter language
▪
If an EtherCAT slave is enabled by default to transmit DiagMessages as events over EtherCAT, this can be activated/deactivated for each individual slave in the CoE 0x10F3:05. TRUE means that the slave provides events for collection via EtherCAT, while FALSE deactivates the function.
Activating/deactivating event transmission
▪
In the respective EtherCAT slave, various "causes" can lead to it transmitting DiagMessages or events. If only some of these are to be generated, you can read in the device documentation whether and how individual causes can be deactivated, e.g. through CoE settings.
▪
Settings for the TwinCAT EventLogger can be found under Tools/Options
Settings TwinCAT EventLogger


CoE overview

Appendix [image] CoE overview
CoE overview
Additional information
•
0x6000 PAI Status Ch.1
•
0x6001 PAI Samples Ch.1
•
0x6002 PAI Synchronous Oversampling Ch.1
•
0x7000 PAI Control Ch.1
•
0x8000 PAI Settings Ch.1
•
0x8001 PAI Filter 1 Settings Ch.1
•
0x8003 PAI Filter 2 Settings Ch.1
•
0x8005 Scaler Settings Ch.1
•
0x800E PAI User Calibration Data Ch.1
•
0x800F PAI Vendor Calibration Data Ch.1
•
0x9000 PAI Internal Data Ch.1
•
0x900F PAI Calibration Dates Ch.1
•
0xF000 Modular device profile
•
0xF008 Code word
•
0xF009 Password Protection
•
0xF010 Module list
•
0xF006 PAI Timestamp
•
0xF900 PAI Info Data
•
0xF912 Filter info
•
0xFB00 PAI Command


0x6000 PAI Status Ch.1

Appendix [image] CoE overview [image] 0x6000 PAI Status Ch.1
0x6000 PAI Status Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
6000:0 | PAI Status Ch.1 |  | UINT8 | RO | 0x0F (15dec)
6000:01 | No of Samples | Number of valid samples within the PDO samples | UINT8 | RO | 0x00 (0dec)
6000:09 | Error | TRUE: General error | BOOLEAN | RO | 0x00 (0dec)
6000:0A | Underrange | TRUE: Measurement event underflow | BOOLEAN | RO | 0x00 (0dec)
6000:0B | Overrange | TRUE: Measurement event overflow | BOOLEAN | RO | 0x00 (0dec)
6000:0D | Diag | TRUE: New diagnostic message available | BOOLEAN | RO | 0x00 (0dec)
6000:0E | TxPDO State | TRUE: data invalid | BOOLEAN | RO | 0x00 (0dec)
6000:0F | Input cycle counter | Incremented by one when values have changed | BIT2 | RO | 0x00 (0dec)


0x6001 PAI Samples Ch.1

Appendix [image] CoE overview [image] 0x6001 PAI Samples Ch.1
0x6001 PAI Samples Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
6001:0 | PAI Samples Ch.1 |  | UINT8 | RO | 0x64 (100dec)
6001:01 | Sample | Samples | INT32 | RO | 0x00000000 (0dec)
… | … | … | … | … | …
6001:64 | Sample | Samples | INT32 | RO | 0x00000000 (0dec)


0x6002 PAI Synchronous Oversampling Ch.1

Appendix [image] CoE overview [image] 0x6002 PAI Synchronous Oversampling Ch.1
0x6002 PAI Synchronous Oversampling Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
6002:0 | PAI Synchronous Oversampling Ch.1 |  | RO | UINT8 | 0x01 (1dec)
6002:01 | Internal Buffer |  | RO | UINT16 | 0x0000 (0dec)


0x7000 PAI Control Ch.1

Appendix [image] CoE overview [image] 0x7000 PAI Control Ch.1
0x7000 PAI Control Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
7000:0 | PAI Control Ch.1 |  | UINT8 | RO | 0x02 (2dec)
7000:01 | Integrator Reset | Restart of the integration with rising edge | BOOLEAN | RO | 0x00 (0dec)
7000:02 | Peak Hold Reset | Start new peak value detection with rising edge | BOOLEAN | RO | 0x00 (0dec)


0x8000 PAI Settings Ch.1

Appendix [image] CoE overview [image] 0x8000 PAI Settings Ch.1
0x8000 PAI Settings Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
8000:0 | PAI Settings Ch.1 |  | UINT8 | RO | 0x31 (49dec)
8000:01 | Interface | Selection of the measuring configuration: 0 - None 1 - V ±30V 2 - V ±10V 3 - V ±5V 4 - V ±2.5V 5 - V ±1.25V 6 - V ±640mV 7 - V ±320mV 8 - V ±160mV 9 - V ±80mV 10 - V ±40mV 11 - V ±20mV 12 - V ±10mV 13 - V ±5mV 14 - V 0...10V 15 - V 0...5V 17 - I ±20mA 18 - I 0-20mA 19 - I 4-20mA 20 - I 4-20mA NAMUR 33 - RTD/R 2Wire 34 - RTD/R 3Wire 35 - RTD/R 4Wire 49 - SG 1/4 2Wire 350R 50 - SG 1/4 2Wire 120R 51 - SG 1/4 3Wire 350R 52 - SG 1/4 3Wire 120R 53 - SG 1/2 3Wire 54 - SG 1/2 5Wire 55 - SG 1/1 4Wire 56 - SG 1/1 6Wire 65 - Poti 3Wire 66 - Poti 5Wire | UINT16 | RW | 0x0000 (0dec)
8000:02 | SG Voltage | Selection of the SG voltage: 0 - 0 V 1 - 0.5 V 2 - 1.0 V 3 - 1.5 V 4 - 2.0 V 5 - 2.5 V 6 - 3.0 V 7 - 3.5 V 8 - 4.0 V 9 - 4.5 V 10 - 5.0 V | UINT16 | RW | 0x0000 (0dec)
8000:04 | Wire Break Detection | Broken wire detection TRUE = on FALSE = off (see section “Broken wire detection/ optional connection diagnosis”) | BOOLEAN | RW | 0x00 (FALSE)
8000:13 | Wire Resistance Compensation 640 µΩ/ Step | Compensation of the wire resistance with resolution 640 µΩ/ step (only in 2-wire mode, "R/RTD 2-wire" possible) | UINT16 | RW | 0x0000 (0dec)
8000:14 | RTD Element | Selection of the RTD element: 0 - None 1 - PT100 (-200...850°C) 2 - NI100 (-60...250°C) 3 - PT1000 (-200...850°C) 4 - PT500 (-200...850°C) 5 - PT200 (-200...850°C) 6 - NI1000 (-60...250°C) 7 - NI1000 TK5000 or rather 100°C: 1500 Ω (-30...160°C) 8 - NI120 (-60...320°C) 9 - KT100/110/130/210/230 KTY10/11/13/16/19 (-50...150°C) 10 - KTY81/82-110,120,150 (-50...150°C) 11 - KTY81-121 (-50...150°C) 12 - KTY81-122 (-50...150°C) 13 - KTY81-151 (-50...150°C) 14 - KTY81-152 (-50...150°C) 15 - KTY81/82-210,220,250 (-50...150°C) 16 - KTY81-221 (-50...150°C) 17 - KTY81-222 (-50...150°C) 18 - KTY81-251 (-50...150°C) 19 - KTY81-252 (-50...150°C) 20 - KTY83-110,120,150 (-50...175°C) 21 - KTY83-121 (-50...175°C) 22 - KTY83-122 (-50...175°C) 23 - KTY83-151 (-50...175°C) 24 - KTY83-152 (-50...175°C) 25 - KTY84-130,150 (-40...300°C) 26 - KTY84-151 (-40...300°C) 27 - KTY21/23-6 (-50...150°C) 28 - KTY1x-5 (-50...150°C) 29 - KTY1x-7 (-50...150°C) 30 - KTY21/23-5 (-50...150°C) 31 - KTY21/23-7 (-50...150°C) | UINT16 | RW | 0x0000 (0dec)
8000:16 | Filter 1 | Options for filter 1: 0 - None 1 - FIR Notch 50 Hz 2 - FIR Notch 60 Hz 3 - FIR LP 100 Hz 4 - FIR LP 1000 Hz 5 - FIR HP 150 Hz 6 - FIR HP 1500 Hz 16 - IIR Notch 50 Hz 17 - IIR Notch 60 Hz 18 - IIR Butterw. LP 5th Ord. 1 Hz 19 - IIR Butterw. LP 5th Ord. 25 Hz 20 - IIR Butterw. LP 5th Ord. 100 Hz 21 - IIR Butterw. LP 5th Ord. 250 Hz 22 - IIR Butterw. LP 5th Ord. 1000 Hz 32 - User defined FIR Filter 33 - User defined IIR Filter 34 - User defined Average Filter | UINT16 | RW | 0x0000 (0dec)
8000:17 | Average Filter 1 No of Samples | Number of samples for user-defined Average Filter 1 | UINT16 | RW | 0x0001 (1dec)
8000:18 | Decimation Factor | Factor for individual sampling rate (min. 1) | UINT16 | RW | 0x0001 (1dec)
8000:19 | Filter 2 | Options for filter 2: 0 - None 1 - IIR 1 2 - IIR 2 3 - IIR 3 4 - IIR 4 5 - IIR 5 6 - IIR 6 7 - IIR 7 8 - IIR 8 16 - User defined FIR Filter 17 - User defined IIR Filter 18 - User defined Average Filter | UINT16 | RW | 0x0000 (0dec)
8000:1A | Average Filter 2 No of Samples | Number of samples for user-defined Average Filter 2 | UINT16 | RW | 0x0000 (0dec)
8000:1B | True RMS No. of Samples | Number of samples for "True RMS" calculation (min. 1, max. 1000); also see chapter TrueRMS (extended maximum values for ELM360x) | UINT16 | RW | 0x0000 (0dec)
8000:1C | Enable True RMS | Activation of "True RMS" calculation | BOOLEAN | RW | 0x00 (FALSE)
8000:2B | Extended Functions | Options for future functions/settings | UINT16 | RW | 0x0000 (0dec)
8000:2C | Integrator/Differentiator | Options: 0 – Off 1 - Integrator 1x 2 - Integrator 2x (* 3 - Differentiator 1x 4 - Differentiator 2x (* | UINT16 | RW | 0x0000 (0dec)
8000:2D | Differentiator Samples Delta | Distance of samples for the differentiation | UINT16 | RW | 0x0001 (1dec)
8000:2E | Scaler | Scaling (enum): 0 - Extended Range 1 - Linear 2 - Lookup Table 3 - Legacy Range 4 - Lookup Table (additive) | UINT16 | RW | 0x0000 (0dec)
8000:30 | Low Limiter | Smallest PDO output value | INT32 | RW | 0x80000000 (-2147483648dec)
8000:31 | High Limiter | Largest PDO output value | INT32 | RW | 0x7FFFFFFF (2147483647dec)
8000:32 | Low Range Error | Lowest limit at which the error bit and the error LED are set | INT32 | RW | 0xFF800000 (-8388608dec)
8000:33 | High Range Error | Highest limit at which the error bit and the error LED are set | INT32 | RW | 0x007FFFFF (8388607dec)
8000:34 | Timestamp Correction | Value for correcting StartNextLatchTime (timestamp of the first sample) | INT32 | RW | 0x FFFB6C20 (-300000dec)
(* Function is only available from FW03 on


0x8001 PAI Filter 1 Settings Ch.1

Appendix [image] CoE overview [image] 0x8001 PAI Filter 1 Settings Ch.1
0x8001 PAI Filter 1 Settings Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
8001:0 | PAI Filter 1 Settings Ch.1 |  | UINT8 | RO | 0x28 (40dec)
8001:01 | Filter Coefficient 1 | Coefficients for filter 1 | INT32 | RO | 0x00000000 (0dec)
… | … | … | … | … | …
8001:28 | Filter Coefficient 40 | Coefficients for filter 1 | INT32 | RO | 0x00000000 (0dec)


0x8003 PAI Filter 2 Settings Ch.1

Appendix [image] CoE overview [image] 0x8003 PAI Filter 2 Settings Ch.1
0x8003 PAI Filter 2 Settings Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
8003:0 | PAI Filter 2 Settings Ch.1 |  | UINT8 | RO | 0x28 (40dec)
8003:01 | Filter Coefficient 1 | Coefficients for filter 2 | INT32 | RO | 0x00000000 (0dec)
… | … | … | … | … | …
8003:28 | Filter Coefficient 40 | Coefficients for filter 2 | INT32 | RO | 0x00000000 (0dec)


0x8005 Scaler Settings Ch.1

Appendix [image] CoE overview [image] 0x8005 Scaler Settings Ch.1
0x8005 Scaler Settings Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
8005:0 | PAI Scaler Settings Ch.1 | Scaling values offset/gain or LookUp table with 50 x/y value pairs | UINT8 | RO | 0x64 (100dec)
8005:01 | Scaler Offset/ Scaler Value 1 | Scaling offset or LookUp x-value 1 | INT32 | RW | 0x00000000 (0dec)
8005:02 | Scaler-Gain/ Scaler Value 2 | Scaling gain or LookUp y-value 1 | INT32 | RW | 0x00000000 (0dec)
8005:03 | Scaler Value 3 | LookUp x-value 2 | INT32 | RW | 0x00000000 (0dec)
8005:04 | Scaler Value 4 | LookUp y-value 2 | INT32 | RW | 0x00000000 (0dec)
.. | .. | .. | .. | .. | ..
8005:63 | Scaler Value 99 | LookUp x-value 50 | INT32 | RW | 0x00000000 (0dec)
8005:64 | Scaler Value 100 | LookUp y-value 50 | INT32 | RW | 0x00000000 (0dec)


0x800E PAI User Calibration Data Ch.1

Appendix [image] CoE overview [image] 0x800E PAI User Calibration Data Ch.1
0x800E PAI User Calibration Data Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
800E:0 | PAI User Calibration Data Ch.1 |  | UINT8 | RO | 0x0C (12dec)
800E:01 | Calibration Date | Date of calibration | OCTET-STRING[4] | RW | -
800E:02 | Signature | Signature of the calibration values | OCTET-STRING[4] | RW | -
800E:03 | S0 | Offset | REAL32 | RW | 0x00000000 (0dec)
800E:04 | S1 | Coefficient for first-order samples (S1 * sample) | REAL32 | RW | 0x3F800000 (1.0dec)
800E:05 | S2 | Coefficient for second-order samples (S2 * sample2) | REAL32 | RW | 0x00000000 (0.0dec)
800E:06 | S3 | Coefficient for third-order samples (S3 * sample3) | REAL32 | RW | 0x00000000 (0.0dec)
800E:07 | T1 | Temperature coefficient for first-order temperature value (T1 * temp) | REAL32 | RW | 0x00000000 (0.0dec)
800E:08 | T1S1 | Combined coefficient for first-order gain and temperature values (T1S1 * temp * sample) | REAL32 | RW | 0x00000000 (0.0dec)
800E:09 | T2 | Temperature coefficient for second-order temperature value (T2 * temp2) | REAL32 | RW | 0x00000000 (0.0dec)
800E:0A | T2S1 | Combined coefficient for second-order gain and temperature values (T2S1 * temp2 * sample) | REAL32 | RW | 0x00000000 (0.0dec)
800E:0B | T3 | Temperature coefficient for third-order temperature value (T3 * temp3) | REAL32 | RW | 0x00000000 (0.0dec)
800E:0C | T3S1 | Combined coefficient for third-order gain and temperature values (T3S1 * temp3 * sample) | REAL32 | RW | 0x00000000 (0.0dec)


0x800F PAI Vendor Calibration Data Ch.1

Appendix [image] CoE overview [image] 0x800F PAI Vendor Calibration Data Ch.1
0x800F PAI Vendor Calibration Data Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
800F:0 | PAI Vendor Calibration Data Ch.1 |  | UINT8 | RO | 0x0C (12dec)
800F:01 | Calibration Date | Date of calibration | OCTET-STRING[4] | RW | -
800F:02 | Signature | Signature of the calibration values | OCTET-STRING[4] | RW | -
800F:03 | S0 | Offset | REAL32 | RW | 0x00000000 (0dec)
800F:04 | S1 | Coefficient for first-order samples (S1 * sample) | REAL32 | RW | 0x3F800000 (1.0dec)
800F:05 | S2 | Coefficient for second-order samples (S2 * sample2) | REAL32 | RW | 0x00000000 (0.0dec)
800F:06 | S3 | Coefficient for third-order samples (S3 * sample3) | REAL32 | RW | 0x00000000 (0.0dec)
800F:07 | T1 | Temperature coefficient for first-order temperature value (T1 * temp) | REAL32 | RW | 0x00000000 (0.0dec)
800F:08 | T1S1 | Combined coefficient for first-order gain and temperature values (T1S1 * temp * sample) | REAL32 | RW | 0x00000000 (0.0dec)
800F:09 | T2 | Temperature coefficient for second-order temperature value (T2 * temp2) | REAL32 | RW | 0x00000000 (0.0dec)
800F:0A | T2S1 | Combined coefficient for second-order gain and temperature values (T2S1 * temp2 * sample) | REAL32 | RW | 0x00000000 (0.0dec)
800F:0B | T3 | Temperature coefficient for third-order temperature value (T3 * temp3) | REAL32 | RW | 0x00000000 (0.0dec)
800F:0C | T3S1 | Combined coefficient for third-order gain and temperature values (T3S1 * temp3 * sample) | REAL32 | RW | 0x00000000 (0.0dec)


0x9000 PAI Internal Data Ch.1

Appendix [image] CoE overview [image] 0x9000 PAI Internal Data Ch.1
0x9000 PAI Internal Data Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
9000:0 | PAI Internal Data Ch.1 |  | UINT8 | RO | 0x12 (18dec)
9000:01 | Temperature Value | Temperature value of the channel | INT16 | RO | 0x0000 (0dec)
9000:02 | ADC Raw Value | ADC Raw Value | INT32 | RO | 0x00000000 (0dec)
9000:03 | Calibration Value | Value after calibration | INT32 | RO | 0x00000000 (0dec)
9000:04 | Resistor Value | Value after resistance calculation | INT32 | RO | 0x00000000 (0dec)
9000:05 | RTD Element Value | Value after RTD element calculation | INT32 | RO | 0x00000000 (0dec)
9000:06 | Actual Negative Peak Hold | Current absolute minimum value | INT32 | RO | 0x00000000 (0dec)
9000:07 | Actual Positive Peak Hold | Current absolute maximum value | INT32 | RO | 0x00000000 (0dec)
9000:08 | Previous Negative Peak Hold | Absolute minimum value up to last rising edge of "Peak Hold Reset" | INT32 | RO | 0x00000000 (0dec)
9000:09 | Previous Positive Peak Hold | Absolute maximum value up to last rising edge of "Peak Hold Reset" | INT32 | RO | 0x00000000 (0dec)
9000:0A | Filter 1 Value | Value after filter 1 | INT32 | RO | 0x00000000 (0dec)
9000:0B | Filter 2 Value | Value after filter 2 | INT32 | RO | 0x00000000 (0dec)
9000:0C | True RMS Value | Value after "True RMS" calculation | INT32 | RO | 0x00000000 (0dec)
9000:0D | Extended Functions Value | Value after advanced (optional) function | INT32 | RO | 0x00000000 (0dec)
9000:0E | Integrator/Differentiator Value | Value after integration or differentiation | INT32 | RO | 0x00000000 (0dec)
9000:0F | Scaler Value | Value after scaling | INT32 | RO | 0x00000000 (0dec)
9000:10 | Limiter Value | Value after limitation | INT32 | RO | 0x00000000 (0dec)
9000:11 | Overload Time | Absolute time during overload "Overload" means that the channel is electrically overloaded. This is a non-recommendable condition that may eventually lead to atypical aging or even damage. This condition should be avoided Its accumulated duration is displayed here informatively. | UINT32 | RO | 0x00000000 (0dec)
9000:12 | Saturation Time | Absolute time during saturation "Saturation" means that the measuring range of the ADC of the channel is fully utilized, the ADC thus outputs its maximum value and the measured value can no longer be used. "Saturation" is therefore a pre-deregistration, with further signal increase it comes to "overload". The saturation state is not fundamentally harmful, but it indicates an insufficient dimensioning of the measurement channel. Its accumulated response time is displayed here informatively. | UINT32 | RO | 0x00000000 (0dec)
9000:13 | Effective Sample Rate | Effective sampling frequency | UINT32 | RO | Online calculated
9000:14 | Vendor Calibration Counter | Writing counter for vendor calibration data | UINT16 | RO | 0x0000 (0dec)
9000:15 | User Calibration Counter | Writing counter for user calibration data | UINT16 | RO | 0x0000 (0dec)


0x900F PAI Calibration Dates Ch.1

Appendix [image] CoE overview [image] 0x900F PAI Calibration Dates Ch.1
0x900F PAI Calibration Dates Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
900F:0 | PAI Calibration Dates |  | UINT8 | RO | 0xC2 (194dec)
900F:01 | Vendor ±30V |  | OCTET-STRING[4] | RO | {0}
900F:02 | Vendor ±10V |  | OCTET-STRING[4] | RO | {0}
900F:03 | Vendor ±5V |  | OCTET-STRING[4] | RO | {0}
900F:04 | Vendor ±2.5V |  | OCTET-STRING[4] | RO | {0}
900F:05 | Vendor ±1.25V |  | OCTET-STRING[4] | RO | {0}
900F:06 | Vendor ±640mV |  | OCTET-STRING[4] | RO | {0}
900F:07 | Vendor ±320mV |  | OCTET-STRING[4] | RO | {0}
900F:08 | Vendor ±160mV |  | OCTET-STRING[4] | RO | {0}
900F:09 | Vendor ±80mV |  | OCTET-STRING[4] | RO | {0}
900F:0A | Vendor ±40mV |  | OCTET-STRING[4] | RO | {0}
900F:0B | Vendor ±20mV |  | OCTET-STRING[4] | RO | {0}
900F:0C | Vendor ±10mV |  | OCTET-STRING[4] | RO | {0}
900F:0D | Vendor ±5mV |  | OCTET-STRING[4] | RO | {0}
900F:11 | Vendor ±20mA |  | OCTET-STRING[4] | RO | {0}
900F:21 | Vendor RTD/R 2Wire |  | OCTET-STRING[4] | RO | {0}
900F:22 | Vendor RTD/R 3Wire |  | OCTET-STRING[4] | RO | {0}
900F:23 | Vendor RTD/R 4Wire |  | OCTET-STRING[4] | RO | {0}
900F:31 | Vendor SG 1/4 2Wire 350R |  | OCTET-STRING[4] | RO | {0}
900F:32 | Vendor SG 1/4 2Wire 120R |  | OCTET-STRING[4] | RO | {0}
900F:33 | Vendor SG 1/4 3Wire 350R |  | OCTET-STRING[4] | RO | {0}
900F:34 | Vendor SG 1/4 3Wire 120R |  | OCTET-STRING[4] | RO | {0}
900F:35 | Vendor SG 1/2 3Wire |  | OCTET-STRING[4] | RO | {0}
900F:36 | Vendor SG 1/2 5Wire |  | OCTET-STRING[4] | RO | {0}
900F:37 | Vendor SG 1/1 4Wire |  | OCTET-STRING[4] | RO | {0}
900F:38 | Vendor SG 1/1 6Wire |  | OCTET-STRING[4] | RO | {0}
900F:41 | Vendor Poti 3Wire |  | OCTET-STRING[4] | RO | {0}
900F:42 | Vendor Poti 5Wire |  | OCTET-STRING[4] | RO | {0}
900F:81 | User ±30V |  | OCTET-STRING[4] | RO | {0}
900F:82 | User ±10V |  | OCTET-STRING[4] | RO | {0}
900F:83 | User ±5V |  | OCTET-STRING[4] | RO | {0}
900F:84 | User ±2.5V |  | OCTET-STRING[4] | RO | {0}
900F:85 | User ±1.25V |  | OCTET-STRING[4] | RO | {0}
900F:86 | User ±640mV |  | OCTET-STRING[4] | RO | {0}
900F:87 | User ±320mV |  | OCTET-STRING[4] | RO | {0}
900F:88 | User ±160mV |  | OCTET-STRING[4] | RO | {0}
900F:89 | User ±80mV |  | OCTET-STRING[4] | RO | {0}
900F:8A | User ±40mV |  | OCTET-STRING[4] | RO | {0}
900F:8B | User ±20mV |  | OCTET-STRING[4] | RO | {0}
900F:8C | User ±10mV |  | OCTET-STRING[4] | RO | {0}
900F:8D | User ±5mV |  | OCTET-STRING[4] | RO | {0}
900F:91 | User ±20mA |  | OCTET-STRING[4] | RO | {0}
900F:A1 | User RTD/R 2Wire |  | OCTET-STRING[4] | RO | {0}
900F:A2 | User RTD/R 3Wire |  | OCTET-STRING[4] | RO | {0}
900F:A3 | User RTD/R 4Wire |  | OCTET-STRING[4] | RO | {0}
900F:B1 | User SG 1/4 2Wire 350R |  | OCTET-STRING[4] | RO | {0}
900F:B2 | User SG 1/4 2Wire 120R |  | OCTET-STRING[4] | RO | {0}
900F:B3 | User SG 1/4 3Wire 350R |  | OCTET-STRING[4] | RO | {0}
900F:B4 | User SG 1/4 3Wire 120R |  | OCTET-STRING[4] | RO | {0}
900F:B5 | User SG 1/2 3Wire |  | OCTET-STRING[4] | RO | {0}
900F:B6 | User SG 1/2 5Wire |  | OCTET-STRING[4] | RO | {0}
900F:B7 | User SG 1/1 4Wire |  | OCTET-STRING[4] | RO | {0}
900F:B8 | User SG 1/1 6Wire |  | OCTET-STRING[4] | RO | {0}
900F:C1 | User Poti 3Wire |  | OCTET-STRING[4] | RO | {0}
900F:C2 | User Poti 5Wire |  | OCTET-STRING[4] | RO | {0}


0xF000 Modular device profile

Appendix [image] CoE overview [image] 0xF000 Modular device profile
0xF000 Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RO | 0x0000 (0dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0000 (0dec)


0xF008 Code word

Appendix [image] CoE overview [image] 0xF008 Code word
0xF008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word |  | UINT32 | RW | 0x00000000 (0dec)


0xF009 Password Protection

Appendix [image] CoE overview [image] 0xF009 Password Protection
0xF009 Password Protection
Index (hex) | Name | Meaning | Data type | Flags | Default
F009:0 | Password protection |  | UINT32 | RW | 0x00000000 (0dec)


0xF010 Module list

Appendix [image] CoE overview [image] 0xF010 Module list
0xF010 Module list
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list |  | UINT8 | RW | 0x01 (1dec)
F010:01 | Subindex 001 |  | UINT32 | RW | 0x0000015E (350dec)


0xF006 PAI Timestamp

Appendix [image] CoE overview [image] 0xF006 PAI Timestamp
0xF006 PAI Timestamp
Index (hex) | Name | Meaning | Data type | Flags | Default
F600:0 | PAI Timestamp |  | UINT8 | RO | 0x02 (2dec)
F600:01 | Low | Timestamp (low) | UINT32 | RO | 0x00000000 (0dec)
F600:02 | Hi | Timestamp (hi) | UINT32 | RO | 0x00000000 (0dec)


0xF900 PAI Info Data

Appendix [image] CoE overview [image] 0xF900 PAI Info Data
0xF900 PAI Info Data
Index (hex) | Name | Meaning | Data type | Flags | Default
F900:0 | PAI Info Data |  | UINT8 | RO | 0x02 (2dec)
F900:01 | CPU Usage | CPU load in [%]* | UINT16 | RO | 0x0000 (0dec)
F900:02 | Operating Time | Operating time in [min] | UINT32 | RO | 0x00000000 (0dec)
F900:11 | Device Temperature Sensor 1 | Measured temperature in the terminal | INT16 | RO | 0x0000 (0dec)
F900:21 | Min. Temperature Sensor 1 | Lowest measured temperature in the terminal | INT16 | RO | 0x0000 (0dec)
F900:22 | Max. Temperature Sensor 1 | Highest measured temperature in the terminal | INT16 | RO | 0x0000 (0dec)
*) This value depends of additional enabled features (Filters, True RMS, ...); the more functions of the terminal are in use, the greater is the value. Notice amongst others the „Input cycle counter“ (PAI Status Ch1.). The CPU load is an informative value with particularly regard to the "Device-specific Diag messages".


0xF912 Filter info

Appendix [image] CoE overview [image] 0xF912 Filter info
0xF912 Filter info
Index (hex) | Name | Meaning | Data type | Flags | Default
F912:0 | Filter info |  | UINT8 | RO | 0x05 (5dec)
F912:01 | Info header | Basic information for the filter designer | OCTET‑STRING[8] | RO | {0}
F912:02 | Filter 1 | Informations for the filter designer | OCTET‑STRING[30] | RO | {0}
... | ... | ... | ... | ... | ...
F912:05 | Filter n | Informations for the filter designer | OCTET‑STRING[30] | RO | {0}
Note: CoE Objekt "0xF912 Filter info" is available since FW11, revision -0022


0xFB00 PAI Command

Appendix [image] CoE overview [image] 0xFB00 PAI Command
0xFB00 PAI Command
Index (hex) | Name | Meaning | Data type | Flags | Default
FB00:0 | PAI Command |  | UINT8 | RO | 0x03 (3dec)
FB00:01 | Request | Command request The respective functional chapters explain which value is to be entered here. | OCTET-STRING[2] | RW | {0}
FB00:02 | Status | Command status This indicates that the command is still running or has been executed. Functional dependent, see respective sections. Otherwise: 0: Command not existing 1: executed without errors 2,3: executed not successful 100..200: indicates the execution progress (100 = 0% etc.) | UINT8 | RO | 0x00 (0dec)
FB00:03 | Response | Command response If the transferred command returns a response, it will be displayed here. Functional dependent, see resprective sections. | OCTET-STRING[4] | RO | {0}


UL notice

Appendix [image] UL notice
UL notice
culus-logo
Application
Beckhoff EtherCAT modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
culus-logo
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
culus-logo
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
Basic principles
UL certification according to UL508. Devices with this kind of certification are marked by this sign:


ATEX Documentation

Appendix [image] ATEX Documentation
ATEX Documentation
Notes about operation of the Beckhoff terminal systems in potentially explosive areas (ATEX)
Pay also attention to the continuative documentation

Notes about operation of the Beckhoff terminal systems in potentially explosive areas (ATEX)

that is available in the download area of the Beckhoff homepage http:\\www.beckhoff.com!


EtherCAT AL Status Codes

Appendix [image] EtherCAT AL Status Codes
EtherCAT AL Status Codes
For detailed information please refer to the EtherCAT system description.


Firmware Update EL/ES/EM/ELM/EPxxxx

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx
Firmware Update EL/ES/EM/ELM/EPxxxx
This section describes the device update for Beckhoff EtherCAT slaves from the EL/ES, ELM, EM, EK and EP series. A firmware update should only be carried out after consultation with Beckhoff support.
Storage locations
An EtherCAT slave stores operating data in up to 3 locations:
▪
Depending on functionality and performance EtherCAT slaves have one or several local controllers for processing I/O data. The corresponding program is the so-called firmware in *.efw format.
▪
In some EtherCAT slaves the EtherCAT communication may also be integrated in these controllers. In this case the controller is usually a so-called FPGA chip with *.rbf firmware.
▪
In addition, each EtherCAT slave has a memory chip, a so-called ESI-EEPROM, for storing its own device description (ESI: EtherCAT Slave Information). On power-up this description is loaded and the EtherCAT communication is set up accordingly. The device description is available from the download area of the Beckhoff website at (https://www.beckhoff.de). All ESI files are accessible there as zip files.
Customers can access the data via the EtherCAT fieldbus and its communication mechanisms. Acyclic mailbox communication or register access to the ESC is used for updating or reading of these data.
The TwinCAT System Manager offers mechanisms for programming all 3 parts with new data, if the slave is set up for this purpose. Generally the slave does not check whether the new data are suitable, i.e. it may no longer be able to operate if the data are unsuitable.
Simplified update by bundle firmware
The update using so-called bundle firmware is more convenient: in this case the controller firmware and the ESI description are combined in a *.efw file; during the update both the firmware and the ESI are changed in the terminal. For this to happen it is necessary
▪
for the firmware to be in a packed format: recognizable by the file name, which also contains the revision number, e.g. ELxxxx-xxxx_REV0016_SW01.efw
▪
for password=1 to be entered in the download dialog. If password=0 (default setting) only the firmware update is carried out, without an ESI update.
▪
for the device to support this function. The function usually cannot be retrofitted; it is a component of many new developments from year of manufacture 2016.
Following the update, its success should be verified
▪
ESI/Revision: e.g. by means of an online scan in TwinCAT ConfigMode/FreeRun – this is a convenient way to determine the revision
▪
Firmware: e.g. by looking in the online CoE of the device
Note
Risk of damage to the device!
Note the following when downloading new device files

• Firmware downloads to an EtherCAT device must not be interrupted
• Flawless EtherCAT communication must be ensured. CRC errors or LostFrames must be avoided.
• The power supply must adequately dimensioned. The signal level must meet the specification.

In the event of malfunctions during the update process the EtherCAT device may become unusable and require re-commissioning by the manufacturer.
Additional information
•
Device description ESI file/XML
•
Firmware explanation
•
Updating controller firmware *.efw
•
FPGA firmware *.rbf
•
Simultaneous updating of several EtherCAT devices


Device description ESI file/XML

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Device description ESI file/XML
Device description ESI file/XML
Note
Attention regarding update of the ESI description/EEPROM
Some slaves have stored calibration and configuration data from the production in the EEPROM. These are irretrievably overwritten during an update.
The ESI device description is stored locally on the slave and loaded on start-up. Each device description has a unique identifier consisting of slave name (9 characters/digits) and a revision number (4 digits). Each slave configured in the System Manager shows its identifier in the EtherCAT tab:
Device identifier consisting of name EL3204-0000 and revision -0016
The configured identifier must be compatible with the actual device description used as hardware, i.e. the description which the slave has loaded on start-up (in this case EL3204). Normally the configured revision must be the same or lower than that actually present in the terminal network.
For further information on this, please refer to the EtherCAT system documentation.
Update of XML/ESI description
The device revision is closely linked to the firmware and hardware used. Incompatible combinations lead to malfunctions or even final shutdown of the device. Corresponding updates should only be carried out in consultation with Beckhoff support.
Display of ESI slave identifier
The simplest way to ascertain compliance of configured and actual device description is to scan the EtherCAT boxes in TwinCAT mode Config/FreeRun:
Scan the subordinate field by right-clicking on the EtherCAT device
If the found field matches the configured field, the display shows
Configuration is identical
otherwise a change dialog appears for entering the actual data in the configuration.
Change dialog
In this example in Fig. Change dialog, an EL3201-0000-0017 was found, while an EL3201-0000-0016 was configured. In this case the configuration can be adapted with the Copy Before button. The Extended Information checkbox must be set in order to display the revision.
Changing the ESI slave identifier
The ESI/EEPROM identifier can be updated as follows under TwinCAT:
▪
Trouble-free EtherCAT communication must be established with the slave.
▪
The state of the slave is irrelevant.
▪
Right-clicking on the slave in the online display opens the EEPROM Update dialog, Fig. EEPROM Update
EEPROM Update
The new ESI description is selected in the following dialog, see Fig. Selecting the new ESI. The checkbox Show Hidden Devices also displays older, normally hidden versions of a slave.
Selecting the new ESI
A progress bar in the System Manager shows the progress. Data are first written, then verified.
The change only takes effect after a restart.
Most EtherCAT devices read a modified ESI description immediately or after startup from the INIT. Some communication settings such as distributed clocks are only read during power-on. The EtherCAT slave therefore has to be switched off briefly in order for the change to take effect.


Firmware explanation

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Firmware explanation
Firmware explanation
Determining the firmware version
Determining the version on laser inscription
Beckhoff EtherCAT slaves feature serial numbers applied by laser. The serial number has the following structure: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with ser. no.: 12 10 03 02:
12 - week of production 12
10 - year of production 2010
03 - firmware version 03
02 - hardware version 02
Determining the version via the System Manager
The TwinCAT System Manager shows the version of the controller firmware if the master can access the slave online. Click on the E-Bus Terminal whose controller firmware you want to check (in the example terminal 2 (EL3204)) and select the tab CoE Online (CAN over EtherCAT).
CoE Online and Offline CoE
Two CoE directories are available:
• online: This is offered in the EtherCAT slave by the controller, if the EtherCAT slave supports this. This CoE directory can only be displayed if a slave is connected and operational.
• offline: The EtherCAT Slave Information ESI/XML may contain the default content of the CoE. This CoE directory can only be displayed if it is included in the ESI (e.g. "Beckhoff EL5xxx.xml").
The Advanced button must be used for switching between the two views.
In Fig. Display of EL3204 firmware version the firmware version of the selected EL3204 is shown as 03 in CoE entry 0x100A.
Display of EL3204 firmware version
In (A) TwinCAT 2.11 shows that the Online CoE directory is currently displayed. If this is not the case, the Online directory can be loaded via the Online option in Advanced Settings (B) and double-clicking on AllObjects.


Updating controller firmware *.efw

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Updating controller firmware *.efw
Updating controller firmware *.efw
CoE directory
The Online CoE directory is managed by the controller and stored in a dedicated EEPROM, which is generally not changed during a firmware update.
Switch to the Online tab to update the controller firmware of a slave, see Fig. Firmware Update.
Firmware Update
Proceed as follows, unless instructed otherwise by Beckhoff support. Valid for TwinCAT 2 and 3 as EtherCAT master.
▪
Switch TwinCAT system to ConfigMode/FreeRun with cycle time >= 1 ms (default in ConfigMode is 4 ms). A FW-Update during real time operation is not recommended.
▪
Switch EtherCAT Master to PreOP
▪
Switch slave to INIT (A)
▪
Switch slave to BOOTSTRAP
▪
Check the current status (B, C)
▪
Download the new *efw file (wait until it ends). A pass word will not be neccessary usually.
▪
After the download switch to INIT, then PreOP
▪
Switch off the slave briefly (don't pull under voltage!)
▪
Check within CoE 0x100A, if the FW status was correctly overtaken.


FPGA firmware *.rbf

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] FPGA firmware *.rbf
FPGA firmware *.rbf
If an FPGA chip deals with the EtherCAT communication an update may be accomplished via an *.rbf file.
▪
Controller firmware for processing I/O signals
▪
FPGA firmware for EtherCAT communication (only for terminals with FPGA)
The firmware version number included in the terminal serial number contains both firmware components. If one of these firmware components is modified this version number is updated.
Determining the version via the System Manager
The TwinCAT System Manager indicates the FPGA firmware version. Click on the Ethernet card of your EtherCAT strand (Device 2 in the example) and select the Online tab.
The Reg:0002 column indicates the firmware version of the individual EtherCAT devices in hexadecimal and decimal representation.
FPGA firmware version definition
If the column Reg:0002 is not displayed, right-click the table header and select Properties in the context menu.
Context menu Properties
The Advanced Settings dialog appears where the columns to be displayed can be selected. Under Diagnosis/Online View select the '0002 ETxxxx Build' check box in order to activate the FPGA firmware version display.
Dialog Advanced Settings
Update
For updating the FPGA firmware
▪
of an EtherCAT coupler the coupler must have FPGA firmware version 11 or higher;
▪
of an E-Bus Terminal the terminal must have FPGA firmware version 10 or higher.
Older firmware versions can only be updated by the manufacturer!
Updating an EtherCAT device
The following sequence order have to be met if no other specifications are given (e.g. by the Beckhoff support):
▪
Switch TwinCAT system to ConfigMode/FreeRun with cycle time >= 1 ms (default in ConfigMode is 4 ms). A FW-Update during real time operation is not recommended.
▪
In the TwinCAT System Manager select the terminal for which the FPGA firmware is to be updated (in the example: Terminal 5: EL5001) and
click the Advanced Settings button in the EtherCAT tab:
▪
The Advanced Settings dialog appears. Under ESC Access/E²PROM/FPGA click on Write FPGA button:
▪
Select the file (*.rbf) with the new FPGA firmware, and transfer it to the EtherCAT device:
▪
Wait until download ends
▪
Switch slave current less for a short time (don't pull under voltage!). In order to activate the new FPGA firmware a restart (switching the power supply off and on again) of the EtherCAT device is required.
▪
Check the new FPGA status
Note
Risk of damage to the device!
A download of firmware to an EtherCAT device must not be interrupted in any case! If you interrupt this process by switching off power supply or disconnecting the Ethernet link, the EtherCAT device can only be recommissioned by the manufacturer!


Simultaneous updating of several EtherCAT devices

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Simultaneous updating of several EtherCAT devices
Simultaneous updating of several EtherCAT devices
The firmware and ESI descriptions of several devices can be updated simultaneously, provided the devices have the same firmware file/ESI.
Multiple selection and firmware update
Select the required slaves and carry out the firmware update in BOOTSTRAP mode as described above.


Firmware compatibility - passive terminals

Appendix [image] Firmware compatibility - passive terminals
Firmware compatibility - passive terminals
The passive terminals ELxxxx terminal series have no firmware to update.


Restoring the delivery state

Appendix [image] Restoring the delivery state
Restoring the delivery state
To restore the delivery state for backup objects in ELxxxx terminals, the CoE object Restore default parameters, SubIndex 001 can be selected in the TwinCAT System Manager (Config mode) (see Fig. Selecting the Restore default parameters PDO)
Selecting the "Restore default parameters" PDO
Double-click on SubIndex 001 to enter the Set Value dialog. Enter the value 1684107116 in field Dec or the value 0x64616F6C in field Hex and confirm with OK (Fig. Entering a restore value in the Set Value dialog).
All backup objects are reset to the delivery state.
Entering a restore value in the Set Value dialog
Alternative restore value
In some older terminals the backup objects can be switched with an alternative restore value: Decimal value: 1819238756, Hexadecimal value: 0x6C6F6164An incorrect entry for the restore value has no effect.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com