EL34xx - 3-phase energy and power measurement terminals
Home


Product overview – Power measurement terminals

Product overview – Power measurement terminals
Product overview – Power measurement terminals
EL3423
3-phase power measurement terminal, Economy; 480 VAC, 1 A
EL3443
3-phase power measurement terminal with extended functionality; 480 VAC, 1 A
EL3443-0010
3-phase power measurement terminal with extended functionality; 480 VAC, 5 A
EL3443-0011
3-phase power measurement terminal with extended functionality; 480 VAC, 100 mA
EL3443-0013
3-phase power measurement terminal with extended functionality; 480 VAC, 333 mV
EL3446
6-channel current input terminal for distributed power measurement; 1 A AC/DC
EL3453
3-phase power measurement terminal with extended functionality; 690 VAC, 5 A
EL3453-0100
3-phase power measurement terminal with extended functionality; 100 VAC (ULx – N), for current transformers
EL3483
3-phase mains monitoring terminal for voltage, frequency and phase; 480 VAC
EL3483-0060
3-phase mains monitoring terminal with voltage measurement; 480 VAC


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status
•
Version identification of EtherCAT devices


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
2.0
▪
Chapter “Application examples” updated
▪
Update structure
▪
Update revision status
1.9
▪
EL3446 added
▪
EL3453-0100 added
▪
Chapter “Application examples” updated
▪
Update structure
▪
Update revision status
1.8
▪
Chapter “Application examples” updated
▪
Update structure
▪
Update revision status
1.7
▪
Chapter “Object description and parameterization” updated
▪
Update structure
▪
Update revision status
1.6
▪
Chapter “Application examples” updated
▪
Update structure
▪
Update revision status
1.5
▪
Update structure
▪
Update revision status
1.4
▪
EL3443-0011, EL3443-0013, EL3483-0060 added
▪
Update structure
▪
Update revision status
1.3
▪
EL3453 added
▪
Update structure
▪
Update revision status
1.2
▪
Addenda chapter “TcEventLogger and IO” (Appendix)
1.1
▪
Chapter “Technical data” updated
1.0
▪
1st public release
0.2 – 0.5
▪
Complements, corrections
0.1
▪
Provisional documentation for EL34xx


Version identification of EtherCAT devices

Foreword [image] Version identification of EtherCAT devices
Version identification of EtherCAT devices
Designation
A Beckhoff EtherCAT device has a 14-digit designation, made up of
▪
family key
▪
type
▪
version
▪
revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
Notes
▪
The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
▪
EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
▪
The order identifier is made up of
- family key (EL, EP, CU, ES, KL, CX, etc.)
- type (3314)
- version (-0000)
▪
The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
▪
The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Identification number
Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:
Production lot/batch number/serial number/date code/D number
The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02
Exceptions can occur in the IP67 area, where the following syntax can be used (see respective device documentation):
Syntax: D ww yy x y z u
D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB
Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1
Unique serial number/ID, ID number
In addition, in some series each individual module has its own unique serial number.
See also the further documentation in the area
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Terminals with factory calibration certificate and other measuring terminals
Examples of markings
EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
Additional information
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Foreword [image] Version identification of EtherCAT devices [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Product overview

Product overview
Product overview
Additional information
•
EL34xx – Introduction
•
Technical data
•
Basic function principles
•
Current transformers
•
Start


EL34xx – Introduction

Product overview [image] EL34xx – Introduction
EL34xx – Introduction
EL3423 | 3-phase power measurement terminal, Economy
EL3423
The EL3423 EtherCAT Terminal enables measurement of relevant data for an efficient energy management system. The voltage is measured internally via direct connection of L1, L2, L3 and N. The current of the three phases L1, L2 and L3 is fed via simple current transformers (e.g. the SCT series from Beckhoff).
The measured energy values are available separately as generated and accepted values. In the EL3423 version, the active power and the energy consumption for each phase are calculated. In addition, an internally calculated power quality factor provides information about the quality of the monitored power supply. The EL3423 offers basic functionality for mains analysis and energy management.
EL3443 | 3-phase power measurement terminal with extended functionality
EL3443
The EL3443 EtherCAT Terminal enables measurement of all relevant electrical data of the mains supply and performs simple pre-evaluations. The voltage is measured via the direct connection of L1, L2, L3 and N. The current of the three phases L1, L2 and L3 is fed via simple current transformers (e.g. the SCT series from Beckhoff).
All measured currents and voltages are available as RMS values. In the EL3443 version, the active power and the energy consumption for each phase are calculated. The RMS values of voltage U and current I as well as active power P, apparent power S, reactive power Q, frequency f, phase shift angle cos φ and harmonics are available. The EL3443 offers options for comprehensive grid analysis and energy management.
Variants:
▪
EL3443-0000: Version with direct current measurement up to 1 A
▪
EL3443-0010: Version with direct current measurement up to 5 A
▪
EL3443-0011: Version with direct current measurement 100 mA
▪
EL3443-0013: Version with direct voltage measurement 333 mV
EL3446 | 6-channel current input terminal 1 A AC/DC for distributed power measurement
EL3446
The EL3446 EtherCAT Terminal enables the measurement of all relevant electrical data of the supply network and carries out simple pre-evaluation. Since the EL3446 itself has no voltage inputs, the voltage measured values are transmitted via EtherCAT by an EL3443 to be installed once per network.
The current of up to six phases is fed via simple current transformers. All measured currents and voltages are available as root-mean-square values. In the EL3446 terminal, the effective power and energy consumption for each phase are calculated.
The RMS values of voltage U and current I as well as the active power P, apparent power S, reactive power Q, frequency f, phase shift angle cos φ and harmonic are available. The EL3446 offers extended functionality for mains analysis and energy management.
EL3453 | 3-phase power measurement terminal up to 690 V AC with extended functionality
EL3453
The EL3453 EtherCAT power measurement terminal is an advancement based on the EL3413. With up to 690 V AC, the voltage inputs are optimised for the direct monitoring of high-capacity generators, as in the wind power industry, for example. No upstream voltage transformer is required.
The four current inputs are electrically isolated so that the terminal can be used in all common grounded current transformer configurations such as 2- or 3-transformer configurations with star or delta connection incl. neutral conductor current measurement. The EL3453 can be used for simple grid analysis up to the 63rd harmonics analysis. Alternatively, all readings can be combined in a power quality factor for simplified diagnostics. Like all measured terminal data, the harmonic content can be read via the process data.
EL3483 | 3-phase mains monitoring terminal for voltage, frequency and phase
EL3483
The EL3483 EtherCAT Terminal enables monitoring of relevant electrical data of the supply network. The voltage is measured internally via direct connection of L1, L2, L3 and N. The internal measured values are compared with threshold values preset by the user. The result is available as digital information in the process image.
The EL3483 monitors the correct phase sequence L1, L2, L3, phase failure, undervoltage and overvoltage and possible phase imbalance. An error bit is set in case of an incorrect phase sequence or phase failure. If, for example, an imbalance or voltage fault occurs, only a warning bit is set initially. In addition, an internally calculated power quality factor provides information about the quality of the monitored power supply. The EL3483 offers options for simple mains analysis and network control.
The EL3483-0060 variant also outputs the current effective voltage values in the process image.
Quick links
Also see about this
•
Basic function principles
•
Technical data
•
Object description and parameterization
•
Process data
•
Application examples


Technical data

Product overview [image] Technical data
Technical data
EL3423
Technical data | EL3423
Number of inputs | 3 x current, 3 x voltage
Technology | 3-phase power measurement
Oversampling factor | –
Distributed clocks | –
Update interval | >10 s adjustable
Measured values | energy, power, power quality factor
Measuring voltage | max. 480 V AC 3~ (ULX-N: max. 277 V AC; max. 240 V DC)
Measuring current | max. 1 A (AC/DC), via measuring transformers x A/1 A
Measuring error | 0.5% relative to full scale value (U/I), 1% calculated values
Update time | mains-synchronous
Frequency range | 0 (direct current) and 12 ... 400 Hz
Electrical isolation | 2500 V
Current consumption power contacts | -
Current consumption E -Bus | typ. 120 mA
Special features | single-phase operation possible, mains monitoring functionality
Configuration | via TwinCAT System Manager
Weight | approx. 75 g
Dimensions (W x H x D) | approx. 15 mm x 100 mm x 70 mm (width aligned: 12 mm)
Mounting | on 35 mm mounting rail according to EN 60715
Permissible ambient temperature range during operation | -25°C ... +60°C (extended temperature range)
Permissible ambient temperature range during storage | -40°C ... +85°C
Relative humidity | 95 % no condensation
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2/EN 61000-6-4
Protect. class / installation pos. | IP20/any
Approvals | CE
EL3443-00xx
Technical data | EL3443-0000 | EL3443-0010 | EL3443-0011 | EL3443-0013
Number of inputs | 3 x current, 3 x voltage
Technology | 3-phase power measurement
Oversampling factor | –
Distributed clocks | Optional (for determining the zero crossing time)
Activation interval | one mains period (20 ms at 50 Hz)
Measured values | Current, voltage, active power, reactive power, apparent power, active energy, reactive energy, apparent energy, cos φ, frequency, THD, harmonics (up to 40th harmonic), power quality factor
Measuring voltage | max. 480 V AC 3~ (ULX-N: max. 277 V AC; max 240 V DC)
Measuring current | max. 1 A (AC/DC), via measuring transformers x A/1 A | max. 5 A (AC/DC), via measuring transformers x A/5 A | max. 100 mA (AC/DC), via measuring transformers x A/5 A | max. 333 mV (AC/DC), via measuring transformers x A/333 mV
Measuring error | 0.3% relative to the full scale value (U/I), 0.6% calculated values (see documentation)
Threshold frequency | 3000 Hz
Electrical isolation | 2500 V
Update time | mains-synchronous
Current consumption power contacts | –
Current consumption via E-bus | typ. 120 mA
Special features | Single-phase operation possible, mains monitoring functionality, precise voltage zero crossing determination
Weight | approx. 75 g
Dimensions (W x H x D) | approx. 15 mm x 100 mm x 70 mm (width aligned: 12 mm)
Mounting | on 35 mm mounting rail according to EN 60715
Permissible ambient temperature range during operation | -25°C ... +60°C (extended temperature range)
Permissible ambient temperature range during storage | -40°C ... +85°C
Relative humidity | 95 % no condensation
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2/EN 61000-6-4
Protect. class / installation pos. | IP20/any
Approvals | CE
EL3446
Technical data | EL3446
Number of inputs | 6 x current
Technology | 6-channel distributed power measurement
Oversampling factor | –
Distributed clocks | optional (necessary for distributed power measurement)
Update interval | one mains period (20 ms at 50 Hz)
Update time | net-synchronous
Measured values | current, voltage, effective, reactive and apparent power, active, reactive and apparent energy, cos phi, frequency, THD, harmonic (up to 40th harmonic)
Measuring current | max. 1 A (AC/DC), via measuring transformers A/1 A
Measuring error | 0.3 % relative to full scale value (U/I), 0.6 % calculated values (see documentation)
Electrical isolation | 2500 V
Current consumption power contacts | –
Current consumption E-bus | typ. 120 mA
Special features | In combination with an EL3443, the EL3446 allows the measurement of real power values (for apparent, reactive and active power) via distributed power measurement.
Weight | approx. 75 g
Electrical isolation | 2500 V
Dimensions (W x H x D) | approx. 15 mm x 100 mm x 70 mm (width aligned: 12 mm)
Mounting | on 35 mm mounting rail according to EN 60715
Permissible ambient temperature range during operation | 0°C ... +55°C
Permissible ambient temperature range during storage | -25°C ... +85°C
Relative humidity | 95 % no condensation
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2/EN 61000-6-4
Protect. class / installation pos. | IP20/any
Approvals | CE
EL3453
Technical data | EL3453 | EL3453-0100
Number of inputs | 4 x current, 3 x voltage
Technology | 3-phase power measurement
Oversampling-factor | –
Distributed-Clocks | Optional (for zero crossing time determination)
Accuracy of Distributed Clocks | << 1 µs
Update time | with every half-wave (10 ms at 50 Hz)
Measured values | Current, voltage, active power, reactive power, apparent power, active energy, reactive energy, apparent energy, fundamental wave power and energy, cos φ, frequency, THD, harmonics (up to 63rd harmonic), power quality factor
Measuring error | 0.3 % relative to full scale value (U/I) 0.6 % calculated values (see documentation)
Mains voltage (Nominal voltage range) | corresponding to AC: 400 Vrms (ULX-N) or 690 Vrms (ULX-ULY) (TN-system: 600 Vrms) | corresponding to AC: 100 Vrms (ULX-N) for current transformers)
Technical measuring range Voltage | 520 Vrms (ULX-N) or 897 Vrms (ULX-ULY) common reference potential N/GND max. time for voltages above 500 Vrms (ULX-N) or 863 Vrms (ULx-ULy): tmax < 10s * | 145 Vrms (ULX-N) common reference potential N/GND
Maximum permissible overvoltage | max. ±736 V (peak value, ULX-N, corresponds to 520 Vrms) or max. ±1270 V (peak value, ULX-ULY, corresponds to 897 Vrms)* | max. 300 Vrms (ULX-N) *
Internal resolution | 24 bits
Input resistance Voltage path | typ. 1,5 MΩ
Nominal current range | corresponding to AC: 100 mArms;1 Arms (default); 5 Arms recommended via measuring transformer x A AC/1 A AC
Technical measuring range current | 2.25 A (peak value, corresponds to 1.59 Arms ) or. 9.6 A (peak value, corresponds to 6.8 Arms )
Maximum permissible overcurrent | max. ±10 A peak value, corresponds to 7 Arms * per channel and max. total current (I1+I2+I3+IN) ±20 A peak value, corresponds to 14 Arms *
Peak overload capacity | 60 A (sinusoidal) for 1 second, upstream use of current-limiting current transformers recommended
Largest short-term deviation during a specified electrical disturbance test | < ±0.5% of full scale value for current measurement
Input resistance Current path | typ. 3 mΩ
Frequency range | 15 … 400 Hz
Threshold frequency | 4000 Hz
Electrical isolation | 4500 V
Current consumption power contacts | –
Current consumption E-Bus | 260 mA typ.
Weight | approx. 100 g
Dimensions (W x H x D) | approx. 27 mm x 100 mm x 70 mm (width aligned: 24 mm)
Mounting | on 35 mm mounting rail according to EN 60715
Permissible ambient temperature range during operation | 0°C ... +55°C
Permissible ambient temperature range during storage | -25°C ... +85°C
Relative humidity | 95 % no condensation
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2/EN 61000-6-4
Protect. class / installation pos. | IP20/any
Approvals | CE
*) prolonged operation above the nominal range can lead to impairment of function and/or shortening of operating life
EL3483
Technical data | EL3483 | EL3483-0060
Number of inputs | 3 x voltage
Technology | 3-phase mains monitor
Oversampling factor | –
Distributed clocks | –
Update interval | 10 mains periods (200 ms at 50 Hz)
Measured values | digital thresholds and power quality factor | digital thresholds and power quality factor, analog voltage measurement
Measuring voltage | max. 480 V AC 3~ (ULX-N: max. 277 V AC; max. 240 V DC)
Measuring procedure | True RMS, True RMS calculation
Update time | mains-synchronous
Electrical isolation | 2500 V
Current consumption power contacts | –
Current consumption E-Bus | typ. 120 mA
Special features | operation as voltage monitor, frequency monitor and phase monitor also possible in single-phase operation
Monitoring function | phase sequence, phase failure, phase imbalance, undervoltage/overvoltage (adjustable)
Weight | approx. 75 g
Dimensions (W x H x D) | approx. 15 mm x 100 mm x 70 mm (width aligned: 12 mm)
Mounting | on 35 mm mounting rail according to EN 60715
Permissible ambient temperature range during operation | -25°C ... +60°C (extended temperature range)
Permissible ambient temperature range during storage | -40°C ... +85°C
Relative humidity | 95 % no condensation
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2/EN 61000-6-4
Protect. class / installation pos. | IP20/any
Approvals | CE
Measuring transformers
Suitable measuring transformers for use with the energy and power measuring terminals are available with the SCT series from Beckhoff.


Basic function principles

Product overview [image] Basic function principles
Basic function principles
Measuring principle
The EL3443 works with 6 analog/digital converters for recording the current and voltage values of all 3 phases.
Recording and processing is synchronous and identical for the 3 phases. The signal processing for one phase is described below. This description applies correspondingly for all 3 phases.
Voltage u and current i curves
RMS value calculation
The RMS value for voltage and current is calculated during the period T. The following equations are used:
u(t): instantaneous voltage value
i(t): instantaneous current value
n: number of measured values
The instantaneous values for current and voltage are low-pass filtered with a cut-off frequency of 2.5 kHz for the EL3443, EL3423 and EL3483.
Active power measurement
The EL34xx measures the active power P according to the following equation
P: active power
n: number of samples
u(t): instantaneous voltage value
i(t): instantaneous current value
Power s(t) curve
In the first step, the power s(t) is calculated at each sampling instant:
The mean value is calculated over a period.
The power frequency is twice that of the corresponding voltages and currents.
Apparent power measurement
In real networks, not all consumers are purely ohmic. Phase shifts occur between current and voltage. This does not affect the methodology for determining the RMS values of voltage and current as described above.
The situation for the active power is different: Here, the product of RMS voltage and RMS current is the apparent power.
The active power is smaller than the apparent power.
S: apparent power
P: active power
Q: reactive power
φ: Phase shift angle
u, i, p curves with phase shift angle (t) (t) (t)
In this context, further parameters of the mains system and its consumers are significant:
▪
apparent power S
▪
reactive power Q
▪
power factor cos φ
The EL3443 determines the following values:
▪
RMS voltage U and RMS current I
▪
Active power P and active energy E
▪
Apparent power S and apparent energy
▪
Reactive power Q and reactive energy
▪
Power factor and cos(φ)
▪
Distortion factors for current THDI and voltage THDU
▪
Calculated RMS neutral conductor current IN
▪
Voltage imbalance
▪
Power quality factor (details see below)
▪
In "DC synchronous" mode, the distributed clock time of the voltage zero crossing is also available.
Sign for power measurement
The sign of the (fundamental wave) active power P and the power factor cos φ provides information about the direction of the energy flow. A positive sign indicates the motor mode, a negative sign indicates generator mode.
Furthermore, the sign of the fundamental harmonic reactive power Q provides information about the direction of the phase shift between current and voltage. Fig. Four-quadrant representation of active/fundamental harmonic reactive power in motor and generator mode illustrates this. In motor mode (quadrant I + IV), a positive fundamental harmonic reactive power indicates an inductive load, a negative fundamental harmonic reactive power indicates a capacitive load. The information about a capacitive or inductive load behavior is also shown in the sign of the phase angle φ, which is already contained in the EL3443.
In generator mode (quadrant II & III), an inductive generator is indicated by a positive fundamental harmonic reactive power, a capacitive generator by a negative fundamental harmonic reactive power.
Since the total reactive power is defined as the quadratic difference between apparent and active power, it has no sign. For the total active power, signs are permitted, as described above.
Four-quadrant representation of active power/fundamental harmonic reactive power in motor and generator mode
Frequency measurement
The EL34xx can measure the frequency for a voltage path input signal and a current path input signal. CoE objects "Reference" and "Frequency Source" (F800:11 and F800:13) can be used to set which frequency is to be output as PDO.
Power quality factor
The EL34xx calculates a PQF (power quality factor), which reflects the quality of the voltage supply as a simplified analog value between 1.0 and 0.
To calculate this factor, the measured values, frequency, RMS voltage, distortion factor and voltage imbalance are calculated and combined as shown in the following diagram.
Representation of the power quality factor calculation
As can be seen for the time value 120, the calculation method is chosen in such a way that even very short voltage drops cause a clear signal deflection.
The value above which the power supply is to be regarded as "sufficiently good" is strongly dependent on the connected application. The more sensitive the application, the higher the minimum limit value of the PQF should be.
To adapt the power quality factor to your mains supply, enter the nominal voltage and frequency in CoE object "0xF801 PMX Total Settings PQF". This can also be done via the "Settings" tab, which summarizes all the important terminal setting options in a user-friendly manner.
Voltage zero crossing
The EL3443 and EL3453 have the ability to determine the exact time of a voltage zero crossing. However, in order for this to be transmitted to a higher-level controller in a meaningful manner, the controller and the EtherCAT Terminal must have the same time base. Using distributed clocks technology, an EtherCAT system provides such a common time base (for details see EtherCAT system description). In order to be able to use these, the EL3443 must be in "DC synchronous" mode and the EtherCAT master must support the corresponding function.
Once these basic requirements have been met, the EL3443 and EL3453 provide the DC time of the penultimate zero crossing. In order to facilitate exact determination of the fundamental wave, the voltage signal to be evaluated must first be filtered, which inevitably entails a delay. In addition to the time of the voltage zero crossing, the EL3453 also determines the respective current zero crossings.
Statistical evaluation
In addition to the cyclic data, the EL34xx terminals also produce statistical evaluations over longer periods (can be set in the CoE: "F803 PMX Time Settings"). By default, the "F803:12 Measurement Interval" is set to 15 minutes. The clock available for this purpose in the terminal can not only be read out via the CoE object "F803:13 Actual System Time", it can also be actively influenced. Depending on the application, it may make sense to regularly synchronize the clock with an external clock. By default, the clock is set once at system startup based on the local Windows system time, taking into account the set time zone, usually UTC.
In addition, the interval can also be restarted manually via the "Reset Interval" output bit or directly from the application, for example to obtain statistics on a process that varies over time.
Calculation of the neutral current
Since the EL34xx terminals have direct access to the instantaneous current values of all three phases, the neutral current can be calculated or estimated, assuming that no current is lost to the system (in other words: the differential current is zero). The calculated (i.e. not measured) current value is output in index "F601:13 Calculated Neutral Line Current".
Since in the worst case all measurement errors add up, the maximum measurement error is correspondingly higher.
The additional possibility of measuring a fourth current value in the EL3453 means that either the differential current or the neutral current can be calculated. The other current can be measured directly using the fourth current channel. Due to the usual conditions and the corresponding measurement tolerances, however, it makes much more sense to measure the differential current with the aid of a summation current transformer and have the neutral conductor current calculated. Further information on this can be found in the chapter Application examples under the section Power measurement including residual current measurement.
Harmonic calculation
The EL34xx terminals perform an internal harmonic analysis for all current and voltage channels. For this purpose, a fundamental wave in the frequency range from 45 to 65 Hz is determined at the beginning (separately from the system frequency). The frequency value determined for the voltage harmonics can be read, for example, from index 99 (plus channel offset) of the variable output values and the amplitude in volts from index 98. The same applies to the current values - see "Variable output values".
The actual harmonic measured values are output as a percentage of the fundamental wave amplitude. It should also be noted that the zero harmonic indicates the DC component of the signal.


Current transformers

Product overview [image] Current transformers
Current transformers
In principle, the choice of current transformer for the EL34xx is not critical. The internal resistance within the current circuit of the EL34xx is so small that it is negligible for the calculation of the total resistances of the current loop. The transformers should be able to produce a secondary rated current of 1 A. The primary rated current Ipn can be selected arbitrarily. The common permissible overload of 1.2 x Ipn is no problem for the EL34xx, but may lead to small measuring inaccuracies.
Measuring transformers
Suitable measuring transformers for use with the energy and power measuring terminals are available with the SCT series from Beckhoff.
Accuracy
Please note that the overall accuracy of the set-up consisting of EL34xx and current transformers to a large degree depends on the accuracy class of the transformers.
No approval as a billing meter
Even an arrangement with a current transformer of class 0.5 or better is not subject to approval and certification. The EL34xx is not an approved billing meter within the meaning of the standard for electricity meters (DIN 43 856).
Note
DC currents with the EL3453
DC currents can lead to saturation of the internal current transformers and thus to measurement errors!
Current types
The EL34xx can measure any current type up to a limiting proportion of 400 Hz. Since such currents are frequently created by inverters and may contain frequencies of less than 50 Hz or even a DC component, electronic transformers should be used for such applications.
Overcurrent limiting factor FS
The overcurrent limiting factor FS of a current transformer indicates at what multiple of the primary rated current the current transformer changes to saturation mode, in order to protect the connected measuring instruments.
Note
Attention! Risk of damage to the device!
The EL34xx-xxxx must not be subjected to continuous loads that exceed the current values specified in the technical data! In systems, in which the overcurrent limiting factors of the transformers allow higher secondary currents, additional intermediate transformers with a suitable ratio should be used.
Note
Attention! Risk of damage to the device!
The EL3453-xxxx must not be permanently loaded with more than I1 + I2 + I3 + IN = 20 A total current across all channels!
Protection against dangerous touch voltages
During appropriate operation of the EL34xx with associated current transformers, no dangerous voltages occur. The secondary voltage is in the range of a few Volts. However, the following faults may lead to excessive voltages:
▪
Open current circuit of one or several transformers
▪
Neutral conductor cut on the voltage measurement side of the EL34xx
▪
General insulation fault
SmallWarningYellow WARNING
WARNING Risk of electric shock!
The complete wiring of the EL34xx must be protected against accidental contact and equipped with associated warnings! The insulation should be designed for the maximum conductor voltage of the system to be measured!
The EL34xx allows a maximum voltage of 480 V for normal operating conditions. The conductor voltage on the current side must not exceed this value! For higher voltages, an intermediate transformer stage should be used!
An EL34xx is equipped with a protection impedance of typically 1.2 MΩ on the voltage measurement side. If the neutral conductor is not connected and only one connection on the side of the voltage measurement is live, the resulting voltage against earth in a 3-phase system with a phase-to-phase voltage of 400 VAC is 230 VAC. This should also be measured on the side of the current measurement using a multimeter with an internal resistance of 10 MΩ, which does not represent an insulation fault.
Connection cable for current transformers
Please note the following minimum power values for current transformers to be connected:
 | Rated secondary transformer current
 | 1 A | 1 A | 1 A | 1 A | 5 A | 5 A | 5 A | 5 A
Cross-section | 0.5 mm² | 1 mm² | 1.5 mm² | 2.5 mm² | 0.5 mm² | 1 mm² | 1.5 mm² | 2.5 mm²
1 m | 0.3 | 0.2 | 0.2 | 0.2 | 2.4 | 1.3 | 0.9 | 0.6
2 m | 0.4 | 0.3 | 0.3 | 0.2 | 4.6 | 2.4 | 1.7 | 1.1
3 m | 0.5 | 0.3 | 0.3 | 0.3 | 6.8 | 3.5 | 2.4 | 1.5
4 m | 0.6 | 0.4 | 0.3 | 0.3 | 9.0 | 4.6 | 3.1 | 2.0
5 m | 0.6 | 0.4 | 0.3 | 0.3 | 11.2 | 5.7 | 3.9 | 2.4
10 m | 1.1 | 0.6 | 0.5 | 0.4 | 22.2 | 11.2 | 7.5 | 4.6
20 m | 2.0 | 1.1 | 0.8 | 0.6 | 44.2 | 22.2 | 14.9 | 9.0
30 m | 2.8 | 1.5 | 1.1 | 0.7 | 66.2 | 33.2 | 22.2 | 13.4
40 m | 3.7 | 2.0 | 1.4 | 0.9 | 88.2 | 44.2 | 29.5 | 17.8
50 m | 4.6 | 2.4 | 1.7 | 1.1 | 110.2 | 55.2 | 36.9 | 22.2
100 m | 9.0 | 4.6 | 3.1 | 2.0 | 220.2 | 110.2 | 73.5 | 44.2
Cable length | Minimum operating load in VA for current transformers with copper cables and 80 °C operating temperature
Additional measuring devices in the current circuit
Please note that the addition of additional measuring devices (e.g. ammeters) in the current circuit can lead to a significant increase in the total apparent power.
Furthermore, connection IN of the EL34xx must represent a star point for the three secondary windings. Additional measuring devices therefore have to be potential-free and must be wired accordingly.


Start

Product overview [image] Start
Start
For commissioning:
▪
mount the EL34xx as described in the chapter Mounting and wiring
▪
configure the EL34xx in TwinCAT as described in the chapter Commissioning.


Basics communication

Basics communication
Basics communication
Additional information
•
EtherCAT basics
•
EtherCAT cabling – wire-bound
•
General notes for setting the watchdog
•
EtherCAT State Machine
•
CoE Interface
•
Distributed Clock


EtherCAT basics

Basics communication [image] EtherCAT basics
EtherCAT basics
Please refer to the EtherCAT System Documentation for the EtherCAT fieldbus basics.


EtherCAT cabling – wire-bound

Basics communication [image] EtherCAT cabling – wire-bound
EtherCAT cabling – wire-bound
The cable length between two EtherCAT devices must not exceed 100 m. This results from the FastEthernet technology, which, above all for reasons of signal attenuation over the length of the cable, allows a maximum link length of 5 + 90 + 5 m if cables with appropriate properties are used. See also the Design recommendations for the infrastructure for EtherCAT/Ethernet.
Cables and connectors
For connecting EtherCAT devices only Ethernet connections (cables + plugs) that meet the requirements of at least category 5 (CAt5) according to EN 50173 or ISO/IEC 11801 should be used. EtherCAT uses 4 wires for signal transfer.
EtherCAT uses RJ45 plug connectors, for example. The pin assignment is compatible with the Ethernet standard (ISO/IEC 8802-3).
Pin | Color of conductor | Signal | Description
1 | yellow | TD + | Transmission Data +
2 | orange | TD - | Transmission Data -
3 | white | RD + | Receiver Data +
6 | blue | RD - | Receiver Data -
Due to automatic cable detection (auto-crossing) symmetric (1:1) or cross-over cables can be used between EtherCAT devices from Beckhoff.
Recommended cables
Suitable cables for the connection of EtherCAT devices can be found on the Beckhoff website!
E-Bus supply
A bus coupler can supply the EL terminals added to it with the E-bus system voltage of 5 V; a coupler is thereby loadable up to 2 A as a rule (see details in respective device documentation).
Information on how much current each EL terminal requires from the E-bus supply is available online and in the catalogue. If the added terminals require more current than the coupler can supply, then power feed terminals (e.g. EL9410) must be inserted at appropriate places in the terminal strand.
The pre-calculated theoretical maximum E-Bus current is displayed in the TwinCAT System Manager. A shortfall is marked by a negative total amount and an exclamation mark; a power feed terminal is to be placed before such a position.
System manager current calculation
Note
Malfunction possible!
The same ground potential must be used for the E-Bus supply of all EtherCAT terminals in a terminal block!


General notes for setting the watchdog

Basics communication [image] General notes for setting the watchdog
General notes for setting the watchdog
ELxxxx terminals are equipped with a safety feature (watchdog) that switches off the outputs after a specifiable time e.g. in the event of an interruption of the process data traffic, depending on the device and settings, e.g. in OFF state.
The EtherCAT slave controller (ESC) in the EL2xxx terminals features 2 watchdogs:
▪
SM watchdog (default: 100 ms)
▪
PDI watchdog (default: 100 ms)
SM watchdog (SyncManager Watchdog)
The SyncManager watchdog is reset after each successful EtherCAT process data communication with the terminal. If no EtherCAT process data communication takes place with the terminal for longer than the set and activated SM watchdog time, e.g. in the event of a line interruption, the watchdog is triggered and the outputs are set to FALSE. The OP state of the terminal is unaffected. The watchdog is only reset after a successful EtherCAT process data access. Set the monitoring time as described below.
The SyncManager watchdog monitors correct and timely process data communication with the ESC from the EtherCAT side.
PDI watchdog (Process Data Watchdog)
If no PDI communication with the EtherCAT slave controller (ESC) takes place for longer than the set and activated PDI watchdog time, this watchdog is triggered.
PDI (Process Data Interface) is the internal interface between the ESC and local processors in the EtherCAT slave, for example. The PDI watchdog can be used to monitor this communication for failure.
The PDI watchdog monitors correct and timely process data communication with the ESC from the application side.
The settings of the SM- and PDI-watchdog must be done for each slave separately in the TwinCAT System Manager.
EtherCAT tab -> Advanced Settings -> Behavior -> Watchdog
Notes:
▪
the multiplier is valid for both watchdogs.
▪
each watchdog has its own timer setting, the outcome of this in summary with the multiplier is a resulting time.
▪
Important: the multiplier/timer setting is only loaded into the slave at the start up, if the checkbox is activated.
If the checkbox is not activated, nothing is downloaded and the ESC settings remain unchanged.
Multiplier
Multiplier
Both watchdogs receive their pulses from the local terminal cycle, divided by the watchdog multiplier:
1/25 MHz * (watchdog multiplier + 2) = 100 µs (for default setting of 2498 for the multiplier)
The standard setting of 1000 for the SM watchdog corresponds to a release time of 100 ms.
The value in multiplier + 2 corresponds to the number of basic 40 ns ticks representing a watchdog tick.
The multiplier can be modified in order to adjust the watchdog time over a larger range.
Example "Set SM watchdog"
This checkbox enables manual setting of the watchdog times. If the outputs are set and the EtherCAT communication is interrupted, the SM watchdog is triggered after the set time and the outputs are erased. This setting can be used for adapting a terminal to a slower EtherCAT master or long cycle times. The default SM watchdog setting is 100 ms. The setting range is 0...65535. Together with a multiplier with a range of 1...65535 this covers a watchdog period between 0...~170 seconds.
Calculation
Multiplier = 2498 → watchdog base time = 1 / 25 MHz * (2498 + 2) = 0.0001 seconds = 100 µs
SM watchdog = 10000 → 10000 * 100 µs = 1 second watchdog monitoring time
SmallWarningYellow CAUTION
Undefined state possible!
The function for switching off of the SM watchdog via SM watchdog = 0 is only implemented in terminals from version -0016. In previous versions this operating mode should not be used.
SmallWarningYellow CAUTION
Damage of devices and undefined state possible!
If the SM watchdog is activated and a value of 0 is entered the watchdog switches off completely. This is the deactivation of the watchdog! Set outputs are NOT set in a safe state, if the communication is interrupted.


EtherCAT State Machine

Basics communication [image] EtherCAT State Machine
EtherCAT State Machine
The state of the EtherCAT slave is controlled via the EtherCAT State Machine (ESM). Depending upon the state, different functions are accessible or executable in the EtherCAT slave. Specific commands must be sent by the EtherCAT master to the device in each state, particularly during the bootup of the slave.
A distinction is made between the following states:
▪
Init
▪
Pre-Operational
▪
Safe-Operational and
▪
Operational
▪
Boot
The regular state of each EtherCAT slave after bootup is the OP state.
States of the EtherCAT State Machine
Init
After switch-on the EtherCAT slave in the Init state. No mailbox or process data communication is possible. The EtherCAT master initializes sync manager channels 0 and 1 for mailbox communication.
Pre-Operational (Pre-Op)
During the transition between Init and Pre-Op the EtherCAT slave checks whether the mailbox was initialized correctly.
In Pre-Op state mailbox communication is possible, but not process data communication. The EtherCAT master initializes the sync manager channels for process data (from sync manager channel 2), the FMMU channels and, if the slave supports configurable mapping, PDO mapping or the sync manager PDO assignment. In this state the settings for the process data transfer and perhaps terminal-specific parameters that may differ from the default settings are also transferred.
Safe-Operational (Safe-Op)
During transition between Pre-Op and Safe-Op the EtherCAT slave checks whether the sync manager channels for process data communication and, if required, the distributed clocks settings are correct. Before it acknowledges the change of state, the EtherCAT slave copies current input data into the associated DP-RAM areas of the EtherCAT slave controller (ECSC).
In Safe-Op state mailbox and process data communication is possible, although the slave keeps its outputs in a safe state, while the input data are updated cyclically.
Outputs in SAFEOP state
The default set watchdog monitoring sets the outputs of the module in a safe state - depending on the settings in SAFEOP and OP - e.g. in OFF state. If this is prevented by deactivation of the watchdog monitoring in the module, the outputs can be switched or set also in the SAFEOP state.
Operational (Op)
Before the EtherCAT master switches the EtherCAT slave from Safe-Op to Op it must transfer valid output data.
In the Op state the slave copies the output data of the masters to its outputs. Process data and mailbox communication is possible.
Boot
In the Boot state the slave firmware can be updated. The Boot state can only be reached via the Init state.
In the Boot state mailbox communication via the file access over EtherCAT (FoE) protocol is possible, but no other mailbox communication and no process data communication.


CoE Interface

Basics communication [image] CoE Interface
CoE Interface
General description
The CoE interface (CAN application protocol over EtherCAT)) is used for parameter management of EtherCAT devices. EtherCAT slaves or the EtherCAT master manage fixed (read only) or variable parameters which they require for operation, diagnostics or commissioning.
CoE parameters are arranged in a table hierarchy. In principle, the user has read access via the fieldbus. The EtherCAT master (TwinCAT System Manager) can access the local CoE lists of the slaves via EtherCAT in read or write mode, depending on the attributes.
Different CoE parameter types are possible, including string (text), integer numbers, Boolean values or larger byte fields. They can be used to describe a wide range of features. Examples of such parameters include manufacturer ID, serial number, process data settings, device name, calibration values for analog measurement or passwords.
The order is specified in 2 levels via hexadecimal numbering: (main)index, followed by subindex. The value ranges are
▪
Index: 0x0000 …0xFFFF (0...65535dez)
▪
SubIndex: 0x00…0xFF (0...255dez)
A parameter localized in this way is normally written as 0x8010:07, with preceding "x" to identify the hexadecimal numerical range and a colon between index and subindex.
The relevant ranges for EtherCAT fieldbus users are:
▪
0x1000: This is where fixed identity information for the device is stored, including name, manufacturer, serial number etc., plus information about the current and available process data configurations.
▪
0x8000: This is where the operational and functional parameters for all channels are stored, such as filter settings or output frequency.
Other important ranges are:
▪
0x4000: here are the channel parameters for some EtherCAT devices. Historically, this was the first parameter area before the 0x8000 area was introduced. EtherCAT devices that were previously equipped with parameters in 0x4000 and changed to 0x8000 support both ranges for compatibility reasons and mirror internally.
▪
0x6000: Input PDOs ("input" from the perspective of the EtherCAT master)
▪
0x7000: Output PDOs ("output" from the perspective of the EtherCAT master)
Availability
Not every EtherCAT device must have a CoE list. Simple I/O modules without dedicated processor usually have no variable parameters and therefore no CoE list.
If a device has a CoE list, it is shown in the TwinCAT System Manager as a separate tab with a listing of the elements:
"CoE Online " tab
The figure above shows the CoE objects available in device "EL2502", ranging from 0x1000 to 0x1600. The subindices for 0x1018 are expanded.
Data management and function "NoCoeStorage"
Some parameters, particularly the setting parameters of the slave, are configurable and writeable. This can be done in write or read mode
▪
via the System Manager (Fig. "CoE Online" tab) by clicking
This is useful for commissioning of the system/slaves. Click on the row of the index to be parameterised and enter a value in the "SetValue" dialog.
▪
from the control system/PLC via ADS, e.g. through blocks from the TcEtherCAT.lib library
This is recommended for modifications while the system is running or if no System Manager or operating staff are available.
Data management
If slave CoE parameters are modified online, Beckhoff devices store any changes in a fail-safe manner in the EEPROM, i.e. the modified CoE parameters are still available after a restart.
The situation may be different with other manufacturers.

An EEPROM is subject to a limited lifetime with respect to write operations. From typically 100,000 write operations onwards it can no longer be guaranteed that new (changed) data are reliably saved or are still readable. This is irrelevant for normal commissioning. However, if CoE parameters are continuously changed via ADS at machine runtime, it is quite possible for the lifetime limit to be reached. Support for the NoCoeStorage function, which suppresses the saving of changed CoE values, depends on the firmware version.
Please refer to the technical data in this documentation as to whether this applies to the respective device.
•
If the function is supported: the function is activated by entering the code word 0x12345678 once in CoE 0xF008 and remains active as long as the code word is not changed. After switching the device on it is then inactive. Changed CoE values are not saved in the EEPROM and can thus be changed any number of times.
•
Function is not supported: continuous changing of CoE values is not permissible in view of the lifetime limit.
Startup list
Changes in the local CoE list of the terminal are lost if the terminal is replaced. If a terminal is replaced with a new Beckhoff terminal, it will have the default settings. It is therefore advisable to link all changes in the CoE list of an EtherCAT slave with the Startup list of the slave, which is processed whenever the EtherCAT fieldbus is started. In this way a replacement EtherCAT slave can automatically be parameterized with the specifications of the user.
If EtherCAT slaves are used which are unable to store local CoE values permanently, the Startup list must be used.
Recommended approach for manual modification of CoE parameters
▪
Make the required change in the System Manager
The values are stored locally in the EtherCAT slave
▪
If the value is to be stored permanently, enter it in the Startup list.
The order of the Startup entries is usually irrelevant.
Startup list in the TwinCAT System Manager
The Startup list may already contain values that were configured by the System Manager based on the ESI specifications. Additional application-specific entries can be created.
Online/offline list
While working with the TwinCAT System Manager, a distinction has to be made whether the EtherCAT device is "available", i.e. switched on and linked via EtherCAT and therefore online, or whether a configuration is created offline without connected slaves.
In both cases a CoE list as shown in Fig. “CoE online tab” is displayed. The connectivity is shown as offline/online.
▪
If the slave is offline
–
The offline list from the ESI file is displayed. In this case modifications are not meaningful or possible.
–
The configured status is shown under Identity.
–
No firmware or hardware version is displayed, since these are features of the physical device.
–
Offline is shown in red.
Offline list
▪
If the slave is online
–
The actual current slave list is read. This may take several seconds, depending on the size and cycle time.
–
The actual identity is displayed
–
The firmware and hardware version of the equipment according to the electronic information is displayed
–
Online is shown in green.
Online list
Channel-based order
The CoE list is available in EtherCAT devices that usually feature several functionally equivalent channels. For example, a 4-channel analog 0...10 V input terminal also has 4 logical channels and therefore 4 identical sets of parameter data for the channels. In order to avoid having to list each channel in the documentation, the placeholder "n" tends to be used for the individual channel numbers.
In the CoE system 16 indices, each with 255 subindices, are generally sufficient for representing all channel parameters. The channel-based order is therefore arranged in 16dec/10hex steps. The parameter range 0x8000 exemplifies this:
▪
Channel 0: parameter range 0x8000:00 ... 0x800F:255
▪
Channel 1: parameter range 0x8010:00 ... 0x801F:255
▪
Channel 2: parameter range 0x8020:00 ... 0x802F:255
▪
...
This is generally written as 0x80n0.
Detailed information on the CoE interface can be found in the EtherCAT system documentation on the Beckhoff website.


Distributed Clock

Basics communication [image] Distributed Clock
Distributed Clock
The distributed clock represents a local clock in the EtherCAT slave controller (ESC) with the following characteristics:
▪
Unit 1 ns
▪
Zero point 1.1.2000 00:00
▪
Size 64 bit (sufficient for the next 584 years; however, some EtherCAT slaves only offer 32-bit support, i.e. the variable overflows after approx. 4.2 seconds)
▪
The EtherCAT master automatically synchronizes the local clock with the master clock in the EtherCAT bus with a precision of < 100 ns.
For detailed information please refer to the EtherCAT system description.


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Instructions for ESD protection
•
Installation on mounting rails
•
Connection
•
Installation positions
•
Positioning of passive Terminals
•
EL34xx - LEDs and connection


Instructions for ESD protection

Mounting and wiring [image] Instructions for ESD protection
Instructions for ESD protection
Note
Destruction of the devices by electrostatic discharge possible!
The devices contain components at risk from electrostatic discharge caused by improper handling.
•
Please ensure you are electrostatically discharged and avoid touching the contacts of the device directly.
•
Avoid contact with highly insulating materials (synthetic fibers, plastic film etc.).
•
Surroundings (working place, packaging and personnel) should by grounded probably, when handling with the devices.
•
Each assembly must be terminated at the right hand end with an EL9011 or EL9012 bus end cap, to ensure the protection class and ESD protection.
Spring contacts of the Beckhoff I/O components


Installation on mounting rails

Mounting and wiring [image] Installation on mounting rails
Installation on mounting rails
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Assembly
Attaching on mounting rail
The bus coupler and bus terminals are attached to commercially available 35 mm mounting rails (DIN rails according to EN 60715) by applying slight pressure:
1.
First attach the fieldbus coupler to the mounting rail.
2.
The bus terminals are now attached on the right-hand side of the fieldbus coupler. Join the components with tongue and groove and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
If the terminals are clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.
Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail. At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail. To mount the mounting rails with a height of 7.5 mm under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).
Disassembly
Disassembling of terminal
Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
1.
Pull the terminal by its orange-colored lugs approximately 1 cm away from the mounting rail. In doing so for this terminal the mounting rail lock is released automatically and you can pull the terminal out of the bus terminal block easily without excessive force.
2.
Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal out of the bus terminal block.
Connections within a bus terminal block
The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:
▪
The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
▪
The power contacts deal with the supply for the field electronics and thus represent a supply rail within the bus terminal block. The power contacts are supplied via terminals on the Bus Coupler (up to 24 V) or for higher voltages via power feed terminals.
Power Contacts
During the design of a bus terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts. Power Feed Terminals (KL91xx, KL92xx or EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.
PE power contact
The power contact labeled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Power contact on left side
Note
Possible damage of the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a nominal voltage of 230 V). For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.
SmallWarningYellow WARNING
Risk of electric shock!
The PE power contact must not be used for other potentials!


Connection

Mounting and wiring [image] Connection
Connection
Additional information
•
Connection system
•
Wiring
•
Shielding


Connection system

Mounting and wiring [image] Connection [image] Connection system
Connection system
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Overview
The Bus Terminal system offers different connection options for optimum adaptation to the respective application:
▪
The terminals of ELxxxx and KLxxxx series with standard wiring include electronics and connection level in a single enclosure.
▪
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level and enable steady wiring while replacing.
▪
The High Density Terminals (HD Terminals) include electronics and connection level in a single enclosure and have advanced packaging density.
Standard wiring (ELxxxx / KLxxxx)
Standard wiring
The terminals of ELxxxx and KLxxxx series have been tried and tested for years.
They feature integrated screwless spring force technology for fast and simple assembly.
Pluggable wiring (ESxxxx / KSxxxx)
Pluggable wiring
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level.
The assembly and wiring procedure is the same as for the ELxxxx and KLxxxx series.
The pluggable connection level enables the complete wiring to be removed as a plug connector from the top of the housing for servicing.
The lower section can be removed from the terminal block by pulling the unlocking tab.
Insert the new component and plug in the connector with the wiring. This reduces the installation time and eliminates the risk of wires being mixed up.
The familiar dimensions of the terminal only had to be changed slightly. The new connector adds about 3 mm. The maximum height of the terminal remains unchanged.
A tab for strain relief of the cable simplifies assembly in many applications and prevents tangling of individual connection wires when the connector is removed.
Conductor cross sections between 0.08 mm2 and 2.5 mm2 can continue to be used with the proven spring force technology.
The overview and nomenclature of the product names for ESxxxx and KSxxxx series has been retained as known from ELxxxx and KLxxxx series.
High Density Terminals (HD Terminals)
High Density Terminals
The Bus Terminals from these series with 16 terminal points are distinguished by a particularly compact design, as the packaging density is twice as large as that of the standard 12 mm Bus Terminals. Massive conductors and conductors with a wire end sleeve can be inserted directly into the spring loaded terminal point without tools.
Wiring HD Terminals
The High Density Terminals of the ELx8xx and KLx8xx series doesn't support pluggable wiring.
Ultrasonically "bonded" (ultrasonically welded) conductors
Ultrasonically “bonded" conductors
It is also possible to connect the Standard and High Density Terminals with ultrasonically "bonded" (ultrasonically welded) conductors. In this case, please note the tables concerning the wire-size width below!


Wiring

Mounting and wiring [image] Connection [image] Wiring
Wiring
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Terminals for standard wiring ELxxxx/KLxxxx and for pluggable wiring ESxxxx/KSxxxx
Connecting a cable on a terminal point
Up to eight terminal points enable the connection of solid or finely stranded cables to the Bus Terminal. The terminal points are implemented in spring force technology. Connect the cables as follows:
1.
Open a terminal point by pushing a screwdriver straight against the stop into the square opening above the terminal point. Do not turn the screwdriver or move it alternately (don't toggle).
2.
The wire can now be inserted into the round terminal opening without any force.
3.
The terminal point closes automatically when the pressure is released, holding the wire securely and permanently.
See the following table for the suitable wire size width.
Terminal housing | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Wire size width (single core wires) | 0.08 ... 2.5 mm2 | 0.08 ... 2.5 mm2
Wire size width (fine-wire conductors) | 0.08 ... 2.5 mm2 | 0,08 ... 2.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 1.5 mm2 | 0.14 ... 1.5 mm2
Wire stripping length | 8 ... 9 mm | 9 ... 10 mm
High Density Terminals (HD Terminals) with 16 terminal points
The conductors of the HD Terminals are connected without tools for single-wire conductors using the direct plug-in technique, i.e. after stripping the wire is simply plugged into the terminal point. The cables are released, as usual, using the contact release with the aid of a screwdriver. See the following table for the suitable wire size width.
Terminal housing | High Density Housing
Wire size width (single core wires) | 0.08 ... 1.5 mm2
Wire size width (fine-wire conductors) | 0.25 ... 1.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 0.75 mm2
Wire size width (ultrasonically “bonded" conductors) | only 1.5 mm2
Wire stripping length | 8 ... 9 mm


Shielding

Mounting and wiring [image] Connection [image] Shielding
Shielding
Shielding
Encoder, analog sensors and actors should always be connected with shielded, twisted paired wires.


Installation positions

Mounting and wiring [image] Installation positions
Installation positions
Note
Constraints regarding installation position and operating temperature range
Please refer to the technical data for a terminal to ascertain whether any restrictions regarding the installation position and/or the operating temperature range have been specified. When installing high power dissipation terminals ensure that an adequate spacing is maintained between other components above and below the terminal in order to guarantee adequate ventilation!
Optimum installation position (standard)
The optimum installation position requires the mounting rail to be installed horizontally and the connection surfaces of the EL/KL terminals to face forward (see Fig. Recommended distances for standard installation position). The terminals are ventilated from below, which enables optimum cooling of the electronics through convection. “From below” is relative to the acceleration of gravity.
Recommended distances for standard installation position
Compliance with the distances shown in Fig. Recommended distances for standard installation position is recommended.
Other installation positions
All other installation positions are characterized by different spatial arrangement of the mounting rail - see Fig “Other installation positions”.
The minimum distances to ambient specified above also apply to these installation positions.
Other installation positions


Positioning of passive Terminals

Mounting and wiring [image] Positioning of passive Terminals
Positioning of passive Terminals
Hint for positioning of passive terminals in the bus terminal block
EtherCAT Terminals (ELxxxx / ESxxxx), which do not take an active part in data transfer within the bus terminal block are so called passive terminals. The passive terminals have no current consumption out of the E-Bus.
To ensure an optimal data transfer, you must not directly string together more than 2 passive terminals!
Examples for positioning of passive terminals (highlighted)
Correct positioning
Incorrect positioning


EL34xx - LEDs and connection

Mounting and wiring [image] EL34xx - LEDs and connection
EL34xx - LEDs and connection
SmallWarningYellow WARNING
Caution: Risk of electric shock!
If you do not connect the terminal point N with the neutral conductor of your mains supply (e.g. if the EL3443/EL3453 is used purely for current measurements), terminal point N should be earthed, in order to avoid dangerous overvoltages in the event of a current transformer fault!
SmallWarningYellow WARNING
Caution: Risk of electric shock!
Please note that many vendors do not permit their current transformers to be operated in no-load mode! Connect the EL3443/EL3453 to the secondary windings of the current transformers before using the current transformer!
Measuring transformers
Suitable measuring transformers for use with the energy and power measuring terminals are available with the SCT series from Beckhoff.
EL3423 - LEDs and connection
EL3423 LEDs
LED | Color | Meaning
RUN | green | This LED indicates the terminal's operating state:
 |  | off | State of the EtherCAT State Machine: INIT = initialization of the terminal
 |  | flashing rapidly | State of the EtherCAT State Machine: BOOTSTRAP = function for terminal firmware updates
 |  | flashing | State of the EtherCAT State Machine: PREOP = function for mailbox communication and different default settings set
 |  | Single flash | State of the EtherCAT State Machine: SAFEOP = verification of the Sync Manager channels and the distributed clocks. Outputs remain in safe state.
 |  | on | State of the EtherCAT State Machine: OP = normal operating state; mailbox and process data communication is possible
System OK | green | on | System OK,
L1 - L3 OK | green | on | Voltage in the normal range L1 [image] L2 [image] L3
 |  | flashes | Voltage in the critical range (warning threshold exceeded) L1 [image] L2 [image] L3
 |  | off | Voltage in prohibited range (error threshold exceeded) L1 [image] L2 [image] L3
L1 - L3 Error | red | on
Terminal point |  | Description | Comment
Name | No.
L1 | 1 | Phase L1 | Connections for the voltage measurement Note the Warnings above " Caution: Risk of electric shock! "
L2 | 2 | Phase L2
L3 | 3 | Phase L3
N | 4 | Neutral conductor N (internally connected to terminal point 8)
IL1 | 5 | Consumer at phase L1 | Connections for the current transformers. Note the Warnings above " Caution: Risk of electric shock!"
IL2 | 6 | Consumer at phase L2
IL3 | 7 | Consumer at phase L3
N | 8 | Neutral conductor N (internally connected to terminal point 4)
EL3443 - LEDs and connection
EL3443 LEDs
LED | Color | Meaning
RUN | green | This LED indicates the terminal's operating state:
 |  | off | State of the EtherCAT State Machine: INIT = initialization of the terminal
 |  | flashing rapidly | State of the EtherCAT State Machine: BOOTSTRAP = function for terminal firmware updates
 |  | flashing | State of the EtherCAT State Machine: PREOP = function for mailbox communication and different default settings set
 |  | Single flash | State of the EtherCAT State Machine: SAFEOP = verification of the Sync Manager channels and the distributed clocks. Outputs remain in safe state.
 |  | on | State of the EtherCAT State Machine: OP = normal operating state; mailbox and process data communication is possible
System OK | green | on | System OK,
L1 - L3 OK | green | on | Voltage in the normal range L1 [image] L2 [image] L3
 |  | flashes | Voltage in the critical range (warning threshold exceeded) L1 [image] L2 [image] L3
 |  | off | Voltage in prohibited range (error threshold exceeded) L1 [image] L2 [image] L3
L1 - L3 Error | red | on
Terminal point |  | Description | Comment
Name | No.
L1 | 1 | Phase L1 | Connections for the voltage measurement Note the Warnings above " Caution: Risk of electric shock! "
L2 | 2 | Phase L2
L3 | 3 | Phase L3
N | 4 | Neutral conductor N (internally connected to terminal point 8)
IL1 | 5 | Consumer at phase L1 | Connections for the current transformers. Note the Warnings above " Caution: Risk of electric shock!"
IL2 | 6 | Consumer at phase L2
IL3 | 7 | Consumer at phase L3
N | 8 | Neutral conductor N (internally connected to terminal point 4)
EL3446 - LEDs and connection
EL3446 LEDs
LED | Color | Meaning
RUN | green | This LED indicates the terminal's operating state:
 |  | off | State of the EtherCAT State Machine: INIT = initialization of the terminal
 |  | flashing rapidly | State of the EtherCAT State Machine: BOOTSTRAP = function for terminal firmware updates
 |  | flashing | State of the EtherCAT State Machine: PREOP = function for mailbox communication and different default settings set
 |  | Single flash | State of the EtherCAT State Machine: SAFEOP = verification of the Sync Manager channels and the distributed clocks. Outputs remain in safe state.
 |  | on | State of the EtherCAT State Machine: OP = normal operating state; mailbox and process data communication is possible
System OK | green | on | System OK,
L1 – L6 OK | green | on | Voltage in the normal range
 |  | flashes | Voltage in the critical range (warning threshold exceeded, Guard Settings see CoE object 0x80n2)
 |  | off | Voltage in prohibited range (error threshold exceeded, Guard Settings see CoE object 0x80n2)
Error | red | on | Error of terminal
Terminal point |  | Description | Comment
Name | No.
IL1 | 1 | Load/current transformer on channel 1 | Connections for the voltage measurement Note the Warnings above " Caution: Risk of electric shock! "
IL2 | 2 | Load/current transformer on channel 2
IL3 | 3 | Load/current transformer on channel 3
N | 4 | Neutral conductor N (internally connected to terminal point 8)
IL4 | 5 | Load/current transformer on channel 4 | Connections for the current transformers. Note the Warnings above " Caution: Risk of electric shock!"
IL5 | 6 | Load/current transformer on channel 5
IL6 | 7 | Load/current transformer on channel 6
N | 8 | Neutral conductor N (internally connected to terminal point 4)
EL3453 - LEDs and connection
EL3453 LED's
LED | Color | Meaning
RUN | green | This LED indicates the terminal's operating state:
 |  | off | State of the EtherCAT State Machine: INIT = initialization of the terminal
 |  | flashing rapidly | State of the EtherCAT State Machine: BOOTSTRAP = function for terminal firmware updates
 |  | flashing | State of the EtherCAT State Machine: PREOP = function for mailbox communication and different default settings set
 |  | Single flash | State of the EtherCAT State Machine: SAFEOP = verification of the Sync Manager channels and the distributed clocks. Outputs remain in safe state.
 |  | on | State of the EtherCAT State Machine: OP = normal operating state; mailbox and process data communication is possible
System OK | green | on | System OK,
L1 - L3 OK | green | on | Right prism: Voltage in normal range L1 [image] L2 [image] L3
 |  | flashes | Right prism: Voltage in the critical range (warning threshold exceeded) L1 [image] L2 [image] L3
 |  | off | Right prism: Voltage in prohibited range (error threshold exceeded) L1 [image] L2 [image] L3
L1 - L3 Error | red | on
IL1 - IL3 OK | green | on | Left prism: Current in normal range IL1 [image] IL2 [image] IL3 [image] IN
 |  | flashes | Left prism: Current in the critical range (warning threshold exceeded) IL1 [image] IL2 [image] IL3 [image] IN
 |  | off | Left prism: Current in prohibited range (error threshold exceeded IL1 [image] IL2 [image] IL3 [image] IN
IL1 - IL3 Error | red | on
Terminal point |  | Description | Comment
Name | No.
IL1 | 1 | Phase L1 current measurement input | Connections for the current transformers. Note the Warnings above " Caution: Risk of electric shock!"
IL2 | 2 | Phase L2 current measurement input
IL3 | 3 | Phase L3 current measurement input
IN | 4 | Neutral conductor current measurement input (star point)
IL1‘ | 5 | Phase L1 current measurement output
IL2‘ | 6 | Phase L2 current measurement output
IL3‘ | 7 | Phase L3 current measurement output
IN‘ | 8 | Neutral conductor current measurement output (star point)
L1 | 1‘ | Phase L1 | Connections for the voltage measurement Note the Warnings above " Caution: Risk of electric shock!
 | 2‘ | n.c.
L3 | 3‘ | Phase L3
N | 4‘ | Neutral conductor (internally connected with terminal point 8‘)
 | 5‘ | n.c.
L2 | 6‘ | Phase L2
 | 7‘ | n.c.
N | 8‘ | Neutral conductor (internally connected with terminal point 4‘)
EL3483 - LEDs and connection
EL3483 LEDs
LED | Color | Meaning
RUN | green | This LED indicates the terminal's operating state:
 |  | off | State of the EtherCAT State Machine: INIT = initialization of the terminal
 |  | flashing rapidly | State of the EtherCAT State Machine: BOOTSTRAP = function for terminal firmware updates
 |  | flashing | State of the EtherCAT State Machine: PREOP = function for mailbox communication and different default settings set
 |  | Single flash | State of the EtherCAT State Machine: SAFEOP = verification of the Sync Manager channels and the distributed clocks. Outputs remain in safe state.
 |  | on | State of the EtherCAT State Machine: OP = normal operating state; mailbox and process data communication is possible
System OK | green | on | System OK,
L1 - L3 OK | green | on | Voltage in the normal range L1 [image] L2 [image] L3
 |  | flashes | Voltage in the critical range (warning threshold exceeded) L1 [image] L2 [image] L3
 |  | off | Voltage in prohibited range (error threshold exceeded) L1 [image] L2 [image] L3
L1 - L3 Error | red | on
Terminal point |  | Description | Comment
Name | No.
L1 | 1 | Phase L1 | Connections for the voltage measurement Note the Warnings above " Caution: Risk of electric shock! "
L2 | 2 | Phase L2
L3 | 3 | Phase L3
N | 4 | Neutral conductor N


Commissioning

Commissioning
Commissioning
Additional information
•
TwinCAT Quick Start
•
TwinCAT Development Environment
•
General Notes - EtherCAT Slave Application
•
Process data
•
Scaling factors
•
Notices on analog specifications
•
Object description and parameterization


TwinCAT Quick Start

Commissioning [image] TwinCAT Quick Start
TwinCAT Quick Start
TwinCAT is a development environment for real-time control including multi-PLC system, NC axis control, programming and operation. The whole system is mapped through this environment and enables access to a programming environment (including compilation) for the controller. Individual digital or analog inputs or outputs can also be read or written directly, in order to verify their functionality, for example.
For further information please refer to http://infosys.beckhoff.com:
▪
EtherCAT Systemmanual:
Fieldbus Components → EtherCAT Terminals → EtherCAT System Documentation → Setup in the TwinCAT System Manager
▪
TwinCAT 2 → TwinCAT System Manager → I/O - Configuration
▪
In particular, TwinCAT driver installation:
Fieldbus components → Fieldbus Cards and Switches → FC900x – PCI Cards for Ethernet → Installation
Devices contain the terminals for the actual configuration. All configuration data can be entered directly via editor functions (offline) or via the "Scan" function (online):
▪
"offline": The configuration can be customized by adding and positioning individual components. These can be selected from a directory and configured.
–
The procedure for offline mode can be found under http://infosys.beckhoff.com:
TwinCAT 2 → TwinCAT System Manager → IO - Configuration → Adding an I/O Device
▪
"online": The existing hardware configuration is read
–
See also http://infosys.beckhoff.com:
Fieldbus components → Fieldbus cards and switches → FC900x – PCI Cards for Ethernet → Installation → Searching for devices
The following relationship is envisaged from user PC to the individual control elements:
Relationship between user side (commissioning) and installation
The user inserting of certain components (I/O device, terminal, box...) is the same in TwinCAT 2 and TwinCAT 3. The descriptions below relate to the online procedure.
Sample configuration (actual configuration)
Based on the following sample configuration, the subsequent subsections describe the procedure for TwinCAT 2 and TwinCAT 3:
▪
Control system (PLC) CX2040 including CX2100-0004 power supply unit
▪
Connected to the CX2040 on the right (E-bus):
EL1004 (4-channel digital input terminal 24 V DC)
▪
Linked via the X001 port (RJ-45): EK1100 EtherCAT Coupler
▪
Connected to the EK1100 EtherCAT coupler on the right (E-bus):
EL2008 (8-channel digital output terminal 24 V DC; 0.5 A)
▪
(Optional via X000: a link to an external PC for the user interface)
Control configuration with Embedded PC, input (EL1004) and output (EL2008)
Note that all combinations of a configuration are possible; for example, the EL1004 terminal could also be connected after the coupler, or the EL2008 terminal could additionally be connected to the CX2040 on the right, in which case the EK1100 coupler wouldn’t be necessary.
Additional information
•
TwinCAT 2
•
TwinCAT 3


TwinCAT 2

Commissioning [image] TwinCAT Quick Start [image] TwinCAT 2
TwinCAT 2
Startup
TwinCAT basically uses two user interfaces: the TwinCAT System Manager for communication with the electromechanical components and TwinCAT PLC Control for the development and compilation of a controller. The starting point is the TwinCAT System Manager.
After successful installation of the TwinCAT system on the PC to be used for development, the TwinCAT 2 System Manager displays the following user interface after startup:
Initial TwinCAT 2 user interface
Generally, TwinCAT can be used in local or remote mode. Once the TwinCAT system including the user interface (standard) is installed on the respective PLC, TwinCAT can be used in local mode and thereby the next step is "Insert Device".
If the intention is to address the TwinCAT runtime environment installed on a PLC as development environment remotely from another system, the target system must be made known first. In the menu under "Actions" → "Choose Target System...", via the symbol " [image] " or the "F8" key, open the following window:
Selection of the target system
Use "Search (Ethernet)..." to enter the target system. Thus a next dialog opens to either:
▪
enter the known computer name after "Enter Host Name / IP:" (as shown in red)
▪
perform a "Broadcast Search" (if the exact computer name is not known)
▪
enter the known computer IP or AmsNetID.
Specify the PLC for access by the TwinCAT System Manager: selection of the target system
Once the target system has been entered, it is available for selection as follows (a password may have to be entered):
After confirmation with "OK" the target system can be accessed via the System Manager.
Adding devices
In the configuration tree of the TwinCAT 2 System Manager user interface on the left, select "I/O Devices” and then right-click to open a context menu and select "Scan Devices…", or start the action in the menu bar via [image]. The TwinCAT System Manager may first have to be set to "Config mode" via [image] or via menu
“Actions" → "Set/Reset TwinCAT to Config Mode…" (Shift + F4).
Select "Scan Devices..."
Confirm the warning message, which follows, and select "EtherCAT" in the dialog:
Automatic detection of I/O devices: selection the devices to be integrated
Confirm the message "Find new boxes", in order to determine the terminals connected to the devices. "Free Run" enables manipulation of input and output values in "Config mode" and should also be acknowledged.
Based on the sample configuration described at the beginning of this section, the result is as follows:
Mapping of the configuration in the TwinCAT 2 System Manager
The whole process consists of two stages, which may be performed separately (first determine the devices, then determine the connected elements such as boxes, terminals, etc.). A scan can also be initiated by selecting "Device ..." from the context menu, which then reads the elements present in the configuration below:
Reading of individual terminals connected to a device
This functionality is useful if the actual configuration is modified at short notice.
Programming and integrating the PLC
TwinCAT PLC Control is the development environment for the creation of the controller in different program environments: TwinCAT PLC Control supports all languages described in IEC 61131-3. There are two text-based languages and three graphical languages.
▪
Text-based languages
–
Instruction List (IL)
–
Structured Text (ST)
▪
Graphical languages
–
Function Block Diagram (FBD)
–
Ladder Diagram (LD)
–
The Continuous Function Chart Editor (CFC)
–
Sequential Function Chart (SFC)
The following section refers to Structured Text (ST).
After starting TwinCAT PLC Control, the following user interface is shown for an initial project:
TwinCAT PLC Control after startup
Sample variables and a sample program have been created and stored under the name "PLC_example.pro":
Sample program with variables after a compile process (without variable integration)
Warning 1990 (missing "VAR_CONFIG") after a compile process indicates that the variables defined as external (with the ID "AT%I*" or "AT%Q*") have not been assigned. After successful compilation, TwinCAT PLC Control creates a "*.tpy" file in the directory in which the project was stored. This file (*.tpy) contains variable assignments and is not known to the System Manager, hence the warning. Once the System Manager has been notified, the warning no longer appears.
First, integrate the TwinCAT PLC Control project in the System Manager via the context menu of the PLC configuration; right-click and select "Append PLC Project…":
Appending the TwinCAT PLC Control project
Select the PLC configuration "PLC_example.tpy" in the browser window that opens. The project including the two variables identified with "AT" are then integrated in the configuration tree of the System Manager:
PLC project integrated in the PLC configuration of the System Manager
The two variables "bEL1004_Ch4" and "nEL2008_value" can now be assigned to certain process objects of the I/O configuration.
Assigning variables
Open a window for selecting a suitable process object (PDO) via the context menu of a variable of the integrated project "PLC_example" and via "Modify Link..." "Standard":
Creating the links between PLC variables and process objects
In the window that opens, the process object for the variable “bEL1004_Ch4” of type BOOL can be selected from the PLC configuration tree:
Selecting PDO of type BOOL
According to the default setting, certain PDO objects are now available for selection. In this sample the input of channel 4 of the EL1004 terminal is selected for linking. In contrast, the checkbox "All types" must be ticked for creating the link for the output variables, in order to allocate a set of eight separate output bits to a byte variable. The following diagram shows the whole process:
Selecting several PDOs simultaneously: activate "Continuous" and "All types"
Note that the "Continuous" checkbox was also activated. This is designed to allocate the bits contained in the byte of the variable "nEL2008_value" sequentially to all eight selected output bits of the EL2008 terminal. In this way it is possible to subsequently address all eight outputs of the terminal in the program with a byte corresponding to bit 0 for channel 1 to bit 7 for channel 8 of the PLC. A special symbol ( [image]) at the yellow or red object of the variable indicates that a link exists. The links can also be checked by selecting a "Goto Link Variable” from the context menu of a variable. The object opposite, in this case the PDO, is automatically selected:
Application of a "Goto Link" variable, using "MAIN.bEL1004_Ch4" as a sample
The process of assigning variables to the PDO is completed via the menu selection "Actions" → "Generate Mappings”, key Ctrl+M or by clicking on the symbol [image] in the menu.
This can be visualized in the configuration:
The process of creating links can also take place in the opposite direction, i.e. starting with individual PDOs to variable. However, in this example it would then not be possible to select all output bits for the EL2008, since the terminal only makes individual digital outputs available. If a terminal has a byte, word, integer or similar PDO, it is possible to allocate this a set of bit-standardised variables (type "BOOL"). Here, too, a "Goto Link Variable” from the context menu of a PDO can be executed in the other direction, so that the respective PLC instance can then be selected.
Activation of the configuration
The allocation of PDO to PLC variables has now established the connection from the controller to the inputs and outputs of the terminals. The configuration can now be activated. First, the configuration can be verified via [image] (or via "Actions" → "Check Configuration”). If no error is present, the configuration can be activated via [image] (or via "Actions" → "Activate Configuration…") to transfer the System Manager settings to the runtime system. Confirm the messages "Old configurations are overwritten!" and "Restart TwinCAT system in Run mode" with "OK".
A few seconds later the real-time status [image] is displayed at the bottom right in the System Manager. The PLC system can then be started as described below.
Starting the controller
Starting from a remote system, the PLC control has to be linked with the Embedded PC over Ethernet via "Online" → “Choose Run-Time System…":
Choose target system (remote)
In this sample "Runtime system 1 (port 801)" is selected and confirmed. Link the PLC with the real-time system via menu option "Online" → "Login", the F11 key or by clicking on the symbol [image]. The control program can then be loaded for execution. This results in the message "No program on the controller! Should the new program be loaded?", which should be acknowledged with "Yes". The runtime environment is ready for the program start:
PLC Control logged in, ready for program startup
The PLC can now be started via "Online" → "Run", F5 key or [image].


TwinCAT 3

Commissioning [image] TwinCAT Quick Start [image] TwinCAT 3
TwinCAT 3
Startup
TwinCAT makes the development environment areas available together with Microsoft Visual Studio: after startup, the project folder explorer appears on the left in the general window area (cf. "TwinCAT System Manager" of TwinCAT 2) for communication with the electromechanical components.
After successful installation of the TwinCAT system on the PC to be used for development, TwinCAT 3 (shell) displays the following user interface after startup:
Initial TwinCAT 3 user interface
First create a new project via [image] (or under "File"→“New"→ "Project…"). In the following dialog make the corresponding entries as required (as shown in the diagram):
Create new TwinCAT project
The new project is then available in the project folder explorer:
New TwinCAT3 project in the project folder explorer
Generally, TwinCAT can be used in local or remote mode. Once the TwinCAT system including the user interface (standard) is installed on the respective PLC, TwinCAT can be used in local mode and thereby the next step is "Insert Device".
If the intention is to address the TwinCAT runtime environment installed on a PLC as development environment remotely from another system, the target system must be made known first. Via the symbol in the menu bar:
expand the pull-down menu:
and open the following window:
Selection dialog: Choose the target system
Use "Search (Ethernet)..." to enter the target system. Thus a next dialog opens to either:
▪
enter the known computer name after "Enter Host Name / IP:" (as shown in red)
▪
perform a "Broadcast Search" (if the exact computer name is not known)
▪
enter the known computer IP or AmsNetID.
Specify the PLC for access by the TwinCAT System Manager: selection of the target system
Once the target system has been entered, it is available for selection as follows (a password may have to be entered):
After confirmation with "OK" the target system can be accessed via the Visual Studio shell.
Adding devices
In the project folder explorer of the Visual Studio shell user interface on the left, select "Devices" within element “I/O”, then right-click to open a context menu and select "Scan" or start the action via [image] in the menu bar. The TwinCAT System Manager may first have to be set to "Config mode" via [image] or via the menu "TwinCAT" → "Restart TwinCAT (Config mode)".
Select "Scan"
Confirm the warning message, which follows, and select "EtherCAT" in the dialog:
Automatic detection of I/O devices: selection the devices to be integrated
Confirm the message "Find new boxes", in order to determine the terminals connected to the devices. "Free Run" enables manipulation of input and output values in "Config mode" and should also be acknowledged.
Based on the sample configuration described at the beginning of this section, the result is as follows:
Mapping of the configuration in VS shell of the TwinCAT3 environment
The whole process consists of two stages, which may be performed separately (first determine the devices, then determine the connected elements such as boxes, terminals, etc.). A scan can also be initiated by selecting "Device ..." from the context menu, which then reads the elements present in the configuration below:
Reading of individual terminals connected to a device
This functionality is useful if the actual configuration is modified at short notice.
Programming the PLC
TwinCAT PLC Control is the development environment for the creation of the controller in different program environments: TwinCAT PLC Control supports all languages described in IEC 61131-3. There are two text-based languages and three graphical languages.
▪
Text-based languages
–
Instruction List (IL)
–
Structured Text (ST)
▪
Graphical languages
–
Function Block Diagram (FBD)
–
Ladder Diagram (LD)
–
The Continuous Function Chart Editor (CFC)
–
Sequential Function Chart (SFC)
The following section refers to Structured Text (ST).
In order to create a programming environment, a PLC subproject is added to the project sample via the context menu of "PLC" in the project folder explorer by selecting "Add New Item….":
Adding the programming environment in "PLC"
In the dialog that opens select "Standard PLC project" and enter "PLC_example" as project name, for example, and select a corresponding directory:
Specifying the name and directory for the PLC programming environment
The "Main" program, which already exists by selecting "Standard PLC project", can be opened by double-clicking on "PLC_example_project" in "POUs”. The following user interface is shown for an initial project:
Initial "Main" program of the standard PLC project
To continue, sample variables and a sample program have now been created:
Sample program with variables after a compile process (without variable integration)
The control program is now created as a project folder, followed by the compile process:
Start program compilation
The following variables, identified in the ST/ PLC program with "AT%", are then available in under "Assignments" in the project folder explorer:
Assigning variables
Via the menu of an instance - variables in the "PLC” context, use the "Modify Link…" option to open a window for selecting a suitable process object (PDO) for linking:
Creating the links between PLC variables and process objects
In the window that opens, the process object for the variable "bEL1004_Ch4" of type BOOL can be selected from the PLC configuration tree:
Selecting PDO of type BOOL
According to the default setting, certain PDO objects are now available for selection. In this sample the input of channel 4 of the EL1004 terminal is selected for linking. In contrast, the checkbox "All types" must be ticked for creating the link for the output variables, in order to allocate a set of eight separate output bits to a byte variable. The following diagram shows the whole process:
Selecting several PDOs simultaneously: activate "Continuous" and "All types"
Note that the "Continuous" checkbox was also activated. This is designed to allocate the bits contained in the byte of the variable "nEL2008_value" sequentially to all eight selected output bits of the EL2008 terminal. In this way it is possible to subsequently address all eight outputs of the terminal in the program with a byte corresponding to bit 0 for channel 1 to bit 7 for channel 8 of the PLC. A special symbol ( [image]) at the yellow or red object of the variable indicates that a link exists. The links can also be checked by selecting a "Goto Link Variable” from the context menu of a variable. The object opposite, in this case the PDO, is automatically selected:
Application of a "Goto Link" variable, using "MAIN.bEL1004_Ch4" as a sample
The process of creating links can also take place in the opposite direction, i.e. starting with individual PDOs to variable. However, in this example it would then not be possible to select all output bits for the EL2008, since the terminal only makes individual digital outputs available. If a terminal has a byte, word, integer or similar PDO, it is possible to allocate this a set of bit-standardised variables (type "BOOL"). Here, too, a "Goto Link Variable” from the context menu of a PDO can be executed in the other direction, so that the respective PLC instance can then be selected.
Note on the type of variable assignment
The following type of variable assignment can only be used from TwinCAT version V3.1.4024.4 onwards and is only available for terminals with a microcontroller.
In TwinCAT it is possible to create a structure from the mapped process data of a terminal. An instance of this structure can then be created in the PLC, so it is possible to access the process data directly from the PLC without having to declare own variables.
The procedure for the EL3001 1-channel analog input terminal -10...+10 V is shown as an example.
1.
First the required process data must be selected in the "Process data" tab in TwinCAT.
2.
After that, the PLC data type must be generated in the tab "PLC" via the check box.
3.
The data type in the "Data Type" field can then be copied using the "Copy" button.
Creating a PLC data type
4.
An instance of the data structure of the copied data type must then be created in the PLC.
Instance_of_struct
5.
Then the project folder must be created. This can be done either via the key combination "CTRL + Shift + B" or via the "Build" tab in TwinCAT.
6.
The structure in the "PLC" tab of the terminal must then be linked to the created instance.
Linking the structure
7.
In the PLC the process data can then be read or written via the structure in the program code.
Reading a variable from the structure of the process data
Activation of the configuration
The allocation of PDO to PLC variables has now established the connection from the controller to the inputs and outputs of the terminals. The configuration can now be activated with [image] or via the menu under "TwinCAT" in order to transfer settings of the development environment to the runtime system. Confirm the messages "Old configurations are overwritten!" and "Restart TwinCAT system in Run mode" with "OK". The corresponding assignments can be seen in the project folder explorer:
A few seconds later the corresponding status of the Run mode is displayed in the form of a rotating symbol [image] at the bottom right of the VS shell development environment. The PLC system can then be started as described below.
Starting the controller
Select the menu option "PLC" → "Login" or click on [image] to link the PLC with the real-time system and load the control program for execution. This results in the message "No program on the controller! Should the new program be loaded?", which should be acknowledged with "Yes". The runtime environment is ready for program start by click on symbol [image], the "F5" key or via "PLC" in the menu selecting “Start”. The started programming environment shows the runtime values of individual variables:
TwinCAT development environment (VS shell): logged-in, after program startup
The two operator control elements for stopping [image] and logout [image] result in the required action (accordingly also for stop "Shift + F5", or both actions can be selected via the PLC menu).


TwinCAT Development Environment

Commissioning [image] TwinCAT Development Environment
TwinCAT Development Environment
The Software for automation TwinCAT (The Windows Control and Automation Technology) will be distinguished into:
▪
TwinCAT 2: System Manager (Configuration) & PLC Control (Programming)
▪
TwinCAT 3: Enhancement of TwinCAT 2 (Programming and Configuration takes place via a common Development Environment)
Details:
▪
TwinCAT 2:
–
Connects I/O devices to tasks in a variable-oriented manner
–
Connects tasks to tasks in a variable-oriented manner
–
Supports units at the bit level
–
Supports synchronous or asynchronous relationships
–
Exchange of consistent data areas and process images
–
Datalink on NT - Programs by open Microsoft Standards (OLE, OCX, ActiveX, DCOM+, etc.)
–
Integration of IEC 61131-3-Software-SPS, Software- NC and Software-CNC within Windows NT/2000/XP/Vista, Windows 7, NT/XP Embedded, CE
–
Interconnection to all common fieldbusses
–
More…
Additional features:
▪
TwinCAT 3 (eXtended Automation):
–
Visual-Studio®-Integration
–
Choice of the programming language
–
Supports object orientated extension of IEC 61131-3
–
Usage of C/C++ as programming language for real time applications
–
Connection to MATLAB®/Simulink®
–
Open interface for expandability
–
Flexible run-time environment
–
Active support of Multi-Core- und 64-Bit-Operatingsystem
–
Automatic code generation and project creation with the TwinCAT Automation Interface
–
More…
Within the following sections commissioning of the TwinCAT Development Environment on a PC System for the control and also the basically functions of unique control elements will be explained.
Please see further information to TwinCAT 2 and TwinCAT 3 at http://infosys.beckhoff.com.
Additional information
•
Installation of the TwinCAT real-time driver
•
Notes regarding ESI device description
•
TwinCAT ESI Updater
•
Distinction between Online and Offline
•
OFFLINE configuration creation
•
ONLINE configuration creation
•
EtherCAT subscriber configuration


Installation of the TwinCAT real-time driver

Commissioning [image] TwinCAT Development Environment [image] Installation of the TwinCAT real-time driver
Installation of the TwinCAT real-time driver
In order to assign real-time capability to a standard Ethernet port of an IPC controller, the Beckhoff real-time driver has to be installed on this port under Windows.
This can be done in several ways. One option is described here.
In the System Manager call up the TwinCAT overview of the local network interfaces via Options → Show Real Time Ethernet Compatible Devices.
System Manager “Options” (TwinCAT 2)
This have to be called up by the Menü “TwinCAT” within the TwinCAT 3 environment:
Call up under VS Shell (TwinCAT 3)
The following dialog appears:
Overview of network interfaces
Interfaces listed under “Compatible devices” can be assigned a driver via the “Install” button. A driver should only be installed on compatible devices.
A Windows warning regarding the unsigned driver can be ignored.
Alternatively an EtherCAT-device can be inserted first of all as described in chapter Offline configuration creation, section “Creating the EtherCAT device” in order to view the compatible ethernet ports via its EtherCAT properties (tab „Adapter“, button „Compatible Devices…“):
EtherCAT device properties(TwinCAT 2): click on „Compatible Devices…“ of tab “Adapter”
TwinCAT 3: the properties of the EtherCAT device can be opened by double click on “Device .. (EtherCAT)” within the Solution Explorer under “I/O”:
After the installation the driver appears activated in the Windows overview for the network interface (Windows Start → System Properties → Network)
Windows properties of the network interface
A correct setting of the driver could be:
Exemplary correct driver setting for the Ethernet port
Other possible settings have to be avoided:
Incorrect driver settings for the Ethernet port
IP address of the port used
IP address/DHCP
In most cases an Ethernet port that is configured as an EtherCAT device will not transport general IP packets. For this reason and in cases where an EL6601 or similar devices are used it is useful to specify a fixed IP address for this port via the “Internet Protocol TCP/IP” driver setting and to disable DHCP. In this way the delay associated with the DHCP client for the Ethernet port assigning itself a default IP address in the absence of a DHCP server is avoided. A suitable address space is 192.168.x.x, for example.
TCP/IP setting for the Ethernet port


Notes regarding ESI device description

Commissioning [image] TwinCAT Development Environment [image] Notes regarding ESI device description
Notes regarding ESI device description
Installation of the latest ESI device description
The TwinCAT EtherCAT master/System Manager needs the device description files for the devices to be used in order to generate the configuration in online or offline mode. The device descriptions are contained in the so-called ESI files (EtherCAT Slave Information) in XML format. These files can be requested from the respective manufacturer and are made available for download. An *.xml file may contain several device descriptions.
The ESI files for Beckhoff EtherCAT devices are available on the Beckhoff website.
The ESI files should be stored in the TwinCAT installation directory.
Default settings:
▪
TwinCAT 2: C:\TwinCAT\IO\EtherCAT
▪
TwinCAT 3: C:\TwinCAT\3.1\Config\Io\EtherCAT
The files are read (once) when a new System Manager window is opened, if they have changed since the last time the System Manager window was opened.
A TwinCAT installation includes the set of Beckhoff ESI files that was current at the time when the TwinCAT build was created.
For TwinCAT 2.11/TwinCAT 3 and higher, the ESI directory can be updated from the System Manager, if the programming PC is connected to the Internet; by
▪
TwinCAT 2: Option → “Update EtherCAT Device Descriptions”
▪
TwinCAT 3: TwinCAT → EtherCAT Devices → “Update Device Descriptions (via ETG Website)…”
The TwinCAT ESI Updater is available for this purpose.
ESI
The *.xml files are associated with *.xsd files, which describe the structure of the ESI XML files. To update the ESI device descriptions, both file types should therefore be updated.
Device differentiation
EtherCAT devices/slaves are distinguished by four properties, which determine the full device identifier. For example, the device identifier EL2521-0025-1018 consists of:
▪
family key “EL”
▪
name “2521”
▪
type “0025”
▪
and revision “1018”
Identifier structure
The order identifier consisting of name + type (here: EL2521-0010) describes the device function. The revision indicates the technical progress and is managed by Beckhoff. In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation. Each revision has its own ESI description. See further notes.
Online description
If the EtherCAT configuration is created online through scanning of real devices (see section Online setup) and no ESI descriptions are available for a slave (specified by name and revision) that was found, the System Manager asks whether the description stored in the device should be used. In any case, the System Manager needs this information for setting up the cyclic and acyclic communication with the slave correctly.
OnlineDescription information window (TwinCAT 2)
In TwinCAT 3 a similar window appears, which also offers the Web update:
Information window OnlineDescription (TwinCAT 3)
If possible, the Yes is to be rejected and the required ESI is to be requested from the device manufacturer. After installation of the XML/XSD file the configuration process should be repeated.
Note
Changing the ‘usual’ configuration through a scan
✓
If a scan discovers a device that is not yet known to TwinCAT, distinction has to be made between two cases. Taking the example here of the EL2521-0000 in the revision 1019
1.
no ESI is present for the EL2521-0000 device at all, either for the revision 1019 or for an older revision. The ESI must then be requested from the manufacturer (in this case Beckhoff).
2.
an ESI is present for the EL2521-0000 device, but only in an older revision, e.g. 1018 or 1017.
In this case an in-house check should first be performed to determine whether the spare parts stock allows the integration of the increased revision into the configuration at all. A new/higher revision usually also brings along new features. If these are not to be used, work can continue without reservations with the previous revision 1018 in the configuration. This is also stated by the Beckhoff compatibility rule.
Refer in particular to the chapter ‘General notes on the use of Beckhoff EtherCAT IO components’ and for manual configuration to the chapter ‘Offline configuration creation’.
If the OnlineDescription is used regardless, the System Manager reads a copy of the device description from the EEPROM in the EtherCAT slave. In complex slaves the size of the EEPROM may not be sufficient for the complete ESI, in which case the ESI would be incomplete in the configurator. Therefore it’s recommended using an offline ESI file with priority in such a case.
The System Manager creates for online recorded device descriptions a new file “OnlineDescription0000...xml” in its ESI directory, which contains all ESI descriptions that were read online.
File OnlineDescription.xml created by the System Manager
Is a slave desired to be added manually to the configuration at a later stage, online created slaves are indicated by a prepended symbol “>” in the selection list (see Figure “Indication of an online recorded ESI of EL2521 as an example”).
Indication of an online recorded ESI of EL2521 as an example
If such ESI files are used and the manufacturer's files become available later, the file OnlineDescription.xml should be deleted as follows:
▪
close all System Manager windows
▪
restart TwinCAT in Config mode
▪
delete "OnlineDescription0000...xml"
▪
restart TwinCAT System Manager
This file should not be visible after this procedure, if necessary press <F5> to update
OnlineDescription for TwinCAT 3.x
In addition to the file described above "OnlineDescription0000...xml" , a so called EtherCAT cache with new discovered devices is created by TwinCAT 3.x, e.g. under Windows 7:

(Please note the language settings of the OS!)
You have to delete this file, too.
Faulty ESI file
If an ESI file is faulty and the System Manager is unable to read it, the System Manager brings up an information window.
Information window for faulty ESI file (left: TwinCAT 2; right: TwinCAT 3)
Reasons may include:
▪
Structure of the *.xml does not correspond to the associated *.xsd file → check your schematics
▪
Contents cannot be translated into a device description → contact the file manufacturer


TwinCAT ESI Updater

Commissioning [image] TwinCAT Development Environment [image] TwinCAT ESI Updater
TwinCAT ESI Updater
For TwinCAT 2.11 and higher, the System Manager can search for current Beckhoff ESI files automatically, if an online connection is available:
Using the ESI Updater (>= TwinCAT 2.11)
The call up takes place under:
“Options” → "Update EtherCAT Device Descriptions"
Selection under TwinCAT 3:
Using the ESI Updater (TwinCAT 3)
The ESI Updater (TwinCAT 3) is a convenient option for automatic downloading of ESI data provided by EtherCAT manufacturers via the Internet into the TwinCAT directory (ESI = EtherCAT slave information). TwinCAT accesses the central ESI ULR directory list stored at ETG; the entries can then be viewed in the Updater dialog, although they cannot be changed there.
The call up takes place under:
“TwinCAT“ → „EtherCAT Devices“ → “Update Device Description (via ETG Website)…“.


Distinction between Online and Offline

Commissioning [image] TwinCAT Development Environment [image] Distinction between Online and Offline
Distinction between Online and Offline
The distinction between online and offline refers to the presence of the actual I/O environment (drives, terminals, EJ-modules). If the configuration is to be prepared in advance of the system configuration as a programming system, e.g. on a laptop, this is only possible in “Offline configuration” mode. In this case all components have to be entered manually in the configuration, e.g. based on the electrical design.
If the designed control system is already connected to the EtherCAT system and all components are energised and the infrastructure is ready for operation, the TwinCAT configuration can simply be generated through “scanning” from the runtime system. This is referred to as online configuration.
In any case, during each startup the EtherCAT master checks whether the slaves it finds match the configuration. This test can be parameterised in the extended slave settings. Refer to note “Installation of the latest ESI-XML device description”.
For preparation of a configuration:
▪
the real EtherCAT hardware (devices, couplers, drives) must be present and installed
▪
the devices/modules must be connected via EtherCAT cables or in the terminal/ module strand in the same way as they are intended to be used later
▪
the devices/modules be connected to the power supply and ready for communication
▪
TwinCAT must be in CONFIG mode on the target system.
The online scan process consists of:
▪
detecting the EtherCAT device (Ethernet port at the IPC)
▪
detecting the connected EtherCAT devices. This step can be carried out independent of the preceding step
▪
troubleshooting
The scan with existing configuration can also be carried out for comparison.


OFFLINE configuration creation

Commissioning [image] TwinCAT Development Environment [image] OFFLINE configuration creation
OFFLINE configuration creation
Creating the EtherCAT device
Create an EtherCAT device in an empty System Manager window.
Append EtherCAT device (left: TwinCAT 2; right: TwinCAT 3)
Select type ‘EtherCAT’ for an EtherCAT I/O application with EtherCAT slaves. For the present publisher/subscriber service in combination with an EL6601/EL6614 terminal select “EtherCAT Automation Protocol via EL6601”.
Selecting the EtherCAT connection (TwinCAT 2.11, TwinCAT 3)
Then assign a real Ethernet port to this virtual device in the runtime system.
Selecting the Ethernet port
This query may appear automatically when the EtherCAT device is created, or the assignment can be set/modified later in the properties dialog; see Fig. “EtherCAT device properties (TwinCAT 2)”.
EtherCAT device properties (TwinCAT 2)
TwinCAT 3: the properties of the EtherCAT device can be opened by double click on “Device .. (EtherCAT)” within the Solution Explorer under “I/O”:
Selecting the Ethernet port
Ethernet ports can only be selected for EtherCAT devices for which the TwinCAT real-time driver is installed. This has to be done separately for each port. Please refer to the respective installation page.
Defining EtherCAT slaves
Further devices can be appended by right-clicking on a device in the configuration tree.
Appending EtherCAT devices (left: TwinCAT 2; right: TwinCAT 3)
The dialog for selecting a new device opens. Only devices for which ESI files are available are displayed.
Only devices are offered for selection that can be appended to the previously selected device. Therefore the physical layer available for this port is also displayed (Fig. “Selection dialog for new EtherCAT device”, A). In the case of cable-based Fast-Ethernet physical layer with PHY transfer, then also only cable-based devices are available, as shown in Fig. “Selection dialog for new EtherCAT device”. If the preceding device has several free ports (e.g. EK1122 or EK1100), the required port can be selected on the right-hand side (A).
Overview of physical layer
▪
“Ethernet”: cable-based 100BASE-TX: EK couplers, EP boxes, devices with RJ45/M8/M12 connector
▪
“E-Bus”: LVDS “terminal bus”, “EJ-module”: EL/ES terminals, various modular modules
The search field facilitates finding specific devices (since TwinCAT 2.11 or TwinCAT 3).
Selection dialog for new EtherCAT device
By default only the name/device type is used as selection criterion. For selecting a specific revision of the device the revision can be displayed as “Extended Information”.
Display of device revision
In many cases several device revisions were created for historic or functional reasons, e.g. through technological advancement. For simplification purposes (see Fig. “Selection dialog for new EtherCAT device”) only the last (i.e. highest) revision and therefore the latest state of production is displayed in the selection dialog for Beckhoff devices. To show all device revisions available in the system as ESI descriptions tick the “Show Hidden Devices” check box, see Fig. “Display of previous revisions”.
Display of previous revisions
Device selection based on revision, compatibility
The ESI description also defines the process image, the communication type between master and slave/device and the device functions, if applicable. The physical device (firmware, if available) has to support the communication queries/settings of the master. This is backward compatible, i.e. newer devices (higher revision) should be supported if the EtherCAT master addresses them as an older revision. The following compatibility rule of thumb is to be assumed for Beckhoff EtherCAT Terminals/ Boxes/ EJ-modules:
device revision in the system >= device revision in the configuration
This also enables subsequent replacement of devices without changing the configuration (different specifications are possible for drives).
Example
If an EL2521-0025-1018 is specified in the configuration, an EL2521-0025-1018 or higher (-1019, -1020) can be used in practice.
Name/revision of the terminal
If current ESI descriptions are available in the TwinCAT system, the last revision offered in the selection dialog matches the Beckhoff state of production. It is recommended to use the last device revision when creating a new configuration, if current Beckhoff devices are used in the real application. Older revisions should only be used if older devices from stock are to be used in the application.
In this case the process image of the device is shown in the configuration tree and can be parameterised as follows: linking with the task, CoE/DC settings, plug-in definition, startup settings, ...
EtherCAT terminal in the TwinCAT tree (left: TwinCAT 2; right: TwinCAT 3)


ONLINE configuration creation

Commissioning [image] TwinCAT Development Environment [image] ONLINE configuration creation
ONLINE configuration creation
Detecting/scanning of the EtherCAT device
The online device search can be used if the TwinCAT system is in CONFIG mode. This can be indicated by a symbol right below in the information bar:
▪
on TwinCAT 2 by a blue display “Config Mode” within the System Manager window: .
▪
on TwinCAT 3 within the user interface of the development environment by a symbol [image].
TwinCAT can be set into this mode:
▪
TwinCAT 2: by selection of [image] in the Menubar or by “Actions” → “Set/Reset TwinCAT to Config Mode…”
▪
TwinCAT 3: by selection of [image] in the Menubar or by „TwinCAT“ → “Restart TwinCAT (Config Mode)“
Online scanning in Config mode
The online search is not available in RUN mode (production operation). Note the differentiation between TwinCAT programming system and TwinCAT target system.
The TwinCAT 2 icon ( [image]) or TwinCAT 3 icon ( [image]) within the Windows-Taskbar always shows the TwinCAT mode of the local IPC. Compared to that, the System Manager window of TwinCAT 2 or the user interface of TwinCAT 3 indicates the state of the target system.
Differentiation local/target system (left: TwinCAT 2; right: TwinCAT 3)
Right-clicking on “I/O Devices” in the configuration tree opens the search dialog.
Scan Devices (left: TwinCAT 2; right: TwinCAT 3)
This scan mode attempts to find not only EtherCAT devices (or Ethernet ports that are usable as such), but also NOVRAM, fieldbus cards, SMB etc. However, not all devices can be found automatically.
Note for automatic device scan (left: TwinCAT 2; right: TwinCAT 3)
Ethernet ports with installed TwinCAT real-time driver are shown as “RT Ethernet” devices. An EtherCAT frame is sent to these ports for testing purposes. If the scan agent detects from the response that an EtherCAT slave is connected, the port is immediately shown as an “EtherCAT Device” .
Detected Ethernet devices
Via respective checkboxes devices can be selected (as illustrated in Fig. “Detected Ethernet devices” e.g. Device 3 and Device 4 were chosen). After confirmation with “OK” a device scan is suggested for all selected devices, see Fig.: “Scan query after automatic creation of an EtherCAT device”.
Selecting the Ethernet port
Ethernet ports can only be selected for EtherCAT devices for which the TwinCAT real-time driver is installed. This has to be done separately for each port. Please refer to the respective installation page.
Detecting/Scanning the EtherCAT devices
Online scan functionality
During a scan the master queries the identity information of the EtherCAT slaves from the slave EEPROM. The name and revision are used for determining the type. The respective devices are located in the stored ESI data and integrated in the configuration tree in the default state defined there.
Example default state
Note
Slave scanning in practice in series machine production
The scanning function should be used with care. It is a practical and fast tool for creating an initial configuration as a basis for commissioning. In series machine production or reproduction of the plant, however, the function should no longer be used for the creation of the configuration, but if necessary for comparison with the defined initial configuration.Background: since Beckhoff occasionally increases the revision version of the delivered products for product maintenance reasons, a configuration can be created by such a scan which (with an identical machine construction) is identical according to the device list; however, the respective device revision may differ from the initial configuration.
Example:
Company A builds the prototype of a machine B, which is to be produced in series later on. To do this the prototype is built, a scan of the IO devices is performed in TwinCAT and the initial configuration ‘B.tsm’ is created. The EL2521-0025 EtherCAT terminal with the revision 1018 is located somewhere. It is thus built into the TwinCAT configuration in this way:
Installing EthetCAT terminal with revision -1018
Likewise, during the prototype test phase, the functions and properties of this terminal are tested by the programmers/commissioning engineers and used if necessary, i.e. addressed from the PLC ‘B.pro’ or the NC. (the same applies correspondingly to the TwinCAT 3 solution files).
The prototype development is now completed and series production of machine B starts, for which Beckhoff continues to supply the EL2521-0025-0018. If the commissioning engineers of the series machine production department always carry out a scan, a B configuration with the identical contents results again for each machine. Likewise, A might create spare parts stores worldwide for the coming series-produced machines with EL2521-0025-1018 terminals.
After some time Beckhoff extends the EL2521-0025 by a new feature C. Therefore the FW is changed, outwardly recognizable by a higher FW version and a new revision -1019. Nevertheless the new device naturally supports functions and interfaces of the predecessor version(s); an adaptation of ‘B.tsm’ or even ‘B.pro’ is therefore unnecessary. The series-produced machines can continue to be built with ‘B.tsm’ and ‘B.pro’; it makes sense to perform a comparative scan against the initial configuration ‘B.tsm’ in order to check the built machine.
However, if the series machine production department now doesn’t use ‘B.tsm’, but instead carries out a scan to create the productive configuration, the revision -1019 is automatically detected and built into the configuration:
Detection of EtherCAT terminal with revision -1019
This is usually not noticed by the commissioning engineers. TwinCAT cannot signal anything either, since virtually a new configuration is created. According to the compatibility rule, however, this means that no EL2521-0025-1018 should be built into this machine as a spare part (even if this nevertheless works in the vast majority of cases).
In addition, it could be the case that, due to the development accompanying production in company A, the new feature C of the EL2521-0025-1019 (for example, an improved analog filter or an additional process data for the diagnosis) is discovered and used without in-house consultation. The previous stock of spare part devices are then no longer to be used for the new configuration ‘B2.tsm’ created in this way.Þ if series machine production is established, the scan should only be performed for informative purposes for comparison with a defined initial configuration. Changes are to be made with care!
If an EtherCAT device was created in the configuration (manually or through a scan), the I/O field can be scanned for devices/slaves.
Scan query after automatic creation of an EtherCAT device (left: TwinCAT 2; right: TwinCAT 3)
Manual triggering of a device scan on a specified EtherCAT device (left: TwinCAT 2; right: TwinCAT 3)
In the System Manager (TwinCAT 2) or the User Interface (TwinCAT 3) the scan process can be monitored via the progress bar at the bottom in the status bar.
Scan progressexemplary by TwinCAT 2
The configuration is established and can then be switched to online state (OPERATIONAL).
Config/FreeRun query (left: TwinCAT 2; right: TwinCAT 3)
In Config/FreeRun mode the System Manager display alternates between blue and red, and the EtherCAT device continues to operate with the idling cycle time of 4 ms (default setting), even without active task (NC, PLC).
Displaying of “Free Run” and “Config Mode” toggling right below in the status bar
TwinCAT can also be switched to this state by using a button (left: TwinCAT 2; right: TwinCAT 3)
The EtherCAT system should then be in a functional cyclic state, as shown in Fig. “Online display example”.
Online display example
Please note:
▪
all slaves should be in OP state
▪
the EtherCAT master should be in “Actual State” OP
▪
“frames/sec” should match the cycle time taking into account the sent number of frames
▪
no excessive “LostFrames” or CRC errors should occur
The configuration is now complete. It can be modified as described under manual procedure.
Troubleshooting
Various effects may occur during scanning.
▪
An unknown device is detected, i.e. an EtherCAT slave for which no ESI XML description is available.
In this case the System Manager offers to read any ESI that may be stored in the device. This case is described in the chapter "Notes regarding ESI device description".
▪
Device are not detected properly
Possible reasons include:
- faulty data links, resulting in data loss during the scan
- slave has invalid device description
The connections and devices should be checked in a targeted manner, e.g. via the emergency scan.
Then re-run the scan.
Faulty identification
In the System Manager such devices may be set up as EK0000 or unknown devices. Operation is not possible or meaningful.
Scan over existing Configuration
Note
Change of the configuration after comparison
With this scan (TwinCAT 2.11 or 3.1) only the device properties vendor (manufacturer), device name and revision are compared at present! A ‘ChangeTo’ or ‘Copy’ should only be carried out with care, taking into consideration the Beckhoff IO compatibility rule (see above). The device configuration is then replaced by the revision found; this can affect the supported process data and functions.
If a scan is initiated for an existing configuration, the actual I/O environment may match the configuration exactly or it may differ. This enables the configuration to be compared.
Identical configuration (left: TwinCAT 2; right: TwinCAT 3)
If differences are detected, they are shown in the correction dialog, so that the user can modify the configuration as required.
Correction dialog
It is advisable to tick the “Extended Information” check box to reveal differences in the revision.
Color
Explanation
green
This EtherCAT slave matches the entry on the other side. Both type and revision match.
blue
This EtherCAT slave is present on the other side, but in a different revision. This other revision can have other default values for the process data as well as other/additional functions.
If the found revision is higher than the configured revision, the slave may be used provided compatibility issues are taken into account.
If the found revision is lower than the configured revision, it is likely that the slave cannot be used. The found device may not support all functions that the master expects based on the higher revision number.
light blue
This EtherCAT slave is ignored (“Ignore” button)
red
▪
This EtherCAT slave is not present on the other side.
▪
It is present, but in a different revision, which also differs in its properties from the one specified.
The compatibility principle then also applies here: if the found revision is higher than the configured revision, use is possible provided compatibility issues are taken into account, since the successor devices should support the functions of the predecessor devices.
If the found revision is lower than the configured revision, it is likely that the slave cannot be used. The found device may not support all functions that the master expects based on the higher revision number.
Device selection based on revision, compatibility
The ESI description also defines the process image, the communication type between master and slave/device and the device functions, if applicable. The physical device (firmware, if available) has to support the communication queries/settings of the master. This is backward compatible, i.e. newer devices (higher revision) should be supported if the EtherCAT master addresses them as an older revision. The following compatibility rule of thumb is to be assumed for Beckhoff EtherCAT Terminals/ Boxes/ EJ-modules:
device revision in the system >= device revision in the configuration
This also enables subsequent replacement of devices without changing the configuration (different specifications are possible for drives).
Example
If an EL2521-0025-1018 is specified in the configuration, an EL2521-0025-1018 or higher (-1019, -1020) can be used in practice.
Name/revision of the terminal
If current ESI descriptions are available in the TwinCAT system, the last revision offered in the selection dialog matches the Beckhoff state of production. It is recommended to use the last device revision when creating a new configuration, if current Beckhoff devices are used in the real application. Older revisions should only be used if older devices from stock are to be used in the application.
In this case the process image of the device is shown in the configuration tree and can be parameterised as follows: linking with the task, CoE/DC settings, plug-in definition, startup settings, ...
Correction dialog with modifications
Once all modifications have been saved or accepted, click “OK” to transfer them to the real *.tsm configuration.
Change to Compatible Type
TwinCAT offers a function “Change to Compatible Type…” for the exchange of a device whilst retaining the links in the task.
Dialog “Change to Compatible Type…” (left: TwinCAT 2; right: TwinCAT 3)
This function is preferably to be used on AX5000 devices.
Change to Alternative Type
The TwinCAT System Manager offers a function for the exchange of a device: Change to Alternative Type
TwinCAT 2 Dialog Change to Alternative Type
If called, the System Manager searches in the procured device ESI (in this example: EL1202-0000) for details of compatible devices contained there. The configuration is changed and the ESI-EEPROM is overwritten at the same time – therefore this process is possible only in the online state (ConfigMode).


EtherCAT subscriber configuration

Commissioning [image] TwinCAT Development Environment [image] EtherCAT subscriber configuration
EtherCAT subscriber configuration
In the left-hand window of the TwinCAT 2 System Manager or the Solution Explorer of the TwinCAT 3 Development Environment respectively, click on the element of the terminal within the tree you wish to configure (in the example: EL3751 Terminal 3).
Branch element as terminal EL3751
In the right-hand window of the TwinCAT System manager (TwinCAT 2) or the Development Environment (TwinCAT 3), various tabs are now available for configuring the terminal. And yet the dimension of complexity of a subscriber determines which tabs are provided. Thus as illustrated in the example above the terminal EL3751 provides many setup options and also a respective number of tabs are available. On the contrary by the terminal EL1004 for example the tabs "General", "EtherCAT", "Process Data" and “Online“ are available only. Several terminals, as for instance the EL6695 provide special functions by a tab with its own terminal name, so “EL6695” in this case. A specific tab “Settings” by terminals with a wide range of setup options will be provided also (e.g. EL3751).
„General“ tab
“General” tab
Name | Name of the EtherCAT device
Id | Number of the EtherCAT device
Type | EtherCAT device type
Comment | Here you can add a comment (e.g. regarding the system).
Disabled | Here you can deactivate the EtherCAT device.
Create symbols | Access to this EtherCAT slave via ADS is only available if this control box is activated.
„EtherCAT“ tab
„EtherCAT“ tab
Type | EtherCAT device type
Product/Revision | Product and revision number of the EtherCAT device
Auto Inc Addr. | Auto increment address of the EtherCAT device. The auto increment address can be used for addressing each EtherCAT device in the communication ring through its physical position. Auto increment addressing is used during the start-up phase when the EtherCAT master allocates addresses to the EtherCAT devices. With auto increment addressing the first EtherCAT slave in the ring has the address 0000hex. For each further slave the address is decremented by 1 (FFFFhex, FFFEhex etc.).
EtherCAT Addr. | Fixed address of an EtherCAT slave. This address is allocated by the EtherCAT master during the start-up phase. Tick the control box to the left of the input field in order to modify the default value.
Previous Port | Name and port of the EtherCAT device to which this device is connected. If it is possible to connect this device with another one without changing the order of the EtherCAT devices in the communication ring, then this combination field is activated and the EtherCAT device to which this device is to be connected can be selected.
Advanced Settings | This button opens the dialogs for advanced settings.
The link at the bottom of the tab points to the product page for this EtherCAT device on the web.
“Process Data” tab
Indicates the configuration of the process data. The input and output data of the EtherCAT slave are represented as CANopen process data objects (Process Data Objects, PDOs). The user can select a PDO via PDO assignment and modify the content of the individual PDO via this dialog, if the EtherCAT slave supports this function.
“Process Data” tab
The process data (PDOs) transferred by an EtherCAT slave during each cycle are user data which the application expects to be updated cyclically or which are sent to the slave. To this end the EtherCAT master (Beckhoff TwinCAT) parameterizes each EtherCAT slave during the start-up phase to define which process data (size in bits/bytes, source location, transmission type) it wants to transfer to or from this slave. Incorrect configuration can prevent successful start-up of the slave.
For Beckhoff EtherCAT EL, ES, EM, EJ and EP slaves the following applies in general:
▪
The input/output process data supported by the device are defined by the manufacturer in the ESI/XML description. The TwinCAT EtherCAT Master uses the ESI description to configure the slave correctly.
▪
The process data can be modified in the system manager. See the device documentation.
Examples of modifications include: mask out a channel, displaying additional cyclic information, 16-bit display instead of 8-bit data size, etc.
▪
In so-called “intelligent” EtherCAT devices the process data information is also stored in the CoE directory. Any changes in the CoE directory that lead to different PDO settings prevent successful startup of the slave. It is not advisable to deviate from the designated process data, because the device firmware (if available) is adapted to these PDO combinations.
If the device documentation allows modification of process data, proceed as follows (see Figure “Configuring the process data”).
▪
A: select the device to configure
▪
B: in the “Process Data” tab select Input or Output under SyncManager (C)
▪
D: the PDOs can be selected or deselected
▪
H: the new process data are visible as linkable variables in the system manager
The new process data are active once the configuration has been activated and TwinCAT has been restarted (or the EtherCAT master has been restarted)
▪
E: if a slave supports this, Input and Output PDO can be modified simultaneously by selecting a so-called PDO record (“predefined PDO settings”).
Configuring the process data
Manual modification of the process data
According to the ESI description, a PDO can be identified as “fixed” with the flag “F” in the PDO overview (Fig. “Configuring the process data”, J). The configuration of such PDOs cannot be changed, even if TwinCAT offers the associated dialog (“Edit”). In particular, CoE content cannot be displayed as cyclic process data. This generally also applies in cases where a device supports download of the PDO configuration, “G”. In case of incorrect configuration the EtherCAT slave usually refuses to start and change to OP state. The System Manager displays an “invalid SM cfg” logger message: This error message (“invalid SM IN cfg” or “invalid SM OUT cfg”) also indicates the reason for the failed start.
A detailed description can be found at the end of this section.
„Startup“ tab
The Startup tab is displayed if the EtherCAT slave has a mailbox and supports the CANopen over EtherCAT (CoE) or Servo drive over EtherCAT protocol. This tab indicates which download requests are sent to the mailbox during startup. It is also possible to add new mailbox requests to the list display. The download requests are sent to the slave in the same order as they are shown in the list.
„Startup“ tab
Column
Description
Transition
Transition to which the request is sent. This can either be
▪
the transition from pre-operational to safe-operational (PS), or
▪
the transition from safe-operational to operational (SO).
If the transition is enclosed in "<>" (e.g. <PS>), the mailbox request is fixed and cannot be modified or deleted by the user.
Protocol
Type of mailbox protocol
Index
Index of the object
Data
Date on which this object is to be downloaded.
Comment
Description of the request to be sent to the mailbox
Move Up | This button moves the selected request up by one position in the list.
Move Down | This button moves the selected request down by one position in the list.
New | This button adds a new mailbox download request to be sent during startup.
Delete | This button deletes the selected entry.
Edit | This button edits an existing request.
“CoE – Online” tab
The additional CoE - Online tab is displayed if the EtherCAT slave supports the CANopen over EtherCAT (CoE) protocol. This dialog lists the content of the object list of the slave (SDO upload) and enables the user to modify the content of an object from this list. Details for the objects of the individual EtherCAT devices can be found in the device-specific object descriptions.
“CoE – Online” tab
Object list display
Column | Description
Index | Index and sub-index of the object
Name | Name of the object
Flags | RW | The object can be read, and data can be written to the object (read/write)
 | RO | The object can be read, but no data can be written to the object (read only)
 | P | An additional P identifies the object as a process data object.
Value | Value of the object
Update List | The Update list button updates all objects in the displayed list
Auto Update | If this check box is selected, the content of the objects is updated automatically.
Advanced | The Advanced button opens the Advanced Settings dialog. Here you can specify which objects are displayed in the list.
Dialog “Advanced settings”
Online - via SDO Information | If this option button is selected, the list of the objects included in the object list of the slave is uploaded from the slave via SDO information. The list below can be used to specify which object types are to be uploaded.
Offline - via EDS File | If this option button is selected, the list of the objects included in the object list is read from an EDS file provided by the user.
„Online“ tab
„Online“ tab
State Machine
Init | This button attempts to set the EtherCAT device to the Init state.
Pre-Op | This button attempts to set the EtherCAT device to the pre-operational state.
Op | This button attempts to set the EtherCAT device to the operational state.
Bootstrap | This button attempts to set the EtherCAT device to the Bootstrap state.
Safe-Op | This button attempts to set the EtherCAT device to the safe-operational state.
Clear Error | This button attempts to delete the fault display. If an EtherCAT slave fails during change of state it sets an error flag. Example: An EtherCAT slave is in PREOP state (pre-operational). The master now requests the SAFEOP state (safe-operational). If the slave fails during change of state it sets the error flag. The current state is now displayed as ERR PREOP. When the Clear Error button is pressed the error flag is cleared, and the current state is displayed as PREOP again.
Current State | Indicates the current state of the EtherCAT device.
Requested State | Indicates the state requested for the EtherCAT device.
DLL Status
Indicates the DLL status (data link layer status) of the individual ports of the EtherCAT slave. The DLL status can have four different states:
Status | Description
No Carrier / Open | No carrier signal is available at the port, but the port is open.
No Carrier / Closed | No carrier signal is available at the port, and the port is closed.
Carrier / Open | A carrier signal is available at the port, and the port is open.
Carrier / Closed | A carrier signal is available at the port, but the port is closed.
File Access over EtherCAT
Download | With this button a file can be written to the EtherCAT device.
Upload | With this button a file can be read from the EtherCAT device.
"DC" tab (Distributed Clocks)
"DC" tab (Distributed Clocks)
Operation Mode
Options (optional):
▪
FreeRun
▪
SM-Synchron
▪
DC-Synchron (Input based)
▪
DC-Synchron
Advanced Settings…
Advanced settings for readjustment of the real time determinant TwinCAT-clock
Detailed information to Distributed Clocks are specified on http://infosys.beckhoff.com:
Fieldbus Components → EtherCAT Terminals → EtherCAT System documentation → EtherCAT basics → Distributed Clocks
Additional information
•
Detailed description of Process Data tab


Detailed description of Process Data tab

Commissioning [image] TwinCAT Development Environment [image] EtherCAT subscriber configuration [image] Detailed description of Process Data tab
Detailed description of Process Data tab
Sync Manager
Lists the configuration of the Sync Manager (SM).
If the EtherCAT device has a mailbox, SM0 is used for the mailbox output (MbxOut) and SM1 for the mailbox input (MbxIn).
SM2 is used for the output process data (outputs) and SM3 (inputs) for the input process data.
If an input is selected, the corresponding PDO assignment is displayed in the PDO Assignment list below.
PDO Assignment
PDO assignment of the selected Sync Manager. All PDOs defined for this Sync Manager type are listed here:
▪
If the output Sync Manager (outputs) is selected in the Sync Manager list, all RxPDOs are displayed.
▪
If the input Sync Manager (inputs) is selected in the Sync Manager list, all TxPDOs are displayed.
The selected entries are the PDOs involved in the process data transfer. In the tree diagram of the System Manager these PDOs are displayed as variables of the EtherCAT device. The name of the variable is identical to the Name parameter of the PDO, as displayed in the PDO list. If an entry in the PDO assignment list is deactivated (not selected and greyed out), this indicates that the input is excluded from the PDO assignment. In order to be able to select a greyed out PDO, the currently selected PDO has to be deselected first.
Activation of PDO assignment
✓
If you have changed the PDO assignment, in order to activate the new PDO assignment,
1.
the EtherCAT slave has to run through the PS status transition cycle (from pre-operational to safe-operational) once (see Online tab),
2.
and the System Manager has to reload the EtherCAT slaves
( [image] button for TwinCAT 2 or [image] button for TwinCAT 3)
PDO list
List of all PDOs supported by this EtherCAT device. The content of the selected PDOs is displayed in the PDO Content list. The PDO configuration can be modified by double-clicking on an entry.
Column | Description
Index | PDO index.
Size | Size of the PDO in bytes.
Name | Name of the PDO. If this PDO is assigned to a Sync Manager, it appears as a variable of the slave with this parameter as the name.
Flags | F | Fixed content: The content of this PDO is fixed and cannot be changed by the System Manager.
 | M | Mandatory PDO. This PDO is mandatory and must therefore be assigned to a Sync Manager! Consequently, this PDO cannot be deleted from the PDO Assignment list
SM | Sync Manager to which this PDO is assigned. If this entry is empty, this PDO does not take part in the process data traffic.
SU | Sync unit to which this PDO is assigned.
PDO Content
Indicates the content of the PDO. If flag F (fixed content) of the PDO is not set the content can be modified.
Download
If the device is intelligent and has a mailbox, the configuration of the PDO and the PDO assignments can be downloaded to the device. This is an optional feature that is not supported by all EtherCAT slaves.
PDO Assignment
If this check box is selected, the PDO assignment that is configured in the PDO Assignment list is downloaded to the device on startup. The required commands to be sent to the device can be viewed in the Startup tab.
PDO Configuration
If this check box is selected, the configuration of the respective PDOs (as shown in the PDO list and the PDO Content display) is downloaded to the EtherCAT slave.


General Notes - EtherCAT Slave Application

Commissioning [image] General Notes - EtherCAT Slave Application
General Notes - EtherCAT Slave Application
This summary briefly deals with a number of aspects of EtherCAT Slave operation under TwinCAT. More detailed information on this may be found in the corresponding sections of, for instance, the EtherCAT System Documentation.
Diagnosis in real time: WorkingCounter, EtherCAT State and Status
Generally speaking an EtherCAT Slave provides a variety of diagnostic information that can be used by the controlling task.
This diagnostic information relates to differing levels of communication. It therefore has a variety of sources, and is also updated at various times.
Any application that relies on I/O data from a fieldbus being correct and up to date must make diagnostic access to the corresponding underlying layers. EtherCAT and the TwinCAT System Manager offer comprehensive diagnostic elements of this kind. Those diagnostic elements that are helpful to the controlling task for diagnosis that is accurate for the current cycle when in operation (not during commissioning) are discussed below.
Selection of the diagnostic information of an EtherCAT Slave
In general, an EtherCAT Slave offers
▪
communication diagnosis typical for a slave (diagnosis of successful participation in the exchange of process data, and correct operating mode)
This diagnosis is the same for all slaves.

as well as
▪
function diagnosis typical for a channel (device-dependent)
See the corresponding device documentation
The colors in Fig. “Selection of the diagnostic information of an EtherCAT Slave” also correspond to the variable colors in the System Manager, see Fig. “Basic EtherCAT Slave Diagnosis in the PLC”.
Colour | Meaning
yellow | Input variables from the Slave to the EtherCAT Master, updated in every cycle
red | Output variables from the Slave to the EtherCAT Master, updated in every cycle
green | Information variables for the EtherCAT Master that are updated acyclically. This means that it is possible that in any particular cycle they do not represent the latest possible status. It is therefore useful to read such variables through ADS.
Fig. “Basic EtherCAT Slave Diagnosis in the PLC” shows an example of an implementation of basic EtherCAT Slave Diagnosis. A Beckhoff EL3102 (2-channel analogue input terminal) is used here, as it offers both the communication diagnosis typical of a slave and the functional diagnosis that is specific to a channel. Structures are created as input variables in the PLC, each corresponding to the process image.
Basic EtherCAT Slave Diagnosis in the PLC
The following aspects are covered here:
Code
Function
Implementation
Application/evaluation
A
The EtherCAT Master's diagnostic information
updated acyclically (yellow) or provided acyclically (green).
At least the DevState is to be evaluated for the most recent cycle in the PLC.
The EtherCAT Master's diagnostic information offers many more possibilities than are treated in the EtherCAT System Documentation. A few keywords:
▪
CoE in the Master for communication with/through the Slaves
▪
Functions from TcEtherCAT.lib
▪
Perform an OnlineScan
B
In the example chosen (EL3102) the EL3102 comprises two analogue input channels that transmit a single function status for the most recent cycle.
Status
▪
the bit significations may be found in the device documentation
▪
other devices may supply more information, or none that is typical of a slave
In order for the higher-level PLC task (or corresponding control applications) to be able to rely on correct data, the function status must be evaluated there. Such information is therefore provided with the process data for the most recent cycle.
C
For every EtherCAT Slave that has cyclic process data, the Master displays, using what is known as a WorkingCounter, whether the slave is participating successfully and without error in the cyclic exchange of process data. This important, elementary information is therefore provided for the most recent cycle in the System Manager
1.
at the EtherCAT Slave, and, with identical contents
2.
as a collective variable at the EtherCAT Master (see Point A)
for linking.
WcState (Working Counter)
0: valid real-time communication in the last cycle
1: invalid real-time communication
This may possibly have effects on the process data of other Slaves that are located in the same SyncUnit
In order for the higher-level PLC task (or corresponding control applications) to be able to rely on correct data, the communication status of the EtherCAT Slave must be evaluated there. Such information is therefore provided with the process data for the most recent cycle.
D
Diagnostic information of the EtherCAT Master which, while it is represented at the slave for linking, is actually determined by the Master for the Slave concerned and represented there. This information cannot be characterized as real-time, because it
▪
is only rarely/never changed, except when the system starts up
▪
is itself determined acyclically (e.g. EtherCAT Status)
State
current Status (INIT..OP) of the Slave. The Slave must be in OP (=8) when operating normally.
AdsAddr
The ADS address is useful for communicating from the PLC/task via ADS with the EtherCAT Slave, e.g. for reading/writing to the CoE. The AMS-NetID of a slave corresponds to the AMS-NetID of the EtherCAT Master; communication with the individual Slave is possible via the port (= EtherCAT address).
Information variables for the EtherCAT Master that are updated acyclically. This means that it is possible that in any particular cycle they do not represent the latest possible status. It is therefore possible to read such variables through ADS.
Note
Diagnostic information
It is strongly recommended that the diagnostic information made available is evaluated so that the application can react accordingly.
CoE Parameter Directory
The CoE parameter directory (CanOpen-over-EtherCAT) is used to manage the set values for the slave concerned. Changes may, in some circumstances, have to be made here when commissioning a relatively complex EtherCAT Slave. It can be accessed through the TwinCAT System Manager, see Fig. “EL3102, CoE directory”:
EL3102, CoE directory
EtherCAT System Documentation
The comprehensive description in the EtherCAT System Documentation (EtherCAT Basics --> CoE Interface) must be observed!
A few brief extracts:
▪
Whether changes in the online directory are saved locally in the slave depends on the device. EL terminals (except the EL66xx) are able to save in this way.
▪
The user must manage the changes to the StartUp list.
Commissioning aid in the TwinCAT System Manager
Commissioning interfaces are being introduced as part of an ongoing process for EL/EP EtherCAT devices. These are available in TwinCAT System Managers from TwinCAT 2.11R2 and above. They are integrated into the System Manager through appropriately extended ESI configuration files.
Example of commissioning aid for a EL3204
This commissioning process simultaneously manages
▪
CoE Parameter Directory
▪
DC/FreeRun mode
▪
the available process data records (PDO)
Although the "Process Data", "DC", "Startup" and "CoE-Online" that used to be necessary for this are still displayed, it is recommended that, if the commissioning aid is used, the automatically generated settings are not changed by it.
The commissioning tool does not cover every possible application of an EL/EP device. If the available setting options are not adequate, the user can make the DC, PDO and CoE settings manually, as in the past.
EtherCAT State: automatic default behaviour of the TwinCAT System Manager and manual operation
After the operating power is switched on, an EtherCAT Slave must go through the following statuses
▪
INIT
▪
PREOP
▪
SAFEOP
▪
OP
to ensure sound operation. The EtherCAT Master directs these statuses in accordance with the initialization routines that are defined for commissioning the device by the ES/XML and user settings (Distributed Clocks (DC), PDO, CoE). See also the section on "Principles of Communication, EtherCAT State Machine" in this connection. Depending how much configuration has to be done, and on the overall communication, booting can take up to a few seconds.
The EtherCAT Master itself must go through these routines when starting, until it has reached at least the OP target state.
The target state wanted by the user, and which is brought about automatically at start-up by TwinCAT, can be set in the System Manager. As soon as TwinCAT reaches the status RUN, the TwinCAT EtherCAT Master will approach the target states.
Standard setting
The advanced settings of the EtherCAT Master are set as standard:
▪
EtherCAT Master: OP
▪
Slaves: OP
This setting applies equally to all Slaves.
Default behaviour of the System Manager
In addition, the target state of any particular Slave can be set in the "Advanced Settings" dialogue; the standard setting is again OP.
Default target state in the Slave
Manual Control
There are particular reasons why it may be appropriate to control the states from the application/task/PLC. For instance:
▪
for diagnostic reasons
▪
to induce a controlled restart of axes
▪
because a change in the times involved in starting is desirable
In that case it is appropriate in the PLC application to use the PLC function blocks from the TcEtherCAT.lib, which is available as standard, and to work through the states in a controlled manner using, for instance, FB_EcSetMasterState.
It is then useful to put the settings in the EtherCAT Master to INIT for master and slave.
PLC function blocks
Note regarding E-Bus current
EL/ES terminals are placed on the DIN rail at a coupler on the terminal strand. A Bus Coupler can supply the EL terminals added to it with the E-bus system voltage of 5 V; a coupler is thereby loadable up to 2 A as a rule. Information on how much current each EL terminal requires from the E-bus supply is available online and in the catalogue. If the added terminals require more current than the coupler can supply, then power feed terminals (e.g. EL9410) must be inserted at appropriate places in the terminal strand.
The pre-calculated theoretical maximum E-Bus current is displayed in the TwinCAT System Manager as a column value. A shortfall is marked by a negative total amount and an exclamation mark; a power feed terminal is to be placed before such a position.
Illegally exceeding the E-Bus current
From TwinCAT 2.11 and above, a warning message "E-Bus Power of Terminal..." is output in the logger window when such a configuration is activated:
Warning message for exceeding E-Bus current
Note
Caution! Malfunction possible!
The same ground potential must be used for the E-Bus supply of all EtherCAT terminals in a terminal block!


Process data

Commissioning [image] Process data
Process data
Additional information
•
Sync Manager
•
Settings
•
Timestamp Distributed Clocks


Sync Manager

Commissioning [image] Process data [image] Sync Manager
Sync Manager
The scope of the process data offered can be viewed on the "Process data" tab.
The following figures show the assigned input process data objects (PDOs) of the EL34xx Sync Manager (SM3) as examples.
Process Data tab SM3, EL3423
Process Data tab SM3, EL3443
Process Data tab SM3, EL3453
Process Data tab SM3, EL3483
Predefined PDO Assignment
The "Predefined PDO Assignment" enables a simplified selection of the process data. The desired function is selected on the lower part of the "Process Data" tab. As a result, all necessary PDOs are automatically activated and the unnecessary PDOs are deactivated.
The following PDO assignments are available:
EL3423
Name | SM2, PDO assignment | SM3, PDO assignment
Default | - | 0x1A00 (L1 Status) 0x1A03 (L1 Energy) 0x1A0A (L2 Status) 0x1A0D (L2 Energy) 0x1A14 (L3 Status) 0x1A17 (L3 Energy) 0x1A1E (Total Total Status) 0x1A21 (Total Total Active) 0x1A22 (Total Total Apparent) 0x1A23 (Total Total Reactive)
Default + Statistics | - | 0x1A00 (L1 Status) 0x1A03 (L1 Energy) 0x1A06 (L1 Statistic Voltage) 0x1A0A (L2 Status) 0x1A0D (L2 Energy) 0x1A10 (L2 Statistic Voltage) 0x1A14 (L3 Status) 0x1A17 (L3 Energy) 0x1A1A (L3 Statistic Voltage) 0x1A1E (Total Total Status) 0x1A20 (Total Total Advanced) 0x1A26 (Total Total Statistic Power) 0x1A27 (Total Total Statistic PQF) 0x1A28 (Total Total Interval Energy)
EL3443
Name | SM2, PDO assignment | SM3, PDO assignment
Default | - | 0x1A00 (L1 Status) 0x1A01 (L1 Basic) 0x1A02 (L1 Power) 0x1A04 (L1 Timing) 0x1A0A (L2 Status) 0x1A0B (L2 Basic) 0x1A0C (L2 Power) 0x1A0E (L2 Timing) 0x1A14 (L3 Status) 0x1A15 (L3 Basic) 0x1A16 (L3 Power) 0x1A18 (L3 Timing) 0x1A1E (Total Total Status) 0x1A1F (Total Total Basic) 0x1A21 (Total Total Active) 0x1A24 (Total Total L-L Voltage)
Default + Variant | 0x1600 (Total Outputs Device) | 0x1A00 (L1 Status) 0x1A01 (L1 Basic) 0x1A02 (L1 Power) 0x1A04 (L1 Timing) 0x1A0A (L2 Status) 0x1A0B (L2 Basic) 0x1A0C (L2 Power) 0x1A0E (L2 Timing) 0x1A14 (L3 Status) 0x1A15 (L3 Basic) 0x1A16 (L3 Power) 0x1A18 (L3 Timing)) 0x1A1E (Total Total Status) 0x1A1F (Total Total Basic) 0x1A25 (Total Variant Value In)
Advanced | - | 0x1A00 (L1 Status) 0x1A01 (L1 Basic) 0x1A02 (L1 Power) 0x1A03 (L1 Energy) 0x1A04 (L1 Timing) 0x1A0A (L2 Status) 0x1A0B (L2 Basic) 0x1A0C (L2 Power) 0x1A0D (L2 Energy) 0x1A0E (L2 Timing) 0x1A14 (L3 Status) 0x1A15 (L3 Basic) 0x1A16 (L3 Power) 0x1A17 (L3 Energy) 0x1A18 (L3 Timing)) 0x1A1E (Total Total Status) 0x1A1F (Total Total Basic) 0x1A20 (Total Total Advanced) 0x1A21 (Total Total Active)
Total Only | 0x1600 (Total Outputs Device) | 0x1A00 (L1 Status) 0x1A0A (L2 Status) 0x1A14 (L3 Status) 0x1A1E (Total Total Status) 0x1A1F (Total Total Basic) 0x1A20 (Total Total Advanced) 0x1A21 (Total Total Active) 0x1A22 (Total Total Apparent) 0x1A23 (Total Total Reactive) 0x1A24 (Total Total L-L Voltage) 0x1A25 (Total Variant Value In) 0x1A26 (Total Total Statistic Power) 0x1A27 (Total Total Statistic PQF) 0x1A28 (Total Total Interval Energy)
Classic | 0x1600 (Total Outputs Device) | 0x1A00 (L1 Status) 0x1A09 (L1 Classic) 0x1A0A (L2 Status) 0x1A13 (L2 Classic) 0x1A14 (L3 Status) 0x1A1D (L3 Classic) 0x1A1E (Total Total Status)
Single Phase | 0x1600 (Total Outputs Device) 0x1601 (Total Interval) | 0x1A00 (L1 Status) 0x1A01 (L1 Basic) 0x1A02 (L1 Power) 0x1A03 (L1 Energy) 0x1A04 (L1 Timing) 0x1A06 (L1 Statistic Voltage) 0x1A1E (Total Total Status) 0x1A1F (Total Total Basic) 0x1A25 (Total Variant Value In) 0x1A28 (Total Total Interval Energy)
EL3453
Name | SM2, PDO assignment | SM3, PDO assignment
Default | - | 0x1A00 (L1 Status) 0x1A01 (L1 Basic) 0x1A02 (L1 Power) 0x1A0C (L2 Status) 0x1A0D (L2 Basic) 0x1A0E (L2 Power) 0x1A18 (L3 Status) 0x1A19 (L3 Basic) 0x1A1A (L3 Power) 0x1A24 (Total Status) 0x1A25 (Total Basic)
Default + Variant | 0x1600 (Total Variant Value Out) | 0x1A00 (L1 Status) 0x1A01 (L1 Basic) 0x1A02 (L1 Power) 0x1A0C (L2 Status) 0x1A0D (L2 Basic) 0x1A0E (L2 Power) 0x1A18 (L3 Status) 0x1A19 (L3 Basic) 0x1A1A (L3 Power) 0x1A24 (Total Status) 0x1A25 (Total Basic) 0x1A2E (Total Variant Value In)
Advanced | - | 0x1A00 (L1 Status) 0x1A01 (L1 Basic) 0x1A02 (L1 Power) 0x1A07 (L1 Advanced) 0x1A0C (L2 Status) 0x1A0D (L2 Basic) 0x1A0E (L2 Power) 0x1A13 (L2 Advanced) 0x1A18 (L3 Status) 0x1A19 (L3 Basic) 0x1A1A (L3 Power) 0x1A1F (L3 Advanced) 0x1A24 (Total Status) 0x1A25 (Total Basic) 0x1A26 (Total Advanced)
Total Only | 0x1600 (Total Variant Value Out) | 0x1A00 (L1 Status) 0x1A0C (L2 Status) 0x1A18 (L3 Status) 0x1A24(Total Status) 0x1A25 (Total Basic) 0x1A26(Total Advanced) 0x1A27(Active) 0x1A29 (Total Apparent) 0x1A2B (Total Reactive) 0x1A2E (Total Variant Value In)
Classic | 0x1600 (Total Variant Value Out) | 0x1A00 (L1 Status) 0x1A0B (L1 Classic) 0x1A0C (L2 Status) 0x1A17 (L2 Classic) 0x1A18 (L3 Status) 0x1A23 (L3 Classic) 0x1A2E (Total Variant Value In)
Single Phase | 0x1600 (Total Outputs Device) 0x1601 (Total Interval) | 0x1A00 (L1 Status) 0x1A01 (L1 Basic) 0x1A02 (L1 Power) 0x1A06 (L1 Timing) 0x1A07 (L1 Advanced) 0x1A24 (Total Status)
EL3483
Name | SM2, PDO assignment | SM3, PDO assignment
Default | - | 0x1A00 (L1 Status) 0x1A0A (L2 Status) 0x1A14 (L3 Status) 0x1A1E (Total Total Status) 0x1A20 (Total Total Advanced)


Settings

Commissioning [image] Process data [image] Settings
Settings
"Settings" Tab
"Settings" tab
The "Settings" tab provides direct access to the most important configuration objects in the object data dictionary. It facilitates the terminal configuration.
The Import/Export button can be used to save and reload existing settings.
Confirmation of variable output values 1 - 4
(PDOs: PMX Variant Value In, Subindex "Index" [0xF60A:12, 0xF60A:14, 0xF60A:16, 0xF60A:18])
The calculated values can be output on the PDOs: PMX Variant Value In, Subindex "Variant value In" [0xF60A:12, 0xF60A:14, 0xF60A:16, 0xF60A:18].
To this end, the corresponding values for the measured value to be output should be entered in the PDOs: PMX Variant Value Out, Subindex "PMX Variant Value Out" [0xF700:11, 0xF700:12, 0xF700:13, 0xF700:14].
Assignment of variable output values plus channel offset (256 for channel 1; 512 for channel 2 or 768 for channel 3)
Values (dec), Entry in PDOs: PMX Variant Value In Index 1-3 REAL [0xF700:11, 0xF700:12.] 0xF700:13] | Values (dec), Entry in PDOs: PMX Variant Value In Index 4 ULINT [0xF700:14] | Meaning | Unit | Description
1 (Examp.: 257 = 1 + 256 for ch. 1) | - | U RMS | V | RMS value of the voltage
2 (Examp.: 770 = 2 + 768 for ch. 3) | - | U peak | V | Peak value of the instantaneous voltage in the last interval
- | 3 | U Last Zero Cross | V | DC time of the penultimate voltage zero crossing
4 | - | U RMS Minimum | V | Minimum RMS value of the voltage in the last interval
5 | - | U RMS Maximum | V | Maximum RMS value of the voltage in the last interval
6 | - | ULL | V | RMS value of the phase-to-phase voltage (Channel 1: U_L1L2; Channel 1: U_L2L3; Channel 3: U_L3L1)
8 | - | I RMS | A | RMS value of the current
9 | - | I peak | A | Peak value of the instantaneous current in the last interval
- | 10* | I Last Zero Cross | ns | DC time of the last current zero crossing
11 | - | I RMS Minimum | A | Minimum RMS value of the current in the last interval
12 | - | I RMS Maximum | A | Maximum RMS value of the current in the last interval
17 | - | Frequency | Hz | Frequency of this phase
21 | - | Phi | ° | Phase angle of the fundamental wave
22 | - | Cos phi | - | Cosine of the fundamental wave phase angle
23 | - | Power Factor | - | Power factor
26 | - | P | W | Active power
27 | - | Pavg | W | Average active power during the last interval
28 | - | Pmin | W | Minimum active power in the last interval
29 | - | Pmax | W | Maximum active power in the last interval
30* | - | Pfund | W | Fundamental wave active power in the last interval
32 | - | S | VA | Apparent power
33 | - | Savg | VA | Average apparent power during the last interval
34 | - | Smin | VA | Minimum apparent power in last interval
35 | - | Smax | VA | Minimum apparent power in last interval
36* | - | Sfund | VA | Fundamental wave apparent power in the last interval
38 | - | Q | Var | Reactive power
39 | - | Qavg | Var | Average reactive power average during the last interval
40 | - | Qmin | Var | Minimum reactive power in the last interval
41 | - | Qmax | Var | Maximum reactive power in the last interval
42* | - | Qfund | Var | Fundamental wave reactive power in last interval
- | 45 | EP | mhW | Recorded active energy
- | 46 | EP pos | mhW | Received active energy
- | 47 | EP neg | mhW | Supplied active energy
- | 51 | ES | mhW | Apparent energy
- | 52 | ES pos | mhW |
- | 53 | ES neg | mhW |
- | 57 | EQ | mhW | Reactive energy
- | 58 | EQ pos | mhW |
- | 59 | EQ neg | mhW |
- | 63* | EP_fund | mhW | Balanced fundamental wave active energy
- | 64* | EP pos_fund | mhW | Related fundamental wave active energy
- | 65* | EP neg_fund | mhW | Input fundamental wave active energy
- | 69* | ES _fund | mhW | Fundamental wave apparent energy
- | 70* | ES pos_fund | mhW |
- | 71* | ES neg_fund | mhW |
- | 75* | EQ _fund | mhW | Balanced fundamental wave reactive energy
- | 76* | EQ pos_fund | mhW | Inductive fundamental wave reactive energy
- | 77* | EQ neg_fund | mhW | Capacitive fundamental wave reactive energy
95 |  | THD_U | - | "Total Harmonic Distortion" is the distortion factor of the voltage. It indicates the ratio of the harmonic components of an oscillation relative to its fundamental.
98 |  | RMS_fund_U | V | Amplitude of the fundamental wave
99 |  | F_Ref_U | Hz | Reference frequency of the voltage harmonic: Specifies the underlying fundamental frequency, e.g.: 50 or 60 Hz.
100-141 - 163* |  | Harmonics U 0 to 41 up to 63* | % of the fundamental wave | 0 => DC component 1 => fundamental wave 2=> 2nd harmonic 3=> 3rd harmonic
165 |  | THD_I | - | "Total Harmonic Distortion" is the distortion factor of the current. It indicates the ratio of the harmonic components of an oscillation relative to its fundamental.
166 |  | TDD_I | % of the maximum current | "Total Demand Distortion" indicates the ratio between the current harmonics and the maximum current (EL3443: 1A and EL3443-0010: 5A)
168 |  | RMS_fund_I | A | Amplitude of the fundamental wave
169 |  | F_Ref_I | Hz | Reference frequency of the current harmonic: Specifies the underlying fundamental frequency, e.g.: 50 or 60 Hz.
170-211 - 233* |  | Harmonics I 0 to 41 up to 63* | % of the fundamental wave | 0 => DC component 1 => fundamental wave 2=> 2nd harmonic 3=> 3rd harmonic
255 |  | Error: INDEX not valid | - | Error message: The selected index is not available.
Values with star* are only available in the EL3453.
Assignment of variable output values across all channels
Values (dec), Entry in PDOs: PMX Variant Value In Index 1-3 REAL [0xF700:11, 0xF700:12, 0xF700:13] | Values (dec), Entry in PDOs: PMX Variant Value In Index 4 ULINT [0xF700:14] | Meaning | Unit | Description
1032 (= 1024 + 8) | - | In RMS | A | Calculated RMS value of the neutral current
1033 (= 1024 + 9)* | - | In peak | A | Highest peak value of the instantaneous current in the last interval
1035 (= 1024 + 11)* | - | In RMS Minimum | A | Smallest effective value of the current in the last interval
1036 (= 1024 + 12)* | - | In RMS Maximum | A | Largest effective value of the current in the last interval
1041 (= 1024 + 17)* | - | Frequency | Hz | Frequency of the PDO value set via CoE (see reference channel of frequency measurement)
1047 (= 1024 + 23) | - | Power Factor | - | Total power factor over all phases
1050 (= 1024 + 26) | - | Ptot | W | Total active power
1051 (= 1024 + 27) | - | Ptotavg | W | Average total active power during the last interval
1052 (= 1024 + 28) | - | Ptotmin | W | Minimum total active power in the last interval
1053 (= 1024 + 29) | - | Ptotmax | W | Maximum total active power in the last interval
1056 (= 1024 + 32) | - | Stot | VA | Total apparent power
1057 (= 1024 + 33) | - | Stotavg | VA | Average total apparent power during the last interval
1058 (= 1024 + 34) | - | Stotmin | VA | Minimum total apparent power in the last interval
1059 (= 1024 + 35) | - | Stotmax | VA | Maximum total apparent power in the last interval
1062 (= 1024 + 38) | - | Qtot | Var | Total reactive power
1063 (= 1024 + 39) | - | Qtotavg | Var | Average total reactive power during the last interval
1064 (= 1024 + 40) | - | Qtotmin | Var | Minimum total reactive power in the last interval
1065 (= 1024 + 41) | - | Qtotmax | Var | Maximum total reactive power in the last interval
- | 1069 (= 1024 + 45) | Eptot | mWh | Balanced total active energy
- | 1070 (= 1024 + 46) | EPtot pos | mWh | Related total active energy
- | 1071 (= 1024 + 47) | EPtot neg | mWh | Input total active energy
- | 1072 (= 1024 + 48) | Eptot_intervall | mWh | Balanced total active energy in last interval
- | 1073 (= 1024 + 49) | EPtot pos_intervall | mWh | Total active energy related in the last interval
- | 1074 (= 1024 + 50) | EPtot neg_intervall | mWh | Input total active energy the last interval
- | 1075 (= 1024 + 51) | EStot | mWh | Total apparent energy
- | 1076 (= 1024 + 52) | EStot pos | mWh |
- | 1077 (= 1024 + 53) | EStot neg | mWh |
- | 1078 (= 1024 + 54) | EStot_intervall | mWh | Total apparent energy in the last interval
- | 1079 (= 1024 + 55) | EStot pos_intervall | mWh |
- | 1080 (= 1024 + 56) | EStot neg_intervall | mWh |
- | 1081 (= 1024 + 57) | EQtot | mWh | Total reactive energy
- | 1082 (= 1024 + 58) | EQtot pos | mWh |
- | 1083 (= 1024 + 59) | EQtot neg | mWh |
- | 1084 (= 1024 + 60) | EQtot_intervall | mWh | Total reactive energy in the last interval
- | 1085 (= 1024 + 61) | EQtot pos_intervall | mWh |
- | 1086 (= 1024 + 62) | EQtot neg_intervall | mWh |
1094 (= 1024 + 70) | - | PhiL1L2 | ° | Phase shift angle between phase L1 and L2
1095 (= 1024 + 71) | - | PhiL1L3 | ° | Phase shift angle between phase L1 and L3
1096 (= 1024 + 72) | - | Unbalance | - | Ratio between negative and positive voltage system
1104 (= 1024 + 80) | - | PQF | - | Power quality factor
1105 (= 1024 + 81) | - | PQF Avg | - | Average value of the power quality factor during the last interval
1106 (= 1024 + 82) | - | PQF Min | - | Minimum power quality factor in the last interval
1107 (= 1024 + 83) | - | PQF Max | - | Maximum power quality factor in the last interval
1107 (= 1024 + 83) | - | PQF Max | - | Maximum power quality factor in the last interval
- | 1124 (= 1024 + 100)* | Eptot_fund | mWh | Balanced total fundamental wave active energy
- | 1125 (= 1024 + 101)* | EPtot_fund pos | mWh | Received total fundamental wave active energy
- | 1126 (= 1024 + 102)* | EPtot_fund neg | mWh | Supplied total fundamental wave active energy
- | 1127 (= 1024 + 103)* | Eptot_fund _intervall | mWh | Balanced total fundamental wave active energy in the last interval
- | 1128 (= 1024 + 104)* | EPtot_fund pos_intervall | mWh | Received total fundamental wave active energy in the last interval
- | 1129 (= 1024 + 105)* | EPtot_fund neg_intervall | mWh | Supplied total fundamental wave active energy in the last interval
- | 1130 (= 1024 + 106)* | EStot_fund | mWh | Total fundamental wave apparent energy
- | 1131 (= 1024 + 107)* | EStot_fund pos | mWh |
- | 1132 (= 1024 + 108)* | EStot_fund neg | mWh |
- | 1133 (= 1024 + 109)* | EStot_fund _intervall | mWh | Total fundamental wave apparent energy in the last interval
- | 1134 (= 1024 + 110)* | EStot_fund pos_intervall | mWh |
- | 1135 (= 1024 + 111)* | EStot_fund neg_intervall | mWh |
- | 1136 (= 1024 + 112)* | EQtot_fund | mWh | Balanced total fundamental wave reactive energy
- | 1137 (= 1024 + 113)* | EQtot_fund pos | mWh | Inductive total fundamental wave reactive energy
- | 1138 (= 1024 + 114)* | EQtot_fund neg | mWh | Capacitive total fundamental wave reactive energy
- | 1139 (= 1024 + 115)* | EQtot_fund _intervall | mWh | Balanced total fundamental wave reactive energy in the last interval
- | 1140 (= 1024 + 116)* | EQtot_fund pos_intervall | mWh | Inductive total fundamental wave reactive energy in the last interval
- | 1141 (= 1024 + 117)* | EQtot_fund neg_intervall | mWh | Capacitive total fundamental wave reactive energy in the last interval
1154 (= 1024 + 130)* | - | Ptot_fund | W | Total fundamental wave active power
1155 (= 1024 + 131)* | - | Ptotavg_fund | W | Total fundamental wave average active power during last interval
1156 (= 1024 + 132)* | - | Ptotmin_fund | W | Total fundamental wave minimum active power in the last interval
1157 (= 1024 + 133)* | - | Ptotmax_fund | W | Total fundamental wave maximum active power in the last interval
1160 (= 1024 + 136)* | - | Stot_fund | VA | Total fundamental wave apparent power
1161 (= 1024 + 137)* | - | Stotavg_fund | VA | Total fundamental wave average apparent power during last interval
1162 (= 1024 + 138)* | - | Stotmin_fund | VA | Total fundamental wave minimum apparent powerin the last interval
1163 (= 1024 + 139)* | - | Stotmax_fund | VA | Total fundamental wave maximum apparent power in the last interval
1166 (= 1024 + 142)* | - | Qtot_fund | Var | Total fundamental wave reactive power
1167 (= 1024 + 143)* | - | Qtotavg_fund | Var | Total fundamental wave avarage reactive power during last interval
1168 (= 1024 + 144)* | - | Qtotmin_fund | Var | Total fundamental wave minimum reactive power during last interval
1169 (= 1024 + 145)* | - | Qtotmax_fund | Var | Total fundamental wave maximum reactive power during last interval
Values with star* are only available in the EL3453.
Reference channel for the frequency measurement (index 0xF800:11 and index 0xF800:13)
The EL34xx can measure the frequency for a voltage path input signal and a current path input signal. CoE objects "Reference" and "Frequency Source" (F800:11 and F800:13) can be used to set which frequency is to be output as PDO.
Default: Voltage at channel 1
Power quality factor setting
To adapt the power quality factor to your mains supply, enter the nominal voltage and frequency in CoE object "0xF801 PMX Total Settings PQF". This can also be done via the "Settings" tab, which summarizes all the important terminal setting options in a user-friendly manner.


Timestamp Distributed Clocks

Commissioning [image] Process data [image] Timestamp Distributed Clocks
Timestamp Distributed Clocks
The terminal transfers the time of the voltage zero crossing as timestamp to objects 0x6006:12 (channel 1), 0x6016:12 (channel 2) or 0x6026:12 (channel 3), if the corresponding indices 0x1A04, 0x1A0E or 0x1A18 are enabled.


Scaling factors

Commissioning [image] Scaling factors
Scaling factors
If no floating point numbers can be used, the EL3443 can be operated in "Classic" mode, in which only integer values are transferred. The following overview shows the scaling factors required to calculate the actual values from the raw process data values.
If the transformer ratios are not stored in the terminal memory, they must also be subsequently calculated in the PLC.
If the transformer ratios are stored in the CoE (Index 80n0 PMX Settings) of the terminal, these can be skipped as scaling factors in the PLC.
Scaling factors for the "Classic" mode of the EL3443-00xx
Values | Calculation
Current | Raw values x 0.0001 A x current transformer ratio
Voltage | Raw values x 0.001 V x voltage transformer ratio
Active power | Raw values x 0.001 W x current and voltage transformer ratio
Apparent power | Raw values x 0.001 VA x current and voltage transformer ratio
Reactive power | Raw values x 0.001 VA x current and voltage transformer ratio
Energy | Raw values x 0.001 Wh x current and voltage transformer ratio
Frequency | Raw values x 0.001 Hz


Notices on analog specifications

Commissioning [image] Notices on analog specifications
Notices on analog specifications
Beckhoff I/O devices (terminals, boxes, modules) with analog inputs are characterized by a number of technical characteristic data; refer to the technical data in the respective documents.
Some explanations are given below for the correct interpretation of these characteristic data.
Additional information
•
Full scale value (FSV)
•
Measuring error/ measurement deviation
•
Temperature coefficient tK [ppm/K]
•
Single-ended/differential typification
•
Common-mode voltage and reference ground (based on differential inputs)
•
Dielectric strength
•
Temporal aspects of analog/digital conversion


Full scale value (FSV)

Commissioning [image] Notices on analog specifications [image] Full scale value (FSV)
Full scale value (FSV)
An I/O device with an analog input measures over a nominal measuring range that is limited by an upper and a lower limit (initial value and end value); these can usually be taken from the device designation.
The range between the two limits is called the measuring span and corresponds to the equation (end value - initial value). Analogous to pointing devices this is the measuring scale (see IEC 61131) or also the dynamic range.
For analog I/O devices from Beckhoff the rule is that the limit with the largest value is chosen as the full scale value of the respective product (also called the reference value) and is given a positive sign. This applies to both symmetrical and asymmetrical measuring spans.
Full scale value, measuring span
For the above examples this means:
▪
Measuring range 0...10 V: asymmetric unipolar, full scale value = 10 V, measuring span = 10 V
▪
Measuring range 4...20 mA: asymmetric unipolar, full scale value = 20 mA, measuring span = 16 mA
▪
Measuring range -200...1370°C: asymmetric bipolar, full scale value = 1370°C, measuring span = 1570°C
▪
Measuring range -10...+10 V: symmetric bipolar, full scale value = 10 V, measuring span = 20 V
This applies to analog output terminals/ boxes (and related Beckhoff product groups).


Measuring error/ measurement deviation

Commissioning [image] Notices on analog specifications [image] Measuring error/ measurement deviation
Measuring error/ measurement deviation
The relative measuring error (% of the full scale value) is referenced to the full scale value and is calculated as the quotient of the largest numerical deviation from the true value (‘measuring error’) referenced to the full scale value.
The measuring error is generally valid for the entire permitted operating temperature range, also called the ‘usage error limit’ and contains random and systematic portions of the referred device (i.e. ‘all’ influences such as temperature, inherent noise, aging, etc.).
It is always to be regarded as a positive/negative span with ±, even if it is specified without ± in some cases.
The maximum deviation can also be specified directly.
Example: Measuring range 0...10 V and measuring error < ± 0.3 % full scale value → maximum deviation ± 30 mV in the permissible operating temperature range.
Lower measuring error
Since this specification also includes the temperature drift, a significantly lower measuring error can usually be assumed in case of a constant ambient temperature of the device and thermal stabilization after a user calibration.
This applies to analog output devices.


Temperature coefficient tK [ppm/K]

Commissioning [image] Notices on analog specifications [image] Temperature coefficient tK [ppm/K]
Temperature coefficient tK [ppm/K]
An electronic circuit is usually temperature dependent to a greater or lesser degree. In analog measurement technology this means that when a measured value is determined by means of an electronic circuit, its deviation from the "true" value is reproducibly dependent on the ambient/operating temperature.
A manufacturer can alleviate this by using components of a higher quality or by software means.
The temperature coefficient, when indicated, specified by Beckhoff allows the user to calculate the expected measuring error outside the basic accuracy at 23 °C.
Due to the extensive uncertainty considerations that are incorporated in the determination of the basic accuracy (at 23 °C), Beckhoff recommends a quadratic summation.
Example: Let the basic accuracy at 23 °C be ±0.01% typ. (full scale value), tK = 20 ppm/K typ.; the accuracy A35 at 35 °C is wanted, hence ΔT = 12 K
General information about the measuring error_formula_en.png
Remarks:
ppm ≙ 10-6
% ≙ 10-2


Single-ended/differential typification

Commissioning [image] Notices on analog specifications [image] Single-ended/differential typification
Single-ended/differential typification
For analog inputs Beckhoff makes a basic distinction between two types: single-ended (SE) and differential (DIFF), referring to the difference in electrical connection with regard to the potential difference.
The diagram shows two-channel versions of an SE module and a DIFF module as examples for all multi-channel versions.
SE and DIFF module as 2-channel version
Note: Dashed lines indicate that the respective connection may not necessarily be present in each SE or DIFF module. Electrical isolated channels are operating as differential type in general, hence there is no direct relation (voltaic) to ground within the module established at all. Indeed, specified information to recommended and maximum voltage levels have to be taken into account.
The basic rule:
▪
Analog measurements always take the form of voltage measurements between two potential points.
For voltage measurements a large R is used, in order to ensure a high impedance. For current measurements a small R is used as shunt. If the purpose is resistance measurement, corresponding considerations are applied.
–
Beckhoff generally refers to these two points as input+/signal potential and input-/reference potential.
–
For measurements between two potential points two potentials have to be supplied.
–
Regarding the terms "single-wire connection" or "three-wire connection", please note the following for pure analog measurements: three- or four-wire connections can be used for sensor supply, but are not involved in the actual analog measurement, which always takes place between two potentials/wires.
In particular this also applies to SE, even though the term suggest that only one wire is required.
▪
The term "electrical isolation" should be clarified in advance.
Beckhoff IO modules feature 1..8 or more analog channels; with regard to the channel connection a distinction is made in terms of:
–
how the channels WITHIN a module relate to each other, or
–
how the channels of SEVERAL modules relate to each other.

The property of electrical isolation indicates whether the channels are directly connected to each other.
–
Beckhoff terminals/ boxes (and related product groups) always feature electrical isolation between the field/analog side and the bus/EtherCAT side. In other words, if two analog terminals/ boxes are not connected via the power contacts (cable), the modules are effectively electrically isolated.
–
If channels within a module are electrically isolated, or if a single-channel module has no power contacts, the channels are effectively always differential. See also explanatory notes below. Differential channels are not necessarily electrically isolated.
▪
Analog measuring channels are subject to technical limits, both in terms of the recommended operating range (continuous operation) and the destruction limit. Please refer to the respective terminal/ box documentation for further details.
Explanation
▪
differential (DIFF)
–
Differential measurement is the most flexible concept. The user can freely choose both connection points, input+/signal potential and input-/reference potential, within the framework of the technical specification.
–
A differential channel can also be operated as SE, if the reference potential of several sensors is linked. This interconnection may take place via the system GND.
–
Since a differential channel is configured symmetrically internally (cf. Fig. SE and DIFF module as 2-channel variant), there will be a mid-potential (X) between the two supplied potentials that is the same as the internal ground/reference ground for this channel. If several DIFF channels are used in a module without electrical isolation, the technical property VCM (common-mode voltage) indicates the degree to which the mean voltage of the channels may differ.
–
The internal reference ground may be accessible as connection point at the terminal/ box, in order to stabilize a defined GND potential in the terminal/ box. In this case it is particularly important to pay attention to the quality of this potential (noiselessness, voltage stability). At this GND point a wire may be connected to make sure that VCM,max is not exceeded in the differential sensor cable.
If differential channels are not electrically isolated, usually only one VCM, max is permitted. If the channels are electrically isolated this limit should not apply, and the channels voltages may differ up to the specified separation limit.
–
Differential measurement in combination with correct sensor wiring has the special advantage that any interference affecting the sensor cable (ideally the feed and return line are arranged side by side, so that interference signals have the same effect on both wires) has very little effect on the measurement, since the potential of both lines varies jointly (hence the term common mode). In simple terms: Common-mode interference has the same effect on both wires in terms of amplitude and phasing.
–
Nevertheless, the suppression of common-mode interference within a channel or between channels is subject to technical limits, which are specified in the technical data.
–
Further helpfully information on this topic can be found on the documentation page Configuration of 0/4..20 mA differential inputs (see documentation for the EL30xx terminals, for example).
▪
Single Ended (SE)
–
If the analog circuit is designed as SE, the input/reference wire is internally fixed to a certain potential that cannot be changed. This potential must be accessible from outside on at least one point for connecting the reference potential, e.g. via the power contacts (cable).
–
In other words, in situations with several channels SE offers users the option to avoid returning at least one of the two sensor cables to the terminal/ box (in contrast to DIFF). Instead, the reference wire can be consolidated at the sensors, e.g. in the system GND.
–
A disadvantage of this approach is that the separate feed and return line can result in voltage/current variations, which a SE channel may no longer be able to handle. See common-mode interference. A VCM effect cannot occur, since the module channels are internally always 'hard-wired' through the input/reference potential.
Typification of the 2/3/4-wire connection of current sensors
Current transducers/sensors/field devices (referred to in the following simply as ‘sensor’) with the industrial 0/4-20 mA interface typically have internal transformation electronics for the physical measured variable (temperature, current, etc.) at the current control output. These internal electronics must be supplied with energy (voltage, current). The type of cable for this supply thus separates the sensors into self-supplied or externally supplied sensors:
Self-supplied sensors
▪
The sensor draws the energy for its own operation via the sensor/signal cable + and -.
So that enough energy is always available for the sensor’s own operation and open-circuit detection is possible, a lower limit of 4 mA has been specified for the 4-20 mA interface; i.e. the sensor allows a minimum current of 4 mA and a maximum current of 20 mA to pass.
▪
2-wire connection see Fig. 2-wire connection, cf. IEC60381-1
▪
Such current transducers generally represent a current sink and thus like to sit between + and – as a ‘variable load’. Refer also to the sensor manufacturer’s information.
2-wire connection
Therefore, they are to be connected according to the Beckhoff terminology as follows:
preferably to ‘single-ended’ inputs if the +Supply connections of the terminal/ box are also to be used - connect to +Supply and Signal
they can, however, also be connected to ‘differential’ inputs, if the termination to GND is then manufactured on the application side – to be connected with the right polarity to +Signal and –Signal
It is important to refer to the information page Configuration of 0/4..20 mA differential inputs (see documentation for the EL30xx terminals, for example)!
Externally supplied sensors
▪
3- and 4-wire connection see Fig. Connection of externally supplied sensors, cf. IEC60381-1
▪
the sensor draws the energy/operating voltage for its own operation from 2 supply cables of its own. One or two further sensor cables are used for the signal transmission of the current loop:
–
1 sensor cable: according to the Beckhoff terminology such sensors are to be connected to ‘single-ended’ inputs in 3 cables with +/-/Signal lines and if necessary FE/shield
–
2 sensor cables: for sensors with 4-wire connection based on +supply/-supply/+signal/-signal, check whether +signal can be connected to +supply or –signal to –supply.
- Yes: then you can connect accordingly to a Beckhoff ‘single-ended’ input.
- No: the Beckhoff ‘differential’ input for +Signal and –Signal is to be selected; +Supply and –Supply are to be connected via additional cables.
It is important to refer to the information page Configuration of 0/4..20 mA differential inputs (see documentation for the EL30xx terminals, for example)!
Note: expert organizations such as NAMUR demand a usable measuring range <4 mA/>20 mA for error detection and adjustment, see also NAMUR NE043.
The Beckhoff device documentation must be consulted in order to see whether the respective device supports such an extended signal range.
Usually there is an internal diode existing within unipolar terminals/ boxes (and related product groups), in this case the polarity/direction of current have to be observed.
Connection of externally supplied sensors
Classification of the Beckhoff terminals/ boxes - Beckhoff 0/4-20 mA terminals/ boxes (and related product groups) are available as differential and single-ended terminals/ boxes (and related product groups):
Single-ended EL3x4x: 0-20 mA, EL3x5x: 4-20 mA; KL and related product groups exactly the same | Differential EL3x1x: 0-20 mA, EL3x2x: 4-20 mA; KL and related product groups exactly the same
Preferred current direction because of internal diode | Preferred current direction because of internal diode
Designed for the connection of externally-supplied sensors with a 3/4-wire connection | The terminal/ box is a passive differential current measuring device; passive means that the sensor is not supplied with power.
Designed for the connection of self-supplied sensors with a 2-wire connection |
Single-ended
Differential
2-, 3- and 4-wire connection at single-ended and differential inputs


Common-mode voltage and reference ground (based on differential inputs)

Commissioning [image] Notices on analog specifications [image] Common-mode voltage and reference ground (based on differential inputs)
Common-mode voltage and reference ground (based on differential inputs)
Common-mode voltage (Vcm) is defined as the average value of the voltages of the individual connections/inputs and is measured/specified against reference ground.
Common-mode voltage (Vcm)
The definition of the reference ground is important for the definition of the permitted common-mode voltage range and for measurement of the common-mode rejection ratio (CMRR) for differential inputs.
The reference ground is also the potential against which the input resistance and the input impedance for single-ended inputs or the common-mode resistance and the common-mode impedance for differential inputs is measured.
The reference ground is usually accessible at or near the terminal/ box, e.g. at the terminal contacts, power contacts (cable) or a mounting rail. Please refer to the documentation regarding positioning. The reference ground should be specified for the device under consideration.
For multi-channel terminals/ boxes with resistive (=direct, ohmic, galvanic) or capacitive connection between the channels, the reference ground should preferably be the symmetry point of all channels, taking into account the connection resistances.
Reference ground samples for Beckhoff IO devices:
1.
Internal AGND fed out: EL3102/EL3112, resistive connection between the channels
2.
0V power contact: EL3104/EL3114, resistive connection between the channels and AGND; AGND connected to 0V power contact with low-resistance
3.
Earth or SGND (shield GND):
–
EL3174-0002: Channels have no resistive connection between each other, although they are capacitively coupled to SGND via leakage capacitors
–
EL3314: No internal ground fed out to the terminal points, although capacitive coupling to SGND


Dielectric strength

Commissioning [image] Notices on analog specifications [image] Dielectric strength
Dielectric strength
A distinction should be made between:
▪
Dielectric strength (destruction limit): Exceedance can result in irreversible changes to the electronics
–
Against a specified reference ground
–
Differential
▪
Recommended operating voltage range: If the range is exceeded, it can no longer be assumed that the system operates as specified
–
Against a specified reference ground
–
Differential
Recommended operating voltage range
The device documentation may contain particular specifications and timings, taking into account:
▪
Self-heating
▪
Rated voltage
▪
Insulating strength
▪
Edge steepness of the applied voltage or holding periods
▪
Normative environment (e.g. PELV)


Temporal aspects of analog/digital conversion

Commissioning [image] Notices on analog specifications [image] Temporal aspects of analog/digital conversion
Temporal aspects of analog/digital conversion
The conversion of the constant electrical input signal to a value-discrete digital and machine-readable form takes place in the analog Beckhoff EL/KL/EP input modules with ADC (analog digital converter). Although different ADC technologies are in use, from a user perspective they all have a common characteristic: after the conversion a certain digital value is available in the controller for further processing. This digital value, the so-called analog process data, has a fixed temporal relationship with the “original parameter”, i.e. the electrical input value. Therefore, corresponding temporal characteristic data can be determined and specified for Beckhoff analogue input devices.
This process involves several functional components, which act more or less strongly in every AI (analog input) module:
▪
the electrical input circuit
▪
the analog/digital conversion
▪
the digital further processing
▪
the final provision of the process and diagnostic data for collection at the fieldbus (EtherCAT, K‑bus, etc.)
Signal processing analog input
Two aspects are crucial from a user perspective:
▪
“How often do I receive new values?”, i.e. a sampling rate in terms of speed with regard to the device/channel
▪
What delay does the (whole) AD conversion of the device/channel cause?
I.e. the hardware and firmware components in its entirety. For technological reasons, the signal characteristics must be taken into account when determining this information: the run times through the system differ, depending on the signal frequency.
This is the “external” view of the “Beckhoff AI channel” system – internally the signal delay in particular is composed of different components: hardware, amplifier, conversion itself, data transport and processing. Internally a higher sampling rate may be used (e.g. in the deltaSigma converters) than is offered “externally” from the user perspective. From a user perspective of the “Beckhoff AI channel” component this is usually irrelevant or is specified accordingly, if it is relevant for the function.
For Beckhoff AI devices the following specification parameters for the AI channel are available for the user from a temporal perspective:
1. Minimum conversion time [ms, µs]
This is the reciprocal value of the maximum sampling rate [sps, samples per second]:
Indicates how often the analog channel makes a newly detected process data value available for collection by the fieldbus. Whether the fieldbus (EtherCAT, K-bus) fetches the value with the same speed (i.e. synchronous), or more quickly (if the AI channel operates in slow FreeRun mode) or more slowly (e.g. with oversampling), is then a question of the fieldbus setting and which modes the AI device supports.
For EtherCAT devices the so-called toggle bit indicates (by toggling) for the diagnostic PDOs when a newly determined analog value is available.
Accordingly, a maximum conversion time, i.e. a smallest sampling rate supported by the AI device, can be specified.
Corresponds to IEC 61131-2, section 7.10.2 2, “Sampling repeat time”
2. Typical signal delay
Corresponds to IEC 61131-2, section 7.10.2 1, “Sampling duration”. From this perspective it includes all internal hardware and firmware components, but not “external” delay components from the fieldbus or the controller (TwinCAT).
This delay is particularly relevant for absolute time considerations, if AI channels also provide a time stamp that corresponds to the amplitude value – which can be assumed to match the physically prevailing amplitude value at the time.
Due to the frequency-dependent signal delay time, a dedicated value can only be specified for a given signal. The value also depends on potentially variable filter settings of the channel.
A typical characterization in the device documentation may be:
2.1 Signal delay (step response)
Keywords: Settling time
The square wave signal can be generated externally with a frequency generator (note impedance!)
The 90 % limit is used as detection threshold.
The signal delay [ms, µs] is then the time interval between the (ideal) electrical square wave signal and the time at which the analog process value has reached the 90 % amplitude.
Diagram signal delay (step response)
2.2 Signal delay (linear)
Keyword: Group delay
Describes the delay of a signal with constant frequency
A test signal can be generated externally with a frequency generator, e.g. as sawtooth or sine. A simultaneous square wave signal would be used as reference.
The signal delay [ms, µs] is then the interval between the applied electrical signal with a particular amplitude and the moment at which the analog process value reaches the same value.
A meaningful range must be selected for the test frequency, e.g. 1/20 of the maximum sampling rate.
Diagram signal delay (linear)
3. Additional Information
May be provided in the specification, e.g.
▪
Actual sampling rate of the ADC (if different from the channel sampling rate)
▪
Time correction values for run times with different filter settings
▪
etc.


Object description and parameterization

Commissioning [image] Object description and parameterization
Object description and parameterization
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Parameterization via the CoE list (CAN over EtherCAT)
The EtherCAT device is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs). Please note the following general CoE notes when using/manipulating the CoE parameters:
- Keep a startup list if components have to be replaced
- Differentiation between online/offline dictionary, existence of current XML description
- use “CoE reload” for resetting changes
Introduction
The CoE overview contains objects for different intended applications:
▪
Objects required for parameterization during commissioning:
–
Restore object index 0x1011
–
Configuration data index 0xF800
▪
Objects intended for regular operation, e.g. through ADS access.
–
PM command object index 0xFB00
▪
Profile-specific objects:
–
Configuration data (vendor-specific) index 0x80nF
–
Input data index 0x60n0
–
Output data index 0x70n0
–
Information and diagnostic data index 0xF000, 0xF008, 0xF100, 0xF801 and 0xF80F
▪
Standard objects
The following section first describes the objects required for normal operation, followed by a complete overview of missing objects.
Additional information
•
EL3423
•
EL3443-00xx
•
EL3446
•
EL3453
•
EL3483-00xx


EL3423

Commissioning [image] Object description and parameterization [image] EL3423
EL3423
Additional information
•
Restore object
•
Configuration data
•
Configuration data (vendor-specific)
•
Input data
•
Output data
•
Information and diagnostic data
•
Standard objects
•
Command object


Restore object

Commissioning [image] Object description and parameterization [image] EL3423 [image] Restore object
Restore object
Index 1011 Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default parameters | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to “0x64616F6C” in the set value dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)


Configuration data

Commissioning [image] Object description and parameterization [image] EL3423 [image] Configuration data
Configuration data
Index 80n0 PMX settings (for ch.1, n = 0; ch.2, n = 1; ch.3, n = 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
80n0:0 | PMX Settings | Max. subindex | UINT8 | RO | 0x13 (19dec)
80n0:11 | Voltage Transformer Ratio | If a voltage transformer is used, its transmission ratio can be entered here. | REAL32 | RW | 0x3F800000 (1065353216dec)
80n0:12 | Current Transformer Ratio | The ratio of the current transformer used can be entered here. | REAL32 | RW | 0x3F800000 (1065353216dec)
80n0:13 | Current Transformer Delay | Here you can enter a possible time delay of the current transformers in milliseconds. | REAL32 | RW | 0x00000000 (0dec)
Index 80n1 PMX Guard Settings (for ch.1, n = 0; ch.2, n = 1; ch.3, n = 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
80n1:0 | PMX Guard Settings | Max. subindex | UINT8 | RO | 0x14 (20dec)
80n1:11 | Voltage Guard Min Error | Lower limit value for a voltage error message | REAL32 | RW | 0x40000000 (1073741824dec)
80n1:12 | Voltage Guard Min Warning | Lower limit value for a voltage warning message | REAL32 | RW | 0x434F0000 (1129250816dec)
80n1:13 | Voltage Guard Max Warning | Upper limit value for a voltage warning message | REAL32 | RW | 0x437D0000 (1132265472dec)
80n1:14 | Voltage Guard Max Error | Upper limit value for a voltage error message | REAL32 | RW | 0x438B0000 (1133182976dec)
Index F800 PMX Settings
Index (hex) | Name | Meaning |  | Data type | Flags | Default
F800:0 | PMX Settings | Max. subindex |  | UINT8 | RO | 0x16 (22dec)
F800:01 | Reset Interval | Manual restart of the measurement and statistics interval |  | BOOLEAN | RW | 0x00 (0dec)
F800:11 | Reference | Timing reference for the RMS calculation Set to "Current" if a current is to be measured without an applied voltage. permitted values: |  | UINT32 | RW | 0x00000000 (0dec)
 |  | 0 | Voltage (default)
 |  | 1 | Current
F800:12 | Measurement Range | Filter setting for determining the fundamental permitted values: |  | UINT32 | RW | 0x00000000 (0dec)
 |  | 0 | 25..65 Hz (default)
 |  | 1 | 25..400 Hz
 |  | 2 | 12..45 Hz
F800:13 | Frequency Source | Source of the system frequency permitted values: |  | BIT1 | RW | 0x00000000 (0dec)
 |  | 0 | Channel 1 (default)
 |  | 1 | Channel 2
 |  | 2 | Channel 3
F800:14 | Power Calculation Threshold | Noise reduction: Here you can enter a minimum limit value in percent for the power calculation, below which all values are zeroed. |  | REAL32 | RW | 0x3F800000 (1065353216dec)
F800:15 | Inaccurate Threshold Voltage | Limit value for the warning bit: Inaccurate Voltage |  | REAL32 | RW | 0x3FDC28F6 (1071393014dec)
F800:16 | Inaccurate Threshold Current | Limit value for the warning bit: Inaccurate Current |  | REAL32 | RW | 0x3BC49BA6 (1002740646dec)
Index F801 PMX Total Settings PQF
Index (hex) | Name | Meaning | Data type | Flags | Default
F801:0 | PMX Total Settings PQF | Max. subindex | UINT8 | RO | 0x13 (19dec)
F801:11 | Nominal voltage | A nominal voltage value or set value is required to calculate the power quality factor (for details see basic function principles). | REAL32 | RW | 0x43660000 (1130758144dec)
F801:12 | Nominal Frequency | A nominal frequency or set value is required to calculate the power quality factor (for details see basic function principles). | REAL32 | RW | 0x42480000 (1112014848dec)
F801:13 | PQF Dataset | permitted values: | UINT32 | RW | 0x00000001 (0dec)
 |  | 0: default 1: default + unbalace
Index F802 PMX Guard Settings
Index (hex) | Name | Meaning | Data type | Flags | Default
F802:0 | PMX Guard Settings | Max. subindex | UINT8 | RO | 0x28 (40dec)
F802:11 | Frequency Guard Min Error | Lower limit value for a frequency error message | REAL32 | RW | 47,000000 (4,700000e+001)
F802:12 | Frequency Guard Min Warning | Lower limit value for a frequency warning message | REAL32 | RW | 49,500000 (4,950000e+001)
F802:13 | Frequency Guard Max Warning | Upper limit value for a frequency warning message | REAL32 | RW | 50,500000 (5,050000e+001)
F802:14 | Frequency Guard Max Error | Upper limit value for a frequency error message | REAL32 | RW | 52,000000 (5,200000e+001)
F802:15 | Neutral Current Guard Min Error | Lower limit value for an error message of the neutral conductor current | REAL32 | RW | EL3423, EL3443 0,000000 (0,000000e+000) EL3453 -1,050000 (-1,050000e+000)
F802:16 | Neutral Current Guard Min Warning | Lower limit value for a warning message of the neutral conductor current | REAL32 | RW | EL3423, EL3443 0,000000 (0,000000e+000) EL3453 -1,000000 (-1,000000e+000)
F802:17 | Neutral Current Guard Max Warning | Upper limit value for a warning message of the neutral conductor current | REAL32 | RW | EL3423, EL3443 0,006000 (6,000000e-003) EL3453 1,000000 (1,000000e+000)
F802:18 | Neutral Current Guard Max Error | Upper limit value for an error message of the neutral conductor current | REAL32 | RW | EL3423, EL3443 0,030000 (3,000000e-002) EL3453 1,050000 (1,050000e+000)
F802:19 | Active Power Guard Min Error | Lower limit value for an active power error message | REAL32 | RW | 0,000000 (0,000000e+000)
F802:1A | Active Power Guard Min Warning | Lower limit value for an active power warning message | REAL32 | RW | 0,000000 (0,000000e+000)
F802:1B | Active Power Guard Max Warning | Upper limit value for an active power warning message | REAL32 | RW | 0,000000 (0,000000e+000)
F802:1C | Active Power Guard Max Error | Upper limit value for an active power error message | REAL32 | RW | 0,000000 (0,000000e+000)
F802:1D | Apparent Power Guard Min Error | Lower limit value for an apparent power error message | REAL32 | RW | 0,000000 (0,000000e+000)
F802:1E | Apparent Power Guard Min Warning | Lower limit value for an apparent power warning message | REAL32 | RW | 0,000000 (0,000000e+000)
F802:1F | Apparent Power Guard Max Warning | Upper limit value for an apparent power warning message | REAL32 | RW | 0,000000 (0,000000e+000)
F802:20 | Apparent Power Guard Max Error | Upper limit value for an apparent power error message | REAL32 | RW | 0,000000 (0,000000e+000)
F802:21 | PQF Guard Min Error | Lower limit value for a power quality factor error message | REAL32 | RW | 0,050000 (5,000000e-002)
F802:22 | PQF Guard Min Warning | Lower limit value for a power quality factor warning message | REAL32 | RW | 0,800000 (8,000000e-001)
F802:23 | PQF Guard Max Warning | Upper limit value for a power quality factor warning message | REAL32 | RW | 1,000000 (1,000000e+000)
F802:24 | PQF Guard Max Error | Upper limit value for a power quality factor error message | REAL32 | RW | 1,000000 (1,000000e+000)
F802:25 | Unbalance Guard Min Error | Lower limit value for an error message due to voltage imbalance | REAL32 | RW | 0,000000 (0,000000e+000)
F802:26 | Unbalance Guard Min Warning | Lower limit value for a warning message due to voltage imbalance | REAL32 | RW | 0,000000 (0,000000e+000)
F802:27 | Unbalance Guard Max Warning | Upper limit value for a warning message due to voltage imbalance | REAL32 | RW | EL3423, EL3453 0,000000 (0,000000e+000) EL3443 2,000000 (2,000000e+000)
F802:28 | Unbalance Guard Max Error | Upper limit value for an error message due to voltage imbalance | REAL32 | RW | EL3423, EL3453 0,000000 (0,000000e+000) EL3443 3,000000 (3,000000e+000)
Index F803 PMX Time Settings
Index (hex) | Name | Meaning | Data type | Flags | Default
F803:0 | PMX Time Settings | Max. subindex | UINT8 | RO | 0x13 (19dec)
F803:11 | Measurement Mode | permitted values: | UINT32 | RW | 0x00000000 (0dec)
 |  | 0
F803:12 | Measurement Interval | Time in seconds to automatic restart of the measurement and statistics interval | UINT32 | RW | 0x00000000 (0dec)
F803:13 | Actual System Time | Shows the current system time of the terminal. Write access to the object is possible in order to change the system time. | STRING | RW |


Configuration data (vendor-specific)

Commissioning [image] Object description and parameterization [image] EL3423 [image] Configuration data (vendor-specific)
Configuration data (vendor-specific)
Index 80nF PMX vendor data (for ch.1, n = 0; ch.2, n = 1; ch.3, n = 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
80nF:0 | PMX Vendor data | Max. subindex | UINT8 | RO | 0x16 (22dec)
80nF:11 | Calibration Voltage Offset | Value in V | REAL32 | RW | 0x00000000 (0dec)
80nF:12 | Calibration Voltage Gain | Factor (without unit) | REAL32 | RW | 0x3F800000 (1065353216dec)
80nF:13 | Calibration Voltage Phase Offset | Value in milliseconds | REAL32 | RW | 0x00000000 (0dec)
80nF:14 | Calibration Current Offset | Value in A | REAL32 | RW | 0x00000000 (0dec)
80nF:15 | Calibration Current Gain | Factor (without unit) | REAL32 | RW | 0x3F800000 (1065353216dec)
80nF:16 | Calibration Current Phase Offset | Value in milliseconds | REAL32 | RW | 0x00000000 (0dec)


Input data

Commissioning [image] Object description and parameterization [image] EL3423 [image] Input data
Input data
Index 60n0 PMX status (n = 0, 1, 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
60n0:0 | PMX Status | Max. subindex | UINT8 | RO | 0x10 (16dec)
60n0:01 | Voltage Sign Bit | Indicates the sign of the current sine wave voltage: 1 = U > 0V 0 = U < 0V | BOOLEAN | RO | 0x00 (0dec)
60n0:02 | Overvoltage | Maximum measurable voltage is exceeded. | BOOLEAN | RO | 0x00 (0dec)
60n0:03 | Overcurrent | Maximum measurable current is exceeded. | BOOLEAN | RO | 0x00 (0dec)
60n0:04 | Inaccurate Voltage | The measured voltage value is smaller than the value entered in CoE object "F800:15 Inaccurate Threshold Voltage". | BOOLEAN | RO | 0x00 (0dec)
60n0:05 | Inaccurate Current | The measured current value is smaller than the value entered in CoE object "F800:16 Inaccurate Threshold Current". | BOOLEAN | RO | 0x00 (0dec)
60n0:06 | Voltage Guard Warning | A warning limit of the voltage monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
60n0:07 | Voltage Guard Error | An error limit of the voltage monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
6000:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
Index 60n4 PMX Energy (n = 0, 1, 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
60n4:0 | PMX Energy | Max. subindex | UINT8 | RO | 0x13 (19dec)
60n4:11 | Active Energy | Active energy in mWh | INT64 | RO |
60n4:12 | Apparent Energy | Apparent energy in mVAh | INT64 | RO |
60n4:13 | Reactive Energy | Reactive energy in mvarh | INT64 | RO |
Index 60n8 PMX Statistic Voltage (n = 0, 1, 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
60n8:0 | PMX Statistic Voltage | Max Subindex | UINT8 | RO | 0x13 (19dec)
60n8:11 | Voltage Peak | Peak value of the instantaneous voltage in the last interval in V | REAL32 | RO | 0x00000000 (0dec)
60n8:12 | Voltage RMS Minimum | Minimum RMS value of the voltage in the last interval in V | REAL32 | RO | 0x00000000 (0dec)
60n8:13 | Voltage RMS Maximum | Maximum RMS value of the voltage in the last interval in V | REAL32 | RO | 0x00000000 (0dec)
Index 60n9 PMX Statistic Current (n = 0, 1, 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
60n9:0 | PMX Statistic Current | Max Subindex | UINT8 | RO | 0x13 (19dec)
60n9:11 | Current Peak | Peak value of the instantaneous current in the last interval in A | REAL32 | RO | 0x00000000 (0dec)
60n9:12 | Current RMS Minimum | Minimum RMS value of the current in the last interval in A | REAL32 | RO | 0x00000000 (0dec)
60n9:13 | Current RMS Maximum | Maximum RMS value of the current in the last interval in A | REAL32 | RO | 0x00000000 (0dec)
Index 60nA PMX Statistic Power (n = 0, 1, 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
60nA:0 | PMX Statistic Power | Max Subindex | UINT8 | RO | 0x19 (25dec)
60nA:11 | Active Power Avg | Average active power during the last interval in W | REAL32 | RO | 0x00000000 (0dec)
60nA:12 | Active Power Min | Minimum active power in the last interval in W | REAL32 | RO | 0x00000000 (0dec)
60nA:13 | Active Power Max | Maximum active power in the last interval in W | REAL32 | RO | 0x00000000 (0dec)
60nA:14 | Apparent Power Avg | Average apparent power during the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
60nA:15 | Apparent Power Max | Maximum apparent power in the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
60nA:16 | Reactive Power Avg | Average reactive power average during the last interval in var | REAL32 | RO | 0x00000000 (0dec)
60nA:17 | Reactive Power Min | Minimum reactive power in the last interval in var | REAL32 | RO | 0x00000000 (0dec)
60nA:18 | Reactive Power Max | Maximum reactive power in the last interval in var | REAL32 | RO | 0x00000000 (0dec)
60nA:19 | Apparent Power Min | Minimum apparent power in the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
Index F600 PMX Total Status
Index (hex) | Name | Meaning | Data type | Flags | Default
F600:0 | PMX Total Status | Max. subindex | UINT8 | RO | 0x11 (17dec)
F600:01 | System State | Overall system state (as a logical disjunction of voltage guard errors, phase sequence, overvoltage, overcurrent and frequency guard errors) | BOOLEAN | RO | 0x00 (0dec)
F600:02 | Grid Direction | Phase sequence L1 - L2 - L3 correctly detected (with clockwise 3-phase mains) | BOOLEAN | RO | 0x00 (0dec)
F600:03 | Frequency Guard Warning | A warning limit of the frequency monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:04 | Frequency Guard Error | An error limit of the frequency monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:05 | Neutral Current Guard Warning | A warning limit of the neutral conductor current monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:06 | Neutral Current Guard Error | An error limit of the neutral conductor current monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:07 | Active Power Guard Warning | A warning limit of the active power monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:08 | Active Power Guard Error | An error limit of the active power monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:09 | Apparent Power Guard Warning | A warning limit of the apparent power monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:0A | Apparent Power Guard Error | An error limit of the apparent power monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:0B | Power Quality Guard Warning | A warning limit of the PQF monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:0C | Power Quality Guard Error | An error limit of the PQF monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:0F | TxPDO State | TRUE for general error | BOOLEAN | RO | 0x00 (0dec)
F600:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
F600:11 | Power Quality Factor | Analog value of the voltage quality between 1.0 and 0 (see basic function principles - Power Quality Factor) | REAL32 | RO | 0x00000000 (0dec)
Index F602 PMX Total Advanced
Index (hex) | Name | Meaning | Data type | Flags | Default
F602:0 | PMX Total Advanced | Max. subindex | UINT8 | RO | 0x02 (2dec)
F602:01 | Unbalance Guard Warning | A warning limit of the unbalance monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F602:02 | Unbalance Guard Error | An error limit of the unbalance monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
Index F603 PMX Total Active
Index (hex) | Name | Meaning | Data type | Flags | Default
F603:0 | PMX Total Active | Max. subindex | UINT8 | RO | 0x14 (20dec)
F603:12 | Active Energy | Recorded active energy in mWh | INT64 | RO |
F603:13 | Active Positive Energy | Received active energy in mWh | INT64 | RO |
F603:14 | Active Negative Energy | Supplied active energy in mWh | INT64 | RO |
Index F605 PMX Total Apparent
Index (hex) | Name | Meaning | Data type | Flags | Default
F605:0 | PMX Total Apparent | Max. subindex | UINT8 | RO | 0x14 (20dec)
F605:12 | Apparent Energy | Recorded apparent energy in mWh | INT64 | RO |
F605:13 | Apparent Positive Energy | Received apparent energy in mWh | UINT64 | RO |
F605:14 | Apparent Negative Energy | Supplied apparent energy in mWh | UINT64 | RO |
Index F607 PMX Total Reactive
Index (hex) | Name | Meaning | Data type | Flags | Default
F607:0 | PMX Total Reactive | Max. subindex | UINT8 | RO | 0x14 (20dec)
F607:12 | Reactive Energy | Recorded reactive energy in mWh | INT64 | RO |
F607:13 | Reactive Positive Energy | Received reactive energy in mWh | UINT64 | RO |
F607:14 | Reactive Negative Energy | Supplied reactive energy in mWh | UINT64 | RO |
Index F60B PMX Total Statistic Power
Index (hex) | Name | Meaning | Data type | Flags | Default
F60B:0 | PMX Total Statistic Power | Max. subindex | UINT8 | RO | 0x19 (25dec)
F60B:11 | Active Power Avg | Average total active power during the last interval in W | REAL32 | RO | 0x00000000 (0dec)
F60B:12 | Active Power Min | Minimum total active power in the last interval in W | REAL32 | RO | 0x00000000 (0dec)
F60B:13 | Active Power Max | Maximum total active power in the last interval in W | REAL32 | RO | 0x00000000 (0dec)
F60B:14 | Apparent Power Avg | Average total apparent power during the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
F60B:15 | Apparent Power Min | Minimum total apparent power in the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
F60B:16 | Apparent Power Max | Maximum total apparent power in the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
F60B:17 | Reactive Power Avg | Average total reactive power average during the last interval in Var | REAL32 | RO | 0x00000000 (0dec)
F60B:18 | Reactive Power Min | Minimum total reactive power in the last interval in Var | REAL32 | RO | 0x00000000 (0dec)
F60B:19 | Reactive Power Max | Maximum total reactive power in the last interval in Var | REAL32 | RO | 0x00000000 (0dec)
Index F60C PMX Total Statistic PQF
Index (hex) | Name | Meaning | Data type | Flags | Default
F60C:0 | PMX Total Statistic PQF | Max. subindex | UINT8 | RO | 0x13 (19dec)
F60C:11 | PQF Avg | Average value of the power quality factor during the last interval | REAL32 | RO | 0x00000000 (0dec)
F60C:12 | PQF Min | Minimum power quality factor in the last interval | REAL32 | RO | 0x00000000 (0dec)
F60C:13 | PQF Max | Maximum power quality factor in the last interval | REAL32 | RO | 0x00000000 (0dec)
Index F60D PMX Total Interval Energy
Index (hex) | Name | Meaning | Data type | Flags | Default
F60D:0 | PMX Total Interval Energy | Max. subindex | UINT8 | RO | 0x19 (25dec)
F60D:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
F60D:11 | Active Energy | Recorded total active energy during the last interval in mWh | REAL32 | RO | 0x00000000 (0dec)
F60D:12 | Active Energy Positive | Received total active energy during the last interval in mWh | REAL32 | RO | 0x00000000 (0dec)
F60D:13 | Active Energy Negative | Supplied total active energy during at last interval in mWh | REAL32 | RO | 0x00000000 (0dec)
F60D:14 | Apparent Energy | Recorded total apparent energy during the last interval in mWh | REAL32 | RO | 0x00000000 (0dec)
F60D:15 | Apparent Energy Positive | Received total apparent energy during the last interval in mWh | REAL32 | RO | 0x00000000 (0dec)
F60D:16 | Apparent Energy Negative | Supplied total apparent energy during the last interval in mWh | REAL32 | RO | 0x00000000 (0dec)
F60D:17 | Reactive Energy | Recorded total reactive energy during the last interval in mWh | REAL32 | RO | 0x00000000 (0dec)
F60D:18 | Reactive Energy Positive | Received total reactive energy during the last interval in mWh | REAL32 | RO | 0x00000000 (0dec)
F60D:19 | Reactive Energy Negative | Supplied total reactive energy during the last interval in mWh | REAL32 | RO | 0x00000000 (0dec)
Index F612 PMX Total Active Reduced
Index (hex) | Name | Meaning | Data type | Flags | Default
F612:0 | PMX Total Active Reduced | Max. subindex | UINT8 | RO | 0x12 (18dec)
F612:11 | Active Power | Active power in W | REAL32 | RO | 0x00000000 (0dec)
F612:12 | Active Energy | Active energy in mWh | INT64 | RO | 0x00000000 (0dec)
Index F613 PMX Total Apparent Reduced
Index (hex) | Name | Meaning | Data type | Flags | Default
F613:0 | PMX Total Apparent Reduced | Max. subindex | UINT8 | RO | 0x12 (18dec)
F613:11 | Apparent Power | Apparent power in VA | REAL32 | RO | 0x00000000 (0dec)
F613:12 | Apparent Energy | Apparent energy in mVAh | INT64 | RO | 0x00000000 (0dec)
Index F614 PMX Total Reactive Reduced
Index (hex) | Name | Meaning | Data type | Flags | Default
F614:0 | PMX Total Reactive Reduced | Max. subindex | UINT8 | RO | 0x12 (18dec)
F614:11 | Reactive Power | Reactive power in var | REAL32 | RO | 0x00000000 (0dec)
F614:12 | Reactive Energy | Reactive energy in mvarh | INT64 | RO | 0x00000000 (0dec)
Index F615 PMX Total Interval Energy Reduced
Index (hex) | Name | Meaning | Data type | Flags | Default
F615:0 | PMX Total Interval Energy Reduced | Max. subindex | UINT8 | RO | 0x13 (19dec)
F615:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00000000 (0dec)
F615:11 | Active Energy | Balanced total effective energy in the last interval in Wh | REAL32 | RO | 0x00000000 (0dec)
F615:12 | Apparent Energy | Balanced total apparent energy in the last interval in VAh | REAL32 | RO | 0x00000000 (0dec)
F615:13 | Reactive Energy | Balanced total reactive energy in the last interval in var | REAL32 | RO | 0x00000000 (0dec)


Output data

Commissioning [image] Object description and parameterization [image] EL3423 [image] Output data
Output data
Index F701 PMX Interval
Index (hex) | Name | Meaning | Data type | Flags | Default
F701:0 | PMX Interval | Max. subindex | UINT8 | RO | 0x01 (1dec)
F701:01 | Reset Interval | Manual option for resetting the interval (see basic function principles – Statistical evaluation) | BOOLEAN | RO | 0x00 (0dec)


Information and diagnostic data

Commissioning [image] Object description and parameterization [image] EL3423 [image] Information and diagnostic data
Information and diagnostic data
Index 90n0 PMX info data voltage (for ch.1, n = 0; ch.2, n = 1; ch.3, n = 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
90n0:0 | PMX Info data Voltage | Max. subindex | UINT8 | RO | 0x13 (19dec)
90n0:11 | Voltage Peak | Peak value of the instantaneous voltage in the last interval in V | REAL32 | RO | 0x00000000 (0dec)
90n0:12 | Voltage RMS Minimum | Minimum RMS value of the voltage in the last interval in V | REAL32 | RO | 0x00000000 (0dec)
90n0:13 | Voltage RMS Maximum | Maximum RMS value of the voltage in the last interval in V | REAL32 | RO | 0x00000000 (0dec)
Index 90n1 PMX info data current (for ch.1, n = 0; ch.2, n = 1; ch.3, n = 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
90n1:0 | PMX Info data Current | Max. subindex | UINT8 | RO | 0x13 (19dec)
90n1:11 | Current Peak | Peak value of the instantaneous current in the last interval in A | REAL32 | RO | 0x00000000 (0dec)
90n1:12 | Current RMS Minimum | Minimum RMS value of the current in the last interval in A | REAL32 | RO | 0x00000000 (0dec)
90n1:13 | Current RMS Maximum | Maximum RMS value of the current in the last interval in A | REAL32 | RO | 0x00000000 (0dec)
Index 90n2 PMX info data power (for ch.1, n = 0; ch.2, n = 1; ch.3, n = 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
90n2:0 | PMX Info data Power | Max. subindex | UINT8 | RO | 0x1B (27dec)
90n2:11 | Active Power Avg | Average active phase power during the last interval in W | REAL32 | RO | 0x00000000 (0dec)
90n2:12 | Active Power Min | Minimum active phase power during the last interval in W | REAL32 | RO | 0x00000000 (0dec)
90n2:13 | Active Power Max | Maximum active phase power during the last interval in W | REAL32 | RO | 0x00000000 (0dec)
90n2:14 | Apparent Power Avg | Average apparent phase power during the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
90n2:15 | Apparent Power Min | Minimum apparent phase power during the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
90n2:16 | Apparent Power Max | Maximum apparent phase power during the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
90n2:17 | Reactive Power Avg | Average reactive phase power during the last interval in var | REAL32 | RO | 0x00000000 (0dec)
90n2:18 | Reactive Power Min | Minimum reactive phase power during the last interval in var | REAL32 | RO | 0x00000000 (0dec)
90n2:19 | Reactive Power Max | Maximum reactive phase power during the last interval in var | REAL32 | RO | 0x00000000 (0dec)
90n2:1A | Phi | Phase angle in degrees (between voltage U_Lx and the corresponding current I_Lx) | REAL32 | RO | 0x00000000 (0dec)
90n2:1B | Phase angle | Phase difference in degrees (between different voltages U_Lx and U_Ly) | REAL32 | RO | 0x00000000 (0dec)
Index 90n3 PMX info data energy (for ch.1, n = 0; ch.2, n = 1; ch.3, n = 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
90n3:0 | PMX info data energy ch.1 | Max. subindex | UINT8 | RO | 0x19 (25dec)
90n3:11 | Active Energy | Recorded active phase energy in mWh | INT64 | RO |
90n3:12 | Positive Active Energy | Received active phase energy in mWh | UINT64 | RO |
90n3:13 | Negative Active Energy | Supplied active phase energy in mWh | UINT64 | RO |
90n3:14 | Apparent Energy | Recorded apparent phase energy in mWh | INT64 | RO |
90n3:15 | Positive Apparent Energy | Received apparent phase energy in mWh | UINT64 | RO |
90n3:16 | Negative Apparent Energy | Supplied apparent phase energy in mWh | UINT64 | RO |
90n3:17 | Reactive Energy | Recorded reactive phase energy in mWh | INT64 | RO |
90n3:18 | Positive Reactive Energy | Received reactive phase energy in mWh | UINT64 | RO |
90n3:19 | Negative Reactive Energy | Supplied reactive phase energy in mWh | UINT64 | RO |
Index A0n0 PMX Diag data (for ch.1, n = 0; ch.2, n = 1; ch.3, n = 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
A0n0:0 | PMX diag data ch.1 | Max. subindex | UINT8 | RO | 0x12 (18dec)
A0n0:11 | Saturation Time Voltage | Time (in 0.1 ms) in which the terminal has measured an overvoltage. | UINT32 | RO | 0x00000000 (0dec)
A0n0:12 | Saturation Time Current | Time (in 0.1 ms) in which the terminal has measured an overcurrent. | UINT32 | RO | 0x00000000 (0dec)
Index F081 Download revision
Index (hex) | Name | Meaning | Data type | Flags | Default
F081:0 | Download revision | Max. subindex | UINT8 | RO | 0x01 (1dec)
F010:01 | Revision number | Configured revision of the terminal, (see note) | UINT32 | RW | 0x00000000 (0dec)
Index F80F PM Vendor data
Index (hex) | Name | Meaning | Data type | Flags | Default
F80F:0 | PMX Vendor data | Max. subindex | UINT8 | RO | 0x11 (17dec)
F80F:11 | Type | Vendor-specific data | UINT32 | RW | 0x00000000 (0dec)
Index F902 PMX Total Info data Power
Index (hex) | Name | Meaning | Data type | Flags | Default
F902:0 | PMX Total Info data Power | Max subindex | UINT8 | RO | 0x19 (25dec)
F902:11 | Active Power Avg | Average total active power during the last interval in W | REAL32 | RO | 0x00000000 (0dec)
F902:12 | Active Power Min | Minimum total active power in the last interval in W | REAL32 | RO | 0x00000000 (0dec)
F902:13 | Active Power Max | Maximum total active power in the last interval in W | REAL32 | RO | 0x00000000 (0dec)
F902:14 | Apparent Power Avg | Average total apparent power during the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
F902:15 | Apparent Power Min | Minimum total apparent power in the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
F902:16 | Apparent Power Max | Maximum total apparent power in the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
F902:17 | Reactive Power Avg | Average total reactive power average during the last interval in var | REAL32 | RO | 0x00000000 (0dec)
F902:18 | Reactive Power Min | Minimum total reactive power in the last interval in var | REAL32 | RO | 0x00000000 (0dec)
F902:19 | Reactive Power Max | Maximum total reactive power in the last interval in var | REAL32 | RO | 0x00000000 (0dec)
Index F903 PMX Total Info data Energy
Index (hex) | Name | Meaning | Data type | Flags | Default
F903:0 | PMX Total Info data Energy | Max. subindex | UINT8 | RO | 0x19 (25dec)
F903:11 | Active Energy | Recorded total active energy in mWh | INT64 | RO |
F903:12 | Positive Active Energy | Received total active energy in mWh | UINT64 | RO |
F903:13 | Negative Active Energy | Supplied total active energy in mWh | UINT64 | RO |
F903:14 | Apparent Energy | Recorded total apparent energy in mWh | INT64 | RO |
F903:15 | Positive Apparent Energy | Received total apparent energy in mWh | UINT64 | RO |
F903:16 | Negative Apparent Energy | Supplied total apparent energy in mWh | UINT64 | RO |
F903:17 | Reactive Energy | Recorded total reactive energy in mWh | INT64 | RO |
F903:18 | Positive Reactive Energy | Received total reactive energy in mWh | UINT64 | RO |
F903:19 | Negative Reactive Energy | Supplied total reactive energy in mWh | UINT64 | RO |
Index F904 PMX Total Info data PQF
Index (hex) | Name | Meaning | Data type | Flags | Default
F904:0 | PMX Total Info data PQF | Max. subindex | UINT8 | RO | 0x13 (19dec)
F904:11 | PQF Avg | Average value of the power quality factor during the last interval | REAL32 | RO | 0x00000000 (0dec)
F904:12 | PQF Min | Minimum power quality factor in the last interval | REAL32 | RO | 0x00000000 (0dec)
F904:13 | PQF Max | Maximum power quality factor in the last interval | REAL32 | RO | 0x00000000 (0dec)
Index FA00 PMX Diag data
Index (hex) | Name | Meaning | Data type | Flags | Default
FA00:0 | PMX Diag data | Max. subindex | UINT8 | RO | 0x13 (19dec)
FA00:11 | Min CPU Die Temperature | Minimum CPU temperature measured so far | REAL32 | RO | 0x00000000 (0dec)
FA00:12 | Max CPU Die Temperature | Maximum CPU temperature measured so far | REAL32 | RO | 0x00000000 (0dec)
FA00:13 | EBUS Voltage | Current E-bus voltage | REAL32 | RO | 0x00000000 (0dec)


Standard objects

Commissioning [image] Object description and parameterization [image] EL3423 [image] Standard objects
Standard objects
Standard objects (0x1000-0x1FFF)
The standard objects have the same meaning for all EtherCAT slaves.
Index 1000 Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x01551389 (22352777dec)
Index 1008 Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EL34xx
Index 1009 Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO |
Index 100A Software Version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO |
Index 100B Bootloader version
Index (hex) | Name | Meaning | Data type | Flags | Default
100B:0 | Bootloader version | Bootloader version | STRING | RO |
Index 1018 Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Length of this object | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x0D5F3052 (224342098dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the low word (bit 0-15) indicates the special terminal number, the high word (bit 16-31) refers to the device description | UINT32 | RO | 0x00100000 (1048576dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the low byte (bit 0-7) of the low word contains the year of production, the high byte (bit 8-15) of the low word contains the week of production, the high word (bit 16-31) is 0 | UINT32 | RO | e.g. 0x00001E06 (KW 30/2006)
Index 10F0 Backup parameter
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter | Length of this object | UINT8 | RO | 0x01
10F0:01 | Checksum | Checksum | UINT32 | RW | 0x00000000 (0dec)
Index 10F3 Diagnosis History
Index | Name | Meaning | Data type | Flags | Default
10F3:0 | Diagnosis History | Maximum subindex | UINT8 | RO | 0x15 (21dec)
10F3:01 | Maximum Messages | Maximum number of stored messages. A maximum of 50 messages can be stored | UINT8 | RO | 0x00 (0dec)
10F3:02 | Newest Message | Subindex of the latest message | UINT8 | RO | 0x00 (0dec)
10F3:03 | Newest Acknowledged Message | Subindex of the last confirmed message | UINT8 | RW | 0x00 (0dec)
10F3:04 | New Messages Available | Indicates that a new message is available | BOOLEAN | RO | 0x00 (0dec)
10F3:05 | Flags | not used | UINT16 | RW | 0x0000 (0dec)
10F3:06 | Diagnosis Message 001 | Message 1 | OCTET STRING[28] | RO | {0}
... | ... | ... | ... | ... | ...
10F3:15 | Diagnosis Message 016 | Message 16 | OCTET STRING[28] | RO | {0}
Index 10F8 Actual Time Stamp
Index | Name | Meaning | Data type | Flags | Default
10F8:0 | Actual Time Stamp | Time stamp | UINT64 | RO | 0x0000000000000000 (0dec)
Index 10F9 Time Distribution Object
Index | Name | Meaning | Data type | Flags | Default
10F9:0 | Time Distribution Object | Max Subindex | UINT8 | RO | 0x01 (1dec)
10F9:01 | Distributed Time Value | Object for time distribution by the EtherCAT Master | INT64 | RW |
Index 1601 Total RxPDO-Map Interval
Index (hex) | Name | Meaning | Data type | Flags | Default
1601:0 | Total RxPDO-Map Interval | PDO Mapping RxPDO 2 | UINT8 | RO | 0x02 (2dec)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF701 (PMX Interval), entry 0x01 (Reset Interval)) | UINT32 | RO | 0xF701:01, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
Index 1App TxPDO-Map Status (for L1, pp = 00; L2, pp = 0A; L3, pp = 14)
Index (hex) | Name | Meaning | Data type | Flags | Default
1App:0 | TxPDO-Map Status | PDO Mapping TxPDO | UINT8 | RO | 0x09 (9dec)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x02 (Overvoltage)) | UINT32 | RO | 0x60n0:02, 1**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x03 (Overcurrent)) | UINT32 | RO | 0x60n0:03, 1**
1App:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x04 (Inaccurate Voltage)) | UINT32 | RO | 0x60n0:04, 1**
1App:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x05 (Inaccurate Current)) | UINT32 | RO | 0x60n0:05, 1**
1App:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x06 (Voltage Guard Warning)) | UINT32 | RO | 0x60n0:06, 1**
1App:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x07 (Voltage Guard Error)) | UINT32 | RO | 0x60n0:07, 1**
1App:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8**
1App:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x60n0:10, 1**
**) for L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Energy (for L1, pp = 03; L2, pp = 0D; L3, pp = 17)
Index (hex) | Name | Meaning | Data type | Flags | Default
1App:0 | TxPDO-Map Energy | PDO Mapping TxPDO | UINT8 | RO | 0x03 (3dec)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n4 (PMX Energy), entry 0x11 (Active Energy)) | UINT32 | RO | 0x60n4:11, 64**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n4 (PMX Energy), entry 0x12 (Apparent Energy)) | UINT32 | RO | 0x60n4:12, 64**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60n4 (PMX Energy), entry 0x13 (Reactive Energy)) | UINT32 | RO | 0x60n4:13, 64**
**) for L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Statistic Voltage (for L1, pp = 06; L2, pp = 10; L3, pp = 1A)
Index (hex) | Name | Meaning | Data type | Flags | Default
1App:0 | TxPDO-Map Statistic Voltage | PDO Mapping TxPDO | UINT8 | RO | 0x03 (3dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n8 (PMX Statistic Voltage), entry 0x11 (Voltage Peak)) | UINT32 | RO | 0x60n8:11, 32**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n8 (PMX Statistic Voltage), entry 0x12 (Voltage RMS Minimum)) | UINT32 | RO | 0x60n8:12, 32**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60n8 (PMX Statistic Voltage), entry 0x13 (Voltage RMS Maximum)) | UINT32 | RO | 0x60n8:13, 32**
**) for L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Statistic Current (for L1, pp = 07; L2, pp = 11; L3, pp = 1B)
Index (hex) | Name | Meaning | Data type | Flags | Default
1App:0 | L1 TxPDO-Map Statistic Current | PDO Mapping TxPDO 8 | UINT8 | RO | 0x03 (3dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n9 (PMX Statistic Current), entry 0x11 (Current Peak)) | UINT32 | RO | 0x60n9:11, 32**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n9 (PMX Statistic Current), entry 0x12 (Current RMS Minimum)) | UINT32 | RO | 0x60n9:12, 32**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60n9 (PMX Statistic Current), entry 0x13 (Current RMS Maximum)) | UINT32 | RO | 0x60n9:13, 32**
**) for L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Statistic Power (for L1, pp = 08; L2, pp = 12; L3, pp = 1C)
Index (hex) | Name | Meaning | Data type | Flags | Default
1App:0 | TxPDO-Map Statistic Power | PDO Mapping TxPDO | UINT8 | RO | 0x09 (9dec)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x11 (Active Power Avg)) | UINT32 | RO | 0x60nA:11, 32**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x12 (Active Power Min)) | UINT32 | RO | 0x60nA:12, 32**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x13 (Active Power Max)) | UINT32 | RO | 0x60nA:13, 32**
1App:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x14 (Apparent Power Avg)) | UINT32 | RO | 0x60nA:14, 32**
1App:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x15 (Apparent Power Max)) | UINT32 | RO | 0x60nA:15, 32**
1App:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x16 (Reactive Power Avg)) | UINT32 | RO | 0x60nA:16, 32**
1App:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x17 (Reactive Power Min)) | UINT32 | RO | 0x60nA:17, 32**
1App:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x18 (Reactive Power Max)) | UINT32 | RO | 0x60nA:18, 32**
1App:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x19 (Apparent Power Min)) | UINT32 | RO | 0x60nA:19, 32**
**) for L1, n = 0; L2, n = 1; L3, n = 2)
Index 1A1E Total TxPDO-Map Total Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1A1E:0 | Total TxPDO-Map Total Status | PDO Mapping TxPDO 31 | UINT8 | RO | 0x10 (16dec)
1A1E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x01 (System State)) | UINT32 | RO | 0xF600:01, 1
1A1E:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x02 (Grid Direction)) | UINT32 | RO | 0xF600:02, 1
1A1E:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x03 (Frequency Guard Warning)) | UINT32 | RO | 0xF600:03, 1
1A1E:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x04 (Frequency Guard Error)) | UINT32 | RO | 0xF600:04, 1
1A1E:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x05 (Neutral Current Guard Warning)) | UINT32 | RO | 0xF600:05, 1
1A1E:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x06 (Neutral Current Guard Error)) | UINT32 | RO | 0xF600:06, 1
1A1E:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x07 (Active Power Guard Warning)) | UINT32 | RO | 0xF600:07, 1
1A1E:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x08 (Active Power Guard Error)) | UINT32 | RO | 0xF600:08, 1
1A1E:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x09 (Apparent Power Guard Warning)) | UINT32 | RO | 0xF600:09, 1
1A1E:0A | SubIndex 010 | 10. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x0A (Apparent Power Guard Error)) | UINT32 | RO | 0xF600:0A, 1
1A1E:0B | SubIndex 011 | 11. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x0B (Power Quality Guard Warning)) | UINT32 | RO | 0xF600:0B, 1
1A1E:0C | SubIndex 012 | 12. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x0C (Power Quality Guard Error)) | UINT32 | RO | 0xF600:0C, 1
1A1E:0D | SubIndex 013 | 13. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A1E:0E | SubIndex 014 | 14. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x0F (TxPDO State)) | UINT32 | RO | 0xF600:0F, 1
1A1E:0F | SubIndex 015 | 15. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0xF600:10, 1
1A1E:10 | SubIndex 016 | 16. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x11 (Power Quality Factor)) | UINT32 | RO | 0xF600:11, 32
Index 1A20 Total TxPDO-Map Total Advanced
Index (hex) | Name | Meaning | Data type | Flags | Default
1A20:0 | Total TxPDO-Map Total Advanced | PDO Mapping TxPDO 33 | UINT8 | RO | 0x03 (3dec)
1A20:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF602 (PMX Total Advanced), entry 0x01 (Unbalance Guard Warning)) | UINT32 | RO | 0xF602:01, 1
1A20:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF602 (PMX Total Advanced), entry 0x02 (Unbalance Guard Error)) | UINT32 | RO | 0xF602:02, 1
1A20:03 | SubIndex 003 | 3. PDO Mapping entry (14 bits align) | UINT32 | RO | 0x0000:00, 14
Index 1A21 Total TxPDO-Map Total Active
Index (hex) | Name | Meaning | Data type | Flags | Default
1A21:0 | Total TxPDO-Map Total Active | PDO Mapping TxPDO 34 | UINT8 | RO | 0x04 (4dec)
1A21:01 | SubIndex 001 | 1. PDO Mapping entry (32 bits align) | UINT32 | RO | 0x0000:00, 32
1A21:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF603 (PMX Total Active), entry 0x12 (Active Energy)) | UINT32 | RO | 0xF603:12, 64
1A21:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF603 (PMX Total Active), entry 0x13 (Active Positive Energy)) | UINT32 | RO | 0xF603:13, 64
1A21:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF603 (PMX Total Active), entry 0x14 (Active Negative Energy)) | UINT32 | RO | 0xF603:14, 64
Index 1A22 Total TxPDO-Map Total Apparent
Index (hex) | Name | Meaning | Data type | Flags | Default
1A22:0 | Total TxPDO-Map Total Apparent | PDO Mapping TxPDO 35 | UINT8 | RO | 0x04 (4dec)
1A22:01 | SubIndex 001 | 1. PDO Mapping entry (32 bits align) | UINT32 | RO | 0x0000:00, 32
1A22:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF605 (PMX Total Apparent), entry 0x12 (Apparent Energy)) | UINT32 | RO | 0xF605:12, 64
1A22:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF605 (PMX Total Apparent), entry 0x13 (Apparent Positive Energy)) | UINT32 | RO | 0xF605:13, 64
1A22:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF605 (PMX Total Apparent), entry 0x14 (Apparent Negative Energy)) | UINT32 | RO | 0xF605:14, 64
Index 1A23 Total TxPDO-Map Total Reactive
Index (hex) | Name | Meaning | Data type | Flags | Default
1A23:0 | Total TxPDO-Map Total Reactive | PDO Mapping TxPDO 36 | UINT8 | RO | 0x04 (4dec)
1A23:01 | SubIndex 001 | 1. PDO Mapping entry (32 bits align) | UINT32 | RO | 0x0000:00, 32
1A23:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF607 (PMX Total Reactive), entry 0x12 (Reactive Energy)) | UINT32 | RO | 0xF607:12, 64
1A23:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF607 (PMX Total Reactive), entry 0x13 (Reactive Positive Energy)) | UINT32 | RO | 0xF607:13, 64
1A23:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF607 (PMX Total Reactive), entry 0x14 (Reactive Negative Energy)) | UINT32 | RO | 0xF607:14, 64
Index 1A26 Total TxPDO-Map Total Statistic Power
Index (hex) | Name | Meaning | Data type | Flags | Default
1A26:0 | Total TxPDO-Map Total Statistic Power | PDO Mapping TxPDO 39 | UINT8 | RO | 0x09 (9dec)
1A26:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x11 (Active Power Avg)) | UINT32 | RO | 0xF60B:11, 32
1A26:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x12 (Active Power Min)) | UINT32 | RO | 0xF60B:12, 32
1A26:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x13 (Active Power Max)) | UINT32 | RO | 0xF60B:13, 32
1A26:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x14 (Apparent Power Avg)) | UINT32 | RO | 0xF60B:14, 32
1A26:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x15 (Apparent Power Min)) | UINT32 | RO | 0xF60B:15, 32
1A26:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x16 (Apparent Power Max)) | UINT32 | RO | 0xF60B:16, 32
1A26:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x17 (Reactive Power Avg)) | UINT32 | RO | 0xF60B:17, 32
1A26:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x18 (Reactive Power Min)) | UINT32 | RO | 0xF60B:18, 32
1A26:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x19 (Reactive Power Max)) | UINT32 | RO | 0xF60B:19, 32
Index 1A27 Total TxPDO-Map Total Statistic PQF
Index (hex) | Name | Meaning | Data type | Flags | Default
1A27:0 | Total TxPDO-Map Total Statistic PQF | PDO Mapping TxPDO 40 | UINT8 | RO | 0x03 (3dec)
1A27:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF60C (PMX Total Statistic PQF), entry 0x11 (PQF Avg)) | UINT32 | RO | 0xF60C:11, 32
1A27:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF60C (PMX Total Statistic PQF), entry 0x12 (PQF Min)) | UINT32 | RO | 0xF60C:12, 32
1A27:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF60C (PMX Total Statistic PQF), entry 0x13 (PQF Max)) | UINT32 | RO | 0xF60C:13, 32
Index 1A28 Total TxPDO-Map Total Interval Energy
Index (hex) | Name | Meaning | Data type | Flags | Default
1A28:0 | Total TxPDO-Map Total Interval Energy | PDO Mapping TxPDO 41 | UINT8 | RO | 0x0B (11dec)
1A28:01 | SubIndex 001 | 1. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1A28:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0xF60D:10, 1
1A28:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x11 (Active Energy)) | UINT32 | RO | 0xF60D:11, 32
1A28:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x12 (Active Energy Positive)) | UINT32 | RO | 0xF60D:12, 32
1A28:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x13 (Active Energy Negative)) | UINT32 | RO | 0xF60D:13, 32
1A28:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x14 (Apparent Energy)) | UINT32 | RO | 0xF60D:14, 32
1A28:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x15 (Apparent Energy Positive)) | UINT32 | RO | 0xF60D:15, 32
1A28:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x16 (Apparent Energy Negative)) | UINT32 | RO | 0xF60D:16, 32
1A28:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x17 (Reactive Energy)) | UINT32 | RO | 0xF60D:17, 32
1A28:0A | SubIndex 010 | 10. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x18 (Reactive Energy Positive)) | UINT32 | RO | 0xF60D:18, 32
1A28:0B | SubIndex 011 | 11. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x19 (Reactive Energy Negative)) | UINT32 | RO | 0xF60D:19, 32
Index 1A29 Total TxPDO-Map Active Reduced
Index (hex) | Name | Meaning | Data type | Flags | Default
1A29:0 | Total TxPDO-Map Active Reduced | PDO Mapping TxPDO 35 | UINT8 | RO | 0x02 (2dec)
1A29:01 | SubIndex 001 | 1. PDO Mapping entry (Alignet)) | UINT32 | RO | 0x0000:00, 32
1A29:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF612 (PMX Total Apparent), entry 0x12 (Active Reduced)) | UINT32 | RO | 0xF612:12, 64
Index 1A2A Total TxPDO-Map Apparent Reduced
Index (hex) | Name | Meaning | Data type | Flags | Default
1A2A:0 | Total TxPDO-Map Apparent Reduced | PDO Mapping TxPDO 35 | UINT8 | RO | 0x02 (2dec)
1A2A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF613 (PMX Total Apparent Reduced), entry 0x11 (Apparent Power)) | UINT32 | RO | 0xF613:11, 32
1A2A:02 | SubIndex 002 | 2. . PDO Mapping entry (object 0xF613 (PMX Total Apparent Reduced), entry 0x12 (Apparent Energy)) | UINT32 | RO | 0xF613:12, 64
Index 1A2B Total TxPDO-Map Reactive Reduced
Index (hex) | Name | Meaning | Data type | Flags | Default
1A2B:0 | Total TxPDO-Map Reactive Reduced | PDO Mapping TxPDO 36 | UINT8 | RO | 0x02 (2dec)
1A2B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF614 (PMX Total Reactive Reduced), entry 0x11 (Reactive Power)) | UINT32 | RO | 0xF614:11, 32
1A2B:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF614 (PMX Total Reactive Reduced), entry 0x12 (Reactive Energy)) | UINT32 | RO | 0xF614:12, 64
Index 1A2C Total TxPDO-Map Interval Energy Reduced
Index (hex) | Name | Meaning | Data type | Flags | Default
1A2C:0 | Total TxPDO-Map Interval Energy Reduced | PDO Mapping TxPDO 36 | UINT8 | RO | 0x05 (5dez)
1A2C:01 | SubIndex 001 | 1. PDO Mapping entry (align) | UINT32 | RO | 0x0000:00, 15
1A2C:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF615 (PMX Total Interval Energy Reduced), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0xF615:10, 1
1A2C:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF615 (PMX Total Interval Energy Reduced), entry 0x11 (Active Energy)) | UINT32 | RO | 0xF615:11, 32
1A2C:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF615 (PMX Total Interval Energy Reduced), entry 0x12 (Apparent Energy)) | UINT32 | RO | 0xF615:12, 32
1A2C:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF615 (PMX Total Interval Energy Reduced), entry 0x13 (reactive Energy)) | UINT32 | RO | 0xF615:13, 32
Index 1C00 Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Length of this object | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RW | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RW | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RW | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RW | 0x04 (4dec)
Index 1C12 RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x01 (1dec)
1C12:01 | SubIndex 001 | 1. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1601 (5633dec)
Index 1C13 TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x04 (4dec)
1C13:01 | SubIndex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | SubIndex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A0A (6666dec)
1C13:03 | SubIndex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A14 (6676dec)
1C13:04 | SubIndex 004 | 4. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A1E (6686dec)
1C13:05 | SubIndex 005 | 5. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:06 | SubIndex 006 | 6. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:07 | SubIndex 007 | 7. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:08 | SubIndex 008 | 8. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:09 | SubIndex 009 | 9. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0A | SubIndex 010 | 10. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0B | SubIndex 011 | 11. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0C | SubIndex 012 | 12. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0D | SubIndex 013 | 13. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0E | SubIndex 014 | 14. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0F | SubIndex 015 | 15. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:10 | SubIndex 016 | 16. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:11 | SubIndex 017 | 17. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:12 | SubIndex 018 | 18. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:13 | SubIndex 019 | 19. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:14 | SubIndex 020 | 20. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:15 | SubIndex 021 | 21. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:16 | SubIndex 022 | 22. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:17 | SubIndex 023 | 23. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 1C32 SM output parameter
Index | Name | Meaning | Data type | Flags | Default
1C32:0 | SM output parameter | Synchronization parameters for the outputs | UINT8 | RO | 0x20 (32dec)
1C32:01 | Sync mode | Current synchronization mode: 0: Free Run 1: Synchron with SM 2 Event 2: DC-Mode - Synchron with SYNC0 Event 3: DC-Mode - Synchron with SYNC1 Event | UINT16 | RW | 0x0000 (0dec)
1C32:02 | Cycle time | Cycle time (in ns): Free Run: Cycle time of the local timer Synchron with SM 2 Event: Master cycle time DC mode: SYNC0/SYNC1 Cycle Time | UINT32 | RW | 0x0016E360 (1500000dec)
1C32:03 | Shift time | Time between SYNC0 event and output of the outputs (in ns, DC mode only) | UINT32 | RO | 0x00000384 (900dec)
1C32:04 | Sync modes supported | Supported synchronization modes: Bit 0 = 1: free run is supported Bit 1 = 1: synchronous with SM 2 event is supported Bit 2-3 = 01: DC mode is supported Bit 4-5 = 10: Output shift with SYNC1 event (only DC mode) Bit 14 = 1: dynamic times (measurement through writing of 1C32:08) | UINT16 | RO | 0x0805 (2053dec)
1C32:05 | Minimum cycle time | Minimum cycle time (in ns) | UINT32 | RO | 0x0007A120 (500000dec)
1C32:06 | Calc and copy time | Minimum time between SYNC0 and SYNC1 event (in ns, DC mode only) | UINT32 | RO | 0x00000384 (900dec)
1C32:07 | Minimum delay time |  | UINT32 | RO | 0x00000384 (900dec)
1C32:08 | Command | 0: Measurement of the local cycle time is stopped 1: Measurement of the local cycle time is started The entries 1C32:03, 1C32:05, 1C32:06, 1C32:09, 1C33:03, 1C33:06, 1C33:09 are updated with the maximum measured values. For a subsequent measurement the measured values are reset | UINT16 | RW | 0x0000 (0dec)
1C32:09 | Maximum delay time | Time between SYNC1 event and output of the outputs (in ns, DC mode only) | UINT32 | RO | 0x00000384 (900dec)
1C32:0B | SM event missed counter | Number of missed SM events in OPERATIONAL (DC mode only) | UINT16 | RO | 0x0000 (0dec)
1C32:0C | Cycle exceeded counter | Number of occasions the cycle time was exceeded in OPERATIONAL (cycle was not completed in time or the next cycle began too early) | UINT16 | RO | 0x0000 (0dec)
1C32:0D | Shift too short counter | Number of occasions that the interval between SYNC0 and SYNC1 event was too short (DC mode only) | UINT16 | RO | 0x0000 (0dec)
Index 1C33 SM input parameter
Index (hex) | Name | Meaning | Data type | Flags | Default
1C33:0 | SM input parameter | Synchronization parameters for the inputs | UINT8 | RO | 0x20 (32dec)
1C33:01 | Sync mode | Current synchronization mode: 0: Free Run 1: Synchron with SM 3 Event (no outputs available) 2: DC - Synchron with SYNC0 Event 3: DC - Synchron with SYNC1 Event 34: Synchron with SM 2 event (outputs available) | UINT16 | RW | 0x0000 (0dec)
1C33:02 | Cycle time | as 1C32:02 | UINT32 | RW | 0x0016E360 (1500000dec)
1C33:03 | Shift time | Time between SYNC0 event and reading of the inputs (in ns, only DC mode) | UINT32 | RO | 0x00000384 (900dec)
1C33:04 | Sync modes supported | Supported synchronization modes: Bit 0: free run is supported Bit 1: Synchron with SM 2 Event is supported (outputs available) Bit 1: Synchron with SM 3 Event is supported (no outputs available) Bit 2-3 = 01: DC mode is supported Bit 4-5 = 01: Input shift through local event (outputs available) Bit 4-5 = 10: Input shift with SYNC1 event (no outputs available) Bit 14 = 1: dynamic times (measurement through writing of 1C32:08 or 1C33:08) | UINT16 | RO | 0x0805 (2053dec)
1C33:05 | Minimum cycle time | as 1C32:05 | UINT32 | RO | 0x0007A120 (500000dec)
1C33:06 | Calc and copy time | Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode) | UINT32 | RO | 0x0007A120 (500000dec)
1C33:07 | Minimum delay time |  | UINT32 | RO | 0x00000384 (900dec)
1C33:08 | Command | as 1C32:08 | UINT16 | RW | 0x0000 (0dec)
1C33:09 | Maximum delay time | Time between SYNC1 event and reading of the inputs (in ns, only DC mode) | UINT32 | RO | 0x00000384 (900dec)
1C33:0B | SM event missed counter | as 1C32:11 | UINT16 | RO | 0x0000 (0dec)
1C33:0C | Cycle exceeded counter | as 1C32:12 | UINT16 | RO | 0x0000 (0dec)
1C33:0D | Shift too short counter | as 1C32:13 | UINT16 | RO | 0x0000 (0dec)
Index F000 Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | Largest subindex of this object | UINT8 | RO | 0x02
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RW | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RW | 0x0003 (3dec)
Index F008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dec)
Code Word
The vendor reserves the authority for the basic calibration of the terminals. The code word is therefore at present reserved.
Index F010 Module List
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list |  | UINT8 | RW | 0x03 (3dec)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x00000155 (341dec)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x00000155 (341dec)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x00000155 (341dec)


Command object

Commissioning [image] Object description and parameterization [image] EL3423 [image] Command object
Command object
Index FB00 PMX Command
The command object is used for triggering an action in the terminal. The command is started by writing subindex 1 (request). Write access is disabled until the current command is completed.
Index (hex) | Name | Meaning |  | Data type | Flags | Default
FB00:0 | PM Command | Largest subindex of this object |  | UINT8 | RO | 0x03
FB00:01 | Request | Byte 0 - service request data |  | OCTET-STRING [2] | RW | 0x0000 (0dec)
 |  | 4hex | Clear energy
 |  | Byte 1 - channel selection
 |  | 00hex | all channels
 |  | 01hex | Channel 1
 |  | 02hex | Channel 2
 |  | 03hex | Channel 3
FB00:02 | Status | Byte 0 |  | UINT8 | RW | 0x00 (0dec)
 |  | reserved
FB00:03 | Response | Byte 0 |  | OCTET-STRING [2] | RW | 0x00000000 (0dec)
 |  | reserved
 |  | Byte 1
 |  | reserved
 |  | Byte 2-n
 |  | reserved


EL3443-00xx

Commissioning [image] Object description and parameterization [image] EL3443-00xx
EL3443-00xx
Additional information
•
Restore object
•
Configuration data
•
Configuration data (vendor-specific)
•
Input data
•
Output data
•
Information and diagnostic data
•
Standard objects
•
Command object


Restore object

Commissioning [image] Object description and parameterization [image] EL3443-00xx [image] Restore object
Restore object
Index 1011 Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default parameters | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to “0x64616F6C” in the set value dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)


Configuration data

Commissioning [image] Object description and parameterization [image] EL3443-00xx [image] Configuration data
Configuration data
Index 80n0 PMX settings (for ch.1, n = 0; ch.2, n = 1; ch.3, n = 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
80n0:0 | PMX Settings | Max. subindex | UINT8 | RO | 0x13 (19dec)
80n0:11 | Voltage Transformer Ratio | If a voltage transformer is used, its transmission ratio can be entered here. | REAL32 | RW | 0x3F800000 (1065353216dec)
80n0:12 | Current Transformer Ratio | The ratio of the current transformer used can be entered here. | REAL32 | RW | 0x3F800000 (1065353216dec)
80n0:13 | Current Transformer Delay | Here you can enter a possible time delay of the current transformers in milliseconds. | REAL32 | RW | 0x00000000 (0dec)
Index 80n1 PMX Guard Settings (for ch.1, n = 0; ch.2, n = 1; ch.3, n = 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
80n1:0 | PMX Guard Settings | Max. subindex | UINT8 | RO | 0x14 (20dec)
80n1:11 | Voltage Guard Min Error | Lower limit value for a voltage error message | REAL32 | RW | 0x40000000 (1073741824dec)
80n1:12 | Voltage Guard Min Warning | Lower limit value for a voltage warning message | REAL32 | RW | 0x434F0000 (1129250816dec)
80n1:13 | Voltage Guard Max Warning | Upper limit value for a voltage warning message | REAL32 | RW | 0x437D0000 (1132265472dec)
80n1:14 | Voltage Guard Max Error | Upper limit value for a voltage error message | REAL32 | RW | 0x438B0000 (1133182976dec)
80n1:15 | Current Guard Min Error | Lower limit value for a current error message | REAL32 | RW | 0xBF866666 (-1081711002dec)
80n1:16 | Current Guard Min Warning | Lower limit value for a current warning message | REAL32 | RW | 0xBF800000 (-1082130432dec)
80n1:17 | Current Guard Max Warning | Upper limit value for a current warning message | REAL32 | RW | 0x3F800000 (1065353216dec)
80n1:18 | Current Guard Max Error | Upper limit value for a current error message | REAL32 | RW | 0x3F866666 (1065772646dec)
Index 80n2 PMX User Scale (for ch.1, n = 0; ch.2, n = 1; ch.3, n = 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
80n2:0 | PMX User Scale Ch.1 | Max. subindex | UINT8 | RO | 0x15 (21dec)
80n2:01 | User Calibration Enable | Set to true to enable user calibration data. | BOOLEAN | RW | 0x00 (0dec)
80n2:11 | User Calibration Voltage Offset | Value in V | REAL32 | RW | 0x00000000 (0dec)
80n2:12 | User Calibration Voltage Gain | Factor (without unit) | REAL32 | RW | 0x3F800000 (1065353216dec)
80n2:13 | User Calibration Current Offset | Value in A | REAL32 | RW | 0x00000000 (0dec)
80n2:14 | User Calibration Current Gain | Factor (without unit) | REAL32 | RW | 0x3F800000 (1065353216dec)
80n2:15 | User Calibration Phase Offset | Value in milliseconds | REAL32 | RW | 0x00000000 (0dec)
Index F800 PMX Settings
Index (hex) | Name | Meaning |  | Data type | Flags | Default
F800:0 | PMX Settings | Max. subindex |  | UINT8 | RO | 0x16 (22dec)
F800:01 | Reset Interval | Manual restart of the measurement and statistics interval |  | BOOLEAN | RW | 0x00 (0dec)
F800:11 | Reference | Timing reference for the RMS calculation Set to "Current" if a current is to be measured without an applied voltage. permitted values: |  | UINT32 | RW | 0x00000000 (0dec)
 |  | 0 | Voltage (default)
 |  | 1 | Current
F800:12 | Measurement Range | Filter setting for determining the fundamental permitted values: |  | UINT32 | RW | 0x00000000 (0dec)
 |  | 0 | 25..65 Hz (default)
 |  | 1 | 25..400 Hz
 |  | 2 | 12..45 Hz
F800:13 | Frequency Source | Source of the system frequency permitted values: |  | BIT1 | RW | 0x00000000 (0dec)
 |  | 0 | Channel 1 (default)
 |  | 1 | Channel 2
 |  | 2 | Channel 3
F800:14 | Power Calculation Threshold | Noise reduction: Here you can enter a minimum limit value in percent for the power calculation, below which all values are zeroed. |  | REAL32 | RW | 0x3F800000 (1065353216dec)
F800:15 | Inaccurate Threshold Voltage | Limit value for the warning bit: Inaccurate Voltage |  | REAL32 | RW | 0x3FDC28F6 (1071393014dec)
F800:16 | Inaccurate Threshold Current | Limit value for the warning bit: Inaccurate Current |  | REAL32 | RW | 0x3BC49BA6 (1002740646dec)
Index F801 PMX Total Settings PQF
Index (hex) | Name | Meaning | Data type | Flags | Default
F801:0 | PMX Total Settings PQF | Max. subindex | UINT8 | RO | 0x13 (19dec)
F801:11 | Nominal voltage | A nominal voltage value or set value is required to calculate the power quality factor (for details see basic function principles). | REAL32 | RW | 0x43660000 (1130758144dec)
F801:12 | Nominal Frequency | A nominal frequency or set value is required to calculate the power quality factor (for details see basic function principles). | REAL32 | RW | 0x42480000 (1112014848dec)
F801:13 | PQF Dataset | permitted values: | UINT32 | RW | 0x00000001 (0dec)
 |  | 0: default 1: default + unbalace
Index F802 PMX Guard Settings
Index (hex) | Name | Meaning | Data type | Flags | Default
F802:0 | PMX Guard Settings | Max. subindex | UINT8 | RO | 0x28 (40dec)
F802:11 | Frequency Guard Min Error | Lower limit value for a frequency error message | REAL32 | RW | 47,000000 (4,700000e+001)
F802:12 | Frequency Guard Min Warning | Lower limit value for a frequency warning message | REAL32 | RW | 49,500000 (4,950000e+001)
F802:13 | Frequency Guard Max Warning | Upper limit value for a frequency warning message | REAL32 | RW | 50,500000 (5,050000e+001)
F802:14 | Frequency Guard Max Error | Upper limit value for a frequency error message | REAL32 | RW | 52,000000 (5,200000e+001)
F802:15 | Neutral Current Guard Min Error | Lower limit value for an error message of the neutral conductor current | REAL32 | RW | EL3423, EL3443 0,000000 (0,000000e+000) EL3453 -1,050000 (-1,050000e+000)
F802:16 | Neutral Current Guard Min Warning | Lower limit value for a warning message of the neutral conductor current | REAL32 | RW | EL3423, EL3443 0,000000 (0,000000e+000) EL3453 -1,000000 (-1,000000e+000)
F802:17 | Neutral Current Guard Max Warning | Upper limit value for a warning message of the neutral conductor current | REAL32 | RW | EL3423, EL3443 0,006000 (6,000000e-003) EL3453 1,000000 (1,000000e+000)
F802:18 | Neutral Current Guard Max Error | Upper limit value for an error message of the neutral conductor current | REAL32 | RW | EL3423, EL3443 0,030000 (3,000000e-002) EL3453 1,050000 (1,050000e+000)
F802:19 | Active Power Guard Min Error | Lower limit value for an active power error message | REAL32 | RW | 0,000000 (0,000000e+000)
F802:1A | Active Power Guard Min Warning | Lower limit value for an active power warning message | REAL32 | RW | 0,000000 (0,000000e+000)
F802:1B | Active Power Guard Max Warning | Upper limit value for an active power warning message | REAL32 | RW | 0,000000 (0,000000e+000)
F802:1C | Active Power Guard Max Error | Upper limit value for an active power error message | REAL32 | RW | 0,000000 (0,000000e+000)
F802:1D | Apparent Power Guard Min Error | Lower limit value for an apparent power error message | REAL32 | RW | 0,000000 (0,000000e+000)
F802:1E | Apparent Power Guard Min Warning | Lower limit value for an apparent power warning message | REAL32 | RW | 0,000000 (0,000000e+000)
F802:1F | Apparent Power Guard Max Warning | Upper limit value for an apparent power warning message | REAL32 | RW | 0,000000 (0,000000e+000)
F802:20 | Apparent Power Guard Max Error | Upper limit value for an apparent power error message | REAL32 | RW | 0,000000 (0,000000e+000)
F802:21 | PQF Guard Min Error | Lower limit value for a power quality factor error message | REAL32 | RW | 0,050000 (5,000000e-002)
F802:22 | PQF Guard Min Warning | Lower limit value for a power quality factor warning message | REAL32 | RW | 0,800000 (8,000000e-001)
F802:23 | PQF Guard Max Warning | Upper limit value for a power quality factor warning message | REAL32 | RW | 1,000000 (1,000000e+000)
F802:24 | PQF Guard Max Error | Upper limit value for a power quality factor error message | REAL32 | RW | 1,000000 (1,000000e+000)
F802:25 | Unbalance Guard Min Error | Lower limit value for an error message due to voltage imbalance | REAL32 | RW | 0,000000 (0,000000e+000)
F802:26 | Unbalance Guard Min Warning | Lower limit value for a warning message due to voltage imbalance | REAL32 | RW | 0,000000 (0,000000e+000)
F802:27 | Unbalance Guard Max Warning | Upper limit value for a warning message due to voltage imbalance | REAL32 | RW | EL3423, EL3453 0,000000 (0,000000e+000) EL3443 2,000000 (2,000000e+000)
F802:28 | Unbalance Guard Max Error | Upper limit value for an error message due to voltage imbalance | REAL32 | RW | EL3423, EL3453 0,000000 (0,000000e+000) EL3443 3,000000 (3,000000e+000)
Index F803 PMX Time Settings
Index (hex) | Name | Meaning | Data type | Flags | Default
F803:0 | PMX Time Settings | Max. subindex | UINT8 | RO | 0x13 (19dec)
F803:11 | Measurement Mode | permitted values: | UINT32 | RW | 0x00000000 (0dec)
 |  | 0
F803:12 | Measurement Interval | Time in seconds to automatic restart of the measurement and statistics interval | UINT32 | RW | 0x00000000 (0dec)
F803:13 | Actual System Time | Shows the current system time of the terminal. Write access to the object is possible in order to change the system time. | STRING | RW |


Configuration data (vendor-specific)

Commissioning [image] Object description and parameterization [image] EL3443-00xx [image] Configuration data (vendor-specific)
Configuration data (vendor-specific)
Index 80nF PMX vendor data (for ch.1, n = 0; ch.2, n = 1; ch.3, n = 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
80nF:0 | PMX Vendor data | Max. subindex | UINT8 | RO | 0x16 (22dec)
80nF:11 | Calibration Voltage Offset | Value in V | REAL32 | RW | 0x00000000 (0dec)
80nF:12 | Calibration Voltage Gain | Factor (without unit) | REAL32 | RW | 0x3F800000 (1065353216dec)
80nF:13 | Calibration Voltage Phase Offset | Value in milliseconds | REAL32 | RW | 0x00000000 (0dec)
80nF:14 | Calibration Current Offset | Value in A | REAL32 | RW | 0x00000000 (0dec)
80nF:15 | Calibration Current Gain | Factor (without unit) | REAL32 | RW | 0x3F800000 (1065353216dec)
80nF:16 | Calibration Current Phase Offset | Value in milliseconds | REAL32 | RW | 0x00000000 (0dec)


Input data

Commissioning [image] Object description and parameterization [image] EL3443-00xx [image] Input data
Input data
Index 60n0 PMX status (n = 0, 1, 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
60n0:0 | PMX Status | Max. subindex | UINT8 | RO | 0x10 (16dec)
60n0:01 | Voltage Sign Bit | Indicates the sign of the current sine wave voltage: 1 = U > 0V 0 = U < 0V | BOOLEAN | RO | 0x00 (0dec)
60n0:02 | Overvoltage | Maximum measurable voltage is exceeded. | BOOLEAN | RO | 0x00 (0dec)
60n0:03 | Overcurrent | Maximum measurable current is exceeded. | BOOLEAN | RO | 0x00 (0dec)
60n0:04 | Inaccurate Voltage | The measured voltage value is smaller than the value entered in CoE object "F800:15 Inaccurate Threshold Voltage". | BOOLEAN | RO | 0x00 (0dec)
60n0:05 | Inaccurate Current | The measured current value is smaller than the value entered in CoE object "F800:16 Inaccurate Threshold Current". | BOOLEAN | RO | 0x00 (0dec)
60n0:06 | Voltage Guard Warning | A warning limit of the voltage monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
60n0:07 | Voltage Guard Error | An error limit of the voltage monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
6000:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
Index 60n1 PMX Basic (n = 0, 1, 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
60n1:0 | PMX Basic | Max. Subindex | UINT8 | RO | 0x12 (18dec)
60n1:11 | Voltage | RMS value of the voltage in V | REAL32 | RO | 0x00000000 (0dec)
60n1:12 | Current | RMS value of the current in A | REAL32 | RO | 0x00000000 (0dec)
Index 60n2 PMX Power (n = 0, 1, 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
60n2:0 | PMX Power | Max Subindex | UINT8 | RO | 0x14 (20dec)
60n2:11 | Active power | Active power in W | REAL32 | RO | 0x00000000 (0dec)
60n2:12 | Apparent Power | Apparent power in VA | REAL32 | RO | 0x00000000 (0dec)
60n2:13 | Reactive Power | Reactive power in var | REAL32 | RO | 0x00000000 (0dec)
60n2:14 | Power Factor | Power factor | REAL32 | RO | 0x00000000 (0dec)
Index 60n4 PMX Energy (n = 0, 1, 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
60n4:0 | PMX Energy | Max. subindex | UINT8 | RO | 0x13 (19dec)
60n4:11 | Active Energy | Active energy in mWh | INT64 | RO |
60n4:12 | Apparent Energy | Apparent energy in mVAh | INT64 | RO |
60n4:13 | Reactive Energy | Reactive energy in mvarh | INT64 | RO |
Index 60n6 PMX Timing (n = 0, 1, 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
60n6:0 | PMX Timing | Max Subindex | UINT8 | RO | 0x12 (18dec)
60n6:12 | Voltage Last Zero Crossing | Last detected voltage zero crossing as distributed clock time | UINT64 | RO |
Index 60n7 PMX Advanced (n = 0, 1, 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
60n7:0 | PMX Advanced | Max Subindex | UINT8 | RO | 0x14 (20dec)
60n7:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
60n7:11 | Voltage Total Harmonic Distortion | "Total Harmonic Distortion" is the distortion factor of the voltage. It indicates the ratio of the harmonic components of an oscillation relative to its fundamental in %. | REAL32 | RO | 0x00000000 (0dec)
60n7:12 | Current Distortion Factor | The "Current Distortion Factor" is also referred to as TDD (Total Demand Distortion). It indicates the ratio between the current harmonics and the maximum current (EL3443: 1A and EL3443-0010: 5A). Specified in % of the maximum current. | REAL32 | RO | 0x00000000 (0dec)
60n7:13 | Current Total Harmonic Distortion | "Total Harmonic Distortion" is the distortion factor of the current. It indicates the ratio of the harmonic components of an oscillation relative to its fundamental in %. | REAL32 | RO | 0x00000000 (0dec)
60n7:14 | Cos phi | Phase angle of the fundamental wave in degrees | REAL32 | RO | 0x00000000 (0dec)
Index 60n8 PMX Statistic Voltage (n = 0, 1, 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
60n8:0 | PMX Statistic Voltage | Max Subindex | UINT8 | RO | 0x13 (19dec)
60n8:11 | Voltage Peak | Peak value of the instantaneous voltage in the last interval in V | REAL32 | RO | 0x00000000 (0dec)
60n8:12 | Voltage RMS Minimum | Minimum RMS value of the voltage in the last interval in V | REAL32 | RO | 0x00000000 (0dec)
60n8:13 | Voltage RMS Maximum | Maximum RMS value of the voltage in the last interval in V | REAL32 | RO | 0x00000000 (0dec)
Index 60n9 PMX Statistic Current (n = 0, 1, 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
60n9:0 | PMX Statistic Current | Max Subindex | UINT8 | RO | 0x13 (19dec)
60n9:11 | Current Peak | Peak value of the instantaneous current in the last interval in A | REAL32 | RO | 0x00000000 (0dec)
60n9:12 | Current RMS Minimum | Minimum RMS value of the current in the last interval in A | REAL32 | RO | 0x00000000 (0dec)
60n9:13 | Current RMS Maximum | Maximum RMS value of the current in the last interval in A | REAL32 | RO | 0x00000000 (0dec)
Index 60nA PMX Statistic Power (n = 0, 1, 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
60nA:0 | PMX Statistic Power | Max Subindex | UINT8 | RO | 0x19 (25dec)
60nA:11 | Active Power Avg | Average active power during the last interval in W | REAL32 | RO | 0x00000000 (0dec)
60nA:12 | Active Power Min | Minimum active power in the last interval in W | REAL32 | RO | 0x00000000 (0dec)
60nA:13 | Active Power Max | Maximum active power in the last interval in W | REAL32 | RO | 0x00000000 (0dec)
60nA:14 | Apparent Power Avg | Average apparent power during the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
60nA:15 | Apparent Power Max | Maximum apparent power in the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
60nA:16 | Reactive Power Avg | Average reactive power average during the last interval in var | REAL32 | RO | 0x00000000 (0dec)
60nA:17 | Reactive Power Min | Minimum reactive power in the last interval in var | REAL32 | RO | 0x00000000 (0dec)
60nA:18 | Reactive Power Max | Maximum reactive power in the last interval in var | REAL32 | RO | 0x00000000 (0dec)
60nA:19 | Apparent Power Min | Minimum apparent power in the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
Index 60nB PMX Classic (n = 0, 1, 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
600B:0 | PMX Classic | Max. subindex | UINT8 | RO | 0x16 (22dec)
600B:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
600B:11 | Voltage | RMS value of the voltage in 0.001 V | INT32 | RO | 0x00000000 (0dec)
600B:12 | Current | RMS value of the current in 0.0001 A | INT32 | RO | 0x00000000 (0dec)
600B:13 | Frequency | Frequency of the fundamental in 0.001 Hz | INT32 | RO | 0x00000000 (0dec)
600B:14 | Active Power | Active power in 0.001 W | INT32 | RO | 0x00000000 (0dec)
600B:15 | Apparent Power | Apparent power in 0.001 VA | INT32 | RO | 0x00000000 (0dec)
600B:16 | Reactive Power | Reactive power in 0.001 var | INT32 | RO | 0x00000000 (0dec)
Index F600 PMX Total Status
Index (hex) | Name | Meaning | Data type | Flags | Default
F600:0 | PMX Total Status | Max. subindex | UINT8 | RO | 0x11 (17dec)
F600:01 | System State | Overall system state (as a logical disjunction of voltage guard errors, phase sequence, overvoltage, overcurrent and frequency guard errors) | BOOLEAN | RO | 0x00 (0dec)
F600:02 | Grid Direction | Phase sequence L1 - L2 - L3 correctly detected (with clockwise 3-phase mains) | BOOLEAN | RO | 0x00 (0dec)
F600:03 | Frequency Guard Warning | A warning limit of the frequency monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:04 | Frequency Guard Error | An error limit of the frequency monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:05 | Neutral Current Guard Warning | A warning limit of the neutral conductor current monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:06 | Neutral Current Guard Error | An error limit of the neutral conductor current monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:07 | Active Power Guard Warning | A warning limit of the active power monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:08 | Active Power Guard Error | An error limit of the active power monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:09 | Apparent Power Guard Warning | A warning limit of the apparent power monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:0A | Apparent Power Guard Error | An error limit of the apparent power monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:0B | Power Quality Guard Warning | A warning limit of the PQF monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:0C | Power Quality Guard Error | An error limit of the PQF monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:0F | TxPDO State | TRUE for general error | BOOLEAN | RO | 0x00 (0dec)
F600:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
F600:11 | Power Quality Factor | Analog value of the voltage quality between 1.0 and 0 (see basic function principles - Power Quality Factor) | REAL32 | RO | 0x00000000 (0dec)
Index F601 PMX Total Basic
Index (hex) | Name | Meaning | Data type | Flags | Default
F601:0 | PMX Total Basic | Max. subindex | UINT8 | RO | 0x13 (19dec)
F601:11 | Frequency | Frequency in Hz | REAL32 | RO | 0x00000000 (0dec)
F601:12 | Power Factor | Power factor | REAL32 | RO | 0x00000000 (0dec)
F601:13 | Calculated Neutral Line Current | Calculated RMS value of the neutral conductor current in A | REAL32 | RO | 0x00000000 (0dec)
Index F602 PMX Total Advanced
Index (hex) | Name | Meaning | Data type | Flags | Default
F602:0 | PMX Total Advanced | Max. subindex | UINT8 | RO | 0x14 (20dec)
F602:01 | Unbalance Guard Warning | A warning limit of the unbalance monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F602:02 | Unbalance Guard Error | An error limit of the unbalance monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F602:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
F602:11 | Max Voltage Harmonic Distortion | Maximum distortion factor of all three phase voltages in %. | REAL32 | RO | 0x00000000 (0dec)
F602:12 | Max Current Harmonic Distortion | Maximum distortion factor of all three phase currents in % | REAL32 | RO | 0x00000000 (0dec)
F602:13 | Max Current Distortion Factor | Maximum "Total Demand Distortion" value of all three phases in % | REAL32 | RO | 0x00000000 (0dec)
F602:14 | Voltage Unbalance | Ratio between negative and positive voltage system in % | REAL32 | RO | 0x00000000 (0dec)
Index F603 PMX Total Active
Index (hex) | Name | Meaning | Data type | Flags | Default
F603:0 | PMX Total Active | Max. subindex | UINT8 | RO | 0x14 (20dec)
F603:11 | Active Power | Active power in W | INT64 | RO |
F603:12 | Active Energy | Recorded active energy in mWh | INT64 | RO |
F603:13 | Active Positive Energy | Received active energy in mWh | INT64 | RO |
F603:14 | Active Negative Energy | Supplied active energy in mWh | INT64 | RO |
Index F605 PMX Total Apparent
Index (hex) | Name | Meaning | Data type | Flags | Default
F605:0 | PMX Total Apparent | Max. subindex | UINT8 | RO | 0x14 (20dec)
F605:11 | Apparent Power | Balanced apparent power in VA | INT64 | RO |
F605:12 | Apparent Energy | Recorded apparent energy in mWh | INT64 | RO |
F605:13 | Apparent Positive Energy | Received apparent energy in mWh | UINT64 | RO |
F605:14 | Apparent Negative Energy | Supplied apparent energy in mWh | UINT64 | RO |
Index F607 PMX Total Reactive
Index (hex) | Name | Meaning | Data type | Flags | Default
F607:0 | PMX Total Reactive | Max. subindex | UINT8 | RO | 0x14 (20dec)
F607:11 | Reactive Power | Balanced reactive power in Var | INT64 | RO |
F607:12 | Reactive Energy | Recorded reactive energy in mWh | INT64 | RO |
F607:13 | Reactive Positive Energy | Received reactive energy in mWh | UINT64 | RO |
F607:14 | Reactive Negative Energy | Supplied reactive energy in mWh | UINT64 | RO |
Index F609 PMX Total L-L Voltages
Index (hex) | Name | Meaning | Data type | Flags | Default
F609:0 | PMX Total L-L Voltages | Max. subindex | UINT8 | RO | 0x13 (19dec)
F609:11 | L1-L2 Voltage | RMS value of the phase-to-phase voltage between L1 and L2 in V | REAL32 | RO | 0x00000000 (0dec)
F609:12 | L2-L3 Voltage | RMS value of the phase-to-phase voltage between L2 and L3 in V | REAL32 | RO | 0x00000000 (0dec)
F609:13 | L3-L1 Voltage | RMS value of the phase-to-phase voltage between L3 and L1 in V | REAL32 | RO | 0x00000000 (0dec)
Index F60A PMX Variant Value In
Index (hex) | Name | Meaning | Data type | Flags | Default
F60A:0 | PMX Variant Value In | Max. subindex | UINT8 | RO | 0x18 (24dec)
F60A:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
F60A:11 | Index 1 REAL | Acknowledge for variable output value 1 | UINT16 | RO | 0x0000 (0dec)
F60A:12 | Value 1 REAL | variable output value channel 1 | REAL32 | RO | 0x00000000 (0dec)
F60A:13 | Index 2 REAL | Acknowledge for variable output value 2 | UINT16 | RO | 0x0000 (0dec)
F60A:14 | Value 2 REAL | variable output value channel 2 | REAL32 | RO | 0x00000000 (0dec)
F60A:15 | Index 3 REAL | Acknowledge for variable output value 3 | UINT16 | RO | 0x0000 (0dec)
F60A:16 | Value 3 REAL | variable output value channel 3 | REAL32 | RO | 0x00000000 (0dec)
F60A:17 | Index 4 ULINT | Acknowledge for variable output value 4 | UINT16 | RO | 0x0000 (0dec)
F60A:18 | Value 4 ULINT | variable output value channel 4 | UINT64 | RO |
Index F60B PMX Total Statistic Power
Index (hex) | Name | Meaning | Data type | Flags | Default
F60B:0 | PMX Total Statistic Power | Max. subindex | UINT8 | RO | 0x19 (25dec)
F60B:11 | Active Power Avg | Average total active power during the last interval in W | REAL32 | RO | 0x00000000 (0dec)
F60B:12 | Active Power Min | Minimum total active power in the last interval in W | REAL32 | RO | 0x00000000 (0dec)
F60B:13 | Active Power Max | Maximum total active power in the last interval in W | REAL32 | RO | 0x00000000 (0dec)
F60B:14 | Apparent Power Avg | Average total apparent power during the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
F60B:15 | Apparent Power Min | Minimum total apparent power in the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
F60B:16 | Apparent Power Max | Maximum total apparent power in the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
F60B:17 | Reactive Power Avg | Average total reactive power average during the last interval in Var | REAL32 | RO | 0x00000000 (0dec)
F60B:18 | Reactive Power Min | Minimum total reactive power in the last interval in Var | REAL32 | RO | 0x00000000 (0dec)
F60B:19 | Reactive Power Max | Maximum total reactive power in the last interval in Var | REAL32 | RO | 0x00000000 (0dec)
Index F60C PMX Total Statistic PQF
Index (hex) | Name | Meaning | Data type | Flags | Default
F60C:0 | PMX Total Statistic PQF | Max. subindex | UINT8 | RO | 0x13 (19dec)
F60C:11 | PQF Avg | Average value of the power quality factor during the last interval | REAL32 | RO | 0x00000000 (0dec)
F60C:12 | PQF Min | Minimum power quality factor in the last interval | REAL32 | RO | 0x00000000 (0dec)
F60C:13 | PQF Max | Maximum power quality factor in the last interval | REAL32 | RO | 0x00000000 (0dec)
Index F60D PMX Total Interval Energy
Index (hex) | Name | Meaning | Data type | Flags | Default
F60D:0 | PMX Total Interval Energy | Max. subindex | UINT8 | RO | 0x19 (25dec)
F60D:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
F60D:11 | Active Energy | Recorded total active energy during the last interval in mWh | REAL32 | RO | 0x00000000 (0dec)
F60D:12 | Active Energy Positive | Received total active energy during the last interval in mWh | REAL32 | RO | 0x00000000 (0dec)
F60D:13 | Active Energy Negative | Supplied total active energy during at last interval in mWh | REAL32 | RO | 0x00000000 (0dec)
F60D:14 | Apparent Energy | Recorded total apparent energy during the last interval in mWh | REAL32 | RO | 0x00000000 (0dec)
F60D:15 | Apparent Energy Positive | Received total apparent energy during the last interval in mWh | REAL32 | RO | 0x00000000 (0dec)
F60D:16 | Apparent Energy Negative | Supplied total apparent energy during the last interval in mWh | REAL32 | RO | 0x00000000 (0dec)
F60D:17 | Reactive Energy | Recorded total reactive energy during the last interval in mWh | REAL32 | RO | 0x00000000 (0dec)
F60D:18 | Reactive Energy Positive | Received total reactive energy during the last interval in mWh | REAL32 | RO | 0x00000000 (0dec)
F60D:19 | Reactive Energy Negative | Supplied total reactive energy during the last interval in mWh | REAL32 | RO | 0x00000000 (0dec)
Index F612 PMX Total Active Reduced
Index (hex) | Name | Meaning | Data type | Flags | Default
F612:0 | PMX Total Active Reduced | Max. subindex | UINT8 | RO | 0x12 (18dec)
F612:11 | Active Power | Active power in W | REAL32 | RO | 0x00000000 (0dec)
F612:12 | Active Energy | Active energy in mWh | INT64 | RO | 0x00000000 (0dec)
Index F613 PMX Total Apparent Reduced
Index (hex) | Name | Meaning | Data type | Flags | Default
F613:0 | PMX Total Apparent Reduced | Max. subindex | UINT8 | RO | 0x12 (18dec)
F613:11 | Apparent Power | Apparent power in VA | REAL32 | RO | 0x00000000 (0dec)
F613:12 | Apparent Energy | Apparent energy in mVAh | INT64 | RO | 0x00000000 (0dec)
Index F614 PMX Total Reactive Reduced
Index (hex) | Name | Meaning | Data type | Flags | Default
F614:0 | PMX Total Reactive Reduced | Max. subindex | UINT8 | RO | 0x12 (18dec)
F614:11 | Reactive Power | Reactive power in var | REAL32 | RO | 0x00000000 (0dec)
F614:12 | Reactive Energy | Reactive energy in mvarh | INT64 | RO | 0x00000000 (0dec)
Index F615 PMX Total Interval Energy Reduced
Index (hex) | Name | Meaning | Data type | Flags | Default
F615:0 | PMX Total Interval Energy Reduced | Max. subindex | UINT8 | RO | 0x13 (19dec)
F615:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00000000 (0dec)
F615:11 | Active Energy | Balanced total effective energy in the last interval in Wh | REAL32 | RO | 0x00000000 (0dec)
F615:12 | Apparent Energy | Balanced total apparent energy in the last interval in VAh | REAL32 | RO | 0x00000000 (0dec)
F615:13 | Reactive Energy | Balanced total reactive energy in the last interval in var | REAL32 | RO | 0x00000000 (0dec)


Output data

Commissioning [image] Object description and parameterization [image] EL3443-00xx [image] Output data
Output data
Index F700 PMX Variant Value Out
Index (hex) | Name | Meaning | Data type | Flags | Default
F700:0 | PMX Variant Value Out | Max. subindex | UINT8 | RO | 0x14 (20dec)
F700:11 | Index 1 REAL | Request for variable output value 1 (REAL) Can be used for all non-energy values (details see settings) | UINT16 | RO | 0x0000 (0dec)
F700:12 | Index 2 REAL | Request for variable output value 2 (REAL) Can be used for all non-energy values (details see settings) | UINT16 | RO | 0x0000 (0dec)
F700:13 | Index 3 REAL | Request for variable output value 3 (REAL) Can be used for all non-energy values (details see settings) | UINT16 | RO | 0x0000 (0dec)
F700:14 | Index 4 ULINT | Request for variable output value 4 (ULINT) Can be used for all energy values (which are output as ULINT): 45-59 and 1069-1083 | UINT16 | RO | 0x0000 (0dec)
Index F701 PMX Interval
Index (hex) | Name | Meaning | Data type | Flags | Default
F701:0 | PMX Interval | Max. subindex | UINT8 | RO | 0x01 (1dec)
F701:01 | Reset Interval | Manual option for resetting the interval (see basic function principles – Statistical evaluation) | BOOLEAN | RO | 0x00 (0dec)


Information and diagnostic data

Commissioning [image] Object description and parameterization [image] EL3443-00xx [image] Information and diagnostic data
Information and diagnostic data
Index 90n0 PMX info data voltage (for ch.1, n = 0; ch.2, n = 1; ch.3, n = 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
90n0:0 | PMX Info data Voltage | Max. subindex | UINT8 | RO | 0x13 (19dec)
90n0:11 | Voltage Peak | Peak value of the instantaneous voltage in the last interval in V | REAL32 | RO | 0x00000000 (0dec)
90n0:12 | Voltage RMS Minimum | Minimum RMS value of the voltage in the last interval in V | REAL32 | RO | 0x00000000 (0dec)
90n0:13 | Voltage RMS Maximum | Maximum RMS value of the voltage in the last interval in V | REAL32 | RO | 0x00000000 (0dec)
Index 90n1 PMX info data current (for ch.1, n = 0; ch.2, n = 1; ch.3, n = 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
90n1:0 | PMX Info data Current | Max. subindex | UINT8 | RO | 0x13 (19dec)
90n1:11 | Current Peak | Peak value of the instantaneous current in the last interval in A | REAL32 | RO | 0x00000000 (0dec)
90n1:12 | Current RMS Minimum | Minimum RMS value of the current in the last interval in A | REAL32 | RO | 0x00000000 (0dec)
90n1:13 | Current RMS Maximum | Maximum RMS value of the current in the last interval in A | REAL32 | RO | 0x00000000 (0dec)
Index 90n2 PMX info data power (for ch.1, n = 0; ch.2, n = 1; ch.3, n = 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
90n2:0 | PMX Info data Power | Max. subindex | UINT8 | RO | 0x1B (27dec)
90n2:11 | Active Power Avg | Average active phase power during the last interval in W | REAL32 | RO | 0x00000000 (0dec)
90n2:12 | Active Power Min | Minimum active phase power during the last interval in W | REAL32 | RO | 0x00000000 (0dec)
90n2:13 | Active Power Max | Maximum active phase power during the last interval in W | REAL32 | RO | 0x00000000 (0dec)
90n2:14 | Apparent Power Avg | Average apparent phase power during the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
90n2:15 | Apparent Power Min | Minimum apparent phase power during the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
90n2:16 | Apparent Power Max | Maximum apparent phase power during the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
90n2:17 | Reactive Power Avg | Average reactive phase power during the last interval in var | REAL32 | RO | 0x00000000 (0dec)
90n2:18 | Reactive Power Min | Minimum reactive phase power during the last interval in var | REAL32 | RO | 0x00000000 (0dec)
90n2:19 | Reactive Power Max | Maximum reactive phase power during the last interval in var | REAL32 | RO | 0x00000000 (0dec)
90n2:1A | Phi | Phase angle in degrees (between voltage U_Lx and the corresponding current I_Lx) | REAL32 | RO | 0x00000000 (0dec)
90n2:1B | Phase angle | Phase difference in degrees (between different voltages U_Lx and U_Ly) | REAL32 | RO | 0x00000000 (0dec)
Index 90n3 PMX info data energy (for ch.1, n = 0; ch.2, n = 1; ch.3, n = 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
90n3:0 | PMX info data energy ch.1 | Max. subindex | UINT8 | RO | 0x19 (25dec)
90n3:11 | Active Energy | Recorded active phase energy in mWh | INT64 | RO |
90n3:12 | Positive Active Energy | Received active phase energy in mWh | UINT64 | RO |
90n3:13 | Negative Active Energy | Supplied active phase energy in mWh | UINT64 | RO |
90n3:14 | Apparent Energy | Recorded apparent phase energy in mWh | INT64 | RO |
90n3:15 | Positive Apparent Energy | Received apparent phase energy in mWh | UINT64 | RO |
90n3:16 | Negative Apparent Energy | Supplied apparent phase energy in mWh | UINT64 | RO |
90n3:17 | Reactive Energy | Recorded reactive phase energy in mWh | INT64 | RO |
90n3:18 | Positive Reactive Energy | Received reactive phase energy in mWh | UINT64 | RO |
90n3:19 | Negative Reactive Energy | Supplied reactive phase energy in mWh | UINT64 | RO |
Index 90n4 PMX Harmonic Voltage (for ch.1, n = 0; ch.2, n = 1; ch.3, n = 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
90n4:0 | PMX Harmonic Voltage Ch.1 | Max. subindex | UINT8 | RO | 0x2A (42dec)
90n4:01 | Harmonic 0 | DC component of the oscillation in % of the fundamental wave | REAL32 | RO | 0x00000000 (0dec)
90n4:02 | Harmonic 1 | Fundamental wave | REAL32 | RO | 0x00000000 (0dec)
90n4:03 | Harmonic 2 | Second harmonic in % of the fundamental wave | REAL32 | RO | 0x00000000 (0dec)
90n4:04 | Harmonic 3 | Third harmonic in % of the fundamental wave | REAL32 | RO | 0x00000000 (0dec)
… | … | … | … | … | …
90n4:2A | Harmonic 41 | 41st harmonic in % of the fundamental wave | REAL32 | RO | 0x00000000 (0dec)
Index 90n5 PMX Harmonic Current (for ch.1, n = 0; ch.2, n = 1; ch.3, n = 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
90n5:0 | PMX Harmonic Voltage Ch.1 | Max. subindex | UINT8 | RO | 0x2A (42dec)
90n5:01 | Harmonic 0 | DC component of the oscillation in % of the fundamental wave | REAL32 | RO | 0x00000000 (0dec)
90n5:02 | Harmonic 1 | Fundamental wave | REAL32 | RO | 0x00000000 (0dec)
90n5:03 | Harmonic 2 | 2nd harmonic in % of the fundamental wave | REAL32 | RO | 0x00000000 (0dec)
90n5:04 | Harmonic 3 | 3rd harmonic in % of the fundamental wave | REAL32 | RO | 0x00000000 (0dec)
… | … | … | … | … | …
90n5:2A | Harmonic 41 | 41st harmonic in % of the fundamental wave | REAL32 | RO | 0x00000000 (0dec)
Index A0n0 PMX Diag data (for ch.1, n = 0; ch.2, n = 1; ch.3, n = 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
A0n0:0 | PMX diag data ch.1 | Max. subindex | UINT8 | RO | 0x12 (18dec)
A0n0:11 | Saturation Time Voltage | Time (in 0.1 ms) in which the terminal has measured an overvoltage. | UINT32 | RO | 0x00000000 (0dec)
A0n0:12 | Saturation Time Current | Time (in 0.1 ms) in which the terminal has measured an overcurrent. | UINT32 | RO | 0x00000000 (0dec)
Index F081 Download revision
Index (hex) | Name | Meaning | Data type | Flags | Default
F081:0 | Download revision | Max. subindex | UINT8 | RO | 0x01 (1dec)
F010:01 | Revision number | Configured revision of the terminal, (see note) | UINT32 | RW | 0x00000000 (0dec)
Index F80F PM Vendor data
Index (hex) | Name | Meaning | Data type | Flags | Default
F80F:0 | PMX Vendor data | Max. subindex | UINT8 | RO | 0x11 (17dec)
F80F:11 | Type | Vendor-specific data | UINT32 | RW | 0x00000000 (0dec)
Index F902 PMX Total Info data Power
Index (hex) | Name | Meaning | Data type | Flags | Default
F902:0 | PMX Total Info data Power | Max subindex | UINT8 | RO | 0x19 (25dec)
F902:11 | Active Power Avg | Average total active power during the last interval in W | REAL32 | RO | 0x00000000 (0dec)
F902:12 | Active Power Min | Minimum total active power in the last interval in W | REAL32 | RO | 0x00000000 (0dec)
F902:13 | Active Power Max | Maximum total active power in the last interval in W | REAL32 | RO | 0x00000000 (0dec)
F902:14 | Apparent Power Avg | Average total apparent power during the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
F902:15 | Apparent Power Min | Minimum total apparent power in the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
F902:16 | Apparent Power Max | Maximum total apparent power in the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
F902:17 | Reactive Power Avg | Average total reactive power average during the last interval in var | REAL32 | RO | 0x00000000 (0dec)
F902:18 | Reactive Power Min | Minimum total reactive power in the last interval in var | REAL32 | RO | 0x00000000 (0dec)
F902:19 | Reactive Power Max | Maximum total reactive power in the last interval in var | REAL32 | RO | 0x00000000 (0dec)
Index F903 PMX Total Info data Energy
Index (hex) | Name | Meaning | Data type | Flags | Default
F903:0 | PMX Total Info data Energy | Max. subindex | UINT8 | RO | 0x19 (25dec)
F903:11 | Active Energy | Recorded total active energy in mWh | INT64 | RO |
F903:12 | Positive Active Energy | Received total active energy in mWh | UINT64 | RO |
F903:13 | Negative Active Energy | Supplied total active energy in mWh | UINT64 | RO |
F903:14 | Apparent Energy | Recorded total apparent energy in mWh | INT64 | RO |
F903:15 | Positive Apparent Energy | Received total apparent energy in mWh | UINT64 | RO |
F903:16 | Negative Apparent Energy | Supplied total apparent energy in mWh | UINT64 | RO |
F903:17 | Reactive Energy | Recorded total reactive energy in mWh | INT64 | RO |
F903:18 | Positive Reactive Energy | Received total reactive energy in mWh | UINT64 | RO |
F903:19 | Negative Reactive Energy | Supplied total reactive energy in mWh | UINT64 | RO |
Index F904 PMX Total Info data PQF
Index (hex) | Name | Meaning | Data type | Flags | Default
F904:0 | PMX Total Info data PQF | Max. subindex | UINT8 | RO | 0x13 (19dec)
F904:11 | PQF Avg | Average value of the power quality factor during the last interval | REAL32 | RO | 0x00000000 (0dec)
F904:12 | PQF Min | Minimum power quality factor in the last interval | REAL32 | RO | 0x00000000 (0dec)
F904:13 | PQF Max | Maximum power quality factor in the last interval | REAL32 | RO | 0x00000000 (0dec)
Index FA00 PMX Diag data
Index (hex) | Name | Meaning | Data type | Flags | Default
FA00:0 | PMX Diag data | Max. subindex | UINT8 | RO | 0x13 (19dec)
FA00:11 | Min CPU Die Temperature | Minimum CPU temperature measured so far | REAL32 | RO | 0x00000000 (0dec)
FA00:12 | Max CPU Die Temperature | Maximum CPU temperature measured so far | REAL32 | RO | 0x00000000 (0dec)
FA00:13 | EBUS Voltage | Current E-bus voltage | REAL32 | RO | 0x00000000 (0dec)


Standard objects

Commissioning [image] Object description and parameterization [image] EL3443-00xx [image] Standard objects
Standard objects
Standard objects (0x1000-0x1FFF)
The standard objects have the same meaning for all EtherCAT slaves.
Index 1000 Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x01551389 (22352777dec)
Index 1008 Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EL34xx
Index 1009 Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO |
Index 100A Software Version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO |
Index 100B Bootloader version
Index (hex) | Name | Meaning | Data type | Flags | Default
100B:0 | Bootloader version | Bootloader version | STRING | RO |
Index 1018 Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x0D733052 (225652818dez)
1018:03 | Revision | Revision number of the EtherCAT slave; the low word (bit 0-15) indicates the special terminal number, the high word (bit 16-31) refers to the device description | UINT32 | RO | 0x00000000 (0dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the low byte (bit 0-7) of the low word contains the year of production, the high byte (bit 8-15) of the low word contains the week of production, the high word (bit 16-31) is 0 | UINT32 | RO | e.g. 0x00001E06 (KW 30/2006)
Index 10F0 Backup parameter
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter | Length of this object | UINT8 | RO | 0x01
10F0:01 | Checksum | Checksum | UINT32 | RW | 0x00000000 (0dec)
Index 10F3 Diagnosis History
Index | Name | Meaning | Data type | Flags | Default
10F3:0 | Diagnosis History | Maximum subindex | UINT8 | RO | 0x15 (21dec)
10F3:01 | Maximum Messages | Maximum number of stored messages. A maximum of 50 messages can be stored | UINT8 | RO | 0x00 (0dec)
10F3:02 | Newest Message | Subindex of the latest message | UINT8 | RO | 0x00 (0dec)
10F3:03 | Newest Acknowledged Message | Subindex of the last confirmed message | UINT8 | RW | 0x00 (0dec)
10F3:04 | New Messages Available | Indicates that a new message is available | BOOLEAN | RO | 0x00 (0dec)
10F3:05 | Flags | not used | UINT16 | RW | 0x0000 (0dec)
10F3:06 | Diagnosis Message 001 | Message 1 | OCTET STRING[28] | RO | {0}
... | ... | ... | ... | ... | ...
10F3:15 | Diagnosis Message 016 | Message 16 | OCTET STRING[28] | RO | {0}
Index 10F8 Actual Time Stamp
Index | Name | Meaning | Data type | Flags | Default
10F8:0 | Actual Time Stamp | Time stamp | UINT64 | RO | 0x0000000000000000 (0dec)
Index 10F9 Time Distribution Object
Index | Name | Meaning | Data type | Flags | Default
10F9:0 | Time Distribution Object | Max Subindex | UINT8 | RO | 0x01 (1dec)
10F9:01 | Distributed Time Value | Object for time distribution by the EtherCAT Master | INT64 | RW |
Index 1600 Total RxPDO-Map Outputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1600:0 | Total RxPDO-Map Outputs Device | PDO Mapping RxPDO 1 | UINT8 | RO | 0x04 (4dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7030 (PMX Variant Value Out), entry 0x11 (Index 1 REAL)) | UINT32 | RO | 0xF700:11, 16
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7030 (PMX Variant Value Out), entry 0x12 (Index 2 REAL)) | UINT32 | RO | 0xF700:12, 16
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7030 (PMX Variant Value Out), entry 0x13 (Index 3 REAL)) | UINT32 | RO | 0xF700:13, 16
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7030 (PMX Variant Value Out), entry 0x14 (Index 4 ULINT)) | UINT32 | RO | 0xF700:14, 16
Index 1601 Total RxPDO-Map Interval
Index (hex) | Name | Meaning | Data type | Flags | Default
1601:0 | Total RxPDO-Map Interval | PDO Mapping RxPDO 2 | UINT8 | RO | 0x02 (2dec)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF701 (PMX Interval), entry 0x01 (Reset Interval)) | UINT32 | RO | 0xF701:01, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
Index 1App TxPDO-Map Status (for L1, pp = 00; L2, pp = 0A; L3, pp = 14)
Index (hex) | Name | Meaning | Data type | Flags | Default
1App:0 | TxPDO-Map Status | PDO Mapping TxPDO | UINT8 | RO | 0x0B (11dec)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x60n0:01, 1**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x03 (Overcurrent)) | UINT32 | RO | 0x60n0:02, 1**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x04 (Inaccurate Voltage)) | UINT32 | RO | 0x60n0:03, 1**
1App:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x05 (Inaccurate Current)) | UINT32 | RO | 0x60n0:04, 1**
1App:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x06 (Voltage Guard Warning)) | UINT32 | RO | 0x60n0:05, 1**
1App:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x07 (Voltage Guard Error)) | UINT32 | RO | 0x60n0:06, 1**
1App:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x08 (Current Guard Warning)) | UINT32 | RO | 0x60n0:07, 1**
1App:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x09 (Current Guard Error)) | UINT32 | RO | 0x60n0:08, 1**
1App:09 | SubIndex 009 | 9. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x60n0:09, 1**
1App:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x00n0:00, 6**
1App:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x60n0:10, 1**
**) for L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Basic (for L1, pp = 01; L2, pp = 0B; L3, pp = 15)
Index (hex) | Name | Meaning | Data type | Flags | Default
1App:0 | TxPDO-Map Statistic Basic | PDO Mapping TxPDO | UINT8 | RO | 0x02 (2dec)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n1 (PMX Basic), entry 0x11 (Voltage)) | UINT32 | RO | 0x60n1:11, 32**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n1 (PMX Basic), entry 0x12 (Current)) | UINT32 | RO | 0x60n1:12, 32**
**) for L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Power (for L1, pp = 02; L2, pp = 0C; L3, pp = 16)
Index (hex) | Name | Meaning | Data type | Flags | Default
1App:0 | TxPDO-Map Power | PDO Mapping TxPDO | UINT8 | RO | 0x04 (4dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n2 (PMX Power), entry 0x11 (Active Power)) | UINT32 | RO | 0x60n2:11, 32**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n2 (PMX Power), entry 0x12 (Apparent Power)) | UINT32 | RO | 0x60n2:12, 32**
1App:03 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n2 (PMX Power), entry 0x13 (Reactive Power)) | UINT32 | RO | 0x60n2:13, 32**
1App:04 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n2 (PMX Power), entry 0x14 (Power Factor)) | UINT32 | RO | 0x60n2:14, 32**
**) for L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Energy (for L1, pp = 03; L2, pp = 0D; L3, pp = 17)
Index (hex) | Name | Meaning | Data type | Flags | Default
1App:0 | TxPDO-Map Energy | PDO Mapping TxPDO | UINT8 | RO | 0x03 (3dec)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n4 (PMX Energy), entry 0x11 (Active Energy)) | UINT32 | RO | 0x60n4:11, 64**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n4 (PMX Energy), entry 0x12 (Apparent Energy)) | UINT32 | RO | 0x60n4:12, 64**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60n4 (PMX Energy), entry 0x13 (Reactive Energy)) | UINT32 | RO | 0x60n4:13, 64**
**) for L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Timing (for L1, pp = 04; L2, pp = 0E; L3, pp = 18)
Index (hex) | Name | Meaning | Data type | Flags | Default
1App:0 | TxPDO-Map Statistic Timing | PDO Mapping TxPDO | UINT8 | RO | 0x02 (2dec)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n6 (PMX Timing), entry 0x12 (Voltage Last Zero Crossing)) | UINT32 | RO | 0x60n6:12, 64**
**) for L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Advanced (for L1, pp = 05; L2, pp = 0F; L3, pp = 19)
Index (hex) | Name | Meaning | Data type | Flags | Default
1App:0 | TxPDO-Map Advanced | PDO Mapping TxPDO | UINT8 | RO | 0x03 (3dec)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x00n0:00, 15**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n7 (PMX Advanced), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x60n7:10, 1**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60n7 (PMX Advanced), entry 0x11 (Voltage Total Harmonic Distortion)) | UINT32 | RO | 0x60n7:11, 32**
1App:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60n7 (PMX Advanced), entry 0x12 (Current Distortion Factor)) | UINT32 | RO | 0x60n7:12, 32**
1App:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60n7 (PMX Advanced), entry 0x13 (Current Total Harmonic Distortion)) | UINT32 | RO | 0x60n7:13, 32**
1App:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60n7 (PMX Advanced), entry 0x14 (Cos Phi)) | UINT32 | RO | 0x60n7:14, 32**
**) for L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Statistic Voltage (for L1, pp = 06; L2, pp = 10; L3, pp = 1A)
Index (hex) | Name | Meaning | Data type | Flags | Default
1App:0 | TxPDO-Map Statistic Voltage | PDO Mapping TxPDO | UINT8 | RO | 0x03 (3dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n8 (PMX Statistic Voltage), entry 0x11 (Voltage Peak)) | UINT32 | RO | 0x60n8:11, 32**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n8 (PMX Statistic Voltage), entry 0x12 (Voltage RMS Minimum)) | UINT32 | RO | 0x60n8:12, 32**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60n8 (PMX Statistic Voltage), entry 0x13 (Voltage RMS Maximum)) | UINT32 | RO | 0x60n8:13, 32**
**) for L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Statistic Current (for L1, pp = 07; L2, pp = 11; L3, pp = 1B)
Index (hex) | Name | Meaning | Data type | Flags | Default
1App:0 | L1 TxPDO-Map Statistic Current | PDO Mapping TxPDO 8 | UINT8 | RO | 0x03 (3dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n9 (PMX Statistic Current), entry 0x11 (Current Peak)) | UINT32 | RO | 0x60n9:11, 32**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n9 (PMX Statistic Current), entry 0x12 (Current RMS Minimum)) | UINT32 | RO | 0x60n9:12, 32**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60n9 (PMX Statistic Current), entry 0x13 (Current RMS Maximum)) | UINT32 | RO | 0x60n9:13, 32**
**) for L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Statistic Power (for L1, pp = 08; L2, pp = 12; L3, pp = 1C)
Index (hex) | Name | Meaning | Data type | Flags | Default
1App:0 | TxPDO-Map Statistic Power | PDO Mapping TxPDO | UINT8 | RO | 0x09 (9dec)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x11 (Active Power Avg)) | UINT32 | RO | 0x60nA:11, 32**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x12 (Active Power Min)) | UINT32 | RO | 0x60nA:12, 32**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x13 (Active Power Max)) | UINT32 | RO | 0x60nA:13, 32**
1App:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x14 (Apparent Power Avg)) | UINT32 | RO | 0x60nA:14, 32**
1App:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x15 (Apparent Power Max)) | UINT32 | RO | 0x60nA:15, 32**
1App:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x16 (Reactive Power Avg)) | UINT32 | RO | 0x60nA:16, 32**
1App:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x17 (Reactive Power Min)) | UINT32 | RO | 0x60nA:17, 32**
1App:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x18 (Reactive Power Max)) | UINT32 | RO | 0x60nA:18, 32**
1App:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x19 (Apparent Power Min)) | UINT32 | RO | 0x60nA:19, 32**
**) for L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Classic (for L1, pp = 09; L2, pp = 13; L3, pp = 1D)
Index (hex) | Name | Meaning | Data type | Flags | Default
1App:0 | TxPDO-Map Classic | PDO Mapping TxPDO | UINT8 | RO | 0x08 (8dec)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x00n0:00, 15**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60nB (PMX Classic), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x60nB:10, 1**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60nB (PMX Classic), entry 0x11 (Voltage)) | UINT32 | RO | 0x60nB:11, 32**
1App:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60nB (PMX Classic), entry 0x12 (Current)) | UINT32 | RO | 0x60nB:12, 32**
1App:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60nB (PMX Classic), entry 0x13 (Frequency)) | UINT32 | RO | 0x60nB:13, 32**
1App:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60nB (PMX Classic), entry 0x14 (Active Power)) | UINT32 | RO | 0x60nB:14, 32**
1App:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60nB (PMX Classic), entry 0x15 (Apparent Power)) | UINT32 | RO | 0x60nB:15, 32**
1App:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60nB (PMX Classic), entry 0x16 (Reactive Power)) | UINT32 | RO | 0x60nB:16, 32**
**) for L1, n = 0; L2, n = 1; L3, n = 2)
Index 1A1E Total TxPDO-Map Total Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1A1E:0 | Total TxPDO-Map Total Status | PDO Mapping TxPDO 31 | UINT8 | RO | 0x10 (16dec)
1A1E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x01 (System State)) | UINT32 | RO | 0xF600:01, 1
1A1E:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x02 (Grid Direction)) | UINT32 | RO | 0xF600:02, 1
1A1E:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x03 (Frequency Guard Warning)) | UINT32 | RO | 0xF600:03, 1
1A1E:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x04 (Frequency Guard Error)) | UINT32 | RO | 0xF600:04, 1
1A1E:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x05 (Neutral Current Guard Warning)) | UINT32 | RO | 0xF600:05, 1
1A1E:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x06 (Neutral Current Guard Error)) | UINT32 | RO | 0xF600:06, 1
1A1E:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x07 (Active Power Guard Warning)) | UINT32 | RO | 0xF600:07, 1
1A1E:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x08 (Active Power Guard Error)) | UINT32 | RO | 0xF600:08, 1
1A1E:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x09 (Apparent Power Guard Warning)) | UINT32 | RO | 0xF600:09, 1
1A1E:0A | SubIndex 010 | 10. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x0A (Apparent Power Guard Error)) | UINT32 | RO | 0xF600:0A, 1
1A1E:0B | SubIndex 011 | 11. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x0B (Power Quality Guard Warning)) | UINT32 | RO | 0xF600:0B, 1
1A1E:0C | SubIndex 012 | 12. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x0C (Power Quality Guard Error)) | UINT32 | RO | 0xF600:0C, 1
1A1E:0D | SubIndex 013 | 13. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A1E:0E | SubIndex 014 | 14. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x0F (TxPDO State)) | UINT32 | RO | 0xF600:0F, 1
1A1E:0F | SubIndex 015 | 15. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0xF600:10, 1
1A1E:10 | SubIndex 016 | 16. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x11 (Power Quality Factor)) | UINT32 | RO | 0xF600:11, 32
Index 1A1F Total TxPDO-Map Total Basic
Index (hex) | Name | Meaning | Data type | Flags | Default
1A1F:0 | Total TxPDO-Map Total Basic | PDO Mapping TxPDO 32 | UINT8 | RO | 0x03 (3dec)
1A1F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF601 (PMX Grid Basic), entry 0x11 (Frequency)) | UINT32 | RO | 0xF601:11, 32
1A1F:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF601 (PMX Grid Basic), entry 0x12 (Power Factor)) | UINT32 | RO | 0xF601:12, 32
1A1F:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF601 (PMX Grid Basic), entry 0x13 (Calculated Neutral Line Current)) | UINT32 | RO | 0xF601:13, 32
Index 1A20 Total TxPDO-Map Advanced
Index (hex) | Name | Meaning | Data type | Flags | Default
1A20:0 | Total TxPDO-Map Advanced | PDO Mapping TxPDO 33 | UINT8 | RO | 0x08 (8dec)
1A20:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF602 (PMX Grid Advanced), entry 0x11 (Max Voltage Harmonic Distortion)) | UINT32 | RO | 0xF602:01, 1
1A20:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF602 (PMX Grid Advanced), entry 0x12 (Max Current Harmonic Distortion)) | UINT32 | RO | 0xF602:02, 1
1A20:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF602 (PMX Grid Advanced), entry 0x13 (Max Current Distortion Factor)) | UINT32 | RO | 0x0000:00, 13
1A20:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF602 (PMX Grid Advanced), entry 0x14 (Voltage Unbalance)) | UINT32 | RO | 0xF602:10, 1
1A20:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF602 (PMX Total Advanced), entry 0x11 (Max Voltage Harmonic Distortion)) | UINT32 | RO | 0xF602:11, 32
1A20:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF602 (PMX Total Advanced), entry 0x12 (Max Current Harmonic Distortion)) | UINT32 | RO | 0xF602:12, 32
1A20:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF602 (PMX Total Advanced), entry 0x13 (Max Current Distortion Factor)) | UINT32 | RO | 0xF602:13, 32
1A20:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF602 (PMX Total Advanced), entry 0x14 (Voltage Unbalance)) | UINT32 | RO | 0xF602:14, 32
Index 1A21 Total TxPDO-Map Total Active
Index (hex) | Name | Meaning | Data type | Flags | Default
1A21:0 | Total TxPDO-Map Total Active | PDO Mapping TxPDO 34 | UINT8 | RO | 0x04 (4dec)
1A21:01 | SubIndex 001 | 1. PDO Mapping entry (32 bits align) | UINT32 | RO | 0x0000:00, 32
1A21:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF603 (PMX Total Active), entry 0x12 (Active Energy)) | UINT32 | RO | 0xF603:12, 64
1A21:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF603 (PMX Total Active), entry 0x13 (Active Positive Energy)) | UINT32 | RO | 0xF603:13, 64
1A21:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF603 (PMX Total Active), entry 0x14 (Active Negative Energy)) | UINT32 | RO | 0xF603:14, 64
Index 1A22 Total TxPDO-Map Apparent
Index (hex) | Name | Meaning | Data type | Flags | Default
1A22:0 | Total TxPDO-Map Apparent | PDO Mapping TxPDO 35 | UINT8 | RO | 0x04 (4dec)
1A22:01 | SubIndex 001 | 1. PDO Mapping entry (32 bits align) | UINT32 | RO | 0x0000:00, 32
1A22:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF605 (PMX Total Apparent), entry 0x12 (Apparent Energy)) | UINT32 | RO | 0xF605:12, 64
1A22:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF605 (PMX Total Apparent), entry 0x13 (Apparent Positive Energy)) | UINT32 | RO | 0xF605:13, 64
1A22:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF605 (PMX Total Apparent), entry 0x14 (Apparent Negative Energy)) | UINT32 | RO | 0xF605:14, 64
Index 1A23 Total TxPDO-Map Reactive
Index (hex) | Name | Meaning | Data type | Flags | Default
1A23:0 | Total TxPDO-Map Reactive | PDO Mapping TxPDO 36 | UINT8 | RO | 0x04 (4dec)
1A23:01 | SubIndex 001 | 1. PDO Mapping entry (32 bits align) | UINT32 | RO | 0x0000:00, 32
1A23:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF607 (PMX Total Reactive), entry 0x12 (Reactive Energy)) | UINT32 | RO | 0xF607:12, 64
1A23:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF607 (PMX Total Reactive), entry 0x13 (Reactive Positive Energy)) | UINT32 | RO | 0xF607:13, 64
1A23:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF607 (PMX Total Reactive), entry 0x14 (Reactive Negative Energy)) | UINT32 | RO | 0xF607:14, 64
Index 1A24 Total TxPDO-Map Total L-L Voltage
Index (hex) | Name | Meaning | Data type | Flags | Default
1A24:0 | Total TxPDO-Map Total L-L Voltage | PDO Mapping TxPDO 37 | UINT8 | RO | 0x03 (3dec)
1A24:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF609 (PMX Grid L-L Voltages), entry 0x11 (L1-L2 Voltage)) | UINT32 | RO | 0xF609:11, 32
1A24:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF609 (PMX Grid L-L Voltages), entry 0x12 (L2-L3 Voltage)) | UINT32 | RO | 0xF609:12, 32
1A24:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF609 (PMX Grid L-L Voltages), entry 0x13 (L3-L1 Voltage)) | UINT32 | RO | 0xF609:13, 32
Index 1A25 Total TxPDO-Map Variant Value In
Index (hex) | Name | Meaning | Data type | Flags | Default
1A25:0 | Total TxPDO-Map Variant Value In | PDO Mapping TxPDO 38 | UINT8 | RO | 0x0A (10dec)
1A25:01 | SubIndex 001 | 1. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1A25:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF60A (PMX Variant Value In), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0xF60A:10, 1
1A25:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF60A (PMX Variant Value In), entry 0x11 (Index 1 REAL)) | UINT32 | RO | 0xF60A:11, 16
1A25:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF60A (PMX Variant Value In), entry 0x12 (Value 1 REAL)) | UINT32 | RO | 0xF60A:12, 32
1A25:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF60A (PMX Variant Value In), entry 0x13 (Index 2 REAL)) | UINT32 | RO | 0xF60A:13, 16
1A25:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF60A (PMX Variant Value In), entry 0x14 (Value 2 REAL)) | UINT32 | RO | 0xF60A:14, 32
1A25:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF60A (PMX Variant Value In), entry 0x13 (Index 3 REAL)) | UINT32 | RO | 0xF60A:15, 16
1A25:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF60A (PMX Variant Value In), entry 0x16 (Value 3 REAL)) | UINT32 | RO | 0xF60A:16, 32
1A25:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF60A (PMX Variant Value In), entry 0x17 (Index 4 ULINT)) | UINT32 | RO | 0xF60A:17, 16
1A25:0A | SubIndex 010 | 10. PDO Mapping entry (object 0xF60A (PMX Variant Value In), entry 0x18 (Value 4 ULINT)) | UINT32 | RO | 0xF60A:18, 64
Index 1A26 Total TxPDO-Map Statistic Power
Index (hex) | Name | Meaning | Data type | Flags | Default
1A26:0 | Total TxPDO-Map Statistic Power | PDO Mapping TxPDO 39 | UINT8 | RO | 0x09 (9dec)
1A26:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x11 (Active Power Avg)) | UINT32 | RO | 0xF60B:11, 32
1A26:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x12 (Active Power Min)) | UINT32 | RO | 0xF60B:12, 32
1A26:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x13 (Active Power Max)) | UINT32 | RO | 0xF60B:13, 32
1A26:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x14 (Apparent Power Avg)) | UINT32 | RO | 0xF60B:14, 32
1A26:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x15 (Apparent Power Min)) | UINT32 | RO | 0xF60B:15, 32
1A26:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x16 (Apparent Power Max)) | UINT32 | RO | 0xF60B:16, 32
1A26:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x17 (Reactive Power Avg)) | UINT32 | RO | 0xF60B:17, 32
1A26:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x18 (Reactive Power Min)) | UINT32 | RO | 0xF60B:18, 32
1A26:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x19 (Reactive Power Max)) | UINT32 | RO | 0xF60B:19, 32
Index 1A27 Total TxPDO-Map Statistic PQF
Index (hex) | Name | Meaning | Data type | Flags | Default
1A27:0 | Total TxPDO-Map Statistic PQF | PDO Mapping TxPDO 40 | UINT8 | RO | 0x03 (3dec)
1A27:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF60C (PMX Total Statistic PQF), entry 0x11 (PQF Avg)) | UINT32 | RO | 0xF60C:11, 32
1A27:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF60C (PMX Total Statistic PQF), entry 0x12 (PQF Min)) | UINT32 | RO | 0xF60C:12, 32
1A27:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF60C (PMX Total Statistic PQF), entry 0x13 (PQF Max)) | UINT32 | RO | 0xF60C:13, 32
Index 1A28 Total TxPDO-Map Interval Energy
Index (hex) | Name | Meaning | Data type | Flags | Default
1A28:0 | Total TxPDO-Map Interval Energy | PDO Mapping TxPDO 41 | UINT8 | RO | 0x0B (11dec)
1A28:01 | SubIndex 001 | 1. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1A28:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0xF60D:10, 1
1A28:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x11 (Active Energy)) | UINT32 | RO | 0xF60D:11, 32
1A28:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x12 (Active Energy Positive)) | UINT32 | RO | 0xF60D:12, 32
1A28:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x13 (Active Energy Negative)) | UINT32 | RO | 0xF60D:13, 32
1A28:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x14 (Apparent Energy)) | UINT32 | RO | 0xF60D:14, 32
1A28:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x15 (Apparent Energy Positive)) | UINT32 | RO | 0xF60D:15, 32
1A28:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x16 (Apparent Energy Negative)) | UINT32 | RO | 0xF60D:16, 32
1A28:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x17 (Reactive Energy)) | UINT32 | RO | 0xF60D:17, 32
1A28:0A | SubIndex 010 | 10. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x18 (Reactive Energy Positive)) | UINT32 | RO | 0xF60D:18, 32
1A28:0B | SubIndex 011 | 11. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x19 (Reactive Energy Negative)) | UINT32 | RO | 0xF60D:19, 32
Index 1A29 Total TxPDO-Map Active Reduced
Index (hex) | Name | Meaning | Data type | Flags | Default
1A29:0 | Total TxPDO-Map Active Reduced | PDO Mapping TxPDO 35 | UINT8 | RO | 0x02 (2dec)
1A29:01 | SubIndex 001 | 1. PDO Mapping entry (Alignet)) | UINT32 | RO | 0x0000:00, 32
1A29:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF612 (PMX Total Apparent), entry 0x12 (Active Reduced)) | UINT32 | RO | 0xF612:12, 64
Index 1A2A Total TxPDO-Map Apparent Reduced
Index (hex) | Name | Meaning | Data type | Flags | Default
1A2A:0 | Total TxPDO-Map Apparent Reduced | PDO Mapping TxPDO 35 | UINT8 | RO | 0x02 (2dec)
1A2A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF613 (PMX Total Apparent Reduced), entry 0x11 (Apparent Power)) | UINT32 | RO | 0xF613:11, 32
1A2A:02 | SubIndex 002 | 2. . PDO Mapping entry (object 0xF613 (PMX Total Apparent Reduced), entry 0x12 (Apparent Energy)) | UINT32 | RO | 0xF613:12, 64
Index 1A2B Total TxPDO-Map Reactive Reduced
Index (hex) | Name | Meaning | Data type | Flags | Default
1A2B:0 | Total TxPDO-Map Reactive Reduced | PDO Mapping TxPDO 36 | UINT8 | RO | 0x02 (2dec)
1A2B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF614 (PMX Total Reactive Reduced), entry 0x11 (Reactive Power)) | UINT32 | RO | 0xF614:11, 32
1A2B:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF614 (PMX Total Reactive Reduced), entry 0x12 (Reactive Energy)) | UINT32 | RO | 0xF614:12, 64
Index 1A2C Total TxPDO-Map Interval Energy Reduced
Index (hex) | Name | Meaning | Data type | Flags | Default
1A2C:0 | Total TxPDO-Map Interval Energy Reduced | PDO Mapping TxPDO 36 | UINT8 | RO | 0x05 (5dez)
1A2C:01 | SubIndex 001 | 1. PDO Mapping entry (align) | UINT32 | RO | 0x0000:00, 15
1A2C:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF615 (PMX Total Interval Energy Reduced), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0xF615:10, 1
1A2C:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF615 (PMX Total Interval Energy Reduced), entry 0x11 (Active Energy)) | UINT32 | RO | 0xF615:11, 32
1A2C:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF615 (PMX Total Interval Energy Reduced), entry 0x12 (Apparent Energy)) | UINT32 | RO | 0xF615:12, 32
1A2C:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF615 (PMX Total Interval Energy Reduced), entry 0x13 (reactive Energy)) | UINT32 | RO | 0xF615:13, 32
Index 1C00 Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Length of this object | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RW | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RW | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RW | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RW | 0x04 (4dec)
Index 1C12 RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x01 (1dec)
1C12:01 | SubIndex 001 | 1. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1601 (5633dec)
Index 1C13 TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x0A (10dec)
1C13:01 | Subindex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A01 (6657dec)
1C13:03 | Subindex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A02 (6658dec)
1C13:04 | Subindex 004 | 4. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A0A (6666dec)
1C13:05 | Subindex 005 | 5. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A0B (6667dec)
1C13:06 | Subindex 006 | 6. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A0C (6668dec)
1C13:07 | Subindex 007 | 7. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A14 (6676dec)
1C13:08 | Subindex 008 | 8. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A15 (6677dec)
1C13:09 | Subindex 009 | 9. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A16 (6678dec)
1C13:0A | Subindex 010 | 10. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A1E (6686dec)
1C13:0B | Subindex 011 | 11. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0C | Subindex 012 | 12. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0D | Subindex 013 | 13. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0E | Subindex 014 | 14. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0F | Subindex 015 | 15. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:10 | Subindex 016 | 16. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:11 | Subindex 017 | 17. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:12 | Subindex 018 | 18. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:13 | Subindex 019 | 19. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:14 | Subindex 020 | 20. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:15 | Subindex 021 | 21. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:16 | Subindex 022 | 22. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:17 | Subindex 023 | 23. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:18 | Subindex 024 | 24. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:19 | Subindex 025 | 25. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:1A | Subindex 026 | 26. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:1B | Subindex 027 | 27. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:1C | Subindex 028 | 28. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:1D | Subindex 029 | 29. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:1E | Subindex 030 | 30. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:1F | Subindex 031 | 31. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:20 | Subindex 032 | 32. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:21 | Subindex 033 | 33. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:22 | Subindex 034 | 34. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:23 | Subindex 035 | 35. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:24 | Subindex 036 | 36. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:25 | Subindex 037 | 37. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:26 | Subindex 038 | 38. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:27 | Subindex 039 | 39. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:28 | Subindex 040 | 40. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:29 | Subindex 041 | 41. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 1C32 SM output parameter
Index | Name | Meaning | Data type | Flags | Default
1C32:0 | SM output parameter | Synchronization parameters for the outputs | UINT8 | RO | 0x20 (32dec)
1C32:01 | Sync mode | Current synchronization mode: 0: Free Run 1: Synchron with SM 2 Event 2: DC-Mode - Synchron with SYNC0 Event 3: DC-Mode - Synchron with SYNC1 Event | UINT16 | RW | 0x0000 (0dec)
1C32:02 | Cycle time | Cycle time (in ns): Free Run: Cycle time of the local timer Synchron with SM 2 Event: Master cycle time DC mode: SYNC0/SYNC1 Cycle Time | UINT32 | RW | 0x0016E360 (1500000dec)
1C32:03 | Shift time | Time between SYNC0 event and output of the outputs (in ns, DC mode only) | UINT32 | RO | 0x00000384 (900dec)
1C32:04 | Sync modes supported | Supported synchronization modes: Bit 0 = 1: free run is supported Bit 1 = 1: synchronous with SM 2 event is supported Bit 2-3 = 01: DC mode is supported Bit 4-5 = 10: Output shift with SYNC1 event (only DC mode) Bit 14 = 1: dynamic times (measurement through writing of 1C32:08) | UINT16 | RO | 0x0805 (2053dec)
1C32:05 | Minimum cycle time | Minimum cycle time (in ns) | UINT32 | RO | 0x0007A120 (500000dec)
1C32:06 | Calc and copy time | Minimum time between SYNC0 and SYNC1 event (in ns, DC mode only) | UINT32 | RO | 0x00000384 (900dec)
1C32:07 | Minimum delay time |  | UINT32 | RO | 0x00000384 (900dec)
1C32:08 | Command | 0: Measurement of the local cycle time is stopped 1: Measurement of the local cycle time is started The entries 1C32:03, 1C32:05, 1C32:06, 1C32:09, 1C33:03, 1C33:06, 1C33:09 are updated with the maximum measured values. For a subsequent measurement the measured values are reset | UINT16 | RW | 0x0000 (0dec)
1C32:09 | Maximum delay time | Time between SYNC1 event and output of the outputs (in ns, DC mode only) | UINT32 | RO | 0x00000384 (900dec)
1C32:0B | SM event missed counter | Number of missed SM events in OPERATIONAL (DC mode only) | UINT16 | RO | 0x0000 (0dec)
1C32:0C | Cycle exceeded counter | Number of occasions the cycle time was exceeded in OPERATIONAL (cycle was not completed in time or the next cycle began too early) | UINT16 | RO | 0x0000 (0dec)
1C32:0D | Shift too short counter | Number of occasions that the interval between SYNC0 and SYNC1 event was too short (DC mode only) | UINT16 | RO | 0x0000 (0dec)
Index 1C33 SM input parameter
Index (hex) | Name | Meaning | Data type | Flags | Default
1C33:0 | SM input parameter | Synchronization parameters for the inputs | UINT8 | RO | 0x20 (32dec)
1C33:01 | Sync mode | Current synchronization mode: 0: Free Run 1: Synchron with SM 3 Event (no outputs available) 2: DC - Synchron with SYNC0 Event 3: DC - Synchron with SYNC1 Event 34: Synchron with SM 2 event (outputs available) | UINT16 | RW | 0x0000 (0dec)
1C33:02 | Cycle time | as 1C32:02 | UINT32 | RW | 0x0016E360 (1500000dec)
1C33:03 | Shift time | Time between SYNC0 event and reading of the inputs (in ns, only DC mode) | UINT32 | RO | 0x00000384 (900dec)
1C33:04 | Sync modes supported | Supported synchronization modes: Bit 0: free run is supported Bit 1: Synchron with SM 2 Event is supported (outputs available) Bit 1: Synchron with SM 3 Event is supported (no outputs available) Bit 2-3 = 01: DC mode is supported Bit 4-5 = 01: Input shift through local event (outputs available) Bit 4-5 = 10: Input shift with SYNC1 event (no outputs available) Bit 14 = 1: dynamic times (measurement through writing of 1C32:08 or 1C33:08) | UINT16 | RO | 0x0805 (2053dec)
1C33:05 | Minimum cycle time | as 1C32:05 | UINT32 | RO | 0x0007A120 (500000dec)
1C33:06 | Calc and copy time | Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode) | UINT32 | RO | 0x0007A120 (500000dec)
1C33:07 | Minimum delay time |  | UINT32 | RO | 0x00000384 (900dec)
1C33:08 | Command | as 1C32:08 | UINT16 | RW | 0x0000 (0dec)
1C33:09 | Maximum delay time | Time between SYNC1 event and reading of the inputs (in ns, only DC mode) | UINT32 | RO | 0x00000384 (900dec)
1C33:0B | SM event missed counter | as 1C32:11 | UINT16 | RO | 0x0000 (0dec)
1C33:0C | Cycle exceeded counter | as 1C32:12 | UINT16 | RO | 0x0000 (0dec)
1C33:0D | Shift too short counter | as 1C32:13 | UINT16 | RO | 0x0000 (0dec)
Index F000 Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | Largest subindex of this object | UINT8 | RO | 0x02
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RW | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RW | 0x0003 (3dec)
Index F008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dec)
Code Word
The vendor reserves the authority for the basic calibration of the terminals. The code word is therefore at present reserved.
Index F010 Module List
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list |  | UINT8 | RW | 0x03 (3dec)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x00000155 (341dec)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x00000155 (341dec)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x00000155 (341dec)


Command object

Commissioning [image] Object description and parameterization [image] EL3443-00xx [image] Command object
Command object
Index FB00 PMX Command
The command object is used for triggering an action in the terminal. The command is started by writing subindex 1 (request). Write access is disabled until the current command is completed.
Index (hex) | Name | Meaning |  | Data type | Flags | Default
FB00:0 | PM Command | Largest subindex of this object |  | UINT8 | RO | 0x03
FB00:01 | Request | Byte 0 - service request data |  | OCTET-STRING [2] | RW | 0x0000 (0dec)
 |  | 4hex | Clear energy
 |  | Byte 1 - channel selection
 |  | 00hex | all channels
 |  | 01hex | Channel 1
 |  | 02hex | Channel 2
 |  | 03hex | Channel 3
FB00:02 | Status | Byte 0 |  | UINT8 | RW | 0x00 (0dec)
 |  | reserved
FB00:03 | Response | Byte 0 |  | OCTET-STRING [2] | RW | 0x00000000 (0dec)
 |  | reserved
 |  | Byte 1
 |  | reserved
 |  | Byte 2-n
 |  | reserved


EL3446

Commissioning [image] Object description and parameterization [image] EL3446
EL3446
Additional information
•
Restore object
•
Configuration data
•
Configuration data (vendor-specific)
•
Input data
•
Output data
•
Information and diagnostic data
•
Standard objects
•
Command object


Restore object

Commissioning [image] Object description and parameterization [image] EL3446 [image] Restore object
Restore object
Index 1011 Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default parameters | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to “0x64616F6C” in the set value dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)


Configuration data

Commissioning [image] Object description and parameterization [image] EL3446 [image] Configuration data
Configuration data
Index 80n0 DPM Channel Settings (for Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2; Ch.4, n = 3; Ch.5, n = 4; Ch.6, n = 5)
Index (hex) | Name | Meaning | Data type | Flags | Default
80n0:0 | DPM Channel Settings | Max. subindex | UINT8 | RO | 0x13 (19dec)
80n0:11 | Supply Channel | Selection of the voltage reference: 0: no reference 1: Channel 1 2: Channel 2 3: Channel 3 | UINT32 | RW | Channel 1 (1)
80n0:12 | Current Transformer Ratio | Here the transmission ratio of the current transformer used can be entered. | REAL32 | RW | 1,000000 (1,000000e+000)
80n0:13 | Current Transformer Delay | A possible time delay of the current transformers in milliseconds can be entered here. | REAL32 | RW | 0,000000 (0,000000e+000)
Index 80n1 DPM Channel User Scale (for Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2; Ch.4, n = 3; Ch.5, n = 4; Ch.6, n = 5)
Index (hex) | Name | Meaning | Data type | Flags | Default
80n1:0 | DPM Channel User Scale | Max. subindex | UINT8 | RO | 0x15 (21dec)
80n1:01 | User Calibration Enable | Set to true to enable user calibration data. | BOOLEAN | RW | 0x00 (0dec)
80n1:11 | User Calibration Current Offset | Value in A | REAL32 | RW | 0,000000 (0,000000e+000)
80n1:12 | User Calibration Current Gain | Factor (without unit) | REAL32 | RW | 1,000000 (1,000000e+000)
80n1:13 | User Calibration Phase Offset | Value in milliseconds | REAL32 | RW | 0,000000 (0,000000e+000)
Index 80n2 DPM Channel Guard Settings - EL3446 (for Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2; Ch.4, n = 3; Ch.5, n = 4; Ch.6, n = 5)
Index (hex) | Name | Meaning | Data type | Flags | Default
80n2:0 | DPM Channel Guard Settings | Max. subindex | UINT8 | RO | 0x14 (20dec)
80n2:01 | Voltage Guard Min Error | Lower limit value for a voltage error message | REAL32 | RW | 2,000000 (2,000000e+000)
80n2:02 | Voltage Guard Min Warning | Lower limit value for a voltage warning message | REAL32 | RW | 207,000000 (2,070000e+002)
80n2:03 | Voltage Guard Max Warning | Upper limit value for a voltage warning message | REAL32 | RW | 253,000000 (2,530000e+002)
80n2:04 | Voltage Guard Max Error | Upper limit value for a voltage error message | REAL32 | RW | 278,000000 (2,780000e+002)
80n2:05 | Current Guard Min Error | Lower limit value for a current error message | REAL32 | RW | -1,050000 (-1,050000e+000)
80n2:06 | Current Guard Min Warning | Lower limit value for a current warning message | REAL32 | RW | -1,000000 (-1,000000e+000)
80n2:07 | Current Guard Max Warning | Upper limit value for a current warning message | REAL32 | RW | 1,000000 (1,000000e+000)
80n2:08 | Current Guard Max Error | Upper limit value for a current error message | REAL32 | RW | 1,050000 (1,050000e+000)
80n2:09 | Active Power Guard Min Error | Lower limit value for an active power error message | REAL32 | RW | -241,500000 (-2,415000e+002)
80n2:0A | Active Power Guard Min Warning | Lower limit value for an active power warning message | REAL32 | RW | -230,000000 (-2,300000e+002)
80n2:0B | Active Power Guard Max Warning | Upper limit value for an active power warning message | REAL32 | RW | 230,000000 (2,300000e+002)
80n2:0C | Active Power Guard Max Error | Upper limit value for an active power error message | REAL32 | RW | 241,500000 (2,415000e+002)
80n2:0D | Apparent Power Guard Min Error | Lower limit value for an apparent power error message | REAL32 | RW | 0,000000 (0,000000e+000)
80n2:0E | Apparent Power Guard Min Warning | Lower limit value for an apparent power warning message | REAL32 | RW | 0,000000 (0,000000e+000)
80n2:0F | Apparent Power Guard Max Warning | Upper limit value for an apparent power warning message | REAL32 | RW | 230,000000 (2,300000e+002)
80n2:10 | Apparent Power Guard Max Error | Upper limit value for an apparent power error message | REAL32 | RW | 241,500000 (2,415000e+002)
80n2:11 | Reactive Power Guard Min Error | Lower limit value for an reactive power error message | REAL32 | RW | 0,000000 (0,000000e+000)
80n2:12 | Reactive Power Guard Min Warning | Lower limit value for an reactive power warning message | REAL32 | RW | 0,000000 (0,000000e+000)
80n2:13 | Reactive Power Guard Max Warning | Upper limit value for an reactive power warning message | REAL32 | RW | 230,000000 (2,300000e+002)
80n2:14 | Reactive Power Guard Max Error | Upper limit value for an reactive power error message | REAL32 | RW | 241,500000 (2,415000e+002)


Configuration data (vendor-specific)

Commissioning [image] Object description and parameterization [image] EL3446 [image] Configuration data (vendor-specific)
Configuration data (vendor-specific)
Index 80nF DPM Channel Vendor data (for Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2; Ch.4, n = 3; Ch.5, n = 4; Ch.6, n = 5)
Index (hex) | Name | Meaning | Data type | Flags | Default
80nF:0 | DPM Channel Vendor data | Max. subindex | UINT8 | RO | 0x13 (19dez)
80nF:11 | Calibration Current Offset | Value in A | REAL32 | RW | 0,000000 (0,000000e+000)
80nF:12 | Calibration Current Gain | Factor (without unit) | REAL32 | RW | 1,000000 (1,000000e+000)
80nF:13 | Calibration Current Phase Offset | Value in milliseconds | REAL32 | RW | 0,000000 (0,000000e+000)


Input data

Commissioning [image] Object description and parameterization [image] EL3446 [image] Input data
Input data
Index 606A DPM Variant Value In
Index (hex) | Name | Meaning | Data type | Flags | Default
606A:0 | DPM Variant Value In | Max. subindex | UINT8 | RO | 0x18 (24dec)
606A:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO has been updated | BOOLEAN | RO | 0x00 (0dec)
606A:11 | Index 1 REAL | Acknowledge for variable output value 1 | UINT16 | RO | 0x0000 (0dec)
606A:12 | Value 1 REAL | Variable output value channel 1 | REAL32 | RO | 0x00000000 (0dec)
606A:13 | Index 2 REAL | Acknowledge for variable output value 2 | UINT16 | RO | 0x0000 (0dec)
606A:14 | Value 2 REAL | Variable output value channel 2 | REAL32 | RO | 0x00000000 (0dec)
606A:15 | Index 3 REAL | Acknowledge for variable output value 3 | UINT16 | RO | 0x0000 (0dec)
606A:16 | Value 3 REAL | Variable output value channel 3 | REAL32 | RO | 0x00000000 (0dec)
606A:17 | Index 4 ULINT | Acknowledge for variable output value 4 | UINT16 | RO | 0x0000 (0dec)
606A:18 | Value 4 ULINT | Variable output value channel 4 | UINT64 | RO |
Index 60n0 DPM Channel (for Ch.1 n = 0; Ch.2 n = 1; Ch.3 n = 2; Ch.4 n = 3; Ch.5 n = 4; Ch.6 n = 5)
Index (hex) | Name | Meaning | Data type | Flags | Default
60n0:0 | DPM Channel | Max. subindex | UINT8 | RO | 0x10 (16dec)
60n0:01 | Overcurrent | Maximum measurable current is exceeded. | BOOLEAN | RO | 0x00 (0dec)
60n0:02 | Inaccurate Current | The measured current value is outside the limits for the current entered in CoE object 0x80n2 | BOOLEAN | RO | 0x00 (0dec)
60n0:03 | Current Guard Warning | The measured current value is outside the warning limits entered in the CoE objects 0x80n2:06 and 0x80n2:07 | BOOLEAN | RO | 0x00 (0dec)
60n0:04 | Current Guard Error | The measured current value is outside the error limits entered in the CoE objects 0x80n2:05 and 0x80n2:08 | BOOLEAN | RO | 0x00 (0dec)
60n0:05 | Apparent Power Guard Warning | The value for the apparent power is outside the warning limits entered in the CoE objects 0x80n2:0A and 0x80n2:0B | BOOLEAN | RO | 0x00 (0dec)
60n0:06 | Apparent Power Guard Error | The value for the apparent power is outside the error limits for the current entered in the CoE objects 0x80n2:09 and 0x80n2:0C | BOOLEAN | RO | 0x00 (0dec)
60n0:07 | Active Power Guard Warning | The value for active power is outside the warning limits entered in the CoE objects 0x80n2:0E and 0x80n2:0F | BOOLEAN | RO | 0x00 (0dec)
60n0:08 | Active Power Guard Error | The value for active power is outside the error limits for the current entered in CoE objects 0x80n2:0D and 0x80n2:10 | BOOLEAN | RO | 0x00 (0dec)
60n0:09 | Reactive Power Guard Warning | The value for the reactive power is outside the warning limits entered in the CoE objects 0x80n2:12 and 0x80n2:13 | BOOLEAN | RO | 0x00 (0dec)
60n0:0A | Reactive Power Guard Error | The value for the reactive power is outside the error limits for the current entered in the CoE objects 0x80n2:11 and 0x80n2:14 | BOOLEAN | RO | 0x00 (0dec)
60n0:0C | DPM Toggle | The DPM toggle is toggled by the slave when the DPM data has been updated. | BOOLEAN | RO | 0x00 (0dec)
60n0:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO has been updated. | BOOLEAN | RO | 0x00 (0dec)
60n0:11 | Current | Actual measured current value | REAL32 | RO | 0x00000000 (0dec)
60n0:12 | Active Power | Actually measured active power | REAL32 | RO | 0x00000000 (0dec)
60n0:13 | Apparent Power | Actual measured apparent power | REAL32 | RO | 0x00000000 (0dec)
60n0:14 | Reactive Power Fundamental | Balanced reactive power fundamental oscillation | REAL32 | RO | 0x00000000 (0dec)
60n0:15 | Active Energy | Actually measured active energy | UINT32 | RO | 0x00000000 (0dec)


Output data

Commissioning [image] Object description and parameterization [image] EL3446 [image] Output data
Output data
Index 7060 DPM Variant Value Out
Index (hex) | Name | Meaning | Data type | Flags | Default
7060:0 | DPM Variant Value Out | Max. subindex | UINT8 | RO | 0x14 (20dec)
7060:11 | Index 1 REAL | Request for variable output value 1 (REAL) | UINT16 | RO | 0x0000 (0dec)
7060:12 | Index 2 REAL | Request for variable output value 2 (REAL) | UINT16 | RO | 0x0000 (0dec)
7060:13 | Index 3 REAL | Request for variable output value 3 (REAL) | UINT16 | RO | 0x0000 (0dec)
7060:14 | Index 4 ULINT | Request for variable output value 4 (ULINT) | UINT16 | RO | 0x0000 (0dec)
Index F700 DPM Data
Index (hex) | Name | Meaning | Data type | Flags | Default
F700:0 | DPM Data | Max. subindex | UINT8 | RO | 0x14 (20dec)
F700:01 | SubIndex 001 |  | UINT32 | RO | 0x00000000 (0dez)
F700:02 | SubIndex 002 |  | UINT32 | RO | 0x00000000 (0dez)
F700:03 | SubIndex 003 |  | UINT32 | RO | 0x00000000 (0dez)
F700:04 | SubIndex 004 |  | UINT32 | RO | 0x00000000 (0dez)
F700:05 | SubIndex 005 |  | UINT32 | RO | 0x00000000 (0dez)
F700:06 | SubIndex 006 |  | UINT32 | RO | 0x00000000 (0dez)
F700:07 | SubIndex 007 |  | UINT32 | RO | 0x00000000 (0dez)
F700:08 | SubIndex 008 |  | UINT32 | RO | 0x00000000 (0dez)
F700:09 | SubIndex 009 |  | UINT32 | RO | 0x00000000 (0dez)
F700:0A | SubIndex 010 |  | UINT32 | RO | 0x00000000 (0dez)
F700:0B | SubIndex 011 |  | UINT32 | RO | 0x00000000 (0dez)
F700:0C | SubIndex 012 |  | UINT32 | RO | 0x00000000 (0dez)
F700:0D | SubIndex 013 |  | UINT32 | RO | 0x00000000 (0dez)
F700:0E | SubIndex 014 |  | UINT32 | RO | 0x00000000 (0dez)
F700:0F | SubIndex 015 |  | UINT32 | RO | 0x00000000 (0dez)
F700:10 | SubIndex 016 |  | UINT32 | RO | 0x00000000 (0dez)
F700:11 | SubIndex 017 |  | UINT32 | RO | 0x00000000 (0dez)
F700:12 | SubIndex 018 |  | UINT32 | RO | 0x00000000 (0dez)
F700:13 | SubIndex 019 |  | UINT32 | RO | 0x00000000 (0dez)
F700:14 | SubIndex 020 |  | UINT32 | RO | 0x00000000 (0dez)


Information and diagnostic data

Commissioning [image] Object description and parameterization [image] EL3446 [image] Information and diagnostic data
Information and diagnostic data
Index 90n0 DPM Channel Harmonics - EL3446 (for Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2; Ch.4, n = 3; Ch.5, n = 4; Ch.6, n = 5)
Index (hex) | Name | Meaning | Data type | Flags | Default
90n0:0 | DPM Channel Harmonics | Max. subindex | UINT8 | RO | 0x14 (20dec)
90n0:01 | Subindex 001 | DC component of the oscillation of the fundamental wave | REAL32 | RO | 0x00000000 (0dec)
90n0:02 | Subindex 002 | Fundamental wave | REAL32 | RO | 0x00000000 (0dec)
90n0:03 | Subindex 003 | 2nd harmonic of the fundamental wave | REAL32 | RO | 0x00000000 (0dec)
90n0:04 | Subindex 004 | 3rd harmonic of the fundamental wave | REAL32 | RO | 0x00000000 (0dec)
… | … | … | … | … | …
90n0:14 | Subindex 020 | 19th harmonic of the fundamental wave | REAL32 | RO | 0x00000000 (0dec)
Index 90n1 DPM Channel Info data Current - EL3446 (for Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2; Ch.4, n = 3; Ch.5, n = 4; Ch.6, n = 5)
Index (hex) | Name | Meaning | Data type | Flags | Default
90n1:0 | DPM Channel Info data Current | Max. subindex | UINT8 | RO | 0x13 (19dec)
90n1:11 | Current Peak | Peak value of the instantaneous current in the last interval in A | REAL32 | RO | 0x00000000 (0dec)
90n1:12 | Current RMS Minimum | Minimum RMS value of the current in the last interval in A | REAL32 | RO | 0x00000000 (0dec)
90n1:13 | Current RMS Maximum | Maximum RMS value of the current in the last interval in A | REAL32 | RO | 0x00000000 (0dec)
Index 90n2 DPM Channel Info data Power - EL3446 (for Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2; Ch.4, n = 3; Ch.5, n = 4; Ch.6, n = 5)
Index (hex) | Name | Meaning | Data type | Flags | Default
90n2:0 | DPM Channel Info data Power | Max. subindex | UINT8 | RO | 0x1B (27dec)
90n2:11 | Active Power Avg | Average active phase power during the last interval in W | REAL32 | RO | 0x00000000 (0dec)
90n2:12 | Active Power Min | Minimum active phase power during the last interval in W | REAL32 | RO | 0x00000000 (0dec)
90n2:13 | Active Power Max | Maximum active phase power during the last interval in W | REAL32 | RO | 0x00000000 (0dec)
90n2:14 | Apparent Power Avg | Average apparent phase power during the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
90n2:15 | Apparent Power Min | Minimum apparent phase power during the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
90n2:16 | Apparent Power Max | Maximum apparent phase power during the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
90n2:17 | Reactive Power Avg | Average reactive phase power during the last interval in var | REAL32 | RO | 0x00000000 (0dec)
90n2:18 | Reactive Power Min | Minimum reactive phase power during the last interval in var | REAL32 | RO | 0x00000000 (0dec)
90n2:19 | Reactive Power Max | Maximum reactive phase power during the last interval in var | REAL32 | RO | 0x00000000 (0dec)
90n2:1A | Phi | Phase angle in degrees (between voltage U_Lx and the corresponding current I_Lx) | REAL32 | RO | 0x00000000 (0dec)
90n2:1B | Phase angle | Phase difference in degrees (between different voltages U_Lx and U_Ly) | REAL32 | RO | 0x00000000 (0dec)
Index 90n3 DPM Channel Info data Energy - EL3446 (for Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2; Ch.4, n = 3; Ch.5, n = 4; Ch.6, n = 5)
Index (hex) | Name | Meaning | Data type | Flags | Default
90n3:0 | DPM Channel Info data Energy | Max. subindex | UINT8 | RO | 0x09 (9dec)
90n3:01 | Active Energy | Recorded active phase energy in mWh | INT64 | RO |
90n3:02 | Positive Active Energy | Received active phase energy in mWh | UINT64 | RO |
90n3:03 | Negative Active Energy | Supplied active phase energy in mWh | UINT64 | RO |
90n3:04 | Apparent Energy | Recorded apparent phase energy in mWh | INT64 | RO |
90n3:05 | Positive Apparent Energy | Received apparent phase energy in mWh | UINT64 | RO |
90n3:06 | Negative Apparent Energy | Supplied apparent phase energy in mWh | UINT64 | RO |
90n3:07 | Reactive Energy | Recorded reactive phase energy in mWh | INT64 | RO |
90n3:08 | Positive Reactive Energy | Received reactive phase energy in mWh | UINT64 | RO |
90n3:09 | Negative Reactive Energy | Supplied reactive phase energy in mWh | UINT64 | RO |
Index A0n0 DPM Channel Diag data - EL3446 (for Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2; Ch.4, n = 3; Ch.5, n = 4; Ch.6, n = 5)
Index (hex) | Name | Meaning | Data type | Flags | Default
A0n0:0 | DPM Channel Diag data | Max. subindex | UINT8 | RO | 0x01 (1dec)
A0n0:01 | Saturation Time Current | Time (in 0.1 ms) in which the terminal has measured an overcurrent. | UINT32 | RO | 0x00000000 (0dec)
Index F081 Download revision
Index (hex) | Name | Meaning | Data type | Flags | Default
F081:0 | Download revision | Max. subindex | UINT8 | RO | 0x01 (1dec)
F010:01 | Revision number | Configured revision of the terminal, (see note) | UINT32 | RW | 0x00000000 (0dec)


Standard objects

Commissioning [image] Object description and parameterization [image] EL3446 [image] Standard objects
Standard objects
Index 1000 Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x01551389 (22352777dec)
Index 1008 Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EL34xx
Index 1009 Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO |
Index 100A Software Version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO |
Index 100B Bootloader version
Index (hex) | Name | Meaning | Data type | Flags | Default
100B:0 | Bootloader version | Bootloader version | STRING | RO |
Index 1018 Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Length of this object | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x0D763052 (225849426dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the low word (bit 0-15) indicates the special terminal number, the high word (bit 16-31) refers to the device description | UINT32 | RO | 0x00140000 (1310720dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the low byte (bit 0-7) of the low word contains the year of production, the high byte (bit 8-15) of the low word contains the week of production, the high word (bit 16-31) is 0 | UINT32 | RO | z.B. 0x00001E06 (KW 30/2006)
Index 10F0 Backup parameter
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter | Length of this object | UINT8 | RO | 0x01
10F0:01 | Checksum | Checksum | UINT32 | RW | 0x00000000 (0dec)
Index 10F3 Diagnosis History
Index | Name | Meaning | Data type | Flags | Default
10F3:0 | Diagnosis History | Maximum subindex | UINT8 | RO | 0x15 (21dec)
10F3:01 | Maximum Messages | Maximum number of stored messages. A maximum of 50 messages can be stored | UINT8 | RO | 0x00 (0dec)
10F3:02 | Newest Message | Subindex of the latest message | UINT8 | RO | 0x00 (0dec)
10F3:03 | Newest Acknowledged Message | Subindex of the last confirmed message | UINT8 | RW | 0x00 (0dec)
10F3:04 | New Messages Available | Indicates that a new message is available | BOOLEAN | RO | 0x00 (0dec)
10F3:05 | Flags | not used | UINT16 | RW | 0x0000 (0dec)
10F3:06 | Diagnosis Message 001 | Message 1 | OCTET STRING[28] | RO | {0}
... | ... | ... | ... | ... | ...
10F3:15 | Diagnosis Message 016 | Message 16 | OCTET STRING[28] | RO | {0}
Index 10F8 Actual Time Stamp
Index | Name | Meaning | Data type | Flags | Default
10F8:0 | Actual Time Stamp | Time stamp | UINT64 | RO | 0x0000000000000000 (0dec)
Index 10F9 Time Distribution Object
Index | Name | Meaning | Data type | Flags | Default
10F9:0 | Time Distribution Object | Max Subindex | UINT8 | RO | 0x01 (1dec)
10F9:01 | Distributed Time Value | Object for time distribution by the EtherCAT Master | INT64 | RW |
Index 1600 DPM RxPDO-Map Variant Value Out
Index (hex) | Name | Meaning | Data type | Flags | Default
1600:0 | DPM RxPDO-Map Variant Value Out | PDO Mapping RxPDO 1 | UINT8 | RO | 0x04 (4dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7060 (DPM Variant Value Out), entry 0x11 (Index 1 REAL)) | UINT32 | RO | 0x7060:11, 16
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7060 (DPM Variant Value Out), entry 0x12 (Index 2 REAL)) | UINT32 | RO | 0x7060:12, 16
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7060 (DPM Variant Value Out), entry 0x13 (Index 3 REAL)) | UINT32 | RO | 0x7060:13, 16
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7060 (DPM Variant Value Out), entry 0x14 (Index 4 ULINT)) | UINT32 | RO | 0x7060:14, 16
Index 1601 DPM RxPDO-Map Data
Index (hex) | Name | Meaning | Data type | Flags | Default
1601:0 | DPM RxPDO-Map Data | PDO Mapping RxPDO 2 | UINT8 | RO | 0x02 (2dec)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF700 (DPM Data), entry 0x01 (Data 1)) | UINT32 | RO | 0xF700:01, 32
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF700 (DPM Data), entry 0x02 (Data 2)) | UINT32 | RO | 0xF700:02, 32
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF700 (DPM Data), entry 0x03 (Data 3)) | UINT32 | RO | 0xF700:03, 32
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF700 (DPM Data), entry 0x04 (Data 4)) | UINT32 | RO | 0xF700:04, 32
1601:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF700 (DPM Data), entry 0x05 (Data 5)) | UINT32 | RO | 0xF700:05, 32
1601:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF700 (DPM Data), entry 0x06 (Data 6)) | UINT32 | RO | 0xF700:06, 32
1601:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF700 (DPM Data), entry 0x07 (Data 7)) | UINT32 | RO | 0xF700:07, 32
1601:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF700 (DPM Data), entry 0x08 (Data 8)) | UINT32 | RO | 0xF700:08, 32
1601:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF700 (DPM Data), entry 0x09 (Data 9)) | UINT32 | RO | 0xF700:09, 32
1601:0A | SubIndex 010 | 10. PDO Mapping entry (object 0xF700 (DPM Data), entry 0x0A (Data 10)) | UINT32 | RO | 0xF700:0A, 32
1601:0B | SubIndex 011 | 11. PDO Mapping entry (object 0xF700 (DPM Data), entry 0x0B (Data 11)) | UINT32 | RO | 0xF700:0B, 32
1601:0C | SubIndex 012 | 12. PDO Mapping entry (object 0xF700 (DPM Data), entry 0x0C (Data 12)) | UINT32 | RO | 0xF700:0C, 32
1601:0D | SubIndex 013 | 13. PDO Mapping entry (object 0xF700 (DPM Data), entry 0x0D (Data 13)) | UINT32 | RO | 0xF700:0D, 32
1601:0E | SubIndex 014 | 14. PDO Mapping entry (object 0xF700 (DPM Data), entry 0x0E (Data 14)) | UINT32 | RO | 0xF700:0E, 32
1601:0F | SubIndex 015 | 15. PDO Mapping entry (object 0xF700 (DPM Data), entry 0x0F (Data 15)) | UINT32 | RO | 0xF700:0F, 32
1601:10 | SubIndex 016 | 16. PDO Mapping entry (object 0xF700 (DPM Data), entry 0x10 (Data 16)) | UINT32 | RO | 0xF700:10, 32
1601:11 | SubIndex 017 | 17. PDO Mapping entry (object 0xF700 (DPM Data), entry 0x11 (Data 17)) | UINT32 | RO | 0xF700:11, 32
1601:12 | SubIndex 018 | 18. PDO Mapping entry (object 0xF700 (DPM Data), entry 0x12 (Data 18)) | UINT32 | RO | 0xF700:12, 32
1601:13 | SubIndex 019 | 19. PDO Mapping entry (object 0xF700 (DPM Data), entry 0x13 (Data 19)) | UINT32 | RO | 0xF700:13, 32
1601:14 | SubIndex 020 | 20. PDO Mapping entry (object 0xF700 (DPM Data), entry 0x14 (Data 20)) | UINT32 | RO | 0xF700:14, 32
Index 1A0C DPM TxPDO-Map Variant Value In
Index (hex) | Name | Meaning | Data type | Flags | Default
1600:0 | DPM TxPDO-Map Variant Value In | PDO Mapping TxPDO | UINT8 | RO | 0x0A (10dez)
1A0C:01 | SubIndex 001 | reserved | UINT32 | RO | 0x000:00, 15
1A0C:02 | SubIndex 002 | 1. PDO Mapping entry (object 0x606A (DPM Variant Value In), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x606A:10, 1
1A0C:03 | SubIndex 003 | 2. PDO Mapping entry (object 0x606A (DPM Variant Value In), entry 0x11 (Index 1 REAL)) | UINT32 | RO | 0x606A:11, 16
1A0C:04 | SubIndex 004 | 3. PDO Mapping entry (object 0x606A (DPM Variant Value In), entry 0x12 (Value 1 REAL)) | UINT32 | RO | 0x606A:12, 32
1A0C:05 | SubIndex 005 | 4. PDO Mapping entry (object 0x606A (DPM Variant Value In), entry 0x13 (Index 2 REAL)) | UINT32 | RO | 0x606A:13, 16
1A0C:06 | SubIndex 006 | 5. PDO Mapping entry (object 0x606A (DPM Variant Value In), entry 0x14 (Value 2 REAL)) | UINT32 | RO | 0x606A:14, 32
1A0C:07 | SubIndex 007 | 6. PDO Mapping entry (object 0x606A (DPM Variant Value In), entry 0x15 (Index 3 REAL)) | UINT32 | RO | 0x606A:15, 16
1A0C:08 | SubIndex 008 | 7. PDO Mapping entry (object 0x606A (DPM Variant Value In), entry 0x16 (Value 3 REAL)) | UINT32 | RO | 0x606A:16, 32
1A0C:09 | SubIndex 009 | 8. PDO Mapping entry (object 0x606A (DPM Variant Value In), entry 0x17 (Index 4 ULINT)) | UINT32 | RO | 0x606A:17, 16
1A0C:0A | SubIndex 010 | 9. PDO Mapping entry (object 0x606A (DPM Variant Value In), entry 0x18 (Value 4 ULINT)) | UINT32 | RO | 0x606A:18, 64
Index 1A0n TxPDO-Map Channel (for Ch.1 n = 0; Ch.2 n = 1; Ch.3 n = 2; Ch.4 n = 3; Ch.5 n = 4; Ch.6 n = 5)
Index (hex) | Name | Meaning | Data type | Flags | Default
1A0n:0 | TxPDO-Map Channel | PDO Mapping TxPDO | UINT8 | RO | 0x13 (19dec)
1A0n:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (Channel), entry 0x01 (Overcurrent)) | UINT32 | RO | 0x600n:01, 1
1A0n:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (Channel), entry 0x02 (Inaccurate Current)) | UINT32 | RO | 0x600n:02, 1
1A0n:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (Channel), entry 0x03 (Current Guard Warning)) | UINT32 | RO | 0x600n:03, 1
1A0n:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (Channel), entry 0x04 (Current Guard Error)) | UINT32 | RO | 0x600n:04, 1
1A0n:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (Channel), entry 0x05 (Apparent Power Guard Warning)) | UINT32 | RO | 0x600n:05, 1
1A0n:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (Channel), entry 0x06 (Apparent Power Guard Error)) | UINT32 | RO | 0x600n:06, 1
1A0n:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (Channel), entry 0x07 (Active Power Guard Warning)) | UINT32 | RO | 0x600n:07, 1
1A0n:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (Channel), entry 0x08 (Active Power Guard Error)) | UINT32 | RO | 0x600n:08, 1
1A0n:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (Channel), entry 0x09 (Reactive Power Guard Warning)) | UINT32 | RO | 0x600n:09, 1
1A0n:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (Channel), entry 0x0A (Reactive Power Guard Error)) | UINT32 | RO | 0x600n:0A, 1
1A0n:0B | SubIndex 011 | Reserved | UINT32 | RO | 0x0000:00, 1
1A0n:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (Channel), entry 0x0C (DPM Timeout)) | UINT32 | RO | 0x600n:0C, 1
1A0n:0D | SubIndex 013 | Reserved | UINT32 | RO | 0x0000:00, 3
1A0n:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6000 (Channel), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x600n:10, 1
1A0n:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6000 (Channel), entry 0x11 (Current)) | UINT32 | RO | 0x600n:11, 32
1A0n:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6000 (Channel), entry 0x12 (Active Power)) | UINT32 | RO | 0x600n:12, 32
1A0n:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (Channel), entry 0x13 (Apparent Power)) | UINT32 | RO | 0x600n:13, 32
1A0n:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6000 (Channel), entry 0x14 (Reactive Power Fundamental)) | UINT32 | RO | 0x600n:14, 32
1A0n:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6000 (Channel), entry 0x15 (Active Energy)) | UINT32 | RO | 0x600n:15, 32
Index 1C00 Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Length of this object | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RW | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RW | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RW | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RW | 0x04 (4dec)
Index 1C12 RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x02 (1dec)
1C12:01 | SubIndex 001 | 1. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1600 (5632dec)
1C12:02 | SubIndex 002 | 2. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1601 (5633dec)
Index 1C13 TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x07 (7dec)
1C13:01 | SubIndex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | SubIndex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A01 (6657dec)
1C13:03 | SubIndex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A02 (6658dec)
1C13:04 | SubIndex 004 | 4. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A03 (6659dec)
1C13:05 | SubIndex 005 | 5. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A04 (6660dec)
1C13:06 | SubIndex 006 | 6. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A05 (6661dec)
1C13:07 | SubIndex 007 | 7. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A0C (6668dec)
Index 1C32 SM output parameter
Index | Name | Meaning | Data type | Flags | Default
1C32:0 | SM output parameter | Synchronization parameters for the outputs | UINT8 | RO | 0x20 (32dec)
1C32:01 | Sync mode | Current synchronization mode: 0: Free Run 1: Synchron with SM 2 Event 2: DC-Mode - Synchron with SYNC0 Event 3: DC-Mode - Synchron with SYNC1 Event | UINT16 | RW | 0x0000 (0dec)
1C32:02 | Cycle time | Cycle time (in ns): Free Run: Cycle time of the local timer Synchron with SM 2 Event: Master cycle time DC mode: SYNC0/SYNC1 Cycle Time | UINT32 | RW | 0x0016E360 (1500000dec)
1C32:03 | Shift time | Time between SYNC0 event and output of the outputs (in ns, DC mode only) | UINT32 | RO | 0x00000384 (900dec)
1C32:04 | Sync modes supported | Supported synchronization modes: Bit 0 = 1: free run is supported Bit 1 = 1: synchronous with SM 2 event is supported Bit 2-3 = 01: DC mode is supported Bit 4-5 = 10: Output shift with SYNC1 event (only DC mode) Bit 14 = 1: dynamic times (measurement through writing of 1C32:08) | UINT16 | RO | 0x0805 (2053dec)
1C32:05 | Minimum cycle time | Minimum cycle time (in ns) | UINT32 | RO | 0x0007A120 (500000dec)
1C32:06 | Calc and copy time | Minimum time between SYNC0 and SYNC1 event (in ns, DC mode only) | UINT32 | RO | 0x00000384 (900dec)
1C32:07 | Minimum delay time |  | UINT32 | RO | 0x00000384 (900dec)
1C32:08 | Command | 0: Measurement of the local cycle time is stopped 1: Measurement of the local cycle time is started The entries 1C32:03, 1C32:05, 1C32:06, 1C32:09, 1C33:03, 1C33:06, 1C33:09 are updated with the maximum measured values. For a subsequent measurement the measured values are reset | UINT16 | RW | 0x0000 (0dec)
1C32:09 | Maximum delay time | Time between SYNC1 event and output of the outputs (in ns, DC mode only) | UINT32 | RO | 0x00000384 (900dec)
1C32:0B | SM event missed counter | Number of missed SM events in OPERATIONAL (DC mode only) | UINT16 | RO | 0x0000 (0dec)
1C32:0C | Cycle exceeded counter | Number of occasions the cycle time was exceeded in OPERATIONAL (cycle was not completed in time or the next cycle began too early) | UINT16 | RO | 0x0000 (0dec)
1C32:0D | Shift too short counter | Number of occasions that the interval between SYNC0 and SYNC1 event was too short (DC mode only) | UINT16 | RO | 0x0000 (0dec)
Index 1C33 SM input parameter
Index (hex) | Name | Meaning | Data type | Flags | Default
1C33:0 | SM input parameter | Synchronization parameters for the inputs | UINT8 | RO | 0x20 (32dec)
1C33:01 | Sync mode | Current synchronization mode: 0: Free Run 1: Synchron with SM 3 Event (no outputs available) 2: DC - Synchron with SYNC0 Event 3: DC - Synchron with SYNC1 Event 34: Synchron with SM 2 event (outputs available) | UINT16 | RW | 0x0000 (0dec)
1C33:02 | Cycle time | as 1C32:02 | UINT32 | RW | 0x0016E360 (1500000dec)
1C33:03 | Shift time | Time between SYNC0 event and reading of the inputs (in ns, only DC mode) | UINT32 | RO | 0x00000384 (900dec)
1C33:04 | Sync modes supported | Supported synchronization modes: Bit 0: free run is supported Bit 1: Synchron with SM 2 Event is supported (outputs available) Bit 1: Synchron with SM 3 Event is supported (no outputs available) Bit 2-3 = 01: DC mode is supported Bit 4-5 = 01: Input shift through local event (outputs available) Bit 4-5 = 10: Input shift with SYNC1 event (no outputs available) Bit 14 = 1: dynamic times (measurement through writing of 1C32:08 or 1C33:08) | UINT16 | RO | 0x0805 (2053dec)
1C33:05 | Minimum cycle time | as 1C32:05 | UINT32 | RO | 0x0007A120 (500000dec)
1C33:06 | Calc and copy time | Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode) | UINT32 | RO | 0x0007A120 (500000dec)
1C33:07 | Minimum delay time |  | UINT32 | RO | 0x00000384 (900dec)
1C33:08 | Command | as 1C32:08 | UINT16 | RW | 0x0000 (0dec)
1C33:09 | Maximum delay time | Time between SYNC1 event and reading of the inputs (in ns, only DC mode) | UINT32 | RO | 0x00000384 (900dec)
1C33:0B | SM event missed counter | as 1C32:11 | UINT16 | RO | 0x0000 (0dec)
1C33:0C | Cycle exceeded counter | as 1C32:12 | UINT16 | RO | 0x0000 (0dec)
1C33:0D | Shift too short counter | as 1C32:13 | UINT16 | RO | 0x0000 (0dec)
Index F000 Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | Largest subindex of this object | UINT8 | RO | 0x02
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RW | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RW | 0x0007 (7dec)
Index F008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dec)
Code Word
The vendor reserves the authority for the basic calibration of the terminals. The code word is therefore at present reserved.
Index F010 Module List
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list |  | UINT8 | RW | 0x03 (3dec)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x00000155 (341dec)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x00000155 (341dec)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x00000155 (341dec)
Index F081 Download revision
Index (hex) | Name | Meaning | Data type | Flags | Default
F081:0 | Download revision | Max. subindex | UINT8 | RO | 0x01 (1dec)
F010:01 | Revision number | Configured revision of the terminal, (see note) | UINT32 | RW | 0x00000000 (0dec)
Index (hex) | Name | Meaning | Data type | Flags | Default
F083:0 | BTN | Beckhoff Traceability Number | STRING | RO | 00000000


Command object

Commissioning [image] Object description and parameterization [image] EL3446 [image] Command object
Command object
Index FB00 PMX Command
The command object is used for triggering an action in the terminal. The command is started by writing subindex 1 (request). Write access is disabled until the current command is completed.
Index (hex) | Name | Meaning |  | Data type | Flags | Default
FB00:0 | PM Command | Largest subindex of this object |  | UINT8 | RO | 0x03
FB00:01 | Request | Byte 0 - service request data |  | OCTET-STRING [2] | RW | 0x0000 (0dec)
 |  | 4hex | Clear energy
 |  | Byte 1 - channel selection
 |  | 00hex | all channels
 |  | 01hex | Channel 1
 |  | 02hex | Channel 2
 |  | 03hex | Channel 3
FB00:02 | Status | Byte 0 |  | UINT8 | RW | 0x00 (0dec)
 |  | reserved
FB00:03 | Response | Byte 0 |  | OCTET-STRING [2] | RW | 0x00000000 (0dec)
 |  | reserved
 |  | Byte 1
 |  | reserved
 |  | Byte 2-n
 |  | reserved


EL3453

Commissioning [image] Object description and parameterization [image] EL3453
EL3453
Additional information
•
Restore object
•
Configuration data
•
Configuration data (vendor-specific)
•
Input data
•
Output data
•
Information and diagnostic data
•
Standard objects
•
Command object


Restore object

Commissioning [image] Object description and parameterization [image] EL3453 [image] Restore object
Restore object
Index 1011 Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default parameters | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to “0x64616F6C” in the set value dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)


Configuration data

Commissioning [image] Object description and parameterization [image] EL3453 [image] Configuration data
Configuration data
Index 80n0 PMX settings (for ch.1, n = 0; ch.2, n = 1; ch.3, n = 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
80n0:0 | PMX Settings | Max. subindex | UINT8 | RO | 0x15 (21dec)
80n0:11 | Voltage Transformer Ratio | If a voltage transformer is used, its transmission ratio can be entered here. | REAL32 | RW | 0x3F800000 (1065353216dec)
80n0:12 | Current Transformer Ratio | The ratio of the current transformer used can be entered here. | REAL32 | RW | 0x3F800000 (1065353216dec)
80n0:13 | Current Transformer Delay | Here you can enter a possible time delay of the current transformers in milliseconds. | REAL32 | RW | 0x00000000 (0dec)
80n0:14 | Current Range | Selection Current range 100: 100 mA 1000: 1 A 5000: 5 A | UINT32 | RW | 1 A (1000)
80n0:15 | Voltage Source | Selection Voltage Source: 0: Channel 1 1: Channel 2 2: Channel 3 | UINT32 | RW | Channel 1 (0)
Index 80n1 PMX Guard Settings (for ch.1, n = 0; ch.2, n = 1; ch.3, n = 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
80n1:0 | PMX Guard Settings | Max. subindex | UINT8 | RO | 0x14 (20dec)
80n1:11 | Voltage Guard Min Error | Lower limit value for a voltage error message | REAL32 | RW | 0x40000000 (1073741824dec)
80n1:12 | Voltage Guard Min Warning | Lower limit value for a voltage warning message | REAL32 | RW | 0x434F0000 (1129250816dec)
80n1:13 | Voltage Guard Max Warning | Upper limit value for a voltage warning message | REAL32 | RW | 0x437D0000 (1132265472dec)
80n1:14 | Voltage Guard Max Error | Upper limit value for a voltage error message | REAL32 | RW | 0x438B0000 (1133182976dec)
80n1:15 | Current Guard Min Error | Lower limit value for a current error message | REAL32 | RW | 0xBF866666 (-1081711002dec)
80n1:16 | Current Guard Min Warning | Lower limit value for a current warning message | REAL32 | RW | 0xBF800000 (-1082130432dec)
80n1:17 | Current Guard Max Warning | Upper limit value for a current warning message | REAL32 | RW | 0x3F800000 (1065353216dec)
80n1:18 | Current Guard Max Error | Upper limit value for a current error message | REAL32 | RW | 0x3F866666 (1065772646dec)
Index 80n2 PMX User Scale (for ch.1, n = 0; ch.2, n = 1; ch.3, n = 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
80n2:0 | PMX User Scale Ch.1 | Max. subindex | UINT8 | RO | 0x15 (21dec)
80n2:01 | User Calibration Enable | Set to true to enable user calibration data. | BOOLEAN | RW | 0x00 (0dec)
80n2:11 | User Calibration Voltage Offset | Value in V | REAL32 | RW | 0x00000000 (0dec)
80n2:12 | User Calibration Voltage Gain | Factor (without unit) | REAL32 | RW | 0x3F800000 (1065353216dec)
80n2:13 | User Calibration Current Offset | Value in A | REAL32 | RW | 0x00000000 (0dec)
80n2:14 | User Calibration Current Gain | Factor (without unit) | REAL32 | RW | 0x3F800000 (1065353216dec)
80n2:15 | User Calibration Phase Offset | Value in milliseconds | REAL32 | RW | 0x00000000 (0dec)
Index F800 PMX Settings
Index (hex) | Name | Meaning |  | Data type | Flags | Default
F800:0 | PMX Settings | Max. subindex |  | UINT8 | RO | 0x17 (23dec)
F800:01 | Reset Interval | Manual restart of the measurement and statistics interval |  | BOOLEAN | RW | 0x00 (0dec)
F800:02 | Enable Static Fund Frequency | Fixation of the fundamental frequency for harmonic calculation |  | BOOLEAN | RW | 0x00 (0dez)
F800:11 | Reference | Timing reference for the RMS calculation Set to "Current" if a current is to be measured without an applied voltage. permitted values: |  | UINT32 | RW | 0x00000000 (0dec)
 |  | 0 | Voltage (default)
 |  | 1 | Current
F800:12 | Measurement Range | Filter setting for determining the fundamental permitted values: |  | UINT32 | RW | 0x00000000 (0dec)
 |  | 0 | 25..65 Hz (default)
 |  | 1 | 25..400 Hz
 |  | 2 | 12..45 Hz
F800:13 | Frequency Source | Source of the system frequency permitted values: |  | BIT1 | RW | 0x00000000 (0dec)
 |  | 0 | Channel 1 (default)
 |  | 1 | Channel 2
 |  | 2 | Channel 3
F800:14 | Power Calculation Threshold | Noise reduction: Here you can enter a minimum limit value in percent for the power calculation, below which all values are zeroed. |  | REAL32 | RW | 0x3F800000 (1065353216dec)
F800:15 | Inaccurate Threshold Voltage | Limit value for the warning bit: Inaccurate Voltage |  | REAL32 | RW | 0x3FDC28F6 (1071393014dec)
F800:16 | Inaccurate Threshold Current | Limit value for the warning bit: Inaccurate Current |  | REAL32 | RW | 0x3BC49BA6 (1002740646dec)
F800:17 | Filter Length | Filter length of the RMS value calculation: 0: Disable 1: 2 Samples 2: 3 Samples 3: 4 Samples 4: 5 Samples 5: 6 Samples |  | UINT32 | RW | Disable (0)
Index F801 PMX Total Settings PQF
Index (hex) | Name | Meaning | Data type | Flags | Default
F801:0 | PMX Total Settings PQF | Max. subindex | UINT8 | RO | 0x13 (19dec)
F801:11 | Nominal voltage | A nominal voltage value or set value is required to calculate the power quality factor (for details see basic function principles). | REAL32 | RW | 0x43660000 (1130758144dec)
F801:12 | Nominal Frequency | A nominal frequency or set value is required to calculate the power quality factor (for details see basic function principles). | REAL32 | RW | 0x42480000 (1112014848dec)
F801:13 | PQF Dataset | permitted values: | UINT32 | RW | 0x00000001 (0dec)
 |  | 0: default 1: default + unbalace
Index F802 PMX Guard Settings
Index (hex) | Name | Meaning | Data type | Flags | Default
F802:0 | PMX Guard Settings | Max. subindex | UINT8 | RO | 0x28 (40dec)
F802:11 | Frequency Guard Min Error | Lower limit value for a frequency error message | REAL32 | RW | 47,000000 (4,700000e+001)
F802:12 | Frequency Guard Min Warning | Lower limit value for a frequency warning message | REAL32 | RW | 49,500000 (4,950000e+001)
F802:13 | Frequency Guard Max Warning | Upper limit value for a frequency warning message | REAL32 | RW | 50,500000 (5,050000e+001)
F802:14 | Frequency Guard Max Error | Upper limit value for a frequency error message | REAL32 | RW | 52,000000 (5,200000e+001)
F802:15 | Neutral Current Guard Min Error | Lower limit value for an error message of the neutral conductor current | REAL32 | RW | EL3423, EL3443 0,000000 (0,000000e+000) EL3453 -1,050000 (-1,050000e+000)
F802:16 | Neutral Current Guard Min Warning | Lower limit value for a warning message of the neutral conductor current | REAL32 | RW | EL3423, EL3443 0,000000 (0,000000e+000) EL3453 -1,000000 (-1,000000e+000)
F802:17 | Neutral Current Guard Max Warning | Upper limit value for a warning message of the neutral conductor current | REAL32 | RW | EL3423, EL3443 0,006000 (6,000000e-003) EL3453 1,000000 (1,000000e+000)
F802:18 | Neutral Current Guard Max Error | Upper limit value for an error message of the neutral conductor current | REAL32 | RW | EL3423, EL3443 0,030000 (3,000000e-002) EL3453 1,050000 (1,050000e+000)
F802:19 | Active Power Guard Min Error | Lower limit value for an active power error message | REAL32 | RW | 0,000000 (0,000000e+000)
F802:1A | Active Power Guard Min Warning | Lower limit value for an active power warning message | REAL32 | RW | 0,000000 (0,000000e+000)
F802:1B | Active Power Guard Max Warning | Upper limit value for an active power warning message | REAL32 | RW | 0,000000 (0,000000e+000)
F802:1C | Active Power Guard Max Error | Upper limit value for an active power error message | REAL32 | RW | 0,000000 (0,000000e+000)
F802:1D | Apparent Power Guard Min Error | Lower limit value for an apparent power error message | REAL32 | RW | 0,000000 (0,000000e+000)
F802:1E | Apparent Power Guard Min Warning | Lower limit value for an apparent power warning message | REAL32 | RW | 0,000000 (0,000000e+000)
F802:1F | Apparent Power Guard Max Warning | Upper limit value for an apparent power warning message | REAL32 | RW | 0,000000 (0,000000e+000)
F802:20 | Apparent Power Guard Max Error | Upper limit value for an apparent power error message | REAL32 | RW | 0,000000 (0,000000e+000)
F802:21 | PQF Guard Min Error | Lower limit value for a power quality factor error message | REAL32 | RW | 0,050000 (5,000000e-002)
F802:22 | PQF Guard Min Warning | Lower limit value for a power quality factor warning message | REAL32 | RW | 0,800000 (8,000000e-001)
F802:23 | PQF Guard Max Warning | Upper limit value for a power quality factor warning message | REAL32 | RW | 1,000000 (1,000000e+000)
F802:24 | PQF Guard Max Error | Upper limit value for a power quality factor error message | REAL32 | RW | 1,000000 (1,000000e+000)
F802:25 | Unbalance Guard Min Error | Lower limit value for an error message due to voltage imbalance | REAL32 | RW | 0,000000 (0,000000e+000)
F802:26 | Unbalance Guard Min Warning | Lower limit value for a warning message due to voltage imbalance | REAL32 | RW | 0,000000 (0,000000e+000)
F802:27 | Unbalance Guard Max Warning | Upper limit value for a warning message due to voltage imbalance | REAL32 | RW | EL3423, EL3453 0,000000 (0,000000e+000) EL3443 2,000000 (2,000000e+000)
F802:28 | Unbalance Guard Max Error | Upper limit value for an error message due to voltage imbalance | REAL32 | RW | EL3423, EL3453 0,000000 (0,000000e+000) EL3443 3,000000 (3,000000e+000)
Index F803 PMX Time Settings
Index (hex) | Name | Meaning | Data type | Flags | Default
F803:0 | PMX Time Settings | Max. subindex | UINT8 | RO | 0x13 (19dec)
F803:11 | Measurement Mode | permitted values: | UINT32 | RW | 0x00000000 (0dec)
 |  | 0
F803:12 | Measurement Interval | Time in seconds to automatic restart of the measurement and statistics interval | UINT32 | RW | 0x00000000 (0dec)
F803:13 | Actual System Time | Shows the current system time of the terminal. Write access to the object is possible in order to change the system time. | STRING | RW |
Index F804 PMX Settings Neutral Current
Index (hex) | Name | Meaning | Data type | Flags | Default
F804:0 | PMX Settings Neutral Current | Max. subindex | UINT8 | RO | 0x14 (20dec)
F804:12 | Current Transformer Ratio | The transmission ratio of the current transformer used can be entered here. | REAL32 | RW | 1,000000 (1,000000e+000)
F804:13 | Current Transformer Delay | A possible time delay of the current transformers in milliseconds can be entered here. | REAL32 | RW | 0,000000 (0,000000e+000)
F804:14 | Current Range | Selection of the current measuring range: 100: 100 mA 1000: 1 A 5000: 5 A | UINT32 | RW | 1 A (1000)
Index F804 PMX Settings Neutral Current
Index (hex) | Name | Meaning | Data type | Flags | Default
F804:0 | PMX Settings Neutral Current | Max. subindex | UINT8 | RO | 0x14 (20dec)
F804:12 | Measurement Mode | permitted values: | UINT32 | RW | 0x00000000 (0dec)
 |  | 0
F804:13 | Measurement Interval | Time in seconds to automatic restart of the measurement and statistics interval | UINT32 | RW | 0x00000000 (0dec)
F804:14 | Actual System Time | Shows the current system time of the terminal. Write access to the object is possible in order to change the system time. | STRING | RW |


Configuration data (vendor-specific)

Commissioning [image] Object description and parameterization [image] EL3453 [image] Configuration data (vendor-specific)
Configuration data (vendor-specific)
Index 80nF PMX vendor data (for ch.1, n = 0; ch.2, n = 1; ch.3, n = 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
80nF:0 | PMX Vendor data | Max. subindex | UINT8 | RO | 0x1C (28dez)
80nF:11 | Calibration Voltage Offset | Value in V | REAL32 | RW | 0,000000 (0,000000e+000)
80nF:12 | Calibration Voltage Gain | Factor (without unit) | REAL32 | RW | 1,000000 (1,000000e+000)
80nF:13 | Calibration Voltage Phase Offset | Value in milliseconds | REAL32 | RW | 0,000000 (0,000000e+000)
80nF:14 | Calibration Current Offset | Value in A | REAL32 | RW | 0,000000 (0,000000e+000)
80nF:15 | Calibration Current Gain | Factor (without unit) | REAL32 | RW | 1,000000 (1,000000e+000)
80nF:16 | Calibration Current Phase Offset | Value in milliseconds | REAL32 | RW | 0,000000 (0,000000e+000)
80nF:17 | Calibration Current 1 Offset | Value in A | REAL32 | RW | 0,000000 (0,000000e+000)
80nF:18 | Calibration Current 1 Gain | Factor (without unit) | REAL32 | RW | 1,000000 (1,000000e+000)
80nF:19 | Calibration Current 1 Phase Offset | Value in milliseconds | REAL32 | RW | 0,000000 (0,000000e+000)
80nF:1A | Calibration Current 2 Offset | Value in A | REAL32 | RW | 0,000000 (0,000000e+000)
80nF:1B | Calibration Current 2 Gain | Factor (without unit) | REAL32 | RW | 1,000000 (1,000000e+000)
80nF:1C | Calibration Current 2 Phase Offset | Value in milliseconds | REAL32 | RW | 0,000000 (0,000000e+000)


Input data

Commissioning [image] Object description and parameterization [image] EL3453 [image] Input data
Input data
Index 60n0 PMX status (n = 0, 1, 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
60n0:0 | PMX Status | Max. subindex | UINT8 | RO | 0x10 (16dec)
60n0:01 | Voltage Sign Bit | Indicates the sign of the current sine wave voltage: 1 = U > 0V 0 = U < 0V | BOOLEAN | RO | 0x00 (0dec)
60n0:02 | Overvoltage | Maximum measurable voltage is exceeded. | BOOLEAN | RO | 0x00 (0dec)
60n0:03 | Overcurrent | Maximum measurable current is exceeded. | BOOLEAN | RO | 0x00 (0dec)
60n0:04 | Inaccurate Voltage | The measured voltage value is smaller than the value entered in CoE object "F800:15 Inaccurate Threshold Voltage". | BOOLEAN | RO | 0x00 (0dec)
60n0:05 | Inaccurate Current | The measured current value is smaller than the value entered in CoE object "F800:16 Inaccurate Threshold Current". | BOOLEAN | RO | 0x00 (0dec)
60n0:06 | Voltage Guard Warning | A warning limit of the voltage monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
60n0:07 | Voltage Guard Error | An error limit of the voltage monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
6000:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
Index 60n1 PMX Basic (n = 0, 1, 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
60n1:0 | PMX Basic | Max. Subindex | UINT8 | RO | 0x12 (18dec)
60n1:11 | Voltage | RMS value of the voltage in V | REAL32 | RO | 0x00000000 (0dec)
60n1:12 | Current | RMS value of the current in A | REAL32 | RO | 0x00000000 (0dec)
Index 60n2 PMX Power (n = 0, 1, 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
60n2:0 | PMX Power | Max Subindex | UINT8 | RO | 0x14 (20dec)
60n2:11 | Active power | Active power in W | REAL32 | RO | 0x00000000 (0dec)
60n2:12 | Apparent Power | Apparent power in VA | REAL32 | RO | 0x00000000 (0dec)
60n2:13 | Reactive Power | Reactive power in var | REAL32 | RO | 0x00000000 (0dec)
60n2:14 | Power Factor | Power factor | REAL32 | RO | 0x00000000 (0dec)
Index 60n3 PMX Power Fundamental (n = 0, 1, 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
60n3:0 | PMX Power Fundamental | Max. subindex | UINT8 | RO | 0x14 (20dec)
60n3:11 | Active power Fund | Active power in W | REAL32 | RO | 0x00000000 (0dec)
60n3:12 | Apparent Power Fund | Apparent power in VA | REAL32 | RO | 0x00000000 (0dec)
60n3:13 | Reactive Power Fund | Reactive power in var | REAL32 | RO | 0x00000000 (0dec)
Index 60n4 PMX Energy (n = 0, 1, 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
60n4:0 | PMX Energy | Max. subindex | UINT8 | RO | 0x13 (19dec)
60n4:11 | Active Energy | Active energy in mWh | INT64 | RO |
60n4:12 | Apparent Energy | Apparent energy in mVAh | INT64 | RO |
60n4:13 | Reactive Energy | Reactive energy in mvarh | INT64 | RO |
Index 60n5 PMX Energy (n = 0, 1, 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
60n5:0 | PMX Energy Fundamental | Max. subindex | UINT8 | RO | 0x13 (19dec)
60n5:11 | Active Energy Fund | Active energy fundamental in mWh | INT64 | RO |
60n5:12 | Apparent Energy Fund | Apparent energy fundamental in mVAh | INT64 | RO |
60n5:13 | Reactive Energy Fund | Reactive energy fundamental in mvarh | INT64 | RO |
Index 60n6 PMX Timing (n = 0, 1, 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
60n6:0 | PMX Timing | Max Subindex | UINT8 | RO | 0x12 (18dec)
60n6:12 | Voltage Last Zero Crossing | Last detected voltage zero crossing as distributed clock time | UINT64 | RO |
60n6:12 | Current Last Zero Crossing | Last detected current zero crossing as distributed clock time | UINT64 | RO |
Index 60n7 PMX Advanced (n = 0, 1, 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
60n7:0 | PMX Advanced | Max Subindex | UINT8 | RO | 0x14 (20dec)
60n7:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
60n7:11 | Voltage Total Harmonic Distortion | "Total Harmonic Distortion" is the distortion factor of the voltage. It indicates the ratio of the harmonic components of an oscillation relative to its fundamental in %. | REAL32 | RO | 0x00000000 (0dec)
60n7:12 | Current Distortion Factor | The "Current Distortion Factor" is also referred to as TDD (Total Demand Distortion). It indicates the ratio between the current harmonics and the maximum current (EL3443: 1A and EL3443-0010: 5A). Specified in % of the maximum current. | REAL32 | RO | 0x00000000 (0dec)
60n7:13 | Current Total Harmonic Distortion | "Total Harmonic Distortion" is the distortion factor of the current. It indicates the ratio of the harmonic components of an oscillation relative to its fundamental in %. | REAL32 | RO | 0x00000000 (0dec)
60n7:14 | Cos phi | Phase angle of the fundamental wave in degrees | REAL32 | RO | 0x00000000 (0dec)
Index 60n8 PMX Statistic Voltage (n = 0, 1, 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
60n8:0 | PMX Statistic Voltage | Max Subindex | UINT8 | RO | 0x13 (19dec)
60n8:11 | Voltage Peak | Peak value of the instantaneous voltage in the last interval in V | REAL32 | RO | 0x00000000 (0dec)
60n8:12 | Voltage RMS Minimum | Minimum RMS value of the voltage in the last interval in V | REAL32 | RO | 0x00000000 (0dec)
60n8:13 | Voltage RMS Maximum | Maximum RMS value of the voltage in the last interval in V | REAL32 | RO | 0x00000000 (0dec)
Index 60n9 PMX Statistic Current (n = 0, 1, 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
60n9:0 | PMX Statistic Current | Max Subindex | UINT8 | RO | 0x13 (19dec)
60n9:11 | Current Peak | Peak value of the instantaneous current in the last interval in A | REAL32 | RO | 0x00000000 (0dec)
60n9:12 | Current RMS Minimum | Minimum RMS value of the current in the last interval in A | REAL32 | RO | 0x00000000 (0dec)
60n9:13 | Current RMS Maximum | Maximum RMS value of the current in the last interval in A | REAL32 | RO | 0x00000000 (0dec)
Index 60nA PMX Statistic Power (n = 0, 1, 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
60nA:0 | PMX Statistic Power | Max Subindex | UINT8 | RO | 0x19 (25dec)
60nA:11 | Active Power Avg | Average active power during the last interval in W | REAL32 | RO | 0x00000000 (0dec)
60nA:12 | Active Power Min | Minimum active power in the last interval in W | REAL32 | RO | 0x00000000 (0dec)
60nA:13 | Active Power Max | Maximum active power in the last interval in W | REAL32 | RO | 0x00000000 (0dec)
60nA:14 | Apparent Power Avg | Average apparent power during the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
60nA:15 | Apparent Power Max | Maximum apparent power in the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
60nA:16 | Reactive Power Avg | Average reactive power average during the last interval in var | REAL32 | RO | 0x00000000 (0dec)
60nA:17 | Reactive Power Min | Minimum reactive power in the last interval in var | REAL32 | RO | 0x00000000 (0dec)
60nA:18 | Reactive Power Max | Maximum reactive power in the last interval in var | REAL32 | RO | 0x00000000 (0dec)
60nA:19 | Apparent Power Min | Minimum apparent power in the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
Index 60nB PMX Classic (n = 0, 1, 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
600B:0 | PMX Classic | Max. subindex | UINT8 | RO | 0x16 (22dec)
600B:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
600B:11 | Voltage | RMS value of the voltage in 0.001 V | INT32 | RO | 0x00000000 (0dec)
600B:12 | Current | RMS value of the current in 0.0001 A | INT32 | RO | 0x00000000 (0dec)
600B:13 | Frequency | Frequency of the fundamental in 0.001 Hz | INT32 | RO | 0x00000000 (0dec)
600B:14 | Active Power | Active power in 0.001 W | INT32 | RO | 0x00000000 (0dec)
600B:15 | Apparent Power | Apparent power in 0.001 VA | INT32 | RO | 0x00000000 (0dec)
600B:16 | Reactive Power | Reactive power in 0.001 var | INT32 | RO | 0x00000000 (0dec)
Index F600 PMX Total Status
Index (hex) | Name | Meaning | Data type | Flags | Default
F600:0 | PMX Total Status | Max. subindex | UINT8 | RO | 0x11 (17dec)
F600:01 | System State | Overall system state (as a logical disjunction of voltage guard errors, phase sequence, overvoltage, overcurrent and frequency guard errors) | BOOLEAN | RO | 0x00 (0dec)
F600:02 | Grid Direction | Phase sequence L1 - L2 - L3 correctly detected (with clockwise 3-phase mains) | BOOLEAN | RO | 0x00 (0dec)
F600:03 | Frequency Guard Warning | A warning limit of the frequency monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:04 | Frequency Guard Error | An error limit of the frequency monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:05 | Neutral Current Guard Warning | A warning limit of the neutral conductor current monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:06 | Neutral Current Guard Error | An error limit of the neutral conductor current monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:07 | Active Power Guard Warning | A warning limit of the active power monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:08 | Active Power Guard Error | An error limit of the active power monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:09 | Apparent Power Guard Warning | A warning limit of the apparent power monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:0A | Apparent Power Guard Error | An error limit of the apparent power monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:0B | Power Quality Guard Warning | A warning limit of the PQF monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:0C | Power Quality Guard Error | An error limit of the PQF monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:0F | TxPDO State | TRUE for general error | BOOLEAN | RO | 0x00 (0dec)
F600:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
F600:11 | Power Quality Factor | Analog value of the voltage quality between 1.0 and 0 (see basic function principles - Power Quality Factor) | REAL32 | RO | 0x00000000 (0dec)
Index F601 PMX Total Basic
Index (hex) | Name | Meaning | Data type | Flags | Default
F601:0 | PMX Total Basic | Max. subindex | UINT8 | RO | 0x13 (19dec)
F601:11 | Frequency | Frequency in Hz | REAL32 | RO | 0x00000000 (0dec)
F601:12 | Power Factor | Power factor | REAL32 | RO | 0x00000000 (0dec)
F601:14 | Calculated Error Current | Calculated residual current (I_L1 + I_L2 + I_L3 + I_N + I_Err = 0) in A | REAL32 | RO | 0x00000000 (0dec)
F601:15 | Neutral line Current | Measured RMS value of neutral current in A | REAL32 | RO | 0x00000000 (0dec)
F601:16 | ROCOF | Rate of change of frequency (ROCOF or df/dt) in Hz/s | REAL32 | RO | 0x00000000 (0dec)
Index F602 PMX Total Advanced
Index (hex) | Name | Meaning | Data type | Flags | Default
F602:0 | PMX Total Advanced | Max. subindex | UINT8 | RO | 0x14 (20dec)
F602:01 | Unbalance Guard Warning | A warning limit of the unbalance monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F602:02 | Unbalance Guard Error | An error limit of the unbalance monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F602:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
F602:11 | Max Voltage Harmonic Distortion | Maximum distortion factor of all three phase voltages in %. | REAL32 | RO | 0x00000000 (0dec)
F602:12 | Max Current Harmonic Distortion | Maximum distortion factor of all three phase currents in % | REAL32 | RO | 0x00000000 (0dec)
F602:13 | Max Current Distortion Factor | Maximum "Total Demand Distortion" value of all three phases in % | REAL32 | RO | 0x00000000 (0dec)
F602:14 | Voltage Unbalance | Ratio between negative and positive voltage system in % | REAL32 | RO | 0x00000000 (0dec)
Index F603 PMX Total Active
Index (hex) | Name | Meaning | Data type | Flags | Default
F603:0 | PMX Total Active | Max. subindex | UINT8 | RO | 0x14 (20dec)
F603:11 | Active Power | Active power in W | INT64 | RO |
F603:12 | Active Energy | Recorded active energy in mWh | INT64 | RO |
F603:13 | Active Positive Energy | Received active energy in mWh | INT64 | RO |
F603:14 | Active Negative Energy | Supplied active energy in mWh | INT64 | RO |
Index F604 PMX Total Active Fundamental
Index (hex) | Name | Meaning | Data type | Flags | Default
F604:0 | PMX Total Active Fundamental | Max. subindex | UINT8 | RO | 0x14 (20dec)
F604:11 | Active Power Fund | Active power of the fundamental oscillation in W | INT64 | RO |
F604:12 | Active Energy Fund | Balanced active energy fundamental oscillation in mWh | INT64 | RO |
F604:13 | Active Positive Energy Fund | Related active energy of the fundamental oscillation in mWh | INT64 | RO |
F604:14 | Active Negative Energy Fund | Active energy fed into the system of the fundamental oscillation in mWh | INT64 | RO |
Index F605 PMX Total Apparent
Index (hex) | Name | Meaning | Data type | Flags | Default
F605:0 | PMX Total Apparent | Max. subindex | UINT8 | RO | 0x14 (20dec)
F605:11 | Apparent Power | Balanced apparent power in VA | INT64 | RO |
F605:12 | Apparent Energy | Recorded apparent energy in mWh | INT64 | RO |
F605:13 | Apparent Positive Energy | Received apparent energy in mWh | UINT64 | RO |
F605:14 | Apparent Negative Energy | Supplied apparent energy in mWh | UINT64 | RO |
Index F606 PMX Total Apparent Fundamental
Index (hex) | Name | Meaning | Data type | Flags | Default
F606:0 | PMX Total Apparent Fundamental | Max. subindex | UINT8 | RO | 0x14 (20dec)
F606:11 | Apparent Power Fund | Apparent power fundamental in VA | INT64 | RO |
F606:12 | Apparent Energy | Recorded apparent energy in mWh | INT64 | RO |
F606:13 | Apparent Positive Energy | Received apparent energy in mWh | UINT64 | RO |
F606:14 | Apparent Negative Energy | Supplied apparent energy in mWh | UINT64 | RO |
Index F607 PMX Total Reactive
Index (hex) | Name | Meaning | Data type | Flags | Default
F607:0 | PMX Total Reactive | Max. subindex | UINT8 | RO | 0x14 (20dec)
F607:11 | Reactive Power | Balanced reactive power in Var | INT64 | RO |
F607:12 | Reactive Energy | Recorded reactive energy in mWh | INT64 | RO |
F607:13 | Reactive Positive Energy | Received reactive energy in mWh | UINT64 | RO |
F607:14 | Reactive Negative Energy | Supplied reactive energy in mWh | UINT64 | RO |
Index F608 PMX Total Reactive Fundamental
Index (hex) | Name | Meaning | Data type | Flags | Default
F608:0 | PMX Total Reactive Fundamental | Max. subindex | UINT8 | RO | 0x14 (20dec)
F608:11 | Reactive Power Fund | Balanced reactive power of the fundamental oscillation in Var | INT64 | RO |
F608:12 | Reactive Energy | Recorded reactive energy in mWh | INT64 | RO |
F608:13 | Reactive Positive Energy | Received reactive energy in mWh | UINT64 | RO |
F608:14 | Reactive Negative Energy | Supplied reactive energy in mWh | UINT64 | RO |
Index F609 PMX Total L-L Voltages
Index (hex) | Name | Meaning | Data type | Flags | Default
F609:0 | PMX Total L-L Voltages | Max. subindex | UINT8 | RO | 0x13 (19dec)
F609:11 | L1-L2 Voltage | RMS value of the phase-to-phase voltage between L1 and L2 in V | REAL32 | RO | 0x00000000 (0dec)
F609:12 | L2-L3 Voltage | RMS value of the phase-to-phase voltage between L2 and L3 in V | REAL32 | RO | 0x00000000 (0dec)
F609:13 | L3-L1 Voltage | RMS value of the phase-to-phase voltage between L3 and L1 in V | REAL32 | RO | 0x00000000 (0dec)
Index F60A PMX Variant Value In
Index (hex) | Name | Meaning | Data type | Flags | Default
F60A:0 | PMX Variant Value In | Max. subindex | UINT8 | RO | 0x18 (24dec)
F60A:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
F60A:11 | Index 1 REAL | Acknowledge for variable output value 1 | UINT16 | RO | 0x0000 (0dec)
F60A:12 | Value 1 REAL | variable output value channel 1 | REAL32 | RO | 0x00000000 (0dec)
F60A:13 | Index 2 REAL | Acknowledge for variable output value 2 | UINT16 | RO | 0x0000 (0dec)
F60A:14 | Value 2 REAL | variable output value channel 2 | REAL32 | RO | 0x00000000 (0dec)
F60A:15 | Index 3 REAL | Acknowledge for variable output value 3 | UINT16 | RO | 0x0000 (0dec)
F60A:16 | Value 3 REAL | variable output value channel 3 | REAL32 | RO | 0x00000000 (0dec)
F60A:17 | Index 4 ULINT | Acknowledge for variable output value 4 | UINT16 | RO | 0x0000 (0dec)
F60A:18 | Value 4 ULINT | variable output value channel 4 | UINT64 | RO |
Index F60B PMX Total Statistic Power
Index (hex) | Name | Meaning | Data type | Flags | Default
F60B:0 | PMX Total Statistic Power | Max. subindex | UINT8 | RO | 0x19 (25dec)
F60B:11 | Active Power Avg | Average total active power during the last interval in W | REAL32 | RO | 0x00000000 (0dec)
F60B:12 | Active Power Min | Minimum total active power in the last interval in W | REAL32 | RO | 0x00000000 (0dec)
F60B:13 | Active Power Max | Maximum total active power in the last interval in W | REAL32 | RO | 0x00000000 (0dec)
F60B:14 | Apparent Power Avg | Average total apparent power during the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
F60B:15 | Apparent Power Min | Minimum total apparent power in the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
F60B:16 | Apparent Power Max | Maximum total apparent power in the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
F60B:17 | Reactive Power Avg | Average total reactive power average during the last interval in Var | REAL32 | RO | 0x00000000 (0dec)
F60B:18 | Reactive Power Min | Minimum total reactive power in the last interval in Var | REAL32 | RO | 0x00000000 (0dec)
F60B:19 | Reactive Power Max | Maximum total reactive power in the last interval in Var | REAL32 | RO | 0x00000000 (0dec)
Index F60C PMX Total Statistic PQF
Index (hex) | Name | Meaning | Data type | Flags | Default
F60C:0 | PMX Total Statistic PQF | Max. subindex | UINT8 | RO | 0x13 (19dec)
F60C:11 | PQF Avg | Average value of the power quality factor during the last interval | REAL32 | RO | 0x00000000 (0dec)
F60C:12 | PQF Min | Minimum power quality factor in the last interval | REAL32 | RO | 0x00000000 (0dec)
F60C:13 | PQF Max | Maximum power quality factor in the last interval | REAL32 | RO | 0x00000000 (0dec)
Index F60D PMX Total Interval Energy
Index (hex) | Name | Meaning | Data type | Flags | Default
F60D:0 | PMX Total Interval Energy | Max. subindex | UINT8 | RO | 0x19 (25dec)
F60D:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
F60D:11 | Active Energy | Recorded total active energy during the last interval in mWh | REAL32 | RO | 0x00000000 (0dec)
F60D:12 | Active Energy Positive | Received total active energy during the last interval in mWh | REAL32 | RO | 0x00000000 (0dec)
F60D:13 | Active Energy Negative | Supplied total active energy during at last interval in mWh | REAL32 | RO | 0x00000000 (0dec)
F60D:14 | Apparent Energy | Recorded total apparent energy during the last interval in mWh | REAL32 | RO | 0x00000000 (0dec)
F60D:15 | Apparent Energy Positive | Received total apparent energy during the last interval in mWh | REAL32 | RO | 0x00000000 (0dec)
F60D:16 | Apparent Energy Negative | Supplied total apparent energy during the last interval in mWh | REAL32 | RO | 0x00000000 (0dec)
F60D:17 | Reactive Energy | Recorded total reactive energy during the last interval in mWh | REAL32 | RO | 0x00000000 (0dec)
F60D:18 | Reactive Energy Positive | Received total reactive energy during the last interval in mWh | REAL32 | RO | 0x00000000 (0dec)
F60D:19 | Reactive Energy Negative | Supplied total reactive energy during the last interval in mWh | REAL32 | RO | 0x00000000 (0dec)
Index F60E PMX Total Interval Energy Fundamental
Index (hex) | Name | Meaning | Data type | Flags | Default
F60E:0 | PMX Total Interval Energy Fundamental | Max. subindex | UINT8 | RO | 0x19 (25dec)
F60E:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
F60E:11 | Active Energy Fund | Balanced total effective energy of the fundamental in the last interval in Wh | REAL32 | RO | 0x00000000 (0dec)
F60E:12 | Active Energy Positive Fund | Total active energy related of the fundamental in the last interval in Wh | REAL32 | RO | 0x00000000 (0dec)
F60E:13 | Active Energy Negative Fund | Total active energy of the fundamental in the last interval fed in Wh | REAL32 | RO | 0x00000000 (0dec)
F60E:14 | Apparent Energy Fund | Balanced total apparent energy of the fundamental in the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
F60E:15 | Apparent Energy Positive Fund | Total apparent energy related of the fundamental in the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
F60E:16 | Apparent Energy Negative Fund | Total apparent energy of the fundamental in the last interval fed in VA | REAL32 | RO | 0x00000000 (0dec)
F60E:17 | Reactive Energy Fund | Balanced total reactive energy of the fundamental in the last interval in var | REAL32 | RO | 0x00000000 (0dec)
F60E:18 | Reactive Energy Positive Fund | Total reactive energy related of the fundamental in the last interval in var | REAL32 | RO | 0x00000000 (0dec)
F60E:19 | Reactive Energy Negative Fund | Total reactive energy of the fundamental in the last interval fed in var | REAL32 | RO | 0x00000000 (0dec)
Index F60F PMX Total System Angles
Index (hex) | Name | Meaning | Data type | Flags | Default
F60F:0 | PMX Total System Angles | Max. subindex | UINT8 | RO | 0x15 (21dec)
F60F:11 | Voltage Angle L1 L2 | Angle between the phase voltages of L1 and L2 | REAL32 | RO | 0x00000000 (0dec)
F60F:12 | Voltage Angle L1 L3 | Angle between the phase voltages of L1 and L3 | REAL32 | RO | 0x00000000 (0dec)
F60F:13 | Current Angle L1 | Phase angle of the current of L1 | REAL32 | RO | 0x00000000 (0dec)
F60F:14 | Current Angle L2 | Phase angle of the current of L2 | REAL32 | RO | 0x00000000 (0dec)
F60F:15 | Current Angle L3 | Phase angle of the current of L3 | REAL32 | RO | 0x00000000 (0dec)
Index F610 PMX Total System
Index (hex) | Name | Meaning | Data type | Flags | Default
F610:0 | PMX Total System | Max. subindex | UINT8 | RO | 0x15 (21dec)
F610:11 | Positive Sequence | Voltage of the co-system | REAL32 | RO | 0x00000000 (0dec)
F610:12 | Negative Sequence | Voltage of the opposing system | REAL32 | RO | 0x00000000 (0dec)
F610:13 | Zero Sequence | Zero system voltage | REAL32 | RO | 0x00000000 (0dec)
Index F611 PMX Total Statistic Power Fundamental
Index (hex) | Name | Meaning | Data type | Flags | Default
F611:0 | PMX Total Statistic Power Fundamental | Max. subindex | UINT8 | RO | 0x18 (24dec)
F611:10 | Active Power Avg Fund | Average total active power of the fundamental of the last interval in W | REAL32 | RO | 0x00000000 (0dez)
F611:11 | Active Power Min Fund | Total active power minimum of the fundamental in the last interval in W | REAL32 | RO | 0x00000000 (0dez)
F611:12 | Active Power Max Fund | Total active power maximum of the fundamental in the last interval in W | REAL32 | RO | 0x00000000 (0dez)
F611:13 | Apparent Power Avg Fund | Average total apparent power of the fundamental of the last interval in VA | REAL32 | RO | 0x00000000 (0dez)
F611:14 | Apparent Power Min Fund | Total apparent power minimum of the fundamental in the last interval in VA | REAL32 | RO | 0x00000000 (0dez)
F611:15 | Apparent Power Max Fund | Total apparent power maximum of the fundamental in the last interval in VA | REAL32 | RO | 0x00000000 (0dez)
F611:16 | Reactive Power Avg Fund | Average total reactive power of the fundamental of the last interval in var | REAL32 | RO | 0x00000000 (0dez)
F611:17 | Reactive Power Min Fund | Total reactive power minimum of the fundamental in the last interval in var | REAL32 | RO | 0x00000000 (0dez)
F611:18 | Reactive Power Max Fund | Total reactive power maximum of the fundamental in the last interval in var | REAL32 | RO | 0x00000000 (0dez)


Output data

Commissioning [image] Object description and parameterization [image] EL3453 [image] Output data
Output data
Index F700 PMX Variant Value Out
Index (hex) | Name | Meaning | Data type | Flags | Default
F700:0 | PMX Variant Value Out | Max. subindex | UINT8 | RO | 0x14 (20dec)
F700:11 | Index 1 REAL | Request for variable output value 1 (REAL) Can be used for all non-energy values (details see settings) | UINT16 | RO | 0x0000 (0dec)
F700:12 | Index 2 REAL | Request for variable output value 2 (REAL) Can be used for all non-energy values (details see settings) | UINT16 | RO | 0x0000 (0dec)
F700:13 | Index 3 REAL | Request for variable output value 3 (REAL) Can be used for all non-energy values (details see settings) | UINT16 | RO | 0x0000 (0dec)
F700:14 | Index 4 ULINT | Request for variable output value 4 (ULINT) Can be used for all energy values (which are output as ULINT): 45-59 and 1069-1083 | UINT16 | RO | 0x0000 (0dec)
Index F701 PMX Interval
Index (hex) | Name | Meaning | Data type | Flags | Default
F701:0 | PMX Interval | Max. subindex | UINT8 | RO | 0x01 (1dec)
F701:01 | Reset Interval | Manual option for resetting the interval (see basic function principles – Statistical evaluation) | BOOLEAN | RO | 0x00 (0dec)


Information and diagnostic data

Commissioning [image] Object description and parameterization [image] EL3453 [image] Information and diagnostic data
Information and diagnostic data
Index 90n0 PMX info data voltage (for ch.1, n = 0; ch.2, n = 1; ch.3, n = 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
90n0:0 | PMX Info data Voltage | Max. subindex | UINT8 | RO | 0x13 (19dec)
90n0:11 | Voltage Peak | Peak value of the instantaneous voltage in the last interval in V | REAL32 | RO | 0x00000000 (0dec)
90n0:12 | Voltage RMS Minimum | Minimum RMS value of the voltage in the last interval in V | REAL32 | RO | 0x00000000 (0dec)
90n0:13 | Voltage RMS Maximum | Maximum RMS value of the voltage in the last interval in V | REAL32 | RO | 0x00000000 (0dec)
Index 90n1 PMX info data current (for ch.1, n = 0; ch.2, n = 1; ch.3, n = 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
90n1:0 | PMX Info data Current | Max. subindex | UINT8 | RO | 0x13 (19dec)
90n1:11 | Current Peak | Peak value of the instantaneous current in the last interval in A | REAL32 | RO | 0x00000000 (0dec)
90n1:12 | Current RMS Minimum | Minimum RMS value of the current in the last interval in A | REAL32 | RO | 0x00000000 (0dec)
90n1:13 | Current RMS Maximum | Maximum RMS value of the current in the last interval in A | REAL32 | RO | 0x00000000 (0dec)
Index 90n2 PMX info data power (for ch.1, n = 0; ch.2, n = 1; ch.3, n = 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
90n2:0 | PMX Info data Power | Max. subindex | UINT8 | RO | 0x1B (27dec)
90n2:11 | Active Power Avg | Average active phase power during the last interval in W | REAL32 | RO | 0x00000000 (0dec)
90n2:12 | Active Power Min | Minimum active phase power during the last interval in W | REAL32 | RO | 0x00000000 (0dec)
90n2:13 | Active Power Max | Maximum active phase power during the last interval in W | REAL32 | RO | 0x00000000 (0dec)
90n2:14 | Apparent Power Avg | Average apparent phase power during the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
90n2:15 | Apparent Power Min | Minimum apparent phase power during the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
90n2:16 | Apparent Power Max | Maximum apparent phase power during the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
90n2:17 | Reactive Power Avg | Average reactive phase power during the last interval in var | REAL32 | RO | 0x00000000 (0dec)
90n2:18 | Reactive Power Min | Minimum reactive phase power during the last interval in var | REAL32 | RO | 0x00000000 (0dec)
90n2:19 | Reactive Power Max | Maximum reactive phase power during the last interval in var | REAL32 | RO | 0x00000000 (0dec)
90n2:1A | Phi | Phase angle in degrees (between voltage U_Lx and the corresponding current I_Lx) | REAL32 | RO | 0x00000000 (0dec)
90n2:1B | Phase angle | Phase difference in degrees (between different voltages U_Lx and U_Ly) | REAL32 | RO | 0x00000000 (0dec)
Index 90n3 PMX info data energy (for ch.1, n = 0; ch.2, n = 1; ch.3, n = 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
90n3:0 | PMX info data energy ch.1 | Max. subindex | UINT8 | RO | 0x19 (25dec)
90n3:11 | Active Energy | Recorded active phase energy in mWh | INT64 | RO |
90n3:12 | Positive Active Energy | Received active phase energy in mWh | UINT64 | RO |
90n3:13 | Negative Active Energy | Supplied active phase energy in mWh | UINT64 | RO |
90n3:14 | Apparent Energy | Recorded apparent phase energy in mWh | INT64 | RO |
90n3:15 | Positive Apparent Energy | Received apparent phase energy in mWh | UINT64 | RO |
90n3:16 | Negative Apparent Energy | Supplied apparent phase energy in mWh | UINT64 | RO |
90n3:17 | Reactive Energy | Recorded reactive phase energy in mWh | INT64 | RO |
90n3:18 | Positive Reactive Energy | Received reactive phase energy in mWh | UINT64 | RO |
90n3:19 | Negative Reactive Energy | Supplied reactive phase energy in mWh | UINT64 | RO |
Index 90n4 PMX Harmonic Voltage (for ch.1, n = 0; ch.2, n = 1; ch.3, n = 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
90n4:0 | PMX Harmonic Voltage Ch.1 | Max. subindex | UINT8 | RO | 0x40 (64dez)
90n4:01 | Harmonic 0 | DC component of the oscillation in % of the fundamental wave | REAL32 | RO | 0x00000000 (0dez)
90n4:02 | Harmonic 1 | Fundamental wave | REAL32 | RO | 0x00000000 (0dez)
90n4:03 | Harmonic 2 | 2nd harmonic in % of the fundamental wave | REAL32 | RO | 0x00000000 (0dez)
90n4:04 | Harmonic 3 | 3rd harmonic in % of the fundamental wave | REAL32 | RO | 0x00000000 (0dez)
… | … | … | … | … | …
90n4:40 | Harmonic 63 | 63rd harmonic in % of the fundamental wave | REAL32 | RO | 0x00000000 (0dez)
Index 90n5 PMX Harmonic Current (for ch.1, n = 0; ch.2, n = 1; ch.3, n = 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
90n5:0 | PMX Harmonic Voltage Ch.1 | Max. subindex | UINT8 | RO | 0x2A (42dec)
90n5:01 | Harmonic 0 | DC component of the oscillation in % of the fundamental wave | REAL32 | RO | 0x00000000 (0dec)
90n5:02 | Harmonic 1 | Fundamental wave | REAL32 | RO | 0x00000000 (0dec)
90n5:03 | Harmonic 2 | 2nd harmonic in % of the fundamental wave | REAL32 | RO | 0x00000000 (0dec)
90n5:04 | Harmonic 3 | 3rd harmonic in % of the fundamental wave | REAL32 | RO | 0x00000000 (0dec)
… | … | … | … | … | …
90n5:40 | Harmonic 63 | 63rd harmonic in % of the fundamental wave | REAL32 | RO | 0x00000000 (0dec)
Index 90n6 PMX Info data Fundamental (for ch.1, n = 0; ch.2, n = 1; ch.3, n = 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
90n6:0 | PMX Info data Fundamental Ch.1 | Max. subindex | UINT8 | RO | 0x13 (19dec)
90n6:10 | Voltage Fundamental RMS | Effective voltage of the fundamental wave from the harmonic calculation | REAL32 | RO | 0.000000 (0.000000e+000)
90n6:11 | Voltage Fundamental Frequency | Frequency of the fundamental voltage wave from the harmonic calculation | REAL32 | RO | 0.000000 (0.000000e+000)
90n6:12 | Current Fundamental RMS | Effective current of the fundamental wave from the harmonic calculation | REAL32 | RO | 0.000000 (0.000000e+000)
90n6:13 | Current Fundamental Frequency | Frequency of the fundamental current wave from the harmonic calculation | REAL32 | RO | 0.000000 (0.000000e+000)
Index A0n0 PMX Diag data (for ch.1, n = 0; ch.2, n = 1; ch.3, n = 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
A0n0:0 | PMX diag data ch.1 | Max. subindex | UINT8 | RO | 0x12 (18dec)
A0n0:11 | Saturation Time Voltage | Time (in 0.1 ms) in which the terminal has measured an overvoltage. | UINT32 | RO | 0x00000000 (0dec)
A0n0:12 | Saturation Time Current | Time (in 0.1 ms) in which the terminal has measured an overcurrent. | UINT32 | RO | 0x00000000 (0dec)
Index F081 Download revision
Index (hex) | Name | Meaning | Data type | Flags | Default
F081:0 | Download revision | Max. subindex | UINT8 | RO | 0x01 (1dec)
F010:01 | Revision number | Configured revision of the terminal, (see note) | UINT32 | RW | 0x00000000 (0dec)
Index F80F PMX vendor data (for ch.1, n = 0; ch.2, n = 1; ch.3, n = 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
F80F:0 | PMX Vendor data | Max. subindex | UINT8 | RO | 0x1A (26dez)
F80F:11 | Type | Vendor-specific data | UINT32 | RW | 0x00000000
F80F:12 | Calibration Current Offset | Value in A | REAL32 | RW | 0,000000 (0,000000e+000)
F80F:13 | Calibration Current Gain | Factor (without unit) | REAL32 | RW | 1,000000 (1,000000e+000)
F80F:14 | Calibration Current Phase Offset | Value in milliseconds | REAL32 | RW | 0,000000 (0,000000e+000)
F80F:15 | Calibration Current 1 Offset | Value in A | REAL32 | RW | 0,000000 (0,000000e+000)
F80F:16 | Calibration Current 1 Gain | Factor (without unit) | REAL32 | RW | 1,000000 (1,000000e+000)
F80F:17 | Calibration Current 1 Phase Offset | Value in milliseconds | REAL32 | RW | 0,000000 (0,000000e+000)
F80F:18 | Calibration Current 2 Offset | Value in A | REAL32 | RW | 0,000000 (0,000000e+000)
F80F:19 | Calibration Current 2 1 Gain | Factor (without unit) | REAL32 | RW | 1,000000 (1,000000e+000)
F80F:1A | Calibration Current 2 Phase Offset | Value in milliseconds | REAL32 | RW | 0,000000 (0,000000e+000)
Index F902 PMX Total Info data Power
Index (hex) | Name | Meaning | Data type | Flags | Default
F902:0 | PMX Total Info data Power | Max. subindex | UINT8 | RO | 0x19 (25dec)
F902:11 | Active Power Avg | Average total active power during the last interval in W | REAL32 | RO | 0x00000000 (0dec)
F902:12 | Active Power Min | Minimum total active power in the last interval in W | REAL32 | RO | 0x00000000 (0dec)
F902:13 | Active Power Max | Maximum total active power in the last interval in W | REAL32 | RO | 0x00000000 (0dec)
F902:14 | Apparent Power Avg | Average total apparent power during the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
F902:15 | Apparent Power Min | Minimum total apparent power in the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
F902:16 | Apparent Power Max | Maximum total apparent power in the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
F902:17 | Reactive Power Avg | Average total reactive power average during the last interval in var | REAL32 | RO | 0x00000000 (0dec)
F902:18 | Reactive Power Min | Minimum total reactive power in the last interval in var | REAL32 | RO | 0x00000000 (0dec)
F902:19 | Reactive Power Max | Maximum total reactive power in the last interval in var | REAL32 | RO | 0x00000000 (0dec)
Index F903 PMX Total Info data Energy
Index (hex) | Name | Meaning | Data type | Flags | Default
F903:0 | PMX Total Info data Energy | Max. subindex | UINT8 | RO | 0x19 (25dec)
F903:11 | Active Energy | Recorded total active energy in mWh | INT64 | RO |
F903:12 | Positive Active Energy | Received total active energy in mWh | UINT64 | RO |
F903:13 | Negative Active Energy | Supplied total active energy in mWh | UINT64 | RO |
F903:14 | Apparent Energy | Recorded total apparent energy in mWh | INT64 | RO |
F903:15 | Positive Apparent Energy | Received total apparent energy in mWh | UINT64 | RO |
F903:16 | Negative Apparent Energy | Supplied total apparent energy in mWh | UINT64 | RO |
F903:17 | Reactive Energy | Recorded total reactive energy in mWh | INT64 | RO |
F903:18 | Positive Reactive Energy | Received total reactive energy in mWh | UINT64 | RO |
F903:19 | Negative Reactive Energy | Supplied total reactive energy in mWh | UINT64 | RO |
Index F904 PMX Total Info data PQF
Index (hex) | Name | Meaning | Data type | Flags | Default
F904:0 | PMX Total Info data PQF | Max. subindex | UINT8 | RO | 0x13 (19dec)
F904:11 | PQF Avg | Average value of the power quality factor during the last interval | REAL32 | RO | 0x00000000 (0dec)
F904:12 | PQF Min | Minimum power quality factor in the last interval | REAL32 | RO | 0x00000000 (0dec)
F904:13 | PQF Max | Maximum power quality factor in the last interval | REAL32 | RO | 0x00000000 (0dec)
Index F905 PMX Total Info data Power Fundamental
Index (hex) | Name | Meaning | Data type | Flags | Default
F905:0 | PMX Grid Info data Power Fundamental | Max. subindex | UINT8 | RO | 0x19 (25dec)
F905:11 | Active Power Avg Fund | Total active power average of fundamental oscillation of the last interval in W | REAL32 | RO | 0x00000000 (0dec)
F905:12 | Active Power Min Fund | Total active power minimum of fundamental oscillation in the last interval in W | REAL32 | RO | 0x00000000 (0dec)
F905:13 | Active Power Max Fund | Total active power maximum of fundamental oscillation in the last interval in W | REAL32 | RO | 0x00000000 (0dec)
F905:14 | Apparent Power Avg Fund | Total apparent power average of fundamental oscillation of the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
F905:15 | Apparent Power Min Fund | Total apparent power minimum of fundamental oscillation of the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
F905:16 | Apparent Power Max Fund | Total apparent power maximum of fundamental oscillation of the last interval in VA | REAL32 | RO | 0x00000000 (0dec)
F905:17 | Reactive Power Avg Fund | Total reactive power average of fundamental oscillation of the last interval in var | REAL32 | RO | 0x00000000 (0dec)
F905:18 | Reactive Power Min Fund | Total reactive power minimum of fundamental oscillation of the last interval in var | REAL32 | RO | 0x00000000 (0dec)
F905:19 | Reactive Power Max Fund | Total reactive power maximum of fundamental oscillation of the last interval in var | REAL32 | RO | 0x00000000 (0dec)
Index FA00 PMX Diag data
Index (hex) | Name | Meaning | Data type | Flags | Default
FA00:0 | PMX Diag data | Max. subindex | UINT8 | RO | 0x13 (19dec)
FA00:11 | Min CPU Die Temperature | Minimum CPU temperature measured so far | REAL32 | RO | 0x00000000 (0dec)
FA00:12 | Max CPU Die Temperature | Maximum CPU temperature measured so far | REAL32 | RO | 0x00000000 (0dec)
FA00:13 | EBUS Voltage | Current E-bus voltage | REAL32 | RO | 0x00000000 (0dec)


Standard objects

Commissioning [image] Object description and parameterization [image] EL3453 [image] Standard objects
Standard objects
Index 1000 Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x01551389 (22352777dec)
Index 1008 Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EL34xx
Index 1009 Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO |
Index 100A Software Version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO |
Index 100B Bootloader version
Index (hex) | Name | Meaning | Data type | Flags | Default
100B:0 | Bootloader version | Bootloader version | STRING | RO |
Index 1018 Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x0D733052 (225652818dez)
1018:03 | Revision | Revision number of the EtherCAT slave; the low word (bit 0-15) indicates the special terminal number, the high word (bit 16-31) refers to the device description | UINT32 | RO | 0x00000000 (0dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the low byte (bit 0-7) of the low word contains the year of production, the high byte (bit 8-15) of the low word contains the week of production, the high word (bit 16-31) is 0 | UINT32 | RO | e.g. 0x00001E06 (KW 30/2006)
Index 10F0 Backup parameter
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter | Length of this object | UINT8 | RO | 0x01
10F0:01 | Checksum | Checksum | UINT32 | RW | 0x00000000 (0dec)
Index 10F3 Diagnosis History
Index | Name | Meaning | Data type | Flags | Default
10F3:0 | Diagnosis History | Maximum subindex | UINT8 | RO | 0x15 (21dec)
10F3:01 | Maximum Messages | Maximum number of stored messages. A maximum of 50 messages can be stored | UINT8 | RO | 0x00 (0dec)
10F3:02 | Newest Message | Subindex of the latest message | UINT8 | RO | 0x00 (0dec)
10F3:03 | Newest Acknowledged Message | Subindex of the last confirmed message | UINT8 | RW | 0x00 (0dec)
10F3:04 | New Messages Available | Indicates that a new message is available | BOOLEAN | RO | 0x00 (0dec)
10F3:05 | Flags | not used | UINT16 | RW | 0x0000 (0dec)
10F3:06 | Diagnosis Message 001 | Message 1 | OCTET STRING[28] | RO | {0}
... | ... | ... | ... | ... | ...
10F3:15 | Diagnosis Message 016 | Message 16 | OCTET STRING[28] | RO | {0}
Index 10F8 Actual Time Stamp
Index | Name | Meaning | Data type | Flags | Default
10F8:0 | Actual Time Stamp | Time stamp | UINT64 | RO | 0x0000000000000000 (0dec)
Index 1600 Total RxPDO-Map Outputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1600:0 | Total RxPDO-Map Outputs Device | PDO Mapping RxPDO 1 | UINT8 | RO | 0x04 (4dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7030 (PMX Variant Value Out), entry 0x11 (Index 1 REAL)) | UINT32 | RO | 0xF700:11, 16
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7030 (PMX Variant Value Out), entry 0x12 (Index 2 REAL)) | UINT32 | RO | 0xF700:12, 16
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7030 (PMX Variant Value Out), entry 0x13 (Index 3 REAL)) | UINT32 | RO | 0xF700:13, 16
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7030 (PMX Variant Value Out), entry 0x14 (Index 4 ULINT)) | UINT32 | RO | 0xF700:14, 16
Index 1601 Total RxPDO-Map Interval
Index (hex) | Name | Meaning | Data type | Flags | Default
1601:0 | Total RxPDO-Map Interval | PDO Mapping RxPDO 2 | UINT8 | RO | 0x02 (2dec)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF701 (PMX Interval), entry 0x01 (Reset Interval)) | UINT32 | RO | 0xF701:01, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
Index 1App TxPDO-Map Status (for L1, pp = 00; L2, pp = 0C; L3, pp = 18)
Index (hex) | Name | Meaning | Data type | Flags | Default
1App:0 | TxPDO-Map Status | PDO Mapping TxPDO | UINT8 | RO | 0x0B (11dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x01 (Voltage Sign Bit)) | UINT32 | RO | 0x60n0:01, 1**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x02 (Overvoltage)) | UINT32 | RO | 0x60n0:02, 1**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x03 (Overcurrent)) | UINT32 | RO | 0x60n0:03, 1**
1App:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x04 (Inaccurate Voltage)) | UINT32 | RO | 0x60n0:04, 1**
1App:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x05 (Inaccurate Current)) | UINT32 | RO | 0x60n0:05, 1**
1App:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x06 (Voltage Guard Warning)) | UINT32 | RO | 0x60n0:06, 1**
1App:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x07 (Voltage Guard Error)) | UINT32 | RO | 0x60n0:07, 1**
1App:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x08 (Current Guard Warning)) | UINT32 | RO | 0x60n0:08, 1**
1App:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x09 (Current Guard Error)) | UINT32 | RO | 0x60n0:09, 1**
1App:0A | SubIndex 010 | 10. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x00n0:00, 6**
1App:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x60n0:10, 1**
**) for L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Basic (for L1, pp = 01; L2, pp = 0D; L3, pp = 19)
Index (hex) | Name | Meaning | Data type | Flags | Default
1App:0 | TxPDO-Map Statistic Basic | PDO Mapping TxPDO | UINT8 | RO | 0x02 (2dec)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n1 (PMX Basic), entry 0x11 (Voltage)) | UINT32 | RO | 0x60n1:11, 32**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n1 (PMX Basic), entry 0x12 (Current)) | UINT32 | RO | 0x60n1:12, 32**
**) for L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Power (for L1, pp = 02; L2, pp = 0E; L3, pp = 1A)
Index (hex) | Name | Meaning | Data type | Flags | Default
1App:0 | TxPDO-Map Power | PDO Mapping TxPDO | UINT8 | RO | 0x04 (4dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n2 (PMX Power), entry 0x11 (Active Power)) | UINT32 | RO | 0x60n2:11, 32**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n2 (PMX Power), entry 0x12 (Apparent Power)) | UINT32 | RO | 0x60n2:12, 32**
1App:03 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n2 (PMX Power), entry 0x13 (Reactive Power)) | UINT32 | RO | 0x60n2:13, 32**
1App:04 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n2 (PMX Power), entry 0x14 (Power Factor)) | UINT32 | RO | 0x60n2:14, 32**
**) for L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Power Fundamental (for L1, pp = 03; L2, pp = 0F; L3, pp = 1B)
Index (hex) | Name | Meaning | Data type | Flags | Default
1App:0 | TxPDO-Map Power Fundamental | PDO Mapping TxPDO | UINT8 | RO | 0x03 (3dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n3 (PMX Power Fundamental), entry 0x11 (Active Power Fund)) | UINT32 | RO | 0x60n3:11, 32**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n3 (PMX Power Fundamental), entry 0x12 (Apparent Power Fund)) | UINT32 | RO | 0x60n3:12, 32**
1App:03 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n3 (PMX Power Fundamental), entry 0x13 (Reactive Power Fund)) | UINT32 | RO | 0x60n3:13, 32**
**) for L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Energy (for L1, pp = 04; L2, pp = 10; L3, pp = 1C)
Index (hex) | Name | Meaning | Data type | Flags | Default
1App:0 | TxPDO-Map Energy | PDO Mapping TxPDO | UINT8 | RO | 0x03 (3dec)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n4 (PMX Energy), entry 0x11 (Active Energy)) | UINT32 | RO | 0x60n4:11, 64**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n4 (PMX Energy), entry 0x12 (Apparent Energy)) | UINT32 | RO | 0x60n4:12, 64**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60n4 (PMX Energy), entry 0x13 (Reactive Energy)) | UINT32 | RO | 0x60n4:13, 64**
**) for L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Energy Fundamental (for L1, pp = 05; L2, pp = 11; L3, pp = 1D)
Index (hex) | Name | Meaning | Data type | Flags | Default
1App:0 | TxPDO-Map Energy Fundamental | PDO Mapping TxPDO | UINT8 | RO | 0x03 (3dec)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n4 (PMX Energy), entry 0x11 (Active Energy)) | UINT32 | RO | 0x60n4:11, 64**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n4 (PMX Energy), entry 0x12 (Apparent Energy)) | UINT32 | RO | 0x60n4:12, 64**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60n4 (PMX Energy), entry 0x13 (Reactive Energy)) | UINT32 | RO | 0x60n4:13, 64**
**) for L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Timing (for L1, pp = 06; L2, pp = 12; L3, pp = 1E)
Index (hex) | Name | Meaning | Data type | Flags | Default
1App:0 | TxPDO-Map Statistic Timing | PDO Mapping TxPDO | UINT8 | RO | 0x02 (2dec)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n6 (PMX Timing), entry 0x12 (Voltage Last Zero Crossing)) | UINT32 | RO | 0x60n6:12, 64**
**) for L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Advanced (for L1, pp = 07; L2, pp = 13; L3, pp = 1F)
Index (hex) | Name | Meaning | Data type | Flags | Default
1App:0 | TxPDO-Map Advanced | PDO Mapping TxPDO | UINT8 | RO | 0x03 (3dec)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x00n0:00, 15**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n7 (PMX Advanced), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x60n7:10, 1**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60n7 (PMX Advanced), entry 0x11 (Voltage Total Harmonic Distortion)) | UINT32 | RO | 0x60n7:11, 32**
1App:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60n7 (PMX Advanced), entry 0x12 (Current Distortion Factor)) | UINT32 | RO | 0x60n7:12, 32**
1App:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60n7 (PMX Advanced), entry 0x13 (Current Total Harmonic Distortion)) | UINT32 | RO | 0x60n7:13, 32**
1App:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60n7 (PMX Advanced), entry 0x14 (Cos Phi)) | UINT32 | RO | 0x60n7:14, 32**
**) for L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Statistic Voltage (for L1, pp = 08; L2, pp = 14; L3, pp = 20)
Index (hex) | Name | Meaning | Data type | Flags | Default
1App:0 | TxPDO-Map Statistic Voltage | PDO Mapping TxPDO | UINT8 | RO | 0x03 (3dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n8 (PMX Statistic Voltage), entry 0x11 (Voltage Peak)) | UINT32 | RO | 0x60n8:11, 32**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n8 (PMX Statistic Voltage), entry 0x12 (Voltage RMS Minimum)) | UINT32 | RO | 0x60n8:12, 32**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60n8 (PMX Statistic Voltage), entry 0x13 (Voltage RMS Maximum)) | UINT32 | RO | 0x60n8:13, 32**
**) for L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Statistic Current (for L1, pp = 09; L2, pp = 15; L3, pp = 21)
Index (hex) | Name | Meaning | Data type | Flags | Default
1App:0 | L1 TxPDO-Map Statistic Current | PDO Mapping TxPDO 8 | UINT8 | RO | 0x03 (3dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n9 (PMX Statistic Current), entry 0x11 (Current Peak)) | UINT32 | RO | 0x60n9:11, 32**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n9 (PMX Statistic Current), entry 0x12 (Current RMS Minimum)) | UINT32 | RO | 0x60n9:12, 32**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60n9 (PMX Statistic Current), entry 0x13 (Current RMS Maximum)) | UINT32 | RO | 0x60n9:13, 32**
**) for L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Statistic Power (for L1, pp = 0A; L2, pp = 16; L3, pp = 22)
Index (hex) | Name | Meaning | Data type | Flags | Default
1App:0 | TxPDO-Map Statistic Power | PDO Mapping TxPDO | UINT8 | RO | 0x09 (9dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x11 (Active Power Avg)) | UINT32 | RO | 0x60nA:11, 32**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x12 (Active Power Min)) | UINT32 | RO | 0x60nA:12, 32**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x13 (Active Power Max)) | UINT32 | RO | 0x60nA:13, 32**
1App:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x14 (Apparent Power Avg)) | UINT32 | RO | 0x60nA:14, 32**
1App:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x15 (Apparent Power Max)) | UINT32 | RO | 0x60nA:15, 32**
1App:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x16 (Reactive Power Avg)) | UINT32 | RO | 0x60nA:16, 32**
1App:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x17 (Reactive Power Min)) | UINT32 | RO | 0x60nA:17, 32**
1App:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x18 (Reactive Power Max)) | UINT32 | RO | 0x60nA:18, 32**
1App:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x19 (Apparent Power Min)) | UINT32 | RO | 0x60nA:19, 32**
**) for L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Classic (for L1, pp = 0B; L2, pp = 17; L3, pp = 23)
Index (hex) | Name | Meaning | Data type | Flags | Default
1App:0 | TxPDO-Map Classic | PDO Mapping TxPDO | UINT8 | RO | 0x08 (8dec)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x00n0:00, 15**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60nB (PMX Classic), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x60nB:10, 1**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60nB (PMX Classic), entry 0x11 (Voltage)) | UINT32 | RO | 0x60nB:11, 32**
1App:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60nB (PMX Classic), entry 0x12 (Current)) | UINT32 | RO | 0x60nB:12, 32**
1App:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60nB (PMX Classic), entry 0x13 (Frequency)) | UINT32 | RO | 0x60nB:13, 32**
1App:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60nB (PMX Classic), entry 0x14 (Active Power)) | UINT32 | RO | 0x60nB:14, 32**
1App:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60nB (PMX Classic), entry 0x15 (Apparent Power)) | UINT32 | RO | 0x60nB:15, 32**
1App:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60nB (PMX Classic), entry 0x16 (Reactive Power)) | UINT32 | RO | 0x60nB:16, 32**
**) for L1, n = 0; L2, n = 1; L3, n = 2)
Index 1A24 Total TxPDO-Map Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1A24:0 | Total TxPDO-Map Status | PDO Mapping TxPDO 31 | UINT8 | RO | 0x10 (16dec)
1A24:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x01 (System State)) | UINT32 | RO | 0xF600:01, 1
1A24:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x02 (Grid Direction)) | UINT32 | RO | 0xF600:02, 1
1A24:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x03 (Frequency Guard Warning)) | UINT32 | RO | 0xF600:03, 1
1A24:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x04 (Frequency Guard Error)) | UINT32 | RO | 0xF600:04, 1
1A24:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x05 (Neutral Current Guard Warning)) | UINT32 | RO | 0xF600:05, 1
1A24:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x06 (Neutral Current Guard Error)) | UINT32 | RO | 0xF600:06, 1
1A24:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x07 (Active Power Guard Warning)) | UINT32 | RO | 0xF600:07, 1
1A24:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x08 (Active Power Guard Error)) | UINT32 | RO | 0xF600:08, 1
1A24:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x09 (Apparent Power Guard Warning)) | UINT32 | RO | 0xF600:09, 1
1A24:0A | SubIndex 010 | 10. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x0A (Apparent Power Guard Error)) | UINT32 | RO | 0xF600:0A, 1
1A24:0B | SubIndex 011 | 11. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x0B (Power Quality Guard Warning)) | UINT32 | RO | 0xF600:0B, 1
1A24:0C | SubIndex 012 | 12. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x0C (Power Quality Guard Error)) | UINT32 | RO | 0xF600:0C, 1
1A24:0D | SubIndex 013 | 13. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A24:0E | SubIndex 014 | 14. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x0F (TxPDO State)) | UINT32 | RO | 0xF600:0F, 1
1A24:0F | SubIndex 015 | 15. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0xF600:10, 1
1A24:10 | SubIndex 016 | 16. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x11 (Power Quality Factor)) | UINT32 | RO | 0xF600:11, 32
Index 1A26 Total TxPDO-Map Advanced
Index (hex) | Name | Meaning | Data type | Flags | Default
1A26:0 | Total TxPDO-Map Advanced | PDO Mapping TxPDO 33 | UINT8 | RO | 0x08 (8dec)
1A26:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF602 (PMX Grid Advanced), entry 0x11 (Max Voltage Harmonic Distortion)) | UINT32 | RO | 0xF602:01, 1
1A26:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF602 (PMX Grid Advanced), entry 0x12 (Max Current Harmonic Distortion)) | UINT32 | RO | 0xF602:02, 1
1A26:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF602 (PMX Grid Advanced), entry 0x13 (Max Current Distortion Factor)) | UINT32 | RO | 0x0000:00, 13
1A26:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF602 (PMX Grid Advanced), entry 0x14 (Voltage Unbalance)) | UINT32 | RO | 0xF602:10, 1
1A26:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF602 (PMX Total Advanced), entry 0x11 (Max Voltage Harmonic Distortion)) | UINT32 | RO | 0xF602:11, 32
1A26:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF602 (PMX Total Advanced), entry 0x12 (Max Current Harmonic Distortion)) | UINT32 | RO | 0xF602:12, 32
1A26:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF602 (PMX Total Advanced), entry 0x13 (Max Current Distortion Factor)) | UINT32 | RO | 0xF602:13, 32
1A26:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF602 (PMX Total Advanced), entry 0x14 (Voltage Unbalance)) | UINT32 | RO | 0xF602:14, 32
Index 1A27 Total TxPDO-Map Active
Index (hex) | Name | Meaning | Data type | Flags | Default
1A27:0 | Total TxPDO-Map Active | PDO Mapping TxPDO 34 | UINT8 | RO | 0x04 (4dec)
1A27:01 | SubIndex 001 | 1. PDO Mapping entry (32 bits align) | UINT32 | RO | 0x0000:00, 32
1A27:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF603 (PMX Total Active), entry 0x12 (Active Energy)) | UINT32 | RO | 0xF603:12, 64
1A27:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF603 (PMX Total Active), entry 0x13 (Active Positive Energy)) | UINT32 | RO | 0xF603:13, 64
1A27:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF603 (PMX Total Active), entry 0x14 (Active Negative Energy)) | UINT32 | RO | 0xF603:14, 64
Index 1A28 Total TxPDO-Map Active Fundamental
Index (hex) | Name | Meaning | Data type | Flags | Default
1A28:0 | Total TxPDO-Map Active Fundamental | PDO Mapping TxPDO 34 | UINT8 | RO | 0x04 (4dez)
1A28:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF604 (PMX Total Active Fundamental), entry 0x11 (Active Power Fund)) | UINT32 | RO | 0xF604:11, 32
1A28:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF604 (PMX Total Active Fundamental), entry 0x12 (Active Energy Fund)) | UINT32 | RO | 0xF604:12, 64
1A28:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF604 (PMX Total Active Fundamental), entry 0x13 (Active Positive Energy Fund)) | UINT32 | RO | 0xF604:13, 64
1A28:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF604 (PMX Total Active Fundamental), entry 0x14 (Active Negative Energy Fund)) | UINT32 | RO | 0xF604:14, 64
Index 1A29 Total TxPDO-Map Apparent
Index (hex) | Name | Meaning | Data type | Flags | Default
1A29:0 | Total TxPDO-Map Apparent | PDO Mapping TxPDO 35 | UINT8 | RO | 0x04 (4dec)
1A29:01 | SubIndex 001 | 1. PDO Mapping entry (32 bits align) | UINT32 | RO | 0x0000:00, 32
1A29:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF605 (PMX Total Apparent), entry 0x12 (Apparent Energy)) | UINT32 | RO | 0xF605:12, 64
1A29:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF605 (PMX Total Apparent), entry 0x13 (Apparent Positive Energy)) | UINT32 | RO | 0xF605:13, 64
1A29:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF605 (PMX Total Apparent), entry 0x14 (Apparent Negative Energy)) | UINT32 | RO | 0xF605:14, 64
Index 1A2A Total TxPDO-Map Apparent Fundamental
Index (hex) | Name | Meaning | Data type | Flags | Default
1A2A:0 | Total TxPDO-Map Apparent Fundamental | PDO Mapping TxPDO 35 | UINT8 | RO | 0x04 (4dez)
1A2A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF606 (PMX Total Apparent Fundamental), entry 0x11 (Apparent Power Fund)) | UINT32 | RO | 0xF606:11, 32
1A2A:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF606 (PMX Total Apparent Fundamental), entry 0x12 (Apparent Energy Fund)) | UINT32 | RO | 0xF606:12, 64
1A2A:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF606 (PMX Total Apparent Fundamental), entry 0x13 (Apparent Positive Energy Fund)) | UINT32 | RO | 0xF606:13, 64
1A2A:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF606 (PMX Total Apparent Fundamental), entry 0x14 (Apparent Negative Energy Fund)) | UINT32 | RO | 0xF606:14, 64
Index 1A2B Total TxPDO-Map Reactive
Index (hex) | Name | Meaning | Data type | Flags | Default
1A2B:0 | Total TxPDO-Map Reactive | PDO Mapping TxPDO 36 | UINT8 | RO | 0x04 (4dez)
1A2B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF607 (PMX Total Reactive), entry 0x11 (Reactive Power)) | UINT32 | RO | 0xF607:11, 32
1A2B:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF607 (PMX Total Reactive), entry 0x12 (Reactive Energy)) | UINT32 | RO | 0xF607:12, 64
1A2B:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF607 (PMX Total Reactive), entry 0x13 (Reactive Positive Energy)) | UINT32 | RO | 0xF607:13, 64
1A2B:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF607 (PMX Total Reactive), entry 0x14 (Reactive Negative Energy)) | UINT32 | RO | 0xF607:14, 64
Index 1A2C Total TxPDO-Map Reactive
Index (hex) | Name | Meaning | Data type | Flags | Default
1A2C:0 | Total TxPDO-Map Reactive Fundamental | PDO Mapping TxPDO 36 | UINT8 | RO | 0x04 (4dec)
1A2C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF608 (PMX Total Reactive Fundamental), entry 0x11 (Reactive Power Fund)) | UINT32 | RO | 0xF608:11, 32
1A2C:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF608 (PMX Total Reactive Fundamental), entry 0x12 (Reactive Energy Fund)) | UINT32 | RO | 0xF608:12, 64
1A2C:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF608 (PMX Total Reactive Fundamental), entry 0x13 (Reactive Positive Energy Fund)) | UINT32 | RO | 0xF608:13, 64
1A2C:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF608 (PMX Total Reactive Fundamental), entry 0x14 (Reactive Negative Energy Fund)) | UINT32 | RO | 0xF608:14, 64
Index 1A2D Total TxPDO-Map L-L Voltage
Index (hex) | Name | Meaning | Data type | Flags | Default
1A2D:0 | Total TxPDO-Map L-L Voltage | PDO Mapping TxPDO 37 | UINT8 | RO | 0x03 (3dez)
1A2D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF609 (PMX Total L-L Voltages), entry 0x11 (L1-L2 Voltage)) | UINT32 | RO | 0xF609:11, 32
1A2D:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF609 (PMX Total L-L Voltages), entry 0x12 (L2-L3 Voltage)) | UINT32 | RO | 0xF609:12, 32
1A2D:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF609 (PMX Total L-L Voltages), entry 0x13 (L3-L1 Voltage)) | UINT32 | RO | 0xF609:13, 32
Index 1A2E Total TxPDO-Map Variant Value In
Index (hex) | Name | Meaning | Data type | Flags | Default
1A2E:0 | Total TxPDO-Map Variant Value In | PDO Mapping TxPDO 38 | UINT8 | RO | 0x0A (10dec)
1A2E:01 | SubIndex 001 | 1. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1A2E:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF60A (PMX Variant Value In), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0xF60A:10, 1
1A2E:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF60A (PMX Variant Value In), entry 0x11 (Index 1 REAL)) | UINT32 | RO | 0xF60A:11, 16
1A2E:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF60A (PMX Variant Value In), entry 0x12 (Value 1 REAL)) | UINT32 | RO | 0xF60A:12, 32
1A2E:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF60A (PMX Variant Value In), entry 0x13 (Index 2 REAL)) | UINT32 | RO | 0xF60A:13, 16
1A2E:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF60A (PMX Variant Value In), entry 0x14 (Value 2 REAL)) | UINT32 | RO | 0xF60A:14, 32
1A2E:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF60A (PMX Variant Value In), entry 0x13 (Index 3 REAL)) | UINT32 | RO | 0xF60A:15, 16
1A2E:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF60A (PMX Variant Value In), entry 0x16 (Value 3 REAL)) | UINT32 | RO | 0xF60A:16, 32
1A2E:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF60A (PMX Variant Value In), entry 0x17 (Index 4 ULINT)) | UINT32 | RO | 0xF60A:17, 16
1A2E:0A | SubIndex 010 | 10. PDO Mapping entry (object 0xF60A (PMX Variant Value In), entry 0x18 (Value 4 ULINT)) | UINT32 | RO | 0xF60A:18, 64
Index 1A2F Total TxPDO-Map Statistic Power
Index (hex) | Name | Meaning | Data type | Flags | Default
1A2F:0 | Total TxPDO-Map Statistic Power | PDO Mapping TxPDO 39 | UINT8 | RO | 0x09 (9dec)
1A2F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x11 (Active Power Avg)) | UINT32 | RO | 0xF60B:11, 32
1A2F:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x12 (Active Power Min)) | UINT32 | RO | 0xF60B:12, 32
1A2F:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x13 (Active Power Max)) | UINT32 | RO | 0xF60B:13, 32
1A2F:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x14 (Apparent Power Avg)) | UINT32 | RO | 0xF60B:14, 32
1A2F:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x15 (Apparent Power Min)) | UINT32 | RO | 0xF60B:15, 32
1A2F:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x16 (Apparent Power Max)) | UINT32 | RO | 0xF60B:16, 32
1A2F:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x17 (Reactive Power Avg)) | UINT32 | RO | 0xF60B:17, 32
1A2F:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x18 (Reactive Power Min)) | UINT32 | RO | 0xF60B:18, 32
1A2F:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x19 (Reactive Power Max)) | UINT32 | RO | 0xF60B:19, 32
Index 1A30 Total TxPDO-Map Statistic PQF
Index (hex) | Name | Meaning | Data type | Flags | Default
1A30:0 | Total TxPDO-Map Statistic PQF | PDO Mapping TxPDO 40 | UINT8 | RO | 0x03 (3dec)
1A30:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF60C (PMX Total Statistic PQF), entry 0x11 (PQF Avg)) | UINT32 | RO | 0xF60C:11, 32
1A30:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF60C (PMX Total Statistic PQF), entry 0x12 (PQF Min)) | UINT32 | RO | 0xF60C:12, 32
1A30:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF60C (PMX Total Statistic PQF), entry 0x13 (PQF Max)) | UINT32 | RO | 0xF60C:13, 32
Index 1A31 Total TxPDO-Map Interval Energy
Index (hex) | Name | Meaning | Data type | Flags | Default
1A31:0 | Total TxPDO-Map Interval Energy | PDO Mapping TxPDO 41 | UINT8 | RO | 0x0B (11dec)
1A31:01 | SubIndex 001 | 1. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1A31:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0xF60D:10, 1
1A31:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x11 (Active Energy)) | UINT32 | RO | 0xF60D:11, 32
1A31:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x12 (Active Energy Positive)) | UINT32 | RO | 0xF60D:12, 32
1A31:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x13 (Active Energy Negative)) | UINT32 | RO | 0xF60D:13, 32
1A31:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x14 (Apparent Energy)) | UINT32 | RO | 0xF60D:14, 32
1A31:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x15 (Apparent Energy Positive)) | UINT32 | RO | 0xF60D:15, 32
1A31:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x16 (Apparent Energy Negative)) | UINT32 | RO | 0xF60D:16, 32
1A31:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x17 (Reactive Energy)) | UINT32 | RO | 0xF60D:17, 32
1A31:0A | SubIndex 010 | 10. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x18 (Reactive Energy Positive)) | UINT32 | RO | 0xF60D:18, 32
1A31:0B | SubIndex 011 | 11. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x19 (Reactive Energy Negative)) | UINT32 | RO | 0xF60D:19, 32
Index 1A32 Total TxPDO-Map Interval Energy Fundamental
Index (hex) | Name | Meaning | Data type | Flags | Default
1A32:0 | Total TxPDO-Map Interval Energy Fundamental | PDO Mapping TxPDO 41 | UINT8 | RO | 0x0B (11dez)
1A32:01 | SubIndex 001 | 1. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1A32:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF60E (PMX Total Interval Energy Fundamental), entry 0x10 (TxPDO Toggle Fund)) | UINT32 | RO | 0xF60E:10, 1
1A32:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF60E (PMX Total Interval Energy Fundamental), entry 0x11 (Active Energy Fund)) | UINT32 | RO | 0xF60E:11, 32
1A32:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF60E (PMX Total Interval Energy Fundamental), entry 0x12 (Active Energy Positive Fund)) | UINT32 | RO | 0xF60E:12, 32
1A32:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF60E (PMX Total Interval Energy Fundamental), entry 0x13 (Active Energy Negative Fund)) | UINT32 | RO | 0xF60E:13, 32
1A32:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF60E (PMX Total Interval Energy Fundamental), entry 0x14 (Apparent Energy Fund)) | UINT32 | RO | 0xF60E:14, 32
1A32:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF60E (PMX Total Interval Energy Fundamental), entry 0x15 (Apparent Energy Positive Fund)) | UINT32 | RO | 0xF60E:15, 32
1A32:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF60E (PMX Total Interval Energy Fundamental), entry 0x16 (Apparent Energy Negative Fund)) | UINT32 | RO | 0xF60E:16, 32
1A32:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF60E (PMX Total Interval Energy Fundamental), entry 0x17 (Reactive Energy Fund)) | UINT32 | RO | 0xF60E:17, 32
1A32:0A | SubIndex 010 | 10. PDO Mapping entry (object 0xF60E (PMX Total Interval Energy Fundamental), entry 0x18 (Reactive Energy Positive Fund)) | UINT32 | RO | 0xF60E:18, 32
1A32:0B | SubIndex 011 | 11. PDO Mapping entry (object 0xF60E (PMX Total Interval Energy Fundamental), entry 0x19 (Reactive Energy Negative Fund)) | UINT32 | RO | 0xF60E:19, 32
Index 1A33 Total TxPDO-Map System Angles
Index (hex) | Name | Meaning | Data type | Flags | Default
1A33:0 | Total TxPDO-Map System Angles | PDO Mapping TxPDO 41 | UINT8 | RO | 0x05 (5dez)
1A33:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF60F (PMX Total System Angles), entry 0x11 (Voltage Angle L1L2)) | UINT32 | RO | 0xF60F:11, 32
1A33:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF60F (PMX Total System Angles), entry 0x12 (Voltage Angle L1L3)) | UINT32 | RO | 0xF60F:12, 32
1A33:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF60F (PMX Total System Angles), entry 0x13 (Current Angle L1)) | UINT32 | RO | 0xF60F:13, 32
1A33:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF60F (PMX Total System Angles), entry 0x14 (Current Angle L2)) | UINT32 | RO | 0xF60F:14, 32
1A33:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF60F (PMX Total System Angles), entry 0x15 (Current Angle L3)) | UINT32 | RO | 0xF60F:15, 32
Index 1A34 Total TxPDO-Map System
Index (hex) | Name | Meaning | Data type | Flags | Default
1A34:0 | Total TxPDO-Map System | PDO Mapping TxPDO 41 | UINT8 | RO | 0x03 (3dez)
1A34:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF610 (PMX Total System ), entry 0x11 (Positive Sequence)) | UINT32 | RO | 0xF610:11, 32
1A34:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF610 (PMX Total System ), entry 0x12 (Negative Sequence)) | UINT32 | RO | 0xF610:12, 32
1A34:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF610 (PMX Total System ), entry 0x13 (Zero Sequence)) | UINT32 | RO | 0xF610:13, 32
Index 1A35 Total TxPDO-Map Statistic Power Fundamental
Index (hex) | Name | Meaning | Data type | Flags | Default
1A35:0 | Total TxPDO-Map Statistic Power Fundamental | PDO Mapping TxPDO 39 | UINT8 | RO | 0x09 (9dez)
1A35:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF611 (PMX Total Statistic Power Fundamental), entry 0x10 (Active Power Avg Fund)) | UINT32 | RO | 0xF611:10, 32
1A35:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF611 (PMX Total Statistic Power Fundamental), entry 0x11 (Active Power Min Fund)) | UINT32 | RO | 0xF611:11, 32
1A35:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF611 (PMX Total Statistic Power Fundamental), entry 0x12 (Active Power Max Fund)) | UINT32 | RO | 0xF611:12, 32
1A35:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF611 (PMX Total Statistic Power Fundamental), entry 0x13 (Apparent Power Avg Fund)) | UINT32 | RO | 0xF611:13, 32
1A35:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF611 (PMX Total Statistic Power Fundamental), entry 0x14 (Apparent Power Min Fund)) | UINT32 | RO | 0xF611:14, 32
1A35:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF611 (PMX Total Statistic Power Fundamental), entry 0x15 (Apparent Power Max Fund)) | UINT32 | RO | 0xF611:15, 32
1A35:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF611 (PMX Total Statistic Power Fundamental), entry 0x16 (Reactive Power Avg Fund)) | UINT32 | RO | 0xF611:16, 32
1A35:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF611 (PMX Total Statistic Power Fundamental), entry 0x17 (Reactive Power Min)) | UINT32 | RO | 0xF611:17, 32
1A35:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF611 (PMX Total Statistic Power Fundamental), entry 0x18 (Reactive Power Max)) | UINT32 | RO | 0xF611:18, 32
Index 1C00 Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Length of this object | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RW | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RW | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RW | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RW | 0x04 (4dec)
Index 1C12 RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x01 (1dec)
1C12:01 | SubIndex 001 | 1. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1601 (5633dec)
Index 1C13 TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x0A (10dec)
1C13:01 | Subindex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A01 (6657dec)
1C13:03 | Subindex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A02 (6658dec)
1C13:04 | Subindex 004 | 4. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A0A (6666dec)
1C13:05 | Subindex 005 | 5. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A0B (6667dec)
1C13:06 | Subindex 006 | 6. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A0C (6668dec)
1C13:07 | Subindex 007 | 7. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A14 (6676dec)
1C13:08 | Subindex 008 | 8. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A15 (6677dec)
1C13:09 | Subindex 009 | 9. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A16 (6678dec)
1C13:0A | Subindex 010 | 10. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A1E (6686dec)
1C13:0B | Subindex 011 | 11. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0C | Subindex 012 | 12. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0D | Subindex 013 | 13. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0E | Subindex 014 | 14. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0F | Subindex 015 | 15. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:10 | Subindex 016 | 16. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:11 | Subindex 017 | 17. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:12 | Subindex 018 | 18. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:13 | Subindex 019 | 19. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:14 | Subindex 020 | 20. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:15 | Subindex 021 | 21. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:16 | Subindex 022 | 22. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:17 | Subindex 023 | 23. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:18 | Subindex 024 | 24. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:19 | Subindex 025 | 25. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:1A | Subindex 026 | 26. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:1B | Subindex 027 | 27. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:1C | Subindex 028 | 28. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:1D | Subindex 029 | 29. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:1E | Subindex 030 | 30. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:1F | Subindex 031 | 31. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:20 | Subindex 032 | 32. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:21 | Subindex 033 | 33. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:22 | Subindex 034 | 34. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:23 | Subindex 035 | 35. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:24 | Subindex 036 | 36. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:25 | Subindex 037 | 37. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:26 | Subindex 038 | 38. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:27 | Subindex 039 | 39. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:28 | Subindex 040 | 40. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:29 | Subindex 041 | 41. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 1C32 SM output parameter
Index | Name | Meaning | Data type | Flags | Default
1C32:0 | SM output parameter | Synchronization parameters for the outputs | UINT8 | RO | 0x20 (32dec)
1C32:01 | Sync mode | Current synchronization mode: 0: Free Run 1: Synchron with SM 2 Event 2: DC-Mode - Synchron with SYNC0 Event 3: DC-Mode - Synchron with SYNC1 Event | UINT16 | RW | 0x0000 (0dec)
1C32:02 | Cycle time | Cycle time (in ns): Free Run: Cycle time of the local timer Synchron with SM 2 Event: Master cycle time DC mode: SYNC0/SYNC1 Cycle Time | UINT32 | RW | 0x0016E360 (1500000dec)
1C32:03 | Shift time | Time between SYNC0 event and output of the outputs (in ns, DC mode only) | UINT32 | RO | 0x00000384 (900dec)
1C32:04 | Sync modes supported | Supported synchronization modes: Bit 0 = 1: free run is supported Bit 1 = 1: synchronous with SM 2 event is supported Bit 2-3 = 01: DC mode is supported Bit 4-5 = 10: Output shift with SYNC1 event (only DC mode) Bit 14 = 1: dynamic times (measurement through writing of 1C32:08) | UINT16 | RO | 0x0805 (2053dec)
1C32:05 | Minimum cycle time | Minimum cycle time (in ns) | UINT32 | RO | 0x0007A120 (500000dec)
1C32:06 | Calc and copy time | Minimum time between SYNC0 and SYNC1 event (in ns, DC mode only) | UINT32 | RO | 0x00000384 (900dec)
1C32:07 | Minimum delay time |  | UINT32 | RO | 0x00000384 (900dec)
1C32:08 | Command | 0: Measurement of the local cycle time is stopped 1: Measurement of the local cycle time is started The entries 1C32:03, 1C32:05, 1C32:06, 1C32:09, 1C33:03, 1C33:06, 1C33:09 are updated with the maximum measured values. For a subsequent measurement the measured values are reset | UINT16 | RW | 0x0000 (0dec)
1C32:09 | Maximum delay time | Time between SYNC1 event and output of the outputs (in ns, DC mode only) | UINT32 | RO | 0x00000384 (900dec)
1C32:0B | SM event missed counter | Number of missed SM events in OPERATIONAL (DC mode only) | UINT16 | RO | 0x0000 (0dec)
1C32:0C | Cycle exceeded counter | Number of occasions the cycle time was exceeded in OPERATIONAL (cycle was not completed in time or the next cycle began too early) | UINT16 | RO | 0x0000 (0dec)
1C32:0D | Shift too short counter | Number of occasions that the interval between SYNC0 and SYNC1 event was too short (DC mode only) | UINT16 | RO | 0x0000 (0dec)
Index 1C33 SM input parameter
Index (hex) | Name | Meaning | Data type | Flags | Default
1C33:0 | SM input parameter | Synchronization parameters for the inputs | UINT8 | RO | 0x20 (32dec)
1C33:01 | Sync mode | Current synchronization mode: 0: Free Run 1: Synchron with SM 3 Event (no outputs available) 2: DC - Synchron with SYNC0 Event 3: DC - Synchron with SYNC1 Event 34: Synchron with SM 2 event (outputs available) | UINT16 | RW | 0x0000 (0dec)
1C33:02 | Cycle time | as 1C32:02 | UINT32 | RW | 0x0016E360 (1500000dec)
1C33:03 | Shift time | Time between SYNC0 event and reading of the inputs (in ns, only DC mode) | UINT32 | RO | 0x00000384 (900dec)
1C33:04 | Sync modes supported | Supported synchronization modes: Bit 0: free run is supported Bit 1: Synchron with SM 2 Event is supported (outputs available) Bit 1: Synchron with SM 3 Event is supported (no outputs available) Bit 2-3 = 01: DC mode is supported Bit 4-5 = 01: Input shift through local event (outputs available) Bit 4-5 = 10: Input shift with SYNC1 event (no outputs available) Bit 14 = 1: dynamic times (measurement through writing of 1C32:08 or 1C33:08) | UINT16 | RO | 0x0805 (2053dec)
1C33:05 | Minimum cycle time | as 1C32:05 | UINT32 | RO | 0x0007A120 (500000dec)
1C33:06 | Calc and copy time | Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode) | UINT32 | RO | 0x0007A120 (500000dec)
1C33:07 | Minimum delay time |  | UINT32 | RO | 0x00000384 (900dec)
1C33:08 | Command | as 1C32:08 | UINT16 | RW | 0x0000 (0dec)
1C33:09 | Maximum delay time | Time between SYNC1 event and reading of the inputs (in ns, only DC mode) | UINT32 | RO | 0x00000384 (900dec)
1C33:0B | SM event missed counter | as 1C32:11 | UINT16 | RO | 0x0000 (0dec)
1C33:0C | Cycle exceeded counter | as 1C32:12 | UINT16 | RO | 0x0000 (0dec)
1C33:0D | Shift too short counter | as 1C32:13 | UINT16 | RO | 0x0000 (0dec)


Command object

Commissioning [image] Object description and parameterization [image] EL3453 [image] Command object
Command object
Index FB00 PMX Command
The command object is used for triggering an action in the terminal. The command is started by writing subindex 1 (request). Write access is disabled until the current command is completed.
Index (hex) | Name | Meaning |  | Data type | Flags | Default
FB00:0 | PM Command | Largest subindex of this object |  | UINT8 | RO | 0x03
FB00:01 | Request | Byte 0 - service request data |  | OCTET-STRING [2] | RW | 0x0000 (0dec)
 |  | 4hex | Clear energy
 |  | Byte 1 - channel selection
 |  | 00hex | all channels
 |  | 01hex | Channel 1
 |  | 02hex | Channel 2
 |  | 03hex | Channel 3
FB00:02 | Status | Byte 0 |  | UINT8 | RW | 0x00 (0dec)
 |  | reserved
FB00:03 | Response | Byte 0 |  | OCTET-STRING [2] | RW | 0x00000000 (0dec)
 |  | reserved
 |  | Byte 1
 |  | reserved
 |  | Byte 2-n
 |  | reserved


EL3483-00xx

Commissioning [image] Object description and parameterization [image] EL3483-00xx
EL3483-00xx
Additional information
•
Restore object
•
Configuration data
•
Configuration data (vendor-specific)
•
Input data
•
Information and diagnostic data
•
Standard objects
•
Command object


Restore object

Commissioning [image] Object description and parameterization [image] EL3483-00xx [image] Restore object
Restore object
Index 1011 Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default parameters | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to “0x64616F6C” in the set value dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)


Configuration data

Commissioning [image] Object description and parameterization [image] EL3483-00xx [image] Configuration data
Configuration data
Index 80n0 PMX settings (for ch.1, n = 0; ch.2, n = 1; ch.3, n = 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
80n0:0 | PMX Settings | Max. subindex | UINT8 | RO | 0x13 (19dec)
80n0:11 | Voltage Transformer Ratio | If a voltage transformer is used, its transmission ratio can be entered here. | REAL32 | RW | 0x3F800000 (1065353216dec)
Index 80n1 PMX Guard Settings (for ch.1, n = 0; ch.2, n = 1; ch.3, n = 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
80n1:0 | PMX Guard Settings | Max. subindex | UINT8 | RO | 0x14 (20dec)
80n1:11 | Voltage Guard Min Error | Lower limit value for a voltage error message | REAL32 | RW | 0x40000000 (1073741824dec)
80n1:12 | Voltage Guard Min Warning | Lower limit value for a voltage warning message | REAL32 | RW | 0x434F0000 (1129250816dec)
80n1:13 | Voltage Guard Max Warning | Upper limit value for a voltage warning message | REAL32 | RW | 0x437D0000 (1132265472dec)
80n1:14 | Voltage Guard Max Error | Upper limit value for a voltage error message | REAL32 | RW | 0x438B0000 (1133182976dec)
Index F800 PMX Settings
Index (hex) | Name | Meaning |  | Data type | Flags | Default
F800:0 | PMX Settings | Max. subindex |  | UINT8 | RO | 0x15 (21dec)
F800:01 | Reset Interval | Manual restart of the measurement and statistics interval |  | BOOLEAN | RW | 0x00 (0dec)
F800:12 | Measurement Range | Filter setting for determining the fundamental permitted values: |  | UINT32 | RW | 0x00000000 (0dec)
 |  | 0 | 25..65 Hz (default)
 |  | 1 | 25..400 Hz
 |  | 2 | 12..45 Hz
F800:13 | Frequency Source | Source of the system frequency permitted values: |  | BIT1 | RW | 0x00000000 (0dec)
 |  | 0 | Channel 1 (default)
 |  | 1 | Channel 2
 |  | 2 | Channel 3
F800:15 | Inaccurate Threshold Voltage | Limit value for the warning bit: Inaccurate Voltage |  | REAL32 | RW | 0x3FDC28F6 (1071393014dec)
Index F801 PMX Total Settings PQF
Index (hex) | Name | Meaning | Data type | Flags | Default
F801:0 | PMX Total Settings PQF | Max. subindex | UINT8 | RO | 0x13 (19dec)
F801:11 | Nominal voltage | A nominal voltage value or set value is required to calculate the power quality factor (for details see basic function principles). | REAL32 | RW | 0x43660000 (1130758144dec)
F801:12 | Nominal Frequency | A nominal frequency or set value is required to calculate the power quality factor (for details see basic function principles). | REAL32 | RW | 0x42480000 (1112014848dec)
F801:13 | PQF Dataset | permitted values: | UINT32 | RW | 0x00000001 (0dec)
 |  | 0: default 1: default + unbalace
Index F802 PMX Guard Settings
Index (hex) | Name | Meaning | Data type | Flags | Default
F802:0 | PMX Guard Settings | Max. subindex | UINT8 | RO | 0x28 (40dec)
F802:11 | Frequency Guard Min Error | Lower limit value for a frequency error message | REAL32 | RW | 0x423C0000 (1111228416dec)
F802:12 | Frequency Guard Min Warning | Lower limit value for a frequency warning message | REAL32 | RW | 0x42460000 (1111883776dec)
F802:13 | Frequency Guard Max Warning | Upper limit value for a frequency warning message | REAL32 | RW | 0x424A0000 (1112145920dec)
F802:14 | Frequency Guard Max Error | Upper limit value for a frequency error message | REAL32 | RW | 0x42500000 (1112539136dec)
F802:21 | PQF Guard Min Error | Lower limit value for a power quality factor error message | REAL32 | RW | 0x3D4CCCCD (1028443341dec)
F802:22 | PQF Guard Min Warning | Lower limit value for a power quality factor warning message | REAL32 | RW | 0x3F4CCCCD (1061997773dec)
F802:23 | PQF Guard Max Warning | Upper limit value for a power quality factor warning message | REAL32 | RW | 0x3F800000 (1065353216dec)
F802:24 | PQF Guard Max Error | Upper limit value for a power quality factor error message | REAL32 | RW | 0x3F800000 (1065353216dec)
F802:25 | Unbalance Guard Min Error | Lower limit value for an error message due to voltage imbalance | REAL32 | RW | 0x00000000 (0dec)
F802:26 | Unbalance Guard Min Warning | Lower limit value for a warning message due to voltage imbalance | REAL32 | RW | 0x00000000 (0dec)
F802:27 | Unbalance Guard Max Warning | Upper limit value for a warning message due to voltage imbalance | REAL32 | RW | 0x00000000 (0dec)
F802:28 | Unbalance Guard Max Error | Upper limit value for an error message due to voltage imbalance | REAL32 | RW | 0x00000000 (0dec)


Configuration data (vendor-specific)

Commissioning [image] Object description and parameterization [image] EL3483-00xx [image] Configuration data (vendor-specific)
Configuration data (vendor-specific)
Index 80nF PMX vendor data (for ch.1, n = 0; ch.2, n = 1; ch.3, n = 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
80nF:0 | PMX Vendor data | Max. subindex | UINT8 | RO | 0x13 (19dec)
80nF:11 | Calibration Voltage Offset | Value in V | REAL32 | RW | 0x00000000 (0dec)
80nF:12 | Calibration Voltage Gain | Factor (without unit) | REAL32 | RW | 0x3F800000 (1065353216dec)
80nF:13 | Calibration Voltage Phase Offset | Value in milliseconds | REAL32 | RW | 0x00000000 (0dec)


Input data

Commissioning [image] Object description and parameterization [image] EL3483-00xx [image] Input data
Input data
Index 60n0 PMX status (n = 0, 1, 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
60n0:0 | PMX Status | Max. subindex | UINT8 | RO | 0x10 (16dec)
60n0:01 | Voltage Sign Bit | Indicates the sign of the current sine wave voltage: 1 = U > 0V 0 = U < 0V | BOOLEAN | RO | 0x00 (0dec)
60n0:02 | Overvoltage | Maximum measurable voltage is exceeded. | BOOLEAN | RO | 0x00 (0dec)
60n0:03 | Overcurrent | Maximum measurable current is exceeded. | BOOLEAN | RO | 0x00 (0dec)
60n0:04 | Inaccurate Voltage | The measured voltage value is smaller than the value entered in CoE object "F800:15 Inaccurate Threshold Voltage". | BOOLEAN | RO | 0x00 (0dec)
60n0:05 | Inaccurate Current | The measured current value is smaller than the value entered in CoE object "F800:16 Inaccurate Threshold Current". | BOOLEAN | RO | 0x00 (0dec)
60n0:06 | Voltage Guard Warning | A warning limit of the voltage monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
60n0:07 | Voltage Guard Error | An error limit of the voltage monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
6000:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
Index 60n1*** PMX Basic (n = 0, 1, 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
60n1:0 | PMX Basic | Max. Subindex | UINT8 | RO | 0x11 (17dec)
60n1:11 | Voltage | RMS value of the voltage in V | REAL32 | RO | 0x00000000 (0dec)
***) only for EL3483-0060
Index F600 PMX Total Status
Index (hex) | Name | Meaning | Data type | Flags | Default
F600:0 | PMX Total Status | Max. subindex | UINT8 | RO | 0x11 (17dec)
F600:01 | System State | Overall system state (as a logical disjunction of voltage guard errors, phase sequence, overvoltage, overcurrent and frequency guard errors) | BOOLEAN | RO | 0x00 (0dec)
F600:02 | Grid Direction | Phase sequence L1 - L2 - L3 correctly detected (with clockwise 3-phase mains) | BOOLEAN | RO | 0x00 (0dec)
F600:03 | Frequency Guard Warning | A warning limit of the frequency monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:04 | Frequency Guard Error | An error limit of the frequency monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:05 | Neutral Current Guard Warning | A warning limit of the neutral conductor current monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:06 | Neutral Current Guard Error | An error limit of the neutral conductor current monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:07 | Active Power Guard Warning | A warning limit of the active power monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:08 | Active Power Guard Error | An error limit of the active power monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:09 | Apparent Power Guard Warning | A warning limit of the apparent power monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:0A | Apparent Power Guard Error | An error limit of the apparent power monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:0B | Power Quality Guard Warning | A warning limit of the PQF monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:0C | Power Quality Guard Error | An error limit of the PQF monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F600:0F | TxPDO State | TRUE for general error | BOOLEAN | RO | 0x00 (0dec)
F600:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
F600:11 | Power Quality Factor | Analog value of the voltage quality between 1.0 and 0 (see basic function principles - Power Quality Factor) | REAL32 | RO | 0x00000000 (0dec)
Index F602 PMX Total Advanced
Index (hex) | Name | Meaning | Data type | Flags | Default
F602:0 | PMX Total Advanced | Max. subindex | UINT8 | RO | 0x02 (2dec)
F602:01 | Unbalance Guard Warning | A warning limit of the unbalance monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)
F602:02 | Unbalance Guard Error | An error limit of the unbalance monitor has been breached. | BOOLEAN | RO | 0x00 (0dec)


Information and diagnostic data

Commissioning [image] Object description and parameterization [image] EL3483-00xx [image] Information and diagnostic data
Information and diagnostic data
Index A0n0 PMX Diag data (for ch.1, n = 0; ch.2, n = 1; ch.3, n = 2)
Index (hex) | Name | Meaning | Data type | Flags | Default
A0n0:0 | PMX diag data ch.1 | Max. subindex | UINT8 | RO | 0x11 (17dec)
A0n0:11 | Saturation Time Voltage | Time (in 0.1 ms) in which the terminal has measured an overvoltage. | UINT32 | RO | 0x00000000 (0dec)
Index F081 Download revision
Index (hex) | Name | Meaning | Data type | Flags | Default
F081:0 | Download revision | Max. subindex | UINT8 | RO | 0x01 (1dec)
F010:01 | Revision number | Configured revision of the terminal, (see note) | UINT32 | RW | 0x00000000 (0dec)
Index F80F PM Vendor data
Index (hex) | Name | Meaning | Data type | Flags | Default
F80F:0 | PMX Vendor data | Max. subindex | UINT8 | RO | 0x11 (17dec)
F80F:11 | Type | Vendor-specific data | UINT32 | RW | 0x00000000 (0dec)
Index F904 PMX Total Info data PQF
Index (hex) | Name | Meaning | Data type | Flags | Default
F904:0 | PMX Total Info data PQF | Max. subindex | UINT8 | RO | 0x13 (19dec)
F904:11 | PQF Avg | Average value of the power quality factor during the last interval | REAL32 | RO | 0x00000000 (0dec)
F904:12 | PQF Min | Minimum power quality factor in the last interval | REAL32 | RO | 0x00000000 (0dec)
F904:13 | PQF Max | Maximum power quality factor in the last interval | REAL32 | RO | 0x00000000 (0dec)
Index FA00 PMX Diag data
Index (hex) | Name | Meaning | Data type | Flags | Default
FA00:0 | PMX Diag data | Max. subindex | UINT8 | RO | 0x13 (19dec)
FA00:11 | Min CPU Die Temperature | Minimum CPU temperature measured so far | REAL32 | RO | 0x00000000 (0dec)
FA00:12 | Max CPU Die Temperature | Maximum CPU temperature measured so far | REAL32 | RO | 0x00000000 (0dec)
FA00:13 | EBUS Voltage | Current E-bus voltage | REAL32 | RO | 0x00000000 (0dec)


Standard objects

Commissioning [image] Object description and parameterization [image] EL3483-00xx [image] Standard objects
Standard objects
Standard objects (0x1000-0x1FFF)
The standard objects have the same meaning for all EtherCAT slaves.
Index 1000 Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x01551389 (22352777dec)
Index 1008 Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EL34xx
Index 1009 Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO |
Index 100A Software Version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO |
Index 100B Bootloader version
Index (hex) | Name | Meaning | Data type | Flags | Default
100B:0 | Bootloader version | Bootloader version | STRING | RO |
Index 1018 Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x0D9B3052 (228274258dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the low word (bit 0-15) indicates the special terminal number, the high word (bit 16-31) refers to the device description | UINT32 | RO | 0x00000000 (0dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the low byte (bit 0-7) of the low word contains the year of production, the high byte (bit 8-15) of the low word contains the week of production, the high word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 Backup parameter
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter | Length of this object | UINT8 | RO | 0x01
10F0:01 | Checksum | Checksum | UINT32 | RW | 0x00000000 (0dec)
Index 10F3 Diagnosis History
Index | Name | Meaning | Data type | Flags | Default
10F3:0 | Diagnosis History | Maximum subindex | UINT8 | RO | 0x15 (21dec)
10F3:01 | Maximum Messages | Maximum number of stored messages. A maximum of 50 messages can be stored | UINT8 | RO | 0x00 (0dec)
10F3:02 | Newest Message | Subindex of the latest message | UINT8 | RO | 0x00 (0dec)
10F3:03 | Newest Acknowledged Message | Subindex of the last confirmed message | UINT8 | RW | 0x00 (0dec)
10F3:04 | New Messages Available | Indicates that a new message is available | BOOLEAN | RO | 0x00 (0dec)
10F3:05 | Flags | not used | UINT16 | RW | 0x0000 (0dec)
10F3:06 | Diagnosis Message 001 | Message 1 | OCTET STRING[28] | RO | {0}
... | ... | ... | ... | ... | ...
10F3:15 | Diagnosis Message 016 | Message 16 | OCTET STRING[28] | RO | {0}
Index 10F8 Actual Time Stamp
Index | Name | Meaning | Data type | Flags | Default
10F8:0 | Actual Time Stamp | Time stamp | UINT64 | RO | 0x0000000000000000 (0dec)
Index 1App TxPDO-Map Status (for L1, pp = 00; L2, pp = 0A; L3, pp = 14)
Index (hex) | Name | Meaning | Data type | Flags | Default
1App:0 | TxPDO-Map Status | PDO Mapping TxPDO | UINT8 | RO | 0x09 (9dec)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x02 (Overvoltage)) | UINT32 | RO | 0x60n0:02, 1**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x03 (Overcurrent)) | UINT32 | RO | 0x60n0:03, 1**
1App:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x04 (Inaccurate Voltage)) | UINT32 | RO | 0x60n0:04, 1**
1App:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x05 (Inaccurate Current)) | UINT32 | RO | 0x60n0:05, 1**
1App:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x06 (Voltage Guard Warning)) | UINT32 | RO | 0x60n0:06, 1**
1App:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x07 (Voltage Guard Error)) | UINT32 | RO | 0x60n0:07, 1**
1App:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8**
1App:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x60n0:10, 1**
**) for L1, n = 0; L2, n = 1; L3, n = 2)
Index 1A01*** L1 TxPDO-Map Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1A01:0 | L1 TxPDO-Map Status | PDO Mapping TxPDO | UINT8 | RO | 0x01 (1dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (PMX Basic), entry 0x01 (Voltage)) | UINT32 | RO | 0x6001:11, 32
***) only for EL3483-0060
Index 1A0B*** L2 TxPDO-Map Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1A0B:0 | L2 TxPDO-Map Status | PDO Mapping TxPDO | UINT8 | RO | 0x01 (1dec)
1A0B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (PMX Basic), entry 0x01 (Voltage)) | UINT32 | RO | 0x6011:11, 32
***) only for EL3483-0060
Index 1A15*** L3 TxPDO-Map Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1A15:0 | L3 TxPDO-Map Status | PDO Mapping TxPDO | UINT8 | RO | 0x01 (1dec)
1A15:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6021 (PMX Basic), entry 0x01 (Voltage)) | UINT32 | RO | 0x6021:11, 32
***) only for EL3483-0060
Index 1A1E Total TxPDO-Map Total Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1A1E:0 | Total TxPDO-Map Total Status | PDO Mapping TxPDO 31 | UINT8 | RO | 0x10 (16dec)
1A1E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x01 (System State)) | UINT32 | RO | 0xF600:01, 1
1A1E:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x02 (Grid Direction)) | UINT32 | RO | 0xF600:02, 1
1A1E:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x03 (Frequency Guard Warning)) | UINT32 | RO | 0xF600:03, 1
1A1E:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x04 (Frequency Guard Error)) | UINT32 | RO | 0xF600:04, 1
1A1E:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x05 (Neutral Current Guard Warning)) | UINT32 | RO | 0xF600:05, 1
1A1E:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x06 (Neutral Current Guard Error)) | UINT32 | RO | 0xF600:06, 1
1A1E:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x07 (Active Power Guard Warning)) | UINT32 | RO | 0xF600:07, 1
1A1E:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x08 (Active Power Guard Error)) | UINT32 | RO | 0xF600:08, 1
1A1E:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x09 (Apparent Power Guard Warning)) | UINT32 | RO | 0xF600:09, 1
1A1E:0A | SubIndex 010 | 10. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x0A (Apparent Power Guard Error)) | UINT32 | RO | 0xF600:0A, 1
1A1E:0B | SubIndex 011 | 11. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x0B (Power Quality Guard Warning)) | UINT32 | RO | 0xF600:0B, 1
1A1E:0C | SubIndex 012 | 12. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x0C (Power Quality Guard Error)) | UINT32 | RO | 0xF600:0C, 1
1A1E:0D | SubIndex 013 | 13. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A1E:0E | SubIndex 014 | 14. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x0F (TxPDO State)) | UINT32 | RO | 0xF600:0F, 1
1A1E:0F | SubIndex 015 | 15. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0xF600:10, 1
1A1E:10 | SubIndex 016 | 16. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x11 (Power Quality Factor)) | UINT32 | RO | 0xF600:11, 32
Index 1A20 Total TxPDO-Map Total Advanced
Index (hex) | Name | Meaning | Data type | Flags | Default
1A20:0 | Total TxPDO-Map Total Advanced | PDO Mapping TxPDO 33 | UINT8 | RO | 0x03 (3dec)
1A20:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF602 (PMX Total Advanced), entry 0x01 (Unbalance Guard Warning)) | UINT32 | RO | 0xF602:01, 1
1A20:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF602 (PMX Total Advanced), entry 0x02 (Unbalance Guard Error)) | UINT32 | RO | 0xF602:02, 1
1A20:03 | SubIndex 003 | 3. PDO Mapping entry (14 bits align) | UINT32 | RO | 0x0000:00, 14
Index 1A24*** Total TxPDO-Map Total L-L Voltage
Index (hex) | Name | Meaning | Data type | Flags | Default
1A24:0 | Total TxPDO-Map Total L-L Voltage | PDO Mapping TxPDO 37 | UINT8 | RO | 0x03 (3dec)
1A24:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF609 (PMX Grid L-L Voltages), entry 0x11 (L1-L2 Voltage)) | UINT32 | RO | 0xF609:11, 32
1A24:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF609 (PMX Grid L-L Voltages), entry 0x12 (L2-L3 Voltage)) | UINT32 | RO | 0xF609:12, 32
1A24:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF609 (PMX Grid L-L Voltages), entry 0x13 (L3-L1 Voltage)) | UINT32 | RO | 0xF609:13, 32
***) only for EL3483-0060
Index 1C00 Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Length of this object | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RW | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RW | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RW | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RW | 0x04 (4dec)
Index 1C12 RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x00 (0dec)
Index 1C13 TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x04 (4dec)
1C13:01 | SubIndex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | SubIndex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A0A (6666dec)
1C13:03 | SubIndex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A14 (6676dec)
1C13:04 | SubIndex 004 | 4. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A1E (6686dec)
1C13:05 | SubIndex 005 | 5. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 1C33 SM input parameter
Index (hex) | Name | Meaning | Data type | Flags | Default
1C33:0 | SM input parameter | Synchronization parameters for the inputs | UINT8 | RO | 0x20 (32dec)
1C33:01 | Sync mode | Current synchronization mode: 0: Free Run 1: Synchron with SM 3 Event (no outputs available) 2: DC - Synchron with SYNC0 Event 3: DC - Synchron with SYNC1 Event 34: Synchron with SM 2 event (outputs available) | UINT16 | RW | 0x0000 (0dec)
1C33:02 | Cycle time | as 1C32:02 | UINT32 | RW | 0x0016E360 (1500000dec)
1C33:03 | Shift time | Time between SYNC0 event and reading of the inputs (in ns, only DC mode) | UINT32 | RO | 0x00000384 (900dec)
1C33:04 | Sync modes supported | Supported synchronization modes: Bit 0: free run is supported Bit 1: Synchron with SM 2 Event is supported (outputs available) Bit 1: Synchron with SM 3 Event is supported (no outputs available) Bit 2-3 = 01: DC mode is supported Bit 4-5 = 01: Input shift through local event (outputs available) Bit 4-5 = 10: Input shift with SYNC1 event (no outputs available) Bit 14 = 1: dynamic times (measurement through writing of 1C32:08 or 1C33:08) | UINT16 | RO | 0x0805 (2053dec)
1C33:05 | Minimum cycle time | as 1C32:05 | UINT32 | RO | 0x0007A120 (500000dec)
1C33:06 | Calc and copy time | Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode) | UINT32 | RO | 0x0007A120 (500000dec)
1C33:07 | Minimum delay time |  | UINT32 | RO | 0x00000384 (900dec)
1C33:08 | Command | as 1C32:08 | UINT16 | RW | 0x0000 (0dec)
1C33:09 | Maximum delay time | Time between SYNC1 event and reading of the inputs (in ns, only DC mode) | UINT32 | RO | 0x00000384 (900dec)
1C33:0B | SM event missed counter | as 1C32:11 | UINT16 | RO | 0x0000 (0dec)
1C33:0C | Cycle exceeded counter | as 1C32:12 | UINT16 | RO | 0x0000 (0dec)
1C33:0D | Shift too short counter | as 1C32:13 | UINT16 | RO | 0x0000 (0dec)
Index F000 Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | Largest subindex of this object | UINT8 | RO | 0x02
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RW | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RW | 0x0003 (3dec)
Index F008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dec)
Code Word
The vendor reserves the authority for the basic calibration of the terminals. The code word is therefore at present reserved.
Index F010 Module List
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list |  | UINT8 | RW | 0x03 (3dec)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x00000155 (341dec)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x00000155 (341dec)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x00000155 (341dec)


Command object

Commissioning [image] Object description and parameterization [image] EL3483-00xx [image] Command object
Command object
Index FB00 PMX Command
The command object is used for triggering an action in the terminal. The command is started by writing subindex 1 (request). Write access is disabled until the current command is completed.
Index (hex) | Name | Meaning |  | Data type | Flags | Default
FB00:0 | PM Command | Largest subindex of this object |  | UINT8 | RO | 0x03
FB00:01 | Request | Byte 0 - service request data |  | OCTET-STRING [2] | RW | 0x0000 (0dec)
 |  | 4hex | Clear energy
 |  | Byte 1 - channel selection
 |  | 00hex | all channels
 |  | 01hex | Channel 1
 |  | 02hex | Channel 2
 |  | 03hex | Channel 3
FB00:02 | Status | Byte 0 |  | UINT8 | RW | 0x00 (0dec)
 |  | reserved
FB00:03 | Response | Byte 0 |  | OCTET-STRING [2] | RW | 0x00000000 (0dec)
 |  | reserved
 |  | Byte 1
 |  | reserved
 |  | Byte 2-n
 |  | reserved


Application examples

Application examples
Application examples
Additional information
•
Power measurement on motor with 2 or 3 current transformers
•
Power measurement at a machine
•
Power measurement in a single-phase mains network
•
Power measurement at a fieldbus station
•
Power measurement at three-phase motors controlled by a frequency converter
•
Power measurement on loads with phase-to-phase voltages
•
Power measurement including differential current measurement
•
Example Function Blocks for Evaluation
•
Example Function Blocks for evaluation using the PLC data types
•
Example program for distributed power measurement


Power measurement on motor with 2 or 3 current transformers

Application examples [image] Power measurement on motor with 2 or 3 current transformers
Power measurement on motor with 2 or 3 current transformers
SmallWarningYellow WARNING
WARNING: Risk of electric shock!
If you do not connect terminal point N with the neutral conductor of your mains supply, you have to earth terminal point N, in order to avoid dangerous overvoltages in the event of a fault with a current transformer!
Note
Attention! Risk of device damage!
Avoid confusing the current and voltage circuit during connection, since the direct connection of mains voltage to the terminal points for the current transformers (typical input resistance 220 mΩ) would destroy the power measurement terminal!
EL3443
▪
The voltage is measured via the connections L1, L2 and L3.
▪
The current is measured with two current transformers (e.g. the SCT series from Beckhoff) via the connections IL1 and IL2.
▪
The sum of all currents in the 3-phase mains network is 0. The value in circuit IL3 can be obtained accordingly by wiring the EL3443.
EL3443, Power measurement with 2 current transformers on a motor
In the circuit shown above (Fig. EL3443, power measurement with 2 current transformers on a motor), ensure that the three-phase system is either earth-free or has an earthed star point. Alternatively a transformer can be included in a Yy0 circuit.
EL3453
▪
The voltage is measured via the connections L1, L2 and L3.
▪
The current is measured with three current transformers e.g. the SCT series from Beckhoff) via the connections IL1, IL2.and IL3
EL3453, Power measurement with 3 current transformers on a motor
In the circuit shown above (Fig. EL3453, Power measurement with 3 current transformers on a motor), ensure that the three-phase system is either earth-free or has an earthed star point. Alternatively a transformer can be included in a Yy0 circuit.


Power measurement at a machine

Application examples [image] Power measurement at a machine
Power measurement at a machine
SmallWarningYellow WARNING
WARNING: Risk of electric shock!
Bring the Bus Terminal system into a safe, voltage-free state before starting mounting, disassembly or wiring of the Bus Terminals!
Note
Attention! Risk of device damage!
Avoid confusing the current and voltage circuit during connection, since the direct connection of mains voltage to the terminal points for the current transformers (typical input resistance 100 mΩ) would destroy the power measurement terminal!
EL3443
▪
The voltage is measured via connections L1, L2, L3 and N.
▪
The current is measured via three current transformers (e.g. from the Beckhoff SCT series) and the connections IL1, IL2, IL3 and IN (star point of the current transformers).
EL3443, power measurement at a machine
**) PE as star point for 3-phase systems without neutral line
Depending on the current transformers used, PE must be connected as star point in 3-phase systems without neutral line as shown in Fig. “EL3443, power measurement at a machine ".
Observe the regulations of the manufacturer of the current transformers!
Negative power values
If negative power values are measured on a circuit, please check whether the associated current transformer circuit is connected correctly.
EL3453
▪
The voltage is measured via connections L1, L2, L3 and N.
▪
The current is measured via 4 current transformers (e.g. from the Beckhoff SCT series) and the connections IL1, IL2, IL3 and IN (star point of the current transformers).
EL3453, power measurement at a machine
Negative power values
If negative power values are measured on a circuit, please check whether the associated current transformer circuit is connected correctly.


Power measurement in a single-phase mains network

Application examples [image] Power measurement in a single-phase mains network
Power measurement in a single-phase mains network
▪
The voltage is measured via connections L1, L2, L3 and N.
▪
The current is measured via three current transformers (e.g. the SCT series from Beckhoff) and the connections IL1, IL2, IL3 and IN (star point of the current transformers).
SmallWarningYellow WARNING
WARNING: Risk of electric shock!
Bring the Bus Terminal system into a safe, voltage-free state before starting mounting, disassembly or wiring of the Bus Terminals!
Note
Attention! Risk of device damage!
Avoid confusing the current and voltage circuit during connection, since the direct connection of mains voltage to the terminal points for the current transformers (typical input resistance 220 mΩ) would destroy the power measurement terminal!
Power measurement in a single-phase mains network


Power measurement at a fieldbus station

Application examples [image] Power measurement at a fieldbus station
Power measurement at a fieldbus station
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminal system into a safe, voltage-free state before starting mounting, disassembly or wiring of the Bus Terminals!
The example illustrates power measurement at three circuits of the fieldbus station. The terminal measures the:
▪
Power consumption of the Bus Coupler and E-bus supply
▪
Power consumption of the power contacts
▪
Power consumption AS-i over the AS-i potential feed terminal (EL9520)
Note
Note rated current!
In the example, the special type EL3443-0010 is used with an extended current measuring range (5 A max.). The standard EL3443 type is not suitable for this application example because the current measuring range is too small (1 A)!
Application example - power measurement at a fieldbus station


Power measurement at three-phase motors controlled by a frequency converter

Application examples [image] Power measurement at three-phase motors controlled by a frequency converter
Power measurement at three-phase motors controlled by a frequency converter
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminal system into a safe, voltage-free state before starting mounting, disassembly or wiring of the Bus Terminals!
The example illustrates power measurement at several three-phase motors that are controlled by a frequency converter (AC converter), e.g. at a conveyor system. Each motor is monitored by a EL3443.
Application example with frequency converter
The electrical isolation of the three-phase-transformer (Yy0) operated by the voltage circuit of the power measurement terminals enables measurement after the frequency converter.
Measuring error in the lower frequency range
If the power measurement takes place after the frequency converter, a larger measuring error is possible in the lower frequency range, particularly for voltage measurement. This error also affects the power calculation.
The three-phase transformer should have a ratio of 1:1. It must not cause a phase shift of the signal! Since high-frequency components only have little influence on the motors, any distortions caused by the three-phase transformer have little effect on the practical measurement during the transfer of the harmonics created by the frequency converter.
The power distribution is mapped very well by using a dedicated power measurement terminal for each motor. Excessive current consumption of an individual motor can be detected in good time.
It is not possible to use this method for measuring direct voltage/DC (e.g. holding currents of synchronous motors)! Practical results can be obtained for voltages/currents with a frequency above 12 Hz, depending on the three-phase transformer and current transformers used.
SmallWarningYellow CAUTION
The terminal points N must be grounded!
Due to the electrical isolation through the three-phase transformer, the terminal points N of the power measurement terminals have to be grounded, in order to avoid dangerous overvoltages in the event of a fault in a current transformer!


Power measurement on loads with phase-to-phase voltages

Application examples [image] Power measurement on loads with phase-to-phase voltages
Power measurement on loads with phase-to-phase voltages
In some cases it may be useful, for the purpose of increasing the power, to operate some consumers in a three-phase network with the phase-to-phase voltage. As this is larger than the phase voltages by a factor of √3, the power also increases by a factor of √3 with the same current or, as the case may be, the same power can be achieved with a lower current.
When using the EL3443 and EL3453, the limitation of the maximum measuring voltage between ULx and N has been taken into account. The technical measuring range of the EL3453 is approx. 130% larger than the nominal measuring range. Therefore, phase-to-phase voltages of up to 277 V can be measured with the EL3443, and nominally up to 400 V and technically up to 520 V with the EL3453. In the case of the EL3453, the maximum time for voltages above 500 V must be taken into account if the nominal measuring range is exceeded (see Technical data).
As standard, the EL3443 and EL3453 measure the phase voltages and currents. If wired correctly, however, the phase-to-phase voltages and the currents through the connected consumers can also be measured and the associated power values calculated. In order to measure the voltage and current correctly and thus to determine the correct power values, the EL3443 or EL3453 respectively must be wired as follows:
EL3443
EL3443 – wiring for measurement of the phase-to-phase voltage
The phase-to-phase voltage between L1 and L2 is measured on the terminal between L1 and N. The voltage of phase L2 is thus the reference potential for phase L1 in order to be able to measure the voltage between the phases.
The current is measured between the current measuring channel for the first phase and the current measuring channel for N or the reference point respectively. When the current between L1 and L2 is measured, the terminal expects the current of phase L1. In a setup with only one consumer, this corresponds to the current that flows through the consumer. If there are several consumers, however, the current is divided at each node accordingly.
EL3453
EL3453 – wiring for measurement of the phase-to-phase voltage
The phase-to-phase voltage between L1 and L2 is measured on the terminal between L1 and N. The voltage of phase L2 is thus the reference potential for phase L1 in order to be able to measure the voltage between the phases.
The current to be measured is the current through the consumer. This is the current that flows from phase 1 through the consumer to phase 2. Using a current transformer, this current can be measured differentially with the EL3453 on the current measuring channel IL1, so that the associated power and energy values can be calculated.


Power measurement including differential current measurement

Application examples [image] Power measurement including differential current measurement
Power measurement including differential current measurement
▪
The voltage is measured via connections L1, L2, L3 and N.
▪
The current is measured via three or four current transformers (e.g. the SCT series from Beckhoff) and the connections IL1, IL1’, IL2, IL2’, IL3, IL3’ and IN, IN’.
SmallWarningYellow WARNING
WARNING: Risk of electric shock!
Bring the Bus Terminal system into a safe, voltage-free state before starting mounting, disassembly or wiring of the Bus Terminals!
Common wiring of the EL3453 power measurement terminal
In the following diagram, the current measuring channel IN is used to measure the neutral conductor current.
Conventional converter arrangement for the EL3453 power measurement terminal including neutral conductor measurement
Diagram of a different transducer arrangement for direct measurement of the differential current:
Transformer configuration of the EL3453 for differential current measurement
The secondary current path of the differential current transformer must be connected to the terminal contacts IN (and IN').
For correct calculation of the differential current value, the corresponding transformer ratio must be entered in CoE object 0xF804:12.
Example: Transformer ratio 1A:50A corresponds to value to be entered 0.02


Example Function Blocks for Evaluation

Application examples [image] Example Function Blocks for Evaluation
Example Function Blocks for Evaluation
Example Function Blocks
The example function block presented here takes over the complete reading of all available values from the EL3443 or EL3453 power measurement terminals and stores them in a STRUCT provided for this purpose:
Representation STRUCT
To be able to use the function block
▪
the predefined PDO assignment "Dafault + Variant" must be selected under "Process Data" for the terminal
Selection of predefined PDO Assignment "Dafault + Variant"
▪
after downloading (see below) and importing PLCopenXML
Import of PLCopenXML
▪
the function block variables must be linked to the corresponding terminal PDOs.
Linking of variables
View in Structure Tree
After activating and starting, all values in the overall structure are to be read out:
View of the overall structure
Reading the terminal information
By multiplexing the over 400 (EL3443) or 600 values (EL3453), the complete reading of the terminal information requires several PLC cycles.
If the application requires individual values more rapidly, these should be read out directly via the corresponding PDOs cycle-currently.


Example Function Blocks for evaluation using the PLC data types

Application examples [image] Example Function Blocks for evaluation using the PLC data types
Example Function Blocks for evaluation using the PLC data types
Example function block (FB_example_evaliation)
The example function block for the EL3443 and EL3453 that is described here has the same function as the function block that is described in the chapter Example function blocks for evaluation. This example function block differs from the function block from the previous chapter in that a structure is generated here from all mapped PDOs, which can be linked to the PLC. This means that fewer variables have to be linked. For each energy and power measurement terminal only one variable has to be linked to the hardware.
Furthermore, in this example function block, unlike the function block from the previous chapter, all variables that are present in both the PDOs and the Variant Values are read out via the PDOs, so that these values are updated every cycle. Due to the multiplexing of the values in the Variant Values, the reading of the terminal information requires several PLC cycles. Cyclic reading of all possible data from the PDOs reduces the time required for complete readout. Compared with multiplexing over several cycles, cyclical reading of the PDOs also makes it easier to detect peak values of variables. The following figure shows a scope recording of the power factor in comparison with the example function blocks for evaluation from the previous chapter and the example function block from this chapter.
Comparison of the PDOs with values from the Variant Value
This block also handles the complete reading of the available values from the EL3443 and EL3453 power measurement terminals and stores them in a STRUCT provided for this purpose:
STRUCT representation
To use the function module
▪
the predefined PDO assignment "Default + Variant" under "Process Data" for the terminal must be selected.
Selection predefined PDO assignment "Default + Variant"
▪
Then the PLC data type (structure from the process data) must be activated in the "PLC" tab.
Activate the PLC data type
▪
After downloading the sample function block it may be added to the PLC project.
Import of the PLCopenXML
▪
You can then create and call an instance of the added function module in MAIN.
Exemplary instance of FB EL3443 in the MAIN
▪
Then the process data structure from the PLC must be linked to the hardware.
Variable for linking
Linking the structure to the hardware
▪
After activating and starting, all values in the overall structure must then be read out:
View of the complete structure


Example program for distributed power measurement

Application examples [image] Example program for distributed power measurement
Example program for distributed power measurement
Example program
Using the EL3446 6-channel current input terminal in conjunction with the EL3443 3-phase power measurement terminal, effective power values can be provided even when voltage and current measurements are physically separated. The application example presented here shows distributed power measurement (DPM) with the two input terminals. For DPM, one EL3443 is required once per network to provide voltage measurement values. The current is then fed into the EL3446 via current transformers. In the application example, all data required for power measurement are transferred from the EL3443 to the EL3446 in order to be able to calculate the power values with the measured current values.
The variables are linked to the hardware via a structure consisting of all mapped PDOs, so that there is only one variable for linking per measuring terminal.
Structure generation with PLC Data Type
The function of the PLC data type for creating a structure from the process data is only available in TwinCAT 3 from version V3.1.4024.4.
The measured values of the EL3443 and EL3446 are read from the Variant Values and PDOs via a function block and stored in a STRUCT provided for this purpose. The data from the EL3443 required for DPM are then transferred to the EL3446 in the example program so that power and energy values can be calculated.
Distributed Power Management with the EL3443
DPM with the EL3443 is only available from revision 0021.


Appendix

Appendix
Appendix
Additional information
•
TcEventLogger and IO
•
EtherCAT AL Status Codes
•
Firmware compatibility
•
Firmware Update EL/ES/EM/ELM/EPxxxx
•
Restoring the delivery state
•
Support and Service


TcEventLogger and IO

Appendix [image] TcEventLogger and IO
TcEventLogger and IO
The TwinCAT 3 EventLogger provides an interface for the exchange of messages between TwinCAT components and non-TwinCAT components.
Schematic representation TCEventLogger
Refer to the explanations in the TwinCAT EventLogger documentation, e.g. in the Beckhoff InfoSys https://infosys.beckhoff.com/ → TwinCAT 3 → TE1000 XAE → Technologies → EventLogger.
The EventLogger saves to a local database under ..\TwinCAT\3.1\Boot\LoggedEvents.db and, unlike the VisualStudio Error Window, is designed for continuous recording.
IO devices can also be a source of messages. If so-called DiagMessages are generated in the IO device, they can be collected by TwinCAT over EtherCAT and displayed in the TcEventLogger with the appropriate device setting. This facilitates the central management of events that hinder operation, as a textual diagnosis no longer needs to be programmed out in the application for each individual IO device. The messages/events can be displayed directly in the TwinCAT HMI, for example, and thus facilitate the diagnosis.
Notes:
▪
This feature is supported from TwinCAT 3.1 build 4022.16.
▪
TwinCAT may be in the RUN or CONFIG mode
▪
On the manufacturer side, the IO device regarded must (1) generate local DiagMessages and (2) be fundamentally capable of transmitting them as events over EtherCAT. This is not the case with all EtherCAT IO devices/terminals/boxes from Beckhoff.
The messages managed by the EventLogger can be output in or read from
▪
the HMI → EventGrid
▪
C#
▪
the PLC
▪
TwinCAT Engineering → Logged Events
The use of the EventLogger with EtherCAT IO with TwinCAT 3.1 build 4022.22 during commissioning is explained below.
▪
The EventLogger window may need to be displayed in the TwinCAT Engineering
Display EventLogger window
▪
Some DiagMessages and the resulting Logged Events are shown below, taking an ELM3602-0002 as an example
Display DiagMessages and Logged Events
▪
Filtering by entries and language is possible in the Logger window.
German: 1031
English: 1033
Setting filter language
▪
If an EtherCAT slave is enabled by default to transmit DiagMessages as events over EtherCAT, this can be activated/deactivated for each individual slave in the CoE 0x10F3:05. TRUE means that the slave provides events for collection via EtherCAT, while FALSE deactivates the function.
Activating/deactivating event transmission
▪
In the respective EtherCAT slave, various "causes" can lead to it transmitting DiagMessages or events. If only some of these are to be generated, you can read in the device documentation whether and how individual causes can be deactivated, e.g. through CoE settings.
▪
Settings for the TwinCAT EventLogger can be found under Tools/Options
Settings TwinCAT EventLogger


EtherCAT AL Status Codes

Appendix [image] EtherCAT AL Status Codes
EtherCAT AL Status Codes
For detailed information please refer to the EtherCAT system description.


Firmware compatibility

Appendix [image] Firmware compatibility
Firmware compatibility
Beckhoff EtherCAT devices are delivered with the latest available firmware version. Compatibility of firmware and hardware is mandatory; not every combination ensures compatibility. The overview below shows the hardware versions on which a firmware can be operated.
Note
▪
It is recommended to use the newest possible firmware for the respective hardware
▪
Beckhoff is not under any obligation to provide customers with free firmware updates for delivered products.
Note
Risk of damage to the device!
Pay attention to the instructions for firmware updates on the separate page.
If a device is placed in BOOTSTRAP mode for a firmware update, it does not check when downloading whether the new firmware is suitable.
This can result in damage to the device! Therefore, always make sure that the firmware is suitable for the hardware version!
EL3423
Hardware (HW) | Firmware | Revision no. | Date of release
01* | 01 | EL3423-0000-0016 | 2018/06
 | 02 | EL3423-0000-0017 | 2018/08
 | 03 | EL3423-0000-0018 | 2018/12
 | 04 |  | 2019/01
 |  | EL3423-0000-0019 | 2019/01
 | 05 | EL3423-0000-0020 | 2019/03
 | 06* |  | 2019/05
EL3443-0000
Hardware (HW) | Firmware | Revision no. | Date of release
01 - 02* | 01 | EL3443-0000-0016 | 2018/06
 | 02 | EL3443-0000-0017 | 2018/08
 | 03 | EL3443-0000-0018 | 2018/12
 | 04 |  | 2019/01
 |  | EL3443-0000-0019 | 2019/01
 | 05 | EL3443-0000-0020 | 2019/03
 | 06* |  | 2019/05
EL3443-0010
Hardware (HW) | Firmware | Revision no. | Date of release
01 - 02* | 01 | EL3443-0010-0016 | 2018/06
 | 02 | EL3443-0010-0017 | 2018/08
 | 03 | EL3443-0010-0018 | 2018/12
 | 04 |  | 2019/01
 |  | EL3443-0010-0019 | 2019/01
 | 05 | EL3443-0010-0020 | 2019/03
 | 06* |  | 2019/05
EL3443-0011
Hardware (HW) | Firmware | Revision no. | Date of release
00 – 01* | 03 | EL3443-0011-0018 | 2018/12
 | 04 |  | 2019/01
 |  | EL3443-0011-0019 | 2019/01
 | 05 | EL3443-0011-0020 | 2019/03
 | 06* |  | 2019/07
EL3443-0013
Hardware (HW) | Firmware | Revision no. | Date of release
00 - 01* | 03 | EL3443-0013-0018 | 2018/12
 | 04 |  | 2019/01
 |  | EL3443-0013-0019 | 2019/01
 | 05 | EL3443-0013-0020 | 2019/03
 | 06* |  | 2019/07
EL3446
Hardware (HW) | Firmware | Revision no. | Date of release
00* | 01* | EL3446-0000-0016 | 2019/11
EL3453, EL3453-0100
Hardware (HW) | Firmware | Revision no. | Date of release
00 - 01 |  | EL3453-0000-0016 | 2018/07
 | 01 | EL3453-0000-0017 | 2018/12
 | 02 | EL3453-0000-0018 | 2019/02
01 – 04* | 03 |  | 2019/05
 | 04 | EL3453-0000-0019 | 2019/10
 | 05 |  | 2019/12
 | 06 | EL3453-0010-0020 | 2019/12
 | 07* |  | 2020/05
EL3483, EL3483-0060
Hardware (HW) | Firmware | Revision no. | Date of release
01 - 02* | 01 | EL3483-0000-0016 | 2018/06
 | 02 | EL3483-0000-0017 | 2018/08
 | 03 | EL3483-0000-0018 | 2018/12
 | 04 |  | 2019/01
 |  | EL3483-0000-0019 | 2019/01
 | 05 | EL3483-0000-0020 | 2019/03
 | 06* |  | 2019/05
*) This is the current compatible firmware/hardware version at the time of the preparing this documentation. Check on the Beckhoff web page whether more up-to-date documentation is available.


Firmware Update EL/ES/EM/ELM/EPxxxx

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx
Firmware Update EL/ES/EM/ELM/EPxxxx
This section describes the device update for Beckhoff EtherCAT slaves from the EL/ES, ELM, EM, EK and EP series. A firmware update should only be carried out after consultation with Beckhoff support.
Storage locations
An EtherCAT slave stores operating data in up to 3 locations:
▪
Depending on functionality and performance EtherCAT slaves have one or several local controllers for processing I/O data. The corresponding program is the so-called firmware in *.efw format.
▪
In some EtherCAT slaves the EtherCAT communication may also be integrated in these controllers. In this case the controller is usually a so-called FPGA chip with *.rbf firmware.
▪
In addition, each EtherCAT slave has a memory chip, a so-called ESI-EEPROM, for storing its own device description (ESI: EtherCAT Slave Information). On power-up this description is loaded and the EtherCAT communication is set up accordingly. The device description is available from the download area of the Beckhoff website at (https://www.beckhoff.de). All ESI files are accessible there as zip files.
Customers can access the data via the EtherCAT fieldbus and its communication mechanisms. Acyclic mailbox communication or register access to the ESC is used for updating or reading of these data.
The TwinCAT System Manager offers mechanisms for programming all 3 parts with new data, if the slave is set up for this purpose. Generally the slave does not check whether the new data are suitable, i.e. it may no longer be able to operate if the data are unsuitable.
Simplified update by bundle firmware
The update using so-called bundle firmware is more convenient: in this case the controller firmware and the ESI description are combined in a *.efw file; during the update both the firmware and the ESI are changed in the terminal. For this to happen it is necessary
▪
for the firmware to be in a packed format: recognizable by the file name, which also contains the revision number, e.g. ELxxxx-xxxx_REV0016_SW01.efw
▪
for password=1 to be entered in the download dialog. If password=0 (default setting) only the firmware update is carried out, without an ESI update.
▪
for the device to support this function. The function usually cannot be retrofitted; it is a component of many new developments from year of manufacture 2016.
Following the update, its success should be verified
▪
ESI/Revision: e.g. by means of an online scan in TwinCAT ConfigMode/FreeRun – this is a convenient way to determine the revision
▪
Firmware: e.g. by looking in the online CoE of the device
Note
Risk of damage to the device!
Note the following when downloading new device files

• Firmware downloads to an EtherCAT device must not be interrupted
• Flawless EtherCAT communication must be ensured. CRC errors or LostFrames must be avoided.
• The power supply must adequately dimensioned. The signal level must meet the specification.

In the event of malfunctions during the update process the EtherCAT device may become unusable and require re-commissioning by the manufacturer.
Additional information
•
Device description ESI file/XML
•
Firmware explanation
•
Updating controller firmware *.efw
•
FPGA firmware *.rbf
•
Simultaneous updating of several EtherCAT devices


Device description ESI file/XML

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Device description ESI file/XML
Device description ESI file/XML
Note
Attention regarding update of the ESI description/EEPROM
Some slaves have stored calibration and configuration data from the production in the EEPROM. These are irretrievably overwritten during an update.
The ESI device description is stored locally on the slave and loaded on start-up. Each device description has a unique identifier consisting of slave name (9 characters/digits) and a revision number (4 digits). Each slave configured in the System Manager shows its identifier in the EtherCAT tab:
Device identifier consisting of name EL3204-0000 and revision -0016
The configured identifier must be compatible with the actual device description used as hardware, i.e. the description which the slave has loaded on start-up (in this case EL3204). Normally the configured revision must be the same or lower than that actually present in the terminal network.
For further information on this, please refer to the EtherCAT system documentation.
Update of XML/ESI description
The device revision is closely linked to the firmware and hardware used. Incompatible combinations lead to malfunctions or even final shutdown of the device. Corresponding updates should only be carried out in consultation with Beckhoff support.
Display of ESI slave identifier
The simplest way to ascertain compliance of configured and actual device description is to scan the EtherCAT boxes in TwinCAT mode Config/FreeRun:
Scan the subordinate field by right-clicking on the EtherCAT device
If the found field matches the configured field, the display shows
Configuration is identical
otherwise a change dialog appears for entering the actual data in the configuration.
Change dialog
In this example in Fig. Change dialog, an EL3201-0000-0017 was found, while an EL3201-0000-0016 was configured. In this case the configuration can be adapted with the Copy Before button. The Extended Information checkbox must be set in order to display the revision.
Changing the ESI slave identifier
The ESI/EEPROM identifier can be updated as follows under TwinCAT:
▪
Trouble-free EtherCAT communication must be established with the slave.
▪
The state of the slave is irrelevant.
▪
Right-clicking on the slave in the online display opens the EEPROM Update dialog, Fig. EEPROM Update
EEPROM Update
The new ESI description is selected in the following dialog, see Fig. Selecting the new ESI. The checkbox Show Hidden Devices also displays older, normally hidden versions of a slave.
Selecting the new ESI
A progress bar in the System Manager shows the progress. Data are first written, then verified.
The change only takes effect after a restart.
Most EtherCAT devices read a modified ESI description immediately or after startup from the INIT. Some communication settings such as distributed clocks are only read during power-on. The EtherCAT slave therefore has to be switched off briefly in order for the change to take effect.


Firmware explanation

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Firmware explanation
Firmware explanation
Determining the firmware version
Determining the version on laser inscription
Beckhoff EtherCAT slaves feature serial numbers applied by laser. The serial number has the following structure: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with ser. no.: 12 10 03 02:
12 - week of production 12
10 - year of production 2010
03 - firmware version 03
02 - hardware version 02
Determining the version via the System Manager
The TwinCAT System Manager shows the version of the controller firmware if the master can access the slave online. Click on the E-Bus Terminal whose controller firmware you want to check (in the example terminal 2 (EL3204)) and select the tab CoE Online (CAN over EtherCAT).
CoE Online and Offline CoE
Two CoE directories are available:
• online: This is offered in the EtherCAT slave by the controller, if the EtherCAT slave supports this. This CoE directory can only be displayed if a slave is connected and operational.
• offline: The EtherCAT Slave Information ESI/XML may contain the default content of the CoE. This CoE directory can only be displayed if it is included in the ESI (e.g. "Beckhoff EL5xxx.xml").
The Advanced button must be used for switching between the two views.
In Fig. Display of EL3204 firmware version the firmware version of the selected EL3204 is shown as 03 in CoE entry 0x100A.
Display of EL3204 firmware version
In (A) TwinCAT 2.11 shows that the Online CoE directory is currently displayed. If this is not the case, the Online directory can be loaded via the Online option in Advanced Settings (B) and double-clicking on AllObjects.


Updating controller firmware *.efw

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Updating controller firmware *.efw
Updating controller firmware *.efw
CoE directory
The Online CoE directory is managed by the controller and stored in a dedicated EEPROM, which is generally not changed during a firmware update.
Switch to the Online tab to update the controller firmware of a slave, see Fig. Firmware Update.
Firmware Update
Proceed as follows, unless instructed otherwise by Beckhoff support. Valid for TwinCAT 2 and 3 as EtherCAT master.
▪
Switch TwinCAT system to ConfigMode/FreeRun with cycle time >= 1 ms (default in ConfigMode is 4 ms). A FW-Update during real time operation is not recommended.
▪
Switch EtherCAT Master to PreOP
▪
Switch slave to INIT (A)
▪
Switch slave to BOOTSTRAP
▪
Check the current status (B, C)
▪
Download the new *efw file (wait until it ends). A pass word will not be neccessary usually.
▪
After the download switch to INIT, then PreOP
▪
Switch off the slave briefly (don't pull under voltage!)
▪
Check within CoE 0x100A, if the FW status was correctly overtaken.


FPGA firmware *.rbf

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] FPGA firmware *.rbf
FPGA firmware *.rbf
If an FPGA chip deals with the EtherCAT communication an update may be accomplished via an *.rbf file.
▪
Controller firmware for processing I/O signals
▪
FPGA firmware for EtherCAT communication (only for terminals with FPGA)
The firmware version number included in the terminal serial number contains both firmware components. If one of these firmware components is modified this version number is updated.
Determining the version via the System Manager
The TwinCAT System Manager indicates the FPGA firmware version. Click on the Ethernet card of your EtherCAT strand (Device 2 in the example) and select the Online tab.
The Reg:0002 column indicates the firmware version of the individual EtherCAT devices in hexadecimal and decimal representation.
FPGA firmware version definition
If the column Reg:0002 is not displayed, right-click the table header and select Properties in the context menu.
Context menu Properties
The Advanced Settings dialog appears where the columns to be displayed can be selected. Under Diagnosis/Online View select the '0002 ETxxxx Build' check box in order to activate the FPGA firmware version display.
Dialog Advanced Settings
Update
For updating the FPGA firmware
▪
of an EtherCAT coupler the coupler must have FPGA firmware version 11 or higher;
▪
of an E-Bus Terminal the terminal must have FPGA firmware version 10 or higher.
Older firmware versions can only be updated by the manufacturer!
Updating an EtherCAT device
The following sequence order have to be met if no other specifications are given (e.g. by the Beckhoff support):
▪
Switch TwinCAT system to ConfigMode/FreeRun with cycle time >= 1 ms (default in ConfigMode is 4 ms). A FW-Update during real time operation is not recommended.
▪
In the TwinCAT System Manager select the terminal for which the FPGA firmware is to be updated (in the example: Terminal 5: EL5001) and
click the Advanced Settings button in the EtherCAT tab:
▪
The Advanced Settings dialog appears. Under ESC Access/E²PROM/FPGA click on Write FPGA button:
▪
Select the file (*.rbf) with the new FPGA firmware, and transfer it to the EtherCAT device:
▪
Wait until download ends
▪
Switch slave current less for a short time (don't pull under voltage!). In order to activate the new FPGA firmware a restart (switching the power supply off and on again) of the EtherCAT device is required.
▪
Check the new FPGA status
Note
Risk of damage to the device!
A download of firmware to an EtherCAT device must not be interrupted in any case! If you interrupt this process by switching off power supply or disconnecting the Ethernet link, the EtherCAT device can only be recommissioned by the manufacturer!


Simultaneous updating of several EtherCAT devices

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Simultaneous updating of several EtherCAT devices
Simultaneous updating of several EtherCAT devices
The firmware and ESI descriptions of several devices can be updated simultaneously, provided the devices have the same firmware file/ESI.
Multiple selection and firmware update
Select the required slaves and carry out the firmware update in BOOTSTRAP mode as described above.


Restoring the delivery state

Appendix [image] Restoring the delivery state
Restoring the delivery state
To restore the delivery state for backup objects in ELxxxx terminals, the CoE object Restore default parameters, SubIndex 001 can be selected in the TwinCAT System Manager (Config mode) (see Fig. Selecting the Restore default parameters PDO)
Selecting the "Restore default parameters" PDO
Double-click on SubIndex 001 to enter the Set Value dialog. Enter the value 1684107116 in field Dec or the value 0x64616F6C in field Hex and confirm with OK (Fig. Entering a restore value in the Set Value dialog).
All backup objects are reset to the delivery state.
Entering a restore value in the Set Value dialog
Alternative restore value
In some older terminals the backup objects can be switched with an alternative restore value: Decimal value: 1819238756, Hexadecimal value: 0x6C6F6164An incorrect entry for the restore value has no effect.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com