EL3413 - 3-phase power measurement terminal up to 690 V AC

BECKHOFF Fieldbus Component

Documentation for

EL3413

3-phase power measurement terminal up to 690 V AC

Version: 1.4
Datum: 2013-11-13

EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.


Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending

The EtherCAT Technology is covered, including but not limited to the following patent applications and patents:
EP1590927, EP1789857, DE102004044764, DE102007017835
with corresponding applications or registrations in various other countries.

The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.

Copyright

© Beckhoff Automation GmbH, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety Instructions

Safety Rules

Consider the following safety instructions and descriptions!
Product specific safety instructions are to be found on the following pages or in the areas mounting, wiring, commissioning etc.

Disclaimer

All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH.

Personnel Qualification

This description is only intended for the use of trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.

Description of symbols

The following symbols with a adjoining safety advise or notice are used in this documentation. You have to read the safety advices carefully and adhere them strictly!

DANGER 		Acute risk of injury!
If you do not adhere the safety advise adjoining this symbol, there is immediate danger to life and health of individuals!

WARNING 		Risk of injury!
If you do not adhere the safety advise adjoining this symbol, there is danger to life and health of individuals!

CAUTION 		Hazard to individuals!
If you do not adhere the safety advise adjoining this symbol, there is obvious hazard to individuals!

Attention 		Hazard to environment and devices
If you do not adhere the notice adjoining this symbol, there is obvious hazard to environment and devices.

Note 		Note or pointer
This symbol indicates information that contributes to better understanding.
UL Pointer
This symbol indicates important information about the UL-compliant.


EL3413 - Documentation issue status

BECKHOFF EL3413: Foreword

Documentation issue status

Version | Comment
1.4 | - Update "Technical data"
1.3 | - Update "Object description"
1.2 | - Update "Object description"
1.1 | - Update "Technical data"
1.0 | - Addenda, 1st public issue
0.1 | - Preliminary documentation for EL3413


Version identification

BECKHOFF: Foreword

Version identification of EtherCAT devices

Designation

A Beckhoff EtherCAT device has a 14-digit designation, made up of

  • family key
  • type
  • version
  • revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017

Notes

  • The order identifier is made up of
    - family key
    - type
    - version
  • The revision indicates the technical progress and is managed by Beckhoff.
    In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise.
    Each revision usually has an associated XML description (ESI, EtherCAT Slave information), which is available for download from the Beckhoff webpage.
  • Type, version and revision are read as decimal numbers.

Serial number

Beckhoff EtherCAT devices usually have an 8-digit serial number, which is printed on the device or attached to it on a sticker. This serial number indicates the construction condition on delivery.

Syntax of the serial number

Structure of the serial number: KK YY FF HH

KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version

Example with ser. no.: 12 06 3A 02:

12 - week of production 12
06 - year of production 2006
3A - firmware version 3A
02 - hardware version 02

Examples of serial number data

Fig. 1: EL6688 EL Terminal

Fig. 2: CU2016 Switch

Fig. 3: EK1100 EtherCAT coupler


EL3413 - Introduction

3-phase power measurement terminal up to 690 V AC

The EL3413 EtherCAT power measurement terminal is a further development of the EL3403. With up to 690 V AC the voltage inputs are optimized for direct monitoring of high-performance generators, as used in the wind power industry, for example.
The full scale value for the current can be set to 0.1 A, 1 A or 5 A via the CoE directory.

No upstream voltage transformer is required. The current inputs are galvanically isolated so that the terminal can be used in all common grounded current transformer configurations such as 2- or 3-transformer configurations with star or delta connection.

The EL3413 can deal with simple network analysis up to the 21st harmonic analysis. Like all measured terminal data, the harmonic content can be read via the process data.

Quick-Links

• EtherCAT basics
• Basic function principles EL3413
• Object description and parameterization
• Process data and operation modes


EL3413 - Technical data

Technical data | EL3413-0000
Measured values | Current, voltage, effective power, apparent power, frequency
Calculated values | Reactive power, energy, efficiency factor (cosj), harmonic oscillations, phase angle
Measuring voltage | max. 690 V AC 3~ (ULX-N: max. 400 V AC) , input voltages must adhere to overvoltage category II
Measuring current | max. 5 A (AC), over current transformer x A / 5 A
Input resistance voltage circuit (typ.) | 1 MW
Input resistance current circuit (typ.) | < 3 mW
Resolution | 0,1 µA, 0,1 mV, 10 mW (for 0,1 A measuring range) [currently not active!] 1 µA, 0,1 mV, 10 mW (for 1 A measuring range) 5 µA, 0,1 mV, 10 mW (for 5 A measuring range)
Measuring accuracy | 0.5 % relative to full scale value (U/I), 1 % calculated value (P)
Frequency range | 45 Hz ..65 Hz
Signal shaping | any (in consideration of frequency range and threshold frequency)
Measuring procedure | True RMS, calculation of the true effective value with 16,800 ( 2,800 per channel) samples/s
Measurement cycle time | 200 ms per measured value preset, free configurable, net-synchronous
Electrical isolation | 4,500 V (terminal/E-bus)
Supply voltage for internal E-bus circuit | via E-Bus
Current consumption via E-bus | typ. 160 mA
Configuration | über TwinCAT System Manager
Dimensions | approx. ca. 27 mm x 100 mm x 70 mm (Breite angereiht: 24 mm)
Weight | approx.. 75 g
Operating temperature | 0 °C ... +55 °C
Storage temperature | -25 °C ... +85 °C
Relative humidity | 95%, no condensation
Mounting | on 35 mm mounting rail conforms to EN 50022
Vibration/shock resistance | conforms to EN 60068-2-6/EN 60068-2-27
EMC resistance burst/ESD | conforms to EN 61000-6-2/EN 61000-6-4
Protect. class/Installation pos. | IP 20/variable
Approval | CE


EL3413 - Basic Function Principles

BECKHOFF EL3413: Product overview

Basic Function Principles

Contents
• Measuring principle
 • RMS value calculation
 - Measuring interval
• Effective power measurement
 • Apparent power measurement
 • Sign for power measurement
 • Frequency counter

Measuring principle

The EL3413 works with 1 analog/digital converter for recording the current and voltage values of all 3 phases.

The measurement and processing of the 3 phases take place successively (45 µs offset) in exactly the same way. The signal processing for one phase is described below. This description applies correspondingly for all 3 phases.

Fig. 1: Voltage u and current i curves

RMS value calculation

The rms value for voltage and current is calculated over a measuring interval, in this case the period T. The following equations are used:

u(t): instantaneous voltage value
i(t): instantaneous current value
n: number of measured values

Measuring interval

The choice of the right measuring interval is important for the quality of the measurement. The default setting for the measuring interval is 10 periods (10 x 20 ms). Experience shows that this is a good compromise between measuring speed and stability. Deviations from this value are only advisable in the event of particular measurement requirements (e.g. high measuring speed).

Effective power measurement

The EL3413 measures the effective power P according to the following equation

P: Effective power
n: number of samples
u(t): instantaneous voltage value
i(t): instantaneous current value

Fig. 2: Power s(t) curve

In the first step, the power s(t) is calculated at each sampling instant:

The mean value over the measuring interval is calculated. Here too, the correct choice of the intervals is important, as described in section RMS value measurement (the interval can only be changed simultaneously for U, I and P).

The power frequency is twice that of the corresponding voltages and currents.

Apparent power measurement

In real networks, not all consumers are purely ohmic. Phase shifts occur between current and voltage. This does not affect the methodology for determining the rms values of voltage and current as described above.

The situation for the effective power is different: Here, the product of effective voltage and effective current is the apparent power.

The effective power is smaller than the apparent power.

S: Apparent power
P: Effective power
Q: Reactive power
j: Phase shift angle

Fig. 3: u(t), i(t), p(t) curves with phase shift angle j

In this context, further parameters of the mains system and its consumers are significant:

  • apparent power S
  • reactive power Q
  • power factor cos j

The EL3413 determines the following values:

  • effective power P
  • effective voltage U
  • effective current I
  • apparent power S
  • reactive power Q
  • power factor cos j
  • harmonic
  • phase shift

Sign for power measurement

The sign of the active power P and of the power factor cos f provide information about the direction of the energy flow. A positive sign indicates the motor mode, a negative sign indicates generator mode.

In addition, the sign of the reactive power Q indicates the direction of the phase shift between current and voltage. In Figure 4 this is illustrated in the four-quadrant diagram. In motor mode (quadrant I & IV) a positive reactive power indicates an inductive load, a negative reactive power indicates a capacitive load. In generator mode (quadrant II & III), an inductive acting generator is indicated by a positive reactive power, a capacitive acting generator by a negative reactive power.

Fig. 4: Four-quadrant representation of active/reactive power in motor and generator mode

Frequency counter

The EL3413 is able to measure the frequency of the signals at the voltage circuits (L1, L2, L3).


EL3413 - Stromwandler

BECKHOFF EL3413: Product overview

Current Transformers

In principle, the choice of current transformer for the EL3413 is not critical. The internal resistance within the current circuit of the EL3413 is so small that it is negligible for the calculation of the total resistances of the current loop. The transformers should be able to produce a secondary rated current of 1 A to 5 A. The primary rated current Ipn can be selected arbitrarily. The common permissible overload of 1.2 x Ipn is no problem for the EL3413, but may lead to small measuring inaccuracies.

Accuracy

Please note that the overall accuracy of the set-up consisting of EL3413 and current transformers to a large degree depends on the accuracy class of the transformers.

Note 		No approval as a billing meter
A set-up with a class 0.5 current transformer cannot be approved or authenticated. The EL3413 is not an approved billing meter according to the electricity meter standard (DIN 43 856).

Current types

The EL3413 can measure any current type up to a limiting proportion 260 Hz. Since such currents are frequently created by inverters and may contain frequencies of less than 50 Hz or even a DC component, electronic transformers should be used for such applications.

Overcurrent limiting factor FS

The overcurrent limiting factor FS of a current transformer indicates at what multiple of the primary rated current the current transformer changes to saturation mode, in order to protect the connected measuring instruments.

Attention 		Attention! Possible damage of device!
The EL3413 must not be subjected to more than 5 A for a prolonged period of time! For systems in which the over-current limiting factors of the transformers allow secondary currents of more than 5 A, additional intermediate transformers with a ratio of 5A/1A or 1A/5A should be used!

Protection against dangerous touch voltages

During appropriate operation of the EL3413 with associated current transformers, no dangerous voltages occur. The secondary voltage is in the range of a few Volts. However, the following faults may lead to excessive voltages:

  • Open current circuit of one or several transformers
  • Neutral conductor cut on the voltage measurement side of the EL3413
  • General insulation fault

WARNING 		WARNING! Risk of electric shock!
The complete wiring of the EL3413 must be protected against accidental contact and equipped with associated warnings! The insulation should be designed for the maximum conductor voltage of the system to be measured!

The EL3413 allows a maximum voltage of 690 V for normal operating conditions. The conductor voltage on the current side must not exceed 690 V! For higher voltages, an intermediate transformer stage should be used!

On the voltage measurement side, a EL3413 is equipped with a protection impedance of 1 MW. If the neutral conductor is not connected and only one connection on the side of the voltage measurement is live, the resulting voltage against earth in a 3-phase system with a phase-to-phase voltage of 690 VAC is 400 VAC against ground. This should also be measured on the side of the current measurement using a multimeter with an internal resistance of 10 MW, which does not represent an insulation fault.

Additional measuring instruments in the current circuit

Please note that the addition of additional measuring instruments (e.g. ammeters) in the current circuit can lead to a significant increase in the total apparent power.


Start

For commissioning:

  • mount the EL3413 as explained in the chapter "Mounting and wiring"
  • configure the EL3413 in TwinCAT as explained in the chapter "Commissioning"


EtherCAT - EtherCAT basics

BECKHOFF EtherCAT: Basics communication

EtherCAT basics

Please refer to the chapter EtherCAT System Documentation for the EtherCAT fieldbus basics.


EtherCAT cabeling

BECKHOFF EtherCAT: Basics communication

EtherCAT cabling – wire-bound

The cable length between two EtherCAT devices must not exceed 100 m. This results from the FastEthernet technology, which, above all for reasons of signal attenuation over the length of the cable, allows a maximum link length of 5 + 90 + 5 m if cables with appropriate properties are used. See also the Design recommendations for the infrastructure for EtherCAT/Ethernet.

Cables and connectors

For connecting EtherCAT devices only Ethernet connections (cables + plugs) that meet the requirements of at least category 5 (CAt5) according to EN 50173 or ISO/IEC 11801 should be used. EtherCAT uses 4 wires for signal transfer.

EtherCAT uses RJ45 plug connectors, for example. The pin assignment is compatible with the Ethernet standard (ISO/IEC 8802-3).

Pin | Color of conductor | Signal | Description
1 | yellow | TD + | Transmission Data +
2 | orange | TD - | Transmission Data -
3 | white | RD + | Receiver Data +
6 | blue | RD - | Receiver Data -

Due to automatic cable detection (auto-crossing) symmetric (1:1) or cross-over cables can be used between EtherCAT devices from Beckhoff.

Note 		Recommended cables
Suitable cables for the connection of EtherCAT devices can be found on the Beckhoff website!

E-Bus supply

A bus coupler can supply the EL terminals added to it with the E-bus system voltage of 5 V; a coupler is thereby loadable up to 2A as a rule (see details in respective device documentation).
Information on how much current each EL terminal requires from the E-bus supply is available online and in the catalogue. If the added terminals require more current than the coupler can supply, then power feed terminals (e.g. EL9400) must be inserted at appropriate places in the terminal strand.

The pre-calculated theoretical maximum E-bus current is displayed in the TwinCAT System Manager. A shortfall is marked by a negative total amount and an exclamation mark; a power feed terminal is to be placed before such a position.

Fig. 1: System manager current calculation

Attention 		Caution! Malfunction possible!
The same ground potential must be used for the E-Bus supply of all EtherCAT terminals in a terminal block!


EtherCAT - General notes for setting the watchdog

BECKHOFF EtherCAT: Basics communication

General notes for setting the watchdog

ELxxxx terminals are equipped with a safety feature (watchdog) that switches off the outputs after a specifiable time e.g. in the event of an interruption of the process data traffic, depending on the device and settings, e.g. in OFF state.

The EtherCAT slave controller (ESC) in the EL2xxx terminals features 2 watchdogs:

  • SM watchdog (default: 100 ms)
  • PDI watchdog (default: 100 ms)

SM watchdog (SyncManager Watchdog)

The SyncManager watchdog is reset after each successful EtherCAT process data communication with the terminal. If no EtherCAT process data communication takes place with the terminal for longer than the set and activated SM watchdog time, e.g. in the event of a line interruption, the watchdog is triggered and the outputs are set to FALSE. The OP state of the terminal is unaffected. The watchdog is only reset after a successful EtherCAT process data access. Set the monitoring time as described below.

The SyncManager watchdog monitors correct and timely process data communication with the ESC from the EtherCAT side.

PDI watchdog (Process Data Watchdog)

If no PDI communication with the EtherCAT slave controller (ESC) takes place for longer than the set and activated PDI watchdog time, this watchdog is triggered.
PDI (Process Data Interface) is the internal interface between the ESC and local processors in the EtherCAT slave, for example. The PDI watchdog can be used to monitor this communication for failure.

The PDI watchdog monitors correct and timely process data communication with the ESC from the application side.

The settings of the SM- and PDI-watchdog must be done for each slave separately in the TwinCAT System Manager.

Fig. 1 EtherCAT tab -> Advanced Settings -> Behavior -> Watchdog

Notes:

  • the multiplier is valid for both watchdogs.
  • each watchdog has its own timer setting, the outcome of this in summary with the multiplier is a resulting time.
  • Important: the multiplier/timer setting is only loaded into the slave at the start up, if the checkbox is activated.
    If the checkbox is not activated, nothing is downloaded and the ESC settings remain unchanged.

Multiplier

Both watchdogs receive their pulses from the local terminal cycle, divided by the watchdog multiplier:

1/25 MHz * (watchdog multiplier + 2) = 100 µs (for default setting of 2498 for the multiplier)

The standard setting of 1000 for the SM watchdog corresponds to a release time of 100 ms.

The value in multiplier + 2 corresponds to the number of basic 40 ns ticks representing a watchdog tick.
The multiplier can be modified in order to adjust the watchdog time over a larger range.

Example "Set SM watchdog"

This checkbox enables manual setting of the watchdog times. If the outputs are set and the EtherCAT communication is interrupted, the SM watchdog is triggered after the set time and the outputs are erased. This setting can be used for adapting a terminal to a slower EtherCAT master or long cycle times. The default SM watchdog setting is 100 ms. The setting range is 0..65535. Together with a multiplier with a range of 1..65535 this covers a watchdog period between 0..~170 seconds.

Calculation

Multiplier = 2498 → watchdog base time = 1 25 MHz * (2498 + 2) = 0.0001 seconds = 100 µs
SM watchdog = 10000 → 10000 * 100 µs = 1 second watchdog monitoring time

CAUTION 		CAUTION! Undefined state possible!
The function for switching off of the SM watchdog via SM watchdog = 0 is only implemented in terminals from version -0016.
In previous versions this operating mode should not be used.

CAUTION 		CAUTION! Damage of devices and undefined state possible!
If the SM watchdog is activated and a value of 0 is entered the watchdog switches off completely. This is the deactivation of the watchdog!
Set outputs are NOT set in a safe state, if the communication is interrupted.

Note 		Outputs in SAFEOP state
The default set watchdog monitoring sets the outputs of the module in a safe state - depending on the settings in SAFEOP and OP - e.g. in OFF state.
If this is prevented by deactivation of the watchdog monitoring in the module, the outputs can be switched or set also in the SAFEOP state.


EtherCAT State Machine

The state of the EtherCAT slave is controlled via the EtherCAT State Machine (ESM). Depending upon the state, different functions are accessible or executable in the EtherCAT slave. Specific commands must be sent by the EtherCAT master to the device in each state, particularly during the bootup of the slave.

A distinction is made between the following states:

  • Init
  • Pre-Operational
  • Safe-Operational and
  • Operational
  • Boot

The regular state of each EtherCAT slave after bootup is the OP state.

Init

After switch-on the EtherCAT slave in the Init state. No mailbox or process data communication is possible. The EtherCAT master initializes sync manager channels 0 and 1 for mailbox communication.

Pre-Operational (Pre-Op)

During the transition between Init and Pre-Op the EtherCAT slave checks whether the mailbox was initialized correctly.

In Pre-Op state mailbox communication is possible, but not process data communication. The EtherCAT master initializes the sync manager channels for process data (from sync manager channel 2), the FMMU channels and, if the slave supports configurable mapping, PDO mapping or the sync manager PDO assignment. In this state the settings for the process data transfer and perhaps terminal-specific parameters that may differ from the default settings are also transferred.

Safe-Operational (Safe-Op)

During transition between Pre-Op and Safe-Op the EtherCAT slave checks whether the sync manager channels for process data communication and, if required, the distributed clocks settings are correct. Before it acknowledges the change of state, the EtherCAT slave copies current input data into the associated DP-RAM areas of the EtherCAT slave controller (ECSC).

In Safe-Op state mailbox and process data communication is possible, although the slave keeps its outputs in a safe state, while the input data are updated cyclically.

Note 		Outputs in SAFEOP state
The default set watchdog monitoring sets the outputs of the module in a safe state - depending on the settings in SAFEOP and OP - e.g. in OFF state.
If this is prevented by deactivation of the watchdog monitoring in the module, the outputs can be switched or set also in the SAFEOP state.

Operational (Op)

Before the EtherCAT master switches the EtherCAT slave from Safe-Op to Op it must transfer valid output data.

In the Op state the slave copies the output data of the masters to its outputs. Process data and mailbox communication is possible.

Boot

In the Boot state the slave firmware can be updated. The Boot state can only be reached via the Init state.

In the Boot state mailbox communication via the file access over EtherCAT (FoE) protocol is possible, but no other mailbox communication and no process data communication.


CoE Interface

Table of contents
• General description
 • Data management
 • Online/offline list
 • Channel-based order

General description

The CoE interface (CANopen over EtherCAT) is used for parameter management of EtherCAT devices. EtherCAT slaves or the EtherCAT master manage fixed (read only) or variable parameters which they require for operation, diagnostics or commissioning.

CoE parameters are arranged in a table hierarchy. In principle, the user has read access via the fieldbus. The EtherCAT master (TwinCAT System Manager) can access the local CoE lists of the slaves via EtherCAT in read or write mode, depending on the attributes.

Different CoE parameter types are possible, including string (text), integer numbers, Boolean values or larger byte fields. They can be used to describe a wide range of features. Examples of such parameters include manufacturer ID, serial number, process data settings, device name, calibration values for analog measurement or passwords.

The order is specified in 2 levels via hexadecimal numbering: (main)index, followed by subindex. The value ranges are

  • Index: 0...65535
  • SubIndex: 0...255

A parameter localized in this way is normally written as x8010:07, with preceding "x" to identify the hexadecimal numerical range and a colon between index and subindex.

The relevant ranges for EtherCAT fieldbus users are:

  • x1000: This is where fixed identity information for the device is stored, including name, manufacturer, serial number etc., plus information about the current and available process data configurations.
  • x8000: This is where the operational and functional parameters for all channels are stored, such as filter settings or output frequency.

Other important ranges are:

  • x4000: In some EtherCAT devices the channel parameters are stored here (as an alternative to the x8000 range).
  • x6000: Input PDOs ("input" from the perspective of the EtherCAT master)
  • x7000: Output PDOs ("output" from the perspective of the EtherCAT master)

Note 		Availability
Not every EtherCAT device must have a CoE list.
Simple I/O modules without dedicated processor usually have no variable parameters and therefore no CoE list..

If a device has a CoE list, it is shown in the TwinCAT System Manager as a separate tab with a listing of the elements:

Fig. 1: "CoE Online " tab

Fig. 1 shows the CoE objects available in device "EL2502", ranging from x1000 to x1600. The subindices for x1018 are expanded.

Data management

Some parameters, particularly the setting parameters of the slave, are configurable and writeable. This can be done in write or read mode

  • via the System Manager (Fig. 1) by clicking
    This is useful for commissioning of the system/slaves. Click on the row of the index to be parameterised and enter a value in the "SetValue" dialog.
  • from the control system/PLC via ADS, e.g. through blocks from the TcEtherCAT.lib library
    This is recommended for modifications while the system is running or if no System Manager or operating staff are available.

Note 		Data management
If slave CoE parameters are modified online, Beckhoff devices store any changes in a fail-safe manner in the EEPROM, i.e. the modified CoE parameters are still available after a restart.

The situation may be different with other manufacturers.

An EEPROM is subject to a limited lifetime with respect to write operations. From typically 100,000 write operations onwards it can no longer be guaranteed that new (changed) data are reliably saved or are still readable. This is irrelevant for normal commissioning. However, if CoE parameters are continuously changed via ADS at machine runtime, it is quite possible for the lifetime limit to be reached. Support for the NoCoeStorage function, which suppresses the saving of changed CoE values, depends on the firmware version.
  • If the function is supported: the function is activated by entering the code word 0x12345678 once in CoE 0xF008 and remains active as long as the code word is not changed. After switching the device on it is then inactive. Changed CoE values are not saved in the EEPROM and can thus be changed any number of times.
  • Function not supported: continuous changing of CoE values is not permissible in view of the lifetime limit.

Please refer to the technical data in this documentation as to whether this applies to the respective device.

Start-up list

Note 		Startup list
Changes in the local CoE list of the terminal are lost if the terminal is replaced. If a terminal is replaced with a new Beckhoff terminal, it will have the default settings. It is therefore advisable to link all changes in the CoE list of an EtherCAT slave with the Startup list of the slave, which is processed whenever the EtherCAT fieldbus is started. In this way a replacement EtherCAT slave can automatically be parameterised with the specifications of the user.

If EtherCAT slaves are used which are unable to store local CoE values permanently, the Startup list must be used.

Recommended approach for manual modification of CoE parameters

  • Make the required change in the System Manager
    The values are stored locally in the EtherCAT slave
  • If the value is to be stored permanently, enter it in the Startup list.
    The order of the Startup entries is usually irrelevant.

Fig. 2: Startup list in the TwinCAT System Manager

The Startup list may already contain values that were configured by the System Manager based on the ESI specifications. Additional application-specific entries can be created.

Online/offline list

While working with the TwinCAT System Manager, a distinction has to be made whether the EtherCAT device is "available", i.e. switched on and linked via EtherCAT and therefore online, or whether a configuration is created offline without connected slaves.

In both cases a CoE list as shown in Fig. 1 is displayed. The connectivity is shown as offline/online.

  • If the slave is offline
    - The offline list from the ESI file is displayed. In this case modifications are not meaningful or possible.
    - The configured status is shown under Identity.
    - No firmware or hardware version is displayed, since these are features of the physical device.
    - Offline is shown in red.

    Fig. 3: Offline list
  • If the slave is online
    - The actual current slave list is read. This may take several seconds, depending on the size and cycle time.
    - The actual identity is displayed
    - The firmware and hardware version of the equipment according to the electronic information is displayed
    - Online is shown in green.

    Fig. 4: Online list

Channel-based order

The CoE list is available in EtherCAT devices that usually feature several functionally equivalent channels. For example, a 4-channel analog 0..10 V input terminal also has 4 logical channels and therefore 4 identical sets of parameter data for the channels. In order to avoid having to list each channel in the documentation, the placeholder "n" tends to be used for the individual channel numbers.

In the CoE system 16 indices, each with 255 subindices, are generally sufficient for representing all channel parameters. The channel-based order is therefore arranged in 16dec/10hex steps. The parameter range x8000 exemplifies this:

  • Channel 0: parameter range x8000:00 ... x800F:255
  • Channel 1: parameter range x8010:00 ... x801F:255
  • Channel 2: parameter range x8020:00 ... x802F:255
  • ...

This is generally written as x80n0.

Detailed information on the CoE interface can be found in the EtherCAT system documentation on the Beckhoff website.


Distributed Clock

BECKHOFF EtrherCAT: Basics communication

Distributed Clocks

The EL3413 does not support Distributed Clocks.


ELxxxx, KLxxxx - Installation on mounting rails

BECKHOFF Fieldbus Components: Mounting and wiring

Installation on mounting rails

WARNING 		Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!

Assembly

The Bus Coupler and Bus Terminals are attached to commercially available 35 mm mounting rails (DIN rails according to EN 50022) by applying slight pressure:

  1. First attach the Fieldbus Coupler to the mounting rail.
  2. The Bus Terminals are now attached on the right-hand side of the Fieldbus Coupler. Join the components with tongue and groove and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
    If the Terminals are clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.

Note 		Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail.
At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail.
To mount the mounting rails with a height of 7.5 mm under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).

Disassembly

Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
  1. Pull the terminal by its orange-colored lugs approximately 1 cm away from the mounting rail. In doing so for this terminal the mounting rail lock is released automatically and you can pull the terminal out of the bus terminal block easily without excessive force.
  2. Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal out of the bus terminal block.

Connections within a bus terminal block

The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:

  • The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
  • The power contacts deal with the supply for the field electronics and thus represent a supply rail within the bus terminal block. The power contacts are supplied via terminals on the Bus Coupler (up to 24 V) or for higher voltages via power feed terminals.

Note 		Power Contacts
During the design of a bus terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts.
Power Feed Terminals (KL91xx, KL92xx or EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.

PE power contact

The power contact labeled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.

Attention 		Possible damage of the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a nominal voltage of 230 V).

For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.

WARNING 		Risk of electric shock!
The PE power contact must not be used for other potentials!


KLxxxx, KSxxxx, ELxxxx, ESxxxx - Connection system

BECKHOFF Feldbuskomponenten: Mounting and wiring

Connection system

WARNING 		Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!

Overview

The Bus Terminal system offers different connection options for optimum adaptation to the respective application:

  • The terminals of KLxxxx and ELxxxx series with standard wiring include electronics and connection level in a single enclosure.
  • The terminals of KSxxxx and ESxxxx series feature a pluggable connection level and enable steady wiring while replacing.
  • The High Density Terminals (HD Terminals) include electronics and connection level in a single enclosure and have advanced packaging density.

Standard wiring

The terminals of KLxxxx and ELxxxx series have been tried and tested for years.
They feature integrated screwless spring force technology for fast and simple assembly.

Pluggable wiring

The terminals of KSxxxx and ESxxxx series feature a pluggable connection level.
The assembly and wiring procedure for the KS series is the same as for the KLxxxx and ELxxxx series.
The KS/ES series terminals enable the complete wiring to be removed as a plug connector from the top of the housing for servicing
The lower section can be removed from the terminal block by pulling the unlocking tab.
Insert the new component and plug in the connector with the wiring.
This reduces the installation time and eliminates the risk of wires being mixed up.

The familiar dimensions of the terminal only had to be changed slightly. The new connector adds about 3 mm. The maximum height of the terminal remains unchanged.

A tab for strain relief of the cable simplifies assembly in many applications and prevents tangling of individual connection wires when the connector is removed.

Conductor cross sections between 0.08 mm2 and 2.5 mm2 can continue to be used with the proven spring force technology.

The overview and nomenclature of the product names for KSxxxx and ESxxxx series has been retained as known from KLxxxx and ELxxxx series.

High Density Terminals (HD Terminals)

The Bus Terminals from these series with 16 connection points are distinguished by a particularly compact design, as the packaging density is twice as large as that of the standard 12 mm Bus Terminals. Massive conductors and conductors with a wire end sleeve can be inserted directly into the spring loaded terminal point without tools.

Note 		Wiring HD Terminals
The High Density (HD) Terminals of the KLx8xx and ELx8xx series doesn't support steady wiring.

Ultrasonically "bonded" (ultrasonically welded) conductors

Note 		Ultrasonically “bonded" conductors
It is also possible to connect the Standard and High Density Terminals with ultrasonically "bonded" (ultrasonically welded) conductors.
In this case, please note the tables concerning the wire-size width below!

Wiring

Terminals for standard wiring ELxxxx / KLxxxx and terminals for steady wiring ESxxxx / KSxxxx

Up to eight connections enable the connection of solid or finely stranded cables to the Bus Terminals. The terminals are implemented in spring force technology. Connect the cables as follows:

  1. Open a spring-loaded terminal by slightly pushing with a screwdriver or a rod into the square opening above the terminal.
  2. The wire can now be inserted into the round terminal opening without any force.
  3. The terminal closes automatically when the pressure is released, holding the wire securely and permanently.

Terminal housing | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Wire size width | 0.08 ... 2,5 mm2 | 0.08 ... 2.5 mm2
Wire stripping length | 8 ... 9 mm | 9 ... 10 mm

High Density Terminals ELx8xx, KLx8xx (HD)

The conductors of the HD Terminals are connected without tools for single-wire conductors using the direct plug-in technique, i.e. after stripping the wire is simply plugged into the contact point. The cables are released, as usual, using the contact release with the aid of a screwdriver. See the following table for the suitable wire size width.

Terminal housing | High Density Housing
Wire size width (conductors with a wire end sleeve) | 0.14... 0.75 mm2
Wire size width (single core wires) | 0.08 ... 1.5 mm2
Wire size width (fine-wire conductors) | 0.25 ... 1.5 mm2
Wire size width (ultrasonically “bonded" conductors) | only 1.5 mm2 (see notice!)
Wire stripping length | 8 ... 9 mm

Shielding

Note 		Shielding
Analog sensors and actors should always be connected with shielded, twisted paired wires.


KLxxxx, ELxxxx installation positions

BECKHOFF Fieldbus components: Installation and wiring

Installation positions

Attention 		Constraints regarding installation position and operating temperature range
Please refer to the technical data for a terminal to ascertain whether any restrictions regarding the installation position and/or the operating temperature range have been specified.

When installing high power dissipation terminals ensure that an adequate spacing is maintained between other components above and below the terminal in order to guarantee adequate ventilation!

Optimum installation position (standard)

The optimum installation position requires the mounting rail to be installed horizontally and the connection surfaces of the EL/KL terminals to face forward (see Fig. 1). The terminals are ventilated from below, which enables optimum cooling of the electronics through convection. "From below" is relative to the acceleration of gravity.

Fig. 1: Recommended distances for standard installation position

Compliance with the distances shown in Fig. 1 is recommended.

Other installation positions

All other installation positions are characterized by different spatial arrangement of the mounting rail - see Fig 2.

The minimum distances to ambient specified above also apply to these installation positions.

Fig. 2: Other installation positions


Mounting of Passive Terminals

Note 		Hint for mounting passive terminals
EtherCAT Bus Terminals (ELxxxx / ESxxxx), which do not take an active part in data transfer within the bus terminal block are so called Passive Terminals.
The Passive Terminals have no current consumption out of the E-Bus
To ensure an optimal data transfer, you must not directly string together more than 2 Passive Terminals!
Examples for mounting passive terminals (highlighted)

Example 1: correct configuration

Example 2: incorrect configuration


EL3413 - LEDs and pin assignment

BECKHOFF EL3413: Mounting and wiring

EL3413 - LEDs and connection

LEDs

LED | Color | Meaning
RUN | green | This LED indicates the terminal's operating state:
 |  | off | State of the EtherCAT State Machine: INIT = Initialization of the terminal or BOOTSTRAP = Function for firmware updates of the terminal
 |  | blinking | State of the EtherCAT State Machine: PREOP = Setting for mailbox communication and variant standard settings
 |  | single flash | State of the EtherCAT State Machine: SAFEOP = Channel checking of the Sync Manager and the Distributed Clocks. Outputs stay in safe operation mode.
 |  | on | State of the EtherCAT State Machine: OP = Normal operation mode, mailbox- and process data communication possible
IL1 OK | green | on | Current detected on L1
IL1 Error | red | on | Overcurrent on L1. Current > 1.1 A (with 1 A measuring range) Current > 5.1 A (with 5 A measuring range)
IL2 OK | green | on | Current detected on L2
IL2 Error | red | on | Overcurrent on L2. Current > 1.1 A (with 1 A measuring range) Current > 5.1 A (with 5 A measuring range)
IL3 OK | green | on | Current detected on L3
IL3 Error | red | on | Overcurrent on L3. Current > 1.1 A (with 1 A measuring range) Current > 5.1 A (with 5 A measuring range)
ccw | green | on | Counter-clockwise rotating field correctly detected
cw | green | on | Clockwise rotating field correctly detected
L1 OK | green | on | Voltage on L1 and zero crossing detected. Voltage > 5 V (L1-N)
L1 Error | red | on | Over- or undervoltage on L1. Voltage < 5 V or voltage > 415 V (L1-N) No zero crossings detected correctly by L1
L2 OK | green | on | Voltage on L2 and zero crossing detected. Voltage > 5 V (L2-N)
L2 Error | red | on | Over- or undervoltage on L2. Voltage < 5 V or voltage > 415 V (L2-N) No zero crossings detected correctly by L2
L3 OK | green | on | Voltage on L3 and zero crossing detected. Voltage > 5 V (L3-N)
L3 Error | red | on | Over- or undervoltage on L3. Voltage < 5 V or voltage > 415 V (L3-N) No zero crossings detected correctly by L3

Connection

Terminal point | Description | Comment
Meaning | No.
IL1 1 Intput current measuring of phase L1 Connections for current transformers:

WARNING 		WARNING! Risk of electric shock!
Please note that many manufacturers do not permit their current transformers to be operated in no-load mode! Connect the EL3413 to the secondary windings of the current transformers before using the current transformer!
IL2 | 2 | Intput current measuring of phase L2
IL3 | 3 | Intput current measuring of phase L3
IL1' | 5 | Output current measuring of phase L1
IL2' | 6 | Output current measuring of phase L2
IL3' | 7 | Output current measuring of phase L3
Terminal point | Description | Comment
Meaning | No.
L1 1 Intput voltage measuring of phase L1 Connections for voltage measurement:

WARNING 		WARNING! Risk of electric shock!
If you do not connect the terminal point N with the neutral conductor of your mains supply (e.g. if the EL3413 is used purely for current measurements), terminal point N should be earthed, in order to avoid dangerous overvoltages in the event of a current transformer fault!
L2 | 2 | Intput voltage measuring of phase L2
L3 | 3 | Intput voltage measuring of phase L3
N | 4 | Input neutral conductur


Installation of the TwinCAT real-time driver

In order to assign real-time capability to a standard Ethernet port of an IPC controller, the Beckhoff real-time driver has to be installed on this port under Windows.

This can be done in several ways. One option is described here.

In the System Manager call up the TwinCAT overview of the local network interfaces via Options -> Show Real Time Ethernet Compatible Devices.

Fig. 1: System Manager option

Fig. 2: overview of network interfaces

Interfaces listed under “Compatible devices” can be assigned a driver via the “Install” button. A driver should only be installed on compatible devices.

A Windows warning regarding the unsigned driver can be ignored.

After the installation the driver appears activated in the Windows overview for the network interface (Windows Start -->System Properties -> Network)

Fig. 3: Windows properties of the network interface

Notice 		IP address/DHCP
In most cases an Ethernet port that is configured as an EtherCAT device will not transport general IP packets. For this reason and in cases where an EL6601 or similar devices are used it is useful to specify a fixed IP address for this port via the “Internet Protocol TCP/IP” driver setting and to disable DHCP.

In this way the delay associated with the DHCP client for the Ethernet port assigning itself a default IP address in the absence of a DHCP server is avoided.

A suitable address space is 192.168.x.x, for example.

Fig. 4: TCP/IP setting for the Ethernet port

Alternatively, the compatible Ethernet ports can be viewed in the System Manager via EtherCAT properties.

Fig. 5: EtherCAT device properties


Notes regarding ESI device description

Contents
• Installation of the latest ESI device description
• Device differentiation
• Online Description
• Faulty ESI file

Installation of the latest ESI device description

The TwinCAT EtherCAT master/System Manager needs the device description files for the devices to be used in order to generate the configuration in online or offline mode. The device descriptions are contained in the so-called ESI files (EtherCAT Slave Information) in XML format. These files can be requested from the respective manufacturer and are made available for download. An *.xml file may contain several device descriptions.

The ESI files for Beckhoff EtherCAT devices are available on the Beckhoff website.

The ESI files should be stored in the TwinCAT installation directory (default: C:\TwinCAT\IO\EtherCAT). The files are read (once) when a new System Manager window is opened, if they have changed since the last time the System Manager window was opened.

A TwinCAT installation includes the set of Beckhoff ESI files that was current at the time when the TwinCAT build was created.

For TwinCAT 2.11 and higher, the ESI directory can be updated from the System Manager, if the programming PC is connected to the Internet (Option -> “Update EtherCAT Device Descriptions”)

Fig. 1: for TwinCAT 2.11 and higher, the System Manager can search for current Beckhoff ESI files automatically, if an online connection is available

Notice 		ESI
The *.xml files are associated with *.xsd files, which describe the structure of the ESI XML files. To update the ESI device descriptions, both file types should therefore be updated.

Device differentiation

EtherCAT devices/slaves are distinguished by 4 properties, which determine the full device identifier. The EL2521-0025-1018 ID consists of

  • family key “EL”
  • name “2521”
  • type “0025”
  • and revision “1018”

Fig. 2: identifier structure

The order identifier consisting of name + type (here: EL2521-0010) describes the device function. The revision indicates the technical progress and is managed by Beckhoff. In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise. Each revision has its own ESI description. See further notes.

Online description

If the EtherCAT configuration is created online through scanning of real devices (see section Online setup) and no ESI descriptions are available for a slave that was found, the System Manager asks whether the description stored in the device should be used. In any case, the System Manager needs this information for setting up the cyclic and acyclic communication with the slave correctly.

Fig. 3: OnlineDescription information window

If possible, this should be declined, and the required ESI should be requested from the device manufacturer. After installation of the XML/XSD file the configuration process should be repeated.

If the OnlineDescription is used regardless, the System Manager reads a copy of the device description from the EEPROM in the EtherCAT slave. In complex slaves the size of the EEPROM may not be sufficient for the complete ESI, in which case the ESI would be incomplete in the configurator. The route via the ESI files is therefore recommended.

The System Manager creates a new file “OnlineDescription0000...xml” its ESI directory, which contains all ESI descriptions that were read online.

Fig. 4: file OnlineDescription.xml created by the System Manager

If slaves are added manually to the configuration at a later stage, slaves created in the manner described above are indicated by an arrow, see Fig. 5, EL2521.

Fig. 5: Arrow indicates ESI recorded from OnlineDescription

If such ESI files are used and the manufacturer's files become available later, the file OnlineDescription.xml should be deleted as follows:

  • close all System Manager windows
  • restart TwinCAT in Config mode
  • delete OnlineDescription file

Faulty ESI file

If an ESI file is faulty and the System Manager is unable to read it, the System Manager brings up an information window.

Fig. 6: information window for faulty ESI file

Reasons may include:

  • structure of the *.xml file does not match the corresponding *.xsd file
  • content cannot be compiled into a device description

Contact the file supplier.


Offline configuration settings (master: TwinCAT 2.x)

Contents
• Distinction between Online and Offline
• Creating the EtherCAT device
• Defining EtherCAT slaves

Distinction between Online and Offline

The distinction between online and offline refers to the presence of the actual I/O environment (drives, terminals). If the configuration is to be prepared in advance of the system configuration as a programming system, e.g. on a laptop, this is only possible in “Offline configuration” mode. In this case all components have to be entered manually in the configuration, e.g. based on the electrical design.

If the designed control system is already connected to the EtherCAT system and all components are energized and the infrastructure is ready for operation, the TwinCAT configuration can simply be generated through “scanning” from the runtime system. This is referred to as online configuration.

In any case, during each startup the EtherCAT master checks whether the slaves it finds match the configuration. This test can be parameterized in the extended slave settings.

Notice 		Installation of the latest ESI-XML device description
The TwinCAT EtherCAT master/System Manager needs the device description files for the devices to be used in order to generate the configuration in online or offline mode. The device descriptions are contained in the so-called ESI files (EtherCAT Slave Information) in XML format. These files can be requested from the respective manufacturer and are made available for download. The ESI files for Beckhoff EtherCAT devices are available on the Beckhoff website.

The ESI files should be saved in the TwinCAT installation directory (default: C:\TwinCAT\IO\EtherCAT ). The files are read (once) when a new System Manager window is opened.

A TwinCAT installation includes the set of Beckhoff ESI files that was current at the time when the TwinCAT build was created.

For TwinCAT 2.11 and higher, the ESI directory can be updated from the System Manager, if the programming PC is connected to the Internet (Option -> “Update EtherCAT Device Descriptions”)

The following conditions must be met before a configuration can be set up:

  • the EtherCAT device must be defined in the System Manager
  • the EtherCAT slaves must be defined

Creating the EtherCAT device

Create an EtherCAT device in an empty System Manager window.

Fig. 1: Append EtherCAT device

Select type ‘EtherCAT’ for an EtherCAT I/O application with EtherCAT slaves. For the present publisher/subscriber service in combination with an EL6601/EL6614 terminal select “EtherCAT Automation Protocol via EL6601”.

Fig. 2: selecting the EtherCAT connection (TwinCAT 2.11)

Fig. 3: selecting the EtherCAT connection (TwinCAT 2.11 R2)

Then assign a real Ethernet port to this virtual device in the runtime system.

Fig. 4: selecting the Ethernet port

This query may appear automatically when the EtherCAT device is created, or the assignment can be set/modified later in the properties dialog (see Fig. 5).

Fig. 5: EtherCAT properties dialog

Notice 		selecting the Ethernet port
Ethernet ports can only be selected for EtherCAT devices for which the TwinCAT real-time driver is installed. This has to be done separately for each port.

Please refer to the respective installation page.

Defining EtherCAT slaves

Further devices can be appended by right-clicking on a device in the configuration tree.

Fig. 6: Appending EtherCAT devices

The dialog for selecting a new device opens. Only devices for which ESI files are available are displayed.

Only devices are offered for selection that can be appended to the previously selected device. Therefore the physical layer available for this port is also displayed (Fig. 7, A). In the case of cable-based Fast-Ethernet physical layer with PHY transfer, then also only cable-based devices are available, as shown in Fig. 7. If the preceding device has several free ports (e.g. EK1122 or EK1100), the required port can be selected on the right-hand side (A).

Overview of physical layer

  • “Ethernet”: cable-based 100BASE-TX: EK couplers, EP boxes, devices with RJ45/M8/M12 connector
  • “E-Bus”: LVDS “terminal bus”: EL/ES terminals, various modular modules

The search field facilitates finding specific devices (TwinCAT 2.11 or higher).

Fig. 7: selection dialog for new EtherCAT device

By default only the name/device type is used as selection criterion. For selecting a specific revision of the device the revision can be displayed as “Extended Information”.

Fig. 8: display of device revision

In many cases several device revisions were created for historic or functional reasons, e.g. through technological advancement. For simplification purposes (see Fig. 7) only the last (i.e. highest) revision and therefore the latest state of production is displayed in the selection dialog for Beckhoff devices. To show all device revisions available in the system as ESI descriptions tick the “Show Hidden Devices” check box, see Fig. 9.

Fig. 9: display of previous revisions

Notice 		Device selection based on revision, compatibility
The ESI description also defines the process image, the communication type between master and slave/device and the device functions, if applicable. The physical device (firmware, if available) has to support the communication queries/settings of the master. This is backward compatible, i.e. newer devices (higher revision) should be supported if the EtherCAT master addresses them as an older revision. The following compatibility rule of thumb is to be assumed for Beckhoff EtherCAT Terminals/Boxes:

device revision in the system >= device revision in the configuration

This also enables subsequent replacement of devices without changing the configuration (different specifications are possible for drives).

Example: If an EL2521-0025-1018 is specified in the configuration, an EL2521-0025-1019 or higher (-1020, -1021) can be used in practice.

If current ESI descriptions are available in the TwinCAT system, the last revision offered in the selection dialog matches the Beckhoff state of production. It is recommended to use the last device revision when creating a new configuration, if current Beckhoff devices are used in the real application. Older revisions should only be used if older devices from stock are to be used in the application.

In this case the process image of the device is shown in the configuration tree and can be parameterized as follows: linking with the task, CoE/DC settings, plug-in definition, startup settings, ...

Fig. 10: EtherCAT terminal in the TwinCAT tree


Online configuration settings “Scanning” (master: TwinCAT 2.x)

Contents
• Distinction between Online and Offline
• Detecting/scanning of the EtherCAT device
• Detecting/Scanning the EtherCAT devices
• Trouble shooting
• Scan over existing Configuration

Distinction between Online and Offline

The distinction between online and offline refers to the presence of the actual I/O environment (drives, terminals). If the configuration is to be prepared in advance of the system configuration as a programming system, e.g. on a laptop, this is only possible in “Offline configuration” mode. In this case all components have to be entered manually in the configuration, e.g. based on the electrical design.

If the designed control system is already connected to the EtherCAT system and all components are energized and the infrastructure is ready for operation, the TwinCAT configuration can simply be generated through “scanning” from the runtime system. This is referred to as online configuration.

In any case, during each startup the EtherCAT master checks whether the slaves it finds match the configuration. This test can be parameterized in the extended slave settings.

Notice 		Installation of the latest ESI-XML device description
The TwinCAT EtherCAT master/System Manager needs the device description files for the devices to be used in order to generate the configuration in online or offline mode. The device descriptions are contained in the so-called ESI files (EtherCAT Slave Information) in XML format. These files can be requested from the respective manufacturer and are made available for download. The ESI files for Beckhoff EtherCAT devices are available on the Beckhoff website..

The ESI files should be saved in the TwinCAT installation directory (default: C:\TwinCAT\IO\EtherCAT ). The files are read (once) when a new System Manager window is opened.

A TwinCAT installation includes the set of Beckhoff ESI files that was current at the time when the TwinCAT build was created.

For TwinCAT 2.11 and higher, the ESI directory can be updated from the System Manager, if the programming PC is connected to the Internet (Option -> “Update EtherCAT Device Descriptions”)

The following conditions must be met before a configuration can be set up:

  • the real EtherCAT hardware (devices, couplers, drives) must be present and installed
  • the devices/modules must be connected via EtherCAT cables or in the terminal strand in the same way as they are intended to be used later
  • the devices/modules be connected to the power supply and ready for communication
  • TwinCAT must be in CONFIG mode on the target system.

The online scan process consists of:

  • detecting the EtherCAT device (Ethernet port at the IPC)
  • detecting the connected EtherCAT devices. This step can be carried out independent of the preceding step
  • troubleshooting

The scan with existing configuration can also be carried out for comparison.

Detecting/scanning of the EtherCAT device

The online device search can be used if the TwinCAT system is in CONFIG mode (blue TwinCAT icon or blue indication in the System Manager).

Fig. 1: TwinCAT CONFIG mode display

Notice 		Online scanning in Config mode
The online search is not available in RUN mode (production operation).

Note the differentiation between TwinCAT programming system and TwinCAT target system. The TwinCAT icon next to the Windows clock always shows the TwinCAT mode of the local IPC. The System Manager window shows the TwinCAT state of the target system.

Right-clicking on “I/O Devices” in the configuration tree opens the search dialog.

Fig. 2: Scan Devices

This scan mode not only tries to find EtherCAT devices (or Ethernet ports that can be used as such), but also NOVRAM, fieldbus cards, SMB etc. Not all devices can be found automatically.

Fig. 3: note for automatic device scan

Ethernet ports with installed TwinCAT real-time driver are shown as “RT Ethernet” devices. An EtherCAT frame is sent to these ports for testing purposes. If the scan agent detects from the response that an EtherCAT slave is connected, the port is immediately shown as an “EtherCAT Device” .

Fig. 4: detected Ethernet devices

After confirmation with “OK” a device scan is suggested for all selected devices, see Fig. 5.

Detecting/Scanning the EtherCAT devices

Notice 		Online scan functionality
During a scan the master queries the identity information of the EtherCAT slaves from the slave EEPROM. The name and revision are used for determining the type. The respective devices are located in the stored ESI data and integrated in the configuration tree in the default state defined there.

If an EtherCAT device was created in the configuration (manually or through a scan), the I/O field can be scanned for devices/slaves.

Fig. 5: scan query after automatic creation of an EtherCAT device

Fig. 6: Manual triggering of a device scan on a specified EtherCAT device

In the System Manager the scan process can be monitored via the progress bar at the bottom of the screen.

Fig. 7: scan progress

The configuration is established and can then be switched to online state (OPERATIONAL).

Fig. 8: Config/FreeRun query

In Config/FreeRun mode the System Manager display alternates between blue and red, and the EtherCAT device continues to operate with the idling cycle time of 4 ms (default setting), even without active task (NC, PLC).

Fig. 9: Config/FreeRun indicator

Notice 		Note for Config/FreeRun
TwinCAT can also be switched to this state by using a button

The EtherCAT system should then be in a functional cyclic state, as shown in Fig. 10.

Fig. 10: online display example

Please note:

  • all slaves should be in OP state
  • the EtherCAT master should be in “Actual State” OP
  • “frames/sec” should match the cycle time taking into account the sent number of frames
  • no excessive “LostFrames” or CRC errors should occur

The configuration is now complete. It can be modified as described under manual procedure.

Troubleshooting

Various effects may occur during scanning.

  • An unknown device is detected, i.e. an EtherCAT slave for which no ESI XML description is available.
    In this case the System Manager offers to read any ESI that may be stored in the device. This case is described here.
  • Device are not detected properly
    Possible reasons include:
    - faulty data links, resulting in data loss during the scan
    - slave has invalid device description
    The connections and devices should be checked in a targeted manner, e.g. via the emergency scan.
    Then re-run the scan.

    Fig. 11: faulty identification

    In the System Manager such devices may be set up as EK0000 or unknown devices. Operation is not possible or meaningful.

Scan over existing Configuration

If a scan is initiated for an existing configuration, the actual I/O environment may match the configuration exactly or it may differ. This enables the configuration to be compared.

Fig. 12: identical configuration

If differences are detected, they are shown in the correction dialog, so that the user can modify the configuration as required.

Fig. 13: correction dialog

It is advisable to tick the “Extended Information” check box to reveal differences in the revision.

Colour | Explanation
green | This EtherCAT slave matches the entry on the other side. Both type and revision match.
blue This EtherCAT slave is present on the other side, but in a different revision. It is possible, that this different revision has also different default settings of the process data and different/additional functions.
If the found revision is higher than the configured revision, the slave may be used provided compatibility issues are taken into account.

If the found revision is lower than the configured revision, it is likely that the slave cannot be used. The found device may not support all functions that the master expects based on the higher revision number.
light blue | This EtherCAT slave is ignored (“Ignore” button)
red
  • This EtherCAT slave is not present on the other side.
  • or the slave is present, but in another revision, which differs also from the characteristics of the specified revision.
    The compatibility principle applies here, too: if the the scanned revision is higher than the configured revision, the operation is possible considering the compatibility, because successor devices should support the functions of the predecessor devices.
    If the scanned revision is lower than the configured revision, the operation is presumably not possible. In this case, the scanned device eventually does not support all functions, which are expected to the master due to the higher revision

Notice 		Device selection based on revision, compatibility
The ESI description also defines the process image, the communication type between master and slave/device and the device functions, if applicable. The physical device (firmware, if available) has to support the communication queries/settings of the master. This is backward compatible, i.e. newer devices (higher revision) should be supported if the EtherCAT master addresses them as an older revision. The following compatibility rule of thumb is to be assumed for Beckhoff EtherCAT Terminals/Boxes:

device revision in the system >= device revision in the configuration

This also enables subsequent replacement of devices without changing the configuration (different specifications are possible for drives).

Example: If an EL2521-0025-1018 is specified in the configuration, an EL2521-0025-1019 or higher (-1020, -1021) can be used in practice.

If current ESI descriptions are available in the TwinCAT system, the last revision offered in the selection dialog matches the Beckhoff state of production. It is recommended to use the last device revision when creating a new configuration, if current Beckhoff devices are used in the real application. Older revisions should only be used if older devices from stock are to be used in the application.

Fig. 14: correction dialog with modifications

Once all modifications have been saved or accepted, click “OK” to transfer them to the real *.tsm configuration.


EtherCAT slave process data settings (PDO)

The process data transferred by an EtherCAT slave during each cycle (Process Data Objects, PDOs) are user data which the application expects to be updated cyclically or which are sent to the slave. To this end the EtherCAT master (Beckhoff TwinCAT) parameterizes each EtherCAT slave during the start-up phase to define which process data (size in bits/bytes, source location, transmission type) it wants to transfer to or from this slave. Incorrect configuration can prevent successful start-up of the slave.

For Beckhoff EtherCAT EL/ES slaves the following applies in general:

  • The input/output process data supported by the device are defined by the manufacturer in the ESI/XML description. The TwinCAT EtherCAT Master uses the ESI description to configure the slave correctly.
  • The process data can be modified in the system manager. See the device documentation.
    Examples of modifications include: mask out a channel, displaying additional cyclic information, 16-bit display instead of 8-bit data size, etc.
  • In so-called “intelligent” EtherCAT devices the process data information is also stored in the CoE directory. Any changes in the CoE directory that lead to different PDO settings prevent successful startup of the slave. It is not advisable to deviate from the designated process data, because the device firmware (if available) is adapted to these PDO combinations.

If the device documentation allows modification of process data, proceed as follows (see Figure 1).

  • A: select the device to configure
  • B: in the “Process Data” tab select Input or Output under SyncManager (C)
  • D: the PDOs can be selected or deselected
  • H: the new process data are visible as linkable variables in the system manager
    The new process data are active once the configuration has been activated and TwinCAT has been restarted (or the EtherCAT master has been restarted)
  • E: if a slave supports this, Input and Output PDO can be modified simultaneously by selecting a so-called PDO record (“predefined PDO settings”).

Fig. 1: Configuring the process data

Note 		Manual modification of the process data
According to the ESI description, a PDO can be identified as “fixed” with the flag “F” in the PDO overview (Fig. 1, J). The configuration of such PDOs cannot be changed, even if TwinCAT offers the associated dialog (“Edit”).

In particular, CoE content cannot be displayed as cyclic process data.

This generally also applies in cases where a device supports download of the PDO configuration, “G”.

In case of incorrect configuration the EtherCAT slave usually refuses to start and change to OP state. The System Manager displays an “invalid SM cfg” logger message:

This error message (“invalid SM IN cfg” or “invalid SM OUT cfg”) also indicates the reason for the failed start.


General Notes - EtherCAT Slave Application

Table of contents
• Diagnosis in real time: WorkingCounter, EtherCAT State and Status
• CoE - Parameter Directory
• Commissioning aid in the TwinCAT System Manager
 • EtherCAT State: automatic default behavior of the TwinCAT System Manager and manual operation
• Note regarding E-Bus current

This summary briefly deals with a number of aspects of EtherCAT Slave operation under TwinCAT. More detailed information on this may be found in the corresponding sections of, for instance, the EtherCAT System Documentation.

Diagnosis in real time: WorkingCounter, EtherCAT State and Status

Generally speaking an EtherCAT Slave provides a variety of diagnostic information that can be used by the controlling task.

This diagnostic information relates to differing levels of communication. It therefore has a variety of sources, and is also updated at various times.

Any application that relies on I/O data from a fieldbus being correct and up to date must make diagnostic access to the corresponding underlying layers. EtherCAT and the TwinCAT System Manager offer comprehensive diagnostic elements of this kind. Those diagnostic elements that are helpful to the controlling task for diagnosis that is accurate for the current cycle when in operation (not during commissioning) are discussed below.

Fig. 1: Selection of the diagnostic information of an EtherCAT Slave

In general, an EtherCAT Slave offers

  • communication diagnosis typical for a slave (diagnosis of successful participation in the exchange of process data, and correct operating mode)
    This diagnosis is the same for all slaves.

    as well as
  • function diagnosis typical for a channel (device-dependent)
    See the corresponding device documentation

The colours in Fig. 1 also correspond to the variable colours in the System Manager, see Fig. 2.

Colour | Meaning
yellow | Input variables from the Slave to the EtherCAT Master, updated in every cycle
red | Output variables from the Slave to the EtherCAT Master, updated in every cycle
green | Information variables for the EtherCAT Master that are updated acyclically. This means that it is possible that in any particular cycle they do not represent the latest possible status. It is therefore useful to read such variables through ADS.

Fig. 2 shows an example of an implementation of basic EtherCAT Slave Diagnosis. A Beckhoff EL3102 (2-channel analogue input terminal) is used here, as it offers both the communication diagnosis typical of a slave and the functional diagnosis that is specific to a channel. Structures are created as input variables in the PLC, each corresponding to the process image.

Fig. 2: basic EtherCAT Slave Diagnosis in the PLC

The following aspects are covered here:

Code Function Implementation Application/evaluation
A The EtherCAT Master's diagnostic information

updated acyclically (yellow) or provided acyclically (green).

 At least the DevState is to be evaluated for the most recent cycle in the PLC.

The EtherCAT Master's diagnostic information offers many more possibilities than are treated in the EtherCAT System Documentation. A few keywords:

  • CoE in the Master for communication with/through the Slaves
  • Functions from TcEtherCAT.lib
  • Perform an OnlineScan
B In the example chosen (EL3102) the EL3102 comprises two analogue input channels that transmit a single function status for the most recent cycle. Status
  • the bit significations may be found in the device documentation
  • other devices may supply more information, or none that is typical of a slave
 In order for the higher-level PLC task (or corresponding control applications) to be able to rely on correct data, the function status must be evaluated there. Such information is therefore provided with the process data for the most recent cycle.
C For every EtherCAT Slave that has cyclic process data, the Master displays, using what is known as a WorkingCounter, whether the slave is participating successfully and without error in the cyclic exchange of process data. This important, elementary information is therefore provided for the most recent cycle in the System Manager
  1. at the EtherCAT Slave, and, with identical contents
  2. as a collective variable at the EtherCAT Master (see Point A)

for linking.

 WcState (Working Counter)

0: valid real-time communication in the last cycle

1: invalid real-time communication

This may possibly have effects on the process data of other Slaves that are located in the same SyncUnit

 In order for the higher-level PLC task (or corresponding control applications) to be able to rely on correct data, the communication status of the EtherCAT Slave must be evaluated there. Such information is therefore provided with the process data for the most recent cycle.
D Diagnostic information of the EtherCAT Master which, while it is represented at the slave for linking, is actually determined by the Master for the Slave concerned and represented there. This information cannot be characterized as real-time, because it
  • is only rarely/never changed, except when the system starts up
  • is itself determined acyclically (e.g. EtherCAT Status)
 State

current Status (INIT..OP) of the Slave. The Slave must be in OP (=8) when operating normally.

AdsAddr

The ADS address is useful for communicating from the PLC/task via ADS with the EtherCAT Slave, e.g. for reading/writing to the CoE. The AMS-NetID of a slave corresponds to the AMS-NetID of the EtherCAT Master; communication with the individual Slave is possible via the port (= EtherCAT address).

 Information variables for the EtherCAT Master that are updated acyclically. This means that it is possible that in any particular cycle they do not represent the latest possible status. It is therefore possible to read such variables through ADS.

Attention 		Diagnostic information
It is strongly recommended that the diagnostic information made available is evaluated so that the application can react accordingly.

CoE Parameter Directory

The CoE parameter directory (CanOpen-over-EtherCAT) is used to manage the set values for the slave concerned. Changes may, in some circumstances, have to be made here when commissioning a relatively complex EtherCAT Slave. It can be accessed through the TwinCAT System Manager, see Fig. 3:

Fig. 3: EL3102, CoE directory

Note 		EtherCAT System Documentation
The comprehensive description in the EtherCAT System Documentation (EtherCAT Basics --> CoE Interface) must be observed!

A few brief extracts:

  • Whether changes in the online directory are saved locally in the slave depends on the device. EL terminals (except the EL66xx) are able to save in this way.
  • The user must manage the changes to the StartUp list.

Commissioning aid in the TwinCAT System Manager

Commissioning interfaces are being introduced as part of an ongoing process for EL/EP EtherCAT devices. These are available in TwinCAT System Managers from TwinCAT 2.11R2 and above. They are integrated into the System Manager through appropriately extended ESI configuration files.

Fig. 4: Example of commissioning aid for a EL3204

This commissioning process simultaneously manages

  • CoE Parameter Directory
  • DC/FreeRun mode
  • the available process data records (PDO)

Although the "Process Data", "DC", "Startup" and "CoE-Online" that used to be necessary for this are still displayed, it is recommended that, if the commissioning aid is used, the automatically generated settings are not changed by it.

The commissioning tool does not cover every possible application of an EL/EP device. If the available setting options are not adequate, the user can make the DC, PDO and CoE settings manually, as in the past.

EtherCAT State: automatic default behaviour of the TwinCAT System Manager and manual operation

After the operating power is switched on, an EtherCAT Slave must go through the following statuses

  • INIT
  • PREOP
  • SAFEOP
  • OP

to ensure sound operation. The EtherCAT Master directs these statuses in accordance with the initialization routines that are defined for commissioning the device by the ES/XML and user settings (Distributed Clocks (DC), PDO, CoE). See also the section on "Principles of Communication, EtherCAT State Machine" in this connection. Depending how much configuration has to be done, and on the overall communication, booting can take up to a few seconds.

The EtherCAT Master itself must go through these routines when starting, until it has reached at least the OP target state.

The target state wanted by the user, and which is brought about automatically at start-up by TwinCAT, can be set in the System Manager. As soon as TwinCAT reaches the status RUN, the TwinCAT EtherCAT Master will approach the target states.

Standard setting

The advanced settings of the EtherCAT Master are set as standard:

  • EtherCAT Master: OP
  • Slaves: OP
    This setting applies equally to all Slaves.

Fig. 5: Default behaviour of the System Manager

In addition, the target state of any particular Slave can be set in the "Advanced Settings" dialogue; the standard setting is again OP.

Fig. 6: Default target state in the Slave

Manual Control

There are particular reasons why it may be appropriate to control the states from the application/task/PLC. For instance:

  • for diagnostic reasons
  • to induce a controlled restart of axes
  • because a change in the times involved in starting is desirable

In that case it is appropriate in the PLC application to use the PLC function blocks from the TcEtherCAT.lib, which is available as standard, and to work through the states in a controlled manner using, for instance, FB_EcSetMasterState.

It is then useful to put the settings in the EtherCAT Master to INIT for master and slave.

Fig. 7: PLC function blocks

Note regarding E-Bus current

EL/ES terminals are placed on the DIN rail at a coupler on the terminal strand. A Bus Coupler can supply the EL terminals added to it with the E-bus system voltage of 5 V; a coupler is thereby loadable up to 2 A as a rule. Information on how much current each EL terminal requires from the E-bus supply is available online and in the catalogue. If the added terminals require more current than the coupler can supply, then power feed terminals (e.g. EL9410) must be inserted at appropriate places in the terminal strand.

The pre-calculated theoretical maximum E-Bus current is displayed in the TwinCAT System Manager as a column value. A shortfall is marked by a negative total amount and an exclamation mark; a power feed terminal is to be placed before such a position.

Fig. 8: illegally exceeding the E-Bus current

From TwinCAT 2.11 and above, a warning message "E-Bus Power of Terminal..." is output in the logger window when such a configuration is activated:

Fig. 9: Warning message for exceeding E-Bus current

Attention 		Caution! Malfunction possible!
The same ground potential must be used for the E-Bus supply of all EtherCAT terminals in a terminal block!


EL3413 - Process data

BECKHOFF EL3413: Commissioning

Process data

Table of contents
• Sync Manager
- PDO assignment
• Operating modes and settings
- Confirmation of the variable output value, channel 1 - 3
- Confirmation of the variable output value, auxiliary channel
• Predifined PDO Assignment

Sync Manager (SM)

The scope of the offered process data can be viewed on the ‘Process data’ tab in the TwinCAT System Manager (see fig. 1 & 2).

Fig. 1 Process Data tab SM2, EL3413

Fig. 2 Process Data tab SM3, EL3413

PDO Assignment

SM2, PDO assignment 0x1C12
Index | Index of excluded PDOs | Size (byte.bit) | Name | PDO content
0x1600 (default) | - | 1.0 | PM Outputs Channel 1 | Index 0x7000:01 - Index
0x1601(default) | - | 1.0 | PM Outputs Channel 2 | Index 0x7010:01 - Index
0x1602 (default) | - | 1.0 | PM Outputs Channel 2 | Index 0x7020:01 - Index
0x1603 (default) | - | 2.0 | PM Auxiliary Outputs Auxiliary | Index 0x7030:01 - Index Index 0x7030:02 - Channel
SM3, PDO Assignment 0x1C13
Index | Index of excluded PDOs | Size (byte.bit) | Name | PDO content
0x1A00 (default) | - | 20.0 | PM Inputs Channel 1 | Index 0x6000:01 - STATUS_Overvoltage Index 0x6000:02 - STATUS_Undervoltage Index 0x6000:03 - STATUS_Overcurrent Index 0x6000:05 - STATUS_Phase sequence cw Index 0x6000:06 - STATUS_Phase sequence ccw Index 0x6000:07 - STATUS_Missing zero crossing Index 0x6000:0F - STATUS_TxPDO State Index 0x6000:10 - STATUS_TxPDO Toggle Index 0x6000:11 - Current Index 0x6000:12 - Voltage Index 0x6000:13 - Active power Index 0x6000:14 - Index Index 0x6000:1D - Variant value
0x1A01(default) | - | 20.0 | PM Inputs Channel 2 | Index 0x6010:01 - STATUS_Overvoltage Index 0x6010:02 - STATUS_Undervoltage Index 0x6010:03 - STATUS_Overcurrent Index 0x6010:05 - STATUS_Phase sequence cw Index 0x6010:06 - STATUS_Phase sequence ccw Index 0x6010:07 - STATUS_Missing zero crossing Index 0x6010:0F - STATUS_TxPDO State Index 0x6010:10 - STATUS_TxPDO Toggle Index 0x6010:11 - Current Index 0x6010:12 - Voltage Index 0x6010:13 - Active power Index 0x6010:14 - Index Index 0x6010:1D - Variant value
0x1A02 (default) | - | 20.0 | PM Inputs Channel 3 | Index 0x6020:01 - STATUS_Overvoltage Index 0x6020:02 - STATUS_Undervoltage Index 0x6020:03 - STATUS_Overcurrent Index 0x6020:05 - STATUS_Phase sequence cw Index 0x6020:06 - STATUS_Phase sequence ccw Index 0x6020:07 - STATUS_Missing zero crossing Index 0x6020:0F - STATUS_TxPDO State Index 0x6020:10 - STATUS_TxPDO Toggle Index 0x6020:11 - Current Index 0x6020:12 - Voltage Index 0x6020:13 - Active power Index 0x6020:14 - Index Index 0x6020:1D - Variant value
0x1A03 (default) | - | 8.0 | PM Auxiliary Inputs Auxiliary | Index 0x6030:10 - STATUS_TxPDO Toggle Index 0x6030:11 - Index Index 0x6030:12 - Channel Index 0x6030:13 - Value

Table 1: SyncManager PDO assignment

Operating modes and settings

Confirmation of the variable output value for channel 1 - 3 (Index 6000:14, 6010:14, 6020:14)

The calculated values can be output on index 6000:1D (channel 1), 6010:1D (channel 2) or 6020:1D (channel 3) (see object description).
To this end enter the associated values for the output value (see 6000:14, 6010:14, 6020:14) in the "Set Value Dialog" window of index 7000:01, 7010:01 or 7020:01 ("CoE Online" tab).

Values (dec), Entry in index 7000:01, 7010:01, 7020:01 | Designation | Unit
0 | Apparent power | 0.01 VA
1 | Reactive power | 0.01 VAR
2 | Energy | 0.001 Wh
3 | cosPhi | 0,001
4 | Frequency | 0.1 Hz
5 | Energy (negative) | 0.001 Wh
6 | Angle λ between phase Lx and phase L1 | 0,01°
7-255 | reserved | -

The standard output value is the apparent power.

Confirmation of the variable output value, auxiliary channel (Index 6030:11)

The calculated values can be output on Index 6030:13 (see object description).
To do this, the corresponding values for the measured variable to be output (see Index 6030:11) are to be entered in the “Set Value Dialog” window of Index 7030:01 (“CoE-Online” tab) and the corresponding channel 1-3 in the “Set Value Dialog” window of Index 7030:02 (“CoE-Online” tab).

Values (dec), Entry in Index 7030:02 | Values (dec), Entry in Index 7030:01 | Designation | Unit
0 | 0 | Reserved (THDN IA + IB + IC) – not yet integrated |
0 | 2 | Sum of the energy (channel 1-3) | 0.001 Wh
0 | 4 | Frequency | 0.1 Hz
0 | 5 | Sum of the energy (negative) (channel 1-3) | 0.001 Wh
0 | 10 | Sum of the active power (channel 1-3) | 0,01 W
0 | 11 | Sum of the reactive power (channel 1-3) | 0.01 Var
0 | 12 | Sum of the apparent power (channel 1-3) | 0.01 VA
0 | 100 | ADC temperature | °C
1..3 | 0 | Calculation ongoing |
1..3 | 1..21 | RMS value of the xth harmonic (current) | 0.000001 A
1..3 | 51..71 | Ratio of the xth harmonic to the fundamental (current) | 0,01 %
1..3 | 100 | Calculation ongoing |
1..3 | 101..121 | RMS value of the xth harmonic (voltage) | 0,0001 V
1..3 | 151..171 | Ratio of the xth harmonic to the fundamental (voltage) | 0,01 %
11..13 | 0 | Apparent power of phase x | 0.01 VA
11..13 | 1 | Reactive power of phase x | 0.01 Var
11..13 | 2 | Energy of phase x | 0.001 Wh
11..13 | 3 | cosPhi of phase x | 0,001
11..13 | 4 | Frequency of phase x | 0.1 Hz
11..13 | 5 | Energy (negative) of phase x | 0.001 Wh
11..13 | 6 | Angle λ between phase x and phase 1 | 0,01°
11..13 | 10 | Current of phase x | 0.000001 A
11..13 | 11 | Voltage of phase x | 0.0001 V
11..13 | 12 | Active power of phase x | 0.01 W

Predifined PDO Assignment

The “Predefined PDO Assignment” enables a simplified selection of the process data. The desired function is selected on the lower part of the “Process Data” tab. As a result, all necessary PDOs are automatically activated and the unnecessary PDOs are deactivated.
If channels are not to be used, it is recommended to deactivate the respective channels in order to avoid possible error messages from the terminal.

Fig. 3: Selection of predefined PDOs

There is a choice of nine PDO assignments:

Name | SM2, PDO assignment | SM3, PDO assignment
Complete (Phase 1/2/3 + Auxiliary) | 0x1600 (PM Outputs Channel 1) 0x1601 (PM Outputs Channel 2) 0x1602 (PM Outputs Channel 3) 0x1603 (PM Outputs Auxiliary) | 0x1A00 (PM Inputs Channel 1) 0x1A01 (PM Inputs Channel 2) 0x1A02 (PM Inputs Channel 3) 0x1A03 (PM Inputs Auxiliary)
Minimal (all phases active, accessible by Auxiliary channel) | 0x1603 (PM Outputs Auxiliary) | 0x1A03 (PM Inputs Auxiliary)
Phase 1/2/3 | 0x1600 (PM Outputs Channel 1) 0x1601 (PM Outputs Channel 2) 0x1602 (PM Outputs Channel 3) | 0x1A00 (PM Inputs Channel 1) 0x1A01 (PM Inputs Channel 2) 0x1A02 (PM Inputs Channel 3)
Phase 1 only | 0x1600 (PM Outputs Channel 1) | 0x1A00 (PM Inputs Channel 1)
Phase 2 only | 0x1601 (PM Outputs Channel 2) | 0x1A01 (PM Inputs Channel 2)
Phase 3 only | 0x1602 (PM Outputs Channel 3) | 0x1A02 (PM Inputs Channel 3)
Phase 1+2 | 0x1600 (PM Outputs Channel 1) 0x1601 (PM Outputs Channel 2) | 0x1A00 (PM Inputs Channel 1) 0x1A01 (PM Inputs Channel 2)
Phase 1+3 | 0x1600 (PM Outputs Channel 1) 0x1602 (PM Outputs Channel 3) | 0x1A00 (PM Inputs Channel 1) 0x1A02 (PM Inputs Channel 3)
Phase 2+3 | 0x1601 (PM Outputs Channel 2) 0x1602 (PM Outputs Channel 3) | 0x1A01 (PM Inputs Channel 2) 0x1A02 (PM Inputs Channel 3)


EL7201 - Configuring the main parameters

BECKHOFF EL3413: Commissioning

Adjustments and measurements

(Master TwinCAT 2.11 R3)

Table of contents
• Reference channel for the frequency measurement and power/energy measurement
• Measuring cycle time
• Current measuring range
• PM Command (Index FB00)

Reference channel for the frequency measurement and power/energy measurement

In the EL3413 all 3 channels are always selected independently of one another as reference for the frequency measurement or power/energy measurement. In order to avoid an error message from the terminal, the channels that are not in use should be deactivated.
The correct channels can be selected with the help of the predefined PDOs. Beyond that individual phases can be switched on or off with the help of the Command Object (index FB00:01).

Measuring cycle time

Number of periods taken as the basis for the calculation of the true RMS value. The higher this value the more uniform the output values. A minimum of 4 periods is necessary; however a minimum of 5 periods is recommended.
The default value of 10 periods has proven to be a good compromise between stability and speed.

The measuring cycle time can be changed with the help of the Command Object (index FB00:01). The command is started by writing subindex 1 (request). Write access is disabled until the current command is completed.

0x0022 Measuring interval 4 periods
0x0122 Measuring interval 5 periods
0x0222 Measuring interval 10 periods (default)
0x0322 Measuring interval 16 periods
0x0422 Measuring interval 32 periods

Example

In order to change the measuring interval to 16 periods, the value 0322hex must be entered in Index FB00:01.

The adoption of the new measuring cycle time can take up to 10 seconds. The value is not stored in the EEPROM; following a voltage reset of the terminal a measuring cycle time of 10 periods is set again. In order to avoid this, the value can be set with the help of a startup parameter.

Current measuring range

The EL3413 offers three current measuring ranges. The full scale value for current can be set to 5A, 1 A or 0.1 A (yet not released). The correct setting of the full scale value is important in order to avoid unnecessary measurement inaccuracies. It is recommended to always measure in the upper third of the full scale value.

Example

In order to change the full scale value to 5 A, the value 2dec must be entered in index 8027:19.

Attention 		Risk of damage to the device!
Exceeding the full scale value can lead to incorrect measurement results and to damage to the terminal.

PM Command (Index FB00)

The command object is used for triggering an action in the terminal. The command is started by writing subindex 1 (request). Write access is disabled until the current command is completed.
When writing the subindex, note that you cannot write directly in the ‘Hex’ field; the ‘Binary’ field must be used for this. The input takes place in the reverse order, with space (see fig. 1).

Example

To delete the energy values of all channels manually enter 0004hex in index FB00:01.

Fig. 1: Writing Subindex 01, Object FB00


EL7201 - Configuring the main parameters

BECKHOFF EL3413: Commissioning

Measurements

(Master TwinCAT 2.11 R3)

Table of contents
• Energy
- manualsaved (Index 90x01:01 and 90x0:02
- autosaved (Index 90x0:03 and 90x0:04)
• PM Inputs Channel 1/2/3
- STATUS
- Current
- Voltage
- Active Power
- Index
- VariantValue
• PM Inputs Channel Auxiliary
- STATUS
- Index
- Channel
- Value
• PM Outputs Channel 1/2/3
- Index
• PM Ouputs Channel Auxiliary
- Index
- Channel

Energy

manualsaved (Index 90x0:01 and 90x0:02)

The energy values of channels 1-3 can be saved in the Objects 90x0:01 (e.g. before switching the system off in order to save the energy value as accurately as possible) or the energy values already saved can be deleted. This is initiated by the Command Object (Index FB00:01). The negative energy value (generator mode) can be saved in the Objects 90x0:02. These values can only be saved or deleted manually.

This value is saved under Index 0xF801 in the case of the EL3403. For reasons of compatibility this index also exists in the EL3413. If program modules are to access this index, these can continue to be used. However, it is recommended to use Index 90x0 in new applications.

Example 1

If the energy value of channel 2 is to be saved manually enter 0214hex in index FB00:01.

Example 2

To delete the energy values of all channels manually enter 0004hex in index FB00:01.

autosaved (Index 90x0:03 and 90x0:04)

The energy values of channels 1-3 are automatically saved in the Objects 90x0:03 every 15 minutes. Beyond that the user has the possibility using the Command Object (Index FB00:01) to also save the momentary energy value at a self-defined moment or to delete complete contents. The 15-minute timer starts again at zero at this moment.

Example 1

If the energy value of channel 3 is to be saved manually enter 0334hex in index FB00:01.

Example 2

To delete the energy values of all channels manually enter 0024hex in index FB00:01.

PM Inputs Channel 1/2/3

STATUS

The following useful status information for the respective channel can be read in with the “STATUS” structure.

  • Overvoltage (voltage is greater than 415 V)
  • Undervoltage (voltage is smaller than 5 V)
  • Overcurrent (current is 1.1x greater than the full scale value)
  • Phase sequence cw (clockwise-rotating field)
  • Phase sequence ccw (counter-clockwise rotating field)
  • Missing zero crossing
  • TxPDO State
  • TxPDO Toggle

Current

Cyclic measurement of the current of the respective phase.

Voltage

Cyclic measurement of the voltage of the respective phase.

Active power

Cyclic measurement of the active power of the respective phase.

Index

Indicates which parameter the “VariantValue” is currently measuring.

VariantValue

There are several parameters behind the VariantValue. It is possible to read in the following values for the respective channel.

  • the apparent power
  • the reactive power
  • the energy
  • the cosPhi
  • the frequency
  • the negative energy
  • the angle α of the respective phase to phase L1

The individual parameters are switched over with the help of the respective cyclic output variable “Index”.

PM Inputs Auxiliary

STATUS

The TxPDO Toggle of this channel can be read in here

Index

Indicates which parameter the “Value” is currently measuring. The value 0 or 100 means that a measurement is currently still running.

Channel

Indicates the channel on which measurement is currently taking place.

Value

There are several parameters behind the Value. If the value ‘0’ is entered in “Channel”, the following values can be read in.

  • THDN IL1+IL2+IL3 (presently not active)
  • Sum of the energy (phase 1-3)
  • Frequency
  • Sum of the negative energy (phase 1-3)
  • Sum of the active power (phase 1-3)
  • Sum of the reactive power (phase 1-3)
  • Sum of the apparent power (phase 1-3)
  • Temperature at the ADC

If the value 1, 2 or 3 is entered in the channel, the following values of the respective phase 1, 2 or 3 can be read in.

  • RMS value of the harmonic of the current
  • Ratio of the harmonic to the fundamental of the current
  • RMS value of the harmonic of the voltage
  • Ratio of the harmonic to the fundamental of the voltage

If the value 11, 12 or 13 is entered in the channel, the following values of the respective phase 1, 2 or 3 can be read in.

  • the apparent power
  • the reactive power
  • the energy
  • the cosPhi
  • the frequency
  • the negative energy
  • the angle λ of the respective phase to phase L1
  • the current
  • the voltage
  • the active power

The individual parameters are switched over with the help of the cyclic output variable “Index”.

PM Outputs Channel 1/2/3

Index

The value of the parameter that is to be measured and read in in the corresponding “Variant value” is to be entered here.

PM Outputs Auxiliary

Index

The value of the parameter that is to be measured and read in in the “Value” is to be entered here.

Channel

The phase that is to be measured can be selected here.


EL3413 - Scaling factors

BECKHOFF EL3413: Commissioning

Scaling factors

The following overview indicates the scaling factors that are required for the calculation of the actual values from the raw process data values.

EL3413 scaling factors

Values | Calculation
Current (5 A) | Raw values x 0.000001 A
Current (1 A) | Raw values x 0.000001 A
Current (0.1 A) | presently not active
Voltage | Raw values x 0.0001 V
Active power | Raw values x 0.01 W
Apparent power | Raw values x 0.01 VA
Reactive power | Raw values x 0.01 Var
Energy | Raw values x 0.001 Wh
cosPhi | Raw values x 0.001
Frequency | Raw values x 0.1 Hz
Angle λ | Raw values x 0.01°
THDN (IA+IB+IC) | presently not active
RMS value of harmonic (Current 1 A) | Raw values x 0.000001 A
RMS value of harmonic (Current 5 A) | Raw values x 0.000001 A
Ratio of harmonic to fundamental | Raw values x 0.01 %
RMS value of harmonic Voltage | Raw values x 0.0001 V

Table 1: Scaling factors for the calculation of the actual values from raw process data values


Notices on analog specifications

Beckhoff I/O devices (terminals, boxes) with analog inputs are characterized by a number of technical characteristic data; refer to the technical data in the respective documents.

Some explanations are given below for the correct interpretation of these characteristic data.

Keyword Explanation
Full scale value An I/O device with an analog input measures over a nominal measuring range that is limited by an upper and a lower limit (initial value and end value); these can usually be taken from the device designation.
The range between the two limits is called the measuring span and corresponds to the equation (end value - initial value). Analogous to pointing devices this is the measuring scale (see IEC 61131) or also the dynamic range.

For analog I/O devices from Beckhoff the rule is that the limit with the largest value is chosen as the full scale value of the respective product (also called the reference value) and is given a positive sign. This applies to both symmetrical and asymmetrical measuring spans.

For the above examples this means:

  • Measuring range 0 to 10 V: asymmetric unipolar, full scale value = 10 V, measuring span = 10 V
  • Measuring range 4 to 20 mA: asymmetric unipolar, full scale value = 20 mA, measuring span = 16 mA
  • Measuring range -200 to 1370 °C: asymmetric bipolar, full scale value = 1370 °C, measuring span = 1570 °C
  • Measuring range -10 to +10 V: symmetric bipolar, full scale value = 10 V, measuring span = 20 V
± measuring error [% of the full scale value]

(also: measurement error)

The relative measuring error is referenced to the full scale value and is calculated as the quotient of the largest numerical deviation from the true value (‘measuring error’) referenced to the full scale value.

The measuring error is generally valid for the entire permitted operating temperature range, also called the ‘usage error limit’ and contains random and systematic portions of the referred device (i.e. ‘all’ influences such as temperature, inherent noise, aging, etc.).

It always to be regarded as a positive/negative span with ±, even if it is specified without ± in some cases.

The maximum deviation can also be specified directly.

Example: Measuring range 0 to 10 V and measuring error < ± 0.3 % full scale value --> maximum deviation ± 30 mV in the permissible operating temperature range.

Notice: since this specification also includes the temperature drift, a significantly lower measuring error can usually be assumed in case of a constant ambient temperature and thermal stabilization of the device.


EL3413 - Object description

BECKHOFF EL3413: Commissioning

Object description and parameterization

Note 		EtherCAT XML Device Description
The description correspond to the display of the CoE objects from the EtherCAT XML Device Description. It is strongly recommended to download the latest revision of the corresponding XML file from the Beckhoff website and follow the installation instructions.

Note 		Parameterization
Terminals' parameterization will be conducted by the CoE tab (double-click on the referring object) or the Process data tab (PDO assignment)

Introduction

The CoE overview contains objects for different intended applications:

  • Objects required for parameterization during commissioning
  • Objects intended for regular operation, e.g. through ADS access.
  • Objects for indicating internal settings (may be fixed)
  • Profile specific objects, showing the input and output data.

The following section first describes the objects require for normal operation, followed by a complete overview of other objects.

Objects for commissioning

Index 1011 Restore default parameters
Index | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore the default settings in the EtherCAT slave | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" ("Set Value Dialog") all terminal-specific objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)
Index 8027 PM Settings
Index | Name | Meaning |  |  | Data type | Flags | Default
8027:0 | PM Settings |  | Value | Description | UINT8 | RO | 0x28 (40dec)
8027:03 | Measuring mode | Measuring method | 0 | 3-wire connection delta, 4-wire connection star | BIT2 | RW | 0x00 (0dec)
 |  |  | 1 | reserved
 |  |  | 2 | reserved
8027:19 | Current range | Current measuring range | 0 | 1 A | BIT4 | RW | 0x00 (0dec)
 |  |  | 1 | 0.1 A (presently not active)
 |  |  | 2 | 5 A
8027:28 | External CT phase Offset | Phase shift of the external current transformers |  |  | UINT16 | RW | 0x000A (0dec)

Objects for regular operation

Index FB00 PM Command

The command object is used for triggering an action in the terminal. The command is started by writing subindex 1 (request). Write access is disabled until the current command is completed.

Index | Name | Meaning |  | Data type | Flags | Default
FB00:0 | PM Command | Max. subindex |  | UINT8 | RO | 0x03 (3dec)
FB00:01 | Request | Byte 0 - Service Request datd |  | OCTET-STRING [2] | RW | 0x0000 (0dec)
 |  | 2hex | Phase measurement switch off
 |  | 4hex | Delete energy value
 |  | 12hex | Switch on phase
 |  | 14hex | Store energy value
 |  | 24hex | Delete energy (autosaved)
 |  | 34hex | Save energy (autosaved)
 |  | Byte 1 - Selection of channel
 |  | 00hex | All channels
 |  | 01hex | Ch. 1
 |  | 02hex | Ch. 2
 |  | 03hex | Ch. 3
FB00:02 | Status | Byte 0 |  | UINT8 | RW | 0x00 (0dec)
 |  | reserved
FB00:03 | Response | Byte 0 |  | OCTET-STRING [4] | RW | 0x00000000 (0dec)
 |  | reserved
 |  | Byte 1
 |  | reserved
 |  | Byte 2-n
 |  | reserved

Complete overview

Standard objects (0x1000-0x1FFF)

The standard objects of all EtherCAT slaves have the same Meaning.

Index 1000 Device type
Index | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device Type of the EtherCAT slave: The Lo-Word contains the supported CoE Profile (5001). | UINT32 | RO | 0x01541389
Index 1008 Device name
Index | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EL3413
Index 1009 Hardware version
Index | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slaves | STRING | RO | 01
Index 100A Software version
Index | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slaves | STRING | RO | 01
Index 1018 Identity
Index | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Contains informations to identify the EtherCAT slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x0D4B3052 (223031378dec)
1018:03 | Revision | Revision number of the EtherCAT-Slave, the Lo-Word (Bit 0-15) indicates the special functions terminal number; the Hi-Word (Bit 16-31) refers to the device description. | UINT32 | RO | 0x00100000 (1048576dec)
1018:04 | Serial number | Serial number of the EtherCAT-Slave, the Lo-Byte (Bit 0-7) of the Lo-Word contains the year of manufacturing, the Hi-Byte (Bit 8-15) of the Lo-Word contains the week of manufacturing, the Hi-Word (Bit 16-31) is 0 . | UINT32 | RO | e.g. 0x00001E06 (KW 30/2006)
Index 10F0 Backup parameter
Index | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter | Contains informations for the standardized Upload and Download of the Backup Entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum over all backup entries | UINT32 | RW | 0x00000000 (0dec)
Index 1600 RxPDO-Map Ch.1
Index | Name | Meaning | Data type | Flags | Default
1600:0 | RxPDO-Map Ch.1 | PDO Mapping RxPDO 1 | UINT8 | RO | 0x01 (1dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (PWM Outputs Ch.1), entry 0x11 (PWM output)) | UINT32 | RW | 0x7000:01, 8
Index 1601 RxPDO-Map Ch.2
Index | Name | Meaning | Data type | Flags | Default
1601:0 | RxPDO-Map Ch.2 | PDO Mapping RxPDO 2 | UINT8 | RO | 0x01 (1dec)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (PWM Outputs Ch.2), entry 0x11 (PWM output)) | UINT32 | RW | 0x7010:01, 8
Index 1602 RxPDO-Map Ch.3
Index | Name | Meaning | Data type | Flags | Default
1602:0 | RxPDO-Map Ch.3 | PDO Mapping RxPDO 3 | UINT8 | RO | 0x01 (1dec)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (PM Outputs Ch.3), entry 0x01 (Index)) | UINT32 | RW | 0x7020:01, 8
Index 1603 RxPDO-Map Auxiliary Channel
Index | Name | Meaning | Data type | Flags | Default
1602:0 | RxPDO-Map Ch.3 | PDO Mapping RxPDO 3 | UINT8 | RO | 0x01 (1dec)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7030 (PM Outputs Ch.3), entry 0x01 (Index)) | UINT32 | RW | 0x7030:01, 8
1603:02 | SubIndex 002 | 1. PDO Mapping entry (object 0x7030 (PM Auxiliary Outputs Ch.3), entry 0x02 (Channel)) | UINT32 | RW | 0x7030:02, 8
Index 1A00 TxPDO-Map Ch.1
Index | Name | Meaning | Data type | Flags | Default
1A00:0 | TxPDO-Map Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x0D (16dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (PM Inputs Ch.1), entry 0x01 (Undervoltage)) | UINT32 | RW | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (PM Inputs Ch.1), entry 0x02 (Overvoltage)) | UINT32 | RW | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (PM Inputs Ch.1), entry 0x03 (Overcurrent)) | UINT32 | RW | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (Align) | UINT32 | RW | 0x0000:00, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (PM Inputs Ch.1), entry 0x05 (Phase sequence cw)) | UINT32 | RW | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (PM Inputs Ch.1), entry 0x06 (Phase sequence ccw)) | UINT32 | RW | 0x6000:06, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (PM Inputs Ch.1), entry 0x7 (Missing zero crossing)) | UINT32 | RW | 0x6000:07, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (Align) | UINT32 | RW | 0x6000:08, 7
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (PM Inputs Ch.1), entry 0x10 (TxPDO State)) | UINT32 | RW | 0x6000:09, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (PM Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RW | 0x6000:10, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (PM Inputs Ch.1), entry 0x11 (Current)) | UINT32 | RW | 0x6000:11, 32
1A00:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (PM Inputs Ch.1), entry 0x12 (Voltage)) | UINT32 | RW | 0x6000:12, 32
1A00:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6000 (PM Inputs Ch.1), entry 0x13 (Active power)) | UINT32 | RW | 0x6000:13, 32
1A00:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6000 (PM Inputs Ch.1), entry 0x14 (Index)) | UINT32 | RW | 0x6000:14, 8
1A00:0F | SubIndex 015 | 15. PDO Mapping entry (Align) | UINT32 | RW | 0x0000:00, 8
1A00:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6000 (PM Inputs Ch.1), entry 0x1D (VariantValue)) | UINT32 | RW | 0x6000:1D, 32
Index 1A01 TxPDO-Map Ch.2
Index | Name | Meaning | Data type | Flags | Default
1A01:0 | TxPDO-Map Ch.2 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x10 (16dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (PM Inputs Ch.1), entry 0x01 (Undervoltage)) | UINT32 | RW | 0x6010:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (PM Inputs Ch.1), entry 0x02 (Overvoltage)) | UINT32 | RW | 0x6010:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (PM Inputs Ch.1), entry 0x03 (Overcurrent)) | UINT32 | RW | 0x6010:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (Align) | UINT32 | RW | 0x0000:00, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (PM Inputs Ch.1), entry 0x05 (Phase sequence cw)) | UINT32 | RW | 0x6010:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (PM Inputs Ch.1), entry 0x06 (Phase sequence ccw)) | UINT32 | RW | 0x6010:06, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (PM Inputs Ch.1), entry 0x7 (Missing zero crossing)) | UINT32 | RW | 0x6010:07, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (Align) | UINT32 | RW | 0x6010:08, 7
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6010 (PM Inputs Ch.1), entry 0x10 (TxPDO State)) | UINT32 | RW | 0x6010:09, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6010 (PM Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RW | 0x6010:10, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6010 (PM Inputs Ch.1), entry 0x11 (Current)) | UINT32 | RW | 0x6010:11, 32
1A01:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6010 (PM Inputs Ch.1), entry 0x12 (Voltage)) | UINT32 | RW | 0x6010:12, 32
1A01:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6010 (PM Inputs Ch.1), entry 0x13 (Active power)) | UINT32 | RW | 0x6010:13, 32
1A01:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6010 (PM Inputs Ch.1), entry 0x14 (Index)) | UINT32 | RW | 0x6010:14, 8
1A01:0F | SubIndex 015 | 15. PDO Mapping entry (Align) | UINT32 | RW | 0x0000:00, 8
1A01:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6010 (PM Inputs Ch.1), entry 0x1D (VariantValue)) | UINT32 | RW | 0x6010:1D, 32
Index 1A02 TxPDO-Map Ch.3
Index | Name | Meaning | Data type | Flags | Default
1A02:0 | TxPDO-Map Ch.3 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x10 (16dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (PM Inputs Ch.1), entry 0x01 (Undervoltage)) | UINT32 | RW | 0x6020:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (PM Inputs Ch.1), entry 0x02 (Overvoltage)) | UINT32 | RW | 0x6020:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (PM Inputs Ch.1), entry 0x03 (Overcurrent)) | UINT32 | RW | 0x6020:03, 1
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (Align) | UINT32 | RW | 0x0000:00, 1
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (PM Inputs Ch.1), entry 0x05 (Phase sequence cw)) | UINT32 | RW | 0x6020:05, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6020 (PM Inputs Ch.1), entry 0x06 (Phase sequence ccw)) | UINT32 | RW | 0x6020:06, 1
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020 (PM Inputs Ch.1), entry 0x7 (Missing zero crossing)) | UINT32 | RW | 0x6020:07, 1
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (Align) | UINT32 | RW | 0x6020:08, 7
1A02:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6020 (PM Inputs Ch.1), entry 0x10 (TxPDO State)) | UINT32 | RW | 0x6020:09, 1
1A02:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6020 (PM Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RW | 0x6020:10, 1
1A02:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6020 (PM Inputs Ch.1), entry 0x11 (Current)) | UINT32 | RW | 0x6020:11, 32
1A02:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6020 (PM Inputs Ch.1), entry 0x12 (Voltage)) | UINT32 | RW | 0x6020:12, 32
1A02:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6020 (PM Inputs Ch.1), entry 0x13 (Active power)) | UINT32 | RW | 0x6020:13, 32
1A02:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6020 (PM Inputs Ch.1), entry 0x14 (Index)) | UINT32 | RW | 0x6020:14, 8
1A02:0F | SubIndex 015 | 15. PDO Mapping entry (Align) | UINT32 | RW | 0x0000:00, 8
1A02:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6020 (PM Inputs Ch.1), entry 0x1D (VariantValue)) | UINT32 | RW | 0x6020:1D, 32
Index 1A03 TxPDO-Map Auxiliary
Index | Name | Meaning | Data type | Flags | Default
1A03:0 | TxPDO-Map Auxiliary | PDO Mapping TxPDO 4 | UINT8 | RO | 0x05 (5dec)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (Align) | UINT32 | RW | 0x0000:00, 15
1A03:02 | SubIndex 002 | 1. PDO Mapping entry (object 0x6030 (PM Auxiliary, entry 0x02 (TxPDO Toggle)) | UINT32 | RW | 0x6030:10, 1
1A03:03 | SubIndex 003 | 1. PDO Mapping entry (object 0x6030 (PM Auxiliary), entry 0x03 (Index)) | UINT32 | RW | 0x6030:10, 8
1A03:04 | SubIndex 004 | 1. PDO Mapping entry (object 0x6030 (PM Auxiliary), entry 0x04 (Channel)) | UINT32 | RW | 0x6030:10, 8
1A03:05 | SubIndex 005 | 1. PDO Mapping entry (object 0x6030 (PM Auxiliary, entry 0x05 (Value)) | UINT32 | RW | 0x6030:10, 32
Index 1C00 Sync manager type
Index | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Usage of the Sync Manager channels | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RW | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RW | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RW | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RW | 0x04 (4dec)
Index 1C12 RxPDO assign
Index | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RO | 0x03 (3dec)
1C12:01 | Subindex 001 | 1. assigned RxPDO (RxPDO-Map Ch.1 (RxPDO 1)) | UINT16 | RO | 0x1600 (5632dec)
1C12:02 | Subindex 002 | 2. assigned RxPDO (RxPDO-Map Ch.2 (RxPDO 2)) | UINT16 | RO | 0x1601 (5633dec)
1C12:03 | Subindex 003 | 3. assigned RxPDO (RxPDO-Map Ch.3 (RxPDO 3)) | UINT16 | RW | 0x1602 (5634dec)
1C12:04 | Subindex 004 | 4. assigned PDO (RxPDO-Map Auxiliary (RxPDO 4)) | UINT16 | RW | 0x1603 (5634dec)
Index 1C13 TxPDO assign
Index | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RO | 0x04 (4dec)
1C13:01 | Subindex 001 | 1. assigned PDO (TxPDO-Map Ch.1 (TxPDO 1)) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2. assigned PDO (TxPDO-Map Ch.2 (TxPDO 2)) | UINT16 | RW | 0x1A01 (6657dec)
1C13:03 | Subindex 003 | 3. assigned PDO (TxPDO-Map Ch.3 (TxPDO 3)) | UINT16 | RW | 0x1A02 (6658dec)
1C13:04 | Subindex 004 | 4. assigned PDO (TxPDO-Map Auxiliary (TxPDO 4)) | UINT16 | RW | 0x1A03 (6659dec)
Index 1C32 SM output parameter
Index | Name | Meaning | Data type | Flags | Default
1C32:0 | SM output parameter | Synchronization parameter of the outputs | UINT8 | RO | 0x20 (32dec)
1C32:01 Sync mode actual synchronization mode:
  • 0: Free Run
  • 1: Synchron with SM 2 Event
  • 2: DC-Mode - Synchron with SYNC0 Event
  • 3: DC-Mode - Synchron with SYNC1 Event
 UINT16 RW 0x0001 (1dec)
1C32:02 Cycle time Cycle time (in ns):
  • Free Run: cycle time of the local timer
  • Synchron with SM 2 Event: Cycle time of the master
  • DC-Mode: SYNC0/SYNC1 Cycle time
 UINT32 RW 0x000AAE60 (700000dec)
1C32:03 | Shift time | Time between SYNC0 Event and Outputs Valid (in ns, only in DC-Mode) | UINT32 | RW | 0x00000000 (0dec)
1C32:04 Sync modes supported Supported synchronization modes:
  • Bit 0 = 1: Free Run is supported
  • Bit 1 = 1: Synchron with SM 2 Event is supported
  • Bit 2-3 = 01: DC-Mode is supported
  • Bit 4-5 = 10: Output Shift with SYNC1 Event (only DC-Mode)
  • Bit 14 = 1: dynamic times (could be measured Messen by writing 1C32:08)
 UINT16 RW 0x8007 (32775dec)
1C32:05 | Minimum cycle time | Minimum cycle time supported (in ns) | UINT32 | RW | 0x000AAE60 (700000dec)
1C32:06 | Calc and copy time | Minimal time between SYNC0 and SYNC1 Event (in ns, only in DC-Mode) | UINT32 | RW | 0x00000000 (0dec)
1C32:08 Command
  • 0: Measurement of the times will be stopped
  • 1: Measurement of the times will be started

The Entries 1C32:03, 1C32:05, 1C32:06, 1C32:09, 1C33:03, 1C33:06, 1C33:09 will be updated with the maximum measured values.

UINT16 RW 0x0000 (0dec)
1C32:09 | Delay time | Time between SYNC1 Event and Outputs Valid (in ns, only in DC-Mode) | UINT32 | RW | 0x00000000 (0dec)
1C32:0B | SM event missed counter | Number of the missed SM-Events in state OPERATIONAL (only in DC Mode) | UINT16 | RW | 0x0000 (0dec)
1C32:0C | Cycle exceeded counter | Number of the exceeded cycles in state OPERATIONAL | UINT16 | RW | 0x0000 (0dec)
1C32:0D | Shift too short counter | Number of the too short distances between SYNC0 and SYNC1 Event (only in DC Mode) | UINT16 | RW | 0x0000 (0dec)
1C32:20 | Sync error | TRUE: In the last cycle the synchronization was not correct (only in DC Mode) | BOOLEAN | RW | 0x00 (0dec)
Index 1C33 SM input parameter
Index | Name | Meaning | Data type | Flags | Default
1C33:0 | SM input parameter | Synchronization parameter of the inputs | UINT8 | RO | 0x20 (32dec)
1C33:01 Sync mode Actual synchronization mode:
  • 0: Free Run
  • 1: Synchron with SM 3 Event (no Outputs available)
  • 2: DC - Synchron with SYNC0 Event
  • 3: DC - Synchron with SYNC1 Event
  • 34: Synchron with SM 2 Event (Outputs available)
 UINT16 RW 0x0022 (34dec)
1C33:02 | Cycle time | Same as 1C32:02 | UINT32 | RW | 0x000AAE60 (700000dec)
1C33:03 | Shift time | Time between SYNC0-Event and Input Latch (in ns, only in DC-Mode) | UINT32 | RW | 0x00000000 (0dec)
1C33:04 Sync modes supported Supported synchronization modes:
  • Bit 0: Free Run is supported
  • Bit 1: Synchron with SM 2 Event is supported (Outputs available)
  • Bit 1: Synchron with SM 3 Event is supported (no Outputs available)
  • Bit 2-3 = 01: DC-Mode is supported
  • Bit 4-5 = 01: Input Shift with local event (Outputs available)
  • Bit 4-5 = 10: Input Shift with SYNC1 Event (no Outputs available)
  • Bit 14 = 1: dynamic times (could be measured Messen by writing 1C32:08 or 1C33:08)
 UINT16 RW 0x8007 (32775dec)
1C33:05 | Minimum cycle time | Same as 1C32:05 | UINT32 | RW | 0x000AAE60 (700000dec)
1C33:06 | Calc and copy time | Time between Input Latch and the availability of the inputs for the master (in ns, only in DC-Mode) | UINT32 | RW | 0x00000000 (0dec)
1C33:08 | Command | Same as 1C32:08 | UINT16 | RW | 0x0000 (0dec)
1C33:09 | Delay time | Time between SYNC1-Event and Input Latch (in ns, only in DC-Mode) | UINT32 | RW | 0x00000000 (0dec)
1C33:0B | SM event missed counter | Same as 1C32:0B | UINT16 | RW | 0x0000 (0dec)
1C33:0C | Cycle exceeded counter | Same as 1C32:0C | UINT16 | RW | 0x0000 (0dec)
1C33:0D | Shift too short counter | Same as 1C32:0D | UINT16 | RW | 0x0000 (0dec)
1C33:20 | Sync error | Same as 1C32:20 | BOOLEAN | RW | 0x00 (0dec)

Profile specific objects (0x6000-0xFFFF)

The profile specific objects have the Same Meaning for all EtherCAT Slaves which support the profile 5001.

Index 6000 PM Inputs Ch.1
Index | Name | Meaning |  |  |  | Data type | Flags | Default
6000:0 | PM Inputs Ch.1 | Max. subindex |  |  |  | UINT8 | RO | 0x1D (29dec)
6000:0E | Sync Error | Reserved |  |  |  | BOOLEAN | RW | 0x00 (0dec)
6000:10 | TxPDO Toggle | Toggled with any zero crossing (Ch. 1) |  |  |  | BOOLEAN | RW | 0x00 (0dec)
6000:11 | Current | Current Ch. 1 | Unit: 0,000001 A |  |  | INT32 | RW | 0x00000000 (0dec)
6000:12 | Voltage | Voltage Ch. 1 | Unit: 0,0001 V |  |  | INT32 | RW | 0x00000000 (0dec)
6000:13 | Active power | Active power Ch. 1 | Unit: 0,01 W |  |  | INT32 | RW | 0x00000000 (0dec)
6000:14 | Index | Acknowledge for variant value Ch. 1 | Index (dec) | Meaning | Unit | UINT8 | RW | 0x00 (0dec)
 |  |  | 0 | Apparent power | 0.01 VA
 |  |  | 1 | Reactive power | 0.01 VAR
 |  |  | 2 | Energy | 0.001 Wh
 |  |  | 3 | cosPhi | 0.001
 |  |  | 4 | Frequency | 0.1 Hz
 |  |  | 5 | Energy (negative) | 0.001 Wh
 |  |  | 6 | Angle α between phase 1 and phase 1 | 0.01 °
 |  |  | 7 - 255 | reserved | -
6000:1D | VariantValue | Variant value Ch. 1 (see Index 6000:14) |  |  |  | INT32 | RW | 0x00000000 (0dec)
Index 6010 PM Inputs Ch.2
Index | Name | Meaning |  |  |  | Data type | Flags | Default
6010:0 | PM Inputs Ch.2 | Max. subindex |  |  |  | UINT8 | RO | 0x1D (29dec)
6010:0E | Sync Error | Reserved |  |  |  | BOOLEAN | RW | 0x00 (0dec)
6010:10 | TxPDO Toggle | Toggled with any zero crossing (Ch. 2) |  |  |  | BOOLEAN | RW | 0x00 (0dec)
6010:11 | Current | Current Ch. 2 | Unit: 0,000001 A |  |  | INT32 | RW | 0x00000000 (0dec)
6010:12 | Voltage | Voltage Ch. 2 | Unit: 0,0001 V |  |  | INT32 | RW | 0x00000000 (0dec)
6010:13 | Active power | Active power Ch. 2 | Unit: 0,01 W |  |  | INT32 | RW | 0x00000000 (0dec)
6010:14 | Index | Acknowledge for variant value Ch. 2 | Index (dec) | Meaning | Unit | UINT8 | RW | 0x00 (0dec)
 |  |  | 0 | Apparent power | 0.01 VA
 |  |  | 1 | Reactive power | 0.01 VAR
 |  |  | 2 | Energy | 0.001 Wh
 |  |  | 3 | cosPhi | 0.001
 |  |  | 4 | Frequency | 0.1 Hz
 |  |  | 5 | Energy | 0.001 Wh
 |  |  | 6 | Angle α between phase 2 and phase 1 | 0.01 °
 |  |  | 7-255 | reserved | -
6010:1D | VariantValue | Variant value Ch. 1 (see Index 6010:14) |  |  |  | INT32 | RW | 0x00000000 (0dec)
Index 6020 PM Inputs Ch.3
Index | Name | Meaning |  |  |  | Data type | Flags | Default
6020:0 | PM Inputs Ch.3 | Max. subindex |  |  |  | UINT8 | RO | 0x1D (29dec)
6020:0E | Sync Error | Reserved |  |  |  | BOOLEAN | RW | 0x00 (0dec)
6020:10 | TxPDO Toggle | Toggled with any zero crossing (Ch. 3) |  |  |  | BOOLEAN | RW | 0x00 (0dec)
6020:11 | Current | Current Ch. 3 | Unit: 0,000001 A |  |  | INT32 | RW | 0x00000000 (0dec)
6020:12 | Voltage | Voltage Ch. 3 | Unit: 0,0001 V |  |  | INT32 | RW | 0x00000000 (0dec)
6020:13 | Active power | Active power Ch. 3 | Unit: 0,01 W |  |  | INT32 | RW | 0x00000000 (0dec)
6020:14 | Index | Acknowledge for variant value Ch. 3 | Index (dec) | Meaning | Unit | UINT8 | RW | 0x00 (0dec)
 |  |  | 0 | Apparent power | 0.01 VA
 |  |  | 1 | Reactive power | 0.01 VAR
 |  |  | 2 | Energy | 0.001 Wh
 |  |  | 3 | cosPhi | 0.001
 |  |  | 4 | Frequency | 0.1 Hz
 |  |  | 5 | Energy | 0.001 Wh
 |  |  | 6 | Angle α between phase 3 and phase 1 | 0.01 °
 |  |  | 7-255 | reserved | -
6020:1D | VariantValue | Variant value Ch. 1 (see Index 6020:14) |  |  |  | INT32 | RW | 0x00000000 (0dec)
Index 6030 PM Inputs Auxiliary
Index | Name | Meaning | Data type | Flags | Default
6030:0 | PM Inputs Ch.3 | Max. subindex | UINT8 | RO | 0x13 (19dec)
6030:10 | TxPDO Toggle | Toggled with any zero crossing (Ch. Aux) | BOOLEAN | RW | 0x00 (0dec)
6030:11 Index Acknowledges for Auxiliary Variables
Channel (dec) | Index (dec) | Meaning | Unit
0 | 0 | Reserved (THDN IA+IB+IC) presently not active |
0 | 2 | Sum of the energy (channel 1-3) | 0.001 Wh
0 | 4 | Frequency | 0.1 Hz
0 | 5 | Sum of the energy (negative) (channel 1-3) | 0.001 Wh
0 | 10 | Sum of the active power (channel 1-3) | 0.01 W
0 | 11 | Sum of the apparent power (channel 1-3) | 0.01 VA
0 | 12 | Sum of the reactive power (channel 1-3) | 0.01 Var
0 | 100 | ADC temperature | °C
1..3 | 0 | Calculation ongoing |
 | 1..21 | RMS value of the xth harmonic (current) | 0.000001 A
 | 51..71 | Ratio of the xth harmonic to the fundamental (current) | 0.01 %
 | 100 | Calculation ongoing |
 | 101..121 | RMS value of the xth harmonic (voltage) | 0.0001 V
 | 151..171 | Ratio of the xth harmonic to the fundamental (voltage) | 0.01 %
11..13 | 0 | Apparent power of phase x | 0.01 VA
 | 1 | Reactive power of phase x | 0.01 VAR
 | 2 | Energy of phase x | 0.001 Wh
 | 3 | cosPhi of phase x | 0.001
 | 4 | Frequency of phase x | 0.1 Hz
 | 5 | Energy (negative) of phase x | 0.001 Wh
 | 6 | Angle α between phase x and phase 1 | 0.01 °
 | 10 | Current of phase x | 0.000001 A
 | 11 | Voltage of phase x | 0.0001 V
 | 12 | Active power of phase x | 0.01 W
 UINT8 RW 0x00 (0dec)
6030:12 | Channel | UINT8 | RW | 0x00 (0dec)
6030:13 | Value | Variant value Aux channel( siehe Index 6030:12) | INT32 | RW | 0x00000000 (0dec)

Note 		Calculation of harmonics
It is not possible to calculate harmonics for more than one channel at the same time.

Index 00 or 100 is returned until the harmonic calculation has been completed

Index 7000 PM Outputs Ch.1
Index | Name | Meaning | Data type | Flags | Default
7000:0 | PM Outputs Ch.1 | Max. subindex | UINT8 | RO | 0x01 (1dec)
7000:01 | Index | Request for variant value Ch. 1 (see Index 6000:14) | UINT8 | RW | 0x00 (0dec)
Index 7010 PM Outputs Ch.2
Index | Name | Meaning | Data type | Flags | Default
7010:0 | PM Outputs Ch.2 | Max. subindex | UINT8 | RO | 0x01 (1dec)
7010:01 | Index | Request for variant value Ch. 2 (see Index 6010:14) | UINT8 | RW | 0x00 (0dec)
Index 7020 PM Outputs Ch.3
Index | Name | Meaning | Data type | Flags | Default
7020:0 | PM Outputs Ch.3 | Max. subindex | UINT8 | RO | 0x01 (1dec)
7020:01 | Index | Request for variant value Ch. 3 (see Index 6020:14) | UINT8 | RW | 0x00 (0dec)
Index 7030 PM Outputs Auxiliary
Index | Name | Meaning | Data type | Flags | Default
7030:0 | PM Outputs Ch.Auxiliary | Max. subindex | UINT8 | RO | 0x02 (2dec)
7030:01 | Index | Request for variant value Ch Aux (see Index 6030:13) | UINT8 | RW | 0x00 (0dec)
7030:02 | Channel | Selection for variant value Ch Aux (see Index 6030:13) | UINT8 | RW | 0x00 (0dec)
Index 800F PM Vendor data Ch.1
Index | Name | Meaning | Data type | Flags | Default
800F:0 | PM Vendor data Ch.1 | Max. subindex | UINT8 | RO | 0x22 (34dec)
800F:02 | Calibration current gain | Vendor calibration: Gain current Ch. 1 | UINT16 | RW | 0x4000 (0dec)
800F:04 | Calibration voltage gain | Vendor calibration: Gain voltage Ch. 1 | UINT16 | RW | 0x4000 (0dec)
800F:12 | Calibration current gain (0,1 A) | Vendor calibration: Gain current measurement range 0.1 A, Ch. 1 | INT16 | RW | 0x4000 (0dec)
800F:14 | Calibration current gain (5 A) | Vendor calibration: Gain current measurement range 5 A, Ch. 1 | INT16 | RW | 0x4000 (0dec)
800F:20 | Calibration phase Offset (1 A) | Vendor calibration: Phase shift measurement range 0.1 A, Ch. 1 | UINT16 | RW | 0x0000 (0dec)
800F:21 | Calibration phase Offset (0,1 A) | Vendor calibration: Phase shift measurement range 1 A, Ch. 1 | UINT16 | RW | 0x0000 (0dec)
800F:22 | Calibration phase Offset (5 A) | Vendor calibration: Phase shift measurement range 5 A, Ch. 1 | UINT16 | RW | 0x0000 (0dec)
Index 801F PM Vendor data Ch.2
Index | Name | Meaning | Data type | Flags | Default
801F:0 | PM Vendor data Ch.2 | Max. subindex | UINT8 | RO | 0x22 (34dec)
801F:02 | Calibration current gain | Vendor calibration: Gain current Ch. 2 | UINT16 | RW | 0x4000 (0dec)
801F:04 | Calibration voltage gain | Vendor calibration: Gain voltage Ch. 2 | UINT16 | RW | 0x4000 (0dec)
801F:12 | Calibration current gain (0,1 A) | Vendor calibration: Gain current measurement range 0.1 A, Ch. 2 | INT16 | RW | 0x4000 (0dec)
801F:14 | Calibration current gain (5 A) | Vendor calibration: Gain current measurement range 5 A, Ch. 2 | INT16 | RW | 0x4000 (0dec)
801F:20 | Calibration phase Offset (1 A) | Vendor calibration: Phase shift measurement range 0.1 A, Ch. 2 | UINT16 | RW | 0x0000 (0dec)
801F:21 | Calibration phase Offset (0,1 A) | Vendor calibration: Phase shift measurement range 1 A, Ch. 2 | UINT16 | RW | 0x0000 (0dec)
801F:22 | Calibration phase Offset (5 A) | Vendor calibration: Phase shift measurement range 5 A, Ch. 2 | UINT16 | RW | 0x0000 (0dec)
Index 802F PM Vendor data Ch.3
Index | Name | Meaning | Data type | Flags | Default
802F:0 | PM Vendor data Ch.3 | Max. subindex | UINT8 | RO | 0x22 (34dec)
802F:02 | Calibration current gain | Vendor calibration: Gain current Ch. 3 | UINT16 | RW | 0x0000 (0dec)
802F:04 | Calibration voltage gain | Vendor calibration: Gain voltage Ch. 3 | UINT16 | RW | 0x0000 (0dec)
802F:12 | Calibration current gain (0,1 A) | Vendor calibration: Gain current measurement range 0.1 A, Ch. 3 | INT16 | RW | 0x4000 (0dec)
802F:14 | Calibration current gain (5 A) | Vendor calibration: Gain current measurement range 5 A, Ch. 3 | INT16 | RW | 0x4000 (0dec)
802F:20 | Calibration phase Offset (1 A) | Vendor calibration: Phase shift measurement range 0.1 A, Ch. 3 | UINT16 | RW | 0x0000 (0dec)
802F:21 | Calibration phase Offset (0,1 A) | Vendor calibration: Phase shift measurement range 1 A, Ch. 3 | UINT16 | RW | 0x0000 (0dec)
802F:22 | Calibration phase Offset (5 A) | Vendor calibration: Phase shift measurement range 5 A, Ch. 3 | UINT16 | RW | 0x0000 (0dec)
Index 9000 PM Persistent data Ch.1
Index | Name | Meaning | Data type | Flags | Default
9000:0 | PM Persistent data Ch.1 | Max. subindex | UINT8 | RO | 0x09
9000:01 | Energy (overall) | saved energy value of Ch. 1 (1) Unit: 0,001 Wh | INT32 | RO | 0x00000000 (0dec)
9000:02 | Energy (negativ) | saved negative energy value of Ch. 1 (1) Unit: 0,001 Wh | INT32 | RO | 0x00000000 (0dec)
9000:03 | Energy (overall) autosaved | autosaved energy value of Ch. 1 (1) Unit: 0,001 Wh | INT32 | RO | 0x00000000 (0dec)
9000:04 | Energy (negativ) autosaved | autosaved negative energy value of Ch. 1 (1) Unit: 0,001 Wh | INT32 | RO | 0x00000000 (0dec)
Index 9010 PM Persistent data Ch.2
Index | Name | Meaning | Data type | Flags | Default
9010:0 | PM Persistent data Ch.2 | Max. subindex | UINT8 | RO | 0x09
9010:01 | Energy (overall) | saved energy value of Ch. 2 (1) Unit: 0,001 Wh | INT32 | RO | 0x00000000 (0dec)
9010:02 | Energy (negativ) | saved negative energy value of Ch. 2 (1) Unit: 0,001 Wh | INT32 | RO | 0x00000000 (0dec)
9010:03 | Energy (overall) autosaved | autosaved energy value of Ch. 2 (1) Unit: 0,001 Wh | INT32 | RO | 0x00000000 (0dec)
9010:04 | Energy (negativ) autosaved | autosaved negative energy value of Ch. 2 (1) Unit: 0,001 Wh | INT32 | RO | 0x00000000 (0dec)
Index 9020 PM Persistent data Ch.3
Index | Name | Meaning | Data type | Flags | Default
9020:0 | PM Persistent data Ch.3 | Max. subindex | UINT8 | RO | 0x09
9020:01 | Energy (overall) | saved energy value of Ch. 3 (1) Unit: 0,001 Wh | INT32 | RO | 0x00000000 (0dec)
9020:02 | Energy (negativ) | saved negative energy value of Ch. 3 (1) Unit: 0,001 Wh | INT32 | RO | 0x00000000 (0dec)
9020:03 | Energy (overall) autosaved | autosaved energy value of Ch. 3 (1) Unit: 0,001 Wh | INT32 | RO | 0x00000000 (0dec)
9020:04 | Energy (negativ) autosaved | autosaved negative energy value of Ch. 3 (1) Unit: 0,001 Wh | INT32 | RO | 0x00000000 (0dec)

(1) The energy values can be saved/deleted with help of the Command Object (see Index FB00). The negative energy value is the value generated by a negative power (generator mode). The energy value in Subindex 01 and 03 is the sum of the generated and consumed energy, i.e. this value will be smaller in generator mode. The two values must be combined in order to calculate the positive energy.

Note 		Index F801
For reasons of compatibility, Object 0xF801 (energy) of the EL3403 can still be read out. In the case of new projects, however, it is recommended to use the objects described above.
Index F000 Modular device profile
Index | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information about the Modular Device Profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance between the objects of two channels | UINT16 | RW | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RW | 0x0003 (3dec)
Index F008 Code word
Index | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dec)


Diagnosis - Diag Messages

Table of contents
• Definition
• TwinCAT System Manager implementation
 • Interpretation
 - Structure of the Text ID
 - General Text IDs

DiagMessages designates a system for the transmission of messages from the EtherCAT Slave to the EtherCAT Master/TwinCAT. The messages are stored by the device in its own CoE under 0x10F3 and can be read by the application or the System Manager. An error message referenced via a code is output for each event stored in the device (warning, error, status change).

Definition

The DiagMessages system is defined in the ETG (EtherCAT Technology Group) in the guideline ETG.1020, chapter 13 “Diagnosis handling”. It is used so that pre-defined or flexible diagnostic messages can be conveyed from the EtherCAT Slave to the Master. In accordance with the ETG, the process can therefore be implemented supplier-independently. Support is optional. The firmware can store up to 250 DiagMessages in its own CoE.

Each DiagMessage consists of

  • Diag Code (4-byte)
  • Flags (2-byte; info, warning or error)
  • Text ID (2-byte; reference to explanatory text from the ESI/XML)
  • Timestamp (8-byte, local slave time or 64-bit Distributed Clock time, if available)
  • Dynamic parameters added by the firmware

The DiagMessages are explained in text form in the ESI/XML file belonging to the EtherCAT device: on the basis of the Text ID contained in the DiagMessage, the corresponding plain text message can be found in the languages contained in the ESI/XML. In the case of Beckhoff products these are usually German and English.

Via the entry NewMessagesAvailable the user receives information that new messages are available.

DiagMessages can be confirmed in the device: the last/latest unconfirmed message can be confirmed by the user.

In the CoE both the control entries and the history itself can be found in the CoE object 0x10F3:

Fig. 1: DiagMessages in the CoE

The subindex of the latest DiagMessage can be read under x10F3:02.

Note 		Support during commissioning
The DiagMessages system is to be used above all during the commissioning of the plant.
The diagnostic values e.g. in the StatusWord of the device (if available) are helpful for online diagnosis during the subsequent continuous operation.

TwinCAT System Manager implementation

From TwinCAT 2.11 DiagMessages, if available, are displayed in the device’s own interface. Operation (collection, confirmation) also takes place via this interface.

Fig. 2: Implementation of the DiagMessage system in the TwinCAT System Manager

The operating buttons (B) and the history read out (C) can be seen on the Diag History tab (A). The components of the message:

  • Info/Warning/Error
  • Acknowledge flag (N = unconfirmed, Q = confirmed)
  • Time stamp
  • Text ID
  • Plain text message according to ESI/XML data

The meanings of the buttons are self-explanatory.

Interpretation

Structure of the Text ID

The structure of the MessageID is not subject to any standardisation and can be supplier-specifically defined. In the case of Beckhoff EtherCAT devices (EL, EP) it usually reads according to xyzz:

x | y | zz
0: Systeminfo 1: Info 4: Warning 8: Error | 1: General 2: Communication 3: Encoder 4: Drive 5: Inputs | Error number

Example: Message 0x4413 --> Drive Warning Number 0x13

General Text IDs

Specific Text IDs should be specified in the device documentation.

Text ID | Type | Place | Text (English only) | Cause
0x0001 | Information | System | No error | No error
0x0002 | Information | System | Communication established | Communication established
0x0003 | Information | System | Initialization: 0x%X, 0x%X, 0x%X | General information; parameters depend on event. See device documentation for interpretation.
0x1000 | Information | System | Information: 0x%X, 0x%X, 0x%X | General information; parameters depend on event. See device documentation for interpretation.
0x1100 | Information | General |  | Detection of the mode of operation ended
0x1135 | Information | General |  | Cycle time OK
0x1201 | Information | Communication | Communication re-established | Communication to the field side restored This message appears, for example, if the voltage was removed from the power contacts and re-applied during operation
0x1300 | Information | Encoder |  | Position set - StartInputhandler
0x1400 | Information | Drive |  | Drive is calibrated
0x4000 | Warning |  | Warning: 0x%X, 0x%X, 0x%X | General warning; parameters depend on event. See device documentation for interpretation.
0x4101 | Warning | General | Terminal-Overtemperature | Overtemperature. The internal temperature of the terminal exceeds the parameterised warning threshold
0x4300 | Warning | Encoder |  | Sub-increments deactivated (despite activated configuration)
0x4301 | Warning | Encoder | Encoder-Warning | General encoder error
0x4400 | Warning | Drive |  | Drive is not calibrated
0x4401 | Warning | Drive |  | Start type is not supported
0x4402 | Warning | Drive |  | Command rejected
0x4405 | Warning | Drive |  | Modulo sub-type invalid
0x4410 | Warning | Drive |  | Target position exceeded
0x4411 | Warning | Drive | DC-Link undervoltage (Warning) | The DC link voltage of the terminal is lower than the parameterised minimum voltage. Activation of the output stage is prevented
0x4412 | Warning | Drive | DC-Link overvoltage (Warning) | The DC link voltage of the terminal is higher than the parameterised maximum voltage. Activation of the output stage is prevented
0x4413 | Warning | Drive | I2T-Model Amplifier overload (Warning) | - The amplifier is being operated outside the specification - The I2T-model of the amplifier is incorrectly parameterised
0x4414 | Warning | Drive | I2T-Model Motor overload (Warning) | - The motor is being operated outside the parameterised rated values - The I2T-model of the motor is incorrectly parameterised
0x4415 | Warning | Drive | Speed limitation active | The maximum speed is limited by the parameterised objects (e.g. velocity limitation, motor speed limitation). This warning is output if the set velocity is higher than one of the parameterised limits
0x8001 | Error | System | Error: 0x%X, 0x%X, 0x%X | General error; parameters depend on event. See device documentation for interpretation.
0x8002 | Error | System | Communication aborded |
0x8003 | Error | System | Configuration error: 0x%X, 0x%X, 0x%X | General; parameters depend on event. See device documentation for interpretation.
0x8100 | Error | General |  | Error bit set in the status word
0x8101 | Error | General |  | Mode of operation incompatible with the PDO interface
0x8102 | Error | General | Invalid combination of Inputs and Outputs PDOs | Invalid combination of input and output PDOs
0x8103 | Error | General | No variable linkage | No variables linked
0x8104 | Error | General | Terminal-Overtemperature | The internal temperature of the terminal exceeds the parameterised error threshold. Activation of the terminal is prevented
0x8105 | Error | General | PD-Watchdog | Communication between the fieldbus and the output stage is secured by a Watchdog. The axis is stopped automatically if the fieldbus communication is interrupted. - The EtherCAT connection was interrupted during operation - The Master was switched to Config mode during operation
0x8135 | Error | General | Cycletime has to be a multiple of 125 µs | The IO or NC cycle time divided by 125 µs does not produce a whole number
0x8200 | Error | Communication |  | Error while writing
0x8201 | Error | Communication | No communication to field-side (Auxiliary voltage missing) | - There is no voltage applied to the power contacts - A firmware update has failed
0x82FF | Error | Communication |  | Boot mode not activated
0x8300 | Error | Encoder |  | Error while setting the position
0x8301 | Error | Encoder |  | Encoder increments not configured
0x8302 | Error | Encoder | Feedback-Error | The amplitude of the resolver is too small
0x8400 | Error | Drive |  | Drive incorrectly configured
0x8401 | Error | Drive |  | Limitation of the calibration velocity
0x8402 | Error | Drive |  | Emergency stop activated
0x8403 | Error | Drive | ADC Error | Error during current measurement in the ADC
0x8404 | Error | Drive | Overcurrent | Overcurrent in phase U, V or W
0x8405 | Error | Drive |  | Modulo position invalid
0x8406 | Error | Drive | DC-Link undervoltage (Error) | The DC link voltage of the terminal is lower than the parameterised minimum voltage. Activation of the output stage is prevented
0x8407 | Error | Drive | DC-Link overvoltage (Error) | The DC link voltage of the terminal is higher than the parameterised maximum voltage. Activation of the output stage is prevented
0x8408 | Error | Drive | I2T-Model Amplifier overload (Error) | - The amplifier is being operated outside the specification - The I2T-model of the amplifier is incorrectly parameterised
0x8409 | Error | Drive | I2T-Model motor overload (Error) | - The motor is being operated outside the parameterised rated values - The I2T-model of the motor is incorrectly parameterised
0x8415 | Error | Drive |  | Modulo factor invalid


Firmware Kompatibilität

BECKHOFF EL3413: Appendix

Firmware compatibility

Beckhoff EtherCAT devices will be equipped with the last available firmware on delivery. There are certain dependencies between firmware and hardware, not all combinations are compatible.
The overview below shows which firmware is compatible to a certain hardware status.

Notice

  • It is strictly recommended to apply the last available firmware on the particular hardware
  • There is no customer right to get a firmware update at no charge for already delivered products by the Beckhoff company.

Attention 		Damage of devices possible!
Please note the details concerning the firmware update on the special page.
If you run a device in BOOTSTRAP mode to initiate a firmware update, it it possible that there is no checking of compatibility of the firmware.
A damage of the device is possible!
Please always make sure, that the firmware is suitable for the hardware status of the device!
EL3413-0000
Hardware (HW) | Firmware (FW) | Revision No. | Date of release
03 - 08* | 02* | EL3413-0000-0016 | 2012/06
 |  | EL3413-0000-0017 | 2012/07

*) At the time of creation of this documentation this is the current compatible hardware status. Please check the Beckhoff website for the latest documentation.


EtherCAT - Firmware

BECKHOFF EtherCAT: Device Update

Firmware EL/ES/EM/EPxxxx

This section describes the device update for Beckhoff EtherCAT slaves from the EL/ES, EM, EK and EP series. A firmware update should only be carried out after consultation with Beckhoff support.

Table of contents
• Storage locations
• Device description ESI file/XML
• Frimware version definition
• Updating Controller firmware *.efw
• FPGA firmware update *.rbf
• Multiple update

Storage locations

An EtherCAT slave stores operating data in up to 3 locations:

  • Depending on functionality and performance EtherCAT slaves have one or several local controllers for processing I/O data. The corresponding program is the so-called firmware in *.efw format.
  • In some EtherCAT slaves the EtherCAT communication may also be integrated in these controllers. In this case the controller is usually a so-called FPGA chip with *.rbf firmware.
  • In addition each EtherCAT slave has a memory chip for storing its own device description, a so-called EEPROM. On power-up this description is loaded and the EtherCAT communication is set up accordingly. The device description is available from the download area of the Beckhoff website at http://www.beckhoff.com . All ESI files (EtherCAT Slave Information) are available in ZIP format.

Customers can access the data via the EtherCAT fieldbus and its communication mechanisms. Acyclic mailbox communication or register access to the ESC is used for updating or reading of these data.

The TwinCAT System Manager offers mechanisms for programming all 3 parts with new data, if the slave is set up for this purpose. Generally the slave does not check whether the new data are suitable, i.e. it may no longer be able to operate if the data are unsuitable.

Attention 		Risk of damage to the device!
Note the following when downloading new device files
  • Firmware downloads to an EtherCAT device must not be interrupted
  • Flawless EtherCAT communication must be ensured. CRC errors or Lost Frames must be avoided.
  • The power supply must adequately dimensioned. The signal level must meet the specification.

In the event of malfunctions during the update process the EtherCAT device may become unusable and require re-commissioning by the manufacturer.

Device description ESI file/XML

Attention 		Notice regarding update of the ESI description/EEPROM
Some slaves have stored calibration and configuration data from the production in the EEPROM. These are irretrievably overwritten during an update.

The ESI device description is stored locally on the slave and loaded on start-up. Each device description has a unique identifier consisting of slave name (9 characters/digits) and a revision number (4 digits). Each slave configured in the System Manager shows its identifier in the EtherCAT tab:

Fig. 1: Device identifier consisting of name EL3204-0000 and revision -0016

The configured identifier must be compatible with the actual device description used as hardware, i.e. the description which the slave has loaded on start-up (in this case EL3204). Generally the configured revision must be equal or lower than the version used in the terminal network.

For further information please refer to the EtherCAT System Documentation.

Note 		Update of XML/ESI description
The device revision is closely linked to the firmware and hardware used. Incompatible combinations lead to malfunctions or even final shutdown of the device.
Corresponding updates should only be carried out in consultation with Beckhoff support.

Display of ESI slave identifier

The simplest way to ascertain compliance of configured and actual device description is to scan the EtherCAT boxes in TwinCAT mode Config/Freerun:

Fig. 2: Scan the subordinate field by right-clicking on the EtherCAT device in Config/FreeRun mode

If the found field matches the configured field, the display shows

Fig. 3: Configuration is identical

otherwise a change dialog for entering the actual data in the configuration.

Fig. 4: Change dialog

In the example shown in Fig. 4. an EL3201-0000-0017 was found, while an EL3201-0000-0016 had been configured. In this case it makes sense to adapt the configuration with the Copy Before button. The Extended Information checkbox must be set in order to have the revision displayed.

Changing the ESI slave identifier

The ESI/EEPROM identifier can be updated as follows under TwinCAT:

  • The EtherCAT communication with the slave must be flawless.
  • The state of the slave is irrelevant.
  • Right-click on the slave in the online display to bring up the EEPROM Update dialog, Fig. 5

Fig. 5: EEPROM Update

Select the new ESI description in the following dialog, see Fig. 6. The ShowHiddenDevices checkbox also shows older, usually hidden slave versions.

Fig. 6: Selecting the new ESI

A progress bar in the System Manager shows the progress. Data are first written, then verified.

Note 		The change only takes effect after a restart.
Most EtherCAT devices read a modified ESI description immediately or after startup from the INIT. Some communication settings such as distributed clocks are only read during power-on.
The EtherCAT slave therefore has to be switched off briefly in order for the change to take effect.

Determining the firmware version

Determining the version on laser inscription

Beckhoff EtherCAT slaves feature serial numbers applied by laser. The serial number has the following structure: KK YY FF HH

KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version

Example with ser. no.: 12 10 03 02:

12 - week of production 12
10 - year of production 2010
03 - firmware version 03
02 - hardware version 02

Determining the version via the System Manager

The TwinCAT System Manager shows the version of the controller firmware if the master can access the slave online. Click on the E-Bus Terminal whose controller firmware you want to check (in the example terminal 2 (EL3204)) and select the tab CoE Online (CAN over EtherCAT).

Note 		CoE Online and Offline CoE
Two CoE directories are available:
  • online: This is offered in the EtherCAT slave by the controller, if the EtherCAT slave does supported it.
    This CoE directory can only be displayed if a slave is connected and operational.
  • offline: The EtherCAT Slave Information ESI/XML may contain the default content of the CoE.
    This CoE directory can only be displayed if it is included in the ESI (e.g. "Beckhoff EL5xxx.xml").

The Advanced button must be used for switching between the two views.

In Fig. 7 the firmware version of the selected EL3204 is shown as 03 in CoE entry x100A.

Fig. 7: Display of EL3204 firmware version

In (A) TwinCAT 2.11 shows that the Online CoE directory is currently displayed. If this is not the case, the Online directory can be loaded via the Online option in Advanced Settings (B) and double-clicking on AllObjects.

Updating controller firmware *.efw

Note 		CoE directory
The Online CoE directory is managed by the controller and stored in a dedicated EEPROM, which is generally not changed during a firmware update.

To update the controller firmware of a slave switch to tab Online, see Fig. 8.

Fig. 8: Firmware Update

Proceed as follows, unless instructed otherwise by Beckhoff support.

  • Switch slave to INIT (A)
  • Switch slave to BOOTSTRAP
  • Check the current status (B, C)
  • Download the new *efw file
  • After the download switch to INIT, then OP
  • Switch off the slave briefly

FPGA firmware *.rbf

If an FPGA chip deals with the EtherCAT communication an update may be accomplished via an *.rbf file.

  • Controller firmware for processing I/O signals
  • FPGA firmware for EtherCAT communication (only for terminals with FPGA)

The firmware version number included in the terminal serial number contains both firmware components. If one of these firmware components is modified this version number is updated.

Determining the version via the System Manager

The TwinCAT System Manager indicates the FPGA firmware version. Click on the Ethernet card of your EtherCAT strand (Device 2 in the example) and select the Online tab.

The Reg:0002 column indicates the firmware version of the individual EtherCAT devices in hexadecimal and decimal representation.

Fig. 9: FPGA firmware version definition

If the column Reg:0002 is not displayed, right-click the table header and select Properties... in the context menu.

Fig. 10: Context menu Properties

The Advanced Settings dialog appears where the columns to be displayed can be selected. Under Diagnosis/Online View select the '0002 ETxxxx Build' check box in order to activate the FPGA firmware version display.

Fig. 11: Dialog Advanced Settings

Update

For updating the FPGA firmware

  • of an EtherCAT coupler the coupler must have FPGA firmware version 11 or higher;
  • of an E-Bus Terminal the terminal must have FPGA firmware version 10 or higher.

Older firmware versions can only be updated by the manufacturer!

Updating an EtherCAT device

In the TwinCAT System Manager select the terminal whose FPGA firmware you want to update (in this example terminal 5: EL5001) and
click on Advanced Settings in the EtherCAT tab.

Fig. 12: Select dialog Advanced Settings

The Advanced Settings dialog appears. Under ESC Access/E²PROM/FPGA click on Write FPGA button,

Fig. 13: Select dialog Write FPGA

select the file (*.rbf) with the new FPGA firmware, and transfer it to the EtherCAT device.

Attention 		Risk of damage to the device!
A firmware download to an EtherCAT device must never be interrupted!

If this process is cancelled, the supply voltage switched off or the Ethernet connection interrupted, the EtherCAT device can only be recommissioned by the manufacturer!

In order to activate the new FPGA firmware a restart (switching the power supply off and on again) of the EtherCAT device is required.

Simultaneous updating of several EtherCAT devices

The firmware and ESI descriptions of several devices can be updated simultaneously, provided the devices have the same firmware file/ESI.

Fig. 14: Multiple selection and firmware update

Select the required slaves and carry out the firmware update in BOOTSTRAP mode as described above.


ELxxxx - restoring the delivery state

BECKHOFF ELxxxx: Configuration

Restoring the delivery state

To restore the delivery state for backup objects in ELxxxx terminals, the CoE object "Restore default parameters", SubIndex 001 can be selected in the TwinCAT System Manager (Config mode) (see Fig. 1)

Fig. 1 Selecting the "Restore default parameters" PDO

Double-click on SubIndex 001 to enter the Set Value dialog. Enter the value 1684107116 in field "Dec" or the value 0x64616F6C in field "Hex" and confirm with OK (Fig. 2).
All backup objects are reset to the delivery state.

Fig. 2 Entering a restore value in the Set Value dialog

Note 		Alternative restore value

In some older terminals the backup objects can be switched with an alternative restore value:

Decimal value: "1819238756"

Hexadecimal value: "0x6C6F6164"

An incorrect entry for the restore value has no effect.


Support and Service

Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.

Beckhoff's branch offices and representatives

Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!

The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com

You will also find further documentation for Beckhoff components there.

Beckhoff Headquarters

Beckhoff Automation GmbH

Eiserstr. 5
33415 Verl
Germany

Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support

Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:

  • support
  • design, programming and commissioning of complex automation systems
  • and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service

The Beckhoff Service Center supports you in all matters of after-sales service:

  • on-site service
  • repair service
  • spare parts service
  • hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com


TwinCAT System Manager - Configuration

BECKHOFF TwinCAT System Manager: Configuration

Configuration by means of the TwinCAT System Manager

(with TwinCAT from version 2.10.0 (Build 1241), using EL5001 from firmware version 0.7 as an example)

In the left-hand window of the TwinCAT System Manager, click on the branch you wish to configure (in the example: EL5001 Terminal 6).

In the right-hand window of the TwinCAT System manager, various tabs are now available for configuring the terminal.

General tab

Name | Name of the EtherCAT device
Id | Number of the EtherCAT device
Type | EtherCAT device type
Comment | Here you can add a comment (e.g. regarding the system).
Disabled | Here you can deactivate the EtherCAT device.
Create symbols | Access to this EtherCAT slave via ADS is only available if this control box is activated.

EtherCAT tab

Type | EtherCAT device type
Product/Revision | Product and revision number of the EtherCAT device
Auto Inc Addr. | Auto increment address of the EtherCAT device. The auto increment address can be used for addressing each EtherCAT device in the communication ring through its physical position. Auto increment addressing is used during the start-up phase when the EtherCAT master allocates addresses to the EtherCAT devices. With auto increment addressing the first EtherCAT slave in the ring has the address 0000hex. For each further slave the address is decremented by 1 (FFFFhex, FFFEhex etc.).
EtherCAT Addr. | Fixed address of an EtherCAT slave. This address is allocated by the EtherCAT master during the start-up phase. Tick the control box to the left of the input field in order to modify the default value.
Previous Port | Name and port of the EtherCAT device to which this device is connected. If it is possible to connect this device with another one without changing the order of the EtherCAT devices in the communication ring, then this combination field is activated and the EtherCAT device to which this device is to be connected can be selected.
Advanced Settings | This button opens the dialogs for advanced settings.

The link at the bottom of the tab points to the product page for this EtherCAT device on the web.

Process Data tab

Indicates the configuration of the process data. The input and output data of the EtherCAT slave are represented as CANopen process data objects (PDO). The user can select a PDO via PDO assignment and modify the content of the individual PDO via this dialog, if the EtherCAT slave supports this function.

Sync Manager

Lists the configuration of the Sync Manager (SM).
If the EtherCAT device has a mailbox, SM0 is used for the mailbox output (MbxOut) and SM1 for the mailbox input (MbxIn).
SM2 is used for the output process data (outputs) and SM3 (inputs) for the input process data.

If an input is selected, the corresponding PDO assignment is displayed in the PDO Assignment list below.

PDO Assignment

PDO assignment of the selected Sync Manager. All PDOs defined for this Sync Manager type are listed here:

  • If the output Sync Manager (outputs) is selected in the Sync Manager list, all RxPDOs are displayed.
  • If the input Sync Manager (inputs) is selected in the Sync Manager list, all TxPDOs are displayed.

The selected entries are the PDOs involved in the process data transfer. In the tree diagram of the System Manager these PDOs are displayed as variables of the EtherCAT device. The name of the variable is identical to the Name parameter of the PDO, as displayed in the PDO list. If an entry in the PDO assignment list is deactivated (not selected and greyed out), this indicates that the input is excluded from the PDO assignment. In order to be able do select a greyed out PDO, the currently selected PDO has to be deselected first.

Note 		Activation of PDO assignment
If you have changed the PDO assignment, in order to activate the new PDO assignment,
  • the EtherCAT slave has to run through the PS status transition cycle (from pre-operational to safe-operational) once (see Online tab),
  • and the System Manager has to reload the EtherCAT slaves ( [image] button)

PDO list

List of all PDOs supported by this EtherCAT device. The content of the selected PDOs is displayed in the PDO Content list. The PDO configuration can be modified by double-clicking on an entry.

Column | Description
Index | PDO index.
Size | Size of the PDO in bytes.
Name | Name of the PDO. If this PDO is assigned to a Sync Manager, it appears as a variable of the slave with this parameter as the name.
Flags | F | Fixed content: The content of this PDO is fixed and cannot be changed by the System Manager.
 | M | Mandatory PDO. This PDO is mandatory and must therefore be assigned to a Sync Manager! Consequently, this PDO cannot be deleted from the PDO Assignment list
SM | Sync Manager to which this PDO is assigned. If this entry is empty, this PDO does not take part in the process data traffic.
SU | Sync unit to which this PDO is assigned.

PDO Content

Indicates the content of the PDO. If flag F (fixed content) of the PDO is not set the content can be modified.

Download

If the device is intelligent and has a mailbox, the configuration of the PDO and the PDO assignments can be downloaded to the device. This is an optional feature that is not supported by all EtherCAT slaves.

PDO Assignment

If this check box is selected, the PDO assignment that is configured in the PDO Assignment list is downloaded to the device on startup. The required commands to be sent to the device can be viewed in the Startup tab.

PDO Configuration

If this check box is selected, the configuration of the respective PDOs (as shown in the PDO list and the PDO Content display) is downloaded to the EtherCAT slave.

Startup tab

The Startup tab is displayed if the EtherCAT slave has a mailbox and supports the CANopen over EtherCAT (CoE) or Servo drive over EtherCAT protocol. This tab indicates which download requests are sent to the mailbox during startup. It is also possible to add new mailbox requests to the list display. The download requests are sent to the slave in the same order as they are shown in the list.

Column | Description
Transition Transition to which the request is sent. This can either be
  • the transition from pre-operational to safe-operational (PS), or
  • the transition from safe-operational to operational (SO).

If the transition is enclosed in "<>" (e.g. <PS>), the mailbox request is fixed and cannot be modified or deleted by the user.
Protocol | Type of mailbox protocol
Index | Index of the object
Data | Date on which this object is to be downloaded.
Comment | Description of the request to be sent to the mailbox
Move Up | This button moves the selected request up by one position in the list.
Move Down | This button moves the selected request down by one position in the list.
New | This button adds a new mailbox download request to be sent during startup.
Delete | This button deletes the selected entry.
Edit | This button edits an existing request.

CoE - Online tab

The additional CoE - Online tab is displayed if the EtherCAT slave supports the CANopen over EtherCAT (CoE) protocol. This dialog lists the content of the object list of the slave (SDO upload) and enables the user to modify the content of an object from this list. Details for the objects of the individual EtherCAT devices can be found in the device-specific object descriptions.

Object list display
Column | Description
Index | Index and sub-index of the object
Name | Name of the object
Flags | RW | The object can be read, and data can be written to the object (read/write)
 | RO | The object can be read, but no data can be written to the object (read only)
 | P | An additional P identifies the object as a process data object.
Value | Value of the object
Update List | The Update list button updates all objects in the displayed list
Auto Update | If this check box is selected, the content of the objects is updated automatically.
Advanced | The Advanced button opens the Advanced Settings dialog. Here you can specify which objects are displayed in the list.

Online - via SDO Information | If this option button is selected, the list of the objects included in the object list of the slave is uploaded from the slave via SDO information. The list below can be used to specify which object types are to be uploaded.
Offline - via EDS File | If this option button is selected, the list of the objects included in the object list is read from an EDS file provided by the user.

Online tab

State Machine

Init | This button attempts to set the EtherCAT device to the Init state.
Pre-Op | This button attempts to set the EtherCAT device to the pre-operational state.
Op | This button attempts to set the EtherCAT device to the operational state.
Bootstrap | This button attempts to set the EtherCAT device to the Bootstrap state.
Safe-Op | This button attempts to set the EtherCAT device to the safe-operational state.
Clear Error | This button attempts to delete the fault display. If an EtherCAT slave fails during change of state it sets an error flag. Example: An EtherCAT slave is in PREOP state (pre-operational). The master now requests the SAFEOP state (safe-operational). If the slave fails during change of state it sets the error flag. The current state is now displayed as ERR PREOP. When the Clear Error button is pressed the error flag is cleared, and the current state is displayed as PREOP again.
Current State | Indicates the current state of the EtherCAT device.
Requested State | Indicates the state requested for the EtherCAT device.

DLL Status

Indicates the DLL status (data link layer status) of the individual ports of the EtherCAT slave. The DLL status can have four different states:

Status | Description
No Carrier / Open | No carrier signal is available at the port, but the port is open.
No Carrier / Closed | No carrier signal is available at the port, and the port is closed.
Carrier / Open | A carrier signal is available at the port, and the port is open.
Carrier / Closed | A carrier signal is available at the port, but the port is closed.

File Access over EtherCAT

Download | With this button a file can be written to the EtherCAT device.
Upload | With this button a file can be read from the EtherCAT device.


UL Requirements

BECKHOFF EKxxxx, ELxxxx: Appendix

UL notice

Application
Beckhoff EtherCAT modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
For devices with Ethernet connectors
Not for connection to telecommunication circuits.

Basic principles

Two UL certificates are met in the Beckhoff EtherCAT product range, depending upon the components:

  • UL certification according to UL508
    Devices with this kind of certification are marked by this sign:

  • UL certification according to UL508 with limited power consumption
    The current consumed by the device is limited to a max. possible current consumption of 4 A. Devices with this kind of certification are marked by this sign:

Almost all current EtherCAT products (as at 2010/05) are UL certified without restrictions.

Application

If terminals certified with restrictions are used, then the current consumption at 24 V DC must be limited accordingly by means of supply

  • from an isolated source protected by a fuse of max. 4A (according to UL248) or
  • from a voltage supply complying with NEC class 2.
    A voltage source complying with NEC class 2 may not be connected in series or parallel with another NEC class 2 compliant voltage supply!

These requirements apply to the supply of all EtherCAT bus couplers, power adaptor terminals, Bus Terminals and their power contacts.