EL3356-00x0 - 1 Channel Input Terminal, Precise Resistor Bridge (strain gauge)
Home


Foreword

Foreword
Foreword
Additional information
•
Pecise Resistor Bridge - Product Overview
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status
•
Version identification of EtherCAT devices


Pecise Resistor Bridge - Product Overview

Foreword [image] Pecise Resistor Bridge - Product Overview
Pecise Resistor Bridge - Product Overview
EL3356 | 1-channel precise load cell analysis (resistor bridge), 16 bit
EL3356-0010 | 1-channel precise load cell analysis (resistor bridge), 24 bit
EL3356-0090 | 1-channel precise load cell analysis (resistor bridge), 24 bit, (TwinSAFE Single Channel)


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
4.2
▪
Update chapter “Basic principles of strain gauge technology”
▪
Update structure
4.1
▪
Update chapter “Basic principles of strain gauge technology”
▪
Update revision status
4.0
▪
Update revision status
▪
Update structure
▪
Update revision status
3.9
▪
Update chapter “Basic principles of strain gauge technology”
▪
Update structure
3.8
▪
Update chapter “Basic principles of strain gauge technology”
▪
Update revision status
▪
Update structure
3.7
▪
Update chapter “Quick start”
▪
Update revision status
3.6
▪
Correction for connection technology in figures “EL3356-xxxx” and “LEDs and pin assignment EL3356, EL3356-00x0”
▪
Update chapter “Technical data”
▪
Update chapter “TwinSAFE SC”
▪
Structural update
▪
Update revision status
3.5
▪
EL3356-0090 added
▪
Update chapter “Connection technology” -> “connection”
▪
Structure update
▪
Update revision status
3.4
▪
Update chapter “Technical data”
▪
Update chapter “Basic function principles”
▪
Structure update
3.3
▪
Update chapter “Technical data”
▪
Note on ESD protection added
▪
Update chapter “Notes on analog specifications”
3.2
▪
Update chapter “Notes on the documentation”
▪
Correction in technical data
▪
Chapter “TwinCAT Quick-Start” added
▪
Update revision status
3.1
▪
Download link for sample program corrected
▪
Addenda chapter “Notes on analog specifications”
3.0
▪
First publication in PDF format
▪
Structure update
▪
Corrections in chapters “Voltage measurement” and “Sync Manager”
2.1
▪
Update chapter “Technical data”
▪
Update chapter “Object description”
▪
Structure update
▪
Update revision status
2.0
▪
Update chapter “Technical data”
▪
Addenda chapter “Installation instructions for enhanced mechanical load capacity”
▪
Structure update
▪
Update revision status
Version
Comment
1.9
▪
Update chapter “Basic function principles”
▪
Update chapter “Technical data”
▪
Update chapter “Process data”
▪
Structure update
1.8
▪
Update chapter “Basic function principles”
1.7
▪
Update chapter “Basic function principles” and “Object description”
1.6
▪
Update Technical data
1.5
▪
Addenda in chapter “Basic function principles”
1.4
▪
Addenda in chapter “Basic function principles”, “Technical data”
1.3
▪
Addenda in chapter “Object description”, “LEDs and connection”
1.2
▪
Addenda chapter “Calibration”
1.1
▪
Addenda in chapter “Basics strain gauge technology”
1.0
▪
Addenda and 1st public issue
0.1 - 0.5
▪
Provisional documentation for EL3356


Version identification of EtherCAT devices

Foreword [image] Version identification of EtherCAT devices
Version identification of EtherCAT devices
Designation
A Beckhoff EtherCAT device has a 14-digit designation, made up of
▪
family key
▪
type
▪
version
▪
revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
Notes
▪
The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
▪
EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
▪
The order identifier is made up of
- family key (EL, EP, CU, ES, KL, CX, etc.)
- type (3314)
- version (-0000)
▪
The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
▪
The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Identification number
Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:
Production lot/batch number/serial number/date code/D number
The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02
Unique serial number/ID, ID number
In addition, in some series each individual module has its own unique serial number.
See also the further documentation in the area
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Terminals with factory calibration certificate and other measuring terminals
Examples of markings
EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
Additional information
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Foreword [image] Version identification of EtherCAT devices [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Product overview

Product overview
Product overview
Additional information
•
EL3356, EL3356-00x0 - Introduction
•
EL3356-00x0 - Technical data
•
Basic principles of strain gauge technology
•
Start


EL3356, EL3356-00x0 - Introduction

Product overview [image] EL3356, EL3356-00x0 - Introduction
EL3356, EL3356-00x0 - Introduction
EL3356
EL3356, EL3356-0010 - 1 channel precise resistor bridge analysis
The EL3356 or EL3356-0010 analog input terminal enables the direct connection of a resistor bridge (strain gauge) or a load cell using a 4 or 6-wire connection technique. The ratio of the bridge voltage UD to the supply voltage UREF is determined with high precision in the input circuit and the final load value is calculated as a process value on the basis of the settings in the terminal. No further calculations are necessary in the PLC/controller.
The terminal family has the following features in order to meet as many requirements as possible:
▪
low measuring error of < ±0.01% (see Technical data)
▪
High resolution: 16-bit (EL3356) or 24-bit (EL3356-0010)
▪
fast measuring cycles: 10 ms (EL3356) or 100 µs (EL3356-0010)
▪
automatic self-calibration of the circuit (can be deactivated)
▪
adapted to synchronization via Distributed Clocks (EL3356-0010 only)
▪
manual input of the load cell characteristic values according to the load cell certificate (theoretical calibration) or automatic determination by means of calibration procedure
▪
Tare function
▪
Special functions for highly dynamic weighing: dynamic filter adaptation, mode change and input freeze
Thus slow weighings can be performed with high precision using the EL3356. The EL3356-0010 is particularly suitable for the fast and precise monitoring of torque or vibration sensors.
The EL3356/EL3356-0010 are not stand-alone scales; they are to be used only in conjunction with a PLC/controller.
EL3356-0090
EL3356-0090 - 1 channel precise resistor bridge analysis, TwinSAFE Single Channel
In addition to the full functionality of the EL3356-0010, the EL3356-0090 supports TwinSAFE SC (Single Channel) technology. This enables the use of standard signals for safety tasks in any networks of fieldbuses.
Quick links
Basic principles of strain gauge technology
Basic function principles
QuickStart
EL3356, EL3356-00x0 - Object description and parameterization
EL3356-0090 - Objects TwinSAFE single Channel
EL3356-0090 - TwinSAFE SC process data


EL3356-00x0 - Technical data

Product overview [image] EL3356-00x0 - Technical data
EL3356-00x0 - Technical data
Technical data | EL3356 | EL3356-0010 | EL3356-0090
Number of analog inputs | 2, for 1 bridge circuit (full bridge)
Resolution | 16 bits, 32 bit display | 24 bits, 32 bit display
Conversion rate | 100..4 sps (samples per second) (10..250 ms conversion time) | 10,000 sps.. 4 sps (0.1...250 ms conversion time)
Distributed Clocks | no | yes
switchable modes | no | yes (2)
Measuring error | < ±0.01% for the calculated load value based on the load end value with 12 V power supply and 24 mV bridge voltage (therefore nominal characteristic value for SG: 2 mV/V), self-calibration active, 50 Hz filter active
Measuring range UD | max. -27 mV ... +27 mV typical (see note on voltage measurement) recommended: -25 mV ... +25 mV rated voltage
Measuring range Uref | max. -13.8 V ... +13.8 V typical (see note on voltage measurement) recommended: -12 V to +12 V rated voltage recommended supply voltage: 10 V via power supply terminal EL9510 or 12 V via EL9512 Note the information provided by the sensor manufacturer!
Supported nominal characteristic values | any, resolution of the parameter: 0.01 µV/V recommended: 0.5..4 mV/V
Min. strain gauge resistance | depending on external supply; parallel operation of strain gauge only recommended with suitable strain gauge
Filter (hardware) | 10 kHz low-pass (-3 dB, see filter notes)
Filter (software) | preset 50 Hz, configurable: 50/60 Hz FIR notch filter, IIR low-pass quadruple averager
Internal resistance | > 200 kΩ (Uref), > 1 MΩ (UD)
Special features | auto-calibration |  | auto-calibration, TwinSAFE SC
Power supply for the electronics | via the E-bus
Current consumption via E-bus | typ. 210 mA | typ. 280 mA
Current consumption power contacts | depending on strain gauge supply, min. 1 mA
Electrical isolation | 500 V (E-bus/signal voltage)
Configuration | via EtherCAT master/CoE
MTBF (+55 °C) | - |  | > 780,000 h
Weight | approx. 60 g
Permissible ambient temperature range during operation | 0°C ... + 55°C
Permissible ambient temperature range during storage | -25°C ... + 85°C
Permissible relative air humidity | 95 %, no condensation
Dimensions (W x H x D) | approx. 15 mm x 100 mm x 70 mm (width aligned: 12 mm)
Mounting | on 35 mm mounting rail according to EN 60715
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27, see also installation instructions for terminals with increased mechanical load capacity |  | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation position | variable
Approvals | CE cULus ATEX IECEx


Basic principles of strain gauge technology

Product overview [image] Basic principles of strain gauge technology
Basic principles of strain gauge technology
Basic information on the technological field of strain gauges/load cells as metrological instruments is to be given below. The information is of general nature; it is up to the user to check the extent to which it applies to his application.
▪
Strain gauges serve either to directly measure the static (0 to a few Hz) or dynamic (up to several kHz) elongations, compressions or torsions of a body by being directly fixed to it, or to measure various forces or movements as part of a sensor (e.g. load cells/force transducers, displacement sensor, vibration sensors).
▪
In the case of the optical strain gauge (e.g. Bragg grating), an application of force causes a proportional change in the optical characteristics of a fiber used as a sensor. Light with a certain wavelength is fed into the sensor. Depending upon the deformation of the grating, which is laser-cut into the sensor, due to the mechanical load, part of the light is reflected and evaluated using a suitable measuring transducer (interrogator).
The commonest principle in the industrial environment is the electrical strain gauge. There are many common terms for this type of sensor: load cell, weighbridge, etc.
Structure of electrical strain gauges
A strain gauge consists of a carrier material (e.g. stretchable plastic film) with an applied metal film from which a lattice of electrically conductive resistive material is worked in very different geometrical forms, depending on the requirements.
Strain gauge
This utilizes a behavior whereby, for example in the case of strain, the length of a metallic resistance network increases and its diameter decreases, as a result of which its electrical resistance increases proportionally.
ΔR/R = k*ε
ε = Δl/l thereby corresponds to the elongation; the strain sensitivity is called the k-factor. This also gives rise to the typical track layout inside the strain gauge: the resistor track or course is laid in a meandering pattern in order to expose the longest possible length to the strain.
Example
The elongation ε = 0.1% of a strain gauge with k-factor 2 causes an increase in the resistance of 0.2%. Typical resistive materials are constantan (k~2) or platinum tungsten (92PT, 8W with k ~4). In the case of semiconductor strain gauges a silicon structure is glued to a carrier material. The conductivity is changed primarily by deformation of the crystal lattice (piezo-resistive effect); k-factors of up to 200 can be achieved.
Measurement of signals
The change in resistance of an individual strain gauge can be determined in principle by resistance measurement (current/voltage measurement) using a 2/3/4-wire measurement technique.
Usually 1/2/4 strain gauges are arranged in a Wheatstone bridge (-> quarter/half/full bridge); the nominal resistance/impedance R0 of all strain gauges (and the auxiliary resistors used if necessary) is usually equivalent to R1=R2=R3=R4=R0. Typical values in the non-loaded state are R0 = 120 Ω, 350 Ω, 700 Ω and 1 kΩ.
The full bridge possesses the best characteristics such as linearity in the feeding of current/voltage, four times the sensitivity of the quarter-bridge as well as systematic compensation of disturbing influences such as temperature drift and creeping. In order to achieve high sensitivity, the four individual strain gauges are arranged on the carrier in such a way that two are elongated and two are compressed in each case.
quarter, half, and full bridge
The measuring bridges can be operated with constant current, constant voltage, or also with AC voltage using the carrier frequency method.
Measuring procedure
The Beckhoff EL/KL335x and ELM35/37xx terminals only support constant voltage excitation. If AC excitation is required, please contact Beckhoff sales.
Full bridge strain gauge at constant voltage (ratiometric measurement)
Since the relative resistance change ΔR is low in relation to the nominal resistance R0, a simplified equation is given for the strain gauge in the Wheatstone bridge arrangement:
UD/UV= ¼ * (ΔR1-ΔR2+ΔR3-ΔR4)/R0.
ΔR usually has a positive sign in the case of elongation and a minus sign in the case of compression.
A suitable measuring instrument measures the bridge supply voltage UV (or USupply) and the resulting bridge voltage UD (or UBridge), and forms the quotients from both voltages, i.e. the ratio. After further calculation and scaling the measured value is output, e.g. in kg. Due to the division of UD and UV the measurement is in principle independent of changes in the supply voltage.
If the voltages UV and UD are measured simultaneously, i.e. at the same moment, and placed in relation to each other, then this is referred to as a ratiometric measurement.
The advantage of this is that (with simultaneous measurement!) brief changes in the supply voltage (e.g. EMC effects) or a generally inaccurate or unstable supply voltage likewise have no effect on the measurement.
A change in UV by e.g. 1% creates the same percentage change in UD according to the above equation. Due to the simultaneous measurement of UD and UV the error cancels itself out completely during the division.
4-wire vs. 6-wire connection
With a constant voltage supply, the magnitude of the current can be quite considerable, e.g. 12 V / 350 Ω = 34.3 mA. This leads not only to dissipated heat, wherein the specification of the strain gauge employed must not be exceeded, but possibly also to measuring errors in the case of inadequate wiring due to line losses not being taken into account or compensated.
In principle a full bridge can be operated with a 4-conductor connection (two conductors for the supply UV and two for the measurement of the bridge voltage UD).
If, for example, a 25 m copper cable (feed + return = 50 m) with a cross section q of 0.25 mm2 is used, this results in a line resistance of
RL= l/ (κ * q) = 50 m / (58 S*m/mm2* 0.25 mm2) = 3.5 Ω
If this value remains constant, then the error resulting from it can be calibrated out. However, assuming a realistic temperature change of, for example, 30° the line resistance RL changes by
ΔRL =30° * 3.9 * 10-4 * 3.5 Ω = 0.41 Ω
In relation to a 350 Ω measuring bridge this means a measuring error of > 0.1%.
4-wire connection
This can be remedied by a 6-wire connection, in particular for precision applications.
6-wire connection
The supply voltage UV is thereby fed to the strain gauge (= current carrying conductor). The incoming supply voltage UV is only measured with high impedance as reference voltage URef as the bridge voltage UD with two currentless return conductors “Sense” each directly at the measuring bridge in the same way. Some measuring amplifiers then increase the supply voltage thus far that the desired supply voltage is available at the bridge despite the potential difference on the supply line. In any case, the conductor-related errors can be compensated by the back measurement.
Since these are very small voltage levels of the order of mV and µV, all conductors should be screened.
Structure of a load cell with a strain gauge
One application of the strain gauge is the construction of load cells.
This involves gluing strain gauges (full bridges as a rule) to an elastic mechanical carrier, e.g. a double-bending beam spring element, and additionally covered to protect against environmental influences.
The individual strain gauges are aligned for maximum output signals according to the load direction (two strain gauges in the elongation direction and two in the compression direction).
Example of a load cell
The most important characteristic data of a load cell
Characteristic data
Please enquire to the sensor manufacturer regarding the exact characteristic data!
Nominal load Emax
Maximum permissible load for normal operation, e.g. 10 kg
Nominal characteristic value mV/V
The nominal characteristic describes the sensitivity of the load cell at nominal load Emax. This unit less value indicates the unbalance of the Wheatstone bridge, which, at supply voltage Us, results in the output voltage UD as follows: a nominal characteristic value 2 mV/V means that, with a supply of US =10 V and at the full load Emax of the load cell, the maximum output voltage UD = 10 V * 2 mV/V = 20 mV. The nominal characteristic value is always a nominal value – a manufacturer’s test report is included with good load cells stating the characteristic value determined for the individual load cell, e.g. 2.0782 mV/V.
Minimum calibration value Vmin
This indicates the smallest mass that can be measured without the maximum permissible error of the load cell being exceeded [RevT].
This value is represented either by the equation Vmin = Emax / n (where n is an integer, e.g. 10000), or in % of Emax (e.g. 0.01).
This means that a load cell with Emax = 10 kg has a maximum resolution of
Vmin = 10 kg / 10000 = 1 g or Vmin = 10 kg * 0.01% = 1 g.
Accuracy class according to OIML R60
The accuracy class is indicated by a letter (A, B, C or D) and an additional number, which encodes the scale interval d with a maximum number nmax (*1000); e.g. C4 means Class C with maximally 4000d scale intervals.
The classes specify a maximum and minimum limit for scale intervals d:
▪
A: 50,000 – unlimited
▪
B: 5000 – 100,000
▪
C: 500 – 10,000
▪
D: 500 – 1000,
The scale interval nmax = 4000d states that, with a load cell with a resolution of Vmin = 1 g, a calibratable set of scales can be built that has a maximum measuring range of 4000d * Vmin = 4 kg. Since Vmin is thereby a minimum specification, an 8 kg set of scales could be built – if the application allows – with the same load cell, wherein the calibratable resolution would then fall to 8 kg/4000d = 2 g. From another point of view the scale interval nmax is a maximum specification; hence, the above load cell could be used to build a set of scales with a measuring range of 4 kg, but a resolution of only 2000 divisions = 2 g, if this is adequate for the respective application. Also the classes differ in certain error limits related to non-repeatability/creep/TC.
Accuracy class according to PTB
The European accuracy classes are defined in an almost identical way (source: PTB).
Class | Calibration value e | Minimum load | Max/e
 |  |  | Minimum value | Maximum value
I Fine scales | 0.001 g <= e | 100 e | 50000 | -
II Precision scales | 0,001 g <= e <= 0,05 g 0,1 g <= e | 20 e 50 e | 100 5000 | 100000 100000
III Commercial scales | 0.1 g <= e <= 2 g 5 g <= e | 20 e 20 e | 100 500 | 10000 10000
IIII Coarse scales | 5 g <= e | 10 e | 100 | 1000
Minimum application range or minimum measuring range in % of rated load
This is the minimum measuring range/measuring range interval, which a calibratable load cell/set of scales must cover.
Example: above load cell Emax = 10 kg; minimum application range e.g. 40% Emax
The used measuring range of the load cell must be at least 4 kg. The minimum application range can lie in any range between Emin and Emax, e.g. between 2 kg and 6 kg if a tare mass of 2 kg already exists for structural reasons. A relationship between nmax and Vmin is thereby likewise apparent:
4000 * 1 g = 4 kg .
There are further important characteristic values, which are for the most part self-explanatory and need not be discussed further here, such as nominal characteristic value tolerance, input/output resistance, recommended supply voltage, nominal temperature range etc.
Parallel connection of strain gauges
It is usual to distribute a load mechanically to several strain gauge load cells at the same time. Hence, for example, the 3-point bearing of a silo container on three load cells can be realized. Taking into account wind loads and loading dynamics, the total loading of the silo including the dead weight of the container can thus be measured. The mechanically parallel-connected load cells are usually also electrically connected in parallel and to one measuring transducer, e.g. the EL3356. To this end the following must be observed:
▪
the load cells must be matched to each other and approved by the manufacturer for this mode of operation.
▪
the impedance of the load cells must be such that the current supply capability of the supply (can be integrated into the transducer electronics) is not overloaded..
▪
the nominal characteristic value [mV/V] remains unchanged, the rated load of the load cells must be added accordingly.
Parallel strain gauge
Sources of error/disturbance variables
Inherent electrical noise of the load cell
Electrical conductors exhibit so-called thermal noise (thermal/Johnson noise), which is caused by irregular temperature-dependent movements of the electrons in the conductor material. The resolution of the bridge signal is already limited by this physical effect. The rms value en of the noise can be calculated by en = √4kTRB.
In the case of a load cell with R0 = 350 Ω at an ambient temperature T = 20 °C (= 293K) and a bandwidth of the measuring transducer of 50 Hz (and Boltzmann constant k = 1.38 * 10‑23 J/K), the rms en = 16.8 nV. The peak-peak noise epp is thus approx. epp ~ 6.6* en = 111 nV.
Example
In relation to the maximum output voltage Ubridge_max of a bridge with 2 mV/V and Us = 5 V, this corresponds to Ubridge_max = 5 V * 2 mV/V = 10 mV. (For the nominal load) this results in a maximum resolution of 10 mV / 111 nV = 90090 digits. Converted into bit resolution: ln(90090)/ln(2) ~ 16 bits. Interpretation: a higher digital measuring resolution than 16 bits is thus inappropriate for such an analog signal in the first step. If a higher measuring resolution is used, then additional measures may need to be taken in the evaluation chain in order to obtain the higher information content from the signal, e.g. hardware low-pass filter or software algorithms.
This resolution applies alone to the measuring bridge without any further interferences. The resolution of the measuring signal can be increased by reducing the bandwidth of the measuring unit.
If the strain gauge is glued to a carrier (load cell) and wired up, both external electrical disturbances (e.g. thermovoltage at connection points) and mechanical vibrations in the vicinity (machines, drives, transformers (mechanical and audible 50 Hz vibration due to magnetostriction etc.)) can additionally impair the result of measurement.
Creep
Under a constant load, spring materials can further deform in the load direction. This process is reversible, but it generates a slowly changing measured value during the static measurement. In an ideal case the error can be compensated by constructive measures (geometry, adhesives).
Hysteresis
If even elongation and compression of the load cell take place, then the output voltage does not follow exactly the same curve, since the deformation of the strain gauge and the carrier may be different due to the adhesive and its layer thickness.
Temperature drift (inherent heating, ambient temperature)
Relatively large currents can flow in strain gauge applications. A full bridge with 4 x 350 Ω (each two in series) for example drags I = Usupply/R0 = 10 V / 350 Ω = 28.6 mA. The power dissipation of the whole full bridge is thus 4x Pv = U*I = 10 V * 28.6 mA = 286 mW. Depending on application/carrier material (= cooling) and ambient temperature, a not insignificant error can arise that is termed apparent elongation. Therefore, the strain gauges on the sensor material are counter-compensated by the manufacturer.
Inadequate circuit technology
As already shown, a full bridge may be able (due to the system) to fully compensate non-linearity, creep and temperature drift. Wiring-related measuring errors are avoided by the 6-conductor connection.
Measuring body and natural frequency
In the dynamic measurement of forces and weights, the setup and some of the properties of the transducer play an essential part in the attainable dynamics. The natural frequency of the complete system limits the dynamics of the application and is influenced by the spring constant of the measuring body and the coupled mass. The softer the measuring body (= larger deformation under nominal load), the lower the natural frequency. In the case of measuring transducers with rigid measuring bodies, too, the coupled mass must always be included if the natural frequency is to be determined.
Load cells are technologically similar to force transducers, but have a softer structure and are usually manufactured at optimized cost. Consequently, the recommendation for the mechanical setup is:
▪
use a rigid measuring transducer and the lightest possible mounted parts.
▪
The natural frequency of the system should be at least 2-5 times higher than the measuring signal frequency (i.e. the dynamically moved test specimen from the application that is to be measured).
▪
Natural frequency specifications in data sheets apply only to the measuring transducer without mounted parts and are therefore not useful in the field. Better: calculate with the nominal measuring path and masses of sensor plus mounted parts. The real natural frequency can be checked by means of a frequency analysis of the pulse response by FFT or manually by determining the period.
The natural frequency is to be calculated with
▪
f0 = natural frequency of the complete setup [Hz]
▪
Fnom = nominal force or nominal load of the transducer [kg]
▪
Snom = nominal measuring path of the transducer (deformation under nominal load) [m]
▪
m = sum of dead weight and coupled mass [kg]
With Fnom = 50 kg and Snom= 0.18 mm, the resulting dependence on the mass, for example, is graphically:
Recommendations for strain gauge measurement with Beckhoff modules
▪
Electrical connection
–
Operation with sense line is recommended:
Full bridge in 6-wire mode, half bridge in 5-wire mode, quarter bridge in 3/4-wire mode
–
The use of full bridges instead of half or quarter bridges is generally recommended in order to achieve high temperature stability and high measuring accuracy
▪
Selection of the feed voltage USupply
–
A feed voltage of 5 V has proven to be useful in many cases
–
In general it should be as high as possible within the permissible range according to the data sheet in order to achieve a large modulation of UBridge with the given nominal parameter [mV/V] and thus to utilize the electrical measuring range of the module well
–
However, it should be considered that the heating of the bridge in the load cell increases quadratically with USupply. With high feed voltages and insufficient heat dissipation from the sensor to the machine, this can lead to drift effects after switching on.
–
If necessary, select a bridge with a higher nominal parameter [mV/V] or a higher internal resistance [Ω]
▪
Selection of the nominal load of the weighbridge
–
It should be selected somewhat larger but as close as possible to the target load so that the mechanical and thus the electrical measuring range is utilized to the fullest extent possible.
–
The overload capacity of the load cell must be observed. Fast weighing procedures in particular can lead to excessive mechanical stresses; nevertheless, as stated above, the bridge should not be over-dimensioned
–
The mechanical natural frequency of the load cell (in which the measuring bridge/strain gauge is installed!) or of the complete setup is to be considered in relation to the weighing procedures (number of product changes, product speed, product weights). If necessary, a nominal load much larger than the target load should be selected, because sensors with a higher nominal load have shorter nominal measuring paths and are thus mechanically more rigid. With a more rigid measuring body – usually the softest part of the entire setup – the natural frequency increases. As a result, the dynamics of the weighing procedure can be cleanly captured and measuring errors due to the natural oscillations of the weighing setup are avoided.
▪
Calibration/compensation of the bridge
–
Regular zero compensation (tare) is recommended
–
The tare effect should be observed in order to recognize a possibly damaged measuring bridge: the signal of a damaged measuring bridge drifts; it does not return to zero after removal of the load
–
For the compensation of a gain error, a compensation point close to the target load should be selected during commissioning and if possible during operation, especially if this lies well below the nominal load (measurements in the partial load range).
▪
Possible filtering of the measurement, dynamic effects
–
In the case of fast weighing procedures (several products per second), it may be possible with adapted digital filters - despite an obviously “poor” measuring signal - to achieve a high measuring accuracy
–
Overshoot effects can often be observed because the product holder actually always moves mechanically (even if only in the µm range).
–
The entire procedure can also be dependent on the product speed; the filters may then need to be dynamically adjusted
–
The optimal signal analysis is supported by Beckhoff with various products: flexible filters in the EtherCAT modules, TwinCAT filter designer, TwinCAT filter library, TwinCAT Analytics and more
References
Some organizations are listed below that provide the specifications or documents for the technological field of weighing technology:
▪
OIML (ORGANISATION INTERNATIONALE DE MÉTROLOGIE LÉGALE) www.oiml.org
▪
PTB - Physikalisch-Technischen Bundesanstalt www.ptb.de
▪
Arbeitsgemeinschaft Mess- und Eichwesen: www.eichamt.de
▪
WELMEC - European cooperation in legal metrology www.welmec.org
▪
DKD - Deutscher Kalibrierdienst www.dkd.eu
▪
Fachgemeinschaft Waagen (AWA) im Verband Deutscher Maschinen- und Anlagenbau VDMA www.vdma.org


Start

Product overview [image] Start
Start
For commissioning:
▪
mount the EL3356 as described in the chapter Mounting and wiring
▪
configure the EL3356 in TwinCAT as described in the chapter Commissioning.
For fast commissioning please refer to chapter Commissioning -> Quick start.


Basics communication

Basics communication
Basics communication
Additional information
•
EtherCAT basics
•
EtherCAT cabling – wire-bound
•
General notes for setting the watchdog
•
EtherCAT State Machine
•
CoE Interface
•
Distributed Clock


EtherCAT basics

Basics communication [image] EtherCAT basics
EtherCAT basics
Please refer to the EtherCAT System Documentation for the EtherCAT fieldbus basics.


EtherCAT cabling – wire-bound

Basics communication [image] EtherCAT cabling – wire-bound
EtherCAT cabling – wire-bound
The cable length between two EtherCAT devices must not exceed 100 m. This results from the FastEthernet technology, which, above all for reasons of signal attenuation over the length of the cable, allows a maximum link length of 5 + 90 + 5 m if cables with appropriate properties are used. See also the Design recommendations for the infrastructure for EtherCAT/Ethernet.
Cables and connectors
For connecting EtherCAT devices only Ethernet connections (cables + plugs) that meet the requirements of at least category 5 (CAt5) according to EN 50173 or ISO/IEC 11801 should be used. EtherCAT uses 4 wires for signal transfer.
EtherCAT uses RJ45 plug connectors, for example. The pin assignment is compatible with the Ethernet standard (ISO/IEC 8802-3).
Pin | Color of conductor | Signal | Description
1 | yellow | TD + | Transmission Data +
2 | orange | TD - | Transmission Data -
3 | white | RD + | Receiver Data +
6 | blue | RD - | Receiver Data -
Due to automatic cable detection (auto-crossing) symmetric (1:1) or cross-over cables can be used between EtherCAT devices from Beckhoff.
Recommended cables
Suitable cables for the connection of EtherCAT devices can be found on the Beckhoff website!
E-Bus supply
A bus coupler can supply the EL terminals added to it with the E-bus system voltage of 5 V; a coupler is thereby loadable up to 2 A as a rule (see details in respective device documentation).
Information on how much current each EL terminal requires from the E-bus supply is available online and in the catalogue. If the added terminals require more current than the coupler can supply, then power feed terminals (e.g. EL9410) must be inserted at appropriate places in the terminal strand.
The pre-calculated theoretical maximum E-Bus current is displayed in the TwinCAT System Manager. A shortfall is marked by a negative total amount and an exclamation mark; a power feed terminal is to be placed before such a position.
System manager current calculation
Note
Malfunction possible!
The same ground potential must be used for the E-Bus supply of all EtherCAT terminals in a terminal block!


General notes for setting the watchdog

Basics communication [image] General notes for setting the watchdog
General notes for setting the watchdog
ELxxxx terminals are equipped with a safety feature (watchdog) that switches off the outputs after a specifiable time e.g. in the event of an interruption of the process data traffic, depending on the device and settings, e.g. in OFF state.
The EtherCAT slave controller (ESC) in the EL2xxx terminals features two watchdogs:
▪
SM watchdog (default: 100 ms)
▪
PDI watchdog (default: 100 ms)
SM watchdog (SyncManager Watchdog)
The SyncManager watchdog is reset after each successful EtherCAT process data communication with the terminal. If no EtherCAT process data communication takes place with the terminal for longer than the set and activated SM watchdog time, e.g. in the event of a line interruption, the watchdog is triggered and the outputs are set to FALSE. The OP state of the terminal is unaffected. The watchdog is only reset after a successful EtherCAT process data access. Set the monitoring time as described below.
The SyncManager watchdog monitors correct and timely process data communication with the ESC from the EtherCAT side.
PDI watchdog (Process Data Watchdog)
If no PDI communication with the EtherCAT slave controller (ESC) takes place for longer than the set and activated PDI watchdog time, this watchdog is triggered.
PDI (Process Data Interface) is the internal interface between the ESC and local processors in the EtherCAT slave, for example. The PDI watchdog can be used to monitor this communication for failure.
The PDI watchdog monitors correct and timely process data communication with the ESC from the application side.
The settings of the SM- and PDI-watchdog must be done for each slave separately in the TwinCAT System Manager.
EtherCAT tab -> Advanced Settings -> Behavior -> Watchdog
Notes:
▪
the multiplier is valid for both watchdogs.
▪
each watchdog has its own timer setting, the outcome of this in summary with the multiplier is a resulting time.
▪
Important: the multiplier/timer setting is only loaded into the slave at the start up, if the checkbox is activated.
If the checkbox is not activated, nothing is downloaded and the ESC settings remain unchanged.
Multiplier
Multiplier
Both watchdogs receive their pulses from the local terminal cycle, divided by the watchdog multiplier:
1/25 MHz * (watchdog multiplier + 2) = 100 µs (for default setting of 2498 for the multiplier)
The standard setting of 1000 for the SM watchdog corresponds to a release time of 100 ms.
The value in multiplier + 2 corresponds to the number of basic 40 ns ticks representing a watchdog tick.
The multiplier can be modified in order to adjust the watchdog time over a larger range.
Example “Set SM watchdog”
This checkbox enables manual setting of the watchdog times. If the outputs are set and the EtherCAT communication is interrupted, the SM watchdog is triggered after the set time and the outputs are erased. This setting can be used for adapting a terminal to a slower EtherCAT master or long cycle times. The default SM watchdog setting is 100 ms. The setting range is 0...65535. Together with a multiplier with a range of 1...65535 this covers a watchdog period between 0...~170 seconds.
Calculation
Multiplier = 2498 → watchdog base time = 1 / 25 MHz * (2498 + 2) = 0.0001 seconds = 100 µs
SM watchdog = 10000 → 10000 * 100 µs = 1 second watchdog monitoring time
SmallWarningYellow CAUTION
Undefined state possible!
The function for switching off of the SM watchdog via SM watchdog = 0 is only implemented in terminals from version -0016. In previous versions this operating mode should not be used.
SmallWarningYellow CAUTION
Damage of devices and undefined state possible!
If the SM watchdog is activated and a value of 0 is entered the watchdog switches off completely. This is the deactivation of the watchdog! Set outputs are NOT set in a safe state, if the communication is interrupted.


EtherCAT State Machine

Basics communication [image] EtherCAT State Machine
EtherCAT State Machine
The state of the EtherCAT slave is controlled via the EtherCAT State Machine (ESM). Depending upon the state, different functions are accessible or executable in the EtherCAT slave. Specific commands must be sent by the EtherCAT master to the device in each state, particularly during the bootup of the slave.
A distinction is made between the following states:
▪
Init
▪
Pre-Operational
▪
Safe-Operational and
▪
Operational
▪
Boot
The regular state of each EtherCAT slave after bootup is the OP state.
States of the EtherCAT State Machine
Init
After switch-on the EtherCAT slave in the Init state. No mailbox or process data communication is possible. The EtherCAT master initializes sync manager channels 0 and 1 for mailbox communication.
Pre-Operational (Pre-Op)
During the transition between Init and Pre-Op the EtherCAT slave checks whether the mailbox was initialized correctly.
In Pre-Op state mailbox communication is possible, but not process data communication. The EtherCAT master initializes the sync manager channels for process data (from sync manager channel 2), the FMMU channels and, if the slave supports configurable mapping, PDO mapping or the sync manager PDO assignment. In this state the settings for the process data transfer and perhaps terminal-specific parameters that may differ from the default settings are also transferred.
Safe-Operational (Safe-Op)
During transition between Pre-Op and Safe-Op the EtherCAT slave checks whether the sync manager channels for process data communication and, if required, the distributed clocks settings are correct. Before it acknowledges the change of state, the EtherCAT slave copies current input data into the associated DP-RAM areas of the EtherCAT slave controller (ECSC).
In Safe-Op state mailbox and process data communication is possible, although the slave keeps its outputs in a safe state, while the input data are updated cyclically.
Outputs in SAFEOP state
The default set watchdog monitoring sets the outputs of the module in a safe state - depending on the settings in SAFEOP and OP - e.g. in OFF state. If this is prevented by deactivation of the watchdog monitoring in the module, the outputs can be switched or set also in the SAFEOP state.
Operational (Op)
Before the EtherCAT master switches the EtherCAT slave from Safe-Op to Op it must transfer valid output data.
In the Op state the slave copies the output data of the masters to its outputs. Process data and mailbox communication is possible.
Boot
In the Boot state the slave firmware can be updated. The Boot state can only be reached via the Init state.
In the Boot state mailbox communication via the file access over EtherCAT (FoE) protocol is possible, but no other mailbox communication and no process data communication.


CoE Interface

Basics communication [image] CoE Interface
CoE Interface
General description
The CoE interface (CAN application protocol over EtherCAT)) is used for parameter management of EtherCAT devices. EtherCAT slaves or the EtherCAT master manage fixed (read only) or variable parameters which they require for operation, diagnostics or commissioning.
CoE parameters are arranged in a table hierarchy. In principle, the user has read access via the fieldbus. The EtherCAT master (TwinCAT System Manager) can access the local CoE lists of the slaves via EtherCAT in read or write mode, depending on the attributes.
Different CoE parameter types are possible, including string (text), integer numbers, Boolean values or larger byte fields. They can be used to describe a wide range of features. Examples of such parameters include manufacturer ID, serial number, process data settings, device name, calibration values for analog measurement or passwords.
The order is specified in two levels via hexadecimal numbering: (main)index, followed by subindex. The value ranges are
▪
Index: 0x0000 …0xFFFF (0...65535dez)
▪
SubIndex: 0x00…0xFF (0...255dez)
A parameter localized in this way is normally written as 0x8010:07, with preceding “0x” to identify the hexadecimal numerical range and a colon between index and subindex.
The relevant ranges for EtherCAT fieldbus users are:
▪
0x1000: This is where fixed identity information for the device is stored, including name, manufacturer, serial number etc., plus information about the current and available process data configurations.
▪
0x8000: This is where the operational and functional parameters for all channels are stored, such as filter settings or output frequency.
Other important ranges are:
▪
0x4000: here are the channel parameters for some EtherCAT devices. Historically, this was the first parameter area before the 0x8000 area was introduced. EtherCAT devices that were previously equipped with parameters in 0x4000 and changed to 0x8000 support both ranges for compatibility reasons and mirror internally.
▪
0x6000: Input PDOs (“input” from the perspective of the EtherCAT master)
▪
0x7000: Output PDOs (“output” from the perspective of the EtherCAT master)
Availability
Not every EtherCAT device must have a CoE list. Simple I/O modules without dedicated processor usually have no variable parameters and therefore no CoE list.
If a device has a CoE list, it is shown in the TwinCAT System Manager as a separate tab with a listing of the elements:
“CoE Online” tab
The figure above shows the CoE objects available in device “EL2502”, ranging from 0x1000 to 0x1600. The subindices for 0x1018 are expanded.
Data management and function “NoCoeStorage”
Some parameters, particularly the setting parameters of the slave, are configurable and writeable. This can be done in write or read mode
▪
via the System Manager (Fig. “CoE Online” tab) by clicking
This is useful for commissioning of the system/slaves. Click on the row of the index to be parameterized and enter a value in the “SetValue” dialog.
▪
from the control system/PLC via ADS, e.g. through blocks from the TcEtherCAT.lib library
This is recommended for modifications while the system is running or if no System Manager or operating staff are available.
Data management
If slave CoE parameters are modified online, Beckhoff devices store any changes in a fail-safe manner in the EEPROM, i.e. the modified CoE parameters are still available after a restart.
The situation may be different with other manufacturers.

An EEPROM is subject to a limited lifetime with respect to write operations. From typically 100,000 write operations onwards it can no longer be guaranteed that new (changed) data are reliably saved or are still readable. This is irrelevant for normal commissioning. However, if CoE parameters are continuously changed via ADS at machine runtime, it is quite possible for the lifetime limit to be reached. Support for the NoCoeStorage function, which suppresses the saving of changed CoE values, depends on the firmware version.
Please refer to the technical data in this documentation as to whether this applies to the respective device.
•
If the function is supported: the function is activated by entering the code word 0x12345678 once in CoE 0xF008 and remains active as long as the code word is not changed. After switching the device on it is then inactive. Changed CoE values are not saved in the EEPROM and can thus be changed any number of times.
•
Function is not supported: continuous changing of CoE values is not permissible in view of the lifetime limit.
Startup list
Changes in the local CoE list of the terminal are lost if the terminal is replaced. If a terminal is replaced with a new Beckhoff terminal, it will have the default settings. It is therefore advisable to link all changes in the CoE list of an EtherCAT slave with the Startup list of the slave, which is processed whenever the EtherCAT fieldbus is started. In this way a replacement EtherCAT slave can automatically be parameterized with the specifications of the user.
If EtherCAT slaves are used which are unable to store local CoE values permanently, the Startup list must be used.
Recommended approach for manual modification of CoE parameters
▪
Make the required change in the System Manager
The values are stored locally in the EtherCAT slave
▪
If the value is to be stored permanently, enter it in the Startup list.
The order of the Startup entries is usually irrelevant.
Startup list in the TwinCAT System Manager
The Startup list may already contain values that were configured by the System Manager based on the ESI specifications. Additional application-specific entries can be created.
Online/offline list
While working with the TwinCAT System Manager, a distinction has to be made whether the EtherCAT device is “available”, i.e. switched on and linked via EtherCAT and therefore online, or whether a configuration is created offline without connected slaves.
In both cases a CoE list as shown in Fig. “CoE online tab” is displayed. The connectivity is shown as offline/online.
▪
If the slave is offline
–
The offline list from the ESI file is displayed. In this case modifications are not meaningful or possible.
–
The configured status is shown under Identity.
–
No firmware or hardware version is displayed, since these are features of the physical device.
–
Offline is shown in red.
Offline list
▪
If the slave is online
–
The actual current slave list is read. This may take several seconds, depending on the size and cycle time.
–
The actual identity is displayed
–
The firmware and hardware version of the equipment according to the electronic information is displayed
–
Online is shown in green.
Online list
Channel-based order
The CoE list is available in EtherCAT devices that usually feature several functionally equivalent channels. For example, a 4-channel analog 0...10 V input terminal also has four logical channels and therefore four identical sets of parameter data for the channels. In order to avoid having to list each channel in the documentation, the placeholder “n” tends to be used for the individual channel numbers.
In the CoE system 16 indices, each with 255 subindices, are generally sufficient for representing all channel parameters. The channel-based order is therefore arranged in 16dec/10hex steps. The parameter range 0x8000 exemplifies this:
▪
Channel 0: parameter range 0x8000:00 ... 0x800F:255
▪
Channel 1: parameter range 0x8010:00 ... 0x801F:255
▪
Channel 2: parameter range 0x8020:00 ... 0x802F:255
▪
...
This is generally written as 0x80n0.
Detailed information on the CoE interface can be found in the EtherCAT system documentation on the Beckhoff website.


Distributed Clock

Basics communication [image] Distributed Clock
Distributed Clock
The distributed clock represents a local clock in the EtherCAT slave controller (ESC) with the following characteristics:
▪
Unit 1 ns
▪
Zero point 1.1.2000 00:00
▪
Size 64 bit (sufficient for the next 584 years; however, some EtherCAT slaves only offer 32-bit support, i.e. the variable overflows after approx. 4.2 seconds)
▪
The EtherCAT master automatically synchronizes the local clock with the master clock in the EtherCAT bus with a precision of < 100 ns.
For detailed information please refer to the EtherCAT system description.


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Instructions for ESD protection
•
Installation on mounting rails
•
Installation instructions for enhanced mechanical load capacity
•
Connection
•
Installation positions
•
Positioning of passive Terminals
•
ATEX - Special conditions (standard temperature range)
•
Continuative documentation about explosion protection
•
UL notice
•
EL3356 - LEDs
•
EL3356 - Connection


Instructions for ESD protection

Mounting and wiring [image] Instructions for ESD protection
Instructions for ESD protection
Note
Destruction of the devices by electrostatic discharge possible!
The devices contain components at risk from electrostatic discharge caused by improper handling.
•
Please ensure you are electrostatically discharged and avoid touching the contacts of the device directly.
•
Avoid contact with highly insulating materials (synthetic fibers, plastic film etc.).
•
Surroundings (working place, packaging and personnel) should by grounded probably, when handling with the devices.
•
Each assembly must be terminated at the right hand end with an EL9011 or EL9012 bus end cap, to ensure the protection class and ESD protection.
Spring contacts of the Beckhoff I/O components


Installation on mounting rails

Mounting and wiring [image] Installation on mounting rails
Installation on mounting rails
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Assembly
Attaching on mounting rail
The bus coupler and bus terminals are attached to commercially available 35 mm mounting rails (DIN rails according to EN 60715) by applying slight pressure:
1.
First attach the fieldbus coupler to the mounting rail.
2.
The bus terminals are now attached on the right-hand side of the fieldbus coupler. Join the components with tongue and groove and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
If the terminals are clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.
Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail. At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail. To mount the mounting rails with a height of 7.5 mm under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).
Disassembly
Disassembling of terminal
Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
1.
Pull the terminal by its orange-colored lugs approximately 1 cm away from the mounting rail. In doing so for this terminal the mounting rail lock is released automatically and you can pull the terminal out of the bus terminal block easily without excessive force.
2.
Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal out of the bus terminal block.
Connections within a bus terminal block
The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:
▪
The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
▪
The power contacts deal with the supply for the field electronics and thus represent a supply rail within the bus terminal block. The power contacts are supplied via terminals on the Bus Coupler (up to 24 V) or for higher voltages via power feed terminals.
Power Contacts
During the design of a bus terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts. Power Feed Terminals (KL91xx, KL92xx or EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.
PE power contact
The power contact labeled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Power contact on left side
Note
Possible damage of the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a nominal voltage of 230 V). For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.
SmallWarningYellow WARNING
Risk of electric shock!
The PE power contact must not be used for other potentials!


Installation instructions for enhanced mechanical load capacity

Mounting and wiring [image] Installation instructions for enhanced mechanical load capacity
Installation instructions for enhanced mechanical load capacity
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminal system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals!
Additional checks
The terminals have undergone the following additional tests:
Verification | Explanation
Vibration | 10 frequency runs in 3 axes
 | 6 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 25 g, 6 ms
Additional installation instructions
For terminals with enhanced mechanical load capacity, the following additional installation instructions apply:
▪
The enhanced mechanical load capacity is valid for all permissible installation positions
▪
Use a mounting rail according to EN 60715 TH35-15
▪
Fix the terminal segment on both sides of the mounting rail with a mechanical fixture, e.g. an earth terminal or reinforced end clamp
▪
The maximum total extension of the terminal segment (without coupler) is:
64 terminals (12 mm mounting with) or 32 terminals (24 mm mounting with)
▪
Avoid deformation, twisting, crushing and bending of the mounting rail during edging and installation of the rail
▪
The mounting points of the mounting rail must be set at 5 cm intervals
▪
Use countersunk head screws to fasten the mounting rail
▪
The free length between the strain relief and the wire connection should be kept as short as possible. A distance of approx. 10 cm should be maintained to the cable duct.


Connection

Mounting and wiring [image] Connection
Connection
Additional information
•
Connection system
•
Wiring
•
Shielding


Connection system

Mounting and wiring [image] Connection [image] Connection system
Connection system
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Overview
The Bus Terminal system offers different connection options for optimum adaptation to the respective application:
▪
The terminals of ELxxxx and KLxxxx series with standard wiring include electronics and connection level in a single enclosure.
▪
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level and enable steady wiring while replacing.
▪
The High Density Terminals (HD Terminals) include electronics and connection level in a single enclosure and have advanced packaging density.
Standard wiring (ELxxxx / KLxxxx)
Standard wiring
The terminals of ELxxxx and KLxxxx series have been tried and tested for years.
They feature integrated screwless spring force technology for fast and simple assembly.
Pluggable wiring (ESxxxx / KSxxxx)
Pluggable wiring
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level.
The assembly and wiring procedure is the same as for the ELxxxx and KLxxxx series.
The pluggable connection level enables the complete wiring to be removed as a plug connector from the top of the housing for servicing.
The lower section can be removed from the terminal block by pulling the unlocking tab.
Insert the new component and plug in the connector with the wiring. This reduces the installation time and eliminates the risk of wires being mixed up.
The familiar dimensions of the terminal only had to be changed slightly. The new connector adds about 3 mm. The maximum height of the terminal remains unchanged.
A tab for strain relief of the cable simplifies assembly in many applications and prevents tangling of individual connection wires when the connector is removed.
Conductor cross sections between 0.08 mm2 and 2.5 mm2 can continue to be used with the proven spring force technology.
The overview and nomenclature of the product names for ESxxxx and KSxxxx series has been retained as known from ELxxxx and KLxxxx series.
High Density Terminals (HD Terminals)
High Density Terminals
The Bus Terminals from these series with 16 terminal points are distinguished by a particularly compact design, as the packaging density is twice as large as that of the standard 12 mm Bus Terminals. Massive conductors and conductors with a wire end sleeve can be inserted directly into the spring loaded terminal point without tools.
Wiring HD Terminals
The High Density Terminals of the ELx8xx and KLx8xx series doesn't support pluggable wiring.
Ultrasonically “bonded” (ultrasonically welded) conductors
Ultrasonically “bonded” conductors
It is also possible to connect the Standard and High Density Terminals with ultrasonically “bonded” (ultrasonically welded) conductors. In this case, please note the tables concerning the wire-size width below!


Wiring

Mounting and wiring [image] Connection [image] Wiring
Wiring
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Terminals for standard wiring ELxxxx/KLxxxx and for pluggable wiring ESxxxx/KSxxxx
Connecting a cable on a terminal point
Up to eight terminal points enable the connection of solid or finely stranded cables to the Bus Terminal. The terminal points are implemented in spring force technology. Connect the cables as follows:
1.
Open a terminal point by pushing a screwdriver straight against the stop into the square opening above the terminal point. Do not turn the screwdriver or move it alternately (don't toggle).
2.
The wire can now be inserted into the round terminal opening without any force.
3.
The terminal point closes automatically when the pressure is released, holding the wire securely and permanently.
See the following table for the suitable wire size width.
Terminal housing | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Wire size width (single core wires) | 0.08 ... 2.5 mm2 | 0.08 ... 2.5 mm2
Wire size width (fine-wire conductors) | 0.08 ... 2.5 mm2 | 0,08 ... 2.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 1.5 mm2 | 0.14 ... 1.5 mm2
Wire stripping length | 8 ... 9 mm | 9 ... 10 mm
High Density Terminals (HD Terminals) with 16 terminal points
The conductors of the HD Terminals are connected without tools for single-wire conductors using the direct plug-in technique, i.e. after stripping the wire is simply plugged into the terminal point. The cables are released, as usual, using the contact release with the aid of a screwdriver. See the following table for the suitable wire size width.
Terminal housing | High Density Housing
Wire size width (single core wires) | 0.08 ... 1.5 mm2
Wire size width (fine-wire conductors) | 0.25 ... 1.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 0.75 mm2
Wire size width (ultrasonically “bonded" conductors) | only 1.5 mm2
Wire stripping length | 8 ... 9 mm


Shielding

Mounting and wiring [image] Connection [image] Shielding
Shielding
Shielding
Encoder, analog sensors and actors should always be connected with shielded, twisted paired wires.


Installation positions

Mounting and wiring [image] Installation positions
Installation positions
Note
Constraints regarding installation position and operating temperature range
Please refer to the technical data for a terminal to ascertain whether any restrictions regarding the installation position and/or the operating temperature range have been specified. When installing high power dissipation terminals ensure that an adequate spacing is maintained between other components above and below the terminal in order to guarantee adequate ventilation!
Optimum installation position (standard)
The optimum installation position requires the mounting rail to be installed horizontally and the connection surfaces of the EL/KL terminals to face forward (see Fig. Recommended distances for standard installation position). The terminals are ventilated from below, which enables optimum cooling of the electronics through convection. “From below” is relative to the acceleration of gravity.
Recommended distances for standard installation position
Compliance with the distances shown in Fig. Recommended distances for standard installation position is recommended.
Other installation positions
All other installation positions are characterized by different spatial arrangement of the mounting rail - see Fig “Other installation positions”.
The minimum distances to ambient specified above also apply to these installation positions.
Other installation positions


Positioning of passive Terminals

Mounting and wiring [image] Positioning of passive Terminals
Positioning of passive Terminals
Hint for positioning of passive terminals in the bus terminal block
EtherCAT Terminals (ELxxxx / ESxxxx), which do not take an active part in data transfer within the bus terminal block are so called passive terminals. The passive terminals have no current consumption out of the E-Bus.
To ensure an optimal data transfer, you must not directly string together more than two passive terminals!
Examples for positioning of passive terminals (highlighted)
Correct positioning
Incorrect positioning


ATEX - Special conditions (standard temperature range)

Mounting and wiring [image] ATEX - Special conditions (standard temperature range)
ATEX - Special conditions (standard temperature range)
SmallWarningYellow WARNING
Observe the special conditions for the intended use of Beckhoff fieldbus components with standard temperature range in potentially explosive areas (directive 2014/34/EU)!
•
The certified components are to be installed in a suitable housing that guarantees a protection class of at least IP54 in accordance with EN 60079-15! The environmental conditions during use are thereby to be taken into account!
•
For dust (only the fieldbus components of certificate no. KEMA 10ATEX0075 X Issue 9): The equipment shall be installed in a suitable enclosure providing a degree of protection of IP54 according to EN 60079-0 for group IIIA or IIIB and IP6X for group IIIC, taking into account the environmental conditions under which the equipment is used.
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of 0 to 55°C for the use of Beckhoff fieldbus components standard temperature range in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The individual terminals may only be unplugged or removed from the Bus Terminal system if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The fuses of the KL92xx/EL92xx power feed terminals may only be exchanged if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
Address selectors and ID switches may only be adjusted if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
▪
EN 60079-31:2013 (only for certificate no. KEMA 10ATEX0075 X Issue 9)
Marking
The Beckhoff fieldbus components with standard temperature range certified according to the ATEX directive for potentially explosive areas bear one of the following markings:

II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … +55°C
II 3D KEMA 10ATEX0075 X Ex tc IIC T135°C Dc Ta: 0 ... +55°C
(only for fieldbus components of certificate no. KEMA 10ATEX0075 X Issue 9)
or

II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … +55°C
II 3D KEMA 10ATEX0075 X Ex tc IIC T135°C Dc Ta: 0 ... +55°C
(only for fieldbus components of certificate no. KEMA 10ATEX0075 X Issue 9)


Continuative documentation about explosion protection

Mounting and wiring [image] Continuative documentation about explosion protection
Continuative documentation about explosion protection
Explosion protection for terminal systems
Pay also attention to the continuative documentation

Notes on the use of the Beckhoff terminal systems in hazardous areas according to ATEX and IECEx

that is available for download on the Beckhoff homepage https:\\www.beckhoff.com!


UL notice

Mounting and wiring [image] UL notice
UL notice
culus-logo
Application
Beckhoff EtherCAT modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
culus-logo
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
culus-logo
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
Basic principles
UL certification according to UL508. Devices with this kind of certification are marked by this sign:


EL3356 - LEDs

Mounting and wiring [image] EL3356 - LEDs
EL3356 - LEDs
EL3356 and special versions
Unless stated otherwise, the designation “EL3356” always refers also to special versions such as the EL3356-0010.
EL3356 LEDs
LED
Color
Meaning
RUN
green
This LED indicates the terminal's operating state:
off
State of the EtherCAT State Machine: INIT = initialization of the terminal
flashing
State of the EtherCAT State Machine: PREOP = function for mailbox communication and different standard-settings set
single flash
State of the EtherCAT State Machine: SAFEOP = verification of the Sync Manager channels and the distributed clocks.
Outputs remain in safe state
on
State of the EtherCAT State Machine: OP = normal operating state; mailbox and process data communication is possible
flickering
State of the EtherCAT State Machine: BOOTSTRAP = function for firmware updates of the terminal
Measure
green
ON
Measurement active (process data are valid)
OFF
▪
Calibration active (if the Calibr. LED is lit) or
▪
Test active (if the Test LED is lit)
▪
Filters are initialized
Steady state
green
ON
The measured value is stable
OFF
The measured value is not stable
Self Calibr.
green
ON
▪
Calibration active
▪
Process data are not valid
Self Test
green
ON
▪
Self-test active
▪
Process data are not valid
Error Dif
red
ON
▪
Channel 1 (strain gauge differential signal) is above or below the valid range
▪
Internal reference voltage for channel 1 is missing
Error Ref
red
ON
▪
Channel 2 (strain gauge differential signal) is above or below the valid range
▪
Internal reference voltage for channel 2 is missing
▪
Reference voltage too low (between -1 V and +1 V)


EL3356 - Connection

Mounting and wiring [image] EL3356 - Connection
EL3356 - Connection
Bridge feed
The EL3356 is designed for 6-wire connection. The measuring bridge is supplied by the supply voltage UV. By feeding the bridge supply voltage UV back from the measuring point to the EL3356, where it is measured as UREF, the distorting influence of line losses is minimized.
The supply voltage for the measuring bridge can be supplied via the power contacts and measured at connection points 3 and 7. Beckhoff power supply terminals, e.g. EL9510 (10 V) can be used for feeding the supply voltage into the power contacts. The EL3356 does not use the supply voltage supplied at the power contacts internally, but transfers it to the terminal points 3/7. Alternatively, the measuring bridge can be supplied by an external source.
For 4-wire connection and if the power contact supply is used, wire jumpers should be used between terminal points 3/6 and 5/7, in order to measure the supply voltage directly at the terminal.
Note
Otherwise components may be damaged: avoid excessive supply voltage
The potential difference between +UREF and -UREF may be up to 13 V.
Ensure that the power contacts carry no more than 13 V, if the measuring bridge is supplied from terminal points 3 and 7.
Note the limit values for the supply voltage specified in the data sheets of the sensor manufacturers.
LEDs and connection EL3356, EL3356-00x0
Terminal point |  | Description
Name | No.
+ UDIFF | 1 | + input measuring voltage
- UDIFF | 2 | - input measuring voltage
- UV | 3 | - supply voltage, connected to power contact within the terminal
Shield | 4 | Shield
+ UREF | 5 | + input reference voltage
- UREF | 6 | - input reference voltage
+UV | 7 | + supply voltage, connected to power contact within the terminal
Shield | 8 | Shield
Electrical isolation of the inputs and shielding concept
Electrical isolation of the inputs


Commissioning

Commissioning
Commissioning
Additional information
•
TwinCAT Quick Start
•
TwinCAT Development Environment
•
General Notes - EtherCAT Slave Application
•
Quick start
•
Basic function principles
•
Application notes
•
Calibration and compensation
•
Notices on analog specifications
•
Voltage measurement
•
Distributed Clocks mode (EL3356-0010, EL3356-0090 only)
•
Process data
•
TwinSAFE SC
•
EL3356-0090 - TwinSAFE SC process data
•
EL3356, EL3356-00x0 - Object description and parameterization
•
EL3356-0090 - Objects TwinSAFE Single Channel
•
Sample Program


TwinCAT Quick Start

Commissioning [image] TwinCAT Quick Start
TwinCAT Quick Start
TwinCAT is a development environment for real-time control including multi-PLC system, NC axis control, programming and operation. The whole system is mapped through this environment and enables access to a programming environment (including compilation) for the controller. Individual digital or analog inputs or outputs can also be read or written directly, in order to verify their functionality, for example.
For further information please refer to http://infosys.beckhoff.com:
▪
EtherCAT Systemmanual:
Fieldbus Components → EtherCAT Terminals → EtherCAT System Documentation → Setup in the TwinCAT System Manager
▪
TwinCAT 2 → TwinCAT System Manager → I/O - Configuration
▪
In particular, TwinCAT driver installation:
Fieldbus components → Fieldbus Cards and Switches → FC900x – PCI Cards for Ethernet → Installation
Devices contain the terminals for the actual configuration. All configuration data can be entered directly via editor functions (offline) or via the “Scan” function (online):
▪
“offline”: The configuration can be customized by adding and positioning individual components. These can be selected from a directory and configured.
–
The procedure for offline mode can be found under http://infosys.beckhoff.com:
TwinCAT 2 → TwinCAT System Manager → IO - Configuration → Adding an I/O Device
▪
“online”: The existing hardware configuration is read
–
See also http://infosys.beckhoff.com:
Fieldbus components → Fieldbus cards and switches → FC900x – PCI Cards for Ethernet → Installation → Searching for devices
The following relationship is envisaged from user PC to the individual control elements:
Relationship between user side (commissioning) and installation
The user inserting of certain components (I/O device, terminal, box...) is the same in TwinCAT 2 and TwinCAT 3. The descriptions below relate to the online procedure.
Sample configuration (actual configuration)
Based on the following sample configuration, the subsequent subsections describe the procedure for TwinCAT 2 and TwinCAT 3:
▪
Control system (PLC) CX2040 including CX2100-0004 power supply unit
▪
Connected to the CX2040 on the right (E-bus):
EL1004 (4-channel digital input terminal 24 VDC)
▪
Linked via the X001 port (RJ-45): EK1100 EtherCAT Coupler
▪
Connected to the EK1100 EtherCAT coupler on the right (E-bus):
EL2008 (8-channel digital output terminal 24 VDC; 0.5 A)
▪
(Optional via X000: a link to an external PC for the user interface)
Control configuration with Embedded PC, input (EL1004) and output (EL2008)
Note that all combinations of a configuration are possible; for example, the EL1004 terminal could also be connected after the coupler, or the EL2008 terminal could additionally be connected to the CX2040 on the right, in which case the EK1100 coupler wouldn’t be necessary.
Additional information
•
TwinCAT 2
•
TwinCAT 3


TwinCAT 2

Commissioning [image] TwinCAT Quick Start [image] TwinCAT 2
TwinCAT 2
Startup
TwinCAT basically uses two user interfaces: the TwinCAT System Manager for communication with the electromechanical components and TwinCAT PLC Control for the development and compilation of a controller. The starting point is the TwinCAT System Manager.
After successful installation of the TwinCAT system on the PC to be used for development, the TwinCAT 2 System Manager displays the following user interface after startup:
Initial TwinCAT 2 user interface
Generally, TwinCAT can be used in local or remote mode. Once the TwinCAT system including the user interface (standard) is installed on the respective PLC, TwinCAT can be used in local mode and thereby the next step is “Insert Device”.
If the intention is to address the TwinCAT runtime environment installed on a PLC as development environment remotely from another system, the target system must be made known first. In the menu under “Actions” → “Choose Target System...”, via the symbol “ [image] ” or the “F8” key, open the following window:
Selection of the target system
Use “Search (Ethernet)...” to enter the target system. Thus a next dialog opens to either:
▪
enter the known computer name after “Enter Host Name / IP:” (as shown in red)
▪
perform a “Broadcast Search” (if the exact computer name is not known)
▪
enter the known computer IP or AmsNetID.
Specify the PLC for access by the TwinCAT System Manager: selection of the target system
Once the target system has been entered, it is available for selection as follows (a password may have to be entered):
After confirmation with “OK” the target system can be accessed via the System Manager.
Adding devices
In the configuration tree of the TwinCAT 2 System Manager user interface on the left, select “I/O Devices” and then right-click to open a context menu and select “Scan Devices…”, or start the action in the menu bar via [image]. The TwinCAT System Manager may first have to be set to “Config mode” via [image] or via menu
“Actions” → “Set/Reset TwinCAT to Config Mode…” (Shift + F4).
Select “Scan Devices...”
Confirm the warning message, which follows, and select “EtherCAT” in the dialog:
Automatic detection of I/O devices: selection the devices to be integrated
Confirm the message “Find new boxes”, in order to determine the terminals connected to the devices. “Free Run” enables manipulation of input and output values in “Config mode” and should also be acknowledged.
Based on the sample configuration described at the beginning of this section, the result is as follows:
Mapping of the configuration in the TwinCAT 2 System Manager
The whole process consists of two stages, which may be performed separately (first determine the devices, then determine the connected elements such as boxes, terminals, etc.). A scan can also be initiated by selecting “Device ...” from the context menu, which then reads the elements present in the configuration below:
Reading of individual terminals connected to a device
This functionality is useful if the actual configuration is modified at short notice.
Programming and integrating the PLC
TwinCAT PLC Control is the development environment for the creation of the controller in different program environments: TwinCAT PLC Control supports all languages described in IEC 61131-3. There are two text-based languages and three graphical languages.
▪
Text-based languages
–
Instruction List (IL)
–
Structured Text (ST)
▪
Graphical languages
–
Function Block Diagram (FBD)
–
Ladder Diagram (LD)
–
The Continuous Function Chart Editor (CFC)
–
Sequential Function Chart (SFC)
The following section refers to Structured Text (ST).
After starting TwinCAT PLC Control, the following user interface is shown for an initial project:
TwinCAT PLC Control after startup
Sample variables and a sample program have been created and stored under the name “PLC_example.pro”:
Sample program with variables after a compile process (without variable integration)
Warning 1990 (missing “VAR_CONFIG”) after a compile process indicates that the variables defined as external (with the ID “AT%I*” or “AT%Q*”) have not been assigned. After successful compilation, TwinCAT PLC Control creates a “*.tpy” file in the directory in which the project was stored. This file (“*.tpy”) contains variable assignments and is not known to the System Manager, hence the warning. Once the System Manager has been notified, the warning no longer appears.
First, integrate the TwinCAT PLC Control project in the System Manager via the context menu of the PLC configuration; right-click and select “Append PLC Project…”:
Appending the TwinCAT PLC Control project
Select the PLC configuration “PLC_example.tpy” in the browser window that opens. The project including the two variables identified with “AT” are then integrated in the configuration tree of the System Manager:
PLC project integrated in the PLC configuration of the System Manager
The two variables “bEL1004_Ch4” and “nEL2008_value” can now be assigned to certain process objects of the I/O configuration.
Assigning variables
Open a window for selecting a suitable process object (PDO) via the context menu of a variable of the integrated project “PLC_example” and via “Modify Link...” “Standard”:
Creating the links between PLC variables and process objects
In the window that opens, the process object for the variable “bEL1004_Ch4” of type BOOL can be selected from the PLC configuration tree:
Selecting PDO of type BOOL
According to the default setting, certain PDO objects are now available for selection. In this sample the input of channel 4 of the EL1004 terminal is selected for linking. In contrast, the checkbox “All types” must be ticked for creating the link for the output variables, in order to allocate a set of eight separate output bits to a byte variable. The following diagram shows the whole process:
Selecting several PDOs simultaneously: activate “Continuous” and “All types”
Note that the “Continuous” checkbox was also activated. This is designed to allocate the bits contained in the byte of the variable “nEL2008_value” sequentially to all eight selected output bits of the EL2008 terminal. In this way it is possible to subsequently address all eight outputs of the terminal in the program with a byte corresponding to bit 0 for channel 1 to bit 7 for channel 8 of the PLC. A special symbol ( [image]) at the yellow or red object of the variable indicates that a link exists. The links can also be checked by selecting a “Goto Link Variable” from the context menu of a variable. The object opposite, in this case the PDO, is automatically selected:
Application of a “Goto Link” variable, using “MAIN.bEL1004_Ch4” as a sample
The process of assigning variables to the PDO is completed via the menu selection “Actions” → “Generate Mappings”, key Ctrl+M or by clicking on the symbol [image] in the menu.
This can be visualized in the configuration:
The process of creating links can also take place in the opposite direction, i.e. starting with individual PDOs to variable. However, in this example it would then not be possible to select all output bits for the EL2008, since the terminal only makes individual digital outputs available. If a terminal has a byte, word, integer or similar PDO, it is possible to allocate this a set of bit-standardized variables (type “BOOL”). Here, too, a “Goto Link Variable” from the context menu of a PDO can be executed in the other direction, so that the respective PLC instance can then be selected.
Activation of the configuration
The allocation of PDO to PLC variables has now established the connection from the controller to the inputs and outputs of the terminals. The configuration can now be activated. First, the configuration can be verified via [image] (or via “Actions” → “Check Configuration”). If no error is present, the configuration can be activated via [image] (or via “Actions” → “Activate Configuration…”) to transfer the System Manager settings to the runtime system. Confirm the messages “Old configurations are overwritten!” and “Restart TwinCAT system in Run mode” with “OK”.
A few seconds later the real-time status [image] is displayed at the bottom right in the System Manager. The PLC system can then be started as described below.
Starting the controller
Starting from a remote system, the PLC control has to be linked with the Embedded PC over Ethernet via “Online” → “Choose Run-Time System…”:
Choose target system (remote)
In this sample “Runtime system 1 (port 801)” is selected and confirmed. Link the PLC with the real-time system via menu option “Online” → “Login”, the F11 key or by clicking on the symbol [image]. The control program can then be loaded for execution. This results in the message “No program on the controller! Should the new program be loaded?”, which should be acknowledged with “Yes”. The runtime environment is ready for the program start:
PLC Control logged in, ready for program startup
The PLC can now be started via “Online” → “Run”, F5 key or [image].


TwinCAT 3

Commissioning [image] TwinCAT Quick Start [image] TwinCAT 3
TwinCAT 3
Startup
TwinCAT makes the development environment areas available together with Microsoft Visual Studio: after startup, the project folder explorer appears on the left in the general window area (cf. “TwinCAT System Manager” of TwinCAT 2) for communication with the electromechanical components.
After successful installation of the TwinCAT system on the PC to be used for development, TwinCAT 3 (shell) displays the following user interface after startup:
Initial TwinCAT 3 user interface
First create a new project via [image] (or under “File”→“New”→ “Project…”). In the following dialog make the corresponding entries as required (as shown in the diagram):
Create new TwinCAT project
The new project is then available in the project folder explorer:
New TwinCAT3 project in the project folder explorer
Generally, TwinCAT can be used in local or remote mode. Once the TwinCAT system including the user interface (standard) is installed on the respective PLC, TwinCAT can be used in local mode and thereby the next step is “Insert Device”.
If the intention is to address the TwinCAT runtime environment installed on a PLC as development environment remotely from another system, the target system must be made known first. Via the symbol in the menu bar:
expand the pull-down menu:
and open the following window:
Selection dialog: Choose the target system
Use “Search (Ethernet)...” to enter the target system. Thus a next dialog opens to either:
▪
enter the known computer name after “Enter Host Name / IP:” (as shown in red)
▪
perform a “Broadcast Search” (if the exact computer name is not known)
▪
enter the known computer IP or AmsNetID.
Specify the PLC for access by the TwinCAT System Manager: selection of the target system
Once the target system has been entered, it is available for selection as follows (a password may have to be entered):
After confirmation with “OK” the target system can be accessed via the Visual Studio shell.
Adding devices
In the project folder explorer of the Visual Studio shell user interface on the left, select “Devices” within element “I/O”, then right-click to open a context menu and select “Scan” or start the action via [image] in the menu bar. The TwinCAT System Manager may first have to be set to “Config mode” via [image] or via the menu “TwinCAT” → “Restart TwinCAT (Config mode)”.
Select “Scan”
Confirm the warning message, which follows, and select “EtherCAT” in the dialog:
Automatic detection of I/O devices: selection the devices to be integrated
Confirm the message “Find new boxes”, in order to determine the terminals connected to the devices. “Free Run” enables manipulation of input and output values in “Config mode” and should also be acknowledged.
Based on the sample configuration described at the beginning of this section, the result is as follows:
Mapping of the configuration in VS shell of the TwinCAT3 environment
The whole process consists of two stages, which may be performed separately (first determine the devices, then determine the connected elements such as boxes, terminals, etc.). A scan can also be initiated by selecting “Device ...” from the context menu, which then reads the elements present in the configuration below:
Reading of individual terminals connected to a device
This functionality is useful if the actual configuration is modified at short notice.
Programming the PLC
TwinCAT PLC Control is the development environment for the creation of the controller in different program environments: TwinCAT PLC Control supports all languages described in IEC 61131-3. There are two text-based languages and three graphical languages.
▪
Text-based languages
–
Instruction List (IL)
–
Structured Text (ST)
▪
Graphical languages
–
Function Block Diagram (FBD)
–
Ladder Diagram (LD)
–
The Continuous Function Chart Editor (CFC)
–
Sequential Function Chart (SFC)
The following section refers to Structured Text (ST).
In order to create a programming environment, a PLC subproject is added to the project sample via the context menu of “PLC” in the project folder explorer by selecting “Add New Item….”:
Adding the programming environment in “PLC”
In the dialog that opens select “Standard PLC project” and enter “PLC_example” as project name, for example, and select a corresponding directory:
Specifying the name and directory for the PLC programming environment
The “Main” program, which already exists by selecting “Standard PLC project”, can be opened by double-clicking on “PLC_example_project” in “POUs”. The following user interface is shown for an initial project:
Initial “Main” program of the standard PLC project
To continue, sample variables and a sample program have now been created:
Sample program with variables after a compile process (without variable integration)
The control program is now created as a project folder, followed by the compile process:
Start program compilation
The following variables, identified in the ST/ PLC program with “AT%”, are then available in under “Assignments” in the project folder explorer:
Assigning variables
Via the menu of an instance - variables in the “PLC” context, use the “Modify Link…” option to open a window for selecting a suitable process object (PDO) for linking:
Creating the links between PLC variables and process objects
In the window that opens, the process object for the variable “bEL1004_Ch4” of type BOOL can be selected from the PLC configuration tree:
Selecting PDO of type BOOL
According to the default setting, certain PDO objects are now available for selection. In this sample the input of channel 4 of the EL1004 terminal is selected for linking. In contrast, the checkbox “All types” must be ticked for creating the link for the output variables, in order to allocate a set of eight separate output bits to a byte variable. The following diagram shows the whole process:
Selecting several PDOs simultaneously: activate “Continuous” and “All types”
Note that the “Continuous” checkbox was also activated. This is designed to allocate the bits contained in the byte of the variable “nEL2008_value” sequentially to all eight selected output bits of the EL2008 terminal. In this way it is possible to subsequently address all eight outputs of the terminal in the program with a byte corresponding to bit 0 for channel 1 to bit 7 for channel 8 of the PLC. A special symbol ( [image]) at the yellow or red object of the variable indicates that a link exists. The links can also be checked by selecting a “Goto Link Variable” from the context menu of a variable. The object opposite, in this case the PDO, is automatically selected:
Application of a “Goto Link” variable, using “MAIN.bEL1004_Ch4” as a sample
The process of creating links can also take place in the opposite direction, i.e. starting with individual PDOs to variable. However, in this example it would then not be possible to select all output bits for the EL2008, since the terminal only makes individual digital outputs available. If a terminal has a byte, word, integer or similar PDO, it is possible to allocate this a set of bit-standardized variables (type “BOOL”). Here, too, a “Goto Link Variable” from the context menu of a PDO can be executed in the other direction, so that the respective PLC instance can then be selected.
Note on the type of variable assignment
The following type of variable assignment can only be used from TwinCAT version V3.1.4024.4 onwards and is only available for terminals with a microcontroller.
In TwinCAT it is possible to create a structure from the mapped process data of a terminal. An instance of this structure can then be created in the PLC, so it is possible to access the process data directly from the PLC without having to declare own variables.
The procedure for the EL3001 1-channel analog input terminal -10...+10 V is shown as an example.
1.
First the required process data must be selected in the “Process data” tab in TwinCAT.
2.
After that, the PLC data type must be generated in the tab “PLC” via the check box.
3.
The data type in the “Data Type” field can then be copied using the “Copy” button.
Creating a PLC data type
4.
An instance of the data structure of the copied data type must then be created in the PLC.
Instance_of_struct
5.
Then the project folder must be created. This can be done either via the key combination “CTRL + Shift + B” or via the “Build” tab in TwinCAT.
6.
The structure in the “PLC” tab of the terminal must then be linked to the created instance.
Linking the structure
7.
In the PLC the process data can then be read or written via the structure in the program code.
Reading a variable from the structure of the process data
Activation of the configuration
The allocation of PDO to PLC variables has now established the connection from the controller to the inputs and outputs of the terminals. The configuration can now be activated with [image] or via the menu under “TwinCAT” in order to transfer settings of the development environment to the runtime system. Confirm the messages “Old configurations are overwritten!” and “Restart TwinCAT system in Run mode” with “OK”. The corresponding assignments can be seen in the project folder explorer:
A few seconds later the corresponding status of the Run mode is displayed in the form of a rotating symbol [image] at the bottom right of the VS shell development environment. The PLC system can then be started as described below.
Starting the controller
Select the menu option “PLC” → “Login” or click on [image] to link the PLC with the real-time system and load the control program for execution. This results in the message No program on the controller! Should the new program be loaded?, which should be acknowledged with “Yes”. The runtime environment is ready for program start by click on symbol [image], the “F5” key or via “PLC” in the menu selecting “Start”. The started programming environment shows the runtime values of individual variables:
TwinCAT development environment (VS shell): logged-in, after program startup
The two operator control elements for stopping [image] and logout [image] result in the required action (accordingly also for stop “Shift + F5”, or both actions can be selected via the PLC menu).


TwinCAT Development Environment

Commissioning [image] TwinCAT Development Environment
TwinCAT Development Environment
The Software for automation TwinCAT (The Windows Control and Automation Technology) will be distinguished into:
▪
TwinCAT 2: System Manager (Configuration) & PLC Control (Programming)
▪
TwinCAT 3: Enhancement of TwinCAT 2 (Programming and Configuration takes place via a common Development Environment)
Details:
▪
TwinCAT 2:
–
Connects I/O devices to tasks in a variable-oriented manner
–
Connects tasks to tasks in a variable-oriented manner
–
Supports units at the bit level
–
Supports synchronous or asynchronous relationships
–
Exchange of consistent data areas and process images
–
Datalink on NT - Programs by open Microsoft Standards (OLE, OCX, ActiveX, DCOM+, etc.)
–
Integration of IEC 61131-3-Software-SPS, Software- NC and Software-CNC within Windows NT/2000/XP/Vista, Windows 7, NT/XP Embedded, CE
–
Interconnection to all common fieldbusses
–
More…
Additional features:
▪
TwinCAT 3 (eXtended Automation):
–
Visual-Studio®-Integration
–
Choice of the programming language
–
Supports object orientated extension of IEC 61131-3
–
Usage of C/C++ as programming language for real time applications
–
Connection to MATLAB®/Simulink®
–
Open interface for expandability
–
Flexible run-time environment
–
Active support of Multi-Core- und 64-Bit-Operatingsystem
–
Automatic code generation and project creation with the TwinCAT Automation Interface
–
More…
Within the following sections commissioning of the TwinCAT Development Environment on a PC System for the control and also the basically functions of unique control elements will be explained.
Please see further information to TwinCAT 2 and TwinCAT 3 at http://infosys.beckhoff.com.
Additional information
•
Installation of the TwinCAT real-time driver
•
Notes regarding ESI device description
•
TwinCAT ESI Updater
•
Distinction between Online and Offline
•
OFFLINE configuration creation
•
ONLINE configuration creation
•
EtherCAT subscriber configuration


Installation of the TwinCAT real-time driver

Commissioning [image] TwinCAT Development Environment [image] Installation of the TwinCAT real-time driver
Installation of the TwinCAT real-time driver
In order to assign real-time capability to a standard Ethernet port of an IPC controller, the Beckhoff real-time driver has to be installed on this port under Windows.
This can be done in several ways. One option is described here.
In the System Manager call up the TwinCAT overview of the local network interfaces via Options → Show Real Time Ethernet Compatible Devices.
System Manager “Options” (TwinCAT 2)
This have to be called up by the Menü “TwinCAT” within the TwinCAT 3 environment:
Call up under VS Shell (TwinCAT 3)
The following dialog appears:
Overview of network interfaces
Interfaces listed under “Compatible devices” can be assigned a driver via the “Install” button. A driver should only be installed on compatible devices.
A Windows warning regarding the unsigned driver can be ignored.
Alternatively an EtherCAT-device can be inserted first of all as described in chapter Offline configuration creation, section “Creating the EtherCAT device” in order to view the compatible ethernet ports via its EtherCAT properties (tab “Adapter”, button “Compatible Devices…”):
EtherCAT device properties(TwinCAT 2): click on “Compatible Devices…” of tab “Adapte””
TwinCAT 3: the properties of the EtherCAT device can be opened by double click on “Device .. (EtherCAT)” within the Solution Explorer under “I/O”:
After the installation the driver appears activated in the Windows overview for the network interface (Windows Start → System Properties → Network)
Windows properties of the network interface
A correct setting of the driver could be:
Exemplary correct driver setting for the Ethernet port
Other possible settings have to be avoided:
Incorrect driver settings for the Ethernet port
IP address of the port used
IP address/DHCP
In most cases an Ethernet port that is configured as an EtherCAT device will not transport general IP packets. For this reason and in cases where an EL6601 or similar devices are used it is useful to specify a fixed IP address for this port via the “Internet Protocol TCP/IP” driver setting and to disable DHCP. In this way the delay associated with the DHCP client for the Ethernet port assigning itself a default IP address in the absence of a DHCP server is avoided. A suitable address space is 192.168.x.x, for example.
TCP/IP setting for the Ethernet port


Notes regarding ESI device description

Commissioning [image] TwinCAT Development Environment [image] Notes regarding ESI device description
Notes regarding ESI device description
Installation of the latest ESI device description
The TwinCAT EtherCAT master/System Manager needs the device description files for the devices to be used in order to generate the configuration in online or offline mode. The device descriptions are contained in the so-called ESI files (EtherCAT Slave Information) in XML format. These files can be requested from the respective manufacturer and are made available for download. An *.xml file may contain several device descriptions.
The ESI files for Beckhoff EtherCAT devices are available on the Beckhoff website.
The ESI files should be stored in the TwinCAT installation directory.
Default settings:
▪
TwinCAT 2: C:\TwinCAT\IO\EtherCAT
▪
TwinCAT 3: C:\TwinCAT\3.1\Config\Io\EtherCAT
The files are read (once) when a new System Manager window is opened, if they have changed since the last time the System Manager window was opened.
A TwinCAT installation includes the set of Beckhoff ESI files that was current at the time when the TwinCAT build was created.
For TwinCAT 2.11/TwinCAT 3 and higher, the ESI directory can be updated from the System Manager, if the programming PC is connected to the Internet; by
▪
TwinCAT 2: Option → “Update EtherCAT Device Descriptions”
▪
TwinCAT 3: TwinCAT → EtherCAT Devices → “Update Device Descriptions (via ETG Website)…”
The TwinCAT ESI Updater is available for this purpose.
ESI
The *.xml files are associated with *.xsd files, which describe the structure of the ESI XML files. To update the ESI device descriptions, both file types should therefore be updated.
Device differentiation
EtherCAT devices/slaves are distinguished by four properties, which determine the full device identifier. For example, the device identifier EL2521-0025-1018 consists of:
▪
family key “EL”
▪
name “2521”
▪
type “0025”
▪
and revision “1018”
Identifier structure
The order identifier consisting of name + type (here: EL2521-0010) describes the device function. The revision indicates the technical progress and is managed by Beckhoff. In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation. Each revision has its own ESI description. See further notes.
Online description
If the EtherCAT configuration is created online through scanning of real devices (see section Online setup) and no ESI descriptions are available for a slave (specified by name and revision) that was found, the System Manager asks whether the description stored in the device should be used. In any case, the System Manager needs this information for setting up the cyclic and acyclic communication with the slave correctly.
OnlineDescription information window (TwinCAT 2)
In TwinCAT 3 a similar window appears, which also offers the Web update:
Information window OnlineDescription (TwinCAT 3)
If possible, the Yes is to be rejected and the required ESI is to be requested from the device manufacturer. After installation of the XML/XSD file the configuration process should be repeated.
Note
Changing the “usual” configuration through a scan
✓
If a scan discovers a device that is not yet known to TwinCAT, distinction has to be made between two cases. Taking the example here of the EL2521-0000 in the revision 1019
1.
no ESI is present for the EL2521-0000 device at all, either for the revision 1019 or for an older revision. The ESI must then be requested from the manufacturer (in this case Beckhoff).
2.
an ESI is present for the EL2521-0000 device, but only in an older revision, e.g. 1018 or 1017.
In this case an in-house check should first be performed to determine whether the spare parts stock allows the integration of the increased revision into the configuration at all. A new/higher revision usually also brings along new features. If these are not to be used, work can continue without reservations with the previous revision 1018 in the configuration. This is also stated by the Beckhoff compatibility rule.
Refer in particular to the chapter “General notes on the use of Beckhoff EtherCAT IO components” and for manual configuration to the chapter “Offline configuration creation”.
If the OnlineDescription is used regardless, the System Manager reads a copy of the device description from the EEPROM in the EtherCAT slave. In complex slaves the size of the EEPROM may not be sufficient for the complete ESI, in which case the ESI would be incomplete in the configurator. Therefore it’s recommended using an offline ESI file with priority in such a case.
The System Manager creates for online recorded device descriptions a new file “OnlineDescription0000...xml” in its ESI directory, which contains all ESI descriptions that were read online.
File OnlineDescription.xml created by the System Manager
Is a slave desired to be added manually to the configuration at a later stage, online created slaves are indicated by a prepended symbol “>” in the selection list (see Figure Indication of an online recorded ESI of EL2521 as an example).
Indication of an online recorded ESI of EL2521 as an example
If such ESI files are used and the manufacturer's files become available later, the file OnlineDescription.xml should be deleted as follows:
▪
close all System Manager windows
▪
restart TwinCAT in Config mode
▪
delete “OnlineDescription0000...xml”
▪
restart TwinCAT System Manager
This file should not be visible after this procedure, if necessary press <F5> to update
OnlineDescription for TwinCAT 3.x
In addition to the file described above “OnlineDescription0000...xml”, a so called EtherCAT cache with new discovered devices is created by TwinCAT 3.x, e.g. under Windows 7:

(Please note the language settings of the OS!)
You have to delete this file, too.
Faulty ESI file
If an ESI file is faulty and the System Manager is unable to read it, the System Manager brings up an information window.
Information window for faulty ESI file (left: TwinCAT 2; right: TwinCAT 3)
Reasons may include:
▪
Structure of the *.xml does not correspond to the associated *.xsd file → check your schematics
▪
Contents cannot be translated into a device description → contact the file manufacturer


TwinCAT ESI Updater

Commissioning [image] TwinCAT Development Environment [image] TwinCAT ESI Updater
TwinCAT ESI Updater
For TwinCAT 2.11 and higher, the System Manager can search for current Beckhoff ESI files automatically, if an online connection is available:
Using the ESI Updater (>= TwinCAT 2.11)
The call up takes place under:
“Options” → “Update EtherCAT Device Descriptions”
Selection under TwinCAT 3:
Using the ESI Updater (TwinCAT 3)
The ESI Updater (TwinCAT 3) is a convenient option for automatic downloading of ESI data provided by EtherCAT manufacturers via the Internet into the TwinCAT directory (ESI = EtherCAT slave information). TwinCAT accesses the central ESI ULR directory list stored at ETG; the entries can then be viewed in the Updater dialog, although they cannot be changed there.
The call up takes place under:
“TwinCAT” → “EtherCAT Devices” → “Update Device Description (via ETG Website)…”.


Distinction between Online and Offline

Commissioning [image] TwinCAT Development Environment [image] Distinction between Online and Offline
Distinction between Online and Offline
The distinction between online and offline refers to the presence of the actual I/O environment (drives, terminals, EJ-modules). If the configuration is to be prepared in advance of the system configuration as a programming system, e.g. on a laptop, this is only possible in “Offline configuration” mode. In this case all components have to be entered manually in the configuration, e.g. based on the electrical design.
If the designed control system is already connected to the EtherCAT system and all components are energised and the infrastructure is ready for operation, the TwinCAT configuration can simply be generated through “scanning” from the runtime system. This is referred to as online configuration.
In any case, during each startup the EtherCAT master checks whether the slaves it finds match the configuration. This test can be parameterised in the extended slave settings. Refer to note “Installation of the latest ESI-XML device description”.
For preparation of a configuration:
▪
the real EtherCAT hardware (devices, couplers, drives) must be present and installed
▪
the devices/modules must be connected via EtherCAT cables or in the terminal/ module strand in the same way as they are intended to be used later
▪
the devices/modules be connected to the power supply and ready for communication
▪
TwinCAT must be in CONFIG mode on the target system.
The online scan process consists of:
▪
detecting the EtherCAT device (Ethernet port at the IPC)
▪
detecting the connected EtherCAT devices. This step can be carried out independent of the preceding step
▪
troubleshooting
The scan with existing configuration can also be carried out for comparison.


OFFLINE configuration creation

Commissioning [image] TwinCAT Development Environment [image] OFFLINE configuration creation
OFFLINE configuration creation
Creating the EtherCAT device
Create an EtherCAT device in an empty System Manager window.
Append EtherCAT device (left: TwinCAT 2; right: TwinCAT 3)
Select type “EtherCAT” for an EtherCAT I/O application with EtherCAT slaves. For the present publisher/subscriber service in combination with an EL6601/EL6614 terminal select “EtherCAT Automation Protocol via EL6601”.
Selecting the EtherCAT connection (TwinCAT 2.11, TwinCAT 3)
Then assign a real Ethernet port to this virtual device in the runtime system.
Selecting the Ethernet port
This query may appear automatically when the EtherCAT device is created, or the assignment can be set/modified later in the properties dialog; see Fig. “EtherCAT device properties (TwinCAT 2)”.
EtherCAT device properties (TwinCAT 2)
TwinCAT 3: the properties of the EtherCAT device can be opened by double click on “Device .. (EtherCAT)” within the Solution Explorer under “I/O”:
Selecting the Ethernet port
Ethernet ports can only be selected for EtherCAT devices for which the TwinCAT real-time driver is installed. This has to be done separately for each port. Please refer to the respective installation page.
Defining EtherCAT slaves
Further devices can be appended by right-clicking on a device in the configuration tree.
Appending EtherCAT devices (left: TwinCAT 2; right: TwinCAT 3)
The dialog for selecting a new device opens. Only devices for which ESI files are available are displayed.
Only devices are offered for selection that can be appended to the previously selected device. Therefore the physical layer available for this port is also displayed (Fig. “Selection dialog for new EtherCAT device”, A). In the case of cable-based Fast-Ethernet physical layer with PHY transfer, then also only cable-based devices are available, as shown in Fig. “Selection dialog for new EtherCAT device”. If the preceding device has several free ports (e.g. EK1122 or EK1100), the required port can be selected on the right-hand side (A).
Overview of physical layer
▪
“Ethernet”: cable-based 100BASE-TX: EK couplers, EP boxes, devices with RJ45/M8/M12 connector
▪
“E-Bus”: LVDS “terminal bus”, “EJ-module”: EL/ES terminals, various modular modules
The search field facilitates finding specific devices (since TwinCAT 2.11 or TwinCAT 3).
Selection dialog for new EtherCAT device
By default only the name/device type is used as selection criterion. For selecting a specific revision of the device the revision can be displayed as “Extended Information”.
Display of device revision
In many cases several device revisions were created for historic or functional reasons, e.g. through technological advancement. For simplification purposes (see Fig. “Selection dialog for new EtherCAT device”) only the last (i.e. highest) revision and therefore the latest state of production is displayed in the selection dialog for Beckhoff devices. To show all device revisions available in the system as ESI descriptions tick the “Show Hidden Devices” check box, see Fig. “Display of previous revisions”.
Display of previous revisions
Device selection based on revision, compatibility
The ESI description also defines the process image, the communication type between master and slave/device and the device functions, if applicable. The physical device (firmware, if available) has to support the communication queries/settings of the master. This is backward compatible, i.e. newer devices (higher revision) should be supported if the EtherCAT master addresses them as an older revision. The following compatibility rule of thumb is to be assumed for Beckhoff EtherCAT Terminals/ Boxes/ EJ-modules:
device revision in the system >= device revision in the configuration
This also enables subsequent replacement of devices without changing the configuration (different specifications are possible for drives).
Example
If an EL2521-0025-1018 is specified in the configuration, an EL2521-0025-1018 or higher (-1019, -1020) can be used in practice.
Name/revision of the terminal
If current ESI descriptions are available in the TwinCAT system, the last revision offered in the selection dialog matches the Beckhoff state of production. It is recommended to use the last device revision when creating a new configuration, if current Beckhoff devices are used in the real application. Older revisions should only be used if older devices from stock are to be used in the application.
In this case the process image of the device is shown in the configuration tree and can be parameterized as follows: linking with the task, CoE/DC settings, plug-in definition, startup settings, ...
EtherCAT terminal in the TwinCAT tree (left: TwinCAT 2; right: TwinCAT 3)


ONLINE configuration creation

Commissioning [image] TwinCAT Development Environment [image] ONLINE configuration creation
ONLINE configuration creation
Detecting/scanning of the EtherCAT device
The online device search can be used if the TwinCAT system is in CONFIG mode. This can be indicated by a symbol right below in the information bar:
▪
on TwinCAT 2 by a blue display “Config Mode” within the System Manager window: .
▪
on TwinCAT 3 within the user interface of the development environment by a symbol [image].
TwinCAT can be set into this mode:
▪
TwinCAT 2: by selection of [image] in the Menubar or by “Actions” → “Set/Reset TwinCAT to Config Mode…”
▪
TwinCAT 3: by selection of [image] in the Menubar or by “TwinCAT” → “Restart TwinCAT (Config Mode)”
Online scanning in Config mode
The online search is not available in RUN mode (production operation). Note the differentiation between TwinCAT programming system and TwinCAT target system.
The TwinCAT 2 icon ( [image]) or TwinCAT 3 icon ( [image]) within the Windows-Taskbar always shows the TwinCAT mode of the local IPC. Compared to that, the System Manager window of TwinCAT 2 or the user interface of TwinCAT 3 indicates the state of the target system.
Differentiation local/target system (left: TwinCAT 2; right: TwinCAT 3)
Right-clicking on “I/O Devices” in the configuration tree opens the search dialog.
Scan Devices (left: TwinCAT 2; right: TwinCAT 3)
This scan mode attempts to find not only EtherCAT devices (or Ethernet ports that are usable as such), but also NOVRAM, fieldbus cards, SMB etc. However, not all devices can be found automatically.
Note for automatic device scan (left: TwinCAT 2; right: TwinCAT 3)
Ethernet ports with installed TwinCAT real-time driver are shown as “RT Ethernet” devices. An EtherCAT frame is sent to these ports for testing purposes. If the scan agent detects from the response that an EtherCAT slave is connected, the port is immediately shown as an “EtherCAT Device” .
Detected Ethernet devices
Via respective checkboxes devices can be selected (as illustrated in Fig. “Detected Ethernet devices” e.g. Device 3 and Device 4 were chosen). After confirmation with “OK” a device scan is suggested for all selected devices, see Fig.: “Scan query after automatic creation of an EtherCAT device”.
Selecting the Ethernet port
Ethernet ports can only be selected for EtherCAT devices for which the TwinCAT real-time driver is installed. This has to be done separately for each port. Please refer to the respective installation page.
Detecting/Scanning the EtherCAT devices
Online scan functionality
During a scan the master queries the identity information of the EtherCAT slaves from the slave EEPROM. The name and revision are used for determining the type. The respective devices are located in the stored ESI data and integrated in the configuration tree in the default state defined there.
Example default state
Note
Slave scanning in practice in series machine production
The scanning function should be used with care. It is a practical and fast tool for creating an initial configuration as a basis for commissioning. In series machine production or reproduction of the plant, however, the function should no longer be used for the creation of the configuration, but if necessary for comparison with the defined initial configuration.Background: since Beckhoff occasionally increases the revision version of the delivered products for product maintenance reasons, a configuration can be created by such a scan which (with an identical machine construction) is identical according to the device list; however, the respective device revision may differ from the initial configuration.
Example:
Company A builds the prototype of a machine B, which is to be produced in series later on. To do this the prototype is built, a scan of the IO devices is performed in TwinCAT and the initial configuration “B.tsm” is created. The EL2521-0025 EtherCAT terminal with the revision 1018 is located somewhere. It is thus built into the TwinCAT configuration in this way:
Installing EthetCAT terminal with revision -1018
Likewise, during the prototype test phase, the functions and properties of this terminal are tested by the programmers/commissioning engineers and used if necessary, i.e. addressed from the PLC “B.pro” or the NC. (the same applies correspondingly to the TwinCAT 3 solution files).
The prototype development is now completed and series production of machine B starts, for which Beckhoff continues to supply the EL2521-0025-0018. If the commissioning engineers of the series machine production department always carry out a scan, a B configuration with the identical contents results again for each machine. Likewise, A might create spare parts stores worldwide for the coming series-produced machines with EL2521-0025-1018 terminals.
After some time Beckhoff extends the EL2521-0025 by a new feature C. Therefore the FW is changed, outwardly recognizable by a higher FW version and a new revision -1019. Nevertheless the new device naturally supports functions and interfaces of the predecessor version(s); an adaptation of “B.tsm” or even “B.pro” is therefore unnecessary. The series-produced machines can continue to be built with “B.tsm” and “B.pro”; it makes sense to perform a comparative scan against the initial configuration “B.tsm” in order to check the built machine.
However, if the series machine production department now doesn’t use “B.tsm”, but instead carries out a scan to create the productive configuration, the revision -1019 is automatically detected and built into the configuration:
Detection of EtherCAT terminal with revision -1019
This is usually not noticed by the commissioning engineers. TwinCAT cannot signal anything either, since virtually a new configuration is created. According to the compatibility rule, however, this means that no EL2521-0025-1018 should be built into this machine as a spare part (even if this nevertheless works in the vast majority of cases).
In addition, it could be the case that, due to the development accompanying production in company A, the new feature C of the EL2521-0025-1019 (for example, an improved analog filter or an additional process data for the diagnosis) is discovered and used without in-house consultation. The previous stock of spare part devices are then no longer to be used for the new configuration “B2.tsm” created in this way. Þ if series machine production is established, the scan should only be performed for informative purposes for comparison with a defined initial configuration. Changes are to be made with care!
If an EtherCAT device was created in the configuration (manually or through a scan), the I/O field can be scanned for devices/slaves.
Scan query after automatic creation of an EtherCAT device (left: TwinCAT 2; right: TwinCAT 3)
Manual triggering of a device scan on a specified EtherCAT device (left: TwinCAT 2; right: TwinCAT 3)
In the System Manager (TwinCAT 2) or the User Interface (TwinCAT 3) the scan process can be monitored via the progress bar at the bottom in the status bar.
Scan progressexemplary by TwinCAT 2
The configuration is established and can then be switched to online state (OPERATIONAL).
Config/FreeRun query (left: TwinCAT 2; right: TwinCAT 3)
In Config/FreeRun mode the System Manager display alternates between blue and red, and the EtherCAT device continues to operate with the idling cycle time of 4 ms (default setting), even without active task (NC, PLC).
Displaying of “Free Run” and “Config Mode” toggling right below in the status bar
TwinCAT can also be switched to this state by using a button (left: TwinCAT 2; right: TwinCAT 3)
The EtherCAT system should then be in a functional cyclic state, as shown in Fig. Online display example.
Online display example
Please note:
▪
all slaves should be in OP state
▪
the EtherCAT master should be in “Actual State” OP
▪
“frames/sec” should match the cycle time taking into account the sent number of frames
▪
no excessive “LostFrames” or CRC errors should occur
The configuration is now complete. It can be modified as described under manual procedure.
Troubleshooting
Various effects may occur during scanning.
▪
An unknown device is detected, i.e. an EtherCAT slave for which no ESI XML description is available.
In this case the System Manager offers to read any ESI that may be stored in the device. This case is described in the chapter “Notes regarding ESI device description”.
▪
Device are not detected properly
Possible reasons include:
–
faulty data links, resulting in data loss during the scan
–
slave has invalid device description
The connections and devices should be checked in a targeted manner, e.g. via the emergency scan.
Then re-run the scan.
Faulty identification
In the System Manager such devices may be set up as EK0000 or unknown devices. Operation is not possible or meaningful.
Scan over existing Configuration
Note
Change of the configuration after comparison
With this scan (TwinCAT 2.11 or 3.1) only the device properties vendor (manufacturer), device name and revision are compared at present! A “ChangeTo” or “Copy” should only be carried out with care, taking into consideration the Beckhoff IO compatibility rule (see above). The device configuration is then replaced by the revision found; this can affect the supported process data and functions.
If a scan is initiated for an existing configuration, the actual I/O environment may match the configuration exactly or it may differ. This enables the configuration to be compared.
Identical configuration (left: TwinCAT 2; right: TwinCAT 3)
If differences are detected, they are shown in the correction dialog, so that the user can modify the configuration as required.
Correction dialog
It is advisable to tick the “Extended Information” check box to reveal differences in the revision.
Color
Explanation
green
This EtherCAT slave matches the entry on the other side. Both type and revision match.
blue
This EtherCAT slave is present on the other side, but in a different revision. This other revision can have other default values for the process data as well as other/additional functions.
If the found revision is higher than the configured revision, the slave may be used provided compatibility issues are taken into account.
If the found revision is lower than the configured revision, it is likely that the slave cannot be used. The found device may not support all functions that the master expects based on the higher revision number.
light blue
This EtherCAT slave is ignored (“Ignore” button)
red
▪
This EtherCAT slave is not present on the other side.
▪
It is present, but in a different revision, which also differs in its properties from the one specified.
The compatibility principle then also applies here: if the found revision is higher than the configured revision, use is possible provided compatibility issues are taken into account, since the successor devices should support the functions of the predecessor devices.
If the found revision is lower than the configured revision, it is likely that the slave cannot be used. The found device may not support all functions that the master expects based on the higher revision number.
Device selection based on revision, compatibility
The ESI description also defines the process image, the communication type between master and slave/device and the device functions, if applicable. The physical device (firmware, if available) has to support the communication queries/settings of the master. This is backward compatible, i.e. newer devices (higher revision) should be supported if the EtherCAT master addresses them as an older revision. The following compatibility rule of thumb is to be assumed for Beckhoff EtherCAT Terminals/ Boxes/ EJ-modules:
device revision in the system >= device revision in the configuration
This also enables subsequent replacement of devices without changing the configuration (different specifications are possible for drives).
Example
If an EL2521-0025-1018 is specified in the configuration, an EL2521-0025-1018 or higher (-1019, -1020) can be used in practice.
Name/revision of the terminal
If current ESI descriptions are available in the TwinCAT system, the last revision offered in the selection dialog matches the Beckhoff state of production. It is recommended to use the last device revision when creating a new configuration, if current Beckhoff devices are used in the real application. Older revisions should only be used if older devices from stock are to be used in the application.
In this case the process image of the device is shown in the configuration tree and can be parameterized as follows: linking with the task, CoE/DC settings, plug-in definition, startup settings, ...
Correction dialog with modifications
Once all modifications have been saved or accepted, click “OK” to transfer them to the real *.tsm configuration.
Change to Compatible Type
TwinCAT offers a function Change to Compatible Type… for the exchange of a device whilst retaining the links in the task.
Dialog “Change to Compatible Type…” (left: TwinCAT 2; right: TwinCAT 3)
This function is preferably to be used on AX5000 devices.
Change to Alternative Type
The TwinCAT System Manager offers a function for the exchange of a device: Change to Alternative Type
TwinCAT 2 Dialog Change to Alternative Type
If called, the System Manager searches in the procured device ESI (in this example: EL1202-0000) for details of compatible devices contained there. The configuration is changed and the ESI-EEPROM is overwritten at the same time – therefore this process is possible only in the online state (ConfigMode).


EtherCAT subscriber configuration

Commissioning [image] TwinCAT Development Environment [image] EtherCAT subscriber configuration
EtherCAT subscriber configuration
In the left-hand window of the TwinCAT 2 System Manager or the Solution Explorer of the TwinCAT 3 Development Environment respectively, click on the element of the terminal within the tree you wish to configure (in the example: EL3751 Terminal 3).
Branch element as terminal EL3751
In the right-hand window of the TwinCAT System Manager (TwinCAT 2) or the Development Environment (TwinCAT 3), various tabs are now available for configuring the terminal. And yet the dimension of complexity of a subscriber determines which tabs are provided. Thus as illustrated in the example above the terminal EL3751 provides many setup options and also a respective number of tabs are available. On the contrary by the terminal EL1004 for example the tabs “General”, “EtherCAT”, “Process Data” and “Online“ are available only. Several terminals, as for instance the EL6695 provide special functions by a tab with its own terminal name, so “EL6695” in this case. A specific tab “Settings” by terminals with a wide range of setup options will be provided also (e.g. EL3751).
“General” tab
“General” tab
Name | Name of the EtherCAT device
Id | Number of the EtherCAT device
Type | EtherCAT device type
Comment | Here you can add a comment (e.g. regarding the system).
Disabled | Here you can deactivate the EtherCAT device.
Create symbols | Access to this EtherCAT slave via ADS is only available if this control box is activated.
“EtherCAT” tab
“EtherCAT” tab
Type | EtherCAT device type
Product/Revision | Product and revision number of the EtherCAT device
Auto Inc Addr. | Auto increment address of the EtherCAT device. The auto increment address can be used for addressing each EtherCAT device in the communication ring through its physical position. Auto increment addressing is used during the start-up phase when the EtherCAT master allocates addresses to the EtherCAT devices. With auto increment addressing the first EtherCAT slave in the ring has the address 0000hex. For each further slave the address is decremented by 1 (FFFFhex, FFFEhex etc.).
EtherCAT Addr. | Fixed address of an EtherCAT slave. This address is allocated by the EtherCAT master during the start-up phase. Tick the control box to the left of the input field in order to modify the default value.
Previous Port | Name and port of the EtherCAT device to which this device is connected. If it is possible to connect this device with another one without changing the order of the EtherCAT devices in the communication ring, then this combination field is activated and the EtherCAT device to which this device is to be connected can be selected.
Advanced Settings | This button opens the dialogs for advanced settings.
The link at the bottom of the tab points to the product page for this EtherCAT device on the web.
“Process Data” tab
Indicates the configuration of the process data. The input and output data of the EtherCAT slave are represented as CANopen process data objects (Process Data Objects, PDOs). The user can select a PDO via PDO assignment and modify the content of the individual PDO via this dialog, if the EtherCAT slave supports this function.
“Process Data” tab
The process data (PDOs) transferred by an EtherCAT slave during each cycle are user data which the application expects to be updated cyclically or which are sent to the slave. To this end the EtherCAT master (Beckhoff TwinCAT) parameterizes each EtherCAT slave during the start-up phase to define which process data (size in bits/bytes, source location, transmission type) it wants to transfer to or from this slave. Incorrect configuration can prevent successful start-up of the slave.
For Beckhoff EtherCAT EL, ES, EM, EJ and EP slaves the following applies in general:
▪
The input/output process data supported by the device are defined by the manufacturer in the ESI/XML description. The TwinCAT EtherCAT Master uses the ESI description to configure the slave correctly.
▪
The process data can be modified in the System Manager. See the device documentation.
Examples of modifications include: mask out a channel, displaying additional cyclic information, 16-bit display instead of 8-bit data size, etc.
▪
In so-called “intelligent” EtherCAT devices the process data information is also stored in the CoE directory. Any changes in the CoE directory that lead to different PDO settings prevent successful startup of the slave. It is not advisable to deviate from the designated process data, because the device firmware (if available) is adapted to these PDO combinations.
If the device documentation allows modification of process data, proceed as follows (see Figure Configuring the process data).
▪
A: select the device to configure
▪
B: in the “Process Data” tab select Input or Output under SyncManager (C)
▪
D: the PDOs can be selected or deselected
▪
H: the new process data are visible as linkable variables in the System Manager
The new process data are active once the configuration has been activated and TwinCAT has been restarted (or the EtherCAT master has been restarted)
▪
E: if a slave supports this, Input and Output PDO can be modified simultaneously by selecting a so-called PDO record (“predefined PDO settings”).
Configuring the process data
Manual modification of the process data
According to the ESI description, a PDO can be identified as “fixed” with the flag “F” in the PDO overview (Fig. Configuring the process data, J). The configuration of such PDOs cannot be changed, even if TwinCAT offers the associated dialog (“Edit”). In particular, CoE content cannot be displayed as cyclic process data. This generally also applies in cases where a device supports download of the PDO configuration, “G”. In case of incorrect configuration the EtherCAT slave usually refuses to start and change to OP state. The System Manager displays an “invalid SM cfg” logger message: This error message (“invalid SM IN cfg” or “invalid SM OUT cfg”) also indicates the reason for the failed start.
A detailed description can be found at the end of this section.
“Startup” tab
The Startup tab is displayed if the EtherCAT slave has a mailbox and supports the CANopen over EtherCAT (CoE) or Servo drive over EtherCAT protocol. This tab indicates which download requests are sent to the mailbox during startup. It is also possible to add new mailbox requests to the list display. The download requests are sent to the slave in the same order as they are shown in the list.
“Startup” tab
Column
Description
Transition
Transition to which the request is sent. This can either be
▪
the transition from pre-operational to safe-operational (PS), or
▪
the transition from safe-operational to operational (SO).
If the transition is enclosed in “<>” (e.g. <PS>), the mailbox request is fixed and cannot be modified or deleted by the user.
Protocol
Type of mailbox protocol
Index
Index of the object
Data
Date on which this object is to be downloaded.
Comment
Description of the request to be sent to the mailbox
Move Up | This button moves the selected request up by one position in the list.
Move Down | This button moves the selected request down by one position in the list.
New | This button adds a new mailbox download request to be sent during startup.
Delete | This button deletes the selected entry.
Edit | This button edits an existing request.
“CoE - Online” tab
The additional CoE - Online tab is displayed if the EtherCAT slave supports the CANopen over EtherCAT (CoE) protocol. This dialog lists the content of the object list of the slave (SDO upload) and enables the user to modify the content of an object from this list. Details for the objects of the individual EtherCAT devices can be found in the device-specific object descriptions.
“CoE - Online” tab
Object list display
Column | Description
Index | Index and sub-index of the object
Name | Name of the object
Flags | RW | The object can be read, and data can be written to the object (read/write)
 | RO | The object can be read, but no data can be written to the object (read only)
 | P | An additional P identifies the object as a process data object.
Value | Value of the object
Update List | The Update list button updates all objects in the displayed list
Auto Update | If this check box is selected, the content of the objects is updated automatically.
Advanced | The Advanced button opens the Advanced Settings dialog. Here you can specify which objects are displayed in the list.
Dialog “Advanced settings”
Online - via SDO Information | If this option button is selected, the list of the objects included in the object list of the slave is uploaded from the slave via SDO information. The list below can be used to specify which object types are to be uploaded.
Offline - via EDS File | If this option button is selected, the list of the objects included in the object list is read from an EDS file provided by the user.
“Online” tab
“Online” tab
State Machine
Init | This button attempts to set the EtherCAT device to the Init state.
Pre-Op | This button attempts to set the EtherCAT device to the pre-operational state.
Op | This button attempts to set the EtherCAT device to the operational state.
Bootstrap | This button attempts to set the EtherCAT device to the Bootstrap state.
Safe-Op | This button attempts to set the EtherCAT device to the safe-operational state.
Clear Error | This button attempts to delete the fault display. If an EtherCAT slave fails during change of state it sets an error flag. Example: An EtherCAT slave is in PREOP state (pre-operational). The master now requests the SAFEOP state (safe-operational). If the slave fails during change of state it sets the error flag. The current state is now displayed as ERR PREOP. When the Clear Error button is pressed the error flag is cleared, and the current state is displayed as PREOP again.
Current State | Indicates the current state of the EtherCAT device.
Requested State | Indicates the state requested for the EtherCAT device.
DLL Status
Indicates the DLL status (data link layer status) of the individual ports of the EtherCAT slave. The DLL status can have four different states:
Status | Description
No Carrier / Open | No carrier signal is available at the port, but the port is open.
No Carrier / Closed | No carrier signal is available at the port, and the port is closed.
Carrier / Open | A carrier signal is available at the port, and the port is open.
Carrier / Closed | A carrier signal is available at the port, but the port is closed.
File Access over EtherCAT
Download | With this button a file can be written to the EtherCAT device.
Upload | With this button a file can be read from the EtherCAT device.
“DC” tab (Distributed Clocks)
“DC” tab (Distributed Clocks)
Operation Mode
Options (optional):
▪
FreeRun
▪
SM-Synchron
▪
DC-Synchron (Input based)
▪
DC-Synchron
Advanced Settings…
Advanced settings for readjustment of the real time determinant TwinCAT-clock
Detailed information to Distributed Clocks is specified on http://infosys.beckhoff.com:
Fieldbus Components → EtherCAT Terminals → EtherCAT System documentation → EtherCAT basics → Distributed Clocks
Additional information
•
Detailed description of Process Data tab


Detailed description of Process Data tab

Commissioning [image] TwinCAT Development Environment [image] EtherCAT subscriber configuration [image] Detailed description of Process Data tab
Detailed description of Process Data tab
Sync Manager
Lists the configuration of the Sync Manager (SM).
If the EtherCAT device has a mailbox, SM0 is used for the mailbox output (MbxOut) and SM1 for the mailbox input (MbxIn).
SM2 is used for the output process data (outputs) and SM3 (inputs) for the input process data.
If an input is selected, the corresponding PDO assignment is displayed in the PDO Assignment list below.
PDO Assignment
PDO assignment of the selected Sync Manager. All PDOs defined for this Sync Manager type are listed here:
▪
If the output Sync Manager (outputs) is selected in the Sync Manager list, all RxPDOs are displayed.
▪
If the input Sync Manager (inputs) is selected in the Sync Manager list, all TxPDOs are displayed.
The selected entries are the PDOs involved in the process data transfer. In the tree diagram of the System Manager these PDOs are displayed as variables of the EtherCAT device. The name of the variable is identical to the Name parameter of the PDO, as displayed in the PDO list. If an entry in the PDO assignment list is deactivated (not selected and greyed out), this indicates that the input is excluded from the PDO assignment. In order to be able to select a greyed out PDO, the currently selected PDO has to be deselected first.
Activation of PDO assignment
✓
If you have changed the PDO assignment, in order to activate the new PDO assignment,
1.
the EtherCAT slave has to run through the PS status transition cycle (from pre-operational to safe-operational) once (see Online tab),
2.
and the System Manager has to reload the EtherCAT slaves
( [image] button for TwinCAT 2 or [image] button for TwinCAT 3)
PDO list
List of all PDOs supported by this EtherCAT device. The content of the selected PDOs is displayed in the PDO Content list. The PDO configuration can be modified by double-clicking on an entry.
Column | Description
Index | PDO index.
Size | Size of the PDO in bytes.
Name | Name of the PDO. If this PDO is assigned to a Sync Manager, it appears as a variable of the slave with this parameter as the name.
Flags | F | Fixed content: The content of this PDO is fixed and cannot be changed by the System Manager.
 | M | Mandatory PDO. This PDO is mandatory and must therefore be assigned to a Sync Manager! Consequently, this PDO cannot be deleted from the PDO Assignment list
SM | Sync Manager to which this PDO is assigned. If this entry is empty, this PDO does not take part in the process data traffic.
SU | Sync unit to which this PDO is assigned.
PDO Content
Indicates the content of the PDO. If flag F (fixed content) of the PDO is not set the content can be modified.
Download
If the device is intelligent and has a mailbox, the configuration of the PDO and the PDO assignments can be downloaded to the device. This is an optional feature that is not supported by all EtherCAT slaves.
PDO Assignment
If this check box is selected, the PDO assignment that is configured in the PDO Assignment list is downloaded to the device on startup. The required commands to be sent to the device can be viewed in the Startup tab.
PDO Configuration
If this check box is selected, the configuration of the respective PDOs (as shown in the PDO list and the PDO Content display) is downloaded to the EtherCAT slave.


General Notes - EtherCAT Slave Application

Commissioning [image] General Notes - EtherCAT Slave Application
General Notes - EtherCAT Slave Application
This summary briefly deals with a number of aspects of EtherCAT Slave operation under TwinCAT. More detailed information on this may be found in the corresponding sections of, for instance, the EtherCAT System Documentation.
Diagnosis in real time: WorkingCounter, EtherCAT State and Status
Generally speaking an EtherCAT Slave provides a variety of diagnostic information that can be used by the controlling task.
This diagnostic information relates to differing levels of communication. It therefore has a variety of sources, and is also updated at various times.
Any application that relies on I/O data from a fieldbus being correct and up to date must make diagnostic access to the corresponding underlying layers. EtherCAT and the TwinCAT System Manager offer comprehensive diagnostic elements of this kind. Those diagnostic elements that are helpful to the controlling task for diagnosis that is accurate for the current cycle when in operation (not during commissioning) are discussed below.
Selection of the diagnostic information of an EtherCAT Slave
In general, an EtherCAT Slave offers
▪
communication diagnosis typical for a slave (diagnosis of successful participation in the exchange of process data, and correct operating mode)
This diagnosis is the same for all slaves.

as well as
▪
function diagnosis typical for a channel (device-dependent)
See the corresponding device documentation
The colors in Fig. Selection of the diagnostic information of an EtherCAT Slave also correspond to the variable colors in the System Manager, see Fig. Basic EtherCAT Slave Diagnosis in the PLC.
Colour | Meaning
yellow | Input variables from the Slave to the EtherCAT Master, updated in every cycle
red | Output variables from the Slave to the EtherCAT Master, updated in every cycle
green | Information variables for the EtherCAT Master that are updated acyclically. This means that it is possible that in any particular cycle they do not represent the latest possible status. It is therefore useful to read such variables through ADS.
Fig. Basic EtherCAT Slave Diagnosis in the PLC shows an example of an implementation of basic EtherCAT Slave Diagnosis. A Beckhoff EL3102 (2-channel analogue input terminal) is used here, as it offers both the communication diagnosis typical of a slave and the functional diagnosis that is specific to a channel. Structures are created as input variables in the PLC, each corresponding to the process image.
Basic EtherCAT Slave Diagnosis in the PLC
The following aspects are covered here:
Code
Function
Implementation
Application/evaluation
A
The EtherCAT Master's diagnostic information
updated acyclically (yellow) or provided acyclically (green).
At least the DevState is to be evaluated for the most recent cycle in the PLC.
The EtherCAT Master's diagnostic information offers many more possibilities than are treated in the EtherCAT System Documentation. A few keywords:
▪
CoE in the Master for communication with/through the Slaves
▪
Functions from TcEtherCAT.lib
▪
Perform an OnlineScan
B
In the example chosen (EL3102) the EL3102 comprises two analogue input channels that transmit a single function status for the most recent cycle.
Status
▪
the bit significations may be found in the device documentation
▪
other devices may supply more information, or none that is typical of a slave
In order for the higher-level PLC task (or corresponding control applications) to be able to rely on correct data, the function status must be evaluated there. Such information is therefore provided with the process data for the most recent cycle.
C
For every EtherCAT Slave that has cyclic process data, the Master displays, using what is known as a WorkingCounter, whether the slave is participating successfully and without error in the cyclic exchange of process data. This important, elementary information is therefore provided for the most recent cycle in the System Manager
1.
at the EtherCAT Slave, and, with identical contents
2.
as a collective variable at the EtherCAT Master (see Point A)
for linking.
WcState (Working Counter)
0: valid real-time communication in the last cycle
1: invalid real-time communication
This may possibly have effects on the process data of other Slaves that are located in the same SyncUnit
In order for the higher-level PLC task (or corresponding control applications) to be able to rely on correct data, the communication status of the EtherCAT Slave must be evaluated there. Such information is therefore provided with the process data for the most recent cycle.
D
Diagnostic information of the EtherCAT Master which, while it is represented at the slave for linking, is actually determined by the Master for the Slave concerned and represented there. This information cannot be characterized as real-time, because it
▪
is only rarely/never changed, except when the system starts up
▪
is itself determined acyclically (e.g. EtherCAT Status)
State
current Status (INIT..OP) of the Slave. The Slave must be in OP (=8) when operating normally.
AdsAddr
The ADS address is useful for communicating from the PLC/task via ADS with the EtherCAT Slave, e.g. for reading/writing to the CoE. The AMS-NetID of a slave corresponds to the AMS-NetID of the EtherCAT Master; communication with the individual Slave is possible via the port (= EtherCAT address).
Information variables for the EtherCAT Master that are updated acyclically. This means that it is possible that in any particular cycle they do not represent the latest possible status. It is therefore possible to read such variables through ADS.
Note
Diagnostic information
It is strongly recommended that the diagnostic information made available is evaluated so that the application can react accordingly.
CoE Parameter Directory
The CoE parameter directory (CanOpen-over-EtherCAT) is used to manage the set values for the slave concerned. Changes may, in some circumstances, have to be made here when commissioning a relatively complex EtherCAT Slave. It can be accessed through the TwinCAT System Manager, see Fig. EL3102, CoE directory:
EL3102, CoE directory
EtherCAT System Documentation
The comprehensive description in the EtherCAT System Documentation (EtherCAT Basics --> CoE Interface) must be observed!
A few brief extracts:
▪
Whether changes in the online directory are saved locally in the slave depends on the device. EL terminals (except the EL66xx) are able to save in this way.
▪
The user must manage the changes to the StartUp list.
Commissioning aid in the TwinCAT System Manager
Commissioning interfaces are being introduced as part of an ongoing process for EL/EP EtherCAT devices. These are available in TwinCAT System Managers from TwinCAT 2.11R2 and above. They are integrated into the System Manager through appropriately extended ESI configuration files.
Example of commissioning aid for a EL3204
This commissioning process simultaneously manages
▪
CoE Parameter Directory
▪
DC/FreeRun mode
▪
the available process data records (PDO)
Although the “Process Data”, “DC”, “Startup” and “CoE-Online” that used to be necessary for this are still displayed, it is recommended that, if the commissioning aid is used, the automatically generated settings are not changed by it.
The commissioning tool does not cover every possible application of an EL/EP device. If the available setting options are not adequate, the user can make the DC, PDO and CoE settings manually, as in the past.
EtherCAT State: automatic default behaviour of the TwinCAT System Manager and manual operation
After the operating power is switched on, an EtherCAT Slave must go through the following statuses
▪
INIT
▪
PREOP
▪
SAFEOP
▪
OP
to ensure sound operation. The EtherCAT Master directs these statuses in accordance with the initialization routines that are defined for commissioning the device by the ES/XML and user settings (Distributed Clocks (DC), PDO, CoE). See also the section on "Principles of Communication, EtherCAT State Machine" in this connection. Depending how much configuration has to be done, and on the overall communication, booting can take up to a few seconds.
The EtherCAT Master itself must go through these routines when starting, until it has reached at least the OP target state.
The target state wanted by the user, and which is brought about automatically at start-up by TwinCAT, can be set in the System Manager. As soon as TwinCAT reaches the status RUN, the TwinCAT EtherCAT Master will approach the target states.
Standard setting
The advanced settings of the EtherCAT Master are set as standard:
▪
EtherCAT Master: OP
▪
Slaves: OP
This setting applies equally to all Slaves.
Default behaviour of the System Manager
In addition, the target state of any particular Slave can be set in the “Advanced Settings” dialogue; the standard setting is again OP.
Default target state in the Slave
Manual Control
There are particular reasons why it may be appropriate to control the states from the application/task/PLC. For instance:
▪
for diagnostic reasons
▪
to induce a controlled restart of axes
▪
because a change in the times involved in starting is desirable
In that case it is appropriate in the PLC application to use the PLC function blocks from the TcEtherCAT.lib, which is available as standard, and to work through the states in a controlled manner using, for instance, FB_EcSetMasterState.
It is then useful to put the settings in the EtherCAT Master to INIT for master and slave.
PLC function blocks
Note regarding E-Bus current
EL/ES terminals are placed on the DIN rail at a coupler on the terminal strand. A Bus Coupler can supply the EL terminals added to it with the E-bus system voltage of 5 V; a coupler is thereby loadable up to 2 A as a rule. Information on how much current each EL terminal requires from the E-bus supply is available online and in the catalogue. If the added terminals require more current than the coupler can supply, then power feed terminals (e.g. EL9410) must be inserted at appropriate places in the terminal strand.
The pre-calculated theoretical maximum E-Bus current is displayed in the TwinCAT System Manager as a column value. A shortfall is marked by a negative total amount and an exclamation mark; a power feed terminal is to be placed before such a position.
Illegally exceeding the E-Bus current
From TwinCAT 2.11 and above, a warning message “E-Bus Power of Terminal...” is output in the logger window when such a configuration is activated:
Warning message for exceeding E-Bus current
Note
Caution! Malfunction possible!
The same ground potential must be used for the E-Bus supply of all EtherCAT terminals in a terminal block!


Quick start

Commissioning [image] Quick start
Quick start
Unless stated otherwise, the designation EL3356 also applies to the EL3356-00x0.
For standard commissioning of the EL3356-xxxx with a full strain gauge bridge (strain gauge, load cell, balance beam) proceed as follows:
1.
Install the EL3356 in the E-bus terminal strand on an EtherCAT coupler, e.g. EK1100 or EK1501.
2.
The EL3356 is fed with the DMS supply voltage from the left via the power contacts. Add an EL95xx power supply terminal before the EL3356 or feed in the supply voltage directly at terminal points 3/7 in the EL3356. An isolating terminal to the previous potential may then need to be inserted.
The following must be observed:
–
Output voltage: 6, 10 or 12 VDC are usual, depending on the requirements of the DMS
The EL33546 may be fed with max. 12 V rated supply voltage.
–
Load current: each strain gauge has a load current (normally 350 Ω internal resistance). This must not overload the source.
–
Supply quality: The most stable and noise-free supply possible must be ensured.
–
Apply suitable EMC safety measures (shielding, shield connection, cable laying).
3.
Connect the strain gauge in accordance with the instructions. The strain gauge is supplied with 4 or 6 connections.
In the case of 4-wire connection, bridges must be connected to terminal points 3/6 and 5/7.
In the case of 6-wire connection, terminal points 1 - 8 can be used directly.
The shield must be connected. Ensure a conductive connection to the system earth.
4.
Set up a correct EtherCAT configuration with the terminal.
Since the device is present and is electrically reachable, the simplest way of accomplishing this is by scanning the devices.
5.
Activate the EtherCAT master and start the terminal in OP state.
In the input variables the EL3356 must deliver State=8 and WC=0.
6.
Parameterize the used DMS in the CoE settings of the EL3356 according to the DMS data sheet.
–
Reverse any previous parameter changes by means of a CoE reset: enter 0x64616F6C in object 0x1011:01
–
Nominal characteristic value in object 0x8000:23 according to the test protocol of the strain gauge manufacturer, e.g. 2.01 mV/V
–
Nominal offset in object 0x8000:25 according to the test protocol of the strain gauge manufacturer, e.g. -0.0154 mV/V
–
Nominal load of the strain gauge in object 0x8000:24 according to the test protocol of the strain gauge manufacturer, 5 kg
Note: the firmware calculates internally without units, the unit used here in "NominalLoad" (as in x8000:28 ReferenceLoad) determines the further calculation
–
Change the scaling factor; default output is in [1 Kg] - enter the factor 1000 here to display in [g]
7.
EL3356-0010 /-0090: During operation, the terminal can be configured for two dynamic ranges and can be switched quickly during runtime via ControlWord: mode 0 HighPrecision or mode 1 HighSpeed (see chapter Conversion mode). The averager and filter can be preset separately for both modes.
8.
The current load can now be read from the process data
What if...
▪
calculation is to take place in other units of weight, e.g. in English pounds (lb)?
-> Then the nominal load is also specified in lb and implicitly brings along the new unit
Note: 1 pound = 0.453592370 kg by definition
▪
acceleration due to gravity at the place of installation is not equal to the average of 9.80665 m/s²?
-> in this case the normal local gravity can be entered via the object 0x8000:26. See note.
▪
the EL3356-0010, EL3356-0090 is to be used in Distributed Clocks mode?
-> then DC and the process data Timestamp must be activated. See note.
▪
the EL3356-0090 is to be used in a safety application?
-> Then it has to be considered that the measurement readings are frozen during automatic adjustment / self-calibration and
->when activating the TwinSAFE SC slot, the measured value has to be selected as INT32.
Note the hints in chapter TwinSAFE SC process data EL3356-0090.
▪
dynamic weighing is demanded, i.e. high measuring accuracy is to be achieved despite rapidly varying loads? This can be the case, for example, when filling sacks or during the mechanical fastening of a bulk material receptacle.
-> in this case the EL3356 offers three concepts: dynamic filter adaptation DynamicIIR, mode change and input freeze
▪
the self-calibration carried out every 3 minutes in the standard setting is not desired?
-> in this case the repeat time is to be changed in the CoE or the calibration procedure itself is to be controlled via the control word.


Basic function principles

Commissioning [image] Basic function principles
Basic function principles
EL3356 and special versions
Unless stated otherwise, the designation “EL3356” always refers also to special versions such as the EL3356-0010.
The measuring functions of the EL3356 can be described as follows:
▪
The EL3356 Analog Input Terminal is used to acquire the supply voltage to a load cell as a reference voltage, and the differential voltage that is proportional to the force acting on the cell.
▪
A full bridge must be connected. If only a quarter or half bridge is available, external auxiliary bridges should be added. In this case, the nominal characteristic value should be modified accordingly.
▪
The reference and differential voltages are measured simultaneously.
▪
Since the two voltages are measured at the same time, there is basically no need for a high-precision reference voltage with respect to the level.
On changing the reference voltage, the differential voltage across the full bridge changes by the same degree. Therefore a stabilized reference voltage should be used that is subject to only low fluctuations (e.g. the EL95xx supply terminal).
▪
The change of the quotient of the differential and reference voltages corresponds to the relative force acting on the load cell.
▪
The quotient is converted into a weight and is output as process data.
▪
The data processing is subject to the following filtering procedures:
–
the analog convertor (ADC) integrates over 76 samples
–
calculation of mean values in the averager (if activated)
–
software filter IIR/FIR (if activated)
▪
The EL3356 has an automatic compensation/self-calibration function.
–
Default state: self-calibration activated, execution every 3 minutes
–
errors in the analog input stages (temperature drift, long-term drift etc.) are checked by regular automatic calibration, and compensated to bring the measurement within the permitted tolerance range.
–
the automatic function can be deactivated or activated in a controlled manner
▪
The EL3356 can also be used as a 2-channel analog input terminal for voltage measurement.
Please note: the PDO Ctrl (CoE 0x7000:0) has no function in this case.
▪
The EL3356-0010 and EL3356-0090 have a timestamp function that can be activated through Distributed Clocks
In DC mode the filter functions are inactive.
Additional information
•
General notes
•
Block diagram
•
Averager
•
Software filter
•
Dynamic filter
•
Calculating the weight
•
Conversion mode


General notes

Commissioning [image] Basic function principles [image] General notes
General notes
▪
The measuring ranges of both channels (supply voltage and bridge voltage) should always be used as widely as possible in order to achieve a high measuring accuracy.
We recommended a supply voltage of 12 V in connection with a load cell that has such a sensitivity (e.g. 2 mV/V) that the largest possible bridge voltage - ideally ±25 mV - is generated.
Note the input voltages (see Technical data).
Max. input voltages
▪
Parallel operation of load cells is possible with the EL3356. Please note:
–
the EL3356 does not provide a supply! Hence, the power supply employed must be sufficiently large, since the total bridge resistance of all strain gauges connected together is considerably reduced due to the parallel connection.
–
Load cells approved and calibrated by the load cell manufacturer for parallel operation should be used. The nominal characteristic values [mV/V], zero offset [mV/V] and impedance [Ω, ohm] are then usually adjusted accordingly.
–
a 6-wire connection is expressly recommended
Parallel connection with EL3356
–
Load cell signals have a low amplitude and are occasionally very sensitive to electromagnetic interference. Considering the typical system characteristics and taking into account the technical possibilities, purposeful state-of-the-art EMC protective measures are to be taken. The shield of the sensor cable can be connected to the EL3356 at the terminal points 4/8. In the case of high electromagnetic interference levels, it may be helpful to additionally connect the cable screen before the terminal using suitable screening material.
–
The minimum permissible assigned EtherCAT cycle time for the EL3356 is 100 µs.
–
If the EL3356-0010 and EL3356-0090 are to be used in Distributed Clocks mode
- DC must be activated
- the timestamp process record must be activated.
In this case, the filter functions are inactive.


Block diagram

Commissioning [image] Basic function principles [image] Block diagram
Block diagram
Block diagram of EL3356-0010
The EL3356 processes the data in the following order
1.
Hardware low-pass 10 KHz
2.
2-channel simultaneous sampling at 10.5/105.5 kSps with 64-fold oversampling by delta-sigma (ΔΣ) converter and internal prefiltration
3.
4-fold averager (can be deactivated)
4.
Software filter (can be deactivated)
5.
Calculating the weight
Measurement principle of delta-sigma (ΔΣ) converter
The measurement principle employed in the EL3356, with real sampling in the MHz range, shifts aliasing effects into a very high frequency range, so that normally no such effects are to be expected in the kHz range.


Averager

Commissioning [image] Basic function principles [image] Averager
Averager
In order to make use of the high data rates of the Analog-to-Digital converter (ADC) even with slow cycle times, a mean value filter is connected after the ADC. This determines the sliding mean value of the last four measured values. This function can be deactivated for each mode via the CoE object “Mode X enable averager”.


Software filter

Commissioning [image] Basic function principles [image] Software filter
Software filter
The EL3356 is equipped with a digital software filter which, depending on its settings, can adopt the characteristics of a Finite Impulse Response filter (FIR filter), or an Infinite Impulse Response filter (IIR filter). The filter is activated by default as 50Hz-FIR.
In the respective measuring mode the filter can be activated (0x8000:01, 0x8000:02) and parameterized (0x8000:11, 0x8000:12) (the EL3356-0000 supports only mode 0).
▪
FIR 50/60 Hz
The filter performs a notch filter function and determines the conversion time of the terminal. The higher the filter frequency, the faster the conversion time. A 50 Hz and a 60 Hz filter are available.
Notch filter means that the filter has zeros (notches) in the frequency response at the filter frequency and multiples thereof, i.e. it attenuates the amplitude at these frequencies. The FIR filter operates as a non-recursive filter.
▪
PDO filter (valid as from firmware 05)
The filter behaves like the 50/60 Hz FIR filter described above. However, the filter frequency can be adjusted here in 0.1 Hz steps by means of an output data object. The filter frequency range extends from 0.1 Hz to 200 Hz and can be reparametrized during operation.
To do this the PDO 0x1601 (“RMB filter frequency”) must be displayed in the process data and the entry “PDO filter frequency” must be selected in the object 0x8000:11.
This function allows the EL3356 to suppress interference of a known frequency in the measuring signal. A typical application, for example, is a silo that is filled and weighed by a driven screw conveyor. The rotary speed of the screw conveyor is known and can be adopted into the object as a frequency. Thus mechanical oscillations can be removed from the measuring signal.
Notch characteristic/amplitude curve and step response of the FIR filter
▪
IIR-Filter 1 to 8
The filter with IIR characteristics is a discrete time, linear, time invariant filter that can be set to eight levels (level 1 = weak recursive filter, up to level 8 = strong recursive filter).
The IIR can be understood to be a moving average value calculation after a low-pass filter.
Step response and Bode diagram of the IIR filter
Overview of conversion times
Filter Settings | Value | PDO update time |  | Filter property | Limit frequency (-3 dB) [Hz] (typ.) | Comment | Rise time 10-90% [s] (typ.)
 |  | EL3356 | EL3356-0010 EL3356-0090
Filter deactivated | - | min. 10 ms | Cycle-synchronous, EL3356-0010 min. 100 µs EL3356-0090 min. 150 µs | - | - | - | -
0 | FIR 50 Hz | min. 10 ms | 312.5 µs | 50 Hz notch filter | 22 Hz | Typ. conversion time 312.5 µs | 0.013
1 | FIR 60 Hz | min. 10 ms | 260.4 µs | 60 Hz notch filter | 25 Hz | Typ. conversion time 260.4 µs | 0.016
2 | IIR1 | Cycle-synchronous (up to min. 10 ms update | Cycle-synchronous (EL3356-0010: up to min. 100 µs) (EL3356-0090: up to min. 150 µs) | Low-pass | 2000 Hz | a0 = 1/21 = 0.5 | 0.0003
3 | IIR2 |  |  | Low-pass | 500 Hz | a0 = 1/22 = 0.25 | 0.0008
4 | IIR3 |  |  | Low-pass | 125 Hz | a0 = 1/24 = 62.5e-3 | 0.0035
5 | IIR4 |  |  | Low-pass | 30 Hz | a0 = 1/26 = 15.6e-3 | 0.014
6 | IIR5 |  |  | Low-pass | 8 Hz | a0 = 1/28 = 3.91e-3 | 0.056
7 | IIR6 |  |  | Low-pass | 2 Hz | a0 = 1/210 = 977e-6 | 0.225
8 | IIR7 |  |  | Low-pass | 0.5 Hz | a0 = 1/212 = 244e-6 | 0.9
9 | IIR8 |  |  | Low-pass | 0.1 Hz | a0 = 1/214 = 61.0e-6 | 3.6
10 | Dynamic IIR |  |  | The filter changes dynamically between the filters IIR1 to IIR8
11 | PDO Filter frequency | min. 10 ms |  | Notch filter with adjustable frequency | approx. 0.443 * PDO value [Hz] | - | -
Filter and cycle time
If the FIR filters (50 Hz or 60 Hz) are switched on, the process data are updated maximally with the specified conversion time. (see table) The IIR filter works cycle-synchronously. Hence, a new measured value is available in each PLC cycle.
IIR filter
Differential equation: Yn = Xn * a0 + Yn-1 * b1
with a0 + b1 = 1
a0 = (see table)
b1 = 1 - a0


Dynamic filter

Commissioning [image] Basic function principles [image] Dynamic filter
Dynamic filter
The dynamic IIR filter automatically switches through the 8 different IIR filters depending on the weight change. The idea:
▪
The target state is always the IIR8-Filter, i.e. the greatest possible damping and hence a very calm measured value.
▪
In the input variable changes rapidly the filter is opened, i.e. switched to the next lower filter (if still possible). This gives the signal edge more weight and the measured value curve can follow the load quickly.
▪
If the measured value changes very little the filter is closed, i.e. switched to the next higher filter (if still possible). Hence the static state is mapped with a high accuracy.
▪
The evaluation as to whether a downward change of filter is required or whether an upward change is possible takes place continuously at fixed time intervals.
Parameterization takes place via the CoE entries 0x8000:13 and 0x8000:14. Evaluation takes place according to two parameters:
▪
The “Dynamic filter change time” object (0x8000:13) is used to set the time interval at which the existing signal is re-evaluated.
▪
Object 0x8000:14 is used to specify the maximum deviation that is permissible during this time without filter switching occurring.
Example:
The dynamic filter is to be adjusted in such a manner that a maximum slope of 0.5 digits per 100 ms (5 digits per second) is possible without the filter being opened. This results in a “calm” measured value. In the case of a faster change, however, it should be possible to immediately follow the load.
▪
Dynamic filter change time (0x8000:13) = 10 (equivalent to 100 ms)
▪
Dynamic filter delta (0x8000:14) = 0.5 (related to the calculated load value)
The measured value curve is shown below for a slower (left) and faster (right) change.
Effect of dynamic IIR filters
▪
Links: The scales are slowly loaded. The change in the weight (delta/time) remains below the mark of 0.5 digits per 100 ms. The filter therefore remains unchanged at the strongest level (IIR8), resulting in a low-fluctuation measured value.
▪
Right: The scales are suddenly loaded. The change in the weight immediately exceeds the limit value of 0.5 digits per 100 ms. The filter is opened every 100 ms by one level (IIR8 --> IIR7 --> IIR6 etc.) and the display value immediately follows the jump. After the removal of the weight the signal quickly falls again. If the change in the weight is less than 0.5 digit per 100 ms, the filter is set one level stronger every 100 ms until IIR8 is reached. The green line is intended to clarify the decreasing “noise level”


Calculating the weight

Commissioning [image] Basic function principles [image] Calculating the weight
Calculating the weight
Each measurement of the analog inputs is followed by the calculation of the resulting weight or the resulting force, which is made up of the ratio of the measuring signal to the reference signal and of several calibrations.
YR = (UDiff / URef) x Ai | (1.0) | Calculation of the raw value in mV/V
YL = ( (YR - CZB) / (Cn - CZB) ) * Emax | (1.1) | Calculation of the weight
YS = YL * AS | (1.2) | Scaling factor (e.g. factor 1000 for rescaling from kg to g)
YG = YS * (G / 9.80665) | (1.3) | Influence of acceleration of gravity
YAUS = YG x Gain - Tare | (1.4) | Gain and Tare
Name | Description | CoE Index
UDiff | Bridge voltage/differential voltage of the sensor element, after averager and filter |
URef | Bridge supply voltage/reference signal of the sensor element, after averager and filter |
Ai | Internal gain, not changeable. This factor accounts for the unit standardization from mV to V and the different full-scale deflections of the input channels |
Cn | Nominal characteristic value of the sensor element (unit mV/V, e.g. nominally 2 mV/V or 2.0234 mV/V according to calibration protocol) | 0x8000:23
CZB | Zero balance of the sensor element (unit mV/V, e.g. -0.0142 according to calibration protocol) | 0x8000:25
Emax | Nominal load of the sensor element The firmware always calculates without units, the unit (kg, g, lb) used here is then also applicable to the result | 0x8000:24
AS | Scaling factor (e.g. factor 1000 for rescaling from kg to g) | 0x8000:27
G | Acceleration of gravity in m/s^2 (default: 9.80665 ms/s^2) | 0x8000:26
Gain |  | 0x8000:21
Tare |  | 0x8000:22


Conversion mode

Commissioning [image] Basic function principles [image] Conversion mode
Conversion mode
The so-called conversion mode determines the speed and latency of the analog measurement in the EL3356. The characteristics:
Mode | Meaning | typ. latency | EL3356 | EL3356-0010, EL3356-0090 | typ. current consumption
0 | High precision Analog conversion at 10.5 kSps (samples per second) Slow conversion and thus high accuracy | 7.2 ms | x | x | 70% (see Technical data regarding nominal value)
1 | High speed / low latency Analog conversion at 105.5 kSps (samples per second) Fast conversion with low latency | 0.72 ms | - | x | 100% (see Technical data regarding nominal value)
Due to the conversion principle of the EL3356, the analog voltage is only available as a digital value after a defined time. This is shown in Fig. Latency of the analog/digital converter.
A step signal 0->1 is applied to the input. The measured value is reached and readable within the defined accuracy after 7.2 or 0.72 ms, depending on the conversion mode 0/1. At this time the timestamp is also acquired in Distributed Clocks mode. In real operation a step signal is not normally connected, but rather a higher frequency but constant signal. The EL3356 then maps the input signal with the corresponding latency for further processing, for which reason faster querying of the sampling unit at shorter intervals than the latency (EL3356-0010 allows up to 100 µs and EL3356-0090 allows up to 150 µs) makes sense for true-to-detail mapping of the analog input signal.
Latency of the Analog-to-Digital converter
It is not possible to change the specified latency.
Beyond that the following are individually adjustable in each mode via CoE
▪
activation of the averager
▪
activation of the filter
▪
type of filter
Setting parameters in CoE belonging to the individual modes
The EL3356 has only mode 0, the El3356-0010 and the EL3356-0090 have modes 0 & 1.
Mode change (EL3356-0010, EL3356-0090 only)
In particular for dynamic weighing procedures it may make sense to considerably change the measuring characteristic during the weighing procedure. For example, if a bulk material is filled by the sack within 5 seconds, a very open filter should initially be used so that the measured value quickly follows the fill level. During this phase it is of no importance that the measured value is very inaccurate and subject to high fluctuations. If the sack is >90% full, filling must be slowed down and the loading must be followed with higher accuracy; the filter must be closed. Therefore the two conversion modes can be switched via the process data bit “Sample mode“ in the EL3356-0010 and EL3356-0090 in relation to the processing of the analog values.
The mode change takes about 30 ms, during which time the measured values are invalid and indicate this by the status byte.
“Sample mode” switching


Application notes

Commissioning [image] Application notes
Application notes
Additional information
•
Symmetric reference potential
•
Wiring fail indication
•
InputFreeze
•
Gravity adaptation
•
Idling recognition
•
Official calibration capability


Symmetric reference potential

Commissioning [image] Application notes [image] Symmetric reference potential
Symmetric reference potential
The EL3356 measures the two voltages Usupply und Ubridge independently of each other and without electrical reference to a supply voltage. The measuring accuracy can be increased further, if an internal coupling is employed to prevent the internal measuring circuits from drifting apart. To this end the EL3356 has an internal switch that is closed in the default state and establishes a potential reference between the internal electronics and the bridge point.
Internal switch for increasing the measuring accuracy
If several strain gauges are supplied by the same power supply and equalizing currents flow that falsify the measurement, the switch can be opened via CoE 0x8000:05. Alternatively, electrically isolated strain gauge supplies are to be installed.


Wiring fail indication

Commissioning [image] Application notes [image] Wiring fail indication
Wiring fail indication
The EL3356 has no express open-circuit recognition facility. If one of the bridge wires is broken, however, the voltage measured there generally moves towards the final value, thus displaying an error in the status word. Over/underrange of the supply voltage is likewise indicated.


InputFreeze

Commissioning [image] Application notes [image] InputFreeze
InputFreeze
If the terminal is placed in the freeze state by InputFreeze in the control word, no further analog measured values are relayed to the internal filter. This function is usable, for example, if a filling surge is expected from the application that would unnecessarily overdrive the filters due to the force load. This would result in a certain amount of time elapsing until the filter had settled again. The user himself must determine a sensible InputFreeze time for his filling procedure.
For clarification: temporal control of the InputFreeze and the decision regarding its use must be realized by the user in the PLC, they are not components of the EL3356.
In the following example (recorded with Scope2) impulses on a 15 kg load cell are recorded; the filter is wide open at IIR1 so that steep edges occur in the signal.
InputFreeze example
Explanation: The weight (A) is shown in blue; the state of the InputFreeze variable, which can be controlled by the PLC program and can be TRUE/FALSE, is shown in red (B). The first two impulses (C) lead to large peak deflections in the signal. After that the following is activated in the PLC program (see example program):
▪
if the measured value for the last cycle (cycle time 100 µs) has changed by more than 10 g (indicating a sudden load),
▪
bInputFreeze is set to TRUE for 50 ms by a TOF block on the EL3356
The effect can be seen in (D): The peak load is no longer acknowledged by the EL3356. If it is optimally adapted to the expected force impulse, the EL3356 can measure the current load value without overshoot.


Gravity adaptation

Commissioning [image] Application notes [image] Gravity adaptation
Gravity adaptation
The calculation of the weight depends on the gravitation/the Earth's gravitational force/acceleration due to gravity at the place of installation of the scales. In general, acceleration due to the gravitational pull of the earth at the place of installation is not equal to the defined standard value of g = 9.80665 m/s². For example, 4 zones of acceleration due to gravity are defined in Germany, in which a local acceleration due to gravity of 9.807 to 9.813 m/s² is to be assumed. Hence, within Germany alone there is a clear dispersion of the order of parts per thousand for acceleration due to gravity, which has a direct effect on the measured weight in accordance with the equation FG = m*g!
If
▪
load cells are used in the theoretical calibration with characteristic values according to the sensor certificate
▪
calibration weights are used whose weight at the place of installation of the scales is by nature different to that at the place of origin
▪
scales of the accuracy class I to III are to be realized
▪
scales that are generally independent of acceleration due to gravity are to be realized
then one should check whether the gravity correction needs to be adapted via object 0x8000:26.


Idling recognition

Commissioning [image] Application notes [image] Idling recognition
Idling recognition
Weighing is a dynamic procedure that can lead to large jumps in the bridge voltage and thus to the calculation of the value. Following a change in load, the measured value must first “settle” so that the process value is evaluable in the controller. The evaluation of the measured value and the decision over the degree of calmness can be done in the controller; however, the EL3356 also offers this function, which is activated by default. The result is output in the status word.
▪
If the load value remains within a range of values y for longer than time x, then the SteadyState is activated in the StatusWord.
▪
SteadyState is set to FALSE as soon as this condition no longer applies.
▪
The parameters x and y can be specified in the CoE
▪
The evaluation is naturally considerably affected by the filter setting
In the following example (recorded with TwinCAT Scope2), a 15 kg load cell is suddenly unloaded and loaded with 547 g. SteadyState is subject to a window time from 100 ms and a tolerance of 8 g (15 kg nominal value, scaling 1000; see CoE).
Idling recognition example


Official calibration capability

Commissioning [image] Application notes [image] Official calibration capability
Official calibration capability
“Official calibration” is a special kind of calibration that is accomplished according to special regulations with the involvement of trained personnel using prescribed aids. The use of “officially calibrated” scales is mandatory in the Central European region, in particular for the filling of foodstuffs. This ensures the correctness of the weighed quantities in a particular way.
The Beckhoff EL/KL335x terminals cannot be officially calibrated as individual devices. However, they can be integrated as elements in applications that can then be equipped by the integrator with the required characteristics for official calibration capability using appropriate means.


Calibration and compensation

Commissioning [image] Calibration and compensation
Calibration and compensation
The term “calibration” can be applied in three different ways to the EL3356:
▪
Sensor calibration: once-only calibration of the employed sensor (strain gauge) during commissioning of the system
▪
Self-calibration: continuously repeated self-calibration of the terminal for the improvement of the measuring accuracy
▪
Tare: repeated gross/net compensation by taring
EL3356 and special versions
Unless stated otherwise, the designation “EL3356” always refers also to special versions such as the EL3356-0010.
Additional information
•
Sensor calibration
•
Self-calibration
•
Taring
•
Overview of commands


Sensor calibration

Commissioning [image] Calibration and compensation [image] Sensor calibration
Sensor calibration
The EL3356 is matched to the characteristic curve of the sensor element by means of the calibration. Two values are required for this procedure: the initial value without a load (“zero balance”) and fully loaded (“rated output”). These values can be determined by a calibration protocol or by a calibration using calibration weights.
Adaptation to the sensor curve
Calibration by means of compensation in the system
In the “practical” calibration, measurement takes place first with the scales unloaded, then with a defined load on the scales. The EL3356 automatically calculates the existing sensor characteristic values from the measured values.
Sequence:
1.
Perform a CoE reset with object 0x1011:01
see Restoring the delivery state
2.
Activate mode 0 via the control word (EL3356-0010 only)
3.
Set scale factor to 1 (0x8000:27)
4.
Set gravity of earth (0x8000:26) if necessary (default: 9.806650)
5.
Set gain to (0x8000:21) = 1
6.
Set tare to 0 (0x8000:22)
7.
Set the filter (0x8000:11) to the strongest level: IIR8
8.
Specify the nominal load of the sensor in 0x8000:24 (“Nominal load”)
9.
Zero balance: Do not load the scales
As soon as the measured value indicates a constant value for at least 10 seconds, execute the command “0x0101” (257dec) on CoE object 0xFB00:01.
This command causes the current mV/V value (0x9000:11) to be entered in the “Zero balance” object.
Check: CoE objects 0xFB00:02 and 0xFB00:03 must contain “0” after execution.
Zero calibration with command 0x0101 in CoE object 0xFB00:01
10.
Load the scales with a reference load. This should be at least 20% of the rated load. The larger the reference load, the better the sensor values can be calculated.
In object 0x8000:28 (“Reference load”), enter the load in the same unit as the rated load (0x8000:24).
As soon as the measured value indicates a constant value for at least 10 seconds, execute the command “0x0102” (258dec) on CoE object 0xFB00:01.
By means of this command the EL3356 determines the output value for the nominal weight (“Rated output”)
Check: CoE objects 0xFB00:02 and 0xFB00:03 must contain “0” after execution.
Loading with reference load, command 0x0102 in CoE object 0xFB00:01
11.
Reset: execute the command “0x0000” (0dec) on CoE object 0xFB00:01.
12.
Set the filter to a lower stage.
Calibration according to the sensor calibration protocol (theoretical calibration)
The sensor characteristic values according to the manufacturer's certificate are communicated here directly to the EL3356, so that it can calculate the load.
1.
Execute a CoE reset
2.
Set scale factor to 1 (0x8000:27)
3.
Set gravity of earth (0x8000:26) if necessary (default: 9.806650)
4.
Set gain to (0x8000:21) = 1
5.
Set tare to 0 (0x8000:22)
6.
Specify the nominal load of the sensor in 0x8000:24 (“Nominal load”)
7.
Adopt the “Rated output” (mV/V value 0x8000:23) from the calibration protocol
8.
Adopt the “Zero balance” (0x8000:25) from the calibration protocol
Calibration
The calibration is of great importance for the accuracy of the system. In order to increase this, the filter should be set as strong as possible over the entire calibration phase. It may take several seconds before a static value is obtained.
Local storage
The values modified during the theoretical and practical calibration are stored in a local EEPROM. This can be written to up to 1 million time. In order to prolong the life of the EEPROM, therefore, the commands should not be executed cyclically.


Self-calibration

Commissioning [image] Calibration and compensation [image] Self-calibration
Self-calibration
Self-calibration of the measuring amplifiers
The measuring amplifiers are periodically subjected to examination and self-calibration. Several analog switches are provided for this purpose, so that the various calibration signals can be connected. It is important for this process that the entire signal path, including all passive components, is examined at every phase of the calibration. Only the interference suppression elements (L/C combination) and the analog switches themselves cannot be examined. In addition, a self-test is carried out at longer intervals.
The self-calibration is carried out every three minutes in the default setting.
▪
Self-calibration
The time interval is set in 100 ms steps with object 0x8000:31; default: 3 min.
Duration approx. 150 ms
▪
Self-test
is additional carried out together with every nth self-calibration.
The multiple (n) is set with object 0x8000:32; default: 10
additional duration approx. 70 ms.
By means of the self-calibration of the input stages at the two operating points (zero point and final value), the two measuring channels are calibrated to each other.
Interface for controller
The self-calibration takes place automatically at the defined intervals. In order to prevent calibration during a time-critical measurement, the automatic calibration can be disabled permanently via the “Disable calibration” bit in ControlWord. If it should be additional necessary to carry out a manual test, this is started by a rising edge of the “Start manual calibration“ bit in the process image.
While the terminal is performing a self-calibration or a self-test, the “Calibration in progress“ bit is set in the process image. Once started, a self-calibration/self-test cannot be aborted.
If the self-calibration has been disabled by “Disable calibration”, it can nevertheless be started by the “Start calibration” process data bit.
Self-calibration
The self-calibration takes place for the first time directly after starting up the terminal. At this point the external reference voltage must already be applied. If the reference voltage is only applied later, the self-calibration must be manually initiated (process data bit: “Start calibration”).
The self-calibration must be executed at least once after each start-up.
The supply voltage must be applied during the self-calibration, since otherwise the necessary reference voltages cannot be generated.
A lower measuring accuracy is to be expected if the self-calibration is disabled for a longer period or permanently.
After a change in the CoE settings (section 0x80nn), a self-calibration is always performed (even if “DisabledCalibration“ = TRUE), since the settings affect the measurement. Changing the CoE settings during an ongoing measurement should therefore be avoided, if possible.


Taring

Commissioning [image] Calibration and compensation [image] Taring
Taring
When taring, the scales are set to zero using an arbitrary applied load; i.e. an offset correction is performed. This is necessary for the gross/net compensation of goods that cannot be weighed without a container that has a mass of its own.
The EL3356 supports two tarings; it is recommended to set a strong filter when taring.
▪
Temporary tare
The correction value is NOT stored in the terminal and is lost in the event of a power failure.
To this end the command “0x0001” is executed on CoE object 0xFB00:01 (binary dialog in the System Manager: “01 00”). This sets the tare object (0x8000:22) such that the display value is 0.
Note: in the case of a device restart (INIT->OP) the tare is not deleted.
In addition this tare can be executed via the control word:
Control word, tare
▪
Permanent tare
The correction value is stored locally in the terminal's EEPROM and is not lost in the event of a power failure.
To this end the command “0x0002” is executed on CoE object 0xFB00:01 (binary dialog in the System Manager: “02 00”). This sets the tare object (0x8000:22) such that the display value is 0.
Local storage
The values modified during the theoretical and practical calibration are stored in a local EEPROM. This can be written to up to 1 million time. In order to prolong the life of the EEPROM, therefore, the commands should not be executed cyclically.


Overview of commands

Commissioning [image] Calibration and compensation [image] Overview of commands
Overview of commands
The functions discussed above are carried out by means of commands in the standardized object 0xFB00.
Index | Name | Comment
FB00:01 | Request | Entry of the command to be executed
FB00:02 | Status | Status of the command currently being executed 0: Command executed without error. 255: Command is being executed
FB00:03 | Response | Optional response value of the command
The function blocks FB_EcCoESdoWrite and FB_EcCoESdoRead from the TcEtherCAT.lib (contained in the standard TwinCAT installation) can be used in order to execute the commands from the PLC.
Commands of the EL3356
The following commands can be transferred to the terminal via the CoE entry 0xFB00:01.
Command | Comment
0x0101 | Execute zero balance
0x0102 | Execute calibration
0x0001 | Execute tare procedure (value is NOT saved in the terminal's EEprom)
0x0002 | Execute tare procedure (value is saved in the terminal's EEprom)


Notices on analog specifications

Commissioning [image] Notices on analog specifications
Notices on analog specifications
Beckhoff I/O devices (terminals, boxes, modules) with analog inputs are characterized by a number of technical characteristic data; refer to the technical data in the respective documents.
Some explanations are given below for the correct interpretation of these characteristic data.
Additional information
•
Full scale value (FSV)
•
Measuring error/ measurement deviation
•
Temperature coefficient tK [ppm/K]
•
Single-ended/differential typification
•
Common-mode voltage and reference ground (based on differential inputs)
•
Dielectric strength
•
Temporal aspects of analog/digital conversion


Full scale value (FSV)

Commissioning [image] Notices on analog specifications [image] Full scale value (FSV)
Full scale value (FSV)
An I/O device with an analog input measures over a nominal measuring range that is limited by an upper and a lower limit (initial value and end value); these can usually be taken from the device designation.
The range between the two limits is called the measuring span and corresponds to the equation (end value - initial value). Analogous to pointing devices this is the measuring scale (see IEC 61131) or also the dynamic range.
For analog I/O devices from Beckhoff the rule is that the limit with the largest value is chosen as the full scale value of the respective product (also called the reference value) and is given a positive sign. This applies to both symmetrical and asymmetrical measuring spans.
Full scale value, measuring span
For the above examples this means:
▪
Measuring range 0...10 V: asymmetric unipolar, full scale value = 10 V, measuring span = 10 V
▪
Measuring range 4...20 mA: asymmetric unipolar, full scale value = 20 mA, measuring span = 16 mA
▪
Measuring range -200...1370°C: asymmetric bipolar, full scale value = 1370°C, measuring span = 1570°C
▪
Measuring range -10...+10 V: symmetric bipolar, full scale value = 10 V, measuring span = 20 V
This applies to analog output terminals/ boxes (and related Beckhoff product groups).


Measuring error/ measurement deviation

Commissioning [image] Notices on analog specifications [image] Measuring error/ measurement deviation
Measuring error/ measurement deviation
The relative measuring error (% of the full scale value) is referenced to the full scale value and is calculated as the quotient of the largest numerical deviation from the true value (‘measuring error’) referenced to the full scale value.
The measuring error is generally valid for the entire permitted operating temperature range, also called the ‘usage error limit’ and contains random and systematic portions of the referred device (i.e. ‘all’ influences such as temperature, inherent noise, aging, etc.).
It is always to be regarded as a positive/negative span with ±, even if it is specified without ± in some cases.
The maximum deviation can also be specified directly.
Example: Measuring range 0...10 V and measuring error < ± 0.3 % full scale value → maximum deviation ± 30 mV in the permissible operating temperature range.
Lower measuring error
Since this specification also includes the temperature drift, a significantly lower measuring error can usually be assumed in case of a constant ambient temperature of the device and thermal stabilization after a user calibration.
This applies to analog output devices.


Temperature coefficient tK [ppm/K]

Commissioning [image] Notices on analog specifications [image] Temperature coefficient tK [ppm/K]
Temperature coefficient tK [ppm/K]
An electronic circuit is usually temperature dependent to a greater or lesser degree. In analog measurement technology this means that when a measured value is determined by means of an electronic circuit, its deviation from the “true” value is reproducibly dependent on the ambient/operating temperature.
A manufacturer can alleviate this by using components of a higher quality or by software means.
The temperature coefficient, when indicated, specified by Beckhoff allows the user to calculate the expected measuring error outside the basic accuracy at 23 °C.
Due to the extensive uncertainty considerations that are incorporated in the determination of the basic accuracy (at 23 °C), Beckhoff recommends a quadratic summation.
Example: Let the basic accuracy at 23 °C be ±0.01% typ. (full scale value), tK = 20 ppm/K typ.; the accuracy A35 at 35 °C is wanted, hence ΔT = 12 K
General information about the measuring error_formula_en.png
Remarks:
ppm ≙ 10-6
% ≙ 10-2


Single-ended/differential typification

Commissioning [image] Notices on analog specifications [image] Single-ended/differential typification
Single-ended/differential typification
For analog inputs Beckhoff makes a basic distinction between two types: single-ended (SE) and differential (DIFF), referring to the difference in electrical connection with regard to the potential difference.
The diagram shows two-channel versions of an SE module and a DIFF module as examples for all multi-channel versions.
SE and DIFF module as 2-channel version
Note: Dashed lines indicate that the respective connection may not necessarily be present in each SE or DIFF module. Electrical isolated channels are operating as differential type in general, hence there is no direct relation (voltaic) to ground within the module established at all. Indeed, specified information to recommended and maximum voltage levels have to be taken into account.
The basic rule:
▪
Analog measurements always take the form of voltage measurements between two potential points.
For voltage measurements a large R is used, in order to ensure a high impedance. For current measurements a small R is used as shunt. If the purpose is resistance measurement, corresponding considerations are applied.
–
Beckhoff generally refers to these two points as input+/signal potential and input-/reference potential.
–
For measurements between two potential points two potentials have to be supplied.
–
Regarding the terms “single-wire connection” or “three-wire connection”, please note the following for pure analog measurements: three- or four-wire connections can be used for sensor supply, but are not involved in the actual analog measurement, which always takes place between two potentials/wires.
In particular this also applies to SE, even though the term suggest that only one wire is required.
▪
The term “electrical isolation” should be clarified in advance.
Beckhoff IO modules feature 1..8 or more analog channels; with regard to the channel connection a distinction is made in terms of:
–
how the channels WITHIN a module relate to each other, or
–
how the channels of SEVERAL modules relate to each other.

The property of electrical isolation indicates whether the channels are directly connected to each other.
–
Beckhoff terminals/ boxes (and related product groups) always feature electrical isolation between the field/analog side and the bus/EtherCAT side. In other words, if two analog terminals/ boxes are not connected via the power contacts (cable), the modules are effectively electrically isolated.
–
If channels within a module are electrically isolated, or if a single-channel module has no power contacts, the channels are effectively always differential. See also explanatory notes below. Differential channels are not necessarily electrically isolated.
▪
Analog measuring channels are subject to technical limits, both in terms of the recommended operating range (continuous operation) and the destruction limit. Please refer to the respective terminal/ box documentation for further details.
Explanation
▪
differential (DIFF)
–
Differential measurement is the most flexible concept. The user can freely choose both connection points, input+/signal potential and input-/reference potential, within the framework of the technical specification.
–
A differential channel can also be operated as SE, if the reference potential of several sensors is linked. This interconnection may take place via the system GND.
–
Since a differential channel is configured symmetrically internally (cf. Fig. SE and DIFF module as 2-channel variant), there will be a mid-potential (X) between the two supplied potentials that is the same as the internal ground/reference ground for this channel. If several DIFF channels are used in a module without electrical isolation, the technical property VCM (common-mode voltage) indicates the degree to which the mean voltage of the channels may differ.
–
The internal reference ground may be accessible as connection point at the terminal/ box, in order to stabilize a defined GND potential in the terminal/ box. In this case it is particularly important to pay attention to the quality of this potential (noiselessness, voltage stability). At this GND point a wire may be connected to make sure that VCM,max is not exceeded in the differential sensor cable.
If differential channels are not electrically isolated, usually only one VCM, max is permitted. If the channels are electrically isolated this limit should not apply, and the channels voltages may differ up to the specified separation limit.
–
Differential measurement in combination with correct sensor wiring has the special advantage that any interference affecting the sensor cable (ideally the feed and return line are arranged side by side, so that interference signals have the same effect on both wires) has very little effect on the measurement, since the potential of both lines varies jointly (hence the term common mode). In simple terms: Common-mode interference has the same effect on both wires in terms of amplitude and phasing.
–
Nevertheless, the suppression of common-mode interference within a channel or between channels is subject to technical limits, which are specified in the technical data.
–
Further helpfully information on this topic can be found on the documentation page Configuration of 0/4..20 mA differential inputs (see documentation for the EL30xx terminals, for example).
▪
Single Ended (SE)
–
If the analog circuit is designed as SE, the input/reference wire is internally fixed to a certain potential that cannot be changed. This potential must be accessible from outside on at least one point for connecting the reference potential, e.g. via the power contacts (cable).
–
In other words, in situations with several channels SE offers users the option to avoid returning at least one of the two sensor cables to the terminal/ box (in contrast to DIFF). Instead, the reference wire can be consolidated at the sensors, e.g. in the system GND.
–
A disadvantage of this approach is that the separate feed and return line can result in voltage/current variations, which a SE channel may no longer be able to handle. See common-mode interference. A VCM effect cannot occur, since the module channels are internally always 'hard-wired' through the input/reference potential.
Typification of the 2/3/4-wire connection of current sensors
Current transducers/sensors/field devices (referred to in the following simply as ‘sensor’) with the industrial 0/4-20 mA interface typically have internal transformation electronics for the physical measured variable (temperature, current, etc.) at the current control output. These internal electronics must be supplied with energy (voltage, current). The type of cable for this supply thus separates the sensors into self-supplied or externally supplied sensors:
Self-supplied sensors
▪
The sensor draws the energy for its own operation via the sensor/signal cable + and -.
So that enough energy is always available for the sensor’s own operation and open-circuit detection is possible, a lower limit of 4 mA has been specified for the 4-20 mA interface; i.e. the sensor allows a minimum current of 4 mA and a maximum current of 20 mA to pass.
▪
2-wire connection see Fig. 2-wire connection, cf. IEC60381-1
▪
Such current transducers generally represent a current sink and thus like to sit between + and – as a ‘variable load’. Refer also to the sensor manufacturer’s information.
2-wire connection
Therefore, they are to be connected according to the Beckhoff terminology as follows:
preferably to ‘single-ended’ inputs if the +Supply connections of the terminal/ box are also to be used - connect to +Supply and Signal
they can, however, also be connected to ‘differential’ inputs, if the termination to GND is then manufactured on the application side – to be connected with the right polarity to +Signal and –Signal
It is important to refer to the information page Configuration of 0/4..20 mA differential inputs (see documentation for the EL30xx terminals, for example)!
Externally supplied sensors
▪
3- and 4-wire connection see Fig. Connection of externally supplied sensors, cf. IEC60381-1
▪
the sensor draws the energy/operating voltage for its own operation from two supply cables of its own. One or two further sensor cables are used for the signal transmission of the current loop:
–
1 sensor cable: according to the Beckhoff terminology such sensors are to be connected to ‘single-ended’ inputs in 3 cables with +/-/Signal lines and if necessary FE/shield
–
2 sensor cables: for sensors with 4-wire connection based on +supply/-supply/+signal/-signal, check whether +signal can be connected to +supply or –signal to –supply.
- Yes: then you can connect accordingly to a Beckhoff ‘single-ended’ input.
- No: the Beckhoff ‘differential’ input for +Signal and –Signal is to be selected; +Supply and –Supply are to be connected via additional cables.
It is important to refer to the information page Configuration of 0/4..20 mA differential inputs (see documentation for the EL30xx terminals, for example)!
Note: expert organizations such as NAMUR demand a usable measuring range <4 mA/>20 mA for error detection and adjustment, see also NAMUR NE043.
The Beckhoff device documentation must be consulted in order to see whether the respective device supports such an extended signal range.
Usually there is an internal diode existing within unipolar terminals/ boxes (and related product groups), in this case the polarity/direction of current have to be observed.
Connection of externally supplied sensors
Classification of the Beckhoff terminals/ boxes - Beckhoff 0/4-20 mA terminals/ boxes (and related product groups) are available as differential and single-ended terminals/ boxes (and related product groups):
Single-ended EL3x4x: 0-20 mA, EL3x5x: 4-20 mA; KL and related product groups exactly the same | Differential EL3x1x: 0-20 mA, EL3x2x: 4-20 mA; KL and related product groups exactly the same
Preferred current direction because of internal diode | Preferred current direction because of internal diode
Designed for the connection of externally-supplied sensors with a 3/4-wire connection | The terminal/ box is a passive differential current measuring device; passive means that the sensor is not supplied with power.
Designed for the connection of self-supplied sensors with a 2-wire connection |
Single-ended
Differential
2-, 3- and 4-wire connection at single-ended and differential inputs


Common-mode voltage and reference ground (based on differential inputs)

Commissioning [image] Notices on analog specifications [image] Common-mode voltage and reference ground (based on differential inputs)
Common-mode voltage and reference ground (based on differential inputs)
Common-mode voltage (Vcm) is defined as the average value of the voltages of the individual connections/inputs and is measured/specified against reference ground.
Common-mode voltage (Vcm)
The definition of the reference ground is important for the definition of the permitted common-mode voltage range and for measurement of the common-mode rejection ratio (CMRR) for differential inputs.
The reference ground is also the potential against which the input resistance and the input impedance for single-ended inputs or the common-mode resistance and the common-mode impedance for differential inputs is measured.
The reference ground is usually accessible at or near the terminal/ box, e.g. at the terminal contacts, power contacts (cable) or a mounting rail. Please refer to the documentation regarding positioning. The reference ground should be specified for the device under consideration.
For multi-channel terminals/ boxes with resistive (=direct, ohmic, galvanic) or capacitive connection between the channels, the reference ground should preferably be the symmetry point of all channels, taking into account the connection resistances.
Reference ground samples for Beckhoff IO devices:
1.
Internal AGND fed out: EL3102/EL3112, resistive connection between the channels
2.
0V power contact: EL3104/EL3114, resistive connection between the channels and AGND; AGND connected to 0V power contact with low-resistance
3.
Earth or SGND (shield GND):
–
EL3174-0002: Channels have no resistive connection between each other, although they are capacitively coupled to SGND via leakage capacitors
–
EL3314: No internal ground fed out to the terminal points, although capacitive coupling to SGND


Dielectric strength

Commissioning [image] Notices on analog specifications [image] Dielectric strength
Dielectric strength
A distinction should be made between:
▪
Dielectric strength (destruction limit): Exceedance can result in irreversible changes to the electronics
–
Against a specified reference ground
–
Differential
▪
Recommended operating voltage range: If the range is exceeded, it can no longer be assumed that the system operates as specified
–
Against a specified reference ground
–
Differential
Recommended operating voltage range
The device documentation may contain particular specifications and timings, taking into account:
▪
Self-heating
▪
Rated voltage
▪
Insulating strength
▪
Edge steepness of the applied voltage or holding periods
▪
Normative environment (e.g. PELV)


Temporal aspects of analog/digital conversion

Commissioning [image] Notices on analog specifications [image] Temporal aspects of analog/digital conversion
Temporal aspects of analog/digital conversion
The conversion of the constant electrical input signal to a value-discrete digital and machine-readable form takes place in the analog Beckhoff EL/KL/EP input modules with ADC (analog digital converter). Although different ADC technologies are in use, from a user perspective they all have a common characteristic: after the conversion a certain digital value is available in the controller for further processing. This digital value, the so-called analog process data, has a fixed temporal relationship with the “original parameter”, i.e. the electrical input value. Therefore, corresponding temporal characteristic data can be determined and specified for Beckhoff analogue input devices.
This process involves several functional components, which act more or less strongly in every AI (analog input) module:
▪
the electrical input circuit
▪
the analog/digital conversion
▪
the digital further processing
▪
the final provision of the process and diagnostic data for collection at the fieldbus (EtherCAT, K‑bus, etc.)
Signal processing analog input
Two aspects are crucial from a user perspective:
▪
“How often do I receive new values?”, i.e. a sampling rate in terms of speed with regard to the device/channel
▪
What delay does the (whole) AD conversion of the device/channel cause?
I.e. the hardware and firmware components in its entirety. For technological reasons, the signal characteristics must be taken into account when determining this information: the run times through the system differ, depending on the signal frequency.
This is the “external” view of the “Beckhoff AI channel” system – internally the signal delay in particular is composed of different components: hardware, amplifier, conversion itself, data transport and processing. Internally a higher sampling rate may be used (e.g. in the deltaSigma converters) than is offered “externally” from the user perspective. From a user perspective of the “Beckhoff AI channel” component this is usually irrelevant or is specified accordingly, if it is relevant for the function.
For Beckhoff AI devices the following specification parameters for the AI channel are available for the user from a temporal perspective:
1. Minimum conversion time [ms, µs]
This is the reciprocal value of the maximum sampling rate [sps, samples per second]:
Indicates how often the analog channel makes a newly detected process data value available for collection by the fieldbus. Whether the fieldbus (EtherCAT, K-bus) fetches the value with the same speed (i.e. synchronous), or more quickly (if the AI channel operates in slow FreeRun mode) or more slowly (e.g. with oversampling), is then a question of the fieldbus setting and which modes the AI device supports.
For EtherCAT devices the so-called toggle bit indicates (by toggling) for the diagnostic PDOs when a newly determined analog value is available.
Accordingly, a maximum conversion time, i.e. a smallest sampling rate supported by the AI device, can be specified.
Corresponds to IEC 61131-2, section 7.10.2 2, “Sampling repeat time”
2. Typical signal delay
Corresponds to IEC 61131-2, section 7.10.2 1, “Sampling duration”. From this perspective it includes all internal hardware and firmware components, but not “external” delay components from the fieldbus or the controller (TwinCAT).
This delay is particularly relevant for absolute time considerations, if AI channels also provide a time stamp that corresponds to the amplitude value – which can be assumed to match the physically prevailing amplitude value at the time.
Due to the frequency-dependent signal delay time, a dedicated value can only be specified for a given signal. The value also depends on potentially variable filter settings of the channel.
A typical characterization in the device documentation may be:
2.1 Signal delay (step response)
Keywords: Settling time
The square wave signal can be generated externally with a frequency generator (note impedance!)
The 90 % limit is used as detection threshold.
The signal delay [ms, µs] is then the time interval between the (ideal) electrical square wave signal and the time at which the analog process value has reached the 90 % amplitude.
Diagram signal delay (step response)
2.2 Signal delay (linear)
Keyword: Group delay
Describes the delay of a signal with constant frequency
A test signal can be generated externally with a frequency generator, e.g. as sawtooth or sine. A simultaneous square wave signal would be used as reference.
The signal delay [ms, µs] is then the interval between the applied electrical signal with a particular amplitude and the moment at which the analog process value reaches the same value.
A meaningful range must be selected for the test frequency, e.g. 1/20 of the maximum sampling rate.
Diagram signal delay (linear)
3. Additional Information
May be provided in the specification, e.g.
▪
Actual sampling rate of the ADC (if different from the channel sampling rate)
▪
Time correction values for run times with different filter settings
▪
etc.


Voltage measurement

Commissioning [image] Voltage measurement
Voltage measurement
EL3356 and special versions
Unless stated otherwise, the designation “EL3356” always refers also to special versions such as the EL3356-0010.
The EL3356 principally offers a 2-channel voltage measurement on one terminal with two very different measuring ranges of ±25 mV and ±12 V nominal voltage. The load on the one connected strain gauge can be calculated from the two simultaneously measured voltages; the EL3356 already performs this calculation in the terminal and thus represents a 1-channel terminal in the sense of load calculation.
Notice: The Ctrl PDO (CoE 0x7000:0) Start/Disable calibration, Input freeze, Sample Mode and Tara have no function in this case.
The following applies to the individual channels:
▪
Channel 1
–
Typical measuring range approx. -13.5 V to 0 to +13.5 V (equivalent to process value 0x80.00.00.00 ... 0 ... 0x7F.FF.FF.FF)
–
Nominal measuring range: -12 V ... 0 ... +12 V
–
max. permissible voltage - Uref vs. +Uref: ± 13.5 V
–
Measuring error< ±0.1 % of the full scale value, 50 Hz filter active
▪
Channel 2:
–
Typical measuring range approx. -27 mV to 0 to +27 mV (equivalent to process value 0x80.00.00.00 ... 0 ... x07F.FF.FF.FF)
–
Nominal measuring range: -25 mV ... 0 ... +25 mV
–
max. permissible voltage -UD vs. +UD: ±27 mV
–
Measuring error< ±0.1 % of the full scale value, 50 Hz filter active
▪
in strain gauge mode the connected strain gauge guarantees that no impermissibly high potential differences arise inside and outside the circuit.
In the standard setting the EL3356 operates as a 1-channel strain gauge monitor with the process image; the terminal can be switched to 2-channel voltage measurement by changing the process data. See the notes on the process image regarding this.
If the EL3356 is not used as a load measuring terminal, but rather as a 2-channel analog input measuring terminal, the following must be observed:
▪
The CoE settings are to be found for
–
Channel 1: objects under 0x8010:xx
–
Channel 2: objects under 0x8020:xx
–
the strain gauge objects under 0x8000:xx have no function
Exception: the averager (0x8000:03) can also be used in voltage measuring mode and applies to both channels simultaneously.
▪
Self-calibration is not possible and useful.
▪
The two analog channels are not calibrated by the manufacturer, since this is not required for the relative measurement in strain gauge mode.
This means, for example, for channel 1 with a nominal measuring range of ±12 V or a typical measuring range of ±13.5 V, that the maximum measured value 0x7F.FF.FF.FF can be output by one terminal for example as 13.4 V and by another as 13.6 V.
If terminals output identical process values for identical applied voltages, meaning that they are exchangeable, each channel must be calibrated by the user by making settings for each channel in the CoE. The user calibration (CoE 0x80n0:17 [offset], 0x80n0:18 [gain]) or the user scaling (CoE 0x80n0:11 [offset], 0x80n0:12 [gain]) can be used for this.
Voltage measurement
In the voltage measuring mode the EL3356 is to be connected to external GND with a single-ended connection.
In addition the internal GND reference is to be closed by the CoE switch SymmetricReferencePotential, see the following figure.
EL3356 voltage measurement - symmetric reference potential


Distributed Clocks mode (EL3356-0010, EL3356-0090 only)

Commissioning [image] Distributed Clocks mode (EL3356-0010, EL3356-0090 only)
Distributed Clocks mode (EL3356-0010, EL3356-0090 only)
In the Distributed Clocks mode (DC mode), the precise timestamp is recorded for each measured value and transmitted to the controller as cyclic process data. To this end
▪
DC must be activated
To do this, select DC-Synchron (input based) on the “DC” tab
▪
The PDO 0x1A03 in the Process data management is to be activated in the SyncManager 3 “Inputs”
Activation of DC and PDO timestamp in the TwinCAT System Manager
The EL3356-0010 and EL3356-0090 operate free running with a cyclic, but not equidistant measurement; the time intervals between two measured values are therefore not constant. For this reason the 64-bit timestamp delivered with the process value must be evaluated by the user.
In order to suppress falsification of the measurement results by upstream filters, both the software filter and the averager are deactivated in this operating mode. The measurement/calculation and provision of the measured value in the process data therefore takes place at the conversion rate corresponding to the mode:
▪
EL3356: 10.5 kSps
▪
EL3356-0010, EL3356-0090: 10.5 or 105.5 kSps
The minimum permissible EtherCAT cycle time with and without DC mode is 100 µs for the EL3356-0010 and 150 µs for the EL3356-0090.
Time stamp
See Notes on latency regarding the time when the actual timestamp is acquired.


Process data

Commissioning [image] Process data
Process data
This section describes the individual PDOs and their content. A PDO (Process Data Object) is a unit on cyclically transmitted process values. Such a unit can be an individual variable (e.g. the weight as a 32-bit value) or a group/structure of variables. The individual PDOs can be activated or deactivated separately in the TwinCAT System Manager. The ‘Process data’ tab is used for this (visible only if the terminal is selected on the left). A change in the composition of the process data in the TwinCAT System Manager becomes effective only after restarting the EtherCAT system.
The EL3356 can be used in two basic operating modes
▪
1-channel strain gauge evaluation (strain gauge, balance beam, load cell)
Here, both analog input voltages are measured internally, they are calculated locally according to the internal settings in the terminal and the resulting load value is output to the controller as a cyclic process value. Here, both analog input voltages are measured internally, they are calculated locally according to the internal settings in the terminal and the resulting load value is output to the controller as a cyclic process value.
The load value can be output as an integer or as a float/real representation.
▪
2-channel voltage measurement
Both analog input voltages are output directly as process values; no load calculation takes place.
The value and status information can be output for each channel.
The basic operating mode of the EL3356 terminal is determined by the selection of the process data (PDO).
EL3356 and special versions
•
EL3356 and EL3356-0010 have the same process data objects except:
⇨
EL3356: no mode switching in the ControlWord
⇨
EL3356-0090: When activating the TwinSAFE SC slot, the measured value has to be selected as INT32 (Index 0x1A01) see chapter TwinSAFE SC process data.
Additional information
•
Selection of process data
•
Default process image
•
Variants Predefined PDO
•
Distributed Clocks
•
Sync Manager


Selection of process data

Commissioning [image] Process data [image] Selection of process data
Selection of process data
The process data of the EL3356 are set up in the TwinCAT System Manager. The PDOs can be activated or deactivated separately. The ‘Process data’ tab is used for this (visible only if the terminal is selected on the left).
EL3356 - process data selection in the TwinCAT System Manager
If the terminal is selected in the System Manager (A), the Process data tab (B) shows the PDO selection. The two SyncManagers of the inputs (SM3) and outputs (SM2) can be changed (C). If one of the two is clicked on, the PDO possible for this SyncManager appears underneath it (D). PDOs that are already activated have an activated checkbox in front of them; this is activated by clicking on it.
The process data which then belong to the device are listed underneath it (G). So that the individual bit meanings are visible, e.g. in the Status status word, and can be separately linked (G), ShowSubVariables must be activated in the System Manager (F). The bit position at which the subvariables are located in the status or control word Ctrl) can be taken from the address overview (H) or the following information.
Predefined PDO Assignment
In order to simplify the configuration, typical configuration combinations of process data are stored in the device description. The predefined configurations can be selected in the process data overview. Therefore the function is available only if the ESI/XML files are saved in the system (downloadable from the Beckhoff website).
The following combinations are possible (see also Fig. EL3356 process data selection in the TwinCAT System Manager, E):
EL3356 selection Predefined PDO Assignment
▪
Standard (INT32): [Default setting] load calculation; 32-bit integer load value as final value according to the calculation specifications in the CoE, no further conversion necessary in the PLC
▪
Standard (REAL): Load calculation; 32-bit floating-point load value as final value according to the calculation specifications in the CoE, no further conversion necessary in the PLC
▪
2x AnalogIn (Standard): 2-channel voltage measurement, 32-bit integer voltage value with additional information (under-range, over-range, error, TxPDO Toggle)
▪
2x AnalogIn (Compact): 2-channel voltage measurement, 32-bit integer voltage value only


Default process image

Commissioning [image] Process data [image] Default process image
Default process image
The default process image is standard (INT32).
Default process image, EL3356-0010
Note regarding EL3356: No switching of SampleMode in the Ctrl word
Function of the variables
Variable | Meaning
Status | The status word (SW) is located in the input process image, and is transmitted from terminal to the controller. For explanation see the entries in the object overview, index 0x6000 see “Bit - meaning of the status word”
Value | calculated 32-bit DINT load value in unit [1], with sign
Value (Real) | calculated 32-bit fixed point REAL load value with mantissa and exponent in unit [1] The format matches the REAL format of IEC 61131-3, which in turn is based on the REAL format of IEC 559. A REAL number (single precision) is defined as follows (See also Beckhoff InfoSys: TwinCAT PLC Control: standard data types). According to IEC 61131, this 32-bit variable can be linked directly with a FLOAT variable of the PLC, see “Bit - meaning of the variable value (REAL)”
WcState | cyclic diagnostic variable; “0” indicates correct data transmission
Status | State of the EtherCAT device; State.3 = TRUE indicates correct operation in OP
AdsAddr | AmsNet address of the EtherCAT device from AmsNetId (in this case: 192.168.0.20.5.1) and port (in this case: 1003)
Ctrl | The control word (CW) is located in the output process image, and is transmitted from the controller to the terminal. For explanation see the entries in the object overview, index 0x7000 see “Bit - meaning of the control word”
See also the example program for the dissection of the Status and CTRL variable.
Bit - meaning of the “status word”
Bit | SW.15 | SW.14 | SW.13 | SW.12 - SW.9 | SW.8 | SW.7 | SW.6 | SW.5 - SW.4 | SW.3 | SW.2 | SW.1 | SW.0
Name | TxPDO Toggle | - | Sync Error | - | Steady State | Calibration in progress | Error | - | Data invalid | - | Over -range | -
Meaning | toggeles 0->1->0 with each updated data set | - | Synchronization error | - | Idling recognition | Calibration in progress | Collective error display | - | Input data are invalid | - | Measuring range exceeded | -
Bit - purpose of the variable “Value (Real)”
Bit position (from left) | 1 | 8 | 23 (+1 “hidden bit”, see IE559)
Function | Sign | Exponent | Mantissa
Bit - meaning of the “control word”
Bit | CW.15 - CW.5 | CW.4 | CW.3 | CW.2 | CW.1 | CW.0
Name | - | Tare | Sample Mode | Input Freeze | Disable Calibration | Start Calibration
Meaning | - | starts tare | mode switching (EL3356-0010 and EL3356-0090 only) | stops the measurement | switches the automatic self-calibration off | starts the self-calibration immediately


Variants Predefined PDO

Commissioning [image] Process data [image] Variants Predefined PDO
Variants Predefined PDO
Fixed-point representation of the load
The display of the load value can also be converted already in the terminal into a point representation. To do this the input PDOs are to be changed as follows:
Load value in fixed-point representation
Variable | Meaning
Value (Real) | calculated 32-bit fixed point REAL load value with mantissa and exponent in unit [1] The format matches the REAL format of IEC 61131-3, which in turn is based on the REAL format of IEC 559. A REAL number (single precision) is defined as follows (See also Beckhoff InfoSys: TwinCAT PLC Control: standard data types). According to IEC61131, this 32-bit variable can be linked directly with a FLOAT variable of the PLC, see “Bit – meaning of the variable value (REAL)”
Voltage measurement
The EL3356 can also be used as a 2-channel analog input terminal for voltage measurement, see Notes.
EL3356 process image for voltage measurement
Variable | Meaning
Underrange | Measurement is below range
Overrange | Measuring range exceeded
Error | Collective error display
TxPdo Toggle | Toggles 0->1->0 with each updated data set
Value | right-justified voltage value over the respective measuring range (range 0x80.00.00.00 ... 0 ... 0x7F.FF.FF.FF) Channel 1: Supply voltage Channel 2: Bridge voltage


Distributed Clocks

Commissioning [image] Process data [image] Distributed Clocks
Distributed Clocks
In DC mode (Distributed Clocks) the process data 0x1A03 Timestamp must be activated.
EL3356-0010, EL3356-0090 activation timestamp 0x1A03 in DC mode
Also, the variables DcOutputShift and DcInputShift are displayed in the process data in DC mode. Upon activation of the configuration these are calculated once in the unit [ns] on the basis of the set EtherCAT cycle time (observe assigned task!) and DC shift times from the EtherCAT master settings. In the InputBased operating mode, DcInputShift indicates by how many nanoseconds [ns] before or after the global Sync the terminal determines your process data. For further information on this, see the EtherCAT system description.
Since the EL3356-0010 and EL3356-0090 are not DC-triggered but determine the timestamp itself, these values have no meaning in these terminals.


Sync Manager

Commissioning [image] Process data [image] Sync Manager
Sync Manager
PDO Assignment
Inputs: SM3, PDO Assignment 0x1C13
Index | Index of excluded PDOs | Size (byte.bit) | Name | PDO content
0x1A00 (default) | - | 2.0 | RMB Status (Resistor Measurement Bridge) | Index 0x6000:02 - Overrange Index 0x6000:04 - Data invalid Index 0x6000:07 - Error Index 0x6000:08 - Calibration in progress Index 0x6000:09 - Steady State Index 0x6000:0E - sync error, correction: Index 0x6000:10 - TxPDO Toggle
0x1A01(default) | 0x1A02 0x1A04 0x1A05 0x1A06 0x1A07 | 4.0 | RMB Value (INT32) | Index 0x6000:11 - Value
0x1A02 | 0x1A01 0x1A04 0x1A05 0x1A06 0x1A07 | 4.0 | RMB Value (Real) | Index 0x6000:12 - Value (Real)
0x1A03 | 0x1A04 0x1A05 0x1A06 0x1A07 | 8.0 | RMB Timestamp | Index 0x6000:13. - Value
0x1A04 | 0x1A00 0x1A01 0x1A02 0x1A03 0x1A05 | 6.0 | AI Standard Channel 1 (Analog Input) | Index 0x6010:01 - Underrange Index 0x6010:02 - Overrange Index 0x6010:07 - Error Index 0x6010:10 - TxPdo Toggle Index 0x6010:11 - Value
0x1A05 | 0x1A00 0x1A01 0x1A02 0x1A03 0x1A04 | 4.0 | AI Compact Channel 1 (Analog Input) | Index 0x6010:11 - Value
0x1A06 | 0x1A00 0x1A01 0x1A02 0x1A03 0x1A07 | 6.0 | AI Standard Channel 2 (Analog Input) | Index 0x6020:01 - Underrange Index 0x6020:02 - Overrange Index 0x6020:07 - Error Index 0x6020:10 - TxPDO Toggle Index 0x6020:11 - Value
0x1A07 | 0x1A00 0x1A01 0x1A02 0x1A03 0x1A06 | 4.0 | AI Compact Channel 2 (Analog Input) | Index 0x6020:11 - Value
Outputs: SM2, PDO assignment 0x1C12
Index | Index of excluded PDOs | Size (byte.bit) | Name | PDO content
0x1600 (default) | - | 2.0 | RMB Control (Resistor Measurement bridge) | Index 0x7000:01 - Start calibration Index 0x7000:02 - Disable calibration Index 0x7000:03 - Input freeze Index 0x7000:04 - Sample Mode (EL3356-0010 and EL3356-0090 only) Index 0x7000:05 - Tare
0x1601 | - | 2.0 | RMB Filter frequency | Index 0x7000:11 - Filter frequency (valid as from firmware 05)


TwinSAFE SC

Commissioning [image] TwinSAFE SC
TwinSAFE SC
Additional information
•
TwinSAFE SC - operating principle
•
TwinSAFE SC - configuration


TwinSAFE SC - operating principle

Commissioning [image] TwinSAFE SC [image] TwinSAFE SC - operating principle
TwinSAFE SC - operating principle
The TwinSAFE SC (Single Channel) technology enables the use of standard signals for safety tasks in any networks of fieldbuses. To do this, EtherCAT Terminals from the areas of analog input, angle/displacement measurement or communication (4…20 mA, incremental encoder, IO-Link, etc.) are extended by the TwinSAFE SC function. The typical signal characteristics and standard functionalities of the I/O components are retained. TwinSAFE SC I/Os have a yellow strip at the front of the housing to distinguish them from standard I/Os.
The TwinSAFE SC technology enables communication via a TwinSAFE protocol. These connections can be distinguished from the usual safe communication via Safety over EtherCAT.
The data of the TwinSAFE SC components are transferred via a TwinSAFE protocol to the TwinSAFE logic, where they can be used in the context of safety-relevant applications. Detailed examples for the correct application of the TwinSAFE SC components and the respective normative classification, which were confirmed/calculated by TÜV SÜD, can be found in the TwinSAFE application manual.


TwinSAFE SC - configuration

Commissioning [image] TwinSAFE SC [image] TwinSAFE SC - configuration
TwinSAFE SC - configuration
The TwinSAFE SC technology enables communication with standard EtherCAT terminals via the Safety over EtherCAT protocol. These connections use another checksum, in order to be able to distinguish between TwinSAFE SC and TwinSAFE. Eight fixed CRCs can be selected, or a free CRC can be entered by the user.
By default the TwinSAFE SC communication channel of the respective TwinSAFE SC component is not enabled. In order to be able to use the data transfer, the corresponding TwinSAFE SC module must first be added under the Slots tab. Only then is it possible to link to a corresponding alias device.
Adding the TwinSAFE SC process data under the component, e.g. EL5021-0090
Additional process data with the ID TSC Inputs, TSC Outputs are generated (TSC - TwinSAFE Single Channel).
Prozessdaten TwinSAFE SC Komponente (iankfd11.png)
TwinSAFE SC component process data, example EL5021-0090
A TwinSAFE SC connection is added by adding an alias devices in the safety project and selecting TSC (TwinSAFE Single Channel)
Adding a TwinSAFE SC connection
After opening the alias device by double-clicking, select the Link button Grafik aus Konfiguration TwinSAFE SC (iak9opa.png) next to Physical Device, in order to create the link to a TwinSAFE SC terminal. Only suitable TwinSAFE SC terminals are offered in the selection dialog.
Grafik aus Konfiguration TwinSAFE SC (i8d09251.png)
Creating a link to TwinSAFE SC terminal
The CRC to be used can be selected or a free CRC can be entered under the Connection tab of the alias device.
Entry Mode | Used CRCs
TwinSAFE SC CRC 1 master | 0x17B0F
TwinSAFE SC CRC 2 master | 0x1571F
TwinSAFE SC CRC 3 master | 0x11F95
TwinSAFE SC CRC 4 master | 0x153F1
TwinSAFE SC CRC 5 master | 0x1F1D5
TwinSAFE SC CRC 6 master | 0x1663B
TwinSAFE SC CRC 7 master | 0x1B8CD
TwinSAFE SC CRC 8 master | 0x1E1BD
Selecting a free CRC
These settings must match the settings in the CoE objects of the TwinSAFE SC component.
The TwinSAFE SC component initially makes all available process data available. The Safety Parameters tab typically contains no parameters. The process data size and the process data themselves can be selected under the Process Image tab.
Selecting the process data size and the process data
The process data (defined in the ESI file) can be adjusted to user requirements by selecting the Edit button in the dialog Configure I/O element(s).
Selection of the process data
The safety address together with the CRC must be entered on the TwinSAFE SC slave side. This is done via the CoE objects under TSC settings of the corresponding TwinSAFE SC component (here, for example, EL5021-0090, 0x8010: 01 and 0x8010: 02). The address set here must also be set in the alias device as FSoE address under the Linking tab.
Under the object 0x80n0:02 Connection Mode the CRC to be used is selected or a free CRC is entered. A total of 8 CRCs are available. A free CRC must start with 0x00ff in the high word.
Grafik aus Konfiguration TwinSAFE SC (iv9tkmo3.png)
CoE objects 0x8010:01 and 0x8010:02
Object TSC Settings
Depending on the terminal, the index designation of the configuration object TSC Settings can vary.
Example:
- EL3214-0090 and EL3314-0090, TSC Settings, Index 8040
- EL5021-0090, TSC Settings, Index 8010
- EL6224-0090, TSC Settings, Index 800F
Grafik aus Konfiguration TwinSAFE SC (isvth0a2.png)
Entering the safety address and the CRC
TwinSAFE SC connections
If several TwinSAFE SC connections are used within a configuration, a different CRC must be selected for each TwinSAFE SC connection.


EL3356-0090 - TwinSAFE SC process data

Commissioning [image] EL3356-0090 - TwinSAFE SC process data
EL3356-0090 - TwinSAFE SC process data
The EL3356-0090 transmits the following process data to the TwinSAFE logic:
Index (hex) | Name | Type | Size
6000:11 | Value | UINT | 2.0
When activating the TwinSAFE SC slot, the measured value has to be selected as INT32 (Index 0x1A01).
Depending on the TwinCAT 3.1 version, process data can be renamed automatically when linking to the Safety Editor.
The minimum permissible assigned EtherCAT cycle time for the EL3356-0090 is 150 µs.
Measurement values are not updated during self-calibration
The EL3356-0090 has automatic calibration / self-calibration. This is activated by default and takes effect every three minutes. During self-calibration, the measured values are not updated, they are frozen. This must be taken into account accordingly in the safety application. The automatic can be switched off or controlled.
Measurement values are not updated during mode change
The EL3356-0090 offers several modes, such as: Eg sample mode. During the mode change, the measurement values are not updated, they are frozen. This must be taken into account accordingly in the safety application.
TwinSAFE SC Objects
The TwinSAFE SC objects of the EL3356-0090 are listed in chapter Objects TwinSAFE Single Channel (EL3356-0090).


EL3356, EL3356-00x0 - Object description and parameterization

Commissioning [image] EL3356, EL3356-00x0 - Object description and parameterization
EL3356, EL3356-00x0 - Object description and parameterization
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Parameterization via the CoE list (CAN over EtherCAT)
The EtherCAT device is parameterized via the CoE-Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs). Please note the following general CoE notes when using/manipulating the CoE parameters:
•
Keep a startup list if components have to be replaced
•
Differentiation between online/offline dictionary, existence of current XML description
•
use “CoE reload” for resetting changes
Additional information
•
Restore object
•
Configuration data
•
Command object
•
Input data
•
Output data
•
Information / diagnostic data
•
Vendor configuration data (device-specific)
•
Standard objects


Restore object

Commissioning [image] EL3356, EL3356-00x0 - Object description and parameterization [image] Restore object
Restore object
Index 1011 Restore default parameters
Index | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default parameters | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to “0x64616F6C” in the set value dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)


Configuration data

Commissioning [image] EL3356, EL3356-00x0 - Object description and parameterization [image] Configuration data
Configuration data
Index 8000 RMB Settings
Index (hex) | Name | Meaning | Data type | Flags | Default
8000:0 | RMB Settings | Max. subindex | UINT8 | RO | 0x32 (50dec)
8000:01 | Mode0 enable filter | 0: No filters active. The terminal operates cycle-synchronous 1: The filter settings selected in subindex 0x8000:11 or 0x8000:12 are active. | BOOLEAN | RW | 0x01 (1dec)
8000:02 | Mode1 enable filter (EL3356-0010, EL3356-0090 only) |  | BOOLEAN | RW | 0x01 (1dec)
8000:03 | Mode0 enable averager | Activate hardware mean value filter | BOOLEAN | RW | 0x01 (1dec)
8000:04 | Mode1 enable averager (EL3356-0010, EL3356-0090 only) |  | BOOLEAN | RW | 0x01 (1dec)
8000:05 | Symmetric reference potential | Activate symmetric measurement | BOOLEAN | RW | 0x01 (1dec)
8000:11 | Mode0 filter settings | 0: FIR 50 Hz 1: FIR 60 Hz 2: IIR 1 3: IIR 2 4: IIR 3 5: IIR 4 6: IIR 5 7: IIR 6 8: IIR 7 9: IIR 8 10: Dynamic IIR 11: PDO Filter frequency (valid as from firmware 05) see Filter | UINT16 | RW | 0x0000 (0dec)
8000:12 | Mode1 filter settings (EL3356-0010, EL3356-0090 only) |  | UINT16 | RW | 0x0000 (0dec)
8000:13 | Dynamic filter change time | Sampling rate for dynamic filter switching. Scaling in 0.01 ms (100 = 1 s) (only if the filters are active and “dynamic IIR” is selected as filter) | UINT16 | RW | 0x000A (10dec)
8000:14 | Dynamic filter delta | Limit value for dynamic filter switching. (only if the filters are active and “dynamic IIR” is selected as filter) | REAL32 | RW | 0x41A00000 (1101004800dec) = 20.0
8000:21 | Gain | Scale factor | REAL32 | RW | 0x3F800000 (1065353216dec) = 1.0
8000:22 | Tare | Process data value offset | REAL32 | RW | 0x00000000 (0dec) = 0.0
8000:23 | Rated output | Nominal characteristic value of the sensor element in mV/V | REAL32 | RW | 0x40000000 (1073741824dec) = 2.0
8000:24 | Nominal load | Nominal load of the force transducer/load cell/etc. (e.g. in kg, N or ...) | REAL32 | RW | 0x40A00000 (1084227584dec) = 5.0
8000:25 | Zero balance | Zero point offset in mV/V | REAL32 | RW | 0x00000000 (0dec) = 0.0
8000:26 | Gravity of earth | Current acceleration of gravity (default 9.806650) | REAL32 | RW | 0x411CE80A (1092413450dec) = 9.806650
8000:27 | Scale factor | This factor can be used to re-scale the process data. In order to change the display from kg to g, for example, the factor 1000 can be entered here. | REAL32 | RW | 0x447A0000 (1148846080dec) = 1000.0
8000:28 | Reference load | Reference weight for manual calibration | REAL32 | RW | 0x40A00000 (1084227584dec) = 5.0
8000:29 | Steady state window | Time constant for the “steady state” bit (used for idle recognition) | UINT16 | RW | 0x03E8 (1000dec)
8000:2A | Steady state tolerance | Tolerance window for the “steady state” bit | UINT32 | RW | 0x00000005 (5dec)
Index (hex) | Name | Meaning | Data type | Flags | Default
8000:31 | Calibration interval | Calibration interval for automatic calibration of the terminal. The unit is 100 ms. The smallest possible value is 5 (500 ms). A value of 0 deactivates automatic self-calibration. This is also possible via the process data bit “Disable calibration”. | UINT16 | RW | 0x0708 (1800dec)
8000:32 | Test interval | This register contains the test interval for the cyclic self-test of the terminal. This interval is always a multiple (the default is 10dec) of the calibration interval (0x8000:31).. The test interval when the terminal leaves the factory is therefore 10 x 180 s = 1800 s. The process data bit “Disable calibration” can be used to deactivate the self-test. | UINT16 | RW | 0x000A (10dec)
Index 8010 , 8020 AI Settings
Index (hex) | Name | Meaning | Data type | Flags | Default
80n0:0 | AI Settings | Max. subindex | UINT8 | RO | 0x18 (24dec)
80n0:01 | Enable user scale | User scale is active. | BOOLEAN | RW | 0x00 (0dec)
80n0:06 | Enable filter | Enable filter | BOOLEAN | RW | 0x01 (1dec)
80n0:0A | Enable user calibration | Enabling of the user calibration | BOOLEAN | RW | 0x00 (0dec)
80n0:0B | Enable vendor calibration | Enabling of the vendor calibration | BOOLEAN | RW | 0x01 (1dec)
80n0:11 | User scale offset | User scaling offset | INT32 | RW | 0x00000000 (0dec)
80n0:12 | User scale gain | User scaling gain. The gain is represented in fixed-point format, with the factor 2-16. The value 1 corresponds to 65535dec (0x00010000hex) and is limited to +/- 0x7FFFF. | INT32 | RW | 0x00010000 (65536dec)
80n0:15 | Filter settings | This object determines the digital filter settings, if it is active via Enable filter (index 0x80n0:06). The possible settings are sequentially numbered. 0: 50 Hz FIR 1: 60 Hz FIR 2: IIR 1 3: IIR 2 4: IIR 3 5: IIR 4 6: IIR 5 7: IIR 6 8: IIR 7 9: IIR 8 | UINT16 | RW | 0x0000 (0dec)
80n0:17 | User calibration offset | User calibration offset | INT32 | RW | 0x00000000 (0dec)
80n0:18 | User calibration gain | User calibration gain | INT16 | RW | 0x4000 (16384dec)


Command object

Commissioning [image] EL3356, EL3356-00x0 - Object description and parameterization [image] Command object
Command object
Index FB00 RMB Command
Index (hex)
Name
Meaning
Data type
Flags
Default
FB00:0
RMB Command
Max. subindex
UINT8
RO
0x03 (3dec)
FB00:01
Request
Commands can be sent to the terminal via the request object. Command:
▪
0x0101: Zero balance
▪
0x0102: Calibration
▪
0x0001 Taring
▪
0x0002 Taring (data are stored in the EEPROM)
see commands
OCTET-STRING[2]
RW
{0}
FB00:02
Status
Status of the command currently being executed
0: Command executed without error.
255: Command is being executed
UINT8
RO
0x00 (0dec)
FB00:03
Response
Optional response value of the command
OCTET-STRING[4]
RO
{0}


Input data

Commissioning [image] EL3356, EL3356-00x0 - Object description and parameterization [image] Input data
Input data
Index 6000 RMB Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
6000:0 | RMB Inputs | Max. Subindex | UINT8 | RO | 0x13 (19dec)
6000:02 | Overrange | The measured value has reached its end value | BOOLEAN | RO | 0x00 (0dec)
6000:04 | Data invalid | The displayed process data are invalid. e.g. during calibration. | BOOLEAN | RO | 0x00 (0dec)
6000:07 | Error | An error has occurred. | BOOLEAN | RO | 0x00 (0dec)
6000:08 | Calibration in progress | Calibration is running. The process data show the last valid measured value. | BOOLEAN | RO | 0x00 (0dec)
6000:09 | Steady state |  | BOOLEAN | RO | 0x00 (0dec)
6000:0E | Sync error | The Sync error bit is only required for Distributed Clocks mode. It indicates whether a synchronization error has occurred during the previous cycle. | BOOLEAN | RO | 0x00 (0dec)
6000:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
6000:11 | Value | Measured value as 32 bit signed integer | INT32 | RO | 0x61746144 (1635017028dec)
6000:12 | Value (Real) | Measured value as real | REAL32 | RO | 0x00000000 (0dec)
6000:13 | Timestamp | Timestamp of the current measured value. (only EL3356-0010 and EL3356-0090 in DC mode) | UINT64 | RO |
Index 6010, 6020 AI Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
60n0:0 | AI Inputs | Max. subindex | UINT8 | RO | 0x11 (17dec)
60n0:01 | Underrange | Value below measuring range. | BOOLEAN | RO | 0x00 (0dec)
60n0:02 | Overrange | Measuring range exceeded. | BOOLEAN | RO | 0x00 (0dec)
60n0:07 | Error | An error has occurred. - Over- / Underrange Udif - Over- / Underrange Uref - The external Uref is too low (between -1 V and +1 V) - Data invalid | BOOLEAN | RO | 0x00 (0dec)
60n0:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
60n0:11 | Value | 32-bit measured value | INT32 | RO | 0x00000000 (0dec)


Output data

Commissioning [image] EL3356, EL3356-00x0 - Object description and parameterization [image] Output data
Output data
Index 7000 RMB Outputs
Index (hex) | Name | Meaning | Data type | Flags | Default
7000:0 | RMB Outputs | Max. subindex | UINT8 | RO | 0x05 (5dec)
7000:01 | Start calibration | The calibration can be started manually with a rising edge. This can be used to prevent the calibration from starting automatically at an unsuitable time. | BOOLEAN | RO | 0x00 (0dec)
7000:02 | Disable calibration | 0: Automatic calibration is active. 1: Automatic calibration is switched off. | BOOLEAN | RO | 0x00 (0dec)
7000:03 | Input freeze | The process data and the digital filters are frozen. | BOOLEAN | RO | 0x00 (0dec)
7000:04 | Sample mode* | Selecting the sample mode: 0: 10.5 kHz High precision 1: 105 kHz Low latency | BOOLEAN | RO | 0x00 (0dec)
7000:05 | Tare | The process record can be set to 0 with a rising edge. The tare value is not stored in the EEPROM and is therefore no longer available after a terminal reset. | BOOLEAN | RO | 0x00 (0dec)
7000:11 | Filter frequency | Filter frequency of the variable PDO filter in 0.1 Hz, see filter Value range: 1 ... 2000 (corresponds to 0.1 ... 200 Hz) If the value is 0 or greater than 2000, the filter behaves like a 50 Hz FIR filter | UINT16 | RO | 0x00 (0dec)
*) EL3356-0010 and EL3356-0090 only


Information / diagnostic data

Commissioning [image] EL3356, EL3356-00x0 - Object description and parameterization [image] Information / diagnostic data
Information / diagnostic data
Index 801E, 802E AI Internal data
Index (hex) | Name | Meaning | Data type | Flags | Default
801E:0 | AI Internal data | Max. subindex | UINT8 | RO | 0x01 (1dec)
801E:01 | ADC raw value 1 | ADC raw value | INT32 | RO | 0x00000000 (0dec)
Index 9000 RMB Info data
Index (hex) | Name | Meaning | Data type | Flags | Default
9000:0 | RMB Info data | Max. subindex | UINT8 | RO | 0x11 (17dec)
9000:11 | mV/V | Current mV/V value | REAL32 | RO | 0x00000000 (0dec)
Index A000 RMB Diag data
Index (hex) | Name | Meaning | Data type | Flags | Default
A000:0 | RMB Diag data | Max. subindex | UINT8 | RO | 0x18 (24dec)
A000:11 | No internal reference supply | No internal reference voltage at the ADC input (URef channel) | BOOLEAN | RO | 0x00 (0dec)
A000:12 | No internal referecnce bridge | No internal reference voltage at the ADC input (UDif channel) | BOOLEAN | RO | 0x00 (0dec)
A000:13 | No external reference supply | The external reference voltage is less than ±1 V. | BOOLEAN | RO | 0x00 (0dec)
A000:15 | Overrange bridge | Measuring range exceeded in the bridge junction | BOOLEAN | RO | 0x00 (0dec)
A000:16 | Underrange bridge | Value below measuring range in the bridge junction | BOOLEAN | RO | 0x00 (0dec)
A000:17 | Overrange supply | Measuring range of the reference voltage exceeded | BOOLEAN | RO | 0x00 (0dec)
A000:18 | Underrange supply | Value below measuring range for the reference voltage | BOOLEAN | RO | 0x00 (0dec)


Vendor configuration data (device-specific)

Commissioning [image] EL3356, EL3356-00x0 - Object description and parameterization [image] Vendor configuration data (device-specific)
Vendor configuration data (device-specific)
Index 801F, 802F AI Vendor data
Index (hex) | Name | Meaning | Data type | Flags | Default
801F:0 | AI Vendor data | Max. subindex | UINT8 | RO | 0x02 (2dec)
801F:01 | Calibration offset | Offset (vendor calibration) | INT32 | RW | 0x01E10000 (31522816dec)
801F:02 | Calibration gain | Gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)


Standard objects

Commissioning [image] EL3356, EL3356-00x0 - Object description and parameterization [image] Standard objects
Standard objects
Index 1000 Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: the Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x01681389 (23597961dec)
Index 1008 Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EL3356, EL3356-0010, EL3356-0090
Index 1009 Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO | 00
Index 100A Software version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO | 01
Index 1018 Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x0D1C3052 (219951186dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the low word (bit 0-15) indicates the special terminal number, the high word (bit 16-31) refers to the device description | UINT32 | RO | 0x00100000 (1048576dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the low byte (bit 0-7) of the low word contains the year of production, the high byte (bit 8-15) of the low word contains the week of production, the high word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 Backup parameter handling
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | Information for standardized loading and saving of backup entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum across all backup entries of the EtherCAT slave | UINT32 | RO | 0x00000000 (0dec)
Index 1600 RMB RxPDO-Map Control (EL3356)
Index (hex) | Name | Meaning | Data type | Flags | Default
1600:0 | RMB RxPDO-Map Control | PDO Mapping RxPDO-Map control | UINT8 | RO | 0x07 (7dec)
1600:01 | Subindex 001 | 1. PDO Mapping entry (object 0x7000 (RMB outputs), entry 0x01 (Start calibration)) | OCTET-STRING[10] | RO | 0x7000:01, 1
1600:02 | Subindex 002 | 2. PDO Mapping entry (object 0x7000 (RMB outputs), entry 0x02 (Disable calibration)) | OCTET-STRING[10] | RO | 0x7000:02, 1
1600:03 | Subindex 003 | 3. PDO Mapping entry (object 0x7000 (RMB outputs), entry 0x03 (Input freeze)) | OCTET-STRING[10] | RO | 0x7000:03, 1
1600:04 | Subindex 004 | 4. PDO Mapping entry (4 bits align) | OCTET-STRING[10] | RO | 0x0000:00, 1
1600:05 | Subindex 005 | 5. PDO Mapping entry (object 0x7000 (RMB outputs), entry 0x05 (Tara)) | OCTET-STRING[10] | RO | 0x7000:05, 1
1600:06 | Subindex 006 | 6. PDO Mapping entry (3 bits align) | OCTET-STRING[10] | RO | 0x0000:00, 3
1600:07 | Subindex 007 | 7. PDO Mapping entry (8 bits align) | OCTET-STRING[10] | RO | 0x0000:00, 8
Index 1600 RMB RxPDO-Map Control (EL3356-0010, EL3356-0090)
Index (hex) | Name | Meaning | Data type | Flags | Default
1600:0 | RMB RxPDO-Map Control | PDO Mapping RxPDO-Map control | UINT8 | RO | 0x07 (7dec)
1600:01 | Subindex 001 | 1. PDO Mapping entry (object 0x7000 (RMB outputs), entry 0x01 (Start calibration)) | OCTET-STRING[10] | RO | 0x7000:01, 1
1600:02 | Subindex 002 | 2. PDO Mapping entry (object 0x7000 (RMB outputs), entry 0x02 (Disable calibration)) | OCTET-STRING[10] | RO | 0x7000:02, 1
1600:03 | Subindex 003 | 3. PDO Mapping entry (object 0x7000 (RMB outputs), entry 0x03 (Input freeze)) | OCTET-STRING[10] | RO | 0x7000:03, 1
1600:04 | Subindex 004 | 4. PDO Mapping entry (object 0x7000 (RMB outputs), entry 0x04 (Sample mode)) | OCTET-STRING[10] | RO | 0x0000:00, 1
1600:05 | Subindex 005 | 5. PDO Mapping entry (object 0x7000 (RMB outputs), entry 0x05 (Tara)) | OCTET-STRING[10] | RO | 0x7000:05, 1
1600:06 | Subindex 006 | 6. PDO Mapping entry (3 bits align) | OCTET-STRING[10] | RO | 0x0000:00, 3
1600:07 | Subindex 007 | 7. PDO Mapping entry (8 bits align) | OCTET-STRING[10] | RO | 0x0000:00, 8
Index 1601 RMB RxPDO-Map Filter frequency
Index (hex) | Name | Meaning | Data type | Flags | Default
1601:0 | RMB RxPDO-Map Filter frequency | PDO Mapping RxPDO-Map Filter frequency | UINT8 | RO | 0x01 (1dec)
1601:01 | Subindex 001 | 1. PDO Mapping entry (object 0x7000 (RMB ouputs), entry 0x11 (Start calibration)) | OCTET-STRING[10] | RO | 0x7000:11, 16
Index 1800 RMB TxPDO-Par Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1800:0 | RMB TxPDO-Par Status | PDO Parameter TxPDO 1 | UINT8 | RO | 0x06 (6dec)
1800:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 1 | OCTET-STRING[10] | RO | 04 1A 05 1A 06 1A 07 1A 00 00
Index 1801 RMB TxPDO-Par Value (INT32)
Index (hex) | Name | Meaning | Data type | Flags | Default
1801:0 | RMB TxPDO-Par Value (INT32) | PDO Parameter TxPDO 2 | UINT8 | RO | 0x06 (6dec)
1801:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 2 | OCTET-STRING[10] | RO | 02 1A 04 1A 05 1A 06 1A 07 1A
Index 1802 RMB TxPDO-Par Value (Real)
Index (hex) | Name | Meaning | Data type | Flags | Default
1802:0 | RMB TxPDO-Par Value (Real) | PDO Parameter TxPDO 3 | UINT8 | RO | 0x06 (6dec)
1802:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 3 | OCTET-STRING[10] | RO | 01 1A 04 1A 05 1A 06 1A 07 1A
Index 1803 RMB TxPDO-Par Timestamp
Index (hex) | Name | Meaning | Data type | Flags | Default
1803:0 | RMB TxPDO-Par Timestamp | PDO Parameter TxPDO 4 | UINT8 | RO | 0x06 (6dec)
1803:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 4 | OCTET-STRING[10] | RO | 04 1A 05 1A 06 1A 07 1A 00 00
Index 1804 AI TxPDO-Par Standard Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1804:0 | AI TxPDO-Par Standard Ch.1 | PDO Parameter TxPDO 5 | UINT8 | RO | 0x06 (6dec)
1804:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 5 | OCTET-STRING[10] | RO | 05 1A 00 1A 01 1A 02 1A 03 1A
Index 1805 AI TxPDO-Par Compact Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1805:0 | AI TxPDO-Par Compact Ch.1 | PDO Parameter TxPDO 6 | UINT8 | RO | 0x06 (6dec)
1805:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 6 | OCTET-STRING[10] | RO | 04 1A 00 1A 01 1A 02 1A 03 1A
Index 1806 AI TxPDO-Par Standard Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1806:0 | AI TxPDO-Par Standard Ch.2 | PDO Parameter TxPDO 7 | UINT8 | RO | 0x06 (6dec)
1806:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 7 | OCTET-STRING[10] | RO | 07 1A 00 1A 01 1A 02 1A 03 1A
Index 1807 AI TxPDO-Par Compact Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1807:0 | AI TxPDO-Par Compact Ch.2 | PDO Parameter TxPDO 8 | UINT8 | RO | 0x06 (6dec)
1807:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 8 | OCTET-STRING[10] | RO | 06 1A 00 1A 01 1A 02 1A 03 1A
Index 1A00 RMB TxPDO-Map Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1A00:0 | RMB TxPDO-Map Status | PDO Mapping RxPDO-Map Status | UINT8 | RO | 0x0C (12dec)
1A00:01 | Subindex 001 | 1. PDO Mapping entry (1 bits align) | OCTET-STRING[10] | RO | 0x0000:00, 1
1A00:02 | Subindex 002 | 2. PDO Mapping entry (object 0x6000 (RMB inputs), entry 0x02 (Overrange)) | OCTET-STRING[10] | RO | 0x6000:02, 1
1A00:03 | Subindex 003 | 3. PDO Mapping entry (1 bits align) | OCTET-STRING[10] | RO | 0x0000:00, 1
1A00:04 | Subindex 004 | 4. PDO Mapping entry (object 0x6000 (RMB inputs), entry 0x04 (Data invalid)) | OCTET-STRING[10] | RO | 0x6000:04, 1
1A00:05 | Subindex 005 | 5. PDO Mapping entry (2 bits align) | OCTET-STRING[10] | RO | 0x0000:00, 2
1A00:06 | Subindex 006 | 6. PDO Mapping entry (object 0x6000 (RMB inputs), entry 0x07 (Error)) | OCTET-STRING[10] | RO | 0x6000:07, 1
1A00:07 | Subindex 007 | 7. PDO Mapping entry (object 0x6000 (RMB inputs), entry 0x08 (Calibration in progress)) | OCTET-STRING[10] | RO | 0x6000:08, 1
1A00:08 | Subindex 008 | 8. PDO Mapping entry (object 0x6000 (RMB inputs), entry 0x09 (Steady state)) | OCTET-STRING[10] | RO | 0x6000:09, 1
1A00:09 | Subindex 009 | 9. PDO Mapping entry (4 bits align) | OCTET-STRING[10] | RO | 0x0000:00, 4
1A00:0A | Subindex 010 | 10. PDO Mapping entry (object 0x6000 (RMB inputs), entry 0x0E (Sync error)) | OCTET-STRING[10] | RO | 0x6000:0E, 1
1A00:0B | Subindex 011 | 11. PDO Mapping entry (1 bits align) | OCTET-STRING[10] | RO | 0x0000:00, 1
1A00:0C | Subindex 012 | 12. PDO Mapping entry (object 0x6000 (RMB inputs), entry 0x10 (TxPDO Toggle)) | OCTET-STRING[10] | RO | 0x6000:10, 1
Index 1A01 RMB TxPDO-Map Value (INT32)
Index (hex) | Name | Meaning | Data type | Flags | Default
1A01:0 | RMB TxPDO-Map Value (INT32) | PDO Mapping Value (INT32) | UINT8 | RW | 0x01 (1dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (RMB inputs), entry 0x11 (Value)) | UINT32 | RW | 0x6000:11, 32
Index 1A02 RMB TxPDO-Map Value (Real)
Index (hex) | Name | Meaning | Data type | Flags | Default
1A02:0 | RMB TxPDO-Map Value (real) | PDO Mapping Value (real) | UINT8 | RW | 0x01 (1dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (RMB inputs), entry 0x12 (Value (real))) | UINT32 | RW | 0x6000:12, 32
Index 1A03 RMB TxPDO-Map Timestamp (EL3356)
Index (hex) | Name | Meaning | Data type | Flags | Default
1A03:0 | RMB TxPDO-Map Timestamp | PDO Mapping Value Timestamp | UINT8 | RW | 0x01 (1dec)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x0000, entry 0x00) | UINT64 | RW | 0x0000:00, 64
Index 1A03 RMB TxPDO-Map Timestamp (EL3356-0010, EL3356-0090)
Index (hex) | Name | Meaning | Data type | Flags | Default
1A03:0 | RMB TxPDO-Map Timestamp | PDO Mapping Value Timestamp | UINT8 | RW | 0x01 (1dec)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (RMB Inputs), entry 0x13 (Timestamp)) | UINT64 | RW | 0x6000:13, 64
Index 1A04 AI TxPDO-Map Standard Ch. 1 (EL3356, EL3356-0010)
Index (hex) | Name | Meaning | Data type | Flags | Default
1A04:0 | AI supply TxPDO-Map Standard Ch. 1 | PDO Mapping TxPDO Standard Ch. 1 | UINT8 | RW | 0x07 (7dec)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (AI supply Inputs), entry 0x01 (Underrange)) | UINT32 | RW | 0x6010:01, 1
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (AI supply Inputs), entry 0x02 (Overrange)) | UINT32 | RW | 0x6010:02, 1
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (4 bits align) | UINT32 | RW | 0x0000:00, 4
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (AI supply Inputs), entry 0x04 (Error)) | UINT32 | RW | 0x6010:07, 1
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
1A04:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010, entry 0x10 (TxPDO Toggle)) | UINT32 | RW | 0x6010:10, 1
1A04:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010, entry 0x11 (Value)) | UINT32 | RW | 0x6010:11, 32
Index 1A04 AI TxPDO-Map Standard Ch. 1 (EL3356-0090)
Index (hex) | Name | Meaning | Data type | Flags | Default
1A04:0 | AI supply TxPDO-Map Standard Ch. 1 | PDO Mapping TxPDO Standard Ch. 1 | UINT8 | RW | 0x08 (8dec)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (AI supply Inputs), entry 0x01 (Underrange)) | UINT32 | RW | 0x6010:01, 1
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (AI supply Inputs), entry 0x02 (Overrange)) | UINT32 | RW | 0x6010:02, 1
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (4 bits align) | UINT32 | RW | 0x0000:00, 4
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (AI supply Inputs), entry 0x04 (Error)) | UINT32 | RW | 0x6010:07, 1
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (1 bits align) | UINT32 | RW | 0x0000:00, 1
1A04:06 | SubIndex 006 | 6. PDO Mapping entry (7 bits align) | UINT32 | RW | 0x0000:00, 7
1A04:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010, entry 0x10 (TxPDO Toggle)) | UINT32 | RW | 0x6010:10, 1
1A04:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010, entry 0x11 (Value)) | UINT32 | RW | 0x6010:11, 32
Index 1A05 AI TxPDO-Map Compact Ch. 1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A05:0 | AI supply TxPDO-Map Compact Ch. 1 | PDO Mapping TxPDO Compact Ch. 1 | UINT8 | RW | 0x01 (1dec)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010, entry 0x11 (Value)) | UINT32 | RW | 0x6010:11, 32
Index 1A06 AI TxPDO-Map Standard Ch. 2 (EL3356, EL3356-0010)
Index (hex) | Name | Meaning | Data type | Flags | Default
1A06:0 | AI supply TxPDO-Map Standard Ch. 2 | PDO Mapping TxPDO Standard Ch. 2 | UINT8 | RW | 0x07 (7dec)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (AI supply Inputs), entry 0x01 (Underrange)) | UINT32 | RW | 0x6020:01, 1
1A06:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (AI supply Inputs), entry 0x02 (Overrange)) | UINT32 | RW | 0x6020:02, 1
1A06:03 | SubIndex 003 | 3. PDO Mapping entry (4 bits align) | UINT32 | RW | 0x0000:00, 4
1A06:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (AI supply Inputs), entry 0x04 (Error)) | UINT32 | RW | 0x6020:07, 1
1A06:05 | SubIndex 005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
1A06:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6020, entry 0x10 (TxPDO Toggle)) | UINT32 | RW | 0x6020:10, 1
1A06:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020, entry 0x11 (Value)) | UINT32 | RW | 0x6020:11, 32
Index 1A06 AI TxPDO-Map Standard Ch. 2 (EL3356-0090)
Index (hex) | Name | Meaning | Data type | Flags | Default
1A06:0 | AI supply TxPDO-Map Standard Ch. 2 | PDO Mapping TxPDO Standard Ch. 2 | UINT8 | RW | 0x07 (7dec)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (AI supply Inputs), entry 0x01 (Underrange)) | UINT32 | RW | 0x6020:01, 1
1A06:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (AI supply Inputs), entry 0x02 (Overrange)) | UINT32 | RW | 0x6020:02, 1
1A06:03 | SubIndex 003 | 3. PDO Mapping entry (4 bits align) | UINT32 | RW | 0x0000:00, 4
1A06:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (AI supply Inputs), entry 0x04 (Error)) | UINT32 | RW | 0x6020:07, 1
1A06:05 | SubIndex 005 | 5. PDO Mapping entry (1 bits align) | UINT32 | RW | 0x0000:00, 1
1A06:06 | SubIndex 006 | 6. PDO Mapping entry (7 bits align) | UINT32 | RW | 0x0000:00, 7
1A06:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020, entry 0x10 (TxPDO Toggle)) | UINT32 | RW | 0x6020:10, 1
1A06:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6020, entry 0x11 (Value)) | UINT32 | RW | 0x6020:11, 32
Index 1A07 AI TxPDO-Map Compact Ch. 2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A07:0 | AI supply TxPDO-Map Compact Ch. 2 | PDO Mapping TxPDO Compact Ch. 2 | UINT8 | RW | 0x01 (1dec)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020, entry 0x11 (Value)) | UINT32 | RW | 0x6020:11, 32
Index 1C00 Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the sync managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign (EL3356, EL3356-0010)
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x02 (2dec)
1C12:01 | Subindex 001 | 1. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1600 (5632dec)
1C12:02 | Subindex 002 | 2. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | -
Index 1C12 RxPDO assign (EL3356-0090)
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x02 (2dec)
1C12:01 | Subindex 001 | 1. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1600 (5632dec)
1C12:02 | Subindex 002 | 2. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1610 (5648dec)
1C12:03 | Subindex 003 | 3. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | -
Index 1C13 TxPDO assign (EL3356, EL3356-0010)
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x02 (2dec)
1C13:01 | Subindex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A01 (6657dec)
1C13:03 | Subindex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | -
Index 1C13 TxPDO assign (EL3356-0090)
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x03 (3dec)
1C13:01 | Subindex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A01 (6657dec)
1C13:03 | Subindex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A10 (6672dec)
1C13:04 | Subindex 004 | 4. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | -
Index 1C32 SM output parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C32:0
SM output parameter
Synchronization parameters for the outputs
UINT8
RO
0x20 (32dec)
1C32:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dec)
1C32:02
Cycle time
Cycle time (in ns):
▪
Free Run: Cycle time of the local timer
▪
Synchronous with SM 2 event: Master cycle time
▪
DC mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000C65D4 (812500dec)
1C32:03
Shift time
Time between SYNC0 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0 = 1: free run is supported
▪
Bit 1 = 1: Synchronous with SM 2 event is supported
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 10: Output shift with SYNC1 event (only DC mode)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08)
UINT16
RO
0x4C06 (19462dec)
1C32:05
Minimum cycle time
Minimum cycle time (in ns)
UINT32
RO
0x000186A0 (100000dec)
1C32:06
Calc and copy time
Minimum time between SYNC0 and SYNC1 event (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:07
Minimum delay time
Minimum time between SYNC1 event and output of the outputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C32:08
Command
▪
0: Measurement of the local cycle time is stopped
▪
1: Measurement of the local cycle time is started
The entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 are updated with the maximum measured values.
For a subsequent measurement the measured values are reset
UINT16
RW
0x0000 (0dec)
1C32:09
Maximum Delay time
Time between SYNC1 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:0B
SM event missed counter
Number of missed SM events in OPERATIONAL (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:0C
Cycle exceeded counter
Number of occasions the cycle time was exceeded in OPERATIONAL (cycle was not completed in time or the next cycle began too early)
UINT16
RO
0x0000 (0dec)
1C32:0D
Shift too short counter
Number of occasions that the interval between SYNC0 and SYNC1 event was too short (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:20
Sync error
The synchronization was not correct in the last cycle (outputs were output too late; DC mode only)
BOOLEAN
RO
0x00 (0dec)
Index 1C33 SM input parameter
Index
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchronous with SM 3 event (no outputs available)
▪
2: DC - Synchronous with SYNC0 Event
▪
3: DC - Synchronous with SYNC1 Event
▪
34: Synchronous with SM 2 event (outputs available)
UINT16
RW
0x0022 (34dec)
1C33:02
Cycle time
as 0x1C32:02
UINT32
RW
0x000C65D4 (812500dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: synchronous with SM 2 event is supported (outputs available)
▪
Bit 1: synchronous with SM 3 event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: input shift through local event (outputs available)
▪
Bit 4-5 = 10: input shift with SYNC1 event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08 or 0x1C33:08)
UINT16
RO
0x4C06 (19462dec)
1C33:05
Minimum cycle time
as 0x1C32:05
UINT32
RO
0x000186A0 (100000dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:07
Minimum delay time
UINT32
RO
0x00000000 (0dec)
1C33:08
Command
as 0x1C32:08
UINT16
RW
0x0000 (0dec)
1C33:09
Maximum Delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:0B
SM event missed counter
as 0x1C32:11
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
as 0x1C32:12
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
as 0x1C32:13
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
as 0x1C32:32
BOOLEAN
RO
0x00 (0dec)
Index F000 Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index spacing of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | EL3356, EL3356-0010: 0x0003 (3dec) EL3356-0090: 0x0004 (4dec)
Index F008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module list
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list | Max. subindex | UINT8 | RW | 0x03 (3dec)
F010:01 | SubIndex 001 | RMB | UINT32 | RW | 0x00000172 (370dec)
F010:02* | SubIndex 002 | TSC | UINT32 | RW | 0x000003B6 (950dec)
*) EL3351-0090 only


EL3356-0090 - Objects TwinSAFE Single Channel

Commissioning [image] EL3356-0090 - Objects TwinSAFE Single Channel
EL3356-0090 - Objects TwinSAFE Single Channel
Index 1610 TSC RxPDO-Map Master Message
Index (hex) | Name | Meaning | Data type | Flags | Default
1610:0 | TSC RxPDO-Map Master Message | PDO Mapping RxPDO | UINT8 | RO | 0x04 (4dec)
1610:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7030 (TSC Master Frame Elements), entry 0x01 (TSC__Master Cmd)) | UINT32 | RO | 0x7030:01, 8
1610:02 | SubIndex 002 | 2. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1610:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7030 (TSC Master Frame Elements), entry 0x03 (TSC__Master CRC_0)) | UINT32 | RO | 0x7030:03, 16
1610:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7030 (TSC Master Frame Elements), entry 0x02 (TSC__Master ConnID)) | UINT32 | RO | 0x7030:02, 16
Index 1A10 TxPDO-Map Slave Message
Index (hex) | Name | Meaning | Data type | Flags | Default
1A10:0 | TxPDO-Map Slave Message | PDO Mapping TxPDO | UINT8 | RW | 0x06 (6dec)
1A10:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6030 (TSC Slave Frame Elements), entry 0x01 (TSC__Slave Cmd)) | UINT32 | RW | 0x6030:01, 8
1A10:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x11 (Value)) | UINT32 | RW | 0x6000:11, 16
1A10:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6030 (TSC Slave Frame Elements), entry 0x03 (TSC__Slave_CRC_0)) | UINT32 | RW | 0x6030:03, 16
1A10:04 | SubIndex 004 | 4. PDO Mapping entry (16 bits align) | UINT32 | RW | 0x0000:00, 16
1A10:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6030 (TSC Slave Frame Elements), entry 0x04 (TSC__Slave_CRC_1)) | UINT32 | RW | 0x6030:04, 16
1A10:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6030 (AI Inputs), entry 0x02 (TSC__Slave ConnID)) | UINT32 | RW | 0x6030:02, 16
Index 6030 TSC Slave Frame Elements
Index (hex) | Name | Meaning | Data type | Flags | Default
6030:0 | TSC Slave Frame Elements | Max. Subindex | UINT8 | RO | 0x04 (dec)
6030:01 | TSC__Slave Cmd | reserved | UINT8 | RO | 0x00 (0dec)
6030:02 | TSC__Slave ConnID | reserved | UINT16 | RO | 0x0000 (0dec)
6030:03 | TSC__Slave CRC_0 | reserved | UINT16 | RO | 0x0000 (0dec)
6030:04 | TSC__Slave CRC_1 | reserved | UINT16 | RO | 0x0000 (0dec)
Index 7030 TSC Master Frame Elements
Index (hex) | Name | Meaning | Data type | Flags | Default
7030:0 | TSC Master Frame Elements | Max. Subindex | UINT8 | RO | 0x03 (3dec)
7030:01 | TSC__Master Cmd | reserved | UINT8 | RO | 0x00 (0dec)
7030:02 | TSC__Master ConnID | reserved | UINT16 | RO | 0x0000 (0dec)
7030:03 | TSC__Master CRC_0 | reserved | UINT16 | RO | 0x0000 (0dec)
Index 8030 TSC Settings
Index (hex) | Name | Meaning | Data type | Flags | Default
8030:0 | TSC Settings | Max. Subindex | UINT8 | RO | 0x02 (2dec)
8030:01 | Address | TwinSAFE SC Address | UINT16 | RO | 0x0000 (0dec)
8030:02 | Connection Mode | Selection of the TwinSAFE SC CRC | UINT32 | RO | 0x00000000 (0dec)


Sample Program

Commissioning [image] Sample Program
Sample Program
Using the sample programs
This document contains sample applications of our products for certain areas of application. The application notes provided here are based on typical features of our products and only serve as examples. The notes contained in this document explicitly do not refer to specific applications. The customer is therefore responsible for assessing and deciding whether the product is suitable for a particular application. We accept no responsibility for the completeness and correctness of the source code contained in this document. We reserve the right to modify the content of this document at any time and accept no responsibility for errors and missing information.
Download
In this example program an EL3356 is addressed by a PLC program. The contains the PLC *.pro and the System Manager *.tsm.
The terminal can be operated via simple visualisation; the function InputFreeze is programmed out by way of example.
Use of the example program
The EL3356 terminal is to be connected as shown below:
Connection of the load sensor/full bridge
An EL9510 power supply terminal is used here to feed the strain gauge with 10 V.
Procedure for starting the program
▪
After clicking the Download button, save the zip file locally on your hard disk, and unzip the *.TSM (configuration) and the *.PRO (PLC program) files into a temporary working folder.
▪
Run the *.TSM file and the *.PRO file; the TwinCAT System Manager and TwinCAT PLC will open.
▪
Connect the hardware in accordance with fig. Connection for sample program and connect the Ethernet adapter of your PC to the EtherCAT coupler (further information on this can be found in the corresponding coupler manuals)
▪
Select the local Ethernet adapter (with real-time driver, if applicable) under System configuration, I/O configuration, I/O devices, Device (EtherCAT); then on the “Adapter” tab choose “Search...”, select the appropriate adapter and confirm (see Fig. Searching the Ethernet adapter + Selection and confirmation of the Ethernet adapter).
Searching the Ethernet adapter
Selection and confirmation of the Ethernet adapter
▪
Activate and confirm the configuration (Fig. Activation of the configuration + Confirming the activation of the configuration)
Activation of the configuration
Confirming the activation of the configuration
▪
Confirm new variable mapping, restart in RUN mode (Fig. Generate variable mapping + Restarting TwinCAT in RUN mode)
Generating variable mapping
Restarting TwinCAT in RUN mode
▪
In TwinCAT PLC, under the “Project” menu, select “Rebuild all” to compile the project (Fig. Compile project)
Compile project
▪
In TwinCAT PLC: log in with the “F11” button, confirm loading the program (Fig. Confirming program start), run the program with the “F5” button
Confirming program start


Appendix

Appendix
Appendix
Additional information
•
EtherCAT AL Status Codes
•
Firmware compatibility
•
Firmware Update EL/ES/EM/ELM/EPxxxx
•
Restoring the delivery state
•
Support and Service


EtherCAT AL Status Codes

Appendix [image] EtherCAT AL Status Codes
EtherCAT AL Status Codes
For detailed information please refer to the EtherCAT system description.


Firmware compatibility

Appendix [image] Firmware compatibility
Firmware compatibility
Beckhoff EtherCAT devices are delivered with the latest available firmware version. Compatibility of firmware and hardware is mandatory; not every combination ensures compatibility. The overview below shows the hardware versions on which a firmware can be operated.
Note
▪
It is recommended to use the newest possible firmware for the respective hardware
▪
Beckhoff is not under any obligation to provide customers with free firmware updates for delivered products.
Note
Risk of damage to the device!
Pay attention to the instructions for firmware updates on the separate page.
If a device is placed in BOOTSTRAP mode for a firmware update, it does not check when downloading whether the new firmware is suitable.
This can result in damage to the device! Therefore, always make sure that the firmware is suitable for the hardware version!
EL3356-0000
Hardware (HW) | Firmware | Revision no. | Date of release
03 - 09 | 03 | EL3356-0000-0017 | 2012/02
 |  | EL3356-0000-0018 | 2012/05
 | 04 |  | 2012/05
 |  | EL3356-0000-0019 | 2012/06
 |  | EL3356-0000-0020 | 2012/07
 | 05 | EL3356-0000-0021 | 2014/01
 | 06 |  | 2014/04
 | 07 | EL3356-0000-0022 | 2014/07
 | 08 |  | 2014/08
 | 09 |  | 2014/09
 |  | EL3356-0000-0023 | 2016/09
 |  | EL3356-0000-0024 | 2017/07
10 - 11* | 10* | EL3356-0000-0025 | 2018/04
EL3356-0010
Hardware (HW) | Firmware | Revision no. | Date of release
03 - 12* | 03 | EL3356-0010-0017 | 2012/02
 |  | EL3356-0010-0018 | 2012/05
 | 04 |  | 2012/05
 |  | EL3356-0010-0019 | 2012/06
 |  | EL3356-0010-0020 | 2012/07
 | 05 | EL3356-0010-0021 | 2014/01
 | 06 |  | 2014/04
 | 07 | EL3356-0010-0022 | 2014/07
 | 08 |  | 2014/08
 | 09 |  | 2014/09
 |  | EL3356-0010-0023 | 2016/09
 |  | EL3356-0010-0024 | 2017/07
 | 10* | EL3356-0010-0025 | 2018/04
EL3356-0090
Hardware (HW) | Firmware | Revision no. | Date of release
09 - 11* | 10* | EL3356-0090-0025 | 2018/04
*) This is the current compatible firmware/hardware version at the time of the preparing this documentation. Check on the Beckhoff web page whether more up-to-date documentation is available.


Firmware Update EL/ES/EM/ELM/EPxxxx

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx
Firmware Update EL/ES/EM/ELM/EPxxxx
This section describes the device update for Beckhoff EtherCAT slaves from the EL/ES, ELM, EM, EK and EP series. A firmware update should only be carried out after consultation with Beckhoff support.
Storage locations
An EtherCAT slave stores operating data in up to three locations:
▪
Depending on functionality and performance EtherCAT slaves have one or several local controllers for processing I/O data. The corresponding program is the so-called firmware in *.efw format.
▪
In some EtherCAT slaves the EtherCAT communication may also be integrated in these controllers. In this case the controller is usually a so-called FPGA chip with *.rbf firmware.
▪
In addition, each EtherCAT slave has a memory chip, a so-called ESI-EEPROM, for storing its own device description (ESI: EtherCAT Slave Information). On power-up this description is loaded and the EtherCAT communication is set up accordingly. The device description is available from the download area of the Beckhoff website at (https://www.beckhoff.de). All ESI files are accessible there as zip files.
Customers can access the data via the EtherCAT fieldbus and its communication mechanisms. Acyclic mailbox communication or register access to the ESC is used for updating or reading of these data.
The TwinCAT System Manager offers mechanisms for programming all three parts with new data, if the slave is set up for this purpose. Generally the slave does not check whether the new data are suitable, i.e. it may no longer be able to operate if the data are unsuitable.
Simplified update by bundle firmware
The update using so-called bundle firmware is more convenient: in this case the controller firmware and the ESI description are combined in a *.efw file; during the update both the firmware and the ESI are changed in the terminal. For this to happen it is necessary
▪
for the firmware to be in a packed format: recognizable by the file name, which also contains the revision number, e.g. ELxxxx-xxxx_REV0016_SW01.efw
▪
for password=1 to be entered in the download dialog. If password=0 (default setting) only the firmware update is carried out, without an ESI update.
▪
for the device to support this function. The function usually cannot be retrofitted; it is a component of many new developments from year of manufacture 2016.
Following the update, its success should be verified
▪
ESI/Revision: e.g. by means of an online scan in TwinCAT ConfigMode/FreeRun – this is a convenient way to determine the revision
▪
Firmware: e.g. by looking in the online CoE of the device
Note
Risk of damage to the device!
✓
Note the following when downloading new device files
1.
Firmware downloads to an EtherCAT device must not be interrupted
2.
Flawless EtherCAT communication must be ensured. CRC errors or LostFrames must be avoided.
3.
The power supply must adequately dimensioned. The signal level must meet the specification.
⇨
In the event of malfunctions during the update process the EtherCAT device may become unusable and require re-commissioning by the manufacturer.
Additional information
•
Device description ESI file/XML
•
Firmware explanation
•
Updating controller firmware *.efw
•
FPGA firmware *.rbf
•
Simultaneous updating of several EtherCAT devices


Device description ESI file/XML

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Device description ESI file/XML
Device description ESI file/XML
Note
Attention regarding update of the ESI description/EEPROM
Some slaves have stored calibration and configuration data from the production in the EEPROM. These are irretrievably overwritten during an update.
The ESI device description is stored locally on the slave and loaded on start-up. Each device description has a unique identifier consisting of slave name (9 characters/digits) and a revision number (4 digits). Each slave configured in the System Manager shows its identifier in the EtherCAT tab:
Device identifier consisting of name EL3204-0000 and revision -0016
The configured identifier must be compatible with the actual device description used as hardware, i.e. the description which the slave has loaded on start-up (in this case EL3204). Normally the configured revision must be the same or lower than that actually present in the terminal network.
For further information on this, please refer to the EtherCAT system documentation.
Update of XML/ESI description
The device revision is closely linked to the firmware and hardware used. Incompatible combinations lead to malfunctions or even final shutdown of the device. Corresponding updates should only be carried out in consultation with Beckhoff support.
Display of ESI slave identifier
The simplest way to ascertain compliance of configured and actual device description is to scan the EtherCAT boxes in TwinCAT mode Config/FreeRun:
Scan the subordinate field by right-clicking on the EtherCAT device
If the found field matches the configured field, the display shows
Configuration is identical
otherwise a change dialog appears for entering the actual data in the configuration.
Change dialog
In this example in Fig. Change dialog, an EL3201-0000-0017 was found, while an EL3201-0000-0016 was configured. In this case the configuration can be adapted with the Copy Before button. The Extended Information checkbox must be set in order to display the revision.
Changing the ESI slave identifier
The ESI/EEPROM identifier can be updated as follows under TwinCAT:
▪
Trouble-free EtherCAT communication must be established with the slave.
▪
The state of the slave is irrelevant.
▪
Right-clicking on the slave in the online display opens the EEPROM Update dialog, Fig. EEPROM Update
EEPROM Update
The new ESI description is selected in the following dialog, see Fig. Selecting the new ESI. The checkbox Show Hidden Devices also displays older, normally hidden versions of a slave.
Selecting the new ESI
A progress bar in the System Manager shows the progress. Data are first written, then verified.
The change only takes effect after a restart.
Most EtherCAT devices read a modified ESI description immediately or after startup from the INIT. Some communication settings such as distributed clocks are only read during power-on. The EtherCAT slave therefore has to be switched off briefly in order for the change to take effect.


Firmware explanation

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Firmware explanation
Firmware explanation
Determining the firmware version
Determining the version on laser inscription
Beckhoff EtherCAT slaves feature serial numbers applied by laser. The serial number has the following structure: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with ser. no.: 12 10 03 02:
12 - week of production 12
10 - year of production 2010
03 - firmware version 03
02 - hardware version 02
Determining the version via the System Manager
The TwinCAT System Manager shows the version of the controller firmware if the master can access the slave online. Click on the E-Bus Terminal whose controller firmware you want to check (in the example terminal 2 (EL3204)) and select the tab CoE Online (CAN over EtherCAT).
CoE Online and Offline CoE
Two CoE directories are available:
• online: This is offered in the EtherCAT slave by the controller, if the EtherCAT slave supports this. This CoE directory can only be displayed if a slave is connected and operational.
• offline: The EtherCAT Slave Information ESI/XML may contain the default content of the CoE. This CoE directory can only be displayed if it is included in the ESI (e.g. “Beckhoff EL5xxx.xml”).
The Advanced button must be used for switching between the two views.
In Fig. Display of EL3204 firmware version the firmware version of the selected EL3204 is shown as 03 in CoE entry 0x100A.
Display of EL3204 firmware version
In (A) TwinCAT 2.11 shows that the Online CoE directory is currently displayed. If this is not the case, the Online directory can be loaded via the Online option in Advanced Settings (B) and double-clicking on AllObjects.


Updating controller firmware *.efw

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Updating controller firmware *.efw
Updating controller firmware *.efw
CoE directory
The Online CoE directory is managed by the controller and stored in a dedicated EEPROM, which is generally not changed during a firmware update.
Switch to the Online tab to update the controller firmware of a slave, see Fig. Firmware Update.
Firmware Update
Proceed as follows, unless instructed otherwise by Beckhoff support. Valid for TwinCAT 2 and 3 as EtherCAT master.
▪
Switch TwinCAT system to ConfigMode/FreeRun with cycle time >= 1 ms (default in ConfigMode is 4 ms). A FW-Update during real time operation is not recommended.
▪
Switch EtherCAT Master to PreOP
▪
Switch slave to INIT (A)
▪
Switch slave to BOOTSTRAP
▪
Check the current status (B, C)
▪
Download the new *efw file (wait until it ends). A pass word will not be neccessary usually.
▪
After the download switch to INIT, then PreOP
▪
Switch off the slave briefly (don't pull under voltage!)
▪
Check within CoE 0x100A, if the FW status was correctly overtaken.


FPGA firmware *.rbf

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] FPGA firmware *.rbf
FPGA firmware *.rbf
If an FPGA chip deals with the EtherCAT communication an update may be accomplished via an *.rbf file.
▪
Controller firmware for processing I/O signals
▪
FPGA firmware for EtherCAT communication (only for terminals with FPGA)
The firmware version number included in the terminal serial number contains both firmware components. If one of these firmware components is modified this version number is updated.
Determining the version via the System Manager
The TwinCAT System Manager indicates the FPGA firmware version. Click on the Ethernet card of your EtherCAT strand (Device 2 in the example) and select the Online tab.
The Reg:0002 column indicates the firmware version of the individual EtherCAT devices in hexadecimal and decimal representation.
FPGA firmware version definition
If the column Reg:0002 is not displayed, right-click the table header and select Properties in the context menu.
Context menu Properties
The Advanced Settings dialog appears where the columns to be displayed can be selected. Under Diagnosis/Online View select the '0002 ETxxxx Build' check box in order to activate the FPGA firmware version display.
Dialog Advanced Settings
Update
For updating the FPGA firmware
▪
of an EtherCAT coupler the coupler must have FPGA firmware version 11 or higher;
▪
of an E-Bus Terminal the terminal must have FPGA firmware version 10 or higher.
Older firmware versions can only be updated by the manufacturer!
Updating an EtherCAT device
The following sequence order have to be met if no other specifications are given (e.g. by the Beckhoff support):
▪
Switch TwinCAT system to ConfigMode/FreeRun with cycle time >= 1 ms (default in ConfigMode is 4 ms). A FW-Update during real time operation is not recommended.
▪
In the TwinCAT System Manager select the terminal for which the FPGA firmware is to be updated (in the example: Terminal 5: EL5001) and
click the Advanced Settings button in the EtherCAT tab:
▪
The Advanced Settings dialog appears. Under ESC Access/E²PROM/FPGA click on Write FPGA button:
▪
Select the file (*.rbf) with the new FPGA firmware, and transfer it to the EtherCAT device:
▪
Wait until download ends
▪
Switch slave current less for a short time (don't pull under voltage!). In order to activate the new FPGA firmware a restart (switching the power supply off and on again) of the EtherCAT device is required.
▪
Check the new FPGA status
Note
Risk of damage to the device!
A download of firmware to an EtherCAT device must not be interrupted in any case! If you interrupt this process by switching off power supply or disconnecting the Ethernet link, the EtherCAT device can only be recommissioned by the manufacturer!


Simultaneous updating of several EtherCAT devices

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Simultaneous updating of several EtherCAT devices
Simultaneous updating of several EtherCAT devices
The firmware and ESI descriptions of several devices can be updated simultaneously, provided the devices have the same firmware file/ESI.
Multiple selection and firmware update
Select the required slaves and carry out the firmware update in BOOTSTRAP mode as described above.


Restoring the delivery state

Appendix [image] Restoring the delivery state
Restoring the delivery state
To restore the delivery state for backup objects in ELxxxx terminals, the CoE object Restore default parameters, SubIndex 001 can be selected in the TwinCAT System Manager (Config mode) (see Fig. Selecting the Restore default parameters PDO)
Selecting the Restore default parameters PDO
Double-click on SubIndex 001 to enter the Set Value dialog. Enter the value 1684107116 in field Dec or the value 0x64616F6C in field Hex and confirm with OK (Fig. Entering a restore value in the Set Value dialog).
All backup objects are reset to the delivery state.
Entering a restore value in the Set Value dialog
Alternative restore value
In some older terminals the backup objects can be switched with an alternative restore value: Decimal value: 1819238756, Hexadecimal value: 0x6C6F6164An incorrect entry for the restore value has no effect.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com