EL320x - Input terminals Pt100 (RTD)

BECKHOFF Fieldbus Components

Documentation for

EL3201, EL3202, EL3204

1-, 2-, 4 channel input terminals Pt100 (RTD)

EL3201-0010, EL3202-0010

1-, 2 channel input terminals Pt100 (RTD), high-precision

EL3201-0020, EL3202-0020

1-, 2 channel input terminals Pt100 (RTD), high-precision with calibration certificate

EL3204-0200

4 channel universal input terminal for RTD up to 240 kΩ, NTC 20 k, 16 bit

Version: 3.1
Date: 2015-04-01

EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.


Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending

The EtherCAT Technology is covered, including but not limited to the following patent applications and patents:
EP1590927, EP1789857, DE102004044764, DE102007017835
with corresponding applications or registrations in various other countries.

The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.

Copyright

© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Safety rules

Consider the following safety instructions and descriptions!
Product specific safety instructions are to be found on the following pages or in the areas mounting, wiring, commissioning etc.

Disclaimer

All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.

Personnel qualification

This description is only intended for the use of trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.

Description of symbols

The following symbols with a adjoining safety advise or notice are used in this documentation. You have to read the safety advices carefully and adhere them strictly!

DANGER 		Acute risk of injury!
If you do not adhere the safety advise adjoining this symbol, there is immediate danger to life and health of individuals!

WARNING 		Risk of injury!
If you do not adhere the safety advise adjoining this symbol, there is danger to life and health of individuals!

CAUTION 		Hazard to individuals!
If you do not adhere the safety advise adjoining this symbol, there is obvious hazard to individuals!

Attention 		Hazard to devices and environment
If you do not adhere the notice adjoining this symbol, there is obvious hazard to materials and environment.

Note 		Note or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Version | Comment
3.1 | - Update chapter "Technical data" - Addenda chapter "Installation instructions for enhanced mechanical load capacity" - Update structure - Update revision status
3.0 | - Structure update
2.9 | - EL3204-0200 added - Structure update
2.8 | - Chapter "Technology" updated
2.7 | - Chapter "Technology of RTD Measurement" updated, EL3204-0200 added
2.6 | - Chapter "Technology" updated
2.5 | - Chapter "RTD technology" added
2.4 | - Update chapter "Technology"
2.3 | - Note "Connection note for analog signal cable" added
2.2 | - Note "calibration certificate" added - Update structure
2.1 | - EL3202-0020 added
2.0 | - Data flow scheme added, Technical data added
1.9 | - Technical data added
1.8 | - Technical data added
1.7 | - Technical addenda and corrections
1.6 | - Technical data added, EL3202-0010 added
1.5 | - KT/KTY characteristic curves added, addenda limit
1.4 | - Technical data corrected
1.3 | - Technical data corrected
1.2 | - EL3201-0010, EL3201-0020 added
1.1 | - Technical data corrected
1.0 | - Technical data added, first public issue
0.2 | - Technical data added
0.1 | - Preliminary documentation for EL320x


Version identification

BECKHOFF: Foreword

Version identification of EtherCAT devices

Designation

A Beckhoff EtherCAT device has a 14-digit designation, made up of

  • family key
  • type
  • version
  • revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017

Notes

  • the elements named above make up the technical designation
  • The order designation, conversely, is made up of
    - family key (EL, EP, CU, ES, KL, CX, etc.
    - type
    - version
  • The revision shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
    In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
    Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff website.
    The revision has been applied to the IP20 terminals on the outside since 2014/01, see fig. 1.
  • The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.

Identification number

Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:

Production lot/batch number/serial number/date code/D number

Serial number is the name generally given to the 8-digit number that is printed on the device or attached to it on a sticker. This serial number indicates the as-built status on delivery and thus ambiguously marks a whole production lot.

Structure of the serial number: KK YY FF HH

KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version

Example with ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02

Exceptions can occur in the IP67 area , where the following syntax can be used (see respective device documentation):

Syntax: D ww yy x y z u

D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB

Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1

Unique serial number/ID

Beyond that there are some series in which each individual module has its own unique, sequential serial number.

See also the further documentation in the area

  • IP67: EtherCAT Box
  • Safety: TwinSafe
Examples of markings:

Fig. 1: EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)

Fig. 2: EK1100 EtherCAT coupler, standard IP20 IO device with batch number

Fig. 3: CU2016 switch with batch number

Fig. 4: EL3202-0020 with batch numbers 26131006 and unique D-number 204418

Fig. 5: EP1258-00001 IP67 EtherCAT Box with batch number 22090101 and serial number 158102

Fig. 6: EP1908-0002 IP76 EtherCAT Safety Box with batch number 071201FF and serial number 00346070

Fig. 7: EL2904 IP20 safety terminal with batch number/date code 50110302 and serial number 00331701


EL320x - Introduction

BECKHOFF EL320x: Product Overview

Introduction

1-, 2-, 4 channel input terminals Pt100 (RTD)

The EL320x analog input terminals allow resistance sensors to be connected directly. The EL3204 circuitry can operate 2 wire sensors, the EL3202 2- and 3 wire sensors. The EL3201 can operate 4 wire versions in addition. Several characteristic sensor curves (PT100, PT1000, NI120, NI1000, KTY types and others) are supported.

The EL3201-0010 is the high-precision version of the 1 channel terminal (EL3202-0010; 2 channel) with a measuring error < ±0.1°C for PT sensors (40°C ambient temperature). These terminals can operate 4 wire sensors. The EL3201-0020 and EL3202-0020 will be delivered with a calibration certificate in addition.

The terminals from the EL320x-xxxx series can measure the temperature at the measuring point or directly output the resistance values of the sensors. For temperature measurements the temperature value is calculated via the characteristic curves stored in the terminal.

The EL3204-0200 can be used with any RTD in the range of 100 Ohm to 240 kOhm. The resistance values are converted (linearization) in the terminal either based on preset characteristic curves, conversion formulas with specific material parameters (e.g. according to IEC 60751, Steinhart-Hart equation, B-parameter equation), or a freely programmable conversion table.

A microprocessor handles linearization across the whole temperature range, which is freely selectable. The EtherCAT Terminal’s standard settings are: resolution 0.1 °C in the temperature range of Pt100 sensors in 3-wire connection. The EtherCAT Terminals indicate their signal state by means of light emitting diodes. Sensor malfunctions such as broken wires are indicated by error LEDs.

Quick-Links

• EtherCAT basics
• Technology EL320x
• Creation of the TwinCAT configuration
• Object description and parameterization
• Status word
• Process data and operation modes
• Settings and application notes EL320x-00xx

• Settings and application notes EL3204-0200


Technology

BECKHOFF EL320x: Commissioning

Technology of RTD measurement

Contents
• Functionality
- Notices regarding series EL320x-0010/-0020 (high-precision)

• Ratiometric voltage measurement
• Connection techniques
 - Example of line compensation in the 2-wire mode
• Overview of suitable resistance sensors

Functionality

The EL320x-xxxx analog input terminals enable resistance sensors in the range 0 - 4096 ohms to be connected directly (EL3204-0200: up to 240 kOhm, see special notes!)

Functions:

  • Resistance measurement
    • Measuring range 0 to 1047 Ω: Resolution 1/64 Ohm
    • Measuring range 0 to 4095 Ω: Resolution 1/16 Ohm
    • The use of the terminal in the range from 0 to 10 ohms is not recommended due to the relatively low measuring accuracy. Resistance measuring terminals such as the EL3692 with 4-wire measurement are to be used for such measurements.
    • EL3201 and EL3202: it is mandatory to connect the +R and +RL contacts with an external jumper in 3-wire mode.
  • Temperature measurement
    The measured sensor resistance is converted directly into a temperature by the internal µC via the desired linearization characteristic curve
    • Standard resolution 1/10 °C (1 digit = 0.1 °C) according to a theoretically representable temperature range [- 3276.7 to 3276.8 °C]
      The physically specified temperature range for the respective sensor is to be observed!
    • Various PTC sensor characteristic curves are implemented over their complete measuring range for selection in the EL320x series: Pt/Ni xxxx, KTY xx
    • Scaling and presentation can be changed
    • If a sensor is to be used that is not already implemented in the EL320x, the EL3204-0200 can be used
      Due to its free programmability, the EL3204-0200 can be adjusted to any sensor characteristic curve in the permissible resistance range.

Additional notes:

  • The resistance is determined by means of ratiometric voltage measurement, see below..
  • The error state ‘wire breakage’ is detected as overrange, signalled as an error to the controller and indicated by the ERROR LED.
  • The error state ‘short-circuit’ is detected as underrange if the resistance is smaller than the smallest resistance of the measuring range, signalled as an error to the controller and indicated by the ERROR LED.
  • Characteristic curves for KT/KTY sensors are implemented from firmware 06 (EL3201, EL3202-xxxx, EL3204) and selectable via the CoE directory.
  • In the delivery state, the measured value is displayed in increments of 1/10° C in two's complement format (integer).
  • Other methods of display, e.g. high resolution with 1/100 °C can be selected via CoE 80n0:02.
    When using the high resolution a temperature range of -320 to +320 °C (-32566 to 32567) is measurable by the 2-byte PDO.

Fig. 1: Display of the measurement and calculation of the resistance/temperature

Notices regarding series EL320x-0010/-0020 (high-precision)

Thanks to its special hardware and software properties the EL320x-0010/0020 is able to measure the resistance value and thus the temperature with high accuracy. Please note:

Note 		Increased accuracy EL320x-00x0
In the case of the high-precision terminals the settings in the object 80n0 / RTD-Settings must not be changed! The high-precision resistance/temperature measurement can only be performed in the range 10 to 220 ohms, corresponding to a PT100 measuring range of -200 to 320 °C.
In order to be able to display the high accuracy, the 0.01 °C/digit display is preset. The increased accuracy of the EL320x-00x0 is therefore valid only for the following settings:
  • Resistance measurement or Pt100 characteristic curve (0.00385 Ω/Ω/°C, IEC60751 characteristic curve Pt385) – other characteristic curves are not guaranteed!
  • Ambient temperature of 40 °C
  • 4-wire connection technology
  • Measuring range -200 to +320 °C
  • 50 Hz filter

Temperatures or resistances outside of the range specified above cannot be measured with high precision. Outside these benchmark figures the high-precision terminal behaves like a terminal with standard accuracy.

Ratiometric voltage measurement

The EL320x-xxxx measures resistance ratiometrically by means of voltage comparison, see fig. 2:

  • A constant voltage of 2.5 V is applied across a highly precise known reference resistance Rref and the sensor Rt connected in series.
    • EL3204-0200: 120 kOhm reference resistor
    • All other EL320x: 5 kOhm reference resistor
  • The sensor resistance can be determined by comparing the two voltages, V1 at reference and V2 at the sensor
  • The measuring current through the sensor thus depends on the sensor resistance; this must be considered in questions of sensor self-heating
    Example: at 20 °C and thus 1000 ohms inherent resistance, a PT1000 thus causes a measuring current of 0.1 mA on an EL3204.

Note 		Wiring of the input channels
Due to this measurement principle (resistive temperature sensor), a sensor may not be connected in parallel to two or more input channels!

Connection techniques

The electrical connection of a resistance sensor to the EL320x can take place using the two-conductor, three-conductor or four-conductor (EL3201 only) methods. Since the measuring method is a resistance measurement, the sensor supply cables with their inherent resistance can falsify the measurement. The following are available for this:

Fig. 2: 4-wire and 3-wire connection technology

  • 4-wire sensors: Current conduction and voltage measurement take place via different cores. Since the voltage is measured by the El32xx with high impedance, the cores for the voltage measurement are subject to virtually no voltage drop.
  • 3-wire sensors: this simplified connection reduces wiring costs and compensates cable resistances to a considerable degree.
  • 2-wire sensors: very simple connection, recommended only for short supply cables
    The supply line resistances can be eliminated from the calculation in 2-wire mode if they are made known to the EL320x in the CoE object 80n0:1B (unit [1/32 Ω]). The determination of the supply line resistance is possible on the application side either by measurement or by comparison.

Note 		Two-conductor connection
If the EL3201/EL3202 is operated with a two-conductor connection, the inputs +R and +RL must be bridged by the user.

Example of line compensation in the 2-wire mode

The cross-sectional area of the 50 metre long copper wire connecting cable is 0.5 mm2. The specific resistance of copper is 0.0175 Ω mm2m-1

Determination of the total resistance of the feed cable:

RLtotal = 0.0175 Ω mm2 m-1 * (2 * 50 m / 0.5 mm2) = 3.5 Ω

In the case of a change of resistance of the Pt100 of ≈0.39 Ω/K this results in a temperature deviation of

3.5 Ω / (0.39 Ω/°C) = 8.97 °C

if the line resistance is not taken into account. If the 3.5 ohms are now entered in 8000:1B as

3.5 Ω / (1/32) Ω = 112dec,

this is subtracted from the measured value and the temperature is corrected accordingly.

Note 		Plug variant ES320x with Pt100 / Ni100 sensors
When using Pt100 / Ni100 sensors we recommend the use of the EL320x in order to avoid losses of accuracy due to transition resistances with the plug variant ES320x.

Overview of suitable resistance sensors

The following resistance sensors are suitable for temperature measurement with the EL320x-0000 (table 1) and can be selected via the object 80n0:19:

The free parameterizing EL3204-0020 should be used for special or differing characteristics (e.g. Pt375).

Type | Resistance range | Implemented temperature range
Pt100 (0,00385 Ω/Ω/°C, IEC60751 characteristic Pt385) | ~ 10 ... ~390 Ohm | -200°C to 850°C (for High Precision Terminals see notice!)
NI100 |  | -60°C to 250°
Pt1000 (0,00385 Ω/Ω/°C, IEC60751 characteristic Pt385) | ~180 ... ~ 3900 Ohm | -200°C to 850°C
Pt500 |  | -200°C to 850°C
Pt200 |  | -200°C to 1,370°C
NI1000 |  | -60°C to 250°C
NI1000 100°C: 1500 Ohm |  | -30 to 160°C
NI120 |  | -60°C to 320°C
KT100/110/130/210/230 KTY10/11/13/16/19 | ~500 ... ~2200 Ohm | -50...150°C
KTY81/82-110,120,150
KTY81-121
KTY81-122
KTY81-151
KTY81-152
KTY81/82-210,220,250
KTY81-221
KTY81-222
KTY81-251
KTY81-252
KTY83-110,120,150 | ~500 ... ~2500 Ohm | -50...175°C
KTY83-121
KTY83-122
KTY83-151
KTY83-152
KTY84-130,150 | ~350 ... ~2500 Ohm | -40...300°C
KTY84-151
KTY21/23-6 | ~500 ... ~4000 Ohm | -50...150°C
KTY1x-5
KTY1x-7
KTY21/23-5
KTY21/23-7

Table 1: Suitable resistance sensors for the EL320x-0000


EL320x - Technical data

BECKHOFF EL320x: Product Overview

Technical data

Technical data | EL3201 | EL3201-0010, EL3201-0020 | EL3202 | El3202-0010, EL3202-0020 | EL3204 | EL3204-0200
Number of inputs | 1 | 1 | 2 | 2 | 4 | 4
Sensor types | Pt100, Pt200, Pt500, Pt1000, Ni100, Ni120, Ni1000, KT/KTY from firmware 06 Resistance measurement 10 Ω…1 kΩ or 10 Ω…4 kΩ (e.g. potentiometer) |  |  |  |  | any RTD in the range of 100 Ω…240 kΩ
Connection method | 2-, 3-, 4-wire | 4-wire | 2- or 3-wire (default: 3-wire) | 4-wire | 2-wire | 2-wire
Temperature range | depends on range: -200…+850°C (PT sensors); -60…+250°C (Ni sensors) | depends on range: -200…+850°C (PT sensors); High Precision measurement only for Pt100 sensors, measurement range -200…+320°C, see notice! -60…+250°C (Ni sensors) | depends on range: -200…+850°C (PT sensors); -60…+250°C (Ni sensors) | depends on range: -200…+850°C (PT sensors); High Precision measurement only for Pt100 sensors, measurement range -200…+320°C, see notice! -60…+250°C (Ni sensors) | depends on range: -200…+850°C (PT sensors); -60…+250°C (Ni sensors) | depends on range
Resolution (default) | 0.1°C per digit | 0.01°C per digit | 0.1°C per digit | 0.01°C per digit | 0.1°C per digit | default: 0.1°C per digit for temperature measuring
Conversion time | approx. 4 .. 500 ms (configurable), depending on configuration and filter setting, approx. 24 ms default setting |  | approx. 800 ms .. 2 ms (configurable), depending on configuration and filter setting, approx. 85 ms default setting |  |  | approx. 4 - 500 ms (configurable), depending on configuration and filter setting approx. 24 ms, preset
Measuring current (depends on sensor element and temperature) | typ. 0.5 mA |  |  |  |  | typ. < 0.03 mA
Measuring error | < ±0.5°C for Pt sensors | < ±0.1°C (for Pt100 sensors, 40°C ambient temperature, 4 wire connection, measuring range -200 to 320°C), 50 Hz Filter | < ±0.5°C for Pt sensors | < ±0.1°C (for Pt100 sensors, 40°C ambient temperature, 4 wire connection, measuring range -200 to 320°C), 50 Hz Filter | < ±1.0°C for Pt sensors | < ±0.3% of the respective full scale value during resistance measurement
Bit width in the process image | max. 4 byte input |  | max. 8 byte input |  | max. 16 byte input | max. 16 byte input
Supply voltage for internal E-bus circuit | via the E-Bus
Current consumption E-bus | typ. 190 mA |  |  |  |  | typ. 150 mA
Electrical isolation | 500 V (E bus/field potential)
Configuration | no address setting, configuration via TwinCAT System Manager
Weight | approx. 60 g
Operating temperature | -25°C ... +60°C (extended temperature range) 0°C ... +55°C (according to cULus for Canada and USA) 0°C ... +55°C (according to ATEX, see special conditions) | 0°C ... +55°C | -25°C ... +60°C (extended temperature range) 0°C ... +55°C (according to cULus for Canada and USA) 0°C ... +55°C (according to ATEX, see special conditions) | 0°C ... +55°C | -25°C ... +60°C (extended temperature range) 0°C ... +55°C (according to cULus for Canada and USA) 0°C ... +55°C (according to ATEX, see special conditions) | 0°C ... +55°C
Storage temperature | -40°C ... + 85°C | -25°C ... + 85°C | -40°C ... + 85°C | -25°C ... + 85°C | -40°C ... + 85°C | -25°C ... + 85°C
Relative humidity | 95%, no condensation
Dimensions | approx. 15 mm x 100 mm x 70 mm (width aligned: 12 mm)
Mounting | on 35 mm mounting rail conforms to EN 60715
Vibration/shock resistance | conforms to EN 60068-2-6/EN 60068-2-27 |  | conforms to EN 60068-2-6/EN 60068-2-27, see Installation instructions for enhanced mechanical load capacity | conforms to EN 60068-2-6/EN 60068-2-27 | conforms to EN 60068-2-6/EN 60068-2-27, see Installation instructions for enhanced mechanical load capacity | conforms to EN 60068-2-6/EN 60068-2-27
EMC resistance burst/ESD | conforms to EN 61000-6-2/EN 61000-6-4
Protect. class | IP 20
Installation pos. | variable
Approval | CE


RTD technology

Certain materials change their electrical resistance if the temperature of the material changes. Thanks to this property they can be used as sensors for the measurement of temperature. Such an RTD element (Resistance Temperature Device) or thermistor then exhibits a well-known material-dependent property, i.e. how the resistance changes in relation to the temperature – the so-called characteristic. In an initial approximation this characteristic can be taken to be a linear equation:

The factor k can be positive or negative and must be specified by the sensor manufacturer:

  • positive coefficient (PTC): resistance increases with increasing temperature, i.e. it conducts less well; the sensor is then referred to as a PTC thermistor
  • negative coefficient (NTC): resistance increases with decreasing temperature, i.e. it conducts better; the sensor is then referred to as an NTC thermistor

The larger the coefficient, the higher the sensitivity of the sensor.

Note 		Temperature measurement
This kind of temperature measurement is to be distinguished from that using thermocouple sensors: these inherently generate a (small) voltage at the contact point of two different metals, which is then measured.

Within a very small measuring range nearly all materials can be described by such a linear characteristic. However, it is often necessary to measure over a large measuring range, e.g. several tens or hundreds of °K. Within such ranges the characteristic must be described for many materials by non-linear equations of a higher order or by using exponential components. Examples of such equations are

  • Platinum/PT sensors (PTC/posistors) according to IEC 60751:2008
    for the range -200.. 0 °C:

    for the range 0 °C..850 °C

    The coefficients A, B and C are to be specified by the sensor manufacturer or taken from the standard. The parameter R0 indicates the resistance in ohm of the platinum sensor at T = 0 °C. The sensor designations are based on these characteristics, e.g. for Pt100 R0 = 100 Ω at T=0 °C.
  • Steinhart-Hart (for NTC thermistor)

    The coefficients a, b, c should be specified by the sensor manufacturer, or they can be determined by measuring the resistance at three known temperatures.
  • B-parameter equation (for NTC thermistor)

    The coefficients RT0, B, T0 should be specified by the sensor manufacturer, or they can be determined by measuring the resistance at three known temperatures.
    The B-parameter equation is a simplified version of the Steinhart-Hart equation. The B-parameter itself is only constant in a small range, e.g. between 25°C.. 50°C or 25°C.. 85°C, which is identified as follows: B 25/50 or B25/85. The accuracy of the equation strongly depends on the B-parameter. The larger the measuring range, the lower the accuracy. If a larger measuring range required, it is preferable to use the Steinhart-Hart equation.
  • and others

A typical characteristic is shown for each of the NTC and PTC families in fig. 1:

Hence, there is no such thing as a general NTC or PTC sensor – in fact, they are names for sensor families with a certain behavior.

For common sensors/characteristics such as PT100, these characteristics are already permanently implemented into the measuring devices. The user must check whether a sensor that he intends to use is supported by the measuring device. The following criteria apply here:

  • Temperature range: does the sensor support the intended temperature range?
  • Measuring range: can the sensor resistance be measured in the intended temperature range?
  • Characteristic: can the measured resistance be converted accordingly into temperature? (base point, gradient/coefficient)
  • Velocity: how often is the resistance measured?

In a quite basic way, a sensor manufacturer can of course also publish the characteristic of its sensor as a value table.

Note 		Resistance measurement
To determine the resistance it is usual to pass a measuring current in the mA range (< 5 mA) through the sensor and to measure the resulting voltage. Three effects must be taken into consideration when doing this:
  • the measuring current can lead to self-heating of the sensor. However, this usually has only a minimal effect on the measuring accuracy.
    Special sensors tend to be used for cryogenic applications.
  • the sensor supply wires also always have a resistance and add a (usually) constant additional resistance to the measurement. This can be compensated by
    • 3 or 4-wire connection of the sensor
    • manually accounting for the known wire resistance in the calculation
    • using a sensor with a higher nominal resistance – the supply wire effects are then of less consequence
  • Insulation faults or thermovoltages can affect the measurement.

For classification there follows an overview of the NTC/PTC property of various sensors:

NTC | PTC
many semiconductors | many metals
various ceramics | various ceramics
NTC20, NTC100, etc. | Pt100, Pt1000, etc.
 | KTY, etc.
 | Ni100, Ni1000, etc.
 | FeT

Note 		Sensor exchange
Please note that 1:1 exchangeability is not always guaranteed, especially in the case of manufacturer-specified sensors. If necessary the new sensor must be recalibrated in the system.


Start

For commissioning:

  • mount the EL320x as explained in the chapter "Mounting and wiring"
  • configure the EL320x in TwinCAT as explained in the chapter "Commissioning"


EtherCAT - EtherCAT basics

BECKHOFF EtherCAT: Basics communication

EtherCAT basics

Please refer to the chapter EtherCAT System Documentation for the EtherCAT fieldbus basics.


EtherCAT cabeling

BECKHOFF EtherCAT: Basics communication

EtherCAT cabling – wire-bound

The cable length between two EtherCAT devices must not exceed 100 m. This results from the FastEthernet technology, which, above all for reasons of signal attenuation over the length of the cable, allows a maximum link length of 5 + 90 + 5 m if cables with appropriate properties are used. See also the Design recommendations for the infrastructure for EtherCAT/Ethernet.

Cables and connectors

For connecting EtherCAT devices only Ethernet connections (cables + plugs) that meet the requirements of at least category 5 (CAt5) according to EN 50173 or ISO/IEC 11801 should be used. EtherCAT uses 4 wires for signal transfer.

EtherCAT uses RJ45 plug connectors, for example. The pin assignment is compatible with the Ethernet standard (ISO/IEC 8802-3).

Pin | Color of conductor | Signal | Description
1 | yellow | TD + | Transmission Data +
2 | orange | TD - | Transmission Data -
3 | white | RD + | Receiver Data +
6 | blue | RD - | Receiver Data -

Due to automatic cable detection (auto-crossing) symmetric (1:1) or cross-over cables can be used between EtherCAT devices from Beckhoff.

Note 		Recommended cables
Suitable cables for the connection of EtherCAT devices can be found on the Beckhoff website!

E-Bus supply

A bus coupler can supply the EL terminals added to it with the E-bus system voltage of 5 V; a coupler is thereby loadable up to 2A as a rule (see details in respective device documentation).
Information on how much current each EL terminal requires from the E-bus supply is available online and in the catalogue. If the added terminals require more current than the coupler can supply, then power feed terminals (e.g. EL9400) must be inserted at appropriate places in the terminal strand.

The pre-calculated theoretical maximum E-bus current is displayed in the TwinCAT System Manager. A shortfall is marked by a negative total amount and an exclamation mark; a power feed terminal is to be placed before such a position.

Fig. 1: System manager current calculation

Attention 		Caution! Malfunction possible!
The same ground potential must be used for the E-Bus supply of all EtherCAT terminals in a terminal block!


EtherCAT - General notes for setting the watchdog

BECKHOFF EtherCAT: Basics communication

General notes for setting the watchdog

ELxxxx terminals are equipped with a safety feature (watchdog) that switches off the outputs after a specifiable time e.g. in the event of an interruption of the process data traffic, depending on the device and settings, e.g. in OFF state.

The EtherCAT slave controller (ESC) in the EL2xxx terminals features 2 watchdogs:

  • SM watchdog (default: 100 ms)
  • PDI watchdog (default: 100 ms)

SM watchdog (SyncManager Watchdog)

The SyncManager watchdog is reset after each successful EtherCAT process data communication with the terminal. If no EtherCAT process data communication takes place with the terminal for longer than the set and activated SM watchdog time, e.g. in the event of a line interruption, the watchdog is triggered and the outputs are set to FALSE. The OP state of the terminal is unaffected. The watchdog is only reset after a successful EtherCAT process data access. Set the monitoring time as described below.

The SyncManager watchdog monitors correct and timely process data communication with the ESC from the EtherCAT side.

PDI watchdog (Process Data Watchdog)

If no PDI communication with the EtherCAT slave controller (ESC) takes place for longer than the set and activated PDI watchdog time, this watchdog is triggered.
PDI (Process Data Interface) is the internal interface between the ESC and local processors in the EtherCAT slave, for example. The PDI watchdog can be used to monitor this communication for failure.

The PDI watchdog monitors correct and timely process data communication with the ESC from the application side.

The settings of the SM- and PDI-watchdog must be done for each slave separately in the TwinCAT System Manager.

Fig. 1 EtherCAT tab -> Advanced Settings -> Behavior -> Watchdog

Notes:

  • the multiplier is valid for both watchdogs.
  • each watchdog has its own timer setting, the outcome of this in summary with the multiplier is a resulting time.
  • Important: the multiplier/timer setting is only loaded into the slave at the start up, if the checkbox is activated.
    If the checkbox is not activated, nothing is downloaded and the ESC settings remain unchanged.

Multiplier

Both watchdogs receive their pulses from the local terminal cycle, divided by the watchdog multiplier:

1/25 MHz * (watchdog multiplier + 2) = 100 µs (for default setting of 2498 for the multiplier)

The standard setting of 1000 for the SM watchdog corresponds to a release time of 100 ms.

The value in multiplier + 2 corresponds to the number of basic 40 ns ticks representing a watchdog tick.
The multiplier can be modified in order to adjust the watchdog time over a larger range.

Example "Set SM watchdog"

This checkbox enables manual setting of the watchdog times. If the outputs are set and the EtherCAT communication is interrupted, the SM watchdog is triggered after the set time and the outputs are erased. This setting can be used for adapting a terminal to a slower EtherCAT master or long cycle times. The default SM watchdog setting is 100 ms. The setting range is 0..65535. Together with a multiplier with a range of 1..65535 this covers a watchdog period between 0..~170 seconds.

Calculation

Multiplier = 2498 → watchdog base time = 1 25 MHz * (2498 + 2) = 0.0001 seconds = 100 µs
SM watchdog = 10000 → 10000 * 100 µs = 1 second watchdog monitoring time

CAUTION 		CAUTION! Undefined state possible!
The function for switching off of the SM watchdog via SM watchdog = 0 is only implemented in terminals from version -0016.
In previous versions this operating mode should not be used.

CAUTION 		CAUTION! Damage of devices and undefined state possible!
If the SM watchdog is activated and a value of 0 is entered the watchdog switches off completely. This is the deactivation of the watchdog!
Set outputs are NOT set in a safe state, if the communication is interrupted.

Note 		Outputs in SAFEOP state
The default set watchdog monitoring sets the outputs of the module in a safe state - depending on the settings in SAFEOP and OP - e.g. in OFF state.
If this is prevented by deactivation of the watchdog monitoring in the module, the outputs can be switched or set also in the SAFEOP state.


EtherCAT State Machine

The state of the EtherCAT slave is controlled via the EtherCAT State Machine (ESM). Depending upon the state, different functions are accessible or executable in the EtherCAT slave. Specific commands must be sent by the EtherCAT master to the device in each state, particularly during the bootup of the slave.

A distinction is made between the following states:

  • Init
  • Pre-Operational
  • Safe-Operational and
  • Operational
  • Boot

The regular state of each EtherCAT slave after bootup is the OP state.

Init

After switch-on the EtherCAT slave in the Init state. No mailbox or process data communication is possible. The EtherCAT master initializes sync manager channels 0 and 1 for mailbox communication.

Pre-Operational (Pre-Op)

During the transition between Init and Pre-Op the EtherCAT slave checks whether the mailbox was initialized correctly.

In Pre-Op state mailbox communication is possible, but not process data communication. The EtherCAT master initializes the sync manager channels for process data (from sync manager channel 2), the FMMU channels and, if the slave supports configurable mapping, PDO mapping or the sync manager PDO assignment. In this state the settings for the process data transfer and perhaps terminal-specific parameters that may differ from the default settings are also transferred.

Safe-Operational (Safe-Op)

During transition between Pre-Op and Safe-Op the EtherCAT slave checks whether the sync manager channels for process data communication and, if required, the distributed clocks settings are correct. Before it acknowledges the change of state, the EtherCAT slave copies current input data into the associated DP-RAM areas of the EtherCAT slave controller (ECSC).

In Safe-Op state mailbox and process data communication is possible, although the slave keeps its outputs in a safe state, while the input data are updated cyclically.

Note 		Outputs in SAFEOP state
The default set watchdog monitoring sets the outputs of the module in a safe state - depending on the settings in SAFEOP and OP - e.g. in OFF state.
If this is prevented by deactivation of the watchdog monitoring in the module, the outputs can be switched or set also in the SAFEOP state.

Operational (Op)

Before the EtherCAT master switches the EtherCAT slave from Safe-Op to Op it must transfer valid output data.

In the Op state the slave copies the output data of the masters to its outputs. Process data and mailbox communication is possible.

Boot

In the Boot state the slave firmware can be updated. The Boot state can only be reached via the Init state.

In the Boot state mailbox communication via the file access over EtherCAT (FoE) protocol is possible, but no other mailbox communication and no process data communication.


CoE Interface

Table of contents
• General description
 • Data management
 • Online/offline list
 • Channel-based order

General description

The CoE interface (CANopen over EtherCAT) is used for parameter management of EtherCAT devices. EtherCAT slaves or the EtherCAT master manage fixed (read only) or variable parameters which they require for operation, diagnostics or commissioning.

CoE parameters are arranged in a table hierarchy. In principle, the user has read access via the fieldbus. The EtherCAT master (TwinCAT System Manager) can access the local CoE lists of the slaves via EtherCAT in read or write mode, depending on the attributes.

Different CoE parameter types are possible, including string (text), integer numbers, Boolean values or larger byte fields. They can be used to describe a wide range of features. Examples of such parameters include manufacturer ID, serial number, process data settings, device name, calibration values for analog measurement or passwords.

The order is specified in 2 levels via hexadecimal numbering: (main)index, followed by subindex. The value ranges are

  • Index: 0...65535
  • SubIndex: 0...255

A parameter localized in this way is normally written as x8010:07, with preceding "x" to identify the hexadecimal numerical range and a colon between index and subindex.

The relevant ranges for EtherCAT fieldbus users are:

  • x1000: This is where fixed identity information for the device is stored, including name, manufacturer, serial number etc., plus information about the current and available process data configurations.
  • x8000: This is where the operational and functional parameters for all channels are stored, such as filter settings or output frequency.

Other important ranges are:

  • x4000: In some EtherCAT devices the channel parameters are stored here (as an alternative to the x8000 range).
  • x6000: Input PDOs ("input" from the perspective of the EtherCAT master)
  • x7000: Output PDOs ("output" from the perspective of the EtherCAT master)

Note 		Availability
Not every EtherCAT device must have a CoE list.
Simple I/O modules without dedicated processor usually have no variable parameters and therefore no CoE list..

If a device has a CoE list, it is shown in the TwinCAT System Manager as a separate tab with a listing of the elements:

Fig. 1: "CoE Online " tab

Fig. 1 shows the CoE objects available in device "EL2502", ranging from x1000 to x1600. The subindices for x1018 are expanded.

Data management

Some parameters, particularly the setting parameters of the slave, are configurable and writeable. This can be done in write or read mode

  • via the System Manager (Fig. 1) by clicking
    This is useful for commissioning of the system/slaves. Click on the row of the index to be parameterised and enter a value in the "SetValue" dialog.
  • from the control system/PLC via ADS, e.g. through blocks from the TcEtherCAT.lib library
    This is recommended for modifications while the system is running or if no System Manager or operating staff are available.

Note 		Data management
If slave CoE parameters are modified online, Beckhoff devices store any changes in a fail-safe manner in the EEPROM, i.e. the modified CoE parameters are still available after a restart.

The situation may be different with other manufacturers.

An EEPROM is subject to a limited lifetime with respect to write operations. From typically 100,000 write operations onwards it can no longer be guaranteed that new (changed) data are reliably saved or are still readable. This is irrelevant for normal commissioning. However, if CoE parameters are continuously changed via ADS at machine runtime, it is quite possible for the lifetime limit to be reached. Support for the NoCoeStorage function, which suppresses the saving of changed CoE values, depends on the firmware version.
  • If the function is supported: the function is activated by entering the code word 0x12345678 once in CoE 0xF008 and remains active as long as the code word is not changed. After switching the device on it is then inactive. Changed CoE values are not saved in the EEPROM and can thus be changed any number of times.
  • Function not supported: continuous changing of CoE values is not permissible in view of the lifetime limit.

Please refer to the technical data in this documentation as to whether this applies to the respective device.

Start-up list

Note 		Startup list
Changes in the local CoE list of the terminal are lost if the terminal is replaced. If a terminal is replaced with a new Beckhoff terminal, it will have the default settings. It is therefore advisable to link all changes in the CoE list of an EtherCAT slave with the Startup list of the slave, which is processed whenever the EtherCAT fieldbus is started. In this way a replacement EtherCAT slave can automatically be parameterised with the specifications of the user.

If EtherCAT slaves are used which are unable to store local CoE values permanently, the Startup list must be used.

Recommended approach for manual modification of CoE parameters

  • Make the required change in the System Manager
    The values are stored locally in the EtherCAT slave
  • If the value is to be stored permanently, enter it in the Startup list.
    The order of the Startup entries is usually irrelevant.

Fig. 2: Startup list in the TwinCAT System Manager

The Startup list may already contain values that were configured by the System Manager based on the ESI specifications. Additional application-specific entries can be created.

Online/offline list

While working with the TwinCAT System Manager, a distinction has to be made whether the EtherCAT device is "available", i.e. switched on and linked via EtherCAT and therefore online, or whether a configuration is created offline without connected slaves.

In both cases a CoE list as shown in Fig. 1 is displayed. The connectivity is shown as offline/online.

  • If the slave is offline
    - The offline list from the ESI file is displayed. In this case modifications are not meaningful or possible.
    - The configured status is shown under Identity.
    - No firmware or hardware version is displayed, since these are features of the physical device.
    - Offline is shown in red.

    Fig. 3: Offline list
  • If the slave is online
    - The actual current slave list is read. This may take several seconds, depending on the size and cycle time.
    - The actual identity is displayed
    - The firmware and hardware version of the equipment according to the electronic information is displayed
    - Online is shown in green.

    Fig. 4: Online list

Channel-based order

The CoE list is available in EtherCAT devices that usually feature several functionally equivalent channels. For example, a 4-channel analog 0..10 V input terminal also has 4 logical channels and therefore 4 identical sets of parameter data for the channels. In order to avoid having to list each channel in the documentation, the placeholder "n" tends to be used for the individual channel numbers.

In the CoE system 16 indices, each with 255 subindices, are generally sufficient for representing all channel parameters. The channel-based order is therefore arranged in 16dec/10hex steps. The parameter range x8000 exemplifies this:

  • Channel 0: parameter range x8000:00 ... x800F:255
  • Channel 1: parameter range x8010:00 ... x801F:255
  • Channel 2: parameter range x8020:00 ... x802F:255
  • ...

This is generally written as x80n0.

Detailed information on the CoE interface can be found in the EtherCAT system documentation on the Beckhoff website.


Distributed Clock

The distributed clock represents a local clock in the EtherCAT slave controller (ESC) with the following characteristics:
  • Unit 1 ns
  • Zero point 1.1.2000 00:00
  • Size 64 bit (sufficient for the next 584 years; however, some EtherCAT slaves only offer 32-bit support, i.e. the variable overflows after approx. 4.2 seconds)
  • The EtherCAT master automatically synchronizes the local clock with the master clock in the EtherCAT bus with a precision of < 100 ns.

For detailed information please refer to the EtherCAT system description.


ELxxxx, KLxxxx - Installation on mounting rails

BECKHOFF Fieldbus Components: Mounting and wiring

Installation on mounting rails

WARNING 		Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!

Assembly

The Bus Coupler and Bus Terminals are attached to commercially available 35 mm mounting rails (DIN rails according to EN 60715) by applying slight pressure:

  1. First attach the Fieldbus Coupler to the mounting rail.
  2. The Bus Terminals are now attached on the right-hand side of the Fieldbus Coupler. Join the components with tongue and groove and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
    If the Terminals are clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.

Note 		Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail.
At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail.
To mount the mounting rails with a height of 7.5 mm under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).

Disassembly

Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
  1. Pull the terminal by its orange-colored lugs approximately 1 cm away from the mounting rail. In doing so for this terminal the mounting rail lock is released automatically and you can pull the terminal out of the bus terminal block easily without excessive force.
  2. Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal out of the bus terminal block.

Connections within a bus terminal block

The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:

  • The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
  • The power contacts deal with the supply for the field electronics and thus represent a supply rail within the bus terminal block. The power contacts are supplied via terminals on the Bus Coupler (up to 24 V) or for higher voltages via power feed terminals.

Note 		Power Contacts
During the design of a bus terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts.
Power Feed Terminals (KL91xx, KL92xx or EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.

PE power contact

The power contact labeled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.

Attention 		Possible damage of the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a nominal voltage of 230 V).

For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.

WARNING 		Risk of electric shock!
The PE power contact must not be used for other potentials!


ELxxxx, KLxxxx - Installation instructions for enhanced mechanical load capacity

BECKHOFF Fieldbus components: Mounting and wiring

Installation instructions for enhanced mechanical load capacity

WARNING 		Risk of injury through electric shock and damage to the device!
Bring the Bus Terminal system into a safe, de-energized state
before starting mounting, disassembly or wiring of the Bus Terminals!

Additional checks

The terminals have undergone the following additional tests:

Verification | Explanation
Vibration | 10 frequency runs in 3 axes
 | 6 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 25 g, 6 ms

Additional installation instructions

For terminals with enhanced mechanical load capacity, the following additional installation instructions apply:

  • Any installation position is permitted
  • Use a mounting rail according to EN 60715 TH35-15
  • Fix the terminal segment on both sides of the mounting rail with a mechanical fixture, e.g. an earth terminal or reinforced end clamp
  • The maximum total extension of the terminal segment (without coupler) is:
    64 terminals (12 mm mounting with) or 32 terminals (24 mm mounting with)
  • Avoid deformation, twisting, crushing and bending of the mounting rail during edging and installation of the rail
  • The mounting points of the mounting rail must be set at 5 cm intervals
  • Use countersunk head screws to fasten the mounting rail
  • The free length between the strain relief and the wire connection should be kept as short as possible. A distance of approx. 10 cm should be maintained to the cable duct.


KLxxxx, KSxxxx, ELxxxx, ESxxxx - Connection system

BECKHOFF Fieldbus Components: Mounting and wiring

Connection system

WARNING 		Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!

Overview

The Bus Terminal system offers different connection options for optimum adaptation to the respective application:

  • The terminals of KLxxxx and ELxxxx series with standard wiring include electronics and connection level in a single enclosure.
  • The terminals of KSxxxx and ESxxxx series feature a pluggable connection level and enable steady wiring while replacing.
  • The High Density Terminals (HD Terminals) include electronics and connection level in a single enclosure and have advanced packaging density.

Standard wiring

The terminals of KLxxxx and ELxxxx series have been tried and tested for years.
They feature integrated screwless spring force technology for fast and simple assembly.

Pluggable wiring

The terminals of KSxxxx and ESxxxx series feature a pluggable connection level.
The assembly and wiring procedure for the KS series is the same as for the KLxxxx and ELxxxx series.
The KS/ES series terminals enable the complete wiring to be removed as a plug connector from the top of the housing for servicing
The lower section can be removed from the terminal block by pulling the unlocking tab.
Insert the new component and plug in the connector with the wiring.
This reduces the installation time and eliminates the risk of wires being mixed up.

The familiar dimensions of the terminal only had to be changed slightly. The new connector adds about 3 mm. The maximum height of the terminal remains unchanged.

A tab for strain relief of the cable simplifies assembly in many applications and prevents tangling of individual connection wires when the connector is removed.

Conductor cross sections between 0.08 mm2 and 2.5 mm2 can continue to be used with the proven spring force technology.

The overview and nomenclature of the product names for KSxxxx and ESxxxx series has been retained as known from KLxxxx and ELxxxx series.

High Density Terminals (HD Terminals)

The Bus Terminals from these series with 16 connection points are distinguished by a particularly compact design, as the packaging density is twice as large as that of the standard 12 mm Bus Terminals. Massive conductors and conductors with a wire end sleeve can be inserted directly into the spring loaded terminal point without tools.

Note 		Wiring HD Terminals
The High Density (HD) Terminals of the KLx8xx and ELx8xx series doesn't support steady wiring.

Ultrasonically "bonded" (ultrasonically welded) conductors

Note 		Ultrasonically “bonded" conductors
It is also possible to connect the Standard and High Density Terminals with ultrasonically "bonded" (ultrasonically welded) conductors.
In this case, please note the tables concerning the wire-size width below!

Wiring

Terminals for standard wiring ELxxxx / KLxxxx and terminals for steady wiring ESxxxx / KSxxxx

Up to eight connections enable the connection of solid or finely stranded cables to the Bus Terminals. The terminals are implemented in spring force technology. Connect the cables as follows:

  1. Open a spring-loaded terminal by slightly pushing with a screwdriver or a rod into the square opening above the terminal.
  2. The wire can now be inserted into the round terminal opening without any force.
  3. The terminal closes automatically when the pressure is released, holding the wire securely and permanently.

Terminal housing | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Wire size width | 0.08 ... 2,5 mm2 | 0.08 ... 2.5 mm2
Wire stripping length | 8 ... 9 mm | 9 ... 10 mm

High Density Terminals ELx8xx, KLx8xx (HD)

The conductors of the HD Terminals are connected without tools for single-wire conductors using the direct plug-in technique, i.e. after stripping the wire is simply plugged into the contact point. The cables are released, as usual, using the contact release with the aid of a screwdriver. See the following table for the suitable wire size width.

Terminal housing | High Density Housing
Wire size width (conductors with a wire end sleeve) | 0.14... 0.75 mm2
Wire size width (single core wires) | 0.08 ... 1.5 mm2
Wire size width (fine-wire conductors) | 0.25 ... 1.5 mm2
Wire size width (ultrasonically “bonded" conductors) | only 1.5 mm2 (see notice!)
Wire stripping length | 8 ... 9 mm

Shielding

Note 		Shielding
Analog sensors and actors should always be connected with shielded, twisted paired wires.


Mounting of Passive Terminals

Note 		Hint for mounting passive terminals
EtherCAT Bus Terminals (ELxxxx / ESxxxx), which do not take an active part in data transfer within the bus terminal block are so called Passive Terminals.
The Passive Terminals have no current consumption out of the E-Bus
To ensure an optimal data transfer, you must not directly string together more than 2 Passive Terminals!
Examples for mounting passive terminals (highlighted)

Example 1: correct configuration

Example 2: incorrect configuration


KLxxxx, ELxxxx installation positions

BECKHOFF Fieldbus components: Installation and wiring

Installation positions

Attention 		Constraints regarding installation position and operating temperature range
Please refer to the technical data for a terminal to ascertain whether any restrictions regarding the installation position and/or the operating temperature range have been specified.

When installing high power dissipation terminals ensure that an adequate spacing is maintained between other components above and below the terminal in order to guarantee adequate ventilation!

Optimum installation position (standard)

The optimum installation position requires the mounting rail to be installed horizontally and the connection surfaces of the EL/KL terminals to face forward (see Fig. 1). The terminals are ventilated from below, which enables optimum cooling of the electronics through convection. "From below" is relative to the acceleration of gravity.

Fig. 1: Recommended distances for standard installation position

Compliance with the distances shown in Fig. 1 is recommended.

Other installation positions

All other installation positions are characterized by different spatial arrangement of the mounting rail - see Fig 2.

The minimum distances to ambient specified above also apply to these installation positions.

Fig. 2: Other installation positions


EL320x- LEDs and connection

BECKHOFF EL320x: Mounting and Wiring

LEDs and connection

Contents
• EL3201, EL3202
• EL3201-0010, EL3202-0010
• EL3204-0x00

EL3201, EL3202

Note 		Two-wire connection
If the EL3201/EL3202 is operated with a two-wire connection, the inputs +R and +RL must be bridged by the user.

LEDs

LED | Color | Meaning
RUN | green | This LED indicates the terminal's operating state:
 |  | off | State of the EtherCAT State Machine: INIT = Initialization of the terminal or BOOTSTRAP = Function for firmware updates of the terminal
 |  | blinking | State of the EtherCAT State Machine: PREOP = Setting for mailbox communication and variant standard settings
 |  | single flash | State of the EtherCAT State Machine: SAFEOP = Channel checking of the Sync Manager and the Distributed Clocks. Outputs stay in safe operation mode.
 |  | on | State of the EtherCAT State Machine: OP = Normal operation mode, mailbox- and process data communication possible
ERROR1, ERROR2** | red | on | Short circuit or wire breakage. The resistance is in the invalid range of the characteristic curve.
**only EL3202

Connection EL3201

Terminal point | No. | Comment
+R1 | 1 | Input +R1
+RL1 | 2 | Input +RL1
-R1 | 3 | Input -R1
-RL1 | 4 | Input -RL1
... | 5 | not connected
... | 6 | not connected
... | 7 | not connected
Shield | 8 | Shield

Connection EL3202

Terminal point | No. | Comment
+R1 | 1 | Input +R1
+RL1 | 2 | Input +RL1
-R1 | 3 | Input -R1
Shield | 4 | Shield (connected internally with terminal 8)
+R2 | 5 | Input +R2
+RL2 | 6 | Input +RL2
-R2 | 7 | Input -R2
Shield | 8 | Shield (connected internally with terminal 4)

EL3201-00x0, EL3202-0010

Note 		4 wire connection
The high precision terminals EL320x-00x0 must be conventional operated with a 4-wire connection.

LEDs

LED | Color | Meaning
RUN | green | This LED indicates the terminal's operating state:
 |  | off | State of the EtherCAT State Machine: INIT = Initialization of the terminal or BOOTSTRAP = Function for firmware updates of the terminal
 |  | blinking | State of the EtherCAT State Machine: PREOP = Setting for mailbox communication and variant standard settings
 |  | single flash | State of the EtherCAT State Machine: SAFEOP = Channel checking of the Sync Manager and the Distributed Clocks. Outputs stay in safe operation mode.
 |  | on | State of the EtherCAT State Machine: OP = Normal operation mode, mailbox- and process data communication possible
ERROR1, ERROR2** | red | on | Short circuit or wire breakage. The resistance is in the invalid range of the characteristic curve.
**only EL3202-0010

Connection EL3201-0010

Terminal point | No. | Comment
+R1 | 1 | Input +R1
+RL1 | 2 | Input +RL1
-R1 | 3 | Input -R1
-RL1 | 4 | Input -RL1
... | 5 | not connected
... | 6 | not connected
... | 7 | not connected
Shield | 8 | Shield

Connection EL3202-0010

Terminal point | No. | Comment
+R1 | 1 | Input +R1
+RL1 | 2 | Input +RL1
-R1 | 3 | Input -R1
-RL1 | 4 | Input -RL1
+R2 | 5 | Input +R2
+RL2 | 6 | Input +RL2
-R2 | 7 | Input -R2
-RL2 | 8 | Input -RL2

EL3204-0x00

LEDs

LED | Color | Meaning
RUN | green | This LED indicates the terminal's operating state:
 |  | off | State of the EtherCAT State Machine: INIT = Initialization of the terminal or BOOTSTRAP = Function for firmware updates of the terminal
 |  | blinking | State of the EtherCAT State Machine: PREOP = Setting for mailbox communication and variant standard settings
 |  | single flash | State of the EtherCAT State Machine: SAFEOP = Channel checking of the Sync Manager and the Distributed Clocks. Outputs stay in safe operation mode.
 |  | on | State of the EtherCAT State Machine: OP = Normal operation mode, mailbox- and process data communication possible
ERROR1, ERROR2, ERROR3, ERROR4 | red | on | Short circuit or wire breakage. The resistance is in the invalid range of the characteristic curve.

Connection EL3204-0x00

Terminal point | No. | Comment
+R1 | 1 | Input +R1
-R1 | 2 | Input -R1
+R3 | 3 | Input +R3
-R3 | 4 | Input -R3
+R2 | 5 | Input +R2
-R2 | 6 | Input -R2
+R4 | 7 | Input +R4
-R4 | 8 | Input -R4


EL320x - connection of analog signal cables

BECKHOFF EL320x: Mounting and wiring

Connection of analog signal cables

The RTD input terminals of the EL32xx series measure the analog resistance of the sensor. The voltage drop at the sensor (including the line resistances, depending on the connection technology) is equivalent to the sensor resistance and therefore a measure for the sensor temperature, if the characteristic sensor curve is known.
The following procedure serves for connecting analog signal cables in order to ensure error-free measurement of the analog signals.

Procedures

  • Sensor cable to be used
    • Tightly twisted
    • Shielded copper braid
    • Use low-impedance cable, particularly for 2-wire connection
  • Keep the sensor and sensor cables free from external potential
    On no account should the GND connections (3/7 for EL3201, EL3202) be connected with other potentials.
  • The resistor for the RTD sensor (e.g. 100 or 1000 Ω nominal) should be chosen based on the ratio between sensor resistance and line resistance, taking account of the connection type (2/3/4-wire).

Shielding measures

Notice 		Shielding measures
Due to the complexity in the "EMC" area, there is no generally applicable guideline, but only technical measures in accordance with the state of the art, which can sometimes contradict each other. These must be checked for feasibility and effectiveness, taking into account the plant specifications, and applied by the plant installer following assessment.

The following notes on shielding are to be understood as technical suggestions that have proven themselves from time to time in practical use. It must be checked in each case which measures can be applied, depending on the installation and plant. The effectiveness of each measure must be checked individually. The formal transferability of measures to other types of plant is in general not possible.

Priority is to be given to typical national or general normative specifications.

A shielding approach is described below that in many cases improves the measurement quality. The suggested measures must be checked for feasibility and effectiveness in the actual plant.

  • Apply the shield with a low resistance and enveloping the cable by 360°
  • at the entry point into the control cabinet, the shield should be earthed conductively
  • the shield should be earthed again at the terminal
    • at the terminal connection point, if present
    • if no terminal connection point is available, earth the shield as close to the terminal as possible
    • to avoid ground loops the shield can be undone after entry into the control cabinet
      A capacitive connection to the terminal shield contact is possible.
    • avoid unshielded cable lengths of > 50 cm

Fig. 1a + 1b: Example for EL3202-0000 shield connection with shield contact, in the presence of potential disturbance sources inside or inside and outside the control cabinet


Installation of the TwinCAT real-time driver

In order to assign real-time capability to a standard Ethernet port of an IPC controller, the Beckhoff real-time driver has to be installed on this port under Windows.

This can be done in several ways. One option is described here.

In the System Manager call up the TwinCAT overview of the local network interfaces via Options -> Show Real Time Ethernet Compatible Devices.

Fig. 1: System Manager option

Fig. 2: overview of network interfaces

Interfaces listed under “Compatible devices” can be assigned a driver via the “Install” button. A driver should only be installed on compatible devices.

A Windows warning regarding the unsigned driver can be ignored.

Alternatively, the compatible Ethernet ports can be viewed in the System Manager via EtherCAT properties.

Fig. 3: EtherCAT device properties

After the installation the driver appears activated in the Windows overview for the network interface (Windows Start -->System Properties -> Network)

Fig. 4: Windows properties of the network interface

Other possible settings are to be avoided:

Fig. 5: incorrect driver settings for the Ethernet port

IP address of the port used

Notice 		IP address/DHCP
In most cases an Ethernet port that is configured as an EtherCAT device will not transport general IP packets. For this reason and in cases where an EL6601 or similar devices are used it is useful to specify a fixed IP address for this port via the “Internet Protocol TCP/IP” driver setting and to disable DHCP.

In this way the delay associated with the DHCP client for the Ethernet port assigning itself a default IP address in the absence of a DHCP server is avoided.

A suitable address space is 192.168.x.x, for example.

Fig. 6: TCP/IP setting for the Ethernet port


Notes regarding ESI device description

Contents
• Installation of the latest ESI device description
• Device differentiation
• Online Description
• Faulty ESI file

Installation of the latest ESI device description

The TwinCAT EtherCAT master/System Manager needs the device description files for the devices to be used in order to generate the configuration in online or offline mode. The device descriptions are contained in the so-called ESI files (EtherCAT Slave Information) in XML format. These files can be requested from the respective manufacturer and are made available for download. An *.xml file may contain several device descriptions.

The ESI files for Beckhoff EtherCAT devices are available on the Beckhoff website.

The ESI files should be stored in the TwinCAT installation directory (default TwinCAT2: C:\TwinCAT\IO\EtherCAT). The files are read (once) when a new System Manager window is opened, if they have changed since the last time the System Manager window was opened.

A TwinCAT installation includes the set of Beckhoff ESI files that was current at the time when the TwinCAT build was created.

For TwinCAT 2.11/TwinCAT 3 and higher, the ESI directory can be updated from the System Manager, if the programming PC is connected to the Internet (Option -> “Update EtherCAT Device Descriptions”)

Fig. 1: for TwinCAT 2.11 and higher, the System Manager can search for current Beckhoff ESI files automatically, if an online connection is available

Note 		ESI
The *.xml files are associated with *.xsd files, which describe the structure of the ESI XML files. To update the ESI device descriptions, both file types should therefore be updated.

Device differentiation

EtherCAT devices/slaves are distinguished by 4 properties, which determine the full device identifier. The EL2521-0025-1018 ID consists of

  • family key “EL”
  • name “2521”
  • type “0025”
  • and revision “1018”

Fig. 2: identifier structure

The order identifier consisting of name + type (here: EL2521-0010) describes the device function. The revision indicates the technical progress and is managed by Beckhoff. In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation. Each revision has its own ESI description. See further notes.

Online description

If the EtherCAT configuration is created online through scanning of real devices (see section Online setup) and no ESI descriptions are available for a slave (specified by name and revision) that was found, the System Manager asks whether the description stored in the device should be used. In any case, the System Manager needs this information for setting up the cyclic and acyclic communication with the slave correctly.

Fig. 3: OnlineDescription information window

In TwinCAT 3.x a similar window appears, which also offers the Web update:

If possible, the Yes is to be rejected and the required ESI is to be requested from the device manufacturer. After installation of the XML/XSD file the configuration process should be repeated.

Attention 		Changing the ‘usual’ configuration through a scan
If a scan discovers a device that is not yet known to TwinCAT, distinction has to be made between two cases. Taking the example here of the EL2521-0000 in the revision 1019:
  • no ESI is present for the EL2521-0000 device at all, either for the revision 1019 or for an older revision. The ESI must then be requested from the manufacturer (in this case Beckhoff).
  • an ESI is present for the EL2521-0000 device, but only in an older revision, e.g. 1018 or 1017.
    In this case an in-house check should first be performed to determine whether the spare parts stock allows the integration of the increased revision into the configuration at all. A new/higher revision usually also brings along new features. If these are not to be used, work can continue without reservations with the previous revision 1018 in the configuration. This is also stated by the Beckhoff compatibility rule.

Refer in particular to the chapter ‘General notes on the use of Beckhoff EtherCAT IO components’ and for manual configuration to the chapter ‘Configuration creation – manual’

If the OnlineDescription is used regardless, the System Manager reads a copy of the device description from the EEPROM in the EtherCAT slave. In complex slaves the size of the EEPROM may not be sufficient for the complete ESI, in which case the ESI would be incomplete in the configurator. The route via the ESI files is therefore recommended.

The System Manager creates a new file “OnlineDescription0000...xml” its ESI directory, which contains all ESI descriptions that were read online.

Fig. 4: file OnlineDescription.xml created by the System Manager

If slaves are added manually to the configuration at a later stage, slaves created in the manner described above are indicated by an arrow, see Fig. 5, EL2521.

Fig. 5: Arrow indicates ESI recorded from OnlineDescription

If such ESI files are used and the manufacturer's files become available later, the file OnlineDescription.xml should be deleted as follows:

  • close all System Manager windows
  • restart TwinCAT in Config mode
  • delete "OnlineDescription0000...xml"
  • restart TwinCAt System Manager

This file should not be visible after this procedure, if necessary press <F5> to update

Note 		OnlineDescription for TwinCAT 3.x
In addition to the file described above "OnlineDescription0000...xml" , a so called EtherCAT cache with new discovered devices is created by TwinCAT 3.x (e.g. under Windows 7)
C:\User\[USERNAME]\AppData\Roaming\Beckhoff\TwinCAT3\Components\Base\EtherCATCache.xml

(Please note the language settings of the OS!)

You have to delete this file, too.

Faulty ESI file

If an ESI file is faulty and the System Manager is unable to read it, the System Manager brings up an information window.

Fig. 6: information window for faulty ESI file

Reasons may include:

  • Structure of the *.xml does not correspond to the associated *.xsd file --> check your schematics
  • Contents cannot be translated into a device description --> contact the file manufacturer


Offline configuration creation (master: TwinCAT 2.x)

Table of contents
• Distinction between Online and Offline
 • Creating the EtherCAT device
• Defining EtherCAT slaves

Distinction between Online and Offline

The distinction between online and offline refers to the presence of the actual I/O environment (drives, terminals). If the configuration is to be prepared in advance of the system configuration as a programming system, e.g. on a laptop, this is only possible in “Offline configuration” mode. In this case all components have to be entered manually in the configuration, e.g. based on the electrical design.

If the designed control system is already connected to the EtherCAT system and all components are energised and the infrastructure is ready for operation, the TwinCAT configuration can simply be generated through “scanning” from the runtime system. This is referred to as online configuration.

In any case, during each startup the EtherCAT master checks whether the slaves it finds match the configuration. This test can be parameterised in the extended slave settings.

Note 		Installation of the latest ESI-XML device description
The TwinCAT EtherCAT master/System Manager needs the device description files for the devices to be used in order to generate the configuration in online or offline mode. The device descriptions are contained in the so-called ESI files (EtherCAT Slave Information) in XML format. These files can be requested from the respective manufacturer and are made available for download. The ESIs for Beckhoff EtherCAT devices are provided on the Beckhoff website.

The ESI files should be saved in the TwinCAT installation directory (default: C:\TwinCAT\IO\EtherCAT ). The files are read (once) when a new System Manager window is opened.

A TwinCAT installation includes the set of Beckhoff ESI files that was current at the time when the TwinCAT build was created.

For TwinCAT 2.11 and higher, the ESI directory can be updated from the System Manager, if the programming PC is connected to the Internet (Option -> “Update EtherCAT Device Descriptions”)

The following conditions must be met before a configuration can be set up:

  • the EtherCAT device must be created/defined in the System Manager
  • the EtherCAT slaves must be defined

Creating the EtherCAT device

Create an EtherCAT device in an empty System Manager window.

Fig. 1: Append EtherCAT device

Select type ‘EtherCAT’ for an EtherCAT I/O application with EtherCAT slaves. For the present publisher/subscriber service in combination with an EL6601/EL6614 terminal select “EtherCAT Automation Protocol via EL6601”.

Fig. 2: selecting the EtherCAT connection (TwinCAT 2.11)

Fig. 3: selecting the EtherCAT connection (TwinCAT 2.11 R2)

Then assign a real Ethernet port to this virtual device in the runtime system.

Fig. 4: selecting the Ethernet port

This query may appear automatically when the EtherCAT device is created, or the assignment can be set/modified later in the properties dialog (see Fig. 5).

Fig. 5: EtherCAT properties dialog

Note 		Selecting the Ethernet port
Ethernet ports can only be selected for EtherCAT devices for which the TwinCAT real-time driver is installed. This has to be done separately for each port.

Please refer to the respective installation page.

Defining EtherCAT slaves

Further devices can be appended by right-clicking on a device in the configuration tree.

Fig. 6: appending EtherCAT devices

The dialog for selecting a new device opens. Only devices for which ESI files are available are displayed.

Only devices are offered for selection that can be appended to the previously selected device. Therefore the physical layer available for this port is also displayed (Fig. 7, A). In the case of cable-based Fast-Ethernet physical layer with PHY transfer, then also only cable-based devices are available, as shown in Fig. 7. If the preceding device has several free ports (e.g. EK1122 or EK1100), the required port can be selected on the right-hand side (A).

Overview of physical layer

  • “Ethernet”: cable-based 100BASE-TX: EK couplers, EP boxes, devices with RJ45/M8/M12 connector
  • “E-Bus”: LVDS “terminal bus”: EL/ES terminals, various modular modules

The search field facilitates finding specific devices (TwinCAT 2.11 or higher).

Fig. 7: selection dialog for new EtherCAT device

By default only the name/device type is used as selection criterion. For selecting a specific revision of the device the revision can be displayed as “Extended Information”.

Fig. 8: display of device revision

In many cases several device revisions were created for historic or functional reasons, e.g. through technological advancement. For simplification purposes (see Fig. 7) only the last (i.e. highest) revision and therefore the latest state of production is displayed in the selection dialog for Beckhoff devices. To show all device revisions available in the system as ESI descriptions tick the “Show Hidden Devices” check box, see Fig. 9.

Fig. 9: display of previous revisions

Note 		Device selection based on revision, compatibility
The ESI description also defines the process image, the communication type between master and slave/device and the device functions, if applicable. The physical device (firmware, if available) has to support the communication queries/settings of the master. This is backward compatible, i.e. newer devices (higher revision) should be supported if the EtherCAT master addresses them as an older revision. The following compatibility rule of thumb is to be assumed for Beckhoff EtherCAT Terminals/Boxes:

device revision in the system >= device revision in the configuration

This also enables subsequent replacement of devices without changing the configuration (different specifications are possible for drives).

Example: If an EL2521-0025-1018 is specified in the configuration, an EL2521-0025-1018 or higher (-1019, -1020) can be used in practice.

If current ESI descriptions are available in the TwinCAT system, the last revision offered in the selection dialog matches the Beckhoff state of production. It is recommended to use the last device revision when creating a new configuration, if current Beckhoff devices are used in the real application. Older revisions should only be used if older devices from stock are to be used in the application.

In this case the process image of the device is shown in the configuration tree and can be parameterised as follows: linking with the task, CoE/DC settings, plug-in definition, startup settings, ...

Fig. 10: EtherCAT terminal in the TwinCAT tree


Offline configuration creation ‘scanning’ (master: TwinCAT 2.x)

Table of contents
• Distinction between Online and Offline
 • Detecting/scanning of the EtherCAT device
 • Detecting/Scanning the EtherCAT devices
 • Troubleshooting
 • Scan over existing Configuration

• Change to compatible device
• Change to Alternative Type

Distinction between Online and Offline

The distinction between online and offline refers to the presence of the actual I/O environment (drives, terminals). If the configuration is to be prepared in advance of the system configuration as a programming system, e.g. on a laptop, this is only possible in “Offline configuration” mode. In this case all components have to be entered manually in the configuration, e.g. based on the electrical design.

If the designed control system is already connected to the EtherCAT system and all components are energised and the infrastructure is ready for operation, the TwinCAT configuration can simply be generated through “scanning” from the runtime system. This is referred to as online configuration.

In any case, during each startup the EtherCAT master checks whether the slaves it finds match the configuration. This test can be parameterised in the extended slave settings.

Note 		Installation of the latest ESI-XML device description
The TwinCAT EtherCAT master/System Manager needs the device description files for the devices to be used in order to generate the configuration in online or offline mode. The device descriptions are contained in the so-called ESI files (EtherCAT Slave Information) in XML format. These files can be requested from the respective manufacturer and are made available for download. The ESIs for Beckhoff EtherCAT devices are provided on the Beckhoff website.

The ESI files should be saved in the TwinCAT installation directory (default: C:\TwinCAT\IO\EtherCAT ). The files are read (once) when a new System Manager window is opened.

A TwinCAT installation includes the set of Beckhoff ESI files that was current at the time when the TwinCAT build was created.

For TwinCAT 2.11 and higher, the ESI directory can be updated from the System Manager, if the programming PC is connected to the Internet (Option -> “Update EtherCAT Device Descriptions”)

The following conditions must be met before a configuration can be set up:

  • the real EtherCAT hardware (devices, couplers, drives) must be present and installed
  • the devices/modules must be connected via EtherCAT cables or in the terminal strand in the same way as they are intended to be used later
  • the devices/modules be connected to the power supply and ready for communication
  • TwinCAT must be in CONFIG mode on the target system.

The online scan process consists of:

  • detecting the EtherCAT device (Ethernet port at the IPC)
  • detecting the connected EtherCAT devices. This step can be carried out independent of the preceding step
  • troubleshooting

The scan with existing configuration can also be carried out for comparison.

Detecting/scanning of the EtherCAT device

The online device search can be used if the TwinCAT system is in CONFIG mode (blue TwinCAT icon or blue indication in the System Manager).

Fig. 1: TwinCAT CONFIG mode display

Note 		Online scanning in Config mode
The online search is not available in RUN mode (production operation).

Note the differentiation between TwinCAT programming system and TwinCAT target system. The TwinCAT icon next to the Windows clock always shows the TwinCAT mode of the local IPC. The System Manager window shows the TwinCAT state of the target system.

Right-clicking on “I/O Devices” in the configuration tree opens the search dialog.

Fig. 2: Scan Devices

This scan mode attempts to find not only EtherCAT devices (or Ethernet ports that are usable as such), but also NOVRAM, fieldbus cards, SMB etc. However, not all devices can be found automatically.

Fig. 3: note for automatic device scan

Ethernet ports with installed TwinCAT real-time driver are shown as “RT Ethernet” devices. An EtherCAT frame is sent to these ports for testing purposes. If the scan agent detects from the response that an EtherCAT slave is connected, the port is immediately shown as an “EtherCAT Device” .

Fig. 4: detected Ethernet devices

After confirmation with “OK” a device scan is suggested for all selected devices, see Fig. 5.

Note 		selecting the Ethernet port
Ethernet ports can only be selected for EtherCAT devices for which the TwinCAT real-time driver is installed. This has to be done separately for each port.

Please refer to the respective installation page.

Detecting/Scanning the EtherCAT devices

Note 		Online scan functionality
During a scan the master queries the identity information of the EtherCAT slaves from the slave EEPROM. The name and revision are used for determining the type. The respective devices are located in the stored ESI data and integrated in the configuration tree in the default state defined there.

Attention 		Slave scanning in practice in series machine production
The scanning function should be used with care. It is a practical and fast tool for creating an initial configuration as a basis for commissioning.

In series machine production or reproduction of the plant, however, the function should no longer be used for the creation of the configuration, but if necessary for comparison with the defined initial configuration.

Background: since Beckhoff occasionally increases the revision version of the delivered products for product maintenance reasons, a configuration can be created by such a scan which (with an identical machine construction) is identical according to the device list; however, the respective device revision may differ from the initial configuration.

Example:

Company A builds the prototype of a machine B, which is to be produced in series later on. To do this the prototype is built, a scan of the IO devices is performed in TwinCAT and the initial configuration ‘B.tsm’ is created. The EL2521-0025 EtherCAT terminal with the revision 1018 is located somewhere. It is thus built into the TwinCAT configuration in this way:

Likewise, during the prototype test phase, the functions and properties of this terminal are tested by the programmers/commissioning engineers and used if necessary, i.e. addressed from the PLC ‘B.pro’ or the NC. (the same applies correspondingly to the TwinCAT3 solution files).

The prototype development is now completed and series production of machine B starts, for which Beckhoff continues to supply the EL2521-0025-0018. If the commissioning engineers of the series machine production department always carry out a scan, a B configuration with the identical contents results again for each machine. Likewise, A might create spare parts stores worldwide for the coming series-produced machines with EL2521-0025-1018 terminals.

After some time Beckhoff extends the EL2521-0025 by a new feature C. Therefore the FW is changed, outwardly recognizable by a higher FW version and a new revision -1019. Nevertheless the new device naturally supports functions and interfaces of the predecessor version(s); an adaptation of ‘B.tsm’ or even ‘B.pro’ is therefore unnecessary. The series-produced machines can continue to be built with ‘B.tsm’ and ‘B.pro’; it makes sense to perform a comparative scan against the initial configuration ‘B.tsm’ in order to check the built machine.

However, if the series machine production department now doesn’t use ‘B.tsm’, but instead carries out a scan to create the productive configuration, the revision -1019 is automatically detected and built into the configuration:

This is usually not noticed by the commissioning engineers. TwinCAT cannot signal anything either, since virtually a new configuration is created. According to the compatibility rule, however, this means that no EL2521-0025-1018 should be built into this machine as a spare part (even if this nevertheless works in the vast majority of cases).

In addition, it could be the case that, due to the development accompanying production in company A, the new feature C of the EL2521-0025-1019 (for example, an improved analog filter or an additional process data for the diagnosis) is discovered and used without in-house consultation. The previous stock of spare part devices are then no longer to be used for the new configuration ‘B2.tsm’ created in this way.

Þ if series machine production is established, the scan should only be performed for informative purposes for comparison with a defined initial configuration. Changes are to be made with care!

If an EtherCAT device was created in the configuration (manually or through a scan), the I/O field can be scanned for devices/slaves.

Fig. 5: scan query after automatic creation of an EtherCAT device

Fig. 6: Manual triggering of a device scan on a specified EtherCAT device

In the System Manager the scan process can be monitored via the progress bar at the bottom of the screen.

Fig. 7: scan progress

The configuration is established and can then be switched to online state (OPERATIONAL).

Fig. 8: Config/FreeRun query

In Config/FreeRun mode the System Manager display alternates between blue and red, and the EtherCAT device continues to operate with the idling cycle time of 4 ms (default setting), even without active task (NC, PLC).

Fig. 9: Config/FreeRun indicator

Note 		Note for Config/FreeRun
TwinCAT can also be switched to this state by using a button

The EtherCAT system should then be in a functional cyclic state, as shown in Fig. 10.

Fig. 10: online display example

Please note:

  • all slaves should be in OP state
  • the EtherCAT master should be in “Actual State” OP
  • “frames/sec” should match the cycle time taking into account the sent number of frames
  • no excessive “LostFrames” or CRC errors should occur

The configuration is now complete. It can be modified as described under manual procedure.

troubleshooting

Various effects may occur during scanning.

  • An unknown device is detected, i.e. an EtherCAT slave for which no ESI XML description is available.
    In this case the System Manager offers to read any ESI that may be stored in the device. This case is described in the chapter "Notes regarding ESI device description".
  • Device are not detected properly
    Possible reasons include:
    - faulty data links, resulting in data loss during the scan
    - slave has invalid device description
    The connections and devices should be checked in a targeted manner, e.g. via the emergency scan.
    Then re-run the scan.

  • Fig. 11: faulty identification

    In the System Manager such devices may be set up as EK0000 or unknown devices. Operation is not possible or meaningful.

Scan over existing Configuration

Attention 		Change of the configuration after comparison
With this scan (TwinCAT 2.11 or 3.1) only the device properties vendor (manufacturer), device name and revision are compared at present!
A ‘ChangeTo’ or ‘Copy’ should only be carried out with care, taking into consideration the Beckhoff IO compatibility rule (see above). The device configuration is then replaced by the revision found; this can affect the supported process data and functions.

If a scan is initiated for an existing configuration, the actual I/O environment may match the configuration exactly or it may differ. This enables the configuration to be compared.

Fig. 12: identical configuration

If differences are detected, they are shown in the correction dialog, so that the user can modify the configuration as required.

Fig. 13: correction dialog

It is advisable to tick the “Extended Information” check box to reveal differences in the revision.

Colour | Explanation
green | This EtherCAT slave matches the entry on the other side. Both type and revision match.
blue This EtherCAT slave is present on the other side, but in a different revision. This other revision can have other default values for the process data as well as other/additional functions.
If the found revision is higher than the configured revision, the slave may be used provided compatibility issues are taken into account.

If the found revision is lower than the configured revision, it is likely that the slave cannot be used. The found device may not support all functions that the master expects based on the higher revision number.

light blue | This EtherCAT slave is ignored (“Ignore” button)
red
  • This EtherCAT slave is not present on the other side.
  • It is present, but in a different revision, which also differs in its properties from the one specified.
    The compatibility principle then also applies here: if the found revision is higher than the configured revision, use is possible provided compatibility issues are taken into account, since the successor devices should support the functions of the predecessor devices.

    If the found revision is lower than the configured revision, it is likely that the slave cannot be used. The found device may not support all functions that the master expects based on the higher revision number.

Note 		Device selection based on revision, compatibility
The ESI description also defines the process image, the communication type between master and slave/device and the device functions, if applicable. The physical device (firmware, if available) has to support the communication queries/settings of the master. This is backward compatible, i.e. newer devices (higher revision) should be supported if the EtherCAT master addresses them as an older revision. The following compatibility rule of thumb is to be assumed for Beckhoff EtherCAT Terminals/Boxes:

device revision in the system >= device revision in the configuration

This also enables subsequent replacement of devices without changing the configuration (different specifications are possible for drives).

Example: If an EL2521-0025-1018 is specified in the configuration, an EL2521-0025-1018 or higher (-1019, -1020) can be used in practice.

If current ESI descriptions are available in the TwinCAT system, the last revision offered in the selection dialog matches the Beckhoff state of production. It is recommended to use the last device revision when creating a new configuration, if current Beckhoff devices are used in the real application. Older revisions should only be used if older devices from stock are to be used in the application.

Fig. 14: correction dialog with modifications

Once all modifications have been saved or accepted, click “OK” to transfer them to the real *.tsm configuration.

Change to compatible device

The TwinCAT System Manager offers a function for the exchange of a device whilst retaining the links in the task: Change to compatible device.

Fig. 15: TwinCAT 2 Dialog ChangeToCompatibleDevice

This function is preferably to be used on AX5000 devices. If called, the System Manager suggests the devices that it finds in the associated sub-folder; in the case of the AX5000, for example, in \TwiNCAT\IO\EtherCAT\Beckhoff AX5xxx.

Change to Alternative Type

The TwinCAT System Manager offers a function for the exchange of a device: Change to Alternative Type

Fig. 16: TwinCAT 2 Dialog ChangeToCompatibleDevice

If called, the System Manager searches in the procured device ESI (in this example: EL1202-0000) for details of compatible devices contained there. The configuration is changed and the ESI-EEPROM is overwritten at the same time – therefore this process is possible only in the online state (ConfigMode).


EtherCAT slave process data settings (PDO)

The process data transferred by an EtherCAT slave during each cycle (Process Data Objects, PDOs) are user data which the application expects to be updated cyclically or which are sent to the slave. To this end the EtherCAT master (Beckhoff TwinCAT) parameterizes each EtherCAT slave during the start-up phase to define which process data (size in bits/bytes, source location, transmission type) it wants to transfer to or from this slave. Incorrect configuration can prevent successful start-up of the slave.

For Beckhoff EtherCAT EL/ES slaves the following applies in general:

  • The input/output process data supported by the device are defined by the manufacturer in the ESI/XML description. The TwinCAT EtherCAT Master uses the ESI description to configure the slave correctly.
  • The process data can be modified in the system manager. See the device documentation.
    Examples of modifications include: mask out a channel, displaying additional cyclic information, 16-bit display instead of 8-bit data size, etc.
  • In so-called “intelligent” EtherCAT devices the process data information is also stored in the CoE directory. Any changes in the CoE directory that lead to different PDO settings prevent successful startup of the slave. It is not advisable to deviate from the designated process data, because the device firmware (if available) is adapted to these PDO combinations.

If the device documentation allows modification of process data, proceed as follows (see Figure 1).

  • A: select the device to configure
  • B: in the “Process Data” tab select Input or Output under SyncManager (C)
  • D: the PDOs can be selected or deselected
  • H: the new process data are visible as linkable variables in the system manager
    The new process data are active once the configuration has been activated and TwinCAT has been restarted (or the EtherCAT master has been restarted)
  • E: if a slave supports this, Input and Output PDO can be modified simultaneously by selecting a so-called PDO record (“predefined PDO settings”).

Fig. 1: Configuring the process data

Note 		Manual modification of the process data
According to the ESI description, a PDO can be identified as “fixed” with the flag “F” in the PDO overview (Fig. 1, J). The configuration of such PDOs cannot be changed, even if TwinCAT offers the associated dialog (“Edit”).

In particular, CoE content cannot be displayed as cyclic process data.

This generally also applies in cases where a device supports download of the PDO configuration, “G”.

In case of incorrect configuration the EtherCAT slave usually refuses to start and change to OP state. The System Manager displays an “invalid SM cfg” logger message:

This error message (“invalid SM IN cfg” or “invalid SM OUT cfg”) also indicates the reason for the failed start.


General Notes - EtherCAT Slave Application

Table of contents
• Diagnosis in real time: WorkingCounter, EtherCAT State and Status
• CoE - Parameter Directory
• Commissioning aid in the TwinCAT System Manager
 • EtherCAT State: automatic default behavior of the TwinCAT System Manager and manual operation
• Note regarding E-Bus current

This summary briefly deals with a number of aspects of EtherCAT Slave operation under TwinCAT. More detailed information on this may be found in the corresponding sections of, for instance, the EtherCAT System Documentation.

Diagnosis in real time: WorkingCounter, EtherCAT State and Status

Generally speaking an EtherCAT Slave provides a variety of diagnostic information that can be used by the controlling task.

This diagnostic information relates to differing levels of communication. It therefore has a variety of sources, and is also updated at various times.

Any application that relies on I/O data from a fieldbus being correct and up to date must make diagnostic access to the corresponding underlying layers. EtherCAT and the TwinCAT System Manager offer comprehensive diagnostic elements of this kind. Those diagnostic elements that are helpful to the controlling task for diagnosis that is accurate for the current cycle when in operation (not during commissioning) are discussed below.

Fig. 1: Selection of the diagnostic information of an EtherCAT Slave

In general, an EtherCAT Slave offers

  • communication diagnosis typical for a slave (diagnosis of successful participation in the exchange of process data, and correct operating mode)
    This diagnosis is the same for all slaves.

    as well as
  • function diagnosis typical for a channel (device-dependent)
    See the corresponding device documentation

The colours in Fig. 1 also correspond to the variable colours in the System Manager, see Fig. 2.

Colour | Meaning
yellow | Input variables from the Slave to the EtherCAT Master, updated in every cycle
red | Output variables from the Slave to the EtherCAT Master, updated in every cycle
green | Information variables for the EtherCAT Master that are updated acyclically. This means that it is possible that in any particular cycle they do not represent the latest possible status. It is therefore useful to read such variables through ADS.

Fig. 2 shows an example of an implementation of basic EtherCAT Slave Diagnosis. A Beckhoff EL3102 (2-channel analogue input terminal) is used here, as it offers both the communication diagnosis typical of a slave and the functional diagnosis that is specific to a channel. Structures are created as input variables in the PLC, each corresponding to the process image.

Fig. 2: basic EtherCAT Slave Diagnosis in the PLC

The following aspects are covered here:

Code Function Implementation Application/evaluation
A The EtherCAT Master's diagnostic information

updated acyclically (yellow) or provided acyclically (green).

 At least the DevState is to be evaluated for the most recent cycle in the PLC.

The EtherCAT Master's diagnostic information offers many more possibilities than are treated in the EtherCAT System Documentation. A few keywords:

  • CoE in the Master for communication with/through the Slaves
  • Functions from TcEtherCAT.lib
  • Perform an OnlineScan
B In the example chosen (EL3102) the EL3102 comprises two analogue input channels that transmit a single function status for the most recent cycle. Status
  • the bit significations may be found in the device documentation
  • other devices may supply more information, or none that is typical of a slave
 In order for the higher-level PLC task (or corresponding control applications) to be able to rely on correct data, the function status must be evaluated there. Such information is therefore provided with the process data for the most recent cycle.
C For every EtherCAT Slave that has cyclic process data, the Master displays, using what is known as a WorkingCounter, whether the slave is participating successfully and without error in the cyclic exchange of process data. This important, elementary information is therefore provided for the most recent cycle in the System Manager
  1. at the EtherCAT Slave, and, with identical contents
  2. as a collective variable at the EtherCAT Master (see Point A)

for linking.

 WcState (Working Counter)

0: valid real-time communication in the last cycle

1: invalid real-time communication

This may possibly have effects on the process data of other Slaves that are located in the same SyncUnit

 In order for the higher-level PLC task (or corresponding control applications) to be able to rely on correct data, the communication status of the EtherCAT Slave must be evaluated there. Such information is therefore provided with the process data for the most recent cycle.
D Diagnostic information of the EtherCAT Master which, while it is represented at the slave for linking, is actually determined by the Master for the Slave concerned and represented there. This information cannot be characterized as real-time, because it
  • is only rarely/never changed, except when the system starts up
  • is itself determined acyclically (e.g. EtherCAT Status)
 State

current Status (INIT..OP) of the Slave. The Slave must be in OP (=8) when operating normally.

AdsAddr

The ADS address is useful for communicating from the PLC/task via ADS with the EtherCAT Slave, e.g. for reading/writing to the CoE. The AMS-NetID of a slave corresponds to the AMS-NetID of the EtherCAT Master; communication with the individual Slave is possible via the port (= EtherCAT address).

 Information variables for the EtherCAT Master that are updated acyclically. This means that it is possible that in any particular cycle they do not represent the latest possible status. It is therefore possible to read such variables through ADS.

Attention 		Diagnostic information
It is strongly recommended that the diagnostic information made available is evaluated so that the application can react accordingly.

CoE Parameter Directory

The CoE parameter directory (CanOpen-over-EtherCAT) is used to manage the set values for the slave concerned. Changes may, in some circumstances, have to be made here when commissioning a relatively complex EtherCAT Slave. It can be accessed through the TwinCAT System Manager, see Fig. 3:

Fig. 3: EL3102, CoE directory

Note 		EtherCAT System Documentation
The comprehensive description in the EtherCAT System Documentation (EtherCAT Basics --> CoE Interface) must be observed!

A few brief extracts:

  • Whether changes in the online directory are saved locally in the slave depends on the device. EL terminals (except the EL66xx) are able to save in this way.
  • The user must manage the changes to the StartUp list.

Commissioning aid in the TwinCAT System Manager

Commissioning interfaces are being introduced as part of an ongoing process for EL/EP EtherCAT devices. These are available in TwinCAT System Managers from TwinCAT 2.11R2 and above. They are integrated into the System Manager through appropriately extended ESI configuration files.

Fig. 4: Example of commissioning aid for a EL3204

This commissioning process simultaneously manages

  • CoE Parameter Directory
  • DC/FreeRun mode
  • the available process data records (PDO)

Although the "Process Data", "DC", "Startup" and "CoE-Online" that used to be necessary for this are still displayed, it is recommended that, if the commissioning aid is used, the automatically generated settings are not changed by it.

The commissioning tool does not cover every possible application of an EL/EP device. If the available setting options are not adequate, the user can make the DC, PDO and CoE settings manually, as in the past.

EtherCAT State: automatic default behaviour of the TwinCAT System Manager and manual operation

After the operating power is switched on, an EtherCAT Slave must go through the following statuses

  • INIT
  • PREOP
  • SAFEOP
  • OP

to ensure sound operation. The EtherCAT Master directs these statuses in accordance with the initialization routines that are defined for commissioning the device by the ES/XML and user settings (Distributed Clocks (DC), PDO, CoE). See also the section on "Principles of Communication, EtherCAT State Machine" in this connection. Depending how much configuration has to be done, and on the overall communication, booting can take up to a few seconds.

The EtherCAT Master itself must go through these routines when starting, until it has reached at least the OP target state.

The target state wanted by the user, and which is brought about automatically at start-up by TwinCAT, can be set in the System Manager. As soon as TwinCAT reaches the status RUN, the TwinCAT EtherCAT Master will approach the target states.

Standard setting

The advanced settings of the EtherCAT Master are set as standard:

  • EtherCAT Master: OP
  • Slaves: OP
    This setting applies equally to all Slaves.

Fig. 5: Default behaviour of the System Manager

In addition, the target state of any particular Slave can be set in the "Advanced Settings" dialogue; the standard setting is again OP.

Fig. 6: Default target state in the Slave

Manual Control

There are particular reasons why it may be appropriate to control the states from the application/task/PLC. For instance:

  • for diagnostic reasons
  • to induce a controlled restart of axes
  • because a change in the times involved in starting is desirable

In that case it is appropriate in the PLC application to use the PLC function blocks from the TcEtherCAT.lib, which is available as standard, and to work through the states in a controlled manner using, for instance, FB_EcSetMasterState.

It is then useful to put the settings in the EtherCAT Master to INIT for master and slave.

Fig. 7: PLC function blocks

Note regarding E-Bus current

EL/ES terminals are placed on the DIN rail at a coupler on the terminal strand. A Bus Coupler can supply the EL terminals added to it with the E-bus system voltage of 5 V; a coupler is thereby loadable up to 2 A as a rule. Information on how much current each EL terminal requires from the E-bus supply is available online and in the catalogue. If the added terminals require more current than the coupler can supply, then power feed terminals (e.g. EL9410) must be inserted at appropriate places in the terminal strand.

The pre-calculated theoretical maximum E-Bus current is displayed in the TwinCAT System Manager as a column value. A shortfall is marked by a negative total amount and an exclamation mark; a power feed terminal is to be placed before such a position.

Fig. 8: illegally exceeding the E-Bus current

From TwinCAT 2.11 and above, a warning message "E-Bus Power of Terminal..." is output in the logger window when such a configuration is activated:

Fig. 9: Warning message for exceeding E-Bus current

Attention 		Caution! Malfunction possible!
The same ground potential must be used for the E-Bus supply of all EtherCAT terminals in a terminal block!


TwinCAT System Manager - Configuration

BECKHOFF TwinCAT System Manager: Configuration

Configuration by means of the TwinCAT System Manager

(with TwinCAT from version 2.10.0 (Build 1241), using EL5001 from firmware version 0.7 as an example)

In the left-hand window of the TwinCAT System Manager, click on the branch you wish to configure (in the example: EL5001 Terminal 6).

In the right-hand window of the TwinCAT System manager, various tabs are now available for configuring the terminal.

General tab

Name | Name of the EtherCAT device
Id | Number of the EtherCAT device
Type | EtherCAT device type
Comment | Here you can add a comment (e.g. regarding the system).
Disabled | Here you can deactivate the EtherCAT device.
Create symbols | Access to this EtherCAT slave via ADS is only available if this control box is activated.

EtherCAT tab

Type | EtherCAT device type
Product/Revision | Product and revision number of the EtherCAT device
Auto Inc Addr. | Auto increment address of the EtherCAT device. The auto increment address can be used for addressing each EtherCAT device in the communication ring through its physical position. Auto increment addressing is used during the start-up phase when the EtherCAT master allocates addresses to the EtherCAT devices. With auto increment addressing the first EtherCAT slave in the ring has the address 0000hex. For each further slave the address is decremented by 1 (FFFFhex, FFFEhex etc.).
EtherCAT Addr. | Fixed address of an EtherCAT slave. This address is allocated by the EtherCAT master during the start-up phase. Tick the control box to the left of the input field in order to modify the default value.
Previous Port | Name and port of the EtherCAT device to which this device is connected. If it is possible to connect this device with another one without changing the order of the EtherCAT devices in the communication ring, then this combination field is activated and the EtherCAT device to which this device is to be connected can be selected.
Advanced Settings | This button opens the dialogs for advanced settings.

The link at the bottom of the tab points to the product page for this EtherCAT device on the web.

Process Data tab

Indicates the configuration of the process data. The input and output data of the EtherCAT slave are represented as CANopen process data objects (PDO). The user can select a PDO via PDO assignment and modify the content of the individual PDO via this dialog, if the EtherCAT slave supports this function.

Sync Manager

Lists the configuration of the Sync Manager (SM).
If the EtherCAT device has a mailbox, SM0 is used for the mailbox output (MbxOut) and SM1 for the mailbox input (MbxIn).
SM2 is used for the output process data (outputs) and SM3 (inputs) for the input process data.

If an input is selected, the corresponding PDO assignment is displayed in the PDO Assignment list below.

PDO Assignment

PDO assignment of the selected Sync Manager. All PDOs defined for this Sync Manager type are listed here:

  • If the output Sync Manager (outputs) is selected in the Sync Manager list, all RxPDOs are displayed.
  • If the input Sync Manager (inputs) is selected in the Sync Manager list, all TxPDOs are displayed.

The selected entries are the PDOs involved in the process data transfer. In the tree diagram of the System Manager these PDOs are displayed as variables of the EtherCAT device. The name of the variable is identical to the Name parameter of the PDO, as displayed in the PDO list. If an entry in the PDO assignment list is deactivated (not selected and greyed out), this indicates that the input is excluded from the PDO assignment. In order to be able do select a greyed out PDO, the currently selected PDO has to be deselected first.

Note 		Activation of PDO assignment
If you have changed the PDO assignment, in order to activate the new PDO assignment,
  • the EtherCAT slave has to run through the PS status transition cycle (from pre-operational to safe-operational) once (see Online tab),
  • and the System Manager has to reload the EtherCAT slaves ( [image] button)

PDO list

List of all PDOs supported by this EtherCAT device. The content of the selected PDOs is displayed in the PDO Content list. The PDO configuration can be modified by double-clicking on an entry.

Column | Description
Index | PDO index.
Size | Size of the PDO in bytes.
Name | Name of the PDO. If this PDO is assigned to a Sync Manager, it appears as a variable of the slave with this parameter as the name.
Flags | F | Fixed content: The content of this PDO is fixed and cannot be changed by the System Manager.
 | M | Mandatory PDO. This PDO is mandatory and must therefore be assigned to a Sync Manager! Consequently, this PDO cannot be deleted from the PDO Assignment list
SM | Sync Manager to which this PDO is assigned. If this entry is empty, this PDO does not take part in the process data traffic.
SU | Sync unit to which this PDO is assigned.

PDO Content

Indicates the content of the PDO. If flag F (fixed content) of the PDO is not set the content can be modified.

Download

If the device is intelligent and has a mailbox, the configuration of the PDO and the PDO assignments can be downloaded to the device. This is an optional feature that is not supported by all EtherCAT slaves.

PDO Assignment

If this check box is selected, the PDO assignment that is configured in the PDO Assignment list is downloaded to the device on startup. The required commands to be sent to the device can be viewed in the Startup tab.

PDO Configuration

If this check box is selected, the configuration of the respective PDOs (as shown in the PDO list and the PDO Content display) is downloaded to the EtherCAT slave.

Startup tab

The Startup tab is displayed if the EtherCAT slave has a mailbox and supports the CANopen over EtherCAT (CoE) or Servo drive over EtherCAT protocol. This tab indicates which download requests are sent to the mailbox during startup. It is also possible to add new mailbox requests to the list display. The download requests are sent to the slave in the same order as they are shown in the list.

Column | Description
Transition Transition to which the request is sent. This can either be
  • the transition from pre-operational to safe-operational (PS), or
  • the transition from safe-operational to operational (SO).

If the transition is enclosed in "<>" (e.g. <PS>), the mailbox request is fixed and cannot be modified or deleted by the user.
Protocol | Type of mailbox protocol
Index | Index of the object
Data | Date on which this object is to be downloaded.
Comment | Description of the request to be sent to the mailbox
Move Up | This button moves the selected request up by one position in the list.
Move Down | This button moves the selected request down by one position in the list.
New | This button adds a new mailbox download request to be sent during startup.
Delete | This button deletes the selected entry.
Edit | This button edits an existing request.

CoE - Online tab

The additional CoE - Online tab is displayed if the EtherCAT slave supports the CANopen over EtherCAT (CoE) protocol. This dialog lists the content of the object list of the slave (SDO upload) and enables the user to modify the content of an object from this list. Details for the objects of the individual EtherCAT devices can be found in the device-specific object descriptions.

Object list display
Column | Description
Index | Index and sub-index of the object
Name | Name of the object
Flags | RW | The object can be read, and data can be written to the object (read/write)
 | RO | The object can be read, but no data can be written to the object (read only)
 | P | An additional P identifies the object as a process data object.
Value | Value of the object
Update List | The Update list button updates all objects in the displayed list
Auto Update | If this check box is selected, the content of the objects is updated automatically.
Advanced | The Advanced button opens the Advanced Settings dialog. Here you can specify which objects are displayed in the list.

Online - via SDO Information | If this option button is selected, the list of the objects included in the object list of the slave is uploaded from the slave via SDO information. The list below can be used to specify which object types are to be uploaded.
Offline - via EDS File | If this option button is selected, the list of the objects included in the object list is read from an EDS file provided by the user.

Online tab

State Machine

Init | This button attempts to set the EtherCAT device to the Init state.
Pre-Op | This button attempts to set the EtherCAT device to the pre-operational state.
Op | This button attempts to set the EtherCAT device to the operational state.
Bootstrap | This button attempts to set the EtherCAT device to the Bootstrap state.
Safe-Op | This button attempts to set the EtherCAT device to the safe-operational state.
Clear Error | This button attempts to delete the fault display. If an EtherCAT slave fails during change of state it sets an error flag. Example: An EtherCAT slave is in PREOP state (pre-operational). The master now requests the SAFEOP state (safe-operational). If the slave fails during change of state it sets the error flag. The current state is now displayed as ERR PREOP. When the Clear Error button is pressed the error flag is cleared, and the current state is displayed as PREOP again.
Current State | Indicates the current state of the EtherCAT device.
Requested State | Indicates the state requested for the EtherCAT device.

DLL Status

Indicates the DLL status (data link layer status) of the individual ports of the EtherCAT slave. The DLL status can have four different states:

Status | Description
No Carrier / Open | No carrier signal is available at the port, but the port is open.
No Carrier / Closed | No carrier signal is available at the port, and the port is closed.
Carrier / Open | A carrier signal is available at the port, and the port is open.
Carrier / Closed | A carrier signal is available at the port, but the port is closed.

File Access over EtherCAT

Download | With this button a file can be written to the EtherCAT device.
Upload | With this button a file can be read from the EtherCAT device.


EL320x - Overview

BECKHOFF EL320x: Commissioning

Settings and application notes EL320x-00xx

Contents

• Default setting
- Notice regarding Resistance Measurement mode
• Changing the slave parameters in the CoE directory
• Further application notes

Default setting

The EL320x-0000 can be used for direct temperature or resistance measurements. Version -0010/-0020 offers enhanced measurement precision. The corresponding CoE settings are shown in the following table.

The relationship between temperature and resistance of a PT100/PT1000 sensor is shown below:

Temperature | typical resistance, approx.
850°C | PT1000: 3.9 kO PT100: 390 O
320°C | PT1000: 2.2 kO PT100: 220 O
-200°C | PT1000: 180 O PT100: 18 O

Characteristic sensor curves are available from the sensor manufacturers.

You can obtain further information in the chapters Object description and parameterization and Process data and operating modes.

EL320x-0000 EL320x-0010/-0020
Default/factory setting
  • 2-conductor connection
  • Pt100 (CoE x80n0:19)
  • Presentation signed (CoE x80n0:02)
  • Limits disabled
  • 50 Hz Filter enabled
  • All channels enabled
  • 4-wire connection (CoE x80n0:1A)
    The connection type is not detected automatically.
  • Pt100 (CoE x80n0:19)
    Measurements take place in a reduced measuring range of –200 to 320 °C or an equivalent resistance range.

    The type label “PT100 (-200 to 850°C)” indicates the usual measuring range of a PT100 element

  • Presentation HighResolution (CoE x80n0:02)
    The temperature is displayed with 1/100 °C per digit (signed).
  • Limits disabled
  • 50 Hz Filter enabled
  • All channels enabled
Area of application The terminal is calibrated in the measuring range "1/16 Ω" (10 Ω to 4 kΩ) and can be used in this resistance range. The high-precision version is calibrated in the measuring range "1/64 Ω" (10 Ω to 1 kΩ) and over a measuring range of 18 to 220 Ω and should only be used in this range or for PT100 measurements.

In other measuring ranges it offers the standard precision of <±0.5°C.

Notice regarding Resistance Measurement mode

In Resistance Measurement mode the measured value is always displayed unsigned, irrespective of the Presentation setting (CoE x80n0:02), as 0..xFFFF with the respective value.

1/16 O -> ~62 mO/Digit

1/64 O -> ~15 mO/Digit

Changing the slave parameters in the CoE directory

During commissioning it may be necessary to change the CoE parameters.

  • If the terminal is accessed online, the CoE directory is read from the slave and can be changed; see fig. 6.
  • If the terminal is accessed offline (the terminal is then not addressable) the data from the XML description is used. The parameters cannot be changed.

The CoE parameters (CAN over EtherCAT) can be changed in the "CoE-Online" tab of the EtherCAT slave.

Fig. 6: Accessing the CoE parameters in TwinCAT System Manager

Attention 		Changes in the CoE directory, in the case of exchange
So that, in the case of exchanging an EtherCAT slave, the CoE parameters are set correctly in the new slave, changes on the customer side must be entered in the start-up list.

Note 		Changes in the CoE directory, program access
The CoE parameters can also be read and written during operation (insofar as it makes sense) by the PLC using corresponding control commands. For details, see the corresponding articles in the Beckhoff Information System, for example.

For detailed information on settings and operating modes, please read the chapter "Process data and operating modes".

Further application notes

Note 		"Filter enable" setting
The filter function is always active, even if the object 8000:06 "Filter enable" is set to FALSE.

Note 		"Connection technology" setting
Besides 2, 3 and 4-wire connection, "not connected" can also be selected for each channel. The channel concerned is completely disabled and the conversion time of the EL320x is correspondingly shortened.
By means of a double click on the corresponding object 80x0:1A, the respective channel can be switched off in the Set Value Dialog by selecting the "Enum" value "not connected".

Fig. 7: "not connected" setting


Technology

BECKHOFF EL320x: Commissioning

Settings and application notes for EL3204-0200

Table of contents
  • Measuring range
  • Direct resistance measurement
  • Fixed characteristic sensor curves
  • Linearisation based on sampling points table
  • Linearisation based on B-parameter equation
  • Linearisation according to DIN 60751
  • Linearisation according to Steinhart-Hart
  • Example for NTC
  • Example for PTC
            •

    The EL3204-0200 differs from the EL3204-0000 (standard type) in terms of an

    • extended measuring range 0 ... 240 kΩ
    • additional linearization/characteristic sensor curves
      • programmed characteristic sensor curves match the measuring range
      • freely programmable according to sampling points table
      • parameterizable formulas according to IEC 60751, Steinhart-Hart equation and B-parameter equation

    Attention     		Changes in the CoE directory, in the case of exchange
    So that, in the case of exchanging an EtherCAT slave, the CoE parameters are set correctly in the new slave, CoE changes on the customer side must be entered in the start-up list.

    Notice     		Changes in the CoE directory, program access
    The CoE parameters can also be read and written during operation (insofar as it makes sense) by the PLC using corresponding control commands. For details, see the corresponding articles in the Beckhoff Information System, for example.

    Notice: The CoE parameters should be written in status PreOp or SafeOp, after which the slave should be switched to status OP.

    Measuring range

    The specified terminal precision refers to the full-scale value for the resistance measurement.

    It is not advisable to use the terminal in the range 0 to 10 Ω, due to the relatively low (relative) measuring accuracy in this range. Specialized resistance measuring terminals such as the EL3692 with 4-wire measurement are to be used for such measurements.

    Notice     		Notes regarding accuracy
    In addition to the accuracy of the terminal resistance measurement, the measurement result is influenced by further factors, as described below:
    • Measuring error of the measuring sensor used
    • Measuring error of the terminal: < +/- 0.3% of full-scale value (240 kΩ for resistance measurement); < +/- 0.5°C for Pt sensors
    • Implementation of the calculation parameters in the firmware, e.g. number of sampling points, accuracy of the calculated parameters,...

    We recommend verifying the settings against a calibrated temperature source.

    Programmed characteristic sensor curves

    • Direct resistance measurement

      The EL3204-0200 can be used for direct resistance measurement in 3 measuring ranges (n = channel 0... 3)

      CoE setting x80n0:19 | Measuring range | Resolution/digit
      x80n0:19 = 101 | 0 ...6,553.5 Ω | 0.1 Ω
      x80n0:19 = 102 | 0 ...65,535 Ω | 1 Ω
      x80n0:19 = 103 | 0 ...240,000 Ω | 10 Ω

      Notice: The way in which the EL3204-0200 measures is electrically the same with these 3 settings. Only the displayed resolution is changed in the firmware. The full-scale value is therefore 240 kΩ for all 3 measurements.

    • Fixed characteristic sensor curves

      Further programmed characteristic sensor curves in the defined measuring range can be selected individually in the CoE entry x80n0:19 for each channel (n = channel 0... 3).

      Type | Resistance range | Implemented temperature range | Resolution/digit
      Pt1000 (0.00385 Ω/Ω/°C, IEC60751 characteristic curve Pt385) (PTC) | ~180 ... ~ 3,900 Ω | -200°C to 850°C | 0.1°C
      Ni1000 (PTC) | ~700 ... ~2,300 Ω | -60°C to 250°C | 0.1°C
      Ni1000 (at 100°C: 1500 Ω) (PTC) | -30 to 160°C | 0.1°C
      NTC 5k (0°C: 16325 Ω) | ~167,000 ... ~340 Ω | -40 ...100°C | 0.1°C
      NTC 10k (0°C: 32650 Ω) | ~176,000 ... ~180 Ω | -30 ...150°C | 0.1°C
      NTC 10k (0°C: 29490 Ω) | ~135,000 ... ~240 Ω | -30 ...150°C | 0.1°C
      NTC 10k (0°C: 27280 Ω, as for KL3204-0030) | ~190,000 ... ~760 Ω | -40 ...110°C | 0.1°C
      NTC 20k (0°C: 70200 Ω) | ~221,000 ... ~270 Ω | -20 ...150°C | 0.1°C
      FeT (0°C: 2226 Ω) | ~1,900 ... ~ 3,900 Ω | -30 ...150°C | 0.1°C

    Freely programmable linearisation

    To connect a resisitive sensor with a characteristic curve that is known but not implemented in the EL320x-xxxx, the characteristic curve can be entered in the terminal via one of four different options.
    Each linearization and each NTC/PTC characteristic curve can be realized within the measuring range. The suitability of the different implementation procedures depends on the sensor type.

      CoE entry in x80n0:19 | Characteristic curve type | PTC sensors (e.g. Pt100, Pt1000, Ni100, Ni1000,...) | NTC sensors (NTC 5k, NTC 10k,..)
x80n0:19 = 110 | RTD table/sampling points table | X | X
x80n0:19 = 111 | B-parameter equation | - | X
x80n0:19 = 112 | DIN EN 60751 equation | X (standard for Pt sensors) | -
x80n0:19 = 113 | Steinhart-Hart equation | - | X

    Select the procedure for the channel in CoE entry x80n0:19. Please note that for each procedure only 1 parameter set can be stored in the terminal, which is then available for all channels.

    Example: 2 sensors are connected to channels 1 and 2. Both are to be linearized with the B-parameter equation. The two sensors have to be "identical", since it is not possible to specify different sets of B-parameters for channels 1 and 2. The same applies to the sampling points table.

    • Sampling points table (x80n0: 19 = x110)

      The required characteristic curve for a PTC or NTC sensor can be stores as a table in CoE x8001. It can either be loaded directly from the PLC into the CoE, or the user can enter it in the startup list for the terminal as an XML file. The entries from the TwinCAT startup list are automatically written to the terminal whenever EtherCAT starts.
      The sampling points table generally has the following structure: A temperature is allocated to the corresponding resistance. The temperature increment must be constant. Between these values linearization is applied.
      The maximum number of sampling points is 100, the maximum measuring range is 0…240 kΩ.
      The precise structure of the sampling points table is explained in the CoE overview and also in a sample file for a Pt1000 sensor.
      The sample file illustrates the structure of an XML file for import. An Excel file (Excel 2010 format) for creating an XML file is also included. Explanatory notes for using the Excel file are included.

      The XML file can be imported directly via the Startup field and activated via "Activate configuration".

      Fig. 1: Importing the XML file

    • B-parameter equation (x80n0:19 = 111)

      The B-parameter equation can be used for NTC sensors (thermistors), i.e. RTD elements with negative coefficient k.

      The coefficient RT0 indicates the resistance at temperature T0. The B-parameter can be taken from the information provided by the sensor manufacturer, or it can be determined by measuring the resistance at two known temperatures.
      The following sample file can be used for calculating the B-parameter. Enter the calculated parameters in the CoE directory x8002.

      Fig. 2: Table for calculating the B-parameter

    • Programmable according to DIN 60751 for Pt sensors (x80n0:19 = x112)

      IEC 751 (and the German version DIN EN 60751) defines the electrical properties of platinum temperature sensors. The characteristic curve is described as follows:

      for temperatures -200.. 0°C:

      for temperatures 0.. 850°C:

      With parameters:

      The parameter R0 indicates the resistance in ohm of the platinum sensor at T = 0 °C. The sensor designations are based on these characteristics, e.g. for Pt100 R0 = 100 Ω at T=0 °C.
      The parameters A, B and C defined in the standard are already stored in CoE directory x8003:y. The Pt sensor is specified via parameter x8003:03, which corresponds to R0.

    • Steinhart-Hart equation (x80n0:19 = x113)

      The Steinhart-Hart equation can be used for NTC sensors (thermistors), i.e. RTD elements with negative coefficient k.

      The coefficients C1, C2 and C4 can either be taken directly from the manufacturer data or calculated.
      The calculation of the Steinhart-Hart parameters is illustrated in a sample file. For determining the parameters the resistance values at three known temperatures are required. These can either be taken from the manufacturer data or measured directly at the sensor. Enter the calculated parameters in the CoE directory x8004. In most cases the parameter C3 is close to zero, i.e. negligible. It is therefore not used in the sample file calculation.

      Fig. 2: Table for calculating the Steinhart-Hart parameters

    Sample implementation of an NTC sensor

    The procedure below illustrates the implementation of an NTC sensor whose characteristic curve is not already stored in the EL3204-0200 based on three methods, i.e. RTD table, B-parameter equation and Steinhart-Hart equation.
    An NTC030WP00 sensor is used in the example.

    In this case the manufacturer provides a table with temperature and corresponding resistance values and the following sensor characteristics: NTC 10kΩ +/- 1% at 25°C, Beta 3435.

  • Implementation based on sampling points table, RTD table

    The general procedure is described in section Sampling points table. This example illustrates some special cases. A sample XML file for the NTC030WP00 sensor is available for download.
    Description | Problem | Approach
    The table covers the temperature range -50 °C... 110 °C, in 1 °C steps The total number of sampling points 160. Currently, up to 100 sampling points can be entered based on the RTD table. 1. Limit the measuring range to correspond with 100 sampling points in total.

    2. Increase the step size, e.g. implement a table with 5 °C steps. The step size should not be too large, since NTC sensors have an exponential characteristic curve (i.e. not linear such as the PTC sensors, for example).

    Resistance values in the temperature range -50 °C.. -44 °C are in the range 330 kΩ.. 240 kΩ Measurement readings at low temperatures exceed the total measuring range of 240 kΩ 1. Check whether the measuring range is required

    2. Select an alternative sensor with lower resistance values at low temperatures.

    The range -40 °C...110 °C should be mapped in 2 °C steps. In addition to the table the following settings are implemented in CoE x8001: The default settings of conversion factor 10 result in errors: The measuring range was exceeded. Adjust the unit of the resistance values to the conversion factor Note the measuring range. For the range 0....240 kΩ a conversion factor of 100 should be entered in x8001:04. The resistance values should then be specified in 1/10 Ω.

    The ranges are defined as follows:
    8001:01 Distance in Degrees | 2
    8001:02 Amount of Entries | 75 | Conversion Factor x8001:04 | Measuring range
    8001:03 Start temperature | -40 | 1 | 0.. 6,533.5 Ω
    8001:04 Conversion Factor | 10 | 10 | 0..65,535.0 Ω
    8001:05 Value 1 | 188500 | 100 | 0..240,000.0 Ω

  • Implementation based on B-parameter equation

    The B-parameter (Beta 3435) and the parameters Rn (10kΩ) and Tn (25°C) can be taken from the manufacturer's data and entered directly in the CoE directory x8002.
    CoE Entry | Entry
    8002:01 Min Temperature | -40
    8002:02 Max Temperature | 110
    8002:03 Rn | 10000
    8002:04 Tn | 25
    8002:05 B-parameter | 3435

    If one compares the implementation of the table and the B-parameter equation, as shown in the diagram below, it becomes clear that the B-parameter equation is only valid in a limited range (large deviations at low temperatures). If the whole temperature range is required, it is preferable to use the Steinhart-Hart equation for the implementation.

  • Implementation via the Steinhart-Hart equation

    The Steinhart-Hart parameters can be calculated based on the sample file. The required resistance values at three defined temperatures (e.g. 0°C, 25°C and 85°C) can be taken from the manufacturer's table or measured direct at the sensor.

    CoE Entry | Entry
    8004:01 Min Temperature | -40
    8004:02 Max Temperature | 110
    8004:03 C1 | 8.8424E-4
    8004:04 C2 | 2.5202E-4
    8002:04 C3 | 0
    8002:04 C4 | 1.9018E-7

    The diagram shows that the implementation via the Steinhart-Hart equation is closer to the values from the manufacturer's table than the implementation via the B-parameter equation. If a manufacturer's table is available, this method is always preferable.

    Fig. 3: Comparison of implementation via B-parameters and Steinhart-Hart parameters

    Sample implementation of an PTC sensor

    The example below illustrates the implementation of a PTC sensor, in particular a platinum sensor (Pt sensor), based on the RTD table and according to DIN EN 60751.

  • Implementation based on sampling points table, RTD table

    The general procedure is explained in section Sampling points table. The example describes the implementation of table for a Pt500 sensor.
    Description | Problem | Approach
    For Pt sensors tables with several 100 entries in 1 °C steps are available. The total number of sampling points is exceeded. Currently, up to 100 sampling points can be entered based on the RTD table. 1. Limit the measuring range to correspond with 100 sampling points in total.

    2. Increase the step size, e.g. implement a table with 5 °C or 10 °C steps. Since the Pt sensor curves are almost linear, an increment value only has a small effect on the measuring accuracy. This is in contrast to NTC sensors, where the curve is exponential and a smaller increment is therefore preferable.

    The manufacturer tables contain universal values | The table values should be adjusted to the specific sensor type | For different Pt sensors the table entries have to be multiplied with the R0 value. R0 indicates the resistance at 0°C. The sensor name is based on the temperature value.
    Pt sensor | R0 (resistance at 0°C)
    Pt100 | 100
    Pt500 | 500
    Pt1000 | 1000

    For the Pt500 sensor the following CoE entries can be selected and used with the following XML file:

    CoE Entry | Entry
    8001:01 Distance in Degrees | 10
    8001:02 Amount of Entries | 60
    8001:03 Start Temperature | -40
    8001:04 Conversion Factor | 10
    8001:05 Value 1 | 4247
    8001:0x, further table entries .....

  • Programmable according to DIN 60751 for Pt sensors

    The implementation according to DIN EN 60751 is described in Programmable_according_to_DIN_60751_for_Pt sensors. The parameters A, B, C are already stored in the CoE. Only the temperature range and the R0 parameter for the specific sensor has to be added. R0 indicates the resistance at 0°C. The sensor name is based on the temperature value. The CoE entry has to be adjusted for the specific sensor.
    Pt sensor | CoE Entry x8003:03
    Pt100 | 100
    Pt200 | 200
    Pt500 | 500
    Pt1000 | 1000

    If one compare curve showing the resistance values over temperature, the RTD table and according to DIN EN 60751, it is clear that both implementation methods deliver almost the same result. Parameterisation according to DIN 60571 is simpler and therefore preferable.

    Fig. 4: Comparison of Pt500 sensor implementation


EL320x - Process data

BECKHOFF EL320x: Commissioning

Process data and operating modes

Contents
• Data flow

• Sync Manager

• Operating modes and settings

- Display
 - Siemens Bits
 - Underrange, Overrange
 - Notch filter (conversion times)
 - Limit 1 and Limit 2
 - Calibration
- Producer Codeword

• Interference from equipment

Data flow

Fig. 1: Data scheme

Sync Manager (SM)

PDO Assignment

SM3, PDO assignment 0x1C13
Index | Index of excluded PDOs | Size (byte.bit) | Name | PDO content
0x1A00 (default) | - | 4.0 | TC Inputs | Index 0x6000:01 - Underrange Index 0x6000:02 - Overrange Index 0x6000:03 - Limit 1 Index 0x6000:05 - Limit 2 Index 0x6000:07 - Error Index 0x1800:07 - TxPDO Status Index 0x1800:09 - TxPDO Toggle Index 0x6000:11 - Value
0x1A01 (default) * | - | 4.0 | ENC Inputs | Index 0x6010:01 - Underrange Index 0x6010:02 - Overrange Index 0x6010:03 - Limit 1 Index 0x6010:05 - Limit 2 Index 0x6010:07 - Error Index 0x1801:07 - TxPDO Status Index 0x1801:09 - TxPDO Toggle Index 0x6010:11 - Value
0x1A02 (default) ** | - | 4.0 | ENC Inputs | Index 0x6020:01 - Underrange Index 0x6020:02 - Overrange Index 0x6020:03 - Limit 1 Index 0x6020:05 - Limit 2 Index 0x6020:07 - Error Index 0x1802:07 - TxPDO Status Index 0x1802:09 - TxPDO Toggle Index 0x6020:11 - Value
0x1A03(default) ** | - | 4.0 | ENC Inputs | Index 0x6030:01 - Underrange Index 0x6030:02 - Overrange Index 0x6030:03 - Limit 1 Index 0x6030:05 - Limit 2 Index 0x6030:07 - Error Index 0x1803:07 - TxPDO Status Index 0x1803:09 - TxPDO Toggle Index 0x6030:11 - Value

* EL3202 and EL3204 only
** EL3204 only

Table 1: SyncManager PDO assignment

Operating modes and settings

Presentation, index 80x0:02

In the delivery state, the measured value is output in increments of 1/10° C in two's complement format (signed integer).
Index 80x0:02 offers the possibility to change the method of representation of the measured value.

Measured value | Output (hexadecimal) | Output (signed integer, decimal)
-250.0 °C | 0xF63C | -2500
-200.0 °C | 0xF830 | -2000
-100.0 °C | 0xFC18 | -1000
-0.1 °C | 0xFFFF | -1
-0,0 °C | 0x0000 | 0
-0.1 °C | 0x0001 | 1
100.0 °C | 0x03E8 | 1000
200.0 °C | 0x07D0 | 2000
500.0 °C | 0x1388 | 5000
850.0 °C | 0x2134 | 8500

Table 2: Output of measured value and process data

Note 		Presentation
• | Signed integer: The measured value is presented in two’s complement format. Maximum presentation range for 16 bit = -32768 .. +32767 Example: 1000 0000 0000 0000bin = 0x8000hex = - 32768dec 1111 1111 1111 1110bin = 0xFFFEhex = - 2dec 1111 1111 1111 1111bin = 0xFFFFhex = - 1dec 0000 0000 0000 0001bin = 0x0001hex = +1dec 0000 0000 0000 0010bin = 0x0002hex = +2dec 0111 1111 1111 1111bin = 0x7FFFhex = +32767dec
• | Absolute value with MSB as sign: The measured value is output in magnitude-sign format. Maximum presentation range for 16 bit = -32767 .. +32767 Example: 1111 1111 1111 1111bin = 0xFFFFhex = - 32767dec 1000 0000 0000 0010bin = 0x8002hex = - 2dec 1000 0000 0000 0001bin = 0x8001hex = - 1dec 0000 0000 0000 0001bin = 0x0001hex = +1dec 0000 0000 0000 0010bin = 0x0002hex = +2dec 0111 1111 1111 1111bin = 0x7FFFhex = +32767dec
• | High resolution (1/100 C°): The measured value is output in 1/100 °C steps. The maximum measurement range is limited to 32767dec * (1/100) °C = 327,67 °C, but can be expanded with the user scale feature!

Siemens Bits, index 80x0:05

If this bit is set, status displays are superimposed on the lowest three bits. In the error case "overrange" or "underrange", bit 0 is set.

Undershoot and overshoot of the measuring range (under-range, over-range), index 60x0:02, 60x0:03

• | Pt 100: T > 850 °C (R > 400 Ω): Index 60x0:02 and index 60x0:07 (over-range and error bit) are set. The linearisation of the characteristic curve is continued with the coefficients of the over-range limit up to the limit stop of the A/D converter or to the maximum value (approx. 500 Ohm for Pt100)
• | Pt100: T < - 200 °C (R < 18 Ω): Index 60x0:01 and index 60x0:07 (under-range and error bit) are set. The least negative number is output (0x8001 comply with -32767).

For over-range or under-range the red error LED is switched on.

Notch filter, index 80x0:06

The EL320x terminals are equipped with a digital filter. The filter performs a notch filter (Kerb filter) function and determines the conversion time of the terminal. It is parameterized via the indices 80x0:15. The higher the filter frequency, the faster the conversion time.
Notchfilter means, that the filter has "notches" at the specified filter frequency and multiples of this frequency. These points will be suppressed in the frequency response. Therefore, to suppress 50 Hz, the 50 Hz or 10 Hz filter can be used. In common, all lower frequencies than the filter frequency should be measured. Therefore, in this case the 50 Hz adjustment has to be used.

Fig. 2: typ. frequency response of a notch filter adjusted to 50 Hz

Note 		Index 80x0:06
The filter function is always active even if the bit is not set, since this is obligatory for the measurement process!

Information about conversion times:

  • the conversion time depends on the number of active channels, the number of measurements (2/4 wire), the filter time, the const. calculation time
  • the conversion time for 2 wire measurement is the double time as for 4 wire measurement
  • the resistor measurement equates to the 4 wire measurement
  • the process data "TxPDO Toggle" changes its status, if a new measured value is pending.

Note 		The filter characteristics are set via index 8000:15
The filter frequencies are set for all channels of the EL320x terminals centrally via index 8000:15 (channel 1).
The corresponding indices 8010:15 of the EL3202 or 8010:15, 8020:15, 8030:15 of the EL3204 have no parameterization function.

Note 		Switching off the unused channels of multi-channel terminals
Unused channels should be switched off if filter frequencies are ≥ 1 kHz (optimization of conversion times)!

The channel concerned is completely disabled and the conversion time of the EL320x is correspondingly shortened.
By means of a double click on the corresponding object 80x0:1A, the respective channel can be switched off in the Set Value Dialog by selecting the "Enum" value "not connected"

Fig. 3: Set Value Dialog

Typical conversion times (EL3204)

Filter frequency | Conversion time (update time)
5 Hz | 800 ms
10 Hz | 400 ms
50 Hz | 82 ms (21 ms / 1 channel)
60 Hz | 70 ms
100 Hz | 43 ms
500 Hz | 11 ms
1000 Hz | 7 ms
2000 Hz | 6.5 ms (2 ms / 1 channel)
3750 Hz | 6 ms
7500 Hz | 6 ms
15000 Hz | 6 ms
30000 Hz | 6 ms
mV range | 6 ms

Table 3: Conversion times in relation to the filter frequencies, 4 wire measurement (subject to unheralded alteration by Beckhoff)

Typical conversion times (EL3201, EL3201-0010, 4 wire measurement)

Filter frequency | Conversion time (update time)
5 Hz | 205 ms
10 Hz | 105 ms
50 Hz | 25 ms
60 Hz | 21 ms
100 Hz | 15 ms
500 Hz | 5 ms
1000 Hz | 4 ms
2000 Hz | 4 ms
3750 Hz | 4 ms
7500 Hz | 4 ms
15000 Hz | 4 ms
30000 Hz | 4 ms

Table 4: Conversion times in relation to the filter frequencies, 4 wire measurement (subject to unheralded alteration by Beckhoff)

Note 		Enhanced accuracy EL320x-00x0
You must not change the settings of the object 8000 / RTD settings at the terminals with enhanced accuracy!
The enhanced accuracy of the EL320x-00x0 is true for the following settings:
  • Pt100 sensors
  • Ambient temperature of 40°C
  • 4 wire connection
  • Measuring range -200 to 320°C
  • 50 Hz filter

Limit 1 and Limit 2, index 80x0:13, index 80x0:14

A temperature range can be set that is compared with the values in the indices 80x0:13 and 80x0:14. The bits are set in the process data if the limit values are undershot or exceeded
The limit evaluation takes place after taking into account the set characteristic curve and negative values.

Limit [2] interpretation (default):

x00, 0: not active
x01, 1: Value > Limit value
x10, 2: Value < Limit value
x11, 3: Value = Limit value

Calibration

User scaling, index 80x0:01

The user scaling is enabled via index 80x0:01. Parameterization takes place via the indices

• | 80x0:11 User scaling offset
• | 80x0:12 User scaling gain

Vendor calibration, index 80xF

The manufacturer calibration is enabled via index 80x0:0B. Parameterization takes place via the indices

• | 80xF:01 Offset (manufacturer calibration)
• | 80xF:02 Gain (manufacturer calibration)
• | 80xF:03 Offset [input RL] (manufacturer calibration)
• | 80xF:04 Gain [input RL] (manufacturer calibration)
• | 80xF:05 Offset [4-wire connection] (manufacturer calibration)
• | 80xF:06 Gain [4-wire connection] (manufacturer calibration)

User calibration, index 80x0:17, 80x0:18

The user calibration is enabled via index 80x0:0A. Parameterization takes place via the indices

• | 80x0:17 User offset calibration
• | 80x0:18 User gain calibration

Process data calculation

The terminal records measured values continuously and places the raw value of its A/D converter into the ADC raw value object 80xE:01 or 80xE:02. The calculation of the correction with the manufacturer’s calibration values takes place after each acquisition of the analog signal. User scaling then follows (optionally):
YH = (XADC - BK) x AK | Measured value following manufacturer calibration (corresponds to YA if index 80x0:0A is inactive)
YA = YH x AW x 2-16 + BW | Measured value following user scaling

Legend

Name | Designation | Index
XADC | Output value of the A/D converter | 80xE:01, 80xE:02
BK | Manufacturer calibration offset (only changeable if the object Producer codeword F008 is set) | 80xF:01, 80xF:03
AK | Manufacturer calibration gain (only changeable if the object Producer codeword F008 is set) | 80xF:02, 80xF:04
BW | User scaling offset (can be activated via index 80x0:0A) | 80x0:17
AW | User scaling gain (can be activated via index 80x0:0A) | 80x0:18
YA | Process data for controller | -

Producer Codeword

Note 		Producer Codeword
The manufacturer reserves the authority for the basic calibration of the terminals. The Producer codeword is therefore at present reserved.

Interference from equipment

When operating the EL320x analog EtherCAT terminals, high frequency superimposed signals from interfering devices (e.g. proportional valves, stepper motors or DC motor output stages) can be picked up by the terminal. In order to guarantee interference-free operation, we recommend the use of separate power supply units for the terminals and the interference-causing devices.


EL320x - Object description and parameterization

BECKHOFF EL320x: Commissioning

Object description and parameterization

Note 		EtherCAT XML Device Description
The description correspond to the display of the CoE objects from the EtherCAT XML Device Description. It is strongly recommended to download the latest revision of the corresponding XML file from the Beckhoff website and follow the installation instructions.

Note 		Parameterization via the CoE list (CAN over EtherCAT)
The terminal is parameterized via the CoE tab (double-click on the respective object) or via the Process data tab (allocation of PDOs).
Please note the following general CoE information when using/manipulating the CoE parameters:
- Keep a startup list if components have to be replaced
- Differentiation between online/offline dictionary, existence of current XML description
- use "CoE reload" for resetting changes

Note 		Relevant objects
• EL3201: all mentioned objects, except with channel description "Ch.2, Ch.3, Ch.4"
• EL3202: all mentioned objects, except with channel description "Ch.3, Ch.4"

• EL3204: all mentioned objects

Introduction

The CoE overview contains objects for different intended applications:

  • Objects required for parameterization and during commissioning and profile specific objects.
  • Objects for indicating internal settings (may be fixed)

The following section first describes the objects require for normal operation, followed by a complete overview of other objects.

Objects for commissioning

Index 1011 Restore default parameters
Index | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore the default settings in the EtherCAT slave | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" ("Set Value Dialog") all terminal-specific objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dez)
Index 8000 RTD Settings Ch.1
Index | Name | Meaning | Data type | Flags | Default
8000:0 | RTD Settings Ch.1 | Max. Subindex | UINT8 | RO | 0x1B (27dez)
8000:01 | Enable user scale | User scale enabled | BOOLEAN | RW | 0x00 (0dez)
8000:02 | Presentation | 0: Signed presentation | BIT3 | RW | 0x00 (0dez)
1: Absolute value with MSB as sign
2: High resolution (1/100 C°) [default for High Precision Terminals EL320x-00x0, see notice!]
The value is output with a resolution of (1/100)°C
8000:05 Siemens bits The S5 bits will be displayed in the least significant bits (Value 60n0:11)

Bit 0 = 1 ("Overange" or "Underrange")
Bit 1 (not used)
Bit 2 (not used) 		BOOLEAN RW 0x00 (0dez)
8000:06 | Enable filter | Filter enabled, the cycle-synchronous data exchange is not applied | BOOLEAN | RW | 0x00 (0dez)
8000:07 | Enable limit 1 | Enable Limit 1 | BOOLEAN | RW | 0x00 (0dez)
8000:08 | Enable limit 2 | Enable Limit 2 | BOOLEAN | RW | 0x00 (0dez)
8000:0A | Enable user calibration | User calibration is enabled, if bit is set | BOOLEAN | RW | 0x00 (0dez)
8000:0B | Enable vendor calibration | Vendor calibration is enabled, if bit is set | BOOLEAN | RW | 0x01 (1dez)
8000:11 | User scale offset | User scale offset | INT16 | RW | 0x0000 (0dez)
8000:12 User scale gain User scale gain
The gain is represented in fixed-point format, with the factor 2-16.
A value of 1 for the gain factor therefore corresponds to 65535dec (0x00010000). 		INT32 RW 0x00010000 (65536dez)
8000:13 | Limit 1 | First limit value for setting the status bits (resolution 0,1 °C) | INT16 | RW | 0x0000 (0dez)
8000:14 | Limit 2 | Second limit value for setting the status bits (resolution 0,1 °C) | INT16 | RW | 0x0000 (0dez)
8000:15 Filter settings This object defines the digital filter settings, if it is activated with index 8000:06 .

The possible settings are numbered consecutively.

Note 		The filter characteristics are set only via index 8000:15
The filter frequencies are set for all channels of the EL320x terminals centrally via index 8000:15 (channel 1).
The corresponding indices 80n0:15 of the EL3202 or EL3204 have no parameterization function!
UINT16 RW 0x0000 (0dez)
0: 50 Hz
1: 60 Hz
2: 100 Hz
3: 500 Hz
4: 1 kHz
5: 2 kHz
6: 3,75 kHz
7: 7,5 kHz
8: 15 kHz
9: 30 kHz
10: 5 Hz
11: 10 Hz
8000:17 | User calibration offset | User calibration offset | INT16 | RW | 0x0000 (0dez)
8000:18 | User calibration gain | User calibration gain | UINT16 | RW | 0xFFFF (65535dez)
8000:19 | RTD element | RTD element | UINT16 | RW | 0x0000 (0dez)
0: Pt100 [for High Precision Terminals see notice!]
-200°C to 850°C
1: Ni100
-60°C to 250°
2: Pt1000
-200°C to 850°C
3: Pt500
-200°C to 850°C
4: Pt200
-200° C to 850°C
5: Ni1000
-60°C to 250°C
6: Ni1000
100°C: 1500 Ohm (-30 to 160°C)
7: Ni120
-60°C to 320°C
8: Output in Ohm
Resolution 1/16 Ohm (10 .. 4095 Ohm)
9: Output in Ohm
Resolution 1/64 Ohm (10 .. 1047 Ohm)
10 - 32:

KT100/110/130/210/230 KTY10/11/13/16/19
KTY81/82-110,120,150 (-50...150°C)
KTY81-121
KTY81-122
KTY81-151
KTY81-152
KTY81/82-210,220,250
KTY81-221
KTY81-222
KTY81-251
KTY81-252
KTY83-110,120,150 (-50...175°C)
KTY83-121
KTY83-122
KTY83-151
KTY83-152
KTY84-130,150 (-40...300°C)
KTY84-151
KTY21/23-6 (-50...150°C)
KTY1x-5
KTY1x-7
KTY21/23-5
KTY21/23-7

8000:1A | Connection technology | Connection technology | UINT16 | RW | 0x0000 (0dez)
0: 2-wire
1: 3-wire
2: 4-wire [default for High Precision Terminals EL320x-00x0, see notice!]
3: not connected
8000:1B | Wire calibration 1/32 Ohm | Wire calibration (resolution 1/32 Ohm) | INT16 | RW | 0x0000 (0dez)
Index 8010 RTD Settings Ch.2
Index | Name | Meaning | Data type | Flags | Default
8010:0 | RTD Settings Ch.2 | Max. Subindex | UINT8 | RO | 0x1B (27dez)
8010:01 | Enable user scale | User scale enabled | BOOLEAN | RW | 0x00 (0dez)
8010:02 | Presentation | 0: Signed presentation | BIT3 | RW | 0x00 (0dez)
1: Absolute value with MSB as sign
2: High resolution (1/100 C°) [default for High Precision Terminals EL320x-00x0, see notice!]
The value is output with a resolution of (1/100)°C
8010:05 Siemens bits The S5 bits will be displayed in the least significant bits (Value 60n0:11)

Bit 0 = 1 ("Overange" or "Underrange")
Bit 1 (not used)
Bit 2 (not used) 		BOOLEAN RW 0x00 (0dez)
8010:06 | Enable filter | Filter enabled, the cycle-synchronous data exchange is not applied | BOOLEAN | RW | 0x00 (0dez)
8010:07 | Enable limit 1 | Enable Limit 1 | BOOLEAN | RW | 0x00 (0dez)
8010:08 | Enable limit 2 | Enable Limit 2 | BOOLEAN | RW | 0x00 (0dez)
8010:0A | Enable user calibration | User calibration is enabled, if bit is set | BOOLEAN | RW | 0x00 (0dez)
8010:0B | Enable vendor calibration | Vendor calibration is enabled, if bit is set | BOOLEAN | RW | 0x01 (1dez)
8010:11 | User scale offset | User scale offset | INT16 | RW | 0x0000 (0dez)
8010:12 User scale gain User scale gain
The gain is represented in fixed-point format, with the factor 2-16.
A value of 1 for the gain factor therefore corresponds to 65535dec (0x00010000). 		INT32 RW 0x00010000 (65536dez)
8010:13 | Limit 1 | First limit value for setting the status bits (resolution 0,1 °C) | INT16 | RW | 0x0000 (0dez)
8010:14 | Limit 2 | Second limit value for setting the status bits (resolution 0,1 °C) | INT16 | RW | 0x0000 (0dez)
8010:15 Filter settings This object defines the digital filter settings, if it is activated with index 8000:06 .

The possible settings are numbered consecutively.

Note 		The filter characteristics are set only via index 8000:15
The filter frequencies are set for all channels of the EL320x terminals centrally via index 8000:15 (channel 1).
The corresponding indices 80n0:15 of the EL3202 or EL3204 have no parameterization function!
UINT16 RW 0x0000 (0dez)
0: 50 Hz
1: 60 Hz
2: 100 Hz
3: 500 Hz
4: 1 kHz
5: 2 kHz
6: 3,75 kHz
7: 7,5 kHz
8: 15 kHz
9: 30 kHz
10: 5 Hz
11: 10 Hz
8010:17 | User calibration offset | User calibration offset | INT16 | RW | 0x0000 (0dez)
8010:18 | User calibration gain | User calibration gain | UINT16 | RW | 0xFFFF (65535dez)
8010:19 | RTD element | RTD element | UINT16 | RW | 0x0000 (0dez)
0: Pt100 [or High Precision Terminals, see notice!]
-200°C to 850°C
1: Ni100
-60°C to 250°
2: Pt1000
-200°C to 850°C
3: Pt500
-200°C to 850°C
4: Pt200
-200° C to 850°C
5: Ni1000
-60°C to 250°C
6: Ni1000
100°C: 1500 Ohm (-30 to 160°C)
7: Ni120
-60°C to 320°C
8: Output in Ohm
Resolution 1/16 Ohm (0 .. 4095 Ohm)
9: Output in Ohm
Resolution 1/64 Ohm (0 .. 1047 Ohm)
10 - 32:

KT100/110/130/210/230 KTY10/11/13/16/19
KTY81/82-110,120,150 (-50...150°C)
KTY81-121
KTY81-122
KTY81-151
KTY81-152
KTY81/82-210,220,250
KTY81-221
KTY81-222
KTY81-251
KTY81-252
KTY83-110,120,150 (-50...175°C)
KTY83-121
KTY83-122
KTY83-151
KTY83-152
KTY84-130,150 (-40...300°C)
KTY84-151
KTY21/23-6 (-50...150°C)
KTY1x-5
KTY1x-7
KTY21/23-5
KTY21/23-7

8010:1A | Connection technology | Connection technology | UINT16 | RW | 0x0000 (0dez)
0: 2-wire
1: 3-wire
2: 4-wire [default for High Precision Terminals EL320x-00x0, see notice!]
3: not connected
8010:1B | Wire calibration 1/32 Ohm | Wire calibration (resolution 1/32 Ohm) | INT16 | RW | 0x0000 (0dez)
Index 8020 RTD Settings Ch.3
Index | Name | Meaning | Data type | Flags | Default
8020:0 | RTD Settings Ch.3 | Max. Subindex | UINT8 | RO | 0x1B (27dez)
8020:01 | Enable user scale | User scale enabled | BOOLEAN | RW | 0x00 (0dez)
8020:02 | Presentation | 0: Signed presentation | BIT3 | RW | 0x00 (0dez)
1: Absolute value with MSB as sign
2: High resolution (1/100 C°)
The value is output with a resolution of (1/100)°C
8020:05 Siemens bits The S5 bits will be displayed in the least significant bits (Value 60n0:11)

Bit 0 = 1 ("Overange" or "Underrange")
Bit 1 (not used)
Bit 2 (not used) 		BOOLEAN RW 0x00 (0dez)
8020:06 | Enable filter | Filter enabled, the cycle-synchronous data exchange is not applied | BOOLEAN | RW | 0x00 (0dez)
8020:07 | Enable limit 1 | Enable Limit 1 | BOOLEAN | RW | 0x00 (0dez)
8020:08 | Enable limit 2 | Enable Limit 2 | BOOLEAN | RW | 0x00 (0dez)
8020:0A | Enable user calibration | User calibration is enabled, if bit is set | BOOLEAN | RW | 0x00 (0dez)
8020:0B | Enable vendor calibration | Vendor calibration is enabled, if bit is set | BOOLEAN | RW | 0x01 (1dez)
8020:11 | User scale offset | User scale offset | INT16 | RW | 0x0000 (0dez)
8020:12 User scale gain User scale gain
The gain is represented in fixed-point format, with the factor 2-16.
A value of 1 for the gain factor therefore corresponds to 65535dec (0x00010000). 		INT32 RW 0x00010000 (65536dez)
8020:13 | Limit 1 | First limit value for setting the status bits (resolution 0,1 °C) | INT16 | RW | 0x0000 (0dez)
8020:14 | Limit 2 | Second limit value for setting the status bits (resolution 0,1 °C) | INT16 | RW | 0x0000 (0dez)
8020:15 Filter settings This object defines the digital filter settings, if it is activated with index 8000:06 .

The possible settings are numbered consecutively.

Note 		The filter characteristics are set only via index 8000:15
The filter frequencies are set for all channels of the EL320x terminals centrally via index 8000:15 (channel 1).
The corresponding indices 80n0:15 of the EL3202 or EL3204 have no parameterization function!
UINT16 RW 0x0000 (0dez)
0: 50 Hz
1: 60 Hz
2: 100 Hz
3: 500 Hz
4: 1 kHz
5: 2 kHz
6: 3,75 kHz
7: 7,5 kHz
8: 15 kHz
9: 30 kHz
10: 5 Hz
11: 10 Hz
8020:17 | User calibration offset | User calibration offset | INT16 | RW | 0x0000 (0dez)
8020:18 | User calibration gain | User calibration gain | UINT16 | RW | 0xFFFF (65535dez)
8020:19 | RTD element | RTD element | UINT16 | RW | 0x0000 (0dez)
0: Pt100
-200°C to 850°C
1: Ni100
-60°C to 250°
2: Pt1000
-200°C to 850°C
3: Pt500
-200°C to 850°C
4: Pt200
-200° C to 850°C
5: Ni1000
-60°C to 250°C
6: Ni1000
100°C: 1500 Ohm (-30 to 160°C)
7: Ni120
-60°C to 320°C
8: Output in Ohm
Resolution 1/16 Ohm (0 .. 4095 Ohm)
9: Output in Ohm
Resolution 1/64 Ohm (0 .. 1047 Ohm)
10 - 32:

KT100/110/130/210/230 KTY10/11/13/16/19
KTY81/82-110,120,150 (-50...150°C)
KTY81-121
KTY81-122
KTY81-151
KTY81-152
KTY81/82-210,220,250
KTY81-221
KTY81-222
KTY81-251
KTY81-252
KTY83-110,120,150 (-50...175°C)
KTY83-121
KTY83-122
KTY83-151
KTY83-152
KTY84-130,150 (-40...300°C)
KTY84-151
KTY21/23-6 (-50...150°C)
KTY1x-5
KTY1x-7
KTY21/23-5
KTY21/23-7

8020:1A | Connection technology | Connection technology | UINT16 | RW | 0x0000 (0dez)
0: 2-wire
1: 3-wire
2: 4-wire
3: not connected
8020:1B | Wire calibration 1/32 Ohm | Wire calibration (resolution 1/32 Ohm) | INT16 | RW | 0x0000 (0dez)
Index 8030 RTD Settings Ch.4
Index | Name | Meaning | Data type | Flags | Default
8030:0 | RTD Settings Ch.4 | Max. Subindex | UINT8 | RO | 0x1B (27dez)
8030:01 | Enable user scale | User scale enabled | BOOLEAN | RW | 0x00 (0dez)
8030:02 | Presentation | 0: Signed presentation | BIT3 | RW | 0x00 (0dez)
1: Absolute value with MSB as sign
2: High resolution (1/100 C°)
The value is output with a resolution of (1/100)°C
8030:05 Siemens bits The S5 bits will be displayed in the least significant bits (Value 60n0:11)

Bit 0 = 1 ("Overange" or "Underrange")
Bit 1 (not used)
Bit 2 (not used) 		BOOLEAN RW 0x00 (0dez)
8030:06 | Enable filter | Filter enabled, the cycle-synchronous data exchange is not applied | BOOLEAN | RW | 0x00 (0dez)
8030:07 | Enable limit 1 | Enable Limit 1 | BOOLEAN | RW | 0x00 (0dez)
8030:08 | Enable limit 2 | Enable Limit 2 | BOOLEAN | RW | 0x00 (0dez)
8030:0A | Enable user calibration | User calibration is enabled, if bit is set | BOOLEAN | RW | 0x00 (0dez)
8030:0B | Enable vendor calibration | Vendor calibration is enabled, if bit is set | BOOLEAN | RW | 0x01 (1dez)
8030:11 | User scale offset | User scale offset | INT16 | RW | 0x0000 (0dez)
8030:12 User scale gain User scale gain
The gain is represented in fixed-point format, with the factor 2-16.
A value of 1 for the gain factor therefore corresponds to 65535dec (0x00010000). 		INT32 RW 0x00010000 (65536dez)
8030:13 | Limit 1 | First limit value for setting the status bits (resolution 0,1 °C) | INT16 | RW | 0x0000 (0dez)
8030:14 | Limit 2 | Second limit value for setting the status bits (resolution 0,1 °C) | INT16 | RW | 0x0000 (0dez)
8030:15 Filter settings This object defines the digital filter settings, if it is activated with index 8000:06 .

The possible settings are numbered consecutively.

Note 		The filter characteristics are set only via index 8000:15
The filter frequencies are set for all channels of the EL320x terminals centrally via index 8000:15 (channel 1).
The corresponding indices 80n0:15 of the EL3202 or EL3204 have no parameterization function!
UINT16 RW 0x0000 (0dez)
0: 50 Hz
1: 60 Hz
2: 100 Hz
3: 500 Hz
4: 1 kHz
5: 2 kHz
6: 3,75 kHz
7: 7,5 kHz
8: 15 kHz
9: 30 kHz
10: 5 Hz
11: 10 Hz
8030:17 | User calibration offset | User calibration offset | INT16 | RW | 0x0000 (0dez)
8030:18 | User calibration gain | User calibration gain | UINT16 | RW | 0xFFFF (65535dez)
8030:19 | RTD element | RTD element | UINT16 | RW | 0x0000 (0dez)
0: Pt100
-200°C to 850°C
1: Ni100
-60°C to 250°
2: Pt1000
-200°C to 850°C
3: Pt500
-200°C to 850°C
4: Pt200
-200° C to 850°C
5: Ni1000
-60°C to 250°C
6: Ni1000
100°C: 1500 Ohm (-30 to 160°C)
7: Ni120
-60°C to 320°C
8: Output in Ohm
Resolution 1/16 Ohm (0 .. 4095 Ohm)
9: Output in Ohm
Resolution 1/64 Ohm (0 .. 1047 Ohm)
10-32:

KT100/110/130/210/230 KTY10/11/13/16/19
KTY81/82-110,120,150 (-50...150°C)
KTY81-121
KTY81-122
KTY81-151
KTY81-152
KTY81/82-210,220,250
KTY81-221
KTY81-222
KTY81-251
KTY81-252
KTY83-110,120,150 (-50...175°C)
KTY83-121
KTY83-122
KTY83-151
KTY83-152
KTY84-130,150 (-40...300°C)
KTY84-151
KTY21/23-6 (-50...150°C)
KTY1x-5
KTY1x-7
KTY21/23-5
KTY21/23-7
8030:1A | Connection technology | Connection technology | UINT16 | RW | 0x0000 (0dez)
0: 2-wire
1: 3-wire
2: 4-wire
3: not connected
8030:1B | Wire calibration 1/32 Ohm | Wire calibration (resolution 1/32 Ohm) | INT16 | RW | 0x0000 (0dez)

Objects for regular operation

In enhanced operating mode the EL5101 has no such objects.

Complete overview

Standard objects (0x1000-0x1FFF)

The standard objects of all EtherCAT slaves have the same meaning.

Index 1000 Device type
Index | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device Type of the EtherCAT slave: The Lo-Word contains the supported CoE Profile (5001). The Hi-Word contains the Module Profile corresponding to the Modular Device Profile. | UINT32 | RO | 0x01401389 (20976521dez)
Index 1008 Device name
Index | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EL3204-0000
Index 1009 Hardware version
Index | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slaves | STRING | RO | 00
Index 100A Software version
Index | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slaves | STRING | RO | 01
Index 1018 Identity
Index | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | contains informations to identify the EtherCAT slave | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x0C843052 (209989714dez)
1018:03 | Revision | Revision number of the EtherCAT-Slave, the Lo-Word (Bit 0-15) indicates the special functions terminal number; the Hi-Word (Bit 16-31) refers to the device descriPtion. | UINT32 | RO | 0x00100000 (1048576dez)
1018:04 | Serial number | Serial number of the EtherCAT-Slave, the Lo-Byte (Bit 0-7) of the Lo-Word contains the year of manufacturing, the Hi-Byte (Bit 8-15) of the Lo-Word contains the week of manufacturing, the Hi-Word (Bit 16-31) is 0 . | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | contains informations for the standardized Upload and Download of the Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksum over all backup entries | UINT32 | RO | 0x00000000 (0dez)
Index 1800 TxPDO-Par Ch.1
Index | Name | Meaning | Data type | Flags | Default
1800:0 | TxPDO-Par Ch.1 | PDO Parameter TxPDO 1 | UINT8 | RO | 0x09 (9dez)
1800:07 | TxPDO-State | The TxPDO State will be set if the corresponding input data could not be read in correctly | BOOLEAN | RO | 0x00 (0dez)
1800:09 | TxPDO-Toggle | the TxPDO Toggle will be toggled with every update of the corresponding input data | BOOLEAN | RO | 0x00 (0dez)
Index 1801 TxPDO-Par Ch.2
Index | Name | Meaning | Data type | Flags | Default
1801:0 | TxPDO-Par Ch.2 | PDO Parameter TxPDO 2 | UINT8 | RO | 0x09 (9dez)
1801:07 | TxPDO-State | The TxPDO State will be set if the corresponding input data could not be read in correctly | BOOLEAN | RO | 0x00 (0dez)
1801:09 | TxPDO-Toggle | the TxPDO Toggle will be toggled with every update of the corresponding input data | BOOLEAN | RO | 0x00 (0dez)
Index 1802 TxPDO-Par Ch.3
Index | Name | Meaning | Data type | Flags | Default
1802:0 | TxPDO-Par Ch.3 | PDO Parameter TxPDO 3 | UINT8 | RO | 0x09 (9dez)
1802:07 | TxPDO-State | The TxPDO State will be set if the corresponding input data could not be read in correctly | BOOLEAN | RO | 0x00 (0dez)
1802:09 | TxPDO-Toggle | the TxPDO Toggle will be toggled with every update of the corresponding input data | BOOLEAN | RO | 0x00 (0dez)
Index 1803 TxPDO-Par Ch.4
Index | Name | Meaning | Data type | Flags | Default
1803:0 | TxPDO-Par Ch.4 | PDO Parameter TxPDO 4 | UINT8 | RO | 0x09 (9dez)
1803:07 | TxPDO-State | The TxPDO State will be set if the corresponding input data could not be read in correctly | BOOLEAN | RO | 0x00 (0dez)
1803:09 | TxPDO-Toggle | the TxPDO Toggle will be toggled with every update of the corresponding input data | BOOLEAN | RO | 0x00 (0dez)
Index 1A00 TxPDO-Map Ch.1
Index | Name | Meaning | Data type | Flags | Default
1A00:0 | TxPDO-Map Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RW | 0x09 (9dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (RTD Inputs Ch.1), entry 0x01 (Underrange)) | UINT32 | RW | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (RTD Inputs Ch.1), entry 0x02 (Overrange)) | UINT32 | RW | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (RTD Inputs Ch.1), entry 0x03 (Limit 1)) | UINT32 | RW | 0x6000:03, 2
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (RTD Inputs Ch.1), entry 0x05 (Limit 2)) | UINT32 | RW | 0x6000:05, 2
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (RTD Inputs Ch.1), entry 0x07 (Error)) | UINT32 | RW | 0x6000:07, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (7 bits align) | UINT32 | RW | 0x0000:00, 7
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x1800 (TxPDO-Par Ch.1), entry 0x07 (TxPDO-State)) | UINT32 | RW | 0x1800:07, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1800 (TxPDO-Par Ch.1), entry 0x09 (TxPDO-Toggle)) | UINT32 | RW | 0x1800:09, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (RTD Inputs Ch.1), entry 0x11 (Value)) | UINT32 | RW | 0x6000:11, 16
Index 1A01 TxPDO-Map Ch.2
Index | Name | Meaning | Data type | Flags | Default
1A01:0 | TxPDO-Map Ch.2 | PDO Mapping TxPDO 2 | UINT8 | RW | 0x09 (9dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (RTD Inputs Ch.2), entry 0x01 (Underrange)) | UINT32 | RW | 0x6010:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (RTD Inputs Ch.2), entry 0x02 (Overrange)) | UINT32 | RW | 0x6010:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (RTD Inputs Ch.2), entry 0x03 (Limit 1)) | UINT32 | RW | 0x6010:03, 2
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (RTD Inputs Ch.2), entry 0x05 (Limit 2)) | UINT32 | RW | 0x6010:05, 2
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (RTD Inputs Ch.2), entry 0x07 (Error)) | UINT32 | RW | 0x6010:07, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (7 bits align) | UINT32 | RW | 0x0000:00, 7
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x1801 (TxPDO-Par Ch.2), entry 0x07 (TxPDO-State)) | UINT32 | RW | 0x1801:07, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1801 (TxPDO-Par Ch.2), entry 0x09 (TxPDO-Toggle)) | UINT32 | RW | 0x1801:09, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6010 (RTD Inputs Ch.2), entry 0x11 (Value)) | UINT32 | RW | 0x6010:11, 16
Index 1A02 TxPDO-Map Ch.3
Index | Name | Meaning | Data type | Flags | Default
1A02:0 | TxPDO-Map Ch.3 | PDO Mapping TxPDO 3 | UINT8 | RW | 0x09 (9dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (RTD Inputs Ch.3), entry 0x01 (Underrange)) | UINT32 | RW | 0x6020:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (RTD Inputs Ch.3), entry 0x02 (Overrange)) | UINT32 | RW | 0x6020:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (RTD Inputs Ch.3), entry 0x03 (Limit 1)) | UINT32 | RW | 0x6020:03, 2
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (RTD Inputs Ch.3), entry 0x05 (Limit 2)) | UINT32 | RW | 0x6020:05, 2
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (RTD Inputs Ch.3), entry 0x07 (Error)) | UINT32 | RW | 0x6020:07, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (7 bits align) | UINT32 | RW | 0x0000:00, 7
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x1802 (TxPDO-Par Ch.3), entry 0x07 (TxPDO-State)) | UINT32 | RW | 0x1802:07, 1
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1802 (TxPDO-Par Ch.3), entry 0x09 (TxPDO-Toggle)) | UINT32 | RW | 0x1802:09, 1
1A02:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6020 (RTD Inputs Ch.3), entry 0x11 (Value)) | UINT32 | RW | 0x6020:11, 16
Index 1A03 TxPDO-Map Ch.4
Index | Name | Meaning | Data type | Flags | Default
1A03:0 | TxPDO-Map Ch.4 | PDO Mapping TxPDO 4 | UINT8 | RW | 0x09 (9dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6030 (RTD Inputs Ch.4), entry 0x01 (Underrange)) | UINT32 | RW | 0x6030:01, 1
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6030 (RTD Inputs Ch.4), entry 0x02 (Overrange)) | UINT32 | RW | 0x6030:02, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6030 (RTD Inputs Ch.4), entry 0x03 (Limit 1)) | UINT32 | RW | 0x6030:03, 2
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6030 (RTD Inputs Ch.4), entry 0x05 (Limit 2)) | UINT32 | RW | 0x6030:05, 2
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6030 (RTD Inputs Ch.4), entry 0x07 (Error)) | UINT32 | RW | 0x6030:07, 1
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (7 bits align) | UINT32 | RW | 0x0000:00, 7
1A03:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x1803 (TxPDO-Par Ch.4), entry 0x07 (TxPDO-State)) | UINT32 | RW | 0x1803:07, 1
1A03:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1803 (TxPDO-Par Ch.4), entry 0x09 (TxPDO-Toggle)) | UINT32 | RW | 0x1803:09, 1
1A03:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6030 (RTD Inputs Ch.4), entry 0x11 (Value)) | UINT32 | RW | 0x6030:11, 16
Index 1C00 Sync manager type
Index | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Usage of the Sync Manager channels | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x00 (0dez)
Index 1C13 TxPDO assign
Index | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x04 (4dez)
1C13:01 | Subindex 001 | 1. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | Subindex 002 | 2. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A01 (6657dez)
1C13:03 | Subindex 003 | 3. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A02 (6658dez)
1C13:04 | Subindex 004 | 4. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A03 (6659dez)
Index 1C33 SM input parameter
Index | Name | Meaning | Data type | Flags | Default
1C33:0 | SM input parameter | Synchronization parameter of the inputs | UINT8 | RO | 0x07 (7dez)
1C33:01 Sync mode actual synchronization mode:
  • 0: Free Run
  • 1: Synchron with SM 3 Event (no Outputs available)
  • 2: DC - Synchron with SYNC0 Event
  • 3: DC - Synchron with SYNC1 Event
  • 34: Synchron with SM 2 Event (Outputs available)
 UINT16 RW 0x0000 (0dez)
1C33:02 Cycle time

Cycle time (in ns):

  • Free Run: cycle time of the local timer
  • Synchron with SM 2 Event: Cycle time of the master
  • DC-Mode: SYNC0/SYNC1 Cycle time
 UINT32 RW 0x00000000 (0dez)
1C33:03 | Shift time | time between SYNC0-Event and Input Latch (in ns, only in DC-Mode) | UINT32 | RW | 0x00000000 (0dez)
1C33:04 Sync modes supported Supported synchronization modes:
  • Bit 0: Free Run is supported
  • Bit 1: Synchron with SM 2 Event is supported (Outputs available)
  • Bit 1: Synchron with SM 3 Event is supported (no Outputs available)
  • Bit 2-3 = 01: DC-Mode is supported
  • Bit 4-5 = 01: Input Shift with local event (Outputs available)
  • Bit 4-5 = 10: Input Shift with SYNC1 Event (no Outputs available)
  • Bit 14 = 1: dynamic times (could be measured Messen by writing 1C33:08)
 UINT16 RO 0x8007 (32775dez)
1C33:05 | Minimum cycle time | Minimum cycle time supported (in ns) | UINT32 | RO | 0x00000000 (0dez)
1C33:06 | Calc and copy time | Minimal time between SYNC0 and SYNC1 Event (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:08 Command
  • 0: Measurement of the times will be stopped
  • 1: Measurement of the times will be started

The Entries 1C33:03, 1C33:06, 1C33:09 will be updated with the maximum measured values.

UINT16 RW 0x0000 (0dez)
1C33:09 | Delay time | Time between SYNC1 Event and Outputs Valid (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:0B | SM event missed counter | Number of the missed SM-Events in state OPERATIONAL (only in DC Mode) | UINT16 | RO | 0x0000 (0dez)
1C33:0C | Cycle exceeded counter | Number of the exceeded cycles in state OPERATIONAL | UINT16 | RO | 0x0000 (0dez)
1C33:0D | Shift too short counter | Number of the too short distances between SYNC0 and SYNC1 Event (only in DC Mode) | UINT16 | RO | 0x0000 (0dez)
1C33:20 | Sync error | TRUE: In the last cycle the synchronization was not correct (only in DC Mode) | BOOLEAN | RO | 0x00 (0dez)

Profile specific objects (0x6000-0xFFFF)

The profile specific objects have the same meaning for all EtherCAT Slaves which support the profile 5001.

Index 6000 RTD Inputs Ch.1
Index | Name | Meaning | Data type | Flags | Default
6000:0 | RTD Inputs Ch.1 | Max. Subindex | UINT8 | RO | 0x11 (17dez)
6000:01 | Underrange | Measurement underrange | BOOLEAN | RO | 0x00 (0dez)
6000:02 | Overrange | Measurement overrange ("open circuit" detection if also "Error" [Index 60n0:07]) is set | BOOLEAN | RO | 0x00 (0dez)
6000:03 | Limit 1 | Limit value monitoring 0: not active 1: Value > Limit value 2: Value < Limit value 3: Value = Limit value | BIT2 | RO | 0x00 (0dez)
6000:05 | Limit 2 | Limit value monitoring 0: not active 1: Value > Limit value 2: Value < Limit value 3: Value = Limit value | BIT2 | RO | 0x00 (0dez)
6000:07 | Error | Error bit is set, if data is invalid (open circuit, overrange, underrange) | BOOLEAN | RO | 0x00 (0dez)
6000:0F | TxPDO State | Valid of data of assigned TxPDO (0=valid, 1=invalid). | BOOLEAN | RO | 0x00 (0dez)
6000:10 | TxPDO Toggle | The TxPDO Toggle is toggled by the slave, if the data of the corresponding PDO was updated. | BOOLEAN | RO | 0x00 (0dez)
6000:11 | Value | Analog input data (resolution 1/10 °C) | INT16 | RO | 0x0000 (0dez)
Index 6010 RTD Inputs Ch.2
Index | Name | Meaning | Data type | Flags | Default
6010:0 | RTD Inputs Ch.2 | Max. Subindex | UINT8 | RO | 0x11 (17dez)
6010:01 | Underrange | Measurement underrange | BOOLEAN | RO | 0x00 (0dez)
6010:02 | Overrange | Measurement overrange ("open circuit" detection if also "Error" [Index 60n0:07]) is set | BOOLEAN | RO | 0x00 (0dez)
6010:03 | Limit 1 | Limit value monitoring 0: not active 1: Value > Limit value 2: Value < Limit value 3: Value = Limit value | BIT2 | RO | 0x00 (0dez)
6010:05 | Limit 2 | Limit value monitoring 0: not active 1: Value > Limit value 2: Value < Limit value 3: Value = Limit value | BIT2 | RO | 0x00 (0dez)
6010:07 | Error | Error bit is set, if data is invalid (open circuit, overrange, underrange) | BOOLEAN | RO | 0x00 (0dez)
6010:0F | TxPDO State | Valid of data of assigned TxPDO (0=valid, 1=invalid). | BOOLEAN | RO | 0x00 (0dez)
6010:10 | TxPDO Toggle | The TxPDO Toggle is toggled by the slave, if the data of the corresponding PDO was updated. | BOOLEAN | RO | 0x00 (0dez)
6010:11 | Value | Analog input data (resolution 1/10 °C) | INT16 | RO | 0x0000 (0dez)
Index 6020 RTD Inputs Ch.3
Index | Name | Meaning | Data type | Flags | Default
6020:0 | RTD Inputs Ch.3 | Max. Subindex | UINT8 | RO | 0x11 (17dez)
6020:01 | Underrange | Measurement underrange | BOOLEAN | RO | 0x00 (0dez)
6020:02 | Overrange | Measurement overrange ("open circuit" detection if also "Error" [Index 60n0:07]) is set | BOOLEAN | RO | 0x00 (0dez)
6020:03 | Limit 1 | Limit value monitoring 0: not active 1: Value > Limit value 2: Value < Limit value 3: Value = Limit value | BIT2 | RO | 0x00 (0dez)
6020:05 | Limit 2 | Limit value monitoring 0: not active 1: Value > Limit value 2: Value < Limit value 3: Value = Limit value | BIT2 | RO | 0x00 (0dez)
6020:07 | Error | Error bit is set, if data is invalid (open circuit, overrange, underrange) | BOOLEAN | RO | 0x00 (0dez)
6020:0F | TxPDO State | Valid of data of assigned TxPDO (0=valid, 1=invalid). | BOOLEAN | RO | 0x00 (0dez)
6020:10 | TxPDO Toggle | The TxPDO Toggle is toggled by the slave, if the data of the corresponding PDO was updated. | BOOLEAN | RO | 0x00 (0dez)
6020:11 | Value | Analog input data (resolution 1/10 °C) | INT16 | RO | 0x0000 (0dez)
Index 6030 RTD Inputs Ch.4
Index | Name | Meaning | Data type | Flags | Default
6030:0 | RTD Inputs Ch.4 | Max. Subindex | UINT8 | RO | 0x11 (17dez)
6030:01 | Underrange | Measurement underrange | BOOLEAN | RO | 0x00 (0dez)
6030:02 | Overrange | Measurement overrange ("open circuit" detection if also "Error" [Index 60n0:07]) is set | BOOLEAN | RO | 0x00 (0dez)
6030:03 | Limit 1 | Limit value monitoring 0: not active 1: Value > Limit value 2: Value < Limit value 3: Value = Limit value | BIT2 | RO | 0x00 (0dez)
6030:05 | Limit 2 | Limit value monitoring 0: not active 1: Value > Limit value 2: Value < Limit value 3: Value = Limit value | BIT2 | RO | 0x00 (0dez)
6030:07 | Error | Error bit is set, if data is invalid (open circuit, overrange, underrange) | BOOLEAN | RO | 0x00 (0dez)
6030:0F | TxPDO State | Valid of data of assigned TxPDO (0=valid, 1=invalid). | BOOLEAN | RO | 0x00 (0dez)
6030:10 | TxPDO Toggle | The TxPDO Toggle is toggled by the slave, if the data of the corresponding PDO was updated. | BOOLEAN | RO | 0x00 (0dez)
6030:11 | Value | Analog input data (resolution 1/10 °C) | INT16 | RO | 0x0000 (0dez)
Index 800E RTD Internal data Ch.1
Index | Name | Meaning | Data type | Flags | Default
800E:0 | RTD Internal data Ch.1 | Max. Subindex | UINT8 | RO | 0x04 (4dez)
800E:01 | ADC raw value 1 | ADC raw value 1 | INT32 | RO | 0x00000000 (0dez)
800E:02 | Resistor 1 | Measuring value resistance sensor, resolution 1/32 Ohm | UINT16 | RO | 0x0000 (0dez)
800E:03 | ADC raw value 2 | ADC raw value 2 [only for EL3201 and EL3202] | INT32 | RO | 0x00000000 (0dez)
800E:04 | Resistor 2 | Measuring value connection wire, resolution 1/32 Ohm [only for EL3201 and EL3202] | UINT16 | RO | 0x0000 (0dez)
Index 800F RTD Vendor data Ch.1
Index | Name | Meaning | Data type | Flags | Default
800F:0 | RTD Vendor data Ch.1 | Max. Subindex | UINT8 | RO | 0x06 (6dez)
800F:01 | Calibration offset | Vendor calibration offset | INT16 | RW | 0x0000 (0dez)
800F:02 | Calibration gain | Vendor calibration gain | UINT16 | RW | 0x9E50 (40528dez)
800F:03 | Calibration offset RL | Vendor calibration offset RL | INT16 | RW | 0x0000 (0dez)
800F:04 | Calibration gain RL | Vendor calibration gain RL | UINT16 | RW | 0x9E50 (40528dez)
800F:05 | Calibration offset 4-wire | Vendor calibration offset 4-wire | INT16 | RW | 0x0000 (0dez)
800F:06 | Calibration gain 4-wire | Vendor calibration gain 4-wire | UINT16 | RW | 0x9E50 (40528dez)
Index 801E RTD Internal data Ch.2
Index | Name | Meaning | Data type | Flags | Default
801E:0 | RTD Internal data Ch.2 | Max. Subindex | UINT8 | RO | 0x04 (4dez)
801E:01 | ADC raw value 1 | ADC raw value 1 | INT32 | RO | 0x00000000 (0dez)
801E:02 | Resistor 1 | Measuring value resistance sensor, resolution 1/32 Ohm | UINT16 | RO | 0x0000 (0dez)
801E:03 | ADC raw value 2 | ADC raw value 2 [only for EL3201 and EL3202] | INT32 | RO | 0x00000000 (0dez)
801E:04 | Resistor 2 | Measuring value connection wire, resolution 1/32 Ohm [only for EL3201 and EL3202] | UINT16 | RO | 0x0000 (0dez)
Index 801F RTD Vendor data Ch.2
Index | Name | Meaning | Data type | Flags | Default
801F:0 | RTD Vendor data Ch.2 | Max. Subindex | UINT8 | RO | 0x06 (6dez)
801F:01 | Calibration offset | Vendor calibration offset | INT16 | RW | 0x0000 (0dez)
801F:02 | Calibration gain | Vendor calibration gain | UINT16 | RW | 0x9E50 (40528dez)
801F:03 | Calibration offset RL | Vendor calibration offset RL | INT16 | RW | 0x0000 (0dez)
801F:04 | Calibration gain RL | Vendor calibration gain RL | UINT16 | RW | 0x9E50 (40528dez)
801F:05 | Calibration offset 4-wire | Vendor calibration offset 4-wire | INT16 | RW | 0x0000 (0dez)
801F:06 | Calibration gain 4-wire | Vendor calibration gain 4-wire | UINT16 | RW | 0x9E50 (40528dez)
Index 802E RTD Internal data Ch.3
Index | Name | Meaning | Data type | Flags | Default
802E:0 | RTD Internal data Ch.3 | Max. Subindex | UINT8 | RO | 0x04 (4dez)
802E:01 | ADC raw value 1 | ADC raw value 1 | INT32 | RO | 0x00000000 (0dez)
802E:02 | Resistor 1 | Measuring value resistance sensor, resolution 1/32 Ohm | UINT16 | RO | 0x0000 (0dez)
802E:03 | ADC raw value 2 | ADC raw value 2 [only for EL3201 and EL3202] | INT32 | RO | 0x00000000 (0dez)
802E:04 | Resistor 2 | Measuring value connection wire, resolution 1/32 Ohm [only for EL3201 and EL3202] | UINT16 | RO | 0x0000 (0dez)
Index 802F RTD Vendor data Ch.3
Index | Name | Meaning | Data type | Flags | Default
802F:0 | RTD Vendor data Ch.3 | Max. Subindex | UINT8 | RO | 0x06 (6dez)
802F:01 | Calibration offset | Vendor calibration offset | INT16 | RW | 0x0000 (0dez)
802F:02 | Calibration gain | Vendor calibration gain | UINT16 | RW | 0x9E50 (40528dez)
802F:03 | Calibration offset RL | Vendor calibration offset RL | INT16 | RW | 0x0000 (0dez)
802F:04 | Calibration gain RL | Vendor calibration gain RL | UINT16 | RW | 0x9E50 (40528dez)
802F:05 | Calibration offset 4-wire | Vendor calibration offset 4-wire | INT16 | RW | 0x0000 (0dez)
802F:06 | Calibration gain 4-wire | Vendor calibration gain 4-wire | UINT16 | RW | 0x9E50 (40528dez)
Index 803E RTD Internal data Ch.4
Index | Name | Meaning | Data type | Flags | Default
803E:0 | RTD Internal data Ch.4 | Max. Subindex | UINT8 | RO | 0x04 (4dez)
803E:01 | ADC raw value 1 | ADC raw value 1 | INT32 | RO | 0x00000000 (0dez)
803E:02 | Resistor 1 | Measuring value resistance sensor, resolution 1/32 Ohm | UINT16 | RO | 0x0000 (0dez)
803E:03 | ADC raw value 2 | ADC raw value 2 [only for EL3201 and EL3202] | INT32 | RO | 0x00000000 (0dez)
803E:04 | Resistor 2 | Measuring value connection wire, resolution 1/32 Ohm [only for EL3201 and EL3202] | UINT16 | RO | 0x0000 (0dez)
Index 803F RTD Vendor data Ch.4
Index | Name | Meaning | Data type | Flags | Default
803F:0 | RTD Vendor data Ch.4 | Max. Subindex | UINT8 | RO | 0x06 (6dez)
803F:01 | Calibration offset | Vendor calibration offset | INT16 | RW | 0x0000 (0dez)
803F:02 | Calibration gain | Vendor calibration gain | UINT16 | RW | 0x9E50 (40528dez)
803F:03 | Calibration offset RL | Vendor calibration offset RL | INT16 | RW | 0x0000 (0dez)
803F:04 | Calibration gain RL | Vendor calibration gain RL | UINT16 | RW | 0x9E50 (40528dez)
803F:05 | Calibration offset 4-wire | Vendor calibration offset 4-wire | INT16 | RW | 0x0000 (0dez)
803F:06 | Calibration gain 4-wire | Vendor calibration gain 4-wire | UINT16 | RW | 0x9E50 (40528dez)
Index F000 Modular device profile
Index | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General informations about the Modular Device Profile | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Index distance between the objects of two channels | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0004 (4dez)
Index F008 Code word
Index | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dez)


EL320x-0200 - Objektbeschreibung und Parametrierung

BECKHOFF EL320x-0200: Commissioning

Object description and parameterization

Note 		EtherCAT XML Device Description
The description correspond to the display of the CoE objects from the EtherCAT XML Device Description. It is strongly recommended to download the latest revision of the corresponding XML file from the Beckhoff website and follow the installation instructions.

Note 		Parameterization via the CoE list (CAN over EtherCAT)
The terminal is parameterized via the CoE tab (double-click on the respective object) or via the Process data tab (allocation of PDOs).
Please note the following general CoE information when using/manipulating the CoE parameters:
- Keep a startup list if components have to be replaced
- Differentiation between online/offline dictionary, existence of current XML description
- use "CoE reload" for resetting changes

Introduction

The CoE overview contains objects for different intended applications:

  • Objects required for parameterization and during commissioning and profile specific objects.
  • Objects for indicating internal settings (may be fixed)

The following section first describes the objects require for normal operation, followed by a complete overview of other objects.

Objects for commissioning

Index 1011 Restore default parameters
Index | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore the default settings in the EtherCAT slave | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" ("Set Value Dialog") all terminal-specific objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)
Index 8000 RTD Settings Ch.1
Index | Name | Meaning |  | Data type | Flags | Default
8000:0 | RTD Settings Ch.1 | Max. Subindex |  | UINT8 | RO | 0x1B (27dec)
8000:01 | Enable user scale | User scale enabled |  | BOOLEAN | RW | 0x00 (0dec)
8000:02 | process data Presentation | allowed values: |  | BIT3 | RW | 0x00 (0dec)
 |  | 0 | Signed
 |  | 1 | Absolute MSB sign
 |  | 2 | High resolution (1/100°C)
8000:05 | Siemens bits | The S5 bits will be displayed in the least significant bits (Value 60n0:11) Bit 0 = 1 ("Overange" or "Underrange") Bit 1 (not used) Bit 2 (not used) |  | BOOLEAN | RW | 0x00 (0dec)
8000:06 | Enable filter | Filter enabled, the cycle-synchronous data exchange is not applied |  | BOOLEAN | RW | 0x00 (0dec)
8000:0A | Enable user calibration | User calibration is enabled, if bit is set |  | BOOLEAN | RW | 0x00 (0dec)
8000:0B | Enable vendor calibration | Vendor calibration is enabled, if bit is set |  | BOOLEAN | RW | 0x01 (1dec)
8000:11 | User scale offset | User scale offset |  | INT16 | RW | 0x0000 (0dec)
8000:12 | User scale gain | User scale gain The gain is represented in fixed-point format, with the factor 2-16. A value of 1 for the gain factor therefore corresponds to 65535dec (0x00010000). |  | INT32 | RW | 0x00010000 (65536dec)
8000:15 | Filter settings | allowed values: |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 50 Hz
 |  | 1 | 60 Hz
 |  | 2 | 100 Hz
 |  | 3 | 500 Hz
 |  | 4 | 1 kHz
 |  | 5 | 2 kHz
 |  | 6 | 3,75 kHz
 |  | 7 | 7,5 kHz
 |  | 8 | 15 kHz
 |  | 9 | 30 kHz
 |  | 10 | 5 Hz
 |  | 11 | 10 Hz
8000:17 | User calibration offset | User calibration offset |  | INT16 | RW | 0x0000 (0dec)
8000:18 | User calibration gain | User calibration gain |  | UINT16 | RW | 0xFFFF (65535dec)
8000:19 | RTD element | allowed values: |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | PT1000 (-200...850°C)
 |  | 2 | NI1000 100°C (bei 100°C 1500 Ohm, -30...160°C)
 |  | 3 | NI1000 (-60...250°C)
 |  | 4 | NTC 5k (0°C: 16325 Ohm, -40...100°C)
 |  | 5 | NTC 10k (0°C: 32650 Ohm, -30...150°C)
 |  | 6 | NTC 10k (0°C: 29490 Ohm, -30...150°C)
 |  | 7 | NTC 10k (0°C: 27280 Ohm, -40...110°C, wie KL3204-0030)
 |  | 8 | NTC 20k (0°C: 70200 Ohm, -20...150°C)
 |  | 9 | Fet (-30...150°C)
 |  | 101 | Resistor 1/10 Ohm resolution (0...6553,5 Ohm)
 |  | 102 | Resistor 1 Ohm resolution (0...65 535 Ohm)
 |  | 103 | Resistor 10 Ohm resolution (0...240 kOhm)
 |  | 110 | RTD-Table (further parameters see x80n1)
 |  | 111 | B-Parameter Equation (further parameters see x80n2)
 |  | 112 | DIN IEC 60751 Equation (further parameters see x80n3)
 |  | 113 | Steinhart Hart Equation (further parameters see x80n4)
8000:1A | Connection technology | allowed values: |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 2-wire
 |  | 3 | not connected (disable channel)
8000:1B | Wire calibration | Offset value to correct static wires to device under test/sensor [1/10] Ohm |  | INT16 | RW | 0x0000 (0dec)
Index 8001 RTD Table

Default values given in this RTD table represents conversion table for PT1000 in the range 0°C to 140°C with a resolution of 1/10 Ohm (just as example).

Index | Name | Meaning | Data type | Flags | Default
8001:0 | RTD Table | The sensor characteristic could be programmed with this table. | UINT8 | RO | 105
8001:01 | Distance in Degrees | This value sets the distance between the entries in degrees. | UINT16 | RW | 10
8001:02 | Amount of Entries | With the Amount of entries, the distance in degrees and the start temperature the measure range is determined. End-Temperature = Start-Temperature + ((Amount of Entries -1) * distance in degrees ) | UINT16 | RW | 15
8001:03 | Start Temperature | This value sets the beginning of the measure range. The default value is 0°C | INT16 | RW | 0
8001:04 | Conversion Factor | 1 = 1/10 Ohm per digit in the table entries. 10 = 1 Ohm per digit in the table entries. 100 = 10 Ohm per digit in the table entries. | UINT16 | RW | 1
8001:05 | Value 1 |  | UINT16 | RW | 0x2710 (10000dec)
8001:06 | Value 2 |  | UINT16 | RW | 0x2896 (10390dec)
8001:07 | Value 3 |  | UINT16 | RW | 0x2A1B (10779dec)
8001:08 | Value 4 |  | UINT16 | RW | 0x2B9F (11167dec)
8001:09 | Value 5 |  | UINT16 | RW | 0x2D22 (11554dec)
8001:0A | Value 6 |  | UINT16 | RW | 0x2EA3 (11939dec)
8001:0B | Value 7 |  | UINT16 | RW | 0x3024 (12324dec)
8001:0C | Value 8 |  | UINT16 | RW | 0x31A3 (12707dec)
8001:0D | Value 9 |  | UINT16 | RW | 0x3321 (13089dec)
8001:0E | Value 10 |  | UINT16 | RW | 0x349E (13470dec)
8001:0F | Value 11 |  | UINT16 | RW | 0x361A (13850dec)
8001:10 | Value 12 |  | UINT16 | RW | 0x3795 (14229dec)
8001:11 | Value 13 |  | UINT16 | RW | 0x390E (14606dec)
8001:13 | Value 14 |  | UINT16 | RW | 0x3A87 (14983dec)
8001:14 | Value 15 |  | UINT16 | RW | 0x3BFE (15358dec)
8001:15 | Value 16 |  | UINT16 | RW | 0x0000 (0dec)
8001:16 | Value 17 |  | UINT16 | RW | 0x0000 (0dec)
8001:17 | Value 18 |  | UINT16 | RW | 0x0000 (0dec)
8001:18 | Value 19 |  | UINT16 | RW | 0x0000 (0dec)
8001:19 | Value 20 |  | UINT16 | RW | 0x0000 (0dec)
8001:1A | Value 21 |  | UINT16 | RW | 0x0000 (0dec)
8001:1B | Value 22 |  | UINT16 | RW | 0x0000 (0dec)
8001:1C | Value 23 |  | UINT16 | RW | 0x0000 (0dec)
8001:1D | Value 24 |  | UINT16 | RW | 0x0000 (0dec)
8001:1E | Value 25 |  | UINT16 | RW | 0x0000 (0dec)
8001:1F | Value 26 |  | UINT16 | RW | 0x0000 (0dec)
8001:20 | Value 27 |  | UINT16 | RW | 0x0000 (0dec)
8001:21 | Value 28 |  | UINT16 | RW | 0x0000 (0dec)
8001:22 | Value 29 |  | UINT16 | RW | 0x0000 (0dec)
8001:23 | Value 30 |  | UINT16 | RW | 0x0000 (0dec)
8001:24 | Value 31 |  | UINT16 | RW | 0x0000 (0dec)
8001:25 | Value 32 |  | UINT16 | RW | 0x0000 (0dec)
8001:26 | Value 33 |  | UINT16 | RW | 0x0000 (0dec)
8001:27 | Value 34 |  | UINT16 | RW | 0x0000 (0dec)
8001:28 | Value 35 |  | UINT16 | RW | 0x0000 (0dec)
8001:29 | Value 36 |  | UINT16 | RW | 0x0000 (0dec)
8001:2A | Value 37 |  | UINT16 | RW | 0x0000 (0dec)
8001:2B | Value 38 |  | UINT16 | RW | 0x0000 (0dec)
8001:2C | Value 39 |  | UINT16 | RW | 0x0000 (0dec)
8001:2D | Value 40 |  | UINT16 | RW | 0x0000 (0dec)
8001:2E | Value 41 |  | UINT16 | RW | 0x0000 (0dec)
8001:2F | Value 42 |  | UINT16 | RW | 0x0000 (0dec)
8001:30 | Value 43 |  | UINT16 | RW | 0x0000 (0dec)
8001:31 | Value 44 |  | UINT16 | RW | 0x0000 (0dec)
8001:32 | Value 45 |  | UINT16 | RW | 0x0000 (0dec)
8001:33 | Value 46 |  | UINT16 | RW | 0x0000 (0dec)
8001:34 | Value 47 |  | UINT16 | RW | 0x0000 (0dec)
8001:35 | Value 48 |  | UINT16 | RW | 0x0000 (0dec)
8001:36 | Value 49 |  | UINT16 | RW | 0x0000 (0dec)
8001:37 | Value 50 |  | UINT16 | RW | 0x0000 (0dec)
8001:38 | Value 51 |  | UINT16 | RW | 0x0000 (0dec)
8001:39 | Value 52 |  | UINT16 | RW | 0x0000 (0dec)
8001:3A | Value 53 |  | UINT16 | RW | 0x0000 (0dec)
8001:3B | Value 54 |  | UINT16 | RW | 0x0000 (0dec)
8001:3C | Value 55 |  | UINT16 | RW | 0x0000 (0dec)
8001:3D | Value 56 |  | UINT16 | RW | 0x0000 (0dec)
8001:3E | Value 57 |  | UINT16 | RW | 0x0000 (0dec)
8001:3F | Value 58 |  | UINT16 | RW | 0x0000 (0dec)
8001:40 | Value 59 |  | UINT16 | RW | 0x0000 (0dec)
8001:41 | Value 60 |  | UINT16 | RW | 0x0000 (0dec)
8001:42 | Value 61 |  | UINT16 | RW | 0x0000 (0dec)
8001:43 | Value 62 |  | UINT16 | RW | 0x0000 (0dec)
8001:44 | Value 63 |  | UINT16 | RW | 0x0000 (0dec)
8001:45 | Value 64 |  | UINT16 | RW | 0x0000 (0dec)
8001:46 | Value 65 |  | UINT16 | RW | 0x0000 (0dec)
8001:47 | Value 66 |  | UINT16 | RW | 0x0000 (0dec)
8001:48 | Value 67 |  | UINT16 | RW | 0x0000 (0dec)
8001:49 | Value 68 |  | UINT16 | RW | 0x0000 (0dec)
8001:4A | Value 69 |  | UINT16 | RW | 0x0000 (0dec)
8001:4B | Value 70 |  | UINT16 | RW | 0x0000 (0dec)
8001:4C | Value 71 |  | UINT16 | RW | 0x0000 (0dec)
8001:4D | Value 72 |  | UINT16 | RW | 0x0000 (0dec)
8001:4E | Value 73 |  | UINT16 | RW | 0x0000 (0dec)
8001:4F | Value 74 |  | UINT16 | RW | 0x0000 (0dec)
8001:50 | Value 75 |  | UINT16 | RW | 0x0000 (0dec)
8001:51 | Value 76 |  | UINT16 | RW | 0x0000 (0dec)
8001:52 | Value 77 |  | UINT16 | RW | 0x0000 (0dec)
8001:53 | Value 78 |  | UINT16 | RW | 0x0000 (0dec)
8001:54 | Value 79 |  | UINT16 | RW | 0x0000 (0dec)
8001:55 | Value 80 |  | UINT16 | RW | 0x0000 (0dec)
8001:56 | Value 81 |  | UINT16 | RW | 0x0000 (0dec)
8001:57 | Value 82 |  | UINT16 | RW | 0x0000 (0dec)
8001:58 | Value 83 |  | UINT16 | RW | 0x0000 (0dec)
8001:59 | Value 84 |  | UINT16 | RW | 0x0000 (0dec)
8001:5A | Value 85 |  | UINT16 | RW | 0x0000 (0dec)
8001:5B | Value 86 |  | UINT16 | RW | 0x0000 (0dec)
8001:5C | Value 87 |  | UINT16 | RW | 0x0000 (0dec)
8001:5D | Value 88 |  | UINT16 | RW | 0x0000 (0dec)
8001:5E | Value 89 |  | UINT16 | RW | 0x0000 (0dec)
8001:5F | Value 90 |  | UINT16 | RW | 0x0000 (0dec)
8001:60 | Value 91 |  | UINT16 | RW | 0x0000 (0dec)
8001:61 | Value 92 |  | UINT16 | RW | 0x0000 (0dec)
8001:62 | Value 93 |  | UINT16 | RW | 0x0000 (0dec)
8001:63 | Value 94 |  | UINT16 | RW | 0x0000 (0dec)
8001:64 | Value 95 |  | UINT16 | RW | 0x0000 (0dec)
8001:65 | Value 96 |  | UINT16 | RW | 0x0000 (0dec)
8001:66 | Value 97 |  | UINT16 | RW | 0x0000 (0dec)
8001:67 | Value 98 |  | UINT16 | RW | 0x0000 (0dec)
8001:68 | Value 99 |  | UINT16 | RW | 0x0000 (0dec)
8001:69 | Value 100 |  | UINT16 | RW | 0x0000 (0dec)
Index 8002 RTD B-Parameter Equation
Index | Name | Meaning | Data type | Flags | Default
8002:0 | RTD B-Parameter Equation | Max. Subindex | UINT8 | RO | 0x05 (5dec)
8002:01 | Min Temperature | This is the start of the measure range in °C. | INT16 | RW | -30
8002:02 | Max Temperature | This is the end of the measure range in °C. | INT16 | RW | 150
8002:03 | Rn | This is the resistor at Tn. In most cases at 25°C. | INT16 | RW | 1000
8002:04 | Tn | This is the reference temperature for Rn. | INT16 | RW | 25
8002:05 | B-Parameter | This is B Parameter [Kelvin] | REAL32 | RW | 3710
Index 8003 RTD DIN EN 60751 Equation
Index | Name | Meaning | Data type | Flags | Default
8003:0 | RTD DIN EN 60751 Equation | The default parameter for PT1000 in the range of 0 to 850°C. | UINT8 | RO | 0x06 (6dec)
8003:01 | Min Temperature | This is the start of the measure range in °C. | INT16 | RW | 0
8003:02 | Max Temperature | This is the end of the measure range in °C. | INT16 | RW | 850
8003:03 | R0 | See equation | UINT16 | RW | 1000
8003:04 | A Parameter | See equation | REAL32 | RW | 3,908E-3
8003:05 | B Parameter | See equation | REAL32 | RW | -5,775E-7
8003:06 | C Parameter | See equation | REAL32 | RW | -4,183E-12
Index 8004 RTD Steinhart Hart Equation
Index | Name | Meaning | Data type | Flags | Default
8004:0 | RTD Steinhart Hart Equation | Default values for a NTC10K with 32650 Ohm at 0°C: C1 default = 1.12119E-03 C2 default = 2.35346E-04 C3 default = 0 C4 default = 8.34620E-08 | UINT8 | RO | 0x06 (6dec)
8004:01 | Min Temperature | This is the start of the measure range in °C. | INT16 | RW | -30
8004:02 | Max Temperature | This is the end of the measure range in °C. | INT16 | RW | 150
8004:03 | C1 | See equation | REAL32 | RW | 1,1211E-03
8004:04 | C2 | See equation | REAL32 | RW | 2,35346E-04
8004:05 | C3 | See equation | REAL32 | RW | 0
8004:06 | C4 | See equation | REAL32 | RW | 8,24620E-08
Index 800E RTD Internal Data Ch.1
Index | Name | Meaning | Data type | Flags | Default
800E:0 | RTD Internal Data Ch.1 | Max. Subindex | UINT8 | RO |
800E:01 | ADC raw value | ADC raw value. | INT32 | RO |
800E:02 | Resistor (1/10 Ohm) | resulting measured resistor | UINT32 | RO |
Index 800F RTD Vendor Data Ch.1
Index | Name | Meaning | Data type | Flags | Default
800F:0 | RTD Vendor Data Ch.1 | Max. Subindex | UINT8 | RO | 0x03 (3dec)
800F:01 | Calibration offset | Calibration offset | INT32 | RW | 0x00000DAC (3500dec)
800F:02 | Calibration gain | Gain value for measurement range 0..5000 Ohm | UINT16 | RW | 0x3D68 (15720dec)
800F:03 | Calibration gain ext. | Gain value for measurement range 5..240 kOhm | UINT16 | RW | 0x05A0 (1440dec)

Values of channel 2 - 4 correspondingly

Complete overview

Standard objects (0x1000-0x1FFF)

The standard objects of all EtherCAT slaves have the same meaning.

Index 1000 Device type
Index | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device Type of the EtherCAT slave: The Lo-Word contains the supported CoE Profile (5001). The Hi-Word contains the Module Profile corresponding to the Modular Device Profile. | UINT32 | RO | 0x01401389 (20976521dec)
Index 1008 Device name
Index | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EL3204-0200
Index 1009 Hardware version
Index | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slaves | STRING | RO |
Index 100A Software version
Index | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slaves | STRING | RO | 01
Index 1011 Restore default parameters
Index | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore the default settings in the EtherCAT slave | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" ("Set Value Dialog") all terminal-specific objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)
Index 1018 Identity
Index | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | contains informations to identify the EtherCAT slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x0C843052 (209989714dec)
1018:03 | Revision | Revision number of the EtherCAT-Slave, the Lo-Word (Bit 0-15) indicates the special functions terminal number; the Hi-Word (Bit 16-31) refers to the device description. | UINT32 | RO | 0x00000000 (0dec)
1018:04 | Serial number | Serial number of the EtherCAT-Slave, the Lo-Byte (Bit 0-7) of the Lo-Word contains the year of manufacturing, the Hi-Byte (Bit 8-15) of the Lo-Word contains the week of manufacturing, the Hi-Word (Bit 16-31) is 0 . | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 Backup parameter handling
Index | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | contains informations for the standardized Upload and Download of the Backup Entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum over all backup entries | UINT32 | RO | 0x00000000 (0dec)
Index 1800 RTD TxPDO-Par Ch.1
Index | Name | Meaning | Data type | Flags | Default
1800:0 | RTD TxPDO-Par Ch.1 | PDO Parameter TxPDO 1 | UINT8 | RO | 0x09 (9dec)
1800:06 | Exclude TxPDOs | This entry contains the TxPDOs (Index of the TxPDO Mapping objects) which shall not be transmitted with TxPDO 1 | OCTET-STRING[0] | RO |
1800:07 | TxPDO State | The TxPDO State will be set if the corresponding input data could not be read in correctly | BOOLEAN | RO | 0x00 (0dec)
1800:09 | TxPDO Toggle | the TxPDO Toggle will be toggled with every update of the corresponding input data | BOOLEAN | RO | 0x00 (0dec)
Index 1801 RTD TxPDO-Par Ch.2
Index | Name | Meaning | Data type | Flags | Default
1801:0 | RTD TxPDO-Par Ch.2 | PDO Parameter TxPDO 2 | UINT8 | RO | 0x09 (9dec)
1801:06 | Exclude TxPDOs | This entry contains the TxPDOs (Index of the TxPDO Mapping objects) which shall not be transmitted with TxPDO 2 | OCTET-STRING[0] | RO |
1801:07 | TxPDO State | The TxPDO State will be set if the corresponding input data could not be read in correctly | BOOLEAN | RO | 0x00 (0dec)
1801:09 | TxPDO Toggle | the TxPDO Toggle will be toggled with every update of the corresponding input data | BOOLEAN | RO | 0x00 (0dec)
Index 1802 RTD TxPDO-Par Ch.3
Index | Name | Meaning | Data type | Flags | Default
1802:0 | RTD TxPDO-Par Ch.3 | PDO Parameter TxPDO 3 | UINT8 | RO | 0x09 (9dec)
1802:06 | Exclude TxPDOs | This entry contains the TxPDOs (Index of the TxPDO Mapping objects) which shall not be transmitted with TxPDO 3 | OCTET-STRING[0] | RO |
1802:07 | TxPDO State | The TxPDO State will be set if the corresponding input data could not be read in correctly | BOOLEAN | RO | 0x00 (0dec)
1802:09 | TxPDO Toggle | the TxPDO Toggle will be toggled with every update of the corresponding input data | BOOLEAN | RO | 0x00 (0dec)
Index 1803 RTD TxPDO-Par Ch.4
Index | Name | Meaning | Data type | Flags | Default
1803:0 | RTD TxPDO-Par Ch.4 | PDO Parameter TxPDO 4 | UINT8 | RO | 0x09 (9dec)
1803:06 | Exclude TxPDOs | This entry contains the TxPDOs (Index of the TxPDO Mapping objects) which shall not be transmitted with TxPDO 4 | OCTET-STRING[0] | RO |
1803:07 | TxPDO State | The TxPDO State will be set if the corresponding input data could not be read in correctly | BOOLEAN | RO | 0x00 (0dec)
1803:09 | TxPDO Toggle | the TxPDO Toggle will be toggled with every update of the corresponding input data | BOOLEAN | RO | 0x00 (0dec)
Index 1A00 RTD TxPDO-Map Ch.1
Index | Name | Meaning | Data type | Flags | Default
1A00:0 | RTD TxPDO-Map Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x08 (8dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (RTD Inputs Ch.1), entry 0x01 (Underrange)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (RTD Inputs Ch.1), entry 0x02 (Overrange)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (RTD Inputs Ch.1), entry 0x07 (Error)) | UINT32 | RO | 0x6000:07, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x1800 (RTD TxPDO-Par Ch.1), entry 0x07 (TxPDO State)) | UINT32 | RO | 0x1800:07, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x1800 (RTD TxPDO-Par Ch.1), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1800:09, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (RTD Inputs Ch.1), entry 0x11 (Value)) | UINT32 | RO | 0x6000:11, 16
Index 1A01 RTD TxPDO-Map Ch.2
Index | Name | Meaning | Data type | Flags | Default
1A01:0 | RTD TxPDO-Map Ch.2 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x08 (8dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (RTD Inputs Ch.2), entry 0x01 (Underrange)) | UINT32 | RO | 0x6010:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (RTD Inputs Ch.2), entry 0x02 (Overrange)) | UINT32 | RO | 0x6010:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (RTD Inputs Ch.2), entry 0x07 (Error)) | UINT32 | RO | 0x6010:07, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x1801 (RTD TxPDO-Par Ch.2), entry 0x07 (TxPDO State)) | UINT32 | RO | 0x1801:07, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x1801 (RTD TxPDO-Par Ch.2), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1801:09, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (RTD Inputs Ch.2), entry 0x11 (Value)) | UINT32 | RO | 0x6010:11, 16
Index 1A02 RTD TxPDO-Map Ch.3
Index | Name | Meaning | Data type | Flags | Default
1A02:0 | RTD TxPDO-Map Ch.3 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x08 (8dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (RTD Inputs Ch.3), entry 0x01 (Underrange)) | UINT32 | RO | 0x6020:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (RTD Inputs Ch.3), entry 0x02 (Overrange)) | UINT32 | RO | 0x6020:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (RTD Inputs Ch.3), entry 0x07 (Error)) | UINT32 | RO | 0x6020:07, 1
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x1802 (RTD TxPDO-Par Ch.3), entry 0x07 (TxPDO State)) | UINT32 | RO | 0x1802:07, 1
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x1802 (RTD TxPDO-Par Ch.3), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1802:09, 1
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6020 (RTD Inputs Ch.3), entry 0x11 (Value)) | UINT32 | RO | 0x6020:11, 16
Index 1A03 RTD TxPDO-Map Ch.4
Index | Name | Meaning | Data type | Flags | Default
1A03:0 | RTD TxPDO-Map Ch.4 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x08 (8dec)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6030 (RTD Inputs Ch.4), entry 0x01 (Underrange)) | UINT32 | RO | 0x6030:01, 1
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6030 (RTD Inputs Ch.4), entry 0x02 (Overrange)) | UINT32 | RO | 0x6030:02, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6030 (RTD Inputs Ch.4), entry 0x07 (Error)) | UINT32 | RO | 0x6030:07, 1
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x1803 (RTD TxPDO-Par Ch.4), entry 0x07 (TxPDO State)) | UINT32 | RO | 0x1803:07, 1
1A03:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x1803 (RTD TxPDO-Par Ch.4), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1803:09, 1
1A03:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6030 (RTD Inputs Ch.4), entry 0x11 (Value)) | UINT32 | RO | 0x6030:11, 16
Index 1C00 Sync manager type
Index | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Usage of the Sync Manager channels | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign
Index | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RO | 0x00 (0dec)
Index 1C13 TxPDO assign
Index | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RO | 0x04 (4dec)
1C13:01 | Subindex 001 | 1. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RO | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RO | 0x1A01 (6657dec)
1C13:03 | Subindex 003 | 3. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RO | 0x1A02 (6658dec)
1C13:04 | Subindex 004 | 4. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RO | 0x1A03 (6659dec)
Index 1C33 SM input parameter

Index

Name

Meaning

Data type

Flags

Default
1C33:0 | SM input parameter | Synchronization parameter of the inputs | UINT8 | RO | 0x20 (32dec)
1C33:01 Sync mode actual synchronization mode:
  • 0: Free Run
  • 1: Synchron with SM 3 Event (no Outputs available)
  • 2: DC - Synchron with SYNC0 Event
  • 3: DC - Synchron with SYNC1 Event
  • 34: Synchron with SM 2 Event (Outputs available)
 UINT16 RW 0x0000 (0dec)
1C33:02 | Cycle time | same as 1C32:02 | UINT32 | RW | 0x00000000 (0dec)
1C33:03 | Shift time | time between SYNC0-Event and Input Latch (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dec)
1C33:04 Sync modes supported Supported synchronization modes:
  • Bit 0: Free Run is supported
  • Bit 1: Synchron with SM 2 Event is supported (Outputs available)
  • Bit 1: Synchron with SM 3 Event is supported (no Outputs available)
  • Bit 2-3 = 01: DC-Mode is supported
  • Bit 4-5 = 01: Input Shift with local event (Outputs available)
  • Bit 4-5 = 10: Input Shift with SYNC1 Event (no Outputs available)
  • Bit 14 = 1: dynamic times (could be measured by writing 1C32:08 or 1C33:08 )
 UINT16 RO 0xC007 (49159dec)
1C33:05 | Minimum cycle time | same as 1C32:05 | UINT32 | RO | 0x00000000 (0dec)
1C33:06 | Calc and copy time | time between Input Latch and the availability of the inputs for the master (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dec)
1C33:07 | Minimum delay time | UINT32 | RO | 0x00000000 (0dec)
1C33:08 | Command | same as 1C32:08 | UINT16 | RW | 0x0000 (0dec)
1C33:09 | Maximum delay time | time between SYNC1-Event and Input Latch (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dec)
1C33:0B | SM event missed counter | same as 1C32:11 | UINT16 | RO | 0x0000 (0dec)
1C33:0C | Cycle exceeded counter | same as 1C32:12 | UINT16 | RO | 0x0000 (0dec)
1C33:0D | Shift too short counter | same as 1C32:13 | UINT16 | RO | 0x0000 (0dec)
1C33:20 | Sync error | same as 1C32:32 | BOOLEAN | RO | 0x00 (0dec)

Profile specific objects

The profile specific objects have the same meaning for all EtherCAT Slaves which support the profile 5001.

Index 6000 RTD Inputs Ch.1
Index | Name | Meaning | Data type | Flags | Default
6000:0 | RTD Inputs Ch.1 | Max. Subindex | UINT8 | RO | 0x11 (17dec)
6000:01 | Underrange | Temperature out of range. | BOOLEAN | RO | 0x00 (0dec)
6000:02 | Overrange | Temperature out of range. | BOOLEAN | RO | 0x00 (0dec)
6000:07 | Error | Error bit is set, if data is invalid (open circuit, overrange, underrange) | BOOLEAN | RO | 0x00 (0dec)
6000:0F | TxPDO State | Valid of data of assigned TxPDO (0=valid, 1=invalid). | BOOLEAN | RO | 0x00 (0dec)
6000:10 | TxPDO Toggle | The TxPDO Toggle is toggled by the slave, if the data of the corresponding PDO was updated. | BOOLEAN | RO | 0x00 (0dec)
6000:11 | Value | Analog input data (resolution 1/10 °C) | INT16 | RO | 0x0000 (0dec)
Index F000 Modular device profile
Index | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information about the Modular Device Profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance between the objects of two channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0004 (4dec)
Index F008 Code word
Index | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module list
Index | Name | Meaning | Data type | Flags | Default
F010:0 | Module list | Max. Subindex | UINT8 | RW | 0x04 (4dec)
F010:01 | SubIndex 001 | RTD channel profile 320 | UINT32 | RW | 0x00000140 (320dec)
F010:02 | SubIndex 002 | RTD channel profile 320 | UINT32 | RW | 0x00000140 (320dec)
F010:03 | SubIndex 003 | RTD channel profile 320 | UINT32 | RW | 0x00000140 (320dec)
F010:04 | SubIndex 004 | RTD channel profile 320 | UINT32 | RW | 0x00000140 (320dec)


EL32xx, EL33xx - Status word

BECKHOFF EL32xx, EL33xx: Commissioning

Status word

The status information for each channel of the EL32xx and EL33xx is transmitted cyclically from the terminal to the EtherCAT Master as process data (PDO). Two versions of the device description are available for the EL32xx and EL33xx, representing the process image in individual and extended forms.

The difference can be seen in the revision number EL3xxxx-xxxx-XXXX.

The EL32xx or EL33xx transmit the following process data:

  • Underrange: Measurement is below range
  • Overrange: Range of measurement exceeded ("Cable break" together with "Error")
  • Limit 1: Limit value monitoring 0: ok, 1: Limit value overshot , 2: Limit value undershot
  • Limit 2: Limit value monitoring 0: ok, 1: Limit value overshot , 2: Limit value undershot
  • Error: The error bit is set if the process data is invalid (cable break, overrange, underrange)
  • TxPDO State: Validity of the data of the associated TxPDO (0 = valid, 1 = invalid).
  • TxPDO Toggle: The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. This allows the currently required conversion time to be derived.

The limit evaluation is set in the "8000" objects in the CoE directory.

Notice 		Differences in the versions of the EL32xx and EL33xx series
The revision differences are illustrated below, using the EL32xx series as an example. The principles of the description apply equally to the EL33xx series.

Revision -0016 (EL32xx-xxxx-0016)

These terminal revisions feature the individual process image, see Fig 1.
Each item of status information is transmitted as a single, linkable process data.

Fig. 1: EL32xx-0000-0016 process image in the TwinCAT 2.11 representation

Revisions -0017 (EL32xx-xxxx-0017) and higher

These terminal revisions also feature the consolidated process image, see Fig 2.
The individual units of information are assembled here in the usual Beckhoff representation as a 16-bit status word, and can be linked into the controller in this way.

Status word
Bit | SW.15 | SW.14 | SW.13 | SW.12 | SW.11 | SW.10 | SW.9 | SW.8 | SW.7 | SW.6 | SW.5 | SW.4 | SW.3 | SW.2 | SW.1 | SW.0
Name | TxPDO Toggle | TxPDO State | - | - | - | - | - | - | - | Error | Limit 2 |  | Limit 1 |  | Overrange | Underrange

In addition to this, the consolidated "status" can be folded out through the "+" symbol, and the items of process data linked individually.

Fig. 2: EL32xx-0000-0017 process image in the TwinCAT 2.11 representation

The individual items of information can also be displayed in the overview window (A) on the right. By clicking on the button

in the menu bar the information can also be displayed there.

Fig. 3: Consolidated process image in the extended representation under TwinCAT 2.11

Notes

  • The consolidated representation is only visible from TwinCAT 2.11 and above. For reasons of compatibility, if a EL32xx-xxxx-0017 (or later) is operated in earlier TwinCAT configurations, the individual process image is displayed, prepended with the identifier "Status__".

    Fig. 4: Consolidated process image represented under TwinCAT 2.10
  • Revisions -0016 and -0017 do not depend on the revision of the firmware installed in the terminal. This means that terminals that were supplied as EL32xx-xxxx-0016 can also be operated with a "newer" -0017 configuration, and therefore can be addressed using the consolidated process image.
    This case of "upwards compatibility" is permitted for the EL32xx-xxxx-0016 and -0017.
  • The easiest way to determine the revision that is installed in the terminal is through a scan of the EtherCAT system. The comparison report shows the differences.

    Fig. 5: Typical result after scanning an EtherCAT system

    Explanations regarding fig. 5: According to the overview on the right, an EL3201-0000-0016 was found in the configuration (*.tsm file), whereas the overview on the left shows revision -0017. The general downward compatibility of the EL terminals ensures that this kind of application is possible.


Notices on analog specifications

Beckhoff I/O devices (terminals, boxes) with analog inputs are characterized by a number of technical characteristic data; refer to the technical data in the respective documents.

Some explanations are given below for the correct interpretation of these characteristic data.

Full scale value

An I/O device with an analog input measures over a nominal measuring range that is limited by an upper and a lower limit (initial value and end value); these can usually be taken from the device designation.
The range between the two limits is called the measuring span and corresponds to the equation (end value - initial value). Analogous to pointing devices this is the measuring scale (see IEC 61131) or also the dynamic range.

For analog I/O devices from Beckhoff the rule is that the limit with the largest value is chosen as the full scale value of the respective product (also called the reference value) and is given a positive sign. This applies to both symmetrical and asymmetrical measuring spans.

For the above examples this means:

  • Measuring range 0 to 10 V: asymmetric unipolar, full scale value = 10 V, measuring span = 10 V
  • Measuring range 4 to 20 mA: asymmetric unipolar, full scale value = 20 mA, measuring span = 16 mA
  • Measuring range -200 to 1370 °C: asymmetric bipolar, full scale value = 1370 °C, measuring span = 1570 °C
  • Measuring range -10 to +10 V: symmetric bipolar, full scale value = 10 V, measuring span = 20 V

This applies equally for analog output terminals.

± Measuring error [% of the full scale value] (also: measurement error)

The relative measuring error is referenced to the full scale value and is calculated as the quotient of the largest numerical deviation from the true value (‘measuring error’) referenced to the full scale value.

The measuring error is generally valid for the entire permitted operating temperature range, also called the ‘usage error limit’ and contains random and systematic portions of the referred device (i.e. ‘all’ influences such as temperature, inherent noise, aging, etc.).

It always to be regarded as a positive/negative span with ±, even if it is specified without ± in some cases.

The maximum deviation can also be specified directly.

Example: Measuring range 0 to 10 V and measuring error < ± 0.3 % full scale value --> maximum deviation ± 30 mV in the permissible operating temperature range.

Notice: since this specification also includes the temperature drift, a significantly lower measuring error can usually be assumed in case of a constant ambient temperature and thermal stabilization of the device.

This applies equally for analog output terminals.

Single-ended/differential typification

For analog inputs Beckhoff makes a basic distinction between two types: single-ended (SE) and differential (DIFF), referring to the difference in electrical connection with regard to the potential difference.

The diagram shows two-channel versions of an SE module and a DIFF module as examples for all multi-channel versions.

Notice: Dashed lines indicate that the respective connection may not necessarily be present in each SE or DIFF module.

The basic rule:

  • Analog measurements always take the form of voltage measurements between two potential points.
    For voltage measurements a large R is used, in order to ensure a high impedance. For current measurements a small R is used as shunt. If the purpose is resistance measurement, corresponding considerations are applied.
    • Beckhoff generally refers to these two points as input+/signal potential and input-/reference potential.
    • For measurements between two potential points two potentials have to be supplied.
    • Regarding the terms "single-wire connection" or "three-wire connection", please note the following for pure analog measurements: three- or four-wire connections can be used for sensor supply, but are not involved in the actual analog measurement, which always takes place between two potentials/wires.
      In particular this also applies to SE, even though the term suggest that only one wire is required.
  • The term "electrical isolation" should be clarified in advance.
    Beckhoff IO modules feature 1..8 or more analog channels; with regard to the channel connection a distinction is made in terms of:
    • how the channels WITHIN a module relate to each other, or
    • how the channels of SEVERAL modules relate to each other.

    The property of electrical isolation indicates whether the channels are directly connected to each other.

    • Beckhoff terminals always feature electrical isolation between the field/analog side and the bus/EtherCAT side. In other words, if two analog terminals are not connected via the power contacts, the modules are effectively electrically isolated.
    • If channels within a module are electrically isolated, or if a single-channel module has no power contacts, the channels are effectively always differential. See also explanatory notes below. Differential channels are not necessarily electrically isolated.
  • Analog measuring channels are subject to technical limits, both in terms of the recommended operating range (continuous operation) and the destruction limit. Please refer to the respective terminal documentation for further details.

Explanation

  • Differential
    • Differential measurement is the most flexible concept. The user can freely choose both connection points, input+/signal potential and input-/reference potential, within the framework of the technical specification.
    • A differential channel can also be operated as SE, if the reference potential of several sensors is linked. This interconnection may take place via the system GND.
    • Since a differential is configured symmetrically internally (see diagram), there will be a mid-potential (X) between the two supplied potentials that is the same as the internal ground/reference ground for this channel. If several DIFF channels are used in a module without electrical isolation, the technical property VCM (common-mode voltage) indicates the degree to which the mean voltage of the channels may differ.
    • The internal reference ground may be accessible as connection point at the terminal, in order to stabilize a defined GND potential in the terminal. In this case it is particularly important to pay attention to the quality of this potential (noiselessness, voltage stability). At this GND point a wire may be connected to make sure that VCM, max is not exceeded in the differential sensor cable.
      If differential channels are not electrically isolated, usually only one VCM, max is permitted. If the channels are electrically isolated this limit should not apply, and the channels voltages may differ up to the specified separation limit.
    • Differential measurement in combination with correct sensor wiring has the special advantage that any interference affecting the sensor cable (ideally the feed and return line are arranged side by side, so that interference signals have the same effect on both wires) has very little effect on the measurement, since the potential of both lines varies jointly (hence the term common mode). In simple terms: Common-mode interference has the same effect on both wires in terms of amplitude and phasing.
    • Nevertheless, the suppression of common-mode interference within a channel or between channels is subject to technical limits, which are specified in the technical data.
    • Further helpful information can be found in the documentation page Configuration of 0/4..20 mA differential inputs.
  • Single Ended
    • If the analog circuit is designed as SE, the input/reference wire is internally fixed to a certain potential that cannot be changed. This potential must be accessible from outside on at least one point for connecting the reference potential, e.g. via the power contacts.
    • In other words, in situations with several channels SE offers users the option to avoid returning at least one of the two sensor cables to the terminal (in contrast to DIFF). Instead, the reference wire can be consolidated at the sensors, e.g. in the system GND.
    • A disadvantage of this approach is that the separate feed and return line can result in voltage/current variations, which a SE channel may no longer be able to handle. See common-mode interference. A VCM effect cannot occur, since the module channels are internally always 'hard-wired' through the input/reference potential.

Typification of the 2/3/4-wire connection of current sensors

Current transducers/sensors/field devices (referred to in the following simply as ‘sensor’) with the industrial 0/4-20 mA interface typically have internal transformation electronics for the physical measured variable (temperature, current, etc.) at the current control output. These internal electronics must be supplied with energy (voltage, current). The type of cable for this supply thus separates the sensors into self-supplied or externally supplied sensors:

• Self-supplied sensors

- The sensor draws the energy for its own operation via the sensor/signal cable + and -.
So that enough energy is always available for the sensor’s own operation and open-circuit detection is possible, a lower limit of 4 mA has been specified for the 4-20 mA interface; i.e. the sensor allows a minimum current of 4 mA and a maximum current of 20 mA to pass.

- For a 2-wire connection see the drawing below; see also IEC60381-1

- Such current transducers generally represent a current sink and thus like to sit between + and – as a ‘variable load’. Refer also to the sensor manufacturer’s information.

Therefore, they are to be connected according to the Beckhoff terminology as follows:

- preferably to ‘single-ended’ inputs if the +Supply connections of the terminal are also to be used - connect to +Supply and Signal

- they can, however, also be connected to ‘differential’ inputs, if the termination to GND is then manufactured on the application side – to be connected with the right polarity to +Signal and -Signal
Be sure to read the information page ‘Wiring of 0/4-20 mA differential inputs’

• Externally supplied sensors

- For a 3/4-wire connection see the drawing below; see also IEC60381-1

- the sensor draws the energy/operating voltage for its own operation from 2 supply cables of its own. One or two further sensor cables are used for the signal transmission of the current loop:

• 1 sensor cable: according to the Beckhoff terminology such sensors are to be connected to ‘single-ended’ inputs in 3 cables with +/-/Signal lines and if necessary FE/shield

• 2 sensor cables: In the case of sensors with 4-wire connection according to +-/+Signal/-Signal, you must check whether +Signal may be connected to +Supply or –Signal to –Supply.

- Yes: then you can connect accordingly to a Beckhoff ‘single-ended’ input.

- No: the Beckhoff ‘differential’ input for +Signal and –Signal is to be selected; +Supply and –Supply are to be connected via additional cables.
Be sure to read the information page ‘Wiring of 0/4-20 mA differential inputs’

Notice: expert organisations such as NAMUR demand a usable measuring range <4 mA/>20 mA for error detection and adjustment, see also NAMUR NE043.
The Beckhoff device documentation must be consulted in order to see whether the respective device supports such an extended signal range.

In general the polarity/direction of current is to be observed due to the internal diode:

Classification of the Beckhoff terminals - Beckhoff 0/4-20 mA terminals are available as differential and single-ended terminals:

  • Differential
    - EL3x1x: 0-20 mA, EL3x2x: 4-20 mA; KL exactly the same
    - Preferred current direction because of internal diode
    - The terminal is a passive differential current measuring device; passive means that the sensor is not supplied with power
  • Single-ended
    - EL3x4x: 0-20mA, EL3x5x: 4-20 mA; KL exactly the same
    - Preferred current direction because of internal diode
    - Designed for the connection of externally-supplied sensors with a 3/4-wire connection
    - Designed for the connection of self-supplied sensors with a 2-wire connection


Calibration certificate

For the high-precision terminals EL320x-0020, Beckhoff provides an individual calibration certificate. This certificate is deposited in the download area on the Beckhoff website.
Under http://www.beckhoff.com/certificates you can identify the terminal certificate with the individual ID of the terminal. This ID is laser-printed on the terminal (see fig. 1)

Fig. 1: laser-printed ID on the terminal


EtherCAT AL Status Codes

Error Code

Meaning

Description

Current State
(or state change)

Resulting State

Solution
0x0000 No error No error

Any

Current state

0x0001 Unspecified error No error code is defined for occurred error.

Any

Any + E

Read user manual or contact device manufacturer.
0x0002 No Memory Less hardware memory, slave need more memory.

Any

Any + E

Download smaller files or objects

Check user manual

Example: For slave configuration, application configuration files are downloaded (possibly via FoE or large CoE objects). The size of those files exceeds the local memory.
0x0011 Invalid requested state change The EtherCAT State Machine (ESM) defines which state changes are allowed. All other state changes are not allowed.

P→S, I→O, P→O, O→B, S→B, P→B

Current State + E

Go step-by-step from the original state to the desired state.
Example: If the master requests the slave to go from OP (AL Control = 0x08) directly to BOOT (AL Control = 0x03).
0x0012 Unknown requested state change The ESM defines the following states. They are coded with fixed values (only lower (=right) nibble):

BOOT: AL Control = 0x03

INIT: AL Control = 0x01

PREOP: AL Control = 0x02

SAFEOP: AL Control = 0x04

OP: AL Control = 0x08

The fifth bit of the AL Control (left nibble is 1) is the “Error Acknowledge Bit”. If the slave is in AL STATUS = 0x14, i.e. ERROR SAFEOP the master acknowledges this by setting the Acknowledge bit.

Any

Current State + E

Do only request the defined states
Example: If any other value for AL Control than those specified are sent.
0x0013 Boot state not supported Device does not support BOOT state, but the master requests the slave to go to BOOT (AL Control = 0x03)

I→B

I + E

0x0014 No valid firmware This error code may be returned after a firmware download, if the downloaded file cannot be used by the application controller.

I→P

I + E

Download a firmware that can be supported by the hardware and bootloader. Check Product Code and Revision Number (CoE object 0x1018). If this cannot be read from the firmware any more you may see this in the network configuration (CoE object dictionary) or probably in the ESI file (element Profile: ObjectDictionary:Objects:Object).
0x0015 Invalid mailbox configuration Mailbox communication (= acyclic parameter exchange) is done via two memory areas on the EtherCAT Slave Controller (ESC) – the “Output Mailbox” (master -> slave) and the “Input Mailbox” (slave-> master). Those memory areas are protected by SyncManagers to prevent from simultaneous access from master and salve controller at the same time. SyncManagers are hardware entities on the ESC. They are configured via certain registers in the ESC register area (starting at 0x0800). The configuration includes start address, length, and direction (output or input). If those settings differ from those expected by the host controller of the slave this error is returned.

I→B

I + E

Replace previous network description of old slave with the one of the new slave.
0x0016 Example: The slave hardware was replaced while the network configuration remained unchanged. The new hardware expects different mailbox SyncManager settings.

I→P

0x0017 Invalid Sync Manager configuration Process data communication (cyclic communication) is done via extra memory areas on the ESC, separated for outputs and inputs. The process data length and the process data SyncManager length have to be the same. If this is not the case or the start address or direction does not match this error is returned.

P→S, S→O

Current State + E

Issue a re-calculation of the EtherCAT configuration.
Example: The process data configuration was changed of the slaves which also changed the length of the data. The change was not activated in the configuration so that the configuration tool would have recalculated the SyncManager settings.
0x0018 No valid inputs available The slave application cannot provide valid input values.

O, S→O

S + E

Example: A certain hardware which needs to be connected to the slave was disconnected.
0x0019 No valid outputs available The slave application cannot recieve valid output values.

O, S→O

S + E

The RxPdoToggle may need to be handled by the PLC program

The outputs valid may have to be set by the PLC program

PLC may have stopped, restart PLC

Example: The slave has a RxPdoToggle output or an “Output Valid” information in its process data. The RxPdoToggle does not toggle or the OutputValid is not true. Therefore the slave has no process data which the application can use. If supported, check the RxPDO Toggle Failed Counter in object 0x1C3x.0E). Also, the Synchronization may have problems (see object 0x10F1:SI2 Sync Error Counter Limit) so that process data are received too late by the slave so that the local slave cycle misses the toggle event. Another reason can be that the PLC stopped working.
0x001A Synchronization error If too many RxPDO Toggle error occure, i.e. the RxPDO Toggle Failed Counter increases the internal limit the slave returns to SAFEPERROR with 0x001A. Multiple synchronization errors. Device is not synchronized any more (used if the causes mirrored by the AL Status Codes 0x2C, 0x2D, 0x32, 0x33, 0x34 cannot be distinguished).

O, S→O

S + E

0x001B Sync manager watchdog The slave did not receive process data within the specified watchdog time. Usually, the WD time is 100ms. The WD is re-started every time it receives new process data, usually when the Output SyncManager (SyncManager2) is written. For devices which have only inputs usually no WD is used. Increasing the WD is not a solution.

Reason: PLC stopped

O, S

S + E

0x001C Invalid Sync Manager Types

O, S, O, P→S

S + E

0x001D Invalid Output Configuration SM configuration for output process data is invalid.

O, S, O, P→S

S + E

0x001E Invalid Input Configuration SM configuration for input process data is invalid

O, S, O, P→S

S + E

0x001F Invalid Watchdog Configuration The Watchdog is configured in the ESC register 0x0400 and 0x0420. EtherCAT defines default watchdog settings (100ms) or they are defined in the ESI file. If the slave does not accept a change of the expected settings it returns this AL Status Code Example: A slave may not accept that the WD is deactivated.

O, S, O, P→S

P + E

Use default WD settings.
0x0020 Slave needs cold start Slave device require a power off - power on reset

Any

Current State + E

0x0021 Slave needs INIT Slave application requests INIT state

B, P, S, O

Current State + E

0x0022 Slave needs PREOP Slave application requests PREOP state

S, O

S + E, O + E

0x0023 Slave needs SAFEOP Slave application requests SAFEOP state

O

O + E

0x0024 Invalid Input Mapping The process data are described by the configuration (PdoConfig) and PDO assignment (PdoAssign).

PdoConfig: list of actual variables (usually indexes 0x6nnn for inputs and 0x7nnn for outputs). Variables are also called PDO entries. There can be one or several variables with in one list (i.e. within one PDO). The Input PDOs have the index 0x1Amm. The Output PDOs have the index 0x16mm.

PdoAssign: The list of PDOs (object index 0x16nn, 0x1Amm) which are actually part of the process data and hence, are transferred cyclically, are listed in the PDO Assign Objects 0x1C12 (output PDOs) and 0x1C13 (input PDOs). All this can be seen in the SystemManager on the TAB “Process Data”. If the mapping which was set by the user on the Process Data tab and which was expected by the slave do not match this Status Code is returned.

P→S

P + E

0x0025 | Invalid Output Mapping | Example: Slave does only support one or certain PDO combinations but a different setting was made by the user. For a bus coupler the connected terminals differ from the configured terminals in the SystemManager.
0x0026 Inconsistent Settings General settings mismatch

P→S

P + E

0x0027 Freerun not supported

P→S

P + E

0x0028 Synchronization not supported

P→S

P + E

0x0029 Freerun needs 3 Buffer Mode FreeRun mode, SM has to run in 3-buffer mode

P→S

P + E

0x002A Background Watchdog

S, O

P + E

0x002B No Valid Inputs and Outputs

O, S→O

S + E

0x002C Fatal Sync Error The hardware interrupt signal (so called Sync signal) generated by the ESC is not generated any more. The master sets and activated the cycle time of the Sync signal during state transition from PREOP to SAFEOP. If a slave was disconnected and reconnected (also due to lost frames or CRC errors) the generation of the SyncSignal may be lost.

O

S + E

Set master to INIT and back to OP so that the DCs are initialized again.
0x002D | ana | SyncSignal not received: In SAFEOP the slave waits for the first Sync0/Sync1 events before switching to OP, if these events were not received during the SAFEOP to OP-Timeout time the slave refuses the state transition to OP.
0x0030 Invalid DC SYNC Configuration Distributed Clock Configuration is invalid due to application requirements.

O, S→O, P→S

P + E, S + E

0x0031 Invalid DC Latch Configuration DC Latch configuration is invalid due to application requirements.

O, S→O, P→S

P + E, S + E

0x0032 PLL Error Master not synchronized, at least one DC event recieved.

O, S→O

S + E

0x0033 DC Sync IO Error Multiple Synchronization Errors: At least one SycnSignal was received before. However, the PLL between slave and master is not synchronized any more. This may occur if the master application jitters too much.

O, S→O

S + E

Use specific industrial pc, standard office PCs may have power saving options, graphic accelerateds and other system services which disturb the real-time of the master

CPU power may be too small for the PLC/NC program

Increas EtherCAT and PLC/NC cycle time

Use SyncUnits for the slaves using DCs

0x0034 DC Sync Timeout Error Multiple Synchronization Errors, too much SM events missed

O, S→O

S + E

0x0035 DC Invalid Sync Cycle Time

P→S

P + E

0x0036 DC Sync0 Cycle Time DC Sync0 cycle time does not fit to the application requirements

P→S

P + E

0x0037 DC Sync1 Cycle Time DC Sync1 cycle time does not fit to the application requirements

P→S

P + E

0x0041 MBX_AOE

B, P, S, O

Current State + E

0x0042 MBX_EOE

B, P, S, O

Current State + E

0x0043 MBX_COE

B, P, S, O

Current State + E

0x0044 MBX_FOE

B, P, S, O

Current State + E

0x0045 MBX_SOE

B, P, S, O

Current State + E

0x004F MBX_VOE

B, P, S, O

Current State + E

0x0050 EEPROM No Access EEPROM not assigned to PDI

Any

Any + E

0x0051 EEPROM Error EEPROM access error

Any

Any + E

0x0060 Slave Requested Locally

Any

I

0x0061 Device Identification Value updated

P

P + E

0x00F0 Application Controller available

I


UL Requirements

BECKHOFF EKxxxx, ELxxxx: Appendix

UL notice

Application
Beckhoff EtherCAT modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
For devices with Ethernet connectors
Not for connection to telecommunication circuits.

Basic principles

Two UL certificates are met in the Beckhoff EtherCAT product range, depending upon the components:

  • UL certification according to UL508
    Devices with this kind of certification are marked by this sign:

  • UL certification according to UL508 with limited power consumption
    The current consumed by the device is limited to a max. possible current consumption of 4 A. Devices with this kind of certification are marked by this sign:

Almost all current EtherCAT products (as at 2010/05) are UL certified without restrictions.

Application

If terminals certified with restrictions are used, then the current consumption at 24 V DC must be limited accordingly by means of supply

  • from an isolated source protected by a fuse of max. 4A (according to UL248) or
  • from a voltage supply complying with NEC class 2.
    A voltage source complying with NEC class 2 may not be connected in series or parallel with another NEC class 2 compliant voltage supply!

These requirements apply to the supply of all EtherCAT bus couplers, power adaptor terminals, Bus Terminals and their power contacts.


Firmware Kompatibilität

BECKHOFF EL320x: Appendix

Firmware compatibility

Beckhoff EtherCAT devices will be equipped with the last available firmware on delivery. There are certain dependencies between firmware and hardware, not all combinations are compatible.
The overview below shows which firmware is compatible to a certain hardware status.

Notice

  • It is strictly recommended to apply the last available firmware on the particular hardware
  • There is no customer right to get a firmware update at no charge for already delivered products by the Beckhoff company.

Attention 		Damage of devices possible!
Please note the details concerning the firmware update on the special page.
If you run a device in BOOTSTRAP mode to initiate a firmware update, it it possible that there is no checking of compatibility of the firmware.
A damage of the device is possible!
Please always make sure, that the firmware is suitable for the hardware status of the device!
EL3201
Hardware (HW) | Firmware (FW) | Revision No. | Date of release
00 - 02 | 03 | EL3201-0000-0016 | 2008/03
 | 04 |  | 2009/04
 | 05 |  | 2009/05
02 | 06 | EL3201-0000-0017 | 2010/04
03 - 10* | 07* |  | 2010/06
 |  | EL3201-0000-0018 | 2012/06
 |  | EL3202-0010-0019 | 2012/07
 |  | EL3202-0010-0020 | 2014/07
 |  | EL3202-0010-0021 | 2015/01
EL3201-0010
Hardware (HW) | Firmware (FW) | Revision No. | Date of release
00 - 02 | 03 | EL3201-0000-0016 | 2008/11
 | 04 |  | 2009/04
 | 05 |  | 2009/05
02 | 06 | EL3201-0000-0017 | 2010/04
03 - 08* | 07* |  | 2010/06
 |  | EL3201-0000-0018 | 2012/06
 |  | EL3202-0010-0019 | 2012/07
 |  | EL3202-0010-0020 | 2014/07
 |  | EL3202-0010-0021 | 2015/01
EL3201-0020
Hardware (HW) | Firmware (FW) | Revision No. | Date of release
00 - 02 | 03 | EL3201-0000-0016 | 2008/11
 | 04 |  | 2009/04
 | 05 |  | 2009/05
02 | 06 | EL3201-0000-0017 | 2010/04
03 - 08* | 07* |  | 2010/06
 |  | EL3201-0000-0018 | 2012/06
 |  | EL3202-0010-0019 | 2012/07
 |  | EL3202-0010-0020 | 2014/07
 |  | EL3202-0010-0021 | 2015/01
EL3202
Hardware (HW) | Firmware (FW) | Revision No. | Date of release
00 - 02 | 03 | EL3202-0000-0016 | 2008/03
 | 04 |  | 2009/04
 | 05 |  | 2009/05
03 - 10* | 06 | EL3202-0000-0017 | 2010/04
 | 07* | EL3202-0000-0018 | 2012/06
 |  | EL3202-0010-0019 | 2012/07
 |  | EL3202-0010-0020 | 2014/07
 |  | EL3202-0010-0021 | 2015/01
EL3202-0010
Hardware (HW) | Firmware (FW) | Revision No. | Date of release
00 - 01 | 05 | EL3202-0010-0016 | 2009/07
 | 06 | EL3202-0010-0017 | 2010/04
01 - 07* | 07 |  | 2010/06
 | 08 |  | 2010/10
 | 09 |  | 2011/07
 | 10* |  | 2011/09
 |  | EL3202-0010-0018 | 2012/06
 |  | EL3202-0010-0019 | 2012/07
 |  | EL3202-0010-0020 | 2014/07
 |  | EL3202-0010-0021 | 2015/01
EL3202-0020
Hardware (HW) | Firmware (FW) | Revision No. | Date of release
01 - 07* | 09 | EL3202-0020-0017 | 2011/02
 | 10* |  | 2011/09
 |  | EL3202-0020-0018 | 2012/06
 |  | EL3202-0010-0019 | 2012/07
 |  | EL3202-0010-0020 | 2014/07
 |  | EL3202-0010-0021 | 2015/01
EL3204
Hardware (HW) | Firmware (FW) | Revision No. | Date of release
00 - 02 | 03 | EL3204-0000-0016 | 2008/03
 | 04 |  | 2009/04
 | 05 |  | 2009/05
03 - 09* | 06 | EL3204-0000-0017 | 2010/04
 | 07* |  | 2011/06
 |  | EL3204-0000-0018 | 2012/07
EL3204-0200
Hardware (HW) | Firmware (FW) | Revision No. | Date of release
00* | 01 | EL3204-0200-0016 | 2013/08
 | 02* | EL3204-0200-0017 | 2014/04

*) At the time of creation of this documentation this is the current compatible hardware status. Please check the Beckhoff website for the latest documentation.


EtherCAT - Firmware

BECKHOFF EtherCAT: Device Update

Firmware EL/ES/EM/EPxxxx

This section describes the device update for Beckhoff EtherCAT slaves from the EL/ES, EM, EK and EP series. A firmware update should only be carried out after consultation with Beckhoff support.

Table of contents
• Storage locations
• Device description ESI file/XML
• Frimware version definition
• Updating Controller firmware *.efw
• FPGA firmware update *.rbf
• Multiple update

Storage locations

An EtherCAT slave stores operating data in up to 3 locations:

  • Depending on functionality and performance EtherCAT slaves have one or several local controllers for processing I/O data. The corresponding program is the so-called firmware in *.efw format.
  • In some EtherCAT slaves the EtherCAT communication may also be integrated in these controllers. In this case the controller is usually a so-called FPGA chip with *.rbf firmware.
  • In addition each EtherCAT slave has a memory chip for storing its own device description, a so-called EEPROM. On power-up this description is loaded and the EtherCAT communication is set up accordingly. The device description is available from the download area of the Beckhoff website at http://www.beckhoff.com . All ESI files (EtherCAT Slave Information) are available in ZIP format.

Customers can access the data via the EtherCAT fieldbus and its communication mechanisms. Acyclic mailbox communication or register access to the ESC is used for updating or reading of these data.

The TwinCAT System Manager offers mechanisms for programming all 3 parts with new data, if the slave is set up for this purpose. Generally the slave does not check whether the new data are suitable, i.e. it may no longer be able to operate if the data are unsuitable.

Attention 		Risk of damage to the device!
Note the following when downloading new device files
  • Firmware downloads to an EtherCAT device must not be interrupted
  • Flawless EtherCAT communication must be ensured. CRC errors or Lost Frames must be avoided.
  • The power supply must adequately dimensioned. The signal level must meet the specification.

In the event of malfunctions during the update process the EtherCAT device may become unusable and require re-commissioning by the manufacturer.

Device description ESI file/XML

Attention 		Notice regarding update of the ESI description/EEPROM
Some slaves have stored calibration and configuration data from the production in the EEPROM. These are irretrievably overwritten during an update.

The ESI device description is stored locally on the slave and loaded on start-up. Each device description has a unique identifier consisting of slave name (9 characters/digits) and a revision number (4 digits). Each slave configured in the System Manager shows its identifier in the EtherCAT tab:

Fig. 1: Device identifier consisting of name EL3204-0000 and revision -0016

The configured identifier must be compatible with the actual device description used as hardware, i.e. the description which the slave has loaded on start-up (in this case EL3204). Generally the configured revision must be equal or lower than the version used in the terminal network.

For further information please refer to the EtherCAT System Documentation.

Note 		Update of XML/ESI description
The device revision is closely linked to the firmware and hardware used. Incompatible combinations lead to malfunctions or even final shutdown of the device.
Corresponding updates should only be carried out in consultation with Beckhoff support.

Display of ESI slave identifier

The simplest way to ascertain compliance of configured and actual device description is to scan the EtherCAT boxes in TwinCAT mode Config/Freerun:

Fig. 2: Scan the subordinate field by right-clicking on the EtherCAT device in Config/FreeRun mode

If the found field matches the configured field, the display shows

Fig. 3: Configuration is identical

otherwise a change dialog for entering the actual data in the configuration.

Fig. 4: Change dialog

In the example shown in Fig. 4. an EL3201-0000-0017 was found, while an EL3201-0000-0016 had been configured. In this case it makes sense to adapt the configuration with the Copy Before button. The Extended Information checkbox must be set in order to have the revision displayed.

Changing the ESI slave identifier

The ESI/EEPROM identifier can be updated as follows under TwinCAT:

  • The EtherCAT communication with the slave must be flawless.
  • The state of the slave is irrelevant.
  • Right-click on the slave in the online display to bring up the EEPROM Update dialog, Fig. 5

Fig. 5: EEPROM Update

Select the new ESI description in the following dialog, see Fig. 6. The ShowHiddenDevices checkbox also shows older, usually hidden slave versions.

Fig. 6: Selecting the new ESI

A progress bar in the System Manager shows the progress. Data are first written, then verified.

Note 		The change only takes effect after a restart.
Most EtherCAT devices read a modified ESI description immediately or after startup from the INIT. Some communication settings such as distributed clocks are only read during power-on.
The EtherCAT slave therefore has to be switched off briefly in order for the change to take effect.

Determining the firmware version

Determining the version on laser inscription

Beckhoff EtherCAT slaves feature serial numbers applied by laser. The serial number has the following structure: KK YY FF HH

KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version

Example with ser. no.: 12 10 03 02:

12 - week of production 12
10 - year of production 2010
03 - firmware version 03
02 - hardware version 02

Determining the version via the System Manager

The TwinCAT System Manager shows the version of the controller firmware if the master can access the slave online. Click on the E-Bus Terminal whose controller firmware you want to check (in the example terminal 2 (EL3204)) and select the tab CoE Online (CAN over EtherCAT).

Note 		CoE Online and Offline CoE
Two CoE directories are available:
  • online: This is offered in the EtherCAT slave by the controller, if the EtherCAT slave does supported it.
    This CoE directory can only be displayed if a slave is connected and operational.
  • offline: The EtherCAT Slave Information ESI/XML may contain the default content of the CoE.
    This CoE directory can only be displayed if it is included in the ESI (e.g. "Beckhoff EL5xxx.xml").

The Advanced button must be used for switching between the two views.

In Fig. 7 the firmware version of the selected EL3204 is shown as 03 in CoE entry x100A.

Fig. 7: Display of EL3204 firmware version

In (A) TwinCAT 2.11 shows that the Online CoE directory is currently displayed. If this is not the case, the Online directory can be loaded via the Online option in Advanced Settings (B) and double-clicking on AllObjects.

Updating controller firmware *.efw

Note 		CoE directory
The Online CoE directory is managed by the controller and stored in a dedicated EEPROM, which is generally not changed during a firmware update.

To update the controller firmware of a slave switch to tab Online, see Fig. 8.

Fig. 8: Firmware Update

Proceed as follows, unless instructed otherwise by Beckhoff support.

  • Switch slave to INIT (A)
  • Switch slave to BOOTSTRAP
  • Check the current status (B, C)
  • Download the new *efw file
  • After the download switch to INIT, then OP
  • Switch off the slave briefly

FPGA firmware *.rbf

If an FPGA chip deals with the EtherCAT communication an update may be accomplished via an *.rbf file.

  • Controller firmware for processing I/O signals
  • FPGA firmware for EtherCAT communication (only for terminals with FPGA)

The firmware version number included in the terminal serial number contains both firmware components. If one of these firmware components is modified this version number is updated.

Determining the version via the System Manager

The TwinCAT System Manager indicates the FPGA firmware version. Click on the Ethernet card of your EtherCAT strand (Device 2 in the example) and select the Online tab.

The Reg:0002 column indicates the firmware version of the individual EtherCAT devices in hexadecimal and decimal representation.

Fig. 9: FPGA firmware version definition

If the column Reg:0002 is not displayed, right-click the table header and select Properties... in the context menu.

Fig. 10: Context menu Properties

The Advanced Settings dialog appears where the columns to be displayed can be selected. Under Diagnosis/Online View select the '0002 ETxxxx Build' check box in order to activate the FPGA firmware version display.

Fig. 11: Dialog Advanced Settings

Update

For updating the FPGA firmware

  • of an EtherCAT coupler the coupler must have FPGA firmware version 11 or higher;
  • of an E-Bus Terminal the terminal must have FPGA firmware version 10 or higher.

Older firmware versions can only be updated by the manufacturer!

Updating an EtherCAT device

In the TwinCAT System Manager select the terminal whose FPGA firmware you want to update (in this example terminal 5: EL5001) and
click on Advanced Settings in the EtherCAT tab.

Fig. 12: Select dialog Advanced Settings

The Advanced Settings dialog appears. Under ESC Access/E²PROM/FPGA click on Write FPGA button,

Fig. 13: Select dialog Write FPGA

select the file (*.rbf) with the new FPGA firmware, and transfer it to the EtherCAT device.

Attention 		Risk of damage to the device!
A firmware download to an EtherCAT device must never be interrupted!

If this process is cancelled, the supply voltage switched off or the Ethernet connection interrupted, the EtherCAT device can only be recommissioned by the manufacturer!

In order to activate the new FPGA firmware a restart (switching the power supply off and on again) of the EtherCAT device is required.

Simultaneous updating of several EtherCAT devices

The firmware and ESI descriptions of several devices can be updated simultaneously, provided the devices have the same firmware file/ESI.

Fig. 14: Multiple selection and firmware update

Select the required slaves and carry out the firmware update in BOOTSTRAP mode as described above.


ELxxxx - restoring the delivery state

BECKHOFF ELxxxx: Configuration

Restoring the delivery state

To restore the delivery state for backup objects in ELxxxx terminals, the CoE object "Restore default parameters", SubIndex 001 can be selected in the TwinCAT System Manager (Config mode) (see Fig. 1)

Fig. 1 Selecting the "Restore default parameters" PDO

Double-click on SubIndex 001 to enter the Set Value dialog. Enter the value 1684107116 in field "Dec" or the value 0x64616F6C in field "Hex" and confirm with OK (Fig. 2).
All backup objects are reset to the delivery state.

Fig. 2 Entering a restore value in the Set Value dialog

Note 		Alternative restore value

In some older terminals the backup objects can be switched with an alternative restore value:

Decimal value: "1819238756"

Hexadecimal value: "0x6C6F6164"

An incorrect entry for the restore value has no effect.


Support and Service

Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.

Beckhoff's branch offices and representatives

Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!

The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com

You will also find further documentation for Beckhoff components there.

Beckhoff Headquarters

Beckhoff Automation GmbH & Co. KG

Huelshorstweg 20
33415 Verl
Germany

Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support

Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:

  • support
  • design, programming and commissioning of complex automation systems
  • and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service

The Beckhoff Service Center supports you in all matters of after-sales service:

  • on-site service
  • repair service
  • spare parts service
  • hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com


Fieldbus Components - ATEX Documentation

BECKHOFF Fieldbus Components: Mounting and wiring

ATEX Documentation

Note 		Notes about operation of the Bus Terminal System in potentially explosive areas (ATEX)
Pay also attention to the continuative documentation

Notes about operation of the Bus Terminal System in potentially explosive areas (ATEX)

that is available in the download area of the Beckhoff homepage http:\\www.beckhoff.com!


ATEX - Special conditions

WARNING 		Observe the special conditions for the intended use of
Beckhoff fieldbus components in potentially explosive areas (directive 94/9/EU)!
  • The certified components are to be installed in a suitable housing that guarantees a protection class of at least IP54 in accordance with EN 60529! The environmental conditions during use are thereby to be taken into account!
  • If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
  • Observe the permissible ambient temperature range of 0 - 55°C for the use of Beckhoff fieldbus components in potentially explosive areas!
  • Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
  • The individual terminals may only be unplugged or removed from the Bus Terminal system if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
  • The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
  • The fuses of the KL92xx power feed terminals may only be exchanged if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
  • Address selectors and ID switches may only be adjusted if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!

Standards

The fundamental health and safety requirements are fulfilled by compliance with the following standards:

  • EN 60079-0: 2006
  • EN 60079-15: 2005

Marking

The Beckhoff fieldbus components certified for potentially explosive areas bear one of the following markings:

II 3 G Ex nA II T4 KEMA 10ATEX0075 X Ta: 0 - 55°C

or

II 3 G Ex nA nC IIC T4 KEMA 10ATEX0075 X Ta: 0 - 55°C

Serial number

The Beckhoff fieldbus components bear a serial number that is structured as follows:

WW YY FF HH

WW - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version

Example with ser. no.: 35 04 1B 01:

35 - week of production 35
04 - year of production 2004
1B - firmware version 1B
01 - hardware version 01