EL252x - Pulse Train Output Terminal, Incremental Encoder Simulation Terminal (Pulse Train)
Home


Foreword

Foreword
Foreword
Additional information
•
Product overview Pulse Train Output Terminals
•
Notes on the documentation
•
Safety instructions
•
Documentation Issue Status
•
Version identification of EtherCAT devices


Product overview Pulse Train Output Terminals

Foreword [image] Product overview Pulse Train Output Terminals
Product overview Pulse Train Output Terminals
EL2521 | 1-channel pulse train output terminal (RS422)
EL2521-0024 | 1-channel pulse train output terminal (24 VDC)
EL2521-0025 | 1-channel pulse train output terminal (24 VDC, negative switching)
EL2521-0124 | 1-channel pulse train output terminal (latch input, 24 VDC output)
EL2522 | 2-channel incremental encoder simulation terminal (pulse train)


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation Issue Status

Foreword [image] Documentation Issue Status
Documentation Issue Status
Version | Comment
4.0 | - Update chapter "Basic function principles” - Update chapter "Technical data"
3.9 | - Update chapter "Basic function principles” - Update revision status - Structural update
3.8 | - Update chapter "Mounting and wiring” - Update revision status - Structural update
3.7 | - Safety instructions new layout - Update chapter "Technical data" - Update chapter "LEDs and connection" - Chapter "ATEX - special conditions (extended temperature range)" added - Chapter "Integration in the NC" added - Update revision status - Structural update
3.6 | - Update chapter "Commissioning"
3.5 | - Update chapter "Technical data" - Structure update - Update chapter "Connection technology" -> "connection" - Update chapter "Firmware Update EL/ES/EM/EPxxxx"
3.4 | - Update chapter "Technical data" - Note on ESD protection added
3.3 | - Update chapter "Commissioning"
3.2 | - Update chapter "Notes on the documentation" - Correction in technical data - Update chapter "TwinCAT 2.1x" -> chapter "TwinCAT development environment" and chapter "TwinCAT Quick Start" - Update revision status
3.1 | - Renaming and restructuring of the chapter "Connection of the EL2522 in the NC"
3.0 | - Revision/migration - EL2522 amended
2.8 | - Update chapter "Technical data" - Addenda chapter "Installation instructions for enhanced mechanical load capacity" - Structure update
2.7 | - Update chapter "Basic function principles"
2.6 | - Update travel distance control
2.5 | - Update Technical data
2.4 | - Firmware compatibility list and technical notes amended
2.3 | - Correction of LED description
2.2 | - Addendum EL2521-0124
2.1 | - Addendum EL2521-0024, EL2521-0025
2.0 | - Addendum Technical data, CoE, PDO
1.0 | - Correction in technical data
0.1 | - Provisional documentation for EL2521


Version identification of EtherCAT devices

Foreword [image] Version identification of EtherCAT devices
Version identification of EtherCAT devices
Designation
A Beckhoff EtherCAT device has a 14-digit designation, made up of
▪
family key
▪
type
▪
version
▪
revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
Notes
▪
The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
▪
EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
▪
The order identifier is made up of
- family key (EL, EP, CU, ES, KL, CX, etc.)
- type (3314)
- version (-0000)
▪
The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
▪
The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Identification number
Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:
Production lot/batch number/serial number/date code/D number
The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02
Exceptions can occur in the IP67 area, where the following syntax can be used (see respective device documentation):
Syntax: D ww yy x y z u
D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB
Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1
Unique serial number/ID, ID number
In addition, in some series each individual module has its own unique serial number.
See also the further documentation in the area
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Terminals with factory calibration certificate and other measuring terminals
Examples of markings
EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
Additional information
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Foreword [image] Version identification of EtherCAT devices [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Product overview

Product overview
Product overview
Additional information
•
EL2521-xxxx
•
EL2522-0000
•
Start Up


EL2521-xxxx

Product overview [image] EL2521-xxxx
EL2521-xxxx
Additional information
•
EL2521 - Introduction
•
EL2521 - Technical data


EL2521 - Introduction

Product overview [image] EL2521-xxxx [image] EL2521 - Introduction
EL2521 - Introduction
EL2521 variants
1 Channel Pulse Train Output Terminal
The EL2521-0000 terminal outputs a predefined sequence of pulses via two RS422 compatible differential outputs. The correlation between Channel A and B is adjustable, e.g. as encoder functionality. The pulse rate and the frequency is specified by the controller via a 16 bit value. The EtherCAT Terminals indicate their signal state by means of light emitting diodes. The LEDs are driven in time with the outputs and each displays an active output. The galvanic isolation from the E-bus is provided.
In the EL2521-0024 version the two output channels are implemented as potential-free FET switches and can be fed externally.
In the EL2521-0025 the two output channels are negative-switching, potential-free FET switches and can also be fed externally. Note the logic reversal in the control. A further variant of this version is the EL2521-0124 with a latch input and a 24 V output.
Quick links
▪
EtherCAT basics
▪
Commissioning
▪
CoE description EL2521-00xx - normal operation mode
▪
CoE description EL2521-00xx - enhanced operation mode
▪
CoE description EL2521-0124 - enhanced operation mode
▪
Process data and operation modes


EL2521 - Technical data

Product overview [image] EL2521-xxxx [image] EL2521 - Technical data
EL2521 - Technical data
Technical data | EL2521-0000 | EL2521-0024 | EL2521-0124 |  | EL2521-0025
Digital outputs | 1 channel (2 differential outputs A, B) | 1 channel (2 potential-free FET outputs) | 1 channel (2 FET outputs) 1 x 24 V output |  | 1 channel (2 potential-free FET outputs), negative switching
Digital inputs | 2 (+T, +Z) |  | 1 x latch input (5..24 VDC) |  | 2 (+T, +Z)
Signal voltage | RS422 level | 5..24 VDC, external supply | 24 VDC, external supply |  | 5..24 VDC, external supply
Load type | RS422 and optocoupler, min. 120 Ω | variable
Output current max. (per channel) | 50 mA, RS485 specification | max. 1 A
Switching threshold, "T" and "Z" inputs | High: >5 V (max. 24 VDC), Low: <1 V
Base frequency | 0 ... 500 kHz, Default: 50 kHz
Resolution | max. 15 bit
Step size | 10 mHz
Voltage supply for electronic | via the E-bus
Current consumption via E-bus | typ. 280 mA (load-dependent)
Electrical isolation | 500 V (E-bus/field voltage)
Bit width in process image | def. 16 bit Data in, 16 bit Data out, 16 bit Control, 16 bit Status
Configuration | via TwinCAT System Manager
Weight | approx. 55 g
Permissible ambient temperature range during operation | 0°C ... + 55°C
Permissible ambient temperature range during storage | -25°C ... + 85°C
Permissible relative humidity | 95%, no condensation
Dimensions (W x H x D) | approx. 15 mm x 100 mm x 70 mm
Mounting | on 35 mm mounting rail conforms to EN 50022
Vibration/shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27, see also installation instructions for enhanced mechanical load capacity
EMC immunity/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation position | variable
Approval | CE ATEX cULus |  |  | CE cULus


EL2522-0000

Product overview [image] EL2522-0000
EL2522-0000
Additional information
•
EL2522 - Introduction
•
EL2522 - Technical data


EL2522 - Introduction

Product overview [image] EL2522-0000 [image] EL2522 - Introduction
EL2522 - Introduction
2 channel incremental encoder simulation terminal (pulse train)
The EL2522 incremental encoder simulation terminal (pulse train) outputs a frequency-modulable signal on two channels with four outputs.
The signal can be used to control motor drivers or other signal receivers, which are controlled by single cycles. As with the EL2521 the pulse sequence and pulse number can be specified directly via the process data in the frequency. Alternatively, the integrated travel distance control can be used. For each channel the operating mode (frequency modulation, pulse/direction specification and incremental encoder simulation) can be selected. In the ABC encoder simulation the EL2522 can control three output channels.
The EL2522 supports the basic operating modes of the EL2521 and has additional operating modes.
Quick links
▪
EtherCAT basics
▪
Commissioning
▪
CoE description EL2522
▪
Process data and operation modes


EL2522 - Technical data

Product overview [image] EL2522-0000 [image] EL2522 - Technical data
EL2522 - Technical data
Technical data | EL2522-0000
Digital outputs | alternatively: 2 channel (2 differential outputs A/A,B/B) or: 1 channel (3 differential outputs A/A, B/B, C/C)
Signal voltage | RS422 level (differential min. 1 V, max. 3 V)
Load type | RS422 and optocoupler, min. 120 Ω
Max. output current (per channel) | 50 mA, RS422 specification
Base frequency | 0 ... 4 MHz, default: 50 kHz
Duty factor | 50 % (± 10 %)
Resolution | max. 15 bit
Step size | min. 10 ns (internal)
Power supply for the electronics | via the E-bus
Current consumption via E-bus | typ. 120 mA
Electrical isolation | 500 V (E-bus/field voltage)
Bit width in process image | default 14 bytes Data in, 28 bytes Data out
Configuration | via TwinCAT System Manager
Weight | approx. 50 g
Permissible ambient temperature range during operation | -25 °C ... + 60 °C
Permissible ambient temperature range during storage | -40 °C ... + 85 °C
Permissible relative air humidity | 95 %, no condensation
Dimensions (W x H x D) | approx. 15 mm x 100 mm x 70 mm
Mounting | on 35 mm mounting rail according to EN 60715
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27, see also Installation instructions for enhanced mechanical load capacity
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation position | variable
Approval | CE cULus


Start Up

Product overview [image] Start Up
Start Up
For commissioning:
▪
mount the EL252x as described in the chapter Mounting and wiring
▪
Configure the EL252x in TwinCAT as described in chapter Commissioning.


Basics communication

Basics communication
Basics communication
Additional information
•
EtherCAT basics
•
EtherCAT cabling – wire-bound
•
General notes for setting the watchdog
•
EtherCAT State Machine
•
CoE Interface
•
Distributed Clock


EtherCAT basics

Basics communication [image] EtherCAT basics
EtherCAT basics
Please refer to the EtherCAT System Documentation for the EtherCAT fieldbus basics.


EtherCAT cabling – wire-bound

Basics communication [image] EtherCAT cabling – wire-bound
EtherCAT cabling – wire-bound
The cable length between two EtherCAT devices must not exceed 100 m. This results from the FastEthernet technology, which, above all for reasons of signal attenuation over the length of the cable, allows a maximum link length of 5 + 90 + 5 m if cables with appropriate properties are used. See also the Design recommendations for the infrastructure for EtherCAT/Ethernet.
Cables and connectors
For connecting EtherCAT devices only Ethernet connections (cables + plugs) that meet the requirements of at least category 5 (CAt5) according to EN 50173 or ISO/IEC 11801 should be used. EtherCAT uses 4 wires for signal transfer.
EtherCAT uses RJ45 plug connectors, for example. The pin assignment is compatible with the Ethernet standard (ISO/IEC 8802-3).
Pin | Color of conductor | Signal | Description
1 | yellow | TD + | Transmission Data +
2 | orange | TD - | Transmission Data -
3 | white | RD + | Receiver Data +
6 | blue | RD - | Receiver Data -
Due to automatic cable detection (auto-crossing) symmetric (1:1) or cross-over cables can be used between EtherCAT devices from Beckhoff.
Recommended cables
Suitable cables for the connection of EtherCAT devices can be found on the Beckhoff website!
E-Bus supply
A bus coupler can supply the EL terminals added to it with the E-bus system voltage of 5 V; a coupler is thereby loadable up to 2 A as a rule (see details in respective device documentation).
Information on how much current each EL terminal requires from the E-bus supply is available online and in the catalogue. If the added terminals require more current than the coupler can supply, then power feed terminals (e.g. EL9410) must be inserted at appropriate places in the terminal strand.
The pre-calculated theoretical maximum E-Bus current is displayed in the TwinCAT System Manager. A shortfall is marked by a negative total amount and an exclamation mark; a power feed terminal is to be placed before such a position.
System manager current calculation
Note
Malfunction possible!
The same ground potential must be used for the E-Bus supply of all EtherCAT terminals in a terminal block!


General notes for setting the watchdog

Basics communication [image] General notes for setting the watchdog
General notes for setting the watchdog
ELxxxx terminals are equipped with a safety feature (watchdog) that switches off the outputs after a specifiable time e.g. in the event of an interruption of the process data traffic, depending on the device and settings, e.g. in OFF state.
The EtherCAT slave controller (ESC) in the EL2xxx terminals features 2 watchdogs:
▪
SM watchdog (default: 100 ms)
▪
PDI watchdog (default: 100 ms)
SM watchdog (SyncManager Watchdog)
The SyncManager watchdog is reset after each successful EtherCAT process data communication with the terminal. If no EtherCAT process data communication takes place with the terminal for longer than the set and activated SM watchdog time, e.g. in the event of a line interruption, the watchdog is triggered and the outputs are set to FALSE. The OP state of the terminal is unaffected. The watchdog is only reset after a successful EtherCAT process data access. Set the monitoring time as described below.
The SyncManager watchdog monitors correct and timely process data communication with the ESC from the EtherCAT side.
PDI watchdog (Process Data Watchdog)
If no PDI communication with the EtherCAT slave controller (ESC) takes place for longer than the set and activated PDI watchdog time, this watchdog is triggered.
PDI (Process Data Interface) is the internal interface between the ESC and local processors in the EtherCAT slave, for example. The PDI watchdog can be used to monitor this communication for failure.
The PDI watchdog monitors correct and timely process data communication with the ESC from the application side.
The settings of the SM- and PDI-watchdog must be done for each slave separately in the TwinCAT System Manager.
EtherCAT tab -> Advanced Settings -> Behavior -> Watchdog
Notes:
▪
the multiplier is valid for both watchdogs.
▪
each watchdog has its own timer setting, the outcome of this in summary with the multiplier is a resulting time.
▪
Important: the multiplier/timer setting is only loaded into the slave at the start up, if the checkbox is activated.
If the checkbox is not activated, nothing is downloaded and the ESC settings remain unchanged.
Multiplier
Multiplier
Both watchdogs receive their pulses from the local terminal cycle, divided by the watchdog multiplier:
1/25 MHz * (watchdog multiplier + 2) = 100 µs (for default setting of 2498 for the multiplier)
The standard setting of 1000 for the SM watchdog corresponds to a release time of 100 ms.
The value in multiplier + 2 corresponds to the number of basic 40 ns ticks representing a watchdog tick.
The multiplier can be modified in order to adjust the watchdog time over a larger range.
Example "Set SM watchdog"
This checkbox enables manual setting of the watchdog times. If the outputs are set and the EtherCAT communication is interrupted, the SM watchdog is triggered after the set time and the outputs are erased. This setting can be used for adapting a terminal to a slower EtherCAT master or long cycle times. The default SM watchdog setting is 100 ms. The setting range is 0...65535. Together with a multiplier with a range of 1...65535 this covers a watchdog period between 0...~170 seconds.
Calculation
Multiplier = 2498 → watchdog base time = 1 / 25 MHz * (2498 + 2) = 0.0001 seconds = 100 µs
SM watchdog = 10000 → 10000 * 100 µs = 1 second watchdog monitoring time
SmallWarningYellow CAUTION
Undefined state possible!
The function for switching off of the SM watchdog via SM watchdog = 0 is only implemented in terminals from version -0016. In previous versions this operating mode should not be used.
SmallWarningYellow CAUTION
Damage of devices and undefined state possible!
If the SM watchdog is activated and a value of 0 is entered the watchdog switches off completely. This is the deactivation of the watchdog! Set outputs are NOT set in a safe state, if the communication is interrupted.


EtherCAT State Machine

Basics communication [image] EtherCAT State Machine
EtherCAT State Machine
The state of the EtherCAT slave is controlled via the EtherCAT State Machine (ESM). Depending upon the state, different functions are accessible or executable in the EtherCAT slave. Specific commands must be sent by the EtherCAT master to the device in each state, particularly during the bootup of the slave.
A distinction is made between the following states:
▪
Init
▪
Pre-Operational
▪
Safe-Operational and
▪
Operational
▪
Boot
The regular state of each EtherCAT slave after bootup is the OP state.
States of the EtherCAT State Machine
Init
After switch-on the EtherCAT slave in the Init state. No mailbox or process data communication is possible. The EtherCAT master initializes sync manager channels 0 and 1 for mailbox communication.
Pre-Operational (Pre-Op)
During the transition between Init and Pre-Op the EtherCAT slave checks whether the mailbox was initialized correctly.
In Pre-Op state mailbox communication is possible, but not process data communication. The EtherCAT master initializes the sync manager channels for process data (from sync manager channel 2), the FMMU channels and, if the slave supports configurable mapping, PDO mapping or the sync manager PDO assignment. In this state the settings for the process data transfer and perhaps terminal-specific parameters that may differ from the default settings are also transferred.
Safe-Operational (Safe-Op)
During transition between Pre-Op and Safe-Op the EtherCAT slave checks whether the sync manager channels for process data communication and, if required, the distributed clocks settings are correct. Before it acknowledges the change of state, the EtherCAT slave copies current input data into the associated DP-RAM areas of the EtherCAT slave controller (ECSC).
In Safe-Op state mailbox and process data communication is possible, although the slave keeps its outputs in a safe state, while the input data are updated cyclically.
Outputs in SAFEOP state
The default set watchdog monitoring sets the outputs of the module in a safe state - depending on the settings in SAFEOP and OP - e.g. in OFF state. If this is prevented by deactivation of the watchdog monitoring in the module, the outputs can be switched or set also in the SAFEOP state.
Operational (Op)
Before the EtherCAT master switches the EtherCAT slave from Safe-Op to Op it must transfer valid output data.
In the Op state the slave copies the output data of the masters to its outputs. Process data and mailbox communication is possible.
Boot
In the Boot state the slave firmware can be updated. The Boot state can only be reached via the Init state.
In the Boot state mailbox communication via the file access over EtherCAT (FoE) protocol is possible, but no other mailbox communication and no process data communication.


CoE Interface

Basics communication [image] CoE Interface
CoE Interface
General description
The CoE interface (CAN application protocol over EtherCAT)) is used for parameter management of EtherCAT devices. EtherCAT slaves or the EtherCAT master manage fixed (read only) or variable parameters which they require for operation, diagnostics or commissioning.
CoE parameters are arranged in a table hierarchy. In principle, the user has read access via the fieldbus. The EtherCAT master (TwinCAT System Manager) can access the local CoE lists of the slaves via EtherCAT in read or write mode, depending on the attributes.
Different CoE parameter types are possible, including string (text), integer numbers, Boolean values or larger byte fields. They can be used to describe a wide range of features. Examples of such parameters include manufacturer ID, serial number, process data settings, device name, calibration values for analog measurement or passwords.
The order is specified in 2 levels via hexadecimal numbering: (main)index, followed by subindex. The value ranges are
▪
Index: 0x0000 …0xFFFF (0...65535dez)
▪
SubIndex: 0x00…0xFF (0...255dez)
A parameter localized in this way is normally written as 0x8010:07, with preceding "x" to identify the hexadecimal numerical range and a colon between index and subindex.
The relevant ranges for EtherCAT fieldbus users are:
▪
0x1000: This is where fixed identity information for the device is stored, including name, manufacturer, serial number etc., plus information about the current and available process data configurations.
▪
0x8000: This is where the operational and functional parameters for all channels are stored, such as filter settings or output frequency.
Other important ranges are:
▪
0x4000: here are the channel parameters for some EtherCAT devices. Historically, this was the first parameter area before the 0x8000 area was introduced. EtherCAT devices that were previously equipped with parameters in 0x4000 and changed to 0x8000 support both ranges for compatibility reasons and mirror internally.
▪
0x6000: Input PDOs ("input" from the perspective of the EtherCAT master)
▪
0x7000: Output PDOs ("output" from the perspective of the EtherCAT master)
Availability
Not every EtherCAT device must have a CoE list. Simple I/O modules without dedicated processor usually have no variable parameters and therefore no CoE list.
If a device has a CoE list, it is shown in the TwinCAT System Manager as a separate tab with a listing of the elements:
"CoE Online " tab
The figure above shows the CoE objects available in device "EL2502", ranging from 0x1000 to 0x1600. The subindices for 0x1018 are expanded.
Data management and function "NoCoeStorage"
Some parameters, particularly the setting parameters of the slave, are configurable and writeable. This can be done in write or read mode
▪
via the System Manager (Fig. "CoE Online" tab) by clicking
This is useful for commissioning of the system/slaves. Click on the row of the index to be parameterised and enter a value in the "SetValue" dialog.
▪
from the control system/PLC via ADS, e.g. through blocks from the TcEtherCAT.lib library
This is recommended for modifications while the system is running or if no System Manager or operating staff are available.
Data management
If slave CoE parameters are modified online, Beckhoff devices store any changes in a fail-safe manner in the EEPROM, i.e. the modified CoE parameters are still available after a restart.
The situation may be different with other manufacturers.

An EEPROM is subject to a limited lifetime with respect to write operations. From typically 100,000 write operations onwards it can no longer be guaranteed that new (changed) data are reliably saved or are still readable. This is irrelevant for normal commissioning. However, if CoE parameters are continuously changed via ADS at machine runtime, it is quite possible for the lifetime limit to be reached. Support for the NoCoeStorage function, which suppresses the saving of changed CoE values, depends on the firmware version.
Please refer to the technical data in this documentation as to whether this applies to the respective device.
•
If the function is supported: the function is activated by entering the code word 0x12345678 once in CoE 0xF008 and remains active as long as the code word is not changed. After switching the device on it is then inactive. Changed CoE values are not saved in the EEPROM and can thus be changed any number of times.
•
Function is not supported: continuous changing of CoE values is not permissible in view of the lifetime limit.
Startup list
Changes in the local CoE list of the terminal are lost if the terminal is replaced. If a terminal is replaced with a new Beckhoff terminal, it will have the default settings. It is therefore advisable to link all changes in the CoE list of an EtherCAT slave with the Startup list of the slave, which is processed whenever the EtherCAT fieldbus is started. In this way a replacement EtherCAT slave can automatically be parameterized with the specifications of the user.
If EtherCAT slaves are used which are unable to store local CoE values permanently, the Startup list must be used.
Recommended approach for manual modification of CoE parameters
▪
Make the required change in the System Manager
The values are stored locally in the EtherCAT slave
▪
If the value is to be stored permanently, enter it in the Startup list.
The order of the Startup entries is usually irrelevant.
Startup list in the TwinCAT System Manager
The Startup list may already contain values that were configured by the System Manager based on the ESI specifications. Additional application-specific entries can be created.
Online/offline list
While working with the TwinCAT System Manager, a distinction has to be made whether the EtherCAT device is "available", i.e. switched on and linked via EtherCAT and therefore online, or whether a configuration is created offline without connected slaves.
In both cases a CoE list as shown in Fig. “CoE online tab” is displayed. The connectivity is shown as offline/online.
▪
If the slave is offline
–
The offline list from the ESI file is displayed. In this case modifications are not meaningful or possible.
–
The configured status is shown under Identity.
–
No firmware or hardware version is displayed, since these are features of the physical device.
–
Offline is shown in red.
Offline list
▪
If the slave is online
–
The actual current slave list is read. This may take several seconds, depending on the size and cycle time.
–
The actual identity is displayed
–
The firmware and hardware version of the equipment according to the electronic information is displayed
–
Online is shown in green.
Online list
Channel-based order
The CoE list is available in EtherCAT devices that usually feature several functionally equivalent channels. For example, a 4-channel analog 0...10 V input terminal also has 4 logical channels and therefore 4 identical sets of parameter data for the channels. In order to avoid having to list each channel in the documentation, the placeholder "n" tends to be used for the individual channel numbers.
In the CoE system 16 indices, each with 255 subindices, are generally sufficient for representing all channel parameters. The channel-based order is therefore arranged in 16dec/10hex steps. The parameter range 0x8000 exemplifies this:
▪
Channel 0: parameter range 0x8000:00 ... 0x800F:255
▪
Channel 1: parameter range 0x8010:00 ... 0x801F:255
▪
Channel 2: parameter range 0x8020:00 ... 0x802F:255
▪
...
This is generally written as 0x80n0.
Detailed information on the CoE interface can be found in the EtherCAT system documentation on the Beckhoff website.


Distributed Clock

Basics communication [image] Distributed Clock
Distributed Clock
The distributed clock represents a local clock in the EtherCAT slave controller (ESC) with the following characteristics:
▪
Unit 1 ns
▪
Zero point 1.1.2000 00:00
▪
Size 64 bit (sufficient for the next 584 years; however, some EtherCAT slaves only offer 32-bit support, i.e. the variable overflows after approx. 4.2 seconds)
▪
The EtherCAT master automatically synchronizes the local clock with the master clock in the EtherCAT bus with a precision of < 100 ns.
For detailed information please refer to the EtherCAT system description.


Mounting and Wiring

Mounting and Wiring
Mounting and Wiring
Additional information
•
Instructions for ESD protection
•
Installation on mounting rails
•
Installation instructions for enhanced mechanical load capacity
•
Connection
•
LEDs and connection
•
Installation positions
•
Positioning of passive Terminals
•
ATEX - Special conditions (standard temperature range)
•
ATEX - Special conditions (extended temperature range)
•
ATEX Documentation
•
UL notice


Instructions for ESD protection

Mounting and Wiring [image] Instructions for ESD protection
Instructions for ESD protection
Note
Destruction of the devices by electrostatic discharge possible!
The devices contain components at risk from electrostatic discharge caused by improper handling.
•
Please ensure you are electrostatically discharged and avoid touching the contacts of the device directly.
•
Avoid contact with highly insulating materials (synthetic fibers, plastic film etc.).
•
Surroundings (working place, packaging and personnel) should by grounded probably, when handling with the devices.
•
Each assembly must be terminated at the right hand end with an EL9011 or EL9012 bus end cap, to ensure the protection class and ESD protection.
Spring contacts of the Beckhoff I/O components


Installation on mounting rails

Mounting and Wiring [image] Installation on mounting rails
Installation on mounting rails
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Assembly
Attaching on mounting rail
The bus coupler and bus terminals are attached to commercially available 35 mm mounting rails (DIN rails according to EN 60715) by applying slight pressure:
1.
First attach the fieldbus coupler to the mounting rail.
2.
The bus terminals are now attached on the right-hand side of the fieldbus coupler. Join the components with tongue and groove and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
If the terminals are clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.
Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail. At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail. To mount the mounting rails with a height of 7.5 mm under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).
Disassembly
Disassembling of terminal
Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
1.
Pull the terminal by its orange-colored lugs approximately 1 cm away from the mounting rail. In doing so for this terminal the mounting rail lock is released automatically and you can pull the terminal out of the bus terminal block easily without excessive force.
2.
Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal out of the bus terminal block.
Connections within a bus terminal block
The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:
▪
The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
▪
The power contacts deal with the supply for the field electronics and thus represent a supply rail within the bus terminal block. The power contacts are supplied via terminals on the Bus Coupler (up to 24 V) or for higher voltages via power feed terminals.
Power Contacts
During the design of a bus terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts. Power Feed Terminals (KL91xx, KL92xx or EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.
PE power contact
The power contact labeled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Power contact on left side
Note
Possible damage of the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a nominal voltage of 230 V). For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.
SmallWarningYellow WARNING
Risk of electric shock!
The PE power contact must not be used for other potentials!


Installation instructions for enhanced mechanical load capacity

Mounting and Wiring [image] Installation instructions for enhanced mechanical load capacity
Installation instructions for enhanced mechanical load capacity
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminal system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals!
Additional checks
The terminals have undergone the following additional tests:
Verification | Explanation
Vibration | 10 frequency runs in 3 axes
 | 6 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 25 g, 6 ms
Additional installation instructions
For terminals with enhanced mechanical load capacity, the following additional installation instructions apply:
▪
The enhanced mechanical load capacity is valid for all permissible installation positions
▪
Use a mounting rail according to EN 60715 TH35-15
▪
Fix the terminal segment on both sides of the mounting rail with a mechanical fixture, e.g. an earth terminal or reinforced end clamp
▪
The maximum total extension of the terminal segment (without coupler) is:
64 terminals (12 mm mounting with) or 32 terminals (24 mm mounting with)
▪
Avoid deformation, twisting, crushing and bending of the mounting rail during edging and installation of the rail
▪
The mounting points of the mounting rail must be set at 5 cm intervals
▪
Use countersunk head screws to fasten the mounting rail
▪
The free length between the strain relief and the wire connection should be kept as short as possible. A distance of approx. 10 cm should be maintained to the cable duct.


Connection

Mounting and Wiring [image] Connection
Connection
Additional information
•
Connection system
•
Wiring
•
Shielding


Connection system

Mounting and Wiring [image] Connection [image] Connection system
Connection system
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Overview
The Bus Terminal system offers different connection options for optimum adaptation to the respective application:
▪
The terminals of ELxxxx and KLxxxx series with standard wiring include electronics and connection level in a single enclosure.
▪
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level and enable steady wiring while replacing.
▪
The High Density Terminals (HD Terminals) include electronics and connection level in a single enclosure and have advanced packaging density.
Standard wiring (ELxxxx / KLxxxx)
Standard wiring
The terminals of ELxxxx and KLxxxx series have been tried and tested for years.
They feature integrated screwless spring force technology for fast and simple assembly.
Pluggable wiring (ESxxxx / KSxxxx)
Pluggable wiring
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level.
The assembly and wiring procedure is the same as for the ELxxxx and KLxxxx series.
The pluggable connection level enables the complete wiring to be removed as a plug connector from the top of the housing for servicing.
The lower section can be removed from the terminal block by pulling the unlocking tab.
Insert the new component and plug in the connector with the wiring. This reduces the installation time and eliminates the risk of wires being mixed up.
The familiar dimensions of the terminal only had to be changed slightly. The new connector adds about 3 mm. The maximum height of the terminal remains unchanged.
A tab for strain relief of the cable simplifies assembly in many applications and prevents tangling of individual connection wires when the connector is removed.
Conductor cross sections between 0.08 mm2 and 2.5 mm2 can continue to be used with the proven spring force technology.
The overview and nomenclature of the product names for ESxxxx and KSxxxx series has been retained as known from ELxxxx and KLxxxx series.
High Density Terminals (HD Terminals)
High Density Terminals
The Bus Terminals from these series with 16 terminal points are distinguished by a particularly compact design, as the packaging density is twice as large as that of the standard 12 mm Bus Terminals. Massive conductors and conductors with a wire end sleeve can be inserted directly into the spring loaded terminal point without tools.
Wiring HD Terminals
The High Density Terminals of the ELx8xx and KLx8xx series doesn't support pluggable wiring.
Ultrasonically "bonded" (ultrasonically welded) conductors
Ultrasonically “bonded" conductors
It is also possible to connect the Standard and High Density Terminals with ultrasonically "bonded" (ultrasonically welded) conductors. In this case, please note the tables concerning the wire-size width below!


Wiring

Mounting and Wiring [image] Connection [image] Wiring
Wiring
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Terminals for standard wiring ELxxxx/KLxxxx and for pluggable wiring ESxxxx/KSxxxx
Connecting a cable on a terminal point
Up to eight terminal points enable the connection of solid or finely stranded cables to the Bus Terminal. The terminal points are implemented in spring force technology. Connect the cables as follows:
1.
Open a terminal point by pushing a screwdriver straight against the stop into the square opening above the terminal point. Do not turn the screwdriver or move it alternately (don't toggle).
2.
The wire can now be inserted into the round terminal opening without any force.
3.
The terminal point closes automatically when the pressure is released, holding the wire securely and permanently.
See the following table for the suitable wire size width.
Terminal housing | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Wire size width (single core wires) | 0.08 ... 2.5 mm2 | 0.08 ... 2.5 mm2
Wire size width (fine-wire conductors) | 0.08 ... 2.5 mm2 | 0,08 ... 2.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 1.5 mm2 | 0.14 ... 1.5 mm2
Wire stripping length | 8 ... 9 mm | 9 ... 10 mm
High Density Terminals (HD Terminals) with 16 terminal points
The conductors of the HD Terminals are connected without tools for single-wire conductors using the direct plug-in technique, i.e. after stripping the wire is simply plugged into the terminal point. The cables are released, as usual, using the contact release with the aid of a screwdriver. See the following table for the suitable wire size width.
Terminal housing | High Density Housing
Wire size width (single core wires) | 0.08 ... 1.5 mm2
Wire size width (fine-wire conductors) | 0.25 ... 1.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 0.75 mm2
Wire size width (ultrasonically “bonded" conductors) | only 1.5 mm2
Wire stripping length | 8 ... 9 mm


Shielding

Mounting and Wiring [image] Connection [image] Shielding
Shielding
Shielding
Encoder, analog sensors and actors should always be connected with shielded, twisted paired wires.


LEDs and connection

Mounting and Wiring [image] LEDs and connection
LEDs and connection
Additional information
•
EL2521-xxxx - LEDs and connection
•
EL2522 - LEDs and connection


EL2521-xxxx - LEDs and connection

Mounting and Wiring [image] LEDs and connection [image] EL2521-xxxx - LEDs and connection
EL2521-xxxx - LEDs and connection
Additional information
•
EL2521-0000
•
EL2521-0024
•
EL2521-0124
•
EL2521-0025
•
Connecting the inputs
•
Connection of the outputs


EL2521-0000

Mounting and Wiring [image] LEDs and connection [image] EL2521-xxxx - LEDs and connection [image] EL2521-0000
EL2521-0000
EL2521-0000 connection and wiring example
Connection EL2521-0000
Terminal point |  | Description
Name | No.
Output +A | 1 | Output +A
Output +B | 2 | Output +B
Input T | 3 | Input T
T.Z. GND/T.Z. Ref. GND | 4 | Signal ground for the outputs
Output -A | 5 | Output -A
Output -B | 6 | Output -B
Input Z | 7 | Input Z
Shield | 8 | Shield
LEDs EL2521-0000
LED | Color | Meaning
Output A, B | green | The illumination of the LEDs for the active frequency outputs A or B at higher frequencies can only be perceived as a glow at half brightness
Input T, Z | green | Lights up when a signal is present
RUN | green | This LED indicates the terminal's operating state:
 |  | off | State of the EtherCAT State Machine: INIT = initialization of the terminal
 |  | flashing | State of the EtherCAT State Machine: PREOP = function for mailbox communication and different default settings set
 |  | Single flash | State of the EtherCAT State Machine: SAFEOP = verification of the Sync Manager channels Outputs remain in safe state
 |  | on | State of the EtherCAT State Machine: OP = normal operating state; mailbox and process data communication is possible
 |  | flickering/ rapidly flashing | State of the EtherCAT State Machine: BOOTSTRAP = function for firmware updates


EL2521-0024

Mounting and Wiring [image] LEDs and connection [image] EL2521-xxxx - LEDs and connection [image] EL2521-0024
EL2521-0024
EL2521-0024 pin assignment and sample connection
Connection EL2521-0024
Terminal point |  | Description
Name | No.
Output +A | 1 | Output +A
Output +B | 2 | Output +B
Input T | 3 | Input T
T.Z. GND/T.Z. Ref. GND | 4 | Signal ground for the outputs
Output -A | 5 | Output -A
Output -B | 6 | Output -B
Input Z | 7 | Input Z
Shield | 8 | Shield
LEDs EL2521-0024
LED | Color | Meaning
Output A, B | green | The illumination of the LEDs for the active frequency outputs A or B at higher frequencies can only be perceived as a glow at half brightness
Input T, Z | green | Lights up when a signal is present
RUN | green | This LED indicates the terminal's operating state:
 |  | off | State of the EtherCAT State Machine: INIT = initialization of the terminal
 |  | flashing | State of the EtherCAT State Machine: PREOP = function for mailbox communication and different default settings set
 |  | Single flash | State of the EtherCAT State Machine: SAFEOP = verification of the Sync Manager channels Outputs remain in safe state
 |  | on | State of the EtherCAT State Machine: OP = normal operating state; mailbox and process data communication is possible
 |  | flickering/ rapidly flashing | State of the EtherCAT State Machine: BOOTSTRAP = function for firmware updates


EL2521-0124

Mounting and Wiring [image] LEDs and connection [image] EL2521-xxxx - LEDs and connection [image] EL2521-0124
EL2521-0124
EL2521-0124 pin assignment and sample connection
Connection EL2521-0124
Terminal point |  | Description
Name | No.
Output +A | 1 | Output +A
Output +B | 2 | Output +B
Latch24 V | 3 | 24 V latch input
Latch/Output GND Ref. GND | 4 | Signal ground for the outputs and for the latch input
Output -A | 5 | Output -A
Output -B | 6 | Output -B
Output 24 V | 7 | 24 V output
Shield | 8 | Shield
LEDs EL2521-0124
LED | Color | Meaning
Output A, B | green | The illumination of the LEDs for the active frequency outputs A or B at higher frequencies can only be perceived as a glow at half brightness
Latch/ Output 24 V | green | Lights up when a signal is present
RUN | green | This LED indicates the terminal's operating state:
 |  | off | State of the EtherCAT State Machine: INIT = initialization of the terminal
 |  | flashing | State of the EtherCAT State Machine: PREOP = function for mailbox communication and different default settings set
 |  | Single flash | State of the EtherCAT State Machine: SAFEOP = verification of the Sync Manager channels Outputs remain in safe state
 |  | on | State of the EtherCAT State Machine: OP = normal operating state; mailbox and process data communication is possible
 |  | flickering/ rapidly flashing | State of the EtherCAT State Machine: BOOTSTRAP = function for firmware updates


EL2521-0025

Mounting and Wiring [image] LEDs and connection [image] EL2521-xxxx - LEDs and connection [image] EL2521-0025
EL2521-0025
EL2521-0025 pin assignment and sample connection
Connection EL2521-0025
Terminal point |  | Description
Name | No.
Output -A | 1 | Output -A
Output -B | 2 | Output -B
Input T | 3 | Input T
T.Z. GND/T.Z. Ref. GND | 4 | Signal ground for the outputs
Output +A | 5 | Output +A
Output +B | 6 | Output +B
Input Z | 7 | Input Z
Shield | 8 | Shield
LEDs EL2521-0025
LED | Color | Meaning
Output A, B | green | The illumination of the LEDs for the active frequency outputs A or B at higher frequencies can only be perceived as a glow at half brightness
Input T, Z | green | Lights up when a signal is present
RUN | green | This LED indicates the terminal's operating state:
 |  | off | State of the EtherCAT State Machine: INIT = initialization of the terminal
 |  | flashing | State of the EtherCAT State Machine: PREOP = function for mailbox communication and different default settings set
 |  | Single flash | State of the EtherCAT State Machine: SAFEOP = verification of the Sync Manager channels Outputs remain in safe state
 |  | on | State of the EtherCAT State Machine: OP = normal operating state; mailbox and process data communication is possible
 |  | flickering/ rapidly flashing | State of the EtherCAT State Machine: BOOTSTRAP = function for firmware updates


Connecting the inputs

Mounting and Wiring [image] LEDs and connection [image] EL2521-xxxx - LEDs and connection [image] Connecting the inputs
Connecting the inputs
The optically isolated inputs are protected from overload by a current limitation. Without further external circuit the operating voltage may lie between 5 and 24 VDC. The GND connection is the common ground of the two inputs T and Z. The circuit diagram shows the internal circuit of the two inputs:
Internal circuit of the inputs T and Z


Connection of the outputs

Mounting and Wiring [image] LEDs and connection [image] EL2521-xxxx - LEDs and connection [image] Connection of the outputs
Connection of the outputs
Circuit examples for output to A. The same principles apply to output B.
EL2521-0000
The outputs A and B of the EL2521 can be used in different connection modes. An integrated DC/DC converter supplies the output stage of the two channels, A and B, with an electrically isolated 5 V power supply.
▪
Connection to RS422 receiver
The output can be operated as an RS422 output. The circuit generates the necessary differential signals.
EL2521-0000 on the RS422 Receiver
▪
Connection to optocoupler (without external supply voltage)
The outputs can be used for direct connection of an optocoupler. The output stage supplies the necessary output current using an internal 5 V supply voltage.
EL2521-0000, direct connection to an optocoupler
EL2521-0024, EL2521-0124
The operation with an external supply voltage depends on the hardware version of the terminal:
▪
Connection to optocoupler (with external supply voltage)
For connection to inputs with a large input resistance, an external supply voltage (up to 24 V) can be used with the EL2521-0024 in order to create the necessary current.
EL2521-0x24, wiring with external power source
Note
EL2521-0124 ground potential
In the case of the EL2521-0124 the outputs -A and -B must be connected to the signal ground (pin 4) in order to avoid damage to the terminal (see fig. Connection and wiring example for EL2521-0124)!
EL2521-0025
Note
Logic reversal with the EL2521-0025
When connecting the EL2521-0025, observe the logic reversal with the wiring (see fig. Connection and wiring example for EL2521-0025)!
▪
Connection to optocoupler (with external supply voltage)
For connection to inputs with a large input resistance, an external supply voltage (up to 24 V) can be used with the EL2521-0025 in order to create the necessary current. Due to the logic reversal, the positive voltage for driving the output current is to be connected to pin 5 or pin 6.
EL2521-0025, wiring with external power source, logic reversal


EL2522 - LEDs and connection

Mounting and Wiring [image] LEDs and connection [image] EL2522 - LEDs and connection
EL2522 - LEDs and connection
EL2522 connection and wiring example
EL2522-0000 connection
Terminal point |  | Description
Name | No.
Output A1+ | 1 | Output A1+
Output B1+ | 2 | Output B1+
not connected | 3 | not connected
Shield | 4 | Shield, internally connected to pins 8, 12 and 16
Output A2+, C1+ | 5 | Output A2+, C1+
Output B2+ | 6 | Output B2+
not connected | 7 | not connected
Shield | 8 | Shield, internally connected to pins 4, 12 and 16
Output A1- | 9 | Output A1-
Output B1- | 10 | Output B1-
GND | 11 | *) from hardware version 04: GND of the outputs for occasional equipotential bonding
Shield | 12 | Shield, internally connected to pins 4, 8 and 16
Output A2-, C1- | 13 | Output A2-, C1-
Output B2- | 14 | Output B2-
GND | 15 | *) from hardware version 04: GND of the outputs for occasional equipotential bonding
Shield | 16 | Shield, internally connected to pins 4, 8 and 12
LEDs EL2522
LED | Color | Meaning
Output A1, A2, B1, B2, C1 | green | The LED for the active frequency output A1, A2, B1, B2 or C1; can only be perceived as a glow at half brightness at higher frequencies.
RUN | green | This LED indicates the terminal's operating state:
 |  | off | State of the EtherCAT State Machine: INIT = initialization of the terminal
 |  | flashing | State of the EtherCAT State Machine: PREOP = function for mailbox communication and different default settings set
 |  | Single flash | State of the EtherCAT State Machine: SAFEOP = verification of the Sync Manager channels Outputs remain in safe state
 |  | on | State of the EtherCAT State Machine: OP = normal operating state; mailbox and process data communication is possible
 |  | flickering/ rapidly flashing | State of the EtherCAT State Machine: BOOTSTRAP = function for firmware updates


Installation positions

Mounting and Wiring [image] Installation positions
Installation positions
Note
Constraints regarding installation position and operating temperature range
Please refer to the technical data for a terminal to ascertain whether any restrictions regarding the installation position and/or the operating temperature range have been specified. When installing high power dissipation terminals ensure that an adequate spacing is maintained between other components above and below the terminal in order to guarantee adequate ventilation!
Optimum installation position (standard)
The optimum installation position requires the mounting rail to be installed horizontally and the connection surfaces of the EL/KL terminals to face forward (see Fig. “Recommended distances for standard installation position”). The terminals are ventilated from below, which enables optimum cooling of the electronics through convection. "From below" is relative to the acceleration of gravity.
Recommended distances for standard installation position
Compliance with the distances shown in Fig. “Recommended distances for standard installation position” is recommended.
Other installation positions
All other installation positions are characterized by different spatial arrangement of the mounting rail - see Fig “Other installation positions”.
The minimum distances to ambient specified above also apply to these installation positions.
Other installation positions


Positioning of passive Terminals

Mounting and Wiring [image] Positioning of passive Terminals
Positioning of passive Terminals
Hint for positioning of passive terminals in the bus terminal block
EtherCAT Terminals (ELxxxx / ESxxxx), which do not take an active part in data transfer within the bus terminal block are so called passive terminals. The passive terminals have no current consumption out of the E-Bus.
To ensure an optimal data transfer, you must not directly string together more than 2 passive terminals!
Examples for positioning of passive terminals (highlighted)
Correct positioning
Incorrect positioning


ATEX - Special conditions (standard temperature range)

Mounting and Wiring [image] ATEX - Special conditions (standard temperature range)
ATEX - Special conditions (standard temperature range)
SmallWarningYellow WARNING
Observe the special conditions for the intended use of Beckhoff fieldbus components with standard temperature range in potentially explosive areas (directive 2014/34/EU)!
•
The certified components are to be installed in a suitable housing that guarantees a protection class of at least IP54 in accordance with EN 60079-15! The environmental conditions during use are thereby to be taken into account!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of 0 to 55°C for the use of Beckhoff fieldbus components standard temperature range in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The individual terminals may only be unplugged or removed from the Bus Terminal system if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The fuses of the KL92xx/EL92xx power feed terminals may only be exchanged if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
Address selectors and ID switches may only be adjusted if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Marking
The Beckhoff fieldbus components with standard temperature range certified according to the ATEX directive for potentially explosive areas bear one of the following markings:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … +55°C
or
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … +55°C


ATEX - Special conditions (extended temperature range)

Mounting and Wiring [image] ATEX - Special conditions (extended temperature range)
ATEX - Special conditions (extended temperature range)
SmallWarningYellow WARNING
Observe the special conditions for the intended use of Beckhoff fieldbus components with extended temperature range (ET) in potentially explosive areas (directive 2014/34/EU)!
•
The certified components are to be installed in a suitable housing that guarantees a protection class of at least IP54 in accordance with EN 60079-15! The environmental conditions during use are thereby to be taken into account!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of -25 to 60°C for the use of Beckhoff fieldbus components with extended temperature range (ET) in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The individual terminals may only be unplugged or removed from the Bus Terminal system if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The fuses of the KL92xx/EL92xx power feed terminals may only be exchanged if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
Address selectors and ID switches may only be adjusted if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Marking
The Beckhoff fieldbus components with extended temperature range (ET) certified according to the ATEX directive for potentially explosive areas bear the following marking:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: -25 … +60°C
or
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: -25 … +60°C


ATEX Documentation

Mounting and Wiring [image] ATEX Documentation
ATEX Documentation
Notes about operation of the Beckhoff terminal systems in potentially explosive areas (ATEX)
Pay also attention to the continuative documentation

Notes about operation of the Beckhoff terminal systems in potentially explosive areas (ATEX)

that is available in the download area of the Beckhoff homepage http:\\www.beckhoff.com!


UL notice

Mounting and Wiring [image] UL notice
UL notice
culus-logo
Application
Beckhoff EtherCAT modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
culus-logo
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
culus-logo
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
Basic principles
UL certification according to UL508. Devices with this kind of certification are marked by this sign:


Commissioning

Commissioning
Commissioning
Additional information
•
TwinCAT Quick Start
•
TwinCAT Development Environment
•
General Notes - EtherCAT Slave Application
•
Integration into the NC configuration
•
EL2521-xxxx
•
EL2522-0000


TwinCAT Quick Start

Commissioning [image] TwinCAT Quick Start
TwinCAT Quick Start
TwinCAT is a development environment for real-time control including multi-PLC system, NC axis control, programming and operation. The whole system is mapped through this environment and enables access to a programming environment (including compilation) for the controller. Individual digital or analog inputs or outputs can also be read or written directly, in order to verify their functionality, for example.
For further information please refer to http://infosys.beckhoff.com:
▪
EtherCAT Systemmanual:
Fieldbus Components → EtherCAT Terminals → EtherCAT System Documentation → Setup in the TwinCAT System Manager
▪
TwinCAT 2 → TwinCAT System Manager → I/O - Configuration
▪
In particular, TwinCAT driver installation:
Fieldbus components → Fieldbus Cards and Switches → FC900x – PCI Cards for Ethernet → Installation
Devices contain the terminals for the actual configuration. All configuration data can be entered directly via editor functions (offline) or via the "Scan" function (online):
▪
"offline": The configuration can be customized by adding and positioning individual components. These can be selected from a directory and configured.
–
The procedure for offline mode can be found under http://infosys.beckhoff.com:
TwinCAT 2 → TwinCAT System Manager → IO - Configuration → Adding an I/O Device
▪
"online": The existing hardware configuration is read
–
See also http://infosys.beckhoff.com:
Fieldbus components → Fieldbus cards and switches → FC900x – PCI Cards for Ethernet → Installation → Searching for devices
The following relationship is envisaged from user PC to the individual control elements:
Relationship between user side (commissioning) and installation
The user inserting of certain components (I/O device, terminal, box...) is the same in TwinCAT 2 and TwinCAT 3. The descriptions below relate to the online procedure.
Sample configuration (actual configuration)
Based on the following sample configuration, the subsequent subsections describe the procedure for TwinCAT 2 and TwinCAT 3:
▪
Control system (PLC) CX2040 including CX2100-0004 power supply unit
▪
Connected to the CX2040 on the right (E-bus):
EL1004 (4-channel digital input terminal 24 V DC)
▪
Linked via the X001 port (RJ-45): EK1100 EtherCAT Coupler
▪
Connected to the EK1100 EtherCAT coupler on the right (E-bus):
EL2008 (8-channel digital output terminal 24 V DC; 0.5 A)
▪
(Optional via X000: a link to an external PC for the user interface)
Control configuration with Embedded PC, input (EL1004) and output (EL2008)
Note that all combinations of a configuration are possible; for example, the EL1004 terminal could also be connected after the coupler, or the EL2008 terminal could additionally be connected to the CX2040 on the right, in which case the EK1100 coupler wouldn’t be necessary.
Additional information
•
TwinCAT 2
•
TwinCAT 3


TwinCAT 2

Commissioning [image] TwinCAT Quick Start [image] TwinCAT 2
TwinCAT 2
Startup
TwinCAT basically uses two user interfaces: the TwinCAT System Manager for communication with the electromechanical components and TwinCAT PLC Control for the development and compilation of a controller. The starting point is the TwinCAT System Manager.
After successful installation of the TwinCAT system on the PC to be used for development, the TwinCAT 2 System Manager displays the following user interface after startup:
Initial TwinCAT 2 user interface
Generally, TwinCAT can be used in local or remote mode. Once the TwinCAT system including the user interface (standard) is installed on the respective PLC, TwinCAT can be used in local mode and thereby the next step is "Insert Device".
If the intention is to address the TwinCAT runtime environment installed on a PLC as development environment remotely from another system, the target system must be made known first. In the menu under "Actions" → "Choose Target System...", via the symbol " [image] " or the "F8" key, open the following window:
Selection of the target system
Use "Search (Ethernet)..." to enter the target system. Thus a next dialog opens to either:
▪
enter the known computer name after "Enter Host Name / IP:" (as shown in red)
▪
perform a "Broadcast Search" (if the exact computer name is not known)
▪
enter the known computer IP or AmsNetID.
Specify the PLC for access by the TwinCAT System Manager: selection of the target system
Once the target system has been entered, it is available for selection as follows (a password may have to be entered):
After confirmation with "OK" the target system can be accessed via the System Manager.
Adding devices
In the configuration tree of the TwinCAT 2 System Manager user interface on the left, select "I/O Devices” and then right-click to open a context menu and select "Scan Devices…", or start the action in the menu bar via [image]. The TwinCAT System Manager may first have to be set to "Config mode" via [image] or via menu
“Actions" → "Set/Reset TwinCAT to Config Mode…" (Shift + F4).
Select "Scan Devices..."
Confirm the warning message, which follows, and select "EtherCAT" in the dialog:
Automatic detection of I/O devices: selection the devices to be integrated
Confirm the message "Find new boxes", in order to determine the terminals connected to the devices. "Free Run" enables manipulation of input and output values in "Config mode" and should also be acknowledged.
Based on the sample configuration described at the beginning of this section, the result is as follows:
Mapping of the configuration in the TwinCAT 2 System Manager
The whole process consists of two stages, which may be performed separately (first determine the devices, then determine the connected elements such as boxes, terminals, etc.). A scan can also be initiated by selecting "Device ..." from the context menu, which then reads the elements present in the configuration below:
Reading of individual terminals connected to a device
This functionality is useful if the actual configuration is modified at short notice.
Programming and integrating the PLC
TwinCAT PLC Control is the development environment for the creation of the controller in different program environments: TwinCAT PLC Control supports all languages described in IEC 61131-3. There are two text-based languages and three graphical languages.
▪
Text-based languages
–
Instruction List (IL)
–
Structured Text (ST)
▪
Graphical languages
–
Function Block Diagram (FBD)
–
Ladder Diagram (LD)
–
The Continuous Function Chart Editor (CFC)
–
Sequential Function Chart (SFC)
The following section refers to Structured Text (ST).
After starting TwinCAT PLC Control, the following user interface is shown for an initial project:
TwinCAT PLC Control after startup
Sample variables and a sample program have been created and stored under the name "PLC_example.pro":
Sample program with variables after a compile process (without variable integration)
Warning 1990 (missing "VAR_CONFIG") after a compile process indicates that the variables defined as external (with the ID "AT%I*" or "AT%Q*") have not been assigned. After successful compilation, TwinCAT PLC Control creates a "*.tpy" file in the directory in which the project was stored. This file (*.tpy) contains variable assignments and is not known to the System Manager, hence the warning. Once the System Manager has been notified, the warning no longer appears.
First, integrate the TwinCAT PLC Control project in the System Manager via the context menu of the PLC configuration; right-click and select "Append PLC Project…":
Appending the TwinCAT PLC Control project
Select the PLC configuration "PLC_example.tpy" in the browser window that opens. The project including the two variables identified with "AT" are then integrated in the configuration tree of the System Manager:
PLC project integrated in the PLC configuration of the System Manager
The two variables "bEL1004_Ch4" and "nEL2008_value" can now be assigned to certain process objects of the I/O configuration.
Assigning variables
Open a window for selecting a suitable process object (PDO) via the context menu of a variable of the integrated project "PLC_example" and via "Modify Link..." "Standard":
Creating the links between PLC variables and process objects
In the window that opens, the process object for the variable “bEL1004_Ch4” of type BOOL can be selected from the PLC configuration tree:
Selecting PDO of type BOOL
According to the default setting, certain PDO objects are now available for selection. In this sample the input of channel 4 of the EL1004 terminal is selected for linking. In contrast, the checkbox "All types" must be ticked for creating the link for the output variables, in order to allocate a set of eight separate output bits to a byte variable. The following diagram shows the whole process:
Selecting several PDOs simultaneously: activate "Continuous" and "All types"
Note that the "Continuous" checkbox was also activated. This is designed to allocate the bits contained in the byte of the variable "nEL2008_value" sequentially to all eight selected output bits of the EL2008 terminal. In this way it is possible to subsequently address all eight outputs of the terminal in the program with a byte corresponding to bit 0 for channel 1 to bit 7 for channel 8 of the PLC. A special symbol ( [image]) at the yellow or red object of the variable indicates that a link exists. The links can also be checked by selecting a "Goto Link Variable” from the context menu of a variable. The object opposite, in this case the PDO, is automatically selected:
Application of a "Goto Link" variable, using "MAIN.bEL1004_Ch4" as a sample
The process of assigning variables to the PDO is completed via the menu selection "Actions" → "Generate Mappings”, key Ctrl+M or by clicking on the symbol [image] in the menu.
This can be visualized in the configuration:
The process of creating links can also take place in the opposite direction, i.e. starting with individual PDOs to variable. However, in this example it would then not be possible to select all output bits for the EL2008, since the terminal only makes individual digital outputs available. If a terminal has a byte, word, integer or similar PDO, it is possible to allocate this a set of bit-standardised variables (type "BOOL"). Here, too, a "Goto Link Variable” from the context menu of a PDO can be executed in the other direction, so that the respective PLC instance can then be selected.
Activation of the configuration
The allocation of PDO to PLC variables has now established the connection from the controller to the inputs and outputs of the terminals. The configuration can now be activated. First, the configuration can be verified via [image] (or via "Actions" → "Check Configuration”). If no error is present, the configuration can be activated via [image] (or via "Actions" → "Activate Configuration…") to transfer the System Manager settings to the runtime system. Confirm the messages "Old configurations are overwritten!" and "Restart TwinCAT system in Run mode" with "OK".
A few seconds later the real-time status [image] is displayed at the bottom right in the System Manager. The PLC system can then be started as described below.
Starting the controller
Starting from a remote system, the PLC control has to be linked with the Embedded PC over Ethernet via "Online" → “Choose Run-Time System…":
Choose target system (remote)
In this sample "Runtime system 1 (port 801)" is selected and confirmed. Link the PLC with the real-time system via menu option "Online" → "Login", the F11 key or by clicking on the symbol [image]. The control program can then be loaded for execution. This results in the message "No program on the controller! Should the new program be loaded?", which should be acknowledged with "Yes". The runtime environment is ready for the program start:
PLC Control logged in, ready for program startup
The PLC can now be started via "Online" → "Run", F5 key or [image].


TwinCAT 3

Commissioning [image] TwinCAT Quick Start [image] TwinCAT 3
TwinCAT 3
Startup
TwinCAT makes the development environment areas available together with Microsoft Visual Studio: after startup, the project folder explorer appears on the left in the general window area (cf. "TwinCAT System Manager" of TwinCAT 2) for communication with the electromechanical components.
After successful installation of the TwinCAT system on the PC to be used for development, TwinCAT 3 (shell) displays the following user interface after startup:
Initial TwinCAT 3 user interface
First create a new project via [image] (or under "File"→“New"→ "Project…"). In the following dialog make the corresponding entries as required (as shown in the diagram):
Create new TwinCAT project
The new project is then available in the project folder explorer:
New TwinCAT3 project in the project folder explorer
Generally, TwinCAT can be used in local or remote mode. Once the TwinCAT system including the user interface (standard) is installed on the respective PLC, TwinCAT can be used in local mode and thereby the next step is "Insert Device".
If the intention is to address the TwinCAT runtime environment installed on a PLC as development environment remotely from another system, the target system must be made known first. Via the symbol in the menu bar:
expand the pull-down menu:
and open the following window:
Selection dialog: Choose the target system
Use "Search (Ethernet)..." to enter the target system. Thus a next dialog opens to either:
▪
enter the known computer name after "Enter Host Name / IP:" (as shown in red)
▪
perform a "Broadcast Search" (if the exact computer name is not known)
▪
enter the known computer IP or AmsNetID.
Specify the PLC for access by the TwinCAT System Manager: selection of the target system
Once the target system has been entered, it is available for selection as follows (a password may have to be entered):
After confirmation with "OK" the target system can be accessed via the Visual Studio shell.
Adding devices
In the project folder explorer of the Visual Studio shell user interface on the left, select "Devices" within element “I/O”, then right-click to open a context menu and select "Scan" or start the action via [image] in the menu bar. The TwinCAT System Manager may first have to be set to "Config mode" via [image] or via the menu "TwinCAT" → "Restart TwinCAT (Config mode)".
Select "Scan"
Confirm the warning message, which follows, and select "EtherCAT" in the dialog:
Automatic detection of I/O devices: selection the devices to be integrated
Confirm the message "Find new boxes", in order to determine the terminals connected to the devices. "Free Run" enables manipulation of input and output values in "Config mode" and should also be acknowledged.
Based on the sample configuration described at the beginning of this section, the result is as follows:
Mapping of the configuration in VS shell of the TwinCAT3 environment
The whole process consists of two stages, which may be performed separately (first determine the devices, then determine the connected elements such as boxes, terminals, etc.). A scan can also be initiated by selecting "Device ..." from the context menu, which then reads the elements present in the configuration below:
Reading of individual terminals connected to a device
This functionality is useful if the actual configuration is modified at short notice.
Programming the PLC
TwinCAT PLC Control is the development environment for the creation of the controller in different program environments: TwinCAT PLC Control supports all languages described in IEC 61131-3. There are two text-based languages and three graphical languages.
▪
Text-based languages
–
Instruction List (IL)
–
Structured Text (ST)
▪
Graphical languages
–
Function Block Diagram (FBD)
–
Ladder Diagram (LD)
–
The Continuous Function Chart Editor (CFC)
–
Sequential Function Chart (SFC)
The following section refers to Structured Text (ST).
In order to create a programming environment, a PLC subproject is added to the project sample via the context menu of "PLC" in the project folder explorer by selecting "Add New Item….":
Adding the programming environment in "PLC"
In the dialog that opens select "Standard PLC project" and enter "PLC_example" as project name, for example, and select a corresponding directory:
Specifying the name and directory for the PLC programming environment
The "Main" program, which already exists by selecting "Standard PLC project", can be opened by double-clicking on "PLC_example_project" in "POUs”. The following user interface is shown for an initial project:
Initial "Main" program of the standard PLC project
To continue, sample variables and a sample program have now been created:
Sample program with variables after a compile process (without variable integration)
The control program is now created as a project folder, followed by the compile process:
Start program compilation
The following variables, identified in the ST/ PLC program with "AT%", are then available in under "Assignments" in the project folder explorer:
Assigning variables
Via the menu of an instance - variables in the "PLC” context, use the "Modify Link…" option to open a window for selecting a suitable process object (PDO) for linking:
Creating the links between PLC variables and process objects
In the window that opens, the process object for the variable "bEL1004_Ch4" of type BOOL can be selected from the PLC configuration tree:
Selecting PDO of type BOOL
According to the default setting, certain PDO objects are now available for selection. In this sample the input of channel 4 of the EL1004 terminal is selected for linking. In contrast, the checkbox "All types" must be ticked for creating the link for the output variables, in order to allocate a set of eight separate output bits to a byte variable. The following diagram shows the whole process:
Selecting several PDOs simultaneously: activate "Continuous" and "All types"
Note that the "Continuous" checkbox was also activated. This is designed to allocate the bits contained in the byte of the variable "nEL2008_value" sequentially to all eight selected output bits of the EL2008 terminal. In this way it is possible to subsequently address all eight outputs of the terminal in the program with a byte corresponding to bit 0 for channel 1 to bit 7 for channel 8 of the PLC. A special symbol ( [image]) at the yellow or red object of the variable indicates that a link exists. The links can also be checked by selecting a "Goto Link Variable” from the context menu of a variable. The object opposite, in this case the PDO, is automatically selected:
Application of a "Goto Link" variable, using "MAIN.bEL1004_Ch4" as a sample
The process of creating links can also take place in the opposite direction, i.e. starting with individual PDOs to variable. However, in this example it would then not be possible to select all output bits for the EL2008, since the terminal only makes individual digital outputs available. If a terminal has a byte, word, integer or similar PDO, it is possible to allocate this a set of bit-standardised variables (type "BOOL"). Here, too, a "Goto Link Variable” from the context menu of a PDO can be executed in the other direction, so that the respective PLC instance can then be selected.
Note on the type of variable assignment
The following type of variable assignment can only be used from TwinCAT version V3.1.4024.4 onwards and is only available for terminals with a microcontroller.
In TwinCAT it is possible to create a structure from the mapped process data of a terminal. An instance of this structure can then be created in the PLC, so it is possible to access the process data directly from the PLC without having to declare own variables.
The procedure for the EL3001 1-channel analog input terminal -10...+10 V is shown as an example.
1.
First the required process data must be selected in the "Process data" tab in TwinCAT.
2.
After that, the PLC data type must be generated in the tab "PLC" via the check box.
3.
The data type in the "Data Type" field can then be copied using the "Copy" button.
Creating a PLC data type
4.
An instance of the data structure of the copied data type must then be created in the PLC.
Instance_of_struct
5.
Then the project folder must be created. This can be done either via the key combination "CTRL + Shift + B" or via the "Build" tab in TwinCAT.
6.
The structure in the "PLC" tab of the terminal must then be linked to the created instance.
Linking the structure
7.
In the PLC the process data can then be read or written via the structure in the program code.
Reading a variable from the structure of the process data
Activation of the configuration
The allocation of PDO to PLC variables has now established the connection from the controller to the inputs and outputs of the terminals. The configuration can now be activated with [image] or via the menu under "TwinCAT" in order to transfer settings of the development environment to the runtime system. Confirm the messages "Old configurations are overwritten!" and "Restart TwinCAT system in Run mode" with "OK". The corresponding assignments can be seen in the project folder explorer:
A few seconds later the corresponding status of the Run mode is displayed in the form of a rotating symbol [image] at the bottom right of the VS shell development environment. The PLC system can then be started as described below.
Starting the controller
Select the menu option "PLC" → "Login" or click on [image] to link the PLC with the real-time system and load the control program for execution. This results in the message "No program on the controller! Should the new program be loaded?", which should be acknowledged with "Yes". The runtime environment is ready for program start by click on symbol [image], the "F5" key or via "PLC" in the menu selecting “Start”. The started programming environment shows the runtime values of individual variables:
TwinCAT development environment (VS shell): logged-in, after program startup
The two operator control elements for stopping [image] and logout [image] result in the required action (accordingly also for stop "Shift + F5", or both actions can be selected via the PLC menu).


TwinCAT Development Environment

Commissioning [image] TwinCAT Development Environment
TwinCAT Development Environment
The Software for automation TwinCAT (The Windows Control and Automation Technology) will be distinguished into:
▪
TwinCAT 2: System Manager (Configuration) & PLC Control (Programming)
▪
TwinCAT 3: Enhancement of TwinCAT 2 (Programming and Configuration takes place via a common Development Environment)
Details:
▪
TwinCAT 2:
–
Connects I/O devices to tasks in a variable-oriented manner
–
Connects tasks to tasks in a variable-oriented manner
–
Supports units at the bit level
–
Supports synchronous or asynchronous relationships
–
Exchange of consistent data areas and process images
–
Datalink on NT - Programs by open Microsoft Standards (OLE, OCX, ActiveX, DCOM+, etc.)
–
Integration of IEC 61131-3-Software-SPS, Software- NC and Software-CNC within Windows NT/2000/XP/Vista, Windows 7, NT/XP Embedded, CE
–
Interconnection to all common fieldbusses
–
More…
Additional features:
▪
TwinCAT 3 (eXtended Automation):
–
Visual-Studio®-Integration
–
Choice of the programming language
–
Supports object orientated extension of IEC 61131-3
–
Usage of C/C++ as programming language for real time applications
–
Connection to MATLAB®/Simulink®
–
Open interface for expandability
–
Flexible run-time environment
–
Active support of Multi-Core- und 64-Bit-Operatingsystem
–
Automatic code generation and project creation with the TwinCAT Automation Interface
–
More…
Within the following sections commissioning of the TwinCAT Development Environment on a PC System for the control and also the basically functions of unique control elements will be explained.
Please see further information to TwinCAT 2 and TwinCAT 3 at http://infosys.beckhoff.com.
Additional information
•
Installation of the TwinCAT real-time driver
•
Notes regarding ESI device description
•
TwinCAT ESI Updater
•
Distinction between Online and Offline
•
OFFLINE configuration creation
•
ONLINE configuration creation
•
EtherCAT subscriber configuration


Installation of the TwinCAT real-time driver

Commissioning [image] TwinCAT Development Environment [image] Installation of the TwinCAT real-time driver
Installation of the TwinCAT real-time driver
In order to assign real-time capability to a standard Ethernet port of an IPC controller, the Beckhoff real-time driver has to be installed on this port under Windows.
This can be done in several ways. One option is described here.
In the System Manager call up the TwinCAT overview of the local network interfaces via Options → Show Real Time Ethernet Compatible Devices.
System Manager “Options” (TwinCAT 2)
This have to be called up by the Menü “TwinCAT” within the TwinCAT 3 environment:
Call up under VS Shell (TwinCAT 3)
The following dialog appears:
Overview of network interfaces
Interfaces listed under “Compatible devices” can be assigned a driver via the “Install” button. A driver should only be installed on compatible devices.
A Windows warning regarding the unsigned driver can be ignored.
Alternatively an EtherCAT-device can be inserted first of all as described in chapter Offline configuration creation, section “Creating the EtherCAT device” in order to view the compatible ethernet ports via its EtherCAT properties (tab „Adapter“, button „Compatible Devices…“):
EtherCAT device properties(TwinCAT 2): click on „Compatible Devices…“ of tab “Adapter”
TwinCAT 3: the properties of the EtherCAT device can be opened by double click on “Device .. (EtherCAT)” within the Solution Explorer under “I/O”:
After the installation the driver appears activated in the Windows overview for the network interface (Windows Start → System Properties → Network)
Windows properties of the network interface
A correct setting of the driver could be:
Exemplary correct driver setting for the Ethernet port
Other possible settings have to be avoided:
Incorrect driver settings for the Ethernet port
IP address of the port used
IP address/DHCP
In most cases an Ethernet port that is configured as an EtherCAT device will not transport general IP packets. For this reason and in cases where an EL6601 or similar devices are used it is useful to specify a fixed IP address for this port via the “Internet Protocol TCP/IP” driver setting and to disable DHCP. In this way the delay associated with the DHCP client for the Ethernet port assigning itself a default IP address in the absence of a DHCP server is avoided. A suitable address space is 192.168.x.x, for example.
TCP/IP setting for the Ethernet port


Notes regarding ESI device description

Commissioning [image] TwinCAT Development Environment [image] Notes regarding ESI device description
Notes regarding ESI device description
Installation of the latest ESI device description
The TwinCAT EtherCAT master/System Manager needs the device description files for the devices to be used in order to generate the configuration in online or offline mode. The device descriptions are contained in the so-called ESI files (EtherCAT Slave Information) in XML format. These files can be requested from the respective manufacturer and are made available for download. An *.xml file may contain several device descriptions.
The ESI files for Beckhoff EtherCAT devices are available on the Beckhoff website.
The ESI files should be stored in the TwinCAT installation directory.
Default settings:
▪
TwinCAT 2: C:\TwinCAT\IO\EtherCAT
▪
TwinCAT 3: C:\TwinCAT\3.1\Config\Io\EtherCAT
The files are read (once) when a new System Manager window is opened, if they have changed since the last time the System Manager window was opened.
A TwinCAT installation includes the set of Beckhoff ESI files that was current at the time when the TwinCAT build was created.
For TwinCAT 2.11/TwinCAT 3 and higher, the ESI directory can be updated from the System Manager, if the programming PC is connected to the Internet; by
▪
TwinCAT 2: Option → “Update EtherCAT Device Descriptions”
▪
TwinCAT 3: TwinCAT → EtherCAT Devices → “Update Device Descriptions (via ETG Website)…”
The TwinCAT ESI Updater is available for this purpose.
ESI
The *.xml files are associated with *.xsd files, which describe the structure of the ESI XML files. To update the ESI device descriptions, both file types should therefore be updated.
Device differentiation
EtherCAT devices/slaves are distinguished by four properties, which determine the full device identifier. For example, the device identifier EL2521-0025-1018 consists of:
▪
family key “EL”
▪
name “2521”
▪
type “0025”
▪
and revision “1018”
Identifier structure
The order identifier consisting of name + type (here: EL2521-0010) describes the device function. The revision indicates the technical progress and is managed by Beckhoff. In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation. Each revision has its own ESI description. See further notes.
Online description
If the EtherCAT configuration is created online through scanning of real devices (see section Online setup) and no ESI descriptions are available for a slave (specified by name and revision) that was found, the System Manager asks whether the description stored in the device should be used. In any case, the System Manager needs this information for setting up the cyclic and acyclic communication with the slave correctly.
OnlineDescription information window (TwinCAT 2)
In TwinCAT 3 a similar window appears, which also offers the Web update:
Information window OnlineDescription (TwinCAT 3)
If possible, the Yes is to be rejected and the required ESI is to be requested from the device manufacturer. After installation of the XML/XSD file the configuration process should be repeated.
Note
Changing the ‘usual’ configuration through a scan
✓
If a scan discovers a device that is not yet known to TwinCAT, distinction has to be made between two cases. Taking the example here of the EL2521-0000 in the revision 1019
1.
no ESI is present for the EL2521-0000 device at all, either for the revision 1019 or for an older revision. The ESI must then be requested from the manufacturer (in this case Beckhoff).
2.
an ESI is present for the EL2521-0000 device, but only in an older revision, e.g. 1018 or 1017.
In this case an in-house check should first be performed to determine whether the spare parts stock allows the integration of the increased revision into the configuration at all. A new/higher revision usually also brings along new features. If these are not to be used, work can continue without reservations with the previous revision 1018 in the configuration. This is also stated by the Beckhoff compatibility rule.
Refer in particular to the chapter ‘General notes on the use of Beckhoff EtherCAT IO components’ and for manual configuration to the chapter ‘Offline configuration creation’.
If the OnlineDescription is used regardless, the System Manager reads a copy of the device description from the EEPROM in the EtherCAT slave. In complex slaves the size of the EEPROM may not be sufficient for the complete ESI, in which case the ESI would be incomplete in the configurator. Therefore it’s recommended using an offline ESI file with priority in such a case.
The System Manager creates for online recorded device descriptions a new file “OnlineDescription0000...xml” in its ESI directory, which contains all ESI descriptions that were read online.
File OnlineDescription.xml created by the System Manager
Is a slave desired to be added manually to the configuration at a later stage, online created slaves are indicated by a prepended symbol “>” in the selection list (see Figure “Indication of an online recorded ESI of EL2521 as an example”).
Indication of an online recorded ESI of EL2521 as an example
If such ESI files are used and the manufacturer's files become available later, the file OnlineDescription.xml should be deleted as follows:
▪
close all System Manager windows
▪
restart TwinCAT in Config mode
▪
delete "OnlineDescription0000...xml"
▪
restart TwinCAT System Manager
This file should not be visible after this procedure, if necessary press <F5> to update
OnlineDescription for TwinCAT 3.x
In addition to the file described above "OnlineDescription0000...xml" , a so called EtherCAT cache with new discovered devices is created by TwinCAT 3.x, e.g. under Windows 7:

(Please note the language settings of the OS!)
You have to delete this file, too.
Faulty ESI file
If an ESI file is faulty and the System Manager is unable to read it, the System Manager brings up an information window.
Information window for faulty ESI file (left: TwinCAT 2; right: TwinCAT 3)
Reasons may include:
▪
Structure of the *.xml does not correspond to the associated *.xsd file → check your schematics
▪
Contents cannot be translated into a device description → contact the file manufacturer


TwinCAT ESI Updater

Commissioning [image] TwinCAT Development Environment [image] TwinCAT ESI Updater
TwinCAT ESI Updater
For TwinCAT 2.11 and higher, the System Manager can search for current Beckhoff ESI files automatically, if an online connection is available:
Using the ESI Updater (>= TwinCAT 2.11)
The call up takes place under:
“Options” → "Update EtherCAT Device Descriptions"
Selection under TwinCAT 3:
Using the ESI Updater (TwinCAT 3)
The ESI Updater (TwinCAT 3) is a convenient option for automatic downloading of ESI data provided by EtherCAT manufacturers via the Internet into the TwinCAT directory (ESI = EtherCAT slave information). TwinCAT accesses the central ESI ULR directory list stored at ETG; the entries can then be viewed in the Updater dialog, although they cannot be changed there.
The call up takes place under:
“TwinCAT“ → „EtherCAT Devices“ → “Update Device Description (via ETG Website)…“.


Distinction between Online and Offline

Commissioning [image] TwinCAT Development Environment [image] Distinction between Online and Offline
Distinction between Online and Offline
The distinction between online and offline refers to the presence of the actual I/O environment (drives, terminals, EJ-modules). If the configuration is to be prepared in advance of the system configuration as a programming system, e.g. on a laptop, this is only possible in “Offline configuration” mode. In this case all components have to be entered manually in the configuration, e.g. based on the electrical design.
If the designed control system is already connected to the EtherCAT system and all components are energised and the infrastructure is ready for operation, the TwinCAT configuration can simply be generated through “scanning” from the runtime system. This is referred to as online configuration.
In any case, during each startup the EtherCAT master checks whether the slaves it finds match the configuration. This test can be parameterised in the extended slave settings. Refer to note “Installation of the latest ESI-XML device description”.
For preparation of a configuration:
▪
the real EtherCAT hardware (devices, couplers, drives) must be present and installed
▪
the devices/modules must be connected via EtherCAT cables or in the terminal/ module strand in the same way as they are intended to be used later
▪
the devices/modules be connected to the power supply and ready for communication
▪
TwinCAT must be in CONFIG mode on the target system.
The online scan process consists of:
▪
detecting the EtherCAT device (Ethernet port at the IPC)
▪
detecting the connected EtherCAT devices. This step can be carried out independent of the preceding step
▪
troubleshooting
The scan with existing configuration can also be carried out for comparison.


OFFLINE configuration creation

Commissioning [image] TwinCAT Development Environment [image] OFFLINE configuration creation
OFFLINE configuration creation
Creating the EtherCAT device
Create an EtherCAT device in an empty System Manager window.
Append EtherCAT device (left: TwinCAT 2; right: TwinCAT 3)
Select type ‘EtherCAT’ for an EtherCAT I/O application with EtherCAT slaves. For the present publisher/subscriber service in combination with an EL6601/EL6614 terminal select “EtherCAT Automation Protocol via EL6601”.
Selecting the EtherCAT connection (TwinCAT 2.11, TwinCAT 3)
Then assign a real Ethernet port to this virtual device in the runtime system.
Selecting the Ethernet port
This query may appear automatically when the EtherCAT device is created, or the assignment can be set/modified later in the properties dialog; see Fig. “EtherCAT device properties (TwinCAT 2)”.
EtherCAT device properties (TwinCAT 2)
TwinCAT 3: the properties of the EtherCAT device can be opened by double click on “Device .. (EtherCAT)” within the Solution Explorer under “I/O”:
Selecting the Ethernet port
Ethernet ports can only be selected for EtherCAT devices for which the TwinCAT real-time driver is installed. This has to be done separately for each port. Please refer to the respective installation page.
Defining EtherCAT slaves
Further devices can be appended by right-clicking on a device in the configuration tree.
Appending EtherCAT devices (left: TwinCAT 2; right: TwinCAT 3)
The dialog for selecting a new device opens. Only devices for which ESI files are available are displayed.
Only devices are offered for selection that can be appended to the previously selected device. Therefore the physical layer available for this port is also displayed (Fig. “Selection dialog for new EtherCAT device”, A). In the case of cable-based Fast-Ethernet physical layer with PHY transfer, then also only cable-based devices are available, as shown in Fig. “Selection dialog for new EtherCAT device”. If the preceding device has several free ports (e.g. EK1122 or EK1100), the required port can be selected on the right-hand side (A).
Overview of physical layer
▪
“Ethernet”: cable-based 100BASE-TX: EK couplers, EP boxes, devices with RJ45/M8/M12 connector
▪
“E-Bus”: LVDS “terminal bus”, “EJ-module”: EL/ES terminals, various modular modules
The search field facilitates finding specific devices (since TwinCAT 2.11 or TwinCAT 3).
Selection dialog for new EtherCAT device
By default only the name/device type is used as selection criterion. For selecting a specific revision of the device the revision can be displayed as “Extended Information”.
Display of device revision
In many cases several device revisions were created for historic or functional reasons, e.g. through technological advancement. For simplification purposes (see Fig. “Selection dialog for new EtherCAT device”) only the last (i.e. highest) revision and therefore the latest state of production is displayed in the selection dialog for Beckhoff devices. To show all device revisions available in the system as ESI descriptions tick the “Show Hidden Devices” check box, see Fig. “Display of previous revisions”.
Display of previous revisions
Device selection based on revision, compatibility
The ESI description also defines the process image, the communication type between master and slave/device and the device functions, if applicable. The physical device (firmware, if available) has to support the communication queries/settings of the master. This is backward compatible, i.e. newer devices (higher revision) should be supported if the EtherCAT master addresses them as an older revision. The following compatibility rule of thumb is to be assumed for Beckhoff EtherCAT Terminals/ Boxes/ EJ-modules:
device revision in the system >= device revision in the configuration
This also enables subsequent replacement of devices without changing the configuration (different specifications are possible for drives).
Example
If an EL2521-0025-1018 is specified in the configuration, an EL2521-0025-1018 or higher (-1019, -1020) can be used in practice.
Name/revision of the terminal
If current ESI descriptions are available in the TwinCAT system, the last revision offered in the selection dialog matches the Beckhoff state of production. It is recommended to use the last device revision when creating a new configuration, if current Beckhoff devices are used in the real application. Older revisions should only be used if older devices from stock are to be used in the application.
In this case the process image of the device is shown in the configuration tree and can be parameterised as follows: linking with the task, CoE/DC settings, plug-in definition, startup settings, ...
EtherCAT terminal in the TwinCAT tree (left: TwinCAT 2; right: TwinCAT 3)


ONLINE configuration creation

Commissioning [image] TwinCAT Development Environment [image] ONLINE configuration creation
ONLINE configuration creation
Detecting/scanning of the EtherCAT device
The online device search can be used if the TwinCAT system is in CONFIG mode. This can be indicated by a symbol right below in the information bar:
▪
on TwinCAT 2 by a blue display “Config Mode” within the System Manager window: .
▪
on TwinCAT 3 within the user interface of the development environment by a symbol [image].
TwinCAT can be set into this mode:
▪
TwinCAT 2: by selection of [image] in the Menubar or by “Actions” → “Set/Reset TwinCAT to Config Mode…”
▪
TwinCAT 3: by selection of [image] in the Menubar or by „TwinCAT“ → “Restart TwinCAT (Config Mode)“
Online scanning in Config mode
The online search is not available in RUN mode (production operation). Note the differentiation between TwinCAT programming system and TwinCAT target system.
The TwinCAT 2 icon ( [image]) or TwinCAT 3 icon ( [image]) within the Windows-Taskbar always shows the TwinCAT mode of the local IPC. Compared to that, the System Manager window of TwinCAT 2 or the user interface of TwinCAT 3 indicates the state of the target system.
Differentiation local/target system (left: TwinCAT 2; right: TwinCAT 3)
Right-clicking on “I/O Devices” in the configuration tree opens the search dialog.
Scan Devices (left: TwinCAT 2; right: TwinCAT 3)
This scan mode attempts to find not only EtherCAT devices (or Ethernet ports that are usable as such), but also NOVRAM, fieldbus cards, SMB etc. However, not all devices can be found automatically.
Note for automatic device scan (left: TwinCAT 2; right: TwinCAT 3)
Ethernet ports with installed TwinCAT real-time driver are shown as “RT Ethernet” devices. An EtherCAT frame is sent to these ports for testing purposes. If the scan agent detects from the response that an EtherCAT slave is connected, the port is immediately shown as an “EtherCAT Device” .
Detected Ethernet devices
Via respective checkboxes devices can be selected (as illustrated in Fig. “Detected Ethernet devices” e.g. Device 3 and Device 4 were chosen). After confirmation with “OK” a device scan is suggested for all selected devices, see Fig.: “Scan query after automatic creation of an EtherCAT device”.
Selecting the Ethernet port
Ethernet ports can only be selected for EtherCAT devices for which the TwinCAT real-time driver is installed. This has to be done separately for each port. Please refer to the respective installation page.
Detecting/Scanning the EtherCAT devices
Online scan functionality
During a scan the master queries the identity information of the EtherCAT slaves from the slave EEPROM. The name and revision are used for determining the type. The respective devices are located in the stored ESI data and integrated in the configuration tree in the default state defined there.
Example default state
Note
Slave scanning in practice in series machine production
The scanning function should be used with care. It is a practical and fast tool for creating an initial configuration as a basis for commissioning. In series machine production or reproduction of the plant, however, the function should no longer be used for the creation of the configuration, but if necessary for comparison with the defined initial configuration.Background: since Beckhoff occasionally increases the revision version of the delivered products for product maintenance reasons, a configuration can be created by such a scan which (with an identical machine construction) is identical according to the device list; however, the respective device revision may differ from the initial configuration.
Example:
Company A builds the prototype of a machine B, which is to be produced in series later on. To do this the prototype is built, a scan of the IO devices is performed in TwinCAT and the initial configuration ‘B.tsm’ is created. The EL2521-0025 EtherCAT terminal with the revision 1018 is located somewhere. It is thus built into the TwinCAT configuration in this way:
Installing EthetCAT terminal with revision -1018
Likewise, during the prototype test phase, the functions and properties of this terminal are tested by the programmers/commissioning engineers and used if necessary, i.e. addressed from the PLC ‘B.pro’ or the NC. (the same applies correspondingly to the TwinCAT 3 solution files).
The prototype development is now completed and series production of machine B starts, for which Beckhoff continues to supply the EL2521-0025-0018. If the commissioning engineers of the series machine production department always carry out a scan, a B configuration with the identical contents results again for each machine. Likewise, A might create spare parts stores worldwide for the coming series-produced machines with EL2521-0025-1018 terminals.
After some time Beckhoff extends the EL2521-0025 by a new feature C. Therefore the FW is changed, outwardly recognizable by a higher FW version and a new revision -1019. Nevertheless the new device naturally supports functions and interfaces of the predecessor version(s); an adaptation of ‘B.tsm’ or even ‘B.pro’ is therefore unnecessary. The series-produced machines can continue to be built with ‘B.tsm’ and ‘B.pro’; it makes sense to perform a comparative scan against the initial configuration ‘B.tsm’ in order to check the built machine.
However, if the series machine production department now doesn’t use ‘B.tsm’, but instead carries out a scan to create the productive configuration, the revision -1019 is automatically detected and built into the configuration:
Detection of EtherCAT terminal with revision -1019
This is usually not noticed by the commissioning engineers. TwinCAT cannot signal anything either, since virtually a new configuration is created. According to the compatibility rule, however, this means that no EL2521-0025-1018 should be built into this machine as a spare part (even if this nevertheless works in the vast majority of cases).
In addition, it could be the case that, due to the development accompanying production in company A, the new feature C of the EL2521-0025-1019 (for example, an improved analog filter or an additional process data for the diagnosis) is discovered and used without in-house consultation. The previous stock of spare part devices are then no longer to be used for the new configuration ‘B2.tsm’ created in this way.Þ if series machine production is established, the scan should only be performed for informative purposes for comparison with a defined initial configuration. Changes are to be made with care!
If an EtherCAT device was created in the configuration (manually or through a scan), the I/O field can be scanned for devices/slaves.
Scan query after automatic creation of an EtherCAT device (left: TwinCAT 2; right: TwinCAT 3)
Manual triggering of a device scan on a specified EtherCAT device (left: TwinCAT 2; right: TwinCAT 3)
In the System Manager (TwinCAT 2) or the User Interface (TwinCAT 3) the scan process can be monitored via the progress bar at the bottom in the status bar.
Scan progressexemplary by TwinCAT 2
The configuration is established and can then be switched to online state (OPERATIONAL).
Config/FreeRun query (left: TwinCAT 2; right: TwinCAT 3)
In Config/FreeRun mode the System Manager display alternates between blue and red, and the EtherCAT device continues to operate with the idling cycle time of 4 ms (default setting), even without active task (NC, PLC).
Displaying of “Free Run” and “Config Mode” toggling right below in the status bar
TwinCAT can also be switched to this state by using a button (left: TwinCAT 2; right: TwinCAT 3)
The EtherCAT system should then be in a functional cyclic state, as shown in Fig. “Online display example”.
Online display example
Please note:
▪
all slaves should be in OP state
▪
the EtherCAT master should be in “Actual State” OP
▪
“frames/sec” should match the cycle time taking into account the sent number of frames
▪
no excessive “LostFrames” or CRC errors should occur
The configuration is now complete. It can be modified as described under manual procedure.
Troubleshooting
Various effects may occur during scanning.
▪
An unknown device is detected, i.e. an EtherCAT slave for which no ESI XML description is available.
In this case the System Manager offers to read any ESI that may be stored in the device. This case is described in the chapter "Notes regarding ESI device description".
▪
Device are not detected properly
Possible reasons include:
- faulty data links, resulting in data loss during the scan
- slave has invalid device description
The connections and devices should be checked in a targeted manner, e.g. via the emergency scan.
Then re-run the scan.
Faulty identification
In the System Manager such devices may be set up as EK0000 or unknown devices. Operation is not possible or meaningful.
Scan over existing Configuration
Note
Change of the configuration after comparison
With this scan (TwinCAT 2.11 or 3.1) only the device properties vendor (manufacturer), device name and revision are compared at present! A ‘ChangeTo’ or ‘Copy’ should only be carried out with care, taking into consideration the Beckhoff IO compatibility rule (see above). The device configuration is then replaced by the revision found; this can affect the supported process data and functions.
If a scan is initiated for an existing configuration, the actual I/O environment may match the configuration exactly or it may differ. This enables the configuration to be compared.
Identical configuration (left: TwinCAT 2; right: TwinCAT 3)
If differences are detected, they are shown in the correction dialog, so that the user can modify the configuration as required.
Correction dialog
It is advisable to tick the “Extended Information” check box to reveal differences in the revision.
Color
Explanation
green
This EtherCAT slave matches the entry on the other side. Both type and revision match.
blue
This EtherCAT slave is present on the other side, but in a different revision. This other revision can have other default values for the process data as well as other/additional functions.
If the found revision is higher than the configured revision, the slave may be used provided compatibility issues are taken into account.
If the found revision is lower than the configured revision, it is likely that the slave cannot be used. The found device may not support all functions that the master expects based on the higher revision number.
light blue
This EtherCAT slave is ignored (“Ignore” button)
red
▪
This EtherCAT slave is not present on the other side.
▪
It is present, but in a different revision, which also differs in its properties from the one specified.
The compatibility principle then also applies here: if the found revision is higher than the configured revision, use is possible provided compatibility issues are taken into account, since the successor devices should support the functions of the predecessor devices.
If the found revision is lower than the configured revision, it is likely that the slave cannot be used. The found device may not support all functions that the master expects based on the higher revision number.
Device selection based on revision, compatibility
The ESI description also defines the process image, the communication type between master and slave/device and the device functions, if applicable. The physical device (firmware, if available) has to support the communication queries/settings of the master. This is backward compatible, i.e. newer devices (higher revision) should be supported if the EtherCAT master addresses them as an older revision. The following compatibility rule of thumb is to be assumed for Beckhoff EtherCAT Terminals/ Boxes/ EJ-modules:
device revision in the system >= device revision in the configuration
This also enables subsequent replacement of devices without changing the configuration (different specifications are possible for drives).
Example
If an EL2521-0025-1018 is specified in the configuration, an EL2521-0025-1018 or higher (-1019, -1020) can be used in practice.
Name/revision of the terminal
If current ESI descriptions are available in the TwinCAT system, the last revision offered in the selection dialog matches the Beckhoff state of production. It is recommended to use the last device revision when creating a new configuration, if current Beckhoff devices are used in the real application. Older revisions should only be used if older devices from stock are to be used in the application.
In this case the process image of the device is shown in the configuration tree and can be parameterised as follows: linking with the task, CoE/DC settings, plug-in definition, startup settings, ...
Correction dialog with modifications
Once all modifications have been saved or accepted, click “OK” to transfer them to the real *.tsm configuration.
Change to Compatible Type
TwinCAT offers a function “Change to Compatible Type…” for the exchange of a device whilst retaining the links in the task.
Dialog “Change to Compatible Type…” (left: TwinCAT 2; right: TwinCAT 3)
This function is preferably to be used on AX5000 devices.
Change to Alternative Type
The TwinCAT System Manager offers a function for the exchange of a device: Change to Alternative Type
TwinCAT 2 Dialog Change to Alternative Type
If called, the System Manager searches in the procured device ESI (in this example: EL1202-0000) for details of compatible devices contained there. The configuration is changed and the ESI-EEPROM is overwritten at the same time – therefore this process is possible only in the online state (ConfigMode).


EtherCAT subscriber configuration

Commissioning [image] TwinCAT Development Environment [image] EtherCAT subscriber configuration
EtherCAT subscriber configuration
In the left-hand window of the TwinCAT 2 System Manager or the Solution Explorer of the TwinCAT 3 Development Environment respectively, click on the element of the terminal within the tree you wish to configure (in the example: EL3751 Terminal 3).
Branch element as terminal EL3751
In the right-hand window of the TwinCAT System manager (TwinCAT 2) or the Development Environment (TwinCAT 3), various tabs are now available for configuring the terminal. And yet the dimension of complexity of a subscriber determines which tabs are provided. Thus as illustrated in the example above the terminal EL3751 provides many setup options and also a respective number of tabs are available. On the contrary by the terminal EL1004 for example the tabs "General", "EtherCAT", "Process Data" and “Online“ are available only. Several terminals, as for instance the EL6695 provide special functions by a tab with its own terminal name, so “EL6695” in this case. A specific tab “Settings” by terminals with a wide range of setup options will be provided also (e.g. EL3751).
„General“ tab
“General” tab
Name | Name of the EtherCAT device
Id | Number of the EtherCAT device
Type | EtherCAT device type
Comment | Here you can add a comment (e.g. regarding the system).
Disabled | Here you can deactivate the EtherCAT device.
Create symbols | Access to this EtherCAT slave via ADS is only available if this control box is activated.
„EtherCAT“ tab
„EtherCAT“ tab
Type | EtherCAT device type
Product/Revision | Product and revision number of the EtherCAT device
Auto Inc Addr. | Auto increment address of the EtherCAT device. The auto increment address can be used for addressing each EtherCAT device in the communication ring through its physical position. Auto increment addressing is used during the start-up phase when the EtherCAT master allocates addresses to the EtherCAT devices. With auto increment addressing the first EtherCAT slave in the ring has the address 0000hex. For each further slave the address is decremented by 1 (FFFFhex, FFFEhex etc.).
EtherCAT Addr. | Fixed address of an EtherCAT slave. This address is allocated by the EtherCAT master during the start-up phase. Tick the control box to the left of the input field in order to modify the default value.
Previous Port | Name and port of the EtherCAT device to which this device is connected. If it is possible to connect this device with another one without changing the order of the EtherCAT devices in the communication ring, then this combination field is activated and the EtherCAT device to which this device is to be connected can be selected.
Advanced Settings | This button opens the dialogs for advanced settings.
The link at the bottom of the tab points to the product page for this EtherCAT device on the web.
“Process Data” tab
Indicates the configuration of the process data. The input and output data of the EtherCAT slave are represented as CANopen process data objects (Process Data Objects, PDOs). The user can select a PDO via PDO assignment and modify the content of the individual PDO via this dialog, if the EtherCAT slave supports this function.
“Process Data” tab
The process data (PDOs) transferred by an EtherCAT slave during each cycle are user data which the application expects to be updated cyclically or which are sent to the slave. To this end the EtherCAT master (Beckhoff TwinCAT) parameterizes each EtherCAT slave during the start-up phase to define which process data (size in bits/bytes, source location, transmission type) it wants to transfer to or from this slave. Incorrect configuration can prevent successful start-up of the slave.
For Beckhoff EtherCAT EL, ES, EM, EJ and EP slaves the following applies in general:
▪
The input/output process data supported by the device are defined by the manufacturer in the ESI/XML description. The TwinCAT EtherCAT Master uses the ESI description to configure the slave correctly.
▪
The process data can be modified in the system manager. See the device documentation.
Examples of modifications include: mask out a channel, displaying additional cyclic information, 16-bit display instead of 8-bit data size, etc.
▪
In so-called “intelligent” EtherCAT devices the process data information is also stored in the CoE directory. Any changes in the CoE directory that lead to different PDO settings prevent successful startup of the slave. It is not advisable to deviate from the designated process data, because the device firmware (if available) is adapted to these PDO combinations.
If the device documentation allows modification of process data, proceed as follows (see Figure “Configuring the process data”).
▪
A: select the device to configure
▪
B: in the “Process Data” tab select Input or Output under SyncManager (C)
▪
D: the PDOs can be selected or deselected
▪
H: the new process data are visible as linkable variables in the system manager
The new process data are active once the configuration has been activated and TwinCAT has been restarted (or the EtherCAT master has been restarted)
▪
E: if a slave supports this, Input and Output PDO can be modified simultaneously by selecting a so-called PDO record (“predefined PDO settings”).
Configuring the process data
Manual modification of the process data
According to the ESI description, a PDO can be identified as “fixed” with the flag “F” in the PDO overview (Fig. “Configuring the process data”, J). The configuration of such PDOs cannot be changed, even if TwinCAT offers the associated dialog (“Edit”). In particular, CoE content cannot be displayed as cyclic process data. This generally also applies in cases where a device supports download of the PDO configuration, “G”. In case of incorrect configuration the EtherCAT slave usually refuses to start and change to OP state. The System Manager displays an “invalid SM cfg” logger message: This error message (“invalid SM IN cfg” or “invalid SM OUT cfg”) also indicates the reason for the failed start.
A detailed description can be found at the end of this section.
„Startup“ tab
The Startup tab is displayed if the EtherCAT slave has a mailbox and supports the CANopen over EtherCAT (CoE) or Servo drive over EtherCAT protocol. This tab indicates which download requests are sent to the mailbox during startup. It is also possible to add new mailbox requests to the list display. The download requests are sent to the slave in the same order as they are shown in the list.
„Startup“ tab
Column
Description
Transition
Transition to which the request is sent. This can either be
▪
the transition from pre-operational to safe-operational (PS), or
▪
the transition from safe-operational to operational (SO).
If the transition is enclosed in "<>" (e.g. <PS>), the mailbox request is fixed and cannot be modified or deleted by the user.
Protocol
Type of mailbox protocol
Index
Index of the object
Data
Date on which this object is to be downloaded.
Comment
Description of the request to be sent to the mailbox
Move Up | This button moves the selected request up by one position in the list.
Move Down | This button moves the selected request down by one position in the list.
New | This button adds a new mailbox download request to be sent during startup.
Delete | This button deletes the selected entry.
Edit | This button edits an existing request.
“CoE – Online” tab
The additional CoE - Online tab is displayed if the EtherCAT slave supports the CANopen over EtherCAT (CoE) protocol. This dialog lists the content of the object list of the slave (SDO upload) and enables the user to modify the content of an object from this list. Details for the objects of the individual EtherCAT devices can be found in the device-specific object descriptions.
“CoE – Online” tab
Object list display
Column | Description
Index | Index and sub-index of the object
Name | Name of the object
Flags | RW | The object can be read, and data can be written to the object (read/write)
 | RO | The object can be read, but no data can be written to the object (read only)
 | P | An additional P identifies the object as a process data object.
Value | Value of the object
Update List | The Update list button updates all objects in the displayed list
Auto Update | If this check box is selected, the content of the objects is updated automatically.
Advanced | The Advanced button opens the Advanced Settings dialog. Here you can specify which objects are displayed in the list.
Dialog “Advanced settings”
Online - via SDO Information | If this option button is selected, the list of the objects included in the object list of the slave is uploaded from the slave via SDO information. The list below can be used to specify which object types are to be uploaded.
Offline - via EDS File | If this option button is selected, the list of the objects included in the object list is read from an EDS file provided by the user.
„Online“ tab
„Online“ tab
State Machine
Init | This button attempts to set the EtherCAT device to the Init state.
Pre-Op | This button attempts to set the EtherCAT device to the pre-operational state.
Op | This button attempts to set the EtherCAT device to the operational state.
Bootstrap | This button attempts to set the EtherCAT device to the Bootstrap state.
Safe-Op | This button attempts to set the EtherCAT device to the safe-operational state.
Clear Error | This button attempts to delete the fault display. If an EtherCAT slave fails during change of state it sets an error flag. Example: An EtherCAT slave is in PREOP state (pre-operational). The master now requests the SAFEOP state (safe-operational). If the slave fails during change of state it sets the error flag. The current state is now displayed as ERR PREOP. When the Clear Error button is pressed the error flag is cleared, and the current state is displayed as PREOP again.
Current State | Indicates the current state of the EtherCAT device.
Requested State | Indicates the state requested for the EtherCAT device.
DLL Status
Indicates the DLL status (data link layer status) of the individual ports of the EtherCAT slave. The DLL status can have four different states:
Status | Description
No Carrier / Open | No carrier signal is available at the port, but the port is open.
No Carrier / Closed | No carrier signal is available at the port, and the port is closed.
Carrier / Open | A carrier signal is available at the port, and the port is open.
Carrier / Closed | A carrier signal is available at the port, but the port is closed.
File Access over EtherCAT
Download | With this button a file can be written to the EtherCAT device.
Upload | With this button a file can be read from the EtherCAT device.
"DC" tab (Distributed Clocks)
"DC" tab (Distributed Clocks)
Operation Mode
Options (optional):
▪
FreeRun
▪
SM-Synchron
▪
DC-Synchron (Input based)
▪
DC-Synchron
Advanced Settings…
Advanced settings for readjustment of the real time determinant TwinCAT-clock
Detailed information to Distributed Clocks are specified on http://infosys.beckhoff.com:
Fieldbus Components → EtherCAT Terminals → EtherCAT System documentation → EtherCAT basics → Distributed Clocks
Additional information
•
Detailed description of Process Data tab


Detailed description of Process Data tab

Commissioning [image] TwinCAT Development Environment [image] EtherCAT subscriber configuration [image] Detailed description of Process Data tab
Detailed description of Process Data tab
Sync Manager
Lists the configuration of the Sync Manager (SM).
If the EtherCAT device has a mailbox, SM0 is used for the mailbox output (MbxOut) and SM1 for the mailbox input (MbxIn).
SM2 is used for the output process data (outputs) and SM3 (inputs) for the input process data.
If an input is selected, the corresponding PDO assignment is displayed in the PDO Assignment list below.
PDO Assignment
PDO assignment of the selected Sync Manager. All PDOs defined for this Sync Manager type are listed here:
▪
If the output Sync Manager (outputs) is selected in the Sync Manager list, all RxPDOs are displayed.
▪
If the input Sync Manager (inputs) is selected in the Sync Manager list, all TxPDOs are displayed.
The selected entries are the PDOs involved in the process data transfer. In the tree diagram of the System Manager these PDOs are displayed as variables of the EtherCAT device. The name of the variable is identical to the Name parameter of the PDO, as displayed in the PDO list. If an entry in the PDO assignment list is deactivated (not selected and greyed out), this indicates that the input is excluded from the PDO assignment. In order to be able to select a greyed out PDO, the currently selected PDO has to be deselected first.
Activation of PDO assignment
✓
If you have changed the PDO assignment, in order to activate the new PDO assignment,
1.
the EtherCAT slave has to run through the PS status transition cycle (from pre-operational to safe-operational) once (see Online tab),
2.
and the System Manager has to reload the EtherCAT slaves
( [image] button for TwinCAT 2 or [image] button for TwinCAT 3)
PDO list
List of all PDOs supported by this EtherCAT device. The content of the selected PDOs is displayed in the PDO Content list. The PDO configuration can be modified by double-clicking on an entry.
Column | Description
Index | PDO index.
Size | Size of the PDO in bytes.
Name | Name of the PDO. If this PDO is assigned to a Sync Manager, it appears as a variable of the slave with this parameter as the name.
Flags | F | Fixed content: The content of this PDO is fixed and cannot be changed by the System Manager.
 | M | Mandatory PDO. This PDO is mandatory and must therefore be assigned to a Sync Manager! Consequently, this PDO cannot be deleted from the PDO Assignment list
SM | Sync Manager to which this PDO is assigned. If this entry is empty, this PDO does not take part in the process data traffic.
SU | Sync unit to which this PDO is assigned.
PDO Content
Indicates the content of the PDO. If flag F (fixed content) of the PDO is not set the content can be modified.
Download
If the device is intelligent and has a mailbox, the configuration of the PDO and the PDO assignments can be downloaded to the device. This is an optional feature that is not supported by all EtherCAT slaves.
PDO Assignment
If this check box is selected, the PDO assignment that is configured in the PDO Assignment list is downloaded to the device on startup. The required commands to be sent to the device can be viewed in the Startup tab.
PDO Configuration
If this check box is selected, the configuration of the respective PDOs (as shown in the PDO list and the PDO Content display) is downloaded to the EtherCAT slave.


General Notes - EtherCAT Slave Application

Commissioning [image] General Notes - EtherCAT Slave Application
General Notes - EtherCAT Slave Application
This summary briefly deals with a number of aspects of EtherCAT Slave operation under TwinCAT. More detailed information on this may be found in the corresponding sections of, for instance, the EtherCAT System Documentation.
Diagnosis in real time: WorkingCounter, EtherCAT State and Status
Generally speaking an EtherCAT Slave provides a variety of diagnostic information that can be used by the controlling task.
This diagnostic information relates to differing levels of communication. It therefore has a variety of sources, and is also updated at various times.
Any application that relies on I/O data from a fieldbus being correct and up to date must make diagnostic access to the corresponding underlying layers. EtherCAT and the TwinCAT System Manager offer comprehensive diagnostic elements of this kind. Those diagnostic elements that are helpful to the controlling task for diagnosis that is accurate for the current cycle when in operation (not during commissioning) are discussed below.
Selection of the diagnostic information of an EtherCAT Slave
In general, an EtherCAT Slave offers
▪
communication diagnosis typical for a slave (diagnosis of successful participation in the exchange of process data, and correct operating mode)
This diagnosis is the same for all slaves.

as well as
▪
function diagnosis typical for a channel (device-dependent)
See the corresponding device documentation
The colors in Fig. “Selection of the diagnostic information of an EtherCAT Slave” also correspond to the variable colors in the System Manager, see Fig. “Basic EtherCAT Slave Diagnosis in the PLC”.
Colour | Meaning
yellow | Input variables from the Slave to the EtherCAT Master, updated in every cycle
red | Output variables from the Slave to the EtherCAT Master, updated in every cycle
green | Information variables for the EtherCAT Master that are updated acyclically. This means that it is possible that in any particular cycle they do not represent the latest possible status. It is therefore useful to read such variables through ADS.
Fig. “Basic EtherCAT Slave Diagnosis in the PLC” shows an example of an implementation of basic EtherCAT Slave Diagnosis. A Beckhoff EL3102 (2-channel analogue input terminal) is used here, as it offers both the communication diagnosis typical of a slave and the functional diagnosis that is specific to a channel. Structures are created as input variables in the PLC, each corresponding to the process image.
Basic EtherCAT Slave Diagnosis in the PLC
The following aspects are covered here:
Code
Function
Implementation
Application/evaluation
A
The EtherCAT Master's diagnostic information
updated acyclically (yellow) or provided acyclically (green).
At least the DevState is to be evaluated for the most recent cycle in the PLC.
The EtherCAT Master's diagnostic information offers many more possibilities than are treated in the EtherCAT System Documentation. A few keywords:
▪
CoE in the Master for communication with/through the Slaves
▪
Functions from TcEtherCAT.lib
▪
Perform an OnlineScan
B
In the example chosen (EL3102) the EL3102 comprises two analogue input channels that transmit a single function status for the most recent cycle.
Status
▪
the bit significations may be found in the device documentation
▪
other devices may supply more information, or none that is typical of a slave
In order for the higher-level PLC task (or corresponding control applications) to be able to rely on correct data, the function status must be evaluated there. Such information is therefore provided with the process data for the most recent cycle.
C
For every EtherCAT Slave that has cyclic process data, the Master displays, using what is known as a WorkingCounter, whether the slave is participating successfully and without error in the cyclic exchange of process data. This important, elementary information is therefore provided for the most recent cycle in the System Manager
1.
at the EtherCAT Slave, and, with identical contents
2.
as a collective variable at the EtherCAT Master (see Point A)
for linking.
WcState (Working Counter)
0: valid real-time communication in the last cycle
1: invalid real-time communication
This may possibly have effects on the process data of other Slaves that are located in the same SyncUnit
In order for the higher-level PLC task (or corresponding control applications) to be able to rely on correct data, the communication status of the EtherCAT Slave must be evaluated there. Such information is therefore provided with the process data for the most recent cycle.
D
Diagnostic information of the EtherCAT Master which, while it is represented at the slave for linking, is actually determined by the Master for the Slave concerned and represented there. This information cannot be characterized as real-time, because it
▪
is only rarely/never changed, except when the system starts up
▪
is itself determined acyclically (e.g. EtherCAT Status)
State
current Status (INIT..OP) of the Slave. The Slave must be in OP (=8) when operating normally.
AdsAddr
The ADS address is useful for communicating from the PLC/task via ADS with the EtherCAT Slave, e.g. for reading/writing to the CoE. The AMS-NetID of a slave corresponds to the AMS-NetID of the EtherCAT Master; communication with the individual Slave is possible via the port (= EtherCAT address).
Information variables for the EtherCAT Master that are updated acyclically. This means that it is possible that in any particular cycle they do not represent the latest possible status. It is therefore possible to read such variables through ADS.
Note
Diagnostic information
It is strongly recommended that the diagnostic information made available is evaluated so that the application can react accordingly.
CoE Parameter Directory
The CoE parameter directory (CanOpen-over-EtherCAT) is used to manage the set values for the slave concerned. Changes may, in some circumstances, have to be made here when commissioning a relatively complex EtherCAT Slave. It can be accessed through the TwinCAT System Manager, see Fig. “EL3102, CoE directory”:
EL3102, CoE directory
EtherCAT System Documentation
The comprehensive description in the EtherCAT System Documentation (EtherCAT Basics --> CoE Interface) must be observed!
A few brief extracts:
▪
Whether changes in the online directory are saved locally in the slave depends on the device. EL terminals (except the EL66xx) are able to save in this way.
▪
The user must manage the changes to the StartUp list.
Commissioning aid in the TwinCAT System Manager
Commissioning interfaces are being introduced as part of an ongoing process for EL/EP EtherCAT devices. These are available in TwinCAT System Managers from TwinCAT 2.11R2 and above. They are integrated into the System Manager through appropriately extended ESI configuration files.
Example of commissioning aid for a EL3204
This commissioning process simultaneously manages
▪
CoE Parameter Directory
▪
DC/FreeRun mode
▪
the available process data records (PDO)
Although the "Process Data", "DC", "Startup" and "CoE-Online" that used to be necessary for this are still displayed, it is recommended that, if the commissioning aid is used, the automatically generated settings are not changed by it.
The commissioning tool does not cover every possible application of an EL/EP device. If the available setting options are not adequate, the user can make the DC, PDO and CoE settings manually, as in the past.
EtherCAT State: automatic default behaviour of the TwinCAT System Manager and manual operation
After the operating power is switched on, an EtherCAT Slave must go through the following statuses
▪
INIT
▪
PREOP
▪
SAFEOP
▪
OP
to ensure sound operation. The EtherCAT Master directs these statuses in accordance with the initialization routines that are defined for commissioning the device by the ES/XML and user settings (Distributed Clocks (DC), PDO, CoE). See also the section on "Principles of Communication, EtherCAT State Machine" in this connection. Depending how much configuration has to be done, and on the overall communication, booting can take up to a few seconds.
The EtherCAT Master itself must go through these routines when starting, until it has reached at least the OP target state.
The target state wanted by the user, and which is brought about automatically at start-up by TwinCAT, can be set in the System Manager. As soon as TwinCAT reaches the status RUN, the TwinCAT EtherCAT Master will approach the target states.
Standard setting
The advanced settings of the EtherCAT Master are set as standard:
▪
EtherCAT Master: OP
▪
Slaves: OP
This setting applies equally to all Slaves.
Default behaviour of the System Manager
In addition, the target state of any particular Slave can be set in the "Advanced Settings" dialogue; the standard setting is again OP.
Default target state in the Slave
Manual Control
There are particular reasons why it may be appropriate to control the states from the application/task/PLC. For instance:
▪
for diagnostic reasons
▪
to induce a controlled restart of axes
▪
because a change in the times involved in starting is desirable
In that case it is appropriate in the PLC application to use the PLC function blocks from the TcEtherCAT.lib, which is available as standard, and to work through the states in a controlled manner using, for instance, FB_EcSetMasterState.
It is then useful to put the settings in the EtherCAT Master to INIT for master and slave.
PLC function blocks
Note regarding E-Bus current
EL/ES terminals are placed on the DIN rail at a coupler on the terminal strand. A Bus Coupler can supply the EL terminals added to it with the E-bus system voltage of 5 V; a coupler is thereby loadable up to 2 A as a rule. Information on how much current each EL terminal requires from the E-bus supply is available online and in the catalogue. If the added terminals require more current than the coupler can supply, then power feed terminals (e.g. EL9410) must be inserted at appropriate places in the terminal strand.
The pre-calculated theoretical maximum E-Bus current is displayed in the TwinCAT System Manager as a column value. A shortfall is marked by a negative total amount and an exclamation mark; a power feed terminal is to be placed before such a position.
Illegally exceeding the E-Bus current
From TwinCAT 2.11 and above, a warning message "E-Bus Power of Terminal..." is output in the logger window when such a configuration is activated:
Warning message for exceeding E-Bus current
Note
Caution! Malfunction possible!
The same ground potential must be used for the E-Bus supply of all EtherCAT terminals in a terminal block!


Integration into the NC configuration

Commissioning [image] Integration into the NC configuration
Integration into the NC configuration
(Master: TwinCAT 2.11)
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Required firmware (FW) version and TwinCAT version
At least the FW version 07 is required for the connection of the EL2522 in the NC;
TwinCAT versions:
- from TC 2.11 R3 Build 2250
- from TC 3.1 Build 4018.16 (recommended)
1.
The terminal must already have been inserted manually under I/O devices or have been scanned in by the system (see section "Inserting the terminal in the EtherCAT Terminal network").
2.
First add a new task.
–
To do this, click with the right mouse button on NC Configuration and
–
select "Append task…" (see fig. Adding a new task).
–
Rename the task if required and confirm with OK.
Adding a new task
3.
Select the operation mode of the terminal in the selection box Predefined PDO Assignment on the register tab Process data.
EL2522 - selection of the operation mode (default)
4.
Adding an NC axis
–
Right-click on Axes, then add a new axis (see Fig. Adding a new axis).
Adding an NC axis
5.
Adding a new axis
–
Name: Change the axis name if necessary
–
Multiple: Enter the number of channels here in case of multi-channel operation. The corresponding number of axes will then be inserted.
–
Type: Select a continuous axis and confirm with OK (see Fig. Selecting and confirming the axis type).
Selecting and confirming the axis type
6.
Linking the non-referenced axes to the terminal
–
Left-click your axis to select it.
–
Under the Settings tab select "Link To..." (see Fig. Linking the axis with the terminal).
–
In the dialog Selection of I/O elements, select the desired terminal (e.g. terminal 3 (EL2522) #Ch.1 and confirm with OK.
Linking the axis with the terminal
7.
In the case of two-channel operation, also link the second axis with channel 2 of the EL2522.
8.
All important links between the NC configuration and the terminal are thus carried out automatically for the selected channels. The links are illustrated in the tree (A) and in the online view (B and C) (see fig. Automatic linking of all main variables).
Automatic linking of all main variables
9.
Target counter value, AutomaticDirection and Target arrival time are not automatically linked under the following conditions. Observe the following chapters here:
–
EL252x - when using the predefined PDO Assignments "n Ch Standard 16 Bit (MDP 253/511)"
–
EL2522 - when using the predefined PDO Assignments "n Ch Standard 32 Bit (MDP 253/511) continuous position w. arrival time"
–
EL2522 - when using older FW or older TwinCAT versions with "Continuous Position" mode
10.
Setting of distributed clock: DC-Synchronous on "DC" tab
Einstellung "DC-Synchron (idh4cjg3.png)
Setting "DC-Synchron
11.
Set the frequency of the terminal in order to achieve the required velocity
–
Channel 1: Index 0x8000:12
–
Channel 2: Index 0x8010:12
Einstellung Base frequency in Index 0x8000:12 (iai27r52.png)
Setting of base frequency in Index 0x8000:12
Additional information
•
EL252x - when using the predefined PDO Assignments "n Ch Standard 16 Bit (MDP 253/511)"
•
EL2522 - when using the predefined PDO Assignments "n Ch Standard 32 Bit (MDP 253/511) continuous position w. arrival time"
•
EL2522 - when using older FW or older TwinCAT versions with "Continuous Position" mode


EL252x - when using the predefined PDO Assignments "n Ch Standard 16 Bit (MDP 253/511)"

Commissioning [image] Integration into the NC configuration [image] EL252x - when using the predefined PDO Assignments "n Ch Standard 16 Bit (MDP 253/511)"
EL252x - when using the predefined PDO Assignments "n Ch Standard 16 Bit (MDP 253/511)"
The links from Axis/Drive/nOutData5 to the "Target Counter Value" of the terminal are not automatically created in the operation modes "n Ch Standard 16 Bit".
Create the link from Axis/Drive/nOutData5 to the "Target Counter Value" of the terminal.
–
To do this, right-click on Target counter value and
–
select "Change link..." (see fig. Change link).
Change Link
–
In the dialog Variable linking, select the variable Axis/Drive/nOutData5 and confirm with OK (see A and B in fig. Creating a link from Axis/Drive/nOutData5 to Target Counter Value).
–
The coverage of 16 bits is confirmed in the subsequent dialog Variable size difference. Confirm with OK (see C in fig. Creating a link from Axis/Drive/nOutData5 to Target Counter Value).
Creating a link from Axis/Drive/nOutData5 to Target Counter Value


EL2522 - when using the predefined PDO Assignments "n Ch Standard 32 Bit (MDP 253/511) continuous position w. arrival time"

Commissioning [image] Integration into the NC configuration [image] EL2522 - when using the predefined PDO Assignments "n Ch Standard 32 Bit (MDP 253/511) continuous position w. arrival time"
EL2522 - when using the predefined PDO Assignments "n Ch Standard 32 Bit (MDP 253/511) continuous position w. arrival time"
Target arrival time will not be automatically linked.
see TC2 Docu


EL2522 - when using older FW or older TwinCAT versions with "Continuous Position" mode

Commissioning [image] Integration into the NC configuration [image] EL2522 - when using older FW or older TwinCAT versions with "Continuous Position" mode
EL2522 - when using older FW or older TwinCAT versions with "Continuous Position" mode
the following must be observed if necessary:
▪
Update of the NC driver
▪
Add axes to the NC
▪
Linking Axis/Drive/nOutData5 to the Target Counter Value of the terminal
a)
b)
Linking Axis/Drive/nOutData5 to the Target Counter Value of the terminal
–
Linking Axis/Drive/nCtrl1 to Automatic Direction of the terminal
a)
Grafik aus Bei Verwendung älterer FW bzw. älterer TwinCAT-Versionen ist bezüglich des _Continues Position_ Modus ggf. folgendes zu beachten_ (iaubjch2.png)
b)
Grafik aus Bei Verwendung älterer FW bzw. älterer TwinCAT-Versionen ist bezüglich des _Continues Position_ Modus ggf. folgendes zu beachten_ (iqr4rqo3.jpg)
c)
Verknüpfung von Axis/Drive/nCtrl1 zu AutomaticDirection der Klemme (ikjhc802.png)
Linking Axis/Drive/nCtrl1 to Automatic Direction of the terminal


EL2521-xxxx

Commissioning [image] EL2521-xxxx
EL2521-xxxx
Additional information
•
Basic function principles
•
Process data
•
Normal operation mode
•
Enhanced operation mode


Basic function principles

Commissioning [image] EL2521-xxxx [image] Basic function principles
Basic function principles
Operating modes of the EL2521
Through the further development of the EL2521 an enhanced operating mode is available (from Firmware 03 / Hardware 02), which can be parameterized in the TwinCAT System Manager, depending on the hardware used.
Older EL2521 terminals do not support this enhanced operating mode.
Version | PDO settings | FW/HW | ESI | Process data | CoE parameters
normal operating mode | Legacy (MDP 252) | up to 02/01 | from EL2521-0000-0000 | Input process data (counter value) in CoE object 0x6000 Output process data (frequency value) in CoE object 0x7000 PDO assignment in 1A00, 1600 | Feature bits and settings in CoE objects 0x8000, 0x8001 and 8800
enhanced operating mode | Standard 16 bit (MDP 253/511) Standard 32 bit (MDP 253/511) | from 03/02 | from EL2521-0000-1016 | Changes to the normal operating mode Distributed clocks support Inputs / outputs in CoE-object 0x6010 / 0x7010 Inputs / outputs in CoE-object 0x6020 / 0x7020 PDO Assignment in 0x1A01, 0x1A02, 0x1A05 or 0x1601, 0x1602, 0x1604, 0x1605, 1607 | Feature bits and settings in CoE object 0x8010
The PDO selection specifies the operating mode in which the EL2521-xxxx is to operate:
Predefined PDO selection in the TwinCAT System Manager
Irrespective of the hardware/firmware version, an EL2521 newly integrated into the system registers itself in the normal operating mode (cf. chapter Process data, delivery state)
During commissioning, a decision must be taken regarding which operating mode the EL2521 should be placed in. This depends on the desired configuration and naturally on the existing hardware version - a terminal with a version earlier than firmware 03 / hardware 02, for example, will not support any configuration in the enhanced operating mode, since the corresponding objects do not exist.
Compatibility in the case of service
An EL2521 employed and projected in enhanced operating mode cannot be replaced by an EL2521 with an older hardware version (<03)!
Process data monitoring
● WcState: if ≠ 0, this EtherCAT device does not take part in the process data traffic
● State: if ≠ 8, the EtherCAT device is not in OP (operational) status
● TxPDO State, SyncError: if ≠ 0, then no valid process data are available, e.g. caused by broken wire
● TxPDO Toggle: If this bit toggles, a new set of process data is available
EL2521 input impedance
The input imedance of the selected destination circuit must not overload the EL2521-0000 due to the potentials in accordance with RS422 can not be reached then.
Delivery state
The delivery state of the EL2521 is the operating mode frequency modulation with a base frequency of 50 kHz and 15 bit resolution.
For testing in the delivery state, PDO setting Standard 16-bit, the output frequency can simply be set to a value >0, then the EL2521-xxxx starts outputting signals.
The number of pulses output is read back into a 16 bit register. The counter overflows with a message to the controller; this is indicated by the status word SW.3 or index 0x6020:05, overflow or SW.2 or index 0x6020:04 (underflow). In parallel to these two bits, SW.6 or index 0x6010:07 is set as a general error bit. This makes the extension to more than 16 bit easier for the controller software to handle. Furthermore, the overflow can be read from the diagnostic object 0xA000:01 (internal 32 bit extension). The counter can be cleared by bit 5 in the control word (CW.5). The counter is cleared in the delivery state with a rising edge (feature bit set in index 0x8000:05); this function is level-controlled if the feature bit in index 0x8000:05 = 0. If the feature bit in index 0x8000:0B = 1, then the counter is set to a value specified in index 0x8800:01 by bit 5 in the control word (CW.5).
Operating mode selection and output pattern
Operating mode selection. Apart from the operating mode FM (Frequency Modulation, index 0x8000:0E or 0x8010:0E = 0dec), the EL2521 can also be used for stepper motor control with pulse direction specification (Frq-Cnt pulse mode, index 0x8000:0E or 0x8010:0E = 1dec). A further operation mode is incremental encoder simulation (index 0x8000:0E or 0x8010:0E = 2dec). It is possible to connect the terminal’s output to an incremental encoder input directly. Such inputs are present on many servo drives and frequency converters. The pulse pattern is output through channels A and B. The necessary operation mode can be configured via the feature object 0x8000:0E or 0x8010:0E. The operating modes differ primarily between the positive logic modes 0, 1 and 2 and the negative logic modes 4, 5 and 6. The negative logic can be activated with index 0x8000:0F or 0x8010:10. Operating modes 2 and 6 simulate an incremental encoder, and permit direct connection to an evaluation unit such as a servo drive or frequency converter with an incremental encoder input.
Operating mode | Function
 | Clockwise rotation Counter clockwise rotation
Frequency modulation positive logic (BA0) |
Pulse-direction control positive logic (BA1) |
Incremental encoder positive logic (BA2) |
Frequency modulation negative logic (BA4) |
Pulse-direction control negative logic (BA5) |
Incremental encoder negative logic (BA6) |
Ramp function
An internal ramp increases/lowers the current frequency to the preset maximum frequency with the preset parameters in index 0x8800:02; it is activated by index 0x8000:06 or 0x8010:06.
CoE parameters
Depending on operating mode, normal or enhanced, the parameters from the objects 0x8000, 0x8001, 0x8800 or 0x8010 are to be used.
The base frequency of the ramp can be selected by index 0x8000:07 or 0x8010:07. Bit 1 of the status word (SW.1) or index 0x6010:02 is set when a ramp is traversed. The deactivation of this function, which can also take place during operation via CW.1 or index 0x7010:02, results in the enabling of CW.0 or index 0x7010:01. This allows the user to quickly change the base frequency during operation; if CW.0 or index 0x7010:01 = 1 (confirmation by SW.0 or index 0x6010:01), then base frequency 2 in object 0x8001:03 or 0x8010:13 is used instead of base frequency 1 in object 0x8001:02 or 0x8010:12 (CW.0 or index 0x7010:01 = 0). The input signals T and Z are transferred by the terminal directly to the controller in the status word (SW.4 / SW.5) or index 0x6010:05 / 0x6010:06. The signals are not given any internal pre-processing.
The terminal offers a facility for soft starting and stopping. Using index 0x8001:04 or 0x8010:14 the ramp gradient for starting can be set with an accuracy of 10 or 1000 Hz/sec (index 0x8000:07 or 0x8010:07). Index 0x8001:05 or 0x8010:15 has the same function for stopping. The process data can be modified during transit of the ramp (CW.2 or index 0x7010:03), and the terminal then takes the new value as its target frequency.
Resolution
The base frequencies are specified with a resolution of 1 Hz per bit (base frequency 1: index 0x8001:02 or 0x8010:12 or base frequency 2: index 0x8001:03 or 0x8010:13). The terminal operates internally at 16 MHz with a resolution of 32 bits. This corresponds to a theoretical minimum step size of 0.0037 Hz/step over the entire frequency range. The output stage allows a maximum frequency of 500 kHz to be output.
Travel distance control
The travel distance control function is available in both normal and enhanced operating mode. Starting from the current counter value, a target counter value is automatically driven to and the corresponding level is output at the outputs. The output frequency thereby changes in accordance with the current counter value. When the given counter contents have been reached, the terminal switches the frequency to zero.
The sequence is determined by several factors, see figure. Before parameterizing the travel distance control, it is recommended to carry out a CoE reset "Restoring the delivery state" in order to rule out side effects.
The sequence and the associated parameters are listed in following table; in enhanced operating mode some parameters are no longer in the CoE, but can be linked as process data.
Phase |  | normal operating mode | enhanced operating mode
Parameterization | Activate travel distance control | 0x8000:0A = TRUE | 0x8010:0A = TRUE
 | Basic ramp frequency (10 Hz / 1 KHz) | 0x8000:07 = ? | 0x8010:07 = ?
 | Ramp time constant "rising" t1 [Δ/sec] | 0x8001:04 = ? | 0x8010:14 = ?
 | Maximum driving frequency f1 | 0x8800:02 = ? | ---
 | Ramp time constant "falling" t3 [Δ/sec] (> 1.1 * ramp time constant t1!) | 0x8001:05 = ? | 0x8010:15 = ?
 | Output frequency f2 | 0x8001:07 = ? | 0x8010:17 = ?
Trip | Specify target position | 0x8800:01 = ? | PDO: TargetCounterValue = ?
 | Trip start | CW.2 = TRUE | PDO: Control.GoCounter = TRUE
 | Maximum driving frequency f1 | --- | PDO: FrequencyValue <> 0
Reset |  | CW.2 = FALSE | PDO: FrequencyValue = 0
 |  |  | PDO: Control.GoCounter = FALSE
In the case of travel distance control in enhanced operating mode, the "Go counter" bit must be set at the same time or before specifying the "Frequency value". If the "Go counter" bit is not set and the "Frequency value" is not equal to 0, then travel distance control is NOT active and clock pulses are already output!
Ramp time constant
The "real" ramp time results from the multiplication of the basic ramp frequency with that of the rising/falling ramp time constant.
Steepness of the falling ramp
In order to travel to a destination with precision, it is necessary that the time constant for the falling ramp is greater than that of the rising ramp by a certain factor. This is necessary so that the slowing down frequency is reached before the final counter state, so that the terminal does not drive up to the end point at full speed. To explain in more detail: the EL2521 calculates the number of steps that are still to be taken in time t2 from time t1 and from the number of steps that have been taken. The calculation for stopping assumes the same number of steps as that found for starting up. The downward ramp must be a little steeper, approx. 10%, so that it is possible to reach the destination exactly in the remaining time t3 + t4 + t5. This relationship changes with the maximum frequency.
Phases of the travel distance control
By way of example, the recording of a short real travel distance ramp is shown here together with the example program.

The short step sequence resets the current counter value to 0 and then drives to the target position 65. In the System Manager file the EL2521-xxxx is set to the appropriate CoE values for this example via the StartUp parameters.
Example travel distance control program
The result is the output of a variable frequency up to the target position 65.
Oscilloscope recording of the pulse sequence
Relative data
The output frequency depends on the base frequency set in the objects 0x8001:02 or 0x8010:12 to 0x8001:03 or 0x8010:13 and the process data (see table).

Example:

Output frequency = base frequency x process data / 32767
Highest resolution = 125 mHz

Base frequency = 100,000 Hz (maximum selected output frequency)
Process data = 0x00FF (255dec)
Output frequency = 778.22 Hz
Process data |  | Output value
 | 0x0000 (0dec) | 0% DC
 | 0x3FFF (16383dec) | 50% of the base frequency, rotation to the right
 | 0x7FFF (32767dec) | 100% of the base frequency, rotation to the right
Two's complement | 0xC000 (-16384dec) | 50% of the base frequency, rotation to the left
 | 0x8000 (-32768dec) | 100% of the base frequency, rotation to the left
Sign / amount representation | 0xBFFF (-16383dec) | 50% of the base frequency, rotation to the left
 | 0xFFFF (-32767dec) | 100% of the base frequency, rotation to the left
Direct data
There is a possibility to directly input the frequency (object 0x8000:08 or 0x8010:08). Here, the process data are multiplied by the factor from object 0x8001:06 or 0x8010:16 and written directly to the synthesis chip.

Example:

Output frequency = frequency factor x process data x 10 mHz
Highest resolution = 10 mHz

Frequency factor = 100
Process data = 0x00FF (255dec)
Output frequency = 255 Hz
Distributed Clocks (DC)
EtherCAT and Distributed Clocks
A basic introduction into EtherCAT and distributed clocks is available for download from the Beckhoff website: the “Distributed clocks system description”.
The EL2521 supports the distributed clocks function. In order for the EL2521 to be able to make the current process data available in time before the arrival of the querying EtherCAT datagram, a suitable signal must be generated cyclically within the terminal. This signal can be triggered in the EL2521 through two events: the SyncManager (SM) and the distributed clock (DC). Under operating mode selection the following options are available (see Figure “DC tab”):
▪
FreeRun/SM synchronous
The SynManager event occurs when an EtherCAT frame successfully exchanges process data with the EL2521. The current process data are thus cyclically processed, frame-triggered, but with the low temporal jitter of the Ethernet frame.
▪
DC-synchronous
In DC operating mode determination of the process data processing is triggered cyclically at constant intervals through the integrated DC unit, synchronous with the bus cycle as standard. More uniform polling offers higher-quality data for a higher-level control algorithm, for example. In the EL2521 the SYNC0 signal acts as trigger.
DC tab (Distributed Clocks)
When DC Synchronous operating mode is activated TwinCAT selects settings that ensure reliable operation of the EL2521 with current data. This means that the processing of the current process data is started by the SYNC0 signal at highly constant intervals and in good time – i.e. with an adequate safety buffer – before the retrieving EtherCAT datagram.
The SYNC0 signal can be shifted along the time axis as required through associated dialogs (right/later and left/earlier) by specifying a user-defined shift time, see Fig. “Advanced Settings for Distributed Clocks”.
▪
Through a shift to the right (positive shift value), the processing of the process data takes place later – regarded relatively from the PLC the degree of currentness is thus increased. However, this increases the risk that the provision may not be finished in time before the arrival of EtherCAT frame, so that no current value is available in this cycle.
▪
Through a shift to the left (negative shift value) the processing of the process data takes place earlier – the degree of currentness is thus decreased; however, the safety buffer is increased before the arrival of the EtherCAT datagram. This setting may be useful in systems with high real-time jitter, if no Industrial PCs from Beckhoff are used for control purposes, for example.
Note
Attention! Risk of device damage!
The mentioned notes and information should be used advisedly. The EtherCAT master automatically allocates SYNC0 and SYNC1 settings that support reliable and timely process data acquisition. User intervention at this point may lead to undesired behavior. If these settings are changed in the System Manager, no plausibility checks are carried out on the software side. Correct function of the terminal with all conceivable setting options cannot be guaranteed.
Default setting
The cyclic writing of the outputs is triggered by the SYNC0 pulse (interrupt) from the DC in the EL2521. The EtherCAT master sets the Sync Unit Cycle time value to the PLC cycle time and therefore the EtherCAT cycle time as standard. Refer to Figure “Advanced Settings for Distributed Clock”: 4000µs = 4 ms, as TwinCAT is in configuration mode.
EL2521 DC settings
Advanced Settings for Distributed Clock (DC), EL2521 terminal
▪
SYNC0
Sync unit cycle: a multiple of the bus cycle time. The process data are periodically processed at this interval (in µs).
▪
User-defined
Arbitrary number up to 232 ns ≈ 4.3 secs. Decimal point values are possible.
▪
Shift Time
The Shift Time can be used to shift the SYNC0 pulse for this EL2521 relative to other terminals and the global SYNC pulse in nanosecond steps. If the outputs of multiple EL2521 terminals are to be written at the same time, the same value must be entered here.
▪
Based on Input Reference
If this option is activated an additional Input Shift is added to the configurable terminal-specific SYNC0 shift (user-defined). This value is calculated and made available by the EtherCAT master (SysMan/Solution Explorer → Device (EtherCAT): tab EtherCAT → Advanced Settings → Distributed Clocks → Input Shift Time, see respective Figures). As a result, all the input terminals in the system (EL1xxx, EL3xxx) read their inputs as close as possible to the time of the EtherCAT frame that will fetch them, thereby supplying the most recent possible input data to the controller.
▪
Enable SYNC0
Automatic activated in DC Synchronous operating mode.
▪
SYNC1
Additional SYNC pulse, derived from SYNC0 or from the DC itself. Not required by the EL2521.
DC settings for EtherCAT master
Higher-level distributed clock parameters can be modified under advanced settings for the EtherCAT master. Refer also to the basic introduction to the topic of EtherCAT and Distributed Clocks; download: the "Distributed Clocks system description".
EtherCAT Master, EtherCAT tab, Advanced Settings
EtherCAT Master, Advanced Settings, Distributed Clock
Code Word
Code Word
The vendor reserves the authority for the basic calibration of the terminals. The code word is therefore at present reserved.
Notes on EL2521-0124
The EL2521-0124 has a latch input and a 24 V compare output, which both operate in connection with the position value.
Explanation on the basis of the associated process data:
Latch input, identical function as in the case of EL encoder terminals
▪
PDO ENC Status (input)
–
External latch valid
–
Status of external latch (current status of the latch input)
–
Latch value
▪
PDO ENC Control (output)
–
Enable latch extern on positive edge
–
Enable latch extern on negative edge
Compare output ‘PLS’ (Programmable Limit Switch)
▪
PLS Control:
–
‘Enable PLS’:
= 0 Output can be switched manually via ‘Outputs’
= 1 Automatic switching function has control of the output
–
Output
Switches the output (no function if ‘Enable PLS’ =1)
–
Switch-on value
Switch-on value (the output is switched on when the counter reaches this value)
–
Switch-off value
Switch-off value (the output is switched off when the counter reaches this value)
Process data EL2521-0124


Process data

Commissioning [image] EL2521-xxxx [image] Process data
Process data
The process data selection in the System Manager specifies the operation mode of the EL2521-xxxx. The process data can be set according to the tables below for inputs and outputs either individually by hand or via the predefined PDO selection with a single click.
predefined PDO selection in the TwinCAT System Manager
Three process data sets are available for the EL2521-xxxx and are listed in following table.
Sync Manager (SM)
PDO assignment of the SyncManager
SM3, PDO Assignment 0x1C13, inputs
Index | assigned to PDO setting | Index of excluded PDOs | Size (byte.bit) | Name | PDO content Index - Name
0x1A00 (default) | Legacy (MDP 252) | 0x1A01 0x1A02 0x1A05 | 4.0 | Inputs | 0x6000:01 - Status 0x6000:02 - Data in
0x1A01 | Standard 16 bit (MDP 253/511) Standard 32 bit (MDP 253/511) | 0x1A00 | 2.0 | PTO Status | 0x6010:01 - Sel. Ack./End counter 0x6010:02 - Ramp active 0x6010:05 - Status of input target 0x6010:06 - Status of input zero 0x6010:07 - Error 0x1C32:20 – Sync error 0x1801:09 - TxPDO Toggle
0x1A02 | Standard 16 bit (MDP 253/511) | 0x1A00 0x1A05 | 4.0 | ENC Status compact | 0x6020:03 - Set counter done 0x6020:04 - Counter underflow 0x6020:05 - Counter overflow 0x1C32:20 – Sync error 0x1802:09 - TxPDO Toggle 0x6020:11 - Counter value
0x1A05 | Standard 32 bit (MDP 253/511) | 0x1A00 0x1A02 | 6.0 | ENC Status | 0x6020:03 - Set counter done 0x6020:04 - Counter underflow 0x6020:05 - Counter overflow 0x1C32:20 – Sync error 0x1805:09 - TxPDO Toggle 0x6020:11 - Counter value
SM2, PDO assignment 0x1C12, outputs
Index | assigned to PDO setting | Index of excluded PDOs | Size (byte.bit) | Name | PDO content Index - hex
0x1600 (default) | Legacy (MDP 252) | 0x1601 0x1604 0x1607 0x1602 0x1605 | 4.0 | Inputs | 0x7000:01 - Ctrl 0x7000:02 - Data out
0x1601 | Standard 16 bit (MDP 253/511) Standard 32 bit (MDP 253/511) | 0x1600 | 4.0 | PTO Control | 0x7010:01 - Frequency select 0x7010:02 - Disable ramp 0x7010:03 - Go counter 0x7010:11 - Frequency value
0x1604 | Standard 16 bit (MDP 253/511) | 0x1600 0x1607 0x1605 | 2.0 | PTO Target compact | 0x7010:12 - Target counter value
0x1607 | Standard 32 bit (MDP 253/511) | 0x1600 0x1604 0x1602 | 4.0 | PTO Target | 0x7010:12 - Target counter value
0x1602 | Standard 16 bit (MDP 253/511) | 0x1600 0x1607 0x1605 | 4.0 | ENC Control compact | 0x7020:03 - Set counter 0x7020:11 - Set counter value
0x1605 | Standard 32 bit (MDP 253/511) | 0x1600 0x1604 0x1602 | 6.0 | ENC Control | 0x7020:03 - Set counter 0x7020:11 - Set counter value
Process data setting options
The extent of process data can be set via the Process Data tab as described below.
PDO setting 1: Legacy (MDP 252)
▪
preset standard configuration in TwinCAT 2.10 (see note below for more up-to-date TwinCAT versions)
▪
to be used only in normal operation mode
▪
compatible with terminals up to and including FW02
Process data and PDO assignment Legacy (MDP 252)
Standard configuration in TwinCAT
The further development of the EL2521-xxxx from FW03 also necessitates a new process image, which is to be used preferentially in new systems. Therefore the standard configuration from TwinCAT 2.11 onwards is normally PDO setting 2 (see below), with which an EL2521-xxxx inserted manually or by scanning appears in the configuration. For reasons of compatibility with existing software, however, some customers require PDO setting 1 "Legacy MDP253" to appear as the standard configuration, even for newly created configurations. In this case the so-called compatibility flag is to be set in the System Manager. Legacy is then selected as the standard PDO configuration. Nevertheless the PDO can, of course, be converted/changed after inserting the terminal into the configuration.

Fig.: Compatibility Mode in the System Manager from TwinCAT 2.11
PDO setting 2: Standard 16 bit (MDP 253/511)
▪
preset standard configuration in TwinCAT 2.11, TwinCAT 3
▪
to be used only in enhanced operating mode
▪
so-called compact process image, since it has only 16-bit-wide variables
▪
allows linking to NC axes according to MDP 253, subprofile 511
Process data and PDO assignment standard 16-bit (MDP 253/511)
PDO setting 3: Standard 32 bit (MDP 253/511)
▪
to be used only in enhanced operating mode
▪
32-bit-wide variables
▪
allows linking to NC axes according to MDP 253, subprofile 511
Process data and PDO assignment standard 32-bit (MDP 253/511)


Normal operation mode

Commissioning [image] EL2521-xxxx [image] Normal operation mode
Normal operation mode
Additional information
•
EL2521-0000


EL2521-0000

Commissioning [image] EL2521-xxxx [image] Normal operation mode [image] EL2521-0000
EL2521-0000
Additional information
•
Control and status word
•
Object description and parameterization


Control and status word

Commissioning [image] EL2521-xxxx [image] Normal operation mode [image] EL2521-0000 [image] Control and status word
Control and status word
Control word
The control word (CW) is located in the output process image, and is transmitted from the controller to the terminal.
Bit | CW.15 | CW.14 | CW.13 | CW.12 | CW.11 | CW.10 | CW.9 | CW.8
Name | - | - | - | - | - | - | - | -
Bit | CW.7 | CW.6 | CW.5 | CW.4 | CW.3 | CW.2 | CW.1 | CW.0
Name | - | - | CNT_CLR | - | - | GO_COUNTER | RAMP_DIS | FREQ_SEL
Legend
Bit | Name | Description
CW.8 - CW.15 | - | - | reserved
CW.7 | - | - | reserved
CW.6 | - | - | reserved
CW.5 | CNT_CLR | 1bin | The counter value is cleared or set by this bit (index 0x8000:0B). Any overflow/underflow bits that have been set are also cleared by this bit. This process can be edge-controlled or level-controlled (index 0x8000:05).
CW.4 | - | - | reserved
CW.3 | - | - | reserved
CW.2 | GO_COUNTER | 1bin | If travel distance control is activated (index 0x8000:0A), a specified counter value is driven to if the bit is set.
CW.1 | RAMP_DIS | 1bin | The ramp function is disabled despite active index 0x8000:06; if the travel distance control is active it is aborted by this bit.
CW.0 | FREQ_SEL | 0bin / 1bin | Fast toggling of the base frequency (only if ramp function is deactivated) 0bin = base frequency 1 (index 0x8001:02) bin = base frequency 2 (index 0x8001:03)
Status word
The status word (SW) is located in the input process image, and is transmitted from terminal to the controller.
Bit | SW.15 | SW.14 | SW.13 | SW.12 | SW.11 | SW.10 | SW.9 | SW.8
Name | - | - | - | - | - | - | - | -
Bit | SW.7 | SW.6 | SW.5 | SW.4 | SW.3 | SW.2 | SW.1 | SW.0
Name | - | ERROR | INPUT_Z | INPUT_T | OVERFLOW | UNDERFLOW | RAMP_ACTIVE | SEL_ACK/ END_COUNTER
Legend
Bit | Name | Description
SW.8 - SW.15 | - | - | reserved
SW.7 | - | - | reserved
SW.6 | ERROR | 1bin | General error bit, is set together with overrange and underrange
SW.5 | INPUT_Z | 1bin | Status of the input INPUT_Z
SW.4 | INPUT_T | 1bin | Status of the input INPUT_T
SW.3 | OVERFLOW | 1bin | This bit is set if the 16-bit counter overflows (65535 -> 0). It is reset when the counter exceeds one third of its measuring range (21845 -> 21846) or immediately an underflow occurs.
SW.2 | UNDERFLOW | 1bin | This bit is set if the 16-bit counter underflows (0 -> 65535). It is reset when the counter drops below two thirds of its measuring range (43690 -> 43689) or immediately an overflow occurs.
SW.1 | RAMP_ACTIVE | 1bin | Ramp is currently being followed
SW.0 | SEL_ACK/ END_COUNTER | 1bin | Confirms the change of base frequency. if travel distance control is activated: target counter value reached


Object description and parameterization

Commissioning [image] EL2521-xxxx [image] Normal operation mode [image] EL2521-0000 [image] Object description and parameterization
Object description and parameterization
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Parameterization via the CoE list (CAN over EtherCAT)
The terminal is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs). Please note the following general CoE information when using/manipulating the CoE parameters:
•
Keep a startup list if components have to be replaced
•
Differentiation between online/offline dictionary, existence of current XML description
•
“CoE-Reload” for resetting the changes
Introduction
The CoE overview contains objects for different intended applications:
▪
Objects required for parameterization during commissioning
▪
Objects intended for regular operation, e.g. through ADS access.
▪
Objects for indicating internal settings (may be fixed)
The following section first describes the objects required for normal operation, followed by a complete overview of missing objects.
Additional information
•
Objects for commissioning
•
Objects for regular operation
•
Standard objects (0x1000-0x1FFF)
•
Profile-specific objects (0x6000-0xFFFF)


Objects for commissioning

Commissioning [image] EL2521-xxxx [image] Normal operation mode [image] EL2521-0000 [image] Object description and parameterization [image] Objects for commissioning
Objects for commissioning
Index 0x1011 Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default settings | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" in the Set Value Dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)
Index 0x8000 Feature bits
Index (hex) | Name | Meaning | Data type | Flags | Default
8000:0 | Feature bits | Max. Subindex | UINT8 | RO | 0x0F (15dec)
8000:02 | Emergency ramp active | TRUE If the watchdog timer responds, the terminal ramps with the time constant set in object 0x8001:08 to the value set in object 0x8001:01. FALSE The function is deactivated | BOOLEAN | RW | 0x00 (0dec)
8000:03 | Watchdog timer inactive | The SM watchdog is evaluated here. TRUE The watchdog timer is deactivated FALSE The watchdog timer is activated in the delivery state. Either the manufacturer's of the user's switch-on value is output if the watchdog overflows. | BOOLEAN | RW | 0x00 (0dec)
8000:04 | Sign/amount representation | TRUE The output value is displayed in signed amount representation: -2dec= 0x8002 -1dec= 0x8001 1dec= 0x0001 2dec= 0x0002 FALSE The output value is output as signed integer in the two's complement: -2dec= 0xFFFE -1dec= 0xFFFF 1dec= 0x0001 2dec= 0x0002 | BOOLEAN | RW | 0x00 (0dec)
8000:05 | Rising edge clears/sets counter | TRUE The counter is cleared/set on a rising edge of the Counter_Clear bit in the control word (CW.5) FALSE The counter is cleared/set on a positive level of the Counter_Clear bit in the control word (CW.5) | BOOLEAN | RW | 0x01 (1dec)
8000:06 | Ramp function active | TRUE Ramp function activated FALSE Ramp function deactivated The ramp controller should only be deactivated if a higher-level controller (e.g. NC controller) takes over the control of travel distance and frequency. | BOOLEAN | RW | 0x01 (1dec)
8000:07 | Ramp base frequency | 0(dec) Ramp base frequency: 10 Hz (pull-down menu) 1(dec) Ramp base frequency: 1 kHz (pull-down menu) | BIT1 | RW | 0x00 (0dec)
8000:08 | Direct input mode | TRUE Direct input mode Relative input mode | BOOLEAN | RW | 0x00 (0dec)
8000:09 | User switch-on value on wdt | TRUE Behavior with triggered watchdog timer: User switch-on value FALSE Behavior with triggered watchdog timer: Manufacturer's switch-on value | BOOLEAN | RW | 0x00 (0dec)
8000:0A | Travel distance control active | TRUE Travel distance control activated FALSE Travel distance control deactivated | BOOLEAN | RW | 0x00 (0dec)
Index (hex) | Name | Meaning | Data type | Flags | Default
8000:0B | Rising edge sets counter | TRUE Rising edge sets counter FALSE Rising edge clears counter | BOOLEAN | RW | 0x00 (0dec)
8000:0E | Operating mode | 0(dec) Frequency modulation operating mode (pull-down menu) 1(dec) Pulse direction specification operating mode (pull-down menu) 2(dec) Incremental encoder operating mode (pull-down menu) | BIT2 | RW | 0x00 (0dec)
8000:0F | Negative logic | TRUE Negative logic FALSE Positive logic | BOOLEAN | RW | 0x00 (0dec)
Index 0x8001 User settings
Index (hex) | Name | Meaning | Data type | Flags | Default
8001:0 | User settings | Max. Subindex | UINT8 | RO | 0x08 (8dec)
8001:01 | User switch-on-value | User switch-on value (frequency) | UINT16 | RW | 0x0000 (0dec)
8001:02 | Base frequency 1 | Base frequency 1 = 50000 Hz | UINT32 | RW | 0x0000C350 (50000dec)
8001:03 | Base frequency 2 | Base frequency 2 = 100000 Hz | UINT32 | RW | 0x000186A0 (100000dec)
8001:04 | Ramp time constant (rising) | Ramp time constant (rising, [1/sec]) The "real" ramp time is obtained by the multiplication of the ramp base frequency by this ramp time constant. | UINT16 | RW | 0x03E8 (1000dec)
8001:05 | Ramp time constant (falling) | Ramp time constant (falling, [1/sec]) The "real" ramp time is obtained by the multiplication of the ramp base frequency by this ramp time constant. | UINT16 | RW | 0x03E8 (1000dec)
8001:06 | Frequency factor (digit x 10 mHz) | Frequency factor (direct input, digit x 10 mHz) | UINT16 | RW | 0x0064 (100dec)
8001:07 | Slowing down frequency | Slowing down frequency, travel distance control | UINT16 | RW | 0x0032 (50dec)
8001:08 | Ramp time constant (emergency) | Ramp time constant for controlled switch-off; User switch-on value is driven to (object 0x8001:01) | UINT16 | RW | 0x03E8 (1000dec)
Index 0x8800 Volatile settings
Index (hex) | Name | Meaning | Data type | Flags | Default
8800:0 | Volatile settings | Max. Subindex | UINT8 | RO | 0x02 (2dec)
8800:01 | Target counter state | Target counter value | UINT32 | RW | 0x00000000 (0dec)
8800:02 | Maximum frequency | Maximum frequency | UINT16 | RW | 0x0000 (0dec)


Objects for regular operation

Commissioning [image] EL2521-xxxx [image] Normal operation mode [image] EL2521-0000 [image] Object description and parameterization [image] Objects for regular operation
Objects for regular operation
In normal operating mode the EL2521 has no such objects.


Standard objects (0x1000-0x1FFF)

Commissioning [image] EL2521-xxxx [image] Normal operation mode [image] EL2521-0000 [image] Object description and parameterization [image] Standard objects (0x1000-0x1FFF)
Standard objects (0x1000-0x1FFF)
The standard objects have the same meaning for all EtherCAT slaves.
Index 0x1000 Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x00001389 (5001dec)
Index 0x1008 Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EL2521-0000
Index 0x1009 Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO | 01
Index 0x100A Software version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO | 02
Index 0x1018 Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x30520002 (810680322dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x000009D9 (2521dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the Low Word (bit 0-15) indicates the special terminal number, the High Word (bit 16-31) refers to the device description | UINT32 | RO | 0x00000000 (0dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the Low Byte (bit 0-7) of the Low Word contains the year of production, the High Byte (bit 8-15) of the Low Word contains the week of production, the High Word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 0x1600 Outputs
Index (hex) | Name | Meaning | Data type | Flags | Default
1600:0 | RxPDO-Map | PDO Mapping RxPDO 1 | UINT8 | RO | 0x02 (2dec)
1600:01 | RxPDO-Mapping Element 1: Ctrl | 1. PDO Mapping entry (object 0x7000 (Outputs), entry 0x01 (Ctrl)) | UINT32 | RO | 0x7000:01, 16
1600:02 | RxPDO-Mapping Element 2: Data out | 2. PDO Mapping entry (object 0x7000 (Outputs), entry 0x02 (Data Out)) | UINT32 | RO | 0x7000:02, 16
Index 0x1A00 Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
1A00:0 | TxPDO-Map | PDO Mapping TxPDO 1 | UINT8 | RO | 0x02 (2dec)
1A00:01 | TxPDO-Mapping Element 1: Status | 1. PDO Mapping entry (object 0x6000 (Inputs), entry 0x01 (Status)) | UINT32 | RO | 0x6000:01, 16
1A00:02 | TxPDO-Mapping Element 2: Data in | 2. PDO Mapping entry (object 0x6000 (Inputs), entry 0x02 (Data In)) | UINT32 | RO | 0x6000:02, 16
Index 0x1C00 Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the Sync Managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 0x1C01 Process data format
Index (hex) | Name | Meaning | Data type | Flags | Default
1C01:0 | Process data format | Process data format | UINT16 | RW | 0x0100 (256dec)
Index 0x1C12 SM 0002 RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x01 (1dec)
1C12:01 | Assigned RxPDO | 1. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1600 (5632dec)
Index 0x1C13 TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x01 (1dec)
1C13:01 | Assigned TxPDO | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)


Profile-specific objects (0x6000-0xFFFF)

Commissioning [image] EL2521-xxxx [image] Normal operation mode [image] EL2521-0000 [image] Object description and parameterization [image] Profile-specific objects (0x6000-0xFFFF)
Profile-specific objects (0x6000-0xFFFF)
The profile-specific objects have the same meaning for all EtherCAT slaves that support the profile 5001.
Index 0x6000 Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
6000:0 | Inputs | Max. Subindex | UINT8 | RO | 0x02 (2dec)
6000:01 | Status | Status Word | UINT16 | RO | 0x0000 (0dec)
6000:02 | Data In | Input process data (counter value) | UINT16 | RO | 0x0000 (0dec)
Index 0x7000 Outputs
Index (hex) | Name | Meaning | Data type | Flags | Default
7000:0 | Outputs | Max. Subindex | UINT8 | RO | 0x02 (2dec)
7000:01 | Ctrl | Control Word | UINT16 | RO | 0x0000 (0dec)
7000:02 | Data Out | Output process data (frequency value) | UINT16 | RO | 0x0000 (0dec)
Index 0xA000 Diagnostic parameter
Index (hex) | Name | Meaning | Data type | Flags | Default
A000:0 | Diagnostic parameter | Max. Subindex | UINT8 | RO | 0x01 (1dec)
A000:01 | Counter extension | Counter extension | UINT16 | RO | 0x0000 (0dec)
Index 0xF000 Profile settings
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0001 (1dec)
Index 0xF008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | currently reserved | UINT32 | RW | 0x00000000 (0dec)


Enhanced operation mode

Commissioning [image] EL2521-xxxx [image] Enhanced operation mode
Enhanced operation mode
Additional information
•
EL2521-0000, EL2521-0024, EL2521-0025
•
EL2521-0124


EL2521-0000, EL2521-0024, EL2521-0025

Commissioning [image] EL2521-xxxx [image] Enhanced operation mode [image] EL2521-0000, EL2521-0024, EL2521-0025
EL2521-0000, EL2521-0024, EL2521-0025
Additional information
•
Object description and parameterization - enhanced operation mode


Object description and parameterization - enhanced operation mode

Commissioning [image] EL2521-xxxx [image] Enhanced operation mode [image] EL2521-0000, EL2521-0024, EL2521-0025 [image] Object description and parameterization - enhanced operation mode
Object description and parameterization - enhanced operation mode
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Parameterization via the CoE list (CAN over EtherCAT)
The terminal is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs). Please note the following general CoE information when using/manipulating the CoE parameters:
•
Keep a startup list if components have to be replaced
•
Differentiation between online/offline dictionary, existence of current XML description
•
“CoE-Reload” for resetting the changes
Introduction
The CoE overview contains objects for different intended applications:
▪
Objects required for parameterization during commissioning
▪
Objects intended for regular operation, e.g. through ADS access.
▪
Objects for indicating internal settings (may be fixed)
The following section first describes the objects required for normal operation, followed by a complete overview of missing objects.
Additional information
•
Objects for commissioning
•
Objects for regular operation
•
Standard objects (0x1000-0x1FFF)
•
Profile-specific objects (0x6000-0xFFFF)


Objects for commissioning

Commissioning [image] EL2521-xxxx [image] Enhanced operation mode [image] EL2521-0000, EL2521-0024, EL2521-0025 [image] Object description and parameterization - enhanced operation mode [image] Objects for commissioning
Objects for commissioning
Index 0x1011 Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default settings | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" in the Set Value Dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)
Index 0x8010 PTO Settings
Index (hex) | Name | Meaning | Data type | Flags | Default
8010:0 | PTO Settings | Max. Subindex | UINT8 | RO | 0x18 (24dec)
8010:02 | Emergency ramp active | TRUE If the watchdog timer responds, the terminal ramps with the time constant set in object 8001:08 0x8010:18 to the value set in object 8001:01 0x8010:11. FALSE The function is deactivated | BOOLEAN | RW | 0x00 (0dec)
8010:03 | Watchdog timer inactive | The SM watchdog is evaluated here. TRUE The watchdog timer is deactivated FALSE The watchdog timer is activated in the delivery state. Either the manufacturer's of the user's switch-on value is output if the watchdog overflows | BOOLEAN | RW | 0x00 (0dec)
8010:04 | Sign/amount representation | TRUE The output value is displayed in signed amount representation: -2dec= 0x8002 -1dec= 0x8001 1dec= 0x0001 2dec= 0x0002 FALSE The output value is output as signed integer in the two's complement: -2dec= 0xFFFE -1dec= 0xFFFF 1dec= 0x0001 2dec= 0x0002 | BOOLEAN | RW | 0x00 (0dec)
8010:06 | Ramp function active | TRUE Ramp function activated FALSE Ramp function deactivated The ramp controller should only be deactivated if a higher-level controller (e.g. NC controller) takes over the control of travel distance and frequency. | BOOLEAN | RW | 0x01 (1dec)
8010:07 | Ramp base frequency | 0(dec) Ramp base frequency: 10 Hz (pull-down menu) 1(dec) Ramp base frequency: 1 kHz (pull-down menu) | BIT1 | RW | 0x00 (0dec)
8010:08 | Direct input mode | TRUE Direct input mode Relative input mode | BOOLEAN | RW | 0x00 (0dec)
8010:09 | User switch-on value on wdt | TRUE Behavior with triggered watchdog timer: User switch-on value FALSE Behavior with triggered watchdog timer: Manufacturer's switch-on value | BOOLEAN | RW | 0x00 (0dec)
8010:0A | Travel distance control active | TRUE Travel distance control activated FALSE Travel distance control deactivated | BOOLEAN | RW | 0x00 (0dec)
Index (hex) | Name | Meaning | Data type | Flags | Default
8010:0E | Operating mode | 0(dec) Frequency modulation operating mode (pull-down menu) 1(dec) Pulse direction specification operating mode (pull-down menu) 2(dec) Incremental encoder operating mode (pull-down menu) | BIT2 | RW | 0x00 (0dec)
8010:10 | Negative logic | TRUE Negative logic FALSE Positive logic | BOOLEAN | RW | 0x00 (0dec)
8010:11 | User switch-on-value | User switch-on value (frequency) | UINT16 | RW | 0x0000 (0dec)
8010:12 | Base frequency 1 | Base frequency 1 = 50000 Hz | UINT32 | RW | 0x0000C350 (50000dec)
8010:13 | Base frequency 2 | Base frequency 2 = 100000 Hz | UINT32 | RW | 0x000186A0 (100000dec)
8010:14 | Ramp time constant (rising) | Ramp time constant (rising) | UINT16 | RW | 0x03E8 (1000dec)
8010:15 | Ramp time constant (falling) | Ramp time constant (falling) | UINT16 | RW | 0x03E8 (1000dec)
8010:16 | Frequency factor (digit x 10 mHz) | Frequency factor (direct input, digit x 10 mHz) | UINT16 | RW | 0x0064 (100dec)
8010:17 | Slowing down frequency | Slowing down frequency, travel distance control | UINT16 | RW | 0x0032 (50dec)
8010:18 | Ramp time constant (emergency) | Ramp time constant for controlled switch-off; User switch-on value is driven to (object 0x8001:01 0x8010:11) | UINT16 | RW | 0x03E8 (1000dec)


Objects for regular operation

Commissioning [image] EL2521-xxxx [image] Enhanced operation mode [image] EL2521-0000, EL2521-0024, EL2521-0025 [image] Object description and parameterization - enhanced operation mode [image] Objects for regular operation
Objects for regular operation
In enhanced operating mode the EL2521 has no such objects.


Standard objects (0x1000-0x1FFF)

Commissioning [image] EL2521-xxxx [image] Enhanced operation mode [image] EL2521-0000, EL2521-0024, EL2521-0025 [image] Object description and parameterization - enhanced operation mode [image] Standard objects (0x1000-0x1FFF)
Standard objects (0x1000-0x1FFF)
The standard objects have the same meaning for all EtherCAT slaves.
Index 0x1000 Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x00001389 (5001dec)
Index 0x1008 Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EL2521
Index 0x1009 Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO | 05
Index 0x100A Software version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO | 06
Index 0x1018 Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x09D93052 (165228626dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the Low Word (bit 0-15) indicates the special terminal number, the High Word (bit 16-31) refers to the device description | UINT32 | RO | 0x03F80000 (66584576dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the Low Byte (bit 0-7) of the Low Word contains the year of production, the High Byte (bit 8-15) of the Low Word contains the week of production, the High Word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 0x10F0 Backup parameter handling
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | Information for standardized loading and saving of backup entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum across all backup entries of the EtherCAT slave | UINT32 | RO | 0x00000000 (0dec)
Index 0x1400 RxPDO-Par
Index (hex) | Name | Meaning | Data type | Flags | Default
1400:0 | RxPDO-Par | PDO Parameter RxPDO 1 | UINT8 | RO | 0x06 (6dec)
1400:06 | Exclude RxPDOs | Specifies the RxPDOs (index (hex) of RxPDO mapping objects) that must not be transferred together with RxPDO 1 | OCTET-STRING[10] | RO | 01 16 04 16 07 16 02 16 05 16
Index 0x1401 PTO RxPDO-Par Control
Index (hex) | Name | Meaning | Data type | Flags | Default
1401:0 | PTO RxPDO-Par Control | PDO Parameter RxPDO 2 | UINT8 | RO | 0x06 (6dec)
1401:06 | Exclude RxPDOs | Specifies the RxPDOs (index (hex) of RxPDO mapping objects) that must not be transferred together with RxPDO 2 | OCTET-STRING[10] | RO | 00 16 00 00 00 00 00 00 00 00
Index 0x1402 ENC RxPDO-Par Control compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1402:0 | ENC RxPDO-Par Control compact | PDO Parameter RxPDO 3 | UINT8 | RO | 0x06 (6dec)
1402:06 | Exclude RxPDOs | Specifies the RxPDOs (index (hex) of RxPDO mapping objects) that must not be transferred together with RxPDO 3 | OCTET-STRING[10] | RO | 00 16 05 16 07 16 00 00 00 00
Index 0x1404 PTO RxPDO-Par Target compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1404:0 | PTO RxPDO-Par Target compact | PDO Parameter RxPDO 5 | UINT8 | RO | 0x06 (6dec)
1404:06 | Exclude RxPDOs | Specifies the RxPDOs (index (hex) of RxPDO mapping objects) that must not be transferred together with RxPDO 5 | OCTET-STRING[10] | RO | 00 16 05 16 07 16 00 00 00 00
Index 0x1405 ENC RxPDO-Par Control
Index (hex) | Name | Meaning | Data type | Flags | Default
1405:0 | ENC RxPDO-Par Control | PDO Parameter RxPDO 6 | UINT8 | RO | 0x06 (6dec)
1405:06 | Exclude RxPDOs | Specifies the RxPDOs (index (hex) of RxPDO mapping objects) that must not be transferred together with RxPDO 6 | OCTET-STRING[10] | RO | 00 16 02 16 04 16 00 00 00 00
Index 0x1407 PTO RxPDO-Par Target
Index (hex) | Name | Meaning | Data type | Flags | Default
1407:0 | PTO RxPDO-Par Target | PDO Parameter RxPDO 8 | UINT8 | RO | 0x06 (6dec)
1407:06 | Exclude RxPDOs | Specifies the RxPDOs (index (hex) of RxPDO mapping objects) that must not be transferred together with RxPDO 8 | OCTET-STRING[10] | RO | 00 16 02 16 04 16 00 00 00 00
Index 0x1600 RxPDO-Map
Index (hex) | Name | Meaning | Data type | Flags | Default
1600:0 | RxPDO-Map | PDO Mapping RxPDO 1 | UINT8 | RO | 0x02 (2dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (Outputs), entry 0x01 (Ctrl)) | UINT32 | RO | 0x7000:01, 16
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (Outputs), entry 0x02 (Data Out)) | UINT32 | RO | 0x7000:02, 16
Index 0x1601 PTO RxPDO-Map Control
Index (hex) | Name | Meaning | Data type | Flags | Default
1601:0 | PTO RxPDO-Map Control | PDO Mapping RxPDO 2 | UINT8 | RO | 0x06 (6dec)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (PTO Outputs), entry 0x01 (Frequency select)) | UINT32 | RO | 0x7010:01, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (PTO Outputs), entry 0x02 (Disable ramp)) | UINT32 | RO | 0x7010:02, 1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (PTO Outputs), entry 0x03 (Go counter)) | UINT32 | RO | 0x7010:03, 1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1601:05 | SubIndex 005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1601:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7010 (PTO Outputs), entry 0x11 (Frequency value)) | UINT32 | RO | 0x7010:11, 16
Index 0x1602 ENC RxPDO-Map Control compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1602:0 | ENC RxPDO-Map Control compact | PDO Mapping RxPDO 3 | UINT8 | RO | 0x05 (5dec)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1602:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7020 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7020:03, 1
1602:03 | SubIndex 003 | 3. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1602:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1602:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7020 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7020:11, 16
Index 0x1604 PTO RxPDO-Map Target compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1604:0 | PTO RxPDO-Map Target compact | PDO Mapping RxPDO 5 | UINT8 | RO | 0x01 (1dec)
1604:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (PTO Outputs), entry 0x12 (Target counter value)) | UINT32 | RO | 0x7010:12, 16
Index 0x1605 ENC RxPDO-Map Control
Index (hex) | Name | Meaning | Data type | Flags | Default
1605:0 | ENC RxPDO-Map Control | PDO Mapping RxPDO 6 | UINT8 | RO | 0x05 (5dec)
1605:01 | SubIndex 001 | 1. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1605:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7020 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7020:03, 1
1605:03 | SubIndex 003 | 3. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1605:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1605:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7020 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7020:11, 32
Index 0x1607 PTO RxPDO-Map Target
Index (hex) | Name | Meaning | Data type | Flags | Default
1607:0 | PTO RxPDO-Map Target | PDO Mapping RxPDO 8 | UINT8 | RO | 0x01 (1dec)
1607:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (PTO Outputs), entry 0x12 (Target counter value)) | UINT32 | RO | 0x7010:12, 32
Index 0x1800 TxPDO-Par
Index (hex) | Name | Meaning | Data type | Flags | Default
1800:0 | TxPDO-Par | PDO parameter TxPDO 1 | UINT8 | RO | 0x06 (6dec)
1800:06 | Exclude TxPDOs | Specifies the TxPDOs (index (hex) of TxPDO mapping objects) that must not be transferred together with TxPDO 1 | OCTET-STRING[6] | RO | 01 1A 02 1A 05 1A
Index 0x1801 PTO TxPDO-Par Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1801:0 | PTO TxPDO-Par Status | PDO parameter TxPDO 2 | UINT8 | RO | 0x09 (9dec)
1801:06 | Exclude TxPDOs | Specifies the TxPDOs (index (hex) of TxPDO mapping objects) that must not be transferred together with TxPDO 2 | OCTET-STRING[6] | RO | 00 1A 00 00 00 00
1801:09 | TxPDO Toggle | The TxPDO toggle is toggled with each update the corresponding input data | BOOLEAN | RO | 0x00 (0dec)
Index 0x1802 ENC TxPDO-Par Status compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1802:0 | ENC TxPDO-Par Status compact | PDO parameter TxPDO 3 | UINT8 | RO | 0x09 (9dec)
1802:06 | Exclude TxPDOs | Specifies the TxPDOs (index (hex) of TxPDO mapping objects) that must not be transferred together with TxPDO 3 | OCTET-STRING[6] | RO | 05 1A 00 1A 00 00
1802:09 | TxPDO Toggle | The TxPDO toggle is toggled with each update the corresponding input data | BOOLEAN | RO | 0x00 (0dec)
Index 0x1805 ENC TxPDO-Par Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1805:0 | ENC TxPDO-Par Status | PDO parameter TxPDO 6 | UINT8 | RO | 0x09 (9dec)
1805:06 | Exclude TxPDOs | Specifies the TxPDOs (index (hex) of TxPDO mapping objects) that must not be transferred together with TxPDO 6 | OCTET-STRING[6] | RO | 02 1A 00 1A 00 00
1805:09 | TxPDO Toggle | The TxPDO toggle is toggled with each update the corresponding input data | BOOLEAN | RO | 0x00 (0dec)
Index 0x1A00 TxPDO-Map
Index (hex) | Name | Meaning | Data type | Flags | Default
1A00:0 | TxPDO-Map | PDO Mapping TxPDO 1 | UINT8 | RO | 0x02 (2dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (Inputs), entry 0x01 (Status)) | UINT32 | RO | 0x6000:01, 16
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (Inputs), entry 0x02 (Data In)) | UINT32 | RO | 0x6000:02, 16
Index 0x1A01 PTO TxPDO-Map Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1A01:0 | PTO TxPDO-Map Status | PDO Mapping TxPDO 2 | UINT8 | RO | 0x0A (10dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (PTO Inputs), entry 0x01 (Sel. Ack/End counter)) | UINT32 | RO | 0x6010:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (PTO Inputs), entry 0x02 (Ramp active)) | UINT32 | RO | 0x6010:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (PTO Inputs), entry 0x05 (Status of input target)) | UINT32 | RO | 0x6010:05, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (PTO Inputs), entry 0x06 (Status of input zero)) | UINT32 | RO | 0x6010:06, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (PTO Inputs), entry 0x07 (Error)) | UINT32 | RO | 0x6010:07, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x1801 (PTO TxPDO-Par Status), entry 0x09 (TxPDO-Toggle)) | UINT32 | RO | 0x1801:09, 1
Index 0x1A02 ENC TxPDO-Map Status compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1A02:0 | ENC TxPDO-Map Status compact | PDO Mapping TxPDO 3 | UINT8 | RO | 0x0A (10dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6020:03, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6020:04, 1
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6020:05, 1
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A02:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x1802 (ENC TxPDO-Par Status compact), entry 0x09 (TxPDO-Toggle)) | UINT32 | RO | 0x1802:09, 1
1A02:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6020 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6020:11, 16
Index 0x1A05 ENC TxPDO-Map Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1A05:0 | ENC TxPDO-Map Status | PDO Mapping TxPDO 6 | UINT8 | RO | 0x0A (10dec)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A05:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6020:03, 1
1A05:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6020:04, 1
1A05:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6020:05, 1
1A05:05 | SubIndex 005 | 5. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1A05:06 | SubIndex 006 | 6. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A05:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A05:08 | SubIndex 008 | 8. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A05:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x1805 (ENC TxPDO-Par Status), entry 0x09 (TxPDO-Toggle)) | UINT32 | RO | 0x1805:09, 1
1A05:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6020 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6020:11, 32
Index 0x1C00 Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the Sync Managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 0x1C12 RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x01 (1dec)
1C12:01 | SubIndex 001 | 1. allocated RxPDO (contains the index (hex) of the associated RxPDO mapping object) | UINT16 | RW | 0x1600 (5632dec)
1C12:02 | SubIndex 002 | 2. allocated RxPDO (contains the index (hex) of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:03 | SubIndex 003 | 3. allocated RxPDO (contains the index (hex) of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 0x1C13 TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x01 (1dec)
1C13:01 | SubIndex 001 | 1. allocated TxPDO (contains the index (hex) of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | SubIndex 002 | 2. allocated TxPDO (contains the index (hex) of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 0x1C32 SM output parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C32:0
SM output parameter
Synchronization parameters for the outputs
UINT8
RO
0x20 (32dec)
1C32:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dec)
1C32:02
Cycle time
Cycle time (in ns):
▪
Free Run: Cycle time of the local timer
▪
Synchron with SM 2 Event: Master cycle time
▪
DC mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x001E8480 (2000000dec)
1C32:03
Shift time
Time between SYNC0 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0 = 1: free run is supported
▪
Bit 1 = 1: Synchron with SM 2 Event is supported
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 10: Output Shift with SYNC1 event (only DC mode)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08)
UINT16
RO
0xC007 (49159dec)
1C32:05
Minimum cycle time
Minimum cycle time (in ns)
UINT32
RO
0x00000000 (0dec)
1C32:06
Calc and copy time
Minimum time between SYNC0 and SYNC1 event (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:08
Command
▪
0: Measurement of the local cycle time is stopped
▪
1: Measurement of the local cycle time is started
The entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 are updated with the maximum measured values.
For a subsequent measurement the measured values are reset
UINT16
RW
0x0000 (0dec)
1C32:09
Delay time
Time between SYNC1 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:0B
SM event missed counter
Number of missed SM events in OPERATIONAL (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:0C
Cycle exceeded counter
Number of occasions the cycle time was exceeded in OPERATIONAL (cycle was not completed in time or the next cycle began too early)
UINT16
RO
0x0000 (0dec)
1C32:0D
Shift too short counter
Number of occasions that the interval between SYNC0 and SYNC1 event was too short (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:20
Sync error
The synchronization was not correct in the last cycle (outputs were output too late; DC mode only)
BOOLEAN
RO
0x00 (0dec)
Index 0x1C33 SM input parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (no outputs available)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (outputs available)
UINT16
RW
0x0022 (34dec)
1C33:02
Cycle time
as 0x1C32:02
UINT32
RW
0x001E8480 (2000000dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: Synchron with SM 2 Event is supported (outputs available)
▪
Bit 1: Synchron with SM 3 Event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: Input Shift through local event (outputs available)
▪
Bit 4-5 = 10: Input Shift with SYNC1 Event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08 or 0x1C33:08)
UINT16
RO
0xC007 (49159dec)
1C33:05
Minimum cycle time
as 0x1C32:05
UINT32
RO
0x00000000 (0dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:08
Command
as 0x1C32:08
UINT16
RW
0x0000 (0dec)
1C33:09
Delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:0B
SM event missed counter
as 0x1C32:11
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
as 0x1C32:12
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
as 0x1C32:13
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
as 0x1C32:32
BOOLEAN
RO
0x00 (0dec)


Profile-specific objects (0x6000-0xFFFF)

Commissioning [image] EL2521-xxxx [image] Enhanced operation mode [image] EL2521-0000, EL2521-0024, EL2521-0025 [image] Object description and parameterization - enhanced operation mode [image] Profile-specific objects (0x6000-0xFFFF)
Profile-specific objects (0x6000-0xFFFF)
The profile-specific objects have the same meaning for all EtherCAT slaves that support the profile 5001.
Index 0x6000 Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
6000:0 | Inputs | Max. Subindex | UINT8 | RO | 0x02 (2dec)
6000:01 | Status | Status Word | UINT16 | RO | 0x0000 (0dec)
6000:02 | Data In | Input process data (counter value, index 0x6020:11) | UINT16 | RO | 0x0000 (0dec)
Index 0x6010 PTO Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
6010:0 | PTO Inputs | Max. Subindex | UINT8 | RO | 0x10 (16dec)
6010:01 | Sel. Ack/End counter | Confirms the change of the base frequency with activated travel distance control: target counter value reached | BOOLEAN | RO | 0x00 (0dec)
6010:02 | Ramp active | Ramp is currently being followed | BOOLEAN | RO | 0x00 (0dec)
6010:05 | Status of input target | Status of the input TARGET (T) | BOOLEAN | RO | 0x00 (0dec)
6010:06 | Status of input zero | Status of the input ZERO (Z) | BOOLEAN | RO | 0x00 (0dec)
6010:07 | Error | General error bit, is set together with overrange and underrange | BOOLEAN | RO | 0x00 (0dec)
6010:0E | Sync Error | The Sync error bit is only required for Distributed Clocks mode. It indicates whether a synchronization error has occurred during the previous cycle. | BOOLEAN | RO | 0x00 (0dec)
6010:10 | TxPDO Toggle | The TxPDO Toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
Index 0x6020 ENC Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
6020:0 | ENC Inputs | Max. Subindex | UINT8 | RO | 0x16 (22dec)
6020:03 | Set counter done | Counter was set. | BOOLEAN | RO | 0x00 (0dec)
6020:04 | Counter underflow | This bit is set if the 16-bit counter underflows (0 -> 65535). It is reset when the counter drops below two thirds of its measuring range (43690 -> 43689) or immediately an overflow occurs. | BOOLEAN | RO | 0x00 (0dec)
6020:05 | Counter overflow | This bit is set if the 16-bit counter overflows (65535 -> 0). It is reset when the counter exceeds one third of its measuring range (21845 -> 21846) or immediately an underflow occurs. | BOOLEAN | RO | 0x00 (0dec)
6020:0E | Sync Error | The Sync error bit is only required for Distributed Clocks mode. It indicates whether a synchronization error has occurred during the previous cycle. | BOOLEAN | RO | 0x00 (0dec)
6020:10 | TxPDO Toggle | The TxPDO Toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
6020:11 | Counter value | Counter value | UINT32 | RO | 0x00000000 (0dec)
Index 0x7000 Outputs
Index (hex) | Name | Meaning | Data type | Flags | Default
7000:0 | Outputs | Max. Subindex | UINT8 | RO | 0x02 (2dec)
7000:01 | Ctrl | Control Word | UINT16 | RO | 0x0000 (0dec)
7000:02 | Data Out | Output process data (frequency value, index 0x7010:11) | UINT16 | RO | 0x0000 (0dec)
Index 0x7010 PTO Outputs
Index (hex) | Name | Meaning | Data type | Flags | Default
7010:0 | PTO Outputs | Max. Subindex | UINT8 | RO | 0x12 (18dec)
7010:01 | Frequency select | Fast toggling of the base frequency (only if ramp function is deactivated) 0bin = base frequency 1 (object 8001:02 0x8010:12) 1bin = base frequency 2 (object 8001:03 0x8010:13) | BOOLEAN | RO | 0x00 (0dec)
7010:02 | Disable ramp | The ramp function is disabled despite active object 0x8000:06 0x8010:06; if travel distance control is active, it is aborted by this bit. | BOOLEAN | RO | 0x00 (0dec)
7010:03 | Go counter | With travel distance control activated (object 0x8000:0A 0x8010:0A) and bit set, a specified counter value is driven to | BOOLEAN | RO | 0x00 (0dec)
7010:11 | Frequency value | Frequency value | UINT16 | RO | 0x0000 (0dec)
7010:12 | Target counter value | Target counter value | UINT32 | RO | 0x00000000 (0dec)
Index 0x7020 ENC Outputs
Index (hex) | Name | Meaning | Data type | Flags | Default
7020:0 | ENC Outputs | Max. Subindex | UINT8 | RO | 0x11 (17dec)
7020:03 | Set counter | Set counter value | BOOLEAN | RO | 0x00 (0dec)
7020:11 | Set counter value | Counter value to be set via index 0x7020:03 | UINT32 | RO | 0x00000000 (0dec)
Index 0xA000 Diagnostic parameter
Index (hex) | Name | Meaning | Data type | Flags | Default
A000:0 | Diagnostic parameter | Max. Subindex | UINT8 | RO | 0x01 (1dec)
A000:01 | Counter extension | Counter extension | UINT16 | RO | 0x0000 (0dec)
Index 0xF000 Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0003 (3dec)
Index 0xF008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | currently reserved | UINT32 | RW | 0x00000000 (0dec)
Index 0xF010 Module list
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list | Max. Subindex | UINT8 | RW | 0x03 (3dec)
F010:01 | SubIndex 001 | - | UINT32 | RW | 0x000000FC (252dec)
F010:02 | SubIndex 002 | - | UINT32 | RW | 0x000000FD (253dec)
F010:03 | SubIndex 003 | - | UINT32 | RW | 0x000001FF (511dec)


EL2521-0124

Commissioning [image] EL2521-xxxx [image] Enhanced operation mode [image] EL2521-0124
EL2521-0124
Additional information
•
Object description and parameterization - enhanced operation mode


Object description and parameterization - enhanced operation mode

Commissioning [image] EL2521-xxxx [image] Enhanced operation mode [image] EL2521-0124 [image] Object description and parameterization - enhanced operation mode
Object description and parameterization - enhanced operation mode
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Parameterization via the CoE list (CAN over EtherCAT)
The terminal is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs). Please note the following general CoE information when using/manipulating the CoE parameters:
•
Keep a startup list if components have to be replaced
•
Differentiation between online/offline dictionary, existence of current XML description
•
“CoE-Reload” for resetting the changes
Introduction
The CoE overview contains objects for different intended applications:
▪
Objects required for parameterization during commissioning
▪
Objects intended for regular operation, e.g. through ADS access.
▪
Objects for indicating internal settings (may be fixed)
The following section first describes the objects required for normal operation, followed by a complete overview of missing objects.
Additional information
•
Objects for commissioning
•
Objects for regular operation
•
Standard objects (0x1000-0x1FFF)
•
Profile-specific objects (0x6000-0xFFFF)


Objects for commissioning

Commissioning [image] EL2521-xxxx [image] Enhanced operation mode [image] EL2521-0124 [image] Object description and parameterization - enhanced operation mode [image] Objects for commissioning
Objects for commissioning
Index 0x1011 Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default settings | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" in the Set Value Dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)
Index 0x8000 PTA Settings
Index (hex) | Name | Meaning | Data type | Flags | Default
8000:0 | PTO Settings | Max. Subindex | UINT8 | RO | 0x18 (24dec)
8000:02 | Emergency ramp active | TRUE If the watchdog timer responds, the terminal ramps with the time constant set in object 8000:18 to the value set in object 0x8000:11. FALSE The function is deactivated | BOOLEAN | RW | 0x00 (0dec)
8000:03 | Watchdog timer inactive | TRUE The watchdog timer is deactivated FALSE The watchdog timer is activated in the delivery state. Either the manufacturer's of the user's switch-on value is output if the watchdog overflows | BOOLEAN | RW | 0x00 (0dec)
8000:04 | Sign/amount representation | TRUE The output value is displayed in signed amount representation: -2dec= 0x8002 -1dec= 0x8001 1dec= 0x0001 2dec= 0x0002 FALSE The output value is output as signed integer in the two's complement: -2dec= 0xFFFE -1dec= 0xFFFF 1dec= 0x0001 2dec= 0x0002 | BOOLEAN | RW | 0x00 (0dec)
8000:06 | Ramp function active | TRUE Ramp function activated FALSE Ramp function deactivated | BOOLEAN | RW | 0x01 (1dec)
8000:07 | Ramp base frequency | 0(dec) Ramp base frequency: 10 Hz (pull-down menu) 1(dec) Ramp base frequency: 1 kHz (pull-down menu) | BIT1 | RW | 0x00 (0dec)
8000:08 | Direct input mode | TRUE Direct input mode Relative input mode | BOOLEAN | RW | 0x00 (0dec)
8000:09 | User switch-on value on wdt | TRUE Behavior with triggered watchdog timer: User switch-on value FALSE Behavior with triggered watchdog timer: Manufacturer's switch-on value | BOOLEAN | RW | 0x00 (0dec)
8000:0A | Travel distance control active | TRUE Travel distance control activated FALSE Travel distance control deactivated | BOOLEAN | RW | 0x00 (0dec)
8000:0B | Output set active low | Inversion of the output logic for output 24 V 0: HIGH level in switched state 1: LOW level in switched state | BOOLEAN | RW | 0x00 (0dec)
Index (hex) | Name | Meaning | Data type | Flags | Default
8000:0E | Operating mode | 0(dec) Frequency modulation operating mode (pull-down menu) 1(dec) Pulse direction specification operating mode (pull-down menu) 2(dec) Incremental encoder operating mode (pull-down menu) | BIT2 | RW | 0x00 (0dec)
8000:10 | Negative logic | TRUE Negative logic FALSE Positive logic | BOOLEAN | RW | 0x00 (0dec)
8000:11 | User switch-on-value | User switch-on value (frequency) | UINT16 | RW | 0x0000 (0dec)
8000:12 | Base frequency 1 | Base frequency 1 = 50000 Hz | UINT32 | RW | 0x0000C350 (50000dec)
8000:13 | Base frequency 2 | Base frequency 2 = 100000 Hz | UINT32 | RW | 0x000186A0 (100000dec)
8000:14 | Ramp time constant (rising) | Ramp time constant (rising) | UINT16 | RW | 0x03E8 (1000dec)
8000:15 | Ramp time constant (falling) | Ramp time constant (falling) | UINT16 | RW | 0x03E8 (1000dec)
8000:16 | Frequency factor (digit x 10 mHz) | Frequency factor (direct input, digit x 10 mHz) | UINT16 | RW | 0x0064 (100dec)
8000:17 | Slowing down frequency | Slowing down frequency, travel distance control | UINT16 | RW | 0x0032 (50dec)
8000:18 | Ramp time constant (emergency) | Ramp time constant for controlled switch-off; User switch-on value is driven to (object 0x8000:11) | UINT16 | RW | 0x03E8 (1000dec)


Objects for regular operation

Commissioning [image] EL2521-xxxx [image] Enhanced operation mode [image] EL2521-0124 [image] Object description and parameterization - enhanced operation mode [image] Objects for regular operation
Objects for regular operation
In enhanced operating mode the EL2521-0124 has no such objects.


Standard objects (0x1000-0x1FFF)

Commissioning [image] EL2521-xxxx [image] Enhanced operation mode [image] EL2521-0124 [image] Object description and parameterization - enhanced operation mode [image] Standard objects (0x1000-0x1FFF)
Standard objects (0x1000-0x1FFF)
The standard objects have the same meaning for all EtherCAT slaves.
Index 0x1000 Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x00001389 (5001dec)
Index 0x1008 Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EL2521-0124
Index 0x1009 Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO | 03
Index 0x100A Software version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO | 01
Index 0x1018 Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x09D93052 (165228626dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the Low Word (bit 0-15) indicates the special terminal number, the High Word (bit 16-31) refers to the device description | UINT32 | RO | 0x0010007C (1048700dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the Low Byte (bit 0-7) of the Low Word contains the year of production, the High Byte (bit 8-15) of the Low Word contains the week of production, the High Word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 0x10F0 Backup parameter handling
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | Information for standardized loading and saving of backup entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum across all backup entries of the EtherCAT slave | UINT32 | RO | 0x00000000 (0dec)
Index 0x1401 ENC RxPDO-Par Control compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1401:0 | ENC RxPDO-Par Control compact | PDO Parameter RxPDO 2 | UINT8 | RO | 0x06 (6dec)
1401:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 2 | OCTET-STRING[6] | RO | 04 16 05 16 06 16
Index 0x1402 PLS RxPDO-Par Control compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1402:0 | PLS RxPDO-Par Control compact | PDO Parameter RxPDO 3 | UINT8 | RO | 0x06 (6dec)
1402:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 3 | OCTET-STRING[6] | RO | 04 16 05 16 06 16
Index 0x1403 PTO RxPDO-Par Target compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1403:0 | PTO RxPDO-Par Target compact | PDO Parameter RxPDO 4 | UINT8 | RO | 0x06 (6dec)
1403:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 4 | OCTET-STRING[6] | RO | 04 16 05 16 06 16
Index 0x1404 ENC RxPDO-Par Control
Index (hex) | Name | Meaning | Data type | Flags | Default
1404:0 | ENC RxPDO-Par Control | PDO Parameter RxPDO 5 | UINT8 | RO | 0x06 (6dec)
1404:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 5 | OCTET-STRING[6] | RO | 01 16 02 16 03 16
Index 0x1405 PLS RxPDO-Par Control
Index (hex) | Name | Meaning | Data type | Flags | Default
1405:0 | PLS RxPDO-Par Control | PDO Parameter RxPDO 6 | UINT8 | RO | 0x06 (6dec)
1405:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 6 | OCTET-STRING[6] | RO | 01 16 02 16 03 16
Index 0x1406 PTO RxPDO-Par Target
Index (hex) | Name | Meaning | Data type | Flags | Default
1406:0 | PTO RxPDO-Par Target | PDO Parameter RxPDO 7 | UINT8 | RO | 0x06 (6dec)
1406:06 | Exclude RxPDOs | Specifies the RxPDOs (index of RxPDO mapping objects) that must not be transferred together with RxPDO 7 | OCTET-STRING[6] | RO | 01 16 02 16 03 16
Index 0x1600 PTO RxPDO-Map Control
Index (hex) | Name | Meaning | Data type | Flags | Default
1600:0 | PTO RxPDO-Map Control | PDO Mapping RxPDO 1 | UINT8 | RO | 0x06 (6dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (PTO Outputs), entry 0x01 (Frequency select)) | UINT32 | RO | 0x7000:01, 1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (PTO Outputs), entry 0x02 (Disable ramp)) | UINT32 | RO | 0x7000:02, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (PTO Outputs), entry 0x03 (Go counter)) | UINT32 | RO | 0x7000:03, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1600:05 | SubIndex 005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1600:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7000 (PTO Outputs), entry 0x11 (Frequency value)) | UINT32 | RO | 0x7000:11, 16
Index 0x1601 ENC RxPDO-Map Control compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1601:0 | ENC RxPDO-Map Control compact | PDO Mapping RxPDO 2 | UINT8 | RO | 0x07 (7dec)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7010:02, 1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7010:03, 1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7010:04, 1
1601:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1601:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1601:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7010:11, 16
Index 0x1602 PLS RxPDO-Map Control compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1602:0 | PLS RxPDO-Map Control compact | PDO Mapping RxPDO 3 | UINT8 | RO | 0x07 (7dec)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (PLS Outputs), entry 0x01 (Enable PLS)) | UINT32 | RO | 0x7020:01, 1
1602:02 | SubIndex 002 | 2. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1602:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7020 (PLS Outputs), entry 0x04 (Output)) | UINT32 | RO | 0x7020:04, 1
1602:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1602:05 | SubIndex 005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1602:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7020 (PLS Outputs), entry 0x11 (Switch on value)) | UINT32 | RO | 0x7020:11, 16
1602:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7020 (PLS Outputs), entry 0x12 (Switch off value)) | UINT32 | RO | 0x7020:12, 16
Index 0x1603 PTO RxPDO-Map Target compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1603:0 | PTO RxPDO-Map Target compact | PDO Mapping RxPDO 4 | UINT8 | RO | 0x01 (1dec)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (PTO Outputs), entry 0x12 (Target counter value)) | UINT32 | RO | 0x7000:12, 16
Index 0x1604 ENC RxPDO-Map Control
Index (hex) | Name | Meaning | Data type | Flags | Default
1604:0 | ENC RxPDO-Map Control | PDO Mapping RxPDO 5 | UINT8 | RO | 0x07 (7dec)
1604:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1604:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7010:02, 1
1604:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7010:03, 1
1604:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7010:04, 1
1604:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1604:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1604:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7010:11, 32
Index 0x1605 PLS RxPDO-Map Control
Index (hex) | Name | Meaning | Data type | Flags | Default
1605:0 | PLS RxPDO-Map Control | PDO Mapping RxPDO 6 | UINT8 | RO | 0x07 (7dec)
1605:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (PLS Outputs), entry 0x01 (Enable PLS)) | UINT32 | RO | 0x7020:01, 1
1605:02 | SubIndex 002 | 2. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1605:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7020 (PLS Outputs), entry 0x04 (Output)) | UINT32 | RO | 0x7020:04, 1
1605:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1605:05 | SubIndex 005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1605:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7020 (PLS Outputs), entry 0x11 (Switch on value)) | UINT32 | RO | 0x7020:11, 32
1605:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7020 (PLS Outputs), entry 0x12 (Switch off value)) | UINT32 | RO | 0x7020:12, 32
Index 0x1606 PTO RxPDO-Map Target
Index (hex) | Name | Meaning | Data type | Flags | Default
1606:0 | PTO RxPDO-Map Target | PDO Mapping RxPDO 7 | UINT8 | RO | 0x01 (1dec)
1606:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (PTO Outputs), entry 0x12 (Target counter value)) | UINT32 | RO | 0x7000:12, 32
Index 0x1801 ENC TxPDO-Par Status compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1801:0 | ENC TxPDO-Par Status compact | PDO parameter TxPDO 2 | UINT8 | RO | 0x09 (9dec)
1801:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 2 | OCTET-STRING[2] | RO | 04 1A
1801:09 | TxPDO Toggle | The TxPDO toggle is toggled with each update the corresponding input data | BOOLEAN | RO | 0x00 (0dec)
Index 0x1804 ENC TxPDO-Par Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1804:0 | ENC TxPDO-Par Status | PDO parameter TxPDO 5 | UINT8 | RO | 0x09 (9dec)
1804:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 5 | OCTET-STRING[2] | RO | 01 1A
1804:09 | TxPDO Toggle | The TxPDO toggle is toggled with each update the corresponding input data | BOOLEAN | RO | 0x00 (0dec)
Index 0x1A00 PTO TxPDO-Map Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1A00:0 | PTO TxPDO-Map Status | PDO Mapping TxPDO 1 | UINT8 | RO | 0x08 (8dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (PTO Inputs), entry 0x01 (Sel. Ack/End counter)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (PTO Inputs), entry 0x02 (Ramp active)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (PTO Inputs), entry 0x07 (Error)) | UINT32 | RO | 0x6000:07, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1800, entry 0x09) | UINT32 | RO | 0x1800:09, 1
Index 0x1A01 ENC TxPDO-Map Status compact
Index (hex) | Name | Meaning | Data type | Flags | Default
1A01:0 | ENC TxPDO-Map Status compact | PDO Mapping TxPDO 2 | UINT8 | RO | 0x0D (13dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6010:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6010:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6010:04, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6010:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6010:0D, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x1801 (ENC TxPDO-Par Status compact), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1801:09, 1
1A01:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6010:11, 16
1A01:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x12 (Latch value)) | UINT32 | RO | 0x6010:12, 16
Index 0x1A02 PLS TxPDO-Map Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1A02:0 | PLS TxPDO-Map Status | PDO Mapping TxPDO 3 | UINT8 | RO | 0x07 (7dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (PLS Inputs), entry 0x01 (PLS Enabled)) | UINT32 | RO | 0x6020:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (PLS Inputs), entry 0x04 (Status of output)) | UINT32 | RO | 0x6020:04, 1
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (9 bits align) | UINT32 | RO | 0x0000:00, 9
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x1802, entry 0x09) | UINT32 | RO | 0x1802:09, 1
Index 0x1A04 ENC TxPDO-Map Status
Index (hex) | Name | Meaning | Data type | Flags | Default
1A04:0 | ENC TxPDO-Map Status | PDO Mapping TxPDO 5 | UINT8 | RO | 0x0D (13dec)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6010:02, 1
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6010:03, 1
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6010:04, 1
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6010:05, 1
1A04:06 | SubIndex 006 | 6. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1A04:07 | SubIndex 007 | 7. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A04:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6010:0D, 1
1A04:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A04:0A | SubIndex 010 | 10. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A04:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x1804 (ENC TxPDO-Par Status), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1804:09, 1
1A04:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6010:11, 32
1A04:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x12 (Latch value)) | UINT32 | RO | 0x6010:12, 32
Index 0x1C00 Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the Sync Managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 0x1C12 RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x03 (3dec)
1C12:01 | SubIndex 001 | 1. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1600 (5632dec)
1C12:02 | SubIndex 002 | 2. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1601 (5633dec)
1C12:03 | SubIndex 003 | 3. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1602 (5634dec)
1C12:04 | SubIndex 004 | 4. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 0x1C13 TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x03 (3dec)
1C13:01 | SubIndex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | SubIndex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A01 (6657dec)
1C13:03 | SubIndex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A02 (6658dec)
Index 0x1C32 SM output parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C32:0
SM output parameter
Synchronization parameters for the outputs
UINT8
RO
0x20 (32dec)
1C32:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dec)
1C32:02
Cycle time
Cycle time (in ns):
▪
Free Run: Cycle time of the local timer
▪
Synchron with SM 2 Event: Master cycle time
▪
DC mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x001E8480 (2000000dec)
1C32:03
Shift time
Time between SYNC0 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0 = 1: free run is supported
▪
Bit 1 = 1: Synchron with SM 2 Event is supported
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 10: Output Shift with SYNC1 event (only DC mode)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08)
UINT16
RO
0xC007 (49159dec)
1C32:05
Minimum cycle time
Minimum cycle time (in ns)
UINT32
RO
0x00000000 (0dec)
1C32:06
Calc and copy time
Minimum time between SYNC0 and SYNC1 event (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:07
Minimum delay time
UINT32
RO
0x00000000 (0dec)
1C32:08
Command
▪
0: Measurement of the local cycle time is stopped
▪
1: Measurement of the local cycle time is started
The entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 are updated with the maximum measured values.
For a subsequent measurement the measured values are reset
UINT16
RW
0x0000 (0dec)
1C32:09
Maximum Delay time
Time between SYNC1 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:0B
SM event missed counter
Number of missed SM events in OPERATIONAL (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:0C
Cycle exceeded counter
Number of occasions the cycle time was exceeded in OPERATIONAL (cycle was not completed in time or the next cycle began too early)
UINT16
RO
0x0000 (0dec)
1C32:0D
Shift too short counter
Number of occasions that the interval between SYNC0 and SYNC1 event was too short (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:20
Sync error
The synchronization was not correct in the last cycle (outputs were output too late; DC mode only)
BOOLEAN
RO
0x00 (0dec)
Index 0x1C33 SM input parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (no outputs available)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (outputs available)
UINT16
RW
0x0022 (34dec)
1C33:02
Cycle time
as 0x1C32:02
UINT32
RW
0x001E8480 (2000000dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: Synchron with SM 2 Event is supported (outputs available)
▪
Bit 1: Synchron with SM 3 Event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: Input Shift through local event (outputs available)
▪
Bit 4-5 = 10: Input Shift with SYNC1 Event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08 or 0x1C33:08)
UINT16
RO
0xC007 (49159dec)
1C33:05
Minimum cycle time
as 0x1C32:05
UINT32
RO
0x00000000 (0dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:07
Minimum delay time
UINT32
RO
0x00000000 (0dec)
1C33:08
Command
as 0x1C32:08
UINT16
RW
0x0000 (0dec)
1C33:09
Maximum Delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:0B
SM event missed counter
as 0x1C32:11
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
as 0x1C32:12
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
as 0x1C32:13
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
as 0x1C32:32
BOOLEAN
RO
0x00 (0dec)


Profile-specific objects (0x6000-0xFFFF)

Commissioning [image] EL2521-xxxx [image] Enhanced operation mode [image] EL2521-0124 [image] Object description and parameterization - enhanced operation mode [image] Profile-specific objects (0x6000-0xFFFF)
Profile-specific objects (0x6000-0xFFFF)
The profile-specific objects have the same meaning for all EtherCAT slaves that support the profile 5001.
Index 0x6000 PTO Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
6000:0 | PTO Inputs | Max. Subindex | UINT8 | RO | 0x10 (16dec)
6000:01 | Sel. Ack/End counter | Confirms the change of the base frequency with activated travel distance control: target counter value reached | BOOLEAN | RO | 0x00 (0dec)
6000:02 | Ramp active | Ramp is currently being followed | BOOLEAN | RO | 0x00 (0dec)
6000:07 | Error | General error bit, is set together with overrange and underrange | BOOLEAN | RO | 0x00 (0dec)
6000:0E | Sync error | The Sync error bit is only required for Distributed Clocks mode. It indicates whether a synchronization error has occurred during the previous cycle. | BOOLEAN | RO | 0x00 (0dec)
6000:10 | TxPDO Toggle | The TxPDO Toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
Index 0x6010 ENC Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
6010:0 | ENC Inputs | Max. Subindex | UINT8 | RO | 0x12 (18dec)
6010:02 | Latch extern valid | The counter value was locked by the external latch input. The data with index 0x6010:12 match the latched value when the bit is set. To reactivate the latch input, index 0x7010:02 or object index 0x7010:04 must be canceled and then reset. | BOOLEAN | RO | 0x00 (0dec)
6010:03 | Set counter done | Counter was set. | BOOLEAN | RO | 0x00 (0dec)
6010:04 | Counter underflow | This bit is set if the 16-bit counter underflows (0 -> 65535). It is reset when the counter drops below two thirds of its measuring range (43690 -> 43689) or immediately an overflow occurs. | BOOLEAN | RO | 0x00 (0dec)
6010:05 | Counter overflow | This bit is set if the 16-bit counter overflows (65535 -> 0). It is reset when the counter exceeds one third of its measuring range (21845 -> 21846) or immediately an underflow occurs. | BOOLEAN | RO | 0x00 (0dec)
6010:0D | Status of extern latch | The status of the latch input | BOOLEAN | RO | 0x00 (0dec)
6010:0E | Sync error | The Sync error bit is only required for Distributed Clocks mode. It indicates whether a synchronization error has occurred during the previous cycle. | BOOLEAN | RO | 0x00 (0dec)
6010:10 | TxPDO Toggle | The TxPDO Toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
6010:11 | Counter value | Counter value | UINT32 | RO | 0x00000000 (0dec)
6010:12 | Latch value | Latch value | UINT32 | RO | 0x00000000 (0dec)
Index 0x6020 PLS Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
6020:0 | PLS Inputs | Max. Subindex | UINT8 | RO | 0x10 (16dec)
6020:01 | PLS Enabled | Automatic counting function activated | BOOLEAN | RO | 0x00 (0dec)
6020:04 | Status of output | Status of the output | BOOLEAN | RO | 0x00 (0dec)
6020:0E | Sync error | The Sync error bit is only required for Distributed Clocks mode. It indicates whether a synchronization error has occurred during the previous cycle. | BOOLEAN | RO | 0x00 (0dec)
6020:10 | TxPDO Toggle | The TxPDO Toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
Index 0x7000 PTO Outputs
Index (hex) | Name | Meaning | Data type | Flags | Default
7000:0 | PTO Outputs | Max. Subindex | UINT8 | RO | 0x12 (18dec)
7000:01 | Frequency select | Fast toggling of the base frequency (only if ramp function is deactivated) 0bin = base frequency 1 (object 0x8000:12) 1bin = base frequency 2 (object 0x8000:13) | BOOLEAN | RO | 0x00 (0dec)
7000:02 | Disable ramp | The ramp function is disabled despite active object 0x8000:06; if the travel distance control is active, it is aborted by this bit. | BOOLEAN | RO | 0x00 (0dec)
7000:03 | Go counter | If travel distance control is activated (object 0x8000:0A), a specified counter value is driven to if the bit is set | BOOLEAN | RO | 0x00 (0dec)
7000:11 | Frequency value | Frequency value | UINT16 | RO | 0x0000 (0dec)
7000:12 | Target counter value | Target counter value | UINT32 | RO | 0x00000000 (0dec)
Index 0x7010 ENC Outputs
Index (hex) | Name | Meaning | Data type | Flags | Default
7010:0 | ENC Outputs | Max. Subindex | UINT8 | RO | 0x11 (17dec)
7010:02 | Enable latch extern on positive edge | Activate external latch with positive edge. | BOOLEAN | RO | 0x00 (0dec)
7010:03 | Set counter | Set counter value | BOOLEAN | RO | 0x00 (0dec)
7010:04 | Enable latch extern on negative edge | Activate external latch with negative edge. | BOOLEAN | RO | 0x00 (0dec)
7010:11 | Set counter value | This is the counter value to be set via "Set counter" (index 0x7010:03). | UINT32 | RO | 0x00000000 (0dec)
Index 0x7020 PLS Outputs
Index (hex) | Name | Meaning | Data type | Flags | Default
7020:0 | PLS Outputs | Max. Subindex | UINT8 | RO | 0x12 (18dec)
7020:01 | Enable PLS | Activate automatic counting function | BOOLEAN | RO | 0x00 (0dec)
7020:04 | Output | Signal at the output | BOOLEAN | RO | 0x00 (0dec)
7020:11 | Switch-on value | Counter value at which the 24 V output is switched on | UINT32 | RO | 0x00000000 (0dec)
7020:12 | Switch-off value | Counter value at which the 24 V output is switched off | UINT32 | RO | 0x00000000 (0dec)
Index 0xF000 Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0003 (3dec)
Index 0xF008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | currently reserved | UINT32 | RW | 0x00000000 (0dec)
Index 0xF010 Module list
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list | Max. Subindex | UINT8 | RW | 0x03 (3dec)
F010:01 | SubIndex 001 | Reserved | UINT32 | RW | 0x000000FD (253dec)
F010:02 | SubIndex 002 | reserved | UINT32 | RW | 0x000001FF (511dec)
F010:03 | SubIndex 003 | reserved | UINT32 | RW | 0x00000200 (512dec)


EL2522-0000

Commissioning [image] EL2522-0000
EL2522-0000
Additional information
•
Basic function principles
•
Process Data
•
Object description and parameterization
•
Connection of the EL2522 in the NC


Basic function principles

Commissioning [image] EL2522-0000 [image] Basic function principles
Basic function principles
Operating modes of the EL2522
In addition to the "enhanced operating mode" known from the EL2521, the EL2522 also supports an "enhanced operating mode with continuous position specification" and an "enhanced operating mode with continuous position specification and arrival time".
As an extension to the EL2521, the EL2522 offers the "enhanced operating mode" in single-channel or single operating mode with A-, B- and C-track (zero track / reference) or in 2-channel or double operating mode, each with A- and B-track.
Version | PDO settings | Comments | FW/HW | ESI | Process data | CoE parameters
Legacy | formerly MDP 252 | not available for the EL2522 | - | - | - | -
enhanced operating mode | 1 Ch. Standard 16 Bit (MDP 253/511) 2 Ch. Standard 16 Bit (MDP 253/511) 1 Ch. Standard 32 Bit (MDP 253/511) 2 Ch. Standard 32 Bit (MDP 253/511) | 1 Ch.: with C-track | from 02 | from EL2522-0000 -0000 | PDO Assignment Inputs: 1A00, 1A02 Outputs: 1600, 1602, 160A | Feature bits and settings in CoE objects (hex) 8000, 8010, 8020 and 8030
enhanced operating mode with continuous position specification | 1 Ch. Standard 32 Bit (MDP 253/511), continues position 2 Ch. Standard 32 Bit (MDP 253/511), continues position | 1 Ch.: with C-track; path without ramp, DC-Synchronous must be selected | from 02 | from EL2522-0000 | PDO Assignment Inputs: 1A03 Outputs: 160B, 1601
enhanced operating mode with continuous position specification and arrival time | 1 Ch. Standard 32 Bit (MDP 253/511), continues position, with arrival time 2 Ch. Standard 32 Bit (MDP 253/511), continues position, with arrival time | 1 Ch.: with C-track; path without ramp, specification of arrival time possible (target time); DC-Synchronous must be selected | from 02 | from EL2522-0000 | PDO Assignment Inputs: 1A03 Outputs: 160B, 1601, 1604
Output modes of the EL2522
The EL2522 has three different output modes. A choice can be made between the output modes "Frequency modulation (value: 0)", "Pulse direction specification (value: 1)" and "Incremental encoder (value: 2)" via index 0x8000:0E for incremental encoder 1 or index 0x8010:0E for incremental encoder 2. In addition, the EL2522 operates cycle-synchronously when using the "continuous position" PDO presets and thus generates pinpoint output control clock signals synchronously with the task cycle. With the additional selection "continuous position w. arrival time", a target time in which a target position is to be reached is specified instead of a frequency. The clock signals are also output cycle-synchronously in this case, too, as long as this specification is within the plausible range.
Output modes | Meaning | Index 0x8000:0E value
Frequency modulation | Only one channel is active per direction, on which a frequency-modulated signal is output. The clockwise direction is realized via channel A, the counter clockwise direction via channel B. | 0
Pulse direction setting | The direction is controlled by channel B. The clockwise direction is represented by a low level and the counter clockwise direction by a high level. The actual signal, conversely, is output in modulated form via channel A. | 1
Incremental encoder | The direction is defined by the shifting of channels A and B. If channel A leads by 90°, this indicates a "forward" movement. If channel B leads by 90°, this indicates a "reverse" movement. In the 1-channel variant the C-track (zero track) can additionally be output. | 2
Process data monitoring
•
WcState: if ≠ 0, this EtherCAT device does not take part in the process data traffic
•
State: if ≠ 8, the EtherCAT device is not in OP (operational) status
•
TxPDO state, SyncError: if ≠ 0, then no valid process data are available, e.g. caused by broken wire
•
TxPDO Toggle: If this bit toggles, a new set of process data is available
Delivery state
Independent of the hardware/firmware version, an EL2522 newly integrated in the system registers itself in the operating mode "2-channel standard 32-bit (MDP 253/511)".
Enhanced operating mode: Incremental encoder simulation
The "enhanced operating mode (253/511)" is the enhanced operating mode familiar from the EL2521. Please refer to the corresponding chapter of the EL2521 (see also chapter EL2521 function) for an explanation of the functionality and the steps necessary for commissioning.
Unlike the EL2521, it is possible to choose between a 1-channel and a 2-channel operating mode (single or double operation). In 1-channel operating mode a C-track is output in addition to the A- and B-tracks. In 2-channel operating mode two outputs are offered per channel, each with an A- and a B-track. Both behave in the same way as the known 1-channel operating mode.
Enhanced operating mode: Incremental encoder simulation with continuous position specification.
In the operating modes 1-channel standard 32-bit, continuous position, and 2-channel standard 32-bit, continuous position, the EL2522 can simulate an incremental encoder with A-, B- and C-tracks (1-channel or single operating mode) or two independent incremental encoders (2-channel or double operating mode), each with an A- and a B-track. As previously with the EL2521 there is also a choice here between the output modes incremental encoder, frequency modulation or pulse direction control.
Basically, the clock signals are output here cycle-synchronously (necessary selection in the EL2522 DC settings: DC-synchronous).
After selection of the respective PDO assignment, the associated process data are represented in accordance with the following illustration.
Fig. 2: Representation of the process data according to the PDO selection "1-channel standard 32-bit, continuous position" in the TwinCAT System Manager.
The output value "Target counter value" is written with the desired target position for the next cycle. Depending on the current position (input value "Counter Value"), the EL2522 calculates the frequency necessary for reaching the desired position in the next cycle. A fixed running direction can be specified by the output bits "Forward" and "Reverse". If the "Automatic direction" bit is set, the terminal selects the running direction depending on the position difference (actual and target value) in favor of the shorter distance.
If 2-channel mode is in use, the process data for the second incremental encoder are added analogously to those for the first.
Enhanced operating mode: Incremental encoder simulation with continuous position specification and arrival time
In addition to the functions mentioned above, it is possible in the operating mode "continuous position specification and arrival time" to define when the target position should be reached. Consequently, the calculation no longer takes place with the specification of the target position to be reached in the next cycle, but taking into account an arrival time specified by the user instead.
Representation of the process data according to the PDO selection "1-channel standard 32-bit, continuous position w. arrival time" in the TwinCAT System Manager.
The desired target time for reaching the target position can be specified by the output value "Target Arrival Time". The frequency is then calculated accordingly. If the calculated frequency should be higher than the set maximum frequency ("Base Frequency 1": incremental encoder 1: index 0x8000:12 or incremental encoder 2: index 0x8010:12), then the frequency is limited to this value and the target position is accordingly reached at a later time.
Use of micro-increments
When using micro-increments, care must be taken that the internal 100 MHz is not exceeded. Example: -cycle time 1 ms – 15-bit micro-increments. If three "genuine" increments should be output in a cycle, that is already (3 x 2^15 ) / 1 ms = approx. 98 MHz.
Setting the counter value / zero calibration (A/B adaptation)
The counter value can be manually set. To do this, the desired counter value must be entered in the index 0x7020:11 (Set counter Value). If index 0x7020:03 (Set Counter) is now set, the counter value is adopted. At the same time, the parameters for the running direction must be set to FALSE (Automatic Direction, Forward, Backward, 0x7000:04 – 0x7000:06). If the counter value is set to "0", the C-track goes into the "high" state. The behavior of channels A and B in this case can be defined by index 80x0:01 "Adapt A/B on position set". By default the value is FALSE; the position of the C-track relative to A and B is then not changed. If the value is set to TRUE, channels A and B are both set to high. Consequently, a change of state occurs on both channels!
Function: automatic adoption of the target value
In the enhanced operating modes "continuous position specification" and "continuous position specification with arrival time" a threshold value (object 0x8020:1A for incremental encoder 1, object 0x8030:1A for incremental encoder 2) can be specified for the automatic adoption of setpoints. If the difference between the setpoint and the actual value exceeds this preset threshold value, the actual value will be overwritten with the setpoint on the next Sync; i.e. the value of the target counter is directly adopted as the counter value WITHOUT incremental encoder clock signals being output.
→ The following steps must be performed in order to use this function.
1.
Activate "DC-Synchronous"
2.
Activate PDOs 0x1A03 (Input) and 0x1603 (Output)
3.
Set the threshold value
Fig. 4: Threshold setting in object 0x8020:1A for incremental encoder 1
Example:
▪
0x8020:1A = "Autoset treshold" = 0x00000100
–
(→ the value is >=1: Autoset Threshold, "Automatic setting" is activated)
▪
Cycle n (setting the target counter value):
–
"Target counter value" = 0x00000200
–
"Counter value" = 0x00000000
→ threshold for automatic setting is exceeded; NO clock signals will be output at the output of the terminal.
▪
The "Target counter Value" is directly adopted into the "Counter value".
–
"Target counter value" = 0x00000200
–
"Counter value" = 0x00000200
▪
Cycle n+1 (resetting the target counter value):
–
"Target counter value" = 0x00000220
–
"Counter value" = 0x00000200
The threshold (0x00000100) is NOT overwritten with the difference between target counter value and current counter value (in this case the value: 0x20) for automatic setting. Therefore clock signals are output at the output of the terminal until the target counter value is reached.
▪
Cycle n+2 (continuation in this operation mode with further target counter values):
–
"Target counter value" = 0x????????
–
"Counter value" = 0x00000220
This function accordingly enables the counter value to be set directly as an alternative to using the object 0x7020:03 (or 0x7030:03) "Set counter".
It is recommended to use the function of the automatic adoption of the setpoint only in special exceptional cases!
Initialization
The actual value is initialized during the transition from SafeOp to Op. The current setpoint is adopted here as the actual value.
Exceeding the maximum frequency
If the set maximum frequency is exceeded when calculating the necessary frequency for reaching the target position within the foreseen period, the maximum frequency is adopted. This leads to "extended" travel distances and should be taken into account and if necessary checked accordingly. The maximum frequency can be set via index 0x8010:12 / 0x8020:12 (Base Frequency 1).


Process Data

Commissioning [image] EL2522-0000 [image] Process Data
Process Data
The process data selection in the System Manager specifies the operation mode of the EL2522.
The process data are entered individually by hand or as "Predefined PDO Assignment" via the "Process Data" tab.
When selecting the EL2522 in the System Manager, the appropriate operation mode can be selected in accordance with the table above by clicking on the "Process Data" tab and selecting the preset PDO assignments.
"Predefined PDO-Assignment" – excerpt from the TwinCAT System Manager on the "Process Data" tab of the EL2522
Eight process data sets are available for the EL2522-0000 and are listed in following table on the basis of the CoE objects used.
Sync Manager (SM)
Process data setting options
The extent of process data can be set via the Process Data tab as described below (2-level incremental encoder settings are presented only):
PDO assignment of the SyncManager
SM1, PDO Assignment 0x1C13, inputs
Index | assigned to PDO setting | Index of excluded PDOs | Size (byte.bit) | Name | PDO Content Index - Name
0x1A00 | 1 Ch. Standard 16 Bit (MDP 253/511) 1 Ch. Standard 32 Bit (MDP 253/511) | 0x1A01, 0x1A03, 0x1A04, 0x1A05 | 2.0 | PTO Status Ch. 1 | 0x6000:01 - Sel. Ack/End counter 0x6000:02 - Ramp active 0x6000:07 - Error 0x6000:0E - Sync error 0x6000:10 - TxPDO Toggle
 | 2 Ch. Standard 16 Bit (MDP 253/511) | 0x1A03, 0x1A05
0x1A01 | 2 Ch. Standard 16 Bit (MDP 253/511) |  | 2.0 | PTO Status Ch. 2
0x1A02 | 1 Ch. Standard 16 Bit (MDP 253/511) | 0x1A01, 0x1A03, 0x1A04, 0x1A05 | 4.0 | ENC Status compact Ch. 1 | 0x6020:03 - Set counter done 0x6020:04 - Counter underflow 0x6020:05 - Counter overflow 0x6020:0E - Sync error 0x6020:0F - TxPDO State 0x6020:10 - TxPDO Toggle 0x6020:11 - Counter value
 | 2 Ch. Standard 16 Bit (MDP 253/511) | 0x1A03, 0x1A05
0x1A03 | 1 Ch. Standard 32 Bit (MDP 253/511) | 0x1A01, 0x1A02, 0x1A04, 0x1A05 | 6.0 | ENC Status Ch. 1
 | 1 Ch. Standard 32 Bit (MDP 253/511), continues position 1 Ch. Standard 32 Bit (MDP 253/511), continues position w. arrival time | 0x1A00, 0x1A01, 0x1A02, 0x1A04, 0x1A05
 | 2 Ch. Standard 32 Bit (MDP 253/511), continuous position | 0x1A00, 0x1A01, 0x1A02, 0x1A04
0x1A04 | 2 Ch. Standard 16 Bit (MDP 253/511) | 0x1A03, 0x1A05 | 4.0 | ENC Status compact Ch. 2
0x1A05 | 2 Ch. Standard 32 Bit (MDP 253/511) | 0x1A02, 0x1A04 | 6.0 | ENC Status Ch. 2
 | 2 Ch. Standard 32 Bit (MDP 253/511), continuous position 2 Ch. Standard 32 Bit (MDP 253/511), continuous position w. arrival time | 0x1A00, 0x1A01, 0x1A02, 0x1A04
SM2, PDO assignment 0x1C12, outputs
Index | assigned to PDO setting | Index of excluded PDOs | Size (byte.bit) | Name | PDO Content Index - Name
0x1600 | 1 Ch. Standard 16 Bit (MDP 253/511) | 0x1601, 0x1603, 0x1604, 0x1605, 0x1606, 0x1607, 0x1608, 0x1609, 0x160B, 0x160C, 0x160D | 4.0 | PTO Control Ch. 1 | 0x7000:01 - Frequency select 0x7000:02 - Disable ramp 0x7000:03 - Go counter 0x7000:11 - Frequency value
 | 2 Ch. Standard 16 Bit (MDP 253/511) | 0x1601, 0x1603, 0x1604, 0x1606, 0x1608, 0x1609, 0x160B, 0x160D
 | 1 Ch. Standard 32 Bit (MDP 253/511) | 0x1601, 0x1602, 0x1604, 0x1605, 0x1606, 0x1607, 0x1608, 0x1609, 0x160A, 0x160C, 0x160D
 | 2 Ch. Standard 32 Bit (MDP 253/511) | 0x1601, 0x1602, 0x1604, 0x1606, 0x1607, 0x1609, 0x160A, 0x160C
0x1601 | 1 Ch. Standard 32 Bit (MDP 253/511), continues position | 0x1600, 0x1602, 0x1604, 0x1605, 0x1606, 0x1607, 0x1608, 0x1609, 0x160A, 0x160C, 0x160D | 6.0 | PTO Control Position Ch. 1 | 0x7000:04 - Automatic direction 0x7000:05 - Forward 0x7000:06 - Backward 0x7000:12 - Target counter value
 | 1 Ch. Standard 32 Bit (MDP 253/511), continues position w. arrival time | 0x1600, 0x1602, 0x1605, 0x1606, 0x1607, 0x1608, 0x1609, 0x160A, 0x160C, 0x160D
 | 2 Ch. Standard 32 Bit (MDP 253/511), continues position | 0x1600, 0x1602, 0x1603, 0x1604, 0x1605, 0x1607, 0x1608, 0x1609, 0x160A, 0x160C
 | 2 Ch. Standard 32 Bit (MDP 253/511), continues position w. arrival time | 0x1600, 0x1602, 0x1603, 0x1604, 0x1605, 0x1607, 0x1608, 0x1609, 0x160A, 0x160C
0x1602 | 1 Ch. Standard 16 Bit (MDP 253/511) | 0x1601, 0x1603, 0x1604, 0x1605, 0x1606, 0x1607, 0x1608, 0x1609, 0x160B, 0x160C, 0x160D | 2.0 | PTO Target compact Ch. 1 | 0x7000:12 - Target counter value
 | 2 Ch. Standard 16 Bit (MDP 253/511) | 0x1601, 0x1603, 0x1604, 0x1606, 0x1608, 0x1609, 0x160B, 0x160D
0x1603 | 1 Ch. Standard 32 Bit (MDP 253/511) | 0x1601, 0x1602, 0x1604, 0x1605, 0x1606, 0x1607, 0x1608, 0x1609, 0x160A, 0x160C, 0x160D | 4.0 | PTO Target Ch. 1 | 0x7000:12 - Target counter value
 | 2 Ch. Standard 32 Bit (MDP 253/511) | 0x1601, 0x1602, 0x1604, 0x1606, 0x1607, 0x1609, 0x160A, 0x160C
0x1604 | 1 Ch. Standard 32 Bit (MDP 253/511), continues position w. arrival time | 0x1600, 0x1602, 0x1605, 0x1606, 0x1607, 0x1608, 0x1609, 0x160A, 0x160C, 0x160D | 8.0 | PTO Arrival Ch. 1 | 0x7000:13 - Target arrival time
 | 2 Ch. Standard 32 Bit (MDP 253/511), continues position w. arrival time | 0x1600, 0x1602, 0x1603, 0x1604, 0x1605, 0x1607, 0x1608, 0x1609, 0x160A, 0x160C
0x1605 | 2 Ch. Standard 16 Bit (MDP 253/511) | 0x1601, 0x1603, 0x1604, 0x1606, 0x1608, 0x1609, 0x160B, 0x160D | 4.0 | PTO Control Ch. 2 | 0x7010:01 - Frequency select 0x7010:02 - Disable ramp 0x7010:03 - Go counter 0x7010:11 - Frequency value
 | 2 Ch. Standard 32 Bit (MDP 253/511) | 0x1601, 0x1602, 0x1604, 0x1606, 0x1607, 0x1609, 0x160A, 0x160C
0x1606 | 2 Ch. Standard 32 Bit (MDP 253/511), continues position | 0x1600, 0x1602, 0x1603, 0x1604, 0x1605, 0x1607, 0x1608, 0x1609, 0x160A, 0x160C | 6.0 | PTO Control Position Ch. 2 | 0x7010:04 - Automatic direction 0x7010:05 - Forward 0x7010:06 - Backward 0x7010:12 - Target counter value
 | 2 Ch. Standard 32 Bit (MDP 253/511), continues position w. arrival time | 0x1600, 0x1602, 0x1603, 0x1604, 0x1605, 0x1607, 0x1608, 0x1609, 0x160A, 0x160C
0x1607 | 2 Ch. Standard 16 Bit (MDP 253/511) | 0x1601, 0x1603, 0x1604, 0x1606, 0x1608, 0x1609, 0x160B, 0x160D | 2.0 | PTO Target compact Ch. 2 | 0x7010:12 - Target counter value
0x1608 | 2 Ch. Standard 32 Bit (MDP 253/511) | 0x1601, 0x1602, 0x1604, 0x1606, 0x1607, 0x1609, 0x160A, 0x160C | 4.0 | PTO Target Ch. 2 | 0x7010:12 - Target counter value
0x1609 | 2 Ch. Standard 32 Bit (MDP 253/511), continues position w. arrival time | 0x1600, 0x1602, 0x1603, 0x1604, 0x1605, 0x1607, 0x1608, 0x1609, 0x160A, 0x160C | 8.0 | PTO Arrival Ch. 2 | 0x7010:13 - Target arrival time
0x160A | 1 Ch. Standard 16 Bit (MDP 253/511) | 0x1601, 0x1603, 0x1604, 0x1605, 0x1606, 0x1607, 0x1608, 0x1609, 0x160B, 0x160C, 0x160D | 4.0 | ENC Control compact Ch. 1 | 0x7020:03 - Set counter (0x7020:10 - Reserved) 0x7020:11 - Set counter value
 | 2 Ch. Standard 16 Bit (MDP 253/511) | 0x1601, 0x1603, 0x1604, 0x1606, 0x1608, 0x1609, 0x160B, 0x160D
0x160B | 1 Ch. Standard 32 Bit (MDP 253/511) | 0x1601, 0x1602, 0x1604, 0x1605, 0x1606, 0x1607, 0x1608, 0x1609, 0x160A, 0x160C, 0x160D | 6.0 | ENC Control Ch. 1 | 0x7020:03 - Set counter (0x7020:10 - Reserved) 0x7020:11 - Set counter value
 | 2 Ch. Standard 32 Bit (MDP 253/511) | 0x1601, 0x1602, 0x1604, 0x1606, 0x1607, 0x1609, 0x160A, 0x160C
 | 1 Ch. Standard 32 Bit (MDP 253/511), continues position | 0x1600, 0x1602, 0x1604, 0x1605, 0x1606, 0x1607, 0x1608, 0x1609, 0x160A, 0x160C, 0x160D
 | 1 Ch. Standard 32 Bit (MDP 253/511), continues position w. arrival time | 0x1600, 0x1602, 0x1605, 0x1606, 0x1607, 0x1608, 0x1609, 0x160A, 0x160C, 0x160D
 | 2 Ch. Standard 32 Bit (MDP 253/511), continues position | 0x1600, 0x1602, 0x1603, 0x1604, 0x1605, 0x1607, 0x1608, 0x1609, 0x160A, 0x160C
 | 2 Ch. Standard 32 Bit (MDP 253/511), continues position w. arrival time | 0x1600, 0x1602, 0x1603, 0x1604, 0x1605, 0x1607, 0x1608, 0x1609, 0x160A, 0x160C
0x160C | 2 Ch. Standard 16 Bit (MDP 253/511) | 0x1601, 0x1603, 0x1604, 0x1606, 0x1608, 0x1609, 0x160B, 0x160D | 4.0 | ENC Control compact Ch. 2 | 0x7030:03 - Set counter (0x7030:10 - Reserved) 0x7030:11 - Set counter value
0x160D | 2 Ch. Standard 32 Bit (MDP 253/511) | 0x1601, 0x1602, 0x1604, 0x1606, 0x1607, 0x1609, 0x160A, 0x160C | 6.0 | ENC Control Ch. 2 | 0x7030:03 - Set counter (0x7030:10 - Reserved) 0x7030:11 - Set counter value
 | 2 Ch. Standard 32 Bit (MDP 253/511), continues position | 0x1600, 0x1602, 0x1603, 0x1604, 0x1605, 0x1607, 0x1608, 0x1609, 0x160A, 0x160C
 | 2 Ch. Standard 32 Bit (MDP 253/511), continues position w. arrival time | 0x1600, 0x1602, 0x1603, 0x1604, 0x1605, 0x1607, 0x1608, 0x1609, 0x160A, 0x160C
PDO setting: 1 Ch. Standard 16 Bit (MDP 253/511)
▪
preset standard configuration in TwinCAT 2.11, TwinCAT 3
▪
so-called compact process image since it has only 16-bit-wide variables
▪
allows linking to NC axes according to MDP 253, subprofile 511
▪
C-track within output mode incremental encoder
1Ch Standard 16 Bit (MDP 253_511).png
Process data and PDO-allocation: Standard 16 Bit (MDP 253/511)
PDO setting: 1 Ch. Standard 32 Bit (MDP 253/511), continues position
▪
32-bit-wide variables
▪
allows linking to NC axes according to MDP 253, subprofile 511
▪
continuous positioning / output cycles cycle-synchronous
▪
Additional output of C-track with incremental encoder output mode (single mode only)
1Ch Standard 32 Bit (MDP 253_511), continuous position.png
Process data and PDO assignment: 1 Ch. Standard 32 Bit (MDP 253/511), continues position
PDO setting: 2 Ch. Standard 32 Bit (MDP 253/511), continues position
▪
32-bit-wide variables
▪
allows linking to NC axes according to MDP 253, subprofile 511
▪
continuous positioning / output pulses cycle-synchronously
▪
double operation mode
2Ch Standard 32 Bit (MDP 253_511), continuous position.png
Process data and PDO-allocation: 2 Ch. Standard 32 Bit (MDP 253/511), continues position
PDO setting: 2 Ch. Standard 32 Bit (MDP 253/511), continues position w. arrival time
▪
32-bit-wide variables
▪
allows linking to NC axes according to MDP 253, subprofile 511
▪
continuous positioning / output pulses cycle-synchronously
▪
specification of arrival time
▪
double operation mode
2Ch Standard 32 Bit (MDP 253_511), continuous position_w_arrival_time.png
Process data and PDO-allocation: 2 Ch. Standard 32 Bit (MDP 253/511), continues position w. arrival time


Object description and parameterization

Commissioning [image] EL2522-0000 [image] Object description and parameterization
Object description and parameterization
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Parameterization via the CoE list (CAN over EtherCAT)
The terminal is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs). Please note the following general CoE information when using/manipulating the CoE parameters:
•
Keep a startup list if components have to be replaced
•
Differentiation between online/offline dictionary, existence of current XML description
•
“CoE-Reload” for resetting the changes
Introduction
The CoE overview contains objects for different intended applications:
▪
Objects required for parameterization during commissioning
▪
Objects intended for regular operation, e.g. through ADS access
▪
Objects for indicating internal settings (may be fixed)
The following section first describes the objects required for normal operation, followed by a complete overview of missing objects.
Additional information
•
Objects for commissioning
•
Standard objects (0x1000-0x1FFF)
•
Profile-specific objects (0x6000-0xFFFF)
•
Objects for regular operation


Objects for commissioning

Commissioning [image] EL2522-0000 [image] Object description and parameterization [image] Objects for commissioning
Objects for commissioning
Index 0x8000 PTO Settings Ch.1
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8000:0 | PTO Settings Ch.1 | Max. subindex |  | UINT8 | RO | 0x18 (24dec)
8000:01 | Adapt A/B on position set | If the counter value is set to "0", the C-track goes into the "high" state. The behavior of channels A and B can be defined in this case. By default the value is FALSE; the position of the C-track relative to A and B is then not changed. If the value is set to TRUE, channels A and B are both set to high. Consequently, a change of state occurs on both channels! |  | BOOLEAN | RW | 0x00 (0dec)
8000:02 | Emergency ramp active | TRUE If the watchdog timer responds, the terminal ramps with the time constant set in object 8ppx:18 to the value set in object 8ppx:11. FALSE The function is deactivated |  | BOOLEAN | RW | 0x00 (0dec)
8000:03 | Watchdog timer deactive | TRUE The watchdog timer is deactivated FALSE The watchdog timer is activated in the delivery state. Either the manufacturer's of the user's switch-on value is output if the watchdog overflows. |  | BOOLEAN | RW | 0x00 (0dec)
8000:04 | Sign/amount representation | TRUE The output value is displayed in magnitude-sign format: -2dec= 0x8002 -1dec= 0x8001 1dec= 0x0001 2dec= 0x0002 FALSE The output value is output as a signed integer in two's complement: -2dec= 0xFFFE -1dec= 0xFFFF 1dec= 0x0001 2dec= 0x0002 |  | BOOLEAN | RW | 0x00 (0dec)
8000:06 | Ramp function active | TRUE Ramp function activated FALSE Ramp function deactivated |  | BOOLEAN | RW | 0x01 (1dec)
8000:07 | Ramp base frequency | permitted values: |  | BIT1 | RW | 0x00 (0dec)
 |  | 0 | 10 Hz
 |  | 1 | 1 kHz
8000:08 | Direct input mode | TRUE Direct input mode FALSE Relative input mode |  | BOOLEAN | RW | 0x00 (0dec)
8000:09 | Users switch-on-value on wdt | TRUE Behavior with triggered watchdog timer: User's switch-on value FALSE Behavior with triggered watchdog timer: Manufacturer's switch-on value |  | BOOLEAN | RW | 0x00 (0dec)
8000:0A | Travel distance control active | TRUE Travel distance control activated FALSE Travel distance control deactivated |  | BOOLEAN | RW | 0x00 (0dec)
8000:0E | Operating mode | permitted values: |  | BIT2 | RW | 0x00 (0dec)
 |  | 0 | Frequency mod.
 |  | 1 | Pulse-dir. ctrl
 |  | 2 | Incremental enc.
8000:10 | Negative logic | TRUE Negative logic FALSE Positive logic |  | BOOLEAN | RW | 0x00 (0dec)
8000:11 | Users switch-on-value | User switch-on value (frequency) |  | UINT16 | RW | 0x0000 (0dec)
8000:12 | Base frequency 1 | Base frequency 1 = 50000 Hz |  | UINT32 | RW | 0x0000C350 (50000dec)
8000:13 | Base frequency 2 | Base frequency 2 = 100000 Hz |  | UINT32 | RW | 0x000186A0 (100000dec)
8000:14 | Ramp time constant (rising) | Ramp time constant (rising) |  | UINT16 | RW | 0x03E8 (1000dec)
Index (hex) | Name | Meaning | Data type | Flags | Default
8000:15 | Ramp time constant (falling) | Ramp time constant (falling) | UINT16 | RW | 0x03E8 (1000dec)
8000:16 | Frequency factor (Digit x 10mHz) | Frequency factor (direct input, digit x 10mHz) | UINT16 | RW | 0x0064 (100dec)
8000:17 | Slowing down frequency | Slowing down frequency, travel distance control | UINT16 | RW | 0x0032 (50dec)
8000:18 | Ramp time constant (emergency) | Ramp time constant for controlled switch-off; user's switch-on value is driven to (object 8pp0:11) | UINT16 | RW | 0x03E8 (1000dec)
Index 0x8010 PTO Settings Ch.2
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8010:0 | PTO Settings Ch.2 | Max. Subindex |  | UINT8 | RO | 0x18 (24dec)
8010:01 | Adapt A/B on position set | If the counter value is set to "0", the C-track goes into the "high" state. The behavior of channels A and B can be defined in this case. The behavior of channels A and B can be defined in this case. If the value is set to TRUE, channels A and B are both set to high. Consequently, a change of state occurs on both channels! |  | BOOLEAN | RW | 0x00 (0dec)
8010:02 | Emergency ramp active | TRUE If the watchdog timer responds, the terminal ramps with the time constant set in object 8ppx:18 to the value set in object 8ppx:11. FALSE The function is deactivated |  | BOOLEAN | RW | 0x00 (0dec)
8010:03 | Watchdog timer deactive | TRUE The watchdog timer is deactivated FALSE The watchdog timer is activated in the delivery state. Either the manufacturer's of the user's switch-on value is output if the watchdog overflows. |  | BOOLEAN | RW | 0x00 (0dec)
8010:04 | Sign/amount representation | TRUE The output value is displayed in magnitude-sign format: -2dec= 0x8002 -1dec= 0x8001 1dec= 0x0001 2dec= 0x0002 FALSE The output value is output as a signed integer in two's complement: -2dec= 0xFFFE -1dec= 0xFFFF 1dec= 0x0001 2dec= 0x0002 |  | BOOLEAN | RW | 0x00 (0dec)
8010:06 | Ramp function active | TRUE Ramp function activated FALSE Ramp function deactivated |  | BOOLEAN | RW | 0x01 (1dec)
8010:07 | Ramp base frequency | permitted values: |  | BIT1 | RW | 0x00 (0dec)
 |  | 0 | 10 Hz
 |  | 1 | 1 kHz
8010:08 | Direct input mode | TRUE Direct input mode FALSE Relative input mode |  | BOOLEAN | RW | 0x00 (0dec)
8010:09 | Users switch-on-value on wdt | TRUE Behavior with triggered watchdog timer: User's switch-on value FALSE Behavior with triggered watchdog timer: Manufacturer's switch-on value |  | BOOLEAN | RW | 0x00 (0dec)
8010:0A | Travel distance control active | TRUE Travel distance control activated FALSE Travel distance control deactivated |  | BOOLEAN | RW | 0x00 (0dec)
8010:0E | Operating mode | permitted values: |  | BIT2 | RW | 0x00 (0dec)
 |  | 0 | Frequency mod.
 |  | 1 | Pulse-dir. ctrl
 |  | 2 | Incremental enc.
8010:10 | Negative logic | TRUE Negative logic FALSE Positive logic |  | BOOLEAN | RW | 0x00 (0dec)
8010:11 | Users switch-on-value | User switch-on value (frequency) |  | UINT16 | RW | 0x0000 (0dec)
8010:12 | Base frequency 1 | Base frequency 1 = 50000 Hz |  | UINT32 | RW | 0x0000C350 (50000dec)
8010:13 | Base frequency 2 | Base frequency 2 = 100000 Hz |  | UINT32 | RW | 0x000186A0 (100000dec)
8010:14 | Ramp time constant (rising) | Ramp time constant (rising) |  | UINT16 | RW | 0x03E8 (1000dec)
Index (hex) | Name | Meaning | Data type | Flags | Default
8010:15 | Ramp time constant (falling) | Ramp time constant (falling) | UINT16 | RW | 0x03E8 (1000dec)
8010:16 | Frequency factor (Digit x 10mHz) | Frequency factor (direct input, digit x 10mHz) | UINT16 | RW | 0x0064 (100dec)
8010:17 | Slowing down frequency | Slowing down frequency, travel distance control | UINT16 | RW | 0x0032 (50dec)
8010:18 | Ramp time constant (emergency) | Ramp time constant for controlled switch-off; user's switch-on value is driven to (object 8pp0:11) | UINT16 | RW | 0x03E8 (1000dec)
Index 0x8020 ENC Settings Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
8020:0 | ENC Settings Ch.1 | Max. Subindex | UINT8 | RO | 0x1A (26dec)
8020:01 | Enable C reset | The counter is reset via the C-track | BOOLEAN | RW | 0x00 (0dec)
8020:0A | Enable micro increments | The counter is more highly resolved with the bits specified in 0x8pp0:16 | BOOLEAN | RW | 0x00 (0dec)
8020:18 | Micro increment bits | If 0x8pp0:0A is enabled: Number of micro increment bits | UINT16 | RW | 0x0008 (8dec)
8020:19 | Pulses per revolution | If C-reset active: Number of increments "per revolution". At 1024 the counter counts | UINT32 | RW | 0x00000400 (1024dec)
8020:1A | Autoset threshold | If the difference between "Target counter value" and "Counter value" exceeds this threshold, no output takes place. 0: function for automatic setting is inactive | UINT32 | RW | 0x00000000 (0dec)
Index 0x8030 ENC Settings Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
8030:0 | ENC Settings Ch.2 | Max. Subindex | UINT8 | RO | 0x1A (26dec)
8030:01 | Enable C reset | The counter is reset via the C-track | BOOLEAN | RW | 0x00 (0dec)
8030:0A | Enable micro increments | The counter is more highly resolved with the bits specified in 0x8pp0:16 | BOOLEAN | RW | 0x00 (0dec)
8030:18 | Micro increment bits | If 0x8pp0:0A is enabled: Number of micro increment bits | UINT16 | RW | 0x0008 (8dec)
8030:19 | Pulses per revolution | If C-reset active: Number of increments "per revolution". At 1024 the counter counts | UINT32 | RW | 0x00000400 (1024dec)
8030:1A | Autoset threshold | If the difference between "Target counter value" and "Counter value" exceeds this threshold, no output takes place. 0: function for automatic setting is inactive | UINT32 | RW | 0x00000000 (0dec)


Standard objects (0x1000-0x1FFF)

Commissioning [image] EL2522-0000 [image] Object description and parameterization [image] Standard objects (0x1000-0x1FFF)
Standard objects (0x1000-0x1FFF)
The standard objects have the same meaning for all EtherCAT slaves.
Index 0x1000 Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x00001389 (5001dec)
Index 0x1008 Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EL2522
Index 0x1009 Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO | 00
Index 0x100A Software version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO | 06
Index 0x1011 Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default settings | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" in the Set Value Dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)
Index 0x1018 Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x09DA3052 (165294162dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the Low Word (bit 0-15) indicates the special terminal number, the High Word (bit 16-31) refers to the device description | UINT32 | RO | 0x00000000 (0dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the Low Byte (bit 0-7) of the Low Word contains the year of production, the High Byte (bit 8-15) of the Low Word contains the week of production, the High Word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 0x10F0 Backup parameter handling
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | Information for standardized loading and saving of backup entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum across all backup entries of the EtherCAT slave | UINT32 | RO | 0x00000000 (0dec)
Index 0x1400 PTO RxPDO-Par Control Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1400:0 | PTO RxPDO-Par Control Ch.1 | PDO Parameter RxPDO 1 | UINT8 | RO | 0x06 (6dec)
1400:06 | Exclude RxPDOs | Specifies the RxPDOs (index 0x of RxPDO mapping objects) that must not be transferred together with RxPDO 1 | OCTET-STRING[6] | RO | 01 16 04 16 00 00
Index 0x1401 PTO RxPDO-Par Control Position Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1401:0 | PTO RxPDO-Par Control Position Ch.1 | PDO Parameter RxPDO 2 | UINT8 | RO | 0x06 (6dec)
1401:06 | Exclude RxPDOs | Specifies the RxPDOs (index 0x of RxPDO mapping objects) that must not be transferred together with RxPDO 2 | OCTET-STRING[6] | RO | 00 16 02 16 03 16
Index 0x1402 PTO RxPDO-Par Target compact Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1402:0 | PTO RxPDO-Par Target compact Ch.1 | PDO Parameter RxPDO 3 | UINT8 | RO | 0x06 (6dec)
1402:06 | Exclude RxPDOs | Specifies the RxPDOs (index 0x of RxPDO mapping objects) that must not be transferred together with RxPDO 3 | OCTET-STRING[6] | RO | 01 16 03 16 00 00
Index 0x1403 PTO RxPDO-Par Target Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1403:0 | PTO RxPDO-Par Target Ch.1 | PDO Parameter RxPDO 4 | UINT8 | RO | 0x06 (6dec)
1403:06 | Exclude RxPDOs | Specifies the RxPDOs (index 0x of RxPDO mapping objects) that must not be transferred together with RxPDO 4 | OCTET-STRING[6] | RO | 01 16 02 16 00 00
Index 0x1404 PTO RxPDO-Par Arrival Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1404:0 | PTO RxPDO-Par Arrival Ch.1 | PDO Parameter RxPDO 5 | UINT8 | RO | 0x06 (6dec)
1404:06 | Exclude RxPDOs | Specifies the RxPDOs (index 0x of RxPDO mapping objects) that must not be transferred together with RxPDO 5 | OCTET-STRING[6] | RO | 00 16 02 16 03 16
Index 0x1405 PTO RxPDO-Par Control Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1405:0 | PTO RxPDO-Par Control Ch.2 | PDO Parameter RxPDO 6 | UINT8 | RO | 0x06 (6dec)
1405:06 | Exclude RxPDOs | Specifies the RxPDOs (index 0x of RxPDO mapping objects) that must not be transferred together with RxPDO 6 | OCTET-STRING[6] | RO | 06 16 09 16 00 00
Index 0x1406 PTO RxPDO-Par Control Position Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1406:0 | PTO RxPDO-Par Control Position Ch.2 | PDO Parameter RxPDO 7 | UINT8 | RO | 0x06 (6dec)
1406:06 | Exclude RxPDOs | Specifies the RxPDOs (index 0x of RxPDO mapping objects) that must not be transferred together with RxPDO 7 | OCTET-STRING[6] | RO | 05 16 07 16 08 16
Index 0x1407 PTO RxPDO-Par Target compact Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1407:0 | PTO RxPDO-Par Target compact Ch.2 | PDO Parameter RxPDO 8 | UINT8 | RO | 0x06 (6dec)
1407:06 | Exclude RxPDOs | Specifies the RxPDOs (index 0x of RxPDO mapping objects) that must not be transferred together with RxPDO 8 | OCTET-STRING[6] | RO | 06 16 08 16 00 00
Index 0x1408 PTO RxPDO-Par Target Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1408:0 | PTO RxPDO-Par Target Ch.2 | PDO Parameter RxPDO 9 | UINT8 | RO | 0x06 (6dec)
1408:06 | Exclude RxPDOs | Specifies the RxPDOs (index 0x of RxPDO mapping objects) that must not be transferred together with RxPDO 9 | OCTET-STRING[6] | RO | 06 16 07 16 00 00
Index 0x1409 PTO RxPDO-Par Arrival Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1409:0 | PTO RxPDO-Par Arrival Ch.2 | PDO Parameter RxPDO 10 | UINT8 | RO | 0x06 (6dec)
1409:06 | Exclude RxPDOs | Specifies the RxPDOs (index 0x of RxPDO mapping objects) that must not be transferred together with RxPDO 10 | OCTET-STRING[6] | RO | 05 16 07 16 08 16
Index 0x140A ENC RxPDO-Par Control compact Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
140A:0 | ENC RxPDO-Par Control compact Ch.1 | PDO Parameter RxPDO 11 | UINT8 | RO | 0x06 (6dec)
140A:06 | Exclude RxPDOs | Specifies the RxPDOs (index 0x of RxPDO mapping objects) that must not be transferred together with RxPDO 11 | OCTET-STRING[6] | RO | 0B 16 00 00 00 00
Index 0x140B ENC RxPDO-Par Control Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
140B:0 | ENC RxPDO-Par Control Ch.1 | PDO Parameter RxPDO 12 | UINT8 | RO | 0x06 (6dec)
140B:06 | Exclude RxPDOs | Specifies the RxPDOs (index 0x of RxPDO mapping objects) that must not be transferred together with RxPDO 12 | OCTET-STRING[6] | RO | 0A 16 00 00 00 00
Index 0x140C ENC RxPDO-Par Control compact Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
140C:0 | ENC RxPDO-Par Control compact Ch.2 | PDO Parameter RxPDO 13 | UINT8 | RO | 0x06 (6dec)
140C:06 | Exclude RxPDOs | Specifies the RxPDOs (index 0x of RxPDO mapping objects) that must not be transferred together with RxPDO 13 | OCTET-STRING[6] | RO | 0D 16 00 00 00 00
Index 0x140D ENC RxPDO-Par Control Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
140D:0 | ENC RxPDO-Par Control Ch.2 | PDO Parameter RxPDO 14 | UINT8 | RO | 0x06 (6dec)
140D:06 | Exclude RxPDOs | Specifies the RxPDOs (index 0x of RxPDO mapping objects) that must not be transferred together with RxPDO 14 | OCTET-STRING[6] | RO | 0C 16 00 00 00 00
Index 0x1600 PTO RxPDO-Map Control Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1600:0 | PTO RxPDO-Map Control Ch.1 | PDO Mapping RxPDO 1 | UINT8 | RO | 0x05 (5dec)
1600:01 | SubIndex 0x001 | 1. PDO Mapping entry (object 0x7000 (PTO Outputs Ch.1), entry 0x01 (Frequency select)) | UINT32 | RO | 0x7000:01, 1
1600:02 | SubIndex 0x002 | 2. PDO Mapping entry (object 0x7000 (PTO Outputs Ch.1), entry 0x02 (Disable ramp)) | UINT32 | RO | 0x7000:02, 1
1600:03 | SubIndex 0x003 | 3. PDO Mapping entry (object 0x7000 (PTO Outputs Ch.1), entry 0x03 (Go counter)) | UINT32 | RO | 0x7000:03, 1
1600:04 | SubIndex 0x004 | 4. PDO Mapping entry (13 bits align) | UINT32 | RO | 0x0000:00, 13
1600:05 | SubIndex 0x005 | 5. PDO Mapping entry (object 0x7000 (PTO Outputs Ch.1), entry 0x11 (Frequency value)) | UINT32 | RO | 0x7000:11, 16
Index 0x1601 PTO RxPDO-Map Control Position Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1601:0 | PTO RxPDO-Map Control Position Ch.1 | PDO Mapping RxPDO 2 | UINT8 | RO | 0x06 (6dec)
1601:01 | SubIndex 0x001 | 1. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1601:02 | SubIndex 0x002 | 2. PDO Mapping entry (object 0x7000 (PTO Outputs Ch.1), entry 0x04 (Automatic direction)) | UINT32 | RO | 0x7000:04, 1
1601:03 | SubIndex 0x003 | 3. PDO Mapping entry (object 0x7000 (PTO Outputs Ch.1), entry 0x05 (Forward)) | UINT32 | RO | 0x7000:05, 1
1601:04 | SubIndex 0x004 | 4. PDO Mapping entry (object 0x7000 (PTO Outputs Ch.1), entry 0x06 (Reward)) | UINT32 | RO | 0x7000:06, 1
1601:05 | SubIndex 0x005 | 5. PDO Mapping entry (10 bits align) | UINT32 | RO | 0x0000:00, 10
1601:06 | SubIndex 0x006 | 6. PDO Mapping entry (object 0x7000 (PTO Outputs Ch.1), entry 0x12 (Target counter value)) | UINT32 | RO | 0x7000:12, 32
Index 0x1602 PTO RxPDO-Map Target compact Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1602:0 | PTO RxPDO-Map Target compact Ch.1 | PDO Mapping RxPDO 3 | UINT8 | RO | 0x01 (1dec)
1602:01 | SubIndex 0x001 | 1. PDO Mapping entry (object 0x7000 (PTO outputs Ch.1), entry 0x12 (Target counter value)) | UINT32 | RO | 0x7000:12, 16
Index 0x1603 PTO RxPDO-Map Target Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1603:0 | PTO RxPDO-Map Target Ch.1 | PDO Mapping RxPDO 4 | UINT8 | RO | 0x01 (1dec)
1603:01 | SubIndex 0x001 | 1. PDO Mapping entry (object 0x7000 (PTO outputs Ch.1), entry 0x12 (Target counter value)) | UINT32 | RO | 0x7000:12, 32
Index 0x1604 PTO RxPDO-Map Arrival Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1604:0 | PTO RxPDO-Map Arrival Ch.1 | PDO Mapping RxPDO 5 | UINT8 | RO | 0x01 (1dec)
1604:01 | SubIndex 0x001 | 1. PDO Mapping entry (object 0x7000 (PTO Outputs Ch.1), entry 0x13 (Target arrival time)) | UINT32 | RO | 0x7000:13, 64
Index 0x1605 PTO RxPDO-Map Control Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1605:0 | PTO RxPDO-Map Control Ch.2 | PDO Mapping RxPDO 6 | UINT8 | RO | 0x05 (5dec)
1605:01 | SubIndex 0x001 | 1. PDO Mapping entry (object 0x7010 (PTO Outputs Ch.2), entry 0x01 (Frequency select)) | UINT32 | RO | 0x7010:01, 1
1605:02 | SubIndex 0x002 | 2. PDO Mapping entry (object 0x7010 (PTO Outputs Ch.2), entry 0x02 (Disable ramp)) | UINT32 | RO | 0x7010:02, 1
1605:03 | SubIndex 0x003 | 3. PDO Mapping entry (object 0x7010 (PTO Outputs Ch.2), entry 0x03 (Go counter)) | UINT32 | RO | 0x7010:03, 1
1605:04 | SubIndex 0x004 | 4. PDO Mapping entry (13 bits align) | UINT32 | RO | 0x0000:00, 13
1605:05 | SubIndex 0x005 | 5. PDO Mapping entry (object 0x7010 (PTO Outputs Ch.2), entry 0x11 (Frequency value)) | UINT32 | RO | 0x7010:11, 16
Index 0x1606 PTO RxPDO-Map Control Position Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1606:0 | PTO RxPDO-Map Control Position Ch.2 | PDO Mapping RxPDO 7 | UINT8 | RO | 0x06 (6dec)
1606:01 | SubIndex 0x001 | 1. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1606:02 | SubIndex 0x002 | 2. PDO Mapping entry (object 0x7010 (PTO Outputs Ch.2), entry 0x04 (Automatic direction)) | UINT32 | RO | 0x7010:04, 1
1606:03 | SubIndex 0x003 | 3. PDO Mapping entry (object 0x7010 (PTO Outputs Ch.2), entry 0x05 (Forward)) | UINT32 | RO | 0x7010:05, 1
1606:04 | SubIndex 0x004 | 4. PDO Mapping entry (object 0x7010 (PTO Outputs Ch.2), entry 0x06 (Reward)) | UINT32 | RO | 0x7010:06, 1
1606:05 | SubIndex 0x005 | 5. PDO Mapping entry (10 bits align) | UINT32 | RO | 0x0000:00, 10
1606:06 | SubIndex 0x006 | 6. PDO Mapping entry (object 0x7010 (PTO Outputs Ch.2), entry 0x12 (Target counter value)) | UINT32 | RO | 0x7010:12, 32
Index 0x1607 PTO RxPDO-Map Target compact Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1607:0 | PTO RxPDO-Map Target compact Ch.2 | PDO Mapping RxPDO 8 | UINT8 | RO | 0x01 (1dec)
1607:01 | SubIndex 0x001 | 1. PDO Mapping entry (object 0x7010 (PTO Outputs Ch.2), entry 0x12 (Target counter value)) | UINT32 | RO | 0x7010:12, 16
Index 0x1608 PTO RxPDO-Map Target Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1608:0 | PTO RxPDO-Map Target Ch.2 | PDO Mapping RxPDO 9 | UINT8 | RO | 0x01 (1dec)
1608:01 | SubIndex 0x001 | 1. PDO Mapping entry (object 0x7010 (PTO Outputs Ch.2), entry 0x12 (Target counter value)) | UINT32 | RO | 0x7010:12, 32
Index 0x1609 PTO RxPDO-Map Arrival Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1609:0 | PTO RxPDO-Map Arrival Ch.2 | PDO Mapping RxPDO 10 | UINT8 | RO | 0x01 (1dec)
1609:01 | SubIndex 0x001 | 1. PDO Mapping entry (object 0x7010 (PTO Outputs Ch.2), entry 0x13 (Target arrival time)) | UINT32 | RO | 0x7010:13, 64
Index 0x160A ENC RxPDO-Map Control compact Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
160A:0 | ENC RxPDO-Map Control compact Ch.1 | PDO Mapping RxPDO 11 | UINT8 | RO | 0x05 (5dec)
160A:01 | SubIndex 0x001 | 1. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
160A:02 | SubIndex 0x002 | 2. PDO Mapping entry (object 0x7020 (ENC Outputs Ch.1), entry 0x03 (Set counter)) | UINT32 | RO | 0x7020:03, 1
160A:03 | SubIndex 0x003 | 3. PDO Mapping entry (12 bits align) | UINT32 | RO | 0x0000:00, 12
160A:04 | SubIndex 0x004 | 4. PDO Mapping entry (object 0x7020 (ENC Outputs Ch.1), entry 0x10 (Reserved)) | UINT32 | RO | 0x7020:10, 1
160A:05 | SubIndex 0x005 | 5. PDO Mapping entry (object 0x7020 (ENC Outputs Ch.1), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7020:11, 16
Index 0x160B ENC RxPDO-Map Control Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
160B:0 | ENC RxPDO-Map Control Ch.1 | PDO Mapping RxPDO 12 | UINT8 | RO | 0x05 (5dec)
160B:01 | SubIndex 0x001 | 1. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
160B:02 | SubIndex 0x002 | 2. PDO Mapping entry (object 0x7020 (ENC Outputs Ch.1), entry 0x03 (Set counter)) | UINT32 | RO | 0x7020:03, 1
160B:03 | SubIndex 0x003 | 3. PDO Mapping entry (12 bits align) | UINT32 | RO | 0x0000:00, 12
160B:04 | SubIndex 0x004 | 4. PDO Mapping entry (object 0x7020 (ENC Outputs Ch.1), entry 0x10 (Reserved)) | UINT32 | RO | 0x7020:10, 1
160B:05 | SubIndex 0x005 | 5. PDO Mapping entry (object 0x7020 (ENC Outputs Ch.1), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7020:11, 32
Index 0x160C ENC RxPDO-Map Control compact Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
160C:0 | ENC RxPDO-Map Control compact Ch.2 | PDO Mapping RxPDO 13 | UINT8 | RO | 0x05 (5dec)
160C:01 | SubIndex 0x001 | 1. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
160C:02 | SubIndex 0x002 | 2. PDO Mapping entry (object 0x7030 (ENC Outputs Ch.2), entry 0x03 (Set counter)) | UINT32 | RO | 0x7030:03, 1
160C:03 | SubIndex 0x003 | 3. PDO Mapping entry (12 bits align) | UINT32 | RO | 0x0000:00, 12
160C:04 | SubIndex 0x004 | 4. PDO Mapping entry (object 0x7030 (ENC Outputs Ch.2), entry 0x10 (Reserved)) | UINT32 | RO | 0x7030:10, 1
160C:05 | SubIndex 0x005 | 5. PDO Mapping entry (object 0x7030 (ENC Outputs Ch.2), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7030:11, 16
Index 0x160D ENC RxPDO-Map Control Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
160D:0 | ENC RxPDO-Map Control Ch.2 | PDO Mapping RxPDO 14 | UINT8 | RO | 0x05 (5dec)
160D:01 | SubIndex 0x001 | 1. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
160D:02 | SubIndex 0x002 | 2. PDO Mapping entry (object 0x7030 (ENC Outputs Ch.2), entry 0x03 (Set counter)) | UINT32 | RO | 0x7030:03, 1
160D:03 | SubIndex 0x003 | 3. PDO Mapping entry (12 bits align) | UINT32 | RO | 0x0000:00, 12
160D:04 | SubIndex 0x004 | 4. PDO Mapping entry (object 0x7030 (ENC Outputs Ch.2), entry 0x10 (Reserved)) | UINT32 | RO | 0x7030:10, 1
160D:05 | SubIndex 0x005 | 5. PDO Mapping entry (object 0x7030 (ENC Outputs Ch.2), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7030:11, 32
Index 0x1802 ENC TxPDO-Par Status compact Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1802:0 | ENC TxPDO-Par Status compact Ch.1 | PDO parameter TxPDO 3 | UINT8 | RO | 0x06 (6dec)
1802:06 | Exclude TxPDOs | Specifies the TxPDOs (index 0x of TxPDO mapping objects) that must not be transferred together with TxPDO 3 | OCTET-STRING[2] | RO | 03 1A
Index 0x1803 ENC TxPDO-Par Status Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1803:0 | ENC TxPDO-Par Status Ch.1 | PDO parameter TxPDO 4 | UINT8 | RO | 0x06 (6dec)
1803:06 | Exclude TxPDOs | Specifies the TxPDOs (index 0x of TxPDO mapping objects) that must not be transferred together with TxPDO 4 | OCTET-STRING[2] | RO | 02 1A
Index 0x1804 ENC TxPDO-Par Status compact Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1804:0 | ENC TxPDO-Par Status compact Ch.2 | PDO parameter TxPDO 5 | UINT8 | RO | 0x06 (6dec)
1804:06 | Exclude TxPDOs | Specifies the TxPDOs (index 0x of TxPDO mapping objects) that must not be transferred together with TxPDO 5 | OCTET-STRING[2] | RO | 05 1A
Index 0x1805 ENC TxPDO-Par Status Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1805:0 | ENC TxPDO-Par Status Ch.2 | PDO parameter TxPDO 6 | UINT8 | RO | 0x06 (6dec)
1805:06 | Exclude TxPDOs | Specifies the TxPDOs (index 0x of TxPDO mapping objects) that must not be transferred together with TxPDO 6 | OCTET-STRING[2] | RO | 04 1A
Index 0x1A00 PTO TxPDO-Map Status Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A00:0 | PTO TxPDO-Map Status Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x0A (10dec)
1A00:01 | SubIndex 0x001 | 1. PDO Mapping entry (object 0x6000 (PTO inputs Ch.1), entry 0x01 (Sel. Ack/End counter)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 0x002 | 2. PDO Mapping entry (object 0x6000 (PTO Inputs Ch.1), entry 0x02 (Ramp active)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 0x003 | 3. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A00:04 | SubIndex 0x004 | 4. PDO Mapping entry (object 0x6000 (PTO Inputs Ch.1), entry 0x07 (Error)) | UINT32 | RO | 0x6000:07, 1
1A00:05 | SubIndex 0x005 | 5. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
1A00:06 | SubIndex 0x006 | 6. PDO Mapping entry (object 0x6000 (PTO Inputs Ch.1), entry 0x0E (Sync error)) | UINT32 | RO | 0x6000:0E, 1
1A00:07 | SubIndex 0x007 | 7. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A00:08 | SubIndex 0x008 | 8. PDO Mapping entry (object 0x6000 (PTO Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6000:10, 1
1A00:09 | SubIndex 0x009 | 9. PDO Mapping entry (object 0x6000 (PTO Inputs Ch.1), entry 0x11 ()) | UINT32 | RO | 0x6000:11, 1
1A00:0A | SubIndex 0x010 | 10. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
Index 0x1A01 PTO TxPDO-Map Status Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A01:0 | PTO TxPDO-Map Status Ch.2 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x0A (10dec)
1A01:01 | SubIndex 0x001 | 1. PDO Mapping entry (object 0x6010 (PTO Inputs Ch.2), entry 0x01 (Sel. Ack/End counter)) | UINT32 | RO | 0x6010:01, 1
1A01:02 | SubIndex 0x002 | 2. PDO Mapping entry (object 0x6010 (PTO Inputs Ch.2), entry 0x02 (Ramp active)) | UINT32 | RO | 0x6010:02, 1
1A01:03 | SubIndex 0x003 | 3. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A01:04 | SubIndex 0x004 | 4. PDO Mapping entry (object 0x6010 (PTO Inputs Ch.2), entry 0x07 (Error)) | UINT32 | RO | 0x6010:07, 1
1A01:05 | SubIndex 0x005 | 5. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
1A01:06 | SubIndex 0x006 | 6. PDO Mapping entry (object 0x6010 (PTO Inputs Ch.2), entry 0x0E (Sync error)) | UINT32 | RO | 0x6010:0E, 1
1A01:07 | SubIndex 0x007 | 7. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A01:08 | SubIndex 0x008 | 8. PDO Mapping entry (object 0x6010 (PTO Inputs Ch.2), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6010:10, 1
1A01:09 | SubIndex 0x009 | 9. PDO Mapping entry (object 0x6010 (PTO Inputs Ch.2), entry 0x11 ()) | UINT32 | RO | 0x6010:11, 1
1A01:0A | SubIndex 0x010 | 10. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
Index 0x1A02 ENC TxPDO-Map Status compact Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A02:0 | ENC TxPDO-Map Status compact Ch.1 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x09 (9dec)
1A02:01 | SubIndex 0x001 | 1. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A02:02 | SubIndex 0x002 | 2. PDO Mapping entry (object 0x6020 (ENC Inputs Ch.1), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6020:03, 1
1A02:03 | SubIndex 0x003 | 3. PDO Mapping entry (object 0x6020 (ENC Inputs Ch.1), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6020:04, 1
1A02:04 | SubIndex 0x004 | 4. PDO Mapping entry (object 0x6020 (ENC Inputs Ch.1), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6020:05, 1
1A02:05 | SubIndex 0x005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1A02:06 | SubIndex 0x006 | 6. PDO Mapping entry (object 0x6020 (ENC Inputs Ch.1), entry 0x0E (Sync error)) | UINT32 | RO | 0x6020:0E, 1
1A02:07 | SubIndex 0x007 | 7. PDO Mapping entry (object 0x6020 (ENC Inputs Ch.1), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6020:0F, 1
1A02:08 | SubIndex 0x008 | 8. PDO Mapping entry (object 0x6020 (ENC Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6020:10, 1
1A02:09 | SubIndex 0x009 | 9. PDO Mapping entry (object 0x6020 (ENC Inputs Ch.1), entry 0x11 (Counter value)) | UINT32 | RO | 0x6020:11, 16
Index 0x1A03 ENC TxPDO-Map Status Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A03:0 | ENC TxPDO-Map Status Ch.1 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x09 (9dec)
1A03:01 | SubIndex 0x001 | 1. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A03:02 | SubIndex 0x002 | 2. PDO Mapping entry (object 0x6020 (ENC Inputs Ch.1), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6020:03, 1
1A03:03 | SubIndex 0x003 | 3. PDO Mapping entry (object 0x6020 (ENC Inputs Ch.1), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6020:04, 1
1A03:04 | SubIndex 0x004 | 4. PDO Mapping entry (object 0x6020 (ENC Inputs Ch.1), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6020:05, 1
1A03:05 | SubIndex 0x005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1A03:06 | SubIndex 0x006 | 6. PDO Mapping entry (object 0x6020 (ENC Inputs Ch.1), entry 0x0E (Sync error)) | UINT32 | RO | 0x6020:0E, 1
1A03:07 | SubIndex 0x007 | 7. PDO Mapping entry (object 0x6020 (ENC Inputs Ch.1), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6020:0F, 1
1A03:08 | SubIndex 0x008 | 8. PDO Mapping entry (object 0x6020 (ENC Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6020:10, 1
1A03:09 | SubIndex 0x009 | 9. PDO Mapping entry (object 0x6020 (ENC Inputs Ch.1), entry 0x11 (Counter value)) | UINT32 | RO | 0x6020:11, 32
Index 0x1A04 ENC TxPDO-Map Status compact Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A04:0 | ENC TxPDO-Map Status compact Ch.2 | PDO Mapping TxPDO 5 | UINT8 | RO | 0x09 (9dec)
1A04:01 | SubIndex 0x001 | 1. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A04:02 | SubIndex 0x002 | 2. PDO Mapping entry (object 0x6030 (ENC Inputs Ch.2), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6030:03, 1
1A04:03 | SubIndex 0x003 | 3. PDO Mapping entry (object 0x6030 (ENC Inputs Ch.2), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6030:04, 1
1A04:04 | SubIndex 0x004 | 4. PDO Mapping entry (object 0x6030 (ENC Inputs Ch.2), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6030:05, 1
1A04:05 | SubIndex 0x005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1A04:06 | SubIndex 0x006 | 6. PDO Mapping entry (object 0x6030 (ENC Inputs Ch.2), entry 0x0E (Sync error)) | UINT32 | RO | 0x6030:0E, 1
1A04:07 | SubIndex 0x007 | 7. PDO Mapping entry (object 0x6030 (ENC Inputs Ch.2), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6030:0F, 1
1A04:08 | SubIndex 0x008 | 8. PDO Mapping entry (object 0x6030 (ENC Inputs Ch.2), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6030:10, 1
1A04:09 | SubIndex 0x009 | 9. PDO Mapping entry (object 0x6030 (ENC Inputs Ch.2), entry 0x11 (Counter value)) | UINT32 | RO | 0x6030:11, 16
Index 0x1A05 ENC TxPDO-Map Status Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A05:0 | ENC TxPDO-Map Status Ch.2 | PDO Mapping TxPDO 6 | UINT8 | RO | 0x09 (9dec)
1A05:01 | SubIndex 0x001 | 1. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A05:02 | SubIndex 0x002 | 2. PDO Mapping entry (object 0x6030 (ENC Inputs Ch.2), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6030:03, 1
1A05:03 | SubIndex 0x003 | 3. PDO Mapping entry (object 0x6030 (ENC Inputs Ch.2), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6030:04, 1
1A05:04 | SubIndex 0x004 | 4. PDO Mapping entry (object 0x6030 (ENC Inputs Ch.2), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6030:05, 1
1A05:05 | SubIndex 0x005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1A05:06 | SubIndex 0x006 | 6. PDO Mapping entry (object 0x6030 (ENC Inputs Ch.2), entry 0x0E (Sync error)) | UINT32 | RO | 0x6030:0E, 1
1A05:07 | SubIndex 0x007 | 7. PDO Mapping entry (object 0x6030 (ENC Inputs Ch.2), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6030:0F, 1
1A05:08 | SubIndex 0x008 | 8. PDO Mapping entry (object 0x6030 (ENC Inputs Ch.2), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6030:10, 1
1A05:09 | SubIndex 0x009 | 9. PDO Mapping entry (object 0x6030 (ENC Inputs Ch.2), entry 0x11 (Counter value)) | UINT32 | RO | 0x6030:11, 32
Index 0x1C00 Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the Sync Managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 0x1C12 RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x06 (6dec)
1C12:01 | Subindex 001 | 1. allocated RxPDO (contains the index 0x of the associated RxPDO mapping object) | UINT16 | RW | 0x1600 (5632dec)
1C12:02 | Subindex 002 | 2. allocated RxPDO (contains the index 0x of the associated RxPDO mapping object) | UINT16 | RW | 0x1603 (5635dec)
1C12:03 | Subindex 003 | 3. allocated RxPDO (contains the index 0x of the associated RxPDO mapping object) | UINT16 | RW | 0x1605 (5637dec)
1C12:04 | Subindex 004 | 4. allocated RxPDO (contains the index 0x of the associated RxPDO mapping object) | UINT16 | RW | 0x1608 (5640dec)
1C12:05 | Subindex 005 | 5. allocated RxPDO (contains the index 0x of the associated RxPDO mapping object) | UINT16 | RW | 0x160B (5643dec)
1C12:06 | Subindex 006 | 6. allocated RxPDO (contains the index 0x of the associated RxPDO mapping object) | UINT16 | RW | 0x160D (5645dec)
Index 0x1C13 TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x04 (4dec)
1C13:01 | Subindex 001 | 1. allocated TxPDO (contains the index 0x of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2. allocated TxPDO (contains the index 0x of the associated TxPDO mapping object) | UINT16 | RW | 0x1A01 (6657dec)
1C13:03 | Subindex 003 | 3. allocated TxPDO (contains the index 0x of the associated TxPDO mapping object) | UINT16 | RW | 0x1A03 (6659dec)
1C13:04 | Subindex 004 | 4. allocated TxPDO (contains the index 0x of the associated TxPDO mapping object) | UINT16 | RW | 0x1A05 (6661dec)
Index 0x1C32 SM output parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C32:0
SM output parameter
Synchronization parameters for the outputs
UINT8
RO
0x20 (32dec)
1C32:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dec)
1C32:02
Cycle time
Cycle time (in ns):
▪
Free Run: Cycle time of the local timer
▪
Synchron with SM 2 Event: Master cycle time
▪
DC mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dec)
1C32:03
Shift time
Time between SYNC0 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0 = 1: free run is supported
▪
Bit 1 = 1: Synchron with SM 2 Event is supported
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 10: Output Shift with SYNC1 event (only DC mode)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08)
UINT16
RO
0x4C07 (19463dec)
1C32:05
Minimum cycle time
Minimum cycle time (in ns)
UINT32
RO
0x000186A0 (100000dec)
1C32:06
Calc and copy time
Minimum time between SYNC0 and SYNC1 event (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:07
Minimum delay time
UINT32
RO
0x00000000 (0dec)
1C32:08
Command
▪
0: Measurement of the local cycle time is stopped
▪
1: Measurement of the local cycle time is started
The entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 are updated with the maximum measured values.
For a subsequent measurement the measured values are reset
UINT16
RW
0x0000 (0dec)
1C32:09
Maximum delay time
Time between SYNC1 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:0B
SM event missed counter
Number of missed SM events in OPERATIONAL (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:0C
Cycle exceeded counter
Number of occasions the cycle time was exceeded in OPERATIONAL (cycle was not completed in time or the next cycle began too early)
UINT16
RO
0x0000 (0dec)
1C32:0D
Shift too short counter
Number of occasions that the interval between SYNC0 and SYNC1 event was too short (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:20
Sync error
The synchronization was not correct in the last cycle (outputs were output too late; DC mode only)
BOOLEAN
RO
0x00 (0dec)
Index 0x1C33 SM input parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (no outputs available)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (outputs available)
UINT16
RW
0x0022 (34dec)
1C33:02
Cycle time
as 0x1C32:02
UINT32
RW
0x000F4240 (1000000dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: Synchron with SM 2 Event is supported (outputs available)
▪
Bit 1: Synchron with SM 3 Event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: Input Shift through local event (outputs available)
▪
Bit 4-5 = 10: Input Shift with SYNC1 Event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08 or 0x1C33:08)
UINT16
RO
0x4C07 (19463dec)
1C33:05
Minimum cycle time
as 0x1C32:05
UINT32
RO
0x000186A0 (100000dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:07
Minimum delay time
UINT32
RO
0x00000000 (0dec)
1C33:08
Command
as 0x1C32:08
UINT16
RW
0x0000 (0dec)
1C33:09
Maximum delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:0B
SM event missed counter
as 0x1C32:11
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
as 0x1C32:12
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
as 0x1C32:13
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
as 0x1C32:32
BOOLEAN
RO
0x00 (0dec)


Profile-specific objects (0x6000-0xFFFF)

Commissioning [image] EL2522-0000 [image] Object description and parameterization [image] Profile-specific objects (0x6000-0xFFFF)
Profile-specific objects (0x6000-0xFFFF)
Index 0x6000 PTO Inputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
6000:0 | PTO Inputs Ch.1 |  | UINT8 | RO | 0x10 (16dec)
6000:01 | Sel. Ack/End counter | Confirms the change of the base frequency with activated travel distance control: target counter value reached | BOOLEAN | RO | 0x00 (0dec)
6000:02 | Ramp active | Ramp is currently being followed | BOOLEAN | RO | 0x00 (0dec)
6000:07 | Error | General error bit, is set together with overrange and underrange | BOOLEAN | RO | 0x00 (0dec)
6000:0E | Sync error | The Sync error bit is only required for DC mode. It indicates whether a synchronization error has occurred during the previous cycle. | BOOLEAN | RO | 0x00 (0dec)
6000:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
Index 0x6010 PTO Inputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
6010:0 | PTO Inputs Ch.2 | Max. Subindex | UINT8 | RO | 0x10 (16dec)
6010:01 | Sel. Ack/End counter | Confirms the change of the base frequency with activated travel distance control: target counter value reached | BOOLEAN | RO | 0x00 (0dec)
6010:02 | Ramp active | Ramp is currently being followed | BOOLEAN | RO | 0x00 (0dec)
6010:07 | Error | General error bit, is set together with overrange and underrange | BOOLEAN | RO | 0x00 (0dec)
6010:0E | Sync error | The Sync error bit is only required for DC mode. It indicates whether a synchronization error has occurred during the previous cycle. | BOOLEAN | RO | 0x00 (0dec)
6010:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
Index 0x6020 ENC Inputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
6020:0 | ENC Inputs Ch.1 |  | UINT8 | RO | 0x11 (17dec)
6020:03 | Set counter done | The counter was set | BOOLEAN | RO | 0x00 (0dec)
6020:04 | Counter underflow | Counter underflow | BOOLEAN | RO | 0x00 (0dec)
6020:05 | Counter overflow | Counter overflow. | BOOLEAN | RO | 0x00 (0dec)
6020:0E | Sync error | The Sync error bit is only required for DC mode. It indicates whether a synchronization error has occurred during the previous cycle. | BOOLEAN | RO | 0x00 (0dec)
6020:0F | TxPDO State | Validity of the data of the associated TxPDO (0 = valid, 1 = invalid). | BOOLEAN | RO | 0x00 (0dec)
6020:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
6020:11 | Counter value | The counter value. | UINT32 | RO | 0x00000000 (0dec)
Index 0x6030 ENC Inputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
6030:0 | ENC Inputs Ch.2 | Max. Subindex | UINT8 | RO | 0x11 (17dec)
6030:03 | Set counter done | The counter was set | BOOLEAN | RO | 0x00 (0dec)
6030:04 | Counter underflow | Counter underflow | BOOLEAN | RO | 0x00 (0dec)
6030:05 | Counter overflow | Counter overflow. | BOOLEAN | RO | 0x00 (0dec)
6030:0E | Sync error | The Sync error bit is only required for DC mode. It indicates whether a synchronization error has occurred during the previous cycle. | BOOLEAN | RO | 0x00 (0dec)
6030:0F | TxPDO State | Validity of the data of the associated TxPDO (0 = valid, 1 = invalid). | BOOLEAN | RO | 0x00 (0dec)
6030:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
6030:11 | Counter value | The counter value. | UINT32 | RO | 0x00000000 (0dec)
Index 0x7000 PTO Outputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
7000:0 | PTO Outputs Ch.1 | Max. Subindex | UINT8 | RO | 0x13 (19dec)
7000:01 | Frequency select | Fast toggling of the base frequency (only if ramp function is deactivated) 0bin = base frequency 1 (object 0x8pp0:12) 1bin = base frequency 2 (object 0x8pp0:13) | BOOLEAN | RO | 0x00 (0dec)
7000:02 | Disable ramp | The ramp function is disabled despite active object 0x8pp0:06. | BOOLEAN | RO | 0x00 (0dec)
7000:03 | Go counter | If travel distance control is activated (object 0x8pp0:0A), a specified counter value is driven to if the bit is set | BOOLEAN | RO | 0x00 (0dec)
7000:04 | Automatic direction | The shortest direction is automatically determined | BOOLEAN | RW | 0x00 (0dec)
7000:05 | Forward | Manual specification of the output direction. ("Automatic direction" may not be set) | BOOLEAN | RW | 0x00 (0dec)
7000:06 | Backward | Manual specification of the output direction. ("Automatic direction" may not be set) | BOOLEAN | RW | 0x00 (0dec)
7000:11 | Frequency value | Output frequency | UINT16 | RO | 0x0000 (0dec)
7000:12 | Target counter value | Target counter value | UINT32 | RO | 0x00000000 (0dec)
7000:13 | Target arrival time | DC time at which the target counter value should be reached | UINT64 | RO |
Index 0x7010 PTO Outputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
7010:0 | PTO Outputs Ch.2 | Max. Subindex | UINT8 | RO | 0x13 (19dec)
7010:01 | Frequency select | Fast toggling of the base frequency (only if ramp function is deactivated) 0bin = base frequency 1 (object 0x8pp0:12) 1bin = base frequency 2 (object 0x8pp0:13) | BOOLEAN | RO | 0x00 (0dec)
7010:02 | Disable ramp | The ramp function is disabled despite active index 0x8pp0:06. | BOOLEAN | RO | 0x00 (0dec)
7010:03 | Go counter | If travel distance control is activated (object 0x8pp0:0A), a specified counter value is driven to if the bit is set | BOOLEAN | RO | 0x00 (0dec)
7010:04 | Automatic direction | The shortest direction is automatically determined | BOOLEAN | RW | 0x00 (0dec)
7010:05 | Forward | Manual specification of the output direction. ("Automatic direction" may not be set) | BOOLEAN | RW | 0x00 (0dec)
7010:06 | Backward | Manual specification of the output direction. ("Automatic direction" may not be set) | BOOLEAN | RW | 0x00 (0dec)
7010:11 | Frequency value | Output frequency | UINT16 | RO | 0x0000 (0dec)
7010:12 | Target counter value | Target counter value | UINT32 | RO | 0x00000000 (0dec)
7010:13 | Target arrival time | DC time at which the target counter value should be reached | UINT64 | RO |
Index 0x7020 ENC Outputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
7020:0 | ENC Outputs Ch.1 | Max. Subindex | UINT8 | RO | 0x11 (17dec)
7020:03 | Set counter | Set the counter value | BOOLEAN | RO | 0x00 (0dec)
7020:10 | Reserved |  | BOOLEAN | RO | 0x00 (0dec)
7020:11 | Set counter value | This is the counter value to be set by 0x7pp0:03 | UINT32 | RO | 0x00000000 (0dec)
Index 0x7030 ENC Outputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
7030:0 | ENC Outputs Ch.2 | Max. Subindex | UINT8 | RO | 0x11 (17dec)
7030:03 | Set counter | Set the counter value | BOOLEAN | RO | 0x00 (0dec)
7030:10 | Reserved |  | BOOLEAN | RO | 0x00 (0dec)
7030:11 | Set counter value | This is the counter value to be set by 0x7pp0:03 | UINT32 | RO | 0x00000000 (0dec)
Index 0xA000 PTO Diag data Ch.1
Index (hex)
Name
Meaning
Data type
Flags
Default
A000:0
PTO Diag data Ch.1
Max. Subindex
UINT8
RO
0x01 (1dec)
A000:01
Overspeed counter
Counts up if the calculated set position does not correspond to the actual position in the next cycle.
Possible causes:
▪
the output frequency is limited by the corresponding "Base frequency 1"
▪
Micro increments are active and the "internal 100 MHz" are exceeded
UINT16
RO
0x0000 (0dec)
Index 0xA010 PTO Diag data Ch.2
Index (hex)
Name
Meaning
Data type
Flags
Default
A010:0
PTO Diag data Ch.2
Max. Subindex
UINT8
RO
0x01 (1dec)
A010:01
Overspeed counter
Counts up if the calculated target position does not correspond to the actual position in the next cycle.
Possible causes:
▪
the output frequency is limited by the corresponding "Base frequency 1"
▪
Micro increments are active and the "internal 100 MHz" are exceeded
UINT16
RO
0x0000 (0dec)
Index 0xF000 Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0004 (4dec)
Index 0xF008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | currently reserved | UINT32 | RW | 0x00000000 (0dec)
Index 0xF010 Module list
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list | Max. Subindex | UINT8 | RW | 0x04 (4dec)
F010:01 | SubIndex 0x001 | Profile number 253 | UINT32 | RW | 0x000000FD (253dec)
F010:02 | SubIndex 0x002 | Profile number 253 | UINT32 | RW | 0x000000FD (253dec)
F010:03 | SubIndex 0x003 | Profile number 511 | UINT32 | RW | 0x000001FF (511dec)
F010:04 | SubIndex 0x004 | Profile number 511 | UINT32 | RW | 0x000001FF (511dec)


Objects for regular operation

Commissioning [image] EL2522-0000 [image] Object description and parameterization [image] Objects for regular operation
Objects for regular operation
In enhanced operating mode the EL2522 has no such objects.


Connection of the EL2522 in the NC

Commissioning [image] EL2522-0000 [image] Connection of the EL2522 in the NC
Connection of the EL2522 in the NC
Required Firmware (FW) Version and TwinCAT Version
At least FW Version 07 is required for Connection of terminal EL2522 to the NC;
TwinCAT-Versions:
- up to TC 2.11 R3 Build 2250
- up to TC 3.1 Build 4018.16 (recommended)
Procedure
When EL2522 terminal was added to TwinCAT-IO, the procedure is as follows:
1. Select a specific EL2522 operating mode
2. Link the non-referenced axes to the terminal
a)
b)
3. Set distributed clock: "DC-Synchronous" on "DC" tab
4. Set the frequency of the terminal in order to achieve the required velocity.
When using no up to date FW or rather not up dated TwinCAT versions, accordingly to the “Continues Position” Mode the following should be noticed, if applicable:
▪
Update the NC driver
▪
Add axis to the NC
As soon as (between step 2. And 3.):
▪
Link Axis/Drive/nOutData5 to the "Target Counter Value" of the terminal
a)
b)
▪
Link Axis/Drive/nCtrl1 to "Automatic Direction" of the terminal
a)
b)
c)


Appendix

Appendix
Appendix
Additional information
•
Firmware compatibility
•
Firmware Update EL/ES/EM/ELM/EPxxxx
•
Restoring the delivery state
•
Support and Service


Firmware compatibility

Appendix [image] Firmware compatibility
Firmware compatibility
Beckhoff EtherCAT devices are delivered with the latest available firmware version. Compatibility of firmware and hardware is mandatory; not every combination ensures compatibility. The overview below shows the hardware versions on which a firmware can be operated.
Note
▪
It is recommended to use the newest possible firmware for the respective hardware.
▪
Beckhoff is not under any obligation to provide customers with free firmware updates for delivered products.
Note
Risk of damage to the device!
Pay attention to the instructions for firmware updates on the separate page.
If a device is placed in BOOTSTRAP mode for a firmware update, it does not check when downloading whether the new firmware is suitable. This can result in damage to the device!
Therefore, always make sure that the firmware is suitable for the hardware version!
EL2521
Hardware (HW) | Firmware | Revision no. | Date of release
02 | 03 | EL2521-0000-0016 | 2008/08
02 - 05 | 04 |  | 2008/09
 | 05 |  | 2008/09
05 - 15* | 06 | EL2521-0000-0018 | 2009/01
 | 07 | EL2521-0000-0019 | 2011/01
 | 08 |  | 2011/04
 | 09 |  | 2011/04
 | 10 |  | 2012/04
 |  | EL2521-0000-0020 | 2012/05
 |  | EL2521-0000-0021 | 2012/07
 | 11* |  | 2014/05
 |  | EL2521-0000-0022 | 2014/11
EL2521-0024
Hardware (HW) | Firmware | Revision no. | Date of release
05 - 16* | 06 | EL2521-0024-1016/17 | 2009/01
 | 07 | EL2521-0024-1018 | 2011/01
 | 08 |  | 2011/04
 | 09 |  | 2011/04
 | 10 |  | 2012/04
 |  | EL2521-0024-1019 | 2012/05
 |  | EL2521-0024-1020 | 2012/07
 | 11* |  | 2014/05
 |  | EL2521-0024-1021 | 2014/11
EL2521-0124
Hardware (HW) | Firmware | Revision no. | Date of release
05 - 06 | 01 | EL2521-0124-0016 | 2009/09
 | 02 |  | 2010/03
 | 03 | EL2521-0124-0017 | 2010/06
06 - 15* | 04 | EL2521-0124-0018 | 2011/01
 | 05 |  | 2011/05
 |  | EL2521-0124-0019 | 2012/05
 |  | EL2521-0124-0020 | 2012/07
 | 06* |  | 2014/06
EL2521-0025
Hardware (HW) | Firmware | Revision no. | Date of release
00 - 08* | 06 | EL2521-0025-1016/17 | 2009/12
 | 07 | EL2521-0025-1018 | 2011/01
 | 08 |  | 2011/04
 | 09 |  | 2011/04
 | 10 |  | 2012/04
 |  | EL2521-0025-1019 | 2012/05
 |  | EL2521-0025-1020 | 2012/07
 | 11* |  | 2014/05
 |  | EL2521-0025-1021 | 2014/11
EL2521-1001
Hardware (HW) | Firmware | Revision no. | Date of release
02 | 03 | EL2521-1001-0016 | 2008/08
02 - 05 | 04 |  | 2008/09
 | 05 |  | 2008/09
05 - 13* | 06 | EL2521-1001-0017 | 2009/01
 | 07 | EL2521-1001-0018 | 2011/01
 | 08 |  | 2011/04
 | 09 |  | 2011/04
 | 10 |  | 2012/04
 |  | EL2521-1001-0019 | 2012/05
 |  | EL2521-1001-0020 | 2012/07
 | 11* |  | 2014/05
EL2522-0000
Hardware (HW) | Firmware | Revision no. | Date of release
00 - 05* | 01 | EL2522-0000-0016 | 2013/12
 | 02 | EL2522-0000-0017 | 2014/08
 | 03 | EL2522-0000-0018 | 2014/09
 | 04 | EL2522-0000-0019 | 2015/01
 | 05 | EL2522-0000-0020 | 2015/01
 | 06 | EL2522-0000-0021 | 2015/01
 | 07* | EL2522-0000-0022 | 2015/07
*) This is the current compatible firmware/hardware version at the time of the preparing this documentation. Check on the Beckhoff web page whether more up-to-date documentation is available.


Firmware Update EL/ES/EM/ELM/EPxxxx

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx
Firmware Update EL/ES/EM/ELM/EPxxxx
This section describes the device update for Beckhoff EtherCAT slaves from the EL/ES, ELM, EM, EK and EP series. A firmware update should only be carried out after consultation with Beckhoff support.
Storage locations
An EtherCAT slave stores operating data in up to 3 locations:
▪
Depending on functionality and performance EtherCAT slaves have one or several local controllers for processing I/O data. The corresponding program is the so-called firmware in *.efw format.
▪
In some EtherCAT slaves the EtherCAT communication may also be integrated in these controllers. In this case the controller is usually a so-called FPGA chip with *.rbf firmware.
▪
In addition, each EtherCAT slave has a memory chip, a so-called ESI-EEPROM, for storing its own device description (ESI: EtherCAT Slave Information). On power-up this description is loaded and the EtherCAT communication is set up accordingly. The device description is available from the download area of the Beckhoff website at (https://www.beckhoff.de). All ESI files are accessible there as zip files.
Customers can access the data via the EtherCAT fieldbus and its communication mechanisms. Acyclic mailbox communication or register access to the ESC is used for updating or reading of these data.
The TwinCAT System Manager offers mechanisms for programming all 3 parts with new data, if the slave is set up for this purpose. Generally the slave does not check whether the new data are suitable, i.e. it may no longer be able to operate if the data are unsuitable.
Simplified update by bundle firmware
The update using so-called bundle firmware is more convenient: in this case the controller firmware and the ESI description are combined in a *.efw file; during the update both the firmware and the ESI are changed in the terminal. For this to happen it is necessary
▪
for the firmware to be in a packed format: recognizable by the file name, which also contains the revision number, e.g. ELxxxx-xxxx_REV0016_SW01.efw
▪
for password=1 to be entered in the download dialog. If password=0 (default setting) only the firmware update is carried out, without an ESI update.
▪
for the device to support this function. The function usually cannot be retrofitted; it is a component of many new developments from year of manufacture 2016.
Following the update, its success should be verified
▪
ESI/Revision: e.g. by means of an online scan in TwinCAT ConfigMode/FreeRun – this is a convenient way to determine the revision
▪
Firmware: e.g. by looking in the online CoE of the device
Note
Risk of damage to the device!
Note the following when downloading new device files

• Firmware downloads to an EtherCAT device must not be interrupted
• Flawless EtherCAT communication must be ensured. CRC errors or LostFrames must be avoided.
• The power supply must adequately dimensioned. The signal level must meet the specification.

In the event of malfunctions during the update process the EtherCAT device may become unusable and require re-commissioning by the manufacturer.
Additional information
•
Device description ESI file/XML
•
Firmware explanation
•
Updating controller firmware *.efw
•
FPGA firmware *.rbf
•
Simultaneous updating of several EtherCAT devices


Device description ESI file/XML

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Device description ESI file/XML
Device description ESI file/XML
Note
Attention regarding update of the ESI description/EEPROM
Some slaves have stored calibration and configuration data from the production in the EEPROM. These are irretrievably overwritten during an update.
The ESI device description is stored locally on the slave and loaded on start-up. Each device description has a unique identifier consisting of slave name (9 characters/digits) and a revision number (4 digits). Each slave configured in the System Manager shows its identifier in the EtherCAT tab:
Device identifier consisting of name EL3204-0000 and revision -0016
The configured identifier must be compatible with the actual device description used as hardware, i.e. the description which the slave has loaded on start-up (in this case EL3204). Normally the configured revision must be the same or lower than that actually present in the terminal network.
For further information on this, please refer to the EtherCAT system documentation.
Update of XML/ESI description
The device revision is closely linked to the firmware and hardware used. Incompatible combinations lead to malfunctions or even final shutdown of the device. Corresponding updates should only be carried out in consultation with Beckhoff support.
Display of ESI slave identifier
The simplest way to ascertain compliance of configured and actual device description is to scan the EtherCAT boxes in TwinCAT mode Config/FreeRun:
Scan the subordinate field by right-clicking on the EtherCAT device
If the found field matches the configured field, the display shows
Configuration is identical
otherwise a change dialog appears for entering the actual data in the configuration.
Change dialog
In this example in Fig. Change dialog, an EL3201-0000-0017 was found, while an EL3201-0000-0016 was configured. In this case the configuration can be adapted with the Copy Before button. The Extended Information checkbox must be set in order to display the revision.
Changing the ESI slave identifier
The ESI/EEPROM identifier can be updated as follows under TwinCAT:
▪
Trouble-free EtherCAT communication must be established with the slave.
▪
The state of the slave is irrelevant.
▪
Right-clicking on the slave in the online display opens the EEPROM Update dialog, Fig. EEPROM Update
EEPROM Update
The new ESI description is selected in the following dialog, see Fig. Selecting the new ESI. The checkbox Show Hidden Devices also displays older, normally hidden versions of a slave.
Selecting the new ESI
A progress bar in the System Manager shows the progress. Data are first written, then verified.
The change only takes effect after a restart.
Most EtherCAT devices read a modified ESI description immediately or after startup from the INIT. Some communication settings such as distributed clocks are only read during power-on. The EtherCAT slave therefore has to be switched off briefly in order for the change to take effect.


Firmware explanation

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Firmware explanation
Firmware explanation
Determining the firmware version
Determining the version on laser inscription
Beckhoff EtherCAT slaves feature serial numbers applied by laser. The serial number has the following structure: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with ser. no.: 12 10 03 02:
12 - week of production 12
10 - year of production 2010
03 - firmware version 03
02 - hardware version 02
Determining the version via the System Manager
The TwinCAT System Manager shows the version of the controller firmware if the master can access the slave online. Click on the E-Bus Terminal whose controller firmware you want to check (in the example terminal 2 (EL3204)) and select the tab CoE Online (CAN over EtherCAT).
CoE Online and Offline CoE
Two CoE directories are available:
• online: This is offered in the EtherCAT slave by the controller, if the EtherCAT slave supports this. This CoE directory can only be displayed if a slave is connected and operational.
• offline: The EtherCAT Slave Information ESI/XML may contain the default content of the CoE. This CoE directory can only be displayed if it is included in the ESI (e.g. "Beckhoff EL5xxx.xml").
The Advanced button must be used for switching between the two views.
In Fig. Display of EL3204 firmware version the firmware version of the selected EL3204 is shown as 03 in CoE entry 0x100A.
Display of EL3204 firmware version
In (A) TwinCAT 2.11 shows that the Online CoE directory is currently displayed. If this is not the case, the Online directory can be loaded via the Online option in Advanced Settings (B) and double-clicking on AllObjects.


Updating controller firmware *.efw

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Updating controller firmware *.efw
Updating controller firmware *.efw
CoE directory
The Online CoE directory is managed by the controller and stored in a dedicated EEPROM, which is generally not changed during a firmware update.
Switch to the Online tab to update the controller firmware of a slave, see Fig. Firmware Update.
Firmware Update
Proceed as follows, unless instructed otherwise by Beckhoff support. Valid for TwinCAT 2 and 3 as EtherCAT master.
▪
Switch TwinCAT system to ConfigMode/FreeRun with cycle time >= 1 ms (default in ConfigMode is 4 ms). A FW-Update during real time operation is not recommended.
▪
Switch EtherCAT Master to PreOP
▪
Switch slave to INIT (A)
▪
Switch slave to BOOTSTRAP
▪
Check the current status (B, C)
▪
Download the new *efw file (wait until it ends). A pass word will not be neccessary usually.
▪
After the download switch to INIT, then PreOP
▪
Switch off the slave briefly (don't pull under voltage!)
▪
Check within CoE 0x100A, if the FW status was correctly overtaken.


FPGA firmware *.rbf

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] FPGA firmware *.rbf
FPGA firmware *.rbf
If an FPGA chip deals with the EtherCAT communication an update may be accomplished via an *.rbf file.
▪
Controller firmware for processing I/O signals
▪
FPGA firmware for EtherCAT communication (only for terminals with FPGA)
The firmware version number included in the terminal serial number contains both firmware components. If one of these firmware components is modified this version number is updated.
Determining the version via the System Manager
The TwinCAT System Manager indicates the FPGA firmware version. Click on the Ethernet card of your EtherCAT strand (Device 2 in the example) and select the Online tab.
The Reg:0002 column indicates the firmware version of the individual EtherCAT devices in hexadecimal and decimal representation.
FPGA firmware version definition
If the column Reg:0002 is not displayed, right-click the table header and select Properties in the context menu.
Context menu Properties
The Advanced Settings dialog appears where the columns to be displayed can be selected. Under Diagnosis/Online View select the '0002 ETxxxx Build' check box in order to activate the FPGA firmware version display.
Dialog Advanced Settings
Update
For updating the FPGA firmware
▪
of an EtherCAT coupler the coupler must have FPGA firmware version 11 or higher;
▪
of an E-Bus Terminal the terminal must have FPGA firmware version 10 or higher.
Older firmware versions can only be updated by the manufacturer!
Updating an EtherCAT device
The following sequence order have to be met if no other specifications are given (e.g. by the Beckhoff support):
▪
Switch TwinCAT system to ConfigMode/FreeRun with cycle time >= 1 ms (default in ConfigMode is 4 ms). A FW-Update during real time operation is not recommended.
▪
In the TwinCAT System Manager select the terminal for which the FPGA firmware is to be updated (in the example: Terminal 5: EL5001) and
click the Advanced Settings button in the EtherCAT tab:
▪
The Advanced Settings dialog appears. Under ESC Access/E²PROM/FPGA click on Write FPGA button:
▪
Select the file (*.rbf) with the new FPGA firmware, and transfer it to the EtherCAT device:
▪
Wait until download ends
▪
Switch slave current less for a short time (don't pull under voltage!). In order to activate the new FPGA firmware a restart (switching the power supply off and on again) of the EtherCAT device is required.
▪
Check the new FPGA status
Note
Risk of damage to the device!
A download of firmware to an EtherCAT device must not be interrupted in any case! If you interrupt this process by switching off power supply or disconnecting the Ethernet link, the EtherCAT device can only be recommissioned by the manufacturer!


Simultaneous updating of several EtherCAT devices

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Simultaneous updating of several EtherCAT devices
Simultaneous updating of several EtherCAT devices
The firmware and ESI descriptions of several devices can be updated simultaneously, provided the devices have the same firmware file/ESI.
Multiple selection and firmware update
Select the required slaves and carry out the firmware update in BOOTSTRAP mode as described above.


Restoring the delivery state

Appendix [image] Restoring the delivery state
Restoring the delivery state
To restore the delivery state for backup objects in ELxxxx terminals, the CoE object Restore default parameters, SubIndex 001 can be selected in the TwinCAT System Manager (Config mode) (see Fig. Selecting the Restore default parameters PDO)
Selecting the "Restore default parameters" PDO
Double-click on SubIndex 001 to enter the Set Value dialog. Enter the value 1684107116 in field Dec or the value 0x64616F6C in field Hex and confirm with OK (Fig. Entering a restore value in the Set Value dialog).
All backup objects are reset to the delivery state.
Entering a restore value in the Set Value dialog
Alternative restore value
In some older terminals the backup objects can be switched with an alternative restore value: Decimal value: 1819238756, Hexadecimal value: 0x6C6F6164An incorrect entry for the restore value has no effect.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com