EL2521 - 1 Channel Pulse Train Output Terminal

BECKHOFF Fieldbus Components

Documentation for

1 Channel Pulse Train Output Terminal

EL2521-0000

RS422

EL2521-0024

24 VDC, external feeding

EL2521-0124

24 VDC, external feeding, latch input/24 V output

EL2521-0025

24 VDC, external feeding, negative switching

Version: 2.8
Date: 2015-03-31

EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.


Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending

The EtherCAT Technology is covered, including but not limited to the following patent applications and patents:
EP1590927, EP1789857, DE102004044764, DE102007017835
with corresponding applications or registrations in various other countries.

The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.

Copyright

© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Safety rules

Consider the following safety instructions and descriptions!
Product specific safety instructions are to be found on the following pages or in the areas mounting, wiring, commissioning etc.

Disclaimer

All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.

Personnel qualification

This description is only intended for the use of trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.

Description of symbols

The following symbols with a adjoining safety advise or notice are used in this documentation. You have to read the safety advices carefully and adhere them strictly!

DANGER 		Acute risk of injury!
If you do not adhere the safety advise adjoining this symbol, there is immediate danger to life and health of individuals!

WARNING 		Risk of injury!
If you do not adhere the safety advise adjoining this symbol, there is danger to life and health of individuals!

CAUTION 		Hazard to individuals!
If you do not adhere the safety advise adjoining this symbol, there is obvious hazard to individuals!

Attention 		Hazard to devices and environment
If you do not adhere the notice adjoining this symbol, there is obvious hazard to materials and environment.

Note 		Note or pointer
This symbol indicates information that contributes to better understanding.


EL2521 - Documentation issue status

BECKHOFF EL2521: Foreword

Documentation issue status

Version | Comment
2.8 | - Update chapter "Technical data" - Addenda chapter "Installation instructions for enhanced mechanical load capacity" - Update structure
2.7 | - Update chapter "Functionality"
2.6 | - Update Ramp distance control
2.5 | - Update Technical data
2.4 | - Firmware compatibility list and Technical data added
2.3 | - Update LED description
2.2 | - EL2521-0124 added
2.1 | - EL2521-0024, EL2521-0025 added
2.0 | - Technical data, CoE, PDO added
1.0 | - Correction Technical data
0.1 | - First provisional documentation for EL2521


Version identification

BECKHOFF: Foreword

Version identification of EtherCAT devices

Designation

A Beckhoff EtherCAT device has a 14-digit designation, made up of

  • family key
  • type
  • version
  • revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017

Notes

  • the elements named above make up the technical designation
  • The order designation, conversely, is made up of
    - family key (EL, EP, CU, ES, KL, CX, etc.
    - type
    - version
  • The revision shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
    In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
    Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff website.
    The revision has been applied to the IP20 terminals on the outside since 2014/01, see fig. 1.
  • The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.

Identification number

Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:

Production lot/batch number/serial number/date code/D number

Serial number is the name generally given to the 8-digit number that is printed on the device or attached to it on a sticker. This serial number indicates the as-built status on delivery and thus ambiguously marks a whole production lot.

Structure of the serial number: KK YY FF HH

KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version

Example with ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02

Exceptions can occur in the IP67 area , where the following syntax can be used (see respective device documentation):

Syntax: D ww yy x y z u

D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB

Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1

Unique serial number/ID

Beyond that there are some series in which each individual module has its own unique, sequential serial number.

See also the further documentation in the area

  • IP67: EtherCAT Box
  • Safety: TwinSafe
Examples of markings:

Fig. 1: EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)

Fig. 2: EK1100 EtherCAT coupler, standard IP20 IO device with batch number

Fig. 3: CU2016 switch with batch number

Fig. 4: EL3202-0020 with batch numbers 26131006 and unique D-number 204418

Fig. 5: EP1258-00001 IP67 EtherCAT Box with batch number 22090101 and serial number 158102

Fig. 6: EP1908-0002 IP76 EtherCAT Safety Box with batch number 071201FF and serial number 00346070

Fig. 7: EL2904 IP20 safety terminal with batch number/date code 50110302 and serial number 00331701


EL2521 - Introduction

1 Channel Pulse Train Output Terminal

The EL2521 terminal outputs a predefined sequence of pulses via two RS422 compatible differential outputs. The correlation between channel A and channel B is adjustable, e.g. as encoder functionality. The pulse number and frequency is preset by a 16 bit value from the automation unit. The EtherCAT Terminal indicates its signal state by means of light emitting diodes. The LEDs are driven in time with the outputs and each displays an active output. The electrical isolation from the E-Bus is given.

The EL2521-0024 version has two potential-free outputs driven by two FET switches and is external fed. The EL2521-0025 variant has two potential-free negative switched outputs driven by two FET switches and is also external fed. Please consider the logic reversal. The EL2521-0124 as a n other variant is equipped with a latch input and a 24 V output..

Quick links

• EtherCAT basics
• Commissioning
• CoE description EL2521-00xx - normal operation mode
• CoE description EL2521-00xx - enhanced operation mode
• CoE description EL2521-0124
• Process data and operation modes


EL2521 - Technical data

Technical data | EL2521-0000 | EL2521-0024 | EL2521-0124 | EL2521-0025
Number of outputs | 1 channel (2 differential outputs A, B) | 1 channel (2 potential-free FET outputs) | 1 channel (2 FET outputs) 1 x 24 V output | 1 channel (2 potential-free FET outputs) negative switching
Number of inputs | 2 (+T, +Z) |  | 1 x latch input (5..24 VDC) | 2 (+T, +Z)
Signal voltage | RS422 level | 5..24 V DC, external feeding | 24 V DC, external feeding | 5..24 V DC, external feeding
Load | RS422 and optocoupler, min. 220 Ω | variable
Output current max. (p. channel) | 50 mA, RS422 specification | max. 1 A
Switching threshold "T" and "Z" inputs | High: >5 V (max. 24 VDC), Low: <1 V
Base frequency | 0 ... 500 kHz, Default: 50 kHz
Resolution | max. 15 bit
Step size | 10 mHz
Supply voltage for internal E-bus circuit | via E-bus
Curr. consump. via E-bus | typ. 280 mA (load-dependent)
Electrical isolation | 500 V (E bus/field potential)
Bits width in process image | 16 bit Data in, 16 bit Data out, 16 bit Control, 16 Bit status
Configuration | no address setting, configuration via TwinCAT System Manager
Weight | approx. 55 g
Operating temperature | 0 °C ... + 55 °C
Storage temperature | -25 °C ... + 85 °C
Relative humidity | 95%, no condensation
Dimensions | approx. 15 mm x 100 mm x 70 mm (width aligned: 12 mm)
Mounting | on 35 mm mounting rail conforms to EN 60715
Vibration/shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27, see Installation instructions for enhanced mechanical load capacity | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance burst/ESD | conforms to EN 61000-6-2/EN 61000-6-4
Protect. class | IP 20
Installation pos. | variable
Approval | CE ATEX cULus


Start

For commissioning:

  • mount the EL2521 as explained in the chapter "Mounting and wiring"
  • configure the EL2521 in TwinCAT as explained in the chapter "Commissioning"


EtherCAT - EtherCAT basics

BECKHOFF EtherCAT: Basics communication

EtherCAT basics

Please refer to the chapter EtherCAT System Documentation for the EtherCAT fieldbus basics.


EtherCAT cabeling

BECKHOFF EtherCAT: Basics communication

EtherCAT cabling – wire-bound

The cable length between two EtherCAT devices must not exceed 100 m. This results from the FastEthernet technology, which, above all for reasons of signal attenuation over the length of the cable, allows a maximum link length of 5 + 90 + 5 m if cables with appropriate properties are used. See also the Design recommendations for the infrastructure for EtherCAT/Ethernet.

Cables and connectors

For connecting EtherCAT devices only Ethernet connections (cables + plugs) that meet the requirements of at least category 5 (CAt5) according to EN 50173 or ISO/IEC 11801 should be used. EtherCAT uses 4 wires for signal transfer.

EtherCAT uses RJ45 plug connectors, for example. The pin assignment is compatible with the Ethernet standard (ISO/IEC 8802-3).

Pin | Color of conductor | Signal | Description
1 | yellow | TD + | Transmission Data +
2 | orange | TD - | Transmission Data -
3 | white | RD + | Receiver Data +
6 | blue | RD - | Receiver Data -

Due to automatic cable detection (auto-crossing) symmetric (1:1) or cross-over cables can be used between EtherCAT devices from Beckhoff.

Note 		Recommended cables
Suitable cables for the connection of EtherCAT devices can be found on the Beckhoff website!

E-Bus supply

A bus coupler can supply the EL terminals added to it with the E-bus system voltage of 5 V; a coupler is thereby loadable up to 2A as a rule (see details in respective device documentation).
Information on how much current each EL terminal requires from the E-bus supply is available online and in the catalogue. If the added terminals require more current than the coupler can supply, then power feed terminals (e.g. EL9400) must be inserted at appropriate places in the terminal strand.

The pre-calculated theoretical maximum E-bus current is displayed in the TwinCAT System Manager. A shortfall is marked by a negative total amount and an exclamation mark; a power feed terminal is to be placed before such a position.

Fig. 1: System manager current calculation

Attention 		Caution! Malfunction possible!
The same ground potential must be used for the E-Bus supply of all EtherCAT terminals in a terminal block!


EtherCAT - General notes for setting the watchdog

BECKHOFF EtherCAT: Basics communication

General notes for setting the watchdog

ELxxxx terminals are equipped with a safety feature (watchdog) that switches off the outputs after a specifiable time e.g. in the event of an interruption of the process data traffic, depending on the device and settings, e.g. in OFF state.

The EtherCAT slave controller (ESC) in the EL2xxx terminals features 2 watchdogs:

  • SM watchdog (default: 100 ms)
  • PDI watchdog (default: 100 ms)

SM watchdog (SyncManager Watchdog)

The SyncManager watchdog is reset after each successful EtherCAT process data communication with the terminal. If no EtherCAT process data communication takes place with the terminal for longer than the set and activated SM watchdog time, e.g. in the event of a line interruption, the watchdog is triggered and the outputs are set to FALSE. The OP state of the terminal is unaffected. The watchdog is only reset after a successful EtherCAT process data access. Set the monitoring time as described below.

The SyncManager watchdog monitors correct and timely process data communication with the ESC from the EtherCAT side.

PDI watchdog (Process Data Watchdog)

If no PDI communication with the EtherCAT slave controller (ESC) takes place for longer than the set and activated PDI watchdog time, this watchdog is triggered.
PDI (Process Data Interface) is the internal interface between the ESC and local processors in the EtherCAT slave, for example. The PDI watchdog can be used to monitor this communication for failure.

The PDI watchdog monitors correct and timely process data communication with the ESC from the application side.

The settings of the SM- and PDI-watchdog must be done for each slave separately in the TwinCAT System Manager.

Fig. 1 EtherCAT tab -> Advanced Settings -> Behavior -> Watchdog

Notes:

  • the multiplier is valid for both watchdogs.
  • each watchdog has its own timer setting, the outcome of this in summary with the multiplier is a resulting time.
  • Important: the multiplier/timer setting is only loaded into the slave at the start up, if the checkbox is activated.
    If the checkbox is not activated, nothing is downloaded and the ESC settings remain unchanged.

Multiplier

Both watchdogs receive their pulses from the local terminal cycle, divided by the watchdog multiplier:

1/25 MHz * (watchdog multiplier + 2) = 100 µs (for default setting of 2498 for the multiplier)

The standard setting of 1000 for the SM watchdog corresponds to a release time of 100 ms.

The value in multiplier + 2 corresponds to the number of basic 40 ns ticks representing a watchdog tick.
The multiplier can be modified in order to adjust the watchdog time over a larger range.

Example "Set SM watchdog"

This checkbox enables manual setting of the watchdog times. If the outputs are set and the EtherCAT communication is interrupted, the SM watchdog is triggered after the set time and the outputs are erased. This setting can be used for adapting a terminal to a slower EtherCAT master or long cycle times. The default SM watchdog setting is 100 ms. The setting range is 0..65535. Together with a multiplier with a range of 1..65535 this covers a watchdog period between 0..~170 seconds.

Calculation

Multiplier = 2498 → watchdog base time = 1 25 MHz * (2498 + 2) = 0.0001 seconds = 100 µs
SM watchdog = 10000 → 10000 * 100 µs = 1 second watchdog monitoring time

CAUTION 		CAUTION! Undefined state possible!
The function for switching off of the SM watchdog via SM watchdog = 0 is only implemented in terminals from version -0016.
In previous versions this operating mode should not be used.

CAUTION 		CAUTION! Damage of devices and undefined state possible!
If the SM watchdog is activated and a value of 0 is entered the watchdog switches off completely. This is the deactivation of the watchdog!
Set outputs are NOT set in a safe state, if the communication is interrupted.

Note 		Outputs in SAFEOP state
The default set watchdog monitoring sets the outputs of the module in a safe state - depending on the settings in SAFEOP and OP - e.g. in OFF state.
If this is prevented by deactivation of the watchdog monitoring in the module, the outputs can be switched or set also in the SAFEOP state.


EtherCAT State Machine

The state of the EtherCAT slave is controlled via the EtherCAT State Machine (ESM). Depending upon the state, different functions are accessible or executable in the EtherCAT slave. Specific commands must be sent by the EtherCAT master to the device in each state, particularly during the bootup of the slave.

A distinction is made between the following states:

  • Init
  • Pre-Operational
  • Safe-Operational and
  • Operational
  • Boot

The regular state of each EtherCAT slave after bootup is the OP state.

Init

After switch-on the EtherCAT slave in the Init state. No mailbox or process data communication is possible. The EtherCAT master initializes sync manager channels 0 and 1 for mailbox communication.

Pre-Operational (Pre-Op)

During the transition between Init and Pre-Op the EtherCAT slave checks whether the mailbox was initialized correctly.

In Pre-Op state mailbox communication is possible, but not process data communication. The EtherCAT master initializes the sync manager channels for process data (from sync manager channel 2), the FMMU channels and, if the slave supports configurable mapping, PDO mapping or the sync manager PDO assignment. In this state the settings for the process data transfer and perhaps terminal-specific parameters that may differ from the default settings are also transferred.

Safe-Operational (Safe-Op)

During transition between Pre-Op and Safe-Op the EtherCAT slave checks whether the sync manager channels for process data communication and, if required, the distributed clocks settings are correct. Before it acknowledges the change of state, the EtherCAT slave copies current input data into the associated DP-RAM areas of the EtherCAT slave controller (ECSC).

In Safe-Op state mailbox and process data communication is possible, although the slave keeps its outputs in a safe state, while the input data are updated cyclically.

Note 		Outputs in SAFEOP state
The default set watchdog monitoring sets the outputs of the module in a safe state - depending on the settings in SAFEOP and OP - e.g. in OFF state.
If this is prevented by deactivation of the watchdog monitoring in the module, the outputs can be switched or set also in the SAFEOP state.

Operational (Op)

Before the EtherCAT master switches the EtherCAT slave from Safe-Op to Op it must transfer valid output data.

In the Op state the slave copies the output data of the masters to its outputs. Process data and mailbox communication is possible.

Boot

In the Boot state the slave firmware can be updated. The Boot state can only be reached via the Init state.

In the Boot state mailbox communication via the file access over EtherCAT (FoE) protocol is possible, but no other mailbox communication and no process data communication.


CoE Interface

Table of contents
• General description
 • Data management
 • Online/offline list
 • Channel-based order

General description

The CoE interface (CANopen over EtherCAT) is used for parameter management of EtherCAT devices. EtherCAT slaves or the EtherCAT master manage fixed (read only) or variable parameters which they require for operation, diagnostics or commissioning.

CoE parameters are arranged in a table hierarchy. In principle, the user has read access via the fieldbus. The EtherCAT master (TwinCAT System Manager) can access the local CoE lists of the slaves via EtherCAT in read or write mode, depending on the attributes.

Different CoE parameter types are possible, including string (text), integer numbers, Boolean values or larger byte fields. They can be used to describe a wide range of features. Examples of such parameters include manufacturer ID, serial number, process data settings, device name, calibration values for analog measurement or passwords.

The order is specified in 2 levels via hexadecimal numbering: (main)index, followed by subindex. The value ranges are

  • Index: 0...65535
  • SubIndex: 0...255

A parameter localized in this way is normally written as x8010:07, with preceding "x" to identify the hexadecimal numerical range and a colon between index and subindex.

The relevant ranges for EtherCAT fieldbus users are:

  • x1000: This is where fixed identity information for the device is stored, including name, manufacturer, serial number etc., plus information about the current and available process data configurations.
  • x8000: This is where the operational and functional parameters for all channels are stored, such as filter settings or output frequency.

Other important ranges are:

  • x4000: In some EtherCAT devices the channel parameters are stored here (as an alternative to the x8000 range).
  • x6000: Input PDOs ("input" from the perspective of the EtherCAT master)
  • x7000: Output PDOs ("output" from the perspective of the EtherCAT master)

Note 		Availability
Not every EtherCAT device must have a CoE list.
Simple I/O modules without dedicated processor usually have no variable parameters and therefore no CoE list..

If a device has a CoE list, it is shown in the TwinCAT System Manager as a separate tab with a listing of the elements:

Fig. 1: "CoE Online " tab

Fig. 1 shows the CoE objects available in device "EL2502", ranging from x1000 to x1600. The subindices for x1018 are expanded.

Data management

Some parameters, particularly the setting parameters of the slave, are configurable and writeable. This can be done in write or read mode

  • via the System Manager (Fig. 1) by clicking
    This is useful for commissioning of the system/slaves. Click on the row of the index to be parameterised and enter a value in the "SetValue" dialog.
  • from the control system/PLC via ADS, e.g. through blocks from the TcEtherCAT.lib library
    This is recommended for modifications while the system is running or if no System Manager or operating staff are available.

Note 		Data management
If slave CoE parameters are modified online, Beckhoff devices store any changes in a fail-safe manner in the EEPROM, i.e. the modified CoE parameters are still available after a restart.

The situation may be different with other manufacturers.

An EEPROM is subject to a limited lifetime with respect to write operations. From typically 100,000 write operations onwards it can no longer be guaranteed that new (changed) data are reliably saved or are still readable. This is irrelevant for normal commissioning. However, if CoE parameters are continuously changed via ADS at machine runtime, it is quite possible for the lifetime limit to be reached. Support for the NoCoeStorage function, which suppresses the saving of changed CoE values, depends on the firmware version.
  • If the function is supported: the function is activated by entering the code word 0x12345678 once in CoE 0xF008 and remains active as long as the code word is not changed. After switching the device on it is then inactive. Changed CoE values are not saved in the EEPROM and can thus be changed any number of times.
  • Function not supported: continuous changing of CoE values is not permissible in view of the lifetime limit.

Please refer to the technical data in this documentation as to whether this applies to the respective device.

Start-up list

Note 		Startup list
Changes in the local CoE list of the terminal are lost if the terminal is replaced. If a terminal is replaced with a new Beckhoff terminal, it will have the default settings. It is therefore advisable to link all changes in the CoE list of an EtherCAT slave with the Startup list of the slave, which is processed whenever the EtherCAT fieldbus is started. In this way a replacement EtherCAT slave can automatically be parameterised with the specifications of the user.

If EtherCAT slaves are used which are unable to store local CoE values permanently, the Startup list must be used.

Recommended approach for manual modification of CoE parameters

  • Make the required change in the System Manager
    The values are stored locally in the EtherCAT slave
  • If the value is to be stored permanently, enter it in the Startup list.
    The order of the Startup entries is usually irrelevant.

Fig. 2: Startup list in the TwinCAT System Manager

The Startup list may already contain values that were configured by the System Manager based on the ESI specifications. Additional application-specific entries can be created.

Online/offline list

While working with the TwinCAT System Manager, a distinction has to be made whether the EtherCAT device is "available", i.e. switched on and linked via EtherCAT and therefore online, or whether a configuration is created offline without connected slaves.

In both cases a CoE list as shown in Fig. 1 is displayed. The connectivity is shown as offline/online.

  • If the slave is offline
    - The offline list from the ESI file is displayed. In this case modifications are not meaningful or possible.
    - The configured status is shown under Identity.
    - No firmware or hardware version is displayed, since these are features of the physical device.
    - Offline is shown in red.

    Fig. 3: Offline list
  • If the slave is online
    - The actual current slave list is read. This may take several seconds, depending on the size and cycle time.
    - The actual identity is displayed
    - The firmware and hardware version of the equipment according to the electronic information is displayed
    - Online is shown in green.

    Fig. 4: Online list

Channel-based order

The CoE list is available in EtherCAT devices that usually feature several functionally equivalent channels. For example, a 4-channel analog 0..10 V input terminal also has 4 logical channels and therefore 4 identical sets of parameter data for the channels. In order to avoid having to list each channel in the documentation, the placeholder "n" tends to be used for the individual channel numbers.

In the CoE system 16 indices, each with 255 subindices, are generally sufficient for representing all channel parameters. The channel-based order is therefore arranged in 16dec/10hex steps. The parameter range x8000 exemplifies this:

  • Channel 0: parameter range x8000:00 ... x800F:255
  • Channel 1: parameter range x8010:00 ... x801F:255
  • Channel 2: parameter range x8020:00 ... x802F:255
  • ...

This is generally written as x80n0.

Detailed information on the CoE interface can be found in the EtherCAT system documentation on the Beckhoff website.


Distributed Clock

The distributed clock represents a local clock in the EtherCAT slave controller (ESC) with the following characteristics:
  • Unit 1 ns
  • Zero point 1.1.2000 00:00
  • Size 64 bit (sufficient for the next 584 years; however, some EtherCAT slaves only offer 32-bit support, i.e. the variable overflows after approx. 4.2 seconds)
  • The EtherCAT master automatically synchronizes the local clock with the master clock in the EtherCAT bus with a precision of < 100 ns.

For detailed information please refer to the EtherCAT system description.


ELxxxx, KLxxxx - Installation on mounting rails

BECKHOFF Fieldbus Components: Mounting and wiring

Installation on mounting rails

WARNING 		Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!

Assembly

The Bus Coupler and Bus Terminals are attached to commercially available 35 mm mounting rails (DIN rails according to EN 60715) by applying slight pressure:

  1. First attach the Fieldbus Coupler to the mounting rail.
  2. The Bus Terminals are now attached on the right-hand side of the Fieldbus Coupler. Join the components with tongue and groove and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
    If the Terminals are clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.

Note 		Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail.
At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail.
To mount the mounting rails with a height of 7.5 mm under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).

Disassembly

Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
  1. Pull the terminal by its orange-colored lugs approximately 1 cm away from the mounting rail. In doing so for this terminal the mounting rail lock is released automatically and you can pull the terminal out of the bus terminal block easily without excessive force.
  2. Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal out of the bus terminal block.

Connections within a bus terminal block

The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:

  • The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
  • The power contacts deal with the supply for the field electronics and thus represent a supply rail within the bus terminal block. The power contacts are supplied via terminals on the Bus Coupler (up to 24 V) or for higher voltages via power feed terminals.

Note 		Power Contacts
During the design of a bus terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts.
Power Feed Terminals (KL91xx, KL92xx or EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.

PE power contact

The power contact labeled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.

Attention 		Possible damage of the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a nominal voltage of 230 V).

For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.

WARNING 		Risk of electric shock!
The PE power contact must not be used for other potentials!


ELxxxx, KLxxxx - Installation instructions for enhanced mechanical load capacity

BECKHOFF Fieldbus components: Mounting and wiring

Installation instructions for enhanced mechanical load capacity

WARNING 		Risk of injury through electric shock and damage to the device!
Bring the Bus Terminal system into a safe, de-energized state
before starting mounting, disassembly or wiring of the Bus Terminals!

Additional checks

The terminals have undergone the following additional tests:

Verification | Explanation
Vibration | 10 frequency runs in 3 axes
 | 6 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 25 g, 6 ms

Additional installation instructions

For terminals with enhanced mechanical load capacity, the following additional installation instructions apply:

  • Any installation position is permitted
  • Use a mounting rail according to EN 60715 TH35-15
  • Fix the terminal segment on both sides of the mounting rail with a mechanical fixture, e.g. an earth terminal or reinforced end clamp
  • The maximum total extension of the terminal segment (without coupler) is:
    64 terminals (12 mm mounting with) or 32 terminals (24 mm mounting with)
  • Avoid deformation, twisting, crushing and bending of the mounting rail during edging and installation of the rail
  • The mounting points of the mounting rail must be set at 5 cm intervals
  • Use countersunk head screws to fasten the mounting rail
  • The free length between the strain relief and the wire connection should be kept as short as possible. A distance of approx. 10 cm should be maintained to the cable duct.


KLxxxx, KSxxxx, ELxxxx, ESxxxx - Connection system

BECKHOFF Fieldbus Components: Mounting and wiring

Connection system

WARNING 		Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!

Overview

The Bus Terminal system offers different connection options for optimum adaptation to the respective application:

  • The terminals of KLxxxx and ELxxxx series with standard wiring include electronics and connection level in a single enclosure.
  • The terminals of KSxxxx and ESxxxx series feature a pluggable connection level and enable steady wiring while replacing.
  • The High Density Terminals (HD Terminals) include electronics and connection level in a single enclosure and have advanced packaging density.

Standard wiring

The terminals of KLxxxx and ELxxxx series have been tried and tested for years.
They feature integrated screwless spring force technology for fast and simple assembly.

Pluggable wiring

The terminals of KSxxxx and ESxxxx series feature a pluggable connection level.
The assembly and wiring procedure for the KS series is the same as for the KLxxxx and ELxxxx series.
The KS/ES series terminals enable the complete wiring to be removed as a plug connector from the top of the housing for servicing
The lower section can be removed from the terminal block by pulling the unlocking tab.
Insert the new component and plug in the connector with the wiring.
This reduces the installation time and eliminates the risk of wires being mixed up.

The familiar dimensions of the terminal only had to be changed slightly. The new connector adds about 3 mm. The maximum height of the terminal remains unchanged.

A tab for strain relief of the cable simplifies assembly in many applications and prevents tangling of individual connection wires when the connector is removed.

Conductor cross sections between 0.08 mm2 and 2.5 mm2 can continue to be used with the proven spring force technology.

The overview and nomenclature of the product names for KSxxxx and ESxxxx series has been retained as known from KLxxxx and ELxxxx series.

High Density Terminals (HD Terminals)

The Bus Terminals from these series with 16 connection points are distinguished by a particularly compact design, as the packaging density is twice as large as that of the standard 12 mm Bus Terminals. Massive conductors and conductors with a wire end sleeve can be inserted directly into the spring loaded terminal point without tools.

Note 		Wiring HD Terminals
The High Density (HD) Terminals of the KLx8xx and ELx8xx series doesn't support steady wiring.

Ultrasonically "bonded" (ultrasonically welded) conductors

Note 		Ultrasonically “bonded" conductors
It is also possible to connect the Standard and High Density Terminals with ultrasonically "bonded" (ultrasonically welded) conductors.
In this case, please note the tables concerning the wire-size width below!

Wiring

Terminals for standard wiring ELxxxx / KLxxxx and terminals for steady wiring ESxxxx / KSxxxx

Up to eight connections enable the connection of solid or finely stranded cables to the Bus Terminals. The terminals are implemented in spring force technology. Connect the cables as follows:

  1. Open a spring-loaded terminal by slightly pushing with a screwdriver or a rod into the square opening above the terminal.
  2. The wire can now be inserted into the round terminal opening without any force.
  3. The terminal closes automatically when the pressure is released, holding the wire securely and permanently.

Terminal housing | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Wire size width | 0.08 ... 2,5 mm2 | 0.08 ... 2.5 mm2
Wire stripping length | 8 ... 9 mm | 9 ... 10 mm

High Density Terminals ELx8xx, KLx8xx (HD)

The conductors of the HD Terminals are connected without tools for single-wire conductors using the direct plug-in technique, i.e. after stripping the wire is simply plugged into the contact point. The cables are released, as usual, using the contact release with the aid of a screwdriver. See the following table for the suitable wire size width.

Terminal housing | High Density Housing
Wire size width (conductors with a wire end sleeve) | 0.14... 0.75 mm2
Wire size width (single core wires) | 0.08 ... 1.5 mm2
Wire size width (fine-wire conductors) | 0.25 ... 1.5 mm2
Wire size width (ultrasonically “bonded" conductors) | only 1.5 mm2 (see notice!)
Wire stripping length | 8 ... 9 mm

Shielding

Note 		Shielding
Analog sensors and actors should always be connected with shielded, twisted paired wires.


KLxxxx, ELxxxx installation positions

BECKHOFF Fieldbus components: Installation and wiring

Installation positions

Attention 		Constraints regarding installation position and operating temperature range
Please refer to the technical data for a terminal to ascertain whether any restrictions regarding the installation position and/or the operating temperature range have been specified.

When installing high power dissipation terminals ensure that an adequate spacing is maintained between other components above and below the terminal in order to guarantee adequate ventilation!

Optimum installation position (standard)

The optimum installation position requires the mounting rail to be installed horizontally and the connection surfaces of the EL/KL terminals to face forward (see Fig. 1). The terminals are ventilated from below, which enables optimum cooling of the electronics through convection. "From below" is relative to the acceleration of gravity.

Fig. 1: Recommended distances for standard installation position

Compliance with the distances shown in Fig. 1 is recommended.

Other installation positions

All other installation positions are characterized by different spatial arrangement of the mounting rail - see Fig 2.

The minimum distances to ambient specified above also apply to these installation positions.

Fig. 2: Other installation positions


Mounting of Passive Terminals

Note 		Hint for mounting passive terminals
EtherCAT Bus Terminals (ELxxxx / ESxxxx), which do not take an active part in data transfer within the bus terminal block are so called Passive Terminals.
The Passive Terminals have no current consumption out of the E-Bus
To ensure an optimal data transfer, you must not directly string together more than 2 Passive Terminals!
Examples for mounting passive terminals (highlighted)

Example 1: correct configuration

Example 2: incorrect configuration


ATEX - Special conditions

WARNING 		Observe the special conditions for the intended use of
Beckhoff fieldbus components in potentially explosive areas (directive 94/9/EU)!
  • The certified components are to be installed in a suitable housing that guarantees a protection class of at least IP54 in accordance with EN 60529! The environmental conditions during use are thereby to be taken into account!
  • If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
  • Observe the permissible ambient temperature range of 0 - 55°C for the use of Beckhoff fieldbus components in potentially explosive areas!
  • Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
  • The individual terminals may only be unplugged or removed from the Bus Terminal system if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
  • The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
  • The fuses of the KL92xx power feed terminals may only be exchanged if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
  • Address selectors and ID switches may only be adjusted if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!

Standards

The fundamental health and safety requirements are fulfilled by compliance with the following standards:

  • EN 60079-0: 2006
  • EN 60079-15: 2005

Marking

The Beckhoff fieldbus components certified for potentially explosive areas bear one of the following markings:

II 3 G Ex nA II T4 KEMA 10ATEX0075 X Ta: 0 - 55°C

or

II 3 G Ex nA nC IIC T4 KEMA 10ATEX0075 X Ta: 0 - 55°C

Serial number

The Beckhoff fieldbus components bear a serial number that is structured as follows:

WW YY FF HH

WW - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version

Example with ser. no.: 35 04 1B 01:

35 - week of production 35
04 - year of production 2004
1B - firmware version 1B
01 - hardware version 01


EL2521 - LEDs and connection

Connection

• EL2521-0000
• EL2521-0024
• EL2521-0124
• EL2521-0025

EL2521-0000

Fig. 1: EL2521-0000 pin assignment and sample connection

EL2521-0024

Fig. 2: EL2521-0124 pin assignment and sample connection

EL2521-0124

Fig. 3: EL2521-0124 pin assignment and sample connection

Pin assignment EL2521-0000, EL2521-0024

Terminal point | No. | Comment
Output +A | 1 | Output +A
Output +B | 2 | Output +B
Input T | 3 | Input T
T.Z. GND/T.Z. Ref. GND | 4 | signal ground for outputs
Output -A | 5 | Output -A
Output -B | 6 | Output -B
Input Z | 7 | Input Z
Shield | 8 | Shield

Pin assignment EL2521-0124

Terminal point | No. | Comment
Output +A | 1 | Output +A
Output +B | 2 | Output +B
Latch24 V | 3 | 24 V latch input
Latch/Output GND Ref. GND | 4 | signal ground for outputs and for latch input
Output -A | 5 | Output -A
Output -B | 6 | Output -B
Output 24 V | 7 | 24 V output
Shield | 8 | Shield

EL2521-0025

Fig. 4: EL2521-0025 pin assignment and sample connection

Pin assignment EL2521-0025

Terminal point | No. | Comment
Output -A | 1 | Output -A
Output -B | 2 | Output -B
Input T | 3 | Input T
T.Z. GND/T.Z. Ref. GND | 4 | signal ground for outputs
Output +A | 5 | Output +A
Output +B | 6 | Output +B
Input Z | 7 | Input Z
Shield | 8 | Shield

LEDs (EL2521-xxxx)

LED | Color | Meaning
Output A, B | green | The LEDs illuminate when the input and output signal levels are active. The illumination of the LEDs for the active frequency outputs A or B at higher frequencies can only be perceived as a glow at half brightness
**nput T, Z | green | Illuminates when input signal level is active.
**Latch/Output 24 V | green | Illuminate when the input and output signal levels are active.
RUN | green | This LED indicates the terminal's operating state:
 |  | off | State of the EtherCAT State Machine: INIT = Initialization of the terminal
 |  | Blinking | State of the EtherCAT State Machine: PREOP = Setting for mailbox communication and variant standard settings
 |  | Single Flash | State of the EtherCAT State Machine: SAFEOP = Channel checking of the Sync Manager. Outputs stay in safe operation mode.
 |  | on | State of the EtherCAT State Machine: OP = Normal operation mode, mailbox- and process data communication possible
 |  | Flickering | State of the EtherCAT State Machine: BOOTSTRAP = Function for firmware updates of the terminal
*) not EL2521-0124
**) only EL2521-0124

Connection of the inputs

The optically isolated inputs are protected from overload by a current limiter. The operating voltage can lie in the range between 5 V ... 24 VDC without any additional external circuitry. The GND connection is the common ground for the two inputs, T and Z.
The circuit diagram shows the internal circuitry of the two inputs:

Fig. 5: Internal circuit of the inputs T and Z

Connection of the outputs

Circuit examples for output to A. The same principles apply to output B.

EL2521-0000

Outputs A and B on the EL2521 can be used with different types of connection. An integrated DC/DC converter supplies the outputs stage of the two channels, A and B, with an electrically isolated 5 V power supply.
Connection to a RS422 receiver
The output can be operated as RS422 output. The circuit generates the necessary differential signals.

Fig. 46: EL2521-0000 connected with a RS422 receiver

Connection to an optocoupler (without external power supply)
The outputs can be used for direct connection of an optocoupler. The output stage supplies the necessary output current using an internal 5 V power supply.

Fig. 7: EL2521-0000, directly connected with an optocoupler

EL2521-0024, EL2521-0124

The functionality with an external power supply depends on the hardware version of the terminal:
Connection to an optocoupler (with external power supply)
For connection to inputs with large internal impedances, an external power supply (of up to 24 V) can be used in order to create the necessary current.

Fig. 8: EL2521-0x24, circuit with external power supply

Attention 		EL2521-0124 ground potential
It is mandatory to connect the outputs -A and -B of the EL2521-0124 with the signal ground potential (Pin 4) to avoid damage of the terminal (see fig. 3)!

EL2521-0025

Attention 		EL2521-0025 reversal logic
Please note the reversal logic when you connect the EL2521-0025 (see fig. 4)!
Connection to an optocoupler (with external power supply)
For connection to inputs with large internal impedances, an external power supply (of up to 24 V) can be used in order to create the necessary current. Because of the reversal logic, you have to connect the positive voltage to pin 5 resp. pin 6 to create the output current.

Fig. 9: EL2521-0025, circuit with external power supply, reversal logic


Installation of the TwinCAT real-time driver

In order to assign real-time capability to a standard Ethernet port of an IPC controller, the Beckhoff real-time driver has to be installed on this port under Windows.

This can be done in several ways. One option is described here.

In the System Manager call up the TwinCAT overview of the local network interfaces via Options -> Show Real Time Ethernet Compatible Devices.

Fig. 1: System Manager option

Fig. 2: overview of network interfaces

Interfaces listed under “Compatible devices” can be assigned a driver via the “Install” button. A driver should only be installed on compatible devices.

A Windows warning regarding the unsigned driver can be ignored.

Alternatively, the compatible Ethernet ports can be viewed in the System Manager via EtherCAT properties.

Fig. 3: EtherCAT device properties

After the installation the driver appears activated in the Windows overview for the network interface (Windows Start -->System Properties -> Network)

Fig. 4: Windows properties of the network interface

Other possible settings are to be avoided:

Fig. 5: incorrect driver settings for the Ethernet port

IP address of the port used

Notice 		IP address/DHCP
In most cases an Ethernet port that is configured as an EtherCAT device will not transport general IP packets. For this reason and in cases where an EL6601 or similar devices are used it is useful to specify a fixed IP address for this port via the “Internet Protocol TCP/IP” driver setting and to disable DHCP.

In this way the delay associated with the DHCP client for the Ethernet port assigning itself a default IP address in the absence of a DHCP server is avoided.

A suitable address space is 192.168.x.x, for example.

Fig. 6: TCP/IP setting for the Ethernet port


Notes regarding ESI device description

Contents
• Installation of the latest ESI device description
• Device differentiation
• Online Description
• Faulty ESI file

Installation of the latest ESI device description

The TwinCAT EtherCAT master/System Manager needs the device description files for the devices to be used in order to generate the configuration in online or offline mode. The device descriptions are contained in the so-called ESI files (EtherCAT Slave Information) in XML format. These files can be requested from the respective manufacturer and are made available for download. An *.xml file may contain several device descriptions.

The ESI files for Beckhoff EtherCAT devices are available on the Beckhoff website.

The ESI files should be stored in the TwinCAT installation directory (default TwinCAT2: C:\TwinCAT\IO\EtherCAT). The files are read (once) when a new System Manager window is opened, if they have changed since the last time the System Manager window was opened.

A TwinCAT installation includes the set of Beckhoff ESI files that was current at the time when the TwinCAT build was created.

For TwinCAT 2.11/TwinCAT 3 and higher, the ESI directory can be updated from the System Manager, if the programming PC is connected to the Internet (Option -> “Update EtherCAT Device Descriptions”)

Fig. 1: for TwinCAT 2.11 and higher, the System Manager can search for current Beckhoff ESI files automatically, if an online connection is available

Note 		ESI
The *.xml files are associated with *.xsd files, which describe the structure of the ESI XML files. To update the ESI device descriptions, both file types should therefore be updated.

Device differentiation

EtherCAT devices/slaves are distinguished by 4 properties, which determine the full device identifier. The EL2521-0025-1018 ID consists of

  • family key “EL”
  • name “2521”
  • type “0025”
  • and revision “1018”

Fig. 2: identifier structure

The order identifier consisting of name + type (here: EL2521-0010) describes the device function. The revision indicates the technical progress and is managed by Beckhoff. In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation. Each revision has its own ESI description. See further notes.

Online description

If the EtherCAT configuration is created online through scanning of real devices (see section Online setup) and no ESI descriptions are available for a slave (specified by name and revision) that was found, the System Manager asks whether the description stored in the device should be used. In any case, the System Manager needs this information for setting up the cyclic and acyclic communication with the slave correctly.

Fig. 3: OnlineDescription information window

In TwinCAT 3.x a similar window appears, which also offers the Web update:

If possible, the Yes is to be rejected and the required ESI is to be requested from the device manufacturer. After installation of the XML/XSD file the configuration process should be repeated.

Attention 		Changing the ‘usual’ configuration through a scan
If a scan discovers a device that is not yet known to TwinCAT, distinction has to be made between two cases. Taking the example here of the EL2521-0000 in the revision 1019:
  • no ESI is present for the EL2521-0000 device at all, either for the revision 1019 or for an older revision. The ESI must then be requested from the manufacturer (in this case Beckhoff).
  • an ESI is present for the EL2521-0000 device, but only in an older revision, e.g. 1018 or 1017.
    In this case an in-house check should first be performed to determine whether the spare parts stock allows the integration of the increased revision into the configuration at all. A new/higher revision usually also brings along new features. If these are not to be used, work can continue without reservations with the previous revision 1018 in the configuration. This is also stated by the Beckhoff compatibility rule.

Refer in particular to the chapter ‘General notes on the use of Beckhoff EtherCAT IO components’ and for manual configuration to the chapter ‘Configuration creation – manual’

If the OnlineDescription is used regardless, the System Manager reads a copy of the device description from the EEPROM in the EtherCAT slave. In complex slaves the size of the EEPROM may not be sufficient for the complete ESI, in which case the ESI would be incomplete in the configurator. The route via the ESI files is therefore recommended.

The System Manager creates a new file “OnlineDescription0000...xml” its ESI directory, which contains all ESI descriptions that were read online.

Fig. 4: file OnlineDescription.xml created by the System Manager

If slaves are added manually to the configuration at a later stage, slaves created in the manner described above are indicated by an arrow, see Fig. 5, EL2521.

Fig. 5: Arrow indicates ESI recorded from OnlineDescription

If such ESI files are used and the manufacturer's files become available later, the file OnlineDescription.xml should be deleted as follows:

  • close all System Manager windows
  • restart TwinCAT in Config mode
  • delete "OnlineDescription0000...xml"
  • restart TwinCAt System Manager

This file should not be visible after this procedure, if necessary press <F5> to update

Note 		OnlineDescription for TwinCAT 3.x
In addition to the file described above "OnlineDescription0000...xml" , a so called EtherCAT cache with new discovered devices is created by TwinCAT 3.x (e.g. under Windows 7)
C:\User\[USERNAME]\AppData\Roaming\Beckhoff\TwinCAT3\Components\Base\EtherCATCache.xml

(Please note the language settings of the OS!)

You have to delete this file, too.

Faulty ESI file

If an ESI file is faulty and the System Manager is unable to read it, the System Manager brings up an information window.

Fig. 6: information window for faulty ESI file

Reasons may include:

  • Structure of the *.xml does not correspond to the associated *.xsd file --> check your schematics
  • Contents cannot be translated into a device description --> contact the file manufacturer


Offline configuration creation (master: TwinCAT 2.x)

Table of contents
• Distinction between Online and Offline
 • Creating the EtherCAT device
• Defining EtherCAT slaves

Distinction between Online and Offline

The distinction between online and offline refers to the presence of the actual I/O environment (drives, terminals). If the configuration is to be prepared in advance of the system configuration as a programming system, e.g. on a laptop, this is only possible in “Offline configuration” mode. In this case all components have to be entered manually in the configuration, e.g. based on the electrical design.

If the designed control system is already connected to the EtherCAT system and all components are energised and the infrastructure is ready for operation, the TwinCAT configuration can simply be generated through “scanning” from the runtime system. This is referred to as online configuration.

In any case, during each startup the EtherCAT master checks whether the slaves it finds match the configuration. This test can be parameterised in the extended slave settings.

Note 		Installation of the latest ESI-XML device description
The TwinCAT EtherCAT master/System Manager needs the device description files for the devices to be used in order to generate the configuration in online or offline mode. The device descriptions are contained in the so-called ESI files (EtherCAT Slave Information) in XML format. These files can be requested from the respective manufacturer and are made available for download. The ESIs for Beckhoff EtherCAT devices are provided on the Beckhoff website.

The ESI files should be saved in the TwinCAT installation directory (default: C:\TwinCAT\IO\EtherCAT ). The files are read (once) when a new System Manager window is opened.

A TwinCAT installation includes the set of Beckhoff ESI files that was current at the time when the TwinCAT build was created.

For TwinCAT 2.11 and higher, the ESI directory can be updated from the System Manager, if the programming PC is connected to the Internet (Option -> “Update EtherCAT Device Descriptions”)

The following conditions must be met before a configuration can be set up:

  • the EtherCAT device must be created/defined in the System Manager
  • the EtherCAT slaves must be defined

Creating the EtherCAT device

Create an EtherCAT device in an empty System Manager window.

Fig. 1: Append EtherCAT device

Select type ‘EtherCAT’ for an EtherCAT I/O application with EtherCAT slaves. For the present publisher/subscriber service in combination with an EL6601/EL6614 terminal select “EtherCAT Automation Protocol via EL6601”.

Fig. 2: selecting the EtherCAT connection (TwinCAT 2.11)

Fig. 3: selecting the EtherCAT connection (TwinCAT 2.11 R2)

Then assign a real Ethernet port to this virtual device in the runtime system.

Fig. 4: selecting the Ethernet port

This query may appear automatically when the EtherCAT device is created, or the assignment can be set/modified later in the properties dialog (see Fig. 5).

Fig. 5: EtherCAT properties dialog

Note 		Selecting the Ethernet port
Ethernet ports can only be selected for EtherCAT devices for which the TwinCAT real-time driver is installed. This has to be done separately for each port.

Please refer to the respective installation page.

Defining EtherCAT slaves

Further devices can be appended by right-clicking on a device in the configuration tree.

Fig. 6: appending EtherCAT devices

The dialog for selecting a new device opens. Only devices for which ESI files are available are displayed.

Only devices are offered for selection that can be appended to the previously selected device. Therefore the physical layer available for this port is also displayed (Fig. 7, A). In the case of cable-based Fast-Ethernet physical layer with PHY transfer, then also only cable-based devices are available, as shown in Fig. 7. If the preceding device has several free ports (e.g. EK1122 or EK1100), the required port can be selected on the right-hand side (A).

Overview of physical layer

  • “Ethernet”: cable-based 100BASE-TX: EK couplers, EP boxes, devices with RJ45/M8/M12 connector
  • “E-Bus”: LVDS “terminal bus”: EL/ES terminals, various modular modules

The search field facilitates finding specific devices (TwinCAT 2.11 or higher).

Fig. 7: selection dialog for new EtherCAT device

By default only the name/device type is used as selection criterion. For selecting a specific revision of the device the revision can be displayed as “Extended Information”.

Fig. 8: display of device revision

In many cases several device revisions were created for historic or functional reasons, e.g. through technological advancement. For simplification purposes (see Fig. 7) only the last (i.e. highest) revision and therefore the latest state of production is displayed in the selection dialog for Beckhoff devices. To show all device revisions available in the system as ESI descriptions tick the “Show Hidden Devices” check box, see Fig. 9.

Fig. 9: display of previous revisions

Note 		Device selection based on revision, compatibility
The ESI description also defines the process image, the communication type between master and slave/device and the device functions, if applicable. The physical device (firmware, if available) has to support the communication queries/settings of the master. This is backward compatible, i.e. newer devices (higher revision) should be supported if the EtherCAT master addresses them as an older revision. The following compatibility rule of thumb is to be assumed for Beckhoff EtherCAT Terminals/Boxes:

device revision in the system >= device revision in the configuration

This also enables subsequent replacement of devices without changing the configuration (different specifications are possible for drives).

Example: If an EL2521-0025-1018 is specified in the configuration, an EL2521-0025-1018 or higher (-1019, -1020) can be used in practice.

If current ESI descriptions are available in the TwinCAT system, the last revision offered in the selection dialog matches the Beckhoff state of production. It is recommended to use the last device revision when creating a new configuration, if current Beckhoff devices are used in the real application. Older revisions should only be used if older devices from stock are to be used in the application.

In this case the process image of the device is shown in the configuration tree and can be parameterised as follows: linking with the task, CoE/DC settings, plug-in definition, startup settings, ...

Fig. 10: EtherCAT terminal in the TwinCAT tree


Offline configuration creation ‘scanning’ (master: TwinCAT 2.x)

Table of contents
• Distinction between Online and Offline
 • Detecting/scanning of the EtherCAT device
 • Detecting/Scanning the EtherCAT devices
 • Troubleshooting
 • Scan over existing Configuration

• Change to compatible device
• Change to Alternative Type

Distinction between Online and Offline

The distinction between online and offline refers to the presence of the actual I/O environment (drives, terminals). If the configuration is to be prepared in advance of the system configuration as a programming system, e.g. on a laptop, this is only possible in “Offline configuration” mode. In this case all components have to be entered manually in the configuration, e.g. based on the electrical design.

If the designed control system is already connected to the EtherCAT system and all components are energised and the infrastructure is ready for operation, the TwinCAT configuration can simply be generated through “scanning” from the runtime system. This is referred to as online configuration.

In any case, during each startup the EtherCAT master checks whether the slaves it finds match the configuration. This test can be parameterised in the extended slave settings.

Note 		Installation of the latest ESI-XML device description
The TwinCAT EtherCAT master/System Manager needs the device description files for the devices to be used in order to generate the configuration in online or offline mode. The device descriptions are contained in the so-called ESI files (EtherCAT Slave Information) in XML format. These files can be requested from the respective manufacturer and are made available for download. The ESIs for Beckhoff EtherCAT devices are provided on the Beckhoff website.

The ESI files should be saved in the TwinCAT installation directory (default: C:\TwinCAT\IO\EtherCAT ). The files are read (once) when a new System Manager window is opened.

A TwinCAT installation includes the set of Beckhoff ESI files that was current at the time when the TwinCAT build was created.

For TwinCAT 2.11 and higher, the ESI directory can be updated from the System Manager, if the programming PC is connected to the Internet (Option -> “Update EtherCAT Device Descriptions”)

The following conditions must be met before a configuration can be set up:

  • the real EtherCAT hardware (devices, couplers, drives) must be present and installed
  • the devices/modules must be connected via EtherCAT cables or in the terminal strand in the same way as they are intended to be used later
  • the devices/modules be connected to the power supply and ready for communication
  • TwinCAT must be in CONFIG mode on the target system.

The online scan process consists of:

  • detecting the EtherCAT device (Ethernet port at the IPC)
  • detecting the connected EtherCAT devices. This step can be carried out independent of the preceding step
  • troubleshooting

The scan with existing configuration can also be carried out for comparison.

Detecting/scanning of the EtherCAT device

The online device search can be used if the TwinCAT system is in CONFIG mode (blue TwinCAT icon or blue indication in the System Manager).

Fig. 1: TwinCAT CONFIG mode display

Note 		Online scanning in Config mode
The online search is not available in RUN mode (production operation).

Note the differentiation between TwinCAT programming system and TwinCAT target system. The TwinCAT icon next to the Windows clock always shows the TwinCAT mode of the local IPC. The System Manager window shows the TwinCAT state of the target system.

Right-clicking on “I/O Devices” in the configuration tree opens the search dialog.

Fig. 2: Scan Devices

This scan mode attempts to find not only EtherCAT devices (or Ethernet ports that are usable as such), but also NOVRAM, fieldbus cards, SMB etc. However, not all devices can be found automatically.

Fig. 3: note for automatic device scan

Ethernet ports with installed TwinCAT real-time driver are shown as “RT Ethernet” devices. An EtherCAT frame is sent to these ports for testing purposes. If the scan agent detects from the response that an EtherCAT slave is connected, the port is immediately shown as an “EtherCAT Device” .

Fig. 4: detected Ethernet devices

After confirmation with “OK” a device scan is suggested for all selected devices, see Fig. 5.

Note 		selecting the Ethernet port
Ethernet ports can only be selected for EtherCAT devices for which the TwinCAT real-time driver is installed. This has to be done separately for each port.

Please refer to the respective installation page.

Detecting/Scanning the EtherCAT devices

Note 		Online scan functionality
During a scan the master queries the identity information of the EtherCAT slaves from the slave EEPROM. The name and revision are used for determining the type. The respective devices are located in the stored ESI data and integrated in the configuration tree in the default state defined there.

Attention 		Slave scanning in practice in series machine production
The scanning function should be used with care. It is a practical and fast tool for creating an initial configuration as a basis for commissioning.

In series machine production or reproduction of the plant, however, the function should no longer be used for the creation of the configuration, but if necessary for comparison with the defined initial configuration.

Background: since Beckhoff occasionally increases the revision version of the delivered products for product maintenance reasons, a configuration can be created by such a scan which (with an identical machine construction) is identical according to the device list; however, the respective device revision may differ from the initial configuration.

Example:

Company A builds the prototype of a machine B, which is to be produced in series later on. To do this the prototype is built, a scan of the IO devices is performed in TwinCAT and the initial configuration ‘B.tsm’ is created. The EL2521-0025 EtherCAT terminal with the revision 1018 is located somewhere. It is thus built into the TwinCAT configuration in this way:

Likewise, during the prototype test phase, the functions and properties of this terminal are tested by the programmers/commissioning engineers and used if necessary, i.e. addressed from the PLC ‘B.pro’ or the NC. (the same applies correspondingly to the TwinCAT3 solution files).

The prototype development is now completed and series production of machine B starts, for which Beckhoff continues to supply the EL2521-0025-0018. If the commissioning engineers of the series machine production department always carry out a scan, a B configuration with the identical contents results again for each machine. Likewise, A might create spare parts stores worldwide for the coming series-produced machines with EL2521-0025-1018 terminals.

After some time Beckhoff extends the EL2521-0025 by a new feature C. Therefore the FW is changed, outwardly recognizable by a higher FW version and a new revision -1019. Nevertheless the new device naturally supports functions and interfaces of the predecessor version(s); an adaptation of ‘B.tsm’ or even ‘B.pro’ is therefore unnecessary. The series-produced machines can continue to be built with ‘B.tsm’ and ‘B.pro’; it makes sense to perform a comparative scan against the initial configuration ‘B.tsm’ in order to check the built machine.

However, if the series machine production department now doesn’t use ‘B.tsm’, but instead carries out a scan to create the productive configuration, the revision -1019 is automatically detected and built into the configuration:

This is usually not noticed by the commissioning engineers. TwinCAT cannot signal anything either, since virtually a new configuration is created. According to the compatibility rule, however, this means that no EL2521-0025-1018 should be built into this machine as a spare part (even if this nevertheless works in the vast majority of cases).

In addition, it could be the case that, due to the development accompanying production in company A, the new feature C of the EL2521-0025-1019 (for example, an improved analog filter or an additional process data for the diagnosis) is discovered and used without in-house consultation. The previous stock of spare part devices are then no longer to be used for the new configuration ‘B2.tsm’ created in this way.

→ if series machine production is established, the scan should only be performed for informative purposes for comparison with a defined initial configuration. Changes are to be made with care!

If an EtherCAT device was created in the configuration (manually or through a scan), the I/O field can be scanned for devices/slaves.

Fig. 5: scan query after automatic creation of an EtherCAT device

Fig. 6: Manual triggering of a device scan on a specified EtherCAT device

In the System Manager the scan process can be monitored via the progress bar at the bottom of the screen.

Fig. 7: scan progress

The configuration is established and can then be switched to online state (OPERATIONAL).

Fig. 8: Config/FreeRun query

In Config/FreeRun mode the System Manager display alternates between blue and red, and the EtherCAT device continues to operate with the idling cycle time of 4 ms (default setting), even without active task (NC, PLC).

Fig. 9: Config/FreeRun indicator

Note 		Note for Config/FreeRun
TwinCAT can also be switched to this state by using a button

The EtherCAT system should then be in a functional cyclic state, as shown in Fig. 10.

Fig. 10: online display example

Please note:

  • all slaves should be in OP state
  • the EtherCAT master should be in “Actual State” OP
  • “frames/sec” should match the cycle time taking into account the sent number of frames
  • no excessive “LostFrames” or CRC errors should occur

The configuration is now complete. It can be modified as described under manual procedure.

troubleshooting

Various effects may occur during scanning.

  • An unknown device is detected, i.e. an EtherCAT slave for which no ESI XML description is available.
    In this case the System Manager offers to read any ESI that may be stored in the device. This case is described in the chapter "Notes regarding ESI device description".
  • Device are not detected properly
    Possible reasons include:
    - faulty data links, resulting in data loss during the scan
    - slave has invalid device description
    The connections and devices should be checked in a targeted manner, e.g. via the emergency scan.
    Then re-run the scan.

  • Fig. 11: faulty identification

    In the System Manager such devices may be set up as EK0000 or unknown devices. Operation is not possible or meaningful.

Scan over existing Configuration

Attention 		Change of the configuration after comparison
With this scan (TwinCAT 2.11 or 3.1) only the device properties vendor (manufacturer), device name and revision are compared at present!
A ‘ChangeTo’ or ‘Copy’ should only be carried out with care, taking into consideration the Beckhoff IO compatibility rule (see above). The device configuration is then replaced by the revision found; this can affect the supported process data and functions.

If a scan is initiated for an existing configuration, the actual I/O environment may match the configuration exactly or it may differ. This enables the configuration to be compared.

Fig. 12: identical configuration

If differences are detected, they are shown in the correction dialog, so that the user can modify the configuration as required.

Fig. 13: correction dialog

It is advisable to tick the “Extended Information” check box to reveal differences in the revision.

Colour | Explanation
green | This EtherCAT slave matches the entry on the other side. Both type and revision match.
blue This EtherCAT slave is present on the other side, but in a different revision. This other revision can have other default values for the process data as well as other/additional functions.
If the found revision is higher than the configured revision, the slave may be used provided compatibility issues are taken into account.

If the found revision is lower than the configured revision, it is likely that the slave cannot be used. The found device may not support all functions that the master expects based on the higher revision number.

light blue | This EtherCAT slave is ignored (“Ignore” button)
red
  • This EtherCAT slave is not present on the other side.
  • It is present, but in a different revision, which also differs in its properties from the one specified.
    The compatibility principle then also applies here: if the found revision is higher than the configured revision, use is possible provided compatibility issues are taken into account, since the successor devices should support the functions of the predecessor devices.

    If the found revision is lower than the configured revision, it is likely that the slave cannot be used. The found device may not support all functions that the master expects based on the higher revision number.

Note 		Device selection based on revision, compatibility
The ESI description also defines the process image, the communication type between master and slave/device and the device functions, if applicable. The physical device (firmware, if available) has to support the communication queries/settings of the master. This is backward compatible, i.e. newer devices (higher revision) should be supported if the EtherCAT master addresses them as an older revision. The following compatibility rule of thumb is to be assumed for Beckhoff EtherCAT Terminals/Boxes:

device revision in the system >= device revision in the configuration

This also enables subsequent replacement of devices without changing the configuration (different specifications are possible for drives).

Example: If an EL2521-0025-1018 is specified in the configuration, an EL2521-0025-1018 or higher (-1019, -1020) can be used in practice.

If current ESI descriptions are available in the TwinCAT system, the last revision offered in the selection dialog matches the Beckhoff state of production. It is recommended to use the last device revision when creating a new configuration, if current Beckhoff devices are used in the real application. Older revisions should only be used if older devices from stock are to be used in the application.

Fig. 14: correction dialog with modifications

Once all modifications have been saved or accepted, click “OK” to transfer them to the real *.tsm configuration.

Change to compatible device

The TwinCAT System Manager offers a function for the exchange of a device whilst retaining the links in the task: Change to compatible device.

Fig. 15: TwinCAT 2 Dialog ChangeToCompatibleDevice

This function is preferably to be used on AX5000 devices. If called, the System Manager suggests the devices that it finds in the associated sub-folder; in the case of the AX5000, for example, in \TwiNCAT\IO\EtherCAT\Beckhoff AX5xxx.

Change to Alternative Type

The TwinCAT System Manager offers a function for the exchange of a device: Change to Alternative Type

Fig. 16: TwinCAT 2 Dialog ChangeToCompatibleDevice

If called, the System Manager searches in the procured device ESI (in this example: EL1202-0000) for details of compatible devices contained there. The configuration is changed and the ESI-EEPROM is overwritten at the same time – therefore this process is possible only in the online state (ConfigMode).


EtherCAT slave process data settings (PDO)

The process data transferred by an EtherCAT slave during each cycle (Process Data Objects, PDOs) are user data which the application expects to be updated cyclically or which are sent to the slave. To this end the EtherCAT master (Beckhoff TwinCAT) parameterizes each EtherCAT slave during the start-up phase to define which process data (size in bits/bytes, source location, transmission type) it wants to transfer to or from this slave. Incorrect configuration can prevent successful start-up of the slave.

For Beckhoff EtherCAT EL/ES slaves the following applies in general:

  • The input/output process data supported by the device are defined by the manufacturer in the ESI/XML description. The TwinCAT EtherCAT Master uses the ESI description to configure the slave correctly.
  • The process data can be modified in the system manager. See the device documentation.
    Examples of modifications include: mask out a channel, displaying additional cyclic information, 16-bit display instead of 8-bit data size, etc.
  • In so-called “intelligent” EtherCAT devices the process data information is also stored in the CoE directory. Any changes in the CoE directory that lead to different PDO settings prevent successful startup of the slave. It is not advisable to deviate from the designated process data, because the device firmware (if available) is adapted to these PDO combinations.

If the device documentation allows modification of process data, proceed as follows (see Figure 1).

  • A: select the device to configure
  • B: in the “Process Data” tab select Input or Output under SyncManager (C)
  • D: the PDOs can be selected or deselected
  • H: the new process data are visible as linkable variables in the system manager
    The new process data are active once the configuration has been activated and TwinCAT has been restarted (or the EtherCAT master has been restarted)
  • E: if a slave supports this, Input and Output PDO can be modified simultaneously by selecting a so-called PDO record (“predefined PDO settings”).

Fig. 1: Configuring the process data

Note 		Manual modification of the process data
According to the ESI description, a PDO can be identified as “fixed” with the flag “F” in the PDO overview (Fig. 1, J). The configuration of such PDOs cannot be changed, even if TwinCAT offers the associated dialog (“Edit”).

In particular, CoE content cannot be displayed as cyclic process data.

This generally also applies in cases where a device supports download of the PDO configuration, “G”.

In case of incorrect configuration the EtherCAT slave usually refuses to start and change to OP state. The System Manager displays an “invalid SM cfg” logger message:

This error message (“invalid SM IN cfg” or “invalid SM OUT cfg”) also indicates the reason for the failed start.


TwinCAT System Manager - Configuration

BECKHOFF TwinCAT System Manager: Configuration

Configuration by means of the TwinCAT System Manager

(with TwinCAT from version 2.10.0 (Build 1241), using EL5001 from firmware version 0.7 as an example)

In the left-hand window of the TwinCAT System Manager, click on the branch you wish to configure (in the example: EL5001 Terminal 6).

In the right-hand window of the TwinCAT System manager, various tabs are now available for configuring the terminal.

General tab

Name | Name of the EtherCAT device
Id | Number of the EtherCAT device
Type | EtherCAT device type
Comment | Here you can add a comment (e.g. regarding the system).
Disabled | Here you can deactivate the EtherCAT device.
Create symbols | Access to this EtherCAT slave via ADS is only available if this control box is activated.

EtherCAT tab

Type | EtherCAT device type
Product/Revision | Product and revision number of the EtherCAT device
Auto Inc Addr. | Auto increment address of the EtherCAT device. The auto increment address can be used for addressing each EtherCAT device in the communication ring through its physical position. Auto increment addressing is used during the start-up phase when the EtherCAT master allocates addresses to the EtherCAT devices. With auto increment addressing the first EtherCAT slave in the ring has the address 0000hex. For each further slave the address is decremented by 1 (FFFFhex, FFFEhex etc.).
EtherCAT Addr. | Fixed address of an EtherCAT slave. This address is allocated by the EtherCAT master during the start-up phase. Tick the control box to the left of the input field in order to modify the default value.
Previous Port | Name and port of the EtherCAT device to which this device is connected. If it is possible to connect this device with another one without changing the order of the EtherCAT devices in the communication ring, then this combination field is activated and the EtherCAT device to which this device is to be connected can be selected.
Advanced Settings | This button opens the dialogs for advanced settings.

The link at the bottom of the tab points to the product page for this EtherCAT device on the web.

Process Data tab

Indicates the configuration of the process data. The input and output data of the EtherCAT slave are represented as CANopen process data objects (PDO). The user can select a PDO via PDO assignment and modify the content of the individual PDO via this dialog, if the EtherCAT slave supports this function.

Sync Manager

Lists the configuration of the Sync Manager (SM).
If the EtherCAT device has a mailbox, SM0 is used for the mailbox output (MbxOut) and SM1 for the mailbox input (MbxIn).
SM2 is used for the output process data (outputs) and SM3 (inputs) for the input process data.

If an input is selected, the corresponding PDO assignment is displayed in the PDO Assignment list below.

PDO Assignment

PDO assignment of the selected Sync Manager. All PDOs defined for this Sync Manager type are listed here:

  • If the output Sync Manager (outputs) is selected in the Sync Manager list, all RxPDOs are displayed.
  • If the input Sync Manager (inputs) is selected in the Sync Manager list, all TxPDOs are displayed.

The selected entries are the PDOs involved in the process data transfer. In the tree diagram of the System Manager these PDOs are displayed as variables of the EtherCAT device. The name of the variable is identical to the Name parameter of the PDO, as displayed in the PDO list. If an entry in the PDO assignment list is deactivated (not selected and greyed out), this indicates that the input is excluded from the PDO assignment. In order to be able do select a greyed out PDO, the currently selected PDO has to be deselected first.

Note 		Activation of PDO assignment
If you have changed the PDO assignment, in order to activate the new PDO assignment,
  • the EtherCAT slave has to run through the PS status transition cycle (from pre-operational to safe-operational) once (see Online tab),
  • and the System Manager has to reload the EtherCAT slaves ( [image] button)

PDO list

List of all PDOs supported by this EtherCAT device. The content of the selected PDOs is displayed in the PDO Content list. The PDO configuration can be modified by double-clicking on an entry.

Column | Description
Index | PDO index.
Size | Size of the PDO in bytes.
Name | Name of the PDO. If this PDO is assigned to a Sync Manager, it appears as a variable of the slave with this parameter as the name.
Flags | F | Fixed content: The content of this PDO is fixed and cannot be changed by the System Manager.
 | M | Mandatory PDO. This PDO is mandatory and must therefore be assigned to a Sync Manager! Consequently, this PDO cannot be deleted from the PDO Assignment list
SM | Sync Manager to which this PDO is assigned. If this entry is empty, this PDO does not take part in the process data traffic.
SU | Sync unit to which this PDO is assigned.

PDO Content

Indicates the content of the PDO. If flag F (fixed content) of the PDO is not set the content can be modified.

Download

If the device is intelligent and has a mailbox, the configuration of the PDO and the PDO assignments can be downloaded to the device. This is an optional feature that is not supported by all EtherCAT slaves.

PDO Assignment

If this check box is selected, the PDO assignment that is configured in the PDO Assignment list is downloaded to the device on startup. The required commands to be sent to the device can be viewed in the Startup tab.

PDO Configuration

If this check box is selected, the configuration of the respective PDOs (as shown in the PDO list and the PDO Content display) is downloaded to the EtherCAT slave.

Startup tab

The Startup tab is displayed if the EtherCAT slave has a mailbox and supports the CANopen over EtherCAT (CoE) or Servo drive over EtherCAT protocol. This tab indicates which download requests are sent to the mailbox during startup. It is also possible to add new mailbox requests to the list display. The download requests are sent to the slave in the same order as they are shown in the list.

Column | Description
Transition Transition to which the request is sent. This can either be
  • the transition from pre-operational to safe-operational (PS), or
  • the transition from safe-operational to operational (SO).

If the transition is enclosed in "<>" (e.g. <PS>), the mailbox request is fixed and cannot be modified or deleted by the user.
Protocol | Type of mailbox protocol
Index | Index of the object
Data | Date on which this object is to be downloaded.
Comment | Description of the request to be sent to the mailbox
Move Up | This button moves the selected request up by one position in the list.
Move Down | This button moves the selected request down by one position in the list.
New | This button adds a new mailbox download request to be sent during startup.
Delete | This button deletes the selected entry.
Edit | This button edits an existing request.

CoE - Online tab

The additional CoE - Online tab is displayed if the EtherCAT slave supports the CANopen over EtherCAT (CoE) protocol. This dialog lists the content of the object list of the slave (SDO upload) and enables the user to modify the content of an object from this list. Details for the objects of the individual EtherCAT devices can be found in the device-specific object descriptions.

Object list display
Column | Description
Index | Index and sub-index of the object
Name | Name of the object
Flags | RW | The object can be read, and data can be written to the object (read/write)
 | RO | The object can be read, but no data can be written to the object (read only)
 | P | An additional P identifies the object as a process data object.
Value | Value of the object
Update List | The Update list button updates all objects in the displayed list
Auto Update | If this check box is selected, the content of the objects is updated automatically.
Advanced | The Advanced button opens the Advanced Settings dialog. Here you can specify which objects are displayed in the list.

Online - via SDO Information | If this option button is selected, the list of the objects included in the object list of the slave is uploaded from the slave via SDO information. The list below can be used to specify which object types are to be uploaded.
Offline - via EDS File | If this option button is selected, the list of the objects included in the object list is read from an EDS file provided by the user.

Online tab

State Machine

Init | This button attempts to set the EtherCAT device to the Init state.
Pre-Op | This button attempts to set the EtherCAT device to the pre-operational state.
Op | This button attempts to set the EtherCAT device to the operational state.
Bootstrap | This button attempts to set the EtherCAT device to the Bootstrap state.
Safe-Op | This button attempts to set the EtherCAT device to the safe-operational state.
Clear Error | This button attempts to delete the fault display. If an EtherCAT slave fails during change of state it sets an error flag. Example: An EtherCAT slave is in PREOP state (pre-operational). The master now requests the SAFEOP state (safe-operational). If the slave fails during change of state it sets the error flag. The current state is now displayed as ERR PREOP. When the Clear Error button is pressed the error flag is cleared, and the current state is displayed as PREOP again.
Current State | Indicates the current state of the EtherCAT device.
Requested State | Indicates the state requested for the EtherCAT device.

DLL Status

Indicates the DLL status (data link layer status) of the individual ports of the EtherCAT slave. The DLL status can have four different states:

Status | Description
No Carrier / Open | No carrier signal is available at the port, but the port is open.
No Carrier / Closed | No carrier signal is available at the port, and the port is closed.
Carrier / Open | A carrier signal is available at the port, and the port is open.
Carrier / Closed | A carrier signal is available at the port, but the port is closed.

File Access over EtherCAT

Download | With this button a file can be written to the EtherCAT device.
Upload | With this button a file can be read from the EtherCAT device.


General Notes - EtherCAT Slave Application

Table of contents
• Diagnosis in real time: WorkingCounter, EtherCAT State and Status
• CoE - Parameter Directory
• Commissioning aid in the TwinCAT System Manager
 • EtherCAT State: automatic default behavior of the TwinCAT System Manager and manual operation
• Note regarding E-Bus current

This summary briefly deals with a number of aspects of EtherCAT Slave operation under TwinCAT. More detailed information on this may be found in the corresponding sections of, for instance,http://www.beckhoff.com/english/download/ethercat.htm#SystemDescription"> EtherCAT System Documentation.

Diagnosis in real time: WorkingCounter, EtherCAT State and Status

Generally speaking an EtherCAT Slave provides a variety of diagnostic information that can be used by the controlling task.

This diagnostic information relates to differing levels of communication. It therefore has a variety of sources, and is also updated at various times.

Any application that relies on I/O data from a fieldbus being correct and up to date must make diagnostic access to the corresponding underlying layers. EtherCAT and the TwinCAT System Manager offer comprehensive diagnostic elements of this kind. Those diagnostic elements that are helpful to the controlling task for diagnosis that is accurate for the current cycle when in operation (not during commissioning) are discussed below.

Fig. 1: Selection of the diagnostic information of an EtherCAT Slave

In general, an EtherCAT Slave offers

  • communication diagnosis typical for a slave (diagnosis of successful participation in the exchange of process data, and correct operating mode)
    This diagnosis is the same for all slaves.

    as well as
  • function diagnosis typical for a channel (device-dependent)
    See the corresponding device documentation

The colours in Fig. 1 also correspond to the variable colours in the System Manager, see Fig. 2.

Colour | Meaning
yellow | Input variables from the Slave to the EtherCAT Master, updated in every cycle
red | Output variables from the Slave to the EtherCAT Master, updated in every cycle
green | Information variables for the EtherCAT Master that are updated acyclically. This means that it is possible that in any particular cycle they do not represent the latest possible status. It is therefore useful to read such variables through ADS.

Fig. 2 shows an example of an implementation of basic EtherCAT Slave Diagnosis. A Beckhoff EL3102 (2-channel analogue input terminal) is used here, as it offers both the communication diagnosis typical of a slave and the functional diagnosis that is specific to a channel. Structures are created as input variables in the PLC, each corresponding to the process image.

Fig. 2: basic EtherCAT Slave Diagnosis in the PLC

The following aspects are covered here:

Code Function Implementation Application/evaluation
A The EtherCAT Master's diagnostic information

updated acyclically (yellow) or provided acyclically (green).

 At least the DevState is to be evaluated for the most recent cycle in the PLC.

The EtherCAT Master's diagnostic information offers many more possibilities than are treated in the EtherCAT System Documentation. A few keywords:

  • CoE in the Master for communication with/through the Slaves
  • Functions from TcEtherCAT.lib
  • Perform an OnlineScan
B In the example chosen (EL3102) the EL3102 comprises two analogue input channels that transmit a single function status for the most recent cycle. Status
  • the bit significations may be found in the device documentation
  • other devices may supply more information, or none that is typical of a slave
 In order for the higher-level PLC task (or corresponding control applications) to be able to rely on correct data, the function status must be evaluated there. Such information is therefore provided with the process data for the most recent cycle.
C For every EtherCAT Slave that has cyclic process data, the Master displays, using what is known as a WorkingCounter, whether the slave is participating successfully and without error in the cyclic exchange of process data. This important, elementary information is therefore provided for the most recent cycle in the System Manager
  1. at the EtherCAT Slave, and, with identical contents
  2. as a collective variable at the EtherCAT Master (see Point A)

for linking.

 WcState (Working Counter)

0: valid real-time communication in the last cycle

1: invalid real-time communication

This may possibly have effects on the process data of other Slaves that are located in the same SyncUnit

 In order for the higher-level PLC task (or corresponding control applications) to be able to rely on correct data, the communication status of the EtherCAT Slave must be evaluated there. Such information is therefore provided with the process data for the most recent cycle.
D Diagnostic information of the EtherCAT Master which, while it is represented at the slave for linking, is actually determined by the Master for the Slave concerned and represented there. This information cannot be characterized as real-time, because it
  • is only rarely/never changed, except when the system starts up
  • is itself determined acyclically (e.g. EtherCAT Status)
 State

current Status (INIT..OP) of the Slave. The Slave must be in OP (=8) when operating normally.

AdsAddr

The ADS address is useful for communicating from the PLC/task via ADS with the EtherCAT Slave, e.g. for reading/writing to the CoE. The AMS-NetID of a slave corresponds to the AMS-NetID of the EtherCAT Master; communication with the individual Slave is possible via the port (= EtherCAT address).

 Information variables for the EtherCAT Master that are updated acyclically. This means that it is possible that in any particular cycle they do not represent the latest possible status. It is therefore possible to read such variables through ADS.

Attention 		Diagnostic information
It is strongly recommended that the diagnostic information made available is evaluated so that the application can react accordingly.

CoE Parameter Directory

The CoE parameter directory (CanOpen-over-EtherCAT) is used to manage the set values for the slave concerned. Changes may, in some circumstances, have to be made here when commissioning a relatively complex EtherCAT Slave. It can be accessed through the TwinCAT System Manager, see Fig. 3:

Fig. 3: EL3102, CoE directory

Note 		EtherCAT System Documentation
The comprehensive descriptionhttp://www.beckhoff.de/german/download/ethercat.htm#SystemDescription"> EtherCAT System Documentation (EtherCAT Basics --> CoE Interface) must be observed!

A few brief extracts:

  • Whether changes in the online directory are saved locally in the slave depends on the device. EL terminals (except the EL66xx) are able to save in this way.
  • The user must manage the changes to the StartUp list.

Commissioning aid in the TwinCAT System Manager

Commissioning interfaces are being introduced as part of an ongoing process for EL/EP EtherCAT devices. These are available in TwinCAT System Managers from TwinCAT 2.11R2 and above. They are integrated into the System Manager through appropriately extended ESI configuration files.

Fig. 4: Example of commissioning aid for a EL3204

This commissioning process simultaneously manages

  • CoE Parameter Directory
  • DC/FreeRun mode
  • the available process data records (PDO)

Although the "Process Data", "DC", "Startup" and "CoE-Online" that used to be necessary for this are still displayed, it is recommended that, if the commissioning aid is used, the automatically generated settings are not changed by it.

The commissioning tool does not cover every possible application of an EL/EP device. If the available setting options are not adequate, the user can make the DC, PDO and CoE settings manually, as in the past.

EtherCAT State: automatic default behaviour of the TwinCAT System Manager and manual operation

After the operating power is switched on, an EtherCAT Slave must go through the following statuses

  • INIT
  • PREOP
  • SAFEOP
  • OP

to ensure sound operation. The EtherCAT Master directs these statuses in accordance with the initialization routines that are defined for commissioning the device by the ES/XML and user settings (Distributed Clocks (DC), PDO, CoE). See also the section on "Principles of Communication, EtherCAT State Machine" in this connection. Depending how much configuration has to be done, and on the overall communication, booting can take up to a few seconds.

The EtherCAT Master itself must go through these routines when starting, until it has reached at least the OP target state.

The target state wanted by the user, and which is brought about automatically at start-up by TwinCAT, can be set in the System Manager. As soon as TwinCAT reaches the status RUN, the TwinCAT EtherCAT Master will approach the target states.

Standard setting

The advanced settings of the EtherCAT Master are set as standard:

  • EtherCAT Master: OP
  • Slaves: OP
    This setting applies equally to all Slaves.

Fig. 5: Default behaviour of the System Manager

In addition, the target state of any particular Slave can be set in the "Advanced Settings" dialogue; the standard setting is again OP.

Fig. 6: Default target state in the Slave

Manual Control

There are particular reasons why it may be appropriate to control the states from the application/task/PLC. For instance:

  • for diagnostic reasons
  • to induce a controlled restart of axes
  • because a change in the times involved in starting is desirable

In that case it is appropriate in the PLC application to use the PLC function blocks from the TcEtherCAT.lib, which is available as standard, and to work through the states in a controlled manner using, for instance, FB_EcSetMasterState.

It is then useful to put the settings in the EtherCAT Master to INIT for master and slave.

Fig. 7: PLC function blocks

Note regarding E-Bus current

EL/ES terminals are placed on the DIN rail at a coupler on the terminal strand. A Bus Coupler can supply the EL terminals added to it with the E-bus system voltage of 5 V; a coupler is thereby loadable up to 2 A as a rule. Information on how much current each EL terminal requires from the E-bus supply is available online and in the catalogue. If the added terminals require more current than the coupler can supply, then power feed terminals (e.g. EL9410) must be inserted at appropriate places in the terminal strand.

The pre-calculated theoretical maximum E-Bus current is displayed in the TwinCAT System Manager as a column value. A shortfall is marked by a negative total amount and an exclamation mark; a power feed terminal is to be placed before such a position.

Fig. 8: illegally exceeding the E-Bus current

From TwinCAT 2.11 and above, a warning message "E-Bus Power of Terminal..." is output in the logger window when such a configuration is activated:

Fig. 9: Warning message for exceeding E-Bus current

Attention 		Caution! Malfunction possible!
The same ground potential must be used for the E-Bus supply of all EtherCAT terminals in a terminal block!


EL2521 - Basic function principles

BECKHOFF EL2521: Product Overview

Basic function principles

Table of contents
• Operation modes of the EL2521
• Default setting
• Operating modes and output pattern
• Ramp function
• Resolution
• Travel distance control
• Relative data
• Direct data
• Distributed Clocks (DC)
• Code word
• Notes on EL2521-0124

Operation modes of the EL2521

Through the further development of the EL2521 an enhanced operating mode is available (from firmware 03 / hardware 02), which can be parameterized in the TwinCAT System Manager, depending on the hardware used.

Older EL2521 devices do not support this enhanced operation mode.

Version | PDO settings | FW/HW | ESI | Process data | CoE parameters
normal operation mode | Legacy (MDP 252) | up to 02/01 | from EL2521-0000-0000 | Input process data (counter value) in CoE object 6000 Output process data (frequency value) in CoE object 7000 PDO assignment in 1A00, 1600 | Feature bits and settings in CoE objects 8000, 8001 and 8800
enhanced operation mode | Standard 16-bit (MDP 253/511) Standard 32-bit (MDP 253/511) | from 03/02 | from EL2521-0000-1016 | Differences compared to normal operation mode Distributed clocks support Inputs / outputs in CoE-object 6010 / 7010 Inputs / outputs in CoE-object 6020 / 7020 PDO assignment in 1A01, 1A02, 1A05 or 1601, 1602, 1604, 1605, 1607 | Feature bits and settings in CoE-object 8010

The PDO selection specifies the operating mode in which the EL2521-xxxx is to operate:

Fig. 1: predefined PDO selection in the TwinCAT System Manager

Irrespective of the hardware/firmware version, after integration into a system an EL2521 reports in normal operation mode (please refer to chapter "Process data, delivery state" )

During commissioning the user has to decide with what functionality, i.e. in what operation mode, the EL2521 is to be used. This depends on the required configuration and, of course, the hardware version. A terminal older then firmware 03 / hardware 02, for example, will not support enhanced operating mode configuration, due to the absence of the corresponding objects .

Note 		Maintenance compatibility
An EL2521 terminal, which is implemented and projected in enhanced operating mode must not replaced with an EL2521 terminal with hardware status older than 03 !

Note 		Process data monitoring
We recommend monitoring the following process data during each cycle:
  • WcState: If ≠ 0, this EtherCAT device does not take part in the process data traffic
  • State: If ≠ 8, the EtherCAT device is not in OP (operational) status
  • TxPDO state, SyncError: If ≠ 0, then no valid process data are available, e.g. through broken wire
  • TxPDO Toggle: If this bit toggles, a new set of process data is available

EL2521 input impedance

The signal source must be able to operate the input impedance of the EL2521 (typically 220Ω, subject to modification) with adequate voltage levels according to RS422.

Default setting

The EL2521 is set to FM mode (frequency modulation) by default, with a basic frequency of 50 kHz and a resolution of 15 bits.
For testing in the delivery state, PDO setting Standard 16-bit, the output frequency can simply be set to a value >0, then the EL2521-xxxx starts outputting signals.

The number of pulses output is read back into a 16 bit register. If the counter overflows a signal is sent to the controller. This is indicated by Status.3, SW.3 or object 6020:05, overflow or Status.2, SW.2 or object 6020:04 underflow). In parallel with these two bits, Status. 6, SW.6 or object 6010:07 is set as a general error bit. This makes the extension to more than 16 bits easier for the controller software to handle. The overflow can also be read from diagnosis object A000:01 (internal 32 bit extension). The counter can be reset to 0 through Control.5 (CW.5). By default, the counter is cleared by a rising edge (feature object 8000:05 = 1). If feature object 8000:05 = 0, the function is level-controlled. If bit 8000:0B = 1 , the counter is set by bit Control.5 (CW.5) to a value defined by object 8800:01.

Operating modes and output pattern

In addition to the FM (frequency modulation; object 8000:0E or 8010:0E = 0dec) operating mode, the EL2521 can also be used to control stepper motors with pulse-direction control (frq. cnt pulse mode; object 8000:0E or 8010:0E = 1dec). Incremental transducer simulation is another operating mode (object 8000:0E or 8010:0E = 2dec). It is possible to connect an incremental transducer directly. Such inputs are present on many servo amplifiers and frequency converters. The pattern of pulses is output through channels A and B. It is possible to configure the necessary operating mode via feature object 8000:0E or 8010:0E. The operating modes differ primarily between the positive logic modes 0, 1 and 2 and the negative logic modes 4, 5 and 6. The negative logic mode will be activated by object 8000:0F or 8010:10. Operating modes 2 and 6 simulate an incremental encoder, and permit direct connection to an evaluation unit such as a servoamplifier or frequency converter with an incremental encoder input.
Operating mode | Function
 | Rotation to right Rotation to left
Frequency modulation positive logic (BA0) |
Puls-direction control positive logic (BA1) |
Incremental encoder positive logic (BA2) |
Frequency modulation negative logic (BA4) |
Puls-direction control negative logic (BA5) |
Incremental encoder negative logic (BA6) |

Ramp function

An internal ramp function raises/lowers the current frequency to the pre-set maximum frequency in accordance with the parameters set in object 8800:02. This is activated by feature-object 8000:06 or 8010:06.

Note 		CoE parameters
Depending on mode of operation, normal or advanced, the parameters from the objects 8000, 8001, 8800 or 8010 are to be used.

The base frequency for the ramp can be selected by feature-object 8000:07 or 8010:07. Status.1, SW.1 or object 6010:02 is set while a ramp is being followed. The releasing of Control.0, CW.0 or object 7010:01 can be used to deactivate the function. During operation this can also be done by Control.1, CW.11 or object 7010:02 . In this way the user can change the base frequency during operation very quickly. Setting Control.0, CW.0 or object 7010:01 = 1 (confirmed by Status.0, SW.0 or object 6010:01 ) the values in object 8001:033 or 8010:13 are used instead of those in object 8001:02 or 8010:12 (CW.00 or object 7010:01 = 0). The input signals T and Z are transferred directly from the terminal to the controller in the status byte (Status.4 / Status.5; SW.4 / SW.5) or objects 6010:05 / 6010:06 . The signals are not given any internal pre-processing. The terminal offers a facility for soft starting and stopping. The ramp gradient for starting can be set in object 8001:04 or 8010:14 with a precision of 10 or 1000 Hz/s (object 8000:07 or 8010:07). Object 8001:055 or 8010:15 performs the same function for stopping. The process data can be modified during transit of the ramp (Control.2; CW.2 or object 7010:03 ), and the terminal then takes the new value as its target frequency.

Resolution

The base frequencies are specified with their resolution of 1 Hz per bit (base frequency 1: object 8001:02 or 8010:12 resp. base frequency 2: object 8001:03 or 8010:13). The terminal operates internally at 16 MHz with a resolution of 32 bits. This corresponds to a theoretical minimum step size of 0.0037 Hz/step over the entire frequency range. The output stage allows a maximum frequency of 500 kHz to be output.

Travel distance control

The travel distance control function is available in both normal and advanced operating mode. Starting from the current counter value, a target counter value is automatically driven to and the corresponding level is output at the outputs. The output frequency thereby changes in accordance with the current counter value. When the given counter contents have been reached, the terminal switches the frequency to zero.

The sequence is determined by several factors, see fig. 2. Before parameterizing the travel distance control, it is recommended to carry out a CoE reset "Restoring the delivery state" in order to rule out side effects.

The sequence and the associated parameters are listed in following table; in enhanced operating mode some parameters are no longer in the CoE, but can be linked as process data.

Phase |  | normal operation mode | enhanced operation mode
Parameterization | Activate travel distance control | 8000:0A = TRUE | 8010:0A = TRUE
 | Basic ramp frequency (10 Hz / 1 KHz) | 8000:07 = ? | 8010:07 = ?
 | Ramp time constant "rising" t1 [?/sec] | 8001:04 = ? | 8010:14 = ?
 | Maximum driving frequency f1 | 8800:02 = ? | ---
 | Ramp time constant "falling" t3 [?/sec] (> 1.1 * ramp time constant t1!) | 8001:05 = ? | 8010:15 = ?
 | Output frequency f2 | 8001:07 = ? | 8010:17 = ?
Trip | Specify target position | 8800:01 = ? | PDO: TargetCounterValue = ?
 | Trip start | CW.2 = TRUE | PDO: Control.GoCounter = TRUE
 | Maximum driving frequency f1 | --- | PDO: FrequencyValue <> 0
Reset |  | CW.2 = FALSE | PDO: FrequencyValue = 0
 |  |  | PDO: Control.GoCounter = FALSE

In the case of travel distance control in enhanced operating mode, the "Go counter" bit must be set at the same time or before specifying the "Frequency value". If the "Go counter" bit is not set and the "Frequency value" is not equal to 0, then travel distance control is NOT active and clock pulses are already output!

Note 		Ramp time constant
The "real" ramp time results from the multiplication of the basic ramp frequency with that of the rising/falling ramp time constant.

Note 		Steepness of the falling ramp
In order to travel to a destination with precision, it is necessary that the time constant for the falling ramp is greater than that of the rising ramp by a certain factor. This is necessary so that the slowing down frequency is reached before the final counter state, so that the terminal does not drive up to the end point at full speed.
To explain in more detail: the EL2521 calculates the number of steps that are still to be taken in time t2 from time t1 and from the number of steps that have been taken. The calculation for stopping assumes the same number of steps as that found for starting up. The downward ramp must be a little steeper, approx. 10%, so that it is possible to reach the destination exactly in the remaining time t3 + t4 + t5. This relationship changes with the maximum frequency.

Fig. 2: Phases of the travel distance control

By way of example, the recording of a short real travel distance ramp is shown here together with the example program [image] used for it.. The short step sequence resets the current counter value to 0 and then drives to the target position 65. In the System Manager file the EL2521-xxxx is set to the appropriate CoE values for this example via the StartUp parameters.

Fig. 3: Example travel distance control program

The result is the output of a variable frequency up to the target position 65.

Fig. 4: Oscilloscope recording of the pulse sequence

Relative data

The output frequency is based on the base frequency that is set in the objects 8001:02 resp. 80010:12 to 8001:03 resp. 8010:13 and the process data (see table).

Example:

Output frequency = base frequency x process data / 32767
Highest resolution = 125 mHz

Base frequency = 100,000 Hz (maximum selected output frequency)
Process data = 0x00FF (255dec)
Output frequency = 778.22 Hz

Process data |  | Output value
 | 0x0000 (0dec) | 0% DC
 | 0x3FFF (16383dec) | 50% of the base frequency, rotation to the right
 | 0x7FFF (32767dec) | 100% of the base frequency, rotation to the right
Two's complement | 0xC000 (-16384dec) | 50% of the base frequency, rotation to the left
 | 0x8000 (-32768dec) | 100% of the base frequency, rotation to the left
Sign-amount | 0xBFFF (-16383dec) | 50% of the base frequency, rotation to the left
 | 0xFFFF (-32767dec) | 100% of the base frequency, rotation to the left

Direct data

It is possible to enter the frequency directly (object 8000:08 resp. 8010:08). In this case the process data is multiplied by the factor contained in object 8001:06 resp. 8010:16, and directly written to the synthesis chip.

Example:

Output frequency = frequency factor x process data x 10 mHz
Highest resolution = 10 mHz

Example: Frequency factor = 100
Process data = 0x00FF (255dec)
Output frequency = 255 Hz

Distributed Clocks (DC)

Note 		EtherCAT and Distributed Clocks
A basic introduction into EtherCAT and distributed clocks can is available for download from the Beckhoff website: "Distributed clocks system description".

The EL2521 device supports the distributed clocks function. In order for the EL2521 to be able to make the current counter value available in the designated process data in time before the arrival of the querying EtherCAT datagram, a suitable signal must be generated cyclically within the terminal. This signal can be triggered in the EL2521 through two events: the SyncManager (SM) and the distributed clock (DC). Under operating mode selection the following options are available (see Fig. 5)

  • SM Synchronous
    The SyncManager event occurs when an EtherCAT frame successfully exchanges process data with the EL2521. In this way cyclical determination of the current counter value is triggered by a frame, although with the small time jitter associated with the Ethernet frame.
  • DC Synchronous
    In DC operating mode determination of the counter value is triggered cyclically at constant intervals through the integrated DC unit, synchronous with the bus cycle as standard. More uniform polling offers higher-quality position data for a higher-level control algorithm, for example. In the EL2521 the SYNC0 signal acts as trigger.

Fig. 2: DC tab (Distributed Clocks)

When DC Synchronous operating mode is activated TwinCAT selects settings that ensure reliable operation of the EL2521 with current position data. This means that determination of the current counter value is triggered by the SYNC0 signal at highly constant intervals and in good time (i.e. with an adequate safety buffer) before retrieving EtherCAT datagram is started.

The SYNC0 signal can be shifted along the time axis as required through associated dialogs (right/later and left/earlier) by specifying a user-defined shift time, see fig. 3.

  • A right-shift (positive shift value) will delay the counter value query, which means the position value becomes more current from the PLC perspective. However, this increases the risk that the position determination may not be finished in time before the arrival of EtherCAT frame, so that no current position value is available in this cycle.
  • A left-shift (negative shift value) means the counter value will be queried earlier, resulting in older position values, with an associated increase in the safety buffer before the arrival of the EtherCAT datagram. This setting may be useful in systems with high real-time jitter, if no Industrial PCs from Beckhoff are used for control purposes, for example.

Attention 		Attention! Risk of device damage!
The mentioned notes and information should be used advisedly.
The EtherCAT master automatically allocates SYNC0 and SYNC1 settings that support reliable and timely process data acquisition.
User intervention at this point may lead to undesired behavior.
If these settings are changed in the System Manager, no plausibility checks are carried out on the software side.
Correct function of the terminal with all conceivable setting options cannot be guaranteed.

Default setting

The cyclic read of the inputs is triggered by the SYNC0 pulse (interrupt) from the DC in the EL1202. The EtherCAT master sets the Sync Unit Cycle time value to the PLC cycle time and therefore the EtherCAT cycle time as standard. See Fig. 7: 4000µs = 4 ms, as TwinCAT is in configuration mode.

DC settings for EL2521

Fig. 3: Advanced Settings for Distributed Clock (DC), EL2521 terminal

• SYNC0
 Sync unit cycle: a multiple of the bus cycle time. The counter value is periodically determined at this interval (in µs).

• User-defined
Any number up to 232 ns or about 4.3 seconds. Use of decimal points is allowed.

• Shift Time
 The Shift Time can be used to shift the SYNC0 pulse for this EL2521 relative to other terminals and the global SYNC pulse in nanosecond steps. If the inputs of multiple EL2521 terminals are to be read at the same time, the same value must be entered here.

• Based on Input Reference
 If this option is activated an additional Input Shift is added to the configurable terminal-specific SYNC0 shift (user-defined). This value is calculated and made available by the EtherCAT master (SysMan/Device EtherCAT/tab EtherCAT/Advanced Settings/Distributed Clocks/Input Shift Time/, see Fig. 8-9). As a result, all the input terminals in the system (EL1xxx, EL3xxx) read their inputs as close as possible to the time of the EtherCAT frame that will fetch them, thereby supplying the most recent possible input data to the controller.

• Enable SYNC0
 Automatically activated in DC Synchronous operating mode.

• SYNC1
 Additional SYNC pulse, derived from SYNC0 or from the DC itself. Not required for the EL2521.

DC settings for EtherCAT master

Higher-level distributed clock parameters can be modified under advanced settings for the EtherCAT master. See also basic introduction into EtherCAT and downloading distributed clocks: "Distributed clocks system description".

Fig. 4: EtherCAT Master, EtherCAT tab, Advanced Settings

Fig. 4: EtherCAT Master, Advanced Settings, Distributed Clock

Code Word

Note 		Code Word
The manufacturer reserves the authority for the basic calibration of the terminals. The Producer codeword is therefore at present reserved.

Notes on EL2521-0124

The EL2521-0124 has a latch input and a 24 V compare output, which both operate in connection with the position value.

Explanation on the basis of the associated process data:

  • Latch input, identical function as in the case of EL encoder terminals
    • PDO ENC Status (input)
      • External latch valid
      • Status of external latch (current status of the latch input)
      • Latch value
    • PDO ENC Control (output)
      • Enable latch extern on positive edge
      • Enable latch extern on negative edge
  • Compare output ‘PLS’ (Programmable Limit Switch)
    • PLS Control:
      • ‘Enable PLS’:
        = 0 Output can be switched manually via ‘Outputs’
        = 1 Automatic switching function has control of the output
      • Output
        Switches the output (no function if ‘Enable PLS’ =1)
      • Switch-on value
        Switch-on value (the output is switched on when the counter reaches this value)
      • Switch-off value
        Switch-off value (the output is switched off when the counter reaches this value)

Fig. 6: Process data EL2521-0124


EL2521 - Process data

BECKHOFF EL2521: Commissioning

Process data

Table of contents
• Sync Manager

• Process data setting options

- PDO Setting 1: Legacy (MDP 252)
- PDO setting 2: Standard 16 Bit (MDP 253/511)
- PDO setting 3: Standard 32 Bit (MDP 253/511)

The process data selection in the System Manager specifies the mode of operation of the EL2521-xxxx. The process data can be set according to the tables below for inputs and outputs either individually by hand or via the predefined PDO selection with a single click.

Fig. 1: predefined PDO selection in the TwinCAT System Manager

Three process data records are available for the EL2521-xxxx and are listed in following table.

Sync Manager (SM)

PDO Assignment

SM3, PDO assignment 0x1C13
Index | Index of excluded PDOs | Size (byte.bit) | Name | PDO content
0x1A00 (default) | 0x1A01 0x1A02 0x1A05 | 4.0 | Inputs | Index 0x6000:01 - Status Index 0x6000:02 - Data in
0x1A01 | 0x1A00 | 2.0 | PTO Status | Index 0x6010:01 - Sel. Ack./End counter Index 0x6010:02 - Ramp active Index 0x6010:05 - Status of input target Index 0x6010:06 - Status of input zero Index 0x6010:07 - Error Index 0x1C32:20 - Sync error Index 0x1801:09 - TxPDO Toggle
0x1A02 | 0x1A00 0x1A05 | 4.0 | ENC Status compact | Index 0x6020:03 - Set counter done Index 0x6020:04 - Counter underflow Index 0x6020:05 - Counter overflow Index 0x1C32:20 - Sync error Index 0x1802:09 - TxPDO Toggle Index 0x6020:11 - Counter value
0x1A05 | 0x1A00 0x1A02 | 6.0 | ENC Status | Index 0x6020:03 - Set counter done Index 0x6020:04 - Counter underflow Index 0x6020:05 - Counter overflow Index 0x1C32:20 - Sync error Index 0x1805:09 - TxPDO Toggle Index 0x6020:11 - Counter value
SM2, PDO assignment 0x1C12
Index | Index of excluded PDOs | Size (byte.bit) | Name | PDO content
0x1600 (default) | 0x1601 0x1604 0x1607 0x1602 0x1605 | 4.0 | Inputs | Index 0x7000:01 - Ctrl Index 0x7000:02 - Data out
0x1601 | 0x1600 | 4.0 | PTO Control | Index 0x7010:01 - Frequency select Index 0x7010:02 - Disable ramp Index 0x7010:03 - Go counter Index 0x7010:11 - Frequency value
0x1604 | 0x1600 0x1607 0x1605 | 2.0 | PTO Target compact | Index 0x7010:12 - Target counter value
0x1607 | 0x1600 0x1604 0x1602 | 4.0 | PTO Target compact | Index 0x7010:12 - Target counter value
0x1602 | 0x1600 0x1607 0x1605 | 4.0 | ENC Control compact | Index 0x7020:03 - Set counter Index 0x7020:11 - Set counter value
0x1605 | 0x1600 0x1604 0x1602 | 6.0 | ENC Control | Index 0x7020:03 - Set counter Index 0x7020:11 - Set counter value

Table 1 + 2: Sync Manager PDO assignment

Process data setting options

The extent of process data can be set via the Process Data tab as described below.

PDO setting 1: Legacy (MDP 252)

  • preset standard configuration in TwinCAT 2.10 (see note below for more up-to-date TwinCAT versions)
  • to be used only in normal operating mode
  • compatible with terminals up to and including FW02

Fig. 2: Process data and PDO assignment Legacy (MDP 252)

Note 		Standard configuration in TwinCAT
The further development of the EL2521-xxxx from FW03 also necessitates a new process image, which is to be used preferentially in new systems. Therefore the standard configuration from TwinCAT 2.11 onwards is normally PDO setting 2 (see below), with which an EL2521-xxxx inserted manually or by scanning appears in the configuration.

For reasons of compatibility with existing software, however, some customers require PDO setting 1 "Legacy MDP253" to appear as the standard configuration, even for newly created configurations.

In this case the so-called compatibility flag is to be set in the System Manager. Legacy is then selected as the standard PDO configuration. Nevertheless the PDO can, of course, be converted/changed after inserting the terminal into the configuration.

Fig. 3: Compatibility Mode in the System Manager from TwinCAT 2.11 on

PDO setting 2: Standard 16-bit (MDP 253/511)

  • preset standard configuration in TwinCAT 2.11, TwinCAT 3
  • to be used only in enhanced operating mode
  • so-called compact process image, since it has only 16-bit-wide variables
  • allows linking to NC axes according to MDP 253, subprofile 511

Fig. 4: Process data and PDO assignment standard 16-bit (MDP 253/511)

PDO setting 3: Standard 32-bit (MDP 253/511)

  • to be used only in enhanced operating mode
  • 32-bit-wide variables
  • allows linking to NC axes according to MDP 253, subprofile 511

Fig. 5: Process data and PDO assignment standard 32-bit (MDP 253/511)


EL2521 - Object description and parameterization - normal operating mode

BECKHOFF EL2521: Commissioning

Object description and parameterization - enhanced operating mode

Note 		EtherCAT XML Device Description
The description correspond to the display of the CoE objects from the EtherCAT XML Device Description. It is strongly recommended to download the latest revision of the corresponding XML file from the Beckhoff website and follow the installation instructions.

Note 		Parameterization via the CoE list (CAN over EtherCAT)
The terminal is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs).
Please note the following general CoE information when using/manipulating the CoE parameters:
- Keep a startup list if components have to be replaced
- Differentiation between online/offline dictionary, existence of current XML description
- use "CoE reload" for resetting changes

Introduction

The CoE overview contains objects for different intended applications:

  • Objects required for parameterization during commissioning
  • Objects intended for regular operation, e.g. through ADS access.
  • Objects for indicating internal settings (may be fixed)

The following section first describes the objects require for normal operation, followed by a complete overview of other objects.

Objects for commissioning

Index 1011 Restore default parameters
Index | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore the default settings in the EtherCAT slave | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" ("Set Value Dialog") all terminal-specific objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)
Index 8000 Feature bits
Index | Name | Meaning | Data type | Flags | Default
8000:0 | Feature bits | Max. subindex | UINT8 | RO | 0x0F (15dec)
8000:02 | Emergency ramp active | TRUE When the watchdog is triggered, the terminal approaches with a ramp (time constant set in object 8001:08 resp. 8010:18) to the value defined in object 8001:01 resp. 8010:11. FALSE The function is deactivated | BOOLEAN | RW | 0x00 (0dec)
8000:03 | Watchdog timer deactivated | Evaluation of the SM watchdog: TRUE The watchdog timer is deactivated FALSE The watchdog timer is switched on by default. Either the manufacturer's of the user's switch-on value is output if the watchdog overflows | BOOLEAN | RW | 0x00 (0dec)
8000:04 | Sign/amount representation | TRUE The measured value is output in magnitude-sign format: -2dec= 0x8002 -1dec= 0x8001 1dec= 0x0001 2dec= 0x0002 FALSE The measurement is output as a signed integer in two's complement format: -2dec= 0xFFFE -1dec= 0xFFFF 1dec= 0x0001 2dec= 0x0002 | BOOLEAN | RW | 0x00 (0dec)
8000:05 | Rising edge clears/sets counter | TRUE Rising edge of Counter_Clear-Bit (CW.5) clears / sets counter FALSE Positive level of Counter_Clear-Bit (CW.5)clears / sets counter | BOOLEAN | RW | 0x01 (1dec)
8000:06 | Ramp function active | TRUE Ramp function active FALSE Ramp function deactive The ramp function should only be deactivated, if the higher-level control (e.g. NC control) assume the travel distance or frequency control | BOOLEAN | RW | 0x01 (1dec)
8000:07 | Ramp base frequency | 0(dec) Ramp base frequency: 10 Hz (pulldown menu) 1(dec) Ramp base frequency: 1 kHz (pulldown menu) | BIT1 | RW | 0x00 (0dec)
8000:08 | Direct input mode | TRUE Input mode: direct FALSE Input mode: relative | BOOLEAN | RW | 0x00 (0dec)
8000:09 | Users switch-on-value on wdt | TRUE Behavior when watchdog triggered: User's switch-on value FALSE Behavior when watchdog triggered: Manufacturer's switch-on value | BOOLEAN | RW | 0x00 (0dec)
8000:0A | Travel distance control active | TRUE Travel distance control: active FALSE Travel distance control: deactive | BOOLEAN | RW | 0x00 (0dec)
8000:0B | Rising edge sets counter | TRUE Rising edge sets counter FALSE Rising edge clears counter | BOOLEAN | RW | 0x00 (0dec)
8000:0E | Operating mode | 0(dec) Operation mode frequency modulation (pulldown menu) 1(dec) Operation mode pulse-direction control (pulldown menu) 2(dec) Operation mode incremental encoder (pulldown menu) | BIT2 | RW | 0x00 (0dec)
8000:0F | Negative logic | TRUE Negative logic FALSE Positive logic | BOOLEAN | RW | 0x00 (0dec)
Index 8001 User settings
Index | Name | Meaning | Data type | Flags | Default
8001:0 | User settings | Max. subindex | UINT8 | RO | 0x08 (8dec)
8001:01 | Users switch-on-value | User's switch-on value | UINT16 | RW | 0x0000 (0dec)
8001:02 | Base frequency 1 | Base frequency 1 = 50000 Hz | UINT32 | RW | 0x0000C350 (50000dec)
8001:03 | Base frequency 2 | Base frequency 2 = 100000 Hz | UINT32 | RW | 0x000186A0 (100000dec)
8001:04 | Ramp time constant (rising) | Ramp time constant (rising [1/sec]) The "real" ramp time is calculated by multiplying the ramp basic frequency with this ramp time constant | UINT16 | RW | 0x03E8 (1000dec)
8001:05 | Ramp time constant (falling) | Ramp time constant (falling [1/sec]) The "real" ramp time is calculated by multiplying the ramp basic frequency with this ramp time constant | UINT16 | RW | 0x03E8 (1000dec)
8001:06 | Frequency factor (Digit x 10mHz) | Frequency factor (direct input, digit x 10mHz) | UINT16 | RW | 0x0064 (100dec)
8001:07 | Slowing down frequency | Slowing down frequency, travel distance control | UINT16 | RW | 0x0032 (50dec)
8001:08 | Ramp time constant (emergency) | Ramp time constant for emergency shut-down; User's switch-on value will be approached (object 8001:01) | UINT16 | RW | 0x03E8 (1000dec)
Index 8800 Volatile settings
Index | Name | Meaning | Data type | Flags | Default
8800:0 | Volatile settings | Max. subindex | UINT8 | RO | 0x02 (2dec)
8800:01 | Target counter state | Target counter state | UINT32 | RW | 0x00000000 (0dec)
8800:02 | Maximum frequency | Maximum frequency | UINT16 | RW | 0x0000 (0dec)

Objects for regular operation

In normal operating mode the EL2521 has no such objects.

Complete overview

Standard objects (0x1000-0x1FFF)

The standard objects of all EtherCAT slaves have the same meaning.

Index 1000 Device type
Index | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device Type of the EtherCAT slave: The Lo-Word contains the supported CoE Profile (5001). The Hi-Word contains the Module Profile corresponding to the Modular Device Profile. | UINT32 | RO | 0x00001389 (5001dec)
Index 1008 Device name
Index | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EL2521
Index 1009 Hardware version
Index | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slaves | STRING | RO | 02
Index 100A Software version
Index | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slaves | STRING | RO | 03
Index 1018 Identity
Index | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | contains informations to identify the EtherCAT slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x09D93052 (165228626dec)
1018:03 | Revision | Revision number of the EtherCAT-Slave, the Lo-Word (Bit 0-15) indicates the special functions terminal number; the Hi-Word (Bit 16-31) refers to the device description. | UINT32 | RO | 0x03F80000 (66584576dec)
1018:04 | Serial number | Serial number of the EtherCAT-Slave, the Lo-Byte (Bit 0-7) of the Lo-Word contains the year of manufacturing, the Hi-Byte (Bit 8-15) of the Lo-Word contains the week of manufacturing, the Hi-Word (Bit 16-31) is 0 . | UINT32 | RO | 0x00000000 (0dec)
Index 1600 RxPDO-Map
Index | Name | Meaning | Data type | Flags | Default
1600:0 | RxPDO-Map | PDO Mapping RxPDO 1 | UINT8 | RO | 0x02 (2dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (Outputs), entry 0x01 (Ctrl)) | UINT32 | RO | 0x7000:01, 16
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (Outputs), entry 0x02 (Data Out)) | UINT32 | RO | 0x7000:02, 16
Index 1A00 TxPDO-Map
Index | Name | Meaning | Data type | Flags | Default
1A00:0 | TxPDO-Map | PDO Mapping TxPDO 1 | UINT8 | RO | 0x02 (2dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (Inputs), entry 0x01 (Status)) | UINT32 | RO | 0x6000:01, 16
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (Inputs), entry 0x02 (Data In)) | UINT32 | RO | 0x6000:02, 16
Index 1C00 Sync manager type
Index | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Usage of the Sync Manager channels | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C01 Process data format
Index | Name | Meaning | Data type | Flags | Default
1C01:0 | Process data format | Process data format | UINT16 | RW | 0x0100 (256dec)
Index 1C12 RxPDO assign
Index | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x01 (1dec)
1C12:01 | SubIndex 001 | 1. assigned RxPDO (contains the index of the corresponding RxPDO Mapping object) | UINT16 | RW | 0x1600 (5632dec)
Index 1C13 TxPDO assign
Index | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x01 (1dec)
1C13:01 | SubIndex 001 | 1. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A00 (6656dec)

Profile specific objects (0x6000-0xFFFF)

The profile specific objects have the same meaning for all EtherCAT Slaves which support the profile 5001.

Index 6000 Inputs
Index | Name | Meaning | Data type | Flags | Default
6000:0 | Inputs | Max. subindex | UINT8 | RO | 0x02 (2dec)
6000:01 | Status | Status word | UINT16 | RO | 0x0000 (0dec)
6000:02 | Data In | Input process data (counter value) | UINT16 | RO | 0x0000 (0dec)
Index 7000 Outputs
Index | Name | Meaning | Data type | Flags | Default
7000:0 | Outputs | Max. subindex | UINT8 | RO | 0x02 (2dec)
7000:01 | Ctrl | Control word | UINT16 | RO | 0x0000 (0dec)
7000:02 | Data Out | Output process data( frequency value) | UINT16 | RO | 0x0000 (0dec)
Index A000 Diagnostic parameter
Index | Name | Meaning | Data type | Flags | Default
A000:0 | Diagnostic parameter | Max. subindex | UINT8 | RO | 0x01 (1dec)
A000:01 | Counter extension | Counter extension | UINT16 | RO | 0x0000 (0dec)
Index F000 Profile settings
Index | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | general informations about the Modular Device Profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance between the objects of two channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | number of channels | UINT16 | RO | 0x0003 (3dec)
Index F008 Code word
Index | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dec)


EL2521 - Control- and Status word

BECKHOFF EL2521: Configuration

Control- and status word

Control word

The control word (CW) is located in the output process image, and is transmitted from the controller to the terminal.

Bit | CW.15 | CW.14 | CW.13 | CW.12 | CW.11 | CW.10 | CW.9 | CW.8
Name | - | - | - | - | - | - | - | -
Bit | CW.7 | CW.6 | CW.5 | CW.4 | CW.3 | CW.2 | CW.1 | CW.0
Name | - | - | CNT_CLR | - | - | GO_COUNTER | RAMP_DIS | FREQ_SEL
Legend
Bit | Name | Function
CW.8 - CW.15 | - | - | reserved
CW.7 | - | - | reserved
CW.6 | - | - | reserved
CW.5 | CNT_CLR | 1bin | The contents of the counter is cleared or set (object 8000:0B) by this bit. Any overflow or underflow bits that might be set are also cleared by this bit. The process can be edge triggered or level triggered (object 8000:05).
CW.4 | - | - | reserved
CW.3 | - | - | reserved
CW.2 | GO_COUNTER | 1bin | If travel distance control is active (object 8000:0A ), then a pre-set counter value is approached when the bit is set
CW.1 | RAMP_DIS | 1bin | Operation of the ramp function is cancelled, in spite of object 8000:06 being active; if travel distance control is active, it is interrupted by this bit
CW.0 | FREQ_SEL | 0bin / 1bin | Rapid change of the base frequency (only if the ramp function is inactive): 0bin = Base frequency 1 (object 8001:02) 1bin = Base frequency 2 (object 8001:03 )

Status word

The status word (SW) is located in the input process image, and is transmitted from the terminal to the controller.

Bit | SW.15 | SW.14 | SW.13 | SW.12 | SW.11 | SW.10 | SW.9 | SW.8
Name | - | - | - | - | - | - | - | -
Bit | SW.7 | SW.6 | SW.5 | SW.4 | SW.3 | SW.2 | SW.1 | SW.0
Name | - | ERROR | INPUT_Z | INPUT_T | OVERFLOW | UNDERFLOW | RAMP_ACTIVE | SEL_ACK/ END_COUNTER
Legend
Bit | Name | Beschreibung
SW.8 - SW.15 | - | - | reserved
SW.7 | - | - | reserved
SW.6 | ERROR | 1bin | General error bit, included with overflow/underflow
SW.5 | INPUT_Z | 1bin | Status of INPUT_Z
SW.4 | INPUT_T | 1bin | Status of INPUT_T
SW.3 | OVERFLOW | 1bin | This bit is set if the 16-bit counter overflows (65535 -> 0). It is reset when the counter exceeds one third of its measuring range (21845 -> 21846) or immediately an underflow occurs
SW.2 | UNDERFLOW | 1bin | This bit is set if the 16-bit counter underflows (0 -> 65535). It is reset when the counter drops below two thirds of its measuring range (43690 -> 43689) or immediately an overflow occurs.
SW.1 | RAMP_ACTIVE | 1bin | Ramp is currently being followed
SW.0 | SEL_ACK/ END_COUNTER | 1bin | Confirms the change of base frequency. At activated travel distance control: target counter value reached


EL2521 - Object description and parameterization - enhanced operating mode

BECKHOFF EL2521-0000, EL2521-0024, EL2521-0025: Commissioning

Object description and parameterization - enhanced operating mode

Note 		EtherCAT XML Device Description
The description correspond to the display of the CoE objects from the EtherCAT XML Device Description. It is strongly recommended to download the latest revision of the corresponding XML file from the Beckhoff website and follow the installation instructions.

Note 		Parameterization via the CoE list (CAN over EtherCAT)
The terminal is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs).
Please note the following general CoE information when using/manipulating the CoE parameters:
- Keep a startup list if components have to be replaced
- Differentiation between online/offline dictionary, existence of current XML description
- use "CoE reload" for resetting changes

Introduction

The CoE overview contains objects for different intended applications:

  • Objects required for parameterization during commissioning
  • Objects intended for regular operation, e.g. through ADS access.
  • Objects for indicating internal settings (may be fixed)

The following section first describes the objects require for normal operation, followed by a complete overview of other objects.

Objects for commissioning

Index 1011 Restore default parameters
Index | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore the default settings in the EtherCAT slave | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" ("Set Value Dialog") all terminal-specific objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)
Index 8010 PTO Settings
Index | Name | Meaning | Data type | Flags | Default
8010:0 | PTO Settings | Max. subindex | UINT8 | RO | 0x18 (24dec)
8010:02 | Emergency ramp active | TRUE When the watchdog is triggered, the terminal approaches with a ramp (time constant set in object 8001:08 resp. 8010:18) to the value defined in object 8001:01 resp. 8010:11. FALSE The function is deactivated | BOOLEAN | RW | 0x00 (0dec)
8010:03 | Watchdog timer deactive | Evaluation of the SM watchdog: TRUE The watchdog timer is deactivated FALSE The watchdog timer is switched on by default. Either the manufacturer's of the user's switch-on value is output if the watchdog overflows | BOOLEAN | RW | 0x00 (0dec)
8010:04 | Sign/amount representation | TRUE The measured value is output in magnitude-sign format: -2dec= 0x8002 -1dec= 0x8001 1dec= 0x0001 2dec= 0x0002 FALSE The measurement is output as a signed integer in two's complement format: -2dec= 0xFFFE -1dec= 0xFFFF 1dec= 0x0001 2dec= 0x0002 | BOOLEAN | RW | 0x00 (0dec)
8010:06 | Ramp function active | TRUE Ramp function active FALSE Ramp function deactive The ramp function should only be deactivated, if the higher-level control (e.g. NC control) assume the travel distance or frequency control | BOOLEAN | RW | 0x01 (1dec)
8010:07 | Ramp base frequency | 0(dec) Ramp base frequency: 10 Hz (pulldown menu) 1(dec) Ramp base frequency: 1 kHz (pulldown menu) | BIT1 | RW | 0x00 (0dec)
8010:08 | Direct input mode | TRUE Input mode: direct FALSE Input mode: relative | BOOLEAN | RW | 0x00 (0dec)
8010:09 | Users switch-on-value on wdt | TRUE Behavior when watchdog triggered: User's switch-on value FALSE Behavior when watchdog triggered: Manufacturer's switch-on value | BOOLEAN | RW | 0x00 (0dec)
8010:0A | Travel distance control active | TRUE Travel distance control: active FALSE Travel distance control: deactive | BOOLEAN | RW | 0x00 (0dec)
8010:0E | Operating mode | 0(dec) Operation mode frequency modulation (pulldown menu) 1(dec) Operation mode pulse-direction control (pulldown menu) 2(dec) Operation mode incremental encoder (pulldown menu) | BIT2 | RW | 0x00 (0dec)
8010:10 | Negative logic | TRUE Negative logic FALSE Positive logic | BOOLEAN | RW | 0x00 (0dec)
8010:11 | Users switch-on-value | User's switch-on value | UINT16 | RW | 0x0000 (0dec)
8010:12 | Base frequency 1 | Base frequency 1 = 50000 Hz | UINT32 | RW | 0x0000C350 (50000dec)
8010:13 | Base frequency 2 | Base frequency 2 = 100000 Hz | UINT32 | RW | 0x000186A0 (100000dec)
8010:14 | Ramp time constant (rising) | Ramp time constant (rising) | UINT16 | RW | 0x03E8 (1000dec)
8010:15 | Ramp time constant (falling) | Ramp time constant (falling) | UINT16 | RW | 0x03E8 (1000dec)
8010:16 | Frequency factor (Digit x 10mHz) | Frequency factor (direct input, digit x 10mHz) | UINT16 | RW | 0x0064 (100dec)
8010:17 | Slowing down frequency | Slowing down frequency, travel distance control | UINT16 | RW | 0x0032 (50dec)
8010:18 | Ramp time constant (emergency) | Ramp time constant for emergency shut-down; User's switch-on value will be approached (object 8001:01) | UINT16 | RW | 0x03E8 (1000dec)
Index 8800 Volatile settings
Index | Name | Meaning | Data type | Flags | Default
8800:0 | Volatile settings | Max. subindex | UINT8 | RO | 0x02 (2dec)
8800:01 | Target counter state | Target counter state | UINT32 | RW | 0x00000000 (0dec)
8800:02 | Maximum frequency | Maximum frequency | UINT16 | RW | 0x0000 (0dec)

Objects for regular operation

In enhanced operating mode the EL2521 has no such objects.

Complete overview

Standard objects (0x1000-0x1FFF)

The standard objects of all EtherCAT slaves have the same meaning.

Index 1000 Device type
Index | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device Type of the EtherCAT slave: The Lo-Word contains the supported CoE Profile (5001). The Hi-Word contains the Module Profile corresponding to the Modular Device Profile. | UINT32 | RO | 0x00001389 (5001dec)
Index 1008 Device name
Index | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EL2521
Index 1009 Hardware version
Index | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slaves | STRING | RO | 02
Index 100A Software version
Index | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slaves | STRING | RO | 03
Index 1018 Identity
Index | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | contains informations to identify the EtherCAT slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x09D93052 (165228626dec)
1018:03 | Revision | Revision number of the EtherCAT-Slave, the Lo-Word (Bit 0-15) indicates the special functions terminal number; the Hi-Word (Bit 16-31) refers to the device description. | UINT32 | RO | 0x03F80000 (66584576dec)
1018:04 | Serial number | Serial number of the EtherCAT-Slave, the Lo-Byte (Bit 0-7) of the Lo-Word contains the year of manufacturing, the Hi-Byte (Bit 8-15) of the Lo-Word contains the week of manufacturing, the Hi-Word (Bit 16-31) is 0 . | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 Backup parameter handling
Index | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | contains informations for the standardized Upload and Download of the Backup Entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum over all backup entries | UINT32 | RO | 0x00000000 (0dec)
Index 1400 RxPDO-Par
Index | Name | Meaning | Data type | Flags | Default
1400:0 | RxPDO-Par | PDO Parameter RxPDO 1 | UINT8 | RO | 0x06 (6dec)
1400:06 | Exclude RxPDOs | This entry contains the RxPDOs (Index of the RxPDO Mapping objects) which shall not be transmitted with RxPDO 1 | OCTET-STRING[10] | RO | 01 16 04 16 07 16 02 16 05 16
Index 1401 PTO RxPDO-Par Control
Index | Name | Meaning | Data type | Flags | Default
1401:0 | PTO RxPDO-Par Control | PDO Parameter RxPDO 2 | UINT8 | RO | 0x06 (6dec)
1401:06 | Exclude RxPDOs | This entry contains the RxPDOs (Index of the RxPDO Mapping objects) which shall not be transmitted with RxPDO 2 | OCTET-STRING[10] | RO | 00 16 00 00 00 00 00 00 00 00
Index 1402 ENC RxPDO-Par Control compact
Index | Name | Meaning | Data type | Flags | Default
1402:0 | ENC RxPDO-Par Control compact | PDO Parameter RxPDO 3 | UINT8 | RO | 0x06 (6dec)
1402:06 | Exclude RxPDOs | This entry contains the RxPDOs (Index of the RxPDO Mapping objects) which shall not be transmitted with RxPDO 3 | OCTET-STRING[10] | RO | 00 16 05 16 07 16 00 00 00 00
Index 1404 PTO RxPDO-Par Target compact
Index | Name | Meaning | Data type | Flags | Default
1404:0 | PTO RxPDO-Par Target compact | PDO Parameter RxPDO 5 | UINT8 | RO | 0x06 (6dec)
1404:06 | Exclude RxPDOs | This entry contains the RxPDOs (Index of the RxPDO Mapping objects) which shall not be transmitted with RxPDO 5 | OCTET-STRING[10] | RO | 00 16 05 16 07 16 00 00 00 00
Index 1405 ENC RxPDO-Par Control
Index | Name | Meaning | Data type | Flags | Default
1405:0 | ENC RxPDO-Par Control | PDO Parameter RxPDO 6 | UINT8 | RO | 0x06 (6dec)
1405:06 | Exclude RxPDOs | This entry contains the RxPDOs (Index of the RxPDO Mapping objects) which shall not be transmitted with RxPDO 6 | OCTET-STRING[10] | RO | 00 16 02 16 04 16 00 00 00 00
Index 1407 PTO RxPDO-Par Target
Index | Name | Meaning | Data type | Flags | Default
1407:0 | PTO RxPDO-Par Target | PDO Parameter RxPDO 8 | UINT8 | RO | 0x06 (6dec)
1407:06 | Exclude RxPDOs | This entry contains the RxPDOs (Index of the RxPDO Mapping objects) which shall not be transmitted with RxPDO 8 | OCTET-STRING[10] | RO | 00 16 02 16 04 16 00 00 00 00
Index 1600 RxPDO-Map
Index | Name | Meaning | Data type | Flags | Default
1600:0 | RxPDO-Map | PDO Mapping RxPDO 1 | UINT8 | RO | 0x02 (2dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (Outputs), entry 0x01 (Ctrl)) | UINT32 | RO | 0x7000:01, 16
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (Outputs), entry 0x02 (Data Out)) | UINT32 | RO | 0x7000:02, 16
Index 1601 PTO RxPDO-Map Control
Index | Name | Meaning | Data type | Flags | Default
1601:0 | PTO RxPDO-Map Control | PDO Mapping RxPDO 2 | UINT8 | RO | 0x06 (6dec)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (PTO Outputs), entry 0x01 (Frequency select)) | UINT32 | RO | 0x7010:01, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (PTO Outputs), entry 0x02 (Disable ramp)) | UINT32 | RO | 0x7010:02, 1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (PTO Outputs), entry 0x03 (Go counter)) | UINT32 | RO | 0x7010:03, 1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1601:05 | SubIndex 005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1601:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7010 (PTO Outputs), entry 0x11 (Frequency value)) | UINT32 | RO | 0x7010:11, 16
Index 1602 ENC RxPDO-Map Control compact
Index | Name | Meaning | Data type | Flags | Default
1602:0 | ENC RxPDO-Map Control compact | PDO Mapping RxPDO 3 | UINT8 | RO | 0x05 (5dec)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1602:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7020 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7020:03, 1
1602:03 | SubIndex 003 | 3. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1602:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1602:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7020 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7020:11, 16
Index 1604 PTO RxPDO-Map Target compact
Index | Name | Meaning | Data type | Flags | Default
1604:0 | PTO RxPDO-Map Target compact | PDO Mapping RxPDO 5 | UINT8 | RO | 0x01 (1dec)
1604:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (PTO Outputs), entry 0x12 (Target counter value)) | UINT32 | RO | 0x7010:12, 16
Index 1605 ENC RxPDO-Map Control
Index | Name | Meaning | Data type | Flags | Default
1605:0 | ENC RxPDO-Map Control | PDO Mapping RxPDO 6 | UINT8 | RO | 0x05 (5dec)
1605:01 | SubIndex 001 | 1. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1605:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7020 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7020:03, 1
1605:03 | SubIndex 003 | 3. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1605:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1605:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7020 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7020:11, 32
Index 1607 PTO RxPDO-Map Target
Index | Name | Meaning | Data type | Flags | Default
1607:0 | PTO RxPDO-Map Target | PDO Mapping RxPDO 8 | UINT8 | RO | 0x01 (1dec)
1607:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (PTO Outputs), entry 0x12 (Target counter value)) | UINT32 | RO | 0x7010:12, 32
Index 1800 TxPDO-Par
Index | Name | Meaning | Data type | Flags | Default
1800:0 | TxPDO-Par | PDO Parameter TxPDO 1 | UINT8 | RO | 0x06 (6dec)
1800:06 | Exclude TxPDOs | This entry contains the TxPDOs (Index of the TxPDO Mapping objects) which shall not be transmitted with TxPDO 1 | OCTET-STRING[6] | RO | 01 1A 02 1A 05 1A
Index 1801 PTO TxPDO-Par Status
Index | Name | Meaning | Data type | Flags | Default
1801:0 | PTO TxPDO-Par Status | PDO Parameter TxPDO 2 | UINT8 | RO | 0x09 (9dec)
1801:06 | Exclude TxPDOs | This entry contains the TxPDOs (Index of the TxPDO Mapping objects) which shall not be transmitted with TxPDO 2 | OCTET-STRING[6] | RO | 00 1A 00 00 00 00
1801:09 | TxPDO-Toggle | the TxPDO Toggle will be toggled with every update of the corresponding input data | BOOLEAN | RO | 0x00 (0dec)
Index 1802 ENC TxPDO-Par Status compact
Index | Name | Meaning | Data type | Flags | Default
1802:0 | ENC TxPDO-Par Status compact | PDO Parameter TxPDO 3 | UINT8 | RO | 0x09 (9dec)
1802:06 | Exclude TxPDOs | This entry contains the TxPDOs (Index of the TxPDO Mapping objects) which shall not be transmitted with TxPDO 3 | OCTET-STRING[6] | RO | 05 1A 00 1A 00 00
1802:09 | TxPDO-Toggle | the TxPDO Toggle will be toggled with every update of the corresponding input data | BOOLEAN | RO | 0x00 (0dec)
Index 1805 ENC TxPDO-Par Status
Index | Name | Meaning | Data type | Flags | Default
1805:0 | ENC TxPDO-Par Status | PDO Parameter TxPDO 6 | UINT8 | RO | 0x09 (9dec)
1805:06 | Exclude TxPDOs | This entry contains the TxPDOs (Index of the TxPDO Mapping objects) which shall not be transmitted with TxPDO 6 | OCTET-STRING[6] | RO | 02 1A 00 1A 00 00
1805:09 | TxPDO-Toggle | the TxPDO Toggle will be toggled with every update of the corresponding input data | BOOLEAN | RO | 0x00 (0dec)
Index 1A00 TxPDO-Map
Index | Name | Meaning | Data type | Flags | Default
1A00:0 | TxPDO-Map | PDO Mapping TxPDO 1 | UINT8 | RO | 0x02 (2dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (Inputs), entry 0x01 (Status)) | UINT32 | RO | 0x6000:01, 16
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (Inputs), entry 0x02 (Data In)) | UINT32 | RO | 0x6000:02, 16
Index 1A01 PTO TxPDO-Map Status
Index | Name | Meaning | Data type | Flags | Default
1A01:0 | PTO TxPDO-Map Status | PDO Mapping TxPDO 2 | UINT8 | RO | 0x0A (10dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (PTO Inputs), entry 0x01 (Sel. Ack/End counter)) | UINT32 | RO | 0x6010:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (PTO Inputs), entry 0x02 (Ramp active)) | UINT32 | RO | 0x6010:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (PTO Inputs), entry 0x05 (Status of input target)) | UINT32 | RO | 0x6010:05, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (PTO Inputs), entry 0x06 (Status of input zero)) | UINT32 | RO | 0x6010:06, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (PTO Inputs), entry 0x07 (Error)) | UINT32 | RO | 0x6010:07, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x1801 (PTO TxPDO-Par Status), entry 0x09 (TxPDO-Toggle)) | UINT32 | RO | 0x1801:09, 1
Index 1A02 ENC TxPDO-Map Status compact
Index | Name | Meaning | Data type | Flags | Default
1A02:0 | ENC TxPDO-Map Status compact | PDO Mapping TxPDO 3 | UINT8 | RO | 0x0A (10dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6020:03, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6020:04, 1
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6020:05, 1
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A02:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x1802 (ENC TxPDO-Par Status compact), entry 0x09 (TxPDO-Toggle)) | UINT32 | RO | 0x1802:09, 1
1A02:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6020 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6020:11, 16
Index 1A05 ENC TxPDO-Map Status
Index | Name | Meaning | Data type | Flags | Default
1A05:0 | ENC TxPDO-Map Status | PDO Mapping TxPDO 6 | UINT8 | RO | 0x0A (10dec)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A05:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6020:03, 1
1A05:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6020:04, 1
1A05:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6020:05, 1
1A05:05 | SubIndex 005 | 5. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1A05:06 | SubIndex 006 | 6. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A05:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A05:08 | SubIndex 008 | 8. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A05:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x1805 (ENC TxPDO-Par Status), entry 0x09 (TxPDO-Toggle)) | UINT32 | RO | 0x1805:09, 1
1A05:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6020 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6020:11, 32
Index 1C00 Sync manager type
Index | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Usage of the Sync Manager channels | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign
Index | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x01 (1dec)
1C12:01 | SubIndex 001 | 1. assigned RxPDO (contains the index of the corresponding RxPDO Mapping object) | UINT16 | RW | 0x1600 (5632dec)
1C12:02 | SubIndex 002 | 2. assigned RxPDO (contains the index of the corresponding RxPDO Mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:03 | SubIndex 003 | 3. assigned RxPDO (contains the index of the corresponding RxPDO Mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 1C13 TxPDO assign
Index | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x01 (1dec)
1C13:01 | SubIndex 001 | 1. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | SubIndex 002 | 2. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 1C32 SM output parameter
Index | Name | Meaning | Data type | Flags | Default
1C32:0 | SM output parameter | Synchronization parameter of the outputs | UINT8 | RO | 0x20 (32dec)
1C32:01 Sync mode actual synchronization mode:
  • 0: Free Run
  • 1: Synchron with SM 2 Event
  • 2: DC-Mode - Synchron with SYNC0 Event
  • 3: DC-Mode - Synchron with SYNC1 Event
 UINT16 RW 0x0001 (1dec)
1C32:02 Cycle time Cycle time (in ns):
  • Free Run: cycle time of the local timer
  • Synchron with SM 2 Event: Cycle time of the master
  • DC-Mode: SYNC0/SYNC1 Cycle time
 UINT32 RW 0x00000000 (0dec)
1C32:03 | Shift time | Time between SYNC0 Event and Outputs Valid (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dec)
1C32:04 Sync modes supported Supported synchronization modes:
  • Bit 0 = 1: Free Run is supported
  • Bit 1 = 1: Synchron with SM 2 Event is supported
  • Bit 2-3 = 01: DC-Mode is supported
  • Bit 4-5 = 10: Output Shift with SYNC1 Event (only DC-Mode)
  • Bit 14 = 1: dynamic times (could be measured Messen by writing 1C32:08)
 UINT16 RO 0xC007 (49159dec)
1C32:05 | Minimum cycle time | Minimum cycle time supported (in ns) | UINT32 | RO | 0x00000000 (0dec)
1C32:06 | Calc and copy time | Minimal time between SYNC0 and SYNC1 Event (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dec)
1C32:08 Command
  • 0: Measurement of the times will be stopped
  • 1: Measurement of the times will be started

The Entries 1C32:03, 1C32:05, 1C32:06, 1C32:09, 1C33:03, 1C33:06, 1C33:09 will be updated with the maximum measured values.

UINT16 RW 0x0000 (0dec)
1C32:09 | Delay time | Time between SYNC1 Event and Outputs Valid (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dec)
1C32:0B | SM event missed counter | Number of the missed SM-Events in state OPERATIONAL (only in DC Mode) | UINT16 | RO | 0x0000 (0dec)
1C32:0C | Cycle exceeded counter | Number of the exceeded cycles in state OPERATIONAL | UINT16 | RO | 0x0000 (0dec)
1C32:0D | Shift too short counter | Number of the too short distances between SYNC0 and SYNC1 Event (only in DC Mode) | UINT16 | RO | 0x0000 (0dec)
1C32:20 | Sync error | TRUE: In the last cycle the synchronization was not correct (only in DC Mode) | BOOLEAN | RO | 0x00 (0dec)
Index 1C33 SM input parameter
Index | Name | Meaning | Data type | Flags | Default
1C33:0 | SM input parameter | Synchronization parameter of the inputs | UINT8 | RO | 0x20 (32dec)
1C33:01 Sync mode actual synchronization mode:
  • 0: Free Run
  • 1: Synchron with SM 3 Event (no Outputs available)
  • 2: DC - Synchron with SYNC0 Event
  • 3: DC - Synchron with SYNC1 Event
  • 34: Synchron with SM 2 Event (Outputs available)
 UINT16 RW 0x0022 (34dec)
1C33:02 | Cycle time | same as 1C32:02 | UINT32 | RW | 0x00000000 (0dec)
1C33:03 | Shift time | time between SYNC0-Event and Input Latch (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dec)
1C33:04 Sync modes supported Supported synchronization modes:
  • Bit 0: Free Run is supported
  • Bit 1: Synchron with SM 2 Event is supported (Outputs available)
  • Bit 1: Synchron with SM 3 Event is supported (no Outputs available)
  • Bit 2-3 = 01: DC-Mode is supported
  • Bit 4-5 = 01: Input Shift with local event (Outputs available)
  • Bit 4-5 = 10: Input Shift with SYNC1 Event (no Outputs available)
  • Bit 14 = 1: dynamic times (could be measured Messen by writing 1C32:08 or 1C33:08)
 UINT16 RO 0xC007 (49159dec)
1C33:05 | Minimum cycle time | same as 1C32:05 | UINT32 | RO | 0x00000000 (0dec)
1C33:06 | Calc and copy time | time between Input Latch and the availability of the inputs for the master (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dec)
1C33:08 | Command | same as 1C32:08 | UINT16 | RW | 0x0000 (0dec)
1C33:09 | Delay time | time between SYNC1-Event and Input Latch (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dec)
1C33:0B | SM event missed counter | same as 1C32:11 | UINT16 | RO | 0x0000 (0dec)
1C33:0C | Cycle exceeded counter | same as 1C32:12 | UINT16 | RO | 0x0000 (0dec)
1C33:0D | Shift too short counter | same as 1C32:13 | UINT16 | RO | 0x0000 (0dec)
1C33:20 | Sync error | same as 1C32:32 | BOOLEAN | RO | 0x00 (0dec)

Profile specific objects (0x6000-0xFFFF)

The profile specific objects have the same meaning for all EtherCAT Slaves which support the profile 5001.

Index 6000 Inputs
Index | Name | Meaning | Data type | Flags | Default
6000:0 | Inputs | Max. subindex | UINT8 | RO | 0x02 (2dec)
6000:01 | Status | Status word | UINT16 | RO | 0x0000 (0dec)
6000:02 | Data In | Input process data (counter value, index 6020:11) | UINT16 | RO | 0x0000 (0dec)
Index 6010 PTO Inputs
Index | Name | Meaning | Data type | Flags | Default
6010:0 | PTO Inputs | Max. subindex | UINT8 | RO | 0x10 (16dec)
6010:01 | Sel. Ack/End counter | Confirms the change of base frequency. At activated travel distance control: target counter value reached | BOOLEAN | RO | 0x00 (0dec)
6010:02 | Ramp active | Ramp is currently being followed | BOOLEAN | RO | 0x00 (0dec)
6010:05 | Status of input target | Status of INPUT TARGET (T) | BOOLEAN | RO | 0x00 (0dec)
6010:06 | Status of input zero | Status of INPUT ZERO (Z) | BOOLEAN | RO | 0x00 (0dec)
6010:07 | Error | General error bit, included with overflow/underflow | BOOLEAN | RO | 0x00 (0dec)
6010:0E | Sync Error | TRUE: In the last cycle the synchronization was not correct (only in DC Mode) | BOOLEAN | RO | 0x00 (0dec)
6010:10 | TxPDO Toggle | The TxPDO Toggle is toggled by the slave, if the data of the corresponding PDO was updated. | BOOLEAN | RO | 0x00 (0dec)
Index 6020 ENC Inputs
Index | Name | Meaning | Data type | Flags | Default
6020:0 | ENC Inputs | Max. subindex | UINT8 | RO | 0x16 (22dec)
6020:03 | Set counter done | Set counter done | BOOLEAN | RO | 0x00 (0dec)
6020:04 | Counter underflow | This bit is set if the 16-bit counter underflows (0 -> 65535). It is reset when the counter drops below two thirds of its measuring range (43690 -> 43689) or immediately an overflow occurs. | BOOLEAN | RO | 0x00 (0dec)
6020:05 | Counter overflow | This bit is set if the 16-bit counter overflows (65535 -> 0). It is reset when the counter exceeds one third of its measuring range (21845 -> 21846) or immediately an underflow occurs | BOOLEAN | RO | 0x00 (0dec)
6020:0E | Sync Error | TRUE: In the last cycle the synchronization was not correct (only in DC Mode) | BOOLEAN | RO | 0x00 (0dec)
6020:10 | TxPDO Toggle | The TxPDO Toggle is toggled by the slave, if the data of the corresponding PDO was updated. | BOOLEAN | RO | 0x00 (0dec)
6020:11 | Counter value | Counter value | UINT32 | RO | 0x00000000 (0dec)
Index 7000 Outputs
Index | Name | Meaning | Data type | Flags | Default
7000:0 | Outputs | Max. subindex | UINT8 | RO | 0x02 (2dec)
7000:01 | Ctrl | Control word | UINT16 | RO | 0x0000 (0dec)
7000:02 | Data Out | Output process data( frequency value, index 7010:11) | UINT16 | RO | 0x0000 (0dec)
Index 7010 PTO Outputs
Index | Name | Meaning | Data type | Flags | Default
7010:0 | PTO Outputs | Max. subindex | UINT8 | RO | 0x12 (18dec)
7010:01 | Frequency select | Rapid change of the base frequency (only if the ramp function is inactive): 0bin = Base frequency 1 (object 8001:02 resp. 8010:12) 1bin = Base frequency 2 (object 8001:03 resp. 8010:13) | BOOLEAN | RO | 0x00 (0dec)
7010:02 | Disable ramp | Operation of the ramp function is cancelled, in spite of object 8000:06 resp. 8010:06 being active; if travel distance control is active, it is interrupted by this bit | BOOLEAN | RO | 0x00 (0dec)
7010:03 | Go counter | If travel distance control is active (object 8000:0A resp. 8010:0A ) then a pre-set counter value is approached when the bit is set | BOOLEAN | RO | 0x00 (0dec)
7010:11 | Frequency value | Frequency value | UINT16 | RO | 0x0000 (0dec)
7010:12 | Target counter value | Target counter value | UINT32 | RO | 0x00000000 (0dec)
Index 7020 ENC Outputs
Index | Name | Meaning | Data type | Flags | Default
7020:0 | ENC Outputs | Max. subindex | UINT8 | RO | 0x11 (17dec)
7020:03 | Set counter | Set counter | BOOLEAN | RO | 0x00 (0dec)
7020:11 | Set counter value | Set counter value (with index 7020:03) | UINT32 | RO | 0x00000000 (0dec)
Index A000 Diagnostic parameter
Index | Name | Meaning | Data type | Flags | Default
A000:0 | Diagnostic parameter | Max. subindex | UINT8 | RO | 0x01 (1dec)
A000:01 | Counter extension | Counter extension | UINT16 | RO | 0x0000 (0dec)
Index F000 Modular device profile
Index | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | general informations about the Modular Device Profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance between the objects of two channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | number of channels | UINT16 | RO | 0x0003 (3dec)
Index F008 Code word
Index | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module list
Index | Name | Meaning | Data type | Flags | Default
F010:0 | Module list | Max. subindex | UINT8 | RW | 0x03 (3dec)
F010:01 | SubIndex 001 | reserved | UINT32 | RW | 0x00000000 (0dec)
F010:02 | SubIndex 002 | reserved | UINT32 | RW | 0x000000FD (253dec)
F010:03 | SubIndex 003 | reserved | UINT32 | RW | 0x000001FF (511dec)


EL2521-0124 - Object description and parameterization

BECKHOFF EL2521-0124: Commissioning

Object description and parameterization - enhanced operating mode

Note 		EtherCAT XML Device Description
The description correspond to the display of the CoE objects from the EtherCAT XML Device Description. It is strongly recommended to download the latest revision of the corresponding XML file from the Beckhoff website and follow the installation instructions.

Note 		Parameterization via the CoE list (CAN over EtherCAT)
The terminal is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs).
Please note the following general CoE information when using/manipulating the CoE parameters:
- Keep a startup list if components have to be replaced
- Differentiation between online/offline dictionary, existence of current XML description
- use "CoE reload" for resetting changes

Introduction

The CoE overview contains objects for different intended applications:

  • Objects required for parameterization during commissioning
  • Objects intended for regular operation, e.g. through ADS access.
  • Objects for indicating internal settings (may be fixed)

The following section first describes the objects require for normal operation, followed by a complete overview of other objects.

Objects for commissioning

Index 1011 Restore default parameters
Index | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore the default settings in the EtherCAT slave | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" ("Set Value Dialog") all terminal-specific objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)
Index 8000 PTO Settings
Index | Name | Meaning | Data type | Flags | Default
8000:0 | PTO Settings | Max. subindex | UINT8 | RO | 0x18 (24dec)
8000:02 | Emergency ramp active | TRUE When the watchdog is triggered, the terminal approaches with a ramp (time constant set in object 8000:18) to the value defined in object 8000:11. FALSE The function is deactivated | BOOLEAN | RW | 0x00 (0dec)
8000:03 | Watchdog timer deactive | TRUE The watchdog timer is deactivated FALSE The watchdog timer is switched on by default. Either the manufacturer's of the user's switch-on value is output if the watchdog overflows | BOOLEAN | RW | 0x00 (0dec)
8000:04 | Sign/amount representation | TRUE The measured value is output in magnitude-sign format: -2dec= 0x8002 -1dec= 0x8001 1dec= 0x0001 2dec= 0x0002 FALSE The measurement is output as a signed integer in two's complement format: -2dec= 0xFFFE -1dec= 0xFFFF 1dec= 0x0001 2dec= 0x0002 | BOOLEAN | RW | 0x00 (0dec)
8000:06 | Ramp function active | TRUE Ramp function active FALSE Ramp function deactive | BOOLEAN | RW | 0x01 (1dec)
8000:07 | Ramp base frequency | 0(dec) Ramp base frequency: 10 Hz (pulldown menu) 1(dec) Ramp base frequency: 1 kHz (pulldown menu) | BIT1 | RW | 0x00 (0dec)
8000:08 | Direct input mode | TRUE Input mode: direct FALSE Input mode: relative | BOOLEAN | RW | 0x00 (0dec)
8000:09 | Users switch-on-value on wdt | TRUE Behavior when watchdog triggered: User's switch-on value FALSE Behavior when watchdog triggered: Manufacturer's switch-on value | BOOLEAN | RW | 0x00 (0dec)
8000:0A | Travel distance control active | TRUE Travel distance control: active FALSE Travel distance control: deactive | BOOLEAN | RW | 0x00 (0dec)
8000:0B | Output set active low | Reversal logic for Output 24 V 0: switched status HIGH level 1: switched status LOW level | BOOLEAN | RW | 0x00 (0dec)
8000:0E | Operating mode | 0(dec) Operation mode frequency modulation (pulldown menu) 1(dec) Operation mode pulse-direction control (pulldown menu) 2(dec) Operation mode incremental encoder (pulldown menu) | BIT2 | RW | 0x00 (0dec)
8000:10 | Negative logic | TRUE Negative logic FALSE Positive logic | BOOLEAN | RW | 0x00 (0dec)
8000:11 | Users switch-on-value | User's switch-on value | UINT16 | RW | 0x0000 (0dec)
8000:12 | Base frequency 1 | Base frequency 1 = 50000 Hz | UINT32 | RW | 0x0000C350 (50000dec)
8000:13 | Base frequency 2 | Base frequency 2 = 100000 Hz | UINT32 | RW | 0x000186A0 (100000dec)
8000:14 | Ramp time constant (rising) | Ramp time constant (rising) | UINT16 | RW | 0x03E8 (1000dec)
8000:15 | Ramp time constant (falling) | Ramp time constant (falling) | UINT16 | RW | 0x03E8 (1000dec)
8000:16 | Frequency factor (Digit x 10mHz) | Frequency factor (direct input, digit x 10mHz) | UINT16 | RW | 0x0064 (100dec)
8000:17 | Slowing down frequency | Slowing down frequency, travel distance control | UINT16 | RW | 0x0032 (50dec)
8000:18 | Ramp time constant (emergency) | Ramp time constant for emergency shut-down; User's switch-on value will be approached (object 8000:11) | UINT16 | RW | 0x03E8 (1000dec)

Objects for regular operation

In enhanced operating mode the EL2521-0124 has no such objects.

Complete overview

Standard objects (0x1000-0x1FFF)

The standard objects of all EtherCAT slaves have the same meaning.

Index 1000 Device type
Index | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device Type of the EtherCAT slave: The Lo-Word contains the supported CoE Profile (5001). The Hi-Word contains the Module Profile corresponding to the Modular Device Profile. | UINT32 | RO | 0x00001389 (5001dec)
Index 1008 Device name
Index | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EL2521-0124
Index 1009 Hardware version
Index | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slaves | STRING | RO | 03
Index 100A Software version
Index | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slaves | STRING | RO | 01
Index 1011 Restore default parameters
Index | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore the default settings in the EtherCAT slave | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" ("Set Value Dialog") all terminal-specific objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)
Index 1018 Identity
Index | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | contains information to identify the EtherCAT slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x09D93052 (165228626dec)
1018:03 | Revision | Revision number of the EtherCAT-Slave, the Lo-Word (Bit 0-15) indicates the special functions terminal number; the Hi-Word (Bit 16-31) refers to the device description. | UINT32 | RO | 0x0010007C (1048700dec)
1018:04 | Serial number | Serial number of the EtherCAT-Slave, the Lo-Byte (Bit 0-7) of the Lo-Word contains the year of manufacturing, the Hi-Byte (Bit 8-15) of the Lo-Word contains the week of manufacturing, the Hi-Word (Bit 16-31) is 0 . | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 Backup parameter handling
Index | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | contains informations for the standardized Upload and Download of the Backup Entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum over all backup entries | UINT32 | RO | 0x00000000 (0dec)
Index 1401 ENC RxPDO-Par Control compact
Index | Name | Meaning | Data type | Flags | Default
1401:0 | ENC RxPDO-Par Control compact | PDO Parameter RxPDO 2 | UINT8 | RO | 0x06 (6dec)
1401:06 | Exclude RxPDOs | This entry contains the RxPDOs (Index of the RxPDO Mapping objects) which shall not be transmitted with RxPDO 2 | OCTET-STRING[6] | RO | 04 16 05 16 06 16
Index 1402 PLS RxPDO-Par Control compact
Index | Name | Meaning | Data type | Flags | Default
1402:0 | PLS RxPDO-Par Control compact | PDO Parameter RxPDO 3 | UINT8 | RO | 0x06 (6dec)
1402:06 | Exclude RxPDOs | This entry contains the RxPDOs (Index of the RxPDO Mapping objects) which shall not be transmitted with RxPDO 3 | OCTET-STRING[6] | RO | 04 16 05 16 06 16
Index 1403 PTO RxPDO-Par Target compact
Index | Name | Meaning | Data type | Flags | Default
1403:0 | PTO RxPDO-Par Target compact | PDO Parameter RxPDO 4 | UINT8 | RO | 0x06 (6dec)
1403:06 | Exclude RxPDOs | This entry contains the RxPDOs (Index of the RxPDO Mapping objects) which shall not be transmitted with RxPDO 4 | OCTET-STRING[6] | RO | 04 16 05 16 06 16
Index 1404 ENC RxPDO-Par Control
Index | Name | Meaning | Data type | Flags | Default
1404:0 | ENC RxPDO-Par Control | PDO Parameter RxPDO 5 | UINT8 | RO | 0x06 (6dec)
1404:06 | Exclude RxPDOs | This entry contains the RxPDOs (Index of the RxPDO Mapping objects) which shall not be transmitted with RxPDO 5 | OCTET-STRING[6] | RO | 01 16 02 16 03 16
Index 1405 PLS RxPDO-Par Control
Index | Name | Meaning | Data type | Flags | Default
1405:0 | PLS RxPDO-Par Control | PDO Parameter RxPDO 6 | UINT8 | RO | 0x06 (6dec)
1405:06 | Exclude RxPDOs | This entry contains the RxPDOs (Index of the RxPDO Mapping objects) which shall not be transmitted with RxPDO 6 | OCTET-STRING[6] | RO | 01 16 02 16 03 16
Index 1406 PTO RxPDO-Par Target
Index | Name | Meaning | Data type | Flags | Default
1406:0 | PTO RxPDO-Par Target | PDO Parameter RxPDO 7 | UINT8 | RO | 0x06 (6dec)
1406:06 | Exclude RxPDOs | This entry contains the RxPDOs (Index of the RxPDO Mapping objects) which shall not be transmitted with RxPDO 7 | OCTET-STRING[6] | RO | 01 16 02 16 03 16
Index 1600 PTO RxPDO-Map Control
Index | Name | Meaning | Data type | Flags | Default
1600:0 | PTO RxPDO-Map Control | PDO Mapping RxPDO 1 | UINT8 | RO | 0x06 (6dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (PTO Outputs), entry 0x01 (Frequency select)) | UINT32 | RO | 0x7000:01, 1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (PTO Outputs), entry 0x02 (Disable ramp)) | UINT32 | RO | 0x7000:02, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (PTO Outputs), entry 0x03 (Go counter)) | UINT32 | RO | 0x7000:03, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1600:05 | SubIndex 005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1600:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7000 (PTO Outputs), entry 0x11 (Frequency value)) | UINT32 | RO | 0x7000:11, 16
Index 1601 ENC RxPDO-Map Control compact
Index | Name | Meaning | Data type | Flags | Default
1601:0 | ENC RxPDO-Map Control compact | PDO Mapping RxPDO 2 | UINT8 | RO | 0x07 (7dec)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7010:02, 1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7010:03, 1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7010:04, 1
1601:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1601:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1601:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7010:11, 16
Index 1602 PLS RxPDO-Map Control compact
Index | Name | Meaning | Data type | Flags | Default
1602:0 | PLS RxPDO-Map Control compact | PDO Mapping RxPDO 3 | UINT8 | RO | 0x07 (7dec)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (PLS Outputs), entry 0x01 (Enable PLS)) | UINT32 | RO | 0x7020:01, 1
1602:02 | SubIndex 002 | 2. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1602:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7020 (PLS Outputs), entry 0x04 (Output)) | UINT32 | RO | 0x7020:04, 1
1602:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1602:05 | SubIndex 005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1602:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7020 (PLS Outputs), entry 0x11 (Switch on value)) | UINT32 | RO | 0x7020:11, 16
1602:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7020 (PLS Outputs), entry 0x12 (Switch off value)) | UINT32 | RO | 0x7020:12, 16
Index 1603 PTO RxPDO-Map Target compact
Index | Name | Meaning | Data type | Flags | Default
1603:0 | PTO RxPDO-Map Target compact | PDO Mapping RxPDO 4 | UINT8 | RO | 0x01 (1dec)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (PTO Outputs), entry 0x12 (Target counter value)) | UINT32 | RO | 0x7000:12, 16
Index 1604 ENC RxPDO-Map Control
Index | Name | Meaning | Data type | Flags | Default
1604:0 | ENC RxPDO-Map Control | PDO Mapping RxPDO 5 | UINT8 | RO | 0x07 (7dec)
1604:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1604:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7010:02, 1
1604:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7010:03, 1
1604:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7010:04, 1
1604:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1604:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1604:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7010:11, 32
Index 1605 PLS RxPDO-Map Control
Index | Name | Meaning | Data type | Flags | Default
1605:0 | PLS RxPDO-Map Control | PDO Mapping RxPDO 6 | UINT8 | RO | 0x07 (7dec)
1605:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (PLS Outputs), entry 0x01 (Enable PLS)) | UINT32 | RO | 0x7020:01, 1
1605:02 | SubIndex 002 | 2. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1605:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7020 (PLS Outputs), entry 0x04 (Output)) | UINT32 | RO | 0x7020:04, 1
1605:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1605:05 | SubIndex 005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1605:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7020 (PLS Outputs), entry 0x11 (Switch on value)) | UINT32 | RO | 0x7020:11, 32
1605:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7020 (PLS Outputs), entry 0x12 (Switch off value)) | UINT32 | RO | 0x7020:12, 32
Index 1606 PTO RxPDO-Map Target
Index | Name | Meaning | Data type | Flags | Default
1606:0 | PTO RxPDO-Map Target | PDO Mapping RxPDO 7 | UINT8 | RO | 0x01 (1dec)
1606:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (PTO Outputs), entry 0x12 (Target counter value)) | UINT32 | RO | 0x7000:12, 32
Index 1801 ENC TxPDO-Par Status compact
Index | Name | Meaning | Data type | Flags | Default
1801:0 | ENC TxPDO-Par Status compact | PDO Parameter TxPDO 2 | UINT8 | RO | 0x09 (9dec)
1801:06 | Exclude TxPDOs | This entry contains the TxPDOs (Index of the TxPDO Mapping objects) which shall not be transmitted with TxPDO 2 | OCTET-STRING[2] | RO | 04 1A
1801:09 | TxPDO Toggle | the TxPDO Toggle will be toggled with every update of the corresponding input data | BOOLEAN | RO | 0x00 (0dec)
Index 1804 ENC TxPDO-Par Status
Index | Name | Meaning | Data type | Flags | Default
1804:0 | ENC TxPDO-Par Status | PDO Parameter TxPDO 5 | UINT8 | RO | 0x09 (9dec)
1804:06 | Exclude TxPDOs | This entry contains the TxPDOs (Index of the TxPDO Mapping objects) which shall not be transmitted with TxPDO 5 | OCTET-STRING[2] | RO | 01 1A
1804:09 | TxPDO Toggle | the TxPDO Toggle will be toggled with every update of the corresponding input data | BOOLEAN | RO | 0x00 (0dec)
Index 1A00 PTO TxPDO-Map Status
Index | Name | Meaning | Data type | Flags | Default
1A00:0 | PTO TxPDO-Map Status | PDO Mapping TxPDO 1 | UINT8 | RO | 0x08 (8dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (PTO Inputs), entry 0x01 (Sel. Ack/End counter)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (PTO Inputs), entry 0x02 (Ramp active)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (PTO Inputs), entry 0x07 (Error)) | UINT32 | RO | 0x6000:07, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1800, entry 0x09) | UINT32 | RO | 0x1800:09, 1
Index 1A01 ENC TxPDO-Map Status compact
Index | Name | Meaning | Data type | Flags | Default
1A01:0 | ENC TxPDO-Map Status compact | PDO Mapping TxPDO 2 | UINT8 | RO | 0x0D (13dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6010:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6010:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6010:04, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6010:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6010:0D, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x1801 (ENC TxPDO-Par Status compact), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1801:09, 1
1A01:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6010:11, 16
1A01:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x12 (Latch value)) | UINT32 | RO | 0x6010:12, 16
Index 1A02 PLS TxPDO-Map Status
Index | Name | Meaning | Data type | Flags | Default
1A02:0 | PLS TxPDO-Map Status | PDO Mapping TxPDO 3 | UINT8 | RO | 0x07 (7dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (PLS Inputs), entry 0x01 (PLS Enabled)) | UINT32 | RO | 0x6020:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (PLS Inputs), entry 0x04 (Status of output)) | UINT32 | RO | 0x6020:04, 1
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (9 bits align) | UINT32 | RO | 0x0000:00, 9
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x1802, entry 0x09) | UINT32 | RO | 0x1802:09, 1
Index 1A04 ENC TxPDO-Map Status
Index | Name | Meaning | Data type | Flags | Default
1A04:0 | ENC TxPDO-Map Status | PDO Mapping TxPDO 5 | UINT8 | RO | 0x0D (13dec)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6010:02, 1
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6010:03, 1
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6010:04, 1
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6010:05, 1
1A04:06 | SubIndex 006 | 6. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1A04:07 | SubIndex 007 | 7. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A04:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6010:0D, 1
1A04:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A04:0A | SubIndex 010 | 10. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A04:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x1804 (ENC TxPDO-Par Status), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1804:09, 1
1A04:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6010:11, 32
1A04:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x12 (Latch value)) | UINT32 | RO | 0x6010:12, 32
Index 1C00 Sync manager type
Index | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Usage of the Sync Manager channels | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign
Index | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x03 (3dec)
1C12:01 | SubIndex 001 | 1. assigned RxPDO (contains the index of the corresponding RxPDO Mapping object) | UINT16 | RW | 0x1600 (5632dec)
1C12:02 | SubIndex 002 | 2. assigned RxPDO (contains the index of the corresponding RxPDO Mapping object) | UINT16 | RW | 0x1601 (5633dec)
1C12:03 | SubIndex 003 | 3. assigned RxPDO (contains the index of the corresponding RxPDO Mapping object) | UINT16 | RW | 0x1602 (5634dec)
1C12:04 | SubIndex 004 | 4. assigned RxPDO (contains the index of the corresponding RxPDO Mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 1C13 TxPDO assign
Index | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x03 (3dec)
1C13:01 | SubIndex 001 | 1. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | SubIndex 002 | 2. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A01 (6657dec)
1C13:03 | SubIndex 003 | 3. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A02 (6658dec)
Index 1C32 SM output parameter
Index | Name | Meaning | Data type | Flags | Default
1C32:0 | SM output parameter | Synchronization parameter of the outputs | UINT8 | RO | 0x20 (32dec)
1C32:01 Sync mode actual synchronization mode:
  • 0: Free Run
  • 1: Synchron with SM 2 Event
  • 2: DC-Mode - Synchron with SYNC0 Event
  • 3: DC-Mode - Synchron with SYNC1 Event
 UINT16 RW 0x0001 (1dec)
1C32:02 Cycle time Cycle time (in ns):
  • Free Run: cycle time of the local timer
  • Synchron with SM 2 Event: Cycle time of the master
  • DC-Mode: SYNC0/SYNC1 Cycle time
 UINT32 RW 0x001E8480 (2000000dec)
1C32:03 | Shift time | Time between SYNC0 Event and Outputs Valid (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dec)
1C32:04 Sync modes supported Supported synchronization modes:
  • Bit 0 = 1: Free Run is supported
  • Bit 1 = 1: Synchron with SM 2 Event is supported
  • Bit 2-3 = 01: DC-Mode is supported
  • Bit 4-5 = 10: Output Shift with SYNC1 Event (only DC-Mode)
  • Bit 14 = 1: dynamic times (could be measured Messen by writing 1C32:08)
 UINT16 RO 0xC007 (49159dec)
1C32:05 | Minimum cycle time | Minimum cycle time supported (in ns) | UINT32 | RO | 0x00000000 (0dec)
1C32:06 | Calc and copy time | Minimal time between SYNC0 and SYNC1 Event (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dec)
1C32:07 | Minimum delay time | UINT32 | RO | 0x00000000 (0dec)
1C32:08 Command
  • 0: Measurement of the times will be stopped
  • 1: Measurement of the times will be started

The Entries 1C32:03, 1C32:05, 1C32:06, 1C32:09, 1C33:03, 1C33:06, 1C33:09 will be updated with the maximum measured values.

UINT16 RW 0x0000 (0dec)
1C32:09 | Maximum Delay time | Time between SYNC1 Event and Outputs Valid (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dec)
1C32:0B | SM event missed counter | Number of the missed SM-Events in state OPERATIONAL (only in DC Mode) | UINT16 | RO | 0x0000 (0dec)
1C32:0C | Cycle exceeded counter | Number of the exceeded cycles in state OPERATIONAL | UINT16 | RO | 0x0000 (0dec)
1C32:0D | Shift too short counter | Number of the too short distances between SYNC0 and SYNC1 Event (only in DC Mode) | UINT16 | RO | 0x0000 (0dec)
1C32:20 | Sync error | TRUE: In the last cycle the synchronization was not correct (only in DC Mode) | BOOLEAN | RO | 0x00 (0dec)
Index 1C33 SM input parameter
Index | Name | Meaning | Data type | Flags | Default
1C33:0 | SM input parameter | Synchronization parameter of the inputs | UINT8 | RO | 0x20 (32dec)
1C33:01 Sync mode actual synchronization mode:
  • 0: Free Run
  • 1: Synchron with SM 3 Event (no Outputs available)
  • 2: DC - Synchron with SYNC0 Event
  • 3: DC - Synchron with SYNC1 Event
  • 34: Synchron with SM 2 Event (Outputs available)
 UINT16 RW 0x0022 (34dec)
1C33:02 | Cycle time | same as 1C32:02 | UINT32 | RW | 0x001E8480 (2000000dec)
1C33:03 | Shift time | time between SYNC0-Event and Input Latch (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dec)
1C33:04 Sync modes supported Supported synchronization modes:
  • Bit 0: Free Run is supported
  • Bit 1: Synchron with SM 2 Event is supported (Outputs available)
  • Bit 1: Synchron with SM 3 Event is supported (no Outputs available)
  • Bit 2-3 = 01: DC-Mode is supported
  • Bit 4-5 = 01: Input Shift with local event (Outputs available)
  • Bit 4-5 = 10: Input Shift with SYNC1 Event (no Outputs available)
  • Bit 14 = 1: dynamic times (could be measured Messen by writing 1C32:08 or 1C33:08)
 UINT16 RO 0xC007 (49159dec)
1C33:05 | Minimum cycle time | same as 1C32:05 | UINT32 | RO | 0x00000000 (0dec)
1C33:06 | Calc and copy time | time between Input Latch and the availability of the inputs for the master (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dec)
1C33:07 | Minimum delay time | UINT32 | RO | 0x00000000 (0dec)
1C33:08 | Command | same as 1C32:08 | UINT16 | RW | 0x0000 (0dec)
1C33:09 | Maximum Delay time | time between SYNC1-Event and Input Latch (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dec)
1C33:0B | SM event missed counter | same as 1C32:11 | UINT16 | RO | 0x0000 (0dec)
1C33:0C | Cycle exceeded counter | same as 1C32:12 | UINT16 | RO | 0x0000 (0dec)
1C33:0D | Shift too short counter | same as 1C32:13 | UINT16 | RO | 0x0000 (0dec)
1C33:20 | Sync error | same as 1C32:32 | BOOLEAN | RO | 0x00 (0dec)

Profile specific objects (0x6000-0xFFFF)

The profile specific objects have the same meaning for all EtherCAT Slaves which support the profile 5001.

Index 6000 PTO Inputs
Index | Name | Meaning | Data type | Flags | Default
6000:0 | PTO Inputs | Max. subindex | UINT8 | RO | 0x10 (16dec)
6000:01 | Sel. Ack/End counter | Confirms the change of base frequency. At activated travel distance control: target counter value reached | BOOLEAN | RO | 0x00 (0dec)
6000:02 | Ramp active | Ramp is currently being followed | BOOLEAN | RO | 0x00 (0dec)
6000:07 | Error | General error bit, included with overflow/underflow | BOOLEAN | RO | 0x00 (0dec)
6000:0E | Sync error | TRUE: In the last cycle the synchronization was not correct (only in DC Mode) | BOOLEAN | RO | 0x00 (0dec)
6000:10 | TxPDO Toggle | The TxPDO Toggle is toggled by the slave, if the data of the corresponding PDO was updated. | BOOLEAN | RO | 0x00 (0dec)
Index 6010 ENC Inputs
Index | Name | Meaning | Data type | Flags | Default
6010:0 | ENC Inputs | Max. subindex | UINT8 | RO | 0x12 (18dec)
6010:02 | Latch extern valid | The counter value was latched with the extern latch input. The data of index 6010:12 correspond to the latched value. To reactivate the latch input, the index 7010:02 or index 7010:04 have to be reset and then set again. | BOOLEAN | RO | 0x00 (0dec)
6010:03 | Set counter done | Set counter done | BOOLEAN | RO | 0x00 (0dec)
6010:04 | Counter underflow | This bit is set if the 16-bit counter underflows (0 -> 65535). It is reset when the counter drops below two thirds of its measuring range (43690 -> 43689) or immediately an overflow occurs. | BOOLEAN | RO | 0x00 (0dec)
6010:05 | Counter overflow | This bit is set if the 16-bit counter overflows (65535 -> 0). It is reset when the counter exceeds one third of its measuring range (21845 -> 21846) or immediately an underflow occurs | BOOLEAN | RO | 0x00 (0dec)
6010:0D | Status of extern latch | Status of extern latch | BOOLEAN | RO | 0x00 (0dec)
6010:0E | Sync error | TRUE: In the last cycle the synchronization was not correct (only in DC Mode) | BOOLEAN | RO | 0x00 (0dec)
6010:10 | TxPDO Toggle | The TxPDO Toggle is toggled by the slave, if the data of the corresponding PDO was updated. | BOOLEAN | RO | 0x00 (0dec)
6010:11 | Counter value | Counter value | UINT32 | RO | 0x00000000 (0dec)
6010:12 | Latch value | Latch value | UINT32 | RO | 0x00000000 (0dec)
Index 6020 PLS Inputs
Index | Name | Meaning | Data type | Flags | Default
6020:0 | PLS Inputs | Max. subindex | UINT8 | RO | 0x10 (16dec)
6020:01 | PLS Enabled | PLS function activated | BOOLEAN | RO | 0x00 (0dec)
6020:04 | Status of output | Status of Output 24 V | BOOLEAN | RO | 0x00 (0dec)
6020:0E | Sync error | TRUE: In the last cycle the synchronization was not correct (only in DC Mode) | BOOLEAN | RO | 0x00 (0dec)
6020:10 | TxPDO Toggle | The TxPDO Toggle is toggled by the slave, if the data of the corresponding PDO was updated. | BOOLEAN | RO | 0x00 (0dec)
Index 7000 PTO Outputs
Index | Name | Meaning | Data type | Flags | Default
7000:0 | PTO Outputs | Max. subindex | UINT8 | RO | 0x12 (18dec)
7000:01 | Frequency select | Rapid change of the base frequency (only if the ramp function is inactive): 0bin = Base frequency 1 (object 8000:12) 1bin = Base frequency 2 (object 8000:13) | BOOLEAN | RO | 0x00 (0dec)
7000:02 | Disable ramp | Operation of the ramp function is cancelled, in spite of object 8000:06 being active; if travel distance control is active, it is interrupted by this bit | BOOLEAN | RO | 0x00 (0dec)
7000:03 | Go counter | If travel distance control is active (object 8000:0A ) then a pre-set counter value is approached when the bit is set | BOOLEAN | RO | 0x00 (0dec)
7000:11 | Frequency value | Frequency value | UINT16 | RO | 0x0000 (0dec)
7000:12 | Target counter value | Target counter value | UINT32 | RO | 0x00000000 (0dec)
Index 7010 ENC Outputs
Index | Name | Meaning | Data type | Flags | Default
7010:0 | ENC Outputs | Max. subindex | UINT8 | RO | 0x11 (17dec)
7010:02 | Enable latch extern on positive edge | Enabling the external latch on positive edge | BOOLEAN | RO | 0x00 (0dec)
7010:03 | Set counter | Set counter | BOOLEAN | RO | 0x00 (0dec)
7010:04 | Enable latch extern on negative edge | Enabling the external latch on negative edge | BOOLEAN | RO | 0x00 (0dec)
7010:11 | Set counter value | The counter value, which can be set via „Set counter“ (Index 7010:03) | UINT32 | RO | 0x00000000 (0dec)
Index 7020 PLS Outputs
Index | Name | Meaning | Data type | Flags | Default
7020:0 | PLS Outputs | Max. subindex | UINT8 | RO | 0x12 (18dec)
7020:01 | Enable PLS | Activation of PLS function | BOOLEAN | RO | 0x00 (0dec)
7020:04 | Output | Signal at Output 24 V | BOOLEAN | RO | 0x00 (0dec)
7020:11 | Switch on value | at this counter value, the Output 24 V is switched on | UINT32 | RO | 0x00000000 (0dec)
7020:12 | Switch off value | at this counter value, the Output 24 V is switched off | UINT32 | RO | 0x00000000 (0dec)
Index F000 Modular device profile
Index | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | general information about the Modular Device Profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance between the objects of two channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | number of channels | UINT16 | RO | 0x0003 (3dec)
Index F008 Code word
Index | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module list
Index | Name | Meaning | Data type | Flags | Default
F010:0 | Module list | Max. subindex | UINT8 | RW | 0x03 (3dec)
F010:01 | SubIndex 001 | reserved | UINT32 | RW | 0x000000FD (253dec)
F010:02 | SubIndex 002 | reserved | UINT32 | RW | 0x000001FF (511dec)
F010:03 | SubIndex 003 | reserved | UINT32 | RW | 0x00000200 (512dec)


EtherCAT AL Status Codes

Error Code 0x0000

Meaning:

No error

Description | Current State (or state change) | Resulting State | Solution
No error | Any | Current state |

Error Code 0x0001

Meaning:

Unspecified error
Description | Current State (or state change) | Resulting State | Solution
No error code is defined for occurred error. | Any | Any + E | Read user manual or contact device manufacturer

Error Code 0x0002

Meaning:

No Memory
Description | Current State (or state change) | Resulting State | Solution
Less hardware memory, slave need more memory. | Any | Any + E | Download smaller files or objects Check user manual
Example: For slave configuration, application configuration files are downloaded (possibly via FoE or large CoE objects). The size of those files exceeds the local memory.

Error Code 0x0011

Meaning:

Invalid requested state change
Description | Current State (or state change) | Resulting State | Solution
The EtherCAT State Machine (ESM) defines which state changes are allowed. All other state changes are not allowed. | P→S, I→O, P→O, O→B, S→B, P→B | Current State + E | Go step-by-step from the original state to the desired state.
Example: If the master requests the slave to go from OP (AL Control = 0x08) directly to BOOT (AL Control = 0x03).

Error Code 0x0012

Meaning:

Unknown requested state change
Description | Current State (or state change) | Resulting State | Solution
The ESM defines the following states. They are coded with fixed values (only lower (=right) nibble): BOOT: AL Control = 0x03 INIT: AL Control = 0x01 PREOP: AL Control = 0x02 SAFEOP: AL Control = 0x04 OP: AL Control = 0x08 The fifth bit of the AL Control (left nibble is 1) is the “Error Acknowledge Bit”. If the slave is in AL STATUS = 0x14, i.e. ERROR SAFEOP the master acknowledges this by setting the Acknowledge bit | Any | Current State + E | Do only request the defined states
Example: If any other value for AL Control than those specified are sent.

Error Code 0x0013

Meaning:

Boot state not supported
Description | Current State (or state change) | Resulting State | Solution
Device does not support BOOT state, but the master requests the slave to go to BOOT (AL Control = 0x03) | I→B | I + E |

Error Code 0x0014

Meaning:

No valid firmware
Description | Current State (or state change) | Resulting State | Solution
This error code may be returned after a firmware download, if the downloaded file cannot be used by the application controller. | I→P | I + E | Download a firmware that can be supported by the hardware and bootloader. Check Product Code and Revision Number (CoE object 0x1018). If this cannot be read from the firmware any more you may see this in the network configuration (CoE object dictionary) or probably in the ESI file (element Profile: ObjectDictionary:Objects:Object).

Error Code 0x0015

Meaning:

Invalid mailbox configuration
Description | Current State (or state change) | Resulting State | Solution
Mailbox communication (= acyclic parameter exchange) is done via two memory areas on the EtherCAT Slave Controller (ESC) – the “Output Mailbox” (master -> slave) and the “Input Mailbox” (slave-> master). Those memory areas are protected by SyncManagers to prevent from simultaneous access from master and salve controller at the same time. SyncManagers are hardware entities on the ESC. They are configured via certain registers in the ESC register area (starting at 0x0800). The configuration includes start address, length, and direction (output or input). If those settings differ from those expected by the host controller of the slave this error is returned. | I→B |  | Replace previous network description of old slave with the one of the new slave.

Error Code 0x0016

Meaning:

Invalid mailbox configuration
Description | Current State (or state change) | Resulting State | Solution
Example: The slave hardware was replaced while the network configuration remained unchanged. The new hardware expects different mailbox SyncManager settings. | I→P | I + E | Replace previous network description of old slave with the one of the new slave.

Error Code 0x0017

Meaning:

Invalid Sync Manager configuration
Description | Current State (or state change) | Resulting State | Solution
Process data communication (cyclic communication) is done via extra memory areas on the ESC, separated for outputs and inputs. The process data length and the process data SyncManager length have to be the same. If this is not the case or the start address or direction does not match this error is returned. | P→S, S→O | Current State + E | Issue a re-calculation of the EtherCAT configuration.
Example: The process data configuration was changed of the slaves which also changed the length of the data. The change was not activated in the configuration so that the configuration tool would have recalculated the SyncManager settings.

Error Code 0x0018

Meaning:

No valid inputs available
Description | Current State (or state change) | Resulting State | Solution
The slave application cannot provide valid input values. | O, S→O | S + E |
Example: A certain hardware which needs to be connected to the slave was disconnected.

Error Code 0x0019

Meaning:

No valid outputs available
Description | Current State (or state change) | Resulting State | Solution
The slave application cannot recieve valid output values. | O, S→O | S + E | The RxPdoToggle may need to be handled by the PLC program The outputs valid may have to be set by the PLC program PLC may have stopped, restart PLC
Example: The slave has a RxPdoToggle output or an “Output Valid” information in its process data. The RxPdoToggle does not toggle or the OutputValid is not true. Therefore the slave has no process data which the application can use. If supported, check the RxPDO Toggle Failed Counter in object 0x1C3x.0E). Also, the Synchronization may have problems (see object 0x10F1:SI2 Sync Error Counter Limit) so that process data are received too late by the slave so that the local slave cycle misses the toggle event. Another reason can be that the PLC stopped working.

Error Code 0x001A

Meaning:

Synchronization error
Description | Current State (or state change) | Resulting State | Solution
If too many RxPDO Toggle error occure, i.e. the RxPDO Toggle Failed Counter increases the internal limit the slave returns to SAFEPERROR with 0x001A. Multiple synchronization errors. Device is not synchronized any more (used if the causes mirrored by the AL Status Codes 0x2C, 0x2D, 0x32, 0x33, 0x34 cannot be distinguished). | O, S→O | S + E |

Error Code 0x001B

Meaning:

Sync manager watchdog
Description | Current State (or state change) | Resulting State | Solution
The slave did not receive process data within the specified watchdog time. Usually, the WD time is 100ms. The WD is re-started every time it receives new process data, usually when the Output SyncManager (SyncManager2) is written. For devices which have only inputs usually no WD is used. Increasing the WD is not a solution. Reason: PLC stopped | O, S | S + E |

Error Code 0x001C

Meaning:

Invalid Sync Manager Types
Description | Current State (or state change) | Resulting State | Solution
 | O, S, O, P→S | S + E |

Error Code 0x001D

Meaning:

Invalid Output Configuration
Description | Current State (or state change) | Resulting State | Solution
SM configuration for output process data is invalid. | O, S, O, P→S | S + E |

Error Code 0x001E

Meaning:

Invalid Input Configuration
Description | Current State (or state change) | Resulting State | Solution
SM configuration for input process data is invalid | O, S, O, P→S | S + E |

Error Code 0x001F

Meaning:

Invalid Watchdog Configuration
Description | Current State (or state change) | Resulting State | Solution
The Watchdog is configured in the ESC register 0x0400 and 0x0420. EtherCAT defines default watchdog settings (100ms) or they are defined in the ESI file. If the slave does not accept a change of the expected settings it returns this AL Status Code Example: A slave may not accept that the WD is deactivated. | O, S, O, P→S | P + E | Use default WD settings.

Error Code 0x0020

Meaning:

Slave needs cold start
Description | Current State (or state change) | Resulting State | Solution
Slave device require a power off - power on reset | Any | Current State + E |

Error Code 0x0021

Meaning:

Slave needs INIT
Description | Current State (or state change) | Resulting State | Solution
Slave application requests INIT state | B, P, S, O | Current State + E |

Error Code 0x0022

Meaning:

Slave needs PREOP
Description | Current State (or state change) | Resulting State | Solution
Slave application requests PREOP state | S, O | S + E, O + E |

Error Code 0x0023

Meaning:

Slave needs SAFEOP
Description | Current State (or state change) | Resulting State | Solution
Slave application requests SAFEOP state | O | O + E |

Error Code 0x0024

Meaning:

Invalid Input Mapping
Description Current State (or state change) Resulting State Solution
The process data are described by the configuration (PdoConfig) and PDO assignment (PdoAssign).

PdoConfig: list of actual variables (usually indexes 0x6nnn for inputs and 0x7nnn for outputs). Variables are also called PDO entries. There can be one or several variables with in one list (i.e. within one PDO). The Input PDOs have the index 0x1Amm. The Output PDOs have the index 0x16mm.

PdoAssign: The list of PDOs (object index 0x16nn, 0x1Amm) which are actually part of the process data and hence, are transferred cyclically, are listed in the PDO Assign Objects 0x1C12 (output PDOs) and 0x1C13 (input PDOs). All this can be seen in the SystemManager on the TAB “Process Data”. If the mapping which was set by the user on the Process Data tab and which was expected by the slave do not match this Status Code is returned.

P→S

P + E

Error Code 0x0025

Meaning:

Invalid Output Mapping
Description | Current State (or state change) | Resulting State | Solution
The process data are described by the configuration (PdoConfig) and PDO assignment (PdoAssign). PdoConfig: list of actual variables (usually indexes 0x6nnn for inputs and 0x7nnn for outputs). Variables are also called PDO entries. There can be one or several variables with in one list (i.e. within one PDO). The Input PDOs have the index 0x1Amm. The Output PDOs have the index 0x16mm. Example: Slave does only support one or certain PDO combinations but a different setting was made by the user. For a bus coupler the connected terminals differ from the configured terminals in the SystemManager. | P→S | P + E |

Error Code 0x0026

Meaning:

Inconsistent Settings
Description | Current State (or state change) | Resulting State | Solution
General settings mismatch | P→S | P + E |

Error Code 0x0027

Meaning:

Freerun not supported
Description | Current State (or state change) | Resulting State | Solution
 | P→S | P + E |

Error Code 0x0028

Meaning:

Synchronization not supported
Description | Current State (or state change) | Resulting State | Solution
 | P→S | P + E |

Error Code 0x0029

Meaning:

Freerun needs 3 Buffer Mode
Description | Current State (or state change) | Resulting State | Solution
FreeRun mode, SM has to run in 3-buffer mode | P→S | P + E |

Error Code 0x002A

Meaning:

Background Watchdog
Description | Current State (or state change) | Resulting State | Solution
 | S, O | P + E |

Error Code 0x002B

Meaning:

No Valid Inputs and Outputs
Description | Current State (or state change) | Resulting State | Solution
 | O, S→O | S + E |

Error Code 0x002C

Meaning:

Fatal Sync Error
Description | Current State (or state change) | Resulting State | Solution
The hardware interrupt signal (so called Sync signal) generated by the ESC is not generated any more. The master sets and activated the cycle time of the Sync signal during state transition from PREOP to SAFEOP. If a slave was disconnected and reconnected (also due to lost frames or CRC errors) the generation of the SyncSignal may be lost. | O | S + E | Set master to INIT and back to OP so that the DCs are initialized again.

Error Code 0x002D

Meaning:

ana

Description | Current State (or state change) | Resulting State | Solution
SyncSignal not received: In SAFEOP the slave waits for the first Sync0/Sync1 events before switching to OP, if these events were not received during the SAFEOP to OP-Timeout time the slave refuses the state transition to OP. |  |  |

Error Code 0x0030

Meaning:

Invalid DC SYNC Configuration
Description | Current State (or state change) | Resulting State | Solution
Distributed Clock Configuration is invalid due to application requirements. | O, S→O, P→S | P + E, S + E |

Error Code 0x0031

Meaning:

Invalid DC Latch Configuration
Description | Current State (or state change) | Resulting State | Solution
DC Latch configuration is invalid due to application requirements. | O, S→O, P→S | P + E, S + E |

Error Code 0x0032

Meaning:

PLL Error
Description | Current State (or state change) | Resulting State | Solution
Master not synchronized, at least one DC event recieved. | O, S→O | S + E |

Error Code 0x0033

Meaning:

DC Sync IO Error
Description | Current State (or state change) | Resulting State | Solution
Multiple Synchronization Errors: At least one SycnSignal was received before. However, the PLL between slave and master is not synchronized any more. This may occur if the master application jitters too much. | O, S→O | S + E | Use specific industrial pc, standard office PCs may have power saving options, graphic accelerateds and other system services which disturb the real-time of the master CPU power may be too small for the PLC/NC program Increas EtherCAT and PLC/NC cycle time Use SyncUnits for the slaves using DCs

Error Code 0x0034

Meaning:

DC Sync Timeout Error
Description | Current State (or state change) | Resulting State | Solution
Multiple Synchronization Errors, too much SM events missed | O, S→O | S + E |

Error Code 0x0035

Meaning:

DC Invalid Sync Cycle Time
Description | Current State (or state change) | Resulting State | Solution
 | P→S | P + E |

Error Code 0x0036

Meaning:

DC Sync0 Cycle Time
Description | Current State (or state change) | Resulting State | Solution
DC Sync0 cycle time does not fit to the application requirements | P→S | P + E |

Error Code 0x0037

Meaning:

DC Sync1 Cycle Time
Description | Current State (or state change) | Resulting State | Solution
DC Sync1 cycle time does not fit to the application requirements | P→S | P + E |

Error Code 0x0041

Meaning:

MBX_AOE
Description | Current State (or state change) | Resulting State | Solution
 | B, P, S, O | Current State + E |

Error Code 0x0042

Meaning:

MBX_EOE
Description | Current State (or state change) | Resulting State | Solution
 | B, P, S, O | Current State + E |

Error Code 0x0043

Meaning:

MBX_COE
Description | Current State (or state change) | Resulting State | Solution
 | B, P, S, O | Current State + E |

Error Code 0x0044

Meaning:

MBX_FOE
Description | Current State (or state change) | Resulting State | Solution
 | B, P, S, O | Current State + E |

Error Code 0x0045

Meaning:

MBX_SOE
Description | Current State (or state change) | Resulting State | Solution
 | B, P, S, O | Current State + E |

Error Code 0x004F

Meaning:

MBX_VOE
Description | Current State (or state change) | Resulting State | Solution
 | B, P, S, O | Current State + E |

Error Code 0x0050

Meaning:

EEPROM No Access
Description | Current State (or state change) | Resulting State | Solution
EEPROM not assigned to PDI | Any | Any + E |

Error Code 0x0051

Meaning:

EEPROM Error
Description | Current State (or state change) | Resulting State | Solution
EEPROM access error | Any | Any + E |

Error Code 0x0060

Meaning:

Slave Requested Locally
Description | Current State (or state change) | Resulting State | Solution
 | Any | I |

Error Code 0x0061

Meaning:

Device Identification Value updated
Description | Current State (or state change) | Resulting State | Solution
 | P | P + E |

Error Code 0x00F0

Meaning:

Application Controller available
Description | Current State (or state change) | Resulting State | Solution
 | I |  |


UL Requirements

BECKHOFF EKxxxx, ELxxxx: Appendix

UL notice

Application
Beckhoff EtherCAT modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
For devices with Ethernet connectors
Not for connection to telecommunication circuits.

Basic principles

Two UL certificates are met in the Beckhoff EtherCAT product range, depending upon the components:

  • UL certification according to UL508
    Devices with this kind of certification are marked by this sign:

  • UL certification according to UL508 with limited power consumption
    The current consumed by the device is limited to a max. possible current consumption of 4 A. Devices with this kind of certification are marked by this sign:

Almost all current EtherCAT products (as at 2010/05) are UL certified without restrictions.

Application

If terminals certified with restrictions are used, then the current consumption at 24 V DC must be limited accordingly by means of supply

  • from an isolated source protected by a fuse of max. 4A (according to UL248) or
  • from a voltage supply complying with NEC class 2.
    A voltage source complying with NEC class 2 may not be connected in series or parallel with another NEC class 2 compliant voltage supply!

These requirements apply to the supply of all EtherCAT bus couplers, power adaptor terminals, Bus Terminals and their power contacts.


Fieldbus Components - ATEX Documentation

BECKHOFF Fieldbus Components: Mounting and wiring

ATEX Documentation

Note 		Notes about operation of the Bus Terminal System in potentially explosive areas (ATEX)
Pay also attention to the continuative documentation

Notes about operation of the Bus Terminal System in potentially explosive areas (ATEX)

that is available in the download area of the Beckhoff homepage http:\\www.beckhoff.com!


Firmware compatibility

Beckhoff EtherCAT devices will be equipped with the last available firmware on delivery. There are certain dependencies between firmware and hardware, not all combinations are compatible.
The overview below shows which firmware is compatible to a certain hardware status.

Notice

  • It is strictly recommended to apply the last available firmware on the particular hardware
  • There is no customer right to get a firmware update at no charge for already delivered products by the Beckhoff company.

Attention 		Damage of devices possible!
Please note the details concerning the firmware update on the special page.
If you run a device in BOOTSTRAP mode to initiate a firmware update, it it possible that there is no checking of compatibility of the firmware.
A damage of the device is possible!
Please always make sure, that the firmware is suitable for the hardware status of the device!
EL2521
Hardware (HW) | Firmware | Revision No. | Date of release
02 | 03 | EL2521-0000-0016 | 2008/08
02 - 05 | 04 |  | 2008/09
 | 05 |  | 2008/09
05 - 12 | 06 | EL2521-0000-0018 | 2009/01
 | 07 | EL2521-0000-0019 | 2011/01
 | 08 |  | 2011/04
 | 09 |  | 2011/04
 | 10 |  | 2012/04
13* | 10 |  | 2012/04
 |  | EL2521-0000-0020 | 2012/05
 |  | EL2521-0000-0021 | 2012/07
 | 11* |  | 2014/05
EL2521-0024
Hardware (HW) | Firmware | Revision No. | Date of release
05 - 13* | 06 | EL2521-0024-0016/17 | 2009/01
 | 07 | EL2521-0024-0018 | 2011/01
 | 08 |  | 2011/04
 | 09 |  | 2011/04
 | 10 |  | 2012/04
 |  | EL2521-0024-0019 | 2012/05
 |  | EL2521-0024-0020 | 2012/07
 | 11* |  | 2014/05
 |  | EL2521-0024-0020 | 2014/11
EL2521-0124
Hardware (HW) | Firmware | Revision No. | Date of release
05 - 06 | 01 | EL2521-0124-0016 | 2009/09
 | 02 |  | 2010/03
 | 03 | EL2521-0124-0017 | 2010/06
06 -12* | 04 | EL2521-0124-0018 | 2011/01
 | 05 |  | 2011/04
 |  | EL2521-0124-0019 | 2011/05
 |  | EL2521-0124-0020 | 2011/07
 | 06* |  | 2014/06
EL2521-0025
Hardware (HW) | Firmware | Revision No. | Date of release
00 - 06* | 06 | EL2521-1025-0016/17 | 2009/12
 | 07 | EL2521-1025-0018 | 2011/01
 | 08 |  | 2011/04
 | 09 |  | 2011/04
 | 10 |  | 2012/04
 |  | EL2521-1025-0019 | 2012/05
 |  | EL2521-1025-0020 | 2012/07
 | 11* |  | 2014/05
 |  | EL2521-1025-0021 | 2014/11
EL2521-1001
Hardware (HW) | Firmware | Revision No. | Date of release
02 | 03 | EL2521-1001-1016 | 2008/08
02 - 05 | 04 |  | 2008/09
 | 05 |  | 2008/09
05 - 12* | 06 | EL2521-1001-1017 | 2009/01
 | 07 | EL2521-1001-1018 | 2011/01
 | 08 |  | 2011/04
 | 09 |  | 2011/04
 | 10 |  | 2012/04
 |  | EL2521-1001-1019 | 2012/05
 |  | EL2521-1001-1020 | 2012/07
 | 11* |  | 2014/05

*) At the time of creation of this documentation this is the current compatible hardware status. Please check the Beckhoff website for the latest documentation.


EtherCAT - Firmware

BECKHOFF EtherCAT: Device Update

Firmware EL/ES/EM/EPxxxx

This section describes the device update for Beckhoff EtherCAT slaves from the EL/ES, EM, EK and EP series. A firmware update should only be carried out after consultation with Beckhoff support.

Table of contents
• Storage locations
• Device description ESI file/XML
• Frimware version definition
• Updating Controller firmware *.efw
• FPGA firmware update *.rbf
• Multiple update

Storage locations

An EtherCAT slave stores operating data in up to 3 locations:

  • Depending on functionality and performance EtherCAT slaves have one or several local controllers for processing I/O data. The corresponding program is the so-called firmware in *.efw format.
  • In some EtherCAT slaves the EtherCAT communication may also be integrated in these controllers. In this case the controller is usually a so-called FPGA chip with *.rbf firmware.
  • In addition each EtherCAT slave has a memory chip for storing its own device description, a so-called EEPROM. On power-up this description is loaded and the EtherCAT communication is set up accordingly. The device description is available from the download area of the Beckhoff website at http://www.beckhoff.com . All ESI files (EtherCAT Slave Information) are available in ZIP format.

Customers can access the data via the EtherCAT fieldbus and its communication mechanisms. Acyclic mailbox communication or register access to the ESC is used for updating or reading of these data.

The TwinCAT System Manager offers mechanisms for programming all 3 parts with new data, if the slave is set up for this purpose. Generally the slave does not check whether the new data are suitable, i.e. it may no longer be able to operate if the data are unsuitable.

Attention 		Risk of damage to the device!
Note the following when downloading new device files
  • Firmware downloads to an EtherCAT device must not be interrupted
  • Flawless EtherCAT communication must be ensured. CRC errors or Lost Frames must be avoided.
  • The power supply must adequately dimensioned. The signal level must meet the specification.

In the event of malfunctions during the update process the EtherCAT device may become unusable and require re-commissioning by the manufacturer.

Device description ESI file/XML

Attention 		Notice regarding update of the ESI description/EEPROM
Some slaves have stored calibration and configuration data from the production in the EEPROM. These are irretrievably overwritten during an update.

The ESI device description is stored locally on the slave and loaded on start-up. Each device description has a unique identifier consisting of slave name (9 characters/digits) and a revision number (4 digits). Each slave configured in the System Manager shows its identifier in the EtherCAT tab:

Fig. 1: Device identifier consisting of name EL3204-0000 and revision -0016

The configured identifier must be compatible with the actual device description used as hardware, i.e. the description which the slave has loaded on start-up (in this case EL3204). Generally the configured revision must be equal or lower than the version used in the terminal network.

For further information please refer to the EtherCAT System Documentation.

Note 		Update of XML/ESI description
The device revision is closely linked to the firmware and hardware used. Incompatible combinations lead to malfunctions or even final shutdown of the device.
Corresponding updates should only be carried out in consultation with Beckhoff support.

Display of ESI slave identifier

The simplest way to ascertain compliance of configured and actual device description is to scan the EtherCAT boxes in TwinCAT mode Config/Freerun:

Fig. 2: Scan the subordinate field by right-clicking on the EtherCAT device in Config/FreeRun mode

If the found field matches the configured field, the display shows

Fig. 3: Configuration is identical

otherwise a change dialog for entering the actual data in the configuration.

Fig. 4: Change dialog

In the example shown in Fig. 4. an EL3201-0000-0017 was found, while an EL3201-0000-0016 had been configured. In this case it makes sense to adapt the configuration with the Copy Before button. The Extended Information checkbox must be set in order to have the revision displayed.

Changing the ESI slave identifier

The ESI/EEPROM identifier can be updated as follows under TwinCAT:

  • The EtherCAT communication with the slave must be flawless.
  • The state of the slave is irrelevant.
  • Right-click on the slave in the online display to bring up the EEPROM Update dialog, Fig. 5

Fig. 5: EEPROM Update

Select the new ESI description in the following dialog, see Fig. 6. The ShowHiddenDevices checkbox also shows older, usually hidden slave versions.

Fig. 6: Selecting the new ESI

A progress bar in the System Manager shows the progress. Data are first written, then verified.

Note 		The change only takes effect after a restart.
Most EtherCAT devices read a modified ESI description immediately or after startup from the INIT. Some communication settings such as distributed clocks are only read during power-on.
The EtherCAT slave therefore has to be switched off briefly in order for the change to take effect.

Determining the firmware version

Determining the version on laser inscription

Beckhoff EtherCAT slaves feature serial numbers applied by laser. The serial number has the following structure: KK YY FF HH

KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version

Example with ser. no.: 12 10 03 02:

12 - week of production 12
10 - year of production 2010
03 - firmware version 03
02 - hardware version 02

Determining the version via the System Manager

The TwinCAT System Manager shows the version of the controller firmware if the master can access the slave online. Click on the E-Bus Terminal whose controller firmware you want to check (in the example terminal 2 (EL3204)) and select the tab CoE Online (CAN over EtherCAT).

Note 		CoE Online and Offline CoE
Two CoE directories are available:
  • online: This is offered in the EtherCAT slave by the controller, if the EtherCAT slave does supported it.
    This CoE directory can only be displayed if a slave is connected and operational.
  • offline: The EtherCAT Slave Information ESI/XML may contain the default content of the CoE.
    This CoE directory can only be displayed if it is included in the ESI (e.g. "Beckhoff EL5xxx.xml").

The Advanced button must be used for switching between the two views.

In Fig. 7 the firmware version of the selected EL3204 is shown as 03 in CoE entry x100A.

Fig. 7: Display of EL3204 firmware version

In (A) TwinCAT 2.11 shows that the Online CoE directory is currently displayed. If this is not the case, the Online directory can be loaded via the Online option in Advanced Settings (B) and double-clicking on AllObjects.

Updating controller firmware *.efw

Note 		CoE directory
The Online CoE directory is managed by the controller and stored in a dedicated EEPROM, which is generally not changed during a firmware update.

To update the controller firmware of a slave switch to tab Online, see Fig. 8.

Fig. 8: Firmware Update

Proceed as follows, unless instructed otherwise by Beckhoff support.

  • Switch slave to INIT (A)
  • Switch slave to BOOTSTRAP
  • Check the current status (B, C)
  • Download the new *efw file
  • After the download switch to INIT, then OP
  • Switch off the slave briefly

FPGA firmware *.rbf

If an FPGA chip deals with the EtherCAT communication an update may be accomplished via an *.rbf file.

  • Controller firmware for processing I/O signals
  • FPGA firmware for EtherCAT communication (only for terminals with FPGA)

The firmware version number included in the terminal serial number contains both firmware components. If one of these firmware components is modified this version number is updated.

Determining the version via the System Manager

The TwinCAT System Manager indicates the FPGA firmware version. Click on the Ethernet card of your EtherCAT strand (Device 2 in the example) and select the Online tab.

The Reg:0002 column indicates the firmware version of the individual EtherCAT devices in hexadecimal and decimal representation.

Fig. 9: FPGA firmware version definition

If the column Reg:0002 is not displayed, right-click the table header and select Properties... in the context menu.

Fig. 10: Context menu Properties

The Advanced Settings dialog appears where the columns to be displayed can be selected. Under Diagnosis/Online View select the '0002 ETxxxx Build' check box in order to activate the FPGA firmware version display.

Fig. 11: Dialog Advanced Settings

Update

For updating the FPGA firmware

  • of an EtherCAT coupler the coupler must have FPGA firmware version 11 or higher;
  • of an E-Bus Terminal the terminal must have FPGA firmware version 10 or higher.

Older firmware versions can only be updated by the manufacturer!

Updating an EtherCAT device

In the TwinCAT System Manager select the terminal whose FPGA firmware you want to update (in this example terminal 5: EL5001) and
click on Advanced Settings in the EtherCAT tab.

Fig. 12: Select dialog Advanced Settings

The Advanced Settings dialog appears. Under ESC Access/E²PROM/FPGA click on Write FPGA button,

Fig. 13: Select dialog Write FPGA

select the file (*.rbf) with the new FPGA firmware, and transfer it to the EtherCAT device.

Attention 		Risk of damage to the device!
A firmware download to an EtherCAT device must never be interrupted!

If this process is cancelled, the supply voltage switched off or the Ethernet connection interrupted, the EtherCAT device can only be recommissioned by the manufacturer!

In order to activate the new FPGA firmware a restart (switching the power supply off and on again) of the EtherCAT device is required.

Simultaneous updating of several EtherCAT devices

The firmware and ESI descriptions of several devices can be updated simultaneously, provided the devices have the same firmware file/ESI.

Fig. 14: Multiple selection and firmware update

Select the required slaves and carry out the firmware update in BOOTSTRAP mode as described above.


ELxxxx - restoring the delivery state

BECKHOFF ELxxxx: Configuration

Restoring the delivery state

To restore the delivery state for backup objects in ELxxxx terminals, the CoE object "Restore default parameters", SubIndex 001 can be selected in the TwinCAT System Manager (Config mode) (see Fig. 1)

Fig. 1 Selecting the "Restore default parameters" PDO

Double-click on SubIndex 001 to enter the Set Value dialog. Enter the value 1684107116 in field "Dec" or the value 0x64616F6C in field "Hex" and confirm with OK (Fig. 2).
All backup objects are reset to the delivery state.

Fig. 2 Entering a restore value in the Set Value dialog

Note 		Alternative restore value

In some older terminals the backup objects can be switched with an alternative restore value:

Decimal value: "1819238756"

Hexadecimal value: "0x6C6F6164"

An incorrect entry for the restore value has no effect.


Support and Service

Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.

Beckhoff's branch offices and representatives

Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!

The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com

You will also find further documentation for Beckhoff components there.

Beckhoff Headquarters

Beckhoff Automation GmbH & Co. KG

Huelshorstweg 20
33415 Verl
Germany

Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support

Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:

  • support
  • design, programming and commissioning of complex automation systems
  • and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service

The Beckhoff Service Center supports you in all matters of after-sales service:

  • on-site service
  • repair service
  • spare parts service
  • hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com