EL125x, EL2258 - 8 Channel Digital Input/Output Terminals
Home


Product overview - 8 channel Digital Input/Output Terminals

Product overview - 8 channel Digital Input/Output Terminals
Product overview - 8 channel Digital Input/Output Terminals
EL1258
8 channel digital input terminal 24 VDC, with Timestamp
EL1259
2 x 8 channel digital input/output terminal 24 VDC, with Timestamp
EL2258
8 channel digital output terminal 24 VDC, with Timestamp


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status
•
Version identification of EtherCAT devices


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
2.7
▪
Addenda chapter "Sensitivity of the inputs"
▪
Update revision status
2.6
▪
Update chapter "Technical data"
▪
Update structure
▪
Update revision status
2.5
▪
Example program for EL1258 (MT Visualization) added to chapter “Commissioning”
2.4
▪
Update chapter "Commissioning", Example program for EL2258 (Multi‑Timestamp)
2.3
▪
Update chapter "Notes on the documentation"
▪
Update chapter "Technical data"
▪
Addenda chapter "Instructions for ESD protection"
▪
Addenda chapter "TwinCAT Quickstart"
▪
Addenda chapter "UL notice"
▪
Update revision status
2.2
▪
Update chapter "Technical data"
▪
Update structure
▪
Update revision status
2.1
▪
Example program for EL2258 (Multi-Timestamp) added to chapter “Commissioning”
2.0
▪
Migration
▪
Update structure
▪
Update revision status
1.4
▪
Update chapter "Distributed Clocks settings"
▪
Update structure
▪
Update revision status
1.3
▪
Update chapter "Distributed Clocks settings"
▪
Update structure
▪
Update revision status
1.2
▪
Update chapter "Technical data"
▪
Addenda chapter "Installation instructions for enhanced mechanical load capacity"
▪
Update structure
▪
Update revision status
1.1
▪
Addenda chapter "Commissioning outputs"
▪
Update revision status
1.0
▪
Addenda
▪
First public issue
0.5
▪
Addenda object directory
0.4
▪
Correction chapter "Technical data"
0.3
▪
Correction chapter "Technical data"
0.2
▪
Correction chapter "Commissioning"
0.1
▪
Provisional documentation for EL125x, EL2258


Version identification of EtherCAT devices

Foreword [image] Version identification of EtherCAT devices
Version identification of EtherCAT devices
Designation
A Beckhoff EtherCAT device has a 14-digit designation, made up of
▪
family key
▪
type
▪
version
▪
revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
Notes
▪
The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
▪
EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
▪
The order identifier is made up of
- family key (EL, EP, CU, ES, KL, CX, etc.)
- type (3314)
- version (-0000)
▪
The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
▪
The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Identification number
Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:
Production lot/batch number/serial number/date code/D number
The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02
Exceptions can occur in the IP67 area, where the following syntax can be used (see respective device documentation):
Syntax: D ww yy x y z u
D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB
Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1
Unique serial number/ID, ID number
In addition, in some series each individual module has its own unique serial number.
See also the further documentation in the area
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Terminals with factory calibration certificate and other measuring terminals
Examples of markings
EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
CU2016 switch with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
EP1258-00001 IP67 EtherCAT Box with batch number/ date code 22090101 and unique serial number 158102
EP1908-0002 IP67 EtherCAT Safety Box with batch number/ date code 071201FF and unique serial number 00346070
EL2904 IP20 safety terminal with batch number/ date code 50110302 and unique serial number 00331701
ELM3604-0002 terminal with unique ID number (QR code) 100001051 and serial/ batch number 44160201
Additional information
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Foreword [image] Version identification of EtherCAT devices [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Product overview

Product overview
Product overview
Additional information
•
EL1258, EL1259, EL2258
•
Start


EL1258, EL1259, EL2258

Product overview [image] EL1258, EL1259, EL2258
EL1258, EL1259, EL2258
Additional information
•
Introduction
•
Technical data
•
Technology


Introduction

Product overview [image] EL1258, EL1259, EL2258 [image] Introduction
Introduction
EL1258
EL1259
EL2258
Digital input/output terminals with timestamp
The 8-channel digital input terminal EL1258 records fast binary control signals from the process level and transfers them electrically isolated to the controller. In contrast to the EL1252 with two channels the EL1258 has eight channels and a lower sampling rate. In addition, the EL1258 offers the option of logging several changes of the input signal per PLC cycle and to transfer these to the controller (MultiTimeStamping). The EL1258 is synchronized with other EtherCAT devices through the distributed clocks system, so that events in the whole system can be measured with a uniform timebase.
The 8-channel digital output terminal EL2258 switches the binary output signals of the controller electrically isolated from the process level. Up to 10 switching orders per PLC cycle can be transferred to the terminal. These are output with an accuracy of up to 10 µs (depending on the selected process image). The distributed clocks are used as time reference. In conjunction with timestamp input terminals the EL2258 enables responses at equidistant intervals that are largely independent of the bus cycle time.
The 16-channel digital EtherCAT Terminal EL1259 combines the function of the EL1258 – eight timestamp inputs – with those of the EL2258 – eight timestamp outputs. The high channel density in conjunction with time stamping of the signals enables fast, efficient processes through optimized sensor and actuator control. The EL1259 is also synchronized with other devices through the distributed clocks system, so that events in the whole system can be measured with a uniform timebase.
Quick-Links


Technical data

Product overview [image] EL1258, EL1259, EL2258 [image] Technical data
Technical data
Technical data | EL1258 | EL1259 | EL2258
Digital inputs | 8 | 8 | -
Digital outputs | - | 8 | 8
Connection technology | 2-wire | 1-wire | 2-wire
Rated voltage | 24 VDC (-15%/+20%)
Signal voltage “0” | -3 V ... +5 V (based on EN 61131-2, type 3) |  | -
Signal voltage “1” | +11 V ... +30 V (based on EN 61131-2, type 3) |  | -
Input current | typ. 3 mA (based on EN 61131-2, type 3) |  | -
Input filter | < 1 µs typ. |  | -
Distributed Clocks | Yes
Distributed clock (DC) precision | << 1 µs
Internal sampling rate/execution | <10 ... <40 µs, depends on PDO configuration (“Microcycle”, see notes)
Minimum EtherCAT cycle time | 90..540 µs, depends on PDO configuration (“Macrocycle”, see notes)
Load type outputs | - | ohmic, inductive, lamp load
Output current | - | max. 0.5 A (short-circuit-proof) per channel
Output stage | - | Push *)
Reverse polarity protection | - | yes
Breaking energy | - | < 150 mJ/channel
Switching times outputs | - | TON: < 1 µs typ., TOFF: < 1 µs typ. *)
Current consumption of power contacts | typ. 6 mA | typ. 30 mA + load
Supply voltage for electronic | via the E-bus
Current consumption via E-bus | typ. 130 mA
Electrical isolation | 500 V (E-bus/field voltage)
Configuration | no address or configuration settings required
Weight | approx. 55 g
Permissible ambient temperature range during operation | 0°C ... +55°C
Permissible ambient temperature range during storage | -25°C ... +85°C
Permissible relative humidity | 95%, no condensation
Dimensions (W x H x D) | approx. 15 mm x 100 mm x 70 mm (width aligned: 12 mm)
Mounting | on 35 mm mounting rail conforms to EN 60715
Vibration/shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27, see also installation instructions for enhanced mechanical load capacity
EMC immunity/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation position | variable
Approval | CE cULus
*) In order to achieve the fastest possible Toff time (negative edge, switch-off), the output must be operated with a load resistor, ideally with a rated load of 0.5 A corresponding to 48 Ohm. The corresponding thermal load capacity of the resistor must be taken into account.


Technology

Product overview [image] EL1258, EL1259, EL2258 [image] Technology
Technology
Table of contents
• Procedure for sampling digital inputs
• Procedure for sampling digital outputs
• Multi-timestamp
The EL1258, EL1259 and EL2258 EtherCAT terminals make up a family of terminals whose members feature a similar range of functions. These are digital input and output terminals that read in or output 24 V signals. The EL1258 can read in eight channels, while the EL2258 can output eight channels. The EL1259 is the mixed version with 8 input and 8 output channels on an overall width of 12 mm. A characteristic feature of these terminals is the multi-timestamp capability, as an extension to the conventional timestamp function.
It is often of great interest when inputs are read in or outputs are switched in a running application. Three general procedures for considering inputs and outputs are described below:
Procedure for sampling digital inputs
▪
Standard sampling
Standard sampling is used for “normal” digital input/output terminals. For the input this means that a 24 V signal (TRUE) or 0 V signal (FALSE) is applied by a sensor (e.g. light barrier). This channel information is queried in the next EtherCAT cycle and transferred to the controller.
In addition it means that this signal was applied to the input within the last cycle time and is still present at the time of sampling. However, no statement can be made as to the precise point in time when this edge arrived at the input, or whether short pulses were already present before that.
Query of input channel information, standard
▪
In Fig. Query of input channel information, standard pulses A and B are not picked up, only pulse C lasts long enough to be present during sampling (blue), so that the "1" is picked up by the bus cycle. This mode of operation is also called frame-triggered.
The time frame for the sampling is thus the task/EtherCAT cycle time employed of e.g. 10 ms or 1 ms. To sample processes in the machine at finer intervals, the cycle time usually has to be reduced to the required or smallest possible value, e.g. 100 µs. However, this entails limitations with regard to the then maximum available computing time and possibly also the EtherCAT data volume within this cycle time.
Two technologies are available to remedy this situation: Oversampling and timestamp.
In principle, the EtherCAT Terminals EL1258, EL1259 and EL2258 can be used for standard sampling.
▪
Oversampling
Within the specified (configurable) cycle time the input terminals read the input status n times and store the states in an array, which is transferred to the controller based on the bus cycle. The correspondingly finer time frame, the microcycle, thus enables a slow bus cycle time with nevertheless extremely fine sampling.
For example, the input terminal EL1262 is capable of 1000-fold oversampling at a 1 µs microcycle.
Query of input channel information, oversampling
▪
In Fig. Query of input channel information, oversampling pulses A and B are also picked up, compared with standard sampling. Over the known microcycle time each individual pulse can be determined from the resulting data stream. However, a constantly high volume of data is transferred with each EtherCAT cycle, even if there are no edge changes at all at the input.
▪
Timestamp
In this mode the input terminal operates only event-based. The edge changes are registered at the input channel. Internally two pieces of information are stored for each event, i.e. the input state 0/1 after the edge change and the exact time of edge change, the timestamp. The time is derived from the synchronized EtherCAT distributed clocks system, which synchronizes all capable EtherCAT devices in the network to a time accuracy of << 1 µs without special configuration (for further information see Basic EtherCAT documentation).
Query of input channel information, with timestamp
▪
In Fig. Query of input channel information, with timestamp the rising and the falling edge of pulse A is picked up as event with timestamp and transferred to the controller during the EtherCAT cycle. The time resolution is 1 ns here – an ‘infinitely’ fine time resolution in mechanical terms. The EL1252 can “only” store one falling and one rising edge per cycle – if several edge changes occur, e.g. a rising edge of pulse C, the first or last event is stored, depending on the configuration (see EL1252 documentation).
In summary, the oversampling and timestamp procedures provide a significantly finer image of the machine sequence than standard sampling of the digital input.
Procedure for sampling digital outputs
The principles described above can be transferred to digital outputs accordingly.
▪
Standard sampling
A frame-triggered standard output can only switch with the time of each EtherCAT cycle if it receives a new target output state:
Output of output channel information, standard
▪
In Fig. Output of output channel information, standard the number of switching events is limited to the cycle time and cannot be changed at the actual switching time. For high-speed or high-precision machines this has a significant effect on the maximum possible production speed and manufacturing tolerances. The oversampling and timestamp technologies help here as well.
▪
Oversampling
The controller calculates the array of digital 0/1 output data in advance and sends it to the output channel. This successively clocks out the target output states in the fixed microcycle.
Output of output channel information, oversampling
▪
This procedure enables a significantly finer time resolution to be achieved for the actuator control, even below the actual cycle time.
The digital output terminal EL2262 can achieve a time resolution of 1 µs with 1000-fold oversampling.
▪
Timestamp
With the timestamp principle the controller calculates an exact time at which the output is to switch to a new state 0/1. After this switching order has been transferred, the terminal waits until this time is reached and then switches automatically, independent of the bus cycle. Here too the distributed clocks function is decisive. It synchronizes the local clock that runs in the output terminal.
Output of output channel information, with timestamp
▪
At (A) the controller transfers a switching order consisting of output state and switching time to the output channel; the order is executed at (B) independently of the cycle. The controller can then send a new switching order (C). The ‘infinitely’ fine time resolution of 1 ns applies here as well.
In general the digital output terminal EL2252 with oversampling requires two cycles for activating a switching order.
Multi-timestamp
The multi-timestamp capability opens up new application options for digital inputs and outputs:
Inputs EL1258, EL1259
▪
8 multi-timestamp channels on an overall width of 12 mm
▪
All channels operate completely independently of one another
▪
Each channel is capable of sampling not only one, but up to 32 signal edges (“events”) per cycle
▪
Each channel has its own buffer. Events are held in the buffer, if more signal edge changes arrive at the input during a cycle than are retrieved via the process data. The buffer can be sent continuously to the controller via the cyclic process data. A handshake mode is also possible – thus no signals to the controller are lost in the event of communication errors.
▪
The process data size can be configured individually for each channel, i.e. how many timestamped events per cycle are to be retrieved from the channel by the PLC
▪
These functions require a process image that differs from the previous EL1252. For reasons of compatibility with the existing user software the terminal can be switched to a compatible process image (without the new functions).
▪
Sampling of the input state 0/1 takes place based on a microcycle of several µs, depending on the selected setting, i.e. significantly faster than the EtherCAT bus cycle time
▪
The timestamp allocated to a signal edge detected in this way is the start time of the microcycle in which it was picked up.
▪
An adjustable digital filter can be activated for each channel which blanks signals that are too short (spikes).
▪
In this way significantly more signal changes can be sampled with timestamp during each cycle, and no event information is lost in the buffer.
Query of input channel information, with multi-timestamp
Outputs EL1259, EL2258
▪
8 multi-timestamp channels on an overall width of 12 mm
▪
All channels operate completely independently of one another
▪
Each channel has a buffer and can therefore store not just one switching order, but up to 32 events. Thus several precisely timed switching events can also be specified within a cycle.
▪
In order to transfer switching orders to the channel as quickly as possible, the multi-timestamp function operates with AutoActivation: new switching orders are taken over in each cycle without special activation; however, an optional handshake procedure is also possible here.
▪
The process data size – i.e. the number of time-stamped switching orders that can be sent by the controller to the channel per cycle – is configurable for each channel.
▪
These functions require a process image that differs from the previous EL2252. For reasons of compatibility with existing user software the terminal can be switched to a compatible process image (without the new functions).
▪
The query whether an executable switching order is present in the buffer takes place based on a microcycle of several µs, depending on the selected setting, and is therefore significantly faster than the EtherCAT bus cycle time. Thus several timestamp switching orders are also possible per bus cycle.
▪
In order to test the actuator connected to the output channel, the output can also be switched manually via the CoE, i.e. without timestamps.
▪
Thus virtually any desired number of switching orders can now be output per channel within the framework of the microcycle, both ‘immediately’ for the following cycle (A) and also through the buffer for later cycles (B).
Output of output channel information, with multi-timestamp


Start

Product overview [image] Start
Start
For commissioning:
▪
mount the EL125x, EL2258 as described in the chapter Mounting and wiring
▪
configure the EL125x, EL2258 in TwinCAT as described in the chapter Commissioning.


Basics communication

Basics communication
Basics communication
Additional information
•
EtherCAT basics
•
EtherCAT cabling – wire-bound
•
General notes for setting the watchdog
•
EtherCAT State Machine
•
CoE Interface
•
Distributed Clock


EtherCAT basics

Basics communication [image] EtherCAT basics
EtherCAT basics
Please refer to the EtherCAT System Documentation for the EtherCAT fieldbus basics.


EtherCAT cabling – wire-bound

Basics communication [image] EtherCAT cabling – wire-bound
EtherCAT cabling – wire-bound
The cable length between two EtherCAT devices must not exceed 100 m. This results from the FastEthernet technology, which, above all for reasons of signal attenuation over the length of the cable, allows a maximum link length of 5 + 90 + 5 m if cables with appropriate properties are used. See also the Design recommendations for the infrastructure for EtherCAT/Ethernet.
Cables and connectors
For connecting EtherCAT devices only Ethernet connections (cables + plugs) that meet the requirements of at least category 5 (CAt5) according to EN 50173 or ISO/IEC 11801 should be used. EtherCAT uses 4 wires for signal transfer.
EtherCAT uses RJ45 plug connectors, for example. The pin assignment is compatible with the Ethernet standard (ISO/IEC 8802-3).
Pin | Color of conductor | Signal | Description
1 | yellow | TD + | Transmission Data +
2 | orange | TD - | Transmission Data -
3 | white | RD + | Receiver Data +
6 | blue | RD - | Receiver Data -
Due to automatic cable detection (auto-crossing) symmetric (1:1) or cross-over cables can be used between EtherCAT devices from Beckhoff.
Recommended cables
Suitable cables for the connection of EtherCAT devices can be found on the Beckhoff website!
E-Bus supply
A bus coupler can supply the EL terminals added to it with the E-bus system voltage of 5 V; a coupler is thereby loadable up to 2 A as a rule (see details in respective device documentation).
Information on how much current each EL terminal requires from the E-bus supply is available online and in the catalogue. If the added terminals require more current than the coupler can supply, then power feed terminals (e.g. EL9410) must be inserted at appropriate places in the terminal strand.
The pre-calculated theoretical maximum E-Bus current is displayed in the TwinCAT System Manager. A shortfall is marked by a negative total amount and an exclamation mark; a power feed terminal is to be placed before such a position.
System manager current calculation
Note
Malfunction possible!
The same ground potential must be used for the E-Bus supply of all EtherCAT terminals in a terminal block!


General notes for setting the watchdog

Basics communication [image] General notes for setting the watchdog
General notes for setting the watchdog
ELxxxx terminals are equipped with a safety feature (watchdog) that switches off the outputs after a specifiable time e.g. in the event of an interruption of the process data traffic, depending on the device and settings, e.g. in OFF state.
The EtherCAT slave controller (ESC) in the EL2xxx terminals features two watchdogs:
▪
SM watchdog (default: 100 ms)
▪
PDI watchdog (default: 100 ms)
SM watchdog (SyncManager Watchdog)
The SyncManager watchdog is reset after each successful EtherCAT process data communication with the terminal. If no EtherCAT process data communication takes place with the terminal for longer than the set and activated SM watchdog time, e.g. in the event of a line interruption, the watchdog is triggered and the outputs are set to FALSE. The OP state of the terminal is unaffected. The watchdog is only reset after a successful EtherCAT process data access. Set the monitoring time as described below.
The SyncManager watchdog monitors correct and timely process data communication with the ESC from the EtherCAT side.
PDI watchdog (Process Data Watchdog)
If no PDI communication with the EtherCAT slave controller (ESC) takes place for longer than the set and activated PDI watchdog time, this watchdog is triggered.
PDI (Process Data Interface) is the internal interface between the ESC and local processors in the EtherCAT slave, for example. The PDI watchdog can be used to monitor this communication for failure.
The PDI watchdog monitors correct and timely process data communication with the ESC from the application side.
The settings of the SM- and PDI-watchdog must be done for each slave separately in the TwinCAT System Manager.
EtherCAT tab -> Advanced Settings -> Behavior -> Watchdog
Notes:
▪
the multiplier is valid for both watchdogs.
▪
each watchdog has its own timer setting, the outcome of this in summary with the multiplier is a resulting time.
▪
Important: the multiplier/timer setting is only loaded into the slave at the start up, if the checkbox is activated.
If the checkbox is not activated, nothing is downloaded and the ESC settings remain unchanged.
Multiplier
Multiplier
Both watchdogs receive their pulses from the local terminal cycle, divided by the watchdog multiplier:
1/25 MHz * (watchdog multiplier + 2) = 100 µs (for default setting of 2498 for the multiplier)
The standard setting of 1000 for the SM watchdog corresponds to a release time of 100 ms.
The value in multiplier + 2 corresponds to the number of basic 40 ns ticks representing a watchdog tick.
The multiplier can be modified in order to adjust the watchdog time over a larger range.
Example “Set SM watchdog”
This checkbox enables manual setting of the watchdog times. If the outputs are set and the EtherCAT communication is interrupted, the SM watchdog is triggered after the set time and the outputs are erased. This setting can be used for adapting a terminal to a slower EtherCAT master or long cycle times. The default SM watchdog setting is 100 ms. The setting range is 0...65535. Together with a multiplier with a range of 1...65535 this covers a watchdog period between 0...~170 seconds.
Calculation
Multiplier = 2498 → watchdog base time = 1 / 25 MHz * (2498 + 2) = 0.0001 seconds = 100 µs
SM watchdog = 10000 → 10000 * 100 µs = 1 second watchdog monitoring time
SmallWarningYellow CAUTION
Undefined state possible!
The function for switching off of the SM watchdog via SM watchdog = 0 is only implemented in terminals from version -0016. In previous versions this operating mode should not be used.
SmallWarningYellow CAUTION
Damage of devices and undefined state possible!
If the SM watchdog is activated and a value of 0 is entered the watchdog switches off completely. This is the deactivation of the watchdog! Set outputs are NOT set in a safe state, if the communication is interrupted.


EtherCAT State Machine

Basics communication [image] EtherCAT State Machine
EtherCAT State Machine
The state of the EtherCAT slave is controlled via the EtherCAT State Machine (ESM). Depending upon the state, different functions are accessible or executable in the EtherCAT slave. Specific commands must be sent by the EtherCAT master to the device in each state, particularly during the bootup of the slave.
A distinction is made between the following states:
▪
Init
▪
Pre-Operational
▪
Safe-Operational and
▪
Operational
▪
Boot
The regular state of each EtherCAT slave after bootup is the OP state.
States of the EtherCAT State Machine
Init
After switch-on the EtherCAT slave in the Init state. No mailbox or process data communication is possible. The EtherCAT master initializes sync manager channels 0 and 1 for mailbox communication.
Pre-Operational (Pre-Op)
During the transition between Init and Pre-Op the EtherCAT slave checks whether the mailbox was initialized correctly.
In Pre-Op state mailbox communication is possible, but not process data communication. The EtherCAT master initializes the sync manager channels for process data (from sync manager channel 2), the FMMU channels and, if the slave supports configurable mapping, PDO mapping or the sync manager PDO assignment. In this state the settings for the process data transfer and perhaps terminal-specific parameters that may differ from the default settings are also transferred.
Safe-Operational (Safe-Op)
During transition between Pre-Op and Safe-Op the EtherCAT slave checks whether the sync manager channels for process data communication and, if required, the distributed clocks settings are correct. Before it acknowledges the change of state, the EtherCAT slave copies current input data into the associated DP-RAM areas of the EtherCAT slave controller (ECSC).
In Safe-Op state mailbox and process data communication is possible, although the slave keeps its outputs in a safe state, while the input data are updated cyclically.
Outputs in SAFEOP state
The default set watchdog monitoring sets the outputs of the module in a safe state - depending on the settings in SAFEOP and OP - e.g. in OFF state. If this is prevented by deactivation of the watchdog monitoring in the module, the outputs can be switched or set also in the SAFEOP state.
Operational (Op)
Before the EtherCAT master switches the EtherCAT slave from Safe-Op to Op it must transfer valid output data.
In the Op state the slave copies the output data of the masters to its outputs. Process data and mailbox communication is possible.
Boot
In the Boot state the slave firmware can be updated. The Boot state can only be reached via the Init state.
In the Boot state mailbox communication via the file access over EtherCAT (FoE) protocol is possible, but no other mailbox communication and no process data communication.


CoE Interface

Basics communication [image] CoE Interface
CoE Interface
General description
The CoE interface (CAN application protocol over EtherCAT)) is used for parameter management of EtherCAT devices. EtherCAT slaves or the EtherCAT master manage fixed (read only) or variable parameters which they require for operation, diagnostics or commissioning.
CoE parameters are arranged in a table hierarchy. In principle, the user has read access via the fieldbus. The EtherCAT master (TwinCAT System Manager) can access the local CoE lists of the slaves via EtherCAT in read or write mode, depending on the attributes.
Different CoE parameter types are possible, including string (text), integer numbers, Boolean values or larger byte fields. They can be used to describe a wide range of features. Examples of such parameters include manufacturer ID, serial number, process data settings, device name, calibration values for analog measurement or passwords.
The order is specified in two levels via hexadecimal numbering: (main)index, followed by subindex. The value ranges are
▪
Index: 0x0000 …0xFFFF (0...65535dez)
▪
SubIndex: 0x00…0xFF (0...255dez)
A parameter localized in this way is normally written as 0x8010:07, with preceding “0x” to identify the hexadecimal numerical range and a colon between index and subindex.
The relevant ranges for EtherCAT fieldbus users are:
▪
0x1000: This is where fixed identity information for the device is stored, including name, manufacturer, serial number etc., plus information about the current and available process data configurations.
▪
0x8000: This is where the operational and functional parameters for all channels are stored, such as filter settings or output frequency.
Other important ranges are:
▪
0x4000: here are the channel parameters for some EtherCAT devices. Historically, this was the first parameter area before the 0x8000 area was introduced. EtherCAT devices that were previously equipped with parameters in 0x4000 and changed to 0x8000 support both ranges for compatibility reasons and mirror internally.
▪
0x6000: Input PDOs (“input” from the perspective of the EtherCAT master)
▪
0x7000: Output PDOs (“output” from the perspective of the EtherCAT master)
Availability
Not every EtherCAT device must have a CoE list. Simple I/O modules without dedicated processor usually have no variable parameters and therefore no CoE list.
If a device has a CoE list, it is shown in the TwinCAT System Manager as a separate tab with a listing of the elements:
“CoE Online” tab
The figure above shows the CoE objects available in device “EL2502”, ranging from 0x1000 to 0x1600. The subindices for 0x1018 are expanded.
Data management and function “NoCoeStorage”
Some parameters, particularly the setting parameters of the slave, are configurable and writeable. This can be done in write or read mode
▪
via the System Manager (Fig. “CoE Online” tab) by clicking
This is useful for commissioning of the system/slaves. Click on the row of the index to be parameterized and enter a value in the “SetValue” dialog.
▪
from the control system/PLC via ADS, e.g. through blocks from the TcEtherCAT.lib library
This is recommended for modifications while the system is running or if no System Manager or operating staff are available.
Data management
If slave CoE parameters are modified online, Beckhoff devices store any changes in a fail-safe manner in the EEPROM, i.e. the modified CoE parameters are still available after a restart.
The situation may be different with other manufacturers.

An EEPROM is subject to a limited lifetime with respect to write operations. From typically 100,000 write operations onwards it can no longer be guaranteed that new (changed) data are reliably saved or are still readable. This is irrelevant for normal commissioning. However, if CoE parameters are continuously changed via ADS at machine runtime, it is quite possible for the lifetime limit to be reached. Support for the NoCoeStorage function, which suppresses the saving of changed CoE values, depends on the firmware version.
Please refer to the technical data in this documentation as to whether this applies to the respective device.
•
If the function is supported: the function is activated by entering the code word 0x12345678 once in CoE 0xF008 and remains active as long as the code word is not changed. After switching the device on it is then inactive. Changed CoE values are not saved in the EEPROM and can thus be changed any number of times.
•
Function is not supported: continuous changing of CoE values is not permissible in view of the lifetime limit.
Startup list
Changes in the local CoE list of the terminal are lost if the terminal is replaced. If a terminal is replaced with a new Beckhoff terminal, it will have the default settings. It is therefore advisable to link all changes in the CoE list of an EtherCAT slave with the Startup list of the slave, which is processed whenever the EtherCAT fieldbus is started. In this way a replacement EtherCAT slave can automatically be parameterized with the specifications of the user.
If EtherCAT slaves are used which are unable to store local CoE values permanently, the Startup list must be used.
Recommended approach for manual modification of CoE parameters
▪
Make the required change in the System Manager
The values are stored locally in the EtherCAT slave
▪
If the value is to be stored permanently, enter it in the Startup list.
The order of the Startup entries is usually irrelevant.
Startup list in the TwinCAT System Manager
The Startup list may already contain values that were configured by the System Manager based on the ESI specifications. Additional application-specific entries can be created.
Online/offline list
While working with the TwinCAT System Manager, a distinction has to be made whether the EtherCAT device is “available”, i.e. switched on and linked via EtherCAT and therefore online, or whether a configuration is created offline without connected slaves.
In both cases a CoE list as shown in Fig. “CoE online tab” is displayed. The connectivity is shown as offline/online.
▪
If the slave is offline
–
The offline list from the ESI file is displayed. In this case modifications are not meaningful or possible.
–
The configured status is shown under Identity.
–
No firmware or hardware version is displayed, since these are features of the physical device.
–
Offline is shown in red.
Offline list
▪
If the slave is online
–
The actual current slave list is read. This may take several seconds, depending on the size and cycle time.
–
The actual identity is displayed
–
The firmware and hardware version of the equipment according to the electronic information is displayed
–
Online is shown in green.
Online list
Channel-based order
The CoE list is available in EtherCAT devices that usually feature several functionally equivalent channels. For example, a 4-channel analog 0...10 V input terminal also has four logical channels and therefore four identical sets of parameter data for the channels. In order to avoid having to list each channel in the documentation, the placeholder “n” tends to be used for the individual channel numbers.
In the CoE system 16 indices, each with 255 subindices, are generally sufficient for representing all channel parameters. The channel-based order is therefore arranged in 16dec/10hex steps. The parameter range 0x8000 exemplifies this:
▪
Channel 0: parameter range 0x8000:00 ... 0x800F:255
▪
Channel 1: parameter range 0x8010:00 ... 0x801F:255
▪
Channel 2: parameter range 0x8020:00 ... 0x802F:255
▪
...
This is generally written as 0x80n0.
Detailed information on the CoE interface can be found in the EtherCAT system documentation on the Beckhoff website.


Distributed Clock

Basics communication [image] Distributed Clock
Distributed Clock
The distributed clock represents a local clock in the EtherCAT slave controller (ESC) with the following characteristics:
▪
Unit 1 ns
▪
Zero point 1.1.2000 00:00
▪
Size 64 bit (sufficient for the next 584 years; however, some EtherCAT slaves only offer 32-bit support, i.e. the variable overflows after approx. 4.2 seconds)
▪
The EtherCAT master automatically synchronizes the local clock with the master clock in the EtherCAT bus with a precision of < 100 ns.
For detailed information please refer to the EtherCAT system description.


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Instructions for ESD protection
•
Installation on mounting rails
•
Installation instructions for enhanced mechanical load capacity
•
Connection
•
Installation positions
•
Positioning of passive Terminals
•
UL notice
•
EL1258, EL1259, EL2258 - LEDs and connection


Instructions for ESD protection

Mounting and wiring [image] Instructions for ESD protection
Instructions for ESD protection
Note
Destruction of the devices by electrostatic discharge possible!
The devices contain components at risk from electrostatic discharge caused by improper handling.
•
Please ensure you are electrostatically discharged and avoid touching the contacts of the device directly.
•
Avoid contact with highly insulating materials (synthetic fibers, plastic film etc.).
•
Surroundings (working place, packaging and personnel) should by grounded probably, when handling with the devices.
•
Each assembly must be terminated at the right hand end with an EL9011 or EL9012 bus end cap, to ensure the protection class and ESD protection.
Spring contacts of the Beckhoff I/O components


Installation on mounting rails

Mounting and wiring [image] Installation on mounting rails
Installation on mounting rails
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Assembly
Attaching on mounting rail
The bus coupler and bus terminals are attached to commercially available 35 mm mounting rails (DIN rails according to EN 60715) by applying slight pressure:
1.
First attach the fieldbus coupler to the mounting rail.
2.
The bus terminals are now attached on the right-hand side of the fieldbus coupler. Join the components with tongue and groove and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
If the terminals are clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.
Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail. At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail. To mount the mounting rails with a height of 7.5 mm under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).
Disassembly
Disassembling of terminal
Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
1.
Pull the terminal by its orange-colored lugs approximately 1 cm away from the mounting rail. In doing so for this terminal the mounting rail lock is released automatically and you can pull the terminal out of the bus terminal block easily without excessive force.
2.
Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal out of the bus terminal block.
Connections within a bus terminal block
The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:
▪
The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
▪
The power contacts deal with the supply for the field electronics and thus represent a supply rail within the bus terminal block. The power contacts are supplied via terminals on the Bus Coupler (up to 24 V) or for higher voltages via power feed terminals.
Power Contacts
During the design of a bus terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts. Power Feed Terminals (KL91xx, KL92xx or EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.
PE power contact
The power contact labeled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Power contact on left side
Note
Possible damage of the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a nominal voltage of 230 V). For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.
SmallWarningYellow WARNING
Risk of electric shock!
The PE power contact must not be used for other potentials!


Installation instructions for enhanced mechanical load capacity

Mounting and wiring [image] Installation instructions for enhanced mechanical load capacity
Installation instructions for enhanced mechanical load capacity
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminal system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals!
Additional checks
The terminals have undergone the following additional tests:
Verification | Explanation
Vibration | 10 frequency runs in 3 axes
 | 6 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 25 g, 6 ms
Additional installation instructions
For terminals with enhanced mechanical load capacity, the following additional installation instructions apply:
▪
The enhanced mechanical load capacity is valid for all permissible installation positions
▪
Use a mounting rail according to EN 60715 TH35-15
▪
Fix the terminal segment on both sides of the mounting rail with a mechanical fixture, e.g. an earth terminal or reinforced end clamp
▪
The maximum total extension of the terminal segment (without coupler) is:
64 terminals (12 mm mounting with) or 32 terminals (24 mm mounting with)
▪
Avoid deformation, twisting, crushing and bending of the mounting rail during edging and installation of the rail
▪
The mounting points of the mounting rail must be set at 5 cm intervals
▪
Use countersunk head screws to fasten the mounting rail
▪
The free length between the strain relief and the wire connection should be kept as short as possible. A distance of approx. 10 cm should be maintained to the cable duct.


Connection

Mounting and wiring [image] Connection
Connection
Additional information
•
Connection system
•
Wiring
•
Shielding


Connection system

Mounting and wiring [image] Connection [image] Connection system
Connection system
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Overview
The Bus Terminal system offers different connection options for optimum adaptation to the respective application:
▪
The terminals of ELxxxx and KLxxxx series with standard wiring include electronics and connection level in a single enclosure.
▪
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level and enable steady wiring while replacing.
▪
The High Density Terminals (HD Terminals) include electronics and connection level in a single enclosure and have advanced packaging density.
Standard wiring (ELxxxx / KLxxxx)
Standard wiring
The terminals of ELxxxx and KLxxxx series have been tried and tested for years.
They feature integrated screwless spring force technology for fast and simple assembly.
Pluggable wiring (ESxxxx / KSxxxx)
Pluggable wiring
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level.
The assembly and wiring procedure is the same as for the ELxxxx and KLxxxx series.
The pluggable connection level enables the complete wiring to be removed as a plug connector from the top of the housing for servicing.
The lower section can be removed from the terminal block by pulling the unlocking tab.
Insert the new component and plug in the connector with the wiring. This reduces the installation time and eliminates the risk of wires being mixed up.
The familiar dimensions of the terminal only had to be changed slightly. The new connector adds about 3 mm. The maximum height of the terminal remains unchanged.
A tab for strain relief of the cable simplifies assembly in many applications and prevents tangling of individual connection wires when the connector is removed.
Conductor cross sections between 0.08 mm2 and 2.5 mm2 can continue to be used with the proven spring force technology.
The overview and nomenclature of the product names for ESxxxx and KSxxxx series has been retained as known from ELxxxx and KLxxxx series.
High Density Terminals (HD Terminals)
High Density Terminals
The Bus Terminals from these series with 16 terminal points are distinguished by a particularly compact design, as the packaging density is twice as large as that of the standard 12 mm Bus Terminals. Massive conductors and conductors with a wire end sleeve can be inserted directly into the spring loaded terminal point without tools.
Wiring HD Terminals
The High Density Terminals of the ELx8xx and KLx8xx series doesn't support pluggable wiring.
Ultrasonically “bonded” (ultrasonically welded) conductors
Ultrasonically “bonded” conductors
It is also possible to connect the Standard and High Density Terminals with ultrasonically “bonded” (ultrasonically welded) conductors. In this case, please note the tables concerning the wire-size width below!


Wiring

Mounting and wiring [image] Connection [image] Wiring
Wiring
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Terminals for standard wiring ELxxxx/KLxxxx and for pluggable wiring ESxxxx/KSxxxx
Connecting a cable on a terminal point
Up to eight terminal points enable the connection of solid or finely stranded cables to the Bus Terminal. The terminal points are implemented in spring force technology. Connect the cables as follows:
1.
Open a terminal point by pushing a screwdriver straight against the stop into the square opening above the terminal point. Do not turn the screwdriver or move it alternately (don't toggle).
2.
The wire can now be inserted into the round terminal opening without any force.
3.
The terminal point closes automatically when the pressure is released, holding the wire securely and permanently.
See the following table for the suitable wire size width.
Terminal housing | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Wire size width (single core wires) | 0.08 ... 2.5 mm2 | 0.08 ... 2.5 mm2
Wire size width (fine-wire conductors) | 0.08 ... 2.5 mm2 | 0,08 ... 2.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 1.5 mm2 | 0.14 ... 1.5 mm2
Wire stripping length | 8 ... 9 mm | 9 ... 10 mm
High Density Terminals (HD Terminals) with 16 terminal points
The conductors of the HD Terminals are connected without tools for single-wire conductors using the direct plug-in technique, i.e. after stripping the wire is simply plugged into the terminal point. The cables are released, as usual, using the contact release with the aid of a screwdriver. See the following table for the suitable wire size width.
Terminal housing | High Density Housing
Wire size width (single core wires) | 0.08 ... 1.5 mm2
Wire size width (fine-wire conductors) | 0.25 ... 1.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 0.75 mm2
Wire size width (ultrasonically “bonded" conductors) | only 1.5 mm2
Wire stripping length | 8 ... 9 mm


Shielding

Mounting and wiring [image] Connection [image] Shielding
Shielding
Shielding
Encoder, analog sensors and actors should always be connected with shielded, twisted paired wires.


Installation positions

Mounting and wiring [image] Installation positions
Installation positions
Note
Constraints regarding installation position and operating temperature range
Please refer to the technical data for a terminal to ascertain whether any restrictions regarding the installation position and/or the operating temperature range have been specified. When installing high power dissipation terminals ensure that an adequate spacing is maintained between other components above and below the terminal in order to guarantee adequate ventilation!
Optimum installation position (standard)
The optimum installation position requires the mounting rail to be installed horizontally and the connection surfaces of the EL/KL terminals to face forward (see Fig. Recommended distances for standard installation position). The terminals are ventilated from below, which enables optimum cooling of the electronics through convection. “From below” is relative to the acceleration of gravity.
Recommended distances for standard installation position
Compliance with the distances shown in Fig. Recommended distances for standard installation position is recommended.
Other installation positions
All other installation positions are characterized by different spatial arrangement of the mounting rail - see Fig “Other installation positions”.
The minimum distances to ambient specified above also apply to these installation positions.
Other installation positions


Positioning of passive Terminals

Mounting and wiring [image] Positioning of passive Terminals
Positioning of passive Terminals
Hint for positioning of passive terminals in the bus terminal block
EtherCAT Terminals (ELxxxx / ESxxxx), which do not take an active part in data transfer within the bus terminal block are so called passive terminals. The passive terminals have no current consumption out of the E-Bus.
To ensure an optimal data transfer, you must not directly string together more than two passive terminals!
Examples for positioning of passive terminals (highlighted)
Correct positioning
Incorrect positioning


UL notice

Mounting and wiring [image] UL notice
UL notice
culus-logo
Application
Beckhoff EtherCAT modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
culus-logo
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
culus-logo
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
Basic principles
UL certification according to UL508. Devices with this kind of certification are marked by this sign:


EL1258, EL1259, EL2258 - LEDs and connection

Mounting and wiring [image] EL1258, EL1259, EL2258 - LEDs and connection
EL1258, EL1259, EL2258 - LEDs and connection
Table of contents
• LEDs and connection EL1258
• LEDs and connection EL1259
• LEDs and connection EL2258
EL1258
EL1258
LED | Color | Meaning
INPUT 1- 8 | green | off | There is no input signal at the respective input
 |  | on | Input signal at the respective input
Connection EL1258
Terminal point |  | Description
Name | No.
Input 1 | 1 | Input 1
Input 2 | 2 | Input 2
Input 3 | 3 | Input 3
Input 4 | 4 | Input 4
Input 5 | 5 | Input 5
Input 6 | 6 | Input 6
Input 7 | 7 | Input 7
Input 8 | 8 | Input 8
+24 V | 9-16 | + 24 V (internal connection of terminal points 9 -16 and positive power contact)
EL1259
EL1259
LED | Color | Meaning
INPUT 1- 8 (Signal LEDs 1 - 8) | green | off | There is no input signal at the respective input
 |  | on | Input signal at the respective input
OUTPUT 1- 8 (Signal LEDs 9 - 16) | green | off | No output signal is present at the respective output
 |  | on | Input signal at the respective input
Connection EL1259
Terminal point |  | Description
Name | No.
Input 1 | 1 | Input 1
Input 2 | 2 | Input 2
Input 3 | 3 | Input 3
Input 4 | 4 | Input 4
Input 5 | 5 | Input 5
Input 6 | 6 | Input 6
Input 7 | 7 | Input 7
Input 8 | 8 | Input 8
Output 1 | 9 | Output 1
Output 2 | 10 | Output 2
Output 3 | 11 | Output 3
Output 4 | 12 | Output 4
Output 5 | 13 | Output 5
Output 6 | 14 | Output 6
Output 7 | 15 | Output 7
Output 8 | 16 | Output 8
EL2258
EL2258
LED | Color | Meaning
OUTPUT 1- 8 | green | off | There is no output signal at the respective input
 |  | on | Output signal at the respective input
Connection EL2258
Terminal point |  | Description
Name | No.
Output 1 | 1 | Output 1
Output 2 | 2 | Output 2
Output 3 | 3 | Output 3
Output 4 | 4 | Output 4
Output 5 | 5 | Output 5
Output 6 | 6 | Output 6
Output 7 | 7 | Output 7
Output 8 | 8 | Output 8
0 V | 9-16 | + 0 V (internal connection of terminal points 9 -16 and negative power contact)


Commissioning

Commissioning
Commissioning
Additional information
•
TwinCAT Quick Start
•
TwinCAT Development Environment
•
General Notes - EtherCAT Slave Application
•
Sensitivity of the input
•
Basic function principles
•
Commissioning inputs
•
Commissioning outputs
•
Distributed Clocks settings
•
CoE object description and parameterization
•
Example programs


TwinCAT Quick Start

Commissioning [image] TwinCAT Quick Start
TwinCAT Quick Start
TwinCAT is a development environment for real-time control including multi-PLC system, NC axis control, programming and operation. The whole system is mapped through this environment and enables access to a programming environment (including compilation) for the controller. Individual digital or analog inputs or outputs can also be read or written directly, in order to verify their functionality, for example.
For further information please refer to http://infosys.beckhoff.com:
▪
EtherCAT Systemmanual:
Fieldbus Components → EtherCAT Terminals → EtherCAT System Documentation → Setup in the TwinCAT System Manager
▪
TwinCAT 2 → TwinCAT System Manager → I/O - Configuration
▪
In particular, TwinCAT driver installation:
Fieldbus components → Fieldbus Cards and Switches → FC900x – PCI Cards for Ethernet → Installation
Devices contain the terminals for the actual configuration. All configuration data can be entered directly via editor functions (offline) or via the “Scan” function (online):
▪
“offline”: The configuration can be customized by adding and positioning individual components. These can be selected from a directory and configured.
–
The procedure for offline mode can be found under http://infosys.beckhoff.com:
TwinCAT 2 → TwinCAT System Manager → IO - Configuration → Adding an I/O Device
▪
“online”: The existing hardware configuration is read
–
See also http://infosys.beckhoff.com:
Fieldbus components → Fieldbus cards and switches → FC900x – PCI Cards for Ethernet → Installation → Searching for devices
The following relationship is envisaged from user PC to the individual control elements:
Relationship between user side (commissioning) and installation
The user inserting of certain components (I/O device, terminal, box...) is the same in TwinCAT 2 and TwinCAT 3. The descriptions below relate to the online procedure.
Sample configuration (actual configuration)
Based on the following sample configuration, the subsequent subsections describe the procedure for TwinCAT 2 and TwinCAT 3:
▪
Control system (PLC) CX2040 including CX2100-0004 power supply unit
▪
Connected to the CX2040 on the right (E-bus):
EL1004 (4-channel digital input terminal 24 VDC)
▪
Linked via the X001 port (RJ-45): EK1100 EtherCAT Coupler
▪
Connected to the EK1100 EtherCAT coupler on the right (E-bus):
EL2008 (8-channel digital output terminal 24 VDC; 0.5 A)
▪
(Optional via X000: a link to an external PC for the user interface)
Control configuration with Embedded PC, input (EL1004) and output (EL2008)
Note that all combinations of a configuration are possible; for example, the EL1004 terminal could also be connected after the coupler, or the EL2008 terminal could additionally be connected to the CX2040 on the right, in which case the EK1100 coupler wouldn’t be necessary.
Additional information
•
TwinCAT 2
•
TwinCAT 3


TwinCAT 2

Commissioning [image] TwinCAT Quick Start [image] TwinCAT 2
TwinCAT 2
Startup
TwinCAT basically uses two user interfaces: the TwinCAT System Manager for communication with the electromechanical components and TwinCAT PLC Control for the development and compilation of a controller. The starting point is the TwinCAT System Manager.
After successful installation of the TwinCAT system on the PC to be used for development, the TwinCAT 2 System Manager displays the following user interface after startup:
Initial TwinCAT 2 user interface
Generally, TwinCAT can be used in local or remote mode. Once the TwinCAT system including the user interface (standard) is installed on the respective PLC, TwinCAT can be used in local mode and thereby the next step is “Insert Device”.
If the intention is to address the TwinCAT runtime environment installed on a PLC as development environment remotely from another system, the target system must be made known first. In the menu under “Actions” → “Choose Target System...”, via the symbol “ [image] ” or the “F8” key, open the following window:
Selection of the target system
Use “Search (Ethernet)...” to enter the target system. Thus a next dialog opens to either:
▪
enter the known computer name after “Enter Host Name / IP:” (as shown in red)
▪
perform a “Broadcast Search” (if the exact computer name is not known)
▪
enter the known computer IP or AmsNetID.
Specify the PLC for access by the TwinCAT System Manager: selection of the target system
Once the target system has been entered, it is available for selection as follows (a password may have to be entered):
After confirmation with “OK” the target system can be accessed via the System Manager.
Adding devices
In the configuration tree of the TwinCAT 2 System Manager user interface on the left, select “I/O Devices” and then right-click to open a context menu and select “Scan Devices…”, or start the action in the menu bar via [image]. The TwinCAT System Manager may first have to be set to “Config mode” via [image] or via menu
“Actions” → “Set/Reset TwinCAT to Config Mode…” (Shift + F4).
Select “Scan Devices...”
Confirm the warning message, which follows, and select “EtherCAT” in the dialog:
Automatic detection of I/O devices: selection the devices to be integrated
Confirm the message “Find new boxes”, in order to determine the terminals connected to the devices. “Free Run” enables manipulation of input and output values in “Config mode” and should also be acknowledged.
Based on the sample configuration described at the beginning of this section, the result is as follows:
Mapping of the configuration in the TwinCAT 2 System Manager
The whole process consists of two stages, which may be performed separately (first determine the devices, then determine the connected elements such as boxes, terminals, etc.). A scan can also be initiated by selecting “Device ...” from the context menu, which then reads the elements present in the configuration below:
Reading of individual terminals connected to a device
This functionality is useful if the actual configuration is modified at short notice.
Programming and integrating the PLC
TwinCAT PLC Control is the development environment for the creation of the controller in different program environments: TwinCAT PLC Control supports all languages described in IEC 61131-3. There are two text-based languages and three graphical languages.
▪
Text-based languages
–
Instruction List (IL)
–
Structured Text (ST)
▪
Graphical languages
–
Function Block Diagram (FBD)
–
Ladder Diagram (LD)
–
The Continuous Function Chart Editor (CFC)
–
Sequential Function Chart (SFC)
The following section refers to Structured Text (ST).
After starting TwinCAT PLC Control, the following user interface is shown for an initial project:
TwinCAT PLC Control after startup
Sample variables and a sample program have been created and stored under the name “PLC_example.pro”:
Sample program with variables after a compile process (without variable integration)
Warning 1990 (missing “VAR_CONFIG”) after a compile process indicates that the variables defined as external (with the ID “AT%I*” or “AT%Q*”) have not been assigned. After successful compilation, TwinCAT PLC Control creates a “*.tpy” file in the directory in which the project was stored. This file (“*.tpy”) contains variable assignments and is not known to the System Manager, hence the warning. Once the System Manager has been notified, the warning no longer appears.
First, integrate the TwinCAT PLC Control project in the System Manager via the context menu of the PLC configuration; right-click and select “Append PLC Project…”:
Appending the TwinCAT PLC Control project
Select the PLC configuration “PLC_example.tpy” in the browser window that opens. The project including the two variables identified with “AT” are then integrated in the configuration tree of the System Manager:
PLC project integrated in the PLC configuration of the System Manager
The two variables “bEL1004_Ch4” and “nEL2008_value” can now be assigned to certain process objects of the I/O configuration.
Assigning variables
Open a window for selecting a suitable process object (PDO) via the context menu of a variable of the integrated project “PLC_example” and via “Modify Link...” “Standard”:
Creating the links between PLC variables and process objects
In the window that opens, the process object for the variable “bEL1004_Ch4” of type BOOL can be selected from the PLC configuration tree:
Selecting PDO of type BOOL
According to the default setting, certain PDO objects are now available for selection. In this sample the input of channel 4 of the EL1004 terminal is selected for linking. In contrast, the checkbox “All types” must be ticked for creating the link for the output variables, in order to allocate a set of eight separate output bits to a byte variable. The following diagram shows the whole process:
Selecting several PDOs simultaneously: activate “Continuous” and “All types”
Note that the “Continuous” checkbox was also activated. This is designed to allocate the bits contained in the byte of the variable “nEL2008_value” sequentially to all eight selected output bits of the EL2008 terminal. In this way it is possible to subsequently address all eight outputs of the terminal in the program with a byte corresponding to bit 0 for channel 1 to bit 7 for channel 8 of the PLC. A special symbol ( [image]) at the yellow or red object of the variable indicates that a link exists. The links can also be checked by selecting a “Goto Link Variable” from the context menu of a variable. The object opposite, in this case the PDO, is automatically selected:
Application of a “Goto Link” variable, using “MAIN.bEL1004_Ch4” as a sample
The process of assigning variables to the PDO is completed via the menu selection “Actions” → “Generate Mappings”, key Ctrl+M or by clicking on the symbol [image] in the menu.
This can be visualized in the configuration:
The process of creating links can also take place in the opposite direction, i.e. starting with individual PDOs to variable. However, in this example it would then not be possible to select all output bits for the EL2008, since the terminal only makes individual digital outputs available. If a terminal has a byte, word, integer or similar PDO, it is possible to allocate this a set of bit-standardized variables (type “BOOL”). Here, too, a “Goto Link Variable” from the context menu of a PDO can be executed in the other direction, so that the respective PLC instance can then be selected.
Activation of the configuration
The allocation of PDO to PLC variables has now established the connection from the controller to the inputs and outputs of the terminals. The configuration can now be activated. First, the configuration can be verified via [image] (or via “Actions” → “Check Configuration”). If no error is present, the configuration can be activated via [image] (or via “Actions” → “Activate Configuration…”) to transfer the System Manager settings to the runtime system. Confirm the messages “Old configurations are overwritten!” and “Restart TwinCAT system in Run mode” with “OK”.
A few seconds later the real-time status [image] is displayed at the bottom right in the System Manager. The PLC system can then be started as described below.
Starting the controller
Starting from a remote system, the PLC control has to be linked with the Embedded PC over Ethernet via “Online” → “Choose Run-Time System…”:
Choose target system (remote)
In this sample “Runtime system 1 (port 801)” is selected and confirmed. Link the PLC with the real-time system via menu option “Online” → “Login”, the F11 key or by clicking on the symbol [image]. The control program can then be loaded for execution. This results in the message “No program on the controller! Should the new program be loaded?”, which should be acknowledged with “Yes”. The runtime environment is ready for the program start:
PLC Control logged in, ready for program startup
The PLC can now be started via “Online” → “Run”, F5 key or [image].


TwinCAT 3

Commissioning [image] TwinCAT Quick Start [image] TwinCAT 3
TwinCAT 3
Startup
TwinCAT makes the development environment areas available together with Microsoft Visual Studio: after startup, the project folder explorer appears on the left in the general window area (cf. “TwinCAT System Manager” of TwinCAT 2) for communication with the electromechanical components.
After successful installation of the TwinCAT system on the PC to be used for development, TwinCAT 3 (shell) displays the following user interface after startup:
Initial TwinCAT 3 user interface
First create a new project via [image] (or under “File”→“New”→ “Project…”). In the following dialog make the corresponding entries as required (as shown in the diagram):
Create new TwinCAT project
The new project is then available in the project folder explorer:
New TwinCAT3 project in the project folder explorer
Generally, TwinCAT can be used in local or remote mode. Once the TwinCAT system including the user interface (standard) is installed on the respective PLC, TwinCAT can be used in local mode and thereby the next step is “Insert Device”.
If the intention is to address the TwinCAT runtime environment installed on a PLC as development environment remotely from another system, the target system must be made known first. Via the symbol in the menu bar:
expand the pull-down menu:
and open the following window:
Selection dialog: Choose the target system
Use “Search (Ethernet)...” to enter the target system. Thus a next dialog opens to either:
▪
enter the known computer name after “Enter Host Name / IP:” (as shown in red)
▪
perform a “Broadcast Search” (if the exact computer name is not known)
▪
enter the known computer IP or AmsNetID.
Specify the PLC for access by the TwinCAT System Manager: selection of the target system
Once the target system has been entered, it is available for selection as follows (a password may have to be entered):
After confirmation with “OK” the target system can be accessed via the Visual Studio shell.
Adding devices
In the project folder explorer of the Visual Studio shell user interface on the left, select “Devices” within element “I/O”, then right-click to open a context menu and select “Scan” or start the action via [image] in the menu bar. The TwinCAT System Manager may first have to be set to “Config mode” via [image] or via the menu “TwinCAT” → “Restart TwinCAT (Config mode)”.
Select “Scan”
Confirm the warning message, which follows, and select “EtherCAT” in the dialog:
Automatic detection of I/O devices: selection the devices to be integrated
Confirm the message “Find new boxes”, in order to determine the terminals connected to the devices. “Free Run” enables manipulation of input and output values in “Config mode” and should also be acknowledged.
Based on the sample configuration described at the beginning of this section, the result is as follows:
Mapping of the configuration in VS shell of the TwinCAT3 environment
The whole process consists of two stages, which may be performed separately (first determine the devices, then determine the connected elements such as boxes, terminals, etc.). A scan can also be initiated by selecting “Device ...” from the context menu, which then reads the elements present in the configuration below:
Reading of individual terminals connected to a device
This functionality is useful if the actual configuration is modified at short notice.
Programming the PLC
TwinCAT PLC Control is the development environment for the creation of the controller in different program environments: TwinCAT PLC Control supports all languages described in IEC 61131-3. There are two text-based languages and three graphical languages.
▪
Text-based languages
–
Instruction List (IL)
–
Structured Text (ST)
▪
Graphical languages
–
Function Block Diagram (FBD)
–
Ladder Diagram (LD)
–
The Continuous Function Chart Editor (CFC)
–
Sequential Function Chart (SFC)
The following section refers to Structured Text (ST).
In order to create a programming environment, a PLC subproject is added to the project sample via the context menu of “PLC” in the project folder explorer by selecting “Add New Item….”:
Adding the programming environment in “PLC”
In the dialog that opens select “Standard PLC project” and enter “PLC_example” as project name, for example, and select a corresponding directory:
Specifying the name and directory for the PLC programming environment
The “Main” program, which already exists by selecting “Standard PLC project”, can be opened by double-clicking on “PLC_example_project” in “POUs”. The following user interface is shown for an initial project:
Initial “Main” program of the standard PLC project
To continue, sample variables and a sample program have now been created:
Sample program with variables after a compile process (without variable integration)
The control program is now created as a project folder, followed by the compile process:
Start program compilation
The following variables, identified in the ST/ PLC program with “AT%”, are then available in under “Assignments” in the project folder explorer:
Assigning variables
Via the menu of an instance - variables in the “PLC” context, use the “Modify Link…” option to open a window for selecting a suitable process object (PDO) for linking:
Creating the links between PLC variables and process objects
In the window that opens, the process object for the variable “bEL1004_Ch4” of type BOOL can be selected from the PLC configuration tree:
Selecting PDO of type BOOL
According to the default setting, certain PDO objects are now available for selection. In this sample the input of channel 4 of the EL1004 terminal is selected for linking. In contrast, the checkbox “All types” must be ticked for creating the link for the output variables, in order to allocate a set of eight separate output bits to a byte variable. The following diagram shows the whole process:
Selecting several PDOs simultaneously: activate “Continuous” and “All types”
Note that the “Continuous” checkbox was also activated. This is designed to allocate the bits contained in the byte of the variable “nEL2008_value” sequentially to all eight selected output bits of the EL2008 terminal. In this way it is possible to subsequently address all eight outputs of the terminal in the program with a byte corresponding to bit 0 for channel 1 to bit 7 for channel 8 of the PLC. A special symbol ( [image]) at the yellow or red object of the variable indicates that a link exists. The links can also be checked by selecting a “Goto Link Variable” from the context menu of a variable. The object opposite, in this case the PDO, is automatically selected:
Application of a “Goto Link” variable, using “MAIN.bEL1004_Ch4” as a sample
The process of creating links can also take place in the opposite direction, i.e. starting with individual PDOs to variable. However, in this example it would then not be possible to select all output bits for the EL2008, since the terminal only makes individual digital outputs available. If a terminal has a byte, word, integer or similar PDO, it is possible to allocate this a set of bit-standardized variables (type “BOOL”). Here, too, a “Goto Link Variable” from the context menu of a PDO can be executed in the other direction, so that the respective PLC instance can then be selected.
Note on the type of variable assignment
The following type of variable assignment can only be used from TwinCAT version V3.1.4024.4 onwards and is only available for terminals with a microcontroller.
In TwinCAT it is possible to create a structure from the mapped process data of a terminal. An instance of this structure can then be created in the PLC, so it is possible to access the process data directly from the PLC without having to declare own variables.
The procedure for the EL3001 1-channel analog input terminal -10...+10 V is shown as an example.
1.
First the required process data must be selected in the “Process data” tab in TwinCAT.
2.
After that, the PLC data type must be generated in the tab “PLC” via the check box.
3.
The data type in the “Data Type” field can then be copied using the “Copy” button.
Creating a PLC data type
4.
An instance of the data structure of the copied data type must then be created in the PLC.
Instance_of_struct
5.
Then the project folder must be created. This can be done either via the key combination “CTRL + Shift + B” or via the “Build” tab in TwinCAT.
6.
The structure in the “PLC” tab of the terminal must then be linked to the created instance.
Linking the structure
7.
In the PLC the process data can then be read or written via the structure in the program code.
Reading a variable from the structure of the process data
Activation of the configuration
The allocation of PDO to PLC variables has now established the connection from the controller to the inputs and outputs of the terminals. The configuration can now be activated with [image] or via the menu under “TwinCAT” in order to transfer settings of the development environment to the runtime system. Confirm the messages “Old configurations are overwritten!” and “Restart TwinCAT system in Run mode” with “OK”. The corresponding assignments can be seen in the project folder explorer:
A few seconds later the corresponding status of the Run mode is displayed in the form of a rotating symbol [image] at the bottom right of the VS shell development environment. The PLC system can then be started as described below.
Starting the controller
Select the menu option “PLC” → “Login” or click on [image] to link the PLC with the real-time system and load the control program for execution. This results in the message No program on the controller! Should the new program be loaded?, which should be acknowledged with “Yes”. The runtime environment is ready for program start by click on symbol [image], the “F5” key or via “PLC” in the menu selecting “Start”. The started programming environment shows the runtime values of individual variables:
TwinCAT development environment (VS shell): logged-in, after program startup
The two operator control elements for stopping [image] and logout [image] result in the required action (accordingly also for stop “Shift + F5”, or both actions can be selected via the PLC menu).


TwinCAT Development Environment

Commissioning [image] TwinCAT Development Environment
TwinCAT Development Environment
The Software for automation TwinCAT (The Windows Control and Automation Technology) will be distinguished into:
▪
TwinCAT 2: System Manager (Configuration) & PLC Control (Programming)
▪
TwinCAT 3: Enhancement of TwinCAT 2 (Programming and Configuration takes place via a common Development Environment)
Details:
▪
TwinCAT 2:
–
Connects I/O devices to tasks in a variable-oriented manner
–
Connects tasks to tasks in a variable-oriented manner
–
Supports units at the bit level
–
Supports synchronous or asynchronous relationships
–
Exchange of consistent data areas and process images
–
Datalink on NT - Programs by open Microsoft Standards (OLE, OCX, ActiveX, DCOM+, etc.)
–
Integration of IEC 61131-3-Software-SPS, Software- NC and Software-CNC within Windows NT/2000/XP/Vista, Windows 7, NT/XP Embedded, CE
–
Interconnection to all common fieldbusses
–
More…
Additional features:
▪
TwinCAT 3 (eXtended Automation):
–
Visual-Studio®-Integration
–
Choice of the programming language
–
Supports object orientated extension of IEC 61131-3
–
Usage of C/C++ as programming language for real time applications
–
Connection to MATLAB®/Simulink®
–
Open interface for expandability
–
Flexible run-time environment
–
Active support of Multi-Core- und 64-Bit-Operatingsystem
–
Automatic code generation and project creation with the TwinCAT Automation Interface
–
More…
Within the following sections commissioning of the TwinCAT Development Environment on a PC System for the control and also the basically functions of unique control elements will be explained.
Please see further information to TwinCAT 2 and TwinCAT 3 at http://infosys.beckhoff.com.
Additional information
•
Installation of the TwinCAT real-time driver
•
Notes regarding ESI device description
•
TwinCAT ESI Updater
•
Distinction between Online and Offline
•
OFFLINE configuration creation
•
ONLINE configuration creation
•
EtherCAT subscriber configuration


Installation of the TwinCAT real-time driver

Commissioning [image] TwinCAT Development Environment [image] Installation of the TwinCAT real-time driver
Installation of the TwinCAT real-time driver
In order to assign real-time capability to a standard Ethernet port of an IPC controller, the Beckhoff real-time driver has to be installed on this port under Windows.
This can be done in several ways. One option is described here.
In the System Manager call up the TwinCAT overview of the local network interfaces via Options → Show Real Time Ethernet Compatible Devices.
System Manager “Options” (TwinCAT 2)
This have to be called up by the Menü “TwinCAT” within the TwinCAT 3 environment:
Call up under VS Shell (TwinCAT 3)
The following dialog appears:
Overview of network interfaces
Interfaces listed under “Compatible devices” can be assigned a driver via the “Install” button. A driver should only be installed on compatible devices.
A Windows warning regarding the unsigned driver can be ignored.
Alternatively an EtherCAT-device can be inserted first of all as described in chapter Offline configuration creation, section “Creating the EtherCAT device” in order to view the compatible ethernet ports via its EtherCAT properties (tab “Adapter”, button “Compatible Devices…”):
EtherCAT device properties(TwinCAT 2): click on “Compatible Devices…” of tab “Adapte””
TwinCAT 3: the properties of the EtherCAT device can be opened by double click on “Device .. (EtherCAT)” within the Solution Explorer under “I/O”:
After the installation the driver appears activated in the Windows overview for the network interface (Windows Start → System Properties → Network)
Windows properties of the network interface
A correct setting of the driver could be:
Exemplary correct driver setting for the Ethernet port
Other possible settings have to be avoided:
Incorrect driver settings for the Ethernet port
IP address of the port used
IP address/DHCP
In most cases an Ethernet port that is configured as an EtherCAT device will not transport general IP packets. For this reason and in cases where an EL6601 or similar devices are used it is useful to specify a fixed IP address for this port via the “Internet Protocol TCP/IP” driver setting and to disable DHCP. In this way the delay associated with the DHCP client for the Ethernet port assigning itself a default IP address in the absence of a DHCP server is avoided. A suitable address space is 192.168.x.x, for example.
TCP/IP setting for the Ethernet port


Notes regarding ESI device description

Commissioning [image] TwinCAT Development Environment [image] Notes regarding ESI device description
Notes regarding ESI device description
Installation of the latest ESI device description
The TwinCAT EtherCAT master/System Manager needs the device description files for the devices to be used in order to generate the configuration in online or offline mode. The device descriptions are contained in the so-called ESI files (EtherCAT Slave Information) in XML format. These files can be requested from the respective manufacturer and are made available for download. An *.xml file may contain several device descriptions.
The ESI files for Beckhoff EtherCAT devices are available on the Beckhoff website.
The ESI files should be stored in the TwinCAT installation directory.
Default settings:
▪
TwinCAT 2: C:\TwinCAT\IO\EtherCAT
▪
TwinCAT 3: C:\TwinCAT\3.1\Config\Io\EtherCAT
The files are read (once) when a new System Manager window is opened, if they have changed since the last time the System Manager window was opened.
A TwinCAT installation includes the set of Beckhoff ESI files that was current at the time when the TwinCAT build was created.
For TwinCAT 2.11/TwinCAT 3 and higher, the ESI directory can be updated from the System Manager, if the programming PC is connected to the Internet; by
▪
TwinCAT 2: Option → “Update EtherCAT Device Descriptions”
▪
TwinCAT 3: TwinCAT → EtherCAT Devices → “Update Device Descriptions (via ETG Website)…”
The TwinCAT ESI Updater is available for this purpose.
ESI
The *.xml files are associated with *.xsd files, which describe the structure of the ESI XML files. To update the ESI device descriptions, both file types should therefore be updated.
Device differentiation
EtherCAT devices/slaves are distinguished by four properties, which determine the full device identifier. For example, the device identifier EL2521-0025-1018 consists of:
▪
family key “EL”
▪
name “2521”
▪
type “0025”
▪
and revision “1018”
Identifier structure
The order identifier consisting of name + type (here: EL2521-0010) describes the device function. The revision indicates the technical progress and is managed by Beckhoff. In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation. Each revision has its own ESI description. See further notes.
Online description
If the EtherCAT configuration is created online through scanning of real devices (see section Online setup) and no ESI descriptions are available for a slave (specified by name and revision) that was found, the System Manager asks whether the description stored in the device should be used. In any case, the System Manager needs this information for setting up the cyclic and acyclic communication with the slave correctly.
OnlineDescription information window (TwinCAT 2)
In TwinCAT 3 a similar window appears, which also offers the Web update:
Information window OnlineDescription (TwinCAT 3)
If possible, the Yes is to be rejected and the required ESI is to be requested from the device manufacturer. After installation of the XML/XSD file the configuration process should be repeated.
Note
Changing the “usual” configuration through a scan
✓
If a scan discovers a device that is not yet known to TwinCAT, distinction has to be made between two cases. Taking the example here of the EL2521-0000 in the revision 1019
1.
no ESI is present for the EL2521-0000 device at all, either for the revision 1019 or for an older revision. The ESI must then be requested from the manufacturer (in this case Beckhoff).
2.
an ESI is present for the EL2521-0000 device, but only in an older revision, e.g. 1018 or 1017.
In this case an in-house check should first be performed to determine whether the spare parts stock allows the integration of the increased revision into the configuration at all. A new/higher revision usually also brings along new features. If these are not to be used, work can continue without reservations with the previous revision 1018 in the configuration. This is also stated by the Beckhoff compatibility rule.
Refer in particular to the chapter “General notes on the use of Beckhoff EtherCAT IO components” and for manual configuration to the chapter “Offline configuration creation”.
If the OnlineDescription is used regardless, the System Manager reads a copy of the device description from the EEPROM in the EtherCAT slave. In complex slaves the size of the EEPROM may not be sufficient for the complete ESI, in which case the ESI would be incomplete in the configurator. Therefore it’s recommended using an offline ESI file with priority in such a case.
The System Manager creates for online recorded device descriptions a new file “OnlineDescription0000...xml” in its ESI directory, which contains all ESI descriptions that were read online.
File OnlineDescription.xml created by the System Manager
Is a slave desired to be added manually to the configuration at a later stage, online created slaves are indicated by a prepended symbol “>” in the selection list (see Figure Indication of an online recorded ESI of EL2521 as an example).
Indication of an online recorded ESI of EL2521 as an example
If such ESI files are used and the manufacturer's files become available later, the file OnlineDescription.xml should be deleted as follows:
▪
close all System Manager windows
▪
restart TwinCAT in Config mode
▪
delete “OnlineDescription0000...xml”
▪
restart TwinCAT System Manager
This file should not be visible after this procedure, if necessary press <F5> to update
OnlineDescription for TwinCAT 3.x
In addition to the file described above “OnlineDescription0000...xml”, a so called EtherCAT cache with new discovered devices is created by TwinCAT 3.x, e.g. under Windows 7:

(Please note the language settings of the OS!)
You have to delete this file, too.
Faulty ESI file
If an ESI file is faulty and the System Manager is unable to read it, the System Manager brings up an information window.
Information window for faulty ESI file (left: TwinCAT 2; right: TwinCAT 3)
Reasons may include:
▪
Structure of the *.xml does not correspond to the associated *.xsd file → check your schematics
▪
Contents cannot be translated into a device description → contact the file manufacturer


TwinCAT ESI Updater

Commissioning [image] TwinCAT Development Environment [image] TwinCAT ESI Updater
TwinCAT ESI Updater
For TwinCAT 2.11 and higher, the System Manager can search for current Beckhoff ESI files automatically, if an online connection is available:
Using the ESI Updater (>= TwinCAT 2.11)
The call up takes place under:
“Options” → “Update EtherCAT Device Descriptions”
Selection under TwinCAT 3:
Using the ESI Updater (TwinCAT 3)
The ESI Updater (TwinCAT 3) is a convenient option for automatic downloading of ESI data provided by EtherCAT manufacturers via the Internet into the TwinCAT directory (ESI = EtherCAT slave information). TwinCAT accesses the central ESI ULR directory list stored at ETG; the entries can then be viewed in the Updater dialog, although they cannot be changed there.
The call up takes place under:
“TwinCAT” → “EtherCAT Devices” → “Update Device Description (via ETG Website)…”.


Distinction between Online and Offline

Commissioning [image] TwinCAT Development Environment [image] Distinction between Online and Offline
Distinction between Online and Offline
The distinction between online and offline refers to the presence of the actual I/O environment (drives, terminals, EJ-modules). If the configuration is to be prepared in advance of the system configuration as a programming system, e.g. on a laptop, this is only possible in “Offline configuration” mode. In this case all components have to be entered manually in the configuration, e.g. based on the electrical design.
If the designed control system is already connected to the EtherCAT system and all components are energised and the infrastructure is ready for operation, the TwinCAT configuration can simply be generated through “scanning” from the runtime system. This is referred to as online configuration.
In any case, during each startup the EtherCAT master checks whether the slaves it finds match the configuration. This test can be parameterised in the extended slave settings. Refer to note “Installation of the latest ESI-XML device description”.
For preparation of a configuration:
▪
the real EtherCAT hardware (devices, couplers, drives) must be present and installed
▪
the devices/modules must be connected via EtherCAT cables or in the terminal/ module strand in the same way as they are intended to be used later
▪
the devices/modules be connected to the power supply and ready for communication
▪
TwinCAT must be in CONFIG mode on the target system.
The online scan process consists of:
▪
detecting the EtherCAT device (Ethernet port at the IPC)
▪
detecting the connected EtherCAT devices. This step can be carried out independent of the preceding step
▪
troubleshooting
The scan with existing configuration can also be carried out for comparison.


OFFLINE configuration creation

Commissioning [image] TwinCAT Development Environment [image] OFFLINE configuration creation
OFFLINE configuration creation
Creating the EtherCAT device
Create an EtherCAT device in an empty System Manager window.
Append EtherCAT device (left: TwinCAT 2; right: TwinCAT 3)
Select type “EtherCAT” for an EtherCAT I/O application with EtherCAT slaves. For the present publisher/subscriber service in combination with an EL6601/EL6614 terminal select “EtherCAT Automation Protocol via EL6601”.
Selecting the EtherCAT connection (TwinCAT 2.11, TwinCAT 3)
Then assign a real Ethernet port to this virtual device in the runtime system.
Selecting the Ethernet port
This query may appear automatically when the EtherCAT device is created, or the assignment can be set/modified later in the properties dialog; see Fig. “EtherCAT device properties (TwinCAT 2)”.
EtherCAT device properties (TwinCAT 2)
TwinCAT 3: the properties of the EtherCAT device can be opened by double click on “Device .. (EtherCAT)” within the Solution Explorer under “I/O”:
Selecting the Ethernet port
Ethernet ports can only be selected for EtherCAT devices for which the TwinCAT real-time driver is installed. This has to be done separately for each port. Please refer to the respective installation page.
Defining EtherCAT slaves
Further devices can be appended by right-clicking on a device in the configuration tree.
Appending EtherCAT devices (left: TwinCAT 2; right: TwinCAT 3)
The dialog for selecting a new device opens. Only devices for which ESI files are available are displayed.
Only devices are offered for selection that can be appended to the previously selected device. Therefore the physical layer available for this port is also displayed (Fig. “Selection dialog for new EtherCAT device”, A). In the case of cable-based Fast-Ethernet physical layer with PHY transfer, then also only cable-based devices are available, as shown in Fig. “Selection dialog for new EtherCAT device”. If the preceding device has several free ports (e.g. EK1122 or EK1100), the required port can be selected on the right-hand side (A).
Overview of physical layer
▪
“Ethernet”: cable-based 100BASE-TX: EK couplers, EP boxes, devices with RJ45/M8/M12 connector
▪
“E-Bus”: LVDS “terminal bus”, “EJ-module”: EL/ES terminals, various modular modules
The search field facilitates finding specific devices (since TwinCAT 2.11 or TwinCAT 3).
Selection dialog for new EtherCAT device
By default only the name/device type is used as selection criterion. For selecting a specific revision of the device the revision can be displayed as “Extended Information”.
Display of device revision
In many cases several device revisions were created for historic or functional reasons, e.g. through technological advancement. For simplification purposes (see Fig. “Selection dialog for new EtherCAT device”) only the last (i.e. highest) revision and therefore the latest state of production is displayed in the selection dialog for Beckhoff devices. To show all device revisions available in the system as ESI descriptions tick the “Show Hidden Devices” check box, see Fig. “Display of previous revisions”.
Display of previous revisions
Device selection based on revision, compatibility
The ESI description also defines the process image, the communication type between master and slave/device and the device functions, if applicable. The physical device (firmware, if available) has to support the communication queries/settings of the master. This is backward compatible, i.e. newer devices (higher revision) should be supported if the EtherCAT master addresses them as an older revision. The following compatibility rule of thumb is to be assumed for Beckhoff EtherCAT Terminals/ Boxes/ EJ-modules:
device revision in the system >= device revision in the configuration
This also enables subsequent replacement of devices without changing the configuration (different specifications are possible for drives).
Example
If an EL2521-0025-1018 is specified in the configuration, an EL2521-0025-1018 or higher (-1019, -1020) can be used in practice.
Name/revision of the terminal
If current ESI descriptions are available in the TwinCAT system, the last revision offered in the selection dialog matches the Beckhoff state of production. It is recommended to use the last device revision when creating a new configuration, if current Beckhoff devices are used in the real application. Older revisions should only be used if older devices from stock are to be used in the application.
In this case the process image of the device is shown in the configuration tree and can be parameterized as follows: linking with the task, CoE/DC settings, plug-in definition, startup settings, ...
EtherCAT terminal in the TwinCAT tree (left: TwinCAT 2; right: TwinCAT 3)


ONLINE configuration creation

Commissioning [image] TwinCAT Development Environment [image] ONLINE configuration creation
ONLINE configuration creation
Detecting/scanning of the EtherCAT device
The online device search can be used if the TwinCAT system is in CONFIG mode. This can be indicated by a symbol right below in the information bar:
▪
on TwinCAT 2 by a blue display “Config Mode” within the System Manager window: .
▪
on TwinCAT 3 within the user interface of the development environment by a symbol [image].
TwinCAT can be set into this mode:
▪
TwinCAT 2: by selection of [image] in the Menubar or by “Actions” → “Set/Reset TwinCAT to Config Mode…”
▪
TwinCAT 3: by selection of [image] in the Menubar or by “TwinCAT” → “Restart TwinCAT (Config Mode)”
Online scanning in Config mode
The online search is not available in RUN mode (production operation). Note the differentiation between TwinCAT programming system and TwinCAT target system.
The TwinCAT 2 icon ( [image]) or TwinCAT 3 icon ( [image]) within the Windows-Taskbar always shows the TwinCAT mode of the local IPC. Compared to that, the System Manager window of TwinCAT 2 or the user interface of TwinCAT 3 indicates the state of the target system.
Differentiation local/target system (left: TwinCAT 2; right: TwinCAT 3)
Right-clicking on “I/O Devices” in the configuration tree opens the search dialog.
Scan Devices (left: TwinCAT 2; right: TwinCAT 3)
This scan mode attempts to find not only EtherCAT devices (or Ethernet ports that are usable as such), but also NOVRAM, fieldbus cards, SMB etc. However, not all devices can be found automatically.
Note for automatic device scan (left: TwinCAT 2; right: TwinCAT 3)
Ethernet ports with installed TwinCAT real-time driver are shown as “RT Ethernet” devices. An EtherCAT frame is sent to these ports for testing purposes. If the scan agent detects from the response that an EtherCAT slave is connected, the port is immediately shown as an “EtherCAT Device” .
Detected Ethernet devices
Via respective checkboxes devices can be selected (as illustrated in Fig. “Detected Ethernet devices” e.g. Device 3 and Device 4 were chosen). After confirmation with “OK” a device scan is suggested for all selected devices, see Fig.: “Scan query after automatic creation of an EtherCAT device”.
Selecting the Ethernet port
Ethernet ports can only be selected for EtherCAT devices for which the TwinCAT real-time driver is installed. This has to be done separately for each port. Please refer to the respective installation page.
Detecting/Scanning the EtherCAT devices
Online scan functionality
During a scan the master queries the identity information of the EtherCAT slaves from the slave EEPROM. The name and revision are used for determining the type. The respective devices are located in the stored ESI data and integrated in the configuration tree in the default state defined there.
Example default state
Note
Slave scanning in practice in series machine production
The scanning function should be used with care. It is a practical and fast tool for creating an initial configuration as a basis for commissioning. In series machine production or reproduction of the plant, however, the function should no longer be used for the creation of the configuration, but if necessary for comparison with the defined initial configuration.Background: since Beckhoff occasionally increases the revision version of the delivered products for product maintenance reasons, a configuration can be created by such a scan which (with an identical machine construction) is identical according to the device list; however, the respective device revision may differ from the initial configuration.
Example:
Company A builds the prototype of a machine B, which is to be produced in series later on. To do this the prototype is built, a scan of the IO devices is performed in TwinCAT and the initial configuration “B.tsm” is created. The EL2521-0025 EtherCAT terminal with the revision 1018 is located somewhere. It is thus built into the TwinCAT configuration in this way:
Installing EthetCAT terminal with revision -1018
Likewise, during the prototype test phase, the functions and properties of this terminal are tested by the programmers/commissioning engineers and used if necessary, i.e. addressed from the PLC “B.pro” or the NC. (the same applies correspondingly to the TwinCAT 3 solution files).
The prototype development is now completed and series production of machine B starts, for which Beckhoff continues to supply the EL2521-0025-0018. If the commissioning engineers of the series machine production department always carry out a scan, a B configuration with the identical contents results again for each machine. Likewise, A might create spare parts stores worldwide for the coming series-produced machines with EL2521-0025-1018 terminals.
After some time Beckhoff extends the EL2521-0025 by a new feature C. Therefore the FW is changed, outwardly recognizable by a higher FW version and a new revision -1019. Nevertheless the new device naturally supports functions and interfaces of the predecessor version(s); an adaptation of “B.tsm” or even “B.pro” is therefore unnecessary. The series-produced machines can continue to be built with “B.tsm” and “B.pro”; it makes sense to perform a comparative scan against the initial configuration “B.tsm” in order to check the built machine.
However, if the series machine production department now doesn’t use “B.tsm”, but instead carries out a scan to create the productive configuration, the revision -1019 is automatically detected and built into the configuration:
Detection of EtherCAT terminal with revision -1019
This is usually not noticed by the commissioning engineers. TwinCAT cannot signal anything either, since virtually a new configuration is created. According to the compatibility rule, however, this means that no EL2521-0025-1018 should be built into this machine as a spare part (even if this nevertheless works in the vast majority of cases).
In addition, it could be the case that, due to the development accompanying production in company A, the new feature C of the EL2521-0025-1019 (for example, an improved analog filter or an additional process data for the diagnosis) is discovered and used without in-house consultation. The previous stock of spare part devices are then no longer to be used for the new configuration “B2.tsm” created in this way. Þ if series machine production is established, the scan should only be performed for informative purposes for comparison with a defined initial configuration. Changes are to be made with care!
If an EtherCAT device was created in the configuration (manually or through a scan), the I/O field can be scanned for devices/slaves.
Scan query after automatic creation of an EtherCAT device (left: TwinCAT 2; right: TwinCAT 3)
Manual triggering of a device scan on a specified EtherCAT device (left: TwinCAT 2; right: TwinCAT 3)
In the System Manager (TwinCAT 2) or the User Interface (TwinCAT 3) the scan process can be monitored via the progress bar at the bottom in the status bar.
Scan progressexemplary by TwinCAT 2
The configuration is established and can then be switched to online state (OPERATIONAL).
Config/FreeRun query (left: TwinCAT 2; right: TwinCAT 3)
In Config/FreeRun mode the System Manager display alternates between blue and red, and the EtherCAT device continues to operate with the idling cycle time of 4 ms (default setting), even without active task (NC, PLC).
Displaying of “Free Run” and “Config Mode” toggling right below in the status bar
TwinCAT can also be switched to this state by using a button (left: TwinCAT 2; right: TwinCAT 3)
The EtherCAT system should then be in a functional cyclic state, as shown in Fig. Online display example.
Online display example
Please note:
▪
all slaves should be in OP state
▪
the EtherCAT master should be in “Actual State” OP
▪
“frames/sec” should match the cycle time taking into account the sent number of frames
▪
no excessive “LostFrames” or CRC errors should occur
The configuration is now complete. It can be modified as described under manual procedure.
Troubleshooting
Various effects may occur during scanning.
▪
An unknown device is detected, i.e. an EtherCAT slave for which no ESI XML description is available.
In this case the System Manager offers to read any ESI that may be stored in the device. This case is described in the chapter “Notes regarding ESI device description”.
▪
Device are not detected properly
Possible reasons include:
–
faulty data links, resulting in data loss during the scan
–
slave has invalid device description
The connections and devices should be checked in a targeted manner, e.g. via the emergency scan.
Then re-run the scan.
Faulty identification
In the System Manager such devices may be set up as EK0000 or unknown devices. Operation is not possible or meaningful.
Scan over existing Configuration
Note
Change of the configuration after comparison
With this scan (TwinCAT 2.11 or 3.1) only the device properties vendor (manufacturer), device name and revision are compared at present! A “ChangeTo” or “Copy” should only be carried out with care, taking into consideration the Beckhoff IO compatibility rule (see above). The device configuration is then replaced by the revision found; this can affect the supported process data and functions.
If a scan is initiated for an existing configuration, the actual I/O environment may match the configuration exactly or it may differ. This enables the configuration to be compared.
Identical configuration (left: TwinCAT 2; right: TwinCAT 3)
If differences are detected, they are shown in the correction dialog, so that the user can modify the configuration as required.
Correction dialog
It is advisable to tick the “Extended Information” check box to reveal differences in the revision.
Color
Explanation
green
This EtherCAT slave matches the entry on the other side. Both type and revision match.
blue
This EtherCAT slave is present on the other side, but in a different revision. This other revision can have other default values for the process data as well as other/additional functions.
If the found revision is higher than the configured revision, the slave may be used provided compatibility issues are taken into account.
If the found revision is lower than the configured revision, it is likely that the slave cannot be used. The found device may not support all functions that the master expects based on the higher revision number.
light blue
This EtherCAT slave is ignored (“Ignore” button)
red
▪
This EtherCAT slave is not present on the other side.
▪
It is present, but in a different revision, which also differs in its properties from the one specified.
The compatibility principle then also applies here: if the found revision is higher than the configured revision, use is possible provided compatibility issues are taken into account, since the successor devices should support the functions of the predecessor devices.
If the found revision is lower than the configured revision, it is likely that the slave cannot be used. The found device may not support all functions that the master expects based on the higher revision number.
Device selection based on revision, compatibility
The ESI description also defines the process image, the communication type between master and slave/device and the device functions, if applicable. The physical device (firmware, if available) has to support the communication queries/settings of the master. This is backward compatible, i.e. newer devices (higher revision) should be supported if the EtherCAT master addresses them as an older revision. The following compatibility rule of thumb is to be assumed for Beckhoff EtherCAT Terminals/ Boxes/ EJ-modules:
device revision in the system >= device revision in the configuration
This also enables subsequent replacement of devices without changing the configuration (different specifications are possible for drives).
Example
If an EL2521-0025-1018 is specified in the configuration, an EL2521-0025-1018 or higher (-1019, -1020) can be used in practice.
Name/revision of the terminal
If current ESI descriptions are available in the TwinCAT system, the last revision offered in the selection dialog matches the Beckhoff state of production. It is recommended to use the last device revision when creating a new configuration, if current Beckhoff devices are used in the real application. Older revisions should only be used if older devices from stock are to be used in the application.
In this case the process image of the device is shown in the configuration tree and can be parameterized as follows: linking with the task, CoE/DC settings, plug-in definition, startup settings, ...
Correction dialog with modifications
Once all modifications have been saved or accepted, click “OK” to transfer them to the real *.tsm configuration.
Change to Compatible Type
TwinCAT offers a function Change to Compatible Type… for the exchange of a device whilst retaining the links in the task.
Dialog “Change to Compatible Type…” (left: TwinCAT 2; right: TwinCAT 3)
This function is preferably to be used on AX5000 devices.
Change to Alternative Type
The TwinCAT System Manager offers a function for the exchange of a device: Change to Alternative Type
TwinCAT 2 Dialog Change to Alternative Type
If called, the System Manager searches in the procured device ESI (in this example: EL1202-0000) for details of compatible devices contained there. The configuration is changed and the ESI-EEPROM is overwritten at the same time – therefore this process is possible only in the online state (ConfigMode).


EtherCAT subscriber configuration

Commissioning [image] TwinCAT Development Environment [image] EtherCAT subscriber configuration
EtherCAT subscriber configuration
In the left-hand window of the TwinCAT 2 System Manager or the Solution Explorer of the TwinCAT 3 Development Environment respectively, click on the element of the terminal within the tree you wish to configure (in the example: EL3751 Terminal 3).
Branch element as terminal EL3751
In the right-hand window of the TwinCAT System Manager (TwinCAT 2) or the Development Environment (TwinCAT 3), various tabs are now available for configuring the terminal. And yet the dimension of complexity of a subscriber determines which tabs are provided. Thus as illustrated in the example above the terminal EL3751 provides many setup options and also a respective number of tabs are available. On the contrary by the terminal EL1004 for example the tabs “General”, “EtherCAT”, “Process Data” and “Online“ are available only. Several terminals, as for instance the EL6695 provide special functions by a tab with its own terminal name, so “EL6695” in this case. A specific tab “Settings” by terminals with a wide range of setup options will be provided also (e.g. EL3751).
“General” tab
“General” tab
Name | Name of the EtherCAT device
Id | Number of the EtherCAT device
Type | EtherCAT device type
Comment | Here you can add a comment (e.g. regarding the system).
Disabled | Here you can deactivate the EtherCAT device.
Create symbols | Access to this EtherCAT slave via ADS is only available if this control box is activated.
“EtherCAT” tab
“EtherCAT” tab
Type | EtherCAT device type
Product/Revision | Product and revision number of the EtherCAT device
Auto Inc Addr. | Auto increment address of the EtherCAT device. The auto increment address can be used for addressing each EtherCAT device in the communication ring through its physical position. Auto increment addressing is used during the start-up phase when the EtherCAT master allocates addresses to the EtherCAT devices. With auto increment addressing the first EtherCAT slave in the ring has the address 0000hex. For each further slave the address is decremented by 1 (FFFFhex, FFFEhex etc.).
EtherCAT Addr. | Fixed address of an EtherCAT slave. This address is allocated by the EtherCAT master during the start-up phase. Tick the control box to the left of the input field in order to modify the default value.
Previous Port | Name and port of the EtherCAT device to which this device is connected. If it is possible to connect this device with another one without changing the order of the EtherCAT devices in the communication ring, then this combination field is activated and the EtherCAT device to which this device is to be connected can be selected.
Advanced Settings | This button opens the dialogs for advanced settings.
The link at the bottom of the tab points to the product page for this EtherCAT device on the web.
“Process Data” tab
Indicates the configuration of the process data. The input and output data of the EtherCAT slave are represented as CANopen process data objects (Process Data Objects, PDOs). The user can select a PDO via PDO assignment and modify the content of the individual PDO via this dialog, if the EtherCAT slave supports this function.
“Process Data” tab
The process data (PDOs) transferred by an EtherCAT slave during each cycle are user data which the application expects to be updated cyclically or which are sent to the slave. To this end the EtherCAT master (Beckhoff TwinCAT) parameterizes each EtherCAT slave during the start-up phase to define which process data (size in bits/bytes, source location, transmission type) it wants to transfer to or from this slave. Incorrect configuration can prevent successful start-up of the slave.
For Beckhoff EtherCAT EL, ES, EM, EJ and EP slaves the following applies in general:
▪
The input/output process data supported by the device are defined by the manufacturer in the ESI/XML description. The TwinCAT EtherCAT Master uses the ESI description to configure the slave correctly.
▪
The process data can be modified in the System Manager. See the device documentation.
Examples of modifications include: mask out a channel, displaying additional cyclic information, 16-bit display instead of 8-bit data size, etc.
▪
In so-called “intelligent” EtherCAT devices the process data information is also stored in the CoE directory. Any changes in the CoE directory that lead to different PDO settings prevent successful startup of the slave. It is not advisable to deviate from the designated process data, because the device firmware (if available) is adapted to these PDO combinations.
If the device documentation allows modification of process data, proceed as follows (see Figure Configuring the process data).
▪
A: select the device to configure
▪
B: in the “Process Data” tab select Input or Output under SyncManager (C)
▪
D: the PDOs can be selected or deselected
▪
H: the new process data are visible as linkable variables in the System Manager
The new process data are active once the configuration has been activated and TwinCAT has been restarted (or the EtherCAT master has been restarted)
▪
E: if a slave supports this, Input and Output PDO can be modified simultaneously by selecting a so-called PDO record (“predefined PDO settings”).
Configuring the process data
Manual modification of the process data
According to the ESI description, a PDO can be identified as “fixed” with the flag “F” in the PDO overview (Fig. Configuring the process data, J). The configuration of such PDOs cannot be changed, even if TwinCAT offers the associated dialog (“Edit”). In particular, CoE content cannot be displayed as cyclic process data. This generally also applies in cases where a device supports download of the PDO configuration, “G”. In case of incorrect configuration the EtherCAT slave usually refuses to start and change to OP state. The System Manager displays an “invalid SM cfg” logger message: This error message (“invalid SM IN cfg” or “invalid SM OUT cfg”) also indicates the reason for the failed start.
A detailed description can be found at the end of this section.
“Startup” tab
The Startup tab is displayed if the EtherCAT slave has a mailbox and supports the CANopen over EtherCAT (CoE) or Servo drive over EtherCAT protocol. This tab indicates which download requests are sent to the mailbox during startup. It is also possible to add new mailbox requests to the list display. The download requests are sent to the slave in the same order as they are shown in the list.
“Startup” tab
Column
Description
Transition
Transition to which the request is sent. This can either be
▪
the transition from pre-operational to safe-operational (PS), or
▪
the transition from safe-operational to operational (SO).
If the transition is enclosed in “<>” (e.g. <PS>), the mailbox request is fixed and cannot be modified or deleted by the user.
Protocol
Type of mailbox protocol
Index
Index of the object
Data
Date on which this object is to be downloaded.
Comment
Description of the request to be sent to the mailbox
Move Up | This button moves the selected request up by one position in the list.
Move Down | This button moves the selected request down by one position in the list.
New | This button adds a new mailbox download request to be sent during startup.
Delete | This button deletes the selected entry.
Edit | This button edits an existing request.
“CoE - Online” tab
The additional CoE - Online tab is displayed if the EtherCAT slave supports the CANopen over EtherCAT (CoE) protocol. This dialog lists the content of the object list of the slave (SDO upload) and enables the user to modify the content of an object from this list. Details for the objects of the individual EtherCAT devices can be found in the device-specific object descriptions.
“CoE - Online” tab
Object list display
Column | Description
Index | Index and sub-index of the object
Name | Name of the object
Flags | RW | The object can be read, and data can be written to the object (read/write)
 | RO | The object can be read, but no data can be written to the object (read only)
 | P | An additional P identifies the object as a process data object.
Value | Value of the object
Update List | The Update list button updates all objects in the displayed list
Auto Update | If this check box is selected, the content of the objects is updated automatically.
Advanced | The Advanced button opens the Advanced Settings dialog. Here you can specify which objects are displayed in the list.
Dialog “Advanced settings”
Online - via SDO Information | If this option button is selected, the list of the objects included in the object list of the slave is uploaded from the slave via SDO information. The list below can be used to specify which object types are to be uploaded.
Offline - via EDS File | If this option button is selected, the list of the objects included in the object list is read from an EDS file provided by the user.
“Online” tab
“Online” tab
State Machine
Init | This button attempts to set the EtherCAT device to the Init state.
Pre-Op | This button attempts to set the EtherCAT device to the pre-operational state.
Op | This button attempts to set the EtherCAT device to the operational state.
Bootstrap | This button attempts to set the EtherCAT device to the Bootstrap state.
Safe-Op | This button attempts to set the EtherCAT device to the safe-operational state.
Clear Error | This button attempts to delete the fault display. If an EtherCAT slave fails during change of state it sets an error flag. Example: An EtherCAT slave is in PREOP state (pre-operational). The master now requests the SAFEOP state (safe-operational). If the slave fails during change of state it sets the error flag. The current state is now displayed as ERR PREOP. When the Clear Error button is pressed the error flag is cleared, and the current state is displayed as PREOP again.
Current State | Indicates the current state of the EtherCAT device.
Requested State | Indicates the state requested for the EtherCAT device.
DLL Status
Indicates the DLL status (data link layer status) of the individual ports of the EtherCAT slave. The DLL status can have four different states:
Status | Description
No Carrier / Open | No carrier signal is available at the port, but the port is open.
No Carrier / Closed | No carrier signal is available at the port, and the port is closed.
Carrier / Open | A carrier signal is available at the port, and the port is open.
Carrier / Closed | A carrier signal is available at the port, but the port is closed.
File Access over EtherCAT
Download | With this button a file can be written to the EtherCAT device.
Upload | With this button a file can be read from the EtherCAT device.
“DC” tab (Distributed Clocks)
“DC” tab (Distributed Clocks)
Operation Mode
Options (optional):
▪
FreeRun
▪
SM-Synchron
▪
DC-Synchron (Input based)
▪
DC-Synchron
Advanced Settings…
Advanced settings for readjustment of the real time determinant TwinCAT-clock
Detailed information to Distributed Clocks is specified on http://infosys.beckhoff.com:
Fieldbus Components → EtherCAT Terminals → EtherCAT System documentation → EtherCAT basics → Distributed Clocks
Additional information
•
Detailed description of Process Data tab


Detailed description of Process Data tab

Commissioning [image] TwinCAT Development Environment [image] EtherCAT subscriber configuration [image] Detailed description of Process Data tab
Detailed description of Process Data tab
Sync Manager
Lists the configuration of the Sync Manager (SM).
If the EtherCAT device has a mailbox, SM0 is used for the mailbox output (MbxOut) and SM1 for the mailbox input (MbxIn).
SM2 is used for the output process data (outputs) and SM3 (inputs) for the input process data.
If an input is selected, the corresponding PDO assignment is displayed in the PDO Assignment list below.
PDO Assignment
PDO assignment of the selected Sync Manager. All PDOs defined for this Sync Manager type are listed here:
▪
If the output Sync Manager (outputs) is selected in the Sync Manager list, all RxPDOs are displayed.
▪
If the input Sync Manager (inputs) is selected in the Sync Manager list, all TxPDOs are displayed.
The selected entries are the PDOs involved in the process data transfer. In the tree diagram of the System Manager these PDOs are displayed as variables of the EtherCAT device. The name of the variable is identical to the Name parameter of the PDO, as displayed in the PDO list. If an entry in the PDO assignment list is deactivated (not selected and greyed out), this indicates that the input is excluded from the PDO assignment. In order to be able to select a greyed out PDO, the currently selected PDO has to be deselected first.
Activation of PDO assignment
✓
If you have changed the PDO assignment, in order to activate the new PDO assignment,
1.
the EtherCAT slave has to run through the PS status transition cycle (from pre-operational to safe-operational) once (see Online tab),
2.
and the System Manager has to reload the EtherCAT slaves
( [image] button for TwinCAT 2 or [image] button for TwinCAT 3)
PDO list
List of all PDOs supported by this EtherCAT device. The content of the selected PDOs is displayed in the PDO Content list. The PDO configuration can be modified by double-clicking on an entry.
Column | Description
Index | PDO index.
Size | Size of the PDO in bytes.
Name | Name of the PDO. If this PDO is assigned to a Sync Manager, it appears as a variable of the slave with this parameter as the name.
Flags | F | Fixed content: The content of this PDO is fixed and cannot be changed by the System Manager.
 | M | Mandatory PDO. This PDO is mandatory and must therefore be assigned to a Sync Manager! Consequently, this PDO cannot be deleted from the PDO Assignment list
SM | Sync Manager to which this PDO is assigned. If this entry is empty, this PDO does not take part in the process data traffic.
SU | Sync unit to which this PDO is assigned.
PDO Content
Indicates the content of the PDO. If flag F (fixed content) of the PDO is not set the content can be modified.
Download
If the device is intelligent and has a mailbox, the configuration of the PDO and the PDO assignments can be downloaded to the device. This is an optional feature that is not supported by all EtherCAT slaves.
PDO Assignment
If this check box is selected, the PDO assignment that is configured in the PDO Assignment list is downloaded to the device on startup. The required commands to be sent to the device can be viewed in the Startup tab.
PDO Configuration
If this check box is selected, the configuration of the respective PDOs (as shown in the PDO list and the PDO Content display) is downloaded to the EtherCAT slave.


General Notes - EtherCAT Slave Application

Commissioning [image] General Notes - EtherCAT Slave Application
General Notes - EtherCAT Slave Application
This summary briefly deals with a number of aspects of EtherCAT Slave operation under TwinCAT. More detailed information on this may be found in the corresponding sections of, for instance, the EtherCAT System Documentation.
Diagnosis in real time: WorkingCounter, EtherCAT State and Status
Generally speaking an EtherCAT Slave provides a variety of diagnostic information that can be used by the controlling task.
This diagnostic information relates to differing levels of communication. It therefore has a variety of sources, and is also updated at various times.
Any application that relies on I/O data from a fieldbus being correct and up to date must make diagnostic access to the corresponding underlying layers. EtherCAT and the TwinCAT System Manager offer comprehensive diagnostic elements of this kind. Those diagnostic elements that are helpful to the controlling task for diagnosis that is accurate for the current cycle when in operation (not during commissioning) are discussed below.
Selection of the diagnostic information of an EtherCAT Slave
In general, an EtherCAT Slave offers
▪
communication diagnosis typical for a slave (diagnosis of successful participation in the exchange of process data, and correct operating mode)
This diagnosis is the same for all slaves.

as well as
▪
function diagnosis typical for a channel (device-dependent)
See the corresponding device documentation
The colors in Fig. Selection of the diagnostic information of an EtherCAT Slave also correspond to the variable colors in the System Manager, see Fig. Basic EtherCAT Slave Diagnosis in the PLC.
Colour | Meaning
yellow | Input variables from the Slave to the EtherCAT Master, updated in every cycle
red | Output variables from the Slave to the EtherCAT Master, updated in every cycle
green | Information variables for the EtherCAT Master that are updated acyclically. This means that it is possible that in any particular cycle they do not represent the latest possible status. It is therefore useful to read such variables through ADS.
Fig. Basic EtherCAT Slave Diagnosis in the PLC shows an example of an implementation of basic EtherCAT Slave Diagnosis. A Beckhoff EL3102 (2-channel analogue input terminal) is used here, as it offers both the communication diagnosis typical of a slave and the functional diagnosis that is specific to a channel. Structures are created as input variables in the PLC, each corresponding to the process image.
Basic EtherCAT Slave Diagnosis in the PLC
The following aspects are covered here:
Code
Function
Implementation
Application/evaluation
A
The EtherCAT Master's diagnostic information
updated acyclically (yellow) or provided acyclically (green).
At least the DevState is to be evaluated for the most recent cycle in the PLC.
The EtherCAT Master's diagnostic information offers many more possibilities than are treated in the EtherCAT System Documentation. A few keywords:
▪
CoE in the Master for communication with/through the Slaves
▪
Functions from TcEtherCAT.lib
▪
Perform an OnlineScan
B
In the example chosen (EL3102) the EL3102 comprises two analogue input channels that transmit a single function status for the most recent cycle.
Status
▪
the bit significations may be found in the device documentation
▪
other devices may supply more information, or none that is typical of a slave
In order for the higher-level PLC task (or corresponding control applications) to be able to rely on correct data, the function status must be evaluated there. Such information is therefore provided with the process data for the most recent cycle.
C
For every EtherCAT Slave that has cyclic process data, the Master displays, using what is known as a WorkingCounter, whether the slave is participating successfully and without error in the cyclic exchange of process data. This important, elementary information is therefore provided for the most recent cycle in the System Manager
1.
at the EtherCAT Slave, and, with identical contents
2.
as a collective variable at the EtherCAT Master (see Point A)
for linking.
WcState (Working Counter)
0: valid real-time communication in the last cycle
1: invalid real-time communication
This may possibly have effects on the process data of other Slaves that are located in the same SyncUnit
In order for the higher-level PLC task (or corresponding control applications) to be able to rely on correct data, the communication status of the EtherCAT Slave must be evaluated there. Such information is therefore provided with the process data for the most recent cycle.
D
Diagnostic information of the EtherCAT Master which, while it is represented at the slave for linking, is actually determined by the Master for the Slave concerned and represented there. This information cannot be characterized as real-time, because it
▪
is only rarely/never changed, except when the system starts up
▪
is itself determined acyclically (e.g. EtherCAT Status)
State
current Status (INIT..OP) of the Slave. The Slave must be in OP (=8) when operating normally.
AdsAddr
The ADS address is useful for communicating from the PLC/task via ADS with the EtherCAT Slave, e.g. for reading/writing to the CoE. The AMS-NetID of a slave corresponds to the AMS-NetID of the EtherCAT Master; communication with the individual Slave is possible via the port (= EtherCAT address).
Information variables for the EtherCAT Master that are updated acyclically. This means that it is possible that in any particular cycle they do not represent the latest possible status. It is therefore possible to read such variables through ADS.
Note
Diagnostic information
It is strongly recommended that the diagnostic information made available is evaluated so that the application can react accordingly.
CoE Parameter Directory
The CoE parameter directory (CanOpen-over-EtherCAT) is used to manage the set values for the slave concerned. Changes may, in some circumstances, have to be made here when commissioning a relatively complex EtherCAT Slave. It can be accessed through the TwinCAT System Manager, see Fig. EL3102, CoE directory:
EL3102, CoE directory
EtherCAT System Documentation
The comprehensive description in the EtherCAT System Documentation (EtherCAT Basics --> CoE Interface) must be observed!
A few brief extracts:
▪
Whether changes in the online directory are saved locally in the slave depends on the device. EL terminals (except the EL66xx) are able to save in this way.
▪
The user must manage the changes to the StartUp list.
Commissioning aid in the TwinCAT System Manager
Commissioning interfaces are being introduced as part of an ongoing process for EL/EP EtherCAT devices. These are available in TwinCAT System Managers from TwinCAT 2.11R2 and above. They are integrated into the System Manager through appropriately extended ESI configuration files.
Example of commissioning aid for a EL3204
This commissioning process simultaneously manages
▪
CoE Parameter Directory
▪
DC/FreeRun mode
▪
the available process data records (PDO)
Although the “Process Data”, “DC”, “Startup” and “CoE-Online” that used to be necessary for this are still displayed, it is recommended that, if the commissioning aid is used, the automatically generated settings are not changed by it.
The commissioning tool does not cover every possible application of an EL/EP device. If the available setting options are not adequate, the user can make the DC, PDO and CoE settings manually, as in the past.
EtherCAT State: automatic default behaviour of the TwinCAT System Manager and manual operation
After the operating power is switched on, an EtherCAT Slave must go through the following statuses
▪
INIT
▪
PREOP
▪
SAFEOP
▪
OP
to ensure sound operation. The EtherCAT Master directs these statuses in accordance with the initialization routines that are defined for commissioning the device by the ES/XML and user settings (Distributed Clocks (DC), PDO, CoE). See also the section on "Principles of Communication, EtherCAT State Machine" in this connection. Depending how much configuration has to be done, and on the overall communication, booting can take up to a few seconds.
The EtherCAT Master itself must go through these routines when starting, until it has reached at least the OP target state.
The target state wanted by the user, and which is brought about automatically at start-up by TwinCAT, can be set in the System Manager. As soon as TwinCAT reaches the status RUN, the TwinCAT EtherCAT Master will approach the target states.
Standard setting
The advanced settings of the EtherCAT Master are set as standard:
▪
EtherCAT Master: OP
▪
Slaves: OP
This setting applies equally to all Slaves.
Default behaviour of the System Manager
In addition, the target state of any particular Slave can be set in the “Advanced Settings” dialogue; the standard setting is again OP.
Default target state in the Slave
Manual Control
There are particular reasons why it may be appropriate to control the states from the application/task/PLC. For instance:
▪
for diagnostic reasons
▪
to induce a controlled restart of axes
▪
because a change in the times involved in starting is desirable
In that case it is appropriate in the PLC application to use the PLC function blocks from the TcEtherCAT.lib, which is available as standard, and to work through the states in a controlled manner using, for instance, FB_EcSetMasterState.
It is then useful to put the settings in the EtherCAT Master to INIT for master and slave.
PLC function blocks
Note regarding E-Bus current
EL/ES terminals are placed on the DIN rail at a coupler on the terminal strand. A Bus Coupler can supply the EL terminals added to it with the E-bus system voltage of 5 V; a coupler is thereby loadable up to 2 A as a rule. Information on how much current each EL terminal requires from the E-bus supply is available online and in the catalogue. If the added terminals require more current than the coupler can supply, then power feed terminals (e.g. EL9410) must be inserted at appropriate places in the terminal strand.
The pre-calculated theoretical maximum E-Bus current is displayed in the TwinCAT System Manager as a column value. A shortfall is marked by a negative total amount and an exclamation mark; a power feed terminal is to be placed before such a position.
Illegally exceeding the E-Bus current
From TwinCAT 2.11 and above, a warning message “E-Bus Power of Terminal...” is output in the logger window when such a configuration is activated:
Warning message for exceeding E-Bus current
Note
Caution! Malfunction possible!
The same ground potential must be used for the E-Bus supply of all EtherCAT terminals in a terminal block!


Sensitivity of the input

Commissioning [image] Sensitivity of the input
Sensitivity of the input
The input circuit of the EL12xx is optimized for fast signal changes and the shortest possible signal detection. The time required for a signal change as a rising/falling edge from the terminal point at the front of the terminal to the logic of the central processing unit (ESC) is specified for the EL12xx series at TON/TOFF < 1 µs, both for rising (TON) and falling edge (TOFF). Due to this low absolute cycle time, the temperature drift of the cycle time is also very low.
It should be considered that the input circuitry has little or no filtering, depending on the type. It is optimized for fastest signal transmission from the input to the evaluation unit. Fast level changes/pulses in the µs range, e.g. due to possible EMC influences, thus arrive at the evaluation unit unfiltered/undamped and are possibly visible as a change of state of the input.
If necessary, shielded cables should be used to exclude environmental influences.


Basic function principles

Commissioning [image] Basic function principles
Basic function principles
Table of contents
• Definitions
- Channel
- Cyclic process data/PDO
- Parameter data/CoE
- Buffer
- Event
- Timestamp
- MTSF
- Macrocycle
- Microcycle
• Compatibility mode in relation to EL1252/EL2252
- PDO definition
Additional information
•
Definitions
•
Compatibility mode in relation to EL1252/EL2252


Definitions

Commissioning [image] Basic function principles [image] Definitions
Definitions
The following section describes some basic terminology relating to the multi-timestamp function. This is based on the explanatory notes on the technology page, which must be referred to for guidance.
Channel
The EL1259, for example, has 8 input and 8 output channels. Every channel can operate independent of the other channels and has its own buffer and its own settings in the CoE (channel-oriented programming is supported).
Notwithstanding the channel-based parameterization (CoE, PDO), the settings for all channels are implemented together in the terminal.
Cyclic process data/PDO
Each channel has 2 different types of cyclic PDO:
- Diagnostics/status/control values created specifically for the buffer
- The actual "values" as time-stamped Boolean data in the form of an array. The array should be set to a suitable size in the configuration. It cannot be changed during runtime.
See also PDO overview on the commissioning pages and the following sections.
Parameter data/CoE
In the CoE each channel has a parameter range 0x80n0:ff with suitable settings for configuring the buffer or the input/output behavior, for example.
See also information in the commissioning pages.
Buffer
Each channel has its own buffer (memory) for 32 events, based on the FIFO principle. It is served via channel-specific PDOs - see PDO overview on the commissioning pages.
▪
For inputs: The channel state is queried for its switching state 0/1 based on the microcycle. Any changes that are detected are stored in the buffer. Depending on the configured multi-timestamp factor for the channel (MTSF), the buffer content is retrieved by the controller/PLC via EtherCAT, either in its entirety or in several steps.
The behavior in case of a buffer overflow can be configured; an overflow of the buffer is indicated in the process data. If necessary the buffer can be emptied by the controller.
▪
For outputs: The controller loads switching orders into the buffer, depending on the configured MTSF. In each microcycle a check is performed to determine whether the highest entry in the buffer is to be executed. The behavior in the case of ‘outdated’ timestamps can be configured. If necessary the buffer can be emptied by the controller.
Note: The current FW supports a buffer for 32 events. Other sizes on request.
Event
An "event" is defined as a changing signal edge at the input or output. Therefore, for an input channel an event is the change in input state from 0->1 or 1->0. This consists of the information timestamp of the event and state 0/1 after the change.
For an output channel an event is a switching order, similarly consisting of two items of information: timestamp of the event and state 0/1 after the desired change.
Timestamp
In its original state the EtherCAT distributed clocks time has the following properties: Starting time 1.1.2000 00:00, 64-bit range with 1 ns resolution (~ 584 years). In order to avoid redundant process data, the multi-timestamp terminals operate with a reduced timestamp width of 32 bits (~ 4.29 sec.). Thus switching orders can be specified up to 4.29 seconds in the future – input events must be processed within 4.2 seconds, as otherwise an overflow occurs and the actually recorded time is no longer secured. Within the framework of this documentation, a function block FB is also provided that accomplishes the filling up of 32-bit input timestamps to the currently valid 64 bits in the PLC.
MTSF
Multi-timestamp factor, currently 1..10, higher on request
In the configuration each channel can be configured to a fixed, maximum number of events that can be transferred per EtherCAT cycle. In other words, this is the maximum number of events (switching orders for outputs or events for input terminals) that can be exchanged with the control/PLC. These process data are to be understood as placeholders, which are not all to be filled at all times. This means for
▪
Inputs:
The number of input events placed in the process data for the controller by the channel matches the number of events that arrived at the input during the last cycle OR are still in the buffer.
▪
Outputs:
The events predefined by the controller are transferred to the channel buffer, which is then processed based on the FIFO principle.
Macrocycle
The terminal requires a certain time for internal cyclic processing of the operations. Depending on the number of active channels and configured MTSF, the internal processing time for the terminal is in the range of several 100 µs, see table below.
The macrocycle time resulting from the actual configuration can be read online from the CoE 0xF900:08.
Microcycle 0xF900:09 & macrocycle 0xF900:08 in the CoE
This time should be regarded as the absolute lower limit for the EtherCAT communication. The EtherCAT task cycle time applied to this terminal should be chosen 10..20 % higher, depending on system performance. The macrocycle times listed in the table below have been determined empirically and should be regarded as guide values. The actual macrocycle time occurring in the system should be verified during commissioning in the CoE object referred to above.
EL1258 macrocycle [µs, typical] | MTSF 1 | MTSF 2 | MTSF 5 | MTSF 10
1 channel | 130 | 140 | 160 | 170
2 channels | 130 | 140 | 160 | 170
4 channels | 130 | 140 | 170 | 200
8 channels | 130 | 160 | 190 | 290
EL1259 macrocycle [µs, typical] | MTSF 1 | MTSF 2 | MTSF 5 | MTSF 10
1 in / 1 out channel | 160 | 160 | 170 | 180
2 in / 2 out channels | 170 | 190 | 210 | 270
4 in / 4 out channels | 180 | 230 | 260 | 360
8 in / 8 out channels | 240 | 320 | 360 | 540
EL2258 macrocycle [µs, typical] | MTSF 1 | MTSF 2 | MTSF 5 | MTSF 10
1 channel | 90 | 90 | 100 | 120
2 channels | 90 | 90 | 100 | 120
4 channels | 140 | 150 | 180 | 230
8 channels | 150 | 170 | 210 | 290
Times for other configurations are best determined via xF900:08.
Microcycle
The microcycle is the internal constant cycle of the terminal, during which sampling of the inputs and testing of the switching orders for outputs takes place. This value depends on the number of active channels, but not on the MTSF value. The corresponding values can be found are in the following table.
The distributed clock in the terminal is controlled via EtherCAT to the standard accuracy of <<1 µs. However, the internal processing microcycle results in a 'coarsening' of the time resolution that can be achieved with the multi-timestamp terminals in practice, as described below.
The microcycle time resulting from the actual configuration can be read online from the CoE 0xF900:09.
Microcycle 0xF900:09 & macrocycle 0xF900:08 in the CoE
The following applies for the sequence:
▪
For inputs: A switching edge arriving from outside at an input channel at any time is picked up during the next microcycle and placed into the buffer. The time inaccuracy for the acquisition is therefore approx. -x/+0 µs (with x = microcycle time).
▪
For outputs: A switching order is executed in a microcycle, if it falls into this microcycle for the first time "after" the execution time. It is then immediately deleted from the buffer.
EL1258 | Microcycle time [µs, typical]
1 channel | 7
2 channels | 10
4 channels | 14
8 channels | 23
EL1259 | Microcycle time [µs, typical]
1 channel | 10
2 channels | 14
4 channels | 22
8 channels | 39
EL2258 | Microcycle time [µs, typical]
1 channel | 7
2 channels | 9
4 channels | 13
8 channels | 21
Times for other configurations are best determined via 0xF900:09.


Compatibility mode in relation to EL1252/EL2252

Commissioning [image] Basic function principles [image] Compatibility mode in relation to EL1252/EL2252
Compatibility mode in relation to EL1252/EL2252
Via the predefined PDO selection the multi-timestamp terminals can be set to a largely identical and therefore compatible process image in relation to the EL1252/EL2252. This means that software interfaces that were created for these timestamp terminals can also be used for multi-timestamp terminals. To this end select the settings "Compatible X-Ch." in the EL1258/EL2258. The behavior is then as for the EL1252/EL2252.
Predefined PDO selection
All channels of the terminal are to be operated in the same way: Either with multi-timestamp process data or with process data that are compatible with EL1252/EL2252.
Option for setting of compatibility modes in relation to EL1252/EL2252
In compatible mode the terminals operate with the following time properties:
EL1258 | Macrocycle time [µs, typical] | Microcycle time [µs, typical]
1 Ch. | 50 | 7
2 Ch. | 70 | 9
4 Ch. | 90 | 13
8 Ch. | 120 | 21
EL1259 | Macrocycle time [µs, typical] | Microcycle time [µs, typical]
1 Ch. In + 1 Ch. Out | 90 | 8
2 Ch. In + 2 Ch. Out | 160 | 11
4 Ch. In + 4 Ch. Out | 180 | 18
8 Ch. In + 8 Ch. Out | 200 | 30
EL2258 | Macrocycle time [µs, typical] | Microcycle time [µs, typical]
1 Ch. | 70 | 7
2 Ch. | 90 | 8
4 Ch. | 110 | 10
8 Ch. | 120 | 15
The microcycle time defines the feasible time resolution of the input capture/output issue.
PDO definition
The process data for inputs and outputs can specified as "predefined PDO" or freely combined:
▪
Selection via "predefined PDO"
Setting multi-timestamping via "predefined PDO"
Several pre-configured combinations of channel number and MTSF are offered. We recommend selecting the process data compilations in this way.
▪
Free compilation
Alternatively, the number of used channels and MTSF per channel can be set as a free compilation via the PDO assignment. The process data objects (PDO) to be transferred cyclically are activated from the inputs/outputs list in the System Manager.
Free selection of the PDO
The meaning of the individual PDOs can be found in the CoE overview. Please note:
▪
“Multi-timestamp PDOs” and “compatible PDOs” cannot be combined
▪
The corresponding control/status must be active for each active input/output channel
▪
The MTSF can be set freely from 1 to 10 for each channel
▪
Only 1 multi-timestamp factor may be active per channel. It is therefore not permitted to activate PDO "MTO Outputs 5x Channel 1" and PDO "MTO Outputs 2x Channel 1" at the same time, for example.
If an irregular PDO combination is selected, it may lead to the ERR-PREOP state ‘invalid output mapping’ or ‘invalid input mapping’.
Event logger message from the System Manager in the event of invalid PDO combination


Commissioning inputs

Commissioning [image] Commissioning inputs
Commissioning inputs
Table of contents
• Basic principles
• Commissioning an MIT channel
- 1. Synchronous or asynchronous operation?
- 2. Setting the multi-timestamping factor (MTSF)
- 3. When should the filter in CoE be activated? (default: deactivated)
- 4. How can I test the input channel?
- 5. Processing of events in the PLC
• Commissioning in compatibility mode
The section below describes commissioning of a digital input terminal with multi-timestamp function at a PLC.
Additional information
•
Basic principles
•
Commissioning of a MTI channel
•
Commissioning in compatibility mode


Basic principles

Commissioning [image] Commissioning inputs [image] Basic principles
Basic principles
Each MTI channel (multi-timestamp input) has inputs and outputs in the cyclic process image, which have to be linked with the PLC/task.
Inputs and outputs in the project tree
The representation in the System Manager depends on the number of configured channels and the respective multi-timestamp factor (MTSF).
MTI inputs provide information on the events:
- Status
▪
NoOfInputEvents: Number of events provided in this process data cycle with timestamp.
▪
InputState: Current state of input 0/1 when the process data are collected via EtherCAT. This corresponds to the classic Bool input and can be used in the same way
▪
InputBufferOverflow = TRUE: Indicates that more events arrived at the input than can be stored in the buffer. In CoE 0x80n0:13 there is an option to select whether further new events arriving at the nput are:
- no longer stored in the buffer (default), or
- stored in the buffer while older events are deleted
▪
InputCycleCounter: The 2-bit counter is used for input process data monitoring. With each process data exchange of the terminal it is incremented by one and is reset to zero when its maximum value of three is exceeded.
▪
EventsInInputBuffer: Number of saved events remaining in the buffer after the events transmitted for the current cycle have been removed
▪
InputOrderFeedback: Reflects the InputOrderCounter. Indicates whether the InputOrderCounter was received and processed by the terminal.
- InputBit-Array: Bit-by-bit input states as array to the corresponding timestamps
Bit 0: Input value after timestamp 1
Bit 1: Input value after timestamp 2
etc.
- InputEventTime x: List of 32-bit timestamps of the respective signal edge
MTI outputs are used for monitoring:
- Ctrl
▪
InputBufferReset TRUE: The channel buffer is cleared. This can make sense, e.g. in the case of a reported InputBufferOverflow, if the application requires this. Via the CoE setting 0x80n0:13 BufferOverflowBehavior the behavior on buffer overflow can be specified.
▪
InputOrderCounter: This counter is only for the asynchronous operation. Only if the counter is incremented by the controller, the channel outputs a new set of events to the fieldbus.
Each CoE channel (from 0x8000) has settings for operating mode selection:
Operating mode selection in CoE from 0x80n0
0x80n0:0 MTI Settings Ch. n=0...7 | Name | Entry | Description
0x80n0:01 | Enable digital filter |  | Activation of the filter for hiding spikes. The filter length can be entered in 0x80n0:14 DigitalFilterCount.
 | 0x80n0:01 FALSE |  | Filter is deactivated
 | 0x80n0:01 TRUE |  | Activation of the input filter
0x80n0:11 | Buffer reset behavior |  | Reset behavior in the event of a reset signal in the status register (PDO)
 | 0x80n0:11 FALSE | reset on rising edge | Reset is executed on rising edge. New data can then be buffered right away.
 | 0x80n0:11 TRUE | reset on high level | Buffer is held in reset as long as the signal is active. Can be used for muting, for example.
0x80n0:12 | Buffer mode |  | Setting of asynchronous or synchronous operation
 | 0x80n0:12 FALSE | Asynchronous (Buffered) | Asynchronous operation. To load the buffer entries into the PDO, the PLC has to increment the InputOrderCounter. This handshake requires one cycle for processing. The data are retained in the event of telegram malfunctions.
 | 0x80n0:12 TRUE | Synchronous | Synchronous operation. The first buffer entries are transferred cyclically to the PDO, as soon as data are available.
0x80n0:13 | Buffer overflow behavior |  | Configuration of the behavior if more than 32 events per channel have to be stored
 | 0x80n0:13 FALSE | Lock buffer | Overwriting of data is blocked, new events will be lost.
 | 0x80n0:13 TRUE | Overwrite oldest event | The oldest data are overwritten, new events are retained.
0x80n0:14 | Digital filter count |  | Number of microcycles until an applied input level as evaluated as valid. In this way spikes are filtered out. An entry of 1 results in disabling of the filter.


Commissioning of a MTI channel

Commissioning [image] Commissioning inputs [image] Commissioning of a MTI channel
Commissioning of a MTI channel
1. Synchronous or asynchronous operation?
▪
Synchronous (default): Synchronous operation should be selected if events are to be transferred from the channel to the controller as quickly as possible.
- In each EtherCAT cycle as many events as possible are loaded into the buffer. The number of events per channel can be read via EventsInInputBuffer. The maximum number of events that can be stored is 32.
- The MTSF is used to specify how many events per cycle are transferred from the buffer into the process data. The factor is currently limited to a maximum of 10.
- If the number of new events consistently exceeds the MTSF value, the buffer may overflow. Via the CoE 0x80n0:13 the behavior on buffer overflow can be configured for each channel.
▪
Asynchronous: If high data integrity is required, asynchronous handshake operation should be selected.
Application from the PLC:
- The channel signals the presence of data with NoOfInputEvents > 0
- The PLC can accept the data (input event states and timestamps).
- The InputOrderCounter has to be incremented (+ 1)
- In the next cycle the InputOrderFeedback should have assumed the value of the InputOrderCounter
- If further events are present in the buffer, they are shown in the process image.
- Starting from the beginning...
Setting in CoE x80n0:12 Asynchronous operation
2. Setting the multi-timestamping factor (MTSF)
To facilitate choosing an appropriate MTSF one should estimate the frequency at which level changes, i.e. events, are expected at the input. The multi-timestamping factor (MTSF) can then be selected. The factor indicates how many events per cycle are transferred from the buffer to the controller. With asynchronous transfer one should note that, due to the handshake, only half the number of events are retrieved per time period.
In order to avoid the transfer of excessive quantities of process data, the following configuration recommendations apply:
Synchronous transfer: MTSF ≥ (expected maximum number of input events per EtherCAT cycle) + 1
Asynchronous transfer MTSF ≥ 2x (expected maximum number of input-events per EtherCAT cycle) + 1
Example: At a cycle time of 1 ms, a maximum of 4 events/ms per channel are expected. All 8 channels of the EL1258 are to be used.
- Synchronous transfer: MTSF ≥ 5
Select "Multi-Timestamping 8 Ch. 5x" via the predefined PDO. If a somewhat larger number of events then occur in a cycle, these are buffered in the channel buffer; the buffer can then be emptied by the controller in the subsequent cycles.
Process data selection (predefined PDO) for synchronous transfer
- Asynchronous transfer: MTSF ≥ 9
Select "Multi-Timestamping 8 Ch. 10x" via the predefined PDO.
Process data selection (predefined PDO) for asynchronous transfer
For example, the process data of an input channel are represented as follows for MTSF = 1x, 5x and 10x:
Different MTSF
For each event there is a bit in the input array (right-justified) and a timestamp.
These process data are placeholders that accept events if there are any to be transmitted.
If fewer channels are required, predefined PDOs are also available for 4, 2 or 1 channel(s), with an MTSF of 1x, 2x, 5x and 10x respectively.
If fewer events arrive at the input than defined by the MTSF, the remaining PDOs are set to 0, in order to highlight this.
Example: NoOfInputEvents = 3 for MTSF=5 means that the first three PDO events (input value + timestamp) are supplied, the remaining two PDOs are set to 0.
3. When should the filter in CoE be activated? (default: deactivated)
The filter can be used to hide short signal jumps (spikes). They are regarded as invalid.
Procedure:
- The filter can be activated via the CoE 0x80n0:01 EnableDigitalFilter.
- If the filter activated is, the object 0x80n0:14 DigitalFilterCounter is used to set the timeframe over which the signal is regarded as valid. The timeframe should be specified as number of microcycles. “1” is synonymous with a deactivated filter.
- Finally you must check whether the macrocycle time achieved in the terminal with the selected settings is shorter than the EtherCAT cycle time.
- In online mode the current microcycle time can be viewed in the CoE.
Setting in CoE x80n0:01 & x80n0:14 for digital filter
Finally you must check whether the macrocycle time achieved in the terminal with the selected settings is shorter than the EtherCAT cycle time. This should generally be 20% longer than the macrocycle. The current macrocycle time can be read in the CoE directory 0xF900:08 CycleTime.
4. How can I test the input channel?
If an input channel is to be tested, the events are hardly visible in the System Manager, since in synchronous mode (default) they are immediately retrieved, and the process data always look "zeroed".
Remedy:
- Set the channel to asynchronous mode, so that the events are retrieved in handshake mode.
or
- Track event timestamp no. 1 in the online display:
Timestamp via online display
5. Processing of events in the PLC
The channel supplies 32-bit timestamp. The following function block can be used for scaling up to the convenient 64-bit format:
Download ( )


Commissioning in compatibility mode

Commissioning [image] Commissioning inputs [image] Commissioning in compatibility mode
Commissioning in compatibility mode
The multi-timestamp terminals can also be operated in compatibility mode with regard to the EL1252. The following settings are required:
Procedure:
 - The changeover should only be implemented via the predefined PDO:
Predefined PDOs for compatibility mode
- Via the CoE 0x80n0:0 TSI Settings (n = 8 ... F) the response for several events in a single cycle can be specified here. This is comparable to the EL1252. In this case MTSF =1.
0x80n0:0 TSI Settings Ch. n=8...F | Name | Entry | Description
80n0:01 | Pos Sample Mode |  | Defines the behavior for rising edges with several signals per cycle
 | 80n0:01 FALSE | Last edge | The last detected event is forwarded to the PLC
 | 80n0:01 TRUE | First edge | The first detected event is forwarded to the PLC
80n0:02 | Neg Sample Mode |  | Defines the behavior for falling edges with several signals per cycle
 | 80n0:02 FALSE | Last edge | The last detected event is forwarded to the PLC
 | 80n0:02 TRUE | First edge | The first detected event is forwarded to the PLC
Free PDO selection
No provision is made for free arrangement of the respective PDOs in compatibility mode.


Commissioning outputs

Commissioning [image] Commissioning outputs
Commissioning outputs
Table of contents
• Basic principles
• Commissioning an MTO channel
- 1. How do I test my actuator?
- 2. Setting the multi-timestamping factor (MTSF)
- 3. How are the outputs with timestamp activated?
• Commissioning in compatibility mode EL2252
Additional information
•
Basic principles
•
Commissioning an MTO channel
•
Commissioning in compatibility mode EL2252


Basic principles

Commissioning [image] Commissioning outputs [image] Basic principles
Basic principles
Each MTO channel (multi-timestamp output) has inputs and outputs in the cyclic process image, which have to be linked with the PLC/task.
Inputs and outputs in the project tree
Additional PDO from FW03/Rev 0017
From FW03 the CtrlWord is provided with the EnableManualOperation function. This function is located at bit position 4 of the CtrlWord and is effective only if it is configured with TRUE. This bit position was previously unused. Thus also newer EL1259/EL2258 terminals can be used in the application according to the Beckhoff IO compatibility rule if a predecessor revision (e.g. 0016) is used in the configuration. Conversely, older terminals with firmware < FW03 may of course not be used in the application if this function is to be used. In general, values not equal to the default value should not be written on the application side to variables/bits that have a placeholder/reserved function and have not yet been configured with a function. The placeholders can thus be configured for future functions as in this case.
MTO inputs returns diagnostic data in real-time for each channel:
- Status
▪
OutputShortCircuit: A short circuit is present at the channel.
▪
OutputBufferOverflow = TRUE: Indicates that more events were to be transferred at the output than can be stored in the buffer. In CoE 0x80n1:12 there is an option to select whether further new events arriving at the output are:
- no longer stored in the buffer (default), or
- stored in the buffer while older events are deleted
▪
OutputState: State of output 0/1 for transfer to the process data via EtherCAT. This corresponds to the classic Bool output and can be used in the same way
▪
InputCycleCounter: The 2-bit counter is used for input process data monitoring. With each process data exchange of the terminal it is incremented by one and is reset to zero when its maximum value of three is exceeded.
▪
EventsInInputBuffer: Number of saved events remaining in the buffer after the events transmitted for the current cycle have been removed.
▪
OutputOrderFeedback: Reflects the OutputOrderCounter. Indicates whether the OutputOrderCounter was received and processed by the terminal.
MTO outputs transfers in each cycle the events to be output to the channel, together with switching state 0/1 and switching time (timestamp)
- Ctrl
▪
OutputBufferReset =TRUE: The channel buffer is cleared. This can make sense, e.g. in the case of a reported OutputBufferOverflow, if the application requires this.
▪
ManualOutputState and EnableManualOperation: This bit can be used for manual switching of the channel output.
A distinction is made between two operating modes
1.
In the CoE the object 0x80n1:02 EnableManualOperation can be set to TRUE. This deactivates timestamp mode for this channel. The channel can then only be switched via the bit "Manual output state".
2.
In the process image the bit "Enable manual operation" is set. The output assumes the state that was specified via the bit "Manual output state". In contrast to the mode described above, processing of the timestamps continues in the background. When the bit "Enable manual operation" is set to False again, the output changes to the status it was allocated through processing of the timestamps.
▪
ForceOrder: In the default state (i.e. FALSE) only future events are processed. Events in the past can be executed by setting this PDO (i.e. TRUE). This PDO only becomes meaningful when the object 0x80n1:03 EnableTimeCheck is activated in the CoE.
▪
OutputOrderCounter: New switching orders are only entered in the process image when the counter is incremented by the controller.
▪
NoOfOutputEvents: Number of events to be output in this process data cycle
- Output Bit Array: Bit-by-bit output states as array to the corresponding timestamps
Bit 0: Output value timestamp 1
Bit 1: Output value timestamp 2
etc.
- Output event time x: List of 32-bit timestamps of the respective signal edge.
Each channel has corresponding settings for selection of the operating mode in the CoE from 0x80n1:
Operating mode selection in CoE from 0x80n1
0x80n1:0 MTO Settings Ch. n=0...7 | Name | Entry | Description
80n1:01 | Use as +24 V power supply |  | Switches the selected output in OP mode as 24 V power supply
 | 0x80n1:01 FALSE |  | Input disabled as power supply
 | 0x80n1:01 TRUE |  | Input activated as power supply
80n1:02 | Enable manual operation |  | Manual setting of inputs (without timestamp) is enabled. This can be used to test actuators or manual procedures.
 | 0x80n1:02 FALSE |  | Manual setting of inputs is blocked
 | 0x80n1:02 TRUE |  | Manual setting of inputs is possible
80n1:03 | Enable time check | See figure EnableTimeCheck Mode 1-3 | Output events must be transferred chronologically. If an event with "outdated" timestamp is transferred to a channel, the following decision options are available: Mode1: Enable time check = 0, Force order = no meaning:: No "outdated" events are transferred. The system waits, including overflow (4.29s) where appropriate, after which the switching order is executed. If EnableTimeCheck is activated, the timestamp width of 4.29 seconds is subdivided into 2.15 seconds past & 2.15 seconds future. In this case switching orders may only be up to 2.15 seconds in the future. The bit ForceOrder, which is available as PDO in the status register for each channel, is used to specify how the "outdated" timestamp should be handled. Mode2: Enable time check = 1, Force order = 0: "Outdated" event is discarded Mode3:Enable time check = 1, Force order = 1: "Outdated" event is output immediately, i.e. effectively delayed.
 | 0x80n1:03 FALSE
 | 0x80n1:03 TRUE
80n1:11 | Buffer reset behavior |  | Reset behavior in the event of a reset signal in the status register (PDO)
 | 0x80n1:11 Entry FALSE | Reset on rising edge | Reset is executed on rising edge. New data can then be buffered right away.
 | 0x80n1:11 Entry TRUE | Reset on high level | Buffer is held in reset as long as the signal is active. With high cycle times this can result in data loss.
80n1:12 | Buffer overflow behavior |  | Configuration of the behavior if more than 32 events per channel have to be stored
 | 0x80n1:12 Entry FALSE | Lock buffer | Overwriting of data is blocked, new events will be lost.
 | 0x80n1:12 Entry TRUE | Overwrite oldest event | The oldest data are overwritten, new events are retained.
EnableTimeCeck Mode 1-3


Commissioning an MTO channel

Commissioning [image] Commissioning outputs [image] Commissioning an MTO channel
Commissioning an MTO channel
1. How do I test my actuator?
How do I test my actuator? Via the regular process data the outputs cannot be controlled without a time specification. The following procedure can be used to test a connected actuator without time specification:
- In the CoE directory 0x80n1:02 EnableManualOperation set the bit for the respective channel.
- If the terminal is in OP state, the PDO ManualOutputState can be set in MTO Outputs Ctrl
Manual control
The output can be set to +24 V continuous power supply. If the terminal is in OP state, the output can be activated by setting the bit in CoE 0x80n1:01 UseAs+24VPowerSupply.
Output in +24 V continuous mode
2. Setting the multi-timestamping factor (MTSF)
To facilitate choosing an appropriate MTSF one should estimate how many switching orders per cycle are to be output. The multi-timestamping factor (MTSF) can then be selected. The factor indicates the maximum number of events that can be loaded into the buffer for each EtherCAT cycle.
In order to avoid the transfer of excessive quantities of process data, the following configuration recommendation applies:
MTSF ≥ expected maximum number of switching orders per EtherCAT cycle
Example: At a cycle time of 1 ms, a maximum of 5 switching orders/ms per channel are expected. All 8 channels of the EL2258 are to be used.
- MTSF = 5
- Select "Multi-Timestamping 8 Ch. 5x" via the predefined PDO.
Process data selection (predefined PDO) for synchronous transfer
For each switching order an output bit in the output array (right-justified) and a timestamp are available.
These process data are placeholders for the switching orders from the PLC to the channel.
If fewer channels are required, predefined PDOs are also available for 4, 2 or 1 channel(s), with an MTSF of 1x, 2x, 5x and 10x respectively.
3. How are the outputs with timestamp activated?
Procedure during each cycle:
- Place all switching orders calculated in the PLC (output state+timestamp[32 bit]) in the PDO
- Set NoOfOutputEvents = x (e.g. x=5 if 5 valid switching orders are sent, x must be <= MTSF)
- Increment OutputOrderCounter (+ 1). This is the instruction that forces the channel to accept switching orders.
The channel returns OutputOrderFeedback = OutputOrderCounter, once it has accepted the switching orders. This is already the case in the next EtherCAT cycle, as long as the macrocycle time was not violated. Therefore two application types are possible:
- Like with a handshake, the PLC always waits to ascertain whether in the next cycle the channel has responded with OutputOrderFeedback = OutputOrderCounter before sending the next set of switching orders. This reduces the number of switching orders that can be executed per second by 50%.
- The PLC does not wait, but continuously sends new switching orders to the channel in each cycle. Nevertheless, it is advisable to check OutputOrderFeedback = OutputOrderCounter in order to ascertain whether a set of switching orders may already have been accepted in the next cycle.
If no new switching orders are to be sent to the channel during a cycle, OutputOrderCounter should simply be left unchanged.
It is recommended to always use (signed) 64-bit times in the PLC. The lower half this time variable can then simply be mapped to the channel PDO. However, note that timestamps/switching orders calculated in the PLC in this way must not be more than approx. 2 seconds in the future.


Commissioning in compatibility mode EL2252

Commissioning [image] Commissioning outputs [image] Commissioning in compatibility mode EL2252
Commissioning in compatibility mode EL2252
The multi-timestamp terminals can also be operated in compatibility mode with regard to the EL2252. The following settings are required:
Procedure:
 - The changeover should only be implemented via the predefined PDO:
Predefined PDOs for compatibility mode
- CoE 0x70n0:0 MTO outputs Ch.n (n=8...F) can be used for configuration, similar to the EL2252. In addition the EL2252 offers a tristate PDO for high-resistance switching of the channels. This PDO is not available for the EL2258.
0x70n0:0 MTO Output Ch. n=8...F | Name | Entry | Description
70n1:01 | Output |  | Activates output 0 V/24 V of channel n=1..8
 | 0x70n0:01 FALSE |  | 0 V present at the output
 | 0x70n0:01 TRUE |  | 24 V present at the output
70n1:11 | Activate |  | This byte activates a new start time in the terminal through the transition 0 --> 3
70n0:41 | Start Time |  | 64-bit value of the next desired switching event
Free PDO selection
No provision is made for free arrangement of the respective PDOs in compatibility mode.


Distributed Clocks settings

Commissioning [image] Distributed Clocks settings
Distributed Clocks settings
Determination of the current Distributed Clock time
If the current distributed clock time is required in a PLC cycle, this can
1.
be linked via an input variable of the EtherCAT master
2.
displayed directly by the terminal as a 64-bit system time
Functions for data types with 64-bit width
A selection of functions for handling 64-bit numbers is available under Beckhoff TwinCAT in the TcUtilities.lib library. Longer execution times are required here than is the case with standard, 32-bit data types.
A data type with a width of 64-bits is defined in TcEthercat.lib as T_DCTIME or in TcUtilities.lib as T_LARGE_INTEGER.
1. Via the EtherCAT master
The EtherCAT master can display a copy of the current master distributed clock. To this end activate the setting "Show DC System Time (64 bit)" in the EtherCAT device --> EtherCAT tab --> Advanced Settings --> Distributed Clocks (Fig. Activation of the master distributed clock display).
Activation of the master distributed clock display
The process image of the EtherCAT master now looks as shown in Fig. Extended process image of the EtherCAT master:
Extended process image of the EtherCAT master
SYSTIME
The EtherCAT master value DcSysTime is to be used with care and should serve only as a coarse indication as to which time zone (order of magnitude: 1-2 task cycles) the Distributed Clocks system is currently in.
This is due to the fact that the local time in the terminal is read into associated buffers several µs before retrieving frame. The EtherCAT strand then requires some time for transporting the process data to the master. Due to the character of the visualization, the online display in the TwinCAT System Manager is accurate at best to a three-figure millisecond range. Within a PLC the SysTime process data may also be outdated to a certain degree: depending on when the analysis takes place in the program code, the process data may be several µs/ms older. If responses of an EtherCAT strand (e.g. an EL2258 output terminal) are to be based on a SysTime read in this way, 2-3 PLC cycles should be taken into account as a buffer.
It is more appropriate to use an EL2258 with other EtherCAT slaves that generate a timestamp based on ambient influences, such as the EL1252.
Alternatively, functions can also be called at NC/PLC runtime that immediately return the current DC time, e.g. F_GetCurDcTickTime. Refer to the notes on the TwinCAT time sources in the EtherCAT system documentation.
2. Terminal's own SysTime
The MultiTimestamp terminals can offer the local DC system time of the terminal directly as a process data:
Setting SysTime
To this end, the "PDO DEV Input Device" has to be activated in the System Manager:
▪
for EL1258: 0x1A28
▪
for EL1259: 0x1A38
▪
for EL2258: 0x1A10
SysTime
The value DcSysTime of the terminal is to be used with care and should serve only as a coarse indication as to which time zone (order of magnitude: +/-1 task cycle) the Distributed Clocks system is currently in. The reason is that the local time in the terminal is only determined once per macro cycle, without specification of the exact time.
It is more appropriate to use an EL2258 with other EtherCAT slaves that generate a timestamp based on ambient influences, such as the EL1252.
Alternatively, functions can also be called at NC/PLC runtime that immediately return the current DC time, e.g. F_GetCurDcTickTime. Refer to the notes on the TwinCAT time sources in the EtherCAT system documentation.
SysTime 32/64 bit
The PDO SysTime is filled as follows:
- in "CompatibleModus" the 64 bit variable is filled with the full 64 bit distributed clock time
- in "MultiTimeStamp Modus" the 64 bit variable is only filled with the lower 32 bit, since this is also the time width of the time stamps.


CoE object description and parameterization

Commissioning [image] CoE object description and parameterization
CoE object description and parameterization
Additional information
•
EL1258
•
EL1259
•
EL2258


EL1258

Commissioning [image] CoE object description and parameterization [image] EL1258
EL1258
Additional information
•
Object description – specific objects
•
Object description - standard objects


Object description – specific objects

Commissioning [image] CoE object description and parameterization [image] EL1258 [image] Object description – specific objects
Object description – specific objects
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Parameterization via the CoE list (CAN over EtherCAT)
The terminal is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs). Please note the following general CoE information when using/manipulating the CoE parameters:
- Keep a startup list if components have to be replaced
- Differentiation between online/offline dictionary, existence of current XML description
- Use "CoE reload" for resetting changes
Additional information
•
Restore object
•
Configuration data
•
Input data
•
Output data
•
Diagnostic data
•
Information data
•
Command object


Restore object

Commissioning [image] CoE object description and parameterization [image] EL1258 [image] Object description – specific objects [image] Restore object
Restore object
Index 1011 Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default parameters | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to “0x64616F6C” in the set value dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)


Configuration data

Commissioning [image] CoE object description and parameterization [image] EL1258 [image] Object description – specific objects [image] Configuration data
Configuration data
Index 8pp0 MTI settings (for 00 ≤ pp ≤ 07; Ch. 1 to Ch. 8)
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8pp0:0 | MTI settings |  |  | UINT8 | RO | 0x14 (20dec)
8pp0:01 | Enable digital filter | Activation of the filter to hide spikes. The filter length should be entered in 8pp0:14 "DigitalFilterCount" (further explanation see here). |  | BOOLEAN | RW | 0x00 (0dec)
8pp0:11 | Buffer reset behavior | Specifies the behavior of the "Input buffer reset" bit Permitted values: |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | Reset on rising edge: The buffer is cleared with a rising edge of "Input buffer reset"
 |  | 1 | Reset on high level: The buffer is cleared with a rising edge of "Input buffer reset" and does not accept new values until "Input buffer reset" is reset.
8pp0:12 | Buffer mode | Specifies whether handshaking is to be used for retrieving the values from the buffer (transmission integrity) or whether new values are to be transferred directly with each PLC cycle (faster). Permitted values (further explanation see here): |  | UINT16 | RW | 0x0001 (1dec)
 |  | 0 | Asynchronous (Buffered): The arrival of new events must be acknowledged by the PLC. To this end the byte "No of input events" must be monitored in the PLC program. If it is greater than zero the pending events can be taken over from the process image. Subsequently the byte "Input order counter" must be incremented. This signals the terminal that the events were accepted and new data can be created in the next cycle.
 |  | 1 | Synchronous: New events are automatically transferred with each PLC cycle
8pp0:13 | Buffer overflow behavior | Specifies the behavior in the event of buffer overflow Permitted values: |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | Lock buffer: New events are discarded
 |  | 1 | Overwrite oldest event: New events overwrite the last events in the buffer
8pp0:14 | Digital filter count | Defines the number of event samples to ensure transfer into the buffer (further explanation see here). |  | UINT16 | RW | 0x0001 (1dec)
Index 8ppF MTI Vendor data (for 00 ≤ pp ≤ 07; Ch. 1 to Ch. 8)
Index (hex) | Name | Meaning | Data type | Flags | Default
8ppF:0 | MTI Vendor data |  | UINT8 | RO | 0x12 (18dec)
8ppF:11 | Offset pos | This object can be used to move the input time of the rising edges. This setting is left to the manufacturer. | INT32 | RW | 0x00000000 (0dec)
8ppF:12 | Offset neg | This object can be used to move the input time of the falling edges. This setting is left to the manufacturer. | INT32 | RW | 0x00000000 (0dec)
Index 8pp0 TSI Settings (for 08 ≤ pp ≤ 0F; Ch. 1 to Ch. 8)
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8pp0:0 | TSI Settings |  |  | UINT8 | RO | 0x02 (2dec)
8pp0:01 | Pos Sample Mode | During each PLC cycle only one rising edge may be detected at the terminal input. If several edges arrive during a cycle, this bit can be used to decide which edge should be shown in the process image. Permitted values: |  | BIT1 | RW | 0x00 (0dec)
 |  | 0 | Last edge: The last edge of the preceding PLC cycle is shown
 |  | 1 | First edge: The first edge of the preceding PLC cycle is shown
8pp0:02 | Neg Sample Mode | During each PLC cycle only one falling edge may be detected at the terminal input. If several edges arrive during a cycle, this bit can be used to decide which edge should be shown in the process image. Permitted values: |  | BIT1 | RW | 0x00 (0dec)
 |  | 0 | Last edge: The last edge of the preceding PLC cycle is shown
 |  | 1 | First edge: The first edge of the preceding PLC cycle is shown
Index 8ppF TSI Vendor data (for 08 ≤ pp ≤ 0F; Ch. 1 to Ch. 8)
Index (hex) | Name | Meaning | Data type | Flags | Default
8ppF:0 | TSI Vendor data |  | UINT8 | RO | 0x12 (18dec)
8ppF:11 | Offset pos | This object can be used to move the input time of the rising edges. This setting is left to the manufacturer. | INT32 | RW | 0x00000000 (0dec)
8ppF:12 | Offset neg | This object can be used to move the input time of the falling edges. This setting is left to the manufacturer. | INT32 | RW | 0x00000000 (0dec)


Input data

Commissioning [image] CoE object description and parameterization [image] EL1258 [image] Object description – specific objects [image] Input data
Input data
Index 6pp1 MTI inputs (for 00 ≤ pp ≤ 07; Ch. 1 to Ch. 8)
Index (hex) | Name | Meaning | Data type | Flags | Default
6pp1:0 | MTI inputs |  | UINT8 | RO | 0x00 (0dec)
6pp1:01 | No of input events | Signals the number of new timestamps available in the process image. If three is returned, for example, only the objects "Input event state 1...3" and "Input event time 1...3" are valid. | UINT8 | RO | 0x00 (0dec)
6pp1:09 | Input state | Indicates the current input state at the time of the process data cycle. | BOOLEAN | RO | 0x00 (0dec)
6pp1:0A | Input buffer overflow | More events occurred at the input than elements were free in the buffer for the channel. | BOOLEAN | RO | 0x00 (0dec)
6pp1:0F | Input cycle counter | Is incremented with each process data cycle and switches to 0 after its maximum value of 3. | BIT2 | RO | 0x00 (0dec)
6pp1:11 | Events in input buffer | Signals the number of events currently in the buffer. | UINT8 | RO | 0x00 (0dec)
6pp1:12 | Input order feedback | This byte reflects the state of the "Input order counter" byte (further explanation see here). | UINT8 | RO | 0x00 (0dec)
6pp1:21 | Input event state 1 | Indicates whether the event was a rising (1) or a falling (0) edge. | BOOLEAN | RO | 0x00 (0dec)
6pp1:22 | Input event state 2 | ... | BOOLEAN | RO | 0x00 (0dec)
6pp1:2A | Input event state 10 | ... | BOOLEAN | RO | 0x00 (0dec)
6pp1:41 | Input event time 1 | 32-bit timestamp for the corresponding "Input event state n" | UINT32 | RO | 0x00000000 (0dec)
6pp1:42 | Input event time 2 | ... | UINT32 | RO | 0x00000000 (0dec)
6pp1:4A | Input event time 10 | ... | UINT32 | RO | 0x00000000 (0dec)
Index 6pp0 TSI Inputs (for 08 ≤ pp ≤ 0F; Ch. 1 to Ch. 8)
Index (hex) | Name | Meaning | Data type | Flags | Default
6pp0:0 | TSI Inputs |  | UINT8 | RO | 0x00 (0dec)
6pp0:01 | Input | Current input status | BOOLEAN | RO | 0x00 (0dec)
6pp0:09 | Status | Bit0: Is set for one cycle if a rising edge was detected. Bit1: Is set for one cycle if a falling edge was detected. | UINT8 | RO | 0x00 (0dec)
6pp0:41 | LatchPos | Timestamp of the rising edge | UINT64 | RO |
6pp0:42 | LatchNeg | Timestamp of the falling edge | UINT64 | RO |
Index F611 DEV Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
F611:0 | DEV Inputs |  | UINT8 | RO | 0x21 (33dec)
F611:02 | Undervoltage Up | The nominal operating voltage at the power contacts was significantly below the minimum value. | BOOLEAN | RO | 0x00 (0dec)
F611:03 | Overtemperature | Overtemperature fault: The temperature of the input or output blocks is too high. For output terminals check whether one of the channels is affected by a short circuit. | BOOLEAN | RO | 0x00 (0dec)
F611:04 | Checksum error | An error occurred in the internal data transfer | BOOLEAN | RO | 0x00 (0dec)
F611:21 | SysTime | DC timestamp of the last input mapping. This timestamp should not be used as reference. (information on DC reference times). | UINT64 | RO |


Output data

Commissioning [image] CoE object description and parameterization [image] EL1258 [image] Object description – specific objects [image] Output data
Output data
Index 7pp0 MTI outputs (for 00 ≤ pp ≤ 07; Ch. 1 to Ch. 8)
Index (hex) | Name | Meaning | Data type | Flags | Default
7pp0:0 | MTI outputs |  | UINT8 | RO | 0x00 (0dec)
7pp0:01 | Input buffer reset | Removes all elements from the buffer Clearing can be achieved through a rising edge or continuously by applying 1 at this bit. The behavior can be parameterized via the CoE object 0x8pp0:11 ("Buffer reset behavior"). | BOOLEAN | RO | 0x00 (0dec)
7pp0:11 | Input order counter | This bit indicates to the terminal that the input events were accepted from the process image and the terminal can copy a new set of input events from the buffer into the process image during the next cycle (see buffer mode). | UINT8 | RO | 0x00 (0dec)


Diagnostic data

Commissioning [image] CoE object description and parameterization [image] EL1258 [image] Object description – specific objects [image] Diagnostic data
Diagnostic data
Index App0 MTI Diag data (for 00 ≤ pp ≤ 07; Ch. 1 to Ch. 8)
Index (hex) | Name | Meaning | Data type | Flags | Default
App0:0 | MTI Diag data |  | UINT8 | RO | 0x02 (2dec)
App0:01 | Overtemperature | The internal terminal temperature is above the valid range. For terminals with output channels check the outputs for short circuit. | BOOLEAN | RO | 0x00 (0dec)
App0:02 | Undervoltage | The voltage at the power contacts is outside the valid range. | BOOLEAN | RO | 0x00 (0dec)
Index A001 MTI common Diag data
Index (hex) | Name | Meaning | Data type | Flags | Default
A001:0 | MTI common Diag data |  | UINT8 | RO | 0x11 (17dec)
A001:11 | Checksum error counter | An error occurred in the internal data transfer | UINT16 | RO | 0x0000 (0dec)
Index A080 TSI common Diag data
Index (hex) | Name | Meaning | Data type | Flags | Default
A080:0 | TSI common Diag data |  | UINT8 | RO | 0x11 (17dec)
A080:11 | Checksum error counter | An error occurred in the internal data transfer | UINT16 | RO | 0x0000 (0dec)


Information data

Commissioning [image] CoE object description and parameterization [image] EL1258 [image] Object description – specific objects [image] Information data
Information data
Index F900 DEV Info data
Index (hex) | Name | Meaning | Data type | Flags | Default
F900:0 | DEV Info data |  | UINT8 | RO | 0x00 (0dec)
F900:08 | Cycle Time | Indicates the smallest possible cycle time that can be set [ns]. | UINT32 | RO | 0x00000000 (0dec)
F900:09 | Sample time | Indicates the sampling time of the inputs and outputs [ns]. | UINT32 | RO | 0x00000000 (0dec)


Command object

Commissioning [image] CoE object description and parameterization [image] EL1258 [image] Object description – specific objects [image] Command object
Command object
Index FB00 command
The command object was implemented for future use. Currently no commands are supported.
Index (hex) | Name | Meaning | Data type | Flags | Default
FB00:0 | Command |  | UINT8 | RO | 0x03 (3dec)
FB00:01 | Request | Commands can be sent to the terminal via the request object. | OCTET-STRING[2] | RW | {0}
FB00:02 | Status | Status of the command currently being executed | UINT8 | RO | 0x00 (0dec)
FB00:03 | Response | Optional response value of the command | OCTET-STRING[6] | RO | {0}


Object description - standard objects

Commissioning [image] CoE object description and parameterization [image] EL1258 [image] Object description - standard objects
Object description - standard objects
Index 1000 Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: the Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x00001389 (5001dec)
Index 1008 Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EL1258
Index 1009 Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO |
Index 100A Software version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO | 99
Index 1018 Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x04EA3052 (82456658dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the low word (bit 0-15) indicates the special terminal number, the high word (bit 16-31) refers to the device description | UINT32 | RO | 0x00000000 (0dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the low byte (bit 0-7) of the low word contains the year of production, the high byte (bit 8-15) of the low word contains the week of production, the high word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 Backup parameter handling
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | Information for standardized loading and saving of backup entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum across all backup entries of the EtherCAT slave | UINT32 | RO | 0x00000000 (0dec)
Index 1600 MTI RxPDO-Map Outputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1600:0 | MTI RxPDO-Map Outputs Ch.1 | PDO Mapping RxPDO 1 | UINT8 | RO | 0x04 (4dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (MTI outputs Ch.1), entry 0x01 (Input buffer reset)) | UINT32 | RO | 0x7000:01, 1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (MTI outputs Ch.1), entry 0x11 (Input order counter)) | UINT32 | RO | 0x7000:11, 8
1600:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1601 MTI RxPDO-Map Outputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1601:0 | MTI RxPDO-Map Outputs Ch.2 | PDO Mapping RxPDO 2 | UINT8 | RO | 0x04 (4dec)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (MTI outputs Ch.2), entry 0x01 (Input buffer reset)) | UINT32 | RO | 0x7010:01, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (MTI outputs Ch.2), entry 0x11 (Input order counter)) | UINT32 | RO | 0x7010:11, 8
1601:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1602 MTI RxPDO-Map Outputs Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1602:0 | MTI RxPDO-Map Outputs Ch.3 | PDO Mapping RxPDO 3 | UINT8 | RO | 0x04 (4dec)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (MTI outputs Ch.3), entry 0x01 (Input buffer reset)) | UINT32 | RO | 0x7020:01, 1
1602:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1602:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7020 (MTI outputs Ch.3), entry 0x11 (Input order counter)) | UINT32 | RO | 0x7020:11, 8
1602:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1603 MTI RxPDO-Map Outputs Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
1603:0 | MTI RxPDO-Map Outputs Ch.4 | PDO Mapping RxPDO 4 | UINT8 | RO | 0x04 (4dec)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7030 (MTI outputs Ch.4), entry 0x01 (Input buffer reset)) | UINT32 | RO | 0x7030:01, 1
1603:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1603:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7030 (MTI outputs Ch.4), entry 0x11 (Input order counter)) | UINT32 | RO | 0x7030:11, 8
1603:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1604 MTI RxPDO-Map Outputs Ch.5
Index (hex) | Name | Meaning | Data type | Flags | Default
1604:0 | MTI RxPDO-Map Outputs Ch.5 | PDO Mapping RxPDO 5 | UINT8 | RO | 0x04 (4dec)
1604:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7040 (MTI outputs Ch.5), entry 0x01 (Input buffer reset)) | UINT32 | RO | 0x7040:01, 1
1604:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1604:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7040 (MTI outputs Ch.5), entry 0x11 (Input order counter)) | UINT32 | RO | 0x7040:11, 8
1604:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1605 MTI RxPDO-Map Outputs Ch.6
Index (hex) | Name | Meaning | Data type | Flags | Default
1605:0 | MTI RxPDO-Map Outputs Ch.6 | PDO Mapping RxPDO 6 | UINT8 | RO | 0x04 (4dec)
1605:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7050 (MTI outputs Ch.6), entry 0x01 (Input buffer reset)) | UINT32 | RO | 0x7050:01, 1
1605:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1605:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7050 (MTI outputs Ch.6), entry 0x11 (Input order counter)) | UINT32 | RO | 0x7050:11, 8
1605:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1606 MTI RxPDO-Map Outputs Ch.7
Index (hex) | Name | Meaning | Data type | Flags | Default
1606:0 | MTI RxPDO-Map Outputs Ch.7 | PDO Mapping RxPDO 7 | UINT8 | RO | 0x04 (4dec)
1606:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7060 (MTI outputs Ch.7), entry 0x01 (Input buffer reset)) | UINT32 | RO | 0x7060:01, 1
1606:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1606:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7060 (MTI outputs Ch.7), entry 0x11 (Input order counter)) | UINT32 | RO | 0x7060:11, 8
1606:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1607 MTI RxPDO-Map Outputs Ch.8
Index (hex) | Name | Meaning | Data type | Flags | Default
1607:0 | MTI RxPDO-Map Outputs Ch.8 | PDO Mapping RxPDO 8 | UINT8 | RO | 0x04 (4dec)
1607:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7070 (MTI outputs Ch.8), entry 0x01 (Input buffer reset)) | UINT32 | RO | 0x7070:01, 1
1607:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1607:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7070 (MTI outputs Ch.8), entry 0x11 (Input order counter)) | UINT32 | RO | 0x7070:11, 8
1607:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1A00 MTI TxPDO-Map Inputs 10x Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A00:0 | MTI TxPDO-Map Inputs 10x Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x1C (28dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x01 (No of input events)) | UINT32 | RO | 0x6001:01, 8
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x09 (Input state)) | UINT32 | RO | 0x6001:09, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6001:0A, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6001:0F, 2
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6001:11, 8
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6001:12, 8
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6001:21, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6001:22, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6001:23, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6001:24, 1
1A00:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6001:25, 1
1A00:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x26 (Input event state 6)) | UINT32 | RO | 0x6001:26, 1
1A00:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x27 (Input event state 7)) | UINT32 | RO | 0x6001:27, 1
1A00:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x28 (Input event state 8)) | UINT32 | RO | 0x6001:28, 1
1A00:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x29 (Input event state 9)) | UINT32 | RO | 0x6001:29, 1
1A00:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x2A (Input event state 10)) | UINT32 | RO | 0x6001:2A, 1
1A00:12 | SubIndex 018 | 18. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1A00:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6001:41, 32
1A00:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6001:42, 32
1A00:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6001:43, 32
1A00:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6001:44, 32
1A00:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6001:45, 32
1A00:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x46 (Input event time 6)) | UINT32 | RO | 0x6001:46, 32
1A00:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x47 (Input event time 7)) | UINT32 | RO | 0x6001:47, 32
1A00:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x48 (Input event time 8)) | UINT32 | RO | 0x6001:48, 32
1A00:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x49 (Input event time 9)) | UINT32 | RO | 0x6001:49, 32
1A00:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x4A (Input event time 10)) | UINT32 | RO | 0x6001:4A, 32
Index 1A01 MTI TxPDO-Map Inputs 5x Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A01:0 | MTI TxPDO-Map Inputs 5x Ch.1 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x12 (18dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x01 (No of input events)) | UINT32 | RO | 0x6001:01, 8
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x09 (Input state)) | UINT32 | RO | 0x6001:09, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6001:0A, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6001:0F, 2
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6001:11, 8
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6001:12, 8
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6001:21, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6001:22, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6001:23, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6001:24, 1
1A01:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6001:25, 1
1A01:0D | SubIndex 013 | 13. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1A01:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6001:41, 32
1A01:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6001:42, 32
1A01:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6001:43, 32
1A01:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6001:44, 32
1A01:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6001:45, 32
Index 1A02 MTI TxPDO-Map Inputs 2x Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A02:0 | MTI TxPDO-Map Inputs 2x Ch.1 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x0C (12dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x01 (No of input events)) | UINT32 | RO | 0x6001:01, 8
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x09 (Input state)) | UINT32 | RO | 0x6001:09, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6001:0A, 1
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6001:0F, 2
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6001:11, 8
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6001:12, 8
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6001:21, 1
1A02:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6001:22, 1
1A02:0A | SubIndex 010 | 10. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1A02:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6001:41, 32
1A02:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6001:42, 32
Index 1A03 MTI TxPDO-Map Inputs 1x Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A03:0 | MTI TxPDO-Map Inputs 1x Ch.1 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x0A (10dec)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x01 (No of input events)) | UINT32 | RO | 0x6001:01, 8
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x09 (Input state)) | UINT32 | RO | 0x6001:09, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6001:0A, 1
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6001:0F, 2
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6001:11, 8
1A03:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6001:12, 8
1A03:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6001:21, 1
1A03:09 | SubIndex 009 | 9. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1A03:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6001:41, 32
Index 1A04 MTI TxPDO-Map Inputs 10x Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A04:0 | MTI TxPDO-Map Inputs 10x Ch.2 | PDO Mapping TxPDO 5 | UINT8 | RO | 0x1C (28dec)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x01 (No of input events)) | UINT32 | RO | 0x6011:01, 8
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x09 (Input state)) | UINT32 | RO | 0x6011:09, 1
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6011:0A, 1
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6011:0F, 2
1A04:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6011:11, 8
1A04:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6011:12, 8
1A04:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6011:21, 1
1A04:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6011:22, 1
1A04:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6011:23, 1
1A04:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6011:24, 1
1A04:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6011:25, 1
1A04:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x26 (Input event state 6)) | UINT32 | RO | 0x6011:26, 1
1A04:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x27 (Input event state 7)) | UINT32 | RO | 0x6011:27, 1
1A04:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x28 (Input event state 8)) | UINT32 | RO | 0x6011:28, 1
1A04:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x29 (Input event state 9)) | UINT32 | RO | 0x6011:29, 1
1A04:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x2A (Input event state 10)) | UINT32 | RO | 0x6011:2A, 1
1A04:12 | SubIndex 018 | 18. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1A04:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6011:41, 32
1A04:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6011:42, 32
1A04:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6011:43, 32
1A04:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6011:44, 32
1A04:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6011:45, 32
1A04:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x46 (Input event time 6)) | UINT32 | RO | 0x6011:46, 32
1A04:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x47 (Input event time 7)) | UINT32 | RO | 0x6011:47, 32
1A04:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x48 (Input event time 8)) | UINT32 | RO | 0x6011:48, 32
1A04:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x49 (Input event time 9)) | UINT32 | RO | 0x6011:49, 32
1A04:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x4A (Input event time 10)) | UINT32 | RO | 0x6011:4A, 32
Index 1A05 MTI TxPDO-Map Inputs 5x Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A05:0 | MTI TxPDO-Map Inputs 5x Ch.2 | PDO Mapping TxPDO 6 | UINT8 | RO | 0x12 (18dec)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x01 (No of input events)) | UINT32 | RO | 0x6011:01, 8
1A05:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x09 (Input state)) | UINT32 | RO | 0x6011:09, 1
1A05:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6011:0A, 1
1A05:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A05:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6011:0F, 2
1A05:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6011:11, 8
1A05:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6011:12, 8
1A05:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6011:21, 1
1A05:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6011:22, 1
1A05:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6011:23, 1
1A05:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6011:24, 1
1A05:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6011:25, 1
1A05:0D | SubIndex 013 | 13. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1A05:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6011:41, 32
1A05:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6011:42, 32
1A05:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6011:43, 32
1A05:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6011:44, 32
1A05:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6011:45, 32
Index 1A06 MTI TxPDO-Map Inputs 2x Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A06:0 | MTI TxPDO-Map Inputs 2x Ch.2 | PDO Mapping TxPDO 7 | UINT8 | RO | 0x0C (12dec)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x01 (No of input events)) | UINT32 | RO | 0x6011:01, 8
1A06:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x09 (Input state)) | UINT32 | RO | 0x6011:09, 1
1A06:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6011:0A, 1
1A06:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A06:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6011:0F, 2
1A06:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6011:11, 8
1A06:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6011:12, 8
1A06:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6011:21, 1
1A06:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6011:22, 1
1A06:0A | SubIndex 010 | 10. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1A06:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6011:41, 32
1A06:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6011:42, 32
Index 1A07 MTI TxPDO-Map Inputs 1x Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A07:0 | MTI TxPDO-Map Inputs 1x Ch.2 | PDO Mapping TxPDO 8 | UINT8 | RO | 0x0A (10dec)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x01 (No of input events)) | UINT32 | RO | 0x6011:01, 8
1A07:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x09 (Input state)) | UINT32 | RO | 0x6011:09, 1
1A07:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6011:0A, 1
1A07:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A07:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6011:0F, 2
1A07:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6011:11, 8
1A07:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6011:12, 8
1A07:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6011:21, 1
1A07:09 | SubIndex 009 | 9. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1A07:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6011:41, 32
Index 1A08 MTI TxPDO-Map Inputs 10x Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1A08:0 | MTI TxPDO-Map Inputs 10x Ch.3 | PDO Mapping TxPDO 9 | UINT8 | RO | 0x1C (28dec)
1A08:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x01 (No of input events)) | UINT32 | RO | 0x6021:01, 8
1A08:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x09 (Input state)) | UINT32 | RO | 0x6021:09, 1
1A08:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6021:0A, 1
1A08:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A08:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6021:0F, 2
1A08:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6021:11, 8
1A08:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6021:12, 8
1A08:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6021:21, 1
1A08:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6021:22, 1
1A08:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6021:23, 1
1A08:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6021:24, 1
1A08:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6021:25, 1
1A08:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x26 (Input event state 6)) | UINT32 | RO | 0x6021:26, 1
1A08:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x27 (Input event state 7)) | UINT32 | RO | 0x6021:27, 1
1A08:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x28 (Input event state 8)) | UINT32 | RO | 0x6021:28, 1
1A08:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x29 (Input event state 9)) | UINT32 | RO | 0x6021:29, 1
1A08:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x2A (Input event state 10)) | UINT32 | RO | 0x6021:2A, 1
1A08:12 | SubIndex 018 | 18. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1A08:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6021:41, 32
1A08:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6021:42, 32
1A08:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6021:43, 32
1A08:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6021:44, 32
1A08:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6021:45, 32
1A08:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x46 (Input event time 6)) | UINT32 | RO | 0x6021:46, 32
1A08:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x47 (Input event time 7)) | UINT32 | RO | 0x6021:47, 32
1A08:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x48 (Input event time 8)) | UINT32 | RO | 0x6021:48, 32
1A08:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x49 (Input event time 9)) | UINT32 | RO | 0x6021:49, 32
1A08:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x4A (Input event time 10)) | UINT32 | RO | 0x6021:4A, 32
Index 1A09 MTI TxPDO-Map Inputs 5x Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1A09:0 | MTI TxPDO-Map Inputs 5x Ch.3 | PDO Mapping TxPDO 10 | UINT8 | RO | 0x12 (18dec)
1A09:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x01 (No of input events)) | UINT32 | RO | 0x6021:01, 8
1A09:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x09 (Input state)) | UINT32 | RO | 0x6021:09, 1
1A09:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6021:0A, 1
1A09:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A09:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6021:0F, 2
1A09:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6021:11, 8
1A09:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6021:12, 8
1A09:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6021:21, 1
1A09:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6021:22, 1
1A09:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6021:23, 1
1A09:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6021:24, 1
1A09:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6021:25, 1
1A09:0D | SubIndex 013 | 13. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1A09:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6021:41, 32
1A09:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6021:42, 32
1A09:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6021:43, 32
1A09:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6021:44, 32
1A09:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6021:45, 32
Index 1A0A MTI TxPDO-Map Inputs 2x Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1A0A:0 | MTI TxPDO-Map Inputs 2x Ch.3 | PDO Mapping TxPDO 11 | UINT8 | RO | 0x0C (12dec)
1A0A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x01 (No of input events)) | UINT32 | RO | 0x6021:01, 8
1A0A:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x09 (Input state)) | UINT32 | RO | 0x6021:09, 1
1A0A:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6021:0A, 1
1A0A:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A0A:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6021:0F, 2
1A0A:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6021:11, 8
1A0A:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6021:12, 8
1A0A:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6021:21, 1
1A0A:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6021:22, 1
1A0A:0A | SubIndex 010 | 10. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1A0A:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6021:41, 32
1A0A:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6021:42, 32
Index 1A0B MTI TxPDO-Map Inputs 1x Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1A0B:0 | MTI TxPDO-Map Inputs 1x Ch.3 | PDO Mapping TxPDO 12 | UINT8 | RO | 0x0A (10dec)
1A0B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x01 (No of input events)) | UINT32 | RO | 0x6021:01, 8
1A0B:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x09 (Input state)) | UINT32 | RO | 0x6021:09, 1
1A0B:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6021:0A, 1
1A0B:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A0B:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6021:0F, 2
1A0B:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6021:11, 8
1A0B:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6021:12, 8
1A0B:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6021:21, 1
1A0B:09 | SubIndex 009 | 9. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1A0B:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6021:41, 32
Index 1A0C MTI TxPDO-Map Inputs 10x Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
1A0C:0 | MTI TxPDO-Map Inputs 10x Ch.4 | PDO Mapping TxPDO 13 | UINT8 | RO | 0x1C (28dec)
1A0C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x01 (No of input events)) | UINT32 | RO | 0x6031:01, 8
1A0C:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x09 (Input state)) | UINT32 | RO | 0x6031:09, 1
1A0C:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6031:0A, 1
1A0C:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A0C:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6031:0F, 2
1A0C:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6031:11, 8
1A0C:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6031:12, 8
1A0C:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6031:21, 1
1A0C:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6031:22, 1
1A0C:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6031:23, 1
1A0C:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6031:24, 1
1A0C:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6031:25, 1
1A0C:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x26 (Input event state 6)) | UINT32 | RO | 0x6031:26, 1
1A0C:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x27 (Input event state 7)) | UINT32 | RO | 0x6031:27, 1
1A0C:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x28 (Input event state 8)) | UINT32 | RO | 0x6031:28, 1
1A0C:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x29 (Input event state 9)) | UINT32 | RO | 0x6031:29, 1
1A0C:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x2A (Input event state 10)) | UINT32 | RO | 0x6031:2A, 1
1A0C:12 | SubIndex 018 | 18. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1A0C:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6031:41, 32
1A0C:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6031:42, 32
1A0C:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6031:43, 32
1A0C:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6031:44, 32
1A0C:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6031:45, 32
1A0C:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x46 (Input event time 6)) | UINT32 | RO | 0x6031:46, 32
1A0C:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x47 (Input event time 7)) | UINT32 | RO | 0x6031:47, 32
1A0C:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x48 (Input event time 8)) | UINT32 | RO | 0x6031:48, 32
1A0C:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x49 (Input event time 9)) | UINT32 | RO | 0x6031:49, 32
1A0C:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x4A (Input event time 10)) | UINT32 | RO | 0x6031:4A, 32
Index 1A0D MTI TxPDO-Map Inputs 5x Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
1A0D:0 | MTI TxPDO-Map Inputs 5x Ch.4 | PDO Mapping TxPDO 14 | UINT8 | RO | 0x12 (18dec)
1A0D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x01 (No of input events)) | UINT32 | RO | 0x6031:01, 8
1A0D:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x09 (Input state)) | UINT32 | RO | 0x6031:09, 1
1A0D:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6031:0A, 1
1A0D:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A0D:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6031:0F, 2
1A0D:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6031:11, 8
1A0D:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6031:12, 8
1A0D:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6031:21, 1
1A0D:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6031:22, 1
1A0D:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6031:23, 1
1A0D:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6031:24, 1
1A0D:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6031:25, 1
1A0D:0D | SubIndex 013 | 13. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1A0D:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6031:41, 32
1A0D:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6031:42, 32
1A0D:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6031:43, 32
1A0D:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6031:44, 32
1A0D:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6031:45, 32
Index 1A0E MTI TxPDO-Map Inputs 2x Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
1A0E:0 | MTI TxPDO-Map Inputs 2x Ch.4 | PDO Mapping TxPDO 15 | UINT8 | RO | 0x0C (12dec)
1A0E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x01 (No of input events)) | UINT32 | RO | 0x6031:01, 8
1A0E:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x09 (Input state)) | UINT32 | RO | 0x6031:09, 1
1A0E:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6031:0A, 1
1A0E:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A0E:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6031:0F, 2
1A0E:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6031:11, 8
1A0E:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6031:12, 8
1A0E:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6031:21, 1
1A0E:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6031:22, 1
1A0E:0A | SubIndex 010 | 10. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1A0E:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6031:41, 32
1A0E:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6031:42, 32
Index 1A0F MTI TxPDO-Map Inputs 1x Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
1A0F:0 | MTI TxPDO-Map Inputs 1x Ch.4 | PDO Mapping TxPDO 16 | UINT8 | RO | 0x0A (10dec)
1A0F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x01 (No of input events)) | UINT32 | RO | 0x6031:01, 8
1A0F:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x09 (Input state)) | UINT32 | RO | 0x6031:09, 1
1A0F:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6031:0A, 1
1A0F:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A0F:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6031:0F, 2
1A0F:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6031:11, 8
1A0F:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6031:12, 8
1A0F:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6031:21, 1
1A0F:09 | SubIndex 009 | 9. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1A0F:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6031:41, 32
Index 1A10 MTI TxPDO-Map Inputs 10x Ch.5
Index (hex) | Name | Meaning | Data type | Flags | Default
1A10:0 | MTI TxPDO-Map Inputs 10x Ch.5 | PDO Mapping TxPDO 17 | UINT8 | RO | 0x1C (28dec)
1A10:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x01 (No of input events)) | UINT32 | RO | 0x6041:01, 8
1A10:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x09 (Input state)) | UINT32 | RO | 0x6041:09, 1
1A10:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6041:0A, 1
1A10:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A10:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6041:0F, 2
1A10:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6041:11, 8
1A10:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6041:12, 8
1A10:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6041:21, 1
1A10:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6041:22, 1
1A10:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6041:23, 1
1A10:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6041:24, 1
1A10:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6041:25, 1
1A10:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x26 (Input event state 6)) | UINT32 | RO | 0x6041:26, 1
1A10:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x27 (Input event state 7)) | UINT32 | RO | 0x6041:27, 1
1A10:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x28 (Input event state 8)) | UINT32 | RO | 0x6041:28, 1
1A10:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x29 (Input event state 9)) | UINT32 | RO | 0x6041:29, 1
1A10:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x2A (Input event state 10)) | UINT32 | RO | 0x6041:2A, 1
1A10:12 | SubIndex 018 | 18. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1A10:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6041:41, 32
1A10:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6041:42, 32
1A10:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6041:43, 32
1A10:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6041:44, 32
1A10:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6041:45, 32
1A10:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x46 (Input event time 6)) | UINT32 | RO | 0x6041:46, 32
1A10:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x47 (Input event time 7)) | UINT32 | RO | 0x6041:47, 32
1A10:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x48 (Input event time 8)) | UINT32 | RO | 0x6041:48, 32
1A10:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x49 (Input event time 9)) | UINT32 | RO | 0x6041:49, 32
1A10:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x4A (Input event time 10)) | UINT32 | RO | 0x6041:4A, 32
Index 1A11 MTI TxPDO-Map Inputs 5x Ch.5
Index (hex) | Name | Meaning | Data type | Flags | Default
1A11:0 | MTI TxPDO-Map Inputs 5x Ch.5 | PDO Mapping TxPDO 18 | UINT8 | RO | 0x12 (18dec)
1A11:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x01 (No of input events)) | UINT32 | RO | 0x6041:01, 8
1A11:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x09 (Input state)) | UINT32 | RO | 0x6041:09, 1
1A11:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6041:0A, 1
1A11:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A11:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6041:0F, 2
1A11:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6041:11, 8
1A11:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6041:12, 8
1A11:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6041:21, 1
1A11:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6041:22, 1
1A11:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6041:23, 1
1A11:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6041:24, 1
1A11:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6041:25, 1
1A11:0D | SubIndex 013 | 13. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1A11:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6041:41, 32
1A11:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6041:42, 32
1A11:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6041:43, 32
1A11:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6041:44, 32
1A11:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6041:45, 32
Index 1A12 MTI TxPDO-Map Inputs 2x Ch.5
Index (hex) | Name | Meaning | Data type | Flags | Default
1A12:0 | MTI TxPDO-Map Inputs 2x Ch.5 | PDO Mapping TxPDO 19 | UINT8 | RO | 0x0C (12dec)
1A12:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x01 (No of input events)) | UINT32 | RO | 0x6041:01, 8
1A12:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x09 (Input state)) | UINT32 | RO | 0x6041:09, 1
1A12:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6041:0A, 1
1A12:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A12:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6041:0F, 2
1A12:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6041:11, 8
1A12:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6041:12, 8
1A12:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6041:21, 1
1A12:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6041:22, 1
1A12:0A | SubIndex 010 | 10. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1A12:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6041:41, 32
1A12:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6041:42, 32
Index 1A13 MTI TxPDO-Map Inputs 1x Ch.5
Index (hex) | Name | Meaning | Data type | Flags | Default
1A13:0 | MTI TxPDO-Map Inputs 1x Ch.5 | PDO Mapping TxPDO 20 | UINT8 | RO | 0x0A (10dec)
1A13:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x01 (No of input events)) | UINT32 | RO | 0x6041:01, 8
1A13:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x09 (Input state)) | UINT32 | RO | 0x6041:09, 1
1A13:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6041:0A, 1
1A13:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A13:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6041:0F, 2
1A13:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6041:11, 8
1A13:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6041:12, 8
1A13:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6041:21, 1
1A13:09 | SubIndex 009 | 9. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1A13:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6041:41, 32
Index 1A14 MTI TxPDO-Map Inputs 10x Ch.6
Index (hex) | Name | Meaning | Data type | Flags | Default
1A14:0 | MTI TxPDO-Map Inputs 10x Ch.6 | PDO Mapping TxPDO 21 | UINT8 | RO | 0x1C (28dec)
1A14:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x01 (No of input events)) | UINT32 | RO | 0x6051:01, 8
1A14:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x09 (Input state)) | UINT32 | RO | 0x6051:09, 1
1A14:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6051:0A, 1
1A14:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A14:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6051:0F, 2
1A14:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6051:11, 8
1A14:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6051:12, 8
1A14:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6051:21, 1
1A14:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6051:22, 1
1A14:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6051:23, 1
1A14:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6051:24, 1
1A14:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6051:25, 1
1A14:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x26 (Input event state 6)) | UINT32 | RO | 0x6051:26, 1
1A14:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x27 (Input event state 7)) | UINT32 | RO | 0x6051:27, 1
1A14:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x28 (Input event state 8)) | UINT32 | RO | 0x6051:28, 1
1A14:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x29 (Input event state 9)) | UINT32 | RO | 0x6051:29, 1
1A14:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x2A (Input event state 10)) | UINT32 | RO | 0x6051:2A, 1
1A14:12 | SubIndex 018 | 18. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1A14:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6051:41, 32
1A14:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6051:42, 32
1A14:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6051:43, 32
1A14:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6051:44, 32
1A14:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6051:45, 32
1A14:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x46 (Input event time 6)) | UINT32 | RO | 0x6051:46, 32
1A14:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x47 (Input event time 7)) | UINT32 | RO | 0x6051:47, 32
1A14:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x48 (Input event time 8)) | UINT32 | RO | 0x6051:48, 32
1A14:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x49 (Input event time 9)) | UINT32 | RO | 0x6051:49, 32
1A14:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x4A (Input event time 10)) | UINT32 | RO | 0x6051:4A, 32
Index 1A15 MTI TxPDO-Map Inputs 5x Ch.6
Index (hex) | Name | Meaning | Data type | Flags | Default
1A15:0 | MTI TxPDO-Map Inputs 5x Ch.6 | PDO Mapping TxPDO 22 | UINT8 | RO | 0x12 (18dec)
1A15:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x01 (No of input events)) | UINT32 | RO | 0x6051:01, 8
1A15:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x09 (Input state)) | UINT32 | RO | 0x6051:09, 1
1A15:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6051:0A, 1
1A15:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A15:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6051:0F, 2
1A15:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6051:11, 8
1A15:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6051:12, 8
1A15:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6051:21, 1
1A15:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6051:22, 1
1A15:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6051:23, 1
1A15:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6051:24, 1
1A15:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6051:25, 1
1A15:0D | SubIndex 013 | 13. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1A15:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6051:41, 32
1A15:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6051:42, 32
1A15:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6051:43, 32
1A15:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6051:44, 32
1A15:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6051:45, 32
Index 1A16 MTI TxPDO-Map Inputs 2x Ch.6
Index (hex) | Name | Meaning | Data type | Flags | Default
1A16:0 | MTI TxPDO-Map Inputs 2x Ch.6 | PDO Mapping TxPDO 23 | UINT8 | RO | 0x0C (12dec)
1A16:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x01 (No of input events)) | UINT32 | RO | 0x6051:01, 8
1A16:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x09 (Input state)) | UINT32 | RO | 0x6051:09, 1
1A16:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6051:0A, 1
1A16:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A16:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6051:0F, 2
1A16:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6051:11, 8
1A16:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6051:12, 8
1A16:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6051:21, 1
1A16:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6051:22, 1
1A16:0A | SubIndex 010 | 10. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1A16:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6051:41, 32
1A16:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6051:42, 32
Index 1A17 MTI TxPDO-Map Inputs 1x Ch.6
Index (hex) | Name | Meaning | Data type | Flags | Default
1A17:0 | MTI TxPDO-Map Inputs 1x Ch.6 | PDO Mapping TxPDO 24 | UINT8 | RO | 0x0A (10dec)
1A17:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x01 (No of input events)) | UINT32 | RO | 0x6051:01, 8
1A17:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x09 (Input state)) | UINT32 | RO | 0x6051:09, 1
1A17:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6051:0A, 1
1A17:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A17:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6051:0F, 2
1A17:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6051:11, 8
1A17:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6051:12, 8
1A17:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6051:21, 1
1A17:09 | SubIndex 009 | 9. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1A17:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6051:41, 32
Index 1A18 MTI TxPDO-Map Inputs 10x Ch.7
Index (hex) | Name | Meaning | Data type | Flags | Default
1A18:0 | MTI TxPDO-Map Inputs 10x Ch.7 | PDO Mapping TxPDO 25 | UINT8 | RO | 0x1C (28dec)
1A18:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x01 (No of input events)) | UINT32 | RO | 0x6061:01, 8
1A18:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x09 (Input state)) | UINT32 | RO | 0x6061:09, 1
1A18:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6061:0A, 1
1A18:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A18:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6061:0F, 2
1A18:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6061:11, 8
1A18:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6061:12, 8
1A18:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6061:21, 1
1A18:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6061:22, 1
1A18:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6061:23, 1
1A18:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6061:24, 1
1A18:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6061:25, 1
1A18:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x26 (Input event state 6)) | UINT32 | RO | 0x6061:26, 1
1A18:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x27 (Input event state 7)) | UINT32 | RO | 0x6061:27, 1
1A18:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x28 (Input event state 8)) | UINT32 | RO | 0x6061:28, 1
1A18:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x29 (Input event state 9)) | UINT32 | RO | 0x6061:29, 1
1A18:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x2A (Input event state 10)) | UINT32 | RO | 0x6061:2A, 1
1A18:12 | SubIndex 018 | 18. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1A18:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6061:41, 32
1A18:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6061:42, 32
1A18:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6061:43, 32
1A18:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6061:44, 32
1A18:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6061:45, 32
1A18:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x46 (Input event time 6)) | UINT32 | RO | 0x6061:46, 32
1A18:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x47 (Input event time 7)) | UINT32 | RO | 0x6061:47, 32
1A18:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x48 (Input event time 8)) | UINT32 | RO | 0x6061:48, 32
1A18:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x49 (Input event time 9)) | UINT32 | RO | 0x6061:49, 32
1A18:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x4A (Input event time 10)) | UINT32 | RO | 0x6061:4A, 32
Index 1A19 MTI TxPDO-Map Inputs 5x Ch.7
Index (hex) | Name | Meaning | Data type | Flags | Default
1A19:0 | MTI TxPDO-Map Inputs 5x Ch.7 | PDO Mapping TxPDO 26 | UINT8 | RO | 0x12 (18dec)
1A19:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x01 (No of input events)) | UINT32 | RO | 0x6061:01, 8
1A19:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x09 (Input state)) | UINT32 | RO | 0x6061:09, 1
1A19:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6061:0A, 1
1A19:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A19:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6061:0F, 2
1A19:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6061:11, 8
1A19:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6061:12, 8
1A19:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6061:21, 1
1A19:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6061:22, 1
1A19:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6061:23, 1
1A19:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6061:24, 1
1A19:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6061:25, 1
1A19:0D | SubIndex 013 | 13. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1A19:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6061:41, 32
1A19:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6061:42, 32
1A19:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6061:43, 32
1A19:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6061:44, 32
1A19:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6061:45, 32
Index 1A1A MTI TxPDO-Map Inputs 2x Ch.7
Index (hex) | Name | Meaning | Data type | Flags | Default
1A1A:0 | MTI TxPDO-Map Inputs 2x Ch.7 | PDO Mapping TxPDO 27 | UINT8 | RO | 0x0C (12dec)
1A1A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x01 (No of input events)) | UINT32 | RO | 0x6061:01, 8
1A1A:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x09 (Input state)) | UINT32 | RO | 0x6061:09, 1
1A1A:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6061:0A, 1
1A1A:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A1A:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6061:0F, 2
1A1A:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6061:11, 8
1A1A:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6061:12, 8
1A1A:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6061:21, 1
1A1A:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6061:22, 1
1A1A:0A | SubIndex 010 | 10. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1A1A:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6061:41, 32
1A1A:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6061:42, 32
Index 1A1B MTI TxPDO-Map Inputs 1x Ch.7
Index (hex) | Name | Meaning | Data type | Flags | Default
1A1B:0 | MTI TxPDO-Map Inputs 1x Ch.7 | PDO Mapping TxPDO 28 | UINT8 | RO | 0x0A (10dec)
1A1B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x01 (No of input events)) | UINT32 | RO | 0x6061:01, 8
1A1B:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x09 (Input state)) | UINT32 | RO | 0x6061:09, 1
1A1B:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6061:0A, 1
1A1B:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A1B:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6061:0F, 2
1A1B:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6061:11, 8
1A1B:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6061:12, 8
1A1B:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6061:21, 1
1A1B:09 | SubIndex 009 | 9. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1A1B:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6061:41, 32
Index 1A1C MTI TxPDO-Map Inputs 10x Ch.8
Index (hex) | Name | Meaning | Data type | Flags | Default
1A1C:0 | MTI TxPDO-Map Inputs 10x Ch.8 | PDO Mapping TxPDO 29 | UINT8 | RO | 0x1C (28dec)
1A1C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x01 (No of input events)) | UINT32 | RO | 0x6071:01, 8
1A1C:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x09 (Input state)) | UINT32 | RO | 0x6071:09, 1
1A1C:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6071:0A, 1
1A1C:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A1C:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6071:0F, 2
1A1C:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6071:11, 8
1A1C:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6071:12, 8
1A1C:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6071:21, 1
1A1C:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6071:22, 1
1A1C:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6071:23, 1
1A1C:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6071:24, 1
1A1C:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6071:25, 1
1A1C:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x26 (Input event state 6)) | UINT32 | RO | 0x6071:26, 1
1A1C:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x27 (Input event state 7)) | UINT32 | RO | 0x6071:27, 1
1A1C:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x28 (Input event state 8)) | UINT32 | RO | 0x6071:28, 1
1A1C:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x29 (Input event state 9)) | UINT32 | RO | 0x6071:29, 1
1A1C:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x2A (Input event state 10)) | UINT32 | RO | 0x6071:2A, 1
1A1C:12 | SubIndex 018 | 18. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1A1C:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6071:41, 32
1A1C:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6071:42, 32
1A1C:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6071:43, 32
1A1C:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6071:44, 32
1A1C:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6071:45, 32
1A1C:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x46 (Input event time 6)) | UINT32 | RO | 0x6071:46, 32
1A1C:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x47 (Input event time 7)) | UINT32 | RO | 0x6071:47, 32
1A1C:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x48 (Input event time 8)) | UINT32 | RO | 0x6071:48, 32
1A1C:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x49 (Input event time 9)) | UINT32 | RO | 0x6071:49, 32
1A1C:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x4A (Input event time 10)) | UINT32 | RO | 0x6071:4A, 32
Index 1A1D MTI TxPDO-Map Inputs 5x Ch.8
Index (hex) | Name | Meaning | Data type | Flags | Default
1A1D:0 | MTI TxPDO-Map Inputs 5x Ch.8 | PDO Mapping TxPDO 30 | UINT8 | RO | 0x12 (18dec)
1A1D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x01 (No of input events)) | UINT32 | RO | 0x6071:01, 8
1A1D:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x09 (Input state)) | UINT32 | RO | 0x6071:09, 1
1A1D:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6071:0A, 1
1A1D:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A1D:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6071:0F, 2
1A1D:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6071:11, 8
1A1D:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6071:12, 8
1A1D:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6071:21, 1
1A1D:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6071:22, 1
1A1D:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6071:23, 1
1A1D:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6071:24, 1
1A1D:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6071:25, 1
1A1D:0D | SubIndex 013 | 13. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1A1D:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6071:41, 32
1A1D:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6071:42, 32
1A1D:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6071:43, 32
1A1D:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6071:44, 32
1A1D:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6071:45, 32
Index 1A1E MTI TxPDO-Map Inputs 2x Ch.8
Index (hex) | Name | Meaning | Data type | Flags | Default
1A1E:0 | MTI TxPDO-Map Inputs 2x Ch.8 | PDO Mapping TxPDO 31 | UINT8 | RO | 0x0C (12dec)
1A1E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x01 (No of input events)) | UINT32 | RO | 0x6071:01, 8
1A1E:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x09 (Input state)) | UINT32 | RO | 0x6071:09, 1
1A1E:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6071:0A, 1
1A1E:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A1E:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6071:0F, 2
1A1E:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6071:11, 8
1A1E:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6071:12, 8
1A1E:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6071:21, 1
1A1E:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6071:22, 1
1A1E:0A | SubIndex 010 | 10. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1A1E:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6071:41, 32
1A1E:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6071:42, 32
Index 1A1F MTI TxPDO-Map Inputs 1x Ch.8
Index (hex) | Name | Meaning | Data type | Flags | Default
1A1F:0 | MTI TxPDO-Map Inputs 1x Ch.8 | PDO Mapping TxPDO 32 | UINT8 | RO | 0x0A (10dec)
1A1F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x01 (No of input events)) | UINT32 | RO | 0x6071:01, 8
1A1F:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x09 (Input state)) | UINT32 | RO | 0x6071:09, 1
1A1F:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6071:0A, 1
1A1F:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A1F:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6071:0F, 2
1A1F:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6071:11, 8
1A1F:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6071:12, 8
1A1F:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6071:21, 1
1A1F:09 | SubIndex 009 | 9. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1A1F:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6071:41, 32
Index 1A20 TSI TxPDO-Map Inputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A20:0 | TSI TxPDO-Map Inputs Ch.1 | PDO Mapping TxPDO 33 | UINT8 | RO | 0x06 (6dec)
1A20:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6080 (TSI Inputs Ch.1), entry 0x01 (Input)) | UINT32 | RO | 0x6080:01, 1
1A20:02 | SubIndex 002 | 2. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A20:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6080 (TSI Inputs Ch.1), entry 0x09 (Status)) | UINT32 | RO | 0x6080:09, 8
1A20:04 | SubIndex 004 | 4. PDO Mapping entry (48 bits align) | UINT32 | RO | 0x0000:00, 48
1A20:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6080 (TSI Inputs Ch.1), entry 0x41 (LatchPos)) | UINT32 | RO | 0x6080:41, 64
1A20:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6080 (TSI Inputs Ch.1), entry 0x42 (LatchNeg)) | UINT32 | RO | 0x6080:42, 64
Index 1A21 TSI TxPDO-Map Inputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A21:0 | TSI TxPDO-Map Inputs Ch.2 | PDO Mapping TxPDO 34 | UINT8 | RO | 0x06 (6dec)
1A21:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6090 (TSI Inputs Ch.2), entry 0x01 (Input)) | UINT32 | RO | 0x6090:01, 1
1A21:02 | SubIndex 002 | 2. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A21:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6090 (TSI Inputs Ch.2), entry 0x09 (Status)) | UINT32 | RO | 0x6090:09, 8
1A21:04 | SubIndex 004 | 4. PDO Mapping entry (48 bits align) | UINT32 | RO | 0x0000:00, 48
1A21:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6090 (TSI Inputs Ch.2), entry 0x41 (LatchPos)) | UINT32 | RO | 0x6090:41, 64
1A21:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6090 (TSI Inputs Ch.2), entry 0x42 (LatchNeg)) | UINT32 | RO | 0x6090:42, 64
Index 1A22 TSI TxPDO-Map Inputs Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1A22:0 | TSI TxPDO-Map Inputs Ch.3 | PDO Mapping TxPDO 35 | UINT8 | RO | 0x06 (6dec)
1A22:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60A0 (TSI Inputs Ch.3), entry 0x01 (Input)) | UINT32 | RO | 0x60A0:01, 1
1A22:02 | SubIndex 002 | 2. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A22:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60A0 (TSI Inputs Ch.3), entry 0x09 (Status)) | UINT32 | RO | 0x60A0:09, 8
1A22:04 | SubIndex 004 | 4. PDO Mapping entry (48 bits align) | UINT32 | RO | 0x0000:00, 48
1A22:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60A0 (TSI Inputs Ch.3), entry 0x41 (LatchPos)) | UINT32 | RO | 0x60A0:41, 64
1A22:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60A0 (TSI Inputs Ch.3), entry 0x42 (LatchNeg)) | UINT32 | RO | 0x60A0:42, 64
Index 1A23 TSI TxPDO-Map Inputs Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
1A23:0 | TSI TxPDO-Map Inputs Ch.4 | PDO Mapping TxPDO 36 | UINT8 | RO | 0x06 (6dec)
1A23:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60B0 (TSI Inputs Ch.4), entry 0x01 (Input)) | UINT32 | RO | 0x60B0:01, 1
1A23:02 | SubIndex 002 | 2. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A23:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60B0 (TSI Inputs Ch.4), entry 0x09 (Status)) | UINT32 | RO | 0x60B0:09, 8
1A23:04 | SubIndex 004 | 4. PDO Mapping entry (48 bits align) | UINT32 | RO | 0x0000:00, 48
1A23:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60B0 (TSI Inputs Ch.4), entry 0x41 (LatchPos)) | UINT32 | RO | 0x60B0:41, 64
1A23:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60B0 (TSI Inputs Ch.4), entry 0x42 (LatchNeg)) | UINT32 | RO | 0x60B0:42, 64
Index 1A24 TSI TxPDO-Map Inputs Ch.5
Index (hex) | Name | Meaning | Data type | Flags | Default
1A24:0 | TSI TxPDO-Map Inputs Ch.5 | PDO Mapping TxPDO 37 | UINT8 | RO | 0x06 (6dec)
1A24:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60C0 (TSI Inputs Ch.5), entry 0x01 (Input)) | UINT32 | RO | 0x60C0:01, 1
1A24:02 | SubIndex 002 | 2. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A24:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60C0 (TSI Inputs Ch.5), entry 0x09 (Status)) | UINT32 | RO | 0x60C0:09, 8
1A24:04 | SubIndex 004 | 4. PDO Mapping entry (48 bits align) | UINT32 | RO | 0x0000:00, 48
1A24:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60C0 (TSI Inputs Ch.5), entry 0x41 (LatchPos)) | UINT32 | RO | 0x60C0:41, 64
1A24:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60C0 (TSI Inputs Ch.5), entry 0x42 (LatchNeg)) | UINT32 | RO | 0x60C0:42, 64
Index 1A25 TSI TxPDO-Map Inputs Ch.6
Index (hex) | Name | Meaning | Data type | Flags | Default
1A25:0 | TSI TxPDO-Map Inputs Ch.6 | PDO Mapping TxPDO 38 | UINT8 | RO | 0x06 (6dec)
1A25:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60D0 (TSI Inputs Ch.6), entry 0x01 (Input)) | UINT32 | RO | 0x60D0:01, 1
1A25:02 | SubIndex 002 | 2. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A25:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60D0 (TSI Inputs Ch.6), entry 0x09 (Status)) | UINT32 | RO | 0x60D0:09, 8
1A25:04 | SubIndex 004 | 4. PDO Mapping entry (48 bits align) | UINT32 | RO | 0x0000:00, 48
1A25:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60D0 (TSI Inputs Ch.6), entry 0x41 (LatchPos)) | UINT32 | RO | 0x60D0:41, 64
1A25:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60D0 (TSI Inputs Ch.6), entry 0x42 (LatchNeg)) | UINT32 | RO | 0x60D0:42, 64
Index 1A26 TSI TxPDO-Map Inputs Ch.7
Index (hex) | Name | Meaning | Data type | Flags | Default
1A26:0 | TSI TxPDO-Map Inputs Ch.7 | PDO Mapping TxPDO 39 | UINT8 | RO | 0x06 (6dec)
1A26:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60E0 (TSI Inputs Ch.7), entry 0x01 (Input)) | UINT32 | RO | 0x60E0:01, 1
1A26:02 | SubIndex 002 | 2. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A26:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60E0 (TSI Inputs Ch.7), entry 0x09 (Status)) | UINT32 | RO | 0x60E0:09, 8
1A26:04 | SubIndex 004 | 4. PDO Mapping entry (48 bits align) | UINT32 | RO | 0x0000:00, 48
1A26:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60E0 (TSI Inputs Ch.7), entry 0x41 (LatchPos)) | UINT32 | RO | 0x60E0:41, 64
1A26:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60E0 (TSI Inputs Ch.7), entry 0x42 (LatchNeg)) | UINT32 | RO | 0x60E0:42, 64
Index 1A27 TSI TxPDO-Map Inputs Ch.8
Index (hex) | Name | Meaning | Data type | Flags | Default
1A27:0 | TSI TxPDO-Map Inputs Ch.8 | PDO Mapping TxPDO 40 | UINT8 | RO | 0x06 (6dec)
1A27:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60F0 (TSI Inputs Ch.8), entry 0x01 (Input)) | UINT32 | RO | 0x60F0:01, 1
1A27:02 | SubIndex 002 | 2. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A27:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60F0 (TSI Inputs Ch.8), entry 0x09 (Status)) | UINT32 | RO | 0x60F0:09, 8
1A27:04 | SubIndex 004 | 4. PDO Mapping entry (48 bits align) | UINT32 | RO | 0x0000:00, 48
1A27:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60F0 (TSI Inputs Ch.8), entry 0x41 (LatchPos)) | UINT32 | RO | 0x60F0:41, 64
1A27:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60F0 (TSI Inputs Ch.8), entry 0x42 (LatchNeg)) | UINT32 | RO | 0x60F0:42, 64
Index 1A28 DEV TxPDO-Map Inputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1A28:0 | DEV TxPDO-Map Inputs Device | PDO Mapping TxPDO 41 | UINT8 | RO | 0x06 (6dec)
1A28:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A28:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF611 (DEV Inputs), entry 0x02 (Undervoltage Up)) | UINT32 | RO | 0xF611:02, 1
1A28:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF611 (DEV Inputs), entry 0x03 (Overtemperature)) | UINT32 | RO | 0xF611:03, 1
1A28:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF611 (DEV Inputs), entry 0x04 (Checksum error)) | UINT32 | RO | 0xF611:04, 1
1A28:05 | SubIndex 005 | 5. PDO Mapping entry (60 bits align) | UINT32 | RO | 0x0000:00, 60
1A28:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF611 (DEV Inputs), entry 0x21 (SysTime)) | UINT32 | RO | 0xF611:21, 64
Index 1C00Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the sync managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x08 (8dec)
1C12:01 | SubIndex 001 | 1. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1600 (5632dec)
1C12:02 | SubIndex 002 | 2. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1601 (5633dec)
1C12:03 | SubIndex 003 | 3. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1602 (5634dec)
1C12:04 | SubIndex 004 | 4. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1603 (5635dec)
1C12:05 | SubIndex 005 | 5. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1604 (5636dec)
1C12:06 | SubIndex 006 | 6. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1605 (5637dec)
1C12:07 | SubIndex 007 | 7. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1606 (5638dec)
1C12:08 | SubIndex 008 | 8. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1607 (5639dec)
Index 1C13 TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x08 (8dec)
1C13:01 | SubIndex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | SubIndex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A04 (6660dec)
1C13:03 | SubIndex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A08 (6664dec)
1C13:04 | SubIndex 004 | 4. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A0C (6668dec)
1C13:05 | SubIndex 005 | 5. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A10 (6672dec)
1C13:06 | SubIndex 006 | 6. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A14 (6676dec)
1C13:07 | SubIndex 007 | 7. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A18 (6680dec)
1C13:08 | SubIndex 008 | 8. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A1C (6684dec)
1C13:09 | SubIndex 009 | 9. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0A | SubIndex 010 | 10. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0B | SubIndex 011 | 11. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0C | SubIndex 012 | 12. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0D | SubIndex 013 | 13. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0E | SubIndex 014 | 14. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0F | SubIndex 015 | 15. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:10 | SubIndex 016 | 16. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:11 | SubIndex 017 | 17. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:12 | SubIndex 018 | 18. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:13 | SubIndex 019 | 19. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:14 | SubIndex 020 | 20. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:15 | SubIndex 021 | 21. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 1C13 TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:16 | SubIndex 022 | 22. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:17 | SubIndex 023 | 23. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:18 | SubIndex 024 | 24. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:19 | SubIndex 025 | 25. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:1A | SubIndex 026 | 26. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:1B | SubIndex 027 | 27. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:1C | SubIndex 028 | 28. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:1D | SubIndex 029 | 29. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:1E | SubIndex 030 | 30. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:1F | SubIndex 031 | 31. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:20 | SubIndex 032 | 32. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:21 | SubIndex 033 | 33. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:22 | SubIndex 034 | 34. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:23 | SubIndex 035 | 35. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:24 | SubIndex 036 | 36. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:25 | SubIndex 037 | 37. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:26 | SubIndex 038 | 38. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:27 | SubIndex 039 | 39. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:28 | SubIndex 040 | 40. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:29 | SubIndex 041 | 41. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 1C32 SM output parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C32:0
SM output parameter
Synchronization parameters for the outputs
UINT8
RO
0x20 (32dec)
1C32:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0000 (0dec)
1C32:02
Cycle time
Cycle time (in ns):
▪
Free Run: Cycle time of the local timer
▪
Synchronous with SM 2 event: Master cycle time
▪
DC mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000C3500 (800000dec)
1C32:03
Shift time
Time between SYNC0 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000384 (900dec)
1C32:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0 = 1: free run is supported
▪
Bit 1 = 1: Synchronous with SM 2 event is supported
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 10: Output shift with SYNC1 event (only DC mode)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08)
UINT16
RO
0x0804 (2052dec)
1C32:05
Minimum cycle time
Minimum cycle time (in ns)
UINT32
RO
0x00001F40 (8000dec)
1C32:06
Calc and copy time
Minimum time between SYNC0 and SYNC1 event (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:07
Minimum delay time
UINT32
RO
0x00000384 (900dec)
1C32:08
Command
▪
0: Measurement of the local cycle time is stopped
▪
1: Measurement of the local cycle time is started
The entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, and 0x1C33:09 are updated with the maximum measured values.
For a subsequent measurement the measured values are reset
UINT16
RW
0x0000 (0dec)
1C32:09
Maximum delay time
Time between SYNC1 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000384 (900dec)
1C32:0B
SM event missed counter
Number of missed SM events in OPERATIONAL (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:0C
Cycle exceeded counter
Number of occasions the cycle time was exceeded in OPERATIONAL (cycle was not completed in time or the next cycle began too early)
UINT16
RO
0x0000 (0dec)
1C32:0D
Shift too short counter
Number of occasions that the interval between SYNC0 and SYNC1 event was too short (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:20
Sync error
The synchronization was not correct in the last cycle (outputs were output too late; DC mode only)
BOOLEAN
RO
0x00 (0dec)
Index 1C33 SM input parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchronous with SM 3 event (no outputs available)
▪
2: DC - Synchronous with SYNC0 Event
▪
3: DC - Synchronous with SYNC1 Event
▪
34: Synchronous with SM 2 event (outputs available)
UINT16
RW
0x0000 (0dec)
1C33:02
Cycle time
as 0x1C32:02
UINT32
RW
0x000C3500 (800000dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000384 (900dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: synchronous with SM 2 event is supported (outputs available)
▪
Bit 1: synchronous with SM 3 event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: input shift through local event (outputs available)
▪
Bit 4-5 = 10: input shift with SYNC1 event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08 or 0x1C33:08)
UINT16
RO
0x0804 (2052dec)
1C33:05
Minimum cycle time
as 0x1C32:05
UINT32
RO
0x00001F40 (8000dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:07
Minimum delay time
UINT32
RO
0x00000384 (900dec)
1C33:08
Command
as 0x1C32:08
UINT16
RW
0x0000 (0dec)
1C33:09
Maximum delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000384 (900dec)
1C33:0B
SM event missed counter
as 0x1C32:11
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
as 0x1C32:12
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
as 0x1C32:13
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
as 0x1C32:32
BOOLEAN
RO
0x00 (0dec)
Index F000 Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index spacing of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0010 (16dec)
Index F008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module list
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list | MDP Profile | UINT8 | RW | 0x10 (16dec)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x00000078 (120dec)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x00000078 (120dec)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x00000078 (120dec)
F010:04 | SubIndex 004 |  | UINT32 | RW | 0x00000078 (120dec)
F010:05 | SubIndex 005 |  | UINT32 | RW | 0x00000078 (120dec)
F010:06 | SubIndex 006 |  | UINT32 | RW | 0x00000078 (120dec)
F010:07 | SubIndex 007 |  | UINT32 | RW | 0x00000078 (120dec)
F010:08 | SubIndex 008 |  | UINT32 | RW | 0x00000078 (120dec)
F010:09 | SubIndex 009 |  | UINT32 | RW | 0x00000079 (121dec)
F010:0A | SubIndex 010 |  | UINT32 | RW | 0x00000079 (121dec)
F010:0B | SubIndex 011 |  | UINT32 | RW | 0x00000079 (121dec)
F010:0C | SubIndex 012 |  | UINT32 | RW | 0x00000079 (121dec)
F010:0D | SubIndex 013 |  | UINT32 | RW | 0x00000079 (121dec)
F010:0E | SubIndex 014 |  | UINT32 | RW | 0x00000079 (121dec)
F010:0F | SubIndex 015 |  | UINT32 | RW | 0x00000079 (121dec)
F010:10 | SubIndex 016 |  | UINT32 | RW | 0x00000079 (121dec)


EL1259

Commissioning [image] CoE object description and parameterization [image] EL1259
EL1259
Additional information
•
Object description and parameterization
•
Object description - standard objects


Object description and parameterization

Commissioning [image] CoE object description and parameterization [image] EL1259 [image] Object description and parameterization
Object description and parameterization
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Parameterization via the CoE list (CAN over EtherCAT)
The terminal is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs). Please note the following general CoE information when using/manipulating the CoE parameters:
- Keep a startup list if components have to be replaced
- Differentiation between online/offline dictionary, existence of current XML description
- Use "CoE reload" for resetting changes
Additional information
•
Restore object
•
Configuration data
•
Input data
•
Output data
•
Diagnostic data
•
Information data
•
Command object


Restore object

Commissioning [image] CoE object description and parameterization [image] EL1259 [image] Object description and parameterization [image] Restore object
Restore object
Index 1011 Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default parameters | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to “0x64616F6C” in the set value dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)


Configuration data

Commissioning [image] CoE object description and parameterization [image] EL1259 [image] Object description and parameterization [image] Configuration data
Configuration data
Index 8pp1 MTO Settings (for 00 ≤ pp ≤ 07; Ch. 1 to Ch. 8)
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8pp1:0 | MTO Settings |  |  | UINT8 | RO | 0x12 (18dec)
8pp1:01 | Use as +24 V power supply | Activates the output permanently. The channel cannot be used for processing of timestamp events. The output is deactivated as soon as the EtherCAT status is not OP. |  | BOOLEAN | RW | 0x00 (0dec)
8pp1:02 | Enable manual operation | Via this object the output can be switched manually. |  | BOOLEAN | RW | 0x00 (0dec)
8pp1:03 | Enable time check | This bit can be used to determine how to handle switching orders that were placed before the current time (further explanation see here). |  | BOOLEAN | RW | 0x00 (0dec)
8pp1:11 | Buffer reset behavior | Specifies the behavior of the "Output buffer reset" bit Permitted values: |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | Reset on rising edge: The buffer is cleared with a rising edge of "Output buffer reset"
 |  | 1 | Reset on high level: The buffer is cleared with a rising edge of "Output buffer reset" and does not accept new values until "Output buffer reset" is reset.
8pp1:12 | Buffer overflow behavior | Specifies the behavior in the event of buffer overflow Permitted values: |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | Lock buffer: New events are discarded
 |  | 1 | Overwrite oldest value: New events overwrite the last events in the buffer
Index 8ppF MTO Vendor data (for 00 ≤ pp ≤ 07; Ch. 1 to Ch. 8)
Index (hex) | Name | Meaning | Data type | Flags | Default
8ppF:0 | MTO Vendor data |  | UINT8 | RO | 0x12 (18dec)
8ppF:11 | Offset pos | This object can be used to move the output time of the rising edges. This setting is left to the manufacturer. | INT32 | RW | 0x00000000 (0dec)
8ppF:12 | Offset neg | This object can be used to move the output time of the falling edges. This setting is left to the manufacturer. | INT32 | RW | 0x00000000 (0dec)
Index 8pp0 MTI settings (for 08 ≤ pp ≤ 0F; Ch. 1 to Ch. 8)
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8pp0:0 | MTI settings |  |  | UINT8 | RO | 0x14 (20dec)
8pp0:01 | Enable digital filter | Activation of the filter to hide spikes. The filter length should be entered in 8pp0:14 "DigitalFilterCount" (further explanation see here). |  | BOOLEAN | RW | 0x00 (0dec)
8pp0:11 | Buffer reset behavior | Specifies the behavior of the "Input buffer reset" bit Permitted values: |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | Reset on rising edge: The buffer is cleared with a rising edge of "Input buffer reset"
 |  | 1 | Reset on high level: The buffer is cleared with a rising edge of "Input buffer reset" and does not accept new values until "Input buffer reset" is reset.
8pp0:12 | Buffer mode | Specifies whether handshaking is to be used for retrieving the values from the buffer (transmission integrity) or whether new values are to be transferred directly with each PLC cycle (faster). Permitted values (further explanation see here): |  | UINT16 | RW | 0x0001 (1dec)
 |  | 0 | Asynchronous (Buffered): The arrival of new events must be acknowledged by the PLC. To this end the byte "No of input events" must be monitored in the PLC program. If it is greater than zero the pending events can be taken over from the process image. Subsequently the byte "Input order counter" must be incremented. This signals the terminal that the events were accepted and new data can be created in the next cycle.
 |  | 1 | Synchronous: New events are automatically transferred with each PLC cycle
8pp0:13 | Buffer overflow behavior | Specifies the behavior in the event of buffer overflow Permitted values: |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | Lock buffer: New events are discarded
 |  | 1 | Overwrite oldest event: New events overwrite the last events in the buffer
8pp0:14 | Digital filter count | Defines the number of event samples to ensure transfer into the buffer (further explanation see here). |  | UINT16 | RW | 0x0001 (1dec)
Index 8ppF MTI Vendor data (for 08 ≤ pp ≤ 0F; Ch. 1 to Ch. 8)
Index (hex) | Name | Meaning | Data type | Flags | Default
8ppF:0 | MTI Vendor data |  | UINT8 | RO | 0x12 (18dec)
8ppF:11 | Offset pos | This object can be used to move the input time of the rising edges. This setting is left to the manufacturer. | INT32 | RW | 0x00000000 (0dec)
8ppF:12 | Offset neg | This object can be used to move the input time of the falling edges. This setting is left to the manufacturer. | INT32 | RW | 0x00000000 (0dec)
Index 8ppF TSO Vendor data (for 10 ≤ pp ≤ 17; Ch. 1 to Ch. 8)
Index (hex) | Name | Meaning | Data type | Flags | Default
8ppF:0 | TSO Vendor data |  | UINT8 | RO | 0x12 (18dec)
8ppF:11 | Offset pos | This object can be used to move the output time of the rising edges. This setting is left to the manufacturer. | INT32 | RW | 0x00000000 (0dec)
8ppF:12 | Offset neg | This object can be used to move the output time of the falling edges. This setting is left to the manufacturer. | INT32 | RW | 0x00000000 (0dec)
Index 8pp0 TSI Settings (for 18 ≤ pp ≤ 1F; Ch. 1 to Ch. 8)
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8pp0:0 | TSI Settings |  |  | UINT8 | RO | 0x02 (2dec)
8pp0:01 | Pos Sample Mode | During each PLC cycle only one rising edge may be detected at the terminal input. If several edges arrive during a cycle, this bit can be used to decide which edge should be shown in the process image. Permitted values: |  | BIT1 | RW | 0x00 (0dec)
 |  | 0 | Last edge: The last edge of the preceding PLC cycle is shown
 |  | 1 | First edge: The first edge of the preceding PLC cycle is shown
8pp0:02 | Neg Sample Mode | During each PLC cycle only one falling edge may be detected at the terminal input. If several edges arrive during a cycle, this bit can be used to decide which edge should be shown in the process image. Permitted values: |  | BIT1 | RW | 0x00 (0dec)
 |  | 0 | Last edge: The last edge of the preceding PLC cycle is shown
 |  | 1 | First edge: The first edge of the preceding PLC cycle is shown
Index 8ppF TSI Vendor data (for 18 ≤ pp ≤ 1F; Ch. 1 to Ch. 8)
Index (hex) | Name | Meaning | Data type | Flags | Default
8ppF:0 | TSI Vendor data |  | UINT8 | RO | 0x12 (18dec)
8ppF:11 | Offset pos | This object can be used to move the input time of the rising edges. This setting is left to the manufacturer. | INT32 | RW | 0x00000000 (0dec)
8ppF:12 | Offset neg | This object can be used to move the input time of the falling edges. This setting is left to the manufacturer. | INT32 | RW | 0x00000000 (0dec)


Input data

Commissioning [image] CoE object description and parameterization [image] EL1259 [image] Object description and parameterization [image] Input data
Input data
Index 6pp0 MTO inputs (for 00 ≤ pp ≤ 07; Ch. 1 to Ch. 8)
Index (hex) | Name | Meaning | Data type | Flags | Default
6pp0:0 | MTO inputs |  | UINT8 | RO | 0x00 (0dec)
6pp0:01 | Output short circuit | The channel signals a short circuit | BOOLEAN | RO | 0x00 (0dec)
6pp0:02 | Output buffer overflow | More events were written to the buffer than it can hold | BOOLEAN | RO | 0x00 (0dec)
6pp0:03 | Output state | Current output state at the time of the process data cycle | BOOLEAN | RO | 0x00 (0dec)
6pp0:0F | Input cycle counter | Is incremented with each process data cycle and switches to 0 after its maximum value of 3. | BIT2 | RO | 0x00 (0dec)
6pp0:11 | Output order feedback | This byte reflects the state of the "Output order counter" byte. | UINT8 | RO | 0x00 (0dec)
6pp0:12 | Events in output buffer | Returns the number of switching orders currently still in the buffer | UINT8 | RO | 0x00 (0dec)
Index 6pp1 MTI inputs (for 08 ≤ pp ≤ 0F; Ch. 1 to Ch. 8)
Index (hex) | Name | Meaning | Data type | Flags | Default
6pp1:0 | MTI inputs |  | UINT8 | RO | 0x00 (0dec)
6pp1:01 | No of input events | Signals the number of new timestamps available in the process image. If three is returned, for example, only the objects "Input event state 1...3" and "Input event time 1...3" are valid. | UINT8 | RO | 0x00 (0dec)
6pp1:09 | Input state | Indicates the current input state at the time of the process data cycle. | BOOLEAN | RO | 0x00 (0dec)
6pp1:0A | Input buffer overflow | More events occurred at the input than elements were free in the buffer for the channel. | BOOLEAN | RO | 0x00 (0dec)
6pp1:0F | Input cycle counter | Is incremented with each process data cycle and switches to 0 after its maximum value of 3. | BIT2 | RO | 0x00 (0dec)
6pp1:11 | Events in input buffer | Signals the number of events currently in the buffer. | UINT8 | RO | 0x00 (0dec)
6pp1:12 | Input order feedback | This byte reflects the state of the "Input order counter" byte (further explanation see here). | UINT8 | RO | 0x00 (0dec)
6pp1:21 | Input event state 1 | Indicates whether the event was a rising (1) or a falling (0) edge. | BOOLEAN | RO | 0x00 (0dec)
6pp1:2A | Input event state 10 |  | BOOLEAN | RO | 0x00 (0dec)
6pp1:41 | Input event time 1 | 32-bit timestamp for the corresponding "Input event state n" | UINT32 | RO | 0x00000000 (0dec)
6pp1:4A | Input event time 10 |  | UINT32 | RO | 0x00000000 (0dec)
Index 6pp0 TSO Inputs (for 10 ≤ pp ≤ 17; Ch. 1 to Ch. 8)
Index (hex) | Name | Meaning | Data type | Flags | Default
6pp0:0 | TSO Inputs |  | UINT8 | RO | 0x00 (0dec)
6pp0:01 | Feedback | Indicates the current output state | BOOLEAN | RO | 0x00 (0dec)
Index 6pp0 TSI Inputs (for 18 ≤ pp ≤ 1F; Ch. 1 to Ch. 8)
Index (hex) | Name | Meaning | Data type | Flags | Default
6pp0:0 | TSI Inputs |  | UINT8 | RO | 0x00 (0dec)
6pp0:01 | Input | Current input status | BOOLEAN | RO | 0x00 (0dec)
6pp0:09 | Status | Bit 0: Is set for one cycle if a rising edge was detected. Bit 1: Is set for one cycle if a falling edge was detected. | UINT8 | RO | 0x00 (0dec)
6pp0:41 | LatchPos | Timestamp of the rising edge | UINT64 | RO |
6pp0:42 | LatchNeg | Timestamp of the falling edge | UINT64 | RO |
Index F611 DEV Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
F611:0 | DEV Inputs |  | UINT8 | RO | 0x00 (0dec)
F611:02 | Undervoltage Up | The nominal voltage at the power contacts was significantly below the minimum value. | BOOLEAN | RO | 0x00 (0dec)
F611:03 | Overtemperature | Overtemperature fault: The temperature of the input or output blocks is too high. For output terminals check whether one of the channels is affected by a short circuit. | BOOLEAN | RO | 0x00 (0dec)
F611:04 | Checksum error | An error occurred in the internal data transfer | BOOLEAN | RO | 0x00 (0dec)
F611:21 | SysTime | DC timestamp of the last input mapping. This timestamp should not be used as reference (information on DC reference times). | UINT64 | RO |


Output data

Commissioning [image] CoE object description and parameterization [image] EL1259 [image] Object description and parameterization [image] Output data
Output data
Index 7pp1 MTO outputs (for 00 ≤ pp ≤ 07; Ch. 1 to Ch. 8)
Index (hex)
Name
Meaning
Data type
Flags
Default
7pp1:0
MTO outputs
UINT8
RO
0x00 (0dec)
7pp1:01
Output buffer reset
Removes all elements from the buffer
Clearing can be achieved through a rising edge or continuously by applying 1 at this bit. The behavior can be parameterized via CoE object 0x8pp1:11.
BOOLEAN
RO
0x00 (0dec)
7pp1:02
Manual output state
This bit can be used to switch the output without using timestamps.
▪
Method 1: The CoE object 0x8pp1:02 ("Enable manual operation") is set to TRUE. Timestamp mode is now switched off, and the output can only be switched via the bit "Manual operation state". This is particularly helpful for the commissioning phase.
▪
Method 2: Via the bit "Enable manual operation" (0x7pp1:04) the channel output can be forced to the value of this object. Timestamp processing continues in the background. Output is only reactivated if the bit "Enable manual operation" is set to 0 again.
BOOLEAN
RO
0x00 (0dec)
7pp1:03
Force order
This bit defines how to deal with timestamps that were placed in the past (see diagram).
BOOLEAN
RO
0x00 (0dec)
7pp1:04
Enable manual operation
See "Manual output state" (0x7pp1:02).
BOOLEAN
RO
0x00 (0dec)
7pp1:09
Output order counter
Incrementing this byte indicates to the channel that new output events can be accepted
UINT8
RO
0x00 (0dec)
7pp1:11
No of output events
Number of filled "Output event state" and "Output event time" objects
UINT8
RO
0x00 (0dec)
7pp1:21
Output event state 1
This bit is used to specify which state the output should assume at the time of "Output event time 1"
BOOLEAN
RO
0x00 (0dec)
7pp1:2A
Output event state 10
BOOLEAN
RO
0x00 (0dec)
7pp1:41
Output event time 1
Time at which the state described in "Output event state 1" is to be applied
UINT32
RO
0x00000000 (0dec)
7pp1:4A
Output event time 10
UINT32
RO
0x00000000 (0dec)
Index 7pp0 MTI outputs (for 08 ≤ pp ≤ 0F; Ch. 1 to Ch. 8)
Index (hex) | Name | Meaning | Data type | Flags | Default
7pp0:0 | MTI outputs |  | UINT8 | RO | 0x00 (0dec)
7pp0:01 | Input buffer reset | Removes all elements from the buffer Clearing can be achieved through a rising edge or continuously by applying 1 at this bit. The behavior can be parameterized via the CoE object 0x8pp0:11 ("Buffer reset behavior"). | BOOLEAN | RO | 0x00 (0dec)
7pp0:11 | Input order counter | This bit indicates to the terminal that the input events were accepted from the process image and the terminal can copy a new set of input events from the buffer into the process image during the next cycle (see buffer mode). | UINT8 | RO | 0x00 (0dec)
Index 7pp0 TSO Outputs (for 10 ≤ pp ≤ 17; Ch. 1 to Ch. 8)
Index (hex) | Name | Meaning | Data type | Flags | Default
7pp0:0 | TSO Outputs |  | UINT8 | RO | 0x00 (0dec)
7pp0:01 | Output | Defines whether a rising (1) or falling (0) edge should be output at the "StartTime" | BOOLEAN | RO | 0x00 (0dec)
7pp0:11 | Activate | A change from 0 to 3 in this byte triggers acceptance of the order with the current StartTime | UINT8 | RO | 0x00 (0dec)
7pp0:41 | StartTime | 64 Bit TimeSTamp | UINT64 | RO |


Diagnostic data

Commissioning [image] CoE object description and parameterization [image] EL1259 [image] Object description and parameterization [image] Diagnostic data
Diagnostic data
Index App0 MTO Diag data (for 00 ≤ pp ≤ 07; Ch. 1 to Ch. 8)
Index (hex) | Name | Meaning | Data type | Flags | Default
App0:0 | MTO Diag data |  | UINT8 | RO | 0x00 (0dec)
App0:01 | Short circuit | The channel signals a short circuit | BOOLEAN | RO | 0x00 (0dec)
App0:02 | Undervoltage | The voltage at the power contacts is outside the valid range. | BOOLEAN | RO | 0x00 (0dec)
Index App0 MTI Diag data (for 08 ≤ pp ≤ 0F; Ch. 1 to Ch. 8)
Index (hex) | Name | Meaning | Data type | Flags | Default
App0:0 | MTI Diag data |  | UINT8 | RO | 0x00 (0dec)
App0:01 | Overtemperature | The internal terminal temperature is above the valid range. For terminals with output channels check the outputs for short circuit. | BOOLEAN | RO | 0x00 (0dec)
App0:02 | Undervoltage | The voltage at the power contacts is outside the valid range. | BOOLEAN | RO | 0x00 (0dec)
Index A001 MTO common Diag data
Index (hex) | Name | Meaning | Data type | Flags | Default
A001:0 | MTO common Diag data |  | UINT8 | RO | 0x00 (0dec)
A001:11 | Checksum error counter | An error occurred in the internal data transfer | UINT16 | RO | 0x0000 (0dec)
Index A081 MTI common Diag data
Index (hex) | Name | Meaning | Data type | Flags | Default
A081:0 | MTI common Diag data |  | UINT8 | RO | 0x00 (0dec)
A081:11 | Checksum error counter | An error occurred in the internal data transfer | UINT16 | RO | 0x0000 (0dec)
Index A100 TSO common Diag data
Index (hex) | Name | Meaning | Data type | Flags | Default
A100:0 | TSO common Diag data |  | UINT8 | RO | 0x00 (0dec)
A100:11 | Checksum error counter | An error occurred in the internal data transfer | UINT16 | RO | 0x0000 (0dec)
Index A180 TSI common Diag data
Index (hex) | Name | Meaning | Data type | Flags | Default
A180:0 | TSI common Diag data |  | UINT8 | RO | 0x00 (0dec)
A180:11 | Checksum error counter | An error occurred in the internal data transfer | UINT16 | RO | 0x0000 (0dec)


Information data

Commissioning [image] CoE object description and parameterization [image] EL1259 [image] Object description and parameterization [image] Information data
Information data
Index F900 DEV Info data
Index (hex) | Name | Meaning | Data type | Flags | Default
F900:0 | DEV Info data |  | UINT8 | RO | 0x00 (0dec)
F900:08 | Cycle Time | Indicates the smallest possible cycle time that can be set [ns]. | UINT32 | RO | 0x00000000 (0dec)
F900:09 | Sample time | Indicates the sampling time of the inputs and outputs [ns]. | UINT32 | RO | 0x00000000 (0dec)


Command object

Commissioning [image] CoE object description and parameterization [image] EL1259 [image] Object description and parameterization [image] Command object
Command object
Index FB00 Command
The command object was implemented for future use. Currently no commands are supported.
Index (hex) | Name | Meaning | Data type | Flags | Default
FB00:0 | Command |  | UINT8 | RO | 0x00 (0dec)
FB00:01 | Request | Commands can be sent to the terminal via the request object. | OCTET-STRING[2] | RW | {0}
FB00:02 | Status | Status of the command currently being executed | UINT8 | RO | 0x00 (0dec)
FB00:03 | Response | Optional response value of the command | OCTET-STRING[6] | RO | {0}


Object description - standard objects

Commissioning [image] CoE object description and parameterization [image] EL1259 [image] Object description - standard objects
Object description - standard objects
Index 1000 Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: the Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x00001389 (5001dec)
Index 1008 Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EL1259
Index 1009 Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO |
Index 100A Software version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO | 01
Index 1018 Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x04EB3052 (82522194dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the low word (bit 0-15) indicates the special terminal number, the high word (bit 16-31) refers to the device description | UINT32 | RO | 0x00000000 (0dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the low byte (bit 0-7) of the low word contains the year of production, the high byte (bit 8-15) of the low word contains the week of production, the high word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 Backup parameter handling
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | Information for standardized loading and saving of backup entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum across all backup entries of the EtherCAT slave | UINT32 | RO | 0x00000000 (0dec)
Index 1600 MTO RxPDO-Map Outputs 10x Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1600:0 | MTO RxPDO-Map Outputs 10x Ch.1 | PDO Mapping RxPDO 1 | UINT8 | RO | 0x1D (29dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7001:01, 1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7001:02, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x03 (Force order)) | UINT32 | RO | 0x7001:03, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7001:04, 1
1600:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1600:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7001:09, 8
1600:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x11 (No of output events)) | UINT32 | RO | 0x7001:11, 8
1600:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1600:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7001:21, 1
1600:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7001:22, 1
1600:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7001:23, 1
1600:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7001:24, 1
1600:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7001:25, 1
1600:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x26 (Output event state 6)) | UINT32 | RO | 0x7001:26, 1
1600:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x27 (Output event state 7)) | UINT32 | RO | 0x7001:27, 1
1600:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x28 (Output event state 8)) | UINT32 | RO | 0x7001:28, 1
1600:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x29 (Output event state 9)) | UINT32 | RO | 0x7001:29, 1
1600:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x2A (Output event state 10)) | UINT32 | RO | 0x7001:2A, 1
1600:13 | SubIndex 019 | 19. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1600:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7001:41, 32
1600:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7001:42, 32
1600:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7001:43, 32
1600:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7001:44, 32
1600:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7001:45, 32
1600:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x46 (Output event time 6)) | UINT32 | RO | 0x7001:46, 32
1600:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x47 (Output event time 7)) | UINT32 | RO | 0x7001:47, 32
1600:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x48 (Output event time 8)) | UINT32 | RO | 0x7001:48, 32
1600:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x49 (Output event time 9)) | UINT32 | RO | 0x7001:49, 32
1600:1D | SubIndex 029 | 29. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x4A (Output event time 10)) | UINT32 | RO | 0x7001:4A, 32
Index 1601 MTO RxPDO-Map Outputs 5x Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1601:0 | MTO RxPDO-Map Outputs 5x Ch.1 | PDO Mapping RxPDO 2 | UINT8 | RO | 0x13 (19dec)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7001:01, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7001:02, 1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x03 (Force order)) | UINT32 | RO | 0x7001:03, 1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7001:04, 1
1601:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1601:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7001:09, 8
1601:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x11 (No of output events)) | UINT32 | RO | 0x7001:11, 8
1601:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1601:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7001:21, 1
1601:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7001:22, 1
1601:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7001:23, 1
1601:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7001:24, 1
1601:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7001:25, 1
1601:0E | SubIndex 014 | 14. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1601:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7001:41, 32
1601:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7001:42, 32
1601:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7001:43, 32
1601:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7001:44, 32
1601:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7001:45, 32
Index 1602 MTO RxPDO-Map Outputs 2x Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1602:0 | MTO RxPDO-Map Outputs 2x Ch.1 | PDO Mapping RxPDO 3 | UINT8 | RO | 0x0D (13dec)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7001:01, 1
1602:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7001:02, 1
1602:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x03 (Force order)) | UINT32 | RO | 0x7001:03, 1
1602:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7001:04, 1
1602:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1602:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7001:09, 8
1602:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x11 (No of output events)) | UINT32 | RO | 0x7001:11, 8
1602:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1602:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7001:21, 1
1602:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7001:22, 1
1602:0B | SubIndex 011 | 11. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1602:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7001:41, 32
1602:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7001:42, 32
Index 1603 MTO RxPDO-Map Outputs 1x Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1603:0 | MTO RxPDO-Map Outputs 1x Ch.1 | PDO Mapping RxPDO 4 | UINT8 | RO | 0x0B (11dec)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7001:01, 1
1603:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7001:02, 1
1603:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x03 (Force order)) | UINT32 | RO | 0x7001:03, 1
1603:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7001:04, 1
1603:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1603:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7001:09, 8
1603:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x11 (No of output events)) | UINT32 | RO | 0x7001:11, 8
1603:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1603:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7001:21, 1
1603:0A | SubIndex 010 | 10. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1603:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7001:41, 32
Index 1604 MTO RxPDO-Map Outputs 10x Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1604:0 | MTO RxPDO-Map Outputs 10x Ch.2 | PDO Mapping RxPDO 5 | UINT8 | RO | 0x1D (29dec)
1604:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7011:01, 1
1604:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7011:02, 1
1604:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x03 (Force order)) | UINT32 | RO | 0x7011:03, 1
1604:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7011:04, 1
1604:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1604:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7011:09, 8
1604:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x11 (No of output events)) | UINT32 | RO | 0x7011:11, 8
1604:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1604:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7011:21, 1
1604:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7011:22, 1
1604:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7011:23, 1
1604:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7011:24, 1
1604:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7011:25, 1
1604:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x26 (Output event state 6)) | UINT32 | RO | 0x7011:26, 1
1604:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x27 (Output event state 7)) | UINT32 | RO | 0x7011:27, 1
1604:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x28 (Output event state 8)) | UINT32 | RO | 0x7011:28, 1
1604:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x29 (Output event state 9)) | UINT32 | RO | 0x7011:29, 1
1604:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x2A (Output event state 10)) | UINT32 | RO | 0x7011:2A, 1
1604:13 | SubIndex 019 | 19. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1604:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7011:41, 32
1604:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7011:42, 32
1604:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7011:43, 32
1604:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7011:44, 32
1604:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7011:45, 32
1604:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x46 (Output event time 6)) | UINT32 | RO | 0x7011:46, 32
1604:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x47 (Output event time 7)) | UINT32 | RO | 0x7011:47, 32
1604:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x48 (Output event time 8)) | UINT32 | RO | 0x7011:48, 32
1604:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x49 (Output event time 9)) | UINT32 | RO | 0x7011:49, 32
1604:1D | SubIndex 029 | 29. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x4A (Output event time 10)) | UINT32 | RO | 0x7011:4A, 32
Index 1605 MTO RxPDO-Map Outputs 5x Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1605:0 | MTO RxPDO-Map Outputs 5x Ch.2 | PDO Mapping RxPDO 6 | UINT8 | RO | 0x13 (19dec)
1605:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7011:01, 1
1605:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7011:02, 1
1605:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x03 (Force order)) | UINT32 | RO | 0x7011:03, 1
1605:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7011:04, 1
1605:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1605:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7011:09, 8
1605:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x11 (No of output events)) | UINT32 | RO | 0x7011:11, 8
1605:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1605:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7011:21, 1
1605:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7011:22, 1
1605:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7011:23, 1
1605:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7011:24, 1
1605:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7011:25, 1
1605:0E | SubIndex 014 | 14. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1605:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7011:41, 32
1605:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7011:42, 32
1605:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7011:43, 32
1605:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7011:44, 32
1605:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7011:45, 32
Index 1606 MTO RxPDO-Map Outputs 2x Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1606:0 | MTO RxPDO-Map Outputs 2x Ch.2 | PDO Mapping RxPDO 7 | UINT8 | RO | 0x0D (13dec)
1606:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7011:01, 1
1606:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7011:02, 1
1606:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x03 (Force order)) | UINT32 | RO | 0x7011:03, 1
1606:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7011:04, 1
1606:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1606:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7011:09, 8
1606:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x11 (No of output events)) | UINT32 | RO | 0x7011:11, 8
1606:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1606:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7011:21, 1
1606:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7011:22, 1
1606:0B | SubIndex 011 | 11. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1606:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7011:41, 32
1606:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7011:42, 32
Index 1607 MTO RxPDO-Map Outputs 1x Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1607:0 | MTO RxPDO-Map Outputs 1x Ch.2 | PDO Mapping RxPDO 8 | UINT8 | RO | 0x0B (11dec)
1607:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7011:01, 1
1607:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7011:02, 1
1607:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x03 (Force order)) | UINT32 | RO | 0x7011:03, 1
1607:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7011:04, 1
1607:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1607:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7011:09, 8
1607:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x11 (No of output events)) | UINT32 | RO | 0x7011:11, 8
1607:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1607:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7011:21, 1
1607:0A | SubIndex 010 | 10. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1607:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7011:41, 32
Index 1608 MTO RxPDO-Map Outputs 10x Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1608:0 | MTO RxPDO-Map Outputs 10x Ch.3 | PDO Mapping RxPDO 9 | UINT8 | RO | 0x1D (29dec)
1608:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7021:01, 1
1608:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7021:02, 1
1608:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x03 (Force order)) | UINT32 | RO | 0x7021:03, 1
1608:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7021:04, 1
1608:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1608:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7021:09, 8
1608:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x11 (No of output events)) | UINT32 | RO | 0x7021:11, 8
1608:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1608:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7021:21, 1
1608:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7021:22, 1
1608:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7021:23, 1
1608:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7021:24, 1
1608:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7021:25, 1
1608:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x26 (Output event state 6)) | UINT32 | RO | 0x7021:26, 1
1608:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x27 (Output event state 7)) | UINT32 | RO | 0x7021:27, 1
1608:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x28 (Output event state 8)) | UINT32 | RO | 0x7021:28, 1
1608:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x29 (Output event state 9)) | UINT32 | RO | 0x7021:29, 1
1608:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x2A (Output event state 10)) | UINT32 | RO | 0x7021:2A, 1
1608:13 | SubIndex 019 | 19. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1608:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7021:41, 32
1608:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7021:42, 32
1608:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7021:43, 32
1608:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7021:44, 32
1608:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7021:45, 32
1608:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x46 (Output event time 6)) | UINT32 | RO | 0x7021:46, 32
1608:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x47 (Output event time 7)) | UINT32 | RO | 0x7021:47, 32
1608:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x48 (Output event time 8)) | UINT32 | RO | 0x7021:48, 32
1608:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x49 (Output event time 9)) | UINT32 | RO | 0x7021:49, 32
1608:1D | SubIndex 029 | 29. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x4A (Output event time 10)) | UINT32 | RO | 0x7021:4A, 32
Index 1609 MTO RxPDO-Map Outputs 5x Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1609:0 | MTO RxPDO-Map Outputs 5x Ch.3 | PDO Mapping RxPDO 10 | UINT8 | RO | 0x13 (19dec)
1609:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7021:01, 1
1609:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7021:02, 1
1609:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x03 (Force order)) | UINT32 | RO | 0x7021:03, 1
1609:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7021:04, 1
1609:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1609:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7021:09, 8
1609:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x11 (No of output events)) | UINT32 | RO | 0x7021:11, 8
1609:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1609:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7021:21, 1
1609:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7021:22, 1
1609:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7021:23, 1
1609:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7021:24, 1
1609:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7021:25, 1
1609:0E | SubIndex 014 | 14. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1609:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7021:41, 32
1609:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7021:42, 32
1609:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7021:43, 32
1609:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7021:44, 32
1609:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7021:45, 32
Index 160A MTO RxPDO-Map Outputs 2x Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
160A:0 | MTO RxPDO-Map Outputs 2x Ch.3 | PDO Mapping RxPDO 11 | UINT8 | RO | 0x0D (13dec)
160A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7021:01, 1
160A:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7021:02, 1
160A:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x03 (Force order)) | UINT32 | RO | 0x7021:03, 1
160A:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7021:04, 1
160A:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
160A:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7021:09, 8
160A:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x11 (No of output events)) | UINT32 | RO | 0x7021:11, 8
160A:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
160A:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7021:21, 1
160A:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7021:22, 1
160A:0B | SubIndex 011 | 11. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
160A:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7021:41, 32
160A:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7021:42, 32
Index 160B MTO RxPDO-Map Outputs 1x Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
160B:0 | MTO RxPDO-Map Outputs 1x Ch.3 | PDO Mapping RxPDO 12 | UINT8 | RO | 0x0B (11dec)
160B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7021:01, 1
160B:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7021:02, 1
160B:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x03 (Force order)) | UINT32 | RO | 0x7021:03, 1
160B:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7021:04, 1
160B:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
160B:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7021:09, 8
160B:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x11 (No of output events)) | UINT32 | RO | 0x7021:11, 8
160B:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
160B:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7021:21, 1
160B:0A | SubIndex 010 | 10. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
160B:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7021:41, 32
Index 160C MTO RxPDO-Map Outputs 10x Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
160C:0 | MTO RxPDO-Map Outputs 10x Ch.4 | PDO Mapping RxPDO 13 | UINT8 | RO | 0x1D (29dec)
160C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7031:01, 1
160C:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7031:02, 1
160C:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x03 (Force order)) | UINT32 | RO | 0x7031:03, 1
160C:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7031:04, 1
160C:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
160C:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7031:09, 8
160C:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x11 (No of output events)) | UINT32 | RO | 0x7031:11, 8
160C:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
160C:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7031:21, 1
160C:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7031:22, 1
160C:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7031:23, 1
160C:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7031:24, 1
160C:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7031:25, 1
160C:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x26 (Output event state 6)) | UINT32 | RO | 0x7031:26, 1
160C:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x27 (Output event state 7)) | UINT32 | RO | 0x7031:27, 1
160C:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x28 (Output event state 8)) | UINT32 | RO | 0x7031:28, 1
160C:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x29 (Output event state 9)) | UINT32 | RO | 0x7031:29, 1
160C:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x2A (Output event state 10)) | UINT32 | RO | 0x7031:2A, 1
160C:13 | SubIndex 019 | 19. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
160C:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7031:41, 32
160C:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7031:42, 32
160C:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7031:43, 32
160C:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7031:44, 32
160C:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7031:45, 32
160C:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x46 (Output event time 6)) | UINT32 | RO | 0x7031:46, 32
160C:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x47 (Output event time 7)) | UINT32 | RO | 0x7031:47, 32
160C:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x48 (Output event time 8)) | UINT32 | RO | 0x7031:48, 32
160C:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x49 (Output event time 9)) | UINT32 | RO | 0x7031:49, 32
160C:1D | SubIndex 029 | 29. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x4A (Output event time 10)) | UINT32 | RO | 0x7031:4A, 32
Index 160D MTO RxPDO-Map Outputs 5x Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
160D:0 | MTO RxPDO-Map Outputs 5x Ch.4 | PDO Mapping RxPDO 14 | UINT8 | RO | 0x13 (19dec)
160D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7031:01, 1
160D:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7031:02, 1
160D:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x03 (Force order)) | UINT32 | RO | 0x7031:03, 1
160D:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7031:04, 1
160D:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
160D:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7031:09, 8
160D:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x11 (No of output events)) | UINT32 | RO | 0x7031:11, 8
160D:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
160D:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7031:21, 1
160D:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7031:22, 1
160D:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7031:23, 1
160D:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7031:24, 1
160D:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7031:25, 1
160D:0E | SubIndex 014 | 14. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
160D:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7031:41, 32
160D:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7031:42, 32
160D:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7031:43, 32
160D:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7031:44, 32
160D:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7031:45, 32
Index 160E MTO RxPDO-Map Outputs 2x Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
160E:0 | MTO RxPDO-Map Outputs 2x Ch.4 | PDO Mapping RxPDO 15 | UINT8 | RO | 0x0D (13dec)
160E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7031:01, 1
160E:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7031:02, 1
160E:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x03 (Force order)) | UINT32 | RO | 0x7031:03, 1
160E:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7031:04, 1
160E:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
160E:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7031:09, 8
160E:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x11 (No of output events)) | UINT32 | RO | 0x7031:11, 8
160E:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
160E:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7031:21, 1
160E:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7031:22, 1
160E:0B | SubIndex 011 | 11. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
160E:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7031:41, 32
160E:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7031:42, 32
Index 160F MTO RxPDO-Map Outputs 1x Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
160F:0 | MTO RxPDO-Map Outputs 1x Ch.4 | PDO Mapping RxPDO 16 | UINT8 | RO | 0x0B (11dec)
160F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7031:01, 1
160F:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7031:02, 1
160F:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x03 (Force order)) | UINT32 | RO | 0x7031:03, 1
160F:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7031:04, 1
160F:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
160F:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7031:09, 8
160F:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x11 (No of output events)) | UINT32 | RO | 0x7031:11, 8
160F:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
160F:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7031:21, 1
160F:0A | SubIndex 010 | 10. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
160F:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7031:41, 32
Index 1610 MTO RxPDO-Map Outputs 10x Ch.5
Index (hex) | Name | Meaning | Data type | Flags | Default
1610:0 | MTO RxPDO-Map Outputs 10x Ch.5 | PDO Mapping RxPDO 17 | UINT8 | RO | 0x1D (29dec)
1610:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7041:01, 1
1610:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7041:02, 1
1610:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x03 (Force order)) | UINT32 | RO | 0x7041:03, 1
1610:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7041:04, 1
1610:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1610:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7041:09, 8
1610:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x11 (No of output events)) | UINT32 | RO | 0x7041:11, 8
1610:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1610:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7041:21, 1
1610:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7041:22, 1
1610:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7041:23, 1
1610:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7041:24, 1
1610:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7041:25, 1
1610:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x26 (Output event state 6)) | UINT32 | RO | 0x7041:26, 1
1610:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x27 (Output event state 7)) | UINT32 | RO | 0x7041:27, 1
1610:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x28 (Output event state 8)) | UINT32 | RO | 0x7041:28, 1
1610:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x29 (Output event state 9)) | UINT32 | RO | 0x7041:29, 1
1610:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x2A (Output event state 10)) | UINT32 | RO | 0x7041:2A, 1
1610:13 | SubIndex 019 | 19. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1610:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7041:41, 32
1610:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7041:42, 32
1610:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7041:43, 32
1610:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7041:44, 32
1610:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7041:45, 32
1610:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x46 (Output event time 6)) | UINT32 | RO | 0x7041:46, 32
1610:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x47 (Output event time 7)) | UINT32 | RO | 0x7041:47, 32
1610:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x48 (Output event time 8)) | UINT32 | RO | 0x7041:48, 32
1610:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x49 (Output event time 9)) | UINT32 | RO | 0x7041:49, 32
1610:1D | SubIndex 029 | 29. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x4A (Output event time 10)) | UINT32 | RO | 0x7041:4A, 32
Index 1611 MTO RxPDO-Map Outputs 5x Ch.5
Index (hex) | Name | Meaning | Data type | Flags | Default
1611:0 | MTO RxPDO-Map Outputs 5x Ch.5 | PDO Mapping RxPDO 18 | UINT8 | RO | 0x13 (19dec)
1611:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7041:01, 1
1611:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7041:02, 1
1611:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x03 (Force order)) | UINT32 | RO | 0x7041:03, 1
1611:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7041:04, 1
1611:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1611:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7041:09, 8
1611:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x11 (No of output events)) | UINT32 | RO | 0x7041:11, 8
1611:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1611:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7041:21, 1
1611:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7041:22, 1
1611:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7041:23, 1
1611:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7041:24, 1
1611:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7041:25, 1
1611:0E | SubIndex 014 | 14. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1611:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7041:41, 32
1611:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7041:42, 32
1611:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7041:43, 32
1611:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7041:44, 32
1611:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7041:45, 32
Index 1612 MTO RxPDO-Map Outputs 2x Ch.5
Index (hex) | Name | Meaning | Data type | Flags | Default
1612:0 | MTO RxPDO-Map Outputs 2x Ch.5 | PDO Mapping RxPDO 19 | UINT8 | RO | 0x0D (13dec)
1612:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7041:01, 1
1612:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7041:02, 1
1612:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x03 (Force order)) | UINT32 | RO | 0x7041:03, 1
1612:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7041:04, 1
1612:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1612:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7041:09, 8
1612:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x11 (No of output events)) | UINT32 | RO | 0x7041:11, 8
1612:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1612:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7041:21, 1
1612:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7041:22, 1
1612:0B | SubIndex 011 | 11. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1612:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7041:41, 32
1612:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7041:42, 32
Index 1613 MTO RxPDO-Map Outputs 1x Ch.5
Index (hex) | Name | Meaning | Data type | Flags | Default
1613:0 | MTO RxPDO-Map Outputs 1x Ch.5 | PDO Mapping RxPDO 20 | UINT8 | RO | 0x0B (11dec)
1613:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7041:01, 1
1613:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7041:02, 1
1613:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x03 (Force order)) | UINT32 | RO | 0x7041:03, 1
1613:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7041:04, 1
1613:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1613:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7041:09, 8
1613:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x11 (No of output events)) | UINT32 | RO | 0x7041:11, 8
1613:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1613:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7041:21, 1
1613:0A | SubIndex 010 | 10. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1613:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7041:41, 32
Index 1614 MTO RxPDO-Map Outputs 10x Ch.6
Index (hex) | Name | Meaning | Data type | Flags | Default
1614:0 | MTO RxPDO-Map Outputs 10x Ch.6 | PDO Mapping RxPDO 21 | UINT8 | RO | 0x1D (29dec)
1614:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7051:01, 1
1614:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7051:02, 1
1614:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x03 (Force order)) | UINT32 | RO | 0x7051:03, 1
1614:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7051:04, 1
1614:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1614:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7051:09, 8
1614:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x11 (No of output events)) | UINT32 | RO | 0x7051:11, 8
1614:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1614:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7051:21, 1
1614:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7051:22, 1
1614:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7051:23, 1
1614:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7051:24, 1
1614:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7051:25, 1
1614:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x26 (Output event state 6)) | UINT32 | RO | 0x7051:26, 1
1614:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x27 (Output event state 7)) | UINT32 | RO | 0x7051:27, 1
1614:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x28 (Output event state 8)) | UINT32 | RO | 0x7051:28, 1
1614:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x29 (Output event state 9)) | UINT32 | RO | 0x7051:29, 1
1614:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x2A (Output event state 10)) | UINT32 | RO | 0x7051:2A, 1
1614:13 | SubIndex 019 | 19. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1614:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7051:41, 32
1614:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7051:42, 32
1614:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7051:43, 32
1614:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7051:44, 32
1614:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7051:45, 32
1614:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x46 (Output event time 6)) | UINT32 | RO | 0x7051:46, 32
1614:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x47 (Output event time 7)) | UINT32 | RO | 0x7051:47, 32
1614:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x48 (Output event time 8)) | UINT32 | RO | 0x7051:48, 32
1614:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x49 (Output event time 9)) | UINT32 | RO | 0x7051:49, 32
1614:1D | SubIndex 029 | 29. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x4A (Output event time 10)) | UINT32 | RO | 0x7051:4A, 32
Index 1615 MTO RxPDO-Map Outputs 5x Ch.6
Index (hex) | Name | Meaning | Data type | Flags | Default
1615:0 | MTO RxPDO-Map Outputs 5x Ch.6 | PDO Mapping RxPDO 22 | UINT8 | RO | 0x13 (19dec)
1615:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7051:01, 1
1615:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7051:02, 1
1615:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x03 (Force order)) | UINT32 | RO | 0x7051:03, 1
1615:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7051:04, 1
1615:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1615:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7051:09, 8
1615:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x11 (No of output events)) | UINT32 | RO | 0x7051:11, 8
1615:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1615:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7051:21, 1
1615:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7051:22, 1
1615:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7051:23, 1
1615:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7051:24, 1
1615:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7051:25, 1
1615:0E | SubIndex 014 | 14. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1615:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7051:41, 32
1615:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7051:42, 32
1615:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7051:43, 32
1615:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7051:44, 32
1615:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7051:45, 32
Index 1616 MTO RxPDO-Map Outputs 2x Ch.6
Index (hex) | Name | Meaning | Data type | Flags | Default
1616:0 | MTO RxPDO-Map Outputs 2x Ch.6 | PDO Mapping RxPDO 23 | UINT8 | RO | 0x0D (13dec)
1616:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7051:01, 1
1616:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7051:02, 1
1616:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x03 (Force order)) | UINT32 | RO | 0x7051:03, 1
1616:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7051:04, 1
1616:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1616:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7051:09, 8
1616:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x11 (No of output events)) | UINT32 | RO | 0x7051:11, 8
1616:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1616:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7051:21, 1
1616:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7051:22, 1
1616:0B | SubIndex 011 | 11. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1616:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7051:41, 32
1616:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7051:42, 32
Index 1617 MTO RxPDO-Map Outputs 1x Ch.6
Index (hex) | Name | Meaning | Data type | Flags | Default
1617:0 | MTO RxPDO-Map Outputs 1x Ch.6 | PDO Mapping RxPDO 24 | UINT8 | RO | 0x0B (11dec)
1617:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7051:01, 1
1617:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7051:02, 1
1617:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x03 (Force order)) | UINT32 | RO | 0x7051:03, 1
1617:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7051:04, 1
1617:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1617:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7051:09, 8
1617:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x11 (No of output events)) | UINT32 | RO | 0x7051:11, 8
1617:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1617:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7051:21, 1
1617:0A | SubIndex 010 | 10. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1617:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7051:41, 32
Index 1618 MTO RxPDO-Map Outputs 10x Ch.7
Index (hex) | Name | Meaning | Data type | Flags | Default
1618:0 | MTO RxPDO-Map Outputs 10x Ch.7 | PDO Mapping RxPDO 25 | UINT8 | RO | 0x1D (29dec)
1618:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7061:01, 1
1618:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7061:02, 1
1618:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x03 (Force order)) | UINT32 | RO | 0x7061:03, 1
1618:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7061:04, 1
1618:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1618:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7061:09, 8
1618:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x11 (No of output events)) | UINT32 | RO | 0x7061:11, 8
1618:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1618:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7061:21, 1
1618:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7061:22, 1
1618:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7061:23, 1
1618:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7061:24, 1
1618:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7061:25, 1
1618:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x26 (Output event state 6)) | UINT32 | RO | 0x7061:26, 1
1618:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x27 (Output event state 7)) | UINT32 | RO | 0x7061:27, 1
1618:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x28 (Output event state 8)) | UINT32 | RO | 0x7061:28, 1
1618:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x29 (Output event state 9)) | UINT32 | RO | 0x7061:29, 1
1618:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x2A (Output event state 10)) | UINT32 | RO | 0x7061:2A, 1
1618:13 | SubIndex 019 | 19. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1618:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7061:41, 32
1618:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7061:42, 32
1618:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7061:43, 32
1618:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7061:44, 32
1618:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7061:45, 32
1618:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x46 (Output event time 6)) | UINT32 | RO | 0x7061:46, 32
1618:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x47 (Output event time 7)) | UINT32 | RO | 0x7061:47, 32
1618:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x48 (Output event time 8)) | UINT32 | RO | 0x7061:48, 32
1618:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x49 (Output event time 9)) | UINT32 | RO | 0x7061:49, 32
1618:1D | SubIndex 029 | 29. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x4A (Output event time 10)) | UINT32 | RO | 0x7061:4A, 32
Index 1619 MTO RxPDO-Map Outputs 5x Ch.7
Index (hex) | Name | Meaning | Data type | Flags | Default
1619:0 | MTO RxPDO-Map Outputs 5x Ch.7 | PDO Mapping RxPDO 26 | UINT8 | RO | 0x13 (19dec)
1619:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7061:01, 1
1619:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7061:02, 1
1619:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x03 (Force order)) | UINT32 | RO | 0x7061:03, 1
1619:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7061:04, 1
1619:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1619:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7061:09, 8
1619:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x11 (No of output events)) | UINT32 | RO | 0x7061:11, 8
1619:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1619:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7061:21, 1
1619:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7061:22, 1
1619:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7061:23, 1
1619:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7061:24, 1
1619:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7061:25, 1
1619:0E | SubIndex 014 | 14. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1619:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7061:41, 32
1619:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7061:42, 32
1619:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7061:43, 32
1619:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7061:44, 32
1619:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7061:45, 32
Index 161A MTO RxPDO-Map Outputs 2x Ch.7
Index (hex) | Name | Meaning | Data type | Flags | Default
161A:0 | MTO RxPDO-Map Outputs 2x Ch.7 | PDO Mapping RxPDO 27 | UINT8 | RO | 0x0D (13dec)
161A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7061:01, 1
161A:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7061:02, 1
161A:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x03 (Force order)) | UINT32 | RO | 0x7061:03, 1
161A:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7061:04, 1
161A:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
161A:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7061:09, 8
161A:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x11 (No of output events)) | UINT32 | RO | 0x7061:11, 8
161A:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
161A:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7061:21, 1
161A:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7061:22, 1
161A:0B | SubIndex 011 | 11. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
161A:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7061:41, 32
161A:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7061:42, 32
Index 161B MTO RxPDO-Map Outputs 1x Ch.7
Index (hex) | Name | Meaning | Data type | Flags | Default
161B:0 | MTO RxPDO-Map Outputs 1x Ch.7 | PDO Mapping RxPDO 28 | UINT8 | RO | 0x0B (11dec)
161B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7061:01, 1
161B:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7061:02, 1
161B:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x03 (Force order)) | UINT32 | RO | 0x7061:03, 1
161B:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7061:04, 1
161B:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
161B:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7061:09, 8
161B:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x11 (No of output events)) | UINT32 | RO | 0x7061:11, 8
161B:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
161B:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7061:21, 1
161B:0A | SubIndex 010 | 10. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
161B:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7061:41, 32
Index 161C MTO RxPDO-Map Outputs 10x Ch.8
Index (hex) | Name | Meaning | Data type | Flags | Default
161C:0 | MTO RxPDO-Map Outputs 10x Ch.8 | PDO Mapping RxPDO 29 | UINT8 | RO | 0x1D (29dec)
161C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7071:01, 1
161C:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7071:02, 1
161C:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x03 (Force order)) | UINT32 | RO | 0x7071:03, 1
161C:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7071:04, 1
161C:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
161C:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7071:09, 8
161C:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x11 (No of output events)) | UINT32 | RO | 0x7071:11, 8
161C:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
161C:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7071:21, 1
161C:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7071:22, 1
161C:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7071:23, 1
161C:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7071:24, 1
161C:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7071:25, 1
161C:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x26 (Output event state 6)) | UINT32 | RO | 0x7071:26, 1
161C:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x27 (Output event state 7)) | UINT32 | RO | 0x7071:27, 1
161C:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x28 (Output event state 8)) | UINT32 | RO | 0x7071:28, 1
161C:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x29 (Output event state 9)) | UINT32 | RO | 0x7071:29, 1
161C:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x2A (Output event state 10)) | UINT32 | RO | 0x7071:2A, 1
161C:13 | SubIndex 019 | 19. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
161C:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7071:41, 32
161C:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7071:42, 32
161C:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7071:43, 32
161C:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7071:44, 32
161C:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7071:45, 32
161C:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x46 (Output event time 6)) | UINT32 | RO | 0x7071:46, 32
161C:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x47 (Output event time 7)) | UINT32 | RO | 0x7071:47, 32
161C:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x48 (Output event time 8)) | UINT32 | RO | 0x7071:48, 32
161C:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x49 (Output event time 9)) | UINT32 | RO | 0x7071:49, 32
161C:1D | SubIndex 029 | 29. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x4A (Output event time 10)) | UINT32 | RO | 0x7071:4A, 32
Index 161D MTO RxPDO-Map Outputs 5x Ch.8
Index (hex) | Name | Meaning | Data type | Flags | Default
161D:0 | MTO RxPDO-Map Outputs 5x Ch.8 | PDO Mapping RxPDO 30 | UINT8 | RO | 0x13 (19dec)
161D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7071:01, 1
161D:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7071:02, 1
161D:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x03 (Force order)) | UINT32 | RO | 0x7071:03, 1
161D:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7071:04, 1
161D:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
161D:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7071:09, 8
161D:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x11 (No of output events)) | UINT32 | RO | 0x7071:11, 8
161D:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
161D:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7071:21, 1
161D:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7071:22, 1
161D:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7071:23, 1
161D:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7071:24, 1
161D:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7071:25, 1
161D:0E | SubIndex 014 | 14. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
161D:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7071:41, 32
161D:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7071:42, 32
161D:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7071:43, 32
161D:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7071:44, 32
161D:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7071:45, 32
Index 161E MTO RxPDO-Map Outputs 2x Ch.8
Index (hex) | Name | Meaning | Data type | Flags | Default
161E:0 | MTO RxPDO-Map Outputs 2x Ch.8 | PDO Mapping RxPDO 31 | UINT8 | RO | 0x0D (13dec)
161E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7071:01, 1
161E:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7071:02, 1
161E:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x03 (Force order)) | UINT32 | RO | 0x7071:03, 1
161E:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7071:04, 1
161E:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
161E:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7071:09, 8
161E:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x11 (No of output events)) | UINT32 | RO | 0x7071:11, 8
161E:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
161E:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7071:21, 1
161E:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7071:22, 1
161E:0B | SubIndex 011 | 11. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
161E:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7071:41, 32
161E:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7071:42, 32
Index 161F MTO RxPDO-Map Outputs 1x Ch.8
Index (hex) | Name | Meaning | Data type | Flags | Default
161F:0 | MTO RxPDO-Map Outputs 1x Ch.8 | PDO Mapping RxPDO 32 | UINT8 | RO | 0x0B (11dec)
161F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7071:01, 1
161F:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7071:02, 1
161F:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x03 (Force order)) | UINT32 | RO | 0x7071:03, 1
161F:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7071:04, 1
161F:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
161F:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7071:09, 8
161F:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x11 (No of output events)) | UINT32 | RO | 0x7071:11, 8
161F:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
161F:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7071:21, 1
161F:0A | SubIndex 010 | 10. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
161F:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7071:41, 32
Index 1620 MTI RxPDO-Map Outputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1620:0 | MTI RxPDO-Map Outputs Ch.1 | PDO Mapping RxPDO 33 | UINT8 | RO | 0x04 (4dec)
1620:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7080 (MTI outputs Ch.1), entry 0x01 (Input buffer reset)) | UINT32 | RO | 0x7080:01, 1
1620:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1620:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7080 (MTI outputs Ch.1), entry 0x11 (Input order counter)) | UINT32 | RO | 0x7080:11, 8
1620:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1621 MTI RxPDO-Map Outputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1621:0 | MTI RxPDO-Map Outputs Ch.2 | PDO Mapping RxPDO 34 | UINT8 | RO | 0x04 (4dec)
1621:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7090 (MTI outputs Ch.2), entry 0x01 (Input buffer reset)) | UINT32 | RO | 0x7090:01, 1
1621:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1621:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7090 (MTI outputs Ch.2), entry 0x11 (Input order counter)) | UINT32 | RO | 0x7090:11, 8
1621:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1622 MTI RxPDO-Map Outputs Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1622:0 | MTI RxPDO-Map Outputs Ch.3 | PDO Mapping RxPDO 35 | UINT8 | RO | 0x04 (4dec)
1622:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x70A0 (MTI outputs Ch.3), entry 0x01 (Input buffer reset)) | UINT32 | RO | 0x70A0:01, 1
1622:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1622:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x70A0 (MTI outputs Ch.3), entry 0x11 (Input order counter)) | UINT32 | RO | 0x70A0:11, 8
1622:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1623 MTI RxPDO-Map Outputs Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
1623:0 | MTI RxPDO-Map Outputs Ch.4 | PDO Mapping RxPDO 36 | UINT8 | RO | 0x04 (4dec)
1623:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x70B0 (MTI outputs Ch.4), entry 0x01 (Input buffer reset)) | UINT32 | RO | 0x70B0:01, 1
1623:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1623:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x70B0 (MTI outputs Ch.4), entry 0x11 (Input order counter)) | UINT32 | RO | 0x70B0:11, 8
1623:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1624 MTI RxPDO-Map Outputs Ch.5
Index (hex) | Name | Meaning | Data type | Flags | Default
1624:0 | MTI RxPDO-Map Outputs Ch.5 | PDO Mapping RxPDO 37 | UINT8 | RO | 0x04 (4dec)
1624:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x70C0 (MTI outputs Ch.5), entry 0x01 (Input buffer reset)) | UINT32 | RO | 0x70C0:01, 1
1624:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1624:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x70C0 (MTI outputs Ch.5), entry 0x11 (Input order counter)) | UINT32 | RO | 0x70C0:11, 8
1624:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1625 MTI RxPDO-Map Outputs Ch.6
Index (hex) | Name | Meaning | Data type | Flags | Default
1625:0 | MTI RxPDO-Map Outputs Ch.6 | PDO Mapping RxPDO 38 | UINT8 | RO | 0x04 (4dec)
1625:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x70D0 (MTI outputs Ch.6), entry 0x01 (Input buffer reset)) | UINT32 | RO | 0x70D0:01, 1
1625:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1625:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x70D0 (MTI outputs Ch.6), entry 0x11 (Input order counter)) | UINT32 | RO | 0x70D0:11, 8
1625:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1626 MTI RxPDO-Map Outputs Ch.7
Index (hex) | Name | Meaning | Data type | Flags | Default
1626:0 | MTI RxPDO-Map Outputs Ch.7 | PDO Mapping RxPDO 39 | UINT8 | RO | 0x04 (4dec)
1626:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x70E0 (MTI outputs Ch.7), entry 0x01 (Input buffer reset)) | UINT32 | RO | 0x70E0:01, 1
1626:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1626:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x70E0 (MTI outputs Ch.7), entry 0x11 (Input order counter)) | UINT32 | RO | 0x70E0:11, 8
1626:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1627 MTI RxPDO-Map Outputs Ch.8
Index (hex) | Name | Meaning | Data type | Flags | Default
1627:0 | MTI RxPDO-Map Outputs Ch.8 | PDO Mapping RxPDO 40 | UINT8 | RO | 0x04 (4dec)
1627:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x70F0 (MTI outputs Ch.8), entry 0x01 (Input buffer reset)) | UINT32 | RO | 0x70F0:01, 1
1627:02 | SubIndex 002 | 2. PDO Mapping entry (15 Bits align) | UINT32 | RO | 0x0000:00, 15
1627:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x70F0 (MTI outputs Ch.8), entry 0x11 (Input order counter)) | UINT32 | RO | 0x70F0:11, 8
1627:04 | SubIndex 004 | 4. PDO Mapping entry (8 Bits align) | UINT32 | RO | 0x0000:00, 8
Index 1628 TSO RxPDO-Map Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1628:0 | TSO RxPDO-Map Ch.1 | PDO Mapping RxPDO 41 | UINT8 | RO | 0x05 (5dec)
1628:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7100 (TSO Outputs Ch.1), entry 0x01 (Output)) | UINT32 | RO | 0x7100:01, 1
1628:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1628:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7100 (TSO Outputs Ch.1), entry 0x11 (Activate)) | UINT32 | RO | 0x7100:11, 8
1628:04 | SubIndex 004 | 4. PDO Mapping entry (40 bits align) | UINT32 | RO | 0x0000:00, 40
1628:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7100 (TSO Outputs Ch.1), entry 0x41 (StartTime)) | UINT32 | RO | 0x7100:41, 64
Index 1629 TSO RxPDO-Map Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1629:0 | TSO RxPDO-Map Ch.2 | PDO Mapping RxPDO 42 | UINT8 | RO | 0x05 (5dec)
1629:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7110 (TSO Outputs Ch.2), entry 0x01 (Output)) | UINT32 | RO | 0x7110:01, 1
1629:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1629:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7110 (TSO Outputs Ch.2), entry 0x11 (Activate)) | UINT32 | RO | 0x7110:11, 8
1629:04 | SubIndex 004 | 4. PDO Mapping entry (40 bits align) | UINT32 | RO | 0x0000:00, 40
1629:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7110 (TSO Outputs Ch.2), entry 0x41 (StartTime)) | UINT32 | RO | 0x7110:41, 64
Index 162A TSO RxPDO-Map Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
162A:0 | TSO RxPDO-Map Ch.3 | PDO Mapping RxPDO 43 | UINT8 | RO | 0x05 (5dec)
162A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7120 (TSO Outputs Ch.3), entry 0x01 (Output)) | UINT32 | RO | 0x7120:01, 1
162A:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
162A:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7120 (TSO Outputs Ch.3), entry 0x11 (Activate)) | UINT32 | RO | 0x7120:11, 8
162A:04 | SubIndex 004 | 4. PDO Mapping entry (40 bits align) | UINT32 | RO | 0x0000:00, 40
162A:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7120 (TSO Outputs Ch.3), entry 0x41 (StartTime)) | UINT32 | RO | 0x7120:41, 64
Index 162B TSO RxPDO-Map Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
162B:0 | TSO RxPDO-Map Ch.4 | PDO Mapping RxPDO 44 | UINT8 | RO | 0x05 (5dec)
162B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7130 (TSO Outputs Ch.4), entry 0x01 (Output)) | UINT32 | RO | 0x7130:01, 1
162B:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
162B:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7130 (TSO Outputs Ch.4), entry 0x11 (Activate)) | UINT32 | RO | 0x7130:11, 8
162B:04 | SubIndex 004 | 4. PDO Mapping entry (40 bits align) | UINT32 | RO | 0x0000:00, 40
162B:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7130 (TSO Outputs Ch.4), entry 0x41 (StartTime)) | UINT32 | RO | 0x7130:41, 64
Index 162C TSO RxPDO-Map Ch.5
Index (hex) | Name | Meaning | Data type | Flags | Default
162C:0 | TSO RxPDO-Map Ch.5 | PDO Mapping RxPDO 45 | UINT8 | RO | 0x05 (5dec)
162C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7140 (TSO Outputs Ch.5), entry 0x01 (Output)) | UINT32 | RO | 0x7140:01, 1
162C:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
162C:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7140 (TSO Outputs Ch.5), entry 0x11 (Activate)) | UINT32 | RO | 0x7140:11, 8
162C:04 | SubIndex 004 | 4. PDO Mapping entry (40 bits align) | UINT32 | RO | 0x0000:00, 40
162C:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7140 (TSO Outputs Ch.5), entry 0x41 (StartTime)) | UINT32 | RO | 0x7140:41, 64
Index 162D TSO RxPDO-Map Ch.6
Index (hex) | Name | Meaning | Data type | Flags | Default
162D:0 | TSO RxPDO-Map Ch.6 | PDO Mapping RxPDO 46 | UINT8 | RO | 0x05 (5dec)
162D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7150 (TSO Outputs Ch.6), entry 0x01 (Output)) | UINT32 | RO | 0x7150:01, 1
162D:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
162D:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7150 (TSO Outputs Ch.6), entry 0x11 (Activate)) | UINT32 | RO | 0x7150:11, 8
162D:04 | SubIndex 004 | 4. PDO Mapping entry (40 bits align) | UINT32 | RO | 0x0000:00, 40
162D:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7150 (TSO Outputs Ch.6), entry 0x41 (StartTime)) | UINT32 | RO | 0x7150:41, 64
Index 162E TSO RxPDO-Map Ch.7
Index (hex) | Name | Meaning | Data type | Flags | Default
162E:0 | TSO RxPDO-Map Ch.7 | PDO Mapping RxPDO 47 | UINT8 | RO | 0x05 (5dec)
162E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7160 (TSO Outputs Ch.7), entry 0x01 (Output)) | UINT32 | RO | 0x7160:01, 1
162E:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
162E:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7160 (TSO Outputs Ch.7), entry 0x11 (Activate)) | UINT32 | RO | 0x7160:11, 8
162E:04 | SubIndex 004 | 4. PDO Mapping entry (40 bits align) | UINT32 | RO | 0x0000:00, 40
162E:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7160 (TSO Outputs Ch.7), entry 0x41 (StartTime)) | UINT32 | RO | 0x7160:41, 64
Index 162F TSO RxPDO-Map Ch.8
Index (hex) | Name | Meaning | Data type | Flags | Default
162F:0 | TSO RxPDO-Map Ch.8 | PDO Mapping RxPDO 48 | UINT8 | RO | 0x05 (5dec)
162F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7170 (TSO Outputs Ch.8), entry 0x01 (Output)) | UINT32 | RO | 0x7170:01, 1
162F:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
162F:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7170 (TSO Outputs Ch.8), entry 0x11 (Activate)) | UINT32 | RO | 0x7170:11, 8
162F:04 | SubIndex 004 | 4. PDO Mapping entry (40 bits align) | UINT32 | RO | 0x0000:00, 40
162F:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7170 (TSO Outputs Ch.8), entry 0x41 (StartTime)) | UINT32 | RO | 0x7170:41, 64
Index 1A00 MTO TxPDO-Map Inputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A00:0 | MTO TxPDO-Map Inputs Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x07 (7dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (MTO inputs Ch.1), entry 0x01 (Output short circuit)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (MTO inputs Ch.1), entry 0x02 (Output buffer overflow)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (MTO inputs Ch.1), entry 0x03 (Output state)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (MTO inputs Ch.1), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6000:0F, 2
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (MTO inputs Ch.1), entry 0x11 (Output order feedback)) | UINT32 | RO | 0x6000:11, 8
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (MTO inputs Ch.1), entry 0x12 (Events in output buffer)) | UINT32 | RO | 0x6000:12, 8
Index 1A01 MTO TxPDO-Map Inputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A01:0 | MTO TxPDO-Map Inputs Ch.2 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x07 (7dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (MTO inputs Ch.2), entry 0x01 (Output short circuit)) | UINT32 | RO | 0x6010:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (MTO inputs Ch.2), entry 0x02 (Output buffer overflow)) | UINT32 | RO | 0x6010:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (MTO inputs Ch.2), entry 0x03 (Output state)) | UINT32 | RO | 0x6010:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (MTO inputs Ch.2), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6010:0F, 2
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (MTO inputs Ch.2), entry 0x11 (Output order feedback)) | UINT32 | RO | 0x6010:11, 8
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (MTO inputs Ch.2), entry 0x12 (Events in output buffer)) | UINT32 | RO | 0x6010:12, 8
Index 1A02 MTO TxPDO-Map Inputs Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1A02:0 | MTO TxPDO-Map Inputs Ch.3 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x07 (7dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (MTO inputs Ch.3), entry 0x01 (Output short circuit)) | UINT32 | RO | 0x6020:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (MTO inputs Ch.3), entry 0x02 (Output buffer overflow)) | UINT32 | RO | 0x6020:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (MTO inputs Ch.3), entry 0x03 (Output state)) | UINT32 | RO | 0x6020:03, 1
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (MTO inputs Ch.3), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6020:0F, 2
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6020 (MTO inputs Ch.3), entry 0x11 (Output order feedback)) | UINT32 | RO | 0x6020:11, 8
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020 (MTO inputs Ch.3), entry 0x12 (Events in output buffer)) | UINT32 | RO | 0x6020:12, 8
Index 1A03 MTO TxPDO-Map Inputs Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
1A03:0 | MTO TxPDO-Map Inputs Ch.4 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x07 (7dec)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6030 (MTO inputs Ch.4), entry 0x01 (Output short circuit)) | UINT32 | RO | 0x6030:01, 1
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6030 (MTO inputs Ch.4), entry 0x02 (Output buffer overflow)) | UINT32 | RO | 0x6030:02, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6030 (MTO inputs Ch.4), entry 0x03 (Output state)) | UINT32 | RO | 0x6030:03, 1
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6030 (MTO inputs Ch.4), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6030:0F, 2
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6030 (MTO inputs Ch.4), entry 0x11 (Output order feedback)) | UINT32 | RO | 0x6030:11, 8
1A03:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6030 (MTO inputs Ch.4), entry 0x12 (Events in output buffer)) | UINT32 | RO | 0x6030:12, 8
Index 1A04 MTO TxPDO-Map Inputs Ch.5
Index (hex) | Name | Meaning | Data type | Flags | Default
1A04:0 | MTO TxPDO-Map Inputs Ch.5 | PDO Mapping TxPDO 5 | UINT8 | RO | 0x07 (7dec)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6040 (MTO inputs Ch.5), entry 0x01 (Output short circuit)) | UINT32 | RO | 0x6040:01, 1
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6040 (MTO inputs Ch.5), entry 0x02 (Output buffer overflow)) | UINT32 | RO | 0x6040:02, 1
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6040 (MTO inputs Ch.5), entry 0x03 (Output state)) | UINT32 | RO | 0x6040:03, 1
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6040 (MTO inputs Ch.5), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6040:0F, 2
1A04:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6040 (MTO inputs Ch.5), entry 0x11 (Output order feedback)) | UINT32 | RO | 0x6040:11, 8
1A04:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6040 (MTO inputs Ch.5), entry 0x12 (Events in output buffer)) | UINT32 | RO | 0x6040:12, 8
Index 1A05 MTO TxPDO-Map Inputs Ch.6
Index (hex) | Name | Meaning | Data type | Flags | Default
1A05:0 | MTO TxPDO-Map Inputs Ch.6 | PDO Mapping TxPDO 6 | UINT8 | RO | 0x07 (7dec)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6050 (MTO inputs Ch.6), entry 0x01 (Output short circuit)) | UINT32 | RO | 0x6050:01, 1
1A05:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6050 (MTO inputs Ch.6), entry 0x02 (Output buffer overflow)) | UINT32 | RO | 0x6050:02, 1
1A05:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6050 (MTO inputs Ch.6), entry 0x03 (Output state)) | UINT32 | RO | 0x6050:03, 1
1A05:04 | SubIndex 004 | 4. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
1A05:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6050 (MTO inputs Ch.6), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6050:0F, 2
1A05:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6050 (MTO inputs Ch.6), entry 0x11 (Output order feedback)) | UINT32 | RO | 0x6050:11, 8
1A05:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6050 (MTO inputs Ch.6), entry 0x12 (Events in output buffer)) | UINT32 | RO | 0x6050:12, 8
Index 1A06 MTO TxPDO-Map Inputs Ch.7
Index (hex) | Name | Meaning | Data type | Flags | Default
1A06:0 | MTO TxPDO-Map Inputs Ch.7 | PDO Mapping TxPDO 7 | UINT8 | RO | 0x07 (7dec)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6060 (MTO inputs Ch.7), entry 0x01 (Output short circuit)) | UINT32 | RO | 0x6060:01, 1
1A06:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6060 (MTO inputs Ch.7), entry 0x02 (Output buffer overflow)) | UINT32 | RO | 0x6060:02, 1
1A06:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6060 (MTO inputs Ch.7), entry 0x03 (Output state)) | UINT32 | RO | 0x6060:03, 1
1A06:04 | SubIndex 004 | 4. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
1A06:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6060 (MTO inputs Ch.7), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6060:0F, 2
1A06:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6060 (MTO inputs Ch.7), entry 0x11 (Output order feedback)) | UINT32 | RO | 0x6060:11, 8
1A06:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6060 (MTO inputs Ch.7), entry 0x12 (Events in output buffer)) | UINT32 | RO | 0x6060:12, 8
Index 1A07 MTO TxPDO-Map Inputs Ch.8
Index (hex) | Name | Meaning | Data type | Flags | Default
1A07:0 | MTO TxPDO-Map Inputs Ch.8 | PDO Mapping TxPDO 8 | UINT8 | RO | 0x07 (7dec)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6070 (MTO inputs Ch.8), entry 0x01 (Output short circuit)) | UINT32 | RO | 0x6070:01, 1
1A07:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6070 (MTO inputs Ch.8), entry 0x02 (Output buffer overflow)) | UINT32 | RO | 0x6070:02, 1
1A07:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6070 (MTO inputs Ch.8), entry 0x03 (Output state)) | UINT32 | RO | 0x6070:03, 1
1A07:04 | SubIndex 004 | 4. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
1A07:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6070 (MTO inputs Ch.8), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6070:0F, 2
1A07:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6070 (MTO inputs Ch.8), entry 0x11 (Output order feedback)) | UINT32 | RO | 0x6070:11, 8
1A07:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6070 (MTO inputs Ch.8), entry 0x12 (Events in output buffer)) | UINT32 | RO | 0x6070:12, 8
Index 1A08 MTI TxPDO-Map Inputs 10x Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A08:0 | MTI TxPDO-Map Inputs 10x Ch.1 | PDO Mapping TxPDO 9 | UINT8 | RO | 0x1C (28dec)
1A08:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x01 (No of input events)) | UINT32 | RO | 0x6081:01, 8
1A08:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x09 (Input state)) | UINT32 | RO | 0x6081:09, 1
1A08:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6081:0A, 1
1A08:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A08:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6081:0F, 2
1A08:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6081:11, 8
1A08:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6081:12, 8
1A08:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6081:21, 1
1A08:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6081:22, 1
1A08:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6081:23, 1
1A08:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6081:24, 1
1A08:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6081:25, 1
1A08:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x26 (Input event state 6)) | UINT32 | RO | 0x6081:26, 1
1A08:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x27 (Input event state 7)) | UINT32 | RO | 0x6081:27, 1
1A08:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x28 (Input event state 8)) | UINT32 | RO | 0x6081:28, 1
1A08:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x29 (Input event state 9)) | UINT32 | RO | 0x6081:29, 1
1A08:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x2A (Input event state 10)) | UINT32 | RO | 0x6081:2A, 1
1A08:12 | SubIndex 018 | 18. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1A08:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6081:41, 32
1A08:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6081:42, 32
1A08:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6081:43, 32
1A08:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6081:44, 32
1A08:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6081:45, 32
1A08:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x46 (Input event time 6)) | UINT32 | RO | 0x6081:46, 32
1A08:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x47 (Input event time 7)) | UINT32 | RO | 0x6081:47, 32
1A08:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x48 (Input event time 8)) | UINT32 | RO | 0x6081:48, 32
1A08:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x49 (Input event time 9)) | UINT32 | RO | 0x6081:49, 32
1A08:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x4A (Input event time 10)) | UINT32 | RO | 0x6081:4A, 32
Index 1A09 MTI TxPDO-Map Inputs 5x Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A09:0 | MTI TxPDO-Map Inputs 5x Ch.1 | PDO Mapping TxPDO 10 | UINT8 | RO | 0x12 (18dec)
1A09:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x01 (No of input events)) | UINT32 | RO | 0x6081:01, 8
1A09:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x09 (Input state)) | UINT32 | RO | 0x6081:09, 1
1A09:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6081:0A, 1
1A09:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A09:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6081:0F, 2
1A09:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6081:11, 8
1A09:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6081:12, 8
1A09:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6081:21, 1
1A09:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6081:22, 1
1A09:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6081:23, 1
1A09:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6081:24, 1
1A09:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6081:25, 1
1A09:0D | SubIndex 013 | 13. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1A09:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6081:41, 32
1A09:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6081:42, 32
1A09:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6081:43, 32
1A09:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6081:44, 32
1A09:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6081:45, 32
Index 1A0A MTI TxPDO-Map Inputs 2x Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A0A:0 | MTI TxPDO-Map Inputs 2x Ch.1 | PDO Mapping TxPDO 11 | UINT8 | RO | 0x0C (12dec)
1A0A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x01 (No of input events)) | UINT32 | RO | 0x6081:01, 8
1A0A:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x09 (Input state)) | UINT32 | RO | 0x6081:09, 1
1A0A:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6081:0A, 1
1A0A:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A0A:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6081:0F, 2
1A0A:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6081:11, 8
1A0A:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6081:12, 8
1A0A:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6081:21, 1
1A0A:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6081:22, 1
1A0A:0A | SubIndex 010 | 10. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1A0A:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6081:41, 32
1A0A:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6081:42, 32
Index 1A0B MTI TxPDO-Map Inputs 1x Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A0B:0 | MTI TxPDO-Map Inputs 1x Ch.1 | PDO Mapping TxPDO 12 | UINT8 | RO | 0x0A (10dec)
1A0B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x01 (No of input events)) | UINT32 | RO | 0x6081:01, 8
1A0B:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x09 (Input state)) | UINT32 | RO | 0x6081:09, 1
1A0B:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6081:0A, 1
1A0B:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A0B:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6081:0F, 2
1A0B:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6081:11, 8
1A0B:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6081:12, 8
1A0B:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6081:21, 1
1A0B:09 | SubIndex 009 | 9. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1A0B:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6081:41, 32
Index 1A0C MTI TxPDO-Map Inputs 10x Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A0C:0 | MTI TxPDO-Map Inputs 10x Ch.2 | PDO Mapping TxPDO 13 | UINT8 | RO | 0x1C (28dec)
1A0C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x01 (No of input events)) | UINT32 | RO | 0x6091:01, 8
1A0C:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x09 (Input state)) | UINT32 | RO | 0x6091:09, 1
1A0C:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6091:0A, 1
1A0C:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A0C:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6091:0F, 2
1A0C:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6091:11, 8
1A0C:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6091:12, 8
1A0C:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6091:21, 1
1A0C:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6091:22, 1
1A0C:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6091:23, 1
1A0C:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6091:24, 1
1A0C:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6091:25, 1
1A0C:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x26 (Input event state 6)) | UINT32 | RO | 0x6091:26, 1
1A0C:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x27 (Input event state 7)) | UINT32 | RO | 0x6091:27, 1
1A0C:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x28 (Input event state 8)) | UINT32 | RO | 0x6091:28, 1
1A0C:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x29 (Input event state 9)) | UINT32 | RO | 0x6091:29, 1
1A0C:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x2A (Input event state 10)) | UINT32 | RO | 0x6091:2A, 1
1A0C:12 | SubIndex 018 | 18. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1A0C:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6091:41, 32
1A0C:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6091:42, 32
1A0C:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6091:43, 32
1A0C:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6091:44, 32
1A0C:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6091:45, 32
1A0C:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x46 (Input event time 6)) | UINT32 | RO | 0x6091:46, 32
1A0C:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x47 (Input event time 7)) | UINT32 | RO | 0x6091:47, 32
1A0C:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x48 (Input event time 8)) | UINT32 | RO | 0x6091:48, 32
1A0C:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x49 (Input event time 9)) | UINT32 | RO | 0x6091:49, 32
1A0C:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x4A (Input event time 10)) | UINT32 | RO | 0x6091:4A, 32
Index 1A0D MTI TxPDO-Map Inputs 5x Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A0D:0 | MTI TxPDO-Map Inputs 5x Ch.2 | PDO Mapping TxPDO 14 | UINT8 | RO | 0x12 (18dec)
1A0D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x01 (No of input events)) | UINT32 | RO | 0x6091:01, 8
1A0D:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x09 (Input state)) | UINT32 | RO | 0x6091:09, 1
1A0D:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6091:0A, 1
1A0D:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A0D:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6091:0F, 2
1A0D:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6091:11, 8
1A0D:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6091:12, 8
1A0D:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6091:21, 1
1A0D:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6091:22, 1
1A0D:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6091:23, 1
1A0D:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6091:24, 1
1A0D:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6091:25, 1
1A0D:0D | SubIndex 013 | 13. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1A0D:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6091:41, 32
1A0D:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6091:42, 32
1A0D:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6091:43, 32
1A0D:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6091:44, 32
1A0D:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6091:45, 32
Index 1A0E MTI TxPDO-Map Inputs 2x Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A0E:0 | MTI TxPDO-Map Inputs 2x Ch.2 | PDO Mapping TxPDO 15 | UINT8 | RO | 0x0C (12dec)
1A0E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x01 (No of input events)) | UINT32 | RO | 0x6091:01, 8
1A0E:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x09 (Input state)) | UINT32 | RO | 0x6091:09, 1
1A0E:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6091:0A, 1
1A0E:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A0E:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6091:0F, 2
1A0E:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6091:11, 8
1A0E:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6091:12, 8
1A0E:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6091:21, 1
1A0E:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6091:22, 1
1A0E:0A | SubIndex 010 | 10. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1A0E:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6091:41, 32
1A0E:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6091:42, 32
Index 1A0F MTI TxPDO-Map Inputs 1x Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A0F:0 | MTI TxPDO-Map Inputs 1x Ch.2 | PDO Mapping TxPDO 16 | UINT8 | RO | 0x0A (10dec)
1A0F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x01 (No of input events)) | UINT32 | RO | 0x6091:01, 8
1A0F:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x09 (Input state)) | UINT32 | RO | 0x6091:09, 1
1A0F:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6091:0A, 1
1A0F:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A0F:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6091:0F, 2
1A0F:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6091:11, 8
1A0F:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6091:12, 8
1A0F:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6091:21, 1
1A0F:09 | SubIndex 009 | 9. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1A0F:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6091:41, 32
Index 1A10 MTI TxPDO-Map Inputs 10x Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1A10:0 | MTI TxPDO-Map Inputs 10x Ch.3 | PDO Mapping TxPDO 17 | UINT8 | RO | 0x1C (28dec)
1A10:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x01 (No of input events)) | UINT32 | RO | 0x60A1:01, 8
1A10:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x09 (Input state)) | UINT32 | RO | 0x60A1:09, 1
1A10:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60A1:0A, 1
1A10:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A10:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60A1:0F, 2
1A10:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60A1:11, 8
1A10:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60A1:12, 8
1A10:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60A1:21, 1
1A10:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x60A1:22, 1
1A10:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x60A1:23, 1
1A10:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x60A1:24, 1
1A10:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x60A1:25, 1
1A10:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x26 (Input event state 6)) | UINT32 | RO | 0x60A1:26, 1
1A10:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x27 (Input event state 7)) | UINT32 | RO | 0x60A1:27, 1
1A10:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x28 (Input event state 8)) | UINT32 | RO | 0x60A1:28, 1
1A10:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x29 (Input event state 9)) | UINT32 | RO | 0x60A1:29, 1
1A10:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x2A (Input event state 10)) | UINT32 | RO | 0x60A1:2A, 1
1A10:12 | SubIndex 018 | 18. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1A10:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60A1:41, 32
1A10:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x60A1:42, 32
1A10:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x60A1:43, 32
1A10:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x60A1:44, 32
1A10:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x60A1:45, 32
1A10:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x46 (Input event time 6)) | UINT32 | RO | 0x60A1:46, 32
1A10:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x47 (Input event time 7)) | UINT32 | RO | 0x60A1:47, 32
1A10:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x48 (Input event time 8)) | UINT32 | RO | 0x60A1:48, 32
1A10:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x49 (Input event time 9)) | UINT32 | RO | 0x60A1:49, 32
1A10:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x4A (Input event time 10)) | UINT32 | RO | 0x60A1:4A, 32
Index 1A11 MTI TxPDO-Map Inputs 5x Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1A11:0 | MTI TxPDO-Map Inputs 5x Ch.3 | PDO Mapping TxPDO 18 | UINT8 | RO | 0x12 (18dec)
1A11:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x01 (No of input events)) | UINT32 | RO | 0x60A1:01, 8
1A11:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x09 (Input state)) | UINT32 | RO | 0x60A1:09, 1
1A11:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60A1:0A, 1
1A11:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A11:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60A1:0F, 2
1A11:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60A1:11, 8
1A11:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60A1:12, 8
1A11:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60A1:21, 1
1A11:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x60A1:22, 1
1A11:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x60A1:23, 1
1A11:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x60A1:24, 1
1A11:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x60A1:25, 1
1A11:0D | SubIndex 013 | 13. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1A11:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60A1:41, 32
1A11:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x60A1:42, 32
1A11:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x60A1:43, 32
1A11:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x60A1:44, 32
1A11:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x60A1:45, 32
Index 1A12 MTI TxPDO-Map Inputs 2x Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1A12:0 | MTI TxPDO-Map Inputs 2x Ch.3 | PDO Mapping TxPDO 19 | UINT8 | RO | 0x0C (12dec)
1A12:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x01 (No of input events)) | UINT32 | RO | 0x60A1:01, 8
1A12:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x09 (Input state)) | UINT32 | RO | 0x60A1:09, 1
1A12:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60A1:0A, 1
1A12:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A12:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60A1:0F, 2
1A12:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60A1:11, 8
1A12:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60A1:12, 8
1A12:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60A1:21, 1
1A12:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x60A1:22, 1
1A12:0A | SubIndex 010 | 10. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1A12:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60A1:41, 32
1A12:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x60A1:42, 32
Index 1A13 MTI TxPDO-Map Inputs 1x Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1A13:0 | MTI TxPDO-Map Inputs 1x Ch.3 | PDO Mapping TxPDO 20 | UINT8 | RO | 0x0A (10dec)
1A13:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x01 (No of input events)) | UINT32 | RO | 0x60A1:01, 8
1A13:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x09 (Input state)) | UINT32 | RO | 0x60A1:09, 1
1A13:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60A1:0A, 1
1A13:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A13:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60A1:0F, 2
1A13:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60A1:11, 8
1A13:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60A1:12, 8
1A13:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60A1:21, 1
1A13:09 | SubIndex 009 | 9. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1A13:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60A1:41, 32
Index 1A14 MTI TxPDO-Map Inputs 10x Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
1A14:0 | MTI TxPDO-Map Inputs 10x Ch.4 | PDO Mapping TxPDO 21 | UINT8 | RO | 0x1C (28dec)
1A14:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x01 (No of input events)) | UINT32 | RO | 0x60B1:01, 8
1A14:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x09 (Input state)) | UINT32 | RO | 0x60B1:09, 1
1A14:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60B1:0A, 1
1A14:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A14:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60B1:0F, 2
1A14:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60B1:11, 8
1A14:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60B1:12, 8
1A14:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60B1:21, 1
1A14:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x60B1:22, 1
1A14:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x60B1:23, 1
1A14:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x60B1:24, 1
1A14:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x60B1:25, 1
1A14:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x26 (Input event state 6)) | UINT32 | RO | 0x60B1:26, 1
1A14:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x27 (Input event state 7)) | UINT32 | RO | 0x60B1:27, 1
1A14:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x28 (Input event state 8)) | UINT32 | RO | 0x60B1:28, 1
1A14:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x29 (Input event state 9)) | UINT32 | RO | 0x60B1:29, 1
1A14:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x2A (Input event state 10)) | UINT32 | RO | 0x60B1:2A, 1
1A14:12 | SubIndex 018 | 18. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1A14:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60B1:41, 32
1A14:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x60B1:42, 32
1A14:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x60B1:43, 32
1A14:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x60B1:44, 32
1A14:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x60B1:45, 32
1A14:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x46 (Input event time 6)) | UINT32 | RO | 0x60B1:46, 32
1A14:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x47 (Input event time 7)) | UINT32 | RO | 0x60B1:47, 32
1A14:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x48 (Input event time 8)) | UINT32 | RO | 0x60B1:48, 32
1A14:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x49 (Input event time 9)) | UINT32 | RO | 0x60B1:49, 32
1A14:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x4A (Input event time 10)) | UINT32 | RO | 0x60B1:4A, 32
Index 1A15 MTI TxPDO-Map Inputs 5x Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
1A15:0 | MTI TxPDO-Map Inputs 5x Ch.4 | PDO Mapping TxPDO 22 | UINT8 | RO | 0x12 (18dec)
1A15:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x01 (No of input events)) | UINT32 | RO | 0x60B1:01, 8
1A15:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x09 (Input state)) | UINT32 | RO | 0x60B1:09, 1
1A15:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60B1:0A, 1
1A15:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A15:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60B1:0F, 2
1A15:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60B1:11, 8
1A15:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60B1:12, 8
1A15:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60B1:21, 1
1A15:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x60B1:22, 1
1A15:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x60B1:23, 1
1A15:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x60B1:24, 1
1A15:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x60B1:25, 1
1A15:0D | SubIndex 013 | 13. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1A15:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60B1:41, 32
1A15:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x60B1:42, 32
1A15:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x60B1:43, 32
1A15:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x60B1:44, 32
1A15:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x60B1:45, 32
Index 1A16 MTI TxPDO-Map Inputs 2x Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
1A16:0 | MTI TxPDO-Map Inputs 2x Ch.4 | PDO Mapping TxPDO 23 | UINT8 | RO | 0x0C (12dec)
1A16:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x01 (No of input events)) | UINT32 | RO | 0x60B1:01, 8
1A16:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x09 (Input state)) | UINT32 | RO | 0x60B1:09, 1
1A16:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60B1:0A, 1
1A16:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A16:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60B1:0F, 2
1A16:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60B1:11, 8
1A16:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60B1:12, 8
1A16:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60B1:21, 1
1A16:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x60B1:22, 1
1A16:0A | SubIndex 010 | 10. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1A16:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60B1:41, 32
1A16:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x60B1:42, 32
Index 1A17 MTI TxPDO-Map Inputs 1x Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
1A17:0 | MTI TxPDO-Map Inputs 1x Ch.4 | PDO Mapping TxPDO 24 | UINT8 | RO | 0x0A (10dec)
1A17:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x01 (No of input events)) | UINT32 | RO | 0x60B1:01, 8
1A17:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x09 (Input state)) | UINT32 | RO | 0x60B1:09, 1
1A17:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60B1:0A, 1
1A17:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A17:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60B1:0F, 2
1A17:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60B1:11, 8
1A17:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60B1:12, 8
1A17:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60B1:21, 1
1A17:09 | SubIndex 009 | 9. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1A17:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60B1:41, 32
Index 1A18 MTI TxPDO-Map Inputs 10x Ch.5
Index (hex) | Name | Meaning | Data type | Flags | Default
1A18:0 | MTI TxPDO-Map Inputs 10x Ch.5 | PDO Mapping TxPDO 25 | UINT8 | RO | 0x1C (28dec)
1A18:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x01 (No of input events)) | UINT32 | RO | 0x60C1:01, 8
1A18:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x09 (Input state)) | UINT32 | RO | 0x60C1:09, 1
1A18:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60C1:0A, 1
1A18:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A18:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60C1:0F, 2
1A18:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60C1:11, 8
1A18:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60C1:12, 8
1A18:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60C1:21, 1
1A18:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x60C1:22, 1
1A18:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x60C1:23, 1
1A18:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x60C1:24, 1
1A18:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x60C1:25, 1
1A18:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x26 (Input event state 6)) | UINT32 | RO | 0x60C1:26, 1
1A18:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x27 (Input event state 7)) | UINT32 | RO | 0x60C1:27, 1
1A18:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x28 (Input event state 8)) | UINT32 | RO | 0x60C1:28, 1
1A18:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x29 (Input event state 9)) | UINT32 | RO | 0x60C1:29, 1
1A18:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x2A (Input event state 10)) | UINT32 | RO | 0x60C1:2A, 1
1A18:12 | SubIndex 018 | 18. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1A18:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60C1:41, 32
1A18:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x60C1:42, 32
1A18:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x60C1:43, 32
1A18:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x60C1:44, 32
1A18:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x60C1:45, 32
1A18:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x46 (Input event time 6)) | UINT32 | RO | 0x60C1:46, 32
1A18:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x47 (Input event time 7)) | UINT32 | RO | 0x60C1:47, 32
1A18:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x48 (Input event time 8)) | UINT32 | RO | 0x60C1:48, 32
1A18:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x49 (Input event time 9)) | UINT32 | RO | 0x60C1:49, 32
1A18:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x4A (Input event time 10)) | UINT32 | RO | 0x60C1:4A, 32
Index 1A19 MTI TxPDO-Map Inputs 5x Ch.5
Index (hex) | Name | Meaning | Data type | Flags | Default
1A19:0 | MTI TxPDO-Map Inputs 5x Ch.5 | PDO Mapping TxPDO 26 | UINT8 | RO | 0x12 (18dec)
1A19:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x01 (No of input events)) | UINT32 | RO | 0x60C1:01, 8
1A19:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x09 (Input state)) | UINT32 | RO | 0x60C1:09, 1
1A19:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60C1:0A, 1
1A19:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A19:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60C1:0F, 2
1A19:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60C1:11, 8
1A19:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60C1:12, 8
1A19:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60C1:21, 1
1A19:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x60C1:22, 1
1A19:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x60C1:23, 1
1A19:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x60C1:24, 1
1A19:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x60C1:25, 1
1A19:0D | SubIndex 013 | 13. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1A19:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60C1:41, 32
1A19:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x60C1:42, 32
1A19:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x60C1:43, 32
1A19:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x60C1:44, 32
1A19:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x60C1:45, 32
Index 1A1A MTI TxPDO-Map Inputs 2x Ch.5
Index (hex) | Name | Meaning | Data type | Flags | Default
1A1A:0 | MTI TxPDO-Map Inputs 2x Ch.5 | PDO Mapping TxPDO 27 | UINT8 | RO | 0x0C (12dec)
1A1A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x01 (No of input events)) | UINT32 | RO | 0x60C1:01, 8
1A1A:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x09 (Input state)) | UINT32 | RO | 0x60C1:09, 1
1A1A:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60C1:0A, 1
1A1A:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A1A:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60C1:0F, 2
1A1A:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60C1:11, 8
1A1A:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60C1:12, 8
1A1A:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60C1:21, 1
1A1A:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x60C1:22, 1
1A1A:0A | SubIndex 010 | 10. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1A1A:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60C1:41, 32
1A1A:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x60C1:42, 32
Index 1A1B MTI TxPDO-Map Inputs 1x Ch.5
Index (hex) | Name | Meaning | Data type | Flags | Default
1A1B:0 | MTI TxPDO-Map Inputs 1x Ch.5 | PDO Mapping TxPDO 28 | UINT8 | RO | 0x0A (10dec)
1A1B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x01 (No of input events)) | UINT32 | RO | 0x60C1:01, 8
1A1B:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x09 (Input state)) | UINT32 | RO | 0x60C1:09, 1
1A1B:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60C1:0A, 1
1A1B:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A1B:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60C1:0F, 2
1A1B:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60C1:11, 8
1A1B:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60C1:12, 8
1A1B:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60C1:21, 1
1A1B:09 | SubIndex 009 | 9. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1A1B:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60C1:41, 32
Index 1A1C MTI TxPDO-Map Inputs 10x Ch.6
Index (hex) | Name | Meaning | Data type | Flags | Default
1A1C:0 | MTI TxPDO-Map Inputs 10x Ch.6 | PDO Mapping TxPDO 29 | UINT8 | RO | 0x1C (28dec)
1A1C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x01 (No of input events)) | UINT32 | RO | 0x60D1:01, 8
1A1C:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x09 (Input state)) | UINT32 | RO | 0x60D1:09, 1
1A1C:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60D1:0A, 1
1A1C:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A1C:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60D1:0F, 2
1A1C:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60D1:11, 8
1A1C:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60D1:12, 8
1A1C:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60D1:21, 1
1A1C:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x60D1:22, 1
1A1C:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x60D1:23, 1
1A1C:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x60D1:24, 1
1A1C:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x60D1:25, 1
1A1C:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x26 (Input event state 6)) | UINT32 | RO | 0x60D1:26, 1
1A1C:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x27 (Input event state 7)) | UINT32 | RO | 0x60D1:27, 1
1A1C:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x28 (Input event state 8)) | UINT32 | RO | 0x60D1:28, 1
1A1C:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x29 (Input event state 9)) | UINT32 | RO | 0x60D1:29, 1
1A1C:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x2A (Input event state 10)) | UINT32 | RO | 0x60D1:2A, 1
1A1C:12 | SubIndex 018 | 18. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1A1C:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60D1:41, 32
1A1C:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x60D1:42, 32
1A1C:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x60D1:43, 32
1A1C:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x60D1:44, 32
1A1C:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x60D1:45, 32
1A1C:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x46 (Input event time 6)) | UINT32 | RO | 0x60D1:46, 32
1A1C:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x47 (Input event time 7)) | UINT32 | RO | 0x60D1:47, 32
1A1C:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x48 (Input event time 8)) | UINT32 | RO | 0x60D1:48, 32
1A1C:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x49 (Input event time 9)) | UINT32 | RO | 0x60D1:49, 32
1A1C:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x4A (Input event time 10)) | UINT32 | RO | 0x60D1:4A, 32
Index 1A1D MTI TxPDO-Map Inputs 5x Ch.6
Index (hex) | Name | Meaning | Data type | Flags | Default
1A1D:0 | MTI TxPDO-Map Inputs 5x Ch.6 | PDO Mapping TxPDO 30 | UINT8 | RO | 0x12 (18dec)
1A1D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x01 (No of input events)) | UINT32 | RO | 0x60D1:01, 8
1A1D:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x09 (Input state)) | UINT32 | RO | 0x60D1:09, 1
1A1D:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60D1:0A, 1
1A1D:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A1D:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60D1:0F, 2
1A1D:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60D1:11, 8
1A1D:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60D1:12, 8
1A1D:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60D1:21, 1
1A1D:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x60D1:22, 1
1A1D:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x60D1:23, 1
1A1D:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x60D1:24, 1
1A1D:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x60D1:25, 1
1A1D:0D | SubIndex 013 | 13. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1A1D:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60D1:41, 32
1A1D:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x60D1:42, 32
1A1D:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x60D1:43, 32
1A1D:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x60D1:44, 32
1A1D:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x60D1:45, 32
Index 1A1E MTI TxPDO-Map Inputs 2x Ch.6
Index (hex) | Name | Meaning | Data type | Flags | Default
1A1E:0 | MTI TxPDO-Map Inputs 2x Ch.6 | PDO Mapping TxPDO 31 | UINT8 | RO | 0x0C (12dec)
1A1E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x01 (No of input events)) | UINT32 | RO | 0x60D1:01, 8
1A1E:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x09 (Input state)) | UINT32 | RO | 0x60D1:09, 1
1A1E:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60D1:0A, 1
1A1E:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A1E:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60D1:0F, 2
1A1E:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60D1:11, 8
1A1E:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60D1:12, 8
1A1E:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60D1:21, 1
1A1E:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x60D1:22, 1
1A1E:0A | SubIndex 010 | 10. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1A1E:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60D1:41, 32
1A1E:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x60D1:42, 32
Index 1A1F MTI TxPDO-Map Inputs 1x Ch.6
Index (hex) | Name | Meaning | Data type | Flags | Default
1A1F:0 | MTI TxPDO-Map Inputs 1x Ch.6 | PDO Mapping TxPDO 32 | UINT8 | RO | 0x0A (10dec)
1A1F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x01 (No of input events)) | UINT32 | RO | 0x60D1:01, 8
1A1F:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x09 (Input state)) | UINT32 | RO | 0x60D1:09, 1
1A1F:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60D1:0A, 1
1A1F:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A1F:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60D1:0F, 2
1A1F:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60D1:11, 8
1A1F:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60D1:12, 8
1A1F:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60D1:21, 1
1A1F:09 | SubIndex 009 | 9. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1A1F:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60D1:41, 32
Index 1A20 MTI TxPDO-Map Inputs 10x Ch.7
Index (hex) | Name | Meaning | Data type | Flags | Default
1A20:0 | MTI TxPDO-Map Inputs 10x Ch.7 | PDO Mapping TxPDO 33 | UINT8 | RO | 0x1C (28dec)
1A20:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x01 (No of input events)) | UINT32 | RO | 0x60E1:01, 8
1A20:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x09 (Input state)) | UINT32 | RO | 0x60E1:09, 1
1A20:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60E1:0A, 1
1A20:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A20:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60E1:0F, 2
1A20:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60E1:11, 8
1A20:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60E1:12, 8
1A20:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60E1:21, 1
1A20:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x60E1:22, 1
1A20:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x60E1:23, 1
1A20:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x60E1:24, 1
1A20:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x60E1:25, 1
1A20:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x26 (Input event state 6)) | UINT32 | RO | 0x60E1:26, 1
1A20:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x27 (Input event state 7)) | UINT32 | RO | 0x60E1:27, 1
1A20:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x28 (Input event state 8)) | UINT32 | RO | 0x60E1:28, 1
1A20:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x29 (Input event state 9)) | UINT32 | RO | 0x60E1:29, 1
1A20:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x2A (Input event state 10)) | UINT32 | RO | 0x60E1:2A, 1
1A20:12 | SubIndex 018 | 18. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1A20:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60E1:41, 32
1A20:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x60E1:42, 32
1A20:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x60E1:43, 32
1A20:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x60E1:44, 32
1A20:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x60E1:45, 32
1A20:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x46 (Input event time 6)) | UINT32 | RO | 0x60E1:46, 32
1A20:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x47 (Input event time 7)) | UINT32 | RO | 0x60E1:47, 32
1A20:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x48 (Input event time 8)) | UINT32 | RO | 0x60E1:48, 32
1A20:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x49 (Input event time 9)) | UINT32 | RO | 0x60E1:49, 32
1A20:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x4A (Input event time 10)) | UINT32 | RO | 0x60E1:4A, 32
Index 1A21 MTI TxPDO-Map Inputs 5x Ch.7
Index (hex) | Name | Meaning | Data type | Flags | Default
1A21:0 | MTI TxPDO-Map Inputs 5x Ch.7 | PDO Mapping TxPDO 34 | UINT8 | RO | 0x12 (18dec)
1A21:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x01 (No of input events)) | UINT32 | RO | 0x60E1:01, 8
1A21:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x09 (Input state)) | UINT32 | RO | 0x60E1:09, 1
1A21:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60E1:0A, 1
1A21:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A21:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60E1:0F, 2
1A21:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60E1:11, 8
1A21:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60E1:12, 8
1A21:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60E1:21, 1
1A21:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x60E1:22, 1
1A21:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x60E1:23, 1
1A21:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x60E1:24, 1
1A21:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x60E1:25, 1
1A21:0D | SubIndex 013 | 13. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1A21:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60E1:41, 32
1A21:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x60E1:42, 32
1A21:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x60E1:43, 32
1A21:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x60E1:44, 32
1A21:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x60E1:45, 32
Index 1A22 MTI TxPDO-Map Inputs 2x Ch.7
Index (hex) | Name | Meaning | Data type | Flags | Default
1A22:0 | MTI TxPDO-Map Inputs 2x Ch.7 | PDO Mapping TxPDO 35 | UINT8 | RO | 0x0C (12dec)
1A22:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x01 (No of input events)) | UINT32 | RO | 0x60E1:01, 8
1A22:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x09 (Input state)) | UINT32 | RO | 0x60E1:09, 1
1A22:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60E1:0A, 1
1A22:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A22:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60E1:0F, 2
1A22:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60E1:11, 8
1A22:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60E1:12, 8
1A22:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60E1:21, 1
1A22:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x60E1:22, 1
1A22:0A | SubIndex 010 | 10. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1A22:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60E1:41, 32
1A22:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x60E1:42, 32
Index 1A23 MTI TxPDO-Map Inputs 1x Ch.7
Index (hex) | Name | Meaning | Data type | Flags | Default
1A23:0 | MTI TxPDO-Map Inputs 1x Ch.7 | PDO Mapping TxPDO 36 | UINT8 | RO | 0x0A (10dec)
1A23:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x01 (No of input events)) | UINT32 | RO | 0x60E1:01, 8
1A23:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x09 (Input state)) | UINT32 | RO | 0x60E1:09, 1
1A23:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60E1:0A, 1
1A23:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A23:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60E1:0F, 2
1A23:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60E1:11, 8
1A23:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60E1:12, 8
1A23:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60E1:21, 1
1A23:09 | SubIndex 009 | 9. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1A23:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60E1:41, 32
Index 1A24 MTI TxPDO-Map Inputs 10x Ch.8
Index (hex) | Name | Meaning | Data type | Flags | Default
1A24:0 | MTI TxPDO-Map Inputs 10x Ch.8 | PDO Mapping TxPDO 37 | UINT8 | RO | 0x1C (28dec)
1A24:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x01 (No of input events)) | UINT32 | RO | 0x60F1:01, 8
1A24:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x09 (Input state)) | UINT32 | RO | 0x60F1:09, 1
1A24:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60F1:0A, 1
1A24:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A24:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60F1:0F, 2
1A24:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60F1:11, 8
1A24:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60F1:12, 8
1A24:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60F1:21, 1
1A24:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x60F1:22, 1
1A24:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x60F1:23, 1
1A24:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x60F1:24, 1
1A24:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x60F1:25, 1
1A24:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x26 (Input event state 6)) | UINT32 | RO | 0x60F1:26, 1
1A24:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x27 (Input event state 7)) | UINT32 | RO | 0x60F1:27, 1
1A24:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x28 (Input event state 8)) | UINT32 | RO | 0x60F1:28, 1
1A24:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x29 (Input event state 9)) | UINT32 | RO | 0x60F1:29, 1
1A24:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x2A (Input event state 10)) | UINT32 | RO | 0x60F1:2A, 1
1A24:12 | SubIndex 018 | 18. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1A24:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60F1:41, 32
1A24:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x60F1:42, 32
1A24:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x60F1:43, 32
1A24:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x60F1:44, 32
1A24:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x60F1:45, 32
1A24:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x46 (Input event time 6)) | UINT32 | RO | 0x60F1:46, 32
1A24:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x47 (Input event time 7)) | UINT32 | RO | 0x60F1:47, 32
1A24:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x48 (Input event time 8)) | UINT32 | RO | 0x60F1:48, 32
1A24:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x49 (Input event time 9)) | UINT32 | RO | 0x60F1:49, 32
1A24:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x4A (Input event time 10)) | UINT32 | RO | 0x60F1:4A, 32
Index 1A25 MTI TxPDO-Map Inputs 5x Ch.8
Index (hex) | Name | Meaning | Data type | Flags | Default
1A25:0 | MTI TxPDO-Map Inputs 5x Ch.8 | PDO Mapping TxPDO 38 | UINT8 | RO | 0x12 (18dec)
1A25:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x01 (No of input events)) | UINT32 | RO | 0x60F1:01, 8
1A25:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x09 (Input state)) | UINT32 | RO | 0x60F1:09, 1
1A25:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60F1:0A, 1
1A25:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A25:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60F1:0F, 2
1A25:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60F1:11, 8
1A25:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60F1:12, 8
1A25:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60F1:21, 1
1A25:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x60F1:22, 1
1A25:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x60F1:23, 1
1A25:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x60F1:24, 1
1A25:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x60F1:25, 1
1A25:0D | SubIndex 013 | 13. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1A25:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60F1:41, 32
1A25:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x60F1:42, 32
1A25:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x60F1:43, 32
1A25:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x60F1:44, 32
1A25:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x60F1:45, 32
Index 1A26 MTI TxPDO-Map Inputs 2x Ch.8
Index (hex) | Name | Meaning | Data type | Flags | Default
1A26:0 | MTI TxPDO-Map Inputs 2x Ch.8 | PDO Mapping TxPDO 39 | UINT8 | RO | 0x0C (12dec)
1A26:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x01 (No of input events)) | UINT32 | RO | 0x60F1:01, 8
1A26:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x09 (Input state)) | UINT32 | RO | 0x60F1:09, 1
1A26:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60F1:0A, 1
1A26:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A26:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60F1:0F, 2
1A26:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60F1:11, 8
1A26:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60F1:12, 8
1A26:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60F1:21, 1
1A26:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x60F1:22, 1
1A26:0A | SubIndex 010 | 10. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1A26:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60F1:41, 32
1A26:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x60F1:42, 32
Index 1A27 MTI TxPDO-Map Inputs 1x Ch.8
Index (hex) | Name | Meaning | Data type | Flags | Default
1A27:0 | MTI TxPDO-Map Inputs 1x Ch.8 | PDO Mapping TxPDO 40 | UINT8 | RO | 0x0A (10dec)
1A27:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x01 (No of input events)) | UINT32 | RO | 0x60F1:01, 8
1A27:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x09 (Input state)) | UINT32 | RO | 0x60F1:09, 1
1A27:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60F1:0A, 1
1A27:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A27:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60F1:0F, 2
1A27:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60F1:11, 8
1A27:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60F1:12, 8
1A27:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60F1:21, 1
1A27:09 | SubIndex 009 | 9. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1A27:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60F1:41, 32
Index 1A28 TSO TxPDO-Map Inputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A28:0 | TSO TxPDO-Map Inputs Ch.1 | PDO Mapping TxPDO 41 | UINT8 | RO | 0x02 (2dec)
1A28:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6100 (TSO Inputs Ch.1), entry 0x01 (Feedback)) | UINT32 | RO | 0x6100:01, 1
1A28:02 | SubIndex 002 | 2. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
Index 1A29 TSO TxPDO-Map Inputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A29:0 | TSO TxPDO-Map Inputs Ch.2 | PDO Mapping TxPDO 42 | UINT8 | RO | 0x02 (2dec)
1A29:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6110 (TSO Inputs Ch.2), entry 0x01 (Feedback)) | UINT32 | RO | 0x6110:01, 1
1A29:02 | SubIndex 002 | 2. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
Index 1A2A TSO TxPDO-Map Inputs Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1A2A:0 | TSO TxPDO-Map Inputs Ch.3 | PDO Mapping TxPDO 43 | UINT8 | RO | 0x02 (2dec)
1A2A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6120 (TSO Inputs Ch.3), entry 0x01 (Feedback)) | UINT32 | RO | 0x6120:01, 1
1A2A:02 | SubIndex 002 | 2. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
Index 1A2B TSO TxPDO-Map Inputs Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
1A2B:0 | TSO TxPDO-Map Inputs Ch.4 | PDO Mapping TxPDO 44 | UINT8 | RO | 0x02 (2dec)
1A2B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6130 (TSO Inputs Ch.4), entry 0x01 (Feedback)) | UINT32 | RO | 0x6130:01, 1
1A2B:02 | SubIndex 002 | 2. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
Index 1A2C TSO TxPDO-Map Inputs Ch.5
Index (hex) | Name | Meaning | Data type | Flags | Default
1A2C:0 | TSO TxPDO-Map Inputs Ch.5 | PDO Mapping TxPDO 45 | UINT8 | RO | 0x02 (2dec)
1A2C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6140 (TSO Inputs Ch.5), entry 0x01 (Feedback)) | UINT32 | RO | 0x6140:01, 1
1A2C:02 | SubIndex 002 | 2. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
Index 1A2D TSO TxPDO-Map Inputs Ch.6
Index (hex) | Name | Meaning | Data type | Flags | Default
1A2D:0 | TSO TxPDO-Map Inputs Ch.6 | PDO Mapping TxPDO 46 | UINT8 | RO | 0x02 (2dec)
1A2D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6150 (TSO Inputs Ch.6), entry 0x01 (Feedback)) | UINT32 | RO | 0x6150:01, 1
1A2D:02 | SubIndex 002 | 2. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
Index 1A2E TSO TxPDO-Map Inputs Ch.7
Index (hex) | Name | Meaning | Data type | Flags | Default
1A2E:0 | TSO TxPDO-Map Inputs Ch.7 | PDO Mapping TxPDO 47 | UINT8 | RO | 0x02 (2dec)
1A2E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6160 (TSO Inputs Ch.7), entry 0x01 (Feedback)) | UINT32 | RO | 0x6160:01, 1
1A2E:02 | SubIndex 002 | 2. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
Index 1A2F TSO TxPDO-Map Inputs Ch.8
Index (hex) | Name | Meaning | Data type | Flags | Default
1A2F:0 | TSO TxPDO-Map Inputs Ch.8 | PDO Mapping TxPDO 48 | UINT8 | RO | 0x02 (2dec)
1A2F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6170 (TSO Inputs Ch.8), entry 0x01 (Feedback)) | UINT32 | RO | 0x6170:01, 1
1A2F:02 | SubIndex 002 | 2. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
Index 1A30 TSI TxPDO-Map Inputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A30:0 | TSI TxPDO-Map Inputs Ch.1 | PDO Mapping TxPDO 49 | UINT8 | RO | 0x06 (6dec)
1A30:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6180 (TSI Inputs Ch.1), entry 0x01 (Input)) | UINT32 | RO | 0x6180:01, 1
1A30:02 | SubIndex 002 | 2. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A30:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6180 (TSI Inputs Ch.1), entry 0x09 (Status)) | UINT32 | RO | 0x6180:09, 8
1A30:04 | SubIndex 004 | 4. PDO Mapping entry (48 bits align) | UINT32 | RO | 0x0000:00, 48
1A30:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6180 (TSI Inputs Ch.1), entry 0x41 (LatchPos)) | UINT32 | RO | 0x6180:41, 64
1A30:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6180 (TSI Inputs Ch.1), entry 0x42 (LatchNeg)) | UINT32 | RO | 0x6180:42, 64
Index 1A31 TSI TxPDO-Map Inputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A31:0 | TSI TxPDO-Map Inputs Ch.2 | PDO Mapping TxPDO 50 | UINT8 | RO | 0x06 (6dec)
1A31:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6190 (TSI Inputs Ch.2), entry 0x01 (Input)) | UINT32 | RO | 0x6190:01, 1
1A31:02 | SubIndex 002 | 2. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A31:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6190 (TSI Inputs Ch.2), entry 0x09 (Status)) | UINT32 | RO | 0x6190:09, 8
1A31:04 | SubIndex 004 | 4. PDO Mapping entry (48 bits align) | UINT32 | RO | 0x0000:00, 48
1A31:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6190 (TSI Inputs Ch.2), entry 0x41 (LatchPos)) | UINT32 | RO | 0x6190:41, 64
1A31:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6190 (TSI Inputs Ch.2), entry 0x42 (LatchNeg)) | UINT32 | RO | 0x6190:42, 64
Index 1A32 TSI TxPDO-Map Inputs Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1A32:0 | TSI TxPDO-Map Inputs Ch.3 | PDO Mapping TxPDO 51 | UINT8 | RO | 0x06 (6dec)
1A32:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x61A0 (TSI Inputs Ch.3), entry 0x01 (Input)) | UINT32 | RO | 0x61A0:01, 1
1A32:02 | SubIndex 002 | 2. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A32:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x61A0 (TSI Inputs Ch.3), entry 0x09 (Status)) | UINT32 | RO | 0x61A0:09, 8
1A32:04 | SubIndex 004 | 4. PDO Mapping entry (48 bits align) | UINT32 | RO | 0x0000:00, 48
1A32:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x61A0 (TSI Inputs Ch.3), entry 0x41 (LatchPos)) | UINT32 | RO | 0x61A0:41, 64
1A32:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x61A0 (TSI Inputs Ch.3), entry 0x42 (LatchNeg)) | UINT32 | RO | 0x61A0:42, 64
Index 1A33 TSI TxPDO-Map Inputs Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
1A33:0 | TSI TxPDO-Map Inputs Ch.4 | PDO Mapping TxPDO 52 | UINT8 | RO | 0x06 (6dec)
1A33:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x61B0 (TSI Inputs Ch.4), entry 0x01 (Input)) | UINT32 | RO | 0x61B0:01, 1
1A33:02 | SubIndex 002 | 2. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A33:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x61B0 (TSI Inputs Ch.4), entry 0x09 (Status)) | UINT32 | RO | 0x61B0:09, 8
1A33:04 | SubIndex 004 | 4. PDO Mapping entry (48 bits align) | UINT32 | RO | 0x0000:00, 48
1A33:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x61B0 (TSI Inputs Ch.4), entry 0x41 (LatchPos)) | UINT32 | RO | 0x61B0:41, 64
1A33:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x61B0 (TSI Inputs Ch.4), entry 0x42 (LatchNeg)) | UINT32 | RO | 0x61B0:42, 64
Index 1A34 TSI TxPDO-Map Inputs Ch.5
Index (hex) | Name | Meaning | Data type | Flags | Default
1A34:0 | TSI TxPDO-Map Inputs Ch.5 | PDO Mapping TxPDO 53 | UINT8 | RO | 0x06 (6dec)
1A34:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x61C0 (TSI Inputs Ch.5), entry 0x01 (Input)) | UINT32 | RO | 0x61C0:01, 1
1A34:02 | SubIndex 002 | 2. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A34:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x61C0 (TSI Inputs Ch.5), entry 0x09 (Status)) | UINT32 | RO | 0x61C0:09, 8
1A34:04 | SubIndex 004 | 4. PDO Mapping entry (48 bits align) | UINT32 | RO | 0x0000:00, 48
1A34:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x61C0 (TSI Inputs Ch.5), entry 0x41 (LatchPos)) | UINT32 | RO | 0x61C0:41, 64
1A34:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x61C0 (TSI Inputs Ch.5), entry 0x42 (LatchNeg)) | UINT32 | RO | 0x61C0:42, 64
Index 1A35 TSI TxPDO-Map Inputs Ch.6
Index (hex) | Name | Meaning | Data type | Flags | Default
1A35:0 | TSI TxPDO-Map Inputs Ch.6 | PDO Mapping TxPDO 54 | UINT8 | RO | 0x06 (6dec)
1A35:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x61D0 (TSI Inputs Ch.6), entry 0x01 (Input)) | UINT32 | RO | 0x61D0:01, 1
1A35:02 | SubIndex 002 | 2. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A35:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x61D0 (TSI Inputs Ch.6), entry 0x09 (Status)) | UINT32 | RO | 0x61D0:09, 8
1A35:04 | SubIndex 004 | 4. PDO Mapping entry (48 bits align) | UINT32 | RO | 0x0000:00, 48
1A35:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x61D0 (TSI Inputs Ch.6), entry 0x41 (LatchPos)) | UINT32 | RO | 0x61D0:41, 64
1A35:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x61D0 (TSI Inputs Ch.6), entry 0x42 (LatchNeg)) | UINT32 | RO | 0x61D0:42, 64
Index 1A36 TSI TxPDO-Map Inputs Ch.7
Index (hex) | Name | Meaning | Data type | Flags | Default
1A36:0 | TSI TxPDO-Map Inputs Ch.7 | PDO Mapping TxPDO 55 | UINT8 | RO | 0x06 (6dec)
1A36:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x61E0 (TSI Inputs Ch.7), entry 0x01 (Input)) | UINT32 | RO | 0x61E0:01, 1
1A36:02 | SubIndex 002 | 2. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A36:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x61E0 (TSI Inputs Ch.7), entry 0x09 (Status)) | UINT32 | RO | 0x61E0:09, 8
1A36:04 | SubIndex 004 | 4. PDO Mapping entry (48 bits align) | UINT32 | RO | 0x0000:00, 48
1A36:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x61E0 (TSI Inputs Ch.7), entry 0x41 (LatchPos)) | UINT32 | RO | 0x61E0:41, 64
1A36:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x61E0 (TSI Inputs Ch.7), entry 0x42 (LatchNeg)) | UINT32 | RO | 0x61E0:42, 64
Index 1A37 TSI TxPDO-Map Inputs Ch.8
Index (hex) | Name | Meaning | Data type | Flags | Default
1A37:0 | TSI TxPDO-Map Inputs Ch.8 | PDO Mapping TxPDO 56 | UINT8 | RO | 0x06 (6dec)
1A37:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x61F0 (TSI Inputs Ch.8), entry 0x01 (Input)) | UINT32 | RO | 0x61F0:01, 1
1A37:02 | SubIndex 002 | 2. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A37:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x61F0 (TSI Inputs Ch.8), entry 0x09 (Status)) | UINT32 | RO | 0x61F0:09, 8
1A37:04 | SubIndex 004 | 4. PDO Mapping entry (48 bits align) | UINT32 | RO | 0x0000:00, 48
1A37:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x61F0 (TSI Inputs Ch.8), entry 0x41 (LatchPos)) | UINT32 | RO | 0x61F0:41, 64
1A37:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x61F0 (TSI Inputs Ch.8), entry 0x42 (LatchNeg)) | UINT32 | RO | 0x61F0:42, 64
Index 1A38 DEV TxPDO-Map Inputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1A38:0 | DEV TxPDO-Map Inputs Device | PDO Mapping TxPDO 57 | UINT8 | RO | 0x06 (6dec)
1A38:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A38:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF611 (DEV Inputs), entry 0x02 (Undervoltage Up)) | UINT32 | RO | 0xF611:02, 1
1A38:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF611 (DEV Inputs), entry 0x03 (Overtemperature)) | UINT32 | RO | 0xF611:03, 1
1A38:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF611 (DEV Inputs), entry 0x04 (Checksum error)) | UINT32 | RO | 0xF611:04, 1
1A38:05 | SubIndex 005 | 5. PDO Mapping entry (60 bits align) | UINT32 | RO | 0x0000:00, 60
1A38:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF611 (DEV Inputs), entry 0x21 (SysTime)) | UINT32 | RO | 0xF611:21, 64
Index 1C00 Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the sync managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x10 (16dec)
1C12:01 | SubIndex 001 | 1. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1600 (5632dec)
1C12:02 | SubIndex 002 | 2. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1604 (5636dec)
1C12:03 | SubIndex 003 | 3. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1608 (5640dec)
1C12:04 | SubIndex 004 | 4. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x160C (5644dec)
1C12:05 | SubIndex 005 | 5. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1610 (5648dec)
1C12:06 | SubIndex 006 | 6. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1614 (5652dec)
1C12:07 | SubIndex 007 | 7. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1618 (5656dec)
1C12:08 | SubIndex 008 | 8. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x161C (5660dec)
1C12:09 | SubIndex 009 | 9. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1620 (5664dec)
1C12:0A | SubIndex 010 | 10. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1621 (5665dec)
1C12:0B | SubIndex 011 | 11. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1622 (5666dec)
1C12:0C | SubIndex 012 | 12. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1623 (5667dec)
1C12:0D | SubIndex 013 | 13. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1624 (5668dec)
1C12:0E | SubIndex 014 | 14. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1625 (5669dec)
1C12:0F | SubIndex 015 | 15. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1626 (5670dec)
1C12:10 | SubIndex 016 | 16. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1627 (5671dec)
1C12:11 | SubIndex 017 | 17. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:12 | SubIndex 018 | 18. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:13 | SubIndex 019 | 19. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:14 | SubIndex 020 | 20. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:15 | SubIndex 021 | 21. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:16 | SubIndex 022 | 22. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:17 | SubIndex 023 | 23. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:18 | SubIndex 024 | 24. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:19 | SubIndex 025 | 25. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:1A | SubIndex 026 | 26. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:1B | SubIndex 027 | 27. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 1C12 RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:1C | SubIndex 028 | 28. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:1D | SubIndex 029 | 29. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:1E | SubIndex 030 | 30. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:1F | SubIndex 031 | 31. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:20 | SubIndex 032 | 32. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:21 | SubIndex 033 | 33. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:22 | SubIndex 034 | 34. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:23 | SubIndex 035 | 35. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:24 | SubIndex 036 | 36. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:25 | SubIndex 037 | 37. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:26 | SubIndex 038 | 38. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:27 | SubIndex 039 | 39. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:28 | SubIndex 040 | 40. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:29 | SubIndex 041 | 41. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:2A | SubIndex 042 | 42. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:2B | SubIndex 043 | 43. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:2C | SubIndex 044 | 44. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:2D | SubIndex 045 | 45. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:2E | SubIndex 046 | 46. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:2F | SubIndex 047 | 47. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:30 | SubIndex 048 | 48. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 1C13 TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x10 (16dec)
1C13:01 | SubIndex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | SubIndex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A01 (6657dec)
1C13:03 | SubIndex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A02 (6658dec)
1C13:04 | SubIndex 004 | 4. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A03 (6659dec)
1C13:05 | SubIndex 005 | 5. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A04 (6660dec)
1C13:06 | SubIndex 006 | 6. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A05 (6661dec)
1C13:07 | SubIndex 007 | 7. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A06 (6662dec)
1C13:08 | SubIndex 008 | 8. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A07 (6663dec)
1C13:09 | SubIndex 009 | 9. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A08 (6664dec)
1C13:0A | SubIndex 010 | 10. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A0C (6668dec)
1C13:0B | SubIndex 011 | 11. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A10 (6672dec)
1C13:0C | SubIndex 012 | 12. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A14 (6676dec)
1C13:0D | SubIndex 013 | 13. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A18 (6680dec)
1C13:0E | SubIndex 014 | 14. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A1C (6684dec)
1C13:0F | SubIndex 015 | 15. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A20 (6688dec)
1C13:10 | SubIndex 016 | 16. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A24 (6692dec)
1C13:11 | SubIndex 017 | 17. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:12 | SubIndex 018 | 18. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:13 | SubIndex 019 | 19. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:14 | SubIndex 020 | 20. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:15 | SubIndex 021 | 21. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:16 | SubIndex 022 | 22. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:17 | SubIndex 023 | 23. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:18 | SubIndex 024 | 24. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:19 | SubIndex 025 | 25. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:1A | SubIndex 026 | 26. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:1B | SubIndex 027 | 27. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 1C13 TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:1C | SubIndex 028 | 28. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:1D | SubIndex 029 | 29. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:1E | SubIndex 030 | 30. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:1F | SubIndex 031 | 31. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:20 | SubIndex 032 | 32. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:21 | SubIndex 033 | 33. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:22 | SubIndex 034 | 34. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:23 | SubIndex 035 | 35. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:24 | SubIndex 036 | 36. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:25 | SubIndex 037 | 37. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:26 | SubIndex 038 | 38. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:27 | SubIndex 039 | 39. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:28 | SubIndex 040 | 40. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:29 | SubIndex 041 | 41. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:2A | SubIndex 042 | 42. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:2B | SubIndex 043 | 43. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:2C | SubIndex 044 | 44. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:2D | SubIndex 045 | 45. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:2E | SubIndex 046 | 46. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:2F | SubIndex 047 | 47. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:30 | SubIndex 048 | 48. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:31 | SubIndex 049 | 49. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:32 | SubIndex 050 | 50. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:33 | SubIndex 051 | 51. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:34 | SubIndex 052 | 52. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:35 | SubIndex 053 | 53. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:36 | SubIndex 054 | 54. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:37 | SubIndex 055 | 55. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:38 | SubIndex 056 | 56. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:39 | SubIndex 057 | 57. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 1C32 SM output parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C32:0
SM output parameter
Synchronization parameters for the outputs
UINT8
RO
0x20 (32dec)
1C32:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0000 (0dec)
1C32:02
Cycle time
Cycle time (in ns):
▪
Free Run: Cycle time of the local timer
▪
Synchronous with SM 2 event: Master cycle time
▪
DC mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000C3500 (800000dec)
1C32:03
Shift time
Time between SYNC0 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000384 (900dec)
1C32:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0 = 1: free run is supported
▪
Bit 1 = 1: Synchronous with SM 2 event is supported
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 10: Output shift with SYNC1 event (only DC mode)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08)
UINT16
RO
0x0804 (2052dec)
1C32:05
Minimum cycle time
Minimum cycle time (in ns)
UINT32
RO
0x00001F40 (8000dec)
1C32:06
Calc and copy time
Minimum time between SYNC0 and SYNC1 event (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:07
Minimum delay time
UINT32
RO
0x00000384 (900dec)
1C32:08
Command
▪
0: Measurement of the local cycle time is stopped
▪
1: Measurement of the local cycle time is started
The entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, and 0x1C33:09 are updated with the maximum measured values.
For a subsequent measurement the measured values are reset
UINT16
RW
0x0000 (0dec)
1C32:09
Maximum delay time
Time between SYNC1 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000384 (900dec)
1C32:0B
SM event missed counter
Number of missed SM events in OPERATIONAL (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:0C
Cycle exceeded counter
Number of occasions the cycle time was exceeded in OPERATIONAL (cycle was not completed in time or the next cycle began too early)
UINT16
RO
0x0000 (0dec)
1C32:0D
Shift too short counter
Number of occasions that the interval between SYNC0 and SYNC1 event was too short (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:20
Sync error
The synchronization was not correct in the last cycle (outputs were output too late; DC mode only)
BOOLEAN
RO
0x00 (0dec)
Index 1C33 SM input parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchronous with SM 3 event (no outputs available)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchronous with SM 2 event (outputs available)
UINT16
RW
0x0000 (0dec)
1C33:02
Cycle time
as 0x1C32:02
UINT32
RW
0x000C3500 (800000dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000384 (900dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: synchronous with SM 2 event is supported (outputs available)
▪
Bit 1: synchronous with SM 3 event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: input shift through local event (outputs available)
▪
Bit 4-5 = 10: input shift with SYNC1 event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08 or 0x1C33:08)
UINT16
RO
0x0804 (2052dec)
1C33:05
Minimum cycle time
as 0x1C32:05
UINT32
RO
0x00001F40 (8000dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:07
Minimum delay time
UINT32
RO
0x00000384 (900dec)
1C33:08
Command
as 0x1C32:08
UINT16
RW
0x0000 (0dec)
1C33:09
Maximum delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000384 (900dec)
1C33:0B
SM event missed counter
as 0x1C32:11
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
as 0x1C32:12
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
as 0x1C32:13
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
as 0x1C32:32
BOOLEAN
RO
0x00 (0dec)
Index F000 Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index spacing of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0020 (32dec)
Index F008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module list
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list | MDP Profile | UINT8 | RW | 0x20 (32dec)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x000000DC (220dec)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x000000DC (220dec)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x000000DC (220dec)
F010:04 | SubIndex 004 |  | UINT32 | RW | 0x000000DC (220dec)
F010:05 | SubIndex 005 |  | UINT32 | RW | 0x000000DC (220dec)
F010:06 | SubIndex 006 |  | UINT32 | RW | 0x000000DC (220dec)
F010:07 | SubIndex 007 |  | UINT32 | RW | 0x000000DC (220dec)
F010:08 | SubIndex 008 |  | UINT32 | RW | 0x000000DC (220dec)
F010:09 | SubIndex 009 |  | UINT32 | RW | 0x00000078 (120dec)
F010:0A | SubIndex 010 |  | UINT32 | RW | 0x00000078 (120dec)
F010:0B | SubIndex 011 |  | UINT32 | RW | 0x00000078 (120dec)
F010:0C | SubIndex 012 |  | UINT32 | RW | 0x00000078 (120dec)
F010:0D | SubIndex 013 |  | UINT32 | RW | 0x00000078 (120dec)
F010:0E | SubIndex 014 |  | UINT32 | RW | 0x00000078 (120dec)
F010:0F | SubIndex 015 |  | UINT32 | RW | 0x00000078 (120dec)
F010:10 | SubIndex 016 |  | UINT32 | RW | 0x00000078 (120dec)
F010:11 | SubIndex 017 |  | UINT32 | RW | 0x000000DD (221dec)
F010:12 | SubIndex 018 |  | UINT32 | RW | 0x000000DD (221dec)
F010:13 | SubIndex 019 |  | UINT32 | RW | 0x000000DD (221dec)
F010:14 | SubIndex 020 |  | UINT32 | RW | 0x000000DD (221dec)
Index F010 Module list
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:15 | SubIndex 021 |  | UINT32 | RW | 0x000000DD (221dec)
F010:16 | SubIndex 022 |  | UINT32 | RW | 0x000000DD (221dec)
F010:17 | SubIndex 023 |  | UINT32 | RW | 0x000000DD (221dec)
F010:18 | SubIndex 024 |  | UINT32 | RW | 0x000000DD (221dec)
F010:19 | SubIndex 025 |  | UINT32 | RW | 0x00000079 (121dec)
F010:1A | SubIndex 026 |  | UINT32 | RW | 0x00000079 (121dec)
F010:1B | SubIndex 027 |  | UINT32 | RW | 0x00000079 (121dec)
F010:1C | SubIndex 028 |  | UINT32 | RW | 0x00000079 (121dec)
F010:1D | SubIndex 029 |  | UINT32 | RW | 0x00000079 (121dec)
F010:1E | SubIndex 030 |  | UINT32 | RW | 0x00000079 (121dec)
F010:1F | SubIndex 031 |  | UINT32 | RW | 0x00000079 (121dec)
F010:20 | SubIndex 032 |  | UINT32 | RW | 0x00000079 (121dec)


EL2258

Commissioning [image] CoE object description and parameterization [image] EL2258
EL2258
Additional information
•
Object description and parameterization
•
Object description - standard objects


Object description and parameterization

Commissioning [image] CoE object description and parameterization [image] EL2258 [image] Object description and parameterization
Object description and parameterization
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Parameterization via the CoE list (CAN over EtherCAT)
The terminal is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs). Please note the following general CoE information when using/manipulating the CoE parameters:
- Keep a startup list if components have to be replaced
- Differentiation between online/offline dictionary, existence of current XML description
- Use "CoE reload" for resetting changes
Additional information
•
Restore object
•
Configuration data
•
Input data
•
Output data
•
Diagnostic data
•
Information data
•
Command object


Restore object

Commissioning [image] CoE object description and parameterization [image] EL2258 [image] Object description and parameterization [image] Restore object
Restore object
Index 1011 Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default parameters | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to “0x64616F6C” in the set value dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)


Configuration data

Commissioning [image] CoE object description and parameterization [image] EL2258 [image] Object description and parameterization [image] Configuration data
Configuration data
Index 8pp1 MTO Settings (for 00 ≤ pp ≤ 07; Ch. 1 to Ch. 8)
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8pp1:0 | MTO Settings |  |  | UINT8 | RO | 0x12 (18dec)
8pp1:01 | Use as +24 V power supply | Activates the output permanently. The channel cannot be used for processing of timestamp events. The output is deactivated as soon as the EtherCAT status is not OP. |  | BOOLEAN | RW | 0x00 (0dec)
8pp1:02 | Enable manual operation | Via this object the output can be switched manually. |  | BOOLEAN | RW | 0x00 (0dec)
8pp1:03 | Enable time check | This bit can be used to determine how to handle switching orders that were placed before the current time (further explanation see here). |  | BOOLEAN | RW | 0x00 (0dec)
8pp1:11 | Buffer reset behavior | Specifies the behavior of the "Output buffer reset" bit Permitted values: |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | Reset on rising edge: The buffer is cleared with a rising edge of "Output buffer reset"
 |  | 1 | Reset on high level: The buffer is cleared with a rising edge of "Output buffer reset" and does not accept new values until "Output buffer reset" is reset.
8pp1:12 | Buffer overflow behavior | Specifies the behavior in the event of buffer overflow Permitted values: |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | Lock buffer: New events are discarded
 |  | 1 | Overwrite oldest value: New events overwrite the last events in the buffer
Index 8ppF MTO Vendor data (for 00 ≤ pp ≤ 07; Ch. 1 to Ch. 8)
Index (hex) | Name | Meaning | Data type | Flags | Default
8ppF:0 | MTO Vendor data |  | UINT8 | RO | 0x12 (18dec)
8ppF:11 | Offset pos | This object can be used to move the output time of the rising edges. This setting is left to the manufacturer. | INT32 | RW | 0x00000000 (0dec)
8ppF:12 | Offset neg | This object can be used to move the output time of the falling edges. This setting is left to the manufacturer. | INT32 | RW | 0x00000000 (0dec)
Index 8ppF TSO Vendor data (for 08 ≤ pp ≤ 0F; Ch. 1 to Ch. 8)
Index (hex) | Name | Meaning | Data type | Flags | Default
8ppF:0 | TSO Vendor data |  | UINT8 | RO | 0x12 (18dec)
8ppF:11 | Offset pos | This object can be used to move the output time of the rising edges. This setting is left to the manufacturer. | INT32 | RW | 0x00000000 (0dec)
8ppF:12 | Offset neg | This object can be used to move the output time of the falling edges. This setting is left to the manufacturer. | INT32 | RW | 0x00000000 (0dec)


Input data

Commissioning [image] CoE object description and parameterization [image] EL2258 [image] Object description and parameterization [image] Input data
Input data
Index 6pp0 MTO inputs (for 00 ≤ pp ≤ 07; Ch. 1 to Ch. 8)
Index (hex) | Name | Meaning | Data type | Flags | Default
6pp0:0 | MTO inputs |  | UINT8 | RO | 0x00 (0dec)
6pp0:01 | Output short circuit | The channel signals a short circuit | BOOLEAN | RO | 0x00 (0dec)
6pp0:02 | Output buffer overflow | More events were written to the buffer than it can hold | BOOLEAN | RO | 0x00 (0dec)
6pp0:03 | Output state | Current output state at the time of the process data cycle | BOOLEAN | RO | 0x00 (0dec)
6pp0:0F | Input cycle counter | Is incremented with each process data cycle and switches to 0 after its maximum value of 3. | BIT2 | RO | 0x00 (0dec)
6pp0:11 | Output order feedback | This byte reflects the state of the "Output order counter" byte. | UINT8 | RO | 0x00 (0dec)
6pp0:12 | Events in output buffer | Returns the number of switching orders currently still in the buffer | UINT8 | RO | 0x00 (0dec)
Index 6pp0 TSO Inputs (for 08 ≤ pp ≤ 0F; Ch. 1 to Ch. 8)
Index (hex) | Name | Meaning | Data type | Flags | Default
6pp0:0 | TSO Inputs |  | UINT8 | RO | 0x00 (0dec)
6pp0:01 | Feedback | Returns the current value of the output | BOOLEAN | RO | 0x00 (0dec)
Index F611 DEV Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
F611:0 | DEV Inputs |  | UINT8 | RO | 0x00 (0dec)
F611:02 | Undervoltage Up | The nominal voltage at the power contacts was significantly below the minimum value. | BOOLEAN | RO | 0x00 (0dec)
F611:03 | Overtemperature | Overtemperature fault: The temperature of the input or output blocks is too high. For output terminals check whether one of the channels is affected by a short circuit. | BOOLEAN | RO | 0x00 (0dec)
F611:04 | Checksum error | An error occurred in the internal data transfer | BOOLEAN | RO | 0x00 (0dec)
F611:21 | SysTime | DC timestamp of the last input mapping. This timestamp should not be used as reference (information on DC reference times). | UINT64 | RO |


Output data

Commissioning [image] CoE object description and parameterization [image] EL2258 [image] Object description and parameterization [image] Output data
Output data
Index 7pp1 MTO outputs (for 00 ≤ pp ≤ 07; Ch. 1 to Ch. 8)
Index (hex)
Name
Meaning
Data type
Flags
Default
7pp1:0
MTO outputs
UINT8
RO
0x00 (0dec)
7pp1:01
Output buffer reset
Removes all elements from the buffer
Clearing can be achieved through a rising edge or continuously by applying 1 at this bit. The behavior can be parameterized via CoE object 0x8pp1:11.
BOOLEAN
RO
0x00 (0dec)
7pp1:02
Manual output state
This bit can be used to switch the output without using timestamps.
▪
Method 1: The CoE object 0x8pp1:02 ("Enable manual operation") is set to TRUE. Timestamp mode is now switched off, and the output can only be switched via the bit "Manual operation state". This is particularly helpful for the commissioning phase.
▪
Method 2: Via the bit "Enable manual operation" (0x7pp1:04) the channel output can be forced to the value of this object. Timestamp processing continues in the background. Output is only reactivated if the bit "Enable manual operation" is set to 0 again.
BOOLEAN
RO
0x00 (0dec)
7pp1:03
Force order
This bit defines how to deal with timestamps that were placed in the past (see diagram).
BOOLEAN
RO
0x00 (0dec)
7pp1:04
Enable manual operation
See "Manual output state" (0x7pp1:02).
BOOLEAN
RO
0x00 (0dec)
7pp1:09
Output order counter
Incrementing this byte indicates to the channel that new output events can be accepted
UINT8
RO
0x00 (0dec)
7pp1:11
No of output events
Number of filled "Output event state" and "Output event time" objects
UINT8
RO
0x00 (0dec)
7pp1:21
Output event state 1
This bit is used to specify which state the output should assume at the time of "Output event time 1"
BOOLEAN
RO
0x00 (0dec)
7pp1:2A
Output event state 10
...
BOOLEAN
RO
0x00 (0dec)
7pp1:41
Output event time 1
Time at which the state described in "Output event state 1" is to be applied
UINT32
RO
0x00000000 (0dec)
7pp1:4A
Output event time 10
...
UINT32
RO
0x00000000 (0dec)
Index 7pp0 TSO Outputs (for 08 ≤ pp ≤ 0F; Ch. 1 to Ch. 8)
Index (hex) | Name | Meaning | Data type | Flags | Default
7pp0:0 | TSO Outputs |  | UINT8 | RO | 0x00 (0dec)
7pp0:01 | Output | Defines whether a rising (1) or falling (0) edge should be output at the "StartTime" | BOOLEAN | RO | 0x00 (0dec)
7pp0:11 | Activate | A change from 0 to 3 in this byte triggers acceptance of the order with the current StartTime | UINT8 | RO | 0x00 (0dec)
7pp0:41 | StartTime | 64 Bit TimeSTamp | UINT64 | RO |


Diagnostic data

Commissioning [image] CoE object description and parameterization [image] EL2258 [image] Object description and parameterization [image] Diagnostic data
Diagnostic data
Index App0 MTO Diag data (for 00 ≤ pp ≤ 07; Ch. 1 to Ch. 8)
Index (hex) | Name | Meaning | Data type | Flags | Default
App0:0 | MTO Diag data |  | UINT8 | RO | 0x00 (0dec)
App0:01 | Short circuit | The channel signals a short circuit | BOOLEAN | RO | 0x00 (0dec)
App0:02 | Undervoltage | The voltage at the power contacts is outside the valid range. | BOOLEAN | RO | 0x00 (0dec)
Index A001 MTO common Diag data
Index (hex) | Name | Meaning | Data type | Flags | Default
A001:0 | MTO common Diag data |  | UINT8 | RO | 0x00 (0dec)
A001:11 | Checksum error counter | An error occurred in the internal data transfer | UINT16 | RO | 0x0000 (0dec)
Index A080 TSO common Diag data
Index (hex) | Name | Meaning | Data type | Flags | Default
A080:0 | TSO common Diag data |  | UINT8 | RO | 0x00 (0dec)
A080:11 | Checksum error counter | An error occurred in the internal data transfer | UINT16 | RO | 0x0000 (0dec)


Information data

Commissioning [image] CoE object description and parameterization [image] EL2258 [image] Object description and parameterization [image] Information data
Information data
Index F900 DEV Info data
Index (hex) | Name | Meaning | Data type | Flags | Default
F900:0 | DEV Info data |  | UINT8 | RO | 0x00 (0dec)
F900:08 | Cycle Time | Indicates the smallest possible cycle time that can be set [ns]. | UINT32 | RO | 0x00000000 (0dec)
F900:09 | Sample time | Indicates the sampling time of the inputs and outputs [ns]. | UINT32 | RO | 0x00000000 (0dec)


Command object

Commissioning [image] CoE object description and parameterization [image] EL2258 [image] Object description and parameterization [image] Command object
Command object
Index FB00 Command
The command object was implemented for future use. Currently no commands are supported.
Index (hex) | Name | Meaning | Data type | Flags | Default
FB00:0 | Command |  | UINT8 | RO | 0x03 (3dec)
FB00:01 | Request | Commands can be sent to the terminal via the request object. | OCTET-STRING[2] | RW | {0}
FB00:02 | Status | Status of the command currently being executed | UINT8 | RO | 0x00 (0dec)
FB00:03 | Response | Optional response value of the command | OCTET-STRING[6] | RO | {0}


Object description - standard objects

Commissioning [image] CoE object description and parameterization [image] EL2258 [image] Object description - standard objects
Object description - standard objects
Index 1000 Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: the Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x00001389 (5001dec)
Index 1008 Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EL2258
Index 1009 Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO |
Index 100ASoftware version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO | 99
Index 1018 Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x08D23052 (147992658dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the low word (bit 0-15) indicates the special terminal number, the high word (bit 16-31) refers to the device description | UINT32 | RO | 0x00000000 (0dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the low byte (bit 0-7) of the low word contains the year of production, the high byte (bit 8-15) of the low word contains the week of production, the high word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 Backup parameter handling
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | Information for standardized loading and saving of backup entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum across all backup entries of the EtherCAT slave | UINT32 | RO | 0x00000000 (0dec)
Index 1600 MTO RxPDO-Map Outputs 10x Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1600:0 | MTO RxPDO-Map Outputs 10x Ch.1 | PDO Mapping RxPDO 1 | UINT8 | RO | 0x1D (29dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7001:01, 1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7001:02, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x03 (Force order)) | UINT32 | RO | 0x7001:03, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7001:04, 1
1600:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1600:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7001:09, 8
1600:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x11 (No of output events)) | UINT32 | RO | 0x7001:11, 8
1600:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1600:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7001:21, 1
1600:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7001:22, 1
1600:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7001:23, 1
1600:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7001:24, 1
1600:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7001:25, 1
1600:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x26 (Output event state 6)) | UINT32 | RO | 0x7001:26, 1
1600:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x27 (Output event state 7)) | UINT32 | RO | 0x7001:27, 1
1600:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x28 (Output event state 8)) | UINT32 | RO | 0x7001:28, 1
1600:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x29 (Output event state 9)) | UINT32 | RO | 0x7001:29, 1
1600:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x2A (Output event state 10)) | UINT32 | RO | 0x7001:2A, 1
1600:13 | SubIndex 019 | 19. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1600:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7001:41, 32
1600:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7001:42, 32
1600:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7001:43, 32
1600:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7001:44, 32
1600:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7001:45, 32
1600:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x46 (Output event time 6)) | UINT32 | RO | 0x7001:46, 32
1600:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x47 (Output event time 7)) | UINT32 | RO | 0x7001:47, 32
1600:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x48 (Output event time 8)) | UINT32 | RO | 0x7001:48, 32
1600:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x49 (Output event time 9)) | UINT32 | RO | 0x7001:49, 32
1600:1D | SubIndex 029 | 29. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x4A (Output event time 10)) | UINT32 | RO | 0x7001:4A, 32
Index 1601 MTO RxPDO-Map Outputs 5x Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1601:0 | MTO RxPDO-Map Outputs 5x Ch.1 | PDO Mapping RxPDO 2 | UINT8 | RO | 0x13 (19dec)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7001:01, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7001:02, 1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x03 (Force order)) | UINT32 | RO | 0x7001:03, 1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7001:04, 1
1601:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1601:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7001:09, 8
1601:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x11 (No of output events)) | UINT32 | RO | 0x7001:11, 8
1601:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1601:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7001:21, 1
1601:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7001:22, 1
1601:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7001:23, 1
1601:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7001:24, 1
1601:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7001:25, 1
1601:0E | SubIndex 014 | 14. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1601:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7001:41, 32
1601:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7001:42, 32
1601:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7001:43, 32
1601:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7001:44, 32
1601:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7001:45, 32
Index 1602 MTO RxPDO-Map Outputs 2x Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1602:0 | MTO RxPDO-Map Outputs 2x Ch.1 | PDO Mapping RxPDO 3 | UINT8 | RO | 0x0D (13dec)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7001:01, 1
1602:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7001:02, 1
1602:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x03 (Force order)) | UINT32 | RO | 0x7001:03, 1
1602:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7001:04, 1
1602:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1602:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7001:09, 8
1602:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x11 (No of output events)) | UINT32 | RO | 0x7001:11, 8
1602:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1602:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7001:21, 1
1602:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7001:22, 1
1602:0B | SubIndex 011 | 11. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1602:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7001:41, 32
1602:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7001:42, 32
Index 1603 MTO RxPDO-Map Outputs 1x Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1603:0 | MTO RxPDO-Map Outputs 1x Ch.1 | PDO Mapping RxPDO 4 | UINT8 | RO | 0x0B (11dec)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7001:01, 1
1603:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7001:02, 1
1603:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x03 (Force order)) | UINT32 | RO | 0x7001:03, 1
1603:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7001:04, 1
1603:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1603:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7001:09, 8
1603:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x11 (No of output events)) | UINT32 | RO | 0x7001:11, 8
1603:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1603:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7001:21, 1
1603:0A | SubIndex 010 | 10. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1603:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7001:41, 32
Index 1604 MTO RxPDO-Map Outputs 10x Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1604:0 | MTO RxPDO-Map Outputs 10x Ch.2 | PDO Mapping RxPDO 5 | UINT8 | RO | 0x1D (29dec)
1604:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7011:01, 1
1604:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7011:02, 1
1604:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x03 (Force order)) | UINT32 | RO | 0x7011:03, 1
1604:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7011:04, 1
1604:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1604:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7011:09, 8
1604:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x11 (No of output events)) | UINT32 | RO | 0x7011:11, 8
1604:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1604:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7011:21, 1
1604:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7011:22, 1
1604:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7011:23, 1
1604:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7011:24, 1
1604:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7011:25, 1
1604:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x26 (Output event state 6)) | UINT32 | RO | 0x7011:26, 1
1604:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x27 (Output event state 7)) | UINT32 | RO | 0x7011:27, 1
1604:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x28 (Output event state 8)) | UINT32 | RO | 0x7011:28, 1
1604:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x29 (Output event state 9)) | UINT32 | RO | 0x7011:29, 1
1604:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x2A (Output event state 10)) | UINT32 | RO | 0x7011:2A, 1
1604:13 | SubIndex 019 | 19. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1604:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7011:41, 32
1604:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7011:42, 32
1604:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7011:43, 32
1604:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7011:44, 32
1604:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7011:45, 32
1604:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x46 (Output event time 6)) | UINT32 | RO | 0x7011:46, 32
1604:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x47 (Output event time 7)) | UINT32 | RO | 0x7011:47, 32
1604:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x48 (Output event time 8)) | UINT32 | RO | 0x7011:48, 32
1604:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x49 (Output event time 9)) | UINT32 | RO | 0x7011:49, 32
1604:1D | SubIndex 029 | 29. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x4A (Output event time 10)) | UINT32 | RO | 0x7011:4A, 32
Index 1605 MTO RxPDO-Map Outputs 5x Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1605:0 | MTO RxPDO-Map Outputs 5x Ch.2 | PDO Mapping RxPDO 6 | UINT8 | RO | 0x13 (19dec)
1605:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7011:01, 1
1605:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7011:02, 1
1605:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x03 (Force order)) | UINT32 | RO | 0x7011:03, 1
1605:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7011:04, 1
1605:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1605:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7011:09, 8
1605:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x11 (No of output events)) | UINT32 | RO | 0x7011:11, 8
1605:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1605:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7011:21, 1
1605:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7011:22, 1
1605:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7011:23, 1
1605:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7011:24, 1
1605:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7011:25, 1
1605:0E | SubIndex 014 | 14. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1605:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7011:41, 32
1605:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7011:42, 32
1605:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7011:43, 32
1605:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7011:44, 32
1605:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7011:45, 32
Index 1606 MTO RxPDO-Map Outputs 2x Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1606:0 | MTO RxPDO-Map Outputs 2x Ch.2 | PDO Mapping RxPDO 7 | UINT8 | RO | 0x0D (13dec)
1606:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7011:01, 1
1606:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7011:02, 1
1606:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x03 (Force order)) | UINT32 | RO | 0x7011:03, 1
1606:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7011:04, 1
1606:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1606:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7011:09, 8
1606:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x11 (No of output events)) | UINT32 | RO | 0x7011:11, 8
1606:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1606:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7011:21, 1
1606:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7011:22, 1
1606:0B | SubIndex 011 | 11. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1606:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7011:41, 32
1606:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7011:42, 32
Index 1607 MTO RxPDO-Map Outputs 1x Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1607:0 | MTO RxPDO-Map Outputs 1x Ch.2 | PDO Mapping RxPDO 8 | UINT8 | RO | 0x0B (11dec)
1607:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7011:01, 1
1607:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7011:02, 1
1607:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x03 (Force order)) | UINT32 | RO | 0x7011:03, 1
1607:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7011:04, 1
1607:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1607:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7011:09, 8
1607:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x11 (No of output events)) | UINT32 | RO | 0x7011:11, 8
1607:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1607:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7011:21, 1
1607:0A | SubIndex 010 | 10. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1607:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7011:41, 32
Index 1608 MTO RxPDO-Map Outputs 10x Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1608:0 | MTO RxPDO-Map Outputs 10x Ch.3 | PDO Mapping RxPDO 9 | UINT8 | RO | 0x1D (29dec)
1608:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7021:01, 1
1608:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7021:02, 1
1608:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x03 (Force order)) | UINT32 | RO | 0x7021:03, 1
1608:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7021:04, 1
1608:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1608:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7021:09, 8
1608:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x11 (No of output events)) | UINT32 | RO | 0x7021:11, 8
1608:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1608:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7021:21, 1
1608:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7021:22, 1
1608:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7021:23, 1
1608:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7021:24, 1
1608:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7021:25, 1
1608:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x26 (Output event state 6)) | UINT32 | RO | 0x7021:26, 1
1608:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x27 (Output event state 7)) | UINT32 | RO | 0x7021:27, 1
1608:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x28 (Output event state 8)) | UINT32 | RO | 0x7021:28, 1
1608:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x29 (Output event state 9)) | UINT32 | RO | 0x7021:29, 1
1608:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x2A (Output event state 10)) | UINT32 | RO | 0x7021:2A, 1
1608:13 | SubIndex 019 | 19. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1608:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7021:41, 32
1608:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7021:42, 32
1608:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7021:43, 32
1608:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7021:44, 32
1608:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7021:45, 32
1608:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x46 (Output event time 6)) | UINT32 | RO | 0x7021:46, 32
1608:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x47 (Output event time 7)) | UINT32 | RO | 0x7021:47, 32
1608:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x48 (Output event time 8)) | UINT32 | RO | 0x7021:48, 32
1608:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x49 (Output event time 9)) | UINT32 | RO | 0x7021:49, 32
1608:1D | SubIndex 029 | 29. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x4A (Output event time 10)) | UINT32 | RO | 0x7021:4A, 32
Index 1609 MTO RxPDO-Map Outputs 5x Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1609:0 | MTO RxPDO-Map Outputs 5x Ch.3 | PDO Mapping RxPDO 10 | UINT8 | RO | 0x13 (19dec)
1609:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7021:01, 1
1609:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7021:02, 1
1609:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x03 (Force order)) | UINT32 | RO | 0x7021:03, 1
1609:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7021:04, 1
1609:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1609:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7021:09, 8
1609:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x11 (No of output events)) | UINT32 | RO | 0x7021:11, 8
1609:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1609:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7021:21, 1
1609:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7021:22, 1
1609:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7021:23, 1
1609:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7021:24, 1
1609:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7021:25, 1
1609:0E | SubIndex 014 | 14. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1609:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7021:41, 32
1609:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7021:42, 32
1609:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7021:43, 32
1609:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7021:44, 32
1609:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7021:45, 32
Index 160A MTO RxPDO-Map Outputs 2x Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
160A:0 | MTO RxPDO-Map Outputs 2x Ch.3 | PDO Mapping RxPDO 11 | UINT8 | RO | 0x0D (13dec)
160A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7021:01, 1
160A:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7021:02, 1
160A:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x03 (Force order)) | UINT32 | RO | 0x7021:03, 1
160A:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7021:04, 1
160A:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
160A:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7021:09, 8
160A:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x11 (No of output events)) | UINT32 | RO | 0x7021:11, 8
160A:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
160A:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7021:21, 1
160A:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7021:22, 1
160A:0B | SubIndex 011 | 11. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
160A:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7021:41, 32
160A:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7021:42, 32
Index 160B MTO RxPDO-Map Outputs 1x Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
160B:0 | MTO RxPDO-Map Outputs 1x Ch.3 | PDO Mapping RxPDO 12 | UINT8 | RO | 0x0B (11dec)
160B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7021:01, 1
160B:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7021:02, 1
160B:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x03 (Force order)) | UINT32 | RO | 0x7021:03, 1
160B:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7021:04, 1
160B:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
160B:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7021:09, 8
160B:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x11 (No of output events)) | UINT32 | RO | 0x7021:11, 8
160B:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
160B:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7021:21, 1
160B:0A | SubIndex 010 | 10. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
160B:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7021:41, 32
Index 160C MTO RxPDO-Map Outputs 10x Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
160C:0 | MTO RxPDO-Map Outputs 10x Ch.4 | PDO Mapping RxPDO 13 | UINT8 | RO | 0x1D (29dec)
160C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7031:01, 1
160C:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7031:02, 1
160C:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x03 (Force order)) | UINT32 | RO | 0x7031:03, 1
160C:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7031:04, 1
160C:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
160C:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7031:09, 8
160C:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x11 (No of output events)) | UINT32 | RO | 0x7031:11, 8
160C:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
160C:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7031:21, 1
160C:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7031:22, 1
160C:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7031:23, 1
160C:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7031:24, 1
160C:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7031:25, 1
160C:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x26 (Output event state 6)) | UINT32 | RO | 0x7031:26, 1
160C:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x27 (Output event state 7)) | UINT32 | RO | 0x7031:27, 1
160C:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x28 (Output event state 8)) | UINT32 | RO | 0x7031:28, 1
160C:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x29 (Output event state 9)) | UINT32 | RO | 0x7031:29, 1
160C:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x2A (Output event state 10)) | UINT32 | RO | 0x7031:2A, 1
160C:13 | SubIndex 019 | 19. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
160C:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7031:41, 32
160C:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7031:42, 32
160C:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7031:43, 32
160C:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7031:44, 32
160C:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7031:45, 32
160C:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x46 (Output event time 6)) | UINT32 | RO | 0x7031:46, 32
160C:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x47 (Output event time 7)) | UINT32 | RO | 0x7031:47, 32
160C:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x48 (Output event time 8)) | UINT32 | RO | 0x7031:48, 32
160C:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x49 (Output event time 9)) | UINT32 | RO | 0x7031:49, 32
160C:1D | SubIndex 029 | 29. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x4A (Output event time 10)) | UINT32 | RO | 0x7031:4A, 32
Index 160D MTO RxPDO-Map Outputs 5x Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
160D:0 | MTO RxPDO-Map Outputs 5x Ch.4 | PDO Mapping RxPDO 14 | UINT8 | RO | 0x13 (19dec)
160D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7031:01, 1
160D:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7031:02, 1
160D:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x03 (Force order)) | UINT32 | RO | 0x7031:03, 1
160D:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7031:04, 1
160D:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
160D:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7031:09, 8
160D:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x11 (No of output events)) | UINT32 | RO | 0x7031:11, 8
160D:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
160D:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7031:21, 1
160D:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7031:22, 1
160D:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7031:23, 1
160D:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7031:24, 1
160D:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7031:25, 1
160D:0E | SubIndex 014 | 14. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
160D:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7031:41, 32
160D:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7031:42, 32
160D:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7031:43, 32
160D:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7031:44, 32
160D:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7031:45, 32
Index 160E MTO RxPDO-Map Outputs 2x Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
160E:0 | MTO RxPDO-Map Outputs 2x Ch.4 | PDO Mapping RxPDO 15 | UINT8 | RO | 0x0D (13dec)
160E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7031:01, 1
160E:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7031:02, 1
160E:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x03 (Force order)) | UINT32 | RO | 0x7031:03, 1
160E:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7031:04, 1
160E:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
160E:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7031:09, 8
160E:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x11 (No of output events)) | UINT32 | RO | 0x7031:11, 8
160E:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
160E:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7031:21, 1
160E:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7031:22, 1
160E:0B | SubIndex 011 | 11. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
160E:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7031:41, 32
160E:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7031:42, 32
Index 160F MTO RxPDO-Map Outputs 1x Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
160F:0 | MTO RxPDO-Map Outputs 1x Ch.4 | PDO Mapping RxPDO 16 | UINT8 | RO | 0x0B (11dec)
160F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7031:01, 1
160F:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7031:02, 1
160F:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x03 (Force order)) | UINT32 | RO | 0x7031:03, 1
160F:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7031:04, 1
160F:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
160F:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7031:09, 8
160F:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x11 (No of output events)) | UINT32 | RO | 0x7031:11, 8
160F:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
160F:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7031:21, 1
160F:0A | SubIndex 010 | 10. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
160F:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7031:41, 32
Index 1610 MTO RxPDO-Map Outputs 10x Ch.5
Index (hex) | Name | Meaning | Data type | Flags | Default
1610:0 | MTO RxPDO-Map Outputs 10x Ch.5 | PDO Mapping RxPDO 17 | UINT8 | RO | 0x1D (29dec)
1610:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7041:01, 1
1610:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7041:02, 1
1610:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x03 (Force order)) | UINT32 | RO | 0x7041:03, 1
1610:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7041:04, 1
1610:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1610:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7041:09, 8
1610:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x11 (No of output events)) | UINT32 | RO | 0x7041:11, 8
1610:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1610:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7041:21, 1
1610:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7041:22, 1
1610:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7041:23, 1
1610:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7041:24, 1
1610:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7041:25, 1
1610:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x26 (Output event state 6)) | UINT32 | RO | 0x7041:26, 1
1610:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x27 (Output event state 7)) | UINT32 | RO | 0x7041:27, 1
1610:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x28 (Output event state 8)) | UINT32 | RO | 0x7041:28, 1
1610:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x29 (Output event state 9)) | UINT32 | RO | 0x7041:29, 1
1610:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x2A (Output event state 10)) | UINT32 | RO | 0x7041:2A, 1
1610:13 | SubIndex 019 | 19. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1610:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7041:41, 32
1610:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7041:42, 32
1610:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7041:43, 32
1610:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7041:44, 32
1610:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7041:45, 32
1610:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x46 (Output event time 6)) | UINT32 | RO | 0x7041:46, 32
1610:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x47 (Output event time 7)) | UINT32 | RO | 0x7041:47, 32
1610:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x48 (Output event time 8)) | UINT32 | RO | 0x7041:48, 32
1610:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x49 (Output event time 9)) | UINT32 | RO | 0x7041:49, 32
1610:1D | SubIndex 029 | 29. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x4A (Output event time 10)) | UINT32 | RO | 0x7041:4A, 32
Index 1611 MTO RxPDO-Map Outputs 5x Ch.5
Index (hex) | Name | Meaning | Data type | Flags | Default
1611:0 | MTO RxPDO-Map Outputs 5x Ch.5 | PDO Mapping RxPDO 18 | UINT8 | RO | 0x13 (19dec)
1611:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7041:01, 1
1611:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7041:02, 1
1611:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x03 (Force order)) | UINT32 | RO | 0x7041:03, 1
1611:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7041:04, 1
1611:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1611:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7041:09, 8
1611:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x11 (No of output events)) | UINT32 | RO | 0x7041:11, 8
1611:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1611:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7041:21, 1
1611:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7041:22, 1
1611:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7041:23, 1
1611:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7041:24, 1
1611:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7041:25, 1
1611:0E | SubIndex 014 | 14. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1611:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7041:41, 32
1611:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7041:42, 32
1611:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7041:43, 32
1611:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7041:44, 32
1611:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7041:45, 32
Index 1612 MTO RxPDO-Map Outputs 2x Ch.5
Index (hex) | Name | Meaning | Data type | Flags | Default
1612:0 | MTO RxPDO-Map Outputs 2x Ch.5 | PDO Mapping RxPDO 19 | UINT8 | RO | 0x0D (13dec)
1612:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7041:01, 1
1612:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7041:02, 1
1612:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x03 (Force order)) | UINT32 | RO | 0x7041:03, 1
1612:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7041:04, 1
1612:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1612:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7041:09, 8
1612:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x11 (No of output events)) | UINT32 | RO | 0x7041:11, 8
1612:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1612:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7041:21, 1
1612:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7041:22, 1
1612:0B | SubIndex 011 | 11. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1612:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7041:41, 32
1612:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7041:42, 32
Index 1613 MTO RxPDO-Map Outputs 1x Ch.5
Index (hex) | Name | Meaning | Data type | Flags | Default
1613:0 | MTO RxPDO-Map Outputs 1x Ch.5 | PDO Mapping RxPDO 20 | UINT8 | RO | 0x0B (11dec)
1613:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7041:01, 1
1613:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7041:02, 1
1613:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x03 (Force order)) | UINT32 | RO | 0x7041:03, 1
1613:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7041:04, 1
1613:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1613:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7041:09, 8
1613:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x11 (No of output events)) | UINT32 | RO | 0x7041:11, 8
1613:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1613:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7041:21, 1
1613:0A | SubIndex 010 | 10. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1613:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7041:41, 32
Index 1614 MTO RxPDO-Map Outputs 10x Ch.6
Index (hex) | Name | Meaning | Data type | Flags | Default
1614:0 | MTO RxPDO-Map Outputs 10x Ch.6 | PDO Mapping RxPDO 21 | UINT8 | RO | 0x1D (29dec)
1614:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7051:01, 1
1614:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7051:02, 1
1614:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x03 (Force order)) | UINT32 | RO | 0x7051:03, 1
1614:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7051:04, 1
1614:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1614:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7051:09, 8
1614:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x11 (No of output events)) | UINT32 | RO | 0x7051:11, 8
1614:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1614:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7051:21, 1
1614:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7051:22, 1
1614:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7051:23, 1
1614:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7051:24, 1
1614:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7051:25, 1
1614:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x26 (Output event state 6)) | UINT32 | RO | 0x7051:26, 1
1614:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x27 (Output event state 7)) | UINT32 | RO | 0x7051:27, 1
1614:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x28 (Output event state 8)) | UINT32 | RO | 0x7051:28, 1
1614:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x29 (Output event state 9)) | UINT32 | RO | 0x7051:29, 1
1614:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x2A (Output event state 10)) | UINT32 | RO | 0x7051:2A, 1
1614:13 | SubIndex 019 | 19. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1614:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7051:41, 32
1614:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7051:42, 32
1614:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7051:43, 32
1614:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7051:44, 32
1614:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7051:45, 32
1614:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x46 (Output event time 6)) | UINT32 | RO | 0x7051:46, 32
1614:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x47 (Output event time 7)) | UINT32 | RO | 0x7051:47, 32
1614:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x48 (Output event time 8)) | UINT32 | RO | 0x7051:48, 32
1614:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x49 (Output event time 9)) | UINT32 | RO | 0x7051:49, 32
1614:1D | SubIndex 029 | 29. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x4A (Output event time 10)) | UINT32 | RO | 0x7051:4A, 32
Index 1615 MTO RxPDO-Map Outputs 5x Ch.6
Index (hex) | Name | Meaning | Data type | Flags | Default
1615:0 | MTO RxPDO-Map Outputs 5x Ch.6 | PDO Mapping RxPDO 22 | UINT8 | RO | 0x13 (19dec)
1615:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7051:01, 1
1615:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7051:02, 1
1615:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x03 (Force order)) | UINT32 | RO | 0x7051:03, 1
1615:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7051:04, 1
1615:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1615:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7051:09, 8
1615:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x11 (No of output events)) | UINT32 | RO | 0x7051:11, 8
1615:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1615:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7051:21, 1
1615:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7051:22, 1
1615:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7051:23, 1
1615:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7051:24, 1
1615:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7051:25, 1
1615:0E | SubIndex 014 | 14. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1615:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7051:41, 32
1615:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7051:42, 32
1615:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7051:43, 32
1615:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7051:44, 32
1615:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7051:45, 32
Index 1616 MTO RxPDO-Map Outputs 2x Ch.6
Index (hex) | Name | Meaning | Data type | Flags | Default
1616:0 | MTO RxPDO-Map Outputs 2x Ch.6 | PDO Mapping RxPDO 23 | UINT8 | RO | 0x0D (13dec)
1616:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7051:01, 1
1616:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7051:02, 1
1616:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x03 (Force order)) | UINT32 | RO | 0x7051:03, 1
1616:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7051:04, 1
1616:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1616:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7051:09, 8
1616:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x11 (No of output events)) | UINT32 | RO | 0x7051:11, 8
1616:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1616:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7051:21, 1
1616:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7051:22, 1
1616:0B | SubIndex 011 | 11. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1616:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7051:41, 32
1616:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7051:42, 32
Index 1617 MTO RxPDO-Map Outputs 1x Ch.6
Index (hex) | Name | Meaning | Data type | Flags | Default
1617:0 | MTO RxPDO-Map Outputs 1x Ch.6 | PDO Mapping RxPDO 24 | UINT8 | RO | 0x0B (11dec)
1617:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7051:01, 1
1617:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7051:02, 1
1617:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x03 (Force order)) | UINT32 | RO | 0x7051:03, 1
1617:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7051:04, 1
1617:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1617:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7051:09, 8
1617:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x11 (No of output events)) | UINT32 | RO | 0x7051:11, 8
1617:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1617:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7051:21, 1
1617:0A | SubIndex 010 | 10. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1617:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7051:41, 32
Index 1618 MTO RxPDO-Map Outputs 10x Ch.7
Index (hex) | Name | Meaning | Data type | Flags | Default
1618:0 | MTO RxPDO-Map Outputs 10x Ch.7 | PDO Mapping RxPDO 25 | UINT8 | RO | 0x1D (29dec)
1618:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7061:01, 1
1618:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7061:02, 1
1618:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x03 (Force order)) | UINT32 | RO | 0x7061:03, 1
1618:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7061:04, 1
1618:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1618:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7061:09, 8
1618:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x11 (No of output events)) | UINT32 | RO | 0x7061:11, 8
1618:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1618:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7061:21, 1
1618:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7061:22, 1
1618:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7061:23, 1
1618:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7061:24, 1
1618:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7061:25, 1
1618:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x26 (Output event state 6)) | UINT32 | RO | 0x7061:26, 1
1618:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x27 (Output event state 7)) | UINT32 | RO | 0x7061:27, 1
1618:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x28 (Output event state 8)) | UINT32 | RO | 0x7061:28, 1
1618:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x29 (Output event state 9)) | UINT32 | RO | 0x7061:29, 1
1618:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x2A (Output event state 10)) | UINT32 | RO | 0x7061:2A, 1
1618:13 | SubIndex 019 | 19. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1618:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7061:41, 32
1618:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7061:42, 32
1618:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7061:43, 32
1618:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7061:44, 32
1618:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7061:45, 32
1618:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x46 (Output event time 6)) | UINT32 | RO | 0x7061:46, 32
1618:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x47 (Output event time 7)) | UINT32 | RO | 0x7061:47, 32
1618:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x48 (Output event time 8)) | UINT32 | RO | 0x7061:48, 32
1618:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x49 (Output event time 9)) | UINT32 | RO | 0x7061:49, 32
1618:1D | SubIndex 029 | 29. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x4A (Output event time 10)) | UINT32 | RO | 0x7061:4A, 32
Index 1619 MTO RxPDO-Map Outputs 5x Ch.7
Index (hex) | Name | Meaning | Data type | Flags | Default
1619:0 | MTO RxPDO-Map Outputs 5x Ch.7 | PDO Mapping RxPDO 26 | UINT8 | RO | 0x13 (19dec)
1619:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7061:01, 1
1619:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7061:02, 1
1619:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x03 (Force order)) | UINT32 | RO | 0x7061:03, 1
1619:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7061:04, 1
1619:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1619:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7061:09, 8
1619:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x11 (No of output events)) | UINT32 | RO | 0x7061:11, 8
1619:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1619:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7061:21, 1
1619:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7061:22, 1
1619:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7061:23, 1
1619:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7061:24, 1
1619:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7061:25, 1
1619:0E | SubIndex 014 | 14. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1619:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7061:41, 32
1619:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7061:42, 32
1619:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7061:43, 32
1619:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7061:44, 32
1619:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7061:45, 32
Index 161A MTO RxPDO-Map Outputs 2x Ch.7
Index (hex) | Name | Meaning | Data type | Flags | Default
161A:0 | MTO RxPDO-Map Outputs 2x Ch.7 | PDO Mapping RxPDO 27 | UINT8 | RO | 0x0D (13dec)
161A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7061:01, 1
161A:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7061:02, 1
161A:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x03 (Force order)) | UINT32 | RO | 0x7061:03, 1
161A:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7061:04, 1
161A:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
161A:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7061:09, 8
161A:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x11 (No of output events)) | UINT32 | RO | 0x7061:11, 8
161A:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
161A:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7061:21, 1
161A:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7061:22, 1
161A:0B | SubIndex 011 | 11. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
161A:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7061:41, 32
161A:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7061:42, 32
Index 161B MTO RxPDO-Map Outputs 1x Ch.7
Index (hex) | Name | Meaning | Data type | Flags | Default
161B:0 | MTO RxPDO-Map Outputs 1x Ch.7 | PDO Mapping RxPDO 28 | UINT8 | RO | 0x0B (11dec)
161B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7061:01, 1
161B:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7061:02, 1
161B:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x03 (Force order)) | UINT32 | RO | 0x7061:03, 1
161B:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7061:04, 1
161B:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
161B:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7061:09, 8
161B:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x11 (No of output events)) | UINT32 | RO | 0x7061:11, 8
161B:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
161B:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7061:21, 1
161B:0A | SubIndex 010 | 10. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
161B:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7061:41, 32
Index 161C MTO RxPDO-Map Outputs 10x Ch.8
Index (hex) | Name | Meaning | Data type | Flags | Default
161C:0 | MTO RxPDO-Map Outputs 10x Ch.8 | PDO Mapping RxPDO 29 | UINT8 | RO | 0x1D (29dec)
161C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7071:01, 1
161C:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7071:02, 1
161C:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x03 (Force order)) | UINT32 | RO | 0x7071:03, 1
161C:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7071:04, 1
161C:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
161C:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7071:09, 8
161C:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x11 (No of output events)) | UINT32 | RO | 0x7071:11, 8
161C:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
161C:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7071:21, 1
161C:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7071:22, 1
161C:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7071:23, 1
161C:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7071:24, 1
161C:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7071:25, 1
161C:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x26 (Output event state 6)) | UINT32 | RO | 0x7071:26, 1
161C:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x27 (Output event state 7)) | UINT32 | RO | 0x7071:27, 1
161C:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x28 (Output event state 8)) | UINT32 | RO | 0x7071:28, 1
161C:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x29 (Output event state 9)) | UINT32 | RO | 0x7071:29, 1
161C:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x2A (Output event state 10)) | UINT32 | RO | 0x7071:2A, 1
161C:13 | SubIndex 019 | 19. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
161C:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7071:41, 32
161C:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7071:42, 32
161C:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7071:43, 32
161C:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7071:44, 32
161C:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7071:45, 32
161C:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x46 (Output event time 6)) | UINT32 | RO | 0x7071:46, 32
161C:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x47 (Output event time 7)) | UINT32 | RO | 0x7071:47, 32
161C:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x48 (Output event time 8)) | UINT32 | RO | 0x7071:48, 32
161C:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x49 (Output event time 9)) | UINT32 | RO | 0x7071:49, 32
161C:1D | SubIndex 029 | 29. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x4A (Output event time 10)) | UINT32 | RO | 0x7071:4A, 32
Index 161D MTO RxPDO-Map Outputs 5x Ch.8
Index (hex) | Name | Meaning | Data type | Flags | Default
161D:0 | MTO RxPDO-Map Outputs 5x Ch.8 | PDO Mapping RxPDO 30 | UINT8 | RO | 0x13 (19dec)
161D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7071:01, 1
161D:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7071:02, 1
161D:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x03 (Force order)) | UINT32 | RO | 0x7071:03, 1
161D:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7071:04, 1
161D:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
161D:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7071:09, 8
161D:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x11 (No of output events)) | UINT32 | RO | 0x7071:11, 8
161D:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
161D:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7071:21, 1
161D:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7071:22, 1
161D:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7071:23, 1
161D:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7071:24, 1
161D:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7071:25, 1
161D:0E | SubIndex 014 | 14. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
161D:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7071:41, 32
161D:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7071:42, 32
161D:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7071:43, 32
161D:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7071:44, 32
161D:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7071:45, 32
Index 161E MTO RxPDO-Map Outputs 2x Ch.8
Index (hex) | Name | Meaning | Data type | Flags | Default
161E:0 | MTO RxPDO-Map Outputs 2x Ch.8 | PDO Mapping RxPDO 31 | UINT8 | RO | 0x0D (13dec)
161E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7071:01, 1
161E:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7071:02, 1
161E:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x03 (Force order)) | UINT32 | RO | 0x7071:03, 1
161E:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7071:04, 1
161E:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
161E:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7071:09, 8
161E:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x11 (No of output events)) | UINT32 | RO | 0x7071:11, 8
161E:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
161E:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7071:21, 1
161E:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7071:22, 1
161E:0B | SubIndex 011 | 11. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
161E:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7071:41, 32
161E:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7071:42, 32
Index 161F MTO RxPDO-Map Outputs 1x Ch.8
Index (hex) | Name | Meaning | Data type | Flags | Default
161F:0 | MTO RxPDO-Map Outputs 1x Ch.8 | PDO Mapping RxPDO 32 | UINT8 | RO | 0x0B (11dec)
161F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7071:01, 1
161F:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7071:02, 1
161F:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x03 (Force order)) | UINT32 | RO | 0x7071:03, 1
161F:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7071:04, 1
161F:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
161F:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7071:09, 8
161F:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x11 (No of output events)) | UINT32 | RO | 0x7071:11, 8
161F:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
161F:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7071:21, 1
161F:0A | SubIndex 010 | 10. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
161F:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7071:41, 32
Index 1620 TSO RxPDO-Map Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1620:0 | TSO RxPDO-Map Ch.1 | PDO Mapping RxPDO 33 | UINT8 | RO | 0x05 (5dec)
1620:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7080 (TSO Outputs Ch.1), entry 0x01 (Output)) | UINT32 | RO | 0x7080:01, 1
1620:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1620:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7080 (TSO Outputs Ch.1), entry 0x11 (Activate)) | UINT32 | RO | 0x7080:11, 8
1620:04 | SubIndex 004 | 4. PDO Mapping entry (40 bits align) | UINT32 | RO | 0x0000:00, 40
1620:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7080 (TSO Outputs Ch.1), entry 0x41 (StartTime)) | UINT32 | RO | 0x7080:41, 64
Index 1621 TSO RxPDO-Map Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1621:0 | TSO RxPDO-Map Ch.2 | PDO Mapping RxPDO 34 | UINT8 | RO | 0x05 (5dec)
1621:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7090 (TSO Outputs Ch.2), entry 0x01 (Output)) | UINT32 | RO | 0x7090:01, 1
1621:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1621:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7090 (TSO Outputs Ch.2), entry 0x11 (Activate)) | UINT32 | RO | 0x7090:11, 8
1621:04 | SubIndex 004 | 4. PDO Mapping entry (40 bits align) | UINT32 | RO | 0x0000:00, 40
1621:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7090 (TSO Outputs Ch.2), entry 0x41 (StartTime)) | UINT32 | RO | 0x7090:41, 64
Index 1622 TSO RxPDO-Map Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1622:0 | TSO RxPDO-Map Ch.3 | PDO Mapping RxPDO 35 | UINT8 | RO | 0x05 (5dec)
1622:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x70A0 (TSO Outputs Ch.3), entry 0x01 (Output)) | UINT32 | RO | 0x70A0:01, 1
1622:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1622:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x70A0 (TSO Outputs Ch.3), entry 0x11 (Activate)) | UINT32 | RO | 0x70A0:11, 8
1622:04 | SubIndex 004 | 4. PDO Mapping entry (40 bits align) | UINT32 | RO | 0x0000:00, 40
1622:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x70A0 (TSO Outputs Ch.3), entry 0x41 (StartTime)) | UINT32 | RO | 0x70A0:41, 64
Index 1623 TSO RxPDO-Map Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
1623:0 | TSO RxPDO-Map Ch.4 | PDO Mapping RxPDO 36 | UINT8 | RO | 0x05 (5dec)
1623:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x70B0 (TSO Outputs Ch.4), entry 0x01 (Output)) | UINT32 | RO | 0x70B0:01, 1
1623:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1623:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x70B0 (TSO Outputs Ch.4), entry 0x11 (Activate)) | UINT32 | RO | 0x70B0:11, 8
1623:04 | SubIndex 004 | 4. PDO Mapping entry (40 bits align) | UINT32 | RO | 0x0000:00, 40
1623:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x70B0 (TSO Outputs Ch.4), entry 0x41 (StartTime)) | UINT32 | RO | 0x70B0:41, 64
Index 1624 TSO RxPDO-Map Ch.5
Index (hex) | Name | Meaning | Data type | Flags | Default
1624:0 | TSO RxPDO-Map Ch.5 | PDO Mapping RxPDO 37 | UINT8 | RO | 0x05 (5dec)
1624:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x70C0 (TSO Outputs Ch.5), entry 0x01 (Output)) | UINT32 | RO | 0x70C0:01, 1
1624:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1624:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x70C0 (TSO Outputs Ch.5), entry 0x11 (Activate)) | UINT32 | RO | 0x70C0:11, 8
1624:04 | SubIndex 004 | 4. PDO Mapping entry (40 bits align) | UINT32 | RO | 0x0000:00, 40
1624:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x70C0 (TSO Outputs Ch.5), entry 0x41 (StartTime)) | UINT32 | RO | 0x70C0:41, 64
Index 1625 TSO RxPDO-Map Ch.6
Index (hex) | Name | Meaning | Data type | Flags | Default
1625:0 | TSO RxPDO-Map Ch.6 | PDO Mapping RxPDO 38 | UINT8 | RO | 0x05 (5dec)
1625:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x70D0 (TSO Outputs Ch.6), entry 0x01 (Output)) | UINT32 | RO | 0x70D0:01, 1
1625:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1625:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x70D0 (TSO Outputs Ch.6), entry 0x11 (Activate)) | UINT32 | RO | 0x70D0:11, 8
1625:04 | SubIndex 004 | 4. PDO Mapping entry (40 bits align) | UINT32 | RO | 0x0000:00, 40
1625:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x70D0 (TSO Outputs Ch.6), entry 0x41 (StartTime)) | UINT32 | RO | 0x70D0:41, 64
Index 1626 TSO RxPDO-Map Ch.7
Index (hex) | Name | Meaning | Data type | Flags | Default
1626:0 | TSO RxPDO-Map Ch.7 | PDO Mapping RxPDO 39 | UINT8 | RO | 0x05 (5dec)
1626:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x70E0 (TSO Outputs Ch.7), entry 0x01 (Output)) | UINT32 | RO | 0x70E0:01, 1
1626:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1626:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x70E0 (TSO Outputs Ch.7), entry 0x11 (Activate)) | UINT32 | RO | 0x70E0:11, 8
1626:04 | SubIndex 004 | 4. PDO Mapping entry (40 bits align) | UINT32 | RO | 0x0000:00, 40
1626:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x70E0 (TSO Outputs Ch.7), entry 0x41 (StartTime)) | UINT32 | RO | 0x70E0:41, 64
Index 1627 TSO RxPDO-Map Ch.8
Index (hex) | Name | Meaning | Data type | Flags | Default
1627:0 | TSO RxPDO-Map Ch.8 | PDO Mapping RxPDO 40 | UINT8 | RO | 0x05 (5dec)
1627:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x70F0 (TSO Outputs Ch.8), entry 0x01 (Output)) | UINT32 | RO | 0x70F0:01, 1
1627:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1627:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x70F0 (TSO Outputs Ch.8), entry 0x11 (Activate)) | UINT32 | RO | 0x70F0:11, 8
1627:04 | SubIndex 004 | 4. PDO Mapping entry (40 bits align) | UINT32 | RO | 0x0000:00, 40
1627:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x70F0 (TSO Outputs Ch.8), entry 0x41 (StartTime)) | UINT32 | RO | 0x70F0:41, 64
Index 1A00 MTO TxPDO-Map Inputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A00:0 | MTO TxPDO-Map Inputs Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x07 (7dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (MTO inputs Ch.1), entry 0x01 (Output short circuit)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (MTO inputs Ch.1), entry 0x02 (Output buffer overflow)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (MTO inputs Ch.1), entry 0x03 (Output state)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (MTO inputs Ch.1), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6000:0F, 2
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (MTO inputs Ch.1), entry 0x11 (Output order feedback)) | UINT32 | RO | 0x6000:11, 8
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (MTO inputs Ch.1), entry 0x12 (Events in output buffer)) | UINT32 | RO | 0x6000:12, 8
Index 1A01 MTO TxPDO-Map Inputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A01:0 | MTO TxPDO-Map Inputs Ch.2 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x07 (7dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (MTO inputs Ch.2), entry 0x01 (Output short circuit)) | UINT32 | RO | 0x6010:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (MTO inputs Ch.2), entry 0x02 (Output buffer overflow)) | UINT32 | RO | 0x6010:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (MTO inputs Ch.2), entry 0x03 (Output state)) | UINT32 | RO | 0x6010:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (MTO inputs Ch.2), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6010:0F, 2
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (MTO inputs Ch.2), entry 0x11 (Output order feedback)) | UINT32 | RO | 0x6010:11, 8
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (MTO inputs Ch.2), entry 0x12 (Events in output buffer)) | UINT32 | RO | 0x6010:12, 8
Index 1A02 MTO TxPDO-Map Inputs Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1A02:0 | MTO TxPDO-Map Inputs Ch.3 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x07 (7dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (MTO inputs Ch.3), entry 0x01 (Output short circuit)) | UINT32 | RO | 0x6020:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (MTO inputs Ch.3), entry 0x02 (Output buffer overflow)) | UINT32 | RO | 0x6020:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (MTO inputs Ch.3), entry 0x03 (Output state)) | UINT32 | RO | 0x6020:03, 1
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (MTO inputs Ch.3), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6020:0F, 2
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6020 (MTO inputs Ch.3), entry 0x11 (Output order feedback)) | UINT32 | RO | 0x6020:11, 8
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020 (MTO inputs Ch.3), entry 0x12 (Events in output buffer)) | UINT32 | RO | 0x6020:12, 8
Index 1A03 MTO TxPDO-Map Inputs Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
1A03:0 | MTO TxPDO-Map Inputs Ch.4 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x07 (7dec)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6030 (MTO inputs Ch.4), entry 0x01 (Output short circuit)) | UINT32 | RO | 0x6030:01, 1
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6030 (MTO inputs Ch.4), entry 0x02 (Output buffer overflow)) | UINT32 | RO | 0x6030:02, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6030 (MTO inputs Ch.4), entry 0x03 (Output state)) | UINT32 | RO | 0x6030:03, 1
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6030 (MTO inputs Ch.4), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6030:0F, 2
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6030 (MTO inputs Ch.4), entry 0x11 (Output order feedback)) | UINT32 | RO | 0x6030:11, 8
1A03:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6030 (MTO inputs Ch.4), entry 0x12 (Events in output buffer)) | UINT32 | RO | 0x6030:12, 8
Index 1A04 MTO TxPDO-Map Inputs Ch.5
Index (hex) | Name | Meaning | Data type | Flags | Default
1A04:0 | MTO TxPDO-Map Inputs Ch.5 | PDO Mapping TxPDO 5 | UINT8 | RO | 0x07 (7dec)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6040 (MTO inputs Ch.5), entry 0x01 (Output short circuit)) | UINT32 | RO | 0x6040:01, 1
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6040 (MTO inputs Ch.5), entry 0x02 (Output buffer overflow)) | UINT32 | RO | 0x6040:02, 1
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6040 (MTO inputs Ch.5), entry 0x03 (Output state)) | UINT32 | RO | 0x6040:03, 1
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6040 (MTO inputs Ch.5), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6040:0F, 2
1A04:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6040 (MTO inputs Ch.5), entry 0x11 (Output order feedback)) | UINT32 | RO | 0x6040:11, 8
1A04:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6040 (MTO inputs Ch.5), entry 0x12 (Events in output buffer)) | UINT32 | RO | 0x6040:12, 8
Index 1A05 MTO TxPDO-Map Inputs Ch.6
Index (hex) | Name | Meaning | Data type | Flags | Default
1A05:0 | MTO TxPDO-Map Inputs Ch.6 | PDO Mapping TxPDO 6 | UINT8 | RO | 0x07 (7dec)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6050 (MTO inputs Ch.6), entry 0x01 (Output short circuit)) | UINT32 | RO | 0x6050:01, 1
1A05:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6050 (MTO inputs Ch.6), entry 0x02 (Output buffer overflow)) | UINT32 | RO | 0x6050:02, 1
1A05:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6050 (MTO inputs Ch.6), entry 0x03 (Output state)) | UINT32 | RO | 0x6050:03, 1
1A05:04 | SubIndex 004 | 4. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
1A05:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6050 (MTO inputs Ch.6), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6050:0F, 2
1A05:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6050 (MTO inputs Ch.6), entry 0x11 (Output order feedback)) | UINT32 | RO | 0x6050:11, 8
1A05:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6050 (MTO inputs Ch.6), entry 0x12 (Events in output buffer)) | UINT32 | RO | 0x6050:12, 8
Index 1A06 MTO TxPDO-Map Inputs Ch.7
Index (hex) | Name | Meaning | Data type | Flags | Default
1A06:0 | MTO TxPDO-Map Inputs Ch.7 | PDO Mapping TxPDO 7 | UINT8 | RO | 0x07 (7dec)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6060 (MTO inputs Ch.7), entry 0x01 (Output short circuit)) | UINT32 | RO | 0x6060:01, 1
1A06:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6060 (MTO inputs Ch.7), entry 0x02 (Output buffer overflow)) | UINT32 | RO | 0x6060:02, 1
1A06:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6060 (MTO inputs Ch.7), entry 0x03 (Output state)) | UINT32 | RO | 0x6060:03, 1
1A06:04 | SubIndex 004 | 4. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
1A06:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6060 (MTO inputs Ch.7), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6060:0F, 2
1A06:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6060 (MTO inputs Ch.7), entry 0x11 (Output order feedback)) | UINT32 | RO | 0x6060:11, 8
1A06:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6060 (MTO inputs Ch.7), entry 0x12 (Events in output buffer)) | UINT32 | RO | 0x6060:12, 8
Index 1A07 MTO TxPDO-Map Inputs Ch.8
Index (hex) | Name | Meaning | Data type | Flags | Default
1A07:0 | MTO TxPDO-Map Inputs Ch.8 | PDO Mapping TxPDO 8 | UINT8 | RO | 0x07 (7dec)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6070 (MTO inputs Ch.8), entry 0x01 (Output short circuit)) | UINT32 | RO | 0x6070:01, 1
1A07:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6070 (MTO inputs Ch.8), entry 0x02 (Output buffer overflow)) | UINT32 | RO | 0x6070:02, 1
1A07:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6070 (MTO inputs Ch.8), entry 0x03 (Output state)) | UINT32 | RO | 0x6070:03, 1
1A07:04 | SubIndex 004 | 4. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
1A07:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6070 (MTO inputs Ch.8), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6070:0F, 2
1A07:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6070 (MTO inputs Ch.8), entry 0x11 (Output order feedback)) | UINT32 | RO | 0x6070:11, 8
1A07:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6070 (MTO inputs Ch.8), entry 0x12 (Events in output buffer)) | UINT32 | RO | 0x6070:12, 8
Index 1A08 TSO TxPDO-Map Inputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A08:0 | TSO TxPDO-Map Inputs Ch.1 | PDO Mapping TxPDO 9 | UINT8 | RO | 0x02 (2dec)
1A08:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6080 (TSO Inputs Ch.1), entry 0x01 (Feedback)) | UINT32 | RO | 0x6080:01, 1
1A08:02 | SubIndex 002 | 2. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
Index 1A09 TSO TxPDO-Map Inputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A09:0 | TSO TxPDO-Map Inputs Ch.2 | PDO Mapping TxPDO 10 | UINT8 | RO | 0x02 (2dec)
1A09:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6090 (TSO Inputs Ch.2), entry 0x01 (Feedback)) | UINT32 | RO | 0x6090:01, 1
1A09:02 | SubIndex 002 | 2. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
Index 1A0A TSO TxPDO-Map Inputs Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1A0A:0 | TSO TxPDO-Map Inputs Ch.3 | PDO Mapping TxPDO 11 | UINT8 | RO | 0x02 (2dec)
1A0A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60A0 (TSO Inputs Ch.3), entry 0x01 (Feedback)) | UINT32 | RO | 0x60A0:01, 1
1A0A:02 | SubIndex 002 | 2. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
Index 1A0B TSO TxPDO-Map Inputs Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
1A0B:0 | TSO TxPDO-Map Inputs Ch.4 | PDO Mapping TxPDO 12 | UINT8 | RO | 0x02 (2dec)
1A0B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60B0 (TSO Inputs Ch.4), entry 0x01 (Feedback)) | UINT32 | RO | 0x60B0:01, 1
1A0B:02 | SubIndex 002 | 2. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
Index 1A0C TSO TxPDO-Map Inputs Ch.5
Index (hex) | Name | Meaning | Data type | Flags | Default
1A0C:0 | TSO TxPDO-Map Inputs Ch.5 | PDO Mapping TxPDO 13 | UINT8 | RO | 0x02 (2dec)
1A0C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60C0 (TSO Inputs Ch.5), entry 0x01 (Feedback)) | UINT32 | RO | 0x60C0:01, 1
1A0C:02 | SubIndex 002 | 2. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
Index 1A0D TSO TxPDO-Map Inputs Ch.6
Index (hex) | Name | Meaning | Data type | Flags | Default
1A0D:0 | TSO TxPDO-Map Inputs Ch.6 | PDO Mapping TxPDO 14 | UINT8 | RO | 0x02 (2dec)
1A0D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60D0 (TSO Inputs Ch.6), entry 0x01 (Feedback)) | UINT32 | RO | 0x60D0:01, 1
1A0D:02 | SubIndex 002 | 2. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
Index 1A0E TSO TxPDO-Map Inputs Ch.7
Index (hex) | Name | Meaning | Data type | Flags | Default
1A0E:0 | TSO TxPDO-Map Inputs Ch.7 | PDO Mapping TxPDO 15 | UINT8 | RO | 0x02 (2dec)
1A0E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60E0 (TSO Inputs Ch.7), entry 0x01 (Feedback)) | UINT32 | RO | 0x60E0:01, 1
1A0E:02 | SubIndex 002 | 2. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
Index 1A0F TSO TxPDO-Map Inputs Ch.8
Index (hex) | Name | Meaning | Data type | Flags | Default
1A0F:0 | TSO TxPDO-Map Inputs Ch.8 | PDO Mapping TxPDO 16 | UINT8 | RO | 0x02 (2dec)
1A0F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60F0 (TSO Inputs Ch.8), entry 0x01 (Feedback)) | UINT32 | RO | 0x60F0:01, 1
1A0F:02 | SubIndex 002 | 2. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
Index 1A10 DEV TxPDO-Map Inputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1A10:0 | DEV TxPDO-Map Inputs Device | PDO Mapping TxPDO 17 | UINT8 | RO | 0x06 (6dec)
1A10:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A10:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF611 (DEV Inputs), entry 0x02 (Undervoltage Up)) | UINT32 | RO | 0xF611:02, 1
1A10:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF611 (DEV Inputs), entry 0x03 (Overtemperature)) | UINT32 | RO | 0xF611:03, 1
1A10:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF611 (DEV Inputs), entry 0x04 (Checksum error)) | UINT32 | RO | 0xF611:04, 1
1A10:05 | SubIndex 005 | 5. PDO Mapping entry (60 bits align) | UINT32 | RO | 0x0000:00, 60
1A10:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF611 (DEV Inputs), entry 0x21 (SysTime)) | UINT32 | RO | 0xF611:21, 64
Index 1C00 Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the sync managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x08 (8dec)
1C12:01 | SubIndex 001 | 1. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1600 (5632dec)
1C12:02 | SubIndex 002 | 2. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1604 (5636dec)
1C12:03 | SubIndex 003 | 3. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1608 (5640dec)
1C12:04 | SubIndex 004 | 4. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x160C (5644dec)
1C12:05 | SubIndex 005 | 5. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1610 (5648dec)
1C12:06 | SubIndex 006 | 6. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1614 (5652dec)
1C12:07 | SubIndex 007 | 7. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x1618 (5656dec)
1C12:08 | SubIndex 008 | 8. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x161C (5660dec)
1C12:09 | SubIndex 009 | 9. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:0A | SubIndex 010 | 10. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:0B | SubIndex 011 | 11. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:0C | SubIndex 012 | 12. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:0D | SubIndex 013 | 13. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:0E | SubIndex 014 | 14. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:0F | SubIndex 015 | 15. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:10 | SubIndex 016 | 16. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:11 | SubIndex 017 | 17. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:12 | SubIndex 018 | 18. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:13 | SubIndex 019 | 19. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:14 | SubIndex 020 | 20. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:15 | SubIndex 021 | 21. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:16 | SubIndex 022 | 22. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:17 | SubIndex 023 | 23. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:18 | SubIndex 024 | 24. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:19 | SubIndex 025 | 25. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:1A | SubIndex 026 | 26. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 1C12 RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:1B | SubIndex 027 | 27. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:1C | SubIndex 028 | 28. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:1D | SubIndex 029 | 29. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:1E | SubIndex 030 | 30. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:1F | SubIndex 031 | 31. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:20 | SubIndex 032 | 32. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:21 | SubIndex 033 | 33. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:22 | SubIndex 034 | 34. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:23 | SubIndex 035 | 35. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:24 | SubIndex 036 | 36. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:25 | SubIndex 037 | 37. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:26 | SubIndex 038 | 38. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:27 | SubIndex 039 | 39. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C12:28 | SubIndex 040 | 40. allocated RxPDO (contains the index of the associated RxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 1C13 TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x08 (8dec)
1C13:01 | SubIndex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | SubIndex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A01 (6657dec)
1C13:03 | SubIndex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A02 (6658dec)
1C13:04 | SubIndex 004 | 4. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A03 (6659dec)
1C13:05 | SubIndex 005 | 5. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A04 (6660dec)
1C13:06 | SubIndex 006 | 6. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A05 (6661dec)
1C13:07 | SubIndex 007 | 7. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A06 (6662dec)
1C13:08 | SubIndex 008 | 8. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A07 (6663dec)
1C13:09 | SubIndex 009 | 9. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0A | SubIndex 010 | 10. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0B | SubIndex 011 | 11. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0C | SubIndex 012 | 12. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0D | SubIndex 013 | 13. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0E | SubIndex 014 | 14. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:0F | SubIndex 015 | 15. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:10 | SubIndex 016 | 16. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
1C13:11 | SubIndex 017 | 17. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x0000 (0dec)
Index 1C32 SM output parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C32:0
SM output parameter
Synchronization parameters for the outputs
UINT8
RO
0x20 (32dec)
1C32:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0000 (0dec)
1C32:02
Cycle time
Cycle time (in ns):
▪
Free Run: Cycle time of the local timer
▪
Synchronous with SM 2 event: Master cycle time
▪
DC mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000C3500 (800000dec)
1C32:03
Shift time
Time between SYNC0 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000384 (900dec)
1C32:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0 = 1: free run is supported
▪
Bit 1 = 1: Synchronous with SM 2 event is supported
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 10: Output shift with SYNC1 event (only DC mode)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08)
UINT16
RO
0x0804 (2052dec)
1C32:05
Minimum cycle time
Minimum cycle time (in ns)
UINT32
RO
0x00001F40 (8000dec)
1C32:06
Calc and copy time
Minimum time between SYNC0 and SYNC1 event (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C32:07
Minimum delay time
UINT32
RO
0x00000384 (900dec)
1C32:08
Command
▪
0: Measurement of the local cycle time is stopped
▪
1: Measurement of the local cycle time is started
The entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, and 0x1C33:09 are updated with the maximum measured values.
For a subsequent measurement the measured values are reset
UINT16
RW
0x0000 (0dec)
1C32:09
Maximum delay time
Time between SYNC1 event and output of the outputs (in ns, DC mode only)
UINT32
RO
0x00000384 (900dec)
1C32:0B
SM event missed counter
Number of missed SM events in OPERATIONAL (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:0C
Cycle exceeded counter
Number of occasions the cycle time was exceeded in OPERATIONAL (cycle was not completed in time or the next cycle began too early)
UINT16
RO
0x0000 (0dec)
1C32:0D
Shift too short counter
Number of occasions that the interval between SYNC0 and SYNC1 event was too short (DC mode only)
UINT16
RO
0x0000 (0dec)
1C32:20
Sync error
The synchronization was not correct in the last cycle (outputs were output too late; DC mode only)
BOOLEAN
RO
0x00 (0dec)
Index 1C33 SM input parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchronous with SM 3 event (no outputs available)
▪
2: DC - Synchronous with SYNC0 Event
▪
3: DC - Synchronous with SYNC1 Event
▪
34: Synchronous with SM 2 event (outputs available)
UINT16
RW
0x0000 (0dec)
1C33:02
Cycle time
as 0x1C32:02
UINT32
RW
0x000C3500 (800000dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000384 (900dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: synchronous with SM 2 event is supported (outputs available)
▪
Bit 1: synchronous with SM 3 event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: input shift through local event (outputs available)
▪
Bit 4-5 = 10: input shift with SYNC1 event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08 or 0x1C33:08)
UINT16
RO
0x0804 (2052dec)
1C33:05
Minimum cycle time
as 0x1C32:05
UINT32
RO
0x00001F40 (8000dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:07
Minimum delay time
UINT32
RO
0x00000384 (900dec)
1C33:08
Command
as 0x1C32:08
UINT16
RW
0x0000 (0dec)
1C33:09
Maximum delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000384 (900dec)
1C33:0B
SM event missed counter
as 0x1C32:11
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
as 0x1C32:12
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
as 0x1C32:13
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
as 0x1C32:32
BOOLEAN
RO
0x00 (0dec)
Index F000 Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index spacing of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0010 (16dec)
Index F008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module list
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list | MDP Profile | UINT8 | RW | 0x10 (16dec)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x000000DC (220dec)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x000000DC (220dec)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x000000DC (220dec)
F010:04 | SubIndex 004 |  | UINT32 | RW | 0x000000DC (220dec)
F010:05 | SubIndex 005 |  | UINT32 | RW | 0x000000DC (220dec)
F010:06 | SubIndex 006 |  | UINT32 | RW | 0x000000DC (220dec)
F010:07 | SubIndex 007 |  | UINT32 | RW | 0x000000DC (220dec)
F010:08 | SubIndex 008 |  | UINT32 | RW | 0x000000DC (220dec)
F010:09 | SubIndex 009 |  | UINT32 | RW | 0x000000DD (221dec)
F010:0A | SubIndex 010 |  | UINT32 | RW | 0x000000DD (221dec)
F010:0B | SubIndex 011 |  | UINT32 | RW | 0x000000DD (221dec)
F010:0C | SubIndex 012 |  | UINT32 | RW | 0x000000DD (221dec)
F010:0D | SubIndex 013 |  | UINT32 | RW | 0x000000DD (221dec)
F010:0E | SubIndex 014 |  | UINT32 | RW | 0x000000DD (221dec)
F010:0F | SubIndex 015 |  | UINT32 | RW | 0x000000DD (221dec)
F010:10 | SubIndex 016 |  | UINT32 | RW | 0x000000DD (221dec)


Example programs

Commissioning [image] Example programs
Example programs
Using the sample programs
This document contains sample applications of our products for certain areas of application. The application notes provided here are based on typical features of our products and only serve as examples. The notes contained in this document explicitly do not refer to specific applications. The customer is therefore responsible for assessing and deciding whether the product is suitable for a particular application. We accept no responsibility for the completeness and correctness of the source code contained in this document. We reserve the right to modify the content of this document at any time and accept no responsibility for errors and missing information.
Preparations for starting the sample programs (tnzip file / TwinCAT 3)
▪
Click on the download button to save the Zip archive locally on your hard disk, then unzip the *.tnzip archive file in a temporary folder.
Opening the *. tnzip archive
▪
Select the .tnzip file (sample program).
▪
A further selection window opens. Select the destination directory for storing the project.
▪
For a description of the general PLC commissioning procedure and starting the program please refer to the terminal documentation or the EtherCAT system documentation.
▪
The EtherCAT device of the example should usually be declared your present system. After selection of the EtherCAT device in the “Solutionexplorer” select the “Adapter” tab and click on “Search...”:
Search of the existing HW configuration for the EtherCAT configuration of the example
▪
Checking NetId: the “EtherCAT” tab of the EtherCAT device shows the configured NetId: .
The first 4 numbers have to be identical with the project NetId of the target system. The project NetId can be viewed within the TwinCAT environment above, where a pull down menu can be opened to choose a target system (by clicking right in the text field). The number blocks are placed in brackets there next to each computer name of a target system.
▪
Modify the NetId: By right clicking on “EtherCAT device” within the solution explorer a context menu opens where “Change NetId...” have to be selected. The first four numbers of the NetId of the target computer have to be entered; the both last values are 4.1 usually.
Example:
–
NetId of project: myComputer (123.45.67.89.1.1)
–
Entry via „Change NetId...“: 123.45.67.89.4.1
Also see more hints in section:
Commissioning, TwinCAT Quickstart, TwinCAT 3, Startup.
Additional information
•
Example program for EL2258: Multi-Timestamp
•
Example program for EL1258 (EL1259): MT Visualization (TC 3)


Example program for EL2258: Multi-Timestamp

Commissioning [image] Example programs [image] Example program for EL2258: Multi-Timestamp
Example program for EL2258: Multi-Timestamp
The following example program delivers 4 x 10 Switching-Tasks within one PLC-Taskcycle to the first four channels of the terminal EL2258 and also sets the respective output states inverting from „1“ to „0“, beginning with „1“ as for the first state.
The arbitrariness, for the first four channels respective different fixed switch times are illustrated by the following oscilloscope recording:
Recording of four channels by the Multi-Timestamp program example
All arrays have to be linked to eight channels with all the necessary status, output and input variables respectively. This is already be done by the downloadable example:
This example requires a PLC control with a terminal EL2258. You can use either an embedded PC that has the terminal placed on the right or an IPC with an EtherCAT link of an e.g. RJ‑45 connector to the EK1100 coupler with the terminal (e.g. C6915 + EK1100 + EL2258). Optionally a digital input terminal e.g. EL1004 can be used for program control.
The further procedure is described in section TwinCAT Quickstart, TwinCAT 3, Starting the controller.
Example program for EL2258: Multi-Timestamp
Variables declaration:
PROGRAM MAIN
VAR CONSTANT
// Number of used channels of the terminal in this code example
nNumOfSwitchTasks : INT:=4;
END_VAR
VAR_INPUT
// External switch to start by user
bEnable AT%I* : BOOL;
// Reference to check if last tasks were already executed
nOutputOrderFeedback AT%I*: ARRAY[0..7] OF USINT;
END_VAR
VAR_OUTPUT
// Link to terminal EL2258 (Output event time n):
aQE_Time AT%Q* : ARRAY[0..7] OF ARRAY[0..9] OF UDINT;
// Link to terminal EL2258 (Output event state n):
aQE_State AT%Q* : ARRAY[0..7] OF ARRAY[0..9] OF BOOL;
// Outputvariables to reset the output buffers of EL2258
bOutputBufReset AT%Q*: ARRAY[0..7] OF BOOL;
// Real number of fixed State/Time-Events as a Task for EL2258
nNoOfOutputEvents AT%Q*: ARRAY[0..7] OF USINT;
// Start-Event to trigger beginning of task scheduling
nOutputOrderCounter AT%Q*: ARRAY[0..7] OF USINT;
END_VAR
VAR
aSwitchTimes : ARRAY[0..7] OF ARRAY[0..9] OF UDINT:=
// All 8 x 10 time offsets in ms allocated to the 10 states and 8 channels
[
[ // Channel 1 time offsets:
100, 50, 25, 75, 75, 25, 50, 25, 50, 50
]
,[ // Channel 2 time offsets:
100, 25, 50, 25, 50, 50, 25, 75, 75, 50
]
,[ // Channel 3 time offsets:
100, 50, 25, 75, 75, 50, 25, 50, 25, 50
]
,[ // Channel 4 time offsets:
100, 25, 50, 50, 25, 75, 75, 50, 50, 25
]
(* More time offsets for switch tasks:
,[ // Channel 5 time offsets:
100, 50, 25, 75, 75, 25, 50, 50, 25, 50
]
,[ // Channel 6 time offsets:
100, 25, 50, 25, 50, 50, 25, 75, 75, 50
]
,[ // Channel 7 time offsets:
100, 50, 25, 75, 75, 50, 25, 50, 25, 50
]
,[ // Channel 8 time offsets:
100, 25, 50, 50, 25, 75, 75, 50, 25, 50
]
*)
];
nState : UINT:=0; // Use for "CASE .. OF" statement
nShortTime : UDINT; // Timevalue of current DC time/ lower 32 Bit only
nCurrentTime : ULINT; // Current DC-Time of the PLC-Task
bStateValue : BOOL; // Variable to set a toggled state of a task-event
nScheduleNo: INT; // Consists No of respective state/time pair of a Switch-Task
nChannel: INT; // Channel of the EL2258
END_VAR
Program:
// Example program: 10x Multi-Timestamp for EL2258
nCurrentTime := F_GetCurDcTaskTime64(); // Get current DC-Time (Task-Related)
CASE nState OF
// ====================== Do some initializations here: ============================
0:
FOR nChannel:= 0 TO (nNumOfSwitchTasks-1) DO
// Reset ouput buffer of the terminal EL2258
bOutputBufReset[nChannel] := TRUE;
END_FOR
nState := nState + 1;// Go to next state
1:
FOR nChannel:= 0 TO (nNumOfSwitchTasks-1) DO
bOutputBufReset[nChannel] := FALSE;
END_FOR
nState := nState + 1; // Go to next state
2:
// Wait for external start-event by user (e.g. ext. switch)
IF bEnable THEN
nState := 10; // Go to next state and set events
END_IF
// =================================================================================
// ============ Now fill up all state/time pairs for the four channels =============
10:
FOR nChannel:= 0 TO (nNumOfSwitchTasks-1) DO
// Last tasks already executed?
IF nOutputOrderFeedback[nChannel] = nOutputOrderCounter[nChannel] THEN
bStateValue:=1;
// Set first state level ('1')
aQE_State[nChannel][0] := bStateValue;
// Cut 64 Bit time value to 32 Bit
nShortTime := ULINT_TO_UDINT(nCurrentTime AND 16#FFFFFFFF);
// Set first time value (duration for "save" begin)
aQE_Time[nChannel][0] := (nShortTime + aSwitchTimes[nChannel][0] * 1000000);
// Put all switch states with their times into the terminal:
FOR nScheduleNo:=1 TO 9 DO // Use 'nScheduleNo' as loop counter
bStateValue := NOT bStateValue;
// Set inverting output states of one switch-task
aQE_State[nChannel][nScheduleNo] := bStateValue;
// Set timestamps by fixed array into one switch-task
aQE_Time[nChannel][nScheduleNo] :=
(aQE_Time[nChannel][nScheduleNo-1]
+ aSwitchTimes[nChannel][nScheduleNo] * 1000000);
END_FOR
END_IF
END_FOR
nState := nState + 1; // Go to next state
// =================================================================================
// ======== Allow some taskcycles (min. 2) to let EL2258 schedule all tasks ========
11:
// 'nScheduleNo' is still 9; wait until 12: 3 more PLC-Taskcycles
IF nScheduleNo = 12 THEN
FOR nChannel:= 0 TO (nNumOfSwitchTasks-1) DO
nNoOfOutputEvents[nChannel] := 10;
// Trigger Multi-Timestamp scheduling: now start:
nOutputOrderCounter[nChannel] := nOutputOrderCounter[nChannel] + 1;
END_FOR
nState := nState + 1;
ELSE
// Just count PLC-Taskcycles here
nScheduleNo := nScheduleNo + 1;
END_IF
12:
// ================================== End ==========================================
// Wait for external switch to be released
IF NOT bEnable THEN
// Go to beginning state (could be '0' also)
nState := 2;
END_IF
END_CASE


Example program for EL1258 (EL1259): MT Visualization (TC 3)

Commissioning [image] Example programs [image] Example program for EL1258 (EL1259): MT Visualization (TC 3)
Example program for EL1258 (EL1259): MT Visualization (TC 3)
This sample program uses a TwinCAT3 visualization to illustrate the multi-timestamp functionality of a digital input of the EL1258 (and accordingly EL1259). In 10x multi-timestamp and asynchronous (buffered) mode, one terminal input is controlled by a digital EL2002 output terminal. The sample program contains the EtherCAT configuration and the corresponding links to the PDOs of the terminals and uses channel 1 (the channel input must be connected to channel output accordingly).
The following structure is recommended for commissioning the sample program:
[EK1100] + [EL1258] + [EL2002] + [EL9011]
Recommended structure for the EL1258 sample program
Download:
The MTI settings for the EL1258 are as follows:
CoE object 0x8000 (MTI settings ch.1): Settings for the sample program
To change settings, select the terminal in the Solution Explorer and select the "CoE - online" tab.
Explanatory notes on the sample program
A TwinCAT 3 visualization is used to illustrate the evaluation of binary input signals. Only the basic functionality is described. To this end, Visualization_1 merely represents a timestamp difference of two events at the input of channel 1 of the EL1258 (input bit 0 → 1 → 0):
Sample program EL1258 / Visualization_1: simple time measurement based on two state changes
A digital output terminal, whose output is directly connected to input channel 1 of the EL1258, switches the output with "SET OUTPUT". The user presses the button for any length of time; the elapsed time is shown in the upper bar-graph display, while the lower bar-graph display shows a time span determined by the timestamps of the EL1258.
Like Visualization_2, this is used for continuous output of a bit pattern or a pseudo-random sequence. All variations are possible here, with the intention to illustrate the behavior of the EL1258, including a reconstruction of the bit pattern using the time stamps of the received events (right side):
Sample program EL1258 / Visualization_2: Display of incoming events in chronological order according to the timestamps of the EL1258
Using the bit pattern defined in the POU "PulseOutputs" (left side):
This bit pattern is stored in the constant "nOutValueInit" as a 64-bit value in binary format and can be changed here with another bit sequence. Furthermore, Visualization_2 illustrates a basic procedure for processing the input signals of the EL1258: after processing current times (aInputEventTimes) and their associated states (aInputEventState) within the program, the system checks whether there are still events in the buffer (nEventsInInputBuffer). This is illustrated as follows:
Query of the "EventInInputBuffer" of the EL1258: Are there any other events stored in the terminal?
"LimitOfEventsInInputBuffer" can be used to specify from when the buffered events should be transferred to the readable PDOs of the terminal. The implementation in MAIN is represented here by the graphically displayed conditional branching and is intended to show that events stored in the terminal are passed on to the PDOs "externally" by incrementing the "InputOrderCounter".
Usage of the example program for EL1259
If the example program shall be used for the EL1259, this terminal have to be set into the configuration instead of the EL1258. All PDO bound to the selected input channel have to be linked with the respective program variables. As shown in figure “CoE object 0x8000 (MTI settings ch.1): Settings for the sample program” above, this device requires an equivalent configuration of channel 1 in CoE object 0x8080.


Appendix

Appendix
Appendix
Additional information
•
EtherCAT AL Status Codes
•
Firmware compatibility
•
Firmware Update EL/ES/EM/ELM/EPxxxx
•
Restoring the delivery state
•
Support and Service


EtherCAT AL Status Codes

Appendix [image] EtherCAT AL Status Codes
EtherCAT AL Status Codes
For detailed information please refer to the EtherCAT system description.


Firmware compatibility

Appendix [image] Firmware compatibility
Firmware compatibility
Beckhoff EtherCAT devices are delivered with the latest available firmware version. Compatibility of firmware and hardware is mandatory; not every combination ensures compatibility. The overview below shows the hardware versions on which a firmware can be operated.
Note
▪
It is recommended to use the newest possible firmware for the respective hardware
▪
Beckhoff is not under any obligation to provide customers with free firmware updates for delivered products.
Note
Risk of damage to the device!
Pay attention to the instructions for firmware updates on the separate page. If a device is placed in BOOTSTRAP mode for a firmware update, it does not check when downloading whether the new firmware is suitable. This can result in damage to the device! Therefore, always make sure that the firmware is suitable for the hardware version!
EL1258
Hardware (HW) | Firmware (FW) | Revision no. | Date of release
00 | 01 | EL1258-0000-0016 | 07/2013
 | 02 |  | 12/2013
 | 03 |  | 01/2014
01 | 04 |  | 06/2015
02 – 04* | 05 | EL1258-0000-0017 | 09/2015
 | 06 |  | 06/2015
 | 07* |  | 07/2018
EL1259
Hardware (HW) | Firmware (FW) | Revision no. | Date of release
00 – 01 | 01 | EL1259-0000-0016 | 01/2013
 | 02 |  | 12/2013
 | 03 | EL1259-0000-0017 | 07/2014
02 - 03* | 04 | EL1259-0000-0018 | 02/2018
 | 05 |  | 06/2019
 | 06* |  | 05/2020
EL2258
Hardware (HW) | Firmware (FW) | Revision no. | Date of release
00 - 01 | 01 | EL2258-0000-0016 | 07/2013
 | 02 |  | 12/2013
 | 03 | EL2258-0000-0017 | 07/2014
02* | 04 |  | 07/2018
 | 05* |  | 06/2019
*) This is the current compatible firmware/hardware version at the time of the preparing this documentation. Check on the Beckhoff web page whether more up-to-date documentation is available.


Firmware Update EL/ES/EM/ELM/EPxxxx

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx
Firmware Update EL/ES/EM/ELM/EPxxxx
This section describes the device update for Beckhoff EtherCAT slaves from the EL/ES, ELM, EM, EK and EP series. A firmware update should only be carried out after consultation with Beckhoff support.
Storage locations
An EtherCAT slave stores operating data in up to three locations:
▪
Depending on functionality and performance EtherCAT slaves have one or several local controllers for processing I/O data. The corresponding program is the so-called firmware in *.efw format.
▪
In some EtherCAT slaves the EtherCAT communication may also be integrated in these controllers. In this case the controller is usually a so-called FPGA chip with *.rbf firmware.
▪
In addition, each EtherCAT slave has a memory chip, a so-called ESI-EEPROM, for storing its own device description (ESI: EtherCAT Slave Information). On power-up this description is loaded and the EtherCAT communication is set up accordingly. The device description is available from the download area of the Beckhoff website at (https://www.beckhoff.de). All ESI files are accessible there as zip files.
Customers can access the data via the EtherCAT fieldbus and its communication mechanisms. Acyclic mailbox communication or register access to the ESC is used for updating or reading of these data.
The TwinCAT System Manager offers mechanisms for programming all three parts with new data, if the slave is set up for this purpose. Generally the slave does not check whether the new data are suitable, i.e. it may no longer be able to operate if the data are unsuitable.
Simplified update by bundle firmware
The update using so-called bundle firmware is more convenient: in this case the controller firmware and the ESI description are combined in a *.efw file; during the update both the firmware and the ESI are changed in the terminal. For this to happen it is necessary
▪
for the firmware to be in a packed format: recognizable by the file name, which also contains the revision number, e.g. ELxxxx-xxxx_REV0016_SW01.efw
▪
for password=1 to be entered in the download dialog. If password=0 (default setting) only the firmware update is carried out, without an ESI update.
▪
for the device to support this function. The function usually cannot be retrofitted; it is a component of many new developments from year of manufacture 2016.
Following the update, its success should be verified
▪
ESI/Revision: e.g. by means of an online scan in TwinCAT ConfigMode/FreeRun – this is a convenient way to determine the revision
▪
Firmware: e.g. by looking in the online CoE of the device
Note
Risk of damage to the device!
✓
Note the following when downloading new device files
1.
Firmware downloads to an EtherCAT device must not be interrupted
2.
Flawless EtherCAT communication must be ensured. CRC errors or LostFrames must be avoided.
3.
The power supply must adequately dimensioned. The signal level must meet the specification.
⇨
In the event of malfunctions during the update process the EtherCAT device may become unusable and require re-commissioning by the manufacturer.
Additional information
•
Device description ESI file/XML
•
Firmware explanation
•
Updating controller firmware *.efw
•
FPGA firmware *.rbf
•
Simultaneous updating of several EtherCAT devices


Device description ESI file/XML

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Device description ESI file/XML
Device description ESI file/XML
Note
Attention regarding update of the ESI description/EEPROM
Some slaves have stored calibration and configuration data from the production in the EEPROM. These are irretrievably overwritten during an update.
The ESI device description is stored locally on the slave and loaded on start-up. Each device description has a unique identifier consisting of slave name (9 characters/digits) and a revision number (4 digits). Each slave configured in the System Manager shows its identifier in the EtherCAT tab:
Device identifier consisting of name EL3204-0000 and revision -0016
The configured identifier must be compatible with the actual device description used as hardware, i.e. the description which the slave has loaded on start-up (in this case EL3204). Normally the configured revision must be the same or lower than that actually present in the terminal network.
For further information on this, please refer to the EtherCAT system documentation.
Update of XML/ESI description
The device revision is closely linked to the firmware and hardware used. Incompatible combinations lead to malfunctions or even final shutdown of the device. Corresponding updates should only be carried out in consultation with Beckhoff support.
Display of ESI slave identifier
The simplest way to ascertain compliance of configured and actual device description is to scan the EtherCAT boxes in TwinCAT mode Config/FreeRun:
Scan the subordinate field by right-clicking on the EtherCAT device
If the found field matches the configured field, the display shows
Configuration is identical
otherwise a change dialog appears for entering the actual data in the configuration.
Change dialog
In this example in Fig. Change dialog, an EL3201-0000-0017 was found, while an EL3201-0000-0016 was configured. In this case the configuration can be adapted with the Copy Before button. The Extended Information checkbox must be set in order to display the revision.
Changing the ESI slave identifier
The ESI/EEPROM identifier can be updated as follows under TwinCAT:
▪
Trouble-free EtherCAT communication must be established with the slave.
▪
The state of the slave is irrelevant.
▪
Right-clicking on the slave in the online display opens the EEPROM Update dialog, Fig. EEPROM Update
EEPROM Update
The new ESI description is selected in the following dialog, see Fig. Selecting the new ESI. The checkbox Show Hidden Devices also displays older, normally hidden versions of a slave.
Selecting the new ESI
A progress bar in the System Manager shows the progress. Data are first written, then verified.
The change only takes effect after a restart.
Most EtherCAT devices read a modified ESI description immediately or after startup from the INIT. Some communication settings such as distributed clocks are only read during power-on. The EtherCAT slave therefore has to be switched off briefly in order for the change to take effect.


Firmware explanation

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Firmware explanation
Firmware explanation
Determining the firmware version
Determining the version on laser inscription
Beckhoff EtherCAT slaves feature serial numbers applied by laser. The serial number has the following structure: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with ser. no.: 12 10 03 02:
12 - week of production 12
10 - year of production 2010
03 - firmware version 03
02 - hardware version 02
Determining the version via the System Manager
The TwinCAT System Manager shows the version of the controller firmware if the master can access the slave online. Click on the E-Bus Terminal whose controller firmware you want to check (in the example terminal 2 (EL3204)) and select the tab CoE Online (CAN over EtherCAT).
CoE Online and Offline CoE
Two CoE directories are available:
• online: This is offered in the EtherCAT slave by the controller, if the EtherCAT slave supports this. This CoE directory can only be displayed if a slave is connected and operational.
• offline: The EtherCAT Slave Information ESI/XML may contain the default content of the CoE. This CoE directory can only be displayed if it is included in the ESI (e.g. “Beckhoff EL5xxx.xml”).
The Advanced button must be used for switching between the two views.
In Fig. Display of EL3204 firmware version the firmware version of the selected EL3204 is shown as 03 in CoE entry 0x100A.
Display of EL3204 firmware version
In (A) TwinCAT 2.11 shows that the Online CoE directory is currently displayed. If this is not the case, the Online directory can be loaded via the Online option in Advanced Settings (B) and double-clicking on AllObjects.


Updating controller firmware *.efw

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Updating controller firmware *.efw
Updating controller firmware *.efw
CoE directory
The Online CoE directory is managed by the controller and stored in a dedicated EEPROM, which is generally not changed during a firmware update.
Switch to the Online tab to update the controller firmware of a slave, see Fig. Firmware Update.
Firmware Update
Proceed as follows, unless instructed otherwise by Beckhoff support. Valid for TwinCAT 2 and 3 as EtherCAT master.
▪
Switch TwinCAT system to ConfigMode/FreeRun with cycle time >= 1 ms (default in ConfigMode is 4 ms). A FW-Update during real time operation is not recommended.
▪
Switch EtherCAT Master to PreOP
▪
Switch slave to INIT (A)
▪
Switch slave to BOOTSTRAP
▪
Check the current status (B, C)
▪
Download the new *efw file (wait until it ends). A pass word will not be neccessary usually.
▪
After the download switch to INIT, then PreOP
▪
Switch off the slave briefly (don't pull under voltage!)
▪
Check within CoE 0x100A, if the FW status was correctly overtaken.


FPGA firmware *.rbf

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] FPGA firmware *.rbf
FPGA firmware *.rbf
If an FPGA chip deals with the EtherCAT communication an update may be accomplished via an *.rbf file.
▪
Controller firmware for processing I/O signals
▪
FPGA firmware for EtherCAT communication (only for terminals with FPGA)
The firmware version number included in the terminal serial number contains both firmware components. If one of these firmware components is modified this version number is updated.
Determining the version via the System Manager
The TwinCAT System Manager indicates the FPGA firmware version. Click on the Ethernet card of your EtherCAT strand (Device 2 in the example) and select the Online tab.
The Reg:0002 column indicates the firmware version of the individual EtherCAT devices in hexadecimal and decimal representation.
FPGA firmware version definition
If the column Reg:0002 is not displayed, right-click the table header and select Properties in the context menu.
Context menu Properties
The Advanced Settings dialog appears where the columns to be displayed can be selected. Under Diagnosis/Online View select the '0002 ETxxxx Build' check box in order to activate the FPGA firmware version display.
Dialog Advanced Settings
Update
For updating the FPGA firmware
▪
of an EtherCAT coupler the coupler must have FPGA firmware version 11 or higher;
▪
of an E-Bus Terminal the terminal must have FPGA firmware version 10 or higher.
Older firmware versions can only be updated by the manufacturer!
Updating an EtherCAT device
The following sequence order have to be met if no other specifications are given (e.g. by the Beckhoff support):
▪
Switch TwinCAT system to ConfigMode/FreeRun with cycle time >= 1 ms (default in ConfigMode is 4 ms). A FW-Update during real time operation is not recommended.
▪
In the TwinCAT System Manager select the terminal for which the FPGA firmware is to be updated (in the example: Terminal 5: EL5001) and
click the Advanced Settings button in the EtherCAT tab:
▪
The Advanced Settings dialog appears. Under ESC Access/E²PROM/FPGA click on Write FPGA button:
▪
Select the file (*.rbf) with the new FPGA firmware, and transfer it to the EtherCAT device:
▪
Wait until download ends
▪
Switch slave current less for a short time (don't pull under voltage!). In order to activate the new FPGA firmware a restart (switching the power supply off and on again) of the EtherCAT device is required.
▪
Check the new FPGA status
Note
Risk of damage to the device!
A download of firmware to an EtherCAT device must not be interrupted in any case! If you interrupt this process by switching off power supply or disconnecting the Ethernet link, the EtherCAT device can only be recommissioned by the manufacturer!


Simultaneous updating of several EtherCAT devices

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Simultaneous updating of several EtherCAT devices
Simultaneous updating of several EtherCAT devices
The firmware and ESI descriptions of several devices can be updated simultaneously, provided the devices have the same firmware file/ESI.
Multiple selection and firmware update
Select the required slaves and carry out the firmware update in BOOTSTRAP mode as described above.


Restoring the delivery state

Appendix [image] Restoring the delivery state
Restoring the delivery state
To restore the delivery state for backup objects in ELxxxx terminals, the CoE object Restore default parameters, SubIndex 001 can be selected in the TwinCAT System Manager (Config mode) (see Fig. Selecting the Restore default parameters PDO)
Selecting the Restore default parameters PDO
Double-click on SubIndex 001 to enter the Set Value dialog. Enter the value 1684107116 in field Dec or the value 0x64616F6C in field Hex and confirm with OK (Fig. Entering a restore value in the Set Value dialog).
All backup objects are reset to the delivery state.
Entering a restore value in the Set Value dialog
Alternative restore value
In some older terminals the backup objects can be switched with an alternative restore value: Decimal value: 1819238756, Hexadecimal value: 0x6C6F6164An incorrect entry for the restore value has no effect.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com