EKM1101 | EtherCAT Coupler with ID switch and diagnostics
Home


Foreword

EKM1101 | EtherCAT Coupler with ID switch and diagnostics
Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status
•
Version identification of EtherCAT devices


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version | Modifications
1.0 | - 1st public issue
0.2 | - Specifications of technical data updated - Insertion of section “Power supply, potential groups” within chapter “Mounting and wiring” - Connection descriptions updated - Chapter “LEDs and connection” updated
0.1 | - First preliminary version


Version identification of EtherCAT devices

Foreword [image] Version identification of EtherCAT devices
Version identification of EtherCAT devices
Designation
A Beckhoff EtherCAT device has a 14-digit designation, made up of
▪
family key
▪
type
▪
version
▪
revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
Notes
▪
The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
▪
EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
▪
The order identifier is made up of
- family key (EL, EP, CU, ES, KL, CX, etc.)
- type (3314)
- version (-0000)
▪
The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
▪
The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Identification number
Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:
Production lot/batch number/serial number/date code/D number
The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02
Exceptions can occur in the IP67 area, where the following syntax can be used (see respective device documentation):
Syntax: D ww yy x y z u
D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB
Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1
Unique serial number/ID, ID number
In addition, in some series each individual module has its own unique serial number.
See also the further documentation in the area
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Terminals with factory calibration certificate and other measuring terminals
Examples of markings
EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
CU2016 switch with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
EP1258-00001 IP67 EtherCAT Box with batch number/ date code 22090101 and unique serial number 158102
EP1908-0002 IP67 EtherCAT Safety Box with batch number/ date code 071201FF and unique serial number 00346070
EL2904 IP20 safety terminal with batch number/ date code 50110302 and unique serial number 00331701
ELM3604-0002 terminal with unique ID number (QR code) 100001051 and serial/ batch number 44160201
Additional information
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Foreword [image] Version identification of EtherCAT devices [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Product overview

Product overview
Product overview
Additional information
•
EKM1101 - Introduction
•
EKM1101 - Technical data


EKM1101 - Introduction

Product overview [image] EKM1101 - Introduction
EKM1101 - Introduction
EKM1101 | EtherCAT Coupler with ID switch and diagnostics
The EKM1101 EtherCAT Coupler connects the ELMxxxx EtherCAT measurement modules or other EL/ES/EMxxxx terminals with EtherCAT. Such a station consists
▪
of an EKM1101 coupler
▪
any number of EtherCAT Terminals (observe mounting rail length as well as E bus current!)
▪
and a bus end cap or an EtherCAT extension such as EK1110 or EK1122.
The coupler converts the passing telegrams from Ethernet 100BASE‑TX to E bus signal representation.
On account of three significant properties, the EKM1101 and the functionally identical ELM9410 power supply terminal are designed to meet the needs of high-precision analog measurement technology, e.g. with ELM3xxx terminals:
▪
To reduce interference by the supply in the connected terminal, both the E-bus supply US and the 24 V power contact supply UP are electrically isolated and filtered in the coupler. The power contact supply can carry a maximum load of 2 A permanently.
▪
The extensive voltage and temperature monitoring provides assistance with commissioning and operation; results are displayed by LED and in the process image.
▪
The built-in three-axis position and vibration sensor allows a constant view of the mechanical situation in the control cabinet.
As a result, the EKM1101 can be used in special measuring situations instead of the conventional EK1100 or EK1101 EtherCAT Coupler. Mixed operation with the following terminal EL9410 is possible, but this negates the concept of electrical isolation.
The EKM1101 has two hexadecimal ID switches for assigning an ID to a group of EtherCAT components. This group can then be located at any position within the EtherCAT network and also being removed and inserted again during run time (TwinCAT HotConnect). Variable topologies are therefore easily implementable.


EKM1101 - Technical data

Product overview [image] EKM1101 - Technical data
EKM1101 - Technical data
Technical data |  | EKM1101
Task within the EtherCAT system |  | Coupling of EtherCAT Terminals (ELMxxxx) to 100BASE-TX EtherCAT networks
Data transfer medium |  | Ethernet/EtherCAT cable (min. Cat. 5), shielded
Distance between stations |  | max. 100 m (100BASE-TX)
Number of EtherCAT Terminals |  | up to 65,534
Type/number of peripheral signals |  | max. 4.2 GB addressable I/O points
Number of configurable IDs |  | 256 (16x16)
Protocol |  | EtherCAT
Delay |  | typical 1 µs
Data transfer rates |  | 100 Mbit/s
Bus interface |  | 2 x RJ45
US (E bus) | Permissible supply US, IN | 24 VDC (-15%/+20%) 130 mA + (∑ E bus current/4)
 | Measurement uncertainty | typ. ±0.85 % of 24V (±0.20 V)
 | Technical measuring range | 32.2 V
 | Output E bus US,Out | 5V typ. IS,OUT = max. 2000 mA
 | Electrical isolation | functional isolation, 500V DC, permanently
UP (power contacts) | Permissible supply UP, OUT | 24 VDC (-15%/+20%) 50 mA + load current
 | Measurement uncertainty | typ. ±0.85% of 24V (±0.20 V)
 | Technical measuring range | 32.2 V
 | Output power contacts UP,OUT | typ. 22.5 V solange UP,IN im zul. Bereich IP,OUT = max. 2000 mA permanent
 | Electrical isolation | functional isolation, 500V DC, permanently
Power dissipation |  | max. 20 W, dependent of the converted electrical power
Special features |  | electrically isolated output voltages, reverse polarity protection, diagnostics of supply and output voltages, diagnostics of internal temperature, diagnostics of position and vibration
Electrical isolation US/UP/EtherCAT |  | 500 V DC
Weight |  | approx. 420 g
Permissible ambient temperature range during operation |  | In standard installation position, at IS,OUT = 2A, without forced ventilation At IP,OUT = 0 A: 0°C ... +55°C At IP,OUT < 0.5 A: 0°C ... +50°C At IP,OUT < 1,0 A: 0°C ... +45°C At IP,OUT < 1.5 A: 0°C ... +40°C At IP,OUT < 2.0 A: 0°C ... +35°C In all other installation positions the above mentioned max. permissible ambient temperature is reduced by 10°C Note: the coupler gives a warning if the internal temperature is exceeded, this must be observed. Note: observe the surface temperature of the housing, the device heats up considerably
Permissible ambient temperature range during storage |  | -40°C ... +85°C
Permissible relative humidity |  | 95%, no condensation
Mounting |  | on 35 mm mounting rail conforms to EN 60715
Vibration/shock resistance |  | conforms to EN 60068-2-6/EN 60068-2-27
EMC immunity/emission |  | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class |  | IP20
Installation position |  | variable
Approval |  | CE


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
LEDs and connection
•
Installation positions
•
Mounting of Passive Terminals
•
ELM/EKM terminal mounting on DIN rail
•
Protective earth (PE)
•
Wiring
•
Power supply, potential groups


LEDs and connection

Mounting and wiring [image] LEDs and connection
LEDs and connection
Diagnostic LEDs EKM1101
EtherCAT Status RUN
LED |  | Display | State | Description
RUN | green | off | Init | The bus coupler is in initialization state
 |  | flashing | Pre-Operational | The bus coupler is in pre operational state
 |  | single flash | Safe-Operational | The bus coupler is in safe operational state
 |  | on | Operational | The bus coupler is in operational state
 |  | flickers | Bootstrap | A new firmware will be loaded
US |  | off | - | No 24 VDC operating voltage for US available on bus coupler
 |  | green | - | Incoming 24 VDC operating voltage for US available on the bus coupler within the permissible range
 |  | red | - | Under voltage approx. < 20.3 V Under voltage approx. > 28.8 V (simultaneously PDO Error = TRUE)
UP |  | off | - | No 24 VDC operating voltage for UP available on bus coupler
 |  | green | - | Incoming 24 VDC operating voltage for UP available on the bus coupler within the permissible range and outgoing UP on power contacts OK
 |  | red | - | Incoming 24 VDC operating voltage for UP or outgoing UP on power contacts: Under voltage approx. < 20.3 V Under voltage approx. > 28.8 V (simultaneously PDO Error = TRUE)
DEV |  | off | - | Normal operation
 |  | yellow | - | Over temperature within device > 85°C Position sensor error
EtherCAT Link LEDs (EKM1101 only)
LED |  | Display | State | Description
LINK/ACT (X001 IN) | green | off | - | No connection on the incoming EtherCAT strand
 |  | on | linked | Preceding EtherCAT device connected
 |  | flashing | active | Communication with preceding EtherCAT device
LINK/ACT (X002 OUT) | green | off | - | No connection on the outgoing EtherCAT strand
 |  | on | linked | Following EtherCAT device connected
 |  | flashing | active | Communication with following EtherCAT device
Connection EKM1101, ELM9410
EKM1101: Terminal point X003 ELM9410: Terminal point X001 |  | Description
Indication | No.
+US | 1, 2 | Supply input + 24 V for Us (E Bus; terminal no. 1 and 2 internal connected)
-US | 3, 4 | Supply input 0 V for Us (E Bus; terminal no. 3 and 4 internal connected)
+UP | 5, 6 | Supply input + 24 V for UP (Power contacts; terminal no. 5 and 6 internal connected)
-UP | 7, 8 | Supply input 0 V for UP (Power contacts; terminal no. 7 and 8 internal connected)
Shield | 9, 10 | Grounding connector to DIN rail or rather housing (terminal no. 9 and 10 internal connected) Note: PE accessible under cover as screw connection


Installation positions

Mounting and wiring [image] Installation positions
Installation positions
Note
Constraints regarding installation position and operating temperature range
Please refer to the technical data for a terminal to ascertain whether any restrictions regarding the installation position and/or the operating temperature range have been specified. When installing high power dissipation terminals ensure that an adequate spacing is maintained between other components above and below the terminal in order to guarantee adequate ventilation!
Optimum installation position (standard)
The optimum installation position requires the mounting rail to be installed horizontally and the connection surfaces of the EL/KL terminals to face forward (see Fig. “Recommended distances for standard installation position”). The terminals are ventilated from below, which enables optimum cooling of the electronics through convection. "From below" is relative to the acceleration of gravity.
Recommended distances for standard installation position
Compliance with the distances shown in Fig. “Recommended distances for standard installation position” is recommended.
Other installation positions
All other installation positions are characterized by different spatial arrangement of the mounting rail - see Fig “Other installation positions”.
The minimum distances to ambient specified above also apply to these installation positions.
Other installation positions


Mounting of Passive Terminals

Mounting and wiring [image] Mounting of Passive Terminals
Mounting of Passive Terminals
Hint for mounting passive terminals
EtherCAT Bus Terminals (ELxxxx / ESxxxx), which do not take an active part in data transfer within the bus terminal block are so called Passive Terminals. The Passive Terminals have no current consumption out of the E-Bus To ensure an optimal data transfer, you must not directly string together more than 2 Passive Terminals!
Examples for mounting passive terminals (highlighted)
Correct configuration
Incorrect configuration


ELM/EKM terminal mounting on DIN rail

Mounting and wiring [image] ELM/EKM terminal mounting on DIN rail
ELM/EKM terminal mounting on DIN rail
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Assembly
The ELM terminal modules are locked to commercially available 35 mm mounting rails (DIN rails according to EN 60715) as following described:
▪
The The ELM terminal module can easily be latched onto the DIN rail. Thererfore the clips of the module on top and down side have to be opened first:
Opening the clips on top and down side by lifting them e.g. with a screw driver
▪
Insert the ELM terminal module to other already on the DIN rail arranged moduls together with tongue and groove and push the terminals against the mounting rail, until it clicks onto the touchdown point of the mounting rail. Then close the both clips on top and down side of the module respectively:
Push-in of the ELM terminal module and closing the mounting rail clips top and down
▪
During closing of the both clips there mustn't be a disruptive mechanical resistance being noticeable. The clips have to be snapped so that they're ending flat with the housing:
Attention: If the ELM terminal module is clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.
Disassembly
Each ELM terminal is secured by a lock on the mounting rail, which must be released for disassembly. The procedure for demounting have to be done in reverse order as described in Assembly:
1.
Release the mounting rail lock of the ELM terminal module on the top and down side and you can pull the terminal out of the bus terminal block easily without excessive force.
2.
Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal out of the bus terminal block.
Opening of the upper and lower mounting rail lock and pull out the ELM terminal module
Connections within a bus terminal block
The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components: The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.


Protective earth (PE)

Mounting and wiring [image] Protective earth (PE)
Protective earth (PE)
The housings of the ELM/EKM series are made of die-cast zinc and are thus metallic. This results in a need for clarification regarding the use of protective earthing against the risk of electric shock.
Attention: The relevant application standards refer to the surrounding control cabinet/control box as "housing", whereas this documentation refers to the Beckhoff terminal as "housing".
See also chapter "Earthing: PE vs. FE vs. Grounding" in this documentation.
The housing offers the option of an M3 bolted connection for connecting a ring terminal to PE.
The procedure for this is as follows:
▪
Lever off the plastic cover from the ELM housing and retain if for later reuse, if required
▪
Secure the previously prepared ring terminal, which was crimped to the protective conductor, using an M3x4 screw; max. torque 0.5 Nm. Use a suitable tool.
ATTENTION: The screw must not be longer than specified, in order to avoid it protruding into the interior, where it could cause damage. This would be evident if the unit is sent in for repair.
▪
Connect the PE cable to the protective conductor system.
Notes on whether a PE connection is necessary in the specific application
▪
A PE connection is required if the terminal could pose a risk of electric shock due to an inadmissible contact voltage. A distinction is made between two causes:
–
if the terminal is subjected to high internal voltages (not SELV/PELV), this high voltage may reach the housing in the event of a fault. For such terminals, a PE connection is essential. See the corresponding mechanical options at the module. For background information please refer to product and device standards such as EN 61010.
Note: The terminals of type ELM3004, ELM3002, ELM3104, ELM3102, ELM3504, ELM3502, ELM3604, ELM3602, ELM3704, ELM3702 operate with low voltage SELV/PELV, so that there is usually no potential risk.
–
A connection to the protective earth conductor system must nevertheless be provided if the terminal operates with protective extra-low voltage (SELV/PELV), but there is a risk that a live conductor may come into contact with the housing in the event of a fault, resulting in unacceptable touch voltage. This is stipulated by application standards such as EN60204‑1 or EN61439‑1 relating to control cabinet design.
▪
It is therefore always necessary to check in which environment the application is used to ascertain whether a PE connection is required.
Note on protective earth (PE) with regard to analog measurements
The protective earth conductor system is specifically designed for discharging high currents. This may result in significant high-frequency interference, which could adversely affect an analog measuring device if it is/has to be connected to the protective conductor system. In such cases, a strictly star-shaped configuration of the FE and PE systems may be advisable, in order to have as few interference sources as possible on the PE system that are close to the analog measuring system. Ideally, no PE connection should be used at all. However, in this case the installation must comply with the two conditions referred to above, which may necessitate splitting the system into a high-voltage and a low-voltage control cabinet, so that no PE would be required for the latter.


Wiring

Mounting and wiring [image] Wiring
Wiring
The two 4- and 6-pole connectors support the push-in wiring of individual wires and fine-wire conductors with wire-end sleeves.
In the case of multi-wire and fine-wire conductors, the latch must be depressed to connect the conductor with the contact point.
Depressing the latch for push-in wiring
Depress the latch with a screwdriver, insert the conductor and release the latch.


Power supply, potential groups

Mounting and wiring [image] Power supply, potential groups
Power supply, potential groups
Bus Coupler power supply US
The EKM1101 Bus Coupler and the ELM9410 Power Feed Terminal require a voltage of 24 V DC for operation. They are connected via the upper 4-pin connector with the designation + and -. The supply voltage is used by the electronics of the Bus Coupler as well as for the voltage generation for the E-bus.
The voltage generation for the E-bus takes place in a DC/DC converter without electrical isolation. The E-bus is supplied with a maximum of 2,000 mA E-bus current. Power feed terminals, e.g. ELM9410, are to be inserted if the appended terminals require more current.
The fuse should have a rating of max. 1 A, depending on the required current consumption of the configured terminals.
Power contact power supply UP
The 4 connectors below that in the lower 6-pin connector with the designations + and - are to be used for the power supply to the periphery if this is needed. These feed the outgoing power contacts +/-.
The voltage for the power contacts is generated in a DC/DC converter with electrical isolation. The power contacts are supplied with a maximum of 2,000 mA. Power feed terminals, e.g. ELM9410, are to be inserted if the appended terminals require more current.
The EKM1101/ELM9410 devices re-condition the power contact supply with electrical isolation so that the downstream terminals are supplied with a stable, smoothed and monitored voltage.
The fuse should have a rating of max. 4 A, depending on the required current consumption and thus on the configured terminals.
Power contacts
The two spring contacts of the power contact connections +/- are located on the right-hand lateral surface of the Bus Coupler. The spring contacts are hidden in slots so that they can not be accidentally touched. By attaching a Bus Terminal the blade contacts on the left hand side of the Bus Terminal are connected to the spring contacts. The tongue and groove guides on the top and bottom of the Bus Coupler and of the Bus Terminals guarantees that the power contacts mate securely. The current load on the power contacts must not permanently exceed 10 A; since the output current is limited to 2 A on the part of EKM1101/ELM9410, this value is not usually exceeded.
Electrical isolation
The EKM1101/ELM9410 devices operate with three independent potential groups.
Note: All Bus Terminals feature electrical isolation from the field side to the E-bus. The E-bus is thus electrically isolated from everything else.
Internal wiring EKM1101 (principle/simplified)


Commissioning/application notes

EKM1101 | EtherCAT Coupler with ID switch and diagnostics
Commissioning/application notes
Commissioning/application notes
Specifications follow


Basics communication

Basics communication
Basics communication
Additional information
•
System properties
•
EtherCAT basics
•
EtherCAT State Machine
•
CoE - Interface: notes
•
Distributed Clock


System properties

Basics communication [image] System properties
System properties
Protocol
The EtherCAT protocol is optimized for process data and is transported directly within the Ethernet frame thanks to a special Ether-type. It may consist of several sub-telegrams, each serving a particular memory area of the logical process images that can be up to 4 gigabytes in size. The data sequence is independent of the physical order of the Ethernet terminals in the network; addressing can be in any order. Broadcast, Multicast and communication between slaves are possible. Transfer directly in the Ethernet frame is used in cases where EtherCAT components are operated in the same subnet as the control computer.
However, EtherCAT applications are not limited to a subnet: EtherCAT UDP packs the EtherCAT protocol into UDP/IP datagrams. This enables any control with Ethernet protocol stack to address EtherCAT systems. Even communication across routers into other subnets is possible. In this variant, system performance obviously depends on the real-time characteristics of the control and its Ethernet protocol implementation. The response times of the EtherCAT network itself are hardly restricted at all: the UDP datagram only has to be unpacked in the first station.
EtherCAT Telegram Structure
Protocol structure: The process image allocation is freely configurable. Data are copied directly in the I/O terminal to the desired location within the process image: no additional mapping is required. The available logical address space is with very large (4 GB).
Topology
Line, tree or star: EtherCAT supports almost any topology. The bus or line structure known from the fieldbuses thus also becomes available for Ethernet. Particularly useful for system wiring is the combination of line and junctions or stubs. The required interfaces exist on the couplers; no additional switches are required. Naturally, the classic switch-based Ethernet star topology can also be used.
EtherCAT Topology
Maximum wiring flexibility:
with or without switch, line or tree topologies, can be freely selected and combined.
Wiring flexibility is further maximized through the choice of different cables. Flexible and cost-effective standard Ethernet patch cables transfer the signals in Ethernet mode (100Base-TX). The complete bandwidth of the Ethernet network - such as different optical fibers and copper cables - can be used in combination with switches or media converters.
Distributed Clocks
Accurate synchronization is particularly important in cases where spatially distributed processes require simultaneous actions. This may be the case, for example, in applications where several servo axes carry out coordinated movements simultaneously.
The most powerful approach for synchronization is the accurate alignment of distributed clocks, as described in the new IEEE 1588 standard. In contrast to fully synchronous communication, where synchronization quality suffers immediately in the event of a communication fault, distributed aligned clocks have a high degree of tolerance vis-à-vis possible fault-related delays within the communication system.
With EtherCAT, the data exchange is fully based on a pure hardware machine. Since the communication utilizes a logical (and thanks to full-duplex Fast Ethernet also physical) ring structure, the mother clock can determine the run-time offset to the individual daughter clocks simply and accurately - and vice versa. The distributed clocks are adjusted based on this value, which means that a very precise network-wide timebase with a jitter of significantly less than 1 microsecond is available.
However, high-resolution distributed clocks are not only used for synchronization, but can also provide accurate information about the local timing of the data acquisition. For example, controls frequently calculate velocities from sequentially measured positions. Particularly with very short sampling times, even a small temporal jitter in the displacement measurement leads to large step changes in velocity. With EtherCAT new, extended data types are introduced as a logical extension (time stamp and oversampling data type). The local time is linked to the measured value with a resolution of up to 10 ns, which is made possible by the large bandwidth offered by Ethernet. The accuracy of a velocity calculation then no longer depends on the jitter of the communication system. It is orders of magnitude better than that of measuring techniques based on jitter-free communication.
Performance
EtherCAT reaches new dimensions in network performance. Protocol processing is purely hardware-based through an FMMU chip in the terminal and DMA access to the network card of the master. It is thus independent of protocol stack run-times, CPU performance and software implementation. The update time for 1000 I/Os is only 30 µs - including terminal cycle time. Up to 1486 bytes of process data can be exchanged with a single Ethernet frame - this is equivalent to almost 12000 digital inputs and outputs. The transfer of this data quantity only takes 300 µs.
The communication with 100 servo axes only takes 100 µs. During this time, all axes are provided with set values and control data and report their actual position and status. Distributed clocks enable the axes to be synchronized with a deviation of significantly less than 1 microsecond.
The extremely high performance of the EtherCAT technology enables control concepts that could not be realized with classic fieldbus systems. For example, the Ethernet system can now not only deal with velocity control, but also with the current control of distributed drives. The tremendous bandwidth enables status information to be transferred with each data item. With EtherCAT, a communication technology is available that matches the superior computing power of modern Industrial PCs. The bus system is no longer the bottleneck of the control concept. Distributed I/Os are recorded faster than is possible with most local I/O interfaces. The EtherCAT technology principle is scalable and not bound to the baud rate of 100 Mbaud – extension to Gbit Ethernet is possible.
Diagnostics
Experience with fieldbus systems shows that availability and commissioning times crucially depend on the diagnostic capability. Only faults that are detected quickly and accurately and which can be precisely located can be corrected quickly. Therefore, special attention was paid to exemplary diagnostic features during the development of EtherCAT.
During commissioning, the actual configuration of the I/O terminals should be checked for consistency with the specified configuration. The topology should also match the saved configuration. Due to the built-in topology recognition down to the individual terminals, this verification can not only take place during system start-up, automatic reading in of the network is also possible (configuration upload).
Bit faults during the transfer are reliably detected through evaluation of the CRC checksum: The 32 bit CRC polynomial has a minimum hamming distance of 4. Apart from breaking point detection and localization, the protocol, physical transfer behavior and topology of the EtherCAT system enable individual quality monitoring of each individual transmission segment. The automatic evaluation of the associated error counters enables precise localization of critical network sections. Gradual or changing sources of error such as EMC influences, defective push-in connectors or cable damage are detected and located, even if they do not yet overstrain the self-healing capacity of the network.
Integration of standard Bus Terminals from Beckhoff
In addition to the new Bus Terminals with E-Bus connection (ELxxxx), all Bus Terminals from the familiar standard range with K-bus connection (KLxxxx) can be connected via the BK1120 or BK1250 Bus Coupler. This ensures compatibility and continuity with the existing Beckhoff Bus Terminal systems. Existing investments are protected.


EtherCAT basics

EKM1101 | EtherCAT Coupler with ID switch and diagnostics
Basics communication [image] EtherCAT basics
EtherCAT basics
Please refer to the EtherCAT System Documentation for the EtherCAT fieldbus basics.


EtherCAT State Machine

Basics communication [image] EtherCAT State Machine
EtherCAT State Machine
The state of the EtherCAT slave is controlled via the EtherCAT State Machine (ESM). Depending upon the state, different functions are accessible or executable in the EtherCAT slave. Specific commands must be sent by the EtherCAT master to the device in each state, particularly during the bootup of the slave.
A distinction is made between the following states:
▪
Init
▪
Pre-Operational
▪
Safe-Operational and
▪
Operational
▪
Boot
The regular state of each EtherCAT slave after bootup is the OP state.
States of the EtherCAT State Machine
Init
After switch-on the EtherCAT slave in the Init state. No mailbox or process data communication is possible. The EtherCAT master initializes sync manager channels 0 and 1 for mailbox communication.
Pre-Operational (Pre-Op)
During the transition between Init and Pre-Op the EtherCAT slave checks whether the mailbox was initialized correctly.
In Pre-Op state mailbox communication is possible, but not process data communication. The EtherCAT master initializes the sync manager channels for process data (from sync manager channel 2), the FMMU channels and, if the slave supports configurable mapping, PDO mapping or the sync manager PDO assignment. In this state the settings for the process data transfer and perhaps terminal-specific parameters that may differ from the default settings are also transferred.
Safe-Operational (Safe-Op)
During transition between Pre-Op and Safe-Op the EtherCAT slave checks whether the sync manager channels for process data communication and, if required, the distributed clocks settings are correct. Before it acknowledges the change of state, the EtherCAT slave copies current input data into the associated DP-RAM areas of the EtherCAT slave controller (ECSC).
In Safe-Op state mailbox and process data communication is possible, although the slave keeps its outputs in a safe state, while the input data are updated cyclically.
Outputs in SAFEOP state
The default set watchdog monitoring sets the outputs of the module in a safe state - depending on the settings in SAFEOP and OP - e.g. in OFF state. If this is prevented by deactivation of the watchdog monitoring in the module, the outputs can be switched or set also in the SAFEOP state.
Operational (Op)
Before the EtherCAT master switches the EtherCAT slave from Safe-Op to Op it must transfer valid output data.
In the Op state the slave copies the output data of the masters to its outputs. Process data and mailbox communication is possible.
Boot
In the Boot state the slave firmware can be updated. The Boot state can only be reached via the Init state.
In the Boot state mailbox communication via the file access over EtherCAT (FoE) protocol is possible, but no other mailbox communication and no process data communication.


CoE - Interface: notes

EKM1101 | EtherCAT Coupler with ID switch and diagnostics
Basics communication [image] CoE - Interface: notes
CoE - Interface: notes
This device has no CoE.
Detailed information on the CoE interface can be found in the EtherCAT system documentation on the Beckhoff website.


Distributed Clock

Basics communication [image] Distributed Clock
Distributed Clock
The distributed clock represents a local clock in the EtherCAT slave controller (ESC) with the following characteristics:
▪
Unit 1 ns
▪
Zero point 1.1.2000 00:00
▪
Size 64 bit (sufficient for the next 584 years; however, some EtherCAT slaves only offer 32-bit support, i.e. the variable overflows after approx. 4.2 seconds)
▪
The EtherCAT master automatically synchronizes the local clock with the master clock in the EtherCAT bus with a precision of < 100 ns.
For detailed information please refer to the EtherCAT system description.


Appendix

Appendix
Appendix
Additional information
•
EtherCAT AL Status Codes
•
Firmware compatibility
•
Support and Service


EtherCAT AL Status Codes

EKM1101 | EtherCAT Coupler with ID switch and diagnostics
Appendix [image] EtherCAT AL Status Codes
EtherCAT AL Status Codes
For detailed information please refer to the EtherCAT system description.


Firmware compatibility

EKM1101 | EtherCAT Coupler with ID switch and diagnostics
Appendix [image] Firmware compatibility
Firmware compatibility
The EKM1101 has no firmware.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com