EK9300 - PROFINET Bus Coupler for EtherCAT Terminals
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status
•
Version identification of EtherCAT devices


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
3.3.0
▪
Update chapter “Technical data”
3.2.6
▪
Update chapter “Configuration”
▪
Update structure
3.2.5
▪
Update chapter “Configuration”
▪
Update structure
3.2.4
▪
Update UL notice
3.2.3
▪
Update Technical data
▪
Update structure
3.2.2
▪
Update chapter “Update Bus Coupler image”
3.2.1
▪
Update chapter “Technical data”
3.2.0
▪
Configuration From firmware Version 8 added
▪
Update chapter “Technical data”
3.1.0
▪
Update chapter "Notes on the documentation"
▪
Update chapter "EK9300 - PROFINET" -> "EKxxxx - Systemübersicht"
▪
Update chapter "Technical data"
▪
Addenda chapter "Instructions for ESD protection"
▪
Addenda chapter "ATEX - Special conditions (standard temperature range)" and note "ATEX Documentation"
▪
Addenda chapter "UL notice"
3.0.0
▪
Migration
▪
Update structure
2.1.0
▪
Chapter CoE data access over PROFINET added
▪
Chapter Multi-configuration mode added
▪
Chapter IO-LINK added
2.0.0
▪
Addenda and corrections
▪
First published
1.0.1
▪
Addenda and corrections
1.0.0
▪
Preliminary version


Version identification of EtherCAT devices

Foreword [image] Version identification of EtherCAT devices
Version identification of EtherCAT devices
Designation
A Beckhoff EtherCAT device has a 14-digit designation, made up of
▪
family key
▪
type
▪
version
▪
revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
Notes
▪
The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
▪
EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
▪
The order identifier is made up of
- family key (EL, EP, CU, ES, KL, CX, etc.)
- type (3314)
- version (-0000)
▪
The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
▪
The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Identification number
Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:
Production lot/batch number/serial number/date code/D number
The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02
Exceptions can occur in the IP67 area, where the following syntax can be used (see respective device documentation):
Syntax: D ww yy x y z u
D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB
Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1
Unique serial number/ID, ID number
In addition, in some series each individual module has its own unique serial number.
See also the further documentation in the area
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Terminals with factory calibration certificate and other measuring terminals
Examples of markings
EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
CU2016 switch with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
EP1258-00001 IP67 EtherCAT Box with batch number/ date code 22090101 and unique serial number 158102
EP1908-0002 IP67 EtherCAT Safety Box with batch number/ date code 071201FF and unique serial number 00346070
EL2904 IP20 safety terminal with batch number/ date code 50110302 and unique serial number 00331701
ELM3604-0002 terminal with unique ID number (QR code) 100001051 and serial/ batch number 44160201
Additional information
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Foreword [image] Version identification of EtherCAT devices [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Product overview

Product overview
Product overview
Additional information
•
EKxxxx - System overview
•
Technical data
•
Technical data PROFINET


EKxxxx - System overview

Product overview [image] EKxxxx - System overview
EKxxxx - System overview
EtherCAT Terminals at an EKxxxx series Bus Coupler
The Bus Couplers from the EKxxxx series allow EtherCAT Terminals to be operated on conventional fieldbus systems. The ultra-fast, high-performance EtherCAT Terminals with their large range of signal types are thus also available for other fieldbus and Industrial Ethernet systems.
The EKxxxx Bus Couplers are fieldbus slaves and contain an EtherCAT master for the EtherCAT terminals. They convert the telegrams from the higher-level fieldbus systems into the E-bus signal representation. A station consists of an EKxxxx and a number of EtherCAT Terminals.
The EKxxxx is integrated in exactly the same way as the Bus Couplers from the BKxxxx series via the corresponding fieldbus system configuration tools and the associated configuration files, such as GSD, ESD or GSDML.
EtherCAT makes a very flexible topology configuration possible. Thanks to the Ethernet physics, long distances can also be bridged without the bus speed being affected. When changing to the field level – without a control cabinet – the EtherCAT Box modules (EPxxxx) in protection class IP65 can also be connected to the EK9xxx.
Bus Couplers for various fieldbus systems
The variants from the EKxxxx series differ from one another by the interface for the higher-level fieldbus system.
An overview of the various Beckhoff Bus Couplers covering the most important fieldbus systems can be found on the Beckhoff Website.
Embedded PCs with fieldbus interface and decentralized control
The TwinCAT-programmable variant is the CX80xx Embedded PC series.
The variants from the CX80xx series differ from one another by the interface for the higher-level fieldbus system and the possibility to program it.
An overview of the various Beckhoff Embedded PCs covering the most important fieldbus systems can be found on the Beckhoff Website.


Technical data

Product overview [image] Technical data
Technical data
Technical data | EK9300
Protocol | PROFINET
Interfaces | 2 x Ethernet 100 Mbit/s, 1 x USB device (behind the front flap)
Bus interface | 2 x RJ 45 (switched)
I/O connection | E-Bus (EtherCAT terminals)
Web-based Management | from firmware version 8
I/O terminals | E-bus (EL, ES, EP)
Power supply | 24 VDC (-15%/+20%)
Input current | 120 mA typ. + (total E-bus current)/4
Power contacts | 24 VDC max./10 A max.
Power supply I/O terminals | 2 A
Max. power loss | 3 W
Electrical isolation | 500 V (power contact/supply voltage/Ethernet)
Max. size of process data | max. 1440 bytes In- and Output data
Dimensions (W x H x L) | 64 mm x 100 mm x 73 mm
Operating/storage temperature horizontal mounting position | -25°C … +60°C/-40°C … +85°C
Operating/storage temperature other mounting position | 0…+55 °C/-25…+85 °C
Relative humidity | 95 % no condensation
Vibration/shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protect. class / installation pos. | IP20/any
Approvals | CE cULus ATEX IECEx
System data | PROFINET (EK9300)
Number of I/O modules | depending on controller
Number of I/O points | depending on controller
Transmission medium | 4 x 2 twisted pair copper cable category 5 (100 Mbit/s)
Cable length | 100 m
Data transfer rate | 100 Mbit/s
Topology | Star-form cabling, line topology


Technical data PROFINET

Product overview [image] Technical data PROFINET
Technical data PROFINET
Technical data Ethernet | EK9300
Number of ports | 2
integrated switch | 2 x Ethernet 100 Mbit/s, 1 x USB device (behind the front flap)
Bus interface | 2 x RJ 45 (switched)
100 Mbit/s | Yes, full-duplex PROFINET
Autocrossing | Yes
Protocol |
PROFINET IO DEVICE | Yes
ADS Interface | Yes
Services |
IRT | no
TCP/IP ADS | Yes
Shared Device | Yes
Prioritized startup | no
MRP | Yes
SNMP | Yes
LLDP | Yes
ARP | Yes
LLDP | Yes
DHCP | Yes
Diagnosis/Status/Alarm |
RUN LED | Yes, green/red
PN LED | Yes, green/red
DIAG LED | Yes, green/red
Connection display LINK TX/RX | Yes
Alarms | Yes
Diagnostic messages | Yes


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Mounting
•
Wiring


Mounting

Mounting and wiring [image] Mounting
Mounting
Additional information
•
Instructions for ESD protection
•
Dimensions
•
Installation on mounting rails – Bus Coupler


Instructions for ESD protection

Mounting and wiring [image] Mounting [image] Instructions for ESD protection
Instructions for ESD protection
Note
Destruction of the devices by electrostatic discharge possible!
The devices contain components at risk from electrostatic discharge caused by improper handling.
•
Please ensure you are electrostatically discharged and avoid touching the contacts of the device directly.
•
Avoid contact with highly insulating materials (synthetic fibers, plastic film etc.).
•
Surroundings (working place, packaging and personnel) should by grounded probably, when handling with the devices.
•
Each assembly must be terminated at the right hand end with an EL9011 or EL9012 bus end cap, to ensure the protection class and ESD protection.
Spring contacts of the Beckhoff I/O components


Dimensions

Mounting and wiring [image] Mounting [image] Dimensions
Dimensions
The following illustrations show the dimensions of the Bus Couplers.
Drawings in DWF and STEP format can be found in the Download section of the Beckhoff website.
EK9xxx – dimensions taking the EK9300 as an example


Installation on mounting rails – Bus Coupler

Mounting and wiring [image] Mounting [image] Installation on mounting rails – Bus Coupler
Installation on mounting rails – Bus Coupler
Snapping onto the mounting rail
The Bus Coupler can simply be snapped onto the mounting rail. To this end position the block on the mounting rail and push it slightly until it engages on the right-hand side. This is indicated by a distinct click. Use a screwdriver to push up the lock on the left-hand side, thereby turning it and causing it to engage audibly.
EK9300 - Snapping onto the mounting rail
Note
Avoid damage!
Do not force the module or apply excessive pressure!
Installation positions
The installation position of the Bus Coupler is arbitrary.
Note
Installation position of EtherCAT terminals
Observe the installation position of the EtherCAT terminals used – not all of them have an arbitrary installation position. Pay attention to the respective EtherCAT infrastructure components and installation instructions.
Recommended distances for standard installation position
Note
Comply with the permitted installation position and minimum distances!
We recommend the installation in the horizontal position for optimum ventilation. Furthermore, it is not necessary with this installation position to check whether there are terminals present that may only be installed horizontally.
Other installation positions are allowed, but not recommended.
Other installation positions


Wiring

Mounting and wiring [image] Wiring
Wiring
Additional information
•
Power supply
•
Ethernet
•
ATEX - Special conditions (standard temperature range)
•
ATEX - Special conditions (extended temperature range)
•
ATEX Documentation
•
UL notice


Power supply

Mounting and wiring [image] Wiring [image] Power supply
Power supply
The power supply unit is equipped with an I/O interface, which permits connection of the Beckhoff Bus Terminals. The power is supplied via the upper spring-loaded terminals with the designations "24 V and "0 V".
The supply voltage supplies the EK system and, via the terminal bus, the Bus Terminals with a voltage of 24 VDC (-15%/+20 %). The dielectric strength of the power supply is 500 V. Since the terminal bus (E-bus) only transfers data, a separate power supply is required for the Bus Terminals. This is provided by means of the power contacts, which are not connected to the power supply.
Bus Coupler EK9xxx power supply
Requirements for the 24 V power supply
In order to guarantee the operation of the Bus Coupler and the terminal segment in all cases, the power supply unit must supply 2.0 A at 24 V.
LED
If the power supply unit is connected correctly and the power supply is switched on, the two upper LEDs in the terminal prism are green. The left LED (Us) indicates the CPU supply. The right LED (Up) indicates the terminal supply. The other LEDs indicate the Terminal Bus status. A detailed description of the LEDs can be found in section "LED troubleshooting".
PE power contacts
Note
Power contact “PE”
The "PE" power contact must not be used for other potentials.


Ethernet

Mounting and wiring [image] Wiring [image] Ethernet
Ethernet
Additional information
•
Ethernet connections
•
Ethernet cable
•
EK9300 PROFINET topology sample


Ethernet connections

Mounting and wiring [image] Wiring [image] Ethernet [image] Ethernet connections
Ethernet connections
RJ45 interface
Assignment of the RJ45 interface, port (switched)
EK9xxx: X001 / X002
PIN | Signal | Description
1 | TD + | Transmit +
2 | TD - | Transmit -
3 | RD + | Receive +
4 | connected | reserved
5
6 | RD - | Receive -
7 | connected | reserved
8


Ethernet cable

Mounting and wiring [image] Wiring [image] Ethernet [image] Ethernet cable
Ethernet cable
Transmission standards
10Base5
The transmission medium for 10Base5 consists of a thick coaxial cable ("yellow cable") with a max. transmission speed of 10 Mbit/s arranged in a line topology with branches (drops) each of which is connected to one network device. Because all the devices are in this case connected to a common transmission medium, it is inevitable that collisions occur often in 10Base5.
10Base2
10Base2 (Cheaper net) is a further development of 10Base5, and has the advantage that the coaxial cable is cheaper and, being more flexible, is easier to lay. It is possible for several devices to be connected to one 10Base2 cable. It is frequent for branches from a 10Base5 backbone to be implemented in 10Base2.
10BaseT
Describes a twisted pair cable for 10 Mbit/s. The network here is constructed as a star. It is no longer the case that every device is attached to the same medium. This means that a broken cable no longer results in failure of the entire network. The use of switches as star couplers enables collisions to be reduced. Using full-duplex connections they can even be entirely avoided.
100BaseT
Twisted pair cable for 100 Mbit/s. It is necessary to use a higher cable quality and to employ appropriate hubs or switches in order to achieve the higher data rate.
10BaseF
The 10BaseF standard describes several optical fiber versions.
Short description of the 10BaseT and 100BaseT cable types
Twisted-pair copper cable for star topologies, where the distance between two devices may not exceed 100 meters.
UTP
Unshielded twisted pair
This type of cable belongs to category 3, and is not recommended for use in an industrial environment.
S/UTP
Screened/unshielded twisted pair (screened with copper braid)
Has an overall shield of copper braid to reduce influence of external interference. This cable is recommended for use with Bus Couplers.
FTP
Foiled shielded twisted pair (screened with aluminum foil)
This cable has an overall shield of laminated aluminum and plastic foil.
S/FTP
Screened/foiled-shielded twisted pair (screened with copper braid and aluminum foil)
Has a laminated aluminum screen with a copper braid on top. Such cables can provide up to 70 dB reduction in interference power.
STP
Shielded twisted pair
Describes a cable with an outer screen, without defining the nature of the screen any more closely.
S/STP
Screened/shielded twisted pair (wires are individually screened)
This identification refers to a cable with a shield for each of the two wires as well as an overall shield.
ITP
Industrial Twisted-Pair
The structure is similar to that of S/STP, but, in contrast to S/STP, it has only one pair of conductors.


EK9300 PROFINET topology sample

Mounting and wiring [image] Wiring [image] Ethernet [image] EK9300 PROFINET topology sample
EK9300 PROFINET topology sample
EK9300
The construction of the EK9300 can take place in a line, with adherence to the following points:
- Maximum 20 couplers one behind the other
- No switches should be used in the line
EK9300 - Topology sample
Use of switches without LLDP
PROFINET uses the LLDP protocol for the topology recognition. The topology recognition and the associated PROFINET services will not work properly if the switch that you use does not support this. In addition, this results in increased network traffic, which is multiplied further with each switch port and connected PROFINET device. The effects of this can be communication errors extending up to the aborting of communication with individual PROFINET devices.


ATEX - Special conditions (standard temperature range)

Mounting and wiring [image] Wiring [image] ATEX - Special conditions (standard temperature range)
ATEX - Special conditions (standard temperature range)
SmallWarningYellow WARNING
Observe the special conditions for the intended use of Beckhoff fieldbus components with standard temperature range in potentially explosive areas (directive 2014/34/EU)!
•
The certified components are to be installed in a suitable housing that guarantees a protection class of at least IP54 in accordance with EN 60079-15! The environmental conditions during use are thereby to be taken into account!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of 0 to 55°C for the use of Beckhoff fieldbus components standard temperature range in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The individual terminals may only be unplugged or removed from the Bus Terminal system if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The fuses of the KL92xx/EL92xx power feed terminals may only be exchanged if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
Address selectors and ID switches may only be adjusted if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Marking
The Beckhoff fieldbus components with standard temperature range certified according to the ATEX directive for potentially explosive areas bear one of the following markings:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … +55°C
or
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … +55°C


ATEX - Special conditions (extended temperature range)

Mounting and wiring [image] Wiring [image] ATEX - Special conditions (extended temperature range)
ATEX - Special conditions (extended temperature range)
SmallWarningYellow WARNING
Observe the special conditions for the intended use of Beckhoff fieldbus components with extended temperature range (ET) in potentially explosive areas (directive 2014/34/EU)!
•
The certified components are to be installed in a suitable housing that guarantees a protection class of at least IP54 in accordance with EN 60079-15! The environmental conditions during use are thereby to be taken into account!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of -25 to 60°C for the use of Beckhoff fieldbus components with extended temperature range (ET) in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The individual terminals may only be unplugged or removed from the Bus Terminal system if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The fuses of the KL92xx/EL92xx power feed terminals may only be exchanged if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
Address selectors and ID switches may only be adjusted if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Marking
The Beckhoff fieldbus components with extended temperature range (ET) certified according to the ATEX directive for potentially explosive areas bear the following marking:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: -25 … +60°C
or
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: -25 … +60°C


ATEX Documentation

Mounting and wiring [image] Wiring [image] ATEX Documentation
ATEX Documentation
Notes about operation of the Beckhoff terminal systems in potentially explosive areas (ATEX)
Pay also attention to the continuative documentation

Notes about operation of the Beckhoff terminal systems in potentially explosive areas (ATEX)

that is available in the download area of the Beckhoff homepage http:\\www.beckhoff.com!


UL notice

Mounting and wiring [image] Wiring [image] UL notice
UL notice
culus-logo
Application
Beckhoff EtherCAT modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
culus-logo
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
culus-logo
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
Basic principles
UL certification according to UL508 with limited power consumption. The current consumed by the device is limited to a max. possible current consumption of 4 A. Devices with this kind of certification are marked by this sign:
Application
If terminals certified with restrictions are used, then the current consumption at 24 VDC must be limited accordingly by means of supply
▪
from an isolated source protected by a fuse of max. 4 A (according to UL248) or
▪
from a voltage supply complying with NEC class 2.
A voltage source complying with NEC class 2 may not be connected in series or parallel with another NEC class 2compliant voltage supply!
These requirements apply to the supply of all EtherCAT bus couplers, power adaptor terminals, Bus Terminals and their power contacts.


Parameterization and commissioning

Parameterization and commissioning
Parameterization and commissioning
Additional information
•
Meaning of the DIP switch
•
Further interfaces
•
Setting the IP address


Meaning of the DIP switch

Parameterization and commissioning [image] Meaning of the DIP switch
Meaning of the DIP switch
10-pole DIP switch S001
The DIP switch has the following meaning for the Ethernet interfaces X001 and X002, which are switched:
DIP switch S001: Left off ”0“, right on “1”
DIP 9
DIP 10
Description
DIP 1..8
Restart behavior
Behavior with factory settings
0
0
Last byte of the IP address via DIP switches 1 to 8
▪
PN name from memory
▪
IP address via DIP switches
172.16.17.xxx (xxx DIP switch)
SNM 255.255.0.0
▪
PN name becomes empty string
▪
IP address via DIP switches
172.16.17.xxx (xxx DIP switch)
SNM 255.255.0.0
0
1
DHCP
DIP switch 1 to 8 set to OFF
▪
PN name from memory
▪
IP address and SNM via DHCP
▪
PN name becomes empty string
▪
IP address and SNM via DHCP
DHCP
DIP switch 1 to 8 set to ON
▪
PN name from memory
▪
IP address from memory
▪
PN name becomes empty string
▪
IP address 0.0.0.0
1
0
Reserved
1
1
PROFINET-compliant
DIP switch 1 to 8 set to OFF
▪
PN name from memory
▪
IP address from memory
▪
PN name becomes empty string
▪
IP address 0.0.0.0
PROFINET with fixed name
DIP switch 1 to 8 set to ON
▪
PN name via
DIP switch 1 to 8
▪
IP address from memory
▪
PN name via
DIP switch 1 to 8
▪
IP address 0.0.0.0
2-pole DIP switch (under the flap between the battery and the SD card slot)
DIP switch (red) | Meaning
1 off and 2 off | normal mode, coupler is started
1 on and 2 off | The EK starts in Config Mode; the internal Flash memory can be accessed via the USB interface (for example for an image update).
1 off and 2 on | Manufacturer's setting
1 on and 2 on | No function so far


Further interfaces

Parameterization and commissioning [image] Further interfaces
Further interfaces
Additional interfaces are located under the flap of the EK9xx0.
Additional interfaces of the EK9xx0
Battery
No battery is required for the EK9xx0, therefore this option is not included.
Red DIP switch
Default setting is OFF/OFF.
In order, for example, to load new firmware to the EK via USB, the first DIP switch must be set to “1” before switching on. If the RUN LED lights up blue, the EK can be connected to the PC by a USB cable. The PC then finds the internal Flash as the storage medium. The storage medium may not be formatted!
Micro SD card
Alternatively the firmware can also be loaded to an SD card. Booting always takes place from the SD card if there is one in the slot. This can be used, for example, to test a firmware before copying it to the EK’s internal Flash.
USB interface
The USB interface can only be used if the “red” DIP switch has been set accordingly. See “Red DIP switch”.


Setting the IP address

Parameterization and commissioning [image] Setting the IP address
Setting the IP address
Usually the IP address is assigned by the PROFINET controller. By default the EK9300 has no IP address. An IP address is necessary, however, in order to reach the device by ADS. This can be assigned by DHCP (a DHCP server must be present) or a fixed IP address can be used. See chapter DIP switch.
If the PROFINET controller is connected, the IP address assigned by the controller is used for PROFINET communication. The fixed IP address or the one assigned by the DHCP is overwritten.
A further possibility is to communicate with the EK9300 via the IP address assigned by the controller; to do this, however, the device must have been initialized at least once by the PROFINET controller/engineering.


Configuration

Configuration
Configuration
Additional information
•
Representation of an EtherCAT slave on PROFINET
•
EK9300 configuration
•
EK9300 EtherCAT configuration
•
EK9300 – Configuration example
•
From firmware Version 6
•
From firmware version 8


Representation of an EtherCAT slave on PROFINET

Configuration [image] Representation of an EtherCAT slave on PROFINET
Representation of an EtherCAT slave on PROFINET
This section is intended to help explain the description of EtherCAT devices on another fieldbus system and to obtain the corresponding information from the existing EtherCAT documentation. In the following terms are explained for a better understanding.
• Introduction
EtherCAT devices such as EL terminals (ES, ELX, ELM), EP modules (ER, EQ, EPP) are EtherCAT slave devices that always consist of process data and, if necessary, parameter data. As a rule, digital EtherCAT devices have no configuration data. Complex EtherCAT devices usually always.
• Process data (PDO, process data object)
Almost all EtherCAT devices have process data1) that can be from 2 bits and up to several 100 bytes in size. With complex EtherCAT devices, different structures and process data sizes can also be specified. These are so-called Predefined PDOs.
The Predefined PDOs must be specified by the EtherCAT (EC) Master and must be known or set here when the EC Master is started. There is always a Default Predefined PDO. Depending on the higher-level bus system used, the PDO mapping can be set on the EC coupler via the higher-level fieldbus system (as with PROFINET or PROFIBUS) or a configuration page (http protocol, as with ModbusTCP or EtherNet/IP).
1) Except for e.g. the EK1100 coupler, which has neither process data nor configuration data, it is equipped with an EtherCAT ASIC and is therefore also visible in the EtherCAT network without process data.
Parameter data (COE)
The parameter data of an EC slave are transmitted via COE (CAN over EtherCAT). As with CAN, these are divided into objects, subobjects and data. Parameter data, for example, is data that sets the resistance value for an EL3202 terminal, i.e. a temperature resistance terminal, such as PT100, PT1000, NI100, etc.
Only the application-specific COE data is made available for the EK coupler. Depending on the superimposed bus system, all or only some COE objects can be accessed here.
Here, too, parameterization can take place via a website (http protocol) in the EC.
PROFINET
PROFINET device devices (slaves) must bring a GSDML file with them. The devices are described in this GSDML (Download: Configuration file). The EK9300 is a modular device. This modular device consists of the head-end station (the EK9300) and a number of EtherCAT devices that are connected to the EK9300. This file (GSDML) must then be integrated in the PROFINET controller. Once this has been done, the coupler and the EtherCAT Terminals can now be integrated and the corresponding settings made.
Predefined PDOs usually consist of different PDOs and are a compilation of different PDOs of the process image.
This is illustrated below with the TwinCAT automation software:
Typical configuration page of an EtherCAT Terminal
Legend:
1.
The EtherCAT Terminal is inserted in the TwinCAT tree and has process data that can be linked to the PLC program.
2.
View of the existing process data in bytes (exactly this number and size can be seen with PROFINET and the Siemens controller, Siemens does not display the process data in more detail although they are described in the GSDML)
3.
Display which PDOs are active in the process data
4.
View of all PDOs
5.
Detailed single PDOs which can be selected in "4”
6.
Predefined PDOs
In the GSDML, only the predefined PDOs can be selected (6). If a different combination of PDOs is required, this can only be done via a Beckhoff controller, such as the CX8093, which has a default PROFINET interface and can be programmed with TwinCAT 2 (TwinCAT 3 requires a CX9020 with B930 interface, or any Beckhoff controller with an EL6631-0010).
Example Mapping of an EL3162 in standard format ( 8 Byte IN / 0 Byte OUT)
Name | Size (Variable) | Bit offset
AI Standard Channel 1.BitArray
Status_Underrange | BIT (BOOL) | 0.0
Status_Overrande | BIT (BOOL) | 0.1
Status_Limit_1[0] | BIT (BOOL) | 0.2
Status_Limit_1[0] | BIT (BOOL) | 0.3
Status_Limit_1[0] | BIT (BOOL) | 0.4
Status_Limit_1[0] | BIT (BOOL) | 0.5
Status_Error | BIT (BOOL) | 0.6
Status_Sync error | BIT (BOOL) | 1.5
Status_TxPDO State | BIT (BOOL) | 1.6
Status_TxPDO Toggle | BIT (BOOL) | 1.7
AI Standard Channel 1.Value | 16 BIT (INT) | 2.0..3.7
AI Standard Channel 2.BitArray
Status_Underrange | BIT (BOOL) | 4.0
Status_Overrande | BIT (BOOL) | 4.1
Status_Limit_1[0] | BIT (BOOL) | 4.2
Status_Limit_1[0] | BIT (BOOL) | 4.3
Status_Limit_1[0] | BIT (BOOL) | 4.4
Status_Limit_1[0] | BIT (BOOL) | 4.5
Status_Error | BIT (BOOL) | 4.6
Status_Sync error | BIT (BOOL) | 5.5
Status_TxPDO State | BIT (BOOL) | 5.6
Status_TxPDO Toggle | BIT (BOOL) | 5.7
AI Standard Channel 2.Value | 16 BIT (INT) | 6.0..7.7
Parameter data
In the following, the parameter or configuration data will be explained. Most of the necessary configuration data is contained in the GSDML; Beckhoff uses the same names and meanings here as on the EtherCAT side, which is contained in the ESI file2) in the CoE description.
EtherCAT: Parameter data of the EL3162 of the ESI under TwinCAT
PROFINET: Parameter data of the EL3162 of the GSDML under TwinCAT
2) The ESI file is the description file for EtherCAT masters (ESI EtherCAT slave information).
Parameter data of the EL3162 of the GSDML under TwinCAT
These parameters for the individual terminals can also be found in the configuration tool of your PROFINET controller, regardless of which manufacturer you use here. You can also access individual parameters acyclically via PROFINET and the record data. To do this, the PROFIENT controller must have an interface to the record data. A CoE protocol description and how it can be used via PROFINET is described in the EK9300 manual.


EK9300 configuration

Configuration [image] EK9300 configuration
EK9300 configuration
GSDML file
Only terminals existing in the GSDML file are supported; extensions are possible however. The GSDML supports submodules; ascertain whether your PROFINET master/controller supports these submodules. If this is not the case, some terminals cannot be used!
Alternatively the CX8093 can be used; this generally supports all EtherCAT slaves.
General
The EK9300 PROFINET coupler is always integrated with the help of a GSDML file in the controller (master). The GSDML file contains all parameterization data necessary for the operation of the coupler on the controller. The configuration tool reads this file and then provides the data to the user.
The respective terminals that are usable on the EK9300 are also specified in the GSDML file. Not all EtherCAT terminals are supported. Therefore, ascertain beforehand whether the terminals that you wish to use are also supported by the coupler.
Data in the DAP (Device Access Point)
2 x 2 bytes of data are located in the DAP of the GSDML file.
This is once the ECCycleCounter (2 bytes). This is incremented on each EtherCAT cycle (1 ms), provided that the EC master is in the "OP" state.
The status (2 BYTE) is located at the DAP. This indicates individual status information bit by bit. These are currently occupied as follows:
▪
Bit 0 – IsSynchron – this is set if it is used as a PTP slave or IRT device and is synchronous.
▪
Bit 1 – IsPTPMaster – this is set if the EK9300 is operated as the PTP master.
▪
Bit 2 – ECFrameError – this is set if an EtherCAT problem is determined. In order to obtain further information about this, the PROFINET diagnosis or the alarms must be read out.
Parameters in the DAP
Activate PN reset value – Off -> EtherCAT data are written to zero. On -> there is a possibility to use another default value with outputs. With digital outputs, for example, the current output process value can be frozen or set to 0 or 1 in case of a PROFINET communication error.
Data presentation – Intel Format data are represented in Intel format, Motorola Format data are represented in Motorola format. In Word variables, for example, the high and low bytes are exchanged.
EBus error behavior – Set IOs to 0 -> input and output data are set to zero in case of an EC error. Legacy -> input data retain their last state, but are no longer updated; output data can still be set (depending on the position of the terminal).
Mapping
Typically the coupler is used in a group with terminals that are connected to the coupler. The terminals are part of the GSDML; the terminals are parameterized from the PROFINET controller.
The mapping is card-slot-oriented, i.e. you must enter the terminals in the hardware configurator in exactly the same way as they are physically connected. It becomes a little more complicated if EtherCAT distributor boxes are used. In this case it is important to know the order in which the other EtherCAT terminals were entered into the process image (see EtherCAT Mapping).
Behavior when starting the Bus Coupler
All EtherCAT devices must always be present when starting the Bus Coupler (or resetting), i.e. all EtherCAT slaves must be supplied with power before or at the same time so that the coupler on the PROFINET also starts up properly.
A solution can be constructed more flexibly with the CX8093.
Configuration of the EtherCAT devices
There are 4 types of EtherCAT devices:
▪
EtherCAT devices without process data
▪
EtherCAT devices with “simple” process data but without parameterization (usually simple digital terminals)
▪
EtherCAT devices with “simple” process data and with parameters (usually analog signals)
▪
EtherCAT devices with different process data and parameters (for example incremental encoders)
All of these must be entered in the configuration.
Grouping digital inputs and outputs (pack terminals)
The digital input and output terminals can also be grouped according to their process data. This option can be used with 2 or 4-channel terminals. To do this a 2 or 4-channel pack terminal (without asterisk) must be appended to the GSDML file. In order to fill the byte, a 2 or 4-channel pack terminal (with asterisk) must be appended next. The terminals must be physically and systematically plugged in one behind the other or logically. The byte limit must not be exceeded.
Sample:
2-channel pack (without asterisk), after that 3 modules from 2-channel pack terminals (with asterisk) may be appended.
Not permitted:
2-channel pack (without asterisk), then 2 modules from 4-channel pack terminals (with asterisk). This exceeds the byte limit.
EtherCAT terminals with different mapping options
Some EtherCAT terminals offer the option to represent different process data. These are represented differently on the basis of the parameters. In the PROFINET controller such a terminal is represented by submodules. The standard mapping is always integrated. If you want to use a different mapping that deviates from the standard, then delete the standard submodule and insert the one that you wish to use. It may be the case that, contradictory to the documentation for the EtherCAT terminal or EtherCAT box, not all mappings can be used under the PROFINET coupler.
Example of an EL5101:
Inserting a sub-module
EtherCAT gateway terminals
The gateway terminals support several submodules; the first or basic module is loaded immediately, the modules for the process data must be created. These must then also be parameterized on the master side of the corresponding gateway. Not all features of a gateway terminal can be used on the EK9300.
EL6631-0010
The PROFINET device terminal enables two different PROFINET networks to be connected; only one device interface is supported on the EK. A default station name can be assigned and IP settings made via parameterization data (GSDML). Note that the complete maximum data length of the EL6631-0010 cannot be used. The length is dependent on the other EtherCAT devices attached to the EK9300.
EL6731-0010
The PROFIBUS slave terminal enables communication with a PROFIBUS master. The PROFIBUS address is specified via the parameter settings (in the GSDML) in the terminal. Only pure process data can be exchanged.
EL6692
The EtherCAT slave terminal enables communication with a EtherCAT master. Only pure process data can be exchanged.
EL6652-0010
The EtherNet/IP slave terminal enables communication with an EtherNet/IP master; only one slave interface is supported on the EK. The IP address and subnet mask are specified via the parameter settings (in the GSDML) of the terminal. Only pure process data can be exchanged. The terminal on the EK supports only one slave interface.


EK9300 EtherCAT configuration

Configuration [image] EK9300 EtherCAT configuration
EK9300 EtherCAT configuration
The EK9300 is an EtherCAT master with automatic configuration, i.e. all EtherCAT terminals must always be present when switching on the system. Since the boot-up of the EK9300 generally takes considerably longer than the start-up of the EtherCAT slave devices, the latter can be operated on the same power supply. With decentralized EtherCAT slaves, care must be taken that they are switched on earlier or at the same time as the supply voltage.
Switching EtherCAT devices on or off during the runtime
If one or more EtherCAT devices should fail during the operating phase, a plug alarm is sent; the EK9300 remains in data exchange. The input data of all EtherCAT devices are invalid and are set to FALSE or ZERO; the output data are no longer accepted. This also applies to the devices that are still in operation on the EK9300. If you wish to use the option to plug in or unplug devices during the runtime, a further “Sync Unit” must be configured. This is not possible with an EK9300. In this case use a CX8093.
EtherCAT devices that don’t exist in the GSDML
Some EtherCAT Slaves are not included in the GSDML and thus cannot be used (yet). The CX8093 can be used here, since it supports all EtherCAT devices in principle.
EtherCAT topology
All EtherCAT devices must be entered in the order in which they map themselves on the EK9300 and thus on the EtherCAT master. EtherCAT devices are addressed automatically; with a few exceptions all EtherCAT Bus Terminals are equipped with an EtherCAT ASIC, which has to be entered in the system, i.e. the PROFINET controller. EtherCAT Terminals without an ASIC are, for example, EL9400, EL9070 and other EL9xxx. You can identify these EtherCAT Terminals using the technical data "Message to E-bus". If there is a “-” here, this terminal does not have to be entered in the PROFINET controller.
EtherCAT devices are registered in the direction of the EtherCAT telegram.
Sample configuration with EK1100 EtherCAT coupler
Sample configuration with EK1100 EtherCAT coupler
Sample configuration with EPxxxx EtherCAT Box
Sample configuration with EPxxxx EtherCAT Box
Sample configuration with EK1122 2-port EtherCAT junction
The counting direction is to be observed when using an EK1122. If EtherCAT junction 1 on the EK1122 is connected, then the EtherCAT frame is forwarded here first (1); if junction 1 is not connected the frame on junction 2 is sent (2), only after that does the sequence continue with the E-bus on the right-hand side (3).
Sample configuration with EK1122 2-port EtherCAT junction
If both junctions are not used, then junction 1 and 2 are short-circuited as it were and the EC frame continues directly from the terminal to the right.
Note that in the PROFINET controller the modules are entered in the direction of the EtherCAT frame.
Sample configuration with EP1122 2-port EtherCAT junction
The counting direction is to be observed when using an EP1122; it is comparable with the EK1122. If EtherCAT junction 1 on the EP1122 is connected, then the EtherCAT frame is forwarded here first (1); if junction 1 is not connected the frame on junction 2 is sent (2), only after that does the sequence continue with the EC-bus on the right-hand side (3).
Sample configuration with EP1122 2-port EtherCAT junction
If both junctions are not used, then junction 1 and 2 are short-circuited as it were and the EC frame continues directly from the terminal to the right.
Note that in the Profinet controller the modules are entered in the direction of the EtherCAT frame.
Connection during operation
You cannot use the EP1122 and EK1122 for Hot Swap or connect or disconnect them during operation. The EP1122 and EK1122 are suitable in conjunction with the EK coupler only as topology extensions (star).


EK9300 – Configuration example

Configuration [image] EK9300 – Configuration example
EK9300 – Configuration example
PDO Mapping
The process data on the EtherCAT side are described via the PDO Mapping. The individual terminals bring along a pre-defined PDO mapping, i.e. a practical combination of individual PDOs, via the ESI file (EtherCAT description file).
EK9300 - Predefined PDO selection dialog
These combinations are described in turn on the Profinet side using different submodules and thus process data; i.e. each pre-defined PDO mapping has an associated submodule.
EK9300 Sub-modules
Such modular terminals always have a fixed submodule plugged into subslot 1 on the EK9300. This is the placeholder for the terminal itself; i.e. the generally valid diagnosis for the terminal is operated via this. The actual process data are plugged into subslot 2 and the PDO mapping on the EC-master is generated on their basis.
SDO Mapping
Each of the plugged-in subslots can bring along parameterization data. The Service Data Objects (SDOs) are transmitted via these data, i.e. the SDOs are mapped to record data sets. The objects 0x8xxx and 0xF8xx are always mapped. Since the indices on the PROFINET side are only vendor-specific from 0 - 0x7FFF, the EtherCAT objects 0x8xxx correspond to the PROFINET record indices 0x3xxx and the EC objects 0xF8xx to the PROFINET index range 0x48xx. In PROFINET the records are always written during the controller start-up phase; they are transferred internally to the EtherCAT master as start-up SDOs. This means that the internal EC master is also restarted during a PROFINET restart.
PROFINET record indices 0x3xxx (corresponds to EtherCAT objects 0x8xxx)
These data records can also be read and written during operation.
Commissioning EL7031
The default settings are adequate for initial commissioning, i.e. only the corresponding submodule needs to be selected. The PDOs and SDOs of the terminal are parameterized on that basis. For example, if the "Velocity Control" submodule is selected, only the Control_Enable bit needs to be set; subsequently turn the motor by specifying a setpoint speed.


From firmware Version 6

Configuration [image] From firmware Version 6
From firmware Version 6
Additional information
•
EK9300 - CoE data access over PROFINET
•
EK9300 - multi-configuration mode
•
EK9300 - IO-LINK


EK9300 - CoE data access over PROFINET

Configuration [image] From firmware Version 6 [image] EK9300 - CoE data access over PROFINET
EK9300 - CoE data access over PROFINET
Description
CoE means Can over EtherCAT. It enables access to all parameters of an EtherCAT device. The CoE data model is based on the principles of CANopen and uses index and subindex for reading from and writing to parameters, if the corresponding access is enabled.
Further information can be found here: System Documentation
Task
Parameters of an EtherCAT device can generally be set and parameterized via the parameters of the GSDML file. However, in some applications it is necessary to change certain parameters at runtime or to carry out optimizations during operation.
Solution
The CoE data are sent via acyclic PROFINET services (PROFINET index 0x200F). The position of the EtherCAT device is specified via the slot number. The CoE data are then entered in the record data. During reading they consist of CoE index and CoE subindex, during writing they consist of CoE index, CoE subindex and the data to be sent.
Reading/writing sample
For reading, a WriteReq record must be sent first. This includes the CoE index and CoE subindex. After the WriteRsp a ReadReq has to be sent in order to retrieve the data, which are then contained in the ReadRsp.
Writing takes place in the same way, except that WriteReq includes the data, and ReadRsp serves as acknowledgement to indicate whether writing was successful.
CoE data access over PROFINET, read/write sample
Getting Started - Reading
PROFINET record data (write request) | Value | Meaning
Slot | Position of the EtherCAT device (1...255) | Slot number, position of the EtherCAT device
SubSlot | 1 | Sub-slot number, always "1"
Index | 0x200F | PROFINET index number
Length | 4 | Length of the following data
Data | Bytes 1 and 2 SDO index Byte 3 CoE subindex Byte 4 "0" reserve | CoE data
Delay time, we recommend 100..250 ms until the read request is sent, which includes an acknowledgment of error-free writing.
PROFINET record data (read request) | Value |  | Meaning
Slot | Position of the EtherCAT device (1...255) |  | Slot number, position of the EtherCAT device
SubSlot | 1 |  | Sub-slot number, always "1"
Index | 0x200F |  | PROFINET index number
Length | Write 4 | Answer 4 bytes + x bytes | Length of the following data
Data | Write Byte 1 "1" Byte 2 "0" Byte 3 "0" Byte 4 "0" | Answer Bytes 1..4 ADS error Bytes 4..x CoE data value | CoE data
The response to the read request, i.e. the read response, includes the data. The first 4 bytes contain the error code. This is "0" if the response is error-free. The error code is an ADS error code. Further information can be found under the following link.
http://infosys.beckhoff.com/content/1031/tcsample/html/ads_returncodes.htm
Wireshark sample for reading ( )
Getting Started - Writing
PROFINET record data (write request) | Value | Meaning
Slot | Position of the EtherCAT device (1...255) | Slot number, position of the EtherCAT device
SubSlot | 1 | Sub-slot number, always "1"
Index | 0x200F | PROFINET index number
Length | 4 | Length of the following data
Data | Bytes 1..2 SDO index Byte 3 SDO subindex Byte 4 "1" constant Bytes 5..8 length as DWORD Bytes 9..x CoE data value | CoE data
Delay time, we recommend 250..500 ms until the read request is sent, which includes an acknowledgment of error-free writing.
PROFINET record data (read request) | Value |  | Meaning
Slot | Position of the EtherCAT device (1...255) |  | Slot number, position of the EtherCAT device
SubSlot | 1 |  | Sub-slot number, always "1"
Index | 0x200F |  | PROFINET index number
Length | Write 0 | Answer 4 | Length of the following data
Data | Write - | Write ADS error code | CoE data
The response to the read request, i.e. the read response, includes confirmation that writing was successful. The first 4 bytes contain the error code; "0" indicates error-free response. The error code is an ADS error code. Further information can be found under the following link.
System docu
Wireshark sample for writing ( )
Observe data format
During reading and writing, observe the data size and the format of the corresponding SDO parameters. We recommend reading the SDO data first, then interpret them and use the read data format also for writing the CoE data (perhaps swap High/Low BYTE/WORD).
Start-up parameters overwrite CoE data
CoE data are typically not stored in the EtherCAT device. Ensure that start-up parameters (GSDML) overwrite the CoE data during startup of the EK9300.


EK9300 - multi-configuration mode

Configuration [image] From firmware Version 6 [image] EK9300 - multi-configuration mode
EK9300 - multi-configuration mode
Description
Multi-configuration mode enables users to operate different hardware, e.g. a EK9300 with varying EtherCAT Terminals, with the same project configuration.
This description uses EtherCAT Terminals (ELxxxx) in the examples. The same principle applies to EtherCAT Box modules (EPxxxx).
Task
The machine manufacturer has a machine, which is to be sold with different options. The options are usually additional signals to be processed and logged, for which additional terminals are required.
For all these options the project configuration should be retained and only be varied via the software. The actual machine options are included in the parameterization.
Solution
The multi-configuration mode is used to configure the maximum number of options in the project configuration. If the machine has less than the maximum number of options, EtherCAT Terminals can be omitted, since these signals are not required. Although unused EtherCAT Terminals are included in the maximum project configuration, they can be disabled by the controller, so that the hardware and the parameterized configuration match again. As soon as this is done, the EK9300 switches to normal data exchange.
Advantage
Less effort for creating and maintaining projects, since the same project configuration can be used for different hardware.
Sample
The standard machine configuration, without options, consists of:
▪
1 x EK9300
▪
2 x EL2004
▪
2 x EL1004
▪
1 x EL5051
The following options can be added:
▪
With energy monitoring for logging the energy consumption: additionally an EL3403
▪
With automatic adjustable axis: additionally an EL7047
▪
With temperature measurement: additionally an EL3314
The maximum configuration (with optional terminals shown in italics) then looks as follows:
▪
1 x EK9300
▪
2 x EL2004
▪
2 x EL1004
▪
1 x EL5051
▪
1 x EL3314
▪
1 x EL7047
▪
1 x EL3403
It is this maximum configuration that is reflected in the hardware configuration.
If the machine is ordered without options, the terminals EL3314, EL7047 and EL3403 have to be disabled in the project configuration. The EK9300 is notified of the record data (acyclic communication) to indicate which terminals are no longer required. The terminals are identified via their position.
Without options, two KL2004 are present (at position 1 and 2), two EL1004 (at position 3 and 4) and one EL5051 (at position 5). The terminals at positions 6, 7 and 8 (optional terminals) must be disabled.
If the machine is ordered with the option "automatic adjustable axis", only terminals 6 and 8 have to be disabled.
Position of optional terminals
Optional terminals can be connected at any position and may be disabled. They do not necessarily have to be located at the end, as shown in the example.
First steps
In order to enable the EK9300 to operate in multi-configuration mode, MultiConfigurationMode must be set to "TRUE" in the DAP (device access point).
There are two possible setting options.
Option 1
This is perhaps a version for testing, since the hardware configuration must be adjusted, which should preferably be avoided.
In the DAP there is a MultiConfigurationMode setting with the slots. Here you can disable EtherCAT Terminals, which are configured but not present.
For some PROFINET controllers this must happen on startup, while other PROFINET controllers enable it to occur at runtime, which simplifies testing significantly. Disabling/enabling of terminals at runtime is a feature of the PROFINET controller and may or may not be possible in practice, depending on the manufacturer of the PROFINET controller.
Option 2
The configuration is sent by the PLC via the record data. Here too, the manufacturers offer different options. Contact the manufacturer of your PROFINET controller, if you have any queries.
A requirement for option 2 is that your PROFINET controller allows and supports access to the record data.
PROFINET record data (write request) | Value | Meaning
Slot* | 0 | Slot number, always "0"
SubSlot* | 1 | Sub-slot number, always "1"
Index | 0#2010 | PROFINET index number
Length | variable | Length of the following data
Data | Each Bus Terminal requires 2 bits: 00bin terminal present 10bin terminal not present | Enabling/disabling of the EtherCAT devices
* For some PROFINET controllers these data are automatically taken from the GSDML and do not have to be configured.
Procedure
Once the station has been configured, the following steps are required.
If the machine is ordered with the maximum configuration (with all options), generally no action is required, since the hardware matches the project configuration.
If one of the options is not included, then hardware and project planning differ. The PROFINET coupler indicates this via the message "Module difference".
Now disable the terminals, which are not present. When this is done, the message "Module Difference" is removed from the coupler. If the message "Module Difference" remains, you may have the wrong slot or too few slots disabled.
No subslots
Subslots are not counted and cannot be used for the multi-configuration mode.
Only slots can be used, irrespective of a module using subslots or not.
No Shared Device
The Shared Device feature cannot be used when the multi-configuration mode is used.
No pack or (*) terminals
Pack or (*) terminals cannot be used in multi-configuration mode.


EK9300 - IO-LINK

Configuration [image] From firmware Version 6 [image] EK9300 - IO-LINK
EK9300 - IO-LINK
Description
The EK9300 (from firmware 6) supports the IO-Link master EL6224 (EtherCAT Terminal) and EP6224 (EtherCAT Box). The GSDML file (from version GSDML-V2.32-beckhoff-EK9300-20160408.xml) includes this IO-Link master. Each IO-Link device is addressed as a submodule and must be configured via the GSDML file.
Task
Connection of an IO-Link sensor to an EK9300.
Configuration of the process data
Each IO-Link device is added as a submodule. For each IO-Link device a submodule is used. The process data size of the submodule must always be equal to or greater than that of the IO-Link device and must not be less.
If not all IO-Link channels are used, empty channels should be entered. For example, if sensors are only connected to inputs 2 and 4 of the IO-Link master, while inputs 1 and 3 are unused, first enter an empty channel as submodule, then the sensor at input 2, then another empty channel and finally the sensor at input 4. The first submodule used by the IO-Link master is a diagnostics module. This is always present when the EL6224/EP6224 is added. This submodule contains the status of all connected IO-Link devices. If the sensor is in IO-Link data exchange, this is indicated via the corresponding byte (0x03 means all OK).
Information on the status byte:
0x_0 = Port disabled
0x_1 = Port in std dig in
0x_2 = Port in std dig out
0x_3 = Port in communication OP
0x_4 = Port in communication COMSTOP / dig in Bit (only in std. IO Mode)
0x_8 = Process Data Invalid Bit
0x1_ = Watchdog detected
0x2_ = internal Error
0x3_ = invalid Device ID
0x4_ = invalid Vendor ID
0x5_ = invalid IO-Link Version
0x6_ = invalid Frame Capability
0x7_ = invalid Cycle Time
0x8_ = invalid PD in length
0x9_ = invalid PD out length
0xA_ = no Device detected
0xB_ = error PreOP/Data storage
Regarding the process data size of an IO-Link device, please refer to the documentation or consult the manufacturer.
Inserting a "generic channel" (in the case of IO-Link devices from other manufacturers)
IO-Link devices from Beckhoff are automatically added with the required parameters. For devices from other manufacturers please use a generic channel and select the process data size.
Configuration of the IO-Link device
The minimum settings required for operating an IO-Link device are:
IO-Link version: Generally 1.1; enter 11
Frame capability: Generally 1
Min. cycle time: Generally 2.3 ms, i.e. 23
Process data in / Out length: Variable (number in bits), for a size of 2 bytes input enter 16 for "Process data in length".
Master control: set to IO-Link
All other settings are optional.
Configuration of the IO-Link device
Reading/writing of parameters
Each IO-Link device has parameters, which can be read or written. The EK9300 does not support this function. I.e. no parameters can be read or written. The communication of the EK9300 with the IO-Link device is limited to the process data.
To access parameters of the IO-Link devices, use a Beckhoff controller (e.g. CX8093). Here you can read the IODD file (IO-Link device description) and read or write the sensor data via the PLC.


From firmware version 8

Configuration [image] From firmware version 8
From firmware version 8
In order to be able to use the updated firmware version 8, you have to use the corresponding GSDM device description, from version GSDML-V2.32-beckhoff-EK9300-20170216.XML.
Add the corresponding GSDML DAP for the firmware (FW8.0).
Adding the GSDML DAP for firmware FW8.0
Additional information
•
EBus Error Behaviour
•
Activating the web page


EBus Error Behaviour

Configuration [image] From firmware version 8 [image] EBus Error Behaviour
EBus Error Behaviour
The parameter EBus error behavior is new in firmware version 8.
The parameter EBus error behavior
This parameter is used to set the response to an E-bus error. The following options are available:
Legacy | Output data is still written, input data is frozen and therefore no longer current.
Set IOs to 0 | Output data is written to zero; input data is written to zero; when the E-bus is error-free, it automatically starts the data exchange.
Set IOs to 0 without EBus restart (Default setting) | Output data is written to zero; input data is written to zero; when the E-bus is error-free, it can be activated again via the record data (see below).
Activating the E-bus after an E-bus error
In the DAP, information about the E-bus is provided via the status DWord. When an error occurs in the E-bus, the bit EcFrameError is set (in the high word bit offset x.2). Once the error has been rectified and the coupler is ready to restart the E-bus, the bit EcFrameError is reset and the flag NeedEBusRese is set in the high word bit offset x.4.
Flag NeedEBusReset
The reset is issued via record data and is structured as follows.
PROFINET record data (write request) | Value | Meaning
Slot | 0 | Slot number
SubSlot | 1 | Sub slot number
Index | 0x2013 | Index Reset
Lenght | 2 | Data length
Data | 0x1234 | Value
Once the reset has been issued, the bit NeedEBusReset is reset.


Activating the web page

Configuration [image] From firmware version 8 [image] Activating the web page
Activating the web page
The web page can be activated via the parameter data of the DAP. Set the parameter Web server to active and connect the EK9300 to your PROFINET controller. Once the connection has been established and the IP address has been received, the web page of the EK9300 can be accessed.
Setting the parameter Web server to active
We recommend to use this web page only for diagnostic purposes and to avoid implementing settings there, since this should generally be done through the PROFINET controller.
The web page can be reached by calling the IP address of the EK9300 with the parameter Config
Example: 192.168.1.10 /Config
User name: guest
Password: 1
In order to access the web page, the following requirements must be met:
▪
The web page must have been activated via the parameter data of the EK9300.
▪
The PROFINET controller must have been in data exchange with the EK9300 at least once, so that the parameters and the IP address on the EK9300 are set.
The coupler must not be de-energized afterwards, otherwise settings/parameters are not accepted and events in the logger of the WebServer are lost.
▪
The PC with the web browser must be in the same IP segment as the EK9300. Use the PING command from the PC to check whether the PC can reach the EK9300. If this is the case, you can call up the web page of the EK9300.
If the PING command fails, check the following:
- Was the web page enabled?
- Was the communication between the PROFINET controller and the EK9300 successful?
- Is the IP address of the PC correct?
Browser recommendation
We recommend Chrome or Firefox for displaying the web page.


Ethernet

Ethernet
Ethernet
Additional information
•
PROFINET system presentation


PROFINET system presentation

Ethernet [image] PROFINET system presentation
PROFINET system presentation
PROFINET is the open Industrial Ethernet-standard of the PNO (PROFIBUS User Organization). PROFINET IO describes the exchange of data between controllers and field devices in several real-time classes: RT (software-based real-time) and IRT (hardware-supported isochronous real-time). In addition, further Ethernet traffic can be transmitted in the NRT (non-real-time) time slot of the PROFINET cycle. RT can be networked with commercially available switches; switches with corresponding hardware support are required for IRT.
PROFINET system overview
Components | Comment
Embedded PCs
CX8093 | Embedded PC with PROFINET RT Device fieldbus interface
CX50xx-M930 | Embedded PC with optional interface PROFINET RT Controller
CX50xx-B930 | Embedded PC with optional PROFINET RT Device interface
EtherCAT Terminals
EL6631 | PROFINET IO controller
EL6631-0010 | PROFINET IO device
EL6632 | PROFINET-IRT controller
Bus Coupler
BK9053 | PROFINET "Compact" Bus Coupler for Bus Terminals
BK9103 | PROFINET Bus Coupler for Bus Terminals
EK9300 | PROFINET Bus Coupler for EtherCAT Terminals
EtherCAT Box
EP9300 | PROFINET Coupler Box for EtherCAT Box Modules
Fieldbus Box
IL230x-B903 | PROFINET Coupler Box for IP-Link Box Modules
PC Fieldbus cards
FC900x | PCI-Ethernet card for all Ethernet (IEEE 802.3)-based protocols
FC9x51 | Mini PCI-Ethernet card for all Ethernet (IEEE 802.3)-based protocols
TwinCAT
TwinCAT PROFINET IO Controller | TwinCAT as PROFINET master
TwinCAT PROFINET IO Device | TwinCAT as PROFINET slave


Error handling and diagnosis

Error handling and diagnosis
Error handling and diagnosis
Additional information
•
Diagnostic LEDs


Diagnostic LEDs

Error handling and diagnosis [image] Diagnostic LEDs
Diagnostic LEDs
EK9300 LEDs
Ethernet interface X001
Interface X001/X002 | Ethernet (CX8090) | Meaning
LED green | on | Link available/activity
LED yellow | is not used | -
LED coupler
Labelling | Meaning | Color | Meaning
RUN | Indicates the status of the coupler | red | May only light up during the start-up phase
 |  | Green | Coupler is ready
 |  | Blue (If red DIP switch 1 is set to on when starting the coupler) | The internal Flash can be reached via USB (firmware update)
LED PN | PROFINET status |  | Meaning
 | green | red
Power On | off | 200 ms flashing | Start-up phase
No name | 200 ms flashing | off | no Profinet name
No IP | 1 s off, 200 ms on | off | No IP address
Run | on | off | OK
LED DIAG | PROFINET diagnosis |  | Meaning
 | green | red
Flashing, PN controller identification | 500 ms | 500 ms | The PN controller is transmitting an identification signal
No AR established | off | 200 ms flashing | The establishment of a connection with the controller has not been completed
Device is in IO exchange Error display of Outputs CR is set to module differences | 1 s off, 200 ms on | off | Problem with establishment of a connection or nominal and actual configuration differ
Device is in IO exchange but provider is in stop | 200 ms | off | Coupler is in data exchange, but PLC is in stop
Device is in IO exchange | on | off | OK
LED power supply terminal
LED power supply terminal
Operation with E-bus terminals
Display LED | Description | Meaning
1 Us 24 V (top left, 1st row) | CX8000 supply voltage | on: connected to: 24 V
2 Up 24 V (top right, 1st row) | Power contacts supply voltage | on: connected to: 24 V
3 L/A (left center, 2nd row) | EtherCAT LED | flashing green: EtherCAT communication active on: E-bus connected / no data traffic off: E-bus not connected


Appendix

Appendix
Appendix
Additional information
•
Update Bus Coupler image
•
EK9300 – FAQ
•
List of Abbreviations
•
Support and Service


Update Bus Coupler image

Appendix [image] Update Bus Coupler image
Update Bus Coupler image
Loss of data
The data in the internal flash memory are deleted.
Save your data before you update the Bus Coupler image.
The Bus Coupler image can be updated via the USB interface. To this end the Bus Coupler is connected with a host PC via a USB cable. Windows then shows the Bus Coupler as a removable data storage device, and the files can be copied.
The Bus Coupler should only be updated after consultation with the Beckhoff Service. The Beckhoff Service will provide all the required files.
Requirements
▪
First, check whether the Bus Coupler supports the image.
▪
The Bus Coupler is connected with the host PC via a USB cable.
Update the image as follows:
1.
Switch off the Bus Coupler.
2.
Switch the red 2-pin DIP switch 1 to “on” (to the right) and switch on the Bus Coupler.
The Bus Coupler appears as a removable data storage device on the host PC.
3.
Select and delete all files. Do not format.

4.
Remove the USB cable, once all files have been copied, and switch the 2-pin DIP switch to “off” (to the left).
5.
Restart the Bus Coupler.
⇨
The image has been updated successfully. After the update, the Bus Coupler may take a little longer to start up.


EK9300 – FAQ

Appendix [image] EK9300 – FAQ
EK9300 – FAQ
How can I leave the outputs in the current state in case of a PROFINET error?
For this, two settings need to be made in the GSDML – i.e. in the configurator. First of all, "Activate PN reset value" in the DAP must be set to ON. The value "Frozen" must then be selected in the corresponding digital output terminal. The setting can only be made for a complete terminal; i.e. in the case of an EL2004 all 4 channels are then in the frozen state.
I would like to change the mapping of an EtherCAT terminal. Why doesn’t it offer me this option?
The standard mapping is always appended by default. If other mappings are possible you must first delete the standard mapping from your configurator and then insert the new submodule.
The 2 or 4-channel digital output terminals are to be mapped to one byte. How do I do that?
The GSDML file contains the so-called “PACK” terminals. Without asterisk means that a byte is created, with asterisk that the byte is filled. Pack terminals must always be situated one behind the other (physically) and the byte may not be exceeded.
Where can I get the GSDML file?
The GSDML file can be found at http://www.beckhoff.de/german/download/bkconfg.htm
Where can I find the MAC address of the coupler?
The MAC address is printed on the label on the side of the coupler.
What is the USB interface for and what can I do with it?
The USB interface is to be used at present only for firmware updates.
What is the purpose of the DIP switch behind the flap?
The DIP switch is necessary, for example, for the use of the firmware update (see chapter entitled "DIP switch").
Can I also connect K-bus terminals?
No, only EtherCAT terminals or EtherCAT boxes can be connected. You can use the BK9053 or BK9103 for K-bus terminals. The use of EtherCAT couplers for K-bus such as the BK1120 or BK1250 is not possible.
I have an EtherCAT slave from a third-party vendor, can I also connect it?
No, devices from other vendors can only be used with a CX (see CX8093 or similar products).
I would like to operate the drive terminals/drives on the EK9300. Is that possible?
No, use a CX with a suitable performance for this – CX9020 or higher.
I would like to operate TwinSAFE terminals on the EK9300. Is that possible?
No, the TwinSAFE terminals require a TwinCAT system for configuration; use the CX8093 for this.
How can I tell whether there is an EtherCAT error?
There is a Status word in the DAP of the coupler. A bit is set here if an error occurs in EtherCAT (see Data in the DAP). Further information about the error can be obtained through the PROFINET alarms.


List of Abbreviations

Appendix [image] List of Abbreviations
List of Abbreviations
ADS
Automation Device Specification (disclosed protocol for the communication of all BECKHOFF controllers)
DAP
Device Access Point
I/O
Inputs and outputs
E-bus
Designation for EtherCAT terminals in the terminal group (ELxxxx, ESxxxx, or EMxxxx)
EtherCAT
EtherCAT (Ethernet for Control Automation Technology) is the Ethernet solution for industrial automation, characterized by outstanding performance and particularly simple handling.
Fast Ethernet
Data rate 100 Mbits/s according to the 100 Base-T standard.
Device name
The device name in the case of PROFINET corresponds in type to the address in the case of Profibus. Most devices have no name at the time of the initial commissioning and must be given a name by the controller or supervisor. However, most BECKHOFF devices also enable a default name to be set by DIP switch, so that the naming of the devices is dispensed with.
GSDML
Basic device file for PROFINET in XML format (corresponds to the GSD file in the case of PROFIBUS).
IP20
Protection class of the Bus Terminals, EtherCAT Terminals
IPC
Industrial PC
K-bus
Terminal bus (KLxxxx, KMxxxx or KSxxxx terminals)
KS2000
Configuration software for Bus Terminals, Bus Couplers, Bus Terminal Controllers, fieldbus box modules, etc.
PE
The PE power contact can be used as a protective earth.
PROFINET
This is a further development of PROFIBUS and is based on Ethernet technology. PROFINET is described in IEC 61158.
PROFINET IO
This is the generic term for PROFINET communication and describes the concept.
PROFINET controller
This is the name for the PROFINET master for the PROFINET devices (slaves)
PROFINET device
This is the name for the slaves on the PROFINET controller (master)
TwinCAT
The Windows Control and Automation Technology, programmer and configuration tool from the BECKHOFF Automation.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com