EK3100 - PROFIBUS Bus Coupler for EtherCAT Terminals
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Modifications
1.5
▪
Update chapter “Technical data”
1.4
▪
Update chapter “Configuration”
1.3
▪
Update chapter UL notice
1.2
▪
Update chapter “Update Bus Coupler image”
1.1
▪
Minor corrections & addenda
1.0
▪
First version and publication


Product overview

Product overview
Product overview
Additional information
•
EKxxxx - System overview
•
EK3100 - Introduction
•
Technical data - EK3100
•
Technical data - PROFIBUS


EKxxxx - System overview

Product overview [image] EKxxxx - System overview
EKxxxx - System overview
EtherCAT Terminals at an EKxxxx series Bus Coupler
The Bus Couplers from the EKxxxx series allow EtherCAT Terminals to be operated on conventional fieldbus systems. The ultra-fast, high-performance EtherCAT Terminals with their large range of signal types are thus also available for other fieldbus and Industrial Ethernet systems.
The EKxxxx Bus Couplers are fieldbus slaves and contain an EtherCAT master for the EtherCAT terminals. They convert the telegrams from the higher-level fieldbus systems into the E-bus signal representation. A station consists of an EKxxxx and a number of EtherCAT Terminals.
The EKxxxx is integrated in exactly the same way as the Bus Couplers from the BKxxxx series via the corresponding fieldbus system configuration tools and the associated configuration files, such as GSD, ESD or GSDML.
EtherCAT makes a very flexible topology configuration possible. Thanks to the Ethernet physics, long distances can also be bridged without the bus speed being affected. When changing to the field level – without a control cabinet – the EtherCAT Box modules (EPxxxx) in protection class IP65 can also be connected to the EK9xxx.
Bus Couplers for various fieldbus systems
The variants from the EKxxxx series differ from one another by the interface for the higher-level fieldbus system.
An overview of the various Beckhoff Bus Couplers covering the most important fieldbus systems can be found on the Beckhoff Website.
Embedded PCs with fieldbus interface and decentralized control
The TwinCAT-programmable variant is the CX80xx Embedded PC series.
The variants from the CX80xx series differ from one another by the interface for the higher-level fieldbus system and the possibility to program it.
An overview of the various Beckhoff Embedded PCs covering the most important fieldbus systems can be found on the Beckhoff Website.


EK3100 - Introduction

Product overview [image] EK3100 - Introduction
EK3100 - Introduction
EK3100 product overview.
The EK3100 Bus Coupler connects PROFIBUS networks with the EtherCAT Terminals (ELxxxx) and EtherCAT Box modules (EPxxxx) and converts the telegrams from PROFIBUS to E-bus signal representation.
One station consists of an EK3100 and any number of EtherCAT Terminals. A 9-pin D-sub connector is used for connecting the coupler to PROFIBUS. In EtherCAT, the PROFIBUS coupler has at its disposal a lower-level, powerful and ultra-fast I/O system with a large selection of terminals. The coupler supports the PROFIBUS profile and therefore fits seamlessly into PROFIBUS networks.
Configuration
The EK3100 is configured via HTML pages provided by the Bus Coupler (Beckhoff device manager) or via the PROFIBUS DPV1 services.


Technical data - EK3100

Product overview [image] Technical data - EK3100
Technical data - EK3100
Technical data | EK3100
Bus interface | 1 x D-sub socket, 9-pin with shielding
Protocol | PROFIBUS DP
Data transfer rates | up to max. 12 Mbaud (automatic recognition)
Interfaces | 1 x USB (behind the front flap)
Web interface | yes
Power supply | 24 V DC (-15 %/+20 %)
Power contacts | 24 V DC max./10 A max.
Electrical isolation | 500 V (power contact/supply voltage)
Max. power loss | 3 W
I/O connection | E-bus (EtherCAT Terminals)
Power supply for I/O terminals | max. 2 A
I/O terminals | E-bus (EL, ES, EP), standard digital signals, standard analog signals. All compatible EtherCAT devices are listed in the GSD file. No gateway EC terminals, no EC terminals with XFC or DC function.
Number of EtherCAT devices | max. 255
Dimensions (W x H x L) | 65 mm x 100 mm x 73 mm
Operating/storage temperature horizontal mounting position | -25°C … +60°C/-40°C … +85°C
Operating/storage temperature other mounting position | 0…+55 °C/-25…+85 °C
Relative humidity | 95 % no condensation
Vibration/shock resistance | Conforms to EN 60068-2-6/EN 60068-2-27
EMC immunity/emission | Conforms to EN 61000-6-2/EN 61000-6-4
Protect. class / installation pos. | IP 20/variable
Approvals | CE, cULus ATEX


Technical data - PROFIBUS

Product overview [image] Technical data - PROFIBUS
Technical data - PROFIBUS
Technical data | PROFIBUS (EK3100)
Number of I/O modules | depending on controller
Number of I/O points | depending on controller
Data transfer medium | shielded copper cable, 2 x 0.25 mm²
Cable length | 1200 m | 1000 m | 400 m | 200 m | 100 m
Data transfer rate | 9.6/19.2/93.75 kbaud | 187.5 kbaud | 500 kbaud | 1500 kbaud | 3 /6 /12 Mbaud
Topology | Line topology
Fieldbus | PROFIBUS DP
Bus interface | 1 x D sub-socket, 9-pin
Extendable process image | Up to 3 virtual slaves in addition
max. process image | 4 slaves x (240 bytes in / 240 bytes out)
Protocol |
PROFIBUS DP slave | Yes
PROFIBUS-DP (virtual slave) | 4 (3 virtual PROFIBUS nodes)
Functions/Services |
PROFIBUS | DP
DPV1 class 1 | Yes
Diagnostics/Status/Alarm |
RUN LED | Yes, green/red
BF LED | Yes, green/red
DIA LED | Yes, green/red


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Instructions for ESD protection
•
Mounting
•
Wiring
•
UL notice
•
ATEX - Special conditions (standard temperature range)
•
ATEX - Special conditions (extended temperature range)
•
Continuative documentation about explosion protection
•
Version identification of EtherCAT devices


Instructions for ESD protection

Mounting and wiring [image] Instructions for ESD protection
Instructions for ESD protection
Note
Destruction of the devices by electrostatic discharge possible!
The devices contain components at risk from electrostatic discharge caused by improper handling.
•
Please ensure you are electrostatically discharged and avoid touching the contacts of the device directly.
•
Avoid contact with highly insulating materials (synthetic fibers, plastic film etc.).
•
Surroundings (working place, packaging and personnel) should by grounded probably, when handling with the devices.
•
Each assembly must be terminated at the right hand end with an EL9011 or EL9012 bus end cap, to ensure the protection class and ESD protection.
Spring contacts of the Beckhoff I/O components


Mounting

Mounting and wiring [image] Mounting
Mounting
Additional information
•
Dimensions
•
Installation on mounting rails – Bus Coupler


Dimensions

Mounting and wiring [image] Mounting [image] Dimensions
Dimensions
The following illustrations show the dimensions of the Bus Couplers.
Drawings in DWF and STEP format can be found in the Download section of the Beckhoff website.
Dimensions, based on EK9300 as an example.


Installation on mounting rails – Bus Coupler

Mounting and wiring [image] Mounting [image] Installation on mounting rails – Bus Coupler
Installation on mounting rails – Bus Coupler
Snapping onto the mounting rail
The Bus Coupler can simply be snapped onto the mounting rail. To this end position the block on the mounting rail and push it slightly until it engages on the right-hand side. This is indicated by a distinct click. Use a screwdriver to push up the lock on the left-hand side, thereby turning it and causing it to engage audibly.
Snapping onto the mounting rail, based on the EK9300 as an example.
Note
Avoid damage!
Do not force the module or apply excessive pressure!
Installation positions
The installation position of the Bus Coupler is arbitrary.
Note
Installation position of EtherCAT terminals
Observe the installation position of the EtherCAT terminals used – not all of them have an arbitrary installation position. Pay attention to the respective EtherCAT infrastructure components and installation instructions.
Recommended distances for standard installation position, based on the EK9300 as an example.
Note
Comply with the permitted installation position and minimum distances!
We recommend the installation in the horizontal position for optimum ventilation. Furthermore, it is not necessary with this installation position to check whether there are terminals present that may only be installed horizontally.
Other installation positions are allowed, but not recommended.
Other installation positions, based on the EK9300 as an example.


Wiring

Mounting and wiring [image] Wiring
Wiring
Additional information
•
Power supply
•
PROFIBUS interface (X001)
•
Cabling
•
Topology


Power supply

Mounting and wiring [image] Wiring [image] Power supply
Power supply
Supply of Bus Couplers and Bus Terminals (Us)
The Bus Coupler requires a supply voltage of 24 VDC (-15 %/+20 %) for operation.
The connection is made via the two upper terminal points labelled 24 V and 0 V. This power input supplies the Bus Coupler electronics and, via the E-Bus, the electronics of the EtherCAT Terminals. It is electrically isolated from the peripheral supply (Up) of the power contacts.
In order to guarantee the operation of the Bus Coupler and the terminal segment in all cases, the power supply unit must supply 2 A at 24 V.
Bus Coupler power supply, based on the EK9300 as an example.
Power contacts supply (Up)
The three power contacts (spring contacts) are located on the right-hand lateral surface of the Bus Coupler. The spring contacts are hidden in slots so that they can not be accidentally touched. When a Bus Terminal is added, its blade contacts are connected to the spring contacts of the Bus Coupler. The tongue and groove guides on the top and bottom of the Bus Terminal Controllers and of the Bus Terminals guarantees that the power contacts mate securely.
The lower six terminal points labelled +, - and PE are for supplying power to the peripheral supply (Up). These terminal points are connected in pairs to a power contact. This power input allows voltages of up to 24 V and is electrically isolated from the Bus Coupler supply voltage (Us).
The connection of these terminal points in pairs enables the supply to be forwarded. The current load of the power contacts may not permanently exceed 10 A. The current carrying capacity between two terminal points is identical to the current carrying capacity of the connecting wires.
The spring-loaded terminal points are designed for wires with cross-sections from 0.08 mm² to 2.5 mm².
LED
If the power supply unit is connected correctly and the power supply is switched on, the two upper LEDs in the terminal prism are green. The left-hand LED (Us) indicates the supply for the Bus Coupler electronics. The right-hand LED (Up) indicates the supply for the power contacts. The other LEDs indicate the state of the E-bus. The detailed meanings of the LED displays are described in the chapter LED displays.
PE power contacts
Note
Power contact PE
The PE power contact must not be used for other potentials.


PROFIBUS interface (X001)

Mounting and wiring [image] Wiring [image] PROFIBUS interface (X001)
PROFIBUS interface (X001)
PROFIBUS, 9-pin D-sub
Pin 6 transfers 5 VDC, pin 5 transfers GND for the active termination resistor. These must never be used for other functions, as this can lead to destruction of the device.
Pins 3 and 8 transfer the PROFIBUS signals. These must never be swapped over, as this will prevent communication.
PROFIBUS, Pin assignment D-Sub
The Profibus bus line is connected via a 9-pin D sub with the following pin assignment:
Pin | Assignment
1 | Shielding
2 | not used
3 | RxD/TxD-P
4 | not used
5 | GND
6 | +5 VDC
7 | not used
8 | RxD/TxD-N
9 | not used
cable colors
PROFIBUS line | D sub
B red | Pin 3
A green | Pin 8


Cabling

Mounting and wiring [image] Wiring [image] Cabling
Cabling
Physical aspects of the data transmission are defined in the PROFIBUS standard (see PROFIBUS layer 1: Physical Layer).
The types of area where a fieldbus system can be used is largely determined by the choice of the transmission medium and the physical bus interface. In addition to the requirements for transmission security, the expense and work involved in acquiring and installing the bus cable is of crucial significance. The PROFIBUS standard therefore allows for a variety of implementations of the transmission technology while retaining a uniform bus protocol.
Cable-based transmission:
This version, which accords with the American EIA RS-485 standard, was specified as a basic version for applications in production engineering, building management and drive technology. A twisted copper cable with one pair of conductors is used. Depending on the intended application area (EMC aspects should be considered) the shielding may be omitted.
Two types of conductor are available, with differing maximum conductor lengths (see the RS485 table).
RS-485 transmission according to the PROFIBUS standard
Network topology | Linear bus, active bus terminator at both ends, stubs are possible.
Medium | Shielded twisted cable, shielding may be omitted, depending upon the environmental conditions (EMC).
Number of stations | 32 stations in each segment with no repeater. Can be extended to 125 stations with repeater
Max. bus length without repeater | 100 m at 12 Mbit/s 200 m at 1500 Kbit/s, up to 1.2 km at 93.75 kbit/s
Max. bus length with repeater | Repeaters can increase the bus length up to 10 km. The number of repeaters possible is at least 3, and, depending on the manufacturer, may be up to 10.
Data transfer rate (adjustable in steps) | 9.6 kbit/s; 19.2 kbit/s; 93.75 kbit/s; 187.5 kbit/s; 500 kbit/s; 1500 kbit/s; 12 Mbit/s
Connector | 9-pin D sub connector for IP20 M12 round connector for IP65/67
Cable-related faults
Note the special requirements on the data cable for bit rates greater than 1.5 Mbit/s. The correct cable is a basic requirement for correct operation of the bus system. If a simple 1.5 Mbit/s cable is used, reflections and excessive attenuation can lead to some surprising phenomena. It is possible, for instance, for a connected PROFIBUS station not to achieve a connection, but for it to be included again when the neighboring station is disconnected. Or there may be transmission errors when a specific bit pattern is transmitted. The result of this can be that when the equipment is not operating, PROFIBUS works without faults, but that there are apparently random bus errors after start-up. Reducing the bit rate (< 93.75 kbit/s) corrects this faulty behavior.
If reducing the bit rate does not correct the error, then in many cases this can indicate a wiring fault. The two data lines may be crossed over at one or more connectors, or the termination resistors may not be active, or they may be active at the wrong locations.
Preassembled cable from BECKHOFF
Installation is made a great deal more straightforward if preassembled cables from BECKHOFF are used! Wiring faults are avoided, and commissioning is more rapidly completed. The BECKHOFF range includes fieldbus cables, power supply cables, sensor cables and accessories such as termination resistors and T-pieces. Connectors and cables for field assembly are nevertheless also available.

The following diagram shows the cabling between two stations, as well as the D sub connection assignment:
PROFIBUS cabling
Termination resistors
In systems with more than two stations all devices are wired in parallel. It is essential that the bus cables are terminated with resistances at the conductor ends in order to avoid reflections and associated transmission problems.
Distances
The bus line is specified in EN 50170. This yields the following lengths for a bus segment.
Bit rate in kbits/sec | 9.6 | 19.2 | 93.75 | 187.5 | 500 | 1500 | 12000
Cable length in m | 1200 | 1200 | 1200 | 1000 | 400 | 200 | 100
Stubs up to 1500 kbit/s <6.6 m; at 12 Mbit/s stub segments should not be used.
Bus segments
A bus segment consists of at most 32 devices. 125 devices are permitted in a PROFIBUS network. Repeaters are required to refresh the signal in order to achieve this number. Each repeater is counted as one device.
IP-Link is the subsidiary bus system for Fieldbus Boxes, whose topology is a ring structure. There is an IP-Link master in the coupler modules (IP230x-Bxxx or IP230x-Cxxx) to which up to 120 extension modules (IExxxx) may be connected. The distance between two modules may not exceed 5 m. When planning and installing the modules, remember that because of the ring structure the IP-Link master must be connected again to the last module.
Installation guidelines
When assembling the modules and laying the cables, observe the technical guidelines provided by the PROFIBUS User Organization (PROFIBUS Nutzerorganization e.V.) for PROFIBUS DP/FMS (see: www.profibus.de).
Check the PROFIBUS cable
A PROFIBUS cable (or a cable segment when using repeaters) can be checked with a few simple resistance measurements. The cable should meanwhile be removed from all stations:
1.
Resistance between A and B at the start of the line: approx. 110 Ohm
2.
Resistance between A and B at the end of the line: approx. 110 Ohm
3.
Resistance between A at the start and A at the end of the line: approx. 0 Ohm
4.
Resistance between B at the start and B at the end of the line: approx. 0 Ohm
5.
Resistance between shield at the start and shield at the end of the line: approx. 0 Ohm
If these measurements are successful, the cable is okay. If, in spite of this, bus malfunctions still occur, this is usually a result of EMC interference. Observe the installation notes from the PROFIBUS User Organization (www.profibus.com).


Topology

Mounting and wiring [image] Wiring [image] Topology
Topology
▪
A bus segment may consist of a maximum of 32 devices (including the repeaters).
▪
The maximum cable length of a segment depends on the data transfer rate in use and on the quality of the bus cables being used.
▪
No more than 9 repeaters may be installed between two devices.
▪
Stubs are to be avoided, and are not permitted above 1.5 Mbaud.
▪
The maximum number of devices is 125
▪
Interrupting the supply voltages from cable ends by switching off the repeater/slave, or by pulling out the plug, is not permitted.
PROFIBUS topology with the EK3100 Bus Coupler.


UL notice

Mounting and wiring [image] UL notice
UL notice
culus-logo
Application
Beckhoff EtherCAT modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
culus-logo
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
culus-logo
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
Basic principles
UL certification according to UL508 with limited power consumption. The current consumed by the device is limited to a max. possible current consumption of 4 A. Devices with this kind of certification are marked by this sign:
Application
If terminals certified with restrictions are used, then the current consumption at 24 VDC must be limited accordingly by means of supply
▪
from an isolated source protected by a fuse of max. 4 A (according to UL248) or
▪
from a voltage supply complying with NEC class 2.
A voltage source complying with NEC class 2 may not be connected in series or parallel with another NEC class 2compliant voltage supply!
These requirements apply to the supply of all EtherCAT bus couplers, power adaptor terminals, Bus Terminals and their power contacts.


ATEX - Special conditions (standard temperature range)

Mounting and wiring [image] ATEX - Special conditions (standard temperature range)
ATEX - Special conditions (standard temperature range)
SmallWarningYellow WARNING
Observe the special conditions for the intended use of Beckhoff fieldbus components with standard temperature range in potentially explosive areas (directive 2014/34/EU)!
•
The certified components are to be installed in a suitable housing that guarantees a protection class of at least IP54 in accordance with EN 60079-15! The environmental conditions during use are thereby to be taken into account!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of 0 to 55°C for the use of Beckhoff fieldbus components standard temperature range in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The individual terminals may only be unplugged or removed from the Bus Terminal system if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The fuses of the KL92xx/EL92xx power feed terminals may only be exchanged if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
Address selectors and ID switches may only be adjusted if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Marking
The Beckhoff fieldbus components with standard temperature range certified according to the ATEX directive for potentially explosive areas bear one of the following markings:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … +55°C
or
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … +55°C


ATEX - Special conditions (extended temperature range)

Mounting and wiring [image] ATEX - Special conditions (extended temperature range)
ATEX - Special conditions (extended temperature range)
SmallWarningYellow WARNING
Observe the special conditions for the intended use of Beckhoff fieldbus components with extended temperature range (ET) in potentially explosive areas (directive 2014/34/EU)!
•
The certified components are to be installed in a suitable housing that guarantees a protection class of at least IP54 in accordance with EN 60079-15! The environmental conditions during use are thereby to be taken into account!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of -25 to 60°C for the use of Beckhoff fieldbus components with extended temperature range (ET) in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The individual terminals may only be unplugged or removed from the Bus Terminal system if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The fuses of the KL92xx/EL92xx power feed terminals may only be exchanged if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
Address selectors and ID switches may only be adjusted if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Marking
The Beckhoff fieldbus components with extended temperature range (ET) certified according to the ATEX directive for potentially explosive areas bear the following marking:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: -25 … +60°C
or
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: -25 … +60°C


Continuative documentation about explosion protection

Mounting and wiring [image] Continuative documentation about explosion protection
Continuative documentation about explosion protection
Explosion protection for terminal systems
Pay also attention to the continuative documentation

Notes on the use of the Beckhoff terminal systems in hazardous areas according to ATEX and IECEx

that is available for download on the Beckhoff homepage https:\\www.beckhoff.com!


Version identification of EtherCAT devices

Mounting and wiring [image] Version identification of EtherCAT devices
Version identification of EtherCAT devices
Designation
A Beckhoff EtherCAT device has a 14-digit designation, made up of
▪
family key
▪
type
▪
version
▪
revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
Notes
▪
The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
▪
EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
▪
The order identifier is made up of
- family key (EL, EP, CU, ES, KL, CX, etc.)
- type (3314)
- version (-0000)
▪
The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
▪
The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Identification number
Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:
Production lot/batch number/serial number/date code/D number
The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02
Exceptions can occur in the IP67 area, where the following syntax can be used (see respective device documentation):
Syntax: D ww yy x y z u
D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB
Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1
Unique serial number/ID, ID number
In addition, in some series each individual module has its own unique serial number.
See also the further documentation in the area
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Terminals with factory calibration certificate and other measuring terminals
Examples of markings
EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
CU2016 switch with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
EP1258-00001 IP67 EtherCAT Box with batch number/ date code 22090101 and unique serial number 158102
EP1908-0002 IP67 EtherCAT Safety Box with batch number/ date code 071201FF and unique serial number 00346070
EL2904 IP20 safety terminal with batch number/ date code 50110302 and unique serial number 00331701
ELM3604-0002 terminal with unique ID number (QR code) 100001051 and serial/ batch number 44160201
Additional information
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Mounting and wiring [image] Version identification of EtherCAT devices [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Parameterization and Commissioning

Parameterization and Commissioning
Parameterization and Commissioning
Additional information
•
USB interface
•
Address selection switch
•
2-pin DIP switch
•
IP address (via USB interface)


USB interface

Parameterization and Commissioning [image] USB interface
USB interface
The USB interface of type B is located behind the front flap of the EK3100 Bus Coupler. The internal flash memory can be reached via the USB interface for updating the image, for example.
USB interface of the EK3100 Bus Coupler.
The USB interface can only be used if the 2-pin DIP switch was set accordingly (see: 2-pin DIP switch).


Address selection switch

Parameterization and Commissioning [image] Address selection switch
Address selection switch
The EK3100 Bus Coupler has two 10-pin address selection switches. The address selection switches can be used to set the Profibus address.
Address selection switches of the EK3100.
Settings:
▪
S001 for address x 1
▪
S002 for address x 10
Example: If S001 is set to 2 and S002 is set to 1, the resulting address is 12.
To ensure that the address set via the two address selection switches is used in TwinCAT, the address also has to be entered in TwinCAT.


2-pin DIP switch

Parameterization and Commissioning [image] 2-pin DIP switch
2-pin DIP switch
The EK3100 Bus Coupler has a 2-pin DIP switch under the front flap.
2-pin DIP switch of the EK3100.
Possible settings of the 2-pin DIP switch.
DIP switch (red), on = right | Meaning
1 off and 2 off | normal mode, coupler is started
1 on and 2 off | The coupler starts in Config mode. The internal flash memory can be reached via the USB interface (e.g. for an image update).
1 off and 2 on | Factory settings.
1 on and 2 on | No function so far


IP address (via USB interface)

Parameterization and Commissioning [image] IP address (via USB interface)
IP address (via USB interface)
The IP address can be used to access the EK3100 Bus Coupler via a host PC. To access the EK3100 Bus Coupler, the corresponding USB driver first has to be installed on the host PC (see: Installing the USB driver).
An ordinary web browser can then be used on the host PC, and the Beckhoff device manager can be started (see: Beckhoff Device Manager).
The EK3100 has the following fixed network settings:
▪
IP address: 172.21.42.1
▪
Subnet mask: 255.255.255.0
Check whether the IP address of the EK3100 Bus Coupler has been assigned to other devices in the local network or is used by your host PC. If this is the case, you have to change the IP addresses of the devices or deactivate them.


Configuration

Configuration
Configuration
Configuring EtherCAT Terminals
Since the PROFIBUS is subject to certain restrictions, EtherCAT Terminals cannot be configured via the GSD file. Some EtherCAT Terminals would exceed the maximum data length solely on account of the number of configuration data.
Configuration via the GSD file was deliberately omitted, and the EtherCAT Terminals are configured as follows:
▪
Via the web interface (see: Beckhoff device manager),
▪
Or via the PROFIBUS DPV1 services (see sample program for a TwinCAT controller: ).
Configuring the process image (mapping) of the EtherCAT Terminals
The process image (mapping) of an EtherCAT Terminal is configured via the GSD file, as usual. If an EtherCAT Terminal has different mappings, the mapping is automatically set by selecting the corresponding module in the GSD file. If an EtherCAT Terminal is added in TwinCAT, for example, you can choose between the available mappings.
The GSD file for the EK3100 Bus Coupler must be copied into the TwinCAT directory:
▪
TwinCAT 2: C:\TwinCAT\Io\Profibus
▪
TwinCAT 3: C:\TwinCAT\3.1\Config\Io\Profibus
Or: The GSD file for the EK3100 Bus Coupler can be installed retrospectively in TwinCAT when the Bus Coupler is added in TwinCAT (see: Adding the EK3100 Bus Coupler in TwinCAT). A corresponding prompt appears in TwinCAT, which asks you to install the GSD file.
Important configuration files
GSD file, USB driver and sample program for the EK3100 Bus Coupler.
File
Download link
GSD file
EK3100DAA.ZIP
(common for all Profibus master from firmware 01(V00.07)
EK3100DAA02.ZIP
(common for all Profibus master from firmware 02(V00.11))
USB driver
EK9XXX_RNDIS6.ZIP
(driver for USB interface for Web Diagnostics)
EK9XXX_RNDIS6_WIN10.ZIP
(driver for USB interface for Web Diagnostics, Windows 10)
Sample program
Additional information
•
EtherCAT configurations
•
Beckhoff Device Manager
•
Configuration in TwinCAT 3
•
Accessing COE data with DPV1 services


EtherCAT configurations

Configuration [image] EtherCAT configurations
EtherCAT configurations
The EK3100 is an EtherCAT master with automatic configuration. This means that all EtherCAT Terminals must be present when the system is switched on. Since the boot-up of the EK3100 generally takes considerably longer than the start-up of the EtherCAT slave devices, the latter can be operated on the same power supply. With decentralized EtherCAT slaves, care must be taken that they are switched on earlier or at the same time as the supply voltage.
Switching EtherCAT devices on or off during the runtime
If one or more EtherCAT devices should fail during the operating phase, an error response is generated on the PROFIBUS. The input data of all EtherCAT devices are then invalid and the output data are no longer accepted. This also applies to the devices that are still in operation on the EK3100. If you wish to use the option to plug in or unplug devices during the runtime, a further “Sync Unit” must be configured. This is not possible with an EK3100. In this case, use a CX803x.
EtherCAT topology
All EtherCAT devices must be entered in the order in which they map themselves on the EK3100 and thus on the EtherCAT master. EtherCAT devices are automatically addressed; with a few exceptions all EtherCAT Bus Terminals are equipped with an EtherCAT ASIC. EtherCAT Terminals without an ASIC are, for example, EL9400, EL9070 and other EL9xxx. You can identify these EtherCAT Terminals using the technical data "Message to E-bus". If there is a "-" here, this terminal need not be taken into account for the mapping.
EtherCAT devices are registered in the direction of the EtherCAT telegram.
Sample configuration with EK1100 EtherCAT coupler
Sample configuration with EK1100 EtherCAT coupler
Sample configuration with EPxxxx EtherCAT Box
Sample configuration with EPxxxx EtherCAT Box
Example configuration with EK1122 (2-port EtherCAT junction in protection class IP20)
The counting direction is to be observed when using an EK1122!
If EtherCAT junction 1 on the EK1122 is connected, then the EtherCAT frame is forwarded here first (1); if junction 1 is not connected the frame on junction 2 is sent (2), only after that does the sequence continue with the E-bus on the right-hand side (3).
Example configuration with EK1122 (2-port EtherCAT junction in protection class IP20)
If neither junction is used, then junctions 1 and 2 are bridged, so to speak, and the EtherCAT frame goes directly to the E-Bus on the right-hand side.
Example configuration with EP1122 (2-port EtherCAT junction in protection class IP65)
The counting direction is to be observed when using an EP1122! It is comparable with the EK1122.
If EtherCAT junction 1 on the EP1122 is connected, then the EtherCAT frame is forwarded here first (1); if junction 1 is not connected the frame on junction 2 is sent (2), only after that does the sequence continue with the EtherCAT connection on the right-hand side (3).
Example configuration with EP1122 (2-port EtherCAT junction in protection class IP65)
If neither junction is used, then junctions 1 and 2 are bridged, so to speak, and the EtherCAT frame goes directly to the EtherCAT connection on the right-hand side.
No Hot Swap during operation
You cannot use EP1122 and EK1122 on an EKxxxx for Hot Swap and also not for connection and disconnection during operation. EP1122 and EK1122 are suitable only for topology extension (star) on an EKxxxx.
Note restrictions
Please note the following restrictions when you use the EK3100 Bus Coupler with EtherCAT devices:
▪
Only EtherCAT devices from Beckhoff are supported. To use EtherCAT device from other manufacturers, use the CX8031 Embedded PC instead.
▪
The EK3100 Bus Coupler does not support hot-plug. All EtherCAT devices have to be connected before the Bus Coupler can be started. The EtherCAT configuration must not be changed during operation. An EtherCAT interrupt generates an error and invalidates the data.
▪
Only one Sync Unit is supported.
▪
The EK3100 Bus Coupler does not support distributed clocks. EtherCAT devices requiring distributed clocks cannot be used.
▪
Use only EtherCAT devices from Beckhoff, which are listed in the GSD file.
▪
Gateway terminals are not supported. These also include ASI and IO-Link terminals. To use gateway terminals, use the CX8031 Embedded PC instead.
▪
EtherCAT K-bus Couplers, such as the BK11x0 or the BK1250, are not supported


Beckhoff Device Manager

Configuration [image] Beckhoff Device Manager
Beckhoff Device Manager
Additional information
•
Installing the USB driver
•
Starting the Beckhoff Device Manager
•
Setting the mappings for EtherCAT Terminals
•
Configuring EtherCAT Terminals
•
Using Restore file


Installing the USB driver

Configuration [image] Beckhoff Device Manager [image] Installing the USB driver
Installing the USB driver
Allocated IP address
The USB driver is not fully installed, if the IP address 172.21.42.15 on the host PC is already allocated.
Use Prompt > ipconfig to check whether the IP address is allocated. If this is the case, change the IP address before proceeding.
To access the Beckhoff Device Manager of the EK3100 Bus Coupler, the corresponding USB driver first has to be installed on the host PC.
After successful installation, the driver simulates an additional local Ethernet interface on the host PC with the fixed IP address: 172.21.42.15 and subnet mask: 255.255.255.0
Requirements:
▪
IP address 172.21.42.15 is not already used on the host PC.
▪
USB driver for the host PC: --- FEHLENDER LINK ---
▪
USB driver for the host PC:
- EK9XXX_RNDIS6.ZIP
(Driver for USB interface for Web Diagnostics)
- EK9XXX_RNDIS6_WIN10.ZIP
(Driver for USB interface for Web Diagnostics, Windows 10)
Install the USB driver as follows:
1.
Use a USB cable to connect the EK3100 Bus Coupler to the host PC and start the Bus Coupler.
The device Beckhoff Automation GmbH EK Series USB appears in the device manager of the host PC.
2.
Click on Beckhoff Automation GmbH EK Series USB, then on Update Driver Software.
3.
Specify the correct file path and install the driver on the host PC.
⇨
The USB driver has been installed successfully if the additional Ethernet interface Beckhoff Automation GmbH EK9XXX Series USB RNDIS6 appears in the device manager.

In the next step you can start the Beckhoff Device Manager.


Starting the Beckhoff Device Manager

Configuration [image] Beckhoff Device Manager [image] Starting the Beckhoff Device Manager
Starting the Beckhoff Device Manager
The Beckhoff Device Manager can be used to configure EtherCAT Terminals that are connected to the Bus Coupler. In addition, the Beckhoff Device Manager can be used for diagnostic purposes relating to the Bus Coupler and the EtherCAT Terminals.
The Beckhoff Device Manager is started via a web browser on a host PC. Access to the Beckhoff Device Manager of the EK3100 Bus Coupler is protected.
Access data for the Beckhoff Device Manager.
URL | Access data
172.21.42.1/config | User name: guest Password: 1
Requirements:
▪
The host PC and the EK3100 Bus Coupler are connected via a USB cable.
▪
USB driver installed on the host PC (see: Installing the USB driver).
Start the Beckhoff Device Manager as follows:
1.
On the host PC enter the IP address of the Bus Coupler in the web browser, in order to start the Beckhoff Device Manager.
Example with IP address: http://172.21.42.1/config
2.
In the authentication window enter the user name and the password.
The start page appears.

⇨
Navigate further in the menu and configure your hardware. Please note that modifications only take effect once they have been confirmed or the EK3100 Bus Coupler has been restarted.


Setting the mappings for EtherCAT Terminals

Configuration [image] Beckhoff Device Manager [image] Setting the mappings for EtherCAT Terminals
Setting the mappings for EtherCAT Terminals
Mapping
Please note that the settings for the mapping in TwinCAT (GSD file) always take precedence. Deviating settings in the Beckhoff Device Manager are not considered or are overwritten.
In the Beckhoff Device Manager you can set the mapping for an EtherCAT Terminal, if this EtherCAT Terminal supports different mappings. For the analog EL3062 EtherCAT Terminal, for example, you can choose between Standard mapping and Compact mapping. The choice affects the size and therefore the type of data that is available as process data (see GSD file).
Requirements:
▪
An EtherCAT Terminal that supports different mappings.
▪
The Beckhoff Device Manager was already started (see: Starting the Beckhoff Device Manager).
Set the mapping for an EtherCAT Terminal as follows:
1.
Click on EtherCAT, then on Master.
EK3100_EtherCAT Slave Mappings
2.
Under EtherCAT Slave Mappings all EtherCAT Terminals are displayed, which support other mappings.
3.
Under EtherCAT Slave Mappings double-click on the EL3062 EtherCAT Terminal and select Standard or Compact mapping.
EK3100_EtherCAT Slave Mappings2
⇨
You have successfully set the mapping for the EL3062 EtherCAT Terminal. Restart the EK3100 Bus Coupler for the settings to take effect after reboot.
Example for process data (mapping)
Description of the process data
Further information on the process data (mapping) for any EtherCAT Terminal can be found in the corresponding documentation. For example, for the EL3062 under: Commissioning > Process data and operation modes> Process data.
The EL3062 EtherCAT Terminal mentioned above offers two different process data per analog channel for transfer. The analog value Value (16-bit) and status information Status (16-bit). The total for the two analog channels is therefore 64 bits or 8 bytes.
There is a choice of two types of process data in the EL3062:
▪
Standard: standard setting, Value (16 bit) and status information (8 or 16 bit) are transmitted per channel.
▪
Compact: only the Value (16 bit) is transmitted per channel.
To obtain a description of the individual bits, add the EtherCAT Terminal to TwinCAT, irrespective of your PROFIBUS configuration, or read the corresponding documentation
Meaning of the individual bits with all subvariables and structure contents for the EL3062.
Status word
The status word (SW) is located in the input process image, and is transmitted from terminal to the controller.
Bit | SW.15 | SW.14 | SW.13 | SW.12 | SW.11 | SW.10 | SW.9 | SW.8
Name | TxPDO Toggle | TxPDO State | - | - | - | - | - | -
Bit | SW.7 | SW.6 | SW.5 | SW.4 | SW.3 | SW.2 | SW.1 | SW.0
Name | - | ERROR | Limit 2 |  | Limit 1 |  | Over-range | Under-range


Configuring EtherCAT Terminals

Configuration [image] Beckhoff Device Manager [image] Configuring EtherCAT Terminals
Configuring EtherCAT Terminals
In this chapter the EL3062 EtherCAT Terminal is used to illustrate how to configure EtherCAT Terminals with the Beckhoff Device Manager.
Further information on the parameters and their meaning for any EtherCAT Terminal can be found in the corresponding documentation. For example, for the EL3062 under: Commissioning > Object description and parameterization > Configuration data.
Requirements:
▪
The Beckhoff Device Manager was already started (see: Starting the Beckhoff Device Manager).
Configure EtherCAT Terminals as follows:
1.
Click on EtherCAT, then on Master.
2.
Click on an EtherCAT Terminal you wish to configure.
The parameters of the EtherCAT Terminal are displayed.
3.
Under Parameters you can change the values for the EtherCAT Terminal.

⇨
The settings are stored in the EtherCAT Terminal. Please note that the settings will be lost when you replace the EtherCAT Terminal with a new one.
In order to retain the settings, you can save them in a Restore file (see: Using Restore file).


Using Restore file

Configuration [image] Beckhoff Device Manager [image] Using Restore file
Using Restore file
Restore files are used in the Beckhoff device manager for saving existing EtherCAT Terminal configurations and settings.
Without a Restore file, EtherCAT Terminal settings are lost, if the terminal is replaced. If a Restore file was created, the parameters can be copied to a new EtherCAT Terminal when the Bus Coupler is started.
Requirements:
▪
The Beckhoff Device Manager was already started (see: Starting the Beckhoff Device Manager).
Use Restore files as follows:
1.
Click on EtherCAT, then on Master.
2.
Under EtherCAT Slaves all EtherCAT Terminals are displayed, for which a Restore file can be created.
3.
Use the option Restore State to show whether a Restore file was created for an EtherCAT Terminal.

EMPTY: No Restore file was created.
VALID: A valid Restore file was created.
MAPPING: The mapping was changed and has not yet been saved in the Restore file.
4.
Under Configuration Management you can specify whether a Restore file should be created, deleted, saved or restored.

⇨
Please note that the settings from a Restore file are not copied to the new EtherCAT Terminal until the Bus Coupler is restarted.


Configuration in TwinCAT 3

Configuration [image] Configuration in TwinCAT 3
Configuration in TwinCAT 3
Additional information
•
Adding the EK3100 Bus Coupler in TwinCAT
•
Using the CtrlStatus DWORD
•
Adding an EtherCAT Terminal
•
Creating a virtual slave
•
Packing digital signals


Adding the EK3100 Bus Coupler in TwinCAT

Configuration [image] Configuration in TwinCAT 3 [image] Adding the EK3100 Bus Coupler in TwinCAT
Adding the EK3100 Bus Coupler in TwinCAT
The EK3100 Bus Coupler is added in TwinCAT under a PROFIBUS master. In this step the CX2020 Embedded PC is used with a CX2500-M310 PROFIBUS fieldbus module as an example.
The EK3100 Bus Coupler requires the appropriate GSD file for TwinCAT. Two options are available. The GSD file can be copied into the TwinCAT directory or added to TwinCAT retrospectively. In this step the GSD file is added to TwinCAT retrospectively.
Requirements:
▪
GSD file for the EK3100 Bus Coupler:
▪
The PROFIBUS master was selected as target system and added in TwinCAT.
Add the EK3100 Bus Coupler in TwinCAT as follows.
1.
In the tree view right-click on the PROFIBUS master Device 1 (CX2500-M310).
2.
Click on Add New Item in the context menu.

3.
Click on Miscellaneous, then on Generic Profibus Box (GSD).

The Open window opens.
4.
Find the GSD file from the Zip archive in your directory and select the file EK3100DAA.gsd for the EK3100 Bus Coupler.
Box 1 (GSD box) (EK3100) appears under the PROFIBUS master.
5.
Click on the Profibus tab and enter the Profibus address under Station No. The address must be the same as the address that was set with the address selection switches.
⇨
You have successfully added the EK3100 Bus Coupler and the corresponding GSD file in TwinCAT. The CtrlStatus DWORD module is automatically added under box 1 (GSD box) (EK3100).

In the next step you can add EtherCAT Terminals in TwinCAT according to your hardware configuration.


Using the CtrlStatus DWORD

Configuration [image] Configuration in TwinCAT 3 [image] Using the CtrlStatus DWORD
Using the CtrlStatus DWORD
The CtrlStatus DWORD module is added automatically when the EK3100 Bus Coupler is added in TwinCAT. The CtrlStatus DWORD (4 bytes) has the following meaning:
Input CtrlStatus DWORD
Structure and meaning of the input CtrlStatus DWORD module.
Byte 3 | Byte 2 | Byte 1 | Byte 0
Reserve | Diag | Counter High Byte | Counter Low Byte
Counter WORD (2 bytes):
The counter is an E-bus counter and is incremented with each E-bus telegram. By default, the E-bus runs at 1 ms. Thus, the counter is incremented every ms. If bit 2 is set in the Diag byte, further information about the error is included instead of the counter.
DIAG BYTE (1 byte):
0x10 E-bus fixed after error. Outputs are disabled and have to be reset manually with the control DWORD.
0x04 E-bus error. In the event of an E-bus error, the EK3100 Bus Coupler continues to exchange data with the PROFIBUS master. However, the input data are invalid. The cause of the error is coded in the high byte, the position in the low byte of the counter.
Byte 1, error code counter | Byte 0, counter | Meaning
1 | Terminal position | Wrong module.
2 |  | Missing module.
3 |  | Module pulled.
4 |  | Wrong module connected.
5 |  | EtherCAT slave not in OP.
6 |  | State change aborted.
7 |  | Abnormal state change.
8 |  | SDO-Abort
9 |  | Wrong SDO length
10 |  | Wrong SDO data.
Example:
Byte 1 0x03 interruption of the E-bus, byte 0 position of the interruption.
Output CtrlStatus DWORD
Structure and meaning of the output CtrlStatus DWORD module.
Byte 3 | Byte 2 | Byte 1 | Byte 0
Reserve | Reserve | Reserve | Control byte
Control byte (bit 0):
If bit 4 (0x10) is set in the DIAG BYTE, the controller can acknowledge the error. To this end, bit 0 (in the first byte of the control DWORD) has to be set to “TRUE”, and the E-bus is restarted with a falling edge of bit 0. The output process data are active again immediately.


Adding an EtherCAT Terminal

Configuration [image] Configuration in TwinCAT 3 [image] Adding an EtherCAT Terminal
Adding an EtherCAT Terminal
Please note the order of the EtherCAT Terminals in TwinCAT. The EtherCAT Terminals have to be added to TwinCAT in the same order as they are plugged or addressed by the EtherCAT master (EK3100 Bus Coupler).
Some EtherCAT Terminals do not have to be added in TwinCAT.
▪
EtherCAT Terminals, which are not visible in the EtherCAT master (EK3100 Bus Coupler) do not have to be entered.
▪
All other EtherCAT Terminals, which are visible in the EtherCAT master (EK3100 Bus Coupler), always have to be entered. This includes EtherCAT Terminals without process data.
EtherCAT Terminals, which are visible but have no process data:
Example: EK1100, EK1110, …
EtherCAT Terminals, which are not visible and have no process data. These terminals are identified in the technical data with a “-” under “Message to E-bus”:
Example: EL9011, EL9080, …
Requirements:
▪
The Bus Coupler was added in TwinCAT together with the corresponding GSD file
Add EtherCAT Terminals as follows:
1.
Always add the first EtherCAT Terminal after the CtrlStatus DWORD module.
2.
Right-click on Box 1 (GSD) (EK3100) on the left in the tree view.

3.
Click on Add New Item in the context menu.
The Insert Module window appears.
4.
Select the corresponding EtherCAT Terminal in the right order.
Please note that some EtherCAT Terminals are listed several times, depending on the available mapping.

Example: For the analog EL3062 EtherCAT Terminal you can choose between Standard mapping and Compact mapping. The choice affects the size and therefore the type of data that is available as process data (see GSD file).
⇨
Add further EtherCAT Terminals in TwinCAT, until your hardware configuration with all EtherCAT devices is fully mapped in TwinCAT.


Creating a virtual slave

Configuration [image] Configuration in TwinCAT 3 [image] Creating a virtual slave
Creating a virtual slave
Up to three virtual slaves can be configured for the EK3100 Bus Coupler. Virtual slaves can be used to increase the transfer rate beyond the standard PROFIBUS rate of 244 bytes. The maximum process data size is 240 byte inputs and 240 byte outputs per slave.
In order to be able to use virtual slaves, the EtherCAT Terminals must be successive, and all EtherCAT Terminals must occur in the slaves. In addition, it is important that a slave contains both input and output terminals.
By default only the first slave is activated. The virtual slaves are enabled in the configuration via the parameter data. The parameter data and the CtrlStatus DWORD only have the full functionality for the first slave.
The addressing is fixed and starts with the address, which the first slave uses via an address selection switch. If the address is set to 11, the following addresses are 12, 13 and 14 if all 4 slaves are active.
Example of a hardware configuration with a slave.
EtherCAT device, actual hardware configuration
EK3100
CtrlStatus
EL1008
EL2008
EL3062
EK1110
EK1100
EL2008
EL1008
EL3154
EL9011
Distribution of the EtherCAT device in TwinCAT over two slaves.
Slave 1 |  |  |  |  |  | Slave 2 (virtual slave)
EK3100 | CtrlStatus | EL1008 | EL2008 | EL3062 | EK1110 | EK3100 | CtrlStatus | EK1100 | EL2008 | EL1008 | EL3154
PROFIBUS address: 11 |  |  |  |  |  | PROFIBUS address: 12. The non-visible EL9011 is omitted.
Requirements
▪
The EK3100 Bus Coupler was already added in TwinCAT.
Create virtual slaves as follows:
1.
In the tree view on the left, double-click on Box 1 (GSD box) (EK3100).

2.
Click on the tab PrmData (Text).
3.
Double-click on Enabled DP Slaves and select the number of virtual slaves.

4.
Add a further EK3100 Bus Coupler under the existing EK3100 Bus Coupler. This Bus Coupler is the virtual slave.
5.
Click on the Profibus tab and enter the PROFIBUS address "12" under Station No.
⇨
Add all EtherCAT Terminals after the EK3100 Bus Coupler and the virtual slave. Use the above table for guidance.


Packing digital signals

Configuration [image] Configuration in TwinCAT 3 [image] Packing digital signals
Packing digital signals
EtherCAT Terminals generally always require 1 full byte for process data. 1 full byte for process data is also assigned for EtherCAT Terminals, which effectively only have a process data size of 2 or 4 bits.
In order to fill 1 byte completely, the 2- or 4-channel EtherCAT Terminals can be packed. Please ensure that these EtherCAT Terminals are connected successively and that 1 byte is not exceeded.
The entry EL1xxx or EL2xxx in the GSD file is used for this purpose. The EtherCAT Terminals to be packed have the entry EL1xxx (pack) or EL2xxx (pack). These EtherCAT Terminals then have no data. The data are added to the preceding terminals in the byte.
Example:
Three EL1002 (each with 2 channels) are connected consecutively. In this example one EL1xxx can be configured and two EL1xxx (pack).
The process data for these EtherCAT Terminals then are as follows:
First EL1002: | x.0 and x.1
Second EL1002: | x.2 and x.3
Third EL1002: | x.4 and x.5
Requirements
▪
The EtherCAT Terminals must be connected consecutively.
Pack digital signals as follows:
1.
Right-click on Box 1 (GSD) (EK3100) on the left in the tree view.
2.
Click on Add New Item in the context menu.
The Insert Module window appears.

3.
Select the terminal EL1xxx.
The EtherCAT Terminal is added in TwinCAT.
4.
Then select the terminal EL1xxx (pack) and enter the value "2" under the option Multiple.
⇨
Three EL1002 EtherCAT Terminals were added in TwinCAT. The data of the two EL1xxx (pack) are added to the preceding EtherCAT Terminal in the byte.

In the example a further EL1002 can be connected to fill the byte. Or other 2-channel input terminals can be used. It is important that they have the same mapping. It is also possible to mix 2-channel and 4-channel EtherCAT Terminals, as long as 1 byte is not exceeded.


Accessing COE data with DPV1 services

Configuration [image] Accessing COE data with DPV1 services
Accessing COE data with DPV1 services
DPV1 MSAC-C1-READ and DPV1 MSAC-C1-WRITE can be used for read and write access to all COE data. The COE data must allow READ and WRITE access.
The access is always via two DPV1 telegrams. The first is always a DPV1 WRITE telegram. The second is a DPV1 READ telegram. The DPV1 WRITE telegram determines which COE data are read or written.
Behavior when the Bus Coupler is restarted
Please note that the COE data, which are changed by your controller, have to be re-sent to the terminal when the EK3100 Bus Coupler is restarted.
▪
Reading data: During reading a DPV1 WRITE telegram is send to the Bus Coupler. It notifies the Bus Coupler which data are to be read. The second DPV1 READ telegram is then used to fetch the data.
▪
Writing data: During writing, the data are transferred with the CoE parameters, and the acknowledgement of the COE write access is transferred with the DPV1 READ telegram. This consists of 4 bytes. If these are zero, the data were written without error. If they are not zero, an error has occurred.

The error corresponds to an ADS error code. The meaning of the ADS error codes can be found in the TwinCAT documentation (see: ADS error codes).
Additional information
•
Activating the DPV1 service
•
Note the structure of the DPV1 telegram


Activating the DPV1 service

Configuration [image] Accessing COE data with DPV1 services [image] Activating the DPV1 service
Activating the DPV1 service
DPV1 MSAC-C1-READ and DPV1 MSAC-C1-WRITE can be used for read and write access to all COE data. The COE data must allow READ and WRITE access.
For read and write access to COE data, the DPV1 service must be active on the EK3100 Bus Coupler in the parameter data for the EK3100 Bus Coupler. In TwinCAT you can control whether the DPV1 service is active, or you can activate the DPV1 service.
Requirements:
▪
The Bus Coupler was added in TwinCAT together with the corresponding GSD file.
Activate the DPV1 service as follows:
1.
In the tree view on the left, double-click on Box 1 (GSD box) (EK3100).

2.
Click on the tab PrmData (Text).
3.
Double-click on the option DPV1 services (class 1) to activate the service.

⇨
You have successfully activated the DPSV1 service. For virtual slaves, the settings in the parameter data are irrelevant.
In the next step, you can view the structure of the DPV1 telegram.


Note the structure of the DPV1 telegram

Configuration [image] Accessing COE data with DPV1 services [image] Note the structure of the DPV1 telegram
Note the structure of the DPV1 telegram
Structure of the DPV1 telegram for write and read access.
Index | 100
Slot number | Position of the EtherCAT Terminal, absolute position.
Structure | Meaning | Length in bytes
CoE Index | CoE index number. | 2
COE subindex | COE subindex number. | 1
READ/ WRITE | 0-read/ 1-write. | 1
Length | Length of the data that is to be written. During reading, this can be zero. | 4
Data | Data, only required for writing. | n
If you use virtual slaves, the slot number must contain the actual terminal position, not the slot position of the EtherCAT Terminal.
Example
You want to read the COE data of EtherCAT Terminal EL3154. This EtherCAT Terminal is configured in TwinCAT under slave 2 (virtual slave).
Distribution of the EtherCAT device in TwinCAT over two slaves.
Slave 1 |  |  |  |  |  | Slave 2 (virtual slave)
EK3100 | CtrlStatus | EL1008 | EL2008 | EL3062 | EK1110 | EK3100 | CtrlStatus | EK1100 | EL2008 | EL1008 | EL3154
PROFIBUS address: 11 |  |  |  |  |  | PROFIBUS address: 12. The non-visible EL9011 is omitted.
In this example EtherCAT Terminal EL3154 has the slot number 8. Both CtrlStatus DWORD modules and the virtual EK3100 slave are not included in the count.
Distribution of the slot numbers across the EtherCAT devices.
Slave 1 |  |  |  |  | Slave 2 (virtual slave)
Slot number | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8
EK3100 | EL1008 | EL2008 | EL3062 | EK1110 | EK1100 | EL2008 | EL1008 | EL3154
PROFIBUS address: 11 |  |  |  |  | PROFIBUS address: 12. The non-visible EL9011 is omitted.


Error handling and diagnostics

Error handling and diagnostics
Error handling and diagnostics
Additional information
•
Diagnostic LEDs
•
Power supply terminal LEDs in K-bus mode
•
Diagnostics via PROFIBUS


Diagnostic LEDs

Error handling and diagnostics [image] Diagnostic LEDs
Diagnostic LEDs
Diagnostic LEDs on the EK3100.
Display | LED | Description | Color | Meaning
 | RUN | Indicates the status of the coupler. | Green | EK3100 started.
 |  |  | Blue | Update of the EK3100 via USB possible.
 | BF | Shows the PROFIBUS status | Flashing green | No PROFIBUS communication.
 |  |  | Green illuminated | EK3100 is in data exchange.
LED | Description | Error code - First sequence | Error location - Second sequence | Meaning
DIA | Flashes red in the event of an error. Indicates the error code and the error location through two consecutive sequences. | 1 pulse | After Bus Terminal n | Wrong module.
 |  | 2 pulses |  | Missing module.
 |  | 3 pulses |  | Module pulled.
 |  | 4 pulses |  | Wrong module connected.
 |  | 5 pulses |  | EtherCAT slave not in OP mode.
 |  | 6 pulses |  | State change aborted.
 |  | 7 pulses |  | Abnormal state change.
 |  | 8 pulses |  | SDO abort.
 |  | 9 pulses |  | Wrong SDO length.
 |  | 10 pulses |  | Wrong SDO data.


Power supply terminal LEDs in K-bus mode

Error handling and diagnostics [image] Power supply terminal LEDs in K-bus mode
Power supply terminal LEDs in K-bus mode
The power supply unit checks the connected EtherCAT Terminals. The "L/A" LED is lit in E-bus mode. The "L/A" LED flashes during data transfer.
Power supply terminal LEDs on the EK3100.
Display | LED |  | Meaning
 | Us 24 V |  | Power supply for basic CPU module. The LED lights green if the power supply is correct.
 | Up 24 V |  | Power supply for terminal bus. The LED lights green if the power supply is correct.
 | L / A | off | E-bus not connected.
 |  | on | E-bus connected / no data traffic.
 |  | flashes | E-bus connected / data traffic on the E-bus.


Diagnostics via PROFIBUS

Error handling and diagnostics [image] Diagnostics via PROFIBUS
Diagnostics via PROFIBUS
The diagnostics via PROFIBUS is configured as follows. The module at slot 1 is always the CtrlStatus DWORD module. The first EtherCAT Terminal from your hardware configuration is therefore always at slot 2.
For the diagnostics the currently projected position is important, not the actual position in the hardware configuration.
Example:
An EtherCAT Terminal, which in the actual hardware configuration is connected in fourth position after the EK3100, has a problem. In this case the diagnostics would indicate the error at slot 5, since slot 1 is always assigned the CtrlStatus DWORD module.
Diagnostic example via PROFIBUS with a Siemens project configuration.
Please note this behavior for diagnostics via PROFIBUS.
Additional information
•
Diagnostics for virtual slaves
•
Configuration of the diagnostic telegram


Diagnostics for virtual slaves

Error handling and diagnostics [image] Diagnostics via PROFIBUS [image] Diagnostics for virtual slaves
Diagnostics for virtual slaves
The diagnostics always indicates the slot from the configuration; the “actual” EtherCAT Terminal is indicated via the text.
Example:
You have configured the EK3100 Bus Coupler with an additional virtual slave, and the EtherCAT Terminal at the 9th position has a problem. This EtherCAT Terminal is configured at the 5th slot on the virtual slave. Use the text from the diagnostics, rather than the slot number, to determine the error location.
Diagnostic example via PROFIBUS for virtual slaves with a Siemens project configuration.
Please note this behavior for diagnostics via PROFIBUS.


Configuration of the diagnostic telegram

Error handling and diagnostics [image] Diagnostics via PROFIBUS [image] Configuration of the diagnostic telegram
Configuration of the diagnostic telegram
Configuration of the diagnostic telegram after DPV0 and DPV1.
Byte | Description
Byte [0…5] | Standard diagnosis after DPV0.
from byte [6] | Diagnosis after DPV1.
Byte [6] | 0x07 header byte after DPV1 = length specification.
Byte [7] | 0x0A status type after DPV1.
Byte [8] | 0xXX slot number after DPV1 The slot number refers to the position in the configuration software. The slot number is always +1, since slot 1 is always assigned the CtrlStatus DWORD module. The actual EtherCAT Terminal is shown in byte [10].
Byte [9] | Specifier after DPV1.
from byte [10] | Vendor-specific.
Byte [10] | EtherCAT slave number.
Byte [11] | Value (1) = EtherCAT slave in INIT.
 | Value (2) = EtherCAT slave in PreOP.
 | Value (3) = EtherCAT slave in SafeOP.
 | Value (4) = EtherCAT slave in OP.
 | Value (5) = EtherCAT slave not present.
Byte [12] | Value (1) = state change aborted.
 | Value (2) = abnormal state change.
 | Value (3) = SDO abort.
 | Value (4) = wrong SDO length.
 | Value (5) = wrong SDO data.
 | Value (6) = wrong module configured.
 | Value (7) = modules pulled.
 | Value (8) = modules connected.
 | Value (9) = not all modules connected.
 | Value (10) = wrong module connected.
 | Value (11) = missing module.


Appendix

Appendix
Appendix
Additional information
•
Update Bus Coupler image
•
Support and Service


Update Bus Coupler image

Appendix [image] Update Bus Coupler image
Update Bus Coupler image
Loss of data
The data in the internal flash memory are deleted.
Save your data before you update the Bus Coupler image.
The Bus Coupler image can be updated via the USB interface. To this end the Bus Coupler is connected with a host PC via a USB cable. Windows then shows the Bus Coupler as a removable data storage device, and the files can be copied.
The Bus Coupler should only be updated after consultation with the Beckhoff Service. The Beckhoff Service will provide all the required files.
Requirements
▪
First, check whether the Bus Coupler supports the image.
▪
The Bus Coupler is connected with the host PC via a USB cable.
Update the image as follows:
1.
Switch off the Bus Coupler.
2.
Switch the red 2-pin DIP switch 1 to “on” (to the right) and switch on the Bus Coupler.
The Bus Coupler appears as a removable data storage device on the host PC.
3.
Select and delete all files. Do not format.

4.
Remove the USB cable, once all files have been copied, and switch the 2-pin DIP switch to “off” (to the left).
5.
Restart the Bus Coupler.
⇨
The image has been updated successfully. After the update, the Bus Coupler may take a little longer to start up.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com