EK18xx - EtherCAT Bus Coupler
Home


Foreword

Foreword
Foreword
Additional information
•
Product overview EtherCAT Bus Coupler
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status
•
Version identification of EtherCAT devices


Product overview EtherCAT Bus Coupler

Foreword [image] Product overview EtherCAT Bus Coupler
Product overview EtherCAT Bus Coupler
EK1814 EtherCAT Bus Coupler with 4 digital inputs and 4 digital outputs
EK1818 EtherCAT Bus Coupler with 8 digital inputs and 4 digital outputs
EK1828 EtherCAT Bus Coupler with 4 digital inputs and 8 digital outputs
EK1828-0010 EtherCAT Bus Coupler with 8 digital outputs


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Modifications
2.3
▪
Update chapter “UL notice”
▪
Update chapter “Firmware compatibility”
▪
Update structure
2.2
▪
Update chapter "Overview EtherCAT couplers"
▪
Update chapter "Safety instructions"
▪
Update revision status
2.1
▪
Update chapter "Notes on the documentation"
▪
Update chapter "Technical data"
▪
Addenda chapter "Instructions for ESD protection"
▪
Update revision status
2.0
▪
Migration
▪
Update revision status
▪
Update structure
1.3
▪
Update structure
▪
Update revision status
▪
Update chapter "Technical data"
1.2
▪
Addenda chapter "Power Supply, Potential Groups"
1.1
▪
EK1818, EK1828, EK1828-0010 added
1.0
▪
First public issue
0.3
▪
Corrections and addenda
0.2
▪
Corrections and addenda
0.1
▪
Preliminary version


Version identification of EtherCAT devices

Foreword [image] Version identification of EtherCAT devices
Version identification of EtherCAT devices
Designation
A Beckhoff EtherCAT device has a 14-digit designation, made up of
▪
family key
▪
type
▪
version
▪
revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
Notes
▪
The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
▪
EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
▪
The order identifier is made up of
- family key (EL, EP, CU, ES, KL, CX, etc.)
- type (3314)
- version (-0000)
▪
The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
▪
The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Identification number
Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:
Production lot/batch number/serial number/date code/D number
The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02
Exceptions can occur in the IP67 area, where the following syntax can be used (see respective device documentation):
Syntax: D ww yy x y z u
D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB
Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1
Unique serial number/ID, ID number
In addition, in some series each individual module has its own unique serial number.
See also the further documentation in the area
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Terminals with factory calibration certificate and other measuring terminals
Examples of markings
EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
CU2016 switch with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
EP1258-00001 IP67 EtherCAT Box with batch number/ date code 22090101 and unique serial number 158102
EP1908-0002 IP67 EtherCAT Safety Box with batch number/ date code 071201FF and unique serial number 00346070
EL2904 IP20 safety terminal with batch number/ date code 50110302 and unique serial number 00331701
ELM3604-0002 terminal with unique ID number (QR code) 100001051 and serial/ batch number 44160201
Additional information
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Foreword [image] Version identification of EtherCAT devices [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Basic principles

Basic principles
Basic principles
Additional information
•
EtherCAT basics
•
EtherCAT cabling – wire-bound
•
EtherCAT State Machine
•
CoE - Interface: notes
•
Distributed Clock


EtherCAT basics

Basic principles [image] EtherCAT basics
EtherCAT basics
Please refer to the EtherCAT System Documentation for the EtherCAT fieldbus basics.


EtherCAT cabling – wire-bound

Basic principles [image] EtherCAT cabling – wire-bound
EtherCAT cabling – wire-bound
The cable length between two EtherCAT devices must not exceed 100 m. This results from the FastEthernet technology, which, above all for reasons of signal attenuation over the length of the cable, allows a maximum link length of 5 + 90 + 5 m if cables with appropriate properties are used. See also the Design recommendations for the infrastructure for EtherCAT/Ethernet.
Cables and connectors
For connecting EtherCAT devices only Ethernet connections (cables + plugs) that meet the requirements of at least category 5 (CAt5) according to EN 50173 or ISO/IEC 11801 should be used. EtherCAT uses 4 wires for signal transfer.
EtherCAT uses RJ45 plug connectors, for example. The pin assignment is compatible with the Ethernet standard (ISO/IEC 8802-3).
Pin | Color of conductor | Signal | Description
1 | yellow | TD + | Transmission Data +
2 | orange | TD - | Transmission Data -
3 | white | RD + | Receiver Data +
6 | blue | RD - | Receiver Data -
Due to automatic cable detection (auto-crossing) symmetric (1:1) or cross-over cables can be used between EtherCAT devices from Beckhoff.
Recommended cables
Suitable cables for the connection of EtherCAT devices can be found on the Beckhoff website!
E-Bus supply
A bus coupler can supply the EL terminals added to it with the E-bus system voltage of 5 V; a coupler is thereby loadable up to 2 A as a rule (see details in respective device documentation).
Information on how much current each EL terminal requires from the E-bus supply is available online and in the catalogue. If the added terminals require more current than the coupler can supply, then power feed terminals (e.g. EL9410) must be inserted at appropriate places in the terminal strand.
The pre-calculated theoretical maximum E-Bus current is displayed in the TwinCAT System Manager. A shortfall is marked by a negative total amount and an exclamation mark; a power feed terminal is to be placed before such a position.
System manager current calculation
Note
Malfunction possible!
The same ground potential must be used for the E-Bus supply of all EtherCAT terminals in a terminal block!


EtherCAT State Machine

Basic principles [image] EtherCAT State Machine
EtherCAT State Machine
The state of the EtherCAT slave is controlled via the EtherCAT State Machine (ESM). Depending upon the state, different functions are accessible or executable in the EtherCAT slave. Specific commands must be sent by the EtherCAT master to the device in each state, particularly during the bootup of the slave.
A distinction is made between the following states:
▪
Init
▪
Pre-Operational
▪
Safe-Operational and
▪
Operational
▪
Boot
The regular state of each EtherCAT slave after bootup is the OP state.
States of the EtherCAT State Machine
Init
After switch-on the EtherCAT slave in the Init state. No mailbox or process data communication is possible. The EtherCAT master initializes sync manager channels 0 and 1 for mailbox communication.
Pre-Operational (Pre-Op)
During the transition between Init and Pre-Op the EtherCAT slave checks whether the mailbox was initialized correctly.
In Pre-Op state mailbox communication is possible, but not process data communication. The EtherCAT master initializes the sync manager channels for process data (from sync manager channel 2), the FMMU channels and, if the slave supports configurable mapping, PDO mapping or the sync manager PDO assignment. In this state the settings for the process data transfer and perhaps terminal-specific parameters that may differ from the default settings are also transferred.
Safe-Operational (Safe-Op)
During transition between Pre-Op and Safe-Op the EtherCAT slave checks whether the sync manager channels for process data communication and, if required, the distributed clocks settings are correct. Before it acknowledges the change of state, the EtherCAT slave copies current input data into the associated DP-RAM areas of the EtherCAT slave controller (ECSC).
In Safe-Op state mailbox and process data communication is possible, although the slave keeps its outputs in a safe state, while the input data are updated cyclically.
Outputs in SAFEOP state
The default set watchdog monitoring sets the outputs of the module in a safe state - depending on the settings in SAFEOP and OP - e.g. in OFF state. If this is prevented by deactivation of the watchdog monitoring in the module, the outputs can be switched or set also in the SAFEOP state.
Operational (Op)
Before the EtherCAT master switches the EtherCAT slave from Safe-Op to Op it must transfer valid output data.
In the Op state the slave copies the output data of the masters to its outputs. Process data and mailbox communication is possible.
Boot
In the Boot state the slave firmware can be updated. The Boot state can only be reached via the Init state.
In the Boot state mailbox communication via the file access over EtherCAT (FoE) protocol is possible, but no other mailbox communication and no process data communication.


CoE - Interface: notes

Basic principles [image] CoE - Interface: notes
CoE - Interface: notes
This device has no CoE.
Detailed information on the CoE interface can be found in the EtherCAT system documentation on the Beckhoff website.


Distributed Clock

Basic principles [image] Distributed Clock
Distributed Clock
The distributed clock represents a local clock in the EtherCAT slave controller (ESC) with the following characteristics:
▪
Unit 1 ns
▪
Zero point 1.1.2000 00:00
▪
Size 64 bit (sufficient for the next 584 years; however, some EtherCAT slaves only offer 32-bit support, i.e. the variable overflows after approx. 4.2 seconds)
▪
The EtherCAT master automatically synchronizes the local clock with the master clock in the EtherCAT bus with a precision of < 100 ns.
For detailed information please refer to the EtherCAT system description.


Product overview

Product overview
Product overview
Additional information
•
Overview of EtherCAT couplers EK18xx
•
EK18xx


Overview of EtherCAT couplers EK18xx

Product overview [image] Overview of EtherCAT couplers EK18xx
Overview of EtherCAT couplers EK18xx
An EtherCAT coupler is required in order to connect EtherCAT Terminals with E-bus-communication (series ELxxxx, ESxxxx, EMxxxx) to an EtherCAT network. This coupler relays the communication from the higher-level EtherCAT network to the terminals, or functions as a master itself and generates telegrams. Beckhoff offers different components for different application scenarios.
The selection of the correct coupler depends on the following criteria:
▪
is a local small controller needed?
▪
is the coupler to be connected via copper cable or optical fiber cable?
▪
is the coupler to be addressed via IP or is it located in the unswitched network?
▪
is the coupler to be controlled via EAP (EtherCAT Automation Protocol) or EtherCAT Device Protocol?
▪
required protection class: IP20 or higher?
▪
is the coupler to be plugged in at different places at the network using the HotConnect technique?
A coupler connects the added terminals to the right; it can be connected to the higher level network to the left. Couplers that support the EtherCAT Device Protocol ‘to the left’ must be connected there to an EtherCAT master.
EtherCAT coupler communication diagram
The following overview can be used for selection:
Characteristic | EK1100 | EK1101 EK1101-0080 | EK1101-0010 | EK1300 | EK1501 | EK1501-0010
Protection class | IP20 | IP20 | IP20 | IP20 | IP20 | IP20
Higher level network technology | 100 MBit FastEthernet (100BASE-TX) | 100 MBit FastEthernet (100BASE-TX) | 100 MBit FastEthernet (100BASE-TX) | 100 MBit FastEthernet (100BASE-TX) | 100 MBit FastEthernet (100BASE-FX) | 100 MBit FastEthernet (100BASE-FX)
Higher level network - max. connection length | 100 m | 100 m | 300 m | 100 m | 2 km | 20 km
Higher level network connection technology | RJ45 | RJ45 | RJ45 | 2 x M8 socket, shielded, screw type, EtherCAT-P-code | SC duplex Multi-mode optical fiber cable | SC duplex Single-mode optical fiber cable
Higher-level network protocol | EtherCAT Device Protocol (formerly Direct Mode) | EtherCAT Device Protocol (formerly Direct Mode) | EtherCAT Device Protocol (formerly Direct Mode) | EtherCAT Device Protocol (to 100BASE-TX EtherCAT P networks) | EtherCAT Device Protocol (formerly Direct Mode) | EtherCAT Device Protocol (formerly Direct Mode)
integrated PLC | - | - | - | - | - | -
supports HotConnect with address setting on the device | - | yes EK1101-0080: Fast-Hot-Connect | - | - | yes | yes
Note | The EK1100 is the "standard" coupler for use directly on the EtherCAT master. |  | Distance between stations: max. 300 m (copper, Cat. 5, 4-wire). | Coupling of EtherCAT Terminals (ELxxxx) to 100BASE-TX EtherCAT P networks |  |
Characteristic | EK1541 | EK18xx | EK9000 | EKx000 | EPxxxx | CX8000
Protection class | IP20 | IP20 | IP20 | IP20 | IP67 | IP20
Higher level network technology | 100 MBit FastEthernet (100BASE-FX) POF | 100 MBit FastEthernet (100BASE-TX) | 100 MBit FastEthernet (100BASE-TX) | diverse see doc. | 100 MBit FastEthernet (100BASE-TX) | 100 MBit FastEthernet (100BASE-TX)
Higher level network - max. connection length | 50 m | 100 m | 100 m | see doc. | 100 m | 100 m
Higher level network connection technology | Versatile Link POF duplex connector Polymeric Optical Fiber | RJ45 | RJ45 | s.Doc | M8 | RJ45
Higher-level network protocol | EtherCAT Device Protocol (formerly Direct Mode) | EtherCAT Device Protocol (formerly Direct Mode) | EAP | see doc. | EtherCAT Device Protocol (formerly Direct Mode) | EtherCAT Device Protocol (formerly Direct Mode)
integrated PLC | - | - | - | - | - | yes
supports HotConnect with address setting on the device | yes | - | - | - | - | -
Note |  | The EK18xx devices integrate a coupler for application directly at the EtherCAT master and digital inputs and outputs without additional wiring. | The EK9000 can be controlled in a switched EtherCAT network with directed IP addressing. | If the EK9000 is provided with another fieldbus connection, this gives rise to the appropriate EKx000 coupler. | Technologically, each EP Box represents a self-contained EtherCAT coupler with internally added I/O functions. | The CX8000 appears to the higher level EtherCAT network as an EtherCAT slave while at the same time managing its attached I/Os as a master.


EK18xx

Product overview [image] EK18xx
EK18xx
Additional information
•
Introduction
•
Technical data
•
Optional distributed clocks support
•
EtherCAT coupler port allocation


Introduction

Product overview [image] EK18xx [image] Introduction
Introduction
EK18xx
EK18xx EtherCAT coupler with digital inputs and outputs
The EK18xx EtherCAT couplers link the EtherCAT device protocol with the EtherCAT Terminals (ELxxxx/ESxxxx/EMxxxx). Depending on the type, they contain a certain number of digital inputs 24 VDC (IEC61131-2 type 3) and outputs 24 VDC; 0.5 A. The coupler in a modern High-Density (HD) housing can be wired using the toolless direct plug-in technique.
One station consists of a coupler, any number of EtherCAT Terminals and a bus end terminal, e.g. EL9011.
The coupler converts the telegrams from Ethernet 100BASE-TX to E-bus signal representation in passing with minimum latency The coupler is connected to the network via the upper Ethernet interface. The lower RJ-45 socket may be used to connect further EtherCAT devices in the same strand.
The coupler supplies the connected terminals with the necessary E-bus current for communication. The coupler can supply a maximum of 5 V/1000 mA. Power feed terminals (e.g. EL9410) must be integrated if more current is required.
In the EtherCAT network, the EK1100 coupler can be installed anywhere in the Ethernet signal transfer section (100BASE-TX). The coupler thereby processes exclusively unaddressed MAC Broadcast telegrams of the type EtherCAT Device Protocol from the EtherCAT master. Since directed addressing via MAC Unicast or IP addressing is not used, neither a switch nor a router can be used.


Technical data

Product overview [image] EK18xx [image] Technical data
Technical data
Technical data | EK1814-0000 | EK1818-0000 | EK1828-0000 | EK1828-0010
Task in the EtherCAT system | Coupling of EtherCAT Terminals (ELxxxx) to 100BASE-TX EtherCAT networks
Number of digital inputs | 4 | 8 | 4 | -
Number of simultaneously controllable inputs, depending on the ambient temperature | 4 (-25 °C ... +60 °C) | 8 (-25 °C ... +55 °C) 4 ( > +55 °C) | 4 (-25 °C ... +60 °C) | -
Number of digital outputs | 4 | 4 | 8 | 8
Number of EtherCAT Terminals | up to 65534 in the overall system
Number of peripheral signals | max. 4.2 GB addressable IO points
Protocol / Baud rate | EtherCAT Device Protocol / 100 MBaud
Cable length between two Bus Couplers | max. 100 m (100BASE-TX)
Transmission medium | at least Ethernet CAT-5 cable
Nominal voltage of the inputs | 24 VDC (-15% / +20%) |  |  | -
Signal voltage “0” | -3 V ... 5 V (EN 61131-2, type 1/3) |  |  | -
Signal voltage “1” | 11 V ... 30 V (EN 61131-2, type 3) |  |  | -
Input filter | 3 ms |  |  | -
Input current | typically 3 mA (EN 61131-2, type 3) |  |  | -
Load type | ohmic, inductive, lamp load
Rated voltage of the outputs | 24 VDC (-15% / +20%)
Switching times | TON: 60 µs typ.; TOFF: 300 µs typ.
Output current per channel | max. 0.5 A (short-circuit-proof)
Short circuit current | < 2 A typ.
Breaking energy (inductive) | max. 150 mJ/channel
Distributed Clocks | no
HotConnect | no
Delay | typical 1 µs
Bus connection | 2 x RJ45
Power supply | 24 VDC (-15%/+20%)
Current consumption from Up | 40 mA + load
Current consumption from Us | 100 mA + (total E-bus current)/4
E-bus power supply (5 V) | max. 1000 mA (in case of higher current consumption, please use additional EL9410 power feed terminals!)
Power contacts | max. 24 VDC, max. 10 A
Electrical isolation | 500 V (power contact/supply voltage/EtherCAT) 500 V (E-bus/field voltage)
Dimensions (W x H x D) | approx. 44 mm x 100 mm x 68 mm
Weight | approx. 125 g
Permissible ambient temperature range during operation | -25 °C ... +60 °C (extended temperature range)
Permissible ambient temperature range during storage | -40 °C ... +85 °C
Permissible relative humidity | 95%, no condensation
Mounting | on 35 mm mounting rail conforms to EN 60715
Vibration/shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation position | variable
Approval | CE cULus


Optional distributed clocks support

Product overview [image] EK18xx [image] Optional distributed clocks support
Optional distributed clocks support
Basic principles Distributed Clocks (DC)
The EtherCAT Distributed Clocks system comprises local clocks that are integrated in the EtherCAT slaves and are synchronized by the EtherCAT master via special datagrams. Not all EtherCAT slaves support the Distributed Clocks procedure. It is only supported by slaves whose function requires it. In the TwinCAT System Manager a slave indicates its DC capability by showing “DC” in the settings dialog.
DC tab for indicating the Distributed Clocks function
Once of these local clocks is the reference clock, based on which all other clocks are synchronized. See also explanatory notes in the Basic EtherCAT documentation. The reference clock must be the first DC-capable EtherCAT slave. By default TwinCAT therefore selects the first DC-capable device as reference clock. This is shown (and can be modified by the user) under advanced properties of the EtherCAT master. The standard setting should not be changed, except in cases where external synchronization is recommended in the relevant documentation, for example.
Advanced Distributed Clocks settings in the EtherCAT master
Fig. Advanced distributed clocks settings in the EtherCAT master illustrates how TwinCAT selects the EL1252 as reference clock by default, since the preceding components do not support DC.
Settings EtherCAT device
System and infrastructure devices such as EK1100 or EK1122 couplers and junction etc. do not require Distributed Clocks to function properly. Nevertheless, it may be topologically expedient to designate the first coupler in an EtherCAT system as reference clock, for example. For this reason, from a certain level the infrastructure components are able to operate as reference clocks, based on special configuration settings.
The components support activation of Distributed Clocks, based on the following table:
Device | XML revision in the configuration | Serial number of the component
BK1150 | from BK1150-0000-0016 | from firmware 01: xxxx01yy
CU1128 | from CU1128-0000-0000 | from firmware 00: xxxx00yy
EK1100 | from EK1100-0000-0017 | from firmware 06: xxxx06yy
EK1101 | from EK1101-0000-0017 | from firmware 01: xxxx01yy
EK1501 | from EK1501-0000-0017 | from firmware 01: xxxx01yy
EK1501-0010 | from EK1501-0010-0017 | from firmware 02: xxxx02yy
EK1122 | from EK1122-0000-0017 | from firmware 01: xxxx02yy
EK1521 | from EK1521-0000-0018 | from firmware 03: xxxx03yy
EK1541 | from EK1541-0000-0016 | from firmware 01: xxxx01yy
EK1561 | from EK1561-0000-0016 | from firmware 01: xxxx01yy
EK1521-0010 | from EK1521-0010-0018 | from firmware 03: xxxx03yy
EK1814 | from EK1814-0000-0016 | from firmware 00: xxxx00yy
Table 1: DC support from rev/firmware version
To ensure that TwinCAT uses such a component as DC reference clock, a manual intervention during the configuration setup is required, as shown here using the EK1100 as an example.
The checkboxes “Cyclic Mode Enable” and “Use as potential Reference Clock” must be set.
TwinCAT setting for using this component as reference clock
Activation of Distributed Clocks support
The (synchronization) procedure described here is only successful for the components described above. The checkboxes can be set for other components, too, although the hardware does not support this function, unless specified in the respective documentation.
In particularly, please note that after commissioning the component may not be replaced with a previous version without DC support.


EtherCAT coupler port allocation

Product overview [image] EK18xx [image] EtherCAT coupler port allocation
EtherCAT coupler port allocation
According to the EtherCAT specification, an ESC (EtherCAT Slave Controller, hardware processing unit of the EtherCAT protocol) can have 1 to 4 ports, which it controls itself. Via an open port it can handle outgoing and incoming Ethernet traffic.
The direction of data flow in a fully wired EK1100 is shown in Fig. Internal and external port assignment for Bus Coupler EK1100:
Example of an EK1100 EtherCAT coupler with 3 ports
The port assignment in the case of the EK1101, EK1501 and EK1501-0010, EK1814 applies accordingly.
Internal and external port assignment EK1100 Bus Coupler
Frame processing sequence
▪
The EtherCAT frame arriving at the EtherCAT signal input is passed on by Port 0 (A) to the EtherCAT processing unit.
▪
The EtherCAT frame arrives at Port 1 (B) and the data frame departs via Port 1 (B) to the following slave in the EtherCAT terminal network (if a slave is connected there and reports "Link").
▪
After the arrival of the data frame at Port 1 (B) from the terminal network, this is passed on to Port 2 (C) and leaves the coupler at the following EtherCAT output (if a slave is connected there and reports "Link").
▪
The data frame arrives at Port 2 (C). This is now passed on to Port 0 (A) and leaves the EK1100 via the EtherCAT input.
Processing of the data
The data in the EtherCAT datagrams are processed only between Ports 0 (A) and 3 (D) in the EtherCAT processing unit. The non-implemented (internal) Port 3 (D) is considered to be closed and passes on the datagram to Port 1 (B).


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Instructions for ESD protection
•
Installation on mounting rails
•
Connection system
•
Positioning of passive Terminals
•
Power supply, potential groups
•
EK18xx - connection


Instructions for ESD protection

Mounting and wiring [image] Instructions for ESD protection
Instructions for ESD protection
Note
Destruction of the devices by electrostatic discharge possible!
The devices contain components at risk from electrostatic discharge caused by improper handling.
•
Please ensure you are electrostatically discharged and avoid touching the contacts of the device directly.
•
Avoid contact with highly insulating materials (synthetic fibers, plastic film etc.).
•
Surroundings (working place, packaging and personnel) should by grounded probably, when handling with the devices.
•
Each assembly must be terminated at the right hand end with an EL9011 or EL9012 bus end cap, to ensure the protection class and ESD protection.
Spring contacts of the Beckhoff I/O components


Installation on mounting rails

Mounting and wiring [image] Installation on mounting rails
Installation on mounting rails
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Assembly
Attaching on mounting rail
The bus coupler and bus terminals are attached to commercially available 35 mm mounting rails (DIN rails according to EN 60715) by applying slight pressure:
1.
First attach the fieldbus coupler to the mounting rail.
2.
The bus terminals are now attached on the right-hand side of the fieldbus coupler. Join the components with tongue and groove and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
If the terminals are clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.
Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail. At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail. To mount the mounting rails with a height of 7.5 mm under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).
Disassembly
Disassembling of terminal
Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
1.
Pull the terminal by its orange-colored lugs approximately 1 cm away from the mounting rail. In doing so for this terminal the mounting rail lock is released automatically and you can pull the terminal out of the bus terminal block easily without excessive force.
2.
Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal out of the bus terminal block.
Connections within a bus terminal block
The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:
▪
The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
▪
The power contacts deal with the supply for the field electronics and thus represent a supply rail within the bus terminal block. The power contacts are supplied via terminals on the Bus Coupler (up to 24 V) or for higher voltages via power feed terminals.
Power Contacts
During the design of a bus terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts. Power Feed Terminals (KL91xx, KL92xx or EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.
PE power contact
The power contact labeled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Power contact on left side
Note
Possible damage of the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a nominal voltage of 230 V). For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.
SmallWarningYellow WARNING
Risk of electric shock!
The PE power contact must not be used for other potentials!


Connection system

Mounting and wiring [image] Connection system
Connection system
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Overview
The Bus Terminal system offers different connection options for optimum adaptation to the respective application:
▪
The terminals of KLxxxx and ELxxxx series with standard wiring include electronics and connection level in a single enclosure.
▪
The terminals of KSxxxx and ESxxxx series feature a pluggable connection level and enable steady wiring while replacing.
▪
The High Density Terminals (HD Terminals) include electronics and connection level in a single enclosure and have advanced packaging density.
Standard wiring
Standard wiring
The terminals of KLxxxx and ELxxxx series have been tried and tested for years.
They feature integrated screwless spring force technology for fast and simple assembly.
Pluggable wiring
Pluggable wiring
The terminals of KSxxxx and ESxxxx series feature a pluggable connection level.
The assembly and wiring procedure for the KS series is the same as for the KLxxxx and ELxxxx series.
The KS/ES series terminals enable the complete wiring to be removed as a plug connector from the top of the housing for servicing.
The lower section can be removed from the terminal block by pulling the unlocking tab.
Insert the new component and plug in the connector with the wiring. This reduces the installation time and eliminates the risk of wires being mixed up.
The familiar dimensions of the terminal only had to be changed slightly. The new connector adds about 3 mm. The maximum height of the terminal remains unchanged.
A tab for strain relief of the cable simplifies assembly in many applications and prevents tangling of individual connection wires when the connector is removed.
Conductor cross sections between 0.08 mm2 and 2.5 mm2 can continue to be used with the proven spring force technology.
The overview and nomenclature of the product names for KSxxxx and ESxxxx series has been retained as known from KLxxxx and ELxxxx series.
High Density Terminals (HD Terminals)
High Density Terminals
The Bus Terminals from these series with 16 connection points are distinguished by a particularly compact design, as the packaging density is twice as large as that of the standard 12 mm Bus Terminals. Massive conductors and conductors with a wire end sleeve can be inserted directly into the spring loaded terminal point without tools.
Wiring HD Terminals
The High Density Terminals of the KLx8xx and ELx8xx series doesn't support steady wiring.
Ultrasonically "bonded" (ultrasonically welded) conductors
Ultrasonically “bonded" conductors
It is also possible to connect the Standard and High Density Terminals with ultrasonically "bonded" (ultrasonically welded) conductors. In this case, please note the tables concerning the wire-size width below!
Wiring
Terminals for standard wiring ELxxxx/KLxxxx and for pluggable wiring ESxxxx/KSxxxx
Mounting a cable on a terminal connection
Up to eight connections enable the connection of solid or finely stranded cables to the Bus Terminals. The terminals are implemented in spring force technology. Connect the cables as follows:
1.
Open a spring-loaded terminal by slightly pushing with a screwdriver or a rod into the square opening above the terminal.
2.
The wire can now be inserted into the round terminal opening without any force.
3.
The terminal closes automatically when the pressure is released, holding the wire securely and permanently.
Terminal housing | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Wire size width | 0.08 ... 2,5 mm2 | 0.08 ... 2.5 mm2
Wire stripping length | 8 ... 9 mm | 9 ... 10 mm
High Density Terminals ELx8xx, KLx8xx (HD)
The conductors of the HD Terminals are connected without tools for single-wire conductors using the direct plug-in technique, i.e. after stripping the wire is simply plugged into the contact point. The cables are released, as usual, using the contact release with the aid of a screwdriver. See the following table for the suitable wire size width.
Terminal housing | High Density Housing
Wire size width (conductors with a wire end sleeve) | 0.14 ... 0.75 mm2
Wire size width (single core wires) | 0.08 ... 1.5 mm2
Wire size width (fine-wire conductors) | 0.25 ... 1.5 mm2
Wire size width (ultrasonically “bonded" conductors) | only 1.5 mm2 (see notice!)
Wire stripping length | 8 ... 9 mm
Shielding
Shielding
Analog sensors and actors should always be connected with shielded, twisted paired wires.


Positioning of passive Terminals

Mounting and wiring [image] Positioning of passive Terminals
Positioning of passive Terminals
Hint for positioning of passive terminals in the bus terminal block
EtherCAT Terminals (ELxxxx / ESxxxx), which do not take an active part in data transfer within the bus terminal block are so called passive terminals. The passive terminals have no current consumption out of the E-Bus.
To ensure an optimal data transfer, you must not directly string together more than 2 passive terminals!
Examples for positioning of passive terminals (highlighted)
Correct positioning
Incorrect positioning


Power supply, potential groups

Mounting and wiring [image] Power supply, potential groups
Power supply, potential groups
Bus Coupler power supply
The Bus Couplers require a 24 VDC supply for their operation. The connection is made by means of the upper spring-loaded terminals labelled 24 V and 0 V. The supply voltage is used by the Bus Coupler electronics and for direct voltage generation for the E-bus. The voltage generation for the E-bus takes place in a DC/DC converter without electrical isolation.
Note
E-bus power supply
The EK18xx units supply the E-bus with max. 1000 mA E-bus current.
Power feed terminals are to be inserted if the added terminals require more current!
Input for power contacts
The connections with spring-loaded terminals can be used for the peripheral supply. The spring-loaded terminals are linked with a power contact. The feed for the power contacts has no connection to the voltage supply for the Bus Coupler. The design of the feed permits voltages of up to 24 V. The current load via the power contacts may not permanently exceed 10 A; the supply line must therefore be protected by a 10 A fuse (slow-blow).
Power contacts
On the right hand face of the Bus Coupler there are two spring contacts for the power contact connections. The spring contacts are hidden in slots so that they can not be accidentally touched. By attaching a Bus Terminal the blade contacts on the left hand side of the Bus Terminal are connected to the spring contacts. The tongue and groove guides on the top and bottom of the Bus Coupler and of the Bus Terminals guarantees that the power contacts mate securely.
The current load of the power contacts may not permanently exceed 10 A.
Electrical isolation
The bus couplers operate by means of three independent potential groups. The supply voltage feeds the E-bus electronics in the bus coupler and the E-bus itself, which are electrically isolated. The supply voltage is also used to generate the operating voltage for the fieldbus.
Note: All the Bus Terminals are electrically isolated from the E-bus. The E-bus is thus electrically isolated from everything else.
Potential connection diagram (example EK1814)
GND concept
GND concept EK18xx
Fuse protection
Coupler supply, fuse 1:
depending on the required current consumption and hence the configured terminals typ. max 500 mA
Calculating the fuse protection
For dimensioning the fuse protection for the system voltage note the calculation of current consumption in the technical data!
Power contacts, fuse 2:
permitted max. 10 A (slow-blow)
Coupler electronics and power contacts can be supplied together from the same source; the fusing must then be dimensioned accordingly to max. 10 A.


EK18xx - connection

Mounting and wiring [image] EK18xx - connection
EK18xx - connection
Additional information
•
EK1814 - connection
•
EK1818 - connection
•
EK1828 - connection
•
EK1828-0010 - connection


EK1814 - connection

Mounting and wiring [image] EK18xx - connection [image] EK1814 - connection
EK1814 - connection
Connection EK1814-0000
Connection
Terminal point |  | Description
Name | No.
Us 24 V | 1 | Power supply for Bus Coupler and E-bus electronics
Input 1 | 2 | Input channel 1
Input 3 | 3 | Input channel 3
n.c. | 4 | not connected
n.c. | 5 | not connected
Up 24 V | 6 | Power supply for the power contacts
Output 1 | 7 | Output channel 1
Output 3 | 8 | Output channel 3
Us 0 V | 9 | Power supply for Bus Coupler and E-bus electronics
Input 2 | 10 | Input channel 2
Input 4 | 11 | Input channel 4
n.c. | 12 | not connected
n.c. | 13 | not connected
Up 0 V | 14 | Power supply for the power contacts
Output 2 | 15 | Output channel 2
Output 4 | 16 | Output channel 4


EK1818 - connection

Mounting and wiring [image] EK18xx - connection [image] EK1818 - connection
EK1818 - connection
Connection EK1818-0000
Connection
Terminal point |  | Description
Name | No.
Us 24 V | 1 | Power supply for Bus Coupler and E-bus electronics
Input 1 | 2 | Input channel 1
Input 3 | 3 | Input channel 3
Input 5 | 4 | Input channel 5
Input 7 | 5 | Input channel 7
Up 24 V | 6 | Power supply for the power contacts
Output 1 | 7 | Output channel 1
Output 3 | 8 | Output channel 3
Us 0 V | 9 | Power supply for Bus Coupler and E-bus electronics
Input 2 | 10 | Input channel 2
Input 4 | 11 | Input channel 4
Input 6 | 12 | Input channel 6
Input 8 | 13 | Input channel 8
Up 0 V | 14 | Power supply for the power contacts
Output 2 | 15 | Output channel 2
Output 4 | 16 | Output channel 4


EK1828 - connection

Mounting and wiring [image] EK18xx - connection [image] EK1828 - connection
EK1828 - connection
Connection EK1828-0000
Connection
Terminal point |  | Description
Name | No.
Us 24 V | 1 | Power supply for Bus Coupler and E-bus electronics
Input 1 | 2 | Input channel 1
Input 3 | 3 | Input channel 3
Output 1 | 4 | Output channel 1
Output 3 | 5 | Output channel 3
Up 24 V | 6 | Power supply for the power contacts
Output 5 | 7 | Output channel 5
Output 7 | 8 | Output channel 7
Us 0 V | 9 | Power supply for Bus Coupler and E-bus electronics
Input 2 | 10 | Input channel 2
Input 4 | 11 | Input channel 4
Output 2 | 12 | Output channel 2
Output 4 | 13 | Output channel 4
Up 0 V | 14 | Power supply for the power contacts
Output 6 | 15 | Output channel 6
Output 8 | 16 | Output channel 8


EK1828-0010 - connection

Mounting and wiring [image] EK18xx - connection [image] EK1828-0010 - connection
EK1828-0010 - connection
Connection EK1828-0010
Connection
Terminal point |  | Description
Name | No.
Us 24 V | 1 | Power supply for Bus Coupler and E-bus electronics
n.c. | 2 | not connected
n.c. | 3 | not connected
Output 1 | 4 | Output channel 1
Output 3 | 5 | Output channel 3
Up 24 V | 6 | Power supply for the power contacts
Output 5 | 7 | Output channel 5
Output 7 | 8 | Output channel 7
Us 0 V | 9 | Power supply for Bus Coupler and E-bus electronics
n.c. | 10 | not connected
n.c. | 11 | not connected
Output 2 | 12 | Output channel 2
Output 4 | 13 | Output channel 4
Up 0 V | 14 | Power supply for the power contacts
Output 6 | 15 | Output channel 6
Output 8 | 16 | Output channel 8


Parameterization and commissioning

Parameterization and commissioning
Parameterization and commissioning
Additional information
•
Configuration overview
•
Overview of process data


Configuration overview

Parameterization and commissioning [image] Configuration overview
Configuration overview
More detailed information on the configuration settings can be found in the EtherCAT system documentation on the Beckhoff website.


Overview of process data

Parameterization and commissioning [image] Overview of process data
Overview of process data
In the TwinCAT System Manager, enter the EK18xx as an EtherCAT (Direct mode) device in Config mode under Devices. If the Bus Coupler is already connected to the network, it can be read. This will cause all the Bus Couplers with Bus Terminals and their configurations to be loaded. You can then adapt these to meet your requirements.
Additional information
•
EK1814
•
EK1818
•
EK1828
•
EK1828-0010


EK1814

Parameterization and commissioning [image] Overview of process data [image] EK1814
EK1814
TwinCAT tree EK1814
Extent of process data EK1814
Extent of process data EK1814 TwinCAT
Extent of process data EK1814 TwinCAT
PDO Assignment EK1814
SM1, PDO Assignment 0x1C11
Index | Size (byte.bit) | Name | PDO content
0x1A00 | 0.1 | Channel 1 | Index 0x6000:01 - Input
0x1A01 | 0.1 | Channel 2 | Index 0x6010:01 - Input
0x1A02 | 0.1 | Channel 3 | Index 0x6020:01 - Input
0x1A03 | 0.1 | Channel 4 | Index 0x6030:01 - Input
SM0, PDO Assignment 0x1C10
Index | Size (byte.bit) | Name | PDO content
0x1608 | 0.1 | Channel 5 | Index 0x7080:01 - Output
0x1609 | 0.1 | Channel 6 | Index 0x7090:01 - Output
0x160A | 0.1 | Channel 7 | Index 0x70A0:01 - Output
0x160B | 0.1 | Channel 8 | Index 0x70B0:01 - Output
Table 1 + 2: PDO assignment of the SyncManagers EK1814


EK1818

Parameterization and commissioning [image] Overview of process data [image] EK1818
EK1818
TwinCAT tree EK1818
Extent of process data EK1818
Extent of process data EK1818 TwinCAT
Extent of process data EK1818 TwinCAT
PDO Assignment EK1818
SM1, PDO Assignment 0x1C11
Index | Size (byte.bit) | Name | PDO content
0x1A00 | 0.1 | Channel 1 | Index 0x6000:01 - Input
0x1A01 | 0.1 | Channel 2 | Index 0x6010:01 - Input
0x1A02 | 0.1 | Channel 3 | Index 0x6020:01 - Input
0x1A03 | 0.1 | Channel 4 | Index 0x6030:01 - Input
0x1A04 | 0.1 | Channel 5 | Index 0x6040:01 - Input
0x1A05 | 0.1 | Channel 6 | Index 0x6050:01 - Input
0x1A06 | 0.1 | Channel 7 | Index 0x6060:01 - Input
0x1A07 | 0.1 | Channel 8 | Index 0x6070:01 - Input
SM0, PDO Assignment 0x1C10
Index | Size (byte.bit) | Name | PDO content
0x1600 | 0.1 | Channel 9 | Index 0x7000:01 - Output
0x1601 | 0.1 | Channel 10 | Index 0x7010:01 - Output
0x1602 | 0.1 | Channel 11 | Index 0x7020:01 - Output
0x1603 | 0.1 | Channel 12 | Index 0x7030:01 - Output
Table 3 + 4: PDO assignment of the SyncManagers EK1818


EK1828

Parameterization and commissioning [image] Overview of process data [image] EK1828
EK1828
TwinCAT tree EK1828
Extent of process data EK1828
Extent of process data EK1828 TwinCAT
Extent of process data EK1828 TwinCAT
Extent of process data EK1828 TwinCAT
PDO Assignment EK1828
SM2, PDO assignment 0x1C12
Index | Size (byte.bit) | Name | PDO content
0x1A00 | 0.1 | Channel 1 | Index 0x6000:01 - Input
0x1A01 | 0.1 | Channel 2 | Index 0x6010:01 - Input
0x1A02 | 0.1 | Channel 3 | Index 0x6020:01 - Input
0x1A03 | 0.1 | Channel 4 | Index 0x6030:01 - Input
SM0, PDO Assignment 0x1C10
Index | Size (byte.bit) | Name | PDO content
0x1600 | 0.1 | Channel 5 | Index 0x7000:01 - Output
0x1601 | 0.1 | Channel 6 | Index 0x7010:01 - Output
0x1602 | 0.1 | Channel 7 | Index 0x7020:01 - Output
0x1603 | 0.1 | Channel 8 | Index 0x7030:01 - Output
SM1, PDO Assignment 0x1C11
Index | Size (byte.bit) | Name | PDO content
0x1604 | 0.1 | Channel 9 | Index 0x7040:01 - Output
0x1605 | 0.1 | Channel 10 | Index 0x7050:01 - Output
0x1606 | 0.1 | Channel 11 | Index 0x7060:01 - Output
0x1607 | 0.1 | Channel 12 | Index 0x7070:01 - Output
Table 5 + 6 + 7: Sync Manager PDO assignment EK1828


EK1828-0010

Parameterization and commissioning [image] Overview of process data [image] EK1828-0010
EK1828-0010
TwinCAT tree EK1828-0010
Extent of process data EK1828-0010
Extent of process data EK1828-0010 TwinCAT
Extent of process data EK1828-0010 TwinCAT
PDO Assignment EK1828-0010
SM0, PDO Assignment 0x1C10
Index | Size (byte.bit) | Name | PDO content
0x1600 | 0.1 | Channel 1 | Index 0x7000:01 - Output
0x1601 | 0.1 | Channel 2 | Index 0x7010:01 - Output
0x1602 | 0.1 | Channel 3 | Index 0x7020:01 - Output
0x1603 | 0.1 | Channel 4 | Index 0x7030:01 - Output
SM1, PDO Assignment 0x1C11
Index | Size (byte.bit) | Name | PDO content
0x1604 | 0.1 | Channel 5 | Index 0x7040:01 - Output
0x1605 | 0.1 | Channel 6 | Index 0x7050:01 - Output
0x1606 | 0.1 | Channel 7 | Index 0x7060:01 - Output
0x1607 | 0.1 | Channel 8 | Index 0x7070:01 - Output
Table 8 + 9 + 10: PDO assignment of the SyncManagers EK1828-0010


Error handling and diagnostics

Error handling and diagnostics
Error handling and diagnostics
Additional information
•
Diagnostic LEDs


Diagnostic LEDs

Error handling and diagnostics [image] Diagnostic LEDs
Diagnostic LEDs
Diagnostic LEDs
LEDs for power supply diagnostics
LED |  | Display | State | Description
Us | green | off | - | No operating voltage present at the Bus Coupler
 |  | on | - | 24 VDC operating voltage present at the Bus Coupler
Up | green | off | - | No power supply present at the power contacts
 |  | on | - | 24 VDC power supply present at the power contacts
Diagnostic LEDs for the EtherCAT State Machine/PLC
LED |  | Display | State | Description
RUN | green | off | Init | The Bus Coupler is in initialization state
 |  | flashing | Pre-Operational | The Bus Coupler is in pre-operational state
 |  | single flash | Safe-Operational | The Bus Coupler is in safe-operational state
 |  | on | Operational | The Bus Coupler is in operational state
 |  | flickers | Bootstrap | Firmware is being loaded.
LEDs for fieldbus diagnostics
LED |  | Display | State | Description
LINK / ACT (X1 IN) | green | off | - | No connection on the incoming EtherCAT strand
 |  | on | linked | Preceding EtherCAT device connected
 |  | flashing | active | Communication with preceding EtherCAT device
LINK / ACT (X2 OUT) | green | off | - | No connection on the incoming EtherCAT strand
 |  | on | linked | Following EtherCAT device connected
 |  | flashing | active | Communication with following EtherCAT device
LINK / ACT E-bus | green | off | - | no connection to internal E-bus
 |  | on | linked | Connection to internal E-bus
 |  | flashing | active | Connection/communication internal E-bus
LEDs for diagnostics of the digital inputs and outputs
LED |  | Display | Description
INPUT** | green | off | Signal voltage "0" (-3 V ... 5 V)
 |  | on | Signal voltage "1" (11 V ... 30 V)
OUTPUT** | green | off | No output signal
 |  | on | 24 VDC output signal at the respective output
**) depending on version


Appendix

Appendix
Appendix
Additional information
•
UL notice
•
Firmware compatibility
•
Firmware Update EL/ES/EM/ELM/EPxxxx
•
Support and Service


UL notice

Appendix [image] UL notice
UL notice
culus-logo
Application
Beckhoff EtherCAT modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
culus-logo
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
culus-logo
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
Basic principles
UL certification according to UL508. Devices with this kind of certification are marked by this sign:


Firmware compatibility

Appendix [image] Firmware compatibility
Firmware compatibility
The EK18xx couplers have no firmware.
An update of the XML device description is described in chapter "Updating the device description", depending on the hardware version and the revision number shown below.
Note
Malfunction possible!
Note the information regarding XML update on the separate page.
Ensure that the XML device description is suitable for the hardware version of the device!
EK1814
Hardware (HW) | Revision no..
00 | EK1814-0000-0016
01 | EK1814-0000-0017
02
03 | EK1814-0000-0018
04
05
06 | EK1814-0000-0019*
07
08
09
10*
EK1818
Hardware (HW) | Revision no..
00 | EK1818-0000-0016
01
02
03 | EK1818-0000-0017
04
05
06 | EK1818-0000-0018*
07
08
09
10
11*
EK1828
Hardware (HW) | Revision no..
02 | EK1828-0000-0017
03
04
05
06 | EK1828-0000-0018*
07
08*
EK1828-0010
Hardware (HW) | Revision no..
02 | EK1828-0010-0017
03
04
05 | EK1828-0010-0018*
06*
*) This is the current compatible revision/hardware version at the time of the preparing this documentation. Check on the Beckhoff web page whether more up-to-date documentation is available.


Firmware Update EL/ES/EM/ELM/EPxxxx

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx
Firmware Update EL/ES/EM/ELM/EPxxxx
This section describes the device update for Beckhoff EtherCAT slaves from the EL/ES, ELM, EM, EK and EP series. A firmware update should only be carried out after consultation with Beckhoff support.
Storage locations
An EtherCAT slave stores operating data in up to 3 locations:
▪
Depending on functionality and performance EtherCAT slaves have one or several local controllers for processing I/O data. The corresponding program is the so-called firmware in *.efw format.
▪
In some EtherCAT slaves the EtherCAT communication may also be integrated in these controllers. In this case the controller is usually a so-called FPGA chip with *.rbf firmware.
▪
In addition, each EtherCAT slave has a memory chip, a so-called ESI-EEPROM, for storing its own device description (ESI: EtherCAT Slave Information). On power-up this description is loaded and the EtherCAT communication is set up accordingly. The device description is available from the download area of the Beckhoff website at (https://www.beckhoff.de). All ESI files are accessible there as zip files.
Customers can access the data via the EtherCAT fieldbus and its communication mechanisms. Acyclic mailbox communication or register access to the ESC is used for updating or reading of these data.
The TwinCAT System Manager offers mechanisms for programming all 3 parts with new data, if the slave is set up for this purpose. Generally the slave does not check whether the new data are suitable, i.e. it may no longer be able to operate if the data are unsuitable.
Simplified update by bundle firmware
The update using so-called bundle firmware is more convenient: in this case the controller firmware and the ESI description are combined in a *.efw file; during the update both the firmware and the ESI are changed in the terminal. For this to happen it is necessary
▪
for the firmware to be in a packed format: recognizable by the file name, which also contains the revision number, e.g. ELxxxx-xxxx_REV0016_SW01.efw
▪
for password=1 to be entered in the download dialog. If password=0 (default setting) only the firmware update is carried out, without an ESI update.
▪
for the device to support this function. The function usually cannot be retrofitted; it is a component of many new developments from year of manufacture 2016.
Following the update, its success should be verified
▪
ESI/Revision: e.g. by means of an online scan in TwinCAT ConfigMode/FreeRun – this is a convenient way to determine the revision
▪
Firmware: e.g. by looking in the online CoE of the device
Note
Risk of damage to the device!
Note the following when downloading new device files

• Firmware downloads to an EtherCAT device must not be interrupted
• Flawless EtherCAT communication must be ensured. CRC errors or LostFrames must be avoided.
• The power supply must adequately dimensioned. The signal level must meet the specification.

In the event of malfunctions during the update process the EtherCAT device may become unusable and require re-commissioning by the manufacturer.
Additional information
•
Device description ESI file/XML
•
Firmware explanation
•
Updating controller firmware *.efw
•
FPGA firmware *.rbf
•
Simultaneous updating of several EtherCAT devices


Device description ESI file/XML

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Device description ESI file/XML
Device description ESI file/XML
Note
Attention regarding update of the ESI description/EEPROM
Some slaves have stored calibration and configuration data from the production in the EEPROM. These are irretrievably overwritten during an update.
The ESI device description is stored locally on the slave and loaded on start-up. Each device description has a unique identifier consisting of slave name (9 characters/digits) and a revision number (4 digits). Each slave configured in the System Manager shows its identifier in the EtherCAT tab:
Device identifier consisting of name EL3204-0000 and revision -0016
The configured identifier must be compatible with the actual device description used as hardware, i.e. the description which the slave has loaded on start-up (in this case EL3204). Normally the configured revision must be the same or lower than that actually present in the terminal network.
For further information on this, please refer to the EtherCAT system documentation.
Update of XML/ESI description
The device revision is closely linked to the firmware and hardware used. Incompatible combinations lead to malfunctions or even final shutdown of the device. Corresponding updates should only be carried out in consultation with Beckhoff support.
Display of ESI slave identifier
The simplest way to ascertain compliance of configured and actual device description is to scan the EtherCAT boxes in TwinCAT mode Config/FreeRun:
Scan the subordinate field by right-clicking on the EtherCAT device
If the found field matches the configured field, the display shows
Configuration is identical
otherwise a change dialog appears for entering the actual data in the configuration.
Change dialog
In this example in Fig. Change dialog, an EL3201-0000-0017 was found, while an EL3201-0000-0016 was configured. In this case the configuration can be adapted with the Copy Before button. The Extended Information checkbox must be set in order to display the revision.
Changing the ESI slave identifier
The ESI/EEPROM identifier can be updated as follows under TwinCAT:
▪
Trouble-free EtherCAT communication must be established with the slave.
▪
The state of the slave is irrelevant.
▪
Right-clicking on the slave in the online display opens the EEPROM Update dialog, Fig. EEPROM Update
EEPROM Update
The new ESI description is selected in the following dialog, see Fig. Selecting the new ESI. The checkbox Show Hidden Devices also displays older, normally hidden versions of a slave.
Selecting the new ESI
A progress bar in the System Manager shows the progress. Data are first written, then verified.
The change only takes effect after a restart.
Most EtherCAT devices read a modified ESI description immediately or after startup from the INIT. Some communication settings such as distributed clocks are only read during power-on. The EtherCAT slave therefore has to be switched off briefly in order for the change to take effect.


Firmware explanation

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Firmware explanation
Firmware explanation
Determining the firmware version
Determining the version on laser inscription
Beckhoff EtherCAT slaves feature serial numbers applied by laser. The serial number has the following structure: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with ser. no.: 12 10 03 02:
12 - week of production 12
10 - year of production 2010
03 - firmware version 03
02 - hardware version 02
Determining the version via the System Manager
The TwinCAT System Manager shows the version of the controller firmware if the master can access the slave online. Click on the E-Bus Terminal whose controller firmware you want to check (in the example terminal 2 (EL3204)) and select the tab CoE Online (CAN over EtherCAT).
CoE Online and Offline CoE
Two CoE directories are available:
• online: This is offered in the EtherCAT slave by the controller, if the EtherCAT slave supports this. This CoE directory can only be displayed if a slave is connected and operational.
• offline: The EtherCAT Slave Information ESI/XML may contain the default content of the CoE. This CoE directory can only be displayed if it is included in the ESI (e.g. "Beckhoff EL5xxx.xml").
The Advanced button must be used for switching between the two views.
In Fig. Display of EL3204 firmware version the firmware version of the selected EL3204 is shown as 03 in CoE entry 0x100A.
Display of EL3204 firmware version
In (A) TwinCAT 2.11 shows that the Online CoE directory is currently displayed. If this is not the case, the Online directory can be loaded via the Online option in Advanced Settings (B) and double-clicking on AllObjects.


Updating controller firmware *.efw

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Updating controller firmware *.efw
Updating controller firmware *.efw
CoE directory
The Online CoE directory is managed by the controller and stored in a dedicated EEPROM, which is generally not changed during a firmware update.
Switch to the Online tab to update the controller firmware of a slave, see Fig. Firmware Update.
Firmware Update
Proceed as follows, unless instructed otherwise by Beckhoff support. Valid for TwinCAT 2 and 3 as EtherCAT master.
▪
Switch TwinCAT system to ConfigMode/FreeRun with cycle time >= 1 ms (default in ConfigMode is 4 ms). A FW-Update during real time operation is not recommended.
▪
Switch EtherCAT Master to PreOP
▪
Switch slave to INIT (A)
▪
Switch slave to BOOTSTRAP
▪
Check the current status (B, C)
▪
Download the new *efw file (wait until it ends). A pass word will not be neccessary usually.
▪
After the download switch to INIT, then PreOP
▪
Switch off the slave briefly (don't pull under voltage!)
▪
Check within CoE 0x100A, if the FW status was correctly overtaken.


FPGA firmware *.rbf

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] FPGA firmware *.rbf
FPGA firmware *.rbf
If an FPGA chip deals with the EtherCAT communication an update may be accomplished via an *.rbf file.
▪
Controller firmware for processing I/O signals
▪
FPGA firmware for EtherCAT communication (only for terminals with FPGA)
The firmware version number included in the terminal serial number contains both firmware components. If one of these firmware components is modified this version number is updated.
Determining the version via the System Manager
The TwinCAT System Manager indicates the FPGA firmware version. Click on the Ethernet card of your EtherCAT strand (Device 2 in the example) and select the Online tab.
The Reg:0002 column indicates the firmware version of the individual EtherCAT devices in hexadecimal and decimal representation.
FPGA firmware version definition
If the column Reg:0002 is not displayed, right-click the table header and select Properties in the context menu.
Context menu Properties
The Advanced Settings dialog appears where the columns to be displayed can be selected. Under Diagnosis/Online View select the '0002 ETxxxx Build' check box in order to activate the FPGA firmware version display.
Dialog Advanced Settings
Update
For updating the FPGA firmware
▪
of an EtherCAT coupler the coupler must have FPGA firmware version 11 or higher;
▪
of an E-Bus Terminal the terminal must have FPGA firmware version 10 or higher.
Older firmware versions can only be updated by the manufacturer!
Updating an EtherCAT device
The following sequence order have to be met if no other specifications are given (e.g. by the Beckhoff support):
▪
Switch TwinCAT system to ConfigMode/FreeRun with cycle time >= 1 ms (default in ConfigMode is 4 ms). A FW-Update during real time operation is not recommended.
▪
In the TwinCAT System Manager select the terminal for which the FPGA firmware is to be updated (in the example: Terminal 5: EL5001) and
click the Advanced Settings button in the EtherCAT tab:
▪
The Advanced Settings dialog appears. Under ESC Access/E²PROM/FPGA click on Write FPGA button:
▪
Select the file (*.rbf) with the new FPGA firmware, and transfer it to the EtherCAT device:
▪
Wait until download ends
▪
Switch slave current less for a short time (don't pull under voltage!). In order to activate the new FPGA firmware a restart (switching the power supply off and on again) of the EtherCAT device is required.
▪
Check the new FPGA status
Note
Risk of damage to the device!
A download of firmware to an EtherCAT device must not be interrupted in any case! If you interrupt this process by switching off power supply or disconnecting the Ethernet link, the EtherCAT device can only be recommissioned by the manufacturer!


Simultaneous updating of several EtherCAT devices

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Simultaneous updating of several EtherCAT devices
Simultaneous updating of several EtherCAT devices
The firmware and ESI descriptions of several devices can be updated simultaneously, provided the devices have the same firmware file/ESI.
Multiple selection and firmware update
Select the required slaves and carry out the firmware update in BOOTSTRAP mode as described above.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com