EK1122, EK15xx - EtherCAT Junctions
Home


Overview EtherCAT Junctions

Overview EtherCAT Junctions
Overview EtherCAT Junctions
Connection RJ45
EK1122 - 2 port EtherCAT junction
EK1122-0080 - 2 port EtherCAT junction, Fast-Hot-Connect
Connection M8
EK1122-0008 - 2 port EtherCAT junction
Connection Fiber optic
EK1521 - 1 port EtherCAT multimode fiber optic junction
EK1521-0010 - 1 port EtherCAT singlemode fiber optic junction
Connection Polymeric Optical Fiber
EK1561 - 1 port EtherCAT polymeric optical fiber junction


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status
•
Version identification of EtherCAT devices


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC® and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, DE102004044764, DE102007017835 with corresponding applications or registrations in various other countries.
The TwinCAT Technology is covered, including but not limited to the following patent applications and patents: EP0851348, US6167425 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Modifications
3.4
▪
Update chapter "Technical data"
▪
Update structure
3.3
▪
Update chapter "Notes on the documentation"
▪
Update chapter "Technical data"
▪
Addenda chapter "Instructions for ESD protection"
▪
Chapter "ATEX - Special conditions" replaced with chapter "ATEX - Special conditions (extended temperature range)"
3.2
▪
Corrections within chapter “Technical data”
3.1
▪
Corrections within chapter “Basic function principles of EtherCAT junctions”
3.0
▪
Addenda of EK1122-0008 (EtherCAT coupler, with M8 sockets);
▪
Migration
2.4
▪
Update chapter "Mounting and wiring"
▪
Update chapter "Technical data"
▪
Update structure
2.3
▪
Update Technical data
2.2
▪
Update Technical data
2.1
▪
Addenda chapter "Optional DC support"
2.0
▪
Addenda EK1122-0080
1.9
▪
Application notes POF junction added
1.8
▪
EK1561 added
1.7
▪
Update chapter "Diagnostic LEDs"
1.6
▪
Technical notes added, structure adjusted
1.5
▪
EK1521-0010 added
1.4
▪
Note PC plug added
1.3
▪
Port assignment added
1.2
▪
Addenda technical notes
1.1
▪
Technical description added
1.0
▪
First public issue
0.1
▪
Preliminary version


Version identification of EtherCAT devices

Foreword [image] Version identification of EtherCAT devices
Version identification of EtherCAT devices
Designation
A Beckhoff EtherCAT device has a 14-digit designation, made up of
▪
family key
▪
type
▪
version
▪
revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
Notes
▪
The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
▪
EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
▪
The order identifier is made up of
- family key (EL, EP, CU, ES, KL, CX, etc.)
- type (3314)
- version (-0000)
▪
The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
▪
The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Identification number
Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:
Production lot/batch number/serial number/date code/D number
The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02
Exceptions can occur in the IP67 area, where the following syntax can be used (see respective device documentation):
Syntax: D ww yy x y z u
D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB
Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1
Unique serial number/ID, ID number
In addition, in some series each individual module has its own unique serial number.
See also the further documentation in the area
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Terminals with factory calibration certificate and other measuring terminals
Examples of markings
EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
CU2016 switch with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
EP1258-00001 IP67 EtherCAT Box with batch number/ date code 22090101 and unique serial number 158102
EP1908-0002 IP67 EtherCAT Safety Box with batch number/ date code 071201FF and unique serial number 00346070
EL2904 IP20 safety terminal with batch number/ date code 50110302 and unique serial number 00331701
ELM3604-0002 terminal with unique ID number (QR code) 100001051 and serial/ batch number 44160201


Product overview

Product overview
Product overview
Additional information
•
Junction with RJ45 connection
•
Junctions with M8 connection
•
Junctions with fiber optic connection
•
Junctions with POF connection


Junction with RJ45 connection

Product overview [image] Junction with RJ45 connection
Junction with RJ45 connection
Additional information
•
EK1122, EK1122-0080


EK1122, EK1122-0080

Product overview [image] Junction with RJ45 connection [image] EK1122, EK1122-0080
EK1122, EK1122-0080
Additional information
•
EK1122, EK1122-0080 - Introduction
•
Technical data
•
Notes re. EtherCAT Fast Hot Connect technology


EK1122, EK1122-0080 - Introduction

Product overview [image] Junction with RJ45 connection [image] EK1122, EK1122-0080 [image] EK1122, EK1122-0080 - Introduction
EK1122, EK1122-0080 - Introduction
EK1122-xxxx
EK1122-0000
The 2-port EtherCAT junction enables configuration of EtherCAT star topologies. A modular EtherCAT star hub can be realized by using several EK1122 units in a station. Individual devices or complete EtherCAT strands can be connected at the junction ports. The EtherCAT junctions are connected via RJ-45 sockets with direct display of link and activity status. The Run LED indicates the status of the EK1122. Through TwinCAT and other suitable EtherCAT masters the EK1122 also supports coupling and uncoupling of EtherCAT strands during operation (hot connect).
EK1122-0080
Hot Connect is an EtherCAT feature for changing topologies through direct coupling or uncoupling during operation. Coupled EtherCAT components are already quickly linked to the data communication after connection as standard. Fast hot-connect technology further reduces the connection time significantly, enabling even faster tool changes. Fast hot-connect ports may only be connected to each other, which is why they are specially identified.
The EK1122-0080 EtherCAT junction with Fast Hot Connect is complemented by the EK1101-0080 EtherCAT coupler with Fast Hot Connect.
Fast Hot Connect ports at the EK1122-0080
In contrast to the EK1122, the RJ45 connections of the FHC ports of the EK1122-0080 are marked with a dotted border (see Fig. 2) Explanatory notes can be found in chapter EtherCAT Fast-Hot-Connect.
Fast-Hot-Connect ports at the EK1122-0080
Connection
Terminal point | Description
Designation
X1/X2 | RJ45 connection for EtherCAT networks (100BASE-TX Ethernet signal representation)
Quick links
▪
EtherCAT basics
▪
Notes on Fast Hot Connect
▪
Application notes
▪
Diagnostic LEDs


Technical data

Product overview [image] Junction with RJ45 connection [image] EK1122, EK1122-0080 [image] Technical data
Technical data
Technical data | EK1122 | EK1122-0080
Task within the EtherCAT system | Coupling of EtherCAT junctions | Coupling of EtherCAT junctions, Fast-Hot-Connect technology
Transmission medium | Ethernet 100BASE-TX (min. CAT5)
Cable length between two Bus Couplers | max. 100 m
Protocol / Baud rate | EtherCAT/ 100 Mbaud
Configuration | no address and configuration settings required
Bus connection | 2 x RJ45
Power supply | from E-bus
Current consumption | typ. 220 mA
Dimensions (W x H x D) | approx. 26 mm x 100 mm x 52 mm (width aligned: 23 mm)
Weight | approx. 70 g
Permissible ambient temperature range during operation | -25°C ... +60°C (extended temperature range)
Permissible ambient temperature range during storage | -40°C ... + 85°C
Permissible relative humidity | 95%, no condensation
Mounting | on 35 mm mounting rail conforms to EN 60715
Vibration/shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation position | variable
Approval | CE ATEX cULus


Notes re. EtherCAT Fast Hot Connect technology

Product overview [image] Junction with RJ45 connection [image] EK1122, EK1122-0080 [image] Notes re. EtherCAT Fast Hot Connect technology
Notes re. EtherCAT Fast Hot Connect technology
EtherCAT components that support Fast Hot Connect enable a faster fieldbus boot up following the establishment of a connection. The boot up depends in detail on the number of devices, the topology and activated Distributed Clocks. Whereas the normal establishment of a connection and communication takes several seconds, less than 1 second is possible with FHC components.
Properties and system behavior
▪
Fast Hot Connect is supported from TwinCAT 2.11R3 Build 2221.
▪
Fast Hot Connect ports are specially marked.
Identification of FHC port at EK1122-0080 and EK1101-0080
▪
Standard EtherCAT devices may not be connected to Fast Hot Connect ports. This is to be ensured by measures on the application side, which is easy to implement by means of the topology change that is usually carried out mechanically in such applications.
Recommended combination of Ethernet ports
▪
If corresponding ports are nevertheless connected, a power reset of the devices involved (branch terminal and coupler/box) is required.
▪
With Fast Hot Connect devices the establishment of an Ethernet connection is accelerated compared to the normal Fast Ethernet connection.
If in addition the use of Distributed Clocks functions is omitted in the entire topology, then the resynchronization time of the components is also dispensed with. Group boot up of < 1 second is then possible, from plugging in the Ethernet connection to the OP state.
▪
An incorrect port allocation is detected in the TwinCAT ADS Logger
Configuration
The configuration of Fast Hot Connect groups in the TwinCAT System Manager takes place in exactly the same way as Hot Connect groups, specifying the associated group ID.
Configuration of a Fast Hot Connect group
Corresponding Fast Hot Connect ports are marked red in the TwinCAT System Manager.
Marking in the TwinCAT System Manager
A configuration of FHC groups is possible only if at least 1 corresponding junction is present e.g. EK1122-0080.
Distributed Clocks
If no Distributed Clocks functions are used, this is visible in the master settings by the absence of "DC in use":
DC master setting
This setting is automatically selected by the System Manager if there are no EtherCAT slaves in the configuration in which Distributed Clocks is activated. "DC in use" should not be randomly deactivated by the user, because otherwise these devices will no longer function.


Junctions with M8 connection

Product overview [image] Junctions with M8 connection
Junctions with M8 connection
Additional information
•
EK1122-0008


EK1122-0008

Product overview [image] Junctions with M8 connection [image] EK1122-0008
EK1122-0008
Additional information
•
EK1122-0008 - Introduction
•
Technical data


EK1122-0008 - Introduction

Product overview [image] Junctions with M8 connection [image] EK1122-0008 [image] EK1122-0008 - Introduction
EK1122-0008 - Introduction
EK1122-0008
EK1122-0008
The 2-port EtherCAT junction enables configuration of EtherCAT star topologies. A modular EtherCAT star hub can be realized by using several EK1122 units in a station. Individual devices or complete EtherCAT strands can be connected at the junction ports. Compared to EK1122 the EK1122-0008 has two M8 sockets compatible to the two RJ45 sockets instead. The EtherCAT junctions are connected via M8 sockets. The link and activity status is indicated by separate LEDs at the front. The Run LED indicates the status of the EK1122. With TwinCAT and other appropriate EtherCAT Masters the EK1122-0008 supports coupling and uncoupling of EtherCAT strands during operation (hot connect).
By using respective powerful Ethernet cables e.g. ZK1090-3131-1xxx distances of 100m are also possible via M8.
Connection
Terminal point | Description
Designation
X1 | 2 x M8 socket, shielded
X2
Quick links
▪
EtherCAT basics
▪
Diagnostic LEDs


Technical data

Product overview [image] Junctions with M8 connection [image] EK1122-0008 [image] Technical data
Technical data
Technical data | EK1122-0008
Task within the EtherCAT system | Coupling of EtherCAT junctions via M8
Transmission medium | Ethernet/EtherCAT-cable (min. CAT 5), shielded
Cable length between two stations | 100 m (100BASE-TX)
Protocol / Baud rate | EtherCAT
Configuration | not required
Bus interface | 2 x M8
Delay | approx. 1 µs
Power supply | from E-bus
E-Bus current consumption | typ. 220 mA
E-bus power supply (5 V) (at higher current consumption the EL9410 power feed terminal can be used in addition) | max. 2000 mA (-25°C ... +55°C)
 | max. 1000 mA (> +55°C)
Dimensions (W x H x D) | approx. 26 mm x 100 mm x 52 mm (width aligned: 23 mm)
Weight | approx. 65 g
Permissible ambient temperature range during operation | -25°C ... +60°C (extended temperature range)
Permissible ambient temperature range during storage | -40°C ... + 85°C
Permissible relative humidity | 95%, no condensation
Mounting | on 35 mm mounting rail conforms to EN 60715
Vibration/shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation position | variable
Approval | CE cULus ATEX


Junctions with fiber optic connection

Product overview [image] Junctions with fiber optic connection
Junctions with fiber optic connection
Additional information
•
EK1521
•
EK1521-0010


EK1521

Product overview [image] Junctions with fiber optic connection [image] EK1521
EK1521
Additional information
•
EK1521 - Introduction
•
Technical data


EK1521 - Introduction

Product overview [image] Junctions with fiber optic connection [image] EK1521 [image] EK1521 - Introduction
EK1521 - Introduction
EK1521
In conjunction with an EK1100 EtherCAT coupler, the 1-port EtherCAT multimode fiber optic junction enables conversion from 100Base-TX to 100Base-FX physics (glass fiber). In this way distances of up to 2 km can be bridged in conjunction with the EK1501 EtherCAT Coupler for multimode optical fibers. Even cable redundant systems with optical fiber can be realized using the 1-port EtherCAT multimode fiber optic junction. The run LED shows the status of the EK1521.
Connection
Terminal point | Description
Designation
X1 | SC duplex connector
Quick links
▪
EtherCAT basics
▪
Application notes
▪
Diagnostic LEDs


Technical data

Product overview [image] Junctions with fiber optic connection [image] EK1521 [image] Technical data
Technical data
Technical data | EK1521
Task within the EtherCAT system | Coupling of EtherCAT junctions
Transmission medium | Multimode glass fiber (MM)
Transceiver wavelength | 1300 nm
Cable length between two Bus Couplers | 2,000 m (100BASE-FX) multimode glass fiber
Protocol / Baud rate | All EtherCAT protocols / 100 Mbaud
Configuration | no address and configuration settings required
Bus connection | 1 x SC Duplex connector
Power supply | from E-bus
Current consumption | typ. 350 mA
Dimensions (W x H x D) | approx. 26 mm x 100 mm x 52 mm (width aligned: 23 mm)
Weight | approx. 70 g
Permissible ambient temperature range during operation | -25°C ... +60°C (extended temperature range)
Permissible ambient temperature range during storage | -40°C ... + 85°C
Permissible relative humidity | 95%, no condensation
Mounting | on 35 mm mounting rail conforms to EN 60715
Vibration/shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation position | variable
Approval | CE ATEX cULus


EK1521-0010

Product overview [image] Junctions with fiber optic connection [image] EK1521-0010
EK1521-0010
Additional information
•
EK1521-0010 - Introduction
•
Technical data


EK1521-0010 - Introduction

Product overview [image] Junctions with fiber optic connection [image] EK1521-0010 [image] EK1521-0010 - Introduction
EK1521-0010 - Introduction
EK1521-0010
In conjunction with an EK110x EtherCAT coupler, the 1-port EtherCAT single-mode fiber optic junction enables conversion from 100Base-TX to 100Base-FX physics (glass fiber). In conjunction with the EK1501-0010 EtherCAT coupler for single-mode optical glass fiber, distances of up to 20 km can be bridged. Even cable redundant systems with optical fiber can be realized using the 1-port EtherCAT single-mode fiber optic junction. The run LED shows the status of the EK1521-0010.
Connection
Terminal point | Description
Designation
X1 | SC duplex connector
Quick links
▪
EtherCAT basics
▪
Application notes
▪
Diagnostic LEDs


Technical data

Product overview [image] Junctions with fiber optic connection [image] EK1521-0010 [image] Technical data
Technical data
Technical data | EK1521-0010
Task within the EtherCAT system | Coupling of EtherCAT junctions
Transmission medium | Single mode glass fiber (SM)
Transceiver wavelength | 1300 nm
Cable length between two Bus Couplers | 20,000 m (100BASE-FX) single mode glass fiber
Protocol / Baud rate | All EtherCAT protocols / 100 Mbaud
Configuration | no address and configuration settings required
Bus connection | 1 x SC Duplex connector
Power supply | from E-bus
Current consumption | typ. 350 mA
Dimensions (W x H x D) | approx. 26 mm x 100 mm x 52 mm (width aligned: 23 mm)
Weight | approx. 70 g
Permissible ambient temperature range during operation | -25°C ... +60°C (extended temperature range)
Permissible ambient temperature range during storage | -40°C ... + 85°C
Permissible relative humidity | 95%, no condensation
Mounting | on 35 mm mounting rail conforms to EN 60715
Vibration/shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation position | variable
Approval | CE ATEX cULus


Junctions with POF connection

Product overview [image] Junctions with POF connection
Junctions with POF connection
Additional information
•
EK1561


EK1561

Product overview [image] Junctions with POF connection [image] EK1561
EK1561
Additional information
•
EK1561 - Introduction
•
Technical data


EK1561 - Introduction

Product overview [image] Junctions with POF connection [image] EK1561 [image] EK1561 - Introduction
EK1561 - Introduction
EK1561
In connection with an EK1100 EtherCAT coupler, the EK1561 single-port POF junction makes it possible to convert from 100BASE-TX physics to 100BASE-FX physics (POF - Polymeric Optical Fiber). Distances of up to 50 m between two couplers can be bridged using the EK1561 and the EK1541 EtherCAT coupler for POF. Unlike the glass fiber, the POF fiber is easily wireable in the field. The Run LED indicates the status of the EK1561.
Connection
Terminal point | Description
Designation
X1 | Versatile Link connection for POF duplex connector (ZS1090-0008)
Quick links
▪
EtherCAT basics
▪
Application notes
▪
Diagnostic LEDs


Technical data

Product overview [image] Junctions with POF connection [image] EK1561 [image] Technical data
Technical data
Technical data | EK1561
Task within the EtherCAT system | Coupling of EtherCAT junctions via POF
Transmission medium | Polymeric Optical Fiber
Transceiver wavelength | 650 nm Laser class 1, see note
Cable length between two stations | max. 50 m (100BASE-FX) POF
Protocol / Baud rate | All EtherCAT protocols / 100 Mbaud
Configuration | no address and configuration settings required
Bus connection | 1 x versatile link for POF duplex connector (connector set ZS1090-0008)
Delay | approx. 1 µs
Power supply | from E-bus
E-Bus current consumption | typ. 200 mA
Dimensions (W x H x D) | approx. 26 mm x 100 mm x 52 mm (width aligned: 23 mm)
Weight | approx. 65 g
Permissible ambient temperature range during operation | -25°C ... +60°C (extended temperature range)
Permissible ambient temperature range during storage | -40°C ... + 85°C
Permissible relative humidity | 95%, no condensation
Mounting | on 35 mm mounting rail conforms to EN 60715
Vibration/shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation position | variable
Approval | CE cULus


Basics

Basics
Basics
Additional information
•
Basic function principles of EtherCAT junctions
•
EtherCAT basics
•
EtherCAT cabling – wire-bound
•
General notes for setting the watchdog
•
EtherCAT State Machine
•
CoE - Interface: notes
•
EKxxxx - Optional Distributed Clocks support


Basic function principles of EtherCAT junctions

Basics [image] Basic function principles of EtherCAT junctions
Basic function principles of EtherCAT junctions
Some Beckhoff EtherCAT devices can be used for junctions in the EtherCAT segment. These include EK1122, EK1521, EP1122 or also CU1128. In the following examples only the EK1122 is used. The technical and system characteristics of the other devices are similar. test
EtherCAT handling in the slaves
With EtherCAT as fieldbus protocol a wide range of bus topologies can be used: line, star and tree topology, with redundancy support even ring topology. The simplest topology is the line topology, in which each EtherCAT slave passes the data on to the only next slave; see following Fig. "EtherCAT line topology".
EtherCAT line topology
When using, for example, EK1100 EtherCAT Couplers, a junction and thus a type of tree topology is possible; see following Fig. "Line topology with extensions".
Line topology with extensions
The basic principle is that internally the Ethernet frame(s) with the EtherCAT protocol data continue to be transported in a logical ring:
▪
the EtherCAT master sends the frame on the two outgoing lines of the Ethernet cable
▪
this frame passes each slave once,
▪
is reversed by the last slave in the logical sequence
▪
and is returned to the master through each EtherCAT slave via two return lines of the Ethernet cable without further processing.
At short cycle times in the order of 50 µs at 20,000 Ethernet frames are in transit in the EtherCAT system every second, plus acyclic organizational frames. The master awaits the return of the sent frames, which return the device input data to the master, for example. Telegram transfer between slaves is link-based: An EtherCAT slave will only forward a frame if a 'link' signal to the next device is present. Normally it can be assumed that the downstream device correctly processes each EtherCAT telegram and returns or process it at the end.
The crucial factor for forwarding EtherCAT telegrams is that a link signal is reported only from one slave to the next if both slaves are actually ready for real-time participation in data processing. Specifically, this means that an EtherCAT slave should not open the respective Ethernet port until it is ready to receive and forward an Ethernet frame immediately.
A switch or router is usually used for standard Ethernet traffic forwarding. Any collisions or frame losses are compensated through frame repetition in the higher level protocol layers (e.g. TCP). This mode is generally not used for EtherCAT due to the short cycle times and the real-time requirement. Some Ethernet devices such as special switches, for example, report a link to the remote terminal even if they will only be ready for data processing in a few milliseconds. This behavior is particularly noticeable in media converters from 100Base-TX (copper) to 100Base-Fx (optical fiber), which may report a link to the preceding EtherCAT slave even if the optical fiber connection is interrupted, depending on the setting on the copper side.
Fast link detection is therefore a central component of each ESC (EtherCAT slave controller, hardware processing unit for the EtherCAT protocol). According to the EtherCAT specification an ESC can have and control 1 to 4 ports. Via an open port it can handle outgoing and incoming Ethernet traffic. The direction of data flow in a fully configured ESC is shown in Fig. "Direction of data flow in the ESC" – the data in the EtherCAT datagrams are thereby processed only between Ports 0 (A) and 3 (D) in the EtherCAT processing unit.
Direction of data flow in the ESC
Ideally link detection and therefore port handling in the ESC should be fast enough that lost frame events are avoided even at 100 µs cycle time. Nevertheless, at least one lost frame can never be ruled out if a connection is disconnected while an Ethernet frame is in transit on this line and in the bus segment downstream of the separation point.
Implementation: EL terminal
A standard EtherCAT slave such as a Beckhoff EL terminal has 2 ports:
▪
one for incoming frames (port 0 [A])
▪
and one for outgoing frames (e.g. port [D]).
The other two ports are internally closed in the ESC. An EtherCAT telegram enters the processing unit via port 0 (A)/top and is forwarded to the next slave via port 3 (D)/left, if a link to this port exists - see green arrows. This is the case if a further EL terminal is connected to the right.
If no link exists, the frame is forwarded to port 1(B) via the purple route. This and port 2 (C) have no link and therefore return the frame to port 0 (A), where the frame leaves via the same Ethernet port through which it arrived at the slave. This is the case if the terminal acts as end terminal.
An EtherCAT device with a single port is therefore only of limited use, since it can only be used as end device.
Implementation: EK1100 EtherCAT Coupler
Three of the four available ports in the EK1100 EtherCAT Coupler are used, thus enabling a connection to the right to terminals and via an RJ45 socket to further couplers; cf. Fig. "Line topology with extensions". In the EK1100 the processing unit is not used for process data exchange.
Implementation: EK1122 EtherCAT junction
In the EK1122 all 4 ESC ports can be connected - two via the internal E-bus and two via the RJ45 sockets with Ethernet configuration. In the TwinCAT System Manager the link statuses of ports 0, 1, 2 and 3 are shown by the online display – they are designated there as ports A, B, C and D; see Fig. "Topology display for interrupted line".
Implementation: EK1521 / EK1521-0010 / EK1561 EtherCAT junction
As in the EK1100, three ESC ports can be connected in these junctions: Two via E-bus within the terminal and one via the SC socket/versatile link and optical fiber cable/POF line.
Implementation: CU1128 EtherCAT junction
The CU1128 integrates three ESCs, which means eight ports in total are available to users. The three ESCs are interconnected via E-bus.
Example configuration with EK1122
The following section describes the link characteristics under TwinCAT and its representation in the System Manager.
Example configuration
The TwinCAT online topology shows the wiring scheme, see Fig. "Online Topology". The EK1122 is selected, so that further information is shown. The green bars above the slaves indicate the correct RUN state in all slaves.
Online topology
An error is now generated by disconnecting the connection between the upper RJ45 socket (X1) and the EL3102 device. Within a few µs the ESC in the EK1122 detects the lost link and automatically closes the affected port. This has the effect that the next incoming EtherCAT telegram is immediately forwarded to port D (port 3) and the EL4732. The link is thus missing here and the System Manager marks this in the online display; see following Fig. "Example configuration with interrupted cable".
Example configuration with interrupted cable
The System Manager messages can be interpreted as follows:
▪
Address 1002 - EK1122: "OP LNK:MIS D": The slave is in OP state, although a link is missing at port D (3) that should be present according to the configuration
▪
Address 1003 - EK1100: "INIT NO_COMM": Since communication with this slave is interrupted its state is shown as INIT
▪
Address 1004 - EL3104: ditto
Logger output
The logger output can be displayed in the lower part of the System Manager (Display → Show Logger Output). This may be helpful for diagnostic purposes (for link interruptions and other situations).
In the topology display any slaves affected by interruption are shown with a red border, see the following Fig. "Topology display for interrupted line".
Topology display for interrupted line
In Fig. "Example configuration" and Fig. "Example configuration with interrupted cable" note the display of acyclic frames, see the following Fig. "Comparison of the frame displays in the System Manager".
Comparison of the frame displays in the System Manager
The image on the left shows a small number (2) of acyclic frames sent by the master during the respective second - all slaves are operating properly. The image on the right shows a significant increase (currently 77 acyclic frames/sec): The EtherCAT master has quickly detected that not all slaves are properly taking part in the data exchange. Once the master has located the fault, it continuously tries to restore the connection.
Reconnection
Once the connection has been restored, the EK1122 reports to the master that a link is present again at port D (3). The EtherCAT master will then make its process data available again for this section. One the preparations are complete, it will instruct the EK1122 to re-open port D (3) for regular data exchange. Cyclic and acyclic data traffic with the other EtherCAT slaves continues normally.
External access to EtherCAT diagnostics
The system offers a wide range of options for accessing status and diagnostic information and EtherCAT master functions from the PLC. Almost all information displayed by the System Manager online can also be retrieved via ADS (see figures on this page). System Manager functions can also be triggered via PLC or ADS. Please refer to the relevant sections in the Beckhoff Information System and the notes on EtherCAT diagnostics.


EtherCAT basics

Basics [image] EtherCAT basics
EtherCAT basics
Please refer to the EtherCAT System Documentation for the EtherCAT fieldbus basics.


EtherCAT cabling – wire-bound

Basics [image] EtherCAT cabling – wire-bound
EtherCAT cabling – wire-bound
The cable length between two EtherCAT devices must not exceed 100 m. This results from the FastEthernet technology, which, above all for reasons of signal attenuation over the length of the cable, allows a maximum link length of 5 + 90 + 5 m if cables with appropriate properties are used. See also the Design recommendations for the infrastructure for EtherCAT/Ethernet.
Cables and connectors
For connecting EtherCAT devices only Ethernet connections (cables + plugs) that meet the requirements of at least category 5 (CAt5) according to EN 50173 or ISO/IEC 11801 should be used. EtherCAT uses 4 wires for signal transfer.
EtherCAT uses RJ45 plug connectors, for example. The pin assignment is compatible with the Ethernet standard (ISO/IEC 8802-3).
Pin | Color of conductor | Signal | Description
1 | yellow | TD + | Transmission Data +
2 | orange | TD - | Transmission Data -
3 | white | RD + | Receiver Data +
6 | blue | RD - | Receiver Data -
Due to automatic cable detection (auto-crossing) symmetric (1:1) or cross-over cables can be used between EtherCAT devices from Beckhoff.
Recommended cables
Suitable cables for the connection of EtherCAT devices can be found on the Beckhoff website!
E-Bus supply
A bus coupler can supply the EL terminals added to it with the E-bus system voltage of 5 V; a coupler is thereby loadable up to 2 A as a rule (see details in respective device documentation).
Information on how much current each EL terminal requires from the E-bus supply is available online and in the catalogue. If the added terminals require more current than the coupler can supply, then power feed terminals (e.g. EL9410) must be inserted at appropriate places in the terminal strand.
The pre-calculated theoretical maximum E-Bus current is displayed in the TwinCAT System Manager. A shortfall is marked by a negative total amount and an exclamation mark; a power feed terminal is to be placed before such a position.
System manager current calculation
Note
Malfunction possible!
The same ground potential must be used for the E-Bus supply of all EtherCAT terminals in a terminal block!


General notes for setting the watchdog

Basics [image] General notes for setting the watchdog
General notes for setting the watchdog
ELxxxx terminals are equipped with a safety feature (watchdog) that switches off the outputs after a specifiable time e.g. in the event of an interruption of the process data traffic, depending on the device and settings, e.g. in OFF state.
The EtherCAT slave controller (ESC) in the EL2xxx terminals features 2 watchdogs:
▪
SM watchdog (default: 100 ms)
▪
PDI watchdog (default: 100 ms)
SM watchdog (SyncManager Watchdog)
The SyncManager watchdog is reset after each successful EtherCAT process data communication with the terminal. If no EtherCAT process data communication takes place with the terminal for longer than the set and activated SM watchdog time, e.g. in the event of a line interruption, the watchdog is triggered and the outputs are set to FALSE. The OP state of the terminal is unaffected. The watchdog is only reset after a successful EtherCAT process data access. Set the monitoring time as described below.
The SyncManager watchdog monitors correct and timely process data communication with the ESC from the EtherCAT side.
PDI watchdog (Process Data Watchdog)
If no PDI communication with the EtherCAT slave controller (ESC) takes place for longer than the set and activated PDI watchdog time, this watchdog is triggered.
PDI (Process Data Interface) is the internal interface between the ESC and local processors in the EtherCAT slave, for example. The PDI watchdog can be used to monitor this communication for failure.
The PDI watchdog monitors correct and timely process data communication with the ESC from the application side.
The settings of the SM- and PDI-watchdog must be done for each slave separately in the TwinCAT System Manager.
EtherCAT tab -> Advanced Settings -> Behavior -> Watchdog
Notes:
▪
the multiplier is valid for both watchdogs.
▪
each watchdog has its own timer setting, the outcome of this in summary with the multiplier is a resulting time.
▪
Important: the multiplier/timer setting is only loaded into the slave at the start up, if the checkbox is activated.
If the checkbox is not activated, nothing is downloaded and the ESC settings remain unchanged.
Multiplier
Multiplier
Both watchdogs receive their pulses from the local terminal cycle, divided by the watchdog multiplier:
1/25 MHz * (watchdog multiplier + 2) = 100 µs (for default setting of 2498 for the multiplier)
The standard setting of 1000 for the SM watchdog corresponds to a release time of 100 ms.
The value in multiplier + 2 corresponds to the number of basic 40 ns ticks representing a watchdog tick.
The multiplier can be modified in order to adjust the watchdog time over a larger range.
Example "Set SM watchdog"
This checkbox enables manual setting of the watchdog times. If the outputs are set and the EtherCAT communication is interrupted, the SM watchdog is triggered after the set time and the outputs are erased. This setting can be used for adapting a terminal to a slower EtherCAT master or long cycle times. The default SM watchdog setting is 100 ms. The setting range is 0..65535. Together with a multiplier with a range of 1..65535 this covers a watchdog period between 0..~170 seconds.
Calculation
Multiplier = 2498 → watchdog base time = 1 / 25 MHz * (2498 + 2) = 0.0001 seconds = 100 µs
SM watchdog = 10000 → 10000 * 100 µs = 1 second watchdog monitoring time
SmallWarningYellow CAUTION
Undefined state possible!
The function for switching off of the SM watchdog via SM watchdog = 0 is only implemented in terminals from version -0016. In previous versions this operating mode should not be used.
SmallWarningYellow CAUTION
Damage of devices and undefined state possible!
If the SM watchdog is activated and a value of 0 is entered the watchdog switches off completely. This is the deactivation of the watchdog! Set outputs are NOT set in a safe state, if the communication is interrupted.


EtherCAT State Machine

Basics [image] EtherCAT State Machine
EtherCAT State Machine
The state of the EtherCAT slave is controlled via the EtherCAT State Machine (ESM). Depending upon the state, different functions are accessible or executable in the EtherCAT slave. Specific commands must be sent by the EtherCAT master to the device in each state, particularly during the bootup of the slave.
A distinction is made between the following states:
▪
Init
▪
Pre-Operational
▪
Safe-Operational and
▪
Operational
▪
Boot
The regular state of each EtherCAT slave after bootup is the OP state.
States of the EtherCAT State Machine
Init
After switch-on the EtherCAT slave in the Init state. No mailbox or process data communication is possible. The EtherCAT master initializes sync manager channels 0 and 1 for mailbox communication.
Pre-Operational (Pre-Op)
During the transition between Init and Pre-Op the EtherCAT slave checks whether the mailbox was initialized correctly.
In Pre-Op state mailbox communication is possible, but not process data communication. The EtherCAT master initializes the sync manager channels for process data (from sync manager channel 2), the FMMU channels and, if the slave supports configurable mapping, PDO mapping or the sync manager PDO assignment. In this state the settings for the process data transfer and perhaps terminal-specific parameters that may differ from the default settings are also transferred.
Safe-Operational (Safe-Op)
During transition between Pre-Op and Safe-Op the EtherCAT slave checks whether the sync manager channels for process data communication and, if required, the distributed clocks settings are correct. Before it acknowledges the change of state, the EtherCAT slave copies current input data into the associated DP-RAM areas of the EtherCAT slave controller (ECSC).
In Safe-Op state mailbox and process data communication is possible, although the slave keeps its outputs in a safe state, while the input data are updated cyclically.
Outputs in SAFEOP state
The default set watchdog monitoring sets the outputs of the module in a safe state - depending on the settings in SAFEOP and OP - e.g. in OFF state. If this is prevented by deactivation of the watchdog monitoring in the module, the outputs can be switched or set also in the SAFEOP state.
Operational (Op)
Before the EtherCAT master switches the EtherCAT slave from Safe-Op to Op it must transfer valid output data.
In the Op state the slave copies the output data of the masters to its outputs. Process data and mailbox communication is possible.
Boot
In the Boot state the slave firmware can be updated. The Boot state can only be reached via the Init state.
In the Boot state mailbox communication via the file access over EtherCAT (FoE) protocol is possible, but no other mailbox communication and no process data communication.


CoE - Interface: notes

Basics [image] CoE - Interface: notes
CoE - Interface: notes
This device has no CoE.
Detailed information on the CoE interface can be found in the EtherCAT system documentation on the Beckhoff website.


EKxxxx - Optional Distributed Clocks support

Basics [image] EKxxxx - Optional Distributed Clocks support
EKxxxx - Optional Distributed Clocks support
Basic principles Distributed Clocks (DC)
The EtherCAT Distributed Clocks system comprises local clocks that are integrated in the EtherCAT slaves and are synchronized by the EtherCAT master via special datagrams. Not all EtherCAT slaves support the Distributed Clocks procedure. It is only supported by slaves whose function requires it. In the TwinCAT System Manager a slave indicates its DC capability by showing “DC” in the settings dialog.
DC tab for indicating the Distributed Clocks function
Once of these local clocks is the reference clock, based on which all other clocks are synchronized. See also explanatory notes in the Basic EtherCAT documentation. The reference clock must be the first DC-capable EtherCAT slave. By default TwinCAT therefore selects the first DC-capable device as reference clock. This is shown (and can be modified by the user) under advanced properties of the EtherCAT master. The standard setting should not be changed, except in cases where external synchronization is recommended in the relevant documentation, for example.
Advanced Distributed Clocks settings in the EtherCAT master
The figure shows how TwinCAT selects the EL1252 as reference clock by default, since the preceding components do not support DC.
Settings EtherCAT device
System and infrastructure devices such as EK1100 or EK1122 couplers and junction etc. do not require Distributed Clocks to function properly. Nevertheless, it may be topologically expedient to designate the first coupler in an EtherCAT system as reference clock, for example. For this reason, from a certain level the infrastructure components are able to operate as reference clocks, based on special configuration settings.
According to the following table (DC support from rev/firmware version), the components support activation of distributed clocks:
Device | XML revision in the configuration | Serial number of the component
BK1150 | from BK1150-0000-0016 | from firmware 01: xxxx01yy
CU1128 | from CU1128-0000-0000 | from firmware 00: xxxx00yy
EK1100 | from EK1100-0000-0017 | from firmware 06: xxxx06yy
EK1101 | from EK1101-0000-0017 | from firmware 01: xxxx01yy
EK1501 | from EK1501-0000-0017 | from firmware 01: xxxx01yy
EK1501-0010 | from EK1501-0010-0017 | from firmware 02: xxxx02yy
EK1122 | from EK1122-0000-0017 | from firmware 01: xxxx02yy
EK1521 | from EK1521-0000-0018 | from firmware 03: xxxx03yy
EK1541 | from EK1541-0000-0016 | from firmware 01: xxxx01yy
EK1561 | from EK1561-0000-0016 | from firmware 01: xxxx01yy
EK1521-0010 | from EK1521-0010-0018 | from firmware 03: xxxx03yy
EK1814 | from EK1814-0000-0016 | from firmware 00: xxxx00yy
To ensure that TwinCAT uses such a component as DC reference clock, a manual intervention during the configuration setup is required, as shown here using the EK1100 as an example.
The checkboxes “Cyclic Mode Enable” and “Use as potential Reference Clock” must be set.
TwinCAT setting for using this component as reference clock
Activation of Distributed Clocks support
The (synchronization) procedure described here is only successful for the components described above. The checkboxes can be set for other components, too, although the hardware does not support this function, unless specified in the respective documentation. In particularly, please note that after commissioning the component may not be replaced with a previous version without DC support.


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Instructions for ESD protection
•
M8 Connector Cabling
•
Nut torque for connectors
•
Mounting and demounting - terminals with front unlocking
•
Recommended mounting rails
•
Positioning of passive Terminals
•
ATEX - Special conditions (extended temperature range)
•
ATEX Documentation


Instructions for ESD protection

Mounting and wiring [image] Instructions for ESD protection
Instructions for ESD protection
Note
Destruction of the devices by electrostatic discharge possible!
The devices contain components at risk from electrostatic discharge caused by improper handling.
•
Please ensure you are electrostatically discharged and avoid touching the contacts of the device directly.
•
Avoid contact with highly insulating materials (synthetic fibers, plastic film etc.).
•
Surroundings (working place, packaging and personnel) should by grounded probably, when handling with the devices.
•
Each assembly must be terminated at the right hand end with an EL9011 or EL9012 bus end cap, to ensure the protection class and ESD protection.
Spring contacts of the Beckhoff I/O components


M8 Connector Cabling

Mounting and wiring [image] M8 Connector Cabling
M8 Connector Cabling
A list of the EtherCAT cable, power cable, sensor cable, Ethernet-/EtherCAT connectors and the field assembled connectors can be found at the following link: http://download.beckhoff.com/download/document/catalog/main_catalog/english/Beckhoff_EtherCAT-Box-Accessories.pdf
You can find the corresponding data sheets at the following link: http://beckhoff.de/english/fieldbus_box/data_sheets.htm?id=69033899254355
EtherCAT cable
ZK1090-3131-0xxx
For connecting EtherCAT devices only shielded Ethernet cables that meet the requirements of at least category 5 (CAT5) according to EN 50173 or ISO/IEC 11801 should be used.
Recommendations about cabling
You may get detailed recommendations about cabling EtherCAT from the documentation "Recommendations for the design of the infrastructure for EtherCAT/Ethernet", that is available for download at www.Beckhoff.com.
EtherCAT uses 4 wires for signal transfer.
Due to automatic cable detection (auto-crossing) symmetric (1:1) or cross-over cables can be used between EtherCAT devices from Beckhoff.
M8 Connector pin assignment
Signal | Description | Pin (M8)
Tx+ | Transmit Data+ | 1
Tx- | Transmit Data- | 4
Rx+ | Receive Data+ | 2
Rx- | Receive Data- | 3
Shield | Shielding | Housing


Nut torque for connectors

Mounting and wiring [image] Nut torque for connectors
Nut torque for connectors
X1 and X2 of EK1122-0008
For usage of the EtherCAT connectors M8 of EK1122-0008 the following have to be noticed:
M8 connectors
It is recommended to pull the M8 connectors tight with a nut torque of 0.4 Nm. When using the torque control screwdriver ZB8800 is also a max. torque of 0.5 Nm permissible.
EtherCAT Box with M8 connectors


Mounting and demounting - terminals with front unlocking

Mounting and wiring [image] Mounting and demounting - terminals with front unlocking
Mounting and demounting - terminals with front unlocking
The terminal modules are fastened to the assembly surface with the aid of a 35 mm mounting rail (e.g. mounting rail TH 35-15).
Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail. At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail. To mount the recommended mounting rails under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Mounting
▪
Fit the mounting rail to the planned assembly location.

and press (1) the terminal module against the mounting rail until it latches in place on the mounting rail (2).
▪
Attach the cables.
Demounting
▪
Remove all the cables.
▪
Lever the unlatching hook back with thumb and forefinger (3). An internal mechanism pulls the two latching lugs (3a) from the top hat rail back into the terminal module.
▪
Pull (4) the terminal module away from the mounting surface.
Avoid canting of the module; you should stabilize the module with the other hand, if required.


Recommended mounting rails

Mounting and wiring [image] Recommended mounting rails
Recommended mounting rails
Terminal Modules und EtherCAT Modules of KMxxxx and EMxxxx series, same as the terminals of the EL66xx and EL67xx series can be snapped onto the following recommended mounting rails:
DIN Rail TH 35-7.5 with 1 mm material thickness (according to EN 60715)
DIN Rail TH 35-15 with 1,5 mm material thickness
Pay attention to the material thickness of the DIN Rail
Terminal Modules und EtherCAT Modules of KMxxxx and EMxxxx series, same as the terminals of the EL66xx and EL67xx series does not fit to the DIN Rail TH 35-15 with 2,2 to 2,5 mm material thickness (according to EN 60715)!


Positioning of passive Terminals

Mounting and wiring [image] Positioning of passive Terminals
Positioning of passive Terminals
Hint for positioning of passive terminals in the bus terminal block
EtherCAT Terminals (ELxxxx / ESxxxx), which do not take an active part in data transfer within the bus terminal block are so called passive terminals. The passive terminals have no current consumption out of the E-Bus.
To ensure an optimal data transfer, you must not directly string together more than 2 passive terminals!
Examples for positioning of passive terminals (highlighted)
Correct positioning
Incorrect positioning


ATEX - Special conditions (extended temperature range)

Mounting and wiring [image] ATEX - Special conditions (extended temperature range)
ATEX - Special conditions (extended temperature range)
SmallWarningYellow WARNING
Observe the special conditions for the intended use of Beckhoff fieldbus components with extended temperature range (ET) in potentially explosive areas (directive 94/9/EU)!
•
The certified components are to be installed in a suitable housing that guarantees a protection class of at least IP54 in accordance with EN 60529! The environmental conditions during use are thereby to be taken into account!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of -25 to 60°C for the use of Beckhoff fieldbus components with extended temperature range (ET) in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The individual terminals may only be unplugged or removed from the Bus Terminal system if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The fuses of the KL92xx/EL92xx power feed terminals may only be exchanged if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
Address selectors and ID switches may only be adjusted if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Marking
The Beckhoff fieldbus components with extended temperature range (ET) certified for potentially explosive areas bear the following marking:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: -25 … 60°C
or
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: -25 … 60°C


ATEX Documentation

Mounting and wiring [image] ATEX Documentation
ATEX Documentation
Notes about operation of the Beckhoff terminal systems in potentially explosive areas (ATEX)
Pay also attention to the continuative documentation

Notes about operation of the Beckhoff terminal systems in potentially explosive areas (ATEX)

that is available in the download area of the Beckhoff homepage http:\\www.beckhoff.com!


Commissioning/application notes

Commissioning/application notes
Commissioning/application notes
Mounting rail installation
Mounting
Please ensure that the EK1122 engages properly on the DIN rail. See mounting rail installation and recommended mounting rails.
Additional information
•
Application notes RJ45 junction
•
Application notes M8 junction
•
Application notes fiber optic junction
•
Application notes POF junction
•
Notes regarding assembly of POF cables with the connector set ZS1090-0008


Application notes RJ45 junction

Commissioning/application notes [image] Application notes RJ45 junction
Application notes RJ45 junction
Additional information
•
Settings and port assignment


Settings and port assignment

Commissioning/application notes [image] Application notes RJ45 junction [image] Settings and port assignment
Settings and port assignment
For normal operation the EK1122 can be used with default settings.
The port ID used in the TwinCAT System Manager is mapped on the EK1122 as follows:
EK1122 port ID
Internal and external port assignment for EK1122


Application notes M8 junction

Commissioning/application notes [image] Application notes M8 junction
Application notes M8 junction
Additional information
•
Settings and port assignment


Settings and port assignment

Commissioning/application notes [image] Application notes M8 junction [image] Settings and port assignment
Settings and port assignment
For normal operation no settings are required at the EK1122-0008.
The port ID used in the TwinCAT System Manager is mapped on the EK1122-0008 as follows:
Port ID for EK1122-0008
Internal and external port assignment for EK1122-0008


Application notes fiber optic junction

Commissioning/application notes [image] Application notes fiber optic junction
Application notes fiber optic junction
Mounting rail installation
Mounting
Please ensure that the EK1521, EK1521-0010 engages properly on the DIN rail. See mounting rail installation and recommended mounting rails.
Additional information
•
Settings and port assignment
•
Notes on suitable optical fiber cables
•
Application with EK1521 and EL1521-0010


Settings and port assignment

Commissioning/application notes [image] Application notes fiber optic junction [image] Settings and port assignment
Settings and port assignment
For normal operation the EK1521, EK1521-0010 can be used with default settings.
The port ID used in the TwinCAT System Manager is mapped on the EK1521, EK1521-0010 as follows:
Port ID for EK1521, EK1521-0010
Internal and external port assignment EK1521, EK1521-0010


Notes on suitable optical fiber cables

Commissioning/application notes [image] Application notes fiber optic junction [image] Notes on suitable optical fiber cables
Notes on suitable optical fiber cables
General information on optical fiber types
Optical fiber are available as multimode and single mode types with different step and graded indices.
Step and graded index
Optical fiber cables consist of 2 concentric materials, the core and cladding, plus a protective (colored) jacket. The core and the cladding have a different index of refraction, causing the light waves (modes; a mode is a natural wave in the optical fiber) to be reflected back into the core at the boundary. Due to the step change in the index of refraction this type of fiber is referred to as step index. A gradual/parabolic transition between the index of refraction in the core and the coating (referred to as graded index) can be achieved by mixing the materials. In a graded index fiber the modes are gradually diffracted back to the core, leading to propagation-time compensation and significantly higher quality of the light pulse at the outlet compared with a multimode step index fiber, where the different light modes have different signal run times (mode dispersion) with associated front distortion.
Single mode
Single-mode fibers have a very thin core (9 µm) and therefore conduct only a single mode of the light used, with high signal quality and virtually without mode dispersion. They are only available as step index fibers. Due to the high signal quality they are suitable for large transmission bandwidths > 10 GHz*km and distances > 50 km. The refractive index profile of single-mode fibers is dimensioned such that the multipath propagation (intermodal dispersion), which is a problem with multi-mode fibers, is omitted – the signal light propagates in a single-mode fiber only in a single guided fiber mode, hence the designation ‘single-mode’. This makes considerably larger transmission distances and/or bandwidths possible, and the limiting effect that arises next is the color distortion of the transmitted mode.
Multimode
Multimode fibers are manufactured as step index or graded index. Step index multimode fiber cables are suitable for transmission bandwidths up to 100 MHz*km and distances up to 1 km. Graded index multimode fiber cables with core diameters between 50 and 62.5 µm reach transmission bandwidths > 1 GHz*km and ranges > 10 km. Multimode means that the core of the optical fiber cable is thick enough to enable several light modes to propagate reflectively in the cable.


Application with EK1521 and EL1521-0010

Commissioning/application notes [image] Application notes fiber optic junction [image] Application with EK1521 and EL1521-0010
Application with EK1521 and EL1521-0010
Application with EK1521 and EL1521-0010
The EK1521, EK1521-0010 is intended for application with optical fiber cables with the following characteristics:
▪
SC duplex connector
▪
EK1521: Duplex multimode 50/125 µm or 62.5/125 µm (inner/outer core diameter). The use of both diameters is possible. However, the use of 50/125 µm is recommended due to the lower attenuation.
▪
EK1521-0010: Duplex single-mode 9/125 µm (inner/outer core diameter). A typically usable cable can be manufactured according to the specification ITU-T G.652.D (0.4 dBm/km at 1300 nm).
Recommended connectors
The use of SC/PC connectors is recommended for connecting to the EK1521, EK1521-0010. The advantage of the "PC" (physical contact) version of this connector is the crowned end face, which allows the region of the fiber core that is relevant to transmission to be optimally joined when the connector is pushed together. Other versions include, for instance, the SC/UPC (ultra-polish PC), SC/HRL (high return loss) and the SC/APC plug (angled physical contact). An additional feature of these connectors is that light that is reflected by the connector's end face, which is at an angle of about 8° to the fiber axis, is refracted from the core by the cladding glass into the air. This avoids interference with the data transmission, optimizing the core size of the back-scatter.
50/125 µm or 62.5/125 µm
The use of both diameters is possible. However, the use of 50/125 µm is recommended due to the lower attenuation.
In optical fibers the wavelengths 850 nm and 1300 nm are usually used for data transfer. Commercially available fiber-optic cables are usually optimized for application in one of these ranges, since signal attenuation is frequency-dependent (like in copper cable), so that large ranges of several km can be achieved for the respective wavelength. Fiber-optic cables in the 1300 nm window generally have lower attenuation than cables in the 850 nm window.
In the EK1521, EK1521-0010 a transceiver with the wavelength of 1300 nm is used.
Range and bandwidth product
Optical fiber cables are available in different qualities from reputable manufacturers. One of the relevant parameters for the user is the frequency-dependent bandwidth product of a cable, specified in [MHz*km]. The greater the bandwidth product, the lower the attenuation, and therefore the larger the range that can be achieved with this cable (see ITU-T G-651). For achieving the maximum range with the EK1521, EK1521-0010, optical fibers with a maximum bandwidth product of 1300 nm should therefore be used; we recommended using class OM2 optical fibers (EN50173:2002). Standard optical fiber cables have a minimum bandwidth product of 500 MHz*km at 1300 nm, higher-quality cables are suitable for distances > 500 m over > 1000 MHz*km. In order to achieve the maximum range, the device to which the EK1521, EK1521-0010 is connected must also support such ranges.
Installation notes
•
permitted bending radius
•
permitted tensile strength
•
sensitivity of the exposed contact ends
Further information can be found in the following documents:
▪
ITU recommendation ITU-T G.651 - G.655
▪
EN 50173:2002
▪
EN 60793-2
Connecting and releasing the optical fiber cable at the junction
Note
Risk of damage to the cable!
To disconnect the optical fiber cable always pull the connector to release the locking mechanism - never pull the optical fiber cable itself.
Crossover cables
Not that crossover cables may have to be used for connecting the EK1521, EK1521-0010 with the EK1501/ EK1501-0010.
Practical tip:
The infrared light emission can be made visible via a digital or smartphone camera at the junction or at the coupler (see figure). Avoid 'light meeting light' when connecting the optical fiber cable (Tx → Tx). In this case no connection can be established, and crossover cables must be used (Tx → Rx).

Figure: Visualization of infrared light at the SC duplex connector
Use of blind plugs
To protect the transceiver from environmental influences, unused connection socket should be sealed with the blind plugs provided!

Figure: Blind plugs in unused sockets


Application notes POF junction

Commissioning/application notes [image] Application notes POF junction
Application notes POF junction
Mounting rail installation
Mounting
Please ensure that the EK1561 engages properly on the DIN rail. See mounting rail installation and recommended mounting rails.
Additional information
•
Settings and port assignment
•
Notes regarding suitable POF cables
•
Application with EK1561


Settings and port assignment

Commissioning/application notes [image] Application notes POF junction [image] Settings and port assignment
Settings and port assignment
For normal operation the EK1561 can be used with default settings.
The port ID used in the TwinCAT System Manager is mapped on the EK1561 as follows:
EK1561 port ID
Internal and external port assignment for EK1561


Notes regarding suitable POF cables

Commissioning/application notes [image] Application notes POF junction [image] Notes regarding suitable POF cables
Notes regarding suitable POF cables
General information about POF cables
The standard polymer fiber is 1 mm thick and consists of a 0.98 mm thick core made of polymethyl methacrylate (PMMA) as well as a thin sheath. In order to enable the guidance of light using the effect of total reflection in the core, the usually very thin sheath consists of fluorinated PMMA, which has a low refractive index. The core diameters lie between 0.06 and 1 mm, as a result of which simple plug connections are easy to implement. Furthermore, the splicing process often used for the connection of glass fibers and the unnecessarily high expenditure associated with it can usually be dispensed with. The maximum operating temperature of standard POF is approximately 60 °C and has a refraction profile with step index (SI-POF). The refractive index of the core material is around 1.49 and that of the sheath around 1.41. The difference determines the numerical aperture (NA) and thus the maximum propagation angle. With a difference of 5% this angle is about 20 degrees in relation to the fiber axis, which leads to a reduction in the bandwidth.
Due to the simple and almost universally applicable connection techniques compared to glass fibers, POFs are used in particular for short transmission distances, such as inside rooms, technical equipment, mechanical systems or cars.
POFs have an attenuation of about 140 dB/km at a wavelength of 650 Nm, so that a maximum data transmission distance of 50 m can be achieved when used with the EK1561.
Insertion of additional connectors in the route increases the signal attenuation. For each additional connector, the maximum permitted distances typically reduces by 6.5 m.


Application with EK1561

Commissioning/application notes [image] Application notes POF junction [image] Application with EK1561
Application with EK1561
Recommended connectors and POF cables
For the connection of the EK1561 it is recommended to use the connector set ZS1090-0008 (Versatile Link Duplex connectors) in conjunction with a duplex polymer fiber with an outside diameter of 2 x 2.2 mm (Z1190), which are available from Beckhoff.
Installation notes
•
permissible bending radius (in general r ≥ 25 mm, refer to the manufacturer’s data!)
•
permitted tensile strength
•
sensitivity of the exposed contact ends
Connecting and releasing the POF cable at the junction
To connect the cable, insert the plug (available as an accessory in the plug set ZS1090-0008) into the connection opening until it audibly latches.
Latching lug with release catch on the POF duplex plug
To release the connector activate the release device with the latching lug. This is located on the right-hand side of the connector (see Fig. “Latching lug with release catch at the POF duplex connector”)
Note
Risk of damage to the cable!
To release the cable, press the release catch on the plug and pull the plug at the same time – never pull by the POF cable alone!
Note
TX / Rx channel assignment
During cable assembly note the assignment of the optical channels in the connection socket. In the EK1561, the light-emitting transmitter channel (Tx) is the upper outlet in the connection socket.

Figure: Transmitter channel in the EK1561
Be sure to observe the safety instructions for class 1 lasers!
Note
Use of blind plugs
In order to avoid accidents due to glare (Class 1 laser, please observe the safety instructions) and to protect the transceiver against environmental influences, unused sockets should be sealed using the blind plugs provided!

Figure: Blind plugs in unused sockets


Notes regarding assembly of POF cables with the connector set ZS1090-0008

Commissioning/application notes [image] Notes regarding assembly of POF cables with the connector set ZS1090-0008
Notes regarding assembly of POF cables with the connector set ZS1090-0008
Duplex connector set ZS1090-0008
The duplex connector set ZS1090-0008 from Beckhoff consists of 10 duplex Versatile Link connectors and several sheets of abrasive paper and polishing paper.
Step-by-step instructions for assembling the POF cable
The following step-by-step guide describes the correct assembly of a POF cable with a Versatile Link duplex connector. The connectors are attached to the cable ends with standard tools such as cutter knife or wire strippers. Polish the assembled cable with the polishing set provided with the connector set, consisting of a plastic sanding gauge, sheets of abrasive paper with grain size 600 and pink polishing sheets. Once assembled, the connector can be used right away.
Materials required:
1. POF cable (Polymeric Optical Fiber, e.g. Z1190 from Beckhoff)
2. Cutter knife or shears
3. Wire strippers
4. Polishing set (included with connector set ZS1090-0008 from Beckhoff)
5. Versatile Link duplex connector (included in connector set ZS1090-0008 from Beckhoff)
1. Stripping the POF cable
The cable should be split over a length between 100 and 150 mm from the cable end, so that the following steps can be carried out properly.
Once you have shortened the cable to the required length, use the wire strippers to remove approx. 7 mm of the external sheathing of the individual wires. The two cable ends should be stripped over approximately the same length.
POF cable stripped over the same length
2. Attaching the connector
Push the two cable ends into the connector and the connector back until it stops. The fibers should now protrude no more than 1.5 mm from the front openings.
Close the connector by folding the upper and lower halves together until they engage.
Cable inserted in the connector
Closed connector
When inserting the wires into the connector ensure the optical channels are crossed (Tx1 → Rx2; Tx2 → Rx1). The 'nose' at the connector hinge can be used as a guide.
Correctly connected optical channels
3. Grinding and polishing
Any fibers protruding more than 1.5 mm from the connector should be shortened with a cutter knife or a pair of scissors.
Now push the connector fully into the sanding gauge, so that the ends to be polished protrude from the lower side. The sanding gauge is suitable for polishing one or two simplex connectors or a duplex connector.
Sanding gauge with protruding fiber ends
Wear indicator
The wear indicator of the sanding gauge consists of four points on the underside. The sanding gauge should be replaced when one of these points is no longer visible.
Now press the sanding gauge onto the abrasive paper with uniform pressure and as perpendicular as possible. In order to achieve a uniform result, use the abrasive paper in the form of a figure of 8, until the fibers are flush with the sanding gauge. Then clean the sanding gauge and the connector from below with a soft, dry cloth.
Polishing in the form of a figure of 8
4. Fine polishing
Now use the pink polishing sheet for fine polishing in the same manner. Apply the connector with the sanding gauge to the matt side of the polishing sheet with slight pressure and polish in the form of a figure of 8 up to 25 times. After the procedure the fiber end should be flat, smooth and clean.
Improving the transfer performance by fine polishing
Fine polishing with a polishing sheet can improve the transfer performance between the transmitter and the receiver or in the cable joint by up to 0.5 dB compared with to treatment with abrasive paper alone. For short transfer distances the polishing step can be omitted.
Fine-polished fibers in the connector


Error handling and diagnostics

Error handling and diagnostics
Error handling and diagnostics
Additional information
•
Diagnostic LEDs EK1122, EK1122-0008
•
Diagnostic LEDs EK1521, EK1521-0010
•
Diagnostic LEDs EK1561


Diagnostic LEDs EK1122, EK1122-0008

Error handling and diagnostics [image] Diagnostic LEDs EK1122, EK1122-0008
Diagnostic LEDs EK1122, EK1122-0008

LEDs for fieldbus diagnostics
LED |  | Display | State | Description
LINK / ACT (X1/X2) | green | off | - | no connection on the EtherCAT strand
 |  | on | linked | EtherCAT device connected
 |  | flashing | active | Communication with EtherCAT device
LED diagnostics EtherCAT state machine
LED | Color | Meaning
RUN | green | This LED indicates the terminal's operating state:
 |  | off | State of the EtherCAT State Machine: INIT = initialization of the terminal
 |  | single flash | State of the EtherCAT State Machine: PREOP = function for mailbox communication and different standard-settings set
 |  | flashing | State of the EtherCAT State Machine: SAFEOP = verification of the sync manager channels and the distributed clocks. Outputs remain in safe state
 |  | on | State of the EtherCAT State Machine: OP = normal operating state; mailbox and process data communication is possible
 |  | flickering | State of the EtherCAT State Machine: BOOTSTRAP = function for terminal firmware updates


Diagnostic LEDs EK1521, EK1521-0010

Error handling and diagnostics [image] Diagnostic LEDs EK1521, EK1521-0010
Diagnostic LEDs EK1521, EK1521-0010

LEDs for fieldbus diagnostics
LED |  | Display | State | Description
LINK / ACT (X1) | green | off | - | no connection on the EtherCAT strand
 |  | on | linked | EtherCAT device connected
 |  | flashing | active | Communication with EtherCAT device
LED diagnostics EtherCAT state machine
LED | Color | Meaning
RUN | green | This LED indicates the terminal's operating state:
 |  | off | State of the EtherCAT State Machine: INIT = initialization of the terminal
 |  | single flash | State of the EtherCAT State Machine: PREOP = function for mailbox communication and different standard-settings set
 |  | flashing | State of the EtherCAT State Machine: SAFEOP = verification of the sync manager channels and the distributed clocks. Outputs remain in safe state
 |  | on | State of the EtherCAT State Machine: OP = normal operating state; mailbox and process data communication is possible
 |  | flickering | State of the EtherCAT State Machine: BOOTSTRAP = function for terminal firmware updates


Diagnostic LEDs EK1561

Error handling and diagnostics [image] Diagnostic LEDs EK1561
Diagnostic LEDs EK1561
LEDs for fieldbus diagnostics
LED | Color | Display | State | Description
LINK / ACT (X1) | green | off | - | no connection on the EtherCAT strand
 |  | on | linked | EtherCAT device connected
 |  | flashing | active | Communication with EtherCAT device
LED diagnostics EtherCAT state machine
LED | Color | Meaning
RUN | green | This LED indicates the terminal's operating state:
 |  | off | State of the EtherCAT State Machine: INIT = initialization of the terminal
 |  | single flash | State of the EtherCAT State Machine: PREOP = function for mailbox communication and different standard-settings set
 |  | flashing | State of the EtherCAT State Machine: SAFEOP = verification of the sync manager channels and the distributed clocks. Outputs remain in safe state
 |  | on | State of the EtherCAT State Machine: OP = normal operating state; mailbox and process data communication is possible
 |  | flickering | State of the EtherCAT State Machine: BOOTSTRAP = function for terminal firmware updates


Appendix

Appendix
Appendix
Additional information
•
Safety instructions and behavioral rules for Class 1 laser
•
UL notice
•
Firmware compatibility
•
Firmware Update EL/ES/EM/EPxxxx
•
Support and Service


Safety instructions and behavioral rules for Class 1 laser

Appendix [image] Safety instructions and behavioral rules for Class 1 laser
Safety instructions and behavioral rules for Class 1 laser
SmallWarningYellow CAUTION
Class 1 laser product – danger of accident due to glare!
The following laser-specific behavioral rules are to be followed for the Class 1 laser products described in this document:
•
The laser beam may not be directed toward persons, since accidents may be caused by glare.
•
Do not look into the direct or reflected beam.
•
If laser radiation meets the eye, the eyes must be consciously closed and the head turned away from the beam immediately.
•
When using the laser, no optical instruments may be used to view the radiation source, since this can lead to exposure limit values being exceeded.
•
Manipulations (modifications) of the laser device are not permitted.


UL notice

Appendix [image] UL notice
UL notice
culus-logo
Application
Beckhoff EtherCAT modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
culus-logo
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
culus-logo
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
Basic principles
Two UL certificates are met in the Beckhoff EtherCAT product range, depending upon the components:
1.
UL certification according to UL508. Devices with this kind of certification are marked by this sign:
2.
UL certification according to UL508 with limited power consumption. The current consumed by the device is limited to a max. possible current consumption of 4 A. Devices with this kind of certification are marked by this sign:
Almost all current EtherCAT products (as at 2010/05) are UL certified without restrictions.
Application
If terminals certified with restrictions are used, then the current consumption at 24 VDC must be limited accordingly by means of supply
▪
from an isolated source protected by a fuse of max. 4 A (according to UL248) or
▪
from a voltage supply complying with NEC class 2.
A voltage source complying with NEC class 2 may not be connected in series or parallel with another NEC class 2compliant voltage supply!
These requirements apply to the supply of all EtherCAT bus couplers, power adaptor terminals, Bus Terminals and their power contacts.


Firmware compatibility

Appendix [image] Firmware compatibility
Firmware compatibility
The EK1122 and EK15xx Couplers have no firmware.


Firmware Update EL/ES/EM/EPxxxx

Appendix [image] Firmware Update EL/ES/EM/EPxxxx
Firmware Update EL/ES/EM/EPxxxx
This section describes the device update for Beckhoff EtherCAT slaves from the EL/ES, EM, EK and EP series. A firmware update should only be carried out after consultation with Beckhoff support.
Storage locations
An EtherCAT slave stores operating data in up to 3 locations:
▪
Depending on functionality and performance EtherCAT slaves have one or several local controllers for processing I/O data. The corresponding program is the so-called firmware in *.efw format.
▪
In some EtherCAT slaves the EtherCAT communication may also be integrated in these controllers. In this case the controller is usually a so-called FPGA chip with *.rbf firmware.
▪
In addition, each EtherCAT slave has a memory chip, a so-called ESI-EEPROM, for storing its own device description (ESI: EtherCAT Slave Information). On power-up this description is loaded and the EtherCAT communication is set up accordingly. The device description is available from the download area of the Beckhoff website at (https://www.beckhoff.de). All ESI files are accessible there as zip files.
Customers can access the data via the EtherCAT fieldbus and its communication mechanisms. Acyclic mailbox communication or register access to the ESC is used for updating or reading of these data.
The TwinCAT System Manager offers mechanisms for programming all 3 parts with new data, if the slave is set up for this purpose. Generally the slave does not check whether the new data are suitable, i.e. it may no longer be able to operate if the data are unsuitable.
Simplified update by bundle firmware
The update using so-called bundle firmware is more convenient: in this case the controller firmware and the ESI description are combined in a *.efw file; during the update both the firmware and the ESI are changed in the terminal. For this to happen it is necessary
▪
for the firmware to be in a packed format: recognizable by the file name, which also contains the revision number, e.g. ELxxxx-xxxx_REV0016_SW01.efw
▪
for password=1 to be entered in the download dialog. If password=0 (default setting) only the firmware update is carried out, without an ESI update.
▪
for the device to support this function. The function usually cannot be retrofitted; it is a component of many new developments from year of manufacture 2016.
Following the update, its success should be verified
▪
ESI/Revision: e.g. by means of an online scan in TwinCAT ConfigMode/FreeRun – this is a convenient way to determine the revision
▪
Firmware: e.g. by looking in the online CoE of the device
Note
Risk of damage to the device!
Note the following when downloading new device files

• Firmware downloads to an EtherCAT device must not be interrupted
• Flawless EtherCAT communication must be ensured. CRC errors or LostFrames must be avoided.
• The power supply must adequately dimensioned. The signal level must meet the specification.

In the event of malfunctions during the update process the EtherCAT device may become unusable and require re-commissioning by the manufacturer.
Additional information
•
Device description ESI file/XML
•
Firmware explanation
•
Updating controller firmware *.efw
•
FPGA firmware *.rbf
•
Simultaneous updating of several EtherCAT devices


Device description ESI file/XML

Appendix [image] Firmware Update EL/ES/EM/EPxxxx [image] Device description ESI file/XML
Device description ESI file/XML
Note
Attention regarding update of the ESI description/EEPROM
Some slaves have stored calibration and configuration data from the production in the EEPROM. These are irretrievably overwritten during an update.
The ESI device description is stored locally on the slave and loaded on start-up. Each device description has a unique identifier consisting of slave name (9 characters/digits) and a revision number (4 digits). Each slave configured in the System Manager shows its identifier in the EtherCAT tab:
Device identifier consisting of name EL3204-0000 and revision -0016
The configured identifier must be compatible with the actual device description used as hardware, i.e. the description which the slave has loaded on start-up (in this case EL3204). Normally the configured revision must be the same or lower than that actually present in the terminal network.
For further information on this, please refer to the EtherCAT system documentation.
Update of XML/ESI description
The device revision is closely linked to the firmware and hardware used. Incompatible combinations lead to malfunctions or even final shutdown of the device. Corresponding updates should only be carried out in consultation with Beckhoff support.
Display of ESI slave identifier
The simplest way to ascertain compliance of configured and actual device description is to scan the EtherCAT boxes in TwinCAT mode Config/FreeRun:
Scan the subordinate field by right-clicking on the EtherCAT device
If the found field matches the configured field, the display shows
Configuration is identical
otherwise a change dialog appears for entering the actual data in the configuration.
Change dialog
In this example in Fig. Change dialog, an EL3201-0000-0017 was found, while an EL3201-0000-0016 was configured. In this case the configuration can be adapted with the Copy Before button. The Extended Information checkbox must be set in order to display the revision.
Changing the ESI slave identifier
The ESI/EEPROM identifier can be updated as follows under TwinCAT:
▪
Trouble-free EtherCAT communication must be established with the slave.
▪
The state of the slave is irrelevant.
▪
Right-clicking on the slave in the online display opens the EEPROM Update dialog, Fig. EEPROM Update
EEPROM Update
The new ESI description is selected in the following dialog, see Fig. Selecting the new ESI. The checkbox Show Hidden Devices also displays older, normally hidden versions of a slave.
Selecting the new ESI
A progress bar in the System Manager shows the progress. Data are first written, then verified.
The change only takes effect after a restart.
Most EtherCAT devices read a modified ESI description immediately or after startup from the INIT. Some communication settings such as distributed clocks are only read during power-on. The EtherCAT slave therefore has to be switched off briefly in order for the change to take effect.


Firmware explanation

Appendix [image] Firmware Update EL/ES/EM/EPxxxx [image] Firmware explanation
Firmware explanation
Determining the firmware version
Determining the version on laser inscription
Beckhoff EtherCAT slaves feature serial numbers applied by laser. The serial number has the following structure: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with ser. no.: 12 10 03 02:
12 - week of production 12
10 - year of production 2010
03 - firmware version 03
02 - hardware version 02
Determining the version via the System Manager
The TwinCAT System Manager shows the version of the controller firmware if the master can access the slave online. Click on the E-Bus Terminal whose controller firmware you want to check (in the example terminal 2 (EL3204)) and select the tab CoE Online (CAN over EtherCAT).
CoE Online and Offline CoE
Two CoE directories are available:
• online: This is offered in the EtherCAT slave by the controller, if the EtherCAT slave supports this. This CoE directory can only be displayed if a slave is connected and operational.
• offline: The EtherCAT Slave Information ESI/XML may contain the default content of the CoE. This CoE directory can only be displayed if it is included in the ESI (e.g. "Beckhoff EL5xxx.xml").
The Advanced button must be used for switching between the two views.
In Fig. Display of EL3204 firmware version the firmware version of the selected EL3204 is shown as 03 in CoE entry 0x100A.
Display of EL3204 firmware version
In (A) TwinCAT 2.11 shows that the Online CoE directory is currently displayed. If this is not the case, the Online directory can be loaded via the Online option in Advanced Settings (B) and double-clicking on AllObjects.


Updating controller firmware *.efw

Appendix [image] Firmware Update EL/ES/EM/EPxxxx [image] Updating controller firmware *.efw
Updating controller firmware *.efw
CoE directory
The Online CoE directory is managed by the controller and stored in a dedicated EEPROM, which is generally not changed during a firmware update.
Switch to the Online tab to update the controller firmware of a slave, see Fig. Firmware Update.
Firmware Update
Proceed as follows, unless instructed otherwise by Beckhoff support. Valid for TwinCAT 2 and 3 as EtherCAT master.
▪
Switch TwinCAT system to ConfigMode/FreeRun with cycle time >= 1 ms (default in ConfigMode is 4 ms). A FW-Update during real time operation is not recommended.
▪
Switch EtherCAT Master to PreOP
▪
Switch slave to INIT (A)
▪
Switch slave to BOOTSTRAP
▪
Check the current status (B, C)
▪
Download the new *efw file (wait until it ends). A pass word will not be neccessary usually.
▪
After the download switch to INIT, then PreOP
▪
Switch off the slave briefly (don't pull under voltage!)
▪
Check within CoE 0x100A, if the FW status was correctly overtaken.


FPGA firmware *.rbf

Appendix [image] Firmware Update EL/ES/EM/EPxxxx [image] FPGA firmware *.rbf
FPGA firmware *.rbf
If an FPGA chip deals with the EtherCAT communication an update may be accomplished via an *.rbf file.
▪
Controller firmware for processing I/O signals
▪
FPGA firmware for EtherCAT communication (only for terminals with FPGA)
The firmware version number included in the terminal serial number contains both firmware components. If one of these firmware components is modified this version number is updated.
Determining the version via the System Manager
The TwinCAT System Manager indicates the FPGA firmware version. Click on the Ethernet card of your EtherCAT strand (Device 2 in the example) and select the Online tab.
The Reg:0002 column indicates the firmware version of the individual EtherCAT devices in hexadecimal and decimal representation.
FPGA firmware version definition
If the column Reg:0002 is not displayed, right-click the table header and select Properties in the context menu.
Context menu Properties
The Advanced Settings dialog appears where the columns to be displayed can be selected. Under Diagnosis/Online View select the '0002 ETxxxx Build' check box in order to activate the FPGA firmware version display.
Dialog Advanced Settings
Update
For updating the FPGA firmware
▪
of an EtherCAT coupler the coupler must have FPGA firmware version 11 or higher;
▪
of an E-Bus Terminal the terminal must have FPGA firmware version 10 or higher.
Older firmware versions can only be updated by the manufacturer!
Updating an EtherCAT device
The following sequence order have to be met if no other specifications are given (e.g. by the Beckhoff support):
▪
Switch TwinCAT system to ConfigMode/FreeRun with cycle time >= 1 ms (default in ConfigMode is 4 ms). A FW-Update during real time operation is not recommended.
▪
In the TwinCAT System Manager select the terminal for which the FPGA firmware is to be updated (in the example: Terminal 5: EL5001) and
click the Advanced Settings button in the EtherCAT tab:
▪
The Advanced Settings dialog appears. Under ESC Access/E²PROM/FPGA click on Write FPGA button:
▪
Select the file (*.rbf) with the new FPGA firmware, and transfer it to the EtherCAT device:
▪
Wait until download ends
▪
Switch slave current less for a short time (don't pull under voltage!). In order to activate the new FPGA firmware a restart (switching the power supply off and on again) of the EtherCAT device is required.
▪
Check the new FPGA status
Note
Risk of damage to the device!
A download of firmware to an EtherCAT device must not be interrupted in any case! If you interrupt this process by switching off power supply or disconnecting the Ethernet link, the EtherCAT device can only be recommissioned by the manufacturer!


Simultaneous updating of several EtherCAT devices

Appendix [image] Firmware Update EL/ES/EM/EPxxxx [image] Simultaneous updating of several EtherCAT devices
Simultaneous updating of several EtherCAT devices
The firmware and ESI descriptions of several devices can be updated simultaneously, provided the devices have the same firmware file/ESI.
Multiple selection and firmware update
Select the required slaves and carry out the firmware update in BOOTSTRAP mode as described above.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com