EJ9001 - Placeholder module
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Intended use
•
Signal distribution board
•
Documentation issue status
•
Guide through documentation
•
Marking of EtherCAT plug-in modules


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Intended use

Foreword [image] Intended use
Intended use
SmallWarningYellow WARNING
Caution - Risk of injury!
EJ components may only be used for the purposes described below!


Signal distribution board

Foreword [image] Signal distribution board
Signal distribution board
Note
Signal distribution board
Make sure that the EtherCAT plug-in modules are used only on a signal distribution board that has been developed and manufactured in accordance with the Design Guide.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
1.5
▪
Update chapter Introduction
▪
Update chapter Pinout
▪
Chapters Basics communication, TwinCAT Quick Start , TwinCAT development environment and General Notes - EtherCAT Slave Application replaced by references in the chapter Guide through documentation
1.4
▪
Note Signal distribution board added
▪
Chapter Version identification of EtherCAT devices replaced by chapter Marking of EtherCAT plug-in modules
▪
Update chapter Technical data
▪
Update chapter Pinout
1.3
▪
Chapter Intended use added
▪
Update Technical data
▪
Update chapter Pinout
▪
Update chapter Installation of EJ modules
▪
Update structure
1.2
▪
Update Technical data
▪
Update chapter Power supply for the EtherCAT plug-in modules
▪
Update structure
1.1
▪
Update Technical data
▪
Pinout added
1.0
▪
First publication EJ9001


Guide through documentation

Foreword [image] Guide through documentation
Guide through documentation
Note
Further components of documentation
The documentations named in the following table are further components of the complete documentation. These documentations are required for the use of EtherCAT plug-in modules.
No.
Title
Description
[1]
EtherCAT System Documentation
▪
System overview
▪
EtherCAT basics
▪
Cable redundancy
▪
Hot Connect
▪
Distributed Clocks
▪
Configuration of EtherCAT-Components
[2]
Infrastructure for EtherCAT/Ethernet
▪
Technical recommendations and notes for design, implementation an testing
[3]
Design GuideSignal-Distribution-Board for standard EtherCAT plug-in modules
Requirements for the design of a Signal-Distribution-Board for standard EtherCAT plug-in modules
▪
Backplane mounting guidelines
▪
Module placement
▪
Routing guidelines


Marking of EtherCAT plug-in modules

Foreword [image] Marking of EtherCAT plug-in modules
Marking of EtherCAT plug-in modules
Designation
A Beckhoff EtherCAT device has a 14-digit technical designation, made up as follows (e.g. EJ1008-0000-0017)
▪
Order identifier
–
family key: EJ
–
product designation: The first digit of product designation is used for assignment to a product group (e.g. EJ2xxx = digital output module).
–
Version number: The four digit version number identifies different product variants.
▪
Revision number:
It is incremented when changes are made to the product.
The Order identifier and the revision number are printed on the side of EtherCAT plug-in modules (s. following illustration (A and B).
Order identifier (A), Revision number (B) and serial number (C) using the example of EJ1008
Product group | Example
 | Product designation | Version | Revision
EtherCAT Coupler EJ11xx | EJ1101 | -0022 (Coupler with external connectors, power supply module and optional ID switches | -0016
Digital input modules EJ1xxx | EJ1008 8-channel | -0000 (basic type) | -0017
Digital output modules EJ2xxx | EJ2521 1-channel | -0224 (2 x 24 V outputs) | -0016
Analog input modules EJ3xxx | EJ3318 8-channel thermocouple | -0000 (basic type) | -0017
Analog output modules EJ4xxx | EJ4134 4-channel | -0000 (basic type) | -0019
Special function modules EJ5xxx, EJ6xxx | EJ6224 IO-Link master | -0090 (with TwinSAFE SC) | -0016
Motion modules EJ7xxx | EJ7211 servomotor | -9414 (with ECT, STO and TwinSAFE SC) | -0029
Notes
▪
The elements mentioned above result in the technical designation. EJ1008-0000-0017 is used in the example below.
▪
EJ1008-0000 is the order identifier, in the case of “-0000” usually abbreviated to EJ1008.
▪
The revision -0017 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
▪
The product designation, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Serial number
The serial number for EtherCAT plug-in modules is usually the 8-digit number printed on the side of the module (see following illustration C). The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Order identifier (A), revision number (B) and serial number (C) using the example of EJ1008
Serial number | Example serial number: 08 15 08 16
KK - week of production (CW, calendar week) | 08 - week of production: 08
YY - year of production | 15 - year of production: 2015
FF - firmware version | 08 -f irmware version: 08
HH - hardware version | 16 - hardware version: 16
Additional information
•
Beckhoff Identification Code (BIC)
•
Certificates


Beckhoff Identification Code (BIC)

Foreword [image] Marking of EtherCAT plug-in modules [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, it shall be replaced by spaces. The data under positions 1-4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971 , 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from items 1 - 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC
Notice
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Certificates

Foreword [image] Marking of EtherCAT plug-in modules [image] Certificates
Certificates
▪
The EhterCAT plug-in modules meet the requirements of the EMC and Low Voltage Directive. The CE mark is printed on the side of the modules.
▪
The cRUus imprint identifies devices that meet product safety requirements according to U.S. and Canadian regulations.
▪
The warning symbol is a request to read the corresponding documentation. The documentations for EtherCAT plug-in modules can be downloaded from the Beckhoff homepage.
Marking for CE and UL using EJ1008 as an example


System overview

System overview
System overview
Electronically, the EJxxxx EtherCAT plug-in modules are based on the EtherCAT I/O system. The EJ system consists of the signal distribution board and EtherCAT plug-in modules. It is also possible to connect an IPC to the EJ system.
The EJ system is suitable for mass production applications, applications with small footprint and applications requiring a low total weight.
The machine complexity can be extended by means of the following:
▪
reserve slots,
▪
the use of placeholder modules,
▪
linking of EtherCAT Terminals and EtherCAT Boxes via an EtherCAT connection.
The following diagram illustrates an EJ system. The components shown are schematic, to illustrate the functionality.
EJ system sample
Signal distribution board
The signal distribution board distributes the signals and the power supply to individual application-specific plug connectors, in order to connect the controller to further machine modules. Using pre-assembled cable harnesses avoids the need for time-consuming connection of individual wires. Coded components reduce the unit costs and the risk of miswiring.
Beckhoff offers development of signal distribution boards as an engineering service. Customers have the option to develop their own signal distribution board, based on the design guide.
EtherCAT plug-in modules
Similar to the EtherCAT terminal system, a module strand consists of a Bus Coupler and I/O modules. Almost all of the EtherCAT Terminals can also be manufactured in the EJ design as EtherCAT plug-in modules. The EJ modules are directly attached to the signal distribution board. The communication, signal distribution and supply take place via the contact pins at the rear of the modules and the PCB tracks of the signal distribution board. The coding pins at the rear serve as mechanical protection against incorrect connection. Color coding on the housing facilitates distinguishing of the modules.


Product overview

Product overview
Product overview
Additional information
•
EJ9001 - Introduction
•
EJ9001 - Technical data
•
EJ9001 - Pinout
•
EJ9001 - LED


EJ9001 - Introduction

Product overview [image] EJ9001 - Introduction
EJ9001 - Introduction
EJ9001
Placeholder module
The EJ9001 placeholder modules are used to close temporary gaps in the module strands. Gaps in the module strand cause interruption in EtherCAT communication and must be equipped with placeholder modules.
In contrast to the passive terminals of the EL series, the placeholder modules actively participate in the data exchange. Several placeholder modules can therefore be connected in series, without impairing the data exchange.
The placeholder modules can be replaced according to the specification of the signal distribution board.
Using placeholder modules and reserve slots for unused slots enables the use of one single distribution board for several variants of machines with the same basic function.


EJ9001 - Technical data

Product overview [image] EJ9001 - Technical data
EJ9001 - Technical data
Technical data | EJ9001
Current consumption via E-bus | typ. 60 mA
Nominal voltage | -
Electrical isolation | 500 V (E-bus/field voltage)
Diagnostics | -
permissible ambient temperature range during operation | -25°C .. + 60°C (extended temperature range)
permissible ambient temperature range during storage | -40°C .. + 85°C
permissible relative humidity | 95 %, no condensation
Operating altitude | max 2,000 m
Dimensions (W x H x D) | approx. 12 mm x 66 mm x 55 mm
Weight | approx. 30 g
Mounting | On signal distribution board
Pollution degree | 2
Installation position | Standard
Position of coding pins | -
Color coding | grey
Vibration/shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27 (with corresponding signal distribution board)
EMC immunity/emission | conforms to EN 61000-6-2/EN 61000-6-4 (with corresponding signal distribution board)
Protection class | EJ module: IP20, EJ system: dependent on signal distribution board and housing
Approval | CE, UL
CE approval
The CE Marking refers to the EtherCAT plug-in module mentioned above.
If the EtherCAT plug-in module is used in the production of a ready-to-use end product (PCB in conjunction with a housing), the manufacturer of the end product must check compliance of the overall system with relevant directives and CE certification.
To operate the EtherCAT plug-in modules, they must be installed in a housing.


EJ9001 - Pinout

Product overview [image] EJ9001 - Pinout
EJ9001 - Pinout
EJ9001 - Pinout
The PCB footprint can be downloaded from the Beckhoff homepage.
Note
Damage to devices possible!
Before installation and commissioning read the chapters Installation of EJ modules and Commissioning!


EJ9001 - LED

Product overview [image] EJ9001 - LED
EJ9001 - LED
EJ9001-LED
LED | Color | Display | State | Description
RUN | green | off | Init | State of the EtherCAT State Machine: INIT = initialization of the plug-in module
 |  | flashing | Pre-Operational | State of the EtherCAT State Machine: PREOP = function for mailbox communication and different standard-settings set
 |  | Single flash | Safe-Operational | State of the EtherCAT State Machine: SAFEOP = verification of the Sync Manager channels and the distributed clocks. Outputs remain in safe state
 |  | on | Operational | State of the EtherCAT State Machine: OP = normal operating state; mailbox and process data communication is possible
 |  | flickering | Bootstrap | State of the EtherCAT State Machine: BOOTSTRAP = function for firmware updates of the plug-in module


Installation of EJ modules

Installation of EJ modules
Installation of EJ modules
Additional information
•
Power supply for the EtherCAT plug-in modules
•
EJxxxx - dimensions
•
Installation positions and minimum distances
•
Codings
•
Installation on the signal distribution board
•
Extension options
•
IPC integration
•
Disassembly of the signal distribution board


Power supply for the EtherCAT plug-in modules

Installation of EJ modules [image] Power supply for the EtherCAT plug-in modules
Power supply for the EtherCAT plug-in modules
SmallWarningYellow WARNING
Power supply
A SELV/PELV power supply must be used to supply power for the EJ coupler and modules. Couplers and modules have to be connected to SELV/PELV circuits exclusively.
The signal distribution board should have a power supply designed for the maximum possible current load of the module string. Information on the current required from the E-bus supply can be found for each module in the respective documentation in section “Technical data”, online and in the catalog. The power requirement of the module string is displayed in the TwinCAT System Manager.
E-bus power supply with EJ1100 or EJ1101-0022 and EJ940x
The EJ1100 Bus Coupler supplies the connected EJ modules with the E-bus system voltage of 3.3 V. The Coupler can accommodate a load up to 2.2 A. If a higher current is required, a combination of the coupler EJ1101-0022 and the power supply units EJ9400 (2.5 A) or EJ9404 (12 A) should be used. The EJ940x power supply units can be used as additional supply modules in the module string.
Depending on the application, the following combinations for the E-bus supply are available:
E-bus power supply with EJ1100 or EJ1101-0022 + EJ940x
In the EJ1101-0022 coupler, the RJ45 connectors and optional ID switches are external and can be positioned anywhere on the signal distribution board, as required. This facilitates feeding through a housing.
The EJ940x power supply plug-in modules provide an optional reset function (see chapter Connection of the documentation for EJ9400 and EJ9404)
E-bus power supply with CXxxxx and EK1110-004x
The Embedded PC supplies the attached EtherCAT terminals and the EtherCAT EJ coupler
▪
with a supply voltage of 24 VDC (-15 %/+20%). This voltage supplies the E-bus and the bus terminal electronics.
The CXxxxx units supply the E-bus with up to 2,000 mA E-bus current. If a higher current is required due to the attached terminals, power feed terminals or power supply plug-in modules must be used for the E-bus supply.
▪
with a peripheral voltage Up of 24 VDC to supply the field electronics.
The EK1110-004x EtherCAT EJ couplers relay the following parameters to the signal distribution board via the rear connector:
▪
the E-bus signals,
▪
the E-bus voltage UEBUS (3.3 V) and
▪
the peripheral voltage UP (24 VDC).
PCB with Embedded PC, EK1110-0043 and EJxxxx, rear view EK1110-0043


EJxxxx - dimensions

Installation of EJ modules [image] EJxxxx - dimensions
EJxxxx - dimensions
The EJ modules are compact and lightweight thanks to their design. Their volume is approx. 50% smaller than the volume of the EL terminals. A distinction is made between four different module types, depending on the width and the height:
Module type | Dimensions (W x H x D) | Sample in figure below
Coupler | 44 mm x 66 mm x 55 mm | EJ1100 (ej_44_2xrj45_coupler)
Single module | 12 mm x 66 mm x 55 mm | EJ1809 (ej_12_16pin_code13)
Double module | 24 mm x 66 mm x 55 mm | EJ7342 (ej_24_2x16pin_code18)
Single module (long) | 12 mm x 152 mm x 55 mm | EJ1957 (ej_12_2x16pin_extended_code4747)
EJxxxx - Dimensions
The technical drawings can be downloaded from the download finder. The drawings are named as described in the drawing below.
Technical drawings from download finder


Installation positions and minimum distances

Installation of EJ modules [image] Installation positions and minimum distances
Installation positions and minimum distances
Additional information
•
Minimum distances for ensuring installability
•
Installation positions


Minimum distances for ensuring installability

Installation of EJ modules [image] Installation positions and minimum distances [image] Minimum distances for ensuring installability
Minimum distances for ensuring installability
Note the dimensions shown in the following diagram for the design of the signal distribution board to ensure safe latching and simple assembly / disassembly of the modules.
Mounting distances EJ module - PCB
Observing the reaching area
A minimum reaching area of 92 mm is required for assembly / disassembly, in order to be able to reach the mounting tabs with the fingers.
Adherence to the recommended minimum distances for ventilation (see section Installation position) ensures an adequate reaching area.
The signal distribution board must have a thickness of 1.6 mm and a minimum distance of 4 mm from the mounting surface, in order to ensure latching of the modules on the board.


Installation positions

Installation of EJ modules [image] Installation positions and minimum distances [image] Installation positions
Installation positions
Note
Constraints regarding installation position and operating temperature range
Please refer to the technical data for the installed components to ascertain whether any restrictions regarding the mounting position and/or the operating temperature range have been specified. During installation of modules with increased thermal dissipation, ensure adequate distance above and below the modules to other components in order to ensure adequate ventilation of the modules during operation!
The standard installation position is recommended. If a different installation position is used, check whether additional ventilation measures are required.
Ensure that the specified conditions (see Technical data) are adhered to!
Optimum installation position (standard)
For the optimum installation position the signal distribution board is installed horizontally, and the fronts of the EJ modules face forward (see Fig. Recommended distances for standard installation position). The modules are ventilated from below, which enables optimum cooling of the electronics through convection. “From below” is relative to the acceleration of gravity.
Recommended distances for standard installation position
Compliance with the distances shown in Fig. Recommended distances for standard installation position is recommend. The recommended minimum distances should not be regarded as restricted areas for other components. The customer is responsible for verifying compliance with the environmental conditions described in the technical data. Additional cooling measures must be provided, if required.
Other installation positions
All other installation positions are characterized by a different spatial position of the signal distribution board, see Fig. Other installation positions.
The minimum distances to ambient specified above also apply to these installation positions.
EJxxx_other mounting positions
Other installation positions


Codings

Installation of EJ modules [image] Codings
Codings
Additional information
•
Color coding
•
Mechanical position coding


Color coding

Installation of EJ modules [image] Codings [image] Color coding
Color coding
EJ modules color code; sample: EJ1809
The EJ modules are color-coded for a better overview in the control cabinet (see diagram above). The color code indicates the signal type. The following table provides an overview of the signal types with corresponding color coding.
Signal type | Modules | Color
Coupler | EJ11xx | No color coding
Digital input | EJ1xxx | Yellow
Digital output | EJ2xxx | Red
Analog input | EJ3xxx | Green
Analog output | EJ4xxx | Blue
Motion | EJ7xxx | orange
System | EJ9xxx | grey


Mechanical position coding

Installation of EJ modules [image] Codings [image] Mechanical position coding
Mechanical position coding
The modules have two signal-specific coding pins on the underside (see Figs. B1 and B2 below). In conjunction with the coding holes in the signal distribution board (see Figs. A1 and A2 below), the coding pins provide an option for mechanical protection against incorrect connection. This significantly reduces the risk of error during installation and service.
Couplers and placeholder modules have no coding pins.
Mechanical position coding with coding pins (B1 and B2) and coding holes (A1 and A2)
The following diagram shows the position of the position coding with position numbers on the left-hand side. Modules with the same signal type have the same coding. For sample, all digital input modules have the coding pins at positions one and three. There is no plug protection between modules with the same signal type. During installation the module type should therefore be verified based on the device name.
Pin coding; sample: digital input modules


Installation on the signal distribution board

Installation of EJ modules [image] Installation on the signal distribution board
Installation on the signal distribution board
EJ modules are installed on the signal distribution board. The electrical connections between coupler and EJ modules are realized via the pin contacts and the signal distribution board.
The EJ components must be installed in a control cabinet or enclosure which must provide protection against fire hazards, environmental conditions and mechanical impact.
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the module system into a safe, de-energized state before starting installation, disassembly or wiring of the modules.
Note
Risk of damage to components through electrostatic discharge!
Observe the regulations for ESD protection.
Installation of EJ modules
A1 / A2 | Latching lugs top / bottom | C1 / C2 | Mounting holes
B1 / B2 | Coding pins | D1 / D2 | Coding holes
To install the modules on the signal distribution board proceed as follows:
1.
Before the installation, ensure that the signal distribution board is securely connected to the mounting surface. Installation on an unsecured signal distribution board may result in damage to the board.
2.
If necessary, check whether the positions of the coding pins (B) match the corresponding holes in the signal distribution board (D).
3.
Compare the device name on the module with the information in the installation drawing.
4.
Press the upper and the lower mounting tabs simultaneously and push the module onto the board while gently moving it up and down, until the module is latched securely.
The required contact pressure can only be established and the maximum current carrying capacity ensured if the module is latched securely.
5.
Use placeholder modules (EJ9001) to fill gaps in the module strand.
Note
•
During installation ensure safe latching of the modules on the signal distribution board! The consequences of inadequate contact pressure include:
⇨
loss of quality of the transferred signals,
⇨
increased power dissipation of the contacts,
⇨
impairment of the service life.


Extension options

Installation of EJ modules [image] Extension options
Extension options
Three options are available for modifications and extensions of the EJ system.
▪
Replacing the placeholder modules with the function modules provided for the respective slot
▪
Assigning function modules specified for the respective slots for the reserve slots at the end of the module string
▪
Linking with EtherCAT Terminals and EtherCAT Box modules via an Ethernet/EtherCAT connection
Additional information
•
Using placeholder modules for unused slots
•
Linking with EtherCAT Terminals and EtherCAT Box modules via an Ethernet/EtherCAT connection


Using placeholder modules for unused slots

Installation of EJ modules [image] Extension options [image] Using placeholder modules for unused slots
Using placeholder modules for unused slots
The EJ9001 placeholder modules are used to close temporary gaps in the module strands (see Fig. A1 below). Gaps in the module strand cause interruption in EtherCAT communication and must be equipped with placeholder modules.
In contrast to the passive terminals of the EL series, the placeholder modules actively participate in the data exchange. Several placeholder modules can therefore be connected in series, without impairing the data exchange.
Unused slots at the end of the module strand can be left as reserve slots (see Fig. B1 below).
The machine complexity is extended (extended version) by allocating unused slots (see Figs. A2 below - Exchanging placeholder modules and B2 - Assigning reserve slots) according to the specifications for the signal distribution board.
Sample: Exchanging placeholder modules and assigning reserve slots
E-bus supply
Exchange the placeholder modules with other modules changes the current input from the E-Bus. Ensure that adequate power supply is provided.


Linking with EtherCAT Terminals and EtherCAT Box modules via an Ethernet/EtherCAT connection

Installation of EJ modules [image] Extension options [image] Linking with EtherCAT Terminals and EtherCAT Box modules via an Ethernet/EtherCAT connection
Linking with EtherCAT Terminals and EtherCAT Box modules via an Ethernet/EtherCAT connection
Example of extension via an Ethernet/EtherCAT connection


IPC integration

Installation of EJ modules [image] IPC integration
IPC integration
Connection of CX and EL terminals via the EK1110-004x EtherCAT EJ Coupler
The EK1110-0043 and EK1110-0044 EtherCAT EJ couplers connect the compact DIN-rail PCs of the CX series and attached EtherCAT terminals (ELxxxx) with the EJ modules on the signal distribution board.
The EK1110-004x are supplied from the power supply unit of the Embedded PC.
The E-bus signals and the supply voltage of the field side UP are routed directly to the PCB via a plug connector at the rear of the EtherCAT EJ couplers.
Due to the direct coupling of the Embedded PC and the EL terminals with the EJ modules on the PCB, no EtherCAT extension (EK1110) or EtherCAT coupler (EJ1100) is required.
The Embedded PC can be expanded with EtherCAT terminals that are not yet available in the EJ system, for example.
Example PCB with Embedded PC, EK1110-0043 and EJxxxx, rear view EK1110-0043
Connection of C6015 / C6017 via the EJ110x-00xx EtherCAT Coupler
Thanks to their ultra-compact design and versatile mounting options, the C6015 and C6017 IPCs are ideally suited for connection to an EJ system.
In combination with the ZS5000-0003 mounting set, it is possible to place the C6015 and C6017 IPCs compactly on the signal distribution board.
The EJ system is optimally connected to the IPC via the corresponding EtherCAT cable (see following Fig. [A]).
The IPC can be supplied directly via the signal distribution board using the enclosed power plug (see Fig. [B] below).
Note
Positioning on the signal distribution board
The dimensions and distances for placement and other details can be found in the Design Guide and the documentation for the individual components.
The figure below shows the connection of a C6015 IPC to an EJ system as an example. The components shown are schematic, to illustrate the functionality.
Example for the connection of a C6015 IPC to an EJ system


Disassembly of the signal distribution board

Installation of EJ modules [image] Disassembly of the signal distribution board
Disassembly of the signal distribution board
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the module system into a safe, de-energized state before starting installation, disassembly or wiring of the modules.
Note
Risk of damage to components through electrostatic discharge!
Observe the regulations for ESD protection.
Each module is secured through latching on the distribution board, which has to be released for disassembly.
Disassembly of EJ modules
To disassemble the module from the signal distribution board proceed as follows:
1.
Before disassembly, ensure that the signal distribution board is securely connected to the mounting surface. Disassembly of an unsecured signal distribution board may result in damage to the board.
2.
Press the upper and lower mounting tabs simultaneously and pull the module from board while gently moving it up and down.


EtherCAT basics

EtherCAT basics
EtherCAT basics
Please refer to the EtherCAT System Documentation for the EtherCAT fieldbus basics.


Commissioning

Commissioning
Commissioning
Note
Damage to devices or loss of data
Please refer to the EtherCAT System Documentation for commissioning basics of EtherCAT devices.


Appendix

Appendix
Appendix
Additional information
•
EtherCAT AL Status Codes
•
EJ9001 - Firmware compatibility
•
Support and Service


EtherCAT AL Status Codes

Appendix [image] EtherCAT AL Status Codes
EtherCAT AL Status Codes
For detailed information please refer to the EtherCAT system description.


EJ9001 - Firmware compatibility

Appendix [image] EJ9001 - Firmware compatibility
EJ9001 - Firmware compatibility
The EtherCAT plug-in module EJ9001 has no firmware.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com