EJ72x1-001x - Servomotormodul mit OCT, 48 V DC
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Bestimmungsgemäße Verwendung
•
Ausgabestände der Dokumentation
•
Wegweiser durch die Dokumentation
•
Kennzeichnung von EtherCAT-Steckmodulen


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Bestimmungsgemäße Verwendung

Vorwort [image] Bestimmungsgemäße Verwendung
Bestimmungsgemäße Verwendung
SmallWarningYellow WARNUNG
Vorsicht Verletzungsgefahr!
Eine Verwendung der EJ - Komponenten, die über die im Folgenden beschriebene bestimmungsgemäße Verwendung hinausgeht, ist nicht zulässig!


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
1.0
▪
1. Veröffentlichung EJ7211-0010


Wegweiser durch die Dokumentation

Vorwort [image] Wegweiser durch die Dokumentation
Wegweiser durch die Dokumentation
Hinweis
Weitere Bestandteile der Dokumentation
Die in der folgenden Tabelle genannten Dokumentationen sind Bestandteil der Gesamtdokumentation. Sie werden für den Einsatz der EtherCAT-Steckmodule benötigt.
Nr.
Titel
Beschreibung
[1]
EtherCAT System-Dokumentation
▪
Systemübersicht
▪
EtherCAT-Grundlagen
▪
Kabel-Redundanz
▪
Hot Connect
▪
Konfiguration von EtherCAT-Geräten
[2]
Infrastruktur für EtherCAT/Ethernet
▪
Technische Empfehlungen und Hinweise zur Auslegung, Ausfertigung und Prüfung
[3]
Design Guide EJ8xxx - Signal-Distribution-Board für Standard EtherCAT-Steckmodule
Hinweise zum Design eines EJ-Distribution-Boards für Standard EtherCAT-Steckmodule
▪
Anforderungen an das Signal-Distribution-Board,
▪
Montagerichtlinie für die Leiterplatte,
▪
Modul Platzierung
▪
Routing-Richtlinie
[4]
Dokumentation der zugehörigen ELxxxx EtherCAT-Klemme
▪
Hinweise zum Funktionsprinzip und
▪
Beschreibungen zur Konfiguration und Parametrierung
sind übertragbar auf die jeweiligen EtherCAT-Steckmodule (s. Hinweis auf Dokumentation ELxxxx).


Kennzeichnung von EtherCAT-Steckmodulen

Vorwort [image] Kennzeichnung von EtherCAT-Steckmodulen
Kennzeichnung von EtherCAT-Steckmodulen
Bezeichnung
Beckhoff EtherCAT-Steckmodule verfügen über eine 14-stellige technische Bezeichnung, die sich wie folgt zusammensetzt (z. B. EJ1008-0000-0017):
▪
Bestellbezeichnung:
–
Familienschlüssel: EJ
–
Produktbezeichnung: Die erste Stelle der Produktbezeichnung dient der Zuordnung zu einer Produktgruppe (z. B. EJ2xxx = Digital - Ausgangsmodul)
–
Versionsnummer: Die vierstellige Versionsnummer kennzeichnet verschiedene Produktvarianten
▪
Revisionsnummer:
Sie wird bei Änderungen am Produkt hochgezählt.
Die Bestellbezeichnung und Revisionsnummer werden auf der Seite der EtherCAT-Steckmodule aufgebracht, siehe folgende Abbildung (A und B).
Bestellbezeichnung (A), Revisionsnummer (B) und Seriennummer (C) am Beispiel EJ1008
Produktgruppe | Beispiel
 | Produktbezeichnung | Version | Revision
EtherCAT-Koppler EJ110x | EJ1101 | -0022 (Koppler mit externen Steckern, Netzteil und optionalen ID-Switchen) | -0016
Digital-Eingangs-Module EJ1xxx | EJ1008 8-kanalig | -0000 (Grundtyp) | -0017
Digital-Ausgangs-Module EJ2xxx | EJ2521 1-kanalig | -0224 (2 x 24 V Ausgänge) | -0016
Analog-Eingangs-Module EJ3xxx | EJ3318 8-kanaliges Thermoelement | -0000 (Grundtyp) | -0017
Analog-Ausgangs-Module EJ4xxx | EJ1434 4-kanalig | -0000 (Grundtyp) | -0019
Sonderfunktions-Module EJ5xxx, EJ6xxx | EJ6224 IO-Link-Master | -0090 (mit TwinSAFE SC) | -0016
Motor-Module EJ7xxx | EJ7211 Servomotorendstufe | -9414 (mit OCT, STO und TwinSAFE SC) | -0029
Hinweise
▪
die oben genannten Elemente ergeben die technische Bezeichnung, im Folgenden wird das Beispiel EJ1008-0000-0017 verwendet.
▪
Davon ist EJ1008-0000 die Bestellbezeichnung, umgangssprachlich bei „-0000“ dann oft nur EJ1008 genannt.
▪
Die Revision -0017 gibt den technischen Fortschritt wie z. B. Feature-Erweiterung in Bezug auf die EtherCAT Kommunikation wieder und wird von Beckhoff verwaltet.
Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders z. B. in der Dokumentation angegeben.
Jeder Revision zugehörig und gleichbedeutend ist üblicherweise eine Beschreibung (ESI, EtherCAT Slave Information) in Form einer XML-Datei, die zum Download auf der Beckhoff Webseite bereitsteht.
Die Revision wird auf der Seite der EtherCAT-Steckmodule aufgebracht, siehe folgende Abbildung.
▪
Produktbezeichnung, Version und Revision werden als dezimale Zahlen gelesen, auch wenn sie technisch hexadezimal gespeichert werden.
Seriennummer
Die 8-stellige Seriennummer ist auf dem EtherCAT-Steckmodul auf der Seite aufgedruckt (s. folgende Abb. C). Diese Seriennummer gibt den Bauzustand im Auslieferungszustand an und kennzeichnet somit eine ganze Produktions-Charge, unterscheidet aber nicht die Module einer Charge.
Bestellbezeichnung (A), Revisionsnummer (B) und Seriennummer (C) am Beispiel EJ1008
Seriennummer | Beispiel Seriennummer: 08 15 08 16
KK - Produktionswoche (Kalenderwoche) | 08 - Produktionswoche 08
YY - Produktionsjahr | 15 - Produktionsjahr 2015
FF - Firmware-Stand | 08 - Firmware-Stand 08
HH - Hardware-Stand | 16 - Hardware-Stand 16
Weiterführende Informationen
•
Beckhoff Identification Code (BIC)
•
Zertifikate


Beckhoff Identification Code (BIC)

Vorwort [image] Kennzeichnung von EtherCAT-Steckmodulen [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
Der Beckhoff Identification Code (BIC) wird vermehrt auf Beckhoff Produkten zur eindeutigen Identitätsbestimmung des Produkts aufgebracht. Der BIC ist als Data Matrix Code (DMC, Code-Schema ECC200) dargestellt, der Inhalt orientiert sich am ANSI-Standard MH10.8.2-2016.
BIC als Data Matrix Code (DMC, Code-Schema ECC200)
Die Einführung des BIC erfolgt schrittweise über alle Produktgruppen hinweg.
Er ist je nach Produkt an folgenden Stellen zu finden:
▪
auf der Verpackungseinheit
▪
direkt auf dem Produkt (bei ausreichendem Platz)
▪
auf Verpackungseinheit und Produkt
Der BIC ist maschinenlesbar und enthält Informationen, die auch kundenseitig für Handling und Produktverwaltung genutzt werden können.
Jede Information ist anhand des so genannten Datenidentifikators (ANSI MH10.8.2-2016) eindeutig identifizierbar. Dem Datenidentifikator folgt eine Zeichenkette. Beide zusammen haben eine maximale Länge gemäß nachstehender Tabelle. Sind die Informationen kürzer, werden sie durch Leerzeichen ersetzt. Die Daten unter den Positionen 1-4 sind immer vorhanden.
Folgende Informationen sind enthalten:
Pos-Nr. | Art der Information | Erklärung | Daten - identifikator | Anzahl Stellen inkl. Datenidentifikator | Beispiel
1 | Beckhoff-Artikelnummer | Beckhoff - Artikelnummer | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Eindeutige Seriennummer, Hinweis s. u. | S | 12 | SBTNk4p562d7
3 | Artikelbezeichnung | Beckhoff Artikelbezeichnung, z. B. EL1008 | 1K | 32 | 1KEL1809
4 | Menge | Menge in Verpackungseinheit, z. B. 1, 10… | Q | 6 | Q1
5 | Chargennummer | Optional: Produktionsjahr und -woche | 2P | 14 | 2P401503180016
6 | ID-/Seriennummer | Optional: vorheriges Seriennummer-System, z. B. bei Safety-Produkten oder kalibrierten Klemmen | 51S | 12 | 51S678294104
7 | Variante | Optional: Produktvarianten-Nummer auf Basis von Standardprodukten | 30P | 32 | 30PF971 , 2*K183
... |  |  |  |  |
Weitere Informationsarten und Datenidentifikatoren werden von Beckhoff verwendet und dienen internen Prozessen.
Aufbau des BICs
Beispiel einer zusammengesetzten Information aus den Positionen 1 - 4 und 6.
Die Datenidentifikatoren sind zur besseren Darstellung jeweils rot markiert:
BTN
Ein wichtiger Bestandteil des BICs ist die Beckhoff Traceability Number (BTN, Pos.-Nr. 2). Die BTN ist eine eindeutige, aus acht Zeichen bestehende Seriennummer, die langfristig alle anderen Seriennummern-Systeme bei Beckhoff ersetzen wird (z. B. Chargenbezeichungen auf IO-Komponenten, bisheriger Seriennummernkreis für Safety-Produkte, etc.). Die BTN wird ebenfalls schrittweise eingeführt, somit kann es vorkommen, dass die BTN noch nicht im BIC codiert ist.
Hinweis
Diese Information wurde sorgfältig erstellt. Das beschriebene Verfahren wird jedoch ständig weiterentwickelt. Wir behalten uns das Recht vor, Verfahren und Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern. Aus den Angaben, Abbildungen und Beschreibungen in dieser Information können keine Ansprüche auf Änderung geltend gemacht werden.


Zertifikate

Vorwort [image] Kennzeichnung von EtherCAT-Steckmodulen [image] Zertifikate
Zertifikate
▪
Die EtherCAT-Steckmodule erfüllen die Anforderungen der EMV- und Niederspannungsrichtlinie. Das CE - Zeichen ist auf der Seite der Module aufgedruckt.
▪
Der Aufdruck cRUus kennzeichnet Geräte, welche die Anforderungen für Produktsicherheit nach US-Amerikanischen bzw. kanadischen Vorschriften erfüllen.
▪
Das Warnsymbol gilt als Aufforderung die zugehörige Dokumentation zu lesen. Die Dokumentationen zu den EtherCAT-Steckmodulen werden auf der Beckhoff-Homepage zum Download zur Verfügung gestellt.
Kennzeichen für CE und UL am Beispiel EJ1008


Systemübersicht

Systemübersicht
Systemübersicht
Die EtherCAT-Steckmodule EJxxxx basieren elektronisch auf dem EtherCAT-I/O-System. Das EJ-System besteht aus dem Signal-Distribution-Board und EtherCAT-Steckmodulen. Auch die Anbindung eines IPCs im EJ-System ist möglich.
Die Anwendung des EJ-Systems eignet sich für die Produktion von Großserien, Applikationen mit geringem Platzbedarf und Applikationen, die ein geringes Gesamtgewicht fordern.
Eine Erweiterung der Maschinenkomplexität kann folgende Maßnahmen erreicht werden:
▪
die Auslegung von Reserve-Slots,
▪
den Einsatz von Platzhaltermodulen,
▪
die Verknüpfung von EtherCAT-Klemmen und EtherCAT-Boxen über eine EtherCAT-Verbindung.
Die folgende Abbildung zeigt beispielhaft ein EJ-System. Die abgebildeten Komponenten dienen ausschließlich der funktionell-schematischen Darstellung.
EJ-System Beispiel
Signal-Distribution-Board
Das Signal-Distribution-Board verteilt die Signale und die Spannungsversorgung auf einzelne applikationsspezifische Steckverbinder, um die Steuerung mit weiteren Maschinenmodulen zu verbinden. Durch das Anstecken von vorkonfektionierten Kabelbäumen entfällt die aufwändige Einzeladerverdrahtung. Die Stückkosten und das Risiko der Fehlverdrahtung werden durch kodierte Bauteile reduziert.
Die Entwicklung des Signal-Distribution-Boards kann als Engineering-Dienstleistung durch Beckhoff erfolgen. Es besteht ebenfalls die Möglichkeit, dass der Kunde auf Basis des Design-Guides das Signal-Distribution-Board selbst entwickelt.
EtherCAT - Steckmodule
Analog zum EtherCAT-Klemmensystem besteht ein Modulstrang aus einem Buskoppler und I/O-Modulen. Nahezu alle EtherCAT-Klemmen lassen sich auch in der EJ-Bauform als EtherCAT-Steckmodul realisieren. Die EJ-Module werden direkt auf das Signal-Distribution-Board aufgesteckt. Die Kommunikation, Signalverteilung und Versorgung erfolgt über die Kontakt-Pins auf der Rückseite des Moduls und die Leiterbahnen des Signal-Distribution-Boards. Die Kodierstifte auf der Rückseite dienen als mechanischer Fehlsteckschutz. Zur besseren Unterscheidung der Module ist das Gehäuse mit einer Farbkodierung versehen.


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
EJ7211-0010 - Einführung
•
EJ7211-0010 - Technische Daten
•
Technologie
•
EJ7211-0010 - Kontaktbelegung
•
EJ7211-0010 - LEDs


EJ7211-0010 - Einführung

Produktübersicht [image] EJ7211-0010 - Einführung
EJ7211-0010 - Einführung
EJ7211-0010
Servomotormodul für OCT, 48 VDC, 4,5 A (Ieff)
Das Servomotor-EtherCAT-Steckmodul EJ7211-0010, mit integrierter One Cable Technology (OCT), bietet hohe Servo-Performance in sehr kompakter Bauform, für Motoren der Baureihe AM8100, bis 4,5 A (Ieff). Die One Cable Technology vereinigt Motorleitung und ein absolutes Feedbacksystem in einer einzigen Leitung. Das integrierte elektronische Typenschild der AM81xx-Motoren kann von dem Servomodul automatisch eingelesen werden und konfiguriert die Motorparameter automatisch. Dadurch vereinfachen sich Verdrahtungsaufwand und Inbetriebnahme auf ein Minimum.
Die schnelle Regelungstechnik, auf Basis einer feldorientierten Strom- und PI-Drehzahlregelung, unterstützt schnelle und hochdynamische Positionieraufgaben. Zahlreiche Überwachungen, wie der Über- und Unterspannung, des Überstroms, der Modultemperatur oder der Motorauslastung, über die Berechnung eines I²T-Modells, bieten ein Höchstmaß an Betriebssicherheit. EtherCAT, als leistungsfähige Systemkommunikation, und CAN-over-EtherCAT (CoE), als Applikationsschicht, ermöglichen die ideale Anbindung an die PC-basierte Steuerungstechnik. Neueste Leistungshalbleiter garantieren minimale Verlustleistung und ermöglichen beim Bremsbetrieb eine Rückspeisung in den Zwischenkreis. Signal-LEDs zeigen Status-, Warn- und Fehlermeldungen sowie eventuell aktive Limitierungen an.
Empfohlende TwinCAT-Version
Um die volle Performance des Moduls in Anspruch nehmen zu können wird empfohlen, das Modul mit mindestens TwinCAT 2.11 R3 zu betreiben!
Obligatorische Hardware
Das Modul muss mit einem echtzeitfähigen Rechner und Distributed Clocks betrieben werden!
Freigegebene Motoren
Ein einwandfreier Betrieb kann nur mit den von Beckhoff freigegebenen Motoren gewährleistet werden.


EJ7211-0010 - Technische Daten

Produktübersicht [image] EJ7211-0010 - Technische Daten
EJ7211-0010 - Technische Daten
Technische Daten | EJ7211-0010
Anzahl Kanäle | 1 Servomotor, absolutes Feedback, Motorbremse, 2 digitale Eingänge
Anschlusstechnik | Motordirektanschluss
Lastart | Permanenterregte Synchronmotoren
Zwischenkreisversorgungsspannung | 8 .. 48 VDC
Ausgangsstrom IN | 4,5 A (effektiv) / 6,3 A (Spitzenwert)
Spitzenstrom IN | 9 A (effektiv) / 12.6 A (Spitzenwert) für 1 Sekunde
Frequenzbereich | 0 Hz .. 599 Hz
PWM-Taktfrequenz | 16 kHz
Stromreglerfrequenz | doppelte PWM Schaltfrequenz
Drehzahlreglerfrequenz | 16 kHz
Ausgangsspannung Motorhaltebremse | 24 VDC
Max. Ausgangsstrom Motorhaltebremse | max. 0,5 A
Stromaufnahme E-Bus | typ. 130 mA
Unterstützt Funktion NoCoeStorage | ja
Potenzialtrennung | 500 V (E-Bus/Signalspannung)
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C .. + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C .. + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Betriebshöhe | max 2.000 m
Abmessungen (B x H x T) | ca. 24 mm x 66 mm x 55 mm
Gewicht | ca. 50 g
Montage | Auf Signal-Distribution-Board
Verschmutzungsgrad | 2
Einbaulage | Standard
Position der Kodierstifte | 1 und 8
Farbkodierung | orange
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27 (mit entsprechendem Signal-Distribution-Board)
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4 (mit entsprechendem Signal-Distribution-Board)
EMV Kategorie | Kategorie C3 - Standard Kategorie C2, C1 - Zusatzfilter erforderlich
Schutzart | EJ-Modul: IP20 EJ-System: abhängig von Signal-Distribution-Board und Gehäuse
Zulassung | CE, UL
CE-Zulassung
Die CE-Kennzeichnung bezieht sich auf das genannte EtherCAT-Steckmodul.
Bei Einbau des EtherCAT-Steckmoduls zur Herstellung eines verwendungsfertigen Endprodukts (Leiterkarte in Verbindung mit einem Gehäuse) ist die Richtlinienkonformität und die CE-Zertifizierung des Gesamtsystems durch den Hersteller des Endprodukts zu prüfen.
Für den Betrieb der EtherCAT-Steckmodule ist der Einbau in ein Gehäuse vorgeschrieben.


Technologie

Produktübersicht [image] Technologie
Technologie
Das Servomotormodul EJ72x1-xxxx integriert einen vollwertigen Servoverstärker für Servomotoren bis 276 W in kleinster Bauform.
Servomotor
Der Servomotor ist ein elektrischer Motor. Zusammen mit einem Servoverstärker bildet der Servomotor einen Servoantrieb. Der Servomotor wird in einem geschlossenen Regelkreis positions-, moment- oder geschwindigkeitsgeregelt betrieben.
Das Servomotormodul EJ72x1-xxxx unterstützt die Ansteuerung von permanenterregten Synchronmotoren. Diese bestehen aus drei um 120° verschobenen Spulen und einem permanenterregten Rotor.
Drei um 120° verschobenen Spulen eines Synchronmotors
Besonders in hochdynamischen und präzise-positionierenden Anwendungen zeigen Servomotoren ihre Vorzüge:
▪
sehr hohe Positioniergenauigkeit bei Applikationen mit höchstem Präzisionsanspruch durch integrierte Positionsrückführung
▪
hoher Wirkungsgrad und hohes Beschleunigungsvermögen
▪
Servomotoren sind überlastbar und verfügen daher über eine weitaus höhere Dynamik als beispielsweise ein Schrittmotor
▪
belastungsunabhängiges hohes Drehmoment bis in die oberen Drehzahlbereiche
▪
reduzierter Einsatz von Wartung auf ein Minimum
Das EtherCAT-Servomotormodul bietet dem Anwender die Möglichkeit kompakte und kostengünstige Anlagen zu konstruieren, ohne auf die Vorteile eines Servomotors verzichten zu müssen.
Das Beckhoff Servomodul
Das Servomotormodul EJ72x1-xxxx ist ein vollwertiger Servoverstärker für den direkten Anschluss von Servomotoren im unteren Leistungsbereich. Weitere Module oder Verkabelung, um eine Verbindung zum Steuerungssystem herzustellen entfallen dadurch komplett. Das führt zu einer sehr kompakten Steuerungslösung. Durch die E-Bus-Anbindung des Servomotormoduls EJ72x1-xxxx stehen dem Anwender die Eigenschaften von EtherCAT in vollen Zügen zur Verfügung. Dazu zählen insbesondere die kurze Zykluszeit, der niedrige Jitter, die Gleichzeitigkeit und die einfache Diagnose, die EtherCAT zu bieten hat. Mit Hilfe dieser Performance von EtherCAT kommt die Dynamik, die ein Servomotor erreichen kann, optimal zur Geltung.
Eine Nennspannung von max. 48 VDC und ein Nennstrom von max. 4,5 A ermöglichen es dem Anwender einen Servomotor mit einer Leistung von bis zu 276 W anzutreiben. Als Last können permanenterregte Synchronmotoren mit einem Nennstrom bis 4,5 A betrieben werden. Zahlreiche Überwachungen, z. B. der Über- und Unterspannung, des Überstroms, der Modultemperatur oder der Motorauslastung, bieten ein Höchstmaß an Betriebssicherheit. Moderne Leistungshalbleiter garantieren minimale Verlustleistung und ermöglichen, im Bremsbetrieb, eine Rückspeisung in den Zwischenkreis.
Die integrierte, schnelle Regelungstechnik, mit einer feldorientierten Strom- und PI-Drehzahlregelung unterstützt hochdynamische Positionieraufgaben. Neben dem direkten Anschluss von Motor und Resolver ist auch der Anschluss einer Motorhaltebremse möglich.
Das EtherCAT-Steckmodul EJ72x1-xx1x verfügt über zwei digitale Eingänge, die für die Funktion „Touch Probe“ genutzt werden können. Der Status der Eingänge kann über die „Select Info Data“ (Profil MDP 742 und DS 402) zurückgelesen werden.
Anbindung an die Steuerung
Ein weiterer großer Vorteil des Servomotormoduls EJ72x1-xxxx ist die einfache Anbindung an die Steuerungslösung. Die vollständige Integration in das Steuerungssystem erleichtert die Inbetriebnahme und Parametrierung. Wie jedes andere EtherCAT-Steckmodul wird das Servomotormodul EJ72x1-xxxx einfach auf das Signal-Distribution-Board aufgesteckt. Anschließend kann der Modulstrang komplett vom TwinCAT System Manager eingescannt oder vom Applikateur manuell angefügt werden. Im System Manager kann das Servomotormodul EJ72x1-xxxx mit der TwinCAT NC verknüpft und parametriert werden.
Skalierbare Motion-Lösung
Das Servomodul ergänzt die Produktpalette der Kompakt-Antriebstechnik für die Beckhoff I/O-Systeme, die für Schrittmotoren, AC- und DC-Motoren verfügbar sind. Mit dem Servomodul EJ72x1-xxxx wird das Angebot an Servoverstärkern noch feiner skalierbar: Vom Kleinst-Servoverstärker bis 170 W, in der EtherCAT-Klemme, bis zum AX5000-Servoverstärker mit 118 kW, bietet Beckhoff ein breites Programm, inklusive der Servomotoren.
Die Baureihe AM81xx wurde speziell für die Servomotorklemme EL72x1/ das Servomotormodul EJ72x1 entwickelt.
Die One Cable Technology (OCT)
Bei den Servomotoren der Serie AM8100-xF2 x erfolgt die Übertragung der Feedback-Signale direkt über die Leitung zur Spannungsversorgung, sodass Power und Feedbacksystem in einem Motoranschlusskabel zusammengefasst sind. Durch die One Cable Technology werden die Informationen störsicher und zuverlässig über eine digitale Schnittstelle übertragen. Da sowohl motor- als auch reglerseitig Kabel und Steckverbinder entfallen, werden die Komponenten- und Inbetriebnahmekosten reduziert.
Thermisches Motormodell I²T
Das thermische I²T Motormodell bildet das thermische Verhalten der Motorwicklung unter Berücksichtigung des absoluten Wärmewiderstands Rth und der Wärmekapazität Cth des Motors und der Statorwicklung ab.
Im Modell wird angenommen, dass der Motor bei Dauerbetrieb mit Nennstrom Inenn seine maximale Dauerbetriebstemperatur Tnenn erreicht. Diese Temperatur entspricht einer Auslastung des Motors von 100%. Bei Betrieb mit Nennstrom erreicht das Motormodell nach einer Zeit von τth=Rth∙Cth eine Auslastung von 63% und erreicht langsam seine Dauerbetriebstemperatur.
Wird der Motor mit einem Strom größer dem Nennstrom betrieben, erreicht das Modell eine Auslastung von 100% schneller.
Überschreitet die Auslastung des I²T Modells den Wert von 100%, wird der angeforderte Sollstrom auf den Nennstrom limitiert, um die Motorwicklung thermisch zu schützen. Die Auslastung fällt auf maximal 100% zurück. Bei Unterschreiten des Nennstroms fällt die Auslastung auf unter 100% und die Limitierung des Sollstroms wird aufgehoben.
Bei einem vorher auf Umgebungstemperatur abgekühlten Motor kann die Zeit zum Erreichen von 100% Auslastung bei Bestromung mit einem Sollstrom größer als Nennstrom grob mit τth∙Inenn²/Iist² abgeschätzt werden.
Die exakte Berechnung des Durchtritts von 100% Auslastung erfordert die Kenntnis der aktuellen Auslastung.
Limitierung auf den Nennstroms des Motors


EJ7211-0010 - Kontaktbelegung

Produktübersicht [image] EJ7211-0010 - Kontaktbelegung
EJ7211-0010 - Kontaktbelegung
EJ7211-0010 - Kontaktbelegung
Der Leiterkarten Footprint steht auf der Beckhoff-Homepage zum Download bereit.
Hinweis
Schädigung von Geräten möglich!
•
Die mit „NC“ benannten Pins dürfen nicht kontaktiert werden.
•
Vor der Montage und Inbetriebnahme lesen Sie auch die Kapitel Installation von EJ-Modulen und Inbetriebnahme!


EJ7211-0010 - LEDs

Produktübersicht [image] EJ7211-0010 - LEDs
EJ7211-0010 - LEDs
EJ7211-0010 - LEDs
LEDs (linke Seite)
LED | Farbe | Anzeige | Zustand | Beschreibung
RUN | grün | aus | Init | Zustand der EtherCAT State Machine: INIT = Initialisierung des Steckmoduls
 |  | blinkend | Pre-Operational | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | Einzelblitz | Safe-Operational | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Ausgänge bleiben im sicheren Zustand
 |  | an | Operational | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
 |  | flimmernd | Bootstrap | Zustand der EtherCAT State Machine: BOOTSTRAP = Funktion für Firmware-Updates des Steckmoduls
Read OCT | grün | blinkt | - | Das elektronische Typenschild wird gelesen
 |  | aus | - | Das Lesen des elektronischen Typenschilds wurde beendet
I 1…I 2 | grün | aus | - | Signalspannung „0“
 |  | an | - | Signalspannung „1“
LEDs (rechte Seite)
LED | Farbe | Anzeige | Bedeutung
Driver | grün | an | Treiberstufe betriebsbereit
+48V | grün | aus | Versorgungsspannung (48 VDC) nicht vorhanden
 |  | an | Versorgungsspannung (48 VDC) vorhanden
Up | grün | aus | Keine Spannungsversorgung 24 VDC angeschlossen
 |  | an | Spannungsversorgung 24 VDC angeschlossen
Enable | grün | an | Die LED ist mit dem Bit 1 und 2 des Statuswortes (MDP742 / DS402) verknüpft (wenn „Switched on“ oder „Operation enabled“) Treiberstufe freigegeben
LIMIT | gelb | an | Die LED ist mit dem Bit 11 des Statuswortes (MDP742 / DS402) verknüpft (Internal limit active) Limit erreicht (z. B. Torque- oder Drehzahllimit)
WARN | gelb | blinkt | Fehler beim Lesen des Typenschildes
 |  | an | Die LED ist mit dem Bit 7 des Statuswortes (MDP742 / DS402) verknüpft (Warning) •Der Schwellwert „Warning“ ist überschritten. •I²T-Modell •Temperatur (80°C) überschritten •Spannung
ERR | rot | an | Die LED ist mit dem Bit 3 des Statuswortes (MDP742 / DS402) verknüpft (Fault) •Der Schwellwert für „Error“ ist überschritten. •Überstrom •Spannung nicht vorhanden •Resolver nicht angeschlossen •max. Temperatur (100°C) überschritten


Installation von EJ-Modulen

Installation von EJ-Modulen
Installation von EJ-Modulen
Weiterführende Informationen
•
Spannungsversorgung der EtherCAT-Steckmodule
•
EJxxxx - Abmessungen
•
Einbaulagen und Mindestabstände
•
Hinweise zur Strommessung über Hall-Sensor
•
Kodierungen
•
Montage auf dem Signal-Distribution-Board
•
Erweiterungsmöglichkeiten
•
IPC Integration
•
Demontage vom Signal-Distribution-Board


Spannungsversorgung der EtherCAT-Steckmodule

Installation von EJ-Modulen [image] Spannungsversorgung der EtherCAT-Steckmodule
Spannungsversorgung der EtherCAT-Steckmodule
SmallWarningYellow WARNUNG
Spannungsversorgung
Zur Versorgung der EJ-Koppler und -Module muss eine Schutzkleinspannung SELV/PELV verwendet werden. EJ-Koppler und -Module dürfen ausschließlich an SELV/PELV Stromkreise angeschlossen werden.
Beim Design des Signal-Distribution-Boards ist die Spannungsversorgung für die maximal mögliche Strombelastung des Modulstrangs auszulegen. Die Information, wie viel Strom aus der E-Bus-Versorgung benötigt wird, finden Sie für jedes Modul in der jeweiligen Dokumentation im Kapitel „Technische Daten“, online und im Katalog. Im TwinCAT System Manager wird der Strombedarf des Modulstrangs angezeigt.
E-Bus-Spannungsversorgung mit EJ1100 oder EJ1101-0022 und EJ940x
Der Buskoppler EJ1100 versorgt die angefügten EJ-Module mit der E-Bus-Systemspannung von 3,3 V. Dabei ist der Koppler bis zu 2,2 A belastbar. Wird mehr Strom benötigt, ist die Kombination aus dem Koppler EJ1101-0022 und den Netzteilen EJ9400 (2,5 A) oder EJ9404 (12 A) zu verwenden. Die Netzteile EJ940x können als zusätzliche Einspeisemodule im Modulstrang eingesetzt werden.
Je nach Applikation stehen folgende Kombinationen zur E-Bus-Versorgung zur Verfügung:
E-Bus-Spannungsversorgung mit EJ1100 oder EJ1101-0022 + EJ940x
Bei dem Koppler EJ1101-0022 sind die RJ45 Verbinder und die optionalen ID-Switche extern ausgeführt und können auf dem Signal-Distribution-Board beliebig platziert werden. Somit wird die einfache Durchführung durch ein Gehäuse ermöglicht.
Die Netzteil-Steckmodule EJ940x stellen eine optionale Reset-Funktion zur Verfügung (s. Kapitel Kontaktbelegung der Dokumentationen zu EJ9400 und EJ9404)
E-Bus-Spannungsversorgung mit CXxxxx und EK1110-004x
Der Embedded PC versorgt die angereihten EtherCAT-Klemmen und den EtherCAT-EJ-Koppler
▪
mit einer Versorgungsspannung 24 VDC ( -15 %/+20%). Aus dieser Spannung werden der E-Bus und die Busklemmenelektronik versorgt.
Die CXxxxx versorgen den E-Bus mit max. 2.000 mA E-Bus-Strom. Wird durch die angefügten Klemmen mehr Strom benötigt, sind Einspeiseklemmen bzw. Netzteil-Steckmodule zur E-Bus-Versorgung zu setzen.
▪
mit einer Peripheriespannung Up von 24 VDC zur Versorgung der Feldelektronik.
Die EtherCAT-EJ-Koppler EK1110-004x leiten über den rückwärtigen Stecker
▪
die E-Bus Signale,
▪
die E-Bus Spannung UEBUS (3,3 V) und
▪
die Peripheriespannung UP (24 VDC)
an das Signal-Distribution-Board weiter.
Leiterkarte mit Embedded PC, EK1110-0043 und EJxxxx, Rückansicht EK1110-0043


EJxxxx - Abmessungen

Installation von EJ-Modulen [image] EJxxxx - Abmessungen
EJxxxx - Abmessungen
Die EJ-Module sind aufgrund ihrer Bauform kompakt und leicht. Ihr Volumen ist ca. 50% kleiner als das Volumen der EL-Klemmen. Je nach Breite und Höhe wird zwischen vier verschiedenen Modultypen unterschieden:
Modultyp | Abmessungen (B x H x T) | Bsp. In folgender Abb. (Benennung der Zeichnung im Downloadfinder)
Koppler | 44 mm x 66 mm x 55 mm | EJ1100 (ej_44_2xrj45_coupler)
1-fach Modul | 12 mm x 66 mm x 55 mm | EJ1809 (ej_12_16pin_code13)
2-fach Modul | 24 mm x 66 mm x 55 mm | EJ7342 (ej_24_2x16pin_code18)
1-fach Modul (lang) | 12 mm x 152 mm x 55 mm | EJ1957 (ej_12_2x16pin_extended_code4747)
EJxxxx - Abmessungen
Zeichnungen für die EtherCAT-Steckmodule finden Sie im Downloadfinder. Die Benennung der Zeichnungen setzt sich wie in untenstehender Zeichnung beschrieben zusammen.
Technischen Zeichnungen im Downloadfinder


Einbaulagen und Mindestabstände

Installation von EJ-Modulen [image] Einbaulagen und Mindestabstände
Einbaulagen und Mindestabstände
Weiterführende Informationen
•
Mindestabstände zur Sicherung der Montagefähigkeit
•
Einbaulagen


Mindestabstände zur Sicherung der Montagefähigkeit

Installation von EJ-Modulen [image] Einbaulagen und Mindestabstände [image] Mindestabstände zur Sicherung der Montagefähigkeit
Mindestabstände zur Sicherung der Montagefähigkeit
Zur sicheren Verrastung und einfachen Montage / Demontage der Module berücksichtigen Sie beim Design des Signal-Distribution-Boards die in der folgenden Abbildung angegebenen Maße.
Montageabstände EJ-Modul - PCB
Einhalten des Griffbereichs
Es wird zur Montage / Demontage ein Griffbereich von mindestens 92 mm benötigt, um mit den Fingern die Montagelaschen erreichen zu können.
Bei Einhaltung der empfohlenen Mindestabstände zur Belüftung (s. Kapitel Einbaulage), ist ein ausreichend großer Griffbereich gewährleistet.
Das Signal-Distribution-Board muss eine Stärke von 1,6 mm und einen Abstand von mindestens 4 mm zur Montagefläche haben, um die Verrastung der Module auf dem Board sicherzustellen.


Einbaulagen

Installation von EJ-Modulen [image] Einbaulagen und Mindestabstände [image] Einbaulagen
Einbaulagen
Hinweis
Einschränkung von Einbaulage und Betriebstemperaturbereich
Entnehmen Sie den technischen Daten der verbauten Komponenten, ob es Einschränkungen bei Einbaulage und/oder Betriebstemperaturbereich unterliegt. Sorgen Sie bei der Montage von Modulen mit erhöhter thermischer Verlustleistung dafür, dass im Betrieb oberhalb und unterhalb der Module ausreichend Abstand zu anderen Komponenten eingehalten wird, so dass die Module ausreichend belüftet werden!
Die Verwendung der Standard Einbaulage wird empfohlen. Wird eine andere Einbaulage verwendet, prüfen Sie, ob zusätzliche Maßnahmen zur Belüftung erforderlich sind!
Stellen Sie sicher, dass die spezifizierten Umgebungsbedingungen (siehe technische Daten) eingehalten werden!
Optimale Einbaulage (Standard)
Für die optimale Einbaulage wird das Signal-Distribution-Board waagerecht montiert und die Fronten der EJ-Module weisen nach vorne (siehe Abb. Empfohlene Abstände bei Standard Einbaulage). Die Module werden dabei von unten nach oben durchlüftet, was eine optimale Kühlung der Elektronik durch Konvektionslüftung ermöglicht. Bezugsrichtung „unten“ ist hier die Erdbeschleunigung.
Empfohlene Abstände bei Standard Einbaulage
Die Einhaltung der Abstände nach Abb. Empfohlene Abstände bei Standard Einbaulage wird empfohlen. Die empfohlenen Mindestabstände sind nicht als Sperrbereiche für andere Bauteile zu sehen. Die Einhaltung der in den Technischen Daten beschriebenen Umgebungsbedingungen ist durch den Kunden zu prüfen und gegebenenfalls durch zusätzliche Maßnahmen zur Kühlung sicherzustellen.
Weitere Einbaulagen
Alle anderen Einbaulagen zeichnen sich durch davon abweichende räumliche Lage des Signal-Distribution-Boards aus, s. Abb. Weitere Einbaulagen.
Auch in diesen Einbaulagen empfiehlt sich die Anwendung der oben angegebenen Mindestabstände zur Umgebung.
EJxxx_other mounting positions
Weitere Einbaulagen


Hinweise zur Strommessung über Hall-Sensor

Installation von EJ-Modulen [image] Hinweise zur Strommessung über Hall-Sensor
Hinweise zur Strommessung über Hall-Sensor
Das in dieser Dokumentation angesprochene Gerät verfügt über einen oder mehrere integrierte Hall-Sensoren zur Strommessung.
Dabei wird das magnetische Feld, das durch einen Stromfluss durch einen Leiter erzeugt wird, von dem Hall-Sensor quantitativ erfasst.
Um die Messung nicht zu beeinträchtigen wird empfohlen, äußere Magnetfelder vom Gerät abzuschirmen oder hinreichend weit entfernt zu halten.
Hinweis
Hintergrund
Ein stromdurchflossener Leiter erzeugt in seinem Umfeld ein magnetisches Feld nach
B = µ0 * I / (2π * d)
mit
B [Tesla] magnetisches Feld
µ0 = 4*π*10-7 [H/m] (Annahme: keine magnetische Abschirmung)
I [A] Strom
d [m] Abstand zum Leiter
Beeinträchtigung durch äußere Magnetfelder
Die magnetische Feldstärke sollte allseitig um das Gerät herum eine zulässige Größe nicht übersteigen.
Praktisch bedeutet dies für den empfohlenen Mindestabstand eines benachbarten Stromleiters zur Geräteoberfläche:
- Strom 10 A: 12 mm
- Strom 20 A: 25 mm
- Strom 40 A: 50 mm
Wenn es in der Gerätedokumentation nicht anders spezifiziert ist, ist das Aneinanderreihen von Modulen (z.B. Reihenklemmen im 12 mm Rastermaß) gleichen Typs (z.B. EL2212-0000) darüber hinaus zulässig.


Kodierungen

Installation von EJ-Modulen [image] Kodierungen
Kodierungen
Weiterführende Informationen
•
Farbkodierung
•
Mechanische Positionskodierung


Farbkodierung

Installation von EJ-Modulen [image] Kodierungen [image] Farbkodierung
Farbkodierung
EJ-Module Farbcode am Beispiel EJ1809
Zur besseren Übersicht im Schaltschrank verfügen die EJ-Module über eine Farbkodierung (s. Abb. oben). Der Farbcode gibt die Signalart an. Die folgende Tabelle gibt einen Überblick über die Signalart mit der zugehörigen Farbkodierung.
Signalart | Module | Farbe
Koppler | EJ11xx | Ohne Farbkodierung
Digital Eingang | EJ1xxx | Gelb
Digital Ausgang | EJ2xxx | Rot
Analog Eingang | EJ3xxx | Grün
Analog Ausgang | EJ4xxx | Blau
Motion | EJ7xxx | orange
System | EJ9xxx | grau


Mechanische Positionskodierung

Installation von EJ-Modulen [image] Kodierungen [image] Mechanische Positionskodierung
Mechanische Positionskodierung
Die Module verfügen über zwei signalspezifische Kodierstifte an der Unterseite (s. folgende Abb. B1 und B2). Die Kodierstifte bieten, in Verbindung mit den Kodierlöchern im Signal-Distribution-Board (folgende Abb. A1 und A2), die Option, einen mechanischen Fehlsteckschutz zu realisieren. Während der Montage und im Servicefall wird so das Fehlerrisiko deutlich reduziert.
Koppler und Platzhaltermodule haben keine Kodierstifte.
Mechanische Positionskodierung mit Kodierstiften (B1 u. B2) und Kodierlöchern (A1 u. A2)
Die folgende Abbildung zeigt die Position der Positionskodierung mit den Positionsnummern auf der linken Seite. Module mit gleicher Signalart haben die gleiche Kodierung. So haben z. B. alle Digitalen Eingangsmodule die Kodierstifte an den Positionen eins und drei. Es besteht kein Steckschutz zwischen Modulen der gleichen Signalart. Deshalb ist bei der Montage der Einsatz des korrekten Moduls anhand der Gerätebezeichnung zu prüfen.
Pin-Kodierung am Beispiel digitaler Eingangsmodule


Montage auf dem Signal-Distribution-Board

Installation von EJ-Modulen [image] Montage auf dem Signal-Distribution-Board
Montage auf dem Signal-Distribution-Board
EJ-Module werden auf dem Signal-Distribution Board montiert. Die elektrischen Verbindungen zwischen Koppler und EJ-Modulen werden über die Pin-Kontakte und das Signal-Distribution Board realisiert.
Die EJ-Komponenten müssen in einem Schaltschrank oder Gehäuse installiert werden, welches vor Brandgefahren, Umwelteinflüssen und mechanischen Einflüssen schützen muss.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Modul-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Module beginnen!
Hinweis
Beschädigung von Komponenten durch Elektrostatische Entladung möglich!
Beachten Sie die Vorschriften zum ESD-Schutz!
Montage EJ–Module
A1 / A2 | Rastnasen oben / unten | C1 / C2 | Halterungslöcher
B1 / B2 | Kodierstifte | D1 / D2 | Kodierlöcher
Zur Montage des Moduls auf dem Signal-Distribution-Board gehen Sie wie folgt vor:
1.
Stellen Sie sicher, dass das Signal-Distribution-Board vor der Montage der Module fest mit der Montagefläche verbunden ist. Die Montage auf dem unbefestigten Signal-Distribution-Board kann zu Beschädigungen des Boards führen.
2.
Prüfen Sie ggf., ob die Position der Kodierstifte (B) und der entsprechenden Löcher im Signal-Distribution-Board (D) übereinstimmen.
3.
Vergleichen Sie die Gerätebezeichnung auf dem Modul mit den Angaben im Installationsplan.
4.
Drücken Sie die obere und die untere Montagelasche gleichzeitig und stecken das Modul unter leichter Aufwärts- und Abwärtsbewegung auf das Board bis das Modul sicher verrastet ist.
Nur wenn das Modul fest eingerastet ist, kann der benötigte Kontaktdruck aufgebaut und die maximale Stromtragfähigkeit gewährleistet werden.
5.
Belegen Sie Lücken im Modulstrang mit Platzhaltermodulen (EJ9001).
Hinweis
•
Achten Sie bei der Montage auf sichere Verrastung der Module mit dem Board! Die Folgen mangelnden Kontaktdrucks sind:
⇨
Qualitätsverluste des übertragenen Signals,
⇨
erhöhte Verlustleistung der Kontakte,
⇨
Beeinträchtigung der Lebensdauer.


Erweiterungsmöglichkeiten

Installation von EJ-Modulen [image] Erweiterungsmöglichkeiten
Erweiterungsmöglichkeiten
Für Änderungen und Erweiterungen des EJ-Systems stehen drei Möglichkeiten zur Verfügung.
▪
Austausch der Platzhaltermodule gegen die für den jeweiligen Slot vorgesehenen Funktionsmodule
▪
Belegung von Reserveslots am Ende des Modulstrangs mit den für die jeweiligen Slots vorgegebenen Funktionsmodulen
▪
Verknüpfung mit EtherCAT-Klemmen und EtherCAT-Box-Modulen über eine Ethernet/EtherCAT-Verbindung
Weiterführende Informationen
•
Belegung ungenutzter Slots durch Platzhaltermodule
•
Verknüpfung mit EtherCAT-Klemmen und EtherCAT-Box-Modulen über eine Ethernet/EtherCAT-Verbindung


Belegung ungenutzter Slots durch Platzhaltermodule

Installation von EJ-Modulen [image] Erweiterungsmöglichkeiten [image] Belegung ungenutzter Slots durch Platzhaltermodule
Belegung ungenutzter Slots durch Platzhaltermodule
Die Platzhaltermodule EJ9001 schließen temporäre Lücken im Modulstrang (s. folgende Abb. A1). Lücken im Modulstrang führen zu einer Unterbrechung der EtherCAT-Kommunikation und müssen durch Platzhaltermodule geschlossen werden.
Im Gegensatz zu den passiven Klemmen der EL-Serie nehmen die Platzhaltermodule aktiv am Datenaustausch teil. Es können daher mehrere Platzhaltermodule hintereinander gesteckt werden, ohne den Datenaustausch zu beeinträchtigen.
Ungenutzte Slots am Ende des Modulstrangs können als Reserveslots freigelassen werden (s. folgende Abb. B1).
Durch die Belegung ungenutzter Slots (s. folgende Abb. A2 - Austausch Platzhaltermodul und B2 - Belegung Reserveslots) entsprechend der Vorgaben für das Signal-Distribution-Board wird die Maschinenkomplexität erweitert (Extended-Version).
Beispiel Austausch Platzhaltermodule u. Belegung Reserveslots
E-Bus - Versorgung
Nach dem Austausch der Platzhaltermodule gegen andere Module verändert sich die Stromaufnahme aus dem E-Bus. Stellen Sie sicher, dass eine ausreichende Versorgung weiterhin gewährleistet wird.


Verknüpfung mit EtherCAT-Klemmen und EtherCAT-Box-Modulen über eine Ethernet/EtherCAT-Verbindung

Installation von EJ-Modulen [image] Erweiterungsmöglichkeiten [image] Verknüpfung mit EtherCAT-Klemmen und EtherCAT-Box-Modulen über eine Ethernet/EtherCAT-Verbindung
Verknüpfung mit EtherCAT-Klemmen und EtherCAT-Box-Modulen über eine Ethernet/EtherCAT-Verbindung
Beispiel Erweiterung über eine Ethernet/EtherCAT-Verbindung


IPC Integration

Installation von EJ-Modulen [image] IPC Integration
IPC Integration
Anbindung von CX- und EL-Klemmen über die EtherCAT-EJ-Koppler EK1110-004x
Die EtherCAT-EJ-Koppler EK1110-0043 und EK1110-0044 verbinden die kompakten Hutschienen-PCs der Serie CX und angereihte EtherCAT-Klemmen (ELxxxx) mit den EJ-Modulen auf dem Signal-Distribution-Board.
Die Spannungsversorgung der EK1110-004x erfolgt aus dem Netzteil des Embedded-PCs.
Die E-Bus-Signale und die Versorgungsspannung der Feldseite UP werden über einen Steckverbinder auf der Rückseite des EtherCAT-EJ-Kopplers direkt auf die Leiterkarte weitergleitet.
Durch die direkte Ankopplung des Embedded-PCs und der EL-Klemmen mit den EJ-Modulen auf der Leiterkarte können eine EtherCAT-Verlängerung (EK1110) und ein EtherCAT-Koppler (EJ1100) entfallen.
Der Embedded-PC ist mit EtherCAT-Klemmen erweiterbar, die z. B. noch nicht im EJ-System zur Verfügung stehen.
Beispiel Leiterkarte mit Embedded PC, EK1110-0043 und EJxxxx, Rückansicht EK1110-0043
Anbindung von C6015 / C6017 über die EtherCAT-Koppler EJ110x-00xx
Aufgrund der ultrakompakten Bauweise und der flexiblen Montagemöglichkeiten eignen sich die IPCs C6015 und C6017 ideal für die Anbindung an ein EJ-System.
In Kombination mit dem Montage-Set ZS5000-0003 ergibt sich die Möglichkeit den IPC C6015 und C6017 kompakt auf dem Signal-Distribution-Board zu platzieren.
Über das entsprechende EtherCAT-Kabel (s. folgende Abb. [A]) wird das EJ-System bestmöglich mit dem IPC verbunden.
Die Versorgung des IPCs kann mit beigefügtem Power-Stecker (s. folgende Abb. [B]) direkt über das Signal-Distribution-Board erfolgen.
Hinweis
Platzierung auf dem Signal-Distribution-Board
Die Abmessungen und Abstände für die Platzierung sowie weitere Details sind dem Design-Guide und den Dokumentationen zu den einzelnen Komponenten zu entnehmen.
Die folgende Abbildung zeigt beispielhaft die Anbindung des IPC C6015 an ein EJ-System. Die abgebildeten Komponenten dienen ausschließlich der funktionell-schematischen Darstellung.
Beispiel für die Anbindung des IPC C6015 an ein EJ-System


Demontage vom Signal-Distribution-Board

Installation von EJ-Modulen [image] Demontage vom Signal-Distribution-Board
Demontage vom Signal-Distribution-Board
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Modul-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Module beginnen!
Hinweis
Beschädigung von Komponenten durch Elektrostatische Entladung möglich!
Beachten Sie die Vorschriften zum ESD-Schutz!
Jedes Modul wird durch die Verrastung auf dem Distribution-Board gesichert, die zur Demontage gelöst werden muss.
Demontage EJ - Module
Zur Demontage vom Signal-Distribution-Board gehen Sie wie folgt vor:
1.
Stellen Sie sicher, dass das Signal-Distribution-Board vor der Demontage der Module fest mit der Montagefläche verbunden ist. Die Demontage vom unbefestigten Signal-Distribution-Board kann zu Beschädigungen des Boards führen.
2.
Drücken Sie die obere und die untere Montagelasche gleichzeitig und ziehen das Modul unter leichter Aufwärts- und Abwärtsbewegung vom Board ab.


EtherCAT-Grundlagen

EtherCAT-Grundlagen
EtherCAT-Grundlagen
Grundlagen zum Feldbus EtherCAT entnehmen Sie bitte der EtherCAT System-Dokumentation.


Inbetriebnahme

Inbetriebnahme
Inbetriebnahme
Weiterführende Informationen
•
Hinweis auf Dokumentation EL72x1-001x


Hinweis auf Dokumentation EL72x1-001x

Inbetriebnahme [image] Hinweis auf Dokumentation EL72x1-001x
Hinweis auf Dokumentation EL72x1-001x
Eine ausführliche Dokumentation zur Inbetriebnahme der EJ72x1-001x Module ist in Vorbereitung.
Hinweis
Schädigung von Geräten oder Datenverlust
Die Beschreibungen und Hinweise zur Inbetriebnahme der EtherCAT-Klemmen EL72x1-001x sind übertragbar auf die EtherCAT-Steckmodule EJ72x1-001x.
Lesen Sie vor der Inbetriebnahme die ausführliche Beschreibung der Prozessdaten, Betriebsmodi und Parametrierung der EL72x1-001x Dokumentation.


Diagnose - Grundlagen zu Diag Messages

Diagnose - Grundlagen zu Diag Messages
Diagnose - Grundlagen zu Diag Messages
Mit DiagMessages wird ein System der Nachrichtenübermittlung vom EtherCAT Slave an den EtherCAT Master/TwinCAT bezeichnet. Die Nachrichten werden vom Gerät im eigenen CoE unter 0x10F3 abgelegt und können von der Applikation oder dem System Manager ausgelesen werden. Für jedes im Gerät hinterlegtes Ereignis (Warnung, Fehler, Statusänderung) wird eine über einen Code referenzierte Fehlermeldung ausgegeben.
Definition
Das System DiagMessages ist in der ETG (EtherCAT Technology Group) in der Richtlinie ETG.1020, Kap. 13 "Diagnosis Handling" definiert. Es wird benutzt, damit vordefinierte oder flexible Diagnosemitteilungen vom EtherCAT-Slave an den Master übermittelt werden können. Das Verfahren kann also nach ETG herstellerübergreifend implementiert werden. Die Unterstützung ist optional. Die Firmware kann bis zu 250 DiagMessages im eigenen CoE ablegen.
Jede DiagMessage besteht aus
▪
Diag Code (4 Byte)
▪
Flags (2 Byte; Info, Warnung oder Fehler)
▪
Text-ID (2 Byte; Referenz zum erklärenden Text aus der ESI/XML)
▪
Zeitstempel (8 Byte, lokale Slave-Zeit oder 64-Bit Distributed-Clock-Zeit, wenn vorhanden)
▪
dynamische Parameter, die von der Firmware mitgegeben werden
In der zum EtherCAT-Gerät gehörigen ESI/XML-Datei werden die DiagMessages in Textform erklärt: Anhand der in der DiagMessage enthaltenen Text-ID kann die entsprechende Klartextmeldung in den Sprachen gefunden werden, die in der ESI/XML enthalten sind. Üblicherweise sind dies bei Beckhoff-Produkten deutsch und englisch.
Der Anwender erhält durch den Eintrag NewMessagesAvailable Information, dass neue Meldungen vorliegen.
DiagMessages können im Gerät bestätigt werden: die letzte/neueste unbestätigte Meldung kann vom Anwender bestätigt werden.
Im CoE finden sich sowohl die Steuereinträge wie die History selbst im CoE-Objekt 0x10F3:
DiagMessages im CoE
Unter x10F3:02 ist der Subindex der neuesten DiagMessage auslesbar.
Unterstützung zur Inbetriebnahme
Das System der DiagMesssages ist vor allem während der Anlageninbetriebnahme einzusetzen. Zur Online-Diagnose während des späteren Dauerbetriebs sind die Diagnosewerte z.B. im StatusWord des Gerätes (wenn verfügbar) hilfreich.
Implementierung TwinCAT System Manager
Ab TwinCAT 2.11 werden DiagMessages, wenn vorhanden, beim Gerät in einer eigenen Oberfläche angezeigt. Auch die Bedienung (Abholung, Bestätigung) erfolgt darüber.
Implementierung DiagMessage-System im TwinCAT System Manager
Im Reiter Diag History (A) sind die Betätigungsfelder (B) wie auch die ausgelesene History (C) zu sehen. Die Bestandteile der Message:
▪
Info/Warning/Error
▪
Acknowledeg-Flag (N = unbestätigt, Q = bestätigt)
▪
Zeitstempel
▪
Text-ID
▪
Klartext-Meldung nach ESI/XML Angabe
Die Bedeutung der Buttons ist selbsterklärend.
DiagMessages im ADS Logger/Eventlogger
Ab TwinCAT 3.1 build 4022 werden von einer Klemme abgesetzte DiagMessages auch im TwinCAT ADS Logger gezeigt. Da nun IO-übergreifend DiagMessages an einem Ort dargestellt werden, vereinfacht dies die Inbetriebnahme. Außerdem kann die Logger-Ausgabe in eine Datei gespeichert werden – somit stehen die DiagMessages auch langfristig für Analysen zur Verfügung.
DiagMessages liegen eigentlich nur lokal im CoE 0x10F3 in der Klemme vor und können bei Bedarf manuell z.B. über die oben genannte DiagHistory ausgelesen werden.
Bei Neuentwicklungen sind die EtherCAT-Klemmen standardmäßig so eingestellt, dass sie das Vorliegen einer DiagMessage über EtherCAT als Emergency melden; der Eventlogger kann die DiagMessage dann abholen. Die Funktion wird in der Klemme über 0x10F3:05 aktiviert, deshalb haben solche Klemmen folgenden Eintrag standardmäßig in der StartUp-Liste:
Soll die Funktion deaktiviert werden weil z.B. viele Meldungen kommen oder der EventLogger nicht genutzt wird, kann der StartUp-Eintrag gelöscht oder auf 0 gesetzt werden.
Nachrichten in die PLC einlesen
- In Vorbereitung -
Interpretation
Zeitstempel
Der Zeitstempel wird aus der lokalen Uhr der Klemme zum Zeitpunkt des Ereignisses gewonnen. Die Zeit ist üblicherweise die Distributed-Clocks-Zeit (DC) aus Register x910.
Bitte beachten: die DC-Zeit wird in der Referenzuhr gleich der lokalen IPC/TwinCAT-Zeit gesetzt, wenn EtherCAT gestartet wird. Ab diesem Moment kann die DC-Zeit gegenüber der IPC-Zeit divergieren, da die IPC-Zeit nicht nachgeregelt wird. Es können sich so nach mehreren Wochen Betrieb ohne EtherCAT Neustart größere Zeitdifferenzen entwickeln. Als Abhilfe kann die sog. Externe Synchronisierung der DC-Zeit genutzt werden, oder es wird fallweise eine manuelle Korrekturrechnung vorgenommen: die aktuelle DC-Zeit kann über den EtherCAT Master oder durch Einsicht in das Register x901 eines DC-Slaves ermittelt werden.
Aufbau der Text-ID
Der Aufbau der MessageID unterliegt keiner Standardisierung und kann herstellerspezifisch definiert werden. Bei Beckhoff EtherCAT-Geräten (EL, EP) lautet er nach xyzz üblichwerweise:
x | y | zz
0: Systeminfo 1: Info 2: reserved 4: Warning 8: Error | 0: System 1: General 2: Communication 3: Encoder 4: Drive 5: Inputs 6: I/O allgemein 7: reserved | Fehlernummer
Beispiel: Meldung 0x4413 --> Drive Warning Nummer 0x13
Übersicht Text-IDs
Spezifische Text-IDs sind in der Gerätedokumentation aufgeführt.
Text-ID | Typ | Ort | Text Message | Zusätzlicher Kommentar
0x0001 | Information | System | No error | Kein Fehler
0x0002 | Information | System | Communication established | Verbindung aufgebaut
0x0003 | Information | System | Initialisation: 0x%X, 0x%X, 0x%X | allgemeine Information, Parameter je nach Ereignis. Interpretation siehe Gerätedokumentation.
0x1000 | Information | System | Information: 0x%X, 0x%X, 0x%X | allgemeine Information, Parameter je nach Ereignis. Interpretation siehe Gerätedokumentation.
0x1012 | Information | System | EtherCAT state change Init - PreOp |
0x1021 | Information | System | EtherCAT state change PreOp - Init |
0x1024 | Information | System | EtherCAT state change PreOp - Safe-Op |
0x1042 | Information | System | EtherCAT state change SafeOp - PreOp |
0x1048 | Information | System | EtherCAT state change SafeOp - Op |
0x1084 | Information | System | EtherCAT state change Op - SafeOp |
0x1100 | Information | Allgemein | Detection of operation mode completed: 0x%X, %d | Erkennung der Betriebsart beendet
0x1135 | Information | Allgemein | Cycle time o.k.: %d | Zykluszeit o.k.
0x1157 | Information | Allgemein | Data manually saved (Idx: 0x%X, SubIdx: 0x%X) | Daten manuell gespeichert
0x1158 | Information | Allgemein | Data automatically saved (Idx: 0x%X, SubIdx: 0x%X) | Daten automatisch gespeichert
0x1159 | Information | Allgemein | Data deleted (Idx: 0x%X, SubIdx: 0x%X) | Daten gelöscht
0x117F | Information | Allgemein | Information: 0x%X, 0x%X, 0x%X | Information
0x1201 | Information | Kommunikation | Communication re-established | Kommunikation zur Feldseite wiederhergestellt Die Meldung tritt auf, wenn z. B. im Betrieb die Spannung der Powerkontakte entfernt und wieder angelegt wurde.
0x1300 | Information | Encoder | Position set: %d, %d | Position gesetzt - StartInputhandler
0x1303 | Information | Encoder | Encoder Supply ok | Encoder Netzteil OK
0x1304 | Information | Encoder | Encoder initialization successfully, channel: %X | Encoder Initialisierung erfolgreich abgeschlossen
0x1305 | Information | Encoder | Sent command encoder reset, channel: %X | Sende Kommando Encoder Reset
0x1400 | Information | Drive | Drive is calibrated: %d, %d | Antrieb ist kalibriert
0x1401 | Information | Drive | Actual drive state: 0x%X, %d | Aktueller Status des Antriebs
0x1705 | Information |  | CPU usage returns in normal range (< 85%%) | Prozessorauslastung ist wieder im normalen Bereich
0x1706 | Information |  | Channel is not in saturation anymore | Kanal ist nicht mehr in Sättigung
0x1707 | Information |  | Channel is not in overload anymore | Kanal ist nicht mehr überlastet
0x170A | Information |  | No channel range error anymore | Es liegt kein Messbereichsfehler mehr vor
0x170C | Information |  | Calibration data saved | Abgleichdaten wurden gespeichert
0x170D | Information |  | Calibration data will be applied and saved after sending the command “0x5AFE” | Abgleichdaten werden erst nach dem Senden des Kommandos „0x5AFE“ übernommen und gespeichert
Text-ID | Typ | Ort | Text Message | Zusätzlicher Kommentar
0x2000 | Information | System | %s: %s |
0x2001 | Information | System | %s: Network link lost | Netzwerk Verbindung verloren
0x2002 | Information | System | %s: Network link detected | Netzwerk Verbindung gefunden
0x2003 | Information | System | %s: no valid IP Configuration - Dhcp client started | Ungültige IP Konfiguration
0x2004 | Information | System | %s: valid IP Configuration (IP: %d.%d.%d.%d) assigned by Dhcp server %d.%d.%d.%d | Gültige, vom DHCP-Server zugewiesene IP-Konfiguration
0x2005 | Information | System | %s: Dhcp client timed out | Zeitüberschreitung DHCP-Client
0x2006 | Information | System | %s: Duplicate IP Address detected (%d.%d.%d.%d) | Doppelte IP-Adresse gefunden
0x2007 | Information | System | %s: UDP handler initialized | UDP-Handler initialisiert
0x2008 | Information | System | %s: TCP handler initialized | TCP-Handler initialisiert
0x2009 | Information | System | %s: No more free TCP sockets available | Keine freien TCP Sockets verfügbar
Text-ID
Typ
Ort
Text Message
Zusätzlicher Kommentar
0x4000
Warnung
Warning: 0x%X, 0x%X, 0x%X
allgemeine Warnung, Parameter je nach Ereignis. Interpretation siehe Gerätedokumentation.
0x4001
Warnung
System
Warning: 0x%X, 0x%X, 0x%X
0x4002
Warnung
System
%s: %s Connection Open (IN:%d OUT:%d API:%dms) from %d.%d.%d.%d successful
0x4003
Warnung
System
%s: %s Connection Close (IN:%d OUT:%d) from %d.%d.%d.%d successful
0x4004
Warnung
System
%s: %s Connection (IN:%d OUT:%d) with %d.%d.%d.%d timed out
0x4005
Warnung
System
%s: %s Connection Open (IN:%d OUT:%d) from %d.%d.%d.%d denied (Error: %u)
0x4006
Warnung
System
%s: %s Connection Open (IN:%d OUT:%d) from %d.%d.%d.%d denied (Input Data Size expected: %d Byte(s) received: %d Byte(s))
0x4007
Warnung
System
%s: %s Connection Open (IN:%d OUT:%d) from %d.%d.%d.%d denied (Output Data Size expected: %d Byte(s) received: %d Byte(s))
0x4008
Warnung
System
%s: %s Connection Open (IN:%d OUT:%d) from %d.%d.%d.%d denied (RPI:%dms not supported -> API:%dms)
0x4101
Warnung
Allgemein
Terminal-Overtemperature
Übertemperatur. Die Innentemperatur der Klemme überschreitet die parametrierte Warnschwelle.
0x4102
Warnung
Allgemein
Discrepancy in the PDO-Configuration
Die ausgewählten PDOs passen nicht zur eingestellten Betriebsart.
Beispiel: Antrieb arbeitet im Velocity-Mode. Das Velocity-PDO ist jedoch nicht in die PDOs gemapped.
0x417F
Warnung
Allgemein
Warnung: 0x%X, 0x%X, 0x%X
0x428D
Warnung
Allgemein
Challenge is not Random
0x4300
Warnung
Encoder
Subincrements deactivated: %d, %d
Subinkremente deaktiviert (trotz aktivierter Konfiguration)
0x4301
Warnung
Encoder
Encoder-Warning
Allgemeiner Encoderfehler
0x4400
Warnung
Drive
Drive is not calibrated: %d, %d
Antrieb ist nicht kalibriert
0x4401
Warnung
Drive
Starttype not supported: 0x%X, %d
Starttyp wird nicht unterstützt
0x4402
Warnung
Drive
Command rejected: %d, %d
Kommando abgewiesen
0x4405
Warnung
Drive
Invalid modulo subtype: %d, %d
Modulo-Subtyp ungültig
0x4410
Warnung
Drive
Target overrun: %d, %d
Zielposition wird überfahren
0x4411
Warnung
Drive
DC-Link undervoltage (Warning)
Die Zwischenkreisspannung der Klemme unterschreitet die parametrierte Mindestspannung. Das Aktivieren der Endstufe wird unterbunden.
0x4412
Warnung
Drive
DC-Link overvoltage (Warning)
Die Zwischenkreisspannung der Klemme überschreitet die parametrierte Maximalspannung. Das Aktivieren der Endstufe wird unterbunden.
0x4413
Warnung
Drive
I2T-Model Amplifier overload (Warning)
▪
Der Verstärker wir außerhalb der Spezifikation betrieben
▪
Das I2T-Modell des Verstärkers ist falsch parametriert
0x4414
Warnung
Drive
I2T-Model Motor overload (Warning)
▪
Der Motor wird außerhalb der parametrierten Nennwerte betrieben.
▪
Das I2T-Modell des Motors ist falsch parametriert.
0x4415
Warnung
Drive
Speed limitation active
Die maximale Drehzahl wird durch die parametrierten Objekte (z. B. velocity limitation, motor speed limitation) begrenzt. Die Warnung wird ausgegeben, wenn die Sollgeschwindigkeit größer ist, als eines der parametrierten Begrenzungen.
0x4416
Warnung
Drive
Step lost detected at position: 0x%X%X
Schrittverlust erkannt
0x4417
Warnung
Drive
Motor-Overtemperature
Die Innentemperatur des Motors übersteigt die parametrierte Warnschwelle.
0x4418
Warnung
Drive
Limit: Current
Limit: Strom wird limitiert
0x4419
Warnung
Drive
Limit: Amplifier I2T-model exceeds 100%%
Die Schwellwerte für den maximalen Strom wurden überschritten.
0x441A
Warnung
Drive
Limit: Motor I2T-model exceeds 100%%
Limit: Motor I2T-Modell übersteigt 100%
0x441B
Warnung
Drive
Limit: Velocity limitation
Die Schwellwerte für die maximale Drehzahl wurden überschritten.
0x441C
Warnung
Drive
STO while the axis was enabled
Es wurde versucht die Achse zu aktivieren, obwohl die Spannung am STO-Eingang nicht anliegt.
0x4600
Warnung
Allgemein IO
Wrong supply voltage range
Versorgungsspannung im falschen Bereich
0x4610
Warnung
Allgemein IO
Wrong output voltage range
Ausgangsspannung im falschen Bereich
0x4705
Warnung
Processor usage at %d %%
Prozessorauslastung bei %d %%
0x470A
Warnung
EtherCAT Frame missed (change Settings or DC Operation Mode or Sync0 Shift Time)
EtherCAT Frame verpasst (Einstellungen, DC Operation Mode oder Sync0 Shift Time ändern)
Text-ID
Typ
Ort
Text Message
Zusätzlicher Kommentar
0x8000
Fehler
System
%s: %s
0x8001
Fehler
System
Error: 0x%X, 0x%X, 0x%X
allgemeiner Fehler, Parameter je nach Ereignis. Interpretation siehe Gerätedokumentation.
0x8002
Fehler
System
Communication aborded
Kommunikation abgebrochen
0x8003
Fehler
System
Configuration error: 0x%X, 0x%X, 0x%X
allgemeine, Parameter je nach Ereignis.
Interpretation siehe Gerätedokumentation.
0x8004
Fehler
System
%s: Unsuccessful FwdOpen-Response received from %d.%d.%d.%d (%s) (Error: %u)
0x8005
Fehler
System
%s: FwdClose-Request sent to %d.%d.%d.%d (%s)
0x8006
Fehler
System
%s: Unsuccessful FwdClose-Response received from %d.%d.%d.%d (%s) (Error: %u)
0x8007
Fehler
System
%s: Connection with %d.%d.%d.%d (%s) closed
0x8100
Fehler
Allgemein
Status word set: 0x%X, %d
Fehlerbit im Statuswort gesetzt
0x8101
Fehler
Allgemein
Operation mode incompatible to PDO interface: 0x%X, %d
Betriebsart inkompatibel zum PDO-Interface
0x8102
Fehler
Allgemein
Invalid combination of Inputs and Outputs PDOs
Ungültige Kombination von In- und Output PDOs
0x8103
Fehler
Allgemein
No variable linkage
Keine Variablen verknüpft
0x8104
Fehler
Allgemein
Terminal-Overtemperature
Die Innentemperatur der Klemme überschreitet die parametrierte Fehlerschwelle. Das Aktivieren der Klemme wird unterbunden.
0x8105
Fehler
Allgemein
PD-Watchdog
Die Kommunikation zwischen Feldbus und Endstufe wird durch einen Watchdog abgesichert. Sollte die Feldbuskommunikation abbrechen, wird die Achse automatisch gestoppt.
▪
Die EtherCAT-Verbindung wurde im Betrieb unterbrochen
▪
Der Master wurde im Betrieb in den Config-Mode geschaltet
0x8135
Fehler
Allgemein
Cycletime has to be a multiple of 125 µs
Die IO- oder NC-Zykluszeit ist nicht ganzzahlig durch 125µs teilbar.
0x8136
Fehler
Allgemein
Configuration error: invalid sampling rate
Konfigurationsfehler: Ungültige Samplingrate
0x8137
Fehler
Allgemein
Elektronisches Typenschild: CRC-Fehler
Inhalt des Speicher des externen Typenschildes nicht gültig.
0x8140
Fehler
Allgemein
Sync Error
Echtzeitverletztung
0x8141
Fehler
Allgemein
Sync%X Interrupt lost
Sync%X Interrupt fehlt
0x8142
Fehler
Allgemein
Sync Interrupt asynchronous
Sync Interrupt asynchron
0x8143
Fehler
Allgemein
Jitter too big
Jitter Grenzwertüberschreitung
0x817F
Fehler
Allgemein
Error: 0x%X, 0x%X, 0x%X
0x8200
Fehler
Kommunikation
Write access error: %d, %d
Fehler beim Schreiben
0x8201
Fehler
Kommunikation
No communication to field-side (Auxiliary voltage missing)
▪
Es ist keine Spannung an den Powerkontakten angelegt
▪
Ein Firmware Update ist fehlgeschlagen
0x8281
Fehler
Kommunikation
Ownership failed: %X
0x8282
Fehler
Kommunikation
To many Keys founded
0x8283
Fehler
Kommunikation
Key Creation failed: %X
0x8284
Fehler
Kommunikation
Key loading failed
0x8285
Fehler
Kommunikation
Reading Public Key failed: %X
0x8286
Fehler
Kommunikation
Reading Public EK failed: %X
0x8287
Fehler
Kommunikation
Reading PCR Value failed: %X
0x8288
Fehler
Kommunikation
Reading Certificate EK failed: %X
0x8289
Fehler
Kommunikation
Challenge could not be hashed: %X
0x828A
Fehler
Kommunikation
Tickstamp Process failed
0x828B
Fehler
Kommunikation
PCR Process failed: %X
0x828C
Fehler
Kommunikation
Quote Process failed: %X
0x82FF
Fehler
Kommunikation
Bootmode not activated
Bootmode nicht aktiviert
0x8300
Fehler
Encoder
Set position error: 0x%X, %d
Fehler beim Setzen der Position
0x8301
Fehler
Encoder
Encoder increments not configured: 0x%X, %d
Enkoderinkremente nicht konfiguriert
0x8302
Fehler
Encoder
Encoder-Error
Die Amplitude des Resolvers ist zu klein.
0x8303
Fehler
Encoder
Encoder supply error
Encoder Netzteil Fehler
0x8304
Fehler
Encoder
Encoder communication error, channel: %X
Encoder Kommunikationsfehler
0x8305
Fehler
Encoder
EnDat2.2 is not supported, channel: %X
EnDat2.2 wird nicht unterstützt
0x8306
Fehler
Encoder
Delay time, tolerance limit exceeded, 0x%X, channel: %X
Laufzeitmessung, Toleranz überschritten
0x8307
Fehler
Encoder
Delay time, maximum value exceeded, 0x%X, channel: %X
Laufzeitmessung, Maximalwert überschritten
0x8308
Fehler
Encoder
Unsupported ordering designation, 0x%X, channel: %X (only 02 and 22 is supported)
Falsche EnDat Bestellbezeichnung
0x8309
Fehler
Encoder
Encoder CRC error, channel: %X
Encoder CRC Fehler
0x830A
Fehler
Encoder
Temperature %X could not be read, channel: %X
Temperatur kann nicht gelesen werden
0x830C
Fehler
Encoder
Encoder Single-Cycle-Data Error, channel. %X
CRC Fehler festgestellt. Überprüfen Sie den Übertragungsweg und das CRC Polynom
0x830D
Fehler
Encoder
Encoder Watchdog Error, channel. %X
Der Sensor hat nicht innerhalb einer vordefinierten Zeitspanne geantwortet
0x8400
Fehler
Drive
Incorrect drive configuration: 0x%X, %d
Antrieb fehlerhaft konfiguriert
0x8401
Fehler
Drive
Limiting of calibration velocity: %d, %d
Begrenzung der Kalibrier-Geschwindigkeit
0x8402
Fehler
Drive
Emergency stop activated: 0x%X, %d
Emergency-Stop aktiviert
0x8403
Fehler
Drive
ADC Error
Fehler bei Strommessung im ADC
0x8404
Fehler
Drive
Overcurrent
Überstrom Phase U, V, oder W
0x8405
Fehler
Drive
Invalid modulo position: %d
Modulo-Position ungültig
0x8406
Fehler
Drive
DC-Link undervoltage (Error)
Die Zwischenkreisspannung der Klemme unterschreitet die parametrierte Mindestspannung. Das Aktivieren der Endstufe wird unterbunden.
0x8407
Fehler
Drive
DC-Link overvoltage (Error)
Die Zwischenkreisspannung der Klemme überschreitet die parametrierte Maximalspannung. Das Aktivieren der Endstufe wird unterbunden.
0x8408
Fehler
Drive
I2T-Model Amplifier overload (Error)
▪
Der Verstärker wir außerhalb der Spezifikation betrieben
▪
Das I2T-Modell des Verstärkers ist falsch parametriert
0x8409
Fehler
Drive
I2T-Model motor overload (Error)
▪
Der Motor wird außerhalb der parametrierten Nennwerte betrieben.
▪
Das I2T-Modell des Motors ist falsch parametriert.
0x840A
Fehler
Drive
Overall current threshold exceeded
Summenstrom überschritten
0x8415
Fehler
Drive
Invalid modulo factor: %d
Modulo-Faktor ungültig
0x8416
Fehler
Drive
Motor-Overtemperature
Die Innentemperatur des Motors übersteigt die parametrierte Fehlerschwelle. Der Motor bleibt sofort stehen. Das Aktivieren der Endstufe wird unterbunden.
0x8417
Fehler
Drive
Maximum rotating field velocity exceeded
Drehfeldgeschwindigkeit übersteigt den von Dual Use (EU 1382/2014) vorgeschriebenen Wert.
0x841C
Fehler
Drive
STO while the axis was enabled
Es wurde versucht die Achse zu aktivieren, obwohl die Spannung am STO-Eingang nicht anliegt.
0x8550
Fehler
Inputs
Zero crossing phase %X missing
Nulldurchgang Phase %X fehlt
0x8551
Fehler
Inputs
Phase sequence Error
Drehrichtung Falsch
0x8552
Fehler
Inputs
Overcurrent phase %X
Überstrom Phase %X
0x8553
Fehler
Inputs
Overcurrent neutral wire
Überstrom Neutralleiter
0x8581
Fehler
Inputs
Wire broken Ch %D
Leitungsbruch Ch %d
0x8600
Fehler
Allgemein IO
Wrong supply voltage range
Versorgungsspannung im falschen Bereich
0x8601
Fehler
Allgemein IO
Supply voltage to low
Versorgungsspannung zu klein
0x8602
Fehler
Allgemein IO
Supply voltage to high
Versorgungsspannung zu groß
0x8603
Fehler
Allgemein IO
Over current of supply voltage
Überstrom der Versorgungsspannung
0x8610
Fehler
Allgemein IO
Wrong output voltage range
Ausgangsspannung im falschen Bereich
0x8611
Fehler
Allgemein IO
Output voltage to low
Ausgangsspannung zu klein
0x8612
Fehler
Allgemein IO
Output voltage to high
Ausgangsspannung zu groß
0x8613
Fehler
Allgemein IO
Over current of output voltage
Überstrom der Ausgangsspannung
0x8700
Fehler
Channel/Interface not calibrated
Kanal/Interface nicht abgeglichen
0x8701
Fehler
Operating time was manipulated
Betriebslaufzeit wurde manipuliert
0x8702
Fehler
Oversampling setting is not possible
Oversampling Einstellung nicht möglich
0x8703
Fehler
No slave controller found
Kein Slave Controller gefunden
0x8704
Fehler
Slave controller is not in Bootstrap
Slave Controller ist nicht im Bootstrap
0x8705
Fehler
Processor usage to high (>= 100%%)
Prozessorauslastung zu hoch (>= 100%%)
0x8706
Fehler
Channel in saturation
Kanal in Sättigung
0x8707
Fehler
Channel overload
Kanalüberlastung
0x8708
Fehler
Overloadtime was manipulated
Überlastzeit wurde manipuliert
0x8709
Fehler
Saturationtime was manipulated
Sättigungszeit wurde manipuliert
0x870A
Fehler
Channel range error
Messbereichsfehler des Kanals
0x870B
Fehler
no ADC clock
Kein ADC Takt vorhanden
0xFFFF
Information
Debug: 0x%X, 0x%X, 0x%X
Debug: 0x%X, 0x%X, 0x%X


Anhang

Anhang
Anhang
Weiterführende Informationen
•
EtherCAT AL Status Codes
•
EJ7211-0010 - Firmware Kompatibilität
•
Firmware Update EL/ES/ELM/EM/EPxxxx
•
Wiederherstellen des Auslieferungszustandes
•
Support und Service


EtherCAT AL Status Codes

Anhang [image] EtherCAT AL Status Codes
EtherCAT AL Status Codes
Detaillierte Informationen hierzu entnehmen Sie bitte der vollständigen EtherCAT-Systembeschreibung.


EJ7211-0010 - Firmware Kompatibilität

Anhang [image] EJ7211-0010 - Firmware Kompatibilität
EJ7211-0010 - Firmware Kompatibilität
Beckhoff EtherCAT Geräte werden mit dem aktuell verfügbaren letzten Firmware-Stand ausgeliefert. Dabei bestehen zwingende Abhängigkeiten zwischen Firmware und Hardware; eine Kompatibilität ist nicht in jeder Kombination gegeben. Die unten angegebene Übersicht zeigt auf welchem Hardware-Stand eine Firmware betrieben werden kann.
Anmerkung
▪
Es wird empfohlen, die für die jeweilige Hardware letztmögliche Firmware einzusetzen
▪
Ein Anspruch auf ein kostenfreies Firmware-Udpate bei ausgelieferten Produkten durch Beckhoff gegenüber dem Kunden besteht nicht.
Hinweis
Beschädigung des Gerätes möglich!
Beachten Sie die Hinweise zum Firmware Update auf der gesonderten Seite.
Wird ein Gerät in den BOOTSTRAP-Mode zum Firmware-Update versetzt, prüft es u.U. beim Download nicht, ob die neue Firmware geeignet ist.
Dadurch kann es zur Beschädigung des Gerätes kommen! Vergewissern Sie sich daher immer, ob die Firmware für den Hardware-Stand des Gerätes geeignet ist!
EJ7211-0010
Hardware (HW) | Firmware (FW) | Revision Nr. | Release-Datum
00 - 01* | 11 | EJ7211-0010-0026 | 2016/07
 | 12 | EJ7211-0010-0027 | 2016/11
 | 13 | EJ7211-0010-0028 | 2017/09
 | 14 |  | 2017/11
 | 15 |  | 2018/02
 | 16 | EJ7211-0010-0029 | 2018/05
 | 17 |  | 2018/06
 | 18 |  | 2018/12
 | 19 | EJ7211-0010-0030 | 2020/02
 | 20* | EJ7211-0010-0031 | 2020/05
*) Zum Zeitpunkt der Erstellung dieser Dokumentation ist dies der aktuelle kompatible Firmware/Hardware-Stand. Überprüfen Sie auf der Beckhoff Website, ob eine aktuellere Dokumentation vorliegt.


Firmware Update EL/ES/ELM/EM/EPxxxx

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx
Firmware Update EL/ES/ELM/EM/EPxxxx
Dieses Kapitel beschreibt das Geräte-Update für Beckhoff EtherCAT Slaves der Serien EL/ES, ELM, EM, EK und EP. Ein FW-Update sollte nur nach Rücksprache mit dem Beckhoff Support durchgeführt werden.
Speicherorte
In einem EtherCAT-Slave werden an bis zu drei Orten Daten für den Betrieb vorgehalten:
▪
Je nach Funktionsumfang und Performance besitzen EtherCAT Slaves einen oder mehrere lokale Controller zur Verarbeitung von IO-Daten. Das darauf laufende Programm ist die sog. Firmware im Format *.efw.
▪
In bestimmten EtherCAT Slaves kann auch die EtherCAT Kommunikation in diesen Controller integriert sein. Dann ist der Controller meist ein so genannter FPGA-Chip mit der *.rbf-Firmware.
▪
Darüber hinaus besitzt jeder EtherCAT Slave einen Speicherchip, um seine eigene Gerätebeschreibung (ESI; EtherCAT Slave Information) zu speichern, in einem sog. ESI-EEPROM. Beim Einschalten wird diese Beschreibung geladen und u. a. die EtherCAT Kommunikation entsprechend eingerichtet. Die Gerätebeschreibung kann von der Beckhoff Website (http://www.beckhoff.de) im Downloadbereich heruntergeladen werden. Dort sind alle ESI-Dateien als Zip-Datei zugänglich.
Kundenseitig zugänglich sind diese Daten nur über den Feldbus EtherCAT und seine Kommunikationsmechanismen. Beim Update oder Auslesen dieser Daten ist insbesondere die azyklische Mailbox-Kommunikation oder der Registerzugriff auf den ESC in Benutzung.
Der TwinCAT Systemmanager bietet Mechanismen, um alle drei Teile mit neuen Daten programmieren zu können, wenn der Slave dafür vorgesehen ist. Es findet üblicherweise keine Kontrolle durch den Slave statt, ob die neuen Daten für ihn geeignet sind, ggf. ist ein Weiterbetrieb nicht mehr möglich.
Vereinfachtes Update per Bundle-Firmware
Bequemer ist der Update per sog. Bundle-Firmware: hier sind die Controller-Firmware und die ESI-Beschreibung in einer *.efw-Datei zusammengefasst, beim Update wird in der Klemme sowohl die Firmware, als auch die ESI verändert. Dazu ist erforderlich
▪
dass die Firmware in dem gepackten Format vorliegt: erkenntlich an dem Dateinamen der auch die Revisionsnummer enthält, z. B. ELxxxx-xxxx_REV0016_SW01.efw
▪
dass im Download-Dialog das Passwort=1 angegeben wird. Bei Passwort=0 (default Einstellung) wird nur das Firmware-Update durchgeführt, ohne ESI-Update.
▪
dass das Gerät diese Funktion unterstützt. Die Funktion kann in der Regel nicht nachgerüstet werden, sie wird Bestandteil vieler Neuentwicklungen ab Baujahr 2016.
Nach dem Update sollte eine Erfolgskontrolle durchgeführt werden
▪
ESI/Revision: z. B. durch einen Online-Scan im TwinCAT ConfigMode/FreeRun – dadurch wird die Revision bequem ermittelt
▪
Firmware: z. B. durch einen Blick ins Online-CoE des Gerätes
Hinweis
Beschädigung des Gerätes möglich!
✓
Beim Herunterladen von neuen Gerätedateien ist zu beachten
1.
Das Herunterladen der Firmware auf ein EtherCAT-Gerät darf nicht unterbrochen werden.
2.
Eine einwandfreie EtherCAT-Kommunikation muss sichergestellt sein, CRC-Fehler oder LostFrames dürfen nicht auftreten.
3.
Die Spannungsversorgung muss ausreichend dimensioniert, die Pegel entsprechend der Vorgabe sein.
⇨
Bei Störungen während des Updatevorgangs kann das EtherCAT-Gerät ggf. nur vom Hersteller wieder in Betrieb genommen werden!
Weiterführende Informationen
•
Gerätebeschreibung ESI-File/XML
•
Erläuterungen zur Firmware
•
Update Controller-Firmware *.efw
•
FPGA-Firmware *.rbf
•
Gleichzeitiges Update mehrerer EtherCAT-Geräte


Gerätebeschreibung ESI-File/XML

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Gerätebeschreibung ESI-File/XML
Gerätebeschreibung ESI-File/XML
Hinweis
ACHTUNG bei Update der ESI-Beschreibung/EEPROM
Manche Slaves haben Abgleich- und Konfigurationsdaten aus der Produktion im EEPROM abgelegt. Diese werden bei einem Update unwiederbringlich überschrieben.
Die Gerätebeschreibung ESI wird auf dem Slave lokal gespeichert und beim Start geladen. Jede Gerätebeschreibung hat eine eindeutige Kennung aus Slave-Name (9-stellig) und Revision-Nummer (4-stellig). Jeder im Systemmanager konfigurierte Slave zeigt seine Kennung im EtherCAT-Reiter:
Gerätekennung aus Name EL3204-0000 und Revision -0016
Die konfigurierte Kennung muss kompatibel sein mit der tatsächlich als Hardware eingesetzten Gerätebeschreibung, d.h. der Beschreibung die der Slave (hier: EL3204) beim Start geladen hat. Üblicherweise muss dazu die konfigurierte Revision gleich oder niedriger der tatsächlich im Klemmenverbund befindlichen sein.
Weitere Hinweise hierzu entnehmen Sie bitte der EtherCAT System-Dokumentation.
Update von XML/ESI-Beschreibung
Die Geräterevision steht in engem Zusammenhang mit der verwendeten Firmware bzw. Hardware. Nicht kompatible Kombinationen führen mindestens zu Fehlfunktionen oder sogar zur endgültigen Außerbetriebsetzung des Gerätes. Ein entsprechendes Update sollte nur in Rücksprache mit dem Beckhoff Support ausgeführt werden.
Anzeige der Slave-Kennung ESI
Der einfachste Weg die Übereinstimmung von konfigurierter und tatsächlicher Gerätebeschreibung festzustellen, ist im TwinCAT-Modus Config/FreeRun das Scannen der EtherCAT-Boxen auszuführen:
Rechtsklick auf das EtherCAT Gerät bewirkt das Scannen des unterlagerten Feldes
Wenn das gefundene Feld mit dem konfigurierten übereinstimmt, erscheint
Konfiguration identisch
ansonsten erscheint ein Änderungsdialog, um die realen Angaben in die Konfiguration zu übernehmen.
Änderungsdialog
In diesem Beispiel in Abb. „Änderungsdialog“. wurde eine EL3201-0000-0017 vorgefunden, während eine EL3201-0000-0016 konfiguriert wurde. In diesem Fall bietet es sich an, mit dem Copy Before-Button die Konfiguration anzupassen. Die Checkbox Extended Information muss gesetzt werden, um die Revision angezeigt zu bekommen.
Änderung der Slave-Kennung ESI
Die ESI/EEPROM-Kennung kann unter TwinCAT wie folgt aktualisiert werden:
▪
Es muss eine einwandfreie EtherCAT-Kommunikation zum Slave hergestellt werden
▪
Der State des Slave ist unerheblich
▪
Rechtsklick auf den Slave in der Online-Anzeige führt zum Dialog EEPROM Update, Abb. EEPROM Update
EEPROM Update
Im folgenden Dialog wird die neue ESI-Beschreibung ausgewählt, s. Abb. Auswahl des neuen ESI. Die CheckBox Show Hidden Devices zeigt auch ältere, normalerweise ausgeblendete Ausgaben eines Slave.
Auswahl des neuen ESI
Ein Laufbalken im Systemmanager zeigt den Fortschritt - erst erfolgt das Schreiben, dann das Veryfiing.
Änderung erst nach Neustart wirksam
Die meisten EtherCAT-Geräte lesen eine geänderte ESI-Beschreibung umgehend bzw. nach dem Aufstarten aus dem INIT ein. Einige Kommunikationseinstellungen wie z. B. Distributed Clocks werden jedoch erst bei PowerOn gelesen. Deshalb ist ein kurzes Abschalten des EtherCAT Slave nötig, damit die Änderung wirksam wird.


Erläuterungen zur Firmware

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Erläuterungen zur Firmware
Erläuterungen zur Firmware
Versionsbestimmung der Firmware
Versionsbestimmung nach Laseraufdruck
Auf einem Beckhoff EtherCAT Slave ist eine Seriennummer aufgelasert. Der Aufbau der Seriennummer lautet: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 12 10 03 02:
12 - Produktionswoche 12
10 - Produktionsjahr 2010
03 - Firmware-Stand 03
02 - Hardware-Stand 02
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der Controller-Firmware an, wenn der Slave online für den Master zugänglich ist. Klicken Sie hierzu auf die E-Bus-Klemme deren Controller-Firmware Sie überprüfen möchten (im Beispiel Klemme 2 (EL3204) und wählen Sie den Karteireiter CoE-Online (CAN over EtherCAT).
CoE-Online und Offline-CoE
Es existieren zwei CoE-Verzeichnisse:
• online: es wird im EtherCAT Slave vom Controller angeboten, wenn der EtherCAT Slave dies unterstützt. Dieses CoE-Verzeichnis kann nur bei angeschlossenem und betriebsbereitem Slave angezeigt werden.
• offline: in der EtherCAT Slave Information ESI/XML kann der Default-Inhalt des CoE enthalten sein. Dieses CoE-Verzeichnis kann nur angezeigt werden, wenn es in der ESI (z. B. „Beckhoff EL5xxx.xml“) enthalten ist.
Die Umschaltung zwischen beiden Ansichten kann über den Button Advanced vorgenommen werden.
In Abb. Anzeige FW-Stand EL3204 wird der FW-Stand der markierten EL3204 in CoE-Eintrag 0x100A mit 03 angezeigt.
Anzeige FW-Stand EL3204
TwinCAT 2.11 zeigt in (A) an, dass aktuell das Online-CoE-Verzeichnis angezeigt wird. Ist dies nicht der Fall, kann durch die erweiterten Einstellungen (B) durch Online und Doppelklick auf All Objects das Online-Verzeichnis geladen werden.


Update Controller-Firmware *.efw

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Update Controller-Firmware *.efw
Update Controller-Firmware *.efw
CoE-Verzeichnis
Das Online-CoE-Verzeichnis wird vom Controller verwaltet und in einem eigenen EEPROM gespeichert. Es wird durch ein FW-Update im allgemeinen nicht verändert.
Um die Controller-Firmware eines Slave zu aktualisieren, wechseln Sie zum Karteireiter Online, s. Abb. Firmware Update.
Firmware Update
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z. B. durch den Beckhoff Support vorliegen. Gültig für TwinCAT 2 und 3 als EtherCAT Master.
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
EtherCAT Master in PreOP schalten
▪
Slave in INIT schalten (A)
▪
Slave in BOOTSTRAP schalten
▪
Kontrolle des aktuellen Status (B, C)
▪
Download der neuen *efw-Datei, abwarten bis beendet. Ein Passwort wird in der Regel nicht benötigt.
▪
Nach Beendigung des Download in INIT schalten, dann in PreOP
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!)
▪
Im CoE 0x100A kontrollieren ob der FW-Stand korrekt übernommen wurde.


FPGA-Firmware *.rbf

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] FPGA-Firmware *.rbf
FPGA-Firmware *.rbf
Falls ein FPGA-Chip die EtherCAT-Kommunikation übernimmt, kann ggf. mit einer *.rbf-Datei ein Update durchgeführt werden.
▪
Controller-Firmware für die Aufbereitung der E/A-Signale
▪
FPGA-Firmware für die EtherCAT-Kommunikation (nur für Klemmen mit FPGA)
Die in der Seriennummer der Klemme enthaltene Firmware-Versionsnummer beinhaltet beide Firmware-Teile. Wenn auch nur eine dieser Firmware-Komponenten verändert wird, dann wird diese Versionsnummer fortgeschrieben.
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der FPGA-Firmware an. Klicken Sie hierzu auf die Ethernet-Karte Ihres EtherCAT-Stranges (im Beispiel Gerät 2) und wählen Sie den Karteireiter Online.
Die Spalte Reg:0002 zeigt die Firmware-Version der einzelnen EtherCAT-Geräte in hexadezimaler und dezimaler Darstellung an.
Versionsbestimmung FPGA-Firmware
Falls die Spalte Reg:0002 nicht angezeigt wird, klicken sie mit der rechten Maustaste auf den Tabellenkopf und wählen im erscheinenden Kontextmenü, den Menüpunkt Properties.
Kontextmenu Eigenschaften (Properties)
In dem folgenden Dialog Advanced Settings können Sie festlegen, welche Spalten angezeigt werden sollen. Markieren Sie dort unter Diagnose/Online Anzeige das Kontrollkästchen vor '0002 ETxxxx Build' um die Anzeige der FPGA-Firmware-Version zu aktivieren.
Dialog Advanced settings
Update
Für das Update der FPGA-Firmware
▪
eines EtherCAT-Kopplers, muss auf diesem Koppler mindestens die FPGA-Firmware-Version 11 vorhanden sein.
▪
einer E-Bus-Klemme, muss auf dieser Klemme mindestens die FPGA-Firmware-Version 10 vorhanden sein.
Ältere Firmware-Stände können nur vom Hersteller aktualisiert werden!
Update eines EtherCAT-Geräts
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z. B. durch den Beckhoff Support vorliegen:
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1 ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
Wählen Sie im TwinCAT System-Manager die Klemme an, deren FPGA-Firmware Sie aktualisieren möchten (im Beispiel: Klemme 5: EL5001) und klicken Sie auf dem Karteireiter EtherCAT auf die Schaltfläche Weitere Einstellungen:
▪
Im folgenden Dialog Advanced Settings klicken Sie im Menüpunkt ESC-Zugriff/E²PROM/FPGA auf die Schaltfläche Schreibe FPGA:
▪
Wählen Sie die Datei (*.rbf) mit der neuen FPGA-Firmware aus und übertragen Sie diese zum EtherCAT-Gerät:
▪
Abwarten bis zum Ende des Downloads
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!). Um die neue FPGA-Firmware zu aktivieren ist ein Neustart (Aus- und Wiedereinschalten der Spannungsversorgung) des EtherCAT-Geräts erforderlich
▪
Kontrolle des neuen FPGA-Standes
Hinweis
Beschädigung des Gerätes möglich!
Das Herunterladen der Firmware auf ein EtherCAT-Gerät dürfen Sie auf keinen Fall unterbrechen! Wenn Sie diesen Vorgang abbrechen, dabei die Versorgungsspannung ausschalten oder die Ethernet-Verbindung unterbrechen, kann das EtherCAT-Gerät nur vom Hersteller wieder in Betrieb genommen werden!


Gleichzeitiges Update mehrerer EtherCAT-Geräte

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Gleichzeitiges Update mehrerer EtherCAT-Geräte
Gleichzeitiges Update mehrerer EtherCAT-Geräte
Die Firmware von mehreren Geräten kann gleichzeitig aktualisiert werden, ebenso wie die ESI-Beschreibung. Voraussetzung hierfür ist, dass für diese Geräte die gleiche Firmware-Datei/ESI gilt.
Mehrfache Selektion und FW-Update
Wählen Sie dazu die betreffenden Slaves aus und führen Sie das Firmware-Update im BOOTSTRAP Modus wie o. a. aus.


Wiederherstellen des Auslieferungszustandes

Anhang [image] Wiederherstellen des Auslieferungszustandes
Wiederherstellen des Auslieferungszustandes
Um den Auslieferungszustand der Backup-Objekte bei den ELxxxx-Klemmen wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoE-Objekt Restore default parameters, Subindex 001angewählt werden (s. Abb. Auswahl des PDO‚ Restore default parameters)
Auswahl des PDO Restore default parameters
Durch Doppelklick auf SubIndex 001 gelangen Sie in den Set Value -Dialog. Tragen Sie im Feld Dec den Wert 1684107116 oder alternativ im Feld Hex den Wert 0x64616F6C ein und bestätigen Sie mit OK (Abb. Eingabe des Restore-Wertes im Set Value Dialog).
Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.
Eingabe des Restore-Wertes im Set Value Dialog
Alternativer Restore-Wert
Bei einigen Klemmen älterer Bauart lassen sich die Backup-Objekte mit einem alternativen Restore-Wert umstellen: Dezimalwert: 1819238756, Hexadezimalwert: 0x6C6F6164. Eine falsche Eingabe des Restore-Wertes zeigt keine Wirkung!


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.