EJ3255 - 5-Channel Potentiometer Measurement with Sensor Supply
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Intended use
•
Signal distribution board
•
Documentation issue status
•
Guide through documentation
•
Marking of EtherCAT plug-in modules


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Intended use

Foreword [image] Intended use
Intended use
SmallWarningYellow WARNING
Caution - Risk of injury!
EJ components may only be used for the purposes described below!


Signal distribution board

Foreword [image] Signal distribution board
Signal distribution board
Note
Signal distribution board
Make sure that the EtherCAT plug-in modules are used only on a signal distribution board that has been developed and manufactured in accordance with the Design Guide.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
1.1
▪
Chapters Basics communication, TwinCAT Quick Start , TwinCAT development environment and General Notes - EtherCAT Slave Application replaced by references in the chapter Guide through documentation
▪
Chapter EJ3255 - Object description and parameterization added
▪
Update chapter EJ3255 - Pinout
1.0
▪
First publication EJ3255


Guide through documentation

Foreword [image] Guide through documentation
Guide through documentation
Note
Further components of documentation
The documentations named in the following table are further compontents of the complete documentation. These documentations are required for the use of EtherCAT plug-in modules.
No.
Title
Description
[1]
EtherCAT System Documentation
▪
System overview
▪
EtherCAT basics
▪
Cable redundancy
▪
Hot Connect
▪
Distributed Clocks
▪
Configuration of EtherCAT-Components
[2]
Infrastructure for EtherCAT/Ethernet
▪
Technical recommendations and notes for design, implementation an testing
[3]
Design GuideSignal-Distribution-Board for standard EtherCAT plug-in modules
Requirements for the design of a Signal-Distribution-Board for standard EtherCAT plug-in modules
▪
Backplane mounting guidelines
▪
Module placement
▪
Routing guidelines
[4]
Documentation of the corresponding terminal ELxxxx
▪
Notes on the principle of operation and
▪
Descriptions for configuration and parameterization
are transferable to the corresponding Module EJxxxx (s. note on documentation of ELxxxx).


Marking of EtherCAT plug-in modules

Foreword [image] Marking of EtherCAT plug-in modules
Marking of EtherCAT plug-in modules
Designation
A Beckhoff EtherCAT device has a 14-digit technical designation, made up as follows (e.g. EJ1008-0000-0017)
▪
Order identifier
–
family key: EJ
–
product designation: The first digit of product designation is used for assignment to a product group (e.g. EJ2xxx = digital output module).
–
Version number: The four digit version number identifies different product variants.
▪
Revision number:
It is incremented when changes are made to the product.
The Order identifier and the revision number are printed on the side of EtherCAT plug-in modules (s. following illustration (A and B).
Order identifier (A), Revision number (B) and serial number (C) using the example of EJ1008
Product group | Example
 | Product designation | Version | Revision
EtherCAT Coupler EJ11xx | EJ1101 | -0022 (Coupler with external connectors, power supply module and optional ID switches | -0016
Digital input modules EJ1xxx | EJ1008 8-channel | -0000 (basic type) | -0017
Digital output modules EJ2xxx | EJ2521 1-channel | -0224 (2 x 24 V outputs) | -0016
Analog input modules EJ3xxx | EJ3318 8-channel thermocouple | -0000 (basic type) | -0017
Analog output modules EJ4xxx | EJ4134 4-channel | -0000 (basic type) | -0019
Special function modules EJ5xxx, EJ6xxx | EJ6224 IO-Link master | -0090 (with TwinSAFE SC) | -0016
Motion modules EJ7xxx | EJ7211 servomotor | -9414 (with ECT, STO and TwinSAFE SC) | -0029
Notes
▪
The elements mentioned above result in the technical designation. EJ1008-0000-0017 is used in the example below.
▪
EJ1008-0000 is the order identifier, in the case of “-0000” usually abbreviated to EJ1008.
▪
The revision -0017 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
▪
The product designation, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Serial number
The serial number for EtherCAT plug-in modules is usually the 8-digit number printed on the side of the module (see following illustration C). The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Order identifier (A), revision number (B) and serial number (C) using the example of EJ1008
Serial number | Example serial number: 08 15 08 16
KK - week of production (CW, calendar week) | 08 - week of production: 08
YY - year of production | 15 - year of production: 2015
FF - firmware version | 08 -f irmware version: 08
HH - hardware version | 16 - hardware version: 16
Additional information
•
Beckhoff Identification Code (BIC)
•
Certificates


Beckhoff Identification Code (BIC)

Foreword [image] Marking of EtherCAT plug-in modules [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, it shall be replaced by spaces. The data under positions 1-4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971 , 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from items 1 - 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC
Notice
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Certificates

Foreword [image] Marking of EtherCAT plug-in modules [image] Certificates
Certificates
▪
The EhterCAT plug-in modules meet the requirements of the EMC and Low Voltage Directive. The CE mark is printed on the side of the modules.
▪
The cRUus imprint identifies devices that meet product safety requirements according to U.S. and Canadian regulations.
▪
The warning symbol is a request to read the corresponding documentation. The documentations for EtherCAT plug-in modules can be downloaded from the Beckhoff homepage.
Marking for CE and UL using EJ1008 as an example


System overview

System overview
System overview
Electronically, the EJxxxx EtherCAT plug-in modules are based on the EtherCAT I/O system. The EJ system consists of the signal distribution board and EtherCAT plug-in modules. It is also possible to connect an IPC to the EJ system.
The EJ system is suitable for mass production applications, applications with small footprint and applications requiring a low total weight.
The machine complexity can be extended by means of the following:
▪
reserve slots,
▪
the use of placeholder modules,
▪
linking of EtherCAT Terminals and EtherCAT Boxes via an EtherCAT connection.
The following diagram illustrates an EJ system. The components shown are schematic, to illustrate the functionality.
EJ system sample
Signal distribution board
The signal distribution board distributes the signals and the power supply to individual application-specific plug connectors, in order to connect the controller to further machine modules. Using pre-assembled cable harnesses avoids the need for time-consuming connection of individual wires. Coded components reduce the unit costs and the risk of miswiring.
Beckhoff offers development of signal distribution boards as an engineering service. Customers have the option to develop their own signal distribution board, based on the design guide.
EtherCAT plug-in modules
Similar to the EtherCAT terminal system, a module strand consists of a Bus Coupler and I/O modules. Almost all of the EtherCAT Terminals can also be manufactured in the EJ design as EtherCAT plug-in modules. The EJ modules are directly attached to the signal distribution board. The communication, signal distribution and supply take place via the contact pins at the rear of the modules and the PCB tracks of the signal distribution board. The coding pins at the rear serve as mechanical protection against incorrect connection. Color coding on the housing facilitates distinguishing of the modules.


Product overview

Product overview
Product overview
Additional information
•
EJ3255 - Introduction
•
EJ3255 - Technical data
•
EJ3255 - Pinout
•
EJ3255 - LEDs


EJ3255 - Introduction

Product overview [image] EJ3255 - Introduction
EJ3255 - Introduction
EJ3255
5-channel analog input module, potentiometer measurement with Sensor supply
The EJ3255 EtherCAT plug-in module enables potentiometers to be connected directly. A stabilized power supply in the module for the connected potentiometers and ratiometric measurement of the input voltage offer the prerequisites for precise measuring. On account of its high sampling rate and together with potentiometer position encoders, the compact, 5-channel EtherCAT plug-in module enables a temporally high-resolution and cost-efficient position detection.
The EJ3255 diagnostics detect broken wire, loss of supply voltage and short-circuit for each channel.
The 5 channels are measured simultaneously (at the same time).


EJ3255 - Technical data

Product overview [image] EJ3255 - Technical data
EJ3255 - Technical data
Technical data | EJ3255
Number of analog inputs | 5
Power supply | via Up contacts
Technology | ratiometric potentiometer evaluation with own supply, 3-wire connection
Distributed Clocks | yes
Feed voltage potentiometer | typ. 10 V ±10%
Internal resistance | >> 100 kΩ to wiper connection
Input filter limit frequency | typ. -3 dB at 3 kHz and potentiometer 50 kΩ
Sensor types | Potentiometer 300 Ω .. 50 kΩ
Output current | Max. 0.3 A total supply current for the potentiometers
Wiring fail indication | yes
Conversion time | typ. 300 .. 700 µs, dependent on settings, default setting: approx.. 500 µs (5 channels, filter deactivated)
Resolution | 16 bits representation (including sign)
Measuring error (total measuring range) | < ± 0.5 % (relative to full scale value)
Electrical isolation | 500 V (E-bus/signal voltage)
Current consumption load voltage (Up contacts) | dependent on the potentiometers, max. 70 mA
Current consumption via E-bus | typ. 80 mA
Special Features | Open-circuit recognition, supply monitoring, activatable filters simultaneous measurement of the channels
Permissible ambient temperature range during operation | 0°C .. +55°C
Permissible ambient temperature range during storage | -25°C .. +85°C
Permissible relative air humidity | 95 %, no condensation
Operating altitude | max. 2,000 m
Dimensions (W x H x D) | approx. 12 mm x 66 mm x 55 mm
Weight | app. 30 g
Mounting | on signal distribution board
Pollution degree | 2
Installation position | Standard
Position of the coding pins | 1 and 6
Color coding | green
Vibration / shock resistance | according to EN 60068-2-6/EN 60068-2-27 (with corresponding signal distribution board)
EMC immunity / emission | according to EN 61000-6-2/EN 61000-6-4 (with corresponding signal distribution board)
Protection class | EJ module: IP20 EJ system: Dependent on the signal distribution board
Approval | CE
CE approval
The CE Marking refers to the EtherCAT plug-in module mentioned above.
If the EtherCAT plug-in module is used in the production of a ready-to-use end product (PCB in conjunction with a housing), the manufacturer of the end product must check compliance of the overall system with relevant directives and CE certification.
To operate the EtherCAT plug-in modules, they must be installed in a housing.


EJ3255 - Pinout

Product overview [image] EJ3255 - Pinout
EJ3255 - Pinout
EJ3255 - Pinout
The PCB footprint can be downloaded from the Beckhoff homepage.
Note
Damage to devices possible!
•
The pins named with “NC” must not be connected.
•
Before installation and commissioning read the chapters Installation of EJ modules and Commissioning!


EJ3255 - LEDs

Product overview [image] EJ3255 - LEDs
EJ3255 - LEDs
EJ3255 - LEDs
LED
Color
Display
State
Description
RUN
green
off
Init
State of the EtherCAT State Machine: INIT = initialization of the plug-in module
flashing
Pre-Operational
State of the EtherCAT State Machine: PREOP = function for mailbox communication and different default settings set
single flash
Safe-Operational
State of the EtherCAT State Machine: SAFEOP = verification of the Sync Manager channels and the distributed clocks.
Outputs remain in safe state
on
Operational
State of the EtherCAT State Machine: OP = normal operating state; mailbox and process data communication is possible
flickering
Bootstrap
State of the EtherCAT State Machine: BOOTSTRAP = function for firmware updates of the plug-in module
Up
green
off
-
No 24 VDC power supply connected
on
-
24 VDC power supply connected
ERR1 ERR2 ERR3 ERR4 ERR5
red
off
-
No error
on
-
There is an error on the corresponding channel:
▪
Broken wire on wiper or supply
▪
Potentiometer outside the specified range (300.. 50 kΩ)
▪
Short-circuit
▪
Overload
If channels are not used they can be deactivated via the PDO selection. The corresponding LED goes out.


Installation of EJ modules

Installation of EJ modules
Installation of EJ modules
Additional information
•
Power supply for the EtherCAT plug-in modules
•
EJxxxx - dimensions
•
Installation positions and minimum distances
•
Codings
•
Installation on the signal distribution board
•
Extension options
•
IPC integration
•
Disassembly of the signal distribution board


Power supply for the EtherCAT plug-in modules

Installation of EJ modules [image] Power supply for the EtherCAT plug-in modules
Power supply for the EtherCAT plug-in modules
SmallWarningYellow WARNING
Power supply
A SELV/PELV power supply must be used to supply power for the EJ coupler and modules. Couplers and modules have to be connected to SELV/PELV circuits exclusively.
The signal distribution board should have a power supply designed for the maximum possible current load of the module string. Information on the current required from the E-bus supply can be found for each module in the respective documentation in section “Technical data”, online and in the catalog. The power requirement of the module string is displayed in the TwinCAT System Manager.
E-bus power supply with EJ1100 or EJ1101-0022 and EJ940x
The EJ1100 Bus Coupler supplies the connected EJ modules with the E-bus system voltage of 3.3 V. The Coupler can accommodate a load up to 2.2 A. If a higher current is required, a combination of the coupler EJ1101-0022 and the power supply units EJ9400 (2.5 A) or EJ9404 (12 A) should be used. The EJ940x power supply units can be used as additional supply modules in the module string.
Depending on the application, the following combinations for the E-bus supply are available:
E-bus power supply with EJ1100 or EJ1101-0022 + EJ940x
In the EJ1101-0022 coupler, the RJ45 connectors and optional ID switches are external and can be positioned anywhere on the signal distribution board, as required. This facilitates feeding through a housing.
The EJ940x power supply plug-in modules provide an optional reset function (see chapter Connection of the documentation for EJ9400 and EJ9404)
E-bus power supply with CXxxxx and EK1110-004x
The Embedded PC supplies the attached EtherCAT Terminals and the EtherCAT EJ Coupler
▪
with a supply voltage of 24 VDC (-15 %/+20%). This voltage supplies the E-bus and the Bus Terminal electronics.
The CXxxxx units supply the E-bus with up to 2,000 mA E-bus current. If a higher current is required due to the attached terminals, power feed terminals or power supply plug-in modules must be used for the E-bus supply.
▪
with a peripheral voltage Up of 24 VDC to supply the field electronics.
The EK1110-004x EtherCAT EJ Couplers relay the following parameters to the signal distribution board via the rear connector:
▪
the E-bus signals,
▪
the E-bus voltage UEBUS (3.3 V) and
▪
the peripheral voltage UP (24 VDC).
PCB with Embedded PC, EK1110-0043 and EJxxxx, rear view EK1110-0043


EJxxxx - dimensions

Installation of EJ modules [image] EJxxxx - dimensions
EJxxxx - dimensions
The EJ modules are compact and lightweight thanks to their design. Their volume is approx. 50% smaller than the volume of the EL terminals. A distinction is made between four different module types, depending on the width and the height:
Module type | Dimensions (W x H x D) | Sample in figure below
Coupler | 44 mm x 66 mm x 55 mm | EJ1100 (ej_44_2xrj45_coupler)
Single module | 12 mm x 66 mm x 55 mm | EJ1809 (ej_12_16pin_code13)
Double module | 24 mm x 66 mm x 55 mm | EJ7342 (ej_24_2x16pin_code18)
Single module (long) | 12 mm x 152 mm x 55 mm | EJ1957 (ej_12_2x16pin_extended_code4747)
EJxxxx - Dimensions
The technical drawings can be downloaded from the download finder. The drawings are named as described in the drawing below.
Technical drawings from download finder


Installation positions and minimum distances

Installation of EJ modules [image] Installation positions and minimum distances
Installation positions and minimum distances
Additional information
•
Minimum distances for ensuring installability
•
Installation positions


Minimum distances for ensuring installability

Installation of EJ modules [image] Installation positions and minimum distances [image] Minimum distances for ensuring installability
Minimum distances for ensuring installability
Note the dimensions shown in the following diagram for the design of the signal distribution board to ensure safe latching and simple assembly / disassembly of the modules.
Mounting distances EJ module - PCB
Observing the reaching area
A minimum reaching area of 92 mm is required for assembly / disassembly, in order to be able to reach the mounting tabs with the fingers.
Adherence to the recommended minimum distances for ventilation (see section Installation position) ensures an adequate reaching area.
The signal distribution board must have a thickness of 1.6 mm and a minimum distance of 4 mm from the mounting surface, in order to ensure latching of the modules on the board.


Installation positions

Installation of EJ modules [image] Installation positions and minimum distances [image] Installation positions
Installation positions
Note
Constraints regarding installation position and operating temperature range
Please refer to the technical data for the installed components to ascertain whether any restrictions regarding the mounting position and/or the operating temperature range have been specified. During installation of modules with increased thermal dissipation, ensure adequate distance above and below the modules to other components in order to ensure adequate ventilation of the modules during operation!
The standard installation position is recommended. If a different installation position is used, check whether additional ventilation measures are required.
Ensure that the specified conditions (see Technical data) are adhered to!
Optimum installation position (standard)
For the optimum installation position the signal distribution board is installed horizontally, and the fronts of the EJ modules face forward (see Fig. Recommended distances for standard installation position). The modules are ventilated from below, which enables optimum cooling of the electronics through convection. “From below” is relative to the acceleration of gravity.
Recommended distances for standard installation position
Compliance with the distances shown in Fig. Recommended distances for standard installation position is recommend. The recommended minimum distances should not be regarded as restricted areas for other components. The customer is responsible for verifying compliance with the environmental conditions described in the technical data. Additional cooling measures must be provided, if required.
Other installation positions
All other installation positions are characterized by a different spatial position of the signal distribution board, see Fig. Other installation positions.
The minimum distances to ambient specified above also apply to these installation positions.
EJxxx_other mounting positions
Other installation positions


Codings

Installation of EJ modules [image] Codings
Codings
Additional information
•
Color coding
•
Mechanical position coding


Color coding

Installation of EJ modules [image] Codings [image] Color coding
Color coding
EJ modules color code; sample: EJ1809
The EJ modules are color-coded for a better overview in the control cabinet (see diagram above). The color code indicates the signal type. The following table provides an overview of the signal types with corresponding color coding.
Signal type | Modules | Color
Coupler | EJ11xx | No color coding
Digital input | EJ1xxx | Yellow
Digital output | EJ2xxx | Red
Analog input | EJ3xxx | Green
Analog output | EJ4xxx | Blue
Motion | EJ7xxx | orange
System | EJ9xxx | grey


Mechanical position coding

Installation of EJ modules [image] Codings [image] Mechanical position coding
Mechanical position coding
The modules have two signal-specific coding pins on the underside (see Figs. B1 and B2 below). In conjunction with the coding holes in the signal distribution board (see Figs. A1 and A2 below), the coding pins provide an option for mechanical protection against incorrect connection. This significantly reduces the risk of error during installation and service.
Couplers and placeholder modules have no coding pins.
Mechanical position coding with coding pins (B1 and B2) and coding holes (A1 and A2)
The following diagram shows the position of the position coding with position numbers on the left-hand side. Modules with the same signal type have the same coding. For sample, all digital input modules have the coding pins at positions one and three. There is no plug protection between modules with the same signal type. During installation the module type should therefore be verified based on the device name.
Pin coding; sample: digital input modules


Installation on the signal distribution board

Installation of EJ modules [image] Installation on the signal distribution board
Installation on the signal distribution board
EJ modules are installed on the signal distribution board. The electrical connections between coupler and EJ modules are realized via the pin contacts and the signal distribution board.
The EJ components must be installed in a control cabinet or enclosure which must provide protection against fire hazards, environmental conditions and mechanical impact.
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the module system into a safe, de-energized state before starting installation, disassembly or wiring of the modules.
Note
Risk of damage to components through electrostatic discharge!
Observe the regulations for ESD protection.
Installation of EJ modules
A1 / A2 | Latching lugs top / bottom | C1 / C2 | Mounting holes
B1 / B2 | Coding pins | D1 / D2 | Coding holes
To install the modules on the signal distribution board proceed as follows:
1.
Before the installation, ensure that the signal distribution board is securely connected to the mounting surface. Installation on an unsecured signal distribution board may result in damage to the board.
2.
If necessary, check whether the positions of the coding pins (B) match the corresponding holes in the signal distribution board (D).
3.
Compare the device name on the module with the information in the installation drawing.
4.
Press the upper and the lower mounting tabs simultaneously and push the module onto the board while gently moving it up and down, until the module is latched securely.
The required contact pressure can only be established and the maximum current carrying capacity ensured if the module is latched securely.
5.
Use placeholder modules (EJ9001) to fill gaps in the module strand.
Note
•
During installation ensure safe latching of the modules on the signal distribution board! The consequences of inadequate contact pressure include:
⇨
loss of quality of the transferred signals,
⇨
increased power dissipation of the contacts,
⇨
impairment of the service life.


Extension options

Installation of EJ modules [image] Extension options
Extension options
Three options are available for modifications and extensions of the EJ system.
▪
Replacing the placeholder modules with the function modules provided for the respective slot
▪
Assigning function modules specified for the respective slots for the reserve slots at the end of the module string
▪
Linking with EtherCAT Terminals and EtherCAT Box modules via an Ethernet/EtherCAT connection
Additional information
•
Using placeholder modules for unused slots
•
Linking with EtherCAT Terminals and EtherCAT Box modules via an Ethernet/EtherCAT connection


Using placeholder modules for unused slots

Installation of EJ modules [image] Extension options [image] Using placeholder modules for unused slots
Using placeholder modules for unused slots
The EJ9001 placeholder modules are used to close temporary gaps in the module strands (see Fig. A1 below). Gaps in the module strand cause interruption in EtherCAT communication and must be equipped with placeholder modules.
In contrast to the passive terminals of the EL series, the placeholder modules actively participate in the data exchange. Several placeholder modules can therefore be connected in series, without impairing the data exchange.
Unused slots at the end of the module strand can be left as reserve slots (see Fig. B1 below).
The machine complexity is extended (extended version) by allocating unused slots (see Figs. A2 below - Exchanging placeholder modules and B2 - Assigning reserve slots) according to the specifications for the signal distribution board.
Sample: Exchanging placeholder modules and assigning reserve slots
E-bus supply
Exchange the placeholder modules with other modules changes the current input from the E-Bus. Ensure that adequate power supply is provided.


Linking with EtherCAT Terminals and EtherCAT Box modules via an Ethernet/EtherCAT connection

Installation of EJ modules [image] Extension options [image] Linking with EtherCAT Terminals and EtherCAT Box modules via an Ethernet/EtherCAT connection
Linking with EtherCAT Terminals and EtherCAT Box modules via an Ethernet/EtherCAT connection
Example of extension via an Ethernet/EtherCAT connection


IPC integration

Installation of EJ modules [image] IPC integration
IPC integration
Connection of CX and EL terminals via the EK1110-004x EtherCAT EJ Coupler
The EK1110-0043 and EK1110-0044 EtherCAT EJ Couplers connect the compact DIN-rail PCs of the CX series and attached EtherCAT terminals (ELxxxx) with the EJ modules on the signal distribution board.
The EK1110-004x are supplied from the power supply unit of the Embedded PC.
The E-bus signals and the supply voltage of the field side UP are routed directly to the PCB via a plug connector at the rear of the EtherCAT EJ Couplers.
Due to the direct coupling of the Embedded PC and the EL terminals with the EJ modules on the PCB, no EtherCAT extension (EK1110) or EtherCAT Coupler (EJ1100) is required.
The Embedded PC can be expanded with EtherCAT terminals that are not yet available in the EJ system, for example.
Example PCB with Embedded PC, EK1110-0043 and EJxxxx, rear view EK1110-0043
Connection of C6015 / C6017 via the EJ110x-00xx EtherCAT Coupler
Thanks to their ultra-compact design and versatile mounting options, the C6015 and C6017 IPCs are ideally suited for connection to an EJ system.
In combination with the ZS5000-0003 mounting set, it is possible to place the C6015 and C6017 IPCs compactly on the signal distribution board.
The EJ system is optimally connected to the IPC via the corresponding EtherCAT cable (see following Fig. [A]).
The IPC can be supplied directly via the signal distribution board using the enclosed power plug (see Fig. [B] below).
Note
Positioning on the signal distribution board
The dimensions and distances for placement and other details can be found in the Design Guide and the documentation for the individual components.
The figure below shows the connection of a C6015 IPC to an EJ system as an example. The components shown are schematic, to illustrate the functionality.
Example for the connection of a C6015 IPC to an EJ system


Disassembly of the signal distribution board

Installation of EJ modules [image] Disassembly of the signal distribution board
Disassembly of the signal distribution board
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the module system into a safe, de-energized state before starting installation, disassembly or wiring of the modules.
Note
Risk of damage to components through electrostatic discharge!
Observe the regulations for ESD protection.
Each module is secured through latching on the distribution board, which has to be released for disassembly.
Disassembly of EJ modules
To disassemble the module from the signal distribution board proceed as follows:
1.
Before disassembly, ensure that the signal distribution board is securely connected to the mounting surface. Disassembly of an unsecured signal distribution board may result in damage to the board.
2.
Press the upper and lower mounting tabs simultaneously and pull the module from board while gently moving it up and down.


EtherCAT basics

EtherCAT basics
EtherCAT basics
Please refer to the EtherCAT System Documentation for the EtherCAT fieldbus basics.


Commissioning

Commissioning
Commissioning
Additional information
•
Note on documentation for the EL3255
•
EJ3255 - Object description and parameterization


Note on documentation for the EL3255

Commissioning [image] Note on documentation for the EL3255
Note on documentation for the EL3255
Detailed documentation on the commissioning of the EJ3255 module is being prepared.
Note
Damage to devices or loss of data
The descriptions and notes on the commissioning of the EL3255 EtherCAT Terminal is transferable to the EJ3255 EtherCAT plug-in modules.
Before commissioning, read the detailed description of the process data, operating modes and parameterization in the EL3255 documentation.


EJ3255 - Object description and parameterization

Commissioning [image] EJ3255 - Object description and parameterization
EJ3255 - Object description and parameterization
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Parameterization via the CoE list (CAN over EtherCAT)
The EtherCAT device is parameterized via the CoE-Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs). Please note the following general CoE notes when using/manipulating the CoE parameters:
•
Keep a startup list if components have to be replaced
•
Differentiation between online/offline dictionary, existence of current XML description
•
use “CoE reload” for resetting changes
Relevant objects
The object description refers to the Pt100 (RTD) analog input module in the two and four-channel versions. Observe the indices with regard to the objects relevant for the respective terminal (channel dependent).
Introduction
The CoE overview contains objects for different purposes of use:
▪
Objects required for parameterization and profile-specific objects required during commissioning
▪
Objects for indicating internal settings (may be fixed)
The following section first describes the objects required for normal operation, followed by a complete overview of missing objects.
Additional information
•
Restore object
•
Configuration data
•
Profile-specific objects (0x6000-0xFFFF)
•
Input data
•
Configuration data vendor-specific
•
Information and diagnostic data
•
Standard objects (0x1000-0x1FFF)


Restore object

Commissioning [image] EJ3255 - Object description and parameterization [image] Restore object
Restore object
Index 1011 Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default parameters | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to “0x64616F6C” in the set value dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)


Configuration data

Commissioning [image] EJ3255 - Object description and parameterization [image] Configuration data
Configuration data
Index 80n0 AI Settings for 0 ≤ n ≤ 4 (Ch. 1 - 5, dependent on the number of channels)
The filter characteristics are set via index 0x8000:15
The filter frequencies are set for all channels of the module centrally via index 0x8000:15 (channel 1). All other corresponding indices 0x80n0:15 have no parameterization function! The latest firmware version (see status table) returns an EtherCAT-compliant error message, if the filter characteristics of other channels (index 0x80n0:06, 0x80n0:15) are set.
Index (hex) | Name | Meaning | Data type | Flags | Default
80n0:0 | AI Settings | Maximum subindex | UINT8 | RO | 0x1C (28dec)
80n0:01 | Enable user scale | Enablement of the user scaling | BOOLEAN | RW | 0x00 (0dec)
80n0:05 | Siemens bits | The S5 bits are shown in the three low-order bits (value 0x60n0:11) Bit 0 = 1 (“overrange” or “underrange”) Bit 1 (not used) Bit 2 (not used) | BOOLEAN | RW | 0x00 (0dec)
80n0:06 | Enable filter | Enable filter, which makes PLC-cycle-synchronous data exchange unnecessary | BOOLEAN | RW | 0x00 (0dec)
80n0:07 | Enable limit 1 | The status bits are set in relation to Limit 1 | BOOLEAN | RW | 0x00 (0dec)
80n0:08 | Enable limit 2 | The status bits are set in relation to Limit 2 | BOOLEAN | RW | 0x00 (0dec)
80n0:0A | Enable user calibration | Enabling of the user calibration | BOOLEAN | RW | 0x00 (0dec)
80n0:0B | Enable vendor calibration | Enabling of the vendor calibration | BOOLEAN | RW | 0x01 (1dec)
80n0:0E | Swap limit bits | Swap limit bits | BOOLEAN | RW | 0x01 (1dec)
80n0:11 | User scale offset | User scaling offset | INT16 | RW | 0x0000 (0dec)
80n0:12 | User scale gain | This is the user scaling gain. The gain is represented in fixed-point format, with the factor 2-16. The value 1 corresponds to 65535 (0x00010000). | INT32 | RW | 0x00010000 (65536dec)
80n0:13 | Limit 1 | First limit value for setting the status bits (resolution 0.1 °C) | INT16 | RW | 0x0000 (0dec)
80n0:14 | Limit 2 | Second limit value for setting the status bits (resolution 0.1 °C) | INT16 | RW | 0x0000 (0dec)
Index (hex) | Name | Meaning | Data type | Flags | Default
80n0:15 | Filter settings | This object determines the digital filter settings, if it is active via “Enable filter” (index 0x80n0:06). The possible settings are sequentially numbered. see note "Setting the filter characteristics via Index 0x8000:15" 0: 50 Hz 1: 60 Hz 2: IIR1 (400 Hz) 3: IIR2 (500 Hz) 4: IIR3 (100 Hz) 5: IIR4 (50 Hz) 6: IIR5 (24 Hz) 7: IIR6 (12 Hz) 8: IIR7 (6.2 Hz) 9: IIR8 (3.0 Hz) | UINT16 | RW | 0x0000 (0dec)
80n0:17 | User calibration offset | User calibration offset | INT16 | RW | 0x0000 (0dec)
80n0:18 | User calibration gain | User gain calibration | UINT16 | RW | 0x4000 (16384dec)
80n0:1C | Linearization | Linearization for potentiometer values ≥ 25 kΩ: 0 = off (up to 10 kΩ), 1 = 25 kΩ, 2 = 50 kΩ, | INT16 | RW | 0x0000 (0dec)
Index 8047 AI Device Settings
Index (hex) | Name | Meaning | Data type | Flags | Default
8047:0 | AI Device Settings | Max. Subindex | UINT8 | RO | 0x11 (17dec)
8047:11 | Wire breakage detection | 0: sensor/load/supply monitoring 1: load/supply monitoring 2: supply monitoring 3: off | ENUM16 | RW | 0x0000 (0dec)


Profile-specific objects (0x6000-0xFFFF)

Commissioning [image] EJ3255 - Object description and parameterization [image] Profile-specific objects (0x6000-0xFFFF)
Profile-specific objects (0x6000-0xFFFF)
The profile-specific objects have the same meaning for all EtherCAT slaves that support the profile 5001.


Input data

Commissioning [image] EJ3255 - Object description and parameterization [image] Input data
Input data
Index 60n0 AI Inputs for 0 ≤ n ≤ 4 (Ch. 1 - 5, dependent on the number of channels)
Index (hex) | Name | Meaning | Data type | Flags | Default
60n0:0 | AI inputs | Maximum subindex | UINT8 | RO | 0x11 (17dec)
60n0:01 | Underrange | The measuring range is undershot. | BOOLEAN | RO | 0x00 (0dec)
60n0:02 | Overrange | The measuring range is overshot. (“open circuit” detection if “Error” [Index 0x60n0:07]) is set | BOOLEAN | RO | 0x00 (0dec)
60n0:03 | Limit 1 | Limit value monitoring 0: not active 1: Value > limit value 2: Value < limit value 3: Value = limit value | BIT2 | RO | 0x00 (0dec)
60n0:05 | Limit 2 |  | BIT2 | RO | 0x00 (0dec)
60n0:07 | Error | The error bit is set if the data is invalid. | BOOLEAN | RO | 0x00 (0dec)
60n0:0E | Sync Error | The Sync Error bit is only required for the Distributed Clocks mode. It indicates whether a synchronization error occurred in the expired cycle. |  |  |
60n0:0F | TxPDO State | Validity of the data of the associated TxPDO (0 = valid, 1 = invalid). | BOOLEAN | RO | 0x00 (0dec)
60n0:10 | TxPDO Toggle | The TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. | BOOLEAN | RO | 0x00 (0dec)
60n0:11 | Value | Measured value as 32 bit signed integer | INT16 | RO | 0x0000 (0dec)


Configuration data vendor-specific

Commissioning [image] EJ3255 - Object description and parameterization [image] Configuration data vendor-specific
Configuration data vendor-specific
Index 80nF AI Vendor data for 0 ≤ n ≤ 4 (Ch. 1 - 5)
Index (hex) | Name | Meaning | Data type | Flags | Default
80nF:0 | AI vendor data | Maximum subindex | UINT8 | RO | 0x02 (2dec)
80nF:01 | Calibration offset | Vendor calibration offset | INT32 | RW | 0x00000000 (0dec)
80nF:02 | Calibration gain | Vendor calibration gain | UINT16 | RW | 0x4000 (16384dec)


Information and diagnostic data

Commissioning [image] EJ3255 - Object description and parameterization [image] Information and diagnostic data
Information and diagnostic data
Index 80nE RTD Internal data for 0 ≤ n ≤ 4 (Ch. 1 - 5, dependent on the number of channels)
Index (hex) | Name | Meaning | Data type | Flags | Default
80nE:0 | AI internal data | Maximum subindex | UINT8 | RO | 0x01 (1dec)
80nE:01 | ADC raw value 1 | ADC raw value 1 | INT32 | RO | 0x00000000 (0dec)
Index F000 Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0001 (1dec)
Index F008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | currently reserved | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module list [for {n=1} (1-channel) to {n=1,..,n=4} (5-channel)]
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list | Maximum subindex | UINT8 | RO | 0x05 (5dec)
F010:0n | Subindex 00n | AI Profiles | INT32 | RO | 0x0000012C (300dec)


Standard objects (0x1000-0x1FFF)

Commissioning [image] EJ3255 - Object description and parameterization [image] Standard objects (0x1000-0x1FFF)
Standard objects (0x1000-0x1FFF)
The standard objects have the same meaning for all EtherCAT slaves.
Index 1000 Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x012C1389 (19665801dec)
Index 1008 Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EJ3255
Index 1009 Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO | 00
Index 100A Software version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO | 01
Index 1018 Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | ( )
1018:03 | Revision | Revision number of the EtherCAT slave; the Low Word (bit 0-15) indicates the special terminal number, the High Word (bit 16-31) refers to the device description | UINT32 | RO | ( )
1018:04 | Serial number | Serial number of the EtherCAT slave; the Low Byte (bit 0-7) of the Low Word contains the year of production, the High Byte (bit 8-15) of the Low Word contains the week of production, the High Word (bit 16-31) is 0 | UINT32 | RO | ( )
Index 10F0 Backup parameter handling
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | Information for standardized loading and saving of backup entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum across all backup entries of the EtherCAT slave | UINT32 | RO | 0x00000000 (0dec)
Index 1800 AI TxPDO-Par Standard Ch. 1
Index (hex) | Name | Meaning | Data type | Flags | Default
1800:0 | AI TxPDO-Par Standard Ch. 1 | PDO parameter TxPDO 1 | UINT8 | RO | 0x06 (6dec)
1800:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 1. | OCTET-STRING[2] | RO | 01 1A
Index 1801 AI TxPDO-Par Compact Ch. 1
Index (hex) | Name | Meaning | Data type | Flags | Default
1801:0 | AI TxPDO-Par Compact Ch.1 | PDO parameter TxPDO 2 | UINT8 | RO | 0x06 (6dec)
1801:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 2. | OCTET-STRING[2] | RO | 00 1A
Index 1802 AI TxPDO-Par Standard Ch. 2
Index (hex) | Name | Meaning | Data type | Flags | Default
1802:0 | AI TxPDO-Par Standard Ch.2 | PDO parameter TxPDO 3 | UINT8 | RO | 0x06 (6dec)
1802:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 3. | OCTET-STRING[2] | RO | 03 1A
Index 1803 AI TxPDO-Par Compact Ch. 2
Index (hex) | Name | Meaning | Data type | Flags | Default
1803:0 | AI TxPDO-Par Compact Ch.2 | PDO parameter TxPDO 4 | UINT8 | RO | 0x06 (6dec)
1803:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 4. | OCTET-STRING[2] | RO | 02 1A
Index 1804 AI TxPDO-Par Standard Ch. 3
Index (hex) | Name | Meaning | Data type | Flags | Default
1804:0 | AI TxPDO-Par Standard Ch.3 | PDO parameter TxPDO 5 | UINT8 | RO | 0x06 (6dec)
1804:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 5. | OCTET-STRING[2] | RO | 05 1A
Index 1805 AI TxPDO-Par Compact Ch. 3
Index (hex) | Name | Meaning | Data type | Flags | Default
1805:0 | AI TxPDO-Par Compact Ch.3 | PDO parameter TxPDO 6 | UINT8 | RO | 0x06 (6dec)
1805:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 6. | OCTET-STRING[2] | RO | 04 1A
Index 1806 AI TxPDO-Par Standard Ch. 4
Index (hex) | Name | Meaning | Data type | Flags | Default
1806:0 | AI TxPDO-Par Standard Ch.2 | PDO parameter TxPDO 7 | UINT8 | RO | 0x06 (6dec)
1806:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 7. | OCTET-STRING[2] | RO | 07 1A
Index 1807 AI TxPDO-Par Compact Ch. 4
Index (hex) | Name | Meaning | Data type | Flags | Default
1807:0 | AI TxPDO-Par Compact Ch.4 | PDO parameter TxPDO 8 | UINT8 | RO | 0x06 (6dec)
1807:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 8. | OCTET-STRING[2] | RO | 06 1A
Index 1808 AI TxPDO-Par Standard Ch. 5
Index (hex) | Name | Meaning | Data type | Flags | Default
1808:0 | AI TxPDO-Par Standard Ch.5 | PDO parameter TxPDO 9 | UINT8 | RO | 0x06 (6dec)
1808:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 9. | OCTET-STRING[2] | RO | 09 1A
Index 1809 AI TxPDO-Par Compact Ch. 5
Index (hex) | Name | Meaning | Data type | Flags | Default
1809:0 | AI TxPDO-Par Compact Ch.5 | PDO parameter TxPDO 10 | UINT8 | RO | 0x06 (6dec)
1809:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 10. | OCTET-STRING[2] | RO | 08 1A
Index 1A00 AI TxPDO-Map Standard Ch. 1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A00:0 | AI TxPDO-Map Standard Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RW | 0x0B (11dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x01 (Underrange)) | UINT32 | RW | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x02 (Overrange)) | UINT32 | RW | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x03 (Limit 1)) | UINT32 | RW | 0x6000:03, 2
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x05 (Limit 2)) | UINT32 | RW | 0x6000:05, 2
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x07 (Error)) | UINT32 | RW | 0x6000:07, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (1 bit align) | UINT32 | RW | 0x0000:00, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (5 bits align) | UINT32 | RW | 0x0000:00, 5
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x0E (Sync error)) | UINT32 | RW | 0x6000:0E, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x0F (TxPDO-State)) | UINT32 | RW | 0x6000:0F, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x10 (TxPDO-Toggle)) | UINT32 | RW | 0x6000:10, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x11 (Value)) | UINT32 | RW | 0x6000:11, 16
Index 1A01 AI TxPDO-Map Compact Ch. 1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A01:0 | AI TxPDO-Map Compact Ch.1 | PDO Mapping TxPDO 2 | UINT8 | RW | 0x01 (1dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x11 (Value)) | UINT32 | RW | 0x6000:11, 1
Index 1A02 AI TxPDO-Map Standard Ch. 2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A02:0 | AI TxPDO-Map Standard Ch.2 | PDO Mapping TxPDO 3 | UINT8 | RW | 0x0B (11dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (AI Inputs Ch.2), entry 0x01 (Underrange)) | UINT32 | RW | 0x6010:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (AI Inputs Ch.2), entry 0x02 (Overrange)) | UINT32 | RW | 0x6010:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (AI Inputs Ch.2), entry 0x03 (Limit 1)) | UINT32 | RW | 0x6010:03, 2
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (AI Inputs Ch.2), entry 0x05 (Limit 2)) | UINT32 | RW | 0x6010:05, 2
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (AI Inputs Ch.2), entry 0x07 (Error)) | UINT32 | RW | 0x6010:07, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (1 bit align) | UINT32 | RW | 0x0000:00, 1
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (5 bits align) | UINT32 | RW | 0x0000:00, 5
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (AI Inputs Ch.2), entry 0x0E (Sync error)) | UINT32 | RW | 0x6010:0E, 1
1A02:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6010 (AI Inputs Ch.2), entry 0x0F (TxPDO-State)) | UINT32 | RW | 0x6010:0F, 1
1A02:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6010 (AI Inputs Ch.2), entry 0x10 (TxPDO-Toggle)) | UINT32 | RW | 0x6010:10, 1
1A02:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6010 (AI Inputs Ch.2), entry 0x11 (Value)) | UINT32 | RW | 0x6010:11, 16
Index 1A03 AI TxPDO-Map Compact Ch. 2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A03:0 | AI TxPDO-Map Compact Ch.2 | PDO Mapping TxPDO 4 | UINT8 | RW | 0x01 (1dec)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (AI Inputs Ch.2), entry 0x11 (Value)) | UINT32 | RW | 0x6010:11, 1
Index 1A04 AI TxPDO-Map Standard Ch. 3
Index (hex) | Name | Meaning | Data type | Flags | Default
1A04:0 | AI TxPDO-Map Standard Ch.3 | PDO Mapping TxPDO 5 | UINT8 | RW | 0x0B (11dec)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (AI Inputs Ch.3), entry 0x01 (Underrange)) | UINT32 | RW | 0x6020:01, 1
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (AI Inputs Ch.3), entry 0x02 (Overrange)) | UINT32 | RW | 0x6020:02, 1
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (AI Inputs Ch.3), entry 0x03 (Limit 1)) | UINT32 | RW | 0x6020:03, 2
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (AI Inputs Ch.3), entry 0x05 (Limit 2)) | UINT32 | RW | 0x6020:05, 2
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (AI Inputs Ch.3), entry 0x07 (Error)) | UINT32 | RW | 0x6020:07, 1
1A04:06 | SubIndex 006 | 6. PDO Mapping entry (1 bit align) | UINT32 | RW | 0x0000:00, 1
1A04:07 | SubIndex 007 | 7. PDO Mapping entry (5 bits align) | UINT32 | RW | 0x0000:00, 5
1A04:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6020 (AI Inputs Ch.3), entry 0x0E (Sync error)) | UINT32 | RW | 0x6020:0E, 1
1A04:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6020 (AI Inputs Ch.3), entry 0x0F (TxPDO-State)) | UINT32 | RW | 0x6020:0F, 1
1A04:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6020 (AI Inputs Ch.3), entry 0x10 (TxPDO-Toggle)) | UINT32 | RW | 0x6020:10, 1
1A04:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6020 (AI Inputs Ch.3), entry 0x11 (Value)) | UINT32 | RW | 0x6020:11, 16
Index 1A05 AI TxPDO-Map Compact Ch. 3
Index (hex) | Name | Meaning | Data type | Flags | Default
1A05:0 | AI TxPDO-Map Compact Ch.3 | PDO Mapping TxPDO 6 | UINT8 | RW | 0x01 (1dec)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (AI Inputs Ch.3), entry 0x11 (Value)) | UINT32 | RW | 0x6020:11, 1
Index 1A06 AI TxPDO-Map Standard Ch. 4
Index (hex) | Name | Meaning | Data type | Flags | Default
1A06:0 | AI TxPDO-Map Standard Ch.4 | PDO Mapping TxPDO 7 | UINT8 | RW | 0x0B (11dec)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6030 (AI Inputs Ch.4), entry 0x01 (Underrange)) | UINT32 | RW | 0x6030:01, 1
1A06:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6030 (AI Inputs Ch.4), entry 0x02 (Overrange)) | UINT32 | RW | 0x6030:02, 1
1A06:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6030 (AI Inputs Ch.4), entry 0x03 (Limit 1)) | UINT32 | RW | 0x6030:03, 2
1A06:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6030 (AI Inputs Ch.4), entry 0x05 (Limit 2)) | UINT32 | RW | 0x6030:05, 2
1A06:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6030 (AI Inputs Ch.4), entry 0x07 (Error)) | UINT32 | RW | 0x6030:07, 1
1A06:06 | SubIndex 006 | 6. PDO Mapping entry (1 bit align) | UINT32 | RW | 0x0000:00, 1
1A06:07 | SubIndex 007 | 7. PDO Mapping entry (5 bits align) | UINT32 | RW | 0x0000:00, 5
1A06:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6030 (AI Inputs Ch.4), entry 0x0E (Sync error)) | UINT32 | RW | 0x6030:0E, 1
1A06:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6030 (AI Inputs Ch.4), entry 0x0F (TxPDO-State)) | UINT32 | RW | 0x6030:0F, 1
1A06:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6030 (AI Inputs Ch.4), entry 0x10 (TxPDO-Toggle)) | UINT32 | RW | 0x6030:10, 1
1A06:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6030 (AI Inputs Ch.4), entry 0x11 (Value)) | UINT32 | RW | 0x6030:11, 16
Index 1A07 AI TxPDO-Map Compact Ch. 4
Index (hex) | Name | Meaning | Data type | Flags | Default
1A07:0 | AI TxPDO-Map Compact Ch.4 | PDO Mapping TxPDO 8 | UINT8 | RW | 0x01 (1dec)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6030 (AI Inputs Ch.4), entry 0x11 (Value)) | UINT32 | RW | 0x6030:11, 1
Index 1A08 AI TxPDO-Map Standard Ch. 5
Index (hex) | Name | Meaning | Data type | Flags | Default
1A08:0 | AI TxPDO-Map Standard Ch.5 | PDO Mapping TxPDO 9 | UINT8 | RW | 0x0B (11dec)
1A08:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6040 (AI Inputs Ch.5), entry 0x01 (Underrange)) | UINT32 | RW | 0x6040:01, 1
1A08:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6040 (AI Inputs Ch.5), entry 0x02 (Overrange)) | UINT32 | RW | 0x6040:02, 1
1A08:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6040 (AI Inputs Ch.5), entry 0x03 (Limit 1)) | UINT32 | RW | 0x6040:03, 2
1A08:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6040 (AI Inputs Ch.5), entry 0x05 (Limit 2)) | UINT32 | RW | 0x6040:05, 2
1A08:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6040 (AI Inputs Ch.5), entry 0x07 (Error)) | UINT32 | RW | 0x6040:07, 1
1A08:06 | SubIndex 006 | 6. PDO Mapping entry (1 bit align) | UINT32 | RW | 0x0000:00, 1
1A08:07 | SubIndex 007 | 7. PDO Mapping entry (5 bits align) | UINT32 | RW | 0x0000:00, 5
1A08:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6040 (AI Inputs Ch.5), entry 0x0E (Sync error)) | UINT32 | RW | 0x6040:0E, 1
1A08:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6040 (AI Inputs Ch.5), entry 0x0F (TxPDO-State)) | UINT32 | RW | 0x6040:0F, 1
1A08:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6040 (AI Inputs Ch.5), entry 0x10 (TxPDO Toggle)) | UINT32 | RW | 0x6040:10, 1
1A08:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6040 (AI Inputs Ch.5), entry 0x11 (Value)) | UINT32 | RW | 0x6040:11, 16
Index 1A09 AI TxPDO-Map Compact Ch. 5
Index (hex) | Name | Meaning | Data type | Flags | Default
1A09:0 | AI TxPDO-Map Compact Ch.5 | PDO Mapping TxPDO 10 | UINT8 | RW | 0x01 (1dec)
1A09:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6040 (AI Inputs Ch.5), entry 0x11 (Value)) | UINT32 | RW | 0x6040:11, 1
Index 1C00 Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the Sync Managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x00 (0dec)
Index 1C13 TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x05 (5dec)
1C13:01 | Subindex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A02 (6658dec)
1C13:03 | Subindex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A04 (6660dec)
1C13:04 | Subindex 004 | 4. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A06 (6662dec)
1C13:05 | Subindex 005 | 5. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A08 (6664dec)
Index 1C33 SM input parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (no outputs available)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (outputs available)
UINT16
RW
0x0001 (1dec)
1C33:02
Cycle time
Cycle time (in ns):
▪
Free Run: Cycle time of the local timer
▪
Synchron with SM 2 Event: Master cycle time
▪
DC mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x00030D40 (200000dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, DC mode only)
UINT32
RW
0x0002E630 (19000dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: Synchron with SM 2 Event is supported (outputs available)
▪
Bit 1: Synchron with SM 3 Event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: Input Shift through local event (outputs available)
▪
Bit 4-5 = 10: Input Shift with SYNC1 Event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C33:08)
UINT16
RO
0x400B (16359dec)
1C33:05
Minimum cycle time
Minimum cycle time (in ns)
UINT32
RO
0x00030D40 (200000dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, DC mode only)
UINT32
RO
0x00002710 (10000dec)
1C33:07
Minimum delay time
Minimum time between Sync-1 Event and reading of the inputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C33:08
Command
▪
0: Measurement of the local cycle time is stopped
▪
1: Measurement of the local cycle time is started
The entries 0x1C33:03, 0x1C33:06, 0x1C33:09 are updated with the maximum measured values.
For a subsequent measurement the measured values are reset
UINT16
RW
0x0000 (0dec)
1C33:09
Maximum Delay time
Time between SYNC1 event and reading of the inputs (in ns, DC mode only)
UINT32
RO
0x00000000 (0dec)
1C33:0B
SM event missed counter
Number of missed SM events in OPERATIONAL (DC mode only)
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
Number of occasions the cycle time was exceeded in OPERATIONAL (cycle was not completed in time or the next cycle began too early)
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
Number of occasions that the interval between SYNC0 and SYNC1 event was too short (DC mode only)
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
The synchronization was not correct in the last cycle (outputs were output too late; DC mode only)
BOOLEAN
RO
0x00 (0dec)


Appendix

Appendix
Appendix
Additional information
•
EtherCAT AL Status Codes
•
EJ3255 - Firmware compatibility
•
Firmware Update EL/ES/EM/ELM/EPxxxx
•
Restoring the delivery state
•
Support and Service


EtherCAT AL Status Codes

Appendix [image] EtherCAT AL Status Codes
EtherCAT AL Status Codes
For detailed information please refer to the EtherCAT system description.


EJ3255 - Firmware compatibility

Appendix [image] EJ3255 - Firmware compatibility
EJ3255 - Firmware compatibility
Beckhoff EtherCAT devices are delivered with the latest available firmware version. Compatibility of firmware and hardware is mandatory; not every combination ensures compatibility. The overview below shows the hardware versions on which a firmware can be operated.
Note
▪
It is recommended to use the newest possible firmware for the respective hardware
▪
Beckhoff is not under any obligation to provide customers with free firmware updates for delivered products.
Note
Risk of damage to the device!
Pay attention to the instructions for firmware updates on the separate page.
If a device is placed in BOOTSTRAP mode for a firmware update, it does not check when downloading whether the new firmware is suitable.
This can result in damage to the device! Therefore, always make sure that the firmware is suitable for the hardware version!
EJ3255
Hardware (HW) | Firmware (FW) | Revision no. | Release date
00* | 10* | EJ3255-0000-0023 | 2019/03
*) This is the current compatible firmware/hardware version at the time of the preparing this documentation. Check on the Beckhoff website whether more up-to-date documentation is available.


Firmware Update EL/ES/EM/ELM/EPxxxx

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx
Firmware Update EL/ES/EM/ELM/EPxxxx
This section describes the device update for Beckhoff EtherCAT slaves from the EL/ES, ELM, EM, EK and EP series. A firmware update should only be carried out after consultation with Beckhoff support.
Storage locations
An EtherCAT slave stores operating data in up to 3 locations:
▪
Depending on functionality and performance EtherCAT slaves have one or several local controllers for processing I/O data. The corresponding program is the so-called firmware in *.efw format.
▪
In some EtherCAT slaves the EtherCAT communication may also be integrated in these controllers. In this case the controller is usually a so-called FPGA chip with *.rbf firmware.
▪
In addition, each EtherCAT slave has a memory chip, a so-called ESI-EEPROM, for storing its own device description (ESI: EtherCAT Slave Information). On power-up this description is loaded and the EtherCAT communication is set up accordingly. The device description is available from the download area of the Beckhoff website at (https://www.beckhoff.de). All ESI files are accessible there as zip files.
Customers can access the data via the EtherCAT fieldbus and its communication mechanisms. Acyclic mailbox communication or register access to the ESC is used for updating or reading of these data.
The TwinCAT System Manager offers mechanisms for programming all 3 parts with new data, if the slave is set up for this purpose. Generally the slave does not check whether the new data are suitable, i.e. it may no longer be able to operate if the data are unsuitable.
Simplified update by bundle firmware
The update using so-called bundle firmware is more convenient: in this case the controller firmware and the ESI description are combined in a *.efw file; during the update both the firmware and the ESI are changed in the terminal. For this to happen it is necessary
▪
for the firmware to be in a packed format: recognizable by the file name, which also contains the revision number, e.g. ELxxxx-xxxx_REV0016_SW01.efw
▪
for password=1 to be entered in the download dialog. If password=0 (default setting) only the firmware update is carried out, without an ESI update.
▪
for the device to support this function. The function usually cannot be retrofitted; it is a component of many new developments from year of manufacture 2016.
Following the update, its success should be verified
▪
ESI/Revision: e.g. by means of an online scan in TwinCAT ConfigMode/FreeRun – this is a convenient way to determine the revision
▪
Firmware: e.g. by looking in the online CoE of the device
Note
Risk of damage to the device!
Note the following when downloading new device files

• Firmware downloads to an EtherCAT device must not be interrupted
• Flawless EtherCAT communication must be ensured. CRC errors or LostFrames must be avoided.
• The power supply must adequately dimensioned. The signal level must meet the specification.

In the event of malfunctions during the update process the EtherCAT device may become unusable and require re-commissioning by the manufacturer.
Additional information
•
Device description ESI file/XML
•
Firmware explanation
•
Updating controller firmware *.efw
•
FPGA firmware *.rbf
•
Simultaneous updating of several EtherCAT devices


Device description ESI file/XML

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Device description ESI file/XML
Device description ESI file/XML
Note
Attention regarding update of the ESI description/EEPROM
Some slaves have stored calibration and configuration data from the production in the EEPROM. These are irretrievably overwritten during an update.
The ESI device description is stored locally on the slave and loaded on start-up. Each device description has a unique identifier consisting of slave name (9 characters/digits) and a revision number (4 digits). Each slave configured in the System Manager shows its identifier in the EtherCAT tab:
Device identifier consisting of name EL3204-0000 and revision -0016
The configured identifier must be compatible with the actual device description used as hardware, i.e. the description which the slave has loaded on start-up (in this case EL3204). Normally the configured revision must be the same or lower than that actually present in the terminal network.
For further information on this, please refer to the EtherCAT system documentation.
Update of XML/ESI description
The device revision is closely linked to the firmware and hardware used. Incompatible combinations lead to malfunctions or even final shutdown of the device. Corresponding updates should only be carried out in consultation with Beckhoff support.
Display of ESI slave identifier
The simplest way to ascertain compliance of configured and actual device description is to scan the EtherCAT boxes in TwinCAT mode Config/FreeRun:
Scan the subordinate field by right-clicking on the EtherCAT device
If the found field matches the configured field, the display shows
Configuration is identical
otherwise a change dialog appears for entering the actual data in the configuration.
Change dialog
In this example in Fig. Change dialog, an EL3201-0000-0017 was found, while an EL3201-0000-0016 was configured. In this case the configuration can be adapted with the Copy Before button. The Extended Information checkbox must be set in order to display the revision.
Changing the ESI slave identifier
The ESI/EEPROM identifier can be updated as follows under TwinCAT:
▪
Trouble-free EtherCAT communication must be established with the slave.
▪
The state of the slave is irrelevant.
▪
Right-clicking on the slave in the online display opens the EEPROM Update dialog, Fig. EEPROM Update
EEPROM Update
The new ESI description is selected in the following dialog, see Fig. Selecting the new ESI. The checkbox Show Hidden Devices also displays older, normally hidden versions of a slave.
Selecting the new ESI
A progress bar in the System Manager shows the progress. Data are first written, then verified.
The change only takes effect after a restart.
Most EtherCAT devices read a modified ESI description immediately or after startup from the INIT. Some communication settings such as distributed clocks are only read during power-on. The EtherCAT slave therefore has to be switched off briefly in order for the change to take effect.


Firmware explanation

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Firmware explanation
Firmware explanation
Determining the firmware version
Determining the version on laser inscription
Beckhoff EtherCAT slaves feature serial numbers applied by laser. The serial number has the following structure: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with ser. no.: 12 10 03 02:
12 - week of production 12
10 - year of production 2010
03 - firmware version 03
02 - hardware version 02
Determining the version via the System Manager
The TwinCAT System Manager shows the version of the controller firmware if the master can access the slave online. Click on the E-Bus Terminal whose controller firmware you want to check (in the example terminal 2 (EL3204)) and select the tab CoE Online (CAN over EtherCAT).
CoE Online and Offline CoE
Two CoE directories are available:
• online: This is offered in the EtherCAT slave by the controller, if the EtherCAT slave supports this. This CoE directory can only be displayed if a slave is connected and operational.
• offline: The EtherCAT Slave Information ESI/XML may contain the default content of the CoE. This CoE directory can only be displayed if it is included in the ESI (e.g. "Beckhoff EL5xxx.xml").
The Advanced button must be used for switching between the two views.
In Fig. Display of EL3204 firmware version the firmware version of the selected EL3204 is shown as 03 in CoE entry 0x100A.
Display of EL3204 firmware version
In (A) TwinCAT 2.11 shows that the Online CoE directory is currently displayed. If this is not the case, the Online directory can be loaded via the Online option in Advanced Settings (B) and double-clicking on AllObjects.


Updating controller firmware *.efw

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Updating controller firmware *.efw
Updating controller firmware *.efw
CoE directory
The Online CoE directory is managed by the controller and stored in a dedicated EEPROM, which is generally not changed during a firmware update.
Switch to the Online tab to update the controller firmware of a slave, see Fig. Firmware Update.
Firmware Update
Proceed as follows, unless instructed otherwise by Beckhoff support. Valid for TwinCAT 2 and 3 as EtherCAT master.
▪
Switch TwinCAT system to ConfigMode/FreeRun with cycle time >= 1 ms (default in ConfigMode is 4 ms). A FW-Update during real time operation is not recommended.
▪
Switch EtherCAT Master to PreOP
▪
Switch slave to INIT (A)
▪
Switch slave to BOOTSTRAP
▪
Check the current status (B, C)
▪
Download the new *efw file (wait until it ends). A pass word will not be neccessary usually.
▪
After the download switch to INIT, then PreOP
▪
Switch off the slave briefly (don't pull under voltage!)
▪
Check within CoE 0x100A, if the FW status was correctly overtaken.


FPGA firmware *.rbf

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] FPGA firmware *.rbf
FPGA firmware *.rbf
If an FPGA chip deals with the EtherCAT communication an update may be accomplished via an *.rbf file.
▪
Controller firmware for processing I/O signals
▪
FPGA firmware for EtherCAT communication (only for terminals with FPGA)
The firmware version number included in the terminal serial number contains both firmware components. If one of these firmware components is modified this version number is updated.
Determining the version via the System Manager
The TwinCAT System Manager indicates the FPGA firmware version. Click on the Ethernet card of your EtherCAT strand (Device 2 in the example) and select the Online tab.
The Reg:0002 column indicates the firmware version of the individual EtherCAT devices in hexadecimal and decimal representation.
FPGA firmware version definition
If the column Reg:0002 is not displayed, right-click the table header and select Properties in the context menu.
Context menu Properties
The Advanced Settings dialog appears where the columns to be displayed can be selected. Under Diagnosis/Online View select the '0002 ETxxxx Build' check box in order to activate the FPGA firmware version display.
Dialog Advanced Settings
Update
For updating the FPGA firmware
▪
of an EtherCAT coupler the coupler must have FPGA firmware version 11 or higher;
▪
of an E-Bus Terminal the terminal must have FPGA firmware version 10 or higher.
Older firmware versions can only be updated by the manufacturer!
Updating an EtherCAT device
The following sequence order have to be met if no other specifications are given (e.g. by the Beckhoff support):
▪
Switch TwinCAT system to ConfigMode/FreeRun with cycle time >= 1 ms (default in ConfigMode is 4 ms). A FW-Update during real time operation is not recommended.
▪
In the TwinCAT System Manager select the terminal for which the FPGA firmware is to be updated (in the example: Terminal 5: EL5001) and
click the Advanced Settings button in the EtherCAT tab:
▪
The Advanced Settings dialog appears. Under ESC Access/E²PROM/FPGA click on Write FPGA button:
▪
Select the file (*.rbf) with the new FPGA firmware, and transfer it to the EtherCAT device:
▪
Wait until download ends
▪
Switch slave current less for a short time (don't pull under voltage!). In order to activate the new FPGA firmware a restart (switching the power supply off and on again) of the EtherCAT device is required.
▪
Check the new FPGA status
Note
Risk of damage to the device!
A download of firmware to an EtherCAT device must not be interrupted in any case! If you interrupt this process by switching off power supply or disconnecting the Ethernet link, the EtherCAT device can only be recommissioned by the manufacturer!


Simultaneous updating of several EtherCAT devices

Appendix [image] Firmware Update EL/ES/EM/ELM/EPxxxx [image] Simultaneous updating of several EtherCAT devices
Simultaneous updating of several EtherCAT devices
The firmware and ESI descriptions of several devices can be updated simultaneously, provided the devices have the same firmware file/ESI.
Multiple selection and firmware update
Select the required slaves and carry out the firmware update in BOOTSTRAP mode as described above.


Restoring the delivery state

Appendix [image] Restoring the delivery state
Restoring the delivery state
To restore the delivery state for backup objects in ELxxxx terminals, the CoE object Restore default parameters, SubIndex 001 can be selected in the TwinCAT System Manager (Config mode) (see Fig. Selecting the Restore default parameters PDO)
Selecting the "Restore default parameters" PDO
Double-click on SubIndex 001 to enter the Set Value dialog. Enter the value 1684107116 in field Dec or the value 0x64616F6C in field Hex and confirm with OK (Fig. Entering a restore value in the Set Value dialog).
All backup objects are reset to the delivery state.
Entering a restore value in the Set Value dialog
Alternative restore value
In some older terminals the backup objects can be switched with an alternative restore value: Decimal value: 1819238756, Hexadecimal value: 0x6C6F6164An incorrect entry for the restore value has no effect.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com