CX9020 Embedded PC

BECKHOFF Automation

Hardware documentation for CX9020 Embedded PC

CX9020-011x

Version: 1.0
Date: 2013-03-06


Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending

The EtherCAT Technology is covered, including but not limited to the following patent applications and patents:
EP1590927, EP1789857, DE102004044764, DE102007017835
with corresponding applications or registrations in various other countries.

The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.

Copyright

© Beckhoff Automation GmbH.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Safety rules

Consider the following safety instructions and descriptions!
Product specific safety instructions are to be found on the following pages or in the areas mounting, wiring, commissioning etc.

Disclaimer

All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH.

Personnel qualification

This description is only intended for the use of trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.

Description of symbols

The following symbols with a adjoining safety advise or notice are used in this documentation. You have to read the safety advices carefully and adhere them strictly!

DANGER 		Acute risk of injury!
If you do not adhere the safety advise adjoining this symbol, there is immediate danger to life and health of individuals!

WARNING 		Risk of injury!
If you do not adhere the safety advise adjoining this symbol, there is danger to life and health of individuals!

CAUTION 		Hazard to individuals!
If you do not adhere the safety advise adjoining this symbol, there is obvious hazard to individuals!

Attention 		Hazard to devices and environment
If you do not adhere the notice adjoining this symbol, there is obvious hazard to materials and environment.

Note 		Note or pointer
This symbol indicates information that contributes to better understanding.


Documentation Issue Status

Version | Changes
1.0 | First publication


Intended use

The CX9020 device series is a modular control system designed for top-hat rail installation. The system is scalable, so that the required modules can be assembled and installed in the control cabinet or terminal box as required.

Only switch the PC off after closing the software

Before the Embedded PC is switched off, the software currently running on it should be stopped properly in order to avoid data loss on the hard disk. Please read the section on “Switching off”.

Switch off all system components and uncouple the Industrial PC from the system if the PC is not used for control purposes, e.g. during a function test. To disconnect first pull the first terminal behind the power supply unit (optional), then pull the connectors of the fieldbus connections.
System components that have been switched off must be secured against being switched on again.

The Embedded PC’s power supply unit must be supplied with 24 VDC.

Attention

Damage to the environment or devices
Do not exchange any parts when under power! The exchange of controller parts when live can lead to short-circuits or overvoltages. These can damage the controller itself and connected peripherals (terminals, monitors, input devices, etc.).

When components are being fitted or removed, the supply voltage must be switched off.

Software knowledge

Attention

System malfunctions
Mandatory software knowledge! Every user must be familiar with any of the functions of the software installed on the PC that he can reach.


System overview

The system

The CX9020 is a compact, DIN rail-mountable Ethernet control system with 1 GHz ARM Cortex™ A8 CPU. The connection for the Beckhoff I/O systems is directly integrated into the CPU module. The unit offers automatic bus system identifi cation (K-bus or E-bus) and independently switches in the corresponding mode. The CX9020 comprises the CPU with two microSD card slots, the internal RAM and 128 kB NOVRAM as nonvolatile memory. The basic confi guration also includes two switched Ethernet RJ 45 interfaces, four USB-2.0 interfaces and a DVI-D interface. The RJ 45 interfaces are connected to an internal switch and offer a simple option for creating a line topology without the need for additional Ethernet switches. The operating system is Microsoft Windows Embedded Compact 7. TwinCAT 2 automation software transforms a CX9020 system into a powerful PLC and Motion Control system that can be operated with or without visualisation. Optionally, the unit can be ordered with a fi eldbus, serial or audio interface.
The extended operating temperature range between -25 and +60 °C enables application in climatically demanding situations.

EtherCAT as a fast I/O system

The CX9020 Embedded PC was developed for optimum interaction with EtherCAT.

Interestingly, EtherCAT offers several options for connecting conventional fieldbus systems to the CX9020:
As an EtherCAT device in terminal form. The PROFIBUS master is available either as a CX1500-M310 or as a EL6731 EtherCAT terminal. In practice, this means that the PROFIBUS master can be positioned exactly where it is required within a machine. It no longer has to be implemented as a plug-in card in the IPC or a master controller in the control cabinet.

PLC, Motion Control, interpolation and visualisation

As a DIN rail IPC and in conjunction with the TwinCAT software from Beckhoff, the CX9020 offers the same functionality as large Industrial PCs. In terms of PLC, up to four virtual IEC 61131 CPUs can be programmed with up to four tasks each. All IEC 61131-3 languages can be used.

Moreover, all TwinCAT functionalities are available for Motion Control applications:
In theory, up to 256 axes can be controlled. In addition to simple point-to-point movements, more complex multi-axis functions such as “electronic gearbox”, “cam plates” and “flying saw” can be implemented.

In addition to real-time execution of control tasks, the TwinCAT real-time kernel ensures that enough time remains for the user interface (HMI), to communicate with the real-time components via software interfaces such as ADS or OPC.

For CX9020 the familiar basic principle applies: it is a programming tool for all controllers.
The complete programming of PLC, Motion Control and visualisation is transferable to all PC controls from Beckhoff, which is reassuring in cases where it becomes apparent during a project that more processing power is required after all. In this case a system with higher performance can be used.

Fieldbus interfaces

The fieldbus interfaces are currently available as master and slave versions for the following fieldbuses:

Optional interfaces:

The optional interfaces can be used to connect single-channel fieldbus interfaces. Operation is limited to one interface at a time. If several fieldbus interfaces are required, they can be added as E-bus terminals (EL67xx). The following fieldbus interfaces are available:

  • CX9020-N020 = Audio, 3 x 3.5 mm jack plugs, Line-In, Mic-In, Line-Out
  • CX9020-N030 = RS232, D-Sub connector, 9-pin
  • CX9020-N031 = RS422/RS485,D-Sub socket, 9-pin
  • CX9020-B110 = EtherCAT slave, EtherCAT IN und OUT (2 x RJ 45)
  • CX9020-M310 = PROFIBUS master, D-Sub socket, 9-pin
  • CX9020-B310 = PROFIBUS slave,D-Sub socket, 9-pin
  • CX9020-M510 = CANopen master, D-Sub socket, 9-pin
  • CX9020-B510 = CANopen slave, D-Sub socket, 9-pin
  • CX9020-M930 = PROFINET RT, controller Ethernet (2 x RJ 45)
  • CX9020-B930 = PROFINET RT, device, Ethernet (2 x RJ-45-Switch)
  • CX9020-B950 = EtherNet/IP slave, Ethernet (2 x RJ-45-Switch)

The software

In combination with the TwinCAT automation software, the CX9020 Industrial PC becomes a powerful IEC 61131-3 PLC with up to four user tasks. Additionally, Motion Control tasks can also be executed. Depending on the required cycle time, several servo axes can be controlled.

The CX9020 system is programmed in the same way as other bus controllers:

Remote programming via Ethernet

This option is used if the basic unit is equipped with “Windows Embedded Compact 7”. In this case, the system is programmed via a laptop or a desktop PC, which is connected to the CX via Ethernet (network or crossover cable). The programs are developed on the laptop with a standard TwinCAT software licence and then loaded into the target device.


Technical data

BECKHOFF CX9020: Product overview

CX9020 Technical data

The basic configuration of the CX9020 includes a 256 MB µSD Flash card. The basic configuration includes two Ethernet RJ-45 interfaces (connected via the internal switch), four USB 2.0 interfaces and a DVI-D interface.

Technical Data | CX9020
Processor | ARM Cortex™-A8, 1 GHz
Internal Flash memory | 256 MB MicroSD (optional expandable), 2 x MicroSD card slot
Internal main memory | 1 GB DDR3 RAM
Persistent memory | 128 kB NOVRAM interior
Interfaces | 2 x RJ 45 (Ethernet, internal Switch), 10/100 MBit/s, DVI-D, 4 x USB 2.0, 1 x optional interface
Diagnostics LED | 1 x power, 1 x TC status, 2 x bus status, 2 x flash access
Clock | Internal clock with battery backup for time and date (battery replaceable)
Operating system | Microsoft Windows Embedded Compact 7
Control software | TwinCAT 2 PLC runtime or TwinCAT 2 NC PTP runtime
Power supply | 24 V DC (-15 %/+20 %)
Current supply | I/O terminals 2 A
Max. power loss | 5 W (including system interfaces)
Dielectric strength | 500 Veff (supply/internal electronics)
Dimensions (H x W x D) | 84 mm x 99 mm x 91 mm
Dimensions (H x W x D) | approx. 590 g
Operating/storage temperature | -25° C ... +60° C / -40° C ... +85° C
Relative humidity | 95 % no condensation
Vibration/shock resistant | conforms to EN 60068-2-6/EN 60068-2-27/ 29
EMC immunity/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP 20

Further Information: www.beckhoff.de/CX9020


Types

The CPU module can be equipped with different software options for control software. The operating system is limited to "Windows Embedded Compac 7". The TwinCAT automation software transforms a CX9020 system into powerful PLC and Motion Control system that can be operated with or without visualisation. Further system interfaces (pre-installed in the factory) or fieldbus connections can be added to the basic CPU module.

The CX9020 modules are available in the following types:

Module | CPU frequency | Windows CE | no TwinCAT | TwinCAT 2PLC Runtime | TwinCAT 2 NC PTP Runtime
CX9020-0110 | 1 GHz | - | X | - | -
CX9020-0111 | 1 GHz | X | - | X | -
CX9020-0112 | 1 GHz | X | - | - | X

Note 		Software Images
A list of the different software images can be found in the Software Documentation.


Battery compartment

The battery compartment is located under the front cover of the CX20x0. The opening in which the battery bracket is mounted can be seen when the front cover is opened. The battery is then pulled carefully out of the holder with the help of the ejection tab and then removed.

To insert a new battery push it into the battery compartment. Ensure correct polarity. Then close the front cover. The battery change is then complete.

The battery is a CR2032 type from Panasonic.

The correct specifications are:

Battery type | Electrical properties (at 20 °C) |  | Standard charge | Dimensions
 | nominal voltage | nominal capacity | continuous load | Diameter | Height | Weight
CR2032 | 3.0 V | 225 mAh | 0.20 mA | 20.0 mm | 3.20 mm | 3.1 g

Attention

An incorrectly inserted battery may explode!
Only use the same battery type (CR2032) from Sanyo or Panasonic.

Make absolutely sure that positive and negative terminals of the battery are inserted correctly. (minus pole on the left)

Never open the battery or throw it into a fire.

The battery cannot be recharged.

Notice

Battery maintenance
The battery must be replaced every 5 years.

Spare batteries can be ordered from Beckhoff Service.


CF slot

BECKHOFF CX9020: Product overview

Micro-SD slot

Two µSD Flash slots are located at the front, which enables the storage medium to be replaced. This allows the storage medium to be exchanged. The card in the upper slot (Slot 1) is used for the operating system. The lower slot (Slot 2) is used for an additional µSD card. Here data or further programs can be archvied. The µSD Flash card can be removed from the module for maintenance. This should only be done in switched-off state, otherwise the system may crash. In this way it is also possible to expand the system (only operating system and program memory). MicroSD Flash cards (µSD cards) are available as accessories in various sizes.

The following images illustrate the handling of the µSD cards. The eject mechanism is based on the push-push principle: The CFast Flash card is disengaged with a soft click by lightly pressing the card ( with a screwdriver) . At the same time the card moves approx. 2-3 mm out of the housing, so that it can be pulled out.

When the card is pushed back the eject mechanism locks again. The card is positioned correctly, if it is located approx. 1 mm lower than the front of the housing.


Mirco SD card

The micro SD Flash Card (µSD Card) is a non-volatile memory.

Data to be retained in the event of a power failure should be saved on the µSD card. The µSD card operates like a hard disk.

Notice 		Using µSD cards
We strongly recommend that only µSD cards supplied by Beckhoff Automation GmbH should be used.
These are industrial µSD cards with a higher number of write/read cycles and an extended temperature range (+85 °C).

Proper operation can only be guaranteed with µSD cards from Beckhoff Automation GmbH!


Unpacking, assembly and transport

BECKHOFF CX9020: Mounting and wiring

Unpacking, installation and transport

The specified storage conditions must be adhered to (see "Technical data").

Dimensions and weight of the individual modules:

Dimensions (W x H x D): 100 x 84 x 91 mm

Weight: 590 g (basic module)

Unpacking

Proceed as follows to unpack the unit:

  1. Remove packaging.
  2. Do not discard the original packaging. Keep it for transporting the device in the future.
  3. Check the delivery for completeness by comparing it with your order.
  4. Please keep the associated paperwork. It contains important information for handling the unit.
  5. Check the contents for visible shipping damage.
  6. If you notice any shipping damage or inconsistencies between the contents and your order, you should notify Beckhoff Service.

Attention 		Danger of damage to the unit!
During transport in cold conditions, or if the unit is subjected to extreme temperature swings, condensation on and inside the unit must be avoided.

Prior to operation, the unit must be allowed to slowly adjust to room temperature. Should condensation occur, a delay time of approximately 12 hours must be allowed before the unit is switched on.

Installation

The devices are designed for installation in control cabinets.

Shipping and relocation

Despite the robust design of the unit, the components are sensitive to strong vibrations and impacts. During transport, your computer should therefore be protected from excessive mechanical stress. Therefore, please use the original packaging.


Dimensions

The following drawing shows the dimensions of the CX9020 devices.

Dimensions


Installation on the mounting rail

Snapping onto the mounting rail

The CX9020 can simply be snapped onto the mounting rail. The bar clips are inserted on the top side and underside Then simply position the block on the mounting rail and push it slightly until it engages on the right-hand side. This is indicated by a distinct click. The bars are then engaged again. The engagement of the individual bars is indicated by a distinct click.

Attention 		Avoid damage!
Do not force the module or apply excessive pressure!

Installation position

Attention 		Comply with the permitted installation position and minimum distances!
The maximum ambient temperature for CPU modules mounted on a top-hat rail is 60°C. The orientation in which the device is fitted must be selected in such a way that cooling air can flow vertically through the ventilation holes. The images below show the permitted and two incorrect installation positions.

Mounting must provide a clearance of 30 mm both above and below a CX9020 device combination to ensure adequate ventilation of the base CPU module and the power supply unit.

Correct installation position

The high performance and the compact design of the CX9020 systems may result in increased heat generation. The heat is dissipated via a passive ventilation system. This system requires the unit to be mounted correctly. Ventilation openings are located at the top and bottom of the housing. The system therefore has to be installed horizontally. This ensures optimum air flow.

Incorrect installation positions

The CX9020 system must not be operated vertically on the top-hat rail. A vertical position would lead to insufficient CPU ventilation, since the ventilation openings are located on the top and bottom of the housing. Installation of the system on its side would also lead to inadequate ventilation.

invalid installation position | invalid installation position


Power supply

This power supply unit is equipped with an I/O interface, which permits connection of the Beckhoff Bus Terminals. The power is supplied via the upper spring-loaded terminals labeled “24V” and “0V”.
The supply voltage supplies the CX system ant the terminal Bus and Bus Terminal with a voltage of 24 V DC (-15 %/+20 %). The dielectric strength of the power supply unit is 500 Vrms. Since the Terminal Bus (K- and E-bus) only transfers data, a separate power supply is required for the Bus Terminals. This is provided by means of the power contacts, which are not connected to the power supply.

Requirements for the 24V power supply

The power supply must be capable to supply 4A at 24 V to guarantee proper function of CPU CX9020 module and terminals.

The terminals are implemented in spring force technology. Connect the cables as follows:

  1. Open a spring-loaded terminal by slightly pushing with a screwdriver or a rod into the square opening above the terminal.
  2. The wire can now be inserted into the round terminal opening without any force.
  3. The terminal closes automatically when the pressure is released, holding the wire securely and permanently.
Wire size width | 0.5 ... 2.5 mm2 | AWG 20 .. AWG 14
Wire stripping length | 8 ... 9 mm | 0.33 inch

LED

If the power supply unit is connected correctly and the power supply is switched on, the two upper LEDs in the terminal prism are green. The left LED (Us) indicates the CPU supply. The right LED (Up) indicates the terminal supply. The other LEDs indicate the Terminal Bus status. A detailed description of the LEDs can be found in section "LED troubleshooting".

UL requirements

DANGER 		Compliance of the UL requirements
For the compliance of the UL requirements the CX-Controllers should only be supplied
  • by a 24 VDC supply voltage, supplied by an isolating source and protected by means of a fuse (in accordance with UL248), rated maximum 4 Amp.
  • by a 24 VDC power source, that has to satisfy NEC class 2.
    A NEC class 2 power supply shall not be connected in series or parallel with another (class 2) power source!

This UL requirements are valid for all supply voltages of the CX-Controllers!

DANGER 		Compliance of the UL requirements
To meet the UL requirements, the CX-Controllers must not be connected to unlimited power sources!

Power contact PE

Achtung 		Powerkontakt "PE"
The “PE” power contact must not be used for other potentials. "PE" und "0V" (24V CX-System supply) have to be on the same potential. (connected in the cabinet)
Der Powerkontakt "PE" darf nicht für andere Potentiale verwendet werden. "PE" und "0V" (24V Systemversorgung) müssen auf dem gleichen Potential liegen. (im Schaltschrank verbunden)

The wiring the cabinet has to follow the Norm EN EN 60204-1:2006: Safety of machinery - Electrical equipment of machines - (PELV = Protective Extra Low Voltage)

EN 60204-1:2006 chapter 6.4.1:

b): One side of the circuit or a point of the energy source of the circuit must be connected to protective earth system

Achtung 		Interrupt power supply / switching off

If the power supply should be disconnected the "0V" must not be disconnected. Always disconnect the "24V" wire first. Otherwise there can be electrical current flow via the shield.

Possibly connected devices with own power supply (e.g. panel) must have the same electrical potential for "PE" and "GND" as the CX-unit. Otherwise the CX-unit and/or the connected device can be damaged.


Mounting of passive terminals on the CX9020 power supply

Notice 		Note on the mounting of passive terminals
EtherCAT Bus Terminals (ELxxxx/ESxxxx) that do not actively participate in data exchange within the Bus Terminal block are called passive terminals. These terminals can be recognised by their lack of power consumption from the E-Bus.
In order to ensure optimal data exchange, these may not be connected directly in-line to the power supply!
Examples of the mounting of passive terminals (coloured dark):

The following drawing shows impermissible mounting:

The following illustration shows the correct mounting of the passive terminal:


DVI-D port

DVI-D port (X200)

The DVI-D interface transfers digital data and is suitable for connecting a digital display. The resolution at the display or the Beckhoff Control Panel depends on the distance from the display device. The maximum distance is 5 m. Beckhoff offers various Panels with an integrated “DVI extension”. These make a cable length of up to 50 metres possible.

Notice 		DVI-D Interface
The DVI interface does not use VGA signals, so that the connection of CRT VGA monitors to the CX9020 system using a DVI to VGA adapter is not possible.

DVI-I socket

Pin | Assignment | Pin | Assignment | Pin | Assignment
1 | TMDS Data 2- | 9 | TMDS Data 1- | 17 | TMDS Data 0-
2 | TMDS Data 2+ | 10 | TMDS Data 1+ | 18 | TMDS Data 0+
3 | TMDS Data 2/4 Shield | 11 | TMDS Data 1/3 Shield | 19 | TMDS Data 0/5 Shield
4 | not connected | 12 | not connected | 20 | not connected
5 | not connected | 13 | not connected | 21 | not connected
6 | DDC Clock | 14 | + 5V Power | 22 | TMDS Clock Shield
7 | DDC Data | 15 | Ground ( +5V, Analog H/V Sync) | 23 | TMDS Clock +
8 | Analog Vertical Sync | 16 | Hot Plug Detect | 24 | TMDA Clock -
Resolution at the monitor
Resolution in pixels | Distance of the interface from the monitor
1920 x 1200 | 5 m
1600 x 1200 | 5 m
1280 x 1024 | 5 m
1024 x 768 | 5 m
800 x 600 | 5 m
640 x 480 | 5 m


USB connections

USB interface (X100 / X101 / X102 / X103):

The CX9020 has 4 independent USB interfaces, for connecting keyboards, mice, touchscreens and other input or data storage devices. Attention is thereby to be paid to the power consumption of the individual devices: No more than 500 mA can be output per port.

The USB socket is a type A socket. The USB interface complies with the USB 2.0 specification.

Pin | Assignment | Typical assignment
1 | VBUS | Red
2 | D- | White
3 | D+ | Green
4 | GND | Black
Shell | Shield | Drain Wire


LAN connections

LAN interface (X000/ X001)

The CX9020 systems have two switched LAN interfaces. Both ports are able to operate at speeds of 10 / 100 Mbit. The LEDs on the left-hand sides of the RJ45 sockets indicate the status of the LAN connection. The upper LED indicates whether the port is connected to a network. The LED flashes if data traffic takes place on the port (Link /Activity). The lower LED indicates the connection speed. The LED is off if the speed is 10 Mbit. In 100 Mbit mode the LED is green.

Configuration of the RJ45 interface, port 1 (X000)

PIN | Signal | Description
1 | TD + | Transmit +
2 | TD - | Transmit -
3 | RD + | Receive +
4 | connected | not used
5
6 | RD - | Receive -
7 | connected | not used
8

Configuration of the RJ45 interface, port 2 (X001)

PIN | Signal | Description
1 | TD + | Transmit +
2 | TD - | Transmit -
3 | RD + | Receive +
4 | connected | not used
5
6 | RD - | Receive -
7 | connected | not used
8

Notice 		Dependence of the ports
Both ports are dependent of each other. In contrast to the CX50x0 and CX20x0 systems, one switch is integrated. For a line topology no further switch is required.


Audio interface (CX9020-N020)

This system interface provides the audio interface for the CX9020 system. Two inputs, "LINE IN" (X300) and "MIC IN" (X302), are available. The "LINE OUT" (X301) connection is used as output for audio signals. It can also be used for connecting headphones with a maximum output of 200 mW. The audio interfaces are accessed via the operating system.

The 3.5 mm sockets are designed for jack plugs.

Standard / stereo mode:

The audio module operates in stereo mode as standard, using stereo outputs/inputs and a single-channel input for the microphone. The inputs should be connected as indicated. The pin assignments are described below.

Line In / Line Out stereo jack plugs (X300 / X302):

Pin assognment Line In /Line Out:

Signal | Description
L | Left channel
R | right channel
Ground | Ground

The left channel is transferred via the tip of the jack plug, the right channel via the first ring. The remainder of the sleeve is used for earthing.

Mic In mono jack plug (X301):

The only existing channel is transferred via the tip, the remainder of the sleeve is used for earthing.

The audio settingsa can be done via the Beckhoff CX-Configuration Tool. Open the tool via

Startmenue -> Control Panel -> CX Configuration

Navigate to tab "Miscellaneous" to change audio settings.

The checkbox "Enable Audio Device" enables or disables the interface. With "Audio Settings" a "Mixer" can be called. The volume for the output and input is selected with the slider. The input source can be selected with "Input select". Only one source (LINE or MIC) can be active at once. "OK" confirms these settings.


RS232 connections (CX9020-N030)

The CX9020-N030 system interface provides an RS232 interface, COM1 (X300). It is implemented on a 9-pole Sub-D pin strip. If more than one interface is required the system can be extended via the Terminal Bus (K- or E-bus) or Bus Terminals (KL/EL6001) which provide serial interfaces. The pin assignment is shown at the bottom of the page.

The maximum baud rate on both channels is 115 kbit. The interface parameters are set via the operating system or from the PLC program.

RS232 COM interface (connector)

Pin assignment of the COM interface

PIN | Signal | Type | Description
2 | RxD | Signal in | Receive Data
3 | TxD | Signal out | Transmit Data
5 | GND | Ground | Ground
7 | RTS | Signal out | Ready to Send
8 | CTS | Signal in | Clear to Send


RS422/RS485 connections (CX9020-N031)

The CX9020-N030 system interface provides an RS422 or RS 485 interface, COM1 (X300). It is implemented on a 9-pole Sub-D socket strip. If more than one interface is required the system can be extended via the Terminal Bus (K- or E-bus) or Bus Terminals (KL/EL6021) which provide serial interfaces. The pin assignment is shown at the bottom of the page.

The maximum baud rate on both channels is 115 kbit. The interface parameters are set via the operating system or from the PLC program.

COM interface (socket)

Pin assignment of the COM interface

PIN | Signal | Type | Description
2 | TxD+ | Data-Out + | Transmit 422
3 | RxD+ | Data-In + | Receive 422
5 | GND | Ground | Ground
6 | VCC | VCC | +5V
7 | TxD- | Data-Out - | Transmit 422
8 | RxD- | Data-In - | Receive 422

For RS 485 pins 2 and 3 (data +) must be connected, and pins 7 and 8 (data -).

Setting the interface parameters

The interface is parameterised as follows in the delivery condition:

RS485 without echo, end point (terminated) standard setting

Function | Status
Echo on | off
Echo off | on
Auto send on | on
Always send on | off
Auto receive on | on
Always receive on | off
Term on | on
Term on | on

Notice

Changing the interface parameters

If parameters other than those set should be required, please contact Service


Switching on and off

Switching on

The power supply for the basic CPU module comes from the power supply unit. The basic CPU module starts automatically when the power supply unit is connected to the mains.

Switching on for the first time

When you switch on the PC for the first time, the pre-installed operating system (optional) will be started.

Switching off

The Embedded PC switches off when the power supply unit is switched off. The control software typically running on Embedded PCs should be shut down or stopped correctly. A user who may not close software may also not switch the Embedded PC off, since data can be lost from the hard disk by switching off while software is running.

Once the software has been stopped, the operating system can be shut down. Only then should the power supply be interrupted.


LEDs on the basic CP Umodule

BECKHOFF CX9020: Error handling and diagnostics

LEDs on the basic CPU module

Display | LED | Meaning
 | PWR | Power supply The Power LED comes on when the device is connected to a live power supply unit (green).
 | TC | TwinCAT status LED TwinCAT is in Run mode (green) TwinCAT is in Stop mode (red) TwinCAT is in Config mode (blue)
 | FB1 | Status LED1 for fieldbus (function is written at the fieldbus interface)
 | FB2 | Status LED2 for fieldbus (function is written at the fieldbus interface)
 | HDD 1 | Indicates access to the µSD card in slot 1. LED flashes green during read access. LED flahes yellow during write access.
 | HDD 2 | Indicates access to the µSD card in slot 2. LED flashes green during read access. LED flahes yellow during write access.


LEDs of the power supply in K-Bus mode

After switching on, the power supply immediately checks the connected Bus Terminal configuration. If K-Bus terminals are detected, the error-free bootup is signalled by the red “I/O ERR LED” going out. If the ”I/O ERR" LED blinks, an error in the area of the terminals is indicated. The error code can be determined from the frequency and number of blinks. This permits rapid rectification of the error.

Display | LED | Meaning
 | Us 24 V | Power supply for the CPU module The LED lights green if the power supply is correct.
 | Up 24V | Power supply for terminal bus. The LED lights green if the power supply is correct.
 | K-BUS RUN | K-Bus diagnostics The green LED lights up in order to indicate fault-free operation. "Fault-free" means that the communication with the fieldbus system is also running.
 | K-BUS ERR | K-Bus diagnostics The red LED flashes to indicate an error. The red LED blinks with two different frequencies.

The I/O error LED blink code

fast blinking | Start of the error code
first slow sequence | Error code
second slow sequence | Error code argument

LEDs for K-Bus diagnosis

Error code | Error code argument | Description | Remedy
Persistent, continuous flashing EMC problems
  • Check power supply for undervoltage or overvoltage peaks
  • Implement EMC measures
  • If a K-Bus error is present, it can be localised by a restart of the power supply (by switching it off and then on again)
1 pulse | 0 | EEPROM checksum error | Revert to the manufacturer’s setting
1 | Code buffer overflow | Insert fewer Bus Terminals. Too many entries in the table for the programmed configuration
2 | Unknown data type | Software update required for the power supply
2 pulses | 0 | Programmed configuration has an incorrect table entry | Check programmed configuration for correctness
n (n > 0) | Table comparison (Bus Terminal n) | Incorrect table entry
3 pulses 0 K-Bus command error
  • No Bus Terminal inserted
  • One of the Bus Terminals is defective; halve the number of Bus Terminals attached and check whether the error is still present with the remaining Bus Terminals. Repeat until the defective Bus Terminal is located.
4 pulses | 0 | K-Bus data error, break behind the power supply | Check whether the n+1 Bus Terminal is correctly connected; replace if necessary.
n | Break behind Bus Terminal n | Check whether the Bus End Terminal 9010 is connected.
5 pulses | n | K-Bus error in register communication with Bus Terminal n | Exchange the nth bus terminal
7 pulses | 0 | Process data lengths of the set and actual configurations do not correspond | Check configuration and terminals for consistency
9 pulses | 0 | Checksum error in Flash program | Revert to the manufacturer’s setting
n (n>0) | Bus Terminal n is not consistent with the configuration that existed when the boot project was created | Revert to the manufacturer's setting which will clear the boot project.
14 pulses | n | nth Bus Terminal has the wrong format | Start the power supply again, and if the error occurs again then exchange the Bus Terminal.
15 pulses | n | Number of Bus Terminals is no longer correct | Start the power supply up again.
16 pulses | n | Length of the K-Bus data is no longer correct | Start the power supply up again.

Error code argument

The number of pulses indicates the position of the last Bus Terminal before the fault. Passive Bus Terminals, such as a power feed terminal, are not included in the count.

In the case of some errors, rectification does not cause the power supply to leave the blink sequence. The power supply can only be restarted by switching its supply voltage off and on again.


LEDs of the power supply in E-bus mode

After switching on, the power supply immediately checks the connected Bus Terminal configuration. If K-Bus terminals are detected, the error-free bootup is signalled by the red “I/O ERR LED” going out. If the ”I/O ERR" LED blinks, an error in the area of the terminals is indicated. The error code can be determined from the frequency and number of blinks. This permits rapid rectification of the error.

Display | LED |  | Meaning
 | Us 24 V |  | Power supply for the CPU module The LED lights green if the power supply is correct.
 | Up 24V |  | Power supply for terminal bus. The LED lights green if the power supply is correct.
 | L/A | off | E-bus not connected
 |  | on | E-bus connected / no data traffic
 |  | flashing | E-bus connected / data traffic on the E-bus.


Faults

Please also refer to the Safety instructions section.

Possible faults and their correction

Fault | Cause | Measures
no function after the Embedded PC has been switched on | no power supply for the Embedded PC other causes | 1. Check fuse 2. Measure voltage at connection, check plug wiring Call Beckhoff support
Embedded PC does not boot fully | Hard disk damaged (e.g. due to switching off while software is running), incorrect setup, other causes | Check setup Call Beckhoff support
Computer boots, software starts, but control does not operate correctly | Cause of the fault is either in the software or in parts of the plant outside the Embedded PC | Call the manufacturer of the machine or the software.
µSD card access error | Faulty µSD card, faulty card slot | Use a different µSD card to check the card slot Call Beckhoff support
Embedded PC only works partially or temporarily | Defective components in the Embedded PC | Call Beckhoff support

Please make a note of the following information before contacting Beckhoff service or support:

  1. Precise device ID: CXxxxx-xxxx
  2. Serial number
  3. Hardware version
  4. Any interfaces (N030, N031, B110, ...)
  5. TwinCAT version used
  6. Any components / software used

The quickest response will come from support / service in your country. Therefore please contact your regional contact. For details please refer to our website at www.beckhoff.de or ask your distribution partner.


Disassembly and disposal

A CX9020 hardware configuration is dismantled in 2 stages:

1. Switching off and disconnecting the power supply

Before a CX9020 system can be dismantled, the system should be switched off, and the power supply should be disconnected.

2. Removing from the top-hat rail:

Before the individual modules are disconnected, the whole CX9020 hardware block should be removed from the top-hat rail. Proceed as follows:

2.1. Release and remove the first Terminal next to the power supply unit on the top-hat rail.

First remove any wiring from power supply unit and then from the first terminal on the top-hat rail next to the power supply unit. If the wiring is to be reused for another system, it is advisable to make a note of the connections. Then pull the orange terminal release (see arrow) to release the terminal and pull it out.

2.2. Releasing the CX9020 systems

To release the CX9020 block, release the orange DIN rail bracket on the left-hand side of the device. Push back the lower hook. An audible click indicates that the device is released.

After pulling the terminal release of the power supply unit, the block can be removed carefully from the top-hat rail.

Attention
 Do not use force to open the device!
Opening the module housing by force would destroy it. The devices may only be opened by Beckhoff service personnel.

Disposal

The device must be fully dismantled in order to dispose of it.

Electronic parts must be disposed of in accordance with national electronics scrap regulations.


Accessories

MicroSD cards

instead of the 256 MB microSD card

oder number | Description
CX1900-0123 | 1 GByte microSD card, instead of 256 MB microSD card
CX1900-0125 | 2 GByte microSD card, instead of 256 MB microSD card
CX1900-0127 | 4 GByte microSD card, instead of 256 MB microSD card
CX1900-0129 | 8 GByte microSD card, instead of 256 MB microSD card

spare microSD cards

oder number | Description
CX1900-0122 | 256 MByte microSD card
CX1900-0124 | 1 GByte microSD card
CX1900-0126 | 2 GByte microSD card
CX1900-0128 | 4 GByte microSD card
CX1900-0130 | 8 GByte microSD card

Spare battery for CX-Systems

oder number | Description
CX1900-0102 | Battery for the CX-Systems - original product description: Panasonic type CR2032 3V/225mAh


Certifications

All products of the Embedded PC family are CE, UL and GOST-R certified. Since the product family is continuously developed further, we are unable to provide a full listing here. The current list of certified products can be found on the Embedded PC certificates web page or at www.beckhoff.com under Embedded PC.


Support and Service

Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.

Beckhoff's branch offices and representatives

Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!

The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com

You will also find further documentation for Beckhoff components there.

Beckhoff Headquarters

Beckhoff Automation GmbH

Huelshorstweg 20
33415 Verl
Germany

Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support

Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:

  • support
  • design, programming and commissioning of complex automation systems
  • and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service

The Beckhoff Service Center supports you in all matters of after-sales service:

  • on-site service
  • repair service
  • spare parts service
  • hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com