CX8091 - Embedded PC for BACnet/IP or OPC UA

BECKHOFF Feldbuskomponenten

Documentation for

CX8091

Embedded PC for BACnet/IP or OPC UA

Version: 1.1.0
Datum: 2015-07-29


Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending

The EtherCAT Technology is covered, including but not limited to the following patent applications and patents:
EP1590927, EP1789857, DE102004044764, DE102007017835
with corresponding applications or registrations in various other countries.

The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.

Copyright

© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Safety rules

Consider the following safety instructions and descriptions!
Product specific safety instructions are to be found on the following pages or in the areas mounting, wiring, commissioning etc.

Disclaimer

All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.

Personnel qualification

This description is only intended for the use of trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.

Description of symbols

The following symbols with a adjoining safety advise or notice are used in this documentation. You have to read the safety advices carefully and adhere them strictly!

DANGER 		Acute risk of injury!
If you do not adhere the safety advise adjoining this symbol, there is immediate danger to life and health of individuals!

WARNING 		Risk of injury!
If you do not adhere the safety advise adjoining this symbol, there is danger to life and health of individuals!

CAUTION 		Hazard to individuals!
If you do not adhere the safety advise adjoining this symbol, there is obvious hazard to individuals!

Attention 		Hazard to devices and environment
If you do not adhere the notice adjoining this symbol, there is obvious hazard to materials and environment.

Note 		Note or pointer
This symbol indicates information that contributes to better understanding.


CX8091 - Documentation issue status

BECKHOFF CX8091: Foreword

Documentation issue status

Version Comment
1.1.0
  • Foreword updated
  • Chapter 1-second UPS added
  • Chapter Operating System added
1.0.0
  • First release
0.1
  • Preliminary version

Image Version CX8091

Firmware Description
Build 2242
  • Released version
Build 2241
  • First version


CX80xx - System overview

CX80xx is a device family of programmable controllers with 32-bit ARM-based CPU, which can be used for processing of PLC programs or as slave devices for higher-level fieldbus systems. Unlike with the non-programmable EtherCAT couplers of the EK series, which only act as gateway between the associated fieldbus system and the connected EtherCAT terminals, the CX80xx is programmable and able to run its own control program.

The devices from the CX80xx series represent a further development of the well-known and proven 16-bit microcontroller-based Bus Terminal Controllers from the BC and BX series including more efficient 32-bit processors. As with the BC/BX, it is also ensured in the case of the CX80xx that the control and the local program continue to be executed in the case of interruption of the higher-level fieldbus system. The CX80xx devices can therefore be used as local controllers. Alternatively, Bus Terminals (K-bus) or EtherCAT Terminals (E-bus) can be connected; the CX80xx automatically recognizes which terminals are connected during the start-up phase. The use of EtherCAT gives rise to further options, such as the realization of different topologies, the integration of further bus systems such as CANopen, PROFIBUS and PROFINET and – with the EtherCAT Box Modules – connection to the IP67 world.

Like all CX products, the CX80xx devices are programmed and commissioned via the Ethernet interface, which can, of course, also be used for connection of the control system with a regular network. Some of the Embedded PCs have further Ethernet interfaces with switch functions, so that a linear “daisy chain” topology can be constructed inexpensively, without additional hardware. The other connections on the lower plug level are fieldbus-specific. Under the cover at the upper housing level there is an exchangeable button cell for date and time, a set of DIP switches for setting function modes, a slot for Micro-SD Flash memory cards and a type B USB connection. Thanks to their low power consumption, the devices are fanless.

Microsoft Windows CE is used as the operating system. In the absence of a monitor port, the operating system and its “virtual” display can only be accessed via the network. As for all other Beckhoff devices, the TwinCAT software is used for system configuration and the programming of the PLC functionality. The CX80xx target device features a pre-installed TwinCAT PLC runtime environment. All software required for operating the device, including the operating system, the TwinCAT files and user files and data, is stored on the Micro SD Flash card. This simplifies exchange in the case of service. Commercial card readers can be used to access the card data. The size of the Micro SD Flash card (e.g. 512 MB) can be chosen depending on the application and the quantity of data to be stored.

The CX80xx device family features an integrated, capacitive 1-second UPS, which in the event of a failure of the supply voltage provides sufficient energy for saving persistent data. Important data are thus preserved in a non-volatile manner without battery backup.

With a high-performance but nevertheless energy-saving 32-bit ARM processor, EtherCAT as I/O bus and TwinCAT PLC with extensive PLC libraries, the Embedded Controllers from the CX80xx series represent high-performance and versatile controllers with slave fieldbus connection.

Fieldbus-interface

The variants from the CX80xx series differ by their fieldbus interfaces. Various versions cover the most important fieldbus systems:

  • CX8010: EtherCAT Slave
  • CX8030: PROFIBUS DP Master
  • CX8031: PROFIBUS DP Slave
  • CX8050: CAN Master
  • CX8051: CANopen Slave
  • CX8080: RS232/485
  • CX8090: Ethernet (RT-Ethernet, EAP, ModbusTCP, TCP/IP, UDP/IP, Web Services)
  • CX8091: BACnet IP/OPC UA
  • CX8093: PROFINET RT Device (Slave)
  • CX8095: Ethernet/IP Slave
  • CX8097: Sercos III Slave

Programming

The CX80xx controller is programmed according to the high-performance IEC 61131-3 standard. As with all other Beckhoff controllers, the TwinCAT automation software is the basis for parameterization and programming. Users therefore have the familiar TwinCAT tools available, e.g. PLC programming interface, System Manager and TwinCAT Scope.

Configuration

The configuration is also carried out using TwinCAT. The fieldbus interface and the real-time clock can be configured and parameterized via the System Manager. The System Manager can read all connected devices and Bus Terminals. The configuration is stored on the CX after the parameterization. The configuration thus created can be accessed again later.


CX8091 - Introduction

The CX8091 is a controller with a switched Ethernet port. The BACnet/IP or OPC UA protocols are supported.

Alternatively K-bus or E-bus terminals can be series-connected; the CX8091 automatically detects which type of terminal is connected during the start-up phase.

The CX8091 is programmed with TwinCAT 2 via the fieldbus interface or the additional Ethernet interface.

In the basic version the CX80xx contains a 512 MB MicroSD card. The basic equipment includes two Ethernet interfaces as well as a K-bus or E-bus interface.

The smallest task time to be used is 1 ms (a task time of 1 to 50 ms is recommended for the I/O data, further tasks can also be set slower).
When using shorter cycle times, the total system utilization rate is to be observed.
If too short a cycle time is selected, the Web visualization and remote desktop may operate very slowly or cause timeouts.
The user is responsible for projecting and configuring his system such that it is not overloaded.


CX8091 - Technical data

BECKHOFF CX8091: Product overview

Technical data

Technical data | CX8091
Processor | 32 bit, 400 MHz, ARM9
Internal main memory | 64 MB RAM (internal, not extendable)
Operating system | Microsoft Windows CE 6.0
Web-based Management | yes
Flash memory | MicroSD card (ATP) 512 MB (optionally 1, 2, 4 GB)
Interfaces | 1 x USB device (behind the front flap) 1 x RJ45 Ethernet, 10/100 Mbit/s 2 x RJ45 switched, 100 Mbit/s
Protocols | ADS, BACnet/IP, OPC UA
Interface for I/O terminals | K-bus or E-bus, automatic recognition
Process data on the K-Bus | max. 2 KB input data max. 2 KB output data
Diagnostics LED | 1 x power, 1 x TC status, 2 x bus status
Clock | internal battery-backed clock (RTC) for time and date (battery exchangeable)
Operating system | Microsoft Windows CE
Control software | TwinCAT PLC runtime (from version 2.11 R3)
Programming | TwinCAT PLC
Programming languages | IEC 61131-3
Online Change | Yes
Up/download code | Yes/Yes
Power supply | 24 VDC (-15 %/+20 %)
UPS | 1-second UPS
Power supply for I/O terminals | 2 A max.
Max. power loss | 3.0 W (including system interfaces)
Dielectric strength | 500 V (supply / internal electronics)
Dimensions (W x H x D) | 64 mm x100 mm x 73 mm
Weight | approx. 180 g
Permissible ambient temperature during operation | 0° C ... +55° C
Permissible ambient temperature during storage | -25° C ... +85° C
Installation position | See chapter Installation positions
Relative humidity | 95 % no condensation
Vibration / shock resistance | Conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity/emission | Conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
System data | Ethernet (CX8091)
Number of I/O modules | depending on controller
Number of I/O points | depending on controller
Transmission medium | 4 x 2 twisted pair copper cable; category 5 (100 Mbaud), shielded
Cable length | 100 m
Data transfer rate | 100 Mbaud
Topology | Star-form cabling, line topology


CX8091 - Technical data - Ethernet

BECKHOFF CX8091: Product overview

Technical data - Ethernet

System data X001 | Ethernet (CX8091)
Transmission medium | 4 x 2 twisted pair copper cable category 5 (100 Mbaud)
Cable length | 100 m from switch to CX8091
Data transfer rate | 10/100 Mbaud
Topology | star wiring
Protocols | all non-real-time-capable protocols that are based on TCP or UDP and do not require a real-time extension, OPC UA
System data X101/102 | Ethernet (CX8091) real-time interface
Transmission medium | 4 x 2 twisted pair copper cable category 5 (100 Mbaud)
Cable length | 100 m from switch to CX8091
Data transfer rate | 100 Mbaud
Topology | Star-form cabling, line topology
Protocols (real-time) | BACnet/IP
Protocols (non-real-time) | all non-real-time-capable protocols that are based on TCP or UDP and do not require a real-time extension, OPC UA


CX80xx - MicroSD cards

BECKHOFF CX80xx: Product overview

Micro SD cards

In the basic version the CX80xx contains a MicroSD card with 512 MB. You can order it as an option with larger cards (up to 4 GB).

The cards employed are SLC memory with extended temperature range for industrial applications. Use exclusively MicroSD cards approved by Beckhoff.

Example of a MicroSD card:

Order designation | Capacitance | Description
CX1900-0123 | 1 GB | MicroSD card (SLC memory) with extended temperature range for industrial applications instead of the 512 MB card (ordering option)
CX1900-0125 | 2 GB
CX1900-0127 | 4 GB
CX1900-0122 | 512 MB | MicroSD card (SLC memory) with extended temperature range for industrial applications as spare part.
CX1900-0124 | 1 GB
CX1900-0126 | 2 GB
CX1900-0128 | 4 GB

Further Information: http://www.beckhoff.com/CX8000


CX80xx - Dimensions

BECKHOFF CX80xx: Mounting and wiring

Dimensions

The following drawings show the dimensions of the CX80xx Embedded PCs.

Dimensions

Drawings in several CAD formats can be found at: http://www.beckhoff.com/english.asp?download/cx1000.htm


CX80xx - Installation on mounting rails

BECKHOFF CX80xx: Mounting and wiring

Installation on mounting rails

Snapping onto the mounting rail

The CX80xx can simply be snapped onto the mounting rail. To this end simply position the block on the mounting rail and push it slightly until it engages on the right-hand side. The is indicated by a distinct click. Use a screwdriver to push up the lock on the left-hand side, thereby turning it and causing it to engage audibly.

Attention 		Avoid damage!
Do not force the module or apply excessive pressure!

Permissible installation positions and minimum distances

Installation position up to 55 °C

Attention 		Comply with the permitted installation position and minimum distances!
The maximum ambient temperature for CPU modules mounted on a top-hat rail is 55°C. The orientation in which the device is fitted must be selected in such a way that cooling air can flow vertically through the ventilation holes. The images show the permitted and two incorrect installation positions.

Mounting must provide a clearance of 30 mm both above and below a CX80xx device combination to ensure adequate ventilation of the base CPU module and the power supply unit.

The high performance and the compact design of the CX80xx systems may result in increased heat generation. The heat is dissipated via a passive ventilation system. This system requires the unit to be mounted correctly. Ventilation openings are located at the top and bottom of the housing. The system therefore has to be installed horizontally. This ensures optimum air flow.

Installation positions with reduced temperature range up to 45°C

Other installation positions are permitted with a temperature range up to 45°C.


CX80xx - Power supply

BECKHOFF CX80xx: Mounting and wiring

Power supply

WARNING 		Risk of electric shock and damage of device!
Bring the CX80xx into a safe, powered down state
before starting installation, disassembly or wiring!

This power supply unit is equipped with an I/O interface, which permits connection of the Beckhoff Bus Terminals. The power is supplied via the upper spring-loaded terminals with the designation 24 V and 0 V.

The supply voltage supplies the CX system and, via the terminal bus, the Bus Terminals with a voltage of 24 VDC (15 %/+20 %). The dielectric strength of the power supply is 500 V. Since the Terminal Bus (K- and E-bus) only transfers data, a separate power supply is required for the Bus Terminals. This is provided by means of the power contacts, which are not connected to the power supply. The maximum current load of the power contacts is 10 A.

Requirements for the power supply (24 V)

In order to guarantee the operation of the CPU (CX80xx module) and the terminal strand in all cases, the power supply must supply 2.0 A at 24 V.

LED

If the power supply unit is connected correctly and the power supply is switched on, the two upper LEDs in the terminal prism are green. The left LED (Us) indicates the CPU supply. The right LED (Up) indicates the terminal supply. The other LEDs indicate the Terminal Bus status. A detailed description of the LEDs can be found in section “LED troubleshooting”.

Power contact PE

CAUTION 		Power contact PE
The PE power contact must not be used for other potentials.


CX80xx, EK9xxx - Ethernet connections

BECKHOFF CX80xx, EK9xxx: Ethernet

Ethernet connections

Assignment of the RJ45 interface, port 1

X001

PIN | Signal | Description
1 | TD + | Transmit +
2 | TD - | Transmit -
3 | RD + | Receive +
4 | connected | reserved
5
6 | RD - | Receive -
7 | connected | reserved
8

Assignment of the RJ45 interface, port 2 (switched)

CX8010, CX809x: X101 / 102
EK9xxx: X001 / X002

PIN | Signal | Description
1 | TD + | Transmit +
2 | TD - | Transmit -
3 | RD + | Receive +
4 | connected | reserved
5
6 | RD - | Receive -
7 | connected | reserved
8


Ethernet Cable

Transmission standards

10Base5

The transmission medium for 10Base5 consists of a thick coaxial cable ("yellow cable") with a max. transmission speed of 10 MBaud arranged in a line topology with branches (drops) each of which is connected to one network device. Because all the devices are in this case connected to a common transmission medium, it is inevitable that collisions occur often in 10Base5.

10Base2

10Base2 (Cheapernet) is a further development of 10Base5, and has the advantage that the coaxial cable is cheaper and, being more flexible, is easier to lay. It is possible for several devices to be connected to one 10Base2 cable. It is frequent for branches from a 10Base5 backbone to be implemented in 10Base2.

10BaseT

Describes a twisted pair cable for 10 MBaud. The network here is constructed as a star. It is no longer the case that every device is attached to the same medium. This means that a broken cable no longer results in failure of the entire network. The use of switches as star couplers enables collisions to be reduced. Using full-duplex connections they can even be entirely avoided.

100BaseT

Twisted pair cable for 100 MBaud. It is necessary to use a higher cable quality and to employ appropriate hubs or switches in order to achieve the higher data rate.

10BaseF

The 10BaseF standard describes several optical fiber versions.

Short description of the 10BaseT and 100BaseT cable types

Twisted pair copper cable for star topologies, where the distance between two devices may not exceed 100 meters.

UTP

Unshielded twisted pair
This type of cable belongs to category 3, and is not recommended for use in an industrial environment.

S/UTP

Screened/unshielded twisted pair (screened with copper braid)
Has a general screen of copper braid to reduce influence of external interference. This cable is recommended for use with Bus Couplers.

FTP

Foiled shielded twisted pair (screened with aluminum foil)
This cable has an outer screen of laminated aluminum and plastic foil.

S/FTP

Screened/foiled-shielded twisted pair (screened with copper braid and aluminum foil)
Has a laminated aluminum screen with a copper braid on top. Such cables can provide up to 70 dB reduction in interference power.

STP

Shielded twisted pair
Describes a cable with an outer screen, without defining the nature of the screen any more closely.

S/STP

Screened/shielded twisted pair (wires are individually screened)
This identification refers to a cable with a screen for each of the two wires as well as an outer shield.

ITP

Industrial Twisted-Pair
The structure is similar to that of S/STP, but, in contrast to S/STP, it has only one pair of conductors.


CX80xx - Changing the battery

BECKHOFF CX80xx: Mounting and wiring

Changing the battery

The battery of the CX80xx is required for the real-time clock (RTC) of the CX80xx. It ensures that the RTC continues to run in the power-off state so that the set time is available again on restarting.

  • Step 1: Open the flap
  • Step 2/3: Take a small flat-blade screwdriver, insert it above the battery and prize the battery carefully out of the device
  • Step 4: Insert the new battery. The plus pole must be on the left
  • Step 5: Close the flap again
Battery type | Technical data
Duracell 303/357 SR44 | 1,5 V / 165 mAh

Note 		Battery maintenance

The battery must be replaced every 5 years.

Spare batteries can be ordered from Beckhoff Service.

Attention 		An incorrectly inserted battery may explode!

Use exclusively the specified battery type.

Make absolutely sure that positive and negative terminals of the battery are inserted correctly. (plus pole on the left)

Never open the battery or throw it into a fire.

The battery cannot be recharged.


CX8090 - DIP switch

BECKHOFF CX8090: Parameterization and commissioning

DIP switch

10-pole DIP switch S101

The DIP switch has only one meaning for the Ethernet interfaces X101 and X102 which are switched.

Left off “0”, right on “1”.

DIP switch S101 | Meaning
10 on and 9 off | DHCP active
10 off and 9 off | Fixed IP address 192.168.1.xxx; xxx stands for DIP switches 1 to 8, subnet mask is 255.255.255.0. The “basic IP address” can be modified in the operating system. The last byte of the IP address is then specified once again by the DIP switches.
10 off and 9 off DIP 1 to 8 all on | The complete IP address is taken from the operating system.

2-pole DIP switch (under the flap between the battery and the SD card slot)

DIP switch (red) | Meaning
1 off and 2 off | normal mode, TwinCAT is started
1 on and 2 off | The CX mode starts in Config Mode; the flash memory or, in the case of the CX80xx the SD card, is reachable via the USB interface (for example for an image update).
1 off and 2 on | Restore the registry
1 on and 2 on | No function so far


CX8090/8091 - IP address

BECKHOFF CX8090/CX8091: Parameterization and commissioning

IP address

The CX8090/CX8091 has two Ethernet interfaces that are visible to the operating system - X001 and X101/102.

X001

IP addressing via the operating system; default is DHCP (represented in the operating system as FEC1)

X101/102

IP addressing via the DIP switches (represented in the operating system as TCCCATMP1)

EtherCAT interface

The EtherCAT interface is a further Ethernet interface that is not visible in the operating system for the IP addressing.


CX8090 – Setting the address via DHCP server

BECKHOFF CX8090: Parameterization and commissioning

Setting the address via DHCP server

Port 1 (X001) is set to DHCP by default.

Port 2 (X101 and X102) is to be configured by DIP switch (see DIP switch)

If DHCP is switched on, the CX is automatically assigned an IP address by the DHCP server. The DHCP server must know the MAC ID of the Bus Terminal Controller for this. The IP address should be assigned statically by the DHCP server. A local IP address is used if no DHCP server is reachable.

The DNS name is formed from the type and the last 3 byte of the MAC ID. The MAC ID is given on the production label of the Bus Terminal Controller.

CX8090 example
  • MAC ID: 00-01-05-01-02-03
  • DNS name: CX-010203


CX80xx - Subnet mask

BECKHOFF CX80xx : Parameterizing and comissioning

Subnet mask

The subnet mask is subject to the control of the network administrator, and specifies the structure of the subnet.

Small networks without a router do not require a subnet mask. The same is true if you do not use registered IP numbers. A subnet mask can be used to subdivide the network with the aid of the mask instead of using a large number of network numbers.

The subnet mask is a 32-bit number:

  • Ones in the mask indicate the subnet part of an address space.
  • Zeros indicate that part of the address space which is available for the host IDs.
Description | Binary representation | Decimal representation
IP address | 10101100.00010000.00010001.11001000 | 172.16.17.200
Subnet mask | 11111111.11111111.00010100.00000000 | 255.255.20.0
Network ID | 10101100.00010000.00010000.00000000 | 172.16.16.0
Host ID | 00000000.00000000.00000001.11001000 | 0.0.1.200

Standard subnet mask

Address class | Standard subnet mask (decimal) | Standard subnet mask (hex)
A | 255.0.0.0 | FF.00.00.00
B | 255.255.0.0 | FF.FF.00.00
C | 255.255.255.0 | FF.FF.FF.00

Note 		Assignment of subnets, host numbers and IP addresses

Neither subnet 0 nor the subnet consisting only of ones may be used.

Neither host number 0 nor the host number consisting only of ones may be used!

If the IP address is set using the KS2000 configuration software, it is necessary for the subnet mask also to be changed with the KS2000 configuration software.

If ARP addressing is used, the associated standard subnet mask, based on the IP address, is entered.

Under BootP or DHCP the subnet mask is transmitted also by the server.


CX8090 - CCAT adaptor

BECKHOFF CX8090: Parameterization and commissioning

CCAT adaptor

The CCAT adaptor is the driver for the various interfaces of the CX8090. It is found when scanning the CX8090 and can then be used in connection with the Real-Time Ethernet protocols.

No settings need to be made on the CCAT adaptor and it does not need to be linked with a task. It only needs to be present in the System Manager.

Notice 		Search for protocol or driver
The CCAT adaptor must be selected when searching for the EtherCAT Automation Protocol (EAP) or the driver for the RT-Ethernet communication. See the relevant chapters.


CX80xx - Operating system

The CX80xx comes with a Microsoft CE operating system, version 6.0. This operating system is adapted and optimized for the CX80xx. Not all CE6.0 components are available.

Safety

From image version 3.54b security was tightened. This applies to CERHOST and TELNET. Both services are now switched off in delivery state. To reactivate these services, you need a Micro SD card reader.

CERHOST

CERHOST is deactivated by current images on first start-up via the registry file CeRemoteDisplay_Disable.reg, which is located in the folder RegFiles.

To reactivate CERHOST, delete the file CeRemoteDisplay_Disable.reg from the folder RegFiles and also the folder Documents and Settings.
Then reinsert the Micro SD card in the CX and reboot. The CX creates a new Document and Settings directory and then reboots automatically.
The CX is then accessible again via CERHOST.

TELNET

TELNET is deactivated by current images on first start-up via the registry file Telnet_Disable.reg, which is located in the folder RegFiles.

To reactivate TELNET, delete the file Telnet_Disable.reg from the folder RegFiles and also the folder Documents and Settings.
Then reinsert the Micro SD card in the CX and reboot. The CX creates a new Document and Settings directory and then reboots automatically.
The CX is then accessible again via TELNET.

IMAGE

If you do not know what image is loaded on the CX80xx, you can determine it quite easily.

  • Via the web diagnostics page of the CX. Here you can find the build number under the TwinCAT device.
    Opening the web diagnostics page:
    - IP address</config
    or
    - CX name/config
    Example:
    - 172.16.17.201/config
    or
    - CX-01551E/config
  • Via a Micro SD card reader.
    The Micro SD card contains a file with the name of the image.
    Example CX8000_CE600_LF_v354b_TC211R3_B2248.
    TC211R3_2248 indicates the TwinCAT build; in the example the build is 2248.
Feature / platform | CX80x0 LF version 3.xx
ATL | Xtd
MFC | X
XML DOM | X
COM | X
COM Storage | -
Winsock | X
TCP/IP | X
TCP/IPv6 | -
Firewall | X
Network Utilities (IpConfig, Ping, Route) | X
UPnP |
Control Point | -
Device Host | X
SOAP |
Client | -
Server | -
DCOM | -
Object Exchange Protocol OBEX | -
Message Queuing MSMQ | -
Server |
File Server (SMB/CIFS) | X
File Server | X
Print-Server (SMB/CIFS) | -
RAS Server / PPTP Server | -
Simple Network Management Protocol (SNMP) | X
Telnet Server | X
HTTP / ASP / FTP / SNTP -Server | X
Web Server (HTTPD) / Active Server Pages (ASP) Support / JScript 5.6 / VBScript 5.6 | X
Simple Network Time Protocol (SNTP) | X
HTML / DHTML, TLS, ISAPI extensions | X
Internet Explorer 6.0 | -
Java Applets | -
NET Compact Framework | v3.5
RDP Client (Remote Desktop protocol) | -
CAB File Installer/Uninstaller | X
TwinCAT (Level PLC) | X
USB support | X
Printer, storage on Compact Flash, for example | -
HID (Human interface devices) | -
Touch | -


CX80xx - K-Bus interface

BECKHOFF CX80xx: Parameterization and commissioning

K-Bus interface

It is possible to operate K-Bus terminals on the CX80xx.

The CX80xx recognizes these terminals automatically on scanning, reads out the terminal types and automatically places them in the System Manager.

Fig. K-Bus interface

K-Bus state

The K-Bus status is saved in the state byte (see fig. K-bus interface “1”). If the value is 0 the K-Bus is operating synchronously and without errors. If the value should be <>0 this can be an error, but it may also be just a notice that, for example, the K-bus requires longer than the employed task and is thus no longer synchronous to the task. The task time should be faster than 100 ms. We recommend a task time of less than 50 ms. The K-Bus update time typically lies between one and five ms.

Bit 0 = K-Bus Err
Bit 1 = Terminal State Err
Bit 2 = Process Data Length Err
Bit 8 = No valid Inputs
Bit 9 = K-Bus Input Update busy
Bit 10 = K-Bus Output Update busy
Bit 11 = Watchdog Err
Bit 15 = Acyc. Function active (e.g. K-Bus Reset)

If there is a K-bus error, this can be reset via the IOF_DeviceReset function block (in the TcIoFunctions.lib).

The NetID is that of the CX80xx and can thus be entered as an empty string, the Device ID (see fig. K-bus Interface “2”) is to be taken from the System Manager.


CX80xx - E-Bus interface

The operation of E-Bus terminals and EtherCAT devices is possible on the CX80xx.

The CX80xx recognizes these terminals automatically on scanning, reads out the terminal types and automatically places them in the System Manager.

Hinweis 		DC Distributed-Clocks
The CX80xx series is not suitable for the use of EtherCAT slaves that need the distributed clock functionality.


CX8091 - BACnet/IP

BECKHOFF CX8091: Parameterisation and commissioning

BACnet/IP

The BACnet/IP supplement is already installed on the CX8091 in delivery state. No further installation or key input is required.
Further information on BACnet/IP can be found in the supplement description (see TS8020).

The BACnet/IP supplement can be used via Ethernet port X101/102. Port X001 cannot be used for BACnet/IP.

Note 		Deactivating the OPC UA supplement
If the BACnet supplement is used, the OPC UA driver must be disabled. To this end the file TcOpcUaSrv.exe in the System folder has to be renamed or deleted. A reboot of the CX8091 is then required.

Note 		Memory usage
Check whether the memory (RAM) is adequate for your application. Trend log objects can use up all the available memory.
We recommend using a maximum of 250 BACnet objects. The actual maximum number may be higher or lower.
This depends on the CPU and memory load (RAM) of the CX8091 and the BACnet objects used, and perhaps other factors.

Note 		Recommendations regarding performance
  • On the CX8091 no other supplements such as ModbusTCP or TCP/IP server should be used. These are not installed on the CX8091 in delivery state.
  • The simultaneous use of the OPC UA driver is not recommended.
  • Do not install additional software from other manufacturers (third-party) on the CX8091.
  • If it is not possible to follow these recommendations regarding performance, it may be advisable to use a CX with a larger CPU and more memory (RAM) than the CX8091.


CX8091 - OPC UA

BECKHOFF CX8091: Parameterisation and commissioning

OPC UA

The OPC UA supplement is already installed on the CX8091 in delivery state. No further installation is required. Further information on OPC UA can be found in the supplement description (see TS6100-0030). The OPC UA supplement can be used via Ethernet port X001 or via port X101/102.

Note 		Memory usage
Check whether the memory (RAM) is adequate for your application. The Historical Access function may use up all the available memory.
We recommend a maximum of 500 variables.
The sampling rate for 500 variables is typically less than one second (at approx. 35% CPU load), although it may be higher.
It depends on the CPU load of system, amongst other factors.

Note 		Recommendations regarding performance
  • On the CX8091 no other supplements such as ModbusTCP or TCP/IP server should be used. These are not installed on the CX8091 in delivery state.
  • It is not advisable to use the BACnet/IP driver at the same time. The BACnet driver is only started if it is configured in the System Manager.
  • Do not install additional software from other manufacturers (third-party) on the CX8091.
  • If it is not possible to follow these recommendations regarding performance, it may be advisable to use a CX with a larger CPU and more memory (RAM) than the CX8091.


CX80xx - Upnp web pages

BECKHOFF CX80xx: Web services

Upnp web pages

There is a Upnp webpage on the CX80xx for diagnosis.

User name: guest
Password: 1

Enter the IP address or the device name.

Example

http://cx-0f94ac/config

http://172.16.17.55/config

The diagnostic page has been revised from v354c Image.


CX80xx - Web visualization

BECKHOFF CX80xx: Web services

Web visualization

There is a web visualization on the CX80xx. This can be prepared and activated with the help of the PLC Control in TwinCAT.

Fig. 1: activation of the web visualization in the PLC Control

The call is made via the IP address or the device name in a web browser.
Further information can be taken from the documentation on the web visualization (see TwinCAT Supplements PLC HMI Web).

Example

http://cx-0f94ac/TcWebVisu/

http://172.16.17.44/TcWebVisu/

Ascertain before logging in (i.e. in the logged out condition) whether a ADS connection is established to the CX – “TwinCAT Running” in the bottom right-hand corner must be green. If that is not the case, please go onto Online /Selection again and call the CX once again.

The following path must be specified for downloading the web data for the web user interface:

\hard disk\twincat\boot\webvisu\

If that is not the case, the PLC Control will copy the data into the wrong folder and the webpage will be displayed incorrectly or not at all.

Fig. 2: path specification


CX80xx - Remote Display

BECKHOFF CX80xx: Web services

Remote Display

This page describes the steps for remotely controlling a CE device with CE operating system from a further PC by ‘Remote Display’.

Requirements

Software required on the PC:

  • Windows NT, Windows 2000, Windows XP or Windows 7
  • Microsoft Remote Display (CERHOST, available licence-free from Microsoft)

Establishing the connection

The “Remote Display” tool is started on the PC. The address of the CE device can now be entered under the menu option “File - > Connect”; this can be both the TCP-IP address or, if available, also the name of the CE device.

If the CE device is provided with password protection, then the password must also be entered accordingly. No password is set in the delivery condition.

After entering the target address, the user interface of the CE device is available for remote control on the PC.

CERHOST download:


CX80xx - Real Time Clock (RTC)

BECKHOFF CX80xx: Parameterization and commissioning

Real Time Clock (RTC)

The RTC is read out via the FB_LocalSystemTime function blocks and can be set with the NT_SetLocalTime block (see TcUtilities.lib).

The RTC is supplied by the battery and can thus continue to run in the power-off state.


CX80xx -1 Second UPS

BECKHOFF CX80xx: Parameterization and commissioning

1-second UPS (Uninterruptible Power Supply

Technical concept

The 1-second UPS is an UltraCap capacitor, which, in the event of a voltage outage, continues to supply power to the processor for approx. 4 to 5 seconds, so that persistent data can be saved. Data saving generally takes less than 4 to 5 seconds. However, due to ageing of the components used, one should assume that the UPS can provide power for a maximum of 1 second. You can assume that data saving continues to work smoothly, even after many years. If you save data yourself, we recommend that this should take place within 1 second. Should it take longer, we would advise against it.

The 1-second UPS supplies neither the K-bus nor the E-bus with power. Please note that the data of these devices may already be invalid when the 1-second UPS is activated. Also, the fieldbus system (or Ethernet) may not work or not work properly once the 1-second UPS was activated.

Saving of the persistent data only takes place in conjunction with the function block FB_S_UPS_CX80xx. This block must be called cyclically. We strongly recommend using the default values for the block.

Saving and loading persistent data

The persistent data are stored on the SD card as a wdp file. When the PLC starts up, the wdp file is loaded from the SD card, saved there as a wd~-file (backup), and then deleted. Another current wpd file is not written until the system is shut down or the 1-second UPS is activated. If no wdp file is present when the CX starts up, the persistent data are invalid and are deleted (default setting).
The reason is that the 1-second UPS was activated before the TwinCAT PLC was started during startup of the CX. In this case no persistent data were saved, since the system was unable to ensure sufficient buffer time for saving the data.

Loading a backup of the persistent data

To load the persistent data from the backup (wp~-file), it has to be enabled in the System Manager.

Or via the following registry entry:

[HKEY_LOCAL_MACHINE\SOFTWARE\Beckhoff\TwinCAT\Plc]"ClearInvalidPersistentData"= 0

The default factory setting is "1".

Checking whether current persistent data (from wdp file) or saved persistent data from the backup (wd~-file) were loaded

In this example, the CX8090 indicates via the ERR LED whether the persistent data were loaded. The LED cannot be used for other CX8xxx models.

IF systeminfo.bootDataFlags.4 AND NOT systeminfo.bootDataFlags.5 THEN
F_CX8090_LED_ERR(eLED_GREEN_ON); (* persistent data is OK *)
ELSIF systeminfo.bootDataFlags.4 AND systeminfo.bootDataFlags.5 THEN
F_CX8090_LED_ERR(eLED_RED_ON); (* load backup persistent data *)
ELSE
F_CX8090_LED_ERR(eLED_RED_FLASHING_200ms); (* no persistent data *)
END_IF

Note 		Purpose of the 1-second UPS
The 1-second UPS should only be used for managing the persistent data.
Other applications are not supported and are not covered by our complaints procedure.

Retain data cannot be used for the 1-second UPS!


CX8090 - CPU load

BECKHOFF CX8090: Parameterization and commissioning

CPU load

By default the CPU load display is deactivated on all CX80xx devices (this is displayed with a constant 10 %). The CPU load display is deactivated, since this accounts for a considerable portion of the CPU load itself. The CPU load can be activated for brief diagnostic help; however, we recommend that you deactivate it again after the diagnosis.

HKEY_LOCAL_MACHINE/SOFTWARE/BECKHOFF/TWINCAT/RTime/EnableRTimeMeasurement 0 deactivated, 1 activated

A software reset of the CX80xx is necessary after making the setting.

Notice 		CPU load
The CPU load is calculated internally with 10 ms.
If one or more tasks exceeding 10 ms are used, the CPU load may fluctuate very strongly.


Library for CX80xx

Library download


CX80xx - FUNCTION_BLOCK FB_S_UPS_CX80xx

BECKHOFF CX80xx: Programming

FUNCTION_BLOCK FB_S_UPS_CX80xx

The FB_S_UPS function block can be used on the CX80xx with the seconds UPS in order to activate the seconds UPS from the PLC. This allows the persistent data to be saved and a quick shutdown to be performed in the event of a power failure. If possible the default values of the INPUTs of the FB_S_UPS should be retained.

Attention 		Loss of data
The seconds UPS can be used only for a few seconds in the event of a power failure in order, for example, to save persistent data. The data must be saved in the fast persistent mode “SPDM_2PASS”, even though this can lead to real-time violations. Sufficient router memory must be configured for the storage of the persistent data!

The second UPS does not have sufficient capacity for bridging power failures. Saving can take place only on Micro SD cards.

A QuickShutdown is performed automatically in the eSUPS_WrPersistData_Shutdown mode (standard setting) after the storage of the persistent data.

In the eSUPS_WrPersistData_NoShutdown mode only the persistent data are saved, no QuickShutdown is performed.

In the eSUPS_ImmediateShutdown mode a QuickShutdown is executed immediately without saving data.

In the eSUPS_CheckPowerStatus mode only a check is performed as to whether a power failure has occurred. If this is the case, the module only switches back to the PowerOK state after the expiry of tRecoverTime (10s).

Independent of the mode and thus independent of the saving or the shutting down of the controller, the UPS switches the main board off after the capacitors have discharged, even if the voltage has returned in the meantime.

Attention 		Caution when using files:
If other applications or the PLC keep other files open or write to them, this can lead to faulty files if the UPS switches off the controller.

FUNCTION_BLOCK FB_S_UPS_CX80xx

VAR_INPUT

VAR_INPUT
    sNetID          : T_AmsNetId := '';               (* '' = local netid *)
    iPLCPort        : UINT := AMSPORT_R0_PLC_RTS1;    (* PLC Runtime System for writing persistent data *)
    iUPSPort        : UINT := 16#4A8;                 (* Port for reading Power State of UPS, dafault 16#4A8 *)
    tTimeout        : TIME := DEFAULT_ADS_TIMEOUT;    (* ADS Timeout *)
    eUpsMode        : E_S_UPS_Mode := eSUPS_WrPersistData_Shutdown; (* UPS mode (w/wo writing persistent data, w/wo shutdown) *)
    ePersistentMode : E_PersistentMode := SPDM_2PASS; (* mode for writing persistent data *)
    tRecoverTime    : TIME := T#10s;                  (* ON time to recover from short power failure in mode eSUPS_WrPersistData_NoShutdown/eSUPS_CheckPowerStatus *)
END_VAR

sNetID : AmsNetID of the controller.

iPLCPort : Port number of the PLC runtime system (AMSPORT_R0_PLC_RTS1 = 801, AMSPORT_R0_PLC_RTS2 = 811, AMSPORT_R0_PLC_RTS3 = 821, AMSPORT_R0_PLC_RTS4 = 831).

iUPSPort : Port number via which the UPS status is read (standard value is 16#4A8).

tTimeout : Timeout for the execution of the QuickShutdown.

eUpsMode : The eUpsMode defines whether persistent data are to be written and whether a QuickShutdown is to be performed.
Standard value is eSUPS_WrPersistData_Shutdown, i.e. with writing of the persistent data and then QuickShutdown. See E_S_UPS_Mode.

ePersistentMode : Mode for the writing of the persistent data. Standard value is SPDM_2PASS.
SPDM_2PASS, all persistent data are saved at once, which can lead to the cycle time being exceeded.
SPDM_VAR_BOOST, here, each persistent variable is written separately; if there is a large amount of persistent data this can accordingly take many cycles. This is not recommended as some data may be lost if the time of the seconds UPS is not sufficient.

tRecoverTime : Time after which the UPS reverts to the PowerOK status in the case of UPS modes without shutdown.
The tRecoverTime must be somewhat longer than the maximum holding time of the UPS, since the UPS switches off even when the voltage returns.

VAR_OUTPUT

VAR_OUTPUT
    bPowerFailDetect	: BOOL;            (* TRUE while powerfailure is detected *)
    eState 		: E_S_UPS_State;   (* current ups state *)
END_VAR

bPowerFailDetect : True during the power failure; False if the supply voltage is present.

eState : Internal state of the function block, for values see E_S_UPS_State.

VAR_GLOBAL

VAR_GLOBAL
    eGlobalSUpsState : E_S_UPS_State;    (* current ups state *)
END_VAR

eGlobalUpsState : Internal state of the function block as a global copy of the VAR_OUTPUT eState; for values see E_S_UPS_State.

Development environment | Target platform | Hardware | PLC libraries to be linked
TwinCAT v2.11.0 build 2220 or higher (R3) | ARM | Seconds UPS | -


CX80xx - TYPE E_S_UPS_Mode

BECKHOFF CX80xx: Programming

TYPE E_S_UPS_Mode

eSUPS_WrPersistData_Shutdown:   write persistent data and then QuickShutdown
eSUPS_WrPersistData_NoShutdown: write persistent data only (no QuickShutdown)
eSUPS_ImmediateShutdown:        QuickShutdown only (no writing of persistent data)
eSUPS_CheckPowerStatus:         determine status only (neither write persistent data nor QuickShutdown)

Development environment | Target platform | Hardware | PLC libraries to be linked
TwinCAT v2.11.0 build 2220 or higher (R3) | ARM | Seconds UPS | -


CX80xx - TYPE E_S_UPS_State

BECKHOFF CX80xx: Programming

TYPE E_S_UPS_State

eSUPS_PowerOK:
    in all modes: supply voltage is OK

eSUPS_PowerFailure:
    in all modes: Supply voltage faulty (applied for one cycle only)

eSUPS_WritePersistentData:
    in eSUPS_WrPersistData_Shutdown mode: writing of the persistent data is active
    in eSUPS_WrPersistData_NoShutdown mode: writing of the persistent data is active

eSUPS_QuickShutdown:
    in eSUPS_WrPersistData_Shutdown mode: QuickShutdown is active
    in eSUPS_ImmediateShutdown mode: QuickShutdown is active

eSUPS_WaitForRecover:
    in eSUPS_WrPersistData_NoShutdown mode: wait for return of the voltage
    in eSUPS_CheckPowerStatus mode: wait for return of the voltage

eSUPS_WaitForPowerOFF:
    in eSUPS_WrPersistData_Shutdown mode: wait for shutdown by the UPS
    in eSUPS_ImmediateShutdown mode: wait for shutdown by the UPS

Development environment | Target platform | Hardware | PLC libraries to be linked
TwinCAT v2.11.0 build 2220 or higher (R3) | ARM | Seconds UPS | -


CX8090 - FUNCTION F_CX8090_LED_WD

BECKHOFF CX8080, CX8090, CX8091: Programming

FUNCTION F_CX8090_LED_WD (WD=Watchdog)

Since the CX8080, CX8090 and CX8091 supports different protocols, the two LEDs on the CX8080/CX809x are not used by the firmware. Hence, the user has the possibility to generate diagnostic messages himself, which must then also be documented for the end customer so that he can also interpret these messages. For example, you can use the LEDs to display whether the DHCP server has assigned an IP address to the CX8080/CX809xor, if you are using the RT-Ethernet with bus couplers such as the BK9000, you can display whether all BK9000s are in data exchange. Possible colors are red and green.

The F_CX8090_LED_WD function uses the WD LED on the CX8080/CX809x. Various colors and flash modes can be used here.

VAR_INPUT

VAR_INPUT
    eMode          : E_CX8090_LED;
END_VAR

eMode : way in which the LED lights up.

VAR_OUTPUT

F_CX8090_LED_WD		: INT;

F_CX8090_LED_WD : -1, non-implemented flash code, 0 OK

Development environment | Target platform | Hardware | PLC libraries to be linked
TwinCAT v2.11.0 build 2220 or higher (R3) | ARM | CX8080, CX8090, CX8091 | -


CX8090 - FUNCTION_CX8090_LED_ERR

BECKHOFF CX8080, CX8090, CX8091: Programming

FUNCTION F_CX8090_LED_ERR

Since the CX8080, CX8090 and CX8091 supports different protocols, the two LEDs on the CX8080/CX809x are not used by the firmware. Hence, the user has the possibility to generate diagnostic messages himself, which must then also be documented for the end customer so that he can also interpret these messages. For example, you can use the LEDs to display whether the DHCP server has assigned an IP address to the CX8080/CX809x or, if you are using the RT-Ethernet with bus couplers such as the BK9000, you can display whether all BK9000s are in data exchange. Possible colors are red and green.

The F_CX8090_LED_ERR function uses the ERR LED on the CX8080/CX809x. Various colors and flash modes can be used here.

VAR_INPUT

VAR_INPUT
    eMode          : E_CX8090_LED;
END_VAR

eMode : way in which the LED lights up.

VAR_OUTPUT

F_CX8090_LED_ERR		: INT;

F_CX8090_LED_ERR : -1, non-implemented flash code, 0 OK

Development environment | Target platform | Hardware | PLC libraries to be linked
TwinCAT v2.11.0 build 2220 or higher (R3) | ARM | CX8080,CX8090, CX8091 | -


TYPE E_S_UPS_State

CX8000 - Programmierung

TYPE E_CX8090_LED

TYPE E_CX8090_LED : (
    eLED_GREEN_OFF,
    eLED_GREEN_ON,
    eLED_GREEN_FLASHING_Quick,
    eLED_GREEN_FLASHING_200ms,
    eLED_GREEN_FLASHING_500ms,
    eLED_GREEN_FLASHING_Pulse,
    eLED_RED_OFF:=20,
    eLED_RED_ON,
    eLED_RED_FLASHING_Quick,
    eLED_RED_FLASHING_200ms,
    eLED_RED_FLASHING_500ms,
    eLED_RED_FLASHING_Pulse,
    eLED_GREEN_RED_OFF:=100,
    eLED_GREEN_RED_FLASHING_200ms,
    eLED_GREEN_RED_FLASHING_500ms
);
END_TYPE


CX80xx - FUNCTION_CX80xx_ADDRESS

BECKHOFF CX80xx: Programming

FUNCTION F_CX80xx_ADDRESS

With this function the address selection switch or the DIP switch of the CX80xx device can be read out. Here, for example, you can activate different parts of the program depending on the address by reading the switch position.

VAR_INPUT

VAR_INPUT
    iCX_Typ          : INT;
END_VAR

iCX_Typ : The CX type used is entered here - just the number without the designation CX: for example, CX8031 is then entered as 8031.

VAR_OUTPUT

F_CX80xx_ADDRESS		: INT;

F_CX80xx_ADDRESS : -1, non-implemented CX, address of the switch

Development environment | Target platform | Hardware | PLC libraries to be linked
TwinCAT v2.11.0 build 2220 or higher (R3) | ARM | CX80xx | -


Ethernet

Ethernet was originally developed by DEC, Intel and XEROX (as the DIX standard) for passing data between office devices. The term nowadays generally refers to the IEEE 802.3 CSMA/CD specification, published in 1985. Because of the high acceptance around the world this technology is available everywhere and is very economical. This means that it is easy to make connections to existing networks.

There are now a number of quite different transmission media: coaxial cable (10Base5), optical fiber (10BaseF) or twisted pairs (10BaseT) with screen (STP) or without screen (UTP). A variety of topologies such as ring, line or star can be constructed with Ethernet.

Ethernet transmits Ethernet packets from a sender to one or more receivers. This transmission takes place without acknowledgement, and without the repetition of lost packets. To achieve reliable data communication, there are protocols, such as TCP/IP, that can run on top of Ethernet.

MAC-ID

The sender and receiver of Ethernet packets are addressed by means of the MAC-ID. The MAC-ID is a 6 byte identification code unique to every Ethernet device in the world. The MAC-ID consists of two parts. The first part (i.e. the first 3 bytes) is a manufacturer identifier. The identifier for Beckhoff is 00 01 05. The next 3 bytes are assigned by the manufacturer and implement a unique serial number. The MAC-ID can, for example, be used for the BootP protocol in order to set the TCP/IP number. This involves sending a telegram containing the information such as the name or the TCP/IP number to the corresponding node. You can read the MAC-ID with the KS2000 configuration software.

The Internet Protocol (IP)

The internet protocol (IP) forms the basis of this data communication. IP transports data packets from one device to another; the devices can be in the same network, or in different networks. IP here looks after the address management (finding and assigning MAC-IDs), segmentation and routing. Like the Ethernet protocol, IP does not guarantee that the data is transported - data packets can be lost, or their sequence can be changed.

TCP/IP was developed to provide standardized, reliable data exchange between any number of different networks. TCP/IP is thus substantially independent of the hardware or software being used. Although the term is often used as if it were a single concept, a number of protocols are layered together: e.g. IP, TCP, UDP, ARP and ICMP.

Transmission Control Protocol (TCP)

The Transmission Control Protocol (TCP) which runs on top of IP is a connection-oriented transport protocol. It includes error detection and error handling mechanisms. Lost telegrams are repeated.

User Datagram Protocol (UDP)

UDP is connectionless transport protocol. It provides no control mechanism when exchanging data between sender and receiver. This results in a higher processing speed than, for example, TCP. Checking whether or not the telegram has arrived must be carried out by the higher-level protocol.

Protocols running on top of TCP/IP and UDP/IP

The following protocols can run on top of TCP/IP or UDP:

  • ADS
  • ModbusTCP

Both of these protocols are implemented in parallel on the Bus Coupler, so that no configuration is needed to activate the protocols.

ADS can be used on top of either TCP or UDP, but ModbusTCP is always based on TCP/IP.


CX8091 - Topology example

BECKHOFF CX8091: Ethernet

Topology example

CX8091 - Structure of an Ethernet line

Note 		Number of devices in a line
The number of devices in a line should not exceed 20.
Please note that the Ethernet system data volume and load are highest at the start of the line.

The line should not contain further Ethernet switches or subroutes.


CX8091 - BACnet/IP

BECKHOFF CX8091: EtherNet

BACnet/IP

In TwinCAT BACnet/IP, Beckhoff offers a complete product line that is characterized by its high scalability:
Starting from the compact ARM-based controller, the CX8091, which supports up to several hundred data points,
up to the CX5020, on which several thousand data points can be collected and processed centrally,
the devices can be used as BACnet Building Controller (BBC) without restriction.
The DIN rail-mountable Embedded PCs from the CX series integrate an interface for the direct serial connection of the Bus Terminals.

The devices of CX8091, CX9020 and CX50xx series from Beckhoff meet all requirements of the global BACnet standard ISO 16484-5:2012
and thus offer scalable control platforms for cross-vendor building automation covering all building services.

Numerous additional functions have been implemented that extend beyond the requirements for BACnet building controllers.
The integration of the BACnet protocol in the TwinCAT System Manager enables efficient configuration of the Bus Terminals and the BACnet devices with a single tool.
The Automapping function enables comfortable working and shortens the development time.

Extensive additional functions supplement the required interoperability function blocks of the Beckhoff BBC devices.
Support of different string encoding fonts (UTF8, USC2, USC2, ISO8859 ... ) enables TwinCAT BACnet/IP to be used in applications worldwide.
Further functions cover the dynamic creation of BACnet objects, whereby timing diagrams and trend objects among other things can be subsequently created and configured.

Distributed clocks can be synchronized with the aid of the supported Client and Master functions.

BBMD (BACnet Broadcast Management Device) services have been integrated into TwinCAT BACnet/IP for use in widely distributed networks.

The integration of spatially remote and third-party devices is particularly convenient within the framework of the Client functionality. BACnet networks can be searched.

Thanks to support for the EDE format (Engineering Data Exchange), Beckhoff controllers also work in connection with BACnet devices from other manufacturers.

TwinCAT BACnet/IP is rounded off by extensive diagnostic functions.

  • Overview of all certified BACnet devices based on Revision 12
  • BACnet IPC list
  • BACnet certificate
  • AMEV certification [image] (German) [image] (English)

BACnet notes for the CX8091

BACnet and CX8091 First steps


CX8091 - OPC UA

BECKHOFF CX8091: Ethernet

OPC UA

OPC Unified Architecture (IEC 62541) is the new technology generation of the OPC Foundation
for safe, reliable and manufacturer-neutral transport of raw data and pre-processed information
from the production level right into the production planning or ERP system.

With OPC UA, all desired information is available to every authorized application and every authorized person at any time and in any place.

TwinCAT OPC UA Server

  • Certified in the OPC Laboratory, Europe
  • DataAccess/HistoricalAccess functions
  • PLC blocks for diagnosis and restart
  • Intermediate storage of data on the server: interruption of the communication connection does not lead to loss of data


ADS Communication

The ADS protocol (ADS: Automation Device Specification) is a transport layer within the Beckhoff TwinCAT system. It was developed for data exchange between the different software modules, for instance the communication between the NC and the PLC. This protocol offers the freedom of using other tools to communicate with any point in TwinCAT. If it is necessary to communicate with another PC or device, the ADS protocol is used on top of TCP/IP. This means that in a networked system, all the data is accessible from any desired point.

The ADS protocol runs on top of the TCP/IP or UDP/IP protocols. It allows the user within the Beckhoff system to use almost any connecting route to communicate with all the connected devices and to parameterize them. Outside the Beckhoff system a variety of methods are available to exchange data with other software tools.

Software interfaces

ADS-OCX

The ADS-OCX is an Active-X component. It offers a standard interface to, for instance, Visual Basic, Delphi, etc.

ADS-DLL

You can link the ADS-DLL (DLL: Dynamic Link Library) into your C program.

OPC

The OPC interface is a standardised interface for communication used in automation engineering. Beckhoff offer an OPC server for this purpose.


ADS protocol

The ADS functions provide a method for accessing the Bus Coupler information directly from the PC. ADS function blocks can be used in TwinCAT PLC Control for this. The function blocks are contained in the PLCSystem.lib library. It is also equally possible to call the ADS functions from AdsOCX, ADSDLL or OPC.

AMSNetID

The AMSNetID provides a reference to the device that is to be addressed. This is taken from the Mac address of the first Ethernet port (X001) and is printed on the side of the CX80xx. For the AMSNetID the bytes 3 to 6 plus “.1.1” are typically used.
Example:
MAC address 00-01-05-01-02-03
AMSNetID 5.1.2.3.1.1

Port number

The port number distinguishes sub-elements in the connected device.
Port 801: local process data PLC runtime 1

Index group

The index group distinguishes different data within a port.

Index offset

Indicates the offset, the byte from which reading or writing is to start.

Len

Gives the length of the data, in bytes, that is to be read or written.

TCP port number

The TCP port number for the ADS protocol is 48898 or 0xBF02.


CX8090/CX8091 - Diagnostic LEDs

BECKHOFF CX8090/CX8091: Error handling and diagnosis

Diagnostic LEDs

Ethernet interface X001

Interface X001 | Ethernet (CX8090, CX8091) | Meaning
LED green | on | Link present
LED yellow | flashing | Activity

Ethernet interface X101 and X102

Interface X101-102 | Ethernet (CX8090, CX8091) | Meaning
LED green | flashing | Activity
LED yellow | is not used | -

LED coupler

Labelling | Meaning | Colour | Meaning
TC | Displays the TwinCAT mode | red | TwinCAT in Stop
 |  | green | TwinCAT in Running Mode
 |  | Blue | TwinCAT in Config Mode
WD* | no function | - | -
ERR* | Error or Boot Diagnosis LED | red when switching on | Software is being loaded
 |  | off | Everything OK

* The WD and ERR LED can be set and used by function block.

LED power supply terminal

Operation with K-bus terminals Operation with E-bus terminals

Display LED | Description | Meaning
1 Us 24 V (top left, 1st row) | CX80xx supply voltage | connected to -24 V
2 Up 24 V (top right, 1st row) | Power contacts supply voltage | connected to -24 V
3 L/A (left centre, 2nd row) | EtherCAT LED | flashing green: EtherCAT communication active connected to E-bus / no data traffic not connected to E-bus
4 K-BUS RUN (right centre, 2nd row) | K-bus LED RUN | Lights up green: K-bus running, everything OK
6 K-BUS ERR (bottom right, 3rd row) | K-bus LED ERR | Lights up red: K-bus error - see K-bus error code

K-bus error code

Error code | Error code argument | Description | Remedy
Persistent, continuous flashing EMC problems
  • Check power supply for undervoltage or overvoltage peaks
  • Implement EMC measures
  • If a K-Bus error is present, it can be localized by a restart of the coupler (by switching it off and then on again)
3 pulses 0 K-Bus command error - No Bus Terminal inserted
- One of the Bus Terminals is defective; halve the number of Bus Terminals attached and check whether the error is still present with the remaining Bus Terminals. Repeat until the defective Bus Terminal is located.
4 pulses | 0 | K-Bus data error, break behind the Bus Coupler | Check whether the n+1 Bus Terminal is correctly connected; replace if necessary.
n | Break behind Bus Terminal n | Check whether the Bus End Terminal 9010 is connected.
5 pulses | n | K-Bus error in register communication with Bus Terminal n | Exchange the nth bus terminal
6 pulses | 0 | Error at initialization | Exchange Bus Coupler
1 | Internal data error | Perform a hardware reset on the Bus Coupler (switch off and on again)
8 | Internal data error | Perform a hardware reset on the Bus Coupler (switch off and on again)
7 pulses | 0 | Process data length is not correct | Check the configuration and the K-Bus terminals
1..n | K-Bus Reset error | Check the K-Bus terminals


CX8091 - First steps with BACnet/IP

BECKHOFF CX8091: Appendix

First steps with BACnet/IP

The BACnet/IP supplement is already installed on the CX8091. BACnet/IP is only supported via Ethernet ports X101 and X102. The Ethernet port X001 is not used for BACnet applications. It can be used for programming and configuration. However, this is not necessary, since the switched port X101/102 can also be used for these purposes.

For the example you need a PC with TwinCAT R3 build 2241 or higher, a digital input terminal (KL1104), a digital output terminal (KL2114) and a KL9010 end terminal. Connect the terminals to the CX8091. To test BACnet you need a PC with Intel chipset and real-time Ethernet driver installed.

First steps
  1. Disable the OPC UA server (see Deactivating the OPC UA server)
  2. Connect your PC with the CX8091 X101. The IP address is set to DHCP by default (see Address selection switch).
    A local IP address is issued if the CX is operated in a local network without DHCP server. Usually this takes 2 to 3 minutes.
  3. Switch TwinCAT on the PC to Config mode (blue TwinCAT icon) and start the System Manager.
  4. Then use a broadcast search on your programming PC to find the CX. In the System Manager, click on the PC symbol (Choose Target System) or press >F8<

  5. The following dialog box opens; click on Search (Ethernet).

  6. Select option 1 if DHCP was used for addressing or option 2 if the IP address was not allocated by the DHCP server.
    Then click on Broadcast Search.

    Your network is scanned for Beckhoff controllers. If none is found, this means that the DHCP of the controller is not yet completed or the network settings on your PC are incorrect. Another reason may be a disconnected network cable.
  7. By default the host name made up of "CX-" and the last 4 bytes of the MAC address. You can find the MAC address on the side of the CX80xx. The MAC address is always 6 bytes long and the first three bytes are the vendor ID, which is always 00 01 05 in the case of Beckhoff devices.

    An X next to connected means that the CX is already known in the system and can be used. To make it known, click in the list on the CX with which you want to connect and then click on Add route. An input mask opens with User name and Password. By default there is no password, simply confirm by clicking on OK. Afterwards the X should appear next to connected.
  8. The CX should now appear in the list of devices. Select it and confirm with OK.
  9. In the bottom right corner of the System Manager check whether the connection is available. The indicator must be blue or green but not yellow.

  10. If the indicator is green, switch the CX to Config mode ([Shift] [F4], or press the blue TC icon in the System Manager).
    The System Manager will now prompt you whether you want to switch to Config mode. Confirm with OK.
  11. The indicator at the bottom right of the System Manager switches to blue. The TC LED of the CX80xx should now also be blue.
  12. Now click on I/O Devices and then on Scan Devices.

  13. A message appears to indicate that not all devices were detected automatically.
  14. Usually the CCAT interface (CX809x) or the corresponding fieldbus interface (other CX80xx devices) is found plus either a K-bus interface or an EtherCAT interface, depending on which terminals are connected to the CX.

    The CCAT interface must be present in the System Manager file and may not be deleted.
    If an error message should appear when scanning, check the revision level of your TwinCAT version and perform an update if necessary.
  15. Click on the BACnet device and add a BACnet server.

  16. Now select the server.
    In the Settings tab then select EtherCAT/K-Bus AutoMapping and press the Map button.
    Confirm the next dialog also with Map
  17. After successful mapping your configuration should have been extended with the BACnet objects corresponding to the terminals.

  18. Now activate the configuration. A PLC program is not necessary.
  19. For the first binary output click on the Online tab and set the PresentValue to active. The digital output should now switch on.

    If not, check the following:
    • The cabling: is the 24 V supply connected to the power contacts?
    • Does the K-bus/E-bus have a fault?
    • Is the CX in Running mode? (TwinCAT icon and/or TC LED on the CX8091 green?)
  20. If your PC has an Ethernet chipset from Intel, you can now operate this PC as a BACnet client, scan the BACnet network, add the CX8091 and control the digital output with the BACnet client. Ensure that you are in the same IP network.


CX8091 - First steps with OPC UA

BECKHOFF CX8091: Appendix

First steps with OPC UA

The OPC UA supplement is already installed on the CX8091. OPC UA can be used via the Ethernet ports X001, X101 and X102.

For the example you need a PC with TwinCAT R3 build 2241 or higher, a digital input terminal (KL1104), a digital output terminal (KL2114) and a KL9010 end terminal for connection to the CX8091.

In principle no terminals are required for the communication with OPC UA. However, the project does use terminals in order to illustrate the functionality.

Download:

Further information and notes for OPC UA in conjunction with CX8091

OPC UA documentation


CX8091 - Deactivating the OPC UA server

BECKHOFF CX8091: Appendix

Deactivating the OPC UA server

In order to save memory we recommend disabling the OPC server when BACnet/IP is used.

Log into the CX with the CERHOST software.

Click on START/Programs/Windows Explorer.

Navigate to the folder Hard Disk/ System.
Here you will find the file TcOpcUaSrv.exe. We recommend renaming this file, for example with a underscore to _TcOpcUaSrv.exe.
Renaming prevents the file being called when the CX8091 starts up.

After renaming the CX has to be restarted. To this end select Start/Suspend. The CX is rebooted.


CX80xx Image Update

BECKHOFF CX80xx: Appendix

Image Update

There are two different possibilities to update the image of the CX80xx.

Notice 		Requirements
  • Please make sure before the update that your CX80xx supports the image that you want to load.
  • When updating the image, please first update all existing files and only then copy the new image.

Always copy all files and directories in order to update a CX80xx.

Update via USB

A USB cable is required for this!

  • Switch off the CX80xx
  • Set red dip switch (under the flap) DIP 1 to ON
  • Switch on the CX
  • Connect the PC with USB
  • Delete all files (we recommend that you backup all files first), no formatting
  • Wait until copying has finished, then remove the USB cable
  • Switch DIP switch 1 to OFF
  • Switch off the CX80xx
  • Switch on the CX80xx; it may take a little longer the first time

Update the MicroSD card

A MicroSD card reader is required for this!

  • Remove the MicroSD card from the switched-off CX device.
  • Insert the MicroSD card into the reader
  • Delete all files (we recommend that you backup all files first), no formatting
  • Load the new image
  • Wait until copying has finished, then remove the MicroSD card
  • Insert the MicroSD card into the SD slot of the switched-off CX again
  • Now switch on the CX again; it may take a little longer the first time


CX80xx - example of Web Visu, IP address and fieldbus LEDs

BECKHOFF CX80xx: Appendix

Example of Web Visualization, IP address and fieldbus LEDs

The attached example shows how the IP address of the CX8090 is read out and how its fieldbus LEDs WD and ERR are used.

Download Zip-File:


CX8091 - Bibliography

BECKHOFF CX8091: Appendix

Bibliography

German books

BACNet

  • BACnet and BACnet/IP
    How does it work?
    by Friedbert Tiersch, Christian Kuhles
    ISBN: 978-3-922420-13-2
  • BACnet
    Building automation 1.12
    by Hans R. Kranz
    ISBN: 978-3-922420-25-5

Web sites

  • http://www.big-eu.org
  • http://www.bacnetinternational.org/
  • https://opcfoundation.org/
  • http://opcf.org


CX8091 - List of abbreviations

BECKHOFF CX8091: Appendix

List of Abbreviations

BACNet

Building Automation and Control Networks

BIBB

BACnet Interoperability Building Block

Client

Is the device that takes on the active role and calls up data from a server.

E-bus

EtherCAT, used in conjunction with the EtherCAT Terminals (ELxxxx).

EtherCAT

EtherCAT (Ethernet for Control Automation Technology) is the Ethernet solution for industrial automation, characterized by outstanding performance and particularly simple handling.

IP20, IP65, IP66, IP67

Protection class (contact, water, dust)

K-bus

Terminal Bus: Internal bus for communication between Bus Coupler and Bus Terminals (KLxxx, KSxxxx, KMxxxx)

OPC UA

OLE for Process Control Unified Architecture

PICS

BACnet Interoperability Building Block

Server

Is the device that makes data available or consumes data from a client. The server is usually passive and waits for requests from the client.

PLC

Programmable logic controller


Support and Service

Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.

Beckhoff's branch offices and representatives

Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!

The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com

You will also find further documentation for Beckhoff components there.

Beckhoff Headquarters

Beckhoff Automation GmbH & Co. KG

Huelshorstweg 20
33415 Verl
Germany

Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support

Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:

  • support
  • design, programming and commissioning of complex automation systems
  • and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service

The Beckhoff Service Center supports you in all matters of after-sales service:

  • on-site service
  • repair service
  • spare parts service
  • hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com


CX8093 – DIP switch

BECKHOFF CX8093: Parameterisation and commissioning

DIP switch

Ten-pole DIP switch S101

The DIP switch has the following meaning for the Ethernet interfaces X101 and X102 which are switched:

Left OFF (0), right ON (1).

DIP 9 DIP 10 Description
DIP 1...8 		Restart behaviour Behaviour with factory settings
OFF (0) OFF (0) Last byte of the IP address via DIP switches 1 to 8
  • PN name from memory
  • IP address via DIP switch 1 to 8
  • PN name becomes empty string
  • IP address via DIP switches
    172.16.17.xxx (xxx DIP switch)
    SNM 255.255.0.0
OFF (0) ON (1) DHCP
DIP switch 1 to 8 set to OFF
  • PN name from memory
  • IP address and SNM via DHCP
  • PN name becomes an empty string
  • IP address and SNM via DHCP
DHCP
DIP switch 1 to 8 set to ON
  • PN name via DIP switch 1 to 8
  • IP address and SNM via DHCP
  • PN name via DIP switch 1 to 8
  • IP address and SNM via DHCP
ON (1) OFF (0) reserved - -
ON (1) ON (1) PROFINET-compliant
DIP switch 1 to 8 set to OFF
  • PN name from memory
  • IP address from memory
  • PN name becomes empty string
  • IP address 0.0.0.0
PROFINET with fixed name
DIP switch 1 to 8 set to ON
  • PN name via
    DIP switch 1 to 8
  • IP address from memory
  • PN name via
    DIP switch 1 to 8
  • IP address 0.0.0.0

Two-pole DIP switch

Located under the flap between the battery and the SD card slot.

DIP switch (red) |  | Meaning
DIP 1 | DIP 2
OFF | OFF | normal mode, coupler is started
ON | OFF | The CX starts in Config Mode; the internal Flash memory can be accessed via the USB interface (for example for an image update).
OFF | ON | Factory setting
ON | ON | reserved


CX8093 – IP addresses

BECKHOFF CX8093: Parameterisation and commissioning

IP addresses

The CX8093 has two Ethernet interfaces that are visible to the operating system - X001 and X101/102.

Notice 		IP addresses
Make sure that the IP address of the PROFINET interface (X101/102) and the IP address of the programming interface (X001) belong to different networks (IP number ranges) (see PROFINET interface).
X001

IP addressing takes place via the operating system; default is DHCP (represented in the operating system as FEC1)

X101/102 (PROFINET interface)

The IP addressing or PROFINET name resolution takes place via the DIP switches (represented in the operating system as TCCCATMP1).
The IP address cannot be registered in the operating system. Hence all other services, apart from PROFINET, are no longer possible via this interface (see PROFINET interface).

EtherCAT interface

The EtherCAT interface is a further Ethernet interface that is not visible in the operating system for the IP addressing.