CX2500-0060 - Embedded PC

BECKHOFF Automation

Hardware documentation

for 2 x Gigabit-Ethernet interface for CX20x0

CX2500-0060

version: 1.1
date: 2013-16-10


Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending

The EtherCAT Technology is covered, including but not limited to the following patent applications and patents:
EP1590927, EP1789857, DE102004044764, DE102007017835
with corresponding applications or registrations in various other countries.

The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.

Copyright

© Beckhoff Automation GmbH, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Safety rules

Consider the following safety instructions and descriptions!
Product specific safety instructions are to be found on the following pages or in the areas mounting, wiring, commissioning etc.

Disclaimer

All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH.

Personnel qualification

This description is only intended for the use of trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.

Description of symbols

The following symbols with a adjoining safety advise or notice are used in this documentation. You have to read the safety advices carefully and adhere them strictly!

DANGER 		Acute risk of injury!
If you do not adhere the safety advise adjoining this symbol, there is immediate danger to life and health of individuals!

WARNING 		Risk of injury!
If you do not adhere the safety advise adjoining this symbol, there is danger to life and health of individuals!

CAUTION 		Hazard to individuals!
If you do not adhere the safety advise adjoining this symbol, there is obvious hazard to individuals!

Attention 		Hazard to devices and environment
If you do not adhere the notice adjoining this symbol, there is obvious hazard to materials and environment.

Note 		Note or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue state

Version | Changes
1.1 | updated technical data
1.0 | updated Version
0.1 | first Version


CX2500-0060 - Technische Daten

BECKHOFF CX2500-0060: Product overview

CX2500-0060 - Technical data

The system interface CX2500-0060 expands a CX20x0 by two further Gigabit-Ethernet interfaces.

Technical data | CX2500-0060
Interfaces | 2 x GBit Ethernet RJ45
Ethernet Controller | Intel 82574l
Power supply | via system bus (via power supply module CX2100-0xxx)
Power consumption | 3 W
Dielectric strength | 500 V (supply / internal electronics)
Dimensions (W x H x D) | 24 mm x 99 mm x 54,5 mm
Weight | approx. 195 g
Operating/storage temperature | -25° C ... +60° C / -40° C ... +85° C
Relative humidity | 95% no condensation
Vibration/shock resistant | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity/emission | conforms to EN 61000-6-2/EN 61000-6-4
Protection class | IP 20

Further Information: www.beckhoff.de/CX2000


CX20x0 - Systemübersicht

BECKHOFF CX2500-00xx: Product overview

System overview

CX2500-00xx System modules

The system modules for the CX2000 family are connected to the CPU on the left-hand side via a multi-pin connector. Internally they are connected via PCI Express. Up to four modules can be connected in any order. The CX2500-0020 audio module has jack plug (5 x 3.5 mm) and cinch plug for digital signals (SPDIF). Up to 7.1 multi-channel audio can be used. Serial interfaces can be added with the modules CX2500-0030 (RS232) and CX2500-0031 (RS422/RS485). The CX2500-0060 module provides two further independent Gbit Ethernet interfaces. The CX2500-0070 module can be used to add up to four further USB 3.0 interfaces.

The expansion modules for the CX2000 family are connected to the CPU on the right-hand side via a multi-pin connector. Up to two CX2550-0010 CFast modules can be connected, so that a total of up to three CFast slots are available.


CX20x0 - Intended use

BECKHOFF CX20x0: Product overview

Intended use

The CX20x0 device series is a modular control system designed for top-hat rail installation. The system is scalable, so that the required modules can be assembled and installed in the control cabinet or terminal box as required.

Only switch the PC off after closing the software

Before the Embedded PC is switched off, the software currently running on it should be stopped properly in order to avoid data loss on the hard disk. Please read the section on “Switching off”.

Switch off all system components and uncouple the Industrial PC from the system if the PC is not used for control purposes, e.g. during a function test. To disconnect first pull the first terminal behind the power supply unit (optional), then pull the connectors of the fieldbus connections.
System components that have been switched off must be secured against being switched on again.

The Embedded PC’s power supply unit must be supplied with 24 VDC.

Attention

Damage to the environment or devices
Do not exchange any parts when under power! The exchange of controller parts when live can lead to short-circuits or overvoltages. These can damage the controller itself and connected peripherals (terminals, monitors, input devices, etc.).

When components are being fitted or removed, the supply voltage must be switched off.

Software knowledge

Attention

System malfunctions
Mandatory software knowledge! Every user must be familiar with any of the functions of the software installed on the PC that he can reach.


Unpacking, installation and transport

The specified storage conditions must be adhered to (see "Technical data").

Dimensions and weight of the individual modules:

Dimensions (W x H x D): 24 mm x 100 mm x 55 mm

Weight: approx. 195 g (system interface)

Unpacking

Proceed as follows to unpack the unit:

  1. Remove packaging.
  2. Do not discard the original packaging. Keep it for transporting the device in the future.
  3. Check the delivery for completeness by comparing it with your order.
  4. Please keep the associated paperwork. It contains important information for handling the unit.
  5. Check the contents for visible shipping damage.
  6. If you notice any shipping damage or inconsistencies between the contents and your order, you should notify Beckhoff Service.

Attention

 Danger of damage to the unit!
During transport in cold conditions, or if the unit is subjected to extreme temperature swings, condensation on and inside the unit must be avoided.

Prior to operation, the unit must be allowed to slowly adjust to room temperature. Should condensation occur, a delay time of approximately 12 hours must be allowed before the unit is switched on.

Installation

The devices are designed for installation in control cabinets.

Shipping and relocation

Despite the robust design of the unit, the components are sensitive to strong vibrations and impacts. During transport, your computer should therefore be protected from excessive mechanical stress. Therefore, please use the original packaging.


CX2500-0060 - Dimensions

BECKHOFF CX2500-0060: Mounting and wiring

Dimensions

The following drawings show the dimensions of the CX2500-0060 interface

Dimensions


CX2500-00x0 - Installation of the system interface

BECKHOFF CX2500-00x0: Mounting and wiring

Attaching the system interface to the CX20x0 system

Opening the PCI Express bus cover

The system interfaces for the CX20x0 system are connected via the internal PCI Express bus, which has a protective cap. The cap can be removed with a screwdriver. To this end insert the screwdriver into the recess in the short side (see diagram) and lever off the cap. The bus connector is then accessible, as shown in the diagram.

Once the bus connector is accessible, the module can be attached on the left-hand side.

The module audibly locks into place.

Further modules can be connected to the system in the same way. Once all modules are connected, the system is placed on the DIN rail as a block. For details please refer to the section on DIN rail mounting.

Notice

Maximum number of system interfaces
Up to four system interfaces can be attached on the left-hand side of the system.


CX20x0 - Installation on the mounting rail

BECKHOFF CX20x0: Mounting and wiring

Installation on the mounting rail

Snapping onto the mounting rail

The CX20x0 can simply be snapped onto the mounting rail. The bar clips are inserted on the top side and underside Then simply position the block on the mounting rail and push it slightly until it engages on the right-hand side. This is indicated by a distinct click. The bars are then engaged again. The engagement of the individual bars is indicated by a distinct click.

Attention 		Avoid damage!
Do not force the module or apply excessive pressure!

Installation position

Attention 		Comply with the permitted installation position and minimum distances!
The maximum ambient temperature for CPU modules mounted on a top-hat rail is 60°C. The orientation in which the device is fitted must be selected in such a way that cooling air can flow vertically through the ventilation holes. The images below show the permitted and two incorrect installation positions.

Mounting must provide a clearance of 30 mm both above and below a CX20x0 device combination to ensure adequate ventilation of the base CPU module and the power supply unit.

Correct installation position

The high performance and the compact design of the CX20x0 systems may result in increased heat generation. The heat is dissipated via a passive ventilation system. This system requires the unit to be mounted correctly. Ventilation openings are located at the top and bottom of the housing. The system therefore has to be installed horizontally. This ensures optimum air flow.

Incorrect installation positions

The CX20x0 system must not be operated vertically on the top-hat rail. A vertical position would lead to insufficient CPU ventilation, since the ventilation openings are located on the top and bottom of the housing. Installation of the system on its side would also lead to inadequate ventilation.


CX2500-0070 - Installation on the mounting rail

BECKHOFF CX2500-0070: Mounting and wiring

Mounting the module lock

Mounting the lock

The CX20x0 controller system is fully modular, i.e. all system interfaces of the system are field-configurable. As a rule the latching of the modules to each other is sufficiently strong. However, it is possible for the controller and its modules to be exposed to vibrations, shocks or impacts. The modules can be securely connected to one another with the aid of bar clips.

The bar clips are inserted on the top side and underside.

If all system interfaces are locked, then the entire assembly can be snapped onto the support rail.

Dismounting the lock

In order to dismantle the assembly it must first be removed from the support rail. Afterwards the bar clips can be removed with the aid of a screwdriver:

Once the bar clips have been raised they can be pulled out. Subsequently, the system interfaces can be separated again.


CX2500-0060 - LAN connections

BECKHOFF CX2500-0060: Product overview

LAN connections

LAN inerface (X600/ X601)

The CX20x0 systems have two independent LAN interfaces. Both ports are able to operate at speeds of 10 / 100 / 1000 Mbit. The LEDs on the left-hand sides of the RJ45 sockets indicate the status of the LAN connection. The upper LED indicates whether the port is connected to a network. If this is the case the LED is green. The LED flashes if data traffic takes place on the port. The lower LED indicates the connection speed. If the speed is 10 Mbit the LED is off. The LED is green if the speed is 100 Mbit. In 1000 Mbit mode (Gigabit) the LED is red.

Configuration of the RJ45 interface, port 1 (X600)

PIN | Signal | Description
1 | TD + | Transmit +
2 | TD - | Transmit -
3 | RD + | Receive +
4 | connected | not used
5
6 | RD - | Receive -
7 | connected | not used
8

Configuration of the RJ45 interface, port 2 (X601)

PIN | Signal | Description
1 | TD + | Transmit +
2 | TD - | Transmit -
3 | RD + | Receive +
4 | connected | not used
5
6 | RD - | Receive -
7 | connected | not used
8


CX20x0: Switching on and off

BECKHOFF CX20x0: Commissioning

Switching on and off

Switching on

The power supply for the basic CPU module comes from the power supply unit. The basic CPU module starts automatically when the power supply unit is connected to the mains.

Switching on for the first time

When you switch on the PC for the first time, the pre-installed operating system (optional) will be started.

Switching off

The Embedded PC switches off when the power supply unit is switched off. The control software typically running on Embedded PCs should be shut down or stopped correctly. A user who may not close software may also not switch the Embedded PC off, since data can be lost from the hard disk by switching off while software is running.

Once the software has been stopped, the operating system can be shut down. Only then should the power supply be interrupted.


CX2500-0060: LEDs des Ethernet-Systemschnittstelle

BECKHOFF CX2500-0060: Error handling and diagnostics

LEDs on the Ethernet system interface

Display | LED | Meaning
 | LINK / ACT 1 | OFF: no connection Green: Port is connected with network. The LED flashes if data traffic takes place on the port.
 | SPEED 1 | OFF: 10 Mbit Mode Green: 100 Mbit Mode Red: 1000 Mbit Mode (green)
 | LINK / ACT 2 | OFF: no connection Green: Port is connected with network. The LED flashes if data traffic takes place on the port.
 | SPEED 2 | OFF: 10 Mbit Mode Green: 100 Mbit Mode Red: 1000 Mbit Mode (green)


CX20x0: Faults

BECKHOFF CX20x0: Error handling and diagnostics

Faults

Please also refer to the Safety instructions section.

Possible faults and their correction

Fault | Cause | Measures
no function after the Embedded PC has been switched on | no power supply for the Embedded PC other causes | 1. Check fuse 2. Measure voltage at connection, check plug wiring Call Beckhoff support
Embedded PC does not boot fully | Hard disk damaged (e.g. due to switching off while software is running), incorrect setup, other causes | Check setup Call Beckhoff support
Computer boots, software starts, but control does not operate correctly | Cause of the fault is either in the software or in parts of the plant outside the Embedded PC | Call the manufacturer of the machine or the software.
CF card access error | Faulty CFast card, faulty CFast slot | Use a different CFast card to check the CFast slot Call Beckhoff support
Embedded PC only works partially or temporarily | Defective components in the Embedded PC | Call Beckhoff support

Please make a note of the following information before contacting Beckhoff service or support:

  1. Precise device ID: CXxxxx-xxxx
  2. Serial number
  3. Hardware version
  4. Any interfaces (N030, N031, B110, ...)
  5. TwinCAT version used
  6. Any components / software used

The quickest response will come from support / service in your country. Therefore please contact your regional contact. For details please refer to our website at www.beckhoff.de or ask your distribution partner.


CX20x0 - Disassembly and disposal

BECKHOFF CX2500: Decommissioning

Disassembly and disposal

A CX20x0 hardware configuration with system interfaces is dismantled in 3 stages:

1. Switching off and disconnecting the power supply

Before a CX20x0 system can be dismantled, the system should be switched off, and the power supply should be disconnected.

2. Removing from the top-hat rail:

Before the individual modules are disconnected, the whole CX20x0 hardware block should be removed from the top-hat rail. Proceed as follows:

2.1. Release and remove the first Terminal next to the power supply unit on the top-hat rail.

First remove any wiring from power supply unit and then from the first terminal on the top-hat rail next to the power supply unit. If the wiring is to be reused for another system, it is advisable to make a note of the connections. Then pull the orange terminal release (see arrow) to release the terminal and pull it out.

2.2. Releasing the CX20x0 systems

To release the CX20x0 block, release the DIN rail bracket above and below the device. Push the hook outer with a screw driver. An audible click indicates that the device is released.

After pulling the terminal release of the power supply unit (see arrow), the block can be removed carefully from the top-hat rail.

3. Disconnecting the system interface

Disconnecting the system modules from the basic module

If the modules are locked, i.e. attached with tie clips, the clips must be released. To this end lift the tie clips with a screwdriver and pull them out. Subsequently, the system interfaces can be separated again.

Attention 		Do not use force to open the device!
Opening the module housing by force would destroy it. The devices may only be opened by Beckhoff service personnel.

Disposal

The device must be fully dismantled in order to dispose of it.

Electronic parts must be disposed of in accordance with national electronics scrap regulations


Certifications

All products of the Embedded PC family are CE, UL and GOST-R certified. Since the product family is continuously developed further, we are unable to provide a full listing here. The current list of certified products can be found on the Embedded PC certificates web page or at www.beckhoff.com under Embedded PC.


Support and Service

Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.

Beckhoff's branch offices and representatives

Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!

The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com

You will also find further documentation for Beckhoff components there.

Beckhoff Headquarters

Beckhoff Automation GmbH

Huelshorstweg 20
33415 Verl
Germany

Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support

Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:

  • support
  • design, programming and commissioning of complex automation systems
  • and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service

The Beckhoff Service Center supports you in all matters of after-sales service:

  • on-site service
  • repair service
  • spare parts service
  • hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com