Ausgabestände der Dokumentation

CX1500-x750: Sercos - Busanschaltungen für CX-Systeme

Dokumentation zu

Sercos - Busanschaltung für CX-Systeme

CX1500-M750

Version: 1.0
Datum: 06.06.2006


Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® und XFC® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Sicherheitsbestimmungen

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Auslieferungszustand

Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard-, oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH.

Qualifikation des Personals

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.

Erklärung der Sicherheitssymbole

In der vorliegenden Betriebsanleitung werden die folgenden Sicherheitssymbole verwendet. Diese Symbole sollen den Leser vor allem auf den Text des nebenstehenden Sicherheitshinweises aufmerksam machen.

Gefahr Dieses Symbol weist darauf hin, dass Gefahren für Leben und Gesundheit von Personen bestehen.

Achtung Dieses Symbol weist darauf hin, dass Gefahren für Maschine, Material oder Umwelt bestehen.

Hinweis Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Version | Änderungen
1.0 | überarbeitete Version
0.1 | Vorläufige Version


Hinweise zum Handbuch

CX1500-M750: Systemübersicht

Systemübersicht

Feldbusmaster ermöglichen das dezentrale Einsammeln von Prozessdaten und Signalen auch bei weitläufigeren Maschinen oder Anlagen. Der Einsatz von Feldbusmastermodulen ermöglicht einem CX10x0-System die Nutzung aller Beckhoff Feldbuskomponenten (z. B. Buskoppler, Busklemmen Controller, Antriebstechnik) als dezentrale Steuerungskomponenten für den Aufbau von komplexeren Anlagen. Dabei ist auch der parallele Betrieb mehrerer gleicher oder unterschiedlicher Masteranschaltungen möglich, z. B. können zwei PROFIBUS-Master oder ein PROFIBUS-Master und ein SERCOS interface-Master gleichzeitig im System vorhanden sein. Auch der Mischbetrieb aus Master- und Slaveanschaltungen ist möglich. Somit kann ein CX10x0-System auch die Funktionalität eines intelligenten Gateways zwischen verschiedenen Feldbussen übernehmen, welches Daten aus einem Feldbus empfängt, sie durch ein Programm verarbeitet und sie dann in einen anderen Feldbus einspeist.

Die Leistungsdaten der CX-Feldbusmastermodule sind nahezu identisch mit denen der Beckhoff PC-Feldbuskarten, bis auf die Tatsache, dass es sich bei den CX10x0-Varianten stets um einkanalige Ausführungen handelt. Die Anzahl der anschließbaren Slaves ist nur durch das jeweilige Bussystem begrenzt. Durch den Einsatz von Master- bzw. Slaveanschaltungen ist auch die Vernetzung mehrerer CX10x0-Systeme untereinander über die Feldbusebene machbar. Im Gegensatz zu der Vernetzung über Ethernet ist hier eine streng deterministische Datenübertragung erzielbar.

CX10x0-Feldbusmodule sind im Feld nachrüst- und austauschbar und können an ein bestehendes CX10x0-System über den PC104-Systembus angereiht werden. Die Spannungsversorgung der Feldbusanschaltungen wird ebenfalls über den PC104-Bus gewährleistet.


Technische Daten

CX1500-M750: Technische Daten

Technische Daten CX1500-M750

Technische Daten | CX1500-M750
Feldbus | Sercos Interface
Übertragungsrate | 2, 4, 8, 16 MBaud
Busanschluss | F-SMA-Norm, IEC 872-2
Busteilnehmer | max. 254 Slaves
Max. I/O-Größe | 508 Bytes Input / 508 Byte Output
Interface zur CPU | 16 Bit ISA (PC104-Standard) / 2 kByte DPRAM
Max. Verlustleistung | 1,3 W
Abmessungen | 38 mm x 100 mm x 91 mm
Gewicht | 190 g
Betriebstemperatur | 0 °C ... +55 °C
Lagertemperatur | -25 °C ... +85 °C
Relative Feuchte | 95% ohne Betauung
Vibrations-/Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27/29
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP 20


Anschlüsse

CX1500-M750: Anschlüsse

Anschlüsse CX1500-M750

Der Anschluss an den SERCOS-Bus erfolgt über ein LWL-Kabel. Die Stecker werden mit Gewindeverschraubungen an den Steckerenden fixiert.

Der Stecker hat folgendes Aussehen:

Details zum Kabel sind unter dem Kapitel Anschlüsse / Verkabelung nachzulesen.


Technische Daten CX1100-0001

CX1500-M750: Übersicht der Speicheradressen

Adapter RAM Hardware Adressübersicht

verfügbarer Adressraum bei CX1000: D0000-EFFFF (hex)

Base Address (hex) | End Address (hex) | Size(Bytes)(hex) | Access Type | Description
DC000 | DDFFF | 2000 | R/W | CX1500-M750 Sercos Master DPRAM

verfügbarer Adressraum bei CX1020: D0000-DFFFF (hex)

Base Address (hex) | End Address (hex) | Size(Bytes)(hex) | Access Type | Description
DC000 | DDFFF | 2000 | R/W | CX1500-M750 Sercos Master DPRAM

Beim CX1020 ist der Speicherbereich oberhalb von Adresse DFFFF durch das BIOS und andere Funktionen belegt.

Werden mehrere Masterfelsbusanschaltung eines Feldbustyps benötigt, müssen verschiedene Module bestellt werden. Bei der Standardkonfiguration eines Feldbusmaster ist die Adresse im Speicherbereich fest eingestellt. Für weitere Anschaltungen müssen bei der Bestellung Module mit anderen Basisadressen bestellt werden. Diese lauten dann wie folgt:

Bestellnummer | Alternative ISA-Adresse
CX1500-M750-0001 | D4000
CX1500-M750-0002 | D6000
CX1500-M750-0003 | D8000
CX1500-M750-0004 | DA000
CX1500-M750-0005 | DC000

Hinweis |
 | Es können zwei Feldbusanbindungen (Master oder Slave) ohne Einschränkungen eingesetzt werden. Für mehr als zwei Anbindungen ist eine Freigabe durch die Beckhoff Automation GmbH erforderlich.


Sercos Overview

BECKHOFF Automation: Sercos Bussystem

Sercos Bussystemübersicht

Systembeschreibung

SERCOS ist ein offenes, schnelles Bussystem, das seit 1995 internationale Norm (IEC 61491) für numerisch gesteuerte Maschinen ist. Die Erfüllung hoher Echtzeitanforderungen und die störsichere Übertragung in Lichtwellenleitertechnologie (LWL) sind wesentliche Merkmale dieses Bussystems, dessen Einsatz ist in der Antriebstechnik weit verbreitet ist. Der Bus besteht aus einem Master und mehreren Slaves. Die Slaves stellen bei SERCOS die Servoverstärker oder der SERCOS-Buskoppler BK7500 dar.

Die Bustopologie ist ein Ring-System, an dem bis zu 254 Stationen betrieben werden. Die Übertragungsgeschwindigkeit beträgt 2, 4, 8 oder 16 MBit/s. Grundsätzlich gibt es drei Telegrammarten:

  1. Das Master-Sync-Telegramm wird von allen Slaves empfangen und dient der Synchronisation.
  2. Das Master-Datentelegramm wird ebenfalls von allen Slaves empfangen und enthält die zyklischen Daten und die Servicedaten.
  3. Die Slaves senden ihre Daten als Antriebstelegramm.
PC-Feldbuskarten für SERCOS interface

Speziell für SERCOS interface im Einsatz mit den Embedded-PCs entwickelte Beckhoff die Feldbusanbindung CX1500-M750 (1-Kanal) mit PC104-Interface. Der in der Automatisierungssoftware TwinCAT integrierte Treiber sorgt für eine optimale Performance dieser passiven Masterkarten, so dass dem Anwender im Vergleich zu einer aktiven Lösung keinerlei unnötige Beschränkungen bezüglich Teilnehmerzahl oder Datenlänge entstehen. Es lassen sich auch größere SERCOS-Projekte von mehr als 50 Achsen realisieren. Dazu werden mehrere PCs über SERCOS präzise synchronisiert, wobei ein PC zum Master und alle anderen zu Slaves definiert werden.

Buskoppler für SERCOS interface

Ein weiterer Vorteil ergibt sich durch den Einsatz von Beckhoff Busklemmen am SERCOS-Buskoppler BK7500, der die hohe Datenrate, die kurze Zykluszeit und die hohe Deterministik von SERCOS auch für die klassische E/A-Technik nutzbar macht. An einen Buskoppler lassen sich bis zu 64 der Busklemmen für die unterschiedlichen analogen oder digitalen Signale ankoppeln. Maschinenbauer mit einem hohen Antriebs- und geringen E/A-Aufwand können so auf die Installation eines zusätzlichen E/A-Busses verzichten.

SERCOS-Steuerungssystem

Mit TwinCAT als Software-SPS/NC, den SERCOS-Karten, den digitalen Servoverstärkern und den Busklemmen als E/A-System stellt Beckhoff so ein komplettes PC-basiertes Steuerungssystem für SERCOS interface zur Verfügung.


Auspacken, Aufstellung und Transport

Beachten Sie die vorgeschriebenen Lagerbedingungen (siehe "Technische Daten").

Abmessungen und Gewicht der einzelnen Module:

Modultyp | CX1500-M750
Abmessungen (B x H x T) | 38 mm x 100 mm x 91 mm
Gewicht | 190 g

Auspacken

Gehen Sie beim Auspacken des Gerätes wie folgt vor:
1. Entfernen Sie die Verpackung.
2. Werfen Sie die Originalverpackung nicht weg. Bewahren Sie sie für einen Wiedertransport auf.
3. Überprüfen Sie die Lieferung anhand Ihrer Bestellung auf Vollständigkeit.
4. Bitte bewahren Sie unbedingt die mitgelieferten Unterlagen auf, sie enthalten wichtige Informationen zum Umgang mit Ihrem Gerät.
5. Prüfen Sie den Verpackungsinhalt auf sichtbare Transportschäden.
6. Sollten Sie Transportschäden oder Unstimmigkeiten zwischen Verpackungsinhalt und Ihrer Bestellung feststellen, informieren Sie bitte den Beckhoff Service.

Achtung |
 | Beschädigungsgefahr des Gerätes!

Bei Transporten in kalter Witterung oder wenn das Gerät extremen Temperaturunterschieden ausgesetzt ist, muss darauf geachtet werden, dass sich keine Feuchtigkeit an und im Gerät niederschlägt (Betauung). Das Gerät ist langsam der Raumtemperatur anzugleichen, bevor es in Betrieb genommen wird. Bei Betauung darf das Gerät erst nach einer Wartezeit von ca. 12 Stunden eingeschaltet werden.

Aufstellen

Die Geräte eignen sich für den Einbau in Schaltschränke.
Die Einbauanleitung finden Sie auf den nächsten Seiten.

Transport durchführen

Trotz des robusten Aufbaus sind die eingebauten Komponenten empfindlich gegen starke Erschütterungen und Stöße. Schützen Sie deshalb Ihren Rechner bei Transporten vor großer mechanischer Belastung. Für den Versand sollten Sie die Originalverpackung benutzen.


Maße

Die Produktreihe der CX10x0-Systeme zeichnet sich durch geringes Bauvolumen und hohe Modularität aus. Für die Projektierung muss ein CPU Modul und ein Netzteil sowie die entsprechenden Systemschnittstellen und die Feldbusschnittstellen vorgesehen werden. Die Gesamtbreite der Anwendung setzt sich aus den einzelnen verwendeten Module zusammen.
Mit einer Höhe von 100 mm entsprechen die Maße der Module exakt denen der Beckhoff Busklemmen. Achtung: es muss noch ein Sicherheitsabstand zur ausreichenden Kühlung des CPU-Moduls vorgesehen werden. (Details hierzu unter Einbaulage) Außerdem ermöglichen die abgesenkten Steckerflächen den Einsatz in einem Standard Klemmenkasten von 120 mm Höhe.

CX1500-M750 Feldbusanschaltung

Die Module für die Feldbusanschaltungen besitzen die Abmessung 38 x 100 x 91 mm.

CX1500-M750:


Mechanischer Anbau der Feldbusanschaltung

Der Anbau einer Feldbusanschaltung erfolgt in mehreren Schritten:

1. Entfernung der Abdeckung am CX1020-Grundmodul

Um die Feldbusanschaltung am CX1020-Grundmodul befestigen zu können, muss zunächst die Abdeckung am CX1000/CX1020-Grundmodul entfernt werden. Dieses wird durch einen leichten Druck gegen die Abdeckung erreicht.

2. Zusammenbau der Anschaltung mit der CX1000/CX1020-Konfiguration

Da sich die CX1000-Konfiguration bereits auf der Hutschiene befindet, muss zunächst die Anschaltung auf die Hutschiene gedrückt werden. Dazu ist zuerst das Lösen des Rastmechanismus anhand der weißen Zuglaschen (nach unten ziehen) notwendig.
Die Befestigung der Anschaltung mit der bestehenden CX1000/CX1020-Konfiguration wird durch das einfache Zusammenstecken erreicht. Dabei ist zu beachten, dass der Stecker des PC104 Interface nicht beschädigt wird.
Bei richtiger Montage ist kein nennenswerter Spalt zwischen den angereihten Gehäusen zu sehen. Am Schluss werden die weißen Zuglaschen wieder in ihre Ausgangsstellung gebracht, damit der Verriegelungsmechanismus einrastet.

3. Abdeckung anbringen

Falls die Anschaltung linksseitig keinen Abschlussdeckel besitzt, wird die vorhin entfernte Abdeckung auf die Anschaltung gedrückt, bis sie hörbar einrastet.

Hinweis:

Wenn sich die CX1000/CX1020-Konfiguration nicht auf der Hutschiene befindet, ist es ist möglich, die Anschaltung zunächst mit der CX1000/CX1020-Konfiguration zu verbinden und danach die gesamten Module auf die Hutschiene aufzurasten. Die Montage erfolgt dann wie in Kapitel Einbau und Verdrahtung.

Hinweis:

Die einzelnen Gehäuse können durch einen Verriegelungsmechanismus nicht mehr abgezogen werden.


Anschlüsse

BECKHOFF Automation SERCOS: Montage und Verdrahtung

Montageanweisung für Stecker Z1003

Fertigansicht

Achtung

Beachten Sie beim Abisolieren und bei der Montage,
  • das der Lichtwellenleiter nicht geknickt und
  • der minimale Biegeradius von 30 mm nicht unterschritten wird!

Kabelenden vorbereiten

  • Kürzen Sie beim Lichtwellenleiter Z1101 zuerst den Außenmantel (1) um ca. 100 mm und schneiden Sie die darunter liegenden Zugentlastungsfasern (gelb) mit einem scharfen Seitenschneider bündig am Außenmantel ab.
  • Kürzen Sie den schwarzen Fasermantel (2) um ca. 10 mm.
    Die Faser (3) darf dabei nicht verletzt werden! Verletzte Fasern verursachen eine erhöhte Kabeldämpfung.

Stecker montieren

  • Schieben Sie die Verschraubung (4) auf den Lichtwellenleiter.
  • Stecken Sie das Steckergehäuse (5) bis zum Anschlag auf den Lichtleiter. Die Faser soll ca. 2 mm aus der Steckerführung herausstehen, damit eventuell in der Faserschnittfläche vorhandene Risse außerhalb des Steckers liegen und abgeschliffen werden können!
  • Ziehen Sie die Verschraubung handfest an (6) (benutzen Sie kein Werkzeug).

Faser bündig schleifen

Schneiden Sie das aus der Steckerführung herausstehende Faserende nicht ab, weil beim Schneiden Risse in der Faserschnittfläche entstehen können, sondern

  • schleifen Sie das überstehende Faserende mit Schleifpapier (600er Körnung) bis zur Steckerführung bündig. Die Steckerführung darf dabei nicht angeschliffen werden!

Faserenden prüfen (Sichtkontrolle) (7)

Überprüfen Sie die geschliffenen Faserenden:

  • Das Ende der Faser muss bündig und rechtwinkelig zur Steckerführung eine saubere, plane Fläche aufweisen.
  • Richten Sie ein Kabelende auf eine Lichtquelle. Am anderen Kabelende dürfen in der leuchtenden Faser keine Kratzer oder Risse zu sehen sein.


Quick Start TwinCAT CX1500-M750

CX1500-M750: Inbetriebnahme TwinCAT

Betrieb der Feldbusanbindung CX1500-M750 für SERCOS

Das Modul CX1500-M750 (Masteranbindung für SERCOS) wird, wie die anderen Module eines CX-Systems auch über den System Manager von TwinCAT eingebunden. Dazu wählt der Anwender das gewünschte System aus. Anders als bei den anderen Feldbusanbindungen wird der SERCOS-Master manuell eingetragen. Dazu wird mit der rechten Maustaste das Kontextmenu zum Anfügen eines Geräts ausgewählt.

Danach öffnet sich der Dialog um Auswählen des Geräts. Unter SERCOS interface wird der SERCOS Master CX1500-M750 angewählt.

Die Feldbusanbindung wird automatisch in den Baum eingetragen. Die Eigenschaften sind über die Karteireiter einstellbar. Im Reiter Allgemein kann die interne Bezeichnung für den SERCOS Master eingetragen werden.

Unter dem nächsten Reiter wird die Feldbusanbindung konfiguriert. Zunächst wird die Basisadresse eingestellt. Klickt man auf den Button suchen, so öffnet sich ein Dialogfeld in dem freiverfügbare Adressen angezeigt werden. Der SERCOS Master liegt in der der Standardeinstellung bei 0xDC000. Wird der Busmaster mit weiteren SERCOS-Feldbusanbindungen eingesetzt, so muss jedes weitere mit einer anderen Basisadresse bestellt werden. Diese wird dann eingestellt.

Das folgende Bild zeigt den Dialog zum Einstellen der Adresse.

Als nächstes wird die Datenrate eingestellt. Standardmäßig ist bei den Beckhoff-Drives 4 MBaud eingestellt. Die Sendeleistung wird entsprechend der Kabellänge eingestellt. Bei Betriebsart kann der Master zusätzlich mit einem weiteren Master (mit eigenem Ring) synchronisiert werden. Bei der Verbindung der Master untereinander fungiert einer als Master. Dieser wird bei Betriebsart eingestellt. Die weiteren Einstellung sind im Kapitel Softwareansteuerung erläutert. Als nächstes wird nach Geräten auf dem SERCOS-Bus gesucht. Klickt man auf den Button "Teilnehmer suchen..." so öffnet sich folgender Dialog:

Hier wird der Adressraum der angeschlossenen Geräte gewählt. Als zulässige Eingaben sind Werte von 1 bis 254 zulässig. Aus Performanzgründen sollte nur der Bereich abgesucht werden, in dem sich die angeschlossenen Geräte befinden. Die gefundenen Geräte werden dann in den Hierarchiebaum eingetragen.

Um den gefunden Servo-Regler mit zusammen mit dem SPS Programm zu verwenden muss eine NC-Task angelegt werden. Dies geschieht über das Kontextmenu von NC-Konfiguration.

Im folgenden Dialog kann ein anwendungsspezifischer Name für die NC-Task vergeben werden.

Die angelegte Task wird entsprechend in den Hierarchiebaum eingefügt.

In dem Kontextmenu für Achsen wird eine Achse hinzugefügt:

Neben einem anwerdnungsspezifischen Namen kann der Typ der Achse eingestellt werden.

Ist die Achse eingebunden, so müssen zur Verwendung mit dem SERCOS-Master zwei weitere Einstellungen vorgenommen werden. Unter dem Karteireiter "Einstellungen" Wird als Achstyp SERCOS Achse ausgewählt.

Des weiteren müssen die Steuersignale der SPS mit den Ein- und Ausgängen des Geräts verbunden werden. Dies geschieht mit dem Klick auf "Verknüpft mit..."

Es öffnet sich ein Fenster in dem die noch nicht verbundenen Servoregler angezeigt werden. Mit der Auswahl des Geräts und der Bestätigung (Klick auf "Okay") ist die Verknüpfung hergestellt.

Im Prozessabbild des Hierarchiebaums zeigen kleine Pfeile an den Signalen die Verknüpfung an. (Details hierzu sind in der TwinCAT Dokumentation nachzulesen.)

Sind die alle Achsen eingebunden und verknüpft, so muss die Konfiguration nur noch auf das Gerät übertragen und aktiviert werden. Dies geschieht mit dem Klick auf das Piktogramm "Konfiguration aktivieren" [image].

Die Achssteuerung und der SERCOS-Bus sind nun konfiguriert und können betrieben werden. Weitere Details sind in der TwinCAT Dokumentation beschrieben.


Konfiguration

Die CX1500-M750 ist eine einkanalige passive SERCOS Karte (SErial Realtime COmmunication System) mit PCI Interface. Sie kann sowohl als Sercos Master und-/oder als Sercos Slave betrieben werden. Es wird das Sercos Asic SERCON816 verwendet, dass neben 2 und 4 MBaud auch 8 und 16 MBaud unterstützt.

Kontextmenü

Box Anfügen... <Einfg>

Fügt Sercos Slaves (Boxen) an:
Unterstützte Boxen | Beschreibung
BK7500 | Buskoppler
Sercos Achse | Sercos Achse

Gerät Löschen... <Entf>

Entfernt die FC750x Feldbuskarte und alle untergeordneten Elemente aus der E/A Konfiguration.

Online Reset

Initiiert einen Online Reset auf den Sercos Master, d.h. ein Phasenumschalten auf Phase 0 und dann wieder auf die davor aktuelle Phase.


Karteireiter FC7500

BECKHOFF FC750x: Konfiguration

Karteireiter FC750x

PCI-Slot / IRQ

Zeigt an in welchem logischen PCI-Slot die Karte gefunden wurde und welcher IRQ ihr zugewiesen wurde. Der IRQ wird nicht benutzt.

Suchen...

Hierüber werden alle gesteckten FC750x-Kanäle gesucht, und es kann der gewünschte ausgewählt werden. Bei einer FC7502 erscheinen beide Kanäle A und B, die sich logisch wie zwei FC7501-Karten verhalten.

PCI-Cfg...

Hiermit kann die Adresse der FC750x in den unteren Memory-Bereich (unterhalb von 1 MB) des PCs eingestellt werden.

Bus absuchen...

Hiermit wird Sercos Ring gescannt und alle gefunden Geräte werden dem Device hinzugefügt. Bei Beckhoff-Boxen wird die Konfiguration genau ausgelesen.

Datenrate

Hier wird die Sercos Baudrate eingestellt. Auswählbar sind 2MBaud, 4MBaud, 8MBaud und 16MBaud.

Sendeleistung

Hier wird die Sendeleistung des Transmitters in Abhängigkeit der dort verwendeten Lichtwellenleiterlänge eingestellt.

Betriebsart

Die FC750x kann sowohl als Sercos Master als auch als Sercos Slave verwendet werden. In beiden Betriebsarten kann die Karte als Synchron-Master (der PC und andere synchrone Geräte werden erhalten vom Sync-Master ihren Takt) oder als Synchron Slave (die Karte, bzw. der Kartenkanal, erhält das Sync-Signal vom anderen Kanal oder über das Sync-Kabel von einer anderen Karte) verwendet werden. Innerhalb eines PCs ist nur ein Synchron Master möglich. Werden bei einer FC7502 beide Kanäle verwendet, dann kann nur der A-Kanal (der Kanal, der näher am Motherboard ist) als Sync-Master verwendet werden.

Startup auf Phase 4

Wenn angewählt wird ei jedem TwinCAT Start versucht den Sercos Bus in Phase 4 und damit in den zyklischen Datenaustausch zu versetzen. Ist diese Option nicht angewählt verbleibt die Karte in Phase 2 und muß später per ADS z.B. von der SPS in Phase 4 versetzt werden.

Überprüfe Timing

Wenn angewählt wird in jedem Zyklus das exakte Echtzeitverhalten beim Zugriff auf die Karte überwacht und bei Verletzungen (Istwerte werden zu früh gelesen oder Sollwerte werden zu spät geschrieben) wird ein entsprechender Zähler, der in den Prozessdaten zu finden ist, inkrementiert. Die Überwachung benötigt nur sehr wenig Performance, so dass sie in normalen Anwendungen ohne Nachteile mitlaufen kann. In Anwendungen mit sehr kurzer Zykluszeit und Performance Engpässen kann sie dagegen abgeschaltet werden.

Watchdog

Das verwendete Sercos Asic SERCON816 besitzt einen Hardware Watchdog, der den regelmäßigen Zugriff des PC's überwacht und bei ausbleibenden Zugriffen die Phase 0 aktiviert. Hier kann angegeben werden wie viele Zyklen Toleranz der Watchdog erlaubt. Mit einer Toleranz von 0 wird der Watchdog deaktiviert.

NC Zugriffszeit

Hier wird angegeben wie lange die NC benötigt um pro Zyklus die Istwerte zu lesen und die Sollwerte zu schreiben. Dieser Wert wird nur für die interne Zeitschlitzberechnung verwendet um bereits im Vorfeld mögliche Zeitschlitzprobleme (vergl. Check Timing Errors) zu erkennen.

NC Shift Zeit

Mit Hilfe der NC Shift Zeit kann der Zeitpunkt an dem die NC anfängt die Istwerte zulesen verschoben werden. Dieser Wert gibt die Anzahl der µs nach dem letzen AT an. Der Defaultwert von 50µs stellt im Normalfall sicher, das auch bei geringem Jitter des Echtzeitsystems die ATs und damit die Istwerte sicher beim Master angekommen sind bevor die NC zugreift. Wenn mehr als ein Sercos Ring verwendet wird, muss dieser Wert eventuell angepasst werden da der NC Zugriff für alle Ringe quasi gleichzeitig erfolgt, das letzte AT des jeweiligen Ringes auf Grund der angeschlossenen Teilnehmer aber zu unterschiedlichen Zeiten eintreffen. Da die Sercos Ringe auf dem Bus hardwaremäßig synchronisiert sind gilt folgende Regel: Die NC Shift Zeit sollte bei allen Ringen so eingestellt werden, das die resultierende Zeit tNcAccess (siehe Timing) bei allen Ringen etwa gleich ist. Außerdem sollte die NC Shift Zeit bei keinem Ring wesentlich kleiner als etwa 20 µs betragen.

Cycle-Time(3-4)

Hier wird die Zykluszeit der zugehörigen höchstprioren Task angezeigt , diese wird in den Phasen 3 und 4 verwendet .

Cycle-Time(0-2)

Hier wird die Zykluszeit in den Phasen 0 bis 2 angegeben, die für den Hochlauf des Busses verwendet werden.

Die nachfolgenden Werte ermöglichen die interne Zeitschlitzberechnung zu beeinflussen um bei Kommunikationsproblemen oder Auslastungsproblemen noch einige µs zu verändern. Dieses sollte aber nur durchgeführt werden, wenn entsprechendes Sercos Know-how vorliegt und die Einflüsse abgeschätzt werden können.

JT1 User

Der eingestellte Wert verändert den intern bei der Zeitschlitzberechnung errechneten Jitter JT1.

JT2 User

Der eingestellte Wert verändert den intern bei der Zeitschlitzberechnung errechneten Jitter JT2.

JTSCyc User

Der eingestellte Wert verändert den intern bei der Zeitschlitzberechnung errechneten Jitter JTSCyc.

T3 User

Der eingestellte Wert verändert die intern bei der Zeitschlitzberechnung errechnete Zeit T3.

T4 User

Der eingestellte Wert verändert die intern bei der Zeitschlitzberechnung errechnete Zeit T4.


Karteireiter Timing

BECKHOFF FC750x: Konfiguration

Karteireiter Timing (Online/Offline)

Der Timing-Karteireiter informiert über interne Details der Zeitschlitzberechnung. Da für die Zeitschlitzberechnung auch Parameter aus den Teilnehmern ausgelesen werden und in Berechnung mir eingehen, wird zwischen einem Online und Offline Modus unterschieden. Im Offline Modus (TwinCAT ist gestoppt) werden Defaultwerte für die normalerweise aus den Teilnehmern ausgelesenen Timingwerte verwand, so dass diese Berechnung geringfügig von den tatsächlich verwendeten Werten abweichen kann. Für eine recht gute Abschätzung des Bustimings reicht die Offline Berechnung in der Regel jedoch aus. Im Online Modus (TwinCAT ist gestartet und der Sercos Bus muss in Phase 3 oder 4 sein) werden die exakten Werte angezeigt und geben dem fachkundigen Anwender genaueste Informationen über das Timing auf dem Bus.

Die Grafik im unteren Teil gibt einen guten Überblick über die erzeugt Buslast bzw. über die noch vorhandenen Kapazitäten. Zwischen den beiden roten Master Steuer Telegramme (MST) wird ein Sercos Zyklus dargestellt. Nachdem MST senden die Teilnehmer als erstes ihre Antriebstelegramme (grün) und nach der NC Shift Zeit beginnt die NC Zugriffszeit (gestrichelter Bereich), in der die NC die Istwerte übernimmt und neue Sollwerte übergibt. Der nachfolgende freie Bereich bis zum Master Daten Telegramm (MDT, blau) kennzeichnet noch "frei Buslast" und könnte für weitere Teilnehmer bzw. zusätzliche Daten der vorhandenen Teilnehmer genutzt werden.

Kurz hinter dem MDT wird vom Master bereits ein weiteres MST gesendet und damit der nächst Zyklus gestartet. Die Zeiten T3 und T4 geben an, wann die Teilnehmer alle gleichzeitig die Sollwerte übernehmen bzw. die Istwerte erfassen sollen.


Karteireiter Online

Über den Online-Reiter kann die aktuelle Phase des Sercos Ringes ermittelt und verändert werden. Drei rote Striche "---" als Phasenangabe deuten auf einen nicht geschlossenen Ring hin. Eine Phasenangabe der Art "2->3" zeigt an, das gerade eine Phasenumschaltung aktiv ist, die unter Umständen länger dauern kann.


Karteireiter DPRAM (Online)

Bei aktivem TwinCAT kann zu Diagnosezwecken direkt auf das DPRAM der Feldbuskarten lesend zugegriffen werden.

Im Anschluss an das DPRAM des SERCON816 sind ab Adresse 0x1000 die Register des ASIC zu sehen.


Ausgabestände der Dokumentation

CX1500-M750: LED-Blink-Codes

LED Diagnose Codes

Anzeige | LEDs |  | Bedeutung
 | RUN | ERR |
 | aus | aus | Gerät hat noch nicht gebootet.
 | aus | leuchtet | LWL Ring ist unterbrochen
 | leuchtet | aus | Es werden Pakete über den Bus gesendet.


Diagnose Eingänge

BECKHOFF FC750x: Diagnose

Diagnoseeingänge

Die FC750x verfügt automatisch über verschiedene Diagnosevariablen, die den Zustand der Karte und des Sercos Ringes beschreiben:

ActualPhase

Es wird die aktuelle Phase des Sercos Ringes angezeigt.

RequestedPhase

Es wird die aktuell angeforderte Phase (z.B. von der SPS) angezeigt. Die Karte bzw. der Treiber versucht gerade diese Phase zu aktivieren.

SystemState

Gibt genaueren Aufschluss über die
momentane Phase:
0xE001 = Phase 0
0xE002 = Phase 1
0xE003 = Phase 2
0xE004 = Phase 3
0xE005 = Phase 4
0xE008 = Break
0xE011 = Phase switch 0 -> 1
0xE012 = Phase switch 1 -> 2
0xE013 = Phase switch 2 -> 3
0xE014 = Phase switch 3 -> 4

SystemError

Zeigt den
aktuellen Fehler an:
0x0000 = No error
0x8005 = Drive addresses are incorrect
0x8006 = HS-timeout (service channel)
0x8007 = Double AT-failure
0x8009 = LWL-bus is interrupted
0xD002 = Break
0xD003 = Switch from 2->3 failure (S-0-0127)
0xD004 = Switch from 3->4 failure (S-0-0128)
0xF001 = Configuration error (actual/nominal channel)
0xF002 = Error in the time slot calculation
0xF003 = Incorrect phase setting by the NC
0xF004 = Internal error
0xF005 = Error lifecounter
0xF008 = Double MDT-failure
0xF009 = Double MST-failure
0xF00A = Sync-In signal failure

TimingError1

Ein Zähler, der inkrementiert wird, wenn die NC zu früh auf die Istwerte zugreift ('Überprüfe Timing" muss angewählt sein).

TimingError2

Ein Zähler, der inkrementiert wird, wenn die NC zu spät neue Sollwerte liefert ('Überprüfe Timing" muss angewählt sein).

RDistErrorCnt

Ein Fehlerzähler, der zerstört empfangene Telegramme zählt (vergl. RDIST im Reference Manual des SERCON816). Ursache könnte eine falsche Baudrate sein.

FibBrErrorCnt

Ein Fehlerzähler, der zerstört empfangene Telegramme zählt (vergl. FIBBR im Reference Manual des SERCON816). Ursache könnte eine falsche Baudrate sein.

RRerrErrorCnt

Ein Fehlerzähler, der verlorene oder zum falschen Zeitpunkt empfangene Telegramme zählt (vergl. RERR im Reference Manual des SERCON816).

MstLateErrorCnt

Ein Fehlerzähler, der zu spät empfangene MSTs zählt (vergl. MSTLATE im Reference Manual des SERCON816).

MstEarlyErrorCnt

Ein Fehlerzähler, der zu früh empfangene MSTs zählt (vergl. MSTEARLY im Reference Manual des SERCON816).


Abbau und Entsorgung

Der Abbau einer CX10x0-Hardwarekonfiguration erfolgt in 2 Schritten:

0. Abschalten und Entfernen der Stromversorgung

Bevor der Abbau eines CX10x0-System erfolgen kann, sollte das System abgeschaltet sein und die Stromversorgung entfernt werden.

1. Demontage von der Hutschiene:

Vor der Trennung der einzelner CX10x0 Module muss der gesamte CX1020-Hardwareblock zunächst von der Hutschiene abmontiert werden. Dazu geht man folgendermaßen vor:

1.1. Lösen und Entfernen der ersten Klemme neben der Stromversorgung auf der Hutschiene.

Zuerst entfernt man alle eventuell vorhandene Verkabelung der Stormversorgung und der ersten Klemme auf der Hutschiene neben der Stromversorgung. Soll die Verkabelung später mit einem anderen System wieder hergestellt werden, so empfiehlt es sich die Beschaltung zu notieren. Dann zieht man an der orangefarbenen Klemmenentriegelung (siehe Pfeil), löst damit die Klemme und zieht sie nach vorne heraus.

1.2. Entriegeln des CX10x0 - Systems

Um den CX10x0-Block zu lösen, werden die weißen Laschen an der Unterseite der Modul in Pfeilrichtung gezogen. Sie arretieren dann in der ausgezogenen Position. Nach dem Ziehen an der Klemmenentriegelung der Stromversorgung lässt sich der Block vorsichtig von der Hutschiene nehmen.

2. Trennung der einzelnen Module

2.1. Trennen von Stromversorgung und CX10x0-CPU sowie weiterer Komponenten

Man setzt den CX10x0-Block mit der Vorderseite auf eine geeignete Unterlage. Dann wird ein Schlitzschraubendreher der Größe 1,0 x 5,5 x 150 mm in den Verriegelungsmechanismus einführt und mit einer etwa 90 Grad Drehung der Schieber betätigt. Der rückseitige Verriegelungsmechanismus bewirkt eine ca. 2-3mm breite Trennung der mechanischen Einrastung der Module und drückt diese auseinander. Die Stecker des PC 104 Interface können anschließend vorsichtig auseinander gezogen werden.

Nur Module (CPU, Feldbusanschaltungen und USV-Module) die sich zerstörungsfrei trennen lassen verfügen über eine Entriegelung. Module, die nicht voneinander getrennt werden können, haben lediglich einen Markierungspunkt (mit oder ohne roten Versieglungslack). Eine Krafteinwirkung an diesen Elementen führt zur Zerstörung.

Achtung |
 | Das gewaltsame Öffnen der Modulgehäuse (z.B. Entfernen der Deckel) führt zur Zerstörung der Gehäuse.

Entsorgung

Zur Entsorgung muss das Gerät auseinandergebaut und vollständig zerlegt werden.

Elektronik-Bestandteile sind entsprechend der nationalen Elektronik-Schrott-Verordnung zu entsorgen.


Mechanischer Zusammenbau des Grundmoduls

Der Einbau der Module erfolgt in drei Schritten:

1. Reihenfolge der Module

Das CPU-Grundmodul mit den werkseitig links angeschlossenen Systemschnittstellen wird auf der rechten Seite um das Netzteil, und auf der linken Seite um die Feldbusanschaltung (Master bzw. Slave), soweit vorhanden, erweitert.

2. Zusammenbau der CPU mit dem Netzteil

Die Befestigung der einzelnen Module untereinander wird durch das einfache Zusammenstecken erreicht. Dabei ist zu beachten, dass die Stecker des PC104 Interface nicht beschädigt werden. Bei richtiger Montage ist kein nennenswerter Spalt zwischen den angereihten Gehäusen zu sehen.

3. Aufrasten auf die Hutschiene

Auf der Unterseite der Module befindet sich eine weiße Zuglasche, die mit einem Rastmechanismus verbunden ist. Diese Zuglaschen müssen vor dem Anbringen auf die Hutschiene nach unten gezogen werden. Dieses kann mittels eines Schlitzschraubendrehers und einer leichten Drehung geschehen.

Anschließend wird der CX1020-Block mit Hilfe der Verrieglungslaschen auf der Hutschiene fixiert. Dabei sollte ein leisen Klicken zu vernehmen sein.

Keine Gewalt oder zu großen Druck auf die Baugruppe ausüben!

Die Gehäuse nur an unempfindlichen Stellen (Gehäusekanten) drücken. Auf keinen Fall Druck auf das Display, die Taster oder bewegliche Teile am CX10x0-System ausüben.

Nach erfolgreichem Aufrasten auf die Hutschiene müssen die Zuglaschen wieder in die Ausgangsstellung geschoben werden.

Hinweis:

Die einzelnen Gehäuse können durch einen Verriegelungsmechanismus nicht mehr abgezogen werden. Ausführliche Informationen zur Demontage der CX1020-Konfiguration von der Hutschiene finden Sie auf der Seite "Abbau und Entsorgung".

Einbaulage:

Achtung

Das auf eine Hutschiene montierte CPU Modul darf nur bis Umgebungstemperaturen von 50°C betrieben werden. Die Einbaulage muss so gewählt werden, dass die Kühlung durch die Lüftungsöffnungen in vertikaler Richtung möglich ist. Die Bilder zeigen die erlaubte ( BILD8) sowie zwei verbotene Einbaulagen (BILD 9 & BILD10).

Mindestabstand einhalten!

Beim Einbau ist ein Freiraum von jeweils 30 Millimetern oberhalb und unterhalb einer CX1020 Gerätekombination erforderlich, um eine ausreichende Belüftung des CPU Grundmoduls und des Netzteils zu erreichen.
Zulässige Einbaulage:

Auf Grund der hohen Leistung des CX1020-Systems kommt es zu einer erhöhten Wärmeentwicklung. Diese Wärme wird durch ein passives Lüftungssystem abgeführt. Dieses System erfordert allerdings eine korrekte Einbaulage. Lüftungsöffnungen befinden sich auf der Gehäuseunter- und Gehäuseoberseite. Daher muss das System waagerecht montiert werden. Auf diese Weise kommt ein optimaler Luftstrom zustande.

Unzulässige Einbaulagen:

Es ist nicht zulässig das CX1020-System senkrecht auf der Hutschiene zu betreiben. Es ist dann keine ausreichende Belüftung für die CPU gewährleistet, da sich die Belüftungsöffnungen auf der Gehäuseober- und Gehäuseunterseite befinden. Auch in liegender Position ist das System nicht ausreichend belüftet.


Technische Daten

 | FC7501 | FC7502
Feldbus | SERCOS interface
Anzahl Feldbuskanäle | 1 | 2
Übertragungsrate | 2, 4, 8 oder 16 MBaud
Synchronisierung | Synchronisierung mehrerer Karten über Flachbandkabel
Busteilnehmer | maximal 254 je Kanal
Zykluszeit | alle von SERCOS interface unterstützten (ab 62,5 µs)
Hardware Diagnose | 1 LED je Kanal
Interface zum PC | Plug and Play PCI-Interface 32 Bit, direkter Zugriff auf DPRAM und Register des SERCON816
Stromaufnahme aus dem PCI-Bus | typisch 180 mA | typisch 285 mA
Maße | ca. 95 x 120 mm
zulässige Umgebungstemperatur im Betrieb | 0° bis 55° C
Bestellangaben
Bestellbezeichnung | Produkt
FC7501 | SERCOS interface PCI-Karte, einkanalig
FC7502 | SERCOS interface PCI-Karte, zweikanalig
Z1003 | FSMA-Stecker mit Rändelmutter für 1000 µm Kunststoff-Faser
Z1100 | Kunststoff-Lichtleiter, 1-adrig, 1000 µm
Z1101 | Kunststoff-Lichtleiter, 1-adrig, 1000 µm mit PU-Schutzmantel und Kevlar-Zugentlastung
ZB7501 | SERCOS Master Sync-Kabel, zur Verbindung von SERCOS interface PCI-Karten eines PCs


Ausgabestände der Dokumentation

CX1500-x750: Zubehör

Zubehör

Kabel und Stecker für die Verbindung der Sercos-Komponenten.

Kabel

Artikelnummer | Beschreibung
Z1003 | FSMA-Stecker mit Rändelmutter für 1000-μm-Kunststoff-Faser
Z1100 | Leitung 1-adrig, 100-μm-Kunststoff-Faser, Durchmesser 2,2 mm

Stecker

Artikelnummer | Beschreibung
Z1003 | FSMA-Stecker mit Rändelmutter für 1000-μm-Kunststoff-Faser


Zulassungen

BECKHOFF Automation: Anhang

Zertifizierungen

Prinzipiell sind alle Produkte der Embedded-PC Familie CE, UL und GOST-R zertifiziert. Da sich aber die Produktfamilie ständig weiterentwickelt, kann hier keine Auflistung angegeben werden. Die aktuelle Auflistung der zertifizierten Produkte kann auf der Internetseite Zertifikate Embedded PC oder www.beckhoff.de unter Embedded-PC nachgelesen werden.


Support und Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.

Beckhoff Support

Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:

  • Support
  • Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
  • umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com

Beckhoff Service

Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:

  • Vor-Ort-Service
  • Reparaturservice
  • Ersatzteilservice
  • Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com

Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.

Beckhoff Firmenzentrale

Beckhoff Automation GmbH & Co. KG

Hülshorstweg 20
33415 Verl
Deutschland

Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com

Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de

Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.