Title

CX1500-x310: Profibus - Fieldbus connection for CX-Systems

Documentation for

Profibus - Connectors for CX-Systems

CX1500-M310

CX1500-B310

version: 1.0
date: 2006-06-07


Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending

The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.

Copyright

© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety Instructions

Safety Rules

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

State at Delivery

All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH.

Personnel Qualification

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.

Description of safety symbols

The following safety symbols are used in this operating manual. They are intended to alert the reader to the associated safety instructions.

Danger This symbol is intended to highlight risks for the life or health of personnel.

Warning This symbol is intended to highlight risks for equipment, materials or the environment.

Note This symbol indicates information that contributes to better understanding.


Documentation Issue Status

Version | Changes
1.0 | revised version
0.1 | preliminary version


Hardware description

The connection to the Profibus for the CX-family is realized by field assembles modules. There are two versions of modules:

  • Master connection
  • Slave connection

The function is similar to the function of the Beckhoff PCI fieldbus cards. In opposite to them only one port is available in the modules for CX-Systems. The connection parameters will be set by using TwinCAT. The data transfer to the system is realized by a DPRAM via PC104 bus.

As alternative a Profibus connection can be realized with CX10x0 (no CX1000) Systems via a E-Bus terminal. Further details can be read in documentation for EL6731 / EL6731-0010.


Hinweise zum Handbuch

CX1500-M310: System overview

System overview

Fieldbus connection enable the distributed collection of process data and signals, even for distant machines or equipment. The use of fieldbus master modules in a CX10x0 system enables the
utilization of all Beckhoff fieldbus components (e. g. Bus Coupler, Bus Terminal Controller, drive technology) as distributed control components for the assembly of complex systems.

Parallel operation of several identical or different master connections is also possible, Mixed operation of master and slave connections is also not a problem. A CX system can thus also assume the functionality of an intelligent gateway between different fieldbuses, receiving data from a fieldbus, processing them via a program and then feeding them into another fieldbus.

The performance data of the CX fieldbus master modules are nearly identical to those of the Beckhoff PC fieldbus cards, except for the fact that the CX variants are always single-channel types. The number of slaves that can be connected is only limited by the respective bus system. The use of master or slave connections enables networking of several CX systems with each other via the fieldbus level. In contrast to networking via Ethernet, strictly deterministic data transmission can be achieved in this case.

CX fieldbus modules can be upgraded or exchanged in the field and can be connected to an existing CX system via the PC104 system bus. The power supply of the fieldbus connections is also ensured via the PC104 bus. Despite the ISA bus, no address switch is required for the address setting, since the modules are assigned an address via internal setup. (The address must be selected by ordering the module)

The software integration of the fieldbus connections into the TwinCAT automation software is done in the usual comfortable way: Scanning and detection of the modules, parameterization, configuration of the connected I/O components as well as online diagnosis of the process and fieldbus status are carried out in the familiar way through the TwinCAT System Manager.


Technical Data

CX1500-M310: Technical Data

Technical data CX1500-M310

Technical data | CX1500-M310
Fieldbus | PROFIBUS-DP, DP-V1, DP-V2 (MC)
Transmission rate | 9,6 kbaud –12 Mbaud
Bus connection | 1 x D-Sub, 9-pin
Bus nodes | max. 125 slaves
Max. I/O-Größe | 244 Bytes input / 244 Byte output parameter, configuration, diagnostic data per slave
Interface to the CPU | 16 bit ISA (PC104-Standard) / 2 kbyte DPRAM
Max. power consumption | 1,8 W
Dimensions | 38 mm x 100 mm x 91 mm
Weight | 190 g
Operating temperature | 0 °C ... +55 °C
Storage temperature | -25 °C ... +85 °C
Relative humidity | 95% no condensation
Vibration/shock resistance | confirms to EN 60068-2-6 / EN 60068-2-27/29
EMC resistance burst /ESD | confirms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP 20


Connections

CX1500-M310/CX1500-B310: Connections

Connections CX1500-M310 / B310

The connection to Profibus is realized by a 9 pin sub D plug. The assignment of the pins is described below.

Assignment 9-pol. Sub-D:

Pin | Meaning
1 | -
2 | -
3 | RxD / TXD - P
4 | -
5 | Masse (M5V)
6 | VP (P5V / 100mA)
7 | -
8 | RxD / TxD - N
9 | Masse (M5V)

The cable for Profibus is normally realized as 2 wired, shielded twisted pair. When selecting a cable and connector pay attention to the maximal transfer rate. The bus is connected to the unit via pin 3 (RxD/TxD - P) and pin 8 RxD/TxD - N). Make sure all Profibus units have the same data lines otherwise the is no operation possible.


Technical Data CX1500-M310

CX1500-M310: Overview of memory mapping

Adapter RAM Hardware address overview

available memory addresses for CX1000: D0000-EFFFF (hex)

Base Address (hex) | End Address (hex) | Size(Bytes)(hex) | Access Type | Description
D4000 | D5FFF | 2000 | R/W | CX1500-M310 Profibus Master DPRAM
E4000 | E5FFF | 2000 | R/W | CX1500-B310 Profibus Slave DPRAM

available memory addresses for CX1020: D0000-DFFFF (hex)

Base Address (hex) | End Address (hex) | Size(Bytes)(hex) | Access Type | Description
D4000 | D5FFF | 2000 | R/W | CX1500-M310 Profibus Master DPRAM

For CX1020 the memory space upper DFFFF is reserved for the BIOS and other functions.

For some fieldbus connections (all Slave modules) the base addresses are mapped in the memory region upper DFFFF(hex). So this modules must be ordered with other base addresses. The same situation takes place if more than two or more master modules of same type are used (for more see note below). The order numbers for the modules are:

Order number | Alternative ISA-Address
CX1500-M310-0001 | D4000
CX1500-M310-0002 | D6000
CX1500-M310-0003 | D8000
CX1500-M310-0004 | DA000
CX1500-M310-0005 | DC000

Note

Two connection modules (master or slave) can be used simultaneously.

If more than two connections are needed call Beckhoff Automation GmbH for further information.


Systemoverview

CX1500-B310: System overview

System overview

Fieldbus connection enable the distributed collection of process data and signals, even for distant machines or equipment. The use of fieldbus master modules in a CX1000 / CX1020 system enables the
utilization of all Beckhoff fieldbus components (e. g. Bus Coupler, Bus Terminal Controller, drive technology) as distributed control components for the assembly of complex systems.

Parallel operation of several identical or different master connections is also possible, Mixed operation of master and slave connections is also not a problem. A CX system can thus also assume the functionality of an intelligent gateway between different fieldbuses, receiving data from a fieldbus, processing them via a program and then feeding them into another fieldbus.

The performance data of the CX fieldbus master modules are nearly identical to those of the Beckhoff PC fieldbus cards, except for the fact that the CX variants are always single-channel types. The number of slaves that can be connected is only limited by the respective bus system. The use of master or slave connections enables networking of several CX systems with each other via the fieldbus level. In contrast to networking via Ethernet, strictly deterministic data transmission can be achieved in this case.

CX fieldbus modules can be upgraded or exchanged in the field and can be connected to an existing CX system via the PC104 system bus. The power supply of the fieldbus connections is also ensured via the PC104 bus. Despite the ISA bus, no address switch is required for the address setting, since the modules are assigned an address via internal setup. (The address must be selected by ordering the module)

The software integration of the fieldbus connections into the TwinCAT automation software is done in the usual comfortable way: Scanning and detection of the modules, parameterization, configuration of the connected I/O components as well as online diagnosis of the process and fieldbus status are carried out in the familiar way through the TwinCAT System Manager.


Technical Data

CX1500-B310: Technical Data

Technical data CX1500-B310

Technical data | CX1500-B310
Fieldbus | PROFIBUS-DP, DP-V1, DP-V2 (MC)
Transmission rate | 9,6 kbaud –12 Mbaud
Bus connection | 1 x D-Sub, 9-pin
Bus nodes | max. 125 slaves
Max. I/O-Größe | 244 Bytes input / 244 Byte output parameter, configuration, diagnostic data per slave
Interface to the CPU | 16 bit ISA (PC104-Standard) / 2 kbyte DPRAM
Max. power consumption | 1,8 W
Dimensions | 38 mm x 100 mm x 91 mm
Weight | 190 g
Operating temperature | 0 °C ... +55 °C
Storage temperature | -25 °C ... +85 °C
Relative humidity | 95% no condensation
Vibration/shock resistance | confirms to EN 60068-2-6 / EN 60068-2-27/29
EMC resistance burst /ESD | confirms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP 20


Technical Data CX1500-B310

CX1500-B310: Overview of memory mapping

Adapter RAM Hardware Address overview

available memory addresses for CX1000: D0000-EFFFF (hex)

Base Address (hex) | End Address (hex) | Size (Bytes)(hex) | Access Type | Description
D4000 | D5FFF | 2000 | R/W | CX1500-M310 Profibus Master DPRAM
E4000 | E5FFF | 2000 | R/W | CX1500-B310 Profibus Slave DPRAM

available memory addresses for CX1020: D0000-DFFFF (hex)

Base Address (hex) | End Address (hex) | Size (Bytes)(hex) | Access Type | Description
D4000 | D5FFF | 2000 | R/W | CX1500-M310 Profibus Master DPRAM

For some fieldbus connections (all Slave modules) the base addresses are mapped in the memory region upper DFFFF(hex). So this modules must be ordered with other base addresses. The same situation takes place if more than two or more master modules of same type are used (for more see note below). The order numbers for the modules are:

Order number | Alternative ISA-Address
CX1500-B310-0001 | D4000
CX1500-B310-0002 | D6000
CX1500-B310-0003 | D8000
CX1500-B310-0004 | DA000
CX1500-B310-0005 | DC000

Note |
 | Two connection modules (master or slave) can be used simultaneously. If more than two connections are needed call Beckhoff Automation GmbH for further information.


Profibus Introduction

PROFIBUS has achieved wide acceptance in the world of automation engineering through its openness and its compatibility across manufacturers. PROFIBUS was developed as part of a joint fieldbus project. The aim of the project was the adoption of a standard. Today a wide range of different products from independent manufacturers are available that meet DIN 19245 Part 1 and 2. Operation of standard-compliant PROFIBUS devices within a bus system is ensured.

PROFIBUS defines the technical and functional characteristics of a serial fieldbus system for networking of distributed digital and analog field automation devices in the lower (sensor/actuator level) to medium performance range (cell level).

PROFIBUS distinguishes between master and slave devices. Master devices determine the data traffic on the bus.

A master may transmit messages without having received an external request when it is in possession of the bus access authorisation. Within the PROFIBUS protocol masters are also referred to as active devices.

Slaves are peripheral devices. Typical slave devices include sensors, actuators, measuring transducers, Beckhoff Bus Couplers BK3000, BK3100, BK3110, BK3010, and CX1500-B310 fieldbus connections. They have no bus access rights, i.e. they can only acknowledge received messages or transfer messages to a master on request. Slaves are also referred to as passive devices. Beckhoff Bus Couplers are passive devices that support PROFIBUS DP and PROFIBUS-FMS. They are also referred to as combined FMS/DP slaves.

Profibus DP

PROFIBUS-DP is designed for fast data exchange at the sensor / actuator level. Central control devices (such as, for example, programmable logic controllers) communicate here over a fast serial connection with distributed input and output devices. Data is mainly exchanged with these distributed devices cyclically. The central controller (master) reads the input information from the slaves, and writes the output information to the slaves. The bus cycle time must here be shorter than the central controller’s program cycle time, which in many applications is less than 10 ms.

A high data throughput is not in itself sufficient for successful use of a bus system. Ease of handling, good diagnostic facilities and secure transmission technology are also of the utmost importance if the user's demands are to be satisfied. These properties are ideally combined in PROFIBUS DP.

For the transmission of 512 bits of input data and 512 bits of output data distributed over 32 bus devices PROFIBUS-DP needs approx. 6 ms at a transmission rate of 1.5 Mbit/s or less than 2 ms at 12 Mbit/s.


Unpacking, installation and transport

The specified storage conditions must be adhered to (see "Technical data").

Dimensions and weight of the individual modules:

Module type | CX1500-M310 | CX1500-B310
Dimensions (B x H x T) | 38 mm x 100 mm x 91 mm | 38 mm x 100 mm x 91 mm
weight | 190 g | 190 g

Unpacking

Proceed as follows to unpack the unit:
1. Remove packaging.
2. Do not discard the original packaging. Keep it for future relocation.
3. Check the delivery for completeness by comparing it with your order.
4. Please keep the associated paperwork. It contains important information for handling the unit.
5. Check the contents for visible shipping damage.
6. If you notice any shipping damage or inconsistencies between the contents and your order, you should notify Beckhoff Service.

Warning |
 | Danger of damage to the unit!

During transport in cold conditions, or if the unit is subjected to extreme temperature swings, condensation on and inside the unit must be avoided.
Prior to operation, the unit must be allowed to slowly adjust to room temperature. Should condensation occur, a delay time of approximately 12 hours must be allowed before the unit is switched on.

Installation

The devices are designed for installation in control cabinets. You will find installation instructions in the chapter mechanical mounting.

Shipping and relocation

Despite the robust design of the unit, the components are sensitive to strong vibrations and impacts. During transport, your computer should therefore be protected from excessive mechanical stress. Therefore, please use the original packaging.


Dimensions

The CX10x0 product range is characterized by small overall installed size and high modularity. For project planning purposes, a CPU module, a power supply unit and the associated system interfaces and fieldbus interfaces have to be provided. The overall width of the application is made up of the individual modules. With a height of 100 mm, the module dimensions exactly match those of the Beckhoff Bus Terminals. Together with the lowered connector surfaces, this means that it can be used in a standard terminal box with a height of 120 mm.

CX1500-M310 und CX1500-B310 Fieldbus connections

The modules for fieldbus connection have the dimension of 38 x 100 x 91 mm. Master- and Slave connections have the same dimensions.

CX1500-M310:

CX1500-B310:


Mechanical installation of the fieldbus connection

Installation of a fieldbus connection involves several steps:

1. Removing the cover of the basic CX1020 module

In order to be able to connect the fieldbus to the basic CX1020 module, the cover of the basic CX1000/CX1020 module has to be removed first. This is achieved by applying slight pressure on the cover.

2. Assembly and connection to the CX1000/CX1020 configuration

Since the CX1000 configuration is already positioned on the top-hat rail, the assembly first has to be pushed onto the top-hat rail. To this end the latching mechanism has to be released by pulling the white straps downwards.
The assembly is connected to the existing CX1000/CX1020 configuration by simply plugging the two units together. Care must be taken that the plug of the PC104 interface is not damaged.
When correctly assembled, no significant gap can be seen between the attached housings. Finally, the white straps are returned to their original position, so that the locking mechanism engages.

3. Install cover

If the connection area does not have a closing cover on the left-hand side, the cover that was previously removed should be pressed over the connections until it audibly engages.

Note:

If the CX1000/CX1020 configuration is not positioned on the top-hat rail, it is possible to connect the assembly with the CX1000/CX1020 configuration first and then latch the whole module onto the top-hat rail. The installation is described in section Installation and wiring.

Note:

A locking mechanism prevents the individual housings from being pulled off again.


BECKHOFF Profibus Cabling

BECKHOFF Fieldbus Components: Mounting and Wiring

PROFIBUS Cabling

Physical aspects of the data transmission are defined in the PROFIBUS standard (see PROFIBUS layer 1: Physical Layer).

The types of area where a fieldbus system can be used is largely determined by the choice of the transmission medium and the physical bus interface. In addition to the requirements for transmission security, the expense and work involved in acquiring and installing the bus cable is of crucial significance. The PROFIBUS standard therefore allows for a variety of implementations of the transmission technology while retaining a uniform bus protocol.

Cable-based transmission

This version, which accords with the American EIA RS-485 standard, was specified as a basic version for applications in production engineering, building management and drive technology. A twisted copper cable with one pair of conductors is used. Depending on the intended application area (EMC aspects should be considered) the screening may be omitted.

Two types of conductor are available, with differing maximum conductor lengths (see the RS-485 table).

RS485 - Fundamental properties
RS-485 transmission according to the Profibus standard
Network topology | Linear bus, active bus terminator at both ends, stubs are possible.
Medium | Screened twisted cable, screening may be omitted, depending upon the environmental conditions (EMC).
Number of stations | 32 stations in each segment with no repeater. Can be extended to 127 stations with repeater
Max. bus length without repeater | 100 m at 12 MBit/s 200 m at 1500 KBit/s, up to 1.2 km at 93.75 KBit/s
Max. bus length with repeater | Line amplifiers, or repeaters, can increase the bus length up to 10 km. The number of repeaters possible is at least 3, and, depending on the manufacturer, may be up to 10.
Transmission speed (adjustable in steps) | 9.6 kBit/s; 19.2 kBit/s; 93.75 kBit/s; 187.5 kBit/s; 500 kBit/s; 1500 kBit/s; 12 MBit/s
Plug connector | 9-pin D-Sub connector for IP20 M12 round connector for IP65/67

Cabling for PROFIBUS DP and PROFIBUS FMS

Note the special requirements on the data cable for baud rates greater than 1.5 MBaud. The correct cable is a basic requirement for correct operation of the bus system. If a simple 1.5 Mbaud cable is used, reflections and excessive attenuation can lead to some surprising phenomena. It is possible, for instance, for a connected PROFIBUS station not to achieve a connection, but for it to be included again when the neighboring station is disconnected. Or there may be transmission errors when a specific bit pattern is transmitted. The result of this can be that when the equipment is not operating, PROFIBUS works without faults, but that there are apparently random bus errors after start-up. Reducing the baud rate (< 93,75 kBaud) corrects this faulty behavior.

If reducing the baud rate does not correct the error, then in many cases this can indicate a wiring fault. The two data lines maybe crossed over at one or more connectors, or the termination resistors may not be active, or they may be active at the wrong locations.

Note 		Pre-assembled cables from Beckhoff
Installation is made a great deal more straightforward if pre-assembled cables from Beckhoff are used! Wiring errors are avoided, and commissioning is more rapidly completed. The Beckhoff range includes fieldbus cables, power supply cables, sensor cables and accessories such as terminating resistors and T-pieces. Connectors and cables for field assembly are nevertheless also available.

Note 		Termination resistors
In systems with more than two stations all devices are wired in parallel. It is essential that the bus cables are terminated with resistors at the conductor ends in order to avoid reflections and associated transmission problems.

Distances

The bus cable is specified in EN 50170. This yields the following lengths for a bus segment.

Baud rate in kbits/sec | 9.6 | 19.2 | 93.75 | 187.5 | 500 | 1500 | 12000
Cable length in m | 1200 | 1200 | 1200 | 1000 | 400 | 200 | 100

Stubs up to 1500 kbaud <6.6 m; at 12 Mbaud stub segments should not be used.

Bus segments

A bus segment consists of at most 32 devices. 126 devices are permitted in a PROFIBUS network. Repeaters are required to refresh the signal in order to achieve this number. Each repeater is counted as one device.

IP-Link is the subsidiary bus system for Fieldbus Boxes, whose topology is a ring structure. There is an IP master in the coupler modules (IP230x-Bxxx or IP230x-Cxxx) to which up to 120 extension modules (IExxxx) may be connected. The distance between two modules may not exceed 5 m. When planning and installing the modules, remember that because of the ring structure the IP-Link master must be connected again to the last module.

Installation guidelines

When assembling the modules and laying the cables, observe the technical guidelines provided by the PROFIBUS User Organization (PROFIBUS Nutzerorganisation e.V.) for PROFIBUS DP/FMS (see www.profibus.com).

Checking the PROFIBUS wiring

A PROFIBUS cable (or a cable segment when using repeaters) can be checked with a few simple resistance measurements. The cable should meanwhile be removed from all stations:

  1. Resistance between A and B at the start of the lead: approx. 110 Ohm
  2. Resistance between A and B at the end of the lead: approx. 110 Ohm
  3. Resistance between A at the start and A at the end of the lead: approx. 0 Ohm
  4. Resistance between B at the start and B at the end of the lead: approx. 0 Ohm
  5. Resistance between screen at the start and screen at the end of the lead: approx. 0 Ohm

If these measurements are successful, the cable is okay. If, in spite of this, bus malfunctions still occur, this is usually a result of EMC interference. Observe the installation notes from the PROFIBUS User Organization (www.profibus.com).


PROFIBUS Connection

M12 circular connector

The M12 socket is inverse coded, and has five pins. Pin 1 is 5 VDC and 3 is GND for the active termination resistor. These must never be misused for other functions, as this can lead to destruction of the device.

Pin 2 and pin 4 are the PROFIBUS signals. These must never be swapped over, as this will prevent communication. Pin 5 is the shield, and this is capacitatively coupled to the Fieldbus Box chassis.

M12 socket pin assignment (-B310)

M12 socket/plug pin assignment (-B318)

Nine pole D-Sub

Pin 6 is 5 VDC und Pin 5 is GND for the active termination resistor. These must never be misused for other functions, as this can lead to destruction of the device.

Pin 3 and pin 8 are the PROFIBUS signals. These must never be swapped over, as this will prevent communication.

D-Sub socket pin assignment

PROFIBUS conductor colors

PROFIBUS conductors | M12 | D-Sub
B red | Pin 4 | Pin 3
A green | Pin 2 | Pin 8

Connection of Fieldbus Box modules

The connection of the Fieldbus Box modules is done direct or via a T-piece (or Y-piece).

The B318 series does have a male and female connector, that means no external T-piece is required. The supply voltage (+5VDC) for the termination resistor is only supplied via the female M12 connector. The termination resistor ZS1000-1610 is only available with male connector.

Therefore the incoming PROFIBUS line should end in a female connector.

Two T-pieces are available:

  • ZS1031-2600 with +5VDC on male and female connector for the termination resistor
  • ZS1031-2610 with +5VDC only on the female connector


FC310x - Overview

BECKHOFF FC310x: Master

Overview

In TwinCAT RunMode, the DP master is always synchronized with the highest priority task with which the variables are linked. The cycle time for the corresponding task is displayed under Cycle time on the master's "FC310x" tab (for TwinCAT 2.8 and TwinCAT 2.9), as soon as the mapping has once been created. It is possible to set for the task whether the "I/O at task start" should be updated or not.

I/O at Task Start

If the setting "I/O at task start" has been selected using the checkbox, which is the default setting for the NC task, then a check is made before the task is started as to whether the previous DP cycle has been completed. The inputs and outputs (the outputs being those from the previous task cycle) are copied, and the DP cycle is started. In the example, the task cycle time is 2 ms, and real-time resources are 80%:

If, in the previous example, the copying of the inputs and outputs and the task computation time exceeds 0.8 ms, then NT will interrupt execution of the task, because 80% of real time resources has been reached:

This case would still not be a problem, because the DP cycle was completed within the available time. If "I/O at task start" is not selected, then the process is somewhat more critical, as is described below.

I/O not at Task Start

If the setting "I/O at task start" has not been selected using the checkbox, which is the default setting for the PLC task, then a check is made before the task is started as to whether the previous DP cycle has been completed, and the inputs are copied. After this the task is processed, and at the end of the task the outputs are copied and the DP cycle is started. In the example, the task cycle time is 2 ms, and real-time resources are 80%:

Because in the case where "I/O not at task start" is selected the task and the PROFIBUS must share the bandwidth, the effect of exceeding the available real-time resources is significantly greater than is the case when "I/O at task start" is selected:

In the case described, the DP cycle starts later, and is no longer finished within the time available before the following task cycle begins. The effect of this is that it is seen before the task is executed that the previous DP cycle has still not been completed. It follows that inputs are not copied before starting the task, so that the task computes with the old inputs; after the task has been processed no outputs are copied, nor is the DP cycle restarted, so that a DP cycle is omitted. The omission of a DP cycle can be detected with the CycleCounter, as described in the Master Diagnostics section.

Comparison of I/O at task start and I/O not at task start

An advantage when "I/O at task start" is selected is that the task and the DP cycle do not have to share the available bandwidth, and that the DP cycle starts very regularly, any jitter being the TwinCAT jitter. If "I/O not at task start" is selected, then it is more likely that a DP cycle will be omitted; the regularity of the start times of the DP cycles depends additionally on the jitter in the task processing. The disadvantage of the "I/O at task start" is that the dead time, or system reaction time, becomes longer.


FC310x - Slave Prioritisation/Multiple DP Cycles

Slave Prioritisation/Multiple DP Cycles

Distribution of the DP slaves over a number of DP cycles (prioritization of the slaves)

Slaves can be prioritized so that the DP cycle time can be kept as short as possible in systems in which a few slaves must be polled very rapidly, whereas a larger cycle time would be adequate for other slaves. It is possible to specify for each slave in what multiple of cycles (Divider under Data-Exch Poll-Rate on the slave's Features tab) it will be polled. Distributing the polling is then helpful, as, for instance, in the case illustrated below where there are four slaves, each of which is only to be addressed in every second cycle. It is possible to make settings so that two slaves will be polled in one cycle and the other two slaves in the other cycle, so that the overall DP cycle time is kept as constant as possible. For this purpose, the Features tab for the slave offers the Modulo setting under Data-Exch Poll-Rate. In the illustrated case, slaves 3 and 5 have Modulo 0 while slaves 4 and 6 are given Modulo 1. The current modulo value can be read in the ActualModulo variable which is described in the Master Diagnostics section.

Multiple DP Cycles in one Task Cycle

If the task cycle time is more than twice as long as the DP cycle time, it is possible for a number of DP cycles to be carried out within a single task cycle, in order to acquire the most up-to-date input data possible. In accordance with a factor set on the master's "FC310x" tab (for TwinCAT 2.8 and TwinCAT 2.9) governing the Number of DP cycles per task cycle, a timer is started at the beginning of the first DP cycle, loaded with the cycle time (task cycle time/(number of DP cycles per task cycle)), and this is then used to start further DP cycles. It is, however, necessary to check that the last DP cycle is completed in good time (before the next task start), since otherwise one DP cycle will fail (or possibly more than one, depending on the ratio expressed in the number of DP cycles per task cycle), as described in the Synchronization section.

Multiple Data Samples Within One Task Cycle

The two functionalities just described can now be combined in order, for instance, to give one or more slaves in a 2 ms cycle new data every 1 ms, or to obtain new data from the slave in order to achieve better regulation quality. In this case, settings are made under Additional Data_Exchange Samples on the slave's Features tab instead of under Data-Exch Poll-Rate (as described above).

In the example illustrated below, the Number of DP cycles per task cycle factor is to be set to 2 on the master's "FC310x" tab (for TwinCAT 2.8 and TwinCAT 2.9). So that the task can send 2 different values to the slave, or is able to receive 2 different values from the slave, the appropriate slave is to be entered into the System Manager twice. All settings, with the exception of Modulo under Additional Data_Exchange Samples on the slave's Features tab, must be the same. A 0 is entered here for the corresponding slave in one of the boxes and a 1 in the other box in the System Manager. The Multiplier under Additional Data_Exchange Samples is to be set for this slave in both boxes to 2, so that each of the two boxes that have been entered is only polled in every second DP cycle (the slave is in fact polled in each DP cycle, as it is entered twice). For all other slaves that are only to be polled once within the task cycle (and which of course are only therefore entered once in the System Manager), the Multiplier under Additional Data_Exchange Samples is also set to 2. Modulo under Additional Data_Exchange Samples can now be used to distribute these slaves over the two cycles. A slave that is polled twice but which is only to have one variable image in the task is only to be inserted once; the Multiplier would be set to 1, and Modulo to 0.

In the present example, slaves 1 and 2 would each be entered into the System Manager twice, with these settings:

  • Additional Data_Exchange Samples/Multiplier = 2
  • Additional Data_Exchange Samples/Modulo = 0 or 1

Slaves 3 and 5 would only be entered into the System Manager once, and would have these settings:

  • Additional Data_Exchange Samples/Multiplier = 2
  • Additional Data_Exchange Samples/Modulo = 0

Slaves 4 and 6 would also only be entered into the System Manager once, with these settings:

  • Additional Data_Exchange Samples/Multiplier = 2
  • Additional Data_Exchange Samples/Modulo = 1

For slaves 1 and 2, the variables are present twice (in each case there 2 boxes in the System Manager). The variables associated with the box where Additional Data_Exchange Samples/Modulo is set to 0 are sent or received first.


FC310x - Sync/Freeze functionality

Sync/Freeze functionality

Sync is used for the simultaneous outputting of outputs for several slaves, Freeze is used for reading in inputs from several slaves simultaneously.

The process in TwinCAT with FC310x and Bus Couplers (in K-Bus synchronous mode) would therefore be as follows (see the Synchronisation section):

  • The outputs are written at the beginning (I/O at the start of the task) or the end (I/O not at the start of the task) of the task cycle
  • This will start the PROFIBUS cycle
  • A Sync/Freeze telegram is sent at the start of the PROFIBUS cycle
  • This will cause the Bus Couplers to start a K-Bus cycle with the outputs from the last task cycle and transfer the inputs from the last K-Bus cycle
  • The master will then send the current outputs to each slave and pick up the transferred inputs
  • The inputs are read at the start of the next task cycle
  • etc.

Outputs and inputs are therefore always one cycle old.

For the FC310x the operation mode is to be set on the master's "FC310x" tab (for TwinCAT 2.8 and TwinCAT 2.9) to "DP/MC (Equidistant)". For the boxes that are to be operated with Sync/Freeze, the Sync/Freeze enable flag is to be clicked on these slave's Profibus tab. The master always uses group 1 for the Sync/Freeze synchronization.


Quick Start TwinCAT CX1500-M310

CX1500-M310: Startup for TwinCAT

Startup of CX1500-M310 for Profibus

The module CX1500-M310 (master connection for Profibus) can, as all other modules of the CX-system, be accessed via the TwinCAT System Manager. The user selects the desired system and search for units in the System Manager (click with right button on I/O Units - this operation is only available in config-mode) After some seconds the connected units are listed. The user selects the devices he / she wants to make use of in the program.

Next the scan for boxes is requested. Answering "yes" starts the scan for boxes connected to the profibus. In some cases not all boxes can be found. Restart scan to find the missing boxes. If there are still boxes missing please check cables and operation mode of the boxes (the mode should be operational)

The status of the Profibus is shown in the upper region of CX1500-M310 entry. The programmer can connect these signals with variables in PLC to analyze them in the program (e.g. error codes for saving states or registers). Below "BOX1" is a status field (DpState and ExtDiagFlag) for transfer diagnosis. Next are the input / output signals. If the box is a bus coupler (see Box 11) the available bus terminals are displayed. Box 2 is a CX1500-B310 with a 1 WORD input signal. The number of the box represents the bus address . In "Free-Run-Mode" of TwinCAT the bus function can be checked easily: Just force a signal by "write online" and see if the control LED ion the terminal lights up.

If the PLC project is loaded the signals can be connected with the variables by double click in signal. (For further details see documentation on TwinCAT). The connected signals are marked by a small arrow on the signal icon. If all signals and variables are connected the new configuration can be saved and loaded onto the CX-System. The PLC program is started via PLC control.


FC310x - Master

Master

As master, the PROFIBUS DP, PROFIBUS DPV1, PROFIBUS DPV2, S5-FDL-AGAG communication and the PROFIDRIVE-PKW interface protocols are supported.

PROFIBUS DP

A summary of the PROFIBUS-DP master functions follows:

Function | Description
Standard DP | The PROFIBUS DP section describes the necessary steps for establishing a DP connection (Set_Prm - parameter, Chk_Cfg - configuration) and for the exchange of user data (Data_Exchange).
Task synchronization | The Synchronisation section describes how the TwinCAT task is synchronized with the PROFIBUS cycle.
Slave priorities | The slaves can receive telegrams with differing cycle times. The necessary settings are described in the Slave Prioritisation/Multiple DP Cycles section.
Multiple DP cycles | In order to receive the most recent possible inputs when the task cycles are long, a number of DP cycles can be carried out for each task cycle, as described in the section on Slave Prioritization/Multiple DP Cycles.
Diagnostic | The diagnostic facilities are described in this section.
Error Reactions | It is possible for different error reactions to be set in the event of a fault (a slave fails or the task is stopped).
Sync/Freeze | Activation of the sync and freeze commands is described in the Sync/Freeze section.
Upload Configuration | The slaves connected to the PROFIBUS can be read via Upload Configuration.
Master redundancy | The Master redundancy section describes the settings required to have a second master with the same configuration configured as a standby master (as from TwinCAT 2.9).

PROFIBUS DPV1

A summary of the PROFIBUS-DPV1 master functions follows:

Function | Description
MSAC_C1 | The MSAC_C1 connection is established along with the cyclic connection. The Read, Write and Data_Transport services are supported.
MSAC_C2 | The MSAC_C2 connection is established independently of the cyclic connection, and can also be used by a second master (while the first one is communicating with the slave over the cyclic MSAC_C1 connection). The Initiate, Abort, Read, Write and Data_Transport services are supported.

PROFIBUS DPV2

A summary of the PROFIBUS-DPV2 master functions follows:

Function | Description
Equidistance | The DPV2 equidistance functionality is described in the PROFIBUS MC section.

S5-FDL-AGAG Communication

S5-FDL-AGAG communication is described in the S5-FDL section.

PROFIDRIVE-PKW Interface

The PROFIDRIVE PKW protocol is implemented in the PROFIBUS master, and can be used by means of acyclic ADS calls.


FC310x - PROFIBUS DP

PROFIBUS DP

Standard DP Operation

In order to configure standard DP operation, proceed as follows in the TwinCAT system manager:

Configure the DP Master

It is first necessary to configure a "PROFIBUS Master FC310x, PCI" I/O device (selecting "I/O devices" with the right hand mouse button, and then selecting "Insert device"). The appropriate channel can be searched for on the "FC310x" tab ("Search" button) and the baud rate, which is set to 12 Mbaud as standard, adjusted if necessary. The tab "FC310x" is described for TwinCAT 2.8 and TwinCAT 2.9.

Add DP slaves

The Beckhoff slaves or devices from other manufacturers are to be configured. All slaves whose GSD files are stored in the system manager's PROFIBUS subdirectory are displayed automatically, sorted according to manufacturer; in order to link other GSD files, "General PROFIBUS box (GSD)" is to be selected under Miscellaneous.

In the case of modular slaves, it is then still necessary to add the terminal/IL modules (for Beckhoff slaves) or the DP module (for devices from other manufacturers).

System Start

TwinCAT Configuration Mode (from TwinCAT 2.9)

For the TwinCAT configuration mode, it is only necessary to exchange data with the configured slaves. To do this, TwinCAT configuration mode is started, and configuration of the DP master is activated using the "Reload devices" button on the toolbar. After this, the data relating to the configured slaves can be read and written on the associated Variables tab from the System Manager.

TwinCAT Run-Mode

For the TwinCAT Run mode, it is now necessary for at least one variable of the PROFIBUS master or of the configured slave to be linked to a task. The project is then to be stored in the registry, and the TwinCAT system then started in Run mode. Data exchange with the slaves is not carried out until the associated task is started. If a number of tasks are linked with the PROFIBUS master or with the configured slave, then whichever task has the highest priority must be started in order for data to be exchanged with the slave.

Bus parameters

TwinCAT 2.8: The PROFIBUS DP Bus parameters are to be found on the device's PROFIBUS tab, and should only be a modified by expert users.

TwinCAT 2.9: The PROFIBUS DP Bus parameters are to be found on the device's Bus-Parameter dialog, which can be selected on the tab FC310x (Button "Bus-Parameter (DP)" , and should only be a modified by expert users.


FC310x - Master redundancy

Master redundancy

It is possible to start the DP master in redundancy mode in order to assemble a redundant controller system. In this case, the DP master only listens to the bus, but is not active on it.

To assemble a redundant controller system, two masters are on the PROFIBUS. The primary master, which performs communication under normal circumstances, and the redundancy master, which only listens to the bus without transmitting, both have identical configurations. The only difference in the PROFIBUS configuration between the primary and redundancy masters should be the setting of the Redundancy Mode and of SetPrm-Unlock before DP Start-Up or SetPrm-Unlock at Shutdown (TwinCAT 2.8: see the master's PROFIBUS tab, TwinCAT 2.9: see master's Fault-Settings dialog), and possibly of the Watchdog of the device (TwinCAT 2.8: see the master's FC310x tab, TwinCAT 2.9: see master's Fault-Settings dialog).

Primary-Master: the Redundancy Mode is not active. The settings of SetPrm-Unlock before DP Start-Up and of SetPrm-Unlock at Shutdown should be deactivated, if there is to be no interaction on the DP slaves when the primary master starts or stops (outputs remain unchanged). It is also necessary for the Watchdog to be set on the device's "FC310x" tab (for TwinCAT 2.8 and TwinCAT 2.9), so that if the PC crashes, the primary master will log itself off the bus.

Redundancy Master: the Redundancy Mode is active. The settings of SetPrm-Unlock before DP Start-Up and of SetPrm-Unlock at Shutdown should be deactivated, if there is to be no interaction on the DP slaves when the primary master starts or stops (outputs remain unchanged).

There are also three counters and a StartRedundancyMasterFlag as interfaces to the PC:

Counter[2] (ReceivedTelegram-Counter): This counter is incremented every time a valid PROFIBUS telegram is received.

Counter[3] (ReceivedTelegramFromPrimary-Counter): This counter is incremented every time a valid PROFIBUS telegram is received from the primary master (which has the same station address as the redundancy master).

Counter[4] (ClaimTokenTimeout-Counter): This counter is incremented every time the redundancy master detects a time-out on the bus after it has taken over bus activity under normal circumstances, i.e. with Redundancy mode deactivated. (ClaimTokenTimeout time = (6 + 2 * station address of the DP master) * slot time).

StartRedundancyMasterFlag: This can be used to start or stop the redundancy master.

The application, which may be the PLC task or another program, is therefore itself responsible for diagnosing the failure of the primary master. This might, for instance, seen from the fact that the ReceivedTelegram Counter and the ReceivedTelegramFromPrimaryMaster Counter are no longer being incremented, the ClaimTokenTimeout Counter is incremented, or because the application-specific monitoring in the two PCs triggers. The redundancy master only becomes active on the bus when the StartRedundancyMaster flag is set. Starting takes approximately 10 x the minimum slave interrupt (TwinCAT 2.8: see the master's PROFIBUS tab, TwinCAT 2.9: see master's Bus-Parameter dialog). When the StartRedundancyMaster flag is reset again, the redundancy master ends its bus activity the next time a token is sent. This will be at the end of the DP cycle, and at the latest after the Estimated Cycle Time (see the device's "FC310x" tab (for TwinCAT 2.8 and TwinCAT 2.9)). The connection to the slave is not removed (independently of the SetPrm-Unlock at Shutdown setting).

When setting the DP slave's DP watchdog (see the box's PROFIBUS tab) it is important to ensure that the DP watchdog time is longer than the application's monitoring time for the primary master plus the start-up time of the redundancy master, so that the redundancy master can take over the DP slave without interactions.

The redundancy master, furthermore, does not update any process data as long as it is only listening to the bus. The DpState of the boxes should be evaluated when it starts; if this is 0, the process data is also up-to-date.


FC310x - Configuration Data - CfgData

Configuration Data - CfgData

The CfgData describes the structure and length of the input and output data that is to be cyclically exchanged via Data_Exchange. There follows a description of the DP configuration data bytes

Bits 4-7 | Meaning
0000B | Module without data. Bits 0-3 indicate how many bytes of manufacturer-specific data are still to follow.
0001B | Inputs of type byte, with no consistency. Bits 0-3 contain the length of the input data minus 1 (i.e. bits 0-3 = 0000B corresponds to a length of one byte, while bits 0-3 = 1111B corresponds to a length of 16 bytes)
0010B | Outputs of type byte, with no consistency. Bits 0-3 contain the length of the output data minus 1 (i.e. bits 0-3 = 0000B corresponds to a length of one byte, while bits 0-3 = 1111B corresponds to a length of 16 bytes)
0011B | Inputs and outputs of type byte, with no consistency. Bits 0-3 contain the length of the input or output data minus 1 (i.e. bits 0-3 = 0000B corresponds to a length of one byte, while bits 0-3 = 1111B corresponds to a length of 16 bytes)
0100B | A special identification format for inputs. A byte follows that describes the associated input data (see below). Bits 0-3 indicate how many bytes of manufacturer-specific data are still to follow.
0101B | Inputs of type word, with no consistency. Bits 0-3 contain the length of the input data minus 1 (i.e. bits 0-3 = 0000B corresponds to a length of one word, while bits 0-3 = 1111B corresponds to a length of 16 words)
0110B | Outputs of type word, with no consistency. Bits 0-3 contain the length of the output data minus 1 (i.e. bits 0-3 = 0000B corresponds to a length of one word, while bits 0-3 = 1111B corresponds to a length of 16 words)
0111B | Inputs and outputs of type word, with no consistency. Bits 0-3 contain the length of the input or output data minus 1 (i.e. bits 0-3 = 0000B corresponds to a length of one word, while bits 0-3 = 1111B corresponds to a length of 16 words)
1000B | A special identification format for outputs. A byte follows that describes the associated output data (see below). Bits 0-3 indicate how many bytes of manufacturer-specific data are still to follow.
1001B | Inputs of type byte, with consistency. Bits 0-3 contain the length of the input data minus 1 (i.e. bits 0-3 = 0000B corresponds to a length of one byte, while bits 0-3 = 1111B corresponds to a length of 16 bytes)
1010B | Outputs of type byte, with consistency. Bits 0-3 contain the length of the output data minus 1 (i.e. bits 0-3 = 0000B corresponds to a length of one byte, while bits 0-3 = 1111B corresponds to a length of 16 bytes)
1011B | Inputs and outputs of type byte, with consistency. Bits 0-3 contain the length of the input or output data minus 1 (i.e. bits 0-3 = 0000B corresponds to a length of one byte, while bits 0-3 = 1111B corresponds to a length of 16 bytes)
1100B | A special identification format for inputs and outputs. A byte first follows that describes the associated output data, and then one describing the associated input data (see below). Bits 0-3 indicate how many bytes of manufacturer-specific data are still to follow.
1101B | Inputs of type word, with consistency. Bits 0-3 contain the length of the input data minus 1 (i.e. bits 0-3 = 0000B corresponds to a length of one word, while bits 0-3 = 1111B corresponds to a length of 16 words)
1110B | Outputs of type word, with consistency. Bits 0-3 contain the length of the output data minus 1 (i.e. bits 0-3 = 0000B corresponds to a length of one word, while bits 0-3 = 1111B corresponds to a length of 16 words)
1111B | Inputs and outputs of type word, with consistency. Bits 0-3 contain the length of the input or output data minus 1 (i.e. bits 0-3 = 0000B corresponds to a length of one word, while bits 0-3 = 1111B corresponds to a length of 16 words)

If the first byte has the type "special identification format", then the second or third bytes have the following meaning:

Bits 6-7 | Meaning
00B | Type byte, with no consistency. Bits 0-5 contain the length of the data minus 1 (i.e. bits 0-5 = 000000B corresponds to a length of one byte, while bits 0-5 = 111111B corresponds to a length of 64 bytes)
01B | Type word, with no consistency. Bits 0-5 contain the length of the data minus 1 (i.e. bits 0-5 = 000000B corresponds to a length of one word, while bits 0-5 = 111111B corresponds to a length of 64 words)
10B | Type byte, with consistency. Bits 0-5 contain the length of the data minus 1 (i.e. bits 0-5 = 000000B corresponds to a length of one byte, while bits 0-5 = 111111B corresponds to a length of 64 bytes)
11B | Type word, with consistency. Bits 0-5 contain the length of the data minus 1 (i.e. bits 0-5 = 000000B corresponds to a length of one word, while bits 0-5 = 111111B corresponds to a length of 64 words)


FC310x - DPV1 Error Codes

DPV1 Error Codes

In the event of an incorrect DPV1 access, the slave replies with 4 bytes of data (any values that are not described here are not defined in the DPV1 standard, and are therefore to be found in the slave's manual):

Byte 0 | DPV1 service
0xD1 | Data_Transport
0xD7 | Initiate
0xDE | Read
0xDF | Write

Byte 1 | Error_Decode
0x80 | DPV1
0xFE | FMS
0xFF | HART

Byte 2 |  | Error_Code_1
Error-Class (bits 4-7) | Error-Code (bits 0-3) |
0x0A | 0x00 | Application, Read Error
 | 0x01 | Application, Write Error
 | 0x02 | Application, Module Failure
 | 0x08 | Application, Version Conflict
 | 0x09 | Application, Feature Not Supported
0x0B | 0x00 | Access, Invalid Index
 | 0x01 | Access, Write Length Error
 | 0x02 | Access, Invalid Slot
 | 0x03 | Access, Type Conflict
 | 0x04 | Access, Invalid Area
 | 0x05 | Access, State Conflict
 | 0x06 | Access, Access Denied
 | 0x07 | Access, Invalid Range
 | 0x08 | Access, Invalid Parameter
 | 0x09 | Access, Invalid Type
0x0C | 0x00 | Resource, Read Constrain Conflict
 | 0x01 | Resource, Write Constrain Conflict
 | 0x02 | Resource, Busy
 | 0x03 | Resource, Unavailable

Byte 3 Error_Code_1


Quick Start TwinCAT CX1500-B310

CX1500-M310: Operation with TwinCAT

Operation of CX1500-M310 for Profibus

The following chapter describes the functions of the Beckhoff PCI card FC310x with TwinCAT (NCI, PLC and IO). TwinCAT Version 2.8 supports all described features except redundancy and ADS interface in slave mode. (Both features are supported since version 2.9) Though the are two descriptions: one for TwinCAT 2.8 and one for TwinCAT version 2.9 and further. If there is no reason to use TwinCAT 2.8 make use of version 2.9 or greater.

Note |
 | The following chapters describe the handling with the PCI card FC310. This card has the same functions and behavior as the PROFIBUS connection of the CX10x0-Systems (CX1500-M310 (Master) or CX1500-B310 (Slave)). The name"FC310x" refers also to CX1500-M310-Master or CX1500-B310-Slave connection.


FC310x - The FC310x Tab

The FC310x Tab

PCI Slot/Irq: Indicates in which logical PCI slot the card was found.

Search...: Searches for all connected FC310x channels. Select those required. In the case of an FC3102 both channels A and B appear. These behave in logical terms like two FC3101 cards.

Hardware Configuration...: The hardware version number of the FC310x can be displayed here.

Upload Configuration …: The PROFIBUS is scanned with this command, and all the devices found are added to the FC310x device. (A box may not be added in TwinCAT 2.8; as from TwinCAT 2.9 scanning can also take place even when boxes are inserted. The FC310x then accepts the new configuration, but does show changes). In the case of Beckhoff boxes, the configuration is read precisely. In the case of external devices, the corresponding GSD file will be searched.

Verify Configuration...: This causes the PROFIBUS to be scanned and compared with the currently inserted boxes. Changes are displayed (from TwinCAT 2.9).

Firmware: This causes the current firmware version of the FC310x to be showed.

Firmware Update...: This command can be used to update the FC310x card firmware.

Stations No.: Each PROFIBUS device requires a unique station number - including the master.

Baudrate: Set the PROFIBUS baud rate.

Operating Mode: In all three operating modes, the highest-priority task linked to the appropriate device will take control of the PROFIBUS cycle and is therefore synchronized with the DP cycle (see the Synchronization section). If this task is stopped or reaches a breakpoint, the FC310x switches to CLEAR mode (slave outputs will assume 0 or safe values) (see the Error Reactions section). All other tasks are served asynchronously via corresponding buffers. If one of these tasks is stopped or reaches a breakpoint, the System Manager will generally display a message saying that the watchdog of the appropriate asynchronous mapping has been activated, and the appropriate outputs are set to 0. For all operating modes, one polling rate per slave can be set (in the Features tab for the Box). The sequence of the slaves in the PROFIBUS cycle corresponds to the sequence in which they are located in the FC310x device tree. The operating mode ”DP” is designed for standard DP operation, the operating modes ”DP/MC (equidistant)” and ”Equidistant (no GC)” are described in section PROFIBUS MC, as well as the parameters NC Access Time, Relation NC Access Time/Cycle Time, PLL Sync Time and Safety Time, the Sync Mode settings and the Calculate Equi-Times button, which are only relevant for PROFIBUS MC.

Cycle Time: Displays the cycle time of the corresponding highest priority task.

Estimated Cycle: Displays the expected PROFIBUS cycle time.

Watchdog Time: Here a watchdog can be activated, which, in case of a PC crash, will cause the FC310x to enter the STOP state and terminate the data exchange with all configured slaves (see Error Reactions). The time is important in Redundancy Mode of the primary master.

Calculate DP-Slave Watchdog Time: This will set the DP watchdog time for all the DP slaves to a reasonable value, in accordance with the formula Estimated cycle time * 10.


FC310x - The Profibus Tab

The PROFIBUS Tab

Slot-Time: The Slot Time indicates how long the DP master will wait for a response from the DP slave before it sends either a repetition or the next telegram.

min. Tsdr: The minimum Tsdr indicates the minimum length of time for which the DP slave will wait with a response. This time is set for all the DP slaves during the DP start-up (the value range is 11-255 bit periods). The minimum Tsdr must be smaller than the maximum Tsdr.

max. Tsdr: The maximum Tsdr indicates the maximum length of time for which the DP slave may wait with a response. This time is set according to the DP slave's GSD file entries. The maximum Tsdr must be smaller than the slot time.

Max-Retry-Limit: The Max Retry Limit specifies how often a telegram should be repeated, if the device addressed does not answer. The minimum value should be 1, so that, in case of an error, there will be at least one repeat for acyclic telegrams (see the Error Reactions section).

Max-Retry-Limit (DX): Since the Data_Exchange telegram is repeated cyclically, a value of 0 could be used for the repetition of the Data_Exchange telegram here, in order to keep the cycle relatively constant in equidistant mode, even if there is no response from a device. However, in this case it would make sense to set the Features tab for the box such that lack of response of the slave would not lead to DATA EXCH being exited. The fact that a device has not responded is apparent from DpState, which would not be equal 0 for one cycle (see the Error Reactions section).

GAP Update: The GAP update asks all stations up to HSA at intervals to confirm their presence. It can be en/disabled. The GAP update is relevant only for multi-master operation. In single master operation it increases PROFIBUS cycle jitter and is therefore switched off by default.

GAP-Factor: The GAP factor determines how often the GAP update will be carried out (assuming it is activated). The time between two GAP updates cycles is Gap factor * Target rot. t.

HSA: The HSA specifies the highest active address up to which the GAP update is carried out (assuming it is active).

Min. Slave-Int.: The MinSlaveInterval indicates the minimum cycle time with which the DP StartUp telegrams are sent the DP slaves (it is determined from the settings found in the GSD file).

PROFIBUS Mode: This is where the selection is made between master functionality (the default setting) and slave functionality.

Auto-Clear-Mode: It is possible to specify here whether the master enters (or stays in) the "Clear" state as long as either at least one MC slave (the "Only MC-Slaves" setting) or any slave (the "All Slaves" setting) does not respond correctly (has a DpState other than 0) (see the Error Reactions section).

Clear-Delay: The DP master changes automatically into the clear mode (the outputs of the slaves are set either to 0 or to the fail-safe value) when it ceases to receive an interrupt from the associated task (e.g. a PLC breakpoint has been reached, or the system has crashed). It is possible to specify here how many missing tasks cycles can be tolerated before the master switches into the clear mode. This setting is independent of the setting in the Auto-Clear-Mode.

Operate-Delay: The DP master changes automatically, observing the Auto-Clear-Mode, into the operate state when the task is started. The transition from Clear to Operate can be delayed or with the Operate delay time. In the Clear state, all the outputs are set to 0 (if the DP slave does not support Fail_Safe values) or to the Fail_Safe value (if the DP slave supports Fail_Safe), whereas in the Operate state the outputs have the values specified by the task.

Reaction on PLC-STOP: It is possible to specify here whether the DP master should set the outputs to 0 when reaching a PLC stop or breakpoint, or should leave them unchanged (see the Fault Reactions section).

Redundancy-Mode: Redundancy mode can be set here for the DP master. In that case all that it does is to listen to the bus (see the Master Redundancy section).

SetPrm-Unlock before DP-Start-Up: Normally, during DP start-up, the DP master removes the cyclic connections, so that the DP slave can always recognise that the DP master has restarted. In redundancy mode, however, it may be specifically desirable for the DP slave to remain unaware of this, because the switch-over from the primary master to the redundant master should not have any interactions for the DP slave (see the Master Redundancy section).

SetPrm-Unlock at DP-Shutdown: Normally, during DP shut-down, the DP master removes the cyclic connections, so that the DP slave can always recognise that the DP master has stopped. In redundancy mode, however, it may be specifically desirable for the DP slave to remain unaware of this, because the switch-over from the primary master to the redundant master should not have any interactions for the DP slave (see the Master Redundancy section).


FC310x - The ADS Tab

The ADS Tab

The FC310x is an ADS device with its own net ID, which can be changed here. All ADS services (diagnosis, acyclical communication) going to the FC310x must address this net ID.


FC310x - The General Diag Tab

The General Diag Tab

Here, bus cabling problems and DP cycle times are displayed:

detected bus errors: Here, the number of detected bus errors is displayed. If this counter is not equal 0, the cabling should be checked (provided that no PROFIBUS connectors were pulled or inserted - usually there are short bus disturbances during pulling or inserting of PROFIBUS connectors).

CycleWithRepeatCounter: Here, the number of PROFIBUS cycles is displayed, in which a telegram was repeated at lease once. Repetitions are also an indication that the physical bus characteristics are not 100% OK.

max. Repeat/Cycle: Here, the maximum number of repetitions within a cycle is displayed.

min./max./actual Cycle-Time: Here, the minimum, maximum and current DP cycle time is displayed. Only those cycles are considered, during which all slaves participated in the data exchange and no repetitions occurred.

CycleWithNoDxch-Counter: Increments if not all slaves participate in the data exchange (i.e. have a DpState not equal 0).

Real Failed-Cycle-Counter: Increments if the DP cycle was not completed before the next task cycle began and all the slaves are involved in the data exchange (i.e. have a DpState of 0).


FC310x - The EquiDiag Tab

The EquiDiag Tab

The ”EquiDiag” tab is available for displaying various equidistant monitoring parameters online:

TcIo-Statistics

max. TwinCAT-Jitter: Here, the maximum TwinCAT jitter is displayed; the measurement is reset as soon as the tab is no longer active.

min./max. Mapping Time or NC Access Time: Here, the minimum or maximum NC Access Time is displayed. Apart from the Mapping Time, this also contains the task run-time (provided that ”IO at Task Start” for the highest-priority task linked to the FC310x (usually the NC task) is set).

The NC Access Time should be greater than the sum of the two measured times (max. TwinCAT Jitter plus max. Mapping Time or (NC) Task Time), with a safety margin of approx. 10%.

max. FCxxxx Jitter: This is only relevant for Sync Mode = ”disabled”. If the value is greater than 5, real time jitter will become excessive, and a more powerful PC should be used. If the associated (NC) task does not have the highest priority, the maximum FCxxxx jitter can also be larger. This should be avoided.

FC310x-Statistics

Since the PROFIBUS MC slaves should always be added to the FC310x device first, they are always addressed before the DP slaves in the DP cycle. This part of the DP cycle will be called Equi-Cycle below. If the Equi-Cycle becomes greater than the To-time of the MC slaves, the last MC slaves at the FC310x device will usually get a synchronization error (error 597 or 598 for Simodrive 611U).

max. Repeats/Equi-Cycle: This will show the maximum number of repeated Data_Exchange telegrams during an Equi-Cycle. This will extend the Equi-Cycle, usually no repetitions should occur (unless a bus plug was pulled or an MC slave was switched off).

min./max. Equi-Cycle: Here, the minimum or maximum Equi-Cycle Time is displayed.

Equi-Cycle-Repeat-Counter: Here, the number of telegram repetitions within the Equi-Cycle is displayed.

Equi-Cycle-NoDxch-Counter: Here, the number of occurrences is displayed, for which not all MC slaves were in data exchange during an Equi-Cycle.

FC310x-Failed Counter

Sync-Failed-Counter: This counter will increment if TwinCAT task and DP cycle are not synchronized with each other. This may happen during start-up of the TwinCAT system, after which this counter should no longer increment. If the associated (NC) task does not have the highest priority, this counter can also increment. This should be avoided.

Time-Control-Failed-Counter: This counter will increment if the PROFIBUS was not free at the time of the DP cycle start. Possible causes are bus faults, non-existent device, a second master or a safety time that is too small.

PLL-Overflow-/-Underflow-Counter: This counter is only relevant during Sync mode ”disabled” and will increment in case of excessive jitter of the TwinCAT task which the DP cycle uses for synchronization (this may happen, for example, if the DP cycle is not synchronized with the highest-priority task). If the associated (NC) task does not have the highest priority, this counter can also increment. This should be avoided.

To-Statistics

For each MC slave the To-time specifies when, relative to the DP cycle start, the slave should accept the outputs received from the master. The MC slaves can be synchronized with each other, if the same To value is set for all MC slaves. However, this value must be equal or greater than the Equi-Cycle Time plus a safety margin of approx. 200 µs. The To-time is calculated for all MC slaves via the button "Calc. Equi-Times" (see above).

calc. To-Reserve: This contains the calculated To-reserve (To-time - Equi-Cycle Time)

min./max. To-Reserve: Here, the min. or max. To-reserve is measured.

Max. GC jitter (from TwinCAT 2.8)

Here, the maximum jitter of the DP cycle is measured (GC for global control telegram, which is always sent at the start of a cycle). During start-up, the jitter may be somewhat greater, in the steady state it should not exceed 1 µs (for Sync mode "Sync Master") or 2 µs (for Sync mode "Disabled").


FC310x - The Profibus Tab

The Bus-Parameter Dialog

Slot-Time: The Slot Time indicates how long the DP master will wait for a response from the DP slave before it sends either a repetition or the next telegram.

min. Tsdr: The minimum Tsdr indicates the minimum length of time for which the DP slave will wait with a response. This time is set for all the DP slaves during the DP start-up (the value range is 11-255 bit periods). The minimum Tsdr must be smaller than the maximum Tsdr.

max. Tsdr: The maximum Tsdr indicates the maximum length of time for which the DP slave may wait with a response. This time is set according to the DP slave's GSD file entries. The maximum Tsdr must be smaller than the slot time.

GAP-Factor: The GAP factor determines how often the GAP update will be carried out (assuming it is activated). The time between two GAP updates cycles is Gap factor * Target rot. t.

Max-Retry-Limit: The Max Retry Limit specifies how often a telegram should be repeated, if the device addressed does not answer. The minimum value should be 1, so that, in case of an error, there will be at least one repeat for acyclic telegrams (see the Error Reactions section).

Max-Retry-Limit (DX): Since the Data_Exchange telegram is repeated cyclically, a value of 0 could be used for the repetition of the Data_Exchange telegram here, in order to keep the cycle relatively constant in equidistant mode, even if there is no response from a device. However, in this case it would make sense to set the Features tab for the box such that lack of response of the slave would not lead to DATA EXCH being exited. The fact that a device has not responded is apparent from DpState, which would not be equal 0 for one cycle (see the Error Reactions section).

HSA: The HSA specifies the highest active address up to which the GAP update is carried out (assuming it is active).

Min. Slave-Int.: The MinSlaveInterval indicates the minimum cycle time with which the DP StartUp telegrams are sent the DP slaves (it is determined from the settings found in the GSD file).

PROFIBUS Mode: This is where the selection is made between master functionality (the default setting) and slave functionality.

Redundancy-Mode: Redundancy mode can be set here for the DP master. In that case all that it does is to listen to the bus (see the Master Redundancy section).

GAP Update: The GAP update asks all stations up to HSA at intervals to confirm their presence. It can be en/disabled. The GAP update is relevant only for multi-master operation. In single master operation it increases PROFIBUS cycle jitter and is therefore switched off by default.

Optimize Bus-Parameter: Sets the optimized Bus-Parameter settings.

Default Bus-Parameter: Sets the default Bus-Parameter settings.


FC310x - The FC310x Tab

The MC Tab

Task-Access-Time (Shift-Time): This time must be greater than the maximum TwinCAT jitter plus the maximum mapping time (see chapter PROFIBUS MC)

Task-Access-Time/Task Cycle-Time: This relation ist helpful when using the Calculate MC-Times-Button to avoid adapting the Task-Access-Time manually after using this button.

PLL-Sync-Time: Only necessary for Sync-Mode Disabled, sets the PLL-Window on the FC310x

Task Cycle Time: Displays the cycle time of the corresponding highest priority task.

Estimated DP-Cycle Time: Displays the expected PROFIBUS cycle time.

Estimated Mapping Time: Displays the expected Mapping time.

Set To on Box: The To-Time can set individually for each slave on the tab Prm Data(Text) of the box.

Set Ti on Box: The Ti-Time can set individually for each slave on the tab Prm Data(Text) of the box.

To-Time: If the Check-Box Set To on Box is not selected, the To-Time can set unique for all slaves.

Ti-Time: If the Check-Box Set Ti on Box is not selected, the Ti-Time can set unique for all slaves.

Estimated Equi-Cycle Time: Displays the expected DPV2-part of PROFIBUS cycle time.

Calculate MC-Times: This button causes all DPV2-times to be calculated.

Sync-Mode: The Sync-Mode decides, if the FC follows the PC (Disabled) or the PC follows the FC (Master) to synchronize the TwinCAT- with the PROFIBUS-cycle.


FC310x - The FC310x Tab

The FC310x Tab

PCI Slot/Irq: Indicates in which logical PCI slot the card was found.

Search...: Searches for all connected FC310x channels. Select those required. In the case of an FC3102 both channels A and B appear. These behave in logical terms like two FC3101 cards.

Identify Device...: A LED-Code will be displayed on the corresponding FC310x channel.

Stations No.: Each PROFIBUS device requires a unique station number - including the master.

Baudrate: Set the PROFIBUS baud rate.

Bus-Parameter (DP)...: The dialog Bus-Parameter can be opened here.

Operating Mode: In all three operating modes, the highest-priority task linked to the appropriate device will take control of the PROFIBUS cycle and is therefore synchronized with the DP cycle (see the Synchronisation section). If this task is stopped or reaches a breakpoint, the FC310x switches to CLEAR mode (slave outputs will assume 0 or safe values) (see the Error Reactions section). All other tasks are served asynchronously via corresponding buffers. If one of these tasks is stopped or reaches a breakpoint, the System Manager will generally display a message saying that the watchdog of the appropriate asynchronous mapping has been activated, and the appropriate outputs are set to 0. For all operating modes, one polling rate per slave can be set (in the Features tab for the Box). The sequence of the slaves in the PROFIBUS cycle corresponds to the sequence in which they are located in the FC310x device tree. The operating mode ”DP” is designed for standard DP operation, the operating modes ”DP/MC (equidistant)” and ”Equidistant (no GC)” are described in section PROFIBUS MC

Cycle Time: Displays the cycle time of the corresponding highest priority task.

Estimated Cycle: Displays the expected PROFIBUS cycle time.

DP-Cycles/Task-Cycle: To get newer inputs more than one DP-cycle can be operated during one Task-cycle (s. chapter Slave Prioritisation/Multiple DP Cycles).

Timing DP-Cycle...: The timing of the DP-cycle will be displayed here, especially useful for the Slave Prioritisation.

Start-Up/Fault-settings...: The dialog Fault-Settings will be opened here.

Firmware: This causes the current firmware version of the FC310x to be showed.

Firmware Update...: This command can be used to update the FC310x card firmware.

Hardware Configuration...: The hardware version number of the FC310x can be displayed here.

Upload Configuration …: The PROFIBUS is scanned with this command, and all the devices found are added to the FC310x device. (A box may not be added in TwinCAT 2.8; as from TwinCAT 2.9 scanning can also take place even when boxes are inserted. The FC310x then accepts the new configuration, but does show changes). In the case of Beckhoff boxes, the configuration is read precisely. In the case of external devices, the corresponding GSD file will be searched.

Verify Configuration...: This causes the PROFIBUS to be scanned and compared with the currently inserted boxes. Changes are displayed (from TwinCAT 2.9).


FC310x - The Profibus Tab

The Fault-Settings Dialog

SetPrm-Unlock before DP-Start-Up: Normally, during DP start-up, the DP master removes the cyclic connections, so that the DP slave can always recognize that the DP master has restarted. In redundancy mode, however, it may be specifically desirable for the DP slave to remain unaware of this, because the switch-over from the primary master to the redundant master should not have any interactions for the DP slave (see the Master Redundancy section).

SetPrm-Unlock at DP-Shutdown: Normally, during DP shut-down, the DP master removes the cyclic connections, so that the DP slave can always recognize that the DP master has stopped. In redundancy mode, however, it may be specifically desirable for the DP slave to remain unaware of this, because the switch-over from the primary master to the redundant master should not have any interactions for the DP slave (see the Master Redundancy section).

Operate-Delay: The DP master changes automatically, observing the Auto-Clear-Mode, into the operate state when the task is started. The transition from Clear to Operate can be delayed or with the Operate delay time. In the Clear state, all the outputs are set to 0 (if the DP slave does not support Fail_Safe values) or to the Fail_Safe value (if the DP slave supports Fail_Safe), whereas in the Operate state the outputs have the values specified by the task.

Reaction on Task-STOP: It is possible to specify here whether the DP master should set the outputs to 0 when reaching a PLC stop or breakpoint, or should leave them unchanged (see the Fault Reactions section).

Task-Watchdog: The DP master changes automatically into the clear mode (the outputs of the slaves are set either to 0 or to the fail-safe value) when it ceases to receive an interrupt from the associated task (e.g. a PLC breakpoint has been reached, or the system has crashed). It is possible to specify here how many missing tasks cycles can be tolerated before the master switches into the clear mode. This setting is independent of the setting in the Clear-Mode.

Clear-Mode: It is possible to specify here whether the master enters (or stays in) the "Clear" state as long as either at least one MC slave (the "Only MC-Slaves" setting) or any slave (the "All Slaves" setting) does not respond correctly (has a DpState other than 0) (see the Error Reactions section).

Windows-Watchdog: Here a watchdog can be activated, which, in case of a PC crash, will cause the FC310x to enter the STOP state and terminate the data exchange with all configured slaves (see Error Reactions). The time is important in Redundancy Mode of the primary master.

Set WD individually for each Slave: It can be selected here, if the DP-Watchdog should be set for each slave individually (on the tab PROFIBUS of the box)

DP-Watchdog-Time: If the Check-Box "Set WD individually for each Slave" is not selected, a unique DP-Watchdog for all slaves can be set here.

Calculate DP-Slave Watchdog Time: This will set the DP watchdog time for all the DP slaves to a reasonable value.


FC310x - The General Diag Tab

The DP-Diag Tab

Here, bus cabling problems and DP cycle times are displayed:

detected bus errors: Here, the number of detected bus errors is displayed. If this counter is not equal 0, the cabling should be checked (provided that no PROFIBUS connectors were pulled or inserted - usually there are short bus disturbances during pulling or inserting of PROFIBUS connectors).

CycleWithRepeatCounter: Here, the number of PROFIBUS cycles is displayed, in which a telegram was repeated at lease once. Repetitions are also an indication that the physical bus characteristics are not 100% OK.

max. Repeat/Cycle: Here, the maximum number of repetitions within a cycle is displayed.

min./max./actual Cycle-Time: Here, the minimum, maximum and current DP cycle time is displayed. Only those cycles are considered, during which all slaves participated in the data exchange and no repetitions occurred.

CycleWithNoDxch-Counter: Increments if not all slaves participate in the data exchange (i.e. have a DpState not equal 0).

Real Failed-Cycle-Counter: Increments if the DP cycle was not completed before the next task cycle began and all the slaves are involved in the data exchange (i.e. have a DpState of 0).


FC310x - The EquiDiag Tab

The MC-Diag Tab

The ”MC-Diag” tab is available for displaying various equidistant monitoring parameters online:

TcIo-Statistics

max. TwinCAT-Jitter: Here, the maximum TwinCAT jitter is displayed; the measurement is reset as soon as the tab is no longer active.

min./max. Mapping Time or NC Access Time: Here, the minimum or maximum NC Access Time is displayed. Apart from the Mapping Time, this also contains the task run-time (provided that ”IO at Task Start” for the highest-priority task linked to the FC310x (usually the NC task) is set).

The NC Access Time should be greater than the sum of the two measured times (max. TwinCAT Jitter plus max. Mapping Time or (NC) Task Time), with a safety margin of approx. 10%.

max. FCxxxx Jitter: This is only relevant for Sync Mode = ”disabled”. If the value is greater than 5, real time jitter will become excessive, and a more powerful PC should be used. If the associated (NC) task does not have the highest priority, the maximum FCxxxx jitter can also be larger. This should be avoided.

FC310x-Statistics

Since the PROFIBUS MC slaves should always be added to the FC310x device first, they are always addressed before the DP slaves in the DP cycle. This part of the DP cycle will be called Equi-Cycle below. If the Equi-Cycle becomes greater than the To-time of the MC slaves, the last MC slaves at the FC310x device will usually get a synchronization error (error 597 or 598 for Simodrive 611U).

max. Repeats/Equi-Cycle: This will show the maximum number of repeated Data_Exchange telegrams during an Equi-Cycle. This will extend the Equi-Cycle, usually no repetitions should occur (unless a bus plug was pulled or an MC slave was switched off).

min./max. Equi-Cycle: Here, the minimum or maximum Equi-Cycle Time is displayed.

Equi-Cycle-Repeat-Counter: Here, the number of telegram repetitions within the Equi-Cycle is displayed.

Equi-Cycle-NoDxch-Counter: Here, the number of occurrences is displayed, for which not all MC slaves were in data exchange during an Equi-Cycle.

FC310x-Failed Counter

Sync-Failed-Counter: This counter will increment if TwinCAT task and DP cycle are not synchronized with each other. This may happen during start-up of the TwinCAT system, after which this counter should no longer increment. If the associated (NC) task does not have the highest priority, this counter can also increment. This should be avoided.

Time-Control-Failed-Counter: This counter will increment if the PROFIBUS was not free at the time of the DP cycle start. Possible causes are bus faults, non-existent device, a second master or a safety time that is too small.

PLL-Overflow-/-Underflow-Counter: This counter is only relevant during Sync mode ”disabled” and will increment in case of excessive jitter of the TwinCAT task which the DP cycle uses for synchronization (this may happen, for example, if the DP cycle is not synchronized with the highest-priority task). If the associated (NC) task does not have the highest priority, this counter can also increment. This should be avoided.

To-Statistics

For each MC slave the To-time specifies when, relative to the DP cycle start, the slave should accept the outputs received from the master. The MC slaves can be synchronized with each other, if the same To value is set for all MC slaves. However, this value must be equal or greater than the Equi-Cycle Time plus a safety margin of approx. 200 µs. The To-time is calculated for all MC slaves via the button "Calc. Equi-Times" (see above).

calc. To-Reserve: This contains the calculated To-reserve (To-time - Equi-Cycle Time)

min./max. To-Reserve: Here, the min. or max. To-reserve is measured.

Max. GC jitter (from TwinCAT 2.8)

Here, the maximum jitter of the DP cycle is measured (GC for global control telegram, which is always sent at the start of a cycle). During start-up, the jitter may be somewhat greater, in the steady state it should not exceed 1 µs (for Sync mode "Sync Master") or 2 µs (for Sync mode "Disabled").


FC310x - The Profibus Tab

The PROFIBUS Tab

Stations No.: Here, the PROFIBUS station address must be set for each slave. For some slaves, the station address cannot be set in the hardware, but only via the SetSlaveAddress service. In this case, the button ”Set..” should be pressed. This will open a dialog, through which transmission of a SetSlaveAddress telegram can be triggered.

Watchdog: Activates the DP watchdog. If the slave does not receive a DP telegram for the duration of the watchdog time with the watchdog switched on, it will automatically exit the data exchange. The minimum watchdog time to be set depends on the DP cycle time, and should be larger than the value calculated by the following formula: Estimated-Cycle-Time * 10

For particularly critical outputs it is possible to set a DP watchdog time down to as little as 2 ms for DP slaves that support a watchdog base time of 1 ms (namely all Beckhoff slaves with the exception of the BK3000 and BK3100, and any devices from other manufacturers whose GSD file contains the entry "WD_Base_1ms_supp = 1"). The DP watchdog time should, however, be at least twice as long as the greater of the Cycle time and the Estimated cycle time (see the master's FC310x tab).

Ident No.: Here, the Ident number from the GSD file is displayed.

PrmData: Allows editing of the PROFIBUS-specific parameter data. The values of the current parameter data are also displayed. The PrmData can usually be set as text (-> PrmData (text)) or for Beckhoff DP slaves partly via the ”Beckhoff” tab.

CfgData: The current configuration data (resulting from the attached modules or terminals) as well as their length is displayed.

Sync/Freeze: In operating mode DP/MC (equidistant) of the master, slaves can be operated with Sync and Freeze.

DPV1 Class 2: With FC310x, a DPV1 class 2 connection to a DPV1 slave can be activated. This is a good idea, for example, if the DP slave is in data exchange with another master, but should nevertheless be addressed acyclically by TwinCAT. The class 2 connection monitoring time is set via the timeout parameter (see section DPV1).

DP Class 2: ”No Cyclic Connection” or ”ReadOnly” should be selected under DP class 2, if the DP slave is in data exchange with another master, but should nevertheless be addressed acyclically by TwinCAT, or the DP inputs and outputs should be read cyclically. If "ReadOnly" is selected, then the modules are to be selected as in the case of the normal cyclic connection. They all, however, appear in the TwinCAT system with input variables, regardless of whether they are in fact input or output modules (ReadOnly only as from firmware version 3.00).

ResetSlave: With this button, provided TwinCAT has been started, cyclic data exchange with the DP slave can be disabled and re-established immediately (corresponds to a IO reset but only for the one slave).


FC310x - Features Tab

Features Tab

Data_Exchange Poll-Rate: A different polling rate (Divider) can be set for each slave. Divider 1 means that the slave is polled during each cycle, Divider 2 means every 2nd cycle, etc. The modulo will distribute slaves with dividers greater than 1 across different cycles in order to minimize the maximum cycle time (divider 2 and modulo 0 means that the slave is polled every even-numbered cycle, divider 2 and modulo 1 means that the slave is polled every oddly-numbered cycle). (see the section on Slave Prioritisation/Multiple DP Cycles).

Additional Data_Exchange Samples: It is possible to run a number of DP cycles within one task cycle. It is then optionally possible for each slave to be supplied with different output data in each DP cycle, and for the input data from each of those DP cycles to be transferred to the controller. In this case, there is an individual set of variables for each DP cycle (see the section on Slave Prioritisation/Multiple DP Cycles).

NoAnswer-Reaction: You can specify, for each slave, whether it should remain in the Data Exch, despite responding incorrectly or not at all. In this case (Stay in Data-Exch), data exchange is only exited if the slave has never responded correctly within the address monitoring time (provided the watchdog (see the box's PROFIBUS tab) is activated, otherwise data exchange is only terminated once the slave has not responded correctly 65,535 times) (see the Error Reactions section).

Restart-Behavior: It is possible to specify for each slave whether, after leaving Data-Exch, it should automatically start up again, or should remain in the Wait-Prm state (see the Error Reactions section).

Reaction of the Master: You can specify for each slave, whether its exit from Data-Exch should cause the PROFIBUS cycle to stop (all slaves abandon data exchange and go into Wait Prm mode, restart after IO reset or TwinCAT system restart) (see the Error Reactions section).

Changes of the Input Data: For each slave it can be specified whether, on exiting of Data Exch (DpState not equal 0), its input data should be set to 0 or remain unchanged (see the Error Reactions section).

acyclic Services: The number of parallel ADS services to one box can be set here.


FC310x - The PrmData (text) tab

The PrmData (text) tab

Click on a line to change the current value. The description of the respective settings can be found in the documentation of the relevant manufacturer.


FC310x - The Diag Tab

The Diag Tab

The following information can be displayed here:

BoxState: The current DpState is displayed here.

Receive-Error-Counter: Number of disturbed telegrams from the slave.

Repeat-Counter: Number of required repetitions due to missing or disturbed response from the slave.

NoAnswer-Counter: Number of telegrams that remained unanswered by the slave.

Last DPV1 error: Error-Decode, Error-Class, Error-Code and Error-Code 2 (see description of the DPV1 Error Codes)

For Beckhoff DP slaves, further diagnostic information will be displayed.


FC310x - ADS Interface

ADS Interface

All acyclic data are transmitted to or from the FC310x via ADS-Read, ADS-Write or ADS-Write-Control. The FC310x has its own Net-ID and supports the following ports:

Port | Description
200 | This addresses the FC310x itself, i.e. data that reside locally on the FC310x, and for which usually no additional bus access is required
0x1000 - 0x107E | This addresses a connected PROFIBUS device, with the address calculated from port-0x1000; this always involves a bus access

ADS-Read

An overview of the IndexGroups/IndexOffsets supported by the FC310x during ADS-Read is provided below.

IndexGroup for local FC310x addressing (port 200)

IndexGroup (Lo-Word) | IndexGroup (Hi-Word) | IndexOffset | Description
0xF100 | 0x00 | BYTE offset within the data | This reads the diagnostic data from the FC310x. If the ADS-Read is answered without error (error code = 0), the data will contain the diagnostic data of the FC310x described in section Master-Diagnose. The FC310x will reset the FC310x DiagFlag. It will be set again, if the FC310x diagnostic data change again.
0xF181 | 0x00-0x7E | BYTE offset within the data | This will read the diagnostic data of a configured DP slave. The station address is calculated from the IndexGroup(Hi-Word). If the ADS Read is answered without error (error code = 0), the data will contain the diagnostic data of a configured DP slave described in section Slave-Diagnose.
0xF830 | 0x8000-0x807E | always 0 | This enables detection of the DP slaves present at the PROFIBUS, independent of whether they were configured or not. The station address is calculated from IndexGroup(Hi-Word)-0x8000. If the ADS-Read is answered without error (error code = 0), the corresponding DP slave has answered correctly. The data contain the Ident no. of the slave (BYTE offset 0-1) and the read CfgData (from BYTE offset 2) (see section Upload Configuration).
0xF840 | 0 | BYTE offset within the data | This will read the firmware version and the station address of the FC310x. If the ADS-Read is answered without error (error code = 0), the data will contain the firmware version (BYTE offset 0-1) and the station address of the FC310x (BYTE offset 2).

IndexGroup for addressing of a configured PROFIBUS device (port 0x1000-0x107E)

IndexGroup (Lo-Word) | IndexGroup (Hi-Word) | IndexOffset | Description
0x00-0xFF | 0x00 | 0x00-0xFF | This will send a DPV1-Read to the appropriate, configured DPV1 slave via a Class 1 connection; the DPV1 slot number corresponds to the IndexGroup, the DPV1 index corresponds to the IndexOffset. If the ADS-Read is answered without error (error code = 0), the data will contain the read DPV1 data (see section DPV1)
0x100-0x1FF | 0x00 | 0x00-0xFF | This will send a DPV1-Read to the appropriate, configured DPV1 slave via a Class 2 connection; the DPV1 slot number corresponds to the IndexGroup - 0x100, the DPV1 index corresponds to the IndexOffset. If the ADS-Read is answered without error (error code = 0), the data will contain the read DPV1 data (see section DPV1)
0x0000 - 0xFFF | 0x10000000 - 0xF0000000 | 0x00-0xFF | This will transmit a PKW-Read to the appropriate, configured PROFIDRIVE slave; the parameter number (PNU) is contained in the Low WORD of the IndexGroup, the sub-index for access to an array is in the IndexOffset, the addressed axis is in bits 28-31 of the IndexGroup (for a 1-axis unit, this must be 1), the PKW compatibility can be adjusted in bits 26, 27 (unfortunately, not all PROFIDRIVE slaves are compatible, see section PKW-Interface).
0 | 0x01000000 | 0 | This will send FDL-Read for Siemens AG interfacing to the appropriate configured FDL station (see section S5-FDL).

ADS-Write

An overview of the IndexGroups/IndexOffsets supported by the FC310x during ADS-Write is provided below.

IndexGroup for local FC310x addressing (port 200)

IndexGroup (Lo-Word) | IndexGroup (Hi-Word) | IndexOffset | Description
0xF100 | 0x00 | 0 -2 | This will reset the equidistant diagnostic data (IndexOffset = 0), the Repeat counters (IndexOffset = 1) or the NoAnswer counters (IndexOffset = 2) of the FC310x.

IndexGroup for addressing of a configured PROFIBUS device (port 0x1000-0x107E)

IndexGroup (Lo-Word) | IndexGroup (Hi-Word) | IndexOffset | Description
0x00-0xFF | 0x00 | 0x00-0xFF | This will send a DPV1-Write to the appropriate, configured DPV1 slave via a Class 1 connection; the DPV1 slot number corresponds to the IndexGroup, the DPV1 index corresponds to the IndexOffset (see section DPV1).
0x100-0x1FF | 0x00 | 0x00-0xFF | This will send a DPV1-Write to the appropriate, configured DPV1 slave via a Class 2 connection; the DPV1 slot number corresponds to the 0x100 IndexGroup, the DPV1 index corresponds to the IndexOffset (see section DPV1).
0x400 | 0x00 | 0x00 | With this, a DPV1 Abort is sent to the appropriate configured DPV1 slave via a class 2 connection; the abort parameters are included in the data (-> section DPV1).
0x0000 - 0xFFF | 0x10000000 - 0xF0000000 | 0x00-0xFF | This will transmit a PKW-Write to the appropriate, configured PROFIDRIVE slave; the parameter number (PNU) is contained in the Low WORD of the IndexGroup, the sub-index for access to an array is in the IndexOffset, the addressed axis is in bits 28-31 of the IndexGroup (for a 1-axis unit, this must be 1), the PKW compatibility can be adjusted in bits 26, 27 (unfortunately, not all PROFIDRIVE slaves are compatible, see section PKW-Interface).
0 | 0x01000000 | 0 | This will send FDL-Write for Siemens AG interfacing to the appropriate configured FDL station (see section S5-FDL).
0 | 0x02000000 | 0 | This will send a SetSlaveAddress command to a configured DP slave, whereby the DP slave must be configured with the new station address; the old station address must be entered at BYTE offset 0 of the ADS-Write data. Furthermore, the Ident no. of the slave must be contained under BYTE offset 1 and 2, and BYTE offset 3 must contain information as to whether the slave may be modified later (0) or not (not equal 0). Altogether, 4 bytes of ADS-Write data will therefore have to be sent.

ADS-ReadWrite

An overview of the IndexGroups/IndexOffsets supported by the FC310x during ADS-ReadWrite is provided below.

IndexGroup for addressing of a configured PROFIBUS device (port 0x1000-0x107E)

IndexGroup (Lo-Word) | IndexGroup (Hi-Word) | IndexOffset | Description
0x100-0x1FF | 0x00 | 0x00-0xFF | This will send a DPV1-Data_Transport to the appropriate, configured DPV1 slave via a Class 2 connection; the DPV1 slot number corresponds to the 0x100 IndexGroup, the DPV1 index corresponds to the IndexOffset (see section DPV1).
0x200 | 0x00 | 0x00 | With this, a DPV1 Initiate is sent to the appropriate configured DPV1 slave via a class 2 connection; the initiate parameters are included in the data (-> section DPV1).

ADS-WriteControl

An overview of the ADS-Write-Control commands supported by the FC310x is provided below.

ADS-WriteControl for local FC310x addressing (port 200)

AdsState | DeviceState | State of the FC310x | Description
STOP (6) | 0x00 | RUN (5) | This will stop the FC310x, i.e. the process data connections to all DP slaves (Data_Exchange) are removed (with SetPrm,Unlock).
RUN (5) | 0x00 | STOP (6) | This will restart the FC310x after a stop, i.e. the process data connections to all DP slaves (Data_Exchange) are re-established (normal DP start-up).

ADS-WriteControl for addressing a configured PROFIBUS device (port 0x1000-0x107E)

AdsState | DeviceState | State of the FC310x | Description
STOP (6) | 0x00 | RUN (5) | This will stop the slave, i.e. the process data connection to the relevant DP slave (Data_Exchange) is removed (with SetPrm,Unlock).
RUN (5) | 0x00 | STOP (6) | This will restart the slave after a stop, i.e. the process data connection to the relevant DP slave (Data_Exchange) is re-established (normal DP start-up).

ADS Error Codes

The 32 bit ADS error code always consists of a general ADS error code (Low Word, see ADS documentation) and a FC310x-specific, unique error code (High Word, -> chapter FC310x ADS error codes). The appropriate text message will also be displayed in the TwinCAT System Manager Logger.


FC310x - PROFIBUS DPV1

PROFIBUS DPV1

On a C1 connection, the master supports the Read and Write services, and on the C2 connection it supports the Read, Write, Data_Transport, Initiate and Abort services.

C1 Connection (MSAC-C1)

The C1 connection is reserved for the master that cyclically exchanges data with the slave (C1 master). In order for a slave to be able to use the C1 connection, the slave must support DPV1 (this means that the line "DPV1_Slave = 1" and the key word "C1_Max_Data_Len" with an appropriate length must be in the GSD file). If it is also generally necessary to activate the C1 functionality by setting bit 7 in the PrmData byte 0 (see the slave's PROFIBUS tab) for the corresponding slave (this is done automatically for those Beckhoff devices that support DPV1).

MSAC-C1-Read is shown in ADS-Read, and MSAC-C1-Write is represented in ADS-Write:

MSAC-C1 Read

ADS-Read parameters | Meaning
Net-ID | Net-ID of the master (see the device's ADS tab)
Port | 0x1000 + station address of the slave
IndexGroup | Slot number (DPV1 parameter)
IndexOffset | Index (DPV1 parameter)
Length | Length of the data that is to be read
Data | In response: data that has been read

MSAC-C1 Write

ADS-Write parameters | Meaning
Net-ID | Net-ID of the master (see the device's ADS tab)
Port | 0x1000 + station address of the slave
IndexGroup | Slot number (DPV1 parameter)
IndexOffset | Index (DPV1 parameter)
Length | Length of the data that is to be written
Data | In request: data that is to be written

C2 Connection (MSAC-C2)

The C2 connection is as a rule intended for a second master (C2 master) that does not communicate with the slave cyclically, but it is also possible for the C1 master to make use of the C2 connection. In order for a slave to be able to use the C2 connection, the slave must support DPV1 (this means that the line "DPV1_Slave = 1" and the key word "C2_Max_Data_Len" with an appropriate length must be in the GSD file).

The connection is automatically established by the master as soon as a Read, Write or Data_Transport access is requested; it can, however, also be explicitly established through an Initiate. When the connection is being established automatically, the master sends the Initiate parameters that have most recently been passed (see the description of Initiate), and initializes the Initiate parameters with 0 after a TwinCAT start (or restart); monitoring of the connection is an exception - this is initialized in accordance with the value set in the System Manager (Watchdog under DPV1 Class 2 on the slave's PROFIBUS tab).

It is also necessary for the C2 functionality to be activated for each slave that is to be addressed using C2 services by selecting the Enable check box under DPV1 Class 2 (see the slave's PROFIBUS tab).

If a different master performs cyclic data exchange with the slave, then the "No cyclic connection" setting must be chosen under DP Class 2 (see the slave's PROFIBUS tab). This could, for instance, be useful in order to be able to debug a BC3100/IL23xx-C310 over PROFIBUS, even though it is being operated by an external controller.

MSAC-C2-Read is represented in ADS-Read, MSAC-C2-Write in ADS-Write, MSAC-C2-Data_Transport in ADS-ReadWrite, MSAC-C2-Initiate in ADS-ReadWrite, and MSAC-C2-Abort in ADS-Write:

MSAC-C2 Read

ADS-Read parameters | Meaning
Net-ID | Net-ID of the master (see the device's ADS tab)
Port | 0x1000 + station address of the slave
IndexGroup | 0x100 + slot number (DPV1 parameter)
IndexOffset | Index (DPV1 parameter)
Length | Length of the data that is to be read
Data | In response: data that has been read

MSAC-C2 Write

ADS-Write parameters | Meaning
Net-ID | Net-ID of the master (see the device's ADS tab)
Port | 0x1000 + station address of the slave
IndexGroup | 0x100 + slot number (DPV1 parameter)
IndexOffset | Index (DPV1 parameter)
Length | Length of the data that is to be written
Data | In request: data that is to be written

MSAC-C2 Data_Transport

ADS-ReadWrite parameters | Meaning
Net-ID | Net-ID of the master (see the device's ADS tab)
Port | 0x1000 + station address of the slave
IndexGroup | 0x100 + slot number (DPV1 parameter)
IndexOffset | Index (DPV1 parameter)
Write-Length | Length of the data that is to be written
Read-Length | Length of the data that is to be read
Data | In request: data that is to be written; in Response: data that has been read

MSAC-C2 Initiate

The MSAC-C2-Initiate service allows the C2 connection to the slave to be established or, if it already exists, for new Initiate parameters to be passed.

ADS-ReadWrite parameters | Meaning
Net-ID | Net-ID of the master (see the device's ADS tab)
Port | 0x1000 + station address of the slave
IndexGroup | 0x200 + slot number (DPV1 parameter)
IndexOffset | 0
Read-Length | Length of the Initiate Response parameter (6)
Write-Length | Length of the Initiate Request parameter (10 - 42)
Data | Initiate Request parameter or Initiate Response parameter

Initiate Request parameter

0x00 - 0x01 | Feature_Supported
0x02 - 0x03 | Profile_Feature_Supported
0x04 - 0x05 | Profile_Ident_number
0x06 | sType
0x07 | sLen: Length of sAddr (0 - 16)
0x08 | dType
0x09 | dLen: Length of dAddr (0 - 16)
0x0A - 0x19 | sAddr
0x1A - 0x29 | dAddr

Initiate Response parameter

0x00 - 0x01 | Feature_Supported (value received from slave)
0x02 - 0x03 | Profile_Feature_Supported (value received from slave)
0x04 - 0x05 | Profile_Ident_number (value received from slave)

MSAC-C2 Abort

The MSAC-C2 Abort service allows the C2 connection to the slave to be removed again.

ADS-Write parameters | Meaning
Net-ID | Net-ID of the master (see the device's ADS tab)
Port | 0x1000 + station address of the slave
IndexGroup | 0x400 + slot number (DPV1 parameter)
IndexOffset | 0
Length | Length of the Abort parameter (3)
Data | In request: Abort parameter

Abort parameter

0x00 | Reason_Code
0x01 - 0x02 | Additional_Detail


FC310x - Uploading the Configuration

Uploading the Configuration

The PROFIBUS can be scanned by ADS read for new devices during operation:

ADS-Read parameters | Meaning
Net-ID | Net-ID of the master (see the device's ADS tab)
Port | 200
IndexGroup | 0xzzyyF830 (yy = station address, zz = 0: in Beckhoff devices, tables 0, 1 and 9 are read, zz = 0x80: Beckhoff devices return the same information as devices from other manufacturers)
IndexOffset | 0
Length | 1538
Data | Configuration data of the slave

If the IndexGroup indicates that, for Beckhoff devices, tables 0, 1 and 9 are to be read, then the following data is supplied, provided the device is a Beckhoff device:

Offset | Description
0 -1 | 0
2 -513 | Table 0. Amongst the information contained here is the precise coupler type and the firmware version.
514 - 1025 | Table 9 (includes the coupler number and the terminal numbers)
1026 - 1537 | Table 1 (only relevant for bus controllers. The assignment of the terminals is part of the information contained here)

If the device is from another manufacturer, or if the IndexGroup indicates that Beckhoff devices are to behave in exactly the same way as devices from other manufacturers, then the following information is returned in the ADS read response:

Offset | Description
0 -1 | 1
2 - 7 | DP diagnostic data bytes 0-5 (see Slave Diagnostics)
8 - 251 | DP configuration data (CfgData)


FC310x - PKW Interface of PROFIDRIVE Slaves

PKW Interface of PROFIDRIVE Slaves

The PKW interface is integrated into the FC310x; it can then be accessed via ADS from the controller program. PKW Read is then represented by ADS Read, PKW Write by ADS Write and PKW-Read No Of Array Elements by ADS Read:

PKW Read

ADS-Read parameters | Meaning
Net-ID | Net-ID of the master (see the device's ADS tab)
Port | 0x1000 + station address of the slave
IndexGroup | Bits 0-11: parameter number (PNU)
 | Bits 12-25: 0
 | Bit 26: 1 = Sub-index in octet 3 (standard), 0 = sub-index in octet 4 (Simodrive 611U)
 | Bit 27: 1 = ARRAY codes are not supported by PROFIDRIVE slave
 | Bits 28-31: axis number (for single axis modules always 1)
IndexOffset | Sub-index (for ARRAY access)
Length | Parameter length: 2 or 4
Data | In response: Parameter value

PKW Write

ADS-Write parameters | Meaning
Net-ID | Net-ID of the master (see the device's ADS tab)
Port | 0x1000 + station address of the slave
IndexGroup | Bits 0-11: parameter number (PNU)
 | Bits 12-25: 0
 | Bit 26: 1 = Sub-index in octet 3 (standard), 0 = sub-index in octet 4 (Simodrive 611U)
 | Bit 27: 1 = ARRAY codes are not supported by PROFIDRIVE slave
 | Bits 28-31: axis number (for single axis modules always 1)
IndexOffset | Sub-index (for ARRAY access)
Length | Parameter length: 2 or 4
Data | In request: Parameter value

PKW ReadNoOfArrayElements

ADS-Read parameters | Meaning
Net-ID | Net-ID of the master (see the device's ADS tab)
Port | 0x1000 + station address of the slave
IndexGroup | Bits 0-11: parameter number (PNU)
 | Bits 12-15: 0
 | Bit 16: 1
 | Bits 17-25: 0
 | Bit 26: 1 = Sub-index in octet 3 (standard), 0 = sub-index in octet 4 (Simodrive 611U)
 | Bit 27: 1 = ARRAY codes are not supported by PROFIDRIVE slave
 | Bits 28-31: axis number (for single axis modules always 1)
IndexOffset | 0
Length | Parameter length: 1
Data | In response: Number of the parameter 's array elements


FC310x - S5-FDL Communication

S5-FDL Communication

FDL-AGAG communication is possible with S5 controllers or with other PROFIBUS FDL devices. The following specifications apply here to the PROFIBUS SAPs:

FC310x sends

SDA request with DSAP = station address + 1 of the FC310x and SSAP = station address + 1 of the other FDL device. Data corresponds to the data length passed with the ADS write. The SDA telegram is only sent when there is a call to ADS write:

ADS-Write parameters | Meaning
Net-ID | Net-ID of the master (see the device's ADS tab)
Port | 0x1000 + station address of the other FDL device
IndexGroup | 0x01000000
IndexOffset | 0
Length | Length of the data that is to be written
Data | In request: data that is to be written

Other FDL device sends:

SDA request with DSAP = station address + 1 of the other FDL device and SSAP = station address + 1 of the FC310X. Data corresponds to the data length set at the other FDL device. The FC310x temporarily stores the received data which can be read by ADS read:

ADS-Read parameters | Meaning
Net-ID | Net-ID of the master (see the device's ADS tab)
Port | 0x1000 + station address of the other FDL device
IndexGroup | 0x01000000
IndexOffset | 0
Length | Length of the received data
Data | In response: received data. There is a receive counter at the end of the received data that is incremented with every reception.
ADS-Read parameters | Meaning
Net-ID | Net-ID of the master (see the device's ADS tab)
Port | 0x1000 + station address of the other FDL device
IndexGroup | 0x04000000
IndexOffset | Station address of the other FDL device * 2
Length | 2
Data | In response: receive counter, incremented with each reception


Quick Start TwinCAT CX1500-B310

CX1500-B310: Startup for TwinCAT

Startup of CX1500-B310 for Profibus

The module CX1500-B310 (salve connection for Profibus) can, as all other modules of the CX-system, be accessed via the TwinCAT System Manager. The user selects the desired system and search for units in the System Manager (click with right button on I/O Units - this operation is only available in config-mode) After some seconds the connected units are listed. The user selects the devices he / she wants to make use of in the program.

Next the scan for boxes is questioned. Answering with "yes" opens the following dialog.

Now the date type (WORD / BYTE) and the transfer direction (Slave-Out/ Master-In, Slave-In/Master-Out) can be selected. The used can add as much signals as needed. To abort entry just click on "ABORT" when ready.

A new box is inserted in the System Manager. Via this box the data can be accessed in PLC. If the user wants to add more signals he/she can do so by opening the context menu of "BOX1" -> "Add module" In the opening dialog wrong signals can be removed either. If all desired signals are inserted the following view appears:

The status of the Profibus is shown in the upper region of CX1500-B310 entry. The programmer can connect these signals with variables in PLC to analyze them in the program (e.g. error codes for saving states or registers). Below "BOX1" is a status field (DpState and ExtDiagFlag) for transfer diagnosis. Next are the input / output signals. If the PLC project is loaded the signals can be connected with the variables by double click in signal. (For further details see documentation on TwinCAT).

The connected signals are marked by a small arrow on the signal icon. If all signals and variables are connected the new configuration can be saved and loaded onto the CX-System. The PLC program is started via PLC control.


FC310x - Diagnostic

Overview

The Error reactions section describes the reactions that will be given to slaves that do not answer or that answer incorrectly, to a PLC stop or at start-up. The Slave Diagnostics section explains how diagnostic data provided by the slave and slave statistics can be read, while the Master Diagnostics section describes general diagnostic information and statistics.


M310: LED-Blink-Codes

RUN | BF | Meaning
on | off | Operation state: RUN, Inputs are read and outputs are set
off | blink at 10 Hz | STOP
blink at 10 Hz | off | TwinCAT is not started yet, all bus participants are running without errors (RUN)
off | on | RESET, OFFLINE

RESET, OFFLINE

When switching power ON the M310 is in RESET state. It switches to STOP state by starting TwinCAT. If TwinCAT is stopped or a critical bus error occurred the operation mode is switched to OFFLINE. If the unit is in OFFLINE state it has no activity on the fieldbus.

STOP

After the start of TwinCAT or during accessing the bus configuration via the system manager the B310 in in STOP state. The unit has bus activity but does not exchange data with other bus participants. During TwinCAT start or I/O-Reset the unit is in STOP mode. It switches to RUN state automatically, when initialization phase is completed.

RUN

In RUN state the B310 unit starts to communicate with the project defined participants. If the TwinCAT task is started the data exchange takes place otherwise the unit starts reading and sending diagnostic data to the bus slaves. If the attached TwinCAT task is stopped (e.g. PLC STOP or breakpoint in PLC) the unit switches to CLEAR mode (all outputs are set to 0 or the slave behaves as the PLC program defines this state). If the task is running again the unit switches back to OPERATE mode it automatically resume its work.


Error handling and diagnostics

CX1500-B310: Error handling and diagnostics

B310: LED diagnosis codes

Display | RUN | BF | Meaning
 | on | off | Operation state: RUN, Inputs are read and outputs are set
 | off | blink at 10 Hz | STOP
 | blink at 10 Hz | off | TwinCAT is not started yet, all bus participants are running without errors (RUN)
 | off | on | RESET, OFFLINE

RESET, OFFLINE

When switching power ON the B310 is in RESET state. It switches to STOP state by starting TwinCAT. If TwinCAT is stopped or a critical bus error occurred the operation mode is switched to OFFLINE. If the unit is in OFFLINE state it has no activity on the fieldbus.

STOP

After the start of TwinCAT or during accessing the bus configuration via the system manager the B310 in in STOP state. The unit has bus activity but does not exchange data with other bus participants. During TwinCAT start or I/O-Reset the unit is in STOP mode. It switches to RUN state automatically, when initialization phase is completed.

RUN

In RUN state the B310 unit starts to communicate with the project defined participants. If the TwinCAT task is started the data exchange takes place otherwise the unit starts reading and sending diagnostic data to the bus master. If the bus master switches to CLEAR mode (all outputs are set to 0), the unit behaves as the PLC program defines this state. If the master switches back to OPERATE mode the unit automatically resume its work.

DIA

The DIA LED is reserved for further functions and has no meaning so far.


FC310x - Error Reactions

Error Reactions

Failure of a slave

If a slave does not answer, or answers incorrectly, the master repeats the telegram a number of times up to the Max Retry Limit (TwinCAT 2.8: see the master's PROFIBUS tab, TwinCAT 2.9: see master's Bus-Parameter dialog). The master repeats the telegram immediately on receipt of a faulty telegram, whereas in the timeout case the master has waited for an answer from the slave for the Slot Time (TwinCAT 2.8: see the master's PROFIBUS tab, TwinCAT 2.9: see master's Bus-Parameter dialog). At 12 Mbaud, a slot time of 1000 bit-periods and a max retry limit of 4 (the default values) then a Data_Exchange telegram will delay sending the following telegram by

TDelay = (4 x ((15 + number of outputs) x 11 + 1000) - (15 + number of inputs) x 11)/12 µs

The DpState of the slave is set to 0x02 (timeout) or 0x0B (faulty telegram). The effect on the DP connection can be set (see below).

Normal DP cycle (12 Mbaud, 5 slaves, an average of 20 bytes I, 20 bytes O for each slave)

first occurrence of a faulty DP cycle (slave 3 does not answer)

subsequent DP cycles (slave 3 no longer in the polling list)

It can still happen that the slave answers incorrectly (e.g. because, as a result of a local event on the slave, the DP connection has been removed). In this case, the telegram is not repeated, but the system continues by sending the next telegram. The DpState is set to a value other than 0, the slave is removed from the polling list and is no longer addressed in the following DP cycle (which means that the time at which the following telegram is sent changes), until the DP connection can be established again.

Reactions in the master

The master's reactions can be set differently for each slave (see the tab for the slave's Features).

Effect on the DP connection (NoAnswer reaction) if the slave either does not answer or does not answer correctly

This specifies whether the DP connection to the slave should be removed immediately in the absence of a correct reception telegram, or only after the DP watchdog time has elapsed (see the slave's PROFIBUS tab).

1. If the DP connection is to be removed immediately (Leave Data Exch, default setting) the slave is removed from the polling list and is no longer addressed in the following DP cycles until the DP connection is established once again. In order to re-establish the DP connection to the slave, at least 7 telegrams are sent, and the process generally requires at least 10-20 ms.

2. If the DP connection is only to be removed when the slave has not answered (or not answered correctly) within the DP watchdog time (Stay in Data-Exch (for WD-Time)), a further attempt is made in the next polling cycle to address the slave, but if the slave does not answer, a repeat is not sent.

The "Stay in Data-Exch (for WD-Time))" (2.) setting makes sense if the PROFIBUS cycle is to continue to operate at the most regular possible period even if a slave fails, and if the failure of a slave for one or more cycles can be tolerated (e.g. in the DP/MC (Equidistant) operating mode). In that case the DP watchdog time for the slave should be set to correspond to the slave's tolerable failure time, and the Max Retry Limit (DX) (TwinCAT 2.8: see the master's PROFIBUS tab, TwinCAT 2.9: see master's Bus-Parameter dialog) should be set to 0.

Normal DP cycle (12 Mbaud, 5 slaves, an average of 20 bytes I, 20 bytes O for each slave) in the "Stay in Data-Exch (for WD-Time)" mode

first faulty and subsequent DP cycles in the "Stay in Data-Exch (for WD-Time)" mode (slave 3 does not respond)

Changes of the slave's input data if the slave does not respond correctly

This specifies whether the slave's input data is set to 0 when it fails ("Inputs will be set to 0", which is the default setting) or whether the existing values are retained ("No changes"). In either case the DpState of the slave is set to value other than 0, so that the task can always recognize whether or not the data is valid. If a slave gives a faulty answer, the input data is always set to 0, independently of the setting of Changes of the Input Data.

Setting the slave's restart behavior if the DP connection to the slave is removed

This specifies whether the DP connection to slave whose DP connection has been removed is automatically re-established, or whether this should be done manually as a result of a call to ADS-WriteControl (see ADS-Interface).

The reaction of the master if the DP connection to the slave is removed

This specifies whether removing the DP connection to a slave has no other effects (No Reaction, the default setting), or whether the master should enter the STOP state, thus removing the DP connections to all the slaves.

Effect on the state of the master (Clear Mode), if the DP connection to the slave is removed

The Clear Mode (TwinCAT 2.8: see the master's PROFIBUS tab, TwinCAT 2.9: see master's Fault-Settings dialog) can be used to specify whether the master enters (or stays in) the "Clear" state as long as either at least one MC slave (the "Only MC-Slaves" setting) or any slave (the "All Slaves" setting) does not respond correctly (has a DpState other than 0).

The Reaction of the Master setting (see the slave's Features tab), which was described in the previous section, has priority over the Clear Mode, so that when an appropriately set slave fails, the Master enters the STOP state.

Failure of the master

Monitoring in the PLC/IO task

In the presence of a persistent bus fault, the DP cycle can be extended up to 100 ms, even at 12 Mbaud. In order to monitor the DP master, there is a status variable CycleCounter, and this can be linked in the PLC (see the Master Diagnosis section). This variable is incremented by the master after each DP cycle, so that failure of the master can be detected in by monitoring this variable in the PLC.

Monitoring in the slave

In order to monitor failure of the master and data transmission on the PROFIBUS, a watchdog (see the box's PROFIBUS tab) can be activated (default setting: watchdog activated with 200 ms). The watchdog time must be set to a length at least twice as great as the greater of Estimated Cycle Time and Cycle Time (see the device's "FC310x" tab (for TwinCAT 2.8 and TwinCAT 2.9)).

Failure of the PLC/IO task

A distinction is made between a PLC stop, reaching a break point and a task stop (the I/O task and NC task are only stopped when the entire system stops). In the case of a PLC stop, the output data is set to 0 by the PLC, whereas when a breakpoint is reached the data initially remains unchanged.

The task is monitored in the master using a monitoring time (TwinCAT 2.8: corresponding to the setting of Clear Delay x task cycle time on the master's PROFIBUS tab, TwinCAT 2.9: corresponding to the setting of Task-Watchdog x task cycle time on the master's Fault-Settings dialog). If no new data is transferred within this monitoring period, then, according to the setting of Reaction on PLC-Stop or Reaction on Task-Stop (TwinCAT 2.8: see the master's PROFIBUS tab, TwinCAT 2.9: see master's Fault-Settings dialog), the Master will enter the "Clear" state, in which outputs are set to 0 or to the safe state (if Fail_Safe = 1 in the GSD file), which is the default setting, or remains in the "Operate" state (outputs retain their most recent value). The "Operate" setting is valuable when the outputs should not be cleared when a breakpoint is reached in the PLC. However, if the PLC stops, the outputs will still be set to 0 (by the PLC), even if the master remains in the "Operate" state. It should, however, be noted that the outputs will only be zeroed if the previous DP cycle is completed in time (see the Synchronization section). It should therefore only be set during the commissioning phase.

Failure of the host

In order to monitor for failure of the host (e.g. if a PC goes into the blue screen state) it is possible for a watchdog time to be set (see the master's "FC310x" tab (for TwinCAT 2.8 and TwinCAT 2.9)). If this watchdog timer elapses, the master enters the OFFLINE state, so that the DP connections to all the slaves are removed, and the master logs off from the PROFIBUS, ceasing to carry out bus accesses.

Start-up behavior

The DP connections to all the slaves are established when the TwinCAT system starts up. Until the highest priority task that is involved has not been started, the master still does not send any Data_Exchange telegrams even after the DP connection has been established, and sends only diagnostic telegrams. As soon as the highest priority task has transferred data once, and the DP connection for the corresponding DP slave has been established, the master cyclically (with the highest priority assigned task) sends one Data_Exchange telegram to each of the corresponding slaves.

It is also possible to specify by means of the Operate Delay and Clear Mode settings (TwinCAT 2.8: see the master's PROFIBUS tab, TwinCAT 2.9: see master's Fault-Settings dialog) when the master will change from the "Clear" state (in which the outputs are set either to 0 or to the safe state (Fail_Safe = 1 in the GSD file)) into the "Operate" state (in which the outputs correspond to the outputs supplied by the task). The Operate Delay specifies the minimum length of time for which the master should remain in the "Clear" state following the first transfer of data. As has been described above, the Clear Mode specifies whether the master changes into or remains in the "Clear" state if a slave in general or an MC slave in particular fails.

Shut-down behavior

The reaction to the stopping of the TwinCAT system is exactly the same as has been described above in the "Failure of the Host" section; the DP connections to all slaves are removed, and the master logs itself off from the bus.


FC310x - Master Diagnostics

Diagnosis Inputs

The master possesses a variety of diagnostic variables that describe the state of the card and of the PROFIBUS. They can be linked in the PLC:

CdlInfo:

CdlInfo.error: Shows the number of slaves with which data exchange could not take place in the last cycle. The box status (BoxState) of the slaves should only be checked if this value is not equal to 0.

CdlInfo.cycleCounter: Is incremented at the end of each PROFIBUS cycle in order that this variable can indicate whether the last cycle was completed before the task was started.

CdlInfo.actualCycleTime: Shows the current cycle time in 4/25 µs. This variable is updated only when all slaves are involved in the data exchange (also when CdlInfo.error is 0).

CdlInfo.actualModulo: Indicates the current modulo. This variable is only of significance if the slaves are prioritized (see the Slave Prioritisation/Multiple DP Cycles section)

Counter: Used for the Redundancy mode

DiagFlag: Indicates whether the card's master diagnostic information has changed. It can then be read via ADS by the controller program, after that the "DiagFlag" variable is reset.

GlobalState: GlobalState[0] indicates the state of the FC310x, GlobalState[1-2] indicate global bus statuses, while GlobalState[3] is reserved for extensions:

RESET (1): Card router not started (after start-up of the PC).

INIT (2): Router started but card not active on PROFIBUS.

STOP (3): Card active on PROFIBUS, but no cyclical data exchange.

STOPPING (4): Card ends cyclical data exchange.

RUN (0): Card in cyclical data exchange.

GlobalState[1] counts the detected bus errors (as from FC310x, version 1).

GlobalState[2]: Bit 0 is set, if no 11 bit idle time is detected on the PROFIBUS (-> check cabling), bit 1 contains the operating mode CLEAR (bit 1 = 1) or OPERATE (bit 1 = 0), the other bits (2..7) are reserved for expansions (from FC310x, version 1).

GlobalState[3] is reserved for expansions.

CycleFailedCounter: This counter shows how often the FC310x PROFIBUS cycle was unready at the start of the TwinCAT task.

StartRedundantMasterFlag: Is used for the Redundancy mode

Master Diagnostics Data

The master diagnostic data can be read by ADS:
ADS-Read parameters | Meaning
Net-ID | Net-ID of the master (see the device's ADS tab)
Port | 200
IndexGroup | 0x0000F100
IndexOffset | offset within the diagnosis data
Length | Length of the diagnostic data that is to be read
Data | Diagnostic data

The master diagnostic data has the following structure:
Offset | Description
0 -125 | BusStatus List, one byte per station address 0-125 which contains the station status (see BoxState for PROFIBUS boxes and for non-selected stations: 0x80 - not present, 0x81 - slave, 0x82 - master not ready for token ring, 0x83 - master ready for token ring, 0x84 - master in token ring).
126 - 127 | reserved
128 - 135 | State of the FC310x (->GlobalState).
136 - 137 | Send error counter for all sent telegrams.
138 - 139 | Receive error counter for all received telegrams.
140 - 255 | reserved for extensions
256 - 257 | Sync Failed Counter (see EquiDiag tab for TwinCAT 2.8 and MC-Diag tab for TwinCAT 2.9).
258 - 259 | Cycle Start Error Counter, counts up one when the PROFIBUS cycle is restarted before the old cycle is complete (intercepted by the TwinCAT-IO driver, only possible with customised drivers).
260 - 261 | Time Control Failed Counter (see EquiDiag tab for TwinCAT 2.8 and MC-Diag tab for TwinCAT 2.9).
262 - 263 | reserved for extensions
264 - 265 | Minimum reload value of real time timer.
266 - 267 | Maximum reload value of real time timer (max. FCxxxx-Jitter (see EquiDiag tab for TwinCAT 2.8 and MC-Diag tab for TwinCAT 2.9) = max. reload value - min. reload value).
268 - 269 | PLL Overflow counter (see EquiDiag tab for TwinCAT 2.8 and MC-Diag tab for TwinCAT 2.9)
270 - 271 | PLL Underflow counter (see EquiDiag tab for TwinCAT 2.8 and MC-Diag tab for TwinCAT 2.9)

TcIo diagnostic data

The TcIo driver also generates diagnostic data that can be read, activated, deactivated and reset by ADS. It is, however, deactivated by default. It is activated if the EquiDiag or GeneralDiag tab (TwinCAT 2.8) or MC-Diag or DP-Diag tab (TwinCAT 2.9) of the device is selected, and is deactivated when the tab is deselected.

Activation, deactivation and resetting the TcIo diagnostic data

ADS-Write parameters | Meaning
Net-ID | PC Net ID.
Port | 300
IndexGroup | 0x00005000 + Device-Id (device's General tab)
IndexOffset | 0xFFFFF100
Length | 2
Data | 0: Deactivation of the Tclo diagnostic data 1: Activation of the Tclo diagnostic data 2: Resetting the Tclo diagnostic data

Reading the Tclo diagnostic data

ADS-Read parameters | Meaning
Net-ID | PC Net ID.
Port | 300
IndexGroup | 0x00005000 + Device-Id (device's General tab)
IndexOffset | 0xFFFFF100
Length | Length of the Tclo diagnostic data
Data | TcIo diagnostic data

The Tclo diagnostic data has the following structure:
Offset | Description
0 -3 | Max. TwinCAT jitter (in 100 ns, see EquiDiag tab for TwinCAT 2.8 and MC-Diag tab for TwinCAT 2.9)
4 - 7 | Min. Mapping-Time (in 100 ns, see EquiDiag tab for TwinCAT 2.8 and MC-Diag tab for TwinCAT 2.9)
8 - 11 | Max. Mapping-Time (in 100 ns, see EquiDiag tab for TwinCAT 2.8 and MC-Diag tab for TwinCAT 2.9)
12 - 15 | max. FC310x jitter (in FC310x ticks, see EquiDiag tab for TwinCAT 2.8 and MC-Diag tab for TwinCAT 2.9)
16 - 19 | CycleWithNoDxch-Counter (see GeneralDiag tab for TwinCAT 2.8 and DP-Diag tab for TwinCAT 2.9)
20 - 23 | CycleWithRepeat-Counter (see GeneralDiag tab for TwinCAT 2.8 and DP-Diag tab for TwinCAT 2.9)
24 - 27 | Max. Repeat/Cycle (see GeneralDiag tab for TwinCAT 2.8 and DP-Diag tab for TwinCAT 2.9)
28 - 31 | Actual Cycle-Time (in 4/25 µs, see GeneralDiag tab for TwinCAT 2.8 and DP-Diag tab for TwinCAT 2.9)
32 - 35 | Max. Cycle-Time (in 4/25 µs, see GeneralDiag tab for TwinCAT 2.8 and DP-Diag tab for TwinCAT 2.9)
36 - 39 | Min. Cycle-Time (in 4/25 µs, see GeneralDiag tab for TwinCAT 2.8 and DP-Diag tab for TwinCAT 2.9)
40 - 43 | RealFailedCycle-Counter (see GeneralDiag tab for TwinCAT 2.8 and DP-Diag tab for TwinCAT 2.9)
44 - 47 | EquiCycleNoDxch-Counter (see EquiDiag tab for TwinCAT 2.8 and MC-Diag tab for TwinCAT 2.9)
48 - 51 | EquiCycleRepeat-Counter (see EquiDiag tab for TwinCAT 2.8 and MC-Diag tab for TwinCAT 2.9)
52 - 55 | Max. Repeats/Equi-Cycle (see EquiDiag tab for TwinCAT 2.8 and MC-Diag tab for TwinCAT 2.9)
56 - 59 | Actual Equi-Cycle-Time (in 4/25 µs, see EquiDiag tab for TwinCAT 2.8 and MC-Diag tab for TwinCAT 2.9)
60 - 63 | Max. Equi-Cycle-Time (in 4/25 µs, see EquiDiag tab for TwinCAT 2.8 and MC-Diag tab for TwinCAT 2.9)
64 - 67 | Min. Equi-Cycle-Time (in 4/25 µs, see EquiDiag tab for TwinCAT 2.8 and MC-Diag tab for TwinCAT 2.9)


FC310x - Slave Diagnostics

Slave Diagnostics

DP-State

Each DP slave has a status variable that indicates the current state of that DP slave. This status is maintained in real time, so that it is always adapted to the current DP slave data, and can be linked to a PLC variable (-> DpState of the slave):

Diagnostic data

Any DP slave can acyclically report DP diagnostic data during data exchange operation. The slave here sets the Diag_Flag in the response to the cyclic Data_Exchange telegram, as a result of which the DP master automatically reads the DP diagnostic data from the slave. This does not affect the Data-Exchange cycle in the Beckhoff DP master, because the DP diagnostic telegram is sent at the end of the cyclic Data-Exchange cycle, and before the beginning of the next cycle. If the DP diagnostic data read from the slave has changed from its previous state, the DP master sets the "ExtDiagFlag" variable, which can be linked to a variable in the controller program.

The DP slave's current diagnostic data is displayed in the system manager on the slave's Diag tab. It can also be read by the controller program via ADS, which will cause the "ExtDiagFlag" flag to be reset once more:

ADS-Read parameters | Meaning
Net-ID | Net-ID of the master (see the device's ADS tab)
Port | 200
IndexGroup | 0x00yyF181 (yy = station address of the slave)
IndexOffset | offset within the diagnosis data
Length | Length of the diagnostic data that is to be read
Data | Diagnostic data

The diagnostic data contains the slave statistics (32 bytes) and the DP diagnostic data sent by the slave (up to 244 bytes), and is constructed as follows:

Offset | Meaning
Slave statistics
0 | Receive Error Counter (WORD): The number of faulty telegrams occurring while communicating with this slave.
2 | Repeat-Counter[8] (WORD): The repeat counters indicate how many repeats have had to be made, and how often. Repeat Counter[0] indicates how often it has been necessary to repeat a telegram for this slave once, Repeat Counter[1] shows how often a telegram for this slave has had to be repeated twice, and so on. The maximum number of repeats is set by the Max Retry-Limit parameter (TwinCAT 2.8: see the master's PROFIBUS tab, TwinCAT 2.9: see master's Bus-Parameter dialog). The range of values extends from 0 to 8, which is why there are 8 repeat counters (for 1 to 8 repetitions)
18 | reserved for extensions
20 | NoAnswer Counter (DWORD): The number of telegrams in communication with this slave that have not received a answer. The first time that a slave fails to answer, the telegram is repeated up to MaxRetryLimit times, but if it does not answer even then, further telegrams are not repeated.
24-27 | Last-DPV1-Error[4] (BYTE): The most recent faulty DPV1 response is entered here (byte 0: DPV1 service (bit 7 is set, thus indicating an error), byte 1: Error_Decode, byte 2: Error_Code_1 (Error_Class/Error_Code), byte 3: Error_Code_2), see description of the DPV1 error codes
27-31 | reserved for future use
from 32 | DP diagnostic data


FC310x - DP State of the Slaves

DP State of the Slaves

Value | Description
0 | No Error - station is exchanging data
1 | Station deactivated - slave has been deactivated, temporary state during StartUp
2 | Station not exists - slave does not reply on the bus -> check whether slave is switched on, whether PROFIBUS plug is in, correct station address or bus cables
3 | Master lock - slave is exchanging data with another master -> remove other master from bus or release slave again by other master
4 | Invalid slave response - incorrect answer from slave, occurs temporarily if slave has ceased data exchange as a result of a local event
5 | Parameter fault - check whether Bus Coupler / GSD file is correct, that station address is correct or that UserPrmData settings are correct
6 | Not supported - DP function is not supported -> check whether GSD file is correct or whether station address is correct
7 | Config fault – configuration fault -> check whether the added terminals / modules are correct
8 | Station not ready -> station starting up, temporarily displayed during StartUp
9 | Static diagnosis - slave signalling static diagnosis and cannot deliver valid data at present -> check operating state at the slave
10 | Diagnosis overflow - slave signalling a diagnosis overflow -> check diagnostic data (using ADS-Read, see below) and operating state at the slave
11 | Physical fault - physical fault interfering with slave response -> check cables
13 | Severe bus fault ->check cabling
14 | Telegram fault - slave responding with an invalid telegram -> must not occur
15 | Station has no resources -> slave has insufficient resources for the telegram -> check that GSD file is correct
16 | Service not activated -> temporary fault when slave ceases data exchange due to a local event, otherwise check whether DP functions are disabled at the slave
17 | Unexpected telegram -> can occur temporarily if two PROFIBUS networks are connected together or check whether bus times for the second master are set identically
18 | Station ready -> can occur temporarily during StartUp and until the task is started
19 | DPV1 StartUp -> occurs temporarily after the DP has started up if there is still data to be sent by DPV1 Write
128 | FC310x in slave mode, waiting for data transfer -> slave was parameterized and configured but has not yet received a Data_Exchange telegram
129 | FC310x in slave mode, waiting for configuration -> slave was parameterized, but has not yet received a Chk_Cfg telegram
130 | FC310x in slave mode, waiting for parameters -> slave was not yet parameterized, waiting for Set_Prm (Lock) telegram


FC310x - ADS Error Codes of the FC310x

ADS Error Codes of the FC310x

Error code | Meaning
0x1129 | IndexOffset too large during reading of the FC310x diagnostic data
0x112B | IndexOffset too large during reading of the slave diagnostic data
0x112D | Invalid station address during reading of the slave diagnostic data
0x2023 | Invalid IndexOffset during resetting of the FC310x diagnostic data
0x2024 | Invalid data during resetting of the FC310x diagnostic data
0x2025 | Invalid data length during resetting of the FC310x diagnostic data
0x2101 | DPV1-C1-Read: cyclic connection to slave not yet established
0x2102 | PKW-Read: only data lengths 2 and 4 are permitted
0x2103 | PKW-Read: slave not in data exchange
0x2105 | PKW-Read: slave does not support PKW
0x2106 | PKW-Read: wrong IndexOffset
0x2107 | PKW-Read: wrong IndexGroup
0x2109 | DPV1-C1-Read: FDL fault (no response etc.)
0x210A | DPV1-C1-Read: syntax error (DPV1 syntax not correct)
0x210B | DPV1-C1-Read: DPV1 fault (4 bytes error code in the diagnostic data of the slave)
0x210C | PKW-Read: syntax error
0x210D | PKW-Read: PKW error
0x210E | PKW-Read: incorrect data type
0x210F | DPV1-C1-Write: cyclic connection to slave not yet established
0x2110 | PKW-Write: only data lengths 2 and 4 are permitted
0x2111 | PKW-Write: wrong IndexOffset
0x2112 | PKW-Write: slave does not support PKW
0x2113 | PKW-Write: wrong IndexGroup
0x2114 | Read general: wrong IndexGroup
0x2115 | DPV1-C1-Write: FDL fault (no response etc.)
0x2116 | DPV1-C1-Write: syntax error (DPV1 syntax not correct)
0x2117 | DPV1-C1-Write: DPV1 fault (4 bytes error code in the diagnostic data of the slave)
0x211C | Read general: wrong IndexGroup
0x211D | SetSlaveAdress: wrong IndexOffset
0x211E | FDL-AGAG-Write: wrong IndexOffset
0x211F | FDL-AGAG-Read: wrong IndexOffset
0x2120 | FDL-AGAG-Write: wrong length
0x2121 | SetSlaveAddress: wrong length
0x2122 | FDL-AGAG-Read: wrong length
0x2131 | Write general: wrong IndexGroup
0x2132 | Write general: wrong IndexGroup
0x2137 | PKW-Read: WORD received, but read data length does not equal 2
0x2138 | PKW-Read: DWORD received, but read data length does not equal 4
0x2139 | PKW-Read: unknown AK received (1,2 or 7 expected)
0x213A | PKW-Read-Array: WORD received, but read data length does not equal 2
0x213B | PKW-Read-Array: DWORD received, but read data length does not equal 4
0x213C | PKW-Read-Array: unknown AK received (4.5 or 7 expected)
0x213D | PKW-Write-Array: unknown AK received (2 or 7 expected)
0x213E | PKW-Write: unknown AK received (1 or 7 expected)
0x213F | PKW-Write: unknown AK received (2 or 7 expected)
0x2140 | PKW-Write-Array: unknown AK received (1 or 7 expected)
0x2142 | SetSlaveAddress: wrong parameter during setting of address in slave mode
0x2144 | Incorrect IndexGroup in ReadWrite
0x2147 | DPV1-C2-Initiate: MSAC_C2 is not activated
0x2148 | Incorrect IndexGroup in Read
0x2149 | Incorrect IndexGroup in Write
0x214E | DPV1-C2-Read: MSAC_C2 is not activated
0x214F | DPV1-C2-Write: MSAC_C2 is not activated
0x2150 | DPV1-C2-DataTransport: MSAC_C2 is not activated
0x2151 | DPV1-C2-Read: FDL fault (no response etc.)
0x2152 | DPV1-C2-Read: connection aborted
0x2153 | DPV1-C2-Read: DPV1 fault (4 bytes error code in the diagnostic data of the slave)
0x2154 | PKW-ReadNoOfElements: length must equal 1
0x2155 | PKW-ReadNoOfElements: PKW is not activated
0x2156 | PKW-ReadNoOfElements: axis number is too great
0x2157 | PKW-ReadNoOfElements: slave not in data exchange
0x2158 | PKW-ReadNoOfElements: unknown AK received (6 or 7 expected)
0x215A | DPV1-C2-Write: FDL fault (no response etc.)
0x215B | DPV1-C2-Write: connection aborted
0x215C | DPV1-C2-Write: DPV1 fault (4 bytes error code in the diagnostic data of the slave)
0x215D | DPV1-C2-DataTransport: FDL fault (no response etc.)
0x215E | DPV1-C2-DataTransport: connection aborted
0x215F | DPV1-C2-DataTransport: DPV1 fault (4 bytes error code in the diagnostic data of the slave)
0x2163 | DPV1-C2-DataTransport: wrong IndexOffset
0x2600-0x26FF | AK 7 (error) during PKW processing, error code in low byte
0x2700-0x27FF | Fault during DPV1 processing, 4 bytes error code in the slave diagnostic data, byte 3 of the error code (error class) is in Low byte


FC310x - Diagnostic Data - DiagData

Diagnostic Data - DiagData

There follows a description of the DP diagnostic data

Offset | Meaning
0x00.0 | StationNonExistent: slave did not reply to the last telegram
0x00.1 | StationNotReady: slave still processing the Set_Prm / Chk_Cfg telegram
0x00.2 | CfgFault: slave signalling a configuration error
0x00.3 | ExtDiag: extended DiagData available and valid
0x00.4 | NotSupported: slave does not support a feature requested via Set_Prm or Global_Control
0x00.5 | InvalidSlaveResponse: slave response not DP-compatible
0x00.6 | PrmFault: Slave reports a parameterization error
0x00.7 | MasterLock: slave currently exchanging data with another master
0x01.0 | PrmReq: re-parameterize and reconfigure slave
0x01.1 | StatDiag: slave signalling static diagnosis / DPV1 slave application not yet ready for data exchange
0x01.2 | PROFIBUS DP slave
0x01.3 | WdOn: DP watchdog on
0x01.4 | FreezeMode: DP slave in freeze mode
0x01.5 | SyncMode: DP slave in sync mode
0x01.6 | reserved
0x01.7 | Deactivated: DP slave has been deactivated
0x02.0 | reserved
0x02.1 | reserved
0x02.2 | reserved
0x02.3 | reserved
0x02.4 | reserved
0x02.5 | reserved
0x02.6 | reserved
0x02.7 | ExtDiagOverflow: too much extended data present
0x03 | MasterAdd: station address of master with which slave is exchanging data
0x04, 0x05 | IdentNumber
from 0x06 | Extended DiagData

Extended DiagData

A distinction is made in the Extended DiagData between identification diagnosis, channel diagnosis and manufacturer-specific diagnosis. The first byte indicates the type of the diagnosis and the length of the associated data. Several diagnostic types can also follow one another in the Extended DiagData.

Header Byte

Bit | Meaning
0-5 | Length of the associated diagnostic data, including header byte
6-7 | 0 = manufacturer-specific diagnosis (DPV1 is not supported) or DPV1 diagnosis (DPV1 is supported (DPV1_Enable = 1) in associated GSD file)
 | Module diagnosis
 | Channel diagnosis
 | Revision number

Manufacturer-specific diagnosis

The structure of the manufacturer-specific diagnosis may be found in the documentation for the DP slave.

DPV1 Diagnosis

In the case of DP slaves that also support DPV1, the DPV1 diagnosis, in which a distinction is made between status messages and alarms, is sent instead of the manufacturer-specific diagnosis.

Byte | Meaning
0 | Header-Byte (bits 6,7 = 0, bits 0-5 = 4..63)
1 | Bits 0-6: Alarm type
 | Bit 7: always 0
2 | Slot number (0-254)
3 | Bits 0-1: Alarm specifier
 | Bit 2: Additional acknowledge
 | Bits 3-7: Sequence number
4-63 | Manufacturer specific (see the documentation for the DP slave)

Alarm type

Value | Meaning
0 | reserved
1 | Diagnostic alarm
2 | Process alarm
3 | Withdrawal alarm
4 | Insertion alarm
5 | Status alarm
6 | Update alarm
7-31 | reserved
20-126 | Manufacturer specific (see the documentation for the DP slave)
127 | reserved

Module diagnosis

The module diagnosis contain one bit for each DP module. The bit indicates whether a diagnosis for the corresponding DP module is present.

Byte | Meaning
0 | Header-Byte (bits 6,7 = 1, bits 0-5 = 2..32)
1 | Bit 0: 1. DP module has diagnosis
 | Bit 1: 2. DP module has diagnosis
 | ...
 | Bit 7: 8. DP module has diagnosis
... | ...
31 | Bit 0: 241. DP module has diagnosis
 | Bit 1: 242. DP module has diagnosis
 | Bit 2: 243. DP module has diagnosis
 | Bit 3: 244. DP module has diagnosis (a maximum of 244 DP modules as possible)

Channel diagnosis

The channel diagnosis provides a closer description of the cause of the diagnosis of a DP module.

Byte | Meaning
0 | Header byte = 0x83 (3 bytes including header, bits 6, 7 = 2)
1 | Bits 0-5: Channel number
 | Bits 6-7: 0 = reserved, 1 = input, 2 = output, 3 = input/output
2 | Bits 0-4: Error type
 | Bits 5-7: Channel type

Error type

Value | Meaning
0 | reserved
1 | Short circuit
2 | Under voltage
3 | Overvoltage
4 | Overload
5 | Over temperature
6 | Open circuit fault
7 | Upper limit value exceeded
8 | Value below lower limit
9 | Error
10-15 | reserved
16-31 | Manufacturer specific (see the documentation for the DP slave)

Channel type

Value | Meaning
0 | Any type
1 | Bit
2 | 2 bit
3 | 4 bit
4 | Byte
5 | Word
6 | 2 words
7 | reserved

Revision number

The structure of the revision number may be found in the documentation for the DP slave.


Removal and disposal

A CX10x0 hardware configuration is dismantled in 2 stages:

0. Switching off and disconnecting the power supply

Before a CX10x0 system can be dismantled, the system should be switched off, and the power supply should be disconnected.

1. Removing from the top-hat rail:

Before the individual CX10x0 modules are disconnected, the whole CX1020 hardware block should be removed from the top-hat rail. Proceed as follows:

1.1. Release and remove the first Terminal next to the power supply unit on the top-hat rail.

First remove any wiring from power supply unit and then from the first terminal on the top-hat rail next to the power supply unit. If the wiring is to be reused for another system, it is advisable to make a note of the connections. Then pull the orange terminal release (see arrow) to release the terminal and pull it out.

1.2. Releasing the CX10x0 system

In order to release the CX10x0 block, pull the white straps at the bottom of the module in the direction of the arrows. They will lock in the extended position. After pulling the terminal release of the power supply unit, the block can be removed carefully from the top-hat rail.

2. Separating the individual modules

2.1. Separating the power supply unit, the CX10x0 CPU and other components

Place the CX10x0 block onto a suitable support with the front facing down. Then insert a flat screwdriver with dimensions 1.0 x 5.5 x 150 mm into the locking mechanism, and then operating the slider by turning it about 90 degrees. The locking mechanism on the rear affects an approx. 2-3 mm wide clearance of the module latching mechanism, pushing them apart. The plug connectors of the PC 104 interface can then be pulled apart carefully.

Only modules (CPU, fieldbus connections and UPS modules) that can be separated non-destructively feature a release device. Modules that cannot be separated only feature a marking point (with or without red paint seal). Applying force to these elements will destroy them.

Warning |
 | Forcibly opening the module housing (e.g. removing the cover) will destroy the housing.

Disposal

The device must be fully dismantled in order to dispose of it.

Electronic parts must be disposed of in accordance with national electronics scrap regulations.


FC310x - Slave

BECKHOFF FC310x: Slave

Slave

As a slave, the PROFIBUS DP and PROFIBUS DPV1 protocols are supported.

PROFIBUS DP

In order to configure the slave for cyclic DP operation, proceed as follows in the TwinCAT system manager:

Configure DP slave

It is first necessary to configure a "PROFIBUS Slave FC310x, PCI" I/O device (selecting "I/O devices" with the right hand mouse button, and then selecting "Insert device"). This will cause the device and a box to be added. The GSD file "TCDPSLAV.GSD" must be present in the "TwinCAT\Io\PROFIBUS" directory for this purpose:

The appropriate channel can be searched for on the device's "FC310x" tab ("Search" button). The station address will need to be adjusted, and so, possibly, may the baud rate, which is set to 12 Mbaud as standard. The tab "FC310x" is described for TwinCAT 2.8 and TwinCAT 2.9.

Add modules

Modules are to be a added to the box corresponding to the data that is to be transferred cyclically. This is done by clicking with the right mouse button on the box, and then selecting "Add modules":

Configuring the Master

The GSD file "TCDPSLAV.GSD" is to be taken out of the "TwinCAT\Io\PROFIBUS" directory to configure the master. The modules must be inserted in the master configuration in the same sequence as they are in the configuration of the slave in the System Manager.

Error Reactions

In the default setting, the DP slave's inputs are set to 0 when the DP slave is not involved in data exchange. It is possible to change this input error reaction to "No changes" under Changes of the Input Data on the "Features" tab for the box:

PROFIBUS DPV1

The DP slave supports a DPV1-MSAC_C1 server connection that is established along with the cyclic connection. This can be used so that larger quantities of acyclic data can be transferred alongside the cyclic data. A DPV1 read telegram received by the master is reported to the PLC as an ADS read indication, while a DPV1 write telegram is reported to the PLC as an ADS write indication. The PLC program is then responsible for the read or write response. To do this, the ADS read response or ADS write response functions are to be called.

MSAC-C1 Read

A DPV1-MSAC_C1 read indication is represented in an ADS read indication as follows:

ADS read indication parameter | Meaning
Source-Net-ID (NETID) | Net-ID of the slave (see the device's ADS tab)
Source-Port (PORT) | 0x200
Invoke-ID (INVOKEID) | A unique number that must reappear in the response
IndexGroup (IDXGRP) | Slot number (DPV1 parameter)
IndexOffset (IDXOFFS) | Index (DPV1 parameter)
Length (LENGTH) | Length of the data that is to be read

An ADS read response is represented in a DPV1-MSAC_C1 read response as follows:

ADS read response parameter | Meaning
Destination-Net-ID (NETID) | Net-ID of the slave (see the device's ADS tab)
Destination-Port (PORT) | 0x200
Invoke-ID (INVOKEID) | A unique number, as under indication
Result (RESULT) | Result of the read: 0 = no error, otherwise: bits 0-15 = standard ADS error codes, bits 16-23 = Error_Code_1, bits 24-31 = Error_Code_2, see description of the DPV1 error codes
Length (LENGTH) | Length of the data that has been read
Data (DATAADDR) | read data

MSAC-C1 Write

A DPV1-MSAC_C1 write indication is represented in an ADS write indication as follows:

ADS write indication parameter | Meaning
Source-Net-ID (NETID) | Net-ID of the slave (see the device's ADS tab)
Source-Port (PORT) | 0x200
Invoke-ID (INVOKEID) | A unique number that must reappear in the response
IndexGroup (IDXGRP) | Slot number (DPV1 parameter)
IndexOffset (IDXOFFS) | Index (DPV1 parameter)
Length (LENGTH) | Length of the data that is to be written
Data (DATAADDR) | data that is to be written

An ADS read response is represented in a DPV1-MSAC_C1 read response as follows:

ADS read response parameter | Meaning
Destination-Net-ID (NETID) | Net-ID of the slave (see the device's ADS tab)
Destination-Port (PORT) | 0x200
Invoke-ID (INVOKEID) | A unique number, as under indication
Result (RESULT) | Result of the read: 0 = no error, otherwise: bits 0-15 = standard ADS error code, bits 16-23 = Error_Code_1, bits 24-31 = Error_Code_2, see description of the DPV1 error codes
Length (LENGTH) | Length of the data that has been read

ADS Interface from TwinCAT 2.9

Communication can also take place via ADS in TwinCAT systems. The functionality is extremely similar to that of an ADS connection between two PCs over Ethernet, although transmission takes place over PROFIBUS, with the exception that the requester that initiates the ADS job is always the DP master PC. An FC310x DP master is then linked to an FC310x-DP slave.

In the DP master, the ADS Interface should be activated on the "ADS" tab of the box, and the Net-ID of the DP slave PC is to be entered:

At the DP slave the Net-ID of the DP master PC is to be added under Add. NetIds on the device's "ADS" tab:


FC310x - PROFIBUS MC

PROFIBUS MC

The difference between PROFIBUS MC and PROFIBUS DP is that the PROFIBUS cycle is constant, with a jitter of a few microseconds (for PROFIBUS DP, the jitter is greater than 100µs), and at the start of the cycle a broadcast global control telegram is sent, which can be used by the MC slaves for synchronization. This enables precise synchronization of drive control loops with the NC.

However, this precise synchronization means that bus disturbances, switching off of slaves, pulling of bus plugs etc. will usually lead to a loss of synchronicity between master and slave, since the bus timing is changed.

FC310x with Simodrive 611U has Plug&Play functionality

The following steps are required for operating a Simodrive 611U on a FC310x:

  1. Set FC310x to operating mode ”DP/MC (equidistant)”.
  2. Add box ”Siemens AG, Profidrive MC”.
  3. Adjust 611U station address (”PROFIBUS” box tab).
  4. Append axis (or 2 axes for 611U with 2 axes) to NC task, select axis type ”continuous axis”.
  5. Link axis (or axes) with 611U (select axis type ”ProfiDrive MC” in the ”Settings” axis tab, then link with 611U; for a 2-axis 611U, both axes have to be linked, otherwise a 611U error will occur).
  6. Press the ”Calculate equi-time” button on the ”FC310x” tab at the FC310x.
  7. Save project in the registry and start TwinCAT. The 611U should now change to RUN, the axis can be operated via the NC online menu.

Should this not be the case, check the following:

  • DpState of the 611U in TwinCAT is 2: Check 611U station address.
  • DpState of the 611U in TwinCAT is 5: Check whether the correct PROFIBUS module is inserted at the 611U.
  • DpState of the 611U in TwinCAT is 7: Check whether P922 is set to the correct standard telegram (according to the ProcessData tab for 611U in the System Manager).
  • DpState of the 611U in TwinCAT is 0, but 611U still does not change to RUN: Check the 611U firmware version; for firmware versions below 3.4.3, 611U synchronization errors (error 597 or 598) can only be rectified via a hardware reset of the 611Us, otherwise look up the error code in the Siemens manual.

If several 611Us are configured, the equidistant times may have to be adjusted (see below).

DP/MC Equidistant Mode

In order to operate the FC310x with PROFIBUS MC it is necessary to set the "DP/MC (Equidistant)" Operation Mode on the master's "FC310x" tab (for TwinCAT 2.8 and TwinCAT 2.9). Whichever task uses the equidistant functionality of the FC310x (most often this is the NC task) should have the highest priority, as otherwise the synchronicity can be disturbed. Additionally, the Sync Mode can be selected. This specifies where the synchronization signal is generated.

Disabled (PC is Sync Master)

The synchronization signal is generated by the PC, the FC310x synchronizes itself with the PC (PROFIBUS cycle jitter approx. 2-4 µs).

The NC Access Time specifies by how much the PROFIBUS cycle is shifted towards the TwinCAT cycle, the PLL Sync Time should be set to approx. 10% of the NC-Access-Time (max. 50 µs).

Sync Slave

The synchronization signal comes from another device, whose Sync mode must be set to ”Sync Master”. The connection between the sync master and the sync slave is made through a hardware link. This is only supported as from FC310x hardware version 4 and firmware version 3.00. No times have to be set.

Sync Master

The synchronization signal is generated by the FC310x, the PC synchronizes itself with the FC310x (jitter of the PROFIBUS cycle approx. 1 µs).

The NC Access Time specifies by how much the TwinCAT cycle is shifted towards the PROFIBUS cycle.

Setting of Equidistant Times

The Calculate Equi Times button (TwinCAT 2.8: see master's FC310x tab, TwinCAT 2.9: see master's MC tab) can be used to set all the equidistant parameters automatically. The only parameter that may possibly have to be adjusted later is the NC Access Time, because this depends on the maximum TwinCAT jitter and on the maximum mapping time. This in turn depends on all the devices, so that adding and linking boxes to other devices has the effect that it may nevertheless be necessary to change the NC Access Time for an unchanged device. If "I/O not at task start" is selected (see the Synchronization section), then the NC Access Time also depends on the task runtime. In order to avoid the NC Access Time having to be adjusted manually every time the Calculate Equi-Times button is pressed, the ratio of NC Access Time to Cycle Time can be specified (default is 15%).

Disabled (PC is Sync Master) or Sync Master

The NC Access Time must be greater than the maximum TwinCAT jitter plus the maximum mapping time, plus, if "I/O not at task start" is selected for whichever task linked to the FC310x has the highest priority, it's task runtime.

Diagnosis of Equidistant Times

Diagnostics of the equidistant times can be carried out with the EquiDiag tab (TwinCAT 2.8) or MC-Diag (TwinCAT 2.9) in the System Manager, of by ADS in the controller program (see Master Diagnostics section).


Mechanical assembly of the basic module

The installation of the modules takes place in three steps:

1. The sequence of the modules

The basic CPU module with system interfaces, which are factory-installed on the left side, is extended with the power supply unit on the right and with the fieldbus connection (master or slave) left side if available.

2. Assembly of the CPU and the power supply unit

The individual modules are simply plugged together. The PC104 connector plugs should be handled carefully in order to avoid damage. When correctly assembled, no significant gap can be seen between the attached housings.

3. Engaging on the top-hat rail

On the bottom of the modules, there is a white tension strap, which is connected with a latching mechanism. These tension straps must be pulled down before attaching to the top-hat rail. This can be done using an ordinary screwdriver and a slight turn.

Then fix the CX1020 block on the top hat-rail using the latching straps. You should hear a soft click.

Do not force the module or apply excessive pressure!

Only apply pressure at insensitive points of the housing (edges). Never apply pressure on the display, the buttons or movable parts of the CX10x0 system.

After successful latching on the top-hat rail the straps should be pushed back to their original position.

Note:

A locking mechanism prevents the individual housings from being pulled off again. Detailed information relating to disassembly of the CX1020 configuration from the top-hat rail can be found on page "Removal and disposal".

Installation position:

Warning

The maximum ambient temperature for CPU modules mounted on a top-hat rail is 50°C. The orientation in which the device is fitted must be selected in such a way that cooling air can flow vertically through the ventilation holes. The images show the correct (Fig. 8) and two incorrect installation positions (Figs. 9 & 10).

Observe minimum clearance!

Mounting must provide a clearance of 30 mm both above and below a CX1000 device combination to ensure adequate ventilation of the base CPU module and the power supply unit.
Correct installation position:

The high-performance CX1020 system generates a significant amount of heat, which is dissipated via a passive ventilation system. This system requires the unit to be mounted correctly. Ventilation openings are located at the top and bottom of the housing. The system therefore has to be installed horizontally. This ensures optimum air flow.

Incorrect installation positions:

The CX1020 system must not be operated vertically on the top-hat rail. A vertical position would lead to insufficient CPU ventilation, since the ventilation openings are located on the top and bottom of the housing. Installation of the system on its side would also lead to inadequate ventilation.


Accessories

CX1500-x310: Accessories

Accessories PROFIBUS

wires and connectors for Profibus.

Connectors

Order number | Description
ZB3100 | 9 pin D-Sub connector up to 12 Mbaud, with resistive terminator
ZB3101 | 9 pin D-Sub connector up to 12 Mbaud, with programming interface
ZB3102 | 9 pin D-Sub connector up to 12 Mbaud, with resistive terminator, inversed PROFIBUS connector
ZS1031-3000 | 9 pin D-Sub connector up to 12 Mbaud, with resistive terminator (other design as ZB3100)
ZS1031-3500 | Fiber optic conductor for BK35xx (part of the Bus Coupler delivery)

Wires

Copper conductor for Bus Coupler BK3xxx (PROFIBUS)

Order number | Description
ZB3200 | PROFIBUS cable, 12 Mbaud, 1 x 2 x 0,64 mm² for fixed Installation
ZB3300 | PROFIBUS cable, 12 Mbaud, 2 x 0,25; 3 x 0,75 mm², 5-wire, suitable as trailing cable

Fiber optic conductor for for Bus Coupler BK3500 (PROFIBUS)

Order number | Description
Z1100 | Plastic fiber optic conductor 1000 μm core, 1-wire, diameter 2.2 mm
Z1101 | Plastic fiber optic conductor 1000 μm core, 1-wire, PU jacket, diameter 5.5 mm
Z1102 | Like Z1101, on cable drum, length = 500 m
Z1121 | Plastic fiber optic conductor 1000 μm core, 2-wire, PU jacket, diameter 5.5 mm


Certifications

All products of the Embedded PC family are CE, UL and GOST-R certified. Since the product family is continuously developed further, we are unable to provide a full listing here. The current list of certified products can be found on the Embedded PC certificates web page or at www.beckhoff.com under Embedded PC.


Support and Service

Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.

Beckhoff's branch offices and representatives

Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!

The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com

You will also find further documentation for Beckhoff components there.

Beckhoff Headquarters

Beckhoff Automation GmbH

Huelshorstweg 20
33415 Verl
Germany

Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support

Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:

  • support
  • design, programming and commissioning of complex automation systems
  • and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service

The Beckhoff Service Center supports you in all matters of after-sales service:

  • on-site service
  • repair service
  • spare parts service
  • hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com