Title

BECKHOFF CX1100-09xx: UPS - Modules for CX10x0-System

Documentation for

UPS - Modules for CX10x0-Systems

CX1100-0900 (550 mA / 20 As)

CX1100-0910 (1.1 A / 20 As)

CX1100-0920 (1.1 A / 40 As)

CX1100-0930 (2.0 A / 40 As)

version: 1.4
date: 2009-03-23


Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending

The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.

Copyright

© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety Instructions

Safety Rules

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

State at Delivery

All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH.

Personnel Qualification

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.

Description of safety symbols

The following safety symbols are used in this operating manual. They are intended to alert the reader to the associated safety instructions.

Danger

This symbol is intended to highlight risks for the life or health of personnel.

Warning

This symbol is intended to highlight risks for equipment, materials or the environment.

Note

This symbol indicates information that contributes to better understanding.


Documentation Issue Status

Version | Changes
1.4 | new UPS CX1100-0930 added
1.3 | usage with CX systems added
1.2 | technical data for charge corrected
1.1 | annotations to usage of CX1100-0900 and CX1020
1.0 | released version
0.4 | revision of discharge graphs, licenses added
0.3 | resorting / small corrections
0.2 | revised version
0.1 | preliminarily version


Appropriate Use

The CX10x0 device series is a modular control system designed for top-hat rail installation. The system is scalable, so that the required modules can be assembled and installed in the control cabinet or terminal box as required.

The UPS Modules are designed to supply CX10x0 Embedded PCs and their bus terminals.


CX1100-09xx: System overview

BECKHOFF CX1100-09xx: System overview

System overview

UPS module is available in four variations:

  • CX1100-0900
  • CX1100-0910
  • CX1100-0920
  • CX1100-0930

The UPS module is used for the uninterruptible power supply of CX CPUs and any connected CX components. In the event of a failure of the external supply, the module ensures that the application software can save important data, e. g. on a Compact Flash card, NOVRAM or in a database via the network. During the UPS retention time, the machine or process can be transferred into a defined state, and the operating system can be shut down. The retention time can be set via a rotary switch or via software. The use of state of the art capacitors makes this UPS module – unlike other battery powered techniques – absolutely maintenance-free and offers rapid charging. The module can simply added to a CX system. Only a 24 V DC supply cable is needed. The 24 V DC output voltage of the UPS is protected against short circuit and overload. The CX1100-09xx may be retrofitted on site. A DPRAM user interface provides options for settings and UPS status messages. The functionality of the UPS is therefore independent of the operating system to be used. No driver software is required. The TwinCAT System Manager recognizes the UPS module automatically, and the UPS signals are available to the PLC programmer. A controlled 24 V DC power supply unit with a minimum output current of 4 A is required.

Setup of UPS module:

sample configuration1:

sample configuration 2:


CX1100-09xx: Technical Data

BECKHOFF CX1100-09xx: Vorwort
BECKHOFF CX1100-09xx: Technical Data

Technical Data CX1100-0900, CX1100-0910, CX1100-0920, CX1100-0930

The UPS-Modules are available in four versions. The user can choose the fitting version for his purpose. The table shows differences and common properties:

Technical data | CX1100-0900 | CX1100-0910 | CX1100-0920 | CX1100-0930
Power supply | 24 V DC (-15 %/+20 %)
Storage technology | capacitive
Charge | 20 As | 20 As | 40 As | 40 As
Retention time | adjustable, load-dependent
Output current max. | 550 mA (24 V DC) | 1.1 A (24 V DC) | 1.1 A (24 V DC) | 2.0 A (24 V DC)
Charging current | max. 4 A
Diagnostics LED | 24 V DC-Input, 24 V DC-Output, CHARGE
System bus | 16 Bit ISA (PC104 standard)
Max. power consumption | 2 W
Dimensions (W x H x D) | 57 mm x 100 mm x 91 mm | 76 mm x 100 mm x 91 mm | 95 mm x 100mm x 91 mm | 95 mm x 100mm x 91 mm
weight | app. 345 g | app. 465 g | app. 617 g | app. 650 g
Operating temperature | 0 °C ... +55 °C
Storage temperature | -25 °C ... +85 °C
Relative humidity | 95% no condensation
Vibration/Shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27/29
EMC resistance burst / ESD | conforms to EN 61000-6-2 / EN 61000-6-4
protection class | IP 20

Note

The maximal output current for UPS module CX1100-0900 is 550 mA!

For higher output current make use of the UPS modules (CX1100-0910 / CX1100-0920), with bigger output current.

The maximal output current is not suitable for the CX1020 Embedded PCs. So it is strongly recommended to make use of the UPS modules (CX1100-0910 / CX1100-0920), with bigger output current.


Connections

BECKHOFF CX1100-09xx: Connections

CX1100-09xx Connections

The UPS-Modules are supplied with power by 5-pin "Open Pluggable Connector". The other components of the embedded system are supplied via the PC 104 bus with 24V DC. (-15 % to +20 % tolerance)

Pin assignment "Open Pluggable Connector":

Pin | Assignment
5 | 0 V DC OUT ( UPS output current)
4 | 24 V DC OUT ( UPS output current)
3 | PWR FAIL (digital output)
2 | 0 V DC IN (UPS incoming power supply)
1 | 24 V DC IN (UPS incoming power supply)

Connection to power supply

For power supply units with K-bus / E-bus connection (CX1100-0002, CX1100-0003 und CX1100-004) the supply is realized as follows:

Though the power supply CX1100-0001 has no terminal bus interface the module is connected to the upper input connectors (24V). Older versions of the power supply are labeled with UPS -/+. These input are not used and more and must not be connected. The figure shows the correct connection.

Power-Fail-Signal Connection

The UPS modules can also be used to supply other bus couplers. To use the UPS module with the bus coupler the power supply has to be connected with the UPS. The power supply for the bus terminals has to be connected seperaty. This depends on the terminal bus load. The Power-Fail connection should be connected to a digital input terminal. (see picture below)

In case of power failure the UPS module rises the POWER-FAIL signal. The PLC program reads the input via the terminal bus and can shutdown the application. In this mode the control of the UPS module is controlled by the torque switch at the front side of the module.


Technical data

BECKHOFF CX1100-09xx: Technical data

Technical data CX1100-0900, CX1100-0910, CX1000-0920, CX1100-0930

Depending on the performance and the operating system the different CPU-Modules of the CX systems need different UPS modules. The following table show the recommended combinations of CPU and UPS modules. The view is kept in the CPU module and the system interfaces only. Terminals are not part on the scope.

CX System | CX1100-0900 | CX1100-0910 | CX1100-0920 | CX1100-0930
CX9000 (with WINDOWS CE) | yes* | yes* | yes* | yes*
CX9010 (with WINDOWS CE) | yes* | yes* | yes* | yes*
CX1000 (with WINDOWS CE) | yes | yes | yes | yes
CX1000 (with WINDOWS XP) | yes | yes | yes | yes
CX1010 (with WINDOWS CE) | yes | yes | yes | yes
CX1010 (with WINDOWS XP) | yes | yes | yes | yes
CX1020 (with WINDOWS CE) | no | no | yes | yes
CX1020 (with WINDOWS XE) | no | no | yes | yes
CX1030 (with WINDOWS CE) | no | no | no | yes
CX1030 (with WINDOWS XE) | no | no | no | yes

* at the moment only the FAIL-Signal control is supported (see chapter connections)

Note

The maximum power output for UPS-module CX1100-0920 is 1.1 A!

For the Embedded PCs of the CX1030 family this power output is not suitable.
If a UPS for this CPU is needed, at this moment only a standard power supply with UPS must be used.


Unpacking, installation and transport

The specified storage conditions must be adhered to (see "Technical data").

Dimensions and weight of the individual modules:

Module | CX1100-0900 | CX1100-0910 | CX1100-0920 | CX1100-0930
Dimensions (W x H x D) | 57 mm x 100 mm x 91 mm | 76 mm x 100 mm x 91 mm | 95 mm x 100 mm x 91 mm | 95 mm x 100 mm x 91 mm
Weight | 345 g | 465 g | 617 g | 650 g

Unpacking

Proceed as follows to unpack the unit:
1. Remove packaging.
2. Do not discard the original packaging. Keep it for future relocation.
3. Check the delivery for completeness by comparing it with your order.
4. Please keep the associated paperwork. It contains important information for handling the unit.
5. Check the contents for visible shipping damage.
6. If you notice any shipping damage or inconsistencies between the contents and your order, you should notify Beckhoff Service.

Warning |
 | Danger of damage to the unit!

During transport in cold conditions, or if the unit is subjected to extreme temperature swings, condensation on and inside the unit must be avoided.
Prior to operation, the unit must be allowed to slowly adjust to room temperature. Should condensation occur, a delay time of approximately 12 hours must be allowed before the unit is switched on.

Installation

The devices are designed for installation in control cabinets. You will find installation instructions in the chapter mechanical mounting.

Shipping and relocation

Despite the robust design of the unit, the components are sensitive to strong vibrations and impacts. During transport, your computer should therefore be protected from excessive mechanical stress. Therefore, please use the original packaging.


Dimensions

The CX10x0 product range is characterized by small overall installed size and high modularity. For project planning purposes, a CPU module, a power supply unit and the associated system interfaces and fieldbus interfaces have to be provided. The overall width of the application is made up of the individual modules. With a height of 100 mm, the module dimensions exactly match those of the Beckhoff Bus Terminals. Together with the lowered connector surfaces, this means that it can be used in a standard terminal box with a height of 120 mm.

the three available UPS-Modules for the CX10x0-family have different dimensions:

CX1100-0900 UPS Module:

CX1100-0910 UPS Module:

CX1100-0920 UPS Module:

CX1100-0930 UPS Module:


Fitting and wiring

BECKHOFF CX1100-09xx: Fitting and wiring

Mechanical installation of the UPS Module

The UPS module can be connected to the Embedded PC System at any positions. It is recommended to place it between CPU basic module and power supply unit. (see picture in system overview)

0. Switching off and disconnecting the power supply

Before a CX10x0 system can be dismantled, the system should be switched off, and the power supply should be disconnected.

1. Removing from the top-hat rail:

Before the individual CX10x0 modules are disconnected, the whole CX1020 hardware block should be removed from the top-hat rail. Proceed as follows:

1.1. Release and remove the first Terminal next to the power supply unit on the top-hat rail.

First remove any wiring from power supply unit and then from the first terminal on the top-hat rail next to the power supply unit. If the wiring is to be reused for another system, it is advisable to make a note of the connections. Then pull the orange terminal release (see arrow) to release the terminal and pull it out.

1.2. Releasing the CX10x0 system

In order to release the CX10x0 block, pull the white straps at the bottom of the module in the direction of the arrows. They will lock in the extended position. After pulling the terminal release of the power supply unit, the block can be removed carefully from the top-hat rail.

1.3 Separating the power supply unit, the CX10x0 CPU and other components

Place the CX10x0 block onto a suitable support with the front facing down. Then insert a flat screwdriver with dimensions 1.0 x 5.5 x 150 mm into the locking mechanism, and then operating the slider by turning it about 90 degrees. The locking mechanism on the rear affects an approx. 2-3 mm wide clearance of the module latching mechanism, pushing them apart. The plug connectors of the PC 104 interface can then be pulled apart carefully.

2 Assembly of the CPU basic module, the UPS and the power supply unit

2.1 Assembly the the CX10x0 system block

The individual modules are simply plugged together. The PC104 connector plugs should be handled carefully in order to avoid damage. When correctly assembled, no significant gap can be seen between the attached housings.

2.2 Engaging on the top-hat rail

Before engaging the system back on the top-hat rail the user should ensure all white tension straps are pulled down. The user should take care of the space between the terminals and the Embedded PC system. The space for the removed terminal must be kept to reinstall the terminal.

Then fix the CX1020 block on the top hat-rail using the latching straps. You should hear a soft click.

Do not force the module or apply excessive pressure!

Only apply pressure at insensitive points of the housing (edges). Never apply pressure on the display, the buttons or movable parts of the CX10x0 system.

After successful latching on the top-hat rail the straps should be pushed back to their original position.

2.3 Connecting the Embedded PC to the terminal bus

By reinstalling the once removed terminal the system is connected to the bus.

Finally the wiring must be reinstalled. The removed terminal is reconnected as before. The power supply is now connected via the UPS-connectors. (see chapter connections for details)


CX1100-09xx: Charging time

BECKHOFF CX1100-09xx: Charging time

Charging time

The charging time of the UPS module depends on actual the discharge and can not be measured exactly. It is possible to estimate the "maximal charging time". This time describes the charging behavior of completely discharged storage cells. The test units were discharged over night. Then the time to system start was measured. The following table shows the results of the measurements.

Charging time
Model | Charging time
CX1100-0900 | 42 s
CX1100-0910 | 46 s
CX1100-0920 | 116 s
CX1100-0930 | 65 s

Note |
 | The given times are average values. In operation the time for discharging must be added to the time. in mode "No Abort" e.g. the storage cells will be discharged before the charging starts.


CX1100_09xx discharging behavior

BECKHOFF CX1100-09xx: Discharging time

Discharging time

The measure the time for discharging of the different UPS modules a precision load was connected to the UPS. The retention time was measured depending of load and switch setting. The test scene is shown in the picture below.

A measurement starts app. 30 seconds after the module signals full charge (CHARGE glows green). The power supply to the UPS is disconnected by releasing the switch. At the same time a clock is triggered. The measurement stops when the LEDs at the front of the module extinguish. Several series of measurements have been processed. The following diagrams show the retention time in relation to switch setting. As load the maximal load for the CX1100-0900 is used.

Note

The maximal output current for UPS module CX1100-0900 is 550 mA!

For higher output current make use of the UPS modules (CX1100-0910 / CX1100-0920), with bigger output current.

The maximal output current is not suitable for the CX1020 Embedded PCs. So it is strongly recommended to make use of the UPS modules (CX1100-0910 / CX1100-0920), with bigger output current.

The other UPS module have a maximal load of 1100 mA. The results are shown below.

Retention time in relation to load at switch setting 0

For maximal discharging the torque switch is set to 0. The load is increased by steps of 50 mA. The curves show the measured retention times.

Measurements with sample configurations

As an example for a real load some Embedded PC configurations have been tested. The retention time was measured in relation to switch setting. The first test configuration is a CX1000 System (CX1000-0111) with typical configuration. Only the system interface N001 is connected to the basic system. The K-bus is supplied via the UPS, too. As terminals one digital input and one output terminal are connected to the bus. The system configuration shown in the picture.

The retention times are:

The second test configuration is an Embedded PC with maximal configuration. CX1000-System (CX1000-0122) with system interfaces N001 (2x USB, DIV), N002 (2x RS232), N003 (Audio), M200 (IP-Link-Master) und M319 (Profibus-Master). A keyboard with a hub and a mass storage device are connected to the USB ports as load. The system configuration is shown below.

The light bus is shorted by a fiber optic cable. The PROFI bus master connection is connected to a BK3100 with terminals. The retention times are measured in relation to switch setting.

The third test configuration consists of a CX1020-System (CX1020-0120). The configuration is typical. Only the system interface N010 is connected to the basic module. The terminal bus is an E-bus. One digital output terminal is connected to the bus.

The results are as folows:

The next test configuration is a CX1020-system in maximal configuration. The test connections are the same as in the test 2.

The retentions times are:

The last tested configuration is a CX900-system (CX9000-0002). The configuration is typical. Video, USB and serial interfaces are connected to the basic system. The load connected to the USB ports are the same as before.

The retention times are:


CX1100-09xx: Retention time for UPS modules

BECKHOFF CX1100-09xx: Retention times

Setting retention time

The retention time is set via the torque switch.

Switch / position | retention time
0 | 100 %
9 | 90 %
8 | 80 %
7 | 70 %
6 | 60 %
5 | 50 %
4 | 40 %
3 | 30 %
2 | 20 %
1 | 10 %

The position 0 (=100%) means that the full capacity of UPS can be used. Depending of the connected load the power supply can be secured for some minutes. The time can be reduced if the connected system shuts down fast. If the system shuts down fast the restart can be accelerated.

note
The retention time should last longer than system shutdown time.

For secure operation a time reserve is advised (XPe shutdown time plus 20-30 %)

The retention time can also be set in TwinCAT system manager:

The description can be found in "Settings for UPS module in System Manager".


CX1100-09xx: Registers

BECKHOFF CX1100-09xx: Register

Register settings CX1100-09xx

 |  | Bit7 | Bit6 | Bit5 | Bit4 | Bit3 | Bit2 | Bit1 | Bit0
0x0D1010 | IN-Register | State_3 | State_2 | State_1 | State_0 | reserved | reserved | 24V_IN_OK | 24V_OUT_OK
+1 | charge state | C7 | C6 | C5 | C4 | C3 | C2 | C1 | C0
+2 | OUT-Register | IRQ3 | IRQ2 | IRQ1 | IRQ0 | AUTO_RES | DIP_DIS | reserved | Output OFF
+3 | DIP-DATA | D7 | D6 | D5 | D4 | D3 | D2 | D1 | D0
+4 | identifier 0 | "C" (ASCII)
+5 | identifier 1 | "X" (ASCII)
+6 | identifier 2 | "11" (DEC)
+7 | identifier 3 | "90" (DEC)

base address 0D1010

C = charge state 0% = 00h, 100% = FFh

IRQ = binary coded IRQ number; 0000 = disabled

DIP_DIS = 1 : disable DIP switch with DIP-DATA

AUTO_RES = 1 : auto reboot (shutdown after short power failure)

Warning

The AUTO_RES bit must be reset before system shutdown to "0" !

Meaning of STATE-Nibble:

Value | State
0 | no function
1 | charging
2 | full charged
3 | discharged
4 | discharging and restart
5 | output off
6 | overload
7 | not used
8 | not used
9 | not used


CX1100-09xx: Operating the UPS-Module - Systemmanager

BECKHOFF CX1100-09xx: Commissioning the UPS module - System Manager

Settings in the System Manager

The CX1100-0900 UPS module is inserted as a "Box" under the CX1100 module. You will find a detailed explanation of how to add hardware in the documentation for the TwinCAT System Manager.

The UPS is added automatically when TwinCAT scans automatically for boxes in its configuration mode.

"General" tab:

Displays general device information on the selected device. The inputs and outputs of the UPS module can be displayed on the left browser window. This can be used to manipulate the UPS from the PLC.

A detailed description of the setting options will be found in the documentation for the TwinCAT System Manager.

There are fundamentally two different methods of controlling the UPS module. The first way is to make the operating settings directly in the TwinCAT System Manager. In this case it is not necessary for any other control to be exercised from the PLC program. The status signals from the UPS can, however, be evaluated in the program. As an alternative, the control can be exercised from the PLC program. This is described exhaustively in the section entitled "Controlling the UPS from the PLC". Operation through the TwinCAT System Manager, however, is described below.

Operating the UPS with the TwinCAT System Manager

Two configurations for operating the UPS are available in the System Manager:

Configuration 1:

"Enable Automatic Shutdown" is active, but "No Abort" however is not:

"CX1190 UPS" tab:

Enable Automatic Shut Down:

If this switch is selected, then TwinCAT is stopped after an adjustable retention time, and "Windows XPe" is shut down. Device 1 (here the CX1100) is switched off after the retention time has elapsed. Even when the power fails for very short periods (<<10s) the system shuts down and the CX is switched off.

Problem: If the voltage returns after TwinCAT has stopped but while "Windows XPe" is still in the process of shutting down, the CX remains on, but "Windows XPe" remains stopped.

The UPS is fully charged again. The voltage must remain switched off for long enough for the UPS to switch off, and only after this will reboot take place.

Configuration 2:

"Enable Automatic Shutdown" and "No Abort" are active:

"CX1190 UPS" tab:

Enable Automatic Shut Down:

If this switch is selected, then TwinCAT is stopped after an adjustable retention time, and "Windows XPe" is shut down. Device 1 (here the CX1100) is switched off after the retention time has elapsed. Even when the power fails for very short periods (<<10s) the system shuts down and the CX10x0 is switched off.

No Abort:

If the power voltage returns after TwinCAT has stopped, but while "Windows XPe2" is still shutting down, the CX10x0 will still reboot.

The problem of staying stuck in OFF, as above (option 1) does not occur. As soon as the UPS is fully charged again, the CX switches on once more.

Problem: The CX10x0 boots in every case, even when power failures are extremely short

Using the System Manager to set the retention time

The retention time of the UPS is set through the rotary switch on the front panel of the UPS. Details on this can be consulted in the technical description of the switch. It is possible to ignore this setting, and to set the retention time of the UPS through the System Manager. This is done by selecting the "Override DIP Switch" dialog box. The "DIP Switch" check box is activated here. A value from 0 to 9 can be chosen. This value corresponds to the setting of the rotary switch. The position of the rotary switch no longer has any effect.

Activating the settings

Once all the desired settings have been made, the configuration must be activated through the System Manager. You will find further explanations in the documentation for the TwinCAT System Manager.


Control by the PLC program

BECKHOFF CX1100-09xx: Control by the PLC program

Controlling the UPS from the PLC

It is possible to control the UPS module from the PLC. There are two TwinCAT blocks that permit this control. This allows the PLC program to deal with a power failure. It is, however, first necessary to make some settings in the TwinCAT System Manager, so that the UPS can be properly included. The UPS module is integrated in the TwinCAT System Manager, as described under Commissioning. It is necessary, however, for a few important settings to be made so that the PLC can obtain control. The controller must be switched off in the System Manager. It is also necessary for the hardware inputs and outputs of the UPS to be linked to the corresponding variables in the PLC program. The inputs and outputs must be declared in the program as GLOBAL variables. (Further details are given below.) First the settings of the System Manager are described.

Necessary System Manager settings:

- Everything must be set to OFF! In other words, on the CX1190 UPS tab, neither "Enable Automatic Shutdown" nor "No Abort" may be activated.

- In addition, both inputs (24V State and Charge State) and both outputs (Control and DIP Control) of the System Manager must be linked in the PLC to the UPS block in the corresponding variables.

The illustration shows the UPS being incorporated in the System Manager. The inputs and outputs of the UPS will be found both in the process image and in the hardware image in the hierarchy browser.

The signals are associated by a double-click. This association is required in order for the function block in the PLC program to operate properly. The PLC process image will, however, not be available until after the program has been compiled. This means that it must be linked into a PLC program before being linked with the UPS control block.

Details of linking signals are given in the documentation for the TwinCAT System Manager.

Linking the UPS control block into a PLC program:

The UPS is controlled from the PLC, with the aid of the FB_CX1000SimpleUps function block which is in the TC CX1000System.lib. This must, however, be linked by the library administrator. If this has been done, the block is available as a function block. It is instanced as such in the declarations part of the program.

PROGRAM MAIN_UPS
VAR
    UPS : FB_CX1000SimpleUps;
END_VAR

It is then called from the program with its parameters. There are three parameters for this function block:

  • bDIPDisable : BOOL;
  • iDischargeLevel : USINT;
  • tDelay : TIME;

"tDelay" sets the maximum retention time for which the power may be absent before the UPS switches the PLC off. The permitted entries here are between 0 and 10 seconds. The boolean expression "bDIPDisable" allows the setting of the rotary switch on the UPS to be ignored. If the value is "TRUE" then the value set by "iDischargeLevel" is used as the valid retention time. The call then looks like this:

UPS(
    bDIPDisable := TRUE, 	(* TRUE for DIP switch override *)
    iDischargeLevel := 30,	(* Values from 0.1, ... 9 *)
    tDelay := t#5s		(* Retention time before shutdown t#0s .. t#10s *)
);

In order for the function block to operate, the signals that are to be linked in TwinCAT's System Manager must be created as variables. This is done automatically when the process image is read into the System Manager. The linking process stores the addresses in the "TwinCAT_Configuration" file, and they are introduced during the next call to the compiler. (A more precise description can be read in the description of TwinCAT.) Alternatively it is possible to assign the addresses by hand. After compilation, warnings about the missing configuration for the signals are displayed. The signals are inserted into the "Variablen_Konfiguration" file through the "Insert -> All instances" menu item. It is possible to enter the addresses for the signals here. (E.g. MAIN.UPS.Li24VState AT %IB0 : BYTE for memory address 0).

VAR
    MAIN.UPS.Ii24VState AT %IB0 	: BYTE;
    MAIN.UPS.IiChargeState AT %IB1	: BYTE;
    MAIN.UPS.QiControl AT %QB0		: BYTE;
    MAIN.UPS.QiDipControl AT %QB1 	: BYTE;
END_VAR

The block supplies a few status signals for evaluating the program environment. These can then be used for control, e.g. saving the process data in NOVRAM, or for setting defined states or positions for axes. In detail, the block supplies the following signals:

  • bPowerFailure : BOOL;
  • bShutdownActive : BOOL;
  • bUpsReady : BOOL;
  • b24VInOK : BOOL;
  • bHolding : BOOL;
  • tTimeUntilShutdown : TIME;
  • eUpsState : E_UPS_STATE

"bPowerFailure" returns "TRUE" when a failure in the power supply voltage is detected . The signal goes back to "FALSE" when the input voltage returns.

"bShutdownActive" indicates that a stop or shutdown is being executed.

"bUpsReady" indicates that the UPS is providing the output voltage.

"b24VInOK" reports that the UPS is being supplied with 24 V input voltage.

"bHolding" returns "TRUE" when a failure in the supply voltage has been detected, and the retention time has not yet elapsed.

"tTimeUntilShutdown" indicates the retention time remaining until shutdown.

"eUpsState" displays the status of the UPS [UNDEF | CHARGING | CHARGED | DISCHARGE | DISCHARGE_RESTART | OUTPUT_OFF | OVERLOAD

Note

The function block bridges short supply voltage drop-outs without generating a shutdown, while longer supply failures cause TwinCAT to be stopped and the operating system to be shut down.

  • The CX10x0 is switched off by the UPS when it has reached it is discharge limit, even if the current returns during the shutdown.
  • The CX10x0 is switched on again by the UPS once the UPS is fully charged.

If it is necessary for the UPS to behave in a different way, e.g. with a longer retention time, resetting the bus, or definitely restarting the PLC even when the power failure was short, then the FB_CX1000UPSHANDLING function block from TC CX1000System.lib can be used as an alternative. This library must, however, be integrated through the library administrator. If this has been done, the block is available as a function block. It is instanced as such in the declarations part of the program.

PROGRAM MAIN_UPS
VAR
    UPS : FB_CX1000UPSHANDLING;
END_VAR

It is then called from the program with its parameters. There are seven parameters for this function block:

  • bAutoReset : BOOL;
  • bDIPDisable : BOOL;
  • bShutdown24V : BOOL;
  • bShutdown5V : BOOL;
  • iDischargeLevel : USINT;
  • bTcStopOnly : BOOL;
  • tDelay : TIME;

"bAutoReset" does not switch the CX10x0 system off if the supply voltage returns in time (this is set under "tDelay"). If this behaviour is wanted, the input must be set to "TRUE". As in the case of the other module, "bDIPDisable" can be used to ignore the setting of the rotary switch (by setting the input to "TRUE"). In that case again, the value set under "iDischargeLevel" is used. "bShutdown24V" switches off the 24V voltage. Warning! "bShutdown5V" is not used at present. This input must always be set to "FALSE"! It is, however, only necessary to ignore it, as it is initialised with "FALSE". "iDischargeLevel" indicates the discharge capacity of the UPS. The range of values extends from 0 to 9, whereby, for instance, 3 corresponds to switch setting 3 and means that the UPS will switch off after losing 30% of its capacity. "TDelay" indicates the retention time before a stop or shutdown is initiated. The "bTcStopOnly" switch is required for writing the persistent data under the "Microsoft Windows CE" operating system. Shutdown causes the system to reboot. It is necessary, however, to stop TwinCAT in order to write the persistent data. This stop signal is set through the "bTCStopOnly" input ("bTcStopOnly" := "TRUE"). Under "Microsoft Windows XP embedded" shutting down causes the persistent data to be written. The switch is therefore not necessary (bTcStopOnly = FALSE).

The call then looks like this:

UPS(
    bAutoReset	:= TRUE; (* TRUE if operation is to continue when the supply returns)
    bDIPDisable	:= TRUE;	(* TRUE for DIP switch override *)
    bShutdown24V	:= FALSE;(* Only TRUE if switching off is desired -> everything OFF !!! *)
    bShutdown5V	:= FALSE;(* DO NOT USE ---> reserved function *)
    iDischargeLevel	:= 3;	(* Values from 0.1, ... 9 *)
    bTcStopOnly	:= TRUE;	(* Under WINDOWS CE in order to save the persistent data, otherwise FALSE*)
    tDelay		:= t#5s; (* Retention time before shutting down *)
);

This function block also needs further variables for its operation. They are linked in TwinCAT's System Manager with signals from the UPS. These variables still have to be created. This is done automatically when the process image is read into the System Manager. The linking process stores the addresses in the "TwinCAT_Configuration" file, and they are introduced during the next call to the compiler. (A more precise description can be referred to in the description of TwinCAT.) Alternatively it is possible to assign the addresses by hand. After compilation, warnings about the missing configuration for the signals are displayed. The signals are inserted into the "Variablen_Konfiguration" file through the "Insert -> All instances" menu item. It is possible to enter the addresses for the signals here. (E.g. MAIN.UPS.Li24VState AT %IB0 : BYTE for memory address 0).

VAR
    MAIN.UPS.Ii24VState AT %IB0 	: BYTE;
    MAIN.US.IiChargeState AT %IB1	: USINT;
    MAIN.UPS.QiControl AT %QB0		: BYTE;
    MAIN.UPS.QiDipControl AT %QB1 	: USINT;
    MAIN.UPS.IbPowerFault AT %I 	: BOOL;

END_VAR

The block supplies a few status signals for evaluating the program environment. These can then be used for control, e.g. saving the process data in NOVRAM, or for setting defined states or positions for axes. In detail, the block supplies the following signals:

  • bPowerFailure : BOOL;
  • bShutdownActive : BOOL;
  • bUpsReady : BOOL;
  • b24VInOK : BOOL;

"bPowerFailure" returns "TRUE" when a failure in the power supply voltage is detected . The signal goes back to "FALSE" when the input voltage returns.

"bShutdownActive" indicates that a stop or shutdown is being executed.

"bUpsReady" indicates that the UPS is providing the output voltage.

"b24VInOK" reports that the UPS is being supplied with 24 V input voltage.

Note

The function block gives the PLC program full control over the behaviour of the UPS. Depending on the operating mode, the developer must see to it that the system is in the desired state when switched off, and/or that the system behaves correctly when it restarts. Problems that can occur include, for instance:

  • The system has halted, the UPS however provides voltage again -> the system remains inert, even though a power supply is present.
  • The system starts again, but the UPS is still in the discharge phase, and does not switch off until fully discharged -> the system starts up, but then is powered down without warning.


LEDs UPS-Modules CX1100-09xx

BECKHOFF CX1100-09xx: Error handling and diagnostics

LEDs CX1100-09xx

The UPS-Modules show their state of operating via status LEDs. The LEDs reside on the front of the module. The following table shows the possible states and their meaning.

Display | LED | Meaning
 | 24 V IN | power supply (in) The LED glows green if input power supply ( >21,5 V) is connected , otherwise it glows red.
 | 24 V OUT | power supply (out) The LED glows green if a consuming unit is connected to the power output ( >21,5 V), otherwise it glows red. In case of short circuit the LED start blinking red.
 | CHARGE (Charge status) | - charging: yellow - full charged: green - discharging: red


Decommissioning

BECKHOFF CX1100-09xx: Removal and disposal

Removal and disposal

A CX10x0 hardware configuration is dismantled in 2 stages:

0. Switching off and disconnecting the power supply

Before a CX10x0 system can be dismantled, the system should be switched off, and the power supply should be disconnected.

1. Removing from the top-hat rail:

Before the individual CX10x0 modules are disconnected, the whole CX10x0 hardware block should be removed from the top-hat rail. Proceed as follows:

1.1. Release and remove the first Terminal next to the power supply unit on the top-hat rail.

First remove any wiring from power supply unit and then from the first terminal on the top-hat rail next to the power supply unit. If the wiring is to be reused for another system, it is advisable to make a note of the connections. Then pull the orange terminal release (see arrow) to release the terminal and pull it out.

1.2. Releasing the CX10x0 system

In order to release the CX10x0 block, pull the white straps at the bottom of the module in the direction of the arrows. They will lock in the extended position. After pulling the terminal release of the power supply unit, the block can be removed carefully from the top-hat rail.

2. Separating the individual modules

2.1. Separating the power supply unit, the CX10x0 CPU and other components

Place the CX10x0 block onto a suitable support with the front facing down. Then insert a flat screwdriver with dimensions 1.0 x 5.5 x 150 mm into the locking mechanism, and then operating the slider by turning it about 90 degrees. The locking mechanism on the rear affects an approx. 2-3 mm wide clearance of the module latching mechanism, pushing them apart. The plug connectors of the PC 104 interface can then be pulled apart carefully.

Only modules (CPU, fieldbus connections and UPS modules) that can be separated non-destructively feature a release device. Modules that cannot be separated only feature a marking point (with or without red paint seal). Applying force to these elements will destroy them.

Warning |
 | Forcibly opening the module housing (e.g. removing the cover) will destroy the housing.

Disposal

The device must be fully dismantled in order to dispose of it.

Electronic parts must be disposed of in accordance with national electronics scrap regulations.


Certifications

All products of the Embedded PC family are CE, UL and GOST-R certified. Since the product family is continuously developed further, we are unable to provide a full listing here. The current list of certified products can be found on the Embedded PC certificates web page or at www.beckhoff.com under Embedded PC.


Support and Service

Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.

Beckhoff's branch offices and representatives

Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!

The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com

You will also find further documentation for Beckhoff components there.

Beckhoff Headquarters

Beckhoff Automation GmbH

Huelshorstweg 20
33415 Verl
Germany

Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support

Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:

  • support
  • design, programming and commissioning of complex automation systems
  • and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service

The Beckhoff Service Center supports you in all matters of after-sales service:

  • on-site service
  • repair service
  • spare parts service
  • hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com


CX1100-09xx: Start-up procedure

BECKHOFF CX1100-09xx: Start-up procedure

Switching the UPS on and off

Switching on

he power supply for the basic CPU module comes from the power supply unit. The basic CPU module starts automatically when the power supply unit is connected to the mains. The Embedded PC system will supplied with power if the storage cells are charged.

Switching off

If the power supply is shut down, the UPS assumes a power failure. The UPS continues to supply the system as long as the retention time is set. It switches off the system and discharges totally as no charging current is connected to the UPS.