Titel

CX1000: Embedded-PC-System

Hardware documentation

for CX1000 Embedded PC

CX1000-0xxx

CX1000-Nxxx

version: 1.2
date: 2010-03-01


Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending

The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.

Copyright

© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety Instructions

Safety Rules

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

State at Delivery

All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH.

Personnel Qualification

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.

Description of safety symbols

The following safety symbols are used in this operating manual. They are intended to alert the reader to the associated safety instructions.

Danger |
 | This symbol is intended to highlight risks for the life or health of personnel.

Warning |
 | This symbol is intended to highlight risks for equipment, materials or the environment.

Note |
 | This symbol indicates information that contributes to better understanding.


Documentation Issue Status

Version | Changes
1.2 | annotations to battery recycling added
1.1 | comments on hardware watchdog added
1.0 | updated version
0.1 | preliminarily version


Appropriate Use

The CX1000 device series is a modular control system that can be mounted on top hat rails. Its components are plugged together and installed in the control cabinet or junction box, depending on the required function.

Note:

The device configuration CX1000 is not recommended for new projects.

As new standard configuration the type CX1010 is available.


System Overview

The System

The CX1000 system covers the whole range of Beckhoff control technology both in terms of price and performance: The new product range is designed for tasks requiring the characteristics and computing capacity of Industrial PCs, but whose budget does not stretch to full-blown Industrial PCs.

The system only uses those components that are actually required. For example, a CX1000 can be operated in „headless“mode, i.e. without display or keyboard; in this case, the associated interface is not required. Whilst the resulting control system has no visualisation, it does have communications capability via the built-in Ethernet and RS 232 interfaces.

If local visualisation is required, this can be implemented via a DVI (digital video interface), to which all Beckhoff Control Panels and all commercially available monitors with DVI-input can be connected. The touch screen signal is read via one of the two available USB interfaces.

The components

The modules of the CX1000 series system are connected with each other via the standardised PC104 bus (16 bit). The individual system components are modules that can be arranged in series. The basic unit consists of a CPU module(CX1000-0000) and a power supply module(CX1100-000x). Further system interfaces for serial communication(2x RS 232, and RS422, RS485) as well as audio signals are available separately.

CPU base module

The CPU module is available in several variants. These relate to:

– Internal memory configuration: there are two options – either 16 MB Flash/32 MB RAM or 64 MB Flash / 128 MB RAM. The latter is required if the system is to be equipped with Windows XP Embedded.

– System interface configuration: as an option, a DVI and two USB Interfaces can be added to the combination of Ethernet and RS 232 that is always present.

– Operating system: There is a choice between Microsoft Windows CE.NET and Microsoft Windows XP Embedded.

– Pre-installed TwinCAT software: CX1000 can be preinstalled without a TwinCAT system, with TwinCAT CE PLC or with TwinCAT CE NC PTP, or with the associated full version of the individual TwinCAT levels for PLC and Motion Control.

System interfaces

Further system interfaces for serial communication(2x RS 232, and RS422, RS485) as well as audio signals are available separately.

Fieldbus interfaces

The range of optional modules for theCX1000 is complemented by fieldbus connectionsfor Profibus, CANopen, DeviceNet,SERCOS interface and Lightbus, both asmaster and slave versions.

The following fieldbus interfaces are available:

Beckhoff Lightbus (master and slave), Profibus DP (master and slave), CANopen (master and slave), DeviceNet (master and slave) und SERCOS Interface (only master).

The use of fieldbus master modules in a CX1000 system enables the utilisation of all Beckhoff fieldbus components (e. g. Bus Coupler, Bus Terminal Controller, drive technology) as distributed control components for the assembly of complex systems

The use of fieldbus slave modules enables the utilisation of a CX1000 system as subordinate distributed control for the configuration of complex or modular systems.

The Software

In combination with the TwinCAT automation software, the CX1000 Industrial PC becomes a powerful IEC 61131-3 PLC with up to four user tasks. Additionally, MotionControl tasks can also be executed. Depending on the required cycle time, several servo axes can be controlled. Even special functions such as flying saw, electronic gearbox and cam plate can be realised.

Remote programming via Ethernet

This option is used if the basic unit is equipped with Windows CE.NET. In this case, the system is programmed via a laptop or a desktop PC, which is connected to the CX1000 via Ethernet (network or crossover cable). The programs are developed on the laptop with a standard TwinCAT software licence and then loaded into the target device.

Visualisation

The Beckhoff OPC server is available for interfacing with SCADA software on both operating system variants Windows CE.NET or Windows XP Embedded. In other words, the CX1000 also offers unproblematic visualisation and simultaneous control in realtime on a single system. Beckhoff control devices


Technical Data

The CX1000 CPU module is the basic module of the CX system. It comprises the CPU and the internal flash memory in two implementation levels and offers the option to operate an additional memory medium in Compact Flash type II format. Ethernet and an RS 232 interface are also part of the basic configuration. All other CX family components can be connected via the PC104 interface that is available on both sides. The CPU module requires a CX1100 type power supply module.

Technical data | CX1000-0000
Processor | compatible with Pentium MMX, clock frequency 266 MHz
Flash memory | 64 MByte Compact Flash card
Internal main memory | 32 MByte RAM (expandable to 128 MByte)
Interfaces | 1 x RJ45 (Ethernet) and 1 x 9-pinD-Sub (RS 232)
Diagnostics LED | 1 x Power, 1 x Link, 1x 100 MBit , 1 x LAN Aktivität, 1 x Flash access
Expansion slot | 1 x Compact Flash type II insert with ejector
Clock | battery-powered internal clock for time and date
Operating system | Microsoft Windows CE.NET or Microsoft Windows XP Embedded
Control software | TwinCAT PLC Runtime or TwinCAT NC PTP Runtime
System bus | 16 Bit ISA (PC104 standard)
Power supply | via system bus (through CX1100 power supply module)
Dimensions | 57 mm x 100 mm x 91 mm
Weight approx. | 355 g ( with DVI/USB 435 g)

The passive cooling module CX1000-COOL is included in the scope of supply.

Note

The Watchdog function is only supported by Beckhoff in combination of TwinCAT with WINDOWS NT based systems. For other operating systems without TwinCAT it is not possible to give a general solution. The user must find a solution to the implementation of watchdog access on his own. As the only support Beckhoff can provide
  • the processor hardware description
  • the CX-architecture description (CX1100-000x power supply manual)

The documents can be found in the Download area of our webserver (www.beckhoff.com).


Types

The CPU module can be equipped with different hardware and software options: the internal memory is expandable to 32 MB Flash/128 MB RAM; the operating systems can be Windows CE.NET or Windows XP Embedded. The TwinCAT automation software transforms a CX1000 system into powerful PLC and Motion Control system that can be operated with or without visualisation. Further system interfaces (pre-installed in the factory) or fieldbus connections can be added to the basic CPU module.

Since not all combinations are sensible, the following table contains a breakdown of the permissible combinations.

The CX 1000 modules are available in the following types:

Modules | 16/32 MB | 64/128 MB | DVI / USB | Windows CE.NET | Windows XPE | without TwinCAT | TwinCAT PLC Runtime | TwinCAT NC PTP Runtime
CX1000-0010 | * |  |  | * |  | * |  |
CX1000-0011 | * |  |  | * |  |  | * |
CX1000-0012 | * |  |  | * |  |  |  | *
CX1000-0110 | * |  | * | * |  | * |  |
CX1000-0111 | * |  | * | * |  |  | * |
CX1000-0112 | * |  | * | * |  |  |  | *
CX1001-0000 | * |  |  |  |  |  |  |
CX1001-0010 |  | * |  | * |  | * |  |
CX1001-0011 |  | * |  | * |  |  | * |
CX1001-0012 |  | * |  | * |  |  |  | *
CX1001-0020 |  | * |  |  | * | * |  |
CX1001-0021 |  | * |  |  | * |  | * |
CX1001-0022 |  | * |  |  | * |  |  | *
CX1001-0110 |  | * | * | * |  | * |  |
CX1001-0111 |  | * | * | * |  |  | * |
CX1001-0112 |  | * | * | * |  |  |  | *
CX1001-0120 |  | * | * |  | * | * |  |
CX1001-0121 |  | * | * |  | * |  | * |
CX1001-0122 |  | * | * |  | * |  |  | *

CX1000 systems with Windows XP Embedded require a Compact Flash card with a minimum capacity of 1 GB.

Note:

A list of the different software images can be found in the CX1000 Software Documentation .


Connections

The basic CPU module is available with different hardware and software options. It is supplied from the power supply unit, so that only the connections are described here.

Basic CPU module with Ethernet RJ 45 and COM1 (RS232) interface:

RJ 45 interface (socket):

Assignment of the RJ45 interface:

PIN | Signal | Description
1 | TD + | Transmit +
2 | TD - | Transmit -
3 | RD + | Receive +
4 | connected | not used
5
6 | RD - | Receive -
7 | connected | not used
8

TD & RD are exchanged at the hubs or between two PCs.

COM1 interface (connector):

Assignment of the COM1 interface:

PIN | Signal | Type | Description
1 | DCD | Signal in | Data Carrier Detect
2 | RxD | Signal in | Receive Data
3 | TxD | Signal out | Transmit Data
4 | DTR | Signal out | Data Terminal Ready
5 | GND | Ground | Ground
6 | DSR | Signal in | Data Set Ready
7 | RTS | Signal out | Request to Send
8 | CTS | Signal in | Clear to Send
9 | RI | Signal in | Ring Indicator

Basic CPU module with DVI/USB interface:

In addition to the Ethernet and COM interface, this basic module features a DVI-I and two USB interfaces. The pin assignment of the basic CPU module with two USB and a DVI-I interface is explained under the associated system interface CX1000-N001.

Applicable to all basic CPU modules:

LED

The green power LED (PWR) is on if the basic CPU module is connected correctly to a live power supply unit.

Compact Flash slot

Further information can be found under Compact Flash slot.

PC 104 Bus

The PC 104 bus is a standardised bus with 104 ISA signals for compact embedded systems.


Compact Flash slot

A Compact Flash slot is provided at the front of the basic CPU module. This enables an additional Compact Flash memory medium (format I or II) to be operated. The change is only allowed while the system is powered down - otherwise the system could crash. The card can be removed for maintenance or to extend the system storage capacity. The Compact Flash cards (CF cards) are available as accessories with different storage capacities.

Activating the eject mechanism below the slot with a screwdriver causes the card to be ejected by approx. 4 mm (FIGURE 1), so that it can be pulled out (FIGURE 2). If the card is pushed in (FIGURE 3), the eject mechanism will re-engage. The card is positioned correctly, if it is located approx. 1 mm lower than the front of the housing.

FIG1: Ejecting the CF card FIG2: Removing the CF card

FIG3: Inserting the CF card

Warning

The Compact Flash slot is a memory interface, not an I/O type CF slot.


Compact Flash card

Embedded PC: Product overview

Compact-Flash card

The Compact Flash card (CF card) is a non-volatile memory medium.

Data to be retained in the event of a power failure should be saved on the CF card. The CF card operates similar to a hard disk.

Warning

It is recommended only use CF cards supplied by Beckhoff Automation GmbH.

The CF cards are made for industrial use. They possess a higher number of read / write cycles and an enhance temperature range (up to + 85°C).

A proper operation of the CX-System can only be guaranteed with the use of CF cards from Beckhoff Automation GmbH!


PC 104 Bus

The PC 104 bus is a standerdised bus with 104ISA signals for compact embedded systems.

For the functionality of the CX1000 modules eight further signals have been added ( here marked with color).

Pin assignment of 16 bit PC 104 bus:

Pin Number | J1/P1 Row A | J1/P1 Row B | J1/P1 Row C | J1/P1 Row D
0 | -- | -- | GND | GND
1 | IOCHCHK* | GND | SBHE* | MEMCS16*
2 | SD7 | RESETDRV | LA23 | IOCS16*
3 | SD6 | +5V | LA22 | IRQ10
4 | SD5 | IRQ9 | LA21 | IRQ11
5 | SD4 | -5V | LA20 | IRQ12
6 | SD3 | DRQ2 | LA19 | IRQ13
7 | SD2 | -12V | LA18 | IRQ14
8 | SD1 | ENDXFR* | LA17 | DACK0*
9 | SD0 | +12V | MEMR* | DRQ0
10 | IOCHRDY | (KEY)² | MEMW* | DACK5*
11 | AEN | SMEMW* | SD8 | DRQ5
12 | SA19 | SMEMR* | SD9 | DACK6*
13 | SA18 | IOW* | SD10 | DRQ6
14 | SA17 | IOR* | SD11 | DACK7*
15 | SA16 | DACK3* | SD12 | DRQ7
16 | SA15 | DRQ3 | SD13 | +5V
17 | SA14 | DACK1* | SD14 | MASTER*
18 | SA13 | DRQ1 | SD15 | GND
19 | SA12 | REFRESH* | (KEY)² | GND
20 | SA11 | SYSCLK | -- | --
21 | SA10 | IRQ7 | -- | --
22 | SA9 | IRQ6 | -- | --
23 | SA8 | IRQ5 | -- | --
24 | SA7 | IRQ4 | -- | --
25 | SA6 | IRQ3 | -- | --
26 | SA5 | DACK2* | -- | --
27 | SA4 | TC | -- | --
28 | SA3 | BALE | -- | --
29 | SA2 | +5V | -- | --
30 | SA1 | OSC | -- | --
31 | SA0 | GND | -- | --
32 | GND | GND | -- | --

Remarks:

2. B10 and C19 are key locations.

3. Signal timing and function are as specified in ISA specification.

4. Signal source/sink current differ from ISA values.

Pin assignment of the addtional signals

Pin number | Assignment
1 | I²C SCL
2 | USB D+
3 | I²C SDA
4 | USB D-
5 | ONCTRL
6 | Ustby 5 V
7 | POR
8 | PWRBTN

Note:

Further information about the PC 104 bus can be found under http://www.pc104.org


Technical Data

Unlike other CX components, the system interfaces cannot be upgraded or expanded in the field. They are supplied ex factory in the specified configuration and cannot be separated from the CPU module. The system interfaces run through the internal PC104, so that further CX components can be connected. The power supply of the system interface modules is ensured via the internal PC104 bus.
Technical data | CX1000-N001 | CX1000-N002 | CX1000-N003 | CX1000-N005*
Interfaces | 1 x DVI + 2 x USB 1.1 | 1 x COM2 + 1 x COM3 | Line IN, Line Mic IN, Line OUT | 1 x COM2 + 1 x COM3
Connection type | DVI-I 29-pin socket + 2 USB ports type A | 2 x 9-pin D-Sub | 3.5 mm socket for jack plug | 2 x 9-pin D-Sub
Properties | DVI-I interface also carries out VGA signals (DVI-A) | max. Baud rate 115 kBaud on both interfaces COM1: RXD, TXD, DTR COM2: RXD, TXD | built-in PC Beeper Line OUT output, max. 200 mW, suitable for earphones | max. Baud rate 115 kBaud on both interfaces 2 x RS485/422, optically isolated
Power supply | via system bus (through CX1100 power supply module)
Dimensions | 19 mm x 100 mm x 91 mm
Weight approx. | 80 g

* can only be used instead of and not at the same time as CX1000-N002


CX1000-N001 connections

In addition to the Ethernet and RS232 interface, this module features a DVI-I and two USB interfaces.

DVI-I interface

The DVI-I interface transfers analog and digital data and is suitable for connection to analog graphics cards with 15 pin D-Sub connector and digital graphics cards with DVI-D output. The resolution at the screen or the Beckhoff Control Panel depends on the distance (maximum 7 m).

The DVI interface uses VGA signals, so that the connection of CRT VGA monitors to the CX1000 system using a DVI to VGA adapter is also possible.
This adapter is available as an accessory.

DVI-I socket:

Pin | Assignment | Pin | Assignment | Pin | Assignment
1 | TMDS Data 2- | 9 | TMDS Data 1- | 17 | TMDS Data 0-
2 | TMDS Data 2+ | 10 | TMDS Data 1+ | 18 | TMDS Data 0+
3 | TMDS Data 2/4 Shield | 11 | TMDS Data 1/3 Shield | 19 | TMDS Data 0/5 Shield
4 | not connected | 12 | not connected | 20 | not connected
5 | not connected | 13 | not connected | 21 | not connected
6 | DDC Clock | 14 | + 5V Power | 22 | TMDS Clock Shield
7 | DDC Data | 15 | Ground ( +5V, Analog H/V Sync) | 23 | TMDS Clock +
8 | Analog Vertical Sync | 16 | Hot Plug Detect | 24 | TMDA Clock -

Pin assignment (cross)

Pin | Assignment
C1 | Analog Red Video Out
C2 | Analog Green Video Out
C3 | Analog Blue Video Out
C4 | Analog Horizontal Sync

Resolution at the monitor:

Resolution in pixels | Distance of the interface from the monitor
1024 x 768 | 5 m
800 x 600 | 6 m
640 x 480 | 7 m

USB interface:

The USB socket is a type A socket. The USB interface complies to USB 1.1 specification

Pin | Assignment | Typical assignment
1 | VBUS | Red
2 | D- | White
3 | D+ | Green
4 | GND | Black
Shell | Shield | Drain Wire


CX1000-N002 connections

The CX1000-N002 system interface features two RS232 interfaces, COM2 and COM3 (9 pin Sub-D plug connector).
The maximum baud rate on both channels is 115 kBit.

RS232 COM interface (connector):

Pin assignment of the COM2 interface:

PIN | Signal | Type | Description
2 | RxD | Signal in | Receive Data
3 | TxD | Signal out | Transmit Data
4 | DTR | Signal out | Data Terminal Ready
5 | GND | Ground | Ground

The pins not listed are not used.

Pin assignment of the COM3 interface:

PIN | Signal | Type | Description
2 | RxD | Signal in | Receive Data
3 | TxD | Signal out | Transmit Data
5 | GND | Ground | Ground

The pins not listed are not used.


CX1000-N003 connections

This system interface contains the audio interfaces Line In, Mic In (microphone signal input) and Line Out (also for earphones), max. 200 mW.
It also features a PC beeper.
The 3.5 mm sockets are designed for jack plugs.

Line In / Line Out stereo jack plugs:

Pin assignment Line In /Line Out:

Signal | Description
L | Left Signal
R | Right Signal
Gound | Ground

The left channel is transferred via the tip of the jack plug, the right channel via the first ring. The remainder of the sleeve is used for earthing.

Mic In mono jack plug:

The only existing channel is transferred via the tip, the remainder of the sleeve is used for earthing.


CX1000-N005 connections

The system interface CX1000-N005 contains two RS422, RS485 interfaces, COM2 and COM3 (9 pin Sub-D plug connector).
The maximum baud rate on both channels is 115 kBit.

COM interface (plug):

Pin assignment of the COM interface:

PIN | Signal | Type | Description
2 | TxD+ | Data-Out + | Transmit 422
3 | RxD+ | Data-In + | Receive 422
5 | GND | Ground | Ground
6 | VCC | VCC | +5V
7 | TxD- | Data-Out - | Transmit 422
8 | RxD- | Data-In - | Receive 422

For RS 485 Pin 2 and 3 ( Data +) as well as Pin7 and 8 (Data -) have to be connected.

The pins not listed are not used.

Settings DIP switches RS485:

RS485 without Echo, End-Point ( Terminated) DEFAULT SETTING

DIP | Status | Function
1 | off | Echo on
2 | on | Echo off
3 | on | Auto send on
4 | off | Always send on
5 | on | Auto receive on
6 | off | Always receive on
7 | on | Term on
8 | on | Term on

RS485 with Echo, End-Point ( Terminated)

DIP | Status | Function
1 | on | Echo on
2 | off | Echo off
3 | on | Auto send on
4 | off | Always send on
5 | off | Auto receive on
6 | on | Always receive on
7 | on | Term on
8 | on | Term on

RS485 without Echo, Drop-Point ( without Termination)

DIP | Status | Function
1 | off | Echo on
2 | on | Echo off
3 | on | Auto send on
4 | off | Always send on
5 | off | Auto receive on
6 | on | Always receive on
7 | off | Term on
8 | off | Term on

RS485 with Echo, Drop-Point ( without Termination)

DIP | Status | Function
1 | on | Echo on
2 | off | Echo off
3 | on | Auto send on
4 | off | Always send on
5 | off | Auto receive on
6 | on | Always receive on
7 | off | Term on
8 | off | Term on

Settings DIP Switches RS422:

RS422 full duplex end point

DIP | Status | Function
1 | on | Echo on
2 | off | Echo off
3 | off | Auto send on
4 | on | Always send on
5 | off | Auto receive on
6 | on | Always receive on
7 | on | Term on
8 | on | Term on

The dip switches for the configuration of the RS485/422 interfaces can be found at the left side of the module. If you remove the grey cover you can see the switch.


Technical Data CX1100-0001

One of three power supply modules can be selected for a CX1000 system. The power supply of all other system components is ensured via the internal PC104 bus; no separate supply lines are required. However, the CX1100 components offer further important characteristics that go beyond a pure power supply: an integrated NOVRAM enables the fail-safe storage of process data, an LCD display with two lines of 16 characters each is used for displaying system and user messages.

The power supply CX1100-N001 has no I/O interfaces.

Technical data | CX1100-0001
Power supply | 24 V DC (-15%/+20%)
Dieletric strength | 500 Veff (supply / internal electronics)
Max. power consumption | 30 W
Recommended fuse at 24 V | 2 A
K-Bus connection | -
IP-Link connection | -
Connection type | 1 x open pluggable connector, 5-pin
NOVRAM | 8 kByte
Display | FSTN display 2 lines x 16 characters of text, illuminated
I/O-DPRAM | -
Diagnostics LED | 1 x PWR
Dimensions | 45 mm x 100 mm x 91 mm
Weight approx. | 180 g


Technical Data CX1100-0002 / CX1100-0003

Local I/O signals are connected via the CX1100-0002 power supply variant, to which all Beckhoff Bus Terminals can be connected, or via CX1100-0003, which in addition to the Bus Terminals enables the connection of Extension Box IExxxx type Beckhoff Fieldbus Box modules. The option to connect Bus Terminals or a Fieldbus Box creates a control system with a very variable, expandable I/O level with large signal variety. The I/O data are stored in a DPRAM, which is accessible by the CPU via the system bus. The power supplies of the CX system can be changed in the field.

Technical Data | CX1100-0002 | CX1100-0003
Power supply | 24 V DC (-15%/+20%)
Dielectric strength | 500 Veff (supply / internal electronics)
Max. power consumption | 30 W
Recommended fuse at 24 V | 2 A
K-Bus connection | yes (adapter terminal)
IP-Link connection | - | yes
Connection type | Cage Clamp (adapter terminal)
NOVRAM | 8 kByte
Display | FSTN display 2 lines x 16 characters of text, illuminated
I/O-DPRAM | 2 kByte | 4 kByte
Diagnostics LED | 1 x PWR, 1 x I/O Run, 1 x I/O Err
Dimensions | 39 mm x 100 mm x 91 mm | 58 mm x 100 mm x 91 mm
Weight approx. | 250 g | 330 g


CX1100-0001 Connections

This power supply unit does not have an I/O interface. The power supply is therefore connected through the 5-pin open pluggable connector. The power supply unit supplies all further system components with a voltage of 24 V DC (-15 %/+20%) via the PC104 bus. The dielectric strength of the power supply unit is 500 Vrms.
The integrated NOVRAM permits storage of process data that is safe against power failure.

Pin Allocation Open Style Connector:

Pin | Assignment
1 | +24 V DC
2 | 0 V DC
3 | GROUND
4 | +UPS (+ 24 V DC)
5 | -UPS (0 V DC)

LED:

With proper connection of the power supply unit and with power supply turned on, the power LED (PWR) lights up green. In the case of a short-circuit, it lights up red.


CX1100-0002 Connections

This power supply unit is equipped with an I/O interface, which permits connection of the Beckhoff Bus Terminals. The power is supplied via the upper spring-loaded terminals labelled “24V” and “0V”.
The supply voltage feeds the CX system and supplies a voltage of 24 V DC (-15 %/+20%) to the Bus Terminals via the K-Bus. The dielectric strength of the power supply unit is 500 Vrms. Since the K-Bus does no more than pass data on, a further power supply is necessary for the Bus Terminals. This is provided by means of the power contacts, which are not connected to the power supply.
The integrated NOVRAM permits storage of process data that is safe against power failure.

LED:

With proper connection of the power supply unit and with power supply turned on, the power LED (PWR) lights up green. In the case of a short-circuit, it lights up red.

The I/O LEDs display the operation status of the Bus Terminals. Error-free start-up of the configuration is signalled by the red "I/O ERR" LED being extinguished. If the ”I/O ERR" LED blinks, an error in the area of the terminals is indicated. The error code can be determined from the frequency and number of blinks.

PE power contacts

The ”PE" power contact must not be used for other potentials.


CX1100-0003 Connections

This power supply unit permits not only the connection of the Beckhoff Bus Terminals, but also the serial connection of the Beckhoff fieldbus box modules of the type extension box IExxxx. The power is supplied via the upper spring-loaded terminals labelled “24V” and “0V”.
The supply voltage feeds the CX system and, over the K-Bus, the Bus Terminals. Since the K-Bus does no more than pass data on, a further power supply is necessary for the Bus Terminals. This is provided by means of the power contacts, which are not connected to the power supply.

Fieldbus connection:

Plug the IP link connector into the respective connections, i.e. one fibre-optic cable each into IN (x03) and OUT (x04). You then connect the other end with the corresponding IP link interface of the extension box. The connection must be made so that the output of the fieldbus connection is connected to the input of the extension box and vice versa.

LED:

With proper connection of the power supply unit and with power supply turned on, the power LED (PWR) lights up green. In the case of a short-circuit, it lights up red. The I/O LEDs display the operation status of the Bus Terminals. Error-free start-up of the configuration is signalled by the red "I/O ERR" LED being extinguished. If the ”I/O ERR" LED blinks, an error in the area of the terminals is indicated. The error code can be determined from the frequency and number of blinks.

PE power contacts

The ”PE" power contact must not be used for other potentials.


LCD Display

The LCD display of the power supply units has two rows of 16 characters each and is used for displaying system and user messages.

"Index-Group/Offset" Specification for the LCD Display

ADS Port 300

Index Group | Index Offset | Access | Data type | Phys. unit | Def. range | Description | Remarks
0x00005000 + DeviceID | 0xFFFF90FF | R&W |  |  |  | Cursor OFF |
0x00005000 + DeviceID | 0xFFFF91FF | R&W |  |  |  | Cursor ON |
0x00005000 + DeviceID | 0xFFFF92FF | R&W |  |  |  | Cursor blink OFF |
0x00005000 + DeviceID | 0xFFFF93FF | R&W |  |  |  | Cursor blink ON |
0x00005000 + DeviceID | 0xFFFF94FF | R&W |  |  |  | Display OFF |
0x00005000 + DeviceID | 0xFFFF95FF | R&W |  |  |  | Display ON |
0x00005000 + DeviceID | 0xFFFF96FF | R&W |  |  |  | Backlight OFF |
0x00005000 + DeviceID | 0xFFFF97FF | R&W |  |  |  | Backlight ON |
0x00005000 + DeviceID | 0xFFFFA0FF | R&W |  |  |  | Write Text line 1 |
0x00005000 + DeviceID | 0xFFFF00FF | R&W |  |  |  | Write Text line 2 |


Unpacking, installation and transport

The specified storage conditions must be adhered to (see "Technical data").

Dimensions and weight of the individual modules:

Dimensions (W x H x D): 19 x 100 x 91 mm (system interface) to 58 x 100 x 91 mm (power supply unit with I/O interface)

Weight: 80 g (system interface) to 435 g (basic module)

Unpacking

Proceed as follows to unpack the unit:
1. Remove packaging.
2. Do not discard the original packaging. Keep it for future relocation.
3. Check the delivery for completeness by comparing it with your order.
4. Please keep the associated paperwork. It contains important information for handling the unit.
5. Check the contents for visible shipping damage.
6. If you notice any shipping damage or inconsistencies between the contents and your order, you should notify Beckhoff Service.

Warning |
 | Danger of damage to the unit!

During transport in cold conditions, or if the unit is subjected to extreme temperature swings, condensation on and inside the unit must be avoided.
Prior to operation, the unit must be allowed to slowly adjust to room temperature. Should condensation occur, a delay time of approximately 12 hours must be allowed before the unit is switched on.

Installation

The devices are designed for installation in control cabinets.
You will find installation instructions on the following pages.

Shipping and relocation

Despite the robust design of the unit, the components are sensitive to strong vibrations and impacts. During transport, your computer should therefore be protected from excessive mechanical stress. Therefore, please use the original packaging.


Dimensions

The CX1000 product range is characterised by small overall installed size and high modularity. For project planning purposes, a CPU module, a power supply unit and the associated system interfaces and fieldbus interfaces have to be provided.
The overall width of the application is made up of the individual modules.
With a height of 100 mm, the module dimensions exactly match those of the Beckhoff Bus Terminals. Together with the lowered connector surfaces, this means that it can be used in a standard terminal box with a height of 120 mm.

Basic CX1000 CPU modules:

The basic CPU module measures 57 x 100 x 91mm.

CX1000-N00x system interfaces:

The four system interfaces all measure 19 x 100 x 91 mm.

CX1100-000x power supplies:

CX1100-0001

Power supply without I/O interface

Dimensions in mm: 45 x 100 x 91

CX1100-0002

Power supply with I/O interface

Dimensions in mm: 39 x 100 x 91

CX1100-0003

Power supply with I/O interface and IP-Link

Dimensions in mm: 58 x 100 x 91

CX1100-0004 ( only usable with CX1020 )

Power supply with E-Bus ( EtherCAT)

Dimensions in mm: 39 x 100 x 91

CX1100-09x0 UPS modules:

CX1100-0900

Dimensions in mm: 57 x 100 x 91

CX1100-0910

Dimensions in mm: 76 x 100 x 91

CX1100-0920

Dimensions in mm: 95 x 100 x 91

CX1500-Mxxx and CX1500-Bxxx fieldbus connections

The modules for the fieldbus connections measure 38 x 100 x 91 mm, irrespective of whether a master or slave type connection is used.


Mechanical Assembly

Embedded PC: Fitting and wiring

Mechanical Assembly of the base module

The installation of the modules takes place in three steps:

1. The Sequence of the Modules

The CPU basic module with system interfaces, which are factory-installed on the left side, is extended with the power supply unit on the right and with the fieldbus connection (master or slave) left side if available. The mounting of an filedbus module is described on the next page.

2. Assembly with Other Modules

The attachment of the individual modules is done by simple plugging them together (FIG. 1). Care must be taken that the plug of the PC104 interface is not damaged.
When correctly assembled, no significant gap can be seen between the attached housings.

FIG. 1: Engaging of the Modules

3. Engaging on the top-hat rail

On the bottom of the modules, there is a white tension strap, which is connected with a latching mechanism. These tension straps must be pulled down before attaching to the mounting rail. This can be done with a slotted screwdriver and a small rotation. (FIG. 4). After engaging the module on the top-hat rail successfully (FIG. 5), the tension straps must be shifted into the starting position again (FIG. 6).

FIG. 4: Tension straps down FIG. 5: Engaging on the top-hat rail

FIG. 6: Tension straps back in starting position FIG.7: Tension straps not engaged / engaged

Note:

A locking mechanism prevents the individual housings from being pulled off again. More detailed information about disassembling the CX configuration from the top-hat rail can be found on the page decommissioning.

By lowering the front surfaces, which contain the interfaces, installation can easily be done in a standard terminal box of 120 mm height.

Installation position:

Warning
The CPU module installed on a top-hat rail may be operated only in case of ambient temperatures up to 55°C. The orientation in which the device is fitted must be selected in such a way that cooling air can flow vertically through the ventilation holes. The images show the permitted ( FIG. 8 and FIG. 9) as well as a forbidden installation positions (FIG. 10).

Observe minimum clearance!

Mounting must provide a clearance of 30 mm both above and below a CX1000 device combination to ensure adequate ventilation of the CPU base module and the power supply unit.

FIG. 8: Allowable installation position FIG. 9: Allowable installation position

FIG. 10: Unallowable installation position


Mechanical Assembly of the Fieldbus modules

Embedded PC: Fitting and wiring

Mechanical mounting of the Fieldbus modules

The mounting of the Fieldbus modules takes place in several steps:

1. Remove cover at CX1000/CX1020 basic module

In order to be able to fasten the connection of the fieldbus connection to the CPU basic module, the cover must first be removed (FIG 1, 2). This can be achieved by a small pressure against the cover.

FIG.1+2: Remove Cover

2. Assembly with CX1000/CX1020 configuration

Because the CX1000 configuration is already on the top-hat rail, the fieldbus module first has to be pressed on the top-hat rail. For that purpose the locking of the latching mechanism with the white tension straps (pull down) is required.

The attachment of the individual modules is done by simple plugging them together (FIG. 3). Care must be taken that the plug of the PC104 interface is not damaged.
When correctly assembled, no significant gap can be seen between the attached housings. At the end the white tension strips must be shifted into the starting position again in order that the latching mechanism locks.

FIG. 3: Stick modules together FIG. 4: Tension straps back in starting position

3. Attach Cover

If the connection area does not have a closing cover on the left-hand side, the cover that was previously removed should be pressed over the connections until it audibly engages.

Note:

If the CX1000/CX1020 configuration is not positioned on the top-hat rail it is possible to join the connection first with the CX1000/CX1020 configuration, as shown in FIG. 3, and then to clip the entire module onto the top-hat rail.

Note:

A locking mechanism prevents the individual housings from being pulled off again.


LEDs of the basic CPU module

Display | LED | Meaning
 | PWR | Power supply The Power LED comes on when the device is connected to a live power supply unit.
 | Link | LAN Link 10 MBit This LED comes on when the network speed is 10 MBit or 100 MBit (if the device is part of a network).
 | 100MBit | LAN Link 100 MBit This LED comes on when the network speed is 100 MBit (if the device is part of a network).
 | Activity | Transmit /Receive Packets This LED flashes once when data packets are being transferred within the LAN.
 | HDD | Read/Write Compact Flash Indicates access to the CF card.

Network speed LED

  • The LINK LED comes on when the network speed is 10 MBit or 100 MBit.
  • The 100 MBit LED comes on when the network speed is 100 MBit.


CX1100-0001 power supply LEDs

Display | LED | Meaning
 | Power | Power supply The LED lights up green when the power supply is correct, but red if there is a short circuit.


CX1100-0002 power supply LEDs

After switching on, the power supply immediately checks the connected Bus Terminal configuration. Error-free start-up is signalled by the red "I/O ERR” LED being extinguished. If the ”I/O ERR" LED blinks, an error in the area of the terminals is indicated. The error code can be determined from the frequency and number of blinks. This permits rapid rectification of the error.

Display | LED | Meaning
 | Power | Power supply The LED lights up green when the power supply is correct, but red if there is a short circuit.
 | I/O Run | K-Bus diagnostics The green LED lights up in order to indicate fault-free operation. "Fault-free" means that the communication with the fieldbus system is also running.
 | I/O Error | K-Bus diagnostics The red LED flashes to indicate an error. The red LED blinks with two different frequencies.

The I/O error LED blink code

Fast blinking | Start of the error code
First slow sequence | Error code
Second slow sequence | Error code argument

LEDs for K-Bus diagnosis

Error code | Error code argument | Description | Remedy
Persistent, continuous blinking |  | EMC problems | - Check power supply for overvoltage or undervoltage peaks - Implement EMC measures - If a K-Bus error is present, it can be localised by a restart of the power supply (by switching it off and then on again)
1 pulse | 0 | EEPROM checksum error | Revert to the manufacturer’s setting
 | 1 | Code buffer overflow | Insert fewer Bus Terminals. The programmed configuration has too many entries in the table
 | 2 | Unknown data type | Software update required for the power supply
2 pulses | 0 | Programmed configuration has an incorrect table entry | Check programmed configuration for correctness
 | n (n > 0) | Table comparison (Bus Terminal n) | Incorrect table entry
3 pulses | 0 | K-Bus command error | - No Bus Terminal inserted - One of the Bus Terminals is defective; halve the number of Bus Terminals attached and check whether the error is still present with the remaining Bus Terminals. Repeat until the defective Bus Terminal is located.
4 pulses | 0 | K-Bus data error, break behind the power supply | Check whether the n+1 Bus Terminal is correctly connected; replace if necessary.
 | n | Break behind Bus Terminal n | Check whether the Bus End Terminal 9010 is connected.
5 pulses | n | K-Bus error in register communication with Bus Terminal n | Exchange the nth bus terminal
9 pulses | 0 | Checksum error in Flash program | Revert to the manufacturer’s setting
 | n (n>0) | Bus Terminal n is not consistent with the configuration that existed when the boot project was created | Revert to the manufacturer's setting which will clear the boot project.
14 pulses | n | nth Bus Terminal has the wrong format | Start the power supply again, and if the error occurs again then exchange the Bus Terminal.
15 pulses | n | Number of Bus Terminals is no longer correct | Start the power supply up again.
16 pulses | n | Length of the K-Bus data is no longer correct | Start the power supply up again.

Error code argument

The number of pulses indicates the position of the last Bus Terminal before the fault. Passive Bus Terminals, such as a power feed terminal, are not included in the count.

In the case of some errors, rectification does not cause the power supply to leave the blink sequence. The power supply can only be restarted by switching its supply voltage off and on again.

Note:

The supply voltage of the power supply unit, which is necessary to supply power to the CX1000 system, must not be interrupted in the middle of operation. Switching off the supply voltage to the power supply unit refers here to the power supply on the power contacts.


CX1100-0002 power supply LEDs

Embedded PC: Error handling and diagnosis

CX1100-0003 power supply LEDs

After switching on, the power supply immediately checks the connected Bus Terminal configuration. Error-free start-up is signalled by the red "I/O ERR” LED being extinguished. If the ”I/O ERR" LED blinks, an error in the area of the terminals is indicated. The error code can be determined from the frequency and number of blinks. This permits rapid rectification of the error.

Display | LED | Meaning
 | Power | Power supply The LED lights up green when the power supply is correct, but red if there is a short circuit.
 | I/O Run | K-Bus diagnostics The green LED lights up in order to indicate fault-free operation. "Fault-free" means that the communication with the fieldbus system is also running.
 | I/O Error | K-Bus diagnostics The red LED flashes to indicate an error. The red LED blinks with two different frequencies.

The I/O error LED blink code

Fast blinking | Start of the error code
First slow sequence | Error code
Second slow sequence | Error code argument

LEDs for K-Bus diagnosis

Error code | Error code argument | Description | Remedy
Persistent, continuous blinking |  | EMC problems | - Check power supply for overvoltage or undervoltage peaks - Implement EMC measures - If a K-Bus error is present, it can be localised by a restart of the power supply (by switching it off and then on again)
1 pulse | 0 | EEPROM checksum error | Revert to the manufacturer’s setting
 | 1 | Code buffer overflow | Insert fewer Bus Terminals. The programmed configuration has too many entries in the table
 | 2 | Unknown data type | Software update required for the power supply
2 pulses | 0 | Programmed configuration has an incorrect table entry | Check programmed configuration for correctness
 | n (n > 0) | Table comparison (Bus Terminal n) | Incorrect table entry
3 pulses | 0 | K-Bus command error | - No Bus Terminal inserted - One of the Bus Terminals is defective; halve the number of Bus Terminals attached and check whether the error is still present with the remaining Bus Terminals. Repeat until the defective Bus Terminal is located.
4 pulses | 0 | K-Bus data error, break behind the power supply | Check whether the n+1 Bus Terminal is correctly connected; replace if necessary.
 | n | Break behind Bus Terminal n | Check whether the Bus End Terminal 9010 is connected.
5 pulses | n | K-Bus error in register communication with Bus Terminal n | Exchange the nth bus terminal
9 pulses | 0 | Checksum error in Flash program | Revert to the manufacturer’s setting
 | n (n>0) | Bus Terminal n is not consistent with the configuration that existed when the boot project was created | Revert to the manufacturer's setting which will clear the boot project.
14 pulses | n | nth Bus Terminal has the wrong format | Start the power supply again, and if the error occurs again then exchange the Bus Terminal.
15 pulses | n | Number of Bus Terminals is no longer correct | Start the power supply up again.
16 pulses | n | Length of the K-Bus data is no longer correct | Start the power supply up again.

Error code argument

The number of pulses indicates the position of the last Bus Terminal before the fault. Passive Bus Terminals, such as a power feed terminal, are not included in the count.

In the case of some errors, rectification does not cause the power supply to leave the blink sequence. The power supply can only be restarted by switching its supply voltage off and on again.

Note:

The supply voltage of the power supply unit, which is necessary to supply power to the CX1000 system, must not be interrupted in the middle of operation. Switching off the supply voltage to the power supply unit refers here to the power supply on the power contacts.


Faults

Please also refer to the Safety instructions section.

Possible faults and their correction

If servicing is required, please quote the project number of your PC (on the type plate).

BECKHOFF support number:
for Germany: 05246/963-157
international: +49-5246/963-157

Fault | Cause | Measures
no function after the Embedded PC has been switched on | no power supply other causes | 1.Check fuse 2. Measure voltage at connection, check connector pin assignment. Call Beckhoff support
Embedded PC does not boot fully | Hard disk damaged (e.g. due to switching off while software is running), incorrect setup, other causes | Check setup. Call Beckhoff support
Computer boots, software starts, but control does not operate correctly | Cause of the fault is either in the software or in parts of the plant outside the Embedded PC. | Call the manufacturer of the machine or the software.
CF card access error | faulty CF card, faulty CF slot | Use a different CF card to check the CF slot Call Beckhoff support
Embedded PC only works partially or temporarily | Defective components in the Embedded PC | Call Beckhoff support


Removal and disposal

A CX1000 hardware configuration is dismantled in 2 stages:

1. Removing from the top-hat rail:

The white straps on the underneath of all the modules must be pulled downwards (FIG 1). This can be done using an ordinary screwdriver and a slight turn. The latching mechanism that provides fixing to the top-hat rail opens up (this procedure is not visible).

If the configuration has a power supply unit with an I/O interfaces, it is first necessary to release the first terminal from the top-hat rail (FIG 2) so that the CX1000 configuration can be separated from the I/O hardware, allowing the module to be removed from the top-hat rail (FIG 3).

FIG 1: Straps down FIG. 2: Releasing the I/O terminal from the top-hat rail

FIG. 3: Separating the module from the top-hat rail

2. Separating the individual modules:

Before separating the individual modules from one another, the entire CX1000 hardware block must first be removed from the top-hat rail, as described in Step 1. The individual modules can then be separated from one another by means of the separation mechanism mounted on the rear, as shown in Fig 4. This is done by inserting a flat screwdriver with dimensions 1.0 x 5.5 x 150 mm into the locking mechanism, and then operating the slider by turning it about 90 degrees. The rear-mounted locking mechanism creates a separation of approx. 2-3 mm in the mechanical engagement of the modules, pushing them apart, so that the PC 104 interface connectors can then carefully be pulled apart (FIG 5). Modules that cannot be separated from one another do not have a slider slot, but merely a marking point (which may or may not be sealed with red lacquer). Applying force to these elements will destroy them.

FIG. 4: Undoing the latching mechanism FIG 5: Separating the modules

The CPU can be separated from the power supply unit and the fieldbus connections in this way.

Note:

If the configuration has a power supply unit with an I/O interface, it is first necessary to release one terminal from the top-hat rail so that the configuration can be separated from the I/O hardware.

Note:

The embedded PC must be shut down and the power supply disconnected before dismantling!

Warning |
 | Forcibly opening the module housing (e.g. removing the cover) will destroy the housing.

Disposal

The device must be fully dismantled in order to dispose of it.

Battery-recycling:

This unit contains an accumulator. This must must be disposed of in accordance with national electronics scrap regulations.

Used batteries / accumulators may contain harmful substances or heavy metal that can harm the environment and health. Batteries will be recycled. They contain important commodities as iron, zinc, nickel or manganese.

The environment and Beckhoff thank for your understanding.

Electronic parts must be disposed of in accordance with national electronics scrap regulations.


Accessories

Compact flash cards

order number | Description
CX1900-0023 | 1 GByte compact flash card type I
CX1900-0025 | 2 GByte compact flash card type I
CX1900-0027 | 4 GByte compact flash card type I

Connectors and Adaptors

order number | Description
CX1900-0101 | DVI-to-VGA passive Adaptor for connecting a standard desktop VGA monitor to the CX1000 system – singles out the VGA signals of the DVI-I interface of the CX1000-N001 module – 29-pin male DVI-A connector (bottom) to 15-pin female connector (top) – weight approx. 40 g – dimensions (W x H x D) 40 x 42 x 15 mm

Labelling Tags

order number | Description
CX1900-0200 | Universal plastic labels for the CX1000 system (package contains 1000 labels) – snaps into the premoulded spots on the CX1000 components – labelling can be done with a X-Y plotter – dimension of the single label 15 x 5 mm – material: white coloured plastic – Murrplastik type KMR 5/15, order number 86401014


Support and Service

Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.

Beckhoff's branch offices and representatives

Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!

The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com

You will also find further documentation for Beckhoff components there.

Beckhoff Headquarters

Beckhoff Automation GmbH

Huelshorstweg 20
33415 Verl
Germany

Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support

Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:

  • support
  • design, programming and commissioning of complex automation systems
  • and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service

The Beckhoff Service Center supports you in all matters of after-sales service:

  • on-site service
  • repair service
  • spare parts service
  • hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com


Certifications

All products of the Embedded PC family are CE, UL and GOST-R certified. Since the product family is continuously developed further, we are unable to provide a full listing here. The current list of certified products can be found on the Embedded PC certificates web page or at www.beckhoff.com under Embedded PC.


Support and Service

Embedded-PC: Appendix

Support

BECKHOFF and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to BECKHOFF products and system solutions.

BECKHOFF Support

Support offers you comprehensive technical assistance, helping you no only with the application of individual BECKHOFF products, but also with other, wide-ranging services:

  • world-wide support
  • design, programming and commissioning of complex automation systems
  • and extensive training program for BECKHOFF system components

Hotline: +49(0)5246/963-157

Fax: +49(0)5246/963-9157

E-Mail: support@beckhoff.com

BECKHOFF Service

The BECKHOFF Service Center supports you in all matters of after-sales service:

  • on-site service
  • repair service
  • spare parts service
  • hotline service

Hotline: +49(0)5246/963-460

Fax: +49(0)5246/963-479

E-Mail: service@beckhoff.com

You will find further support and service addresses on our Internet pages under http://www.beckhoff.com. You will also find documentation for BECKHOFF components there.

If you have suggestions to make or ideas about our documentation, please send us an e-mail, stating the version number, at Dokumentation@Beckhoff.de.